Welcome to WPF Studio
What is Actipro WPF Studio?

WPF Studio is a bundled suite of professional user interface controls and components for Windows Presentation Foundation (WPF). The company behind WPF Studio, Actipro Software, has been making top-notch Windows Forms controls since .NET was first introduced, and was the very first control vendor to release a commercial WPF control.

Today Actipro Software is a leader in the WPF control market with their WPF Studio suite. Many products found in Actipro's Universal Windows and Silverlight Studio suites share codebases with their WPF Studio counterparts, thereby allowing for a high degree of code compatibility between WPF, UWP, and Silverlight.

Price Discounts

While the WPF Studio suite provides enormous price discounts of almost 60% over ordering all of our WPF products separately, you are free to purchase licenses for individual WPF control products if you don't require the entire suite.

Included Products

In addition to great savings, having licenses for WPF Studio also enables you to immediately be licensed for any new WPF control products that are released and added to WPF Studio while your year of free upgrades is active.

These products are currently included in the WPF Studio suite:

Product Name Description Sample UI
Actipro Bar Code

Actipro Bar Code is the first bar code generation product natively written for WPF.

All the most common bar code symbologies are supported. There are many configurable display options and each bar code is rendered using vector-based drawing so that it scales crisp and clean to any zoom level and on any sort of media.

Actipro Charts

Actipro Charts is a set of charts that are designed to provide rich visualization for complex, quantitative data.

Chart types include area, bar, line, pie, donut, and scatter, as well as stacked area and stacked bar. Visualization features include legends, axis ticks and labels, data point labels, grid lines and stripes, as well as customization, styling, and templating support.

Actipro WPF DataGrid Add-ons

The Microsoft WPF DataGrid can be used to display various data in a grid of rows and columns, with several options available to customize the behavior and appearance. Actipro is giving back to the community by providing two add-ons that make using the WPF DataGrid easier than ever.

The Actipro WPF DataGrid Contrib add-on offers reusable extension methods, attached behaviors, and commands. It also provides three Office themes, in addition to the default system themes. Finally, it integrates all the themes into the Shared Library's ThemeManager, which allows for dynamic theme changing.

The Actipro Editors/DataGrid Interop add-on allows controls from the Actipro Editors for WPF product to be quickly and easily integrated into the DataGrid. This allows the cells in a DataGrid to leverage parts-based and masked text editors, which make data entry faster and more intuitive.

Actipro Docking & MDI

Actipro Docking & MDI is a complete solution for easily adding a docking tool window and/or multiple document interface to your WPF applications.

Docking & MDI has been implemented with flexibility in mind. It has more options than nearly any other competitive product out there. While it supports all the types of standard layouts you find in most docking window products, it also supports some extended functionality such as: floating document windows, nested dock sites (a self-contained set of docking windows within another docking window), side-by-side dock sites (two or more self-contained sets of docking windows next to each other), tool window inner fill (no workspace area), tabbed and standard MDI styles, custom workspace content, total control over docking window capabilities and appearance, animated transitions, and much more.

Actipro Editors

Actipro Editors is a suite of controls that can be used to collect user input and can easily be integrated into the Actipro PropertyGrid.

User input can be validated and restricted using the MaskedTextBox and a regular expression mask, which supports alternations, quantifiers, as well as other regular expression constructs. The parts-based editor can be used to modify individual parts of a .Net object/type, such as modifying the year of a DateTime. Several type-specific parts-based editors are provided, including DateTime, or the existing framework can be leveraged for any custom types.

Actipro Gauge

Actipro Gauge provides circular, linear, digital gauge, LED and toggle switch controls, natively written for the WPF framework. Each control is fully customizable and is packed with features.

The circular and linear gauge controls include support for tick marks, labels, pointers, ranges, and much more. The digital gauge control can be used to display text using segmented or matrix characters. The LED control mimics an LED light and presents simple states. The toggle switch can be used in place of a WPF CheckBox, while providing the look and feel of a real-life switch.

Actipro Grids

Actipro Grids is a product that includes our PropertyGrid and custom tree structure (TreeListBox and TreeListView) controls.

PropertyGrid allows for all the properties of one or more objects to be displayed, optionally using categories. Pre-defined editors for modifying properties are auto-generated based on property type, and custom property/category editors can be easily created, allowing for total customization of the property editing experience.

PropertyGrid can also optionally harness our advanced data editing controls found in our Editors product (sold separately) when appropriate. Many editing features are driven using standard .NET attributes like BrowsableAttribute, CategoryAttribute, DisplayNameAttribute, etc. Support for sorting, filtering, collections, read-only display, nested properties, and deep customization are all included.

TreeListBox is a single-column tree control similar to the Visual Studio Solution Explorer tree control. TreeListView is a multi-column variant of TreeListBox that renders similar to a standard ListView but has additional features.

Actipro Micro Charts

Actipro Micro Charts is a set of charts that visualize quantitative data and are designed to render clearly in compact spaces.

Many chart types are supported, from basic line and bar charts to stacked area charts. The chart control includes numerous useful features such as multiple series, stacking, hot tracking, customizable palettes, and data aggregation. Common usage scenarios for micro charts are within dashboards, reports, and grids.

Actipro Navigation

Actipro Navigation is a control suite that includes NavigationBar, ExplorerBar, Breadcrumb, and ZoomContentControl controls, along with styles for animated Expander controls.

NavigationBar is a control that fully implements all features found in Outlook 2007, such as complete end user customization, layout save/load, minimization to both left and right sides, and much more.

Explorer bar is an implementation of the task bar that was introduced in Windows XP's explorer. Each expander pane uses smooth animation to fade in and slide down its contents when expanded.

Breadcrumb is an implementation of the breadcrumb that was introduced in Windows Vista's explorer. The control can be used to select a single item from hierarchical data, much like a TreeView but requiring less screen real estate.

ZoomContentControl allows any content to be interactively zoomed and scrolled using customizable mouse and keyboard behaviors.

Actipro Ribbon

Actipro Ribbon is a control suite that implements an Office-like user interface for WPF and meets 100% of the required AND optional Microsoft licensing requirements for implementation of a ribbon user interface.

Features include unrivaled ribbon resizing capabilities, application menu, QAT, many built-in control types, multiple layout options, key tips, screen tips, usage of the WPF command model, mini-toolbar, contextual tab groups, several themes, RTL support, and much more.

Actipro Shell

Actipro Shell controls allow for easy folder and file browsing. While the product comes packed with a pre-built implementation for the Windows shell that mimics Windows Explorer, the controls are fully customizable, allowing you to filter or change the folders/files presented. Or build your own shell service to support other files systems, such the remote side for a FTP client.

The ShellTreeListBox control presents a shell folder hierarchy in a tree structure. It is often paired with a ShellListView control, which shows the contents of a selected folder using column-based property display. Both controls are constructed of pure WPF UI and support tool tips, context menus, and renaming.

Actipro SyntaxEditor

SyntaxEditor is a powerful text editing control that is packed with features for efficient code editing, including syntax highlighting, line numbers, block selection, IntelliPrompt UI, code outlining, parsing, split views, zooming, bi-di support, and much more. It has many of the same code editing features found in the Visual Studio code editor.

SyntaxEditor is built on top of our next-generation extensible text/parsing framework. While over free 20 sample languages are available to get you started (such as C#, VB, XML, and more), custom language definitions can be developed and distributed with your applications as well. SyntaxEditor is designed for use in IDE (integrated development environment) applications, however there are many other applications out there than can take advantage of such a control.

These free add-ons are included with SyntaxEditor:

  • LL(*) Parser Framework - Easily build advanced parsers using EBNF-like notation
  • ANTLR parser integration
  • Irony parser integration

These optional premium add-ons for advanced syntax language implementations are shipped and demoed with the WPF controls, but are sold separately:

  • .NET Languages Add-on - Advanced C# and Visual Basic
  • Python Language Add-on - Advanced Python
  • Web Languages Add-on - Advanced XML, JavaScript, and JSON
Actipro Themes

Actipro Themes ensures that a great consistent visual appearance is applied to all controls within your application, regardless of whether they are Actipro control products or native WPF controls.

It is built right into the Actipro Shared Library, which means it may be freely used by any developer who has a license for one of our WPF control products.

Actipro Views

Actipro Views is a suite of controls and panels that supports fluid animations of the child elements arrangement. Different animations can be applied to elements entering or leaving the panel, as well as elements simply moving to a new location or changing size. Several built-in animations are provided that allow elements to be smoothly moved, sized, faded, scaled, rotated, or translated.

Actipro Views also includes a TaskBoard control that makes it easy to add interactive task scheduling and prioritization to your apps, a Book control with page turning presentations, and an InertiaScrollViewer that adds inertia animations to a ScrollViewer.

Actipro Wizard

Actipro Wizard is the premiere control for building wizard dialogs in WPF that conform to the Aero Wizard and Wizard97 specifications.

Features include multiple page types, easy page sequencing, selection change processing, full control over button states, page titles that update the containing Window, theming, templating, animated page transitions, automatic layout, and much more.

Actipro Shared Library

The Actipro WPF Shared Library is a common control library referenced by all of our WPF .NET controls. It contains a number of very useful controls and components that can be used in your projects.

The Shared Library components are free for use by any licensed customers of WPF Studio or one of its individual products.

Commitment to WPF

Actipro firmly believes that WPF is the best platform for Microsoft-oriented Windows desktop development, and is committed to enhancing and expanding its WPF product offerings going forward. As mentioned above, a license of Actipro WPF Studio enables you to use all of Actipro's current WPF products, along with any new products or features that are implemented in the future during your license subscription period.

What is the Sample Browser?

The Sample Browser is the main sample project that ships with WPF Studio.

It is an application with full source code that is designed to provide information, demos, and QuickStarts for all of the products that are part of WPF Studio. This source code is invaluable for learning how to use the various WPF Studio products.

The Sample Browser project can be opened with Visual Studio or Expression Blend.

XBAP Compatibility

All of the controls in the WPF Studio suite are 100% written in C# and are able to be used in XBAPs (WPF browser applications). This means that you can use the next-generation Actipro WPF Studio user interface components within the sandboxed, browser-based application model for WPF.

Since XBAPs are browser-based, there is a strict security model in place regarding their usage. While much of the WPF framework functions well within the bounds of the security model, there are a number of areas that don't. Throughout the design of our controls, we have identified and worked around any security restrictions that we've encountered, thereby finding ways to provide you the rich functionality you find in our products when used within Windows applications.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Why Choose Actipro Products?
Experience

Actipro Software has been developing Windows Forms components since .NET was first released, and has been working on commercial WPF control development since WPF was first introduced in 2006. Actipro began development of Silverlight controls in 2009.

Interesting Fact Interesting Fact
Actipro Wizard was the very first commercial UI control for WPF from any component vendor, released back in December 2006.

We've become very familiar with the in's and out's of WPF and have architected our products to implement WPF best practices. Our object models are very refined and easy to work with.

Documentation, Samples, and Designer Support

We realize that creating a good product is only half the battle in product development. The other half is providing thorough product documentation, samples, and having rich design-time functionality to aid in development efficiency.

We've spent a lot of time creating extensive documentation along with numerous product demos and QuickStarts so that you can get up and running with our products in minutes.

All our products also have designer interaction support when used in Visual Studio or Expression Blend.

Attention to Detail

Unlike most software vendors who slap together products just to get them out the door making money, we prefer to distinguish ourselves by taking a different approach to software development.

At Actipro, we pay attention to the minute details. We add that extra polish to our products that really makes the difference to developers and end users alike.

Quality, Not Quantity

Sure, other competitor companies may offer a couple more controls than we do, but rest assured that our products are well thought out and have enormous feature sets that you won't find anywhere else.

Interesting Fact Interesting Fact
We run our control product source code through Visual Studio's Code Analyzer and resolve all warnings it generates. This ensures that our code is well-designed and meets all appropriate .NET standards.

Customer Satisfaction

Every day we strive to please our customers. Are you used to waiting a week for a response from other vendors? Not at Actipro. We always try to reply to customers within one business day, and are frequently told we provide top-notch support to our customers.

Interesting Fact Interesting Fact
Organizations across the globe from over 80 countries own Actipro products

Save Time and Money

Simply stated, we've put hundreds of hours into the design and development of our products so that you don't have to. Why spend weeks developing in-house custom user interface controls when ours are already mature and can be purchased for the cost of several hours of development time?

You Speak, We Listen

We love to hear your feedback and often drive our products' designs based on the needs of our customers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Recent Documentation Updates

WPF Studio's documentation has frequent updates so this topic is the best place to get caught up on recent major new documentation updates for each of the products.

If you are looking for a list of recently-added major new features to WPF Studio products, please see the Sample Browser's Recent Updates page instead.

This topic contains these sections:

  • Updates for v19.1.0682
  • Updates for v19.1.0680
  • Updates for v18.1.0675
  • Updates for v18.1.0674
  • Updates for v18.1.0673
  • Updates for v18.1.0671
  • Updates for v18.1.0670
  • Updates for v17.2.0665
  • Updates for v17.2.0663
  • Updates for v17.2.0662
  • Updates for v17.2.0660
  • Updates for v17.1.0651
  • Updates for v17.1.0650
  • Updates for v16.1.0636
  • Updates for v16.1.0634
  • Updates for v16.1.0633
  • Updates for v16.1.0632
  • Updates for v16.1.0631
  • Updates for v16.1.0630

Updates for v19.1.0682

  • Editors: Updated several numeric edit box and picker topics with information about the new RoundingDecimalPlace property.
  • SyntaxEditor: Updated the Content Providers topic with information on the new ability for HtmlContentProvider to be supplied a background color hint, which can result in the best Metro image set (light or dark) being used when Metro images are active.

Updates for v19.1.0680

  • SyntaxEditor: Added the Search Overlay Pane topic with information on the new built-in search overlay pane functionality.
  • SyntaxEditor: Added the Line Number Provider topic with information on setting the document origin line number and providing customized line number text for display in the line number margin.
  • SyntaxEditor: Updated the Highlighting Styles, Locations, Offsets, and Positions, Caret, View Lines, Scrolling, Selection, Splitting, Adornment Layers, Single-Line Mode, Zooming, Default Key Bindings, Image Source Providers, EditorSearchView Control, and Search Result Highlighting topics with information on improved/changed features.
  • SyntaxEditor: Added the Converting to 2019.1 topic with detailed information on handling breaking changes made for the new version.

Updates for v18.1.0675

  • Editors: Updated the topic with information on the new feature for comparing the old and new color values in the picker popup.

Updates for v18.1.0674

  • Charts: Updated the Pie Slice Labels and ToolTips topic with information on the new tooltip features.

Updates for v18.1.0673

  • Gauge: Updated the Characters topic with information on the new text alignment feature.
  • Views: Updated the TaskBoard topic with information on new features for selectively blocking certain drop targets.

Updates for v18.1.0671

  • Docking: Updated the Layout Serialization topic with information on a new property that can be set to keep open document windows that were open prior to a document layout deserialization, even if they aren't in the deserialized layout data.
  • Shell: Updated the Shell Objects topic with information on new features for accessing thumbnail images.
  • Shell: Updated the ShellListView Control topic with information on new layout mode features.

Updates for v18.1.0670

  • Shell: Added documentation for the new Shell product, which supports folder and file browsing with built-in support for the Windows shell.

Updates for v17.2.0665

  • Docking: Updated the Auto-Hidden Tool Windows topic with information on a new property that allows an auto-hide popup to remain open while a dialog Window is displayed.

Updates for v17.2.0663

  • Charts: Updated the Axes topic with information on an optional display optimizations feature that is intended to remove anti-aliasing of lines, but can introduce jaggedness for smooth curves.
  • Editors: Updated the MaskedTextBox topic with information on the new MatchedText property.
  • Grids: Updated the Property Editors topic with information on the new commit on Enter keypress features.
  • SyntaxEditor: Updated the Tags and Classification Types topic with information on the new read-only region tag features for blocking text changes that border on a region.

Updates for v17.2.0662

  • Editors: Updated the Edit Box Basics topic with information on the new features for adding inline UI elements.
  • Editors: Updated the ColorPicker topic with information on the new mode selection feature that toggles between RGB and HSB text input.
  • Grids: Updated the Columns (TreeListView) topic with information on the new sort direction property.

Updates for v17.2.0660

  • Docking: Updated the Floating Dock Hosts topic with information on the new DockingWindow.IsFloating property.
  • Editors: Added the AutoCompleteBox topic with information on the new control.
  • Editors: Updated the brush editing control topics with information on the new options for preventing reuse of brush instances on component changes.
  • Grids: Updated the Drag and Drop topic with information on the support added for selectively expanding items when a drag/hover occurs above them.
  • SyntaxEditor: Added the Intra-Line Adornments topic with information on the new intra-line adornments functionality for replicating features like Visual Studio's Code Lens and Peek Definition.
  • SyntaxEditor: Updated the SyntaxEditor .NET Add-on Assemblies topic with information on the new Roslyn extensions option for loading binary assemblies.
  • Shared: Added the AdvancedTextBlock topic with information on the new control.

Updates for v17.1.0651

  • Grids: Updated the Filtering topic with information on the new included with descendants and empty content display features.
  • Grids: Updated the Columns topic with information on the new column header tap event.
  • Grids: Updated the Inline Editing topic with information on customizing the text selection made when starting edit mode, and customizing the edited content that is committed.

Updates for v17.1.0650

  • All: Updated the Licensing topic with information on "licenses.licx" file changes starting in v2017.1.
  • Editors: Updated the Editors product documentation based on the enhancements and changes made to the product.
  • Grids: Added Grids product documentation for the new property grid control and tree controls.
  • Themes: Updated the Window Chrome topic with information on the new title text alignment property.

Updates for v16.1.0636

  • Ribbon: Updated the Backstage / ApplicationMenu topic with information on how to prevent the Backstage from closing.

Updates for v16.1.0634

  • Docking: Updated the Docking Window Capabilities topic with information on a new event for limiting the dock guides that are displayed when docking windows are dragged over a new drop target.
  • Grids (work-in-progress): Added the Filtering topic with information on the new data filtering features.

Updates for v16.1.0633

  • Docking: Updated the Floating Dock Hosts topic with information on a new property for preventing tool windows from being dragged to floating dock hosts that contain a workspace.
  • Grids (work-in-progress): Added the Grids topics, which cover the new TreeListBox and TreeListView controls that are in development and ready for alpha testing.
  • Ribbon: Updated the Monochrome Images topic with information on preventing certain portions of a vector image from being converted to monochrome.
  • SyntaxEditor: Updated the Text Changes and Operations topic with information on the new feature that allows a programmatically-created text change to be merged into the previous text change on the undo stack.
  • SyntaxEditor: Updated the JSON Text Formatter topic with information on the new JSON text formatter service that beautifies the text data.
  • Shared: Added the DynamicImage topic with information on the new drop-in replacement control for Image that renders the image content as grayscale when disabled.

Updates for v16.1.0632

  • Shared Library: Added the Progress Spinners topic with information on the new RingSpinner control.

Updates for v16.1.0631

  • Themes: Updated the Themes Getting Started topic with information on optimization of theme catalog registration and main window startup.

Updates for v16.1.0630

  • Docking: Made massive updates to the Docking/MDI documentation, covering all the new features. See the Converting to 2016.1 topic for details on how to port your code to the new version.
  • Ribbon: Add the Monochrome Images topic that discusses how some Metro themes will automatically convert Ribbon button images to white monochrome when appropriate.
  • SyntaxEditor: Updated the SyntaxEditor Image Source Providers topic with information on the new image sets that are included with SyntaxEditor and how to choose between them.
  • SyntaxEditor: Updated the SyntaxEditor Line Commenters topic with information on new features that allow for enhanced comment locating when uncommenting.
  • Themes: Updated the Themes Getting Started topic with information on the new Metro accented themes that render similar to the Office 2016 apps. See the Converting to 2016.1 topic for details on how to port your code to the new version.
  • Themes: Updated the WindowChrome topic with information on the new option to hide the title bar icon.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Bar Code is the first bar code generation product natively written for the Windows Presentation Foundation framework. Use bar codes in your organization to more efficiently input data or even save money on postage (via the use of Postnet).

Two BarCode control instances, each with a different symbology

This product is useful for adding bar codes to any WPF application or report. Bar codes can be saved in XPS document content, saved to image files, rendered directly to a WPF DrawingContext, or added as a child control in any FixedDocument, FlowDocument or other WPF control.

Actipro Bar Code takes all the work out of the bar code generation process, by allowing you to simply say what value to encode. It will automatically calculate any appropriate checksums and will generate the bar code for you. The output is completely customizable with many options, everything from setting the bar height to display of the encoded value below the bar lines.

The most common symbologies are all supported, including EAN-13, EAN-8, UPC-A, UPC-E, Code 39 (and full ASCII variant), Code 93 (and full ASCII variant), Code 128, Codabar, Interleaved 2 of 5, and Postnet. In addition, the 2D QR Code symbology is supported.

What About Bar Code Fonts?

Up until now, the only way to generate bar codes in WPF was to use bar code fonts (a.k.a. fontware). However bar code fonts have a lot of limitations. When you compare them to Actipro Bar Code, you'll find that Actipro Bar Code provides the best solution for bar code generation in WPF.

Please see our Why Not Bar Code Fonts? topic for more information.

Features

Symbology Implementations

  • 2D symbology implementations:
    1. QR Code
      • With automatic detection of best version, encoding, and mask based on value
  • Linear symbology implementations:
    1. Codabar
      • Optional display of start/stop characters
    2. Code 128
      • Auto-generation and insertion of a checksum
    3. Code 39
      • Optional display of start/stop characters
      • Optional auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    4. Code 39 Extended (full ASCII)
      • Optional display of start/stop characters
      • Optional auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    5. Code 93
      • Optional display of start/stop characters
      • Auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    6. Code 93 Extended (full ASCII)
      • Optional display of start/stop characters
      • Auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    7. EAN-8
      • Auto-generation and insertion of a checksum
    8. EAN-13
      • Auto-generation and insertion of a checksum
    9. Interleaved 2 of 5
      • Optional auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    10. Postnet
      • Auto-generation and insertion of a checksum
    11. UPC-A
      • Auto-generation and insertion of a checksum
    12. UPC-E

BarCode Control Features

  • Implemeted as a WPF Control that can be used in any WPF context.
  • Use in a FixedDocument, FlowDocument, or add to an XPS document.
  • Add borders around the bar code and adjust their corner radius.
  • Add a caption above the bar code.
  • Easily switch between symbologies.
  • Rotate to any angle and scale the bar code using WPF layout transforms.
  • Provides a lot of features that you can't get using bar code fonts (a.k.a. fontware).
    • See our Why Not Bar Code Fonts? document for more information.

Symbology Features

  • Easily render a bitmap of the bar code and save to any image format (.png, .gif, .jpg, etc.) supported by WPF.
  • Programmatically measure and render bar codes to a DrawingContext.
  • Set the fore and background colors of the bar code output.
  • Set the bar height of linear bar codes.
  • Set the cell size of 2D codes.
  • Set the minimum bar height/width ratio so that long bar codes are tall enough to be read properly.
  • Specify the thickness of the quiet zone surrounding the bar code.
  • Use multiple value display styles for linear bar codes including:
    • None - The value is not displayed.
    • Centered - The value is centered horizontally.
    • LeftAligned - The value is left-aligned.
    • RightAligned - The value is right-aligned.
    • CharactersAlignedWithBars - The characters in the value are centered under the bars that represent each character.
    • QuietZoneExtension - The first and last characters are drawn in the lead/tail quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as UPC-A.
    • QuietZoneExtensionLeft - The first character is drawn in the lead quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as EIN-13.
  • Specify how far (if at all) the displayed value "intrudes" into the bar lines (used in bar codes like UPC-A).
  • Inclusion of ValidationRule classes for every symbology, that can be used to validate input.
  • Validate bar code values programmatically.

Code and Requirements

  • Includes detailed documentation and a sample project that demos nearly every feature.
  • Written in 100% pure C# and is based on the Windows Presentation Foundation framework.
  • Requires the .NET 4.0 or later run-time framework.
  • Full XAML support and XBAP compatibility.
  • Extensive Visual Studio and Expression Blend designer capabilities.
  • Visual Studio and/or Expression Blend are recommended development tools for this product.

Additional Symbology Implemetations

Do you require implementation of another symbology not listed? Just write us, our bar code framework was designed from the ground up to be extensible so that nearly any symbology can be added without too much work.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Why Not Bar Code Fonts?
Top 10 Reasons To Use Actipro Bar Code Instead of a Bar Code Font

  1. Bar code fonts (a.k.a. fontware) usually require licensing - While you may be able to scour the web to find a royalty-free implementation of a bar code font for a simple bar code symbology such as Code 39, most font creators charge licensing fees even in excess of $100 for the use of a single bar code font. Beware because even some free bar code fonts don't permit distribution with an application. With Actipro Bar Code, you get a large number of bar code symbology implementations at a low price and royalty-free distribution.
  2. Bar code fonts require registration in the Windows Fonts folder - When you distribute a bar code font with your application, you must update your installer to register the font with the target system's Windows Fonts folder, which is not a straightforward process. Also if the end user removes the font manually from the Fonts folder, the bar codes in your application are suddenly broken. With Actipro Bar Code, there is no font registration necessary since we natively vector draw each bar code.
  3. Actipro Bar Code can render the character value under the bar code lines, bar code fonts can't - Bar code fonts are incapable of rendering the represented value below the bar code. Actipro Bar Code can do this and even provides a number of display style options for the displayed value, including the ability to have the value's characters intrude into the bars such as in UPC-A.
  4. Actipro Bar Code can alter the height of the bar code lines, bar code fonts can't - Bar code fonts only support a fixed height of lines, whereas Actipro Bar Code allows you via a property setting to exactly specify a desired line height.
  5. Actipro Bar Code auto-computes checksums, bar code fonts can't - A font can't do math. A major benefit of using Actipro Bar Code is that each symbology automatically computes any appropriate checksum values for you so there is no math that needs to be done manually by you.
  6. Actipro Bar Code supports bar width ratios, bar code fonts don't - In some symbologies such as Code 39, you are permitted to have dark lines be anywhere from two to three times as wide as narrow lines. Actipro Bar Code provides an option for controlling this. Bar code fonts are always fixed bar widths.
  7. Actipro Bar Code is written in WPF, for WPF developers - Actipro Bar Code is written in 100% C# and is designed for use with any WPF application. All Actipro Bar Code drawing is done in vectors, so it cleanly scales to any size and always looks crisp on your printouts. The bar code itself is displayed by a BarCode control, which is a Visual that can be used in a FixedDocument, FlowDocument, or added to an XPS document.
  8. Actipro Bar Code supports borders and a caption - Actipro Bar Code can support the rendering of a border around the bar code (with total control over the roundness of the corners), along with an optional caption that is rendered above the bar code. You can't do this with bar code fonts.
  9. Actipro Bar Code supports WPF scaling and rotation - Bar codes produced by Actipro Bar Code can be resized or rotated however you like via the use of WPF layout transforms. You could even use a WPF Viewbox to have the bar code auto scale to fit a certain area.
  10. Actipro Bar Code can render to a WPF DrawingContext - In one line of code, render any bar code onto a DrawingContext via a call to the BarCodeSymbology.Render method.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

We've engineered bar code to be extremely easy to use.

This topic contains these sections:

  • Add Assembly References
  • Add the BarCode Control
  • Assign a Symbology
  • Further Study

Add Assembly References

First, add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.BarCode.Wpf.dll assemblies. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Add the BarCode Control

Then find the parent element that will contain the bar code. This could be a Window, a UserControl, a FlowDocument, a FixedDocument, or any other type of WPF UIElement.

Next, add a BarCode control to the desired parent element. In this sample we will add the BarCode to a FlowDocument:

XAML
Copy
​<FlowDocument
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:barCode="http://schemas.actiprosoftware.com/winfx/xaml/barcode"
    FontFamily="Calibri" FontSize="14" TextAlignment="Left"
    >
    <barCode:BarCode>
    </barCode:BarCode>
</FlowDocument>

Assign a Symbology

Now we need to set the type of symbology that we wish to use. In this sample we will use Code 39 Extended, which is one of the most common types of bar codes and supports all lower ASCII characters.

XAML
Copy
​<FlowDocument
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:barCode="http://schemas.actiprosoftware.com/winfx/xaml/barcode"
    FontFamily="Calibri" FontSize="14" TextAlignment="Left"
    >
    <barCode:BarCode>
        <barCode:Code39ExtendedSymbology Value="123456" BarHeight="25" />
    </barCode:BarCode>
</FlowDocument>

Note that we have also set a couple options like the BarCodeSymbology.Value of the symbology (the value that is encoded) and the height of the bars (via LinearBarCodeSymbology.BarHeight).

That's all we need to do! You can optionally configure many other settings for the bar code and/or its symbology. See the other topics in this documentation to see which features are available.

Further Study

It's very easy to use Bar Code and there are probably a lot of great features that you aren't aware of.

Run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of Bar Code.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


BarCode Basics

The BarCode control itself has several options like borders and a caption that can be used to wrap its symbology presentation.

This topic contains these sections:

  • Border Around the Bar Code
  • Caption Above the Bar Code
  • Setting a Symbology
  • Setting the Value to Encode
  • Rotating or Scaling the Bar Code
  • Changing Symbology Options

Border Around the Bar Code

The BarCode inherits Control and therefore has several border-related properties such as BorderBrush and BorderThickness. Set those properties to add a border around the bar code.

We also have added a CornerRadius property that can be used to round off one or more of the corners. It accepts a standard CornerRadius.

Caption Above the Bar Code

Normally the bar code's value is displayed below the bar code. You can also display content above the bar code.

For instance, perhaps you wish to show some text indicating what the bar code is for.

The Caption property can be set to add a caption. The property accepts any object so you can use text or another UIElement and it will be centered above the bar code, but within the bar code's outer border, if any.

Setting a Symbology

Each bar code symbology is implemented in a separate .NET type. For instance, Code 39 is implemented by the Code39Symbology class.

Set the symbology that you would like to use for your bar code to the BarCode.Symbology property.

See the Symbologies topic for a list of the available symbologies.

Setting the Value to Encode

You set the value to encode directly on the BarCodeSymbology class instance that you assign to the BarCode. This is done via the Value property.

Rotating or Scaling the Bar Code

Since BarCode is a Control, you can apply RotateTransform and ScaleTransform objects to its LayoutTransform and RenderTransform properties.

Changing Symbology Options

Each symbology has its own options. Although many share some common options such as BarHeight or ValueDisplayStyle, others like Code39Symbology have extended options such as AreStartStopCharactersVisible and IsChecksumEnabled.

See the documentation for each symbology to learn what options are available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Bar Code includes a number of built-in common symbology implementations.

Name Description
QR Code

QR Code is a 2D symbology, originally used in automotive manufacturing, that is now used worldwide for a wide variety of purposes.

It is readable by most mobile devices with cameras and can be used to display text to a user, add a vCard contact to the user's device, open a URL, or compose a text message or e-mail.

EAN-13

EAN-13 is a linear symbology, based on the original 12-digit Universal Product Code (UPC) system developed in North America.

EAN-8

EAN-8 is a linear symbology, used on smaller retail packages where EAN-13 bar codes don't fit.

UPC-A

UPC-A is a linear symbology, widely used in the United States and Canada for tracking trade items in stores.

UPC-E

UPC-E is a linear symbology, used on smaller retail packages where UPC-A bar codes don't fit.

Postnet

Postnet is used by the United States Postal Service to assist in directing mail.

Code 39

Code 39 is a linear symbology, and is one of the first alphanumeric bar codes.

Code 39 Extended

Code 39 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 39.

Code 93

Code 93 is a linear symbology, designed in 1982 by Intermec to provide a higher density and data security enhancement to Code 39.

Code 93 Extended

Code 93 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 93.

Code 128

Code 128 is a high-density barcode symbology, used extensively worldwide in shipping and packaging industries.

Codabar

Codabar is a linear symbology, developed in 1972 by Pitney Bowes, Inc.

Interleaved 2 of 5

Interleaved 2 of 5 is a linear symbology, that provides higher density than the Industrial 2 of 5 symbology that it is based on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


QR Code

QR Code is a 2D symbology, originally used in automotive manufacturing, that is now used worldwide for a wide variety of purposes.

It is readable by most mobile devices with cameras and can be used to display text to a user, add a vCard contact to the user's device, open a URL, or compose a text message or e-mail.

A sample of this symbology

This symbology can encode up to 7,089 numeric characters, 4,296 alpha numeric characters, or 2,953 bytes. Encoding modes are automatically switched when it is most efficient to do so. This symbology implementation also auto-calculates the QR Code symbol version and inserts error correction codewords.

Note Note
When using larger version numbers (i.e. version 25 and up), it may be neccessary to lower the default cell size in order for QR code readers to properly read the value.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML
  • Trademark

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | QrCodeSymbology
Base Class | Grid2DBarCodeSymbology
Encodable Characters | Number characters, alphanumeric characters, and bytes.
Supports Error Correction | Yes. The implementation will auto-calculate and insert error correction data.
Fixed Length Requirements | No. The maximum length of the value varies depending on the type of data being encoded, the symbol version selected, and the error correction level selected.

Important Members

This symbology has these important members:

Member | Description
AllowLowercase Property | Gets or sets a value indicating whether lowercase characters are allowed. The QR code specification does not allow lowercase characters when using the alphanumeric encoding mode. Therefore, when allowing lowercase characters the binary encoding mode must be used.
Background Property | Gets or sets the Brush to use for rendering the background.
CellSize Property | Gets or sets the size in pixels of each cell.
DisplayName Property | Gets the display name of the symbology.
EncodingMode Property | Gets the mode in which the value will be encoded. The default value is null, which indicates the encoding mode will be auto-selected based on the specified value.
ErrorCorrectionLevel Property | Gets the level of error correction that will be added to the encoded data. The higher the error correction level is, the lower the quantity of data that can be encoded is.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MaskIndex Property | Gets or sets the QR mask applied to the code. The default value is null, which indicates the mask will be auto-selected based on the specified value.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
QuietZoneThickness Property | Gets the thickness of the margin on each side of the rendered symbol.
Version Property | Gets the symbol version that should be rendered. The default value is null, which indicates the version will be auto-selected based on the specified value.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:QrCodeSymbology Value="0123456789" />
</barCode:BarCode>

Trademark

QR Code is registered trademark of DENSO WAVE INCORPORATED. The trademark only applies to the word "QR Code", and not for any QR Code pattern (image).

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EAN-13

EAN-13 is a linear symbology, based on the original 12-digit Universal Product Code (UPC) system developed in North America.

EAN-13 bar codes are used worldwide for marking retail goods.

A sample of this symbology

The 13 character value is divided into four parts: system code, manufacturer code, product code, and check digit.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Ean13Symbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | Ean13ValidationRule
Encodable Characters | Number characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts a check digit.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | The value must be 12 characters with a 13th character, the check digit, automatically calculated and added by the symbology.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:Ean13Symbology Value="003600029145" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EAN-8

EAN-8 is a linear symbology, used on smaller retail packages where EAN-13 bar codes don't fit.

A sample of this symbology

The 8 character value is divided into three parts: system code, product code, and check digit.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Ean8Symbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | Ean8ValidationRule
Encodable Characters | Number characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts a check digit.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | The value must be 7 characters with a 8th character, the check digit, automatically calculated and added by the symbology.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:Ean8Symbology Value="5512345" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UPC-A

UPC-A is a linear symbology, widely used in the United States and Canada for tracking trade items in stores.

This symbology is also known as Universal Product Code version A.

A sample of this symbology

The 13 character value is divided into four parts: system code, manufacturer code, product code, and check digit.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | UpcASymbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | UpcAValidationRule
Encodable Characters | Number characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts a check digit.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | The value must be 11 characters with a 12th character, the check digit, automatically calculated and added by the symbology.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:UpcASymbology Value="03600029145" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UPC-E

UPC-E is a linear symbology, used on smaller retail packages where UPC-A bar codes don't fit.

This symbology is also known as Universal Product Code version E.

A sample of this symbology

The 8 character value is divided into three parts: system code, product code, and check digit.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | UpcESymbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | UpcEValidationRule
Encodable Characters | Number characters.
Supports Checksum | No. This symbology uses a check digit, but it is not currently calculated automatically.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | The value must be 8 characters, including the developer-calculated check digit.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:UpcESymbology Value="04252614" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Postnet

Postnet is used by the United States Postal Service to assist in directing mail.

A sample of this symbology

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | PostnetSymbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | PostnetValidationRule
Encodable Characters | Number characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts a check character.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | The symbology must be either 5, 9, or 11 numbers in length, where the required 5 characters are the 5-digit zip code, the optional next 4 characters are the zip+4 code, and the optional last two digits represent the last two numbers of the numeric address number.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:PostnetSymbology Value="80122-1905" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 39

Code 39 is a linear symbology, and is one of the first alphanumeric bar codes.

Each character encoded is made up of 5 bars and 4 spaces for a total of 9 elements. 3 out of the 9 element are always wide. Although it is not as dense of a symbology such as Code 128, it is one of the most widely supported symbologies by devices.

A sample of this symbology

An extended implementation of Code 39 is available in Code 39 Extended. That implementation allows for all lower 128 ASCII characters to be encoded based on the core Code 39 concepts.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code39Symbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | Code39ValidationRule
Encodable Characters | Number, uppercase letter, and -$% ./+ characters.
Supports Checksum | Yes. While this symbology is self-checking, the implementation can optionally auto-calculate and insert a check character. This is referred to as Code 39 mod 43.
Has Special Start/Stop Characters | Yes. Must start and stop with * characters, but these are automatically appended for you.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
IsChecksumEnabled Property | Gets or sets whether the optional checksum should be added.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:Code39Symbology Value="ABC-123" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 39 Extended

Code 39 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 39.

This symbology is also known as Code 39 Full ASCII.

A sample of this symbology

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code39ExtendedSymbology
Base Class | Code39Symbology
Related ValidationRule Class | Code39ExtendedValidationRule
Encodable Characters | All lower 128 ASCII characters.
Supports Checksum | Yes. While this symbology is self-checking, the implementation can optionally auto-calculate and insert a check character. This is referred to as Code 39 mod 43.
Has Special Start/Stop Characters | Yes. Must start and stop with * characters, but these are automatically appended for you.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
IsChecksumEnabled Property | Gets or sets whether the optional checksum should be added.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:Code39ExtendedSymbology Value="abc-123" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 93

Code 93 is a linear symbology, designed in 1982 by Intermec to provide a higher density and data security enhancement to Code 39.

Each Code 93 character is divided into nine modules and always has three bars and three spaces. This symbology is primarily used by the Canadian postal office.

A sample of this symbology

An extended implementation of Code 93 is available in Code 93 Extended. That implementation allows for all lower 128 ASCII characters to be encoded based on the core Code 93 concepts.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code93Symbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | Code93ValidationRule
Encodable Characters | Number, uppercase letter, and -$% ./+ characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts two check characters.
Has Special Start/Stop Characters | Yes. Must start and stop with * characters, but these are automatically appended for you.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:Code93Symbology Value="ABC-123" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 93 Extended

Code 93 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 93.

This symbology is also known as Code 93 Full ASCII.

A sample of this symbology

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code93ExtendedSymbology
Base Class | Code93Symbology
Related ValidationRule Class | Code93ExtendedValidationRule
Encodable Characters | All lower 128 ASCII characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts two check characters.
Has Special Start/Stop Characters | Yes. Must start and stop with * characters, but these are automatically appended for you.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:Code93ExtendedSymbology Value="abc-123" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 128

Code 128 is a high-density barcode symbology, used extensively worldwide in shipping and packaging industries.

It is especially efficient when encoding sequential numbers since they are merged into a single output character width.

A sample of this symbology

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code128Symbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | Code128ValidationRule
Encodable Characters | All lower 128 ASCII characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts a check character.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:Code128Symbology Value="ABC-123" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Codabar

Codabar is a linear symbology, developed in 1972 by Pitney Bowes, Inc.

It is most commonly used by libraries, blood banks, and on FedEx airbills.

A sample of this symbology

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | CodabarSymbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | CodabarValidationRule
Encodable Characters | Number and -$:/.+ characters, along with 4 start/stop characters.
Supports Checksum | No. This symbology is self-checking, so no checksum or check digit is required.
Has Special Start/Stop Characters | Yes. Each encoded value must start and stop with A, B, C, or D.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:CodabarSymbology Value="A12345678A" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Interleaved 2 of 5

Interleaved 2 of 5 is a linear symbology, that provides higher density than the Industrial 2 of 5 symbology that it is based on.

It is most commonly used by the distribution and warehouse industry.

A sample of this symbology

This symbology can encode numeric digits, and requires that an even number of digits (including the optional check digit) are encoded. This symbology implementation will automatically add a 0 at the start of the encoded value to ensure that an even number of digits are encoded.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Interleaved2of5Symbology
Base Class | LinearBarCodeSymbology
Related ValidationRule Class | Interleaved2of5ValidationRule
Encodable Characters | Number characters.
Supports Checksum | Yes. The implementation can optionally auto-calculate and insert a check digit.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | No. The symbology value may be any number of characters. A 0 is added at the start of the encoded value if the supplied value is an odd number of characters.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
IsChecksumEnabled Property | Gets or sets whether the optional checksum should be added.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ToBitmap Method | Creates a BitmapSource based on the contents of the symbology.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barCode:BarCode>
    <barCode:Interleaved2of5Symbology Value="0123456789" />
</barCode:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Bar Code supports some advanced features such as drawing directly to a WPF DrawingContext, exporting bar codes to images, and use within XPS documents.

Drawing to a DrawingContext

Bar codes can be rendered directly to a WPF DrawingContext.

See the Drawing to a DrawingContext topic for more information.

Export to Image

Bar codes can easily be exported to any image format supported by WPF, including PNG, BMP, GIF, JPEG, and TIFF image formats.

See the Export to Image topic for more information.

Validation Rules

Each symbology included with Actipro Bar code has a related ValidationRule implementation that may be used when data binding in XAML to ensure that a value supplied is supported by the symbology.

See the Validation Rules topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Drawing to a DrawingContext

A lot of times it is useful to be able to render a bar code directly onto a WPF DrawingContext. This can be done simply by calling the Render method of the desired symbology class.

Measuring the Bar Code

You can retrieve a Size measurement of the bar code for a symbology by calling its BarCodeSymbology.MeasureDesiredSize method.

This sample code measures the bar code symbology in the variable symbology.

C#
VB
Copy
​Size desiredSize = symbology.MeasureDesiredSize(new Size(double.PositiveInfinity, double.PositiveInfinity));
​Dim desiredSize As Size = symbology.MeasureDesiredSize(New Size(Double.PositiveInfinity, D.PositiveInfinity))

Rendering the Bar Code

You can render the bar code for a symbology by calling its BarCodeSymbology.Render method and passing it a DrawingContext, location and size.

The Size should be the same size that is retrieved from the MeasureDesiredSize method.

This sample code renders the bar code symbology to a DrawingContext.

C#
VB
Copy
​symbology.Render(e.DrawingContext, new Point(0, 0), desiredSize);
​symbology.Render(e.DrawingContext, New Point(0, 0), desiredSize)

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Export to Image

Bar codes can easily be exported to any image format supported by WPF, including PNG, BMP, GIF, JPEG, and TIFF image formats.

It's easy to generate a BitmapSource from a symbology, simply by calling its ToBitmap method. When you have an image representation of a bar code, you can save it to a file or paste the image in other applications for usage.

Sample Code

This sample code creates a BitmapSource from a Code 39 extended bar code.

C#
VB
Copy
​Code39ExtendedSymbology symbology = new Code39ExtendedSymbology();
symbology.Value = "ABC-123";
BitmapSource source = symbology.ToBitmap(96, 96);
​Dim symbology As Code39ExtendedSymbology = New Code39ExtendedSymbology()
symbology.Value = "ABC-123"
Dim source As BitmapSource = symbology.ToBitmap(96, 96)

This sample code takes the BitmapSource from the previous sample code and writes it to a PNG file whose path is assumed to be in outputPath.

C#
VB
Copy
​FileStream outStream = new FileStream(outputPath, FileMode.Create);
PngBitmapEncoder enc = new PngBitmapEncoder();
enc.Frames.Add(BitmapFrame.Create((BitmapSource)outputImage.Source));
enc.Save(outStream);
outStream.Dispose();
​Dim outStream As FileStream = New FileStream(outputPath, FileMode.Create)
Dim enc As PngBitmapEncoder = New PngBitmapEncoder()
enc.Frames.Add(BitmapFrame.Create(CType(outputImage.Source, BitmapSource)))
enc.Save(outStream)
outStream.Dispose()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Validation Rules

Each symbology included with Actipro Bar code has a related ValidationRule implementation that may be used when data binding in XAML to ensure that a value supplied is supported by the symbology.

All the validation rules are located in the ValidationRules namespace.

Using a ValidationRule

This sample XAML code shows how to use the validation rule for Code 39 Extended, Code39ExtendedValidationRule, to ensure that the value that is bound to a TextBox is valid for that symbology. When the value is not valid, the error message will be set to a ToolTip on the TextBox.

XAML
Copy
​<StackPanel>
    <barCode:BarCode HorizontalAlignment="Left" Caption="Product ID" BorderThickness="1" CornerRadius="3">
        <barCode:Code39ExtendedSymbology x:Name="symbology" Value="ABC-123" />
    </barCode:BarCode>
    <TextBox>
        <TextBox.Style>
            <Style TargetType="{x:Type TextBox}">
                <Style.Triggers>
                    <Trigger Property="Validation.HasError" Value="true">
                        <Setter Property="ToolTip" Value="{Binding RelativeSource={RelativeSource Self}, Path=(Validation.Errors)[0].ErrorContent}" />
                    </Trigger>
                </Style.Triggers>
            </Style>
        </TextBox.Style>
        <TextBox.Text>
            <Binding ElementName="symbology" Path="Value" Mode="TwoWay" UpdateSourceTrigger="PropertyChanged">
                <Binding.ValidationRules>
                    <barCode:Code39ExtendedValidationRule />
                </Binding.ValidationRules>
            </Binding>
        </TextBox.Text>
    </TextBox>
</StackPanel>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Bar Code has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to quickly create your bar codes and assign a symbology.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • BarCode Context Menu
  • Task Pane Introduction
  • BarCode Task Pane
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

BarCode Context Menu

A context menu for the BarCode control is provided. You can right click on the control in the designer to display the context menu.

A BarCode context menu in the Visual Studio designer

Use the context menu options to select the current symbology in the designer for editing in the property grid or in XAML, and also to change to a different symbology from the sub-menu of symbology options.

Task Pane Introduction

Whenever you select a BarCode control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

BarCode Task Pane

The BarCode task pane provides quick access for selecting the current symbology (allows editing of the symbology in the property grid or in the XAML source) or changing to a different symbology. Click on a symbology link in the task pane to switch to that symbology.

The task pane for the BarCode control in the Visual Studio designer

You also can type in the caption or the bar code value. The bar code updates dynamically as you type.

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to v4.0 topic contains information on converting to v4.0 from an older version.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from an older version.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to v4.0

During the development of v4.0, we made a commitment to ensure that all our WPF product assemblies are scanned using Visual Studio Code Analysis, and that all warnings are handled appropriately. Code Analysis helps make sure that code is kept up to the highest standards and we are proud to now support it. All of the breaking changes below were made to properly handle Code Analysis warnings.

This topic contains these sections:

  • Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll

Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll

Per Code Analysis guidelines, the WPF portion of the assembly names was renamed to Wpf. If you have any problems with existing references to the assemblies, just remove the old references in your project and new ones. Also be sure your licenses.licx file is up to date with the info listed in the Licensing topic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Theming Architectural and Style Changes

Theming Architectural and Style Changes

See unified conversion topic for details on breaking changes made to the theming architecture, which affects control styles and related dictionaries.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Charts are meant to help visualize quantitative data. They are the full-featured counterpart to Micro Charts, and include rich visual elements such as legends, axes, labels, and more. Use charts to convey rich data and trends in your custom apps, dashboards, and reports.

Sample sales illustrated using three line series on an XYChart

Sample sales illustrated using PieChart

Actipro Charts makes it easy to generate charts based on any custom data source. It will automatically calculate the best scales to fit the data into the control, or you can customize the scales as needed. It includes support for aggregation of large data sets to improve performance and readability, highlighting ranges or key data points, and much more.

Several types of charts are supported, which include Area, Bar, Line, Pie, Donut, and Scatter. Stacked and 100% stacked variations of area and bar charts are available as well.

Features

Chart Types

  • Area
    • Includes support for spline curves and stepped lines.
    • Optionally display a line along the series.
    • Optionally display markers to highlight data points.
    • Show markers for first, last, high, low, and negative data points.
  • Bar
    • Quickly customize the spacing between the bars and groups of bars to fit your needs.
    • Stack bars side-by-side, on top of each other, or by percentage (100%).
    • Customize the range that a bar represents.
    • Advanced customization of bars using styles.
  • Line
    • Includes support for spline curves and stepped lines.
    • Optionally display markers to highlight data points.
    • Show markers for for first, last, high, low, and negative data points.
  • Pie / Donut
    • Nest multiple series or support hierarchical data.
    • Several label display options.
    • 'Other' slice for aggregating small pie slices.
  • Scatter
    • Show markers for first, last, high, low, and negative data points.

Data Source Features

  • Supports displaying any numeric and date/time values from custom data sources.
  • Supports displaying and grouping complex data based on equality or custom logic.
  • Data can be automatically aggregated to reduce the number of data points rendered.
  • Automatically group data together under single bars in a bar chart, based on a numeric or date range.

Appearance Features

  • Combine any number of different series into a single chart.
  • Supports stacking multiple series, both normally and using 100% scale.
  • Customizable baseline value, which dictates which values are considered 'negative', and optional display of baseline.
  • Customizable minimum and maximum values of each axis for fixed scales.
  • Add horizontal or vertical ranges, which are used to highlight specific data ranges.
  • Easily customize the various brushes used to render charts via palettes and palette selectors.
  • Set the visibility of any series to dictate whether or not it is rendered on the chart.
  • Over 10 built-in palettes.
  • Show axis ticks, labels, and title; with customizable appearance.
  • Stack multiple axis and assign each axis to a specific series or share with multiple series.
  • Show customizable labels and markers on data points; labels move to avoid overlapping each other.
  • Display grid lines and stripes behind chart for easy viewing; with customizable appearance.
  • Customize bars in bar charts to fit the look and style you want.
  • Show and position a customizable legend.

Code and Requirements

  • Includes detailed documentation and a sample project that demos nearly every feature.
  • Written in 100% pure C# and is based on the Windows Presentation Foundation framework.
  • Requires the .NET 4.0 or later run-time framework.
  • Full XAML support and XBAP compatibility.
  • Extensive Visual Studio and Expression Blend designer capabilities.
  • Visual Studio and/or Expression Blend are recommended development tools for this product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Getting started with Charts is simple. Follow the steps below to build your first chart.

This topic contains these sections:

  • Add Assembly References
  • Add the XYChart Control
  • Add a Series
  • Further Study

Add Assembly References

First, add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.Charts.Wpf.dll assemblies. The assemblies should be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Add the XYChart Control

Then find the parent element that will contain the chart. This could be a UserControl or any other type of UIElement.

Next, add a XYChart control to the desired parent element. In this sample we will add the XYChart to a UserControl:

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:charts="http://schemas.actiprosoftware.com/winfx/xaml/charts">
    <charts:XYChart Width="300" Height="200"/>
</UserControl>

Add a Series

Now we need to add a series, which renders a single set of data points on the chart. In this sample we will add a AreaSeries series, but the other types are added in a similar manner.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:charts="http://schemas.actiprosoftware.com/winfx/xaml/charts">
    <charts:XYChart Width="300" Height="200">
        <charts:AreaSeries ItemsSource="{Binding}" />
    </charts:XYChart>
</UserControl>

Note that this sample assumes that the chart's DataContext is a list of numeric (i.e. Double, Decimal, etc) or DateTime objects. With this configuration, the chart's X values will represent the index value in the list and the chart's Y values will represent the list's actual value at the related list index.

If our list contained custom objects and we wanted to pull the X and Y values from properties on that object, then we would have to specify the property path on the series.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:charts="http://schemas.actiprosoftware.com/winfx/xaml/charts">
    <charts:XYChart Width="300" Height="200">
        <charts:AreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyNumericProperty" />
    </charts:XYChart>
</UserControl>

This sample assumes the objects in the list each contain a property named MyDateProperty and MyNumericProperty, which are then used for the associated axis.

Note Note
If a list contains custom data objects but the index of each entry should be used as the X-values, leave out the XPath attribute and just specify the YPath to the data object's property that contains the value to display.

Additional series can be added and they will all be rendered on the same chart using the same X and Y scales.

Further Study

To familiarize yourself with all of the features in Charts, take a look at the feature documentation and also look at the numerous QuickStarts located in the sample project.

If you require further assistance after looking through those, please visit our Charts support forum.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Chart Basics

This topic discusses some of the basic concepts for using Charts.

This topic contains these sections:

  • Primary vs. Secondary Axis
  • Adding a Series
  • Specifying Items

Primary vs. Secondary Axis

The XYChart control supports two axes, X and Y. The X axis runs horizontally along the control, and the Y axis runs vertically. All series default to rendering horizontally, which means that Y is the primary axis and X is the secondary axis.

Certain series types, such as Bar, support vertical orientations as well as the default horizontal orientation. With vertically oriented series, X is the primary axis and Y is the secondary axis.

See the Chart Types topic for additional information.

Horizontal Bar Chart

Vertical Bar Chart

Adding a Series

Each series is represented by an individual .NET type. For instance, a Line series is implemented by the LineSeries class.

Add any series you would like to display to the XYChart.Series collection. The chart will automatically scale the X and Y axes to fit the data of each series properly, however you can also specify axes and control how they are displayed. See Axes for more details.

See the Chart Types topic for a list of the available chart types.

Specifying Items

Each series is bound to it's own data source, which is indicated by the ItemsSource property. The XPath and YPath will determine the property path used for values on the X and Y axes.

When XPath and YPath are not specified, then the respective X and Y values will instead be the items in the ItemsSource collection.

When X or Y axes values resolve to a quantifiable or numeric data type, such as Double, Decimal, Int32 or DateTime, then the respective axis should match the data type. If axes are not specified, they wil be set automatically.

When X or Y axes values resolve to a complex object or reference type, such as String or a user-provided type, then the respective axis should be XYGroupedAxis. By default, these type of values will be grouped based on object equality. Grouping can be determined based on custom criteria by specifying XYGroupedAxis.GroupingFunc.

See the Specifying Items topic for additional information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Charts includes a number of built-in chart types.

Name | Description
Area | An area chart is a derivative of a line chart. The area between the line and axis is filled in. Markers and lines can optionally be displayed.
Bar | A bar chart displays rectangular bars with lengths proportional to the values they represent.
Line | A line chart render quantitative data as a series of points connected by line segments. Lines can be straight, curved, or stepped. Markers can optionally be displayed.
Pie / Donut | A pie chart can display data points as pie slices, or in the case of a donut chart, cocentric rings.
Scatter | Scatter charts render data points where each point is represented by a marker.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Area

An area chart is a derivative of a line chart where the area between the line and axis is filled in.

This topic contains these sections:

  • Baseline Value
  • Line Kind
  • Line
  • Markers

Baseline Value

The area series will pivot it's polygon based on the chart's baseline value, as specified by the Baseline property on XYDateTimeAxis, XYDoubleAxis, or XYDecimalAxis The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following examples, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum. Since our baseline is 0 (the default), the polygon is not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the polyon will appear to pivot around the baseline.

Line Kind

The area series supports three kinds of lines specified by the LineKind, which also determines how the area is rendered. By default, the Normal kind of line is used which simply draws a line to connect the data points when determining the area's polygon.

An area series using a normal line kind

The Spline line kind builds a canonical spline that runs through the data points, producing a smooth line.

An area series using a spline line kind

The Step line kind creates a polygon that only uses horizontal and vertical lines to connect the data points, producing a step look.

An area series using a step line kind

Line

The area series can render an actual line along the top of the area to distinguish it better. By default the line is not rendered, but it can be shown by setting LineVisibility to a value other than None. The area series has the same configuration properties available as the line series, with regards to line rendering.

An area series with LineVisibility set to All.

See the Line topic for more information on the options available.

Markers

The area series can render a markers at each data point to highlight the actual location. By default the markers is not rendered, but they can be shown by setting MarkerVisibility to a value other than None. The area series has the same configuration properties available as the scatter series, with regards to marker rendering.

An area series with MarkerVisibility set to All.

See the Scatter topic for more information on the options available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Bar

A bar chart displays rectangular bars with lengths proportional to the values they represent.

This topic contains these sections:

  • Baseline Value
  • Orientation
  • Bar Spacing

Baseline Value

The bar series will pivot it's bars based on the chart's baseline value, as specified by the Baseline property on XYDateTimeAxis, XYDoubleAxis, or XYDecimalAxis.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 25, 10, 20, 5, 20, 10 for the Y-axis. The first image shows the series using 5 as the minimum value along the Y-axis, and 25 for the maximum. Since our baseline is 0 (the default), the bars are not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the bars will appear to "grow" down instead of up.

Orientation

The bar chart can be oriented horizontally (the default) or vertically by setting the Orientation property. When switching orientation, the values of the XPath and YPath properties may need to be swapped.

Bar Spacing

The BarSpacing property can be used to configure the space between the bars. The default value is 1px, which indicates there should be a 1 pixel space between the bars.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line

A line chart renders quantitative data as a series of points connected by line segments, which can be straight, curved, or stepped.

This topic contains these sections:

  • Baseline Value
  • Line Kind
  • Markers

Baseline Value

The chart's baseline value, as specified by the Baseline property on XYDateTimeAxis, XYDoubleAxis, or XYDecimalAxis.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative". Visually nothing will change unless the baseline is shown, using XYChart.IsAxisBaselineVisible.

Line Kind

The line series supports three kinds of lines specified by the LineKind. By default, the Normal kind of line is used which simply draws a line to connect the data points.

An line series using a normal line kind

The Spline line kind builds a canonical spline that runs through the data points, producing a smooth line.

An line series using a spline line kind

The Step line kind creates a line that only uses horizontal and vertical lines to connect the data points, producing a step look.

An line series using a step line kind

Markers

The line series can render a markers at each data point to highlight the actual location. By default the markers is not rendered, but they can be shown by setting MarkerVisibility to a value other than None. The line series has the same configuration properties available as the scatter series, with regards to marker rendering.

See the Scatter topic for more information on the options available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Pie / Donut

A pie / donut chart displays pie slices with sizes proportional to the values they represent.

This topic contains these sections:

  • Donut Chart
  • Customization

Donut Chart

Donut charts act just like pie charts, except for an adjustable donut hole in the center of the chart. Refer to Donut Chart for more information.

Customization

Pie / donut charts support several customization options, such as labels, legends, multiple series and more. Refer to Pie Chart Features for details on how to use these features.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Scatter

Scatter charts render data points where each point is represented by a marker.

This topic contains these sections:

  • Marker Shape Kinds

Marker Shape Kinds

Markers support several built in shape kinds, which include:

Kind | Example
Diamond |
Ellipse |
Hexagon |
Pentagon |
Octagon |
Rectangle |
RoundedRectangle |
Star4Points |
Star5Points |
Star6Points |
Star8Points |
Triangle |

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Multiple and Stacked Series

The chart control supports multiple series which can be optionally stacked on top of the previous series.

This topic contains these sections:

  • Multiple Series
  • No Stacking
  • Normal Stacking
  • Percentage Stacking

Multiple Series

Any number of series can be added to the chart, which will simply render one on top of each (in z-order) Simply add the series to the XYChart.Series collection that you would like to be rendered.

In this example, we display a bar and line series in the same chart:

XAML
Copy
​<charts:XYChart Width="200" Height="100" >
    <charts:BarSeries ItemsSource="4;11;3;1;8;9;14" />
    <charts:LineSeries ItemsSource="7;3;5;1;1;3;10" />
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis Minimum="0"/>
    </charts:XYChart.YAxes>
</charts:XYChart>

This results in the following chart:

The chart will automatically align the multiple series along the secondary axis (X in this example). So, if the series have data with disparate values, then it will automatically adjust to fit the data.

In this example, we add additional data points to the line series:

XAML
Copy
​<charts:XYChart Width="200" Height="100">
    <charts:BarSeries ItemsSource="4;11;3;1;8;9;14" />
    <charts:LineSeries ItemsSource="7;3;5;1;1;3;10;5;2;8;1;14" />
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis Minimum="0"/>
    </charts:XYChart.YAxes>
</charts:XYChart>

This results in the following chart, which has extended the line series beyond the bar series since it has more data points:

No Stacking

When not stacked, series will render on top of each other. For BarSeries, bars will render next to each other. This can be done by setting StackKind on the series to None.

XAML
Copy
​<charts:XYChart Width="200" Height="150" >
    <charts:AreaSeries ItemsSource="{Binding Data1}" StackKind="None" />
    <charts:AreaSeries ItemsSource="{Binding Data2}" StackKind="None" />
</charts:XYChart>

Normal Stacking

Two or more series can be stacked one on top of the other to convey cumlative values to the end user.

By setting StackKind on the series to Normal, the values of each series will be added to the previous stacked series.

In this sample the second series will be stacked on top of the first series.

XAML
Copy
​<charts:XYChart Width="200" Height="150" >
    <charts:AreaSeries ItemsSource="{Binding Data1}" StackKind="Normal" />
    <charts:AreaSeries ItemsSource="{Binding Data2}" StackKind="Normal" />
</charts:XYChart>

Percentage Stacking

Two or more area series can be stacked one on top of the other to convey proportional values to the end user. In this mode, the series render to fill the chart height. At any given location, the height of each rendered series indicates its value percentage relative to the total.

By setting StackKind on the series to Percentage, the values of each series will be added to the previous stacked series and a percentage of the total value will be used.

In this sample the second series will be stacked on top of the first series.

XAML
Copy
​<charts:XYChart Width="200" Height="150" >
    <charts:AreaSeries ItemsSource="{Binding Data1}" StackKind="Percentage" />
    <charts:AreaSeries ItemsSource="{Binding Data2}" StackKind="Percentage" />
</charts:XYChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The XYChart control contains several features that can be used to customize the appearance and data.

Axes

Axes control the range of values that are visible in a chart, and also can display ticks, labels, titles, and other elements.

See the Axes topic for more information.

Bar Chart Custom Styles

Bar Charts can be customized to have a unique look that fits your needs.

See the Bar Chart Custom Styles topic for more information.

Baseline

A baseline value can be used to alter the look of area, bar, and win/loss series, and can be optionally displayed on the chart.

See the Baseline topic for more information.

Data Aggregation

The chart control supports aggregating its data to reduce the number of data points displayed.

See the Data Aggregation topic for more information.

Data Point Labels

Data point labels allow you to show the values of a given data point.

See the Data Point Labels topic for more information.

Grid Lines and Stripes

Grid lines and stripes appear behind the chart data and allow the user to easily compare data against axis values.

See the Grid Lines and Stripes topic for more information.

Legend

A legend can provide context for what each series in a chart represents. Legends are fully stylable and can be customized to match the look and feel of your application.

See the Legend topic for more information.

Palettes

There are an enormous number of configuration options related to palettes. The various brushes used by the chart can be easily customized using a palette of colors or the styles can be completely overridden.

See the Palettes topic for more information.

Ranges

Specific value ranges of the chart can be highlighted to convey additional information to the end-user.

See the Ranges topic for more information.

Series Visibility

The visibility of any series can be set to dictate whether or not it is rendered on the chart.

See the Series Visibility topic for more information.

Specifying Items

The chart control can be bound to any custom data source and supports several data types.

See the Specifying Items topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Axes

Axes control the range of values that are visible on a chart. Visually, they provide a quick reference to lookup the value of data points on a chart.

This topic contains these sections:

  • Getting Started
  • Minimum and Maximum
  • Grouped Axis
  • Percentage Axis
  • Ticks
  • Labels
  • Titles
  • Position
  • Stacking / Sharing Axis
  • Display Optimizations (Removing Anti-Aliasing)

Getting Started

If you do not specify axes on your chart, then default values will be used. If your axis is a numeric or quantifiable type, then the Minimum and Maximum values will be automatically set to the lowest and highest values in your data set. To specify axes and axis properties on your chart, you must choose the correct axis for your data.

Note the example below, where the X axis data contains DateTime values and the Y axis data contains Double values.

XAML
Copy
​<charts:XYChart Width="300" Height="200">
    <charts:AreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyDoubleProperty" />
</charts:XYChart>

For this case, you would add a XYDateTimeAxis to XYChart.XAxes, and a XYDoubleAxis to XYChart.YAxes, like in the following example.

XAML
Copy
​<charts:XYChart Width="300" Height="200">
    <charts:XYChart.XAxes>
        <XYDateTimeAxis&quot;/>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <XYDoubleAxis/>
    </charts:XYChart.YAxes>
    <charts:AreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyDoubleProperty" />
</charts:XYChart>

Once the axis is specified, you can set properties on it, like the example below:

XAML
Copy
​<charts:XYChart Width="300" Height="200">
    <charts:XYChart.XAxes>
        <XYDateTimeAxis Minimum="1/1/1990" Maximum="1/1/2000"/>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <XYDoubleAxis Minimum="100" Maximum"100000"/>
    </charts:XYChart.YAxes>
    <charts:AreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyDoubleProperty" />
</charts:XYChart>

Minimum and Maximum

The Minimum and Maximum properties on XYDateTimeAxis, XYDoubleAxis, and XYDecimalAxis control the range of values that are displayed on the chart. Any values outside of the Minimum / Maximum range will not be displayed on the chart (unless they fall in the space around the chart created by XYChart.PaddingPercentage).

When Minimum and Maximum are not specified, or when the axes are not defined in markup, Minimum will be automatically set to the lowest value in the data set, and Maximum will be set to the highest.

Grouped Axis

When your X or Y axis values are a String or other complex data type, then XYGroupedAxis will be used.

Note the example below, where the X axis data contains String values and the Y axis data contains Double values.

XAML
Copy
​<charts:XYChart Width="300" Height="200">
    <charts:BarSeries ItemsSource="{Binding}" XPath="MyStringProperty" YPath="MyDoubleProperty" />
</charts:XYChart>

In the example above, and by default, values on the secondary axis (in this case, the X axis) will be grouped based on object equality. So any strings that are equal to each other will be grouped under the same bar. In the cases where mutliple objects are grouped, the values on the primary axis (in this case, the Y axis) will be summed up, if they are a numeric data type. If the primary axis values are not set, or are a non-numeric data type, they will be ignored and replaced with the number of items in each group.

Grouping

By default, items will be grouped by object equality. To change how groups are determined, you can specify XYGroupedAxis.GroupingFunc. This is a Func<object,object,bool> that takes two objects to compare and returns a bool. Return True if they should be grouped together, elsewise, return False.

This example shows a custom grouping function that groups by the first letter in each string.
C#
VB
Copy
​GroupByFirstLetter = (a, b) => {
    char firstLetterForA = ((string)a).ToLower()[0];
    char firstLetterForB = ((string)b).ToLower()[0];
    return firstLetterForA.Equals(firstLetterForB);
};
​Dim groupByFirstLetter = Function(a, b) CStr(a).Chars(0).Equals(CStr(b).Chars(0))

Labeling Groups

By default, groups will be labelled using the ToString() result on the first object in each group. To change how groups are labelled, you can specify XYGroupedAxis.LabelFunc. This is a Func<object,string> that takes the first object in a group and returns a string to be used as the group label.

This example shows a custom labeling function that labels using first letter in each string.
C#
VB
Copy
​Func<object,string> labelWithFirstLetter = a => ((string) a).Substring(0, 1);
​Dim labelWithFirstLetter = Function(a) CStr(a).Substring(0, 1)

Sorting Groups

By default, groups will not be sorted. To change how groups are sorted, you can specify XYGroupedAxis.SortingFunc. This is a Func<object,object,int> that takes the first object from two groups and returns an int describing how they compare to each other.

  • If the function returns a negative value, then the first instance is sorted before the second.
  • If the function returns zero, then the instances are considered equal and sorted next to each other.
  • If the function returns a positive value, then the first instance is sorted after the second.

This example shows a custom sorting function that sorts using first letter in each string.
C#
VB
Copy
​Func<object,object,int> sortAlphabetically = (a, b) => {
    char firstLetterForA = ((string)a).ToLower()[0];
    char firstLetterForB = ((string)b).ToLower()[0];
    return firstLetterForA - firstLetterForB;
};
​Dim sortAlphabetically = Function(a, b) AscW(CStr(a).ToLower().Chars(0)) - AscW(CStr(b).ToLower().Chars(0))
Percentage Axis

When your series has XYSeriesBase.StackKind set to XYSeriesStackKind.Percentage, then XYPercentageAxis will be used and data will be stacked by percentage on the secondary axis.

"Stacked by percentage" means that instead of a value being placed on a cartesian axis, it is instead stacked on top of values from other series. The position and size of the value is relative to the sum of all values in that slot.

So, if there are two values in a slot, 5.0 and 5.0, they will both occupy 50% of the available size since they are both half of the sum (5.0 + 5.0 = 10.0). If there are two values in a slot, 2.0 and 8.0, they will occupy 20% and 80% of the available size.

Note that XYPercentageAxis can only be used on numeric data. DateTime and complex types cannot be placed on the axis.

Labeling

By default, major ticks on XYPercentageAxis will be labeled using the percentage formatting of the environment's current culture.

For simple custom formatting, you can specify XYAxisBase.LabelFormat. The parameter "{0}" will be the percentage of the tick, represented by a value between 0.0 and 1.0. You can reference this MSDN article for numeric format strings.

This example will format the percent with two decimal places (note the use of the additional {} to escape the use of curly brackets in XAML). So, a percentage value of 0.2543 would be displayed as 25.43 % in the en-US culture.
XAML
Copy
​<XYPercentageAxis LabelFormat=&quot;{}{0:P2}/>

For more advanced labeling scenarios, you can specify XYPercentageAxis.LabelFunc. Setting this will override whatever is specified for XYAxisBase.LabelFormat. LabelFunc is a Func<double,string> that takes an object (the percentage of the current tick) and returns a string to be used as the label for the tick.

This example shows a custom labeling function that spells out the word "Percent".
C#
VB
Copy
​Func<double,string> labelFunc = percent => (percent*100).ToString() + " Percent";
​Dim labelFunc = Function(percent) (percent*100).ToString() + " Percent"
Ticks

Axis ticks create a "guide" that help to communicate the value of any given point in your chart. Major ticks generally are more prominent and have labels associated with them, while minor ticks are less prominent and do not have labels.

Tick Visibility

Major and minor ticks can be shown or hidden using XYAxisBase.AreMajorTicksVisible and XYAxisBase.AreMinorTicksVisible, respectively.

This example shows a chart with minor and major ticks visible on Y axis.
XAML
Copy
​<XYDoubleAxis AreMajorTicksVisible="True" AreMinorTicksVisible="True" ... TickMajorInterval="5" TickMinorInterval="2.5"/>

Intervals

Tick intervals control how frequently major and minor ticks occur on the axis.

For XYDoubleAxis and XYDecimalAxis, TickMajorInterval and TickMinorInterval are used. When tick intervals are not specified, they will automatically be calculated based on the chart data.

This example shows a chart with major tick interval set to 10, and minor tick interval set to 5. Compare with the examples above and note how the ticks are further spread out.
XAML
Copy
​<XYDoubleAxis TickMajorInterval="10" TickMinorInterval="5" ... />

For XYPercentageAxis, tick intervals work slightly differently. You can control how far major and minor ticks are spaced apart by setting XYPercentageAxis.TickMajorInterval and XYPercentageAxis.TickMinorInterval. Both of these properties take a Double value between 0.0 and 1.0. This represents how far apart the ticks are spaced, by percentage. For example, if the interval is set to 0.25, a tick will be placed every 25%. So there will be ticks at 0%, 25%, 50%, 75%, and 100%.

For XYDateTimeAxis, tick intervals can be set via the TickMajorInterval and TickMinorInterval properties. However the TickMajorIntervalUnit and TickMinorIntervalUnit properties must also be set to a TimeUnit that describes the unit specified by the tick intervals (days, hours, etc.). A major tick interval will automatically be calculated if none is set.

Labels

Label Visibility

Labels can be displayed on the major ticks using XYAxisBase.AreLabelsVisible.

This example shows a chart with labels and ticks visible on Y axis.
XAML
Copy
​<XYDoubleAxis AreLabelsVisible="True" ... TickMajorInterval="5" TickMinorInterval="2.5"/>

Label Visibility

Titles

An axis can be titled using XYAxisBase.Title.

This example shows a chart with a title set on the Y axis.
XAML
Copy
​<XYDoubleAxis Title="Sales" ... />

An axis title can be styled using XYAxisBase.TitleStyle.

This example shows a chart with a title style set on the Y axis.
XAML
Copy
​<charts:XYDoubleAxis Title="Sales" ...>
    <charts:XYDoubleAxis.TitleStyle>
        <Style TargetType="ContentControl">
            <Setter Property="FontSize" Value="18"/>
            <Setter Property="Foreground" Value="#004dee"/>
        </Style>
    </charts:XYDoubleAxis.TitleStyle>
</charts:XYDoubleAxis>

Position

Axes can be placed on the near edge or far edge of the chart using the XYAxisBase.Position property.

This example shows a chart with both axes on the far edge of the chart.
XAML
Copy
​<charts:XYChart ...>
    <charts:LineSeries .../>
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis Position="FarEdge" .../>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis Position="FarEdge" .../>
    </charts:XYChart.YAxes>
</charts:XYChart>

Stacking / Sharing Axis

A chart can contain multiple Y axes and multiple X axes. You can specify which series is bound to which axis by using XYSeriesBase.XAxis and XYSeriesBase.YAxis.

This example shows a chart with two series, each bound to a different Y axis with a unique range of values.
XAML
Copy
​<charts:XYChart Width="300" Height="150" >
    <charts:BarSeries ItemsSource="4;11;3;1;8;9;14" YAxis="{Binding ElementName=yAxis1}" />
    <charts:LineSeries ItemsSource="700;300;500;100;100;300;900" YAxis="{Binding ElementName=yAxis2}"/>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis x:Name="yAxis1" Minimum="0" Maximum="15" IsTickMajorVisible="True" TickMajorInterval="2" AreLabelsVisible="True" Title="Sales (Line)"/>
        <charts:XYDoubleAxis x:Name="yAxis2" Position="FarEdge" Minimum="0" Maximum="1000" AreMajorTicksVisible="True" TickMajorInterval="200"  AreLabelsVisible="True" Title="Revenue (Bar)"/>
    </charts:XYChart.YAxes>
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis AreMajorTicksVisible="False" AreMinorTicksVisible="False" AreLabelsVisible="False"/>
    </charts:XYChart.XAxes>
</charts:XYChart>
Note that each series is bound by ElementName to an axis in the XYChart.YAxes collection.

Display Optimizations (Removing Anti-Aliasing)

The XYAxisBase.UseDisplayOptimizations determines if data point values are rounded to better appear on display pixels. This property is usually good to leave as its default value of true because it will ensure that lines render with minimal anti-aliasing. It accomplishes this by slightly rounding data point values as needed.

However if precise data point locations are required, such as when rendering a smooth curved line graph, set this property to false to remove line jaggedness.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Bar Chart Custom Styles

Bar Charts can be customized to have a unique look that fits your needs.

This topic contains these sections:

  • Brushes & Styling
  • Custom Template

Brushes & Styling

Bar Series can have custom styles applied to the bars using BarSeriesBase.BarStyle.

This example shows a chart the bars styled uniquely.
XAML
Copy
​<charts:BarSeries ItemsSource="11;2;3;14;20;6">
    <charts:BarSeries.BarStyle>
        <Style TargetType="Border">
            <Setter Property="Background" Value="#55ee00ee"/>
            <Setter Property="BorderBrush" Value="#ee880088"/>
            <Setter Property="CornerRadius" Value="3"/>
            <Setter Property="BorderThickness" Value="1"/>
            <Setter Property="Effect">
                <Setter.Value>
                    <DropShadowEffect Opacity="0.4"/>
                </Setter.Value>
            </Setter>
        </Style>
    </charts:BarSeries.BarStyle>
</charts:BarSeries>

Custom Template

For a more dramatic change, you can retemplate the bar content completely by using BarSeriesBase.BarTemplate.

This example shows a chart the bars retemplated uniquely.
XAML
Copy
​<charts:XYChart Width="200" Height="150" Margin="20" HorizontalAlignment="Left">
    <charts:BarSeries ItemsSource="11;2;3;14;20;6">
        <charts:BarSeries.BarStyle>
            <Style TargetType="Border">
                <Setter Property="Background" Value="Transparent"/>
                <Setter Property="BorderBrush" Value="Transparent"/>
            </Style>
        </charts:BarSeries.BarStyle>
        <charts:BarSeries.BarTemplate>
            <DataTemplate>
                <Viewbox shared:ClipToBoundsBehavior.ClipToBounds="True" StretchDirection="DownOnly"
                                Stretch="UniformToFill" Margin="0" VerticalAlignment="Bottom" >
                    <StackPanel Width="20" Orientation="Vertical">
                        <StackPanel.Resources>
                            <Style x:Key="EllipseStyle" TargetType="Ellipse">
                                <Setter Property="Width" Value="20"/>
                                <Setter Property="Height" Value="20"/>
                                <Setter Property="Fill" Value="#8bbcde"/>
                            </Style>
                        </StackPanel.Resources>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                    </StackPanel>
                </Viewbox>
            </DataTemplate>
        </charts:BarSeries.BarTemplate>
    </charts:BarSeries>
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis BarSpacing="10" IsTickMajorVisible="False" IsTickMinorVisible="False" AreLabelsVisible="False"/>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis AreMajorTicksVisible="True" AreMinorTicksVisible="True" AreLabelsVisible="False" TickMajorInterval="5" TickMinorInterval="2.5" Minimum="0"/>
    </charts:XYChart.YAxes>
</charts:XYChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Baseline

Baseline is the point on an axis that separates positive and negative values. A baseline value can be used to alter the look of area and bar series, and can be optionally displayed on the chart.

This topic contains these sections:

  • Baseline Value
  • Baseline Visibility and Style

Baseline Value

The baseline value determines what the chart considers "positive" and "negative" values. Any value greater than or equal to the baseline value is considered positive, and any value less than the baseline value is considered negative.

The baseline value can be customized using the Baseline property on XYDoubleAxis, XYDecimalAxis, and XYDateTimeAxis. Baseline defaults to 0 for numeric values and DateTime.MinValue for date/time.

In addition, area and bar series will pivot their polygons around the baseline value, which alters their appearance.

In the following examples, the data rendered by the area chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum. Since our baseline is 0 (the default), the polygon is not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the polyon will appear to pivot around the baseline.

Baseline Visibility and Style

An actual line can be rendered at the specified baseline value to highlight its location in the chart. The visibility of the line is configured using the IsAxisBaselineVisible property, which is false by default.

For example, the following line series uses the same fixed values from above (10, 20, 10, 20, 10, 20, 10) and a baseline value of 15. In this particular example, since the line is rendered with a single color, it is not possible to visually determine what is considered above or below the baseline.

If we set IsAxisBaselineVisible to True, then we can easily determine this information.

The style of the line can be customized using the AxisBaselineStyle property. The associated Style should target the Shape type, which includes properties such as Stroke and StrokeThickness.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Aggregation

The chart control supports aggregating its data to reduce the number of data points displayed.

This topic contains these sections:

  • Aggregation Factor
  • Aggregation Kinds

Aggregation Factor

In order to increase performance, the chart control will automatically determine the optimal number of data points to display based on the size of the control. This is determined using the AggregationFactor property, which defaults to 0.2.

For example, if the chart control is 100 pixels wide and uses an aggregation factor of 0.1, then the optimal number of data points would be 10. If the data source contained 1000 items, then the chart would create 10 groups, each with 100 items in it. Then some sort of aggregation function would be performed on each group to generate a single data point for display.

A line series with markers visible with no aggregation, 10% aggregation, and 50% aggregation

Aggregation is enabled by default and can be disabled by setting IsAggregationEnabled to false.

Aggregation Kinds

There are various aggregation functions that can be performed on the items in a group. The supported aggregation kinds are specified using the PrimaryAggregationKind and SecondaryAggregationKind.

The PrimaryAggregationKind is typically used for the Y values, but for vertically-oriented series this will be used by the X values. Similarly the SecondaryAggregationKind is used for X values, but will be used by Y values for vertically-oriented series.

The following table lists the supported aggregation kinds:

Aggregation Kind | Description
Average | Averages all the values in the group and uses that as the aggregated value.
First | Uses the first value in the group as the aggregated value.
Last | Uses the last value in the group as the aggregated value.
Maximum | Uses the maximum value in the group as the aggregated value.
Minimum | Uses the minimum value in the group as the aggregated value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Point Labels

Data point labels allow you to show the values of a given data point.

This topic contains these sections:

  • Visibility
  • Style
  • Formatting
  • Advanced Customization
  • Angle
  • Layout
  • Collision Avoidance

Visibility

Visibility of data point labels can be controlled using SeriesBase.LabelVisibility. LabelVisibility defaults to Hidden, in which no labels are visible.

This is an example of setting LabelVisibility to Visible, in which all labels are visible.
XAML
Copy
​<charts:BarSeries LabelVisibility="Visible" .../>

This is an example of setting LabelVisibility to PointerAxis, in which labels are visible on all data points near the mouse pointer on the secondary axis.
XAML
Copy
​<charts:BarSeries LabelVisibility="PointerAxis" .../>

This is an example of setting LabelVisibility to PointerProximity, in which labels are visible on all data points near the mouse pointer.
XAML
Copy
​<charts:BarSeries LabelVisibility="PointerProximity" .../>

Style

The sytle of the data point labels can be changed using SeriesBase.LabelStyle. The style TargetType must be DataPointLabel.

This is an example of a custom data point label style. Note how the default label color is available by binding to DataPointLabel.SeriesDefaultBrush.
XAML
Copy
​<charts:BarSeries ItemsSource="11;2;3;14;20" LabelVisibility="Visible">
    <charts:BarSeries.LabelStyle>
        s<Style TargetType="charts:DataPointLabel">
            <Setter Property="Background" Value="White"/>
            <Setter Property="BorderBrush" Value="{Binding SeriesDefaultBrush}"/>
            <Setter Property="BorderThickness" Value="2"/>
            <Setter Property="Foreground" Value="{Binding SeriesDefaultBrush}"/>
            <Setter Property="FontWeight" Value="Bold"/>
            <Setter Property="Effect">
                <Setter.Value>
                    <DropShadowEffect Opacity="0.1"/>
                </Setter.Value>
            </Setter>
        </Style>
    </charts:BarSeries.LabelStyle>
</charts:BarSeries>

Formatting

The formatting of the data point labels can be changed using SeriesBase.LabelFormat. Label format provides four parameters:

  • {0} is the value on the primary axis.
  • {1} is the value on the secondary axis.
  • {2} is the value on the X axis.
  • {3} is the value on the Y axis.

This is an example of a custom data point label format. The label format is "X:{2} Y:{3}". Note the extra pair of curly-braces used to escape the format string in XAML.
XAML
Copy
​<charts:BarSeries LabelFormat="{}X:{2} Y:{3}" .../>

Advanced Customization

There may be situations where SeriesBase.LabelFormat is not sufficient for your needs. In those cases, you can use SeriesBase.LabelFunc to create custom labels using a custom function. LabelFunc is a Func<object,object,object,object,object,string>. It has the following parameters: primary axis value, secondary axis value, X axis value, Y axis value, and original value. The string that is returned is used for the data point label.

This is an example of a custom data point label func.
XAML
Copy
​<charts:BarSeries LabelFunc="{Binding CustomLabelFunc}" .../>
It is bound to a Func<object,object,object,object,object,string> property on the DataContext, which has a function pointer with a matching signature assigned to it.
C#
VB
Copy
​private readonly Func<object, object, object, object, object, string> customLabelFunc = GetCustomLabel;

public Func<object, object, object, object, object, string> CustomLabelFunc {
    get { return customLabelFunc; }
}

public static string GetCustomLabel(object primaryValue, object secondaryValue, object xValue, object yValue, object originalValue) {
    return string.Format("X: {0}{1}Y: {2}", xValue, Environment.NewLine, yValue);
}
​Private ReadOnly _customLabelFunc As New Func(Of Object, Object, Object, Object, Object, String)(AddressOf GetCustomLabel)

Public ReadOnly Property CustomLabelFunc() As Func(Of Object, Object, Object, Object, Object, String)
    Get
        Return _customLabelFunc
    End Get
End Property

Public Shared Function GetCustomLabel(ByVal primaryValue As Object, ByVal secondaryValue As Object, ByVal xValue As Object, ByVal yValue As Object, ByVal originalValue As Object) As String
    Return String.Format("X: {0}{1}Y: {2}", xValue, Environment.NewLine, yValue)
End Function

Angle

The angle of data point labels can be changed using SeriesBase.LabelAngle.

This is an example of a custom data point label angle at 45 degrees.
XAML
Copy
​<charts:BarSeries LabelAngle="45" .../>

Layout

Each series uses the best method for determining label position by default, but this can be customized when needed. You can set LabelPositioningMode on BarSeries, LineSeries, AreaSeries, or ScatterSeries to determine how labels are positioned. The two possible values are LabelPositioningMode.FromBaseline, which positions labels away from the baseline, and LabelPositioningMode.FromAverage, which positions labels away from the average value of the primary axis.

Collision Avoidance

By default, data point labels have collision detection enabled and will attempt to not overlap each other by stacking away from the baseline.

If you want to disable this behavior, you can use XYChart.LabelCollisionMode and set it to None.

This is an example of the label collision detection being disabled.
XAML
Copy
​<charts:XYChart LabelCollisionMode="None" .../>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Grid Lines and Stripes

Grid lines and stripes appear behind the chart data and allow the user to easily compare data against axis values.

This topic contains these sections:

  • Line Visibility
  • Stripe Visibility
  • Line Customization
  • Stripe Customization

Line Visibility

Visibility of the grid lines is controlled using XYChart.GridLineMajorVisibility and XYChart.GridLineMinorVisibility. These properties can be set to None, All, X, or Y.

This is an example of setting GridLineMajorVisibility to Y, in which grid lines are shown for each major tick on the Y axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="Y" .../>

This is an example of setting GridLineMajorVisibility to X, in which grid lines are shown for each major tick on the X axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="X" .../>

This is an example of setting GridLineMajorVisibility to All, in which grid lines are shown for each major tick on the X and Y axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="All" .../>

Stripe Visibility

Visibility of the grid stripes is controlled using XYChart.GridStripeVisibility. This property can be set to None, X, or Y.

This is an example of setting GridLineMajorVisibility to Y, in which grid stripes are shown alternating between each major tick on the Y axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="Y" .../>

This is an example of setting GridLineMajorVisibility to X, in which grid stripes are shown alternating between each major tick on the X axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="X" .../>

Line Customization

The color of major and minor grid lines can be controlled using XYChart.GridLineMajorBrush and XYChart.GridLineMinorBrush, respectively.

This is an example of setting GridLineMajorBrush and GridLineMinorBrush to custom colors.
XAML
Copy
​<charts:XYChart .... GridLineMajorBrush="#338833" GridLineMinorBrush="#33bb33">

Stripe Customization

The color of grid stripes and alternating grid stripes can be controlled using XYChart.GridStripeBrush and XYChart.GridStripeAlternatingBrush.

This is an example of setting GridStripeBrush and GridStripeAlternatingBrush to custom colors.
XAML
Copy
​<charts:XYChart .... GridStripeBrush="#55338833" GridStripeAlternatingBrush="#2233bb33">

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Legend

A chart legend is a reference that shows a description of each data set and the color it is represented by.

This topic contains these sections:

  • Description
  • Visibility
  • Position
  • Legend Customization
  • Legend Item Customization

Description

The XYSeriesBase.Description property determines the textual description that is used in the legend to represent each series.

Visibility

The visibility of the legend can be controlled using XYChart.IsLegendVisible.

This is an example of setting IsLegendVisible to true.
XAML
Copy
​<charts:XYChart IsLegendVisible="true" .../>

Position

The position of the legend can be controlled using XYChart.LegendHorizontalPosition and XYChart.LegendVerticalPosition. Legend positions have two modifiers, Inside and Outside (for example, LeftInside and TopOutside. Inside means the legend will be positioned relative to the chart drawing area, and Outside means the legend will be positioned relative to the entire chart control. So CenterInside will be in the center of the chart drawing area, wheras CenterOutside will be in the center of the entire chart control.

This is an example of setting LegendHorizontalPosition to RightOutside and LegendVerticalPosition to TopOutside. Note how when placed outside the chart drawing area, the chart will resize to make room for the legend.
XAML
Copy
​<charts:XYChart LegendHorizontalPosition="RightOutside" LegendVerticalPosition="TopOutside" .../>

This is an example of setting LegendHorizontalPosition to LeftInside and LegendVerticalPosition to BottomInside.
XAML
Copy
​<charts:XYChart LegendHorizontalPosition="LeftInside" LegendVerticalPosition="BottomInside" .../>

Legend Customization

The legend can be styled using XYChart.LegendStyle. The style you provide should have a TargetType of ItemsControl.

This is an example of providing a custom LegendStyle.
XAML
Copy
​<charts:XYChart.LegendStyle>
    <Style TargetType="ItemsControl">
        <Setter Property="BorderBrush" Value="LightGray"/>
        <Setter Property="BorderThickness" Value="3"/>
        <Setter Property="Background">
            <Setter.Value>
                <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                    <GradientStop Color="#222222" Offset="0.0"/>
                    <GradientStop Color="#444444" Offset="0.2"/>
                    <GradientStop Color="#444444" Offset="0.8"/>
                    <GradientStop Color="#222222" Offset="1.0"/>
                </LinearGradientBrush>
            </Setter.Value>
        </Setter>
        <Setter Property="Padding" Value="10"/>
        <Setter Property="Effect">
            <Setter.Value>
                <DropShadowEffect Opacity="0.5"/>
            </Setter.Value>
        </Setter>
        <Setter Property="FontFamily" Value="Trebuchet MS"/>
        <Setter Property="FontWeight" Value="Normal"/>
        <Setter Property="FontStyle" Value="Italic"/>
        <Setter Property="FontSize" Value="14"/>
        <Setter Property="Foreground" Value="White"/>
    </Style>
</charts:XYChart.LegendStyle>

Legend Item Customization

Each individual legend item can be retemplated by setting ItemTemplate in XYChart.LegendStyle. The data source for the template is LegendKey, allowing you to bind to properties from the template such as LegendKey.Label and LegendKey.LegendMarkerStyle.

This is an example of providing a custom LegendStyle to retemplate the legend items.
XAML
Copy
​<charts:XYChart.LegendStyle>
    <Style TargetType="ItemsControl">
        <Setter Property="ItemTemplate">
            <Setter.Value>
                <DataTemplate>
                    <Border Background="#dddddd" Padding="5" Margin="5">
                        <StackPanel Orientation="Horizontal">
                            <charts:ChartMarker Margin="0,0,5,0" Style="{Binding LegendMarkerStyle}" BorderBrush="#333333"/>
                            <TextBlock Text="{Binding Label}" Foreground="#111111" FontFamily="Arial"/>
                        </StackPanel>
                    </Border>
                </DataTemplate>
            </Setter.Value>
        </Setter>
    </Style>
</charts:XYChart.LegendStyle>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Palettes

There are an enormous number of configuration options related to palettes. The various brushes used by the chart can be easily customized using a palette of colors or the styles can be completely overridden.

This topic contains these sections:

  • Introduction
  • Built-In Palettes
  • Palette Color Selection
  • Palette Shade Generation
  • Custom Palette Colors
  • Customizing Highlight Effect Brushes

Introduction

When any series is being rendered within a chart, it uses the chart's XYChart.SeriesStyleSelector to determine which styles to apply to the various shapes displayed. These shapes include the basic shapes representing lines, areas, bars, markers, etc.

The SeriesPaletteStyleSelector class inherits SeriesStyleSelector and provides many settings that can be used to completely customize how a chart renders its series.

An important thing to note is that the SeriesPaletteStyleSelector builds shape styles based on colors defined in a Palette that has been assigned to its PaletteStyleSelectorBase`1.Palette property. The palette contains multiple colors so that when more than one series is used in a chart, each series will cycle to use a different palette color.

Built-In Palettes

Numerous built-in palettes are included with the product, each named via a value within the PaletteKind enumeration.

A built-in palette can be assigned to a chart like this (in this case the Roman palette):

XAML
Copy
​<charts:XYChart Width="100" Height="18">
    <charts:XYChart.SeriesStyleSelector>
        <charts:SeriesPaletteStyleSelector>
            <charts:Palette Kind="Roman" />
        </charts:SeriesPaletteStyleSelector>
    </charts:XYChart.SeriesStyleSelector>
    ...
</charts:XYChart>

For simple cases where no other customization is needed on the SeriesPaletteStyleSelector, the palette kind can simply be set as an attribute value as well, where the text specified matches one of the PaletteKind values:

XAML
Copy
​<charts:XYChart Width="100" Height="18" SeriesStyleSelector="Roman">
    ...
</charts:XYChart>

Palette Color Selection

Each palette has two mode options for how colors will be assigned to series in a chart. The mode is set by specifying a ColorSelectionHint value on the Palette.ColorSelectionHint property.

Mode | Description
Sequential | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
UniformDistribution | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.

The default is to use UniformDistribution mode on the built-in palettes, and Sequential mode on custom palettes.

Palette Shade Generation

Each palette has a list of base colors used directly as the core color for each series in a chart. Most palettes define six colors. But what happens when there are more than six series in a chart?

If shade generation is enabled on a palette, via its Palette.IsShadeGenerationEnabled property, additional darker and lighter shades of the base colors will be generated and used for the other series. By default, this feature is enabled.

If this feature is disabled, the color assignments will recycle and the seventh series will simply use the first base color again, and so on.

Custom Palette Colors

It's very easy to create custom palettes. Simply create a Palette and assign the custom colors to its BaseColors collection.

This sample shows the creation of a palette that contains two custom colors:

XAML
Copy
​<charts:XYChart Width="100" Height="18">
    <charts:XYChart.SeriesStyleSelector>
        <charts:SeriesPaletteStyleSelector>
            <charts:Palette>
                <Color>#46bff7</Color>
                <Color>#06226b</Color>
            </charts:Palette>
        </charts:SeriesPaletteStyleSelector>
    </charts:XYChart.SeriesStyleSelector>
    ...
</charts:XYChart>

Note Note
When multiple series are used in a chart, make sure that your palette has enough base color entries to match or exceed your series count. Or ensure that the shade generation feature (described above) is active.

Customizing Highlight Effect Brushes

As described in the introduction above, there are many ways certain data points (and related markers, bars, etc.) can be highlighted. The SeriesPaletteStyleSelector class has an enormous number of property-based options for customizing highlight effects:

  • Area
  • Bar
  • Legend
  • Line
  • Marker

Each of these options generally has three properties on SeriesPaletteStyleSelector, such as these for normal areas:

  • AreaBrushCustom
  • AreaBrushKind
  • AreaTintColor

Custom Brush

A custom Brush, if specified via properties like AreaBrushCustom, will cause the related shape (in this case, a normal area) to directly use that brush for rendering.

Brush Kind

A brush kind can be specified via properties like AreaBrushKind. This kind is of type SeriesBrushKind and has many values that can "modify" the palette color assigned to the series:

  • Default - Use the exact palette color.
  • Light - Use a slightly lighter version of the palette color.
  • Dark - Use a slightly darker version of the palette color.
  • SemiTransparent - Use gradient, from a semi-transparent version of the palette color to transparent.
  • SemiTransparentGradient - Use a gradient, from a semi-transparent version of the palette color to an almost completely transparent version of the palette color.
  • DarkToLightGradient - Use a gradient, from the Dark to Light color.
  • LightToDarkGradient - Use a gradient, from the Light to Dark color.
  • CylinderGradient - Use a gradient, creating a cylindrical appearance.

By using a brush kind setting instead of specifying an exact custom brush, the brush used for each series will be relative to the palette color assigned to that series.

Tint Color

A tint color can be set via properties like AreaTintColor. If specified, the tint will be applied to the resulting brush from the brush kind setting. The tint color is not used if a custom brush is directly set.

The default usage of tint colors is for high areas/markers to tint towards green, and low areas/markers to tint towards red.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ranges

Specific value ranges of the chart can be highlighted to convey additional information to the end-user.

A line chart with a green and red range for positive and negative values, respectively

This topic contains these sections:

  • Orientation
  • Minimum and Maximum Values

Orientation

By default, ranges will be aligned horizontally, which means they highlight value ranges along the Y-axis. A vertical range can be created by setting the Orientation property to Vertical. Vertical ranges highlight value ranges along the X-axis.

A line chart with a yellow range between the X values 2 and 5

In this example, the line series is set to a collection of doubles. Therefore, the X values will range from 0 to 7 (since there are 8 entries) and the actual values shown will be used along the Y axis:

XAML
Copy
​<charts:XYChart IsLegendVisible="True" ...>
    <charts:LineSeries ItemsSource="11;2;3;14;20" />
    <charts:LineSeries ItemsSource="3;8;1;15;10" />
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis ...>
            <charts:XYDoubleAxis.Ranges>
                <charts:XYRange Background="#66FFFF00" Minimum="1" Maximum="2" Orientation="Vertical"/>
            </charts:XYDoubleAxis.Ranges>
        </charts:XYDoubleAxis>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis .../>
    </charts:XYChart.YAxes>
</charts:XYChart>

Minimum and Maximum Values

The values of a range are specified using the Maximum and Minimum properties.

If either of these properties is unset (or set to null), then it's value will be auto-calculated based on the data points from all series. The Maximum will run to the highest value and likewise the Minimum will run to the lowest value.

For example, we can produce two ranges that run up (green) and down (red) from 0 using the following code:

XAML
Copy
​<charts:XYChart ...>
    <charts:LineSeries ItemsSource="11;2;3;14;20" />
    <charts:LineSeries ItemsSource="3;8;1;15;10" />
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis .../>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis ...>
            <charts:XYDoubleAxis.Ranges>
                <charts:XYRange Minimum="10">
                    <charts:XYRange.Background>
                        <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                            <GradientStop Color="Transparent" Offset="0" />
                            <GradientStop Color="#2200FF00" Offset="0.95" />
                            <GradientStop Color="#3300FF00" Offset="1" />
                        </LinearGradientBrush>
                    </charts:XYRange.Background>
                </charts:XYRange>
                <charts:XYRange Maximum="10">
                    <charts:XYRange.Background>
                        <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                            <GradientStop Color="#33FF0000" Offset="0" />
                            <GradientStop Color="#22FF0000" Offset="0.05" />
                            <GradientStop Color="Transparent" Offset="1" />
                        </LinearGradientBrush>
                    </charts:XYRange.Background>
                </charts:XYRange>
            </charts:XYDoubleAxis.Ranges>
        </charts:XYDoubleAxis>
    </charts:XYChart.YAxes>
</charts:XYChart>

This produces the following chart:

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Series Visibility

The visibility of any series can be set to dictate whether or not it is rendered on the chart.

Usage

The visibility of a series can be changed in order to create the ability to show/hide the series on the chart. With this feature several series can be contained within a chart then their visibilities can be manipulated to better compare just a couple at a time. The visibility of a series can be customized with the SeriesBase.Visibility property, which defaults to Visible.

In this example, the visibility property of the line series is bound to the IsChecked property of the checkbox so that the series is shown when checked and not shown when unchecked:

XAML
Copy
​<charts:XYChart ...>
    <charts:BarSeries Description="New York" ... />
    <charts:LineSeries Description="Los Angeles" Visibility="{Binding IsChecked, ElementName=seriesVisibleCheckBox, Converter={StaticResource BooleanToVisibilityConverter}}" .../>
</charts:XYChart>
...
<CheckBox x:Name="seriesVisibleCheckBox" Content="Los Angeles series visible" IsChecked="True"/>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Specifying Items

The chart control can be bound to any custom data source and supports several data types.

This topic contains these sections:

  • Supported Quantifiable Axis Types
  • Other Axis Types
  • Setting ItemsSource

Supported Quantifiable Axis Types

The chart control supports a fixed set of quantifiable data types along each axis.

The supported data types include:

  • Byte
  • DateTime
  • Decimal
  • Double
  • Int16
  • Int32
  • Int64
  • Float
  • SByte
  • UInt16
  • UInt32
  • UInt64

When the X or Y axis values are of these data types, then the values can be mapped on an axis according to their relative position within the axis Minimum and Maximum values.

Other Axis Types

For all other types of data, including complex objects and String, they will be mapped using XYGroupedAxis.

When using XYGroupedAxis, items will be grouped based on object equality by default. Items can be grouped using custom logic by specifying XYGroupedAxis.GroupingFunc.

Setting ItemsSource

Each series in a chart control can be bound to a separate data source, or to different properties on the same data source. The ItemsSource property on each series can be set to any collection of objects, including custom objects, as long as the collection implements IEnumerable.

In this case, the XPath and/or YPath properties must be set to the name of a property on the objects in the collection.

Note Note
You can traverse complex hierarchies to get to the value you need by using a property path that is delimited by a period ("."). For example you can set XPath or YPath to something like "MyProperty.MyOtherProperty.MyDoubleValue", similar to how binding paths work in XAML.

For example, consider the following custom object:

C#
VB
Copy
​public class SalesData {

    private decimal amount;
    private DateTime date;

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // OBJECT
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Initializes a new instance of the <c>SalesData</c> class.
    /// </summary>
    /// <param name="date">The date for which the amount is specified.</param>
    /// <param name="amount">The sales amount.</param>
    public SalesData(DateTime date, decimal amount) {
        this.date = date;
        this.amount = amount;
    }

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // PUBLIC PROCEDURES
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Gets the sales amount.
    /// </summary>
    /// <value>The sales amount.</value>
    public decimal Amount {
        get {
            return amount;
        }
    }

    /// <summary>
    /// Gets the date for which the amount is specified.
    /// </summary>
    /// <value>The date for which the amount is specified.</value>
    public DateTime Date {
        get {
            return date;
        }
    }

}
​Public Class SalesData

    Private amount_Renamed As Decimal
    Private date_Renamed As DateTime

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' OBJECT
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Initializes a new instance of the <c>SalesData</c> class.
    ''' </summary>
    ''' <param name="date">The date for which the amount is specified.</param>
    ''' <param name="amount">The sales amount.</param>
    Public Sub New(ByVal [date] As DateTime, ByVal amount As Decimal)
        Me.date_Renamed = [date]
        Me.amount_Renamed = amount
    End Sub

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' PUBLIC PROCEDURES
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Gets the sales amount.
    ''' </summary>
    ''' <value>The sales amount.</value>
    Public ReadOnly Property Amount() As Decimal
        Get
            Return amount_Renamed
        End Get
    End Property

    ''' <summary>
    ''' Gets the date for which the amount is specified.
    ''' </summary>
    ''' <value>The date for which the amount is specified.</value>
    Public ReadOnly Property [Date]() As DateTime
        Get
            Return date_Renamed
        End Get
    End Property

End Class

We can specify that the Y values should be pulled from the Amount property by setting YPath to "Amount". If we want to use the index in the collection as our X values, then we do not need to set XPath.

If instead we want the X values to be pulled from the Date property, then we would need to set XPath to "Date".

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Pie charts have several features that allow you to customize their function and appearance to meet your needs.

Customizing Appearance

Several properties allow you to change the colors used for the pie slices, along with other elements in pie charts.

See the Customizing Appearance topic for more information.

Donut Chart

Donut charts act just like pie charts, except for an adjustable donut hole in the center of the chart.

See the Donut Chart topic for more information.

Legend

A legend can provide context for what each pie slice represents. Legends are fully stylable to match the look and feel of your application.

See the Legend topic for more information.

Multiple Series

Pie charts and donut charts can contain multiple series, displayed as cocentric rings. They also support heirarchical data, displaying a child ring outside or inside the parent.

See the Multiple Series topic for more information.

'Other' Slice

Small slices can be aggregated into an 'Other' slice. This can be based on a numeric threshold or a percentage.

See the 'Other' Slice topic for more information.

Pie Slice Labels

Labels can be displayed on each pie slice and fully customized.

See the Pie Slice Labels topic for more information.

Specifying Items

Pie / donut charts can be bound to any custom data source as long as it contains a numeric value to determine pie slice percentages from.

See the Specifying Items topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Customizing Appearance

Several properties allow you to change the colors used for the pie slices, along with other elements in pie charts.

This topic contains these sections:

  • Built-In Palettes
  • Custom Palettes
  • Chart Border
  • Chart Background

Built-In Palettes

Style selectors determine what style will be applied to each pie slice. To change the style selector, set PieSeries.SliceStyleSelector to an instance of PieSlicePaletteStyleSelector, or a custom implementation of IPieSliceStyleSelector.

PieSlicePaletteStyleSelector contains several built-in palettes to make styling your pie chart or donut chart easier. The full list can be found in the PaletteKind enumeration.

A built-in palette can be assigned to a pie / donut chart like this (in this case the Roman palette):

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries>
        <charts:PieSeries.SliceStyleSelector>
            <charts:PieSlicePaletteStyleSelector>
                <charts:Palette Kind="Roman"/>
            </charts:PieSlicePaletteStyleSelector>
        </charts:PieSeries.SliceStyleSelector>
    </charts:PieSeries>
</charts:PieChart>

Custom Palettes

Custom palettes can be assigned by specifying your own colors on an instance of Palette.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries>
        <charts:PieSeries.SliceStyleSelector>
            <charts:PieSlicePaletteStyleSelector>
                <charts:Palette>
                    <Color>#FFFF00</Color>
                    <Color>#00FFFF</Color>
                    <Color>#FF00FF</Color>
                    <Color>#00FF00</Color>
                    <Color>#FF0000</Color>
                    <Color>#0000FF</Color>
                </charts:Palette>
            </charts:PieSlicePaletteStyleSelector>
        </charts:PieSeries.SliceStyleSelector>
    </charts:PieSeries>
</charts:PieChart>

Chart Border

The color and thickness of a pie / donut chart border can be changed using the PieChart.BorderBrush and PieChart.BorderThickness properties, respectively.

XAML
Copy
​<charts:PieChart BorderBrush="DarkSlateGray" BorderThickness="3"/>

Chart Background

The color of a pie / donut chart background can be changed using the PieChart.Background property.

XAML
Copy
​<charts:PieChart Background="DimGray"/>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Donut Chart

Donut charts act just like pie charts, except for an adjustable donut hole in the center of the chart. DonutChart is a subclass of PieChart, so all pie chart documentation also applies to donut chart.

This topic contains these sections:

  • Specifying Hole Radius

Specifying Hole Radius

The hole radius of a donut chart can be specified by changing DonutChart.HoleRadiusPercentage. HoleRadiusPercentage determines what percentage of the DonutChart is consumed by the donut hole, from 0.0 (0%) to 1.0 (100%).

A donut chart with a donut hole radius at 80%:

XAML
Copy
​<charts:DonutChart HoleRadiusPercentage="0.8"/>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Legend

A legend can provide context for what each pie slice represents. Legends are fully stylable to match the look and feel of your application.

This topic contains these sections:

  • Getting Started
  • Legend Position
  • Styling Legend
  • Legend Item Customization

Getting Started

The legend will display the title of each pie slice in the pie chart, along with the color of each pie slice as a key in the legend. To display a legend on a pie / donut chart, set PieChart.IsLegendVisible to true.

XAML
Copy
​<charts:PieChart IsLegendVisible="true"/>

Legend Position

The position of the legend can be controlled using PieChart.LegendHorizontalPosition and PieChart.LegendVerticalPosition. Legend positions have two modifiers, Inside and Outside (for example, LeftInside and TopOutside.

Inside means the legend will be positioned within the pie chart drawing area and may overlap labels and other elements. Outside means the legend will be positioned outside of the pie chart drawing area and space will be made so that it does not overlap the pie chart or labels.

This is a legend displayed at TopInside and RightInside. Note how it overlaps other elements on the pie chart.

XAML
Copy
​<charts:PieChart LegendVerticalPosition="TopInside" LegendHorizontalPosition="RightInside"/>

This is a legend displayed at TopInside and RightOutside. Note how room is made to place the legend on the right, outside the chart.

XAML
Copy
​<charts:PieChart LegendVerticalPosition="TopInside" LegendHorizontalPosition="RightOutside"/>

Legend position can also be fine-tuned using PieChart.LegendMargin. LegendMargin is a Thickness that determines how the legend is placed after PieChart.LegendHorizontalPosition and PieChart.LegendVerticalPosition are applied.

This is a legend displayed at TopInside and RightInside, with a LegendMargin of 0,40,0,0. Note how the legend is placed 40 pixels lower than it normally would be without the margin.

XAML
Copy
​<charts:PieChart LegendVerticalPosition="TopInside"
                        LegendHorizontalPosition="RightInside" LegendMargin="0,40,0,0"/>

Styling Legend

The legend can be styled using PieChart.LegendStyle. The style you provide should have a TargetType of ItemsControl.

This is an example of providing a custom LegendStyle.
XAML
Copy
​<charts:PieChart.LegendStyle>
    <Style TargetType="ItemsControl">
        <Setter Property="BorderBrush" Value="LightGray"/>
        <Setter Property="BorderThickness" Value="3"/>
        <Setter Property="Background">
            <Setter.Value>
                <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                    <GradientStop Color="#222222" Offset="0.0"/>
                    <GradientStop Color="#444444" Offset="0.2"/>
                    <GradientStop Color="#444444" Offset="0.8"/>
                    <GradientStop Color="#222222" Offset="1.0"/>
                </LinearGradientBrush>
            </Setter.Value>
        </Setter>
        <Setter Property="Padding" Value="10"/>
        <Setter Property="Effect">
            <Setter.Value>
                <DropShadowEffect Opacity="0.5"/>
            </Setter.Value>
        </Setter>
        <Setter Property="FontFamily" Value="Trebuchet MS"/>
        <Setter Property="FontWeight" Value="Normal"/>
        <Setter Property="FontStyle" Value="Italic"/>
        <Setter Property="FontSize" Value="14"/>
        <Setter Property="Foreground" Value="White"/>
    </Style>
</charts:PieChart.LegendStyle>

Legend Item Customization

Each individual legend item can be retemplated by setting ItemTemplate in PieChart.LegendStyle. The data source for the template is LegendKey, allowing you to bind to properties from the template such as LegendKey.Label and LegendKey.LegendMarkerStyle.

This is an example of providing a custom LegendStyle to retemplate the legend items.
XAML
Copy
​<charts:PieChart.LegendStyle>
    <Style TargetType="ItemsControl">
        <Setter Property="ItemTemplate">
            <Setter.Value>
                <DataTemplate>
                    <Border Padding="5,0">
                        <StackPanel Orientation="Horizontal">
                            <charts:ChartMarker Margin="0,0,5,0" Style="{Binding LegendMarkerStyle}" BorderBrush="#333333" ShapeKind="Star5Points" Width="15" Height="15" />
                            <TextBlock Text="{Binding Label}" Foreground="#111111" FontFamily="Arial" FontSize="16"/>
                        </StackPanel>
                    </Border>
                </DataTemplate>
            </Setter.Value>
        </Setter>
    </Style>
</charts:PieChart.LegendStyle>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Multiple Series

Pie charts and donut charts can contain multiple series, displayed as cocentric rings. They also support hierarchical data, displaying a child ring outside or inside the parent.

This topic contains these sections:

  • Stacked Pie Series
  • Child (Hierarchical) Pie Series

Stacked Pie Series

To display multiple pie series, simply specify them as PieChart.Content the same way you would specify a single pie series:

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="[...]"/>
    <charts:PieSeries ItemsSource="[...]"/>
</charts:PieChart>

The size of pie series can be adjusted using the PieSeries.Length property. This is a number that is relative to the other pie series on the chart. If there are two pie series with a length of 1.0, both pie series will display at 50%. In the example below, one pie series has a length of 1.0 and the other 3.0. Because of this, one will display at 25% and the other at 75%.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries Length="1" ItemsSource="[...]"/>
    <charts:PieSeries Length="3" ItemsSource="[...]"/>
</charts:PieChart>

Child (Hierarchical) Pie Series

Data can be displayed hierarchically, so that inside or outside of each pie slice there are child slices. To display children, you must set PieSeries.ChildrenPath. ChildrenPath is a property path to an item on your data source that contains an IEnumerable of child items. At a minimum, children must have values, so PieSeries.ChildSliceValuePath must be set as well, and resolve to a numeric value.

There are numerous properties on PieSeries that have a matching counterpart for child slices: ChildLabelBrush, ChildLabelPosition, ChildLabelStyle, ChildSliceLabelFormat, ChildSliceLabelFunc, ChildSliceTitlePath, and ChildSliceValuePath are all properties that have a matching counterpart for parent pie slices. Consult the relevant sections at Pie Chart Features to understand how these properties work.

Example

As an example, let's say we have an IEnumerable of Person for our PieSeries.ItemsSource.

C#
VB
Copy
​public class Person {
    public string Name { get; set; }
    public double Income { get; set; }
    public IEnumerable<Person> Employees { get; set; }
}
​Public Class Person
    Public Property Name() As String
    Public Property Income() As Double
    Public Property Employees() As IEnumerable(Of Person)
End Class
Our IEnumerable of Person is called People, and we set it as our data source:
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="{Binding People}" SliceValuePath="Income" SliceTitlePath="Name"/>
</charts:PieChart>
Note how the Person class has a Employees property, which is also an IEnumerable of Person. Let's use that as our child data source for each pie slice. We also need to set the ChildSliceValuePath and the ChildSliceTitlePath.
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="{Binding People}" ChildrenPath="Employees"
                      SliceValuePath="Income" SliceTitlePath="Name"
                      ChildSliceValuePath="Income" ChildSliceTitlePath="Name"
                      Length="5" ChildrenLength="1" [...]/>
</charts:PieChart>
Now we can see each child as a slice under the parent:

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


'Other' Slice

Small slices can be aggregated into an 'Other' slice. This can be based on a numeric threshold or a percentage.

This topic contains these sections:

  • Specifying Threshold

Specifying Threshold

To aggregate smaller slices into an 'Other' slice, you can set PieSeries.OtherThreshold. If PieSeries.IsOtherThresholdPercent is set to true, then OtherThreshold will represent a percentage between 0.0 (0%) and 1.0 (100%). If set to false, then OtherThreshold will represent a numeric value. All values below this threshold will get aggregated into an 'Other' slice.

In this example, all values below 6% are aggregated into an 'Other' slice.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries IsOtherThresholdPercent="true" OtherThreshold="0.6"/>
</charts:PieChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Pie Slice Labels and ToolTips

Labels can be displayed on each pie slice and fully customized. Tooltips are also available for each pie slice.

This topic contains these sections:

  • Customizing Labels
  • Label Position
  • Label Inside Fit Mode
  • Label Appearance
  • Customizing ToolTips

Customizing Labels

Label Format

Pie slice labels by default display percentage only. They can be customized using PieSeries.SliceLabelFormat and PieSeries.ChildSliceLabelFormat. This is a format string with three parameters:

  • {0} - The percentage of the pie slice, between 0.0 (0%) and 1.0 (100%).
  • {1} - The original value of the pie slice.
  • {2} - The title of the pie slice.

In this example, the pie slice label is configured to show all three parameters, with the first parameter displayed in percent formatting. Note a couple things of interest: the :P0 used to format the first parameter as a percent, the opening angle brackets used to escape future angle brackets in the string, and the &#x0a; used to add new lines in XAML.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries SliceLabelFormat="{}{2}
{1} ({0:P0})" AreLabelsVisible="True"/>
</charts:PieChart>

Label Func

In some cases, PieSeries.SliceLabelFormat may be too limited. Some labels may require additional customization that can not be done using standard .NET format strings. In this case, you may provide a custom function that will allow you to fully customize pie slice labels with PieSeries.SliceLabelFunc and PieSeries.ChildSliceLabelFunc. The function must match the signature string MethodName(double, object, string). The label function takes in percentage, original value, and title as parameters, and returns the desired label.

In this example, SliceLabelFunc is bound to a function in the code behind.

C#
Copy
​public MainControl() {
    CustomLabelFunc = GetLabel;
    DataContext = this;
    InitializeComponent();
}

public Func<double, object, string, string> CustomLabelFunc { get; set; }

public static string GetLabel(double percent, object originalValue, string title) {
    string format = "{0}";
    if (percent < 0.1)
        format = "{0} - LOW";

    return string.Format(format, title.ToUpper());
}
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries SliceLabelFunc="{Binding CustomLabelFunc}"/>
</charts:PieChart>

Label Position

By default, labels are displayed on the inside of each pie slice. They can also be displayed on the outside of the chart by setting PieSeries.LabelPosition to PieSliceLabelPosition.Sides. This will place the labels in one of two columns on either side of the pie chart.

Pie slice labels positioned on the insides of the pie slices.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelPosition="Inside"/>
</charts:PieChart>

Pie slice labels positioned on the sides of the pie chart.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelPosition="Sides"/>
</charts:PieChart>

Label Inside Fit Mode

When labels are positioned inside pie slices, they will automatically be hidden if they overlap the pie slice. To disable this, you can set PieSeries.LabelInsideFitMode to PieSliceLabelInsideFitMode.None. This will display all labels regardless of whether or not they fit inside the pie slice.

Labels hidden when they do not fit inside pie slices.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelInsideFitMode="Hide"/>
</charts:PieChart>

Labels always shown, even if they do not fit inside pie slices.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelInsideFitMode="None"/>
</charts:PieChart>

Label Appearance

Label Color

To set the same label color for the entire pie chart, you can simply set PieChart.Foreground. To set different label colors for different pie series, set PieSeries.LabelBrush and PieSeries.ChildLabelBrush.

This example shows a different color set on parent and child pie slice labels.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelPosition="Inside" ChildLabelPosition="Sides"
                      ChildrenPosition="Outside"
                      AreLabelsVisible="True" AreChildLabelsVisible="True"
                      LabelBrush="White" ChildLabelBrush="Black"
                      [...]/>
</charts:PieChart>

Label Style

For more advanced customization, you can set PieSeries.LabelStyle and PieSeries.ChildLabelStyle. The style must have a TargetType of TextBlock.

This example shows a custom style applied to pie slice labels.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries>
        <charts:PieSeries.LabelStyle>
            <Style TargetType="TextBlock">
                <Setter Property="FontSize" Value="20"/>
                <Setter Property="FontStyle" Value="Italic"/>
            </Style>
        </charts:PieSeries.LabelStyle>
    </charts:PieSeries>
</charts:PieChart>

Customizing ToolTips

ToolTip Format

Sometimes you may wish to show pie slice data in a tooltip in addition to, or instead of, a label. Pie slices do not have any tooltips by default, but they can easily be added using the exact same formatting options as labels. If specified, the PieSeries.SliceToolTipFormat and PieSeries.ChildSliceToolTipFormat properties designate that pie slices should have tooltips. Like labels, this is a format string with three parameters:

  • {0} - The percentage of the pie slice, between 0.0 (0%) and 1.0 (100%).
  • {1} - The original value of the pie slice.
  • {2} - The title of the pie slice.

See the "Label Format" section above for an example of how to specify the format string.

ToolTip Func

In some cases, PieSeries.SliceToolTipFormat may be too limited. Some tooltips may require additional customization that can not be done using standard .NET format strings. In this case, you may provide a custom function that will allow you to fully customize pie slice tooltips with PieSeries.SliceToolTipFunc and PieSeries.ChildSliceToolTipFunc. The function must match the signature string MethodName(double, object, string). The tooltip function takes in percentage, original value, and title as parameters, and returns the desired tooltip.

See the "Label Func" section above for an example of how to specify the format string.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Specifying Items

Pie / donut charts can be bound to any custom data source.

This topic contains these sections:

  • Getting Started
  • Setting Value Path
  • Setting Title Path

Getting Started

To set a data source, set the PieSeries.ItemsSource property. This is an IEnumerable of whatever your items are. Each item will represent a pie slice.

Setting Value Path

The value path is a property path that points to a numeric property on the items in your ItemsSource that will be used to determine how large the pie slice is in relation to the other pie slices. You must set SliceValuePath to use pie chart correctly.

As an example, let's say we have an IEnumerable of Person for our PieSeries.ItemsSource.

C#
VB
Copy
​public class Person {
    public string Name { get; set; }
    public double Income { get; set; }
}
​Public Class Person
    Public Property Name() As String
    Public Property Income() As Double
End Class
Our IEnumerable of Person is called People, and we set it as our data source:
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="{Binding People}" SliceValuePath="Income" AreLabelsVisible="True"/>
</charts:PieChart>

Note Note
The value path must point to a property with a numeric type (double, int, decimal, etc) or an exception will be thrown.
Note Note
Negative values will be treated as zero (0).
Setting Title Path

The value path is a property path that points to a property on the items in your ItemsSource that will be used to determine what the title of the pie slice is. The title is, by default, displayed on the pie chart legend, but also can optionally be displayed on the pie chart label.

Using the previous example of Person:

C#
VB
Copy
​public class Person {
    public string Name { get; set; }
    public double Income { get; set; }
}
​Public Class Person
    Public Property Name() As String
    Public Property Income() As Double
End Class
We can set our title as the person's name and use a custom label format to display it:
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="{Binding People}" SliceValuePath="Income" SliceTitlePath="Name" SliceLabelFormat="{}{2} - {0:P0}" AreLabelsVisible="True"/>
</charts:PieChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Charts has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to quickly create your charts and series.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • XYChart Context Menu
  • Task Pane Introduction
  • XYChart Task Pane
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

XYChart Context Menu

A context menu for the XYChart control is provided. You can right click on the control in the designer to display the context menu.

A XYChart context menu in the Visual Studio designer

Use the context menu options to add new series or remove all the series in a chart.

Task Pane Introduction

Whenever you select a XYChart control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

XYChart Task Pane

Use the task pane options to add, remove, or arrange series, configure tha axes, set the baseline, and enable hot tracking.

The XYChart task pane provides quick access for adding, removing, or arranging series. It can also be used to configure the axes, baseline, hot tracking, and style selector.

The task pane for the XYChart control in the Visual Studio designer

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The Microsoft WPF DataGrid can be used to display various data in a grid of rows and columns, with several options available to customize the behavior and appearance. Actipro is giving back to the community by providing two add-ons that make using the WPF DataGrid easier than ever.

A DataGrid using the customized Aero theme provided by Actipro

The Actipro WPF DataGrid Contrib add-on offers the ThemedDataGrid control, which extends the WPF DataGrid control to provide customized Aero and Office (blue, black, and silver) themes. The themes are integrated into the Shared Library's ThemeManager, which allows for dynamic theme changing. The add-on also provides extension methods, attached behaviors, and commands that can be used by ThemedDataGrid or the WPF DataGrid.

The Actipro Editors/DataGrid Interop add-on allows controls from the Actipro Editors for WPF product to be quickly and easily integrated into the WPF DataGrid or ThemedDataGrid. This allows the cells in a DataGrid to leverage parts-based and masked text editors, which make data entry faster and more intuitive.

Features

Microsoft WPF DataGrid Features

  • Auto column generation based on data
  • Several built-in and extensible column types
  • Columns can be easily be rearranged
  • Support for frozen columns that remain fixed when scrolling
  • Data can be sorted programmatically or interactively
  • Inline editing of cells
  • Intuitive keyboard navigation
  • Resizable rows and/or columns
  • Interactively add or delete rows
  • Display rows using alternating colors
  • Support for single or multiple selections
  • Several selection modes including row and cell
  • Support for row details which can display additional info
  • Data validation can be applied at the cell and/or row
  • Fully customizable row and column headers
  • Select all button can be used to select all cells
  • Exposes several properties that can customize the look and feel
  • Supports virtualization of containers both vertically and horizontally
  • and much more...

WPF DataGrid Contrib Add-on Features

  • Includes a routed command that allows a column to be easily frozen and unfrozen.
  • Provides several extension methods for the DataGrid and relating controls.
  • Customize the look and feel of the new row using an attached behavior.
  • Easily track the focus or selection in the column headers (for visual customization) using attached behaviors.
  • Customized system themes which are more visually appealing
  • Adds Office blue/black/silver themes for the DataGrid.
  • Integrates the default Windows system themes and Office themes into the ThemeManager allowing for dynamic theme changing.
  • Custom theme tinting options.
  • Completely open-source and freely available.

Editors/DataGrid Interop Add-on Features

  • Easily integrate the controls offered by the Actipro Actipro Editors for WPF product.
  • Quickly integrate any custom parts-based editors by leveraging reusable components.

Licensing

See the Licensing topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Getting up and running with the WPF DataGrid is extremely easy.

This topic's information will assume you are using Visual Studio to write your XAML code for a WPF Window that will contain one of the DataGrid controls.

This topic contains these sections:

  • Add Assembly References
  • Getting Started with DataGrid
  • Getting Started with Editors/DataGrid Interop
  • Further Study

Add Assembly References

If you would like to leverage the Actipro Contrib or Actipro Editors/DataGrid Interop assemblies, then add references to ActiproSoftware.Shared.Wpf.dll and then ActiproSoftware.DataGrid.Contrib.Wpf.dll and/or ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll, respectively. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Getting Started with DataGrid

This code shows the base XAML that you can use to create a simple ThemedDataGrid:

XAML
Copy
​xmlns:datagrid="http://schemas.actiprosoftware.com/winfx/xaml/datagrid"
...
<datagrid:ThemedDataGrid AutoGenerateColumns="False" ItemsSource="{Binding Source=...}">
    <datagrid:ThemedDataGrid.Columns>
        <DataGridTextColumn Binding="{Binding String}" Header="String" />
        <DataGridCheckBoxColumn Binding="{Binding Boolean}" Header="Boolean" />
        <DataGridHyperlinkColumn Binding="{Binding UriSource}" Header="Boolean" />
        ...
    </datagrid:ThemedDataGrid.Columns>
</datagrid:ThemedDataGrid>

Getting Started with Editors/DataGrid Interop

This code shows the base XAML that you can use to create a simple DataGrid that leverages several Editors' controls:

XAML
Copy
​xmlns:datagrid="http://schemas.actiprosoftware.com/winfx/xaml/datagrid"
xmlns:datagrideditors="http://schemas.actiprosoftware.com/winfx/xaml/datagrideditors"
...
<datagrid:ThemedDataGrid AutoGenerateColumns="False" ItemsSource="{Binding Source=...}">
    <datagrid:ThemedDataGrid.Columns>
        <datagrideditors:DataGridInt32Column Binding="{Binding Integer}" Header="Integer" />
        <datagrideditors:DataGridDateTimeColumn Binding="{Binding DateTime}" Header="DateTime" Format="d" />
        <datagrideditors:DataGridMaskedTextColumn Binding="{Binding String}" Header="String" Mask="\d*" />
        ...
    </datagrid:ThemedDataGrid.Columns>
</datagrid:ThemedDataGrid>

Further Study

It's very easy to use the WPF DataGrid and ThemedDataGrid controls and there are probably a lot of great features that you aren't aware of.

Run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of the controls.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Themes

The WPF DataGrid includes multiple built-in themes and is fully extensible so that other product themes can be custom developed. Acitpro WPF DataGrid Contrib adds the ThemedDataGrid, which supports dynamic theme changing, sharper looking system themes, as well was Office themes.

Note Note
Be sure to read the Actipro Themes product documentation too since that explains in great detail how the themes management works with Actipro controls.

This topic contains these sections:

  • DataGrid Themes
  • ThemedDataGrid Themes
  • Theme Catalog
  • Tinting Themes

DataGrid Themes

The WPF DataGrid includes built-in themes for Aero, Luna blue/olive/silver, classic, and royale.

The DataGrid control in its Aero, Luna (Homestead), Luna (Silver), and Classic themes

ThemedDataGrid Themes

Acitpro WPF DataGrid Contrib includes the ThemedDataGrid control, which has customized system themes that look more professional out of the box.

The ThemedDataGrid control in its Aero, Luna (Homestead), Royale, and Classic themes

Addtionally, the Acitpro WPF DataGrid Contrib adds additional themes for the Office color schemes for the ThemedDataGrid control.

The ThemedDataGrid control in its Office theme

Theme Catalog

The DataGridThemeCatalog is used to provide dynamic theme-switching to this product, and is automatically registered when WPF loads the system themes from the associated assembly.

To explicitly load and register the theme catalog, call the Register staic method on DataGridThemeCatalogRegistrar.

Tinting Themes

Any theme can be completely or partially tinted towards a color or set of colors. The general Tinting topic explains how to perform tinting in detail.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Attached Behaviors

The Acitpro WPF DataGrid Contrib assembly includes attached behaviors, which are described in this topic.

This topic contains these sections:

  • FocusBehavior
  • NewRowTemplateBehavior
  • SelectionBehavior

Note Note
The attached behaviors described in this topic can be applied to the WPF DataGrid or the ThemedDataGrid .

FocusBehavior

This class provides attached behavior for DataGrid controls to track the focus, which is configured by setting the FocusBehavior.TrackingModesProperty attached property to one or more values from the FocusTrackingModes enumeration.

Column Header

When FocusBehavior.TrackingModesProperty includes the Headers enumeration flag, then the read-only FocusBehavior.IsFocusedHeaderProperty attached property will be tracked/maintained. This allows one or more triggers to alter the look of the column headers when one of the associated cells has focus.

NewRowTemplateBehavior

This class provides attached behavior for controls to customize the new row template. The NewRowTemplateBehavior.TemplateProperty attached property can be set to a custom ControlTemplate to use when the new row is not currently editing.

By default, the new row looks identical to actual data rows, but with empty cells. Using NewRowTemplateBehavior, a more appealling look can easily be achieved.

The DataGrid control with default (top) and custom (bottom) looks of the new row

SelectionBehavior

This class provides attached behavior for DataGrid controls to track the selection, which is configured by setting the SelectionBehavior.TrackingModesProperty attached property to one or more values from the SelectionTrackingModes enumeration.

Column Header

When SelectionBehavior.TrackingModesProperty includes the Headers enumeration flag, then the read-only SelectionBehavior.IsSelectedHeaderProperty attached property will be tracked/maintained. This allows one or more triggers to alter the look of the column headers when one or more of the associated cells is selected.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Commands

The Acitpro WPF DataGrid Contrib assembly includes routed commands defined in the DataGridCommands static class, which are described in this topic.

This topic contains these sections:

  • ToggleFrozenColumn Command

Note Note
The commands described in this topic can be applied to the WPF DataGrid or the ThemedDataGrid .
ToggleFrozenColumn Command

This command can be used to toggle the frozen state of a column. The CommandParameter should be set to the DataGridColumnHeader associated with the column that should be frozen/unfrozen.

Frozen columns must appear before any non-frozen columns. Therefore, this command will move any columns that are being frozen before any non-frozen columns. Likewise, it will move any columns that are being unfrozen after any frozen columns.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Extension Methods

The Acitpro WPF DataGrid Contrib assembly includes extension methods defined in the DataGridExtensions static class, which are described in this topic.

This topic contains these sections:

  • DataGrid

Note Note
The extension methods described in this topic can be applied to the WPF DataGrid or the ThemedDataGrid .
DataGrid

The following extension methods are provided for the DataGrid type:

Method | Description
GetRow | There are two overloads for this method, each of which returns a DataGridRow. One overload takes the index of the row to return. The second overload returns the row associated with a specified item.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Editors

The controls provided by the Editors product can be easily integrated into Microsoft's WPF DataGrid, through the use of custom DataGridColumn objects. An Interop assembly is provided that ties the two products together.

DataGrid with Editors integrated using the Interop assembly

See the Interoperability topic under Actipro Editors for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Licensing

This topic convers the licensing of the WPF DataGrid, the Actipro WPF DataGrid Contrib, and the Actipro Editors/DataGrid Interop.

This topic contains these sections:

  • WPF DataGrid
  • Actipro WPF DataGrid Contrib
  • Actipro Editors/DataGrid Interop

WPF DataGrid

The WPF DataGrid, created by Microsoft, is included in the WPF framework.

Actipro WPF DataGrid Contrib

Actipro WPF DataGrid Contrib is provided by Actipro and is available on CodePlex. This project is also released under the Microsoft Public License (Ms-PL) (external).

Actipro Editors/DataGrid Interop

Actipro Editors/DataGrid Interop is available for use by any developer who owns a license to the Actipro Editors for WPF product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

This topic contains troubleshooting data specific to the WPF DataGrid.

Note Note
For some more troubleshooting information that relates both to this product as well as the WPF Studio products, please see the more general TroubleShooting topic.

This topic contains these sections:

  • Where to get help?
  • Visual Studio is reporting several binding errors

Where to get help?

The discussion forum on CodePlex (external) is the best place to get general help relating to the WPF DataGrid. For issues relating to the Actipro WPF DataGrid Contrib or Actipro Editors/DataGrid Interop products, see our Support topic about contacting Actipro.

Visual Studio is reporting several binding errors

When CanUserAddRows is set to true, Visual Studio will report several binding errors because the DataGrid uses CollectionView.NewItemPlaceholder as the data item for the new row. When the columns use binding, CollectionView.NewItemPlaceholder doesn't have any of the associated properties. This results in the binding errors. This is a known issue and is working as designed.

For more more information please see this forum discussion (external) on CodePlex.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to 2011.2 topic contains information on converting to 2011.2 from an older version.
  • The Converting to 2012.1 topic contains information on converting to 2012.1 from 2011.2.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Theming Architectural and Style Changes
  • Consolidated Glyphs

Theming Architectural and Style Changes

See unified conversion topic for details on breaking changes made to the theming architecture, which affects control styles and related dictionaries.

Consolidated Glyphs

Previously, two glyphs were included in the DataGrid assembly for freezing and unfreezing (i.e. pinning and unpinning) columns. As these glyphs are used by other products, they have been consolidated into the Shared Library.

The glyphs were previously referenced using two ComponentResourceKey properites defined on DataGridCommonDictionary, specificaly DataGridCommonDictionary.PinnedGlyphKey and DataGridCommonDictionary.UnpinnedGlyphKey. The glphs can still be referenced in the same manner but their keys have been moved to SharedResourceKeys.UnpinGlyphTemplateKey and SharedResourceKeys.PinGlyphTemplateKey, respectively.

Upgrade Instructions Upgrade Instructions
  1. All references to DataGridCommonDictionary.PinnedGlyphKey must be replaced with SharedResourceKeys.UnpinGlyphTemplateKey.
  2. All references to DataGridCommonDictionary.UnpinnedGlyphKey must be replaced with SharedResourceKeys.PinGlyphTemplateKey.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2012.1

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • DataGrid Add-on Updated to Use .NET 4.0

DataGrid Add-on Updated to Use .NET 4.0

The DataGrid add-on has been updated to reference the native .NET 4.0 version instead of the one from the WPF Toolkit.

Upgrade Instructions Upgrade Instructions
Convert to using the native .NET 4.0 DataGrid instead of the WPF Toolkit one.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Docking & MDI is a complete solution for easily adding a docking tool window and/or multiple document interface to your applications.

Docking windows and tabbed MDI provided by this product

Docking & MDI has been implemented with flexibility in mind. It has more options than nearly any other competitive product out there, including enhanced MVVM support. While it supports all the types of standard layouts you find in most docking window products, it also supports some extended functionality such as: floating document areas, nested dock sites (a self-contained set of docking windows within another docking window), side-by-side dock sites (two or more self-contained sets of docking windows next to each other), linked dock sites (two or more self-contained sets of docking windows whose windows can be moved to either site), tool window inner fill (no workspace area), tabbed and standard MDI styles, custom workspace content, total control over docking window capabilities and appearance, fluid animations, and much more.

Features

MVVM Features

  • Bind to separate document and tool view-model collections.
  • Bind to VM properties to open, close, activate, and change the state of docking windows.
  • Fully customizable styles and data templates for both document and tool windows.
  • Can be optionally used in conjunction with non-MVVM defined document and tool windows.

Docking Window Features

  • Document windows that remain in MDI but can be floated.
  • Tool windows that can be docked, auto-hidden, floated, or moved into MDI.
  • Auto-hidden tool windows show as tabs along the outer edge of a dock host and show a popup when clicked.
  • Create nested hierarchies of tool windows within a dock site or in a separate floating windows.
  • Resize any control via the use of built-in splitters.
  • Rich object model for opening, closing, and repositioning docking windows anywhere in a layout.
  • Tons of global options for controlling everything from whether windows can drag to whether tool windows have options buttons.
  • Window-specific instance overrides for nearly all global options.
  • Multiple ways to designate preferences for initial dock location when a docking window is opened.
  • Ability to customize all context and drop-down menus.
  • Multiple Ctrl+Tab switcher types, including one with a Visual Studio-like interface.
  • Dock guides that make selecting document and tool window drop target locations easier.
  • Drag to reorder windows within a tab group.
  • Dragging floating windows can snap next to other floating windows using magnetism features. Also works for documents in standard MDI mode.
  • Numerous centralized docking window-related events.

Appearance Features

  • Built-in Metro, Office, and Windows system themes.
  • Subtle fluid animations that occur throughout use of the product.
  • Ability to create hosted floating windows that can fade out with inactivity.
  • Create tool windows that don't have a title bar and/or cannot be moved.
  • Easily integrates with Actipro Ribbon to make a unique user interface.
  • An implementation of a control that mimics a standard Window but can be used in any control context.
  • Specify custom contextual content (status indicators, buttons, etc.) within tabs or title bars.
  • Tint specific docking window tabs.
  • Built-in tab flashing capabilities to grab attention.

Workspace and MDI Features

  • Ability to host any sort of custom content in a workspace area.
  • Tabbed MDI support that is capable of multi-directional hierarchies of documents.
  • Tabbed MDI options like tab images and tab placement on any side.
  • Document tabs can be rendered as pinned, normal, or preview tabs.
  • Optional new tab button in the tab well.
  • Built-in read-only document glyph display.
  • Standard MDI that supports a windowed approach to managing documents.
  • Cascade, tile horizontally, and tile vertically documents.

Layout, Globalization, and Accessibility Features

  • Full support for nested and side-by-side dock sites.
  • Dock sites can be linked, which allows windows to be dragged from one dock site to another.
  • Tool window inner-fill mode supported.
  • Complete tool window layout save/load capabilities, for persisting end user customizations.
  • Layout logic does its best to adhere to optional specified desired, minimum, and maximum container sizes.
  • Size-to-content support for floating windows and standard MDI documents when displayed.
  • Use any pointer such as mouse, touch, or pen to interact with docking windows.
  • Support for interop content such as WinForms or ActiveX controls.
  • AdvancedTabControl control included that extends the standard TabControl with powerful capabilities.
  • Right-to-left support is fully integrated for languages such as Hebrew or Arabic.
  • All text properties use localization attributes, and string resources may be customized.
  • Follows the standard accessibility model for UI automation.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Getting up and running with Docking & MDI controls is extremely easy.

This topic's information will assume you are using Visual Studio to write your XAML code for control that will contain docking windows and/or MDI.

This topic contains these sections:

  • Add Assembly References
  • Getting Started with Docking & MDI
  • The Visual Studio Item Templates
  • Further Study

Add Assembly References

First, add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.Docking.Wpf.dll assemblies. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Getting Started with Docking & MDI

This 'xmlns' declaration in your root XAML control allows access to the various controls in this product:

XAML
Copy
​xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"

This code shows the base XAML that you can use to create a simple docking window layout with several windows:

XAML
Copy
​<docking:DockSite>
    <docking:SplitContainer>
        <docking:Workspace>
            <docking:TabbedMdiHost>
                <docking:TabbedMdiContainer>
                    <docking:DocumentWindow Title="Document1.txt" Description="Text document" FileName="Document1.rtf">
                        <TextBox BorderThickness="0" TextWrapping="Wrap" Text="This is a document window." />
                    </docking:DocumentWindow>
                </docking:TabbedMdiContainer>
            </docking:TabbedMdiHost>
        </docking:Workspace>
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 1" />
            <docking:ToolWindow Title="Tool Window 2" />
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>

This code shows the base XAML that you can use to create a simple docking window layout that leverages MVVM support:

XAML
Copy
​<docking:DockSite DocumentItemsSource="{Binding DocumentItems}" DocumentItemContainerStyle="..."
            ToolItemsSource="{Binding ToolItems}" ToolItemContainerStyle="...">
    <docking:Workspace>
        <docking:TabbedMdiHost />
    </docking:Workspace>
</docking:DockSite>
Several ways of opening the windows are shown in the MVVM examples found in our Sample Browser.

The Visual Studio Item Templates

If you have Visual Studio, several item templates named Docking & Standard MDI Window (WPF), Docking & Standard MDI Page (WPF), Docking & Tabbed MDI Window (WPF), Docking & Tabbed MDI Page (WPF), Docking Inner Fill Window (WPF), and Docking Inner Fill Page (WPF) should have been installed during the WPF Studio installation procedure.

When you wish to create a new Window or Page (for use in XBAP) with a tabbed MDI, standard MDI, or inner fill in your application, simply choose Add New Item in Visual Studio and select the appropriate item template. A DockSite with several tool and documents already defined will be added to your project and opened.

The use of item templates is the fastest way to get started with our products in your own applications.

Further Study

There are fair number of controls and concepts to understand when working with this product. We encourage you to at a minimum, read through the Term Definitions and Control Hierarchy topics since they cover some essential things to know.

Also, please run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of the controls.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Term Definitions

There are some key terms and concepts to understand when working with this product. This topic defines all of the docking-related terms.

This topic contains these sections:

  • General Terms
  • Lifecycle Terms
  • State Terms
  • Container Terms

General Terms

Term | Description
Docking Window | A docking window (represented by the DockingWindow class) is a general term that could mean either a tool window or a document window, since both of those inherit the base docking window functionality.
Dock Site | A dock site (represented by the DockSite class) is the root control that contains a tool window hierarchy and/or MDI, and provides management functionality for all contained docking-related controls.
Document | A document is a docking window (either a document window or tool window) that is within the MDI area.
Document Window

A document window (represented by the DocumentWindow class) is a docking window that is restricted to only be used within a MDI area.

By default it is destroyed after it is closed, however this behavior can be changed.

Floating | Floating is where you have a floating dock host that contains one or more tool windows or a secondary MDI area, and is able to be moved anywhere above the dock site's control hierarchy.
MDI

MDI stands for Multiple Document Interface, meaning the method with which documents can be visually interacted by the end user.

The two built-in types of MDI are Tabbed MDI and Standard MDI.

MVVM

MVVM stands for Model View ViewModel and is a design pattern used to build applications where the logic is separated from the user interface, testability is increased, as well as other benefits.

Nested Dock Sites

Nested dock sites is when you have one DockSite that is contained within a docking window that belongs to a parent DockSite.

In this scenario, the docking windows may only be moved within their respective owner dock sites.

Standard MDI | Standard MDI (implemented via the StandardMdiHost class and its children) is the windowed variation of MDI, where each document is represented by a window that can be moved around within the workspace. Windows can be cascaded or tiled.
Tabbed MDI | Tabbed MDI (implemented via the TabbedMdiHost class and its children) is where the full size of the workspace is filled with one or more tabbed containers, with each tab representing a document. Windows can be cascaded or tiled.
Tool Window

A tool window (represented by the ToolWindow class) is a docking window that can be used in a number of states, including within the MDI area.

Tool windows usually continue to exist after being closed and can be reactivated later.

Tool Window Inner-Fill | Tool window inner-fill occurs when there is no Workspace within a DockSite, and the dock site hierarchy consists only of tool windows that fill its content area.
Workspace

A workspace (represented by the Workspace class) is the area around which tool windows may be docked.

If the workspace's content is a TabbedMdiHost, then tabbed MDI is in use. If the workspace's content is a StandardMdiHost, then standard MDI is in use. The workspace's content can be set to anything else when MDI is not needed and custom content should be displayed.

By not including a workspace within a DockSite hierarchy, tool window inner-fill mode is activated.

Lifecycle Terms

Term | Description
Activate | Ensure that a docking window is open, its contents are visible, and optionally allows focus to be set. If the activated window is represented by a tab, it will become the selected tab in the parent container.
Close | Remove a docking window from the dock site hierarchy so that it is no longer accessible.
Closed | When a docking window is not currently accessible in the dock site hierarchy.
Open | Ensure that a docking window is accessible in the dock site hierarchy, although its contents may not necessarily be visible such as when it is represented by an unselected tab.
Opened | When a docking window is currently accessible in the dock site hierarchy, although its related tab may or may not currently be selected. In the latter case, clicking the tab ensures the window's contents are visible.
Selected | When a docking window is opened and represented by a tab that is currently selected.

State Terms

Term | Description
Auto-Hide | When a tool window's tab appears along the outer edge of a dock host. Clicking the tab makes the tool window's content slide into view. Tool windows that are auto-hidden within a floating dock host are still considered to be in an auto-hide state. This state only applies tool windows.
Docked | When a tool window is docked somewhere within a dock host hierarchy, but not in MDI. Tool windows that are docked within a floating dock host are still considered to be in a docked state. This state only applies tool windows.
Document | When a docking window is within the MDI area. Docking windows that are in the MDI area of a floating dock host are still considered to be in a document state. This state applies to both tool and document windows.

Container Terms

Term | Description
Dock Host | A dock host (represented by the DockHost class) is the actual root hierarchy container. A primary dock host is implicitly created within a dock site, while other dock hosts are created behind-the-scenes whenever docking windows are floated. Dock hosts should never be explicitly created by you.
Split Container | A split container (represented by the SplitContainer class) is used to hold one or more other docking containers and provide splitter-based resizing capabilities between them. Split containers can be oriented horizontally or vertically.
Standard MDI Host | A standard MDI host (represented by the StandardMdiHost class) is the root container for standard MDI implementation, that is placed as the direct child of a workspace.
Tabbed MDI Container | A tabbed MDI container (represented by the TabbedMdiContainer class) is the direct parent of one or more docking windows that are in tabbed MDI.
Tabbed MDI Host | A tabbed MDI host (represented by the TabbedMdiHost class) is the root container for tabbed MDI implementation, that is placed as the direct child of a workspace.
Tool Window Container

A tool window container (represented by the ToolWindowContainer class) is the direct parent of one or more tool windows that are docked or auto-hidden.

This container provides a title area displaying the selected tool window's title. When more than one tool windows are included, it also contains tabs for selecting the other tool windows.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Control Hierarchy

Since a number of controls are involved in creating a docking window and MDI hierarchy, this topic delves into what can be contained by what in your XAML.

Note Note
When creating a layout programmatically (not in XAML), refer to some of the other topics in this documentation.

This topic contains these sections:

  • DockSite Hierarchy
  • Tabbed MDI Hierarchy
  • Standard MDI Hierarchy

DockSite Hierarchy

The DockSite is always the root control in a docking window and/or MDI hierarchy. It implicitly creates a primary DockHost within its template. The DockSite has a single child control that becomes the child control of the primary DockHost in the template.

A DockSite hierarchy diagram

Child Content

The DockSite.Child can be one of the following:

  • SplitContainer
  • ToolWindowContainer
  • Workspace

Each SplitContainer has an Orientation property that indicates whether the splits are horizontal or vertical. SplitContainer objects can be nested to create complex hierarchies. SplitContainer children can be one of the following:

  • SplitContainer
  • ToolWindowContainer
  • Workspace

ToolWindowContainer controls contain one or more ToolWindow controls and provide a title bar and tabs for selecting between tool windows.

Workspace defines the area around which tool window can be docked. If no Workspace is included within the hierarchy, tool window inner-fill mode is activated. A Workspace control has a single child. If the Workspace .Content is a TabbedMdiHost, tabbed MDI is activated. If the Workspace .Content is a StandardMdiHost, standard MDI is activated.

This example shows two attached tool windows docked on the right side of a workspace with empty tabbed MDI:

XAML
Copy
​xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
...

<docking:DockSite>
    <docking:SplitContainer>
        <docking:Workspace>
            <docking:TabbedMdiHost />
        </docking:Workspace>

        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 1" />
            <docking:ToolWindow Title="Tool Window 2" />
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>

Auto-Hide Configuration

To add tool windows into an auto-hide state, use the four auto-hide properties:

  • DockSite.AutoHideLeftContainers
  • DockSite.AutoHideTopContainers
  • DockSite.AutoHideRightContainers
  • DockSite.AutoHideBottomContainers
Each of those accepts one or more ToolWindowContainer controls, each of which can contain one or more ToolWindow controls.

This example shows two tool windows docked vertically on the right side of a workspace with empty tabbed MDI, and an auto-hidden tool window on the left:

XAML
Copy
​xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
...

<docking:DockSite>
    <docking:DockSite.AutoHideLeftContainers>
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 3" />
        </docking:ToolWindowContainer>
    </docking:DockSite.AutoHideLeftContainers>

    <docking:SplitContainer>
        <docking:Workspace>
            <docking:TabbedMdiHost />
        </docking:Workspace>

        <docking:SplitContainer Orientation="Vertical">
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="Tool Window 1" />
            </docking:ToolWindowContainer>
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="Tool Window 2" />
            </docking:ToolWindowContainer>
        </docking:SplitContainer>
    </docking:SplitContainer>
</docking:DockSite>

Tabbed MDI Hierarchy

When the Workspace .Content is a TabbedMdiHost, tabbed MDI mode is activated. Tabbed MDI is where the full size of the workspace is filled with one or more tabbed containers, with each tab representing a document. Windows can be cascaded or tiled.

A tabbed MDI hierarchy diagram

The TabbedMdiHost control has a single child, which can be one of the following:

  • SplitContainer
  • TabbedMdiContainer

Each SplitContainer has an Orientation property that indicates whether the splits are horizontal or vertical. SplitContainer objects can be nested to create complex hierarchies. SplitContainer children can be one of the following:

  • SplitContainer
  • TabbedMdiContainer

TabbedMdiContainer controls contain one or more ToolWindow and/or DocumentWindow controls and provide tabs for selecting between the documents.

This example shows a single document open in tabbed MDI:

XAML
Copy
​xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
...

<docking:DockSite>
    <docking:Workspace>
        <docking:TabbedMdiHost>
            <docking:TabbedMdiContainer>
                <docking:DocumentWindow Title="Document1.txt" Description="Text document" FileName="Document1.rtf">
                    <TextBox BorderThickness="0" TextWrapping="Wrap" Text="This is a document window." />
                </docking:DocumentWindow>
            </docking:TabbedMdiContainer>
        </docking:TabbedMdiHost>
    </docking:Workspace>
</docking:DockSite>

Standard MDI Hierarchy

When the Workspace .Content is a StandardMdiHost, standard MDI mode is activated. Standard MDI is the windowed variation of MDI, where each document is represented by a window that can be moved around within the workspace. Windows can be cascaded or tiled.

A standard MDI hierarchy diagram

The StandardMdiHost control contains one or more ToolWindow and/or DocumentWindow controls. It renders each document as a window.

This example shows a single document open in standard MDI:

XAML
Copy
​xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
...

<docking:DockSite>
    <docking:Workspace>
        <docking:StandardMdiHost>
            <docking:DocumentWindow Title="Document1.txt" Description="Text document" FileName="Document1.rtf">
                <TextBox BorderThickness="0" TextWrapping="Wrap" Text="This is a document window." />
            </docking:DocumentWindow>
        </docking:StandardMdiHost>
    </docking:Workspace>
</docking:DockSite>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

There are an enormous feature set in Actipro Docking & MDI related to docking windows.

Docking Window States

There are three states in which docking windows can be: auto-hide, docked, and document. Docking windows can be in these states even when they are in a floating dock host.

See the Docking Window States topic for more information.

Lifecycle and Docking Management

The lifecycle of a docking window includes its creation, specifying initial size and/or size restrictions, providing a default open location, opening, moving to various states, docking to various locations, closing, and destruction. This topic covers how to perform all of those operations.

See the Lifecycle and Docking Management topic for more information.

Docking Window Capabilities

One of the best features of Actipro Docking & MDI is the number of options that are available to you as a developer. Many options control the behaviors and capabilities of the docking windows and can be set at a global level as well as at a docking window instance level.

See the Docking Window Capabilities topic for more information.

Docking Window Events

There are a number of events to which you can attach to know when various actions occur to docking windows.

See the Docking Window Events topic for more information.

Docked Tool Windows

Tool windows in docked state appear docked in containers around an optional workspace within their dock host. When two or more tool windows are in the same container, tabs allow for selecting which one is visible.

See the Docked Tool Windows topic for more information.

Auto-Hidden Tool Windows

Tool windows in auto-hide state show tabs along a tray area on the side of their dock host. When a tab is clicked, the related tool window's content is displayed in an animated popup.

See the Auto-Hidden Tool Windows topic for more information.

Floating Dock Hosts

Docking windows can be dragged to float, meaning appear in a floating dock host that can move independently above the dock site's primary dock host.

See the Floating Dock Hosts topic for more information.

Contextual Content

Contextual content, such as buttons or status indicators, can be displayed throughout the docking window UI within tabs and title bars.

See the Contextual Content topic for more information.

Fixed Tool Windows

By turning off various options on a specific tool window, you can completely prevent it from being moved and can keep it "fixed" within a tool window layout, while still allowing other tool windows to be docked around it.

See the Fixed Tool Windows topic for more information.

Menu Customization

All context menus displayed by this product can be customized or replaced entirely before they are shown to the end user.

See the Menu Customization topic for more information.

Switchers

Switchers are used during Ctrl+Tab, etc. key presses to easily navigate between open documents and tool windows.

See the Switchers topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Docking Window States

There are three states in which docking windows can be: auto-hide, docked, and document. Docking windows can be in these states even when they are in a floating dock host. These states are represented by the DockingWindowState enumeration.

Document windows can only be in the Document state, while tool windows are more flexible and can be in any of the three states.

Note Note
See the Floating Dock Hosts topic for an explanation of why there is no specific floating state.

This topic contains these sections:

  • The AutoHide State
  • The Docked State
  • The Document State
  • State Changes

The AutoHide State

A tool window is in auto-hide state when its tab appears along one of four outer edges of a dock host. Clicking the tab makes the tool window's content slide into view using a quick animation. The content remains visible while it has focus. When the focus leaves the content area or when the tab is clicked again, the tool window slides back out of view, while its tab remains visible.

The Solution Explorer tool window in AutoHide state with its popup displayed

The AutoHide state is only available to tool windows. Auto-hide is always supported in the primary dock host, and is only supported in floating dock hosts that have a workspace visible.

The Docked State

A tool window is considered Docked when it is within a dock host hierarchy but not in auto-hide and not in MDI (the document area).

The Solution Explorer tool window in Docked state

The Docked state is only available to tool windows. Tool windows that are dragged to float are considered in a Docked state in their containing floating dock host.

The Document State

A docking window is in Document state when it is within the MDI area. It could be a tab in tabbed MDI or a window in standard MDI.

The Solution Explorer tool window in Document state (tabbed MDI)

The Solution Explorer tool window in Document state (standard MDI)

The Document state is available to both tool and document windows. Documents that are dragged to float will create a MDI host in their containing floating dock host.

State Changes

The DockingWindow.State property can be set to alter where the docking window is located. Note that setting the state will not automatically open the docking window if it currently closed. It is designed this way so that the state can be set and other properties configured prior to the open occuring, which can be done by setting the IsOpen property to true, setting the IsActive property to true, calling the Open method, or calling the Activate method.

The DockSite.WindowsStateChanged event can be used to detect changes to the DockingWindow.State property of the various registered windows. This event may fire once for a group of docking windows that change state together, with the event arguments containing the list of affected docking windows.

Alternatively, the DockingWindow.OnStateChanged virtual method can be overridden by custom window classes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lifecycle and Docking Management

The lifecycle of a docking window includes its creation, specifying initial size and/or size restrictions, providing a default open location, opening, moving to various states, docking to various locations, closing, and destruction. This topic covers how to perform all of those operations.

This topic contains these sections:

  • Tool Windows vs. Document Windows
  • Creation and Destruction
  • Preventing Document Windows from Auto-Destroying on Close
  • Opening and Closing
  • Activating and Focusing
  • Default Initial Size
  • Minimum and Maximum Size
  • Default Locations
  • Programmatically Changing States and Docking
  • Determining the Location of a Tool Window in Relation to the Workspace
  • Programmatically Starting a Drag
  • Splitter Drag Kinds

Tool Windows vs. Document Windows

Tool and document windows are the two varieties of docking windows that exist in the Docking/MDI product. While they both share many capabilities, they have several functional differences and you should choose to use the appropriate kind based on your UI needs.

Tool windows are capable of being docked outside of MDI, auto-hidden to the side of a dock host, or used in the MDI area. They have no out-of-the-box restrictions on where they can go. Tool windows are typically used for scenarios where the docking window needs to support all those state locations, or needs to frequently be closed and reopened. They remain registered with the dock site after they are closed, and thus can be readily reopened into the layout in their previous locations.

Document windows on the other hand can only be used within the MDI area. Since document windows are intended to have a limited lifetime, they are destroyed (unregistered from the dock site) by default when they are closed. See a section below for information on altering this behavior. Document windows are typically used for scenarios where the docking window is no longer needed after it is closed.

Creation and Destruction

When a DockingWindow has been associated with a DockSite, it is considered created. Note that at this time it may not yet be opened (accessible in the user interface).

After a docking window ceases to be managed by a DockSite, it is considered destroyed.

While being tracked by a DockSite, tool windows will be contained in its ToolWindows collection and document windows will be contained in its DocumentWindows collection.

Creating Tool Window

Use this code to create a tool window. Always use a constructor that accepts a DockSite parameter since this associates the tool window with that DockSite.

C#
VB
Copy
​TextBox tb = new TextBox();
tb.BorderThickness = new Thickness(0);
ToolWindow window = new ToolWindow(dockSite, "MyToolWindow1", "My First Tool Window",
    new BitmapImage(new Uri("/Resources/Images/Properties16.png", UriKind.Relative)), tb);
​Dim tb As TextBox = New TextBox()
tb.BorderThickness = new Thickness(0)
Dim window As ToolWindow = New ToolWindow(dockSite, "MyToolWindow1", "My First Tool Window", _
    New BitmapImage(New Uri("/Resources/Images/Properties16.png", UriKind.Relative)), tb)

When using the constructor in the example above, the first parameter is the DockSite that will manage the window.

The second is the value to be assigned to the Name property.

Note Note
A unique Name or SerializationId must be assigned to each tool window if layout serialization will be used in your application. The Name property must be a valid C#/VB identifier (underscore, letter, and number characters only), while the SerializationId is more flexible and can consist of any characters.

The third and fourth parameters are the title text and ImageSource respectively that will be displayed in the UI for the tool window.

The final parameter is the content that will be placed in the tool window.

Creating Document Windows

Use this code to create a document window. Always use a constructor that accepts a DockSite parameter since this associates the document window with that DockSite.

C#
VB
Copy
​TextBox tb = new TextBox();
tb.BorderThickness = new Thickness(0);
DocumentWindow window = new DocumentWindow(dockSite, "MyDocumentWindow1", "My First Document Window",
    new BitmapImage(new Uri("/Resources/Images/TextDocument16.png", UriKind.Relative)), tb);
​Dim tb As TextBox = New TextBox()
tb.BorderThickness = new Thickness(0)
Dim window As DocumentWindow = New DocumentWindow(dockSite, "MyDocumentWindow1", "My First Document Window", _
    New BitmapImage(New Uri("/Resources/Images/TextDocument16.png", UriKind.Relative)), tb)

The same notes above regarding constructor parameters apply to document windows as well with one exception. Since document windows are not normally serialized with a layout, the Name parameter is not important to pass and may be null.

Destroying Docking Windows

Both tool and document windows may be destroyed by calling the DockingWindow.Destroy method.

This closes them out of the UI (if currently open) and removes them from their managing DockSite.

Note Note
By default, document windows auto-destroy themselves when closed. See the following section for more information.

Preventing Document Windows from Auto-Destroying on Close

By default, document windows are only alive while open and will destroy themselves after being closed. This is the default because normally once a document is closed, it is no longer needed unless the the end user specifically chooses to open it again, which may or may not ever occur.

You can alter this behavior by changing the DockSite.AreDocumentWindowsDestroyedOnClose property to false. When false, document windows will continue to be associated with the DockSite and will remain within its DocumentWindows collection, allowing them to be retrived for later reopening.

Opening and Closing

When open, a docking window is accessible in the user interface. When closed, it is not.

Note Note
It is very important to NOT set the DockingWindow.Visibility property yourself. The docking framework itself will manage user interface visibility based on whether a docking window is currently open or not.

Opening Docking Windows

Docking windows aren't added to the user interface until specifically opened. A call to the DockingWindow.Open method will restore the docking window to its previous state and location, if known. If the docking window doesn't have a prior location breadcrumb available, it will restore to a default location based on its property settings.

Setting the IsOpen property to true is the same as calling the parameterless Open method. This property can be bound to in MVVM scenarios.

Closing Docking Windows

Docking windows can be removed from the user interface by a call to their DockingWindow.Close method.

Setting the IsOpen property to false is the same as calling the Close method. This property can be bound to in MVVM scenarios.

When closed, tool windows remain in the DockSite.ToolWindows collection until destroyed. However when document windows are closed, by default they will be destroyed as well unless the DockSite.AreDocumentWindowsDestroyedOnClose property is set to false.

Activating and Focusing

Activating is a superset of the Open functionality. When the DockingWindow.Activate method is called, if the docking window is currently closed, it will be opened. Additionally if it is open but in a tabbed scenario where it is not the selected tab, its tab will be selected.

The Activate method also has an overload for whether to set focus to the docking window's content.

Setting the IsActive property to true is the same as calling the parameterless Activate method. This property can be bound to in MVVM scenarios.

The LastActiveDateTime property is updated every time the docking window is activated, either programmatically or by focus moving within it. Sorting docking windows by this property value allows you to determine the sequence in which the docking windows were last active.

The DockSite.ActiveWindow tracks the currently active window. This property changes whenever a different docking window gains focus, and the the DockSite.WindowActivated event fires in response.

Default Initial Size

Docking windows default to a desired initial size of 200,200. Sometimes you may wish to set a different default initial size for docking windows. This can be done by using the DockingWindow.ContainerDockedSize property.

This example shows the property being set that will request that the ToolWindow have an initial size of 300, 150:

XAML
Copy
​... <docking:ToolWindow Title="Wide" ContainerDockedSize="300,150"> ...

Important Note Important Note
Since the docking elements need to dynamically change their size based on their location and available space, the Width, Height, MinWidth, MinHeight, MaxWidth, and MaxHeight properties should NEVER be used.

Minimum and Maximum Size

Docking windows default to a minimum size of 30,30 and a maximum size of positive infinity. Sometimes you may wish to designate some restrictions on size, such as a tool window's container should always try to be a minimum of 180 high. This can be done by using the DockingWindow.ContainerMinSize and ContainerMaxSize properties.

This example shows how to request a minimum container height of 180:

XAML
Copy
​... <docking:ToolWindow Title="Min Height" ContainerMinSize="30,180"> ...

By setting the minimum size to the same thing as the maximum height, you can achieve a fixed size. This example shows how to request a fixed container height of 180:

XAML
Copy
​... <docking:ToolWindow Title="Fixed Height" ContainerMinSize="30,180" ContainerMaxSize="10000,180"> ...

Important Note Important Note
Since the docking elements need to dynamically change their size based on their location and available space, the Width, Height, MinWidth, MinHeight, MaxWidth, and MaxHeight properties should NEVER be used.

Default Locations

When a docking window is opened via calling its DockingWindow.Open method or by setting the IsOpen property to true, it will first attempt to restore to a previous location where a related breadcrumb was left. If no breadcrumb is found, it will restore to a default location instead.

This is how a default location is determined:

  • First, if a WindowGroupName value is specified, the docking window will try to find another open docking window that has the same window group name.
  • Second, the DockingWindow.DefaultLocationRequested event fires with the DockingWindowDefaultLocationEventArgs.Target property initialized to the docking window found in the same window group, if any.
  • Third, the DockSite.WindowDefaultLocationRequested event fires with the same event arguments.
  • Both of these events allow you to programmatically indicate the window should float (and optionally a specific floating location), or alternatively customize where the default location for the window will be. You can indicate a dock target and optional side around which it should dock. Passing null as the side will trigger an attach.
  • If a dock target isn't set by an event handler, the docking window will fall back to opening in a default side specified by the ToolWindow.DefaultDockSide property. If an existing root level container is found at that side, the docking window will attach to that container.

Programmatically Changing States and Docking

It's very easy to move document and tool windows to anywhere in the layout programmatically.

State Change and Docking Members

The DockingWindow class has a number of methods that make it easy to programmatically move a docking window to another state.

Member Description
Float Method

Moves the tool or document window into a floating dock host.

One overload of this method restores the docking window back to its default floating bounds, and others let you optionally specify location and size.

Note Note
If you wish for the docking window to auto-size itself to its content when floated, update the DockingWindow.SizeToContentModes property to contain the SizeToContentModes.Floating flag.

This method will keep the docking window in its current State, but it will be contained within a new floating dock host.

MoveToMdi Method

Moves the tool or document window into the MDI area. Note that tabbed MDI or standard MDI modes should be active before calling this method.

One overload of this method restores the docking window back to its default document location and the other lets you specify the target dock host.

This method changes the docking window into a Document state.

The ToolWindow class defines additional methods that can be used to move a tool window to any state at either a default or target location.

Member | Description
Attach Method | Attaches the tool window to the specified dock target, which could be another open docking window, tabbed MDI container, or tool window container. This method changes the tool window into the state defined by the dock target.
AutoHide Method | Auto-hides the tool window to the outer-edge of the current dock host. One overload of this method goes to a default dock side, and the other lets you specify the target dock side. This method changes the tool window into an AutoHide state.
Dock Method | Docks the tool window within the dock host hierarchy. One overload of this method restores the tool window back to its default dock location and the other lets you specify a target and side against which to dock. This method changes the tool window into a Docked state.

The DocumentWindow class defines additional methods that can be used to move a document window to a target location.

Member | Description
Attach Method | Attaches the document window to the specified dock target, which could be another tabbed document window or tabbed MDI container.
Dock Method | Docks the document window to the side of a specified target, which could be another tabbed document window or tabbed MDI container.

Example: Docking to the Top of a Target

In this example we will dock the solutionExplorerToolWindow to the top of the propertiesToolWindow.

C#
VB
Copy
​solutionExplorerToolWindow.Dock(propertiesToolWindow, Side.Top);
​solutionExplorerToolWindow.Dock(propertiesToolWindow, Side.Top)

Example: Creating a Tabbed Group

In this example we will create a tabbed group of tool windows by "attaching" the solutionExplorerToolWindow to the propertiesToolWindow.

C#
VB
Copy
​solutionExplorerToolWindow.Attach(propertiesToolWindow);
​solutionExplorerToolWindow.Attach(propertiesToolWindow)

Example: Floating to a Location

In this example we will float the solutionExplorerToolWindow to a particular location.

C#
VB
Copy
​solutionExplorerToolWindow.Float(new Point(100, 100));
​solutionExplorerToolWindow.Float(New Point(100, 100))

Example: Floating and sizing to fit content

In this example we will float the solutionExplorerToolWindow to its previous location and have it size-to-content.

C#
VB
Copy
​solutionExplorerToolWindow.SizeToContentModes = SizeToContentModes.Floating;
solutionExplorerToolWindow.Float();
​solutionExplorerToolWindow.SizeToContentModes = SizeToContentModes.Floating
solutionExplorerToolWindow.Float()

Determining the Location of a Tool Window in Relation to the Workspace

The ToolWindow class has a GetCurrentSide method that returns a Side specifying where the tool window currently is in relation to the workspace, if one is in use.

If the tool window is open in a Document state, null is returned. If the tool window is open in an AutoHide state, a Side indicating the auto-hide dock side is returned. If the tool window is open in a Docked state and a workspace is in use in the dock site (no tool window inner-fill), a Side indicating the location of the tool window relative to the workspace is returned. If the tool window is open in a Docked state and the containing dock host does not has a workspace (tool window inner-fill is active), a Side indicating the location of the tool window's midpoint relative to the dock host's bounds is returned. Otherwise, if the tool window is closed, null is returned.

Programmatically Starting a Drag

It is possible to programmatically start a drag operation on DocumentWindow, ToolWindow, or ToolWindowContainer, by calling the associated DragMove method.

The only requirements are that the DocumentWindow/ToolWindow be registered with a DockSite and that the left mouse button be pressed when the method is called. This means that the method can even be called on windows that are not currently selected, in the auto-hide state, or in a standard MDI host. Also note that a InputPointerButtonEventArgs must be passed so that the related pointer can be captured.

In this example we trigger a programmatic drag on a tool window in the window variable from within an event handler for its primary pointer button being down:

C#
VB
Copy
​window.DragMove(new InputPointerButtonEventArgs(e, InputPointerButtonKind.Primary));
​window.DragMove(New InputPointerButtonEventArgs(e, InputPointerButtonKind.Primary))

Splitter Drag Kinds

Live splitting is enabled by default, meaning that when a splitter is dragged, the surrounding containers will immediately resize. This feature can be turned off by setting the DockSite.IsLiveSplittingEnabled property to false. When false, highlights are dragged instead and the containers only resize when the splitter is dropped.

While the live splitting feature is desirable for most scenarios, if your docking window content has very complex element trees that don't measure/arrange fast, turning off live splitting will improve performance when the end user uses splitters.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Docking Window Capabilities

One of the best features of Actipro Docking & MDI is the number of options that are available to you as a developer. Many options control the behaviors and capabilities of the docking windows and can be set at a global level as well as at a docking window instance level.

This topic contains these sections:

  • Global Default Options
  • Docking Window Instance Options
  • How to Allow Tabs to Be Reordered, But Not Dragged Elsewhere
  • Limiting the Allowed Dock Guides While Dragging
  • Magnetism
  • Images on Tabs Option
  • Single Tab Layout Behavior
  • Tinting Tabs
  • Flashing Tabs
  • ToolWindowContainer Title Font

Global Default Options

A number of global default options appear on the DockSite. By default, docking windows will use these options unless their instance settings overrides them.

Member | Description
DockSite.AreDocumentWindowsDestroyedOnClose Property | Gets or sets whether document windows are automatically destroyed (removed from the DockSite) when closed. The default value is true.
DockSite.AreNewTabsInsertedBeforeExistingTabs Property | Gets or sets whether new tabs are inserted before existing tabs when they are added, such as when dragging and attaching a tool window to an existing tool window container. The default value is true.
TabbedMdiHost.CanDocumentsAttach Property | Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping. The default value is true.
TabbedMdiHost.CanDocumentsCloseOnMiddleClick Property | Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button. The default value is true.
TabbedMdiHost.CanDocumentTabsDrag Property | Gets or sets the global setting for whether document tabs may be dragged to another location. The default value is true.
DockSite.CanDocumentWindowsClose Property | Gets or sets the global setting for whether document windows can be closed. The default value is true.
DockSite.CanToolWindowsDragToFloatingDockHostsWithWorkspaces Property | Gets or sets the global setting for whether tool windows may be dragged to floating dock hosts that contain a workspace. The default value is true. When false, tool windows can still be dragged and docked against floating dock hosts that only contain tool windows.
DockSite.CanDocumentWindowsDragToLinkedDockSites Property | Gets or sets the global setting for whether document windows may be dragged to a linked dock site. The default value is true.
DockSite.CanDocumentWindowsFloat Property | Gets or sets the global setting for whether document windows may be contained in a floating window. The default value is false.
DockSite.CanFloatingDockHostsHideOnDockSiteUnload Property | Gets or sets whether DockSite.FloatingDockHosts should hide when the DockSite is unloaded, such as in nested DockSite scenarios when the parent tab is deselected. The default value is false.
DockSite.CanToolWindowsAttach Property | Gets or sets the global setting for whether the end user can edit document window titles in-place when a document window tab is double-clicked. The default value is true.
DockSite.CanToolWindowsAutoHide Property | Gets or sets the global setting for whether tool windows may be placed in auto-hide mode. The default value is true.
DockSite.CanToolWindowsBecomeDocuments Property | Gets or sets the global setting for whether tool windows may be placed in a document state. The default value is true.
DockSite.CanToolWindowsClose Property | Gets or sets the global setting for whether tool windows can be closed. The default value is true.
DockSite.CanToolWindowsCloseOnMiddleClick Property | Gets or sets a value indicating whether tool windows can be closed by clicking the tab with the middle mouse button. The default value is true.
DockSite.CanToolWindowsDock Property | Gets or sets the global setting for whether tool windows can be docked. The default value is true.
DockSite.CanToolWindowTabsDrag Property | Gets or sets the global setting for whether tool window tabs may be dragged to another location. The default value is true.
DockSite.CanToolWindowsDragToLinkedDockSites Property | Gets or sets the global setting for whether tool windows may be dragged to a linked dock site. The default value is true.
DockSite.CanToolWindowsFloat Property | Gets or sets the global setting for whether tool windows may be floated into separate top-level containers. The default value is true.
DockSite.ClosePerContainer Property | Gets or sets the global setting for whether tool windows may be attached to another tool window, creating a tabbed grouping. The default value is false.
DockSite.ContainersHaveNewTabButtons Property | Gets or sets whether containers have new tab buttons. The default value is false.
DockSite.FloatingToolWindowContainersHaveMaximizeButtons Property | Gets or sets whether floating ToolWindowContainer controls can have title bar maximize buttons. The default value is true.
DockSite.FloatingToolWindowContainersHaveMinimizeButtons Property | Gets or sets whether floating ToolWindowContainer controls can have title bar maximize buttons. The default value is false.
DockSite.HasTabCloseButtons Property | Gets or sets whether close buttons should appear on document tabs. The default value is true.
TabbedMdiHost.TabOverflowBehavior Property | Gets or sets the global setting for the overflow behavior of the document tabs. The default value is TabOverflowBehavior.Menu.
DockSite.IsDockGuideAnimationEnabled Property | Gets or sets whether dock guide animation is enabled. The default value is true.
DockSite.IsFloatingWindowSnapToScreenEnabled Property | Gets or sets whether floating windows are snapped onto the closest screen when displayed via a method other than being dragged. The default value is true.
DockSite.IsLiveSplittingEnabled Property | Gets or sets whether live splitting of docking windows is enabled. The default value is true.
DockSite.IsTabLayoutAnimationEnabled Property | Gets or sets whether animation effects are applied during tab layout, such as when tabs are added or removed. The default value is true.
TabbedMdiHost.TabStripPlacement Property | Gets or sets a Side indicating the side upon which the tabs are located. The default value is Top.
DockSite.ToolWindowsHaveCloseButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar close buttons. The default value is true.
DockSite.ToolWindowsHaveOptionsButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar options buttons. The default value is true.
DockSite.ToolWindowsHaveTitleBarIcons Property | Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window. The default value is false.
DockSite.ToolWindowsHaveTitleBars Property | Gets or sets the global setting for whether tool windows display a title bar when not in MDI. The default value is true.
DockSite.ToolWindowsHaveToggleAutoHideButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar toggle auto-hide buttons. The default value is true.
DockSite.ToolWindowsSingleTabLayoutBehavior Property | Gets or sets the global setting for the behavior used when a single tool window is in a container. The default value is SingleTabLayoutBehavior.Hide.
DockSite.ToolWindowsTabOverflowBehavior Property | Gets or sets the global setting for the overflow behavior of the tool window tabs. The default value is TabOverflowBehavior.Shrink.
DockSite.ToolWindowsTabStripPlacement Property | Gets or sets the global setting for the overflow behavior of the tool window tabs. The default value is Bottom.
DockSite.UseDragFloatPreviews Property | Gets or sets whether to use float previews when dragging windows instead of instantly creating floating windows. The default value is false.
DockSite.UseHostedFloatingWindows Property | Gets or sets whether floating windows should be hosted within the bounds of the dock site. The default value is false.
DockSite.UseHostedPopups Property | Gets or sets whether popups should be hosted within the bounds of the dock site. The default value is true.

Docking Window Instance Options

All of the global default options listed above will apply to docking windows by default. Related docking window instance options are all nullable booleans with default values of null, indicating that they will inherit the global defaults.

Member | Description
DockingWindow.CanAttach Property | Gets or sets whether the window may be attached to another window, creating a tabbed grouping.
ToolWindow.CanAutoHide Property | Gets or sets whether the tool window may be placed in auto-hide mode.
ToolWindow.CanBecomeDocument Property | Gets or sets whether the tool window may be placed in a document state.
DockingWindow.CanClose Property | Gets or sets whether the window may be closed.
DockingWindow.CanDock Property | Gets or sets whether the tool window may be docked.
DockingWindow.CanDragTab Property | Gets or sets whether the window's tab may be dragged to another location.
DockingWindow.CanDragToLinkedDockSites Property | Gets or sets whether the window may be dragged to a linked dock site.
DockingWindow.CanFloat Property | Gets or sets whether the window may be floated into a separate top-level container.
DockingWindow.CanSerialize Property | Gets or sets whether the window's layout information may be serialized.
DockingWindow.CanStandardMdiMaximize Property | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost.
DockingWindow.CanStandardMdiMinimize Property | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost.
ToolWindow.HasOptionsButton Property | Gets or sets whether the window has an options menu available.
ToolWindow.HasTitleBar Property | Gets or sets whether the window displays a title bar when docked.

How to Allow Tabs to Be Reordered, But Not Dragged Elsewhere

In some situations you may wish to keep docking windows in their current container but still want to allow them to be reordered.

To accomplish this, turn all the appropriate options off such as can dock and can raft, etc. but leave can drag on. This will allow the user to reorder tabs by dragging them within their container but will prevent the docking window from moving outside of the container.

Limiting the Allowed Dock Guides While Dragging

The DockSite.WindowsDragOver event is raised while dragging docking windows over a new drop target. This event is passed an instance of DockingWindowsDragOverEventArgs, which indicates the DockHost being dragged, the docking windows inside that DockHost, and the IDockTarget control that the pointer is currently over.

The DockingWindowsDragOverEventArgs.SupportedDockGuideKinds property lists the dock guide kinds (a DockGuideKinds flags enumeration value) that are supported with this particular combination and will be shown by default.

If you wish to prevent certain supported dock guides from being displayed, change the DockingWindowsDragOverEventArgs.AllowedDockGuideKinds property value. It defaults to the SupportedDockGuideKinds property value.

For instance, if you'd only like docking windows to be able to dock left, right, or center (attach), you could set the AllowedDockGuideKinds property to OuterLeft | InnerLeft | Center | InnerRight | OuterRight. Any values that you set to this property that aren't "supported" at the time will be ignored.

You can use complex logic to tailor the allowed dock guides based on your application design and its current state.

Magnetism

Magnetism allows floating windows to be "snapped" together when moving or resizing. This makes it easier for the end-user to line up the windows into rows or columns.

Magnetism can be configured using DockSite.MagnetismSnapDistance and DockSite.MagnetismGapDistance. The snap distance indicates the distance at which magnetism begins to snap windows being dragged. The gap distance indicates the distance between windows that are snapped together via magnetism. Magnetism can be disabled by setting the snap distance to 0.

Images on Tabs Option

The DockingWindow.ImageSource image can appear on docking window tabs when tab images are enabled. Several themes, such as the non-Metro themes, turn this feature on by default.

You can force the image to display on the tool window tabs by setting the DockSite.ToolWindowsHaveTabImages property to true, or on tabbed MDI tabs by setting the TabbedMdiHost.HasTabImages property to true.

Single Tab Layout Behavior

By default, when a ToolWindowContainer only has a single ToolWindow, then the tabs are hidden. This mimics the behavior seen in Visual Studio, but can be customized. The tab for the single window can be hidden or shown.

The behavior can be customized using the DockSite.ToolWindowsSingleTabLayoutBehavior property, whose default value is Hide.

A ToolWindowContainer with a single window using Hide and Show behaviors

Tinting Tabs

Tabs can be tinted towards a color by setting the DockingWindow.TabTintColor property. The tab will have the same general visual appearance but the colors will be skewed towards the tint color.

Several tinted tabs

Flashing Tabs

Tabs can enter a flashing mode by setting the DockingWindow.TabFlashMode property to either Blink or Smooth. The Blink mode will cause the tab to appear as flashing for a bit, then instantly restore it to normal for a bit, then appear as flashing for a bit, and so on until the mode is changed back to None. The Smooth mode will do a smooth transition between the flashing appearance and normal appearance.

The DockingWindow.TabFlashColor property specifies the color used to tint the tab for its flash effect.

Flashing is best used to grab the end user's attention, and let them know that a tab should be clicked. Watch the DockSite.WindowActivated event to see when the docking window is activated. At that point, set the TabFlashMode property back to None to disable flashing.

ToolWindowContainer Title Font

The ToolWindowContainer control has several properties that can be set to alter its title font appearance:

  • TitleFontFamily
  • TitleFontSize
  • TitleFontWeight

Properties like these should never be set directly on specific instances of container controls since containers are created and destroyed dynamically at run-time with layout changes. Instead, if you wish to change these properties, use an implicit Style that targets ToolWindowContainer in your application's Resources:

XAML
Copy
​<Style TargetType="docking:ToolWindowContainer">
    <Setter Property="TitleFontFamily" Value="Verdana" />
    <Setter Property="TitleFontSize" Value="14" />
    <Setter Property="TitleFontWeight" Value="Bold" />
</Style>

That implicit Style will update all instances of the container within your application.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Docking Window Events

There are a number of events to which you can attach to know when various actions occur to docking windows.

This topic contains these sections:

  • DockSite Events
  • Displaying a StatusBar Message During Drags
  • Customizing Menus

DockSite Events

The DockSite that owns the docking window receiving an action has these events:

Member | Description
FloatingWindowOpening Event | Occurs when a floating window is opening, allowing for customization before it is displayed.
MdiKindChanged Event | Occurs when the DockSite.MdiKind property is changed.
MenuOpening Event | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
NewWindowRequested Event | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
PrimaryDocumentChanged Event | Occurs when the DockSite.PrimaryDocument property has changed.
WindowActivated Event | Occurs after a DockingWindow has been activated.
WindowAutoHidePopupClosed Event | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
WindowAutoHidePopupOpened Event | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
WindowDeactivated Event | Occurs after a DockingWindow has been deactivated.
WindowDefaultLocationRequested Event | Occurs when a DockingWindow's default location is requested.
WindowRegistered Event | Occurs after a DockingWindow has been registered.
WindowsAutoHiding Event | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
WindowsClosed Event | Occurs after one or more DockingWindow controls have been closed.
WindowsClosing Event | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
WindowsDockHostChanged Event | Occurs after one or more DockingWindow controls' DockHost properties have changed.
WindowsDragged Event | Occurs after one or more DockingWindow controls are dragged by the end user.
WindowsDragging Event | Occurs before one or more DockingWindow controls are dragged by the end user.
WindowsDragOver Event | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
WindowsOpened Event | Occurs after one or more DockingWindow controls have been opened.
WindowsOpening Event | Occurs before one or more DockingWindow controls is opened.
WindowsStateChanged Event | Occurs after one or more DockingWindow controls' states have changed.
WindowUnregistered Event | Occurs after a DockingWindow has been unregistered.

Most of the event arguments pass references to the related DockingWindow controls.

Displaying a StatusBar Message During Drags

It is a common practice to display a status bar message during tool window drags to indicate to the end user that they can move over the dock guides to docks a tool window.

To accomplish this, handle the WindowsDragging and display a message like this in your status bar:

Use the guide diamond to choose a docking location. To prevent docking, hold down CTRL.

Handle the WindowsDragged event and restore the status bar message back to something like Ready.

Customizing Menus

The MenuOpening event fires before any menu is displayed for a window or button, allowing you to customize it or replace it with your own.

See the Menu Customization topic for details on handling this event.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Docked Tool Windows

Tool windows in docked state appear docked in containers around an optional workspace within their dock host. When two or more tool windows are in the same container, tabs allow for selecting which one is visible.

When a tool window is docked, it appears within a ToolWindowContainer.

The Solution Explorer tool window docked

This topic contains these sections:

  • Allowing Docking
  • Programmatically Docking a Tool Window
  • Appearance Options
  • Title vs. Tab Text
  • Tab Tool Tip
  • Tab Images
  • Tab and Title Bar Contextual Content
  • Tab Strip Placement
  • Tab Overflow Behavior
  • Single Tab Behavior
  • Keyboard Shortcuts

Allowing Docking

Only tool windows can be docked. A global DockSite.CanToolWindowsDock property (defaults to true) determines the default value for whether they have that capability, but it can be overridden at an instance-level by setting the DockingWindow.CanDock property.

The DockingWindow.CanAttach property can be set to false to prevent a tool window from attaching (becoming tabbed with) another tool window in the same container.

Programmatically Docking a Tool Window

A tool window can be programmatically docked by calling the ToolWindow.Dock method. An overload of the method allows you to specify the IDockTarget and Side against which to dock around the target.

The IDockTarget can be a DockSite, DockHost, Workspace, or another docking window.

Appearance Options

These options control the appearance of tool window containers:

Member | Description
DockSite.ToolWindowsHaveCloseButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar close buttons.
DockSite.ToolWindowsHaveOptionsButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar options buttons.
DockSite.ToolWindowsHaveTitleBarIcons Property | Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window.
DockSite.ToolWindowsHaveTitleBars Property | Gets or sets the global setting for whether tool windows display a title bar when not in MDI.
DockSite.ToolWindowTabItemContainerStyle Property | Gets or sets the Style to use for rendering the tab item containers in a ToolWindowContainer.

The ToolWindowContainer control also defines TitleFontFamily and TitleFontSize properties that can adjust the look of a title in a tool window container. These properties can only be altered with an implicit Style that targets ToolWindowContainer that is in your application's Resources.

Title vs. Tab Text

The DockingWindow.Title property is normally set to determine the title text that is rendered in tabs as well as in title bars and on the standard switcher. In some cases, it might be desirable to have longer text for the Title, such as "Properties - Document1.txt", while having shorting text that renders on tabs, such as "Properties". This allows your title to provide more extensive contextual information.

By setting the TabText property to a non-null value, its value will be used to render the tab text instead of the Title value. In that scenario, the Title value will still be used in title bars and on the standard switcher when the window is selected.

Tab Tool Tip

The DockingWindow.TabToolTip property is automatically bound to the Title property for tool windows. Override the TabToolTip property to set alternate tool tip content.

Tab Images

By default the DockingWindow.ImageSource image will not appear on tool window tabs.

You can force the image to display on the tabs by setting the DockSite.ToolWindowsHaveTabImages property to true.

Tab and Title Bar Contextual Content

Tool window tabs and tool window container title bars can display any context-related content to the right of the title. This content is set via the ToolWindow.ToolWindowContainerTabContextContentTemplate and ToolWindow.ToolWindowContainerTitleBarContextContentTemplate properties respectively.

See the Contextual Content topic for some more information.

Tab Strip Placement

By default the tool window tabs will appear below their content, but can be changed to appear on any side of the content.

You can alter the location of the tool window tabs by changing the value of the DockSite.ToolWindowsTabStripPlacement property.

Tab Overflow Behavior

There are numerous options from the TabOverflowBehavior enumeration for selecting what happens when the tabs overflow the available tab strip space.

By default, the tabs shrink to fit within the available tab strip space. This can be changed via the DockSite.ToolWindowsTabOverflowBehavior property.

Single Tab Behavior

Use the DockSite.ToolWindowsSingleTabLayoutBehavior property to adjust whether tool window containers that have a single tool window should show a tab or not. By default, tabs only show when there are two or more tool windows in a container.

Keyboard Shortcuts

The Alt+- keyboard shortcut shows the options menu for the currently selected tool window in the container.

Other keyboard shortcuts allow you to jump directly to a tab. Ctrl+1 will activate the first tab, with Ctrl+2 activating the second tab, and so on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Auto-Hidden Tool Windows

Tool windows in auto-hide state show tabs along a tray area on the side of their dock host. When a tab is clicked, the related tool window's content is displayed in an animated popup.

The Solution Explorer tool window in AutoHide state with its popup displayed

This topic contains these sections:

  • Allowing Auto-Hide
  • Programmatically Auto-Hiding a Tool Window
  • Behavior and Animation Options
  • Appearance Options
  • Iterating Auto-Hidden Tool Windows
  • Determining If an Auto-Hide Popup Is Displayed
  • Preventing an Auto-Hide Popup From Closing
  • Dynamically Altering the Auto-Hide Side
  • Auto-Hide Popup Events
  • Notes on Interop Usage

Allowing Auto-Hide

Only tool windows can be auto-hidden. A global DockSite.CanToolWindowsAutoHide property (defaults to true) determines the default value for whether they have that capability, but it can be overridden at an instance-level by setting the ToolWindow.CanAutoHide property.

Programmatically Auto-Hiding a Tool Window

A tool window can be programmatically auto-hidden by calling the ToolWindow.AutoHide method. An overload of the method allows you to specify the Side against which to auto-hide.

Behavior and Animation Options

These options control auto-hide functionality behavior and ensuing animation:

Member | Description
DockSite.AutoHidePerContainer Property | Gets or sets whether auto-hide state toggles affect all the windows in the parent container. The default value is true.
DockSite.AutoHidePopupCloseAnimationDuration Property | Gets or sets the time in milliseconds of the animation that is applied to an auto-hide popup close. The default value is 150ms.
DockSite.AutoHidePopupCloseDelay Property | Gets or sets the time in milliseconds of the delay between when the pointer leaves an auto-hide popup and when the popup closes if the mouse has not moved back over the popup. This only applies when AutoHidePopupOpensOnMouseHover is true. The default value is 500ms.
DockSite.AutoHidePopupOpenAnimationDuration Property | Gets or sets the time in milliseconds of the animation that is applied to an auto-hide popup open. The default value is 150ms.
DockSite.AutoHidePopupOpenDelay Property | Gets or sets the time in milliseconds of the delay between when the pointer moves over an auto-hide tab item and the auto-hide popup opens to display the tool window represented by the tab item. This only applies when AutoHidePopupOpensOnMouseHover is true. The default value is 200ms.
DockSite.AutoHidePopupOpensOnMouseHover Property | Gets or sets whether the auto-hide popup displays when the mouse hovers over an auto-hide tab item. The default value is false for most themes, but may be true for some themes.

Appearance Options

These options control the appearance of auto-hide tabs:

Member | Description
ToolWindow.AutoHideTabContextContentTemplate Property | Gets or sets the DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.
DockSite.AutoHideTabItemTemplate Property | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
DockSite.AutoHideTabItemTemplateSelector Property | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.

Iterating Auto-Hidden Tool Windows

These DockSite properties are the four collections of ToolWindowContainer controls, one collection for each side of the dock site.

  • DockSite.AutoHideLeftContainers
  • DockSite.AutoHideTopContainers
  • DockSite.AutoHideRightContainers
  • DockSite.AutoHideBottomContainers
Each of those accepts one or more ToolWindowContainer controls, each of which can contain one or more ToolWindow controls.

The properties above are simple wrappers for similar properties on the DockHost returned by the DockSite.PrimaryDockHost property. You can iterate through those collections to see which tool windows are on each side of the primary dock host.

You can also examine each floating DockHost, if there are any, by iterating the DockSite.FloatingDockHosts collection and examining the DockHost.AutoHideLeftContainers, etc. properties on them.

Determining If an Auto-Hide Popup Is Displayed

The DockHost.IsAutoHidePopupOpen property returns true when there is an auto-hide popup displayed.

The DockHost.AutoHidePopupToolWindow property returns the ToolWindow that is currently open in that popup. The ToolWindow.IsAutoHidePopupOpen property of that tool window will return true while it is open in the popup.

Preventing an Auto-Hide Popup From Closing

Auto-hide popups will close by default after a brief delay whenever the keyboard focus is moved outside of them. This can be a problem in scenarios where a dialog Window is opened from the tool window displayed in the auto-hide popup. In that scenario, the keyboard focus moves to the dialog and the auto-hide popup is closed. However you may wish to keep the auto-hide popup visible while the dialog is displayed so that focus properly returns to it when the dialog is closed.

This code shows how to display a dialog and keep any current auto-hide popup open:

C#
VB
Copy
​try {
    dockSite.AutoHidePopupClosesOnLostFocus = false;
    window.ShowDialog();
}
finally {
    dockSite.AutoHidePopupClosesOnLostFocus = true;
}
​Try
    dockSite.AutoHidePopupClosesOnLostFocus = False
    window.ShowDialog()
Finally
    dockSite.AutoHidePopupClosesOnLostFocus = True
End Try

Dynamically Altering the Auto-Hide Side

The WindowsAutoHiding event fires whenever one or more tool windows are auto-hidden, allowing for the side upon which they are being auto-hidden to be customized. This is useful in scenarios like when you wish to restrict auto-hiding to only the left/right or top/bottom of a dock host.

The event is passed arguments of type DockingWindowsAutoHidingEventArgs, which has a Side property. An event handler can examine the list of windows being auto-hidden and can choose to change the side to another side.

Auto-Hide Popup Events

The WindowAutoHidePopupOpened and WindowAutoHidePopupClosed events on DockSite fire whenever the auto-hide popup is opened or closed. The event arguments specify which tool window was opened or closed.

Notes on Interop Usage

If you use an interop (WinForms, ActiveX, etc.) control in your docking windows, auto-hide popups in their default configuration will not appear on top of the interop content due to WPF airspace issues with interop content in the same Window. By setting the DockSite.UseHostedPopups property to false, non-hosted popups will be used to display auto-hide content instead. This uses a separate Window to render the popup and thereby allows WPF content in the popup to render above the interop content. The only downside to setting this property is that you lose the popup open/close animation.

See the Interop Compatibility topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Floating Dock Hosts

Docking windows can be dragged to float, meaning appear in a floating dock host that can move independently above the dock site's primary dock host.

This topic contains these sections:

  • Floating Dock Host Overview
  • Allowing Floating Windows
  • Programmatically Floating a Docking Window
  • Preventing Tool Windows from Docking Against Floating Dock Hosts Containing Workspaces
  • Determining if a Docking Window is on a Floating Dock Host
  • Floating Window Icon and Title
  • Using Drag Float Previews
  • Snap to Screen Threshold
  • Size-to-Content
  • Limiting Floating Window Initial Sizes
  • Non-Hosted vs. Hosted Floating Windows
  • Hosted Floating Window Inactivity Animations
  • Hosted Floating Window Container
  • Determining Which Floating Windows Show in the Windows TaskBar

Floating Dock Host Overview

Any time a docking window is floated, a floating DockHost is created to contain it. If a document window is floated, the dock host will contain its own workspace and MDI host in which the floated document window will appear. If a tool window is floated, the dock host will contain a single tool window container.

For floating dock hosts with a workspace, other documents can be added to the floating dock host's MDI host and other tool windows can be docked around the workspace, or even auto-hidden. For floating dock hosts that do not have a workspace and only have tool window containers, other tool windows can be attached or docked next to the tool window containers.

Allowing Floating Windows

Both tool and document windows can be floated, but only tool windows have floating enabled by default.

A global DockSite.CanToolWindowsFloat property (defaults to true) determines the default value for whether tool windows have that capability, and a global DockSite.CanDocumentWindowsFloat property (defaults to false) determines the default value for whether document windows have that capability. The properties can be overridden at an instance-level by setting the DockingWindow.CanFloat property.

Programmatically Floating a Docking Window

A docking window can be programmatically floated by calling the DockingWindow.Float method. Overloads of the method are available that allow you to specify the location or size of the floating dock host.

Preventing Tool Windows from Docking Against Floating Dock Hosts Containing Workspaces

In some scenarios, you might only wish to allow tool windows to be dragged and docked against floating dock hosts that only contain tool windows, and don't have a workspace. To enable this feature, set the DockSite.CanToolWindowsDragToFloatingDockHostsWithWorkspaces property to false.

Determining if a Docking Window is on a Floating Dock Host

When the DockingWindow.IsOpen property returns true, the docking window is open in the layout and is nested within a DockHost. The dock host can be retrieved via the DockingWindow.DockHost property. If the dock host is in the DockSite.FloatingDockHosts collection, then it is a floating dock host, and thus the docking window is "floating".

This code shows how to do this check:

C#
VB
Copy
​var isOnFloatingDockHost = (window.IsOpen) && (window.DockSite.FloatingDockHosts.Contains(window.DockHost));
​Dim isOnFloatingDockHost = (window.IsOpen) AndAlso (window.DockSite.FloatingDockHosts.Contains(window.DockHost))

The DockingWindow.IsFloating property makes this even easier:

C#
VB
Copy
​var isOnFloatingDockHost = (window.IsOpen) && (window.IsFloating);
​Dim isOnFloatingDockHost = (window.IsOpen) AndAlso (window.IsFloating)

Note that the DockingWindowState enumeration doesn't have a Floating item. This is due to the fact that Docking/MDI's advanced floating dock host features allow tool windows to be in a docked, auto-hide, or in document state when they are in a floating dock host.

For instance, if a tool window is floated, it will show up in a single ToolWindowContainer inside of a floating dock host and its state will be Docked. If a document window is floated, it will show up in a MDI area inside of a floating dock host and its state will be Document. A tool window could then be dragged and docked next to that MDI area. Once that is done, it could be auto-hidden, and its state would be AutoHide. These examples show how various docking window states can exist within a floating dock host.

Floating Window Icon and Title

A floating dock host can have its icon and title set via the DockSite.FloatingWindowIcon and FloatingWindowTitle properties respectively. It's generally a good practice to use an application icon as the icon and the application title as the title.

Using Drag Float Previews

By default, dragging a docking window will instantly float it, giving it more of a live feel. The DockSite.UseDragFloatPreviews property, which defaults to false, can be set to true to prevent this behavior and only show a float preview highlight while dragging.

This property should be set to true when docking window content contains a large number of elements that may not measure/arrange quickly. When this property is true, fewer layout cycles occur since a float preview is used to show where the floating window will be created instead of instantly moving the dragged windows into a floating window.

Snap to Screen Threshold

When the DockSite.IsFloatingWindowSnapToScreenEnabled property is true, which is the default, floating windows are snapped onto the closest screen when displayed via a method other than being dragged. This feature ensures that floating windows are fully visible on-screen when being programmatically displayed, such as when a layout is loaded.

The minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen can be set by the DockSite.FloatingWindowSnapToScreenThreshold property. If a floating window is completely beyond the screen edge, it will be fully snapped back onto the screen. If a floating window is only partially beyond the screen edge, but the visible portion is less than this property's value, it will be snapped partially back onto the screen.

Size-to-Content

If you wish for a docking window to auto-size itself to its content when floated, update its DockingWindow.SizeToContentModes property to contain the SizeToContentModes.Floating flag.

Limiting Floating Window Initial Sizes

The DockSite.FloatingWindowOpening event fires whenever a floating window is opening, allowing for customization before it is displayed. It is passed arguments of type FloatingWindowOpeningEventArgs that indicate the child control of the floating dock host that will be created, along with the default size of the floating window.

The FloatingWindowOpeningEventArgs.Size property can be altered in the event handler to limit the size of the floating window. This feature is useful since sometimes when a MDI area fills most of the screen, dragged-to-float documents would fully obscure what is behind them.

This code shows an event handler implementation that ensures that floating windows are never longer than 600 on their long side, and 300 on their short side.

C#
VB
Copy
​private void OnDockSiteFloatingWindowOpening(object sender, FloatingWindowOpeningEventArgs e) {
    // Make sure the long side is no longer than 600, and the short side is no longer than 300
    if (e.Size.Width > e.Size.Height)
        e.Size = new Size(Math.Min(600.0, e.Size.Width), Math.Min(300.0, e.Size.Height));
    else
        e.Size = new Size(Math.Min(300.0, e.Size.Width), Math.Min(600.0, e.Size.Height));
}
​Private Sub OnDockSiteFloatingWindowOpening(ByVal sender As Object, ByVal e As FloatingWindowOpeningEventArgs)
    ' Make sure the long side is no longer than 600, and the short side is no longer than 300
    If e.Size.Width > e.Size.Height Then
        e.Size = New Size(Math.Min(600.0, e.Size.Width), Math.Min(300.0, e.Size.Height))
    Else
        e.Size = New Size(Math.Min(300.0, e.Size.Width), Math.Min(600.0, e.Size.Height))
    End If
End Sub

Non-Hosted vs. Hosted Floating Windows

Non-hosted floating windows are used by default in WPF desktop applications, which means that when a floating dock host is created, it will be contained by its own Window that can be independently moved anywhere. Drags of non-hosted floating windows make use of Windows' Aero snap features, meaning you can drag to the top of a screen to maximize it, to the side to make it take up half the screen, or to a corner to make it take up a quarter of the screen.

The DockSite.UseHostedFloatingWindows property can be set to true to force floating dock hosts to use a hosted floating window instead. In this scenario, a WindowControl is used as a wrapper around the floating dock host and is allowed to move anywhere within the bounds of the dock site, or DockSite.HostedFloatingWindowContainer if specified.

When using hosted floating windows, the floating dock host is embedded within the same root Window as the dock site. Hosted floating windows have a subtle outer glow that gives them some depth and distinguishes them from the content dock site underneath.

Due to security restrictions where XBAPs don't support Window controls (which are used for non-hosted floating windows), hosted floating windows are used for XBAP applications.

Hosted Floating Window Inactivity Animations

A great feature implemented by hosted floating windows that cannot be implemented in normal floating windows is inactivity animation.

Basically after the pointer has not moved over a hosted floating window for a while and it doesn't have focus, it will begin to slowly fade out to partial transparency. You have total control over whether this feature is enabled and how long it takes to fade, etc.

These DockSite properties control the inactivity behavior:

Member | Description
InactiveFloatingWindowFadeDelay Property | Gets or sets the duration of inactivity that must take place for a floating window before it starts to fade out. The default value is 20 seconds.
InactiveFloatingWindowFadeDuration Property | Gets or sets the duration over which an inactive floating window will fade. The default value is 20 seconds.
InactiveFloatingWindowFadeOpacity Property | Gets or sets the target opacity to which inactive floating windows to fade. The default value is 0.25 (25% opacity).
IsInactiveFloatingWindowFadeEnabled Property | Gets or sets whether floating windows will fade out following inactivity. The default value is true.

Hosted Floating Window Container

To ensure that a portion of the hosted floating windows are always visible to the end user, their bounds are coerced such that part of the title bar is always visible. The DockSite.HostedFloatingWindowContainer property can be set to any visual ancestor of the DockSite, and hosted floating window bounds will be constrained to the bounds of the specified container. If a container is not specified, the DockSite will be used as the container.

Determining Which Floating Windows Show in the Windows TaskBar

The DockSite.FloatingWindowShowInTaskBarMode property can be used to determine which kinds of non-hosted floating windows are displayed in the Windows taskbar. The default behavior is for any floating window that contains a "workspace" (such as a floating tabbed MDI document) to show up in the taskbar and not be "owned" by the main window. This means that the floating window can appear behind the main window when the main window is activated, but is ok since the floating window can be accessed via the taskbar.

Change the property to FloatingWindowShowInTaskBarMode.Never to prevent all floating windows from showing in the taskbar. In this scenario, all floating windows will be "owned" by the main window so that they remain accessible.

Change the property to FloatingWindowShowInTaskBarMode.Always to force all floating windows to show in the taskbar. In this scenario, no floating windows will be "owned" by the main window and they all will be able to appear behind it when the main window is activated.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Contextual Content

Contextual content, such as buttons or status indicators, can be displayed throughout the docking window UI within tabs and title bars.

A status indicator showing in both the tool window tab and title bar

This topic contains these sections:

  • Contextual Content Locations
  • Tool Window Container Title Bar Alignment
  • Status Indicator Example
  • Tool Window Title Bar Buttons

Contextual Content Locations

There are five locations that support contextual content. Each of the properties below can be assigned a DataTemplate that specifies the contextual content to use for the related location.

The data context of the DataTemplate will be the DataContext of the docking window, unless the DataContext is a UIElement. In that case, no data context is passed since it could otherwise lead to logical tree issues.

Member | Description
ToolWindow.AutoHideTabContextContentTemplate Property | The tab of an auto-hidden tool window.
DockingWindow.StandardMdiTitleBarContextContentTemplate Property | The title bar of a standard MDI document.
DockingWindow.TabbedMdiTabContextContentTemplate Property | The tab of a tabbed MDI document.
ToolWindow.ToolWindowContainerTabContextContentTemplate Property | The tab of a docked tool window.
ToolWindow.ToolWindowContainerTitleBarContextContentTemplate Property | The title bar of a docked tool window.

Tool Window Container Title Bar Alignment

The DockSite.ToolWindowsTitleBarContextContentAlignment property can be set to a ContextContentAlignment that indicates if the context content is aligned to the near (left) side of the title, or to the far (right) side. The far side is just left of any title bar buttons, and is the default alignment.

Status Indicator Example

Let's see how to reproduce the Status tool window in the screenshot above.

This DataTemplate contains an ellipse whose fill color is bound to the value of the docking window's DataContext. A special value converter is used to convert the value to a Brush. See the related QuickStart in the Sample Browser for the full source code.

XAML
Copy
​<DataTemplate x:Key="StatusIconDataTemplate">
    <Ellipse Margin="2" Width="12" Height="12" StrokeThickness="1" Stroke="#ffffff" HorizontalAlignment="Center" VerticalAlignment="Center"
    Fill="{Binding Converter={StaticResource StatusLightConditionalConverter}}" />
</DataTemplate>

This XAML within a dock site shows how a tool widnow could be defined to use the DataTemplate above in all possible locations. Note how its DataContext is initialized to a boolean value.

XAML
Copy
​<docking:ToolWindow x:Name="statusToolWindow" Title="Status"
    AutoHideTabContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    StandardMdiTitleBarContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    TabbedMdiTabContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    ToolWindowContainerTabContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    ToolWindowContainerTitleBarContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    >
    <docking:ToolWindow.DataContext>
        <system:Boolean>False</system:Boolean>
    </docking:ToolWindow.DataContext>
    ...
</docking:ToolWindow>

Tool Window Title Bar Buttons

Buttons can be embedded in tool window title bar containers. To achieve the same appearance as the built-in buttons, define the button with these properties:

XAML
Copy
​<Button Style="{StaticResource {x:Static themes:SharedResourceKeys.EmbeddedButtonBaseOverrideStyleKey}}"
    Padding="2" VerticalAlignment="Center">
    <Button.ContentTemplate>
        <DataTemplate>
              <Canvas Width="10" Height="10">
                <Path Width="10" Height="10" StrokeThickness="1" Stroke="{Binding RelativeSource={RelativeSource Self}, Path=(TextElement.Foreground)}"
                        Data="M 0.5,3.5 A 3,3 90 0 1 3.5,0.5 A 3,3 90 0 1 6.5,3.5 A 3,3 90 0 1 3.5,6.5 A 3,3 90 0 1 0.5,3  M 5.5,6 L 9,9.5 L 9.5,9 L 6,5.5 Z"  />
              </Canvas>
        </DataTemplate>
    </Button.ContentTemplate>
</Button>

The sample above produces a button with a search icon.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Fixed Tool Windows

By turning off various options on a specific tool window, you can completely prevent it from being moved and can keep it "fixed" within a tool window layout, while still allowing other tool windows to be docked around it.

A fixed tool window without a title bar surrounded by the workspace and some other tool windows

A fixed tool window like the one in the screenshot can be created by setting:

  • ToolWindow.CanAttach = false
  • ToolWindow.CanDragTab = false
  • ToolWindow.HasTitleBar = false

Those settings prevent other tool windows from attaching (creating tabbed groups) to the tool window, being dragged anywhere, and having a title bar.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Menu Customization

All menus displayed by this product can be customized or replaced entirely before they are shown to the end user.

This topic contains these sections:

  • The MenuOpening Event
  • Customizing Individual Menu Items
  • Using a Different Context Menu
  • Context Menu Styles

The MenuOpening Event

The customization of menus is handled via the DockSite.MenuOpening event. This event fires whenever a menu is displayed for a docking window, when an options button is pressed for a docking window, etc.

The event arguments that are passed are type DockingMenuEventArgs, which indicates the DockingWindow for which the event was fired. The DockingMenuEventArgs.Kind property supplies a DockingMenuKind value that can be used to determine the type of menu being constructed.

The event arguments passes a pre-configured ContextMenu in its Menu property.

Customizing Individual Menu Items

As mentioned above, the event argument's Menu property includes all the menu items, already initialized.

You can customize the items in that menu, and add or remove new ones as needed.

Using a Different Context Menu

To use a completely different menu, simply set the new menu to the event argument's Menu property. The alternate menu you specify will be displayed instead.

Context Menu Styles

You can apply a Style to the context menu if you have one that matches the rest of your application. Note that since our default context menus are plain WPF ContextMenu controls, they will automatically pick up any ContextMenu styles that you set for your application.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Switchers

Switchers are used during Ctrl+Tab, etc. key presses to easily navigate between open documents and tool windows.

The standard switcher

These two built-in switcher options are included with Actipro Docking & MDI:

  • Simple
  • Standard

This topic contains these sections:

  • Activation Key Gestures
  • Configuration
  • The Simple Switcher
  • The Standard Switcher

Activation Key Gestures

If a switcher is available, these key gestures will activate it:

Key | Description
Ctrl+Tab | Select the next document.
Alt+F7 | Select the next tool window.
Ctrl+Shift+Tab | Select the previous document.
Shift+Alt+F7 | Select the previous tool window.

You can customize the key gestures above by changing these properties:

Member | Description
SelectNextDocumentKeyGesture Property | Gets or sets the KeyGesture that is used to select the next document. The default value is Ctrl+Tab.
SelectNextToolWindowKeyGesture Property | Gets or sets the KeyGesture that is used to select the next tool window. The default value is Alt+F7.
SelectPreviousDocumentKeyGesture Property | Gets or sets the KeyGesture that is used to select the previous document. The default value is Ctrl+Shift+Tab.
SelectPreviousToolWindowKeyGesture Property | Gets or sets the KeyGesture that is used to select the previous tool window. The default value is Shift+Alt+F7.

Configuration

By default the DockSite is assigned a StandardSwitcher to its Switcher property.

You can clear the Switcher property to not use switchers, or can set that property to another SwitcherBase-inherited class instance to use another switcher. StandardSwitcher and SimpleSwitcher are implementations of SwitcherBase.

This sample XAML code shows how to use a simple switcher for a dock site.

XAML
Copy
​<docking:DockSite>
    <docking:DockSite.Switcher>
        <docking:SimpleSwitcher />
    </docking:DockSite.Switcher>
</docking:DockSite>

The Simple Switcher

The simple switcher does not display a user interface. Instead, pressing the switcher key gestures will toggle through the various documents and tool windows.

The Standard Switcher

The standard switcher is more advanced and displays a user interface shown in the screenshot above. It shows multiple columns of open tool windows and documents. You also can use the arrow keys to navigate through the windows while the switcher is open.

There are many properties that allow you to completely customize the appearance of the switcher. Everything from the appearance of items to the number of document columns can be set.

Member | Description
AreDocumentsVisible Property | Gets or sets a value indicating whether the documents are visible in the switcher. The default value is true.
AreToolWindowsVisible Property | Gets or sets a value indicating whether the tool windows are visible in the switcher. The default value is true.
DropShadowZOffset Property | Gets or sets the z-offset of the drop shadow. The default value is 6.
FooterTemplate Property | Gets or sets the DataTemplate to use for the footer area of the switcher, whose content is the SelectedWindow.
HeaderTemplate Property | Gets or sets the DataTemplate to use for the header area of the switcher, whose content is the SelectedWindow.
ItemContainerStyle Property | Gets or sets the Style to use for rendering items.
ItemTemplate Property | Gets or sets the DataTemplate to use for rendering items.
MaxDocumentColumnCount Property | Gets or sets the maximum number of document columns to display. The default value is 3.
MaxRowCount Property | Gets or sets the maximum number of item rows that can be displayed. The default value is 15.
ScrollButtonStyle Property | Gets or sets the Style to use for a scroll button.
ScrollDownButtonContentTemplate Property | Gets or sets the DataTemplate to use for the scroll down button content.
ScrollUpButtonContentTemplate Property | Gets or sets the DataTemplate to use for the scroll up button content.

In scenarios where you don't use tool windows at all, set the AreToolWindowsVisible property to false. Likewise, if you don't use MDI, set the AreDocumentsVisible property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Docking & MDI supports an optional workspace area, which can contain custom content or multiple types of MDI (multiple document interface).

Workspace

The workspace is the central area of a dock site hierarchy, around which tool windows are docked. It can contain optional MDI hosts or can host any other sort of content.

See the Workspace topic for more information.

Tabbed MDI

Tabbed MDI is the default type of MDI found in most modern applications and is fully supported by Actipro Docking & MDI.

See the Tabbed MDI topic for more information.

Standard MDI

A standard (windowed) MDI option is implemented by Actipro Docking & MDI via a WindowControl control that mimics the functionality of a native window with resizable borders, minimize/maximize/close buttons, etc.

See the Standard MDI topic for more information.

Working with Documents

All documents can be easily managed via DockSite properties and methods, regardless of whether tabbed or standard MDI is in use. This allows your document-related code to remain the same regardless of the style of MDI in use.

See the Working with Documents topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Workspace

The workspace is the central area of a dock site hierarchy, around which tool windows are docked. It can contain optional MDI hosts or can host any other sort of content.

A workspace with custom content (the Actipro logo)

This topic contains these sections:

  • Control and Hierarchy
  • Workspace with Custom Content
  • Workspace with Tabbed MDI
  • Workspace with Standard MDI
  • MDI Only (No Tool Window Hierarchy)
  • Switching MDI Modes at Run-Time
  • Determining the Location of a Tool Window in Relation to the Workspace

Control and Hierarchy

A workspace is implemented by the Workspace control. Only one Workspace can be included within a dock host hierarchy at a time.

If no workspace is within a dock host hierarchy, tool window inner-fill mode is activated.

See the Control Hierarchy topic for help on which controls can be parents to a workspace.

Workspace with Custom Content

As mentioned above, any sort of content can be placed as the child of a workspace. Just set the custom content to the Content property of the Workspace.

The screenshot above shows a workspace with custom content loaded.

When placing custom content in a workspace, a TabbedMdiHost or StandardMdiHost can optionally be the content. If neither host is defined as the workspace content, then no MDI features will be available.

Workspace with Tabbed MDI

If you want to have tabbed MDI features in your docking layout, you must place a TabbedMdiHost control directly as the Content of the Workspace.

The DockSite.MdiKind property returns Tabbed when a tabbed MDI host is present. Additionally, DockSite.PrimaryDockHost.MdiHost returns the MDI host registered with the primary dock host (the one implicitly defined within the dock site).

Tabbed MDI will not function correctly if the TabbedMdiHost is placed elsewhere.

Workspace with Standard MDI

If you want to have standard MDI features in your docking layout, you must place a StandardMdiHost control directly as the Content of the Workspace.

The DockSite.MdiKind property returns Standard when a standard MDI host is present. Additionally, DockSite.PrimaryDockHost.MdiHost returns the MDI host registered with the primary dock host (the one implicitly defined within the dock site).

Standard MDI will not function correctly if the StandardMdiHost is placed elsewhere.

MDI Only (No Tool Window Hierarchy)

In some scenarios you may wish to have MDI functionality but no tool windows surrounding the MDI area.

To achieve this, place the Workspace directly as a child of the DockSite. And use either a TabbedMdiHost or a StandardMdiHost as a child of the workspace, depending on which type of MDI you wish to have.

Switching MDI Modes at Run-Time

You can easily switch between MDI modes at run-time by setting the DockSite.MdiKind property. When switching modes, all open documents should remain open.

Determining the Location of a Tool Window in Relation to the Workspace

The ToolWindow.GetCurrentSide method can be used to determine where an open tool window is in relation to the workspace.

See the Lifecycle and Docking Management topic for some more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tabbed MDI

Tabbed MDI is the default type of MDI found in most modern applications and is fully supported by Actipro Docking & MDI.

Tabbed MDI without any tool windows active

With tabbed MDI, the Workspace area is filled with one or more tab controls (implemented by TabbedMdiContainer) where each tab provides access to its related docking window.

This topic contains these sections:

  • Implementation and Hierarchy
  • Tab Layout Kinds (Pinned, Normal, Preview)
  • Behavior Options
  • Tab Close Buttons
  • Tab Pin Buttons
  • Title vs. Tab Text
  • Tab Tool Tip
  • Tab Images
  • Tab Contextual Content
  • Tab Strip Placement
  • Tab Overflow Behavior
  • Tab Insertion Order
  • New Tab Buttons
  • Content for Empty MDI Hosts
  • Listing All Documents in the MDI Host
  • Cascading Documents
  • Tiling Documents
  • Switching to Tabbed MDI at Run-Time
  • Floating Documents
  • Tab Control Custom Styling
  • Keyboard Shortcuts

Implementation and Hierarchy

At design-time, the MDI area can be instantiated via XAML code. The Control Hierarchy topic has a diagram showing the controls that are needed to implement this type of MDI from XAML. But essentially, to have tabbed MDI features available in your docking layout, you must place a TabbedMdiHost control directly as the Content of the Workspace within the dock site.

At run-time, you can use the common document framework (shared with standard MDI) to manage the documents in the MDI area. The Working with Documents topic describes how to interact with this common document framework to open and close documents along with performing other common tasks. But before doing so, please ensure that a TabbedMdiHost control is the direct Content of the Workspace within the dock site.

Tab Layout Kinds (Pinned, Normal, Preview)

There are three kinds of tabs available: pinned, normal, and preview.

The three kinds of tabs

Normal tabs are the default kind of tab and render normally.

Pinned tabs are tabs that have been pinned by the end user and align to the leftmost end of the tab strip. They also render like normal tabs other than having an unpin button visible.

Preview tabs render on the far right side of the tab strip, generally in a slightly faded-out appearance. They have a keep open button visible that when clicked, will make the tab a normal tab. It is advisable to only have a single preview tab in the UI at any given time.

Switching Kinds

The DockingWindow.TabbedMdiLayoutKind property specifies which kind of tab to use for the docking window when in tabbed MDI.

The end user can use context menus and tab buttons when appropriate to alter the tab layout kind. You can toggle it manually by setting the above property.

Behavior Options

Tabbed MDI has numerous behavior capability options that are available. Several of these are global settings (like TabbedMdiHost.CanDocumentsAttach) and can be overridden by related window-instance settings on the DockingWindow class.

Member | Description
TabbedMdiHost.CanDocumentsAttach Property | Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping. The default value is true.
TabbedMdiHost.CanDocumentsCloseOnMiddleClick Property | Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button. The default value is true.
TabbedMdiHost.CanDocumentTabsDrag Property | Gets or sets the global setting for whether document tabs may be dragged to another location. The default value is true.

Tab Close Buttons

By default, a close button appears directly on the tabs. This feature can be disabled by setting the TabbedMdiHost.HasTabCloseButtons property to false.

Tab Pin Buttons

By default, no pin button appears directly on 'normal' tabs. This feature can be enabled by setting the TabbedMdiHost.HasTabPinButtons property to true. That option will force a pin button to show on 'normal' tabs when the pointer is over the tab.

Title vs. Tab Text

The DockingWindow.Title property is normally set to determine the title text that is rendered in tabs as well as in title bars and on the standard switcher. In some cases, it might be desirable to have longer text for the Title, such as "Properties - Document1.txt", while having shorting text that renders on tabs, such as "Properties". This allows your title to provide more extensive contextual information.

By setting the TabText property to a non-null value, its value will be used to render the tab text instead of the Title value. In that scenario, the Title value will still be used in title bars and on the standard switcher when the window is selected.

Tab Tool Tip

The DockingWindow.TabToolTip property is automatically bound to the Title property for tool windows and to the FileName property for document windows. Override the TabToolTip property to set alternate tool tip content.

Tab Images

By default the DockingWindow.ImageSource image will not appear on document tabs.

You can force the image to display on the tabs by setting the TabbedMdiHost.HasTabImages property to true.

Tab Contextual Content

Tabbed MDI tabs can display any context-related content to the right of the tab title. This content is set via the DockingWindow.TabbedMdiTabContextContentTemplate property.

See the Contextual Content topic for some more information.

Tab Strip Placement

By default the document tabs will appear above their content, but can be changed to appear on any side of the content.

You can alter the location of the document tabs by changing the value of the TabbedMdiHost.TabStripPlacement property.

Tab Overflow Behavior

There are numerous options from the TabOverflowBehavior enumeration for selecting what happens when the tabs overflow the available tab strip space.

By default, a menu button is displayed that lists all open documents for a container when clicked. This can be changed via the TabbedMdiHost.TabOverflowBehavior property.

Tab Insertion Order

The DockSite.AreNewTabsInsertedBeforeExistingTabs property determines whether new tabs are inserted at the start of a tabbed MDI container. It defaults to true and may be set to false to add new tabs at the end of the container instead.

New Tab Buttons

The TabbedMdiHost.ContainersHaveNewTabButtons property can be set to true to display a new tab button. When this button is clicked, the DockSite.NewWindowRequested event fires. A handler of this event should activate a new document.

This feature is useful for browser-like applications and works best when the TabOverflowBehavior is set to Shrink or ShrinkWithMenu.

Content for Empty MDI Hosts

The TabbedMdiHost.EmptyContentTemplate property can be set to a DataTemplate that should be displayed in the MDI host whenever there are no documents open. If additional data needs to be passed into the data template, set it to the EmptyContent property.

This is a great place to place a company or application logo, or give end users instructions on what to do next to open a document.

Listing All Documents in the MDI Host

The TabbedMdiHost.GetDocuments method returns a list of all documents that are within the MDI host.

Cascading Documents

Call the TabbedMdiHost.Cascade method to automatically cascade the documents into a single TabbedMdiContainer.

Alternatively, the DockSite.CascadeDocuments method provides access to the same functionality but for all MDI hosts, including those on primary and floating dock hosts.

Tiling Documents

The tiling of documents makes more efficient use of space and will position each document so that it is visible within the workspace.

Call the TabbedMdiHost.TileHorizontally method to tile documents horizontally. Likewise, the TabbedMdiHost.TileVertically method will tile documents vertically.

Alternatively, two methods on DockSite, TileDocumentsHorizontally and TileDocumentsVertically, provide access to the same functionality but for all MDI hosts, including those on primary and floating dock hosts.

Switching to Tabbed MDI at Run-Time

You can easily switch to tabbed MDI mode at run-time by setting the DockSite.MdiKind property to Tabbed, as long as a Workspace is defined in the dock site.

Floating Documents

While disabled by default, document windows can be floated, similar to tool windows.

Tabbed MDI with a floating document

To float a document window, click on the associated tab and drag it away from the tabbed MDI host. A floating dock host is created with its own tabbed MDI host that contains the dragged document. The document can be redocked at any time.

To enable this feature and allow document windows to be floated, set the DockSite.CanDocumentWindowsFloat property to true.

Tab Control Custom Styling

The TabbedMdiHost.TabControlStyle property can be set to a custom Style for the AdvancedTabControl that is used within the templates of TabbedMdiContainer controls in the host.

The TabbedMdiHost.TabItemContainerStyle property can be set to a custom Style for the AdvancedTabItem controls that render the tabs within those AdvancedTabControl controls.

Use these properties to customize the appearance of the tab controls and their tabs.

This code shows the default XAML assigned to the TabbedMdiHost.TabItemContainerStyle property:

XAML
Copy
​<Style TargetType="docking:AdvancedTabItem">
    <Setter Property="Header" Value="{Binding TabTextResolved}" />
    <Setter Property="HeaderTemplate">
        <Setter.Value>
            <DataTemplate>
                <TextBlock Text="{Binding}" TextTrimming="CharacterEllipsis" VerticalAlignment="Center" />
            </DataTemplate>
        </Setter.Value>
    </Setter>
</Style>

Keyboard Shortcuts

The Alt+- keyboard shortcut shows the context menu for the currently selected document in the active tabbed MDI container.

The Ctrl+Alt+DownArrow keyboard shortcut shows the document list menu for the active tabbed MDI container.

Other keyboard shortcuts allow you to jump directly to a tab. Ctrl+1 will activate the first tab in a normal state, with Ctrl+2 activating the second normal tab, and so on. Ctrl+Alt+1 will activate the first tab in a pinned state, with Ctrl+Alt+2 activating the second pinned tab, and so on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Standard MDI

A standard (windowed) MDI option is implemented by Actipro Docking & MDI via a WindowControl control that mimics the functionality of a native window with resizable borders, minimize/maximize/close buttons, etc.

A context menu is displayed whenever clicking the window icon or right-clicking the title bar.

Standard MDI without any tool windows active

Standard MDI is the first style of MDI found in Windows and still remains popular in certain applications. Each document is represented as its own window and can be moved, resized, minimized, maximized, restored, and closed.

This topic contains these sections:

  • Implementation and Hierarchy
  • Allowing Windows to Maximize/Minimize
  • Window State
  • Restored Window Bounds
  • Making Windows Maximized
  • Hiding Frames when Maximized
  • Size-to-Content
  • Magnetism
  • Title Bar Contextual Content
  • Listing All Documents in the MDI Host
  • Cascading Documents
  • Tiling Documents
  • Arranging Minimized Windows
  • Scrolling
  • Switching to Standard MDI at Run-Time

Implementation and Hierarchy

At design-time, the MDI area can be instantiated via XAML code. The Control Hierarchy topic has a diagram showing the controls that are needed to implement this type of MDI from XAML. But essentially, to have standard MDI features available in your docking layout, you must place a StandardMdiHost control directly as the Content of the Workspace within the dock site.

At run-time, you can use the common document framework (shared with tabbed MDI) to manage the documents in the MDI area. The Working with Documents topic describes how to interact with this common document framework to open and close documents along with performing other common tasks. But before doing so, please ensure that a StandardMdiHost control is the direct Content of the Workspace within the dock site.

Allowing Windows to Maximize/Minimize

The maximize and minimize buttons on windows within the standard MDI area can be selectively shown or hidden using the StandardMdiHost.CanWindowsMaximize and StandardMdiHost.CanWindowsMinimize properties, respectively.

Individual windows can have its maximize and minimize buttons selectively shown or hidden using the DockingWindow.CanStandardMdiMaximize and DockingWindow.CanStandardMdiMinimize properties, respectively.

In addition to hiding the maximize button, the StandardMdiHost.CanWindowsMaximize and DockingWindow.CanStandardMdiMaximize properties will disable the ability to double click the titlebar of a window to maximize it. Windows that do not display their maximize or minimize buttons can still be programmatically maximized/minimized.

Window State

The state, such as normal/minimized/maximized, of the MDI child windows can be retrieved or set using the DockingWindow.StandardMdiWindowState property.

Restored Window Bounds

The restored window bounds and be retrieved or set using the DockingWindow.StandardMdiBounds property.

Making Windows Maximized

The StandardMdiHost.AreWindowsMaximized property gets or sets whether the windows within the standard MDI area are currently maximized.

If you wish for your windows to be opened as maximized by default, set it to true.

Hiding Frames when Maximized

The StandardMdiHost.AreMaximizedWindowFramesVisible can be set to false to hide the title bar and frame of the child MDI windows when they are maximized. This gives more room to the MDI window and is typical for a standard MDI layout.

When hiding the frame, the title and minimize/restore/close buttons are typically presented by an assocated Ribbon, toolbar, or menu of the containing window/control. The Sample Browser includes a 'Standard MDI-Only' sample that show how this can be accomplished.

When using external buttons to manage the windows, these StandardMdiHost commands are available for use with the buttons: MinimizePrimaryWindowCommand, RestorePrimaryWindowCommand, MaximizePrimaryWindowCommand, and ClosePrimaryWindowCommand.

Size-to-Content

If you wish for a docking window to auto-size itself to its content when opened in standard MDI, update its DockingWindow.SizeToContentModes property to contain the SizeToContentModes.StandardMdi flag.

Magnetism

Magnetism allows windows within the standard MDI area to be "snapped" together when moving or resizing. This makes it easier for the end-user to line up the windows into rows or columns.

Magnetism can be configured using DockSite.MagnetismSnapDistance and DockSite.MagnetismGapDistance. The snap distance indicates the distance at which magnetism begins to snap windows being dragged. The gap distance indicates the distance between windows that are snapped together via magnetism. Magnetism can be disabled by setting the snap distance to 0.

Title Bar Contextual Content

Standard MDI window title bars can display any context-related content to the right of the tab title. This content is set via the DockingWindow.StandardMdiTitleBarContextContentTemplate property.

See the Contextual Content topic for some more information.

Listing All Documents in the MDI Host

The StandardMdiHost.GetDocuments method returns a list of all documents that are within the MDI host.

Cascading Documents

Call the StandardMdiHost.Cascade method to automatically cascade the documents as displayed in the screenshot above.

Alternatively, the DockSite.CascadeDocuments method provides access to the same functionality but for all MDI hosts, including those on primary and floating dock hosts.

By default, the documents will automatically be cascaded on the initial load of the standard MDI host. This behavior can be disabled by setting the StandardMdiHost.IsAutoCascadeEnabled property to false.

Tiling Documents

The tiling of documents makes more efficient use of space and will position each document so that it is visible within the workspace. The visible documents fill the entire workspace area.

Call the StandardMdiHost.TileHorizontally method to tile documents horizontally. Likewise, the StandardMdiHost.TileVertically method will tile documents vertically.

Alternatively, two methods on DockSite, TileDocumentsHorizontally and TileDocumentsVertically, provide access to the same functionality but for all MDI hosts, including those on primary and floating dock hosts.

Arranging Minimized Windows

Call the StandardMdiHost.ArrangeMinimizedWindows method to automatically arrange the minimized windows at the bottom of the MDI host.

Scrolling

By setting the StandardMdiHost.IsScrollingEnabled property to true, scrolling support can be enabled in the standard MDI host. This allows MDI child windows to be dragged out of view, while still allowing the end-user to easily bring it back into view.

This setting is set to false by default.

Switching to Standard MDI at Run-Time

You can easily switch to standard MDI mode at run-time by setting the DockSite.MdiKind property to Standard, as long as a Workspace is defined in the dock site.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Working with Documents

All documents can be easily managed via DockSite properties and methods, regardless of whether tabbed or standard MDI is in use. This allows your document-related code to remain the same regardless of the style of MDI in use.

This topic contains these sections:

  • Creating a New Document
  • Additional Document Window Properties
  • Opening a Document
  • Activating a Document
  • Enumerating Open Documents
  • Primary Document
  • Working with Open Documents
  • Closing a Document
  • Contextual Content
  • Read-Only Documents

Creating a New Document

A document is just a term referring to a docking window (either a tool or document window) that is in the MDI area.

See the Lifecycle and Docking Management topic for details on how to create a new docking window via code.

Additional Document Window Properties

Document windows have a couple additional properties that aid in their user interface presentation.

The DocumentWindow.FileName property should be set to the full file or URL path of the document content, if appropriate. If this doesn't apply, leave the value null.

The DocumentWindow.Description property should be set to a description of the document type, such as: Text document This value gets displayed on a standard switcher.

Opening a Document

Opening a document will make it visible in the UI, but it won't necessarily be selected or have focus. To ensure a document is opened, selected, and focused, it must be activated instead.

A call to the DockingWindow.Open method will open the document. Alternatively, the IsOpen property can be set to true.

DocumentWindow controls will always open in the MDI area. ToolWindow controls on the other hand will only open in the MDI area if their State is Document before the open occurs.

Activating a Document

Activating a document will open it, select it, and focus its content as well. There is no need to open a document before activating it, because activating includes the open behavior.

A call to the DockingWindow.Activate method will activate the document. An overload of this method allows you to ensure the document is selected but not focused. Alternatively, the IsActive property can be set to true.

As described above, to ensure that a ToolWindow opens in the MDI area, make sure its State property is set to Document before activating it.

Enumerating Open Documents

Use the DockSite.Documents collection to enumerate through the open documents.

Sort the collection by DockingWindow.LastActiveDateTime to order them by which the documents were last activated.

The DockSite.HasDocuments property indicates whether there are currently any open documents.

Primary Document

The DockSite.PrimaryDocument property gets the document that currently is the primary document in the dock site. The primary document is the same as DockSite.ActiveWindow if the active window is a document. When the DockSite.ActiveWindow is not a document, then the primary document is the open document that was last activated.

The DockSite.PrimaryDocumentChanged event fires whenever the primary document changes.

Working with Open Documents

There are numerous DockSite methods that can be used to manipulate open documents.

Member | Description
ActivateNextDocument Method | Activates the next document.
ActivatePreviousDocument Method | Activates the previous document.
ActivatePrimaryDocument Method | Activates the primary (currently selected) document DockingWindow, if there is one.
CascadeDocuments Method | Cascades all open documents, if using tabbed or standard MDI.
CloseAllDocuments Method | Closes all open documents.
ClosePrimaryDocument Method | Closes the primary (currently selected) document DockingWindow if there is one.
TileDocumentsHorizontally Method | Tiles all open documents horizontally, if using tabbed or standard MDI.
TileDocumentsVertically Method | Tiles all open documents vertically, if using tabbed or standard MDI.

Closing a Document

A document can be closed by calling its DockingWindow.Close method.

Note Note
For document windows this will also destroy the window by default unless the DockSite.AreDocumentWindowsDestroyedOnClose property is set to false.

Contextual Content

Tabbed MDI tabs and standard MDI window title bars can display custom contextual content such as buttons or status indicators.

See the Contextual Content topic for some more information.

Read-Only Documents

Document windows have a special feature for automatically supporting the representation of read-only states. When a document window should be marked as read-only in the user interface, set DocumentWindow.IsReadOnly property to true. This will display a small lock context icon next to the document title.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Docking & MDI has an enormous feature set related to layouts, globalization and accessibility.

Layout Serialization

The full tool window layout can be saved to XML and restored later, allowing end users to retain their customized layout information across multiple application executions.

See the Layout Serialization topic for more information.

Nested Dock Sites

Dock sites can be nested, where a child DockSite is placed within a document window or tool window of an ancestor DockSite.

See the Nested Dock Sites topic for more information.

Side-by-Side Dock Sites

Dock sites are completely self-contained, meaning that you can have two DockSite in the same Window and tool windows belonging to one can't be moved into other, and vice versa.

See the Side-by-Side Dock Sites topic for more information.

Tool Window Inner-Fill

Actipro Docking & MDI supports tool window inner-fill mode, in which all tool windows fill the entire content area of the ancestor DockSite.

See the Tool Window Inner-Fill topic for more information.

Programmatic Layout

This topic covers several methods for programmatically arranging and resizing the docking windows.

See the Programmatic Layout topic for more information.

Flow Direction

Docking & MDI supports both left-to-right and right-to-left layouts via a simple property switch.

See the Flow Direction topic for more information.

Localization

All strings that are displayed in the user interface can be customized and localized. In addition, all user interface text properties have the Localizability attribute applied to them.

See the Localization topic for more information.

UI Automation

This product follows the WPF accessibility model for UI automation.

See the UI Automation topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Layout Serialization

The full window layout can be saved to XML and restored later, allowing end users to retain their customized layout information across multiple application executions.

Window layout data stores the location, size, state, and other related information for all document and tool windows currently being managed by the dock site.

This topic contains these sections:

  • Requirements for Docking Windows to Serialize Properly
  • Saving Layout Data
  • Loading Layout Data
  • Window Deserialization Behaviors
  • Keeping All Existing Documents Open
  • Persisting Custom Data in the Layout Data
  • Optimal Memory Utilization when Using Layout Serializers
  • Disabling Floating Window Snap-to-Screen

Requirements for Docking Windows to Serialize Properly

When serializing a layout, each ToolWindow and DocumentWindow must have either its SerializationId or Name property set to a unique value. These properties are used to restore the layout later by matching the docking windows in the layout with already-registered docking windows in the dock site, meaning tool windows in the DockSite.ToolWindows collection and document windows in the DockSite.DocumentWindows collection.

The Name property is only used for matching if the SerializationId property is not specified. Thus, SerializationId has a higher priority than Name in terms of which property is used to match layout data with registered docking window instances.

The SerializationId property is the preferred property to use for matching layout data with docking windows for two reasons. First, it can accept any text characters as its value, whereas the Name property must be a valid C#/VB identifier (underscore, letter, and number characters only). Second, it can be bound to in ways where the Name property might sometimes be restricted from supporting a binding.

Important Note Important Note
Please make sure every docking window has either a unique SerializationId or Name set as described above, or else layout deserialization will not work properly.

Docking windows can be individually prevented from serializing within a layout by setting their DockingWindow.CanSerialize property to false. This property defaults to true, meaning that all applicable docking windows will normally participate in the serialized layout.

Saving Layout Data

Dock site layout data can be persisted in XML format and loaded at a later time. Probably the two most common ways to store layouts are in files and in a database.

The DockSiteLayoutSerializer class fully implements the XML object hierarchy serialization framework described in the Serialization topic. Please see that topic for a list of methods that can be called for saving to files, string, etc.

This sample code shows how to save a DockSite layout to an XML string:

C#
VB
Copy
​string layout = new DockSiteLayoutSerializer().SaveToString(dockSite);
​Dim layout As String = New DockSiteLayoutSerializer().SaveToString(dockSite)

Saving the Entire Layout (Including Document Windows and MDI)

By default, only layout information of tool windows is serialized. The full layout, including document windows and the MDI layout, can be saved by setting the DockSiteLayoutSerializer.SerializationBehavior to DockSiteSerializationBehavior.All.

Loading Layout Data

When loaded, dock site layout data restores the location, size, and state of all document and/or tool windows. Layouts that include the full layout information (as described above), will restore document windows, tool windows, and the MDI layout.

The layout data loading code matches the SerializationId (or Name) of windows that were stored in the layout data to the SerializationId (or Name) of windows currently registered with the DockSite.

The DockSiteLayoutSerializer class fully implements the XML object hierarchy serialization framework described in the Serialization topic. Please see that topic for a list of methods that can be called for loading from files, string, etc.

This sample code shows how to load a DockSite layout from the XML string:

C#
VB
Copy
​new DockSiteLayoutSerializer().LoadFromString(layout, dockSite);
​New DockSiteLayoutSerializer().LoadFromString(layout, dockSite)

Window Deserialization Behaviors

When loading a previously saved layout, any document or tool windows that are missing will not have their layout restored. So if a tool window with the name "TW1" has size and position information in the layout string, but is not currently registered with the DockSite, then it's layout information is ignored.

There are two other behaviors supported, which allow the layout information to be retained and then applied to the associated window. These behaviors can be configured using the DocumentWindowDeserializationBehavior and/or ToolWindowDeserializationBehavior properties on DockSiteLayoutSerializer.

Lazy Loading

The window layout information will be applied to the DocumentWindow and/or ToolWindow later, when they are registered with the DockSite. When loading the layout data, the information for any missing document or tool windows is saved in the DockSite and applied if and when the window is ever created.

This allows the layout information to be properly restored, without have to immediately create the associated document or tool windows.

When using this feature, the DocumentWindow and/or ToolWindow must specify a unique SerializationId or Name so that its associated layout data can be found. In addition, when creating a DocumentWindow and/or ToolWindow its SerializationId or Name must be specified before it is registered with the DockSite. If this is not done, then the layout data will not be restored.

This sample code will not properly load the layout data, because the ToolWindow is registered before it SerializationId property is set:

C#
VB
Copy
​// INCORRECT
ToolWindow tw = new ToolWindow(this.dockSite) {
    SerializationId = "MyToolWindow",
};
​' INCORRECT
Dim tw As ToolWindow = New ToolWindow(Me.dockSite) {
    .SerializationId = "MyToolWindow"
}

This sample code will properly load the layout data, because the ToolWindow has its SerializationId property is set before it is registered:

C#
VB
Copy
​// CORRECT
ToolWindow tw = new ToolWindow() {
    SerializationId = "MyToolWindow",
};
this.dockSite.ToolWindows.Add(tw);
​' CORRECT
Dim tw As ToolWindow = New ToolWindow() {
    .SerializationId = "MyToolWindow"
}
Me.dockSite.ToolWindows.Add(tw)

This sample code will also properly load the layout data, because the ToolWindow has its SerializationId property value passed to the constructor:

C#
VB
Copy
​// CORRECT
ToolWindow tw = new ToolWindow(this.dockSite, "MyToolWindow", "Title", null, "Content");
​' CORRECT
Dim tw As ToolWindow = New ToolWindow(Me.dockSite, "MyToolWindow", "Title", Nothing, "Content")

Normally when a layout is serialized, the dock site's unused lazy load data for docking windows that have not yet been registered will be discarded in the serialized layout. This prevents the data from accumulating over time if you have a scenario where you dynamically create different docking windows with limited lifetime. In some cases, you may wish for this unused lazy load data to persist in the serialized layout. To enable this feature, set the DockSiteLayoutSerializer.CanSerializeUnusedLazyLoadData property to true.

Auto Creation

Alternatively, the missing document or tool windows can be automatically created and registered with the DockSite. During this process, certain information must be manually configured, such as the title, image, and content. There are two wasy that this can be done. First, by using the DockSiteLayoutSerializer.DockingWindowDeserializing or the DockSite.WindowsOpening event. Second, by using a custom class that derives from DocumentWindow or ToolWindow.

The DockSiteLayoutSerializer.DockingWindowDeserializing is fired before any document and/or tool window is deserialized. The event arguments are of type DockingWindowDeserializingEventArgs, which include the XML node from the layout data and the associated DockingWindow. When using auto-creation, the docking window is a new instance created during the deserialization process. The properties on this window can then be explicitly set, as needed. The event handler attached to DockingWindowDeserializing simply needs to check the name of the XML node to know the window for which the event was fired.

If the DockSite.WindowsOpening event is used instead, check to see if any of the windows specified in the event args have been initialized yet. If not, then set appropriate properties like title, image, and content on the uninitialized windows.

When using a custom class that derives from DocumentWindow or ToolWindow, the properties can be assigned in the constructor of the class. In addition, a XAML file with code-behind can be leveraged to allow the window to be designed in the Visual Studio designer.

Keeping All Existing Documents Open

When deserializing document layouts, all documents are closed and only those document windows that are listed in the layout data are re-opened. This means that if a document was open prior to the layout deserialization, but it is not listed within the layout data, it will be closed (and destroyed if DockSite.AreDocumentWindowsDestroyedOnClose is set).

Sometimes this is not desired, and you may wish to keep documents open that were already open prior to layout deserialization, but aren't in the layout data. This can be achieved by setting the DockSiteLayoutSerializer.CanKeepExistingDocumentWindowsOpen property to true.

Persisting Custom Data in the Layout Data

One benefit of our XML object hierarchy serialization framework is that you can insert and later retrieve information anywhere within the serialized data. Any time an object is serialized or deserialized, an event fires. You can intercept this event and save/load custom data.

The Serialization topic explains how to do this.

Optimal Memory Utilization when Using Layout Serializers

The layout serializer uses an XmlSerializer as the core .NET object that reads/writes XML data. One issue that has been discovered in the Microsoft .NET framework is that XmlSerializer is capable of creating memory leaks. The leak occurs whenever a new instance of XmlSerializer is created.

To combat this leak we've implemented some caching code on our end, but also highly recommend that instead of creating a new layout serializer any time you do a layout serialization, you instead keep a reference to a single app-wide instance of the layout serializer and use that for each layout serialization.

Disabling Floating Window Snap-to-Screen

By default, when a floating window is created and displayed for reasons other than a drag operation, such as when a layout containing floating windows is loaded, the floating windows will attempt to snap back onto their closest screen. This ensures that they are fully visible to the user and prevents scenarios where the user might have moved a floating window to a location where it is no longer visible on a screen due to screen resolution changes, etc.

This feature can be disabled by setting the DockSite.IsFloatingWindowSnapToScreenEnabled property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Nested Dock Sites

Dock sites are completely self-contained and can be nested, where a child DockSite is placed within a document window or tool window of an ancestor DockSite.

Nested dock sites where there are tool windows in inner-fill mode within a document window of another dock site

Many other competitive docking products don't support this feature.

This topic contains these sections:

  • Configuration and Features
  • A XAML Example

Configuration and Features

The creation of a nested dock site scenario is very easy. Just create a root DockSite then add a couple document windows. Within the first document window, place another inner DockSite control and add docking windows to it. Note that you could have chosen to place the child dock site in a tool window instead.

Now, when you drag tool windows around from the dock sites, notice how they remain self-contained within their own ancestor DockSite.

Also try to float a tool window from within the inner dock site. Then switch to the other document window. Notice how the floating tool window automatically closes. When you switch back to the original document window, the rafted window automatically reappears. This auto-close behavior can be disabled by setting the DockSite.CanFloatingDockHostsHideOnDockSiteUnload property to false.

A XAML Example
This sample XAML code shows how to create a nested scenario.
XAML
Copy
​<!-- Outer DockSite -->
<docking:DockSite>
    <docking:SplitContainer>
        <docking:Workspace>
            <docking:TabbedMdiHost>
                <docking:TabbedMdiContainer>

                    <docking:DocumentWindow Title="Document1">
                        <!-- Inner DockSite 1 -->
                        <docking:DockSite>
                            <docking:ToolWindowContainer>
                                <docking:ToolWindow Title="Inner DockSite 1-1">
                                    <TextBox BorderThickness="0" />
                                </docking:ToolWindow>
                                <docking:ToolWindow Title="Inner DockSite 1-2">
                                    <TextBox BorderThickness="0" />
                                </docking:ToolWindow>
                            </docking:ToolWindowContainer>
                        </docking:DockSite>
                    </docking:DocumentWindow>

                    <docking:DocumentWindow Title="Document2">
                        <!-- Inner DockSite 2 -->
                        <docking:DockSite>
                            <docking:ToolWindowContainer>
                                <docking:ToolWindow Title="Inner DockSite 2-1">
                                    <TextBox BorderThickness="0" />
                                </docking:ToolWindow>
                                <docking:ToolWindow Title="Inner DockSite 2-2">
                                    <TextBox BorderThickness="0" />
                                </docking:ToolWindow>
                            </docking:ToolWindowContainer>
                        </docking:DockSite>
                    </docking:DocumentWindow>

                </docking:TabbedMdiContainer>
            </docking:TabbedMdiHost>
        </docking:Workspace>

        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Outer DockSite 1">
                <TextBox BorderThickness="0" />
            </docking:ToolWindow>
            <docking:ToolWindow Title="Outer DockSite 2">
                <TextBox BorderThickness="0" />
            </docking:ToolWindow>
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Side-by-Side Dock Sites

Dock sites are completely self-contained, meaning that you can have two DockSite in the same Window and tool windows belonging to one can't be moved into other, and vice versa.

Two separate dock sites on the same Window

Many other competitive docking products don't support this feature.

This topic contains these sections:

  • Configuration and Features
  • A XAML Example

Configuration and Features

When placing two separate DockSite controls within a root container, they will automatically be independent of each other.

Tool windows will not be able to be dragged from one dock site into the other, unless you link the dock sites.

A XAML Example
This sample XAML code shows how to create a side-by-side scenario.
XAML
Copy
​<Grid>
    <Grid.RowDefinitions>
        <RowDefinition Height="Auto" />
        <RowDefinition Height="*" />
    </Grid.RowDefinitions>
    <Grid.ColumnDefinitions>
        <ColumnDefinition Width="*" />
        <ColumnDefinition Width="7" />
        <ColumnDefinition Width="*" />
    </Grid.ColumnDefinitions>

    <Border Padding="3">
        <TextBlock Text="DockSite #1" />
    </Border>

    <!-- DockSite #1 -->
    <docking:DockSite Grid.Row="1">
        <docking:DockSite.AutoHideLeftContainers>
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="DockSite 1-3" />
                <docking:ToolWindow Title="DockSite 1-4" />
            </docking:ToolWindowContainer>
        </docking:DockSite.AutoHideLeftContainers>

        <docking:SplitContainer>
            <docking:Workspace/>

            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="DockSite 1-1" />
                <docking:ToolWindow Title="DockSite 1-2" />
            </docking:ToolWindowContainer>
        </docking:SplitContainer>
    </docking:DockSite>

    <Border Grid.Column="2" Padding="3">
        <TextBlock Text="DockSite #2" />
    </Border>

    <!-- DockSite #2 -->
    <docking:DockSite Grid.Row="1" Grid.Column="2">
        <docking:DockSite.AutoHideRightContainers>
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="DockSite 2-3" />
                <docking:ToolWindow Title="DockSite 2-4" />
            </docking:ToolWindowContainer>
        </docking:DockSite.AutoHideRightContainers>

        <docking:SplitContainer>
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="DockSite 2-1" />
                <docking:ToolWindow Title="DockSite 2-2" />
            </docking:ToolWindowContainer>

            <docking:Workspace/>
        </docking:SplitContainer>
    </docking:DockSite>

</Grid>
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Linked Dock Sites

Dock sites are completely self-contained but they can be linked, which allows the document and tool windows from one dock site to be dragged/moved to the other dock site.

This topic contains these sections:

  • Linking/Unlinking Dock Sites
  • Programmatically Moving Windows
  • Preventing Windows from Dragging
  • Nested Dock Sites

Linking/Unlinking Dock Sites

A DockSite can be linked with one or more other DockSites using the DockSite.LinkDockSite method. This method only needs to be called on one of the dock sites, as both dock sites will be linked to each other.

Two dock sites can be unlinked using the DockSite.UnlinkDockSite method. Like with the LinkDockSite method, this method only needs to be called on one of the two linked dock sites.

The list of currently linked dock sites can be obtained using the DockSite.LinkedDockSites property.

Note Note
Dock sites hold weak references to their linked dock sites. This allows dock sites to be implicitly unlinked by allowing a dock site to fall out of scope and garbage collected.

Programmatically Moving Windows

The DockingWindow.MoveToLinkedDockSite method can be used to move a specific document or tool window to a linked dock site. After the method has been called, you can use any programmatic methods to open, dock, move to MDI, etc. the docking window within its new dock site.

Preventing Windows from Dragging

As soon as the dock sites are linked, the documents and/or tool windows can be moved between them, both programmatically and interactively. The DockSite.CanDocumentWindowsDragToLinkedDockSites can be set to false to prevent DocumentWindows from being interactively dragged between linked dock sites. To prevent ToolWindows from being interactively dragged to a linked dock site, the DockSite.CanToolWindowsDragToLinkedDockSites can be set to false. Alternatively, the DockingWindow.CanDragToLinkedDockSites property can be used to prevent windows from being dragged to linked dock sites on a window by window basis.

Nested Dock Sites

When nested dock sites are linked and you are dragging over multiple dock hosts, the dock guides will show for the dock host in the same dock site by default. Hold the Shift key while dragging to show the dock guides for an alternate dock host instead, which could be an inner or outer dock host.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tool Window Inner-Fill

Actipro Docking & MDI supports tool window inner-fill mode, in which all tool windows fill the entire content area of the ancestor DockSite.

Tool windows in inner-fill mode, where there is no MDI area

Many other competitive docking products don't support this feature.

Configuration and Features

Tool window inner-fill mode is achieved by omitting a Workspace from within the DockSite.

By leaving out the workspace, the dock site will automatically switch to tool window inner-fill mode. This is similar to the layout mode that is active for floating tool windows.

When in tool window inner-fill mode, no MDI is available and tool windows fill the entire content area of the dock site. Thus all layout sizing is done based on ratios of the initial ToolWindow.ContainerDockedSize values. For instance if two tool windows are docked next to each other, and the first has a ContainerDockedSize width of 100, while the second has a ContainerDockedSize width of 200, the second one will fill the area at twice the width of the first. If the dock site is 600 wide, the first tool window would be 200 wide, while the second would be 400 wide in that example.

A XAML Example
This sample XAML code shows how to create a tool window inner-fill scenario.
XAML
Copy
​<docking:DockSite x:Name="dockSite">
    <docking:DockSite.AutoHideLeftContainers>
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 8" />
            <docking:ToolWindow Title="Tool Window 9" />
        </docking:ToolWindowContainer>
    </docking:DockSite.AutoHideLeftContainers>
    <docking:DockSite.AutoHideBottomContainers>
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 10" />
            <docking:ToolWindow Title="Tool Window 11" />
        </docking:ToolWindowContainer>
    </docking:DockSite.AutoHideBottomContainers>

    <docking:SplitContainer>
        <docking:SplitContainer Orientation="Vertical">
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="Tool Window 1" />
                <docking:ToolWindow Title="Tool Window 2" />
            </docking:ToolWindowContainer>

            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="Tool Window 3" />
                <docking:ToolWindow Title="Tool Window 4" />
                <docking:ToolWindow Title="Tool Window 5" />
            </docking:ToolWindowContainer>
        </docking:SplitContainer>

        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 6" />
            <docking:ToolWindow Title="Tool Window 7" />
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Programmatic Layout

This topic covers several methods for programmatically arranging and resizing the docking windows.

This topic contains these sections:

  • Resizing Split Container Slots
  • Reversing Split Container Slots
  • Arranging Tabbed MDI Windows
  • Arranging Standard MDI Windows
  • Setting Docking Window Initial Sizes
  • Setting Docking Window Default Locations

Resizing Split Container Slots

The SplitContainer control is used to arrange the various docking elements vertically or horizontally, while also allowing dynamic resizing. The child elements of the SplitContainer are arranged into slots, which allows the elements to be sized proportionally as the SplitContainer is sized.

The SplitContainer.ResizeSlots method can be used to resize the associated slots, and therefore the underlying docking elements. The ResizeSlots method accepts zero or more ratios, represented by a double array. The ratios are used to calculate new sizes for the associated slots.

For example, this code shows a SplitContainer with two child elements, therefore the SplitContainer has two slots:

XAML
Copy
​...
<docking:SplitContainer Orientation="Horizontal">
    <docking:TabbedMdiContainer>
        <docking:DocumentWindow Title="Upper-1">
            <TextBox TextWrapping="Wrap" Text="A document window in the upper-left corner of the tabbed MDI area." />
        </docking:DocumentWindow>
    </docking:TabbedMdiContainer>
    <docking:TabbedMdiContainer>
        <docking:DocumentWindow Title="Upper-2">
            <TextBox TextWrapping="Wrap" Text="A document window in the upper-right corner of the tabbed MDI area." />
        </docking:DocumentWindow>
    </docking:TabbedMdiContainer>
</docking:SplitContainer>
...

This code can be used to evenly distribute the available space between the two elemnents in the above example:

C#
VB
Copy
​splitContainer.ResizeSlots();
​splitContainer.ResizeSlots()

This code can be used to give the first element twice as much space as the second element:

C#
VB
Copy
​splitContainer.ResizeSlots(2, 1);
​splitContainer.ResizeSlots(2, 1)

The only restriction on the ratios passed is that they be greater than 0. If there are more ratios than there are slots, then the extra ratios will be ignored. If there are more slots than there are ratios, then the last ratio will be repeated for the remaining slots. As a result, passing a single ratio is equivalent to not passing any ratios, since all the slots will share the same ratio.

There is no way to indicate that one slot should use star ('*') sizing. Instead, take into account the current size of the split container and adjust the ratios passed to the ResizeSlots method to get child controls into their desired sizes.

The above code shows how to call the ResizeSlots method, but does not illustrate how the reference to the SplitContainer was obtained.

Note Note
You should never used XAML name references to obtain a specific SplitContainer, as these elements are created and destroyed dynamically as changes are made to the docking layout.

The VisualTreeHelper and VisualTreeHelperExtended can be used to locate the various SplitContainer elements currently used. VisualTreeHelperExtended offers several helper methods for walking up and down the visual tree.

See the Media topic for more information on VisualTreeHelperExtended.

Reversing Split Container Slots

A SplitContainer.ReverseSlots helper method is available that reverses the order of all the children in the container.

This code reverses the order of the SplitContainer's children:

C#
VB
Copy
​splitContainer.ReverseSlots();
​splitContainer.ReverseSlots()

Arranging Tabbed MDI Windows

See the Tabbed MDI topic for more information on arranging tabbed MDI windows.

Arranging Standard MDI Windows

See the Standard MDI topic for more information on arranging standard MDI windows.

Setting Docking Window Initial Sizes

See the Lifecycle and Docking Management topic for more information on setting a different default initial size for docking windows.

Setting Docking Window Default Locations

See the Lifecycle and Docking Management topic for more information on setting a different default location for docking windows.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Flow Direction

Docking & MDI supports both left-to-right and right-to-left layouts via a simple property switch.

By default, Docking & MDI will use the flow direction designated by the system.

What is Flow Direction?

The flow direction of content typically corresponds to the innate flow direction of the language being represented. English, German, and Russian provide examples of languages that naturally flow from left-to-right. Hebrew and Arabic provide examples of languages that naturally flow from right-to-left.

When a right-to-left flow direction is applied to a user interface control, all contained content is essentially "flipped" over to align to the opposite side as displayed below:

Docking & MDI with a right-to-left flow direction

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Localization

All strings that are displayed in the user interface can be customized and localized. In addition, all user interface text properties have the Localizability attribute applied to them.

This topic contains these sections:

  • Customizing String Resources
  • Localizable Text Properties

Customizing String Resources

All strings that are displayed in the user interface are available from static methods on the ActiproSoftware.Products.Docking.SR class. Use that class to customize string resources as well.

Note Note
String resource customization is described in great detail in the general Customizing String Resources topic. Please see that topic for in-depth information related to localization of string resources.

An enumation named SRName includes a list of all the string resource names. A XAML markup extension named SRExtension is available for use within XAML templates to access string resources.

Localizable Text Properties

The following text properties are flagged as localizable via the Localizability attribute:

  • DockingWindow.Description
  • DockingWindow.TabText
  • DockingWindow.TabToolTip
  • DockingWindow.Title
  • DockingWindow.FloatingWindowTitle
  • WindowControl.Title

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UI Automation

Actipro Docking & MDI follows the accessibility model for UI automation.

What is UI Automation?

Microsoft UI Automation is the new accessibility framework for Microsoft Windows. It addresses the needs of assistive technology products and automated test frameworks by providing programmatic access to information about the user interface (UI).

Docking & MDI implements automation peers for the following classes:

  • The DockSite class, which is the manager of all docking functionality.
  • The DockHost class, which is the top-level container for all docking hierarchies.
  • The SplitContainer class, which contains two or more other containers in a docking hierarchy.
  • The DockingWindowContainerBase class, which is the base class of TabbedMdiContainer and ToolWindowContainer. This automation peer provides access to the child DockingWindow elements.
  • The StandardMdiHost class. This automation peer provides access to the child DockingWindow elements.
  • The DockingWindow class, which is the base class of DocumentWindow and ToolWindow.
  • The WindowControl class. This automation peer provides access to the child elements and programmatic access to move, resize, or close the window.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


MVVM Features

The Docking & MDI product has been designed to support the popular MVVM pattern. The DockSite control's item container generation features and infrastructure are similar to a standard ItemsControl, but geared towards the generation of docking windows.

Tip Tip
Many of the concepts below are implemented in the MVVM-related samples in the Sample Browser, so be sure to examine those samples.

This topic contains these sections:

  • Specifying Document and Tool Items
  • Styling the Document and Tool Windows
  • Layout Serialization Support
  • Opening and Positioning the Docking Windows
  • Item Containers
  • Item Container Unregistration Triggering Items Source Update
  • Troubleshooting

Specifying Document and Tool Items

The DockSite includes several properties and methods that mimic the design of the native ItemsControl. Using these properties and methods, the DockSite can be bound to a collection of view-models for documents and/or tool windows.

Document Windows

Document windows can be defined by binding the DockSite.DocumentItemsSource property to a collection of items, such as view-models. The items will be wrapped in an instance of DocumentWindow, which is the container used to present the item.

A Style can be applied to the generated DocumentWindow instances by using the DockSite.DocumentItemContainerStyle or DocumentItemContainerStyleSelector properties. Alternatively, an implicit Style for the DocumentWindow type can be defined and placed in the Application.Resources. The Style can be used to bind various properties of the DocumentWindow to the item.

The DataTemplate used by the DocumentWindow instances to present the associated item can be specified using the DockSite.DocumentItemTemplate or DocumentItemTemplateSelector properties. Alternatively, an implicit DataTemplate for the item's type can be defined and placed in the Application.Resources.

Tool Windows

Tool windows can be defined by binding the DockSite.ToolItemsSource property to a collection of items, such as view-models. The items will be wrapped in an instance of ToolWindow, which is the container used to present the item.

A Style can be applied to the generated ToolWindow instances by using the DockSite.ToolItemContainerStyle or ToolItemContainerStyleSelector properties. Alternatively, an implicit Style for the ToolWindow type can be defined and placed in the Application.Resources. The Style can be used to bind various properties of the ToolWindow to the item.

The DataTemplate used by the ToolWindow instances to present the associated item can be specified using the DockSite.ToolItemTemplate or ToolItemTemplateSelector properties. Alternatively, an implicit DataTemplate for the item's type can be defined and placed in the Application.Resources.

Container Customization

The DockSite includes several virtual methods that can be overridden to customize the containers created based on the bound items. These methods mimic the native ItemsControl and includes ClearContainerForItemOverride, GetContainerForItemOverride, IsItemItsOwnContainerOverride, and PrepareContainerForItemOverride. Each of these methods works like it's ItemsControl counterpart, with one exception. Each method includes an additional parameter that specifies whether the container is for a document or tool item.

The PrepareContainerForItemOverride method override could be used to bind your view model's properties to the containing docking window's related properties. The ClearContainerForItemOverride method override would clear those bindings. You don't need to override these methods if you are setting up your bindings in a Style instead that gets used by DocumentItemContainerStyle, ToolItemContainerStyle, etc.

Content and Template

As with a standard ItemsControl bound to a collection of view model items, each item will be assigned to the Content property of the generated container docking window.

These view model items require that a content template be specified to properly render their data. As mentioned above, the DocumentItemTemplate, DocumentItemTemplateSelector, ToolItemTemplate, and ToolItemTemplateSelector properties can be used to designate the DataTemplate to use for each item.

Styling the Document and Tool Windows

Custom styles can easily be applied to the DocumentWindow and/or ToolWindow containers created for the bound items. The DocumentItemContainerStyle, DocumentItemContainerStyleSelector, ToolItemContainerStyle, or ToolItemContainerStyleSelector properties can be used to apply a custom Style. Alternatively, an implicit Style for the DocumentWindow and/or ToolWindow types can be defined. The Style can be used to bind various properties of the DocumentWindow and/or ToolWindow to the item.

These styles pulled from our MVVM samples in the Sample Browser show how you can bind various view model properties to the docking windows. The resulting DocumentWindowStyle and ToolWindowStyle properties could then be set to the DockSite.DocumentItemContainerStyle and ToolItemContainerStyle properties respectively:

XAML
Copy
​xmlns:common="clr-namespace:ActiproSoftware.ProductSamples.DockingSamples.Common"
xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
...

<common:ToolItemDockSideConverter x:Key="ToolItemDockSideConverter" />
<common:ToolItemStateConverter x:Key="ToolItemStateConverter" />

<Style x:Key="DockingWindowStyle" TargetType="docking:DockingWindow">
    <Setter Property="Description" Value="{Binding Path=Description, Mode=TwoWay}" />
    <Setter Property="ImageSource" Value="{Binding Path=ImageSource, Mode=TwoWay}" />
    <Setter Property="IsActive" Value="{Binding Path=IsActive, Mode=TwoWay}" />
    <Setter Property="IsOpen" Value="{Binding Path=IsOpen, Mode=TwoWay}" />
    <Setter Property="IsSelected" Value="{Binding Path=IsSelected, Mode=TwoWay}" />
    <Setter Property="SerializationId" Value="{Binding Path=SerializationId, Mode=TwoWay}" />
    <Setter Property="Title" Value="{Binding Path=Title, Mode=TwoWay}" />
    <Setter Property="WindowGroupName" Value="{Binding Path=WindowGroupName, Mode=TwoWay}" />
</Style>

<Style x:Key="DocumentWindowStyle" TargetType="docking:DocumentWindow" BasedOn="{StaticResource DockingWindowStyle}">
    <Setter Property="FileName" Value="{Binding Path=FileName, Mode=TwoWay}" />
    <Setter Property="IsReadOnly" Value="{Binding Path=IsReadOnly, Mode=TwoWay}" />
</Style>

<Style x:Key="ToolWindowStyle" TargetType="docking:ToolWindow" BasedOn="{StaticResource DockingWindowStyle}">
    <Setter Property="DefaultDockSide" Value="{Binding Path=DefaultDockSide, Mode=TwoWay, Converter={StaticResource ToolItemDockSideConverter}}" />
    <Setter Property="State" Value="{Binding Path=State, Mode=TwoWay, Converter={StaticResource ToolItemStateConverter}}" />
</Style>

Layout Serialization Support

If you plan on serializing your layout between application execution sessions, you must assign your docking windows a unique Name or SerializationId. It is recommended that you use the SerializationId property since unlike the Name property, it can be bound easier and allows any character to be used in the value.

Opening and Positioning the Docking Windows

The DocumentWindow and/or ToolWindow containers created for the bound items will initially be closed and must be opened to appear in the visible layout.

Numerous bindable properties are available on DockingWindow for determining the state and position of docking windows, along with whether they are open and active. For instance, the State property can be set to designate which state the window should open in. This property must remain Document for any DocumentWindow. To open a docking window and add it to the layout, set its IsOpen property to true. To open a docking window (if it isn't already open) and ensure it's selected and focused, set its IsActive property to true. This can be done instead of setting IsOpen. Finally, to make sure an already-open docking window's tab is selected, set its IsSelected property to true.

When a docking window is opened via its IsOpen or IsActive properties, it will open in a default location. There are numerous properties and events available that allow you to customize this default location prior to opening the docking window. Some examples are ToolWindow.DefaultDockSide, DockingWindow.WindowGroupName, DockSite.WindowDefaultLocationRequested, etc.

If you prefer to open, activate, dock, etc. a docking window in code-behind instead, this can be easily accomplished by adding a handler for the DockSite.WindowRegistered event. This event is fired once per DocumentWindow and/or ToolWindow when it is initially registered with the DockSite.

The following code shows an example of a WindowRegistered handler:

C#
VB
Copy
​dockSite.WindowRegistered += this.OnDockSiteWindowRegistered;

// ...

/// <summary>
/// Handles the <c>WindowRegistered</c> event of the <c>DockSite</c> control.
/// </summary>
/// <param name="sender">The source of the event.</param>
/// <param name="e">The <see cref="DockingWindowEventArgs"/> instance containing the event data.</param>
private void OnDockSiteWindowRegistered(object sender, DockingWindowEventArgs e) {
    DockSite dockSite = sender as DockSite;
    if (dockSite == null)
        return;

    // Ensure the DockingWindow exists and is generated for an item
    DockingWindow dockingWindow = e.Window;
    if (dockingWindow == null || !dockingWindow.IsContainerForItem)
        return;

    // Open the DockingWindow, if it's not already open
    if (!dockingWindow.IsOpen) {
        // ** Open window in desired location here
    }
}
​AddHandler dockSite.WindowRegistered, AddressOf OnDockSiteWindowRegistered

' ...

''' <summary>
''' Handles the <c>WindowRegistered</c> event of the <c>DockSite</c> control.
''' </summary>
''' <param name="sender">The source of the event.</param>
''' <param name="e">The <see cref="DockingWindowEventArgs"/> instance containing the event data.</param>
Private Sub OnDockSiteWindowRegistered(ByVal sender As Object, ByVal e As DockingWindowEventArgs)
    Dim dockSite As DockSite = TryCast(sender, DockSite)
    If dockSite Is Nothing Then
        Return
    End If

    ' Ensure the DockingWindow exists and is generated for an item
    Dim dockingWindow As DockingWindow = e.Window
    If dockingWindow Is Nothing OrElse (Not dockingWindow.IsContainerForItem) Then
        Return
    End If

    ' Open the DockingWindow, if it's not already open
    If Not dockingWindow.IsOpen Then
        ' ** Open window in desired location here
    End If
End Sub

Item Containers

The DockingWindow.IsContainerForItem property returns true when a docking window is a generated container for an item in the DockSite.DocumentItemsSource or DockSite.ToolItemsSource collections.

The ContainerFromItem method can be used to retrieve the DocumentWindow or ToolWindow associated with a given item. If the type of the item is known, then the ContainerFromDocumentItem or ContainerFromToolItem methods can be used instead.

Item Container Unregistration Triggering Items Source Update

The DockSite.CanUpdateItemsSourceOnUnregister property indicates whether to watch the WindowUnregistered event for an item container DockingWindow to be unregistered. If that property is true, the dock site will try to automatically remove the related item from the appropriate DockSite.DocumentItemsSource or DockSite.ToolItemsSource collection.

The functionality will only succeed if the items source is an IList that is not read-only or fixed size.

In scenarios where the above conditions are not met, it is up to you to watch the WindowUnregistered event and remove the related item from its items source.

Troubleshooting

See the Troubleshooting topic for more information, with some specific details on configuring data contexts properly.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Interop Compatibility

There are several issues in general when embedding interop controls (such as WinForms, ActiveX, etc. controls) in docking window content. This topic discusses some of the ways Actipro Docking & MDI has been designed to improve compatibility with interop controls.

The two primary issues are:

  • Interop content is always rendered on top of WPF content in the same root window (a.k.a. the airspace issue).
  • Interop content doesn't always raise WPF focus-related events properly.

This topic contains these sections:

  • Quick Summary
  • Using Non-Hosted Popups
  • Live Splitting
  • Handling Focus Issues
  • How to Embed WinForms Content in a Docking Window
  • Impact of Transparent Backgrounds on Performance

Quick Summary

If you don't wish to read the details below, the way to enable maximum compatibility with interop controls is to:

  • Set the DockSite.UseHostedPopups property to false.
  • Set the DockSite.IsLiveSplittingEnabled property to false.
  • Set the InteropFocusTracking.IsEnabled attached property on all HwndHost instances (like WindowsFormsHost, etc.) to true.

Read the following sections for more information on interop compatibility.

Using Non-Hosted Popups

Due to the airspace rendering issue mentioned above, if your application will host interop content, set the DockSite.UseHostedPopups property to false. Setting that to false will allow auto-hide popups and splitters to properly appear above interop content.

This will also allow interop content to appear properly in the auto-hide popups because it will disable auto-hide popup animation, which sometimes causes rendering glitches in interop controls.

If you do not plan on having interop content in your application, we recommend leaving the UseHostedPopups property as its default value of true.

Live Splitting

By default, live splitting is enabled meaning that there is no preview highlight when dragging a splitter. The surrounding containers are immediately resized during splitter drags in this mode.

Sometimes this mode doesn't work well with interop controls since they could have glitchy rendering as they are resized. It's recommended to disable live splitting by setting the DockSite.IsLiveSplittingEnabled property to false. In that mode, the splitters in the dock site will only resize the content when the drag operation has been completed. A preview of the split location is shown as the user drags to indicate the relative sizes of the content if the user releases the pointer. This allows complex UI to only be rendered once, after the drag operation is completed.

Handling Focus Issues

There are known issues in core WPF with how it tracks and reports focus movement in and out of HwndHost. This makes it difficult to use standard WPF-based focus events when dealing with HwndHost-based scenarios, because the events don't fire properly.

We provide a workaround for most of these issues in the form of an InteropFocusTracking.IsEnabled attached property that should be set on any HwndHost-based control, such as WindowsFormsHost, WPF WebBrowser, etc. Set that attached property to true on such controls in your docking window hierarchy to enable our workarounds.

How to Embed WinForms Content in a Docking Window
This sample XAML code shows how to create a document window that contains a Windows Forms WebBrowser control embedded in it. Note that any WinForms controls must be wrapped with a WindowsFormsHost. Set the attached InteropFocusTracking.IsEnabled property on the WindowsFormsHost.
XAML
Copy
​xmlns:winforms="clr-namespace:System.Windows.Forms;assembly=System.Windows.Forms"
...

<docking:DockSite>
    <docking:Workspace>
        <docking:TabbedMdiHost>
            <docking:TabbedMdiContainer>
                <docking:DocumentWindow Title="Document1">
                    <WindowsFormsHost docking:InteropFocusTracking.IsEnabled="True">
                        <winforms:WebBrowser Url="http://www.actiprosoftware.com" />
                    </WindowsFormsHost>
                </docking:DocumentWindow>
            </docking:TabbedMdiContainer>
        </docking:TabbedMdiHost>
    </docking:Workspace>
</docking:DockSite>
Impact of Transparent Backgrounds on Performance
As a quick aside, we've noticed in certain scenarios that if you wrap a WindowsFormsHost with a control that has a Transparent background, core WPF can cause performance degradation in layout cycles due to how it's attempting to blend backgrounds with interop content. This sample XAML code shows the scenario:
XAML
Copy
​xmlns:winforms="clr-namespace:System.Windows.Forms;assembly=System.Windows.Forms"
...

<docking:DocumentWindow Title="Document1">
    <Border Background="Transparent">
        <WindowsFormsHost docking:InteropFocusTracking.IsEnabled="True">
            <winforms:WebBrowser Url="http://www.actiprosoftware.com" />
        </WindowsFormsHost>
    </Border>
</docking:DocumentWindow>

If the Background is left its default null value, or is set to a solid color, performance is significantly better. This can occur anywhere in WPF (not just the Docking/MDI product), and we wanted to pass along the tip.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AdvancedTabControl

Docking & MDI includes a very full-featured tab control named AdvancedTabControl that is extremely customizable and can be used independently of docking windows in your apps. AdvancedTabControl inherits the native WPF TabControl and extends it with many helpful features.

An AdvancedTabControl with curved, slanted, overlapping tabs

The type of item for the AdvancedTabControl is AdvancedTabItem. Make sure to use that type or a derived class whenever specifying tab items.

This topic contains these sections:

  • Selection
  • Tab Layout Kinds
  • Tab Images
  • Tab Overflow Behavior
  • Tab Strip Placement
  • Tab Content Orientation
  • Tab Control Appearance
  • Tab Appearance
  • New Tab Button
  • Embedded Buttons
  • Tab Closing
  • Tab Dragging to Reorder
  • Tab Selection on System Drag Over
  • Layout Animation
  • Menus
  • Keyboard Shortcuts

Selection

Just like with standard ItemsControl and Selector controls, the SelectedItem property specifies the item that is currently selected in the tab control. Note that in MVVM scenarios, this will return the item that is selected and not the AdvancedTabItem.

Tab Layout Kinds

Tabs can be displayed in three layout kinds within the tab control: pinned, normal, and preview. Each tab's layout kind is set via the AdvancedTabItem.LayoutKind property, which defaults to Normal.

Normal tabs appear normally and left-aligned within the tab strip. If the AdvancedTabControl.CanTabsPin is true they will show a pin button that allows them to change to the Pinned layout kind when clicked.

Pinned tabs always appear to the left of all normal tabs. They always show an unpin button that when clicked, will return them to Normal layout kind.

Preview tabs show up right-aligned in the tab strip. They are meant to show temporary contextual information. As long as the AdvancedTabControl.CanTabsPromote property remains its default true value, preview tabs will have a button on them that when clicked, will change the tab to a Normal layout kind.

Tab Images

Tabs can show images on them if the AdvancedTabControl.HasTabImages property is set to true and the AdvancedTabItem.ImageSource property is set to a valid ImageSource.

Tab Overflow Behavior

There are numerous options from the TabOverflowBehavior enumeration for selecting what happens when the tabs overflow the available tab strip space.

By default, the tabs shrink to fit within the available tab strip space. This can be changed via the AdvancedTabControl.TabOverflowBehavior property.

Tab Strip Placement

The tab strip can be located on any side (left, top, right, bottom) of the tab control. Use the TabStripPlacement property to adjust the side as needed.

Tab Content Orientation

Tabs will normally always display their content in a horizontal orientation, even when the tab strip placement is on the left or right.

Tab content can be rotated to a vertical orientation by setting the AdvancedTabControl.IsTabContentHorizontal property to false.

Tab Control Appearance

The tab control has several properties that adjust its own appearance.

Tab Strip Visibility

The tab strip can be hidden by setting the AdvancedTabControl.IsTabStripVisible property to false.

Highlight

The tab strip can display an optional highlight border around its outside. The border thickness is set by the AdvancedTabControl.HighlightThickness property and the brushes used to render the highlight are specified via the HighlightBrushInactive and HighlightBrushActive properties. Which one is used depends on if the tab control is marked active.

Flagging as Active

The AdvancedTabControl.IsActive property flags the tab control as whether it is currently active or not. This flag is generally set to true when the focus moves within the tab control. The active setting affects which brushes are used for highlight effects and tab rendering.

Tab Appearance

Numerous properties allow you to completely customize the appearance of tabs in the tab control.

Background, Border, and Foreground

There are numerous variations of properties like AdvancedTabControl.TabBackground, such as TabBackgroundPointerOver, etc. that determine the background brush used to render tabs in various layout kinds and states.

Likewise, similar sets of layout kind and state properties are available for TabBorderBrush and TabForeground.

Corner Radius

The AdvancedTabControl.TabCornerRadius property sets the corner radius of tab borders, relative to a top-facing tab.

Padding

The AdvancedTabControl.TabPadding property sets the tab padding, relative to a top-facing tab.

Spacing

The AdvancedTabControl.TabSpacing property, which defaults to 0, determines the amount of space between each tab. Set it to a negative value to have tabs overlap each other.

Minimum and Maximum Extents

The AdvancedTabControl.MinTabExtent and MaxTabExtent properties set the minimum and maximum extent (length) that a tab can be. Set these properties to the same value to create fixed size tabs.

Side Slant

The AdvancedTabControl.TabNearSlantExtent and TabFarSlantExtent properties set the amount of slant that tabs have on their near (left) and far (right) sides.

Highlighting Inactive Tabs On Pointer Over

The AdvancedTabControl.CanTabsHighlightOnPointerOverWhenInactive property sets whether tabs can highlight when the pointer is over inactive ones. The default value is false.

New Tab Button

A new tab button can be displayed by setting the AdvancedTabControl.HasNewTabButton property to true. The new tab button appears just to the right of the normal tabs. It is recommended that one of the shrink-related overflow behaviors is used when a new tab button is present.

The style of the button can be set with the NewTabButtonStyle property.

When the button is clicked, the NewTabRequested event fires. Handlers of that event should add a new tab to the control in response.

Embedded Buttons

The tab control and its tabs can embed several buttons. Tab control embedded buttons generally display in response to the tab overflow behavior setting. Several tab embedded buttons depend on the tab's layout kind and other options like AdvancedTabControl.HasTabCloseButtons.

Some tab embedded buttons are only visible when the tab is selected or in a pointer over state. The AdvancedTabControl.AreTabEmbeddedButtonsAlwaysVisible property sets whether tab embedded buttons are always visible, even when the tab is unselected.

The AdvancedTabControl.EmbeddedButtonStyle property allows you to customize the Style of tab control embedded buttons, while the TabEmbeddedButtonStyle property allows you to customize the Style of tab embedded buttons,

The AdvancedTabControl.MenuButtonContentTemplate, OverflowMenuButtonContentTemplate, ScrollBackwardButtonContentTemplate, and ScrollForwardButtonContentTemplate properties allow you to customize the DataTemplate of the related tab control embedded buttons.

Tab Closing

Tabs can close when their embedded close button is clicked or also on middle-click if the AdvancedTabControl.CanTabsCloseOnMiddleClick property is set to true. These features also require that the AdvancedTabItem.CanClose property is true.

When a tab is about to close, it raises the AdvancedTabControl.TabClosing event. If the Cancel flag is set to true in the event arguments, the close will not occur. This event is a good place to prompt the end user about unsaved changes, etc.

Tab Dragging to Reorder

While tabs do support dragging to reorder themselves, the feature is not enabled by default. To enable this behavior, set the AdvancedTabControl.CanTabsDrag property to true.

Tab Selection on System Drag Over

By default, performing a system (e.g. text, file) drag over a tab will select the tab so that the dragged content can be dropped on a control on the tab's content area. To disable this feature, set the AdvancedTabControl.CanTabsSelectOnDragOver property to false.

Layout Animation

By default, animation effects are applied during layout, such as when tabs are added or removed from the tab control. To disable these animation effects, set the AdvancedTabControl.IsLayoutAnimationEnabled property to false.

Menus

The AdvancedTabControl.MenuOpening event fires before a context or drop-down menu is opening. Its event arguments specify the related AdvancedTabItem, if any, along with the default menu that will be displayed. You can fully customize or change the menu to suit your needs.

Keyboard Shortcuts

When the AdvancedTabControl.IsTabKeyboardSwitchingEnabled property is true (the default), the Ctrl+Tab shortcut will switch to the next tab and the Ctrl+Shift+Tab shortcut will switch to the previous tab.

When the AdvancedTabControl.IsTabKeyboardAccessEnabled property is true (the default), keyboard access to directly select a tab is enabled. Ctrl+1 will activate the first tab in a normal state, with Ctrl+2 activating the second normal tab, and so on. Ctrl+Alt+1 will activate the first tab in a pinned state, with Ctrl+Alt+2 activating the second pinned tab, and so on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


WindowControl

During the implementation of standard MDI and hosted floating windows for this product, we ran into the need for a Window-like class that was skinnable and behaved like a regular Control. Thus we developed WindowControl, a control that looks and acts like a Window and can mimic both normal and tool window styles.

A WindowControl on top of a Canvas

WindowControl is a Control that implements most of same members as the standard WPF Window class.

This topic contains these sections:

  • What Can I Do with WindowControl?
  • Restrictions / XBAP Compatibility
  • Themes
  • Working with the WindowControl
  • Managing the Title Bar

What Can I Do with WindowControl?

Unlike a normal Window, WindowControl can be put in any control hierarchy. It also supports complete templating and can be animated.

Want to have a window that flies and rotates into view? No problem!

While we use WindowControl in two general areas in this product, we wanted to make it available to you as well in case you find your own uses for it.

Restrictions / XBAP Compatibility

Since WindowControl is a Control it still must be contained by a root Window (in Windows desktop apps) or a Page (in XBAPs). Yes, the control is fully compatible with XBAP.

Themes

This control has a number of built-in themes, with various Metro, Office, and operating system theme options.

Various built-in WindowControl themes

Working with the WindowControl

WindowControl inherits ContentControl so set its

As mentioned above we implemented many of the same members found in a WPF Window within WindowControl. You can set properties such as WindowState or ResizeMode. Browse through the members list on the WindowControl control to see what is available to you.

There are also a number of extra properties, methods, and events that aren't on Window, such as the ToggleWindowState method, the TitleBarMenuOpening event, etc.

Title bar drags and border resize operations will cause the control's Left, Top, Width, and Height properties to be altered. To support drag operations visually, place the WindowControl in a Canvas and bind the Canvas.Left attached property to the WindowControl.Left property, and Canvas.Top attached property to the WindowControl.Top property.

Managing the Title Bar

The title bar can be hidden entirely by setting HasTitleBar to false. Alternatively, the buttons, icon, and text displayed by the title bar can be customized as described below.

Buttons

A number of properties can be used to alter the state or visibility of the title bar buttons. By default, the current window state governs which of the minimize, restore, and maximize buttons are visible.

The CanClose property indicates if the close button is enabled.

Sometimes it is useful to be able to always force one or more of the buttons to be hidden. One use case is where you don't wish to allow minimization of the window and never want the minimize button visible. The HasMinimizeButton, HasRestoreButton, HasMaximizeButton, and HasCloseButton properties can be set to false to specify that their related button should never be visible.

Icon

An icon can be displayed by setting WindowControl.Icon to a valid ImageSource. By default, the icon is displayed when an valid image is specified. You can alter this behavior by explicitly setting WindowControl.HasIcon. Therefore, you can force the WindowControl to display the specified image by setting HasIcon to true.

Note Note
The icon is restricted to be 16 pixels wide by 16 pixels high.

Context Content

Additional context content can be added to the right of the title bar text by using the WindowControl.ContextContent, WindowControl.ContextContentTemplate, and WindowControl.ContextContentTemplateSelector properties.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Themes

This product includes multiple built-in themes for Metro, Office, and Windows system themes. It is fully extensible so that other product themes can be custom developed. Themes can be tinted towards any color or set of colors, and brush resources from them may be reused.

Note Note
Be sure to read the Actipro Themes product documentation too since that explains in great detail how the themes management works with Actipro controls.

This topic contains these sections:

  • Built-In Themes
  • Theme Catalog
  • Tinting Themes

Built-In Themes

Docking & MDI includes built-in themes that are color matched exactly with their real-world counterparts and Actipro's other controls like Ribbon.

Several built-in Docking & MDI themes

Theme Catalog

The DockingThemeCatalog is used to provide dynamic theme-switching to this product, and is automatically registered when WPF loads the system themes from the associated assembly.

To explicitly load and register the theme catalog, call the Register staic method on DockingThemeCatalogRegistrar.

Tinting Themes

Any theme can be completely or partially tinted towards a color or set of colors. The general Tinting topic explains how to perform tinting in detail.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to 2009.2 topic contains information on converting to 2009.2 from an older version.
  • The Converting to 2010.2 topic contains information on converting to 2010.2 from an older version.
  • The Converting to 2011.1 topic contains information on converting to 2011.1 from an older version.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from an older version.
  • The Converting to 2016.1 topic contains information on converting to 2016.1 from an older version.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2009.2

The release of version 2009.2 added Visual Studio 2010 features to the Docking & MDI product. This includes floating documents, maximizable rafting windows (non-hosted only), more intuitive dock guides, and much more.

All of the breaking changes are detailed below.

This topic contains these sections:

  • Changed Docking Window States
  • Changed Serialization Properties
  • Changed Docking Commands
  • Dock Target Changes
  • Drop Targets Consolidated
  • Dock Guide Cross Extended
  • Removed Unused Cursors

Changed Docking Window States

One feature that was removed from the 2009.2 release of Docking & MDI was the concept of floating windows, which was present in Visual Studio 2008 and earlier versions. Previously a tool window could be rafted in one of two states, Floating and Undocked. These two states shared most characteristics with one exception, Floating windows could not be docked until the user explicitly made the window "dockable". Therefore, the Floating state and it's support was removed. In addition to keep the terminology intuitive, the Undocked state, as well as any supporting properties or methods, was renamed to Floating.

The following DockingWindowState members were removed:

  • Floating

The following DockingWindowState members were renamed:

  • Undocked was renamed to Floating

The following DockingWindowState members were removed:

  • Floating

The following ToolWindow members were moved to it's base class, DockingWindow:

  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.CanRaft
  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.CanRaftProperty
  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.CanRaftResolved
  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.CanRaftResolvedProperty
  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.HasTitleBar
  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.HasTitleBarProperty
  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.HasTitleBarResolved
  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.HasTitleBarResolvedProperty
  • MoveToMdi
  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.RaftingLocation
  • ActiproSoftware.Windows.Controls.Docking.DockingWindow.RaftingLocationProperty
  • Undock (renamed to Float)

The following ToolWindow members were removed:

  • Float

A new docking window container base class was added, that consolidates rafting container code shared between tool and document windows. The new primitive class, ActiproSoftware.Windows.Controls.Docking.Primitives.RaftableDockingWindowContainer, is the new base class of ToolWindowContainer.

In addition, the control template part "PART_TitleBar" was moved from ToolWindowContainer to ActiproSoftware.Windows.Controls.Docking.Primitives.RaftableDockingWindowContainer.

The following classes were added:

  • ActiproSoftware.Windows.Controls.Docking.Primitives.RaftableDockingWindowContainer

The following ToolWindowContainer members were moved to it's base class, ActiproSoftware.Windows.Controls.Docking.Primitives.RaftableDockingWindowContainer:

  • RaftableDockingWindowContainer.CanDock
  • ActiproSoftware.Windows.Controls.Docking.Primitives.RaftableDockingWindowContainer.CanDrag
  • ActiproSoftware.Windows.Controls.Docking.Primitives.RaftableDockingWindowContainer.CanRaft
  • ActiproSoftware.Windows.Controls.Docking.Primitives.RaftableDockingWindowContainer.MoveToMdi
  • TitleBarBackgroundActive>
  • >TitleBarBackgroundActiveProperty>
  • >TitleBarBackgroundInactive>
  • >TitleBarBackgroundInactiveProperty>
  • >TitleBarBorderActiveBrush>
  • >TitleBarBorderActiveBrushProperty>
  • >TitleBarBorderCornerRadius>
  • >TitleBarBorderCornerRadiusProperty>
  • >TitleBarBorderInactiveBrush>
  • >TitleBarBorderInactiveBrushProperty>
  • >TitleBarBorderThickness>
  • >TitleBarBorderThicknessProperty>
  • >TitleBarForegroundActive>
  • >TitleBarForegroundActiveProperty>
  • >TitleBarForegroundInactive>
  • >TitleBarForegroundInactiveProperty>
  • Undock (renamed to Float)

The following ToolWindowContainer members were removed:

  • Float

Changed Serialization Properties

The ActiproSoftware.Windows.Controls.Docking.Serialization.XmlSizedDockingObject.UndockedSize property has been replaced with the ActiproSoftware.Windows.Controls.Docking.Serialization.XmlSizedDockingObject.FloatingSize property.

The following ActiproSoftware.Windows.Controls.Docking.Serialization.XmlSizedDockingObject members were added:

  • ActiproSoftware.Windows.Controls.Docking.Serialization.XmlSizedDockingObject.FloatingSize
  • ActiproSoftware.Windows.Controls.Docking.Serialization.XmlSizedDockingObject.FloatingSizeSerializable

The following ActiproSoftware.Windows.Controls.Docking.Serialization.XmlSizedDockingObject members were removed:

  • UndockedSize
  • UndockedSizeSerializable

Changed Docking Commands

Previously, a rafted window could be in one of two states: Floating or Undocked. With the former indicating that the associated tool window could not be docked. The ActiproSoftware.Windows.Controls.Docking.DockingCommands.MakeDockable could be used to make a floating window dockable. Since the floating state has been removed this command is no longer needed.

The ActiproSoftware.Windows.Controls.Docking.DockingCommands.MakeDocked command can be used to dock a floating window (document or tool).

The following ActiproSoftware.Windows.Controls.Docking.DockingCommands members were added:

  • ActiproSoftware.Windows.Controls.Docking.DockingCommands.MakeDocked

The following ActiproSoftware.Windows.Controls.Docking.DockingCommands members were removed:

  • MakeDockable

The resources associated with the commands have also been updated to more closely match Visual Studio 2010.

The following SRName members were added:

  • UICommandMakeDockedWindowText ("Dock")

The following SRName members were removed:

  • UICommandMakeDockableWindowText ("Dockable")

The text associated with the following SRName members has been updated:

  • UICommandMakeDocumentWindowText changed from "Document" to "Dock as Document"
  • UICommandMakeFloatingWindowText changed from "Floating" to "Float"

Dock Target Changes

Two new members were added to the IDockTarget interface, which allow for more customization of the dock targets.

The following IDockTarget members were added:

  • ActiproSoftware.Windows.Controls.Docking.IDockTarget.GetTarget
  • ActiproSoftware.Windows.Controls.Docking.IDockTarget.Priority

Drop Targets Consolidated

Previously, the document and tool windows used separate drop target elements, which provide visual feed back as the associated window was dragged. These drop target elements were consolidated so that bot the document and tool windows can leverage them.

The following classes were added:

  • ActiproSoftware.Windows.Controls.Docking.Preview.DockingWindowDockedDropTarget
  • ActiproSoftware.Windows.Controls.Docking.Preview.DockingWindowRaftingDropTarget

The following classes were removed (and replaced with the associated class above):

  • DocumentDockedDropTarget
  • DocumentDockedRaftingTarget
  • ToolWindowDockedDropTarget
  • ToolWindowDockedRaftingTarget

Dock Guide Cross Extended

The dock guide cross, represented by the ActiproSoftware.Windows.Controls.Docking.Preview.DockGuideCross class, allows a window to be docked in one of four cardinal points, or as content. Four additional cardinal points have been added, to differentiate between docking a tool window as a tabbed MDI document and docking a tool window around the tabbed MDI host. In addition, some terminology was cleaned up.

The following DockGuideCross control template parts were added:

  • PART_HitMaskContentBottom
  • PART_HitMaskContentLeft
  • PART_HitMaskContentRight
  • PART_HitMaskContentTop

The following DockGuideCross control template parts were renamed:

  • PART_HitMaskCenter was renamed to PART_HitMaskContent

The following members were added:

  • ActiproSoftware.Windows.Controls.Docking.Preview.DockGuideCross.IsContentBottomVisible
  • ActiproSoftware.Windows.Controls.Docking.Preview.DockGuideCross.IsContentLeftVisible
  • ActiproSoftware.Windows.Controls.Docking.Preview.DockGuideCross.IsContentRightVisible
  • ActiproSoftware.Windows.Controls.Docking.Preview.DockGuideCross.IsContentTopVisible

The following members were renamed:

  • ActiproSoftware.Windows.Controls.Docking.Preview.DockGuideCross.IsCenterVisible was renamed to ActiproSoftware.Windows.Controls.Docking.Preview.DockGuideCross.IsContentVisible

Removed Unused Cursors

Previously, one of two cursors were used when dragging a document window. The cursor would indicate if the current mouse location was a valid drop location for the document. With the new document floating feature, these cursors have been replaced with the blue preview windows (which were previously used by tool windows).

The following resources have been removed:

  • DocumentDragMove.cur
  • DocumentDragNone.cur

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2010.2

The release of version 2010.2 addresses some design issues with previous versions and to add new features. All of the breaking changes are detailed below.

This topic contains these sections:

  • Removed TabbedMdiHost.AreDocumentDropDownButtonsVisible and TabbedMdiContainer.TabbedMdiHost Properties
  • Renamed StandardMdiHost.WindowsHaveMinimizeButtons Property
  • Changed How Docking Window Styles Are Applied
  • Removed TabbedMdiTabPanel and ToolWindowTabPanel
  • Changed DockingCommands.OpenOptionsMenu Parameter
  • Removed DockSiteLayoutSerializer.CanLoadToolWindowTitles Property
  • Replaced XmlSerializerBase Notification Handlers

Removed TabbedMdiHost.AreDocumentDropDownButtonsVisible and TabbedMdiContainer.TabbedMdiHost Properties

The AreDocumentDropDownButtonsVisible property on TabbedMdiHost and TabbedMdiContainer determined whether the documents drop-down button was visible. The documents drop-down button displays a context menu with an entry for each associated docking window in the container. This allows quick access to all documents, even if they are not currently visible.

In version 2010.2 this property is replaced with the TabbedMdiHost.TabOverflowBehavior and ActiproSoftware.Windows.Controls.Docking.TabbedMdiContainer.TabOverflowBehavior properties. This property defines the behavior to be used when there are more tabs than will fit in the available space.

Setting TabOverflowBehavior to None is equivalent to setting AreDocumentDropDownButtonsVisible to false. Setting TabOverflowBehavior to Menu is equivalent to setting AreDocumentDropDownButtonsVisible to true. There are several other overflow behaviors available, some of which also include the documents drop-down button.

Renamed StandardMdiHost.WindowsHaveMinimizeButtons Property

The StandardMdiHost property WindowsHaveMinimizeButtons was renamed to CanWindowsMinimize to match other properties with a similiar function. In addition, the backing dependency property WindowsHaveMinimizeButtonsProperty was renamed to CanWindowsMinimizeProperty.

Any references to the previous property name should be updated to reference the new property name.

Changed How Docking Window Styles Are Applied

Overview

There are several built-in styles defined that are applied to instances of DocumentWindow and ToolWindow. The style applied varies depending on where the docking window is located (i.e. docked as a tool window, in a tabbed MDI, or in a standard MDI).

Previously, the appropriate styles were applied using implicit Styles, which were defined in the control templates of the appropriate container element. These container elements include ToolWindowContainer, TabbedMdiHost, and StandardMdiHost. The problem with this design approach is that it is very difficult to override or extend the default styles, because the implicit styles in the control templates override any style defined in the application code.

Changes

Instead of applying the built-in styles using implicit styles, the ItemsControl.ItemContainerStyle property is leveraged. This change allows the styles of the docking window to be dynamically switched based on the associated container, while still allowing the end user to easily override or extend the built-in styles.

In order to allow the DocumentWindow and ToolWindow classes to be easily derived, the Style property needed to be set such that it would use the implicit style of it's base class. Without such code, any custom classes would not automatically pick up the implicit style needed to properly present the window.

The setting of the Style property was automatically handled, so that creating custom classes would be more intuitive. Due to a conflict with the code that sets the Style property and the use of the ItemsControl.ItemContainerStyle property, the code that would set the Style property was removed. Since implicit styles are no longer used, the code that would set the Style property was no longer needed anyway. The DockingWindow.AutoApplyStyleToInheritedClasses property was previously used to control whether the Style property was set. This property has also been removed.

Custom Styles

The built-in styles use a ComponentResourceKey, which are accessible using DockingCommonDictionary static properties: ToolWindowStyleKey, TabbedMdiDocumentStyleKey, and StandardMdiDocumentStyleKey. The ItemsControl.ItemContainerStyle properties on the various containers are set using DynamicResource and the appropriate ComponentResourceKey. This allows the styles to be redefined and/or extended using the same ComponentResourceKey.

For example, the following style extends the built-in style for tool windows and is automatically picked up by all tool windows that are not located in the MDI area:

XAML
Copy
​<Application xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
    xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"
    ...>
    <Application.Resources>

    <Style x:Key="{x:Static themes:DockingCommonDictionary.ToolWindowStyleKey}" TargetType="{x:Type docking:ToolWindow}"
        BasedOn="{StaticResource {x:Static themes:DockingCommonDictionary.ToolWindowStyleKey}}">
        ...
    </Style>

    </Application.Resources>
</Application>

The same concept can be applied to the TabbedMdiDocumentStyleKey, and StandardMdiDocumentStyleKey styles. In addition, the built-in style can be completely replaced by removing the BasedOn attribute.

Removed TabbedMdiTabPanel and ToolWindowTabPanel

The TabbedMdiTabPanel was used to properly layout the tabbed MDI document tabs, while the ToolWindowTabPanel was used for the tool window tabs. These panels performed a similar function, with a few differences. In version 2010.2, support for various "overflow" behaviors has been added, including scrolling support. The ActiproSoftware.Windows.Controls.Docking.Primitives.DockingWindowTabPanel was created to replace TabbedMdiTabPanel and ToolWindowTabPanel, and add logical scrolling of the tabs. It can therefore be hosted in a ScrollViewer and allows the tabs to be scrolled one by one.

Changed DockingCommands.OpenOptionsMenu Parameter

Previously, the ActiproSoftware.Windows.Controls.Docking.DockingCommands.OpenOptionsMenu command would take a UIElement as it's command parameter. The UIElement would be used to determine where the associated menu should be placed. If no UIElement was specified, then the menu would be displayed at the current mouse point.

In order to support the new ActiproSoftware.Windows.Controls.Docking.DockingWindowContextMenuEventArgs.ContextMenuType property (which provides additional context about the menu being created/displayed), the command parameter was changed to be an instance of ActiproSoftware.Windows.Controls.Docking.DockingContextMenuType.

Removed DockSiteLayoutSerializer.CanLoadToolWindowTitles Property

The CanLoadToolWindowTitles property on DockSiteLayoutSerializer was removed, since the title is not part of the layout and doesn't need to be saved/restored.

Any references to this property should be removed.

Replaced XmlSerializerBase Notification Handlers

The XmlSerializerBase`2 class, which has some breaking changes, is the based class of DockSiteLayoutSerializer. Thus, DockSiteLayoutSerializer is affected by the breaking change.

See the Shared Library's conversion topic for more information on this breaking change.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.1

The release of version 2011.1 addresses some design issues with previous versions and to add new features. All of the breaking changes are detailed below.

This topic contains these sections:

  • Changed How Docking Window Styles Are Applied
  • Added Parameter to IRaftingWindow.Setup Method
  • Replaced Resolved Properties (2011.1 build 0534)
  • Changed Attached/Inherited Properties (2011.1 build 0534)
  • Enabling Live Splitting

Changed How Docking Window Styles Are Applied

Overview

There are several built-in styles defined that are applied to instances of DocumentWindow and ToolWindow. The style applied varies depending on where the docking window is located (i.e. docked as a tool window, in a tabbed MDI, or in a standard MDI).

In versions prior to 2010.2, the appropriate styles were applied using implicit Styles, which were defined in the control templates of the appropriate container element. These container elements include ToolWindowContainer, TabbedMdiHost, and StandardMdiHost. The problem with this design approach is that it is very difficult to override or extend the default styles, because the implicit styles in the control templates override any style defined in the application code.

In 2010.2, the appropriate styles were applied using the ItemsControl.ItemContainerStyle property of the container elements. This allowed the styles to be more easily extended, while still allowing the style to be dynamically changed based on the location of the docking window. The problem with this design approach is that it does not fit well with the MVVM design pattern. When using MVVM, the docking windows are generated by the DockSite, which should also be able to apply a user-defined style. The user-defined style is responsible for binding docking window properties with the associated view-model. Under this design, on the ItemsControl.ItemContainerStyle style or the user-defined style could be applied, which would not work.

Changes

All the various built-in styles have been consolidated into a single default style, which uses style triggers to switch the "look" based on the state/location of the associated docking window. The allows implicit or explicit (such as those referenced by DockSite.DocumentItemContainerStyle and DockSite.ToolItemContainerStyle) styles to be applied as needed. This is the same behavior seen with the native WPF controls, and is generally how users expect styles to work.

Custom Styles

The built-in styles no longer use a ComponentResourceKey, which were accessible using DockingCommonDictionary static properties: ToolWindowStyleKey, TabbedMdiDocumentStyleKey, StandardMdiDocumentStyleKey. Instead of having a separate style for each "look", the default style dynamically changes based on the state/location of the docking window. Therefore, any custom styles can be applied using implicit styles.

For example, the following implicit style will be applied to any tool windows whose Style property has not been set explicitly:

XAML
Copy
​<Application xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
    ...>
    <Application.Resources>

    <Style x:Key="{x:Type docking:ToolWindow}" TargetType="{x:Type docking:ToolWindow}">
        ...
        <Style.Triggers>
            <MultiTrigger>
                <MultiTrigger.Conditions>
                    <Condition Property="State" Value="Document" />
                    <Condition Property="docking:Workspace.MdiTypeKey" Value="{x:Static docking:TabbedMdiHost.MdiTypeKey}" />
                </MultiTrigger.Conditions>
                <!-- Tabbed MDI document -->
            </MultiTrigger>
            <MultiTrigger>
                <MultiTrigger.Conditions>
                    <Condition Property="State" Value="Document" />
                    <Condition Property="docking:Workspace.MdiTypeKey" Value="{x:Static docking:StandardMdiHost.MdiTypeKey}" />
                </MultiTrigger.Conditions>
                <!-- Standard MDI document -->
            </MultiTrigger>
            <Trigger Property="State" Value="AutoHide">
                <!-- Auto-hidden -->
            </Trigger>
            <Trigger Property="State" Value="Docked">
                <!-- Docked -->
            </Trigger>
            <Trigger Property="State" Value="Floating">
                <!-- Floating -->
            </Trigger>
        </Style.Triggers>
    </Style>

    </Application.Resources>
</Application>

Custom Windows

Custom windows, that derive from DocumentWindow or ToolWindow, may need to be updated as well. Generally, custom controls override the property metadata for the DefaultStyleKeyProperty in order to specify a custom key for the control's default Style. If the custom window does not alter the visual aspect of the base class window, then this override should be removed, as it can prevent the custom window from displaying correctly. If the custom window does in fact define a custom Style and ControlTemplate, then the property metadata override will be needed.

Added Parameter to IRaftingWindow.Setup Method

The ActiproSoftware.Windows.Controls.Docking.Primitives.IRaftingWindow.Setup method was updated to accept a WindowState parameter. This allows windows to be initially maximized or minimized when opening the window. Any code that implements ActiproSoftware.Windows.Controls.Docking.Primitives.IRaftingWindow must be updated to accept the new parameter, but can ignore it if desired.

Replaced Resolved Properties (2011.1 build 0534)

Several "resolved" properties were replaced with methods, due to the new linked dock sites feature. Previously, these resolved properties were pre-determined based on the current configuration. With the new linked dock sites feature, these "resolved" properites need to be determined dynamically, and where therefore replaced with methods.

The following properties were changed:

  • DockingWindow.CanAttachResolved property was replaced with the ActiproSoftware.Windows.Controls.Docking.DockingWindow.GetCanAttachResolved methods
  • DockingWindow.CanDockBottomResolved property was replaced with the ActiproSoftware.Windows.Controls.Docking.DockingWindow.GetCanDockBottomResolved methods
  • DockingWindow.CanDockLeftResolved property was replaced with the ActiproSoftware.Windows.Controls.Docking.DockingWindow.GetCanDockLeftResolved methods
  • DockingWindow.CanDockRightResolved property was replaced with the ActiproSoftware.Windows.Controls.Docking.DockingWindow.GetCanDockRightResolved methods
  • DockingWindow.CanDockTopResolved property was replaced with the ActiproSoftware.Windows.Controls.Docking.DockingWindow.GetCanDockTopResolved methods
  • DockingWindowContainer.CanAttach property was replaced with the ActiproSoftware.Windows.Controls.Docking.DockingWindowContainer.GetCanAttach methods
  • RaftableDockingWindowContainer.CanDock property was replaced with the ActiproSoftware.Windows.Controls.Docking.Primitives.RaftableDockingWindowContainer.GetCanDock methods
  • ToolWindow.CanBecomeDocumentResolved property was replaced with the ActiproSoftware.Windows.Controls.Docking.ToolWindow.GetCanBecomeDocumentResolved methods

Changed Attached/Inherited Properties (2011.1 build 0534)

Several attached/inherited dependency properties were changed to regular dependency properties, as their inheritance behavior was no longer needed.

The following properties were changed:

  • DockSite.CanToolWindowsAttachProperty
  • DockSite.CanToolWindowsBecomeDocumentsProperty
  • ActiproSoftware.Windows.Controls.Docking.DockSite.CanToolWindowsDockBottomProperty
  • ActiproSoftware.Windows.Controls.Docking.DockSite.CanToolWindowsDockLeftProperty
  • ActiproSoftware.Windows.Controls.Docking.DockSite.CanToolWindowsDockRightProperty
  • ActiproSoftware.Windows.Controls.Docking.DockSite.CanToolWindowsDockTopProperty
  • TabbedMdiHost.CanDocumentsAttachProperty
  • ActiproSoftware.Windows.Controls.Docking.TabbedMdiHost.CanDocumentsDockBottomProperty
  • ActiproSoftware.Windows.Controls.Docking.TabbedMdiHost.CanDocumentsDockLeftProperty
  • ActiproSoftware.Windows.Controls.Docking.TabbedMdiHost.CanDocumentsDockRightProperty
  • ActiproSoftware.Windows.Controls.Docking.TabbedMdiHost.CanDocumentsDockTopProperty

Enabling Live Splitting

When live splitting was introduced, it would automatically enable/disable based on the ActiproSoftware.Windows.Controls.Docking.DockSite.UseHostedAutoHidePopups property. The problem with this approach is live splitting could not be enabled even when Interop content was not used, and vice-versa. The DockSite.IsLiveSplittingEnabled property was added to allow this feature to be customized.

Since this feature was previously tied to a different property, it may be neccessary to set IsLiveSplittingEnabled as desired manually.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Theming Architectural and Style Changes
  • Changed Default Value of TabbedMdiHost IsCloseButtonOnTab Property
  • Removed State-Oriented Properties
  • Moved Keyed Styles
  • Removed Unused Resource
  • Removed TitleBarButton and TitleBarRepeatButton Controls

Theming Architectural and Style Changes

See unified conversion topic for details on breaking changes made to the theming architecture, which affects control styles and related dictionaries.

Changed Default Value of TabbedMdiHost IsCloseButtonOnTab Property

In previous versions, the default value of the ActiproSoftware.Windows.Controls.Docking.TabbedMdiHost.IsCloseButtonOnTab property was false. In the 2011.2 release, this has been changed to true to better mimic the latest Visual Studio look.

Upgrade Instructions Upgrade Instructions
Review whether ActiproSoftware.Windows.Controls.Docking.TabbedMdiHost.IsCloseButtonOnTab needs to be explicitly set to false.

Removed State-Oriented Properties

Various state-oriented brush properties were removed to make control styles more consistent. These brushes can be customized by redefining the associated resource or using custom styles/triggers.

note note
See the Reusable Assets topic for more information on redefining asset resources.

  1. Removed the following properties from AutoHideTabItem:
    • HighlightBrush
  2. Removed the following properties from DockingWindow:
    • TabBackgroundHover
    • TabBackgroundNormal
    • TabBackgroundSelected
    • TabBorderBrushHover
    • TabBorderBrushNormal
    • TabBorderBrushSelected
    • TabForegroundHover
    • TabForegroundNormal
    • TabForegroundSelected
    • TabHighlightBrushHover
    • TabHighlightBrushNormal
    • TabHighlightBrushSelected
    Note Note
    The ActiproSoftware.Windows.Controls.Docking.DockingWindow.TabBackground, ActiproSoftware.Windows.Controls.Docking.DockingWindow.TabBorderBrush, and ActiproSoftware.Windows.Controls.Docking.DockingWindow.TabForeground properties have been added to allow customization as needed.
  3. Removed the following properties from ToolWindowContainer:
    • TabBarSpacerBackground
    • TabBarSpacerBorderBrush
  4. Removed the following properties from ActiproSoftware.Windows.Controls.Docking.Primitives.RaftableDockingWindowContainer:
    • TitleBarBackgroundActive
    • TitleBarBackgroundInactive
    • TitleBarBorderActiveBrush
    • TitleBarBorderInactiveBrush
    • TitleBarBorderCornerRadius
    • TitleBarBorderThickness
    • TitleBarForegroundActive
    • TitleBarForegroundInactive
  5. Removed the following properties from TabbedMdiContainer
    • OutlineBackground
    • OutlineInnerBorderBrush
    • OutlineOuterBorderBrush
    • OutlineTintColor (renamed to ActiproSoftware.Windows.Controls.Docking.TabbedMdiContainer.TintColor)

Upgrade Instructions Upgrade Instructions
All references to these properties would need to be removed. In order to custom the various brushes, the associated resource would need to be customized.

Moved Keyed Styles

The now deprecated DockingCommonDictionary class had a couple ComponentResourceKey properties defined for reusable/customizable styles. This included DockingCommonDictionary.DockingTabScrollViewerStyleKey and DockingCommonDictionary.SplitterPreviewBrushKey, which have been moved to ActiproSoftware.Windows.Themes.DockingResourceKeys.DockingTabScrollViewerStyleKey and ActiproSoftware.Windows.Themes.DockingResourceKeys.SplitterPreviewBrushKey, respectively.

Upgrade Instructions Upgrade Instructions
  1. All references to DockingCommonDictionary.DockingTabScrollViewerStyleKey must be replaced with ActiproSoftware.Windows.Themes.DockingResourceKeys.DockingTabScrollViewerStyleKey.
  2. All references to DockingCommonDictionary.SplitterPreviewBrushKey must be replaced with ActiproSoftware.Windows.Themes.DockingResourceKeys.SplitterPreviewBrushKey.

Removed Unused Resource

The SRName.UICommandAutoHideWindowText resource was not being used and has been removed.

Upgrade Instructions Upgrade Instructions
All references to SRName.UICommandAutoHideWindowText should be removed.

Removed TitleBarButton and TitleBarRepeatButton Controls

The TitleBarButton and TitleBarRepeatButton controls have been removed, since they only existed to facilitate theming. Instead, a native Button or RepeatButton can be used along with the Style associated with the SharedResourceKeys.EmbeddedButtonBaseOverrideStyleKey key.

These controls defined an attached and inherited dependency property named IsActiveProperty, which was used to determine which window inside a DockSite was focused. This property has been moved to ActiproSoftware.Windows.Controls.Docking.DockingWindowContainer.IsActiveProperty.

Upgrade Instructions Upgrade Instructions
  1. All references to TitleBarButton and TitleBarRepeatButton should be replaced with a native Button and RepeatButton, respectively, that use the EmbeddedButtonBaseOverrideStyleKey style.
  2. All references to TitleBarButton.IsActiveProperty must be replaced with ActiproSoftware.Windows.Controls.Docking.DockingWindowContainer.IsActiveProperty.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2016.1

For the 2016.1 version, we completely rewrote the entire Docking/MDI product from the ground up based on our years of experience in this area. Along the way, we added nearly all of the major features our customers have requested and the result is the most feature-rich docking window and MDI product of its kind.

Although the internals of the product were rewritten, much of the public API has remained the same to help ensure a smooth, easy transition from older versions. There are some cases where type members were renamed, others dropped that didn't need to be kept, and an enormous number of new types and members added to support the massive new feature set.

The 'Complete Update Details' section in this topic gives information on the breaking changes made, such as renamed/removed types/members. The sections before it walk through some selected larger breaking changes in detail.

We realize that some customers may wish to upgrade to 2016.1 immediately, but it might take some time to get their applications updated to work with the new codebase. For those scenarios, the final section of this topic tells how you can still access the old version of the Docking assembly (called Docking.Legacy) and continue to use that while you work on upgrading to the new codebase. Please only do this if needed, as you want to get on the this new version as soon as possible to continue getting new features and bug fixes.

This topic contains these sections:

  • Docking Window Role in UI
  • Docking Window SerializationId Set in Constructor Instead of Name
  • Programmatic Layout Updates Don't Work Until Loaded
  • All Styles and Templates Rebuilt
  • DockSite.ControlSize Attached Property Removed
  • LastActiveDocument and LastActiveToolWindow Removed
  • Clicking a Tab Close Button Won't Focus Within Container
  • Renamed Rafting to Floating
  • Multiple DockSite Events Changed to Pass Multiple Docking Windows
  • DockingWindowState.Floating Value Removed
  • Tool Window Transitions Removed
  • DockSiteViewModelBehavior Removed from MVVM Samples
  • DockingCommands Class Removed
  • Tabbed MDI Tab Title Editing Feature Removed
  • DockSite.FullScreen Property Removed
  • SingleTabLayoutBehavior.Stretch Option Removed
  • ToolWindowTabFlashBehavior Sample Class Removed
  • Header/HeaderTemplate Properties Removed
  • Prism Integration Changes
  • Complete Update Details
  • Temporary Inclusion of Older Docking and Prism Interop Legacy Assemblies

Docking Window Role in UI

In the old version, the ToolWindow and DocumentWindow classes were rendered in UI as tabs. This wasn't the best design since sometimes they weren't visible, even though their content was.

In this version, ToolWindow and DocumentWindow now are simple containers of the content they display. That means that they are effectively used like a ContentControl and are always visible in the UI if their content is visible. This allows both the visual and UI automation trees to be more representative of the intended hierarchy.

Docking Window SerializationId Set in Constructor Instead of Name

This version adds a new DockingWindow.SerializationId property that can optionally be used instead of the Name property when serializing/deserializing layouts. The new property is better than Name because it can hold any text data and isn't limited to .NET identifier syntax. It also can be fully two-way data bound.

Since SerializationId is a better property to use than Name for serialization purposes, although Name can still be used, we have updated the constructors for both ToolWindow and DocumentWindow that used to accept a Name parameter to switch that parameter to assign the SerializationId property instead.

The only real negative side effect of this is that an indexer of the DockSite.ToolWindows and DocumentWindows collections works off of Name. Since that property won't be set directly any more by using the constructor that used to set it, indexer calls off those collections may return a null value unless you manually set the Name property on each docking window instance.

Programmatic Layout Updates Don't Work Until Loaded

Sometimes docking windows are programmatically added to a layout (via opening, docking, layout loading, etc.) within the contructor of a root element like a Window or UserControl after its InitializeComponent method executes. In situations like this, the code to add the docking windows to the layout needs to be performed at or after the time that root element's Loaded event fires.

When the root element has loaded, that means that all the templates of the control hierarchy within the dock site have been properly loaded and applied as well. The dock site and its features are then ready for programmatic interaction.

The old version did allow some limited programmatic interaction with a layout before the dock site was fully loaded due to the heavy use of inherited dependency properties to register various docking hierarchy controls with the dock site. This version has eliminated all use of inherited dependency properties since they slow things down, but a side effect of that is that not all docking hierarchy controls get their templates applied or are registered with the owner dock site until after the DockSite's (or one of its containers') Loaded event has fired.

All Styles and Templates Rebuilt

In this version, all styles and templates for the docking controls have been rebuilt from scratch. They are now much simpler, use better composition of primitive controls (such as the new AdvancedTabControl), and are far easier to customize.

Any styles designed for the old version will NOT work with this version and will need to be reimplemented. Several primitive controls, such as ReverseMeasureDockPanel that were used in the old version and are no longer needed in this version, have been removed.

DockSite.ControlSize Attached Property Removed

In the old verison, a DockSite.ControlSize property could be set to containers like ToolWindowContainer to designate their initial size.

In this version, that property has been removed and new properties directly on docking windows themselves have been added. The DockingWindow.ContainerDockedSize property can be set for docked scenarios. It is encouraged to set the same value to all docking windows in the same container. The ToolWindow.ContainerAutoHideSize property can be set for auto-hide popup size.

There are also new ContainerMinSize and ContainerMaxSize properties that allow you to set a desired minimum and maximum size to which a container can be resized.

LastActiveDocument and LastActiveToolWindow Removed

The old LastActiveDocument, LastActiveToolWindow, and related property change events have been removed in this version.

Use the DockSite.ActiveWindow to know which window is currently active, and watch the WindowDeactivated and WindowActivated events to know when that changes.

Use the new DockSite.PrimaryDocument property to know which document is currently the primary document. This value will be the same as ActiveWindow if the active window is a document. If the active window is a tool window outside of the MDI area instead, the primary document will refer to the last open document that was active. The PrimaryDocumentChanged event fires when the related property value changes.

All docking windows now have a LastActiveDateTime property that you can examine to sort them by when they were last active.

Clicking a Tab Close Button Won't Focus Within Container

In the old version, if the focus was in one container (such as a docked tool window) and then the close X button on a document tab was clicked, the tab would be closed and the next document tab in that tabbed MDI container would become active. In vNext in this same scenario, focus remains in the original container (docked tool window) instead of activating the next tabbed document.

This means that the DockSite.WindowActivated event won't fire for the next tabbed document. If you relied on this event to know when a new document became the primary document, switch over to using the new PrimaryDocumentChanged event instead, which is described inthe previous section. The new DockSite.PrimaryDocument returns the open document that is currently active, or was last active in the case where a non-document is currently active.

Renamed Rafting to Floating

In the previous version, the term "rafting" was used in a number of property names. In this version, all instances of "rafting" are now named as "floating".

An example is the DockSite .CanDocumentWindowsRaft property is now named CanDocumentWindowsFloat.

Multiple DockSite Events Changed to Pass Multiple Docking Windows

Several DockSite events have been slightly renamed to a plural name to account for the fact that they now pass multiple affected docking windows instead of a single docking window. The renamed events are: WindowsClosing, WindowsClosed, WindowsOpening, WindowsOpened, and WindowsStateChanged.

The revised WindowsClosing event is handy in particular because when the Close All Documents and Close Others menu items are used, a single dialog with all windows listed can be presented to the user to check whether to close the windows.

DockingWindowState.Floating Value Removed

The DockingWindowState enumeration no longer has a Floating value. The reason is that now floating dock hosts can have docked, auto-hidden or document-oriented docking windows in them, so that option no longer fit.

In addition, this change means that the DockSite.WindowsStateChanged event will no longer fire when a docking window is moved to or from a floating dock host, unless doing so is a transition between the docked, auto-hide, or document states.

Tool Window Transitions Removed

Tool window content animated transitions have been removed since they aren't used much, are distracting, and add more visual complexity to the layout model. Other new subtle quick animations are used throughout the UI (such as for dock guides, drop targets, etc.) that don't affect layout performance and yet give the app an even more fluid feel.

DockSiteViewModelBehavior Removed from MVVM Samples

The old DockSiteViewModelBehavior class has been removed from all MVVM samples since it is no longer needed due to new MVVM-friendly features. Two way data binding on DockingWindow.IsOpen, IsActive, IsSelected, and State are all supported.

In addition, there are numerous new features described in the Lifecycle and Docking Management topic that deal with adjusting (even dynamically) the default location for opened windows.

Finally, there are new built-in features for the dock site to automatically remove a view model item from the DockSite.ToolItemsSource or DockSite.DocumentItemsSource collections when the related container docking window is destroyed. This is possible only if the items source property is assigned a collection that is an editable list. If another non-editable collection is used instead, you must attach to the DockSite.WindowUnregistered event and remove the related item from the items source yourself.

DockingCommands Class Removed

The old DockingCommands class that contained static properties with docking window-related commands has been removed. Command properties have been moved to their appropriate target class instead, such as the DockingWindow.ActivateCommand property.

Tabbed MDI Tab Title Editing Feature Removed

The tabbed MDI tab title editing feature (DockSite.CanDocumentWindowsEditTitles) has been removed since it is rarely used and would add much more complexity to the AdvancedTabItem control template. If you used this feature in the old version, we recommend adding a context menu item to tabs via the DockSite.MenuOpening event that when clicked, triggers a title text editing dialog.

DockSite.FullScreen Property Removed

The dock site FullScreen property has been removed since its old implementation wouldn't have functioned well with the new features of floating dock hosts where complete secondary MDIs are supported in them.

SingleTabLayoutBehavior.Stretch Option Removed

The SingleTabLayoutBehavior.Stretch option has been removed. If a similar feature is added in the future, it would be to force all tabs to fill up to the available space instead of just a single tab.

ToolWindowTabFlashBehavior Sample Class Removed

The ToolWindowTabFlashBehavior attached behavior class that used to be in the Sample Browser has been removed. That class allowed for animated tinting of tabs to achieve a flash effect, but is no longer needed since new properties are now available directly on DockingWindow that support this feature.

See the Docking Window Capabilities topic for more information on tab flashing features.

Header/HeaderTemplate Properties Removed

The previous version had Header and HeaderTemplate properties that could be used to provide custom content for tabs, since the tab templates themselves were the docking windows.

In this version, docking windows are no longer represented in UI as tabs themselves, and are instead simple containers around their actual child content when in UI. The AdvancedTabControl primitive control is now used to render tab UI for docking windows where appropriate. See the Docking Window Role in UI section above for more detail.

While properties like DockingWindow.Title, TabText, and ImageSource can be used to indicate tab content, sometimes you also want to be able to include additional contextual content. This could be anything from status indicators, buttons, etc. The Contextual Content topic talks about how you can provide various DataTemplate values to inject custom content into tabs in multiple locations throughout the docking UI.

Prism Integration Changes

In the old version, we maintained and shipped a separate ActiproSoftware.Docking.Interop.Prism.Wpf.dll assembly that contained some Prism integration logic. This assembly's source code was also located at http://actipro.codeplex.com. The latest source code of that assembly, compiled for Prism 5.0 and Actipro WPF Controls 2015.1 is still available there.

Starting in this version, we no longer ship a newer version of that assembly but do include everything you need for Prism 6.1 compatibility right in the Prism integration sample that comes with the WPF controls. This way, you are able to easily see all the source code, copy it to your own application, and customize it as needed. The same features as before are available in this new open source offering, and it works with the latest Prism and Actipro WPF Controls versions.

The old version had an IDockingWindowInitializer interface and several class implementations of that interface that allowed you to supply both capability property and default location information for a docking window. Those types have been removed in the new version, but there are improved replacements for similar functionality.

Now that Docking/MDI is much more MVVM friendly, for property setting, all you do in the new version is bind properties in a docking window Style as seen in the MVVM Features topic.

The specifying of default locations can now be done through the "Default Locations" features described in the Lifecycle and Docking Management topic. Those powerful features give you full control over where a docking window will be located when it is first opened.

Complete Update Details

The list below is the entire detailed update log, including breaking changes.

Layout

  • Layout logic now does its best to adhere to desired, minimum, and maximum docked size hints on docking windows when space is available.
  • DockSite.ControlSize attached property no longer used. Set ContainerDockedSize property on docking windows instead.
  • Minimum and maximum container docked sizes supported on docking windows. Set to the same value to suggest fixed sizes.
  • When a layout is sized very small, then grows larger again, the original docking window sizes are restored instead of keeping them minimal.
  • The DockSite.UseHostedPopups property replaces UseHostedAutoHidePopups and UseHostedDockGuides.

Splitters

  • Live splitting enabled by default, but can be disabled.
  • When not using live splitting and UseHostedPopups is false, splitters will appear above interop controls.

Docking Windows

  • Docking windows now are styled as simple presentation wrappers for their content that is displayed in UI, and no longer are styled to appear as tabs. The new AdvancedTabControl is used in container templates that require tabbed UI.
  • DockingWindow.WindowGroupName property added, which designates a group of windows that the window can attempt to attach to when first opened.
  • DockingWindow.DefaultLocationRequested event added, which allows configutation of dynamic default location information for a window when it is first opened.
  • DockSite.WindowDefaultLocationRequested event added, which provides generalized functionality similar to DockingWindow.DefaultLocationRequested event.
  • DockingWindow.DefaultDockSide property added, which designates the fallback default side in the dock host to dock when first opened.
  • When docking to a default side in a dock host, a window will attempt to attach to another existing container on the same side, if one is available.
  • DockingWindow.TabText property added, which optionally provides specific text to only use on tabs. If not specified, the Title is used in those locations.
  • ToolWindow.GetCurrentSide method added that returns the side where the tool window is currently located and replaces the GetDirectionRelativeToWorkspace method.
  • DockingWindow.IsActive property added, which is only true when the DockSite.ActiveWindow is the window. Set it to true to activate the window.
  • Various ICommand-based properties added to DockingWindow and ToolWindow, instead of the old generalized DockingCommands class.
  • ToolWindow.Dock method changed to use Side parameter instead of Direction, and Attach method added for docking directly into a specified container (instead of former Direction.Content option).
  • DockingWindow.CanDockLeft, CanDockTop, CanDockRight, CanDockBottom and related global DockSite/TabbedMdiHost properties (like DockSite.CanToolWindowsDockTop, TabbedMdiHost.CanDocumentsDockTop, etc.) removed and replaced with a single DockingWindow.CanDock property. For restricting the sides upon which docking windows can dock during a drag operation, please see the "Limiting the Allowed Dock Guides While Dragging" section in the Docking Window Capabilities topic.
  • DockingWindow.CanRaft property renamed to CanFloat, and related DockSite.CanToolWindowsRaft property renamed to CanToolWindowsFloat.
  • DockingWindow.TabFlashMode and TabFlashColor properties added, allowing for flash effects to be applied to a tab.
  • DockingWindow.TabToolTip property added, which is what is now used to set the tooltip content for a docking window's tab.
  • DockingWindow.SerializationId property added, which can be used to designate a unique ID for layout deserialization that matches layout data to a window in place of the Name property.
  • DockingWindow.CanSerialize property added that can be set to false to prevent the window from being included in layout serialization.
  • DockingWindow.ContextImageSource and DocumentWindow.ReadOnlyContextImageSource properties removed and replaced with a DockingWindow.TabbedMdiTabContextContentTemplate property that allows for more flexibility.
  • DockingWindow.LastActiveDateTime property added, which can be used to sort docking windows by when they were last focused.
  • DockingWindow.CanDrag property renamed to CanDragTab, and DockSite.CanToolWindowsDrag renamed to CanToolWindowTabsDrag and TabbedMdiHost.CanDocumentsDrag renamed to CanDocumentTabsDrag to match.
  • DockingWindow.MoveToMdi method overload that targeted a TabbedMdiContainer removed. Use the Attach or Dock methods instead.
  • DockSite.LastActiveToolWindow property removed since it can be derived by looking at the open tool windows and sorting by their LastActiveDateTime properties.
  • DockSite.WindowClosing event renamed to WindowsClosing and now can pass multiple e.Windows, which is useful when the Close All Documents and Close Others menu items are used since a single dialog with all windows listed can be presented to the user to check whether to close the windows.
  • Several other DockSite events renamed so they now can pass multiple e.Windows, including WindowClosed to WindowsClosed, WindowDragging to WindowsDragging, WindowDragged to WindowsDragged, WindowOpening to WindowsOpening, WindowOpened to WindowsOpened, and WindowStateChanged to WindowsStateChanged.
  • ToolWindow and DocumentWindow multi-parameter constructors changed to accept SerializationId parameter in place of Name to help avoid issues with having to conform Name's value to identifier syntax.
  • Dockingwindow.TabBackground, TabBorderBrush, TabBorderThickness, TabForeground properties removed since they are no longer applicable.
  • DockingWindow.LastState property removed since the State property can be used.
  • DockingWindow.OptionsMenu property removed. Handle the DockSite.MenuOpening event instead to change/customize the menu.
  • DockingWindow.DragMove method updated to require an InputPointerButtonEventArgs argument.

Tool Window Containers

  • ToolWindowContainer uses the new AdvancedTabControl within its template, bringing all features of that control to the container's UI.
  • Use the DockSite.ToolWindowsHaveOptionsButtons, ToolWindowsHaveToggleAutoHideButtons, and ToolWindowsHaveCloseButtons properties to determine if title bar buttons are visible, without affecting context menu options or capabilities.
  • Use the ToolWindow.ToolWindowContainerTitleBarContextContentTemplate property to add custom buttons into the title bar.
  • Add contextual UI to tool window tabs via the ToolWindow.ToolWindowContainerTabContextContentTemplate property.
  • Customize the appearance of tool window container tabs via the DockSite.ToolWindowContainerTabItemContainerStyle property.
  • DockSite.CanToolWindowsCloseOnMiddleClick property added, allowing for closing tool window tabs on middle-click.
  • DockSite.ToolWindowsHaveImagesOnTabs property renamed to ToolWindowsHaveTabImages.
  • DockSite.ToolWindowsTabPlacement property renamed to ToolWindowsTabStripPlacement and uses a different enum type, with new options for all sides.
  • ToolWindowContainer.TitleFontFamily and TitleFontSize properties added, allowing for easy customization of title text appearance.
  • ToolWindow.HasOptions property renamed to HasOptionsButton and DockSite.ToolWindowsHaveOptions property renamed to ToolWindowsHaveOptionsButtons.
  • DockSite.ToolWindowTransitionSelector property removed since transitions are no longer supported to improve tab switching performance.
  • Alt+- keyboard shortcut shows options menu.

Auto-hide

  • When UseHostedPopups is false, auto-hide popups now fully track with the dock host when crossing over screen edges.
  • When not using live splitting and UseHostedPopups is false, splitters will now remain fully visible when dragged outside of the auto-hide popup.
  • DockSite.AutoHidePopupOpenAnimationDuration and AutoHidePopupCloseAnimationDuration property defaults made slightly faster.
  • DockSite.AutoHidePopupOpenAnimation and AutoHidePopupCloseAnimation properties removed. Auto-hide popups now always use a fade/slide animation when animation durations are greater than zero.
  • Auto-hide popups now close when another docking window is activated instead of blindly watching for pointer clicks.
  • DockSite.WindowsAutoHiding event added, which allows for customization of the side upon which one or more tool windows will auto-hide.
  • Drag/drop of objects over an auto-hide tab opens the auto-hide popup.
  • DockHost.AutoHidePopupToolWindow property added, which specifies the tool window currently open in an auto-hide popup, if any.
  • DockHost.IsAutoHidePopupOpen property added, returning if the auto-hide popup is currently open.
  • DockHost.CloseAutoHidePopup property added, allowing for the auto-hide popup to be closed instantly or with animation.
  • Add contextual UI to auto-hidden tool window tabs via the ToolWindow.AutoHideTabContextContentTemplate property.
  • Customize the appearance of auto-hide tabs via the DockSite.AutoHideTabItemTemplate and AutoHideTabItemTemplateSelector properties.
  • Removed the DockSite.CanToolWindowsRestoreToAutoHideState property and now always restores to auto-hide state when appropriate.
  • DockSite.AutoHideHost property removed and related functionality moved to DockSite/DockHost.
  • DockSite auto-hide Duration-based properties changed to use a double representing milliseconds instead.

Floating Windows

  • Floating windows rearchitected to fully support Windows Aero snapping.
  • DockSite.UseDragFloatPreviews property added that determines if float previews should be used when dragging windows instead of instantly creating floating windows.
  • DockSite.FloatingWindowTitle and FloatingWindowIcon properties added, allowing for customization of floating window title bars.
  • DockSite.FloatingToolWindowContainersHaveMaximizeButtons and FloatingToolWindowContainersHaveMinimizeButtons properties added, allowing for easy customization of whether maximize/minimize buttons appear on floating tool window containers.
  • DockSite.UseHostedRaftingWindows property renamed to UseHostedFloatingWindows.
  • DockSite.HostedRaftingWindowContainer property renamed to HostedFloatingWindowContainer.
  • DockSite.IsRaftingWindowSnapToScreenEnabled property renamed to IsFloatingWindowSnapToScreenEnabled.
  • DockSite.FloatingWindowSnapToScreenThreshold property added that determines what minimum amount a floating window must be visible to avoid being snapped to screen. Partially-visible floating windows will now snap to this minimum threshold as appropriate.
  • DockSite.FloatingWindowOpening event added that can alter and limit a floating window's initial size.
  • The DockSite.CreateRaftingWindow method is no longer available. Use other new properties to configure desired functionality.
  • DockSite.CanRaftingWindowsCloseOnDockSiteUnload property renamed to CanFloatingDockHostsHideOnDockSiteUnload, and refactored logic for showing/hiding floating dock hosts based on DockSite visibility.
  • Floating window wrappers now change close button visibility based on the CanCloseResolved property of all descendant docking windows.
  • DockSite.InactiveRaftingWindowFadeDelay, InactiveRaftingWindowFadeDuration, InactiveRaftingWindowFadeOpacity, and IsInactiveRaftingWindowFadeEnabled properties renamed to use FloatingWindow in their names in place of RaftingWindow.
  • DockSite.AreRaftingWindowsMaximizedOnDoubleClick property removed.
  • DockingWindow.RaftingLocation property removed. Use the Float method to specify a location instead.
  • DockingWindow.Float overload that took a FloatSizingBehavior removed. Set the DockingWindow.SizeToContentModes property with a Float value instead and then call Float() to have it size-to-content.
  • DockSite.CanToolWindowsMaximize and CanDocumentWindowsMaximize properties, and DockingWindow.CanMaximize property removed due to not being appropriate for the new floating MDI support. DockSite.FloatingToolWindowContainersHaveMaximizeButtons can be used as a replacement for all tool window containers.
  • DockingWindowState enumeration no longer has a Floating value.

Dock Guides and Previews

  • Dock guides and previews restyled with a more modern appearance, and display with subtle animations.
  • Animations can be disabled by setting DockSite.IsDockGuideAnimationEnabled to false.
  • DockSite.DockGuideAnimationDuration property removed since animations are now forced to be quick.
  • Dock guide control classes restructured and moved to the Primitives namespace.
  • New DockPreview and FloatPreview controls added that show dock/float location hints in various scenarios.

Tabbed MDI

  • TabbedMdiContainer uses the new AdvancedTabControl within its template, bringing all features of that control to the container's UI.
  • Three modes of tab display (normal, pinned, preview) are now available via the new DockingWindow.TabbedMdiLayoutKind property.
  • New 'Close Others' and 'Close All Documents' context menu item.
  • New 'Pin Tab' context menu toggle item to toggle between a pinned and normal tab.
  • New 'Keep Tab Open' context menu item that converts a preview tab to a normal tab.
  • The TabbedMdiHost.ContainersHaveNewTabButtons property can be set to true to show a new tab button. The DockSite.NewWindowRequested event can be handled in response to those button clicks. New tab buttons work best when paired with a TabOverflowBehavior of Shrink or ShrinkWithMenu.
  • TabbedMdiHost.EmptyContentTemplate property added that allows a custom DataTemplate to be displayed when there are no visible documents.
  • TabbedMdiHost.TabPlacement property renamed to TabStripPlacement and uses a different enum type, with new options for all sides.
  • TabbedMdiHost.IsCloseButtonOnTab property renamed to HasTabCloseButtons.
  • TabbedMdiHost.IsImageOnTab property renamed to HasTabImages.
  • TabbedMdiHost.HasTabPinButtons property added that can show a pin button on normal tabs.
  • Alt+- keyboard shortcut shows selected document's context menu.
  • Ctrl+Alt+DownArrow keyboard shortcut shows document list menu.
  • Tab-based title editing features removed since they are rarely used and would add complexity to all UI tab items.
  • TabbedMdiHost no longer inherits ContentControl so use its Child property to specify a child element instead.

Standard MDI

  • Dock guides now support attach docking over standard MDI host, which moves dragged docking windows to MDI.
  • Context menu now available when clicking a standard MDI window icon.
  • Context menu now available when right-clicking a standard MDI docking window title bar.
  • Support for optional automatic size-to-content when adding a docking window to MDI via the new DockingWindow.SizeToContentModes property.
  • Standard MDI window bounds is bound to new DockingWindow.StandardMdiBounds property.
  • Standard MDI window state is bound to new DockingWindow.StandardMdiWindowState property.
  • Add contextual UI to title bars via the DockingWindow.StandardMdiTitleBarContextContentTemplate property.
  • StandardMdiHost.IsExternalMaximizedUIRequired property added that indicates when external maximized window button UI should be displayed, useful in scenarios when AreMaximizedWindowFramesVisible is false.

MDI (Common)

  • DockSite.MdiKind property added, allowing for easy switching of MDI kinds. Use instead of old Workspace.SwitchToTabbedMdi and SwitchToStandardMdi methods.
  • DockSite.MdiKindChanged event added.
  • Added a new DockSite.SetMdiKindCommand property whose value can be wired up to menu items for easy MDI kind switching.
  • Added new DockSite.CascadeDocumentsCommand, TileDocumentsHorizontallyCommand, and TileDocumentsVerticallyCommand properties whose values can be wired up to menu items for easy MDI layout adjustments.
  • Added the DockSite.PrimaryDocument property and PrimaryDocumentChanged event, which replaces the LastActiveDocument property and LastActiveDocumentChanged event.
  • Added several DockSite methods like ActivatePrimaryDocument, ActivateNextDocument, ActivatePreviousDocument, and ClosePrimaryDocument, along with related commands.

MVVM

  • DockingWindow.IsOpen property can be set to true via a view-model binding to open the DockingWindow container in the layout without necessarily activating it.
  • DockingWindow.IsActive property can be set to true via a view-model binding to make the DockingWindow container active (focused).
  • DockingWindow.IsSelected property can be set to true via a view-model binding to ensure the DockingWindow container is selected within its container.
  • DockingWindow.State property setter added, which can be set via a view-model binding to alter the ToolWindow container's state (docked, auto-hide, or document).
  • MVVM implementation improved to be more straightforward since docking windows are now the actual container of their content.
  • When a docking window becomes unregistered, it will also attempt to remove the related item from the ToolItemsSource or DocumentItemsSource properties if they implement a non-read-only IList and DockSite.CanUpdateItemsSourceOnUnregister remains true.
  • Newer, simplified samples for basic MVVM design without the need for an external behavior class as in the previous version.
  • DockSite.ItemContainerRetentionMode property removed since it is no longer needed due to restructuring of DockingWindow control hierarchy.
  • Docking windows can be defined in XAML and have their IsOpen property set to false to close them on initial dock site load, but leave behind a breadcrumb for future restoration.

Switcher

  • Reimplemented StandardSwitcher with a new, more modern user interface that animates on display and supports scrolling when there is overflow.
  • Added the StandardSwitcher.HeaderTemplate and FooterTemplate properties that can be used to customize the header/footer presentation for the selected window.
  • Added the StandardSwitcher.ItemContainerStyle and ItemTemplate properties that can be used to customize the appearance of window list items. The new container class is StandardSwitcherItem.
  • Added the StandardSwitcher.ScrollButtonStyle, ScrollUpButtonContentTemplate, and ScrollDownButtonContentTemplate properties that can be used to customize the appearance of scroll up/down buttons that display as needed.
  • Added the StandardSwitcher.MaxRowCount property, that sets the maximum number of item rows that can be displayed.
  • Renamed StandardSwitcher.MaxDocumentsColumns to MaxDocumentColumnCount.
  • Moved the switcher controls into the main Docking namespace.

WindowControl

  • WindowControl.DragMove method now requires an input event args so that it can capture the related pointer referenced in the event args.
  • WindowControl.RestoreBounds property renamed to RestoredBounds.
  • WindowControl.WindowStyle property removed.

Miscellaneous

  • All UI control styles/templates rebuilt from scratch to be simpler and easier to customize.
  • Quick subtle animations updated and added throughout the product to give it a more vibrant feel.
  • Refactored context and drop-down menu customization design. The old DockSite.WindowContextMenu event was renamed to MenuOpening.
  • Refactored and centralized focus handling and setting logic.
  • Refactored magnetism handling.
  • DockSite.PrimaryDockHost and FloatingDockHosts properties added.
  • DockSite.Child property should now be used to specify the child element, instead of Content, which has been removed.
  • DockSite.Workspace property removed since floating dock hosts now support full MDI features. Use DockSite.PrimaryDockHost.Workspace to access what used to be in DockSite.Workspace.
  • DockSite.ToHierarchyString method added that returns a string containing a textual representation of the hierarchy.
  • DockSite.DefaultControlSize and MinimumSlot properties removed. Use the new DockingWindow.ContainerDockedSize and ContainerMinSize properties instead.
  • DockSite.FullScreen property removed since it wouldn't work well with the new floating MDI features.
  • SingleTabLayoutBehavior.Stretch property removed since another property may be added in the future to stretch all tabs when there is space, instead of only when there is one tab.
  • ActiproSoftware.Windows.Controls.Docking.Preview and ActiproSoftware.Windows.Controls.Docking.Switching namespaces removed and their contents merged into other namespaces.
  • The older Docking/MDI versions relied on inherited attached properties to register docking-related controls with the DockSite. This approach is no longer to used since use of inherited properties can affect performance. Now the registrations are done based on the proper control hierarchy being established, such as a MDI host being a direct child of a Workspace.
  • Rewrote UIA to ensure better compatibility with Coded UI Test.

AdvancedTabControl

  • Standalone control that can be used independently of docking windows.
  • Normal, pinned, and preview tabs.
  • Minimum and maximum tab sizes; set the same to make fixed size tabs.
  • Place tabs on any side.
  • Use tab item properties to adjust tab brushes, side border slant (WPF only), and corner radius.
  • Numerous overflow options.
  • Animated overflow scrolling.
  • Animated tab layout changes and tab insertions.
  • Animated tab drag/drop support.
  • New tab button, that can be optionally included and styled.
  • Customizable embedded button appearances.
  • Multiple tab highlight states including: none, pointer over, active selected, preview, preview pointer over, preview active selected, and inactive selected.
  • Tabs can optionally always show embedded buttons.
  • Options for tab close, pin, and promote support.
  • Option to close tab on middle-click.
  • Show any custom contextual content.
  • Read-only flag can auto-set a read-only contextual content.
  • Keyboard shortcuts (e.g. Ctrl+1) can directly access normal tabs by tab number.
  • Keyboard shortcuts (e.g. Ctrl+Alt+1) can directly access pinned tabs by tab number.
  • Optional Ctrl+Tab and Ctrl+Shift+Tab support to switch tabs.
Temporary Inclusion of Older Docking and Prism Interop Legacy Assemblies

We recognize that for the 2016.1 version, numerous breaking changes were made and that you might not be able to immediately update to the newer logic. While we fully encourage you to do so since all future updates and maintenance will only be done on this newer Docking/MDI codebase, we still offer the older Docking/MDI version along with its related pre-compiled Prism interop assemblies.

These older legacy assemblies are not installed by default. You must check the 'Control Assemblies / Legacy' option in the installer to install them. Once you do so, these Docking/MDI-related assemblies will appear in a 'Legacy' subfolder of the Actipro assembly install folder (see the Deployment topic for the default location), but will not appear in the GAC:

  • ActiproSoftware.Docking.Legacy.Wpf.dll
  • ActiproSoftware.Docking.Interop.Prism.Legacy.Wpf.dll

You will be able to reference the ActiproSoftware.Docking.Legacy.Wpf assembly in place of the new ActiproSoftware.Docking.Wpf assembly to maintain full backward compatibility with the old version, while you work on upgrading your application to the new version.

See the Licensing topic for info on how to add an entry to the licenses.licx file (updated info added in v2017.1).

Do NOT reference both the ActiproSoftware.Docking.Wpf and ActiproSoftware.Docking.Legacy.Wpf assemblies in the same project, since they have many types/members named the same.

Again, these legacy assemblies will only be included temporarily. We encourage you to upgrade your code to the latest Docking/MDI assembly as soon as it is feasible so that you can continue to receive the latest product feature additions and bug fixes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

This topic contains troubleshooting data specific to the Docking & MDI product.

Note Note
For some more troubleshooting information that relates both to this product as well as other WPF Studio products, please see the more general TroubleShooting topic.

This topic contains these sections:

  • Document/Tool Window Content Sizing Is Incorrect
  • Programmatic Layout Updates Don't Work Until Loaded
  • Document/ToolWindow DataContext Cleared On Layout Changes
  • Active Window is Incorrect With Interop Controls
  • Implicit Style/DataTemplate Is Not Always Applied

Document/Tool Window Content Sizing Is Incorrect

A common mistake is to set the Width, Height, MinWidth, MinHeight, MaxWidth, or MaxHeight properties of a docking window (ToolWindow or DocumentWindow) instance. Since the docking elements need to dynamically change their size based on their location, these properties should never be set by you.

Instead, you can set the DockingWindow.ContainerDockedSize, ContainerMinSize, ContainerMaxSize, and ToolWindow.ContainerAutoHideSize properties as appropriate for your needs.

See the Lifecycle and Docking Management topic for details on using these properties.

Programmatic Layout Updates Don't Work Until Loaded

Sometimes docking windows are programmatically added to a layout (via opening, docking, layout loading, etc.) within the contructor of a root element like a Window or UserControl after its InitializeComponent method executes. In situations like this, the code to add the docking windows to the layout needs to be performed at or after the time that root element's Loaded event fires.

When the root element has loaded, that means that all the templates of the control hierarchy within the dock site have been properly loaded and applied as well. The dock site and its features are then ready for programmatic interaction.

Document/ToolWindow DataContext Cleared On Layout Changes

In many common app design scenarios, you set a data context on a root container in your element hierarchy. Naturally you expect it to inherit down the tree of elements and into the ToolWindow and DocumentWindow.DataContext properties.

While that may work on initial load, the problem is that as soon as the layout changes, such as when an end user drags a tool window to float, the DataContext will clear. This is because the tool window has now moved to a new root container, and the data context is no longer inheriting down.

Note Note
This issue is not present when using our MVVM Features since in that case, the DataContext of each docking window becomes the item you bound in the DockSite.ToolItemsSource or DocumentItemsSource properties.

If the content of your docking windows will rely on a data context that normally would be inherited down, you should explicitly bind your docking window's DataContext property to the dock site's DataContext like this:

XAML
Copy
​<docking:DockSite x:Name="dockSite">
    <docking:SplitContainer>
        <docking:Workspace />
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="DataContext Test" DataContext="{Binding ElementName=dockSite, Path=DataContext}">
                <TextBlock Text="{Binding}" />
            </docking:ToolWindow>
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>

By doing that, you ensure that the docking window data contexts will still match the dock site's data context, even when any layout changes occur, such as floating windows.

The same concept applies if you have a Workspace that has direct content (no MDI) and that content relies on an inherited data context. Changing the docking window layout around the workspace will briefly cause the workspace to be removed from and added back into the layout. Both are actions that temporarily change the inherited data context. By using a binding as above on the workspace's data context, that can be prevented.

Active Window is Incorrect With Interop Controls

The DockSite.ActiveWindow property might not be correct when clicking into interop (WinForms, ActiveX, etc.) controls. This is due to issues WPF has with tracking focus that enters HwndHost controls, and then properly reporting it back in WPF events.

We include a helper that is generally able to work around the focus tracking issues. See the Interop Compatibility topic for details.

Implicit Style/DataTemplate Is Not Always Applied

The DockSite leverages one or more Window instances that contain a DockHost for floating document and/or tool windows when DockSite.UseHostedFloatingWindows is false (the default). Therefore, any implicit Style or DataTemplate definitions must be defined in the application resources, so they will be available to the main window and any floating windows.

Alternatively, the implicit Style or DataTemplate definitions can be redefined/merged in the resources of a floating DockHost. This can be accomplished in a DockSite.FloatingWindowOpening event handler.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Editors provide a number of edit controls for common .NET data types such as dates, times, numbers, brushes, colors, enumerations, sizes, and many more. Other miscellaneous controls include a regex-based masked textbox, auto-complete box, calculator, month calendar, star rating, gradient stop slider, and various color component pickers.

Each of the controls features unique designs that have been specifically crafted to support input by keyboard, mouse, and touch. The control appearances align with other native controls, allowing them to be dropped right into an app and be instantly approachable by end users.

Features

Edit Boxes

  • Common Features
    • Ability to type values directly in, or use mouse/touch to show advanced picker drop-downs.
    • Typed-in values are validated when committed.
    • Use up/down arrow and PgUp/PgDn keys to cycle through known values in a current part.
    • Use left/right arrow keys to move between parts in multi-part edit boxes.
    • Optional null value support.
    • Optional clear and popup buttons.
    • Optional read-only mode.
    • Optional non-editable mode, changing behavior to be similar to a ComboBox.
    • Placeholder text and header support.
    • Drop-down picker customization options.
    • Renders just like a standard ComboBox.
    • Alternate appearance that automatically kicks in for Windows Phone usage.
  • .NET Types Supported
    • Brush - Shows brush swatch and optionally allows alpha component and gradients.
    • Byte - Display format, min/max values, and small/large change values supported.
    • Color - Shows color swatch and optionally allows alpha component.
    • CornerRadius - Display format, min/max values, and small/large change values supported.
    • Date - Display format, and min/max values supported. Can optionally retain time component.
    • DateTime - Display format, and min/max values supported.
    • Double - Display format, min/max values, and small/large change values supported.
    • Enum - Supports flags and non-flags enums. Optional custom sorting and use of display attributes.
    • Guid - New GUID generation button.
    • Int16 - Display format, min/max values, and small/large change values supported.
    • Int32 - Display format, min/max values, and small/large change values supported.
    • Int32Rect - Display format, min/max values, and small/large change values supported.
    • Int64 - Display format, min/max values, and small/large change values supported.
    • Point - Display format, min/max values, and small/large change values supported.
    • Rect - Display format, min/max values, and small/large change values supported.
    • Size - Display format, min/max values, and small/large change values supported.
    • Thickness - Display format, min/max values, and small/large change values supported.
    • Time - Display format, and min/max values supported.
    • TimeSpan - Display format, min/max values, and small/large change values supported.
    • Vector - Display format, min/max values, and small/large change values supported.

Pickers

  • Common Features
    • Designed for keyboard, mouse, and touch support and generally used in drop-downs.
    • Has many of the same options found in the related edit box.
  • .NET Types Supported
    • Brush - Combines a ColorPicker with GradientStopSlider for brush entry.
    • Byte - Uses a radial slider or calculator.
    • Color - Combines a HsbColorPicker with multiple Int32EditBox controls for ARGB component entry.
    • CornerRadius - Uses tabbed radial sliders.
    • Date - Users a MonthCalendar.
    • DateTime - Combines a MonthCalendar and TimePicker.
    • Double - Uses a radial slider or calculator.
    • Enum - Uses an EnumListBox.
    • Int16 - Uses a radial slider or calculator.
    • Int32 - Uses a radial slider or calculator.
    • Int32Rect - Uses tabbed radial sliders.
    • Int64 - Uses a radial slider or calculator.
    • Point - Uses tabbed radial sliders.
    • Rect - Uses tabbed radial sliders.
    • Single - Uses a radial slider or calculator.
    • Size - Uses tabbed radial sliders.
    • Thickness - Uses tabbed radial sliders.
    • Time - Uses radial sliders to input hour and minute values, similar to an analog clock.
    • TimeSpan - Uses tabbed radial sliders.
    • Vector - Uses tabbed radial sliders.

Other Controls

  • AutoCompleteBox - Text entry with auto-completion, useful for search query and quick launch box scenarios.
  • Calculator - Provides a familiar calculator interface to interactively calculate numeric values.
  • CountryComboBox - Includes a complete country list as defined by the ISO.
  • CurrencyComboBox - Includes a complete currency list as defined by the ISO.
  • EnumListBox - Presents the values of an enumeration in a list box. Supports flags and non-flags enums.
  • GradientStopSlider - Modify the stops within a gradient brush.
  • HsbColorPicker - Selects a HSB (hue, saturation, brightness) color via a RadialHuePicker and SaturationBrightnessPicker.
  • MaskedTextBox - A text box that restricts input based on a specified regular expression mask. Support for input prompts and literal completion is included.
  • MonthCalendar - Month, year, decade, and century views with animated changes. Appearance customization supported.
  • RadialHuePicker - Uses a radial slider to select a color hue.
  • Rating - Renders glyphs that can be used present an average rating or collect a user rating.
  • SaturationBrightnessPicker - Uses a 2D slider to select saturation/brightness values in a square.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Getting started with Editors is simple. Follow the steps below to build your first chart.

This topic contains these sections:

  • Add Assembly References
  • Add Any Editor Control
  • Further Study

Add Assembly References

First, add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.Editors.Wpf.dll assemblies. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Add Any Editor Control

This 'xmlns' declaration in your root XAML control allows access to the various controls in this product:

XAML
Copy
​xmlns:editors="http://schemas.actiprosoftware.com/winfx/xaml/editors"

Then find the parent element that will contain the editor. This could be a UserControl or any other type of UIElement.

Next, add an editor control to the desired parent element. In this sample we will add a Int32EditBox:

XAML
Copy
​<editors:Int32EditBox Minimum="1" Maximum="100" />

Next configure the control's options, set up a binding to the Value property, and you are all done.

There are over 30 editor controls contained in this product. Be sure to check them all out.

Further Study

To familiarize yourself with all of the features in Editors, take a look at the feature documentation and also look at the numerous QuickStarts located in the sample project.

If you require further assistance after looking through those, please visit our Editors support forum.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Editors includes a number of edit boxes, which are controls that allow for the editing/selection of common data type values. They are designed to visually fit right in with the standard Windows controls.

This topic contains these sections:

  • Edit Box Basics
  • Edit Box Controls

Edit Box Basics

All of the edit box controls listed below share a base class that provides common core functionality.

See the Edit Box Basics topic for more information.

Edit Box Controls

This table shows the edit box controls that are included in the product:

Name | Description
BrushEditBox | Allows for the input of a Brush value.
ByteEditBox | Allows for the input of a Byte (8-bit positive integer) value.
ColorEditBox | Allows for the input of a Color value.
CornerRadiusEditBox | Allows for the input of a CornerRadius (top-left, top-right, bottom-right, bottom-left) value.
DateEditBox | Allows for the input of a DateTime value's date component.
DateTimeEditBox | Allows for the input of a DateTime value.
DoubleEditBox | Allows for the input of a Double (floating-point number) value.
EnumEditBox | Allows for the input of an Enum (flags and non-flags enumeration) value.
GuidEditBox | Allows for the input of a Guid (unique ID) value.
Int16EditBox | Allows for the input of an Int16 (16-bit integer) value.
Int32EditBox | Allows for the input of an Int32 (32-bit integer) value.
Int32RectEditBox | Allows for the input of an Int32Rect (X, Y, width, height) value.
Int64EditBox | Allows for the input of an Int64 (64-bit integer) value.
PointEditBox | Allows for the input of a Point (X, Y) value.
RectEditBox | Allows for the input of a Rect (X, Y, width, height) value.
SingleEditBox | Allows for the input of a Single (floating-point number) value.
SizeEditBox | Allows for the input of a Size (width, height) value.
ThicknessEditBox | Allows for the input of a Thickness (left, top, right, bottom) value.
TimeEditBox | Allows for the input of a DateTime value's time component.
TimeSpanEditBox | Allows for the input of a TimeSpan (days, hours, minutes, seconds, milliseconds) value.
VectorEditBox | Allows for the input of a Vector (X, Y) value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Edit Box Basics

All of the edit box controls share a PartEditBoxBase`1 base class that provides common core functionality.

This topic contains these sections:

  • Designed for Keyboard, Mouse, and Touch Input
  • Values
  • Null Values
  • Value Validation
  • Incrementing/Cycling Values
  • Moving Between Parts
  • Input Scope Hints
  • Read-Only Mode
  • Non-Editable Mode
  • Popups and Picker Customization
  • Placeholder Text
  • Disabling Undo/Redo
  • Inline UI Elements
  • Appearances That Match Native Controls

Designed for Keyboard, Mouse, and Touch Input

Unlike many other third party editor controls, the Actipro Editors have been specifically designed to work great for whichever form of input (keyboard, mouse, or touch) is utilized by the end user.

Each editor's main appearance is similar to a standard TextBox, where the value can be typed in via a keyboard for maximum efficiency. Certain keyboard keys and the mouse wheel can often be used to increment/cycle values. See the related section below for more information.

Most editors also contain a default popup picker that is geared for mouse and touch-based input. The popup can easily be invoked by tapping the edit box's drop-down button, if it is optionally displayed.

Values

The Value property gets/sets the value that is being edited by the edit box. When using an edit box in your UI, you generally want to bind this property to your view model via two-way binding.

As the user types in a value, the temporary value derived from the text being typed is available in the IntermediateValue property. This intermediate value gets 'committed' (or set to the Value property) when Enter is pressed, or the control loses focus. There also is a Commit method that will programmatically commit the intermediate value. In the event that a typed value isn't desired, the user can press Esc to revert back to the last committed value.

When the Value property is changed, the ValueChanged event is raised.

Null Values

The IsNullAllowed property determines if a null value is permitted. It can be set to false to designate that a non-null value is required.

Many of the Value properties are implemented as nullable types. For instance, the Int32EditBox.Value property is of type Nullable<Int32>. When IsNullAllowed is false, an integer will always be returned in the Value property and the control will make its default value show 0 instead of blank text.

Value Validation

Value validation occurs when the user types in a value and attempts to commit it. In this scenario, the protected TryConvertFromString method is called and the edit box attempts to convert the typed text into a value. Then that value is checked via a call to the IsValidValue method. If no conversion is possible or if the value fails validation, the value is not committed.

Custom conversion and validation logic can be implemented by overriding the TryConvertFromString and its related ConvertToString method.

Incrementing/Cycling Values

Up/down arrow keys, PgUp/PgDn keys, and the mouse wheel can all be used to increment and decrement the value in many edit boxes.

The up/down arrow keys and mouse wheel will cycle values by a small amount (in the case of numbers) and PgUp/PgDn keys will cycle values by a larger amount.

The SpinWrapping property property determines the wrapping behavior used when spinning past a minimum or maximum value in the active part. See the documentation on the SpinWrapping enumeration for more information on the available options.

Moving Between Parts

Some edit boxes have multiple component parts. An example is the TimeEditBox, which generally has hour, minute, and AM/PM parts.

For these types of edit boxes, the IsArrowKeyPartNavigationEnabled property determines if the left/right arrow keys move between parts. When true, pressing one of those arrow keys will move to the previous/next part and select its text. This makes it easy to quickly jump to a certain component of the value being edited and then either type over that component value or increment/cycle it.

Input Scope Hints

The InputScopeNameValue property accepts a value of type InputScopeNameValue, which provides a hint of how non-read-only edit boxes should display their soft keyboards. Edit boxes with number, date, and time values will default to a Number setting, while all others will use the Default setting.

Read-Only Mode

When the IsReadOnly property is true, the text in the edit box remains selectable but is read-only and can't be changed. Some edit boxes may still show a popup but the picker on the popup will remain read-only as well.

Non-Editable Mode

When the IsEditable property is false, the edit box converts its appearance and behavior to that of a standard ComboBox as long as the edit box indicates it has a popup. Tapping anywhere on the edit box will open an available popup, if there is one. The popup can be used to alter the value.

Up/down arrow keys, PgUp/PgDn keys, and the mouse wheel can be used to increment and decrement the value in non-editable edit boxes that have a single part.

When in non-editable mode, the standard clipboard keyboard shortcuts (Ctrl+C, Ctrl+X, and Ctrl+V) are available to get/set the text value of the edit box. Cut and paste will not modify the value if the control is in read-only mode.

Popups and Picker Customization

Most edit boxes have popups that can optionally be displayed, which contain pickers that are geared for mouse/touch data input. If a popup is available, a drop-down button will be displayed in the right side of the edit box. This drop-down button can be hidden by setting the HasPopup property to false.

Each edit box with a popup has a default picker control associated with it. For instance, the Int32EditBox control has a related separate Int32Picker control that is used in its popup. The edit box and pickers are named with the same prefix so that it's easy to know how they are paired up.

A custom picker style can be easily assigned to an edit box to give the picker a unique custom user interface. In the screenshot above, we've made a new Style for Int32Picker that uses a linear slider and assigned that style to the Int32EditBox.PopupPickerStyle property.

Placeholder Text

Edit boxes support placeholder text that is rendered when there is no value in the control. This text can be designated via the PlaceholderText property.

Disabling Undo/Redo

The IsUndoEnabled property, which defaults to true, can be set to false to prevent the text-editing portion of the control from supporting undo/redo.

Inline UI Elements

Edit boxes support the insertion of inline UI elements. For instance, you can inject a unit TextBlock in a DoubleEditBox, or a button that sets the current time in a TimeEditBox.

Inlines are specified via instances of the PartEditBoxInline class. The class requires that you set a DataTemplate to its ContentTemplate property. This DataTemplate will contain the UI elements for the inline.

The ContentPresenter that is generated behind the scenes to host the DataTemplate will have a WeakReference to the edit box as its Content/DataContext. We cannot pass the edit box control itself as Content since this ContentPresenter is inserted into the edit box, which could lead to issues with the framework. By passing a WeakReference, we can still provide the edit box as a data context while not triggering any framework issues. The distinction here is that you need to reference any properties on the edit box by prefixing the Path with "Target.", as in the example below.

This example shows how to insert a "Now" button into a TimeEditBox that uses the built-in SetValueToNowCommand.

XAML
Copy
​<editors:TimeEditBox>
    <editors:TimeEditBox.Inlines>
        <editors:PartEditBoxInlineCollection>
            <editors:PartEditBoxInline>
                <DataTemplate>
                    <Button Content="Now" Command="{Binding Target.SetValueToNowCommand}"
                            Style="{StaticResource {x:Static themes:SharedResourceKeys.EmbeddedButtonBaseStyleKey}}"
                            Padding="4,0" VerticalAlignment="Stretch" />
                </DataTemplate>
            </editors:PartEditBoxInline>
        </editors:PartEditBoxInlineCollection>
    </editors:TimeEditBox.Inlines>
</editors:TimeEditBox>

A similar SetValueToTodayCommand could also be used in a DateEditBox to change the value to today's date.

Appearances That Match Native Controls

The edit boxes have been carefully crafted to match the standard UI of related native controls found in Windows.

Above we see how a ColorEditBox fits right in with any standard Windows app TextBox or ComboBox.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


BrushEditBox

The BrushEditBox control allows for the input of a Brush value. It uses the BrushPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Alpha Transparency
  • Gradient Support
  • Swatch Display
  • Reusing Brushes
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | No.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Alpha Transparency

The BrushEditBox.IsAlphaEnabled property can be set to false to prevent alpha transparency from being supported.

When false, the edit box will only allow selection of RGB colors instead of ARGB colors.

Gradient Support

The BrushEditBox.IsGradientAllowed property can be set to false to prevent gradient brushes from being supported.

When false, the edit box will only allow selection of solid color brushes.

Swatch Display

The BrushEditBox.HasSwatch property defaults to true, meaning that a small swatch will display the Brush value. Set the property to false to hide the swatch.

The SwatchMargin property sets the margin thickness around the swatch.

Reusing Brushes

By default, the brush instance will generally be reused when a component like gradient stop is updated. But this prevents the ValueChanged event from firing on certain component changes, and also bindings to the Value property from updating when using value converters. The CanReuseBrush property can be set to false to force a new brush to be created any time a component is updated, which works around those issues.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:BrushEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ByteEditBox

The ByteEditBox control allows for the input of a Byte (8-bit positive integer) value. It uses the BytePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Built-in Picker Kinds
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C0 (currency without decimals)
  • D
  • Dx, where x is the number of zero-padded digits (e.g. D3)
  • G
  • N0
  • X (uppercase hexadecimal)
  • x (lowercase hexadecimal)

Basic custom numeric formats are also supported, such as:

  • 0' days'

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 8, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the ByteEditBox.PickerKind property, which is of type ByteEditBoxPickerKind.

The default value in WPF is Calculator.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:ByteEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ColorEditBox

The ColorEditBox control allows for the input of a Color value. It uses the ColorPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Alpha Transparency
  • Initial Value Comparison on Popup
  • Swatch Display
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Alpha Transparency

The ColorEditBox.IsAlphaEnabled property can be set to false to prevent alpha transparency from being supported.

When false, the edit box will only allow selection of an RGB color instead of an ARGB color.

Initial Value Comparison on Popup

When the ColorEditBox.IsInitialValueComparedOnPopup property is set to true (the default), the initial color will display on the left side of the picker hue ring's fill area. The initial color is the edit box's value as the picker popup opens. The right side of the picker hue ring's fill area will contain the current color value being selected. This allows the old and new values to be compared side-by-side.

If the property is set to false, the picker hue ring's fill area will be completely filled by the current color value being selected.

Swatch Display

The ColorEditBox.HasSwatch property defaults to true, meaning that a small swatch will display the Brush value. Set the property to false to hide the swatch.

The SwatchMargin property sets the margin thickness around the swatch.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • A (optional)
  • R
  • G
  • B

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current color component by a single unit. Large value changes alter the current color component by 16 units.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:ColorEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CornerRadiusEditBox

The CornerRadiusEditBox control allows for the input of a CornerRadius (top-left, top-right, bottom-right, bottom-left) value. It uses the CornerRadiusPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Rounding Decimal Places
  • Allowing NaN or Infinity Values
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Top-left
  • Top-right
  • Bottom-right
  • Bottom-left

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity component values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:CornerRadiusEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DateEditBox

The DateEditBox control allows for the input of a DateTime value's date component. It uses the DatePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Time Retention
  • Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Wrap.

Time Retention

When using separate DateEditBox and TimeEditBox controls that bind to the same DateTime object, it's sometimes helpful to have the DateEditBox retain the time portion as selections are made, instead of reverting the time to midnight. The CanRetainTime property can be set to true to enable time retention.

Note that a DateTimeEditBox can be used in place of separate DateEditBox and TimeEditBox controls if dates and times require input.

Formats

Standard date formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • d
  • D
  • m
  • y
  • MM/dd/yyyy
  • MM/dd/yy
  • yyyy-MM-dd
  • d MMMM yyyy
  • d MMM yyyy
  • dd.MM.yyyy
  • d.M.yyyy

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Year
  • Month
  • Day
  • Hour
  • Minute
  • Second
  • AM/PM

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DateEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DateTimeEditBox

The DateTimeEditBox control allows for the input of a DateTime value. It uses the DateTimePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Wrap.

Formats

Standard date/time formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • g
  • G
  • f
  • F
  • MM/dd/yyyy hh:mm tt
  • MM/dd/yy h:mm:ss tt
  • yyyy-MM-dd HH:mm:ss
  • d MMMM yyyy HH:mm
  • d MMM yyyy HH:mm
  • dd.MM.yyyy HH:mm
  • d.M.yyyy HH:mm

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Year
  • Month
  • Day

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DateTimeEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DoubleEditBox

The DoubleEditBox control allows for the input of a Double (floating-point number) value. It uses the DoublePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Rounding Decimal Places
  • Allowing NaN or Infinity Values
  • Built-in Picker Kinds
  • Sample XAML
  • Sample XAML for Currency Input

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C (currency)
  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G
  • N
  • Nx, where x is the number of decimal places (e.g. N1)
  • P (percentage)

Basic custom numeric formats are also supported, such as:

  • 0.0#' ft'

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the DoubleEditBox.PickerKind property, which is of type DoubleEditBoxPickerKind.

The default value in WPF is Calculator.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DoubleEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Sample XAML for Currency Input

This control is great for currency input, which can be implemented with this XAML:

XAML
Copy
​<editors:DoubleEditBox Format="C" Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EnumEditBox

The EnumEditBox control allows for the input of an Enum (flags and non-flags enumeration) value. It uses the EnumPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Enumeration Value and Type
  • Using Display Attributes
  • Custom Sorting
  • Hiding Enumeration Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes. Non-editable by default.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Simple wrap.

Enumeration Value and Type

The Value property provides a quick and easy way to setup to the list box. The EnumType property is used to to build the items presented by the EnumEditBox. The items are constructed by reflecting the enumeration type, with full support for the FlagsAttribute.

When the Value property is bound/set to a non-null enumeration value, then the enumeration type will be automatically set (if it has not been explicitly set). Therefore, the EnumType only needs to be set when Value is bound to a nullable enumeration type.

Using Display Attributes

Sometimes it is helpful to display an alternate text version of an enumeration value, especially when the values are made of multiple concatenated words. For instance, an enumeration value named "FooBar" might appear nicer as "Foo Bar".

This scenario is fully supported by EnumEditBox. A System.ComponentModel.DataAnnotations.DisplayAttribute can be applied to a value to give it an alternate textual description. Then as long as the UseDisplayAttributes property is set to true, that alternate text will be used.

If the DisplayAttribute.ResourceType property is left blank, it will use the direct value specified by the Name property. Otherwise, it will look in the specified resource Type for a localized resource value within the property indicated by Name.

In this example, the DisplayAttribute will look for a property named MyFirstValue in the string resources type MyResources and use that property's value:

C#
VB
Copy
​public enum SampleEnum {

    [Display(ResourceType = typeof(MyResources), Name = "MyFirstValue")]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <Display(ResourceType := GetType(MyResources), Name := "MyFirstValue")>
    MyFirstValue = 1

    ...
End Enum

Note Note
The WPF version of EnumEditBox also supports System.ComponentModel.DescriptionAttribute to supply textual descriptions in place of System.ComponentModel.DataAnnotations.DisplayAttribute.

Custom Sorting

By default, values are listed in the order they are defined. The exception is that in flags enums, group values get placed together.

Sorting can be altered by implementing a custom IComparer<Enum> class and assigning it to the EnumSortComparer property. The EnumValueNameSortComparer.Instance static property provides access to a pre-built comparer for listing enumeration values alphabetically by name.

Hiding Enumeration Values

By default, all values are listed in the control's popup and when cycling through values using arrow keys. If you wish to hide a specific value from the end user, use EditorBrowsableAttribute on the value with EditorBrowsableState.Never.

In this example, the EditorBrowsableAttribute hides the MyFirstValue value from the user interface:

C#
VB
Copy
​public enum SampleEnum {

    [EditorBrowsable(EditorBrowsableState.Never)]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <EditorBrowsable(EditorBrowsableState.Never)>
    MyFirstValue = 1

    ...
End Enum

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented as long as a single value is specified. Please see the Edit Box Basics topic for information on how to do this.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:EnumEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


GuidEditBox

The GuidEditBox control allows for the input of a Guid (unique ID) value.

This topic contains these sections:

  • Common Capabilities
  • Generating a New GUID
  • Formats
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | No.
Has a popup | No.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Generating a New GUID

The plus button in the edit box can be used to generate a new GUID value.

Formats

Standard GUID formats are supported via the Format property and affect the textual value display. These formats are allowed:

  • N - 32 digits (uppercase)
  • n - 32 digits (lowercase)
  • D - 32 digits separated by hyphens (uppercase)
  • d - 32 digits separated by hyphens (lowercase)
  • B - 32 digits separated by hyphens, enclosed in braces (uppercase)
  • b - 32 digits separated by hyphens, enclosed in braces (lowercase)
  • P - 32 digits separated by hyphens, enclosed in parentheses (uppercase)
  • p - 32 digits separated by hyphens, enclosed in parentheses (lowercase)

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:GuidEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int16EditBox

The Int16EditBox control allows for the input of an Int16 (16-bit integer) value. It uses the Int16Picker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Built-in Picker Kinds
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C0 (currency without decimals)
  • D
  • Dx, where x is the number of zero-padded digits (e.g. D3)
  • G
  • N0
  • X (uppercase hexadecimal)
  • x (lowercase hexadecimal)

Basic custom numeric formats are also supported, such as:

  • 0' days'

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the Int16EditBox.PickerKind property, which is of type Int16EditBoxPickerKind.

The default value in WPF is Calculator.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int16EditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int32EditBox

The Int32EditBox control allows for the input of an Int32 (32-bit integer) value. It uses the Int32Picker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Built-in Picker Kinds
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C0 (currency without decimals)
  • D
  • Dx, where x is the number of zero-padded digits (e.g. D3)
  • G
  • N0
  • X (uppercase hexadecimal)
  • x (lowercase hexadecimal)

Basic custom numeric formats are also supported, such as:

  • 0' days'

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the Int32EditBox.PickerKind property, which is of type Int32EditBoxPickerKind.

The default value in WPF is Calculator.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int32EditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int32RectEditBox

The Int32RectEditBox control allows for the input of an Int32Rect (X, Y, width, height) value. It uses the Int32RectPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • D
  • Dx, where x is the number of digits (e.g. D2)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • X
  • Y
  • Width
  • Height

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int32RectEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int64EditBox

The Int64EditBox control allows for the input of an Int64 (64-bit integer) value. It uses the Int64Picker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Built-in Picker Kinds
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C0 (currency without decimals)
  • D
  • Dx, where x is the number of zero-padded digits (e.g. D3)
  • G
  • N0
  • X (uppercase hexadecimal)
  • x (lowercase hexadecimal)

Basic custom numeric formats are also supported, such as:

  • 0' days'

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the Int64EditBox.PickerKind property, which is of type Int64EditBoxPickerKind.

The default value in WPF is Calculator.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int64EditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PointEditBox

The PointEditBox control allows for the input of a Point (X, Y) value. It uses the PointPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Rounding Decimal Places
  • Allowing NaN or Infinity Values
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • X
  • Y

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity component values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:PointEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RectEditBox

The RectEditBox control allows for the input of a Rect (X, Y, width, height) value. It uses the RectPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Rounding Decimal Places
  • Allowing NaN or Infinity Values
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • X
  • Y
  • Width
  • Height

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity component values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:RectEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SingleEditBox

The SingleEditBox control allows for the input of a Single (floating-point number) value. It uses the SinglePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Rounding Decimal Places
  • Allowing NaN or Infinity Values
  • Sample XAML
  • Built-in Picker Kinds
  • Sample XAML for Currency Input

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C (currency)
  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G
  • N
  • Nx, where x is the number of decimal places (e.g. N1)
  • P (percentage)

Basic custom numeric formats are also supported, such as:

  • 0.0#' ft'

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 7, but can be set to any value in the range 0 to 7. Or set the value to null to prevent rounding.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SingleEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the SingleEditBox.PickerKind property, which is of type SingleEditBoxPickerKind.

The default value in WPF is Calculator.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML for Currency Input

This control is great for currency input, which can be implemented with this XAML:

XAML
Copy
​<editors:SingleEditBox Format="C" Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SizeEditBox

The SizeEditBox control allows for the input of a Size (width, height) value. It uses the SizePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Rounding Decimal Places
  • Allowing NaN or Infinity Values
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Width
  • Height

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity component values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SizeEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ThicknessEditBox

The ThicknessEditBox control allows for the input of a Thickness (left, top, right, bottom) value. It uses the ThicknessPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Rounding Decimal Places
  • Allowing NaN or Infinity Values
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Left
  • Top
  • Right
  • Bottom

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity component values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:ThicknessEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TimeEditBox

The TimeEditBox control allows for the input of a DateTime value's time component. It uses the TimePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Wrap.

Formats

Standard time formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • t
  • T
  • hh:mm tt
  • h:mm:ss tt
  • HH:mm:ss
  • HH:mm

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Hour
  • Minute
  • Second
  • AM/PM

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:TimeEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TimeSpanEditBox

The TimeSpanEditBox control allows for the input of a TimeSpan (days, hours, minutes, seconds, milliseconds) value. It uses the TimeSpanPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Wrap.

Formats

Standard time formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • c
  • g
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Days
  • Hours
  • Minutes
  • Seconds
  • Milliseconds

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by other amounts, based on the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:TimeSpanEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


VectorEditBox

The VectorEditBox control allows for the input of a Vector (X, Y) value. It uses the VectorPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Rounding Decimal Places
  • Allowing NaN or Infinity Values
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a spinner | Yes, and can be hidden or optionally displayed only when the control is active.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard .NET numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • X
  • Y

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

The DefaultValue property sets the value that will be set when incrementing or decrementing from a null value.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity component values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:VectorEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Editors includes a number of pickers that are generally intended to be used within popups. In many cases, the pickers are designed to work with a related edit box of a similar name.

This topic contains these sections:

  • Picker Controls

Picker Controls

This table shows the picker controls that are included in the product:

Name | Description
BrushPicker | Allows for the input of a Brush value.
BytePicker | Allows for the input of a Byte (8-bit positive integer) value.
ColorPicker | Allows for the input of a Color value.
CornerRadiusPicker | Allows for the input of a CornerRadius (top-left, top-right, bottom-right, bottom-left) value.
DatePicker | Allows for the input of a DateTime value's date component.
DateTimePicker | Allows for the input of a DateTime value.
DoublePicker | Allows for the input of a Double (floating-point number) value.
EnumPicker | Allows for the input of an Enum (flags and non-flags enumeration) value.
HsbColorPicker | Allows for the input of a Color value.
Int16Picker | Allows for the input of an Int16 (16-bit integer) value.
Int32Picker | Allows for the input of an Int32 (32-bit integer) value.
Int32RectPicker | Allows for the input of an Int32Rect (X, Y, width, height) value.
Int64Picker | Allows for the input of an Int64 (64-bit integer) value.
PointPicker | Allows for the input of a Point (X, Y) value.
RadialHuePicker | Allows for the input of a color's hue component.
RectPicker | Allows for the input of a Rect (X, Y, width, height) value.
SaturationBrightnessPicker | Allows for the input of a color's saturation and brightness components.
SinglePicker | Allows for the input of a Single (floating-point number) value.
SizePicker | Allows for the input of a Size (width, height) value.
ThicknessPicker | Allows for the input of a Thickness (left, top, right, bottom) value.
TimePicker | Allows for the input of a DateTime value's time component.
TimeSpanPicker | Allows for the input of a TimeSpan (days, hours, minutes, seconds, milliseconds) value.
VectorPicker | Allows for the input of a Vector (X, Y) value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


BrushPicker

The BrushPicker control makes it easy for end users to select a Brush via touch or a mouse. It is generally intended for display within a popup, such as for the BrushEditBox control.

It combines a horizontal list for picking the brush kind, along with ColorPicker and GradientStopSlider controls for modifying the brush value.

Alpha transparency and gradients are also optionally supported.

This topic contains these sections:

  • Alpha Transparency
  • Gradient Support
  • Null Support
  • Reusing Brushes
  • Sample XAML

Alpha Transparency

The BrushPicker.IsAlphaEnabled property governs whether alpha transparency is supported.

When false, the edit box will only allow selection of RGB colors instead of ARGB colors.

Gradient Support

The BrushPicker.IsGradientAllowed property can be set to false to prevent gradient brushes from being supported.

When false, the picker will hide all brush kind options related to gradients.

Null Support

The BrushPicker.IsNullAllowed property can be set to false to always require that a valid Brush value is present, and that null is not supported.

When false, the picker will hide the null brush kind option.

Reusing Brushes

By default, the brush instance will generally be reused when a component like gradient stop is updated. But this prevents the ValueChanged event from firing on certain component changes, and also bindings to the Value property from updating when using value converters. The CanReuseBrush property can be set to false to force a new brush to be created any time a component is updated, which works around those issues.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:BrushPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


BytePicker

The ByteEditBox control allows for the input of a Byte (8-bit positive integer) value. It is generally intended for display within a popup, such as for the ByteEditBox control.

The control allows for selection of an Byte value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:BytePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ColorPicker

The ColorPicker control makes it easy for end users to select a color via touch or a mouse. It is generally intended for display within a popup, such as for the ColorEditBox control.

It combines a HsbColorPicker with edit boxes for RGB (red, green, blue). This allows the end user to select the color either via HSB (hue, saturation, brightness) or RGB values. In addition, a drop-down allows selection of a HSB text input mode, where HSB edit boxes are displayed in place of the RGB ones.

Alpha transparency selection is also optionally supported.

This topic contains these sections:

  • Alpha Transparency
  • Embedded ColorEditBox
  • Comparison Value
  • Sample XAML

Alpha Transparency

The ColorPicker.IsAlphaEnabled property governs whether alpha transparency is supported.

When false, the edit box will only allow selection of an RGB color instead of an ARGB color.

Embedded ColorEditBox

The ColorPicker.HasColorEditBox property, which defaults to true, defines whether a ColorEditBox is embedded within the picker.

The edit box is used to display and allow editing of the hex color value.

Comparison Value

The ColorPicker.IsComparisonValueVisible property can be set to true to display a comparison color value on the left side of the hue ring's fill area. The color displayed is specified by the ComparisonValue property.

This is useful when setting up a comparison of old/new color values.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:ColorPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CornerRadiusPicker

The CornerRadiusPicker control allows for the input of a CornerRadius (top-left, top-right, bottom-right, bottom-left) value. It is generally intended for display within a popup, such as for the CornerRadiusEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the TopLeft, TopRight, BottomRight or BottomLeft component of the CornerRadius. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Rounding Decimal Places
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:CornerRadiusPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DatePicker

The DatePicker control allows for the input of a DateTime value's date component. It uses a month calendar with animated view changes and its design is similar to the layout of a standard calendar, making it instantly approachable by end users.

Use the previous/next buttons in the calendar's header to navigate to a nearby month, or tap the current view's title to 'zoom out' to year, decade, or century views.

The DatePicker directly embeds a MonthCalendar control to provide the functionality mentioned above. See the MonthCalendar topic for more information on that control's capabilities.

This topic contains these sections:

  • Time Retention
  • Minimum and Maximum Values
  • Sample XAML

Time Retention

When using separate DatePicker and TimePicker controls that bind to the same DateTime object, it's sometimes helpful to have the DatePicker retain the time portion as selections are made, instead of reverting the time to midnight. The CanRetainTime property can be set to true to enable time retention.

Note that a DateTimePicker can be used in place of separate DatePicker and TimePicker controls if dates and times require input.

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DatePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DateTimePicker

The DateTimePicker control allows for the input of a DateTime value using a month calendar with animated view changes for date selection, and two radial sliders for time selection. Its design is similar to the layout of a standard calendar and clock, making it instantly approachable by end users.

Use the previous/next buttons in the calendar's header to navigate to a nearby month, or tap the current view's title to 'zoom out' to year, decade, or century views.

The time portion's inner radial slider sets the hours value. It can be rotated up to two full cycles, where each cycle represents a 12 hour period. The outer radial slider sets the minutes value, and can be rotated freely.

The toggle at the top determines whether the DateTimePicker is currently modifying the date or time component of the DateTime. The date component is edited with a DatePicker and the time component is edited with a TimePicker.

This topic contains these sections:

  • Minimum and Maximum Values
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DateTimePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DoublePicker

The DoublePicker control allows for the input of a Double (floating-point number) value. It is generally intended for display within a popup, such as for the DoubleEditBox control, and is also used within many other pickers.

The control allows for selection of a Double value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Rounding Decimal Places
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DoublePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EnumPicker

The EnumPicker control allows for the input of an Enum value using a standard list presentation. It supports both flags and non-flags enumerations, altering the user interface as appropriate.

The EnumPicker directly embeds an EnumListBox control to provide the functionality mentioned above.

This topic contains these sections:

  • Enumeration Value and Type
  • Using Display Attributes
  • Custom Sorting
  • Hiding Enumeration Values
  • Sample XAML

Enumeration Value and Type

The Value property provides a quick and easy way to setup to the list box. The EnumType property is used to to build the items presented by the EnumPicker. The items are constructed by reflecting the enumeration type, with full support for the FlagsAttribute.

When the Value property is bound/set to a non-null enumeration value, then the enumeration type will be automatically set (if it has not been explicitly set). Therefore, the EnumType only needs to be set when Value is bound to a nullable enumeration type.

Using Display Attributes

Sometimes it is helpful to display an alternate text version of an enumeration value, especially when the values are made of multiple concatenated words. For instance, an enumeration value named "FooBar" might appear nicer as "Foo Bar".

This scenario is fully supported by EnumPicker. A System.ComponentModel.DataAnnotations.DisplayAttribute can be applied to a value to give it an alternate textual description. Then as long as the UseDisplayAttributes property is set to true, that alternate text will be used.

If the DisplayAttribute.ResourceType property is left blank, it will use the direct value specified by the Name property. Otherwise, it will look in the specified resource Type for a localized resource value within the property indicated by Name.

In this example, the DisplayAttribute will look for a property named MyFirstValue in the string resources type MyResources and use that property's value:

C#
VB
Copy
​public enum SampleEnum {

    [Display(ResourceType = typeof(MyResources), Name = "MyFirstValue")]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <Display(ResourceType := GetType(MyResources), Name := "MyFirstValue")>
    MyFirstValue = 1

    ...
End Enum

Note Note
The WPF version of EnumPicker also supports System.ComponentModel.DescriptionAttribute to supply textual descriptions in place of System.ComponentModel.DataAnnotations.DisplayAttribute.

Custom Sorting

By default, values are listed in the order they are defined. The exception is that in flags enums, group values get placed together.

Sorting can be altered by implementing a custom IComparer<Enum> class and assigning it to the EnumSortComparer property. The EnumValueNameSortComparer.Instance static property provides access to a pre-built comparer for listing enumeration values alphabetically by name.

Hiding Enumeration Values

By default, all values are listed in the control. If you wish to hide a specific value from the end user, use EditorBrowsableAttribute on the value with EditorBrowsableState.Never.

In this example, the EditorBrowsableAttribute hides the MyFirstValue value from the user interface:

C#
VB
Copy
​public enum SampleEnum {

    [EditorBrowsable(EditorBrowsableState.Never)]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <EditorBrowsable(EditorBrowsableState.Never)>
    MyFirstValue = 1

    ...
End Enum

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:EnumPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


HsbColorPicker

The HsbColorPicker control combines several primitives (RadialHuePicker and SaturationBrightnessPicker) together to create a control that allows for easy selection of a HSB (hue, saturation, brightness) color.

The outer ring of the control is a radial slider for selecting the hue. The inner square allows for selection of the saturation (x-axis) and brightness (y-axis).

This topic contains these sections:

  • Comparison Value
  • Sample XAML

Comparison Value

The HsbColorPicker.IsComparisonValueVisible property can be set to true to display a comparison color value on the left side of the hue ring's fill area. The color displayed is specified by the ComparisonValue property.

This is useful when setting up a comparison of old/new color values.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:HsbColorPicker Color="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int16Picker

The Int16EditBox control allows for the input of an Int16 (16-bit integer) value. It is generally intended for display within a popup, such as for the Int16EditBox control.

The control allows for selection of an Int16 value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int16Picker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int32Picker

The Int32EditBox control allows for the input of an Int32 (32-bit integer) value. It is generally intended for display within a popup, such as for the Int32EditBox control.

The control allows for selection of an Int32 value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int32Picker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int32RectPicker

The Int32RectPicker control allows for the input of an Int32Rect (X, Y, width, height) value. It is generally intended for display within a popup, such as for the Int32RectEditBox control.

The toggle at the top determines whether the embedded Int32Picker is currently modifying the X, Y, Width or Height component of the Int32Rect. See the Int32Picker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int32RectPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int64Picker

The Int64EditBox control allows for the input of an Int64 (64-bit integer) value. It is generally intended for display within a popup, such as for the Int64EditBox control.

The control allows for selection of an Int64 value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int64Picker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PointPicker

The PointPicker control allows for the input of a Point (X, Y) value. It is generally intended for display within a popup, such as for the PointEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the X or Y component of the Point. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Rounding Decimal Places
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:PointPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RadialHuePicker

The RadialHuePicker control renders a circular gradient of the color spectrum and uses a radial slider to select a color hue.

This topic contains these sections:

  • Sample XAML

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:RadialHuePicker Hue="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RectPicker

The RectPicker control allows for the input of a Rect (X, Y, width, height) value. It is generally intended for display within a popup, such as for the RectEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the X, Y, Width or Height component of the Rect. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Rounding Decimal Places
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:RectPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SaturationBrightnessPicker

The SaturationBrightnessPicker control allows for the input of color saturation and brightness values.

The control displays a two-dimensional gradient of color values for a given hue, where the vertical gradient represents brightness and the horizontal gradient represents saturation.

A gripper can be dragged to change the selected color.

This topic contains these sections:

  • Setting the Hue
  • Sample XAML

Setting the Hue

This picker shows the saturation and brightness cross-section for a particular hue. Therefore it is important to set the Hue property appropriately. 0 is red, 120 is green, and 240 is blue. The hue may be set to any value between 0 and 360.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SaturationBrightnessPicker Hue="120" Saturation="{Binding Path=YourSVMProperty, Mode=TwoWay}"
    Brightness="{Binding Path=YourBVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SinglePicker

The SinglePicker control allows for the input of a Single (floating-point number) value. It is generally intended for display within a popup, such as for the SingleEditBox control, and is also used within many other pickers.

The control allows for selection of a Single value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Rounding Decimal Places
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 7, but can be set to any value in the range 0 to 7. Or set the value to null to prevent rounding.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SinglePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SizePicker

The SizePicker control allows for the input of a Size (width, height) value. It is generally intended for display within a popup, such as for the SizeEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the Width or Height component of the Size. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Rounding Decimal Places
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SizePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ThicknessPicker

The ThicknessPicker control allows for the input of a Thickness (left, top, right, bottom) value. It is generally intended for display within a popup, such as for the ThicknessEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the Left, Top, Right or Bottom component of the Thickness. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Rounding Decimal Places
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:ThicknessPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TimePicker

The TimePicker control allows for the input of a DateTime value's time component. Its design uses two radial sliders and is similar to the layout of a standard analog clock, making it instantly approachable by end users.

The inner radial slider sets the hours value. It can be rotated up to two full cycles, where each cycle represents a 12 hour period. The second cycle (for PM times) applies a subtle highlight effect on the track. The outer radial slider sets the minutes value, and can be rotated freely.

This topic contains these sections:

  • Minimum and Maximum Values
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:TimePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TimeSpanPicker

The TimeSpanPicker control allows for the input of a TimeSpan (days, hours, minutes, seconds, milliseconds) value. It is generally intended for display within a popup, such as for the TimeSpanEditBox control.

The toggle at the top determines whether the embedded Int32Picker is currently modifying the Days, Hours, Minutes, Seconds or Milliseconds component of the TimeSpan. See the Int32Picker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:TimeSpanPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


VectorPicker

The VectorPicker control allows for the input of a Vector (X, Y) value. It is generally intended for display within a popup, such as for the VectorEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the X or Y component of the Vector. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Rounding Decimal Places
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Rounding Decimal Places

The RoundingDecimalPlace property determines the maximum decimal place at which to round floating-point numbers. It defaults to 8, but can be set to any value in the range 0 to 15. Or set the value to null to prevent rounding.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:VectorPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Editors includes a number of additional helpful controls beyond edit boxes and pickers.

This topic contains these sections:

  • Additional Controls

Additional Controls

This table shows the additional controls that are included in the product:

Name | Description
AutoCompleteBox | The AutoCompleteBox control allows text entry and provides suggestions for auto-completion. This kind of control is ideal for use in search query and quick launch kinds of scenarios.
Calculator | Provides a familiar calculator interface to interactively calculate numeric values.
CountryComboBox | Allows for the selection of an ISO country.
CurrencyComboBox | Allows for the selection of an ISO currency.
EnumListBox | Presents the values of an enumeration in a list box. The control supports both flags and non-flags enums.
GradientStopSlider | Allows for adding, changing, and removing the various gradient stops within a GradientBrush, such as a LinearGradientBrush.
MaskedTextBox | Used to restrict user input based on a specified regular expression mask. Support for input prompts and literal completion is included.
MonthCalendar | Allows for selection of a date from a calendar with animated view changes.
Rating | Renders glyphs that can be used present an average rating or collect a user rating.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AutoCompleteBox

The AutoCompleteBox control allows text entry and provides suggestions for auto-completion. This kind of control is ideal for use in search query and quick launch kinds of scenarios.

The control supports automatic filtering of suggested items as the end user types via data filters. Or you can also choose to completely rebuild the list of suggested items on each text edit for a more tailored suggestion display.

This topic contains these sections:

  • Text and Text Changes
  • Populating the Suggestion List
  • Using Data Filters
  • Updating the Suggestion List
  • No Items Content
  • Suggested Item Selection
  • Popup Behavior
  • Submitting
  • Placeholder Text
  • Character Casing

Text and Text Changes

The AutoCompleteBox control renders like an editable ComboBox in that it has a text entry area and a drop-down button.

The Text property provides access to the string value being edited in the control's text area and supports two-way binding. The TextChanged event fires whenever the text is changed. Event arguments pass the reason for the change, along with the new text. Set the AutoCompleteBoxEventArgs.IsPopupAllowed property to false to prevent the suggestion list popup from possibly opening in response to the change.

Set the IsReadOnly property to true to prevent editing of the text value.

Populating the Suggestion List

The AutoCompleteBox control's template also contains an embedded list control that is used to render the suggestion list. This list displays in a popup. There are a number of common ItemsControl properties used to populate the list and determine how suggestion items render.

The ItemsSource property should be set to a collection of suggestion items. This collection is run through a data filter (if supplied) and the results are placed in the FilteredItemsSource property. The suggestion list binds to this property.

For basic scenarios where you simply want to display a text property in the list for each suggestion, the DisplayMemberPath property can be used. If your suggestion item objects have a Name property that should be shown to the end user, set the DisplayMemberPath property to "Name".

If you wish to customize the display of each suggestion item, the control provides ItemContainerStyle, ItemContainerStyleSelector, ItemTemplate, and ItemTemplateSelector properties. The container elements that are generated are of type EmbeddedListBoxItem. When using custom item templates, do not use the DisplayMemberPath property.

The suggestion list selects the first item by default. If you wish to set another item as the default selection, use the SelectedItem property.

Using Data Filters

Data filters provide a generic mechanism for filtering data objects based on string matching or custom predicate-based logic. Any IDataFilter object can be assigned to the DataFilter property. When a data filter is assigned, it is used to automatically trim down the suggested items as the end user types without having to assign a new items source.

The IDataFilter.Filter method is called with the text of the suggested item (as determined by the ConvertToString method, which uses TextMemberPath) along with a context object, which is the value of the FilterText property (defaults to returning the current Text of the control).

A pre-built AutoCompleteBoxStringFilter class is available that automatically handles this for you. The only requirement is that you set the TextMemberPath to the name of the property by which to filter against. This property is similar to the DisplayMemberPath property, but only affects data filtering and what text gets inserted when a suggested item is selected.

Updating the Suggestion List

While data filters might handle many common scenarios, there are other cases where you may wish to completely rebuild the list whenever the text changes. This is more commonly done for quick launch kinds of scenarios where you only show the most popular suggested items that match what has been typed. Or you might want to actually include the typed text in the suggested items themselves (e.g. "Get help on 'foo'").

To accomplish this, set the ItemsSource to a new collection in response to the TextChanged event firing.

No Items Content

When the FilteredItemsSource returns an empty collection, either since the ItemsSource is empty or all items were filtered out, the NoItemsContent and NoItemsContentTemplate will be displayed.

The NoItemsContentTemplate property's DataTemplate generally consists of a TextBlock whose text is bound to a string set to the NoItemsContent property, which says there are no results.

Suggested Item Selection

When the end user clicks on a suggested item or presses Enter while the suggestion list is open, the SuggestionChosen event is raised.

The TextMemberPath property is used to determine the text for the item. The logic for converting an item to text is implemented in the virtual ConvertToString method.

The result of that item-to-text conversion is passed to the SuggestionChosen event in its event arguments. The text in the event arguments can be updated to a different value if desired, or set to null to prevent any text change.

If the CanSelectAllOnUpdate property is true (the default), the entire text will be selected. Otherwise, the caret will move to the end of the inserted text.

Popup Behavior

The popup containing the suggestion list displays whenever the drop-down button is clicked. This button can be hidden by setting the HasPopupButton property to false.

The popup can also auto-open in other scenarios. The MinCharacterCountToOpenPopup property specifies the minimum number of characters that must be typed before the popup automatically opens. The default value is 1.

The IsPopupOpenedOnFocus property can be set to true to auto-open the popup whenever the control gains focus. This feature should generally only be used if the HasPopupButton property is false.

The height of the popup can be restricted by setting the MaxPopupHeight property.

Submitting

When the end user clicks on a suggested item or presses Enter (even if the suggestion list is not open at the time), the Submitted event is raised. Handlers of this event should perform whichever search query or command execution is appropriate based on the supplied text.

Placeholder Text

Edit boxes support placeholder text that is rendered when there is no value in the control. This text can be designated via the PlaceholderText property.

Character Casing

Use the CharacterCasing property to determine how characters are cased when they are manually entered into the text box. This property can force typed characters to uppercase or lowercase if desired.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Calculator

The Calculator control provides a familiar calculator interface to interactively calculate numeric values.

This topic contains these sections:

  • Overview
  • Customization

Overview

The calculator can be operated by tapping its various buttons or by focusing it and typing on the keyboard.

The Calculator.Value property gets or sets the current numeric calculator value, and supports data binding. It is a Double value.

The DisplayText property gets the current text that is rendered in the display area of the calculator.

Customization

Calculator offers several properties that can be used to customize the look of the control.

General

There properties can be used to customize the overall look of the Calculator, as described below.

Property | Description
DisplayFontSize | The display font size.
HasDisplay | Whether the calculator output is displayed.
HasMemoryButtons | Whether the memory buttons are displayed.

Styles

The various buttons presented by the Calculator can be customized using a Style.

Property | Description
DigitButtonStyle | Specifies the Style to use for digit buttons.
MemoryButtonStyle | Specifies the Style to use for memory buttons.
OperationButtonStyle | Specifies the Style to use for operation buttons.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CountryComboBox

The CountryComboBox can be used to select a Country from a list of countries in the world. The country code can then be used with LINQ and CountryCurrencyMapping to query the Currency that is used in that Country.

This topic contains these sections:

  • Overview
  • List of Countries
  • Selection
  • Country/Currency Mapping

Overview

The CountryComboBox extends the native ComboBox and displays a list of countries as defined by the ISO. A country is represented by an instance of Country, and the list of countries is defined by the Country.Countries collection

List of Countries

The list of countries can be customized by updating the Country.Countries collection. Items can be added or removed as needed directly from this list. In addition, a custom list can be assigned to the ItemsSource property.

This example code shows how the default full list of countries can be filtered down to several European countries via LINQ:

C#
VB
Copy
​var countries = new string[] { "PT", "ES", "GB", "FR", "DE" };
countryComboBox.ItemSource = from c in Country.Countries where countries.Contains(c.Code) select c;
​Dim countries = New String() {"PT", "ES", "GB", "FR", "DE"}
countryComboBox.ItemSource = From c In Country.Countries
    Where countries.Contains(c.Code)
    Select c

Selection

The selected Country is accessible through the SelectedItem property. In addition, the unique ISO code associated with the country can be accessed through the SelectedValue property.

Country/Currency Mapping

The CountryCurrencyMapping class contains Mappings between Country.Countries and Currency.Currencies. This is useful for seeing which countries use which currencies, and which currencies are used by which countries.

It is possible to use LINQ with CountryCurrencyMapping.Mappings, Country.Countries and Currency.Currencies. This shows the currencies for the United States.

C#
VB
Copy
​var results =
    from mapping in CountryCurrencyMapping.Mappings
    join currency in Currency.Currencies on mapping.CurrencyCode equals currency.Code
    where mapping.CountryCode == "US"
    select currency;
​Dim results =
    From mapping In CountryCurrencyMapping.Mappings
    Join currency In Currency.Currencies On mapping.CurrencyCode Equals currency.Code
    Where mapping.CountryCode = "US"
    Select currency

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CurrencyComboBox

The CurrencyComboBox can be used to select a Currency from a list of currencies in the world. The currency code can then be used with LINQ and CountryCurrencyMapping to query the Country or countries that use that Currency.

This topic contains these sections:

  • Overview
  • List of Currencies
  • Selection
  • Country/Currency Mapping

Overview

The CurrencyComboBox extends the native ComboBox and displays a list of currencies as defined by the ISO. A currency is represented by an instance of Currency, and the list of currencies is defined by the Currency.Currencies collection.

List of Currencies

The list of currencies can be customized by updating the Currency.Currencies collection. Items can be added or removed as needed directly from this list. In addition, a custom list can be assigned to the ItemsSource property.

Selection

The selected Currency is accessible through the SelectedItem property. In addition, the unique ISO code associated with the currency can be accessed through the SelectedValue property.

Country/Currency Mapping

See the CountryComboBox topic for more information on the CountryCurrencyMapping class.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EnumListBox

The EnumListBox control automatically presents the values of an enumeration with a more intuitive interface.

This topic contains these sections:

  • Enumeration Value and Type
  • Using Display Attributes
  • Custom Sorting
  • Hiding Enumeration Values

Enumeration Value and Type

The EnumValue property provides a quick and easy way to setup to the list box. The EnumType property is used to to build the items presented by the EnumListBox. The items are constructed by reflecting the enumeration type, with full support for the FlagsAttribute.

When the EnumValue property is bound/set to a non-null enumeration value, then the enumeration type will be automatically set (if it has not been explicitly set). Therefore, the EnumType only needs to be set when EnumValue is bound to a nullable enumeration type.

By default, the items are presented in a standard single selection list box style. When the enumeration type is marked with the FlagsAttribute, then the items are presented using a CheckBox control and the list box allows multiple selection. In addition, flag enumerations are separate into three sections. The first section contains values that are equal to zero. The second section contains union values, or values that have more than one bit set. The third section contains the remaing values, which have one and only one bit set.

EnumListBox bound to a flags enum

Using Display Attributes

Sometimes it is helpful to display an alternate text version of an enumeration value, especially when the values are made of multiple concatenated words. For instance, an enumeration value named "FooBar" might appear nicer as "Foo Bar".

This scenario is fully supported by EnumListBox. A System.ComponentModel.DataAnnotations.DisplayAttribute can be applied to a value to give it an alternate textual description. Then as long as the UseDisplayAttributes property is set to true, that alternate text will be used.

If the DisplayAttribute.ResourceType property is left blank, it will use the direct value specified by the Name property. Otherwise, it will look in the specified resource Type for a localized resource value within the property indicated by Name.

In this example, the DisplayAttribute will look for a property named MyFirstValue in the string resources type MyResources and use that property's value:

C#
VB
Copy
​public enum SampleEnum {

    [Display(ResourceType = typeof(MyResources), Name = "MyFirstValue")]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <Display(ResourceType := GetType(MyResources), Name := "MyFirstValue")>
    MyFirstValue = 1

    ...
End Enum

Note Note
The WPF version of EnumListBox also supports System.ComponentModel.DescriptionAttribute to supply textual descriptions in place of System.ComponentModel.DataAnnotations.DisplayAttribute.

Custom Sorting

By default, values are listed in the order they are defined. The exception is that in flags enums, group values get placed together.

Sorting can be altered by implementing a custom IComparer<Enum> class and assigning it to the EnumSortComparer property. The EnumValueNameSortComparer.Instance static property provides access to a pre-built comparer for listing enumeration values alphabetically by name.

Hiding Enumeration Values

By default, all values are listed in the control. If you wish to hide a specific value from the end user, use EditorBrowsableAttribute on the value with EditorBrowsableState.Never.

In this example, the EditorBrowsableAttribute hides the MyFirstValue value from the user interface:

C#
VB
Copy
​public enum SampleEnum {

    [EditorBrowsable(EditorBrowsableState.Never)]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <EditorBrowsable(EditorBrowsableState.Never)>
    MyFirstValue = 1

    ...
End Enum

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


GradientStopSlider

The GradientStopSlider control allows for adding, changing, and removing the various gradient stops within a GradientBrush, such as a LinearGradientBrush.

This topic contains these sections:

  • Usage
  • Stop Add/Remove Capabilities
  • Track Height
  • Commands for External Buttons
  • Reusing Brushes

Usage

The slider will display a thumb for each GradientStop in the gradient brush. Each stop consists of an offset and Color pair.

Thumbs can be dragged to adjust their offsets and the color for the selected thumb can be changed. When dragging a thumb far above or below the slider, it will turn semi-transparent meaning that it will be removed if it is released at that location. Double click an empty area of the slider track to insert a new thumb.

The GradientStopSlider.ActiveBrush is the property that you apply a two-way binding to whichever Brush-based property that you wish to adjust using the slider.

You also need to add a two-way binding to the SelectedColor property that binds to an external control for altering the color of the selected stop. Any one of the coloring picking controls in this product can be used for this purpose.

Stop Add/Remove Capabilities

The CanAddStops and CanRemoveStops properties can be used to restrict whether stops can be added to or removed from the gradient brush. They are both true by default.

Track Height

The TrackHeight property sets the height of the track, which is the area in which the actual gradient brush is rendered.

Commands for External Buttons

There are several properties that return ICommand and can be utilized by external buttons or menu items:

  • AddStopCommand
  • RemoveSelectedStopCommand
  • ReverseStopsCommand

Simply bind the Command property of an external button or menu item to the appropriate slider property to have them interact with the control.

Reusing Brushes

By default, the brush instance will generally be reused when a gradient stop is added/updated/removed. But this prevents bindings to the ActiveBrush property from updating when using value converters. The CanReuseBrush property can be set to false to force a new brush to be created any time a gradient stop is added/updated/removed, which works around those issues.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


MaskedTextBox

The MaskedTextBox control can be used to restrict user input based on a specified regular expression mask. Support for input prompts and literal completion is included.

Since the MaskedTextBox control inherits the native TextBox control, it fully supports features such as UI automation, IME input, etc.

When typing text data, the control will attempt to move the caret past any literal (fixed) characters it encounters in the mask.

The "12" were typed by the user and the remaining text with bullets/dashes is a prompt

This topic contains these sections:

  • Mask, Text, and MatchedText
  • Prompts
  • Case Sensitivity and Case-Correction
  • Regular Expression Mask Syntax
  • Wildcard Mask Syntax

Mask, Text, and MatchedText

The Mask property can be used to define the desired mask pattern that must be input. It defaults to using a regular expression pattern. Any characters or input that violate this mask will be discarded. This ensures that only data in the proper format is entered.

The MaskKind property indicates whether the Mask is a regular expression (the default) or wildcard pattern. See the reference below for more details on each mask kind, as they have different pattern syntax.

The Text property can be used to retrieve any text entered by the end user, along with any prompt text that is currently displayed.

The MatchedText property can be used to get/set the text entered by the end user, without any prompt text that is currently displayed. This is typically the property you want to data-bind against, instead of Text.

Prompts

Prompts can be appended to the end of the text in scenarios where further text input is required to properly match a mask. The prompts do their best to indicate literal characters as themselves. Any time there is a choice in character, a prompt character specified by the PromptChar is inserted.

By default the prompts will only be appended when the control has focus. The PromptVisibility property can be changed to Always to always show prompts, even when the control doesn't has focus. The Never option prevents prompts from ever showing.

Case Sensitivity and Case-Correction

The control attempts to match the mask in a case-insensitive way by default, meaning that both 'A' and 'a' will match an "a" pattern. If you wish to force your mask to be case sensitive, set the IsCaseSensitive property to true.

If you wish to allow case-insensitivity and also coerce characters to match the pattern, set the IsCaseAutoCorrected property to true. When this property is set, the IsCaseSensitive property is ignored. Say the mask pattern is "(Male|Female)". This means only one of the two strings can be typed. If the user types a 'm' into the control, it will convert the typed character to 'M'. The control also will automatically insert the rest of the text, making it read "Male" since the "ale" characters are considered literals at those character offsets. Note that this last feature occurs regardless of case options.

Regular Expression Mask Syntax

The MaskedTextBox uses a custom regular expression engine implementation with full support for Unicode categories. The engine includes support for most common regular expression constructs, as described below, when the MaskKind property is Regex.

Literals

Literal characters can be included in the regular expression, but special characters must be escaped using the backslash character (\).

Whitespace such as spaces are treated as a literal.

Groups

Any number of regular expression elements can grouped together by enclosing them in parenthesis. Alternations, which are described below, are a special type of group which are also enclosed in parenthesis. Groups can be repeated using one of the support quantifiers after the closing paraenthesis.

For example, the regular expression "ABC*" requires A and B, then allows for zero or more of C. The regular expression "(ABC)*", which groups "ABC" into a single element, allows for zero or more of "ABC" together.

In terms of literal completion, only the A character would ever be entered by the end-user for the "(ABC)*" regular expresssion. When the user types an A, then the BC are required and are therefore automatically inserted by the control. If an additional A is typed, then again the BC would be auto completed, resulting in "ABCABC" as the text.

Alternations

Alternation allows for two or more alternate branches to be taken and is defined by using the vertical bar in parenthesis. For example, the "(AB|CD)" regular expression can match the string "AB" or the string "CD". The alternate branches can be any other supported regular expression element, including other groups or alternations. This allows for very complex scenarioes to be defined and used as a mask.

When showing prompt indicators for uncompleted sections of the maks, the control will choose the shortest branch of an alternation that would result in completion of the mask.

Quantifiers

Quantifiers can be used to specify the number of times a regular expression element should be repeated. There are several methods for defining quantifiers, which are:

Quantifier | Description
? | Indicates that the regular expression element is optional. For example, the regular expression "AB?C" will match the string "ABC" or "AC".
* | Indicates that the regular expression element is can be repeated zero or more times, with no upper limit. For example, the regular expression "AB*C" will match the string "ABC" or "AC", as well as "ABBBBBBBC".
+ | Indicates that the regular expression element must occur once, but can be repeat any number of times. For example, the regular expression "AB+C" will match the string "ABC" or "ABBBBBBBC", but will not match "AC".
{N} | Indicates that the regular expression element must occur exactly N times, where N is a postive integer value. For example, the regular expression "AB{2}C" will only match the string "ABBC".
{N,} | Indicates that the regular expression element must occur exactly N times, where N is a postive integer value, but can be repeated any number of times. For example, the regular expression "AB{2,}C" will match the string "ABBC" or "ABBBBBBC".
{N,M} | Indicates that the regular expression element must occur exactly N times, where N is a postive integer value, but can be repeated M times, where M is a positive integer value greater than N. For example, the regular expression "AB{2,3}C" will match the string "ABBC" or "ABBBC", but not "ABBBBC".

Character Classes

Character classes can be used to define one or more characters, using ranges or by explicitly defining individual characters.

Custom character classes are enclosed in square brackets. Ranges can be defined using a start character, followed by a dash (-), followed by an end character. For example, the character class "[0-9]", includes all digits. Additional ranges can be appended to specify non-contiguous ranges. For example, the character class "[0-357-9]", includes all digits except 4 and 6. The caret (^) can be used to negate the character class. For example, the character class "[^0-9]" includes all characters except the digits.

The following table summarizes character matching syntax for custom and built-in character classes.

Character Class | Description
. | Matches any character except \n. When within a character class, the . will be treated as a period character.
[aeiou] | Matches any single character included in the specified set of characters.
[^aeiou] | Matches any single character not in the specified set of characters.
[0-9a-fA-F] | Use of a hyphen (–) allows specification of contiguous character ranges.
\p{name} | Matches any character in the Unicode general category specified by name (for example, Ll, Nd, Z).
\P{name} | Matches any character not in Unicode general category specified in name.
\w | Matches any word character, which includes letters, digits, and underscores.
\W | Matches any non-word character.
\s | Matches any whitespace character.
\S | Matches any non-whitespace character.
\d | Matches any decimal digit.
\D | Matches any non-digit.
[.\w\s] | Escaped built-in character classes such as \w and \s may be used in a character class. This example matches any period, word or whitespace character.

Supported Unicode General Categories

Unicode defines the general categories and descriptions listed in the following table. These categories can be used with the \p and \P character classes described above.

Category | Description
Lu | Letter, Uppercase
Ll | Letter, Lowercase
Lt | Letter, Titlecase
Lm | Letter, Modifier
Lo | Letter, Other
Mn | Mark, Nonspacing
Mc | Mark, Spacing Combining
Me | Mark, Enclosing
Nd | Number, Decimal Digit
Nl | Number, Letter
No | Number, Other
Pc | Punctuation, Connector
Pd | Punctuation, Dash
Ps | Punctuation, Open
Pe | Punctuation, Close
Pi | Punctuation, Initial quote
Pf | Punctuation, Final quote
Po | Punctuation, Other
Sm | Symbol, Math
Sc | Symbol, Currency
Sk | Symbol, Modifier
So | Symbol, Other
Zs | Separator, Space
Zl | Separator, Line
Zp | Separator, Paragraph
Cc | Other, Control
Cf | Other, Format
Cs | Other, Surrogate
Co | Other, Private Use
Cn | Other, Not Assigned

Additional special categories are supported that represent a set of Unicode character categories, as shown in the following table:

Category | Description
C | (All control characters) Cc, Cf, Cs, Co, and Cn.
L | (All letters) Lu, Ll, Lt, Lm, and Lo.
M | (All diacritic marks) Mm, Mc, and Me.
N | (All numbers) Nd, Nl, and No.
P | (All punctuation) Pc, Pd, Ps, Pe, Pi, Pf and Po.
S | (All symbols) Sm, Sc, Sk, and So.
Z | (All separators) Zs, Zl, and Zp.

Wildcard Mask Syntax

Wildcard based patterns are supported when the MaskKind property is Wildcard. In this mode, the wildcard pattern is converted to an equivalent regular expression pattern behind the scenes.

Wildcard pattern providers search for text by using "wildcard" pattern matching. The following wildcard patterns are recognized:

Construct | Description
* | Specifies zero or more of any character, except the line feed character.
? | Specifies any single character, except the line feed character.
# | Specifies any single digit.
[aeiou] | Matches any one character in the set.
[!aeiou] | Matches any one character not in the set.

Any other character in the pattern matches the character. An example wildcard pattern is "#####-####".

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


MonthCalendar

The MonthCalendar control presents a calendar using several view levels. It includes smooth animations when navigating and is highly customizable.

This topic contains these sections:

  • Navigation
  • Selection
  • Disabled Dates
  • Customization

Navigation

The current view presented by the MonthCalendar is controlled by the ActiveDate and ActiveViewMode properties. There are various methods of navigating through the control, which are described below.

Zooming In and Out

The MonthCalendar control supports four view modes: Month, Year, Decade, and Century. The various view modes make it easier to navigate from one date to another, by allowing to user to zoom out and then drill back in to a specific date.

The MonthCalendar control showing the year, decade, and century views, repsectively.

The end-user can zoom out by clicking the title bar text (e.g. "August 2014" for the month view). When an individual item is clicked, that item is zoomed in. So clicking on "August" in the year view, will zoom in to the month view for August.

Tip Tip
To zoom out using the keyboard, press the '-' key while holding down the Control key. Similarly, pressing the '+' key while hold down the Control key will zoom in.

By default, the user can zoom out all the way out to the century view. This can be restricted by setting the MaxViewMode property.

Scrolling

Using the arrows in the title bar, the current view can be scrolled left or right. For the month view, scrolling left will move to the previous month and scrolling right will move to the next month. The other views move to their respective previous and next views (e.g. year, decade, century).

Tip Tip
To scroll left using the keyboard, press the PageDown key. Similarly, pressing the PageUp key will scroll right.

Keyboard/Item Navigation

When the MonthCalendar has focus, the arrow keys can be used to navigate through the current view. When moving onto an overflow item, which is an item that actually belongs to the next or previous view, then the next/previous view will be scrolled into view.

Today Button

A "today" command is available via the MonthCalendar.SelectTodayCommand property that can be bound to any button. When the button is tapped, the item that contains DateTime.Today will be selected and scrolled into view.

View Reset

The view presented by the MonthCalendar can be reset to the Month view when it loses focus, by setting the ViewResetMode property. This feature is useful when the calendar is being hosted in a Popup.

Selection

The MonthCalendar can be used to select one or more dates. The currently selected dates are available in the SelectedDates collection. Additionally, the first selected date can be retrieved using the SelectedDate property. The SelectedDate property supports two-way binding.

Note Note
Disabled dates, as described below, are automatically excluded from selection.

The SelectionChanged event fires whenever the SelectedDate or SelectedDates properties change.

The number of selected dates can be restricted using the MaxSelectionCount property. When set to -1 (the default value), no limit is imposed.

The calendar supports several selection modes, each with a unique behavior. The selection mode is configured using the SelectionMode property.

Note Note
The selection mode only limits how the end-user can select dates. The selection mode restrictions are not enforce when adding dates to SelectedDates programmatically.

Mode | Description
Single | Specifies that only a single date can be selected.
Multiple | Specifies that multiple dates can be selected, but must be done so explicitly (e.g. each item must be selected individually). When clicking on an item it's selection state is toggled.
Extended | Specifies that multiple dates can be selected, by using the Control (to toggle a selected day) and Shift (to select a range) keys.
Range | Specifies that multiple dates can be selected, by using the Shift (to select a range) key. Works like the Extended mode, but the selected dates must be in a continguous range (not including disabled dates).

The day of week header items and week number items can be used for selection, when the SelectionMode allows multiple dates to be selected. This feature can be disabled by setting IsDayOfWeekSelectionEnabled and/or IsWeekNumberSelectionEnabled properties to false.

A "clear" button can be included by setting IsClearButtonVisible to true. This button clears the current selection, which is useful when multiple date selection is enabled.

Disabled Dates

The Minimum and Maximum properties can be used to restrict the date range over which the user can navigate and select a date. Any dates falling outside of that range will appear disabled and won't be selectable.

Within the minimum and maximum range, other dates can be disabled as well. All instances of dates that fall over certain days of week can be disabled by setting the DisabledDaysOfWeek property, which accepts one or more values from the flags enumeration DaysOfWeek. This is useful for scenarios like where you might not wish to allow weekend days to be selected.

Note Note
When DisabledDaysOfWeek is set to DaysOfWeek.All then the user will not be able to navigate away from the currently active date.

Finally, for any dates that would normally be enabled within the Minimum and Maximum range, and aren't disabled by the DisabledDaysOfWeek property, a special IsDateDisabledFunc property can optionally supply a function that is passed a DateTime and returns true if the specified date should be disabled. This function is called for each day cell that is rendered.

This example code shows how to set the IsDateDisabledFunc property with a function that disables the first Tuesday of each month.

C#
VB
Copy
​disabledDaysCalendar.IsDateDisabledFunc = d => (d.DayOfWeek == DayOfWeek.Tuesday) && (d.Day >= 8) && (d.Day <= 14);
​disabledDaysCalendar.IsDateDisabledFunc = Function(d) (d.DayOfWeek = DayOfWeek.Tuesday) AndAlso (d.Day >= 8) AndAlso (d.Day <= 14)

Customization

MonthCalendar offers several properties that can be used to customize the look of the control.

General

There properties can be used to customize the overall look of the MonthCalendar, as described below.

Property | Description
CalendarWeekRule | By default the calender week rule, which determines how weeks are numbered, is retrieved from the current culture, but this property can be used to override the value.
DayOfWeekFormatPattern | Specifies the format used to display the values in the day of week header.
FirstDayOfWeek | By default the first day of the week is retrieved from the current culture, but this property can be used to override the value.
IsTodayButtonVisible | Indicates whether the today button is visible.
IsTodayHighlighted | Indicates whether today is highlighted with an outline.
IsWeekNumberColumnVisible | Indicates whether the week number column is visible.

Styles

The various items presented by the MonthCalendar can be customized using a DataTemplate or Style.

Property | Description
ClearButtonStyle | Specifies the Style to use for the Clear button within the calendar.
DayItemTemplate | Specifies the DataTemplate to use for day items within the calendar.
DayItemTemplateSelector | Specifies the DataTemplateSelector to use for day items within the calendar.
DayNameItemContainerStyle | Specifies the Style to use for day name items within the calendar.
DayNameItemTemplate | Specifies the DataTemplate to use for day name items within the calendar.
DecadeItemTemplate | Specifies the DataTemplate to use for decade items within the calendar.
MonthItemTemplate | Specifies the DataTemplate to use for month items within the calendar.
NavigationButtonStyle | Specifies the Style to use for navigation buttons within the calendar.
TitleButtonStyle | Specifies the Style to use for the title button within the calendar.
TodayButtonStyle | Specifies the Style to use for the Today button within the calendar.
WeekNumberItemContainerStyle | Specifies the Style to use for week number items within the calendar.
WeekNumberItemTemplate | Specifies the DataTemplate to use for week number items within the calendar.
YearItemTemplate | Specifies the DataTemplate to use for year items within the calendar.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Rating

The Rating control inherits from ItemsControl and renders glyphs that can be used present an average rating or collect a user rating.

This topic contains these sections:

  • Average Value and Value
  • Populating the Rating
  • Glyphs and DataTemplates
  • Item Content
  • Orientation

Average Value and Value

The Rating control has two different value properties, AverageValue and Value.

The AverageValue property is displayed when the Value property is null. Generally, this would be the average value of all the known ratings for the associated item. The user cannot modify this value through use of the control, and it must be set programmatically.

Rating showing an average value of 3.5

The Value property is displayed when non-null and effectively hides the AverageValue. This value indicates the user's selection and can be updated using a pointer or the keyboard.

Populating the Rating

The Rating control is an ItemsControl, and as such, you can populate the Items collection directly with RatingItem instances, with each item representing a new "star" or rating value.

To simplify the use of the Rating control, the ItemCount property can be used to automatically populate the Items collection with 0 or more instances of RatingItem.

This XAML shows how five items can be created and the control's value bound to a view model property:

XAML
Copy
​<editors:Rating ItemCount="5" Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Glyphs and DataTemplates

The RatingItem class is used to present each "star" or rating glyph. By default, a star glyph is shown, but this can easily be customized. Using the following properties, one or more DataTemplates can be specified to be used by the various states of a RatingItem:

  • NormalGlyphTemplate - Used when the item is in the normal (unselected) state.
  • ActiveGlyphTemplate - Used when the end user's pointer actively over this item or one after it.
  • AverageGlyphTemplate - Used when the item is involved in rendering an average value for the overall rating.
  • SelectedGlyphTemplate - Used when the item is involved in the end user's value selection.

These properties can be set using a Style that targets the RatingItem class with a setter for each of the glyph templates. Set the style to the rating's ItemContainerStyle property.

Custom glyph templates for each item

Alternatively, if the Rating control is manually populated (i.e. one or more RatingItem instances are manually added to the Items collection), the RatingItem properties can be set directly. This approach is needed to achieve advanced display scenarios like in the screenshot above.

Item Content

The RatingItem class inherits ContentControl and thus has several properties like Content, ContentTemplate, etc. Any content-related properties that are set will render the content below each item when in a horizontal orientation, or next to each item when in a vertical orientation.

In the screenshot above, the first item has "Poor" content, the second has "Fair" content, and the third has "Good" content.

Orientation

The Rating control can be oriented horizontally (the default) or vertically by setting the Orientation property.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The various edit boxes can be easily integrated and used within other controls.

  • The PropertyGrid topic contains information on integrating with the Actipro PropertyGrid control.
  • The Ribbon topic contains information on integrating with the Actipro Ribbon control.
  • The DataGrid topic contains information on integrating with the native WPF DataGrid control.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PropertyGrid

The controls provided in the Editors product can be easily integrated into the PropertyGrid control, through the use of custom property editors. In order to keep both products segregated, an Interop assembly is provided that ties the two products together.

PropertyGrid with BrushEditBox integrated

This topic contains these sections:

  • Interop Assembly
  • Property Editors
  • Adding to PropertyGrid

Interop Assembly

The Interop functionality is provided through a separate assembly, which is called ActiproSoftware.Editors.Interop.Grids.Wpf.dll. Therefore, a reference to this assembly must be added in order to leverage the property editors it provides. This assembly should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Property Editors

The PropertyGrid uses "property editors" to tie a properties to controls, by property name and/or property type. For example, you can tell the PropertyGrid that all properties of the type DateTime should use MyControlA and all properties of the type String should use MyControlB. This gives you a lot of control over what control is used for the various properties. In reality, the "control" is actually a DataTemplate since it will most likely be used multiple times.

Property editors are defined via an instance of the PropertyEditor class. Derivations of this class can provide default values, such as a known DataTemplate or property Type. In addition, derivations are required in order to decorate properties with EditorAttribute. EditorAttribute only allows the editor Type to be specified, therefore that Type needs to provide a default DataTemplate (via a derivation of PropertyEditor).

Note Note
Property editors can actually provide a DataTemplate for the value cell and the name cell, but typically the name cell does not need to be altered.

See the Property Editors topic under Actipro PropertyGrid for more information.

The Interop assembly provides a set of classes that derive from PropertyEditor and provide default values for the DataTemplate used for the value cell and the property Type. These classes include:

Class | Description
BrushPropertyEditor | Represents an property editor that uses a BrushEditBox for editing Brush property values.
BytePropertyEditor | Represents an property editor that uses a ByteEditBox for editing Byte property values.
ColorPropertyEditor | Represents an property editor that uses a ColorEditBox for editing Color property values.
CornerRadiusPropertyEditor | Represents an property editor that uses a CornerRadiusEditBox for editing CornerRadius property values.
DatePropertyEditor | Represents an property editor that uses a DateEditBox for editing DateTime (date-only) property values.
DateTimePropertyEditor | Represents an property editor that uses a DateTimeEditBox for editing DateTime property values.
DoublePropertyEditor | Represents an property editor that uses a DoubleEditBox for editing Double property values.
EnumPropertyEditor | Represents an property editor that uses a EnumEditBox for editing Enum property values.
GuidPropertyEditor | Represents an property editor that uses a GuidEditBox for editing Guid property values.
Int16PropertyEditor | Represents an property editor that uses a Int16EditBox for editing Int16 property values.
Int32PropertyEditor | Represents an property editor that uses a Int32EditBox for editing Int32 property values.
Int32RectPropertyEditor | Represents an property editor that uses a Int32RectEditBox for editing Int32Rect property values.
Int64PropertyEditor | Represents an property editor that uses a Int64EditBox for editing Int64 property values.
MaskedStringPropertyEditor | Represents an property editor that uses a MaskedTextBox for editing property values.
NullableBytePropertyEditor | Represents an property editor that uses a ByteEditBox for editing Byte? property values.
NullableColorPropertyEditor | Represents an property editor that uses a ColorEditBox for editing Color? property values.
NullableCornerRadiusPropertyEditor | Represents an property editor that uses a CornerRadiusEditBox for editing CornerRadius? property values.
NullableDatePropertyEditor | Represents an property editor that uses a DateEditBox for editing DateTime? (date-only) property values.
NullableDateTimePropertyEditor | Represents an property editor that uses a DateTimeEditBox for editing DateTime? property values.
NullableDoublePropertyEditor | Represents an property editor that uses a DoubleEditBox for editing Double? property values.
NullableGuidPropertyEditor | Represents an property editor that uses a GuidEditBox for editing Guid? property values.
NullableInt16PropertyEditor | Represents an property editor that uses a Int16EditBox for editing Int16? property values.
NullableInt32PropertyEditor | Represents an property editor that uses a Int32EditBox for editing Int32? property values.
NullableInt32RectPropertyEditor | Represents an property editor that uses a Int32RectEditBox for editing Int32Rect? property values.
NullableInt64PropertyEditor | Represents an property editor that uses a Int64EditBox for editing Int64? property values.
NullablePointPropertyEditor | Represents an property editor that uses a PointEditBox for editing Point? property values.
NullableRectPropertyEditor | Represents an property editor that uses a RectEditBox for editing Rect? property values.
NullableSinglePropertyEditor | Represents an property editor that uses a SingleEditBox for editing Single? property values.
NullableSizePropertyEditor | Represents an property editor that uses a SizeEditBox for editing Size? property values.
NullableThicknessPropertyEditor | Represents an property editor that uses a ThicknessEditBox for editing Thickness? property values.
NullableTimePropertyEditor | Represents an property editor that uses a TimeEditBox for editing DateTime? (time-only) property values.
NullableTimeSpanPropertyEditor | Represents an property editor that uses a TimeSpanEditBox for editing TimeSpan? property values.
NullableVectorPropertyEditor | Represents an property editor that uses a VectorEditBox for editing Vector? property values.
PointPropertyEditor | Represents an property editor that uses a PointEditBox for editing Point property values.
RectPropertyEditor | Represents an property editor that uses a RectEditBox for editing Rect property values.
SinglePropertyEditor | Represents an property editor that uses a SingleEditBox for editing Single property values.
SizePropertyEditor | Represents an property editor that uses a SizeEditBox for editing Size property values.
ThicknessPropertyEditor | Represents an property editor that uses a ThicknessEditBox for editing Thickness property values.
TimePropertyEditor | Represents an property editor that uses a TimeEditBox for editing DateTime (time-only) property values.
TimeSpanPropertyEditor | Represents an property editor that uses a TimeSpanEditBox for editing TimeSpan property values.
VectorPropertyEditor | Represents an property editor that uses a VectorEditBox for editing Vector property values.

Each property editor exposes some of the more common settings available on their associated control. For example, the MaskedStringPropertyEditor has a Mask property that allows you to set the associated Mask on the underlying MaskedTextBox. Remember that the controls are defined using a DataTemplate, so normally it is not easy to access the settings on the controls. Using the settings available on the property editor, the underlying controls can be quickly configured.

Adding to PropertyGrid

The property editors provided can be added to a PropertyGrid using several methods, which are described below.

All Default Property Editors

All default Editors integration property editors can be easily injected into a single PropertyGrid instance by setting the attached BuiltinPropertyEditors.IsEnabled property to true.

Note Note
Setting this attached property simply appends our Editors integration property editors to the PropertyGrid.PropertyEditors collection. You can add your own customized property editors to that collection through XAML too, and your custom property editors will be appended after our default Editors integration property editors. This gives your custom property editors higher priority for selection over ours.

This can be done on the specific instance or via an implicit Style that targets all PropertyGrid instances in the app.

This code adds the required xmlns definitions:

XAML
Copy
​xmlns:grids="http://schemas.actiprosoftware.com/winfx/xaml/grids"
xmlns:gridseditors="http://schemas.actiprosoftware.com/winfx/xaml/gridseditors"

This code shows how add the default Editors integration property editor definitions to a single PropertyGrid:

XAML
Copy
​<grids:PropertyGrid ... gridseditors:BuiltinPropertyEditors.IsEnabled="True">
    ...
</grids:PropertyGrid>

If you wish to apply the property editors provided to all property grid instances in the application, the attached BuiltinPropertyEditors.IsEnabled property can be set to true on a PropertyGridPropertyEditorsModifier object that you define in Application.Resources. Please see the Property Editors topic under Actipro PropertyGrid for more information on defining property editors in XAML using PropertyGridPropertyEditorsModifier.

Note Note
There are several property editors that cannot be installed via the built-in editors property described above and must be manually added to a PropertyGrid.PropertyEditors collection:
  • DatePropertyEditor - Targets DateTime and normally the DateTimePropertyEditor handles that.
  • MaskedStringPropertyEditor - Targets String and requires that a Mask is set.
  • NullableDatePropertyEditor - Targets DateTime? and normally the NullableDateTimePropertyEditor handles that.
  • NullableTimePropertyEditor - Targets DateTime? and normally the NullableDateTimePropertyEditor handles that.
  • TimePropertyEditor - Targets DateTime and normally the DateTimePropertyEditor handles that.

Specific Property Editors via PropertyGrid.PropertyEditors

Property editors can also be manually defined on a single instance of the PropertyGrid control by updating the PropertyEditors collection.

Several property editors (described above) require this since they can't be automatically set up by the built-in editors property. Note that you can apply the built-in editor and manually-defined editors on the same property grid.

This code shows how manually add several property editor definitions to a single PropertyGrid:

XAML
Copy
​<grids:PropertyGrid ... >
    <grids:PropertyGrid.PropertyEditors>
        <gridseditors:DatePropertyEditor PropertyName="DateLongValue" Format="D" />
        <gridseditors:MaskedStringPropertyEditor PropertyName="MaskedString" Mask="\w+([.]\w+)*@\w+([.]\w+)+" />
        <gridseditors:EnumPropertyEditor UseDisplayAttributes="True" />
    </grids:PropertyGrid.PropertyEditors>
</grids:PropertyGrid>

Using EditorAttribute

A property editor can also be associated right on the data objects displayed by PropertyGrid using the EditorAttribute.

This code shows how associated a ColorEditBox property editor with a property:

C#
VB
Copy
​[Editor(typeof(ColorPropertyEditor), typeof(PropertyEditor))]
public Color MyColor {
    ...
}
​<Editor(GetType(ColorPropertyEditor), GetType(PropertyEditor))> _
Public Property MyColor() As Color
    ...
End Property

Since EditorAttribute only allows a Type to be specified, if you need to alter any default property values, create a class that inherits the desired property editor Type and set the property values in the class' constructor.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ribbon

The controls provided by the Editors product can be easily integrated into the Ribbon product. Several properties need to be set on Editors controls to make them use a similar appearance to other Ribbon-embedded controls.

Ribbon with Editors integrated

This topic contains these sections:

  • Setting Appearance Properties
  • Applying a Label

Setting Appearance Properties

Each edit box has a PartEditBoxBase`1.UsageContext property that can be set to ToolBar to alter the edit box to render more for a ToolBar or Ribbon-embedded scenario.

For Ribbon usage, the MinHeight should also be set to RibbonMeasurements.RibbonControlSmallHeight.

This code shows how to set the properties mentioned above:

XAML
Copy
​xmlns:editors="http://schemas.actiprosoftware.com/winfx/xaml/editors"
xmlns:ribbon="http://schemas.actiprosoftware.com/winfx/xaml/ribbon"
...
<ribbon:Ribbon>
    ...
    <editors:BrushEditBox Width="130" Value="#00FF00" UsageContext="ToolBar"
        MinHeight="{x:Static ribbon:RibbonMeasurements.RibbonControlSmallHeight}" />
    ...
</ribbon:Ribbon>

Applying a Label

An optional label can be specified on an Editors control by using the RibbonControlService.IsExternalContentSupportedProperty and RibbonControlService.LabelProperty attached properties. Labels can show up when controls are in a StackPanel within a Ribbon.

This code shows how to set the label on a BrushEditBox control:

XAML
Copy
​xmlns:editors="http://schemas.actiprosoftware.com/winfx/xaml/editors"
xmlns:ribbon="http://schemas.actiprosoftware.com/winfx/xaml/ribbon"
...
<ribbon:Ribbon>
    ...
    <editors:BrushEditBox Width="130" Value="#00FF00"
        ...
        ribbon:RibbonControlService.IsExternalContentSupportedProperty="True"
        ribbon:RibbonControlService.Label="Brush" />
    ...
</ribbon:Ribbon>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DataGrid

The controls provided by the Editors product can be easily integrated into Microsoft's WPF DataGrid, through the use of custom DataGridColumn objects. An Interop assembly is provided that ties the two products together. This topic convers the various aspects of the Interop assembly.

DataGrid with Editors integrated using the Interop assembly

This topic contains these sections:

  • Interop Assembly
  • Columns
  • Adding to DataGrid

Interop Assembly

The Interop functionality is provided through a separate assembly, which is called ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll. Therefore, a reference to this assembly must be added in order to leverage the custom DataGridColumn objects it provides. This assembly should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Columns

The DataGrid allows the columns to be statically defined in XAML via the Columns property. The Interop assembly provides several DataGridColumn-derived classes that leverage Editors' controls.

Note Note
The Editors' controls can be used in a DataGridTemplateColumn as well, but the columns provided by the Interop assembly are typically more convenient.

The Interop assembly provides a set of classes that derive from DataGridBoundColumn, which derives from DataGridColumn. These classes include:

Class | Description
DataGridBrushColumn | Represents an property editor that uses a BrushEditBox for editing Brush property values.
DataGridByteColumn | Represents an property editor that uses a ByteEditBox for editing Byte property values.
DataGridColorColumn | Represents an property editor that uses a ColorEditBox for editing Color property values.
DataGridCornerRadiusColumn | Represents an property editor that uses a CornerRadiusEditBox for editing CornerRadius property values.
DataGridDateColumn | Represents an property editor that uses a DateEditBox for editing DateTime (date-only) property values.
DataGridDateTimeColumn | Represents an property editor that uses a DateTimeEditBox for editing DateTime property values.
DataGridDoubleColumn | Represents an property editor that uses a DoubleEditBox for editing Double property values.
DataGridEnumColumn | Represents an property editor that uses a EnumEditBox for editing Enum property values.
DataGridGuidColumn | Represents an property editor that uses a GuidEditBox for editing Guid property values.
DataGridInt16Column | Represents an property editor that uses a Int16EditBox for editing Int16 property values.
DataGridInt32Column | Represents an property editor that uses a Int32EditBox for editing Int32 property values.
DataGridInt32RectColumn | Represents an property editor that uses a Int32RectEditBox for editing Int32Rect property values.
DataGridInt64Column | Represents an property editor that uses a Int64EditBox for editing Int64 property values.
DataGridMaskedStringColumn | Represents an property editor that uses a MaskedTextBox for editing String property values.
DataGridPointColumn | Represents an property editor that uses a PointEditBox for editing Point property values.
DataGridRectColumn | Represents an property editor that uses a RectEditBox for editing Rect property values.
DataGridSingleColumn | Represents an property editor that uses a SingleEditBox for editing Single property values.
DataGridSizeColumn | Represents an property editor that uses a SizeEditBox for editing Size property values.
DataGridThicknessColumn | Represents an property editor that uses a ThicknessEditBox for editing Thickness property values.
DataGridTimeColumn | Represents an property editor that uses a TimeEditBox for editing DateTime (time-only) property values.
DataGridTimeSpanColumn | Represents an property editor that uses a TimeSpanEditBox for editing TimeSpan property values.
DataGridVectorColumn | Represents an property editor that uses a VectorEditBox for editing Vector property values.

Each column exposes some of the more common settings available on their associated control. For example, the DataGridMaskedStringColumn has a Mask property that allows you to set the associated Mask on the underlying MaskedTextBox.

Adding to DataGrid

The Interop columns can be defined on a single instance of the DataGrid control using the Columns collection.

This code shows how add the Interop column definitions to a single DataGrid:

XAML
Copy
​xmlns:datagrideditors="http://schemas.actiprosoftware.com/winfx/xaml/datagrideditors"
xmlns:toolkit="http://schemas.microsoft.com/wpf/2008/toolkit"

<toolkit:DataGrid AutoGenerateColumns="False" ItemsSource="...">
    <toolkit:DataGrid.Columns>
        <datagrideditors:DataGridBrushColumn Binding="{Binding BrushValue}" Header="Brush" />
        <datagrideditors:DataGridByteColumn Binding="{Binding ByteValue}" Header="Byte" />
        <datagrideditors:DataGridColorColumn Binding="{Binding ColorValue}" Header="Color" />
        <datagrideditors:DataGridCornerRadiusColumn Binding="{Binding CornerRadiusValue}" Header="CornerRadius" />
        <datagrideditors:DataGridDateColumn Binding="{Binding DateValue}" Header="Date" />
        <datagrideditors:DataGridDateTimeColumn Binding="{Binding DateTimeValue}" Header="DateTime" />
        <datagrideditors:DataGridDoubleColumn Binding="{Binding DoubleValue}" Header="Double" />
        <datagrideditors:DataGridEnumColumn Binding="{Binding EnumValue}" Header="Enum" />
        <datagrideditors:DataGridGuidColumn Binding="{Binding GuidValue}" Header="Guid" />
        <datagrideditors:DataGridInt16Column Binding="{Binding Int16Value}" Header="Int16" />
        <datagrideditors:DataGridInt32Column Binding="{Binding Int32Value}" Header="Int32" />
        <datagrideditors:DataGridInt32RectColumn Binding="{Binding Int32RectValue}" Header="Int32Rect" />
        <datagrideditors:DataGridInt64Column Binding="{Binding Int64Value}" Header="Int64" />
        <datagrideditors:DataGridMaskedStringColumn Binding="{Binding StringValue}" Header="String" />
        <datagrideditors:DataGridPointColumn Binding="{Binding PointValue}" Header="Point" />
        <datagrideditors:DataGridRectColumn Binding="{Binding RectValue}" Header="Rect" />
        <datagrideditors:DataGridSingleColumn Binding="{Binding SingleValue}" Header="Single" />
        <datagrideditors:DataGridSizeColumn Binding="{Binding SizeValue}" Header="Size" />
        <datagrideditors:DataGridThicknessColumn Binding="{Binding ThicknessValue}" Header="Thickness" />
        <datagrideditors:DataGridTimeColumn Binding="{Binding TimeValue}" Header="Time" />
        <datagrideditors:DataGridTimeSpanColumn Binding="{Binding TimeSpanValue}" Header="TimeSpan" />
        <datagrideditors:DataGridVectorColumn Binding="{Binding VectorValue}" Header="Vector" />
    </toolkit:DataGrid.Columns>
</toolkit:DataGrid>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to 2010.1 topic contains information on converting to 2010.1 from an older version.
  • The Converting to 2011.1 topic contains information on converting to 2011.1 from an older version through 2010.1.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from 2011.1.
  • The Converting to 2017.1 topic contains information on converting to 2017.1 from an older version through 2011.2.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2010.1

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Removed default sorting in EnumEditBox and EnumListBox

Removed default sorting in EnumEditBox and EnumListBox

Previously, the EnumEditBox and EnumListBox controls would sort the values of an enumeration marked with FlagsAttribute alphabetically by name. The values of enumerations not marked with FlagsAttribute would not be sorted, and would thus use the order the values were defined.

To provide consistency and configurablity, the EnumSortComparer property was added. This IComparer<Enum> is then used to sort the enumeration values. This property defaults to null, which indicates that no sorting should be applied. This change will break any applications that use EnumEditBox or EnumListBox to present a flag enumeration and except it to be sorted alphabetically.

To restore the alphabetic sorting, the ActiproSoftware.Windows.Controls.Editors.EnumValueNameSortComparer can be used in code-behind or XAML.

This code shows how to use EnumValueNameSortComparer in XAML:

XAML
Copy
​xmlns:editors="http://schemas.actiprosoftware.com/winfx/xaml/editors"
...

<editors:EnumEditBox EnumSortComparer="{x:Static editors:EnumValueNameSortComparer.Instance}" ... >

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.1

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Added support for Linear and Radial brushes to BrushEditBox and BrushEditor (2011.1 build 0534)

Added support for Linear and Radial brushes to BrushEditBox and BrushEditor (2011.1 build 0534)

Support for linear and radial gradient brushes was added to BrushEditbox and BrushEditor. In previous version, these types of brushes were not supported. The ActiproSoftware.Windows.Controls.Editors.BrushEditBox.AllowGradientBrushes and ActiproSoftware.Windows.Controls.Editors.Primitives.BrushEditor.AllowGradientBrushes properties can be used to revert to the old behavior, which only allows solid color or null brushes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Theming Architectural and Style Changes
  • Renamed Part Methods
  • Updates To Hint Properties
  • Consolidated Converters
  • Consolidated PopupButton Styles
  • Changes to Calendar Controls

Theming Architectural and Style Changes

See unified conversion topic for details on breaking changes made to the theming architecture, which affects control styles and related dictionaries.

Renamed Part Methods

The ActiproSoftware.Windows.Controls.Editors.Parts.Primitives.TypeSpecificPartBase`1.CommitChangesToValue method was renamed to CommitPendingChanges to better align with the new CancelPendingChanges method.

Upgrade Instructions Upgrade Instructions
All references to CommitChangesToValue must be replaced with CommitPendingChanges.

Updates To Hint Properties

The NullContent, NullContentTemplate, and NullContentTemplateSelector properties on ActiproSoftware.Windows.Controls.Editors.PartEditBox and ActiproSoftware.Windows.Controls.Editors.PartGroup have been renamed to ActiproSoftware.Windows.Controls.Editors.PartEditBox.Hint, ActiproSoftware.Windows.Controls.Editors.PartEditBox.HintTemplate, and ActiproSoftware.Windows.Controls.Editors.PartEditBox.HintTemplateSelector, respectively. This was done to provide consistency across all our products, with regards to hints.

Upgrade Instructions Upgrade Instructions
  1. All references to NullContent must be replaced with Hint.
  2. All references to NullContentTemplate must be replaced with HintTemplate.
  3. All references to NullContentTemplateSelector must be replaced with HintTemplateSelector.

Consolidated Converters

The ActiproSoftware.Windows.Controls.Calendar.DateTimePicker and ActiproSoftware.Windows.Controls.Calendar.MonthCalendar controls (which are now located in our Legacy assembly) and the DateTimeEditBox and MonthCalendar controls found in our Editors for WPF product used identical IValueConverters to convert certain date types to strings. These converters have been consolidated to reduce duplication and confusion.

The DayOfWeekToStringConverter and CalendarDayOfWeekFormat types were replaced with DayOfWeekFormatPatternConverter and DayOfWeekFormatPattern, respectively.

In addition, the IsNullOrTransparentBrushConverter type has as been moved to the Shared Library, so that it may be leveraged by other products.

Upgrade Instructions Upgrade Instructions
  1. All references to DayOfWeekToStringConverter must be replaced with DayOfWeekFormatPatternConverter. For XAML files, editors:DayOfWeekToStringConverter must be replaced with shared:DayOfWeekFormatPatternConverter.
  2. All references to CalendarDayOfWeekFormat must be replaced with DayOfWeekFormatPattern. For XAML files, editors:CalendarDayOfWeekFormat must be replaced with shared:DayOfWeekFormatPattern.
  3. Any references to IsNullOrTransparentBrushConverter may need to reference the ActiproSoftware.Windows.Media namespace. For XAML files, editors:IsNullOrTransparentBrushConverter must be replaced with shared:IsNullOrTransparentBrushConverter.

Consolidated PopupButton Styles

The Editors product included a style for the PopupButton control, for use in the parts-based editors. This styles has been consolidated into the Shared Library for general use when embedding a PopupButton in another control.

In previous versions, the style could be referenced using the ComponentResourceKey defined by the EditorsCommonDictionary.PopupButtonStyleKey property, but has been moved to SharedResourceKeys.EmbeddedPopupButtonOverrideStyleKey.

There is one breaking change to the Style itself as well. Previously, the Style would change the default display mode of the PopupButton from Split to ButtonOnly. With this release, the display mode is not set by the Style and must be done manually.

Alternatively, a native Button could be used in place of the PopupButton when using the ButtonOnly display mode. In this case, the Style referenced by the SharedResourceKeys.EmbeddedButtonBaseOverrideStyleKey property would be used instead.

Upgrade Instructions Upgrade Instructions
  1. All references to EditorsCommonDictionary.PopupButtonStyleKey must be reviewed and either:
    • Replaced with SharedResourceKeys.EmbeddedPopupButtonOverrideStyleKey
    • Replaced with SharedResourceKeys.EmbeddedButtonBaseOverrideStyleKey and replace the PopupButton with a Button.

Changes to Calendar Controls

In addition to the changes listed above in the "Consolidated Converters" section, a few object model changes have been made to the Editors' calendar controls in order to provide consistency.

The CalendarDayOfWeekFormat enumeration has been renamed to DayOfWeekFormatPattern and moved to the Shared Library.

Because of this change, the DayOfWeekFormat property on MonthCalendar and ActiproSoftware.Windows.Controls.Editors.Primitives.Calendar.DayOfWeekItem have been renamed to DayOfWeekFormatPattern.

Upgrade Instructions Upgrade Instructions
  1. All references to CalendarDayOfWeekFormat must be replaced with DayOfWeekFormatPattern. For XAML files, editors:CalendarDayOfWeekFormat must be replaced with shared:DayOfWeekFormatPattern.
  2. All references to MonthCalendar.DayOfWeekFormat must be replaced with MonthCalendar.DayOfWeekFormatPattern.
  3. All references to DayOfWeekItem.DayOfWeekFormat must be replaced with DayOfWeekItem.DayOfWeekFormatPattern.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2017.1

The old versions of the edit boxes in Editors, while providing many features, were very complex and used many UI elements to support their functionality. This meant that windows with a lot of editors (such as when used in property grids or grids) could be very memory intensive and take a while to load.

For the 2017.1 version, we reimplemented them with a design that is code-compatible with the Universal Windows variations of Editors. These new edit boxes are now lightweight controls that harness a native TextBox control in their templates. They use far fewer elements and bindings than before and load very quickly. New edit boxes, pickers, and other miscellaneous controls have been added as well.

We realize that some customers may wish to upgrade to 2017.1 immediately, but it might take some time to get their applications updated to work with the new codebase. For those scenarios, the final section of this topic tells how you can still access the old versions of the Editors assembly (called Editors.Legacy) and related assemblies, and continue to use them while you work on upgrading to the new codebase. Please only do this if needed, as you want to get on the this new version as soon as possible to continue getting new features and bug fixes.

Note Note
The new Editors contains most, but not all of the features in the old version, along with many new features. If the new version is missing a feature area that you need that was in the old version, please write our support team and we can work with you to determine if it's feasible to add back in.

The rest of this topic discusses the breaking changes made between the old and new versions, and how to update in cases where appropriate.

This topic contains these sections:

  • General PartEditBox and Part Updates
  • PropertyGrid Integration Updates
  • DataGrid Integration Updates
  • Ribbon Integration Updates
  • AnalogClock Changed to TimePicker
  • BrushEditBox Updates
  • BrushEditor Changed to BrushPicker
  • Calculator Updates
  • ColorEditBox Updates
  • ColorEditor Changed to ColorPicker
  • CornerRadiusEditBox Updates
  • DateTimeEditBox Updates
  • DateTimeEditor Changed to DateTimePicker
  • EnumEditBox Updates
  • EnumListBox Updates
  • EnumListBoxItem Updates
  • GuidEditBox Updates
  • Int32RectEditBox Updates
  • MaskedTextBox Updates
  • MonthCalendar Updates
  • PasswordBox Removed
  • PointEditBox Updates
  • Rating Updates
  • RatingItem Updates
  • RectEditBox Updates
  • SizeEditBox Updates
  • Spinner Updates
  • TextBox Removed
  • ThicknessEditBox Updates
  • TimeEditor Changed to TimePicker
  • TimeSpanEditBox Updates
  • VectorEditBox Updates
  • Temporary Inclusion of Older Editors and Interop Legacy Assemblies

General PartEditBox and Part Updates

The part edit box infrastructure was completely rewritten in the 2017.1 version to use a native TextBox control in templates and to be lighter weight in terms of elements. Most of the features of the old edit boxes are still available in the new version, along with many new ones, but some lesser-used features were removed in scenarios where they didn't add much value and would have introduced extensive complexity to the controls. A benefit of using TextBox as the primary input method is that now features like IME input and rich UIA are fully supported.

The old version's part edit boxes had a three tier infrastructure: edit box, part groups, and parts. Now part edit boxes have two-tiers: edit box and parts.

Edit boxes no longer work like an items control in terms of how UI is constructed (there are no more placement slots). Some edit boxes have templates that contain preview swatches (like for Brush or Color display) that are left-aligned. All edit boxes have a TextBox that allows text entry of a string representation of the object being edited. Many edit boxes have an optional drop-down button that shows if the HasPopup property is true. The template of each edit box can be customized if additional buttons or UI needs to be added.

  • In an effort to simplify the object model, part groups no longer exist in the new version. ArePartGroupsDisabledWhenUnchecked, ArePartGroupsSelectable, and DefaultPartGroupVisibility properties removed.
  • Since a simpler TextBox is used for input, several properties no longer apply. BackgroundEditable, BackgroundNonEditable, ForegroundEditable, and ForegroundNonEditable properties removed.
  • Similarly, CenterSlotHorizontalAlignment, CenterSlotMargin, LeftSlotMargin, and RightSlotMargin properties removed. If you need to alter the alignment of the text in the TextBox, use the HorizontalContentAlignment property instead.
  • Nullable edit boxes no longer have a checkbox. Instead, select all the text and delete it to null out a nullable edit box. IsChecked, CheckBoxInactiveVisibility, CheckBoxMargin, CheckBoxPlacementOrder, CheckBoxPlacementSlot, CheckBoxTemplate, and CheckBoxVisibility properties removed.
  • The InitialValue property was removed since the former checkbox used to initialize it. However numerous edit boxes have a new DefaultValue property that is similar and is used as the value to set when incrementing/decrementing (via spinner or arrow keys) from a null value.
  • The drop-down button is now defined in each edit box control's template so placement properties no longer apply. DropDownButtonInactiveVisibility, DropDownButtonMargin, DropDownButtonPlacementOrder, DropDownButtonPlacementSlotSpinnerTemplate, DropDownButtonTemplate, DropDownHorizontalAlignment, and DropDownStaysOpen properties removed.
  • DropDownButtonVisibility property removed. Use HasPopup property instead.
  • DropDownClosed and DropDownOpened events removed.
  • DropDownContent, DropDownContentTemplate, and DropDownContentTemplateSelector properties removed. Each edit box now has a related picker (i.e. DatePicker for DateEditBox) and its style can be set via PopupPickerStyle. This Style value can set a new Template for the picker if needed.
  • Focus (overload) and SelectFirstGroup methods removed. Use the normal Focus method instead.
  • Hint, HintTemplate, HintTemplateSelector, IsHintTransitioningEnabled, and IsHintVisible properties removed. Use PlaceholderText property instead.
  • IsDropDownButtonTransparencyModeEnabled property removed. Use UsageContext property instead.
  • IsDropDownOpen property removed. Use IsPopupOpen property instead.
  • IsFocusMovedOnTerminalMatches property removed.
  • MaxDropDownHeight, MaxDropDownWidth, MinDropDownHeight, and MinDropDownWidth properties removed.
  • PartValueCancelTriggers property and PartValueCancelTriggers type removed.
  • PartValueCommitTriggers property renamed to CommitTriggers, and PartValueCommitTriggers type renamed to PartEditBoxCommitTriggers.
  • PromptIndicatorVisibility property removed.
  • SelectFirstGroup method removed. SelectAll method can be used instead.
  • SpinBehavior property renamed to SpinWrapping and related SpinBehavior enum renamed to SpinWrapping.
  • SpinnerInactiveVisibility property removed and SpinnerVisibility property return value changed to cover both former properties. Use the revised SpinnerVisibility property instead.
  • Spinner is now defined in each edit box control's template so placement properties no longer apply. SpinnerMargin, SpinnerPlacementOrder, SpinnerPlacementSlot, and SpinnerTemplate properties removed.

In addition to the above, some number-oriented edit boxs have had these property changes:

  • StepValue property renamed to SmallChange, which is used with arrow key, mouse wheel, spinner, and slider incrementing. A new LargeChange property is used for PgUp/PgDn incrementing. Number-oriented structure edit boxes like ThicknessEditBox now use the same Type for the change property values, so that different increments can be given for the different parts.
  • Minimum and Maximum now use non-nullable types instead of the same type as the Value property. So for a DoubleEditBox (which has a Value of type Nullable<Double>), the type for those two properties will be Double.
  • AllowInfinity and AllowNaN properties are now available only on DoubleEditBox and SingleEditBox as IsPositiveInfinityAllowed, IsNegativeInfinityAllowed, and IsNaNAllowed properties.

PropertyGrid Integration Updates

The new "ActiproSoftware.Editors.Interop.Grids.Wpf.dll" assembly provides integration of edit boxes with the PropertyGrid control. found in the Grids product via the use of custom property editors. This feature is similar to what was in the old "ActiproSoftware.Editors.Interop.PropertyGrid.Wpf.dll" assembly. Several of the property editor classes (like BrushPropertyEditor, etc.) have had property updates to correspond to the related edit box property changes (adds, renames, or removes) described in this topic. Also the MaskedTextBoxPropertyEditor class is now named MaskedStringPropertyEditor.

The Editors and PropertyGrid Interoperability topic covers the property editors that are available, including additional ones like DatePropertyEditor, to integrate edit boxes with PropertyGrid and how to do so in the new version.

DataGrid Integration Updates

The new "ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll" assembly provides easy integration of edit boxes with the native WPF DataGrid control. Several of the column classes (like DataGridBrushColumn, etc.) have had property updates to correspond to the related edit box property changes (adds, renames, or removes) described in this topic. Also the DataGridMaskedTextColumn class is now named DataGridMaskedStringColumn.

The Editors and DataGrid Interoperability topic covers the column classes that are available, including additional ones like DataGridDateColumn, to integrate edit boxes with DataGrid.

Ribbon Integration Updates

The old "ActiproSoftware.Editors.Interop.Ribbon.Wpf.dll" assembly, which provided Ribbon control-like appearance for edit boxes via a RibbonEditorsStyleBehavior class is no longer used in the new version. Instead the new edit box templates include a built-in special mode that can be activated for toolbar/Ribbon contextual usage.

The Editors and Ribbon Interoperability topic covers the properties that should be set on edit boxes to achieve a Ribbon control-like appearance, and to also optionally support labels.

AnalogClock Changed to TimePicker

The AnalogClock control has been removed. Use the new TimePicker control instead.

BrushEditBox Updates

  • AllowGradientBrushes property renamed to IsGradientAllowed.
  • BrushEditorStyle property renamed to PopupPickerStyle.
  • BrushPreviewInactiveVisibility property removed and swatch is always visible now.
  • BrushPreviewMargin property renamed to SwatchMargin.
  • BrushPreviewPlacementOrder property removed.
  • BrushPreviewPlacementSlot property removed.
  • BrushPreviewTemplate property removed.
  • BrushPreviewVisibility property renamed to HasSwatch.
  • IsAlphaComponentEditable property removed.
  • IsAlphaComponentVisible property renamed to IsAlphaEnabled.

BrushEditor Changed to BrushPicker

The BrushEditor and BrushPreviewControl controls have been removed. Use the new BrushPicker control instead.

Calculator Updates

  • DisplayMode property removed in favor of new HasDisplay and HasMemoryButtons properties.
  • DisplayString property renamed to DisplayText.
  • CalculatorCommands class removed in favor of new command properties directly on Calculator.

ColorEditBox Updates

  • ColorEditorStyle property renamed to PopupPickerStyle.
  • ColorPreviewInactiveVisibility property removed and swatch is always visible now.
  • ColorPreviewMargin property renamed to SwatchMargin.
  • ColorPreviewPlacementOrder property removed.
  • ColorPreviewPlacementSlot property removed.
  • ColorPreviewTemplate property removed.
  • ColorPreviewVisibility property renamed to HasSwatch.
  • EditableParts property and related ColorEditableParts enumeration removed.
  • ExportFormat property removed.
  • Format property removed.
  • IsAlphaComponentVisible property renamed to IsAlphaEnabled.

ColorEditor Changed to ColorPicker

The ColorEditor control has been removed. Use the new ColorPicker control instead.

CornerRadiusEditBox Updates

  • EditableParts property and related CornerRadiusEditableParts enumeration removed.

DateTimeEditBox Updates

  • AnalogClockStyle and MonthCalendarStyle properties removed. Use PopupPickerStyle with a DateTimePicker style instead.
  • DateValue property removed. Use the new DateEditBox control when doing date-only selection.
  • DefaultDropdownContentType property removed since there are separate DateTimeEditBox, DateEditBox, and TimeEditBox controls now.
  • EditableParts property and related DateTimeEditableParts enumeration removed.
  • ExportFormat property removed.

DateTimeEditor Changed to DateTimePicker

The DateTimeEditor control has been removed. Use the new DateTimePicker control instead.

EnumEditBox Updates

  • EnumListBoxStyle property renamed to PopupPickerStyle.
  • UseDescriptionAttributes property renamed to UseDisplayAttributes. Both DescriptionAttribute and DisplayAttribute are now supported.

EnumListBox Updates

  • DisplayMode property and related EnumListBoxDisplayMode enumeration removed.
  • IsItemsSourceAutoUpdated property removed.
  • EnumListBoxStyle property renamed to PopupPickerStyle.
  • UseDescriptionAttributes property renamed to UseDisplayAttributes. Both DescriptionAttribute and DisplayAttribute are now supported.

EnumListBoxItem Updates

  • DisplayMode property removed.
  • UseDescriptionAttributes property removed.

GuidEditBox Updates

  • NewGuidButtonInactiveVisibility property removed and swatch is always visible now.
  • NewGuidButtonMargin property removed.
  • NewGuidButtonPlacementOrder property removed.
  • NewGuidButtonPlacementSlot property removed.
  • NewGuidButtonTemplate property removed.
  • NewGuidButtonVisibility property removed. Set IsReadOnly to true to hide the button.
  • SetValueToNewGuid property renamed to NewGuidCommand.

Int32RectEditBox Updates

  • EditableParts property and related RectEditableParts enumeration removed.

MaskedTextBox Updates

  • MaskedTextBox changed to inherit the native TextBox control.
  • IsMatchedChanged event changed to be an EventHandler.
  • IsMatchedTerminally property and IsMatchedTerminallyChanged event removed
  • MaskType property renamed to MaskKind, and related MaskType enumeration renamed to MaskKind.
  • PromptBrush, PromptGeometry, and PromptIndicatorType properties removed since MaskedTextBox now inherits the native TextBox instead of rendering prompt glyphs itself.
  • TextChanged and TextChanging events changed to use the native TextBox versions, since MaskedTextBox how inherits TextBox.

MonthCalendar Updates

  • ActiveViewMode and MaxViewMode properties changed to return MonthCalendarViewMode, renamed from CalendarViewMode.
  • AreTransitionAnimationsEnabled property removed and animations always occur.
  • BeginUpdate/EndUpdate methods removed.
  • ClearButtonContent property changed to a string and renamed to ClearButtonText.
  • ClearButtonContentTemplate property removed. Use the new ClearButtonStyle property instead.
  • DayItemStyle and DayItemStyleSelector properties removed. Use the new DayItemTemplate property instead.
  • DayOfWeekItemStyle and DayOfWeekItemStyleSelector properties removed. Use the new DayNameItemContainerStyle and DayNameItemTemplate properties instead.
  • DecadeItemStyle and DecadeItemStyleSelector properties removed. Use the new DecadeItemTemplate property instead.
  • IsDayOfWeekHeaderVisible property removed, and header will always be visible.
  • MaxDate property renamed to Maximum.
  • MinDate property renamed to Minimum.
  • MonthItemStyle and MonthItemStyleSelector properties removed. Use the new MonthItemTemplate property instead.
  • NextViewButtonStyle and PreviousViewButtonStyle properties removed. Use the new NavigationButtonStyle property instead.
  • Refresh method added a parameter.
  • SelectedDates property changed to use a new DateRangeCollection implemention in the Shared Library.
  • SelectionChanged event declaration changed.
  • SelectionChanging event removed.
  • SelectionMode property changed to return MonthCalendarSelectionMode, renamed from CalendarSelectionMode.
  • ViewResetMode property changed to return MonthCalendarViewResetMode, renamed from CalendarViewResetMode.
  • WeekNumberItemStyle and WeekNumberItemStyleSelector properties removed. Use the new WeekNumberItemContainerStyle and WeekNumberItemTemplate properties instead.
  • YearItemStyle and YearItemStyleSelector properties removed. Use the new YearItemTemplate property instead.

PasswordBox Removed

Use the native PasswordBox control instead.

PointEditBox Updates

  • EditableParts property and related PointEditableParts enumeration removed.

Rating Updates

  • IsReadOnly property removed. Set the IsEnabled property to false to simulate read-only mode.

RatingItem Updates

  • HoverGlyphTemplate, SelectedAlternateBackgroundGlyphTemplate, and SelectedAlternateForegroundGlyphTemplate properties replaced by the ActiveGlyphTemplate and AverageGlyphTemplate properties.

RectEditBox Updates

  • EditableParts property and related RectEditableParts enumeration removed.

SizeEditBox Updates

  • EditableParts property and related SizeEditableParts enumeration removed.

Spinner Updates

  • CommandTarget property removed.
  • DecrementValue property renamed to DecrementCommand.
  • IncrementValue property renamed to IncrementCommand.

TextBox Removed

Use the native TextBox control instead.

ThicknessEditBox Updates

  • EditableParts property and related ThicknessEditableParts enumeration removed.

TimeEditor Changed to TimePicker

The TimeEditor control has been removed. Use the new TimePicker control instead.

TimeSpanEditBox Updates

  • EditableParts property and related TimeSpanEditableParts enumeration removed.
  • ExportFormat property removed.

VectorEditBox Updates

  • EditableParts property and related VectorEditableParts enumeration removed.

Temporary Inclusion of Older Editors and Interop Legacy Assemblies

We recognize that for the 2017.1 version, numerous breaking changes were made and that you might not be able to immediately update to the newer logic. While we fully encourage you to do so since all future updates and maintenance will only be done on this newer Editors codebase, we still offer the older Editors version along with its related interop assemblies.

These older legacy assemblies are not installed by default. You must check the 'Control Assemblies / Legacy' option in the installer to install them. Once you do so, these Editors-related assemblies will appear in a 'Legacy' subfolder of the Actipro assembly install folder (see the Deployment topic for the default location), but will not appear in the GAC:

  • ActiproSoftware.Editors.Legacy.Wpf.dll
  • ActiproSoftware.Editors.Interop.DataGrid.Legacy.Wpf.dll
  • ActiproSoftware.Editors.Interop.PropertyGrid.Legacy.Wpf.dll
  • ActiproSoftware.Editors.Interop.Ribbon.Legacy.Wpf.dll

You will be able to reference the ActiproSoftware.Editors.Legacy.Wpf assembly in place of the new ActiproSoftware.Editors.Wpf assembly to maintain full backward compatibility with the old version, while you work on upgrading your application to the new version.

See the Licensing topic for info on how to add an entry to the licenses.licx file (updated info added in v2017.1).

Do NOT reference both the ActiproSoftware.Editors.Wpf and ActiproSoftware.Editors.Legacy.Wpf assemblies (or similar for interop assemblies) in the same project, since they have many types/members named the same.

Again, these legacy assemblies will only be included temporarily. We encourage you to upgrade your code to the latest Editors assembly as soon as it is feasible so that you can continue to receive the latest product feature additions and bug fixes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Gauge provides circular, linear, and digital gauge controls natively written for the Windows Presentation Foundation framework. The gauge controls can be used to to more effectively present various data.

A recreation of an automotive instrument cluster

To get started using the control, read through this documentation and study the sample project. The sample includes live demos of many of Gauge's features.

This topic contains these sections:

  • What is a Gauge?
  • Features at a Glance

What is a Gauge?

A gauge is a presentation tool that helps to monitor and regulate the level, state, and dimensions or forms of a variable, which is bounded within a range.

The most common example of gauges is seen in the dashboard of a car, which indicate the speed of the car, the temperature of the engine, available fuel, etc. The image above shows a recreation of a car's dashboard using all three gauge controls.

Features at a Glance

General Features

  • Data-binding is fully supported allowing for live updates and custom animations.
  • Any WPF control can be embedded and precisely positioned inside the gauge controls, including z-layer positioning.
  • All gauge elements can be customized as desired to achieve a unique and consistent look.
  • Includes built-in converters that can be used by the gauge controls to present the average, maximum, and/or minimum values.
  • Easily render a bitmap of the gauge control and save to any image format (.png, .gif, .jpg, etc.) supported by WPF.
  • Gauge elements can automatically adjust their sized based on the size of the gauge control.

CircularGauge Features

  • Includes several built-in frame rims and backgrounds, each with a unique effect.
  • Any number of scales can be specified, which determine the placement of all other gauge elements.
  • The start angle and sweep angle of the scales can be fully customized.
  • Tick sets can be used to specify the minimum and maximum values used by all child elements.
  • Interval steps can be used to position tick marks and labels and the interval origin can be set to the minimum value, zero, or the maximum value.
  • Tick marks and/or labels can be automatically included at the major and minor intervals with several customization options.
  • Tick marks and/or labels can be manually added at a specific value.
  • Logarithmic tick-sets are fully supported with a configurable base.
  • Includes five unique pointer types, each with several styles.
  • Needle and Marker pointers can render a custom image or Geometry.
  • Ability to include any number of pointers, which can show unique values all on the same gauge.
  • Caps can be used to cover the ends of needles, providing for a more realistic looking gauge.
  • Support for interactive pointers, which can be dragged by the end-user using the mouse.
  • Pointer values can be snapped to a configurable interval, such as restricting values to whole numbers.
  • Dampening allows for pointer movements to be smoothed and animated.
  • Ability to include any number of ranges, which can highlight areas of interest.
  • Refresh rate can be used to limit the number of updates made to a pointer, which gives the user enough time to see the updated values.

DigitalGauge Features

  • Includes several built-in frame rims and backgrounds, each with a unique effect.
  • Supports five character styles, which can be used to display characters as well as numbers.
  • The size and placement of the character display is fully customizable.
  • Refresh rate can be used to limit the number of updates made to the display, which gives the user enough time to see the updated values.
  • Skew angles can be used to produce italic characters.
  • Led lights can be turned on or off, or set to blink, all using smooth animations.
  • Text display can be automatically scrolled to the left or right, using a configurable interval.

Led Features

  • Includes several built-in frame rims and backgrounds, each with a unique effect.
  • Supports several led light shapes and customizable colors.
  • Led light can be turned on or off, or set to blink, all using smooth animations.

LinearGauge Features

  • Includes several built-in frame rims and backgrounds, each with a unique effect.
  • Can be oriented horizontally or vertically.
  • Any number of scales can be specified, which determine the placement of all other gauge elements.
  • Tick sets can be used to specify the minimum and maximum values used by all child elements.
  • Interval steps can be used to position tick marks and labels and the interval origin can be set to the minimum value, zero, or the maximum value.
  • Tick marks and/or labels can be automatically included at the major and minor intervals with several customization options.
  • Tick marks and/or labels can be manually added at a specific value.
  • Logarithmic tick-sets are fully supported with a configurable base.
  • Includes three unique pointer types, each with several styles.
  • Marker pointers can render a custom image or Geometry.
  • Ability to include any number of pointers, which can show unique values all on the same gauge.
  • Bar pointers include continuous and segmented looks, and can include a blub tip similiar to glass mercury thermometers.
  • Dampening allows for pointer movements to be smoothed and animated.
  • Support for interactive pointers, which can be dragged by the end-user using the mouse.
  • Pointer values can be snapped to a configurable interval, such as restricting values to whole numbers.
  • Ability to include any number of ranges, which can highlight areas of interest.
  • Refresh rate can be used to limit the number of updates made to a pointer, which gives the user enough time to see the updated values.

ToggleSwitch Features

  • Includes several built-in frame rims and backgrounds, each with a unique effect.
  • Supports two switch types and customizable colors.
  • Allows for two or three checked states, with smooth animations used when transitioning between states.

Code and Requirements

  • Includes detailed documentation and a sample project that demos nearly every feature.
  • Written in 100% pure C# and is based on the Windows Presentation Foundation framework.
  • Requires the .NET 4.0 or later run-time framework.
  • Full XAML support and XBAP compatibility.
  • Extensive Visual Studio and Expression Blend designer capabilities.
  • Visual Studio and/or Expression Blend are recommended development tools for this product.

Extensive Documentation and Samples

Actipro has spent a lot of time refining the design of Gauge to take advantage of WPF best practices. We realize that a good product is only part of the equation though and have also worked very hard to write detailed documentation on the product. In addition to that, Gauge ships with the full source for many QuickStart examples that each focus on learning a specific Gauge feature.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Getting up and running with Gauge controls is extremely easy, especially with the samples we include.

This topic's information will assume you are using Visual Studio to write your XAML code for a WPF Window that will contain one of the Gauge controls.

This topic contains these sections:

  • Read the Documentation Topics
  • Add Assembly References
  • Getting Started with CircularGauge
  • Getting Started with DigitalGauge
  • Getting Started with Led
  • Getting Started with LinearGauge
  • Getting Started with ToggleSwitch
  • Further Study

Read the Documentation Topics

This documentation file contains a lot of information about using Actipro Gauge and its related controls to its fullest. Whenever you have specific questions about a feature, please read through its documentation topic to search for answers.

Add Assembly References

First, add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.Gauge.Wpf.dll assemblies. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Getting Started with CircularGauge

This code shows the base XAML that you can use to create a simple CircularGauge with a few gauge elements:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<gauge:CircularGauge Width="200" Height="200" Radius="100">
    <gauge:CircularScale Radius="80">
        <gauge:CircularTickSet>
            <gauge:CircularTickSet.Ticks>
                <gauge:CircularTickMarkMinor />
                <gauge:CircularTickMarkMajor />
                <gauge:CircularTickLabelMajor ScalePlacement="Inside" />
            </gauge:CircularTickSet.Ticks>
            <gauge:CircularTickSet.Pointers>
                <gauge:CircularPointerNeedle Value="25" Background="Yellow" />
            </gauge:CircularTickSet.Pointers>
        </gauge:CircularTickSet>
    </gauge:CircularScale>
</gauge:CircularGauge>

Getting Started with DigitalGauge

This code shows the base XAML that you can use to create a simple DigitalGauge to display a string:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<gauge:DigitalGauge Width="200" Height="100" Value="Testing" />

Getting Started with Led

This code shows the base XAML that you can use to create a simple Led with a green light:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<gauge:Led Width="100" Height="100" LedForeground="Green" />

Getting Started with LinearGauge

This code shows the base XAML that you can use to create a simple LinearGauge with a few gauge elements:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<gauge:LinearGauge Width="200" Height="100">
    <gauge:LinearScale BarExtent="85%">
        <gauge:LinearTickSet>
            <gauge:LinearTickSet.Ticks>
                <gauge:LinearTickMarkMinor />
                <gauge:LinearTickMarkMajor />
                <gauge:LinearTickLabelMajor ScalePlacement="Inside" />
            </gauge:LinearTickSet.Ticks>
            <gauge:LinearTickSet.Pointers>
                <gauge:LinearPointerMarker Value="25" Background="Yellow" />
            </gauge:LinearTickSet.Pointers>
        </gauge:LinearTickSet>
    </gauge:LinearScale>
</gauge:LinearGauge>

Getting Started with ToggleSwitch

This code shows the base XAML that you can use to create a simple ToggleSwitch:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<gauge:ToggleSwitch Width="100" Height="100" IsChecked="true" />

Further Study

It's very easy to use the various Gauge controls and there are probably a lot of great features that you aren't aware of.

Run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of the controls.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Coordinate System

This section contains information regarding the Actipro Gauge coordinate system, which is used to position elements and controls.

This topic contains these sections:

  • X/Y Coordinates
  • Coordinate Origin
  • Z-Order

X/Y Coordinates

The X/Y coordinates specify an offset from an origin point, which by default is the center of the gauge. The values along the X-axis increase from left to right, while the values along the Y-axis increase from top to bottom.

The X/Y coordinates can be specified using a fixed pixel offset, or using a percentage. The basis of the percentage varies based on the control. For CircularGaugeBase-derived controls, the Radius is used as the basis. For the remaining controls, the ActualWidth and ActualHeight are used.

Percentage based sizes can be specified by appending the percent character (%) at then end of the value (e.g. X="10%").

The coordinate system shown on a CircularGauge

The coordinate system shown on a DigitalGauge

The coordinate system shown on a LinearGauge

Coordinate Origin

By default, the origin point of the X/Y coordinates is the center of the gauge. The origin point can be changed to any one of nine locations, defined by CoordinateOrigin.

The coordinate origins shown on a CircularGauge

Value | Description
1. TopLeft | Indicates that the top-left point will be used at the origin.
2. CenterTop | Indicates that the center-top point will be used at the origin.
3. TopRight | Indicates that the top-right point will be used at the origin.
4. MiddleLeft | Indicates that the middle-left point will be used at the origin.
5. Center | Indicates that the center point will be used at the origin. This is the default origin.
6. MiddleRight | Indicates that the middle-right point will be used at the origin.
7. BottomLeft | Indicates that the bottom-left point will be used at the origin.
8. CenterBottom | Indicates that the center-bottom point will be used at the origin.
9. BottomRight | Indicates that the bottom-right point will be used at the origin.
Z-Order

The z-order of the elements presented by the gauge controls is determined by the ZIndexProperty attached property. An element with a higher z-index will be rendered on top of an element with a lower z-index.

Note Note
The gauge elements all derive from GaugeElement, which exposes the ZIndex property. Therefore, the z-index of the gauge elements can be set without having to use the attached property syntax.

When one or more elements have the same z-index value, then the last one added to the gauge control will be rendered on top.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

To allow for easy customization, most of the functionality found in the CircularGauge control is actually provided through child elements. This topic will briefly describe each aspect of the CircularGauge control starting from the top and working down. Additional topics are provided for areas that require more detailed explanations.

This topic contains these sections:

  • Extents and Ascents
  • Frames
  • Scales
  • Tick Sets
  • Tick Marks and Labels
  • Ranges
  • Pointers

Extents and Ascents

Most of the CircularGauge elements provide one or more properties that control the size of the rendered content. For example, TickMarkExtent and TickMarkAscent control the width/height of the tick marks.

Extent refers to the length of the element outward from the center. In other words, the extent runs along an imaginary line drawn from the center point outwards. This allows the extent to change direction depending on the current angle. Therefore, an element drawn on the right side of the gauge would be as wide as an element drawn at the top is tall. The ascent is always runs perpendicular to the extent.

Two CircularGauges with blue extent lines, and their associated green ascent lines

Both extents and ascents can be specified as a percentage of the frame radius, or as a fixed value. For example, TickMarkExtent="5%" will size the tick mark to be 5% of the frame radius, therefore if the frame radius is changed the tick mark size will change proportionally.

Frames

Several frames are support and are rendered in the background of the control.

See the Frames topic for more information.

Scales

CircularGauge uses CircularScale elements to host the remaining elements described below and is used for overall positioning.

See the Scales topic for more information.

Tick Sets

The CircularScale elements can contain one or more CircularTickSet elements, which specify the minimum value, maximum value, and intervals used by the remaining elements.

See the Tick Sets topic for more information.

Tick Marks and Labels

The CircularTickSet elements can contain one or more CircularTickMarkMajor, CircularTickMarkMinor, CircularTickMarkCustom, CircularTickLabelMajor, CircularTickLabelMinor, and/or CircularTickLabelCustom elements, which render the tick marks/labels along the scale bar.

See the Tick Marks and Labels topic for more information.

Ranges

The CircularTickSet elements can contain one or more CircularRange elements, which are used to highlight a value range of interest.

See the Ranges topic for more information.

Pointers

The CircularTickSet elements can contain one or more CircularPointerBar, CircularPointerCap, CircularPointerLabel, CircularPointerMarker and/or, CircularPointerNeedle elements, which provide visual feedback of a value.

See the Pointers topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Frames

The CircularGauge frame is made up of a rim and a background. Each of which can be configured independenty to create a customized look.

This topic contains these sections:

  • Frame Rim
  • Frame Background
  • Glass Effect

Frame Rim

The frame rim is rendered at the bottom most layer of the control and supports many styles, each with a special effect. The rim type can be set using the RimType property and the supported rim types can be seen using the sample project provided.

Brush and Effect

The rim color can be customized by setting the RimBrush property. The rim effect varies based on the rim type, but can be disabled entirely by setting IsRimEffectEnabled to false.

Two CircularGauge controls with a blue rim; the right image has the rim effect disabled

Note Note
The rim effect is only supported when IsRimEffectEnabled is set to true and RimBrush is set to a SolidColorBrush.

Size

The size, or radius, of the frame rim is determined by the Radius property.

Custom Geometry/ImageSource

When the built-in rim types are not flexible enough to achieve the look desired, a custom Geometry or ImageSource can be used.

When RimType is set to to CustomRimGeometry, then the Geometry specified by RimGeometry is used when rendering the rim.

Note Note
Custom geometries will be automatically centered and scaled to fit inside the gauge control.

When RimType is set to to CustomRimImage, then the ImageSource specified by RimImageSource is used when rendering the rim.

Frame Background

The frame background is rendered on top of the frame rim and supports many styles, each with a special effect. The background type can be set using the BackgroundType property and the supported background types types can be seen using the sample project provided.

Brush and Effect

The background color can be customized by setting the Background property. The background effect varies based on the background type, but can be disabled entirely by setting IsBackgroundEffectEnabled to false.

Two CircularGauge controls with a red background; the right image has the background effect disabled

Note Note
The background effect is only supported when IsBackgroundEffectEnabled is set to true and Background is set to a SolidColorBrush.

Size

The size, or radius, of the frame background is determined by the Radius and BackgroundRadiusRatio properties. This allows more or less of the frame background to cover the frame rim as needed.

Two CircularGauge controls with a background radius ratio of 80% (left) and 60% (right)

Custom Geometry/ImageSource

When the built-in background types are not flexible enough to achieve the look desired, a custom Geometry or ImageSource can be used.

When BackgroundType is set to to CustomBackgroundGeometry, then the Geometry specified by BackgroundGeometry is used when rendering the background.

Note Note
Custom geometries will be automatically centered and scaled to fit inside the gauge control.

When BackgroundType is set to to CustomBackgroundImage, then the ImageSource specified by BackgroundImageSource is used when rendering the rim.

Glass Effect

A glass effect can be overlayed on the gauge, and any elements inside the gauge, by setting the GlassType property.

A CircularGauge with a circular glass effect

Note Note

The glass effect has a z-index of 100, therefore elements can be placed on top of the glass effect by setting their z-index to a value greater than 100.

For more information on setting the z-index of elements, see the Coordinate System topic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Scales

CircularScale is used to control the overall layout of tick marks, tick labels, pointers, and ranges, as well render an optional scale bar.

A CircularGauge with two scales, one shown in green and the other in yellow

This topic contains these sections:

  • Scale Bar
  • Range of Motion

Scale Bar

The scale bar is rendered by the CircularScale element as a continuous band spanning the entire sweep angle. The scale bar is also used as a basis for the placement of child elements, such as the tick marks.

The radius of the scale bar is controlled by the Radius property, which can be specified as a percentage of the frame radius or using an fixed value. This allows the scale bar, and therefore all the child elements, to be moved in and out as needed. In the image above, the green scale has a larger radius than the yellow scale bar. This allows for several scales to be defined and positioned as desired.

In addition, the size (or thickness) of the scale bar can be altered using the BarExtent property. The scale bar can also be hidden completely by setting IsBarVisible to false.

Range of Motion

The range of motion for all the child elements of a scale can be specified using the StartAngle and SweepAngle properties.

The start angle determines the angle of origin of the scale, which will typically specify the location of the minimum value. Following WPF standards, 0° points due east and positive angles result in a clockwise rotation.

Note Note
It is possible to reverse the direction of the value range (by setting IsReversed to true for any tick-sets specified in the scale), in this case the angle of origin will actually specify the location of the maximum value.

The green scale has a start angle of 100°

The sweep angle determines the overall travel or length of the scale. If the sweep angle is specified as 360°, then range of motion will be a complete circle and the minimum and maximum values will share the same location.

The green scale has a sweep angle of 340°

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tick Sets

CircularTickSet is used to specify the minimum value, maximum value, and intervals used by the tick marks, tick labels, pointers, and ranges.

This topic contains these sections:

  • Value Range
  • Intervals

Value Range

The value range determines the overall range of values supported, as well as their placement along the sweep angle.

Minimum/Maximum

The value range is defined by the Minimum and Maximum properties, much like a ProgressBar control.

A CircularGauge with a value range from -50 to 50

Reversing Range

By default, the values start from the minimum value and move clock-wise to the maximum value. It is possible to reverse this direction by setting the IsReversed property to true.

A CircularGauge with a value range from 50 to -50

Logarithmic Range

A logarithmic value range can be specified by setting IsLogarithmic to true. The logarithmic base can be changed by setting LogarithmicBase, which defaults to 10.

Note Note
When using a logarithmic value range, the minimum value will be coerced to be greater than or equal to zero, and the maximum value will be coerced to be greater than or equal to one.

A CircularGauge with a logarithmic value range from 1 to 100, using a base of 10

Intervals

There are two intervals, major and minor, which are used by the various tick marks and tick labels. The major interval specifies where the major tick marks and tick labels will be rendered. The minor interval specifies where the minor tick marks and tick labels will be rendered.

See the Tick Marks and Labels topic for more information.

Note Note
Minor tick marks and tick labels are not rendered when their associated value also falls on the major interval.

Interval Origin

The interval origin determines the value used as a basis for the intervals. By default, the minimum value is used, which means that the intervals will be added incrementally to the minimum value until the maximum value is reached, or exceeded.

A CircularGauge with a major interval of 13, which uses the minimum value (-50) as the origin

As you can see from the image above, the intervals start counting with the minimum value and work up to the maximum value. The first major tick is placed at -50 (minimum value), then the next major tick is placed at -37 (minimum value + major interval), and so on.

The basis, or origin, of the intervals can be altered by setting the IntervalOrigin property to one of three values: Minimum (default), Zero, or Maximum.

Two CircularGauge controls with a major interval of 13 and an origin of Zero (left) and Maximum (right)

When the interval origin is set to Zero, the intervals will be added incrementally starting from zero until the maximum value (if the maximum value is greater than 0) is reached, or exceeded. Additionally, the intervals will be subtracted incrementally starting from zero until the minimum value (if the minimum value is less than 0) is reached, or exceeded.

Note Note
Any values outside the minimum/maximum range will be discarded, when the range does not contain zero.

When the interval origin is et to Maximum, the intervals will be subtracted incrementally from the maximum value until the minimum value is reached, or exceeded.

Linear Intervals

By default, the intervals will added/subtracted cumulatively (or linearly) to the interval origin. As seen above, if the major interval is 13 and using the minimum value (-50) as the origin, major ticks would be placed at -50, -37, -24, etc.

The major and minor intervals can be set using MajorInterval and MinorInterval, respectively. Both these properties support any positive value.

Logarithmic Intervals

When IsLogarithmic is set to true, logarithmic intervals will also be used. Like linear intervals, the logarithmic interval will added/subtracted to the interval origin until the maximum/minimum value is reached. The value added/subtracted is calculated using exponential calculations, with the major/minor interval as the base.

As an example, assume a tick-set has a minimum value of 1, a maximum value of 100, a major interval of 10, and an interval origin of Zero. The first tick will be placed at 1 (0 + 100), the second tick will be placed at 10 (0 + 101), and the last tick will be placed at 100 (0 + 102). Therefore, the forumla equates to 0 + intervalk for an interval origin of Zero, minimum value + intervalk for an interval origin of Minimum, and maximum value - intervalk for an interval origin of Maximum, where k starts at zero and is incremented by one, until the minimum/maximum value is reached, or exceeded.

The major and minor intervals can be set using MajorInterval and MinorInterval, respectively. Both these properties support any positive value, or can be set to Double.NaN to use the CircularTickSet.LogarithmicBase.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tick Marks and Labels

Tick marks and tick labels can be included and make it easier to visually determine the current value of a pointer.

A CircularGauge with various tick marks and tick labels

This topic contains these sections:

  • Tick Marks
  • Tick Labels
  • Scale Placement

Tick Marks

Tick marks are indicators or shapes rendered at a given interval along a value range. Both the interval and the value range are defined on the associated CircularTickSet element. See the Tick Sets topic for more information.

There are three types of tick marks: Major, Minor, and Custom.

Major Tick Marks

Major tick marks are rendered at the MajorInterval specified on the associated CircularTickSet. By default, major tick marks are larger than minor tick marks.

A CircularGauge with the major tick marks highlighted

Major tick marks can be included by adding an instance of CircularTickMarkMajor to the CircularTickSet.Ticks collection. A single instance of CircularTickMarkMajor is typically used to render all of the major tick marks.

Which tick marks are rendered by an instance of CircularTickMarkMajor can be restricted using the following properties:

Property | Description
EndValue | Specifies the last (or largest) value that should be rendered by the element. Set to Double.NaN to specify that there is no end value.
MaximumTickVisibility | Specifies when the tick mark for the maximum value should be rendered.
MinimumTickVisibility | Specifies when the tick mark for the minimum value should be rendered.
SkipValues | Specifies 0 or more specific values that should not be rendered.
StartValue | Specifies the first (or smallest) value that should be rendered by the element. Set to Double.NaN to specify that there is no start value.

Tip Tip
You can use multiple instances of CircularTickMarkMajor to show tick marks in a specific range using a unique look.

Using the images above as an example, one instance could be set to use a black background (as shown) and have an end value of 50. A second instance could be set to use a red background and have a start value of 60.

Minor Tick Marks

Minor tick marks are rendered at the MinorInterval specified on the associated CircularTickSet. Additionally, minor tick marks are not rendered when they fall on the major interval.

A CircularGauge with the minor tick marks highlighted

Minor tick marks can be included by adding an instance of CircularTickMarkMinor to the CircularTickSet.Ticks collection. A single instance of CircularTickMarkMinor is typically used to render all of the minor tick marks.

Which tick marks are rendered by an instance of CircularTickMarkMinor can be restricted using the following properties:

Property | Description
EndValue | Specifies the last (or largest) value that should be rendered by the element. Set to Double.NaN to specify that there is no end value.
SkipValues | Specifies 0 or more specific values that should not be rendered.
StartValue | Specifies the first (or smallest) value that should be rendered by the element. Set to Double.NaN to specify that there is no start value.

Tip Tip
You can use multiple instances of CircularTickMarkMinor to show tick marks in a specific range using a unique look.

Using the images above as an example, one instance could be set to use a black background (as shown) and have an end value of 55. A second instance could be set to use a red background and have a start value of 65.

Custom Tick Marks

When the major and minor tick marks do not offer enough customization, custom tick marks maybe used. Custom tick marks can be placed at a specifc value (shown at value 54 in the images above) by setting the Value property. Just like the major and minor tick marks, the look of the custom tick marks can be fully customized.

Tick Labels

Tick labels are textual representation of a value rendered at a given interval along a value range. Both the interval and the value range are defined on the associated CircularTickSet element. See the Tick Sets topic for more information.

There are three types of tick labels: Major, Minor, and Custom.

Major Tick Labels

Major tick labels are rendered at the MajorInterval specified on the associated CircularTickSet.

A CircularGauge with the major tick labels highlighted

Major tick labels can be included by adding an instance of CircularTickLabelMajor to the CircularTickSet.Ticks collection. A single instance of CircularTickLabelMajor is typically used to render all of the major tick labels.

Which tick labels are rendered by an instance of CircularTickLabelMajor can be restricted using the following properties:

Property | Description
EndValue | Specifies the last (or largest) value that should be rendered by the element. Set to Double.NaN to specify that there is no end value.
MaximumTickVisibility | Specifies when the tick label for the maximum value should be rendered.
MinimumTickVisibility | Specifies when the tick label for the minimum value should be rendered.
SkipValues | Specifies 0 or more specific values that should not be rendered.
StartValue | Specifies the first (or smallest) value that should be rendered by the element. Set to Double.NaN to specify that there is no start value.

Tip Tip
You can use multiple instances of CircularTickLabelMajor to show tick labels in a specific range using a unique look.

Using the images above as an example, one instance could be set to use a black foreground (as shown) and have an end value of 50. A second instance could be set to use a red foreground and have a start value of 60.

Minor Tick Labels

Minor tick labels are rendered at the MinorInterval specified on the associated CircularTickSet. Additionally, minor tick labels are not rendered when they fall on the major interval.

A CircularGauge with the minor tick labels highlighted

Minor tick labels can be included by adding an instance of CircularTickLabelMinor to the CircularTickSet.Ticks collection. A single instance of CircularTickLabelMinor is typically used to render all of the minor tick labels.

Which tick labels are rendered by an instance of CircularTickLabelMinor can be restricted using the following properties:

Property | Description
EndValue | Specifies the last (or largest) value that should be rendered by the element. Set to Double.NaN to specify that there is no end value.
SkipValues | Specifies 0 or more specific values that should not be rendered.
StartValue | Specifies the first (or smallest) value that should be rendered by the element. Set to Double.NaN to specify that there is no start value.

Tip Tip
You can use multiple instances of CircularTickLabelMinor to show tick labels in a specific range using a unique look.

Using the images above as an example, one instance could be set to use a black foreground (as shown) and have an end value of 55. A second instance could be set to use a red foreground and have a start value of 65.

Custom Tick Labels

When the major and minor tick labels do not offer enough customization, custom tick labels maybe used. Custom tick labels can be placed at a specifc value (shown at value 54 in the images above) by setting the Value property. Additionally, the text displayed by the custom label can be specified using the Text property. Just like the major and minor tick labels, the look of the custom tick labes can be fully customized.

Rounding and Text Format

By default, the tick labels will round the associated value(s) to the nearest whole number and convert that to a string, which is displayed on the gauge. Both the method of rounding and the text format can be customized using the RoundMode and TextFormat properties, respectively.

The rounding used is specified using the RoundMode enumeration, which offers several rounding methods. See the PixelSnapper topic for more information on the various round modes.

The format is used to convert double values to a string using the String.Format method, which uses the associated value as the only input parameter (e.g. {0}).

Scale Placement

Tick marks and tick labels are positioned relative to the scale bar defined by the associated CircularScale element. By default, the ticks will be overlayed and centered on the scale bar. The placement of the ticks can be altered using the ScalePlacement and ScaleOffset properties.

There are three possible values for the ScalePlacement property:

Value | Description
Inside | Indicates that the tick will be placed inside (or closer to the center) of the scale bar. The outer edge of the tick will be aligned with the inner edge of the scale bar.
Outside | Indicates that the tick will be placed outside (or further from the center) of the scale bar. The inner edge of the tick will be aligned with the outer edge of the scale bar.
Overlay | Indicates that the tick will be centered over (or on top) of the scale bar. The center line of the tick will be aligned with the center line of the scale bar.

In addition to the placement, the ScaleOffset can be used to further customize the location of the ticks.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ranges

Ranges can be used to highlight a value range of interest, and can be included by adding an instance of CircularRange to the CircularTickSet.Ranges collection.

A CircularGauge with two ranges, one shown in green and one in red

This topic contains these sections:

  • Value Range
  • Appearance
  • Scale Placement

Value Range

The area covered by a range is controled using the StartValue and EndValue properties.

A CircularGauge with the green range updated to span from 0 to 40

Appearance

There are several properties that control the appearance of the range.

Colors/Brushes

There are two brushes used by the range: Background and BorderBrush. The BorderBrush property is only used when the BorderWidth property is greater than 0.

Extents

Ranges can be configured to use the same extent for their entire length, or they can be used to produce sweeping arcs. Using the StartExtent and EndExtent properties, you can create a range with a varying thickness.

A CircularGauge with the green start extent updated to 0

Scale Placement

Ranges are positioned relative to the scale bar defined by the associated CircularScale element. By default, ranges will be overlayed and centered on the scale bar. The placement of the range can be altered using the ScalePlacement and ScaleOffset properties.

There are three possible values for the ScalePlacement property:

Value | Description
Inside | Indicates that the range will be placed inside (or closer to the center) of the scale bar. The outer edge of the range will be aligned with the inner edge of the scale bar.
Outside | Indicates that the range will be placed outside (or further from the center) of the scale bar. The inner edge of the range will be aligned with the outer edge of the scale bar.
Overlay | Indicates that the range will be centered over (or on top) of the scale bar. The center line of the range will be aligned with the center line of the scale bar.

In addition to the placement, the ScaleOffset can be used to further customize the location of the range.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Pointers

Pointers can be used to show the current value, or values, represented by a gauge. There are five supported pointer types: bars, caps, label, markers, and needles.

Any number of pointers can be included by adding an instance of CircularPointerBar, CircularPointerCap, CircularPointerLabel, CircularPointerMarker, and/or CircularPointerNeedle to the CircularTickSet.Pointers collection. In addition, each pointer can present a separate and specific value by setting the Value property.

A CircularGauge showing all four pointer types

This topic contains these sections:

  • Bars
  • Caps
  • Labels
  • Markers
  • Needles
  • Pointer Direction
  • Dampening
  • Refresh Rate
  • Snapping
  • Interactive Pointers
  • Scale Placement
  • Value Events

Bars

Bars show a continuous band to the current value, much like ranges. By default, the bars are shown from the minimum value to the current value (as seen in the images). It is possible to "anchor" the bar to zero or the maximum value by setting the BarOrigin property appropriately.

A CircularGauge with the bar highlighted

Colors/Brushes

There are two brushes used by bars: Background and BorderBrush. The BorderBrush property is only used when the BorderWidth property is greater than 0.

Extents

Bars use the PointerExtent property to determine the thickness of the band. The PointerAscent property is not used.

Caps

Caps are a special type of pointer that do not actually "point" to a specific value. Caps are typically used in conjunction with 1 or more needles to provide a cleaner and more realistic look.

A CircularGauge with the cap highlighted

Types

Several cap types are supported and can be configured by setting the CapType property. Each cap type supports a special effect.

Colors/Brushes

There are two brushes used by caps: Background and BorderBrush. The BorderBrush property is only used when the BorderWidth property is greater than 0.

Extents

Caps use the PointerExtent property to determine the radius of the cap. The PointerAscent property is not used.

Labels

Labels are pointers that render text at the specified value.

Text

When Text is non-null, then that sting is used. When null, the text is determined by the DisplayValue, RoundMode, and TextFormat properties.

Font and Foreground

There are several properties for setting the appropriate font and/or foreground.

Markers

Markers are indicators or shapes rendered at the specified value.

A CircularGauge with the marker highlighted

Types

Several marker types are supported and can be configured by setting the MarkerType property.

Colors/Brushes

There are two brushes used by markers: Background and BorderBrush. The BorderBrush property is only used when the BorderWidth property is greater than 0.

Extents/Ascents

Markers use the PointerExtent and PointerAscent properties to determine the overall bounding rectangle of the shape rendered.

Needles

Needles are shapes that point to the specified value and are anchored (or pivot) around a central point.

A CircularGauge with the needle highlighted

Types

Several needle types are supported and can be configured by setting the NeedleType property.

Colors/Brushes

There are two brushes used by needles: Background and BorderBrush. The BorderBrush property is only used when the BorderWidth property is greater than 0.

Extents/Ascents

Needles use the PointerExtent and PointerAscent properties to determine the overall bounding rectangle.

Pointer Direction

When using a sweep angle of 360 degrees, the direction that the pointer rotates can be customized. By default, the pointer always moves between the minimum and maximum values, and does not cross over the minimum/maximum value location.

This behavior can be changed by setting the PointerDirection property. The pointer can be set to only move clockwise or counter-clockwise, or to always take the shortest path to the new value.

Dampening

All four pointer types can be configured to animate value changes, using a dampening feature. The DampeningMaximumDuration determines the amount of time it should take the pointer to travel the entire length of the scale. The pointers will use a relative duration when only traveling a portion of the scale. For example, if the pointer needs to travel half the length of the scale, then it will take half of the DampeningMaximumDuration to animate to the new location.

When making small value changes then the relative duration may be too short, resulting in a pointer that "jumps". To ensure the duration is not too small, the DampeningMinimumDuration can be used to set a minimum duration.

Refresh Rate

When using a CircularGauge to display real-time data, it is possible that the value displayed by the gauge will change to quickly for the user to read the individual values. The PointerBase.RefreshRate property can be used to limit the number of updates displayed to the user.

The refresh rate is specified as the amount of time to wait between updates. Therefore, if the refresh rate is set to 500 milliseconds, then there will be two updates to the display every second. If several hundreds value changes are made during that second, then only two of the values will actually be displayed.

Snapping

The values presented by the various pointers, can be any real value between the minimum and maximum values, including fractions. Pointer values can be "snapped" to a configurable interval, by setting IsSnappingEnabled to true. When snapping is enabled, the pointer value will be coerced so that it is evenly divisible by the snapping interval, which is specified by the SnappingInterval property.

For example, if snapping is enabled with an interval of 1, then the pointer value will be automatically rounded to the nearest whole number.

Tip Tip
Snapping can be used in conjunction with interactive pointers.

Interactive Pointers

Pointer values can be interctively changed, by the end-user, using the mouse when CanDrag is set to true. When enabled, the cursor is changed to Cursors.Hand when the mouse is hovered over the pointer. The cursor can be customized by setting DragCursor.

Tip Tip
By setting IsFocusable to true on a pointer element, the end-user can press the Escape key to cancel a drag operation.

By default, the pointer is not animated when the value is changed using the mouse. This behavior can be altered by setting IsDraggingAnimated to true.

Scale Placement

Bar and marker pointers are positioned relative to the scale bar defined by the associated CircularScale element. By default, these pointers will be overlayed and centered on the scale bar. The placement of these pointers can be altered using the ScalePlacement and ScaleOffset properties.

There are three possible values for the ScalePlacement property:

Value | Description
Inside | Indicates that the bar or marker pointer will be placed inside (or closer to the center) of the scale bar. The outer edge of the bar or marker pointer will be aligned with the inner edge of the scale bar.
Outside | Indicates that the bar or marker pointer will be placed outside (or further from the center) of the scale bar. The inner edge of the bar or marker pointer will be aligned with the outer edge of the scale bar.
Overlay | Indicates that the bar or marker pointer will be centered over (or on top) of the scale bar. The center line of the bar or marker pointer will be aligned with the center line of the scale bar.

In addition to the placement, the ScaleOffset can be used to further customize the location of the bar or marker pointers.

Value Events

The ValueChanging and ValueChanged are raised before and after the pointer's value is changed, respectively. Using the IsValueChangingEventRaised and IsValueChangedEventRaised properties these events can either be enabled or disabled, for performance reasons. By default, the ValueChanging is disabled and the ValueChanged event is enabled.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

DigitalGauge displays a specified value using segemented characters which are custom rendered.

This topic contains these sections:

  • Value
  • Frames
  • Characters
  • Refresh Rate
  • Text Scrolling
  • Led State

Value

The text displayed by the DigitalGauge is obtained from a "value" Object. If the value is a String, then the text is display as-is. If the value is a Double, then it is rounded down and then converted into a String. All other objects will be converted to a String using the ToString method.

Frames

DigitalGauge supports the same frame features as LinearGauge, for more information see the LinearGauge Features\Frames.

Characters

The characters displayed by DigitalGauge have several options available to customize their look.

See the Characters topic for more information.

Refresh Rate

When using a DigitalGauge to display real-time data, it is possible that the value displayed by the gauge will change to quickly for the user to read the individual values. The RefreshRate property can be used to limit the number of updates displayed to the user.

The refresh rate is specified as the amount of time to wait between updates. Therefore, if the refresh rate is set to 500 milliseconds, then there will be two updates to the display every second. If several hundreds value changes are made during that second, then only two of the values will actually be displayed.

Text Scrolling

The text presented by the DigitalGauge can automatically be scrolled to the left or right. Scrolling is configured using the ScrollState property, which defaults to None.

The ScrollInterval controls the amount of time to wait before shift the characters left or right.

Led State

The led lights rendered by the DigitalGauge support three states: on (default), off, and blinking. This functionality mimics the states supported by the Led control.

See the Led Features\Led Light topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Characters

This topic covers the options available for customizing the characters displayed by a DigitalGauge.

This topic contains these sections:

  • Types
  • Appearance
  • Casing
  • Placement

Types

Five types of character segments are supported: 7-segment (normal), 7-segment (trapezoid), 14-segment (normal), and using 5-by-7 matrix with ellipses or rectangles.

Note Note
Because of the number of segments is limited, certain letters/numbers may be rendered using the same segments.

A DigitalGauge with characters displayed using 7-segments (normal)

A DigitalGauge with characters displayed using 7-segments (trapezoid)

A DigitalGauge with characters displayed using 14-segments (normal)

A DigitalGauge with characters displayed using 5-by-7 matrix (ellipse)

A DigitalGauge with characters displayed using 5-by-7 matrix (rectangle)

Appearance

The DigitalGauge offers several options to customize the look of the characters displayed.

Colors/Brushes

There are two brushes used by characters: Foreground and DimmedBrush. Each brush is used to render the lit and unlit segments, respectively.

Skew Angles

The skew angle properties, SkewAngleX and SkewAngleY, allow for the characters to be skewed along the x-axis and/or y-axis.

Note Note
The SkewAngleX can be used to produce italic characters.

Segment Thickness

The CharacterSegmentThickness property can be used to set a specific thickness for the segments that make up a character. Please note that not all character types support this feature. The CharacterSegmentThickness property defaults to Double.NaN, which means that automatic thickness logic is applied, making the thickness a percentage of the character height.

Casing

The DigitalGauge offers the option to override whether characters are rendered uppercase or lowercase by setting the CharacterCasing property. Because of the limitations inherent to segmented displays, not all characters have uppercase and lowercase versions. In these instances, the character will be rendered in the case available.

Placement

The DigitalGauge offers several options to customize the placement of the characters displayed.

Character Count

The DigitalGauge will only display a certain number of characters, specified by the CharacterCount property. If the string representation of the current value is longer than the character count, then it is truncated.

Character Size

The size of the characters displayed is determined by the CharacterHeight and CharacterWidthRatio properties. By default, the CharacterHeight is set to Double.NaN, which indicates that the height of the characters should be automatically calculated based on the height of the gauge control and the number of characters.

The width of the characters is calculated as a ratio of the CharacterHeight, as specified by the CharacterWidthRatio property.

Character Padding/Spacing

The padding around all the characters can be set using the CharacterPadding property.

The space between characters is controlled by the CharacterSpacing property, which specifies the number of pixels between each character. This space is used when rendering sub-characters, such as period or colon.

Text Alignment

The DigitalGauge can align the text characters to the left or the right (the default) side of the control. The alignment is specified by the TextAlignment property.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The Led control can be broken down into separate areas, which are described below. Additional topics are provided for areas that require more detailed explanations.

This topic contains these sections:

  • Frames
  • Led Light

Frames

Led supports the same frame features as CircularGauge, for more information see the CircularGauge Features\Frames.

Note Note
The Led control defaults the BackgroundType to None, which differs from the CircularGauge.

Led Light

Led supports on, off, or blinking states, and includes several options for customizing the look of the led light.

See the Led Light topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Led Light

Led supports on, off, or blinking states, and includes several options for customizing the look of the led light.

This topic contains these sections:

  • State
  • Appearance
  • Value Converters

State

The led light can be in one of three states (on, off, or blinking), which is set using the LedState property.

Two Led controls with the led light on (left) and off (right)

When blinking, the light will be toggle between on and off at the interval specified by the BlinkInterval.

Appearance

Light Shape

The led light defaults to a circle, but supports several shapes including arrows, triangles, rectangles, etc. The led light type is specified using the LedType property.

Led using an arrow that points down for the led light

When the built-in led types are not flexible enough to achieve the look desired, a custom Geometry can be used.

When LedType is set to to CustomGeometry, then the Geometry specified by LedGeometry is used when rendering the led light.

Light Size

The size of the led light is control by the LedRadiusRatio property, which is defined as a percentage of the Radius.

Note Note
When using led light that is not circular, the associated shape is sized such that it would fit inside a circle with the associated radius computed from LedRadiusRatio and Radius.

Two Led controls with a led radius ratio of 80% (left) and 60% (right)

Brush and Effect

The led background and foreground colors can be customized by setting the LedBackground and LedForeground, respectively. The led effect can be disabled entirely by setting IsLedEffectEnabled to false.

Two Led controls with a red light; the right image has the led effect disabled

Note Note
The led effect is only supported when IsLedEffectEnabled is set to true and LedBackground/LedForeground are set to a SolidColorBrush.

The LedState of the Led determines how the foreground of the light is rendered, but regardless of the state the led light background is rendered using the LedBackground brush. Using the LedState, the led light foreground is rendered on top of the background, using a varying opacity. If the the light is On then LedOnOpacity is used. If the the light is Off then LedOffOpacity is used. If the the light is Blinking then the opacity is animated to and from LedOnOpacity and LedOffOpacity.

By default, the led light includes a thin black border, but this can be customzied by setting the LedBorderBrush and/or LedBorderThickness appropriately.

Value Converters

A value converter, that can be used in data binding, is provided to convert between Boolean and LedState types. See the Advanced Features\Converters topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

To allow for easy customization, most of the functionality found in the LinearGauge control is actually provided through child elements. This topic will briefly describe each aspect of the LinearGauge control starting from the top and working down. Additional topics are provided for areas that require more detailed explanations.

This topic contains these sections:

  • Orientation
  • Extents and Ascents
  • Frames
  • Scales
  • Tick Sets
  • Tick Marks and Labels
  • Ranges
  • Pointers

Orientation

Linear gauges can be oriented horizontally (default) and vertically by setting the Orientation property.

Extents and Ascents

Most of the LinearGauge elements provide one or more properties that control the size of the rendered content. For example, TickMarkExtent and TickMarkAscent control the width/height of the tick marks.

When the linear gauge is oriented horizontally, the extent equates to the width of the element and the ascent equates to the height. When oriented vertically, the extent and ascent change meaning so the extent equates to the height of the element and the ascent equates to the width.

Both extents and ascents can be specified as a percentage of the frame width/height, or as a fixed value. For example, TickMarkExtent="5%" will size the tick mark to be 5% of the frame width/height (depending on orientation), therefore if the frame width/height is changed the tick mark size will change proportionally.

Frames

Several frames are support and are rendered in the background of the control.

See the Frames topic for more information.

Scales

LinearGauge uses LinearScale elements to host the remaining elements described below and is used for overall positioning.

See the Scales topic for more information.

Tick Sets

The LinearScale elements can contain one or more LinearTickSet elements, which specify the minimum value, maximum value, and intervals used by the remaining elements.

See the Tick Sets topic for more information.

Tick Marks and Labels

The LinearTickSet elements can contain one or more LinearTickMarkMajor, LinearTickMarkMinor, LinearTickMarkCustom, LinearTickLabelMajor, LinearTickLabelMinor, and/or LinearTickLabelCustom elements, which render the tick marks/labels along the scale bar.

See the Tick Marks and Labels topic for more information.

Ranges

The LinearTickSet elements can contain one or more LinearRange elements, which are used to highlight a value range of interest.

See the Ranges topic for more information.

Pointers

The LinearTickSet elements can contain one or more LinearPointerBar, LinearPointerLabel, and/or LinearPointerMarker elements, which provide visual feedback of a value.

See the Pointers topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Frames

The LinearGauge frame is made up of a rim and a background. Each of which can be configured independenty to create a customized look.

This topic contains these sections:

  • Frame Rim
  • Frame Background
  • Glass Effect

Frame Rim

The frame rim is rendered at the bottom most layer of the control and supports many styles, each with a special effect. The rim type can be set using the RimType property and the supported rim types can be seen using the sample project provided.

Brush and Effect

The rim color can be customized by setting the RimBrush property. The rim effect varies based on the rim type, but can be disabled entirely by setting IsRimEffectEnabled to false.

Two LinearGauge controls with a dark blue rim; the right image has the rim effect disabled

Note Note
The rim effect is only supported when IsRimEffectEnabled is set to true and RimBrush is set to a SolidColorBrush.

Custom Geometry/ImageSource

When the built-in rim types are not flexible enough to achieve the look desired, a custom Geometry or ImageSource can be used.

When RimType is set to to CustomRimGeometry, then the Geometry specified by RimGeometry is used when rendering the rim.

Note Note
Custom geometries will be automatically centered and scaled to fit inside the gauge control.

When RimType is set to to CustomRimImage, then the ImageSource specified by RimImageSource is used when rendering the rim.

Frame Background

The frame background is rendered on top of the frame rim and supports many styles, each with a special effect. The background type can be set using the BackgroundType property and the supported background types types can be seen using the sample project provided.

Brush and Effect

The background color can be customized by setting the Background property. The background effect varies based on the background type, but can be disabled entirely by setting IsBackgroundEffectEnabled to false.

Two LinearGauge controls with a dark red background; the right image has the background effect disabled

Note Note
The background effect is only supported when IsBackgroundEffectEnabled is set to true and Background is set to a SolidColorBrush.

Size

The size of the frame background is determined by the ActualWidth, ActualHeight, and BackgroundSizeRatio properties. This allows more or less of the frame background to cover the frame rim as needed.

Two LinearGauge controls with a background radius ratio of 80% (left) and 60% (right)

Custom Geometry/ImageSource

When the built-in background types are not flexible enough to achieve the look desired, a custom Geometry or ImageSource can be used.

When BackgroundType is set to to CustomBackgroundGeometry, then the Geometry specified by BackgroundGeometry is used when rendering the background.

Note Note
Custom geometries will be automatically centered and scaled to fit inside the gauge control.

When BackgroundType is set to to CustomBackgroundImage, then the ImageSource specified by BackgroundImageSource is used when rendering the rim.

Glass Effect

A glass effect can be overlayed on the gauge, and any elements inside the gauge, by setting the GlassType property.

A LinearGauge with a glass effect

Note Note

The glass effect has a z-index of 100, therefore elements can be placed on top of the glass effect by setting their z-index to a value greater than 100.

For more information on setting the z-index of elements, see the Coordinate System topic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Scales

LinearScale is used to control the overall layout of tick marks, tick labels, pointers, and ranges, as well render an optional scale bar.

A LinearGauge with one scale with a gray scale bar

This topic contains these sections:

  • Scale Bar
  • Range of Motion

Scale Bar

The scale bar is rendered by the LinearScale element as a continuous band. The scale bar is also used as a basis for the placement of child elements, such as the tick marks.

The extent of the scale bar is controlled by the BarExtent property. Depending on the orientation of the gauge, the extent refers to either the width (oriented horizontally) or the height (oriented vertically) of the bar.

In addition, the ascent of the scale bar can be altered using the BarAscent property. The scale bar can also be hidden completely by setting IsBarVisible to false.

Range of Motion

The range of motion for all the child elements follow the associated scale bar.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tick Sets

LinearTickSet is used to specify the minimum value, maximum value, and intervals used by the tick marks, tick labels, pointers, and ranges.

This topic contains these sections:

  • Value Range
  • Intervals

Value Range

The value range determines the overall range of values supported, as well as their placement along the gauge.

Minimum/Maximum

The value range is defined by the Minimum and Maximum properties, much like a ProgressBar control.

A LinearGauge with a value range from -50 to 50

Reversing Range

By default, the values start from the minimum value and move clock-wise to the maximum value. It is possible to reverse this direction by setting the IsReversed property to true.

A LinearGauge with a value range from 50 to -50

Logarithmic Range

A logarithmic value range can be specified by setting IsLogarithmic to true. The logarithmic base can be changed by setting LogarithmicBase, which defaults to 10.

Note Note
When using a logarithmic value range, the minimum value will be coerced to be greater than or equal to zero, and the maximum value will be coerced to be greater than or equal to one.

A LinearGauge with a logarithmic value range from 1 to 100, using a base of 10

Intervals

There are two intervals, major and minor, which are used by the various tick marks and tick labels. The major interval specifies where the major tick marks and tick labels will be rendered. The minor interval specifies where the minor tick marks and tick labels will be rendered.

See the Tick Marks and Labels topic for more information.

Note Note
Minor tick marks and tick labels are not rendered when their associated value also falls on the major interval.

Interval Origin

The interval origin determines the value used as a basis for the intervals. By default, the minimum value is used, which means that the intervals will be added incrementally to the minimum value until the maximum value is reached, or exceeded.

A LinearGauge with a major interval of 13, which uses the minimum value (-50) as the origin

As you can see from the image above, the intervals start counting with the minimum value and work up to the maximum value. The first major tick is placed at -50 (minimum value), then the next major tick is placed at -37 (minimum value + major interval), and so on.

The basis, or origin, of the intervals can be altered by setting the IntervalOrigin property to one of three values: Minimum (default), Zero, or Maximum.

Two LinearGauge controls with a major interval of 13 and an origin of Zero (left) and Maximum (right)

When the interval origin is set to Zero, the intervals will be added incrementally starting from zero until the maximum value (if the maximum value is greater than 0) is reached, or exceeded. Additionally, the intervals will be subtracted incrementally starting from zero until the minimum value (if the minimum value is less than 0) is reached, or exceeded.

Note Note
Any values outside the minimum/maximum range will be discarded, when the range does not contain zero.

When the interval origin is et to Maximum, the intervals will be subtracted incrementally from the maximum value until the minimum value is reached, or exceeded.

Linear Intervals

By default, the intervals will added/subtracted cumulatively (or linearly) to the interval origin. As seen above, if the major interval is 13 and using the minimum value (-50) as the origin, major ticks would be placed at -50, -37, -24, etc.

The major and minor intervals can be set using MajorInterval and MinorInterval, respectively. Both these properties support any positive value.

Logarithmic Intervals

When IsLogarithmic is set to true, logarithmic intervals will also be used. Like linear intervals, the logarithmic interval will added/subtracted to the interval origin until the maximum/minimum value is reached. The value added/subtracted is calculated using exponential calculations, with the major/minor interval as the base.

As an example, assume a tick-set has a minimum value of 1, a maximum value of 100, a major interval of 10, and an interval origin of Zero. The first tick will be placed at 1 (0 + 100), the second tick will be placed at 10 (0 + 101), and the last tick will be placed at 100 (0 + 102). Therefore, the forumla equates to 0 + intervalk for an interval origin of Zero, minimum value + intervalk for an interval origin of Minimum, and maximum value - intervalk for an interval origin of Maximum, where k starts at zero and is incremented by one, until the minimum/maximum value is reached, or exceeded.

The major and minor intervals can be set using MajorInterval and MinorInterval, respectively. Both these properties support any positive value, or can be set to Double.NaN to use the LinearTickSet.LogarithmicBase.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tick Marks and Labels

Tick marks and tick labels can be included and make it easier to visually determine the current value of a pointer.

A LinearGauge with various tick marks and tick labels

This topic contains these sections:

  • Tick Marks
  • Tick Labels
  • Scale Placement

Tick Marks

Tick marks are indicators or shapes rendered at a given interval along a value range. Both the interval and the value range are defined on the associated LinearTickSet element. See the Tick Sets topic for more information.

There are three types of tick marks: Major, Minor, and Custom.

Major Tick Marks

Major tick marks are rendered at the MajorInterval specified on the associated LinearTickSet. By default, major tick marks are larger than minor tick marks.

A LinearGauge with the major tick marks highlighted

Major tick marks can be included by adding an instance of LinearTickMarkMajor to the LinearTickSet.Ticks collection. A single instance of LinearTickMarkMajor is typically used to render all of the major tick marks.

Which tick marks are rendered by an instance of LinearTickMarkMajor can be restricted using the following properties:

Property | Description
EndValue | Specifies the last (or largest) value that should be rendered by the element. Set to Double.NaN to specify that there is no end value.
MaximumTickVisibility | Specifies when the tick mark for the maximum value should be rendered.
MinimumTickVisibility | Specifies when the tick mark for the minimum value should be rendered.
SkipValues | Specifies 0 or more specific values that should not be rendered.
StartValue | Specifies the first (or smallest) value that should be rendered by the element. Set to Double.NaN to specify that there is no start value.

Tip Tip
You can use multiple instances of LinearTickMarkMajor to show tick marks in a specific range using a unique look.

Using the images above as an example, one instance could be set to use a black background (as shown) and have an end value of 90. A second instance could be set to use a red background and have a start value of 100.

Minor Tick Marks

Minor tick marks are rendered at the MinorInterval specified on the associated LinearTickSet. Additionally, minor tick marks are not rendered when they fall on the major interval.

A LinearGauge with the minor tick marks highlighted

Minor tick marks can be included by adding an instance of LinearTickMarkMinor to the LinearTickSet.Ticks collection. A single instance of LinearTickMarkMinor is typically used to render all of the minor tick marks.

Which tick marks are rendered by an instance of LinearTickMarkMinor can be restricted using the following properties:

Property | Description
EndValue | Specifies the last (or largest) value that should be rendered by the element. Set to Double.NaN to specify that there is no end value.
SkipValues | Specifies 0 or more specific values that should not be rendered.
StartValue | Specifies the first (or smallest) value that should be rendered by the element. Set to Double.NaN to specify that there is no start value.

Tip Tip
You can use multiple instances of LinearTickMarkMinor to show tick marks in a specific range using a unique look.

Using the images above as an example, one instance could be set to use a black background (as shown) and have an end value of 95. A second instance could be set to use a red background and have a start value of 105.

Custom Tick Marks

When the major and minor tick marks do not offer enough customization, custom tick marks maybe used. Custom tick marks can be placed at a specifc value (shown at value 98.6 in the images above) by setting the Value property. Just like the major and minor tick marks, the look of the custom tick marks can be fully customized.

Tick Labels

Tick labels are textual representation of a value rendered at a given interval along a value range. Both the interval and the value range are defined on the associated LinearTickSet element. See the Tick Sets topic for more information.

There are three types of tick labels: Major, Minor, and Custom.

Major Tick Labels

Major tick labels are rendered at the MajorInterval specified on the associated LinearTickSet.

A LinearGauge with the major tick labels highlighted

Major tick labels can be included by adding an instance of LinearTickLabelMajor to the LinearTickSet.Ticks collection. A single instance of LinearTickLabelMajor is typically used to render all of the major tick labels.

Which tick labels are rendered by an instance of LinearTickLabelMajor can be restricted using the following properties:

Property | Description
EndValue | Specifies the last (or largest) value that should be rendered by the element. Set to Double.NaN to specify that there is no end value.
MaximumTickVisibility | Specifies when the tick label for the maximum value should be rendered.
MinimumTickVisibility | Specifies when the tick label for the minimum value should be rendered.
SkipValues | Specifies 0 or more specific values that should not be rendered.
StartValue | Specifies the first (or smallest) value that should be rendered by the element. Set to Double.NaN to specify that there is no start value.

Tip Tip
You can use multiple instances of LinearTickLabelMajor to show tick labels in a specific range using a unique look.

Using the images above as an example, one instance could be set to use a black foreground (as shown) and have an end value of 90. A second instance could be set to use a red foreground and have a start value of 100.

Minor Tick Labels

Minor tick labels are rendered at the MinorInterval specified on the associated LinearTickSet. Additionally, minor tick labels are not rendered when they fall on the major interval.

A LinearGauge with the minor tick labels highlighted

Minor tick labels can be included by adding an instance of LinearTickLabelMinor to the LinearTickSet.Ticks collection. A single instance of LinearTickLabelMinor is typically used to render all of the minor tick labels.

Which tick labels are rendered by an instance of LinearTickLabelMinor can be restricted using the following properties:

Property | Description
EndValue | Specifies the last (or largest) value that should be rendered by the element. Set to Double.NaN to specify that there is no end value.
SkipValues | Specifies 0 or more specific values that should not be rendered.
StartValue | Specifies the first (or smallest) value that should be rendered by the element. Set to Double.NaN to specify that there is no start value.

Tip Tip
You can use multiple instances of LinearTickLabelMinor to show tick labels in a specific range using a unique look.

Using the images above as an example, one instance could be set to use a black foreground (as shown) and have an end value of 95. A second instance could be set to use a red foreground and have a start value of 105.

Custom Tick Labels

When the major and minor tick labels do not offer enough customization, custom tick labels maybe used. Custom tick labels can be placed at a specifc value (shown at value 98.6 in the images above) by setting the Value property. Additionally, the text displayed by the custom label can be specified using the Text property. Just like the major and minor tick labels, the look of the custom tick labes can be fully customized.

Rounding and Text Format

By default, the tick labels will round the associated value(s) to the nearest whole number and convert that to a string, which is displayed on the gauge. Both the method of rounding and the text format can be customized using the RoundMode and TextFormat properties, respectively.

The rounding used is specified using the RoundMode enumeration, which offers several rounding methods. See the PixelSnapper topic for more information on the various round modes.

The format is used to convert double values to a string using the String.Format method, which uses the associated value as the only input parameter (e.g. {0}).

Scale Placement

Tick marks and tick labels are positioned relative to the scale bar defined by the associated LinearScale element. By default, the ticks will be overlayed and centered on the scale bar. The placement of the ticks can be altered using the ScalePlacement and ScaleOffset properties.

There are three possible values for the ScalePlacement property:

Value | Description
Inside | Indicates that the tick will be placed below, when oriented horizontally, or to the left, when oriented vertically, of the scale bar. The outer edge of the tick will be aligned with the inner edge of the scale bar.
Outside | Indicates that the tick will be placed above, when oriented horizontally, or to the right, when oriented vertically, of the scale bar. The inner edge of the tick will be aligned with the outer edge of the scale bar.
Overlay | Indicates that the tick will be centered over (or on top) of the scale bar. The center line of the tick will be aligned with the center line of the scale bar.

In addition to the placement, the ScaleOffset can be used to further customize the location of the ticks.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ranges

Ranges can be used to highlight a value range of interest, and can be included by adding an instance of LinearRange to the LinearTickSet.Ranges collection.

A LinearGauge with two ranges, one shown in green and one in red

This topic contains these sections:

  • Value Range
  • Appearance
  • Scale Placement

Value Range

The area covered by a range is controled using the StartValue and EndValue properties.

A LinearGauge with the green range updated to span from 0 to 40

Appearance

There are several properties that control the appearance of the range.

Colors/Brushes

There are two brushes used by the range: Background and BorderBrush. The BorderBrush property is only used when the BorderWidth property is greater than 0.

Ascents

Ranges can be configured to use the same ascent for their entire length, or they can be used to produce slopes. Using the StartAscent and EndAscent properties, you can create a range with a varying thickness.

A LinearGauge with the green start ascent updated to 0

Scale Placement

Ranges are positioned relative to the scale bar defined by the associated LinearScale element. By default, ranges will be overlayed and centered on the scale bar. The placement of the range can be altered using the ScalePlacement and ScaleOffset properties.

There are three possible values for the ScalePlacement property:

Value | Description
Inside | Indicates that the range will be placed below, when oriented horizontally, or to the left, when oriented vertically, of the scale bar. The outer edge of the range will be aligned with the inner edge of the scale bar.
Outside | Indicates that the range will be placed above, when oriented horizontally, or to the right, when oriented vertically, of the scale bar. The inner edge of the range will be aligned with the outer edge of the scale bar.
Overlay | Indicates that the range will be centered over (or on top) of the scale bar. The center line of the range will be aligned with the center line of the scale bar.

In addition to the placement, the ScaleOffset can be used to further customize the location of the range.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Pointers

Pointers can be used to show the current value, or values, represented by a gauge. There are three supported pointer types: bars, labels, and markers.

Any number of pointers can be included by adding an instance of LinearPointerBar, LinearPointerLabel, and/or LinearPointerMarker to the LinearTickSet.Pointers collection. In addition, each pointer can present a separate and specific value by setting the Value property.

A LinearGauge showing both pointer types

This topic contains these sections:

  • Bars
  • Labels
  • Markers
  • Dampening
  • Refresh Rate
  • Snapping
  • Interactive Pointers
  • Scale Placement
  • Value Events

Bars

Bars show a continuous band to the current value, much like ranges. By default, the bars are shown from the minimum value to the current value (as seen in the images). It is possible to "anchor" the bar to zero or the maximum value by setting the BarOrigin property appropriately.

A LinearGauge with the bar highlighted

Colors/Brushes

There are two brushes used by bars: Background and BorderBrush. The BorderBrush property is only used when the BorderWidth property is greater than 0.

Extents/Ascents

Bars use the PointerExtent property to determine the thickness of the band. The PointerAscent property is used when rendering a blub at the end of the bar. In this case, the ascent determines the radius of the blub.

Labels

Labels are pointers that render text at the specified value.

Text

When Text is non-null, then that sting is used. When null, the text is determined by the DisplayValue, RoundMode, and TextFormat properties.

Font and Foreground

There are several properties for setting the appropriate font and/or foreground.

Markers

Markers are indicators or shapes rendered at the specified value.

A LinearGauge with the three separate markers highlighted

Types

Several marker types are supported and can be configured by setting the MarkerType property.

Colors/Brushes

There are two brushes used by markers: Background and BorderBrush. The BorderBrush property is only used when the BorderWidth property is greater than 0.

Extents/Ascents

Markers use the PointerExtent and PointerAscent properties to determine the overall bounding rectangle of the shape rendered.

Dampening

Both pointer types can be configured to animate value changes, using a dampening feature. The DampeningMaximumDuration determines the amount of time it should take the pointer to travel the entire length of the scale. The pointers will use a relative duration when only traveling a portion of the scale. For example, if the pointer needs to travel half the length of the scale, then it will take half of the DampeningMaximumDuration to animate to the new location.

When making small value changes then the relative duration may be too short, resulting in a pointer that "jumps". To ensure the duration is not too small, the DampeningMinimumDuration can be used to set a minimum duration.

Refresh Rate

When using a LinearGauge to display real-time data, it is possible that the value displayed by the gauge will change to quickly for the user to read the individual values. The PointerBase.RefreshRate property can be used to limit the number of updates displayed to the user.

The refresh rate is specified as the amount of time to wait between updates. Therefore, if the refresh rate is set to 500 milliseconds, then there will be two updates to the display every second. If several hundreds value changes are made during that second, then only two of the values will actually be displayed.

Snapping

The values presented by the various pointers, can be any real value between the minimum and maximum values, including fractions. Pointer values can be "snapped" to a configurable interval, by setting IsSnappingEnabled to true. When snapping is enabled, the pointer value will be coerced so that it is evenly divisible by the snapping interval, which is specified by the SnappingInterval property.

For example, if snapping is enabled with an interval of 1, then the pointer value will be automatically rounded to the nearest whole number.

Tip Tip
Snapping can be used in conjunction with interactive pointers.

Interactive Pointers

Pointer values can be interctively changed, by the end-user, using the mouse when CanDrag is set to true. When enabled, the cursor is changed to Cursors.Hand when the mouse is hovered over the pointer. The cursor can be customized by setting DragCursor.

Tip Tip
By setting IsFocusable to true on a pointer element, the end-user can press the Escape key to cancel a drag operation.

By default, the pointer is not animated when the value is changed using the mouse. This behavior can be altered by setting IsDraggingAnimated to true.

Scale Placement

Bar and marker pointers are positioned relative to the scale bar defined by the associated LinearScale element. By default, these pointers will be overlayed and centered on the scale bar. The placement of these pointers can be altered using the ScalePlacement and ScaleOffset properties.

There are three possible values for the ScalePlacement property:

Value | Description
Inside | Indicates that the bar or marker pointer will be placed below, when oriented horizontally, or to the left, when oriented vertically, of the scale bar. The outer edge of the bar or marker pointer will be aligned with the inner edge of the scale bar.
Outside | Indicates that the bar or marker pointer will be placed above, when oriented horizontally, or to the right, when oriented vertically, of the scale bar. The inner edge of the bar or marker pointer will be aligned with the outer edge of the scale bar.
Overlay | Indicates that the bar or marker pointer will be centered over (or on top) of the scale bar. The center line of the bar or marker pointer will be aligned with the center line of the scale bar.

In addition to the placement, the ScaleOffset can be used to further customize the location of the bar or marker pointers.

Value Events

The ValueChanging and ValueChanged are raised before and after the pointer's value is changed, respectively. Using the IsValueChangingEventRaised and IsValueChangedEventRaised properties these events can either be enabled or disabled, for performance reasons. By default, the ValueChanging is disabled and the ValueChanged event is enabled.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The ToggleSwitch control can be broken down into separate areas, which are described below. Additional topics are provided for areas that require more detailed explanations.

This topic contains these sections:

  • Frames
  • Switch

Frames

ToggleSwitch supports the same frame features as CircularGauge, for more information see the CircularGauge Features\Frames.

Note Note
The ToggleSwitch control defaults the BackgroundType to None, which differs from the CircularGauge.

Switch

ToggleSwitch supports two or three check states, and includes several options for customizing the look of the switch.

See the Switch topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Switch

ToggleSwitch supports two or three check states, and includes several options for customizing the look of the switch.

This topic contains these sections:

  • Checked State
  • Appearance

Checked State

The ToggleSwitch mimics most of the functionality found in the native WPF ToggleButton, such as the IsChecked and IsThreeState properties.

The IsChecked property determines the position of the switch (up for true, down for false, or in the middle for null). By default, only true and false are supported, but if IsThreeState is set to true then null (or indeterminate) is also supported.

Two ToggleSwitch controls with one checked (left) and one unchecked (right)

When animating from one state to another, the SwitchInterval determines how long it takes the switch to travel to the new location.

Appearance

Switch Type

There are two switch types supported (circular and flat), which can be specified using the SwitchType property.

Two ToggleSwitch controls with a flat switch (left) and one with a circular switch (right)

Switch Size

The size of the switch is control by the SwitchRadiusRatio property, which is defined as a percentage of the Radius.

Brush and Effect

The switch can be broken down into two different parts; the base of the switch and then the switch itself. The brushed used for each part can be customized independenty.

The base color can be customized by setting the BaseBackground property. Additionally, the accent color (the octagon) can be customized by setting the BaseAccentBrush property.

ToggleSwitch with the base in red and the base accent in blue

The actual switch is made up of a ball, shaft, and a tip. The colors from these elements can be customized using BallBrush, ShaftBrush, and TipBrush respectively.

Two ToggleSwitch control, one circular and one flat, with a green ball, yellow shaft, and blue tip

The switch includes an effect that can be disabled by setting IsSwitchEffectEnabled to false.

Note Note
The led effect is only supported when IsSwitchEffectEnabled is set to true and the associated brush is set to a SolidColorBrush.
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

There are some advanced features supported by the gauge controls, which are discussed in the section.

Embedding Controls

All three gauge controls can host any UIElement, such as adding a TextBlock element for custom labeling.

See the Embedding Controls topic for more information.

Converters

Gauge comes with a few built-in converters that provide additional features for use with the gauge controls.

See the Converters topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Embedding Controls

Any UIElement can be embedded and precisely placed inside any of the gauge controls.

This topic contains these sections:

  • Adding/Removing UIElements
  • Positioning UIElements

Adding/Removing UIElements

UIElement objects can be added or removed from the gauge controls using the Items collection property.

This code shows how a TextBlock can be added to a DigitalGauge:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<gauge:DigitalGauge Width="300" Height="100" Value="Actipro">
    <gauge:DigitalGauge.Items>
        <TextBlock Text="WPF" Foreground="White" />
    </gauge:DigitalGauge.Items>
</gauge:DigitalGauge>

Positioning UIElements

By default, UIElement objects will be centered in the associated gauge control, but it's position can be specified using the XProperty, YProperty, OriginProperty, and ZIndexProperty attached properties.

Continuing from the example above, this code shows how the TextBlock can be positioned 10-pixels to the right and 10-pixels down from the top-left corner:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<gauge:DigitalGauge Width="300" Height="100" Value="Actipro">
    <gauge:DigitalGauge.Items>
        <TextBlock gauge:DigitalGauge.Origin="TopLeft" gauge:DigitalGauge.X="10" gauge:DigitalGauge.Y="10" Text="WPF" Foreground="White" />
    </gauge:DigitalGauge.Items>
</gauge:DigitalGauge>

See the Coordinate System topic for more information on positioning controls, including setting the z-index.

The gauge controls use the HorizontalAlignment and VerticalAlignment properties of FrameworkElement-derived objects to further control the positioning. The tables below describe the behavior used for the various alignment values.

HorizontalAlignment | Description
Center | Indicates that the center of the FrameworkElement will be aligned with the point specified along the X-axis. This is the default alignment and is always used for non-FrameworkElement-derived objects.
Left | Indicates that the left side of the FrameworkElement will be aligned with the point specified along the X-axis.
Right | Indicates that the right side of the FrameworkElement will be aligned with the point specified along the X-axis.
Stretch | See Center.
VerticalAlignment | Description
Bottom | Indicates that the bottom side of the FrameworkElement will be aligned with the point specified along the Y-axis.
Center | Indicates that the center of the FrameworkElement will be aligned with the point specified along the Y-axis. This is the default alignment and is always used for non-FrameworkElement-derived objects.
Top | Indicates that the top side of the FrameworkElement will be aligned with the point specified along the Y-axis.
Stretch | See Center.
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converters

Actipro Gauge comes with a few built-in converters that provide additional features for use with the gauge controls.

This topic contains these sections:

  • Average Value
  • Maximum Value
  • Minimum Value
  • Boolean to LedState

Average Value

The DoubleAverageConverter class can be used to calculate the average of any number of values. It returns the running average of all the Double values that it has been used to convert. When calculating the running average, the entire set of previous values is not required. Therefore, calculating the running average only requires a few bytes of storage in memory.

DoubleAverageConverter can be configured to only use the last N items, where N is controlled by ValueCount.

This code shows how a DoubleAverageConverter can be declared and used to calculate the average of the last 100 values of the bar pointer:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<Window.Resources>

    <!-- Converters -->
    <gauge:DoubleAverageConverter x:Key="DoubleAverageConverter" ValueCount="100" />

</Window.Resources>

...

<gauge:LinearGauge Width="200" Height="50">
    <gauge:LinearScale>
        <gauge:LinearTickSet>
            <gauge:LinearTickSet.Pointers>
                <gauge:LinearPointerBar x:Name="bar" />
                <gauge:LinearPointerMarker MarkerType="TriangleSharp" ScalePlacement="Inside"
                        Value="{Binding ElementName=bar, Path=Value, Converter={StaticResource DoubleAverageConverter}}" />
            </gauge:LinearTickSet.Pointers>
        </gauge:LinearTickSet>
    </gauge:LinearScale>
</gauge:LinearGauge>

Maximum Value

The DoubleMaximumConverter class can be used to calculate the maximum value of any number of values.

DoubleMaximumConverter can be configured to only use the last N items, where N is controlled by ValueCount.

This code shows how a DoubleMaximumConverter can be declared and used to calculate the maximum value of the last 100 values of the bar pointer:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<Window.Resources>

    <!-- Converters -->
    <gauge:DoubleMaximumConverter x:Key="DoubleMaximumConverter" ValueCount="100" />

</Window.Resources>

...

<gauge:LinearGauge Width="200" Height="50">
    <gauge:LinearScale>
        <gauge:LinearTickSet>
            <gauge:LinearTickSet.Pointers>
                <gauge:LinearPointerBar x:Name="bar" />
                <gauge:LinearPointerMarker MarkerType="TriangleSharp" ScalePlacement="Inside"
                        Value="{Binding ElementName=bar, Path=Value, Converter={StaticResource DoubleMaximumConverter}}" />
            </gauge:LinearTickSet.Pointers>
        </gauge:LinearTickSet>
    </gauge:LinearScale>
</gauge:LinearGauge>

Minimum Value

The DoubleMinimumConverter class can be used to calculate the minimum value of any number of values.

DoubleMinimumConverter can be configured to only use the last N items, where N is controlled by ValueCount.

This code shows how a DoubleMinimumConverter can be declared and used to calculate the minimum value of the last 100 values of the bar pointer:

XAML
Copy
​xmlns:gauge="http://schemas.actiprosoftware.com/winfx/xaml/gauge"
...

<Window.Resources>

    <!-- Converters -->
    <gauge:DoubleMinimumConverter x:Key="DoubleMinimumConverter" ValueCount="100" />

</Window.Resources>

...

<gauge:LinearGauge Width="200" Height="50">
    <gauge:LinearScale>
        <gauge:LinearTickSet>
            <gauge:LinearTickSet.Pointers>
                <gauge:LinearPointerBar x:Name="bar" />
                <gauge:LinearPointerMarker MarkerType="TriangleSharp" ScalePlacement="Inside"
                        Value="{Binding ElementName=bar, Path=Value, Converter={StaticResource DoubleMinimumConverter}}" />
            </gauge:LinearTickSet.Pointers>
        </gauge:LinearTickSet>
    </gauge:LinearScale>
</gauge:LinearGauge>

Boolean to LedState

The BooleanToLedStateConverter class can be used to bind an LedState property to a Boolean property.

BooleanToLedStateConverter contains two properties: TrueState and FalseState, which indicate what LedState enumeration value to return when convert to/from true and false (and null for bool? types), respectively.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Gauge follows WPF best practices for areas such as layout, globalization and accessibility.

Flow Direction

Gauge supports both left-to-right and right-to-left layouts via a simple property switch.

See the Flow Direction topic for more information.

Localization

All user interface text properties have the Localizability attribute applied to them.

See the Localization topic for more information.

UI Automation

This product follows the WPF accessibility model for UI automation.

See the UI Automation topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Flow Direction

Gauge supports both left-to-right and right-to-left layouts via a simple property switch.

By default, Gauge will use the flow direction designated by the system.

What is Flow Direction?

The flow direction of content typically corresponds to the innate flow direction of the language being represented. English, German, and Russian provide examples of languages that naturally flow from left-to-right. Hebrew and Arabic provide examples of languages that naturally flow from right-to-left.

When a right-to-left flow direction is applied to a user interface control, all contained content is essentially "flipped" over to align to the opposite side as displayed below:

The same CircularGauge with left-to-right (left) and right-to-left (right) flow directions

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Localization

All user interface text properties have the Localizability attribute applied to them.

This topic contains these sections:

  • Localizable Text Properties

Localizable Text Properties

The following text properties are flagged as localizable via the Localizability attribute:

  • CircularTickLabelCustom.Text
  • LinearTickLabelCustom.Text

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UI Automation

Actipro Gauge follows the WPF accessibility model for UI automation.

What is UI Automation?

Microsoft UI Automation is the new accessibility framework for Microsoft Windows. It addresses the needs of assistive technology products and automated test frameworks by providing programmatic access to information about the user interface (UI).

Gauge implements automation peers for the following classes:

  • The GaugeBase class, which is the base class of CircularGauge, DigitalGauge, Led, DigitalGauge, and ToggleSwitch. This automation peer provides access to the child elements.
  • The DigitalGauge class exposes the currently displayed text to the automation framework using internal classes. This is in addition to the functionality provided by the GaugeBase automation peer.
  • The Led class exposes the current state of the led light to the automation framework. This is in addition to the functionality provided by the GaugeBase automation peer.
  • The ToggleSwitch class exposes the current state of the switch to the automation framework. This is in addition to the functionality provided by the GaugeBase automation peer.
  • The PointerBase class, which is the base class of CircularPointerBar, CircularPointerMarker, CircularPointerNeedle, LinearPointerBar, and LinearPointerMarker. This automation peer provides access to the value of the pointer.
    Note Note
    CircularPointerCap does not implement an automation peer, since is it only used for aesthetics.
  • The ScaleBase class, which is the base class of CircularScale and LinearScale. This automation peer provides access to the child elements.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Gauge has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to work with the gauge controls.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • Context Menus
  • Task Pane Introduction
  • CircularGauge Task Pane
  • DigitalGauge Task Pane
  • Led Task Pane
  • LinearGauge Task Pane
  • ToggleSwitch Task Pane
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

Context Menus

Context menus for the CircularGauge, DigitalGauge, LinearGauge, and several of the other gauge element types are provided. You can right click on either of those controls in the designer to display the related context menu.

The context menus for CircularGauge and LinearGauge allow you to quickly add a new scale to the gauge.

Task Pane Introduction

Whenever you select a Gauge control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

CircularGauge Task Pane

The CircularGauge task pane allows you to quickly add a new scale, change the order of the scales, and configure the frame.

The task pane for the CircularGauge control in the Visual Studio designer

DigitalGauge Task Pane

The DigitalGauge task pane allows you to quickly configure the text displayed and the frame.

The task pane for the DigitalGauge control in the Visual Studio designer

Led Task Pane

The Led task pane allows you to quickly configure the frame and led light.

The task pane for the Led control in the Visual Studio designer

LinearGauge Task Pane

The LinearGauge task pane allows you to quickly add a new scale, change the order of the scales, and configure the frame.

The task pane for the LinearGauge control in the Visual Studio designer

ToggleSwitch Task Pane

The ToggleSwitch task pane allows you to quickly configure the frame and switch.

The task pane for the ToggleSwitch control in the Visual Studio designer

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to 2011.2 topic contains information on converting to 2011.2 from an older version.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Grids is a product that includes our PropertyGrid and custom tree structure (TreeListBox and TreeListView) controls.

PropertyGrid allows for all the properties of one or more objects to be displayed, optionally using categories. Pre-defined editors for modifying properties are auto-generated based on property type, and custom property/category editors can be easily created, allowing for total customization of the property editing experience.

TreeListBox is a single-column tree control similar to the Visual Studio Solution Explorer tree control. TreeListView is a multi-column variant of TreeListBox that renders similar to a standard ListView but has additional features.

Features

PropertyGrid Control

  • Displays a grid of all accessible properties for one or more objects, with full UI virtualization support.
  • Based on TreeListView, thereby inheriting all of it and TreeListBox's UI customization features.
  • Numerous built-in property editors are provided, and custom property editors can be created to customize the look and/or feel of a given property.
  • Property editors can be tied to a property by name, Type, or both, which allows for all properties of a specified Type to use the same editor.
  • A model-based data factory architecture allows for complete low-level customization of the property item presented.
  • Explicitly-defined property models can be used in place of, or in addition to, any property models dynamically-generated by a factory.
  • Support for BrowsableAttribute, DisplayNameAttribute, DescriptionAttribute, and several other ComponentModel attributes.
  • Properties can be automatically categorized via usage of CategoryAttribute, and nested categories can be created with a special syntax.
  • Built-in and custom filters can be used to exclude items from being displayed.
  • Properties can be automatically sorted and custom sort comparers can be defined.
  • Options for determining whether categories and properties are expanded by default.
  • Advanced expansion and inline editing (including adding/removing items where appropriate) support for collections, lists and dictionaries.
  • Ability to merge multiple objects, which means only properties common to all objects are presented.
  • Support for custom category editors, which can be used to provide more complex interfaces for presenting/modifying specified properties.
  • Support for expandable properties and lazy loading, which allows for cyclic references and faster load times.
  • Full support and integration with the standard platform data validation infrastructure.
  • Attached properties are supported and can be filtered.
  • Includes fully customizable and resizable summary area, which shows details about the selected property item.
  • Columns can be resized or customized as needed to provide a different appearance, and new columns can even be added.
  • Read-only state can be used to prevent changes to items through the UI.
  • Customizable built-in context menu.
  • Events for property value changes and collection children add/removes.

TreeListBox Control

  • Fully customize the appearance of each node.
  • UI virtualization, allowing for hundreds of thousands of nodes to be loaded into a tree very quickly.
  • No scrollbar jumpiness as seen in other virtualized tree controls when scrolling vertically.
  • Use your own custom data models as the source for the tree, with no dependencies on UI or our interfaces. An adapter class is used (and can be fully customized to fit your model) to communicate between the UI and the model for things like expansion state, getting children, etc.
  • The adapter can be coded with bindings in XAML (convenient, yet can be slow in very large trees) or via method overrides (slightly more work but lightning fast).
  • Optionally show the root item in the control.
  • Fine-grained control over expandability and children query triggers.
  • Optional async loading with busy indicator display.
  • Events for expansion.
  • Events for selection.
  • Single or multi-selection, with Ctrl and Shift-based selection options.
  • Filter selection such as only allowing sibling nodes to be multi-selected, or nodes of the same depth.
  • All common tree hotkeys supported including special ones for expanding and collapsing entire branches.
  • Select or ensure nodes are visible by path.
  • Double-click and Return key default action handling.
  • Optional checkboxes within the data templates.
  • Intelligent text searching so when you start typing while the control has focus, it will auto-focus the item that matches the typed text.
  • Inline editing via F2 and single-click on a selected item.
  • Per-item context menus that can be constructed dynamically via an event.
  • Drag items to external controls, drop data from external controls, or drag/drop items within the control itself.
  • Dragged items can highlight above, on, and below drop areas for each item.
  • Single and multiple item dragging is supported.
  • Optional data virtualization optimization when using virtualized collections.
  • Indentation of top-level and other nodes can be set independently.
  • Customizable item filtering that supports string, boolean, or predicate-based logic.
  • Filtered items can automatically have their ancestors expanded.

TreeListView Control

  • All features found in TreeListBox.
  • Templates, template selectors, or text property bindings used to specify custom content for each cell.
  • Column width can be a specific pixel value, auto (size to header, cells, or both), or star-sized.
  • Optional minimum and maximum widths for column auto/star-sizing modes.
  • Columns can optionally be resized, reordered, and have visibility toggled by the end user.
  • Frozen columns that don't scroll horizontally.
  • Set which column renders the indentation and expander buttons.
  • Column headers have a built-in context menu, and the headers themselves can be hidden.
  • Size columns to fit contents.
  • Optional grid line display.
  • Numerous events for column resizing, reordering, visibility changes, and header menu requests.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

PropertyGrid allows for all the properties of one or more objects to be displayed, optionally using categories. Pre-defined editors for modifying properties are auto-generated based on property type, and custom property/category editors can be easily created, allowing for total customization of the property editing experience.

The PropertyGrid control showing properties for a UI control

The PropertyGrid control's items can be populated simply by binding to a target data object (or data objects), by adding pre-defined property models to a properties collection, or by making a custom data factory.

Several property editors are included, which leverage existing native controls for value display and editing. Custom property or category editors can be used as well, to provide a highly-tailored presentation for your needs.

This topic contains these sections:

  • Features

Features

PropertyGrid Control

  • Displays a grid of all accessible properties for one or more objects, with full UI virtualization support.
  • Based on TreeListView, thereby inheriting all of it and TreeListBox's UI customization features.
  • Numerous built-in property editors are provided, and custom property editors can be created to customize the look and/or feel of a given property.
  • Property editors can be tied to a property by name, Type, or both, which allows for all properties of a specified Type to use the same editor.
  • A model-based data factory architecture allows for complete low-level customization of the property item presented.
  • Explicitly-defined property models can be used in place of, or in addition to, any property models dynamically-generated by a factory.
  • Support for BrowsableAttribute, DisplayNameAttribute, DescriptionAttribute, and several other ComponentModel attributes.
  • Properties can be automatically categorized via usage of CategoryAttribute, and nested categories can be created with a special syntax.
  • Built-in and custom filters can be used to exclude items from being displayed.
  • Properties can be automatically sorted and custom sort comparers can be defined.
  • Options for determining whether categories and properties are expanded by default.
  • Advanced expansion and inline editing (including adding/removing items where appropriate) support for collections, lists and dictionaries.
  • Ability to merge multiple objects, which means only properties common to all objects are presented.
  • Support for custom category editors, which can be used to provide more complex interfaces for presenting/modifying specified properties.
  • Support for expandable properties and lazy loading, which allows for cyclic references and faster load times.
  • Full support and integration with the standard platform data validation infrastructure.
  • Attached properties are supported and can be filtered.
  • Includes fully customizable and resizable summary area, which shows details about the selected property item.
  • Columns can be resized or customized as needed to provide a different appearance, and new columns can even be added.
  • Read-only state can be used to prevent changes to items through the UI.
  • Customizable built-in context menu.
  • Events for property value changes and collection children add/removes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

It's very easy to get up and running with the PropertyGrid control. In fact, setting a single property is often enough to start.

PropertyGrid is extremely customizable and allows you to alter everything from sorting, to filtering, to even the properties that are allowed to display. Be sure to read through this and other documentation topics to learn all about the advanced capabilities property grid supports.

The various Actipro Editors edit box and MaskedTextBox controls can be quickly integrated with a property grid too. These editors help provide enhanced editing features for certain .NET data types. See the Editors/PropertyGrid Interoperability topic for more information.

This topic contains these sections:

  • Displaying Properties of a Data Object
  • Read-Only Display

Displaying Properties of a Data Object

This code shows the base XAML that creates a simple PropertyGrid used to modify the properties of a .NET object, which is the most common usage scenario:

XAML
Copy
​<grids:PropertyGrid DataObject="{Binding YourVMProperty}" />

The PropertyGrid.DataObject property allows for a single data object's properties to be displayed in the control. If multiple data objects need their common properties displayed, bind to the DataObjects property instead.

Note Note
There are other ways to populate property items, such as explictly defining them, all of which are described in the Data Models and Factories topic.

Read-Only Display

While most property grid usage scenarios involve wanting end users to be able to alter property values, the property grid is also great for displaying property values in a read-only fashion.

The PropertyGrid control in read-only mode

Set the PropertyGrid.IsReadOnly property to true to prevent any values from being changed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Models and Factories

There are several ways to populate the PropertyGrid control with items (categories, properties, etc.). This topic covers the various alternatives, along with descriptions of the data models used behind the scenes and how data factories supply the data models.

The resulting data models are passed to property editors and other UI-related layers to create the user interface.

This topic contains these sections:

  • Setting the DataObject or DataObjects Properties
  • Explicitly Defining Properties
  • Data Models
  • Property Data Models
  • Category Data Models
  • Category Editor Data Models
  • Data Factories
  • Custom Data Factories

Setting the DataObject or DataObjects Properties

The property grid can easily present the properties of any .NET object or objects by setting the DataObject or DataObjects properties, respectively. When one of these two properties is set, the current data factory examines the data object(s) and generates a property data model for each of the accessible properties. Data factories are described in detail in a later section of this topic and can be highly customized, which is one of the best parts of the property grid's design.

On the WPF platform, type descriptors are used by the default data factory to enumerate and examine properties.

If categorization is enabled, category data models are also created by the data factory. When category editors are supported, category editor data models can also be generated.

The entire hierarchy of data models (properties, categories, category editors, etc.) is then passed back to the property grid control and is bound to the control as the data source for display. The PropertyGrid control inherits TreeListView, which inherits TreeListBox. Thus the property grid harnesses and expands upon the fast data population and display framework provided by those base classes. And as such, most of the topics in the Tree Control Features area of the documentation can also apply to property grid.

Mutually-Exclusive

The DataObject and DataObjects properties are mutually exclusive and are automatically synchronized by the property grid. Therefore, if DataObject is set then DataObjects is automatically set to an object array containing only one item, the data object. Conversely, if DataObjects is set then DataObject is automatically set to the first item in the object array, if any. This functionality mirrors the Windows Forms PropertyGrid control.

Setting DataObject Example

This code shows the base XAML that creates a simple PropertyGrid used to modify the properties of a single .NET object, which is the most common usage scenario:

XAML
Copy
​<grids:PropertyGrid DataObject="{Binding YourVMProperty}" />

Setting DataObjects Example

This code shows the base XAML that creates a simple PropertyGrid used to modify the properties of multiple .NET objects:

XAML
Copy
​<grids:PropertyGrid DataObjects="{Binding YourVMProperty}" />

When the DataObjects property is used and includes more than one .NET object, the data factory only generates property data models for "common properties". Common properties are properties that have the same name and Type and are present on all the data objects. These common properties are merged into a single property data model and presented as a single item in the property grid control. This allows any number of .NET objects to be presented or modified all at once.

See the Multiple Objects topic for more information.

Explicitly Defining Properties

PropertyGrid has a Properties collection property that accepts one or more IPropertyModel items. The PropertyModel class is generally used in this collection since it lets you set all the IPropertyModel properties yourself.

Any property models in this collection will be appended to any property models that the data factory generates for DataObject/DataObjects. Then all of the properties will be categorized (if appropriate) together and the property grid control will render the user interface for the data models. Explicitly-defined property can be used without bound data objects too.

This code shows the base XAML that you can use to create a simple property grid with two statically-defined properties via the PropertyGrid.Properties collection:

XAML
Copy
​<grids:PropertyGrid>
    <grids:PropertyModel x:Name="property1" ValueType="system:String" DisplayName="Text" Value="A string value" Description="Description for the property." />
    <grids:PropertyModel x:Name="property2" ValueType="system:Boolean" DisplayName="Boolean" Value="True" Description="Description for the property." />
</grids:PropertyGrid>

The property models can be named per the XAML above and their values checked in code. Alternatively, bindings to Value and some other properties are supported since PropertyModel does inherit DependencyObject.

This code shows the implementation of a Binding. Note the use of Source with an x:Reference to another named element instead of use of ElementName. Since the property model isn't in the visual tree, this binding syntax is required.

XAML
Copy
​<grids:PropertyGrid>
    <grids:PropertyModel ValueType="system:String" DisplayName="Text" Value="{Binding Source={x:Reference boundTextBox}, Path=Text, Mode=TwoWay}" />
</grids:PropertyGrid>

Data Models

The PropertyData namespace defines a number of interfaces and classes related to data models generated by the data factory of property grid. There are data models for properties, categories, and category editors. All data models implement the core IDataModel interface and are hierarchy objects, meaning each one can have one or more child data models. This allows for nested categories and properties.

The abstract DataModelBase class implements IDataModel and INotifyPropertyChanged. It is the base class for the more concrete data model implementations.

The core IDataModel interface defines properties related to hierarchy (Parent, Children, and IsRoot), properties related to appearance (DisplayName, Description, IsExpanded, IsSelected, and IsModified), and properties related to sorting (SortComparer, SortImportance, and SortOrder). There also is a Tag property that can hold custom data related to the data model.

The display name is what shows in the property grid's name column. The description is what shows in the property grid's summary area (if displayed) when the related property is selected.

Property Data Models

The IPropertyModel interface inherits IDataModel and is designed to represent a property in a property grid. This interface has a large number of properties related to property display and editing, all of which can be bound to within a property editor.

The abstract PropertyModelBase class implements many of the core features of IPropertyModel. Then another abstract CachedPropertyModelBase class inherits PropertyModelBase and provides caching of results for various properties for optimal performance. PropertyDescriptorPropertyModel inherits that base class and uses property descriptors to retrieve values for many of the IPropertyModel properties.

Another PropertyModel class inherits PropertyModelBase and can be used in scenarios where you want to explicitly configure all of the various properties on the property model instead of using results from something like a property descriptor.

The following sections talk about the various properties declared in IPropertyModel.

Target

The Target property returns the object that owns the property. For instance, if a Foo class instance was set to PropertyGrid.DataObject, and a property model was generated for a Bar property on the Foo class, that property model's Target would return the Foo instance.

The TargetType property returns the Type of the Target instance. In the example above, it would return a Type representing the Foo class.

Value and Type

The Value property gets or sets the actual property value.

Some UI controls like TextBox require that a string representation be used. A ValueAsString property, also a get/set, converts the Value to/from a string that can be bound to. The conversions are done in protected virtual ConvertToString and ConvertFromString methods. These methods can be overridden and customized if additional logic is required for the conversion.

The ValueType property returns the Type of the Value property.

The Values property returns a list of property values in scenarios where there will be more than one if the property model represents a merged property.

Read-Only

The IsHostReadOnly property returns whether the entire host property grid is flagged as read-only via PropertyGrid.IsReadOnly. The IsValueReadOnly property returns whether the property itself is flagged as read-only, such as by not having a setter, or by having a ReadOnlyAttribute applied.

If either of those two values is true, then the IsReadOnly property will return true. This is the property that UI controls in value editing templates will bind to for a read-only state.

That property can also return true if the property model is for a nested property and the parent property model is flagged with IsImmutable.

Standard Values

Standard values can be specified for a property, which are effectively a list of known values from which the end user can choose for the property. The HasStandardValues property returns if the property has any standard values.

If the IsLimitedToStandardValues property returns true, the end user can only choose from standard values when entering a value. Otherwise, freeform entry is allowed and the standard values are presented solely as options.

The StandardValues property returns the actual collection of standard values. As an example, this collection could be bound to a CombBox.ItemsSource. For cases where these must be converted to strings, use the StandardValuesAsStrings property instead.

For scenarios where StandardValues is being used and the IsLimitedToStandardValues property is true, it is assumed that a complex object type is being used for standard value items. The StandardValuesDisplayMemberPath property can be set to the name of the property to dispaly in the data template for each standard value item.

The CycleToNextStandardValue method can be manually called to change the Value to the next standard value.

Name Property Editors and Templates

The actual DataTemplate to use for showing the property display name in a property grid is determined by the NameTemplate, NameTemplateSelector, NameTemplateKey properties, and finally related properties on a property editor, in that order.

If a property editor is used to select the DataTemplate, it will be available in the NamePropertyEditor property.

The DataTemplate-selecting process is described in detail in the Property Editors topic.

Value Property Editors and Templates

The actual DataTemplate to use editing the property value in a property grid is determined by the ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind properties, and finally related properties on a property editor, in that order.

If a property editor is used to select the DataTemplate, it will be available in the ValuePropertyEditor property.

The DataTemplate-selecting process is described in detail in the Property Editors topic.

Resetting

The CanResetValue property determines if the value can be reset to a default value.

If so, a virtual ResetValue method is called. A related ResetValueCommand property can be used with UI controls like menu items to invoke that method.

Merging

When the IsMergeable property returns true, the property can be merged with other similarly named/typed properties. This situation can happen if multiple objects are set to the PropertyGrid.DataObjects property.

Collections

For property models that represent collections, the CanAddChild property returns whether the collection allows child items to be added. This process occurs when the IPropertyModel.AddChild method is called, or the AddChildCommand is used with a UI control to invoke the method.

For property models that represent an item within a collection, the CanRemove property returns whether the collection allows the child item to be removed. This process occurs when the IPropertyModel.Remove method is called, or the RemoveCommand is used with a UI control to invoke the method.

Category Data Models

The ICategoryModel interface inherits IDataModel and is designed to represent a category in a property grid. The interface is implemented by the CategoryModel class.

Category data models are created by the data factory when the PropertyGrid.IsCategorized property is set to true. In this scenario, the IPropertyModel.Category property is examined for each property model and properties with the same category are grouped together as child models of a category model.

Categories and how they work are described in detail in the Categorization and Sorting topic.

Category Editor Data Models

The ICategoryEditorModel interface inherits IDataModel and is designed to represent a category editor in a property grid. The interface is implemented by the CategoryEditorModel class.

Category editors and how they work are described in detail in the Category Editors topic.

Data Factories

Each property grid has a data factory assigned to the PropertyGrid.DataFactory property. A data factory is a class that implements IDataFactory. It is responsible for handling requests for generating data models via its IDataFactory.GetDataModels method. Property grid may request data models whenever a top-level control property changes (e.g. PropertyGrid.IsCategorized, etc.), when expanding nested items, or when a change is detected to certain property models.

DataFactoryBase is the abstract base class that implements IDataFactory and provides all the base logic needed to build a data factory. It handles most of the mundane details of how a data factory should work so that inherited classes can focus more on actual property model creation instead of merging, categorization, sorting, etc.

On the WPF platform, an instance of the TypeDescriptorFactory class is the default data factory applied to PropertyGrid.DataFactory. This class inherits DataFactoryBase and uses type descriptors to return data models.

How DataFactoryBase Works

Whenever a request for data models (generally for PropertyGrid.DataObjects) is made to the data factory, the GetDataModels method is called. This method is passed an IDataFactoryRequest object that contains various parameters describing what is requested. The request object also contains many options that directly come from PropertyGrid control options.

The DataFactoryBase.GetDataModels method first calls into the abstract GetPropertyModels method to get the IPropertyModel objects found for each property of each of the requested data objects to examine. These property models are stored in a data model collection. If multiple data objects are being examined and a merged property needs to be created, the CreateMergedPropertyModel method will be called.

The TypeDescriptorFactory.GetPropertyModels method implementation uses type descriptors to find property descriptors on the data objects. If a property descriptor is for a collection property, the CreateCollectionPropertyModel method is called to create an IPropertyModel. Otherwise, the CreatePropertyModel method is called to create an IPropertyModel.

Next, if the request is made for a root data object, any additional explicitly-defined properties (via PropertyGrid.Properties) will be appended to the data model collection.

If categorization is enabled (via PropertyGrid.IsCategorized), then the CategorizeDataModels method is called. In that method, each of the properties in the data model collection is examined to see which category the property falls into. If no category is specified, a default Misc category is used. The final display name of this Misc category can be set with the PropertyGrid.MiscCategoryName property. ICategoryModel objects are created as appropriate to contain each of the properties in the related category. The CreateCategoryModel method is called to create the ICategoryModel object. In scenarios where category editors should be applied, the CreateCategoryEditorModel method is called to create the ICategoryEditorModel object. These category and category editor models are placed in a new top-level data model collection and they are what is returned by the GetDataModels method. If categorization is not enabled, the original uncategorized property models are what would be returned by the GetDataModels method instead.

Finally, before the results are returned, the data model collection is sorted via a call to the SortDataModels method. By default, the data models are sorted in order of sort importance (a DataModelSortImportance value), sort order (an integer), numeric display name index (if applicable and using format like [0])), and finally display name.

Note Note
All of the DataFactoryBase methods described above are virtual and can be overridden in derived classes to customize or replace default functionality.

Custom Data Factories

Custom data factories can be written to tailor what is displayed by the property grid. Custom factories can populate the property grid using entries in a collection, xml document, or application settings. It is not limited to strictly properties.

A custom factory needs to implement IDataFactory and must be assigned to the PropertyGrid.DataFactory property for it to be used.

While it's generally easiest to inherit TypeDescriptorFactory for your custom factory and to simply override its methods as appropriate, you could inherit the lower-level DataFactoryBase, or even implement IDataFactory completely yourself.

The following sections summarize all of the virtual methods you can override in various data factory implementations that originally described above in the "How DataFactoryBase Works" portion of the documentation.

GetDataModels Method

The IDataFactory.GetDataModels method (implemented by DataFactoryBase.GetDataModels) is the main entry and exit point of a data factory. Thus you can override it to alter request data, reimplement all core logic, or alter the default final data model results for the request.

GetPropertyModels Method

The abstract DataFactoryBase.GetPropertyModels method is implemented by inheriting classes. It is passed a single data object and the IDataFactoryRequest object and expects that a collection of IPropertyModel objects is returned, where each property model represents an accessible property on the data object. Override this method to customize which properties are accessible for the specified data object.

Note Note
This is the most commonly overridden method for a custom data factory.

CreatePropertyModel Method

The TypeDescriptorFactory.CreatePropertyModel method is called by DataFactoryBase.GetPropertyModels to create an IPropertyModel for a normal property. The default return type is PropertyDescriptorPropertyModel.

CreateCollectionPropertyModel Method

The TypeDescriptorFactory.CreateCollectionPropertyModel method is called by DataFactoryBase.GetPropertyModels to create an IPropertyModel for a collection property. The default return type is CollectionPropertyDescriptorPropertyModel.

CreateMergedPropertyModel Method

The DataFactoryBase.CreateMergedPropertyModel method is called by DataFactoryBase.GetDataModels to create an IPropertyModel representing merged properties. The default return type is MergedPropertyModel.

CategorizeDataModels Method

The DataFactoryBase.CategorizeDataModels method is called by DataFactoryBase.GetDataModels to create top-level ICategoryModel objects when categorization is enabled.

CreateCategoryModel Method

The DataFactoryBase.CreateCategoryModel method is called by DataFactoryBase.CategorizeDataModels to create an ICategoryModel object for a certain category. The default return type is CategoryModel.

CreateCategoryEditorModel Method

The DataFactoryBase.CreateCategoryEditorModel method is called by DataFactoryBase.CategorizeDataModels to create an ICategoryEditorModel object for a certain category editor. The default return type is CategoryEditorModel.

SortDataModels Method

The DataFactoryBase.SortDataModels method is called by DataFactoryBase.GetDataModels to sort the data models before they are returned. While other features described in the Categorization and Sorting topic can be used to sort data models, override this method to implement a lower-level sort mechanism.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Supported Property Attributes

The data models and factories are designed to support all the common property attributes found in namespaces like System.ComponentModel and System.ComponentModel.DataAnnotations. These property attributes can help control everything from display name to description to visibility and much more.

This topic contains these sections:

  • System.ComponentModel Attributes
  • System.ComponentModel.DataAnnotations Attributes
  • Browsable Properties

System.ComponentModel Attributes

The System.ComponentModel attributes in the table below are supported. The more commonly-used attributes include usage examples.

Attribute Description
AttributeProviderAttribute

Specifies another Type from which additional attributes should be queried. This is called attribute redirection.

See MSDN (external) for more information on this attribute.

BrowsableAttribute

Indicates whether a property should be displayed. This attribute is compared to the PropertyGrid.BrowsableAttributes, which defaults to a [Browsable(true)] entry.

This code shows an example of applying BrowsableAttribute to hide the Bar property:

C#
VB
Copy
​public class Foo {
    [Browsable(false)]
    public int Bar { get; set; }
}
​Public Class Foo
    <Browsable(False)>
    Public Property Bar() As Integer
End Class

See MSDN (external) for more information on this attribute.

CategoryAttribute

Specifies the name of the category in which to group the property.

When PropertyGrid.IsCategorized is set to false this attribute is ignored, as the properties are not categorized. Properties that do not have an explicitly defined category name will be placed in a miscellaneous category, whose display name can be customized by changing the PropertyGrid.MiscCategoryName property.

This code shows an example of applying CategoryAttribute to set the property's category:

C#
VB
Copy
​public class Foo {
    [Category("Common")]
    public int Bar { get; set; }
}
​Public Class Foo
    <Category("Common")>
    Public Property Bar() As Integer
End Class

See MSDN (external) for more information on this attribute.

DefaultValueAttribute

Specifies the default value for a property.

The default value can be used when determine if a property has been modified, or when resetting a property. The value specified by this attribute takes precedence over the "Reset"/"ShouldSerialize" methods, if any.

This code shows an example of applying DefaultValueAttribute to set the property's default value:

C#
VB
Copy
​public class Foo {
    [DefaultValue(5)]
    public int Bar { get; set; }
}
​Public Class Foo
    <DefaultValue(5)>
    Public Property Bar() As Integer
End Class

See MSDN (external) for more information on this attribute.

DescriptionAttribute

Specifies a description for a property.

The description is displayed in the summary area of a property grid.

This code shows an example of applying DescriptionAttribute to set the property's description:

C#
VB
Copy
​public class Foo {
    [Description("A description about Bar.")]
    public int Bar { get; set; }
}
​Public Class Foo
    <Description("A description about Bar.")>
    Public Property Bar() As Integer
End Class

See MSDN (external) for more information on this attribute.

DisplayNameAttribute

Specifies the display name for a property.

The display name typically a user friendly version of the property name (e.g. "Display Name" versus "DisplayName"). This string is displayed in the name column and summary area of a property grid. If not specified, then the property name is used.

This code shows an example of applying DisplayNameAttribute to set the property's display name:

C#
VB
Copy
​public class Foo {
    [DisplayName("Bar Property")]
    public int Bar { get; set; }
}
​Public Class Foo
    <DisplayName("Bar Property")>
    Public Property Bar() As Integer
End Class

See MSDN (external) for more information on this attribute.

EditorAttribute

Specifies the editor to use to change a property.

In the context of property grid, this attribute can be used to specify the property editor used for selecting a name cell or value editor cell DataTemplate. This property editor would override any other default property editor that normally would have been used.

This code shows an example of applying EditorAttribute to set the property's editor to use a DatePropertyEditor instead of a default DateTimePropertyEditor when Editors interop is being used:

C#
VB
Copy
​public class Foo {
    [Editor(typeof(DatePropertyEditor), typeof(PropertyEditor))]
    public DateTime Bar { get; set; }
}
​Public Class Foo
    <Editor(GetType(DatePropertyEditor), GetType(PropertyEditor))>
    Public Property Bar() As DateTime
End Class

See the Property Editors for more information on how to use this attribute.

See MSDN (external) for more information on this attribute.

ImmutableObjectAttribute

Specifies that an object is immutable and has no child properties capable of being edited. Child properties of immutable objects cannot be modified.

See MSDN (external) for more information on this attribute.

MergablePropertyAttribute

Indicates whether a property can be combined with other properties, when multiple selected objects are being modified at once.

See the Multiple Objects topic for more information on property merging.

See MSDN (external) for more information on this attribute.

NotifyParentPropertyAttribute

Indicates whether the parent property is notified when the value of the property that this attribute is applied to is modified.

See MSDN (external) for more information on this attribute.

ParenthesizePropertyNameAttribute

Indicates whether the name of a property is displayed within parentheses (e.g. "(Name)" versus "Name").

This attribute is typically used to sort more important properties to the top, when sorting alphabetically. However other sorting features can alter sort order. In addition, the parentheses make the property stand out slightly.

See MSDN (external) for more information on this attribute.

ReadOnlyAttribute

Indicates whether a property is read-only or read/write.

Properties that do not have a set accessor are automatically considered read-only. If a set accessor is available, then this attribute can be used to force the property to be displayed as read-only.

This code shows an example of applying ReadOnlyAttribute to force the property to be read-only when in a property grid:

C#
VB
Copy
​public class Foo {
    [ReadOnly(true)]
    public DateTime Bar { get; set; }
}
​Public Class Foo
    <ReadOnly(True)>
    Public Property Bar() As DateTime
End Class

See MSDN (external) for more information on this attribute.

TypeConverterAttribute

Specifies a TypeConverter class that should be used to convert values for a property.

TypeConverter-derived classes offer alot of functionality in allowing various types of input. For example, the EnumConverter class allows a property, whose type is an enum, to be set to the string representation of one of the enum values. Without EnumConverter, only actual enum values could be assigned to the property.

A custom TypeConverter can be used to validate or coerce input as needed.

See MSDN (external) for more information on this attribute.

TypeDescriptionProviderAttribute

Specifies the custom TypeDescriptionProvider for a class.

This is currently only supported by the TypeDescriptorFactory.

See MSDN (external) for more information on this attribute.

System.ComponentModel.DataAnnotations Attributes

The System.ComponentModel.DataAnnotations.dll assembly has other attributes that can be used by property data and factories.

The System.ComponentModel.DataAnnotations attributes in the table below are supported. The more commonly-used attributes include usage examples.

Attribute Description
DisplayAttribute

Provides a general-purpose attribute that lets you specify sort order and localizable strings for category, display name, description.

This attribute can be used in place of CategoryAttribute, DisplayNameAttribute, and DescriptionAttribute. It is nicer since only one attribute needs to be used for all these data annoatations and the values returned are localizable with string resources.

This code shows an example of applying DisplayAttribute to set sort order (via Order), category (via GroupName), display name (via ShortName), and description (via Description) for a property:

C#
VB
Copy
​public class Foo {
    [Display(Order = 4, GroupName = "Common", ShortName = "Bar Property", Description = "A description about Bar.")]
    public int Bar { get; set; }
}
​Public Class Foo
    <Display(Order = 4, GroupName = "Common", ShortName = "Bar Property", Description = "A description about Bar.")>
    Public Property Bar() As int
End Class

See MSDN (external) for more information on this attribute.

EditableAttribute

Indicates whether a property is editable.

This attribute is similar to ReadOnlyAttribute but in opposite terms.

When not specified, the property is editable by default if there is a set accessor available. However if this attribute is supplied with its AllowEdit property set to false, the property will be displayed as read-only.

This code shows an example of applying EditableAttribute to force the property to be read-only when in a property grid:

C#
VB
Copy
​public class Foo {
    [Editable(false)]
    public int Bar { get; set; }
}
​Public Class Foo
    <Editable(False)>
    Public Property Bar() As int
End Class

See MSDN (external) for more information on this attribute.

Browsable Properties

The properties returned by the built-in factories can be filtered based on a set of "browsable attributes". These attributes, which are defined in the BrowsableAttributes property, must be explicitly defined on a property or must be the default value for the given attribute Type. In addition, any settings stored by the attribute must be equal, such as the BrowsableAttribute.Browsable.

The default value of BrowsableAttributes contains only one entry, which is BrowsableAttribute.Yes. This is a statically defined instance of BrowsableAttribute that indicates a property is browsable. If a property does not explicitly define a BrowsableAttribute, then it is assumed to be browsable. Therefore, the default setting BrowsableAttributes filters out properties that have been explicitly marked with BrowsableAttribute.No.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Property Editors

Property editors are configured to tell the property grid how to choose a user interface for displaying/editing each property. For instance, boolean properties show a check box in the value cell by default. But a custom property editor could be used to change this to a toggle switch control instead.

Property editors have the ability to match properties based on object type, property name, and property type. When a match is made, the property editor gives the user interface (via DataTemplate objects) for the property. Both the name and value cells can have a custom DataTemplate applied.

A number of built-in property editors are included with property grid, and these can be extended with any number of custom property editors. The Actipro Editors can even be easily integrated with property grid through the use of property editors, providing advanced editing features for common .NET types like numbers, dates, enums, colors, etc.

This topic contains these sections:

  • Name/Value Cells
  • Mapping UI to Properties
  • Property Editor Selection Process
  • Built-in DataTemplates and Property Editors
  • Integrating with Actipro Editors
  • Creating DataTemplates
  • Specifying a Property Editor in XAML
  • Specifying a Property Editor at the Property Level
  • Starting Property Value Editing
  • Committing Property Value Changes
  • Canceling Property Value Changes
  • Property Dialogs (ExtendedStringPropertyEditor)

Name/Value Cells

DataTemplate objects can be used to customize the display of the name and/or value cells for one or more properties. Typically, only the value cell is customized, but this is not a requirement. Cell customization is accomplished by assigning a DataTemplate to a property-related cell through property models or the use of PropertyEditor objects.

Property editors can be defined in several locations, which are discussed in detail below.

Mapping UI to Properties

Whenever the PropertyGrid control goes to generate a name or value cell for a property, it uses its NameTemplateSelector and ValueTemplateSelector objects respectively. The NameTemplateSelector property is pre-assigned with a PropertyGridNameTemplateSelector instance that has logic for matching property editors to a property and selecting a DataTemplate to use in the name cell. Likewise the ValueTemplateSelector property is pre-assigned with a PropertyGridValueTemplateSelector instance that has logic for matching property editors to a property and selecting a DataTemplate to use in the value cell.

Both template selectors use the following general prioritization for selecting a DataTemplate for an IPropertyModel. The steps are followed in order until a valid DataTemplate is found.

  1. IPropertyModel.NameTemplate / ValueTemplate
  2. IPropertyModel.NameTemplateSelector / ValueTemplateSelector
  3. IPropertyModel.NameTemplateKey / ValueTemplateKey - Attempts to locate a DataTemplate resource with the supplied x:Key.
  4. IPropertyModel.ValueTemplateKind (value cells only) - If a kind other than DefaultValueTemplateKind.None, uses a specified built-in template.
  5. Find the best PropertyEditor to use for subsequent logic. If a IPropertyModel.NamePropertyEditor / ValuePropertyEditor is specified, which can be done using EditorAttribute as described below, use it. Otherwise, use property editor matching logic described below to try and locate a property editor.
  6. PropertyEditor.NameTemplate / ValueTemplate
  7. PropertyEditor.NameTemplateSelector / ValueTemplateSelector
  8. PropertyEditor.NameTemplateKey / ValueTemplateKey - Attempts to locate a DataTemplate resource with the supplied x:Key.
  9. PropertyEditor.ValueTemplateKind (value cells only) - If a kind other than DefaultValueTemplateKind.None, uses a specified built-in template.

If none of the above steps supply a DataTemplate for a name cell, the fallback PropertyGrid.DefaultStringNameTemplate object will be used.

If none of the above steps supply a DataTemplate for a value cell, one of the following templates will be selected as fallback:

  • For property models with HasStandardValues and string-based IsLimitedToStandardValues, the PropertyGrid.DefaultLimitedStringValueTemplate object will be used.
  • For property models with HasStandardValues and non-string-based IsLimitedToStandardValues, the PropertyGrid.DefaultLimitedObjectValueTemplate object will be used.
  • For property models with HasStandardValues that aren't limited, the PropertyGrid.DefaultSuggestedStringValueTemplate object will be used.
  • Otherwise the PropertyGrid.DefaultStringValueTemplate object will be used.

Property Editor Selection Process

As mentioned in the template selection process flow above, there are scenarios where an attempt is made to locate the property editor that best matches a property. The IPropertyModel.NamePropertyEditor and The ValuePropertyEditor properties are first examined to see if a property editor is already available. If not, the property editors defined in the PropertyGrid.PropertyEditors and PropertyGrid.DefaultPropertyEditors collections are the ones that are examined next.

The PropertyGrid.PropertyEditors collection contains property editors that should only be used by that particular property grid control instance. The PropertyGrid.DefaultPropertyEditors collection on the other hand is a global collection that is shared by all property grid controls and has a number of pre-defined property editors built-in. This collection is where property editors should be defined that apply to all property grid controls in an application. Any number of custom property editors can be added to either collection.

Each PropertyEditor object has several properties that are used to determine the best match: ObjectType, PropertyName, and PropertyType. Property names must match exactly, while types offer a few more comparison options. In addition to exact matches, types can match if one of their base classes is specified in the property editor, or if it (or one of its base classes) implements a specified interface.

This table defines the precedence of property editor defintions, with the highest priority at the top ('-' indicates the given property is null or undefined):

Source | Object Type | Property Name | Property Type
PropertyEditor defined directly on the property via EditorAttribute
Instance PropertyEditors | Exact Match | Exact Match | Exact Match
Global DefaultPropertyEditors | Exact Match | Exact Match | Exact Match
Instance PropertyEditors | Exact Match | Exact Match | Sub-class Match
Global DefaultPropertyEditors | Exact Match | Exact Match | Sub-class Match
Instance PropertyEditors | Exact Match | Exact Match | Interface Match
Global DefaultPropertyEditors | Exact Match | Exact Match | Interface Match
Instance PropertyEditors | Exact Match | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | Exact Match | Exact Match | Generic Interface Match
Instance PropertyEditors | Sub-class Match | Exact Match | Exact Match
Global DefaultPropertyEditors | Sub-class Match | Exact Match | Exact Match
Instance PropertyEditors | Sub-class Match | Exact Match | Sub-class Match
Global DefaultPropertyEditors | Sub-class Match | Exact Match | Sub-class Match
Instance PropertyEditors | Sub-class Match | Exact Match | Interface Match
Global DefaultPropertyEditors | Sub-class Match | Exact Match | Interface Match
Instance PropertyEditors | Sub-class Match | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | Sub-class Match | Exact Match | Generic Interface Match
Instance PropertyEditors | Interface Match | Exact Match | Exact Match
Global DefaultPropertyEditors | Interface Match | Exact Match | Exact Match
Instance PropertyEditors | Interface Match | Exact Match | Sub-class Match
Global DefaultPropertyEditors | Interface Match | Exact Match | Sub-class Match
Instance PropertyEditors | Interface Match | Exact Match | Interface Match
Global DefaultPropertyEditors | Interface Match | Exact Match | Interface Match
Instance PropertyEditors | Interface Match | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | Interface Match | Exact Match | Generic Interface Match
Instance PropertyEditors | Generic Interface Match | Exact Match | Exact Match
Global DefaultPropertyEditors | Generic Interface Match | Exact Match | Exact Match
Instance PropertyEditors | Generic Interface Match | Exact Match | Sub-class Match
Global DefaultPropertyEditors | Generic Interface Match | Exact Match | Sub-class Match
Instance PropertyEditors | Generic Interface Match | Exact Match | Interface Match
Global DefaultPropertyEditors | Generic Interface Match | Exact Match | Interface Match
Instance PropertyEditors | Generic Interface Match | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | Generic Interface Match | Exact Match | Generic Interface Match
Instance PropertyEditors | - | Exact Match | Exact Match
Global DefaultPropertyEditors | - | Exact Match | Exact Match
Instance PropertyEditors | - | Exact Match | Sub-class Match
Global DefaultPropertyEditors | - | Exact Match | Sub-class Match
Instance PropertyEditors | - | Exact Match | Interface Match
Global DefaultPropertyEditors | - | Exact Match | Interface Match
Instance PropertyEditors | - | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | - | Exact Match | Generic Interface Match
Instance PropertyEditors | - | Exact Match | -
Global DefaultPropertyEditors | - | Exact Match | -
Instance PropertyEditors | - | - | Exact Match
Global DefaultPropertyEditors | - | - | Exact Match
Instance PropertyEditors | - | - | Sub-class Match
Global DefaultPropertyEditors | - | - | Sub-class Match
Instance PropertyEditors | - | - | Interface Match
Global DefaultPropertyEditors | - | - | Interface Match
Instance PropertyEditors | - | - | Generic Interface Match
Global DefaultPropertyEditors | - | - | Generic Interface Match
Instance PropertyEditors | - | - | -
Global DefaultPropertyEditors | - | - | -

Note Note
The search through the PropertyEditors and PropertyGrid.DefaultPropertyEditors collections will take the best match per the table above. If two or more matches are made with the same precedence level, the last one in the collection is chosen. This ensures that any user-defined property editors have a higher priority than built-in ones.

Built-in DataTemplates and Property Editors

The property grid comes with several built-in DataTemplate objects based on native controls and property editors that reference them. Each of the built-in DataTemplate objects is a property on PropertyGrid, such as DefaultStringValueTemplate. This way, it's easy to alter the built-in DataTemplate objects as needed.

The following table lists the built-in DataTemplate object for use in name cells:

Property | Description
DefaultStringNameTemplate | A DataTemplate with a read-only TextBlock that can be used for name column cells. This is used by default for all name cells.

The following table lists the built-in DataTemplate objects and property editors for use in value cells:

Property | Description
DefaultBooleanValueTemplate | A DataTemplate for editing a Boolean value with a two-state CheckBox. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.Boolean is used. The BooleanPropertyEditor class also selects this template.
DefaultBrushValueTemplate | A DataTemplate for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.Brush is used. The BrushPropertyEditor class also selects this template.
DefaultColorValueTemplate | A DataTemplate for editing a Color value with a swatch that renders the value, and a TextBox for editing the value. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.Color is used. The ColorPropertyEditor class also selects this template.
DefaultExtendedStringValueTemplate | A DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.ExtendedString is used. The ExtendedStringPropertyEditor class also selects this template.
DefaultFontFamilyValueTemplate | A DataTemplate for editing a FontFamily value with a ComboBox that contains system font families. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.FontFamily is used. The FontFamilyPropertyEditor class also selects this template.
DefaultFontStretchValueTemplate | A DataTemplate for editing a FontStretch value with a ComboBox that contains font stretch options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.FontStretch is used. The FontStretchPropertyEditor class also selects this template.
DefaultFontStyleValueTemplate | A DataTemplate for editing a FontStyle value with a ComboBox that contains font style options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.FontStyle is used. The FontStylePropertyEditor class also selects this template.
DefaultFontWeightValueTemplate | A DataTemplate for editing a FontWeight value with a ComboBox that contains font weight options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.FontWeight is used. The FontWeightPropertyEditor class also selects this template.
DefaultLimitedObjectValueTemplate | A DataTemplate for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.LimitedObject is used. The LimitedObjectPropertyEditor class also selects this template.
DefaultLimitedStringValueTemplate | A DataTemplate for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.LimitedString is used. The LimitedStringPropertyEditor class also selects this template.
DefaultNullableBooleanValueTemplate | A DataTemplate for editing a nullable Boolean with a three-state CheckBox. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.NullableBoolean is used. The NullableBooleanPropertyEditor class also selects this template.
DefaultStringValueTemplate | A DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.String is used. The StringPropertyEditor class also selects this template.
DefaultSuggestedStringValueTemplate | A DataTemplate for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.SuggestedString is used. The SuggestedStringPropertyEditor class also selects this template.

Integrating with Actipro Editors

The powerful edit box controls in the Actipro Editors product (sold separately from Grids) can be easily integrated with the property grid for handling advanced editing of numeric types, enumerations, and more. Often this functionality is enabled by adding one line of code.

See the Actipro Editors / PropertyGrid Interoperability topic for details.

Creating DataTemplates

The data context passed to each DataTemplate is the IPropertyModel for which the DataTemplate was selected. This means that any UI controls in the value cell template should generally two-way bind to properties like Value or ValueAsString if the UI control requires a string value. Properties like IsReadOnly can also be used to ensure that the UI control is read-only when appropriate.

This code shows the default DataTemplate used in PropertyGrid.DefaultStringValueTemplate:

XAML
Copy
​<shared:NoOpConverter x:Key="NoOpConverter" />
<DataTemplate>
    <TextBox Text="{Binding ValueAsString, Mode=TwoWay, ValidatesOnExceptions=True, ValidatesOnDataErrors=True, NotifyOnValidationError=True, Converter={StaticResource NoOpConverter}}"
        IsReadOnly="{Binding IsReadOnly}"
        Style="{StaticResource {x:Static themes:SharedResourceKeys.EmbeddedTextBoxStyleKey}}"
        />
</DataTemplate>

Note Note
There is an issue when binding the ValueAsString property to a string property, such as the TextBox.Text. When setting ValueAsString, if the underlying object or TypeConverter modifies the value such that the ValueAsString value is updated then the bound control will not update accordingly. The problem arises from an optimization present in the WPF binding system, and can be corrected by using a no-op (no operation) converter, such as NoOpConverter. The use of the converter on the binding statement, regardless of whether it actually converts the value, forces the control to update itself appropriately.

When ValueAsString is used, the Value is converted to a string representation with the virtual PropertyModelBase.ConvertToString method. Likewise, the string value can be converted back to an appropriate object with the virtual ConvertFromString method. The logic of these methods can be overridden in custom property model classes.

Additionally, a TypeConverter can be defined on the value class/struct/enum and can be used to convert the object to and from a string (e.g. for editing in a TextBox). Many .NET primitives have built-in type converters that support string conversion.

This code shows the default DataTemplate used in PropertyGrid.DefaultLimitedObjectValueTemplate:

XAML
Copy
​<shared:NoOpConverter x:Key="NoOpConverter" />
<DataTemplate>
    <ComboBox SelectedItem="{Binding Value, Mode=TwoWay, ValidatesOnExceptions=True, ValidatesOnDataErrors=True, NotifyOnValidationError=True}"
        ItemsSource="{Binding StandardValues}" IsEditable="False" IsReadOnly="{Binding IsReadOnly}"
        Style="{StaticResource {x:Static themes:SharedResourceKeys.EmbeddedComboBoxStyleKey}}"
        />
</DataTemplate>

If a PropertyEditor is used to select the DataTemplate, it will be available in the IPropertyModel.NamePropertyEditor or ValuePropertyEditor properties. Sometimes custom property editors may have additional option properties set on them. As an example, the DataTemplate could bind to a Format property on a custom value property editor with this sort of binding syntax: {Binding ValuePropertyEditor.Format}. Since the IPropertyModel itself is the binding context, the property editor and its options can be accessed in this way.

Specifying a Property Editor in XAML

It's very easy to define custom property editors in XAML, both at instance and global levels.

This example shows how a custom property editor can be applied to a property named "Foo" via the PropertyGrid.PropertyEditors property, but only on the single property grid instance upon which the property editor is defined.

XAML
Copy
​<grids:PropertyGrid DataObject="{Binding}">
    <grids:PropertyGrid.PropertyEditors>
        <grids:PropertyEditor PropertyName="Foo">
            <grids:PropertyEditor.ValueTemplate>
                <DataTemplate>
                    <!-- NOTE: Put your UI here -->
                </DataTemplate>
            </grids:PropertyEditor.ValueTemplate>
        </grids:PropertyEditor>
    </grids:PropertyGrid.PropertyEditors>
</grids:PropertyGrid>

This example shows how a custom property editor can be applied to a property named "Foo" via a PropertyGridPropertyEditorsModifier, which is a mechanism used to alter the global PropertyGrid.DefaultPropertyEditors collection (applies to all property grid instances in the application). The PropertyGridPropertyEditorsModifier.Clear property can be set to true to force the built-in default property editors collection to first clear. Then any property editors added to the modifier are added to the collection.

XAML
Copy
​<grids:PropertyGridPropertyEditorsModifier x:Key="{x:Static grids:PropertyGrid.PropertyEditorsModifierKey}">
    <grids:PropertyEditor PropertyName="Foo">
        <grids:PropertyEditor.ValueTemplate>
            <DataTemplate>
                <!-- NOTE: Put your UI here -->
            </DataTemplate>
        </grids:PropertyEditor.ValueTemplate>
    </grids:PropertyEditor>
</grids:PropertyGridPropertyEditorsModifier>

Note Note
The PropertyGridPropertyEditorsModifier needs to be placed in your app's Application.Resources using the x:Key specified above, or it will not be applied properly.

Specifying a Property Editor at the Property Level

As described above, the IPropertyModel.NamePropertyEditor or ValuePropertyEditor properties can provide a specific PropertyEditor to use for a property model. These properties or even the DataTemplate-related selection properties on IPropertyModel can be set in a data factory or in the case of the PropertyModel, set directly in XAML.

EditorAttribute can be used to designate a PropertyEditor-based type as the property editor for a property.

For instance, if integrating with Actipro Editors and a date-only property editor should be used on a DateTime-based property, you can apply a DatePropertyEditor to the the property like this:

C#
VB
Copy
​[Editor(typeof(DatePropertyEditor), typeof(PropertyEditor))]
public DateTime MyProperty {
    ...
}
​<Editor(GetType(DatePropertyEditor), GetType(PropertyEditor))> _
Public Property MyProperty() As DateTime
    ...
End Property

Since EditorAttribute only allows a Type to be specified, if you wish to have any non-default options set on a property editor or if you are building a custom property editor, you need to make a class that directly or indirectly inherits PropertyEditor and updates/sets those options in its constructor. Then reference that derived type in the EditorAttribute.

Starting Property Value Editing

PropertyGridItem is the "container" UI control for each row in a PropertyGrid. When a PropertyGridItem has keyboard focus, any text input can be forwarded to the first focusable control. The first focusable control is typically located in the associated value cell. This makes it easier to start to input data for a given property.

This behavior is controlled by the static PropertyGrid.StartPropertyValueEditHandlers dictionary. This dictionary maps a Type to a PropertyGridItemActionHandler delegate. Using the type of the first focusable control, the property grid will search for an associated delegate to execute. The search will start with the concrete type, then search up the base class types until a delegate is found or until no more base types are available.

Once a delegate is found, it will be executed. The delegate is responsible for moving the focus and/or passing the text input. The dictionary is initialized with several entries to support TextBox, ToggleButton, and UIElement.

Committing Property Value Changes

When the property grid receives a key down event for the Enter key, it will attempt to find an appropriate action to perform. The action would generally commit any pending changes for controls like TextBox that don't push changes to binding sources immediately. For other control types, such as CheckBox, the value is always immediately committed back, and custom actions aren't needed. After the action is executed, focus is automatically moved back to the parent PropertyGridItem if focus was within a property editor.

This behavior is control by the static PropertyGrid.CommitPropertyValueEditHandlers dictionary. This dictionary maps a Type to a PropertyGridItemActionHandler delegate. Using the type of the focused control, the property grid will search for an associated delegate to execute. The search will start with the concrete type, then search up the base class types until a delegate is found or until no more base types are available.

Once a delegate is found, it will be executed. The delegate is responsible for committing any changes. The dictionary is initialized with a two entries to support TextBox and ComboBox.

This sample code shows the default handler for TextBox, which can be used as a basis for how to handle custom controls:

C#
VB
Copy
​private bool CommitForTextBox(PropertyGridItemActionRequest request) {
    if (request == null)
        return false;

    var control = request.Element as TextBox;
    if ((control == null) || (!control.IsEnabled) || (control.IsReadOnly))
        return false;

    var bindingExpression = control.GetBindingExpression(TextBox.TextProperty);
    if (bindingExpression != null) {
        bindingExpression.UpdateSource();
        return true;
    }

    return false;
}
​Private Function CancelForTextBox(ByVal request As PropertyGridItemActionRequest) As Boolean
    If request Is Nothing Then
        Return False
    End If

    Dim control = TryCast(request.Element, TextBox)
    If (control Is Nothing) OrElse ((Not control.IsEnabled)) OrElse (control.IsReadOnly) Then
        Return False
    End If

    Dim bindingExpression = control.GetBindingExpression(TextBox.TextProperty)
    If bindingExpression IsNot Nothing Then
        bindingExpression.UpdateSource()
        Return True
    End If

    Return False
End Function

This behavior can be disabled by setting KeyboardNavigation.AcceptsReturn to false on the property grid.

Canceling Property Value Changes

When the property grid receives a key down event for the Escape key, it will attempt to find an appropriate action to perform. The action would generally cancel any pending changes. After the action is executed, focus is automatically moved back to the parent PropertyGridItem if focus was within a property editor.

This behavior is control by the static PropertyGrid.CancelPropertyValueEditHandlers dictionary. This dictionary maps a Type to a PropertyGridItemActionHandler delegate. Using the type of the focused control, the property grid will search for an associated delegate to execute. The search will start with the concrete type, then search up the base class types until a delegate is found or until no more base types are available.

Once a delegate is found, it will be executed. The delegate is responsible for cancelling any changes. The dictionary is initialized with a two entries to support TextBox and ComboBox.

This sample code shows the default handler for TextBox, which can be used as a basis for how to handle custom controls:

C#
VB
Copy
​private bool CancelForTextBox(PropertyGridItemActionRequest request) {
    if (request == null)
        return false;

    var control = request.Element as TextBox;
    if ((control == null) || (!control.IsEnabled) || (control.IsReadOnly))
        return false;

    var bindingExpression = control.GetBindingExpression(TextBox.TextProperty);
    if (bindingExpression != null) {
        bindingExpression.UpdateTarget();
        return true;
    }

    return false;
}
​Private Function CancelForTextBox(ByVal request As PropertyGridItemActionRequest) As Boolean
    If request Is Nothing Then
        Return False
    End If

    Dim control = TryCast(request.Element, TextBox)
    If (control Is Nothing) OrElse ((Not control.IsEnabled)) OrElse (control.IsReadOnly) Then
        Return False
    End If

    Dim bindingExpression = control.GetBindingExpression(TextBox.TextProperty)
    If bindingExpression IsNot Nothing Then
        bindingExpression.UpdateTarget()
        Return True
    End If

    Return False
End Function

Property Dialogs (ExtendedStringPropertyEditor)

The ExtendedStringPropertyEditor class activates a value DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button. A common use of this UI is to allow the end user to show a dialog or popup that allows extended input by clicking the ellipses button.

The button's Command property is bound to the ExtendedStringPropertyEditor.ButtonCommand property, which must be set in your code to an ICommand that shows appropriate UI such as a dialog in response. The related IPropertyModel is passed as a parameter to the command.

This sample code uses the ExtendedStringPropertyEditor for a property named Path:

XAML
Copy
​<grids:PropertyGrid x:Name="propGrid" DataObject="{Binding}">
    <grids:PropertyGrid.PropertyEditors>
        <grids:ExtendedStringPropertyEditor x:Name="dialogEditor" PropertyName="Path" />
    </grids:PropertyGrid.PropertyEditors>
</grids:PropertyGrid>

This sample code wires up the command to the property editor:

C#
VB
Copy
​private void InitializeDialogEditorButtonCommand() {
    dialogEditor.ButtonCommand = new DelegateCommand<object>(p => {
        var propertyModel = p as IPropertyModel;
        if (propertyModel != null) {
            // NOTE: Show a dialog or popup here and update propertyModel.Value after
        }
    });
}
​Private Sub InitializeDialogEditorButtonCommand()
    dialogEditor.ButtonCommand = New DelegateCommand(Of Object)(Sub(p)
        Dim propertyModel = TryCast(p, IPropertyModel)
        If propertyModel IsNot Nothing Then
            ' NOTE: Show a dialog or popup here and update propertyModel.Value after
        End If
    End Sub)
End Sub

TextBox and Button Enabled States

The TextBox and ellipses Button will both be disabled by default when IPropertyModel.IsReadOnly is true. This can be a problem in various scenarios though.

A common scenario is where a collection property only has a getter, and thus the property model thinks it's read-only. In this scenario, the TextBox and ellipses Button will be disabled. There is a ExtendedStringPropertyEditor.Behavior property that can be set to a ExtendedStringPropertyEditorBehavior value to better control read-only/enabled states of controls in the template. Set the Behavior property to ButtonEnabled to ensure the button is enabled for collection properties.

This sample code uses the ExtendedStringPropertyEditor for a collection property named Items that only has a getter, allowing the end user to show a dialog for editing the collection:

XAML
Copy
​<grids:PropertyGrid x:Name="propGrid" DataObject="{Binding}">
    <grids:PropertyGrid.PropertyEditors>
        <grids:ExtendedStringPropertyEditor x:Name="collectionEditor" PropertyName="Items" Behavior="ButtonEnabled" />
    </grids:PropertyGrid.PropertyEditors>
</grids:PropertyGrid>

In other scenarios where you have a get/set property and want the ellipses Button to remain enabled but don't want the TextBox editable, set the Behavior property to TextReadOnly.

Note that when IPropertyModel.IsHostReadOnly is true (meaning the PropertyGrid.IsReadOnly property is set), both the TextBox and ellipses Button will both be disabled, even if a behavior described above says otherwise.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Category Editors

Category editors provide a way to consume several properties within a category and provide a custom user interface for them.

A property grid showing a category editor

This topic contains these sections:

  • Defining a Category Editor
  • Example Category Editor

Defining a Category Editor

The CategoryEditor class represents a category editor. Add each CategoryEditor instance that should be active to the PropertyGrid.CategoryEditors collection.

Category editors consist of three main aspects:

  • Standard display properties like Category (the category that the category editor should fall under), DisplayName, and Description.
  • A Properties collection of CategoryEditorProperty objects that are the properties to be consumed.
  • Editor DataTemplate selection properties like EditorTemplate and EditorTemplateKey. The DataTemplate provides the user interface for the collection editor.

The Category property indicates which category the editor should be under.

Note Note
If the category associated with a CategoryEditor is not used, then the category editor will not be used.

Properties to be consumed by a category editor are defined in the Properties collection. Each CategoryEditorProperty object specifies the criteria used to match properties to be consumed, such as ObjectType, PropertyName, and/or PropertyType. When a property is consumed, it is not displayed in the property grid and the category editor is responsible for presenting it.

The data factory creates an ICategoryEditorModel whenever a category editor needs to be displayed. This model has a Children collection property that provides access to each of the consumed IPropertyModel objects. The collection is enumerable and can be indexed by property name as well. The DataTemplate used by a category editor can access any of the aggregated property models and their values through that collection, such as for binding to UI controls. Although there is no requirement that a category editor allow a property to be modified.

Example Category Editor

This code shows how category editor is used to consume all properties in a "Colors" category that have a return type of Color:

XAML
Copy
​<grids:PropertyGrid DataObject="{Binding}">
    <grids:PropertyGrid.CategoryEditors>

        <grids:CategoryEditor Category="Colors" DisplayName="Colors" Description="Edit multiple Color properties using a single category editor.">
            <grids:CategoryEditor.Properties>
                <grids:CategoryEditorProperty PropertyType="Color" />
            </grids:CategoryEditor.Properties>
            <grids:CategoryEditor.EditorTemplate>
                <DataTemplate>
                    <StackPanel>
                        <ListBox x:Name="propertyListBox" BorderThickness="0" ItemsSource="{Binding Children}" SelectedIndex="0" HorizontalContentAlignment="Stretch" IsTabStop="False">
                            <ListBox.ItemTemplate>
                                <DataTemplate>
                                    <Grid Margin="0,-2">
                                        <Grid.ColumnDefinitions>
                                            <ColumnDefinition Width="*" />
                                            <ColumnDefinition Width="Auto" />
                                            <ColumnDefinition Width="*" />
                                        </Grid.ColumnDefinitions>

                                        <TextBlock Text="{Binding Name}" TextTrimming="CharacterEllipsis" VerticalAlignment="Center" />

                                        <Grid Grid.Column="1" Margin="5,3,3,3" Height="14" Width="14" Background="#ffffff" VerticalAlignment="Center">
                                            <Path Margin="1" Fill="#cccccc" Data="M4,0 L8,0 L8,4 L4,4 Z  M0,4 L4,4 L4,8 L0,8 Z  M8,4 L12,4 L12,8 L8,8 Z  M4,8 L8,8 L8,12 L4,12 Z" />

                                            <Border BorderThickness="1" BorderBrush="{DynamicResource {x:Static themes:AssetResourceKeys.BulletBorderDisabledBrushKey}}" SnapsToDevicePixels="True">
                                                <Border.Background>
                                                    <SolidColorBrush Color="{Binding Value}" />
                                                </Border.Background>
                                            </Border>
                                        </Grid>

                                        <TextBlock Grid.Column="2" Text="{Binding ValueAsString}" TextTrimming="CharacterEllipsis" VerticalAlignment="Center" />
                                    </Grid>
                                </DataTemplate>
                            </ListBox.ItemTemplate>
                        </ListBox>

                        <shared:SpectrumColorPicker Margin="6,3" Width="Auto" Height="120" IsInitialColorVisible="False"
                            SelectedColor="{Binding ElementName=propertyListBox, Path=SelectedItem.Value, Mode=TwoWay}" />
                    </StackPanel>
                </DataTemplate>
            </grids:CategoryEditor.EditorTemplate>
        </grids:CategoryEditor>

    </grids:PropertyGrid.CategoryEditors>
</grids:PropertyGrid>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Categorization and Sorting

Properties displayed in the property grid can be categorized into groups and sorted.

This topic contains these sections:

  • Categorization
  • Sorting

Categorization

Overview

The properties presented by the property grid can be grouped together into categories, which is controlled by the IsCategorized property.

In reality, the data factory performs the categorization of the properties based on that option. When enabled, the built-in data factory examines all data object properties for CategoryAttribute (or DisplayAttribute with a GroupName). These values get stored in the IPropertyModel.Category property for the property models that are generated. Then the data factory groups all the property models with the same category together as children of a new ICategoryModel.

Expansion

By default, all categories are automatically expanded. This default can be changed via information detailed in the Expandability topic.

Nested Categories

Properties can also be categorized into nested categories. For example, if a property specifies a category of "One\Two", then by default the property will be in a top-level category titled "One\Two". By setting PropertyGrid.AreNestedCategoriesSupported to true, the PropertyGrid will interpret the category name as a path to the desired category. In the previous example, a top-level category titled "One" will be created, with a nested category titled "Two" (which will contain the property).

If two properties specify the same root category name, then the nested categories & properties will be combined. Continuing the example from above, if another property specifies a category of "One" then it will be contained in the category titled "One" along with the nested category "Two".

Any number of nested categories can be specified, at any level. A category titled "One\Two\Three" would create three categories, with each of the latter two being nested.

The PropertyGrid.MiscCategoryName property also supports the nested category syntax. For example, if set to "One\Two" then any miscellaneous properties will be placed in the category titled "Two", which is nested in the top-level category "One".

Sorting

The items presented by the property grid can be sorted using any custom logic. By default, the items will be sorted by this data in ascending order:

  • IDataModel.SortImportance
  • IDataModel.SortOrder
  • Numeric IDataModel.DisplayName index (i.e. [0], [1], etc.) if applicable
  • IDataModel.DisplayName

Note Note
The DataModelSortImportance enumeration defines several levels of sorting, which allows categories to be sorted before category editors and properties, and category editors before properties. Statically-defined properties (via PropertyGrid.Properties) can easily change their sort importance by setting the IDataModel.SortImportance property.

The default sort comparer is what implements the above logic and can be completely customized. It is specified via the PropertyGrid.SortComparer property. This is initialized by default with an instance of DataModelSortComparer, which is a class implementing IComparer<IDataModel>. The class has boolean properties to optionally disable any of the sorting mechanisms described above and the logic to sort each one is implemented in a separate virtual method that can be overridden with custom logic.

Set the PropertyGrid.SortComparer property to null to prevent default sorting.

The data factory is what locates and applies sorting based on a sort comparer that was found. This occurs in the virtual DataFactoryBase.SortDataModels method.

Every IDataModel that is generated by the data factory has a SortComparer property. If that property is left null, then the property grid default sort comparer is used for child models of the data model. If a sort comparer is specified for a particular data model (such as a category), then that model's direct children will be sorted using the sort comparer.

While any custom sort comparer must inherit DataModelSortComparer, any of its virtual Compare* methods may be overridden with custom logic tailored to your needs.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Collections

The property grid supports inline collection display and even editing in some cases.

This topic contains these sections:

  • Collection Property Display Mode
  • Collection TypeConverter
  • Related Events

Collection Property Display Mode

By default, collections are simply displayed using their associated type converter. Out of the box, only the type converter for arrays (ArrayConverter) allows expansion. The default type converter used for other collection types, such as lists and dictionaries, does not allow expansion. The PropertyGrid.CollectionPropertyDisplayMode property can be used to override this behavior.

A property grid showing several collections using Default

If PropertyGrid.CollectionPropertyDisplayMode is set to Expandable, the type converter for supported collection types will be overridden to allow expansion. In addition, the item count of the collection is used when converting a collection to a string (as seen in the following image).

A property grid showing several collections using Expandable

EditableInline works exactly like Expandable, but adds inline editing buttons for collections that support them.

A property grid showing several collections using EditableInline

Collection TypeConverter

When CollectionDisplayMode property is set to Default (which is the default value), collections with continue to use their default type converters. If this property is changed to Expandable or EditableInline, then the default collection type converters will be overridden/replaced.

When using Expandable or EditableInline, the built-in data factory will check for properties that implement ICollection, IList, IDictionary, and their generic variations. When a collection property is encountered, it is represented using CollectionPropertyDescriptorPropertyModel instead of PropertyDescriptorPropertyModel.

CollectionPropertyDescriptorPropertyModel overrides the type converter of the collection, when it is one of the known default types. These types include:

  • TypeConverter
  • ArrayConverter
  • CollectionConverter
  • ReferenceConverter
If the collection uses one of these type converters, then the CollectionPropertyDescriptorPropertyModel will call its virtual CreateExpandableCollectionConverter method and will use the type converter that is returned. By default, an instance of ExpandableCollectionConverter is returned.

ExpandableCollectionConverter supports expanding any object that implements ICollection, IList, IDictionary, and their generic variations. If more control is required over the generation of the sub-items, a derivation of ExpandableCollectionConverter can be created to customize the behavior/look.

Related Events

There are several PropertyGrid events that are raised before and after a child is added or removed, which are: ChildPropertyAdding, ChildPropertyAdded, ChildPropertyRemoving, and ChildPropertyRemoved.

The PropertyModelChildChangeEventArgs event arguments class used for the ChildPropertyAdding and ChildPropertyAdded events includes references to the parent IPropertyModel (the collection property), the child IPropertyModel (the item if known), and the child value being added. The ChildPropertyAdding event fires before the item is added to the collection and the event args' Cancel property can be set to true to prevent the add. Changing the ChildValue in this event handler will also change the item being added.

The PropertyModelChildChangeEventArgs event arguments class used for the ChildPropertyRemoving and ChildPropertyRemoved events includes references to the parent IPropertyModel (the collection property), the child IPropertyModel (the item if known), and the child value being removed. The ChildPropertyRemoving event fires before the item is removed from the collection and the event args' Cancel property can be set to true to prevent the remove.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Filtering

The property grid includes advanced filtering support, which can be used to narrow down the items that are displayed. Built-in filters can be applied to several properties and can be combined into groups. Filter groups can perform a logical AND or OR operation on the child filters, and several levels of groups can be used for total control. String filters offer several comparison options including regular expressions.

This topic contains these sections:

  • Filter Infrastructure
  • Built-in PropertyModelStringFilter
  • Built-in PropertyModelBooleanFilter
  • Group Filters
  • Predicate or Custom Filters

Filter Infrastructure

The Tree Controls Filtering topic describes the core filtering mechanism used by property grid. Please review that topic first since PropertyGrid indirectly inherits TreeListBox and harnesses the same core filtering mechanism for its own filtering.

Property grid comes with a couple built-in filters that are designed to filter common properties on property models. These are described in the following sections.

Note Note
To activate filtering functionality, set the IsFilterActive property to true. It is false by default. For optimal performance, keep it false unless you have a DataFilter set and you are actively want to filter displayed properties.

Built-in PropertyModelStringFilter

The PropertyModelStringFilter class is an IDataFilter implementation for IPropertyModel string properties. It inherits StringFilterBase and all of the information in the Tree Controls Filtering topic related to "String Filters" applies. There are numerous comparison operators available, and even regular expressions are supported.

The PropertyModelStringFilter class introduces a Source property that accepts a PropertyModelStringFilterSource value and defaults to DisplayName.

That enumeration has these values:

Value | Description
Category | The IPropertyModel.Category property should be used as the source.
Description | The IDataModel.Description property should be used as the source.
DisplayName | The IDataModel.DisplayName property should be used as the source.
Name | The IDataModel.Name property should be used as the source.
ValueType | The IPropertyModel.ValueType property should be used as the source.

This code shows how to only show properties that contain "is" in their display names:

XAML
Copy
​<grids:PropertyGrid ... IsFilterActive="True">
    <grids:PropertyGrid.DataFilter>
        <grids:PropertyModelStringFilter x:Name="stringFilter" Source="DisplayName" Operation="Contains" Value="is" />
    </grids:PropertyGrid.DataFilter>
</grids:PropertyGrid>

Built-in PropertyModelBooleanFilter

The PropertyModelBooleanFilter class is an IDataFilter implementation for IPropertyModel boolean properties. It inherits BooleanFilterBase and all of the information in the Tree Controls Filtering topic related to "Boolean Filters" applies. There are numerous comparison operators available.

The PropertyModelBooleanFilter class introduces a Source property that accepts a PropertyModelBooleanFilterSource value and defaults to IsReadOnly.

That enumeration has these values:

Value | Description
CanResetValue | The IPropertyModel.CanResetValue property should be used as the source.
HasStandardValues | The IPropertyModel.HasStandardValues property should be used as the source.
IsLimitedToStandardValues | The IPropertyModel.IsLimitedToStandardValues property should be used as the source.
IsMergeable | The IPropertyModel.IsMergeable property should be used as the source.
IsModified | The IDataModel.IsModified property should be used as the source.
IsReadOnly | The IPropertyModel.IsReadOnly property should be used as the source.

This code shows how to apply a filter that excludes read-only properties:

XAML
Copy
​<grids:PropertyGrid ... IsFilterActive="True">
    <grids:PropertyGrid.DataFilter>
        <grids:PropertyModelBooleanFilter x:Name="booleanFilter" Source="IsReadOnly" Operation="Equals" Value="False" />
    </grids:PropertyGrid.DataFilter>
</grids:PropertyGrid>

Group Filters

Multiple filters like PropertyModelStringFilter and PropertyModelBooleanFilter can be combined in a group with logical AND or OR operators to return a filter result.

See the Tree Controls Filtering topic for details on using group filters.

This code shows how to only show properties that contain "is" in their display names and aren't read-only:

XAML
Copy
​<grids:PropertyGrid ... IsFilterActive="True">
    <grids:PropertyGrid.DataFilter>
        <shared:DataFilterGroup x:Name="filterGroup">
            <grids:PropertyModelStringFilter x:Name="stringFilter" Source="DisplayName" Operation="Contains" Value="is" />
            <grids:PropertyModelBooleanFilter x:Name="booleanFilter" Source="IsReadOnly" Operation="Equals" Value="False" />
        </shared:DataFilterGroup>
    </grids:PropertyGrid.DataFilter>
</grids:PropertyGrid>

Predicate or Custom Filters

Predicates or completely custom filters can be created as well. See the Tree Controls Filtering topic for details on using predicate or custom filters.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Expandability

Certain complex properties are capable of being expandable in the property grid. Categories will auto-expand by default, while expandable properties will not auto-expand by default. This behavior can be changed in several ways.

This topic contains these sections:

  • Determining Property Expandability
  • Category Auto-Expansion
  • Property Auto-Expansion
  • Selectively Expanding Categories or Properties

Determining Property Expandability

The PropertyExpandability option helps guide if and when a property is deemed expandable. The PropertyExpandability enumeration returned by that property has these values:

Value | Description
Default | Indicates that properties will be expandable if the associated type converter allows sub-properties to be retrieved.
None | Indicates that properties will never be expandable.
ForceSimple | Indicates that properties will be forced to be expandable if a custom type converter has not been specified.
ForceAlways | Indicates that properties will be forced to be expandable even if a custom type converter has been specified. If a custom type converter has been specified, then it will only be overridden if it does not allow the property to be expandable.

Most properties aren't expandable, however they can be expandable if their current value has sub-properties of its own. In that case, the expandability option above governs if a property is expandable.

For the Default case, assigning a TypeConverter that is or inherits ExpandableTypeConverter onto the object type will allow it to be expandable based on the expandability setting.

This code shows how to mark a class as expandable via ExpandableTypeConverter:

C#
VB
Copy
​[TypeConverter(typeof(ExpandableObjectConverter))]
public class Foo {
    ...
}
​<TypeConverter(GetType(ExpandableObjectConverter))>
Public Class Foo
   Private ...
End Class

Category Auto-Expansion

Categories auto-expand by default, revealing the properties within them. The AreCategoriesAutoExpanded property can be set to false to not auto-expand categories.

Property Auto-Expansion

Expandable properties don't auto-expand by default. The ArePropertiesAutoExpanded property can be set to true to auto-expand all expandable properties.

Selectively Expanding Categories or Properties

Data factories generate the data models (categories, properties, etc.) that the property grid consumes when building its user interface. The IDataModel.IsExpanded property determines if a data model is expanded. It defaults to false, but as mentioned above, the AreCategoriesAutoExpanded and ArePropertiesAutoExpanded properties can alter the defaults for categories and properties respectively.

There may be certain scenarios where you wish to only expand certain categories or properties. In these cases, set AreCategoriesAutoExpanded or and ArePropertiesAutoExpanded (whichever is appropriate) to false and then make a custom data factory.

In the WPF platform, the custom data factory should inherit TypeDescriptorFactory. Override the CreatePropertyModel or CreateCollectionPropertyModel methods as appropriate and call their base methods. If the IPropertyModel result is for a property that should be expanded, set its IsExpanded property to true.

Note that you could alternatively add this logic in a more generalized GetDataModels method override. In that case, call the base method and iterate through the IPropertyModel results. Look for properties that should be expanded and set their IsExpanded properties to true.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Multiple Objects

The property grid fully supports editing properties on multiple objects at the same time. When in a multiple object scenario, only the mergeable properties of the same name and Type will be displayed in the property grid.

This topic contains these sections:

  • Setting Multiple Objects
  • Factory Support
  • Displaying Values
  • Updating Values

Setting Multiple Objects

The DataObjects property can be set or bound to any collection that implements IEnumerable.

Note Note
When the DataObjects property is updated, then the DataObject property is automatically set to the first item in the list, or to null if there are no items.

This code shows how to the DataObjects property can be bound to the selected items of a ListBox:

XAML
Copy
​<grids:PropertyGrid DataObjects="{Binding SelectedItems, ElementName=listBox}" />

Factory Support

The built-in data factory has special support for merging the properties of more than one data object. The properties of all the data objects are retrieved, and all the common properties are located. Common properties are those that have same name and Type and that exist on all the data objects. A MergedPropertyModel is created for each merged property, which effectively wraps the related IPropertyModel for each of the data object's properties that were merged together into one.

When information about a merged property is requested, the MergedPropertyModel uses information from the wrapped property models to determine the best possible "merged information". For example, if one wrapped property accessor is read-only, then the merged property is considered read-only.

Tip Tip
The MergablePropertyAttribute can be used on a property to prevent it from being merged. Also, only one property from all the data objects needs to be marked as not mergable.

Displaying Values

Because only a single value can be displayed in the property for single property, the values of multiple properties must be compared. If all the values are equal, then that single value is used. In all other instances, null is used. The get method for the MergedPropertyModel.Value property performs this comparison.

It is possible to get the unique values of all the selected objects using the The get method for the MergedPropertyModel.Values property. A custom property editor could then be developed that presented each unique value, if so desired.

Updating Values

When updating multiple objects, the specified value is set on each object in turn. If any errors occur in the process of updating, then the remaining objects are not updated.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Validation

The property grid supports native data validation features.

This topic contains these sections:

  • Validation Rules
  • Customizing the ErrorTemplate
  • Handling Error Event

Validation Rules

All the built-in property editors use ExceptionValidationRule and DataErrorValidationRule for data validations. Custom validation rules can be used as well, by customizing the Binding statement between the property value and the associated control.

ExceptionValidationRule requires that the data validation be performed in the property setter method and when invalid data is encountered an exception should be thrown. This exception will be caught and handled by the ExceptionValidationRule.

This code shows how the input for a property is validated in the property setter:

C#
VB
Copy
​set {
    if (value == "BadInput")
        throw new ArgumentException("Bad input");
    this.myProperty = value;
}
​Set(ByVal value As String)
    If value = "BadInput" Then
        Throw New ArgumentException("Bad input")
    End If
    _myProperty = value
End Set

DataErrorValidationRule requires that the associated object implement the IDataErrorInfo interface. This allows the object to provide custom data validation without using exceptions.

It is possible to add custom ValidationRule objects to a Binding, which allows the input to be validated before the underlying property is set. To use a custom ValidationRule with the PropertyGrid a new property editor must be defined, whose Binding includes the rule.

This code shows a custom ValidationRule that requires an integer value to be greater than zero:

C#
VB
Copy
​public class PositiveInt32ValidationRule : ValidationRule {
    public override ValidationResult Validate(object value, CultureInfo cultureInfo) {
        int i = Convert.ToInt32(value);
        if (i > 0)
            return new ValidationResult(true, null);
        else
            return new ValidationResult(false, "Value is not positive");
    }
}
​Public Class PositiveInt32ValidationRule
    Inherits ValidationRule
    Public Overrides Function Validate(ByVal value As Object, ByVal cultureInfo As CultureInfo) As ValidationResult
        Dim i As Int32 = Convert.ToInt32(value)
        If i > 0 Then
            Return New ValidationResult(True, Nothing)
        Else
            Return New ValidationResult(False, "Value is not positive")
        End If
    End Function
End Class

This code shows how to use the custom ValidationRule in a DataTemplate which can be used in a property editor:

XAML
Copy
​xmlns:sample="clr-namespace:CustomRuleNamespace"

...

<DataTemplate x:Key="CustomTextBoxValueTemplate">
    <TextBox IsReadOnly="{Binding IsReadOnly}" Style="{StaticResource {x:Static themes:SharedResourceKeys.EmbeddedTextBoxStyleKey}}">
        <TextBox.Text>
            <Binding Path="Value" Mode="TwoWay" NotifyOnValidationError="True">
                <Binding.ValidationRules>
                    <sample:PositiveInt32ValidationRule />
                    <ExceptionValidationRule />
                </Binding.ValidationRules>
            </Binding>
        </TextBox.Text>
    </TextBox>
</DataTemplate>

See the Property Editors topic for more information on using a custom DataTemplate in a property editor.

Customizing the ErrorTemplate

When a validation rule reports that the data input is invalid, a visual indicator is used to indicate that there is a problem. The visual indicator is defined by Validation.ErrorTemplate, which is shown in an adorner layer above the control with the offending data. By default, the control is highlight with a red border, but this can be customized by setting the ErrorTemplate on the control.

A property grid with invalid data highlight using the default ErrorTemplate

The type of the ErrorTemplate property is ControlTemplate, and a special placement element called AdornedElementPlaceholder which is used to to indicate the location of the associated control.

This code shows how to define a custom ErrorTemplate that shows a pulsing red indicator:

XAML
Copy
​<ControlTemplate x:Key="CustomValidationTemplate">
    <Grid>
        <Border IsHitTestVisible="False" Background="Pink" BorderBrush="Red" BorderThickness="1" Opacity="0.1">
            <Border.Triggers>
                <EventTrigger RoutedEvent="Control.Loaded">
                    <BeginStoryboard>
                        <Storyboard RepeatBehavior="Forever">
                            <DoubleAnimation Storyboard.TargetProperty="Opacity" From="0.1" To="0.4"
                                    DecelerationRatio="0.25" AccelerationRatio="0.25" AutoReverse="True"
                                    Duration="0:0:0.75" />
                        </Storyboard>
                    </BeginStoryboard>
                </EventTrigger>
            </Border.Triggers>
        </Border>
        <AdornedElementPlaceholder />
    </Grid>
</ControlTemplate>

A PropertyGrid with invalid data highlight using a custom ErrorTemplate

Tip Tip
There is known issue where the visual indicator is not hidden when the associated control is hidden, which is covered in the Troubleshooting topic.

There are two ways to associate the custom ErrorTemplate with a control in the PropertyGrid. The first requires that a custom property editor DataTemplate be used (as shown above), which would have the Validation.ErrorTemplate set appropriately. The second method uses a custom Style to set the Validation.ErrorTemplate property. This can be done through a property editor or implicit styles.

Handling Error Event

When more control is needed over the handling of invalid input, the Validation.Error event can be used. This event is raised when one or more rules on a Binding object indicate that the data is invalid, including the ExceptionValidationRule. The only requirement is that the NotifyOnValidationError property on the Binding object must be explicitly set to true.

Once the Binding is properly setup, an event handler can be defined on the PropertyGrid. The event handler can then perform any action required, such as displaying an error dialog.

This code shows how to hook up an event handler for the Validation.Error event:

XAML
Copy
​<grids:PropertyGrid Validation.Error="OnPropertyGridValidationError">
    ...
</grids:PropertyGrid>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Columns

The property grid contains two resizable columns by default (a name and a value column), and also supports custom columns.

A custom column that shows a red dot for modified properties

This topic contains these sections:

  • Resizing Support
  • Default Columns and Widths
  • Adding a Custom Column

Resizing Support

By default, the columns in the property grid are resizable within their defined bounds. The CanColumnsResize property can be set to false to prevent resizing.

Default Columns and Widths

The two columns that are generated by default are the name and value columns. The name column's cells show the display names of categories and properties, while the value column's cells provide for the display/editing of property values.

The two columns have certain width settings and restrictions configured by default. These are intended to handle most common scenarios so that the end user never needs to resize the columns.

The name column and value column are set to use star (*) sizing, similar to as in a Grid where each one is equal width. However with the goals of keeping the name column cells readable and maximizing editing space in the value column cells, there are certain minimum and maximum width restrictions on each column.

The name column has a minimum width of 100 and a maximum width of NameColumnMaxWidth, which defaults to 180. This means that the name column will always stay within the range of 100 to 180 pixels wide. This is a good range to keep display name text visible.

The value column has a minimum width of 60 and no maximum width.

If you wish to allow the end user to make the name column larger, you can increase the value of the NameColumnMaxWidth property. You also can examine the Columns collection yourself to locate the appropriate column and manually tweak any of the width values to suit your needs.

Adding a Custom Column

It's very easy to add a custom column. Simply initialize a new TreeListViewColumn object and add it to the Columns collection.

This code shows how to add a custom column that renders a red dot for any modified properties:

C#
VB
Copy
​var column = new TreeListViewColumn();
column.CellBorderThickness = new Thickness(0, 0, 1, 0);
column.CellPadding = new Thickness(3, 0, 3, 0);
column.CellTemplate = this.FindResource("IsModifiedTemplate") as DataTemplate;
column.MinWidth = 16;
column.Width = GridLength.Auto;
propGrid.Columns.Insert(1, column);
​Dim column = New TreeListViewColumn()
column.CellBorderThickness = New Thickness(0, 0, 1, 0)
column.CellPadding = New Thickness(3, 0, 3, 0)
column.CellTemplate = TryCast(Me.FindResource("IsModifiedTemplate"), DataTemplate)
column.MinWidth = 16
column.Width = GridLength.Auto
propGrid.Columns.Insert(1, column)
This code shows the DataTemplate referenced above:
XAML
Copy
​<BooleanToVisibilityConverter x:Key="BooleanToVisibilityConverter" />

<DataTemplate x:Key="IsModifiedTemplate">
    <Ellipse Width="12" Height="12" StrokeThickness="1" Stroke="#ffffff" Fill="#d40404" HorizontalAlignment="Center" VerticalAlignment="Center"
                Visibility="{Binding IsModified, Mode=OneWay, Converter={StaticResource BooleanToVisibilityConverter}}" ToolTip="Modified" />
</DataTemplate>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Summary Area

The summary area is optionally displayed at the bottom of the property grid and displays information about the currently-selected property grid item, which could be a category or property.

A property grid with the summary area visible

This topic contains these sections:

  • Visibility
  • Height and Resizing
  • Customizing the DataTemplate

Visibility

The visibility of the summary area can be controlled using the IsSummaryVisible property. By default, the summary area is visible.

The end user has the ability to toggle the visibility via a "Description" context menu item. This ability can be disabled by setting the IsSummaryToggleAllowed property to false.

Height and Resizing

When the summary area is visible, it can be resized by the end-user with the mouse. This allows the end-user to show more or less of the summary area as desired. Additionally, the height of the summary area can be set programmatically using the SummaryHeight property.

By setting the IsSummaryResizable property to false, the summary will not be resizable by the end-user.

The summary area includes an "auto-size" feature, in which the summary area is dynamically sized to fit it's content. When CanSummaryAutoSize is set to true, the end-user can double click the summary area splitter to enter the auto-size mode. If the end-user resizes the summary area, then the new explict size is used and it is no longer in the auto-size mode. The summary area can be set to auto-size programmatically by setting the SummaryHeight property to Double.NaN (or "Auto" if defining in XAML).

Customizing the DataTemplate

The default DataTemplate used by the summary area includes the display name and description of the currently selected, similar to how the Windows Forms PropertyGrid control displayed information. The template also include support for scrolling content that is too large to be displayed.

A custom DataTemplate can be used by setting the SummaryTemplate or SummaryTemplateSelector properties.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Property Events

The property grid has several property events that get raised in various scenarios.

Note Note
Since PropertyGrid indirectly inherits TreeListBox, all of the events described for that control such as those related to selection, expansion, etc. apply to property grid as well.

This topic contains these sections:

  • Property Change Events
  • Collection Change Events

Property Change Events

The OnPropertyValueChanging and PropertyValueChanged events are raised before and after, respectively, a property's value is updated through the property grid. The event arguments for both events include the PropertyModelValueChangeEventArgs.PropertyModel being changed and the new Value.

To cancel an update to the property value, handle the OnPropertyValueChanging event and set e.Cancel to true. This will prevent the new value from being assigned and will not raise the PropertyValueChanged event.

Collection Change Events

When a property model represents a collection property, there are several events relating to the adding and removing of child items.

See the Collections topic for a description of each of these events and when they occur.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context Menu Customization

Property grid item (category, property, etc.) context menus displayed by this product can be customized or replaced entirely before they are shown to the end user.

This topic contains these sections:

  • Default Category Menu
  • Default Property Menu
  • Customizing the Menu or Items

Default Category Menu

A default context menu can be pre-configured if the PropertyGrid.IsDefaultItemContextMenuEnabled property is set to true.

The default context menu for a category has a menu item for toggling the display of the summary area, if that feature is enabled via PropertyGrid.IsSummaryToggleAllowed.

Default Property Menu

A default context menu can be pre-configured if the PropertyGrid.IsDefaultItemContextMenuEnabled property is set to true.

The default context menu for a property has a menu item for resetting the value to its default, if the control determines the property has been modified.

When the PropertyGrid.AreClipboardMenuItemsEnabled property is true, several clipboard-related menu items are added. One copies the display name of the property, while another copies the value to the clipboard. Another allows for pasting in of a value from the clipboard.

The context menu also has a menu item for toggling the display of the summary area, if that feature is enabled via PropertyGrid.IsSummaryToggleAllowed.

Customizing the Menu or Items

The customization of context menus is handled via the PropertyGrid.ItemMenuRequested event. This event fires whenever a context menu is displayed for an item in the property grid.

The event arguments passed are of type TreeListBoxItemMenuEventArgs, which indicates the IDataModel for which the event was fired in its Item property. This IDataModel could be an ICategoryModel, IPropertyModel, or ICategoryEditorModel.

Any pre-configured default menu is passed in the TreeListBoxItemMenuEventArgs.Menu property. Its menu items can be changed or removed, or new menu items added.

The default menu is built with all native controls such as ContextMenu and MenuItem. This means that custom styles targeting those types can be applied.

If you wish to completely replace the default menu and supply a custom one, set the TreeListBoxItemMenuEventArgs.Menu property to a menu of your own.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Virtualization

The property grid control uses both UI virtualization and lazy loading techniques to achieve maximum performance.

This topic contains these sections:

  • UI Virtualization
  • Lazy Loading

UI Virtualization

UI virtualization means that if many property grid items (categories, properties, etc.) are loaded in the property grid, containers are only generated for items that are visible or are close to being visible. Without UI virtualization enabled, containers would be generated for all items in the control, regardless of whether they are (or are close to being) visible, and that can severely affect UI performance. Especially since a property grid can contain a large number of items based on the data object(s) being examined.

Since property grid uses a selector to switch styles/templates for items (between properties, categories, etc.), "Standard" virtualization mode is used by default instead of "Recycling".

Note Note
"Recycling" virtualization mode is not used since it can run into display issues on older .NET framework versions.

For more information on UI virtualization and the related features inherited via TreeListBox, please see the tree control Virtualization topic.

Lazy Loading

The property grid is designed to lazy load items. When property items are generated for a root data object, the list of root properties is first retrieved by a call to the data factory. Then additional calls are made to the data factory for each of the property value objects. This is done to see if any of them have child properties, so that property grid knows if the root property should be marked as expandable.

No deeper calls to the data factory are made until one of those root properties is expanded, at which point each of the child properties of the expanded property's value object are examined in the same way to see if any of them are expandable.

This process ensures that if a large hierarchy of expandable objects is used with property grid, it's doing the minimum number of calls to the data factory to keep the property grid UI up-to-date.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The TreeListBox control is a single-column tree control with many advanced features, similar to the Visual Studio Solution Explorer tree control. The TreeListView control is a multi-column variant of TreeListBox that renders similar to a standard ListView but has additional features.

While TreeListBox may initially appear similar to a native TreeView control, and TreeListView may appear similar to a native ListView control, they offer many more features than what is found in the native controls. See the Features list below for a summary of what they can do.

Note Note
Since the TreeListView control inherits TreeListBox, all of the documentation related to TreeListBox also applies to TreeListView.

This topic contains these sections:

  • Features
  • Getting Started
  • Columns (TreeListView)
  • Expandability
  • Selection
  • Default Actions
  • Item Paths
  • Item CheckBoxes
  • Item Context Menus
  • Inline Editing
  • Drag and Drop
  • Text Searching
  • Filtering
  • Virtualization
  • Keyboard Shortcuts

Features

TreeListBox Control

  • Fully customize the appearance of each node.
  • UI virtualization, allowing for hundreds of thousands of nodes to be loaded into a tree very quickly.
  • No scrollbar jumpiness as seen in other virtualized tree controls when scrolling vertically.
  • Use your own custom data models as the source for the tree, with no dependencies on UI or our interfaces. An adapter class is used (and can be fully customized to fit your model) to communicate between the UI and the model for things like expansion state, getting children, etc.
  • The adapter can be coded with bindings in XAML (convenient, yet can be slow in very large trees) or via method overrides (slightly more work but lightning fast).
  • Optionally show the root item in the control.
  • Fine-grained control over expandability and children query triggers.
  • Optional async loading with busy indicator display.
  • Events for expansion.
  • Events for selection.
  • Single or multi-selection, with Ctrl and Shift-based selection options.
  • Filter selection such as only allowing sibling nodes to be multi-selected, or nodes of the same depth.
  • All common tree hotkeys supported including special ones for expanding and collapsing entire branches.
  • Select or ensure nodes are visible by path.
  • Double-click and Return key default action handling.
  • Optional checkboxes within the data templates.
  • Intelligent text searching so when you start typing while the control has focus, it will auto-focus the item that matches the typed text.
  • Inline editing via F2 and single-click on a selected item.
  • Per-item context menus that can be constructed dynamically via an event.
  • Drag items to external controls, drop data from external controls, or drag/drop items within the control itself.
  • Dragged items can highlight above, on, and below drop areas for each item.
  • Single and multiple item dragging is supported.
  • Optional data virtualization optimization when using virtualized collections.
  • Indentation of top-level and other nodes can be set independently.
  • Customizable item filtering that supports string, boolean, or predicate-based logic.
  • Filtered items can automatically have their ancestors expanded.

TreeListView Control

  • All features found in TreeListBox.
  • Templates, template selectors, or text property bindings used to specify custom content for each cell.
  • Column width can be a specific pixel value, auto (size to header, cells, or both), or star-sized.
  • Optional minimum and maximum widths for column auto/star-sizing modes.
  • Columns can optionally be resized, reordered, and have visibility toggled by the end user.
  • Frozen columns that don't scroll horizontally.
  • Set which column renders the indentation and expander buttons.
  • Column headers have a built-in context menu, and the headers themselves can be hidden.
  • Size columns to fit contents.
  • Optional grid line display.
  • Numerous events for column resizing, reordering, visibility changes, and header menu requests.

Getting Started

This topic covers everything you need to get started, including high-level information about how item adapters work, how to bind to data, and how to provide customized UI for your items.

See the Getting Started topic for more information.

Columns (TreeListView)

The TreeListView control supports one or more columns of cells that can be displayed within each item (row). Columns can be resized, reordered, hidden, frozen, and much more.

See the Columns (TreeListView) topic for more information.

Expandability

Everything from when children are queried to expander display is configurable, and events allow for expand/collapse operations to be canceled. Child items can be loaded asynchronously while a progress spinner shows that activity is occurring.

See the Expandability topic for more information.

Selection

Both single and multi-selection modes are supported. Various properties and events allow for the selection of certain items to be blocked.

See the Selection topic for more information.

Default Actions

A default action occurs when an item is double-tapped or Enter is pressed. This action can be fully customized to execute custom logic.

See the Default Actions topic for more information.

Item Paths

Sometimes it's handy to be able to supply a string path to obtain or work with an item. Each item can provide its own path. A full path can be constructed by appending a path separator delimiter and the item's path to its parent's full path.

See the Item Paths topic for more information.

Item CheckBoxes

CheckBox controls can be inserted into item templates to make items checkable, and default actions can be implemented to toggle checked states for double-taps and Enter key presses.

See the Item CheckBoxes topic for more information.

Item Context Menus

Context menus can be generated dynamically upon request by items.

See the Item Context Menus topic for more information.

Inline Editing

Items support inline editing, which means that a special UI mode can be entered where their text or other properties are in an editable state.

See the Inline Editing topic for more information.

Drag and Drop

This control supports the standard system drag and drop functionality and even has built-in features for displaying an optional drop indicator over items when dragging over the control. Full control over the drag and drop capabilities and drop result is available.

See the Drag and Drop topic for more information.

Text Searching

Text searching allows the end user to start typing text and for a visible (all ancestor items expanded, but not necessarily scrolled into view) item that starts with the typed text to be focused and scrolled into view.

See the Text Searching topic for more information.

Filtering

Filtering allows a tree to be narrowed down to only display items that match filter criteria. A powerful data filtering mechanism is provided that uses string, boolean, and predicate-based logic to filter items. The underlaying data model is not altered in any way, only the view is.

See the Filtering topic for more information.

Virtualization

The tree controls are lightning-fast because they have UI virtualization on by default. Data virtualization is an additional option for scenarios where virtualized child collections are in use.

See the Virtualization topic for more information.

Keyboard Shortcuts

Many keyboard shortcuts are supported that provide access to expand/collapse, focus/selection, default actions and editing mode.

See the Keyboard Shortcuts topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

This topic covers everything you need to get started, including high-level information about how item adapters work, how to bind to data, and how to provide customized UI for your TreeListBox and TreeListView items.

After reading through this topic, see other topics to learn more about expansion, selection, and other advanced features offered by the tree controls.

This topic contains these sections:

  • Item Adapters
  • Recommended Item and Adapter Samples
  • Binding to Data
  • Item Templates
  • Per-Item Appearance Customization
  • Root Item Visibility
  • Ensuring An Item Is Visible
  • Item Indentation

Item Adapters

The TreeListBox and TreeListView controls are geared for MVVM usage, knowing that items can be any custom type and there could be many thousands of items. A common practice in many third-party tree controls is to force items to implement a certain interface. We specifically designed Actipro's tree controls so that your items would never have to implement an interface from our library. After all, data libraries requiring dependencies on UI libraries are frowned upon. In order to support a powerful API, keep performance very fast, and avoid any virtualization quirks that are present in some competitive libraries, the tree controls use an adapter design.

An item adapter is a class of type TreeListBoxItemAdapter that can communicate between the control and items, and is set to the TreeListBox.ItemAdapter property. It has methods that TreeListBox and TreeListView call into to retrieve data and set various states, and is essential to activating many control features.

At a minimum, an item adapter must tell the control how to retrieve the child items of a particular item. See the next section for an example of accomplishing that. But an item adapter can do much more, such as getting/setting expansion, managing selection, triggering editing, handing drag/drop, etc. An item adapter can also do things like return search text, item paths, manage drag and drop, and more.

Recommended Item and Adapter Samples

The "Common" folder in the Grids portion of samples contains full source sample implementations of tree node models (e.g. the TreeNodeModel class) that can be used as a starting point for your own items. There also is a DefaultTreeListBoxItemAdapter class that implements method overrides for all adapter methods and provides optimal performance (no binding usage) when working with items of type TreeNodeModel. Using those classes, you can load hundreds of thousands of items nearly instantly.

Binding to Data

Every tree has a root and that root item should be set to the TreeListBox.RootItem property. The RootItemChanged event fires when the root item is changed.

The root item is always expanded and can optionally be displayed in the tree (see below), but by default, it is not visible. Whenever the control needs to query for child items, it will do so through the item adapter by a call to the TreeListBoxItemAdapter.GetChildren method.

A Binding can be set in XAML to the TreeListBoxItemAdapter.ChildrenBinding property to tell how an item should retrieve child items. The GetChildren method will use that binding if it is supplied, and will otherwise return null Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetChildren method instead with custom logic to retrieve the appropriate value.

The TreeListBoxItemAdapter.ChildrenPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the ChildrenBinding property, for performance reasons, it is just used temporarily to get the value in the adapter method's default implementation. The binding doesn't persist, and that's why the ChildrenPath property is required for property change notifications. This is only needed if the children collection property itself will ever change. The control will natively monitor any observable collection returned from GetChildren for changes to its items.

Here's an example specifying a children binding right in XAML. Note that this is not a recommended approach if you have very large trees or see any performance issues. In those scenarios, it's better to override the GetChildren method directly.

XAML
Copy
​<grids:TreeListBox>
    <grids:TreeListBox.ItemAdapter>
        <grids:TreeListBoxItemAdapter ChildrenBinding="{Binding Children}" ChildrenPath="Children" />
    </grids:TreeListBox.ItemAdapter>
</grids:TreeListBox>

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override IEnumerable GetChildren(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.Children : null);
}
​Public Overrides Function GetChildren(ByVal item As Object) As IEnumerable
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.Children, Nothing))
End Function

Item Templates

Since items can be any custom type, it is essential that you supply an item template containing UI for your items.

For the single-column TreeListBox control, this can be done by setting a DataTemplate to the TreeListBox.ItemTemplate property. The DataTemplate can contain any elements and those elements can be bound to properties on your item. All of this UI will appear indented based on item depth level and with an expander to the left of it.

Here's an example of a common DataTemplate that includes a Image and a TextBlock. This example assumes that you are using an item type that has ImageSource and Name properties.

XAML
Copy
​<grids:TreeListBox>
    <grids:TreeListBox.ItemTemplate>
        <DataTemplate>
            <StackPanel Orientation="Horizontal">
                <Image Width="16" Height="16" Source="{Binding ImageSource}" Stretch="None" VerticalAlignment="Center" />
                <TextBlock Text="{Binding Name}" VerticalAlignment="Center" />
            </StackPanel>
        </DataTemplate>
    </grids:TreeListBox.ItemTemplate>
</grids:TreeListBox>

For the multi-column TreeListView control, the TreeListView.ItemTemplate property is not used. Instead, a DataTemplate can be set for each defined column via the TreeListViewColumn.CellTemplate property .

Here's an example of how to specify the same item template as above, but for a TreeListView column:

XAML
Copy
​<grids:TreeListView>
    <grids:TreeListView.Columns>
        <grids:TreeListViewColumn Header="Name">
            <DataTemplate>
                <StackPanel Orientation="Horizontal">
                    <Image Width="16" Height="16" Source="{Binding ImageSource}" Stretch="None" VerticalAlignment="Center" />
                    <TextBlock Text="{Binding Name}" VerticalAlignment="Center" />
                </StackPanel>
            </DataTemplate>
        </grids:TreeListViewColumn>
    </grids:TreeListView.Columns>
</grids:TreeListView>

If you need your appearance to vary per item, see the next section.

Per-Item Appearance Customization

For the single-column TreeListBox control, the ItemTemplateSelector property may be set to a custom DataTemplateSelector instance that picks a DataTemplate to use based on the supplied item. Use of template selectors can be important when different items require a different appearance. For instance, one DataTemplate might just show an image and text, while another may show text and a micro chart. Several examples of template selectors are found in the product QuickStarts.

For the multi-column TreeListView control, the TreeListViewColumn.CellTemplateSelector property can be set for each column, instead of the TreeListView.ItemTemplateSelector property.

You also can set the ItemContainerStyleSelector property to a custom StyleSelector instance that picks a TreeListBoxItem class or TreeListViewItem Style to use based on the supplied item. Normally only template selectors are ever required when doing per-item appearance customization, but the higher-level style selection option is there as well.

Root Item Visibility

The TreeListBox.IsRootItemVisible property (defaulting to false) determines if the RootItem is visible in the control. When true, it will be the sole top-level item. When false, its child items will be the top-level items.

Ensuring An Item Is Visible

The TreeListBox.BringItemIntoView and BringItemIntoViewByFullPath methods can be used to ensure that an item is visible and scrolled into view.

Both methods will expand any collapsed ancestor items so that the target item is visible. The BringItemIntoView method can be a bottleneck in very large trees where the specified node hasn't yet been exposed to the control by its ancestor nodes all being expanded. In that scenario, a full tree search is required to locate the node. For that case, it is recommended to use the BringItemIntoViewByFullPath method that searches by full path instead, since that can be much faster. See the Item Paths topic for more information on working with paths.

Item Indentation

There are two properties that determine the indentation of items for each depth level. Expanders are generally rendered within the indentation space.

The primary property is TreeListBox.IndentIncrement, and that is the step indentation increment amount between depth levels.

The TreeListBox.TopLevelIndent is used for the top-level items only, to determine how far in they indent. Set this property to zero when top-level items aren't expandable (see the Expandability topic for more informatation). That ensures that the top-level items don't have empty whitespace on the left when they never show expanders.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Columns (TreeListView)

The TreeListView control supports one or more columns of cells that can be displayed within each item (row). Columns can be resized, reordered, hidden, frozen, and much more.

Columns are created by adding TreeListViewColumn instances to the TreeListView.Columns collection. Properties set on the column instance affect all cells within that column.

This topic contains these sections:

  • Header and Cell Appearance
  • Widths
  • Resizing
  • Reordering
  • Visibility
  • Frozen Columns
  • Specifying the Expansion Column
  • Handling Column Header Taps
  • Column Header Context Menus
  • Size-to-Fit
  • Grid Lines
  • Column Index
  • Sort Direction
  • Important Note on Data Bindings in Column Properties

Header and Cell Appearance

Header Appearance

For a basic text column header, simply set the TreeListViewColumn.Header property to a text value.

If you need to display additional content such as images, you can set the HeaderTemplate property to a custom DataTemplate. The HeaderTemplateSelector property can be used if you have a DataTemplateSelector instance for multiple columns that is responsible for supplying a DataTemplate for each column based on the column's Header content.

The TreeListViewColumnHeader control that is used to render the chrome of a column header can have an additional style applied via the HeaderContainerStyle property. This allows you to customize the appearance of the header chrome.

The HeaderHorizontalAlignment property lets you set the horizontal alignment of content within the header cell. This is useful in cases such as numeric columns where you may wish to right-align text.

The HeaderCellPadding property controls the amount of padding between the header cell's border and its content.

The HeaderCellBorderThickness property sets the thickness of the border around the header cell.

Cell Appearance

Each column has TreeListViewColumn.CellTemplate and CellTemplateSelector properties that can be set to generate templated content for each cell within that column. See the Getting Started topic for some examples of setting the cell template properties.

The CellHorizontalAlignment and CellVerticalAlignment properties let you set the horizontal and vertical alignments of content within the item cells. This is useful in cases such as numeric columns where you may wish to right-align text. The default horizontal alignment is Stretch and the default vertical alignment is Center.

The CellPadding property controls the amount of padding between each item cell's border and its content.

The CellBorderThickness property sets the thickness of the border around each item cell.

Widths

A column's width is specified via the TreeListViewColumn.Width property. This property accepts a GridLength value and effectively works the same as a Grid panel's column width specification where a value can be a specific pixel length, Auto, or can be a star (*) sized length.

In the case of auto and star-sized columns, the MinWidth and MaxWidth values are also examined. These properties set minimum and maximum values for any calculated widths.

The current pixel width of the column is returned by the ActualWidth property.

Pixel Width

Pixel width columns will always render at the specified width value.

Here's an example of specifying a pixel width for a column:

XAML
Copy
​<grids:TreeListView>
    <grids:TreeListView.Columns>
        <grids:TreeListViewColumn Header="Name" Width="150" />
        <grids:TreeListViewColumn Header="Description" Width="250" />
    </grids:TreeListView.Columns>
</grids:TreeListView>

Auto Width

Auto width columns will auto-size to their content. The AutoWidthMode property governs whether the auto-size includes header-only, items-only, or both (the default). It can be set to another TreeListViewColumnAutoWidthMode value to alter this behavior. It is common to set minimum and/or maximum width values on these sorts of columns.

Here's an example of specifying an auto width (which is also the default) for a column, ensuring it is at least 50px, and indicating that only item cells should be used for auto-width calculation:

XAML
Copy
​<grids:TreeListView>
    <grids:TreeListView.Columns>
        <grids:TreeListViewColumn Header="Name" Width="Auto" MinWidth="50" AutoWidthMode="ItemsOnly" />
        <grids:TreeListViewColumn Header="Description" Width="250" />
    </grids:TreeListView.Columns>
</grids:TreeListView>

Star Width

Star-sized columns fill the remaining available space. It is generally a good idea to set minimum and/or maximum width values on these sorts of columns.

Here's an example of specifying star-sized widths for columns (the second column will be twice as wide as the first):

XAML
Copy
​<grids:TreeListView>
    <grids:TreeListView.Columns>
        <grids:TreeListViewColumn Header="Name" Width="*" MinWidth="50" />
        <grids:TreeListViewColumn Header="Description" Width="2*" MinWidth="50" />
    </grids:TreeListView.Columns>
</grids:TreeListView>

Resizing

The TreeListView.CanColumnsResize property (defaults to true) is a global property that indicates whether columns can resize by default. This value can be overridden on an instance basis by setting the TreeListViewColumn.CanResize property to a non-null value.

When a column is allowed to resize, the end user can click and drag a gripper on the right side of the column's header to resize it. Note that this feature is only available for star-sized columns when there is another visible star-sized column after it in the same control.

The SizeToFitCommand property returns a command that can be wired up to menu items to size the column to fit its visible contents.

The TreeListView.ColumnsResized event is raised after the end user resizes columns.

Reordering

The TreeListView.CanColumnsReorder property (defaults to false) is a global property that indicates whether columns can be reordered by default. This value can be overridden on an instance basis by setting the TreeListViewColumn.CanReorder property to a non-null value.

When a column is allowed to be reordered, the end user can click and drag the column header to a new location. Drop indicators will show where the drop will occur.

The TreeListView.ColumnReordered event is raised after the end user reorders a column.

Visibility

A column's visibility can be controlled via the TreeListViewColumn.IsVisible property. The TreeListView.ColumnIsVisibleChanged event is raised after a column's visibility changes.

The TreeListView.CanColumnsToggleVisibility property (defaults to false) is a global property that indicates whether columns can toggle their visibility by default. This value can be overridden on an instance basis by setting the TreeListViewColumn.CanToggleVisibility property to a non-null value.

When a column is allowed to have its visibility toggled, the end user can right-click the column header to show a context menu (see a section below for more on column header context menus) and the default context menu provides an option for toggling visibility.

The ToggleVisibilityCommand property returns a command that can be wired up to menu items to toggle the visibility of the column.

Frozen Columns

Frozen columns are one or more columns that appear fixed to the left side of the TreeListView control and are outside of the scrollable portion of the control.

Set the TreeListView.FrozenColumnCount to a value larger than 0 to indicate the number of columns to freeze. Make sure the columns you intend to freeze are the first columns in the Columns collection. The count doesn't examine the current visibility state of the columns, only their index in the collection.

Specifying the Expansion Column

Set the TreeListView.ExpansionColumnIndex property to the index of the column that should contain the expander buttons and be indented based on nesting level. This property defaults to 0, meaning use the first column.

The index doesn't examine the current visibility state of the columns, so it is possible to hide the expansion column. It's good practice to set the CanToggleVisibility to false on the expansion column index if you are enabling column visibility toggling in general.

Handling Column Header Taps

When a column header is tapped and is not being dragged at the time, the TreeListView.ColumnHeaderTapped event is raised. Handle this event to take some appropriate action, such as sorting items by the values presented in that column.

Column Header Context Menus

When the TreeListView.IsDefaultColumnHeaderContextMenuEnabled property is set to true (the default), a default context menu will be generated when a column header is right-clicked. The default context menus has size-to-fit options and column visibility options, all based on if the related features are enabled.

If you are using column header templates instead of setting the TreeListViewColumn.Header properties to string values, be sure to set the Title property to a string that describes the column title. This string will be used in the default column header context menu and/or other UI.

The TreeListView.ColumnHeaderMenuRequested event is raised immediately before the menu is displayed. This allows you to customize the menu as needed with custom logic, or prevent it from showing at all.

Size-to-Fit

The TreeListViewColumn.SizeToFit method can be called to size a column to its visible contents based on the AutoWidthMode setting.

A companion SizeToFitCommand property is available, returning a command that can be used in menu items to call the SizeToFit method.

Grid Lines

While column headers have grid lines by default due to the TreeListViewColumn.HeaderCellBorderThickness property being 0,0,1,1, item cells don't have grid lines by default.

Set the TreeListViewColumn.CellBorderThickness property to 0,0,1,1 to enable grid lines around the item cells too.

Column Index

The index of the column within its owner control can be retrieved via the TreeListViewColumn.Index property.

Sort Direction

If a custom external sorting mechanism is used, the TreeListViewColumn.SortDirection property can display a glyph indicating ascending or descending sorting is active for the column. The property is nullable and can be set to a null reference to remove the sort glyph.

Handle the TreeListView.ColumnHeaderTapped event to know when a column header is clicked, so that you can programmatically alter the SortDirection property appropriately (which updates the sort arrow glyph) and manually adjust the order of item children in your item nodes.

Important Note on Data Bindings in Column Properties

Since the TreeListViewColumn class isn't a UI element, bindings specified in its properties may fail with a data error. Please see the Troubleshooting topic for more information on the problem, including an example and a workaround.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Expandability

Everything from when children are queried to expander display is configurable, and events allow for expand/collapse operations to be canceled. Child items can be loaded asynchronously while a progress spinner shows that activity is occurring.

This topic contains these sections:

  • Syncing Item Expansion State
  • Expand and Collapse Events
  • Querying Children on Expansion
  • Expander Display
  • Optimizing Leaf Node Items
  • Async Loading of Children

Syncing Item Expansion State

The control can two-way communicate with items regarding their expansion state. This is accomplished by calls to the TreeListBoxItemAdapter.GetIsExpanded and TreeListBoxItemAdapter.SetIsExpanded methods (via TreeListBox.ItemAdapter).

A two-way Binding can be set in XAML to the TreeListBoxItemAdapter.IsExpandedBinding property to tell how an item should retrieve the selection state. The GetIsExpanded method will use that binding if it is supplied, and will otherwise return false. The SetIsExpanded method will also use that binding if it is supplied. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsExpanded and SetIsExpanded methods instead with custom logic to retrieve/set the appropriate values.

Note Note
The GetIsExpanded method is generally called much more than other item adapter methods and as such, its performance if using bindings per above can cause UI sluggishness. That being said, for any small to medium size trees, using bindings is generally fine.

The TreeListBoxItemAdapter.IsExpandedPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the IsExpandedBinding property, for performance reasons, it is just used temporarily to get/set the value in the adapter methods' default implementations. The binding doesn't persist, and that's why the IsExpandedPath property is required for property change notifications.

This example code shows how to override the methods for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsExpanded(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsExpanded : false);
}

public override void SetIsExpanded(object item, bool value) {
    var model = item as TreeNodeModel;
    if (model != null)
        model.IsExpanded = value;
}
​Public Overrides Function GetIsExpanded(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsExpanded, False))
End Function

Public Overrides Sub SetIsExpanded(ByVal item As Object, ByVal value As Boolean)
    Dim model = TryCast(item, TreeNodeModel)
    If model IsNot Nothing Then
        model.IsExpanded = value
    End If
End Sub

Expand and Collapse Events

There are several events on TreeListBox that are raised when items are expanding and collapsing. All of them are passed an event arguments object of type TreeListBoxItemExpansionEventArgs, which specifies the related Item and its UI Container.

In addition, the event arguments indicate the kind of expand/collapse (Single, Branch, or All) via the Kind property and also the root item where the event occurred via the SourceItem property. This source item is the same as the Item when affecting a single item, specifies the branch root item when affecting a branch of items, and is null when affecting all items. Branch and all expand/collapse scenarios occur when pressing *, Ctrl+*, /, and Ctrl+/. See the Keyboard Shortcuts topic for more information.

The ItemExpanding event is raised immediately before an item is expanded. Set its Cancel property to true to prevent the expand. The ItemExpanded event is raised after the expand.

The ItemCollapsing event is raised immediately before an item is collapsed. Set its Cancel property to true to prevent the collapse. The ItemCollapsed event is raised after the collapse.

Querying Children on Expansion

The TreeListBoxItemAdapter.ChildrenQueryModeDefault property (via TreeListBox.ItemAdapter) returns a TreeItemChildrenQueryMode value that determines when children are queried. The default value is OnDisplay, meaning that any time an item first becomes visible, a query will be made for its child items. If no child items are found, the item's expander will be hidden.

If the property is changed to OnExpansion instead, a query will only be made for the child items when it is first expanded. Again, if no child items are found, the item's expander will be hidden.

Expander Display

The TreeListBoxItemAdapter.GetExpandability method (via TreeListBox.ItemAdapter) returns a TreeItemExpandability value that indicates if a given item can be expandable, assuming it has child items. The default logic for this method will return Never if the specified item is top-level and the TreeListBoxItemAdapter.TopLevelExpandabilityDefault property value is Never. Otherwise, the TreeListBoxItemAdapter.ExpandabilityDefault property value is returned.

A TreeListBoxItemAdapter.GetExpandability method result of Never will never show an expander and double-clicking items won't toggle their expansion state. This is useful when you wish to display a full tree without letting the user toggle expansion. A result of Auto means the children querying logic described above will determine if the expander is visible.

If an item doesn't initially have any children, thereby preventing the expander from displaying, and at a later time children are added while the item is collapsed, the TreeListBox.InvalidateChildren method can be called to clear the cached state.

Note Note
If you wish to always have top-level items expanded, ensure the top-level items are expanded and set TreeListBoxItemAdapter.TopLevelExpandabilityDefault to Never. It is also generally advised to set TreeListBox.TopLevelIndent to 0 in this case so there is no whitespace to the left of the top-level items.

Optimizing Leaf Node Items

Sometimes certain items might be of a type that they are always leaves in the tree and can never have child items. This is very applicable when using the TreeItemChildrenQueryMode.OnExpansion query mode. In these cases, you can override the TreeListBoxItemAdapter.CanHaveChildren method (via TreeListBox.ItemAdapter) to return false. It returns true by default, and should never return false if the item can have child items, but doesn't at the current time. Optimizations are in place to not call TreeListBoxItemAdapter.GetChildren when this method returns true for an item.

This example code shows how to override the method to return true if the item is of type LeafTreeNodeModel.

C#
VB
Copy
​public virtual bool CanHaveChildren(object item) {
    return (item is LeafTreeNodeModel);
}
​Public Overridable Function CanHaveChildren(ByVal item As Object) As Boolean
    Return (TypeOf item Is LeafTreeNodeModel)
End Function

Async Loading of Children

Sometimes child item queries can be lengthy operations and it's not desirable to lock up the UI while they occur. Scenarios where this is applicable are file system, web, or database queries. TreeListBox fully supports async loading of child items. While an item is flagged as loading, it will keep its expander visible.

When setting the TreeListBoxItemAdapter.ChildrenQueryModeDefault property to TreeItemChildrenQueryMode.OnExpansion, you can add a TreeListBox.ItemExpanding event handler. In that event handler, inform the control that the item is doing async loading and start an async Task with your loading code. The task's logic should execute your potentially lengthy loading code and end with a Dispatcher.BeginInvoke that creates the new child items, adds them to the parent item's children collection, and finally informs the control that the item is done async loading.

The loading state is provided to the control by calls to the TreeListBoxItemAdapter.GetIsLoading method (via TreeListBox.ItemAdapter).

A Binding can be set in XAML to the TreeListBoxItemAdapter.IsLoadingBinding property to tell how an item should retrieve the loading state. The GetIsLoading method will use that binding if it is supplied, and will otherwise return false. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsLoading method instead with custom logic to retrieve the appropriate value.

The TreeListBoxItemAdapter.IsLoadingPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the IsLoadingBinding property, for performance reasons, it is just used temporarily to get/set the value in the adapter methods' default implementations. The binding doesn't persist, and that's why the IsLoadingPath property is required for property change notifications.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsLoading(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsLoading : false);
}
​Public Overrides Function GetIsLoading(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsLoading, False))
End Function

Note Note
It is a good idea to swap out the image for the item that is performing async loading and to replace it with a small progress spinner until the loading is complete.

A full sample of how everything described above works is in the Folder Browser demo.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Selection

Both single and multi-selection modes are supported. Various properties and events allow for the selection of certain items to be blocked.

This topic contains these sections:

  • Single or Multiple Selection
  • Returning Selectability
  • Multiple Selection Filtering
  • Syncing Item Selection State
  • Selection Events

Single or Multiple Selection

The TreeListBox.SelectionMode property indicates the kind of selection supported by the control. The default is Single.

Mode | Description
Single | The user can select only one item at a time.
Multiple | The user can select multiple items without holding down a modifier key.
Extended | The user can select multiple consecutive items while holding down the Shift key or can toggle selection on items while holding the Ctrl key. This is a more common selection mode for multi-select over the Multiple option.

The TreeListBox.SelectedItem property gets and sets the primary selected item, while the SelectedItems property contains the collection of currently-selected items.

Returning Selectability

The control calls the TreeListBoxItemAdapter.GetIsSelectable method (via TreeListBox.ItemAdapter) to return whether an item is capable of being selected. This method returns true by default, but can return false for items that aren't currently capable of being selected, such as for temporary placeholder items.

A Binding can be set in XAML to the TreeListBoxItemAdapter.IsSelectableBinding property to tell how an item should retrieve the path segment. The GetIsSelectable method will use that binding if it is supplied, and will otherwise return null. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsSelectable method instead with custom logic to retrieve the appropriate value.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsSelectable(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsSelectable : true);
}
​Public Overrides Function GetIsSelectable(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsSelectable, True))
End Function

Multiple Selection Filtering

The TreeListBox.MultiSelectionKind property (of type TreeMultiSelectionKind) can be used when multi-selection is enabled. It can apply restrictions to items being added to an existing selection. The default is Any, meaning any items can be added to the selection. This table lists the other options:

Mode | Description
Any | Any node can be selected.
SameType | Any node that is the same type can be selected.
SameDepth | Any node at the same depth can be selected.
Siblings | Any node that shares the same parent can be selected.

The TreeListBox.ItemSelecting event is also raised prior to any selection being made. The event is passed arguments of type TreeListBoxItemEventArgs, which specifies the related Item and its UI Container. If you wish to prevent a certain item from being selected, set the event args' Cancel property to true.

Syncing Item Selection State

The control needs to two-way communicate with items regarding their selection state. This is accomplished by calls to the TreeListBoxItemAdapter.GetIsSelected and TreeListBoxItemAdapter.SetIsSelected methods (via TreeListBox.ItemAdapter).

A two-way Binding can be set in XAML to the TreeListBoxItemAdapter.IsSelectedBinding property to tell how an item should retrieve the selection state. The GetIsSelected method will use that binding if it is supplied, and will otherwise return false. The SetIsSelected method will also use that binding if it is supplied. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsSelected and SetIsSelected methods instead with custom logic to retrieve/set the appropriate values.

The TreeListBoxItemAdapter.IsSelectedPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the IsSelectedBinding property, for performance reasons, it is just used temporarily to get/set the value in the adapter methods' default implementations. The binding doesn't persist, and that's why the IsSelectedPath property is required for property change notifications.

This example code shows how to override the methods for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsSelected(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsSelected : false);
}

public override void SetIsSelected(object item, bool value) {
    var model = item as TreeNodeModel;
    if (model != null)
        model.IsSelected = value;
}
​Public Overrides Function GetIsSelected(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsSelected, False))
End Function

Public Overrides Sub SetIsSelected(ByVal item As Object, ByVal value As Boolean)
    Dim model = TryCast(item, TreeNodeModel)
    If model IsNot Nothing Then
        model.IsSelected = value
    End If
End Sub

Selection Events

The TreeListBox.SelectionChanged event is raised whenever the selection (such the values stored in the SelectedItem and SelectedItems properties) has changed.

The TreeListBox.ItemSelecting event is raised before an item is about to be selected. The Cancel property on the event arguments can be set to true to prevent the item from being selected.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Default Actions

A default action occurs when an item is double-tapped or Enter is pressed. This action can be fully customized to execute custom logic.

This topic contains these sections:

  • Built-In Default Actions
  • Customizing Default Actions

Built-In Default Actions

The only built-in default action is for expandable items to toggle their expansion state. You can cancel this default action by handling the TreeListBox.ItemDefaultActionExecuting event and setting the event args' Cancel property to true.

Customizing Default Actions

In addition to blocking a default action from occurring as above, the TreeListBox.ItemDefaultActionExecuting event can be used for notifications of when to execute a custom action. For instance, when including check boxes on items, you might want to toggle the checked state of the item. Take whatever custom action you wish to take in response to that event. The event is passed arguments of type TreeListBoxItemEventArgs, which specifies the related Item and its UI Container.

If the ItemDefaultActionExecuting event doesn't cancel the default action, then the control will look to see if a TreeListBoxItem.DefaultActionCommand exists. If so, it will try to execute that command.

The TreeListBoxItem.DefaultActionCommand can be set in a TreeListBox.PrepareContainerForItemOverride override. It alternatively be set via Setter binding in a TreeListBox.ItemContainerStyle style.

Otherwise, the built-in default action will execute, if appropriate.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Item Paths

Sometimes it's handy to be able to supply a string path to obtain or work with an item. Each item can provide its own path. A full path can be constructed by appending a path separator delimiter and the item's path to its parent's full path.

This topic contains these sections:

  • Providing an Item Path
  • Setting the Path Separator
  • Getting an Item From a Full Path
  • Getting an Item's Full Path
  • Other Operations by Full Path

Providing an Item Path

An item's path segment is provided to the control by calls to the TreeListBoxItemAdapter.GetPath method (via TreeListBox.ItemAdapter).

A Binding can be set in XAML to the TreeListBoxItemAdapter.PathBinding property to tell how an item should retrieve the path segment. The GetPath method will use that binding if it is supplied, and will otherwise return null. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetPath method instead with custom logic to retrieve the appropriate value.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override string GetPath(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.Name: null);
}
​Public Overrides Function GetPath(ByVal item As Object) As String
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.Name, Nothing))
End Function

Setting the Path Separator

The TreeListBox.PathSeparator property is what defines the delimiter text that separates each item's path segment to build a full path. Its default value is \.

Getting an Item From a Full Path

If you know the full path of an item and wish to obtain the item itself, you can call the TreeListBox.GetItemByFullPath method, passing in the full path as an argument.

Getting an Item's Full Path

If you have an item reference and wish to obtain its full path, you can call the TreeListBox.GetFullPath method, passing in the item as an argument.

Other Operations by Full Path

This methods can be executed by supplying a full path.

Member | Description
TreeListBox.BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view.
TreeListBox.FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed.
TreeListBox.SelectItemByFullPath | Sets the TreeListBox.SelectedItem to the node with the specified full path.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Item CheckBoxes

CheckBox controls can be inserted into item templates to make items checkable, and default actions can be implemented to toggle checked states for double-taps and Enter key presses.

This topic contains these sections:

  • Displaying CheckBoxes
  • Using Default Actions to Toggle Checked State

Displaying CheckBoxes

CheckBox controls aren't built into the control itself but rather are part of the DataTemplate you supply for the items.

Here's an example of a DataTemplate that includes a CheckBox. This example assumes that you are using an item type that has IsThreeState, IsChecked, and Name properties. The IsChecked property has a two-way binding so that it can update the item's property as the end user toggles the CheckBox.

XAML
Copy
​<DataTemplate>
    <StackPanel Orientation="Horizontal">
        <CheckBox Margin="0,0,4,0" VerticalAlignment="Center"
                  Visibility="{Binding IsCheckable, Converter={StaticResource BooleanToVisibilityConverter}}"
                  IsThreeState="{Binding IsThreeState}" IsChecked="{Binding IsChecked, Mode=TwoWay}"
                  />

        <TextBlock Text="{Binding Name}" TextTrimming="CharacterEllipsis" VerticalAlignment="Center" />
    </StackPanel>
</DataTemplate>

Using Default Actions to Toggle Checked State

Default actions are executed when an item is double-tapped or Enter is pressed. When using CheckBox controls in item templates, it's generally good practice to handle item default actions and toggle the item's IsChecked property appropriately.

This example code shows how to handle a default action (via the TreeListBox.ItemDefaultActionExecuting event) and toggle the checked state on a CheckableTreeNodeModel item type that has IsCheckable, IsThreeState, and IsChecked properties.

C#
VB
Copy
​private void OnTreeListBoxItemDefaultActionExecuting(object sender, TreeListBoxItemEventArgs e) {
    var model = e.Item as CheckableTreeNodeModel;
    if ((model != null) && (model.IsCheckable)) {
        e.Cancel = true;

        // Toggle the checked state
        switch (model.IsChecked) {
            case true:
                model.IsChecked = (model.IsThreeState ? (bool?)null : false);
                return;
            case null:
                model.IsChecked = false;
                return;
            default:
                model.IsChecked = true;
                return;
        }
    }
}
​Private Sub OnTreeListBoxItemDefaultActionExecuting(ByVal sender As Object, ByVal e As TreeListBoxItemEventArgs)
    Dim model = TryCast(e.Item, CheckableTreeNodeModel)
    If (model IsNot Nothing) AndAlso (model.IsCheckable) Then
        e.Cancel = True

        ' Toggle the checked state
        Select Case model.IsChecked
            Case True
                model.IsChecked = (model.IsThreeState ? (If(Boolean, )Nothing, False))
                Return
            Case Nothing
                model.IsChecked = False
                Return
            Case Else
                model.IsChecked = True
                Return
        End Select
    End If
End Sub

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Item Context Menus

Context menus can be generated dynamically upon request by items.

This topic contains these sections:

  • Dynamically Creating Context Menus

Dynamically Creating Context Menus

The TreeListBox.ItemMenuRequested event is raised whenever a context menu is required for an item. The event is passed arguments of type TreeListBoxItemMenuEventArgs, which specifies the related Item and its UI Container.

No context menu is automatically created by default. It is up to you to set the TreeListBoxItemMenuEventArgs.Menu property to a menu you generate. Responding to the event allows you to dynamically build a menu based on the context of the item.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Inline Editing

Items support inline editing, which means that a special UI mode can be entered where their text or other properties are in an editable state.

This topic contains these sections:

  • Starting Editing
  • Selecting EditableContentControl TextBox Text
  • Handling EditableContentControl Edited Text
  • Using an Editable Item Template
  • Providing Whether an Item Is Editable
  • Syncing Item Editing State

Starting Editing

If an item is editable (see below for how to provide this), pressing F2 while it is focused, or single tapping on an EditableContentControl in the item's template will trigger edit mode. This is often kept in sync with an item's IsEditing property.

Note Note
When edit mode is active, no arrow key-based item navigation will be enabled. Therefore it is important to only mark items as editable (see below) that have a control in the item template that will respond to IsEditing property changes (from F2 pressed or the item is single tapped) and that also exits the edit mode when appropriate (i.e. focus loss). The default implementation of EditableContentControl does all this for you if you two-way bind its IsEditing property. If you wish to manage the IsEditing state on your own, do not mark the item as editable.

Selecting EditableContentControl TextBox Text

The default EditableContentControl template uses a TextBox when in edit mode. The virtual EditableContentControl.SelectText method is called as edit mode is entered, with its default implementation set to select all the text.

This method can be overridden to select a certain range of text instead. A common scenario is when editing filenames, to only select the actual name (without extension) portion of the filename.

Handling EditableContentControl Edited Text

When a value being edited in an EditableContentControl is committed, the virtual SetContentAfterEditing method is called and the edited content is passed in. The default implementation of this method simply sets the Content property to the specified edited content.

This method can be overridden to coerce the edited content as needed. Or if the edited content is invalid, you could choose to not call the base method, which would effectively cancel the edit. If you wish to keep edit mode active, set the IsEditing property back to true. This is sometimes done if there is an invalid value.

Using an Editable Item Template

When an item's text should be editable, use a EditableContentControl in its item template instead of a TextBlock to display the text. The text will display like a normal TextBlock by default, but will switch to a TextBox for editing when in edit mode.

Here's an example of a DataTemplate that includes a Image and EditableContentControl. This example assumes that you are using an item type that has ImageSource, Name, and IsEditing properties. The IsEditing property has a two-way binding so that it can update the item's property as the end user exits edit mode.

XAML
Copy
​<DataTemplate>
    <StackPanel Orientation="Horizontal">
        <Image Width="16" Height="16" Source="{Binding ImageSource}" Stretch="None" VerticalAlignment="Center" />
        <shared:EditableContentControl Margin="2,0,0,0" Content="{Binding Name, Mode=TwoWay}" IsEditing="{Binding IsEditing, Mode=TwoWay}" />
    </StackPanel>
</DataTemplate>

By specifying a ContentTemplate on the content control, you can surround the bound text content with other text. For instance, if Name has value "Foo", instead of just showing "Foo" in the item template, you could display the text as "Solution 'Foo'". Here's an example:

XAML
Copy
​<DataTemplate>
    <StackPanel Orientation="Horizontal">
        <Image Width="16" Height="16" Source="{Binding ImageSource}" Stretch="None" VerticalAlignment="Center" />
        <shared:EditableContentControl Margin="2,0,0,0" Content="{Binding Name, Mode=TwoWay}" IsEditing="{Binding IsEditing, Mode=TwoWay}">
            <shared:EditableContentControl.ContentTemplate>
                <DataTemplate>
                    <StackPanel Orientation="Horizontal">
                        <TextBlock Text="Solution '" VerticalAlignment="Center" />
                        <TextBlock Text="{Binding}" VerticalAlignment="Center" />
                        <TextBlock Text="'" VerticalAlignment="Center" />
                    </StackPanel>
                </DataTemplate>
            </shared:EditableContentControl.ContentTemplate>
        </shared:EditableContentControl>
    </StackPanel>
</DataTemplate>

When an item with the above item template is edited, the surrounding "Solution'" and "'" text disappears and the TextBox occupies the entire space, editing the Name value.

Providing Whether an Item Is Editable

An item will only enter edit mode if the adapter returns that it is editable. The editable state is provided to the control by calls to the TreeListBoxItemAdapter.GetIsEditable method (via TreeListBox.ItemAdapter).

A Binding can be set in XAML to the TreeListBoxItemAdapter.IsEditableBinding property to tell how an item should retrieve the editable state. The GetIsEditable method will use that binding if it is supplied, and will otherwise return the TreeListBoxItemAdapter.IsEditableDefault property value. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsEditable method instead with custom logic to retrieve the appropriate value.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsEditing(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsEditing : false);
}
​Public Overrides Function GetIsEditing(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsEditing, False))
End Function

Syncing Item Editing State

The control needs to two-way communicate with items regarding their editing state. This is accomplished by calls to the TreeListBoxItemAdapter.GetIsEditing and TreeListBoxItemAdapter.SetIsEditing methods (via TreeListBox.ItemAdapter).

A two-way Binding can be set in XAML to the TreeListBoxItemAdapter.IsEditingBinding property to tell how an item should retrieve the editable state. The GetIsEditing method will use that binding if it is supplied, and will otherwise return false. The SetIsEditing method will also use that binding if it is supplied. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsEditable and SetIsEditing methods instead with custom logic to retrieve/set the appropriate values.

The TreeListBoxItemAdapter.IsEditingPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the IsEditingBinding property, for performance reasons, it is just used temporarily to get/set the value in the adapter methods' default implementations. The binding doesn't persist, and that's why the IsEditingPath property is required for property change notifications.

This example code shows how to override the methods for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsEditing(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsEditing : false);
}

public override void SetIsEditing(object item, bool value) {
    var model = item as TreeNodeModel;
    if (model != null)
        model.IsEditing = value;
}
​Public Overrides Function GetIsEditing(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsEditing, False))
End Function

Public Overrides Sub SetIsEditing(ByVal item As Object, ByVal value As Boolean)
    Dim model = TryCast(item, TreeNodeModel)
    If model IsNot Nothing Then
        model.IsEditing = value
    End If
End Sub

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Drag and Drop

This control supports the standard system drag and drop functionality and even has built-in features for displaying an optional drop indicator over items when dragging over the control. Full control over the drag and drop capabilities and drop result is available.

This topic contains these sections:

  • Dragging Support
  • Multiple Item Dragging and Filtering
  • Initializing a DataObject
  • Dropping Support
  • Handling OnDragOver and OnDrop Notifications
  • Expanding an Item on Drag/Hover

Dragging Support

Dragging is not enabled by default and must be activated by setting the TreeListBox.CanDragItems property to true.

When dragging is enabled and dragging over collapsed items, they will expand after a delay. Similarly, dragging around the very top and bottom of the control will scroll the control.

Multiple Item Dragging and Filtering

The TreeListBox.MultiDragKind property (of type TreeMultiDragKind) can be used when multiple item drag is enabled. It can apply restrictions so that certain items cannot be dragged together. The default is None, meaning only single item selection drags are permitted. This table lists the other options:

Mode | Description
None | Drags are not allowed when multiple items are selected. Only single item selection drags are permitted.
Any | Any node can be dragged.
SameType | Any node that is the same type can be dragged.
SameDepth | Any node at the same depth can be dragged.
Siblings | Any node that shares the same parent can be dragged.

Initializing a DataObject

When items are about to be dragged, the TreeListBoxItemAdapter.InitializeDataObject method (via TreeListBox.ItemAdapter) is called to initialize the drag data.

By default, the InitializeDataObject method simply returns DragDropEffects.None and needs an override implementation for drag support.

The TreeListBox.ItemDataFormat format can be used to store custom data referencing each item being dragged. We recommend storing a string object in that format where each line in the string is a full path to the item. See the Item Paths topic for more information on paths. Each full path should be able to uniquely identify the item.

Other formats can be added to the drag data. For instance, if one item is being dragged, it's common to set a text value that contains the primary text displayed for the item. This text value could then be dropped onto other external controls like TextBox controls.

Note Note
A full sample of drag and drop functionality is included in the product QuickStarts. It contains fairly extensive logic and should be referred to for better understanding of how drag and drop works.

Dropping Support

Dropping is not enabled by default. Set the TreeListBox.AllowDrop property to true to allow dropping. When dropping is allowed, various notification methods will be called on the item adapter as described below. Dropped items can be sourced from the same control or from external controls as well.

Handling OnDragOver and OnDrop Notifications

The TreeListBoxItemAdapter.OnDragOver method (via TreeListBox.ItemAdapter) notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback.

The default implementation of this method flags that dropping is not allowed and returns TreeItemDropArea.None, meaning no visual feedback should be given. Override this method if you wish to support dropping and add logic to properly handle the dragged data.

The target item (which can be null if over the whitespace area below the last item in the control) and a TreeItemDropArea based on hit testing over the target item are passed in as arguments. If dropping is to be supported and a drop indicator should be displayed, the TreeItemDropArea returned can be the same value, or coerced to another value. The resulting value will affect the displayed drop indicator. Possible values are None (no indicator), Before (small bar at the top of the target item), On (a highlight under the item), or After (small bar at the bottom of the target item). Some implementations of drag/drop may wish to keep the drop indicators simple by only returning None or On (coercing Before and After to On).

The DragEventArgs.Effects property should also be set appropriately.

Finally if a drop does occur, the TreeListBoxItemAdapter.OnDrop method (via TreeListBox.ItemAdapter) is called and requests that appropriate updates are made to the supplied DragEventArgs.

The default implementation of this method flags that no drop occurred and takes no further action. Override this method if you wish to support dropping and add logic to properly handle the dragged data.

Here again, the target item (which can be null if over the whitespace area below the last item in the control) and a TreeItemDropArea based on hit testing over the target item are passed in as arguments. An override of this method takes appropriate action to update tree items. This could involve moving items, copying items, inserting new items, etc.

Note Note
A full sample of drag and drop functionality is included in the product QuickStarts. It contains fairly extensive logic and should be referred to for better understanding of how drag and drop works.

Expanding an Item on Drag/Hover

By default, when a drag occurs over an item and the pointer hovers for a brief time, the item will expand if it is currently collapsed and expandable.

The TreeListBoxItemAdapter.OnDragHover method is called when this scenario occurs, allowing you to return a TreeItemExpandability. The default implementation of that method simply returns TreeItemExpandability.Auto.

This method can be overridden in scenarios where you don't wish to allow drag/hover to auto-expand collapsed items. The related DragEventArgs and target item are passed in. Logic can be used to determine if expansion is supported based on the dragged data and target item combination. Return Never for target items that shouldn't support expansion on drag/hover.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Searching

Text searching allows the end user to start typing text and for a visible (all ancestor items expanded, but not necessarily scrolled into view) item that starts with the typed text to be focused and scrolled into view.

This topic contains these sections:

  • Runtime Functionality
  • Providing Search Text

Runtime Functionality

When text searching is supported, any unhandled text input that bubbles up to item's container will be used for text searching purposes. As a character is typed, the character is added to a prefix string that is stored internally. Then the active item, the one with focus, is examined and its search text is retrieved (see a section below on how to provide search text). A case-insensitive check is made to see if the retrieved item search text starts with the currently typed prefix. If the item search text does start with the prefix, the item is focused and searching quits. Otherwise, the next visible item is examined with the same process. Item examination continues and wraps to the top of the control as needed to find a match.

As more characters are typed, they are appended to the prefix string. That is unless there was a pause in between typing. In that case, the character starts a new prefix string.

A great feature built into text searching is that if you continue pressing the last character that was typed and no matches that were made using the old prefix with the new character appended, it will reuse the old prefix and look for another match without the newly-typed character. Picture a scenario where there are three items (Foo 1, Foo 2, and Foo 3). Typing 'f' focuses the first item. Typing 'o' keeps focus on the first item. Typing 'o' again keeps focus on the first item since everything matches thus far. Typing 'o' another time doesn't match "fooo" with any items in the control, so a second search is made with the previous prefix ("foo") and Foo 2 is focused. Similarly, typing 'o' another time would focus Foo 3.

Providing Search Text

Text search only works if the control knows what search text applies to each visible item. Search text is provided to the control by calls to the TreeListBoxItemAdapter.GetSearchText method (via TreeListBox.ItemAdapter).

A Binding can be set in XAML to the TreeListBoxItemAdapter.SearchTextBinding property to tell how an item should retrieve search text. The GetSearchText method will use that binding if it is supplied, and will otherwise return null. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetSearchText method instead with custom logic to retrieve the appropriate value.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override string GetSearchText(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.Name: null);
}
​Public Overrides Function GetSearchText(ByVal item As Object) As String
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.Name, Nothing))
End Function

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Filtering

Filtering allows a tree to be narrowed down to only display items that match filter criteria. A powerful data filtering mechanism is provided that uses string, boolean, and predicate-based logic to filter items. The underlaying data model is not altered in any way, only the view is.

This topic contains these sections:

  • Using Filters
  • Automatically Including Descendants
  • Predicate Filters
  • String Filters
  • Boolean Filters
  • Filter Groups
  • Custom Filters
  • Auto-Expanding to Filtered Items
  • Empty Content

Using Filters

To activate filtering functionality, set the TreeListBox.IsFilterActive property to true. It is false by default.

When filtering is active, the control will iterate over every item in the tree and will call the TreeListBoxItemAdapter.Filter method for each item. That method should return a DataFilterResult:

  • Included - The item passed all filter conditions and is included in the filter. Tree descendants will also be examined by the filter.
  • IncludedWithDescendants - The item passed all filter conditions and is included in the filter. Tree descendants will not be examined by the filter, but will all be included as well.
  • IncludedByDescendants - The item did not pass all filter conditions and will only be included in the filter if one or more of its tree descendants are included. Tree descendants will also be examined by the filter.
  • Excluded - The item did not pass all filter conditions and will not be included in the filter. None of its tree descendants will be examined by the filter.

Note Note
When a filter includes an item, that item will be visible in the tree. When a filter excludes an item, that item will not be visible in the tree.

The Filter method is virtual and at a low level can be overridden to use custom filter logic.

However, this generally is not necessary since there is a higher level filtering mechanism that is provided via the TreeListBox.DataFilter property. By default, the TreeListBoxItemAdapter.Filter method will get the IDataFilter instance (if set) in the DataFilter property and will call its IDataFilter.Filter method to get the filter result. If no IDataFilter is available, the method will fall back to returning DataFilterResult.Included.

The main benefit of this approach is that there are several built-in IDataFilter implementations that can be plugged into the DataFilter property. Custom implementations can be made as well. This keeps the filtering mechanism very modular.

Another benefit of using IDataFilter objects for filtering is that each has an IsEnabled property that can be set to false to prevent that filter from being applied. This is especially useful when building complex filter groups, as described below. You still want to make sure the TreeListBox.IsFilterActive property is set back to false when no filtering is needed, since that will improve performance.

Tip Tip
It is most efficient to set and configure the DataFilter property prior to setting the TreeListBox.IsFilterActive property to true.

Automatically Including Descendants

The DataFilterBase class, used as a base class for the default IDataFilter implementations, has a IncludedFilterResult property that returns the filter result to use when an item is included in the filter. This defaults to DataFilterResult.Included but can alternatively be set to DataFilterResult.IncludedWithDescendants if you wish for all descendant items automatically be included without needing to pass the filter themselves.

All of the built-in filters return the IncludedFilterResult property value when a filter includes an item.

Predicate Filters

The PredicateFilter class, a built-in implementation of IDataFilter, uses a custom Predicate<object> to return filter results.

Simply set the Predicate property to the predicate to use. If the predicate returns true, the IncludedFilterResult property value will be returned by the filter. Otherwise, DataFilterResult.IncludedByDescendants will be returned.

This example code shows how to set a predicate filter that assumes each item is a TreeNodeModel (your custom model type) and checks to see if the Name starts with "Foo".

C#
VB
Copy
​treeListBox.DataFilter = new PredicateFilter(i => ((TreeNodeModel)i).Name.StartsWith("Foo"));
​treeListBox.DataFilter = New PredicateFilter(Function(i) (CType(i, TreeNodeModel)).Name.StartsWith("Foo"))

String Filters

The abstract StringFilterBase class, a built-in implementation of IDataFilter, can be used to easily construct a filter that is based on a string value comparison. Regular expressions are even supported. It has several properties that factor into the comparison.

Target Value

The Value property needs to be set to the operand value used by the filter. The is the target value against which the comparison will be made.

Operation

The Operation property is set to a StringFilterOperation value that determines the kind of comparison operation to perform. The default value is Contains, but all of these operations are available: Contains, NotContains, StartsWith, NotStartsWith, EndsWith, NotEndsWith, Equals, NotEquals, RegexMatch, and NotRegexMatch.

Culture and Case Sensitivity

The StringComparison property is set to a StringComparison value that determines how to compare the strings in terms of culture and case sensitivity. The default value is CurrentCultureIgnoreCase, but can be set to other options if you would prefer ordinal or case sensitive comparisons.

Regular Expressions

When Operation is set to RegexMatch or NotRegexMatch, regular expression matching will be used. The regular expression should be specified in the Value property. If a StringComparison option is used that ignores case, then the regular expression matching will be told to ignore case as well.

If any other RegexOptions (matching options) need to be set, they can be assigned to the RegexOptions property.

Implementing a String Filter

This example code shows how to create a TreeNodeModelStringFilter class that knows how to examine a TreeNodeModel (your custom model type) and check its Name property.

C#
VB
Copy
​public class TreeNodeModelStringFilter : StringFilterBase {
    public override bool Filter(object item, object context) {
        return (this.FilterByString(((TreeNodeModel)item).Name, this.Value) ? this.IncludedFilterResult : DataFilterResult.IncludedByDescendants);
    }
}
​Public Class TreeNodeModelStringFilter
    Inherits StringFilterBase
    Public Overrides Function Filter(ByVal item As Object, ByValue context As Object) As Boolean
        Return (If(Me.FilterByString((CType(item, TreeNodeModel)).Name, Me.Value), Me.IncludedFilterResult, DataFilterResult.IncludedByDescendants))
    End Function
End Class

Once the string filter has been created, it can be implemented in XAML like this to filter all models whose Name starts with Foo:

XAML
Copy
​<grids:TreeListBox ...>
    <grids:TreeListBox.DataFilter>
        <local:TreeNodeModelStringFilter x:Name="stringFilter" Operation="StartsWith" Value="Foo" />
    </grids:TreeListBox.DataFilter>
    ...
</grids:TreeListBox>

The filter's value or other properties can be dynamically updated to refresh the filter results. For instance, with string filters it is common for a TextBox in the user interface to update a string filter's value as text is typed.

Boolean Filters

The abstract BooleanFilterBase class, a built-in implementation of IDataFilter, can be used to easily construct a filter that is based on a boolean value comparison. It has several properties that factor into the comparison.

Target Value

The Value property needs to be set to the operand value used by the filter. The is the target value against which the comparison will be made.

Operation

The Operation property is set to a BooleanFilterOperation value that determines the kind of comparison operation to perform. The default value is Equals, but all of these operations are available: Equals, NotEquals, And, Or and Xor.

Implementing a Boolean Filter

This example code shows how to create a TreeNodeModelBooleanFilter class that knows how to examine a TreeNodeModel (your custom model type) and check its IsActive property.

C#
VB
Copy
​public class TreeNodeModelBooleanFilter : BooleanFilterBase {
    public override bool Filter(object item, object context) {
        return (this.FilterByBoolean(((TreeNodeModel)item).IsActive) ? this.IncludedFilterResult : DataFilterResult.IncludedByDescendants);
    }
}
​Public Class TreeNodeModelBooleanFilter
    Inherits BooleanFilterBase
    Public Overrides Function Filter(ByVal item As Object, ByVal context As Object) As Boolean
        Return (If(Me.FilterByBoolean((CType(item, TreeNodeModel)).IsActive), Me.IncludedFilterResult, DataFilterResult.IncludedByDescendants))
    End Function
End Class

Once the boolean filter has been created, it can be implemented in XAML like this to filter all models whose IsActive property is true:

XAML
Copy
​<grids:TreeListBox ...>
    <grids:TreeListBox.DataFilter>
        <local:TreeNodeModelBooleanFilter x:Name="booleanFilter" Operation="Equals" Value="True" />
    </grids:TreeListBox.DataFilter>
    ...
</grids:TreeListBox>

The filter's value or other properties can be dynamically updated to refresh the filter results. For instance, with boolean filters it is common for a CheckBox in the user interface to update a boolean filter's value as its checked state changes.

Filter Groups

The DataFilterGroup class, a built-in implementation of IDataFilter, can be used to perform a logical AND or OR operation on any number of child filters.

Note Note
A filter group can contain other filters or filter groups. Combine that with the ability for filters to be individually enabled or disabled (via IDataFilter.IsEnabled) and complex filter tree logic can be easily implemented.

Child Filters

The Children property is the collection of child filters to use.

Operation

The Operation property is set to a DataFilterGroupOperation value that determines the kind of comparison operation to perform. The default value is And (all child filters must pass), but Or (any child filter must pass) can be chosen as well.

Implementing a Filter Group

This example code shows how to use the filters described above in a filter group, where both must pass for an item to be included:

XAML
Copy
​<grids:TreeListBox ...>
    <grids:TreeListBox.DataFilter>
        <shared:DataFilterGroup>
            <local:TreeNodeModelStringFilter x:Name="stringFilter" Operation="StartsWith" Value="Foo" />
            <local:TreeNodeModelBooleanFilter x:Name="booleanFilter" Operation="Equals" Value="True" />
        </shared:DataFilterGroup>
    </grids:TreeListBox.DataFilter>
    ...
</grids:TreeListBox>

Custom Filters

While the built-in classes described above will suit most needs, custom IDataFilter implementations can be written as well. The easiest way to do this is to make a class that inherits DataFilterBase, as that class already implements most of the details of the IDataFilter interface. Your only task then is to implement the Filter method with custom logic.

Your custom filter can then be set to the TreeListBox.DataFilter property or can be used in a DataFilterGroup.

It is also possible to inherit the other base classes like StringFilterBase or BooleanFilterBase and augment them.

Auto-Expanding to Filtered Items

The TreeListBox.AutoExpandItemsOnFilter property can be set to true to ensure that when filtering occurs and an item is included in the filter, all of its ancestor items will be expanded automatically. The propertly's default value is false, meaning don't enable this behavior.

This feature is useful when you want to ensure that filtered items are always fully visible immediately and can't be hidden by collapsed ancestor items.

When this feature is enabled, as soon as filtering is deactivated, the expansion state of the items is restored to what it was before filtering activated.

Empty Content

The TreeListBox.EmptyContentTemplate property can be set to a DataTemplate that should be displayed in the control whenever there are no visible items. If additional data needs to be passed into the data template, set it to the EmptyContent property.

This feature is useful when filters can possibly hide all items and a message should be displayed in their place.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Virtualization

The tree controls are lightning-fast because they have UI virtualization on by default. Data virtualization is an additional option for scenarios where virtualized child collections are in use.

This topic contains these sections:

  • UI Virtualization
  • Data Virtualization

UI Virtualization

UI virtualization means that if many items are loaded in the control, containers are only generated for items that are visible or are close to being visible. Without UI virtualization enabled, containers would be generated for all items in the control, regardless of whether they are (or are close to being) visible, and that can severely affect UI performance.

The tree controls have "Recycling" UI virtualization active by default, and nothing needs to be done to configure it. As the control is scrolled, containers for items that are scrolled out of view may be recycled and reused for other items that are being scrolled into view. This recycling helps performance because it prevents UI elements from being created new for every container that is needed.

Recycling Virtualization Mode Issues Recycling Virtualization Mode Issues

If you see issues with bound data showing up on incorrect containers or styles not being applied properly, especially while scrolling, please see the Troubleshooting topic. That topic has a section that describes this scenario in more detail and talks about how to change the virtualization mode back to "Standard", which should solve the issue. "Standard" virtualization is a little slower than "Recycling" virtualization, but is still fast.

The problems described above mostly tend to happen in scenarios where you are switching styles/templates for tree control items on the fly with a selector, based on data. Most tree control usage scenarios don't use selectors, and thus shouldn't run into the problem.

Data Virtualization

Normally, when the control goes to query for an item's children, it will do a for-each through all the items that are indicated as the children's IEnumerable. In some special scenarios where a virtualizing list is used as the children collection, and that virtualizing list should only do paged lookups of data based on what is needed for display, then data virtualization can be enabled by setting the TreeListBox.IsDataVirtualizationEnabled property to true. Otherwise, just leave the property its default of false.

When data virtualization is enabled and an item's children are being queried, the control will first see if the children's IEnumerable is an IList. If so, it will enter data virtualization mode and will populate a list of ITreeItemVirtualPlaceholder objects, one for each child in the source list. This process does not actually access any items in the source list. It only checks the Count of the source list. ITreeItemVirtualPlaceholder is a simple interface to represent a slot in a virtualized list, and just has an Index property.

The TreeListBoxItemAdapter.CreateVirtualPlaceholder method (via TreeListBox.ItemAdapter) is called during the process of creating ITreeItemVirtualPlaceholder objects. The method is passed the parent item and the index of the child that needs a virtual placeholder. Normally this method doesn't need to be overridden since it will return a default placeholder, but you can customize it to return a custom placeholder if you wish.

When a container is generated for an item that is a virtual placeholder, the control will access the parent item's children list and retrieve the child at the index specified by ITreeItemVirtualPlaceholder.Index via its indexer. This is the point at which a paged lookup in the virtualized list can occur, so that a page of items around the specified item can be loaded if needed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Keyboard Shortcuts

Many keyboard shortcuts are supported that provide access to expand/collapse, focus/selection, default actions and editing mode.

This topic contains these sections:

  • Expand and Collapse Shortcuts
  • Focus and Selection Keyboard Shortcuts
  • Other Keyboard Shortcuts

Expand and Collapse Shortcuts

Key | Description
Add | Expands the active item.
Divide | Collapses the active item and all of its descendants.
Ctrl+Divide | Collapses all items.
Left | Contracts the active item (if it is expanded with children) or focuses the parent item.
Multiply | Expands the active item and all of its descendants.
Ctrl+Multiply | Expands all items.
Right | Expands the active item (if it is collapsed) or focuses the first child item.
Subtract | Collapses the active item.

Focus and Selection Keyboard Shortcuts

Key | Description
Ctrl+A | Selects all items when in a multi-selection mode.
Down | Focuses the next visible item.
Ctrl+Down | Focuses the next visible item, without selecting it.
End | Focuses the last visible item.
Ctrl+End | Focuses the last visible item, without selecting it.
Home | Focuses the first visible item.
Ctrl+Home | Focuses the first visible item, without selecting it.
PgDn | Focuses the next appropriate item from a page down request.
Ctrl+PgDn | Focuses the next appropriate item from a page down request, without selecting it.
PgUp | Focuses the next appropriate item from a page up request.
Ctrl+PgUp | Focuses the next appropriate item from a page up request, without selecting it.
Space | Selects the active item.
Ctrl+Space | Toggles selection on the active item.
Shift+Space | Extends the selection to the active item when in extended selection mode.
Up | Focuses the previous visible item.
Ctrl+Up | Focuses the previous visible item, without selecting it.

Other Keyboard Shortcuts

Key | Description
Enter | Performs the default action for the active item.
F2 | Starts editing the active item, if it supports editing.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

This topic contains troubleshooting data specific to the Grids product.

Note Note
For some more troubleshooting information that relates both to this product as well as other products, please see the more general TroubleShooting topic.

This topic contains these sections:

  • TreeListBox/TreeListView Data Not Binding Correctly
  • Bindings in TreeListViewColumn Properties Fail
  • Property Editor Values Might Not Be Committed When Pressing ToolBar Buttons
  • Adorner Shows on Top of Other Controls

TreeListBox/TreeListView Data Not Binding Correctly

In some usage scenarios (particularly if data is late-bound) the core ItemsControl recycling logic might not be able to properly identify when data items change for a container. This often happens if DataTemplate bindings don't give enough data to indicate a difference between bound data items. Symptoms of this scenario are visible when you see items rendering with incorrect bound data, especially when scrolling, since in that case the item containers aren't rebinding to data or reapplying styles/templates properly while recycling.

When you see odd symptoms like this happening, simply set the VirtualizingPanel.VirtualizationMode="Standard" attached attribute on the root TreeListBox (or derived) control. "Standard" virtualization isn't quite as fast as "Recycling" virtualization but it should solve the problem because it doesn't reuse containers.

Bindings in TreeListViewColumn Properties Fail

Bindings within a TreeListViewColumn's property may fail since the column object isn't a UI element and isn't within the visual tree.

This is an example of trying to bind a ColumnName property from a view model as the header for a column:

XAML
Copy
​<grids:TreeListViewColumn x:Name="nameColumn" Header="{Binding ColumnName}" />

The above scenario will likely trigger a "Cannot find governing FrameworkElement or FrameworkContentElement for target element." warning in Visual Studio Output. Use of ElementName will not work.

One workaround for this is to add the binding in code instead, so that the binding source can be specified. Here's an example:

C#
VB
Copy
​BindingOperations.SetBinding(nameColumn, TreeListViewColumn.HeaderProperty, new Binding("DataContext.ColumnName") { Source = treeListView });
​BindingOperations.SetBinding(nameColumn, TreeListViewColumn.HeaderProperty, New Binding("DataContext.ColumnName") With {.Source = treeListView})

Property Editor Values Might Not Be Committed When Pressing ToolBar Buttons

Many property editors use bindings that update on focus loss. Consider a scenario where a TextBox-based property editor is being used to change a property value. The user changes the value and clicks a toolbar button. Since toolbars are in a different focus scope, no focus loss occurs in the TextBox so the pending value hasn't yet been committed to the bound property. The toolbar button click handler needs the fully committed data value though.

This situation can also occur when the user is editing a property and presses a hotkey that invokes a command. The command execute handler needs the fully commmitted data.

The PropertyGrid.TryCommitPropertyValueEdit method can be called to force a pending update to be committed, thereby ensuring that the data model is up-to-date. We recommend that this is only done in situations where the data model must be up-to-date.

Adorner Shows on Top of Other Controls

When using data validation and the user inputs invalid data, the Validation.ErrorTemplate is displayed in an adorner layer. There are instances where the error template will show over top other controls, such as when the parent item is collapsed. One known instance where this occurs is when using a TabItem in a category editor.

This can be solved by wrapping the content with a AdornerDecorator. This allows the error template to be propertly hidden with its associated control.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to 2010.2 topic contains information on converting to 2010.2 from v4.5 through 2010.1.
  • The Converting to 2011.1 topic contains information on converting to 2011.1 from 2010.2.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from 2011.1.
  • The Converting to 2017.1 topic contains information on converting to 2017.1 from an older version through 2011.2.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2010.2

WPF Studio 2010.2 includes several changes to the PropertyGrid to increase the overall performance. The changes are described below, as well as a detailed description of the breaking changes to each control.

This topic contains these sections:

  • Overview of Changes
  • Detailed Changes

Overview of Changes

Panel

Items now use a custom panel to arrange/measure the cells into columns. In previous builds, the Grid panel was used by each item, which all used the same shared scope. This change reduced the number of visuals used, which sped up the arrange/measure phases as well as reduced memory.

Inherited Properties

Several inherited attached dependency properties were demoted to regular dependency properties, and their values were explicitly passed down using bindings. There are several layout related properties that were previously being passed down to the elements that needed them using visual property inheritance. This resulted in extraneous arrange/measure calls, since the visual tree would need to be built before the "layout" properties could be applied. After they were applied the visual tree would need to be refreshed.

By altering the code to pass these values down manually the "layout" properties are now available earlier in the construction of the visual tree, which eliminates the need to refresh the visual tree numerous times. In addition, this simplified the bindings in several locations to speed up the loading of the DataTemplates and ControlTemplates.

DataTemplate Selection

The PropertyGrid uses two custom DataTemplateSelectors to dynamically choose the appropriate DataTemplate (or property editor) for each property displayed, based on it's name and/or type. The DataTemplateSelectors used by the name and value cells are defined by the ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid.NameTemplateSelector and ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid.ValueTemplateSelector properties, respectively. Previously, each cell element would bind to the appropriate selector using {RelativeSource AncestorType={x:Type propgrid:PropertyGrid}. This binding was applied using a built-in Style.

This approach has two performance problems, the first being that each cell has to search up it's visual tree for it's appropriate DataTemplateSelector. The second and larger problem is that the DataTemplateSelector is not applied until after the visual tree is constructed. This, like the "Inherited Properties" section above, causes the visual tree to be refreshed needlessly.

Detailed Changes

This section contains a list of detailed changes by control. Breaking changes are marked in red.

PropertyGrid

  • See the TreeListView section below

PropertyGridDataAccessorItem

  • Default Style(s) - Simplified a few bindings
  • Default Style(s) - Updated to pass several required properties down the to associated expansion toggle button (for categories and category editors)

    Resolution: The properties can no longer by referenced as attached properties, nor can their value be altered at any point in the visual tree. Instead, the values must be explicitly set on the PropertyGrid and/or PropertyGridDataAccessorItem.

  • Default Style(s) - Updated to pass several required properties down the to associated row presenter (for properties)

    Resolution: The properties can no longer by referenced as attached properties, nor can their value be altered at any point in the visual tree. Instead, the values must be explicitly set on the PropertyGrid and/or PropertyGridDataAccessorItem.

  • See the TreeListViewItem section below

TreeListView

  • General - No longer sets itself as a shared size scope for Grids

    Resolution: If a shared size scope is needed, then Grid.IsSharedSizeScope="True" must be explicitly set on the control.

  • Default Style(s) - Updated to pass several required properties down the to associated row presenter

    Resolution: The properties can no longer by referenced as attached properties, nor can their value be altered at any point in the visual tree. Instead, the values must be explicitly set on the TreeListView and/or TreeListViewItem.

  • ColumnsProperty field - Changed from an inherited attached dependency property to a regular dependency property
  • IndentationIncrementProperty field - Changed from an inherited attached dependency property to a regular dependency property
  • SplitterStyleProperty field - Changed from an inherited attached dependency property to a regular dependency property
  • GetColumns/SetColumns methods - Removed as ColumnsProperty is no longer inherited
  • GetIndentationIncrement/SetIndentationIncrement methods - Removed as IndentationIncrementProperty is no longer inherited
  • GetSplitterStyle/SetSplitterStyle methods - Removed as SplitterStyleProperty is no longer inherited

TreeListViewColumn

  • GetColumnDefinition method - Removed since the TreeListViewColumn no longer needs to construct a ColumnDefinition for use in a Grid panel
  • SharedSizeGroup property - Removed since the TreeListViewColumn no longer needs a unique shared size group for use in a Grid panel

TreeListViewGrid

  • General - Removed entirely and has been replaced by TreeListViewRowPresenterBase and it's derivations

TreeListViewItem

  • Default Style(s) - Updated to pass several required properties down the to associated row presenter

    Resolution: The properties can no longer by referenced as attached properties, nor can their value be altered at any point in the visual tree. Instead, the values must be explicitly set on the TreeListView and/or TreeListViewItem.

  • Default Style(s) - Simplified a couple bindings

TreeListViewRowPresenterBase

  • General - Base class was changed from an ItemsControl to a Panel, to provide custom arranging/measuring based on specified columns. Therefore an implicit Style cannot be applied to this type any more.
  • UpdateItems method - Was replaced with the UpdateChildren() method

TreeListViewSplitter

  • Default Style(s) - Updated to support use by itself, instead of in tandem with another TreeListViewSplitter

    Resolution: If a custom style was created for the TreeListViewSplitter, then it must be updated to better align it self for use by itself.

TreeListViewToggleButton

  • Default Style(s) - Removed property settings that were not required
  • Default Style(s) - Simplified a couple bindings

Style for Name Cells

  • General - Removed setter for ContentTemplateSelector (value is now passed down from PropertyGrid.NameTemplateSelector via bindings setup in code-behind)

    Resolution: The ContentTemplateSelector can no longer be set via a style. Instead, the ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid.NameTemplateSelector property must be explicitly set.

  • Control Template(s) - Replaced trigger with binding
  • Control Template(s) - Simplified triggers dealing with highlighting the selected/mouse over items
  • Control Template(s) - Removed extraneous elements

Style for Value Cells

  • General - Removed setter for ContentTemplateSelector (value is now passed down from PropertyGrid.ValueTemplateSelector via bindings setup in code-behind)

    Resolution: The ContentTemplateSelector can no longer be set via a style. Instead, the ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid.NameTemplateSelector property must be explicitly set.

  • Control Template(s) - Replaced two trigger with bindings

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.1

Breaking changes made to the PropertyGrid control are detailed below.

This topic contains these sections:

  • Enhanced Property Editor Mapping

Enhanced Property Editor Mapping

In previous versions, a ActiproSoftware.Windows.Controls.PropertyGrid.Editors.PropertyEditor could only be used to map a DataTemplate to one or more properties based on the property's name and type. This has been extended to optionally include the type of the object that owns the property. This allows property editors to target specific properties on specific types, instead of generically targeting all properties of the given name or type.

In order to support this, the method signature of ActiproSoftware.Windows.Controls.PropertyGrid.Editors.PropertyEditor.GetMatchOrder, ActiproSoftware.Windows.Controls.PropertyGrid.Editors.PropertyEditorCollection.GetNameEditor, and ActiproSoftware.Windows.Controls.PropertyGrid.Editors.PropertyEditorCollection.GetValueEditor have been modified to include the object type.

Unless these methods are being used directly by user-code, then this change will not be breaking change. If these methods are used directly by user-code, then they will need to be updated to reflect the new signatures.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Theming Architectural and Style Changes
  • Updates To Hint Properties
  • Removed State-Oriented Properties
  • Changed PropertyGridDataAccessorItem Content Alignment Values
  • Simplified Styles
  • Modified IPropertyDataAccessor's Refresh Method
  • Modified Default Behavior for String Collections
  • Replaced IsUITypeEditorPreferred with an enumeration on WinFormsInteropValueTemplateSelector

Theming Architectural and Style Changes

See unified conversion topic for details on breaking changes made to the theming architecture, which affects control styles and related dictionaries.

Updates To Hint Properties

The ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid control's EmptyTemplate and EmptyTemplateSelector properties have been replaced with the ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid.Hint, ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid.HintTemplate, and ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid.HintTemplateSelector properties. This was done to provide consistency across all our products, with regards to hints.

Upgrade Instructions Upgrade Instructions
  1. All references to EmptyTemplate must be replaced with ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid.HintTemplate.
  2. All references to EmptyTemplateSelector must be replaced with ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid.HintTemplateSelector.

Removed State-Oriented Properties

Various state-oriented brush properties were removed to make control styles more consistent. These brushes can be customized by redefining the associated resource or using custom styles/triggers.

note note
See the Reusable Assets topic for more information on redefining asset resources.

  1. Removed the following properties from ActiproSoftware.Windows.Controls.PropertyGrid.Primitives.TreeListViewSplitter:
    • BackgroundNormal
    • BackgroundHover

Upgrade Instructions Upgrade Instructions
All references to these properties would need to be removed. In order to custom the various brushes, the associated resource would need to be customized.

Changed PropertyGridDataAccessorItem Content Alignment Values

The default Style for ActiproSoftware.Windows.Controls.PropertyGrid.Primitives.PropertyGridDataAccessorItem previously bounds the HorizontalContentAlignment and VerticalContentAlignment to it's parent's value, much like the TreeListView. These bindings resulted in several binding errors during runtime, in certain scenarios, due to a timing issue in WPF. Since these values are rarely set, the bindings have been removed and fixed values are now being used.

These properties can still be customized using an implicit Style for PropertyGridDataAccessorItem, but setting them on one item will no longer be propagated down to it's descendents.

Upgrade Instructions Upgrade Instructions
Review whether HorizontalContentAlignment and VerticalContentAlignment are currently being customized and if that customization is needed. If it is, then add an implicit Style targeting ActiproSoftware.Windows.Controls.PropertyGrid.Primitives.PropertyGridDataAccessorItem that sets these properties appropriately.

Simplified Styles

A couple changes were made to allow a single default Style to be used by both the ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid and it's base class. These changes include:

  1. Moved the CategoryDepth and CategoryIndentationWidth from the ActiproSoftware.Windows.Controls.PropertyGrid.PropertyGrid to it's base class.
  2. Replaced the SubPropertyDepth and SubPropertyIndentationWidth with the existing Depth and IndentationWidth properties, respectively.
  3. Consolidated the UpdateCategoryDepth and UpdateSubPropertyDepth virtual methods into a single ActiproSoftware.Windows.Controls.PropertyGrid.TreeListViewItem.UpdateDepths virtual method.

Upgrade Instructions Upgrade Instructions
Review all usages of the affected members and update appropriately.

Modified IPropertyDataAccessor's Refresh Method

In previous versions, the ActiproSoftware.Windows.Controls.PropertyGrid.Primitives.IPropertyDataAccessor defined a single Refresh method, which would force a property's editor to update. This would also force the property to rebuild any child properties it may have. This caused problems, such as unusual focus movement, in several scenarios. To correct these problems, two overloads for the ActiproSoftware.Windows.Controls.PropertyGrid.Primitives.IPropertyDataAccessor.Refresh were introduced.

The first overload takes a ActiproSoftware.Windows.Controls.PropertyGrid.PropertyRefreshBehavior enumeration, which indicates which type of refresh should be performed (value-only or value & children). The second overload takes a ActiproSoftware.Windows.Controls.PropertyGrid.Primitives.PropertyRefreshReason enumeration, which indicates why the property is being refresh, so the best behavior can be determined.

Upgrade Instructions Upgrade Instructions
All references to the Refresh method can be replaced with Refresh(PropertyRefreshBehavior.ValueAndChildren}, but some may benefit from just refreshing the value (when it is known that the children will not change).

Modified Default Behavior for String Collections

In this release, it is possible to add string.Empty entries into a modifiable string collection, such as List<string> by default. In previous versions, a custom ActiproSoftware.Windows.Controls.PropertyGrid.Primitives.ExpandableCollectionConverter was required to accomplish this.

Upgrade Instructions Upgrade Instructions
Review string collection properties and verify their behavior is still correct.

Replaced IsUITypeEditorPreferred with an enumeration on WinFormsInteropValueTemplateSelector

The ActiproSoftware.Windows.Controls.PropertyGrid.Interop.WinForms.WinFormsInteropValueTemplateSelector.IsUITypeEditorPreferred boolean property was replaced with the ActiproSoftware.Windows.Controls.PropertyGrid.Interop.WinForms.WinFormsInteropValueTemplateSelector.UITypeEditorPriority enumeration property. In addition, the associated constructors were updated to take an enumeration value, instead of a boolean value.

Upgrade Instructions Upgrade Instructions
If IsUITypeEditorPreferred was explicitly set to true, then update it to set UITypeEditorPriority to UITypeEditorPriority.Highest. If IsUITypeEditorPreferred was explicitly set to false, then update it to set UITypeEditorPriority to UITypeEditorPriority.Lowest.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2017.1

The old PropertyGrid control was very feature-rich and was very customizable. The downside of it was that it was relatively slow to load objects and didn't make the best use of virtualization.

For the 2017.1 version, we are introducing a new Grids product that replaces the old PropertyGrid product. Customers who have active PropertyGrid license subscriptions will get Grids for free, and Grids is included in WPF Studio similar to how PropertyGrid was. Grids first started off with implementations of tree controls (TreeListBox and TreeListView) that were built from the ground up to render tree structures in a highly-performant way, making full use of virtualization. The new PropertyGrid extends these controls and loads large complex objects instantly, even in cases where the old PropertyGrid may have taken several seconds to load. The entire data model and data factory design has been rewritten to be simpler and easier than ever to customize, while retaining all of the abilities found in the old PropertyGrid. Integration with the new Editors controls continues to be fully supported.

We realize that some customers may wish to upgrade to 2017.1 immediately, but it might take some time to get their applications updated to work with the new codebase. For those scenarios, the final section of this topic tells how you can still access the old versions of the PropertyGrid assembly (called PropertyGrid.Legacy) and related assemblies, and continue to use them while you work on upgrading to the new codebase. Please only do this if needed, as you want to get on the this new version as soon as possible to continue getting new features and bug fixes.

The rest of this topic discusses the breaking changes made between the old and new versions, and how to update in cases where appropriate.

This topic contains these sections:

  • Control Infrastructure Redesigned
  • SelectedObject(s) Properties Renamed to DataObject(s)
  • Data Accessors and Factories Redesigned
  • Property Editors Changes
  • Integration with Editors Updated
  • Events Renamed
  • Modified Property Display Removed
  • Sorting Changes
  • Filtering Changes
  • Summary Area Changes
  • List Modifiers Removed
  • Other Changes
  • Temporary Inclusion of Older PropertyGrid and Interop Legacy Assemblies

Control Infrastructure Redesigned

In the 2017.1 version, the entire core infrastructure of the control hierarchy for property grid was redesigned. It now is based on our new tree controls (TreeListBox and TreeListView) and is much faster as a result.

The new tree controls allow custom columns to be inserted and the ability to resize columns can be disabled by setting the CanColumnsResize property (formerly named AreDefaultColumnsResizable) to false. See the Columns topic for details on columns, resizing, and creating custom columns.

SelectedObject(s) Properties Renamed to DataObject(s)

Since the new base tree controls have a number of "Select*" properties like SelectedItem that generally correspond to which "row" (PropertyGridItem) is selected, we renamed the former SelectedObject and SelectedObjects properties to DataObject and DataObjects respectively.

Data Accessors and Factories Redesigned

The former data accessors (now called data models) and data factories have been redesigned. The concepts behind them are similar to before but there are different class names used (all in the PropertyData namespace) and some properties on the data models may be different to accommodate new features and general API cleanup. The Data Models and Factories topic digs into these areas in detail.

Interface and Class Mappings

While the data model API has been redesigned, many of the new interfaces and classes generally resemble the old ones. Data model types are now in the PropertyData namespace. Here are some quick notes on conversion:

  • IDataAccessor interface is now IDataModel.
  • DataAccessorBase class is now DataModelBase.
  • IPropertyDataAccessor interface is now IPropertyModel.
  • PropertyDataAccessorBase class is now PropertyModelBase.
  • CachedPropertyDataAccessorBase class is now CachedPropertyModelBase.
  • PropertyDescriptorDataAccessorBase and PropertyDescriptorDataAccessor classes are now PropertyDescriptorPropertyModel.
  • CollectionPropertyDescriptorDataAccessor class is now CollectionPropertyDescriptorPropertyModel.
  • MergedPropertyDataAccessor class is now MergedPropertyModel.
  • ImmutablePropertyDescriptorDataAccessor class is no longer needed.
  • PropertyGridPropertyItem (a class you could use to directly define a property in XAML) is now PropertyModel. Instances can be added to the PropertyGrid.Properties collection.
  • ICategoryDataAccessor interface is now ICategoryModel.
  • CategoryDataAccessor class is now ICategoryModel.
  • PropertyGridCategoryItem (a class you could use to directly define a category in XAML) is removed. Instead, add PropertyModel instances to the PropertyGrid.Properties collection and assign the proper category name to each PropertyModel. The properties will be automatically categorized by the data factory.
  • ICategoryEditorDataAccessor interface is now CategoryModel.
  • CategoryEditorDataAccessor class is now CategoryEditorModel.

PropertyGridDataAccessorItem Removed and Binding Changes

In the old version, each IPropertyDataAccessor you supplied to the property grid either via a data factory or directly as PropertyGridPropertyItem was "wrapped" by a PropertyGridDataAccessorItem. Bindings in name and value data templates used to need to have RelativeSource={RelativeSource AncestorType={x:Type propgridPrimitives:IPropertyDataAccessor}}, which would locate and return the wrapper PropertyGridDataAccessorItem. While the wrapper exposed most common properties to the data templates, if you needed direct access to the "wrapped" data accessor, you could look at the DataContext of the PropertyGridDataAccessorItem. Needless to say, this design was confusing and not performant due to all bindings needing to do ancestor searching.

The new data model API is much more straightforward, faster, and the idea of PropertyGridDataAccessorItem has been removed. Any IPropertyModel supplied to the property grid either via a data factory or directly via PropertyGrid.Properties is used as the data context for all name and value data templates. This means that all control bindings work directly off the source property model with no ancestor searching needed.

Data Accessor Properties

Some properties on the interfaces/classes mentioned above have been changed or renamed as well. While several notable model changes are described below, see the Data Models and Factories topic for details on how to use the new data model API.

Here are some quick notes on conversion:

  • CanReset property is now CanResetValue.
  • IsMergable property is now IsMergeable.
  • IsReadOnly property is now IsValueReadOnly. IsReadOnly is still there, but is now a resolved value per below.
  • One Refresh method overload removed.
  • Reset method is now ResetValue.
  • ValueName property is now Name.

The property structure for property models to indicate read-only state has changed. In the old data accessors, there was an IsReadOnly property that returned whether the data accessor was read-only and then in the property editor value template, triggers examined that along with a lookup to the ancestor PropertyGrid to see if it was read-only. If either of those were true, setters would make the controls in the template read-only or disabled as appropriate. In the new property model API, the IPropertyModel.IsReadOnly property now returns a resolved result of whether the property is read-only, by looking at the IsHostReadOnly property (which comes from PropertyGrid.IsReadOnly) and the IsValueReadOnly property (which returns whether the property value itself is read-only. This is a nicer design since the one resolved IsReadOnly can be bound directly to controls in property editor value templates. Any logic that used to be in old data accessor's IsReadOnly property should be moved to determine the IsValueReadOnly property value now.

Data Factories

In regards to data factories, the abstract DataFactory class is now DataFactoryBase and the TypeDescriptorFactory class is still named TypeDescriptorFactory, but has an updated API. There is no need for TypeReflectionFactory any more, so it has been removed. Data factory types are now in the PropertyData namespace.

Property Editors Changes

Property editors have been reworked to an extent. Instead of the old BuiltinEditors class that had resource key properties, there are now numerous properties on PropertyGrid like DefaultStringNameTemplate and DefaultStringValueTemplate that can be changed to customize the appearance of all built-in name/value editors.

The global BuiltinEditors.PropertyEditors collection is renamed to PropertyGrid.DefaultPropertyEditors. The PropertyEditorModifier class and its related actions have had some API changes to make them easier to use. The former PropertyEditorModifier concept is now implemented through the PropertyGridPropertyEditorsModifier class and its updated API explained in detail in the Property Editors topic.

In the past, a custom DataTemplate used for value editors would have to use FindAncestor bindings to bind to the value and other data model properties. The actual data context for the DataTemplate was the PropertyEditor object. In the new version, the data context for the DataTemplate is now the IPropertyModel, making it much easier to bind to any property on the data model. Additionally, the PropertyEditor used to display the DataTemplate, if any, is available via the IPropertyModel.ValuePropertyEditor property. Each DataTemplate is now much smaller and simpler, which helps improve property grid performance.

See the Property Editors topic for detailed information on how property editors work in the new version and how to completely customize them.

Integration with Editors Updated

The new "ActiproSoftware.Editors.Interop.Grids.Wpf.dll" assembly provides integration of edit boxes with the property grid via the use of custom property editors. This feature is similar to what was in the old "ActiproSoftware.Editors.Interop.PropertyGrid.Wpf.dll" assembly. Several of the property editor classes (like BrushPropertyEditor, etc.) have had property updates to correspond to the related edit box property changes (adds, renames, or removes) described in the Editors' Converting to 2017.1 topic. Also the MaskedTextBoxPropertyEditor class is now named MaskedStringPropertyEditor.

The Editors and PropertyGrid Interoperability topic covers the property editors that are available, including additional ones like DatePropertyEditor, to integrate edit boxes with PropertyGrid and how to do so in the new version.

Events Renamed

While we rebuilt the infrastructure, we took some time to clarify and rename events as well.

  • ItemContextMenuOpening event renamed to ItemMenuRequested and now uses TreeListBoxItemMenuEventArgs.
  • PropertyChanged event renamed to PropertyValueChanged and now uses PropertyModelValueChangeEventArgs.
  • PropertyChanging event renamed to PropertyValueChanging and now uses PropertyModelValueChangeEventArgs.
  • PropertyChildAdded event renamed to ChildPropertyAdded and now uses PropertyModelChildChangeEventArgs.
  • PropertyChildAdding event renamed to ChildPropertyAdding and now uses PropertyModelChildChangeEventArgs.
  • PropertyChildRemoved event renamed to ChildPropertyRemoved and now uses PropertyModelChildChangeEventArgs.
  • PropertyChildRemoving event renamed to ChildPropertyRemoving and now uses PropertyModelChildChangeEventArgs.
  • SelectedObjectsChanged event removed.

Modified Property Display Removed

In an effort to maximize performance and simplify the elements and logic in the name and value cell presenatation, we removed the extra logic needed to support modified property display. The related ModifiedPropertyDisplayMode property was removed. It is possible to add back in custom display by altering the property editor templates or even adding an additional column that shows modified states.

Sorting Changes

The way data models at each level are sorted has changed. The AreDefaultSortDescriptionsEnabled and SortDescriptions properties have been removed. Use the SortComparer property instead, which requires an instance of DataModelSortComparer or a derived class. The property can be set to null to disable default sorting.

Filtering Changes

The filtering model has been reworked to an extent and large portions of it moved to the Shared Library. in the Filtering namespace. The property grid-specific filters (e.g. PropertyModelStringFilter and PropertyModelBooleanFilter) are now in the PropertyData namespace.

Summary Area Changes

The SummaryCanAutoSize property was renamed to CanSummaryAutoSize. The SummaryTransitionDuration and SummaryTransitionSelector properties were removed, since transitions are no longer used in the summary area in an effort to simply the default templates.

List Modifiers Removed

The list modifier features that were used in certain scenarios to help configure property editors in XAML have been removed. There is now a new mechanism for specifying the default property editors in XAML, as described in the Property Editors topic.

Other Changes

These other miscellaneous changes were made to the PropertyGrid class:

  • AreEmptyAccessorsFiltered property removed, as it is no longer needed.
  • BeginUpdate and EndUpdate optimization methods removed, since performance is very fast in the new version even without them.
  • CollectionConverter property removed, which was used by CollectionPropertyDescriptorDataAccessor. The new virtual CollectionPropertyDescriptorPropertyModel.CreateExpandableCollectionConverter method now creates the ExpandableCollectionConverter to use.
  • CollectionDisplayMode property renamed to CollectionPropertyDisplayMode and related PropertyGridCollectionDisplayMode enum renamed to CollectionPropertyDisplayMode.
  • CommitPendingChanges method renamed to TryCommitPropertyValueEdit.
  • EscapeKeyDownDelegates property renamed to CancelPropertyValueEditHandlers and the dictionary values are now of type PropertyGridItemActionHandler.
  • TextInputFocusDelegates property renamed to StartPropertyValueEditHandlers and the dictionary values are now of type PropertyGridItemActionHandler.
  • Hint, HintTemplate, and HintTemplateSelector properties removed. Use the new EmptyContent and EmptyContentTemplate properties instead.
  • IsAsynchronous and IsItemsSourceAutoUpdated properties removed since they are no longer needed due to performance improvements.
  • The NameCellContainerStyle, NameTemplateSelector, ValueCellContainerStyle, and ValueTemplateSelector properties have been replaced by a new infrastructure. See the Property Editors topic for an explanation of how things work in the new version.
  • The static ShowPropertyDialogCommand property has been removed, which helped support dialog display buttons. This feature is still present but in an improved design. See the "Property Dialogs" section in the Property Editors topic for more information on how to implement property dialogs.

Temporary Inclusion of Older PropertyGrid and Interop Legacy Assemblies

We recognize that for the 2017.1 version, numerous breaking changes were made and that you might not be able to immediately update to the newer logic. While we fully encourage you to do so since all future updates and maintenance will only be done on this newer Grids codebase, we still offer the older PropertyGrid version along with its related interop assemblies.

These older legacy assemblies are not installed by default. You must check the 'Control Assemblies / Legacy' option in the installer to install them. Once you do so, these PropertyGrid-related assemblies will appear in a 'Legacy' subfolder of the Actipro assembly install folder (see the Deployment topic for the default location), but will not appear in the GAC:

  • ActiproSoftware.PropertyGrid.Legacy.Wpf.dll
  • ActiproSoftware.PropertyGrid.Interop.WinForms.Legacy.Wpf.dll

You will be able to reference the ActiproSoftware.PropertyGrid.Legacy.Wpf assembly in place of the new ActiproSoftware.Grids.Wpf assembly to maintain full backward compatibility with the old version, while you work on upgrading your application to the new version.

See the Licensing topic for info on how to add an entry to the licenses.licx file (updated info added in v2017.1).

Do NOT reference both the ActiproSoftware.Grids.Wpf and ActiproSoftware.PropertyGrid.Legacy.Wpf assemblies (or similar for interop assemblies) in the same project, since they have many types/members named the same.

Again, these legacy assemblies will only be included temporarily. We encourage you to upgrade your code to the latest Grids assembly as soon as it is feasible so that you can continue to receive the latest product feature additions and bug fixes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Micro Charts are a special form of chart that are meant to be used in small spaces, to help visualize quantitative data. Use micro charts to quickly convey data and trends in your custom dashboards, reports, and grids.

Sample sales illustrated using two bar series

Actipro Micro Charts makes it easy to generate charts based on any custom data source. It will automatically calculate the best scales to fit the data into the control, or you can customize the scales as needed. It includes support for aggregation of large data sets to improve performance and readability, highlighting ranges or key data points, and much more.

Several types of charts are supported, which include Area, Bar, Line, Scatter, Win/Loss, and Heat Map. Stacked and 100% stacked variations of area and bar charts are available as well.

Features

Chart Types

  • Area
    • Includes support for spline curves and stepped lines.
    • Highlight values below the baseline using custom styles.
    • Optionally display a line along the series.
    • Optionally display markers to highlight data points.
    • Easily apply alternate marker styles for first, last, high, low, and negative data points.
  • Bar
    • Quickly customize the spacing between the bars to fit your needs.
    • Easily apply alternate bar styles for high, low, and negative data points.
  • Line
    • Includes support for spline curves and stepped lines.
    • Highlight values below the baseline using custom styles.
    • Optionally display markers to highlight data points.
    • Easily apply alternate marker styles for first, last, high, low, and negative data points.
  • Scatter
    • Easily apply alternate marker styles for first, last, high, low, and negative data points.
  • Win/Loss
    • Quickly customize the spacing between the bars to fit your needs.
    • Easily apply alternate bar styles for high, low, and negative data points.
  • Bullet Graph
    • Compare a data value to a target or goal and a future projection.
    • Put data into the context of several qualitative ranges.
  • Box Plot
    • Display the distribution of a set of values.
    • Identify the outliers and extreme values of a data set.
  • Candlestick
    • Visualize price movements over time.
    • Track the status of stocks, currency values, or securities.
  • Heat Map
    • Use color and/or size changing markers to represent data.
  • Segment
    • Visualizes an integer value in relation to a total number.
    • Use on dashboards, infographics, or as progress indicators.
    • Customizable color, size, shape, and layout.
  • Trend Indicator
    • Uses three states to reflect whether a numeric value is higher, the same as, or lower than an origin value.

Data Source Features

  • Supports displaying any numeric and date/time values from custom data sources.
  • Data can be automatically aggregated to reduce the number of data points rendered.

Appearance Features

  • Combine any number of different series into a single chart.
  • Supports stacking multiple series, both normally and using 100% scale.
  • Customizable baseline value, which dictates which values are considered 'negative', and optional display of baseline.
  • Customizable minimum and maximum values of each axis for fixed scales.
  • Add horizontal or vertical ranges, which are used to highlight specific data ranges.
  • Support for a hot-tracking tool tip, which allows the end user to hover over the chart and read the associated value.
  • Easily customize the various brushes used to render charts via palettes and palette selectors.
  • Set the visibility of any series to dictate whether or not it is rendered on the chart.
  • Over 10 built-in palettes.

Code and Requirements

  • Includes detailed documentation and a sample project that demos nearly every feature.
  • Written in 100% pure C# and is based on the Windows Presentation Foundation framework.
  • Requires the .NET 4.0 or later run-time framework.
  • Full XAML support and XBAP compatibility.
  • Extensive Visual Studio and Expression Blend designer capabilities.
  • Visual Studio and/or Expression Blend are recommended development tools for this product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

It's easy to get started using Micro Charts. Simply follow the steps below to build your first chart.

This topic contains these sections:

  • Add Assembly References
  • Add the MicroXYChart Control
  • Add a Series
  • Further Study

Add Assembly References

First, add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.MicroCharts.Wpf.dll assemblies. The assemblies should be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Add the MicroXYChart Control

Then find the parent element that will contain the micro chart. This could be a UserControl or any other type of UIElement.

Next, add a MicroXYChart control to the desired parent element. In this sample we will add the MicroXYChart to a UserControl:

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:microcharts="http://schemas.actiprosoftware.com/winfx/xaml/microcharts"
    >
    <microcharts:MicroXYChart Width="100" Height="18">
    </microcharts:MicroXYChart>
</UserControl>

Add a Series

Now we need to add a series, which renders a single set of data points on the chart. In this sample we will add a MicroAreaSeries series, but the other types are added in a similar manner.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:microcharts="http://schemas.actiprosoftware.com/winfx/xaml/microcharts"
    >
    <microcharts:MicroXYChart Width="100" Height="18">
        <microcharts:MicroAreaSeries ItemsSource="{Binding}" />
    </microcharts:MicroXYChart>
</UserControl>

Note that this sample assumes that the chart's DataContext is a list of numeric (i.e. Double, Decimal, etc) or DateTime objects. With this configuration, the chart's X values will represent the index value in the list and the chart's Y values will represent the list's actual value at the related list index.

If our list contained custom objects and we wanted to pull the X and Y values from properties on that object, then we would have to specify the property path on the series.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:microcharts="http://schemas.actiprosoftware.com/winfx/xaml/microcharts"
    >
    <microcharts:MicroXYChart Width="100" Height="18">
        <microcharts:MicroAreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyNumericProperty" />
    </microcharts:MicroXYChart>
</UserControl>

This sample assumes the objects in the list each contain a property named MyDateProperty and MyNumericProperty, which are then used for the associated axis.

Note Note
If a list contains custom data objects but the index of each entry should be used as the X-values, leave out the XPath attribute and just specify the YPath to the data object's property that contains the value to display.

Additional series can be added and they will all be rendered on the same chart using the same X and Y scales.

Further Study

It's very easy to use Micro Charts and there are probably a lot of great features that you aren't aware of.

Run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of Micro Charts.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Micro Chart Basics

This topic discusses some of the basic concepts to know about using micro charts.

This topic contains these sections:

  • Primary vs. Secondary Axis
  • Adding a Series
  • Specifying Items

Primary vs. Secondary Axis

The MicroXYChart control supports two axes, X and Y. The X axis runs horizontally along the control, and the Y axis runs vertically. All series default to rendering horizontally, which means that Y is the primary axis and X is the secondary axis.

Certain series types, such as Bar and Win/Loss, support vertical orientations as well as the default horizontal orientation. With vertically oriented series, X is the primary axis and Y is the secondary axis.

See the Chart Types topic for additional information.

Adding a Series

Each series type is implemented in a separate .NET type. For instance, a Line series is implemented by the MicroLineSeries class.

Add any series you would like to display to the MicroXYChart.Series collection. The chart will automatically scale the X and Y axes to fit the data of each series properly.

See the Chart Types topic for a list of the available chart types.

Specifying Items

Each series is bound to it's own data source, which is indicated by the ItemsSource property. The data source can be a collection of numeric values (i.e. Double, Decimal, Int32, etc), DateTime values, or custom objects.

When the data source is a collection of numeric or DateTime values, then the series' XPath and YPath properties should not be set. The series will automatically use the value from the collection as the data point's primary value (which is typically the Y value) and the index in the data source as the secondary value.

When the data source is a collection of custom objects, then the series' XPath and YPath need to be set appropriately. The index in the data source can be used as the secondary value (which is typically the X value), in which case the associated path property can be left blank. The path primary value must be specified and must indicate the name of a numeric or date/time property on the custom object.

See the Specifying Items topic for additional information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Micro Charts includes a number of built-in chart types.

Name | Description
Area | An area chart is a derivative of a line chart. The area between the line and axis is filled in. Markers and lines can optionally be displayed.
Bar | A bar chart displays rectangular bars with lengths proportional to the values they represent.
Line | A line chart render quantitative data as a series of points connected by line segments. Lines can be straight, curved, or stepped. Markers can optionally be displayed.
Scatter | Scatter charts render data points where each point is represented by a marker.
Win/Loss | A win/loss chart is a special kind of bar chart where any positive value renders as a full-height upward bar, any negative value renders as a full-height downward bar, and zero values render as a line in the middle.
Box Plot | A box plot is a chart that displays a list of data in a five number summary shown by the ends of the whiskers, ends of the box, and the median bar.
Bullet Graph | A bullet graph is a special kind of bar chart used to display a single value in a context of one or more related values.
Candlestick | Candlestick charts are used to visualize price movements over time, such as changing stock or currency values.
Heat Map | A heat map is a grid where each cell renders color and/or size differences to reflect data values. The MicroHeatMapPresenter control is the marker used in each heat map cell, and automatically handles the color and/or size rendering for its particular data value representation.
Segment | A segment chart provides a visual representation of an integer value in relation to a total number. Each segment in the chart is rendered as highlighted or unhighlighted. For instance, if the value is 3 of 10, there will be 10 total segments displayed, with the first 3 rendering as highlighted. This sort of chart is great for use on dashboards, and also as an indicator of steps or progress achieved.
Trend Indicator | The trend indicator is a three state control that is intended to reflect whether a numeric value is higher, the same as, or lower than an origin value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Area

An area chart is a derivative of a line chart where the area between the line and axis is filled in.

This topic contains these sections:

  • Baseline Value
  • Style Kinds
  • Line Kind
  • Line
  • Markers

Baseline Value

The area series will pivot it's polygon based on the chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property. The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following examples, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum. Since our baseline is 0 (the default), the polygon is not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the polyon will appear to pivot around the baseline.

Style Kinds

The negative areas can be rendered using a distinct style and brush to highlight them. This is done using the AreaStyleKinds property, which is used to specify which style kinds should be used. If we explicitly set this to Negative, then we can see the bottom area is rendered using a contrasting brush.

The normal style can be customized using the AreaStyle property, and negative style can be customized using the AreaNegativeStyle property. The associated Style should target the Shape type, which includes properties such as Fill, Stroke, and StrokeThickness.

Line Kind

The area series supports three kinds of lines specified by the LineKind, which also determines how the area is rendered. By default, the Normal kind of line is used which simply draws a line to connect the data points when determining the area's polygon.

An area series using a normal line kind, zoomed 400%

The Spline line kind builds a canonical spline that runs through the data points, producing a smooth line.

An area series using a spline line kind, zoomed 400%

The Step line kind creates a polygon that only uses horizontal and vertical lines to connect the data points, producing a step look.

An area series using a step line kind, zoomed 400%

Line

The area series can render an actual line along the top of the area to distinguish it better. By default the line is not rendered, but it can be shown by setting LineVisibility to a value other than None. The area series has the same configuration properties available as the line series, with regards to line rendering.

See the Line topic for more information on the options available.

Markers

The area series can render a markers at each data point to highlight the actual location. By default the markers is not rendered, but they can be shown by setting MarkerVisibility to a value other than None. The area series has the same configuration properties available as the scatter series, with regards to marker rendering.

See the Scatter topic for more information on the options available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Bar

A bar chart displays rectangular bars with lengths proportional to the values they represent.

This topic contains these sections:

  • Baseline Value
  • Style Kinds
  • Orientation
  • Bar Spacing

Baseline Value

The bar series will pivot it's bars based on the chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property. The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 25, 10, 20, 5, 20, 10 for the Y-axis. The first image shows the series using 5 as the minimum value along the Y-axis, and 25 for the maximum. Since our baseline is 0 (the default), the bars are not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the bars will appear to "grow" down instead of up.

Style Kinds

The bar series can render various bars differently, which is specified using the BarStyleKinds property. Supported options include High, Low, Negative, or any combination of those values.

If we include the High and Low flags, then the bars associated with the data points with the highest and lowest value will render using a distinct style/brush.

If we include the Negative flags, then the bar associated with the data points whose value is less than 15 will render using a distinct style/brush.

The normal style can be customized using the BarStyle property, and negative style can be customized using the BarNegativeStyle property. Similarly, the high and low bars can be styled using the BarHighStyle and BarLowStyle, respectively. The associated Style should target the Shape type, which includes properties such as Fill, Stroke, and StrokeThickness.

Orientation

The bar chart can be oriented horizontally (the default) or vertically by setting the Orientation property. When switching orientation, the values of the XPath and YPath properties may need to be swapped.

Bar Spacing

The BarSpacing property can be used to configure the space between the bars. The default value is 1px, which indicates there should be a 1 pixel space between the bars.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line

A line chart renders quantitative data as a series of points connected by line segments, which can be straight, curved, or stepped.

This topic contains these sections:

  • Baseline Value
  • Style Kinds
  • Line Kind
  • Markers

Baseline Value

The chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property, only determines which portion of the line is considered "negative" when using various style kinds. The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative". Visually nothing will change until the Negative flag is included in the LineStyleKinds property.

Style Kinds

The negative lines can be rendered using a distinct style and brush to highlight them. This is done using the LineStyleKinds property, which is used to specify which style kinds should be used. If we explicitly set this to Negative, then we can see the bottom line is rendered using a contrasting brush.

The normal style can be customized using the LineStyle property, and negative style can be customized using the LineNegativeStyle property. The associated Style should target the Shape type, which includes properties such as Fill, Stroke, and StrokeThickness.

Line Kind

The line series supports three kinds of lines specified by the LineKind. By default, the Normal kind of line is used which simply draws a line to connect the data points.

An line series using a normal line kind, zoomed 400%

The Spline line kind builds a canonical spline that runs through the data points, producing a smooth line.

An line series using a spline line kind, zoomed 400%

The Step line kind creates a line that only uses horizontal and vertical lines to connect the data points, producing a step look.

An line series using a step line kind, zoomed 400%

Markers

The line series can render a markers at each data point to highlight the actual location. By default the markers is not rendered, but they can be shown by setting MarkerVisibility to a value other than None. The line series has the same configuration properties available as the scatter series, with regards to marker rendering.

See the Scatter topic for more information on the options available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Scatter

Scatter charts render data points where each point is represented by a marker.

This topic contains these sections:

  • Baseline and Style Kinds
  • Marker Shape Kinds

Baseline and Style Kinds

The scatter series can render various markers differently, which is specified using the MarkerStyleKinds property. Supported options include First, Last, High, Low, Negative, or any combination of those values.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 25, 10, 20, 5, 20, 10 for the Y-axis. The first image shows the series using 5 as the minimum value along the Y-axis, and 25 for the maximum.

If we include the First and Last flags, then the first and last markers will render slightly different from the other markers.

If we include the High and Low flags, then the markers associated with the data points with the highest and lowest value will render using a distinct style/brush.

The chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property, can be used to indicate which markers are considered "negative". If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative". The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue. If we include the Negative flags, then the markers associated with the data points whose value is less than 15 will render using a distinct style/brush.

The normal style can be customized using the MarkerStyle property, and negative style can be customized using the MarkerNegativeStyle property. Similarly, the first, last, high, and low markers can be styled using the MarkerFirstStyle, MarkerLastStyle, MarkerHighStyle, and MarkerLowStyle, respectively. The associated Style should target the MicroChartMarker type, which includes properties such as Fill, Stroke, StrokeThickness, and ShapeKind.

Marker Shape Kinds

Markers support several built in shape kinds, which include:

Kind | Example
Diamond |
Ellipse |
Hexagon |
Pentagon |
Octagon |
Rectangle |
RoundedRectangle |
Star4Points |
Star5Points |
Star6Points |
Star8Points |
Triangle |

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Win/Loss

A win/loss chart is a special kind of bar chart where any positive value renders as a full-height upward bar, any negative value renders as a full-height downward bar, and zero values render as a line in the middle.

This topic contains these sections:

  • Baseline Value
  • Style Kinds
  • Orientation
  • Bar Spacing

Baseline Value

The win/loss series uses the chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property, to determine which values are positive (i.e. above the baseline) and negative (i.e. below the baseline). The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 25, 10, 20, 5, 20, 10 for the Y-axis. The first image shows the series using 5 as the minimum value along the Y-axis, and 25 for the maximum. Since our baseline is 0 (the default) all the values are considered positive.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the bars will appear to "grow" down instead of up.

Style Kinds

The win/loss series can render various bars differently, which is specified using the BarStyleKinds property. Supported options include High, Low, Negative, or any combination of those values.

If we include the High and Low flags, then the bars associated with the data points with the highest and lowest value will render using a distinct style/brush.

If we include the Negative flags, then the bar associated with the data points whose value is less than 15 will render using a distinct style/brush.

The normal style can be customized using the BarStyle property, and negative style can be customized using the BarNegativeStyle property. Similarly, the high and low bars can be styled using the BarHighStyle and BarLowStyle, respectively. The associated Style should target the Shape type, which includes properties such as Fill, Stroke, and StrokeThickness.

Orientation

The win/loss chart can be oriented horizontally (the default) or vertically by setting the Orientation property. When switching orientation, the values of the XPath and YPath properties may need to be swapped.

Bar Spacing

The BarSpacing property can be used to configure the space between the bars. The default value is 1px, which indicates there should be a 1 pixel space between the bars.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Multiple and Stacked Series

The chart control supports multiple series which can be optionally stacked on top of the previous series.

This topic contains these sections:

  • Multiple Series
  • Normal Stacking
  • Percentage Stacking

Multiple Series

Any number of series can be added to the chart, which will simply render one on top of each (in z-order) Simply add the series to the MicroXYChart.Series collection that you would like to be rendered.

In this example, we display a bar and line series in the same chart:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" YAxisMinimum="0">
    <microcharts:MicroBarSeries ItemsSource="4;11;3;1;8;9;14" />
    <microcharts:MicroLineSeries ItemsSource="7;3;5;1;1;3;10" />
</microcharts:MicroXYChart>

This results in the following chart:

The chart will automatically align the multiple series along the secondary axis (X in this example). So, if the series have data with disparate values, then it will automatically adjust to fit the data.

In this example, we add additional data points to the line series:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" YAxisMinimum="0">
    <microcharts:MicroBarSeries ItemsSource="4;11;3;1;8;9;14" />
    <microcharts:MicroLineSeries ItemsSource="7;3;5;1;1;3;10;5;2;8;1;14" />
</microcharts:MicroXYChart>

This results in the following chart, which has extended the line series beyond the bar series since it has more data points:

Normal Stacking

Two or more series can be stacked one on top of the other to convey cumlative values to the end user.

By setting StackKind on the series to Normal, the values of each series will be added to the previous stacked series.

In this sample the second series will be stacked on top of the first series.

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" >
    <microcharts:MicroAreaSeries ItemsSource="{Binding Data1}" StackKind="Normal" />
    <microcharts:MicroAreaSeries ItemsSource="{Binding Data2}" StackKind="Normal" />
</microcharts:MicroXYChart>

Percentage Stacking

Two or more area series can be stacked one on top of the other to convey proportional values to the end user. In this mode, the series render to fill the chart height. At any given location, the height of each rendered series indicates its value percentage relative to the total.

By setting StackKind on the series to Percentage, the values of each series will be added to the previous stacked series and a percentage of the total value will be used.

In this sample the second series will be stacked on top of the first series.

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" >
    <microcharts:MicroAreaSeries ItemsSource="{Binding Data1}" StackKind="Percentage" />
    <microcharts:MicroAreaSeries ItemsSource="{Binding Data2}" StackKind="Percentage" />
</microcharts:MicroXYChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Box Plot

A box plot is a chart that displays a set of data through five major values: the lower whisker value, the lower quartile value, the median, the upper quartile, and the upper whisker value. The median is the value found directly in the center of the data when it is sorted, meaning half of the data lies above it, and half lies below it. The median is displayed as a perpendicular line to the chart. The lower quartile is the median of the lower half of data, resulting in a quarter of the data being less than it, and three-quarters being greater. The upper quartile is the median of the higher half of data, resulting in three-quarters of the data being less than it, and a quarter being greater. The upper and lower quartiles define the edges of a box drawn on the chart, resulting in the middle half of the data being contained within the box. The difference between the upper and lower quartiles is known as the Interquartile Range (IQR). The product of the IQR and the IQR multiplier (normally a value of 1.5) is then subtracted from the lower quartile value to get the lower whisker value and added to the upper quartile value to get the upper whisker value. The whiskers are displayed as "T" bars that extend from the edges of the box to their respective values.

The spacing between the different parts of the box plot help indicate the degree of spread in the data. Box Plots are particularly useful for displaying distributions of a group in a compact way. This is good for creating charts that compare a group of data such as the performance of salespeople, heights of a group of people, temperatures along a latitude, and more.

This topic contains these sections:

  • Data Display
  • Graph Minimum and Maximum
  • Orientation
  • Appearance Customization
  • Tool Tips

Data Display

The MicroBoxPlot control accepts a collection of data in its Values property, and then from that data it calculates the median value, which can optionally be displayed, the upper and lower quartile values (the 75th and 25th percentiles respectively), the upper and lower whisker values, and the minimum and maximum values. Outliers, values that fall outside the range between the whisker values, can be optionally displayed. If outliers are not displayed they will not affect the minimum and maximum values. The mean, or average, value can also be displayed optionally. Below is an example of a MicroBoxPlot with all parts displayed and labeled.

Note that the box's ends are defined by the upper and lower quartile values. The width of the box, equal to the difference between the upper and lower quartiles, is known as the Interquartile Range (IQR). The IQR is used to calculate the whisker values. The whiskers extend to the furthest data point from the edges of the box within a distance equal to the IQR multiplied by the IqrMultiplier, which defaults to 1.5. Not that if the IqrMultiplier is set to a number less than or equal to zero no whiskers will be displayed. An example of populating the collection of values is shown below.

XAML
Copy
​<microcharts:MicroBoxPlot Values="1; 2; 3; 4; 5; 6" />

Graph Minimum and Maximum

The minimum and maximum of the chart are auto-calculated if they are not given a value. The minimum and maximum are set to the smallest and largest displayed values respectively. The minimum and maximum can also be set to specific values, note that any data values outside of the set range will be clipped and not displayed.

Setting the minimum and maximum chart values can be useful for putting group of box plots into the same context. This allows all the charts to display the same range and makes it easy to compare several data sets. The box plots could then be placed in a vertical column to produce a comprehensive report.

Orientation

The MicroBoxPlot.Orientation property is Horizontal by default, but can be set to Vertical as well. Setting the chart's orientation to vertical effectively rotates the control 90 degrees counter-clockwise, so the minimum value is on the bottom and the maximum is at the top of the control.

Appearance Customization

Every part of the MicroBoxPlot has a style that can be customized to change its color, size, and visual features. Below is a list of the different parts with what member can be accessed to change their style. Note that the target type of the styles should be Shape.

Part Name | Member Name
Box | MicroBoxPlot.BoxStyle
Mean Bar | MicroBoxPlot.MeanStyle
Median bar | MicroBoxPlot.MedianStyle
Outliers | MicroBoxPlot.OutlierStyle
Whiskers | MicroBoxPlot.WhiskerStyle

Styles can be used to set the brushes on the Fill and/or Stroke properties of the parts to change their color, and the StrokeThickness property can be set on the whiskers, mean, and median bars to alter their size. In addition, there is a WhiskerAscent property that controls the size of the whiskers' end lines. The ascent property takes a Unit value that is generally a pixel or percentage type. Note that setting the WhiskerAscent to zero will result in no end lines being rendered.

Since the outliers are MicroChartMarkers their ShapeKind value can be set to any of the following shapes:

Kind | Example
Diamond |
Ellipse |
Hexagon |
Pentagon |
Octagon |
Rectangle |
RoundedRectangle |
Star4Points |
Star5Points |
Star6Points |
Star8Points |
Triangle |

XAML
Copy
​<microcharts:MicroBoxPlot Values="1; 2; 3; 4; 5; 6">
    <microcharts:MicroBoxPlot.Style>
        <Style TargetType="microcharts:MicroBoxPlot" BasedOn="{StaticResource MicroBoxPlotStyleBase}">
            <Setter Property="BoxStyle">
                <Setter.Value>
                    <Style TargetType="Shape">
                        <Setter Property="Fill" Value="#3b8525" />
                    </Style>
                </Setter.Value>
            </Setter>
            <Setter Property="MedianStyle">
                <Setter.Value>
                    <Style TargetType="Shape">
                        <Setter Property="Stroke" Value="#ffffff" />
                        <Setter Property="StrokeThickness" Value="3" />
                    </Style>
                </Setter.Value>
            </Setter>
            <Setter Property="WhiskerStyle">
                <Setter.Value>
                    <Style TargetType="Shape">
                        <Setter Property="Stroke" Value="#3b8525" />
                        <Setter Property="StrokeThickness" Value="3" />
                    </Style>
                </Setter.Value>
            </Setter>
        </Style>
    </microcharts:MicroBoxPlot.Style>
</microcharts:MicroBoxPlot>

The above example shows how to set values for the different parts' styles and customize the size values.

Tool Tips

MicroBoxPlots support tooltips that can be custom formatted and can display the values of the quartiles, whiskers and mean, as well as the minimum and maximum.

Format Parameter | Description
{0} | The minimum value.
{1} | The lower whisker value.
{2} | The lower quartile value (Q1).
{3} | The median value (Q2).
{4} | The upper quartile value (Q3).
{5} | The upper whisker value.
{6} | The maximum value.
{7} | The mean value.
{8} | The number of values.

This example displays the upper and lower quartile values as well as the mean value of the data. Note how numeric formatting is used on the values.

XAML
Copy
​<microcharts:MicroBoxPlot ... LegendStringFormat="Lower Quartile: {2:F1}, Upper Quartile: {4:F1}, Average: {7:F1}">

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Bullet Graph

Bullet graphs are used to simultaneously display and evaluate data. They show a single data value with contextual information to give the value further meaning. The actual value is represented by a featured measure bar, which is juxtaposed with a comparative value displayed as a bar perpendicular to it. The featured and comparative values are then placed in the context of specific ranges such as poor, average, and excellent.

Bullet graphs were originally designed to replace meters and gauges in a more compact way while still being informative. Bullet graphs are excellent to use as gauges or meters; however, they can also be used to display many other types of data very effectively. They are most suited to display a value that has other related values to be compared to, such as last year's mark, a goal or target, or a projected future value. Examples could include annual income or expenses data, sales data, and performance ratings data.

This topic contains these sections:

  • Measure Display
  • Graphing Minimum and Maximum
  • Orientation
  • Appearance Customization
  • Tooltips

Measure Display

The MicroBulletGraph is capable of displaying a featured value, a comparative value, a projected value, and any number of ranges. The only required value is the featured value, all others default to NaN, in which case they will not be displayed. If all parts are present the order they are rendered from top to bottom is: featured, comparative, projected, then the ranges in order from the smallest value to the largest value.

By default the featured and projected bars take up a third of the control and extend from zero to a length proportional to their respective values. The comparative bar is displayed perpendicular to the featured bar, with a default width of two and fills two thirds of the control. Ranges fill the entire control and extend to a length proportional to their value, any ranges that aren't given a value will fill to the end of the control. The MicroBulletGraph.QualitativeRanges member is used to set and access the collection of MicroQualitativeRanges displayed by the chart. An example of populating the collection is shown below.

XAML
Copy
​<bulletGraph:MicroBulletGraph Maximum="800" FeaturedMeasureValue="450" FeaturedMeasureBrush="Black">
    <bulletGraph:MicroBulletGraph.QualitativeRanges>
        <bulletGraph:MicroQualitativeRange Value="200" Background="DarkSlateGray"/>
        <bulletGraph:MicroQualitativeRange Value="350" Background="DimGray" />
        <bulletGraph:MicroQualitativeRange Value="500" Background="Gray" />
        <bulletGraph:MicroQualitativeRange Value="650" Background="DarkGray" />
        <bulletGraph:MicroQualitativeRange Background="LightGray" />
    </bulletGraph:MicroBulletGraph.QualitativeRanges>
</bulletGraph:MicroBulletGraph>

Graphing Minimum and Maximum

The Minimum and Maximum of the graph are auto-calculated if they are not given a value. The minimum is set to zero, or the smallest part value less than zero if one exists. The maximum is set to the largest part value. The minimum and maximum can also be set, in which case the displayed values will be coerced into the range so all specified values will be displayed.

Ellipses Display

If the Minimum is set to a value greater than zero, the featured value, and projected value if there is one, will be displayed as an ellipse centered on the value. The image below shows an example with the minimum set to one.

Negative Values

Negative values are supported by the MicroBulletGraph control. If the featured and/or projected bar is given a negative value they will start at zero and extend in the opposite direction to a length proportional to their value.

Orientation

The MicroBulletGraph.Orientation property is Horizontal by default, but can be set to Vertical as well. Setting the chart's orientation to vertical effectively rotates the control 90 degrees counter-clockwise, so the minimum value is on the bottom and the maximum is at the top of the control.

Appearance Customization

Brushes

Every part of the graph has a brush that can be customized to display any color or gradient desired. To specify the brush used on a range set its background property. Below is a list of the different parts and what member can be accessed to change their brush.

Part Name | Member Name
Featured bar/ellipse | MicroBulletGraph.FeaturedMeasureBrush
Projected bar/ellipse | MicroBulletGraph.ProjectedMeasureBrush
Comparative bar | MicroBulletGraph.ComparativeMeasureBrush
Range(s) | MicroQualitativeRange.Background

Sizes

The size of the featured, projected, and comparative bars can be customized using the FeaturedMeasureAscent, ComparativeMeasureAscent, and ComparativeMeasureExtent properties. The ascent properties are Unit values that specify the amount of the control that the part should fill (height for horizontal orientation and width for vertical). The FeaturedMeasureAscent property changes both the featured and projected bars and is commonly set as a percentage, but can also be a pixel value. The ComparativeMeasureExtent property represents the thickness, generally in pixels, of the comparative bar (width for horizontal orientation and height for vertical).

XAML
Copy
​<microcharts:MicroBulletGraph FeaturedMeasureValue="72" FeaturedMeasureBrush="White"
            ProjectedMeasureValue="80" ProjectedMeasureBrush="LightGray" ComparativeMeasureValue="60"
            Maximum="100" ComparativeMeasureBrush="White" FeaturedMeasureAscent="30%"
            ComparativeMeasureAscent="60%" ComparativeMeasureExtent="5">
    <microcharts:MicroBulletGraph.QualitativeRanges>
        <microcharts:MicroQualitativeRange Value="33" Background="#505f74" />
        <microcharts:MicroQualitativeRange Value="66" Background="#758498" />
        <microcharts:MicroQualitativeRange Background="#a9b2be" />
    </microcharts:MicroBulletGraph.QualitativeRanges>
</microcharts:MicroBulletGraph>

The above example shows how to set values for the different part brushes and customize the size values.

Tooltips

MicroBulletGraphs support tooltips that can be custom formatted and can display the values of the bars as well as of the ranges and the minimum and maximum.

Format Parameter | Description
{0} | The featured measure value.
{1} | The projected measure value.
{2} | The comparative measure value.
{3} | The minimum value.
{4} | The maximum value.
{5} | The value of the first qualitative range.
{6} | The value of the second qualitative range.
{7} | The value of the third qualitative range.
{8} | The value of the fourth qualitative range.
{9} | The value of the fifth qualitative range.

This example displays the featured value as well as the ranges from the minimum to the end of the third range. Note how numeric formatting is used on the featured value.

XAML
Copy
​<microcharts:MicroBulletGraph ... LegendStringFormat="Rating:{0:F2} (Poor:{3}-{5} Satisfactory:{5}-{6} Excellent:{6}-{7})">

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Candlestick

Candlestick charts are designed to visualize a change in value over an interval of time, and as such are excellent at showing price movements in stocks, currency values, or securities such as bonds. While a single candlestick can display the changes over one time interval, several can be placed side by side to show a trend over a longer time period, or to provide comparisons.

A candlestick chart displays an opening, closing, highest, and lowest price value for a time interval. The chart consists of a box with two lines, known as wicks, that extend out of either end of it. The wicks extend to the highest and lowest values reached during the interval. The edges of the box are defined by the opening and closing values. If the closing value is less than the opening value then the box is shaded and filled in with the color selected to display loss. If the closing value is greater than the opening value than the box remains unshaded, or is optionally filled in with an alternate color selected to display gain.

The MicroCandlestickChart control accepts values for the opening, closing, high, and low values. The control will determine if there is a gain or loss based on the opening and closing values and display the parts using the appropriate style. Note that if the high value is equal to either the opening or closing values, the upper wick will not be displayed; similarly the lower wick will not be displayed if the low value is equal to either the opening or closing values. An example of giving the parts values is shown below.

XAML
Copy
​<microcharts:MicroCandlestickChart HighValue="60" LowValue="5" OpenValue="15" CloseValue="33" />

This topic contains these sections:

  • Graph Minimum and Maximum
  • Orientation
  • Appearance Customization
  • Tool Tips

Graph Minimum and Maximum

The minimum and maximum of the chart are auto-calculated if they are not given a value. The minimum and maximum are set to the smallest and largest displayed values respectively. The minimum and maximum can also be set to specific values, note that any data values outside of the set range will be clipped and not displayed.

Setting the minimum and maximum chart values can be useful for putting group of candlestick charts into the same context. This allows all the charts to display the same range and makes it easy to compare several data sets. The charts could then be rendered vertically and placed in a row to produce a comprehensive report.

Orientation

The MicroCandlestickChart.Orientation property is Horizontal by default, but can be set to Vertical as well. Setting the chart's orientation to vertical effectively rotates the control 90 degrees counter-clockwise, so the minimum value is on the bottom and the maximum is at the top of the control.

Appearance Customization

The MicroCandlestickChart control has a GainStyle and LossStyle property that can be customized to alter the appearance of the chart. Note that both styles should be set for a Shape. The control uses the gain style if the closing value is greater than the opening value and the loss style if the closing value is less than the opening value. The selected style is applied wicks and the box of the control, the stroke defining the color of the wicks and box outline and the fill defining the color inside the box. If GainStyle is not given a value then LossStyle will be used with the fill being set to Transparent instead. By default the stroke and fill of the loss style are black and the gain style is not given a value.

XAML
Copy
​<microcharts:MicroCandlestickChart ... >
      <microcharts:MicroCandlestickChart.LossStyle>
             <Style TargetType="Shape">
                    <Setter Property="Stroke" Value="#5778B6" />
                    <Setter Property="Fill" Value="#5778B6" />
                    <Setter Property="StrokeThickness" Value="3" />
             </Style>
      </microcharts:MicroCandlestickChart.LossStyle>
</microcharts:MicroCandlestickChart>

The above example shows how to set a style for the chart and the appearance of a gain and loss situation.

Tool Tips

MicroCandlestickCharts support tooltips that can be custom formatted and can display the low, high, open, and close values.

Format Parameter | Description
{0} | The low value.
{1} | The high value.
{2} | The open value.
{3} | The close value.

This example displays the upper and lower quartile values as well as the mean value of the data. Note how numeric formatting is used on the values.

XAML
Copy
​<microcharts:MicroCandlestickChart ... LegendStringFormat "Low: {0:C2}; High: {1:C2}; Open: {2:C2}; Close: {3:C2}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Heat Map

A heat map is a grid where each cell renders color and/or size differences to reflect data values. The MicroHeatMapPresenter control is the marker used in each heat map cell, and automatically handles the color and/or size rendering for its particular data value representation.

This topic contains these sections:

  • What is a Heat Map?
  • Reusing Styles
  • Color Changing Ability
  • Sizing Ability
  • Marker Shape Kinds
  • Tooltips

What is a Heat Map?

Heat maps are charts made up of individual markers that use changing color and/or size to represent one or two pieces of data. Each marker has one or two values that are part of the set(s) of data represented by the chart. For each value the marker gets its size or color based on the position of that value within the range defined by the minimum and maximum values in the set.

In the example above the markers are changing color and size to represent their two values. The smaller the values represented by color are shown with lighter markers, and the smaller the values represented by size are shown with smaller markers. The two values are independent of one another, meaning a large marker can be very light and a small marker can be very dark.

The MicroHeatMapPresenter control provides this dynamic functionality for a single marker. Multiple instances can be used to create a heat map. In the example, each single circle is one MicroHeatMapPresenter control, with its own color and size values.

Reusing Styles

Generally a group of MicroHeatMapPresenter controls will all use the same values for their GradientStops property, minimum and maximum values, LegendStringFormat (for tooltips) property, IsSizingEnabled property, and Height and Width properties. Instead of setting these properties for each individual control it is much more practical to set a style that the controls can inherit from. The style can be set in the Resources property of the container for the elements, such as a Grid or Border.

XAML
Copy
​<Border>
      <Border.Resources>
             <Style TargetType="microcharts:MicroHeatMapPresenter">
                    <Setter Property="GradientStops">
                           <Setter.Value>
                                         <GradientStopCollection>
                                                <GradientStop Color="WhiteSmoke" Offset="0" />
                                                <GradientStop Color="DarkGreen" Offset="1" />
                                         </GradientStopCollection>
                           </Setter.Value>
                    </Setter>

                    <Setter Property="MarkerStyle">
                           <Setter.Value>
                                  <Style TargetType="microcharts:MicroChartMarker">
                                        <Setter Property="ShapeKind" Value="Ellipse" />
                                 </Style>
                           </Setter.Value>
                    </Setter>

                    <Setter Property="Height" Value="20" />
                    <Setter Property="Width" Value="20" />
                    <Setter Property="ColorMaximum" Value="100" />
                    <Setter Property="SizeMaximum" Value="10000" />
                    <Setter Property="Margin" Value="3" />
                    <Setter Property="IsSizingEnabled" Value="True" />

             <Setter Property="LegendStringFormat" Value="Revenue per item:       {0:C2}  Items sold: {3:N0}" />
             </Style>
      </Border.Resources>

      <StackPanel>
             <microcharts:MicroHeatMapPresenter ColorValue="15" SizeValue="1250" />
             <microcharts:MicroHeatMapPresenter ColorValue="21" SizeValue="2590" />
      </StackPanel>
</Border>

The sample code above sets the style used in the example from the "What is a Heat Map?" section. Note that the ColorMaximum and SizeMaximum properties are hard-coded in. Generally these values will come from data and not be set in the style, unless the range is known regardless of the data. This style is applied to each MicroHeatMapPresenter within the Border. This can be repeated for several different containers on a page to create multiple charts, or the style can be put into the App.Resources to apply to all MicroHeatMapPresenter controls in the application.

Color Changing Ability

The MicroHeatMapPresenter.GradientStops property can be set to a GradientStopsCollection from which it will select a color based on its ColorValue. The control will select its color based on the GradientStop(s) with the offset value(s) closest to the percentage of the ColorValue from the ColorMinimum to the ColorMaximum. If the percentage lies within two offsets the control will find and use the color at the proper point between the two colors. If the GradientStops property is not defined then the control will display black.

Below is an example of initializing the color variables so the control will find its place in the range between the min and max and render at a color selected from the gradient specified.

XAML
Copy
​<microcharts:MicroHeatMapPresenter ColorValue="21" ColorMinimum="10" ColorMaximum="70">
      <microcharts:MicroHeatMapPresenter.GradientStops>
             <GradientStopCollection>
                    <GradientStop Color="#90bc0b" Offset="0.0" />
                    <GradientStop Color="#c3d92e" Offset="0.2" />
                    <GradientStop Color="#e0cc2e" Offset="0.4" />
                    <GradientStop Color="#d79c36" Offset="0.6" />
                    <GradientStop Color="#e07b3d" Offset="0.8" />
                    <GradientStop Color="#da4d38" Offset="1.0" />
             </GradientStopCollection>
      </microcharts:MicroHeatMapPresenter.GradientStops>
</microcharts:MicroHeatMapPresenter>

Sizing Ability

By default the MicroHeatMapPresenter will size to fit its container. The control can be set to change size to reflect data by setting the IsSizingEnabled property to true. The marker will then render at a percentage of its normal size equal to the percentage of its SizeValue from the SizeMinimum to the SizeMaximum. If the SizeValue is equal to the maximum it will render at the full defined size, and if it is equal to the minimum it will not render visibly.

Below is an example of a MicroHeatMapPresenter with its IsSizingEnabled property set to true. Note that the GradientStops property is not set, so the control will render black for a sizing-only effect.

XAML
Copy
​<microcharts:MicroHeatMapPresenter SizeValue="1250" SizeMinimum="100" SizeMaximum="10000" Width = “20” Height = “20” IsSizingEnabled="True"/>

Marker Shape Kinds

The marker of the control supports several built in shape kinds, which include:

Kind | Example
Diamond |
Ellipse |
Hexagon |
Pentagon |
Octagon |
Rectangle |
RoundedRectangle |
Star4Points |
Star5Points |
Star6Points |
Star8Points |
Triangle |

Tooltips

MicroHeatMapPresenters support tooltips that can be custom formatted and can display the color and size value as well as the color and size minimums and maximums.

Format Parameter | Description
{0} | The value represented by color.
{1} | The minimum color value.
{2} | The maximum color value.
{3} | The value represented by size.
{4} | The minimum size value.
{5} | The maximum size value.

This example displays the ColorValue as well as the ColorMinimum and the ColorMaximum to show the range. Note how numeric formatting is used on the ColorValue.

XAML
Copy
​<microcharts:MicroHeatMapPresenter ... LegendStringFormat="Temperature: {0:F2}°C  (Range: {1}-{2}°C)" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Segment

A segment chart provides a visual representation of an integer value in relation to a total number. Each segment in the chart is rendered as highlighted or unhighlighted. For instance, if the value is 3 of 10, there will be 10 total segments displayed, with the first 3 rendering as highlighted.

This sort of chart is great for use on dashboards, and also as an indicator of steps or progress achieved.

The style for the segments can be customized, allowing for any sort of shape, size, or color combination. The Panel used to render the chart can also be set, enabling wrapping and other layout scenarios.

Value converters can be used to further customize the brush or size of each segment to create some interesting effects.

This topic contains these sections:

  • Basic Usage
  • Appearance Customization
  • Increment and Decrement Commands

Basic Usage

It's easy to use the MicroSegmentChart control. Simply set its Total property to the total number of segments that should be displayed. Then bind the Value property to a value indicating the number of segments that should be highlighted. This value should be less than or equal to the total segment count.

XAML
Copy
​<microcharts:MicroSegmentChart Total="5" Value="{Binding CurrentValue}" />

Appearance Customization

The MicroSegmentChart control can easily be customized to render segments in many interesting ways.

Size and Shape

This code shows how to make red 13x13 squares with a 1px margin:

XAML
Copy
​<microcharts:MicroSegmentChart Value="7" Total="10">
    <microcharts:MicroSegmentChart.ItemContainerStyle>
        <Style TargetType="microcharts:MicroSegmentChartItem">
            <Setter Property="HighlightedBackground" Value="#e73232" />
            <Setter Property="Margin" Value="1" />
            <Setter Property="MinHeight" Value="13" />
            <Setter Property="MinWidth" Value="13" />
        </Style>
    </microcharts:MicroSegmentChart.ItemContainerStyle>
</microcharts:MicroSegmentChart>

This code shows how to customize the chart template to create the purple circles seen above:

XAML
Copy
​<microcharts:MicroSegmentChart Value="5" Total="15" HorizontalAlignment="Left">
    <microcharts:MicroSegmentChart.ItemContainerStyle>
        <Style TargetType="microcharts:MicroSegmentChartItem">
            <Setter Property="Background" Value="#d0d0d0" />
            <Setter Property="HighlightedBackground" Value="#9e5aac" />
            <Setter Property="MinHeight" Value="15" />
            <Setter Property="MinWidth" Value="15" />
            <Setter Property="Template">
                <Setter.Value>
                    <ControlTemplate TargetType="microcharts:MicroSegmentChartItem">

                        <Ellipse x:Name="background" Fill="{TemplateBinding Background}" />

                        <ControlTemplate.Triggers>
                            <Trigger Property="IsHighlighted" Value="True">
                                <Setter TargetName="background" Property="Fill" Value="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=HighlightedBackground}" />
                            </Trigger>
                        </ControlTemplate.Triggers>
                    </ControlTemplate>
                </Setter.Value>
            </Setter>
        </Style>
    </microcharts:MicroSegmentChart.ItemContainerStyle>
</microcharts:MicroSegmentChart>

Segment Number Display

Each segment is passed its number as the data context. This allows the segment number to be rendered in the segment via custom templates.

XAML
Copy
​<microcharts:MicroSegmentChart Value="6" Total="10" HorizontalAlignment="Left">
    <microcharts:MicroSegmentChart.ItemContainerStyle>
        <Style TargetType="microcharts:MicroSegmentChartItem">
            <Setter Property="Background" Value="#d0d0d0" />
            <Setter Property="Foreground" Value="#000000" />
            <Setter Property="HighlightedBackground" Value="#0073cd" />
            <Setter Property="MinHeight" Value="25" />
            <Setter Property="MinWidth" Value="25" />
            <Setter Property="Template">
                <Setter.Value>
                    <ControlTemplate TargetType="microcharts:MicroSegmentChartItem">

                        <Border x:Name="background" Background="{TemplateBinding Background}" BorderBrush="{TemplateBinding BorderBrush}"
                                BorderThickness="{TemplateBinding BorderThickness}" Padding="{TemplateBinding Padding}">
                            <TextBlock x:Name="text" Text="{Binding}" Foreground="{TemplateBinding Foreground}" HorizontalAlignment="Center" VerticalAlignment="Center" />
                        </Border>

                        <ControlTemplate.Triggers>
                            <Trigger Property="IsHighlighted" Value="True">
                                <Setter TargetName="background" Property="Background" Value="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=HighlightedBackground}" />
                                <Setter TargetName="text" Property="Foreground" Value="#ffffff" />
                            </Trigger>
                        </ControlTemplate.Triggers>
                    </ControlTemplate>
                </Setter.Value>
            </Setter>
        </Style>
    </microcharts:MicroSegmentChart.ItemContainerStyle>
</microcharts:MicroSegmentChart>

Alternate Panels

By setting a custom ItemsPanel property value, different backing Panel controls can be used. In the screenshot above, we display 100 segments in a large square with this code:

XAML
Copy
​<microcharts:MicroSegmentChart Value="57" Total="100" HorizontalAlignment="Left">
    <microcharts:MicroSegmentChart.ItemContainerStyle>
        <Style TargetType="microcharts:MicroSegmentChartItem">
            <Setter Property="HighlightedBackground" Value="#26b106" />
            <Setter Property="Margin" Value="1" />
            <Setter Property="MinHeight" Value="8" />
            <Setter Property="MinWidth" Value="8" />
        </Style>
    </microcharts:MicroSegmentChart.ItemContainerStyle>
    <microcharts:MicroSegmentChart.ItemsPanel>
        <ItemsPanelTemplate>
            <toolkit:WrapPanel MaxWidth="100" />
        </ItemsPanelTemplate>
    </microcharts:MicroSegmentChart.ItemsPanel>
</microcharts:MicroSegmentChart>

Changing Colors and Sizes Per Segment

Value converters can even be used to alter the color or size of individual segments, as in the screenshot above. See the full sample in our samples project.

Increment and Decrement Commands

The MicroSegmentChart control has two ICommand properties that can be bound to any button to allow incrementing or decrementing of the Value property.

XAML
Copy
​<RepeatButton Margin="0,0,5,0" MinWidth="20" MinHeight="20" Content="-" Command="{Binding ElementName=commandedSegmentChart, Path=DecreaseCommand}" />
<microcharts:MicroSegmentChart x:Name="commandedSegmentChart" Value="3" Total="10" />
<RepeatButton Margin="5,0,0,0" MinWidth="20" MinHeight="20" Content="+" Command="{Binding ElementName=commandedSegmentChart, Path=IncreaseCommand}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Trend Indicator

The trend indicator is a three state control that is intended to reflect whether a numeric value is higher, the same as, or lower than an origin value.

This sort of element is commonly used in stock value display where the origin value is bound to the previous day's stock price, and the value is bound to the current price. The trend indicator then renders an upward green triangle if there was positive movement, a gray line if no change, or a red triangle if there was negative movement.

If the values are updating live, the indicator changes use a pleasing animation that rotates and fades in the new indicator. The template for each state's indicator can be customized as well.

This topic contains these sections:

  • Basic Usage
  • Appearance Customization

Basic Usage

Simply bind the control's OriginValue property to the original value (or previous value) and the Value property to the current value. The control will animate and display one of three indicator templates.

XAML
Copy
​<microcharts:MicroTrendIndicator OriginValue="{Binding OriginValue}" Value="{Binding CurrentValue}" />

Appearance Customization

The MicroTrendIndicator control can display custom indicator templates for each of its three states.

This code alters the indicator templates to all use circles:

XAML
Copy
​<microcharts:MicroTrendIndicator OriginValue="7" Value="10">
    <microcharts:MicroTrendIndicator.HigherTemplate>
        <DataTemplate>
            <Ellipse Fill="#42cb0c" />
        </DataTemplate>
    </microcharts:MicroTrendIndicator.HigherTemplate>
    <microcharts:MicroTrendIndicator.NeutralTemplate>
        <DataTemplate>
            <Ellipse Fill="#808080" />
        </DataTemplate>
    </microcharts:MicroTrendIndicator.NeutralTemplate>
    <microcharts:MicroTrendIndicator.LowerTemplate>
        <DataTemplate>
            <Ellipse Fill="#cb0c0c" />
        </DataTemplate>
    </microcharts:MicroTrendIndicator.LowerTemplate>
</microcharts:MicroTrendIndicator>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

It's easy to use any simple or complex objects as data sources for charts, and data aggregation is fully supported.

Specifying Items

The chart control can be bound to any custom data source and supports several data types.

See the Specifying Items topic for more information.

Data Aggregation

The chart control supports aggregating its data to reduce the number of data points displayed.

See the Data Aggregation topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Specifying Items

The chart control can be bound to any custom data source and supports several data types.

This topic contains these sections:

  • Supported Axis Types
  • Setting ItemsSource

Supported Axis Types

The chart control supports a fixed set of data types along each axis.

The supported data types include:

  • Byte
  • DateTime
  • Decimal
  • Double
  • Int16
  • Int32
  • Int64
  • Float
  • SByte
  • UInt16
  • UInt32
  • UInt64

An exception will be thrown if an unsupported data type is specified.

Setting ItemsSource

Each series in a chart control can be bound to a separate data source, or to different properties on the same data source. The ItemsSource property on each series can be set to any collection of objects, including custom objects, as long as the collection implements IEnumerable.

There are two types of collections that can be used, simple (such as as list of Double) and complex (such as a list of custom objects).

Simple Collections

A collection of supported axis data types (shown above) can be used as-is without specifying a path to a source property. The index in the collection will be used as the secondary value (which is typically the X value) and the actual value in the collection will be used as the primary value (which is typically the Y value).

In this example, the line series is set to a collection of doubles, defined inline in XAML. Therefore, the X values will range from 0 to 11 (since there are 12 entries) and the actual values shown will be used along the Y axis:

XAML
Copy
​<microcharts:MicroLineSeries ItemsSource="7;3;5;1;1;3;10;5;2;8;1;14" />
Assuming the Counts binding below in the ItemsSource referenced an IEnumerable of the same numeric data values as above, this code would produce identical output:
XAML
Copy
​<microcharts:MicroLineSeries ItemsSource="{Binding Counts}" />

Complex Collections

Collections of custom complex objects can also be used. In this case, the XPath and/or YPath properties must be set to the name of a property on the objects in the collection.

For example, consider the following custom object:

C#
VB
Copy
​public class SalesData {

    private decimal amount;
    private DateTime date;

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // OBJECT
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Initializes a new instance of the <c>SalesData</c> class.
    /// </summary>
    /// <param name="date">The date for which the amount is specified.</param>
    /// <param name="amount">The sales amount.</param>
    public SalesData(DateTime date, decimal amount) {
        this.date = date;
        this.amount = amount;
    }

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // PUBLIC PROCEDURES
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Gets the sales amount.
    /// </summary>
    /// <value>The sales amount.</value>
    public decimal Amount {
        get {
            return amount;
        }
    }

    /// <summary>
    /// Gets the date for which the amount is specified.
    /// </summary>
    /// <value>The date for which the amount is specified.</value>
    public DateTime Date {
        get {
            return date;
        }
    }

}
​Public Class SalesData

    Private amount_Renamed As Decimal
    Private date_Renamed As DateTime

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' OBJECT
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Initializes a new instance of the <c>SalesData</c> class.
    ''' </summary>
    ''' <param name="date">The date for which the amount is specified.</param>
    ''' <param name="amount">The sales amount.</param>
    Public Sub New(ByVal [date] As DateTime, ByVal amount As Decimal)
        Me.date_Renamed = [date]
        Me.amount_Renamed = amount
    End Sub

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' PUBLIC PROCEDURES
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Gets the sales amount.
    ''' </summary>
    ''' <value>The sales amount.</value>
    Public ReadOnly Property Amount() As Decimal
        Get
            Return amount_Renamed
        End Get
    End Property

    ''' <summary>
    ''' Gets the date for which the amount is specified.
    ''' </summary>
    ''' <value>The date for which the amount is specified.</value>
    Public ReadOnly Property [Date]() As DateTime
        Get
            Return date_Renamed
        End Get
    End Property

End Class

We can specify that the Y values should be pulled from the Amount property by setting YPath to "Amount". If we want to use the index in the collection as our X values, then we do not need to set XPath.

If instead we want the X values to be pulled from the Date property, then we would need to set XPath to "Date".

Note Note
You can traverse complex hierarchies to get to the value you need by using a property path that is delimited by a period ("."). For example you can set XPath or YPath to something like "MyProperty.MyOtherProperty.MyDoubleValue", similar to how binding paths work in XAML.
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The chart control contains several other features that can be used to customize the appearance.

Baseline

A baseline value can be used to alter the look of area, bar, and win/loss series, and can be optionally displayed on the chart.

See the Baseline topic for more information.

Hot Tracking

Hot tracking displays a customizable tooltip which contains the values of the data point closest to the end-user's mouse cursor.

See the Hot Tracking topic for more information.

Palettes

There are an enormous number of configuration options related to palettes. The various brushes used by the chart can be easily customized using a palette of colors or the styles can be completely overridden.

See the Palettes topic for more information.

Ranges

Specific value ranges of the chart can be highlighted to convey additional information to the end-user.

See the Ranges topic for more information.

Series Visibility

The visibility of any series can be set to dictate whether or not it is rendered on the chart.

See the Series Visibility topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Baseline

A baseline value can be used to alter the look of area, bar, and win/loss series, and can be optionally displayed on the chart.

This topic contains these sections:

  • Baseline Value
  • Baseline Visibility and Style

Baseline Value

The baseline value determines what the chart considers "positive" and "negative" values. Any value greater than or equal to the baseline value is considered positive, and any value less than the baseline value is considered negative.

The baseline value can be customized using the MicroXYChart.AxisBaselineValue property, which defaults to 0 for numeric values and DateTime.MinValue for date/time.

This positive/negative distinction can affect which style is used for various elements in the chart. For example, when enabled the MarkerNegativeStyle style will be used for any markers below the baseline value, while values above it will use the MarkerStyle style.

In addition, area, bar, and win/loss series will pivot their polygons around the baseline value, which alters their appearance.

In the following examples, the data rendered by the area chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum. Since our baseline is 0 (the default), the polygon is not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the polyon will appear to pivot around the baseline.

Finally, if we enable the use of negative styles then the portions of the polygon below the baseline use a distinct style.

Baseline Visibility and Style

An actual line can be rendered at the specified baseline value to highlight its location in the chart. The visibility of the line is configured using the IsAxisBaselineVisible property, which is false by default.

For example, the following line series uses the same fixed values from above (10, 20, 10, 20, 10, 20, 10) and a baseline value of 15. In this particular example, since the line is rendered with a single color, it is not possible to visually determine what is considered above or below the baseline.

If we set IsAxisBaselineVisible to True, then we can easily determine this information.

The style of the line can be customized using the AxisBaselineStyle property. The associated Style should target the Shape type, which includes properties such as Stroke and StrokeThickness.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Hot Tracking

Hot tracking displays a customizable tooltip which contains the values of the data point closest to the end-user's mouse cursor.

This topic contains these sections:

  • Enabling Hot-Tracking
  • Legend String Format
  • Legend Marker Style
  • Legend Item Template

Enabling Hot-Tracking

Hot-tracking can be enabled by setting the MicroXYChart.IsHotTrackingEnabled property to true. It is set to false by default.

Once enabled, as the end user's mouse moves over the chart, values nearest the mouse will display in a tooltip. The tooltip's contents can be completely customized via the various series-oriented legend settings discussed below.

Legend String Format

The legend's string format is the easiest way to customize what is displayed in a tooltip for a series. The series-specific string format is set via the MicroXYSeriesBase.LegendStringFormat property. By default the value of the primary axis is displayed.

Format Parameter | Description
{0} | The value of the primary axis, generally the Y value.
{1} | The value of the secondary axis, generally the X value.
{2} | The X value.
{3} | The Y value.
{4} | Reserved for future use.
{5} | The series description, as indicated in the MicroXYSeriesBase.Description property.

This example shows the display of both X and Y values. Note how numeric formatting is used on the Y value.

XAML
Copy
​<microcharts:MicroLineSeries ... LegendStringFormat="{}X: {2}, Y: {3:F2}" />

This example shows two series in the same chart, and each indicates its own description and value.

XAML
Copy
​<microcharts:MicroLineSeries ... Description="{Binding DataSet[0].Name}" LegendStringFormat="{}{5}: {0:C0}" />
<microcharts:MicroLineSeries ... Description="{Binding DataSet[1].Name}" LegendStringFormat="{}{5}: {0:C0}" />

Legend Marker Style

The legend markers, used to render a series' base color in front of its string formatted display value within the tooltip, use a square shape by default. This shape renders using the style assigned to the MicroXYSeriesBase.LegendMarkerStyle property.

By setting that property to another Style that targets the MicroChartMarker type, the shape used in the tooltip can be customized. Properties such as Fill, Stroke, StrokeThickness, and ShapeKind can be set.

See the Scatter chart type topic for more information on available shape kinds.

Legend Item Template

The default legend item template renders the legend marker to the left of the string formatted display value. This can be customized if a different layout is preferred, by setting the MicroXYSeriesBase.LegendItemTemplate property with an alternate DataTemplate.

This example shows the default DataTemplate used:

XAML
Copy
​<DataTemplate>
    <Grid>
        <Grid.ColumnDefinitions>
            <ColumnDefinition Width="Auto" />
            <ColumnDefinition Width="*" />
        </Grid.ColumnDefinitions>
        <microcharts:MicroChartMarker Width="8" Height="8" Style="{Binding MarkerStyle}" VerticalAlignment="Center" />
        <TextBlock Grid.Column="1" Margin="3,0,0,0" Text="{Binding Text}" />
    </Grid>
</DataTemplate>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Palettes

There are an enormous number of configuration options related to palettes. The various brushes used by the chart can be easily customized using a palette of colors or the styles can be completely overridden.

This topic contains these sections:

  • Introduction
  • Built-In Palettes
  • Palette Color Selection
  • Palette Shade Generation
  • Custom Palette Colors
  • Customizing Highlight Effect Brushes

Introduction

When any series is being rendered within a chart, it uses the chart's MicroChartBase.SeriesStyleSelector to determine which styles to apply to the various shapes displayed. These shapes include the basic shapes representing lines, areas, bars, markers, etc.

For instance, by default a line series that shows all markers will render the markers in the same color. An option can be set to apply highlight effects (different brushes) to certain markers such as the first/last, high/low, or negative ones. Similar options are available where appropriate for lines, areas, and bars. These highlight effects are achieved by the series style selector telling the chart which style to use. Normal markers get their style from a MicroSeriesStyleSelector.SelectMarkerStyle call. If the series has indicated it wants negative value markers to be rendered differently, the negative value markers get their style from a MicroSeriesStyleSelector.SelectMarkerNegativeStyle call, and so on for other highlight effects.

The MicroSeriesPaletteStyleSelector class inherits MicroSeriesStyleSelector and provides many settings that can be used to completely customize how a chart renders its series.

An important thing to note is that the MicroSeriesPaletteStyleSelector builds shape styles based on colors defined in a MicroPalette that has been assigned to its Palette property. The palette contains multiple colors so that when more than one series is used in a chart, each series will cycle to use a different palette color.

Built-In Palettes

Numerous built-in palettes are included with the product, each named via a value within the MicroPaletteKind enumeration.

A built-in palette can be assigned to a chart like this (in this case the Roman palette):

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18">
    <microcharts:MicroXYChart.SeriesStyleSelector>
        <microcharts:MicroSeriesPaletteStyleSelector>
            <microcharts:MicroPalette Kind="Roman" />
        </microcharts:MicroSeriesPaletteStyleSelector>
    </microcharts:MicroXYChart.SeriesStyleSelector>
    ...
</microcharts:MicroXYChart>

For simple cases where no other customization is needed on the MicroSeriesPaletteStyleSelector, the palette kind can simply be set as an attribute value as well, where the text specified matches one of the MicroPaletteKind values:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" SeriesStyleSelector="Roman">
    ...
</microcharts:MicroXYChart>

Palette Color Selection

Each palette has two mode options for how colors will be assigned to series in a chart. The mode is set by specifying a MicroColorSelectionHint value on the MicroPalette.ColorSelectionHint property.

Mode | Description
Sequential | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
UniformDistribution | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.

The default is to use UniformDistribution mode on the built-in palettes, and Sequential mode on custom palettes.

Palette Shade Generation

Each palette has a list of base colors used directly as the core color for each series in a chart. Most palettes define six colors. But what happens when there are more than six series in a chart?

If shade generation is enabled on a palette, via its MicroPalette.IsShadeGenerationEnabled property, additional darker and lighter shades of the base colors will be generated and used for the other series. By default, this feature is enabled.

If this feature is disabled, the color assignments will recycle and the seventh series will simply use the first base color again, and so on.

Custom Palette Colors

It's very easy to create custom palettes. Simply create a MicroPalette and assign the custom colors to its BaseColors collection.

This sample shows the creation of a palette that contains two custom colors:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18">
    <microcharts:MicroXYChart.SeriesStyleSelector>
        <microcharts:MicroSeriesPaletteStyleSelector>
            <microcharts:MicroPalette>
                <Color>#46bff7</Color>
                <Color>#06226b</Color>
            </microcharts:MicroPalette>
        </microcharts:MicroSeriesPaletteStyleSelector>
    </microcharts:MicroXYChart.SeriesStyleSelector>
    ...
</microcharts:MicroXYChart>

Note Note
When multiple series are used in a chart, make sure that your palette has enough base color entries to match or exceed your series count. Or ensure that the shade generation feature (described above) is active.

Customizing Highlight Effect Brushes

As described in the introduction above, there are many ways certain data points (and related markers, bars, etc.) can be highlighted. The MicroSeriesPaletteStyleSelector class has an enormous number of property-based options for customizing highlight effects:

  • Area (also used for bars) - Normal, high, low, negative
  • Line - Normal, negative
  • Marker - Normal, first, last, high, low, negative

Each of these options generally has three properties on MicroSeriesPaletteStyleSelector, such as these for normal areas:

  • AreaBrushCustom
  • AreaBrushKind
  • AreaTintColor

Custom Brush

A custom Brush, if specified via properties like AreaBrushCustom, will cause the related shape (in this case, a normal area) to directly use that brush for rendering.

Brush Kind

A brush kind can be specified via properties like AreaBrushKind. This kind is of type MicroSeriesBrushKind and has many values that can "modify" the palette color assigned to the series:

  • Default - Use the exact palette color.
  • Light - Use a slightly lighter version of the palette color.
  • Dark - Use a slightly darker version of the palette color.
  • SemiTransparent - Use a semi-transparent version of the palette color.
  • DarkToLightGradient - Use a gradient, from the Dark to Light color.
  • LightToDarkGradient - Use a gradient, from the Light to Dark color.
  • Complement - Use a complement of the Default color.
  • ComplementLight - Use a complement of the Light color.
  • ComplementDark - Use a complement of the Dark color.
  • ComplementSemiTransparent - Use a semi-transparent version of the Default color.
  • ComplementDarkToLightGradient - Use a gradient, from the ComplementDark to ComplementLight color.
  • ComplementLightToDarkGradient - Use a gradient, from the ComplementLight to ComplementDark color.

By using a brush kind setting instead of specifying an exact custom brush, the brush used for each series will be relative to the palette color assigned to that series.

Tint Color

A tint color can be set via properties like AreaTintColor. If specified, the tint will be applied to the resulting brush from the brush kind setting. The tint color is not used if a custom brush is directly set.

The default usage of tint colors is for high areas/markers to tint towards green, and low areas/markers to tint towards red.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ranges

Specific value ranges of the chart can be highlighted to convey additional information to the end-user.

A line chart with a green and red range for positive and negative values, respectively

This topic contains these sections:

  • Orientation
  • Minimum and Maximum Values

Orientation

By default, ranges will be aligned horizontally, which means they highlight value ranges along the Y-axis. A vertical range can be created by setting the Orientation property to Vertical. Vertical ranges highlight value ranges along the X-axis.

A line chart with a yellow range between the X values 2 and 5

In this example, the line series is set to a collection of doubles. Therefore, the X values will range from 0 to 7 (since there are 8 entries) and the actual values shown will be used along the Y axis:

XAML
Copy
​<microcharts:MicroXYChart Width="130" Height="40">
    <microcharts:MicroLineSeries ItemsSource="4;-5;3;6;9;-9;1;5" MarkerVisibility="All" MarkerStyleKinds="All" />
    <microcharts:MicroXYChart.Ranges>
        <microcharts:MicroXYRange Background="#88FFFF00" Minimum="2" Maximum="5" Orientation="Vertical"/>
    </microcharts:MicroXYChart.Ranges>
</microcharts:MicroXYChart>

Minimum and Maximum Values

The values of a range are specified using the Maximum and Minimum properties.

If either of these properties is unset (or set to null), then it's value will be auto-calculated based on the data points from all series. The Maximum will run to the highest value and likewise the Minimum will run to the lowest value.

For example, we can produce two ranges that run up (green) and down (red) from 0 using the following code:

XAML
Copy
​<microcharts:MicroXYChart Width="130" Height="40">
    <microcharts:MicroLineSeries ItemsSource="4;-5;3;6;9;-9;1;5" MarkerVisibility="All" MarkerStyleKinds="All" />
    <microcharts:MicroXYChart.Ranges>
        <microcharts:MicroXYRange Minimum="0">
            <microcharts:MicroXYRange.Background>
                <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                    <GradientStop Color="Transparent" Offset="0" />
                    <GradientStop Color="#2200FF00" Offset="1" />
                </LinearGradientBrush>
            </microcharts:MicroXYRange.Background>
        </microcharts:MicroXYRange>
        <microcharts:MicroXYRange Maximum="0">
            <microcharts:MicroXYRange.Background>
                <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                    <GradientStop Color="#22FF0000" Offset="0" />
                    <GradientStop Color="Transparent" Offset="1" />
                </LinearGradientBrush>
            </microcharts:MicroXYRange.Background>
        </microcharts:MicroXYRange>
    </microcharts:MicroXYChart.Ranges>
</microcharts:MicroXYChart>

This produces the following chart:

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Series Visibility

The visibility of any series can be set to dictate whether or not it is rendered on the chart.

Usage

The visibility of a series can be changed in order to create the ability to show/hide the series on the chart. With this feature several series can be contained within a chart then their visibilities can be manipulated to better compare just a couple at a time. The visibility of a series can be customized with the MicroSeriesBase.Visibility property, which defaults to Visible.

In this example, the visibility property of the line series is bound to the IsChecked property of the checkbox so that the series is shown when checked and not shown when unchecked:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" IsHotTrackingEnabled="True">
    <microcharts:MicroBarSeries Description="New York" ItemsSource="581415; 591966; 492003; 460123; 523962; 622962; 649196; 789123; 800124; 750126; 741612; 720556" LegendStringFormat="{}{5}: {0:C0}"/>
    <microcharts:MicroLineSeries Description="Los Angeles" ItemsSource="318624; 358185; 381725; 310128; 251929; 370125; 380120; 354501; 263105; 492031; 423123; 380125" LegendStringFormat="{}{5}: {0:C0}"
        Visibility="{Binding IsChecked, ElementName=seriesVisibleCheckBox, Converter={StaticResource BooleanToVisibilityConverter}}"/>
</microcharts:MicroXYChart>
...
<CheckBox x:Name="seriesVisibleCheckBox" Content="Los Angeles series visible" IsChecked="True"/>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Micro Charts has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to quickly create your charts and series.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • MicroXYChart Context Menu
  • Task Pane Introduction
  • MicroXYChart Task Pane
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

MicroXYChart Context Menu

A context menu for the MicroXYChart control is provided. You can right click on the control in the designer to display the context menu.

A MicroXYChart context menu in the Visual Studio designer

Use the context menu options to add new series or remove all the series in a chart.

Task Pane Introduction

Whenever you select a MicroXYChart control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

MicroXYChart Task Pane

Use the task pane options to add, remove, or arrange series, configure tha axes, set the baseline, and enable hot tracking.

The MicroXYChart task pane provides quick access for adding, removing, or arranging series. It can also be used to configure the axes, baseline, hot tracking, and style selector.

The task pane for the MicroXYChart control in the Visual Studio designer

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Navigation is a control suite that includes NavigationBar, ExplorerBar, Breadcrumb, and ZoomContentControl controls, along with styles for animated Expander controls.

NavigationBar

NavigationBar provides a facility for navigating through different panes of data. This concept was introduced in Outlook, and NavigationBar implements all of the features found in Office. It has an elegant user interface which uses buttons to control which navigation pane is selected. Panes can display data or simply act as a container for child controls.

The NavigationBar control in its Office blue theme

If screen real estate is available, large buttons can be used for pane selection. The end-user has the option of using a splitter to move the large buttons into the overflow button tray, which uses smaller buttons. If not all of the buttons can fit in that tray, they flow out into the overflow menu, accessible by the chevron button.

The NavigationBar can also be minimized, so that its selected pane's content can be displayed in a popup by clicking a button.

End user layout customizations can be persisted in XML format and restored later.

ExplorerBar

Explorer bar is an implementation of the task bar that was introduced in Windows XP's explorer. It hosts a vertical stack of expandable panes that generally provide task-based information to the end user.

The ExplorerBar control in its Luna normal-color theme

Each expander pane uses smooth animation to fade in and slide down its contents when expanded. Likewise, when an expander pane is collapsed, its contents fade out and slide back up. Any content can be placed within each expander pane and the alternate style of pane headers is supported via a simple style setting.

Breadcrumb

Breadcrumb is an implementation of the breadcrumb that was introduced in Windows Vista's explorer. It can be used to select a single item from hierarchical data, much like a TreeView but requiring less screen real estate.

The Breadcrumb control in its Aero normal-color theme

Hierarchical data can be navigated using the buttons and menus available for each item, or the user can manually enter a new path or select an item from the drop-down list. If not all of the items can fit in control, they flow out into an overflow menu, accessible by a chevron button.

The progress of long running operations can be presented to the user via an embedded progress bar in the Breadcrumb control. In addition, any number of custom action buttons can be added to the right side.

ZoomContentControl

ZoomContentControl allows any content to be interactively zoomed and scrolled using customizable mouse and keyboard behaviors. Includes an optional built-in view control pane, which can be used to zoom or pan the content and collapsed when not needed. Numerous methods, properties, and commands are provided which can be used to programmatically zoom/pan the display.

The ZoomContentControl control showing some custom content

Features

Breadcrumb Features

  • Duplicates all functionality found in the Windows Vista explorer breadcrumb control.
  • Built-in themes for Aero, Luna blue/olive/silver, classic, and royale.
  • Allows the selected item to be set using numerous methods.
  • Includes an edit mode, which allows the selected path to be modified directly.
  • Fully customizable drop-down list, which can contain recent items, favorite items, or any other custom items.
  • Auto-minimizes any number of non-selected items.
  • Hides items when the selected trail cannot fit into the current width of the control.
  • Integrated progress bar, which is displayed in the background.
  • Support for tail items, which allow for faster navigation down the hierarchy.
  • Support for custom action buttons shown on the right side of the control.
  • Support for HierarchicalDataTemplate.

ExplorerBar Features

  • Duplicates all functionality found in the Windows XP explorer bar.
  • Built-in themes for Luna blue/olive/silver, classic, and royale.
  • Displays a vertical list of expanders that use animation to fade and slide when expanding/collapsing.
  • Optionally only allow one expander to be expanded at a time.
  • Alternate style can be applied to an individual expander to give it emphasis.
  • Place text and images in expander headers.
  • Vertical scrollbar automatically added when expanders exceed container height.

NavigationBar Features

  • Duplicates all functionality found in the Office navigation bar.
  • Built-in themes for Office blue/black/silver, Luna blue/olive/silver, classic, and high-contrast.
  • Buttons provide single-click access to each pane.
  • Buttons can be collapsed to an overflow area, allowing for more client area real estate.
  • Entire bar may be minimized, with a button that can be clicked to display a popup containing the selected pane's content.
  • Minimize to both left and right sides.
  • Customize button provides access to customization features and hidden buttons.
  • Ability to alter the menu displayed by the customize button.
  • Built-in Navigation Bar Options dialog for reordering buttons and controlling which buttons are visible.
  • Automated reset button order functionality.
  • Support for large and small image sizes.
  • Ability to disable specific pane buttons.
  • Optionally hide pane buttons to use as a headered container.
  • Persist end user layout customizations to XML.

ZoomContentControl Features

  • Adds zooming and panning capabilities to the native WPF ContentControl.
  • Supports smooth animations when zooming and panning.
  • Vertical and horizontal scrollbars can be used for panning or hidden.
  • Mouse and keyboard behavior can be easily customized using standard WPF input bindings.
  • Built-in support for numerous commands with associated mouse cursors.
  • Exposes several methods and properties that can be used to manipulate the view.
  • Includes an optional standard view control pane that can be used to zoom and pan the view.
  • Standard view control pane is collapsable or it can be fixed.
  • Add custom buttons to the horizontal bar of the view control pane.
  • Built-in styles for use with various button controls that match the view control pane look.
  • Support for custom overlay elements which can be anchored, but not zoomed.

Layout, Globalization, and Accessibility Features

  • Right-to-left support is fully integrated for languages such as Hebrew or Arabic.
  • All text properties use localization attributes, and string resources may be customized.
  • Follows the WPF accessibility model for UI automation.

Code and Requirements

  • Includes detailed documentation and a sample project that demos nearly every feature.
  • Written in 100% pure C# and is based on the Windows Presentation Foundation framework.
  • Requires the .NET 4.0 or later run-time framework.
  • Full XAML support and XBAP compatibility.
  • Extensive Visual Studio and Expression Blend designer capabilities.
  • Visual Studio and/or Expression Blend are recommended development tools for this product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Getting up and running with Navigation controls is extremely easy.

This topic's information will assume you are using Visual Studio to write your XAML code for a WPF Window that will contain one of the Navigation controls.

This topic contains these sections:

  • Add Assembly References
  • The Visual Studio Item Templates for Navigation Controls
  • Getting Started with Breadcrumb
  • Getting Started with ExplorerBar
  • Getting Started with NavigationBar
  • Getting Started with ZoomContentControl
  • Further Study

Add Assembly References

First, add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.Navigation.Wpf.dll assemblies. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

The Visual Studio Item Templates for Navigation Controls

If you have Visual Studio, item templates named Navigation Bar Window (WPF) and Explorer Bar Window (WPF) should have been installed during the WPF Studio installation procedure.

When you wish to create a new Window containing one of the Navigation controls in your application, simply choose Add New Item in Visual Studio and select the appropriate the item template. A Window with the related Navigation control on it will be added to your project and opened.

The use of item templates is the fastest way to get started with our products in your own applications.

Getting Started with Breadcrumb

This code shows the base XAML that you can use to create a simple Breadcrumb with a few items:

XAML
Copy
​xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
xmlns:navigation="http://schemas.actiprosoftware.com/winfx/xaml/navigation"
...

<navigation:Breadcrumb Width="200">
    <navigation:BreadcrumbItem Header="RootItem" PathEntry="RootItem">
        <navigation:BreadcrumbItem Header="Folder 1" PathEntry="Folder 1">
            <navigation:BreadcrumbItem Header="Subfolder 1" PathEntry="Subfolder 1" />
            <navigation:BreadcrumbItem Header="Subfolder 2" PathEntry="Subfolder 2" />
        </navigation:BreadcrumbItem>
        <navigation:BreadcrumbItem Header="Folder 2" PathEntry="Folder 2">
            <navigation:BreadcrumbItem Header="Subfolder 3" PathEntry="Subfolder 3" />
            <navigation:BreadcrumbItem Header="Subfolder 4" PathEntry="Subfolder 4" />
        </navigation:BreadcrumbItem>
    </navigation:BreadcrumbItem>
</navigation:Breadcrumb>

Getting Started with ExplorerBar

This code shows the base XAML that you can use to create a simple ExplorerBar with two panes:

XAML
Copy
​xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
xmlns:navigation="http://schemas.actiprosoftware.com/winfx/xaml/navigation"
...
<navigation:ExplorerBar Width="200">
    <shared:AnimatedExpander Header="Pane 1" IsExpanded="True">
        <TextBlock Text="Content here" />
    </shared:AnimatedExpander>
    <shared:AnimatedExpander Header="Pane 2" IsExpanded="True">
        <TextBlock Text="Content here" />
    </shared:AnimatedExpander>
</navigation:ExplorerBar>

Getting Started with NavigationBar

This code shows the base XAML that you can use to create a simple NavigationBar with two panes:

XAML
Copy
​xmlns:navigation="http://schemas.actiprosoftware.com/winfx/xaml/navigation"
...
<navigation:NavigationBar ContentWidth="160" MaxWidth="250">
    <navigation:NavigationPane x:Name="firstPane" Title="Pane 1">
        <TextBlock Margin="10" Text="Content here" TextWrapping="Wrap" />
    </navigation:NavigationPane>
    <navigation:NavigationPane x:Name="secondPane" Title="Pane 2">
        <TextBlock Margin="10" Text="Content here" TextWrapping="Wrap" />
    </navigation:NavigationPane>
</navigation:NavigationBar>

Getting Started with ZoomContentControl

This code shows the base XAML that you can use to create a simple ZoomContentControl with a few items:

XAML
Copy
​xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
xmlns:navigation="http://schemas.actiprosoftware.com/winfx/xaml/navigation"
...

<navigation:ZoomContentControl>
    <shared:ActiproLogo />
</navigation:ZoomContentControl>

Further Study

It's very easy to use the various Navigation controls and there are probably a lot of great features that you aren't aware of.

Run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of the controls.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Breadcrumb is a control that presents a selected item from a hierarchy in a linear fashion.

Some of the more major features include:

  • Duplicates all functionality found in the Windows Vista explorer breadcrumb control.
  • Built-in themes for Aero, Luna blue/olive/silver, classic, and royale.
  • Allows the selected item to be set using numerous methods.
  • Includes an edit mode, which allows the selected path to be modified directly.
  • Fully customizable drop-down list, which can contain recent items, favorite items, or any other custom items.
  • Auto-minimizes any number of non-selected items.
  • Hides items when the selected trail cannot fit into the current width of the control.
  • Integrated progress bar, which is displayed in the background.
  • Support for tail items, which allow for faster navigation down the hierarchy.
  • Support for custom action buttons shown on the right side of the control.
  • Support for HierarchicalDataTemplate.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Action Buttons

The Breadcrumb control supports custom action buttons, which are presented on the right side of the control. These buttons can be used to perform any operation, however for proper usage their purpose should be related to the nodes represented in the Breadcrumb.

The Breadcrumb control using the Aero theme with various action buttons

This topic contains these sections:

  • Adding an Action Button
  • Supported Commands
  • Associated Members

Adding an Action Button

Any Button, or Button derived class, can be added to the ActionButtons collection property using XAML (as shown below) or by calling the Add or Insert methods directly. Because the embedded progress bar can be shown under the action buttons, it is recommended that the PopupButton control (with its transparency mode enabled) be used for action buttons.

This sample code shows how to add an action button:

XAML
Copy
​xmlns:navigation="http://schemas.actiprosoftware.com/winfx/xaml/navigation"
xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
...
<navigation:Breadcrumb ... >
    <navigation:Breadcrumb.ActionButtons>
        <!-- Define action buttons here -->
        <shared:PopupButton Content="New PopupButton"
                            DisplayMode="ButtonOnly"
                            IsRounded="false"
                            IsTransparencyModeEnabled="true" />
    </navigation:Breadcrumb.ActionButtons>
</navigation:Breadcrumb>

Supported Commands

The Breadcrumb supports the following NavigationCommands:

Routed Command | Action Performed
BrowseHome | Selects the root item.
FirstPage | Selects the root item.
GoToPage | Selects the item whose path is indicated by the command parameter.
LastPage | Selects the last visible item below the currently selected item. This command is only valid when 1 or more tail items are visible.
NextPage | Selects the next visible item below the currently selected item. This command is only valid when 1 or more tail items are visible.
PreviousPage | Selects the parent item of the currently selected item.

Associated Members

The following Breadcrumb members are associated with action buttons:

Member | Description
ActionButtons Property | Gets the action buttons shown on the right side of the breadcrumb control.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Auto-Minimize

The Breadcrumb control can be configured to automatically minimize any number of items, not including the selected item. By default, only the root item is minimized when it is no longer selected.

The Breadcrumb control using the Aero theme with the Desktop item minimized

This topic contains these sections:

  • Setting Auto Minimize Count
  • Customizing Minimized Items
  • Associated Members

Setting Auto Minimize Count

The number of items automatically minimized is controlled by the Breadcrumb.AutoMinimizeItemCount property. This number counts down from the top of the hierarchy and can include tail items. The selected item is never minimized, but is counted. Therefore, this count can also be thought of as the level in the hierarchy tree.

For example, if AutoMinimizeItemCount is set to 2 then only the root item and its direct children are ever eligible for minimization.

Customizing Minimized Items

By default, minimized items will only show the popup indicator button, but this look can be fully customized using the Breadcrumb.ItemMinimizedTemplate property.

Typically, all minimized items in the Breadcrumb would use the template defined in Breadcrumb.ItemMinimizedTemplate. But, it is possible to override this template at various points in the hierarchy by setting the BreadcrumbItem.ItemMinimizedTemplate property to a different template.

Associated Members

The following Breadcrumb members are associated with auto-minimizing:

Member | Description
AutoMinimizeItemCount Property | Gets or sets the number of items that will be automatically minimized, starting from root item.
ItemMinimizedTemplate Property | Gets or sets the DataTemplate used to display each minimized item in the trail.
ItemMinimizedTemplateSelector Property | Gets or sets the custom logic for choosing a template used to display each minimized item in the trail.

The following BreadcrumbItem members are associated with auto-minimizing:

Member | Description
IsMinimized Property | Gets a value indicating whether the item is minimized.
ItemMinimizedTemplate Property | Gets or sets the DataTemplate used to display each minimized item in the trail.
ItemMinimizedTemplateSelector Property | Gets or sets the custom logic for choosing a template used to display each minimized item in the trail.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context Menus

The Breadcrumb control displays context menus when the overflow button is clicked and when the popup button on the individual items is clicked. These context menus are automatically populated by the Breadcrumb control, but can be customized during runtime.

This topic contains these sections:

  • Customizing the Menu
  • Menu and Text Alignment
  • Associated Members

Customizing the Menu

You can completely customize the default ContextMenus or even supply an alternate menu by handling the Breadcrumb.OverflowButtonClick or BreadcrumbItem.NavigateButtonClick events. The Item property of the event arguments is the ContextMenu that will be displayed. Add/update/remove menu items as necessary there.

In addition, there are numereous properties listed below, which allow the look of the context menus to be customized as well.

Menu and Text Alignment

The menus displayed by the Breadcrumb control are offset from their associated drop-down button for better alignment. This offset varies based on the theme loaded and defaults to values appropriate for ContextMenus using the same theme. Therefore, the Aero theme for the Breadcrumb control assumes that the menus will also be using the Aero theme and adjusts the offset accordingly.

The menu offset can be customized as needed by setting MenuHorizontalOffset or MenuVerticalOffset, either on the Breadcrumb control or the individual BreadcrumbItem controls. Typically, only the horizontal offset should be adjusted.

When defining a custom DataTemplate for MenuItemTemplate or MenuItemExpandedTemplate, a 2-pixel margin should typically be included on the left side. This 2-pixel margin allows the text in the menu to line up with the text of the next BreadcrumbItem, which is more visually appealing. When using the default DataTemplates, the 2-pixel margin is already defined.

Associated Members

The following Breadcrumb members are associated with the context menus:

Member | Description
MenuHorizontalOffset Property | Gets or sets the horizontal distance between the target origin and the content menu alignment point.
MenuItemContainerExpandedStyle Property | Gets or sets the Style that is applied to the MenuItem elements generated for expanded items in context menus.
MenuItemContainerExpandedStyleSelector Property | Gets or sets custom logic for choosing a Style that can be applied to MenuItem elements generated for expanded items in context menus.
MenuItemContainerStyle Property | Gets or sets the Style that is applied to the MenuItem elements generated for items in context menus.
MenuItemContainerStyleSelector Property | Gets or sets custom logic for choosing a Style that can be applied to MenuItem elements generated for items in context menus.
MenuItemExpandedTemplate Property | Gets or sets the DataTemplate used to display expanded items in a MenuItem.
MenuItemExpandedTemplateSelector Property | Gets or sets the custom logic for choosing a template used to display expanded items in a MenuItem.
MenuItemTemplate Property | Gets or sets the DataTemplate used to display items in a MenuItem.
MenuItemTemplateSelector Property | Gets or sets the custom logic for choosing a template used to display items in a MenuItem.
MenuVerticalOffset Property | Gets or sets the vertical distance between the target origin and the content menu alignment point.
OverflowButtonClick Event | Occurs when the overflow button is clicked, allowing for customization of the ContextMenu it will display.

The following BreadcrumbItem members are associated with the context menus:

Member | Description
MenuHorizontalOffset Property | Gets or sets the horizontal distance between the target origin and the content menu alignment point.
MenuItemContainerExpandedStyle Property | Gets or sets the Style that is applied to the MenuItem elements generated for expanded items in context menus.
MenuItemContainerExpandedStyleSelector Property | Gets or sets custom logic for choosing a Style that can be applied to MenuItem elements generated for expanded items in context menus.
MenuItemContainerStyle Property | Gets or sets the Style that is applied to the MenuItem elements generated for items in context menus.
MenuItemContainerStyleSelector Property | Gets or sets custom logic for choosing a Style that can be applied to MenuItem elements generated for items in context menus.
MenuItemExpandedTemplate Property | Gets or sets the DataTemplate used to display expanded items in a MenuItem.
MenuItemExpandedTemplateSelector Property | Gets or sets the custom logic for choosing a template used to display expanded items in a MenuItem.
MenuItemTemplate Property | Gets or sets the DataTemplate used to display items in a MenuItem.
MenuItemTemplateSelector Property | Gets or sets the custom logic for choosing a template used to display items in a MenuItem.
MenuVerticalOffset Property | Gets or sets the vertical distance between the target origin and the content menu alignment point.
NavigateButtonClick Event | Occurs when the navigate button is clicked, allowing for customization of the ContextMenu it will display.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Edit Mode

The Breadcrumb control supports an edit mode, in which the user can manually type a new path or select an item from a drop-down list. The edit mode is supported using an embedded ComboBox, whose drop-down items can be fully customized. Typically, this list would include recently selected items and/or favorite items.

The user can enter edit mode by:

  • Pressing the Space key when the breadcrumb has the keyboard focus
  • Clicking on the icon on the left
  • Clicking in the empty space on the right
  • Opening the drop-down list

The user can exit edit mode by:

  • Pressing the Enter key when the text box has the keyboard focus
  • Pressing the Escape key when the text box has the keyboard focus (any changes will be discarded)
  • Selecting an item from the drop-down list
  • Moving focus away from the Breadcrumb control (any changes will be discarded)

The Breadcrumb control using the Aero theme in edit mode and drop-down list open

This topic contains these sections:

  • Disabling Edit Mode
  • Populating the Drop-Down List
  • Associated Members

Disabling Edit Mode

The edit mode can be disabled by setting the IsEditable property to false. When the edit mode is disabled, the drop-down list is hidden and the user cannot directly enter a path.

Populating the Drop-Down List

The embedded combo box drop-down list is populated using the ComboBoxItemsSource property. This property can be set in the same manner as the ComboBox.ItemsSource property.

Note Note
Logic to convert a combo box item to a trail must be provided. See the Item Conversion topic for more information.

Associated Members

The following Breadcrumb members are associated with edit mode:

Member | Description
ComboBoxIsReadOnly Property | Gets or sets a value that enables selection-only mode, in which the contents of the embedded combo box are selectable but not editable. The default value is false.
ComboBoxItemContainerStyle Property | Gets or sets the Style that is applied to the ComboBoxItem elements generated for items in the embedded combo box. The default value is null.
ComboBoxItemContainerStyleSelector Property | Gets or sets custom logic for choosing a Style that can be applied to ComboBoxItem elements generated by the embedded combo box. The default value is null.
ComboBoxItemsSource Property | Gets or sets a collection used to generate the content of the embedded combo box. The default value is null.
ComboBoxItemTemplate Property | Gets or sets the DataTemplate used to display each item in the embedded combo box. The default value is null.
ComboBoxItemTemplateSelector Property | Gets or sets the custom logic for choosing a template used to display each item in the embedded combo box. The default value is null.
ComboBoxStaysOpenOnEdit Property | Gets or sets whether the drop-down control for the embedded combo box will remain open when a user clicks the text area. The default value is false.
IsEditable Property | Gets or sets a value indicating whether the breadcrumb control can enter edit mode. The default value is true.
IsEditing Property | Gets or sets a value indicating whether the breadcrumb control is currently in edit mode. The default value is false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Hierarchical Data

When binding a WPF control, such as the Breadcrumb or TreeView controls, to a hierarchical data source you must specify how to locate the "child" items. This allows the WPF control to walk down the hierarchy and is typically done using the HierarchicalDataTemplate class. Although, this can also be accomplished using a Style.

This topic contains these sections:

  • Using a HierarchicalDataTemplate
  • Using a Style
  • Breadcrumb Considerations

Using a HierarchicalDataTemplate

The HierarchicalDataTemplate class can be used to define the look of the data and how to locate any child items. The look of the data is defined in the exact same manner as with the DataTemplate class, by specifying zero or more visual elements and binding them appropriately. The child items can be specified by setting the ItemsSource property on the HierarchicalDataTemplate class.

This sample code shows how to define a HierarchicalDataTemplate for the sample XML data below:

XAML
Copy
​<HierarchicalDataTemplate ItemsSource="{Binding XPath=MyXmlElement}"
                          ...>
    <TextBlock Text="{Binding XPath=@Name}" />
</HierarchicalDataTemplate>
XML
Copy
​<?xml version="1.0" encoding="utf-8" ?>
<MyXmlElement Name="Root Item">
    <MyXmlElement Name="First Child Item">
        <MyXmlElement Name="First Grandchild Item" />
        <MyXmlElement Name="Second Grandchild Item" />
    </MyXmlElement>
    <MyXmlElement Name="Second Child Item" />
</MyXmlElement>

As you can see, the Name attribute is used by the TextBlock control to define the look. The ItemsSource property is bound to the child MyXmlElement elements, which can be used by WPF controls to find any child items.

Since hierachical data is rarely this uniform, the ItemTemplate or ItemTemplateSelector properties of the HierarchicalDataTemplate class can be used to change the template as needed.

This sample code shows how to define a HierarchicalDataTemplate for the sample XML data below, which uses distinct elements at each level:

XAML
Copy
​<!-- Because this item does not have any child items we can use
     regular DataTemplate. -->
<DataTemplate x:Key="MyGrandchildXmlElementTemplate">
    <TextBlock Text="{Binding XPath=@Name}" />
</DataTemplate>

<HierarchicalDataTemplate x:Key="MyChildXmlElementTemplate"
                          ItemsSource="{Binding XPath=MyGrandchildXmlElement}"
                          ItemTemplate="{StaticResource MyGrandchildXmlElementTemplate}">
    <TextBlock Text="{Binding XPath=@Name}" />
</HierarchicalDataTemplate>

<HierarchicalDataTemplate x:Key="MyRootXmlElementTemplate"
                          ItemsSource="{Binding XPath=MyChildXmlElement}"
                          ItemTemplate="{StaticResource MyChildXmlElementTemplate}">
    <TextBlock Text="{Binding XPath=@Name}" />
</HierarchicalDataTemplate>
XML
Copy
​<?xml version="1.0" encoding="utf-8" ?>
<MyRootXmlElement Name="Root Item">
    <MyChildXmlElement Name="First Child Item">
        <MyGrandchildXmlElement Name="First Grandchild Item" />
        <MyGrandchildXmlElement Name="Second Grandchild Item" />
    </MyChildXmlElement>
    <MyChildXmlElement Name="Second Child Item" />
</MyRootXmlElement>

As you can see, we now define a HierarchicalDataTemplate for each distinct XML element and assign them appropriately as we move down the hierarchy.

Using a Style

A Style can also be used to to define the look of the data, using a DataTemplate, and how to locate any child items. This can be accomplished by setting the ItemsSource and ItemTemplate directly on the container elements, typically an ItemsControl-derived class, created for each data object. Examples of container elements include BreadcrumbItem and TreeViewItem.

This sample code shows how to define a Style for the sample XML data below:

XAML
Copy
​<!-- Used to define the look -->
<DataTemplate x:Key="MyXmlElementTemplate">
    <TextBlock Text="{Binding XPath=@Name}" />
</DataTemplate>

<Style ...>
    <Setter Property="ItemsSource"
            Value="{Binding XPath=MyXmlElement}" />
    <Setter Property="ItemTemplate"
            Value="{StaticResource MyXmlElementTemplate}" />
</Style>
XML
Copy
​<?xml version="1.0" encoding="utf-8" ?>
<MyXmlElement Name="Root Item">
    <MyXmlElement Name="First Child Item">
        <MyXmlElement Name="First Grandchild Item" />
        <MyXmlElement Name="Second Grandchild Item" />
    </MyXmlElement>
    <MyXmlElement Name="Second Child Item" />
</MyXmlElement>

As you can see, the DataTemplate class defines the look just like with the HierarchicalDataTemplate class. Although, now the ItemsSource property is explictly bound to the child MyXmlElement elements using a Setter in the Style. Once the ItemsSource property is set, it can be used by WPF controls to find any child items.

This sample code shows how to define a Style for the sample XML data below, which uses distinct elements at each level:

XAML
Copy
​<!-- This can be reused across all elements, because they
     all have the Name attribute -->
<DataTemplate x:Key="MyXmlElementTemplate">
    <TextBlock Text="{Binding XPath=@Name}" />
</DataTemplate>

<Style x:Key="MyGrandchildXmlElementStyle"
       ...>
       ...
</Style>

<Style x:Key="MyChildXmlElementStyle"
       ...>
    <Setter Property="ItemsSource"
            Value="{Binding XPath=MyGrandchildXmlElement}" />
    <Setter Property="ItemContainerStyle"
            Value="{StaticResource MyGrandchildXmlElementStyle}" />
    <Setter Property="ItemTemplate"
            Value="{StaticResource MyXmlElementTemplate}" />
</Style>

<Style x:Key="MyRootXmlElementStyle"
       ...>
    <Setter Property="ItemsSource"
            Value="{Binding XPath=MyChildXmlElement}" />
    <Setter Property="ItemContainerStyle"
            Value="{StaticResource MyChildXmlElementStyle}" />
    <Setter Property="ItemTemplate"
            Value="{StaticResource MyXmlElementTemplate}" />
</Style>
XML
Copy
​<?xml version="1.0" encoding="utf-8" ?>
<MyRootXmlElement Name="Root Item">
    <MyChildXmlElement Name="First Child Item">
        <MyGrandchildXmlElement Name="First Grandchild Item" />
        <MyGrandchildXmlElement Name="Second Grandchild Item" />
    </MyChildXmlElement>
    <MyChildXmlElement Name="Second Child Item" />
</MyRootXmlElement>

As you can see, we now define a Style for each distinct XML element and assign them appropriately as we move down the hierarchy.

Breadcrumb Considerations

The Breadcrumb control supports both methods of defining the data hierarchy, as does the TreeView control and others. The Breadcrumb control does differ slightly, in that the same data can be presented in more than one area of the control. For example, a data object can be displayed in a BreadcrumbItem control, a MenuItem when in a context menu, and a ComboBoxItem when display in the drop-down list.

If the data source of the Breadcrumb will be shared with another hiearchical control, then using a HierarchicalDataTemplate class would allow the look of the data to be shared. But typically, a Style is still be required to set properties not supported by the HierarchicalDataTemplate class, such as MenuItemExpandedTemplate.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Item Conversion

In order to support the various methods of setting the selected item, the Breadcrumb requires that certain information about data objects to be provided upon request. There are two pieces of information that the Breadcrumb may request: a path string representation of the data object and a top down list of how to find the data object (called a trail).

This topic contains these sections:

  • Default Handling
  • Handling Conversion Requests
  • Path Conversion
  • Trail Conversion

Default Handling

When the items presented by the Breadcrumb are defined using BreadcrumbItem, then the majority of the conversions are automatically handled. The only requirement is that the BreadcrumbItem.PathEntry property be set to a String that uniquely identifies the item among its siblings. This behavior can be adjusted or completely replaced using the ConvertItem event described in the following section.

Handling Conversion Requests

The Breadcrumb fires the ConvertItem event, when it needs a path or a trail. The event arguments are an instance of BreadcrumbConvertItemEventArgs and include information about the conversion request.

This sample code shows how to define an event handler for the ConvertItem event:

XAML
Copy
​xmlns:navigation="http://schemas.actiprosoftware.com/winfx/xaml/navigation"
...
<navigation:Breadcrumb ConvertItem="OnBreadcrumbConvertItem"
                       ... />
C#
Copy
​private void OnBreadcrumbConvertItem(object sender, BreadcrumbConvertItemEventArgs e) {
    // Set e.Path from e.Item, if e.TargetType == BreadcrumbConvertItemTargetType.Path
    // Set e.Trail from e.Item or e.Path, if e.TargetType == BreadcrumbConvertItemTargetType.Trail
    ...
}

Path Conversion

The path of a data object is displayed in the Breadcrumb when in edit mode and is accessible through the SelectedPath property. A path can be any string, but should uniquely identify the given item. This works much like file system paths, where no two files have the same path.

For path conversions, the event arguments for the ConvertItem event will include the data object whose path is needed.

Trail Conversion

The trail of a data object direct the Breadcrumb control to the data object in the hierarchy. The trail is needed when a user enters a path in edit mode, selects an item from the drop-down list, the SelectedItem property is set programmaticaly, or the SelectedPath property is set programmaticaly. Without the trail, the Breadcrumb would not be able to find the data object and would be unable to select it.

The trail is simply an IList, which includes all the parent items of the specified data object and the specified data object. For example, the conversion for the path "RootItem\ChildItem\GrandchildItem" should return an IList whose first item is the data object for "RootItem", second item is the data object for "ChildItem", and third item is the data object for "GrandchildItem".

For trail conversions, the event arguments for the ConvertItem event will include the data object, or its path, whose trail is needed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Item Display

The Breadcrumb control allows the look of the represented data to be customized using various properties.

This topic contains these sections:

  • Customizing the Item Look
  • Setting Images
  • Associated Members

Customizing the Item Look

The items in the Breadcrumb control use the Breadcrumb.ItemTemplate as their DataTemplate. In addtion, the Breadcrumb.ItemContainerStyle can be used to further customize the look of an item.

Typically, these properties are set on the Breadcrumb control for use by all the items displayed. But the associated properties on the BreadcrumbItem control can be used to change the look for its descendents. Therefore, if desired, each item in the trail could be given a custom look.

Setting Images

The image associated with the selected item is displayed on the left side of the Breadcrumb control. This image is obtained from the BreadcrumbItem.ImageSource property.

Tip Tip
The ImageConverter value converter can be used to create an Image element from a BitmapSource, allowing you to use the BreadcrumbItem.ImageSource property to assign the MenuItem.Icon property for use in the context menus.

In addition, Breadcrumb.ImageMinWidth can be used to set the minimum width of the image area. By default, this property is set to 16.0.

Associated Members

The following Breadcrumb members can be used to customize the display of items:

Member | Description
ImageMinWidth Property | Gets or sets the minimum width of the image displayed on the left side of the Breadcrumb. The default value is 16.0.
ItemContainerStyle Property | Gets or sets the Style that is applied to BreadcrumbItem elements generated for items in the trail. The default value is null.
ItemContainerStyleSelector Property | Gets or sets custom logic for choosing a Style that can be applied to BreadcrumbItem elements generated. The default value is null.
ItemTemplate Property | Gets or sets the DataTemplate used to display each item in the trail. The default value is null.
ItemTemplateSelector Property | Gets or sets the custom logic for choosing a template used to display each item in the trail. The default value is null.

The following BreadcrumbItem members can be used to customize the display of child items:

Member | Description
ImageSource Property | Gets or sets the image that appears in the Breadcrumb when the BreadcrumbItem is selected. The default value is null.
ItemContainerStyle Property | Gets or sets the Style that is applied to BreadcrumbItem elements generated for items in the trail. The default value is null.
ItemContainerStyleSelector Property | Gets or sets custom logic for choosing a Style that can be applied to BreadcrumbItem elements generated. The default value is null.
ItemTemplate Property | Gets or sets the DataTemplate used to display each item in the trail. The default value is null.
ItemTemplateSelector Property | Gets or sets the custom logic for choosing a template used to display each item in the trail. The default value is null.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Item Selection

The Breadcrumb control allows a single item from a hierarchy of data to be selected. The selection can be change interactively using the keyboard or mouse, or programmtically by setting various properties.

This topic contains these sections:

  • Interactive Selection
  • Programmatic Selection

Interactive Selection

The user can navigate down the hierarchy using the drop-down menus provided by items with children. This menu can be opened using the mouse, or by pressing the Down key when the associated item has the keyboard focus.

The Breadcrumb control using the Aero theme showing the menu for the Computer item

The user can navigate directly to any visible item by clicking the associated item, or by pressing the Enter key when the associated item has the keyboard focus.

The Breadcrumb control using the Aero theme showing Computer item

The user can enter the path of an item to select when in edit mode.

The Breadcrumb control using the Aero theme in edit mode

The user can select and item or path from the drop-down list.

The Breadcrumb control using the Aero theme showing the drop-down list

Programmatic Selection

The selected item can be changed by setting the Breadcrumb.SelectedItem or Breadcrumb.SelectedPath properties.

Note that for these features to work when using data items, you will need to support item conversion so that the Breadcrumb control knows how to obtain a trail.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overflow

When the width of the Breadcrumb control is not large enough to display all of the visible items, any non-selected items will be automatically hidden, or overflowed.

The Breadcrumb control using the Aero theme with the overflow button visible and open

This topic contains these sections:

  • Overflow Rules
  • Associated Members

Overflow Rules

Tail items, or items below the selected item, will be the first items to be hidden. Hidden tail items can still be accessed through the menu on the last visible item.

Head items, or items above the selected item, will be hidden next. When this occurs, an overflow chevron button appears at the left side of the Breadcrumb control. The overflow button shows a menu which provides access to the hidden head items. In addition, the child items of the RootItem are shown in a separate section at the bottom of this menu.

Note Note
See the Context Menus topic for information on how you can customize the menus shown by the Breadcrumb control.

After all non-selected items have been overflowed, the selected item will begin to dynamically size smaller as needed.

Associated Members

The following Breadcrumb members are associated with overflowing:

Member | Description
IsOverflowButtonVisible Property | Gets a value indicating whether the overflow button is visible.

The following BreadcrumbItem members are associated with overflowing:

Member | Description
IsOverflowed Property | Gets a value indicating whether this item has been moved to the overflow button because of limited space in the breadcrumb control.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Progress Bar

The Breadcrumb control contains an embedded AnimatedProgressBar control, which can be used to show the progress of long running operations.

Note Note
Check out the AnimatedProgressBar control topic for more information on it's features.

The Breadcrumb control using the Aero theme with the progress bar in the three possible states, Normal, Paused, and Error

This topic contains these sections:

  • Showing the Progress Bar
  • Associated Members

Showing the Progress Bar

By default, the progress bar is hidden and must be explicitly shown by setting IsProgressBarVisible to true. Also, the progress bar is only visible when the Breadcrumb control is not in edit-mode (when IsEditing is false).

Note Note
Changes to IsProgressBarVisible are animated, so the progress bar will fade in when this property is set to true and fade out when set to false.

The Breadcrumb control using the Aero theme with the bottom control in edit mode

The progress bar spans the entire height and width of the Breadcrumb control, including the area reserved for the action buttons. Therefore, if an action button does not have a transparent background then it will hide a portion of the progress bar. The Breadcrumb uses PopupButton controls internally, and it is recommended that the PopupButton control (with its transparency mode enabled) be used for custom action buttons as well.

This sample code shows how to create a PopupButton which can be used as an action button:

XAML
Copy
​xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
...
<shared:PopupButton Content="New PopupButton"
                    DisplayMode="ButtonOnly"
                    IsRounded="false"
                    IsTransparencyModeEnabled="true" />

Associated Members

The following Breadcrumb members are associated with the embedded progress bar:

Member | Description
IsProgressBarVisible Property | Gets or sets a value indicating whether the embedded progress bar is visible. The default value is false.
ProgressBarDecreaseDuration Property | Gets or sets the Duration of the decrease animation of the embedded progress bar. The default value is 500 milliseconds.
ProgressBarIncreaseDuration Property | Gets or sets the Duration of the increase animation of the embedded progress bar. The default value is 500 milliseconds.
ProgressBarIsAnimationEnabled Property | Gets or sets value indicating whether the embedded progress bar should animate ProgressBarValue changes. The default value is true.
ProgressBarIsIndeterminate Property | Gets or sets a value indicating whether the embedded progress bar shows actual values or generic, continuous progress feedback. The default value is false.
ProgressBarMaximum Property | Gets or sets the highest possible ProgressBarValue of the embedded progress bar. The default value is 1.0.
ProgressBarMinimum Property | Gets or sets the lowest possible ProgressBarValue of the embedded progress bar. The default value is 0.0.
ProgressBarState Property | Gets or sets the state of the embedded progress bar. The default value is Normal.
ProgressBarValue Property | Gets or sets the current value of the embedded progress bar. The default value is 0.0.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tail Items

By default, the last item displayed is the selected item. However, the Breadcrumb control can be configured to display any number of tail items.

Tail items are items that were part of the last selected branch, meaning they were either selected or contained the selection, and are below the currently selected item. In the image below, the Actipro Software item was selected and then the selection was changed to the Desktop item. In this scenario, the selection moved up the current branch. By retaining the tail items in the current branch, the user can quickly navigate back down.

If the selection is changed to a different branch, then the tail items below the selected item will be reset.

The Breadcrumb control using the Aero theme with several tails items

This topic contains these sections:

  • Setting Tail Item Count
  • Customizing Tail Items
  • Associated Members

Setting Tail Item Count

The number of tail items is controlled by the Breadcrumb.MaxTailItemCount property. This number counts down from the selected item.

For example, if MaxTailItemCount is set to 1 then only one tail item will ever be displayed.

Customizing Tail Items

By default, tail items are display with an Opacity of 0.5, or 50%, but this look can be fully customized using various properties.

The Breadcrumb.TailItemOpacity property, can be used to quickly customize the opacity and more complex customization can be accomplish using a Style.

This sample code shows how more complex looks can be achieved by using the Breadcrumb.ItemContainerStyle property:

XAML
Copy
​xmlns:navigation="http://schemas.actiprosoftware.com/winfx/xaml/navigation"
...
<Style x:Key="BreadcrumbItemStyleProgressiveFade70"
       TargetType="{x:Type navigation:BreadcrumbItem}">
    ...
    <Style.Triggers>
        <!-- This trigger will progressively dim the tail items -->
        <Trigger Property="IsTailItem"
                 Value="true">
            <Setter Property="Opacity"
                    Value="0.7" />
        </Trigger>
    </Style.Triggers>
</Style>
...
<navigation:Breadcrumb ItemContainerStyle="{StaticResource BreadcrumbItemStyleProgressiveFade70}"
                       MaxTailItemCount="10"
                       ... />

Associated Members

The following Breadcrumb members are associated with tail items:

Member | Description
MaxTailItemCount Property | Gets or sets the number of items that will be automatically minimized, starting from root item. The default is 1.
TailItemOpacity Property | Gets or sets the opacity of the tail items. The default is 0.5.

The following BreadcrumbItem members are associated with tail items:

Member | Description
IsTailItem Property | Gets a value indicating whether the item is a tail item.
TailIndex Property | Gets the position of the tail item below the selected item. If the item is selected or contains the selection, then this index will be -1.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Themes

This product includes multiple built-in themes for all Office themes and Windows system themes. It is fully extensible so that other product themes can be custom developed. Themes can be tinted towards any color or set of colors, and brush resources from them may be reused.

Note Note
Be sure to read the Actipro Themes product documentation too since that explains in great detail how the themes management works with Actipro controls.

This topic contains these sections:

  • Built-In Themes
  • Theme Catalog
  • Tinting Themes

Built-In Themes

Breadcrumb includes built-in themes for Office blue/black/silver, Aero, Luna blue/olive/silver, Royale, classic, and high-contrast that match the real Windows themes.

The Breadcrumb control in its Aero, Luna Homestead, and Classic themes

Theme Catalog

The NavigationThemeCatalog is used to provide dynamic theme-switching to this product, and is automatically registered when WPF loads the system themes from the associated assembly.

To explicitly load and register the theme catalog, call the Register staic method on NavigationThemeCatalogRegistrar.

Tinting Themes

Any theme can be completely or partially tinted towards a color or set of colors. The general Tinting topic explains how to perform tinting in detail.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Explorer bar is an implementation of the task bar that was introduced in Windows XP's explorer.

Some of the more major features include:

  • Duplicates all functionality found in the Windows XP explorer bar.
  • Built-in themes for Luna blue/olive/silver, classic, and royale.
  • Displays a vertical list of expanders that use animation to fade and slide when expanding/collapsing.
  • Optionally only allow one expander to be expanded at a time.
  • Alternate style can be applied to an individual expander to give it emphasis.
  • Place text and images in expander headers.
  • Vertical scrollbar automatically added when expanders exceed container height.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Themes

This product includes multiple built-in themes for all Office themes and Windows system themes. It is fully extensible so that other product themes can be custom developed. Themes can be tinted towards any color or set of colors, and brush resources from them may be reused.

Note Note
Be sure to read the Actipro Themes product documentation too since that explains in great detail how the themes management works with Actipro controls.

This topic contains these sections:

  • Built-In Themes
  • Accessing Theme Styles
  • Theme Catalog
  • Tinting Themes

Built-In Themes

ExplorerBar includes built-in themes for Office blue/black/silver, Aero, Luna blue/olive/silver, Royale, classic, and high-contrast that match the real Windows themes.

The ExplorerBar control in its Aero, Luna normal-color and Windows Classic themes

Accessing Theme Styles

The ExplorerBar class contains a number of static properties that return ResourceKey objects referencing Style resources.

Styles can be referenced explicitly using DynamicResource:

XAML
Copy
​xmlns:navigation="http://schemas.actiprosoftware.com/winfx/xaml/navigation"
...
<Expander Header="Alternate"
    Style="{DynamicResource {x:Static navigation:ExpanderBar.ExpanderAlternateStyleKey}}">
    ...

The static properties on ExplorerBar that are for Style resources are named ending with StyleKey.

Theme Catalog

The NavigationThemeCatalog is used to provide dynamic theme-switching to this product, and is automatically registered when WPF loads the system themes from the associated assembly.

To explicitly load and register the theme catalog, call the Register staic method on NavigationThemeCatalogRegistrar.

Tinting Themes

Any theme can be completely or partially tinted towards a color or set of colors. The general Tinting topic explains how to perform tinting in detail.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Headers and Content

ExplorerBar has several configuration options for the display of its expander panes.

This topic contains these sections:

  • Headers
  • Image/Text and Alternate Pane Style Example
  • Content

Headers

For pane headers, the Expander.Header can be set to either a string or an ImageTextInfo object.

If the header is a string, it will be displayed like File and Folder Tasks in the screenshot above. Alternatively, the ImageTextInfo class gives you the option of displaying text and an image.

Image/Text and Alternate Pane Style Example

This sample shows how to create an expander pane with an alternate style (which attracts attention and is sometimes used for the first pane item). It also has an image in the header, showing the use of ImageTextInfo. Note how some extra margin space is defined for the top of the pane since the image will stretch into the margin area.

XAML
Copy
​<navigation:ExplorerBar>
    <shared:AnimatedExpander IsExpanded="True" Margin="0,7,0,0"
        Style="{DynamicResource {x:Static themes:ExplorerBarCommonDictionary.ExpanderAlternateStyleKey}}">
        <shared:AnimatedExpander.Header>
            <shared:ImageTextInfo ImageSourceLarge="/Resources/Images/PictureTasks32.png" Text="Picture Tasks" />
        </shared:AnimatedExpander.Header>
        <!-- Content here -->
    </shared:AnimatedExpander>
<navigation:ExplorerBar>

Content

Any sort of content can be placed in the content portion of a pane. A common practice is to use a StackPanel of Hyperlink controls in some panes. But the general rule of thumb for content of a pane is that it should relate in some way to the context outside of the ExplorerBar, such as providing tasks or information related to the outer content.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Expanding/Collapsing Panes

ExplorerBar is a vertical stack of expander pane items. The pane items inherit the native WPF Expander control but are styled by ExplorerBar to have the Windows task bar appearance.

This topic contains these sections:

  • Animated Expanding/Collapsing Panes
  • Changing Animation Durations
  • Only Allowing a Single Pane to be Expanded
  • Overflow

Animated Expanding/Collapsing Panes

You can expand or collapse expander panes simply by clicking on their headers.

The ExplorerBar control with its second pane being expanded with animated fade in and slide down

When expanding, the pane's content slides down and fades in. When collapsing, the pane's content slides up and fades out. These affects provide a very pleasing, yet subtle, effect.

Changing Animation Durations

If your Expander items are instances of AnimatedExpander (which inherits Expander), you can specify the ExpandDuration and CollapseDuration times.

Only Allowing a Single Pane to be Expanded

You can optionally set the ExplorerBar.CanExpandMultiple to false to make ExplorerBar only allow one pane to be expanded at a time. In this mode, if the end user tries to expand another pane, the currently-expanded pane will collapse.

Overflow

When the combined height of the expander panes exceeds the height of the ExplorerBar, a vertical scrollbar is automatically added, allowing you to scroll to hidden panes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

NavigationBar is a control that presents multiple categorized panes of data, one of which is selected at a time.

Some of the more major features include:

  • Duplicates all functionality found in the Office navigation bar.
  • Built-in themes for Aero, Office blue/black/silver, Luna blue/olive/silver, classic, and high-contrast.
  • Buttons provide single-click access to each pane.
  • Buttons can be collapsed to an overflow area, allowing for more client area real estate.
  • Entire bar may be minimized, with a button that can be clicked to display a popup containing the selected pane's content.
  • Minimize to both left and right sides.
  • Customize button provides access to customization features and hidden buttons.
  • Ability to alter the menu displayed by the customize button.
  • Built-in Navigation Bar Options dialog for reordering buttons and controlling which buttons are visible.
  • Automated reset button order functionality.
  • Support for large and small image sizes.
  • Ability to disable specific pane buttons.
  • Optionally hide pane buttons to use as a headered container.
  • Persist end user layout customizations to XML.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Pane Buttons and Selection

The NavigationBar control's run-time features are very easy to use. The NavigationBar contains a number of panes of data, but only displays one NavigationPane at a time.

The NavigationBar control, showing large and overflow buttons

This topic contains these sections:

  • Setting the Title and Images for a Pane
  • Navigation Pane Button Locations
  • Changing the Selected Navigation Pane
  • Adjusting How Many Large Buttons Appear
  • Adding or Removing Buttons
  • Disabling Buttons

Setting the Title and Images for a Pane

The title and images for a NavigationPane can be set via several simple properties:

Member | Description
ImageSourceLarge Property | Gets or sets the ImageSource for the 32x32 image to display for the control.
ImageSourceSmall Property | Gets or sets the ImageSource for the 16x16 image to display for the control.
Title Property | Gets or sets the title of the pane, which appears on pane access buttons, in the navigation bar header, and on menus.

Navigation Pane Button Locations

Each NavigationPane has an associated header button that can be clicked to display the pane.

Depending on available space and the desired number of large pane header buttons that are displayed, there are three places where the buttons that represent panes can be located:

  • Normal button area - Displaying the large image and title of the pane
  • Overflow button area - Displaying the small image only
  • Overflow menu - The pane can only be selected by clicking the customize button and select it from a menu

Changing the Selected Navigation Pane

To change the selected NavigationPane, the end-user can click the corresponding button for the pane. The selected pane's content is then displayed in the NavigationBar and its title is displayed in the header of the control.

Since NavigationBar inherits Selector, you can change the selected pane via properties like SelectedIndex or SelectedItem as well.

Adjusting How Many Large Buttons Appear

If the NavigationBar is resized small enough so that the buttons in the normal area do not fit in the client area of the control, they will be shuffled down into the overflow area at the bottom of the control. If the buttons in the overflow area do not fit in the overflow area, the buttons that couldn't fit are moved into the menu area. As more space in the control becomes available, the buttons are shuffled back.

The end-user can adjust how many buttons are displayed in the bar area by clicking on the splitter and dragging it up or down. This has the same effect as setting the MaxLargePaneCount property, whose default value is 5.

The typical overflow menu also displays Show More Buttons and Show Fewer Buttons menu items that allow for adjusting how many buttons appear in the normal area.

Adding or Removing Buttons

Buttons for a NavigationPane can be added or removed by the end-user via two methods.

An Add or Remove Buttons sub-menu is available on the overflow menu. That sub-menu lists all of the panes and a checked state indicates whether the button for each is currently visible. By clicking the menu item for a pane, the button's visibility is toggled.

The second way to add or remove buttons is to use the Options window. From there, panes can be checked or unchecked in a list to indicate whether they should be visible.

Disabling Buttons

Simply set the NavigationPane's IsEnabled property to false to disable a pane's button. When disabled, the button will render with gray text and a faded-out image.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Themes

This product includes multiple built-in themes for all Office themes and Windows system themes. It is fully extensible so that other product themes can be custom developed. Themes can be tinted towards any color or set of colors, and brush resources from them may be reused.

Note Note
Be sure to read the Actipro Themes product documentation too since that explains in great detail how the themes management works with Actipro controls.

This topic contains these sections:

  • Built-In Themes
  • Theme Catalog
  • Tinting Themes

Built-In Themes

NavigationBar includes built-in themes for Office blue/black/silver, Aero, Luna blue/olive/silver, Royale, classic, and high-contrast that match the real Outlook themes.

The NavigationBar control in its Office blue, Luna Homestead, and custom red-tinted themes

Theme Catalog

The NavigationThemeCatalog is used to provide dynamic theme-switching to this product, and is automatically registered when WPF loads the system themes from the associated assembly.

To explicitly load and register the theme catalog, call the Register staic method on NavigationThemeCatalogRegistrar.

Tinting Themes

Any theme can be completely or partially tinted towards a color or set of colors. The general Tinting topic explains how to perform tinting in detail.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Customize Button

A built-in ContextMenu is displayed when the NavigationBar's customize button is clicked.

The menu has options for showing more or less pane buttons, showing the Options Window, showing/hiding individual panes, and selecting any panes whose header buttons don't fit in the main NavigationBar UI.

This topic contains these sections:

  • Customizing the Menu
  • Hiding the Customize Button

Customizing the Menu

You can completely customize the default ContextMenu or even supply an alternate menu by handling the NavigationBar.CustomizeButtonClick event. The Item property of the event arguments is the ContextMenu that will be displayed. Add/update/remove menu items as necessary there.

Hiding the Customize Button

Set the NavigationBar.IsCustomizationEnabled property to false to hide the customize button.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Minimization

The NavigationBar supports a minimized mode in which it is collapsed to be very narrow. A button appears in the original content area of the NavigationBar and when clicked, a popup displays containing the content of the currently-selected pane.

A minimized NavigationBar control with its content popup displayed

This topic contains these sections:

  • Related Members
  • Preventing Minimization
  • Changing the Popup Resize Mode

Related Members

The NavigationBar has several members related to minimization:

Member | Description
Expanded Event | Occurs when the IsMinimized property changes to false.
IsMinimizable Property | Gets or sets whether the navigation bar can be minimized. The default value is true.
IsMinimized Property | Gets or sets whether the navigation bar is currently minimized. The default value is false.
IsPopupEnabled Property | Gets or sets whether the navigation bar's minimized popup is currently enabled.
IsPopupOpen Property | Gets or sets whether the navigation bar's minimized popup is currently displayed.
Minimized Event | Occurs when the IsMinimized property changes to true.
MinimizedTitle Property | Gets or sets the title of the navigation bar when the navigation bar is minimized.
MinimizesLeftProperty Property | Gets or sets whether the navigation bar minimizes to the left. The default value is true. Set this property to false when docking the navigation bar on the right side of its container.
PopupClosed Event | Occurs when the IsPopupOpen property changes to false.
PopupOpened Event | Occurs when the IsPopupOpen property changes to true.
PopupResizeMode Property | Gets or sets a ControlResizeMode that indicates the type of resizing that the popup performs. The default value is ControlResizeMode.Both.

The NavigationPane has several members related to minimization:

Member | Description
PopupPadding Property | Gets or sets the amount of padding added around the pane's content, when displayed in a popup. The default value is 0,0,0,0.

Preventing Minimization

When the IsMinimizable property is false, no minimize button will be visible in the NavigationBar's header.

Changing the Popup Resize Mode

The PopupResizeMode property lets you configure whether and how the minimized popup can be resized.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Hiding Pane Buttons

The NavigationBar control can optionally hide its pane buttons, allowing it to be used as a simple headered container with the styles that match a "normal" looking NavigationBar.

A NavigationBar control in the Luna normal-color theme containing a single pane, and with pane buttons hidden

To achieve this effect, set the ArePanesVisible to false. Be sure to set IsMinimizable to false as well.

If you are using Office 2010 themes, also set the BorderThickness propery to 1 (since there is no border by default in those themes) and IsHeaderContentVisible to true (since header content is not displayed by default in those themes).

Note Note
The appearance of the NavigationBar in this mode depends on the theme that is currently active.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Header Area

This topic covers the options available for the NavigationBar header area.

The NavigationBar control with header hidden

This topic contains these sections:

  • Hiding the Header Area
  • Hiding the Header Content

Hiding the Header Area

The header area can be completely hidden, with the exception of the minimize button, by setting NavigationBar.IsHeaderVisible to false. This mimics the look seen in the Office 2010 products, where the minimize button overlays the content area. The default value for this property is true.

Hiding the Header Content

The header content can be hidden by setting NavigationBar.IsHeaderContentVisible to false. This allows the minimize button to be displayed separately from it's content, while still hiding the header text. The default value for this property is true.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Options Window

A built-in Options window comes packaged with NavigationBar.

The NavigationBar control's built-in Options window

The window offers the end-user the ability to reorder navigation pane buttons by using the Move Up and Move Down buttons. Navigation pane buttons can also be hidden by unchecking the button items in the list. The visibility and sort order can be reset back to defaults by clicking the Reset button.

This topic contains these sections:

  • Showing the Options Window
  • Controlling Reset Button Functionality

Showing the Options Window

The default overflow menu has a menu item for displaying the Options window. This is executed via the NavigationBarCommands.ShowOptionsWindow command.

However you can manually show the Options window by calling NavigationBar.ShowOptionsWindow.

That method calls GetOptionsWindow first to get a reference to an Options window instance. By creating a class that inherits NavigationBar you can override that method to return any sort of custom Window that you'd like to use for the options.

The NavigationBar.Title property is what determines the title of the navigation bar that is displayed in Options window UI.

Controlling Reset Button Functionality

The Reset button on the window is used to reset the panes to their original order and active state. There are a couple properties on NavigationPane that the window uses to determine how to do this.

Member | Description
DefaultSortOrder Property | Gets or sets the default sort order of the pane, that is used when the pane is reset in the options window. The default value is -1. Leave the value -1 to have it auto-configured the first time the options window is displayed.
DefaultVisibility Property | Gets or sets the default Visibility of the pane, that is used when the pane is reset in the options window. The default value is Visible. This property should match the initial setting of the Visibility property for the pane.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Layout Serialization

A NavigationBar layout is defined as the selected pane, buttons visible, pane order, and pane visibility for a NavigationBar control.

Sometimes it is useful to save the layout state of a NavigationBar and restore it later. This allows for end users to retain their customizations across multiple application executions. The way to do this is to persist the NavigationBar layout data.

Note Note
When persisting layouts, each NavigationPane must have a unique value assigned to its Name property, otherwise the layout cannot be created.

This topic contains these sections:

  • Saving Layout Data
  • Loading Layout Data
  • Persisting Custom Data in the Layout Data
  • Optimal Memory Utilization when Using Layout Serializers

Saving Layout Data

NavigationBar layout data can be persisted in XML format and loaded at a later time. Probably the two most common ways to store layouts are in files and in a database.

The NavigationBarLayoutSerializer class fully implements the XML object hierarchy serialization framework described in the Serialization topic. Please see that topic for a list of methods that can be called for saving to files, string, etc.

This sample code shows how to save a NavigationBar layout to an XML string:

C#
VB
Copy
​string layout = new NavigationBarLayoutSerializer().SaveToString(navBar);
​Dim layout As String = New NavigationBarLayoutSerializer().SaveToString(navBar)

Loading Layout Data

When loaded, NavigationBar layout data restores the order and visibility states of the panes being managed by the NavigationBar control. It also determines the number of large buttons to display and selects the pane that was selected when the layout was saved.

The layout data loading code matches the Name of panes that were stored in the layout data to the Name of panes contained in the NavigationBar.

The NavigationBarLayoutSerializer class fully implements the XML object hierarchy serialization framework described in the Serialization topic. Please see that topic for a list of methods that can be called for loading from files, string, etc.

This sample code shows how to load a NavigationBar layout from the XML string:

C#
VB
Copy
​new NavigationBarLayoutSerializer().LoadFromString(layout, navBar);
​New NavigationBarLayoutSerializer().LoadFromString(layout, navBar)

Persisting Custom Data in the Layout Data

One benefit of our XML object hierarchy serialization framework is that you can insert and later retrieve information anywhere within the serialized data. Any time an object is serialized or deserialized, an event fires. You can intercept this event and save/load custom data.

The Serialization topic explains how to do this.

Optimal Memory Utilization when Using Layout Serializers

The layout serializer uses an XmlSerializer as the core .NET object that reads/writes XML data. One issue that has been discovered in the Microsoft .NET framework is that XmlSerializer is capable of creating memory leaks. The leak occurs whenever a new instance of XmlSerializer is created.

To combat this leak we've implemented some caching code on our end, but also highly recommend that instead of creating a new layout serializer any time you do a layout serialization, you instead keep a reference to a single app-wide instance of the layout serializer and use that for each layout serialization.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

ZoomContentControl is a control that presents a selected item from a hierarchy in a linear fashion.

Some of the more major features include:

  • Adds zooming and panning capabilities to the native WPF ContentControl.
  • Supports smooth animations when zooming and panning.
  • Vertical and horizontal scrollbars can be used for panning or hidden.
  • Mouse and keyboard behavior can be easily customized using standard WPF input bindings.
  • Built-in support for numerous commands with associated mouse cursors.
  • Exposes several methods and properties that can be used to manipulate the view.
  • Includes an optional standard view control pane that can be used to zoom and pan the view.
  • Standard view control pane is collapsable or it can be fixed.
  • Add custom buttons to the horizontal bar of the view control pane.
  • Built-in styles for use with various button controls that match the view control pane look.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


View Manipulation

The ZoomContentControl offers numerous way to manipulate the view, both interactively and programmatically. This topic covers these aspects of the control.

This topic contains these sections:

  • Zooming
  • Panning
  • Virtual Space
  • Mouse Behavior
  • Supported Commands
  • Scroll Bars
  • Batch Updates
  • Animations

Zooming

The content displayed by the ZoomContentControl will be scaled by ZoomLevel, along both the X and Y axes. There are several ways to interactively and programmatically adjust the zoom level.

Minimum/Maximum Zoom Level

The ZoomLevel is restricted to the range defined by the MinZoomLevel and MaxZoomLevel properties. Both of these properties must be greater than 0, and the MaxZoomLevel must be larger than or equal to the MinZoomLevel.

If the zoom level is set to the value outside of this range, it will be coerced to fall within the range.

Zoom Level Stops

The ZoomLevelStops property is used by several of the helper methods listed below to incrementally increase or decrease ZoomLevel. When specified, the ZoomLevel will be increment or decremented to the next stop value. This allows the zoom in and out commands/methods to follow a predefined sets of zoom levels (e.g.. 10%, 25%, 33%, 50%, 75%, 100%, 200%, 300%, etc).

Note Note
If an appropriate stop value cannot be found, then the minimum or maximum zoom level will be used, based on whether the user is zooming in or out.

By default, this property is set to null which indicates that the ZoomStep (described below) should be used.

Zoom Step

As an alternative to the zoom level stops, the ZoomStep property can provide a fixed value that derives exponential zoom level stop power increments.

If one or more zoom level stops are specified in the ZoomLevelStops collection, then the ZoomStep property is not used.

Helper Methods

There are several methods that can be used to adjust the zoom level, which include:

Member | Description
CenterAndZoomInToPoint Method | Centers the view to the specified point and zooms the content in using ZoomLevelStops or ZoomStep. If no point is specified, then the view will be centered to the current mouse position.
CenterAndZoomOutFromPoint Method | Centers the view to the specified point and zooms the content out using ZoomLevelStops or ZoomStep. If no point is specified, then the view will be centered to the current mouse position.
ResetView Method | Resets the view to the DefaultZoomLevel and DefaultCenterPoint.
StartZoomDrag Method | Starts a zoom-drag operation, where the user can zoom-in by moving the mouse up and zoom-out by moving the mouse down. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can zoom the content until the mouse button is released.
StartZoomIn Method | Starts a zoom-in operation, where the user can continuously zoom-in by holding the mouse button down. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can continuously zoom-in the content until the mouse button is released.
StartZoomOut Method | Starts a zoom-out operation, where the user can continuously zoom-out by holding the mouse button down. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can continuously zoom-out the content until the mouse button is released.
StartZoomToRegion Method | Starts a zoom-to-region operation, where the user can draw a rectangle over the content to indicate the desired region. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can draw a rectangle over the content until the mouse button is released.
ZoomIn Method | Zooms the content in using ZoomLevelStops or ZoomIn.
ZoomInToPoint Method | Zooms the content in using ZoomLevelStops or ZoomStep with the specific point as an anchor. If no point is specified, then the current mouse position will be used.
ZoomOut Method | Zooms the content out using ZoomLevelStops or ZoomStep.
ZoomOutFromPoint Method | Zooms the content out using ZoomLevelStops or ZoomStep with the specific point as an anchor. If no point is specified, then the current mouse position will be used.
ZoomToFit Method | Zooms the content so that it fits with-in the bounds of the control and centers the view. Various overloads can be used to zoom-to-fit horizontally and/or vertically, and optionally center the view.

Panning

The content displayed by the ZoomContentControl can be scrolled (or panned) in any direction. There are several ways to interactively and programmatically adjust the pan offsets.

Center Point

The CenterPoint property is used to track the current pan offsets. The center point is relative the content, not the ZoomContentControl control. Therefore, a point of 0,0 would indicate that the top-left corner of the content should be centered in the view.

The size of the content can be obtained from the ChildSize property. If the center point falls outside of this range, it will be coerced to fall within the range.

The resolved coerced value (that is the current true center point) is available from the CenterPointResolved property.

Horizontal/Vertical Steps

The HorizontalScrollLineStep, HorizontalScrollPageStep, VerticalScrollLineStep, and VerticalScrollPageStep properties are used by several of the helper methods listed below to incrementally increase or decrease the X or Y values of the CenterPoint.

These steps values are specified using a Unit, which can represent a fixed number of pixels or a percentage of the visible area. For example, a value of Unit.Percentage(100) would scroll the view one full page either horizontally or vertically, assuming the content is large enough to allow scrolling.

Helper Methods

There are several methods that can be used to adjust the zoom level, which include:

Member | Description
CenterAndZoomInToPoint Method | Centers the view to the specified point and zooms the content in by the ZoomStep value. If no point is specified, then the view will be centered to the current mouse position.
CenterAndZoomOutFromPoint Method | Centers the view to the specified point and zooms the content out by the ZoomStep value. If no point is specified, then the view will be centered to the current mouse position.
CenterToPoint Method | Centers the view to the specified point. If no point is specified, then the view will be centered to the current mouse position.
CenterView Method | Centers the content in the view horizontally and/or vertically.
LineDown Method | Scrolls the content down by VerticalScrollLineStep, with an optional factor (which is multipled by the step value).
LineLeft Method | Scrolls the content left by HorizontalScrollLineStep, with an optional factor (which is multipled by the step value).
LineRight Method | Scrolls the content right by HorizontalScrollLineStep, with an optional factor (which is multipled by the step value).
LineUp Method | Scrolls the content up by VerticalScrollLineStep, with an optional factor (which is multipled by the step value).
PageDown Method | Scrolls the content down by VerticalScrollPageStep, with an optional factor (which is multipled by the step value).
PageLeft Method | Scrolls the content left by HorizontalScrollPageStep, with an optional factor (which is multipled by the step value).
PageRight Method | Scrolls the content right by HorizontalScrollPageStep, with an optional factor (which is multipled by the step value).
PageUp Method | Scrolls the content up by VerticalScrollPageStep, with an optional factor (which is multipled by the step value).
Pan Method | Pans the view by the specified x and y offsets.
ResetView Method | Resets the view to the DefaultZoomLevel and DefaultCenterPoint.
StartPanDrag Method | Starts a pan-drag operation, where the user can move the content along with the mouse. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can pan the content until the mouse button is released.

Virtual Space

When the content can be fully displayed (either horizontally, vertically, or both) in the ZoomContentControl then it is centered, and the view cannot be panned. Additionally, the content must always be aligned to the edges of the view. For example, the left edge of the content cannot be scrolled to the right of the left edge of the view.

By setting IsVirtualSpaceEnabled to true, then any part of the content can be centered into the view. This setting adds "virtual space" around the control to allow, which increases the scrollable area.

Mouse Behavior

The mouse behavior of the ZoomContentControl can be customized customized by updating the InputBindings collection.

See the Input Bindings topic for more information.

Supported Commands

The commands supported by the ZoomContentControl are defined by the ZoomContentControlCommands static class.

Note Note
Several of the commands in ZoomContentControlCommands return a command that is defined elsewhere. For example, the LineDown command returns the command defined by ScrollBar.LineDownCommand. This makes it easier to find the supported commands.

The following table describes the various commands.

Member | Description
CenterAndZoomInToPoint Property | Centers the view to the point specified as the command parameter and zooms the content in using ZoomLevelStops or ZoomStep. If no point is specified, then the view will be centered to the current mouse position.
CenterAndZoomOutFromPoint Property | Centers the view to the point specified as the command parameter and zooms the content out using ZoomLevelStops or ZoomStep. If no point is specified, then the view will be centered to the current mouse position.
CenterToPoint Property | Centers the view to the point specified as the command parameter. If no point is specified, then the view will be centered to the current mouse position.
LineDown Property | Scrolls the content down by VerticalScrollLineStep, with an optional factor (which is multipled by the step value) specified as the command parameter.
LineLeft Property | Scrolls the content left by HorizontalScrollLineStep, with an optional factor (which is multipled by the step value) specified as the command parameter.
LineRight Property | Scrolls the content right by HorizontalScrollLineStep, with an optional factor (which is multipled by the step value) specified as the command parameter.
LineUp Property | Scrolls the content up by VerticalScrollLineStep, with an optional factor (which is multipled by the step value) specified as the command parameter.
PageDown Property | Scrolls the content down by VerticalScrollPageStep, with an optional factor (which is multipled by the step value) specified as the command parameter.
PageLeft Property | Scrolls the content left by HorizontalScrollPageStep, with an optional factor (which is multipled by the step value) specified as the command parameter.
PageRight Property | Scrolls the content right by HorizontalScrollPageStep, with an optional factor (which is multipled by the step value) specified as the command parameter.
PageUp Property | Scrolls the content up by VerticalScrollPageStep, with an optional factor (which is multipled by the step value) specified as the command parameter.
ResetView Property | Resets the view to the DefaultZoomLevel and DefaultCenterPoint.
StartPanDrag Property | Starts a pan-drag operation, where the user can move the content along with the mouse. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can pan the content until the mouse button is released.
StartZoomDrag Property | Starts a zoom-drag operation, where the user can zoom-in by moving the mouse up and zoom-out by moving the mouse down. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can zoom the content until the mouse button is released.
StartZoomIn Property | Starts a zoom-in operation, where the user can continuously zoom-in by holding the mouse button down. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can continuously zoom-in the content until the mouse button is released.
StartZoomOut Property | Starts a zoom-out operation, where the user can continuously zoom-out by holding the mouse button down. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can continuously zoom-out the content until the mouse button is released.
StartZoomToRegion Property | Starts a zoom-to-region operation, where the user can draw a rectangle over the content to indicate the desired region. The left, right, or middle mouse button must be pressed when this method is called. Once the operation is started, the end-user can draw a rectangle over the content until the mouse button is released.
ZoomIn Property | Zooms the content in using ZoomLevelStops or ZoomIn.
ZoomInToPoint Property | Zooms the content in using ZoomLevelStops or ZoomStep with the point specified as the command parameter as an anchor. If no point is specified, then the current mouse position will be used.
ZoomOut Property | Zooms the content out using ZoomLevelStops or ZoomStep.
ZoomOutFromPoint Property | Zooms the content out using ZoomLevelStops or ZoomStep with the point specified as the command parameter as an anchor. If no point is specified, then the current mouse position will be used.
ZoomToFit Property | Zooms the content so that it fits with-in the bounds of the control and centers the view. An Orientation can be passed as the command parameter to only zoom-to-fit horizontally or vertically.

Scroll Bars

The ZoomContentControl includes a ScrollViewer in the default control template. The visibility of associated scrollbars can be customized using the HorizontalScrollBarVisibility and/or VerticalScrollBarVisibility properties.

Tip Tip
If HorizontalScrollBarVisibility or VerticalScrollBarVisibility is set to ScrollBarVisibility.Auto then the view will shift when the scrollbars are shown or hidden (as the viewport size will shrink or grow, respectively).

Batch Updates

By default, the ZoomContentControl will immediately update the display when the zoom level or the center point is changed. Changes can be batched together, so that only a single update is made to the display. To batch changes into a single update, the changes must be wrapped by calls to BeginUpdate and EndUpdate.

The EndUpdate includes an overload that can be used to prevent the changes from being animated.

Animations

ZoomContentControl supports smooth animations when zooming and panning. The duration of the animations are control by the ZoomAnimationDuration and PanAnimationDuration properties, respectively.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Input Bindings

The ZoomContentControl supports interactive zooming and panning through the use of input bindings. This topic convers the default behavior, as well as how to customize the behavior.

This topic contains these sections:

  • Mouse Gestures
  • Default Mouse Behavior
  • Mouse Cursor

Mouse Gestures

The Windows Presentation Framework (WPF) includes support for defining input bindings on controls, through the InputBindings collection. This collection defines various gestures, which when executed will raise an associated command.

There are two native WPF gestures that can be used: MouseGesture and KeyboardGesture. MouseGesture encompasses actions like clicking (and double-clicking) mouse buttons, while KeyboardGesture captures pressing keys. Both types support modifier keys, such as Control, Shift, etc. This tells the gesutre that the specifed modifier key must be pressed when the gesture is performed for the assocated command to be fired. For example, when using MouseAction.LeftClick with a modifier key of ModifierKeys.Control, then the associated command is only fired when the user click the left mouse button while holding down the control key.

The Shared Library adds an additional gesture that can bind mouse wheel actions to a command. MouseWheelGesture supports positive or negative changes (i.e. up or down scrolling of the mouse wheel), and can also be used with the ZoomContentControl.

There are several helper types that make defining a gesture easier via XAML, whic include KeyboardBinding, MouseBinding, and MouseWheelBinding. Using these classes, the Gesture property can be set to a simple string value. For example, setting the MouseBinding.Gesture property to "Control+LeftClick" will automatically create the appropriate MouseGesture.

Default Mouse Behavior

The ZoomContentControl includes several default input bindings that use MouseGesture and MouseWheelGesture with one of the commands defined by ZoomContentControlCommands.

The following table lists the default MouseGesture bindings and their associated command.

Gesture | Command
LeftClick | StartPanDrag
Control+LeftClick | StartZoomIn
Control+Shift+LeftClick | StartZoomOut
Shift+LeftClick | StartPanDrag

The following table lists the default MouseWheelGesture bindings and their associated command.

Gesture | Command
PositiveDelta | LineUp
NegativeDelta | LineDown
Shift+PositiveDelta | LineLeft
Shift+NegativeDelta | LineRight
Control+PositiveDelta | ZoomInToPoint
Control+NegativeDelta | ZoomOutFromPoint
Control+Shift+PositiveDelta | ZoomInToPoint
Control+Shift+NegativeDelta | ZoomOutFromPoint

The default input bindings can be disabled by setting AreDefaultInputBindingsEnabled to false. This allows the InputBindings to be completely customized from XAML.

Mouse Cursor

The ZoomContentControl will automatically update it's Cursor property based on the specified input bindings. Specifically, it looks for an input binding that uses a MouseGesture with a MouseAction.LeftClick action and specifies modifier keys that match the current key state. For example, if the Control key is currently pressed, then it will search for a MouseGesture with a MouseAction.LeftClick action and with ModifierKeys.Control defined.

If an input binding is found that matches the current state, then the cursor will be updated based on the specified command. The following table lists the commands and their associated cursor.

Command | Cursor
CenterAndZoomInToPoint |
CenterAndZoomOutFromPoint |
CenterToPoint |
ResetView | None
StartPanDrag | and
StartZoomDrag |
StartZoomIn |
StartZoomOut |
StartZoomToRegion |
ZoomIn |
ZoomInToPoint |
ZoomOut |
ZoomOutFromPoint |
ZoomToFit | None

The mouse cursor can be customized as needed by overriding the UpdateCursor method.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


View Control Pane

The ZoomContentControl includes a view control pane, which allows the user to manipulate the view. This topic covers the view control pane and it's options.

This topic contains these sections:

  • Showing/Hiding
  • Expanding/Collapsing
  • Showing/Hiding Controls
  • Adding Custom Buttons

Showing/Hiding

The view control pane is visible by default, but can be hidden by setting the IsViewControlPaneVisible property to false.

Expanding/Collapsing

The view control pane can be collapsed and expanded by clicking the double arrow button. This minimizes the foot print of the view control pane, when the user wants to view more of the content.

The IsViewControlPaneMinimized property indicates whether the view control pane is current collapsed, and can be used to programmatically expand/collapse the pane. Additionally, the IsViewControlPaneMinimizable property can be used to prevent the view control pane from being interatively collapsed/expanded.

Showing/Hiding Controls

The various controls included on the view control pane can be shown or hidden individually to achive a custom look. The following table lists the various properties used to show or hide the controls.

Property | Description
AreZoomButtonsVisible | Gets or sets a value indicating whether the zoom buttons (which are located directly above and below the zoom slider) are visible on the view control pane.
IsPanPadVisible | Gets or sets a value indicating whether the pan pad is visible in the view control pane.
IsResetViewButtonVisible | Gets or sets a value indicating whether the reset view button is visible in the view control pane.
IsZoomLabelVisible | Gets or sets a value indicating whether the zoom label is visible in the view control pane.
IsZoomSliderVisible | Gets or sets a value indicating whether the zoom slider is visible in the view control pane.
IsZoomToFitButtonVisible | Gets or sets a value indicating whether the zoom-to-fit button is visible in the view control pane.

Adding Custom Buttons

Custom elements (including buttons) can be added to the horizontal bar of the view control pane using the HorizontalItems collection. By default, any elements added will not match the style of the view control pane. Therefore, several Style definitions are provided, which can be used to match the style of the view control pane.

The following table lists various WPF button types and the associated styles.

Type | Description
Button | ButtonBaseStyleKey
RadioButton | ButtonBaseStyleKey
RepeatButton | ButtonBaseStyleKey
Separator | HorizontalSeparatorStyleKey and VerticalSeparatorStyleKey
ToggleButton | ButtonBaseStyleKey

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overlays

Custom UIElement objects can be overlayed on top of the ZoomContentControl content. These elements can be anchored to a specified point, but will not be scaled along with the content.

This topic contains these sections:

  • Overlay Elements
  • Positioning

Overlay Elements

The Overlays collection specifies the elements that will be placed on top of the content.

Positioning

The overlay elements are display in a Canvas element that is postioned on top of the ZoomContentControl content. Therefore, the Canvas.Left, Canvas.Top, Canvas.Right, and Canvas.Bottom properties can be used to position the overlay elements.

The position values are relative to the content. So the point "0,0" is the top-left corner of the content.

The top-left corner of an overlay element can be anchored by only setting the Canvas.Left and Canvas.Top properties. The bottom-left corner of an overlay element can be anchored by only setting the Canvas.Left and Canvas.Bottom properties. The same concept applies to the top-right and bottom-right corners.

The visibility of all the overlay elements can be controlled using the AreOverlaysVisible property.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Supporting Controls

There are two controls that support the ZoomContentControl that can be used independently, as needed. This topic covers these controls and their options.

This topic contains these sections:

  • PanPad
  • ZoomDecorator

PanPad

The PanPad control allows continuous and directional scrolling using the mouse. Once the control has been clicked it will continuously raise the Pan event while the mouse button is held down.

The offsets of the Pan event are calculated using the mouse click location and the current mouse location, which includes both a direction and a magnitude. The offsets can be limited using the MaxOffset property.

Finally, the internval at which the Pan event is fired can be customized using the Interval property.

ZoomDecorator

The ZoomContentControl uses a ZoomDecorator in the default control template to display it's content. The ZoomDecorator can be used to zoom or pan a UIElement, much like the ZoomContentControl, but does not offer any built-in user interaction (such as mouse interation, scroll bars, or the view control pane). The view can still be programmatically zoomed or panned.

Since ZoomDecorator implements IScrollInfo, it can be wrapped in a ScrollViewer if only scrollbars are needed. The only requirement is that ScrollViewer.CanContentScroll be set to true.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Navigation follows WPF best practices for areas such as layout, globalization and accessibility.

Some of the more major features include:

  • Right-to-left support is fully integrated for languages such as Hebrew or Arabic.
  • All text properties use localization attributes.
  • Follows the WPF accessibility model for UI automation.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Flow Direction

Navigation controls supports both left-to-right and right-to-left layouts via a simple property switch.

By default, the controls will use the flow direction designated by the system.

What is Flow Direction?

The flow direction of content typically corresponds to the innate flow direction of the language being represented. English, German, and Russian provide examples of languages that naturally flow from left-to-right. Hebrew and Arabic provide examples of languages that naturally flow from right-to-left.

When a right-to-left flow direction is applied to a user interface control, all contained content is essentially "flipped" over to align to the opposite side as displayed below:

ExplorerBar using a right-to-left flow direction

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Localization

All of the Navigation controls' text properties have the Localizability attribute applied to them, and all strings that are displayed in the user interface can be customized and localized.

This topic contains these sections:

  • Localizable NavigationBar Properties
  • Localizable NavigationPane Properties
  • Localizable BreadcrumbItem Properties
  • Customizing String Resources

Localizable NavigationBar Properties

The following properties on the NavigationBar control are localizable:

  • Title

Localizable NavigationPane Properties

The following properties on the NavigationPane control are localizable:

  • Title

Localizable BreadcrumbItem Properties

The following properties on the BreadcrumbItem control are localizable:

  • PathEntry

Customizing String Resources

All strings that are displayed in the user interface are available from static methods on the ActiproSoftware.Products.Navigation.SR class. Use that class to customize string resources as well.

Note Note
String resource customization is described in great detail in the general Customizing String Resources topic. Please see that topic for in-depth information related to localization of string resources.

An enumation named SRName includes a list of all the string resource names. A XAML markup extension named SRExtension is available for use within XAML templates to access string resources.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UI Automation

Navigation controls follow the WPF accessibility model for UI automation.

What is UI Automation?

Microsoft UI Automation is the new accessibility framework for Microsoft Windows. It addresses the needs of assistive technology products and automated test frameworks by providing programmatic access to information about the user interface (UI).

Navigation implements automation peers for the following classes:

  • The ExpanderBar class, which is the base class of NavigationBar and ExplorerBar. Also the pane items of those controls are WPF Expander controls, which already have UI automation capabilities. These automation peers allow for programmatic access to those UI elements and their child controls.
  • The Breadcrumb class. Also the AnimatedProgressBar class and PopupButton class, which are used in the Breadcrumb, have UI automation capabilities.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Navigation has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to work with the navigation controls.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • Context Menus
  • Task Pane Introduction
  • NavigationBar Task Pane
  • NavigationPane Task Pane
  • Changing the NavigationBar's Selected Pane
  • ExplorerBar Task Pane
  • Breadcrumb Task Pane
  • ZoomContentControl Task Pane
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

Context Menus

Context menus for the NavigationBar, ExplorerBar, and Breadcrumb types are provided. You can right click on either of those controls in the designer to display the related context menu.

The context menus for NavigationBar and ExplorerBar allow for quick addition of new panes to each control. The context menu for Breadcrumb allows for quick addition of a root item or new action buttons to the control. The context menu for ZoomContentControl allows for quick addition of various button types to the horizontal items collection.

Task Pane Introduction

Whenever you select a Navigation control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

NavigationBar Task Pane

The NavigationBar task pane allows you to quickly add a new pane and configure many of its most common options.

The task pane for the NavigationBar control in the Visual Studio designer

You also can reorder panes in the NavigationBar and determine whether the minimized popup can be resized.

NavigationPane Task Pane

The NavigationPane task pane gives you options for configuring the images and title associated with the pane. You can also set its visibility and default sort order (for use with the run-time options window).

The task pane for the NavigationPane control in the Visual Studio designer

Changing the NavigationBar's Selected Pane

You can select a pane and show its content by selecting the pane's header button in the designer.

ExplorerBar Task Pane

The ExplorerBar task pane allows you to quickly add a new expander item. You also can control whether mutiple items can be expanded at once, and can reorder items.

The task pane for the ExplorerBar control in the Visual Studio designer

Breadcrumb Task Pane

The Breadcrumb task pane allows you to quickly add a root item or new action buttons. You can also control various other properties of the Breadcrumb, including properties of the embedded ComboBox and AnimatedProgressBar controls.

The task pane for the Breadcrumb control in the Visual Studio designer

ZoomContentControl Task Pane

The ZoomContentControl task pane allows you to quickly set various properties and add a button to the horizontal items collection.

The task pane for the ZoomContentControl control in the Visual Studio designer

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to v4.0 topic contains information on converting to v4.0 from an older version.
  • The Converting to 2010.2 topic contains information on converting to 2010.2 from v4.0.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from 2010.2.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to v4.0

During the development of v4.0, we made a commitment to ensure that all our WPF product assemblies are scanned using Visual Studio Code Analysis, and that all warnings are handled appropriately. Code Analysis helps make sure that code is kept up to the highest standards and we are proud to now support it. All of the breaking changes below were made to properly handle Code Analysis warnings.

This topic contains these sections:

  • Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll
  • ItemRoutedEventHandler<T>, PropertyChangedRoutedEventHandler<T> Removed

Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll

Per Code Analysis guidelines, the WPF portion of the assembly names was renamed to Wpf. If you have any problems with existing references to the assemblies, just remove the old references in your project and new ones. Also be sure your licenses.licx file is up to date with the info listed in the Licensing topic.

ItemRoutedEventHandler<T>, PropertyChangedRoutedEventHandler<T> Removed

The event handlers listed above were removed per Code Analysis recommendation and replaced with EventHandler<T> usage. This will probably only affect you if you have created class-based event handlers since those reference the delegates. The base event args classes remain the same.

See the Shared Library - Converting to v4.0 topic for more information on these changes, where they affect this product, and how to resolve any issues in your code.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2010.2

Any breaking changes made to the Shared Library are described below.

This topic contains these sections:

  • Replaced XmlSerializerBase Notification Handlers

Replaced XmlSerializerBase Notification Handlers

The XmlSerializerBase`2 class, which has some breaking changes, is the based class of NavigationBarLayoutSerializer. Thus, NavigationBarLayoutSerializer is affected by the breaking change.

See the Shared Library's conversion topic for more information on this breaking change.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.2

Any breaking changes made to the Shared Library are described below.

This topic contains these sections:

  • Theming Architectural and Style Changes
  • Consolidated NavigationBar Expander Styles
  • Moved ExplorerBar's Related Styles
  • Moved ZoomContentControl's Related Styles
  • Added Theming to ZoomContentControlSlider and ZoomContentControlScrollViewer

Theming Architectural and Style Changes

See unified conversion topic for details on breaking changes made to the theming architecture, which affects control styles and related dictionaries.

Consolidated NavigationBar Expander Styles

The Navigation product included two styles for the Expander control. These styles have been consolidated into the Shared Library for use when theming native Expander controls.

In previous versions, the styles could be referenced using the ComponentResourceKeys defined by the NavigationBarCommonDictionary.ExpanderStyleKey and NavigationBarCommonDictionary.ExpanderAlternateStyleKey properties. The NavigationBarCommonDictionary.ExpanderStyleKeyStyle has been removed and the NavigationBarCommonDictionary.ExpanderAlternateStyleKey has been moved to SharedResourceKeys.ExpanderStyleKey.

Upgrade Instructions Upgrade Instructions
  1. All references to NavigationBarCommonDictionary.ExpanderStyleKey must be reviewed and possibly replaced with SharedResourceKeys.ExpanderStyleKey.
  2. All references to NavigationBarCommonDictionary.ExpanderAlternateStyleKey must be replaced with SharedResourceKeys.ExpanderStyleKey.

Moved ExplorerBar's Related Styles

The ExplorerBar has several secondary styles for controls that typically used in conjunction. In previous versions, the styles could be referenced using the ComponentResourceKeys defined by the ExplorerBarCommonDictionary.ExpanderStyleKey, ExplorerBarCommonDictionary.ExpanderAlternateStyleKey, ExplorerBarCommonDictionary.ExpanderHeaderStyleKey, and ExplorerBarCommonDictionary.ExpanderHeaderAlternateStyleKey properties. These Style have been moved to ExplorerBar.ExpanderStyleKey, ExplorerBar.ExpanderAlternateStyleKey, ExplorerBar.ExpanderHeaderStyleKey, and ExplorerBar.ExpanderHeaderAlternateStyleKey, respectively.

Upgrade Instructions Upgrade Instructions
  1. All references to ExplorerBarCommonDictionary.ExpanderStyleKey must be replaced with ExplorerBar.ExpanderStyleKey.
  2. All references to ExplorerBarCommonDictionary.ExpanderAlternateStyleKey must be replaced with ExplorerBar.ExpanderAlternateStyleKey.
  3. All references to ExplorerBarCommonDictionary.ExpanderHeaderStyleKey must be replaced with ExplorerBar.ExpanderHeaderStyleKey.
  4. All references to ExplorerBarCommonDictionary.ExpanderHeaderAlternateStyleKey must be replaced with ExplorerBar.ExpanderHeaderAlternateStyleKey.

Moved ZoomContentControl's Related Styles

The ZoomContentControl has several secondary styles for controls that typically used in conjunction. In previous versions, the styles could be referenced using the ComponentResourceKeys defined by the ZoomContentControlCommonDictionary.ButtonStyleKey, ZoomContentControlCommonDictionary.HorizontalSeparatorStyleKey, ZoomContentControlCommonDictionary.RadioButtonStyleKey, ZoomContentControlCommonDictionary.RepeatButtonStyleKey, ZoomContentControlCommonDictionary.ToggleButtonStyleKey, and ZoomContentControlCommonDictionary.VerticalSeparatorStyleKey properties. The Button styles have been consolidated and moved to ZoomContentControl.ButtonBaseStyleKey, and the Separator styles have been moved to ZoomContentControl.HorizontalSeparatorStyleKey and ZoomContentControl.VerticalSeparatorStyleKey, respectively.

Upgrade Instructions Upgrade Instructions
  1. All references to ZoomContentControlCommonDictionary.ButtonStyleKey, ZoomContentControlCommonDictionary.RadioButtonStyleKey, ZoomContentControlCommonDictionary.RepeatButtonStyleKey, and ZoomContentControlCommonDictionary.ToggleButtonStyleKey must be replaced with ZoomContentControl.ButtonBaseStyleKey.
  2. All references to ZoomContentControlCommonDictionary.HorizontalSeparatorStyleKey must be replaced with ZoomContentControl.HorizontalSeparatorStyleKey.
  3. All references to ZoomContentControlCommonDictionary.VerticalSeparatorStyleKey must be replaced with ZoomContentControl.VerticalSeparatorStyleKey.

Added Theming to ZoomContentControlSlider and ZoomContentControlScrollViewer

In previous versions, neither ZoomContentControlSlider or ZoomContentControlScrollViewer where themed. This meant if you switched from one theme to another, then these controls would always show the default system theme. This has changed with this release, as these controls are now fully themed.

In general, this is not a breaking change, but if theming had been manuallly applied to these controls, then those styles can now be removed.

Upgrade Instructions Upgrade Instructions
Review and possibly remove any Styles applied to ZoomContentControlSlider or ZoomContentControlScrollViewer.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Ribbon is a control suite that implements an Office-like user interface for Windows Presentation Foundation (WPF) and meets all of the core Microsoft licensing requirements for implementation of a ribbon user interface.

A Ribbon demo showing exact reproduction of Word's Insert tab resizing behavior

Ribbon has been designed from the ground up to follow WPF best practices, be extremely configurable, use a command-driven model, and allow for reproduction of nearly all the user interface features found in Office.

To get started using the control, read through this documentation and study the sample project. The sample includes live demos of many of Ribbon's features.

What is a Ribbon?

A ribbon is the term for the great new user interface that Microsoft originally developed for the Office 2007 release. The ribbon user interface was designed to replace the standard types of menus and toolbars that have been used in applications for the past 10+ years.

Ribbons consolidate all user interface commands into a single location, which is easy to use and scales up and down well, thereby providing fast access to all commands regardless of window size.

Features at a Glance

Dynamic Control Layouts

Actipro Ribbon has the most robust control layout code found in any product of its type... and it's fast too! As you resize the Ribbon, you designate how groups and their child controls move through a sequence of progressively smaller variants. All the controls included with Ribbon support multiple variant styles and several panel controls are provided that support variant changes from large to smaller items, along with managing multiple rows of items. Unlike our competition, Actipro's Ribbon's layout features allow you to exactly mimic the layout behavior found in Office.

Integrates with WPF Command Model

All of the controls included with Ribbon are designed specifically for use with the WPF command model (routed commands, ICommandSource, etc). Commands can manage live previews, assign values (font families, sizes, etc.), and can even globally assign user interface elements such as images, labels, and screen tip data to controls that use them.

Numerous Built-In Controls

Actipro Ribbon is bundled with numerous advanced controls that can be both inside and outside of the Ribbon. Controls range from simple buttons, checkboxes, and radio buttons, to popup and split buttons. There are galleries, comboboxes (regular, font family, and font size variations), textboxes, several layout controls and more.

In-Ribbon and Popup Galleries

Galleries are controls that are designed to present a choice to the end user visually. Galleries are often used to render things like styles, colors, underlines, etc. that may be applied to a document. Both in-ribbon and popup galleries are included with Ribbon. In-ribbon galleries always show items within a parent Group, and can optionally scale their width to show items based on the available width. Any control that has a popup (such as a popup button, split button, or in-ribbon gallery) can have a popup gallery on it. Popup galleries support categorization, filtering, zoomed-in items on mouse over, and popup resizing. Any gallery item can be rendered via templates or custom drawn via code. Gallery items support selection tracking and live preview as well.

Color Picker Galleries

Color picker galleries are generally used in popups and present a defined list of colors to the end user. The gallery can optionally auto-generate groups of lighter/darker shades for base colors you specify. Multiple categories of colors may be added to a single gallery, and optional filtering can be applied. These galleries have all the features found in popup galleries, such as color item screen tips, selection tracking and live preview.

Advanced Popups Supporting Any Content, Resizing, Multiple Menu Columns, and More

The popups used in Ribbon allow for complete flexibility for your design. You can place any sort of content within a popup, not just menu items. Any sort of complex panel layouts are possible, including popup headers, multiple columns of menu items, etc. A common use of this is to place popup galleries on a popup with menu items above and/or below the gallery. Ribbon also includes a ContextMenu-based control that supports all of these advanced features and may be used anywhere that a regular ContextMenu can be used.

Backstage / Application Menu / Recent Documents Management

The application menu is where application-level buttons and menu items are generally located. Complete support for the Office 2010-like Backstage menu with tabs and buttons is included. Alternatively Ribbon supports the more traditional Office 2007-like applicaiton menu with large menu items, footer buttons, and additional content display on its right side. Generally recent documents are listed in the additional content area, and Ribbon even comes packed with a control for managing and displaying recent documents, along with pinning capabilities.

Quick Access ToolBar

The Quick Access ToolBar (QAT) may be located above the Ribbon, below the Ribbon or hidden completely. It is always visible no matter which Tab is selected. The QAT has a customize menu that you may add custom items to, and will overflow items to a popup when space is limited. Ribbon has a cloning framework for supporting run-time QAT customizations and persisting changes between application sessions. The complete source code for a fully-functional Customize QAT dialog page is included.

Mini-ToolBar

The mini-toolbar semi-transparently appears near the mouse when a selection is made, offering controls related to the selection. It becomes more opaque as the mouse moves closer to it and becomes less opaque as the mouse moves away from it. Mini-toolbars can also be paired with context menus so that they display above or below the context menu, providing additional options that aren't normally on the context menu. Any controls, including galleries, can be used on the mini-toolbar.

Ribbon Minimization

The Ribbon may be minimized to increase the screen real estate. When in mimized mode, only the Ribbon's Tabs are visible. A Tab may be clicked to display its groups in a popup.

Key Tips and Screen Tips

Ribbon implements key tips provide easy keyboard access to any control on the Ribbon or in its popups. Ribbon also implements screen tips, which are similar to tool tips except that they support some automated layout features, along with contextual help.

Contextual Tab Groups

Contextual tab groups may be displayed when the context of the selection is appropriate for them to be visible. For instance a Picture Tools contextual tab group's Tabs may become active when a picture is selected in a document. Each group may be assigned a separate base tab/background color for visual differentiation.

RibbonWindow (Office-like Window)

The RibbonWindow class mimics the window user interface found in Office, with its rounded corners and custom title bar. When used in Vista with glass enabled, it automatically changes to draw using glass transparency effects behind the QAT and title bar area. RibbonWindow may be used with or without an embedded Ribbon control.

Office Styles for Native WPF Controls

Since Actipro recognizes the need for developers to have a consistent look and feel throughout their application, we have included many Office-like styles for native WPF controls. You can easily apply these themes to scrollbars, statusbars, etc.

Theming

Multiple built-in themes that mimic Office's blue, black and silver themes, as well as all system themes are included. However you can also generate a completely custom theme with a single line of code. Individual theme colors may also be altered as needed. For advanced developers who want even more customization possibilities, we've made all our controls so that they can be styled and templated and all primitive elements that are used in our built-in control templates are public.

Right-to-left, Localization, and Scaling

All Ribbon UI supports right-to-left layouts and all text in the user interface may be localized to other languages. The Ribbon and RibbonWindow may be scaled up so that the UI appears larger to the end user while still retaining precise vector-based clarity.

XBAP Support

Ribbon fully supports use in XBAPs (browser applications). We have specifically engineered it to operate within the bounds of the XBAP security sandbox.

Extensive Documentation and Samples

Actipro has spent a lot of time refining the design of Ribbon to take advantage of WPF best practices. We realize that a good product is only part of the equation though and have also worked very hard to write detailed documentation on the product. In addition to that, Ribbon ships with the full source for many QuickStart examples that each focus on learning a specific Ribbon feature.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Getting up and running with Ribbon is very easy, especially with the samples we include. Ribbon provides all the Office-like ribbon user interface features right out of the box, saving you hundreds of hours of work over implementing it yourself.

This topic contains these sections:

  • Read the Documentation Topics
  • Start with the Sample Project's "Getting Started" QuickStart Series
  • Examine the Other QuickStarts
  • Add Assembly References
  • The Visual Studio Item Templates (Ribbon Window, Ribbon Page)
  • Copy Code from the Sample Project

Read the Documentation Topics

This documentation file contains a lot of information about using Ribbon and its related controls to its fullest. Whenever you have specific questions about a feature, please read through its documentation topic to search for answers.

Start with the Sample Project's "Getting Started" QuickStart Series

The sample project includes a series of "Getting Started" QuickStart windows that walk you through the creation of a ribbon for an application window, step by step. The first step starts with simple creation of a RibbonWindow without a Ribbon control on it. The steps proceed to add a Ribbon, configuring a new feature in each step until at the last step, there is a fully-functional ribbon. Since the XAML code for a ribbon implementation can get quite large, we chose to put all our sample code in the Getting Started series of quick starts instead of in this documentation file.

The Getting Started series is probably the best place to go for quickly getting up and running. All of the "Getting Started" windows can be run from the Sample Browser and their source code (the most important thing) is located in the sample browser's project.

Although each "Getting Started" QuickStart focuses on adding a new piece of functionality to the ribbon and the changes for each step are described within the QuickStarts, it still may be useful to use a "text diff" application to see exactly what code differences are between each "Getting Started" step.

Examine the Other QuickStarts

We've spent a lot of time adding numerous QuickStarts for Ribbon that are located in the sample project. Each QuickStart focuses on a specific feature area and provides some great code that you can look at to use in your own applications.

Add Assembly References

Once you are ready to add Ribbon to your own application, first add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.Ribbon.Wpf.dll assemblies. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

The Visual Studio Item Templates (Ribbon Window, Ribbon Page)

If you have Visual Studio, two item templates named Ribbon Window (WPF) and Ribbon Page (WPF) should have been installed during the WPF Studio installation procedure.

When you wish to create a new RibbonWindow in your application, simply choose Add New Item in Visual Studio and select the Ribbon Window (WPF) item template. A RibbonWindow with a Ribbon already on it will be added to your project and opened.

When you wish to create a new Page in your application (for use in XBAP), simply choose Add New Item in Visual Studio and select the Ribbon Page (WPF) item template. A Page with a Ribbon already on it will be added to your project and opened.

The use of item templates is the fastest way to get started with our products in your own applications.

Copy Code from the Sample Project

We encourage you to copy any code from our sample project. It will really help you build a ribbon framework in a matter of minutes instead of hours. Again, the best place to copy from is the "Getting Started" series of QuickStarts.

Note Note
Please note that some images in the sample project are copyrighted by Microsoft and we include them in our sample project for control demonstration purposes only!

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Ribbon has a large number of built-in controls that are ready for use. Some controls are for interactive use by the end user while others are used more for layout purposes.

This portion of the documentation links to the various other help topics that relate to controls: learning the basics, information on the control types, and other miscellaneous information.

Control Basics

All of the built-in interactive ribbon controls and several other ribbon controls share some common characteristics and concepts.

See the Control Basics topic for more information on general ribbon control concepts.

Built-in Interactive Controls

Interactive controls are controls that are located throughout the ribbon user interface and in menus and are the ones that end users primarily interact with.

Control Type | Description
Button | Normal button and checkable button.
PopupButton | Button that displays a popup when clicked.
SplitButton | Button that has two clickable areas. The button portion of the split button acts like a normal button or checkable button. The drop-down portion of the split button displays a popup.
CheckBox | A checkbox control.
RadioButton | A radio button control.
TextBox | A textbox control.
ComboBox | A combobox control.
FontFamilyComboBox | A combobox control that allows for selection of a font family.
FontSizeComboBox | A combobox control that allows for selection of a font size.
Separator | A separator when used in a menu or as a large item in a group. Can display text when a label is specified in menus. Also renders as a normal label when used as a small item in a group.
RibbonGallery | A control that allows for the presentation of one or more categories of items within the ribbon. The items act like buttons and are displayed in a scrollable list that animates when scrolled.
PopupGallery | A control that allows for the presentation of one or more categories of items within a popup. The items act like buttons and are displayed in a scrollable list that can be categorized and filtered.
ColorPickerGallery | A control that presents one or more categories of colors within a popup, supports screen tips for colors, and optional auto-generation of lighter/darker shades of colors.

Built-in Layout Controls

Layout controls govern where other controls are placed within a Ribbon.

Control Type | Description
ButtonGroup | A layout control that is most often used as a child item of a RowPanel or a StatusBarItem. The button group contains one or more child controls and optionally draws a border around them.
RowPanel | A layout control that can be used in a Group to provide two-row layouts of child controls, which can switch to a three-row variant as available width decreases.
StackPanel | Displays up to three child controls in large variants horizontally and switches to a vertically-stacked layout of smaller control variants as available width decreases. As available width continues to decrease, child control labels are removed.

Built-in Miscellaneous Controls

There are a number of other miscellaneous controls used in the ribbon user interface.

Control Type | Description
ApplicationMenu | The application menu displayed when the application button on the ribbon is clicked.
ContextMenu | A context menu that inherits ContextMenu and through use of a contained Menu control, allows any ribbon control to be used as child items. This allows for a consistent presentation throughout your application. Best of all, since our context menu class inherits ContextMenu, it can be used anywhere that a regular ContextMenu can.
ContextualTabGroup | A contextual tab group that contains one or more Tab controls and can be displayed based on document context.
Group | A group that can appear on a Tab.
Menu | A control that renders its items using templates that have menu item-like functionality.
Mini-ToolBar | The mini-toolbar can be displayed semi-transparently after a mouse selection or paired along with a context menu.
QuickAccessToolBar | The quick access toolbar (QAT) that can be displayed above or below the ribbon.
RecentDocumentMenu | A control that can be used as the additional content of an ApplicationMenu. It manages a sorted list of recently-opened documents and allows pinning of the documents.
Tab | A tab within a ribbon. The tab contains one or more Group controls.

Working with Popups

A number of ribbon controls have popups associated with them. The popups can contain any sort of content, including a Menu of menu items or one or more custom controls.

See the Working with Popups topic for more information on all the capabilities of popups.

Customizing the QAT

Actipro Ribbon supports complete run-time customization of the Quick Access ToolBar (QAT) by the end user via the use of context menus and also Customize QAT dialog windows.

See the Customizing the QAT topic for more information on how to get up and running with run-time QAT customization features in your application.

Using Custom Controls

Actipro Ribbon has been designed so that nearly any control can be used within the Ribbon itself, in ribbon menus, or in popups.

See the Custom Controls topic for more information on adding custom controls to the ribbon user interface.

Customizing Context Menus

Ribbon allows for the dynamic creation/updating of context menus as well as the same for the QuickAccessToolBar Customize button's menu.

See the Customizing Context Menus topic for more information on how to dynamically customize context menus.

Standalone Control Usage

Actipro has created the ribbon controls with WPF control design best practices in mind and so that they can be used outside of the ribbon, in other parts of your application as well.

See the Standalone Control Usage topic for more details on using ribbon controls outside of the ribbon and even in other windows.

RibbonWindow

Actipro Ribbon includes a RibbonWindow class, which is an implementation of the Window class that provides a custom window user interface much like that found in Office.

See the RibbonWindow topic for more information on using the RibbonWindow class, even without a Ribbon control inside of it.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Control Basics

All of the built-in interactive ribbon controls and several other ribbon controls share some common characteristics and concepts. This topic reviews some of the core concepts for all these controls.

This topic contains these sections:

  • Base Classes
  • Context and Variant Size
  • User Interface Elements
  • Commands
  • Popups
  • Key Tips
  • Screen Tips

Base Classes

Almost all of the controls described in the following sections inherit one of these four abstract base classes:

  • ControlBase
  • ItemsControlBase
  • ComboBoxBase
  • TextBoxBase

These base classes all implement a number of attached properties from classes like RibbonControlService.

Context and Variant Size

Each control is associated with a context that describes how the control is currently being used. This allows a control to alter its appearance and/or behavior if it is on the ribbon vs. on a menu item.

The context is available via the Context property, which returns an enumeration value of type ControlContext.

Many controls also support the concept of a variant. A variant is a different look for a control that can be applied while in the same context. For instance, Button controls have three variant sizes that are used for most cases, like when they are in the ribbon. The large variant size is a tall button with a large image and text underneath it. The medium variant size is a more normal size button with a small image and text label to the right of it. The small variant size is like the medium variant size except that the label disappears.

The variant size is available via the VariantSize property, which returns an enumeration value of type VariantSize.

All of the controls that support multiple variants use triggers in their styles to switch templates based on their current context and variant size settings.

User Interface Elements

The base classes above all define some common user interface properties for how a control is displayed. In many cases, controls on a ribbon require a text label and/or image to be set per the ribbon requirements.

These can be set on the control instance and alternatively can be set on a ribbon command (see the Using Commands to Provide User Interface Elements topic) that the control uses. Note that the control instance property values override those supplied by a ribbon commands.

These members on the base classes relate to user interface elements:

Member | Description
HasImage Property | Gets whether the control has an image available for display.
HasLabel Property | Gets whether the control has a label available for display.
ImageSourceLarge Property | Gets or sets the ImageSource for the 32x32 image to display for the control.
ImageSourceSmall Property | Gets or sets the ImageSource for the 16x16 image to display for the control.
Label Property | Gets or sets the text label to display for the control.

Commands

Many of the interactive ribbon controls support a completely command-driven user interface. This means that commands are able to process actions such as the pressing of the button as well as provide common user interface elements such as images and labels to any control that uses the command.

Please see the Using Commands to Provide User Interface Elements topic for detailed information on using commands with controls and how to optionally have them provide common user interface elements.

Popups

Several controls like PopupButton and SplitButton have popups associated with them. The popups can contain any sort of content, including a Menu of menu items or one or more custom controls.

See the Working with Popups topic for more information on all the features available to you with popups.

Key Tips

The control base classes all have built-in support for key tips, which are little popups that display when Alt is pressed and allow for quick keyboard access to each control.

Please see the Key Tips topic for detailed information on working with key tips.

Screen Tips

The control base classes also all have built-in support for screen tips, which are essentially tooltips that display a lot of helpful contextual information to the end user for a control.

Please see the Screen Tips topic for detailed information on working with screen tips.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Interactive controls are controls that are located throughout the ribbon user interface and in menus and are the ones that end users primarily interact with.

Control Type | Description
Button | Normal button and checkable button.
PopupButton | Button that displays a popup when clicked.
SplitButton | Button that has two clickable areas. The button portion of the split button acts like a normal button or checkable button. The drop-down portion of the split button displays a popup.
CheckBox | A checkbox control.
RadioButton | A radio button control.
TextBox | A textbox control.
ComboBox | A combobox control.
FontFamilyComboBox | A combobox control that allows for selection of a font family.
FontSizeComboBox | A combobox control that allows for selection of a font size.
Separator | A separator when used in a menu or as a large item in a group. Can display text when a label is specified in menus. Also renders as a normal label when used as a small item in a group.
RibbonGallery | A control that allows for the presentation of one or more categories of items within the ribbon. The items act like buttons and are displayed in a scrollable list that animates when scrolled.
PopupGallery | A control that allows for the presentation of one or more categories of items within a popup. The items act like buttons and are displayed in a scrollable list that can be categorized and filtered.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Button

The Button class provides an implementation of normal buttons and checkable buttons.

This topic contains these sections:

  • Variants
  • Capabilities
  • Managing the Checked State
  • Adding a Description for Large Menu Items
  • Changing the Image Size
  • Preventing the Large Variant's Label from Word Wrapping
  • Sample XAML
  • Toggle Minimization Button

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | Large |
MenuItem | Medium, Small |
(any other) | Large |
(any other) | Medium |
(any other) | Small |
(any other) | Collapsed | (also has ImageSourceSmallSize set to 11,11 for this sample)

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | Yes.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | ButtonBase.
Child items | None.
Has popup | No.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | No.
Click event trigger | When the button is clicked.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | Yes. Controls the checked state of the button.
Supports IValueCommandParameter | No.
Default CommandParameter | CheckableCommandParameter.

Managing the Checked State

This control is designed to use the WPF command model to maintain the checked state of the control. By default a CheckableCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Checkable Controls topic for detailed information on using this command parameter to manage the checked state.

Adding a Description for Large Menu Items

Any ButtonBase-derived control has a MenuItemDescription property. This property can be set to a string to display an extended description when used in a large menu context, such as in the application menu.

When set, the Label of the control will be displayed in bold above the description. The description will wrap to as many lines as needed to display itself. This feature is best used on button-based controls that appear on a child menu of a root application menu item.

Changing the Image Size

In any of the non-large variant sizes, you can set the ImageSourceSmallSize property to the specific size image that you'd like to display. By default, this is 16x16 however you could make it smaller or larger if you have a smaller or larger image.

This functionality is typically used outside of the Ribbon in standalone use of the control. If you wish to have a smaller control than the default, be sure to set MinHeight to 0 as well since the MinHeight for the Medium and Small variants of this control currently ensures the control is the proper height for usage in the Ribbon, per the requirements stated by Microsoft.

Preventing the Large Variant's Label from Word Wrapping

Sometimes you may have a short couple of words that make up a button's label and you run across a case where instead of the button placing words on two separate lines, you would prefer to have them both on the same line. Ribbon includes an easy way to accomplish this.

Instead of using a normal space character between the words in your label, use a non-breaking space character like this:

XAML
Copy
​<ribbon:Button Label="Data Set" />

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:Button ImageSourceLarge="/Images/SmartArt32.png"
    ImageSourceSmall="/Images/SmartArt16.png" Label="SmartArt" KeyTipAccessText="M" />

This code shows how to prototype this control in in XAML but by also using a ribbon command to set up its user interface:

XAML
Copy
​<ribbon:Button Command="ApplicationCommands.Paste" KeyTipAccessText="P" />

Toggle Minimization Button

There is a special built-in button that adds button-based toggle minimization functionality to the Ribbon, as first seen in Office 2010. This button, implemented by the ToggleMinimizationButton class, can be inserted in the TabPanelItems to show up on the right side of the ribbon, in the same row as its tabs.

This code shows how to insert the toggle minimization button into a ribbon.

XAML
Copy
​<ribbon:Ribbon>
    ...
    <ribbon:Ribbon.TabPanelItems>
        <ribbon:ToggleMinimizationButton />
    </ribbon:Ribbon.TabPanelItems>
    ...
</ribbon:Ribbon>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CheckBox

The CheckBox class provides an implementation of checkboxes.

This topic contains these sections:

  • Variants
  • Capabilities
  • Managing the Checked State
  • Checked State Events
  • Adding a Description for Large Menu Items
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | Large |
MenuItem | Medium, Small |
(any other) | (any) |

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | No.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | ButtonBase.
Child items | None.
Has popup | No.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | No.
Click event trigger | When the checkbox is clicked.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | Yes. Controls the checked state of the checkbox.
Supports IValueCommandParameter | No.
Default CommandParameter | CheckableCommandParameter.

Managing the Checked State

This control is designed to use the WPF command model to maintain the checked state of the control. By default a CheckableCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Checkable Controls topic for detailed information on using this command parameter to manage the checked state.

In addition you can manage the checked state of this control programmatically by setting the IsChecked property. When no command is set to the control, the control will automatically toggle IsChecked when it is clicked. By default it will toggle between true and false, but if IsThreeState is true, it will also toggle into an indeterminate state.

Checked State Events

This control exposes three events that can fire when the IsChecked property changes value. Each event fires for a certain value of IsChecked:

  • Checked event
  • Indeterminate event
  • Unchecked event

Adding a Description for Large Menu Items

Any ButtonBase-derived control has a MenuItemDescription property. This property can be set to a string to display an extended description when used in a large menu context, such as in the application menu.

When set, the Label of the control will be displayed in bold above the description. The description will wrap to as many lines as needed to display itself. This feature is best used on button-based controls that appear on a child menu of a root application menu item.

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:CheckBox Label="Toggle Bold" KeyTipAccessText="B" />

This code shows how to prototype this control in in XAML but by also using a ribbon command to set up its user interface:

XAML
Copy
​<ribbon:CheckBox Command="EditingCommands.ToggleBold" KeyTipAccessText="B" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ColorPickerGallery

The ColorPickerGallery class provides an implementation of color selection galleries that appear within a popup. Multiple categories of colors can be added, lighter/darker shades of colors can be auto-generated, screen tips can be assigned to items, and optional filtering can be applied.

This topic contains these sections:

  • Variants
  • Capabilities
  • Items Must Be SolidColorBrushes
  • Auto-Generating Lighter/Darker Shades of Colors
  • Initial Column Display
  • Hiding the Selected Value
  • Processing Item Clicks and Managing the Selected Value
  • Supporting Live Preview
  • Categorizing Items
  • Categorized Item Filtering
  • Gallery Item Templates
  • Item Screen Tips
  • Important Members
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports a single variant although the overall appearance of the gallery may be altered by specifying a different initial column count, the optional use of categorization, and the optional use of filtering.

Context | Variant Size | Sample UI
(any) | (any) |

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | No. Is not for use in the ribbon itself, but rather on popups.
Supports normal size | Yes, however the control's normal size can be quite large.
Supports use in a Menu | No. This gallery should be used in a popup but outside of a Menu control. However one commonly-used technique is to use a native WPF StackPanel as the popup content with the PopupGallery as one child and a Menu containing menu items above or below the gallery.
Base class | PopupGallery.
Child items | Yes. The items must be of type SolidColorBrush and gallery may be bound to an ItemsSource as well.
Has popup | No.
Key tip access | No.
Is key tip scope | Yes.
Click event trigger | When an item in the gallery is clicked.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | No.
Supports IValueCommandParameter | Yes. Controls the selected value of the PopupGallery and supports live preview.
Default CommandParameter | BrushValueCommandParameter.

Items Must Be SolidColorBrushes

The items of this control must be of type SolidColorBrush. This makes it easy to use the selected color directly when you apply it to other controls. And it also means that attached properties (like for screen tips, categorization and layout behavior) can be be applied to each item.

Auto-Generating Lighter/Darker Shades of Colors

The gallery can intelligently auto-generate lighter and darker shades of base colors on any colors you like. When using this feature, there are several requirements.

First, the base colors must be set to the ColorPickerGallery.CategorizedItemsSource property. Doing this allows extra colors to be added to the "real" items source that is set to the ItemsSource property automatically.

Second, the base color items that need shades generated must have the ColorPickerGallery.LayoutBehaviorProperty attached property set to Shaded. This tells the gallery to generate the array of lighter and darker shades for that base color.

Third, the ColorPickerGallery.InitialColumnCount property must be set to the number of base colors that will have auto-generated shades added. This ensures that the generated items wrap properly within the gallery and appear directly under the proper base color.

After doing those things, you are ready to go. You can even add other colors that don't require shades, however please place them in a separate category from the category used for the shade base colors.

Initial Column Display

The ColorPickerGallery.InitialColumnCount property is used to specify the initial number of columns that should be displayed when the popup that contains the PopupGallery is displayed.

The gallery measures the size of the items for you and determines how wide to ensure the popup is so that the number of columns of items you specify can be displayed.

Note Note
If the auto-generation of lighter/darker shades is being used, InitialColumnCount must be set to the number of base colors before a break is inserted for the auto-generated groups of shade colors. In the screenshot above, the initial column count is 10.

Hiding the Selected Value

By default, the SelectedItem will be drawn with a highlight to indicate its selected state to the end user. However they may be cases where you wish to prevent the end user from seeing any sort of highlighted item in the gallery. To do this, set the IsSelectionHighlightVisible property to false.

Processing Item Clicks and Managing the Selected Value

When an item is clicked, the ItemClick is raised. This event passes arguments that specify which item was clicked. The clicked item becomes the SelectedItem and is passed through as the value to the command for the gallery.

Galleries are designed to support the WPF command model for maintaining the selected value of the control. By default an ObjectValueCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Value Controls topic for detailed information on using this command parameter to manage the control's value (selected item) and support live preview.

If you aren't using commands, you can choose to handle to SelectedItemChanged event to be notified when the SelectedItem property is changed.

Supporting Live Preview

When the mouse moves over an item, the item becomes the ActiveItem. Many applications use the currently "active" item to supply a live preview to the end user of what would happen if the item was clicked. Live preview for galleries can be implemented in one of two ways.

If you are using commands, the Interaction with Value Controls topic explains how to support live preview using command can-execute handlers.

Alternatively, if you would rather use events, the ActiveItemChanged event fires whenever the ActiveItem property is changed.

Categorizing Items

The PopupGallery.CategoryProperty attached property can be assigned to each item. If you choose to show categories in your ColorPickerGallery, the property values you specify will be used to group the items into categories. The list style screenshot above shows categories being used.

This sample XAML code shows how to apply the Category attached property to an item:

XAML
Copy
​<media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#C00000" ribbon:ScreenTipService.ScreenTipHeader="Dark Red" />
<media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#FF0000" ribbon:ScreenTipService.ScreenTipHeader="Red" />

By default the categorization feature is disabled in PopupGallery. You can enable it by binding your items to the CategorizedItemsSource property instead of the normal ItemsSource property. This tells ColorPickerGallery to switch to categorized item mode.

Categorized Item Filtering

If you have categorization enabled in your ColorPickerGallery as described above, you can optionally add filtering capabilities. The filter is a button at the top of the ColorPickerGallery that when clicked, shows a menu of available filters.

There is always an All option and then rest of the options are the various category names. The All filter is used by default and does not perform any filtering. When a specific category is chosen as a filter, only the items in that category are displayed.

Use the CanFilter property to determine whether the filtering UI is available to the end user. The current category that is being filtered is available via the FilterCategory property.

Gallery Item Templates

The default item template for this control is defined as:

XAML
Copy
​<DataTemplate>
    <Rectangle Fill="{Binding BindsDirectlyToSource=True}" Width="13" Height="13" />
</DataTemplate>

You could define another template with a different size rectangle if you require larger items.

Item Screen Tips

Screen tips can be attached directly to gallery items via the ScreenTipService attached properties like this:

XAML
Copy
​<media:SolidColorBrush Color="#C00000" ribbon:ScreenTipService.ScreenTipHeader="Dark Red" />

Important Members

Since galleries indirectly inherit ItemsControl, you should use the Items or ItemsSource properties to bind the gallery to data. If you are going to want to use auto-generation of lighter/darker shades of colors then you must use the CategorizedItemsSource property.

This table lists the important members of the PopupGallery control, other than the ones inherited from ItemsControl.

Member | Description
ActiveItem Property | Gets the item that is currently active (being previewed).
ActiveItemChanged Event | Occurs when the ActiveItem property is changed.
CanFilter Property | Gets or sets whether the gallery can filter categorized items. The default value is false. This property requires that CategorizedItemsSource is not null for it to function correctly.
CategorizedItemsSource Property | Gets or sets the items source to used when categorization of items is desired. Use this property instead of ItemsSource when categorization of items is desired. By setting this property, the ItemsSource will be set to a view that supports categories and the IsCategorized property will be set to true.
CategoryProperty Attached Property | The text-based attached property that should be applied to items when categorization of items is desired.
CategoryTemplate Property | Gets or sets the DataTemplate to use for the display of categories. This template is used when the IsCategorized property is true.
DefaultThemeColors Property | Gets an array of default theme colors. This array can be used to programmatically build SolidColorBrush items for this gallery.
FilterCategory Property | Gets or sets the category of items that is currently being filtered when CanFilter is true. This property does nothing if CanFilter is false or CategorizedItemsSource is null. When set to null, no filtering will be performed and items in all categories will be displayed.
InitialColumnCount Property | Gets or sets the initial number of gallery item columns that are displayed when the popup appears. The default value is 10.
IsCategorized Property | Gets whether the gallery is currently categorizing its items. This property will be set to true if the CategorizedItemsSource property is set to an items source.
IsPreviewEnabled Property | Gets or sets whether preview command notifications are enabled for the items. The default value is false so set it to true to enable live preview functionality.
IsSelectionHighlightVisible Property | Gets or sets whether the SelectedItem's selection highlight is visible for the gallery. The default value is true.
ItemClick Event | Occurs when an item is clicked.
LayoutBehaviorProperty Attached Property | The attached property of type ColorPickerGalleryItemLayoutBehavior that should be applied to items to alter their layout. Use the Shaded option for colors that should have lighter/darker shades added.
SelectedItem Property | Gets or sets the item that is currently selected.
SelectedItemChanged Event | Occurs when the SelectedItem property is changed.
StandardColors Property | Gets an array of standard colors. This array can be used to programmatically build SolidColorBrush items for this gallery.

Sample XAML

This sample XAML code shows how to create a foreground color picker similar to the one in Word.

XAML
Copy
​<ribbon:ColorPickerGallery InitialColumnCount="10" VerticalScrollBarVisibility="Hidden" HorizontalAlignment="Center">
    <ribbon:PopupGallery.CategorizedItemsSource>
        <x:Array Type="{x:Type media:SolidColorBrush}">
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#FFFFFF" ribbon:ScreenTipService.ScreenTipHeader="White" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#000000" ribbon:ScreenTipService.ScreenTipHeader="Black" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#EEECE1" ribbon:ScreenTipService.ScreenTipHeader="Tan" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#1F497D" ribbon:ScreenTipService.ScreenTipHeader="Dark Blue" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#4F81BD" ribbon:ScreenTipService.ScreenTipHeader="Blue" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#C0504D" ribbon:ScreenTipService.ScreenTipHeader="Red" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#9BBB59" ribbon:ScreenTipService.ScreenTipHeader="Olive Green" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#8064A2" ribbon:ScreenTipService.ScreenTipHeader="Purple" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#4BACC6" ribbon:ScreenTipService.ScreenTipHeader="Aqua" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Theme Colors" ribbon:ColorPickerGallery.LayoutBehavior="Shaded" Color="#F79646" ribbon:ScreenTipService.ScreenTipHeader="Orange" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#C00000" ribbon:ScreenTipService.ScreenTipHeader="Dark Red" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#FF0000" ribbon:ScreenTipService.ScreenTipHeader="Red" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#FFC000" ribbon:ScreenTipService.ScreenTipHeader="Orange" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#FFFF00" ribbon:ScreenTipService.ScreenTipHeader="Yellow" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#92D050" ribbon:ScreenTipService.ScreenTipHeader="Light Green" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#00B050" ribbon:ScreenTipService.ScreenTipHeader="Green" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#00B0F0" ribbon:ScreenTipService.ScreenTipHeader="Light Blue" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#0070C0" ribbon:ScreenTipService.ScreenTipHeader="Blue" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#002060" ribbon:ScreenTipService.ScreenTipHeader="Dark Blue" />
            <media:SolidColorBrush ribbon:PopupGallery.Category="Standard Colors" Color="#7030A0" ribbon:ScreenTipService.ScreenTipHeader="Purple" />
        </x:Array>
    </ribbon:PopupGallery.CategorizedItemsSource>
</ribbon:ColorPickerGallery>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ComboBox

The ComboBox class provides an implementation of native WPF ComboBox that has enhanced functionality for use in a ribbon.

This topic contains these sections:

  • Variants
  • Capabilities
  • Managing the Selected Value
  • Supporting Live Preview
  • Text to Value Conversion
  • Layout on the Ribbon and in Menus
  • Working with the ComboBox
  • Hint Text
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | (all) |
(any other) | Medium (when in StackPanel) |
(any other) | (any other) |

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | No. When in the ribbon, it should be placed in a StackPanel that is in a Medium variant or smaller.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | ComboBoxBase.
Child items | Yes. The items collection inherits from the native WPF ComboBox class and data binding to ItemsSource is fully supported.
Has popup | Yes. The items are displayed in the popup.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | No.
Click event trigger | When the Enter key is pressed while in the control, when a new ComboBox selection is made, or when the control loses focus and the value is changed.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | No.
Supports IValueCommandParameter | Yes. Controls the selected value of the ComboBox and supports live preview.
Default CommandParameter | ObjectValueCommandParameter.

Managing the Selected Value

This control is designed to use the WPF command model to maintain the selected value of the control. By default an ObjectValueCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Value Controls topic for detailed information on using this command parameter to manage the control's value and support live preview.

Supporting Live Preview

When the mouse moves over an item, the item becomes the ActiveItem. Many applications use the currently "active" item to supply a live preview to the end user of what would happen if the item was clicked. Live preview for comboboxes can be implemented in one of two ways.

If you are using commands, the Interaction with Value Controls topic explains how to support live preview using command can-execute handlers.

Alternatively, if you would rather use events, the ActiveItemChanged event fires whenever the ActiveItem property is changed.

Text to Value Conversion

When the ComboBox is flagged as editable (via IsEditable), the TextToValueConverter property should be set to a converter that is capable of converting from a string to your target item type like a Brush, etc. This allows you to type in values that don't necessarily exist in the ComboBox's list and use the new value.

Note that when the items in the ComboBox are strings, no converter is necessary.

Layout on the Ribbon and in Menus

It is recommended that when a ComboBox is used in the ribbon that a specific Width be set. When used within a StackPanel, controls such as ComboBox (that don't draw labels inside their bounds like Button controls do) will be lined up and stacked vertically and their optional labels and images will be drawn to the left of them.

When used in a Menu, a MinWidth should be set on the ComboBox. Since the left edge of controls like ComboBox will vary based on the width of its Label, setting a MinWidth ensures that the ComboBox itself will be at least a certain appropriate width and can grow as needed to fill the width of the menu.

Working with the ComboBox

The ribbon ComboBox indirectly inherits the native WPF ComboBox control, so anything you can do in the native WPF ComboBox you can do in the ribbon ComboBox.

Please see the MSDN documentation on the native WPF ComboBox for more details on its capabilities.

Hint Text

Hint text is a faded out blurb of text that appears when a TextBox or ComboBox is empty. It usually gives some simple instruction for related to the data that should be input to the control, or a description of that data that should be entered.

The hint text starts out somewhat opaque when there is no content in the control. If the control gains focus, the hint text becomes slightly more transparent. If content is entered, the hint text disappears completely.

The same TextBox in three hint text states... the top TextBox doesn't have focus or content, the middle TextBox has focus but no content, and the bottom TextBox has focus and content

Transitions between the various hint text states use smooth animations for visual appeal.

This code shows how to set hint text:

XAML
Copy
​<ribbon:ComboBox Width="100" HintText="Type here" />

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:ComboBox Width="140" ImageSourceSmall="/Images/Find16.png" Label="Find" KeyTipAccessText="F" />

This code shows how to prototype this control in in XAML but by also using a ribbon command to set up its user interface:

XAML
Copy
​<ribbon:ComboBox Width="140" Command="ApplicationCommands.Find" KeyTipAccessText="F" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


FontFamilyComboBox

The FontFamilyComboBox class provides an implementation of a ComboBox that allows for selection of a font family. The font family list is automatically populated.

This topic contains these sections:

  • Variants
  • Capabilities
  • Managing the Selected Value
  • Layout on the Ribbon and in Menus
  • Working with the FontFamilyComboBox
  • Setting Whether Items Display Text Using the Font Family
  • Validating Typefaces
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | (all) |
(any other) | Medium (when in StackPanel) |
(any other) | (any other) |

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | No. When in the ribbon, it should be placed in a StackPanel that is in a Medium variant or smaller.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | ComboBox.
Child items | Yes. The items collection inherits from the native WPF ComboBox class and data binding to ItemsSource is fully supported.
Has popup | Yes. The items are displayed in the popup.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | No.
Click event trigger | When the Enter key is pressed while in the control, when a new ComboBox selection is made, or when the control loses focus and the value is changed.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | No.
Supports IValueCommandParameter | Yes. Controls the selected value of the ComboBox and supports live preview.
Default CommandParameter | FontFamilyValueCommandParameter.

Managing the Selected Value

This control is designed to use the WPF command model to maintain the selected value of the control. By default an FontFamilyValueCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Value Controls topic for detailed information on using this command parameter to manage the control's value and support live preview.

Layout on the Ribbon and in Menus

It is recommended that when a ComboBox is used in the ribbon that a specific Width be set. When used within a StackPanel, controls such as ComboBox (that don't draw labels inside their bounds like Button controls do) will be lined up and stacked vertically and their optional labels and images will be drawn to the left of them.

When used in a Menu, a MinWidth should be set on the ComboBox. Since the left edge of controls like ComboBox will vary based on the width of its Label, setting a MinWidth ensures that the ComboBox itself will be at least a certain appropriate width and can grow as needed to fill the width of the menu.

Working with the FontFamilyComboBox

The ribbon FontFamilyComboBox indirectly inherits the native WPF ComboBox control, so anything you can do in the native WPF ComboBox you can do in the ribbon FontFamilyComboBox.

Please see the MSDN documentation on the native WPF ComboBox for more details on its capabilities.

You can also use the SelectedValue property to get/set the actual selected FontFamily value. The static FontFamilyComboBox.GetFontFamily method can be used to retrieve a FontFamily from a font family name, allowing you to set the control's value manually like this:

C#
VB
Copy
​myFontFamilyComboBox.SelectedValue = FontFamilyComboBox.GetFontFamily("Courier New");
​myFontFamilyComboBox.SelectedValue = FontFamilyComboBox.GetFontFamily("Courier New")

Setting Whether Items Display Text Using the Font Family

By default each item in the drop-down will draw its font family name in the actual FontFamily that it represents. This behavior can be disabled by setting the FontFamilyComboBox.UsePreviewInItemRendering property to false.

When this feature is disabled, each item will draw the font family name in the standard UI font.

Validating Typefaces

The control has a IsTypefaceValidationEnabled property that defaults to false. When set to true, it will examine each font family's typefaces as the font family is being added to the combobox. If the font family's typefaces cannot be loaded for some reason (which can occur with some Adobe fonts), it will not be added to the control. The downside of this feature is that it can potentially cause a couple second delay during window load time, thus it is disabled by default.

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:FontFamilyComboBox Width="135" Label="Font Family" KeyTipAccessText="FF" />

This code shows how to prototype this control in in XAML but by also using a ribbon command to set up its user interface:

XAML
Copy
​<ribbon:FontFamilyComboBox Width="135"
    Command="sample:ApplicationCommands.FontFamily" KeyTipAccessText="FF" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


FontSizeComboBox

The FontSizeComboBox class provides an implementation of a ComboBox that allows for selection of a font size. The font size list is automatically populated.

This topic contains these sections:

  • Variants
  • Capabilities
  • Managing the Selected Value
  • Layout on the Ribbon and in Menus
  • Working with the FontSizeComboBox
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | (all) |
(any other) | Medium (when in StackPanel) |
(any other) | (any other) |

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | No. When in the ribbon, it should be placed in a StackPanel that is in a Medium variant or smaller.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | ComboBox.
Child items | Yes. The items collection inherits from the native WPF ComboBox class and data binding to ItemsSource is fully supported.
Has popup | Yes. The items are displayed in the popup.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | No.
Click event trigger | When the Enter key is pressed while in the control, when a new ComboBox selection is made, or when the control loses focus and the value is changed.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | No.
Supports IValueCommandParameter | Yes. Controls the selected value of the ComboBox and supports live preview.
Default CommandParameter | DoubleValueCommandParameter.

Managing the Selected Value

This control is designed to use the WPF command model to maintain the selected value of the control. By default an DoubleValueCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Value Controls topic for detailed information on using this command parameter to manage the control's value and support live preview.

Layout on the Ribbon and in Menus

It is recommended that when a ComboBox is used in the ribbon that a specific Width be set. When used within a StackPanel, controls such as ComboBox (that don't draw labels inside their bounds like Button controls do) will be lined up and stacked vertically and their optional labels and images will be drawn to the left of them.

When used in a Menu, a MinWidth should be set on the ComboBox. Since the left edge of controls like ComboBox will vary based on the width of its Label, setting a MinWidth ensures that the ComboBox itself will be at least a certain appropriate width and can grow as needed to fill the width of the menu.

Working with the FontSizeComboBox

The ribbon FontSizeComboBox indirectly inherits the native WPF ComboBox control, so anything you can do in the native WPF ComboBox you can do in the ribbon FontSizeComboBox.

Please see the MSDN documentation on the native WPF ComboBox for more details on its capabilities.

You can also use the SelectedValue property to get/set the actual selected Double value. Set the control's value manually like this:

C#
VB
Copy
​myFontSizeComboBox.SelectedValue = 12.0;
​myFontSizeComboBox.SelectedValue = 12.0

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:ComboBox MinWidth="40" Label="Font Size" KeyTipAccessText="FS" />

This code shows how to prototype this control in in XAML but by also using a ribbon command to set up its user interface:

XAML
Copy
​<ribbon:FontSizeComboBox MinWidth="40"
    Command="sample:ApplicationCommands.FontSize" KeyTipAccessText="FS" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PopupButton

The PopupButton class provides an implementation of buttons that display a popup when clicked.

The popup content is usually a Menu, but instead may be any sort of content that you wish, including a Panel of mutiple controls or elements.

This topic contains these sections:

  • Variants
  • Capabilities
  • Adding Popup Content
  • Making the Popup Resizable
  • Disabling When Child Items Are All Disabled
  • Adding a Description for Large Menu Items
  • Changing the Image Size
  • Preventing the Large Variant's Label from Word Wrapping
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | Large |
MenuItem | Medium, Small |
(any other) | Large |
(any other) | Medium |
(any other) | Small |
(any other) | Collapsed | (also has ImageSourceSmallSize set to 11,11 for this sample)

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | Yes.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | PopupButtonBase.
Child items | Yes. Single item set via the PopupContent property. The content may be any object and can be templated if desired. The most common content is a Menu control.
Has popup | Yes.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | Yes.
Click event trigger | None.
Supports use outside of Ribbon | Yes.
Supports commands | Yes, but for populating the user interface only.
Supports ICheckableCommandParameter | No.
Supports IValueCommandParameter | No.
Default CommandParameter | None.

Adding Popup Content

Any sort of content may be displayed in the popup for this control. Simply assign the content to the PopupContent property. If the content is not a UI element and needs to be templated, you may use the PopupContentTemplate or PopupContentTemplateSelector properties to do so.

The most common content for a popup is a Menu control, which renders its items as menu items:

XAML
Copy
​<ribbon:PopupButton ImageSourceLarge="/Resources/Images/Paste32.png" ImageSourceSmall="/Resources/Images/Paste16.png" Label="Paste" KeyTipAccessText="V">
    <ribbon:Menu>
        <ribbon:Button ImageSourceSmall="/Resources/Images/Paste16.png" Label="Paste" KeyTipAccessText="P" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/PasteSpecial16.png" Label="Paste Special" KeyTipAccessText="S" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/PasteHyperlink16.png" Label="Paste Hyperlink" KeyTipAccessText="H" />
    </ribbon:Menu>
</ribbon:PopupButton>

Note Note
To properly add multiple controls for use as popup content, use a Panel as the PopupContent. For instance, use a native WPF StackPanel to stack a popup header banner image on top of a Menu of items. By using techniques like this (also illustrated throughout the sample project), you can create complex layouts of popup content.

See the Working with Popups topic for more detailed information on what you can do with popups.

Making the Popup Resizable

With a Contained PopupGallery

The popup has a special gripper that can be used by assigning a value to the PopupResizeMode property. However the gripper is only intended to work if there is a PopupGallery control contained somewhere in the popup content since there is special resizing logic needed to handle that scenario.

Without a Contained PopupGallery

There may be other scenarios where your popup content doesn't include a PopupGallery control but you still want the popup to be resizable. In this case, leave the PopupResizeMode property its default value of None and wrap your popup content with a ResizableContentControl (located in the Shared Library). This will add a gripper to the content allowing for resizing of the popup.

This is very useful if you want to have a control like a native WPF TextBox be resizable in a PopupButton's popup.

Here is some XAML code showing a sample implementation:

XAML
Copy
​<ribbon:PopupButton ImageSourceLarge="/Resources/Images/Paste32.png" Label="Popup with Resizable Content">
    <shared:ResizableContentControl MinWidth="250" MinHeight="50" MaxWidth="600" MaxHeight="400">
        <TextBox Text="This popup can be resized." AcceptsReturn="True"
            BorderThickness="0" HorizontalScrollBarVisibility="Visible" VerticalScrollBarVisibility="Visible" />
    </shared:ResizableContentControl>
</ribbon:PopupButton>

Disabling When Child Items Are All Disabled

One of the ribbon UI design requirements is that when a popup button's child items are all disabled, the popup button must also be disabled. Because of the way WPF commands work, the PopupButton control only examines child items if a command is assigned to its Command property. So as long as you have a command set to the PopupButton, this functionality will work. If you need to use a temporary command while prototyping, use ApplicationCommands.NotACommand.

If you would like to prevent this automated functionality from occurring, you can set the AutoDisableWhenPopupContentIsDisabled to false.

Adding a Description for Large Menu Items

Any ButtonBase-derived control has a MenuItemDescription property. This property can be set to a string to display an extended description when used in a large menu context, such as in the application menu.

When set, the Label of the control will be displayed in bold above the description. The description will wrap to as many lines as needed to display itself. This feature is best used on button-based controls that appear on a child menu of a root application menu item.

Changing the Image Size

In any of the non-large variant sizes, you can set the ImageSourceSmallSize property to the specific size image that you'd like to display. By default, this is 16x16 however you could make it smaller or larger if you have a smaller or larger image.

This functionality is typically used outside of the Ribbon in standalone use of the control. If you wish to have a smaller control than the default, be sure to set MinHeight to 0 as well since the MinHeight for the Medium and Small variants of this control currently ensures the control is the proper height for usage in the Ribbon, per the requirements stated by Microsoft.

Preventing the Large Variant's Label from Word Wrapping

Sometimes you may have a short couple of words that make up a button's label and you run across a case where instead of the button placing words on two separate lines, you would prefer to have them both on the same line. Ribbon includes an easy way to accomplish this.

Instead of using a normal space character between the words in your label, use a non-breaking space character like this:

XAML
Copy
​<ribbon:PopupButton Label="Data Set" />

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:PopupButton ImageSourceLarge="/Images/Table32.png" Label="Table" KeyTipAccessText="T" />

This code shows how to prototype this control in in XAML but by also using a ribbon command to set up its user interface:

XAML
Copy
​<ribbon:PopupButton Command="ApplicationCommands.Paste" KeyTipAccessText="P" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PopupGallery

The PopupGallery class provides an implementation of galleries that appear within a popup. These galleries are controls that allow for the presentation of items visually within the popup for controls such as a RibbonGallery, PopupButton, or SplitButton. The items act like buttons and are displayed in a scrollable list that can be optionally categorized and filtered.

The items in the gallery could be any sort of object to which a visual representation can be applied. For instance, you may wish to provide visual representations of list styles that can be applied to a selection.

The gallery automatically determines the item size and how wide each column is. You don't need to bother with specifying it yourself.

This topic contains these sections:

  • Variants
  • Capabilities
  • Initial Column Display
  • Resizing the Containing Popup
  • Hiding the Selected Value
  • Processing Item Clicks and Managing the Selected Value
  • Supporting Live Preview
  • Categorizing Items
  • Categorized Item Filtering
  • Zooming-In on Mouse Over
  • Gallery Item Templates
  • Important Members
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports a single variant although the overall appearance of the gallery may be altered by specifying a different initial column count, the optional use of categorization, and the optional use of filtering.

Context | Variant Size | Sample UI
(any) | (any) |

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | No. Is not for use in the ribbon itself, but rather on popups.
Supports normal size | Yes, however the control's normal size can be quite large.
Supports use in a Menu | No. This gallery should be used in a popup but outside of a Menu control. However one commonly-used technique is to use a native WPF StackPanel as the popup content with the PopupGallery as one child and a Menu containing menu items above or below the gallery.
Base class | GalleryBase.
Child items | Yes. The items may be any object and gallery may be bound to an ItemsSource as well.
Has popup | No.
Key tip access | No.
Is key tip scope | Yes.
Click event trigger | When an item in the gallery is clicked.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | No.
Supports IValueCommandParameter | Yes. Controls the selected value of the PopupGallery and supports live preview.
Default CommandParameter | ObjectValueCommandParameter.

Initial Column Display

The PopupGallery.InitialColumnCount property is used to specify the initial number of columns that should be displayed when the popup that contains the PopupGallery is displayed.

The gallery measures the size of the items for you and determines how wide to ensure the popup is so that the number of columns of items you specify can be displayed.

Resizing the Containing Popup

When a PopupGallery is on a popup, it can optionally work with the popup to support resizing. Once the popup is resized and closed, the next time the popup is displayed, the popup is auto-sized back to its default setting based on the initial column count you specify. This is a requirement of the Ribbon UI Design Guidelines.

To enable popup resizing for a control that has a popup with a PopupGallery on it, set the anchor control's PopupResizeMode to a non-None value. Note that the enumeration used by the resize mode property accepts a ControlResizeMode however only its None, Vertical, and Both options are supported.

Note Note
If you want to ensure that only one column of items is ever displayed no matter what the width of the popup is, set the UseSingleColumn property to true.

Hiding the Selected Value

By default, the SelectedItem will be drawn with a highlight to indicate its selected state to the end user. However they may be cases where you wish to prevent the end user from seeing any sort of highlighted item in the gallery. To do this, set the IsSelectionHighlightVisible property to false.

Processing Item Clicks and Managing the Selected Value

When an item is clicked, the ItemClick is raised. This event passes arguments that specify which item was clicked. The clicked item becomes the SelectedItem and is passed through as the value to the command for the gallery.

Galleries are designed to support the WPF command model for maintaining the selected value of the control. By default an ObjectValueCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Value Controls topic for detailed information on using this command parameter to manage the control's value (selected item) and support live preview.

If you aren't using commands, you can choose to handle to SelectedItemChanged event to be notified when the SelectedItem property is changed.

Supporting Live Preview

When the mouse moves over an item, the item becomes the ActiveItem. Many applications use the currently "active" item to supply a live preview to the end user of what would happen if the item was clicked. Live preview for galleries can be implemented in one of two ways.

If you are using commands, the Interaction with Value Controls topic explains how to support live preview using command can-execute handlers.

Alternatively, if you would rather use events, the ActiveItemChanged event fires whenever the ActiveItem property is changed.

Categorizing Items

The PopupGallery.CategoryProperty attached property can be assigned to each item. If you choose to show categories in your PopupGallery, the property values you specify will be used to group the items into categories. The list style screenshot above shows categories being used.

This sample XAML code shows how to apply the Category attached property to an item:

XAML
Copy
​<mediaImaging:BitmapImage ribbon:PopupGallery.Category="Recently Used Bullets" UriSource="/Resources/Images/GalleryBulletsType1.png" />
<mediaImaging:BitmapImage ribbon:PopupGallery.Category="Bullet Library" UriSource="/Resources/Images/GalleryBulletsNone.png" />

By default the categorization feature is disabled in PopupGallery. You can enable it by binding your items to the CategorizedItemsSource property instead of the normal ItemsSource property. This tells PopupGallery to switch to categorized item mode.

Categorized Item Filtering

If you have categorization enabled in your PopupGallery as described above, you can optionally add filtering capabilities. The filter is a button at the top of the PopupGallery that when clicked, shows a menu of available filters.

There is always an All option and then rest of the options are the various category names. The All filter is used by default and does not perform any filtering. When a specific category is chosen as a filter, only the items in that category are displayed.

Use the CanFilter property to determine whether the filtering UI is available to the end user. The current category that is being filtered is available via the FilterCategory property.

Zooming-In on Mouse Over

Galleries support zooming-in on mouse over functionality. This means that as the mouse moves over an item, a popup will appear over the item and it can display an alternate template, provided by the ZoomedInItemTemplate property.

The zoomed-in template should display more detail than the standard item template (from ItemTemplate). Its use is completely optional. Clicks through the zoomed-in popup are transparent an will affect the item under it.

To enable zooming-in, set the ZoomedInItemTemplate or ZoomedInItemTemplateSelector property to a non-null value.

Gallery Item Templates

Items in a Gallery Must Have the Same Width/Height

The item templates used for galleries can be any width/height however the one rule to which you must adhere is that all items within the same gallery must be the same width and height. The layout routines rely on this assumption. Not only that, it makes for a better presentation to the end user.

The best way to ensure this is to explicitly set a width/height on the root element of your item template and the gallery will take care of measuring the additional gallery item border size for you.

Render Items with Templates or Programmatically

The normal way to render an item is to use the ItemTemplate and WPF elements to provide the user interface. However sometimes you need more control over what is rendered, and must render the item via code.

In those cases, we've added a CustomDrawElement element that can be placed in your item template. Simply attach to its CustomDraw event and in the event handler, draw the item however you need.

Item Screen Tips

Screen tips can be attached to gallery items in their item templates via the various ScreenTipService attached properties.

Alternatively you may use the ItemContainerStyle like this to apply them to the container GalleryItem.

XAML
Copy
​<ribbon:PopupGallery.ItemContainerStyle>
    <Style TargetType="{x:Type ribbon:GalleryItem}">
        <Setter Property="ribbon:ScreenTipService.ScreenTipHeader" Value="{Binding Path=MyScreenTipProperty}" />
    </Style>
</ribbon:PopupGallery.ItemContainerStyle>

Important Members

Since galleries indirectly inherit ItemsControl, you should use the Items or ItemsSource properties to bind the gallery to data. Then use the ItemTemplate or ItemTemplateSelector property to provide templates for the items.

This table lists the important members of the PopupGallery control, other than the ones inherited from ItemsControl.

Member | Description
ActiveItem Property | Gets the item that is currently active (being previewed).
ActiveItemChanged Event | Occurs when the ActiveItem property is changed.
CanFilter Property | Gets or sets whether the gallery can filter categorized items. The default value is false. This property requires that CategorizedItemsSource is not null for it to function correctly.
CategorizedItemsSource Property | Gets or sets the items source to used when categorization of items is desired. Use this property instead of ItemsSource when categorization of items is desired. By setting this property, the ItemsSource will be set to a view that supports categories and the IsCategorized property will be set to true.
CategoryProperty Attached Property | The text-based attached property that should be applied to items when categorization of items is desired.
CategoryTemplate Property | Gets or sets the DataTemplate to use for the display of categories. This template is used when the IsCategorized property is true.
FilterCategory Property | Gets or sets the category of items that is currently being filtered when CanFilter is true. This property does nothing if CanFilter is false or CategorizedItemsSource is null. When set to null, no filtering will be performed and items in all categories will be displayed.
InitialColumnCount Property | Gets or sets the initial number of gallery item columns that are displayed when the popup appears. The default value is 1.
IsCategorized Property | Gets whether the gallery is currently categorizing its items. This property will be set to true if the CategorizedItemsSource property is set to an items source.
IsPreviewEnabled Property | Gets or sets whether preview command notifications are enabled for the items. The default value is false so set it to true to enable live preview functionality.
IsSelectionHighlightVisible Property | Gets or sets whether the SelectedItem's selection highlight is visible for the gallery. The default value is true.
ItemClick Event | Occurs when an item is clicked.
SelectedItem Property | Gets or sets the item that is currently selected.
SelectedItemChanged Event | Occurs when the SelectedItem property is changed.
UseSingleColumn Property | Gets or sets whether the gallery's items are displayed in a single column. The default value is false. When this property is false, items will fill in the available space horizontally before wrapping to the next line.
VerticalScrollBarVisibility Property | Gets or sets a value that indicates whether a vertical scrollbar should be displayed. The default value is Visible.
ZoomedInItemTemplate Property | Gets or sets the DataTemplate that is applied to zoomed-in items. When this property is specified, a zoom-in effect will be made when hovering over items. This template supplies an alternate template for the zoomed-in item that can provide more detail than the normal one.
ZoomedInItemTemplateSelector Property | Gets or sets the DataTemplateSelector that is used to select a template for zoomed-in items. When this property is specified, a zoom-in effect will be made when hovering over items. This template selector supplies an alternate template for the zoomed-in item that can provide more detail than the normal one.

Sample XAML

This sample XAML code shows how to create a list styles gallery similar to the one in Word. Note that in a real application the items would drawn programmatically using CustomDrawElement instead of rendering them using pre-defined images.

XAML
Copy
​<ribbon:PopupGallery InitialColumnCount="6" CanFilter="True">
    <ribbon:PopupGallery.CategorizedItemsSource>
        <x:Array Type="{x:Type mediaImaging:BitmapImage}">
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Recently Used Bullets" UriSource="/Resources/Images/GalleryBulletsType1.png" />
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Bullet Library" UriSource="/Resources/Images/GalleryBulletsNone.png" />
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Bullet Library" UriSource="/Resources/Images/GalleryBulletsType1.png" />
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Bullet Library" UriSource="/Resources/Images/GalleryBulletsType2.png" />
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Bullet Library" UriSource="/Resources/Images/GalleryBulletsType3.png" />
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Bullet Library" UriSource="/Resources/Images/GalleryBulletsType4.png" />
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Bullet Library" UriSource="/Resources/Images/GalleryBulletsType5.png" />
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Bullet Library" UriSource="/Resources/Images/GalleryBulletsType6.png" />
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Bullet Library" UriSource="/Resources/Images/GalleryBulletsType7.png" />
            <mediaImaging:BitmapImage ribbon:PopupGallery.Category="Document Bullets" UriSource="/Resources/Images/GalleryBulletsType1.png" />
        </x:Array>
    </ribbon:PopupGallery.CategorizedItemsSource>
    <ribbon:PopupGallery.ItemTemplate>
        <DataTemplate>
            <Border Margin="2" BorderBrush="#808080" BorderThickness="1" Background="#FFFFFF" Width="40" Height="40" SnapsToDevicePixels="True">
                <Image Source="{Binding BindsDirectlyToSource=True}" Stretch="None" HorizontalAlignment="Center" VerticalAlignment="Center" SnapsToDevicePixels="True" />
            </Border>
        </DataTemplate>
    </ribbon:PopupGallery.ItemTemplate>
    <ribbon:PopupGallery.ZoomedInItemTemplate>
        <DataTemplate>
            <Border Margin="2" BorderBrush="#808080" BorderThickness="1" Background="#FFFFFF" Width="70" Height="70" SnapsToDevicePixels="True">
                <Image Source="{Binding BindsDirectlyToSource=True}" Stretch="None" HorizontalAlignment="Center" VerticalAlignment="Center" SnapsToDevicePixels="True">
                    <Image.LayoutTransform>
                        <ScaleTransform ScaleX="2" ScaleY="2" />
                    </Image.LayoutTransform>
                </Image>
            </Border>
        </DataTemplate>
    </ribbon:PopupGallery.ZoomedInItemTemplate>
</ribbon:PopupGallery>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RadioButton

The RadioButton class provides an implementation of radio buttons.

This topic contains these sections:

  • Variants
  • Capabilities
  • Managing the Checked State
  • Checked State Events
  • Adding a Description for Large Menu Items
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | Large |
MenuItem | Medium, Small |
(any other) | (any) |

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | No.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | ButtonBase.
Child items | None.
Has popup | No.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | No.
Click event trigger | When the radio button is clicked.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | Yes. Controls the checked state of the radio button.
Supports IValueCommandParameter | No.
Default CommandParameter | CheckableCommandParameter.

Managing the Checked State

This control is designed to use the WPF command model to maintain the checked state of the control. By default a CheckableCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Checkable Controls topic for detailed information on using this command parameter to manage the checked state.

In addition you can manage the checked state of this control programmatically by setting the IsChecked property. When no command is set to the control, the control will automatically toggle IsChecked when it is clicked. By default it will toggle between true and false, but if IsThreeState is true, it will also toggle into an indeterminate state.

Checked State Events

This control exposes three events that can fire when the IsChecked property changes value. Each event fires for a certain value of IsChecked:

  • Checked event
  • Indeterminate event
  • Unchecked event

Adding a Description for Large Menu Items

Any ButtonBase-derived control has a MenuItemDescription property. This property can be set to a string to display an extended description when used in a large menu context, such as in the application menu.

When set, the Label of the control will be displayed in bold above the description. The description will wrap to as many lines as needed to display itself. This feature is best used on button-based controls that appear on a child menu of a root application menu item.

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:RadioButton Label="Toggle Bold" KeyTipAccessText="B" />

This code shows how to prototype this control in in XAML but by also using a ribbon command to set up its user interface:

XAML
Copy
​<ribbon:RadioButton Command="EditingCommands.ToggleBold" KeyTipAccessText="B" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RibbonGallery

The RibbonGallery class provides an implementation of in-ribbon galleries. In-ribbon galleries are controls that allow for the presentation of items visually within a ribbon Group. The items act like buttons and are displayed in a scrollable list that animates when scrolled.

The items in the gallery could be any sort of object to which a visual representation can be applied. For instance, you may wish to provide visual representations of styles that can be applied to a selection.

The gallery automatically determines the item size and how wide each column is. You don't need to bother with specifying it yourself.

This topic contains these sections:

  • Variants
  • Capabilities
  • Resizing Behavior
  • Item Rows
  • Hiding the Selected Value
  • Processing Item Clicks and Managing the Selected Value
  • Supporting Live Preview
  • Zooming-In on Mouse Over
  • Gallery Item Templates
  • Adding Popup Content
  • Making the Popup Resizable
  • Important Members
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
(any) | Large |
(any) | Medium |
(any) | Small |

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | Yes.
Supports normal size | No.
Supports use in a Menu | No.
Base class | GalleryBase.
Child items | Yes. The items may be any object and gallery may be bound to an ItemsSource as well.
Has popup | Yes. The popup must contain a PopupGallery control somewhere on it. The popup may also contain any other sort of controls that are appropriate, such as a Menu of items related to the gallery.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | Yes.
Click event trigger | When an item in the gallery is clicked.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | No.
Supports IValueCommandParameter | Yes. Controls the selected value of the RibbonGallery and supports live preview.
Default CommandParameter | ObjectValueCommandParameter.

Resizing Behavior

In-ribbon galleries mimic the Office gallery resizing behavior exactly. In-ribbon galleries can be resized in three distinct stages, with each stage corresponding to the current VariantSize of the parent Group.

Small Variant Size

The first stage occurs when the parent Group has a variant size of Small. The RibbonGallery will collapse and render like a PopupButton if its VariantBehavior property permits collapsing (the default). Clicking on the collapsed button displays a popup with the gallery items on it.

If the RibbonGallery is not permitted to be collapsed, it will display the number of columns of items indicated by its MediumVariantColumnCount property.

An in-ribbon gallery in a group with a small variant

Medium Variant Size

The second stage occurs when the parent Group has a variant size of Medium. When in this stage the gallery will display items. It will show more or less item columns depending on the available space. The range of item columns that are displayed depend on the MediumVariantColumnCount and LargeVariantColumnCount properties.

Note Note
Set those two properties to the same value to prevent the gallery from resizing within a Medium variant.

When space is limited but a Medium variant is active, the number of columns displayed will be MediumVariantColumnCount. As space increases and while still in a Medium variant, the number of columns displayed will grow until LargeVariantColumnCount is reached.

An in-ribbon gallery in a group with a medium variant

Large Variant Size

The final stage occurs when the parent Group has a variant size of Large. If the RibbonGallery's VariantBehavior property permits auto-sizing in the large variant (the default), the number of item columns displayed will increase from LargeVariantColumnCount until the available space is filled in the ribbon.

An in-ribbon gallery in a group with a large variant

VariantBehavior Settings

As mentioned above, the VariantBehavior property controls how the variants behave when resizing.

This table lists the values of the RibbonGalleryVariantBehavior enumeration.

Value | Description
Default | Small variants collapse to a PopupButton. Large variants auto-expand to fill the ribbon.
NoCollapse | Small variants do not collapse to a PopupButton. Large variants auto-expand to fill the ribbon.
NoAutoSize | Small variants collapse to a PopupButton. Large variants do not auto-expand to fill the ribbon.
NoCollapseNoAutoSize | Small variants do not collapse to a PopupButton. Large variants do not auto-expand to fill the ribbon.

Item Rows

The RibbonGallery automatically determines the number of rows displayed based on its size and the size of the items. There can be anywhere from one to three rows, each of which supports smooth row-by-row scrolling.

An in-ribbon gallery showing the same items with different sized templates

Hiding the Selected Value

By default, the SelectedItem will be drawn with a highlight to indicate its selected state to the end user. However they may be cases where you wish to prevent the end user from seeing any sort of highlighted item in the gallery. To do this, set the IsSelectionHighlightVisible property to false.

Processing Item Clicks and Managing the Selected Value

When an item is clicked, the ItemClick is raised. This event passes arguments that specify which item was clicked. The clicked item becomes the SelectedItem and is passed through as the value to the command for the gallery.

Galleries are designed to support the WPF command model for maintaining the selected value of the control. By default an ObjectValueCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Value Controls topic for detailed information on using this command parameter to manage the control's value (selected item) and support live preview.

If you aren't using commands, you can choose to handle to SelectedItemChanged event to be notified when the SelectedItem property is changed.

Supporting Live Preview

When the mouse moves over an item, the item becomes the ActiveItem. Many applications use the currently "active" item to supply a live preview to the end user of what would happen if the item was clicked. Live preview for galleries can be implemented in one of two ways.

If you are using commands, the Interaction with Value Controls topic explains how to support live preview using command can-execute handlers.

Alternatively, if you would rather use events, the ActiveItemChanged event fires whenever the ActiveItem property is changed.

Zooming-In on Mouse Over

Galleries support zooming-in on mouse over functionality. This means that as the mouse moves over an item, a popup will appear over the item and it can display an alternate template, provided by the ZoomedInItemTemplate property.

The zoomed-in template should display more detail than the standard item template (from ItemTemplate). Its use is completely optional. Clicks through the zoomed-in popup are transparent an will affect the item under it.

To enable zooming-in, set the ZoomedInItemTemplate or ZoomedInItemTemplateSelector property to a non-null value.

Gallery Item Templates

Items in a Gallery Must Have the Same Width/Height

The item templates used for galleries can be any width/height however the one rule to which you must adhere is that all items within the same gallery must be the same width and height. The layout routines rely on this assumption. Not only that, it makes for a better presentation to the end user.

The best way to ensure this is to explicitly set a width/height on the root element of your item template and the gallery will take care of measuring the additional gallery item border size for you.

Render Items with Templates or Programmatically

The normal way to render an item is to use the ItemTemplate and WPF elements to provide the user interface. However sometimes you need more control over what is rendered, and must render the item via code.

In those cases, we've added a CustomDrawElement element that can be placed in your item template. Simply attach to its CustomDraw event and in the event handler, draw the item however you need.

Item Screen Tips

Screen tips can be attached to gallery items in their item templates via the various ScreenTipService attached properties.

Alternatively you may use the ItemContainerStyle like this to apply them to the container GalleryItem.

XAML
Copy
​<ribbon:RibbonGallery.ItemContainerStyle>
    <Style TargetType="{x:Type ribbon:GalleryItem}">
        <Setter Property="ribbon:ScreenTipService.ScreenTipHeader" Value="{Binding Path=MyScreenTipProperty}" />
    </Style>
</ribbon:RibbonGallery.ItemContainerStyle>

Adding Popup Content

Any sort of content may be displayed in the popup for this control. Simply assign the content to the PopupContent property. If the content is not a UI element and needs to be templated, you may use the PopupContentTemplate or PopupContentTemplateSelector properties to do so.

One requirement of in-ribbon galleries is that they have a PopupGallery somewhere in their popup that binds to the same items source that the RibbonGallery does.

Note Note
To properly add multiple controls for use as popup content, use a Panel as the PopupContent. For instance, use a native WPF StackPanel to stack a PopupGallery on top of a Menu of items. By using techniques like this (also illustrated throughout the sample project), you can create complex layouts of popup content.

See the Working with Popups topic for more detailed information on what you can do with popups.

Making the Popup Resizable

Since it is assumed that your RibbonGallery popup has a PopupGallery somewhere in its content (a requirement), the popup has a special gripper that can be used by assigning a value to the PopupResizeMode property. The default value is Both.

Important Members

Since galleries indirectly inherit ItemsControl, you should use the Items or ItemsSource properties to bind the gallery to data. Then use the ItemTemplate or ItemTemplateSelector property to provide templates for the items.

This table lists the important members of the RibbonGallery control, other than the ones inherited from ItemsControl.

Member | Description
ActiveItem Property | Gets the item that is currently active (being previewed).
ActiveItemChanged Event | Occurs when the ActiveItem property is changed.
ColumnCount Property | Gets the number of columns that are currently displayed in the in-ribbon gallery.
IsCollapsed Property | Gets whether the gallery is collapsed to a popup button. When collapsed, the gallery items can be viewed in a popup by clicking the button that represents the gallery.
IsPreviewEnabled Property | Gets or sets whether preview command notifications are enabled for the items. The default value is false so set it to true to enable live preview functionality.
IsSelectionHighlightVisible Property | Gets or sets whether the SelectedItem's selection highlight is visible for the gallery. The default value is true.
ItemClick Event | Occurs when an item is clicked.
LargeVariantColumnCount Property | Gets or sets the maximum number of columns that can be displayed in an in-ribbon gallery when in a Group with a Medium variant size, which is also the minimum number of columns that can be displayed when in a Group with a Large variant size.
MediumVariantColumnCount Property | Gets or sets the minimum number of columns that can be displayed in an in-ribbon gallery when in a Group with a Medium variant size.
PopupContent Property | Gets or sets the content that is displayed on the popup for the gallery. The content must contain a PopupGallery somewhere inside of it that binds to the same item list that the RibbonGallery does.
PopupResizeMode Property | Gets or sets a ControlResizeMode that specifies the popup's resizing capabilities.
SelectedItem Property | Gets or sets the item that is currently selected.
SelectedItemChanged Event | Occurs when the SelectedItem property is changed.
VariantBehavior Property | Gets or sets a RibbonGalleryVariantBehavior that specifies how the gallery renders itself based on the current value of the VariantSize property.
ZoomedInItemTemplate Property | Gets or sets the DataTemplate that is applied to zoomed-in items. When this property is specified, a zoom-in effect will be made when hovering over items. This template supplies an alternate template for the zoomed-in item that can provide more detail than the normal one.
ZoomedInItemTemplateSelector Property | Gets or sets the DataTemplateSelector that is used to select a template for zoomed-in items. When this property is specified, a zoom-in effect will be made when hovering over items. This template selector supplies an alternate template for the zoomed-in item that can provide more detail than the normal one.

Sample XAML

This sample XAML code shows how to create a Styles gallery similar to the one in Word.

XAML
Copy
​<ribbon:RibbonGallery ImageSourceLarge="/Resources/Images/QuickStyles32.png" Label="Quick Styles"
    ScreenTipDescription="Format titles, quotes, and other text using the styles in this gallery.">
    <ribbon:RibbonGallery.ItemsSource>
        <x:Array Type="{x:Type mediaImaging:BitmapImage}">
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Normal" UriSource="/Resources/Images/GalleryStylesNormal.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="No Spacing" UriSource="/Resources/Images/GalleryStylesNoSpacing.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Heading 1" UriSource="/Resources/Images/GalleryStylesHeading1.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Heading 2" UriSource="/Resources/Images/GalleryStylesHeading2.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Title" UriSource="/Resources/Images/GalleryStylesTitle.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Subtitle" UriSource="/Resources/Images/GalleryStylesSubTitle.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Subtle Emphasis" UriSource="/Resources/Images/GalleryStylesSubtleEmphasis.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Emphasis" UriSource="/Resources/Images/GalleryStylesEmphasis.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Intense Emphasis" UriSource="/Resources/Images/GalleryStylesIntenseEmphasis.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Strong" UriSource="/Resources/Images/GalleryStylesStrong.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Quote" UriSource="/Resources/Images/GalleryStylesQuote.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Intense Quote" UriSource="/Resources/Images/GalleryStylesIntenseQuote.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Subtle Reference" UriSource="/Resources/Images/GalleryStylesSubtleReference.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Intense Reference" UriSource="/Resources/Images/GalleryStylesIntenseReference.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Book Title" UriSource="/Resources/Images/GalleryStylesBookTitle.png" />
            <mediaImaging:BitmapImage ribbon:ScreenTipService.ScreenTipHeader="Paragraph" UriSource="/Resources/Images/GalleryStylesListParagraph.png" />
        </x:Array>
    </ribbon:RibbonGallery.ItemsSource>
    <ribbon:RibbonGallery.ItemTemplate>
        <DataTemplate>
            <Image Margin="2" Source="{Binding BindsDirectlyToSource=True}" Stretch="None" />
        </DataTemplate>
    </ribbon:RibbonGallery.ItemTemplate>
    <ribbon:RibbonGallery.PopupContent>
        <StackPanel>
            <ribbon:PopupGallery InitialColumnCount="4"
                ItemTemplate="{Binding RelativeSource={RelativeSource Mode=FindAncestor, AncestorType={x:Type ribbon:RibbonGallery}}, Path=ItemTemplate}"
                ItemsSource="{Binding RelativeSource={RelativeSource Mode=FindAncestor, AncestorType={x:Type ribbon:RibbonGallery}}, Path=ItemsSource}"
                />
            <ribbon:Separator />
            <ribbon:Menu>
                <ribbon:Button Label="Save Selection as a New Quick Style..." />
                <ribbon:Button ImageSourceSmall="/Resources/Images/ClearFormatting16.png" Label="Clear Formatting" />
                <ribbon:Button ImageSourceSmall="/Resources/Images/ApplyStyles16.png" Label="Apply Styles..." />
            </ribbon:Menu>
        </StackPanel>
    </ribbon:RibbonGallery.PopupContent>
</ribbon:RibbonGallery>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Separator

The Separator class provides an implementation of a separator when used in a menu, popup or as a large item in a group.

It can display text when a label is specified in menus and also renders as a normal label when used as a medium/small item in a group.

This topic contains these sections:

  • Variants
  • Capabilities
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | Large |
MenuItem | Medium, Small | (no label)
MenuItem | Medium, Small | (with label)
BackstageItem | (any) |
None | Large |
None | Medium, Small |
(any other) | Large |
(any other) | Medium, Small | (with label)

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | Yes.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | ControlBase.
Child items | None.
Has popup | No.
Key tip access | No.
Is key tip scope | No.
Click event trigger | None.
Supports use outside of Ribbon | Yes.
Supports commands | Yes, but for populating the user interface only.
Supports ICheckableCommandParameter | No.
Supports IValueCommandParameter | No.
Default CommandParameter | None.

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:Separator />

This code shows how to prototype this control with a label in XAML-only:

XAML
Copy
​<ribbon:Separator Label="Options" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SplitButton

The SplitButton class provides an implementation of a button that has two clickable areas. The button portion of the split button acts like a normal button or checkable button. The drop-down portion of the split button displays a popup.

The popup content is usually a Menu, but instead may be any sort of content that you wish, including a Panel of mutiple controls or elements.

This topic contains these sections:

  • Variants
  • Capabilities
  • Managing the Checked State
  • Adding Popup Content
  • Making the Popup Resizable
  • Disabling When Child Items Are All Disabled
  • Adding a Description for Large Menu Items
  • Changing the Image Size
  • Preventing the Large Variant's Label from Word Wrapping
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | Large |
MenuItem | Medium, Small |
(any other) | Large |
(any other) | Medium |
(any other) | Small |
(any other) | Collapsed | (also has ImageSourceSmallSize set to 11,11 for this sample)

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | Yes.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | PopupButtonBase.
Child items | Yes. Single item set via the PopupContent property. The content may be any object and can be templated if desired. The most common content is a Menu control.
Has popup | Yes.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | Yes.
Click event trigger | None.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | Yes. Controls the checked state of the button.
Supports IValueCommandParameter | No.
Default CommandParameter | CheckableCommandParameter.

Managing the Checked State

This control is designed to use the WPF command model to maintain the checked state of the control. By default a CheckableCommandParameter is assigned as the CommandParameter of the control.

See the Command Model topic for detailed information on using this command parameter to manage the checked state.

Adding Popup Content

Any sort of content may be displayed in the popup for this control. Simply assign the content to the PopupContent property. If the content is not a UI element and needs to be templated, you may use the PopupContentTemplate or PopupContentTemplateSelector properties to do so.

The most common content for a popup is a Menu control, which renders its items as menu items:

XAML
Copy
​<ribbon:SplitButton ImageSourceLarge="/Resources/Images/Paste32.png" ImageSourceSmall="/Resources/Images/Paste16.png" Label="Paste" KeyTipAccessText="V">
    <ribbon:Menu>
        <ribbon:Button ImageSourceSmall="/Resources/Images/Paste16.png" Label="Paste" KeyTipAccessText="P" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/PasteSpecial16.png" Label="Paste Special" KeyTipAccessText="S" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/PasteHyperlink16.png" Label="Paste Hyperlink" KeyTipAccessText="H" />
    </ribbon:Menu>
</ribbon:SplitButton>

Note Note
To properly add multiple controls for use as popup content, use a Panel as the PopupContent. For instance, use a native WPF StackPanel to stack a popup header banner image on top of a Menu of items. By using techniques like this (also illustrated throughout the sample project), you can create complex layouts of popup content.

See the Working with Popups topic for more detailed information on what you can do with popups.

Making the Popup Resizable

With a Contained PopupGallery

The popup has a special gripper that can be used by assigning a value to the PopupResizeMode property. However the gripper is only intended to work if there is a PopupGallery control contained somewhere in the popup content since there is special resizing logic needed to handle that scenario.

Without a Contained PopupGallery

There may be other scenarios where your popup content doesn't include a PopupGallery control but you still want the popup to be resizable. In this case, leave the PopupResizeMode property its default value of None and wrap your popup content with a ResizableContentControl (located in the Shared Library). This will add a gripper to the content allowing for resizing of the popup.

This is very useful if you want to have a control like a native WPF TextBox be resizable in a SplitButton's popup.

Here is some XAML code showing a sample implementation:

XAML
Copy
​<ribbon:SplitButton ImageSourceLarge="/Resources/Images/Paste32.png" Label="Popup with Resizable Content">
    <shared:ResizableContentControl MinWidth="250" MinHeight="50" MaxWidth="600" MaxHeight="400">
        <TextBox Text="This popup can be resized." AcceptsReturn="True"
            BorderThickness="0" HorizontalScrollBarVisibility="Visible" VerticalScrollBarVisibility="Visible" />
    </shared:ResizableContentControl>
</ribbon:SplitButton>

Disabling When Child Items Are All Disabled

One of the ribbon UI design requirements is that when a split button's child items are all disabled, the split button must also be disabled. Because of the way WPF commands work, the SplitButton control only examines child items if a command is assigned to its Command property. So as long as you have a command set to the SplitButton, this functionality will work. If you need to use a temporary command while prototyping, use ApplicationCommands.NotACommand.

If you would like to prevent this automated functionality from occurring, you can set the AutoDisableWhenPopupContentIsDisabled to false.

Adding a Description for Large Menu Items

Any ButtonBase-derived control has a MenuItemDescription property. This property can be set to a string to display an extended description when used in a large menu context, such as in the application menu.

When set, the Label of the control will be displayed in bold above the description. The description will wrap to as many lines as needed to display itself. This feature is best used on button-based controls that appear on a child menu of a root application menu item.

Changing the Image Size

In any of the non-large variant sizes, you can set the ImageSourceSmallSize property to the specific size image that you'd like to display. By default, this is 16x16 however you could make it smaller or larger if you have a smaller or larger image.

This functionality is typically used outside of the Ribbon in standalone use of the control. If you wish to have a smaller control than the default, be sure to set MinHeight to 0 as well since the MinHeight for the Medium and Small variants of this control currently ensures the control is the proper height for usage in the Ribbon, per the requirements stated by Microsoft.

Preventing the Large Variant's Label from Word Wrapping

Sometimes you may have a short couple of words that make up a button's label and you run across a case where instead of the button placing words on two separate lines, you would prefer to have them both on the same line. Ribbon includes an easy way to accomplish this.

Instead of using a normal space character between the words in your label, use a non-breaking space character like this:

XAML
Copy
​<ribbon:SplitButton Label="Data Set" />

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:SplitButton Label="Bullets" ImageSourceSmall="/Images/Bullets16.png" KeyTipAccessText="U" />

This code shows how to prototype this control in in XAML but by also using a ribbon command to set up its user interface:

XAML
Copy
​<ribbon:SplitButton Command="ApplicationCommands.Paste" KeyTipAccessText="P" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TextBox

The TextBox class provides an implementation of native WPF TextBox that has enhanced functionality for use in a ribbon.

This topic contains these sections:

  • Variants
  • Capabilities
  • Managing the Value
  • Layout on the Ribbon and in Menus
  • Working with the TextBox
  • Hint Text
  • Sample XAML

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
MenuItem | (all) |
(any other) | Medium (when in StackPanel) |
(any other) | (any other) |

Capabilities

The following table gives an overview of the capabilities of the control.

Item | Details
Supports tall size (fills height of Group) | No. When in the ribbon, it should be placed in a StackPanel that is in a Medium variant or smaller.
Supports normal size | Yes.
Supports use in a Menu | Yes.
Base class | TextBoxBase.
Child items | No.
Has popup | No.
Key tip access | Yes. Set via the KeyTipAccessText property.
Is key tip scope | No.
Click event trigger | When the Enter key is pressed while in the control or when the control loses focus and the value is changed.
Supports use outside of Ribbon | Yes.
Supports commands | Yes.
Supports ICheckableCommandParameter | No.
Supports IValueCommandParameter | Yes. Controls the value of the TextBox.
Default CommandParameter | StringValueCommandParameter.

Managing the Value

This control is designed to use the WPF command model to maintain the value of the control. By default an ObjectValueCommandParameter is assigned as the CommandParameter of the control.

See the Interaction with Value Controls topic for detailed information on using this command parameter to manage the control's value.

Layout on the Ribbon and in Menus

It is recommended that when a TextBox is used in the ribbon that a specific Width be set. When used within a StackPanel, controls such as TextBox (that don't draw labels inside their bounds like Button controls do) will be lined up and stacked vertically and their optional labels and images will be drawn to the left of them.

When used in a Menu, a MinWidth should be set on the TextBox. Since the left edge of controls like TextBox will vary based on the width of its Label, setting a MinWidth ensures that the TextBox itself will be at least a certain appropriate width and can grow as needed to fill the width of the menu.

Working with the TextBox

The ribbon TextBox indirectly inherits the native WPF TextBox control, so anything you can do in the native WPF TextBox you can do in the ribbon TextBox.

Please see the MSDN documentation on the native WPF TextBox for more details on its capabilities.

Hint Text

Hint text is a faded out blurb of text that appears when a TextBox or ComboBox is empty. It usually gives some simple instruction for related to the data that should be input to the control, or a description of that data that should be entered.

The hint text starts out somewhat opaque when there is no content in the control. If the control gains focus, the hint text becomes slightly more transparent. If content is entered, the hint text disappears completely.

The same TextBox in three hint text states... the top TextBox doesn't have focus or content, the middle TextBox has focus but no content, and the bottom TextBox has focus and content

Transitions between the various hint text states use smooth animations for visual appeal.

This code shows how to set hint text:

XAML
Copy
​<ribbon:TextBox Width="100" HintText="Type here" />

Sample XAML

This code shows how to prototype this control in XAML-only:

XAML
Copy
​<ribbon:TextBox Width="100" ImageSourceSmall="/Images/Find16.png" Label="Find" KeyTipAccessText="F" />

This code shows how to prototype this control in in XAML but by also using a ribbon command to set up its user interface:

XAML
Copy
​<ribbon:TextBox Width="100" Command="ApplicationCommands.Find" KeyTipAccessText="F" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Layout controls govern where other controls are placed within a Ribbon.

Control Type | Description
ButtonGroup | A layout control that is most often used as a child item of a RowPanel or a StatusBarItem. The button group contains one or more child controls and optionally draws a border around them.
RowPanel | A layout control that can be used in a Group to provide two-row layouts of child controls, which can switch to a three-row variant as available width decreases.
StackPanel | Displays up to three child controls in large variants horizontally and switches to a vertically-stacked layout of smaller control variants as available width decreases. As available width continues to decrease, child control labels are removed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ButtonGroup

The ButtonGroup class provides a container for buttons or other controls and is most often used within a RowPanel or StatusBarItem.

This topic contains these sections:

  • Variants
  • Hiding the Border

Variants

This control supports numerous UI styles (called variants) based on its Context and VariantSize property settings.

Context | Variant Size | Sample UI
StatusBarItem | (any) |
(any other) | (any) |

Hiding the Border

By default, a border is drawn around the items in the button group. Sometimes when the group's items are controls like a ComboBox, you don't want to display the border.

Set the HasBorder property to false to hide it.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RowPanel

The RowPanel is a layout control that displays child controls in somewhat of a toolbar-ish style and is involved in providing alternate layouts of child controls for ribbon resizing.

This topic contains these sections:

  • Variants
  • Resizing Behavior
  • Child Controls
  • Sample XAML

Variants

This control supports two variants: two- and three- row display of items. The parent Group determines which variant to use based on the available width.

A demonstration of row panel variants

Resizing Behavior

By default, RowPanel displays two rows of child controls. As the parent group's size decreases, the RowPanel can shift to a three row layout that uses less overall width. This normally occurs when the parent group changes to a Medium VariantSize, however you have control over where this change occurs via the ThreeRowVariantSize property.

The ribbon resizing topic discusses in detail how and when group variants change and how the variant size updates RowPanel.

Two-Row Variants

When in the two-row variant, the items are layed out in the same order that they are defined in the RowPanel. RowPanel uses complex logic to determine where to split up items between the two rows so that the minimum total width is used.

Three-Row Variants

When in the three-row variant, the items are layed out in the order specified by the RowPanel.ThreeRowItemSortOrder property. This property is an integer collection where there is one entry for each item in the RowPanel. Each entry points to the index of the item within the RowPanel's Children collection.

As an example say there were three items in a RowPanel and the ThreeRowItemSortOrder was set to 1,2,0. This means that the first item (index 0) in Children collection (which is displayed first in the two-row variant) should be displayed in the bottom row of the three-row variant. The second item (index 1) in the Children collection will appear on the top row and the third item in the Children collection will appear in the middle row.

Just like in the two-row variant, RowPanel uses complex logic to determine where to split up items between the three rows so that the minimum total width is used.

Configuring Sort Orders in the Designer

Both the two- and three-row variant item sort orders can be configured visually using the task pane for RowPanel in the designer.

Child Controls

RowPanel can contain any child control however ButtonGroup controls are most often its direct children since those controls have the capability of grouping controls together. This feature is especially useful when the ButtonGroup contains items like Button controls since a border is drawn around the group.

Sample XAML

This code shows how to reproduce a row panel that shifts its appearance when the variant size changes.

XAML
Copy
​<ribbon:RowPanel ThreeRowItemSortOrder="0,1,4,5,6,2,3">
    <ribbon:ButtonGroup>
        <ribbon:SplitButton ImageSourceSmall="/Resources/Images/Bullets16.png" Label="Bullets" KeyTipAccessText="U" />
        <ribbon:SplitButton ImageSourceSmall="/Resources/Images/Numbering16.png" Label="Numbering" KeyTipAccessText="N" />
        <ribbon:PopupButton ImageSourceSmall="/Resources/Images/MultilevelList16.png" Label="Multilevel List" KeyTipAccessText="M" />
    </ribbon:ButtonGroup>
    <ribbon:ButtonGroup>
        <ribbon:Button ImageSourceSmall="/Resources/Images/DecreaseIndent16.png" Label="Decrease Indent" KeyTipAccessText="AO" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/IncreaseIndent16.png" Label="Increase Indent" KeyTipAccessText="AI" />
    </ribbon:ButtonGroup>
    <ribbon:ButtonGroup>
        <ribbon:Button ImageSourceSmall="/Resources/Images/Sort16.png" Label="Sort" KeyTipAccessText="SO" />
    </ribbon:ButtonGroup>
    <ribbon:ButtonGroup>
        <ribbon:Button ImageSourceSmall="/Resources/Images/ToggleSymbols16.png" Label="Show/Hide Symbols" KeyTipAccessText="8" />
    </ribbon:ButtonGroup>
    <ribbon:ButtonGroup>
        <ribbon:Button ImageSourceSmall="/Resources/Images/AlignTextLeft16.png" Label="Align Text Left" KeyTipAccessText="AL" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/AlignTextCenter16.png" Label="Center" KeyTipAccessText="AC" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/AlignTextRight16.png" Label="Align Text Right" KeyTipAccessText="AR" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/AlignTextJustify16.png" Label="Justify" KeyTipAccessText="AJ" />
    </ribbon:ButtonGroup>
    <ribbon:ButtonGroup>
        <ribbon:PopupButton ImageSourceSmall="/Resources/Images/LineSpacing16.png" Label="Line Spacing" KeyTipAccessText="K" />
    </ribbon:ButtonGroup>
    <ribbon:ButtonGroup>
        <ribbon:SplitButton ImageSourceSmall="/Resources/Images/Shading16.png" Label="Shading" KeyTipAccessText="H" />
        <ribbon:SplitButton ImageSourceSmall="/Resources/Images/OutsideBorders16.png" Label="Outside Borders" KeyTipAccessText="B" />
    </ribbon:ButtonGroup>
</ribbon:RowPanel>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


StackPanel

The StackPanel is a layout control that is heavily involved in providing alternate layouts of child controls for ribbon resizing.

This topic contains these sections:

  • Variants
  • Resizing Behavior
  • Item Variant Behavior
  • Row Alignments
  • Horizontal Item Alignment
  • Layout Samples

Variants

This control supports three variants. The parent Group determines which variant to use based on the available width.

A demonstration of stack panel variants

Resizing Behavior

By default, StackPanel displays up to three child controls horizontally using a Large VariantSize. As the group size decreases, the panel shifts to a vertical stack of its children using Medium variants. For buttons and many other child controls, the control's label is still visible in this variant. As the group size decreases further, the panel removes the labels from the child items. This behavior can be completely overridden to meet your own requirements.

The ribbon resizing topic discusses in detail how and when group variants change and how the variant size updates StackPanel.

Item Variant Behavior

As previously mentioned, the layout of the panel's child items can be set up to depend on the variant size of the parent Group.

The StackPanel.ItemVariantBehavior property determines how the StackPanel reacts to parent group variant size changes (which in turn sets the StackPanel's own VariantSize property). It accepts a value of type StackPanelItemVariantBehavior whose values are defined as:

Value | Description
Default | Child controls use a Large variant size when the VariantSize of the StackPanel is Large. They change to a Medium variant size when the VariantSize of the StackPanel is Medium. They change to a Small variant size when the VariantSize of the StackPanel is Small. This option provides the largest number of variants for child controls.
LargeThenMediumWhenMedium | Child controls use a Large variant size when the VariantSize of the StackPanel is Large. They change to a Medium variant size when the VariantSize of the StackPanel is Medium or Small.
LargeThenMediumWhenSmall | Child controls use a Large variant size when the VariantSize of the StackPanel is Large or Medium. They change to a Medium variant size when the VariantSize of the StackPanel is Small.
LargeThenSmallWhenMedium | Child controls use a Large variant size when the VariantSize of the StackPanel is Large. They change to a Small variant size when the VariantSize of the StackPanel is Medium or Small.
LargeThenSmallWhenSmall | Child controls use a Large variant size when the VariantSize of the StackPanel is Large or Medium. They change to a Small variant size when the VariantSize of the StackPanel is Small.
MediumThenSmallWhenMedium | Child controls use a Medium variant size when the VariantSize of the StackPanel is Large. They change to a Small variant size when the VariantSize of the StackPanel is Medium or Small.
MediumThenSmallWhenSmall | Child controls use a Medium variant size when the VariantSize of the StackPanel is Large or Medium. They change to a Small variant size when the VariantSize of the StackPanel is Small.
AlwaysLarge | Child controls always use a Large variant size no matter what the VariantSize of the StackPanel is. This option is the same as not using a StackPanel to encapsulate the child controls.
AlwaysMedium | Child controls always use a Medium variant size no matter what the VariantSize of the StackPanel is.
AlwaysSmall | Child controls always use a Small variant size no matter what the VariantSize of the StackPanel is.

So say for instance you wanted to have your stack panel always show medium variant-sized items (with labels) but never want to let them collapse the labels. This code accomplishes that requirement:

XAML
Copy
​<ribbon:StackPanel ItemVariantBehavior="AlwaysMedium">
    <ribbon:PopupButton ImageSourceSmall="/Resources/Images/QuickParts16.png" Label="Quick Parts" KeyTipAccessText="Q" />
    <ribbon:PopupButton ImageSourceSmall="/Resources/Images/WordArt16.png" Label="WordArt" KeyTipAccessText="W" />
    <ribbon:PopupButton ImageSourceSmall="/Resources/Images/DropCap16.png" Label="Drop Cap" KeyTipAccessText="RC" />
</ribbon:StackPanel>

Row Alignments

Stack panels normally show three child controls however when there is only one or two child controls, you have a choice as to how the controls are aligned vertically. You can either align them to the top or to the center.

The RowAlignment property takes a StackPanelRowAlignment that indicates which layout style to use.

Horizontal Item Alignment

When stack panels show items in a vertical layout, the items will by default align to the left side of the control.

The HorizontalContentAlignment property can be set to Stretch to have the items all align to be the same width.

Layout Samples

It's very easy by using the properties described above to create some interesting layouts for child controls, even if you aren't concerned with ribbon resizing.

Some sample stack panel layouts.

Sample 1

The first section in the screenshot above was created using this code for four stack panels:

XAML
Copy
​<ribbon:StackPanel ItemVariantBehavior="AlwaysSmall" RowAlignment="Center">
    <ribbon:Button Command="EditingCommands.AlignLeft" />
    <ribbon:Button Command="EditingCommands.ToggleBold" />
</ribbon:StackPanel>
<ribbon:StackPanel ItemVariantBehavior="AlwaysSmall" RowAlignment="Center">
    <ribbon:Button Command="EditingCommands.AlignCenter" />
    <ribbon:Button Command="EditingCommands.ToggleItalic" />
</ribbon:StackPanel>
<ribbon:StackPanel ItemVariantBehavior="AlwaysSmall" RowAlignment="Center">
    <ribbon:Button Command="EditingCommands.AlignRight" />
    <ribbon:Button Command="EditingCommands.ToggleUnderline" />
</ribbon:StackPanel>
<ribbon:StackPanel ItemVariantBehavior="AlwaysSmall" RowAlignment="Center">
    <ribbon:Button Command="EditingCommands.AlignJustify" />
    <ribbon:Button Command="sample:ApplicationCommands.ToggleStrikethrough" />
</ribbon:StackPanel>

These StackPanel items will always use a Small (no label) variant, no matter what the variant size of the parent group is.

Sample 2

The second section in the screenshot above was created using this code:

XAML
Copy
​<ribbon:StackPanel ItemVariantBehavior="MediumThenSmallWhenSmall" RowAlignment="Center">
    <ribbon:Button ImageSourceSmall="/Resources/Images/DecreaseIndent16.png" Label="Decrease Indent" />
    <ribbon:Button ImageSourceSmall="/Resources/Images/IncreaseIndent16.png" Label="Increase Indent" />
</ribbon:StackPanel>

This StackPanel's items will start off in a Medium variant and then remove the labels when the group changes to a Small variant size. The items are aligned to the center.

Sample 3

The third section in the screenshot above was created using this code:

XAML
Copy
​<ribbon:StackPanel ItemVariantBehavior="MediumThenSmallWhenMedium">
    <ribbon:Button ImageSourceSmall="/Resources/Images/DecreaseIndent16.png" Label="Decrease Indent" />
    <ribbon:Button ImageSourceSmall="/Resources/Images/IncreaseIndent16.png" Label="Increase Indent" />
</ribbon:StackPanel>

This StackPanel's items will start off in a Medium variant and then remove the labels when the group changes to a Small variant size. The items are aligned to the top (the default).

Sample 4

The fourth section in the screenshot above was created using this code:

XAML
Copy
​<ribbon:StackPanel>
    <ribbon:Button ImageSourceLarge="/Resources/Images/Header32.png" ImageSourceSmall="/Resources/Images/Header16.png" Label="Header"/>
    <ribbon:Button ImageSourceLarge="/Resources/Images/Footer32.png" ImageSourceSmall="/Resources/Images/Footer16.png" Label="Footer" />
    <ribbon:Button ImageSourceLarge="/Resources/Images/PageNumber32.png" ImageSourceSmall="/Resources/Images/PageNumber16.png" Label="Page Number" />
</ribbon:StackPanel>

This StackPanel's items will start off layed out horizontally in a Large variant. They will switch to a vertical stack of Medium variant sizes when available width decreases. Finally, as available width decreases more, they will shift to a Small variant by removing their labels.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

There are a number of other miscellaneous controls used in the ribbon user interface.

Control Type | Description
Backstage / ApplicationMenu | The application menu displays when the application button on the ribbon is clicked. Both the newer Backstage and traditional application menu styles are available.
ContextMenu | A context menu that inherits ContextMenu and through use of a contained Menu control, allows any ribbon control to be used as child items. This allows for a consistent presentation throughout your application. Best of all, since our context menu class inherits ContextMenu, it can be used anywhere that a regular ContextMenu can.
ContextualTabGroup | A contextual tab group that contains one or more Tab controls and can be displayed based on document context.
Group | A group that can appear on a Tab.
Menu | A control that renders its items using templates that have menu item-like functionality.
Mini-ToolBar | The mini-toolbar can be displayed semi-transparently after a mouse selection or paired along with a context menu.
QuickAccessToolBar | The quick access toolbar (QAT) that can be displayed above or below the ribbon.
RecentDocumentMenu | A control that can be used on a Backstage, or as the additional content of an ApplicationMenu. It manages a sorted list of recently-opened documents and allows pinning of the documents.
Tab | A tab within a ribbon. The tab contains one or more Group controls.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Backstage / ApplicationMenu

The ribbon's application menu is displayed by clicking the large button in the upper left hand side of the ribbon. The application menu should generally be populated by application-wide menu items such as new, open, save file operations as well as other operations such as printing. Both the newer Backstage and traditional application menu styles are available.

This topic contains these sections:

  • Backstage Application Menu
  • Traditional Application Menu
  • Completely Hiding the Application Button

Backstage Application Menu

The Backstage application menu was introduced in Office 2010 and is a large popup that occupies the entire Window when open, overlaying all content.

A Backstage application menu with styled buttons

The Backstage is organized such that buttons and tabs appear on the left side (the header area) and the selected tab's content appears on the right side (the content area).

Note Note
The background blue watermark image used in the lower right corner of Backstage samples is just for demo purposes and should be replaced with your own image, one that you have created or properly licensed.

Defining a Backstage

The Backstage application menu may be defined in XAML by setting a Backstage control to the Ribbon.ApplicationMenu property.

This code sample shows how to define a Backstage application menu for a ribbon. Combine it with the code in the following sections to define your buttons and tabs.

XAML
Copy
​<ribbon:Ribbon>
    <ribbon:Ribbon.ApplicationMenu>
        <ribbon:Backstage>
            <ribbon:Backstage.Background>
                <ImageBrush ImageSource="YourLowerRightWatermarkImage.png" Stretch="None" TileMode="None" AlignmentX="Right" AlignmentY="Bottom" />
            </ribbon:Backstage.Background>

            <ribbon:Button Label="Save" ImageSourceSmall="/Resources/Images/Save16.png" KeyTipAccessText="S" />
            <!-- More buttons above tabs go here -->

            <!-- Optional RecentDocumentMenu goes here -->

            <ribbon:BackstageTab Header="Info" KeyTipAccessText="I">
                <!-- Info tab content goes here -->
            </ribbon:BackstageTab>
            <!-- More tabs go here -->

            <!-- More buttons below tabs go here -->
            <ribbon:Button Label="Exit" ImageSourceSmall="/Resources/Images/CloseTab16.png" KeyTipAccessText="X" />
        </ribbon:Backstage>
    </ribbon:Ribbon.ApplicationMenu>
</ribbon:Ribbon>

Key Tip Access

The Backstage.KeyTipAccessText property can be set to define the key tip access text for the application button. It defaults to F, allowing the Alt+F key combination to open the application menu.

Defining Backstage Items

The Backstage control can contain these types of controls, which appear vertically in its header area: Button, BackstageTab, Separator, and RecentDocumentMenu.

Controls will appear in the order in which they are defined in the Backstage. This allows you to freely intermix the order of buttons, tabs and any recent document menu.

Button controls generally appear at the top and bottom of the Backstage header area. They are often set to the most common application commands such as Save, that can be easily executed with one click.

BackstageTab controls can be added when there are multiple configuration possibilities or there is data that needs to be displayed. For instance, an Info tab may provide information and statistics about the current document. A Recent tab might show a RecentDocumentMenu with its VariantSize property set to Large, allowing for recent documents to be selected. A New tab might show multiple options for creating new documents.

The header of the BackstageTab is what is rendered in the Backstage header area. This is typically just a string. The tab's content is what is displayed in the Backstage content area when the tab is selected.

If you wish to add recent document buttons to your Backstage header, a RecentDocumentMenu control can be added. The template for this control when in the Backstage header will render a separator followed by buttons for each of the filtered documents specified by the menu's RecentDocumentManager. It is a good idea to insert a Separator before the RecentDocumentManager.

Auto-Selecting a Tab When Backstage Opens

The Ribbon.IsApplicationMenuOpen property gets or sets whether the application menu is currently open. A related Ribbon.IsApplicationMenuOpenChanged event fires whenever that property changes. This is an ideal place to initialize Backstage so that a certain tab is always selected when it opens.

The event handler for the Ribbon.IsApplicationMenuOpenChanged event can check to see if the application menu is being opened and if so, ensure the Backstage.SelectedItem property is set to the desired tab.

TaskTabControl

The TaskTabControl is a styled version of a native WPF TabControl that renders its tabs on the left side. The selected tab's content appears on the right side. This tab control is ideal for use on a BackstageTab since it provides a secondary level of tabs. It can be used external to Backstage as well.

A TaskTabControl with Separators and a Button on the selected tab.

The items of a TaskTabControl can be either Separator or TaskTabItem controls. Separators should have their Label properties set, and they will appear as group headers for the tab items. TaskTabItem tab headers can be any content, but to render similarly to Office, they should show an image and a text label.

Button and PopupButton Styles

The Backstage content area can show large silver buttons. Both the Button and PopupButton controls have a special template that kicks in if their ControlBase.Context is set to BackstageItem and their ControlBase.VariantSize is set to Large

Use of those properties can trigger the style of buttons found in Office's Backstage, and as seen above.

Separator Styles

The Backstage content area can labeled separators. The Separator controls has a special template for use on Backstage that activates if their ControlBase.Context is set to BackstageItem.

Use of those properties can trigger the style of labeled separators found in Office's Backstage, and as seen above.

Preventing Backstage from Closing

The Backstage.CanClose property can be set to false which prevents the Backstage from closing by hiding the close button and blocking Esc from closing Backstage.

This is useful in scenarios where you are starting up an application and wish to block end user access to the main window until they create a new document or open a document. These or other actions can be presented on a non-closable Backstage.

Traditional Application Menu

The traditional application menu is a medium-sized popup that appears when the ribbon's application button is clicked. The left side of the popup contains application-wide menu items.

A traditional application menu with a RecentDocumentMenu control on it

A section at the bottom of the application menu can used for footer buttons. Generally items such as application options and application exiting are displayed there.

Any content can be placed on the right side of the application menu as well. Generally a RecentDocumentMenu control is used there.

Defining an Application Menu

The application menu may be defined in XAML by setting an ApplicationMenu control to the Ribbon.ApplicationMenu property.

This code sample shows how to define an application menu for a ribbon. Combine it with the code in the following sections to define your application menu and its items.

XAML
Copy
​<ribbon:Ribbon>
    <ribbon:Ribbon.ApplicationMenu>
        <ribbon:ApplicationMenu>
            <!-- Items go here -->
        </ribbon:ApplicationMenu>
    </ribbon:Ribbon.ApplicationMenu>
</ribbon:Ribbon>

Key Tip Access

The ApplicationMenu.KeyTipAccessText property can be set to define the key tip access text for the application button. It defaults to F, allowing the Alt+F key combination to open the application menu.

Defining Menu Items

Menu items that appear on the left side of the application menu are defined via the ApplicationMenu's Items collection.

Control types that should be used here include: Button, PopupButton, SplitButton, and Separator.

This code defines the root items for a typical application menu. Note that some of the items have commands already tied to them and others are prototyped using XAML.

XAML
Copy
​<ribbon:ApplicationMenu>
    <ribbon:SplitButton Command="ApplicationCommands.New" KeyTipAccessText="N" />
    <ribbon:Button Command="ApplicationCommands.Open" KeyTipAccessText="O" />
    <ribbon:Button Command="ApplicationCommands.Save" KeyTipAccessText="S" />
    <ribbon:SplitButton ImageSourceLarge="/Images/SaveAs32.png" Label="Save As" KeyTipAccessText="A" />
    <ribbon:Separator />
    <ribbon:SplitButton ImageSourceLarge="/Images/Print32.png" Label="Print" KeyTipAccessText="P" />
    <ribbon:MenuButton ImageSourceLarge="/Images/Prepare32.png" Label="Prepare" KeyTipAccessText="E" />
    <ribbon:MenuButton ImageSourceLarge="/Images/Send32.png" Label="Send" KeyTipAccessText="D" />
    <ribbon:MenuButton ImageSourceLarge="/Images/Publish32.png" Label="Publish" KeyTipAccessText="U" />
    <ribbon:Separator />
    <ribbon:Button Command="ApplicationCommands.Close" KeyTipAccessText="C" />
    </ribbon:ApplicationMenu>

Defining Footer Buttons

Footer buttons that appear on the bottom of the application menu are defined via the ApplicationMenu.FooterButtons collection. This collection accepts any Button.

This code defines the footer buttons for a typical application menu. Note that buttons in this example are tied to commands defined in the sample project.

XAML
Copy
​<ribbon:ApplicationMenu>
    <ribbon:ApplicationMenu.FooterButtons>
        <ribbon:Button Command="sample:ApplicationCommands.ApplicationOptions" KeyTipAccessText="I" />
        <ribbon:Button Command="sample:ApplicationCommands.ApplicationExit" KeyTipAccessText="X" />
    </ribbon:ApplicationMenu.FooterButtons>
    </ribbon:ApplicationMenu>

Defining Additional Content (Right Side)

Any control may be set to the ApplicationMenu.AdditionalContent property to be displayed in the right side of the application menu.

This code defines a simple TextBlock as content for the right side of the application menu.

XAML
Copy
​<ribbon:ApplicationMenu>
    <ribbon:ApplicationMenu.AdditionalContent>
        <TextBlock>My content here...</TextBlock>
    </ribbon:ApplicationMenu.AdditionalContent>
    </ribbon:ApplicationMenu>

You can create your own complex custom control to fill this space. However keep in mind that per the Microsoft requirements, you are not permitted to use vertical scrollbars in this area.

Many applications will want to place our RecentDocumentMenu control into the application menu's additional content. This control displays a list of recently-opened documents that can be maintained in code-behind and supports pinning of the documents so that they don't fall off the list when newer documents are opened.

This code defines a RecentDocumentMenu as the application menu's additional content.

XAML
Copy
​<ribbon:ApplicationMenu>
    <ribbon:ApplicationMenu.AdditionalContent>
        <ribbon:RecentDocumentMenu>
            <shared:RecentDocumentManager x:Name="recentDocManager" />
        </ribbon:RecentDocumentMenu>
    </ribbon:ApplicationMenu.AdditionalContent>
</ribbon:ApplicationMenu>

Completely Hiding the Application Button

Although it usually isn't recommended, you can optionally hide the application button completely, blocking access to the application menu by the end user.

A ribbon with its application button hidden

To do this, set the Ribbon.IsApplicationButtonVisible property to false.

When in this mode, the QAT and tabs slide over to fill the space that was previously occupied by the application button.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ContextMenu

The ContextMenu class provides functionality for supporting a Menu of ribbon control items in a standard context menu.

Many of the interactive ribbon controls are capable of being hosted in a context menu, via use within a Menu.

A sample ribbon context menu used for an edit control

This topic contains these sections:

  • Compatibility with Native WPF ContextMenu
  • Using Menu as a ContextMenu Child
  • Keeping the ContextMenu Displayed When an Item is Clicked
  • Sample XAML
  • Keyboard Shortcut Display
  • Adding Access Keys to Menu Items

Compatibility with Native WPF ContextMenu

Since the ribbon ContextMenu class inherits the native WPF ContextMenu class, the ribbon ContextMenu may be used anywhere that a regular context menu can be used.

We recommend using the ribbon ContextMenu on any windows that have a ribbon user interfaceso that the UI experience is consistent for end users.

Using Menu as a ContextMenu Child

The Menu control should be used as the direct child of a ribbon ContextMenu. Then add ribbon controls that support menus as children of the Menu.

The Menu topic discusses which controls are best used within that control. Also, see the sample XAML below that shows how the ContextMenu in the screenshot above was created.

Keeping the ContextMenu Displayed When an Item is Clicked

Each ButtonBase defines a StaysOpenOnClick property that governs whether the containing menu closes when the menu item is clicked.

The default value for this property is false but can optionally be set to true.

Sample XAML

This code sample shows how to easily define a context menu for a RichTextBox in XAML.

XAML
Copy
​<RichTextBox>
    <RichTextBox.ContextMenu>
        <ribbon:ContextMenu>
            <ribbon:Menu>
                <ribbon:Button Command="ApplicationCommands.Undo" />
                <ribbon:Button Command="ApplicationCommands.Redo" />
                <ribbon:Separator />
                <ribbon:Button Command="ApplicationCommands.Cut" />
                <ribbon:Button Command="ApplicationCommands.Copy" />
                <ribbon:Button Command="ApplicationCommands.Paste" />
            </ribbon:Menu>
        </ribbon:ContextMenu>
    </RichTextBox.ContextMenu>
</RichTextBox>

Keyboard Shortcut Display

Each ButtonBase defines a InputGestureText property that indicates the keyboard shortcut text to display when in a small menu item context.

If a command assigned to a menu item has a KeyGesture, its text will be used by default. However you can override this value or set a custom one when not using a command by setting the InputGestureText property directly.

Adding Access Keys to Menu Items

When any sort of ribbon button (Button, PopupButton, etc.) is used in a ContextMenu as a menu item, an underline will appear under a character in the menu item's label if the control's KeyTipAccessText property has been set to a single alpha/numeric character and that character appears within the control's label. While the context menu is displayed the access key can be typed to execute the default action on the control.

For instance, a Paste Button that had a label of Paste and a KeyTipAccessText of P would have the P in Paste underlined.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ContextualTabGroup

The controls used most often in an application are always available on the Ribbon. However sometimes a specific object is selected in the document (such as a picture, table, or chart) that requires additional controls for proper interaction with the object. This is where contextual tabs come in since they contain the controls that relate to the selected object.

Contextual tabs are the same as normal tabs except that they are contained by a ContextualTabGroup and are only displayed when the parent ContextualTabGroup is active.

Contextual tab groups displayed for a selection in the document; note how green is used to distinguish the selected contextual tab

The contextual tab group draws a label over the tabs to indicate what they relate to. For instance if a table is selected in the document, the label Table Tools is displayed. It is recommended that the label name the type of object and follow it with Tools.

Each contextual tab group also should have a distinct background color. Actipro Ribbon includes numerous built-in colors for use with contextual tab groups, however you can specify your own as well. The colors apply to not only the contextual tab group label and tab, but also to the background of the tab's content.

Since contextual tabs are typically more important to the end user while they are displayed (because they relate to the current context in the document), the tabs themselves scale down after the "normal" tabs do, thus keeping them more visible longer when the ribbon's width decreases.

This topic contains these sections:

  • Defining a Contextual Tab Group
  • Showing / Hiding a ContextualTabGroup
  • Choosing a ContextualTabGroup Color

Defining a Contextual Tab Group

Contextual tab groups are defined in the Ribbon.ContextualTabGroups collection. Each ContextualTabGroup can contain one or more Tab controls.

This code sample shows how to define a contextual tab group for a ribbon.

XAML
Copy
​<ribbon:ContextualTabGroup Label="Header & Footer Tools" Color="{x:Static ribbon:ContextualTabGroupColors.Green}">
    <ribbon:Tab Label="Design">
        <ribbon:Group ImageSourceSmall="/Images/Header16.png" Label="Header & Footer" KeyTipAccessText="ZH">
            <ribbon:Group.Variants>
                <ribbon:GroupVariant Priority="50" Size="Medium" />
                <ribbon:GroupVariant Priority="130" Size="Collapsed" />
            </ribbon:Group.Variants>
            <ribbon:StackPanel>
                <ribbon:Button ImageSourceLarge="/Images/Header32.png"
                    ImageSourceSmall="/Images/Header16.png" Label="Header" KeyTipAccessText="H" />
                <ribbon:Button ImageSourceLarge="/Images/Footer32.png"
                    ImageSourceSmall="/Images/Footer16.png" Label="Footer" KeyTipAccessText="O" />
                <ribbon:Button ImageSourceLarge="/Images/PageNumber32.png"
                    ImageSourceSmall="/Images/PageNumber16.png" Label="Page Number" KeyTipAccessText="NU" />
            </ribbon:StackPanel>
        </ribbon:Group>
        <ribbon:Group Label="Demo">
            <ribbon:Button ImageSourceLarge="/Images/CloseTab32.png" Label="Close Contextual Tab" />
        </ribbon:Group>
    </ribbon:Tab>
</ribbon:ContextualTabGroup>

Showing / Hiding a ContextualTabGroup

When a ContextualTabGroup is activated, all of its child Tab controls are displayed. Likewise, deactivating a ContextualTabGroup hides all of its child tabs.

The ContextualTabGroup.IsActive property controls whether a contextual tab group and its tabs are visible. Set it to true to display a contextual tab group. This code displays a contextual tab group:

C#
VB
Copy
​ribbon.ContextualTabGroups["Header & Footer Tools"].IsActive = true;
​ribbon.ContextualTabGroups("Header & Footer Tools").IsActive = True

In some cases (please see the Contextual Tabs notes at the bottom of the Microsoft Ribbon UI Design Guidelines topic for details) when a contextual tab group is activated, its first tab should be selected. This code can accomplish the selection of the first tab in the contextual tab group after the contextual tab group has been activated:

C#
VB
Copy
​ribbon.SelectedTab = (Tab)contextualTabGroup.Items[0];
​ribbon.SelectedTab = CType(contextualTabGroup.Items(0), Tab)

The ContextualTabGroup.IsActiveChanged event is raised when the value of the IsActive property changes.

Choosing a ContextualTabGroup Color

As mentioned above, each contextual tab group should have its own distinct color. The color helps visually identify the contextual tab group from other tabs and from other contextual tab groups.

Actipro Ribbon includes several stock colors that can be used. They match the various colors used in Office for contextual tab groups. However you can use your own colors as well. Simply set the ContextualTabGroup.Color property to the base color you'd like to use for the contextual tab group.

This code sets the color of a ContextualTabGroup to the stock green color:

XAML
Copy
​<ribbon:ContextualTabGroup Label="Header & Footer Tools" Color="{x:Static ribbon:ContextualTabGroupColors.Green}">

You'll note that Green is referenced in the above example via a static property reference on ContextualTabGroupColors, which contains several stock color properties that can be used for contextual tab groups.

The stock colors that are defined on the ContextualTabGroupColors class are: Cyan, Green, Orange, Pink, Purple, Red, and Yellow.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Group

The Group control is an integral part of the ribbon user interface. It is used to group multiple controls together on a ribbon and provides a label for them at the bottom.

This topic contains these sections:

  • Variants
  • Dialog Launchers
  • Key Tip Access
  • Diabling Mouse Hover Animation When Remoting

Note Note
See the Control Basics topic for many implementation details that are common to the built-in controls such as this one.

Variants

Each group can have up to four variants for its layout: Large, Medium, Small, and Collapsed. You have total control how each variant adjusts the layout of its child controls to use less total width when a smaller VariantSize is used.

Note Note
Group variants and how they affect child controls is explained in great detail in the ribbon resizing topic.

One of the most powerful features of Actipro Ribbon is the ability to easily create prioritized child control layout changes as the available ribbon width decreases. You won't find anything that matches its robust design anywhere else.

Here is a demonstration of how a single group can change the layout of its child controls as available width decreases.

Variant Size | Sample UI
Large |
Medium |
Small |
Collapsed | (Acts like a PopupButton that displays the expanded Group in a popup when clicked)

Dialog Launchers

If a command has been assigned to the Group via its Command property then a dialog launcher button will be displayed next its label at the bottom of the group. The expanded group screenshot above shows an example of a dialog launcher button.

A group with a dialog launcher button

Dialog launcher buttons should be used to display dialogs that contain advanced functionality related to the group that is not available within the ribbon control.

Key Tip Access

The Group.KeyTipAccessText property can be set to define the key tip access text for the group when it is in a collapsed state. Generally group key tip access text starts with a Z followed by another letter. For instance, the Clipboard group's collapsed key tip text may be ZC.

The key tip access text for a dialog launcher button (if any) can be set by the Group.DialogLauncherKeyTipAccessText property.

Diabling Mouse Hover Animation When Remoting

Sometimes it is beneficial to disable group mouse hover animation when running an application remotely via RDP or Citrix. The attached ThemeProperties.AreAnimationsEnabled property can be set on a Group instance to disable mouse hover animation for that group.

If you are using system or Office 2010 themes, this property can be set via an implicit style in your applicationr resources that targets the Group control instead of on each Group instance itself.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Menu

The Menu is a control that presents its items similar to how a standard native popup menu would except with ribbon styling.

A popup for a SplitButton that contains a Menu with three items on it

This topic contains these sections:

  • Menu Architecture
  • Valid Child Controls
  • Using Other Controls in Menus
  • Child Control Minimum Widths
  • Adding Access Keys to Menu Items
  • Controls with Popups that Can Use Menu

Menu Architecture

The ribbon Menu control is an ItemsControl that is intended to be used exclusively on popups for other controls. It presents its items using alternate templates that look like menu items.

For instance, when a ribbon Button is added to a Menu, the button draws and behaves just like a regular menu item in Office.

Valid Child Controls

Almost all of the interactive controls can be used in a Menu. These include:

  • Button
  • CheckBox (renders like a Button when in a Menu)
  • ComboBox
  • FontFamilyComboBox
  • FontSizeComboBox
  • PopupButton
  • RadioButton (renders like a Button when in a Menu)
  • Separator
  • SplitButton
  • TextBox

The PopupButton and SplitButton controls can be used to provide "sub-menus" since they also have popups that can hold more Menu controls with items.

Using Other Controls in Menus

Due to flexible design of Menu, any sort of small non-ribbon control can be added as a menu item to a Menu control.

The really neat feature of this is that you can even assign an image and label to any non-ribbon control. This is accomplished by assigning attached properties from RibbonControlService.

A Menu containing the DateTimePicker control, which is defined in the Shared Library

The first property that needs to be assigned is RibbonControlService.IsExternalContentSupportedProperty. This property should be set to true so that the control being added aligns correctly with the text portion of the menu item. If it is false (the default), the control will span the entire width of the Menu and will cover the image column.

Second, you may optionally assign the RibbonControlService.LabelProperty and RibbonControlService.ImageSourceSmallProperty properties. If you don't assign them, the control will be aligned with the left size of the other menu item labels. If you assign a label, the label will appear under other menu item labels and the control will appear immediately to the right of it. If you assign an image, it will appear in the image column.

This code shows how to add a native WPF TextBox to a Menu:

XAML
Copy
​<TextBox MinWidth="100" ribbon:RibbonControlService.IsExternalContentSupported="True"
    ribbon:RibbonControlService.Label="Native TextBox" />

Child Control Minimum Widths

When certain controls like a TextBox that can expand width based on content are added to a Menu, be sure to set their MinWidth property. This ensures that a minimum width is applied to the control and that the control will expand if there are other longer controls around it.

This concept is not needed for controls like Button since those controls automatically fill the width of the Menu.

Adding Access Keys to Menu Items

When any sort of ribbon button (Button, PopupButton, etc.) is used in a Menu as a menu item, an underline will appear under a character in the menu item's label if the control's KeyTipAccessText property has been set to a single alpha/numeric character and that character appears within the control's label. While the menu is displayed the access key can be typed to execute the default action on the control.

For instance, a Paste Button that had a label of Paste and a KeyTipAccessText of P would have the P in Paste underlined.

Controls with Popups that Can Use Menu

There are several built-in ribbon controls that have popups. The Menu control is most often used as the popup content for the PopupButton, SplitButton, and RibbonGallery controls.

Since Menu is a regular control, more than one Menu can be used on the same popup. By making the popup content a Panel and adding two Menu controls to the Panel (generally with a Separator in between), you could have a popup with two columns of menu items.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Mini-ToolBar

The mini-toolbar is a great new concept introduced in Office 2007. Any controls, including galleries, can be used on the mini-toolbar.

A mini-toolbar showing the use of a color picker gallery child control

Mini-toolbars are typically used in two scenarios: following a mouse selection in a document and for display along with a context menu to provide additional options.

No XBAP Support No XBAP Support
Since the mini-toolbar (per Microsoft requirements) relies heavily on the use of transparency, and popups in XBAPs do not support transparency, the mini-toolbar cannot be used in an XBAP.

This topic contains these sections:

  • Adding Controls to the Mini-ToolBar
  • Showing a Mini-ToolBar After a Mouse Selection
  • Configuring a Mini-ToolBar for Pairing With a Context Menu

Adding Controls to the Mini-ToolBar

The MiniToolBar control inherits ItemsControl and therefore adding controls to it is extremely easy, however we do have some layout tips. Any control can be added to the mini-toolbar.

Use a Grid as the ItemsPanel

The MiniToolBar will use a WrapPanel by default for the items panel however we typically using a more advanced Grid control instead. This yields several benefits, which are apparent in the screenshot above.

First, multiple rows of items are supported by using a Grid.

Second, you can add a colum in the Grid using * layout so that it auto-fills to match the width of another longer row. In the screenshot above, the first row's FontFamilyComboBox has a MinWidth of 70 and it is in its own * layout column. The items in the second row span two columns and have a length longer than the entire first row. But since the FontFamilyComboBox is in a * layout column, it expands the FontFamilyComboBox to make up the space. Therefore both rows end up being the same width and looking great.

Third, the use of a Grid lets you place a spacer row in between the two real rows of items.

Use a ButtonGroup Within the Grid

When using a Grid, you can encapsulate a horizontal run of ribbon controls with a ButtonGroup to ensure the child controls receive the proper context and variant size.

Sample Implementation for Screenshot Above

This code sample shows how the mini-toolbar in the screenshot above could be defined, but note that this code sample doesn't show any commands or popup child controls like the gallery.

XAML
Copy
​<ribbon:MiniToolBar>
    <ribbon:MiniToolBar.ItemsPanel>
        <ItemsPanelTemplate>
            <Grid>
                <Grid.RowDefinitions>
                    <RowDefinition Height="Auto" />
                    <RowDefinition Height="2" />
                    <RowDefinition Height="Auto" />
                </Grid.RowDefinitions>
                <Grid.ColumnDefinitions>
                    <ColumnDefinition Width="*" />
                    <ColumnDefinition Width="Auto" />
                </Grid.ColumnDefinitions>
            </Grid>
        </ItemsPanelTemplate>
    </ribbon:MiniToolBar.ItemsPanel>

    <ribbon:FontFamilyComboBox MinWidth="70" />
    <ribbon:ButtonGroup Grid.Column="1">
        <ribbon:FontSizeComboBox Width="40" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/GrowFont16.png" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/ShrinkFont16.png" />
        <ribbon:PopupButton ImageSourceSmall="/Resources/Images/ChangeCase16.png" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/FormatPainter16.png" />
    </ribbon:ButtonGroup>

    <ribbon:ButtonGroup Grid.Row="2" Grid.ColumnSpan="2">
        <ribbon:Button ImageSourceSmall="/Resources/Images/Bold16.png" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/Italic16.png" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/AlignTextCenter16.png" />
        <ribbon:SplitButton ImageSourceSmall="/Resources/Images/TextHighlightColor16.png" />
        <ribbon:SplitButton ImageSourceSmall="/Resources/Images/FontColor16.png" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/DecreaseIndent16.png" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/IncreaseIndent16.png" />
        <ribbon:SplitButton ImageSourceSmall="/Resources/Images/Bullets16.png" />
    </ribbon:ButtonGroup>

</ribbon:MiniToolBar>

Showing a Mini-ToolBar After a Mouse Selection

When a selection is made in a document, a mini-toolbar can be made to semi-transparently appear above the mouse. As the end user moves the mouse closer to the mini-toolbar, it becomes more opaque. Moving the mouse farther away makes the mini-toolbar more transparent until a point where the mini-toolbar disappears completely. After a certain threshold distance is passed, the mini-toolbar is closed completely and does not reappear until another selection is made.

A mini-toolbar displayed after a selection showing how it changes from semi-transparent to opaque when the mouse moves over it

To show a mini-toolbar after a mouse selection in a RichTextBox for example, simply attach to the RichTextBox's PreviewMouseUp event. In the handler, if there is a selection, call the MiniToolBarService.Show method and pass it the MiniToolBar to display and the location at which to show it. It's as easy as that. Actipro Ribbon handles the rest for you.

Configuring a Mini-ToolBar for Pairing With a Context Menu

A mini-toolbar can optionally be paired and displayed with any ContextMenu. Normally the mini-toolbar appears above the context menu. If a menu item on the context menu is chosen, both the context menu and mini-toolbar close. Alternatively, if the end user clicks a control on the mini-toolbar, the mini-toolbar remains open but the context menu closes. After this point the mini-toolbar behaves as if it was opened standalone.

A mini-toolbar displayed with a context menu

This code sample shows how to define a simple mini-toolbar for a RichTextBox's context menu:

XAML
Copy
​<RichTextBox>
    <RichTextBox.ContextMenu>
        <ribbon:ContextMenu>
            <ribbon:ContextMenu.MiniToolBar>
                <ribbon:MiniToolBar>
                    <ribbon:Button ImageSourceSmall="/Resources/Images/Bold16.png" />
                    <ribbon:Button ImageSourceSmall="/Resources/Images/Italic16.png" />
                    <ribbon:Button ImageSourceSmall="/Resources/Images/Underline16.png" />
                </ribbon:MiniToolBar>
            </ribbon:ContextMenu.MiniToolBar>
            <ribbon:Menu>
                <ribbon:Button Label="Undo" ImageSourceSmall="/Resources/Images/Undo16.png" />
                <ribbon:Button Label="Redo" ImageSourceSmall="/Resources/Images/Redo16.png" />
                <ribbon:Separator />
                <ribbon:Button Label="Cut" ImageSourceSmall="/Resources/Images/Cut16.png" />
                <ribbon:Button Label="Copy" ImageSourceSmall="/Resources/Images/Copy16.png" />
                <ribbon:Button Label="Paste" ImageSourceSmall="/Resources/Images/Paste16.png" />
            </ribbon:Menu>
        </ribbon:ContextMenu>
    </RichTextBox.ContextMenu>
</RichTextBox>

The ContextMenu control that comes with Actipro Ribbon has a MiniToolBar property on it. To associate a MiniToolBar with a context menu, simply set the mini-toolbar to that property. After that, Actipro Ribbon handles the display and management of the mini-toolbar for you. It will show up when the mouse is used to display the context menu and will have all the functionality described above.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


QuickAccessToolBar (QAT)

The ribbon's quick access toolbar can be displayed either above the ribbon (in the window's title bar) or below the ribbon depending on the end user's preference. It provides quick access to the most commonly used commands in your application.

A ribbon quick access toolbar above and below the ribbon

This topic contains these sections:

  • Defining a Quick Access Toolbar Items
  • Quick Access Toolbar Location
  • Hiding the Quick Access Toolbar
  • Hiding the QAT Customize Button
  • Customizing the Customize Button's Menu
  • Persisting End-User Run-Time Item Customizations

Defining a Quick Access Toolbar Items

Quick access toolbar (QAT) items are defined in the Ribbon.QuickAccessToolBarItems collection. The quick access toolbar items may be defined in XAML if you like.

This code sample shows how to define the quick access toolbar items for a ribbon. Note that the buttons listed are tied to commands that express their user interface.

XAML
Copy
​<ribbon:Ribbon>
    <ribbon:Ribbon.QuickAccessToolBarItems>
        <ribbon:Button Command="ApplicationCommands.Save" />
        <ribbon:Button Command="ApplicationCommands.Undo" />
        <ribbon:Button Command="ApplicationCommands.Redo" />
    </ribbon:Ribbon.QuickAccessToolBarItems>
</ribbon:Ribbon>

Quick Access Toolbar Location

The QAT can be located either above or below the ribbon. The Ribbon.QuickAccessToolBarLocation property gets and sets the location of the QAT. It takes an enueration of type QuickAccessToolBarLocation.

The Ribbon.QuickAccessToolBarLocationChanged event fires when the location changes.

Hiding the Quick Access Toolbar

The QuickAccessToolBarLocation property described above also has a None option that when used will hide the QAT completely.

Hiding the QAT Customize Button

The IsQuickAccessToolBarCustomizeButtonVisible property can be set to false to hide the customize button that appears next to the QAT.

Customizing the Customize Button's Menu

Ribbon supports dynamic customization of the Customize button's menu at run-time.

See the Customizing Context Menu topic for a section with information on how to do this.

The Customizing Context Menus QuickStart also shows a sample of this in action.

Persisting End-User Run-Time Item Customizations

Ribbon includes a very flexible framework for supporting multiple forms of QAT customization. If you allow this functionality, you generally will wish to persist the end user's customizations (addition/removal of controls to the QAT) so that they can be restored when your application is started again later.

The Customizing the QAT topic covers how to persist the state of the QAT to an XML string that can be restored later.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RecentDocumentMenu

A RecentDocumentMenu control is a control that is intended to be used within a Backstage, or an ApplicationMenu as its additional content when recent document tracking is desired.

Recently-opened documents are listed in a sorted order and can be clicked on to open them. Mouse hovering over a document provides its full path.

Clicking on a document's pin button will toggle the pinned state of the document. When pinned, the document will not fall of the list if there are other unpinned documents that have been opened more recently.

A ribbon application menu with a RecentDocumentMenu control on it

This topic contains these sections:

  • Adding the RecentDocumentMenu to a Backstage
  • Adding the RecentDocumentMenu to an ApplicationMenu
  • Managing the Recent Document List
  • Processing Clicks on Documents

Adding the RecentDocumentMenu to a Backstage

The RecentDocumentMenu can be added to a Backstage application menu in a couple places.

The first location is directly as an item of a Backstage control. In this case it is advisable to limit the number of items rendered (via the manager) to a small number such as 3 or 4 since a button will be rendered for each document in the left side of the Backstage, thus pushing down any other tabs or buttons after it.

When a RecentDocumentMenu is included in the content of a BackstageTab it should have its VariantSize property set to Large. This will enable it to render similar to Office, showing large icons and descriptions, all of which can be set on the IDocumentReference instances.

Adding the RecentDocumentMenu to an ApplicationMenu

The RecentDocumentMenu can be added to a ApplicationMenu via the AdditionalContent property.

The ApplicationMenu topic provides a sample of doing this.

Changing the Header

By default, the header of the control will read Recent Documents.

To change that text globally, change that field before any UI is instantiated. To change the header text for a specific control instance, set the RecentDocumentMenu.Label property.

Managing the Recent Document List

The recent document list is managed by the RecentDocumentManager that is assigned to the RecentDocumentMenu.Manager property. This object maintains a list of IDocumentReference objects.

See the Document Management topic for details on how to manage the list using the RecentDocumentManager, including the ability to limit the number of documents shown.

Since the RecentDocumentMenu is bound to the RecentDocumentManager to which it is assigned, changes to that manager will automatically update the menu. However certain changes such as updating a document reference's last-opened date/time may not be picked up by the manager as a change. In these cases you must call RecentDocumentManager.RebindFilteredDocuments explicitly. This in turn updates the menu automatically.

Processing Clicks on Documents

When the end user clicks on a document listed in the RecentDocumentMenu, they are attempting to open the document. Therefore, we raise the standard WPF ApplicationCommands.Open command with its command parameter being the IDocumentReference that represents the document.

In your code, handle the ApplicationCommands.Open command and use the command parameter (a IDocumentReference) to determine which Uri to open. If no command parameter is passed, then you can assume the command was triggered by a menu item like on the application menu's generic Open menu item. In this case, you would want to show an Open File dialog.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tab

The Tab is a control that represents one of the tabs at the top of the ribbon.

It contains multiple Group controls, each of which contains multiple child controls.

Several ribbon tabs

This topic contains these sections:

  • Tab Types
  • Adding/Removing Groups
  • Programmatically Selecting a Tab
  • Tab Selection Events
  • Selecting a Tab with the Keyboard
  • Disabling Tabs
  • Tab Color Tinting
  • Sample XAML

Tab Types

There are two types of tabs: normal and contextual.

Normal tabs all draw in the same colors and are added to the ribbon via the Ribbon.Tabs collection.

Contextual tabs are tabs that contain controls that only should be displayed in certain contexts. For instance, perhaps when an image selection is made in a document. Contextual tabs may be grouped together with related contextual tabs in a ContextualTabGroup and are displayed when that group becomes active. Unlike regular tabs, contextual tabs are not added to the Ribbon.Tabs collection. Instead, they are added to a parent ContextualTabGroup. See the ContextualTabGroup topic for detailed information on how to define and activate contextual tab groups.

Adding/Removing Groups

Group controls for a Tab can be added to or removed from the Tab.Items collection.

This collection is the markup content property for the Tab control too, so Group controls can be added to a Tab as direct child elements in XAML.

Programmatically Selecting a Tab

Only one tab can be selected at any time within a ribbon.

The Ribbon.SelectedTab property allows you to get or set the Tab that is currently selected in the ribbon.

Tab Selection Events

The Ribbon control exposes two events related to the selection of a tab. The SelectedTabChanging event fires before a tab change occurs and the SelectedTabChanged event fires after a tab change occurs.

The event arguments for the changing event allow for the tab change to be cancelled by setting e.Cancel to true.

Selecting a Tab with the Keyboard

If you have defined a KeyTipAccessText on a Tab, that tab can quickly be accessed by holding Alt and typing the KeyTipAccessText letter.

For instance, if you assigned a KeyTipAccessText of H to your Home tab, pressing Alt+H will jump to that tab and start key tip mode for the controls within that tab.

Disabling Tabs

Tabs can be disabled by setting their Tab.IsEnabled property to false. While disabled, they cannot be clicked or selected by the end user. Their text will be drawn in a disabled color as well.

Tab Color Tinting

The Tab control has a TintColor property that can be set to tint the tab's background towards a certain color. Normally this is only used when the tab is in a ContextualTabGroup (set automatically in this case), however it can be set independently as well.

Sample XAML

This code sample shows how to easily define Group controls within a Tab in XAML.

XAML
Copy
​<ribbon:Tab Label="Home" KeyTipAccessText="H">
    <ribbon:Group ImageSourceSmall="/Resources/Images/Paste16.png" Label="Clipboard" KeyTipAccessText="ZC" />
    <ribbon:Group ImageSourceSmall="/Resources/Images/FontColor16.png" Label="Font" KeyTipAccessText="ZF" />
    <ribbon:Group ImageSourceSmall="/Resources/Images/ParagraphCenter16.png" Label="Paragraph" KeyTipAccessText="ZP" />
    <ribbon:Group ImageSourceSmall="/Resources/Images/StylesGroup16.png" Label="Styles" KeyTipAccessText="ZS" />
    <ribbon:Group ImageSourceSmall="/Resources/Images/Find16.png" Label="Editing" KeyTipAccessText="ZN" />
</ribbon:Tab>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Working with Popups

Several built-in ribbon controls have popups. Popups in Actipro Ribbon aren't restricted to having just menu items in them. While most of the time you will only place menu items in them, you have the option of displaying any sort of content within a popup.

A popup with two Menu controls in a StackPanel, one with large items and one with small items

All the popup-related properties illustrated below are implementations of attached properties from PopupControlService.

This topic contains these sections:

  • Built-In Controls with Popups
  • Defining Popup Content
  • Hiding the Popup Border
  • Popup Content Layout Options
  • Popup Location
  • Making Popups Resizable
  • Dynamically Generating Popup Content

Built-In Controls with Popups

These controls and any controls derived from them have popups:

  • PopupButton
  • RibbonGallery
  • SplitButton

Defining Popup Content

The built-in controls have several properties that are used for defining content.

Member | Description
PopupContent Property | Gets or sets the content that is displayed on the popup for the button. This can be any object, including panels of multiple controls, however it is generally a Menu.
PopupContentTemplate Property | Gets or sets the DataTemplate to use for the PopupContent. This property is only really useful if your popup content is a data object and not a UI element.
PopupContentTemplateSelector Property | Gets or sets the DataTemplateSelector to use for the PopupContent. This property is only really useful if your popup content is a data object and not a UI element.

Hiding the Popup Border

By default the popup will display a border around its contents. However sometimes it is necessary to hide the default border. This sort of option is used for the ApplicationMenu since it has a custom draw border.

Set the PopupHasBorder property to false to hide the border.

Popup Content Layout Options

The most common content for a popup is a Menu control, which renders its items as menu items:

XAML
Copy
​<ribbon:PopupButton ImageSourceLarge="/Resources/Images/Paste32.png" ImageSourceSmall="/Resources/Images/Paste16.png" Label="Paste" KeyTipAccessText="V">
    <ribbon:Menu>
        <ribbon:Button ImageSourceSmall="/Resources/Images/Paste16.png" Label="Paste" KeyTipAccessText="P" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/PasteSpecial16.png" Label="Paste Special" KeyTipAccessText="S" />
        <ribbon:Button ImageSourceSmall="/Resources/Images/PasteHyperlink16.png" Label="Paste Hyperlink" KeyTipAccessText="H" />
    </ribbon:Menu>
</ribbon:PopupButton>

However there are probably times when you wish to create more complex layouts of controls on a popup. In these scenarios, use a Panel as the PopupContent.

For instance, use a native WPF StackPanel to stack a popup header banner image or a PopupGallery on top of a Menu of items. This sort of layout is very often used in popups that contain a PopupGallery because you can place menu items above and below the PopupGallery as needed.

Or use a native WPF StackPanel with horizontal orientation to create a popup with two Menu controls, one on the left of the other with a Separator in between (two columns of menu items).

By using techniques like this (also illustrated throughout the sample project), you can create complex layouts of popup content.

Popup Location

The built-in controls have several properties that can be used to determine where the popup will be displayed in relation to the parent anchor control. These properties correspond in functionality with the similar properties (without Popup in the name) found on the native WPF Popup class.

Member | Description
CustomPopupPlacementCallback Property | Gets or sets a delegate handler method that positions the popup control.
PopupHorizontalOffset Property | Gets or sets the offset from the left of the area that is specified for the popup control content by a combination of the PopupPlacement, PopupPlacementTarget, and PopupPlacementRectangle properties.
PopupPlacementRectangle Property | Gets or sets the orientation of the popup when the it opens, and specifies the behavior of the popup when it overlaps screen boundaries.
PopupPlacementRectangle Property | Gets or sets the rectangle relative to which the popup control is positioned when it opens.
PopupPlacementTarget Property | Gets or sets the element relative to which the popup is positioned when it opens.
PopupVerticalOffset Property | Gets or sets the offset from the top of the area that is specified for the popup control content by a combination of the PopupPlacement, PopupPlacementTarget, and PopupPlacementRectangle properties.

Making Popups Resizable

With a Contained PopupGallery

The popup has a special gripper that can be used by assigning a value to the PopupResizeMode property. However the gripper is only intended to work if there is a PopupGallery control contained somewhere in the popup content since there is special resizing logic needed to handle that scenario.

Without a Contained PopupGallery

There may be other scenarios where your popup content doesn't include a PopupGallery control but you still want the popup to be resizable. In this case, leave the PopupResizeMode property its default value of None and wrap your popup content with a ResizableContentControl (located in the Shared Library). This will add a gripper to the content allowing for resizing of the popup.

This is very useful if you want to have a control like a native WPF TextBox be resizable in a SplitButton's popup.

Here is some XAML code showing a sample implementation:

XAML
Copy
​<ribbon:SplitButton ImageSourceLarge="/Resources/Images/Paste32.png" Label="Popup with Resizable Content">
    <shared:ResizableContentControl MinWidth="250" MinHeight="50" MaxWidth="600" MaxHeight="400">
        <TextBox Text="This popup can be resized." AcceptsReturn="True"
            BorderThickness="0" HorizontalScrollBarVisibility="Visible" VerticalScrollBarVisibility="Visible" />
    </shared:ResizableContentControl>
</ribbon:SplitButton>

Dynamically Generating Popup Content

Actipro Ribbon makes it easy to dynamically create/change a popup's content before the popup is displayed. This feature is most commonly used to customize menu items for a popup that contains a menu.

All the ribbon controls that display popups raise a PopupOpening event that fires right before a popup is displayed. You can attach to this event and in that handler, alter the popup content however you require.

Here is some code showing how to dynamically create a Menu for a popup before it is displayed.

C#
VB
Copy
​private void OnPopupButtonPopupOpening(object sender, RoutedEventArgs e) {
    RibbonControls.PopupButton popupOwner = (RibbonControls.PopupButton)sender;

    // Create a menu with some items
    RibbonControls.Menu menu = new RibbonControls.Menu();
    for (int index = 0; index < 3; index++) {
        RibbonControls.Button button = new RibbonControls.Button();
        button.Label = String.Format("Dynamically created menu item #{0}, created at {1}", index + 1, DateTime.Now);
        menu.Items.Add(button);
    }
    popupOwner.PopupContent = menu;
}
​Private Sub  OnPopupButtonPopupOpening(ByVal sender As object, ByVal e As RoutedEventArgs) {
    Dim popupOwner As RibbonControls.PopupButton = CType(sender, RibbonControls.PopupButton)

    ' Create a menu with some items
    Dim menu As RibbonControls.Menu = New RibbonControls.Menu()
    Dim index As Integer
    For index = 0 To 2
        Dim button As RibbonControls.Button = new RibbonControls.Button()
        button.Label = String.Format("Dynamically created menu item #{0}, created at {1}", index + 1, DateTime.Now)
        menu.Items.Add(button)
    Next index
    popupOwner.PopupContent = menu
End Sub

See the Dynamic Popup Content QuickStart for a live sample of dynamically generating popup content.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Customizing the QAT

Actipro Ribbon supports complete run-time customization of the Quick Access ToolBar (QAT) by the end user via the use of context menus and also Customize QAT dialog windows.

Ribbon has built-in support for all customization capabilities found in Office. You can even clone an entire Group and place it in the QAT.

This topic contains these sections:

  • Quick Tips
  • All About Cloning
  • Using the Id Property to Mark Duplicate Controls with the Same Functionality
  • Determining Which Controls Can Be Cloned to the QAT
  • Customizing the QAT Via Context Menus
  • Showing Common QAT Items on the QAT's Customize Menu
  • Displaying a 'More Commands'/'Customize Quick Access Toolbar' Item on Auto-Generated Control Context Menus
  • Implementing an Options Window With Complete QAT Customization Functionality
  • Persisting Customized QAT Items in User Settings

Quick Tips

Many more details on configuring all aspects of QAT customization at described below but here are some quick tips to get you started.

By default, end-user QAT customization is enabled. This means that auto-generated context menus for controls that support QAT customization will have items that let them be added to and removed from the QAT. You can disable this default behavior by setting the Ribbon.IsQuickAccessToolBarCustomizationEnabled property to false.

However if you keep that true, certain control types will be able to be added to or removed from the QAT by default. Most ribbon controls support this behavior by default and other controls do not. The CloneService.CanCloneToQuickAccessToolBarProperty attached property can be assigned to any control to configure whether it does support QAT customization.

There are many other QAT customization features and options described in the sections below, including adding common QAT items, displaying a Customize QAT dialog, and more.

All About Cloning

When controls are added to the QAT, other than at design-time, they are generally added as a clone of another existing control. The clone is essentially a duplicate deep copy of a control, with all its dependency property and item collections copied.

The CloneService is the class the provides management and tracking of clones. All of the built-in QAT customization features described below harness the CloneService to support modification of the QAT.

CloneService Important Members

The CloneService class has some important members that you can use to help track clones if you need them.

Member | Description
CanClone Method | Returns whether the specified DependencyObject can be cloned. This method checks that the object is not a clone itself, and that it either implements ICloneable or has a public parameterless constructor.
CreateClone Method | Creates a clone of the specified DependencyObject.
DisposeClone Method | Removes all tracked references to the specified clone.
GetClones Method | Returns the collection of objects that have been cloned from the specified DependencyObject.
GetCloneSource Method | Returns the original source DependencyObject from which the specified DependencyObject was cloned.
HasClones Method | Returns whether the specified DependencyObject has any clones.
IsAClone Method | Returns whether the specified DependencyObject is a root-level clone of another object.

Cloning Events

Several CloneService attached events occur during the clone creation/disposal lifecycle.

Member | Description
CloneCreatingEvent Attached Event | Occurs when a clone creation is first requested. The original source in the event args is the control to clone. Set the Item of the event arguments to a custom-created clone. If you do not set the Item property, a clone will be automatically created for you and passed back to you in the CloneCreatedEvent event.
CloneCreatedEvent Attached Event | Occurs right before a clone is about to be readied for use. The original source in the event args is the control to clone. If the Item of the event arguments was set in a CloneCreatingEvent handler, that value will still be in the Item property. If it was not set in that other event, a clone that was automatically created will be present in the Item property. You can further customize the clone as needed.
CloneDisposedEvent Attached Event | Occurs when a clone is being disposed (tracking by CloneService is done). The original source in the event args is the original control that was cloned. The Item of the event arguments is the clone that is no longer being tracked.

Tip Tip
Handlers for the CloneCreatedEvent event are a good place to attach to events on the cloned control if necessary.

Using the Id Property to Mark Duplicate Controls with the Same Functionality

Controls of the same type and functionality should only be able to be added to the QAT once. Say you had an Open menu item on the application menu but also in a menu for a popup button that appears on the Home tab of your ribbon. In this scenario both menu items perform the same command and should be treated as identical controls for the purposes of dealing with QAT customization. If you add one of the controls to the QAT (which creates a clone of that control), when you show a context menu for the other control, it should have its Add to Quick Access Toolbar menu item disabled. This can be accomplished via the use of the Id property.

The RibbonControlService defines the attached Id property. It is also defined on all the ribbon control base classes. The use of the Id property is completely optional but in cases where you have multiple instances of controls with the same functionality in your ribbon, it should be used.

In the scenario described above, you could set the Id of both Open menu items to FileOpen. When Ribbon examines your controls to determine if they have already been added to the QAT, it will see that both menu items are the same control type (a Button) and they both have the same Id. That is how it will determine that they have the same functionality.

Important Note Important Note
When adding controls to the QAT at design-time or into the QuickAccessToolBarCommonItems collection, it is very important that you assign the Id property.

Determining Which Controls Can Be Cloned to the QAT

The CloneService.CanCloneToQuickAccessToolBarProperty attached property can be assigned to any control to allow it to be added to the QAT by the end user. This property defaults to false in general but for most ribbon controls, it defaults to true. Therefore you probably will never need to worry about setting it.

Controls eligible for cloning to the QAT must also have a RibbonControlService.LabelProperty attached property defined. Note that this property is also more readily available on all ribbon controls via the Label property. The label is used to help represent the control in the Options window's QAT items lists (see below).

Customizing the QAT Via Context Menus

The fastest way to customize the QAT at run-time is to use context menus on ribbon controls. If the Ribbon.IsQuickAccessToolBarCustomizationEnabled property is set to true, the default, Ribbon will automatically add appropriate menu items to context menus for ribbon controls.

A control's context menu showing the Add to Quick Access Toolbar menu item

Ribbon controls that are not in the QAT will have an Add to Quick Access Toolbar menu item. Clicking an add menu item will create a clone of the control and add it to the QAT. This functionality is even available for Group controls.

Ribbon controls that are in the QAT will have a Remove from Quick Access Toolbar menu item. Clicking the remove menu item will remove the control from the QAT, and if it is a clone, will dispose the tracking of the clone.

Showing Common QAT Items on the QAT's Customize Menu

The QAT's Customize button menu can optionally show a list of common items that can be added to the QAT. If any are already listed on the QAT, they will appear checked.

The Quick Access ToolBar's Customize menu, showing some common QAT items

You may define the template common QAT controls by adding them to the Ribbon.QuickAccessToolBarCommonItems collection. The controls in this collection are never directly used, however they will appear in the list of common QAT items in the QAT Customize button's menu. When an unchecked common QAT control menu item is clicked, a clone of the control will be created and added to the QAT.

It is imperative that the controls defined in the QuickAccessToolBarCommonItems collection have Id properties (see info on Id property in a section above) set on them. For instance, the Save button is defined explicitly on the QAT at design-time, but also in the QuickAccessToolBarCommonItems collection, and on the application menu. All three places should have the Id property set to something like File.Save so that Ribbon knows they are identical controls in terms of functionality.

Displaying a 'More Commands'/'Customize Quick Access Toolbar' Item on Auto-Generated Control Context Menus

A More Commands menu item can be added to the QAT Customize button's menu and a Customize Quick Access Toolbar menu item can be added to any auto-generated ribbon control context menus.

A control's context menu showing the Customize Quick Access Toolbar menu item

Set the Ribbon.IsCustomizeQuickAccessToolBarMenuItemVisible property to true to enable the addition of these menu items.

These menu items all trigger the RibbonCommands.CustomizeQuickAccessToolBar command. Add a handler for that command in your application, and in your handler, show an Options window with its Customize QAT page displayed.

Implementing an Options Window With Complete QAT Customization Functionality

We've implemented a demo Options window in the Sample Browser's Document Editor QuickStart for Ribbon. This window uses a UserControl in the Sample Browser's Ribbon Common folder called CustomizeQat. The CustomizeQat control contains all the functionality needed to get the QAT customization functionality working like in the screenshot below.

A sample Options window that has complete QAT customization capabilities

The full source for the window and UserControl are in the Sample Browser project. We encourage you to copy the CustomizeQat control to your own project and to modify it as necessary. But it provides out-of-the-box functionality like what you find in Office.

Using the CustomizeQat UserControl in Your Application

To use the CustomizeQat control in your own application, simply copy it to your project. Then add it to your project's Options window. When the Options window is created, be sure to set its Ribbon property to an instance of the Ribbon to customize. This is how the control knows to bind itself to a Ribbon.

When your Options window's OK button is pressed, you must call CustomizeQat.Save to persist the changes into the Ribbon's QAT. If the Options window was closed without the OK button being pressed, you must call CustomizeQat.Cancel to properly dispose any ununsed clones that were created while the customization was occurring.

CustomizeQat UserControl Implementation Info

Although you generally won't need to change the contents of the CustomizeQat control, here is a quick overview of how it works in case you do.

First, a static method on the RibbonControlCustomizationCategory class provides a default list of RibbonControlCustomizationCategory objects. There is one category for the application menu and one for each the tabs that are defined on the Ribbon. This list is bound to the Choose commands from combobox in the screenshot above.

When a selection is made in that combobox, the listbox below it is populated by binding it to the results of a call to RibbonControlCustomizationCategory.GetControls. This method returns a list of all the controls contained within that category's source object (application menu, tab, etc.). This is a recursively created list so even menu items on ribbon control popups will be included. The list is a collection of RibbonControlReference objects, which contain references to the source object that they represent.

The list on the right contains the items currently in the QAT. It also is bound to a list of RibbonControlReference objects that was created by a call to RibbonControlCustomizationCategory.GetQuickAccessToolBarItems.

The Add button adds a new control clone of the selected item in the available controls list to the QAT items list. The Remove button removes the selected QAT item from the list. The mover buttons on the right allow you to reorder controls in the QAT items list.

Upon a call to the CustomizeQat.Save method, the RibbonControlCustomizationCategory.SetQuickAccessToolBarItems method is executed, which updates the Ribbon's QAT with the items designated in the QAT items list.

Persisting Customized QAT Items in User Settings

The current items and their order can be persisted to an XML string via a single method call to Ribbon.SerializeQuickAccessToolBarItems. You can save this string to your user settings mechanism before your application closes.

When the user starts up the application again, get the XML string and pass it to Ribbon.DeserializeQuickAccessToolBarItems to restore the user's QAT customizations.

The DeserializeQuickAccessToolBarItems method returns a collection of Exception objects. Under normal circumstances, this collection will be empty, indicating that there were no problems when deserializing the saved data. However if a problem did occur and one or more items could not be reloaded, there will be one related Exception entry in this collection for each item that could not be reloaded. This will help you debug what the problem is while still allowing other items to be successfully loaded.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Using Custom Controls

Actipro Ribbon has been designed so that nearly any control can be used within the Ribbon itself, in ribbon menus, or in popups.

For the purposes of this topic, we will use the term "custom control" to mean any non-ribbon control. This could be a UserControl, any native WPF control, or any control from a third-party.

A custom UserControl used as the content for a PopupButton's popup

This topic contains these sections:

  • Custom Controls in the Ribbon
  • Custom Controls in Menus
  • Custom Controls in Popups

Custom Controls in the Ribbon

Custom controls can be used in the ribbon simply by including them directly within a Group or by using them within a RowPanel or StackPanel.

A Ribbon that contains a MediaElement control

Note Note
If the custom control is used within a RowPanel or StackPanel, it must be able to support a small height that is normally associated with standard Button or ComboBox heights.

Here is some XAML code showing how the screenshot above was created.

XAML
Copy
​<ribbon:Group Label="Preview">
    <Border BorderBrush="#000000" BorderThickness="1" Background="#FFFFFF" VerticalAlignment="Center">
        <MediaElement Name="mediaElement" Source="Resources\Videos\Numbers.wmv"
            Width="80" Height="60" LoadedBehavior="Manual" UnloadedBehavior="Stop" />
    </Border>
</ribbon:Group>

Custom Controls in Menus

Custom controls can be used in the Menu control.

A Menu containing the DateTimePicker control, which is a non-ribbon control defined in the Shared Library

When they are added to a Menu, there are some special attached properties that need to be set to properly lay out the control in relation to the other menu items and give the control an optional external label and image.

See the Menu topic for details on how to do this.

Here is some XAML code showing how the screenshot above was created.

XAML
Copy
​<ribbon:PopupButton Label="DateTime on Menu" ImageSourceLarge="/Resources/Images/QuickStart32.png">
    <ribbon:Menu>
        <ribbon:Separator Label="DateTimePicker on Menu" />
        <shared:DateTimePicker Value="12/31/2007"
            ribbon:RibbonControlService.Label="Non-Editable"
            TodayButtonVisible="True" ClearButtonVisible="True" WeekNumbersVisible="True"
            ValueConverterParameter="{x:Static shared:DateTimeToStringPattern.LongDate}" />
        <shared:DateTimePicker Value="{x:Static system:DateTime.Now}" IsEditable="True"
            ribbon:RibbonControlService.Label="Editable" />
    </ribbon:Menu>
</ribbon:PopupButton>

Custom Controls in Popups

The use of custom controls in popups is fully supported. Popups are used by the PopupButton, RibbonGallery, and SplitButton controls.

To use a custom control in a popup, set it to the popup anchor's PopupContent property. In the case of PopupButton and SplitButton, this can be done in XAML by inserting the popup content as a child direcly within the PopupButton and SplitButton tags.

Here is some XAML code showing the use of a custom color picker UserControl within a PopupButton. This code is used in the Document Editor demo and is displayed in the screenshot above.

XAML
Copy
​<ribbon:PopupButton ImageSourceLarge="/Resources/Images/ColorPicker32.png" Label="Custom Theme"
    KeyTipAccessText="C" ScreenTipDescription="Select a completely custom theme color using a color picker.">
    <sample:ColorPicker />
</ribbon:PopupButton>

You also can create complex layouts of popup child controls, meaning that you can support a mix of one or more custom controls with other controls like Menu controls. See the Working with Popups topic for more information on all the things that are possible with popups.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Customizing Context Menus

Ribbon allows for the dynamic creation/updating of context menus as well as the same for the QuickAccessToolBar Customize button's menu.

This topic contains these sections:

  • Customizing a Context Menu
  • Customizing the QuickAccessToolBar Customize Button's Menu

Customizing a Context Menu

Actipro Ribbon auto-generates context menus for most of the controls in it. The auto-generated menu will be created if the control doesn't already have a ContextMenu assigned to it, and contains items for toggling the visibility of the Quick Access ToolBar (QAT), minimizing the ribbon, etc.

However many times it is useful to add custom menu items to a specific control, or a certain type of controls. You can achieve this programmatically by intercepting the ContextMenuOpening event for one or more controls and dynamically updating the ContextMenu that for those controls.

Here is some code showing how to create a class event handler to process the ContextMenuOpening event for each UIElement.

C#
VB
Copy
​EventManager.RegisterClassHandler(typeof(UIElement), FrameworkElement.ContextMenuOpeningEvent, new ContextMenuEventHandler(OnContextMenuOpeningEvent));
​EventManager.RegisterClassHandler(GetType(UIElement), FrameworkElement.ContextMenuOpeningEvent, New ContextMenuEventHandler(OnContextMenuOpeningEvent))

Here is some code to handle the ContextMenuOpening event and add a custom menu item (via a AddCustomMenuItem method that you would create) to the child Menu control if one is found.

C#
VB
Copy
​private void OnContextMenuOpeningEvent(object sender, ContextMenuEventArgs e) {
    RibbonControls.Primitives.ButtonBase button = sender as RibbonControls.Primitives.ButtonBase;
    if ((button != null) && (button.ContextMenu != null) && (button.ContextMenu.Items.Count > 0)) {
        RibbonControls.Menu menu = button.ContextMenu.Items[0] as RibbonControls.Menu;
        if (menu != null)
            this.AddCustomMenuItem(menu);
    }
}
​Private Sub OnContextMenuOpeningEvent(ByVal sender As Object, ByVal e As ContextMenuEventArgs) {
    Dim button As RibbonControls.Primitives.ButtonBase = TryCast(sender, RibbonControls.Primitives.ButtonBase)
    If ((!(button Is Nothing)) And (!(button.ContextMenu Is Nothing)) && (button.ContextMenu.Items.Count > 0)) Then
        Dim menu As RibbonControls.Menu = TryCast(button.ContextMenu.Items(0), RibbonControls.Menu);
        If (!(menu Is Nothing)) Then Me.AddCustomMenuItem(menu)
    End If
End Sub

Customizing the QuickAccessToolBar Customize Button's Menu

The same sort of concept as described above works for the QuickAccessToolBar Customize button's menu.

However the click of that button shows a popup instead of a context menu. Therefore, you should create a class handler for the PopupControlService.PopupOpeningEvent event. In your event handler, look to see if the sender is a QuickAccessToolBarCustomizeButton and if it is, you can customize its PopupContent.

In the case of the Customize button, the popup content will be a Menu with its default items already populated.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Standalone Control Usage

Actipro has created the ribbon controls with WPF control design best practices in mind and so that they can be used outside of the ribbon, in other parts of your application as well.

For instance, perhaps you want to use a ribbon PopupButton on a Window that doesn't have a Ribbon on it. No problem! You can even set the button's properties like VariantSize to get it to display in the desired variant.

This topic contains these sections:

  • Ribbon Controls Designated for Standalone Use
  • Samples

Ribbon Controls Designated for Standalone Use

These ribbon controls are designated as being appropriate for standalone use if you need them:

  • Button
  • CheckBox
  • ComboBox
  • ContextMenu
  • FontFamilyComboBox
  • FontSizeComboBox
  • Group
  • GroupPresenter
  • Menu
  • PopupButton
  • PopupGallery
  • RadioButton
  • RibbonGallery
  • Separator
  • SplitButton
  • TextBox

All of them may be restyled however you need.

Samples

A QuickStart in the sample project shows the standalone usage of the ribbon controls.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RibbonWindow

Actipro Ribbon includes a RibbonWindow class, which is an implementation of the Window class that provides a custom window user interface much like that found in Office.

Although it is always recommended that a Ribbon control implementation be hosted within a RibbonWindow, a RibbonWindow can be used without a Ribbon control at all.

A simple RibbonWindow

Note that in the screenshot above, a simple RichTextBox is hosted within a RibbonWindow and there is no Ribbon being used.

This topic contains these sections:

  • Setting the RibbonWindow Title
  • Enabling Aero Glass
  • Full-Screen Mode (IsTitleBarVisible)
  • Maximize/Minimize Button Visibility
  • Focus Moves on Window Deactivation

Setting the RibbonWindow Title

The title in the RibbonWindow is drawn in two parts, the application name and the document name. Each is drawn using a separate color, which provides some distinction between the two.

The ApplicationName property should be set to the name of the application.

The DocumentName property should be set to the name of the currently open document. If there is no document open, leave this property null.

When both properties are specified, a hyphen will be inserted between the two.

Enabling Aero Glass

The RibbonWindow.IsGlassEnabled property defaults to a null value, which means enable Aero glass on Windows 7 and Vista but not on other operating system versions like Windows 8 (which tends to use chromed windows instead) or XP. It can be set to true or false values directly to force glass support on or off respectively on any Windows system, Vista or later.

Full-Screen Mode (IsTitleBarVisible)

Say you have an application like PowerPoint where there normally is a Ribbon at the top of it however during a slide preview mode, you want to maximize the window, hide the ribbon, and show the content area in full-screen mode.

Normally, setting the Window.WindowStyle property to None would hide a title bar and allow full-screen mode. However, RibbonWindow is often forced to be in None style to achieve its custom UI. Therefore setting this property doesn't hide the title bar area like it would in a normal Window.

To achieve a full-screen mode, set the RibbonWindow.IsTitleBarVisible property to false. This should only be done when the window is maximized and any child Ribbon is collapsed (hidden).

Maximize/Minimize Button Visibility

The visibility of the RibbonWindow's maximize and minimize buttons can be customized using the IsMaximizeButtonVisible and IsMinimizeButtonVisible properties, respectively.

If Aero glass is enabled and active, then the maximize and minimize buttons will only be removed from the title bar when both IsMaximizeButtonVisible and IsMinimizeButtonVisible are set to false. This is the default behavior when using the system window theme.

Focus Moves on Window Deactivation

By default, if a control in the ribbon has focus when the window is deactivated, focus will be moved out of the ribbon and back into the main content area of the window. The IsKeyboardFocusBlurredOnWindowDeactivation property can be set to false to prevent this default behavior.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Ribbon has been designed from the ground up to mimic Office themes, yet allow further customization, and make complete use of WPF styles.

Ribbon includes all three built-in Office themes, all Windows system themes, allows you to generate themes of your own with one line of code, and even allows you to examine or modify any of the hundreds of colors used in each color scheme.

Ribbon comes packaged with a number of styles that may be reused in your own controls (such as listboxes) so that you can keep a consistent user interface throughout your application.

Application Button Content

Ribbon support several different layout and content styles for the application button, including the Scenic ribbon style added in Windows 7 and Office 2010.

See the Application Button Content topic for more information.

Themes

Ribbon uses hundreds of brushes to define the themes used throughout the ribbon user interface and comes packaged with nine default themes. Brushes may be reused in your application to help you maintain a consistent user interface.

See the Themes topic for more information.

StatusBar Styles

Actipro Ribbon includes custom styles that can be applied to a standard WPF StatusBar control and its items and separators.

See the StatusBar Styles topic for more information.

ScrollBar Styles

Actipro Ribbon includes custom styles that can be applied to standard WPF ScrollViewer and ScrollBar controls.

See the ScrollBar Styles topic for more information.

Vista Glass Support

Vista's Aero glass effects are fully supported by Ribbon. Actipro Ribbon has been designed to mimic how Office looks in Vista.

See the Vista Glass Support topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Application Button Content

Ribbon support several different layout and content styles for the application button, including the Scenic ribbon style added in Windows 7 and Office 2010.

The various application button layout/content style options

This topic contains these sections:

  • Scenic Style with Text Content
  • Scenic Style with Image Content
  • Orb Style with Image Content

Scenic Style with Text Content

By default the application button in ribbon will display in Scenic style with the text File as its content. This is a string resource and can be customized by altering the SRName.UIApplicationButtonLabelText string resource before the ribbon is created. The leftmost ribbon in the screenshot shows the default File text content.

Scenic Style with Image Content

Ribbon includes a standard image that can be easily set to the Scenic application button in place of the default File text. To use the built-in application button image, set the Ribbon.ApplicationButtonImageSource property to:

ApplicationButtonImageSource="/ActiproSoftware.Ribbon.Wpf;component/Products/Ribbon/Images/ApplicationButtonDefault16.png"

You could use a 16x16 company logo image source instead if you wish. The center ribbon in the screenshot shows the built-in image that can be used in a Scenic ribbon.

Orb Style with Image Content

By setting the Ribbon.UseScenicLayout property to false, the application button will render using the Office 2007-like Orb style. Set a 32x32 image to the Ribbon.ApplicationButtonImageSource property when using this Orb style.

The Orb style also rearranges the positioning of tabs, the QAT, and hides a RibbonWindow system menu icon while the ribbon is not collapsed. These layout details match how Office 2007 operates.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Themes

This product includes multiple built-in themes for all Office themes and Windows system themes. It is fully extensible so that other product themes can be custom developed. Themes can be tinted towards any color or set of colors, and brush resources from them may be reused.

Note Note
Be sure to read the Actipro Themes product documentation too since that explains in great detail how the themes management works with Actipro controls.

This topic contains these sections:

  • Built-In Themes
  • Theme Catalog
  • Tinting Themes

Built-In Themes

Ribbon includes built-in themes for Office blue/black/silver, Aero, Luna blue/olive/silver, Royale, classic, and high-contrast that match the real Office themes.

Several built-in Office-like Ribbon themes with stunning glass transparency effects

Themes for system themes are included as well, such as Aero, the three Luna variations, Royale, Classic, and high-contrast.

Several built-in Ribbon system-based themes

Theme Catalog

The RibbonThemeCatalog is used to provide dynamic theme-switching to this product, and is automatically registered when WPF loads the system themes from the associated assembly.

To explicitly load and register the theme catalog, call the Register staic method on RibbonThemeCatalogRegistrar.

Tinting Themes

Any theme can be completely or partially tinted towards a color or set of colors. The general Tinting topic explains how to perform tinting in detail.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


StatusBar Styles

Actipro Ribbon includes custom styles that can be applied to a standard WPF StatusBar control and its items and separators.

A StatusBar at the bottom of a RibbonWindow using the built-in style

StatusBar-oriented templates for the ribbon Button and ButtonGroup controls may be applied by setting their Context properties to StatusBarItem.

Special styles for native WPF Slider controls in the StatusBar along with styles for the native WPF RepeatButton controls next to them are available as well.

Adding a StatusBar to a RibbonWindow

A StatusBar is a special control in relation to a RibbonWindow since it extends over part of the non-client area of the window and can also provide a resize grip. Therefore it doesn't really fit in the client area, or content, of the window itself.

The RibbonWindow class implements a special StatusBar property to which a StatusBar control may be assigned. By doing this, the window arranges the StatusBar over the non-client area at the bottom of the window.

This code sample is for the StatusBar displayed above and shows how to assign a StatusBar control to the RibbonWindow.StatusBar property.

XAML
Copy
​<ribbon:RibbonWindow>
    <ribbon:RibbonWindow.StatusBar>
        <!-- StatusBar Control (Is the normal WPF control but with styling) -->
        <StatusBar FocusManager.IsFocusScope="True">
            <StatusBar.Resources>
                <shared:PercentageConverter x:Key="PercentageConverter" />
            </StatusBar.Resources>
            <StatusBar.ItemsPanel>
                <ItemsPanelTemplate>
                    <Grid>
                        <Grid.ColumnDefinitions>
                            <ColumnDefinition Width="Auto" />
                            <ColumnDefinition Width="Auto" />
                            <ColumnDefinition Width="Auto" />
                            <ColumnDefinition Width="Auto" />
                            <ColumnDefinition Width="*" />
                            <ColumnDefinition Width="Auto" />
                            <ColumnDefinition Width="Auto" />
                        </Grid.ColumnDefinitions>
                    </Grid>
                </ItemsPanelTemplate>
            </StatusBar.ItemsPanel>

            <StatusBarItem Grid.Column="0" Padding="3,0,0,0">
                <ribbon:Button Context="StatusBarItem" Padding="6,0,6,0" Label="Page: 1 of 1"
                   ScreenTipHeader="Page number in document. Click to open the Go To dialog box." />
            </StatusBarItem>
            <Separator Grid.Column="1" />
            <StatusBarItem Grid.Column="2" Padding="0">
                <ribbon:Button Context="StatusBarItem" Padding="6,0,6,0" Label="Words: Not available"
                   ScreenTipHeader="Number of words in document. Click to open Word Count dialog box."
                   />
            </StatusBarItem>
            <Separator Grid.Column="3" />
            <StatusBarItem Grid.Column="4" />
            <Separator Grid.Column="5" Style="{StaticResource {x:Static ribbon:RibbonStyles.StatusBarSeparatorAlternateKey}}" />
            <StatusBarItem Grid.Column="6" Padding="4,0,4,0" Style="{StaticResource {x:Static ribbon:RibbonStyles.StatusBarItemAlternateKey}}">
                <StackPanel Orientation="Horizontal">
                    <ribbon:ButtonGroup Context="StatusBarItem">
                        <ribbon:Button ImageSourceSmall="/Resources/Images/ViewPrintLayout16.png" ScreenTipHeader="Print Layout" />
                        <ribbon:Button ImageSourceSmall="/Resources/Images/ViewFullScreenReading16.png" ScreenTipHeader="Full Screen Reading" />
                        <ribbon:Button ImageSourceSmall="/Resources/Images/ViewWebLayout16.png" ScreenTipHeader="Web Layout" />
                        <ribbon:Button ImageSourceSmall="/Resources/Images/ViewOutline16.png" ScreenTipHeader="Outline" />
                        <ribbon:Button ImageSourceSmall="/Resources/Images/ViewDraft16.png" ScreenTipHeader="Draft" />
                    </ribbon:ButtonGroup>

                    <ribbon:Button Context="StatusBarItem" Margin="0,1,0,1"  Padding="6,0,6,0"
                        ScreenTipHeader="Zoom level: Click to open the Zoom dialog box."
                        Label="{Binding ElementName=scaleSlider, Path=Value, Converter={StaticResource PercentageConverter}, ConverterParameter=%}"
                        />

                    <RepeatButton Margin="1,0,1,0" CommandTarget="{Binding ElementName=scaleSlider}" ribbon:ScreenTipService.ScreenTipHeader="Zoom Out"
                        Style="{StaticResource {x:Static ribbon:RibbonStyles.StatusBarSliderDecreaseButtonKey}}"/>
                    <Slider x:Name="scaleSlider" Width="100" Value="1.0" Minimum="0.5" Maximum="2.0" LargeChange="0.5" SmallChange="0.1" VerticalAlignment="Center"
                        IsSnapToTickEnabled="True" TickFrequency="0.1" ribbon:ScreenTipService.ScreenTipHeader="Zoom" />
                    <RepeatButton Margin="1,0,1,0" CommandTarget="{Binding ElementName=scaleSlider}" ribbon:ScreenTipService.ScreenTipHeader="Zoom In"
                        Style="{StaticResource {x:Static ribbon:RibbonStyles.StatusBarSliderIncreaseButtonKey}}"/>
                </StackPanel>
            </StatusBarItem>
        </StatusBar>
    </ribbon:RibbonWindow.StatusBar>
</ribbon:RibbonWindow>

Adding a StatusBar ResizeGrip

If you have a StatusBar assigned to a RibbonWindow and the window's ResizeMode property has a value of CanResizeWithGrip, a resize grip will automatically appear at the bottom right side of the StatusBar.

Normal and Alternate Item Styles

Per the Microsoft Ribbon UI Design Guidelines, a status bar may contain two sides. The left side is used to display notifications and the right side is used to host view-changing controls for the document.

By default, StatusBarItem controls added to a styled StatusBar will use the notification (left) style. The default Separator renders as semi-transparent.

If you wish to add view-changing controls, you must set alternate styles to the appropriate StatusBarItem and Separator objects. The alternate style for a StatusBarItem renders in a darker background color and the alternate style for a Separator renders more opaque than the normal style.

This code shows how to apply the alternate style to a Separator:

XAML
Copy
​<Separator Style="{StaticResource {x:Static ribbon:RibbonStyles.StatusBarSeparatorAlternateKey}}" />

This code shows how to apply the alternate style to a StatusBarItem:

XAML
Copy
​<StatusBarItem Padding="4,0,4,0" Style="{StaticResource {x:Static ribbon:RibbonStyles.StatusBarItemAlternateKey}}">
</StatusBarItem>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ScrollBar Styles

Actipro Ribbon includes two custom styles that can be applied to standard WPF ScrollViewer and ScrollBar controls.

A TextBox with the mouse over the horizontal ScrollBar, showing the application of the alternate ScrollViewer style

A ComboBox showing the application of the default ScrollViewer style

Styling a ScrollViewer

The default ScrollViewer style applies the default light style to the contained ScrollBar controls. Controls like ListBox and ComboBox usually use this style. The ScrollViewer style also styles the little block on the lower right corner, if visible, where the horizontal and vertical ScrollBar controls meet.

The alternate ScrollViewer style is generally used on the main document control of a window. It is darker and emphasizes the control.

This code sample shows how to apply the alternate ScrollViewer style to a RichTextBox.

XAML
Copy
​<RichTextBox>
    <RichTextBox.Resources>
        <!-- Make the scroll viewer in the RichTextBox use the custom scrollbar style -->
        <Style TargetType="ScrollViewer" BasedOn="{StaticResource {x:Static ribbon:RibbonStyles.ScrollViewerAlternateKey}}" />
    </RichTextBox.Resources>
</RichTextBox>

To assign the default lighter style instead, simply change that code to reference ScrollViewerKey instead of ScrollViewerAlternateKey.

Note Note
Use the technique in the sample code above to place a style reference to the normal light ScrollViewer style in your application's resources. This will apply the style by default to all controls in your application.

Styling a ScrollBar

The ScrollBar styles work in the same way as the ScrollViewer styles. There is a normal lighter style and an alternate darker style.

The ScrollBar styles should only be used in cases where you have a ScrollBar but no ScrollViewer. A standalone ScrollBar would be a prime example of this situation.

This code sample shows how to apply the light ScrollBar style to a standalone ScrollBar.

XAML
Copy
​<ScrollBar Style="{DynamicResource {x:Static ribbon:RibbonStyles.ScrollBarKey}}" />

This code sample shows how to apply the alternate dark ScrollBar style to a standalone ScrollBar.

XAML
Copy
​<ScrollBar Style="{DynamicResource {x:Static ribbon:RibbonStyles.ScrollBarAlternateKey}}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Vista Glass Support

Windows Vista introduced a great new style of window visual effects called Aero glass. These effects provide a semi-transparent non-client border around a window that looks like glass.

Glass Is Supported By Ribbon

Yes, Vista's glass effects are fully supported by Ribbon. Actipro Ribbon has been designed to mimic how Office looks in Vista, including title bar text glow effects, transparency on the Quick Access Toolbar, etc.

Ribbon in Windows Vista with Aero glass effects active

Enabling Glass Effects

By default, glass effects are enabled meaning that if you are using a RibbonWindow on Vista, you will see the glass around the outside of the window's client area. Note that glass must also be enabled in Vista's display settings for you to see the effects.

You can optionally disable glass effects for a RibbonWindow if you would like. Simply set the RibbonWindow.IsGlassEnabled property to false.

You can even toggle that property on and off at run-time and the window will adjust accordingly. The sample project's Document Editor demo shows this feature.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Monochrome Images

Several Actipro themes require the use of white monochrome images in specific portions of the ribbon user interface. Ribbon has special logic that will automatically convert BitmapSource and DrawingImage images to a pure white monochrome equivalent for proper display in these scenarios. This allows you to use a single image set for your entire UI while still supporting modern UI.

This topic contains these sections:

  • QuickAccessToolBar and Tab Panel Buttons
  • Status Bar Buttons
  • Optimal Image Design
  • Preventing Portions of a DrawingImage from Converting

QuickAccessToolBar and Tab Panel Buttons

Ribbon in the MetroLightRoyal theme

When one of the Metro Light accent color themes is used, such as MetroLightRoyal above, any button images in the QAT or in the tab panel must be switched over to monochrome variations. Ribbon has logic in it to automatically perform this conversion on a ribbon button with a supplied normal image.

See the Themes' Getting Started page for a complete list of Metro Light accent color themes.

Status Bar Buttons

Numerous Metro themes feature a high contrast status bar background, such as a bright blue color. In these themes, button images need to be switched over to monochrome variations. Ribbon has logic in it to automatically perform this conversion on a ribbon button with a supplied normal image.

Optimal Image Design

The algorithm that the conversion-to-monochrome logic uses is based on the lightness of each pixel. Dark and medium lightness pixels will be converted to white, while light pixels will be converted to transparent.

It is best to use Metro-themed images that don't contain gradients as a basis for this feature.

Note Note
Be careful of images that were already light/white to begin with, as they may end up as appearing completely transparent unless dark colors are used in the image.

Preventing Portions of a DrawingImage from Converting

In some cases, such as for a vector icon that has a portion showing a selected color, you may not wish to convert the selected color portion to monochrome. Yet you may wish for the entire rest of the image to be converted.

This can be achieved by setting the attached ImageSourceContentConverter.CanConvertToMonochrome property to false on the portion for the selected color. That will tell the converter to skip over converting colors within that portion of the image.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview
Actipro Ribbon has an enormous feature set related to layouts, globalization and accessibility.
Ribbon Resizing

Actipro Ribbon has the most powerful and flexible ribbon resizing model of any ribbon control out there. In fact it's capabilities match what Office can do!

See the Ribbon Resizing topic for more information.

Ribbon Minimization

Actipro Ribbon supports minimization, which means that the ribbon may be hidden so that only its tabs appear. In this state, more screen real estate is available to the client area of the window. By clicking a tab, the ribbon appears in a popup over the window client area and all of its controls are accessible.

See the Ribbon Minimization topic for more information.

Ribbon Collapsing

The ribbon is capable of collapsing when it becomes smaller than a threshold size. When in a collapsed state, the ribbon (including its application button and QAT) hides since there is not enough space for its interface.

See the Ribbon Collapsing topic for more information.

Screen Tips

Actipro Ribbon fully implements screen tips for controls, which are advanced variations of standard tooltips.

See the Screen Tips topic for more information.

Key Tips

Actipro Ribbon supports key tips, which are small decorations that pop up over each control indicating a key or series of keys that may be typed to access each control via the keyboard.

See the Key Tips topic for more information.

Flow Direction

Ribbon supports both left-to-right and right-to-left layouts via a simple property switch.

See the Flow Direction topic for more information.

Localization

All of the text properties found within the ribbon suite have localization attributes applied to them and any dynamically-used text in the user interface can be localized.

See the Localization topic for more information.

UI Automation

This product follows the WPF accessibility model for UI automation.

See the UI Automation topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ribbon Resizing

Actipro Ribbon has the most powerful and flexible ribbon resizing model of any ribbon control out there. In fact it's capabilities match what Office can do! To prove this, we've modeled the first two tabs of our sample application after the Home and Insert tabs found in Microsoft Word 2007.

By default, Actipro Ribbon has code built-in to dynamically resize your ribbon. However for those who want more control over what groups change how and in what order, Actipro Ribbon offers full control over those items as well.

This topic contains these sections:

  • Defining Group Size Scaling (Optional)
  • StackPanel, RowPanel, and RibbonGallery Variants
  • Case Study: Insert Tab Resizing (Comparison to Office)

Defining Group Size Scaling (Optional)

Each Group on a Tab has a collection of GroupVariant objects that control its VariantSize. The currently active group size is always indicated by the Group.VariantSize property.

The VariantSize enumeration has these values:

Value | Description
Collapsed | A collapsed size.
Small | A small size.
Medium | A medium size.
Large | A large size (the default).

Therefore, each group can have up to four different variants for how it appears within the ribbon. Considering each tab generally has multiple groups, the end result is that there are many scaling down stages for a tab that can be defined.

So how exactly does scaling work? Well, a number of layout controls such as StackPanel and RowPanel have the ability to alter their layouts based on the currently active parent group variant size. Groups start with a Large size. As the width of the ribbon decreases, they will slowly transition by default in sequence to the next smaller group size until all groups are collapsed. This sequential behavior can be overridden by using priorities as described below.

Group variant sizes are controlled via a set of GroupVariant objects. These are stored in the Group.Variants collection. The defining of group variants is completely optional because as described above, a default sequence will be used if no group variants are defined. However if you do define variants, you have total control over the order of collapsing behavior. It is how we made the Insert tab scale down the same as Word in the case study demonstration below.

Note Note
It is good application design to define a prioritized set of group variants so that the least used group controls shrink and collapse before the more-often used group controls do. For instance, Clipboard groups are most often the last thing to collapse on a tab since they are highly-used.

Each GroupVariant has two properties: Size and Priority. The Size property indicates the VariantSize that is applied when variant becomes active. The Priority property is the integer priority in which the variant takes effect in relation to other variants for the group and for other groups in the same tab. A lower priority means that the variant will be applied sooner (large controls) and a larger priority means that the variant will be applied later (small controls).

The following XAML code defined the Illustrations group in the case study demonstration below. Note that the Large size is assumed by default. The Medium size kicks in at a priority of 60 in relation to other groups on the tab. And so on for the other group variants.

XAML
Copy
​<ribbon:Group ImageSourceSmall="/Images/Picture16.png" Label="Illustrations" KeyTipAccessText="ZI">
    <ribbon:Group.Variants>
        <ribbon:GroupVariant Priority="60" Size="Medium" />
        <ribbon:GroupVariant Priority="110" Size="Small" />
        <ribbon:GroupVariant Priority="140" Size="Collapsed" />
    </ribbon:Group.Variants>
    <ribbon:Button ImageSourceLarge="/Images/Picture32.png"
        ImageSourceSmall="/Images/Picture16.png" Label="Picture" KeyTipAccessText="P" />
    <ribbon:Button ImageSourceLarge="/Images/ClipArt32.png" Label="Clip Art" KeyTipAccessText="F" />
    <ribbon:StackPanel>
        <ribbon:MenuButton ImageSourceLarge="/Images/Shapes32.png"
            ImageSourceSmall="/Images/Shapes16.png" Label="Shapes" KeyTipAccessText="SH" />
        <ribbon:Button ImageSourceLarge="/Images/SmartArt32.png"
            ImageSourceSmall="/Images/SmartArt16.png" Label="SmartArt" KeyTipAccessText="M" />
        <ribbon:Button ImageSourceLarge="/Images/Chart32.png"
            ImageSourceSmall="/Images/Chart16.png" Label="Chart" KeyTipAccessText="C" />
    </ribbon:StackPanel>
</ribbon:Group>

Note Note
The declaration of group variants is an all or nothing process. If you are going to define even one group variant, then you must define them for all groups on the same tab. Otherwise don't define any variants to use the defaults.

When using the default variants, you may set the Group.IsCollapsible property to false to ensure that it never collapses. This is useful for groups that only have one item in them such as the Table group in the case study demonstration below.

StackPanel, RowPanel, and RibbonGallery Variants

Both the StackPanel and RowPanel layout controls, along with the RibbonGallery (in-ribbon gallery) control are able to alter their layouts based on the active group variant.

StackPanel

By default, a StackPanel will start by displaying its items horizontally using their tall variants when the parent group's VariantSize is Large. As the parent group's VariantSize changes to Medium, the panel changes its items to use a Medium variant size and stacks them vertically. When the parent group's VariantSize becomes Small, the panel changes its items to use a Small variant size (usually removes labels) and keeps them stacked vertically.

See the StackPanel topic for more details on the default variant behavior and how to change it however you like. For instance, you can tell the panel to always show items in the vertical stack.

RowPanel

RowPanel controls lay out their child controls in two or three rows. They automatically determine where to wrap items to a new row to obtain the minimal total width necessary for child item display. You can define distinct orders in which child controls appear in both two and three row variants.

See the RowPanel topic for more details on how to define variant behavior.

RibbonGallery

The RibbonGallery control will by default collapse to a popup button when the parent group's VariantSize is Small. It will expand to show a range of items depending on space when the parent group's VariantSize is Medium. Finally, when the parent group's VariantSize is Large, it will expand to fill all remaining space in the tab. All of this behavior is completely configurable.

See the RibbonGallery topic for more details on how to define variant behavior.

Case Study: Insert Tab Resizing (Comparison to Office)

The next series of screenshots show our sample application's Insert tab as the width of the ribbon decreases. We encourage you to compare this to the series of screenshots in the Microsoft Ribbon UI Design Guidelines document under its "Defining Group Combinations for Ribbon Resizing" section. You won't see a difference between that sample (which is Word's Insert tab) and ours because Actipro Ribbon's resizing model can handle any set of prioritized scaling operations you throw at it.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ribbon Minimization

Actipro Ribbon supports minimization, which means that the ribbon may be hidden so that only its tabs appear. In this state, more screen real estate is available to the client area of the window. By clicking a tab, the ribbon appears in a popup over the window client area and all of its controls are accessible.

The ribbon in a minimized state... note that only the tabs are visible

After clicking a tab, a ribbon popup appears over the window client area

Ways to Minimize the Ribbon

There are four ways the end user can toggle minimization of the ribbon:

  • Double-clicking the selected tab
  • Choosing Minimize the Ribbon from a context menu
  • Pressing Ctrl+F1
  • Adding a ToggleMinimizationButton control to the ribbon's TabPanelItems collection and clicking it

Note Note
See the Button topic for more information on the ToggleMinimizationButton control.

Related Members

The Ribbon class defines several members that relate to ribbon minimization.

Member | Description
IsMinimizable Property | Gets or sets whether the ribbon is capable of being minimized by the end user. If this property is true, UI will be added to context menus allowing for the toggling of the IsMinimized property. Additionally, double-clicking a Tab will toggle the IsMinimized property.
IsMinimized Property | Gets or sets whether the ribbon is currently minimized. When minimized, the ribbon's groups are not visible until the end user clicks on a tab, at which point they display in a popup. This saves screen real estate.
IsMinimizedChanged Event | Occurs when the IsMinimized property value has changed.
IsMinimizedPopupOpen Property | Gets whether the ribbon is currently minimized and its minimized popup is open.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ribbon Collapsing

The ribbon is capable of collapsing when it becomes smaller than a threshold size. When in a collapsed state, the ribbon (including its application button and QAT) hides since there is not enough space for its interface.

The ribbon in an expanded normal state

The ribbon in a collapsed state

The automatic collapsing behavior can be disabled and the threshold size can be configured.

Related Members

The Ribbon defines several members that relate to collapsing.

Member | Description
CollapseThresholdSize Property | Gets or sets the threshold Size that triggers a ribbon collapse if the ribbon is sized smaller than the threshold. The default threshold size is 300, 250.
IsCollapsed Property | Gets or sets whether the ribbon is currently collapsed. This property should not need to be called by your code under normal circumstances.
IsCollapsedChanged Event | Occurs when the IsCollapsed property value has changed.
IsCollapsible Property | Gets or sets whether the ribbon collapses when it becomes smaller than a minimum threshold width/height as specified by the CollapseThresholdSize property.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Screen Tips

Actipro Ribbon fully implements screen tips for controls, which are advanced variations of standard tooltips. They not only display a normal tooltip header but also can contain shortcut keys, an image, and a longer description explaining more about what the control does or its current state.

Several varieties of screen tips

Screen tips are displayed in three ways depending on the content that is available. If only a label/header is availble, the screen tip will display as a standard tooltip. If an image is available (generally representing a thumbnail screenshot of a dialog or preview of the action that takes place when the control's command is executed), a larger screen tip is used. If a description of the control is available it also uses a larger style screen tip, although it will not be as wide as if an image is used. Note that images and descriptions can both be used in a screen tip at the same time. Large screen tips display the label/tooltip header in bold.

This topic contains these sections:

  • General Implementation
  • ScreenTipService
  • Use Screen Tips on Anything
  • Dynamically Generating Screen Tip Content
  • Context Sensitive Help Implementation

General Implementation

All ribbon controls have several properties for configuring screen tips: ScreenTipHeader, ScreenTipImageSource, ScreenTipDescription, ScreenTipFooter, and ScreenTipHelpUri.

These properties are all implementations of the ScreenTipService attached properties described in greater detail in the ScreenTipService section below.

This code sample shows how to set a screen tip description for a Button. When the screen tip is displayed, the button's Label will be used as the bold header (since no ScreenTipHeader was specified) and the description will appear under the header.

XAML
Copy
​<ribbon:Button Label="Bold" ScreenTipDescription="Toggles the bold state of the text." />

Ribbon control also have the ScreenTipOpening and ScreenTipClosing events that can be used to programmatically generate screen tip content.

ScreenTipService

The ScreenTipService provides numerous attached properties and events for working with screen tips and manages screen tip display and behavior.

It has these important properties:

Member | Description
AllowScreenTipsOnContextMenus Property | Gets or sets whether screen tips are allowed to display on context menus. The default value is false. If this property is set to false, no screen tips will appear on context menu items.
AllowScreenTipsOnInactiveWindows Property | Gets or sets whether screen tips are allowed to display on inactive windows. The default value is false. If this property is set to false, no screen tips will appear when the containing window is inactive.
CurrentScreenTip Property | Gets the ScreenTip that is currently visible, if any.
ScreenTipClosingEvent Event | Fires after a screen tip is closed.
ScreenTipDescriptionProperty Attached Property | When specified, displays its content under the label/header in the screen tip. It can provide an extended description of the control for which the screen tip is displayed. It is of type object meaning that you can specify plain text or can insert any type of control.
ScreenTipFooterProperty Attached Property | When specified, displays its content under a horizontal separator at the bottom of the screen tip. Footers are most often used to provide extended state information about a control. It is of type object meaning that you can specify plain text or can insert any type of control.
ScreenTipHeaderProperty Attached Property | When specified, displays its content in bold above the rest of the screen tip content. It is of type object meaning that you can specify plain text or can insert any type of control.
ScreenTipHelpUriProperty Attached Property | When specified, adds a "Press F1 for help" message at the bottom of the screen tip. This indicates to the end user that contextual help is available. When handling the ApplicationCommands.Help command, you can look at the ScreenTipService.CurrentScreenTip property to see which screen tip, if any is currently displayed and jump to its help Uri.
ScreenTipImageSourceProperty Attached Property | When specified, displays an image on the left side of the screen tip. The image can be used to display a thumnail of a dialog that will be launched from the control, or can be used to indicate the type of action that will occur when the control's command is executed.
ScreenTipIsEnabledProperty Attached Property | Determines whether screen tips are enabled for the control. When set to false, no screen tip will be displayed for the control.
ScreenTipOpeningEvent Event | Fires before the screen tip is displayed, allowing you to customize the screen tip properties.

Note Note
When no screen tip header is specified and the screen tip's owner control has a Label property, it will be used as the header.

Most of the screen tip content properties are of type object, allowing you to pass a string of text or any control. This allows for great flexibility in what you can display on the screen tip.

Use Screen Tips on Anything

Yes that's right. Our implementation of screen tips is so flexible that you can even assign them to non-ribbon controls!

Simply assign the appropriate ScreenTipService attached properties to the controls that should have screen tips.

This code sample shows how to set a screen tip header and description for a native WPF Button:

XAML
Copy
​<Button Text="Regular Button"
    ribbon:ScreenTipService.ScreenTipHeader="Regular Button."
    ribbon:ScreenTipService.ScreenTipDescription="This is a native WPF Button."/>

Dynamically Generating Screen Tip Content

Screen tip content can be dynamically generated. This allows you to modify the screen tip data on demand to best reflect the current state of the control.

To do this, process the ScreenTipOpening event for the desired control. That event fires before a screen tip is about to display for a control. In the event handler, you may change any screen tip properties before they are rendered to the end user.

Note that at least one screentip-related attached property, such as ScreenTipService.ScreenTipHeader must be set on the desired target object for the event to fire.

Context Sensitive Help Implementation

Whenever the ScreenTipHelpUri property is set to a non-null value, a help icon and text will appear near the bottom of the screen tip that indicates that the user may press F1 to access context sensitive help for that control.

To handle this, simply process an Execute handler for the standard ApplicationCommands.Help command. Then in that code, check the CurrentScreenTip property to see if there is a ScreenTip currently visible. If there is, and a help URI is specified, show the appropriate topic in your help file.

This is demonstrated in the screen tip QuickStart in the sample project.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Key Tips

Actipro Ribbon supports key tips, which are small decorations that pop up over each control indicating a key or series of keys that may be typed to access each control via the keyboard.

Key tips displayed for the Home tab

This topic contains these sections:

  • Key Tip Access Text
  • Navigating Key Tip Scopes
  • General Implementation
  • KeyTipService
  • Key Tip Mode Shortcuts

Key Tip Access Text

Key tip access text must be defined for each control that is used throughout the ribbon, generally via a KeyTipAccessText property. By doing so, the end user doesn't require a mouse to access functionality. Key tips also allow for very fast execution of common commands via 2-3 keystrokes.

So what is key tip access text? It is generally a one or two character string that indicates text that can be typed to access the control when its parent key tip scope is active. For instance, on the Home tab in the screenshot above, the current key tip scope is the Home tab. It is currently displaying the key tips of all controls that are accessible via key tips. Actually, controls that are hidden by collapsed groups are available for access at this point too. Note that the Paste item has a key tip access text of V and the font family combobox has a key tip access text of FF.

Navigating Key Tip Scopes

Pressing and releasing either the Alt or F10 keys will activate key tip mode. This initially places the key tip scope on the ribbon itself, allowing access to the application menu, quick access toolbar items, tabs, or tab panel items. Note that when not in key tip mode, you can also jump right to a tab's key tip scope by pressing Alt and its key tip access text. For instance, to jump directly to the Home tab's key tip scope, you can press Alt+H.

The default key tip access text for the application button (in the upper-left of the ribbon) is F. It can be set via the ApplicationMenu.KeyTipAccessText property. When the application menu becomes the active key tip scope, you can access its menu items or its footer buttons.

When a Tab becomes the active key tip scope, you can access all of its child controls. Collapsed groups can be displayed by typing the group's key tip access text. An interesting note is that controls hidden in collapsed groups can be directly accessed from the tab key tip scope, even though they are not currently visible. By typing a group's dialog launcher key tip access text, you can access the groups dialog launcher.

When a control with a popup becomes the active key tip scope, you can access any of its items.

To return to any parent key tip scope, press the Esc key. Once back at the root ribbon key tip scope, presss the Esc key to quit key tip mode.

Pressing any non-letter/digit key or clicking the mouse will also quit key tip mode.

General Implementation

All ribbon controls have a KeyTipAccessText property that sets the key tip access text for the control. So for most controls, setting up key tip access for them is as simple as setting a unique value for that property.

This code sample shows how to assign key tip access text for a Button.

XAML
Copy
​<ribbon:Button KeyTipAccessText="P" Command="ApplicationCommands.Paste" />

All ribbon controls have a OnKeyTipAccessed method that is called when the key tip for the control is typed. This method is implemented in each control to execute certain functionality upon activation, such as clicking a button, etc.

KeyTipService

The KeyTipService provides numerous attached properties for working with key tips and manages key tip display and behavior.

It has these important properties:

Member | Description
CustomKeyTipPlacementCallbackProperty Attached Property | Gets or sets an optional delegate that can be called to position key tips differently than the default location.
IsKeyTipScopeProperty Attached Property | Gets or sets whether the element to which it is applied is a key tip scope. When an element is a key tip scope, upon navigating to it, it will show key tips for all its children. Tabs are a good example of a control that is a key tip scope.
KeyTipAccessTextProperty Attached Property | Gets or sets the key tip access text for the element to which it is applied. All ribbon controls that support key tips wrap this attached property with a KeyTipAccessText property.

Key Tip Mode Shortcuts

By default, pressing an Alt or F10 key will toggle key tip mode on or off. Sometimes keys like F10 may be assigned as keyboard shortcuts for other features in an application. In this case, it is useful to be able to prevent the key tip service from watching for F10.

The Ribbon.KeyTipModeShortcuts property can be set to a flags KeyTipModeShortcuts value indicating which keys can toggle key tip mode.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Flow Direction

Ribbon supports both left-to-right and right-to-left layouts via a simple property switch.

By default, Ribbon will use the flow direction designated by the system.

What is Flow Direction?

The flow direction of content typically corresponds to the innate flow direction of the language being represented. English, German, and Russian provide examples of languages that naturally flow from left-to-right. Hebrew and Arabic provide examples of languages that naturally flow from right-to-left.

When a right-to-left flow direction is applied to a user interface control, all contained content is essentially "flipped" over to align to the opposite side as displayed below:

Ribbon switching from left-to-right to right-to-left flow direction

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Localization

All user interface text properties have the Localizability attribute applied to them, and all strings that are displayed in the user interface can be customized and localized.

This topic contains these sections:

  • Localizable Text Properties
  • Customizing String Resources

Localizable Text Properties

The following text properties are flagged as localizable via the Localizability attribute:

  • ButtonBase.MenuItemDescription
  • ComboBoxBase.Hint
  • ComboBoxBase.KeyTipAccessText
  • ComboBoxBase.Label
  • ComboBoxBase.ScreenTipDescription
  • ComboBoxBase.ScreenTipFooter
  • ComboBoxBase.ScreenTipHeader
  • ControlBase.KeyTipAccessText
  • ControlBase.Label
  • ControlBase.ScreenTipDescription
  • ControlBase.ScreenTipFooter
  • ControlBase.ScreenTipHeader
  • GalleryItem.ScreenTipDescription
  • GalleryItem.ScreenTipFooter
  • GalleryItem.ScreenTipHeader
  • Group.DialogLauncherKeyTipAccessText
  • ItemsControlBase.KeyTipAccessText
  • ItemsControlBase.Label
  • ItemsControlBase.ScreenTipDescription
  • ItemsControlBase.ScreenTipFooter
  • ItemsControlBase.ScreenTipHeader
  • RecentDocumentMenu.Label
  • Ribbon.ApplicationButtonLabel
  • RibbonCommand.KeyTipAccessText
  • RibbonCommand.Label
  • RibbonCommandUIProvider.KeyTipAccessText
  • RibbonCommandUIProvider.Label
  • RibbonWindow.ApplicationName
  • RibbonWindow.DocumentName
  • TextBoxBase.Hint
  • TextBoxBase.KeyTipAccessText
  • TextBoxBase.Label
  • TextBoxBase.ScreenTipDescription
  • TextBoxBase.ScreenTipFooter
  • TextBoxBase.ScreenTipHeader

Customizing String Resources

All strings that are displayed in the user interface are available from static methods on the ActiproSoftware.Products.Ribbon.SR class. Use that class to customize string resources as well.

Note Note
String resource customization is described in great detail in the general Customizing String Resources topic. Please see that topic for in-depth information related to localization of string resources.

An enumation named SRName includes a list of all the string resource names. A XAML markup extension named SRExtension is available for use within XAML templates to access string resources.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UI Automation

Ribbon controls follow the WPF accessibility model for UI automation.

What is UI Automation?

Microsoft UI Automation is the new accessibility framework for Microsoft Windows. It addresses the needs of assistive technology products and automated test frameworks by providing programmatic access to information about the user interface (UI).

Ribbon implements automation peers for the following classes:

  • The Ribbon class, which provides access to the child elements.
  • The ButtonBase class, which is the base class for several other controsl. This automation peer provides the ability to invoke and toggle (when checkable) the control.
  • The CheckBox class, which provides the ability to toggle the checked state.
  • The ComboBox class, which provides the ability to get or set the current text (when editable), expand or collapse the drop-down list, view selected item (when not editable), or get the items available in the drop-down list.
  • The PopupButton class, which provides the ability to expand or collapse the popup.
  • The RadioButton class, which provides the ability to toggle the checked state.
  • The SplitButton class, which provides the ability to expand or collapse the popup and invoke the button.
  • The TextBox class, which provides the ability to get or set the current text.
  • Several other Ribbon classes implement an automation peer that provides access to the child elements.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Ribbon is designed to be tightly integrated with the great command model found in WPF.

Every ribbon control implements ICommandSource, meaning that it has Command, CommandParameter, and CommandTarget properties. The ICommand that is assigned to a ribbon control can be any command, including those defined in the WPF framework in the System.Windows.Input namespace.

Ribbon controls also can use commands to provide several user interface elements for the controls that use them. These user interface elements include labels, images and screen tip data. Any command can provide this functionality although an extra step is needed for commands that don't implement IRibbonCommandUIProvider.

Once you read through this topic, please see these topics for more an explanation of some more advanced things you can do with commands:

  • Interaction with Checkable Controls
  • Interaction with Value Controls
  • Using Commands to Provide User Interface Elements

Prototype in XAML, Use Commands Later

We encourage you to prototype your ribbon user interface in XAML and then change to a command-driven model later once your ribbon user interface design is approved. Note that switching to a command-driven interface doesn't mean that you stop using XAML. Not at all! In XAML you would simply insert a Command attribute on your controls and pass it the appropriate command you defined in code. If your command also defines user interface elements, you can remove properties like Label, etc. from the XAML definition for the control.

This subject is explained in more detail later in the Using Commands to Provide User Interface Elements topic.

Processing Command Executions

Since Ribbon uses the WPF command model, all the Microsoft documentation on commands applies. But we'll give a quick overview anyhow.

A command is a class implementation of ICommand (typically inheriting from RoutedCommand) that is exposed statically on another class. An example command is System.Windows.Input.EditingCommands.ToggleBold.

There is currently no WPF framework command for toggling strike-through so let's add one to our own ApplicationCommands class.

C#
VB
Copy
​public class ApplicationCommands {

    private static RibbonCommand toggleStrikethrough;

    public static RoutedCommand ToggleStrikethrough {
        get {
            if (toggleStrikethrough == null)
                toggleStrikethrough = new RibbonCommand("ToggleStrikethrough", typeof(Ribbon),
                    "Strikethrough", null, "/Images/Strikethrough16.png",
                    "Draw a line through the middle of the selected text.");
            return toggleStrikethrough;
        }
    }
}
​Public Class ApplicationCommands
    Private Shared toggleStrikethrough As RibbonCommand
    Public Shared ReadOnly Property ToggleStrikethrough() As RoutedCommand
        Get
            If toggleStrikethrough Is Nothing Then
                toggleStrikethrough = New RibbonCommand("ToggleStrikethrough", Type.GetType(Ribbon), _
                    "Strikethrough", Nothing, "/Images/Strikethrough16.png", _
                    "Draw a line through the middle of the selected text.")
            End If
            Return toggleStrikethrough
        End Get
    End Property
End Class

Note that the command is of type RibbonCommand (which implements IRibbonCommandUIProvider) and therefore is capable of providing some user interface elements to any control that uses it. In the example, we have provided a label, small image, and a screen tip description.

Now say that we have a RichTextBox class override named RichTextBoxExtended. In the override, we want to add a handler for a custom ToggleStrikethrough command like so:

C#
VB
Copy
​this.CommandBindings.Add(new CommandBinding(ApplicationCommands.ToggleStrikethrough,
    OnToggleStrikethroughExecute, OnToggleStrikethroughCanExecute));
​Me.CommandBindings.Add(new CommandBinding(ApplicationCommands.ToggleStrikethrough,
    AddressOf OnToggleStrikethroughExecute, AddressOf OnToggleStrikethroughCanExecute))

The OnToggleStrikethroughExecute implementation should look something like this:

C#
VB
Copy
​private void OnToggleStrikethroughExecute(object sender, ExecutedRoutedEventArgs e) {
    this.SelectionStrikethrough = !this.SelectionStrikethrough;
    e.Handled = true;
}
​Private Sub OnToggleStrikethroughExecute(ByVal sender As Object, ByVal e As ExecutedRoutedEventArgs)
    Me.SelectionStrikethrough = Not Me.SelectionStrikethrough
    e.Handled = True
End Sub

The OnToggleStrikethroughCanExecute implementation can be made to update the checked state of any attached ribbon control that supports working with ICheckableCommandParameter. For a sample of this type of code, see the Interaction with Checkable Controls topic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Interaction with Checkable Controls

Many controls (such as Button) supoort a checked state. So the question is, how do you sync up the checked state of a control when there might be multiple control instances that toggle on the same criteria.

An example is the ToggleBold command. There might be an instance of a ToggleBold button in the ribbon and another in the Quick Access Toolbar. They both need to be synced up so that when the selection in the document is bold, the two controls appear checked.

This is done via a ICheckableCommandParameter. By default, the built-in checkable controls assign a CheckableCommandParameter instance (which implements ICheckableCommandParameter) to their CommandParameter property.

When the CanExecute event of the command is handled in your code, set the Handled property of the parameter to true and set the IsChecked property to the checked state value.

This code shows how to handle a ToggleBold command's CanExecute handler to set the checked state of a ribbon control. Note that in this sample code, the SelectionBold property is assumed to return whether the selection in the document is currently bold.

C#
VB
Copy
​private void OnToggleBoldCanExecute(object sender, CanExecuteRoutedEventArgs e) {
    ICheckableCommandParameter parameter = e.Parameter as ICheckableCommandParameter;
    if (parameter != null) {
        parameter.Handled = true;
        parameter.IsChecked = this.SelectionBold;
    }
}
​Private Sub OnToggleBoldCanExecute(ByVal sender As Object, ByVal e As CanExecuteRoutedEventArgs)
    Dim parameter As ICheckableCommandParameter = TryCast(e.Parameter, ICheckableCommandParameter);
    If Not (parameter Is Nothing)
        parameter.Handled = True
        parameter.IsChecked = Me.SelectionBold
    End If
End Sub

Since the ribbon controls require the command's can-execute method logic to fire for updating of the checked state, it may be necessary to raise the command's CanExecuteChanged event following a programmatic change that affects the checked state, especially if the command is not a routed command.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Interaction with Value Controls

Some controls are associated with a value. TextBox, ComboBox, RibbonGallery, and PopupGallery, controls are good examples. For these, an IValueCommandParameter command parameter is assigned by default to the control.

Ribbon includes a generic implementation of IValueCommandParameter named ValueCommandParameter. This class can be constructed using any type such as a string, FontFamily, etc. Ribbon has several built-in constructed types of IValueCommandParameter such as ObjectValueCommandParameter, DoubleValueCommandParameter, StringValueCommandParameter, BrushValueCommandParameter, and FontFamilyComboBox.

When the CanExecute event of the command is handled in your code, set the Handled property of the parameter to true and set the UpdatedValue property to the current value of the control. For instance, in a font family command CanExecute handler, the UpdatedValue would be set to Tahoma if that was the current FontFamily in use. The CanExecute handler for value controls is nearly the same as for checkable controls except that you set the UpdatedValue property instead of IsChecked.

When the Execute event of the command is handled in your code, the Action property indicates the current action (via an enum of type ValueCommandParameterAction), which can be Commit, Preview, or CancelPreview. Commit means use the value in the Value property and commit it to the selection.

Preview and CancelPreview are for controls that support live previewing (hovering over an item to see how selecting that item would change the selection). A great example is font family comboboxes where hovering over items shows how the selection updates to the new font family without really commiting the update until the font family is actually clicked. Preview means to ensure the real state of the selection is backed up and to preview an updated selection based on the value in the PreviewValue property. CancelPreview means to cancel preview mode and restore the backup of the real selection state. A Commit issued during preview mode means to accept the preview as the new selection state.

Since the ribbon controls require the command's can-execute method logic to fire for updating of the value, it may be necessary to raise the command's CanExecuteChanged event following a programmatic change that affects the new value, especially if the command is not a routed command.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Using Commands to Provide User Interface Elements

Commands can provide user interface elements such as labels, images, and screen tip data to any control that uses them. Doing this requires the implementation of the IRibbonCommandUIProvider interface.

If your commands inherit RibbonCommand (which inherits RoutedCommand), they are already set up with properties and methods that support user interface provisioning. Properties such as Label, ImageSourceLarge, etc. can be used to supply any attached controls with those user interface elements.

Now sometimes there are existing commands that you want to use which don't inherit RibbonCommand. No problem, by registering an existing command with the RibbonCommandUIManager, any command can provide user interface elements.

Say that you wanted the WPF framework EditingCommands.ToggleBold command to provide user interface elements to any control that uses it. You would register the command at the startup of your application like this:

C#
VB
Copy
​RibbonCommandUIManager.Register(EditingCommands.ToggleBold,
    new RibbonCommandUIProvider("Bold", null, "pack://application:,,,/SampleBrowser;component/Images/Bold16.png", "Make the selected text bold."));
​RibbonCommandUIManager.Register(EditingCommands.ToggleBold, _
    new RibbonCommandUIProvider("Bold", Nothing, "pack://application:,,,/SampleBrowser;component/Images/Bold16.png", "Make the selected text bold."))

What happens is that RibbonCommandUIManager ties the command to the RibbonCommandUIProvider that you pass. Note that the RibbonCommandUIProvider implements IRibbonCommandUIProvider just like RibbonCommand does.

Be sure to use full pack:// syntax so that the created BitmapImage can be frozen to prevent possible memory leaks.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Ribbon has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to quickly create your ribbon user interfaces and adjust the layout of ribbon controls.

The Visual Studio designer with a SplitButton selected, using the image picker on the SplitButton's task pane

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • Task Pane Introduction
  • Using Image Pickers
  • Ribbon Task Pane
  • Button, CheckBox, ComboBox, PopupButton, RadioButton, SplitButton, and TextBox Task Panes
  • ComboBox and TextBox Task Panes
  • ApplicationMenu Task Pane
  • Backstage Task Pane
  • BackstageTab Task Pane
  • ButtonGroup Task Pane
  • ContextualTabGroup Task Pane
  • Group Task Pane
  • Menu Task Pane
  • RibbonGallery Task Pane
  • RowPanel Task Pane
  • StackPanel Task Pane
  • Tab Task Pane
  • Changing the Selected Tab
  • Configuring Group Variants
  • Moving Controls Within the Ribbon
  • Modifying the Ribbon UI Using the Property Grid
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

Task Pane Introduction

Whenever you select a Ribbon or one of several types of ribbon controls in the designer, a task pane adorner may appear in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

These control types currently have task panes available when they are selected in the Visual Studio designer:

  • Ribbon
  • ApplicationMenu
  • Button
  • ButtonGroup
  • CheckBox
  • ComboBox
  • ContextualTabGroup
  • Group
  • Menu
  • PopupButton
  • RadioButton
  • RibbonGallery
  • RowPanel
  • SplitButton
  • StackPanel
  • Tab
  • TextBox

Nearly all of the task panes have links for quickly adding new child controls to the selected control. Ribbon is very intelligent and adds additional controls as appropriate to increase your productivity. For instance, when adding a contextual tab group, a tab will also be added to that contextual tab group with a single group already in the tab, ready for design. This saves on several clicks for tasks you would have performed anyhow.

One of the nicest features of the task panes are the listboxes that allow you to reorder items. Where appropriate, these listboxes render a visual of the actual items as opposed to giving them text descriptions only.

Almost all of the task panes have little "i" characters with a circle around them (see the screenshot below within the red circle). If you hover over these information icons with your mouse, helpful tooltips appear that explain more about the controls next to them.

The mouse hovering and showing the info tooltip for the Tab's Label property

Using Image Pickers

Many controls support entry of ImageSource objects (like for button images), which is typically done via a relative Uri to a project resource. With Actipro's innovative task pane design, we've made it extremely simple to select images. Clicking an image picker button shows a popup containing a list of open projects and root folders within those projects. You can click down folders to navigate further into the folder tree. The list of links at the top of the popup show you where you currently are in the project hierarchy and also allow you to navigate back up to a specific project/folder level.

An image picker for the SplitButton's small image source property

When a selected folder in a project contains images, they will be displayed along with their name and size. Hover over items to see their full relative Uri path and full-size preview. Click on an image to select it and insert its relative Uri path into the related image source TextBox on the task pane. Selecting images has never been easier!

Ribbon Task Pane

The Ribbon task pane provides quick access for adding new child controls to the Tabs, ContextualTabGroups, TabPanelItems, and QuickAccessToolBarItems collections. It also allows for the reordering of items in all those collections, along with the configuration of several common options.

The task pane for the Ribbon control in the Visual Studio designer

Click a tab in the tabs list to select it in the ribbon and make its contents visible. Alternatively, click on a tab in the designer itself to select it.

In addition, the Ribbon.ApplicationMenu property can be quickly set to a new instance of Backstage (Office 2010) or ApplicationMenu (Office 2007).

Button, CheckBox, ComboBox, PopupButton, RadioButton, SplitButton, and TextBox Task Panes

The task pane used for Button, CheckBox, ComboBox, PopupButton, RadioButton, SplitButton, and TextBox controls makes it simple to quickly configure everything from labels and images to key tips and screen tips for a control.

The task pane for the SplitButton control in the Visual Studio designer

Button-based controls have a couple more items on their task panes than TextBox and ComboBox task panes do, such as menu item description and checked state.

Note Note
To display the popup for a PopupButton or SplitButton, first select it in the designer and then click it again.

ComboBox and TextBox Task Panes

The task pane used for Button, CheckBox, PopupButton, RadioButton, and SplitButton controls makes it simple to quickly configure everything from labels and images to key tips and screen tips for a control.

The task pane for the SplitButton control in the Visual Studio designer

Note Note
To display the popup for a PopupButton or SplitButton, first select it in the designer and then click it again.

ApplicationMenu Task Pane

The ApplicationMenu task pane provides quick access for adding new child controls and reordering those items.

The task pane for the ApplicationMenu control in the Visual Studio designer

Note Note
To display the application menu in the designer, first select the ribbon and then click on the application button/tab.

Backstage Task Pane

The Backstage task pane provides quick access for adding new child controls and tabs, and reordering those items.

The task pane for the Backstage control in the Visual Studio designer

Note Note
To display the backstage in the designer, first select the ribbon and then click on the application button/tab.

BackstageTab Task Pane

The BackstageTab task pane allows the header and key tip to be quickly set.

The task pane for the BackstageTab control in the Visual Studio designer

Note Note
The BackstageTab Header property can be set to any content, but the task pane only supports setting it to a string value.

ButtonGroup Task Pane

The ButtonGroup task pane provides quick access for adding new child controls, reordering those items, and controlling whether the border is visible for the group.

The task pane for the ButtonGroup control in the Visual Studio designer

ContextualTabGroup Task Pane

The ContextualTabGroup task pane provides quick access for adding new child tabs, reordering those tabs, and controlling whether the contextual tab group is active.

The task pane for the ContextualTabGroup control in the Visual Studio designer

It also supports entry of the label for the tab group and selection of the base color used to render the tab group and its content.

Group Task Pane

The Group task pane provides quick access for adding new child controls, reordering those items, and controlling whether the group is collapsible.

The task pane for the Group control in the Visual Studio designer

It also supports entry of the group's label, key tips, and small image (displayed when collapsed).

Menu Task Pane

The Menu task pane provides quick access for adding new child controls and reordering those items.

The task pane for the Menu control in the Visual Studio designer

RibbonGallery Task Pane

The RibbonGallery task pane provides quick access for modifying the control's most common properties.

The task pane for the RibbonGallery control in the Visual Studio designer

RowPanel Task Pane

The RowPanel task pane provides quick access for adding new child controls, reordering those items in both the two- and three-row variants of the panel, and determining when the switch to a three-row variant occurs.

The task pane for the RowPanel control in the Visual Studio designer

StackPanel Task Pane

The StackPanel task pane provides quick access for adding new child controls, reordering those items, and setting the item variant behavior and row alignment for the panel.

The task pane for the StackPanel control in the Visual Studio designer

The bottom of the task pane can expand out to show you a preview of how typical controls collapse based on parent group variant sizes. This is extremely valuable to display while you are choosing layout options.

Tab Task Pane

The Tab task pane provides quick access for adding new child groups and reordering those groups. You can also configure the tab's label and key tip.

The task pane for the Tab control in the Visual Studio designer

The Group Variants expander section on the task pane gives you advanced control over the order in which Groups transition to other variant sizes as available Ribbon width decreases.

When the Ribbon's ideal width can be achieved, each Group starts in a Large variant. As available width decreases, Group variant sizes will change in the order from those at the top of the list first, down towards the bottom of the list, until all Groups fit within the available space.

As an example, say this ribbon is at full ideal width. Then the available width decreases. Based on the screenshot above, the Clipboard Group will first transition to a Small variant. If that doesn't make the ribbon small enough to fit in the available width, the Styles Group will then transition to a Medium variant, and so on.

Creating variants is easy by using this task pane. To add a new Group variant, at the bottom fo the task pane, select the Group (label is displayed in a ComboBox) and the variant size to transition to. Then click the Add button. The variant will be added to the list.

You can remove specific variants by selecting them and clicking Remove. You can clear the entire list by clicking Clear.

Please note that changes are NOT applied until you actually click Apply. This will write out the Group variant data for all the groups in the Tab. If you make a mistake before clicking Apply, use the Reset button to reset the list back to what is currently in the XAML.

If you choose not to define specific Group variants, the make sure you leave the list completely blank (press Clear, then Apply). This will allow Ribbon to automatically generate variants for you. But keep in mind that the best end user experience can be created by you explicitly defining variants so lesser-used Groups collapse first.

Changing the Selected Tab

The Ribbon.SelectedTab property in the Properties window has a special drop-down list that allows for selection of a tab within the Ribbon. This allows you to jump directly to a specific tab clicking on it in the list.

But actually the easier way to change the currently selected tab is to simply click on another tab in the designer. The tab you click on will become selected both in the ribbon and in the designer.

Configuring Group Variants

The Tab's task pane (see details above) has all the functionality needed to allow you to easily configure the order in which Groups transition to various variant sizes based on decreases in available Ribbon width.

Actipro Ribbon has one of the most sophisticated Ribbon layout engines available today, and by using the Tab task pane to set up Group variants, you can utilize its capabilities to the fullest and fully control your Ribbon's layout.

If you choose not to configure Group variants, that's ok too but make sure you don't have any Group variants defined within the Tab. When no Group variants are explicitly defined, Ribbon will use its default algorithms to intelligently auto-create Group variants. For the best end user experience though, it is ideal to define the Group variants yourself since you can make sure that lesser used Groups collapse to smaller sizes first.

Moving Controls Within the Ribbon

Many ribbon controls have a four way arrow adorner that appears near their upper left corner when they are selected in the designer.

Visual Studio showing a drag/move adorner for a button

By clicking on this adorner and dragging it, you can move the control around within the ribbon. If there is a Group on another Tab, you can even hover over the Tab for a brief period of time and then the selected Tab will switch and the control will be dropped in the new Tab.

Groups can be moved to any Tab by hovering over the target Tab for a brief period of time.

Tabs can be reordered via dragging them to a new location as well.

Modifying the Ribbon UI Using the Property Grid

The property grid is very flexible and we've engineered Ribbon so that a lot of the Ribbon can be designed via the property grid.

Visual Studio displaying the collection editor for ribbon tabs

For instance, to edit the tabs in a ribbon, use the collection editor for the Tabs property. From that collection editor you can select a Tab, edit its Items collection and add groups.

Although a lot of the ribbon UI can be configured using the property grid and its dialogs, there are some limits on how far you can traverse, thus requiring you to code in XAML for certain UI features.

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to v3.0 topic contains information on converting to v3.0 from an older version.
  • The Converting to v3.5 topic contains information on converting to v3.5 from v3.0.
  • The Converting to v4.0 topic contains information on converting to v4.0 from v3.5.
  • The Converting to 2010.1 topic contains information on converting to 2010.1 from v4.0 through 2009.2.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from 2010.1 through 2011.1.
  • The Converting to 2016.1 topic contains information on converting to 2016.1 from 2011.2 through 2015.1.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to v3.0

This topic provides in-depth information on breaking changes introduced in Ribbon v3.0 over previous versions and how to update your application code to work in v3.0.

These breaking changes were made to support v3.0 enhanced functionality and in other cases, to make development easier.

If you are converting from an old version to v3.0, please read through this topic carefully since it provides details on converting to v3.0. Several customers have reported converting complex projects very quickly using this guide. If you feel we are missing anything from this guide, please e-mail us and we will help you resolve the issue and possibly add new information to this topic.

This topic contains these sections:

  • MenuButton Control Renamed to PopupButton
  • Popup Content / New Menu Control
  • MenuItemSize Removed
  • StackPanel Layout Properties Simplified
  • RowPanelItemGroup Renamed to ButtonGroup
  • RowPanelItemGroup Layout Properties Simplified
  • Gallery Design Complete
  • Control Base Classes Changed to Inherit More Core WPF Classes
  • IRibbonControl Interface Removed
  • CustomControl Class Removed - Improves ComboBox and TextBox Design
  • RibbonContextMenu Renamed to ContextMenu
  • Use the ScreenTipHeader Property Instead of ToolTip
  • Get Methods Removed from RibbonCommand and RibbonCommandUIProvider
  • Ribbon.ApplicationButtonImage Renamed to ApplicationButtonImageSource
  • Removed the Ribbon.UsesAlternateStyle Attached Property
  • ScrollViewer Normal and Alternate Styles Flipped

MenuButton Control Renamed to PopupButton

The MenuButton class has been renamed to PopupButton since it can now be used to display any sort of popup content, not just menus.

Updating for this change is a simple matter of doing a find/replace in your code from MenuButton to PopupButton in the appropriate spots.

Popup Content / New Menu Control

The PopupButton and SplitButton controls used to accept a collection of menu items as their children. One great new feature found in v3.0 is the ability to add any content or complex layout of controls to a Ribbon control popup. Since the new popup design found in v3.0 allows for any sort of content to be added to a popup, not just menu items, several changes need to be made wherever PopupButton and SplitButton controls are used.

To mimic older versions, place a Menu control (new in v3.0) as the child of the parent PopupButton or SplitButton. Place all your old menu items within this Menu control.

Here is a sample of a MenuButton in an old Ribbon version compared to its corresponding v3.0 code. Note the change to PopupButton as well.

XAML
Copy
​<ribbon:MenuButton Label="Popup">
    <ribbon:Button Label="Menu Item 1" />
    <ribbon:Button Label="Menu Item 2" />
</ribbon:MenuButton>

Here is the same code converted to v3.0.

XAML
Copy
​<ribbon:PopupButton Label="Popup">
    <ribbon:Menu>
        <ribbon:Button Label="Menu Item 1" />
        <ribbon:Button Label="Menu Item 2" />
    </ribbon:Menu>
</ribbon:PopupButton>

Why is this change made? With this change, any content can be placed in the popups. You can have mutiple columns of menu items, a header for your popup, popups with large and small menu items, etc. The sky is the limit. See the QuickStart on popups for some ideas on what you can do.

MenuItemSize Removed

In older versions, the MenuButton and SplitButton controls had an ItemSize property that took an enumeration value of type MenuItemSize.

In v3.0, MenuItemSize has been removed since all item size enumerations have been consolidated into VariantSize. You may now set the ItemVariantSize property on the Menu control to achieve the same behavior.

StackPanel Layout Properties Simplified

The older StackPanel implementation was very robust but was a bit confusing when determining what should be in the SmallVariantGroupSize and SmallNoLabelVariantGroupSize properties. For v3.0, we've removed those two properties and replaced them with a single enumeration property that is much clearer.

The new StackPanelItemVariantBehavior enumeration eliminates the confusion on how items of a StackPanel change their layout when the ribbon is resized. It designates the VariantSize of the child controls based upon the current VariantSize of the parent Group.

For instance, if the StackPanel.ItemVariantBehavior property is set to AlwaysMedium, then its child items will always be stacked vertically with an image and label visible, regardless of the parent Group's variant size. If the item variant behavior is set to LargeThenMediumWhenMedium, the child items will initially be stacked horizontally with a large size and will be transitioned to a vertical stack of smaller items when the parent Group's variant size becomes Medium.

This table shows how to convert the old SmallVariantGroupSize and SmallNoLabelVariantGroupSize property settings to the new StackPanel.ItemVariantBehavior property values (enumeration of type StackPanelItemVariantBehavior):

SmallVariantGroupSize | SmallNoLabelVariantGroupSize | StackPanelItemVariantBehavior
Medium (default) | Small (default) | Default
Collapsed | Collapsed | AlwaysLarge
Medium (default) | Collapsed | LargeThenMediumWhenMedium
Small | Collapsed | LargeThenMediumWhenSmall
Medium (default) | Medium | LargeThenSmallWhenMedium
Small | Small (default) | LargeThenSmallWhenSmall
Large | Medium | MediumThenSmallWhenMedium
Large | Small (default) | MediumThenSmallWhenSmall
Large | Collapsed | AlwaysMedium
(anything) | Large | AlwaysSmall

RowPanelItemGroup Renamed to ButtonGroup

The RowPanelItemGroup control, which was previously only used in RowPanel controls is now renamed to ButtonGroup so that it can be used other places, such as within StatusBar controls.

RowPanelItemGroup Layout Properties Simplified

In previous versions, the RowPanelItemGroup properties RowLocation, ThreeRowLocation, and ThreeRowSortOrder were used to determine where the groups appeared within the parent RowPanel. These have been removed and are no longer necessary since the v3.0 RowPanel implementation is much more robust.

In v3.0, the RowPanel will automatically determine the best way to wrap groups to various rows. In the two-row variant, the order the controls appear within the RowPanel .Items collection determines the order they appear within the UI. In the three-row variant, the order the controls appear in the UI is determined by the setting of the RowPanel.ThreeRowItemSortOrder property. This is a collection of integer values that designate the sort order of each item.

Gallery Design Complete

The previous version of Ribbon had a preview implementation of a gallery control. In v3.0 we have finialized the design of galleries so that they provide all the capabilities found in Office.

The old Gallery control has been broken out into two separate controls: RibbonGallery (for in ribbon groups) and PopupGallery (for in popups). The properties on these controls are different than in the previous Gallery preview implementation. See documentation and samples on galleries to learn how to use them.

Control Base Classes Changed to Inherit More Core WPF Classes

Numerous control base classes have been changed so that they inherit core WPF classes. In controls such as menus, galleries, etc., this enables you to take advantage of all the features of ItemsControl such as data binding, filtering, etc.

The TextBox and ComboBox classes now directly inherit the core WPF TextBox and ComboBox classes instead of being "wrapper" classes.

IRibbonControl Interface Removed

The old IRibbonControl is no longer needed. In v3.0, the internal structure of all controls has been reworked so that they implement attached properties from other classes. For instance, IRibbonControl used to define a Label property. To get the Label in a v3.0 control, you can get the value of the attached RibbonControlService.LabelProperty. Of course all control implementations like Button have a Label property that can be used to access the label directly as well.

Many of the attached properties are available on the RibbonControlService, ScreenTipService, and KeyTipService classes. However as mentioned above, when our core controls implement the attached properties, they provide properties directly on the control type, making it easier to get/set the properties.

CustomControl Class Removed - Improves ComboBox and TextBox Design

One of the great new v3.0 features is that now any element may be added directly to a Group, StackPanel, etc. In previous versions, a CustomControl class was needed to wrap controls such as regular WPF ComboBox, TextBox, or other non-IRibbonControl classes when they should appear in the Ribbon. We've done a lot of work to make adding controls for use in the Ribbon easier than ever. To convert to the new v3.0 code, simply remove your CustomControl wrapper instances around the controls they used to wrap.

One feature of using CustomControl in previous versions is that it would allow you to apply a label or image to your wrapped controls. For wrapped controls like DateTimePicker controls, this was great since the label would appear to the left of the actual control. Don't worry, you still can do this but now it is done via attached properties like:

XAML
Copy
​<shared:DateTimePicker Value="12/31/2007"
    ribbon:RibbonControlService.Label="My Label" ribbon:RibbonControlService.ImageSourceSmall="/Images/MyImage16.png" />

The ComboBox and TextBox controls in the old version of Ribbon actually inherited CustomControl and you could only access the wrapped controls via the CustomControl.Content property. Now that there is no more CustomControl wrapper, the ribbon version of a ComboBox actually does inherit the native WPF ComboBox. This makes accessing its features much easier. Also, if you had previously set the ContentMinWidth property on a CustomControl, now just use the regular MinWidth property.

RibbonContextMenu Renamed to ContextMenu

The RibbonContextMenu control has been renamed to ContextMenu. A Menu control should now be added as a direct child of the ContextMenu with other child controls (such as Button, PopupButton, etc.) as child controls of the Menu.

ContextMenu now supports the complex layout features found in all other Ribbon popups. See the ContextMenu QuickStart for more information.

Our ContextMenu inherits the standard WPF ContextMenu and can be used anywhere a standard ContextMenu can be used.

Use the ScreenTipHeader Property Instead of ToolTip

In the old Ribbon versions, the ToolTip property was sometimes used to provide an alternate header text for a screen tip. In v3.0, use the new ScreenTipHeader property instead. Use of the ToolTip property in v3.0 on ribbon controls will invoke the native WPF tooltip whereas it didn't in previous versions.

This change involves renaming the IRibbonCommandUIProvider .ToolTip property ScreenTipHeader. This also affects the RibbonCommand and RibbonCommandUIProvider classes.

Get Methods Removed from RibbonCommand and RibbonCommandUIProvider

In the old Ribbon versions, the RibbonCommand and RibbonCommandUIProvider classes had various get methods that allowed you to provide a custom programmatic screen tip for example. This functionality has been replaced by a more robust implementation where you can handle the ScreenTipOpening event and update your screen tips there before they are displayed to the end user.

See the screen tip QuickStart for a sample.

Ribbon.ApplicationButtonImage Renamed to ApplicationButtonImageSource

The Ribbon .ApplicationButtonImage property has been renamed to ApplicationButtonImageSource to be more consistent with naming conventions.

Removed the Ribbon.UsesAlternateStyle Attached Property

In older versions there was a Ribbon.UsesAlternateStyle attached property that could be set on some controls to provide alternate styles that may be defined for them. In v3.0, this property has been removed and guidelines for updating your code appropriate are given below.

Ribbon.UsesAlternateStyle used to provide status bar items and separators with a darker alternate style. You may now apply those same styles with the following code:

XAML
Copy
​<Separator Style="{DynamicResource {x:Static ribbon:RibbonStyles.StatusBarSeparatorAlternateKey}}" />
<StatusBarItem Style="{DynamicResource {x:Static ribbon:RibbonStyles.StatusBarItemAlternateKey}}">

Ribbon.UsesAlternateStyle also used to provide scrollbars and scroll viewers with a lighter alternate style. See the next item for an explanation on how to apply these styles.

ScrollViewer Normal and Alternate Styles Flipped

Since most scrollbars other than a document area scrollbar have the lighter Office style (which used to be the alternate style), we have flipped the styles so that the old dark style is now the alternate one, and the light style is the normal one.

Light styles may be applied with the following code:

XAML
Copy
​<ScrollBar Style="{DynamicResource {x:Static ribbon:RibbonStyles.ScrollBarKey}}" />
<ScrollViewer Style="{DynamicResource {x:Static ribbon:RibbonStyles.ScrollViewerKey}}">

Light styles may be applied with the following code:

XAML
Copy
​<ScrollBar Style="{DynamicResource {x:Static ribbon:RibbonStyles.ScrollBarAlternateKey}}" />
<ScrollViewer Style="{DynamicResource {x:Static ribbon:RibbonStyles.ScrollViewerAlternateKey}}">

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to v3.5

This topic provides in-depth information on breaking changes introduced in Ribbon v3.5 since v3.0 and how to update your application code to work in v3.5.

These breaking changes were made to support new Shared Library frameworks introduced in v3.5, including common frameworks for themes management and string resources.

This topic contains these sections:

  • RibbonUIStrings Class Replaced with String Resource (SR) Framework
  • RibbonColorScheme, RibbonColorSchemeType, RibbonColorExtension Removed; Replaced with New Shared Library Themes Framework
  • ContextualTabGroup Stock Color Access

RibbonUIStrings Class Replaced with String Resource (SR) Framework

The RibbonUIStrings class was used in v3.0 and earlier to get access to user interface strings for the Ribbon product. In v3.5, we introduced a common framework for retrieving and customizing string resources for all our products going forward.

If you never accessed the RibbonUIStrings class, then this change will not affect you.

Note Note
See the Customizing String Resources topic for detailed information on how to use the string resources framework to retrieve and customize user interface strings.

The ActiproSoftware.Products.Ribbon.SR class provides methods for retrieving resolved string resources between their customized and default values, along with letting you customize strings.

The names of the available string resources are available in the ActiproSoftware.Products.Ribbon.SRName enumeration. The names are similar to the field names in the old RibbonUIStrings class but have been altered slightly to fit the naming conventions we use for string resources.

This code shows how to retrieve the resolved value of a string resource (including any customizations):

C#
VB
Copy
​string text = SR.GetString(SRName.UIScreenTipPressF1ForMoreHelpText);
​Dim text As String = SR.GetString(SRName.UIScreenTipPressF1ForMoreHelpText)

String resources can also be used directly in XAML via a new markup extension.

XAML
Copy
​xmlns:productsRibbon="clr-namespace:ActiproSoftware.Products.Ribbon;assembly=ActiproSoftware.Ribbon.Wpf30"
...
<Button Content="{productsRibbon:SRExtension UIScreenTipPressF1ForMoreHelpText}" />

RibbonColorScheme, RibbonColorSchemeType, RibbonColorExtension Removed; Replaced with New Shared Library Themes Framework

The old RibbonColorScheme, RibbonColorSchemeType, and RibbonColorExtension classes have been removed so that the new themes framework added in v3.5 of the Shared Library can be used. The new themes framework allows you to set an application-wide theme and have it be applied to any controls that support that theme name.

Note Note
See the Themes topic for detailed information on how the themes framework functions.

The Themes topic for Ribbon also describes more about how to switch Ribbon themes using the new themes framework.

This sample code shows how to make the application use the the Office silver theme, thereby forcing all ribbon controls to use that theme:

C#
VB
Copy
​ThemeManager.CurrentTheme = CommonThemeName.Office2007Silver.ToString();
​ThemeManager.CurrentTheme = CommonThemeName.Office2007Silver.ToString()

The old RibbonColorSchemeType enumeration has been replaced by the CommonThemeName enumeration. The CommonThemeName enumeration contains more theme name options than are supported by the Ribbon product (for instance there is no separate LunaNormalColor Ribbon theme defined. However in that case it will fall back to using the Office2007Blue theme. You can use the Themes framework to register certain available Ribbon themes to be used for particular theme names. The new themes framework is extremely flexible in this regard.

Part of the switch over to the new themes framework involved a change in how the Ribbon themes were defined. In old versions, there was a RibbonColorScheme class that had properties for the colors in the current theme. The RibbonColorExtension markup extension was used to access the colors in XAML. With the new themes framework, colors are no longer defined separately. Instead, the colors are specified directly in the resource dictionaries that define each theme.

One exciting new feature of the themes framework is that the RibbonCommonDictionary class now provides access to resource keys for all brushes defined in a Ribbon theme. So while you cannot access individual color values for a theme like before, you do now have the ability to easily access any brush that is used for Ribbon or its controls. You can even provide your own override of a brush if you wish by redefining the brush in your XAML's resources.

The tinting of Ribbon themes (the entire theme or just portions of) is fully supported with the themes framework.

ContextualTabGroup Stock Color Access

The contextual tab group stock colors used to be accessed using the old RibbonColorExtension markup extension like this:

XAML
Copy
​xmlns:ribbon="http://schemas.actiprosoftware.com/winfx/xaml/ribbon"
...
<ribbon:ContextualTabGroup Label="Picture Tools" Color="{ribbon:RibbonColor ContextualTabGroupStockColorRed}">
All stock color properties are now located on the new RibbonCommonDictionary class as static properties. You can access them like this instead:
XAML
Copy
​xmlns:ribbon="http://schemas.actiprosoftware.com/winfx/xaml/ribbon"
xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"
...
<ribbon:ContextualTabGroup Label="Picture Tools" Color="{x:Static themes:RibbonCommonDictionary.ContextualTabGroupStockColorRed}">

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to v4.0

During the development of v4.0, we made a commitment to ensure that all our WPF product assemblies are scanned using Visual Studio Code Analysis, and that all warnings are handled appropriately. Code Analysis helps make sure that code is kept up to the highest standards and we are proud to now support it. All of the breaking changes below were made to properly handle Code Analysis warnings.

This topic contains these sections:

  • Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll
  • CancelRoutedEventHandler, CustomDrawEventHandler<T>, ItemRoutedEventHandler<T>, PropertyChangedRoutedEventHandler<T>, PropertyChangingRoutedEventHandler<T> Removed
  • Removed ExecuteRoutedEventHandler, replace with EventHandler<ExecuteRoutedEventArgs>
  • Control ID Properties Renamed to Id
  • Renamed Ribbon.IsTabGroupVariantPreLoadingEnabled to IsTabGroupVariantPreloadingEnabled

Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll

Per Code Analysis guidelines, the WPF portion of the assembly names was renamed to Wpf. If you have any problems with existing references to the assemblies, just remove the old references in your project and new ones. Also be sure your licenses.licx file is up to date with the info listed in the Licensing topic.

CancelRoutedEventHandler, CustomDrawEventHandler<T>, ItemRoutedEventHandler<T>, PropertyChangedRoutedEventHandler<T>, PropertyChangingRoutedEventHandler<T> Removed

The event handlers listed above were removed per Code Analysis recommendation and replaced with EventHandler<T> usage. This will probably only affect you if you have created class-based event handlers since those reference the delegates. The base event args classes remain the same.

See the Shared Library - Converting to v4.0 topic for more information on these changes, where they affect this product, and how to resolve any issues in your code.

Removed ExecuteRoutedEventHandler, replace with EventHandler<ExecuteRoutedEventArgs>

Per Code Analysis, all usage of ExecuteRoutedEventHandler should be replaced with EventHandler<ExecuteRoutedEventArgs>.

Instances of usage were:

  • ComboBoxBase.ClickEvent event
  • ComboBoxBase.PreviewClickEvent event
  • ControlBase.ClickEvent event
  • ControlBase.PreviewClickEvent event
  • ItemsControlBase.ClickEvent event
  • ItemsControlBase.PreviewClickEvent event
  • TextBoxBase.ClickEvent event
  • TextBoxBase.PreviewClickEvent event
  • RibbonControlService.ClickEvent event
  • RibbonControlService.PreviewClickEvent event

Control ID Properties Renamed to Id

The ID properties on all control base classes were renamed to comply with proper .NET naming conventions. This change was made on:

  • ComboBoxBase
  • ControlBase
  • ItemsControlBase
  • TextBoxBase
  • RibbonControlPathItem
  • RibbonControlService

This change will mostly affect XAML code. Doing a recompile of your application will show all the XAML and code-behind locations where ID needs to be renamed to Id. When encountering a XAML file that contains a lot of ID usage, use your IDE's find feature to look for ID=" and replace appropriate instances with Id=".

The other area that is affected by this is the XML persistence of QAT customization. Since any persisted XML from v3.5 had ID, it will not load correctly in v4.0. We recommend that you place a try...catch around any QAT customization loading code (should be there anyhow). Also you may try doing a find/replace on the raw XML to convert the ID attribute to Id before loading it the first time.

Renamed Ribbon.IsTabGroupVariantPreLoadingEnabled to IsTabGroupVariantPreloadingEnabled

This property value was renamed to comply with proper .NET naming conventions.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2010.1

WPF Studio 2010.1 updated Ribbon to use newer Scenic style by default. The Scenic style changes the appearance of the application button and alters how some other nearby controls are arranged.

See the Application Button Content topic for details on how to configure the application button style options.

To restore your ribbon to the older Office 2007 "Orb" style application button, set the new Ribbon.UseScenicLayout property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Theming Architectural and Style Changes
  • Updates To Hint Properties
  • Removed RibbonStyles Class
  • Removed RibbonWindowTitleBarButton Controls
  • Style Changes to StatusBar and Its Items
  • Moved Contextual Tab Group Stock Colors
  • Removed Theme-Related Properties

Theming Architectural and Style Changes

See unified conversion topic for details on breaking changes made to the theming architecture, which affects control styles and related dictionaries.

Updates To Hint Properties

The RibbonControlService's HintText attached property was removed. It was replaced by the Hint, HintTemplate, and HintTemplateSelector properties on the HintProperties class. This was done to provide consistency across all our products, with regards to hints.

In addition, the HintText properties on TextBoxBase, ComboBoxBase, and their derivations have been replaced with Hint, HintTemplate, and HintTemplateSelector properties.

Due to this change the hint text will no longer be trimmed by default. In order to define a hint that uses text trimming, the HintTemplate property must be used with a custom TextBlock.

Upgrade Instructions Upgrade Instructions
  1. All references to RibbonControlService.HintTextProperty must be replaced with HintProperty.
  2. All references to HintText on on TextBoxBase, ComboBoxBase, and their derivations must be replaced with Hint or HintTemplate.

Removed RibbonStyles Class

The RibbonStyles and it's associated keys and styles were removed since all native control styles formerly provided by that class are now provided via SharedResourceKeys, often with new options and improved looks.

Upgrade Instructions Upgrade Instructions
All references to RibbonStyles and it's styles must be replaced with similar styles defined by SharedResourceKeys.

Removed RibbonWindowTitleBarButton Controls

The RibbonWindowTitleBarButton control has been removed, since it only existed to facilitate theming. Instead, a native Button can be used along with the Style associated with the SharedResourceKeys.WindowTitleBarButtonBaseStyleKey or SharedResourceKeys.WindowTitleBarButtonBaseAlternateStyleKey keys.

This control defined an attached and inherited dependency property named IsActiveProperty, which was used to determine if the button should render with an active look. This property has been moved to IsActiveProperty.

Upgrade Instructions Upgrade Instructions
  1. All references to RibbonWindowTitleBarButton should be replaced with a native Button that uses either the WindowTitleBarButtonBaseStyleKey or the SharedResourceKeys.WindowTitleBarButtonBaseAlternateStyleKey style.
  2. All references to RibbonWindowTitleBarButton.IsActiveProperty must be replaced with IsActiveProperty.

Style Changes to StatusBar and Its Items

The RibbonWindow previously included an implicit Style for the StatusBar control so that their look would match. In this release, all theming for that native WPF controls, including StatusBar, has been consolidated into the Shared Library. When native themes are not enabled, then the SharedResourceKeys.StatusBarStyleKey must be used explicitly.

The style for Sliders in a StatusBar must now be explicitly set to SharedResourceKeys.StatusBarEmbeddedSliderStyleKey to achieve the Office status bar slider look.

StatusBarItem can now be styled explicitly, using SharedResourceKeys.StatusBarItemStyleKey, or implicitly along with the other native WPF control. The Style referenced by the RibbonStyles.StatusBarItemAlternateKey key has been deprecated.

Upgrade Instructions Upgrade Instructions
  1. To ensure the StatusBar look matches the RibbonWindow then the native themes should be enabled. Alternative, the styles for the StatusBar and it's items can be explicitly set.
  2. If native themes are enabled, then all references to RibbonStyles.StatusBarItemAlternateKey can be removed. Otherwise, it will need to be replaced with SharedResourceKeys.StatusBarItemStyleKey.

Moved Contextual Tab Group Stock Colors

The deprecated RibbonCommonDictionary included several stock colors for use with contextual tab groups, which included ContextualTabGroupStockColorCyan, ContextualTabGroupStockColorGreen, ContextualTabGroupStockColorOrange, ContextualTabGroupStockColorPink, ContextualTabGroupStockColorPurple, ContextualTabGroupStockColorRed, and ContextualTabGroupStockColorYellow. These color definitions have been moved to Cyan, Green, Orange, Pink, Purple, Red, and Yellow, respectively, on the ContextualTabGroupColors class

Upgrade Instructions Upgrade Instructions
  1. All references to RibbonCommonDictionary.ContextualTabGroupStockColorCyan must be replaced with Cyan.
  2. All references to RibbonCommonDictionary.ContextualTabGroupStockColorGreen must be replaced with Green.
  3. All references to RibbonCommonDictionary.ContextualTabGroupStockColorOrange must be replaced with Orange.
  4. All references to RibbonCommonDictionary.ContextualTabGroupStockColorPink must be replaced with Pink.
  5. All references to RibbonCommonDictionary.ContextualTabGroupStockColorPurple must be replaced with Purple.
  6. All references to RibbonCommonDictionary.ContextualTabGroupStockColorRed must be replaced with Red.
  7. All references to RibbonCommonDictionary.ContextualTabGroupStockColorYellow must be replaced with Yellow.

Removed Theme-Related Properties

Various theme-related properties were removed as they were no longer needed.

  1. Removed the following properties from Ribbon:
    • DropShadowsEnabled
  2. Removed the following properties from RibbonWindow:
    • UseClassicStyle

Upgrade Instructions Upgrade Instructions
All references to these properties would need to be removed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2016.1

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • RibbonWindow.IsGlassEnabled Is No Longer Nullable and Defaults to False
  • Ribbon Button Images Auto-Convert To White Monochrome When Appropriate

RibbonWindow.IsGlassEnabled Is No Longer Nullable and Defaults to False

With Metro themes becoming most popular with recent Windows versions and in an effort to have the RibbonWindow's Aero glass enabled state match that of WindowChrome, the IsGlassEnabled property is now a bool (instead of nullable bool) and defaults to false.

If your app uses a non-Metro theme (like AeroNormalColor) and you would like to continue using Aero glass on your RibbonWindow instances, set the IsGlassEnabled property to true. Note that even when that property is true, Aero glass will only be active on Windows 7 and Vista systems since Windows 8.x and later systems don't use Aero glass.

Ribbon Button Images Auto-Convert To White Monochrome When Appropriate

Several Metro themes require that buttons in the QAT, tab panel, or status bar have white monochrome images. New features have been added in the 2016.1 version to automatically perform this conversion for you so that additional image sets aren't required for these usage scenarios.

See the Monochrome Images topic for details on when this auto-conversion occurs.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Microsoft Ribbon UI Design Guidelines

Microsoft has created a 160+ page document that spells out exactly which parts of the ribbon UI must be implemented if you choose to use a ribbon user interface in your product.

Actipro comes in by taking care of implementation of the guidelines. The Actipro Ribbon control has been designed by strictly following the design guidelines that Microsoft created. This ensures that you are able to meet your licensing requirements for when you use a ribbon user interface.

This topic contains these sections:

  • Actipro Ribbon Design Guideline Implementation Status
  • Ribbon UI Guideline Implementation Hints

Actipro Ribbon Design Guideline Implementation Status

The list below details out all of the Microsoft ribbon UI design guideline sections and their implementation status in Actipro Ribbon.

Actipro Ribbon implements ALL required and nearly all optional sections of the official Microsoft ribbon UI design guidelines.

This means that if you use Actipro Ribbon to provide your ribbon user inteface, you know that you are meeting the Microsoft requirements, and that you have access to all of the items that Microsoft has dictated as optional.

Section | Office 2007 UI Required | Office 2010 UI Required | "Must" Item Status | "Should" Item Status
Accessing Document Level Command UI | Yes | Yes | - | -
Office 2007 UI Application Button | Yes | No | Complete | Complete
Office 2010 UI File Tab | No | Yes | Complete | Complete
Application Menu | Yes | Yes | - | -
Application Menu Requirements | Yes | Yes | Complete | Complete
Application Menu Controls | Yes | Yes | Complete | Complete
Backstage View | No | Yes | - | -
Backstage View Requirements | No | Yes | Complete | Complete
Tabs | No | Yes | Complete | Complete
Tab Pane Requirements | No | Yes | Complete | Complete
Commands in the Tab Pane | No | Yes | Complete | Complete
Control Panes | No | Yes | Complete | Complete
Backstage Controls | No | No | - | -
Button | No | No | Complete | Complete
Menu | No | No | Complete | Complete
Icon Gallery | No | No | Not Implemented | Not Implemented
ListBox | No | No | Not Implemented | Not Implemented
Most Recently-Used List | No | No | Complete | Complete
Second Tier Tabs | No | No | Complete | Complete
Ribbon | Yes | Yes | Complete | Complete
Tabs | Yes | Yes | - | -
Displaying Tabs | Yes | Yes | Complete | Complete
Minimizing the Ribbon | No | No | Complete | Complete
Tab Scrolling | No | No | Complete | Complete
Group | Yes | Yes | - | -
Displaying Groups | Yes | Yes | Complete | Complete
Dialog Box Launchers | Yes | Yes | Complete | Complete
Controls | Yes | Yes | - | -
Displaying Controls | Yes | Yes | Complete | Complete
Control Layouts | Yes | Yes | Complete | Complete
Control Labels | Yes | Yes | Complete | Complete
Control Behaviors | Yes | Yes | Complete | Complete
Ribbon Resizing | Yes | Yes | - | -
Defining Groups for Ribbon Resizing | Yes | Yes | Complete | Complete
Collapsed Group Behavior | Yes | Yes | Complete | Complete
Defining Group Combinations for Ribbon Resizing | Yes | Yes | Complete | Complete
Quick Access Toolbar | Yes | Yes | - | -
Displaying the Quick Access Toolbar | Yes | Yes | Complete | Complete
Customizing the Quick Access Toolbar | No | No | Complete | Complete
Displaying Many Controls in the Quick Access Toolbar | No | No | Complete | Complete
Visual Appearance | Yes | Yes | - | -
Application Button | Yes | Yes | Complete | Complete
Position of UI Elements | Yes | Yes | Complete | Complete
Quick Access Toolbar | Yes | Yes | Complete | Complete
Application Title Bar | Yes | Yes | Complete | Complete
Tabs | Yes | Yes | Complete | Complete
Ribbon Background | Yes | Yes | Complete | Complete
Groups | Yes | Yes | Complete | Complete
Scrollbars | No | No | Complete | Complete
Status Bar | No | No | Complete | Complete
File Tab | No | No | Complete | Complete
Keyboard Access | Yes | Yes | - | -
Displaying KeyTips | Yes | Yes | Complete | Complete
Dismissing KeyTips | Yes | Yes | Complete | Complete
Keyboard Navigation | Yes | Yes | Complete | Complete
KeyTip Size and Positioning | Yes | Yes | Complete | Complete
Backstage View KeyTips | Yes | Yes | Complete** | Complete**
KeyTips for Collapsed Groups | Yes | Yes | Complete | Complete
Contextual Tabs | No | No | - | -
Selecting Contextual Tabs When Inserting a New Object | Yes* | Yes* | Complete | Complete
Showing Contextual Tabs After Selecting An Existing Object | Yes* | Yes* | Complete | Complete
Contextual Tab Labels | Yes* | Yes* | Complete | Complete
Galleries | No | No | - | -
Displaying Galleries | Yes* | Yes* | Complete | Complete
In-Ribbon Gallery Navigation Arrows | Yes* | Yes* | Complete | Complete
Displaing Expanded In-Ribbon Galleries | Yes* | Yes* | Complete | Complete
Resizing Expanded In-Ribbon Galleries | No | No | Complete | Complete
Gallery Filters | No | No | Complete | Complete
Mini Toolbar | No | No | - | -
Displaying the Mini Toolbar | Yes* | Yes* | Complete | Complete
Dismissing the Mini Toolbar | Yes* | Yes* | Complete | Complete
Controls Displayed on the Mini Toolbar | Yes* | Yes* | Complete | Complete
Displaying the Mini Toolbar with Context Menus | Yes* | Yes* | Complete | Complete
Previewing Context Menu Control Actions | No | No | Not Implemented | Not Implemented
ScreenTips | Yes | Yes | - | -
Displaying ScreenTips | Yes* | Yes* | Complete | Complete

* Subsection is required only if its optional parent section is implemented.

** Key tips on Backstage view work for top-level buttons and tabs.

Ribbon UI Guideline Implementation Hints

While Actipro Ribbon does meet all the required guidelines, there are some items in the guidelines out of our control that you should be made aware of when developing your ribbon user interface. Many of these are listed in the Best Practices portions of the guidelines document. We've compiled a list of the other items not in the Best Practices portions below to help you fulfill all the requirements and recommendations. Our comments are listed in italics after each item.

  • Accessing Document Level Command UI
    • The Office 2007 UI application button must use the traditional application menu. The Office 2010 UI File tab may use either the traditional application menu or the Backstage view.
  • Backstage View
    • Tab Pane Requirements
      • 1. The first tab MUST be selected whenever the user clicks on the File Tab. The tab that was selected in the Backstage View when it was last closed MUST NOT be selected when it is next opened, unless it is the first tab.
        This can be done as in our samples by handling the Ribbon.IsApplicationMenuOpenChanged event and setting the Backstage.SelectedItem property.
  • Application Menu
    • Displaying the Application Menu
      • 4. The Application Menu MUST display controls for performing actions on the entire document like New, Open, Save, Save As, Print, Send, and Close.
        Be sure to include these basic document commands in your application menu's menu items.
      • 7. The right pane SHOULD display a list of recent documents if applicable.
        You can use our RecentDocumentMenu control for showing a list of recent documents.
      • 10. Vertical scrollbars MUST NOT be displayed for either the left or right pane of the Application Menu.
        Be sure that whatever you place in the right pane, it does not have vertical scrollbars.
  • Ribbon
    • 2. The Ribbon MUST NOT coexist with top-level menus and toolbars.
      Don't use any other main menus or toolbars when using a ribbon user interface.
    • 4. The Ribbon MUST be positioned at the top of the application window in a space that is dedicated to displaying the Ribbon.
      Place the Ribbon control at the top of the containing window.
    • 5. The Ribbon MUST NOT be displayed on either side of the application window or at the bottom of the application window.
      Place the Ribbon control at the top of the containing window.
    • 11. The Ribbon MUST extend the full width of the application window at all times.
      Ensure that the Ribbon control stretches across the full width of the containing window.
  • Tabs
    • Displaying Tabs
      • 4. The tab selected on the Ribbon MUST NOT automatically switch as a result of user selections made in the document (except as noted in the Contextual Tabs section).
        Don't programmatically change the selected tab except under the conditions in the Contextual Tabs section.
    • Minimizing the Ribbon
      • 11. The Ribbon MUST be minimized when the application is opened if the Ribbon was minimized when the application was last closed.
        You must persist whether the ribbon was minimized when your application was last closed.
      • 12. The Ribbon MUST NOT be minimized when the application is opened for the very first time.
        Don't initialize your ribbon to be minimized the first time your application is run.
  • Groups
    • Displaying Groups
      • 3. Controls displayed in a group MUST NOT change as a result of selection. If a control is not active, then the control MUST be grayed out, rather than removed from the group.
        Don't add or remove controls from a group based on the selection in the document.
    • Dialog Box Launchers
      • 5. Dialog Box Launchers MUST NOT execute a command that modifies a selection in the document. Dialog Box Launchers MUST only provide access to additional controls by opening a dialog box or task pane.
        Only open dialog boxes or task panes when a dialog box launcher button is pressed.
  • Controls
    • Displaying Controls
      • 7. Both the menu and button portion of split button controls MUST be disabled on the Ribbon if all of the items in the menu are inactive.
        Because of the way WPF commands work, the SplitButton control only examines child menu items if a command is assigned to its Command property. So as long as you have a command set to the SplitButton this functionality will work. If you need to use a temporary command while prototyping, use ApplicationCommands.NotACommand.
    • Control Labels
      • 3. Text labels for controls in the Ribbon MUST NOT use ellipses to indicate that a dialog box will be displayed.
        Don't add ellipses to any control labels.
    • Control Behaviors
      • 1. For large split button controls, clicking on the icon MUST always perform the default action for the control (i.e., either the first item in the menu or the most recently used item from the menu).
        Always make the split button click perform a command of an item that appears in its drop-down menu.
  • Ribbon Resizing
    • Defining Groups for Ribbon Resizing
      • 7. Groups SHOULD have three – four predefined variants to provide a smooth transition between group variants when the application window is horizontally resized.
        Use Actipro Ribbon's powerful variant features to easy make variants for your groups and controls.
    • Collapsed Group Behavior
      • 6. Clicking outside a collapsed group displayed below the Ribbon MUST NOT dismiss or clear the current selection of objects or text in the document.
        Set the Ribbon.TargetContentContainer property to your document container area and Ribbon will handle this for you.
    • Defining Group Combinations for Ribbon Resizing
      • 13. The entire Ribbon SHOULD completely disappear when the application window is less than 300 pixels wide and 250 pixels tall to provide more space for displaying the document.
        Set the Ribbon.CollapseThresholdSize property to specify the size a which the ribbon collapses if the Ribbon.IsCollapsible property is set to true.
  • Quick Access Toolbar
    • Displaying the Quick Access Toolbar
      • 5. The controls on the Quick Access Toolbar MUST NOT dynamically change when different tabs are selected in the Ribbon or when different objects are selected in the document.
        Don't programmatically change the controls on the QAT based on the selected tab or objects in the document.
      • 18. If the Quick Access Toolbar is displayed below the Ribbon when the application is closed, then the Quick Access Toolbar MUST be displayed below the Ribbon when the application is next opened.
        Restore the previous location of the QAT each time your application is loaded. You can set the Ribbon.IsQuickAccessToolBarBelowRibbon property.
  • Visual Appearance
    • Status Bar
      • 2. If the status bar both displays status information and contains view changing controls, then it MUST be divided into two sides. The left side of the status bar MUST display status notifications. The right side of the status bar MUST display view changing controls.
        See the topic on StatusBar Styles to learn how to apply both styles to items.
      • 4. The status bar MUST be no taller than approximately 23 pixels at 96 dpi.
        Keep the height equal to a regular small-sized control.
  • Keyboard Access
    • Displaying KeyTips
      • 5. Every control MUST have a KeyTip unique to its tab. There MUST NOT be any duplicate KeyTips for any controls on the same tab.
        This really applies to any key tip scope, including menus.
  • Contextual Tabs
    • Selecting Contextual Tabs When Inserting a New Object
      • 3. If Contextual Tabs are available for an object, they MUST be selected when a new object is inserted into the document if the new object is selected (or has keyboard focus) after being inserted.
        Always select the first tab within the appropriate contextual tab group in this scenario.
      • 4. If there is more than one Contextual Tab available for the object, the leftmost Contextual Tab MUST be selected.
        Always select the first tab when selecting a tab in a contextual tab group.
      • 6. Contextual Tabs MUST disappear when the object is no longer selected.
        Deactivate the contextual tab group when it is no longer needed.
      • 8. If more than one object type with associated Contextual Tabs can be selected at once, then all relevant Contextual Tabs MUST be displayed at the same time.
        Actipro Ribbon supports the display of more than one contextual tab group at the same time.
    • Showing Contextual Tabs After Selecting An Existing Object
      • 1. Contextual Tabs MUST be available when the user selects an existing object in the document, but the Contextual Tabs MUST NOT become selected. The currently selected tab MUST continue to be selected in the Ribbon.
        You can activate a contextual tab group but don't set select any of its tabs in this scenario.
      • 2. Contextual Tabs MUST NOT be automatically selected when an existing object is selected in the document. Users MUST click the Contextual Tab for it to be selected.
        Don't select a contextual tab programmatically in this scenario.
      • 3. Contextual Tabs SHOULD be selected when a user double-clicks on an existing object in the document.
        Do select a contextual tab programmatically in this scenario.
      • 4. If a Contextual Tab is selected in the Ribbon when a user deselects and reselects the same object (or type of object) in the document without performing any other action, then the Contextual Tabs SHOULD be reselected.
        You can track the contextual tab groups that you display and whether to reselect them upon redisplay or not.
  • Mini Toolbar
    • Displaying the Mini Toolbar
      • 2. The Mini Toolbar MUST NOT be displayed when text is selected with the keyboard.
        Only show the mini-toolbar when selections are made using the mouse.
    • Displaying the Mini Toolbar with Context Menus
      • 13. The ability to turn off the Mini Toolbar SHOULD be provided in the application’s options. This option SHOULD NOT turn off the Mini Toolbar displayed with context menus. The Mini Toolbar SHOULD always be displayed with context menus.
        When you add such an option in your application, don't execute any code that would show the mini-toolbar following a selection.

Microsoft Office User Interface is subject to protection under U.S. and international intellectual property laws and is used by Actipro Software LLC under license from Microsoft.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

This topic contains troubleshooting data specific to the Ribbon product.

Note Note
For some more troubleshooting information that relates both to this product as well as other WPF Studio products, please see the more general TroubleShooting topic.

This topic contains these sections:

  • FileNotFoundException or DirectoryNotFoundException When Specifying Bitmap Image Sources
  • RibbonWindow Border Bottom is Clipped in VS 2012
  • Ribbon Shows in Designer but Disappears at Run-Time
  • Ribbon Menus Are Anchored in the Incorrect Location

FileNotFoundException or DirectoryNotFoundException When Specifying Bitmap Image Sources

If you use relative paths for your bitmap image sources, you might encounter a FileNotFoundException or DirectoryNotFoundException in some cases. This exception can occur behind the scenes where the image is being reloaded outside of its original XAML context and thus can lose its contextual information for determining a relative path. Using an absolute path via standard WPF pack syntax allows the image to be loaded properly in any scenario.

Many of the Ribbon controls like the buttons use the DynamicImage control in their templates, which is a Shared Library control that allows for disabled buttons to render their images in grayscale. Please see the DynamicImage topic for more detailed information on this exception and exactly how to resolve it.

RibbonWindow Border Bottom is Clipped in VS 2012

For some reason that we haven't been able to determine yet, RibbonWindow's bottom border may be clipped 3-4 pixels at the bottom, but only when the Visual Studio 2012 debugger is attached or when the application is targeting .NET 4.5. If VS 2010's debugger is attached or if a .NET 4.0 application is run directly from explorer, RibbonWindow continues to render everything correctly.

We are going to be working on reimplementing RibbonWindow's code that allows it to render WPF content in the window's non-client area and hope to solve the issue in this particular scenario soon.

Ribbon Shows in Designer but Disappears at Run-Time

This scenario could happen if you accidentally set a Width or Height on the Ribbon control or one of its containers that causes the Ribbon to be smaller than the CollapseThresholdSize. When the Ribbon becomes smaller than CollapseThresholdSize at run-time and IsCollapsible is set to true, the Ribbon will hide. This feature meets one of the ribbon requirements.

This scenario is most likely to occur when you are adjusting control layouts in the designer and adjust the Ribbon or a parent container's size accidentally.

To resolve this issue, simply remove any explicit Width or Height setting on the Ribbon or a parent container that is causing the Ribbon's size be be smaller than CollapseThresholdSize. Alternatively, change IsCollapsible to false.

To help identify when this scenario is occurring, we have added a message that overlays the Ribbon in the Visual Studio designer and warns you that the current size will prevent the ribbon from displaying at run-time (since it will be collapsed). When you see that message, please follow the steps above to resolve the issue and remove the message.

Ribbon Menus Are Anchored in the Incorrect Location

This can occur when you are using a tablet PC or drawing tablet. The menu placement behavior will differ depending on whether the tablet support is configured for left-handed or right-handed use. This was designed so that menus do not appear under the user's hand.

To resolve this issue, simply change the tablet support configuration to left-handed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Shell controls allow for easy folder and file browsing. While the product comes packed with a pre-built implementation for the Windows shell that mimics Windows Explorer, the controls are fully customizable, allowing you to filter or change the folders/files presented. Or build your own shell service to support other files systems, such the remote side for a FTP client.

The ShellTreeListBox control presents a shell folder hierarchy in a tree structure. It is often paired with a ShellListView control, which shows the contents of a selected folder using column-based property display. Both controls support tool tips, context menus, and renaming.

All of the UI found in the Shell controls is native WPF, even the context menus. Unlike competitive products with interop-based user interfaces, the Actipro Shell controls don't have any airspace or focus issues, and every bit of UI can be fully-themed or even customized with XAML data templates.

Features

ShellTreeListBox Control

  • Displays a shell object hierarchy in a tree structure, just like in Windows Explorer.
  • Designed as a standalone control, so it can be used to build 'Browse for Folder' dialogs or can be paired with other shell controls to build a robust folder browser UI.
  • Uses the Actipro shell objects framework with built-in mechanisms to mimic what you see in Windows Explorer, including all non-file system objects.
  • Set a root folder multiple ways (including path) and optionally show the root folder node.
  • Optional default root folder that mimics Windows Explorer's root with Quick Access, This PC, etc.
  • Specify a special root folder (i.e. This PC, Desktop) via an easy-to-use enumeration.
  • Optionally display files and links.
  • Icons, overlay icons, name, and tooltip are data-driven from shell objects and can be customized.
  • Filter out shell objects provided by the shell service, or even add custom ones.
  • Customizable context menu that optionally auto-populates for Windows shell objects.
  • In-line renaming feature that optionally renames Windows shell objects.
  • Selected shell object can be data-bound directly or via a user-friendly string path.
  • Use data templates to alter the appearance of nodes.
  • Icons scale to use more detailed assets properly in high-DPI scenarios.
  • Inherits the TreeListBox control from Actipro Grids and thus contains the vast feature set and configuration mechanisms found in that control.

ShellListView Control

  • Displays a detailed column-based flat list of shell objects within a designated folder.
  • Alternatively use other layout modes that display various sized items in wrapping lists.
  • Designed as a standalone control, and can be paired with other shell controls to build a robust folder browser UI.
  • Uses the Actipro shell objects framework with built-in mechanisms to mimic what you see in Windows Explorer, including all non-file system objects.
  • Set a root folder multiple ways, including direct shell object, path, or special folder kind enumeration.
  • Each column displays properties such as name, date modified, type, size, or others that come directly from the shell.
  • The customizable shell service determines which columns to show for the current root folder.
  • Optionally display folders, files, and links.
  • Icons, overlay icons, thumbnail images, name, and tooltip are data-driven from shell objects and can be customized.
  • Filter out shell objects provided by the shell service, or even add custom ones.
  • Customizable context menu that optionally auto-populates for Windows shell objects.
  • In-line renaming feature that optionally renames Windows shell objects.
  • Single or multiple selection modes.
  • Use data templates to alter the appearance of column headers or cells.
  • Icons scale to use more detailed assets properly in high-DPI scenarios.
  • Inherits the TreeListView control from Actipro Grids and thus contains the vast feature set and configuration mechanisms found in that control.

Shell Objects Framework

  • A framework of objects that support shell (folder, file, and link) hierarchies.
  • Includes a complete implementation of shell objects that operate directly on the Windows shell.
  • Shell objects track name, kind, icons and overlays, thumbnail images, multiple path variations, tool tip, and various capabilities.
  • The shell service is the primary point where the entire shell object hierarchy can be customized, allowing you to filter results or add custom shell objects.
  • The shell service also manages which properties are available on the object and accesses their values.
  • Create a custom shell service and shell objects to use the Actipro shell controls for browsing things like remote file systems in FTP clients, etc.
  • Use the shell objects framework independent of UI controls to inspect a file system hierarchy programmatically.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The Shell Object Framework provides a managed way to access a file system shell. A Windows shell service is included and custom shell services can be written to access other file system shells.

Various shell user interface controls in the product like ShellTreeListBox use the Shell Object Framework to determine what to display and how to interact with shell objects/properties.

Shell Objects

Shell objects represent a folder, file, or link from a shell service. For instance, our Windows shell service implementation creates shell objects to represent the folders, files, and links found on your PC.

See the Shell Objects topic for more information.

Shell Services

A shell service creates and interacts with shell objects, and is the main customization point for interfacing with a file system such as the Windows shell.

See the Shell Services topic for more information.

Custom Shell Objects

The built-in Windows shell functionality can be customized/extended. Or in other cases, completely custom shell objects and services can be written to support non-Windows shells (i.e. a remote file system in a FTP client).

See the Custom Shell Objects topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Shell Objects

Shell objects represent a folder, file, or link from a shell service. For instance, our Windows shell service implementation creates shell objects to represent the folders, files, and links found on your PC.

Each shell object implements the IShellObject interface and provides its name and path (in several forms), kind, icons, thumbnail images, tool tip, and children.

When making your own custom shell object class, it is helpful to use the ShellObjectBase class as a base class, since it implements a lot of the core required functionality. Then you simply override properties and methods as appropriate.

This topic contains these sections:

  • Names and Paths
  • Kind
  • Icons and Overlays
  • Thumbnail Images
  • Tool Tip
  • Children
  • Creating a Child Folder
  • Renaming
  • Watching
  • Wrapping Another Shell Object

Names and Paths

Due to how shell objects can appear in multiple locations in UI such as within a file explorer, there are several name and path properties that handle various usage scenarios as explained below.

Name

The Name property returns the name of the object when it is displayed in trees and lists.

Some examples are "Foo.txt" for a file, or "OneDrive" for the system's OneDrive folder.

File System Path

The FileSystemPath property returns the path to the object if it is part of a file system. The property will return null for any virtual object, such as "This PC", that is not part of the file system.

An example is "C:\OneDrive" for the system's OneDrive folder.

Editing Name

The EditingName property returns the full user-friendly editing name of the shell object, if available. This value is usually the same as FileSystemPath for file system objects, except that it can also return a special value to identify special shell objects. Think of the editing name as the text that you see when you enter edit mode in the Windows Explorer breadcrumb.

Some examples are "OneDrive" for the system's OneDrive folder, but "C:\OneDrive" for the same folder accessed through the C: drive. Objects like This PC will return an editing name of "This PC".

Parsing Name

The ParsingName property returns the full parsing name of the shell object, if available. This value is usually the same as FileSystemPath for file system objects, except that it can also return a special syntax to identify special shell objects. This value is not ever shown in UI, but is intended to reduce ambiguity when locating shell objects.

Some examples are "::{20D04FE0-3AEA-1069-A2D8-08002B30309D}" for the This PC folder, and "C:\OneDrive" for the system's OneDrive folder.

Relative Parsing Name

The RelativeParsingName property returns the parent-relative parsing name of the shell object, if available. This value is usually the same as Name, except that it can also return a special syntax to identify special shell objects. This value is not ever shown in UI, but is intended to reduce ambiguity when locating shell objects.

Some examples are "::{018D5C66-4533-4307-9B53-224DE2ED1FE6}" for the system's OneDrive folder, and "OneDrive" for the same folder accessed through the C: drive.

This property is used when building up a "full path" for Grids' TreeListBox. It is returned as the path segment for the shell object in the ShellObjectItemAdapter.GetPath method.

Kind

Shell objects are all various kinds of folders, files, or links. The Kind property returns an enumeration value of type ShellObjectKind, which covers the basic file system kinds and also things like special folders and libraries.

The IsFolder property returns if the shell object is any sort of folder (file system folder, library, etc.). The IsLink property returns if the shell object is a link to another shell object. If both of those properties return false, then the shell object is a file or virtual non-folder object.

Icons and Overlays

Shell objects provide several size variations of icons and optional related overlay icons, each of which may be used in various UI scenarios.

  • SmallIcon / IShellObject.SmallIconOverlay - The small icon, which is generally 16x16 size.
  • MediumIcon / IShellObject.MediumIconOverlay - The medium icon, which is generally 48x48 size.
  • LargeIcon / IShellObject.LargeIconOverlay - The large icon, which is generally 96x96 size.
  • ExtraLargeIcon / IShellObject.ExtraLargeIconOverlay - The extra large icon, which is generally 256x256 size.

The overlay icon can be used to indicate a "state" that overlays the normal icon. An example is that link shell objects show an arrow overlay.

Thumbnail Images

Shell objects provide several size variations of thumbnail images, each of which may be used in various UI scenarios.

  • MediumThumbnail - The medium thumbnail image, which is generally 48x48 size.
  • LargeThumbnail - The large thumbnail image, which is generally 96x96 size.
  • ExtraLargeThumbnail - The extra large thumbnail image, which is generally 256x256 size.

Thumbnail images can be used in a ShellListView control when its CanUseThumbnails property is true. In that case, a thumbnail image is used in certain larger layout modes when one is available. If no thumbnail image is available, an icon of the same size is used instead.

Tool Tip

Each shell object can return a tool tip to display when the mouse hovers over a UI item for the shell object. The tool tip content can be specified in the ToolTip property.

Children

The Children collection returns the children of the shell object. This collection is lazy-loaded on first call, using the shell service that was passed into the the shell object.

If you wish to know if the Children collection has been loaded already without already triggering a load, use the IShellObject.AreChildrenLoaded property.

The RefreshChildren method can be called to refresh the Children collection if it has already been loaded.

The CanHaveChildFolders property returns whether the shell object can possibly contain any child folders. This property will only return true for folder shell objects. Even some folder shell objects may return false if they know they don't currently have any child folders without a potentially-lengthy query.

Creating a Child Folder

The CanCreateChildFolder property returns whether the shell object can create a child folder. This property will only return true for folder shell objects.

The CreateChildFolder method can be used to create a child folder within the shell object. It is passed the name of the folder to create and returns whether the folder was successfully created.

Renaming

The CanRename property returns whether the shell object can be renamed. When this property returns true, some UI controls may allow features like inline renaming.

The shell object can be renamed by setting the Name property to a new value.

Watching

Watching is a feature where a shell hierarchy can receive change notifications so that it can update itself based on external factors. This feature is not generally invoked directly since UI controls will begin watching shell objects as they enter the UI.

The IsWatching property indicates if the shell object's hierarchy is currently being watched. The StartWatching method starts watching and the StopWatching method stops watching.

Wrapping Another Shell Object

Sometimes you might wish to wrap another shell object for which you don't have source. An example scenario of this is when you are using our Windows shell service to return Windows shell objects, but you want to convert a certain shell object to indicate it's a file instead of a folder. Since the "kind" properties don't have setters, this is an instance where you'd need to wrap the IShellObject returned by the Windows shell service with an IShellObject of your own, and change the returned values of a couple properties. This is where the ShellObjectWrapper class proves to be extremely handy.

ShellObjectWrapper is a full IShellObject implementation, and is passed another IShellObject in its constructor. By default, it fully wraps the passed-in IShellObject, returning the same property values, executing the wrapped object's methods, etc. All the ShellObjectWrapper members are declared as virtual though, which allows you to easily override specific ones while leaving the rest to operate normally.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Shell Services

A shell service creates and interacts with shell objects, and is the main customization point for interfacing with a file system such as the Windows shell.

All shell services implement the IShellService interface, which defines the members needed to drive the user interface and behavior functionality in UI controls like ShellTreeListBox.

This topic contains these sections:

  • Built-In Windows Shell Service
  • Using Independently of UI
  • Creating an Object's Children
  • Creating an Object for a Parsing Name
  • Getting an Object's Full Path
  • Creating an Object's Properties
  • Getting an Object's Property Value
  • Comparing Objects Using a Property

Built-In Windows Shell Service

The Shell Object Framework comes with a pre-built WindowsShellService class for the Windows operating system shell. This shell service wraps up all the native Win32 API and COM calls needed to interface with the full Windows shell. This functionality provides much more than what you can achieve with standard .NET System.IO namespace features, including full access to virtual folders/objects and libraries in the shell, system icons, etc.

An instance of the WindowsShellService class is set as the default shell service for the ShellTreeListBox and ShellListView controls. This allows those UI controls to support working with the Windows shell out of the box.

All of the methods on WindowsShellService are virtual, allowing you to override and customize their results as appropriate.

Using Independently of UI

While shell services are harnessed to drive the user interface of the shell controls, they and the related shell objects can be used completely independently of any user interfaces.

They fully support calls to any of their members, allowing you to programmatically examine shell folder and file hierarchies, or properties of shell objects. This is expecially useful for working with the WindowsShellService, since its implementation provides shell data not available in the System.IO namespace.

Creating an Object's Children

The CreateObjectChildren method creates the collection of child shell objects for the specified parent shell object.

This method is invoked when the ShellObjectBase.Children property is first accessed, which often occurs as the parent shell object is being expanded in a tree control, or is set as the root shell folder of a list control. The method's results are used to construct the collection returned by that property.

Only shell folders (not files or links) should ever return children.

Creating an Object for a Parsing Name

The CreateObjectForParsingName method creates an IShellObject based on the specified full parsing name.

A full parsing name is a unique string that can identify a shell object, often the same as a file system path. See the Shell Objects topic for more information on parsing names.

Getting an Object's Full Path

The Grids tree controls like TreeListBox have their own concept of "paths." Those tree controls provide the foundation of several shell UI controls and thus inherit that "path" concept, which can be different from a shell file system path.

First, a tree control "path" segment is returned for each item in the tree. These paths can be combined with a path separator delimiter (often "\") to construct what is called a "full path." Thus a "full path" becomes a delimited string where each "path" segment in it, can be examined to walk down the tree hierarchy.

The Shell Objects topic has more information on paths. In general though, the IShellObject.RelativeParsingName is what is returned as the path segment for each shell object, used to build up a "full path."

Creating an Object's Properties

The CreateProperties method creates a collection of IShellProperty objects for the specified shell objects.

A ShellPropertyRequestKind enum value is also passed, specifying the kind of properties to return. These values are supported:

  • DefaultColumns - Return the properties that should show in a ShellListView control.
  • AllColumns - Isn't really used in UI but allows you to examine all available properties.

The IShellProperty interface defines a property, such as its key, canonical name (non-localized name), display name, default column width, column sort direction, column horizontal alignment, etc. The column-related properties are specifically for use within a ShellListView control.

If you wish to supply your own shell property results, make a class that implements the IShellProperty interface and return instances of that.

The most common properties returned for file system folders have these canonical names:

  • System.ItemNameDisplay
  • System.DateModified
  • System.ItemType
  • System.Size

Getting an Object's Property Value

The GetPropertyValue method examines an IShellObject to return a value for the specified IShellProperty.

This method is called when getting values to insert into ShellListView control cells.

Comparing Objects Using a Property

The CompareObjectsUsingProperty method compares two IShellObject instances using the specified IShellProperty.

This method is called when sorting a ShellListView control by a column, since each column represents an IShellProperty. The integer result from numerous calls to the method for various shell object pairs is used to determine their final sort order.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Custom Shell Objects

The built-in Windows shell functionality can be customized/extended. Or in other cases, completely custom shell objects and services can be written to support non-Windows shells (i.e. a remote file system in a FTP client).

This topic contains these sections:

  • Customizing the Windows Shell
  • Making a Completely Custom Shell

Customizing the Windows Shell

The built-in WindowsShellService class interacts with the Windows shell, attempting to return the same data you find in Windows Explorer.

There may be cases where you wish to filter out certain shell objects, change certain shell object properties, etc. from what is returned by default. In these cases, you need to make a class that inherits WindowsShellService and set the new instance to your shell UI control's DefaultShellService property.

Filtering Out Shell Objects

To filter out a shell object, override the CreateObjectChildren method and call its base method, which is a collection result. Iterate backwards through the collection and remove any IShellObject that you don't wish to have in the results. This change will affect all shell UI controls that use this shell service. If you wish to filter out shell objects for a single shell UI control, use the method described in the Grids Foundation and Item Adapter topic instead, since that only affects a single view.

Appending Shell Objects

To insert additional shell objects as the children of a parent shell object, override the CreateObjectChildren method and call its base method, which is a collection result. Make a class that inherits ShellObjectBase and will represent your additional shell object(s). Add one or more instances of that class to the list results and the additional shell object(s) should appear in all UI controls, unless they are filtered out at a view-level, as described in the Grids Foundation and Item Adapter topic.

Wrapping a Shell Object

If you wish to change actual properties of a Windows IShellObject (not the IShellProperty objects for a shell object), you must wrap the shell object. A handy wrapper ShellObjectWrapper class is provided specifically for this scenario. That class allows you to pass the IShellObject and it wraps all the calls to the shell object's members in virtual members of its own. For instance if you wanted to customize the icon returned for a shell object, you could override the appropriate icon properties. Or if you wanted to treat a certain shell folder as a file instead, you could override its IsFolder and Kind properties.

To insert this wrapper shell object into the shell object hierarchy, override the CreateObjectChildren method and call its base method, which is a collection result. Replace the original IShellObject in that collection with the related wrapper shell object.

Adding a Column to ShellListView

To add a column to the ShellListView control, create a new class that implements IShellProperty. Override the CreateProperties method and call its base method, which is a collection result, and add it to the collection.

Be sure to also override the GetPropertyValue method to handle returning values for the new IShellProperty if the property is a custom one.

Making a Completely Custom Shell

A custom-written shell service allows for working with any file system. A great example of this is the remote file system for a FTP client application. By using the Shell Object Framework to implement a custom shell service, the same shell UI controls can be used to render a Windows file system as well as another kind of custom file system.

To author a custom shell service, make a class that implements IShellService and set a new instance to your shell UI control's DefaultShellService property.

All of the members described in the Shell Services documentation topic should be implemented to ensure that the attached shell UI controls can behave as expected.

Use the ShellObjectBase class as a base class of your custom shell objects that are returned by your custom shell service. This base class helps reduce the amount of work you need to do to implement the IShellObject interface.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ShellTreeListBox Control

The ShellTreeListBox control presents a shell folder hierarchy in a tree structure, similar to what you see in the left side of Windows Explorer.

It is designed as a standalone control, so it can be used to build 'Browse for Folder' dialogs or can be paired with other shell controls to build a robust folder browser UI.

This topic contains these sections:

  • Getting Started
  • Default Shell Service
  • Root Shell Folder
  • Display Options
  • Selection
  • Item Templates
  • Context Menus
  • Inline Renaming
  • Horizontal ScrollBar Visibility

Getting Started

First, add references to the ActiproSoftware.Shell.Wpf.dll, ActiproSoftware.Grids.Wpf.dll, ActiproSoftware.Editors.Wpf.dll assemblies. All three assemblies are required for the Shell product. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

This sample code shows how a ShellTreeListBox control pointing to a default root shell folder can be added to any XAML:

XAML
Copy
​xmlns:shell="http://schemas.actiprosoftware.com/winfx/xaml/shell"
...
<shell:ShellTreeListBox RootSpecialFolderKind="Default" />

Default Shell Service

The DefaultShellService property is set to an instance of WindowsShellService by default. This allows the control to support Windows shell interaction out of the box.

Note Note
Please see the Memory Management topic for notes on handling shell service changes, since they sometimes use unmanaged resources.

Root Shell Folder

A root shell folder must be set on the control so that it can display that root folder's hierarchy. The root shell folder may be set via three different properties:

  • RootShellFolder - A IShellObject that must be a shell folder. Setting this property updates the RootShellFolderParsingName and RootSpecialFolderKind properties to remain in sync.
  • RootShellFolderParsingName - A parsing name (generally a file system path like "C:\Program Files") that indicates the root shell folder. Setting this property updates the RootShellFolder and RootSpecialFolderKind properties to remain in sync.
  • RootSpecialFolderKind - An enum value of type SpecialFolderKind that indicates a special Windows folder kind ("Computer", "ThisPC", and so on). Setting this property updates the RootShellFolder and RootShellFolderParsingName properties to remain in sync.

Note Note
Please see the Memory Management topic for notes on handling root shell folder changes, since they sometimes use unmanaged resources.

Display Options

There are several display option properties that affect features and functionality:

  • CanIncludeFiles - Whether files should be displayed. The default value is false. Set this to true to also show files in the tree.
  • CanIncludeLinks - Whether links should be displayed. The default value is false.
  • IsRootItemVisible - Whether the root item is visible. The default value is false.

Selection

Since this control inherits TreeListBox, it also inherits that control's SelectedItem, SelectedItems, and SelectionMode properties, and the SelectionChanged event. The "items" in this shell UI control are of type ShellObjectViewModel, as described in the Grids Foundation and Item Adapter topic, so the SelectedItem and SelectedItems properties will return a value of that type. The SelectionMode property determines whether single or multi-selection modes are enabled. For ShellTreeListBox, this is generally left as a single selection.

The ShellTreeListBox control also defines selection-related properties that are more specific to shell objects.

The SelectedShellObject property gets or sets the IShellObject that is selected in the control. This property is effectively the same as binding to the SelectedItem.Model property. It is often bound directly to the RootShellFolder property of a paired ShellListView control so that control tracks with the selection in the tree.

The SelectedShellObjectEditingName property gets or sets the selected shell object's full user-friendly editing name (commonly the same as the file system path), if known. This property can be bound to a path TextBox, which allows the user to type in a file system path (i.e. "C:\Program Files") and have the related shell object get selected in the tree.

Item Templates

The control uses this default DataTemplate in its ItemTemplate property:

XAML
Copy
​<DataTemplate>
    <shared:PixelSnapper VerticalRoundMode="RoundToEven">
        <Grid Margin="2,1" Background="Transparent" ToolTip="{Binding ToolTip, Mode=OneWay, IsAsync=True}">
            <Grid.ColumnDefinitions>
                <ColumnDefinition Width="Auto" />
                <ColumnDefinition Width="*" />
            </Grid.ColumnDefinitions>

            <Image Width="16" Height="16" VerticalAlignment="Center" Source="{Binding SmallIcon, Mode=OneWay}" />
            <Image Width="16" Height="16" VerticalAlignment="Center" Source="{Binding SmallIconOverlay, Mode=OneWay}" />
            <shell:ShellEditableContentControl Grid.Column="1" Margin="2,0,0,0" Content="{Binding Name, Mode=TwoWay}" IsEditing="{Binding IsEditing, Mode=TwoWay}" />
        </Grid>
    </shared:PixelSnapper>
</DataTemplate>

Change the ItemTemplate property to use an alternate DataTemplate. Also note that a custom ItemTemplateSelector can also be supplied for more programmatic selection of a view-model DataTemplate.

Context Menus

These properties help determine context menu behavior:

  • IsDefaultItemContextMenuEnabled - Whether the default context menu is enabled for shell objects. The default value is true.
  • IsNewFolderContextMenuItemAllowed - Whether a "New / Folder" menu item can be injected into the context menu for file system folders. The default value is false.

The context menus themselves are provided by the ShellObjectItemAdapter. Please see the Grids Foundation and Item Adapter topic for more information on how to customize the context menus for both the selection view-models and for the background of the control.

Inline Renaming

The control supports inline renaming if the IsRenamingEnabled property is true, which is the default value. Note that the shell object to be renamed must also support renaming via the IShellObject.CanRename property.

Renaming begins when single clicking on the shell object name, or by selecting an item and pressing F2.

Horizontal ScrollBar Visibility

The default ScrollViewer.HorizontalScrollBarVisibility attached property value for the control is Auto. This allows the control to scroll to the right when necessary. Set the attached property to Disabled to prevent scrolling and force the contents to fit within the control's width.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ShellListView Control

The ShellListView control shows the contents of a selected folder using column-based property display, similar to what you see in the right side of Windows Explorer.

This topic contains these sections:

  • Getting Started
  • Default Shell Service
  • Root Shell Folder
  • Display Options
  • Selection
  • Layout Modes
  • Item Templates
  • Navigation into Folders
  • Context Menus
  • Inline Renaming
  • Column Header Template
  • Properties
  • Sorting

Getting Started

First, add references to the ActiproSoftware.Shell.Wpf.dll, ActiproSoftware.Grids.Wpf.dll, ActiproSoftware.Editors.Wpf.dll assemblies. All three assemblies are required for the Shell product. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

This sample code shows how a ShellListView control pointing to a default root shell folder can be added to any XAML:

XAML
Copy
​xmlns:shell="http://schemas.actiprosoftware.com/winfx/xaml/shell"
...
<shell:ShellListView RootShellFolderParsingName="C:\" />

Default Shell Service

The DefaultShellService property is set to an instance of WindowsShellService by default. This allows the control to support Windows shell interaction out of the box.

Note Note
Please see the Memory Management topic for notes on handling shell service changes, since they sometimes use unmanaged resources.

Root Shell Folder

A root shell folder must be set on the control so that it can display that root folder's hierarchy. The root shell folder may be set via three different properties:

  • RootShellFolder - A IShellObject that must be a shell folder. Setting this property updates the RootShellFolderParsingName and RootSpecialFolderKind properties to remain in sync.
  • RootShellFolderParsingName - A parsing name (generally a file system path like "C:\Program Files") that indicates the root shell folder. Setting this property updates the RootShellFolder and RootSpecialFolderKind properties to remain in sync.
  • RootSpecialFolderKind - An enum value of type SpecialFolderKind that indicates a special Windows folder kind ("Computer", "ThisPC", and so on). Setting this property updates the RootShellFolder and RootShellFolderParsingName properties to remain in sync.

Note Note
Please see the Memory Management topic for notes on handling root shell folder changes, since they sometimes use unmanaged resources.

Display Options

There are several display option properties that affect features and functionality:

  • CanIncludeFiles - Whether files should be displayed. The default value is true.
  • CanIncludeFolders - Whether folders should be displayed. The default value is true.
  • CanIncludeLinks - Whether links should be displayed. The default value is true.
  • IsRootItemVisible - Whether the root item is visible. The default value is false, and this inherited value should NOT be changed for the ShellListView control.

Selection

Since this control inherits TreeListBox, it also inherits that control's SelectedItem, SelectedItems, and SelectionMode properties, and the SelectionChanged event. The "items" in this shell UI control are of type ShellObjectViewModel, as described in the Grids Foundation and Item Adapter topic, so the SelectedItem and SelectedItems properties will return a value of that type. The SelectionMode property determines whether single or multi-selection modes are enabled. For ShellListView, this is generally left as an extended multi-selection.

Layout Modes

The ShellListView control is in Details layout mode by default, which renders items in a vertical list with mutiple columns of data.

The LayoutMode property can be set to another ShellListViewLayoutMode enumeration value to change to an alternate layout mode, such as the LargeIcons layout mode pictured here:

Available layout modes include:

  • Details - A detailed vertical list mode with multiple column display.
  • List - A vertical list mode that renders a small icon and name.
  • SmallIcons - A horizontal list mode that renders a small icon and name.
  • MediumIcons - A horizontal list mode that renders a medium icon and name.
  • LargeIcons - A horizontal list mode that renders a large icon and name.
  • ExtraLargeIcons - A horizontal list mode that renders an extra large icon and name.

The MediumIcons, LargeIcons, and ExtraLargeIcons layout modes can optionally show thumbnail images in place of icons when they are available. Thumbnail images provide previews of the shell object's content. This functionality is enabled by setting the CanUseThumbnails property to true, which is the default.

Item Templates

The control uses multiple DataTemplate-based properties to determine how to render content in various layout modes. The proper DataTemplate is selected by the ShellListViewItemTemplateSelector instance that is set by default to the ItemTemplateSelector property.

The DataTemplate properties for each layout mode include:

  • DetailsLayoutModeItemTemplate - The DataTemplate to use as the ItemTemplate when the layout mode is Details.
  • ExtraLargeIconsLayoutModeItemTemplate - The DataTemplate to use as the ItemTemplate when the layout mode is ExtraLargeIcons.
  • LargeIconsLayoutModeItemTemplate - The DataTemplate to use as the ItemTemplate when the layout mode is LargeIcons.
  • ListLayoutModeItemTemplate - The DataTemplate to use as the ItemTemplate when the layout mode is List.
  • MediumIconsLayoutModeItemTemplate - The DataTemplate to use as the ItemTemplate when the layout mode is MediumIcons.
  • SmallIconsLayoutModeItemTemplate - The DataTemplate to use as the ItemTemplate when the layout mode is SmallIcons.

This is a sample DataTemplate set to the DetailsLayoutModeItemTemplate property:

XAML
Copy
​<DataTemplate>
    <shared:PixelSnapper VerticalRoundMode="RoundToEven">
        <Grid Margin="2,1" Background="Transparent" ToolTip="{Binding ToolTip, Mode=OneWay, IsAsync=True}">
            <Grid.ColumnDefinitions>
                <ColumnDefinition Width="Auto" />
                <ColumnDefinition Width="*" />
            </Grid.ColumnDefinitions>

            <Image Width="16" Height="16" VerticalAlignment="Center" Source="{Binding SmallIcon, Mode=OneWay}" />
            <Image Width="16" Height="16" VerticalAlignment="Center" Source="{Binding SmallIconOverlay, Mode=OneWay}" />
            <shell:ShellEditableContentControl Grid.Column="1" Margin="2,0,0,0" Content="{Binding Name, Mode=TwoWay}" IsEditing="{Binding IsEditing, Mode=TwoWay}" />
        </Grid>
    </shared:PixelSnapper>
</DataTemplate>

Navigation into Folders

The CanNavigateIntoChildFolders property determines whether double-clicking or pressing Enter on an item causes the control's RootShellFolder to be set to the IShellObject whose view-model item triggered the event. The default value is true.

When the ShellListView.RootShellFolder is two-way bound to a ShellTreeListBox.SelectedShellObject property, a navigation change into a folder will also update the selection in the paired ShellTreeListBox control.

Context Menus

The IsDefaultItemContextMenuEnabled property determines whether the default context menu is enabled for shell objects. The default value is true.

The context menus themselves are provided by the ShellObjectItemAdapter. Please see the Grids Foundation and Item Adapter topic for more information on how to customize the context menus for both the selection view-models and for the background of the control.

Inline Renaming

The control supports inline renaming if the IsRenamingEnabled property is true, which is the default value. Note that the shell object to be renamed must also support renaming via the IShellObject.CanRename property.

Renaming begins when single clicking on the shell object name, or by selecting an item and pressing F2.

Column Header Template

The control uses this default DataTemplate in its ColumnHeaderTemplate property:

XAML
Copy
​<DataTemplate>
    <TextBlock Text="{Binding Name}" TextTrimming="CharacterEllipsis" />
</DataTemplate>

Change the ColumnHeaderTemplate property to use an alternate DataTemplate.

Properties

The ShellListView control can show one or more columns, where each column represents an IShellProperty.

The Shell Services topic covers how a shell service provides the shell properties for the RootShellFolder. It also covers how the property values, that are displayed in the list view's cells, are provided. Both of these operations can be customized.

Sorting

Each IShellProperty defines a default sort order. When clicking on a ShellListView column header, the clicked column will be sorted by its default sort order. Clicking on the same column will reverse the sort order.

The Shell Services topic talks about how property value comparisons can be made to properly sort shell objects by a shell property.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Grids Foundation and Item Adapter

Both the ShellTreeListBox and ShellListView controls directly or indirectly inherit the TreeListBox control found in the Actipro Grids product. This base control is very extensible, performant, and provides an excellent foundation for the functionality of the two shell controls.

This topic contains these sections:

  • Assembly Reference and Licensing
  • Item Adapter
  • View-Model Creation
  • Context Menu Creation

Assembly Reference and Licensing

Since the Shell product does rely on types defined in the Grids and Shared libraries, all three of those assemblies must be included in your project references when using the Shell product.

Please note that although a licensed Shell product does allow you to redistribute the Grids assembly, you must still obtain proper developer licenses for the Grids product if you plan on using controls like TreeListBox or TreeListView independently of how they are utilized in the Shell product.

Item Adapter

The Grids tree controls have the concept of item adapters. An item adapter is a class that provides a bridge between the Grids tree controls and the data that is being displayed in them. The item adapter is necessary because it allows you to use data objects that are completely unknown to the Grids product, meaning the data objects can be defined in libraries that have no dependencies at all on UI frameworks or Actipro products.

Since some of the controls in the Shell product inherit Grids' tree controls, a ShellObjectItemAdapter class has been created to provide the bridge between the shell objects and the shell UI controls. An instance of this class is automatically set to the ItemAdapter property of the applicable shell UI controls.

It's important to note that since the core shell objects aren't really UI-related, the item adapter wraps them in a ShellObjectViewModel instance as they are added to a shell UI control. Therefore properties inherited from the Grids tree controls like RootItem, SelectedItem, and SelectedItems will reference the view-model objects that wrap the core IShellObject instances.

If any features of the ShellObjectItemAdapter need to be overridden, such as for features described below, create a custom class that inherits that class and set it to the ItemAdapter property of the shell UI control.

View-Model Creation

The CreateShellObjectViewModel method wraps the specified IShellObject with a ShellObjectViewModel.

This view-model class has properties on it for tracking expansion, editing, selection states, and has a Model property that returns the wrapped IShellObject.

It also has features for auto-returning an upsized icon in scenarios where higher DPI is detected. For instance when in 200% DPI, the ShellObjectViewModel.SmallIcon property will actually return the IShellObject.MediumIcon value so that the image remains crisp.

While the CreateShellObjectViewModel method doesn't generally need to be overridden, it is a good place to filter out shell objects at a view-level instead of at the model-level (via a shell service). This could be useful when sharing shell objects in multiple shell UI controls, but wanting to filter out certain kinds of shell objects for a specific shell UI control. To filter out a shell object, simply override this method and return null.

Context Menu Creation

The ShellObjectItemAdapter class has a couple methods for returning a context menu within a shell UI control. Override the methods to customize the context menus.

If a WindowsShellService is in use, then the default implementations of these methods will attempt to create context menu using data from the Windows shell. The context menus will generally have menu items whose Command is of type WindowsShellMenuItemCommand. This type lists the target shell objects and includes any string verb related to the command that was provided by the system.

GetItemContextMenu Method

The GetItemContextMenu method returns the ContextMenu for the specified collection of view-models. The collection is usually a single view-model.

GetBackgroundContextMenu Method

The GetBackgroundContextMenu method returns the ContextMenu for the background of a control with the specified root view-model. The "background" area is considered to be the control's whitespace area where no items are rendered.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Common Usage Scenarios

The various shell UI controls like ShellTreeListBox and ShellListView can be mixed and matched to fit into many useful scenarios.

This topic contains these sections:

  • File Explorer
  • Browse for Folder
  • FTP Client

File Explorer

A file explorer is where a ShellTreeListBox control is on the left side of the window, and a ShellListView control is on the right side, often with a splitter in between them. A path TextBox or breadcrumb control might also appear above both controls.

The path TextBox's Text property is bound to the ShellTreeListBox.SelectedShellObjectEditingName property, and the ShellListView.RootShellFolder property is bound to the ShellTreeListBox.SelectedShellObject property. A "Move Up" button's command could also be bound to the ShellTreeListBox.MoveUpCommand property.

Browse for Folder

A "Browse for Folder" dialog generally shows a ShellTreeListBox control with a "Make New Folder" button underneath it, alongside "OK" and "Cancel" buttons.

The ShellTreeListBox.IsNewFolderContextMenuItemAllowed property is usually set to true when there is a "Make New Folder" button available in UI. Bind that button to the ShellTreeListBox's SelectedItem.CreateChildFolderCommand property, which is defined on the selected ShellObjectViewModel. Then when the "OK" button is clicked, examine the ShellTreeListBox selection to see what was selected.

FTP Client

FTP clients generally have local and remote file system sides. The local side could use a file explorer setup like what is described above. The same thing could be configured for the remote side, with the only difference being that the remote side would have the ShellTreeListBox.DefaultShellService and ShellListView.DefaultShellService properties both pointing to a custom shell service that knows how to access and enumerate folders and files on the remote file system.

The beauty of this setup is that both sets of controls are configured the same way with only the default shell services being different to distinguish the data provided by local and remote file systems.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Memory Management

Shell objects and services often have to deal with unmanaged resources that need cleanup when they are no longer used. For instance, Windows shell objects internally maintain a system-specified PIDL reference.

The shell types used in this product are all disposable, and it's a best practice to manually dispose them after use. This helps keep memory from building up until those objects would later be automatically finalized.

The shell object framework can be used independently of shell UI controls, and shell objects can even be shared across multiple shell UI controls. Thus it's not really possible for us to know when to automatically dispose shell objects and services, and the objects must rely on you the developer to trigger disposal.

This topic contains these sections:

  • Shell Objects
  • Shell Services
  • Dispose Helper Methods on UI Controls

Shell Objects

A root shell object can be set to controls like ShellTreeListBox when its RootShellFolder property is set directly, or its RootShellFolderParsingName or RootSpecialFolderKind properties are set. In these cases, the shell object hierarchy likely has unmanaged resources being maintained.

When the UI control is no longer in use, the object that was set to the RootShellFolder property directly or indirectly should be disposed, and that property should be set to null.

Shell Services

A WindowsShellService instance is set by default to the DefaultShellService property of controls like ShellTreeListBox. The WindowsShellService doesn't create any unmanaged resources until it's actually used, but it's important to dispose the service.

When the UI control is no longer in use, the object that was set to the DefaultShellService property should be disposed, and that property should be set to null.

Dispose Helper Methods on UI Controls

Both the ShellTreeListBox and ShellListView controls have a DisposeShellInstances helper method that takes the recommended actions for you.

This method takes whichever IShellObject was set as the root shell folder and disposes it, while also resetting the control's RootShellFolder property back to null. Additionally, it takes the current DefaultShellService instance and disposes it, while also setting the DefaultShellService property to null. These steps should help ensure that unmanaged resources aren't memory-leaked.

Note Note
The DisposeShellInstances method should be called whenever that control and any paired controls will no longer be used.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor is a powerful text editing control that is packed with features for efficient code editing, including syntax highlighting, code outlining, parsing, line numbers, block selection, IntelliPrompt UI, split views, zooming, adornments, bi-di support, and much more. It has many of the same code editing features found in the Visual Studio code editor.

The SyntaxEditor control in the SDI Code Editor demo with a custom theme loaded

SyntaxEditor is built on top of our next-generation extensible text/parsing framework. While over 20 sample languages are available to get you started (such as C#, VB, XML, and more), custom language definitions can be developed and distributed with your applications as well. SyntaxEditor is designed for use in IDE (integrated development environment) applications, however there are many other applications out there than can take advantage of such a control.

Features

Editing Features

  • Unlimited undo/redo with ability to batch replace operations.
  • Multiple carets/selections supported, allowing for typing and edits to occur in several places within a document at the same time.
  • Block indent/outdent.
  • Automated line modification tracking.
  • Block (rectangular) selection and ability to prevent certain selection methods.
  • Edit multiple lines at the same time with block selection.
  • Line selection in the selection margin.
  • Clipboard operations and drag/drop natively supported (cut, copy, paste), with support for any DataObject.
  • Complete extended Unicode character, IME (Input Method Editor), and bi-directional editing support.
  • Over 100 edit actions including everything found in Visual Studio such as caret movement, selection, indenting, tabification, transposition, and more.
  • Block, none, and customizable smart auto-indent modes when pressing Enter.
  • Current line and delimiter (bracket) highlighting.
  • Delimiter (bracket) auto-completion.
  • Auto-case correct.
  • Code block selection (expansion/contraction).
  • Scrolling accelerates the longer scrollbar buttons are held down.

Appearance Features

  • Syntax highlighting of code based on classification mechanism, with ability to override lexer-based classifications.
  • Word wrap.
  • Whitespace display.
  • Optional line number, selection, outlining, ruler, and word wrap glyph margins.
  • Indicators (bookmarks, breakpoints, current statement, etc.).
  • Ability to create custom margins and place them anywhere in the editor view.
  • Ability to inject any custom adornment elements into the text area surface, or even inline between characters or view lines.
  • Fully compatible with XAML styles/templates.
  • Multiple font support.
  • Four-way or two-way split views.
  • Scrollbar visibility options, including an auto mode.
  • Customizable scrollbar tray areas that allow for embedding of custom controls next to scrollbars.
  • Animated zoom in and out, via keyboard, mouse wheel, or pinch.
  • Smooth inertia-based touch scrolling.
  • Mouse wheel vertical scrolling, with horizontal scrolling supported when holding Shift.
  • Squiggle lines for marking errors and spelling mistakes.
  • Complete support for both automatic and manual code outlining (folding), with customizable outlining node options.
  • Collapse (hide) regions of text independently of the outlining feature.
  • Indentation guides.
  • Single-line editing mode.

Text/Parsing Framework Features

  • Complete separation of the document model from the user interface.
  • Documents keep track of text via thread-safe versioned snapshots.
  • Snapshots are immutable and can be examined without fear of them changing.
  • Text offsets can be translated between snapshots.
  • Text changes support batching of replace operations.
  • Powerful snapshot text scanning classes that allow scanning by character, text, token, etc.
  • Load and save files, track modified flag.
  • Language definitions that can wrap all editor and parsing functionality for a specific language.
  • Ability to create custom language definitions using the feature-rich Language Designer application.
  • Free sample language definitions for common languages like Assembly, Batch files, C, C#, C++, CSS, HTML, INI files, Java, JavaScript, Lua, Markdown, MSIL, Pascal, Perl, PHP, PowerShell, Python, RTF, Ruby, SQL, VB.NET, VBScript, and XML.
  • Lexing of text into tokens, via a "dynamic" regex pattern-based lexer, "programmatic" hand-coded lexers, or other custom options.
  • Multi-threaded parsing capabilities.
  • Code fragment editing with full IntelliPrompt, such as editing a method body, when using advanced languages.
  • Categorization of text ranges into classifications (used to drive features like syntax highlighting).
  • Tagging mechanism that allows for marking of text ranges with custom data.
  • Line commenting with line and range options.
  • Text formatting capabilities.
  • Export to HTML and RTF.

IntelliPrompt Features

  • Session-based IntelliPrompt object model.
  • Completion lists that improve editing productivity and support complete word functionality.
  • Completion lists support filters (tabs/buttons), multiple matching algorithm options, ability to create custom matching algorithms, matched text highlights, description tips, and much more.
  • Quick info tips that can show detailed information about what is under the mouse, with automated mouse hover tracking.
  • Parameter info tips that can show multiple signature overloads and track the current parameter.
  • Code snippets that allow pre-defined text fragments to be inserted into the editor, and declared fields edited.
  • Lazy load images and content used in IntelliPrompt popups.
  • Optional mini-HTML markup supported for popup content.
  • NavigableSymbolSelector control that provides functionality similar to the VS type/member drop-downs.
  • Vector-based images for clarity in high DPI monitors.

Printing Features

  • WYSIWYG printing and print preview with print-specific format settings.
  • Optional document title, line number, word wrap glyph, and page number margins.
  • Ability to create custom margins and place them anywhere in a printed page.
  • Easy export to XPS.

Searching (Find/Replace) Features

  • All standard options available including match case, match whole word, search up, search in selection, etc.
  • Search pattern options include normal, regular expression, wildcard, acronum, and shorthand.
  • Regular expression searches support captures/substitutions.
  • Custom search patterns can be created.
  • Incremental search mode that automatically searches the entire document as characters are typed.
  • In-line search result highlights.
  • Search overlay pane integrated on the editor surface that responds to Ctrl+F, Ctrl+H, and F3 key variations.
  • EditorSearchView control that provides an implementation of a Visual Studio-like search dialog with animations.

Other Features

  • Designed to perform well with very large documents.
  • Support for read-only documents and specific text ranges within documents.
  • Macro recording and playback.
  • Text statistics that calculate statistics such as line, word, character counts as well as readability scores.
  • Custom input processing handlers that can intercept and handle key and mouse events.
  • Ability to easily create a highlighting styles Options dialog.
  • A TextStylePreview control that can be used to display highlighting styles on an Options dialog.
  • Abstracted and extensible object model design.

Free Add-ons

  • Actipro's advanced LL(*) Parser Framework can be used to build custom grammar-based parsers written in C#/VB using EBNF-like notation, customizable AST construction, advanced error handling/reporting, easy code injection, a complete debugger UI, and much more.
  • Integration with ANTLR-based DSL parsers, which can perform syntax/semantic parsing and AST building.
  • Integration with Irony-based DSL parsers, which can perform syntax/semantic parsing, AST building, and error reporting.

Optional Premium Add-ons

  • .NET Languages Add-on that provides automated IntelliPrompt, code outlining, parsing, AST construction, syntax error reporting, and more for C# and Visual Basic documents.
  • Python Language Add-on that provides automated IntelliPrompt, code outlining, parsing, AST construction, syntax error reporting, and more for Python documents.
  • Web Languages Add-on that provides automated IntelliPrompt, code outlining, validation, formatting, and more for XML documents, driven using XML schemas.
  • Web Languages Add-on also provides automated IntelliPrompt, code outlining, parsing, syntax error reporting, formatting, and more for JavaScript documents.
  • Web Languages Add-on also provides code outlining, parsing, syntax error reporting, formatting, and more for JSON documents.

Premium add-ons are sold separately from SyntaxEditor and its containing bundles.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Although SyntaxEditor is a massive product, it is pretty simple to get up and running fast. Use the tips in this topic to get started.

This topic contains these sections:

  • Understanding Abstraction (Interfaces and Implementation)
  • Read the Documentation Topics
  • Examine the Sample QuickStarts
  • Learn Terms
  • Use the 'How To' Topic
  • Add Assembly References
  • Copy Code from the Sample Project
  • Premium Language Add-ons

Understanding Abstraction (Interfaces and Implementation)

The entire product has been abstracted out into an interface-based object model. This provides for a more open object model that can easily be extended in a number of places.

Most main namespaces in the product contain interfaces, enumerations, structs, and static classes. Classes, both constructable and abstract, that implement the interfaces can be found in Implementation child namespaces of the namespaces that define the related interfaces.

This information is vital to know when examining the class library or reading through these documentation topics.

Read the Documentation Topics

This documentation file contains a lot of information about working with SyntaxEditor and the text/parsing framework. Whenever you have specific questions about a feature, please read through its documentation topic to search for answers.

The documentation is organized such that the text/parsing framework is described first. This framework is the core of the product and the user interface is built around it. Thus the user interface is described after the text/parsing framework. A language creation guide is included to help walk you through the process of creating your own syntax languages.

Note Note
If you have read through the documentation topics and samples and have found that some information is not clear enough, please e-mail us. We want to continue to improve the documentation and samples over time to thoroughly cover all functionality found in this enormous product, and we certainly appreciate your feedback.

Examine the Sample QuickStarts

The sample project contains a lot of full source samples called QuickStarts that focus on specific feature areas. When learning about a certain feature, it's best to examine the documentation on the feature and also look at any related QuickStarts in the sample project.

The QuickStarts contain a wealth of information on almost every product feature area, so be sure to look at them while working with the documentation.

A 'Getting Started' series of QuickStarts is included in the sample project that shows how to build a robust syntax language from start to finish. It is an extremely valuable sample when starting to build your own syntax languages.

Learn Terms

The Term Definitions topic provides an extensive list of terms used in this product. If you ever wonder what a term means, check that list.

Use the 'How To' Topic

The How To... topic provides a great jump off point for where to find information on performing the most common tasks with SyntaxEditor. It's a great resource.

Add Assembly References

Once you are ready to add SyntaxEditor to your own application, you'll need to add references in your project to the proper assemblies. The assemblies should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Look at the Assemblies and Add-on Licensing topic for details on the appropriate assemblies to reference in your project.

Copy Code from the Sample Project

We encourage you to copy and use any code from our sample project, including sample language definitions. It will really help you implement features in a matter of minutes instead of hours.

Note Note
Please note that some images in the sample project are copyrighted by Microsoft and we include them in our sample project for control demonstration purposes only!

Premium Language Add-ons

If you are going to use one of our premium language add-ons (sold separately), it is vital to follow all the steps in their Getting Started topics to ensure they operate correctly:

  • C# syntax language in the .NET Languages Add-on
  • Visual Basic syntax language in the .NET Languages Add-on
  • Python syntax language in the Python Language Add-on
  • XML syntax language in the Web Languages Add-on
  • JavaScript syntax language in the Web Languages Add-on

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Term Definitions

SyntaxEditor is no small product. It has an enormous object model and feature set. While it's easy to get started using it, it also allows for developers to do some very advanced things.

In this topic, we provide the complete list of categorized terms found in this product. If you ever wonder what a term means, use this topic to find the definition.

This topic contains these sections:

  • Text (General) Terms
  • Text (Exporters) Terms
  • Text (Lexing) Terms
  • Text (Parsing) Terms
  • Text (Regular Expressions) Terms
  • Text (Searching) Terms
  • Text (Tagging) Terms
  • Text (Undo) Terms

Text (General) Terms

Term | Description
Case Sensitivity | Indicates how letter matching is performed when parsing, and is represented by the CaseSensitivity enumeration.
Classification Type | A classification type (represented by the IClassificationType interface) is a categorization that can be applied to a range of text via an IClassificationTag tagger.
Classification Type Registry | A classification type registry (represented by the IClassificationTypeRegistry interface) provides a registry of IClassificationType instances.
Code Document | A code document (represented by the ICodeDocument interface) is a text document that also has a syntax language associated with it, providing additional functionality.
Example Text Provider | An example text provider (represented by the IExampleTextProvider interface) is an object that can stores a small code snippet showing many of the constructs for a specific language.
Line Commenter | A line commenter (represented by the ILineCommenter interface) is an object that has logic to comment out and uncomment lines of code using comment delimiters for a specific language.
Line Terminator | Indicates the character or characters used to end a line, and is represented by the LineTerminator enumeration.
Normalized Text Snapshot Range Collection | A normalized text snapshot range collection (represented by the NormalizedTextSnapshotRangeCollection class) is a collection that ensures all contained ranges are for the same snapshot and are guaranteed to be sorted and non-overlapping.
Offset | An offset is a zero-based integer index that refers to the location of a character within text.
Syntax Language | A syntax language (represented by the ISyntaxLanguage interface) is an object that provides access to services and functionality related to the parsing of a code language, such as C#, VB, HTML, etc.
Text Buffer Reader | A text buffer reader (represented by the ITextBufferReader interface) allows you to do very low-level fast scanning over some sort of text source, such as a string or text snapshot.
Text Change | A text change (represented by the ITextChange interface) is a single transaction that modifies a document and creates a new text snapshot. It consists of one or more operations.
Text Change Operation | A text change operation (represented by the ITextChangeOperation interface) is a single atomic replace operation that is performed within a text change. It may replace text, delete text, or insert text.
Text Change Options | Text change options (represented by the ITextChangeOptions interface) provide configurable options to a text change.
Text Change Type | A text change type (represented by the ITextChangeType interface) represents the type of text change, such as Typing, Paste, etc. Custom types can be created.
Text Document

A text document (represented by the ITextDocument interface) represents a textual document.

It always keeps a reference to its current text snapshot. Use the current snapshot to examine the contents of the document.

Text Formatter | A text formatter (represented by the ITextFormatter interface) is an object that has logic to adjust spacing and line terminators around the code for a specific language to beautify it.
Text Offset Tracking Mode | Text offset tracking modes (represented by the TextOffsetTrackingMode enumeration) indicate how an offset should be translated from one text snapshot to another.
Text Position | A text position (represented by the TextPosition structure) provides line and character information about a point in text.
Text Position Range | A text position range (represented by the TextPositionRange structure) represents a range of text positions, with a start and end value.
Text Range | A text range (represented by the TextRange structure) represents a range of offsets, with a start and end value.
Text Range Tracking Mode | Text range tracking modes (represented by the TextRangeTrackingModes enumeration) indicate how a text range should be translated from one text snapshot to another.
Text Snapshot

A text snapshot (represented by the ITextSnapshot interface) is an immutable copy of a document at a certain time. It can be scanned and parsed without the possibility of change via user edits.

All reading of a document is done on a snapshot of the document. The ITextDocument.CurrentSnapshot property always provides the most recent snapshot.

Text Snapshot Line | A text snapshot line (represented by the ITextSnapshotLine interface) represents a text line within a snapshot.
Text Snapshot Offset | A text snapshot offset (represented by the TextSnapshotOffset structure) points to a specific offset within a snapshot. It can be easily translated to other snapshots.
Text Snapshot Range | A text snapshot range (represented by the TextSnapshotRange structure) points to a specific text range within a snapshot. It can be easily translated to other snapshots.
Text Snapshot Reader | A text snapshot reader (represented by the ITextSnapshotReader interface) is used to scan through a specific snapshot and has many useful methods for navigating by token, word, etc.
Text Snapshot Reader Options | Text snapshot reader options (represented by the ITextSnapshotReaderOptions interface) provides configurable options to a text snapshot reader.
Text Statistics | Text statistics (represented by the ITextStatistics interface) examine text and provide numerous statistics on the text such as number of lines, characters, etc.
Text Version | A text version (represented by the ITextVersion interface) is a numeric version that tracks the sequence of changes made to a document. Each snapshot is related to a certain version.
Text Version Range | A text version range (represented by the ITextVersionRange interface) is an object that internally stores a text range for a certain text version. This version range can be translated to any other version or snapshot to get the related text range in that context.
Word-Break Finder | A word-break finder (represented by the IWordBreakFinder interface) is used to locate word breaks for a particular syntax language.

Text (Exporters) Terms

Term | Description
Text Exporter | A text exporter (represented by the ITextExporter interface) is an object that can export text to other output formats, such as HTML or RTF.

Text (Lexing) Terms

Lexer | A lexer (represented by the ILexer interface) scans text and tokenizes it, meaning that a series of tokens are assigned to text ranges that identifies in detail what the text represents.
Lexical Target | A lexical target (represented by the ILexerTarget interface) is an object that is passed to a lexer and is updated by the lexer during its execution to provide lexing results.
Lexical Scope | A lexical scope (represented by the ILexicalScope interface) defines how a parent lexical state can transition to another child lexical state and back.
Lexical State | A lexical state (represented by the ILexicalState interface) is a context in which certain text can be parsed into a set of tokens.
Lexical State ID Provider | A lexical state ID provider (represented by the ILexicalStateIdProvider interface) is a class that is useful for providing all the lexical state IDs for a language.
Lexical State Transition | A lexical state transition (represented by the ILexicalStateTransition interface) specifies a transition that can occur from one lexical state to another, typically in a separate language (i.e. HTML to CSS).
Mergable Lexer | A mergable lexer (represented by the IMergableLexer interface) is a lexer that supports transitioning into other languages that have mergable lexers.
Mergable Lexical Result | A mergable lexer result (represented by the MergableLexerResult class) provides information for the next token that has been read by a mergable lexer.
Mergable Token | A mergable token (represented by the IMergableToken interface) is a token that is created by a mergable lexer.
Mergable Token Lexer Data | Mergable token lexical parse data (represented by the IMergableTokenLexerData interface) is part of a mergable lexical parse result and gets assigned to mergable tokens.
Token | A token (represented by the IToken interface) is a span of text that has some sort of lexical parse data associated with it.
Token ID Provider | A token ID provider (represented by the ITokenIdProvider interface) is a class that is useful for providing all the token IDs for a language.
Token Set | A token set (represented by the ITokenSet interface) is a group of tokens that are returned by an token tagger.

Text (Parsing) Terms

Term | Description
Ambient Parse Request Dispatcher Provider | An ambient parse request dispatcher provider (represented by the AmbientParseRequestDispatcherProvider class) specifies an object that provides the default IParseRequestDispatcher to use, which allows for multi-threaded parsing.
Parse Data | Parse data (represented by the IParseData interface) specifies the data that is returned by an IParser to a document when parsing is completed.
Parse Error | A parse error (represented by the IParseError interface) specifies an error that was encountered when performing parsing.
Parse Error Level | A parse error level (represented by the ParseErrorLevel enumeration) specifies the severity of a parse error.
Parse Error Provider | A parse error provider (represented by the IParseErrorProvider interface) specifies an object that can return parse errors for a parsing operation. This interface is typically implemented by parse data objects.
Parser | A parser (represented by the IParser interface) specifies an object that can perform syntax and/or semantic parsing.
Parse Request | A parse request (represented by the IParseRequest interface) specifies an object that designates a request for a parsing operation, and can be queued by a parse request dispatcher
Parse Request Dispatcher | A parse request dispatcher (represented by the IParseRequestDispatcher interface) specifies an object that is capable of queuing up parse requests and performing them on worker threads.
Parse Error State | A parse error state (represented by the ParseRequestState enumeration) specifies the current state of a parse request, such as whether it is queued, executing, etc.
Parse Target | A parse target (represented by the IParseTarget interface) specifies an object that is notified with parse data results when a parsing operation completes.

Text (Regular Expressions) Terms

Term | Description
Character Class | A character class (represented by the CharClass class) specifies a set of character ranges.
Character Interval | A character interval (represented by the CharInterval structure) specifies a range of characters.

Text (Searching) Terms

Term | Description
Search Capture | A search capture (represented by the ISearchCapture interface) denotes a single regular expression capture made during a find operation.
Search Options | Search options (represented by the ISearchOptions interface) contains the settings used during find/replace operations, such as the text to find, whether to match case, etc.
Search Pattern Provider | A search pattern provider (represented by the ISearchPatternProvider interface) is an object that converts find/replace pattern syntax to a format that is compatible with the search engine. Built-it search pattern providers include normal, regular expression, wildcard, etc.
Search Result | A search result (represented by the ISearchResult interface) is a single result from a search operation that is included within a result set.
Search Result Set | A search result set (represented by the ISearchResultSet interface) is an object that provides the results of a search operation.
Search Operation Type | Indicates a type of search operation, such as find next or replace all, and is represented by the SearchOperationType enumeration.

Text (Tagging) Terms

Term | Description
Classification Tag | A classification tag (represented by the IClassificationTag interface) is a tag that specifies an IClassificationType, and when used in an editor, tells the editor how to syntax highlight text based on related highlighting styles.
Tag | A tag (represented by the ITag interface) is an object that can store data and be applied over a range of text via a tagger.
Tag Aggregator | A tag aggregator (represented by the ITagAggregator`1 interface) collects tags of a certain type from all the available taggers.
Tag Snapshot Range | A tag snapshot range (represented by the TagSnapshotRange`1 structure) specifies a text snapshot range and an ITag that is applied over the range.
Tag Version Range | A tag version range (represented by the TagVersionRange`1 structure) specifies a text version range and an ITag that is applied over the range.
Tagger | A tagger (represented by the ITagger`1 interface) provides tag snapshot ranges that are within specified snapshot ranges.
Tagger Provider | A tagger provider (represented by the ICodeDocumentTaggerProvider and ITextViewTaggerProvider interfaces) is a language service that can create taggers for documents/views that use the language.
Token Tag | A token tag (represented by the ITokenTag interface) is a tag that specifies an IToken.
Token Tagger | A token tagger (represented by the TokenTagger interface) is a special tagger that provides incremental lexing capabilities to an ILexer.

Text (Undo) Terms

Term | Description
Save Point Change Type | Indicates the save point change type (none, unsaved changes, or saved changes) for a line within the current snapshot of a document, and is represented by the SavePointChangeType enumeration.
Undoable Text Change | An undoable text change (represented by the IUndoableTextChange interface) is used to track information for an ITextChange that has been placed into the undo history.
Undoable Text Change Stack | An undoable text change stack (represented by the IUndoableTextChangeStack interface) is a stack that stores IUndoableTextChange entries for either the undo or redo stacks.
Undo History | An undo history (represented by the IUndoHistory interface) provides access to all the undo/redo functionality for an ITextDocument.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


How To...

Since the documentation for SyntaxEditor is quite large, this topic provides a quick jump off point for the most common tasks of working with the product.

This topic contains these sections:

  • Text Features
  • Parsing Features
  • IntelliPrompt Features

Text Features

How to get text from a document?

Immutable snapshots are what store the text for a document. Each ITextDocument points to its current text content via the CurrentSnapshot property.

The Documents, Snapshots, and Versions topic talks about some basic methods for getting the full text or substrings from a snapshot.

The Scanning Text Using a Reader topic talks about more advanced scanning of a snapshot's text, characters, tokens, and more.

How to make changes to a document?

Text changes can be made using a couple different methods, both described in the Text Changes and Operations topic. Batch changes that are flagged as a single undoable unit are fully supported.

How to load a document from or save a document to a file/Stream?

The text content of an ITextDocument can easily be saved to a file or Stream via methods described in the Loading and Saving Files topic.

How to convert between offsets and text positions?

The Offsets, Ranges, and Positions topic describes all the types of character indices used by the text framework and how to convert between them.

Why are offsets that I externally found not syncing up with document offsets?

Normal multi-line strings in Windows use both carriage return and newline characters as line terminators. When ITextDocument objects load text, they convert all line terminators to newline characters only. This helps with parsing performance.

The Line Terminators topic talks about why this is done and how to get document text back out using any common line terminator.

How to programmatically find and replace text?

The Low-Level Search Operations topic describes how to programmatically find/replace text using the lowest-level search object model.

How to perform an undo or redo?

The Undo History topic describes how to perform an undo or redo operation.

How to obtain statistics for snapshot text or a string?

The Text Statstics topic shows how to easy obtain a wealth of statistics about snapshot text or text within a String.

How to export a snapshot's text to HTML or RTF?

The Exporting to HTML / RTF topic describes how to export a snapshot's text to HTML or RTF format.

Parsing Features

How to comment or uncomment text in a document?

The Line Commenting topic demonstrates how to comment or uncomment text.

IntelliPrompt Features

How to display a completion list in response to the end user typing a '.', '<', etc.?

The Completion List topic contains several samples on how to display a completion list in response to user typing.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Assemblies and Add-on Licensing

SyntaxEditor is a bit unique in relation to our other WPF control products in that it requires several assemblies depending on which features and add-ons you use.

This topic contains these sections:

  • What is an Add-on?
  • Add-on Packaging
  • Assemblies and Cost

What is an Add-on?

An add-on is simply a term used to describe some sort of functionality that can optionally be added onto the main product.

Add-ons may include very advanced syntax language implementations that have features such as automated IntelliPrompt, etc. These sorts of add-ons are generally sold separately from SyntaxEditor or its containing bundles.

Three add-ons we include with SyntaxEditor are free assemblies for integrating SyntaxEditor with parsers created using Microsoft Oslo's Dataflow ('M' Language Definitions), Irony, and ANTLR parsing frameworks. These add-ons are optionally installed during setup.

Add-on Packaging

Add-ons can come in one or more assemblies. Often add-ons for a syntax language implementation involve two assemblies. One contains the core text/parsing (non-UI) implementation for language and the other provides UI-related functionality such as working with IntelliPrompt.

The reason add-on assemblies are split up in this way is that we have designed this SyntaxEditor framework to be multi-platform capable. This means that the core text/parsing assembly could be used in WPF, Windows Forms, ASP.NET, etc. Then each platform would have their own UI-related assembly that interacted with the user interface.

Assemblies and Cost

This list of assemblies indicates all of the assemblies related to SyntaxEditor, if they are required or optional, the related add-on (if any), and if they are included for free or sold separately from SyntaxEditor and its containing bundles.

Assembly | Required | Add-on | Cost | Description
ActiproSoftware.Shared.Wpf.dll | Yes | - | Included | Core framework for all Actipro WPF controls
ActiproSoftware.Text.Wpf.dll | Yes | - | Included | Core text/parsing framework for SyntaxEditor
ActiproSoftware.Text.LLParser.Wpf.dll | Yes | - | Included | Framework for building top-down text parsers that parse input left-to-right and construct a leftmost derivation.
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | - | Included | SyntaxEditor for WPF control
ActiproSoftware.Text.Addons.Antlr.Wpf.dll | No | ANTLR | Included | Integrates ANTLR-based parsers with syntax languages; optionally installed during setup
ActiproSoftware.Text.Addons.Irony.Wpf.dll | No | Irony | Included | Integrates Irony-based parsers with syntax languages; optionally installed during setup
ActiproSoftware.Text.Addons.DotNet.Wpf.dll | No | .NET Languages | Sold Separately | Core text/parsing for .NET languages
ActiproSoftware.Text.Addons.DotNet.Roslyn.Wpf.dll | No | .NET Languages | Sold Separately | Optional extensions to load binary assembly reflection data with Roslyn
ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll | No | .NET Languages | Sold Separately | SyntaxEditor for WPF advanced C# and VB syntax language implementations
ActiproSoftware.Text.Addons.JavaScript.Wpf.dll | No | Web Languages | Sold Separately | Core text/parsing for the JavaScript and JSON languages
ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll | No | Web Languages | Sold Separately | SyntaxEditor for WPF advanced JavaScript and JSON syntax language implementations
ActiproSoftware.Text.Addons.Python.Wpf.dll | No | Python Language | Sold Separately | Core text/parsing for the Python language
ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll | No | Python Language | Sold Separately | SyntaxEditor for WPF advanced Python syntax language implementation
ActiproSoftware.Text.Addons.Xml.Wpf.dll | No | Web Languages | Sold Separately | Core text/parsing for the XML language
ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll | No | Web Languages | Sold Separately | SyntaxEditor for WPF advanced XML syntax language implementation

Although the add-ons that are marked as sold separately are included with the WPF controls sample for demo purposes, licenses for them must be purchased separately if you would like to use them. However, the pricing on the add-ons is very affordable and licenses are all Enterprise licenses, meaning they cover your entire organization.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The text and parsing framework included with this product provide for complete separation from the user interface and can be reused across mutiple platforms.

This topic contains these sections:

  • Core Text Features
  • Syntax Languages
  • Lexing
  • Tagging
  • Parsing
  • Advanced Text Features

Core Text Features

The core text features presented in this portion of the documentation are essential knowledge for working with nearly every other portion of the product.

See the Core Text Features topic for more information.

Syntax Languages

Syntax languages are objects that provide access to services and functionality related to the parsing of a code language, such as C#, VB, HTML, etc.

See the Syntax Languages topic for more information.

Lexing

Lexing is the process of scanning text and breaking it up into meaningful tokens that can be examined by a higher-level parser.

See the Lexing topic for more information.

Tagging

Tagging is a generic mechanism that allows any sort of data to be associated with a text range. This tagged data can then be retrieved on-demand by tag aggregators. Tagging is the core mechanism behind features such as tokenization, classification (which in turn drives syntax highlighting when used in an editor), and more.

See the Tagging topic for more information.

Parsing

Parsing is the process of performing syntax and/or semantic analysis on a text, and outputting some sort of parse data, generally an AST. The parsing framework supports automated calling of parsers via worker threads following text changes. Any custom or third-party parser (such as ANTLR) can be called.

See the Parsing topic for more information.

Advanced Text Features

The text framework contains numerous advanced features that build upon the core text features, everything from a search object model to the exporting of HTML and RTF.

See the Advanced Text Features topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The core text features presented in this portion of the documentation are essential knowledge for working with nearly every other portion of the product.

This topic contains these sections:

  • Documents, Snapshots, and Versions
  • Offsets, Ranges, and Positions
  • Line Terminators
  • Snapshot Translation
  • Text Changes and Operations
  • Scanning Text Using a Reader
  • Loading and Saving Files

Documents, Snapshots, and Versions

Documents, snapshots, and versions are used to store text data. Documents allow for text updates, while a snapshot provides an immutable view of text within a document for a certain version that can be read.

See the Documents, Snapshots, and Versions topic for more information.

Offsets, Ranges, and Positions

There are several ways to reference the location of characters within a string or snapshot, each with their own benefits.

See the Offsets, Ranges, and Positions topic for more information.

Line Terminators

While the text framework can load text using any sort of standard line terminator character sequence, the framework internally tracks all line terminators as a single line feed character. Text can easily be exported back out with any line terminator.

See the Line Terminators topic for more information.

Snapshot Translation

Offsets and offset ranges can be translated from one snapshot to another using a feature called snapshot translation. Snapshots are immutable views of a document and are able to determine the changes made between any two snapshots for the same document. This allows for the locating of a certain offset or range of text in the current snapshot based on some offset/range created using an older snapshot, even with mutiple document changes being made in between the two snapshots.

See the Snapshot Translation topic for more information.

Text Changes and Operations

A large portion of the text framework is focused on the ability to make changes to document text. Multiple individual replace transactions, called text change operations, can be batched up into a single text change and performed together as a single modification.

See the Text Changes and Operations topic for more information.

Scanning Text Using a Reader

The text framework has very robust features built-in for scanning through snapshot text via the use of readers.

See the Scanning Text Using a Reader topic for more information.

Loading and Saving Files

It's very easy to load document text from a file, stream, or string. Likewise, document text can be saved back out to a file, stream, or string.

See the Loading and Saving Files topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Documents, Snapshots, and Versions

Documents, snapshots, and versions are used to store text data. Documents allow for text updates, while a snapshot provides an immutable view of text within a document for a certain version that can be read.

This topic contains these sections:

  • Looking at a Document's Current Text Data
  • Object Relationships
  • Memory Usage and Performance
  • Reading Text, Use Snapshots
  • Writing Text, Use Document
  • Multiple Snapshots and Snapshot Translation

Looking at a Document's Current Text Data

The ITextDocument interface has a CurrentSnapshot property that returns the "current" ITextSnapshot for the document.

Think of ITextSnapshot objects like .NET strings. They are immutable, meaning their contents cannot be changed, and they can be used across threads. Therefore you are able to examine and parse a snapshot without fear of its contents changing from some other operations in a separate thread.

There are multiple ways to examine text in a snapshot, some of the most common are described below.

Object Relationships

ITextDocument objects only store a reference to the "current" ITextSnapshot, meaning the snapshot the specifies the text contents of the document at this point in time.

Each snapshot is related to a single version. Therefore, each ITextSnapshot has a Version property that returns a reference to its ITextVersion. The ITextVersion has a version number.

A sequence of text changes made, showing how new snapshots and versions are created

As changes are made to a document, new snapshots and related versions are created. For instance a blank document would have a current snapshot with version 0. If the text "Actipro" was appended to the document, it would now have a current snapshot with version 1. If the first three characters were removed, the document would now have a current snapshot with version 2. And so on.

Essentially, the version increments with any change and provides the data needed for snapshot translation. Each snapshot references a single version and the snapshot contains a complete immutable copy of the text that is related to the version.

Memory Usage and Performance

After reading above that every change creates a completely new immutable copy of the document text in a snapshot, it would be conceivable to think that memory usage would be enormous and performance would suffer, especially for large documents.

Actually this is not the case at all. Snapshots are designed to share data as much as possible that is not different between consecutive snapshots. Besides that, once a snapshot is no longer referenced by your code, it and its contents drop out of memory. Therefore there really isn't much of a memory impact by adding the great features provided by snapshots.

It's also important to mention that snapshots and their creation are designed to be very fast. There is no performance decrease by using them.

Reading Text, Use Snapshots

Whenever you need to read or examine the contents of a document, get the ITextDocument.CurrentSnapshot and use the snapshot's various properties and methods.

These members on ITextSnapshot are related to reading text:

Member | Description
GetReader Method | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
GetSubstring Method | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
GetText Method | Returns the entire text of the snapshot using the specified LineTerminator for line ends.
GetWordText Method | Gets the text of the word at the specified offset.
Length Property | Gets the number of characters in the snapshot, excluding any carriage-returns but including newlines.
Lines Property | Gets the collection of ITextSnapshotLine objects, each of which represents a line in the snapshot.
Text Property | Gets the entire text of the snapshot using LineTerminator.CarriageReturnNewline for line ends, which is not intended to be used for parsing for classification reasons.

Writing Text, Use Document

Whenever making text changes to a document, thereby creating a new snapshot, use methods on the ITextDocument interface.

The Text Changes and Operations topic talks about making text changes in details. See that topic for information on modifying a document.

Multiple Snapshots and Snapshot Translation

As displayed by the diagram above, multiple snapshots can be active for a document at any given time. Sometimes it's useful to store an offset range of text that was parsed from a particular snapshot and at some later arbitrary time, see where the same range is in the "current" snapshot for a document.

This can easily be done and is really a neat feature provided by the snapshot/version design. See the Snapshot Translation topic for more information on doing this.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Offsets, Ranges, and Positions

There are several ways to reference the location of characters within a string or snapshot, each with their own benefits.

This topic contains these sections:

  • Offsets
  • Text Ranges
  • Text Positions
  • Text Position Ranges
  • Converting Between Offsets and Text Positions
  • Snapshot Offsets
  • Snapshot Ranges
  • Normalized Snapshot Range Collection
  • Version Ranges

Offsets

Offsets are zero-based integer numbers indicating a character index from the beginning of a string or snapshot.

The first character in a document is at index 0. The offset past the last character in a snapshot can be retrieved via the ITextSnapshot.Length property.

Text Ranges

It is often necessary to work with an ordered pair of offsets. For instance when getting a substring of text in a snapshot, you need to pass the offset range to obtain.

The TextRange structure represents an ordered pair of two offsets. It has many methods for comparing the range with other offsets and ranges.

To create a text range that spans 2 characters starting at offset 3, you'd create a text range with start offset 3 and end offset 5. Note that the end offset is the offset after the last character encapsulated by the range.

C#
VB
Copy
​TextRange range = new TextRange(3, 5);
​Dim range As TextRange = New TextRange(3, 5)

This code creates a TextRange with the same offset values but creates it using start offset and length combinations instead.

C#
VB
Copy
​TextRange range = TextRange.FromSpan(3, 2);
​Dim range As TextRange = TextRange.FromSpan(3, 2)

Text Positions

TextPosition structures are similar to offsets in that they indicate a certain character within a string or snapshot. However they work in terms of a line index and a character index within that line.

The Line and Character values of text positions are zero-based so a text position representing line index 1 and character 7 references the eighth character on the second line in the text.

This code creates a TextPosition with line index 1 and character 7:

C#
VB
Copy
​TextPosition position = new TextPosition(1, 7);
​Dim position As TextPosition = New TextPosition(1, 7)

Text Position Ranges

Similar to how TextRange provides a range of offsets, the TextPositionRange structure provides a range of TextPosition objects.

This code creates a TextPositionRange from position (1,7) to (2,3):

C#
VB
Copy
​TextPositionRange positionRange = new TextPositionRange(1, 7, 2, 3);
​Dim positionRange As TextPositionRange = New TextPositionRange(1, 7, 2, 3)

Converting Between Offsets and Text Positions

Sometimes it's useful to convert between offsets and text positions. Likewise, conversion between text ranges and text positions is possible.

These members in the ITextSnapshot inteface allow for conversion:

Member | Description
OffsetToPosition Method | Returns the TextPosition that represents the specified offset within the text lines.
PositionRangeToTextRange Method | Returns the TextRange that represents the specified TextPositionRange within the snapshot.
PositionToOffset Method | Returns the offset for the specified TextPosition within the text lines.
TextRangeToPositionRange Method | Returns the TextPositionRange that represents the specified TextRange within the snapshot.

Snapshot Offsets

The TextSnapshotOffset structure is a bit more advanced than a simple offset or TextPosition. It stores a reference to a particular location within an ITextSnapshot and provides access to the offset or TextPosition of that location.

The root ITextSnapshot and the ITextSnapshotLine that contains the snapshot offset are accessible from the snapshot offset.

This code creates a TextSnapshotOffset at offset 5 within the document's current ITextSnapshot:

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = new TextSnapshotOffset(document.CurrentSnapshot, 5);
​Dim snapshotOffset As TextSnapshotOffset = New TextSnapshotOffset(document.CurrentSnapshot, 5)

Snapshot offsets can be translated to another snaphot. Details on this are available in the Snapshot Translation topic.

Snapshot Ranges

The TextSnapshotRange structure is similar to a TextSnapshotOffset in that it references a specific ITextSnapshot. The different is that it tracks two normalized locations within the snapshot.

Accordingly, it can do additional things like return the text contained within the range, give the offset/text positions of the start/end, etc.

To create a snapshot range that spans 2 characters starting at offset 3, you'd create a snapshot range with start offset 3 and end offset 5. Note that the end offset is the offset after the last character encapsulated by the range.

C#
VB
Copy
​TextSnapshotRange snapshotRange = new TextSnapshotRange(document.CurrentSnapshot, 3, 5);
​Dim snapshotRange As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 3, 5)

This code creates a TextSnapshotRange with the same offset values but creates it using start offset and length combinations instead.

C#
VB
Copy
​TextSnapshotRange snapshotRange = TextSnapshotRange.FromSpan(document.CurrentSnapshot, 3, 2);
​Dim snapshotRange As TextSnapshotRange = TextSnapshotRange.FromSpan(document.CurrentSnapshot, 3, 2)

Snapshot ranges can be translated to another snaphot. Details on this are available in the Snapshot Translation topic.

Normalized Snapshot Range Collection

The NormalizedTextSnapshotRangeCollection class provides a collection implementation that normalizes all of its contained TextSnapshotRange objects.

This means that snapshot ranges in the collection are guaranteed to:

  • All be based on the same ITextSnapshot.
  • Be in sequential order by start offset.
  • Not overlap (overlapping snapshot ranges are merged when the collection is built).

Version Ranges

As described in the Documents, Snapshots, and Versions topic, text versions are placeholders that provide the core functionality needed to link snapshots together and support features like Snapshot Translation.

The ITextVersionRange interface designates an object that can refer to a text range within an ITextVersion. By itself, the ITextVersionRange object is not very useful since it doesn't provide direct access to the text range data. It also holds no references to any text snapshots, which makes it very lightweight.

The nice thing about version ranges though is that they are a lightweight reference to a text range that can be easily translated to any snapshot range or other text range in a specific text version. This makes them ideal for use in scenarios where you wish to store a version-oriented range for a long period of time, without needing to retain the related snapshot in memory.

Version ranges can be created with the various ITextVersion.CreateRange methods.

C#
VB
Copy
​ITextVersionRange versionRange = document.CurrentSnapshot.Version.CreateRange(1, 3);
​Dim versionRange As ITextVersionRange = document.CurrentSnapshot.Version.CreateRange(1, 3)

Version ranges can be translated to any snapshot for the same document:

C#
VB
Copy
​TextSnapshotRange snapshotRange = versionRange.Translate(document.CurrentSnapshot);
​Dim snapshotRange As TextSnapshotRange = versionRange.Translate(document.CurrentSnapshot)

Version ranges also can be translated to a text range for particular lightweight ITextVersion that is also from the same document.

C#
VB
Copy
​TextRange range = versionRange.Translate(document.CurrentSnapshot.Version);
​Dim range As TextRange = versionRange.Translate(document.CurrentSnapshot.Version)

Another way a version range can be created is from a TextSnapshotRange:

C#
VB
Copy
​ITextVersionRange versionRange = snapshotRange.ToVersionRange(TextRangeTrackingModes.Default);
​Dim versionRange As ITextVersionRange = snapshotRange.ToVersionRange(TextRangeTrackingModes.Default)

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line Terminators

While the text framework can load text using any sort of standard line terminator character sequence, the framework internally tracks all line terminators as a single line feed character. Text can easily be exported back out with any line terminator.

This topic contains these sections:

  • Standard Line Terminators
  • Why Does the Framework Only Track Line Feeds?
  • Impact on Offsets
  • The ITextSnapshot.Text and GetSubstring Members
  • Getting Text and Substrings with a Specific Line Terminator

Standard Line Terminators

The standard line terminators are:

  • Carriage return followed immediately by a newline (CR/LF)
  • Carriage return only (CR)
  • Newline only (LF)

Standard line terminators can be specified by the LineTerminator enumeration.

Why Does the Framework Only Track Line Feeds?

As mentioned above, it is important to know that when text added to an ITextDocument, it is converted so that the internal buffer stores the text using a single line feed character for denoting line terminators, regardless of what sort of line terminator was originally used.

The main reason for doing this is for performance when parsing. If we didn't store line terminators this way, any parsing code would require more complicated and time consuming procedures to be looking for carriage return characters, line feed characters, or potentially both at each line terminator. Using a single LF character makes it easy for parsing to perform quickly and efficiently since we know which specific single character denotes the end of a line.

Note Note
Since text is tracked internally using only line feeds, see the following sections for information on how to retrieve text back out of the text framework with specific line terminators.

Impact on Offsets

An offset is the zero-based index of a character within text. Sometimes you may have scanned some text that has CR/LF endings and saved a character range. Then you passed the text into a document and tried to get the substring of the range. What you'd find is that the returned text is not what you expected.

A simple diagram will illustrate why. Say your text string was:

Code Snippet
Copy
int a;
int b;

In a string with a CR/LF line terminator, the b character would be located at offset 12 like in the diagram below.

The top character sequence showing original text, the bottom showing how it is stored in documents

The bottom part of the diagram shows how an ITextDocument would convert the text to LF line terminators. You can see how offset 12 now points to the semi-colon character instead.

To work around this issue, use the text framework to determine your offsets once it's in a document.

Note Note
If you will be doing any external parsing, use the GetText method (described below) to retrieve the text with LF-only format so the offsets remain in sync.

The ITextSnapshot.Text and GetSubstring Members

The ITextSnapshot.Text property and GetSubstring method both return text back out with CR/LF format.

Since those properties are generally accessed when getting text and using it in other places within your application, they return the Windows default line terminator, which is CR/LF.

Getting Text and Substrings with a Specific Line Terminator

Since the two members above return text using CR/LF, sometimes you need to get the text with LF-only or CR-only. To do this, you can use the GetText method and the GetSubstring method overload that accepts a LineTerminator parameter.

Both of those methods allow you to obtain the text with any line terminator that you specify.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Snapshot Translation

Offsets and offset ranges can be translated from one snapshot to another using a feature called snapshot translation. Snapshots are immutable views of a document and are able to determine the changes made between any two snapshots for the same document. This allows for the locating of a certain offset or range of text in the current snapshot based on some offset/range created using an older snapshot, even with mutiple document changes being made in between the two snapshots.

Note Note
See the Documents, Snapshots, and Versions topic for a basic overview on snapshots and how different snapshots relate to each other wihin a document.

This topic contains these sections:

  • Scenario 1: Threaded Parsing
  • Scenario 2: Text Range Results
  • Storing Results in Preparation for a Translation
  • Offset Translation
  • Text Range Translation

Scenario 1: Threaded Parsing

Say you start some time-consuming parsing on the most current snapshot, which we'll call snapshot 1. While the parsing is executing in a separate thread on snapshot 1, more text changes in the document are made, bringing us to what we'll call snapshot 2. Then assume snapshot 1's parsing completes and returns an AST of the document.

All the offsets for the AST are based on the text found in snapshot 1. Since snapshot 2 is the the most current snapshot, the offsets for the AST are most likely incorrect by some delta amount since they were not based on snapshot 2.

The text framework can translate offsets from one snapshot to another, taking any text changes into account. So if we were editing a document in an editor and wanted to jump directly to a class name whose offset we know from the AST based on snapshot 1, we can translate the offset from snapshot 1 to the current snapshot (snapshot 2), and move the editor's caret right to the translated offset.

Scenario 2: Text Range Results

Another common scenario where snapshot translation is useful is when working with some sort of parsing result set.

Say you do a "find all" operation on a snapshot and list the replace locations in a ListBox. By tracking a TextSnapshotRange for each result, you could move directly to the found text on double-clicks by translating the clicked range to the current snapshot, even after multiple edits have been made following the find all operation.

Storing Results in Preparation for a Translation

The TextSnapshotOffset and TextSnapshotRange structures can both be used to translate offsets/ranges.

TextSnapshotOffset stores an offset and references a particular ITextSnapshot. Likewise, TextSnapshotRange stores a text range and references a particular ITextSnapshot.

Both have TranslateTo methods that are used to translate the offset/range to a new ITextSnapshot.

When persisting results related to a parse operation, such as in the two scenarios above, there are a couple recommended options. The first options is to directly use TextSnapshotOffset and TextSnapshotRange instances to store the data. Alternatively, if you have some sort of result set, have the root result set store the ITextSnapshot from which the results were found and use integer offsets or TextRange structures to store the individual results. With this approach, you can use the ITextSnapshot and offset/range to create TextSnapshotOffset and TextSnapshotRange instances as needed.

Offset Translation

The TextSnapshotOffset structure provides functionality for translating an offset from one snapshot to another. By calling the TranslateTo method, a new TextSnapshotOffset can be retrieved, indicating the offset value within the target ITextSnapshot.

The TranslateTo method accepts two parameters: the target ITextSnapshot, and a TextOffsetTrackingMode value.

The tracking mode indicates how the offset tends to move when text changes are made next to or surrounding it, between the original snapshot and the target snapshot. See the TextOffsetTrackingMode enumeration documentation for details on available values.

This code shows how to translate an offset to a new snapshot after changes are made to the document:

C#
VB
Copy
​TextSnapshotOffset offset = new TextSnapshotOffset(document.CurrentSnapshot, 10);
// Document changes made here, meaning new snapshots are created
TextSnapshotOffset translatedOffset = offset.TranslateTo(document.CurrentSnapshot, TextOffsetTrackingMode.Negative);
​Dim offset As TextSnapshotOffset = New TextSnapshotOffset(document.CurrentSnapshot, 10)
' Document changes made here, meaning new snapshots are created
Dim translatedOffset As TextSnapshotOffset = offset.TranslateTo(document.CurrentSnapshot, TextOffsetTrackingMode.Negative)

A TextSnapshotOffset can be marked as "deleted" via its IsDeleted property. The Deleted static property provides access to an instance of the structure that has been marked "deleted". This variation of the offset may be useful when you wish to flag that some edit operation removed the range that contained the offset.

Text Range Translation

The TextSnapshotRange structure provides functionality for translating an offset range (or TextRange) from one snapshot to another. By calling the TranslateTo method, a new TextSnapshotRange can be retrieved, indicating the offset range within the target ITextSnapshot.

The TranslateTo method accepts two parameters: the target ITextSnapshot, and a TextRangeTrackingModes value.

The tracking modes indicates how the range tends to update when text changes are made next to or surrounding it, between the original snapshot and the target snapshot. See the TextRangeTrackingModes enumeration documentation for details on available values.

This code shows how to translate a text range to a new snapshot after changes are made to the document:

C#
VB
Copy
​TextSnapshotRange range = new TextSnapshotRange(document.CurrentSnapshot, 10, 15);
// Document changes made here, meaning new snapshots are created
TextSnapshotRange translatedRange = range.TranslateTo(document.CurrentSnapshot, TextRangeTrackingModes.Default);
​Dim offset As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 10, 15)
' Document changes made here, meaning new snapshots are created
Dim translatedRange As TextSnapshotRange = range.TranslateTo(document.CurrentSnapshot, TextRangeTrackingModes.Default)

When translating a TextSnapshotRange, it is possible that the resulting range no longer exists. For example, this coudl happen if the user deleted the line that contained the range. In these cases, then IsDeleted property may be set to true, depending on which tracking mode options were used.

Note Note
The TextSnapshotRange.IsDeleted static property provides access to an instance of the structure that has been marked "deleted".

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Scanning Text Using a Reader

The text framework has very robust features built-in for scanning through snapshot text via the use of readers.

This topic contains these sections:

  • ITextBufferReader vs. ITextSnapshotReader
  • Getting an ITextSnapshotReader for a Snapshot
  • Getting an ITextBufferReader for a Snapshot
  • Notes on Performance
  • ITextSnapshotReader Options
  • Getting an ITextBufferReader for a String
  • Getting a System.IO.TextReader for an ITextBufferReader

ITextBufferReader vs. ITextSnapshotReader

There are two types of readers included with the text framework: ITextBufferReader and ITextSnapshotReader.

ITextBufferReader

ITextBufferReader provides a very fast, low-level interface for scanning through text. It reads character-by-character, but does allow for jumping to a specific offset.

The current character's value, offset, and TextPosition can be retrieved at any time. This interface also has some help methods like ReadThrough, that advance the reader until it encounters and passes a particular character.

Please see the ITextBufferReader members list in the class library to see what scanning features are available for use.

ITextSnapshotReader

ITextSnapshotReader is a higher-level interface for scanning through text, and is made specifically for reading an ITextSnapshot instance. It internally uses a ITextBufferReader but wraps the core buffer reader with a ton of extended functionality.

A snapshot reader can return the current character, offset, TextPosition, current IToken, current token text, current ITextSnapshotLine, and more.

It has a large number of helper methods for navigating through text, such as ReadToken, GoToNextTokenWithId, etc.

Please see the ITextSnapshotReader members list in the class library to see what scanning features are available for use.

Getting an ITextSnapshotReader for a Snapshot

To get an ITextSnapshotReader for an ITextSnapshot, call the ITextSnapshot.GetReader method.

There are two overloads for this method. Each accept a parameter indicating to where in the snapshot the reader should be initialized. The first overload accepts an offset and the second accepts a TextPosition.

This code retrieves an ITextSnapshotReader for the current text in a document, starting at offset 0:

C#
VB
Copy
​ITextSnapshotReader reader = document.CurrentSnapshot.GetReader(0);
​Dim reader As ITextSnapshotReader = document.CurrentSnapshot.GetReader(0)

Getting an ITextBufferReader for a Snapshot

As mentioned above, the ITextSnapshotReader implementations use a core ITextBufferReader instance. So once you have an ITextSnapshotReader instance via the code in the previous section, simply use its BufferReader property to return the wrapped ITextBufferReader.

This code retrieves an ITextBufferReader from the reader defined above:

C#
VB
Copy
​ITextBufferReader bufferReader = reader.BufferReader;
​Dim bufferReader As ITextBufferReader = reader.BufferReader

Notes on Performance

If you only need to do core character scanning for a snapshot, use an ITextBufferReader. It is the most low-level reader available and therefore has the fastest performance.

You also can do basic text/character scanning with an ITextSnapshotReader. This will incur a negligible performance loss since all of those members essentially just call members on the core ITextBufferReader.

Performance, while still fast, will be lessened a little when using the various members on ITextSnapshotReader that deal with tokens and token scanning. Any of these methods do additional work to ensure that tokens are in sync with the reader. However overall they should still perform fast, as this is a common usage for readers.

The ITextSnapshotReader.Options property allows you to customize some optimizations used for token scanning to aid in performance. Since tokens are virtualized in the text/parsing framework, tweaking these options to best fit your scenario can make a difference in scanning performance. The following section describes the options.

ITextSnapshotReader Options

The ITextSnapshotReader interface has an Options property that allows you to modify the options for the reader instance. The options are of type ITextSnapshotReaderOptions and must be changed prior to using any members on the reader, if you are changing the options.

The options are mainly used to configure optimizations for token scanning, since tokens are virtualized in the text/parsing framework. If you will not be doing token scanning with yoru reader, you do not need to change the options. Even if you are doing token scanning, you can optionally leave the default options if you wish.

The options basically deal with how large of a block of tokens to load up, both initially and afterward, when scanning through text. They also let you indicate whether you primarily plan on scanning forward, backward, or both.

Please see the ITextSnapshotReaderOptions members list in the class library to see what options available for use.

Getting an ITextBufferReader for a String

The StringTextBufferReader class is an implementation of ITextBufferReader that operates on a string.

This code creates a StringTextBufferReader for a string:

C#
VB
Copy
​StringTextBufferReader bufferReader = new StringTextBufferReader("Text to read");
​Dim bufferReader As StringTextBufferReader = New StringTextBufferReader("Text to read")

Getting a System.IO.TextReader for an ITextBufferReader

The ITextBufferReader.AsTextReader method can be used to create a System.IO.TextReader instance.

System.IO.TextReader objects are defined in the core .NET framework and are useful for passing to various external components that are based on text readers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Changes and Operations

A large portion of the text framework is focused on the ability to make changes to document text. Multiple individual replace transactions, called text change operations, can be batched up into a single text change and performed together as a single undoable modification.

This topic contains these sections:

  • Text Changes vs. Text Change Operations
  • Text Change Types
  • Single vs. Multiple Operation Text Changes
  • Single-Operation Text Changes
  • Multiple-Operation Text Changes
  • Text Change Options
  • Offset Deltas
  • Auto Character Casing

Text Changes vs. Text Change Operations

Text changes, represented by the ITextChange interface, consist of one or more text change operations. Each text change is considered a single undoable modification.

A text change operation, represented by the ITextChangeOperation interface, is a single replace transaction. The operation can insert text, delete text, or do both.

A text change and its operations are not performed until the text change is applied.

Text Change Types

Each text change is described by an ITextChangeType instance that is assigned to the ITextChange when it is created. Text change types can be anything, but some common examples are Typing, Paste, Auto-Complete, etc.

Note Note
The TextChangeTypes static class provides quick access to the most common text change types.

If you are creating a text change for which no TextChangeTypes member property describes, you can build your own custom text change type by making a class that implements ITextChangeType.

Single vs. Multiple Operation Text Changes

The text framework supports both single- and multiple-operation text changes. It is up to you to decide which to use, but the key thing to remember is that each text change is considered a single undoable modification in the undo history.

If you were just going to append some text to the end of the document, you'd use a single-operation text change. If you were writing some code to insert a comment delimiter at the start of multiple lines, you'd use a multiple-operation text change instead.

Single-Operation Text Changes

The ITextDocument interface provides a number of helper methods that quickly create and instantly apply single-operation text changes:

Member | Description
AppendText Method | Appends text to the end of the current snapshot's text. There are two overloads of this method. One overload accepts an ITextChangeOptions parameter.
DeleteText Method | Performs a delete text change in the current snapshot. There are four overloads of this method. Various overloads accept offset/length parameters vs. a TextRange parameter. Two overloads accept an ITextChangeOptions parameter.
InsertText Method | Performs an insert text change in the current snapshot at the specified offset. There are two overloads of this method. One overload accepts an ITextChangeOptions parameter.
ReplaceText Method | Performs a replace text change in the current snapshot at the specified offset. There are four overloads of this method. Various overloads accept offset/length parameters vs. a TextRange parameter. Two overloads accept an ITextChangeOptions parameter.
SetText Method | Replaces all the text in the current snapshot. There are three overloads of this method. The simplest overload that only accepts a String parameter replaces all the text in the current snapshot and also clears the undo history. One overload accepts an ITextChangeOptions parameter.

When using the methods above, you do not interact directly with an ITextChange since it is created and applied behind the scenes for you.

Multiple-Operation Text Changes

Use the following techniques whenever you are going to perform a number of replaces that should be considered a single undoable modification.

Creating an ITextChange

First, create an ITextChange object by calling the ITextDocument.CreateTextChange.

This code creates an ITextChange:

C#
VB
Copy
​TextChangeOptions options = new TextChangeOptions();
options.OffsetDelta = TextChangeOffsetDelta.SequentialOnly;
ITextChange change = document.CreateTextChange(TextChangeTypes.CommentLines, options);
​Dim options As TextChangeOptions = New TextChangeOptions();
options.OffsetDelta = TextChangeOffsetDelta.SequentialOnly
Dim change As ITextChange = document.CreateTextChange(TextChangeTypes.CommentLines, options)

The ITextChangeType parameter describes the text change that will be performed.

In this sample we also used the overload of CreateTextChange that accepts an ITextChangeOptions parameter. One of the settings in the options was set to apply a "sequential-only" offset delta. This is described in detail in the "Text Change Options" section below.

Creating a Reader

Most often, when performing multiple operations in a text change, you need to scan an ITextSnapshot. To do this, create an ITextSnapshotReader as described in the Scanning Text Using a Reader topic.

But be sure to use the ITextSnapshot for which the ITextChange is based. This ensures that the offsets will be properly in sync.

This code retrieves an ITextSnapshotReader for the ITextChange's snapshot, starting at offset 0:

C#
VB
Copy
​ITextSnapshotReader reader = change.Snapshot.GetReader(0);
​Dim reader As ITextSnapshotReader = change.Snapshot.GetReader(0)

Scanning Using a Reader and Adding Operations

Often the next code that you'd implement is to scan through the snapshot using the ITextSnapshotReader that was created.

This code uses the reader to scan through code and insert a C-like comment at the start of each line:

C#
VB
Copy
​while (!reader.IsAtSnapshotEnd) {
    change.InsertText(reader.Offset, "//");
    reader.ReadCharacterThrough('\n');
}
​While Not reader.IsAtSnapshotEnd
    change.InsertText(reader.Offset, "//")
    reader.ReadCharacterThrough(ControlChars.Lf);
End While

Applying the Text Change

Finally when you have completely constructed the text change, call its Apply method to perform the text change on the document.

This code applies the text change.

C#
VB
Copy
​change.Apply();
​change.Apply()

Text Change Options

All methods that either quickly perform a single-operation text change or create an ITextChange have an overload that accepts an optional ITextChangeOptions object. This object allows you to specify some additional settings that are used when the text change is applied.

Custom Data

The CustomData property allows you to pass some custom data object with the text change. This custom data object will be persisted in the undo history. Therefore when examining the undo history or undoing back to this change, you can retrieve the custom data object via the IUndoableTextChange.CustomData property.

Check Read-Only

By default, programmatically-created text changes will not check for read-only regions when applying the text change. You can change this behavior to force the text change to cancel if it attempts to alter a read-only region by setting the CheckReadOnly property to true.

Offset Delta

The OffsetDelta property can be used to auto-apply an offset delta when performing multiple operations in a text change. This feature is described in the following section.

Retain Selection

By default, when a text change is applied, any attached editor will move its caret to the end of the last operation in the text change. This behavior can be disabled by setting then RetainSelection property to true.

Source

Sometimes it's useful to know the source object that created the text change. This most often is some sort of editor view and can be passed in the Source property.

Can Merge Into Previous Change

When the CanMergeIntoPreviousChange property is true, the text change will try and merge into a previous text change on the undo stack. This is useful when you want to apply a programmatically-created text change that shouldn't have its own undo history entry. Enabling this feature means that if an undo occurs after this text change is applied, the undo will include all of the operations in the merged text change along with those of the text change they were merged into, all acting as a single atomic text change.

The ITextChange.IsMerged property returns if a text change is the result of two or more text changes being merged.

Offset Deltas

Text changes have a great optional feature called offset deltas that make things much easier when performing multiple operations in a single text change. To explain the benefit, let's examine a simple scenario.

Assume that you scan a snapshot and determine that you would like to insert the text // at offsets 0 and 10. Therefore you create an ITextChange. The first insert operation would be made at offset 0 and would insert 2 characters. Now we have a problem since if we make the second insert operation at offset 10, it would be off by 2 characters from what we originally wanted. By default, operations added to a text change are made at absolute offsets, so that means at the offsets that will exist after the previous operations that have occurred for the text change.

There are two ways around this. The first and harder way is to keep some sort of delta variable yourself to determine that any operations you perform need to be offset by the delta. Then after each operation, update the delta to account for the deletion and insertion lengths of the operation. For the scenario example above, you'd have to tell the second insert operation to occur at offset 12, not 10, to achieve the correct results.

Obviously that is tedious so the text framework provides a really handy feature to do the delta calculations for you. The only caveat is that you must be performing the operations in forward sequence, meaning no operation can start at an offset that is earlier than the start offsets of any previously-added operation.

In the multi-operation example above, we activate this feature by passing options to the text change that set ITextChangeOptions.OffsetDelta to TextChangeOffsetDelta.SequentialOnly. When this option is set, all offsets you pass for operations can be based on the original offsets in the snapshot you scan. This means that in our scenario example above, you can tell the second insert operation to occur at offset 10.

Auto Character Casing

The ITextDocument.AutoCharacterCasing property enables control over the casing of text that is entered into the document via text changes. It supports these CharacterCasing values:

Value | Description
Normal | The case of characters is left unchanged, which is the default.
Upper | Converts all characters to uppercase.
Lower | Converts all characters to lowercase.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Loading and Saving Files

It's very easy to load document text from a file, stream, or string. Likewise, document text can be saved back out to a file, stream, or string.

This topic contains these sections:

  • Loading Text Directly from a File/Stream
  • Loading Text from a String
  • Saving Text to a File
  • Updating the IsModified Property
  • Getting Text into a String
  • Exporting to HTML / RTF
  • Storing the File Name of a Document

Loading Text Directly from a File/Stream

Document text may be loaded from files using one of the overloads of the ITextDocument.LoadFile method.

Use of a LoadFile method will reset the IsModified property to false and will clear the undo history. Use of the LoadFile method overloads that accept a path parameter will auto-update the FileName property with the file path.

Load from File System Using UTF-8 Encoding

The first overload of LoadFile simply accepts a path parameter. It loads files using standard UTF-8 encoding.

This code loads text from a file using UTF-8 encoding:

C#
VB
Copy
​document.LoadFile(@"C:\Code.cs");
​document.LoadFile("C:\Code.cs")

Load from File System Using a Specified Encoding

The second overload of LoadFile accepts a path parameter as well as an Encoding parameter. It loads files using the Encoding that you specify. This allows for easy loading of non-UTF-8 encoded files.

This code loads text from a file using ASCII encoding:

C#
VB
Copy
​document.LoadFile(@"C:\Code.cs", Encoding.ASCII);
​document.LoadFile("C:\Code.cs", Encoding.ASCII)

Load from Stream Using a Specified Encoding

The third overload accepts a Stream parameter as well as an Encoding parameter. It loads from the stream using the Encoding that you specify. This allows for easy loading of non-UTF-8 encoded files.

This code loads text from a Stream using UTF-8 encoding:

C#
VB
Copy
​document.LoadFile(stream, Encoding.UTF8);
​document.LoadFile(stream, Encoding.UTF8)

Loading Text from a String

Sometimes a document's text is fetched using an external process, such as from a database. In this case, the text to place in the document is available as a string variable.

The ITextDocument.SetText method can be used to completely replace the document text with a string.

There are several overloads of the SetText available. The overload that only accepts a String parameter will will reset the IsModified property to false and will clear the undo history. The other overloads will not do this.

This code replaces the text content of a document from a string, marks the IsModified property to false, and clears the undo history:

C#
VB
Copy
​string text = "int a;";
document.SetText(text);
​Dim text As String = "int a;"
document.SetText(text)

This code replaces the text content of a document from a string, without updating the IsModified property or the undo history:

C#
VB
Copy
​string text = "int a;";
document.SetText(TextChangeTypes.Typing, text);
​Dim text As String = "int a;"
document.SetText(TextChangeTypes.Typing, text)

Saving Text to a File

Document text may be saved to files using one of the overloads of the ITextDocument.SaveFile method.

Save to File Using UTI-8 Encoding

The first overload simply accepts a path parameter and a LineTerminator parameter. It saves files using standard UTF-8 encoding.

This code saves document text to a file using UTF-8 encoding:

C#
VB
Copy
​document.SaveFile("C:\Code.cs", LineTerminator.CarriageReturnNewline);
​document.SaveFile("C:\Code.cs", LineTerminator.CarriageReturnNewline)

Save to File Using a Specified Encoding

The second overload accepts a path parameter, a LineTerminator parameter, as well as an Encoding parameter. It saves files using the Encoding that you specify. This allows for easy saving of non-UTF-8 encoded files.

This code saves document text to a file using ASCII encoding:

C#
VB
Copy
​document.SaveFile("C:\Code.cs", Encoding.ASCII, LineTerminator.CarriageReturnNewline);
​document.SaveFile("C:\Code.cs", Encoding.ASCII, LineTerminator.CarriageReturnNewline)

Save to Stream Using a Specified Encoding

The third overload accepts a Stream parameter, a LineTerminator parameter, as well as an Encoding parameter. It saves to the stream using the Encoding that you specify. This allows for easy saving of non-UTF-8 encoded files.

This code saves document text to a Stream using UTF-8 encoding:

C#
VB
Copy
​document.SaveFile(stream, Encoding.UTF8, LineTerminator.CarriageReturnNewline);
​document.SaveFile(stream, Encoding.UTF8, LineTerminator.CarriageReturnNewline)

Updating the IsModified Property

After saving a document, it is a good idea to mark it as no longer modified. Save points are tracked in the undo history so that you are notified when the document reaches the save point.

This code sets a save point by telling a document that it is no longer modified:

C#
VB
Copy
​document.IsModified = false;
​document.IsModified = False

When the ITextDocument.IsModified property is set to false all unsaved changes in undo history's change tracking will be switched to saved changes.

Calling any of the SaveFile overloads with a path parameter will automatically set the ITextDocument.IsModified property to false if the specified path is the same as the document's FileName property value.

Getting Text into a String

Sometimes a document's text needs to be saved using an external process, such as to a database. In this case, the text to save needs to be retrieve into a string variable.

The current snapshot of a document (see the Documents, Snapshots, and Versions topic for more information) is available via the ITextDocument.CurrentSnapshot property. The ITextSnapshot.GetText method can be used to retrieve a snapshot's text content with a specified LineTerminator. The Text property returns the snapshot's text using standard Windows carriage return / newline line terminators.

This code fetches the current document text into a string:

C#
VB
Copy
​string text = document.CurrentSnapshot.Text;
​Dim text As String = document.CurrentSnapshot.Text

Exporting to HTML / RTF

The text framework supports exporting document text to HTML and RTF formats.

See the Exporting to HTML / RTF topic for more information on this feature.

Storing the File Name of a Document

The ITextDocument.FileName property can be used to store the file name (full path) of the file that has been loaded into the document. The LoadFile method overloads that read a file automatically set this property.

When the FileName property value is changed, the FileNameChanged event fires.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Syntax Languages

Syntax languages are objects that can be assigned to any ICodeDocument that provide advanced functionality for working with the text content of the document. This functionality can be simple such as determining where word breaks are, to more complex such as tokenization (lexing) of text, or parsing the text into an abstract syntax tree.

This topic contains these sections:

  • The ISyntaxLanguage Interface (Service Locator Architecture)
  • Creating, Loading, and Using a Language
  • Notification of Document Language Changes
  • Reusing Language Instances

The ISyntaxLanguage Interface (Service Locator Architecture)

The ISyntaxLanguage interface, implemented by any syntax language is designed to be completely open and extensible. The main requirement it has is that a string-based language key is provided that identifies the language. The other requirement is that it supports the service locator design pattern.

The service locator design pattern is somewhat like a dictionary object. Any object can be assigned as a "service" to the language using a Type-based key. There are a number of built-in feature service types that the text/parsing framework and products like SyntaxEditor look for, such as ILexer, ILineCommenter, IWordBreakFinder, etc. Then there are provider services that create/return various objects on-demand, and event sink services that allow you to be notified when various document and UI events occur that can be intercepted and handled by the language.

Note Note
A complete list of the built-in service types, along with a more in-depth look at how the service locator architecture works, is given in the Service Locator Architecture topic.

A Real Service Type Example

Each one of these services provide some functionality that can be requested at any time. As a real example, say we have created an ITextSnapshotReader (see the Scanning Text Using a Reader topic for details), and want to jump to the start of a word. The implementation of the GoToCurrentWordStart method checks with the language currently assigned to the document to see if an IWordBreakFinder service has been registered. If so, it uses that object to find the start of the word. Otherwise it falls back to a default word break finder.

Thus via the use fo the service locator architecture, we can register (or customize) built-in functionality for a particular language.

A Custom Service Type Example

Any custom service types can be registered too. Say you made a service that returns an object which has a method indicating if a passed filename is supported by the language. If our language was Java and the passed filename had a .java extension, we'd return true. You could register similar functionality on all the languages you use and publish this service as a type called IFilenameSupported. Then in your application where you maintained a list of available languages, when a file was opened you could enumerate your list of languages, get the IFilenameSupported service, pass the filename to its method, and see if true was returned. When you encounter a true return value, you know that language supports the file.

Creating, Loading, and Using a Language

The Language Creation Guide has topics that cover how to create, load, and use syntax languages. It also goes into detail about the service locator architecture, event sinks, the available built-in service types, and more.

In addition, we provide a Language Designer application that makes it easy to get started building a custom syntax language. That tool lets you configure information about your language and then it generates language-related code that can be used in your applications. With the application's help, you can be up and running in a few minutes.

Notification of Document Language Changes

The ICodeDocument.LanguageChanged event fires whenever the document's Language property changes. Its event arguments pass the old and newly-assigned languages.

Reusing Language Instances

It is encouraged to reuse ISyntaxLanguage instances among multiple documents that are of the same language. For instance, if your application has multiple instances of a SyntaxEditor control and your IDE edits XML documents, load your XML syntax language one time and apply the same instance to each document. This saves on memory and reduces load time.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Lexing is the process of scanning text and breaking it up into meaningful tokens that can be examined by a higher-level parser.

This topic contains these sections:

  • Basic Concepts
  • Tokens
  • Dynamic Lexers
  • Programmatic Lexers

Basic Concepts

There are various types of lexers and ways to go in terms of implementing them. This topic walks through how a lexer works and the benefits/drawbacks of various implementations.

See the Basic Concepts topic for more information.

Tokens

A token is a span of text within a snapshot that has some sort of lexical parse data associated with it. Tokens are used throughout the product, in various types of parsing, classification, and text scanning.

See the Tokens topic for more information.

Dynamic Lexers

Dynamic lexers are mergable lexers and use our custom pattern-based regular expression engine to match and tokenize text. It is recommended that developers new to the text/parsing framework as well as developers who do not require much advanced parsing use dynamic lexers since they make it simple to get up and running quickly.

See the Dynamic Lexers topic for more information.

Programmatic Lexers

The fastest lexers are handwritten classes (called "programmatic") that are hard-coded to parse a specific language's code.

See the Programmatic Lexers topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Basic Concepts

There are various types of lexers and ways to go in terms of implementing them. This topic walks through how a lexer works and the benefits/drawbacks of various implementations.

This topic contains these sections:

  • What Does a Lexer Do?
  • Key Components of a Lexer
  • Registering with a Syntax Language
  • Mergable vs. Non-Mergable Lexers
  • Changing Mergable Lexers
  • Dynamic, Programmatic, and Other Lexers

What Does a Lexer Do?

A lexer scans text and tokenizes it, meaning that a series of tokens are assigned to text ranges that identifies in detail what the text represents.

The concept is best illustrated with a diagram:

In this diagram, we have two lines of C# code. Each line is tokenized using a C# lexer. Note how a token spans one to many characters. For instance, the text using is contained by a single token that indicates it is a using keyword.

Key Components of a Lexer

Lexer

The root interface for a lexer in the parsing framework is ILexer. This interface is very simple. It has a String-based Key property that identifies the lexer, a Parse method that performs a parsing operation, and an optional TokenIdProvider property, which returns an ITokenIdProvider instance.

Token ID Provider

An ITokenIdProvider is simply a utility class related to the lexer that has integer constants indicating the token ID values used by the lexer. It has a GetKey method that returns the String-based Key for a particular ID and has properties that return the minimum and maximum ID values associated with the provider.

Lexical States

A lexical state, represented by the ILexicalState interface, is a context in which certain text can be parsed into a set of tokens.

For instance, all lexers must have a default lexical state, but then languages such as C# may have another lexical state for XML documentation comments. As you know, XML documentation comment tags are not valid in normal code. The code must have a /// delimiter on a line (thereby entering the XML documentation comment lexical state) and then tags are valid. While in this state, keywords such as void are not recognized and all text other than tags is treated as comment text. The lexical state ends at the line terminator and flips back to its parent default lexical state where again, keywords like void are recognized.

Lexical Scopes

A lexical scope, represented by the ILexicalScope interface, defines how a parent lexical state can transition to another child lexical state and back.

Again using the C# XML documentation comment example, the start scope for the XML documentation comment lexical state recognizes the text /// as its start scope and when found, transitions to the lexical state. Once in the lexical state, it looks for a line terminator, which is the end lexical scope for the lexical state. When that is found, it exits the lexical state and pops back to the parent default state.

Registering with a Syntax Language

An ILexer can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ILexer>(myLexer);
​language.RegisterService(Of ILexer)(myLexer)

Once the lexer is registered with a language, it can be used by other objects such as token taggers or other higher-level syntax or semantic parsers.

Mergable vs. Non-Mergable Lexers

Some languages can perform transitions to other languages, such as in the case of HTML where it can transition to CSS, Javascript, etc. These transitions are made when one lexer determines it should transition to another language's lexer. This feature is only supported by mergable lexers. Although language transitions are a great feature, non-mergable lexers will offer slightly better performance.

Making a Lexer Mergable

Any ILexer that implements IMergableLexer is a mergable lexer and thus supports language transition features.

The IMergableLexer interface can be easily implemented by creating a lexer that inherits MergableLexerBase. With this abstract base class, the only member that is required to be implemented is GetNextToken. That method is passed an ITextBufferReader and the current ILexicalState, and returns a MergableLexerResult object.

The MergableLexerResult class has two properties. The MatchType property is an enumeration indicating whether there was a match, and if so, if the match was exact or loose (such as a case insensitive match). The LexerData property is an IMergableTokenLexerData instance. It provides data about what was parsed. Programmatic lexers can use the built-in LexicalStateTokenData and LexicalScopeTokenData classes as property values.

If no match is made, return the static MergableLexerResult.NoMatch property value.

Tokens

Mergable lexers must generate tokens that implement IMergableToken. Non-mergable lexers, on the other hand, may generate simpler tokens that only implement IToken.

Performance Considerations

A common question is, should I make my language's lexer mergable or not? The two things to weigh are whether your language needs to support transitions to other languages, or would you like maximum parsing speed and minimal memory usage.

Mergable lexers require more overhead, both in the actual parsing operation and in how data ends up being tracked in tokens. This translates into slightly slower overall lexing and some increased memory usage.

Non-mergable lexers, since they don't support language transitions, only need to process the information needed to support the core IToken interface. Therefore they can run faster and use less overall memory.

Changing Mergable Lexers

Mergable lexers sometimes cache data about themselves. Therefore if they are ever to be altered after their initial creation, they need to be notified that something within them has changed.

As an example, this scenario can occur if you load two independent languages and then wish to merge them together, such as HTML with CSS. In this scenario you'd load two ISyntaxLanguage instances, one for HTML and one for CSS. Then you'd create a lexical state that contains a scope transition to CSS. See the Language Transitions QuickStart for a related full sample.

Before you change the HTML language's lexer to add the transitioning state, you need to wrap the change with a using statement executed on the result of the IMergableLexer.CreateChangeBatch method.

This code shows how to wrap changes:

C#
VB
Copy
​using (IDisposable batch = parentLexer.CreateChangeBatch()) {
    // Update lexical states, patterns, etc. on parent lexer here
}
​Using batch As IDisposable = parentLexer.CreateChangeBatch()
    ' Update lexical states, patterns, etc. on parent lexer here
End Using

Another scenario you may need to do this in is if you are dynamically adding/removing lexical patterns to a lexical state after it has already been used.

Dynamic, Programmatic, and Other Lexers

High-Level Comparison

Dynamic lexers use regular expression patterns to tokenize text. The DynamicLexer class inherits MergableLexerBase, meaning that all dynamic lexers are mergable and capable of transitioning to other languages. Dynamic lexers are generic and can support the parsing of nearly any language.

Programmatic lexers are written by hand and optimized to parse a specific language's code. This almost always results in faster parsing performance than dynamic lexers can achieve. Programmatic lexers can optionally be made mergable by implementing IMergableLexer or inheriting MergableLexerBase.

Which to Choose?

When building a new syntax language and making a new lexer, you must choose whether to create a dynamic or programmatic lexer.

It's often best to start out making a dynamic lexer. The reason is that these can be created extremely fast and will get you up and running quicker, especially when using the Language Designer to create your language and lexer.

If at a later time you decide to squeeze some more performance out of your lexer, then create a programmatic lexer instead. Programmatic lexers take more time to write and are really for more advanced developers.

Since any class that implements ILexer can be used by an ISyntaxLanguage, it is important to note that even if you start initially with a dynamic lexer, you can easily swap in a programmatic lexer for your language at a later time.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tokens

A token is a span of text within a snapshot that has some sort of lexical parse data associated with it. Tokens are used throughout the product, in various types of parsing, classification, and text scanning.

This topic contains these sections:

  • Token Basic Properties
  • Mergable Tokens
  • Token Classes

Token Basic Properties

All tokens are represented by classes implementing the IToken interface. This interface defines properties that fall into two categories: identification and location.

Identification properties provide the most basic data for identifying what a token represents. The Id and Key properties are used for this purpose. The Id property is an integer number and the Key is a String value. Either or both can be used to provide identification of the token, although the ID is preferred since integer comparisons are faster than String comparisons.

Location properties give information about the size and location of the token within its text source. The StartOffset and EndOffset properties specify the start/end offsets of the token. The end offset is the offset after the last character contained by the token. The Length property gives the number of characters in the token. The StartPosition and EndPosition properties specify the start/end TextPosition objects that relate to the offsets. The TextRange and PositionRange properties provide the related ranges.

Note Note
See the Offsets, Ranges, and Positions topic for more information on offsets and text positions.

Mergable Tokens

Mergable tokens are represented by classes implementing the IMergableToken interface, which inherits the IToken interface. Mergable tokens are the type of token that is created when using a mergable lexer, meaning a lexer from one language that can merge its results with another language's mergable lexer. This is commonly seen in languages like HTML where multiple child languages like CSS, JavaScript, etc. can be used.

Mergable tokens provide more information about how the token was created, such as its owner ILexicalState, owner ILexicalScope (if appropriate), and the root IMergableLexer

Another key feature provided by the IMergableToken interface is the IClassificationType associated with the token, available via the IMergableToken.ClassificationType property. A classification type is a logical category such as Identifier, Comment, or Whitespace.

Token Classes

If you wish to create a bare bones class that implements IToken for your language, and your language's lexer is not mergable, you can inherit the TokenBase class. It is abstract and only requires that you implement its Id property and optionally the Key property.

For languages that use mergable lexers, you can use the non-abstract MergableToken class for your tokens. Typically you don't even need to worry about this though since the MergableLexerBase class, which most IMergableLexer implementations inherit, automatically creates MergableToken instances for you.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Dynamic Lexers

Dynamic lexers are mergable lexers and use our custom pattern-based regular expression engine to match and tokenize text. It is recommended that developers new to the text/parsing framework as well as developers who do not require much advanced parsing use dynamic lexers since they make it simple to get up and running quickly.

This topic contains these sections:

  • How do they work?
  • Free Samples
  • Lexical States
  • Lexical Scopes
  • Lexical Pattern Groups
  • Lexical Macros
  • Lexical State Transitions (Language Transitions)
  • Lexing Sequence
  • Importance of Pattern Order
  • Optimization
  • Importing SyntaxEditor 4.0 for WinForms Dynamic Language XML Definitions

How do they work?

Dynamic lexers, represented by the DynamicLexer class, harness a specialized pattern-based engine to tokenize document text. This means that no handwritten lexing code needs to be written for dynamic lexers, such as you would write for a programmatic lexer. Instead, you provide the patterns that the lexer engine will use to match the text against. The patterns can be straight text (called explicit) or regular expressions (called regex). They also support case senstivity settings.

The lexer's patterns can be defined either by using a language definition file or by constructing the lexer programmatically via its object model. If a language definition file is used, the Loading a Language Definition topic explains how to load it at runtime.

Note Note
The Language Designer tool has extensive features for building a dynamic lexer. A new dynamic lexer wizard asks you several questions about your language and builds an initial dynamic lexer for you, which you can then modify as needed. Use that wizard to get started fast.

There are a number of pieces that make up a dynamic lexer, all described in greater detail below:

  • Lexical states
  • Lexical scopes
  • Lexical pattern groups
  • Lexical macros
  • Lexical state transitions

Free Samples

There are a number of free open source syntax language samples that use dynamic lexers. These free samples are included in the sample project and cover everything from C# to Perl.

Lexical States

Dynamic lexical states, represented by the DynamicLexicalState class, provide states into which different patterns may be grouped. The lexer only recognizes patterns that are valid within the current lexical state.

For instance, all lexers must have a default lexical state, but then languages such as C# may have another lexical state for XML documentation comments. As you know, XML documentation comment tags are not valid in normal code. The code must have a /// delimiter on a line (thereby entering the XML documentation comment lexical state) and then tags are valid. While in this state, keywords such as void are not recognized and all text other than tags is treated as comment text. The lexical state ends at the line terminator and flips back to its parent default lexical state where again, keywords like void are recognized.

Dynamic lexical states have several default properties that can inherit down to lexical pattern groups inside the state. Defaults are available for case sensitivity, classification type, and token ID/key.

Each dynamic lexical state has a collection of child lexical states and lexical scopes. The child lexical states collection specifies the lexical states that can be entered from the lexical state. When the dynamic lexer engine runs, it looks at each child lexical state to see if any of their lexical scope start lexical pattern groups match at the current offset in the text. If so, that child lexical state is entered. When the child lexical state's end lexical pattern group is recognized at a later point, the parent lexical state is re-entered.

Dynamic lexical states also have a lexical pattern groups collection, which provide the list of patterns that can be recognized while in the lexical state.

Lexical Scopes

Dynamic lexical states are represented by the DynamicLexicalScope class. As mentioned above, lexical scopes control when a child lexical state is entered and exited. Dynamic lexical scopes have a start lexical pattern group and end lexical pattern group property that provide the patterns recognized for entry and exit.

Lexical Pattern Groups

A lexical pattern group, represented by the DynamicLexicalPatternGroup class, is a group of patterns that share common attributes. For instance, in a dynamic lexer there is often one explcit lexical pattern group in the default lexical state that contains a list of keywords, where each pattern is the keyword text.

Lexical pattern groups can be an explicit or regex pattern type. When using the explicit pattern type, the pattern is matched exactly as specified, including whitespace. When using the regex pattern type, the pattern is matched using our regular expression engine. See the Regular Expression Guide for the regex pattern syntax.

Lexical pattern groups have options for case sensitivity, classification type, and token ID/key assigned.

In addition, a look-behind and look-ahead pattern can be set. These patterns are always specified in the regex pattern type and apply to all patterns in the lexical pattern group. When the dynamic lexer engine attempts to match a pattern, it also checks the look-behind pattern and look-ahead pattern to see if they match. They are treated as zero-width assertions, however if either fail, then no patterns in the lexical pattern group can match.

A common look-ahead pattern used for things like keywords is {NonWord}|\z. That look-ahead pattern ensures that patterns in the pattern group will match if the text following the match starts with a non-word character or is at the end of the document. Thus if matching the keyword int, the document text int foo; will match the int at the start while the document text integer foo; will not match.

Lexical Macros

Lexical macros are optional and provide a nice way to define reusable patterns for a dynamic lexer. Custom patterns can be defined as macros, but you can also redefine built-in macros for your lexer.

For instance, in the CSS language the Word macro is redefined as [a-zA-Z_0-9\-], which includes the hyphen character since that is a valid word character in CSS. Likewise, the NonWord is redefined as [^a-zA-Z_0-9\-].

Lexical macros can be referenced by key within { and } characters in any regex pattern. For instance this pattern specifies a C# identifier: (_ | {Alpha})({Word})*

The Dynamic Lexical Macros topic talks in more detail about the built-in macros that are available and how to use them in regex patterns.

Lexical State Transitions (Language Transitions)

There are two types of lexical state transitions to different languages that are supported.

Direct Lexical State Transitions

Sometimes it is necessary for a single pattern match to transition into another language. An instance of that is an ASP directive within an HTML document. In that case the <% directive changes the language to VBScript. Likewise, the %> directive exits back to HTML.

This type of transition is called a direct lexical state transition. You essentially create a dummy lexical state in the root HTML language. You give it a lexical start and end scope, which are the ASP directive patterns.

You then set the dummy lexical state's DynamicLexicalState.Transition property to an LexicalStateTransition object that indicates the language and lexical state to transition into. When the dummy state's start scope is recognized by the lexer, it transitions to the child language you indicated.

Scope Lexical State Transitions

A more complicated scenario is where a lexical state end scope is recognized and at that point, a lexical state transition needs to be made to another language. This occurs in HTML where a <style> tag is recognized, and a transition needs to be made to CSS.

This can be accomplished via a scope lexical state transition. You define a lexical state transition for a lexical scope (in the DynamicLexicalScope.Transition property) and you give the transition a child lexical scope with end pattern that it should look for to exit the child lexical state.

At run-time when the end scope pattern of the lexical state is recognized, the language transition is made. Later on when the transition's child lexical scope end pattern is recognized, the child language is exited and the parent lexical state of the original lexical state is entered.

Lexing Sequence

The lexer coordinator used by mergable lexers matches patterns in sequential order within four sequential groups:

  • Parent scopes (outside of the current lexer) to see if one ends the current state.
  • Child state start scopes to see if one starts a child state.
  • Pattern groups within the current state.
  • Parent scopes (inside of the current language) to see if one ends the current state.

In some scenarios you may wish to not check any ancestor scope to see if it ends the current state. For these scenarios, you can set the ILexicalScope.IsAncestorEndScopeCheckEnabled property to false. This prevents the lexer coordinator from looking at any scope above the current one when checking to see if they end the state.

Importance of Pattern Order

It is extremely important to optimize your dynamic lexer design. By making certain design decisions you can affect the run-time scanning speed of the dynamic lexer. Use the techniques described below to get the most efficiency out of a dynamic lexer.

Most Frequently Matched Patterns Should Be Defined First

Dynamic lexers use our custom NFA regular expression engine to parse text and find a pattern that matches the text. It does this by looping through all of the patterns in the lexer in the order in which they are defined. If a pattern is found to match the current text, the code breaks out of the loop and creates a mergable token containing the pattern's lexical parse information.

The key here is that the looping is done in the order in which the patterns groups are defined. Therefore, lexical parsing will be much faster if you place the most frequently-matched pattern groups first.

For instance, in C#, tokens like { and ( occur much more often than the keyword volatile. The patterns for the { and ( tokens should be defined at the beginning of a lexical state and the pattern for the infrequently-matched keyword volatile should be near the end of a lexical state.

Similar to how frequently-matched pattern groups should be placed first within a lexical state, frequently-matched patterns should be placed first within their parent pattern group. This will help when there are a number of keywords that start with the same character. SyntaxEditor has optimizations to help speed up which patterns to match however every bit of good language design helps speed up lexical parsing.

Be Careful of Pattern Order

When defining patterns, remember that the first match is accepted. Say you have two number pattern groups, one that looks for a series of digits followed by a period and more digits, marked as a real number and another patter than looks for a series of digits that ends with a non-digit, marked as an integer. If the integer pattern is defined first, when the lexical parser encounters a number it will start using the integer pattern. Say the number has a period afterwards and a number and should be defined as a real, the lexical parser would get to the period, see it as a non-digit and assign it as an integer. The real number pattern would never even be reached. Therefore in situations like this, it's important to place the more complicated patterns first. If the real number pattern had been defined first, then the parser would have tokenized the text appropriately.

The Language Designer has several helpful features for sorting explicit pattern group patterns appropriately to avoid this scenario when conflicting patterns are in the same lexical pattern group.

Optimization

For best memory and performance optimization, try and develop patterns that use as long of matches as possible. For instance, in comments, try and consume all comment text in a line in one token. This will perform better than if there is one token for each letter or word.

When using a lexer in SyntaxEditor, it is also beneficial to try and keep tokens on one line. For instance, in a multi-line comment, you should have a state with the text for each line in its own token, with a comment line terminator token for the line terminator. That sort of design helps with the performance of incremental classification, versus possible scenarios where a single token is potentially a thousand lines long.

Importing SyntaxEditor 4.0 for WinForms Dynamic Language XML Definitions

If you are a customer of our SyntaxEditor 4.0 for WinForms product and have created dynamic language XML definitions there, they can easily be converted over to the new language definition format used in this product. Use the Language Designer to import the XML definition and automatically create a language project that can export a language definition file. The Language Designer's Getting Started topic talks about this feature.

The language definition format used by this product is very similar in structure to the SyntaxEditor 4.0 dynamic language XML definition format, but the new format is more extensible and works for all languages, not just those that use a dynamic lexer.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Programmatic Lexers

The fastest lexers are handwritten classes (called "programmatic") that are hard-coded to parse a specific language's code.

This topic contains these sections:

  • Mergable vs. Non-Mergable
  • Implementing a Mergable Programmatic Lexer
  • Implementing a Non-Mergable Programmatic Lexer

Mergable vs. Non-Mergable

Programmatic lexers can be mergable or non-mergable. Mergable lexers allow a language to be merged with other languages at run-time via language transitions. An example of a language that uses merging is HTML since it can transition to CSS, VBScript, etc.

Mergable lexers provide this functionality by implementing the IMergableLexer interface. While this merging functionality is useful for certain scenarios, it does add a bit of overhead and thus results in some performance loss. This performance loss may not be very significant in many situations, but still if you wish to make your lexer as fast as possible and it doesn't need to merge with other language, you should make your lexer non-mergable.

A non-mergable lexer has the best performance among the various lexer types, although it requires a little more work to get started.

Implementing a Mergable Programmatic Lexer

A mergable programmatic lexer is made by creating a class that implements the IMergableLexer interface, although inheriting the MergableLexerBase class is the easiest way to accomplish this. When inheriting MergableLexerBase, the only method we are required to implement is the GetNextToken method.

That method is passed an ITextBufferReader and an ILexicalState that indicates the current lexical state. The reader is already initialized to the current offset that should be scanned to look for tokens. See the Scanning Text Using a Reader topic for some more details on the low-level ITextBufferReader class.

The GetNextToken method asks us to return a MergableLexerResult object. So after we scan a range of text using the reader and identify a token, we need to return an appropriate MergableLexerResult instance.

This code shows how to return a result for some text that was successfully identified as a token:

C#
VB
Copy
​return new MergableLexerResult(MatchType.ExactMatch, new LexicalStateTokenData(lexicalState, tokenId));
​Return New MergableLexerResult(MatchType.ExactMatch, New LexicalStateTokenData(lexicalState, tokenId))

In that example we indicate there was an exact case-sensitive match and also indicates the ILexicalState that match was made in (in case we moved to a new lexical state), along with the ID of the token. The token ID is user defined and varies for each language. For instance a CSS property name token may have ID value 10. A token is created for you behind-the-scenes based on the result value that spans from the reader's original offset through to the reader's current offset.

If there was no successful match, we want to move the reader back to the offset it started at and return MergableLexerResult.NoMatch instead.

There is an example of a mergable programmatic lexer in the sample project for the Simple language.

Implementing a Non-Mergable Programmatic Lexer

A non-mergable programmatic lexer is made by creating a class that implements the core ILexer interface. The main member of this interface is the Parse method.

This method passes a TextSnapshotRange indicating the ITextSnapshot and the range to parse, along with an ILexerTarget. A TextRange is returned that specifies the snapshot range that was modified.

Preparing to Lex

The first step in a Parse implementation is to adjust the range to lex. The TextSnapshotRange passed in tells us the minimum range to lex but often times we'll want to actually start our lexing at the start of the line that contains the range's start offset, or even somewhere on the line before that. Thus you can use the ITextSnapshot instance from the TextSnapshotRange.Snapshot property to find the line start and move the lexing start offset back appropriately.

Once we have determined the lexing start offset, call the ILexerTarget.OnPreParse method, passing in the lexing start offset by reference. This tells the lexer target where we would like to begin lexing at. It will return an ILexerContext object and will further update the lexing start offset to indicate where the offset at which that context is valid, and thus from where we should actually start our lexing.

The ILexerContext instance includes a stack of lexical states and scopes at the specified lexing start offset, thus allowing us to resume incremental parsing. This helps performance since we don't need to start lexing from the beginning of the document.

Lexing

The next step is to actually do some lexing. For this we will need to do some core text scanning by using an ITextBufferReader.

This code retrieves an ITextBufferReader that is initialized at the lexing start offset:

C#
VB
Copy
​ITextBufferReader reader = snapshotRange.Snapshot.GetReader(lexingStartOffset).BufferReader;
​Dim reader As ITextBufferReader = snapshotRange.Snapshot.GetReader(lexingStartOffset).BufferReader

At this point we want to start a loop while the reader.IsAtEnd property returns false, meaning keep going until the end of the snapshot. Inside the loop we scan characters using the reader and tokenize the text.

When some sort of pattern is recognized, we are ready to tell the lexer target. We call the ILexerTarget.OnTokenParsed method by passing it the next IToken that was lexed (which can be any class that inherits TokenBase) and an ILexicalScopeStateNode that can be persisted and returned to us in future ILexerContext instances if we wish to resume incremental lexing at this point.

The OnTokenParsed returns a boolean value indicating if lexing should continue. If that return value is false and we have passed the desired range to parse, we can safely quit our loop and complete lexing. Otherwise we continue the loop.

Completing Lexing

If we exited the loop because the end of the snapshot was reached, we should return a token indicating a document end. The TokenIdProviderBase.DocumentEnd value is the token ID to use for this token type.

Next we need to let the parse target know that parsing is complete so we call ILexerTarget.OnPostParse and tell it the offset of the reader we ended on.

Finally we return a TextRange indicating the actual offset range that was modified.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Tagging is a generic mechanism that allows any sort of data to be associated with a text range. This tagged data can then be retrieved on-demand by tag aggregators. Tagging is the core mechanism behind features such as tokenization, classification (which in turn drives syntax highlighting when used in an editor), and more.

This topic contains these sections:

  • Tags and Classification Types
  • Taggers and Tagger Providers
  • Tag Aggregators

Tags and Classification Types

Tags are objects that store data and can be applied to a text range. Classification types are used throughout the product to categorize objects. Both are key pieces towards understanding tagging.

See the Tags and Classification Types topic for more information.

Taggers and Tagger Providers

Taggers are objects that can return tagged snapshot ranges for any requested snapshot range. They are generally created by tagger providers, which are language service. Tagger results are then consumed by tag aggregators.

See the Taggers and Tagger Providers topic for more information.

Tag Aggregators

Tag aggregators are objects that can monitor all the available taggers for a specific tag type and can return a unioned set of tagged snapshot ranges for a requested snapshot range. They are used for consuming the results of taggers.

See the Tag Aggregators topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tags and Classification Types

Tags are objects that store data and can be applied to a text range. Classification types are used throughout the product to categorize objects. Both are key pieces towards understanding tagging.

This topic contains these sections:

  • What are Tags?
  • Classification Types
  • Tokens vs. Classifications
  • Providing Tagged Ranges

What are Tags?

Tags are any object inheriting ITag that can contain some data and can be applied to and tracked with a range of text in a document.

There are several built-in tag types are are used to drive various functionality pieces in the product. This table lists the built-in tag interface types that are supported, along with optional implementation classes that can be used.

Type Description
IClassificationTag

A tag that refers to an IClassificationType and can be used to classify a range of text (see below), which when used in an editor can also drive syntax highlighting.

The ClassificationTag class implements this tag interface.

IReadOnlyRegionTag

A tag that can mark a range of text as read-only (uneditable) by the end user. This is similar to setting the ITextDocument.IsReadOnly property to true, except that the read-only state only applies to the tagged text ranges.

Normally, only text changes that overlap (cross) the read-only region will be blocked. The IReadOnlyRegionTag.IncludeFirstEdge property can be set to true to also block text changes that border on the leading (first) edge of the read-only region. This is ideal for when you want to prevent text changes at the very start of a document. Likewise the IReadOnlyRegionTag.IncludeLastEdge property can be set to true to block text changes that border on the trailing (last) edge of the read-only region. This is ideal for when you want to prevent text changes at the very end of a document.

The ReadOnlyRegionTag class implements this tag interface and also includes an IClassificationType reference, which defaults to ClassificationTypes.ReadOnlyRegion. If that classification type is registered with a style in the ambient highlighting style registry, it is possible for the read-only regions to render in an alternate appearance, such as with a gray background.

ISquiggleTag

A tag that may be available when the text/parsing framework is used in conjunction with an editor. In that case, the tag can mark a range of text as needing a squiggle underline. This is generally used to flag syntax errors, etc. The tag includes an IClassificationType reference so that the type of squiggle can be classified.

The SquiggleTag class implements this tag interface.

ITokenTag

A tag that refers to an IToken and can be used to mark a range of text with the token. Use of these tags allow snapshot readers to scan through a document by token.

Token tags are typically handled completely internally by the text/parsing framework via the use of token taggers.

Classification Types

The IClassificationType interface provides information about classification types. A classification type is a high-level categorization, such as Identifier or Comment, that can be applied to text ranges via tags.

Each IClassificationType defines a string-based Key that identifies it, along with a more descriptive Description that may be used in user interfaces.

Note Note
Several of the most common classification types are available via static properties on the ClassificationTypes class.

The reuse of IClassificationType instances is highly recommended.

Tokens vs. Classifications

Tokens and classification tags are often related, especially in the case of token taggers. Let us examine an example.

In a C# document, consider a token that has been created via lexing for the keyword foreach. Syntax languages (advanced ones at least) generally assign different token ID values for each individual keyword. So the token ID for keyword foreach could be 50 for instance. This value is likely defined in some enumeration or static class of integer constants for the C# language. By doing this, when we later scan the tokens in the document, we know that this particular token is a foreach token without having to look at its text.

Now assume that a classification tag has been applied over the same text range via a token tagger. This classification would apply a Keyword classification type over that text range.

The difference is that where a token can be very specific as to what it represents, a classification tag over the same range is usually much more general. When the text/parsing framework is used within an editor control such as SyntaxEditor, classification tags are what drive syntax highlighting. In that scenario, each classification type is associated with a highlighting style. Therefore when ranges of text are classified with a classification type, SyntaxEditor maps the classification type to its related highlighting style and renders the text in the range using that style.

Even though token taggers most often provide both ITokenTag and IClassificationTag instances, additional IClassificationTag taggers can be layered on top of a token tagger to override and reclassify text. When used in an editor, this allows for more customized syntax highlighting to be added that merges with the default syntax highlighting.

Providing Tagged Ranges

Taggers are objects that can return an enumerable of tagged snapshot ranges that overlap a requested set of snapshot ranges. They are described in detail in the Taggers topic, along with details on special token taggers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Taggers and Tagger Providers

Taggers are objects that can return tagged snapshot ranges for any requested snapshot range. They are generally created by tagger providers, which are language service. Tagger results are then consumed by tag aggregators.

This topic contains these sections:

  • The ITagger Interface
  • Token Taggers
  • Collection Taggers
  • Parse Error Taggers
  • Tagger Base Classes
  • Sample: ITagger<ISquiggleTag> Implementation
  • Tagger Providers
  • Registering with a Syntax Language

The ITagger Interface

Taggers must implement the ITagger`1 interface. The type parameter indicates the ITag-based type that is provided by the tagger. For instance, a tagger that returns IClassificationTag would be an ITagger<IClassificationTag>.

Returning Tagged Snapshot Ranges

The main focus of this interface is its GetTags method. That method is called when some other object, such as a tag aggregator, needs to know the tagged snapshot ranges provided by the tagger for one or more snapshot ranges. The return value of the method is an IEnumerable<TagSnapshotRange<T>>. This allows the C# yield keyword to be used when implementing a GetTags method.

Lifecycle

Since taggers generally attach to various events on a document or other objects, they have the notion of a lifecycle. The lifecycle starts when the tagger is created and ends when the tagger is closed.

The ITagger`1.Close method can be used to close a tagger. When a tagger is closed, its Closed event fires.

Notification of Tag Changes

Sometimes the data that a tagger monitors is updated in such a way that its tag results are affected. The tagger's TagsChanged event can be raised to notify any watchers, such as tag aggregators, that the tag data that can be retrieved has been updated.

The event arguments should indicate the snapshot range that was updated. If the entire document was updated, pass a snapshot range that starts at offset 0 and goes through the snapshot length.

Ordering Taggers

Most of the time, the order of taggers isn't important. However when working in an editor and layering IClassificationTag taggers, order is important since that governs how the highlighting style data related to one classification type is merged into the highlighting style data from another classification type.

Taggers must implement the IOrderable interface, which allows them to be ordered as desired.

Token Taggers

Token taggers are a special built-in implementation of taggers that return both ITokenTag and IClassificationTag objects. The tokens used are generated by the language's lexer. These tokens are returned in token tags, and are also used to generate related classification tags as appropriate.

Since in an editor, the syntax highlighting is based off of classifications, token taggers provide the mechanism by which a lexer indirectly provides the base syntax highlighting layer for code. Because token tags also report tokens for a given range, they are used to enable the functionality of scanning a snapshot by tokens.

Note Note
Only one token tagger should ever be associated with a document at any given time. Therefore only one tagger provider service should ever be registered on a language.

The TokenTagger Class

The TokenTagger class wraps all this functionality up into a handy package. For languages that have a mergable lexer, the TokenTagger class is all you need, and can be used by your language by adding a TokenTaggerProvider`1 service to your language with the type parameter of TokenTagger.

Note Note
If your language is loaded from a language definition file, a token tagger provider service will be automatically registered with your language. If your language is created in code-behind and all the code was generated by the Language Designer tool, it will make a custom token tagger provider class that can be used.

The standard TokenTagger works for languages with mergable lexers since the tokens created by those lexers already include references to the classification type that should be used for each individual token.

For languages with non-mergable lexers, tokens are smaller and more simplistic. They do not know the related classification type to use. Therefore for languages that use these types of lexers, you must create a class that inherits the TokenTagger class and overrides the ClassifyToken method. This method is passed a token and you return the IClassificationType, if any, to use for that token. The code in the base TokenTagger class takes care of the rest.

The TokenTagger class has a built-in mechanism to support incremental lexing from any point in a document, which is why it is considered a special case tagger type. It completely virtualizes the caching of token data for a document, and allows token data to be generated incrementally on-demand when requested. Whereas most parsing frameworks store all tokens for a document in memory (which can be really bad for large documents), this class instead uses a minimal amount of memory by only caching data at certain intervals and regenerates token data as needed. The net result is that a miniscule amount of memory is used to persist token data for incremental parsing vs. what most other products use, and performance is still good.

Sample: Adding a Token Tagger Provider Service

Assume that we are making an ECMAScript language and have an EcmaScriptTokenTagger class inherits TokenTagger and has a ClassifyToken override. This is how a provider for it could be installed:

C#
VB
Copy
​language.RegisterService(new TokenTaggerProvider<EcmaScriptTokenTagger>());
​language.RegisterService(New TokenTaggerProvider(Of EcmaScriptTokenTagger)())

Note Note
The example above only works for token taggers. For all other taggers, see the documentation on tagger providers below.

Collection Taggers

The ICollectionTagger`1 interface (and related CollectionTagger`1 implementation class) is a ITagger`1 that is ideal for situations where there is a set of tagged ranges that should be maintained like a collection. If you would rather virtualize your tagger results, you should make a tagger that inherits one of the tagger base classes instead.

Collection Items

The collection tagger stores tagged version ranges (TagVersionRange`1) items. This class represents an ITag and its associated ITextVersionRange in a document. The version range can be translated to any snapshot.

A TagVersionRange`1 can be created by passing it a lightweight ITextVersionRange (see the Offsets, Ranges, and Positions topic for details on how to create a version range), along with a tag.

Modifying the Collection

The tagger works just like a collection, where tagged version ranges (TagVersionRange`1 objects) can be added to it with the Add method. Similar Remove and Clear methods are also available.

Two additional overloads for the Add method allows for adding a TagVersionRange`1 indirectly by specifying a TextSnapshotRange and ITag, or an ITextSnapshotLine and ITag. In the latter case, the tagged region will track with a single line. Both of these overloads set the created TagVersionRange`1 to be deleted when it becomes zero-length. If more find-grained control over tracking modes (how the range adjusts due to text changes) is required, use the lower-level Add method that takes a TagVersionRange`1 directly.

An additional overload of the Remove method allows for indirectly removing a TagVersionRange`1 by finding the instance that has a specified ITag.

Two Toggle method overloads toggle whether a tagged range appears over a certain text range. Just like the additional Add method overloads, one accepts a TextSnapshotRange and ITag, and the other an ITextSnapshotLine and ITag. If any tags (within the same tagger) are located in the covered range, they will be removed. If there are no tags within that range, the result is the same as calling the related Add method.

Batch Updates

The tagger will fire off a TagsChanged event any time the collection is modified. When adding multiple tagged ranges, this is not efficient. Therefore, batches are supported. A batch can be created by calling the CreateBatch method. This returns an IDisposable object. When the object gets disposed, the batch is ended and the TagsChanged event is raised. Therefore this disposible object is ideal for use within a C# using block.

This code shows how to wrap tagger modification code in a batch update:
C#
VB
Copy
​using (IDisposable batch = tagger.CreateBatch()) {
    // Make batch updates here
}
​Using batch As IDisposable = tagger.CreateBatch()
    ' Make batch updates here
End Using

Finding Tags

The indexer of the ICollectionTagger`1 type allows you to specify an ITag and the related TagVersionRange`1 item is returned, if one is found.

ICollectionTagger`1 also supports more complex search operations via its FindNext method overloads. The FindNext method will find the next TagVersionRange`1 from the starting point that matches the options that are specified. This method is very useful in scenarios such as trying to find the next bookmark tagged range from the current caret offset in an editor.

One overload is line-based and accepts a start ITextSnapshotLine argument. The other is offset-based and accepts a start TextSnapshotOffset argument. Both overloads also take an optional ITagSearchOptions`1 argument.

The options have properties for setting whether the search should search upwards instead of downward (the default), if the search can wrap if it reaches the start/end of the document with no match, and a filter predicate that can allow for a lambda to decide whether a potential match is valid.

Parse Error Taggers

A ParseErrorTagger class may be available, which is a tagger for ISquiggleTag. When this tagger is provided to a document, it will watch for updates to the document's ParseData property. It will see if the parse data implements the IParseErrorProvider interface. If it does, this tagger will automatically provide related squiggle tags for all parse errors, and when in an editor, will automatically render squiggles under the appropriate text ranges.

For performance reasons, the tagger limits the number of parse errors it can tag. This limit defaults to 5,000, but can be adjusted by changing the ParseErrorTagger.MaximumParseErrorCount property to another value.

This tagger can be attached to a document via a document-oriented tagger provider, described below.

Tagger Base Classes

There are several classes that can be used as base classes for tagger implementations.

Type Description
TaggerBase`1

This is an abstract base class for a tagger that implements nearly all of the ITagger`1 inteface. The only method that you need to implement in an inheriting class is the GetTags method.

In most scenarios, this is the ideal base class to use when writing a tagger.

The TaggerBase`1 constructor takes a string key that identifies the tagger, an optional collection of IOrderable objects (if ordering the tagger), and the ICodeDocument that the tagger is for. There also is an optional flag indicating whether or not the tagger is for a language. In most cases this should be true since it will automatically disconnect the tagger if the document's language is changed.

TokenTagger

This class is used for the special token tagger functionality that is described above. For languages with mergable lexers, an instance of this class can be installed as-is. However for languages with non-mergable lexers, you can make class that inherits TokenTagger and overrides its ClassifyToken method, which returns the IClassificationType to use for an IToken.

Sample: ITagger<ISquiggleTag> Implementation

In this sample we have implemented a tagger that uses the .NET regular expression engine to search for a text pattern. When a match is found, it is tagged with an ISquiggleTag. Assuming this is being used with an editor, a squiggle line will appear under the related text.

C#
VB
Copy
​/// <summary>
/// Provides <see cref="ISquiggleTag"/> objects over text ranges that contain the specified regex pattern text.
/// </summary>
public class CustomSquiggleTagger : TaggerBase<ISquiggleTag> {

    /// <summary>
    /// Initializes a new instance of the <c>CustomSquiggleTagger</c> class.
    /// </summary>
    /// <param name="document">The document to which this manager is attached.</param>
    public CustomSquiggleTagger(ICodeDocument document) :
        base("ActiproPatternBasedSquiggle", null, document, true) {}

    /// <summary>
    /// Returns the tag ranges that intersect with the specified normalized snapshot ranges.
    /// </summary>
    /// <param name="snapshotRanges">The collection of normalized snapshot ranges.</param>
    /// <param name="parameter">An optional parameter that provides contextual information about the tag request.</param>
    /// <returns>The tag ranges that intersect with the specified normalized snapshot ranges.</returns>
    public override IEnumerable<TagSnapshotRange<ISquiggleTag>> GetTags(
        NormalizedTextSnapshotRangeCollection snapshotRanges, object parameter) {

        if (snapshotRanges != null) {
            // Loop through the snapshot ranges
            foreach (TextSnapshotRange snapshotRange in snapshotRanges) {
                // Get the text of the snapshot range
                string text = snapshotRange.Text;

                // Look for a regex pattern match
                MatchCollection matches = Regex.Matches(text, @"\bActipro\b", RegexOptions.IgnoreCase);
                if (matches.Count > 0) {
                    // Loop through the matches
                    foreach (Match match in matches) {
                        // Create a tag
                        SquiggleTag tag = new SquiggleTag();

                        // Yield the tag
                        yield return new TagSnapshotRange<ISquiggleTag>(
                            TextSnapshotRange.FromSpan(snapshotRange.Snapshot,
                                snapshotRange.StartOffset + match.Index, match.Length), tag);
                    }
                }
            }
        }
    }
}
​''' <summary>
''' Provides <see cref="ISquiggleTag"/> objects over text ranges that contain the specified regex pattern text.
''' </summary>
Public Class CustomSquiggleTagger
    Inherits TaggerBase(Of ISquiggleTag)

    ''' <summary>
    ''' Initializes a new instance of the <c>CustomSquiggleTagger</c> class.
    ''' </summary>
    ''' <param name="document">The document to which this manager is attached.</param>
    Public Sub New(ByVal document As ICodeDocument)
        MyBase.New("ActiproPatternBasedSquiggle", Nothing, document, True)
    End Sub

    ''' <summary>
    ''' Returns the tag ranges that intersect with the specified normalized snapshot ranges.
    ''' </summary>
    ''' <param name="snapshotRanges">The collection of normalized snapshot ranges.</param>
    ''' <param name="parameter">An optional parameter that provides contextual information about the tag request.</param>
    ''' <returns>The tag ranges that intersect with the specified normalized snapshot ranges.</returns>
    Public Overrides Function GetTags(ByVal snapshotRanges As NormalizedTextSnapshotRangeCollection, _
        ByVal parameter As Object) As IEnumerable(Of TagSnapshotRange(Of ISquiggleTag))

        Dim results As List(Of TagSnapshotRange(Of ISquiggleTag)) = New List(Of TagSnapshotRange(Of ISquiggleTag))
        If snapshotRanges IsNot Nothing Then
            ' Loop through the snapshot ranges
            For Each snapshotRange As TextSnapshotRange In snapshotRanges
                ' Get the text of the snapshot range
                Dim text As String = snapshotRange.Text

                ' Look for a regex pattern match
                Dim matches As MatchCollection = Regex.Matches(text, "\bActipro\b", RegexOptions.IgnoreCase)
                If matches.Count > 0 Then
                    ' Loop through the matches
                    For Each match As Match In matches
                        ' Create a tag
                        Dim tag As New SquiggleTag()

                        ' Yield the tag
                        results.Add(New TagSnapshotRange(Of ISquiggleTag)(TextSnapshotRange.FromSpan( _
                            snapshotRange.Snapshot, snapshotRange.StartOffset + match.Index, match.Length), tag))
                    Next match
                End If
            Next snapshotRange
        End If
        Return results
    End Function
End Class

Tagger Providers

Tagger providers are objects that can create/retrieve taggers for a particular document or view. Taggers can be created for either a document or a view and their providers are called on-demand when a related tagger is needed.

The general rule is that if a tagger is going to provide tags for that document that should show up in any view that uses the document, a document-oriented tagger provider should be used. Most taggers fall into this category. An example of this would be a tagger that provides syntax error tags. Document-oriented tagger providers are represented by the ICodeDocumentTaggerProvider interface.

For other cases where a tagger should be for a specific view, a view-oriented tagger provider should be used. An example of this would be a tagger that relies on the current selection in a view. View-oriented tagger providers are represented by the ITextViewTaggerProvider interface.

Both tagger provider interfaces have two members: a TagTypes property that returns an enumerable of the Type of tags that are returned by provided taggers, and a GetTagger method that returns a tagger instance to use for the specified document/view.

Built-In Implementation Classes

These types are built-in classes that can be registered as services on syntax languages and used to provide taggers.

Type Description
CodeDocumentTaggerProvider`1

Creates a tagger is associated with an ICodeDocument and any view that uses it.

A constructor overload accepts a "singleton" object key that can be used to persist any created tagger into the ICodeDocument.Properties dictionary using the key. In this case, if the document's language changes, the tagger is automatically closed and removed from the properties dictionary. The tagger associated with the document can be retrieved via the properties dictionary while it is active.

If no "singleton" object is is passed to the tagger provider, a new tagger class instance will be created each time a tag aggregator requests one.

TextViewTaggerProvider`1

Creates a tagger is associated with a specific text view. This type is only available when an editor is used.

A constructor overload accepts a "singleton" object key that can be used to persist any created tagger into the ITextView.Properties dictionary using the key. In this case, if the view's document or the document's language changes, the tagger is automatically closed and removed from the properties dictionary. The tagger associated with the view can be retrieved via the properties dictionary while it is active.

If no "singleton" object is is passed to the tagger provider, a new tagger class instance will be created each time a tag aggregator requests one.

TokenTaggerProvider`1

Creates a token tagger (see above for more info) that is associated with an ICodeDocument and any views that use it.

Only one token tagger provider should ever be registered as a service on the same language at a time.

Registering with a Syntax Language

As described above, CodeDocumentTaggerProvider`1, TextViewTaggerProvider`1, and TokenTaggerProvider`1 objects can be used as language services to provide taggers to any tag aggregator that request them.

This code shows how to register a document-oriented tagger provider language service that provides ParseErrorTagger objects for documents that use the language. Note that we are also passing a "singleton" key so that the tagger that is created for any document using the language is persisted in the document's Properties dictionary while it is active.

C#
VB
Copy
​language.RegisterService(new CodeDocumentTaggerProvider<ParseErrorTagger>(typeof(ParseErrorTagger)));
​language.RegisterService(New CodeDocumentTaggerProvider(Of ParseErrorTagger)(GetType(ParseErrorTagger)))

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tag Aggregators

Tag aggregators are objects that can monitor all the available taggers for a specific tag type and can return a unioned set of tagged snapshot ranges for a requested snapshot range. They are used for consuming the results of taggers.

This topic contains these sections:

  • When to Use Tag Aggregators?
  • Document- or View-Oriented Tag Aggregators
  • Collecting Tags
  • Notification of Tag Changes

When to Use Tag Aggregators?

Tag aggregators are used when you need to collect all the available tagged ranges for a certain snapshot range. Most often, tag aggregators are used in conjunction with adornment layers managers in editors. In this scenario, a tagger is used to mark ranges of text with a custom tag, basically indicating the ranges that need some sort of adornment. Then an adornment layer manager creates a tag aggregator for this custom tag. When the adornment layer manager builds adornments for a certain editor view line, it uses the tag aggregator to get the custom tags that fall in that line's text range and makes appropriate adornments based on the data passed in the custom tag.

To sum up, think of tags as data. Taggers are the data providers. Tag aggregators are the data consumers.

Document- or View-Oriented Tag Aggregators

As discussed in the Taggers and Tagger Providers topic, tagger providers can be oriented to create taggers either for an ICodeDocument or for an ITextView. Similarly, tag aggregators can be document- or view-oriented.

Document-oriented tag aggregators are created by calling the ICodeDocument.CreateTagAggregator method. The type of tag to collect is indicated as a type parameter to that method. The tag aggregator collects all the appropriate tags from any taggers associated with the document.

View-oriented tag aggregators are created by calling the ITextView.CreateTagAggregator method. The type of tag to collect is indicated as a type parameter to that method. The tag aggregator collects all the appropriate tags from any taggers associated with the view's document or with that specific view.

Collecting Tags

The ITagAggregator`1 inteface defines two overloads of a GetTags method. Both methods allow you to request the tags that fall into one or more snapshot ranges.

When either of these methods are called, the tag aggregator examines all of the appropriate taggers that provide the tag type associated with the tag aggregator.

Notification of Tag Changes

Whenever one of the taggers being monitored by a tag aggregator raises an event that notifies its tags have changed, the tag aggregator bubbles the event up as well via the TagsChanged event. Thus any listeners to this event can refresh themselves by requesting the updated tags in the affected range.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Parsing is the process of performing syntax and/or semantic analysis on a text, and outputting some sort of parse data, generally an AST. The parsing framework supports automated calling of parsers via worker threads following text changes. Any custom or third-party parser (such as ANTLR) can be called.

This topic contains these sections:

  • Parse Requests and Dispatchers
  • Parsers
  • AST Nodes
  • Code Fragments
  • The Actipro LL(*) Parser Framework
  • Free Integration with Popular Third-Party Parsers

Parse Requests and Dispatchers

Parse requests are created to request that syntax/semantic analysis be performed on some text. ICodeDocument is capable of automatically making parse requests when its text changes, so long as its ISyntaxLanguage has an IParser service registered.

A parse request dispatcher is notified of incoming parse requests and queues them. It uses one or more worker threads to execute the requested parsing operations in prioritized order, thereby preventing any blocking of the main UI thread.

See the Parse Requests and Dispatchers topic for more information.

Parsers

Parsers are objects that take in a parser request and output some sort of parse data. They are generally called via worker threads to prevent the blocking of the main UI thread.

The parse data returned by a parser is a result of performing syntax and/or semantic analysis on some text indicated by a parse request. Parsers can optionally be implemented to call into other parsing frameworks (Irony, ANTLR, etc.) and return their results.

See the Parsers topic for more information.

AST Nodes

An abstract syntax tree (AST) is a structural tree representation of source code, without the specific details of the language, such as punctuation. An AST is comprised of AST Nodes, each which represent a particular construct in the concrete syntax.

See the AST Nodes topic for more information.

Code Fragments

Documents support code fragment editing, whereby the editable document text is a code fragment that is to be surrounded by header and footer text for the purposes of parsing. This is useful in situations where a language with parsing capabilties is used by a document but the end user should only be able to edit the contents of a specific method, expression, etc.

See the Code Fragments topic for more information.

The Actipro LL(*) Parser Framework

Actipro offers a very robust parser framework that makes it simple to build parsers using EBNF-like notation in C# and VB. It is free to use, has AST construction, error handling, callbacks, and a lot of other features that make it integrate nicely with our core text/parsing framework.

See the LL(*) Parser Framework section for more information.

Free Integration with Popular Third-Party Parsers

There are three free add-ons that come with SyntaxEditor that make it easy to integrate with popular third-party parsers:

  • ANTLR Add-on
  • Irony Add-on

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parse Requests and Dispatchers

Parse requests are created to request that syntax/semantic analysis be performed on some text. CodeDocument is capable of automatically making parse requests when its text changes, so long as its ISyntaxLanguage has an IParser service registered.

A parse request dispatcher is notified of incoming parse requests and queues them. It uses one or more worker threads to execute the requested parsing operations in prioritized order, thereby preventing any blocking of the main UI thread.

This topic contains these sections:

  • Initializing an Ambient Parse Request Dispatcher for an Application
  • CodeDocument Makes Automatic Parse Requests
  • Manually Triggering CodeDocument Parse Requests
  • Creating a Parse Request Manually
  • Other Parse Request Features
  • Other Parse Request Dispatcher Features

Initializing an Ambient Parse Request Dispatcher for an Application

An IParseRequestDispatcher is an object that is capable of receiving parse requests (IParseRequest instances). Upon receipt of a request, it will generally queue the request, possibly disposing of similar previous requests that are still on the queue.

One or more worker threads are then used to perform parsing operations, one by one, based on the data in the requests. More than one worker thread is advantageous when there are potentially many parsing requests queued, while editing of a code document (via a SyntaxEditor control for instance) is taking place. This allows the requests made by the code document to continue to get handled fast, intermixed with the other queued requests.

Important Note Important Note
By default, no ambient IParseRequestDispatcher is installed meaning parsing from code documents (explained in next section) will be done in the main UI thread. Configure an ambient parse request dispatcher (see below) to ensure parsing operations are offloaded into worker threads.

ThreadedParseRequestDispatcher

ThreadedParseRequestDispatcher is the default implementation of an IParseRequestDispatcher that ships with the parsing framework. It is capable of handling parse requests on one or more worker threads.

By default it creates a maximum number of worker threads that is equal to your machine's processor core count minus one. Thus on a quad-core machine, up to three worker threads may be created. If a worker thread is not used for some time, it will be disposed of.

Configuring the Ambient Parse Request Dispatcher

As described below, code documents are capable of making automatic parse requests. They need to know which IParseRequestDispatcher to use though. If they can't find one, then they execute the parsing operation in the main UI thread, which can block UI if the parsing operation takes time.

The AmbientParseRequestDispatcherProvider class is used to indicate which IParseRequestDispatcher should be used by default. Code documents look at the AmbientParseRequestDispatcherProvider, and any manual parse requests should too.

This code is executed at application startup and creates a ThreadedParseRequestDispatcher for use as the ambient parse request dispatcher.

C#
VB
Copy
​AmbientParseRequestDispatcherProvider.Dispatcher = new ThreadedParseRequestDispatcher();
​AmbientParseRequestDispatcherProvider.Dispatcher = New ThreadedParseRequestDispatcher()

Once the code above is executed, worker threads will now be used to execute parsing operations.

At application shutdown, this code can be used to remove the ambient parse request dispatcher, kill its worker threads, and empty its parse queue.

C#
VB
Copy
​IParseRequestDispatcher dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
AmbientParseRequestDispatcherProvider.Dispatcher = null;
dispatcher.Dispose();
​Dim dispatcher As IParseRequestDispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
dispatcher.Dispose()

CodeDocument Makes Automatic Parse Requests

Code documents (CodeDocument instances) have special features built into them such that when a text change occurs, they look at the ISyntaxLanguage that is attached to the document, if any. If the language has an IParser registered as a service, an IParseRequest is automatically generated and sent to the IParseRequestDispatcher specified by the AmbientParseRequestDispatcherProvider to be queued for processing.

Note Note
As indicated above, if no ambient parse request dispatcher is configured, parsing operations will be performed in the main UI thread, possibly blocking it if the parsing operations take time to complete.

All of the parse request generation occurs automatically, as long as a parser is found on the language. The results of the parse operation are returned asynchronously to the ICodeDocument.ParseData property, at which time the document's ParseDataChanged event fires.

Note that ICodeDocument implements IParseTarget, so any code document is capable of receiving parsing operation results. That is how CodeDocument knows when to update its ParseData property.

Manually Triggering CodeDocument Parse Requests

Sometimes there are situations where a configuration option that the parser uses has changed but the text of an ICodeDocument has not been modified. Thus the parse data for the document may no longer be valid.

The ICodeDocument.QueueParseRequest method can be called in this scenario to manually queue up a parse request for the document. Once the parse request is processed, the document's ParseData property will be updated. As discussed above, like all parsing operations, this process may be asynchronous.

Creating a Parse Request Manually

Parse requests can be created manually for any bit of text. No document is necessary. Say that you are loading a C# project and would like to load compilation unit data for each one of the files in the project. In that case you could queue up parsing requests for each of the files. It is best to use a low priority so that the queued requests don't interfere with normal editor/code document parsing.

The ParseRequest class implements IParseRequest. Its constructor takes several parameters:

  • A string source key that identifies the source
  • An ITextBufferReader that is used by the parser to scan text
  • The ISyntaxLanguage (preferred) or IParser that should be used to perform the parsing operation
  • The IParseTarget that is notified once the parsing is completed

The source key is generally a filename but really can be anything you like that uniquely identifies the text content being parsed.

The ITextBufferReader can be any object that supports text reading per the interface members. The interface is described in the Scanning Text Using a Reader topic.

The ISyntaxLanguage is a language that has an IParser. If no ISyntaxLanguage is available, then an IParser instance can be passed in its place, but it is better to pass the language instance. The IParser is any object that has a Parse that accepts an IParseRequest and returns an IParseData result.

The IParseTarget is an object that has a unique ID identifying it, along with a method that is called after a request has been processed and completed.

This code shows how to create a manual request without a language available and queue it:

C#
VB
Copy
​// Create the request
string sourceKey = @"c:\myfilename.txt";
ITextBufferReader reader = new StringTextBufferReader("Text to parse");
IParser parser = new MyTextParser();  // Some class implementing IParser
IParseTarget parseTarget = this;  // Assuming class that executes this code implements IParseTarget
IParseRequest request = new ParseRequest(sourceKey, reader, parser, parseTarget);
request.Priority = ParseRequest.LowPriority;

// Queue the request
if (AmbientParseRequestDispatcherProvider.Dispatcher != null)
    AmbientParseRequestDispatcherProvider.Dispatcher.QueueRequest(request);
​' Create the request
Dim sourceKey As String = "c:\myfilename.txt"
Dim reader As ITextBufferReader = New StringTextBufferReader("Text to parse")
Dim parser As IParser = New MyTextParser() ' Some class implementing IParser
Dim parseTarget As IParseTarget = Me ' Assuming class that executes this code implements IParseTarget
Dim request As IParseRequest = New ParseRequest(sourceKey, reader, parser, parseTarget)
request.Priority = ParseRequest.LowPriority

' Queue the request
If AmbientParseRequestDispatcherProvider.Dispatcher IsNot Nothing Then
    AmbientParseRequestDispatcherProvider.Dispatcher.QueueRequest(request)
End If

Other Parse Request Features

The IParseRequest has some additional useful features.

Creation and Identification

The CreatedDateTime property indicates when the request was created.

The ParseHashKey property returns a hash key that can be used to identify the request, and is used in many IParseRequestDispatcher members.

Queueing - Priority and Optimization

The Priority property allows the priority of the request to be set. Manual parse requests should generally use the priority specified by ParseRequest.LowPriority. Code document requests use MediumPriority. IParseRequestDispatcher implementations generally use the priority setting to determine how to queue requests.

The RepeatedRequestPause property lets you indicate the number of milliseconds to pause if there are repeated attempts for the same request. This scenario can happen if an editor is working on a code document and a lot of typing is occurring. By introducing a small pause, performance is optimized. The default value is 250.

Originating Text Snapshot

The Snapshot property returns a ITextSnapshot that indicates the snapshot from which the request was made, if available. Note that while this property is automatically populated when CodeDocument creates the request, manually-created parse requests may choose not to specify a snapshot.

State

The State property returns a ParseRequestState value that indicates the current state of the request, such as whether it is queued, or being parsed, etc.

Custom Data

The Tag property allows for custom data to be passed along with the request, all the way through to the IParseTarget.

Other Parse Request Dispatcher Features

Generally it is not necessary to call any additional methods on IParseRequestDispatcher since the entire queue and dispatch processing is mostly automated for your convenience. However there are a number of useful members on the dispatcher that can tell you what it is currently doing, etc.

Many of the methods on the dispatcher deal with parse hash keys, which can be retrieved from the IParseRequest.ParseHashKey property.

Queue Updating

The QueueRequest method is used to tell the dispatcher that a new IParseRequest needs to be queued for processing. See the manual parse request example above for a sample of code calling this method.

The RemovePendingRequests method accepts a parse hash key and removes any queued instances of requests with that hash key, if there are any.

Dispatcher Examination

The IsBusy property indicates if there are any requests that need to be completed. PendingRequestCount returns the number of pending requests remaining.

GetPendingRequests returns an array of the pending requests remaining. HasPendingRequest returns whether there are any pending requests with a specific parse hash key.

Blocking Until a Request Has Been Processed

The WaitForParse method can be used to block the calling thread until a pending request with the specified hash key is completed, or a certain timespan is elapsed. The standard timespan used is 250ms.

This method is generally used before building contextual data for IntelliPrompt display since ideally you want the IntelliPrompt UI to have the most up-to-date data in it.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsers

Parsers are objects that take in a parser request and output some sort of parse data. They are generally called via worker threads to prevent the blocking of the main UI thread.

The parse data returned by a parser is a result of performing syntax and/or semantic analysis on some text indicated by a parse request. Parsers can optionally be implemented to call into other parsing frameworks (Irony, ANTLR, etc.) and return their results.

This topic contains these sections:

  • What Does a Parser Do?
  • The IParser Interface
  • The Abstract ParserBase Class
  • Registering with a Syntax Language
  • The IParseData Interface
  • Document Parse Data
  • Quickly Parsing a Text String

What Does a Parser Do?

A parser is an object that can perform syntax and/or semantic analysis on text.

Processing Diagram

The concept is best illustrated with the following diagram, which shows the sequence of events that occur when a text change occurs in a code document. Near the end of the cycle, parsing kicks in and returns the parse data result back to the document.

Note that generally an IParseRequestDispatcher is used to queue parse requests and execute them on worker threads, meaning that parsing most often occurs asynchronously.

Syntax and Semantic Analysis

Syntax analysis is the process of iterating the tokens returned by a lexer, and converting that input into some structured representation. Put quite simply, it is the process of determining the structure of the code. The output from this sort of analysis is generally some sort of parse or syntax tree.

Semantic analysis is more concerned with examining the code to determine its meaning, rather than its syntax, although the output from syntax analysis is often used as input to the semantic analysis phase. Semantic checks may include type-checking, scope rules, or any other requirements described by a language specification.

The output of most parsers is some sort of abstract syntax tree (AST) with the root node being called a compilation unit. It may include symbol table data and/or a list of the syntax/semantic errors that were located during the parsing operation, if there were any. Any data can be returned, as long as it implements the IParseData interface.

Although the syntax and semantic analysis methodology described above is the formal definition of what generally takes place in parsing, parsing really can be any sort of processing that performed as a result of text scanning.

The IParser Interface

The IParser interface is very simple and only has a single Parse method defined. The Parse method takes in an IParseRequest and returns an IParseData object.

Note Note
See the Parse Requests and Dispatchers topic for more information on parse requests.

What does a parser actually do? Well it's entirely up to you. Generally, it calls some sort of external parser such as Irony, ANTLR, etc. to examine the text in the request and return some sort of result.

However the parser could be implemented to simply execute your own custom code instead. Maybe you don't need to run a complicated parser that builds an AST and you simply want to build a list of variables defined and where they are defined. Anything is possible by scanning the text.

The only requirement for whatever the parser does is that it return its results in the form of an IParseData object. This object then gets placed in the calling ICodeDocument's ParseData property.

The Abstract ParserBase Class

An abstract base class called ParserBase that implements IParser is included with the parsing framework.

A parser can be implemented like this:

C#
VB
Copy
​public class MyParser : ParserBase {

    public MyParser() : base("MyParser") {}

    public override IParseData Parse(IParseRequest request) {
        IParseData parseData = null;

        // Perform some sort of parsing here and place the result in parseData

        return parseData;
    }

}
​Public Class MyParser
    Inherits ParserBase

    Public Sub New()
        MyBase.New("MyParser")
    End Sub

    Public Overrides Function Parse(ByVal request As IParseRequest) As IParseData
        Dim parseData As IParseData = Nothing

        ' Perform some sort of parsing here and place the result in parseData

        Return parseData
    End Function

End Class

Once you have a parser class defined, you should register it with your language.

Registering with a Syntax Language

An IParser can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<IParser>(new MyParser());
​language.RegisterService(Of IParser)(New MyParser())

Once the parser is registered with a language, it will be called automatically if any code documents that use the language are modified. See the Parse Requests and Dispatchers topic for more information.

When no IParser is registered with a language that is being used by a code document, then no parsing will occur when changes are made to that document.

The IParseData Interface

The IParseData interface defines the base requirements for an object that is returned as the result of a parsing opertion.

There are not currently any default implementations of this interface so you must ensure that any object that is returned by an IParser implements the interface.

Document Parse Data

The ICodeDocument.ParseData property is used to store the last parse result received for the document by an IParser.

When an IParser completes a parse operation, the IParseData that is returned is placed in the calling ICodeDocument's ParseData property. This generally happens asynchronously if a Parse Request Dispatcher is used.

At that time, the ICodeDocument.ParseDataChanged event fires, allowing you to update the user interface or take other action as appropriate.

Quickly Parsing a Text String

In some cases, it is desirable to load an ISyntaxLanguage and use its parser to parse a text string. There is an extension method called SyntaxLanguageParsingExtensions.Parse that is available when the Parsing namespace is referenced. This makes it simple to obtain the IParseData result of a parsing operation executed on the specified text.

The parsing operation executes within the calling thread, meaning the thread will block until the resulting parse data is obtained.

This sample code shows how to parse a string containing a C# code snippet, by using the CSharpSyntaxLanguage found in the .NET Languages Add-on:

C#
VB
Copy
​ISyntaxLanguage language = new CSharpSyntaxLanguage();
IParseData parseData = language.Parse("class Foo {}");
​Dim language As ISyntaxLanguage = New CSharpSyntaxLanguage()
Dim parseData As IParseData = language.Parse("class Foo {}")

The resulting IParseData object can be cast to the appropriate type that can provide AST and parse error results.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AST Nodes

An abstract syntax tree (AST) is a structural tree representation of source code, without the specific details of the language, such as punctuation. An AST is comprised of AST Nodes, each which represent a particular construct in the concrete syntax.

This topic contains these sections:

  • An Example
  • Introduction to IAstNode
  • The DefaultAstNode Class
  • Type-Specific AST Nodes
  • The AstNodeBase Class

An Example

Here is an example of an AST for two simple expressions. Notice how the constructs of the original expressions are communicated through the AST, but language-specific syntactical details (such as operator precedence and punctuation) are excluded. The AST is correct for both expressions.

Sample Expression 1
Copy
1 + 4 / 7
Sample Expression 2
Copy
1 + (4 / 7)
Sample AST
Copy
"+" [
    1
    "/" [
        4
        7
    ]
]

Introduction to IAstNode

The IAstNode interface provides the base requirements for an AST node. It provides a standardized way for your syntax language's services to communicate or consume the syntactical structure of the document. Any custom or third-party AST node classes can be made to implement the interface.

IParser implementations generally create some sort of AST (a tree of IAstNode objects) for the document being parsed and provide the resulting AST as a property on the IParseData that is returned. The parse data as a whole is stored in the ICodeDocument.ParseData property, which it is available to other language services.

For instance, a code outliner could consume the IAstNode tree by searching for function declaration nodes and making the text range collapsible.

IAstNode Members

Member | Description
Children Property | Gets the list containing the child AST nodes of this AST node.
Contains Method | Returns whether the AST node contains the specified offset.
EndOffset Property | Gets or sets the end offset of the AST node, if known.
FindChildNode Method | Searches through the child nodes for a node that contains the specified offset.
FindDescendantNode Method | Recursively searches through the descendant nodes for a node that contains the specified offset.
HasChildren Property | Gets whether the AST node contains any child AST nodes.
Length Property | Gets the character length of this AST node, if known.
StartOffset Property | Gets or sets the start offset of the AST node, if known.
ToTreeString Method | Outputs the contents of the AST node in tree form.

The DefaultAstNode Class

The DefaultAstNode class provides a completely generic implementation of the IAstNode interface, where each node has a string Value and can contain any other node in its Children collection.

This class is good to use when first prototyping out a grammar, or in scenarios where type-specific AST nodes are not required. It is the default AST node type used by the LL(*) Parser Framework's tree constructors that don't designate a specific AST node type.

Type-Specific AST Nodes

Sometimes it is beneficial to have specific types of AST nodes, where a distinct .NET class is created for each type of AST node. Take this snippet of C# for example, a simple class declaration:

Code Snippet
Copy
class Foo {}

With the default AST nodes discussed above, a resulting AST would be something like:

Code Snippet
Copy
ClassDeclaration[
    Name[
        "Foo"
    ]
]

It's easy to imagine how large the AST grows as you get into much more complex code since additional AST nodes are typically used to describe the context of their contained nodes, such as with the Name node above.

In contrast, assume we build a class called ClassDeclaration like this:

C#
VB
Copy
​public class ClassDeclaration : AstNodeBase {
    public string Name { get; set; }
    ...
}
​Public Class ClassDeclaration
    Inherits AstNodeBase

    Public Property Name() As String
    ...

End Class

The ClassDeclaration class is a type-specific AST node, where instead of wrapping our Foo value node with another Name node, we simply set a string property called Name to the value Foo. The snippet that originally required three AST nodes to represent, now just uses one AST node with a property set. Thus the overall complexity of the AST is reduced.

Another major benefit of using type-specific AST nodes is that since they are .NET classes, you can fully extend them with partial classes, etc. This makes it easy to add helper methods/properties or to override the default ToString result.

The only downside of using type-specific AST nodes is that they can take more time to develop, since you need to define a class for each type of AST node your language grammar can generate. Luckily, we've made this almost a non-issue since the Language Designer tool has full type-specific AST node code generation features. All you have to do is indicate a few settings for each AST node type and its properties, and the code will be generated for you.

The AstNodeBase Class

The abstract AstNodeBase class is available to use as a base class for any type-specific AST nodes. It fully implements the IAstNode interface.

The only requirement of inheritors is that they override its GetChildrenEnumerator method to return an enumerator for any IAstNode objects that are children of the node. This allows the node's IAstNode.Children property enumerate child nodes.

For instance, a ClassDeclaration class might define a Members property where each member is represented by another AST node. In this scenario, the GetChildrenEnumerator method should be overridden to return those AST nodes.

If your type-specific AST nodes are generated by the Language Designer tool, all this work is done for you.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Fragments

Documents support code fragment editing, whereby the editable document text is a code fragment that is to be surrounded by header and footer text for the purposes of parsing. This is useful in situations where a language with parsing capabilties is used by a document but the end user should only be able to edit the contents of a specific method, expression, etc.

This topic contains these sections:

  • How It Works
  • An Example
  • Languages With Significant Line Terminators

How It Works

To set the optional header and footer text for a document, use the ITextDocument.SetHeaderAndFooterText method.

When this method is called, a new ITextSnapshot is created for the document with updated HeaderText and FooterText properties.

Whenever the document's text is changed, a new parse request is made if the document's language has a parser service. One component of this parse request is an ITextBufferReader that is used by the parser to read through the snapshot's text and parse it. A method called ITextSnapshot.GetMergedBufferReader is used to obtain an ITextBufferReader for this purpose. If header/footer text are specified for the snapshot, they are included as part of that buffer reader. The end result is that the parser thinks that the header/footer text, which surround the snapshot's text, are part of the snapshot's text, even though they really are not. All of this happens automatically behind the scenes.

Note Note
If header text is used, the reader will start at a negative offset. This is done so that the real snapshot text still aligns to offset 0, and all AST nodes, syntax errors, etc. that are created by the parser will properly align with the offsets of the snapshot text.

An Example

Say that you wanted an editor to only edit a method body but you still want full IntelliPrompt features while editing. This is an example of code fragment editing.

First you define the header and footer of the code fragment. The header contains the namespace, class, and member declarations. The footer contains the closing braces and any other members that should be accessible while editing the code fragment. The header and footer are set via the ITextDocument.SetHeaderAndFooterText method.

This is an example of C# code fragment editing, where a class named Foo contains a method Bar, and the document's text will be editing the contents of that method.

C#
VB
Copy
​document.SetHeaderAndFooterText("class Foo { object Bar() {", "}}");
​document.SetHeaderAndFooterText("class Foo { object Bar() {", "}}")

If the document's current snapshot has return null; in its text, the buffer reader sent to the parser for parsing will contain:

Code Snippet
Copy
class Foo { object Bar() {return null;}}

The AST built for the document will fully contain the Foo class and Bar method, and any syntax errors will be reported correctly. This allows advanced languages with resolvers and automated IntelliPrompt features to have their functionality work correctly, even in code fragment editing scenarios.

Languages With Significant Line Terminators

Some languages such as Visual Basic treat line terminators as significant tokens in their parser grammars. Namely, in VB, line terminators end statements.

Thus in languages like this, it's very important to ensure there is a line terminator at the end of any header text specified, and probably also at the start of any footer text specified. Since the header, snapshot, and footer text are simply appended together, this ensures that no syntax errors will be generated from missing line terminators.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The text framework contains numerous advanced features that build upon the core text features, everything from a search object model to the exporting of HTML and RTF.

This topic contains these sections:

  • Low-Level Search Operations
  • Undo History
  • Text Statistics
  • Exporting to HTML / RTF
  • Line Commenting
  • Text Formatting
  • Structure Matching
  • Lipsum Generator
  • Document Properties

Low-Level Search Operations

The text framework contains an object model for performing low-level search operations. This low-level object model is usually called by higher-level search object models that are more view-based.

See the Low-Level Search Operations topic for more information.

Undo History

The text framework's undo history tracks undoable text changes, allows for examination and manipulation of the undo/redo stacks, and provides access to the change types (unsaved/saved) for snapshot lines.

See the Undo History topic for more information.

Text Statistics

Text statistics are a powerful feature that provide statistics about text in a document. By default, there are numerous text statistics available, even including things like readability scores. Syntax languages can also choose to customize the statistics by supplying additional ones such as commented-line counts, etc.

See the Text Statistics topic for more information.

Exporting to HTML / RTF

Text from a snapshot can easily be exported to a String or file in various HTML and RTF (rich text) formats.

See the Exporting to HTML / RTF topic for more information.

Line Commenting

The text framework includes an extensible interface for commenting and uncommenting regions of text. Both line-based and range comment styles are supported.

See the Line Commenting topic for more information.

Text Formatting

The text framework includes an interface for formatting regions of text, where whitespace and other symbols such as braces are adjusted to make code more readable.

See the Text Formatting topic for more information.

Structure Matching

The text framework includes support for locating matching structural text delimiters, such as brackets.

See the Structure Matching topic for more information.

Lipsum Generator

A special utility class is included supports the generation of 'lorem ipsum' placeholder text. Placeholder text is useful for developers and designers when prototyping out web pages and screens. It is designed to contain unreadable gibberish sentences, which are ideal for layout.

See the Lipsum Generator topic for more information.

Document Properties

The ICodeDocument.Properties property provides a dictionary-like object that can store any sort of custom data that should be associated with the document.

See the Document Properties topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Low-Level Search Operations

The text framework contains an object model for performing low-level search operations. This low-level object model is usually called by higher-level search object models that are more view-based.

This topic contains these sections:

  • Finding Text
  • Replacing Text
  • Search Results
  • Search Options
  • Built-In Search Pattern Providers
  • Creating a Custom Search Pattern Provider

Finding Text

Since text snapshots provide immutable views on a text document, the ITextSnapshot interface contains several methods for finding text:

Member | Description
FindAll Method | Performs a find all operation. There are two overloads of this method. One overload accepts a TextRange indicating the range of offsets to search.
FindNext Method | Performs a find next operation. There are two overloads of this method. One overload accepts a TextRange indicating the range of offsets to search.

Both methods return an ISearchResultSet object that contains information about the search results. In the case of an find all operation, more than one result may be present within the result set.

Replacing Text

Since text change operations typically originate from a document, the ITextDocument interface contains several methods for replacing text:

Member | Description
ReplaceAll Method | Performs a replace all operation. There are two overloads of this method. One overload accepts a TextRange indicating the range of offsets to search.
ReplaceNext Method | Performs a replace next operation. There are two overloads of this method. One overload accepts a TextRange indicating the range of offsets to search.

Both methods return an ISearchResultSet object that contains information about the search results. In the case of an replace all operation, more than one result may be present within the result set.

Search Results

ISearchResultSet instances are what are returned by all the search methods. The result set provides a deep copy of the ISearchOptions used by the search operation, a SearchOperationType indicating the type of operation (find next, find all, etc.), whether the searching wrapped at the end of the search range, and the collection of ISearchResult objects that specify individual results.

The ToString method of the ISearchResultSet provides a text representation of the search criteria and individual results, and can be useful for display in results windows.

Each ISearchResult object indicates the TextSnapshotRange at which the result was found, and in the case of replace operations, the TextSnapshotRange of the replaced text. If no replace occurred, that TextSnapshotRange will be marked as deleted.

ISearchResult also contains a collection of captures. Since the search engine is based on regular expressions, this collection specifies the captures that were made. Each ISearchCapture has a key that identifies the capture, the text that was captured, and its offset range.

Search Options

The ISearchOptions interface contains all the settings needed to perform a search operation. These options include the text to find/replace, whether to match case, match whole word, search up, and the type of seatch pattern provider to use (normal, regular expressions, etc.). The maximum number of results can also be set, which is useful in find all scenarios.

Each core search method described above accepts an ISearchOptions instance. Any custom implementations of ISearchOptions should implement an Equals method override.

Built-In Search Pattern Providers

A search pattern format is a syntax for entering how to find and replace text within a document. Since the search engine is regular expression-based, the ISearchPatternProvider interface provides two methods, one for getting a regex pattern for supplied find text, and one for getting a regex pattern for supplied replace text.

The text framework ships with five built-in pattern providers:

  • Normal is a plain text find and replace format.
  • Regular Expression uses regular expressions to match find text, and uses regular expression replace pattern syntax to allow for replacements at different matched capture points in the find pattern.
  • Wildcard uses simple wildcard search patterns to match text.
  • Acronym matches a character at the start of a word, then every capital letter or character following an underscore.
  • Shorthand allows any non-whitespace character to be between the search pattern characters.

Note Note
The SearchPatternProviders static class provides access to each of these ISearchPatternProvider instances.

Normal Pattern Provider

This pattern provider searchs for the find text exactly as specified and replaces using the exact replace text.

Regular Expression Pattern Provider

Regular expression find/replace operations search for text by using .NET regular expression syntax pattern matching. It is important to note that pattern whitespace is ignored. Whitespace can be matched by using the \s character class.

The regular expression pattern provider has a feature that the others don't have. In its replace patterns, substitutions can be specified. Replace patterns recognize normal text characters, regular expression escape characters (\n meaning line feed, etc.), and substitution specifications ($1, etc.).

Substitutions place text from captures into the replace text. This is best illustrated by an example. Say the text to search in is using System;, the find text is using \s+ (\w[\w\.]+);, and the replace text is Namespace: $1;. This operation is looking for any C# using statement and is outputting the namespace. So the result in this scenario is Namespace: System;.

See the Regular Expression Language Elements topic for more information on the regular expression syntax.

Wildcard Pattern Provider

Wildcard pattern providers search for text by using "wildcard" pattern matching. The following wildcard patterns are recognized:

Construct | Description
* | Specifies zero or more of any character, except the line feed character.
? | Specifies any single character, except the line feed character.
# | Specifies any single digit.
[aeiou] | Matches any one character in the set.
[!aeiou] | Matches any one character not in the set.

Any other character in the pattern matches the character. An example wildcard pattern is using *;. This pattern will match any C# using statement.

Acronym Pattern Provider

Acronym searching matches a character at the start of a word, then every capital letter or character following an underscore. Space characters have special meaning to match any whitespace character.

An example acronym pattern fr would match the text FindR in the word FindReplace.

Shorthand Pattern Provider

Shorthand searching is even more open in scope than acronyms. It allows any non-whitespace character to be between the search pattern characters. Space characters have special meaning to match any whitespace character.

An example shorthand pattern fr would match the text for in the word therefore.

Creating a Custom Search Pattern Provider

Although the text framework comes packaged with the pattern providers described above, it's easy to create your own custom search pattern providers as well.

The ISearchPatternProvider interface has several members. One is a string Key that identifies it. Another is a more verbose Description that can be displayed in user interfaces. Then there are two methods that must be implemented.

The GetFindPattern method returns the regular expression match pattern to use for find operations, based on the supplied pattern that uses the provider. Likewise, the GetReplacePattern method returns the regular expression match pattern to use for replace operations, based on the supplied pattern that uses the provider.

As mentioned above, the core search engine uses our built-in regular expression engine to perform searching. Therefore search patterns used by the search engine must be provided in regular expression syntax. That is essentially what an ISearchPatternProvider does, converts a custom pattern syntax to regular expression syntax.

Finally, the RequiresCaseSensitivity property returns whether the find patterns used require case sensitivity. If this is false, the default, the ISearchOptions.MatchCase value is used instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Undo History

The text framework's undo history tracks undoable text changes, allows for examination and manipulation of the undo/redo stacks, and provides access to the change types (unsaved/saved) for snapshot lines.

This topic contains these sections:

  • Undo History
  • Clearing the Undo/Redo Stacks
  • Enumerating Undo/Redo Stack Entries
  • Performing an Undo or Redo
  • Getting the Change Type for a Line

Undo History

The ITextDocument.UndoHistory property is used to access the IUndoHistory, which provides the undo/redo features for a document.

The undo history contains two stacks, the UndoStack and RedoStack. As text changes are performed on a document, undo entries are added to the undo stack. When an undo operation is performed, the top item on the undo stack is moved to the redo stack and the document text is updated appropriately. If a redo operation is performed, the top item on the redo stack is moved back to the undo stack and the document text is updated appropriately.

Clearing the Undo/Redo Stacks

The undo/redo stacks can be cleared by calling the IUndoHistory.Clear method. The parameterless overload of this method keeps all change tracking in place, while another overload allows for specifying whether to reset change tracking.

The undo/redo stacks are automatically cleared when the ITextDocument.SetText method overload is called that only accepts a String parameter. This is done since when calling that method, it is assumed that you are completely replacing and resetting the text content of the document.

Enumerating Undo/Redo Stack Entries

The CanUndo and CanRedo properties indicate whether there are any entries currently on the undo/redo stacks.

For enumerating the stack entries, use the UndoStack and RedoStack properties to retrieve the proper stack. These both return an IUndoableTextChangeStack instance.

Each stack has a Count property and the stack is capable of enumerating IUndoableTextChange entries. A specific stack entry can be retrieved using the GetTextChange method. The capacity for a stack can be changed via the Capacity property. The default capacity is 100 entries but can be made as large or small as you wish.

The IUndoableTextChange interface contains a lot of information found on the ITextChange interface that created it. A Description property returns a description of the entry that can be displayed in user interfaces.

Performing an Undo or Redo

An undo operation can be performed like this:

C#
VB
Copy
​document.UndoHistory.Undo();
​document.UndoHistory.Undo()

An redo operation can be performed like this:

C#
VB
Copy
​document.UndoHistory.Redo();
​document.UndoHistory.Redo()

Other overloads for the Undo and Redo methods allow you to undo/redo multiple entries.

Getting the Change Type for a Line

The undo history tracks the change types for lines in the document, meaning whether lines have been modified at all, modified since the last save, or never modified. The change type is represented by the SavePointChangeType enumeration and can be either None, UnsavedChanges, or SavedChanges.

As changes occur in a document, the appropriate ranges are marked as unsaved changes. When the ITextDocument.IsModified property changes to false, the unsaved changes are modified to be saved changes. From that point on, any new changes that occur are marked unsaved again. When the undo history gets cleared (see above), all change tracking is cleared, since it is assumed that the document has been reset.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Statistics

Text statistics are a powerful feature that provide statistics about text in a document. By default, there are numerous text statistics available, even including things like readability scores. Syntax languages can also choose to customize the statistics by supplying additional ones such as commented-line counts, etc.

This topic contains these sections:

  • Built-In Statistics
  • Getting Statistics for a Snapshot
  • Getting Statistics for a String
  • Registering a Custom Statistics Factory for a Syntax Language

Built-In Statistics

The ITextStatistics interface calculates and returns statistics. It includes many built-in statistics such as:

  • Line count
  • Whitespace line count
  • Sentence count
  • Word count
  • Syllable count
  • Character count
  • Whitespace character count
  • Letter count
  • Consonant count
  • Vowel count
  • Average words / sentence
  • Average syllables / word
  • Average letters / word
  • Flesch reading ease score
  • Flesch-Kincaid grade level

See the ITextStatistics class library documentation for a list of the statistic properties on the interface.

Getting Statistics for a Snapshot

The ITextSnapshot.GetTextStatistics method can be called to retrieve the ITextStatistics for the snapshot. If an ISyntaxLanguage is attached to the snapshot's document, it will be used to generate the statistics. This is where custom language-specific statistics can be retrieved if they have been created.

This code shows how to get the statistics for the current snapshot of a document:

C#
VB
Copy
​ITextStatistics stats = document.CurrentSnapshot.GetTextStatistics();
​Dim stats As ITextStatistics = document.CurrentSnapshot.GetTextStatistics()

Getting Statistics for a String

Text statistics can also be generated for a String variable by creating an instance of the TextStatistics class.

This code shows how to generate the built-in statistics for a String variable named text:

C#
VB
Copy
​ITextStatistics stats = new TextStatistics(text);
​Dim stats As ITextStatistics = New TextStatistics(text)

Registering a Custom Statistics Factory for a Syntax Language

In some syntax languages, some of those statistics may not be useful or you may wish to add other statistics, such as comment coverage. Adding new statistics is easy.

First, make a class that inherits TextStatistics.

Second, in your TextStatistics class, calculate your additional statistics in the constructor.

Third, override the GetRawStatistics method so that the additional statistics are added to the returned list. You can optionally remove built-in statistics here too. The returned list has items of type ITextStatistic. The TextStatistics.CreateStatistic static method can be used to create items to add to the list.

Fourth, make a class that implements ITextStatisticsFactory by building a CreateStatistics method. This method should return an instance of the TextStatistics-based class you created in the previous steps.

Finally, we you need to associate the ITextStatisticsFactory with your language so that the custom text statistics can be used. An ITextStatisticsFactory can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ITextStatisticsFactory>(myTextStatisticsFactory);
​language.RegisterService(Of ITextStatisticsFactory)(myTextStatisticsFactory)

Your custom statistics should be ready for use after that.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Exporting to HTML / RTF

Text from a snapshot can easily be exported to a String or file in various HTML and RTF (rich text) formats.

The ITextExporter interface provides a unified model that supports exporting to any custom output format, although the text framework only includes built-in implementations for HTML and RTF.

This topic contains these sections:

  • Built-in HTML Exporters
  • Built-in RTF Exporter
  • Using a Custom IHighlightingStyleRegistry
  • Exporting to a String
  • Exporting to a File
  • Exporting Selected Text in a SyntaxEditor View
  • Exporting a Snapshot Text Range

Built-in HTML Exporters

The text framework has four formats for exporting HTML, all available as methods on the TextExporterFactory class:

Member Description
CreateHtmlClassBased Method

Returns the IHtmlTextExporter that can export text to HTML, using CSS classes for syntax highlighting.

CSS class references will be used for highlighting. This type adds a STYLE tag block to the exported HTML where CSS classes are defined. The text in the code block references these CSS classes, therefore allowing color settings to easily be altered for each highlighting style (i.e. keywords, comments, etc.). Root HTML, BODY and other tags will be added to the output.

CreateHtmlClipboard Method

Returns the IHtmlTextExporter that can export text to HTML, in a format that is compatible with the Windows clipboard HTML data format.

The output of this exporter is the same as CreateHtmlInlineFragment, except that some additional information is added to make the exported text compatible with the Windows clipboard HTML data format.

CreateHtmlInline Method

Returns the IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting.

Inline CSS styles will be used for highlighting. This type allows for the code block to be directly copied out of the exported document and pasted into another. Root HTML, BODY and other tags will be added to the output.

CreateHtmlInlineFragment Method

Returns the IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting and no root HTML or BODY tags.

Inline CSS styles will be used for highlighting. This type allows for the code block to be directly copied out of the exported document and pasted into another. Root HTML, BODY and other tags will not be added to the output.

The appropriate exporter should be used based on your HTML output needs.

Built-in RTF Exporter

The TextExporterFactory class also has a static CreateRtf method for creating a RTF exporter.

Using a Custom IHighlightingStyleRegistry

The constructor of the TextExporterFactory class optionally takes an IHighlightingStyleRegistry argument. If specified, that registry will be used for converting classification types to styles. Otherwise, the AmbientHighlightingStyleRegistry will be used.

Exporting to a String

Exporting to a string is done via the ITextSnapshot.Export method.

This code shows how to export the contents of an ITextSnapshot to a string in RTF format:

C#
VB
Copy
​string text = document.CurrentSnapshot.Export(new TextExporterFactory().CreateRtf());
​Dim text As String = document.CurrentSnapshot.Export(New TextExporterFactory().CreateRtf())

Exporting to a File

Exporting to a file is done via the ITextSnapshot.ExportToFile method.

This code shows how to export the contents of an ITextSnapshot to a file in RTF format:

C#
VB
Copy
​string path = @"C:\output.rtf";
document.CurrentSnapshot.ExportToFile(new TextExporterFactory().CreateRtf(), path);
​Dim path As String = "C:\output.rtf"
document.CurrentSnapshot.ExportToFile(New TextExporterFactory().CreateRtf(), path)

Exporting Selected Text in a SyntaxEditor View

Exporting to the selected text in a SyntaxEditor view to a string is done via the IEditorView.ExportSelectedText method.

This code shows how to export the selected text in the active view to a string in RTF format:

C#
VB
Copy
​string text = editor.ActiveView.ExportSelectedText(new TextExporterFactory().CreateRtf());
​Dim text As String = editor.ActiveView.ExportSelectedText(New TextExporterFactory().CreateRtf())

Exporting a Snapshot Text Range

The ITextExporter.Export method allows for the exporting of any custom snapshot text range.

This code shows how to export a snapshot text range to a string in RTF format:

C#
VB
Copy
​string text = new TextExporterFactory().CreateRtf().Export(snapshot, new TextRange[] { textRange });
​Dim text As String = New TextExporterFactory().CreateRtf().Export(snapshot, New TextRange() { textRange })

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line Commenting

The text framework includes an extensible interface for commenting and uncommenting regions of text. Both line-based and range comment styles are supported.

Commenting is performed by inserting language-specific comment delimiters. Uncommenting is performed by removing the language-specific comment delimiters.

This topic contains these sections:

  • Registering a Line Commenter with a Syntax Language
  • Commenting a Range of Text
  • Uncommenting a Range of Text
  • Creating a Line-Based Line Commenter
  • Creating a Range Line Commenter

Registering a Line Commenter with a Syntax Language

Line commenters implement the ILineCommenter interface. This interface defines two methods.

The Comment method has parameters that indicate the TextSnapshotRange to examine and the ITextChangeOptions to use when inserting comment delimiters. The Uncomment method has the same parameters, although it removes comment delimiters instead.

An ILineCommenter can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ILineCommenter>(myLineCommenter);
​language.RegisterService(Of ILineCommenter)(myLineCommenter)

Registering line commenters with a language is optional, but recommended.

Commenting a Range of Text

This code uses an ICodeDocument's current language's line commenter to comment out a range of text from offset 0-10:

C#
VB
Copy
​if (document.Language.LineCommenter != null) {
    TextSnapshotRange range = new TextSnapshotRange(document.CurrentSnapshot, 0, 10);
    ITextChangeOptions options = new TextChangeOptions();
    document.Language.LineCommenter.Comment(range, options);
}
​If Not (document.Language.LineCommenter Is Nothing) Then
    Dim range As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 0, 10)
    Dim options As ITextChangeOptions = New TextChangeOptions()
    document.Language.LineCommenter.Comment(range, options)
End If

Uncommenting a Range of Text

This code uses an ICodeDocument's current language's line commenter to uncomment a range of text from offset 0-10:

C#
VB
Copy
​if (document.Language.LineCommenter != null) {
    TextSnapshotRange range = new TextSnapshotRange(document.CurrentSnapshot, 0, 10);
    ITextChangeOptions options = new TextChangeOptions();
    document.Language.LineCommenter.Uncomment(range, options);
}
​If Not (document.Language.LineCommenter Is Nothing) Then
    Dim range As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 0, 10)
    Dim options As ITextChangeOptions = New TextChangeOptions()
    document.Language.LineCommenter.Uncomment(range, options)
End If

Creating a Line-Based Line Commenter

Line-based line commenters are used in languages like C# where // should be used to comment out lines of text. To accomplish this, create a LineBasedLineCommenter object.

LineBasedLineCommenter already has the comment and uncomment code implemented. However it defines a StartDelimiter property that must be set to the start comment delimiter for your language.

LineBasedLineCommenter has a CanCommentEmptyLines property that determines whether to comment a line that is only whitespace. The default is true.

For C#, this would be set to the string //. For VB, this would be set to the string '.

Creating a Range Line Commenter

Range line commenters are used in languages like XML where <!-- --> should be used to comment out lines of text. To accomplish this, create a RangeLineCommenter object.

RangeLineCommenter already has the comment and uncomment code implemented. However it defines a StartDelimiter and EndDelimiter properties that must be set to the start and end comment delimiters for your language.

For XML, the start delimiter would be set to the string <!-- and the end delimiter would be set to the string -->.

Comment Token ID

If your range comment consists of a single token and you wish to enhance the comment locating logic when performing an uncomment, set the RangeLineCommenter.CommentTokenId property to the comment token's ID. As long as the selection is fully within a token with that ID, it will be found.

Advanced Logic

If your range comment consists of multiple tokens or requires more advanced logic to properly locate it, you can override the virtual RangeLineCommenter.FindCommentTextRange method. It passes in the TextSnapshotRange to examine. You can create a snapshot reader to examine text and tokens over that range. Then return a TextRange indicating the range of the comment. If no comment was found, return null instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatting

The text framework includes an interface for formatting regions of text. Text that has been formatted can be more readable because whitespace and symbols such as braces are uniformly placed.

This topic contains these sections:

  • Formatting Logic
  • Registering a Text Formatter with a Syntax Language
  • Formatting a Range of Text

Formatting Logic

Text formatters implement the ITextFormatter interface. This interface defines one method, the Format method, which has one parameter that indicates the TextSnapshotRange to examine and update.

The TextSnapshotOffset.Snapshot property gives access to its ITextSnapshot. Likewise, the ITextSnapshot.Document provides access to its owner ITextDocument. The ITextDocument.TabSize property tells how many spaces are in a tab, in case that information is useful while formatting.

If the ITextDocument is an ICodeDocument, the ICodeDocument.ParseData property may also contain AST or other language-specific information that can be useful when formatting.

When formatting, it is likely that multiple changes will be made. These updates can be batched up into a single undoable text change. For information on text changes, see the Text Changes and Operations topic.

Formatters are free to implement any custom logic to perform the formatting. However, there are most likely going to be similarities in the technique that most formatters use. Here are some common steps that a formatter might follow in the process of formatting a document:

  1. Find the next token that allows whitespace between itself and the following non-whitespace token.
  2. Replace all whitespace between these two tokens with the new whitespace, which can either be no whitespace at all, or a combination of any number of linebreaks, tabs and spaces.
  3. Repeat from step 1 until the entire range is formatted.

Registering a Text Formatter with a Syntax Language

An ITextFormatter can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ITextFormatter>(myTextFormatter);
​language.RegisterService(Of ITextFormatter)(myTextFormatter)

Registering a text formatter with a language is optional, but recommended.

Formatting a Range of Text

This code uses an ICodeDocument's current language's text formatter to format a range of text from offset 0-10:

C#
VB
Copy
​ITextFormatter textFormatter = document.Language.GetService<ITextFormatter>();
if (textFormatter != null) {
    TextSnapshotRange range = new TextSnapshotRange(document.CurrentSnapshot, 0, 10);
    textFormatter.Format(range.Snapshot, TextPositionRange.CreateCollection(range.PositionRange, false), TextFormatMode.Ranges);
}
​Dim textFormatter As ITextFormatter = document.Language.GetService(Of ITextFormatter)();
If Not (textFormatter Is Nothing) Then
    Dim range As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 0, 10)
    textFormatter.Format(range.Snapshot, TextPositionRange.CreateCollection(range.PositionRange, False), TextFormatMode.Ranges)
End If

This code uses an ICodeDocument's current language's text formatter to format the entire document:

C#
VB
Copy
​ITextFormatter textFormatter = document.Language.GetService<ITextFormatter>();
if (textFormatter != null)
    textFormatter.Format(document.CurrentSnapshot, TextPositionRange.CreateCollection(document.CurrentSnapshot.SnapshotRange.PositionRange, false), TextFormatMode.All);
​Dim textFormatter As ITextFormatter = document.Language.GetService(Of ITextFormatter)();
If Not (textFormatter Is Nothing) Then
    textFormatter.Format(document.CurrentSnapshot, TextPositionRange.CreateCollection(document.CurrentSnapshot.SnapshotRange.PositionRange, False), TextFormatMode.All)
End If

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Structure Matching

The text framework includes support for locating matching structural text delimiters, such as brackets.

Once the language service is implemented for structure matching, SyntaxEditor features such as move to matching bracket and select to matching bracket are automatically supported. Structure matching is also a requirement for the delimiter highlighting feature.

This topic contains these sections:

  • Matching Logic
  • Registering a Structure Matcher with a Syntax Language
  • Default Structure Matcher Implementation

Matching Logic

Structure matchers implement the IStructureMatcher interface, which defines a single method. The Match method accepts the TextSnapshotOffset to examine and an IStructureMatchOptions object that provides match options. The goal of this method is to look around the offset and built a set of results that indicate if there are structural text delimiters (generally parentheses and braces) around it. For instance if the caret is next to a parenthesis, then the method would return results indicating the range of the parenthesis and also the range of its matching parenthesis, if found.

The TextSnapshotOffset.Snapshot property gives access to its ITextSnapshot. From the ITextSnapshot, an ITextSnapshotReader can be obtained.

A structure matcher generally does text scanning, token scanning, or even AST examination to build its results. The ITextSnapshotReader allows for easy text and token scanning of a snapshot. If an AST is needed for examination and the ITextDocument is an ICodeDocument, the ICodeDocument.ParseData property may also contain AST or other language-specific information that can be useful when performing matching logic.

Options

The IStructureMatchOptions interface defines a IsNavigationRequest property that can be set to true when the request is being made for navigation purposes, such as SyntaxEditor's move to matching bracket feature. When this property is true, the match logic should be a bit more liberal and allow any possible bracket surrounding or next to the source offset to be a valid result.

When this property is false, the request is more likely for a feature such as delimiter highlighting. And in that case, the logic for finding a match next to the source offset should be a bit more strict.

Results

The Match method returns an IStructureMatchResultSet object that contains a collection of IStructureMatchResult objects. Each IStructureMatchResult indicates its TextSnapshotRange and also an optional TextSnapshotOffset if the match is something that can be navigated to when SyntaxEditor's move to matching bracket feature is utilized.

If a structural delimiter is next to the source offset, a result for that delimiter should be included in the result set, and its IsSource property needs to be set to true. Any other "matching" structural delimiters should also be included in the collection.

For example, if parenthesis structure matching is supported, the match logic would first use an ITextSnapshotReader to see if a parenthesis is next to the source offset. If there is one, a result (with IsSource indication) is added to the result set for that parenthesis. Then the reader is used to scan forward or backward as appropriate to look for a matching parenthesis. If one is found, a second result is added to the result set.

Structure matching also supports multiple results. Say that the structure matching should support #if...#else...#endif blocks. If the source offset is within the #else then the result set would include three results (one for each directive text range) and only the one for #else would have its IsSource property set to true.

Each result also has a MatchEdges property that should be set to a StructureMatchEdges value indicating which edges (none, start, end, or both) of the result's range can cause the structure matcher to match the result again. This information is used for optimizations by the delimiter highlighting feature.

Registering a Structure Matcher with a Syntax Language

An IStructureMatcher can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<IStructureMatcher>(myStructureMatcher);
​language.RegisterService(Of IStructureMatcher)(myStructureMatcher)

Registering structure matchers with a language is optional, but recommended.

Default Structure Matcher Implementation

A built-in StructureMatcher class is included that implements IStructureMatcher and makes it easy for a language to support matching of these bracket pairs:

  • Angle braces (disabled by default)
  • Curly braces
  • Parenthesis
  • Square braces

The various supported brace match options can be turned on or off with properties such as StructureMatcher.CanMatchSquareBraces.

By default, this matcher will just perform basic text scanning to match brackets. However this can cause issues when scanning for a pair of parentheses and there is a parenthesis character within a contained string. Thus the matcher also provides optional token IDs that can be set for each character. When a potential text match is found and a related token ID is specified, it will double-check that the token at the offset has that token ID. This eliminates the problem. Properties such as StructureMatcher.OpenParenthesisTokenId are available for indicating the token IDs.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lipsum Generator

A special utility class is included supports the generation of 'lorem ipsum' placeholder text. Placeholder text is useful for developers and designers when prototyping out web pages and screens. It is designed to contain unreadable gibberish sentences, which are ideal for layout.

This topic contains these sections:

  • Generating Placeholder Text

Generating Placeholder Text

A toolbar button or menu item (i.e. a "Insert Lorem Ipsum" item) clicked by the user in your app's UI might trigger the generation of placeholder text.

This code snippet shows how to use the LipsumGenerator class to generate the placeholder text:

C#
VB
Copy
​var text = new LipsumGenerator().GenerateParagraph(true, 30);
​Dim text = New LipsumGenerator().GenerateParagraph(True, 30)

The result of that call might yield:

Lorem ipsum dolor sit amet, consectetur adipisicing elit. Necessitatibus distinctio voluptates facilis nesciunt magnam, tempore similique voluptate cupiditate. Et fugit assumenda necessitatibus eum suscipit maiores ullam. Cum enim consequuntur adipisci.

The GenerateParagraph method generates a single paragraph of placeholder text. It has two parameters. The first is a boolean indicating whether the generated text should begin with the standard starting words "Lorem ipsum dolor sit amet, consectetur adipisicing elit." The second parameter is an integer indicating the total number of words that should be generated in the paragraph. The generated sentences in the paragraph will be of random length and will have commas sporatically inserted.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Document Properties

The ICodeDocument.Properties property provides a dictionary-like object that can store any sort of custom data that should be associated with the document.

The property returns an PropertyDictionary object, which supports any object type as a key or value.

This topic contains these sections:

  • Storing Data
  • Retrieving Data

Storing Data

In this code snippet we store an object referenced by the variable someObject into the properties dictionary under the string key MyPropertyKey:

C#
VB
Copy
​document.Properties["MyPropertyKey"] = someObject;
​document.Properties.Item("MyPropertyKey") = someObject

Retrieving Data

In this code snippet we retrieve an object stored under the string key MyPropertyKey:

C#
VB
Copy
​object someObject;
if (document.Properties.TryGetValue("MyPropertyKey", out someObject)) {
    ...
}
​Dim someObject As Object
If document.Properties.TryGetValue("MyPropertyKey", someObject) Then
    ...
End If

Alternatively the indexer could be used, however it will throw an exception if there is no object stored with the specified key, whereas TryGetValue will not.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The SyntaxEditor user interface implements many of the features you'd expect to see in a powerful code editor.

This topic contains these sections:

  • Editor View Features
  • Input/Output Features
  • Printing Features
  • Searching (Find/Replace) Features
  • IntelliPrompt Features
  • Theme and Highlighting Style Features
  • Adornment Features
  • Outlining and Collapsing Features
  • Globalization and Accessibility Features

Editor View Features

Editor views are where end users primarily interact with documents and are customizable in a number of ways.

See the Editor View Features topic for more information.

Input/Output Features

In addition to the input/output features found in the text framework such as file load/save, exporting to HTML/RTF, etc., SyntaxEditor has a lot of other i/o features built-in.

See the Input/Output topic for more information.

Printing Features

SyntaxEditor's print features include easy dialog access, many print options, and customizable margins.

See the Printing Features topic for more information.

Searching (Find/Replace) Features

SyntaxEditor's view search model interacts with the view's selection and provides extensive find/replace functionality. A standalone EditorSearchView control can be used to instantly recreate a Visual Studio-like search experience for end users.

See the Searching (Find/Replace) Features topic for more information.

IntelliPrompt Features

SyntaxEditor includes some extremely powerful IntelliPrompt features that help enhance end user productivity.

See the IntelliPrompt topic for more information.

Theme and Highlighting Style Features

Highlighting styles govern how SyntaxEditor text is rendered and can be used to create entire themes for various languages.

See the Theme and Highlighting Style Features topic for more information.

Adornment Features

SyntaxEditor has a fully-extensible adornment layer framework that allows for any sort of custom content to be inserted within a view's text area. This can include everything from alternating row highlights, to animated text decorations, or anything else you can imagine.

All the built-in text area rendering is done using adornment layers, such as the text itself, selection, caret, and more.

See the Adornment Features topic for more information.

Outlining and Collapsing Features

SyntaxEditor fully supports automatic (language-driven) and manual (user-driven) code outlining/folding features similar to those found in Visual Studio.

Various text regions can even be collapsed (hidden) independent of the outlining features.

See the Outlining and Collapsing topic for more information.

Globalization and Accessibility Features

SyntaxEditor has full support for editing bi-directional Unicode text, is completely localizable, and implements UI automation.

See the Globalization and Accessibility Features topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Editor views are where end users primarily interact with documents and are customizable in a number of ways.

Tip Tip
If you want your SyntaxEditor instances to look just like Visual Studio's code editor, use the Consolas font with a FontSize of 13.

This topic contains these sections:

  • Caret
  • Selection and Block Selection
  • Locations, Offsets, and Positions
  • View Lines
  • Splitting
  • Editor View Margins
  • Whitespace
  • Word Wrap
  • Zooming
  • Current Line Highlighting
  • Delimiter Highlighting
  • Code Block Selection
  • Indicators
  • Indentation Guides
  • Scrolling
  • Hit Testing
  • View Lifecycle
  • Delayed UI Updates
  • View Properties
  • Single-Line Mode

Caret

The SyntaxEditor caret is the bar that blinks within an editor view and marks the location where typing will insert text. It also is linked to the end position of a selection. SyntaxEditor optionally supports multiple selections and therefore multiple carets, which enables simulataneous editing in several document locations at the same time.

See the Caret topic for more information.

Selection and Block Selection

SyntaxEditor has a powerful text selection model that supports both continuous stream (snaking) as well as block selection within editor views.

See the Selection and Block Selection topic for more information.

Locations, Offsets, and Positions

There are several ways to reference the location of characters within an IEditorView, each with their own benefits.

See the Locations, Offsets, and Positions topic for more information.

View Lines

Each view consists of one or more view lines, which are the lines of text that are visible in the view. View lines don't always match up with snapshot lines when features like word wrap or code outlining are active.

See the View Lines topic for more information.

Splitting

SyntaxEditor supports split views so that you can edit multiple areas of a document at the same time.

See the Splitting topic for more information.

Editor View Margins

While the SyntaxEditor editor views have numerous built-in margins (line number, outlining, etc.), SyntaxEditor offers an extensibility point where custom margins can be created and added to editor views in any location.

See the Editor View Margins topic for more information.

Whitespace

SyntaxEditor can optionally display whitespace characters, change tab size, do tab to space conversion, and more.

See the Whitespace topic for more information.

Word Wrap

Word wrapping is a powerful feature that allows users to view all text for a line by wrapping text that normally would have been outside the view horizontally to one or more view lines in the editor.

See the Word Wrap topic for more information.

Zooming

SyntaxEditor supports animated zooming in and out of views, which is a great feature to use when giving overhead presentations. Only the scrollable area content of each view is zoomed, not the scrollbars.

See the Zooming topic for more information.

Current Line Highlighting

SyntaxEditor supports highlighting of the current editor view line, meaning the view line that currently contains the caret.

See the Current Line Highlighting topic for more information.

Delimiter Highlighting

SyntaxEditor supports highlighting of the delimiter pairs that are currently next to the caret, also known as bracket highlighting.

While delimiter pairs such as {...}, and (...) are most commonly highlighted, delimiter highlighting also supports the highlighting of more than two delimiters at a time, such as when there are #if...#else...#endif blocks.

See the Delimiter Highlighting topic for more information.

Code Block Selection

SyntaxEditor supports code block selection expansion and contraction, meaning that the view's selection can be expanded to include containing code blocks and contracted all the way back down to the caret as appropriate.

For instance, in C# the first time you expand the selection, it may select the containing identifier. By expanding it again, it may select the containing expression, then the containing statement, then the containing method. And so on up the compilation unit.

By contracting the selection, it goes back and selects the previously selected block. Contracting can occur recursively to go back to the original selection.

See the Code Block Selection topic for more information.

Indicators

Indicators are special "tagged" regions of text that display a glyph in the indicator margin also generally highlight the text range with special styles. Quick info can be displayed when hovering over the glyph, and custom mouse handling can be implemented to support functionality like toggling indicators when clicking in the indicator margin.

SyntaxEditor includes several built-in indicators: bookmarks, breakpoints, and current statement markers. Any sort of custom indicator can easily be created as well.

See the Indicators topic for more information.

Indentation Guides

Indentation guides are subtle vertical lines that render at each tab stop on lines prior to the first non-whitespace character. Whitespace-only lines render indentation guides based on the tab stop level of surrounding text.

See the Indentation Guides topic for more information.

Scrolling

Scrolling can be performed by end users via keyboard, mouse wheel, or touch. Editor views can be scrolled programmatically as well.

Scrollbars can optionally be hidden in the views, or even automatically hidden when not needed.

Scrollbar acceleration allows scrolling speed to increase the longer a scrollbar button is held.

Each editor view in SyntaxEditor also has four scrollbar tray areas, where custom controls can be inserted via data templates.

See the Scrolling topic for more information.

Hit Testing

SyntaxEditor makes it easy to hit test any Point in the editor and return detailed information about what is at that location.

See the Hit Testing topic for more information.

View Lifecycle

SyntaxEditor views can be opened and closed via various end user actions. This topic discussed how to be notified when views are opened and closed.

See the View Lifecycle topic for more information.

Delayed UI Updates

SyntaxEditor includes a special event that is raised shortly after any text, caret, or selection changes occur within the editor. This event can be handled to update external UI controls based on updated editor context.

See the Delayed UI Updates topic for more information.

View Properties

The ITextView.Properties property provides a dictionary-like object that can store any sort of custom data that should be associated with the view.

The property returns an PropertyDictionary object, which supports any object type as a key or value.

See the View Properties topic for more information.

Single-Line Mode

SyntaxEditor is a multi-line editor by default, but also supports a single-line edit mode where it looks like a single-line native TextBox.

In this mode, nearly all of SyntaxEditor's features remain available, such as syntax highlighting, syntax error squiggle lines, and automated IntelliPrompt.

See the Single-Line Mode topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Caret

The SyntaxEditor caret is the bar that blinks within an editor view and marks the location where typing will insert text. It also is linked to the end position of a selection. SyntaxEditor optionally supports multiple selections and therefore multiple carets, which enables simulataneous editing in several document locations at the same time.

This topic contains these sections:

  • Accessing the Caret
  • Determining and Moving the Caret Location
  • Multiple Selections and Carets
  • Changing the Blink Interval
  • Changing the Insert and Overwrite Mode Width/Style
  • Temporarily Suspending Blinking
  • Caret Move Event
  • Scroll to Caret

Accessing the Caret

The primary selection's caret and its functionality described below is available via the IEditorViewSelection interface, which can be retrieved from the SyntaxEditor.ActiveView.Selection property.

Determining and Moving the Caret Location

The primary selection has several properties for determining its caret location. A couple of the properties can be set to move the caret.

Member | Description
CaretCharacterColumn Property | Gets the character column of the primary caret within the active view.
CaretDisplayCharacterColumn Property | Gets the character column of the primary caret within the the active view. and adds one to the value for display purposes within a status bar.
CaretOffset Property | Gets or sets the offset of the primary caret within the active view.
CaretPosition Property | Gets or sets the TextPosition of the primary caret within the active view.

This code moves the caret to the start of the third line (the value is zero-based):

C#
VB
Copy
​editor.ActiveView.Selection.CaretPosition = new TextPosition(2, 0);
​editor.ActiveView.Selection.CaretPosition = New TextPosition(2, 0)

Text positions are zero-based by default. Use the one-based TextPosition.DisplayLine and DisplayCharacter properties when displaying the position in a status bar or other user interface.

Multiple Selections and Carets

A caret appears at the end of each editor view selection. Multiple selections are supported when the SyntaxEditor.AreMultipleSelectionRangesEnabled property is true.

See the Selection topic for more information on working with multiple selections and how end users can add selections at run-time.

Changing the Blink Interval

The caret blink interval is set by default to 500ms.

Use the SyntaxEditor.CaretBlinkInterval property to change the blink interval to be faster or slower. The value indicates the millisecond delay between blinks.

This code changes the blink interval to one second:

C#
VB
Copy
​editor.CaretBlinkInterval = 1000;
​editor.CaretBlinkInterval = 1000

Changing the Insert and Overwrite Mode Width/Style

The caret can be in one of two modes: insert and overwrite. Insert mode is the traditional mode where typed text is inserted directly at the caret's offset. Overwrite mode will insert text at the caret's offset but will first remove any existing character on the line that is already at that offset.

The SyntaxEditor.CaretInsertWidth and CaretOverwriteWidth properties can be used to tweak the width of the caret in each respective mode.

The CaretInsertKind and CaretOverwriteKind properties accept a CaretKind value. This value determines the shape/alignment of the caret and can be VerticalLine, HorizontalUnderline, or Block.

Temporarily Suspending Blinking

The SyntaxEditor.SuspendCaretBlinking method can be used to temporarily suspend blinking of the caret. It accepts a boolean parameter indicating whether to display the caret while suspended or not. Generally, false is passed to this method.

When the caret should resume blinking, call the ResumeCaretBlinking method.

Caret Move Event

The SyntaxEditor.ViewSelectionChanged event is raised whenever the caret moves, since the caret is always in sync with the end of the selection.

See the Selection topic for more information on this event.

Scroll to Caret

The editor view will auto-scroll by default to the primary caret when the selection is changed. A batch can be created on the selection using a NoScrollToCaret option to prevent auto-scrolling to the caret following text changes:

C#
VB
Copy
​using (var batch = editor.ActiveView.Selection.CreateBatch(EditorViewSelectionBatchOptions.NoScrollToCaret)) {
    // Perform text changes here
}
​Using batch = editor.ActiveView.Selection.CreateBatch(EditorViewSelectionBatchOptions.NoScrollToCaret)
    ' Perform text changes here
End Using

The SyntaxEditor.ScrollToCaretOnSelectAll property that determines whether to scroll to the caret when a select all operation is performed. It defaults to true.

The IEditorViewScroller interface defines a ScrollToCaret method that can be called manually to scroll to the caret. This code scrolls the active view to the caret:

C#
VB
Copy
​editor.ActiveView.Scroller.ScrollToCaret();
​editor.ActiveView.Scroller.ScrollToCaret()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Selection and Block Selection

SyntaxEditor has a powerful text selection model that supports both continuous stream (snaking) as well as block selection within editor views.

This topic contains these sections:

  • Accessing the Selection
  • Continuous Stream vs. Block Selection
  • Getting Information About the Current Selection
  • Creating Continuous Stream Selections at Run-time
  • Creating Multiple Selections at Run-time
  • Creating Block Selections at Run-time
  • Creating a Single Selection Programmatically
  • Creating Multiple Selections Programmatically
  • Getting or Replacing the Selected Text
  • Determining If Any of the Selected Text is Read-Only
  • Disabling Certain Selection Modes
  • Selection Change Event
  • Capturing and Restoring the Selection State
  • Selection Collapsing
  • Selection Grippers for Touch
  • Virtual Space

Accessing the Selection

Each IEditorView has its own selection model since the selection is unique to each view. The selection and its functionality described below is available via the IEditorViewSelection interface, which can be retrieved from the IEditorView.Selection property.

The currently active view within a SyntaxEditor is available from the SyntaxEditor.ActiveView property.

Continuous Stream vs. Block Selection

Continuous stream is considered the "normal", snaking type of selection. It has a start and end position and encompasses all text in between the positions.

Block selection, sometimes called column or rectangular selection, allows a singular rectangular portion of text to be selected instead of the whole line. The selection includes all of the characters captured within the rectangle defined by the start (anchor) position and the end position in the selection.

Continuous stream (left) vs. block (right) selection

When a block selection is active, multiple lines can be edited at the same time. Typing will enter the character on each line. Pasting single-line text will paste the text on each line. Likewise, operations like Del and Backspace will work on each line.

Getting Information About the Current Selection

There are a number of properties on the IEditorViewSelection interface that allow you to see exactly what is selected in the selection's owner IEditorView.

Member | Description
EndOffset Property | Gets or sets the end offset of the primary selection range.
EndPosition Property | Gets or sets the TextPosition that represents the end of the primary selection range.
FirstOffset Property | Gets the first offset in the primary selection range.
FirstPosition Property | Gets the first TextPosition in the primary selection range.
GetTextRanges Method | Returns an array of TextRange objects that specify the ranges of text that is selected.
IsNormalized Property | Gets whether the primary selection range is normalized (StartPosition occurs at or before the EndPosition).
IsZeroLength Property | Gets whether the primary selection range has a zero length.
LastOffset Property | Gets the last offset in the primary selection range.
LastPosition Property | Gets the last TextPosition in the primary selection range.
Length Property | Gets the absolute offset length of the primary selection range.
Mode Property | Gets a SelectionModes that indicates the selection mode currently in use.
PositionRange Property | Gets or sets the TextPositionRange that describes the start and end TextPosition of the primary selection.
Ranges Property | Gets the collection of selection ranges in the view. This collection ordinarily contains a single range, but can have more than one range when there are multiple selections. Each selection range has its own caret at the selection range's end position.
StartOffset Property | Gets or sets the start offset of the primary selection range.
StartPosition Property | Gets or sets the TextPosition that represents the start of the primary selection range.
TextRange Property | Gets or sets the TextRange that specifies the offset range of the primary selection.

Creating Continuous Stream Selections at Run-time

Continuous stream selections can be made via the mouse or the keyboard.

To make a continuous stream selection with the mouse, left click in the text area and drag to create the selection. Hold Ctrl when click+dragging to select by word instead of character, but only if the SyntaxEditor.AreMultipleSelectionRangesEnabled property is false.

To make a continuous stream selection with the keyboard, hold the Shift key, and press any arrow key. Other keys such as Home, End, PageUp, and PageDn also create selections while holding Shift. Holding Ctrl+Shift when using the arrows keys will select by word instead of character.

Creating Multiple Selections at Run-time

Multiple continuous stream selections can be made when the SyntaxEditor.AreMultipleSelectionRangesEnabled property is true, the default.

A new selection can be added by holding the Ctrl key when clicking in the text area or clicking on the selection or line number margins.

Press the Esc key when there are multiple selection ranges to collapse back to a single primary selection range.

Most built-in edit actions and editing features are designed to support multiple selections. For instance, pressing Shift+Right Arrow will extend all of the selections by one character. Copying text from multiple selections unions the selected text, joining each range's text with a line terminator. Pasting multi-line text into a view with the same number of selections as text lines being pasted will replace each selection with a related line from the pasted text.

Creating Block Selections at Run-time

Block selections can be made via the mouse or the keyboard.

To make a block selection with the mouse, hold the Alt key, left click in the text area and drag to create the selection. Hold Ctrl+Alt+Shift when click+dragging to select by word instead of character.

To make a block selection with the keyboard, hold the Shift+Alt keys, and press any arrow key. Holding Ctrl+Alt+Shift when using the arrows keys will select by word instead of character.

Creating a Single Selection Programmatically

The selection can be set programmatically using a number of the properties and methods on IEditorViewSelection, such as StartOffset.

The SelectRange method has several overloads that allow for easy selection creation with options. For instance you can create a selection via an offset/length, a TextRange, a TextPosition pair, or a TextPositionRange. Each overload also has corresponding overloads that accept a SelectionModes parameter. When you use this parameter, you can indicate whether the selection should be a continuous stream or block selection.

When using setter properties or SelectRange method overloads that don't accept a SelectionModes property, the current selection mode (indicated by the Mode property) will be used.

This code selects the text range 0-20 (20 characters) using the current Mode:

C#
VB
Copy
​editor.ActiveView.Selection.SelectRange(new TextRange(0, 20));
​editor.ActiveView.Selection.SelectRange(New TextRange(0, 20))

This code selects the text range 10-20 (10 characters) using continuous stream mode:

C#
VB
Copy
​editor.ActiveView.Selection.SelectRange(10, 10, SelectionModes.ContinuousStream));
​editor.ActiveView.Selection.SelectRange(10, 10, SelectionModes.ContinuousStream))

This code selects the text position (line, char) range (1,0)-(2,10) using block mode:

C#
VB
Copy
​editor.ActiveView.Selection.SelectRange(new TextPositionRange(1, 0, 2, 10), SelectionModes.Block);
​editor.ActiveView.Selection.SelectRange(New TextPositionRange(1, 0, 2, 10), SelectionModes.Block)

The IEditorViewSelection interface provides a lot of additional methods for performing relative selection operations such as MoveDown, SelectPageDown, SelectBlockRight, etc. Check the IEditorViewSelection class library member list to see the numerous methods that are available.

Creating Multiple Selections Programmatically

The IEditorViewSelection.SelectRanges method allows for a collection of TextPositionRange objects to be specified that will become multiple selections. A caret will be placed at the end of each position range. An optional second parameter allows the index of the primary selection range to be specified. If Esc is pressed by the end user, all selection ranges but the primary selection range will be removed.

Getting or Replacing the Selected Text

The IEditorView.SelectedText property gets and sets the currently selected text and pays proper attention to block selections if applicable. The setter calls the ReplaceSelectedText method.

This code puts the currently selected text in a string:

C#
VB
Copy
​string text = editor.ActiveView.SelectedText;
​Dim text As String = editor.ActiveView.SelectedText

For setting text, the ReplaceSelectedText method can be called to replace the currently selected text with alternate text. The DeleteSelectedText method can be called to delete the currently selected text.

This code deletes currently selected text:

C#
VB
Copy
​editor.ActiveView.DeleteSelectedText(TextChangeTypes.Delete);
​editor.ActiveView.DeleteSelectedText(TextChangeTypes.Delete)

This code replaces currently selected text:

C#
VB
Copy
​editor.ActiveView.ReplaceSelectedText(TextChangeTypes.Typing, "Inserted Text");
​editor.ActiveView.ReplaceSelectedText(TextChangeTypes.Typing, "Inserted Text")

Both these methods have overloads that accept an IEditorViewTextChangeOptions object, which inherits ITextChangeOptions. The base options in ITextChangeOptions are described in the Text Changes and Operations topic. The IEditorViewTextChangeOptions interface defines several additional properties.

The IsBlock option indicates if the text change should be considered a block text change. The SelectInsertedText option determines if the inserted text should be selected. The VirtualCharacterFill option determines if when the caret is at a virtual character position, the text change will insert whitespace into the document to fill up to the insertion point's TextPosition.

Determining If Any of the Selected Text is Read-Only

The IEditorViewSelection.IsReadOnly property returns whether any of the text in the selection is currently flagged as read-only.

Disabling Certain Selection Modes

The SyntaxEditor.SelectionModesAllowed property is a flags enumeration that indicates the types of selection modes that are permitted.

By altering the SelectionModes value set to this property, you can determine whether continuous stream and block selections are allowed. The default is to allow both.

Selection Change Event

The SyntaxEditor.ViewSelectionChanged event fires whenever the selection's anchor or length have changed. This makes the event an ideal place to update the current caret column and position in a status bar.

The event passes an EditorViewSelectionEventArgs that has a number of useful properties on it. It tells you the IEditorView that contains the selection (be sure to only update UI when the view's IsActive property is true). The CaretPosition property contains the primary caret's TextPosition. Use its DisplayLine and DisplayCharacter properties when displaying the caret location in a status bar or other user interface.

Batch Selection Changes

Sometimes multiple selection changes might be made, such as in the case of performing a text change that alters the selection, but wanting to specifically set another selection right afterward. In this scenario, a batch can be created to wrap the text change and any selection changes. The selection changed event will only be raised when the outermost batch is completed.

This example shows how to create a disposable batch object. When the batch is disposed, the batch is completed.

C#
VB
Copy
​using (var batch = editor.ActiveView.Selection.CreateBatch(EditorViewSelectionBatchOptions.None)) {
    // Perform text changes and selection changes here
}
​Using batch = editor.ActiveView.Selection.CreateBatch(EditorViewSelectionBatchOptions.None)
    ' Perform text changes and selection changes here
End Using

Capturing and Restoring the Selection State

Sometimes it's handy to be able to capture and later restore a selection. This feature is used in actions like indent lines where the text in the selection is modified and when complete, the selection still appears to contain the same relative range of text, even though new characters were inserted within the selected text range.

The IEditorViewSelection.CaptureState method can be called to return an IEditorViewSelectionState object. This object persists information about the current selection state. If you make changes and then call the IEditorViewSelectionState.Restore method, the selection will attempt to restore itself as best it can to the text that was originally selected.

This functionality makes use of the snapshot translation feature, found in the text framework.

Selection Collapsing

The Esc key can be pressed to collapse the selection.

If there are multiple selection ranges, the Esc key will first remove all selections other than the primary selection.

When there is a single selection range, the selection will collapse to the caret, meaning make the selection go to zero-length. This behavior can be changed so that the selection collapses to the selection anchor instead. The SyntaxEditor.SelectionCollapsesToAnchor property can be set to true to activate this behavior.

Some end users like the ability to auto-collapse the selection when a copy operation occurs. Set the SyntaxEditor.SelectionCollapsesOnCopy property to true to enable this behavior.

Selection Grippers for Touch

When the end user touches a view, a small selection gripper will appear below the start and end of the selection. The gripper can be dragged to resize the selection, or tapped to show a context menu.

The SyntaxEditor.AreSelectionGrippersEnabled property can be set to false to disable display of the selection grippers.

Virtual Space

The SyntaxEditor.IsVirtualSpaceAtLineEndEnabled property can be set to true to allow virtual space at the end of view lines.

This feature permits the caret is able to move beyond a view line's line terminator. Typing a character while the caret is in virtual space past the end of a line will automatically insert enough whitespace characters to fill up to the typed character before it is inserted.

Block selections can be made in virtual space at the end of lines, even without line end virtual space being enabled. This prevents the caret from snapping to an offset when making a block selection, which can sometimes be problematic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Locations, Offsets, and Positions

There are several ways to reference the location of characters within an IEditorView, each with their own benefits.

Note Note
Before reading this topic, first read the Offsets, Ranges, and Positions topic since that provides a lot of information about core text-related structures that apply to the information in this topic too.

This topic contains these sections:

  • Offsets and Positions
  • Scrolling a View to a Position
  • Locations
  • Converting Between Locations and Offsets/Positions
  • Hit Testing

Offsets and Positions

As mentioned in the Offsets, Ranges, and Positions topic, offsets are zero-based integer numbers indicating a character index from the beginning of a string or snapshot and text positions are similar but specify a line index and a character index within that line instead.

Offsets and positions are used within IEditorView objects to provide layout information to the view lines. However it is important to note that while a TextPosition (4,0) is the fifth line in a view's CurrentSnapshot, it may not be the fifth view line in the view, even when the view is scrolled all the way to the top. Things that can cause this scenario are word wrap, collapsed outlining nodes, etc. So in the same scenario, assume word wrap is on and the second line wrapped once. This would mean that TextPosition (4,0) would appear as the sixth line.

Scrolling a View to a Position

The ITextView.ScrollState property returns the current resolved scroll state for the view.

See the Scrolling topic for details on how to programmatically scroll a view to show a position's view line.

Locations

When related to a view, locations are the term used to describe the x,y layout position such as mouse coordinates, etc. They are specified using the Windows Point structure.

Converting Between Locations and Offsets/Positions

Locations can be translated to a TextPosition by using the IEditorView.LocationToPosition method. This method accepts a Point in text area-relative coordinates. The TransformToTextArea method can transform a view-relative coordinate to the text area. A LocationToPositionAlgorithm enumeration value is also passed, indicating how the logic used to convert the x,y coordinate to a TextPosition.

The GetCharacterBounds method can return the Rect coordinates that contain the character at a particular offset or TextPosition.

Hit Testing

SyntaxEditor features a very powerful hit testing mechanism where you indicate a Point relative to the SyntaxEditor control and it returns very detailed information about what is at the location. Information includes related character offsets, positions, etc. as well.

See the Hit Testing topic for information on how to perform hit testing.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


View Lines

Each view consists of one or more view lines, which are the lines of text that are visible in the view. View lines don't always match up with snapshot lines when features like word wrap and code outlining are active.

This topic contains these sections:

  • View Lines vs. Snapshot Lines
  • Getting a View Line for an Offset
  • Getting a View Line for a Text Position
  • Getting a View Line for a Location
  • Getting a Relative View Line
  • Getting or Setting the First Visible View Line
  • Display Line Number
  • Scrolling
  • Auto-Sizing the View to View Line Contents

View Lines vs. Snapshot Lines

View lines are the rendered display lines within a view, and are represented by the ITextViewLine interface. Snapshot lines are the actual physical lines within a snapshot, and are represented by the ITextSnapshotLine interface.

The view lines most often do line up exactly with the lines in the IEditorView.CurrentSnapshot, however this may not be the case when features such as word wrap or code outlining are active.

To better illustrate the difference, let us examine a snippet of code that is being edited in view. This is the full text as it appears within the document's snapshot (line numbers are included for reference):

Code Snippet
Copy
0: // Sample code
1: int myIntValue = 123;
2: string myStringValue = "This is a long bit of text that will be word wrapped.";
3: // End of code

You can see there are four lines in the snapshot. Now assume that the editor has word wrap enabled. And assume that the second last line is wrapped like so:

Code Snippet
Copy
0: // Sample code
1: int myIntValue = 123;
2: string myStringValue = "This is a long bit of text
3: that will be word wrapped.";
4: // End of code

Even though there are four snapshot lines, there are five view lines needed to display the text due to the word wrap.

View lines are completely virtualized meaning they are generated on demand and are not persisted in memory. This is a key feature since it means much less memory usage and processing required when working with large documents.

Getting a View Line for an Offset

There is an IEditorView.GetViewLine method overload that accepts an offset parameter. This method allows you to retrieve the view line that contains the specified offset.

This code gets the ITextViewLine that contains offset 10:

C#
VB
Copy
​editor.ActiveView.GetViewLine(10);
​editor.ActiveView.GetViewLine(10))

Getting a View Line for a Text Position

There is an IEditorView.GetViewLine method overload that accepts a TextPosition parameter. This method allows you to retrieve the view line that contains the specified text position.

This code gets the ITextViewLine that contains the start of the fourth line:

C#
VB
Copy
​editor.ActiveView.GetViewLine(new TextPosition(3, 0));
​editor.ActiveView.GetViewLine(New TextPosition(3, 0)))

Getting a View Line for a Location

There is an IEditorView.GetViewLine method overload that accepts two parameters: a y-coordinate and a LocationToPositionAlgorithm to use. This method allows you to retrieve the view line under a specific mouse coordinate for example.

Getting a Relative View Line

If you already have an ITextViewLine instance and would like to find a view line that is above or below it by a certain number of lines, there is a IEditorView.GetViewLine overload that accepts the source ITextViewLine instance and the number of lines to traverse, which can be negative.

If you are just iterating view lines, the ITextViewLine has NextLine and previous PreviousLine properties that return the next and previous view lines respectively.

Getting or Setting the First Visible View Line

The IEditorView.ScrollState property returns a TextViewScrollState that indicates the current view scroll state. Scroll states allow a vertical anchor text position to be specified. The view line containing the vertical anchor text position can be placed at the top, center, or bottom of the view and then further displaced by a pixel amount. The view may also be scrolled horizontally by a pixel amount. All of this information is provided by the scroll state.

This code shows how to get the resolved first TextPosition visible on the first view line in the active editor view:

C#
VB
Copy
​var firstVisiblePosition = editor.ActiveView.VisibleViewLines[0].VisibleStartPosition;
​Dim firstVisiblePosition = editor.ActiveView.VisibleViewLines(0).VisibleStartPosition

See the Locations, Offsets, and Positions topic for details on scrolling to a specific TextPosition using a TextViewScrollState.

Display Line Number

Use the DisplayLine property from the ITextViewLine.VisibleStartPosition property result to obtain the one-based line number that appears in the line number margin.

Scrolling

The IEditorView.Scroller property provides access to an IEditorViewScroller for the view. This interface has a lot of methods such as ScrollByPixels, ScrollDown, ScrollToDocumentEnd, ScrollIntoView, ScrollTo (for scrolling to a specific TextViewScrollState), ScrollToCaret, etc. that can be used to scroll the view.

See the IEditorViewScroller class library member list documentation for the list of methods that are available.

Auto-Sizing the View to View Line Contents

Sometimes it is desirable for the editor to resize itself based on the current text content. This feature is useful in scenarios such as where an editor is in a StackPanel and its height needs to grow as text is entered by the user.

The SyntaxEditor.IsViewLineMeasureEnabled property, which defaults to false, can be set to true to force each view line to be measured during measure phases, thus allowing the containing editor to resize based on the the current text content.

Note Note
Enabling this feature will affect performance and is only recommended for scenarios where small documents are expected to be edited. If you expect the editor to always be docked to fill an available space, leave this feature disabled.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Splitting

SyntaxEditor supports split views so that you can edit multiple areas of a document at the same time.

This topic contains these sections:

  • Splitting UI
  • Split Capabilities
  • Split State and Locations
  • Resetting Splits
  • View Placement

Splitting UI

There are two forms of UI that are visible when splitting features are enabled.

A horizontal split of a SyntaxEditor

When splitting is enabled, a small gripper button appears on top of the right vertical scrollbar. This gripper allows you to create a horizontal split by either double-clicking it or dragging it downward.

When split, the area between views can be dragged to resize the splits. The splitter there can be double-clicked to remove the split.

Split Capabilities

These members control splitting features:

Member | Description
CanSplitHorizontally Property | Gets or sets whether the editor can be split horizontally to show more than one view. The default value is true.

Split State and Locations

The following properties are used to determine if there is currently a split in the editor, and can also be used to create a split.

Member | Description
HasHorizontalSplit Property | Gets or sets whether the editor is currently split horizontally to show more than one view.
HorizontalSplitPercentage Property | Gets or sets the percentage across the width of the editor at which the horizontal split is located. The value must be between 0 and 1, where 0 indicates no split.

This code creates a horizontal split:

C#
VB
Copy
​editor.HasHorizontalSplit = true;
​editor.HasHorizontalSplit = True

Resetting Splits

The SyntaxEditor.ResetViews method can be used to reset the editor to showing a single view.

View Placement

The IEditorView.Placement property returns an EditorViewPlacement enumeration value indicating where a view is currently located within the editor.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Editor View Margins

While the SyntaxEditor editor views have numerous built-in margins (line number, outlining, etc.), SyntaxEditor offers an extensibility point where custom margins can be created and added to editor views in any location.

Editor view margins all implement the IEditorViewMargin interface.

This topic contains these sections:

  • Margin Locations
  • Built-In Margin Summary
  • Indicator Margin
  • Line Number Margin
  • Selection Margin
  • Outlining Margin
  • Word Wrap Glyph Margin
  • Ruler Margin
  • Margin Factories
  • Custom Margins

Margin Locations

Editor view margins surround the text area and fall into two categories: scrollable or fixed.

Scrollable margins appear inside of the scrollbars and scroll with the text area as it is scrolled. Fixed margins appear outside of the scrollbars and do not scroll when the text area is scrolled.

Custom margins that show the eight available margin placement locations

All in all there are eight available margin placement locations. The screenshot above shows where each placement is located.

The IEditorViewMargin.Placement property has an EditorViewMarginPlacement enumeration value that indicates one of those eight placement locations.

Since each IEditorViewMargin has a string-based Key, and the interface also implements IOrderable, it has an Orderings property that returns an enumerable of Ordering objects. Each ordering indicates the a string Key of another margin and whether this margin comes before or after that one. When multiple margins are combined into a placement location, they are ordered based on the Orderings property values, where "after" means farther away from the text area.

For instance, the selection margin says it is not after anything, meaning it is placed closes to the text area. The line number margin says it is after the selection margin, and so on.

Built-In Margin Summary

These editor view margins are built-in to the product:

  • Indicator margin
  • Line number margin
  • Selection margin
  • Outlining margin
  • Word wrap glyph margin
  • Ruler margin

All of the built-in margins are scrollable margins, meaning they scroll with the text area.

Indicator Margin

The indicator margin, implemented by the EditorIndicatorMargin class, is used to display glyphs for indicators. It appears in the scrollable left placement.

Visibility

This margin is not visible by default, and can be made visible when the SyntaxEditor.IsIndicatorMarginVisible property is true.

Style

The SyntaxEditor.IndicatorMarginBackground property can be set to any Brush value to alter the display of the margin.

Line Number Margin

The line number margin, implemented by the EditorLineNumberMargin class, is used to display snapshot line numbers. It appears in the scrollable left placement.

Word wrapped lines do not display any line numbers.

Visibility

This margin is not visible by default, and can be made visible when the SyntaxEditor.IsLineNumberMarginVisible property is true.

Style

The SyntaxEditor.LineNumberMarginBackground and LineNumberMarginForeground properties can be set to any Brush value to alter the display of the margin.

In addition, the LineNumberMarginFontFamily and LineNumberMarginFontSize properties can provide an alternate font for display of the line numbers.

Customizing Line Numbers

The origin line number that defaults to 1 can be set via the IEditorDocument.LineNumberOrigin property. Beyond that, an ITextViewLineNumberProvider service can be registered on the syntax language to customize how numbers are rendered in the line number margin if one-based integer numbers are not desired.

See the Line Number Provider topic for more information on implementing this kind of language service.

Selection Margin

The selection margin, implemented by the EditorSelectionMargin class, is used to display line modification marks and to provide an easy way to make line-based selections. It appears in the scrollable left placement.

Visibility

This margin is visible by default, and can be made invisible when the SyntaxEditor.IsSelectionMarginVisible property is false.

Style

The SyntaxEditor.SelectionMarginBackground property can be set to any Brush value to alter the display of the margin.

Outlining Margin

The outlining margin, implemented by the EditorOutliningMargin class, is used to display the code outlining (folding) node tree, also enables the end user to easily expand and collapse nodes. It appears in the scrollable left placement.

Visibility

This margin is visible by default, and can be made invisible when the SyntaxEditor.IsOutliningMarginVisible property is false.

Style

The SyntaxEditor.OutliningMarginBackground property can be set to any Brush value to alter the display of the margin.

Word Wrap Glyph Margin

The word wrap glyph margin, implemented by the EditorWordWrapGlyphMargin class, is used to display glyphs at the end of lines that are too long to fit in the view and must be wrapped. It appears in the scrollable right placement.

Visibility

This margin is not visible by default, and can be made visible when the SyntaxEditor.AreWordWrapGlyphsVisible property is true. The editor must also be in word wrap mode for this margin to be visible.

Style

The SyntaxEditor.WordWrapGlyphMarginBackground and WordWrapGlyphMarginForeground properties can be set to any Brush value to alter the display of the margin.

Ruler Margin

The ruler margin, implemented by the EditorRulerMargin class, is used to display a ruler character for code that uses fixed-width fonts. It appears in the scrollable top placement.

Visibility

This margin is not visible by default, and can be made visible when the SyntaxEditor.IsRulerMarginVisible property is true.

Style

The SyntaxEditor.RulerMarginBackground and RulerMarginForeground properties can be set to any Brush value to alter the display of the margin.

Margin Factories

Margin factories are used to tell SyntaxEditor which margins to display in an editor view. Margin factories are implementations of the IEditorViewMarginFactory interface.

The DefaultEditorViewMarginFactory class is an implementation of a factory that creates all of the built-in margins. While all the built-in margins are added if this factory is used, they still change their visibility based on the related SyntaxEditor margin visibility properties such as IsLineNumberMarginVisible.

The SyntaxEditor.ViewMarginFactories property is a collection of IEditorViewMarginFactory objects. By default it is auto-populated with the DefaultEditorViewMarginFactory, meaning all built-in margins are available. Add additional margin factories to the collection if you wish to add custom margins. A QuickStart is available in the samples that shows how to do this.

Custom Margins

Custom margins are pretty easy to create. These are the basic steps involved:

  • First, make a margin Control that implements IEditorViewMargin.
  • Second, make a custom IEditorViewMarginFactory that creates an instance of your margin class.
  • Third, add your custom margin factory to the SyntaxEditor.ViewMarginFactories collection.

At this point your margin should now be getting added to the view. Scrollable margins need to update when the text area is changed, so be sure to attach to the view's TextAreaLayout event and update the margin properly when that event fires.

For details on implementing a custom margin including several complete examples, please see the related QuickStarts in the samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Whitespace

SyntaxEditor can optionally display whitespace characters, change tab size, do tab to space conversion, and more.

This topic contains these sections:

  • Visible Whitespace
  • Tab Size
  • Tabs to Spaces Conversion While Typing
  • Backspacing to the Previous Tab Stop
  • Tabification and Tab to Space Conversion
  • Whitespace Trim Modes

Visible Whitespace

SyntaxEditor can optionally display whitespace characters when the SyntaxEditor.IsWhitespaceVisible property is set to true.

Tabs and spaces visible in the editor

Visible Whitespace Color

The SyntaxEditor.VisibleWhitespaceForeground property gets/sets the color used to render visible whitespace.

Tab Size

The term tab size refers to the number of spaces that a tab character appears to represent. SyntaxEditor allows you to configure the tab size. The default tab size is 4, meaning tabs render in the space of four space characters.

A tab size of eight spaces, instead of four, which is the default

The tab size can be altered by setting the ITextDocument.TabSize property. When this property is changed, the related TabSizeChanged event fires.

Tabs to Spaces Conversion While Typing

Tabs that are typed can be automatically converted to space characters if the ITextDocument.AutoConvertTabsToSpaces property is set to true.

Backspacing to the Previous Tab Stop

When ITextDocument.AutoConvertTabsToSpaces is true, pressing the Backspace key before the first non-whitespace character of a line will backspace to the previous tab stop by default. Set the SyntaxEditor.CanBackspaceOverSpacesToTabStop property is set to false to alter this behavior to only allow backspacing a single space at a time.

Tabification and Tab to Space Conversion

The IEditorViewTextChangeActions interface, available via the IEditorView.TextChangeActions property, provides several methods for doing tab/space conversions within the currently selected text.

The TabifySelectedLines and UntabifySelectedLines methods convert leading line whitespace from spaces to tabs and back in the current view selection.

The ConvertSpacesToTabs and ConvertTabsToSpaces methods convert all whitespace from spaces to tabs and back in the current view selection.

Whitespace Trim Modes

SyntaxEditor supports automatic trimming of whitespace under certain scenarios. The WhitespaceTrimModes enumeration is a flags enumeration that specifies the types of whitespace trim modes that are available, such as trimming trailing whitespace on paste and trailing whitespace on text replacements.

Set the IEditorDocument.WhitespaceTrimModes property to control the automatic whitespace trim behavior.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Word Wrap

Word wrapping is a powerful feature that allows users to view all text for a line by wrapping text that normally would have been outside the view horizontally to one or more view lines in the editor.

This topic contains these sections:

  • Word Wrap Modes
  • Word Wrap Glyph Margin

Word Wrap Modes

The SyntaxEditor.WordWrapMode property can be set to WordWrapMode.Word to activate word wrap functionality. By default it is set to WordWrapMode.None, meaning no word wrap.

Word wrap active in the editor, with the glyphs on the right indicating wrapped lines

This code activates word wrap:

C#
VB
Copy
​editor.WordWrapMode = WordWrapMode.Word;
​editor.WordWrapMode = WordWrapMode.Word

Word Wrap Glyph Margin

Word wrap glyphs can be displayed on the right side of view lines in a special margin that indicate soft line breaks (wrapped lines).

The SyntaxEditor.AreWordWrapGlyphsVisible property can be set to true to activate this functionality.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Zooming

SyntaxEditor supports animated zooming in and out of views, which is a great feature to use when giving overhead presentations. Only the scrollable area content of each view is zoomed, not the scrollbars.

This topic contains these sections:

  • Mouse Wheel Zoom
  • Keyboard Zoom
  • Touch Zoom
  • Zoom Level
  • Min/Max Zoom Levels
  • IntelliPrompt Zooming
  • Zoom Animation
  • Adjusting the Text Area Font Size Without Zooming

Mouse Wheel Zoom

If the flags-based SyntaxEditor.ZoomModesAllowed enumeration property includes the Mouse value, mouse wheel zooming is enabled.

Mouse wheel zoom is activated at run-time by holding the Ctrl key and turning the mouse wheel up to zoom in (make text larger) and down to zoom out.

The SyntaxEditor.ZoomLevelIncrement property determines the percentage amount by which to zoom with the mouse wheel. It defaults to 0.25, which means a 25% increment on each mouse wheel notch scroll.

Keyboard Zoom

If the flags-based SyntaxEditor.ZoomModesAllowed enumeration property includes the Keyboard value, keyboard zooming is enabled.

Key | Action
Ctrl + + | Zoom in.
Ctrl + - | Zoom out.
Ctrl + 0 | Reset zoom to 100%.

Touch Zoom

If the flags-based SyntaxEditor.ZoomModesAllowed enumeration property includes the Touch value, pinch-to-zoom is enabled.

Place two fingers on the editor view and spread them apart to zoom in, or bring them closer together to zoom out.

Zoom Level

The SyntaxEditor.ZoomLevel property gets and sets the current zoom level of the control.

This code sets the zoom level to 300%:

C#
VB
Copy
​editor.ZoomLevel = 3.0;
​editor.ZoomLevel = 3.0

Tip Tip
You can bind the ZoomLevel property to a Slider control that is in the status bar to provide end users an additional way to zoom.

Min/Max Zoom Levels

The SyntaxEditor.MinZoomLevel and MaxZoomLevel properties denote the range of zoom levels over which zooming can occur.

By setting these properties you can prevent end users from zooming in too far, etc.

IntelliPrompt Zooming

By default, IntelliPrompt popups will automatically scale with the current editor zoom level, but only in the range of 100% - 300%. The SyntaxEditor.MinIntelliPromptZoomLevel and MaxIntelliPromptZoomLevel properties control the range of allowed zoom levels for IntelliPrompt popups.

To prevent IntelliPrompt popups from zooming at all, set the MaxIntelliPromptZoomLevel property to 1.0. Since both the min/max will be 100%, no zooming will occur.

Zoom Animation

Zoom animation occurs by default, meaning that zoom level changes smoothly animate, providing a subtle grow/shrink effect.

The animation duration can be set via the SyntaxEditor.ZoomAnimationDuration property. Set it to 0ms to turn off animation.

Adjusting the Text Area Font Size Without Zooming

The SyntaxEditor.TextAreaFontSize property can adjust the default font size used in the editor's text area, without affecting any overlay panes or IntelliPrompt popups. Whereas the normal FontSize property can affect the entire editor element hierarchy.

Keep the TextAreaFontSize property set to its default 0 to use the FontSize property value as the text area font size.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Current Line Highlighting

SyntaxEditor supports highlighting of the current editor view line, meaning the view line that currently contains the caret.

This topic contains these sections:

  • Activating Current Line Highlighting
  • Changing the Highlight Brush

Activating Current Line Highlighting

The SyntaxEditor.IsCurrentLineHighlightingEnabled property can be set to true to activate current line highlighting. It is off by default.

Changing the Highlight Brush

The brush used to render the highlight can be adjusted by the end user since it is exposed via a special classification type's style in the highlighting style registry.

See the "Special Classification Types" section in the Highlighting Style Registries topic for more information on how to modify the style.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Delimiter Highlighting

SyntaxEditor supports highlighting of the delimiter pairs that are currently next to the caret, also known as bracket highlighting.

While delimiter pairs such as {...}, and (...) are most commonly highlighted, delimiter highlighting also supports the highlighting of more than two delimiters at a time, such as when there are #if...#else...#endif blocks.

This topic contains these sections:

  • Activating Delimiter Highlighting
  • Required Language Services
  • Performance Optimizations
  • Changing the Highlight Brush

Activating Delimiter Highlighting

The SyntaxEditor.IsDelimiterHighlightingEnabled property can be set to true to allow SyntaxEditor to render delimiter highlighting, as long as the current syntax language supports the feature. Delimiter highlighting is enabled on SyntaxEditor by default.

Required Language Services

The current syntax language must have two services registered so that delimiter highlighting can render: a structure matcher and a delimiter highlight tagger.

Structure Matcher

A structure matcher service contains the core logic for examining a document snapshot to see if any delimiters are next to a given offset. The delimiter highlighting feature calls this structure matcher and passes it the caret's offset. The matcher's results are passed back and if there are valid delimiter results next to the caret, they can be highlighted.

See the Structure Matching topic for detail on how structure matchers work and how to register one with the language.

Delimiter Highlight Tagger

A special DelimiterHighlightTagger class has been implemented that watches for text/selection changes within SyntaxEditor and calls the language's structure matcher to look for delimiter pairs as appropriate. When matcher results are found, the ranges are tagged and highlights are rendered by an internal adornment manager.

Without the tagger being registered on the language, no highlights will show for delimiters.

This code shows how to register the tagger with the language:

C#
VB
Copy
​language.RegisterService(new TextViewTaggerProvider<DelimiterHighlightTagger>(typeof(DelimiterHighlightTagger)));
​language.RegisterService(New TextViewTaggerProvider(Of DelimiterHighlightTagger)(GetType(DelimiterHighlightTagger)))

Performance Optimizations

The delimiter highlight mechanism can take time to execute when editing larger documents. This can directly have a negative performance impact on caret movement and typing speed. Thus this feature has been designed to do nearly all the work in worker threads, and utilizes the multi-threaded parser capabilities described in the Parse Requests and Dispatchers topic.

It is very important that an ambient parse request dispatcher is configured per the instructions in that topic, otherwise the delimiter highlighting feature, when enabled, will run in the UI thread and negatively affect performance.

Changing the Highlight Brush

The brush used to render the highlight can be adjusted by the end user since it is exposed via a special classification type's style in the highlighting style registry.

See the "Special Classification Types" section in the Highlighting Style Registries topic for more information on how to modify the style.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Block Selection

SyntaxEditor supports code block selection expansion and contraction, meaning that the view's selection can be expanded to include containing code blocks and contracted all the way back down to the caret as appropriate.

For instance, in C# the first time you expand the selection, it may select the containing identifier. By expanding it again, it may select the containing expression, then the containing statement, then the containing method. And so on up the compilation unit.

By contracting the selection, it goes back and selects the previously selected block. Contracting can occur recursively to go back to the original selection.

This topic contains these sections:

  • Activating Code Block Selection
  • Finder Logic
  • Registering a Code Block Finder with a Syntax Language
  • LLParseDataCodeBlockFinder Implementation
  • Programmatic Execution

Activating Code Block Selection

Code block selection is enabled on SyntaxEditor by default, and can be executed via the default Ctrl+Shift+Num+ (expand) and Ctrl+Shift+Num- (contract) key bindings.

However note that code block selection only functions if the required language service (ICodeBlockFinder interface) is registered.

Finder Logic

The ICodeBlockFinder interface has a single FindContaining method on it that accepts a TextSnapshotRange (which is the current selection range in an editor) and returns a TextSnapshotRange, which should be the text range of the containing code block. The code block could be determined by examining an AST or doing simple text/token scanning.

Registering a Code Block Finder with a Syntax Language

An ICodeBlockFinder can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ICodeBlockFinder>(myCodeBlockFinder);
​language.RegisterService(Of ICodeBlockFinder)(myCodeBlockFinder)

Registering a code block finder with a language is optional, but recommended.

LLParseDataCodeBlockFinder Implementation

The built-in LLParseDataCodeBlockFinder class, which is part of the LL(*) Parser Framework, implements ICodeBlockFinder and can be used as a code block finder service on any language that uses a grammar-based parser from our framework.

It is designed to examine the resulting AST (abstract syntax tree) that was constructed from the parser and walk up the tree as calls are made to the code block finder.

The class has a special Filter property that can optionally be assigned to a predicate delegate. The delegate is passed an IAstNode that the finder is currently examining and considering returning. If the AST node should be used, return true, otherwise return false and the finder will examine the node's parent instead. This mechanism allows for certain AST nodes to be skipped over.

Programmatic Execution

The IEditorViewSelection interface defines two methods (CodeBlockExpand and CodeBlockContract) that can be used to programmatically invoke code block selection functionality.

Again, these methods only function if an ICodeBlockFinder service is registered on the current language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indicators

Indicators are special "tagged" regions of text that display a glyph in the indicator margin also generally highlight the text range with special styles. Quick info can be displayed when hovering over the glyph, and custom mouse handling can be implemented to support functionality like toggling indicators when clicking in the indicator margin.

SyntaxEditor includes several built-in indicators: bookmarks, breakpoints, and current statement markers. Any sort of custom indicator can easily be created as well.

This topic contains these sections:

  • Basic Concepts
  • Line-Based vs. Text Range-Based Indicators
  • Bookmark Indicators
  • Breakpoint Indicators
  • Current Statement Indicators
  • Custom Indicators
  • IntelliPrompt Quick Info for Glyphs
  • Handling Pointer Events in the Indicator Margin

Basic Concepts

Indicators use the same tagging mechanism that is harnessed by many other SyntaxEditor features. A certain text range is marked with a custom tag, in this case a tag that implements IIndicatorTag. As text changes occur, the tagged range is automatically adjusted appropriately.

Glyphs

The indicator margin is where glyphs from indicators are displayed. Glyphs are drawn programmatically and render on the first view line that contains the related indicator. The IIndicatorTag.DrawGlyph method is responsible for rendering the glyph.

Important Note Important Note
The indicator margin is hidden by default and should be made visible via the SyntaxEditor.IsIndicatorMarginVisible property when indicators are used. Otherwise, no glyphs will render in the editor.

It is recommended that glyphs be restricted to 16x16 size. See the custom indicators example for a sample of creating a glyph.

Classifications

While the IIndicatorTag interface just handles rendering of the glyphs, more often than not, indicators also intend to style the contained text range differently. You see this sort of thing with breakpoints, where they highlight the background of the text red. This is accomplished by having the tag instance also implement IClassificationTag.

See the Tags and Classification Types topic for more information on how classification tags can be used to override default syntax highlighting.

Taggers and Indicator Managers

Any ITagger`1 can provide indicators, but indicators are most generally used with ICollectionTagger`1 objects. That sort of tagger works like a collection and allows you to add/remove, etc. indicator tags from it.

Say you wish to support bookmark indicators in your editor. You would add a bookmark indicator tag for each bookmark instance to the ICollectionTagger`1. If the end user toggles off a bookmark, the related tag should be removed from the tagger.

SyntaxEditor provides a helpful indicator manager (IIndicatorManager interface, accessible via the IEditorDocument.IndicatorManager property) that wraps up much of the functionality of creating/accessing a tagger behind the scenes. The manager has a number of generic methods that can be used to interact with indicators at a very high level. When a method on the indicator manager is accessed, it will go see if a related tagger is found on the document. For methods like Add and Toggle, where it is your intention to add an indicator, the manager will install an appropriate ICollectionTagger`1 on the document if one is not already present. This is helpful because it means that a tagger provider language service doesn't need to be set up on your languages for each kind of indicator you wish to use.

IIndicatorManager also provides access to some sub-managers (e.g. via the Breakpoints property) which are even friendlier ways to work directly with the related indicator type.

See below for examples of working with the indicator manager.

Line-Based vs. Text Range-Based Indicators

There are two general kinds of indicators: line-based and text range-based.

A line-based indicator is one that is applied to a single text snapshot line. An example of this kind is a bookmark. As text changes occur in and around the line, the indicator uses special logic and adjusts its tagged range to remain on and fully encompass a single line.

A text range-based indicator is one that is applied to a text snapshot range (start and end offset pair). An example of this kind is a breakpoint. As text changes occur in and around the range, the indicator adjusts its tagged range accordingly. The tagged range can cover a small portion of a line or even span multiple lines.

Bookmark Indicators

Bookmarks are line-based indicators that render a small bookmark glyph in the indicator margin to mark an area of interest for the end user. An app generally supports navigation between the bookmarks so the end user can jump the caret between them.

Bookmarks can be easily managed via the IBookmarkIndicatorManager interface, which is accessible via the IIndicatorManager.Bookmarks property.

This code shows how to toggle a bookmark on the current line that contains the caret:

C#
VB
Copy
​editor.Document.IndicatorManager.Bookmarks.Toggle(editor.ActiveView.Selection.EndSnapshotOffset.Line);
​editor.Document.IndicatorManager.Bookmarks.Toggle(editor.ActiveView.Selection.EndSnapshotOffset.Line)

Bookmark indicators also support an enabled state via their BookmarkIndicatorTag.IsEnabled property. Bookmarks are enabled by default. When disabled, their glyph and styled text range render differently. This is generally a visual reminder to the end user that the bookmark will not be hit when finding the next bookmark.

This code shows how to toggle the enabled state for a bookmark on the current line:

C#
VB
Copy
​var tagRange = editor.Document.IndicatorManager.Bookmarks.GetInstances(editor.ActiveView.Selection.EndSnapshotOffset.Line).FirstOrDefault();
if (tagRange != null)
    editor.Document.IndicatorManager.Bookmarks.ToggleEnabledState(tagRange.Tag)
​Dim tagRange = editor.Document.IndicatorManager.Bookmarks.GetInstances(editor.ActiveView.Selection.EndSnapshotOffset.Line).FirstOrDefault()
If tagRange IsNot Nothing Then
    editor.Document.IndicatorManager.Bookmarks.ToggleEnabledState(tagRange.Tag)

This code shows how to find and move the caret to the next instance of an enabled bookmark:

C#
VB
Copy
​// Create search options
var options = new TagSearchOptions<BookmarkIndicatorTag>();
options.CanWrap = true;
options.SearchUp = false;
options.Filter = (tr => tr.Tag.IsEnabled);

// Find the next indicator
var tagRange = editor.Document.IndicatorManager.Bookmarks.FindNext(editor.ActiveView.Selection.EndSnapshotOffset.Line, options);
if (tagRange != null) {
    // Move the caret
    editor.Caret.Offset = tagRange.VersionRange.Translate(editor.ActiveView.CurrentSnapshot).StartOffset;
}
​' Create search options
Dim options = New TagSearchOptions(Of BookmarkIndicatorTag)()
options.CanWrap = True
options.SearchUp = False
options.Filter = (tr => tr.Tag.IsEnabled);

' Find the next indicator
Dim tagRange = editor.Document.IndicatorManager.Bookmarks.FindNext(editor.ActiveView.Selection.EndSnapshotOffset.Line, options)
If tagRange IsNot Nothing Then
    ' Move the caret
    editor.Caret.Offset = tagRange.VersionRange.Translate(editor.ActiveView.CurrentSnapshot).StartOffset
End If

Breakpoint Indicators

Breakpoints are text range-based indicators that render a red circle glyph in the indicator margin and also highlight the contained text range with a red background. Breakpoint indicators can be used to visually represent a code execution breakpoint when working with an external debugger.

Breakpoints can be easily managed via the IBreakpointIndicatorManager interface, which is accessible via the IIndicatorManager.Breakpoints property.

This code shows how to toggle a breakpoint over a TextSnapshotRange (which generally is the text range of a statement):

C#
VB
Copy
​document.IndicatorManager.Breakpoints.Toggle(snapshotRange);
​document.IndicatorManager.Breakpoints.Toggle(snapshotRange)

This code shows how to clear all breakpoints from a document:

C#
VB
Copy
​document.IndicatorManager.Breakpoints.Clear();
​document.IndicatorManager.Breakpoints.Clear()

Breakpoint indicators also support an enabled state via their BreakpointIndicatorTag.IsEnabled property. Breakpoints are enabled by default. When disabled, their glyph and styled text range render differently. This is generally a visual reminder to the end user that the breakpoint will not be hit when code execution occurs.

This code shows how to toggle the enabled state for a breakpoint on the current line:

C#
VB
Copy
​var tagRange = editor.Document.IndicatorManager.Breakpoints.GetInstances(new TextSnapshotRange(editor.ActiveView.Selection.EndSnapshotOffset)).FirstOrDefault();
if (tagRange != null)
    editor.Document.IndicatorManager.Breakpoints.ToggleEnabledState(tagRange.Tag)
​Dim tagRange = editor.Document.IndicatorManager.Breakpoints.GetInstances(New TextSnapshotRange(editor.ActiveView.Selection.EndSnapshotOffset)).FirstOrDefault()
If tagRange IsNot Nothing Then
    editor.Document.IndicatorManager.Breakpoints.ToggleEnabledState(tagRange.Tag)

Current Statement Indicators

Current statement indicators are text range-based indicators that render a yellow arrow glyph in the indicator margin and also highlight the contained text range with a yellow background. Current statement indicators can be used to visually represent the current code execution point in a debugging session.

Current statement indicators can be easily managed via the ICurrentStatementIndicatorManager interface, which is accessible via the IIndicatorManager.CurrentStatement property. Note that this particular indicator manager is geared towards managing at most a single indicator instance at a time for a document. The reason is that there can only be a single current location in any debugging session.

This code shows how to set the current statement indicator over a TextSnapshotRange (which generally is the text range of a statement):

C#
VB
Copy
​document.IndicatorManager.CurrentStatement.SetInstance(snapshotRange);
​document.IndicatorManager.CurrentStatement.SetInstance(snapshotRange)

This code shows how to clear the current statement indicator from a document:

C#
VB
Copy
​document.IndicatorManager.CurrentStatement.Clear();
​document.IndicatorManager.CurrentStatement.Clear()

Custom Indicators

Custom indicators can easily be created and used with SyntaxEditor. To support a custom indicator, a custom indicator tag class and a custom indicator tagger class must be created.

Note Note
One of the samples included with the product shows a complete implementation of a custom tag and tagger. That is an excellent sample to examine when building a custom indicator.

Indicator Tag

Two base classes are included that make it easier to support custom indicator creation. The first is IndicatorTagBase and is an abstract base class that implements IIndicatorTag. Use this base class when the indicator will only show a glyph and not do any text range styling, such as in the case of bookmarks.

The second base class is IndicatorClassificationTagBase. This abstract base class inherits the first and also implements IClassificationTag, allowing it to style text ranges. See the Tags and Classification Types topic for more information on how classification tags can be used to override default syntax highlighting.

The IIndicatorTag.DrawGlyph method must be overridden to render the glyph for the indicator. It will be called any time the indicator is scrolled into view, and the resulting glyph will appear in the indicator margin.

Indicator Tagger

Similar to the two tag base classes above, two tagger base classes are provided: IndicatorTaggerBase`1 (to be used with IndicatorTagBase tags) and IndicatorClassificationTaggerBase`1 (to be used with IndicatorClassificationTagBase tags). The type parameter is the type of tag being returned by the tagger.

In either case, both taggers implement ICollectionTagger`1 and can be interacted with similar to a collection. See the Taggers and Tagger Providers topic for details on collection taggers.

One important thing to note about the tagger is that your inheriting class must include a public constructor that takes a single ICodeDocument parameter. The constructor should call the base constructor and pass any orderings that are appropriate to it so that indicators from certain taggers can appear above indicator from other taggers.

This code shows an example of a custom tagger that orders itself above the token tagger, meaning if its tags support IClassificationTag then it can override syntax highlighting:

C#
VB
Copy
​public CustomIndicatorTagger(ICodeDocument document) :
    base("CustomIndicator", new Ordering[] {
        new Ordering(TaggerKeys.Token, OrderPlacement.Before)
    }, document, true) {}
​Public Sub New(ByVal document As ICodeDocument)
    MyBase.New("CustomIndicator", New Ordering() {New Ordering(TaggerKeys.Token, OrderPlacement.Before)}, document, True)
End Sub

Indicator Manager

As mentioned above, the IIndicatorManager interface has a number of helpful method for working with indicators, even custom ones. For custom indicators, the generic methods directly on IIndicatorManager should be used. Each of these methods takes two generic type arguments: the type of tagger and the type of tag.

This code shows how to create a custom tag, set its quick info content provider, and add it to a certain TextSnapshotRange:

C#
VB
Copy
​// Create an indicator tag
var tag = new CustomIndicatorTag();
tag.ContentProvider = new PlainTextContentProvider("Custom indicator created at " + DateTime.Now.ToLongTimeString());

// Add the indicator tag (use a generic method provided on the indicator manager for custom indicators)
editor.Document.IndicatorManager.Add<CustomIndicatorTagger, CustomIndicatorTag>(snapshotRange, tag);
​' Create an indicator tag
Dim tag = New CustomIndicatorTag()
tag.ContentProvider = New PlainTextContentProvider("Custom indicator created at " & DateTime.Now.ToLongTimeString())

' Add the indicator tag (use a generic method provided on the indicator manager for custom indicators)
editor.Document.IndicatorManager.Add(Of CustomIndicatorTagger, CustomIndicatorTag)(snapshotRange, tag)

IntelliPrompt Quick Info for Glyphs

IntelliPrompt quick info can be added for the glyphs in the indicator margin. This means that when the mouse hovers over the glyph, a tooltip will display.

The quick info comes from the IContentProvider that is set in the IIndicatorTag.ContentProvider property. The content provider can return simple text, complex markup, etc. as described in the Content Providers topic.

Note Note
There is one requirement for this functionality to work. A special IndicatorQuickInfoProvider language service must be registered on the language. This quick info provider has built-in functionality to watch for the mouse being over indicator glyphs and use their related content provider for the quick info tip content.

This code shows how to register an IndicatorQuickInfoProvider language service on a language:

C#
VB
Copy
​language.RegisterService(new IndicatorQuickInfoProvider());
​language.RegisterService(New IndicatorQuickInfoProvider())

Handling Pointer Events in the Indicator Margin

Mouse events in the indicator margin can be handled via an IEditorViewPointerInputEventSink language service.

For instance, if your app supports a debugging experience, you may wish to allow clicks in the indicator margin to toggle whether a breakpoint is defined on the statement at that line. A full example of implementing this kind of behavior is given in the debugging-related indicators sample.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indentation Guides

Indentation guides are subtle vertical lines that render at each tab stop on lines prior to the first non-whitespace character. Whitespace-only lines render indentation guides based on the tab stop level of surrounding text.

This topic contains these sections:

  • Activating Indentation Guides
  • Changing the Indentation Guide Brush

Activating Indentation Guides

The SyntaxEditor.AreIndentationGuidesVisible property can be set to true to activate indentation guides. Guides are not visible by default.

Changing the Indentation Guide Brush

The brush used to render the indentation guides can be adjusted by the end user since it is exposed via a special classification type's style in the highlighting style registry.

See the "Special Classification Types" section in the Highlighting Style Registries topic for more information on how to modify the style.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Scrolling

Scrolling can be performed by end users via keyboard, mouse wheel, or touch. Editor views can be scrolled programmatically as well.

Scrollbars can optionally be hidden in the views, or even automatically hidden when not needed.

Scrollbar acceleration allows scrolling speed to increase the longer a scrollbar button is held.

Each editor view in SyntaxEditor also has four scrollbar tray areas, where custom controls can be inserted via data templates.

This topic contains these sections:

  • Scrolling Via Keyboard
  • Scrolling Via Mouse Wheel
  • Scrolling Via Touch
  • Programmatically Scrolling a View to a Position
  • ScrollBar Visibility
  • ScrollBar Acceleration
  • ScrollBar Tray Locations
  • Data Templates
  • Button Styles

Scrolling Via Keyboard

SyntaxEditor has default key bindings for all of the standard scroll-related text editing keys, like PgUp, PgDn, Ctrl+End, etc.

Scrolling Via Mouse Wheel

Vertical Scrolling

Vertical scrolling can be performed by spinning the mouse wheel. Each wheel notch scrolled should scroll the view by an average view line height. However if an operating system option is chosen that requests page-based scrolling with the mouse wheel, the view will scroll by the view height amount instead.

Horizontal Scrolling

Horizontal scrolling can be performed by holding the Shift key and spinning the mouse wheel.

Scrolling Via Touch

SyntaxEditor supports smooth inertia-based touch scrolling.

Programmatically Scrolling a View to a Position

The IEditorView.Scroller object has many methods for programmatically scrolling a view.

An editor view can be scrolled such that it displays the line containing a specified TextPosition. This is done by initializing a TextViewScrollState object and passing it to the IEditorViewScroller.ScrollTo method.

The following example shows how to scroll the view line containing the 24th document line (text positions are zero-based) to the center of the view. The first parameter is the vertical anchor text position. The second parameter is a TextViewVerticalAnchorPlacement that indicates where the vertical anchor text position should be placed in the view (e.g. top, center, bottom). The third parameter is a pixel delta from the placement, meaning you could scroll a text position to the top of the view but also displace it down a certain pixel amount so that lines above it are visible too for context. The fourth parameter is the horizontal scroll amount.

C#
VB
Copy
​var scrollState = new TextViewScrollState(new TextPosition(23, 0), TextViewVerticalAnchorPlacement.Center, 0, 0);
this.ActiveView.Scroller.ScrollTo(scrollState);
​Dim scrollState = New TextViewScrollState(New TextPosition(23, 0), TextViewVerticalAnchorPlacement.Center, 0, 0)
Me.ActiveView.Scroller.ScrollTo(scrollState)

The ITextView.ScrollState property returns the current resolved scroll state for the view.

ScrollBar Visibility

The SyntaxEditor.HorizontalScrollBarVisibility and VerticalScrollBarVisibility properties determine the logic behind scrollbar visibility.

  • Visible - Always show the scrollbar. This is generally the default.
  • Auto - Only show the scrollbar when it is necessary.
  • Hidden or Disabled - Hide the scrollbar.

ScrollBar Acceleration

SyntaxEditor supports scrollbar acceleration, meaning the longer the mouse is pressed over a scrollbar button, the faster scrolling will occur.

This feature has been designed to make it easier for end users to scan past large portions of a document.

Maximum Accelerated Scroll Units

The SyntaxEditor.ScrollBarAccelerationMaximum property can be set to control the maximum number of scroll units to scroll per scroll event.

By default this value is 4, meaning that scrolling down for example starts at 1 line per scroll event. If the mouse is held on the vertical scrollbar's down arrow button for a certain interval, then 2 lines scroll per event. If the mouse is still held down after another interval, then 3 lines scroll per event. If the mouse is still held down after another interval, then 4 lines scroll per event. This is the largest number of lines that will be scrolled. The lines scrolled per event resets when the mouse button is released.

Tip Tip
Set the ScrollBarAccelerationMaximum property value to 1 to disable scrollbar acceleration.

Acceleration Interval

The SyntaxEditor.ScrollBarAccelerationInterval property controls how long it takes to increment scroll units during a scroll operation.

The default value is 3 seconds, meaning every three seconds of scrolling, the number of units scrolled per scroll event will increase until the ScrollBarAccelerationMaximum value is reached.

ScrollBar Tray Locations

Each editor view has four distinct scrollbar tray areas. The locations include:

  • Left of the horizontal scrollbar
  • Right of the horizontal scrollbar
  • Above of the vertical scrollbar
  • Below of the vertical scrollbar

An editor view showing controls added in each of the four scrollbar trays

Data Templates

The tray areas are populated based on data templates that are set via these SyntaxEditor properties:

Member | Description
ScrollBarTrayBottomTemplate Property | Gets or sets the DataTemplate containing controls that are displayed under the vertical ScrollBar in an IEditorView.
ScrollBarTrayLeftTemplate Property | Gets or sets the DataTemplate containing controls that are displayed left of the horizontal ScrollBar in an IEditorView.
ScrollBarTrayRightTemplate Property | Gets or sets the DataTemplate containing controls that are displayed right of the horizontal ScrollBar in an IEditorView.
ScrollBarTrayTopTemplate Property | Gets or sets the DataTemplate containing controls that are displayed above the vertical ScrollBar in an IEditorView.

The easiest way to define a data template is in XAML. This code shows how to define the mail ToggleButton seen in the screenshot above:

XAML
Copy
​<editor:SyntaxEditor>
    <editor:SyntaxEditor.ScrollBarTrayBottomTemplate>
        <DataTemplate>
            <ToggleButton ToolTip="ToggleButton in the bottom tray">
                <Image Width="16" Height="16" Stretch="None"
                    Source="/Resources/Images/Mail16.png" />
            </ToggleButton>
        </DataTemplate>
    </editor:SyntaxEditor.ScrollBarTrayBottomTemplate>
</editor:SyntaxEditor>

Button Styles

The most common button controls are auto-styled when used within a tray area. The button types that are auto-styled are:

  • Button (native WPF)
  • ToggleButton (native WPF)
  • RepeatButton (native WPF)
  • PopupButton (Actipro Shared Library)

Use the PopupButton control if you wish to display a menu or other popup such as in the screenshot above.

While WPF buttons can support any content, we recommend small icons as the button content.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Hit Testing

SyntaxEditor makes it easy to hit test any Point in the editor and return detailed information about what is at that location.

This topic contains these sections:

  • Performing a Hit Test
  • Hit Test Results
  • Determining if the Hit Test is Over a Character
  • Scanning Text Around the Hit Test Result

Performing a Hit Test

A hit test can be performed by first obtaining a Point relative to the SyntaxEditor's coordinates and then calling the SyntaxEditor.HitTest method.

This code gets the current location of the mouse and performs a hit test against it:

C#
VB
Copy
​IHitTestResult result = editor.HitTest(Mouse.GetPosition(editor));
​Dim result As IHitTestResult = editor.HitTest(Mouse.GetPosition(editor))

Hit Test Results

The HitTest method returns an object of type IHitTestResult. This object provides information about exactly what is at the location being hit tested.

SyntaxEditor and Location

The SyntaxEditor and Location properties return the SyntaxEditor instance and location that were hit-tested.

Result Type

The Type property returns a HitTestResultType enumeration value. This value gives a high-level categorization of the result.

View and Margin

The View property returns an IEditorView if the location was over a view.

If the location was over a margin in the view, the ViewMargin property returns the IEditorViewMargin.

Offset and Position

The Offset and Position properties return the offset and TextPosition of the character at the location. If the location is not over a character, the nearest character is returned. If the location is not over a view, then the offset is -1.

See information below for how to determine if the offset/position are for an actual character or for a close character.

View Line and Text Area Location

The ViewLine property returns the ITextViewLine that contains the Position.

The TextAreaLocation returns the location, but in text area-relative coordinates.

Snapshot and Reader

The Snapshot property returns the ITextSnapshot that was current when the hit test took place. The GetReader method can be used to obtain an ITextSnapshotReader that is initialized to the hit test offset.

Intra-Text Spacer

The IntraTextSpacerTag property returns the TagSnapshotRange`1 of the IIntraTextSpacerTag that contains the hit test offset, if any. This property is only filled in when the hit test type is ViewTextAreaOverIntraTextSpacer.

VisualElement

The VisualElement property returns the FrameworkElement, if any, that is related to the hit test result.

Determining if the Hit Test is Over a Character

The Type property is useful for determining if the location is over a character in the text area. When its value is ViewTextAreaOverCharacter, the location is directly over a character within an editor view. When its value is ViewTextAreaOverLine, the location is not over a character within an editor view, but it is in the whitespace past the end of a view line. When its value is ViewTextArea, the location is not over any editor view lines, but it is in the text area.

Thus the Offset and Position properties return the exact character the location is over when Type is ViewTextAreaOverCharacter. Otherwise, the offset/position of the closest character is returned.

Scanning Text Around the Hit Test Result

The ITextSnapshotReader returned by the GetReader method can be used to scan text and tokens near the hit test result.

See the Scanning Text Using a Reader topic for more information on scanning text.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


View Lifecycle

SyntaxEditor views can be opened and closed via various end user actions. This topic discussed how to be notified when views are opened and closed.

This topic contains these sections:

  • Editor View Lifecycle
  • Printer View Lifecycle
  • SyntaxEditor Events
  • Language Event Sinks

Editor View Lifecycle

Editor views, represented by the IEditorView interface, are the interactive views that end users type in. There always is one active editor view in a SyntaxEditor instance, retrieved with the SyntaxEditor.ActiveView property.

Via the use of the Splitting feature, additional editor views can be opened and closed with in a SyntaxEditor.

Printer View Lifecycle

Printer views, represented by the IPrinterView interface, are quickly opened and immediately closed when building printable pages.

See the Printing Features topic for more information on printing editor contents.

SyntaxEditor Events

Whenever a view is opened, the SyntaxEditor.ViewOpened event is raised.

Likewise, a corresponding SyntaxEditor.ViewClosed is raised when a view is closed.

Language Event Sinks

Objects implementing the ITextViewLifecycleEventSink interface can be registered as a service on a syntax language. This allows the objects to be notified whenever a view that uses the language is attached or detached.

See the Event Sink Services topic for more information on how to register and implement event sinks.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Delayed UI Updates

SyntaxEditor includes a special event that is raised shortly after any text, caret, or selection changes occur within the editor. This event can be handled to update external UI controls based on updated editor context.

This topic contains these sections:

  • The UserInterfaceUpdate Event
  • Repeated Actions

The UserInterfaceUpdate Event

The SyntaxEditor.UserInterfaceUpdate event is raised following a brief delay after certain actions occur in the editor.

The event is set to raise 1 second after any of these actions occur:

  • Document text changed.
  • Document ParseData property changed.
  • Caret moves.
  • Selection changes.

Repeated Actions

The UserInterfaceUpdate event will not raise until the delay period has elapsed following any action listed above.

For instance, if the end user types a word and then stops, the timer to raise this event starts. However then assume that the end user holds down the down arrow to scroll through the document, before the delay period has elapsed. This action resets the event timer, and the process restarts again. Once the delay period has been reached without any further actions taking place, the event is raised.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


View Properties

The ITextView.Properties property provides a dictionary-like object that can store any sort of custom data that should be associated with the view.

The property returns an PropertyDictionary object, which supports any object type as a key or value.

This topic contains these sections:

  • Storing Data
  • Retriving Data

Storing Data

In this code snippet we store an object referenced by the variable someObject into the properties dictionary under the string key MyPropertyKey:

C#
VB
Copy
​editor.ActiveView.Properties["MyPropertyKey"] = someObject;
​editor.ActiveView.Properties.Item("MyPropertyKey") = someObject

Retriving Data

In this code snippet we retrieve an object stored under the string key MyPropertyKey:

C#
VB
Copy
​object someObject;
if (editor.ActiveView.Properties.TryGetValue("MyPropertyKey", out someObject)) {
    ...
}
​Dim someObject As Object
If editor.ActiveView.Properties.TryGetValue("MyPropertyKey", someObject) Then
    ...
End If

Alternatively the indexer could be used, however it will throw an exception if there is no object stored with the specified key, whereas TryGetValue will not.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Single-Line Mode

SyntaxEditor is a multi-line editor by default, but also supports a single-line edit mode where it looks like a single-line native TextBox.

In this mode, nearly all of SyntaxEditor's features remain available, such as syntax highlighting, syntax error squiggle lines, and automated IntelliPrompt.

This topic contains these sections:

  • Activating Single-Line Mode

Activating Single-Line Mode

The SyntaxEditor.IsMultiLine property can be set to false to activate single-line mode.

When that property is set to false, these properties are also automatically adjusted:

  • AcceptsTab is set to false.
  • IsOutliningMarginVisible is set to false.
  • IsSelectionMarginVisible is set to false.
  • InactiveSelectedTextBackground is set to null.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

In addition to the input/output features found in the text framework such as file load/save, exporting to HTML/RTF, etc., SyntaxEditor has a lot of other i/o features built-in.

This topic contains these sections:

  • Document Swapping
  • Clipboard Operations
  • Drag and Drop
  • Edit Actions
  • Default Key Bindings
  • Macro Recording and Playback
  • Data Binding
  • Indent Providers (Auto-Indent)
  • Delimiter Auto-Completion

Document Swapping

Documents can be attached to zero or more SyntaxEditor controls at any given time, and alternate IEditorDocument instances can be swapped into a SyntaxEditor.

See the Document Swapping topic for more information.

Clipboard Operations

SyntaxEditor makes use the Windows clipboard as a temporary repository for data for cut/copy/paste operations. SyntaxEditor places text on the clipboard using the DataFormats.UnicodeText and DataFormats.Text formats.

See the Clipboard Operations topic for more information.

Drag and Drop

SyntaxEditor supports drag and drop operations within itself, as well as with external controls.

See the Drag and Drop topic for more information.

Edit Actions

Edit actions are classes that implement IEditAction and contain code to perform different simple tasks related to a SyntaxEditor. They are often paired with WPF commands so that commands call can-execute and executed handlers on the edit actions to perform all the work.

See the Edit Actions topic for more information.

Default Key Bindings

Many keyboard shortcuts are automatically bound to allow keyboard access to most of the built-in edit actions.

See the Default Key Bindings topic for more information.

Macro Recording and Playback

SyntaxEditor has full macro recording and playback capabilities. It can record any edit action that is executed and can play back the set of edit actions at a later time. During macro recording mode, mouse input to the editor is ignored.

See the Macro Recording and Playback topic for more information.

Data Binding

SyntaxEditor has the capability of allowing two-way binding of its text to any other data source. This feature is disabled by default for performance reasons, but can be enabled via a property setting.

See the Data Binding topic for more information.

Indent Providers (Auto-Indent)

Indent providers are classes that implement IIndentProvider and contain code to perform automatic indentation when the Enter key is pressed.

See the Indent Providers (Auto-Indent) topic for more information.

Delimiter Auto-Completion

Delimiter auto-completion occurs when the end user types a start delimiter and a related end delimiter is auto-inserted after the caret. This improves code editing productivity since it means less overall typing is required to output the same code.

See the Delimiter Auto-Completion topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Document Swapping

Documents can be attached to zero or more SyntaxEditor controls at any given time, and alternate IEditorDocument instances can be swapped into a SyntaxEditor.

This topic contains these sections:

  • UI and Text Separation
  • Swapping Document Instances

UI and Text Separation

The SyntaxEditor product has been specifically designed such that the text/parsing framework functions completely independently from the user interface layer.

The SyntaxEditor control is the root object of the product's user interface layer. It contains multiple editor views in which text can be edited.

The IEditorDocument interface provides the requirements for a document that can be edited within a SyntaxEditor control. Editor documents are the root of the text/parsing framework hierarchy and specify an ISyntaxLanguage that is used to parse the code in the document.

Swapping Document Instances

The SyntaxEditor control is always editing a single IEditorDocument instance at a time. The Document property gets and sets which IEditorDocument is currently being edited.

A second IEditorDocument could be opened and swapped in place of the SyntaxEditor's current document, by setting the Document property to the new document instance. When this occurs, the SyntaxEditor control detaches from the old document, attaches to the new document, and updates its views to display the text in the new document.

So effectively you could have an application that has a single SyntaxEditor control instance, but a lot of IEditorDocument instances that are loaded in memory. When the end user wishes to edit a particular document, you would swap that document into the editor. This saves on overall memory since mutiple editor control instances are not required.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Clipboard Operations

SyntaxEditor makes use the Windows clipboard as a temporary repository for data for cut/copy/paste operations. SyntaxEditor places text on the clipboard using the DataFormats.UnicodeText and DataFormats.Text formats.

This topic contains these sections:

  • Cutting and Copying Text
  • Cutting and Copying with HTML and RTF Export
  • Pasting Text
  • The Clipboard and XBAP Security
  • Customizing Text to be Cut, Copied, or Dragged
  • Tracking Clipboard Change Events
  • Customizing Text to be Pasted or Dropped

Cutting and Copying Text

The IEditorView.CutLineToClipboard and CopyToClipboard methods may be used to cut and copy text to the clipboard respectively. The text that is placed on the clipboard is the currently selected text designated by the IEditorView.Selection.

If the selection length is zero, or in other words, no text is selected, a feature of SyntaxEditor is to place the entire line of text on the clipboard of which the caret is currently on. You can control whether blank lines will overwrite the clipboard by using the CanCutCopyBlankLineWhenNoSelection property.

There are CutAndAppendToClipboard and CopyAndAppendToClipboard methods on IEditorView as well, that append to the clipboard instead of replacing the contents of the clipboard.

This code demonstrates how to copy the currently selected text to the clipboard:

C#
VB
Copy
​editor.ActiveView.CopyToClipboard();
​editor.ActiveView.CopyToClipboard()

Cutting and Copying with HTML and RTF Export

The text that is copied can also be copied to the clipboard with HTML and RTF exported highlighting. Then, if you paste the text in an application such as Word, the text will appear highlighted.

The SyntaxEditor.CanCutCopyDragWithHtml property controls whether HTML exporting is performed whenever cutting or copying to the clipboard.

The SyntaxEditor.CanCutCopyDragWithRtf property controls whether RTF exporting is performed whenever cutting or copying to the clipboard.

Pasting Text

The IEditorView.PasteFromClipboard method allows text on the clipboard to be pasted into the document, thereby replacing any text that is currently selected within the view from which the method is called.

If text was copied from a SyntaxEditor when the selection length was zero (see above) the entire line of text that was copied will be inserted above the line in which the caret is currently located. In this situation, the caret is not moved.

This code demonstrates how to paste text from the clipboard:

C#
VB
Copy
​editor.ActiveView.PasteFromClipboard();
​editor.ActiveView.PasteFromClipboard()

The Clipboard and XBAP Security

If an XBAP is deployed with Internet security restrictions in place, the XBAP is not permitted to access the Windows clipboard. SyntaxEditor properly recognizes this scenario, and maintains an internal clipboard of its own so that text can be copied and pasted between SyntaxEditor instances or within the same SyntaxEditor control.

Customizing Text to be Cut, Copied, or Dragged

Sometimes it is useful to be able to customize the text, or objects, to be cut, copied, or dragged. The SyntaxEditor.CutCopyDrag event that fires before text is cut or copied to the clipboard, and also before a drag occurs.

In its event arguments, it passes the IDataStore that is to be copied as well as the type of operation that will be performed. When the event fires, the IDataStore has already been initialized with DataFormats.UnicodeText and DataFormats.Text entries based on the current selection in the editor. The IDataStore can be modified to customize what is sent to the clipboard or dragged.

Note Note
The IDataStore interface is used instead of IDataObject because IDataObject will throw a security exception in most XBAP applications. IDataStore is designed to use many of the same method signatures that IDataObject does.

Tracking Clipboard Change Events

Since the SyntaxEditor.CutCopyDrag event fires any time text is cut or copied from the control, it can also be used to maintain an external clipboard-setting history in your application. This is useful for maintaining a clipboard ring for your application.

Customizing Text to be Pasted or Dropped

Just like the SyntaxEditor.CutCopyDrag event, an event is provided to allow for customization of text that is to be pasted or dropped onto the editor. The PasteDragDrop event fires in several situations:

  • Paste operations
  • Paste completion
  • CanPaste checks
  • Drag enter
  • Drag/drop

This event passes the IDataStore that is to be pasted/dropped and the source of the event. The IDataStore is similar to IDataObject (see note above) and provides access to any clipboard data (such as non-text formats) that was used to trigger the event.

The PasteDragDropEventArgs.Text property can be set to the text to be inserted. It also can be set to null to insert nothing.

Note Note
For CanPaste checks and drag enter scenarios, the event arg's Text property can be set to any non-null value to indicate that the object can be pasted or dropped.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Drag and Drop

SyntaxEditor supports drag and drop operations within itself, as well as with external controls.

This topic contains these sections:

  • Allowing Drag and Drop
  • Dragging with HTML and RTF Export
  • Customizing Text to be Cut, Copied, or Dragged
  • Customizing Text to be Pasted or Dropped
  • Reselection of Text After a Drop

Allowing Drag and Drop

SyntaxEditor supports drag and drop by default. However drags and drops can also be disabled if desired.

The SyntaxEditor.AllowDrag property can be set to false to disable dragging from the editor.

The SyntaxEditor.AllowDrop property can be set to false to disable dropping into the editor.

Dragging with HTML and RTF Export

The text that is dragged can include HTML and RTF exported highlighting. Then, if you drop the text in an application such as Word, the text will appear highlighted.

The SyntaxEditor.CanCutCopyDragWithHtml property controls whether HTML exporting is performed whenever dragging.

The SyntaxEditor.CanCutCopyDragWithRtf property controls whether RTF exporting is performed whenever dragging.

Customizing Text to be Cut, Copied, or Dragged

Sometimes it is useful to be able to customize the text, or objects, to be cut, copied, or dragged. The SyntaxEditor.CutCopyDrag event that fires before text is cut or copied to the clipboard, and also before a drag occurs.

In its event arguments, it passes the IDataStore that is to be copied as well as the type of operation that will be performed. When the event fires, the IDataStore has already been initialized with DataFormats.UnicodeText and DataFormats.Text entries based on the current selection in the editor. The IDataStore can be modified to customize what is sent to the clipboard or dragged.

Note Note
The IDataStore interface is used instead of IDataObject because IDataObject will throw a security exception in most XBAP applications. IDataStore is designed to use many of the same method signatures that IDataObject does.

Customizing Text to be Pasted or Dropped

Just like the SyntaxEditor.CutCopyDrag event, an event is provided to allow for customization of text that is to be pasted or dropped onto the editor. The PasteDragDrop event fires in several situations:

  • Paste operations
  • Paste completion
  • CanPaste checks
  • Drag enter
  • Drag over
  • Drag/drop

This event passes the IDataStore that is to be pasted/dropped and the source of the event. The IDataStore is similar to IDataObject (see note above) and provides access to any clipboard data (such as non-text formats) that was used to trigger the event.

The PasteDragDropEventArgs.Text property can be set to the text to be inserted. It also can be set to null to insert nothing.

The Text property is auto-populated by examining the IDataStore to see if any data is present with format "Text". If pasted or dragged data doesn't include data of that format type, then the Text property will be null, indicating no paste or drop should be allowed. In a situation where a file is dragged over the editor, but no data with format "Text" is part of the dragged data, the Text property should be set to something like the full file path in the event handler to allow it to be dropped.

Note Note
For CanPaste checks and drag enter scenarios, the event arg's Text property must be set to any non-null value to indicate that the object can be pasted or dropped. The Text property doesn't need to be set to the actual value to be pasted/dropped in those scenarios, which is helpful when it's time consuming to retrieve the final text that will be pasted/dropped.

The drag over scenario can be ignored unless you wish to change the drag effect.

Reselection of Text After a Drop

By default, any dropped text will be reselected following the drop. The SyntaxEditor.IsDragDropTextReselectEnabled property can be set to false to disable this behavior.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Edit Actions

Edit actions are classes that implement IEditAction and contain code to perform different simple tasks related to a SyntaxEditor. They are often paired with commands so that commands call can-execute and executed handlers on the edit actions to perform all the work.

This topic contains these sections:

  • Edit Actions and Commands
  • Executing Edit Actions
  • Creating a Custom Edit Action
  • Binding New Edit Actions to Keys
  • Binding Built-In Edit Actions to Other Keys

Edit Actions and Commands

SyntaxEditor includes over 100 unique edit actions and related commands, covering everything such as movements, selection types, clipboard operations, and more.

The built-in edit actions are all located in the EditActions namespace.

All commands related to the built-in edit actions are available via static properties on the EditorCommands class.

Executing Edit Actions

To execute an edit action, use the IEditorView.ExecuteEditAction method. Simply pass it an instance of the IEditAction to execute.

This code shows how to execute an IndentAction on the active view:

C#
VB
Copy
​editor.ActiveView.ExecuteEditAction(new IndentAction());
​editor.ActiveView.ExecuteEditAction(New IndentAction())

Most of the edit action classes defined by SyntaxEditor also have helper methods which make running the edit actions easier. or instance, the IEditorViewSelection interface has a method SelectAll, which runs the SelectAllAction. Another example is the IEditorView interface has a method CopyToClipboard, which runs the CopyToClipboardAction.

Creating a Custom Edit Action

Custom edit action classes may be defined. The only requirement is that they implement IEditAction. When defining an edit action, it's easiest to inherit EditActionBase.

This code shows how to define an edit action that surrounds the selected text with custom tags.

C#
VB
Copy
​/// <summary>
/// Provides a custom <see cref="IEditAction"/> implementation that inserts a
/// <c>custom</c> tag surrounding the selected text.
/// </summary>
public class CustomAction : ActiproSoftware.Windows.Controls.SyntaxEditor.Implementation.EditActionBase {

    private static RoutedCommand command;

    /// <summary>
    /// Initializes an instance of the <c>CustomAction</c> class.
    /// </summary>
    public CustomAction() : base("Custom") {}

    /// <summary>
    /// Gets the <see cref="RoutedCommand"/> that can execute this action.
    /// </summary>
    /// <value>
    /// The <see cref="RoutedCommand"/> that can execute this action.
    /// </value>
    public static RoutedCommand Command {
        get {
            if (command == null)
                command = new RoutedCommand("Custom", typeof(ActiproSoftware.Windows.Controls.SyntaxEditor.SyntaxEditor));
            return command;
        }
    }

    /// <summary>
    /// Executes the edit action in the specified <see cref="IEditorView"/>.
    /// </summary>
    /// <param name="view">The <see cref="IEditorView"/> in which to execute the edit action.</param>
    public override void Execute(IEditorView view) {
        view.InsertSurroundingText("<custom>", "</custom>");
    }

}
​''' <summary>
''' Provides a custom <see cref="IEditAction"/> implementation that inserts a
''' <c>custom</c> tag surrounding the selected text.
''' </summary>
Public Class CustomAction
    Inherits ActiproSoftware.Windows.Controls.SyntaxEditor.Implementation.EditActionBase

    Private Shared command_Renamed As RoutedCommand

    ''' <summary>
    ''' Initializes an instance of the <c>CustomAction</c> class.
    ''' </summary>
    Public Sub New()
        MyBase.New("Custom")
    End Sub

    ''' <summary>
    ''' Gets the <see cref="RoutedCommand"/> that can execute this action.
    ''' </summary>
    ''' <value>
    ''' The <see cref="RoutedCommand"/> that can execute this action.
    ''' </value>
    Public Shared ReadOnly Property Command() As RoutedCommand
        Get
            If command_Renamed Is Nothing Then
                command_Renamed = New RoutedCommand("Custom", GetType(ActiproSoftware.Windows.Controls.SyntaxEditor.SyntaxEditor))
            End If
            Return command_Renamed
        End Get
    End Property

    ''' <summary>
    ''' Executes the edit action in the specified <see cref="IEditorView"/>.
    ''' </summary>
    ''' <param name="view">The <see cref="IEditorView"/> in which to execute the edit action.</param>
    Public Overrides Sub Execute(ByVal view As IEditorView)
        view.InsertSurroundingText("<custom>", "</custom>")
    End Sub

End Class

Binding New Edit Actions to Keys

Although there are many default key bindings for edit actions in SyntaxEditor, it's easy to add new ones.

Binding of edit actions to a keyboard shortcut is done in three steps. In the following example, we will bind the CustomAction edit action defined above to the Ctrl+R keyboard shortcut.

Create a Command

First, an ICommand must be defined that is related to the target edit action. Commands can be defined as static properties on a static class as we've done in EditorCommands. Or they can be defined as static properties on the related edit action class.

Add a Command Binding

Second, we need to create a command binding so that SyntaxEditor will wire the command up to execute the CustomAction edit action. EditActionBase defines a handy CreateCommandBinding method that binds a command to the CanExecute and Executed handlers on the edit action.

This code binds the command to the editor and links the command up to the edit action:

C#
VB
Copy
​editor.CommandBindings.Add(new CustomAction().CreateCommandBinding(CustomAction.Command));
​editor.CommandBindings.Add(New CustomAction().CreateCommandBinding(CustomAction.Command))

Add an Input Binding

Finally, add an input binding so that a keyboard shortcut (Ctrl+R) will trigger the command, thereby executing the edit action:

C#
VB
Copy
​editor.InputBindings.Add(new KeyBinding(CustomAction.Command, Key.R, ModifierKeys.Control));
​editor.InputBindings.Add(New KeyBinding(CustomAction.Command, Key.R, ModifierKeys.Control))

Binding Built-In Edit Actions to Other Keys

Changing or adding keyboard shortcuts to the built-in edit actions is easier. In that case it is only a matter of updating the input bindings (see above) since the EditorCommands already defines commands for the built-in edit actions and the SyntaxEditor control has handlers for all those commands.

This code makes Ctrl+R execute the copy to clipboard edit action:

C#
VB
Copy
​editor.InputBindings.Add(new KeyBinding(EditorCommands.CopyToClipboard, Key.R, ModifierKeys.Control));
​editor.InputBindings.Add(New KeyBinding(EditorCommands.CopyToClipboard, Key.R, ModifierKeys.Control))

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Default Key Bindings

Many keyboard shortcuts are automatically bound to allow keyboard access to most of the built-in edit actions.

The following tables describe the default key bindings that are in place when the SyntaxEditor control is created. These can be modified by using the SyntaxEditor.InputBindings collection.

This topic contains these sections:

  • Clipboard/Undo Edit Actions
  • Deletion Edit Actions
  • Insertion Edit Actions
  • IntelliPrompt Edit Actions
  • Miscellaneous Edit Actions
  • Movement Edit Actions
  • Scroll Edit Actions
  • Search Edit Actions
  • Selection Edit Actions

Clipboard/Undo Edit Actions

Key | Edit Action
Ctrl + C | CopyToClipboardAction
Ctrl + Ins | CopyToClipboardAction
Ctrl + X | CutToClipboardAction
Shift + Del | CutToClipboardAction
Ctrl + L | CutLineToClipboardAction
Ctrl + V | PasteFromClipboardAction
Shift + Ins | PasteFromClipboardAction
Ctrl + Y | RedoAction
Ctrl + Shift + Z | RedoAction
Ctrl + Z | UndoAction

Deletion Edit Actions

Key | Edit Action
Backspace | BackspaceAction
Shift + Backspace | BackspaceAction
Ctrl + Backspace | BackspaceToPreviousWordAction
Del | DeleteAction
Ctrl + Shift + L | DeleteLineAction
Ctrl + Del | DeleteToNextWordAction

Insertion Edit Actions

Key | Edit Action
Enter | InsertLineBreakAction
Shift + Enter | InsertLineBreakAction
Ctrl + Enter | OpenLineAboveAction
Ctrl + Shift + Enter | OpenLineBelowAction

IntelliPrompt Edit Actions

Key | Edit Action
Ctrl + Space | RequestIntelliPromptAutoCompleteAction
Ctrl + Shift + Space | RequestIntelliPromptParameterInfoSessionAction

Miscellaneous Edit Actions

Key | Edit Action
Tab | InsertTabStopOrIndentAction
Shift + Tab | RemoveTabStopOrOutdentAction
Ctrl + U | MakeLowercaseAction
Ctrl + Shift + U | MakeUppercaseAction
Insert | ToggleOverwriteModeAction
Ctrl + T | TransposeCharactersAction
Ctrl + Shift + T | TransposeWordsAction
Shift + Alt + T | TransposeLinesAction
Alt + Up | MoveSelectedLinesUpAction
Alt + Down | MoveSelectedLinesDownAction
Ctrl + Num+ | ZoomInAction
Ctrl + Num- | ZoomOutAction
Ctrl + 0 | ResetZoomLevelAction

Movement Edit Actions

Key | Edit Action
Down | MoveDownAction
Up | MoveUpAction
Left | MoveLeftAction
Right | MoveRightAction
Ctrl + Left | MoveToPreviousWordAction
Ctrl + Right | MoveToNextWordAction
Home | MoveToLineStartAction
End | MoveToLineEndAction
Ctrl + Home | MoveToDocumentStartAction
Ctrl + End | MoveToDocumentEndAction
Page Up | MovePageUpAction
Page Down | MovePageDownAction
Ctrl + Page Up | MoveToVisibleTopAction
Ctrl + Page Down | MoveToVisibleBottomAction
Ctrl + ] | MoveToMatchingBracketAction

Scroll Edit Actions

Key | Edit Action
Ctrl + Down | ScrollDownAction
Ctrl + Up | ScrollUpAction

Search Edit Actions

Key | Edit Action
Ctrl + F | FindAction
F3 | FindNextAction
Ctrl + F3 | FindNextSelectedAction
Shift + F3 | FindPreviousAction
Ctrl + Shift + F3 | FindPreviousSelectedAction
Ctrl + H | ReplaceAction
Ctrl + I | IncrementalSearchAction
Ctrl + Shift + I | ReverseIncrementalSearchAction

Selection Edit Actions

Key | Edit Action
Ctrl + Shift + Num- | CodeBlockSelectionContractAction
Ctrl + Shift + Num+ | CodeBlockSelectionExpandAction
Escape | CollapseSelectionAction
Shift + Down | SelectDownAction
Shift + Up | SelectUpAction
Shift + Left | SelectLeftAction
Shift + Right | SelectRightAction
Ctrl + Shift + Left | SelectToPreviousWordAction
Ctrl + Shift + Right | SelectBlockToNextWordAction
Shift + Home | SelectToLineStartAction
Shift + End | SelectToLineEndAction
Ctrl + Shift + Home | SelectToDocumentStartAction
Ctrl + Shift + End | SelectToDocumentEndAction
Shift + Page Up | SelectPageUpAction
Shift + Page Down | SelectPageDownAction
Ctrl + Shift + Page Up | SelectToVisibleTopAction
Ctrl + Shift + Page Down | SelectToVisibleBottomAction
Ctrl + A | SelectAllAction
Ctrl + Shift + W | SelectWordAction
Ctrl + Shift + ] | SelectToMatchingBracketAction
Shift + Alt + Down | SelectBlockDownAction
Shift + Alt + Up | SelectBlockUpAction
Shift + Alt + Left | SelectBlockLeftAction
Shift + Alt + Right | SelectBlockRightAction
Ctrl + Shift + Alt + Left | SelectBlockToPreviousWordAction
Ctrl + Shift + Alt + Right | SelectBlockToNextWordAction

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Macro Recording and Playback

SyntaxEditor has full macro recording and playback capabilities. It can record any edit action that is executed and can play back the set of edit actions at a later time. During macro recording mode, mouse input to the editor is ignored.

This topic contains these sections:

  • Controlling Macro Recording
  • MacroAction
  • Adding Macro Edit Action Key Bindings
  • Macro Commands
  • Serializing and Deserializing Macros to XML

Controlling Macro Recording

All macro recording functionality is accessible via the SyntaxEditor.MacroRecording property. The IMacroRecording interface has a number of important members:

Member | Description
Cancel Method | Cancels recording a macro. When macro recording is cancelled, the old value of the LastMacroAction property is not overwritten.
CurrentMacroAction Property | Gets the MacroAction that is currently being recorded. This method returns null (Nothing in VB) if no macro recording is currently taking place.
LastMacroAction Property | Gets the last MacroAction that was recorded. After macro recording is stopped, this property contains what was recorded.
Pause Method | Pauses recording a macro. Use the Resume method to resume recording.
Resume Method | Resumes recording a macro from a paused state. This method should be called after a Pause to resume recording.
Record Method | Starts recording a new macro. Use the Stop method to end recording and save the macro that was recorded.
State Property | Gets a MacroRecordingState indicating the current state of macro recording.
Stop Method | Stops recording a macro. The MacroAction that is recorded is stored in the LastMacroAction property. If no commands were recorded during this recording session, the old value of the LastMacroAction property will not be overwritten.

All of the methods above raise the SyntaxEditor.MacroRecordingStateChanged event.

MacroAction

Once a macro has been recorded, it is stored in a MacroAction object. The MacroAction class is an IEditAction itself. However it, and the other macro-related edit actions override the CanRecordInMacro property to prevent them from being recorded in other macros.

To play back a MacroAction, execute code like this:

C#
VB
Copy
​editor.ActiveView.ExecuteEditAction(macroAction);
​editor.ActiveView.ExecuteEditAction(macroAction)

The MacroAction class is an enumerable class of child IEditAction objects.

Adding Macro Edit Action Key Bindings

SyntaxEditor ships with several edit actions that can be added as key bindings to the SyntaxEditor.InputBindings collection:

Command | Description
CancelMacroRecordingAction | Cancels recording a macro.
PauseResumeMacroRecordingAction | Pauses or resumes recording a macro, depending on the current state of macro recording.
RunMacroAction | Runs the macro that was last recorded.
ToggleMacroRecordingAction | Starts or stops recording a macro, depending on the current state of macro recording.

By default, these edit actions are not added to the default key bindings.

Macro Commands

The EditorCommands class has a number of static properties containing commands that are handled by SyntaxEditor.

These commands are related to macros and can be used by toolbar buttons, etc. to control macro recording:

  • CancelMacroRecording
  • PauseResumeMacroRecording
  • RunMacro
  • ToggleMacroRecording

The commands use the related edit actions described in the previous section.

Serializing and Deserializing Macros to XML

SyntaxEditor can serialize a macro to XML by using the MacroAction.WriteToXml method. To deserialize a macro later, create an instance of the MacroAction and call its ReadFromXml method. All the child edit actions of the macro should load into the macro so that it is ready to be run.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Binding

SyntaxEditor has the capability of allowing two-way binding of its text to any other data source. This feature is disabled by default for performance reasons, but can be enabled via a property setting.

This topic contains these sections:

  • Why is Data Binding Disabled by Default?
  • Configuring Data Binding on Text

Why is Data Binding Disabled by Default?

Data binding to the SyntaxEditor.Text property is disabled by default for several reasons.

First, supporting the Text dependency property means that two full copies of the document text are stored in memory instead of one, which can increase memory a lot for large documents.

Second, the full text must be set to the dependency property after each text change, meaning performance could suffer depending on the size of the document.

Therefore, databinding is disabled by default.

Configuring Data Binding on Text

To enable data binding on the Text property, simply set the IsTextDataBindingEnabled property to true.

When that property is true, the text dependency property is updated when changes are made to the document, and thus binding to other objects can be achieved.

This code demonstrates how to bind the SyntaxEditor's text to another WPF TextBox:

XAML
Copy
​<editor:SyntaxEditor AreLineModificationMarksVisible="False"
                     IsTextDataBindingEnabled="True"
                     Text="{Binding ElementName=boundTextBox, Path=Text, Mode=TwoWay}" />

Since data binding replaces the complete text of the document with each change in the data source, it is best to set the AreLineModificationMarksVisible property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Providers (Auto-Indent)

Indent providers are classes that implement IIndentProvider and contain code to perform automatic indentation when the Enter key is pressed.

This topic contains these sections:

  • Indent Mode
  • Default Auto-Indent Behavior
  • Smart Indent Logic
  • Registering with a Language
  • Curly Brace Auto-Indent
  • Square Brace Auto-Indent
  • Close Delimiter Indentation Level

Indent Mode

SyntaxEditor has been designed such that customized auto-indent behavior can be implemented to suit the language being edited.

If a class that implements IIndentProvider is registered with a syntax language as an IIndentProvider service, the indent provider's Mode property will be queried by SyntaxEditor to determine the type of indentation it should be performing when Enter is pressed.

There are three mode options:

Mode | Description
None | When selected, no automatic indenting occurs when the end user presses Enter to move to a new line of text, and the cursor is placed at the first column of the next line.
Block | When selected and the end user presses Enter, the new line of text is automatically indented to the same indentation as the line preceding it.
Smart | When selected and the end user presses Enter, the new line of text is automatically indented based on what the current language's IIndentProvider service determines the context to be.

Default Auto-Indent Behavior

If do not you have an indent provider registered with your syntax language, a default "Block" mode will be used. When the end user presses Enter, the new line of text is automatically indented to the same indentation as the line preceding it.

Smart Indent Logic

When an IIndentProvider is registered with the language and the Smart indent mode is set, the GetIndentAmount method will be invoked whenever the Enter key is pressed.

The method is passed a TextSnapshotOffset and the default "block" indent amount. The result of this method should always be the number of columns (spaces) to indent the line, as opposed to tabs. Upon return from the method, SyntaxEditor will automatically indent the first non-whitespace character on the line to the desired column.

The TextSnapshotOffset.Snapshot property gives access to its ITextSnapshot. Likewise, the ITextSnapshot.Document provides access to its owner ITextDocument. The ITextDocument.TabSize property tells how many spaces are in a tab, in case that information is useful while determining the amount to indent.

If the ITextDocument is an ICodeDocument, the ICodeDocument.ParseData property may also contain AST or other language-specific information that can be useful when determining the indent amount.

Indent providers are free to use any custom logic in the GetIndentAmount implementation to perform the indentation. They typically will create an ITextSnapshotReader (see the Scanning Text Using a Reader topic), will scan backwards from the indicated offset and will determine how the passed-in "block" indent amount value should be altered, if at all.

For instance, in C#, if while scanning backwards the first non-whitespace character encountered is a {, then the the indent amount returned should be the "block" indent amount plus an additional tab stop (usually calculated by adding the ITextDocument.TabSize value).

Registering with a Language

This code demonstrates registering an XmlIndentProvider service with the syntax language that is already declared in the language variable:

C#
VB
Copy
​XmlIndentProvider indentProvider = new XmlIndentProvider();
language.RegisterService<IIndentProvider>(indentProvider);
​Dim indentProvider As XmlIndentProvider = New XmlIndentProvider()
language.RegisterService(Of IIndentProvider)(indentProvider)

Curly Brace Auto-Indent

Some languages like C# and JavaScript use curly braces as delimiters for code blocks. When the end user presses Enter while the caret is immediately between a curly brace pair, it is handy for the caret to be moved to the next line, indented, and for the close curly brace to be moved to the line following the caret. This aids in typing efficiency.

This example, where the | character denotes the caret, demonstrates the before and after what is described above:

Code Snippet
Copy
function Foo() {|}
Code Snippet
Copy
function Foo() {
    |
}

A pre-built DelimiterIndentProvider class is included that implements IIndentProvider. While it doesn't actually do anything other than block indent, it does have the code necessary to support curly brace auto-indent, as long as its CanAutoIndentCurlyBraces property is set to true (the default).

Note Note
This class is ideal for use as a base class for your own indent providers, as long as your language should have curly brace auto-indent features.

By default, DelimiterIndentProvider will just perform basic text scanning when determining if delimiters are valid for auto-indent. However this can cause issues when examining an open curly brace and the character is within a string or comment, meaning it's not really a code-oriented brace. Thus the indent provider also provides optional token IDs that can be set for each character. When a potential open/close delimiter pair is found and related token IDs are specified, it will double-check that the tokens have those token IDs. This eliminates the problem. Properties such as DelimiterIndentProvider.OpenCurlyBraceTokenId and DelimiterIndentProvider.CloseCurlyBraceTokenId are available for indicating the token IDs.

In some lexers such as dynamic lexers, token ID's might not be known and string-based token keys might only be set. In these cases, it's easy to handle. Instead of specifying values to the various token ID properties on DelimiterIndentProvider, override its IsValidStartDelimiter and IsValidEndDelimiter methods. An example of this concept is given in the Delimiter Auto-Completion topic.

Square Brace Auto-Indent

The pre-built DelimiterIndentProvider class described above also fully supports square brace auto-indent. This feature can be activated by setting the CanAutoIndentSquareBraces property is set to true.

As with curly braces, DelimiterIndentProvider will just perform basic text scanning when determining if delimiters are valid for auto-indent. However this can cause issues when examining an open curly brace and the character is within a string or comment, meaning it's not really a code-oriented brace. Thus the indent provider also provides optional token IDs that can be set for each character. When a potential open/close delimiter pair is found and related token IDs are specified, it will double-check that the tokens have those token IDs. This eliminates the problem. Properties such as DelimiterIndentProvider.OpenSquareBraceTokenId and DelimiterIndentProvider.CloseSquareBraceTokenId are available for indicating the token IDs.

In some lexers such as dynamic lexers, token ID's might not be known and string-based token keys might only be set. In these cases, it's easy to handle. Instead of specifying values to the various token ID properties on DelimiterIndentProvider, override its IsValidStartDelimiter and IsValidEndDelimiter methods. An example of this concept is given in the Delimiter Auto-Completion topic.

Close Delimiter Indentation Level

When using the DelimiterIndentProvider class described above, the close delimiter will normally flow to the same indent level as the line upon which Enter was pressed, such as:

Code Snippet
Copy
function Foo() {|}
Code Snippet
Copy
function Foo() {
    |
}

If the DelimiterIndentProvider.CloseDelimiterIndentLevel property is set to 1, the close delimiter indent an additional level:

Code Snippet
Copy
function Foo() {|}
Code Snippet
Copy
function Foo() {
    |
    }

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Delimiter Auto-Completion

Delimiter auto-completion occurs when the end user types a start delimiter and a related end delimiter is auto-inserted after the caret. This improves code editing productivity since it means less overall typing is required to output the same code.

This topic contains these sections:

  • Activating Delimiter Auto-Completion
  • Auto-Completion Logic
  • Registering a Delimiter Auto-Completer with a Syntax Language
  • Working with Dynamic Lexers and String Token Keys
  • Single Token String Delimiter Auto-Completion

Activating Delimiter Auto-Completion

The SyntaxEditor.IsDelimiterAutoCompleteEnabled property can be set to true to allow SyntaxEditor to perform delimiter auto-completion, as long as the current syntax language supports the feature. Delimiter auto-completion is enabled on SyntaxEditor by default.

Auto-Completion Logic

Delimiter auto-completers are language services that implement the IDelimiterAutoCompleter interface. A built-in DelimiterAutoCompleter class is included that fully implements IDelimiterAutoCompleter and makes it easy for a language to support auto-completion of these delimiter pairs:

  • Angle braces (disabled by default)
  • Curly braces
  • Double quotes
  • Parenthesis
  • Single quotes (disabled by default)
  • Square braces

The various supported brace match options can be turned on or off with properties such as DelimiterAutoCompleter.CanCompleteSquareBraces.

By default, this auto-completer will just perform basic text scanning when determining if delimiters are valid for auto-completion. However this can cause issues when examining an open parenthesis and the character is within a string or comment, meaning it's not really a code-oriented parenthesis. Thus the auto-completer also provides optional token IDs that can be set for each character. When a potential open delimiter is found and a related token ID is specified, it will double-check that the token at the offset has that token ID. This eliminates the problem. Properties such as DelimiterAutoCompleter.OpenParenthesisTokenId are available for indicating the token IDs.

Registering a Delimiter Auto-Completer with a Syntax Language

An IDelimiterAutoCompleter can be associated with an ISyntaxLanguage by registering it with the language. This example shows how to use a DelimiterAutoCompleter that only has curly brace and parenthesis support:

C#
VB
Copy
​language.RegisterService<IDelimiterAutoCompleter>(new DelimiterAutoCompleter() {
    CanCompleteDoubleQuotes = false,
    CanCompleteSquareBraces = false,
    OpenCurlyBraceTokenId = SimpleTokenId.OpenCurlyBrace,
    OpenParenthesisTokenId = SimpleTokenId.OpenParenthesis,
});
​language.RegisterService(Of IDelimiterAutoCompleter)(New DelimiterAutoCompleter() With { _
    .CanCompleteDoubleQuotes = False, _
    .CanCompleteSquareBraces = False, _
    .OpenCurlyBraceTokenId = SimpleTokenId.OpenCurlyBrace, _
    .OpenParenthesisTokenId = SimpleTokenId.OpenParenthesis _
})

Note how token IDs are specified to ensure start delimiters are properly recognized.

Working with Dynamic Lexers and String Token Keys

In some lexers such as dynamic lexers, token ID's might not be known and string-based token keys might only be set. In these cases, it's easy to handle. Instead of specifying values to the various token ID properties on DelimiterAutoCompleter, override its IsValidStartDelimiter method.

This example shows how to make a customized delimiter auto-completer that adds parenthesis-only auto-completion to the free SQL language:

C#
VB
Copy
​public class SqlDelimiterAutoCompleter : DelimiterAutoCompleter {

    public SqlDelimiterAutoCompleter() {
        this.CanCompleteDoubleQuotes = false;
        this.CanCompleteCurlyBraces = false;
        this.CanCompleteSquareBraces = false;
    }

    protected override bool IsValidStartDelimiter(IToken token, char startDelimiter) {
        switch (startDelimiter) {
            case '(':
                return (token != null) && (token.Key == "OpenParenthesis");
            default:
                return false;
        }
    }

}
​Public Class SqlDelimiterAutoCompleter
    Inherits DelimiterAutoCompleter

    Public Sub New()
        Me.CanCompleteDoubleQuotes = False
        Me.CanCompleteCurlyBraces = False
        Me.CanCompleteSquareBraces = False
    End Sub

    Protected Overrides Function IsValidStartDelimiter(ByVal token As IToken, ByVal startDelimiter As Char) As Boolean
        Select Case startDelimiter
            Case "("c
                Return (token IsNot Nothing) AndAlso (token.Key = "OpenParenthesis")
            Case Else
                Return False
        End Select
    End Function

End Class

Single Token String Delimiter Auto-Completion

Some languages have a single token to represent a string, and the same character is used to delimit the string start and end. In this sort of case, the DelimiterAutoCompleter.IsValidStartDelimiter method can be overridden with some custom logic.

This example shows how we accomplish basic string literal auto-completion in our .NET Languages Add-on's C# language:

C#
VB
Copy
​public class CSharpDelimiterAutoCompleter : DelimiterAutoCompleter {

    ...

    protected override bool IsValidStartDelimiter(ITextSnapshotReader reader, char startDelimiter) {
        if (base.IsValidStartDelimiter(reader, startDelimiter))
            return true;

        if ((reader != null) && (startDelimiter == '"')) {
            var token = ((reader.IsAtTokenStart || reader.IsAtSnapshotEnd) ? reader.PeekTokenReverse() : reader.Token);
            if ((token != null) && (token.Id == CSharpTokenId.LiteralString))
                return (token.StartOffset == reader.Offset - 1);
        }

        return false;
    }

}
​Public Class CSharpDelimiterAutoCompleter
    Inherits DelimiterAutoCompleter

    ...

    Protected Overrides Function IsValidStartDelimiter(ByVal reader As ITextSnapshotReader, ByVal startDelimiter As Char) As Boolean
        If MyBase.IsValidStartDelimiter(reader, startDelimiter) Then
            Return True
        End If

        If (reader IsNot Nothing) AndAlso (startDelimiter = """"c) Then
            Dim token = (If((reader.IsAtTokenStart OrElse reader.IsAtSnapshotEnd), reader.PeekTokenReverse(), reader.Token))
            If (token IsNot Nothing) AndAlso (token.Id = CSharpTokenId.LiteralString) Then
                Return (token.StartOffset = reader.Offset - 1)
            End If
        End If

        Return False
    End Function

End Class

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor's print features include easy dialog access, many print options, and customizable margins.

This topic contains these sections:

  • Print Dialogs
  • Print Options
  • Printer View Margins
  • Printing to XPS

Print Dialogs

SyntaxEditor provides easy access to built-in print dialogs.

See the Print Dialogs topic for more information.

Print Options

There are a large number of options available that affect how printouts render.

See the Print Options topic for more information.

Printer View Margins

While the SyntaxEditor printer views have numerous built-in margins (document title, page number, etc.), SyntaxEditor offers an extensibility point where custom margins can be created and added to printer views in any location.

See the Printer View Margins topic for more information.

Printing to XPS

Any SyntaxEditor document content can be printed out to XPS format with a few lines of code.

See the Printing to XPS topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Print Dialogs

SyntaxEditor provides easy access to built-in print dialogs.

This topic contains these sections:

  • The Print Dialog
  • The Print Preview Dialog

The Print Dialog

The Print dialog can be displayed by calling the SyntaxEditor.ShowPrintDialog method.

The Print dialog

This code shows the dialog:

C#
VB
Copy
​editor.ShowPrintDialog();
​editor.ShowPrintDialog()

The printed content is based on the configuration of the SyntaxEditor.PrintSettings object.

The Print Preview Dialog

The Print Preview dialog can be displayed by calling the SyntaxEditor.ShowPrintPreviewDialog method.

The Print Preview dialog

This code shows the dialog:

C#
VB
Copy
​editor.ShowPrintPreviewDialog();
​editor.ShowPrintPreviewDialog()

The printed content is based on the configuration of the SyntaxEditor.PrintSettings object.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Print Options

There are a large number of options available that affect how printouts render.

This topic contains these sections:

  • Accessing Print Settings
  • The Document Title
  • Turning Off Syntax Highlighting
  • Using a Custom Highlighting Style Registry
  • Displaying Whitespace
  • Page Size and Margins
  • Creating a FixedDocument

Accessing Print Settings

The IPrintSettings interface contains all the options that relate to printing. The print settings are accessed via the SyntaxEditor.PrintSettings property.

The Document Title

The document title can optionally be displayed at the top of each page in a printer view. It is visible when the IPrintSettings.DocumentTitle property is non-null and the IsDocumentTitleMarginVisible property is true, which is the default.

This code sets the document title that is displayed at the top of each page:

C#
VB
Copy
​editor.PrintSettings.DocumentTitle = "My Document";
​editor.PrintSettings.DocumentTitle = "My Document"

Turning Off Syntax Highlighting

Syntax highlighting is on by default for printer views. To turn it off and make text black and white, set the IPrintSettings.IsSyntaxHighlightingEnabled property is set to false.

Using a Custom Highlighting Style Registry

When syntax highlighting is on for printer views, it will use the IHighlightingStyleRegistry that is currently active in the editor. However when the editor is using a dark theme, this is not a desirable registry to use for printouts.

A IPrintSettings.HighlightingStyleRegistry property can be set to a custom IHighlightingStyleRegistry instance that will be used for printer output only, and is ideally set up with darker foreground colors and no backgrounds.

See the Highlighting Style Registries topic for more information on highlighting style registries.

Displaying Whitespace

Tabs and spaces can be visually displayed when the IPrintSettings.IsWhitespaceVisible property is set to true. The default is to not show whitespace.

Page Size and Margins

The IPrintSettings interface has several properties that control the page size and margins.

PageSize determines the Size of each page. A standard 8.5" x 11" page would have values 96 * 8.5, 96 * 11, where 1 inch = 96px in default resolution.

PageMargin gives the Thickness between the page content and the page edge. The default value is 96 * 0.75, where 1 inch = 96px in default resolution. This means the default margin is 0.75in.

Various printer view margin visibility properties such as IsDocumentTitleMarginVisible are included as well. These properties are described in the Printer View Margins topic.

Creating a FixedDocument

The IPrintSettings.CreateFixedDocument method makes it simple to create a WPF FixedDocument that renders the contents of the SyntaxEditor, including applicable printer view margins.

This code creates a FixedDocument of the editor's content:

C#
VB
Copy
​FixedDocument document = editor.PrintSettings.CreateFixedDocument(editor);
​Dim document As FixedDocument = editor.PrintSettings.CreateFixedDocument(editor)

This feature can be used to print to XPS.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Printer View Margins

While the SyntaxEditor printer views have numerous built-in margins (document title, page number, etc.), SyntaxEditor offers an extensibility point where custom margins can be created and added to printer views in any location.

Printer view margins all implement the IPrinterViewMargin interface.

This topic contains these sections:

  • Margin Locations
  • Built-In Margin Summary
  • Document Title Margin
  • Line Number Margin
  • Word Wrap Glyph Margin
  • Page Number Margin
  • Margin Factories
  • Custom Margins

Margin Locations

Printer view margins surround the text area and can be displayed in one of four placement locations (left, top, right, bottom).

The IPrinterViewMargin.Placement property has an PrinterViewMarginPlacement enumeration value that indicates one of those four placement locations.

Since each IPrinterViewMargin has a string-based Key, and the interface also implements IOrderable, it has an Orderings property that returns an enumerable of Ordering objects. Each ordering indicates the a string Key of another margin and whether this margin comes before or after that one. When multiple margins are combined into a placement location, they are ordered based on the Orderings property values, where "after" means farther away from the text area.

Built-In Margin Summary

These printer view margins are built-in to the product:

  • Document title margin
  • Line number margin
  • Word wrap glyph margin
  • Page number margin

Document Title Margin

The document title margin, implemented by the PrinterDocumentTitleMargin class, is used to display the title of the document, which is specified in the IPrintSettings.DocumentTitle property. It appears in the top placement.

Visibility

This margin is visible by default (if a document title is specified), and can be made invisible when the IPrintSettings.IsDocumentTitleMarginVisible property is false.

Line Number Margin

The line number margin, implemented by the PrinterLineNumberMargin class, is used to display snapshot line numbers. It appears in the left placement.

Word wrapped lines do not display any line numbers.

Visibility

This margin is not visible by default, and can be made visible when the IPrintSettings.IsLineNumberMarginVisible property is true.

Word Wrap Glyph Margin

The word wrap glyph margin, implemented by the PrinterWordWrapGlyphMargin class, is used to display glyphs at the end of lines that are too long to fit in the view and must be wrapped. It appears in the right placement.

Visibility

This margin is visible by default, and can be made invisible when the IPrintSettings.IsWordWrapGlyphMarginVisible property is false.

Page Number Margin

The page number margin, implemented by the PrinterPageNumberMargin class, is used to display the current page number on each page, along with the total page count. It appears in the bottom placement.

Visibility

This margin is visible by default, and can be made invisible when the IPrintSettings.IsPageNumberMarginVisible property is false.

Margin Factories

Margin factories are used to tell SyntaxEditor which margins to display in a printer view. Margin factories are implementations of the IPrinterViewMarginFactory interface.

The DefaultPrinterViewMarginFactory class is an implementation of a factory that creates all of the built-in margins. While all the built-in margins are added if this factory is used, they still change their visibility based on the related IPrintSettings margin visibility properties such as IsDocumentTitleMarginVisible.

The IPrintSettings.ViewMarginFactories property is a collection of IPrinterViewMarginFactory objects. By default it is auto-populated with the DefaultPrinterViewMarginFactory, meaning all built-in margins are available. Add additional margin factories to the collection if you wish to add custom margins. A QuickStart is available in the samples that shows how to do this.

Custom Margins

Custom margins are pretty easy to create. These are the basic steps involved:

  • First, make a margin Control that implements IPrinterViewMargin.
  • Second, make a custom IPrinterViewMarginFactory that creates an instance of your margin class.
  • Third, add your custom margin factory to the IPrintSettings.ViewMarginFactories collection.

At this point your margin should now be getting added to the view.

For details on implementing a custom margin including several complete examples, please see the related QuickStarts in the samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Printing to XPS

Any SyntaxEditor document content can be printed out to XPS format with a few lines of code.

This topic contains these sections:

  • What is XPS?
  • Sample Code

What is XPS?

XPS means XML Paper Specification and is a royalty-free document format created by Microsoft to compete with PDF. It is vector-based and supports device and resolution independence.

WPF has built-in support for XPS via several of its controls and classes in the System.Printing assembly.

Sample Code

This code prints the editor's content to an XPS file:

C#
VB
Copy
​FixedDocument document = editor.PrintSettings.CreateFixedDocument(editor);
XpsDocument xpsd = new XpsDocument(dialog.FileName, FileAccess.Write);
XpsDocumentWriter xw = XpsDocument.CreateXpsDocumentWriter(xpsd);
xw.Write(document);
xpsd.Close();
​Dim document As FixedDocument = editor.PrintSettings.CreateFixedDocument(editor)
Dim xpsd As XpsDocument = New XpsDocument(dialog.FileName, FileAccess.Write)
Dim xw As XpsDocumentWriter = XpsDocument.CreateXpsDocumentWriter(xpsd)
xw.Write(document)
xpsd.Close()

Note that it first creates a standard WPF FixedDocument and then uses that to write out to an XPS file.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor's view search model interacts with the view's selection and provides extensive find/replace functionality. A standalone EditorSearchView control can be used to instantly recreate a Visual Studio-like search experience for end users.

This topic contains these sections:

  • Programmatically Searching
  • Search Overlay Pane
  • Incremental Search
  • Search Result Highlighting
  • EditorSearchView Control

Programmatically Searching

SyntaxEditor includes a powerful view search model that is layered on top of the low-level search model found in the text framework.

See the Programmatically Searching topic for more information.

Search Overlay Pane

The search overlay pane is a control built into SyntaxEditor that allows find and replace operations to be performed. When active, the pane appears in-line at the upper right corner of the text area.

See the Search Overlay Pane topic for more information.

Incremental Search

SyntaxEditor supports incremental search, which is a feature that allows for fast text searching via the keyboard, and without the use of any search dialogs or panes.

See the Incremental Search topic for more information.

Search Result Highlighting

When performing searches, many modern editors actively display matching results as the user types the find text. SyntaxEditor supports the live highlighting of search results.

See the Search Result Highlighting topic for more information.

EditorSearchView Control

The EditorSearchView control is a standalone control that can be used within an application tool window to provide an user interface with Visual Studio-like search capabilities for a SyntaxEditor.

See the EditorSearchView Control topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Programmatically Searching

SyntaxEditor includes a powerful view search model that is layered on top of the low-level search model found in the text framework.

This topic contains these sections:

  • Understanding the View Search Model vs. the Low-Level Search Model
  • Accessing the View Search Model
  • Editor Search Options
  • Search Result Sets
  • Performing a Find Next Operation
  • Performing a Replace Next Operation
  • Performing a Replace All Operation

Understanding the View Search Model vs. the Low-Level Search Model

Before diving into this topic any further, it is essential that you understand the information presented in the Low-Level Searching Operations topic. That topic describes the core search object model and its capabilities. Most of the same types described in that topic are used in the "view" search model.

The "view" search model layers itself on top of the core model and provides some extended functionality. Most of the extended functionality deals with manipulating the search operations based on the view's selection and updated the selection when appropriate.

In general, the rule of thumb is: if you are going to search a document that is open within a SyntaxEditor control, use the "view" search model. If you are going to search a document that is not open in a SyntaxEditor control, use the low-level search model.

Accessing the View Search Model

The "view" search model is accessed via the IEditorView.Searcher property. This property returns an IEditorViewSearcher instance, which has find/replace functionality built-in.

Since the view search model is accessed for a particular view, it interacts with the owner view's selection.

Editor Search Options

The IEditorSearchOptions interface specifies the options type that must be passed into the view search model methods. It inherits the low-level ISearchOptions interface, which is described in the Low-Level Searching Operations topic.

This view search model options interface adds a Scope property, which is an enumeration value of type EditorSearchScope. It specifies whether the search is performed within the entire document or in the current selection only.

The EditorSearchOptions is an implementation of the IEditorSearchOptions interface and can be used in your code.

Search Result Sets

Each search method returns an ISearchResultSet object, which is described in detail in the Low-Level Searching Operations topic.

Performing a Find Next Operation

A find next operation can be performed like this:

C#
VB
Copy
​EditorSearchOptions options = new EditorSearchOptions();
options.FindText = "findtext";
options.PatternProvider = SearchPatternProviders.Normal;
ISearchResultSet resultSet = editor.ActiveView.Searcher.FindNext(options);
​Dim options As EditorSearchOptions = New EditorSearchOptions()
options.FindText = "findtext"
options.PatternProvider = SearchPatternProviders.Normal
Dim resultSet As ISearchResultSet = editor.ActiveView.Searcher.FindNext(options)

Performing a Replace Next Operation

A replace next operation can be performed like this:

C#
VB
Copy
​EditorSearchOptions options = new EditorSearchOptions();
options.FindText = "findtext";
options.ReplaceText = "replacetext";
options.PatternProvider = SearchPatternProviders.Normal;
ISearchResultSet resultSet = editor.ActiveView.Searcher.ReplaceNext(options);
​Dim options As EditorSearchOptions = New EditorSearchOptions()
options.FindText = "findtext"
options.ReplaceText = "replacetext"
options.PatternProvider = SearchPatternProviders.Normal
Dim resultSet As ISearchResultSet = editor.ActiveView.Searcher.ReplaceNext(options)

Performing a Replace All Operation

A replace all operation can be performed like this:

C#
VB
Copy
​EditorSearchOptions options = new EditorSearchOptions();
options.FindText = "findtext";
options.ReplaceText = "replacetext";
options.PatternProvider = SearchPatternProviders.Normal;
ISearchResultSet resultSet = editor.ActiveView.Searcher.ReplaceAll(options);
​Dim options As EditorSearchOptions = New EditorSearchOptions()
options.FindText = "findtext"
options.ReplaceText = "replacetext"
options.PatternProvider = SearchPatternProviders.Normal
Dim resultSet As ISearchResultSet = editor.ActiveView.Searcher.ReplaceAll(options)

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Search Overlay Pane

The search overlay pane is a control built into SyntaxEditor that allows find and replace operations to be performed. When active, the pane appears in-line at the upper right corner of the text area.

This topic contains these sections:

  • Built-in Key Bindings
  • The SearchOverlayPane User Interface
  • Pane Events
  • Syncing Options
  • Handling Results
  • Search Result Highlights
  • Control Key Down Opacity
  • Programmatically Opening the Pane

Built-in Key Bindings

SyntaxEditor Search Key Bindings

These key bindings are search-related and are built into the SyntaxEditor control, often triggering the search overlay pane to open.

Key | Edit Action
Ctrl + F | Opens the search overlay pane in find mode and focuses the find textbox.
F3 | Repeats the last search operation in a forward direction.
Ctrl + F3 | Performs a forward find on the current selection, or the current word when there is not selection. Also opens the search overlay pane in find mode.
Shift + F3 | Repeats the last search operation in a backward direction.
Ctrl + Shift + F3 | Performs a backward find on the current selection, or the current word when there is not selection. Also opens the search overlay pane in find mode.
Ctrl + H | Opens the search overlay pane in replace mode and focuses the find what textbox.

Disabling Built-in Search Functionality

To prevent the end user from activating the built-in search features, remove the appropriate entries from the SyntaxEditor.InputBindings collection that correspond to the hotkeys above.

SearchOverlayPane-Only Key Bindings

These key bindings are active when focus is within the search overlay pane, providing quick access to common features.

Key | Edit Action
Esc | Closes the search overlay pane.
Enter (focus in find textbox) | Performs a find operation.
Enter (focus in replace textbox) | Performs a replace operation.
Alt+R | When in replace mode, replaces the next matched search result.
Alt+A | When in replace mode, replaces all matched search results.
Alt+C | Toggles the match case option.
Alt+W | Toggles the whole word option.
Alt+E | Toggles the use regular expressions option.
Alt+U | Toggles the use search up option.

The SearchOverlayPane User Interface

The SearchOverlayPane control is designed to mimic the in-line find/replace pane found in the Visual Studio editor.

The SearchOverlayPane control in replace mode

Search Modes

The control offers two search modes: find and replace. Use the expansion arrow on the left side of the control to toggle between them.

The expansion arrow is displayed by default. However the CanToggleReplace property can be set to false to hide it.

This is useful if you only wish to allow the end user to perform find opertions and not replace operations.

Find All Button Visibility

The Find All button is not displayed by default. The IsFindAllButtonVisible property can be set to true to show it.

This button should only be made visible if the find results will be displayed to the user from within a SyntaxEditor.ViewSearch event handler. A common way to do this is to display the results within a Find Results tool window.

Options Panel

The row containing search options (match case, match whole word, use regular expressions, search up, etc.) can be expanded or collapsed. The IsOptionsPanelExpanded property determines the current expansion state of the panel.

Smooth Animation

When opening/closing the pane or switching between find/replace modes, subtle animated transitions at used.

Animation can be disabled by setting the AnimationDuration property to 0.

Pane Events

The SyntaxEditor.OverlayPaneOpened event is fired when the search overlay pane is opened. The OverlayPaneEventArgs.Pane property contains the SearchOverlayPane instance that is opening. This is where various options may be set on the pane for initialization purposes.

This code shows how to set several options on the pane:

C#
VB
Copy
​private void OnSyntaxEditorOverlayPaneOpened(object sender, OverlayPaneEventArgs e) {
    var pane = e.Pane as SearchOverlayPane;
    if (pane != null) {
        pane.CanToggleReplace = false;  // Hide expansion button to toggle to replace mode
        pane.IsReplaceVisible = false;  // Force find mode, even if Ctrl+H is pressed

        pane.IsFindAllButtonVisible = true;  // Show a "find all" button
    }
}
​Private Sub OnSyntaxEditorOverlayPaneOpened(ByVal sender As Object, ByVal e As OverlayPaneEventArgs)
    Dim pane = TryCast(e.Pane, SearchOverlayPane)
    If pane IsNot Nothing Then
        pane.CanToggleReplace = False ' Hide expansion button to toggle to replace mode
        pane.IsReplaceVisible = False ' Force find mode, even if Ctrl+H is pressed

        pane.IsFindAllButtonVisible = True ' Show a "find all" button
    End If
End Sub

The SyntaxEditor.OverlayPaneClosed event is fired when the pane is closed.

Syncing Options

The SearchOverlayPane.SearchOptions property accepts an IEditorSearchOptions instance that automatically gets assigned the search options instance found in the SyntaxEditor.SearchOptions property.

When the end user alters the "find what" text for instance, the control auto-updates the attached options. The options can be used with any search operation.

Note Note
The EditorSearchOptions class provides an implementation of the IEditorSearchOptions interface.

The default IEditorSearchOptions instance set to the SearchOptions property is a static instance from the EditorSearchOptions.Default property. This allows the search options to be shared amongst multiple SyntaxEditor controls out-of-the-box.

Handling Results

The SyntaxEditor.ViewSearch event fires whenever a search is made using SearchOverlayPane. The event arguments pass along the search options and the result set. That information can then be presented to the user in a Find Results tool window for example.

Search Result Highlights

Search results can be highlighted as the find text and other search options are altered in the search overlay pane. For this functionality to work, please make sure the appropriate display classification type is registered per the requirements listed in the Search Result Highlighting topic.

Control Key Down Opacity

The search overlay pane animates to be semi-transparent when the Ctrl key is held down, thereby allowing the end user to see the text behind it. SearchOverlayPane.ControlKeyDownOpacity property specifies the opacity when the popup is semi-transparent.

Set this property to 1.0 to prevent the list from being semi-transparent.

Programmatically Opening the Pane

This code shows how to programmatically the pane:

C#
VB
Copy
​// NOTE: Update the find text in view.SyntaxEditor.SearchOptions here as needed

// If the editor is in multi-line mode...
if (view.SyntaxEditor.IsMultiLine) {
    // Ensure the search pane is open (visible) and in "find" mode
    var searchPane = view.OverlayPanes[OverlayPaneKeys.Search] as SearchOverlayPane;
    if (searchPane != null) {
        searchPane.IsReplaceVisible = false;
        searchPane.SearchOptions = view.SyntaxEditor.SearchOptions;
    }
    else
        searchPane = view.OverlayPanes.AddSearch(false) as SearchOverlayPane;

    // Activate the pane (only if you wish to focus the "find what" TextBox)
    if (searchPane != null)
        searchPane.Activate();
}
​' NOTE: Update the find text in view.SyntaxEditor.SearchOptions here as needed

' If the editor is in multi-line mode...
If view.SyntaxEditor.IsMultiLine Then
    ' Ensure the search pane is open (visible) and in "find" mode
    Dim searchPane = TryCast(view.OverlayPanes(OverlayPaneKeys.Search), SearchOverlayPane)
    If searchPane IsNot Nothing Then
        searchPane.IsReplaceVisible = False
        searchPane.SearchOptions = view.SyntaxEditor.SearchOptions
    Else
        searchPane = TryCast(view.OverlayPanes.AddSearch(False), SearchOverlayPane)
    End If

    ' Activate the pane (only if you wish to focus the "find what" TextBox)
    If searchPane IsNot Nothing Then
        searchPane.Activate()
    End If
End If

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Incremental Search

SyntaxEditor supports incremental search, which is a feature that allows for fast text searching via the keyboard, and without the use of any search dialogs or panes.

This topic contains these sections:

  • Run-Time Usage
  • UI Updates While Searching
  • Trimming Unmatched Find Text
  • Disabling Incremental Search

Run-Time Usage

Incremental searches are performed from the current caret offset in the editor. To start incremental search mode, press Ctrl+I and start typing some characters. The characters will be accumulated into a find text string and used to search the document for the next instance of the find text, which will be selected.

All find text matches will be automatically highlighted as long as the Search Result Highlighting feature is enabled.

Press Ctrl+I to move to the next match. Press Ctrl+Shift+I to move to the previous match.

Continue typing characters to append to the find text. Backspace can be used to remove characters from the find text. Esc can be used to deactivate incremental search mode.

UI Updates While Searching

The application UI should provide some sort of status indicator when incremental search events occur.

The SyntaxEditor.ViewSearch event fires whenever any editor view search occurs, including when incremental searches take place. In this scenario, the result set's ISearchResultSet.OperationType property will be FindNextIncremental. UI such as a statusbar can be updated in an event handler to indicate that incremental search is active and what the find text is.

The SyntaxEditor.ViewIsIncrementalSearchActiveChanged event fires whenever incremental search mode is activated or deactivated. It's a great place to clear out any UI that indicates incremental search is active. The IEditorView.IsIncrementalSearchActive property is used to know if incremental search mode is active.

This code shows how a statusbar panel could be updated in response to the events mentioned above:

C#
VB
Copy
​private void OnSyntaxEditorViewIsIncrementalSearchActiveChanged(object sender, TextViewEventArgs e) {
    IEditorView editorView = e.View as IEditorView;
    if ((editorView != null) && (!editorView.IsIncrementalSearchActive)) {
        // Incremental search is now deactivated
        messagePanel.Content = "Ready";
    }
}

private void OnSyntaxEditorViewSearch(object sender, EditorViewSearchEventArgs e) {
    // If an incremental search was performed...
    if (e.ResultSet.OperationType == SearchOperationType.FindNextIncremental) {
        // Show a statusbar message
        bool hasFindText = !String.IsNullOrEmpty(e.ResultSet.Options.FindText);
        bool notFound = (hasFindText) && (e.ResultSet.Results.Count == 0);
        string notFoundMessage = (notFound ? " (not found)" : String.Empty);
        messagePanel.Content = "Incremental Search: " + e.ResultSet.Options.FindText + notFoundMessage;
    }
}
​Private Sub OnSyntaxEditorViewIsIncrementalSearchActiveChanged(ByVal sender As Object, ByVal e As TextViewEventArgs)
    Dim editorView As IEditorView = TryCast(e.View, IEditorView)
    If (editorView IsNot Nothing) AndAlso ((Not editorView.IsIncrementalSearchActive)) Then
        ' Incremental search is now deactivated
        messagePanel.Content = "Ready"
    End If
End Sub

Private Sub OnSyntaxEditorViewSearch(ByVal sender As Object, ByVal e As EditorViewSearchEventArgs)
    ' If an incremental search was performed...
    If e.ResultSet.OperationType = SearchOperationType.FindNextIncremental Then
        ' Show a statusbar message
        Dim hasFindText As Boolean = Not String.IsNullOrEmpty(e.ResultSet.Options.FindText)
        Dim notFound As Boolean = (hasFindText) AndAlso (e.ResultSet.Results.Count = 0)
        Dim notFoundMessage As String = (If(notFound, " (not found)", String.Empty))
        messagePanel.Content = "Incremental Search: " & e.ResultSet.Options.FindText & notFoundMessage
    End If
End Sub

Note Note
Incremental search also automatically sets a custom mouse cursor while it is active.

Trimming Unmatched Find Text

The SyntaxEditor.CanIncrementalSearchTrimUnmatchedFindText, which defaults to true, determines whether characters typed by the end user while incremental search is active will be appended to the find text in scenarios where the previous find text didn't match anything.

For instance, say incremental search mode is active and the end user types "int". This finds a match. Then the user types "e" but no match is found. At this point, if CanIncrementalSearchTrimUnmatchedFindText is true and another character like "g" is typed, it will be ignored and not appended to the find text. If the property is false instead, the "g" would be appended to the find text.

Disabling Incremental Search

Incremental search features are on by default and can be accessed by the end user via the Ctrl+I and Ctrl+Shift+I key bindings.

To prevent the end user from activating incremental search mode, remove the appropriate entries from the SyntaxEditor.InputBindings collection.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Search Result Highlighting

When performing searches, many modern editors actively display matching results as the user types the find text. SyntaxEditor supports the live highlighting of search results.

There are two common usage scenarios for search result highlighting: incremental searches and search panes.

This topic contains these sections:

  • Incremental Search Highlights
  • Search Pane Highlights
  • Requirements

Incremental Search Highlights

The Incremental Search features built into SyntaxEditor allow for an end user to quickly search for a string that they type. When the SyntaxEditor.IsSearchResultHighlightingEnabled property is set to true (the default), highlights will appear throughout the document showing all matches for the find text.

This allows the end user to immediately visualize where all matches occur instead of having to navigate through the incremental search matches one-by-one.

Search Pane Highlights

If your app has a search pane, it may wish to highlight search results live as the user types in the search pane's "find what" textbox, and prior to the user pressing the "Find" button.

If you are using the built-in search overlay pane, this will happen automatically. If you are using an external search pane (like an EditorSearchView), then the following manual process is required to update the highlights.

This can be achieved by setting an ISearchOptions instance to the IEditorView.HighlightedResultSearchOptions property. Every time that property is set or an option is updated, a worker task kicks off that does a find all operation in the document and then when complete, updates the search result highlights.

Set the property to a null value when the search pane closes, so that all highlights will be removed.

This code shows how highlights could be displayed over any text in the document with the words "highlight this text":

C#
VB
Copy
​EditorSearchOptions options = new EditorSearchOptions;
options.FindText = "highlight this text";
editor.ActiveView.HighlightedResultSearchOptions = options;
​Dim options As EditorSearchOptions = New EditorSearchOptions
options.FindText = "highlight this text"
editor.ActiveView.HighlightedResultSearchOptions = options

Note Note
Make sure that the ISearchOptions object passed in implements an Equals method override that examines each property in the options, since this is used for internal comparisons. The predefined EditorSearchOptions class does so.

Requirements
This code is required to be called once per application instance since it registers the classification types and related styles for the highlights. If it is not called, then the highlights might not display.
C#
VB
Copy
​new DisplayItemClassificationTypeProvider().RegisterAll();
​CType(New DisplayItemClassificationTypeProvider(), DisplayItemClassificationTypeProvider).RegisterAll()
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EditorSearchView Control

The EditorSearchView control is a standalone control that can be used within an application tool window to provide an user interface with Visual Studio-like search capabilities for a SyntaxEditor.

This topic contains these sections:

  • The EditorSearchView User Interface
  • Syncing Options
  • Attaching to a SyntaxEditor Instance
  • Handling Results

The EditorSearchView User Interface

The EditorSearchView control is designed to mimic the find/replace dialog found in Visual Studio. Since it is a regular WPF control, it can be included in any container. It works great when used with our Docking/MDI tool windows, as seen in the following screenshot:

The EditorSearchView control in Quick Replace mode

Search Modes

The control offers two search modes: Quick Find and Quick Replace. There is a built-in toolbar at the top of the control that allows the end user to toggle between modes.

Programmatically, the mode can be set via the IsReplaceVisible property. Set the property to true to show replace UI.

ToolBar Visibility

The modes toolbar is displayed by default. However the CanToggleReplace property can be set to false to hide it.

This is useful if you only wish to allow the end user to perform find opertions and not replace operations.

Find All Button Visibility

The Find All button is not displayed by default. The IsFindAllButtonVisible property can be set to true to show it.

This button should only be made visible if the find results will be displayed to the user from within a SyntaxEditor.ViewSearch event handler. A common way to do this is to display the results within a Find Results tool window.

Options Panel

The options panel can be expanded or collapsed. The IsOptionsPanelExpanded property determines the current expansion state of the panel.

Search Pattern Providers

The search type drop-down in the options panel allows the end user to select which search pattern provider to use. It is populated via a ISearchPatternProviderFactory, which is a factory interface that can create a collection of ISearchPatternProvider objects.

Any factory instance can be set to the SearchPatternProviderFactory property to change which pattern providers are available. By default, the DefaultSearchPatternProviderFactory is used.

If you create your own search pattern provider and would like to make it available for use within the EditorSearchView control, a custom ISearchPatternProviderFactory would be needed.

Smooth Animation

When switching modes or toggling the display of options, new controls reveal themselves via subtle animated transitions.

Animation can be disabled by setting the AnimationDuration property to 0.

Focusing the Find-What TextBox

The FocusFindWhatTextBox method can be called to "select all" in the find-what TextBox and focus it.

Syncing Options

The EditorSearchView.SearchOptions property accepts an IEditorSearchOptions instance. These options are what are used to populate the user interface of the control.

When the end user alters the "find what" text for instance, the control auto-updates the attached options. The options can be used with any search operation.

Note Note
The EditorSearchOptions class provides an implementation of the IEditorSearchOptions interface.

The default IEditorSearchOptions instance set to the SearchOptions property is a static instance from the EditorSearchOptions.Default property. This allows the search options to be shared amongst multiple SyntaxEditor controls out-of-the-box.

Attaching to a SyntaxEditor Instance

The EditorSearchView control must be attached to a SyntaxEditor control so that it knows which control to search.

This is done by setting a SyntaxEditor control instance to the EditorSearchView.SyntaxEditor property.

Handling Results

The SyntaxEditor.ViewSearch event fires whenever a search is made using EditorSearchView. The event arguments pass along the search options and the result set. That information can then be presented to the user in a Find Results tool window for example.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor includes some extremely powerful IntelliPrompt features that help enhance end user productivity. These features range from popup lists with text completion to popup tips that provide more information about what the end user it editing.

This topic contains these sections:

  • Sessions
  • Quick Info
  • Completion List
  • Parameter Info
  • Code Snippets
  • Content Providers
  • Image Source Providers
  • Navigable Symbol Selector

Sessions

An IntelliPrompt session is essentially a controller for a certain type of IntelliPrompt UI. Each type of IntelliPrompt UI (completion list, quick info, etc.) has a related session. The IntelliPrompt UI and functionality can be made activate by "opening" the related session.

See the Sessions topic for more information.

Quick Info

IntelliPrompt quick info displays helpful popup hints about what is under the mouse or next to the caret. Tip content can include any WPF control and it's easy to generate richly-formatted content using an HTML-like syntax.

See the Quick Info topic for more information.

Completion List

The IntelliPrompt completion list allows you create popups for displaying a list of options used to complete what the end user is typing. This is most used when editing programming languages. Features include ctrl+space support, description tips, multiple matching algorithms, matched text highlights, filters, and more.

See the Completion List topic for more information.

Parameter Info

IntelliPrompt parameter info displays helpful popup hints about an invocation that is being typed, and its parameters. Tip content can include any WPF control and it's easy to generate richly-formatted content using an HTML-like syntax.

See the Parameter Info topic for more information.

Code Snippets

IntelliPrompt code snippets provide a way to insert pre-defined fragments of text into the editor. Each code snippet can declare multiple fields of text, and when a code snippet template session is activated in SyntaxEditor, the text is inserted and the end user can tab between the fields to edit their values.

See the Code Snippets topic for more information.

Content Providers

Content providers are classes that provide content on demand to IntelliPrompt sessions that display popups. An example of their usage is providing content for quick info and completion item description tip popups.

See the Content Providers topic for more information.

Image Source Providers

Image source providers are classes that provide ImageSource objects on demand to IntelliPrompt sessions. An example of their usage is providing image sources for completion list items.

See the Image Source Providers topic for more information.

Navigable Symbol Selector

The NavigableSymbolSelector control displays two side-by-side drop-downs similar to the type/member drop-downs above the code editor in Visual Studio. One drop-down shows all available root symbols (generally types), and the other shows all available member symbols within the currently selected root symbol.

As the caret in a bound SyntaxEditor instance is moved, the selections in the NavigableSymbolSelector update to indicate the enclosing symbols (types/members). The end user can also select a different symbol from the drop-downs to navigate directly to the related symbol declaration.

See the Navigable Symbol Selector topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Sessions

An IntelliPrompt session is essentially a controller for a certain type of IntelliPrompt UI. Each type of IntelliPrompt UI (completion list, quick info, etc.) has a related session. The IntelliPrompt UI and functionality can be made activate by "opening" the related session.

This topic contains these sections:

  • Built-In Sessions
  • Provider Language Services for Built-In Sessions
  • Session Types
  • Opening and Closing Sessions
  • Session Information
  • Managing Sessions at Run-Time
  • Requesting Built-In IntelliPrompt Session Types

Built-In Sessions

IntelliPrompt functionality is active only while related sessions are open. For instance, a completion list is displayed only while its session is open.

SyntaxEditor includes several built-in IntelliPrompt sessions, however you can create your own as well.

These sessions are currently included:

  • Completion list
  • Quick info
  • Parameter info
  • Code snippets (selection / template)

Provider Language Services for Built-In Sessions

There are several provider interfaces that can be registered as language services. These providers make it very easy to respond to certain editor events and respond with the appropriate IntelliPrompt sessions.

These providers are currently included:

  • Completion provider
  • Quick info provider
  • Parameter info provider
  • Code snippet provider

Session Types

Each IntelliPrompt session must be associated with a specific session type. A session type is represented by the IIntelliPromptSessionType interface.

This interface requires that each type specify a unique string-based Key that identifies it. It also has an AreMultipleSessionsAllowed property that returns whether more than one session of that type are permitted at a time. If that property is false and a second session of the same types is added to the manager (see below), the first session will be removed.

The IntelliPromptSessionType class implements IIntelliPromptSessionType and can be used if you need to create your own session type.

Note Note
The IntelliPromptSessionTypes class has a number of static properties that return the most common IIntelliPromptSessionType instances such as session types for Quick Info, Completion List, etc.

Opening and Closing Sessions

When a session is "open", it is active within the user interface. The IIntelliPromptSession.IsOpen property indicates if a session is currently open.

A session can be opened by calling the Open method. This method accepts two parameters: the IEditorView in which the session should be opened and the TextRange in the view that is affected by the session. The text range is most often the selection range or the text range of the word surrounding the caret.

When a session opens, its Opened event fires.

Note Note
Some session implementations may add additional Open method overloads that should be used for that session implementation instead of the basic Open method.

A session can be closed by calling the Close method. This method accepts a Boolean parameter that indicates whether the session was cancelled or not.

When a session opens, its Closed event fires. The event arguments of this event specify whether the session was cancelled.

Session Information

Each IIntelliPromptSession contains these members that provide some useful information about the session:

Member | Description
SessionType Property | Gets the IIntelliPromptSessionType that identifies the type of session.
SnapshotRange Property | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. This member should only be used while the session is open.
View Property | Gets the IEditorView in which the session is opened. This member should only be used while the session is open.

Managing Sessions at Run-Time

The SyntaxEditor class has a IntelliPrompt property that is of type IIntelliPromptManager and provides access to all of the open sessions within the SyntaxEditor.

The Sessions collection lists all the open sessions and can be enumerated.

The CloseAllSessions method closes all open sessions, while the CloseSessions member only closes sessions of a particular IIntelliPromptSessionType.

Requesting Built-In IntelliPrompt Session Types

Sometimes you may wish to programmatically request that a certain type of IntelliPrompt session be opened, but you want the current set of IntelliPrompt providers (generally designated from language services) to decide if an IntelliPrompt session should open and what should be in it. An example scenario is if your language checks to see when the . key is pressed via an event sink service. When that event occurs, it raises a request to see if an IntelliPrompt completion session should open.

The IEditorView.IntelliPrompt object has methods for requesting built-in session types:

Member | Description
RequestAutoComplete Method | Performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset.
RequestCompletionSession Method | Displays a completion list if the language supports an IntelliPrompt completion session at the current offset.
RequestInsertSnippetSession Method | Displays IntelliPrompt 'expansion' code snippet selection at the current offset.
RequestParameterInfoSession Method | Displays IntelliPrompt parameter info based on the current context.
RequestQuickInfoSession Method | Displays IntelliPrompt quick info based on the current context.
RequestSurroundWithSession Method | Displays IntelliPrompt 'surrounds with' code snippet selection at the current offset.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Quick Info

IntelliPrompt quick info displays helpful popup hints about what is under the mouse or next to the caret. Tip content can include any WPF control and it's easy to generate richly-formatted content using an HTML-like syntax.

This topic contains these sections:

  • Creating and Opening a Session
  • Using Rich Formatting for Content
  • Handling Link Clicks
  • Maximum Width
  • Control Key Down Opacity
  • Automatic Quick Info for a Language (Initiated by Mouse Hovers, etc.)
  • Programmatically Requesting Quick Info
  • Built-In Quick Info Providers

Creating and Opening a Session

Creating and opening a quick info session is very easy. There are only a few simple steps to follow.

Creating a Session

The first step is to create a QuickInfoSession:

C#
VB
Copy
​QuickInfoSession session = new QuickInfoSession();
​Dim session As QuickInfoSession = New QuickInfoSession()

Setting the Content to Display

Next, the content that will be displayed must be specified. Since a ContentProvider is used behind the scenes, this could be any object. However it is recommended that you use a WPF UIElement or the output from one of the Content Providers.

This code uses the output from a PlainTextContentProvider as the content to display since it provides a word wrapping TextBlock containing a string:

C#
VB
Copy
​session.Content = new PlainTextContentProvider("Text here").GetContent();
​session.Content = New PlainTextContentProvider("Text here").GetContent()

Open the Session

The final step is to open the session:

C#
VB
Copy
​session.Open(editor.ActiveView, new TextRange(editor.Caret.Offset));
​session.Open(editor.ActiveView, New TextRange(editor.Caret.Offset))

The IQuickInfoSession interface defines an Open method overload that can display the popup against a particular target and location.

For most cases, once the session is opened, the built-in functionality handles all the rest for you, such as when to dismiss the popup.

Using Rich Formatting for Content

As mentioned above, the built-in content providers are a great way to easily populate quick info content. The HtmlContentProvider in particular is nice since it uses a mini-HTML markup to style the text content.

It is highly recommended to make use of the HtmlContentProvider and all of its features that are described in detail in the Content Providers topic.

Handling Link Clicks

When links are present in quick info tip content, the IQuickInfoSession.RequestNavigate event will fire if a link is clicked, requesting that you take some action.

Maximum Width

The IQuickInfoSession.MaxWidth property can be set to specify a maximum width for the popup.

Control Key Down Opacity

The quick info popup animates to be semi-transparent when the Ctrl key is held down, thereby allowing the end user to see the text behind it. The IQuickInfoSession.ControlKeyDownOpacity property specifies the opacity when the popup is semi-transparent.

Set this property to 1.0 to prevent the list from being semi-transparent.

Automatic Quick Info for a Language (Initiated by Mouse Hovers, etc.)

Syntax languages are fully capable of listening for mouse hovers and opening a quick info session in response to hovers over various tokens, or even any other part of the editor.

The IntelliPrompt Quick Info Provider topic describes a special language service that can be implemented to respond to mouse hovers and show a quick info popup.

Programmatically Requesting Quick Info

Sometimes it is desirable to programmatically request that quick info be displayed if the editor caret is in a location at which the language is capable of displaying quick info.

The IEditorView.IntelliPrompt.RequestQuickInfoSession method can be called to request quick info display, if the current language allows it.

Built-In Quick Info Providers

There are built in Quick Info providers for collapsed node text (used with outlining) and squiggle tags.

When using the code outlining features, sometimes the end user will collapse outlining nodes. By default, nothing happens when the mouse is hovered over a collapsed outlining node adornment (normally a box with "..." in it). The built-in IQuickInfoProvider implementation called CollapsedRegionQuickInfoProvider watches for mouse hovers over collapsed regions and will automatically show a quick info tip with the contained content on mouse hovers.

When using the parsing framework and the ParseErrorTagger (or other custom tagger that uses SquiggleTag tags), there will be squiggle adornments in the document window. By default, nothing happens when the mouse is hovered over these adornments. However, there is a built-in IQuickInfoProvider implementation called SquiggleTagQuickInfoProvider that watches for mouse hovers over squiggle adorned regions and will automatically show a quick info tip with the parse error description on mouse hovers.

For additional information on these built-in Quick Info providers, visit the IntelliPrompt Quick Info Provider topic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Completion List

The IntelliPrompt completion list allows you create popups for displaying a list of options used to complete what the end user is typing. This is most used when editing programming languages. Features include ctrl+space support, description tips, multiple matching algorithms, matched text highlights, filters, and more.

As the end user types in the editor, the selected item in the completion list is updated to reflect the item that most closely matches what has been typed. The end user can press Tab or Enter to insert the complete text associated with the item. This immensely helps increase the productivity of end users while typing.

This topic contains these sections:

  • Run-Time Functionality
  • Creating and Opening a Session
  • Opening a Session in Response to a Typed Character ('.', '<', etc.)
  • Having a Language Open a Session in Response to a Typed Character or Ctrl+Space
  • Completion List Items (Images, Text, etc.)
  • Sorting Items
  • Text Insertion
  • Commit and Cancel
  • Auto-Commit Without Showing a Popup (Complete Word)
  • Description Tips
  • Getting the Selection
  • Allowed and Commit Characters
  • Built-In Matching Algorithms
  • Matched Text Highlights
  • Custom Matching Algorithms
  • Case Sensitivity
  • Match Target Text
  • Requiring an Exact Match
  • Filters
  • Filtering via Buttons/Tabs
  • Filtering Unmatched Items (Auto-Shrink)
  • Custom Actions for an Item Selection (Opening a Dialog, etc.)
  • Control Key Down Opacity

Run-Time Functionality

The completion list bases itself on a text range that is passed in when it is opened. While open a list of items is displayed. Arrow keys and the mouse can be used to scroll through the list. As the end user types, the selected item in the list is changed to best fit the typed text based on various matching algorithms.

Optional filters can be toggled by the end user via buttons and tabs to narrow down the list of displayed items.

The pressing and holding of the Ctrl key animates the list to be semi-transparent so that the end user can see the text under the list.

When the Tab key is pressed, the completion list is closed and the selected item's text is auto-inserted into the document. The Esc key can be used to cancel the completion list and close it without inserting any text.

Creating and Opening a Session

Creating and opening a completion list session is very easy. There are only a few simple steps to follow.

Creating a Session

The first step is to create a CompletionSession:

C#
VB
Copy
​CompletionSession session = new CompletionSession();
​Dim session As CompletionSession = New CompletionSession()

Configure Options

Next, configure any options that should be set on the session such as whether to allow complete word functionality, set up filters, etc.:

C#
VB
Copy
​session.CanCommitWithoutPopup = true;  // Allow complete word
​session.CanCommitWithoutPopup = True  ' Allow complete word

Add Items

The next step is to populate the list with all the items that should be included. Items (described in more detail below) must implement ICompletionItem. The CompletionItem class implements this interface and makes it easy to add items.

This code adds a single item for a Boolean native type:

C#
VB
Copy
​session.Items.Add(new CompletionItem("bool",
    new CommonImageSourceProvider(CommonImageKind.StructurePublic),
    new CustomContentProvider(typeof(bool))));
​session.Items.Add(New CompletionItem("Boolean", _
    New CommonImageSourceProvider(CommonImageKind.StructurePublic), _
    New CustomContentProvider(GetType(Boolean))))

Open the Session

The final step is to open the session:

C#
VB
Copy
​session.Open(editor.ActiveView);
​session.Open(editor.ActiveView)

The ICompletionSession interface defines an Open method overload that just takes the IEditorView in which to display. This overload automatically determines the text range with which to initialize the completion list for you. Therefore if the caret is at the end of a partial word when the completion list is opened, the partial word's text will be used to initialize the selection in the completion list.

For most cases, once the session is opened, the built-in functionality handles all the rest for you, including auto-complete of selected items when appropriate.

Opening a Session in Response to a Typed Character ('.', '<', etc.)

Completion lists are often opened in response to a typed character by the end user. For instance, in C# or VB, pressing the . (dot) character generally opens a completion list for the object represented by the text before the dot. In HTML a < character displays a completion list for available tags. Some languages also automatically show a completion list when a letter is typed that starts a new word.

Watching Typed Characters

The SyntaxEditor.DocumentTextChanged event is the best place to watch for specific characters being typed. Its event args, EditorSnapshotChangedEventArgs, has a special helper property called TypedText that is normally a null value but is filled in only when the text change is TextChangeTypes.Typing, and there is a single insert operation in the change.

If your app allows two or more SyntaxEditor controls to operate on the same document, then all of the samples below should be wrapped with a check to ensure that the view in which the text change occurred is the same editor's view in which the completion session will be requested:

C#
VB
Copy
​if (e.TextChange.Source == editor.ActiveView) {
    ...
}
​If (e.TextChange.Source Is editor.ActiveView) Then
    ...
End If

Sample: Showing an HTML Tag List

In this scenario, assume we have an HTML language loaded and wish to show a completion list in response to < characters being typed. Here is sample code for a DocumentTextChanged event handler to do this:

C#
VB
Copy
​switch (e.TypedText) {
    case "<":
        // Open completion list session for HTML tags here
        break;
}
​Select Case e.TypedText
    Case "<"
        ' Open completion list session for HTML tags here
End Select

Sample: Showing a C# Object Member List

In this scenario, assume we have a C# language loaded and wish to show a completion list in response to . characters being typed after the keyword this. Here is sample code for a DocumentTextChanged event handler to do this:

C#
VB
Copy
​switch (e.TypedText) {
    case ".": {
        // Use a snapshot reader to iterate backwards through the active view's current text
        ITextSnapshotReader reader = editor.ActiveView.GetReader();
        reader.ReadCharacterReverseThrough('.');
        IToken token = reader.ReadTokenReverse();

        // In production code, a token ID comparison would be better than this string comparison
        if ((token != null) && (reader.TokenText == "this")) {
            // A dot was typed after a "this" keyword so open the completion list session here
        }
        break;
    }
}
​Select Case e.TypedText
    Case "."
        ' Use a snapshot reader to iterate backwards through the active view's current text
        Dim reader As ITextSnapshotReader = editor.ActiveView.GetReader()
        reader.ReadCharacterReverseThrough("."c)
        Dim token As IToken = reader.ReadTokenReverse()

        ' In production code, a token ID comparison would be better than this string comparison
        If ((token IsNot Nothing) AndAlso (reader.TokenText = "this")) Then
            ' A dot was typed after a "this" keyword so open the completion list session here
        End If
End Select

Note that in this sample, we used an ITextSnapshotReader to scan backwards past the dot and to the token before it. We then did a text compare with the token to see if its text was this. If your language has token IDs available, it's better to do a token ID comparison here instead of a string comparison. Also while scanning back, you may wish to skip over whitespace tokens. If all that criteria was met, the completion list session was opened.

Sample: Showing a Completion List Automatically When a New Word Is Started

In this scenario, we wish to show a completion list whenever a letter is typed by the end user that is starting a new word. This prevents the end user from having to do a Ctrl+Space to initiate a completion session.

Here is sample code for a DocumentTextChanged event handler to do this:

C#
VB
Copy
​// If the text that was typed is a letter character that is starting a word...
if (e.IsTypedWordStart) {
    // If no completion session is currently open, show a completion list
    if (!editor.IntelliPrompt.Sessions.Contains(IntelliPromptSessionTypes.Completion)) {
        // Open the completion list session here
    }
}
​' If the text that was typed is a letter character that is starting a word...
If e.IsTypedWordStart Then
    ' If no completion session is currently open, show a completion list
    If Not editor.IntelliPrompt.Sessions.Contains(IntelliPromptSessionTypes.Completion) Then
        ' Open the completion list session here
    End If
End If

Having a Language Open a Session in Response to a Typed Character or Ctrl+Space

Syntax languages are fully capable of listening to typed characters like above and opening a completion list session in response. To do this, they can use the event sinks mechanism that allows them to be notified of text changes.

The IntelliPrompt Completion Provider topic describes a special language service that can be implemented to respond to Ctrl+Space and show a completion list.

When a completion provider service is registered for a language, the IEditorView.IntelliPrompt.RequestAutoComplete and RequestCompletionSession methods can be called to request auto-complete or completion list display respectively. In that case if the completion provider determines that completion can occur at the current editor caret position, IntelliPrompt action will be taken.

As an example, if a syntax language has an event sink registered that watches for the . key to be typed, it may wish to request that a completion session be opened if appropriate. In that case the event sink handler should call RequestCompletionSession and if a completion provider is available to handle the request, a completion list will display.

Completion List Items (Images, Text, etc.)

All completion list items implement the ICompletionItem interface, which is realized by the CompletionItem class.

The interface has several members on it:

Member | Description
AutoCompletePostText Property | Gets or sets the text that is inserted into the document after the caret when auto-complete is executed.
AutoCompletePreText Property | Gets or sets the text that is inserted into the document before the caret when auto-complete is executed.
DescriptionProvider Property

Gets an IContentProvider that can provide content for a popup displaying a verbose description of the item.

Note Note
See the Content Providers topic for details on the IContentProvider interface and the available built-in implementations.

ImageSourceProvider Property

Gets an IImageSourceProvider that can provide an ImageSource for display within a list.

Note Note
See the Image Source Providers topic for details on the IImageSourceProvider interface and the available built-in implementations.

Tag Property | Gets or sets the object that contains user-defined data about the object.
Text Property | Gets the text for the item that is displayed within a list.

Sorting Items

The items in the completion session should always be sorted so that proper selection matching occurs at run-time as the end user types. You can choose to pre-sort the items yourself before you add them to the Items collection.

Alternatively, you can call the SortItems method right before opening the session to ensure they are properly sorted. This allows you to add items in any order while building the list. A SortItems overload allows a custom comparer to be specified in the event that custom sort logic is required.

Text Insertion

Normally the text displayed in the completion list for an item is the same text that is inserted. That is what happens by default.

However SyntaxEditor has the ability to insert alternate text both before and after the caret. Several variations are shown in the following sections.

Displayed text inserted before the caret

When using the CompletionItem constructor that just takes the text (no auto-complete pre or post text), the text you pass in is displayed in the list and is also what is inserted on auto-complete. So in essence, that constructor fills in AutoCompletePreText with the text value as well.

Alternate text inserted before the caret

Many times the displayed Text is not what should be inserted.

A br tag before and after it is inserted from the completion list

In the screenshot above, a br should be displayed but <br/> should be inserted before the caret. To accomplish this, Text is set to br, AutoCompletePreText is set to <br/>, and AutoCompletePostText is set to a null reference.

Alternate text inserted to surround the caret

Sometimes auto-completes need to surround the caret with text.

An HTML comment before and after it is inserted from the completion list

In the screenshot above, a !-- should be displayed but <!-- --> should surround the caret on auto-complete. To accomplish this, Text is set to !--, AutoCompletePreText is set to <!--, and AutoCompletePostText is set to -->.

Commit and Cancel

When the completion list is committed, auto-complete is performed on whichever item is selected. If the completion list is cancelled, auto-complete is not performed and no text is changed in the document.

The completion list can be programmatically committed by calling the Commit method. Likewise, it can be cancelled by calling the Cancel method.

If committed, two events fire: Committing, then Committed. The first event allows you to set the Cancel property of the event args to cancel auto-complete.

The Tab key commits the selected item at run-time and is consumed. The Enter key commits and is normally consumed as well unless the IsEnterKeyHandledOnCommit property is set to false.

Auto-Commit Without Showing a Popup (Complete Word)

There generally are two modes in which to display a completion list. Ctrl+Space keypresses typically activate a "complete word" mode where if the text range with which the list was initialized is capable of fully selecting an item in the list, the list item is auto-completed and the list is never displayed. If no exact match is made, the list displays and operates like normal. The default mode is to have the list display regardless of whether it can initially match an item.

To enable "complete word" functionality, set the ICompletionSession.CanCommitWithoutPopup property to true.

Description Tips

Description tips, which are essentially quick info tips, are displayed when an item is selected within the completion list. They are optional but can provide some extensive information about the selected item to the end user.

Description tip content is specified on each item via the ICompletionItem.DescriptionProvider property. Since this is a property, the info is pulled-on demand, thereby using less memory in most cases.

Note Note
See the Content Providers topic for details on the IContentProvider interface and the available built-in implementations.

When links are present in description tip content, the ICompletionSession.RequestNavigate event will fire if a link is clicked, requesting that you take some action.

The ICompletionSession.DescriptionTipMaxWidth property can be set to specify a maximum width for the description tip.

The ICompletionSession.DescriptionTipShowDelay accepts a TimeSpan value that indicates the delay length between when a completion item is selected and when its related description tip is displayed. The default value is 400ms.

Getting the Selection

The ICompletionSession.Selection property indicates the current selection of the list. Its value is of type CompletionSelection, which indicates the ICompletionItem that is selected and its selection state (full or partial). If there is no selection then that property returns a null reference.

When the selection changes, the SelectionChanged event fires.

Allowed and Commit Characters

By default, only letters, digits, and underscores are allowed characters. If you type any other character while a completion list is open, it will either auto-complete or cancel depending on whether you have a full selection in the list and if the character is a commit character.

Since sometimes other characters such as ! need to be allowed characters, the completion list session provides the ICompletionSession.AllowedCharacters collection. By adding characters to this collection, they will be allowed to be typed without the session being cancelled.

All letter and digit characters are automatically allowed by the completion popup and therefore do not need to added to this collection.

The ICompletionSession.CommitCharacters property defaults to contain all characters. This means that if a typed character is not an allowed character, it will auto-complete the session if there is a full selection in the list. If you wish to limit the characters that can auto-complete the session, set a new character collection to this property with the appropriate characters.

Built-In Matching Algorithms

Matching algorithms are what are used to select an item in the completion list as you type in the editor. SyntaxEditor includes numerous built-in matching algorithms, each used in a priority order.

Default Matching Algorithm

Normal completion lists match with an algorithm in which the typed characters are compared against the start of each item. This default algorithm has the highest priority when attempting to match items.

If no match is made, the next active algorithm is used.

Acronym Matching Algorithm

Next in priority is an optional algorithm in which the first and every uppercase letter is examined for a match. For words that contain underscores, the first and every character following an underscore are examined for a match instead.

This algorithm is only active if the ICompletionSession.MatchOptions flags property has the CompletionMatchOptions.UseAcronyms flag specified.

If no match is made, the next active algorithm is used.

Shorthand Matching Algorithm

Next in priority is another optional algorithm in which the supplied text provides a wildcard sort of pattern. A match is made if all the characters appear somewhere in the item text. Shorthand provides the most flexibility since it allows substring matches anywhere in the items.

This algorithm is only active if the ICompletionSession.MatchOptions flags property has the CompletionMatchOptions.UseShorthand flag specified.

If no match is made, the next active algorithm is used.

Fallback Partial Matching Algorithm

Finally if no match as been made yet, a partial match can be made at the item that starts with text closest to the typed text.

Matched Text Highlights

As described above, the completion list auto-selects the closest matched item in the list as you type. However another sort of useful visualization is to be able to see how typed text matches against other items as well. Matched text highlights highlight the text in each appropriate item that matches what has been typed by the end user.

Just like with normal auto-selection, SyntaxEditor cycles through the prioritized list of item matching algorithms and uses the first one that matches an item to show highlights indicating where matches were made.

This feature is on by default but can be turned off via the ICompletionSession.CanHighlightMatchedText property.

Custom Matching Algorithms

SyntaxEditor includes the built-in matching algorithms described above. However it's very easy to add custom matching algorithms as well. Matching algorithms as implementations of the ICompletionItemMatcher interface.

The RegexCompletionItemMatcherBase class is the best class to inherit when making a custom matching algorithm. When you inherit that class, all you need to do is override the GetRegex method to return a standard .NET Regex (from the System.Text.RegularExpressions namespace) and override the Key property to return a string-based key that identifies the matcher. The Regex is used to both identify matches and can even perform matched text highlights (see previous section).

A Regex Sample

In this sample implementation of the GetRegex method we'll return a Regex that matches text that appears after any . or _ character:

C#
VB
Copy
​return new Regex(String.Format("[\\._]({0})", Regex.Escape(text)),
    RegexOptions.IgnoreCase | RegexOptions.Singleline);
​Return New Regex(String.Format("[\._]({0})", Regex.Escape(text)), _
    RegexOptions.IgnoreCase | RegexOptions.Singleline)

Note Note
The actual matched text portion(s) in the regular expression pattern should always be surrounded by parenthesis. In the example above, {0} is surrounded by parenthesis. This allows the matched text highlights to work automatically based on your regular expression pattern.

Adding the Custom Item Matcher to the Session

All the item matchers for a session are listed in the ICompletionSession.ItemMatchers collection. By default this collection contains all the built-in matchers although some (like Acroynm) may not be active if its match option is not specified (see above).

To enable a custom item matcher to be used in a session, it must be added to the ItemMatchers collection too. Item matchers are executed in order until one succeeds. The default "starts-with" item matcher should nearly always be used first so it's best to insert your custom item matcher at index 1.

This code installs a CustomCompletionItemMatcher after the "starts-with" matcher:

C#
VB
Copy
​session.ItemMatchers.Insert(1, new CustomCompletionItemMatcher());
​session.ItemMatchers.Insert(1, new CustomCompletionItemMatcher())

Case Sensitivity

By default, matching is done such that matches that actually match the case of the typed text are returned first. If none are found, an insensitive match is returned instead.

This default can be disabled so that insensitive matches are always used by ensuring the ICompletionSession.MatchOptions flags property has the CompletionMatchOptions.IsCaseInsensitive flag specified.

Match Target Text

Completion list items each have display text and text that is actually inserted into the document. By default the text that will be inserted into the document is matched against. However you can change it to match against the display text if you prefer.

Note Note
In most cases, the display text and text to insert actually are the same thing.

Matching can be made to target the display text by ensuring the ICompletionSession.MatchOptions flags property has the CompletionMatchOptions.TargetsDisplayText flag specified.

Requiring an Exact Match

Normally completion list items are fully selected as long as the matched item's text starts with the typed text. However there are scenarios where you may wish for matching to be less aggressive, and to only make full selections if the typed text exactly matches the item's text.

In these scenarios, the ICompletionSession.MatchOptions flags property should have the CompletionMatchOptions.RequiresExact flag specified.

Filters

Completion list filtering is a feature that allows the presented items in the list to be filtered down. This is most useful when you potentially have hundreds of items in a completion list and want the ability for the end user to narrow down the items that are displayed.

SyntaxEditor for WPF contains a feature-rich model for supporting filtering, and even makes it easy to add custom buttons and tabs to support filter toggling by the end user.

Filters are designed with the expectation such that each language developer using the extensible filter object model can make customized filters for each language and in some cases, context within a language. For instance, a completion list for namespaces should have different filters than a type member completion list.

Completion filters are implementations of the ICompletionFilter interface. This interface has a string-based Key that identifies the filter, a boolean IsActive property that indicates if the filter is currently active, and a Filter method that does the actual filtering work.

The CompletionFilter class is a nice implementation of the ICompletionFilter that provides extended functionality for automatically supporting buttons and tabs as described in the next section.

When using the CompletionFilter class, its constructor takes the string-based key that identifies it, and a CompletionFilterPredicate. This predicate is simply a delegate that returns whether the specified item should be excluded from the available completion items. The delegate is passed the ICompletionSession and the ICompletionItem to examine. It returns a CompletionFilterResult indicating if the item should be included or excluded from the available completion items.

A filter is added to a completion session via the ICompletionSession.Filters property. This property is a collection of the available filters, not all of which may be active. If a filter is inactive (even if it is in the collection), it will not be used.

Filtering via Buttons/Tabs

The CompletionFilter class, when used for filtering, provides some extensive functionality to adding buttons and tabs to the completion list user interface.

The CompletionFilter.DisplayMode is the property that governs how the filter is displayed in UI. It is an enumeration of type CompletionFilterDisplayMode, which has None, ToggleButton, Tab, and AllTab options. When the value is None, the default, no user interface is created for the filter.

Buttons and Button Groups

One option for filter UI is the creation of a toggle button. If the toggle button is checked, the filter becomes active and is applied. Leaving all toggle buttons unchecked will not apply any filters.

A completion list where several filter buttons have been auto-generated for the UI

In the screenshots above, the left completion list shows the default unfiltered view. In the right completion list, the inherited filter has been activated, thereby excluding all inherited members from the list.

A filter can be displayed in the UI as a toggle butten when its DisplayMode is set to ToggleButton.

In this display mode, the Content property gets or sets the content to display in the generated user interface control for the filter, which is generally an Image or String.

The ToolTip property sets the content to display in a tooltip for the button.

Groups of buttons can be displayed by placing filters that should be grouped visually in sequence and having their GroupName property value match. In the screenshots above, the first three filters have the same group name and the last filter has a different group name. Thus a separator line is drawn between them.

Tabs

Tabs are another sort of UI that can be generated for filters. With tabs, the related filter is applied only when the tab is selected. There is a special “All” tab that can be added that deactivates any filters that are applied by tabs.

A completion list that shows two filter tabs

A filter can be displayed in the UI as a tab when its DisplayMode is set to Tab or AllTab. When set to Tab, the filter is only applied when it is selected. AllTab is special because it will unapply any other Tab filters. Only one AllTab filter can be added at a time.

The Content property gets or sets the content to display in the generated user interface control for the filter, which is generally a String.

Combining buttons and tabs

Button and tab filters can be used at the same time. There is no problem with implementing things this way.

Filtering Unmatched Items (Auto-Shrink)

There is a handy option that can automatically filter out and hide items from the completion list that don't match the text that has been typed by the end user. This feature is seen when editing Visual Basic files in Visual Studio and using completion lists there. It is a helpful feature since it allows the end user to focus on items that match the text they've typed and it continuously updates the visible items in the completion list as text is modified.

Filtering unmatched items is disabled by default, meaning all unmatched items remain visible. To enable this feature, set the ICompletionSession.CanFilterUnmatchedItems property is set to true.

Custom Actions for an Item Selection (Opening a Dialog, etc.)

Sometimes it is useful to have "special" completion list items that when selected, don't auto-complete and insert text, but rather perform some other custom action. An example is opening a dialog in response to selecting an item.

The way to accomplish this is to first place some sort of way to identify the special item in its ICompletionItem.Tag property.

Then attach to the ICompletionSession.Committing event. In that handler examine the selected item, if any, and look to see if it is a special item. If it is, set e.Cancel to true. This will prevent auto-complete from occurring. Finally, show your dialog.

Control Key Down Opacity

The completion list animates to be semi-transparent when the Ctrl key is held down, thereby allowing the end user to see the text behind it. The ICompletionSession.ControlKeyDownOpacity property specifies the opacity when the list is semi-transparent.

Set this property to 1.0 to prevent the list from being semi-transparent.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parameter Info

IntelliPrompt parameter info displays helpful popup hints about an invocation that is being typed, and its parameters. Tip content can include any WPF control and it's easy to generate richly-formatted content using an HTML-like syntax.

This topic contains these sections:

  • Creating and Opening a Session
  • Managing Parameter Info Sessions
  • Using Rich Formatting for Content
  • Bolding the Current Parameter
  • Handling Link Clicks
  • Maximum Width
  • Arrow Key Selection
  • Programmatically Requesting Parameter Info

Creating and Opening a Session

Creating and opening a parameter info session is very easy. There are only a few simple steps to follow.

Creating a Session

The first step is to create a ParameterInfoSession:

C#
VB
Copy
​ParameterInfoSession session = new ParameterInfoSession();
​Dim session As ParameterInfoSession = New ParameterInfoSession()

Setting the Content to Display

Next, the content that will be displayed must be specified. Parameter info can display one or more overloads of an invocation. When multiple overloads are specified, built-in UI is added to show up and down arrows for switching the selected overload.

Each item in the parameter info is an ISignatureItem instance, that are implemented by the SignatureItem class. This interface consists of a Content Providers and an optional data object.

This code adds a couple method overloads using a PlainTextContentProvider for the displayed content of each item:

C#
VB
Copy
​session.Items.Add(new SignatureItem(new PlainTextContentProvider("void Foo()"));
session.Items.Add(new SignatureItem(new PlainTextContentProvider("void Foo(int a)"));
​session.Items.Add(new SignatureItem(New PlainTextContentProvider("void Foo()"))
session.Items.Add(new SignatureItem(New PlainTextContentProvider("void Foo(int a)"))

Open the Session

The final step is to open the session:

C#
VB
Copy
​session.Open(editor.ActiveView, new TextRange(editor.Caret.Offset));
​session.Open(editor.ActiveView, New TextRange(editor.Caret.Offset))

The above code is simplistic and will display a parameter info session however there is more code required for managing a session and knowing when to switch to a new session (in cases where the caret moves into a nested invocation), supporting the bolding of the current parameter, etc. These concepts are described further below.

Managing Parameter Info Sessions

While it's easy to create and display a parameter info session, there is some more advanced work needed to actually manage the session so that you know when it should be altered (such as bolding a new parameter) or closed. The management of the session is performed by its calling parameter info provider.

See the Parameter Info Provider topic for details on how to manage a parameter info session.

Using Rich Formatting for Content

As mentioned above, the built-in content providers are a great way to easily populate quick info content. The HtmlContentProvider in particular is nice since it uses a mini-HTML markup to style the text content.

It is highly recommended to make use of the HtmlContentProvider and all of its features that are described in detail in the Content Providers topic.

Bolding the Current Parameter

When implementing a content provider for an ISignatureItem, an IParameterizedContentProvider interface can be implemented on the IContentProvider to add support for the designation of the current parameter.

The IParameterizedContentProvider interface defines a ParameterIndex property that is a nullable integer, indicating the current parameter index, if known. The content provider implementation can examine that property and provide some method of focusing the end user's attention on it, such as bolding the parameter name if a HtmlContentProvider is used behind the scenes.

The parameter index can be set by code described in the Managing Parameter Info Sessions topic above.

Handling Link Clicks

When links are present in quick info tip content, the IParameterInfoSession.RequestNavigate event will fire if a link is clicked, requesting that you take some action.

Maximum Width

The IParameterInfoSession.MaxWidth property can be set to specify a maximum width for the popup.

Arrow Key Selection

When two or more signatures are displayed in a parameter info tip, arrow buttons appear in the tip's UI that allow for toggling between which one is selected. The IParameterInfoSession.IsArrowKeySelectionEnabled property determines whether the up and down arrow keys also can toggle between the selected signature.

Programmatically Requesting Parameter Info

Sometimes it is desirable to programmatically request that parameter info be displayed if the editor caret is in a location at which the language is capable of displaying parameter info.

The IEditorView.IntelliPrompt.RequestParameterInfoSession method can be called to request quick info display, if the current language allows it.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Snippets

IntelliPrompt code snippets provide a way to insert pre-defined fragments of text into the editor. Each code snippet can declare multiple fields of text, and when a code snippet template session is activated in SyntaxEditor, the text is inserted and the end user can tab between the fields to edit their values.

Multiple fields can be declared with the same ID. In this scenario, only one of the fields with that ID in a template session will be editable. When that field's value is changed by the end user, the dependent fields (the other non-editable fields with the same ID) will have their value updated as well. This improves end user typing efficiency.

The XML code snippet file format used is the same as Visual Studio's. This allows for any Visual Studio compatible code snippet to be used in SyntaxEditor.

This topic contains these sections:

  • Opening Selection Sessions
  • Opening Template Sessions
  • Template Sessions at Run-Time
  • Template Session Event Sink
  • Code Snippets
  • Code Snippet Serialization
  • Code Snippet Folders and Metadata
  • Loading a Code Snippet Folder
  • Code Snippet Providers
  • Customizing Code Snippet Providers
  • Code Snippets in Completion Lists

Opening Selection Sessions

Functionality is included that displays a helpful popup where the end user can type the title of an accessible code snippet to activate it. A completion list that shows the code snippets and child folders at the current folder level is also displayed below the popup and fully supports partial matches and Tab-based selection. The code snippets used to populate the selection session come from the ICodeSnippetProvider language service.

When a folder is selected in the completion list, the scope of the selection popup changes to that folder and the user can access the code snippets and child folders within it. Pressing Backspace or clicking the parent folder's link, backs up to the parent folder level.

Programmatic Session Creation

A code snippet selection session can be opened via two different method calls. Both require that a ICodeSnippetProvider language service is registered on the language. One displays the code snippets that are designated as 'expansion' types and the other displays those designated as 'surrounds with' types:

C#
VB
Copy
​editor.ActiveView.IntelliPrompt.RequestInsertSnippetSession();  // Show 'expansion' code snippets
// editor.ActiveView.IntelliPrompt.RequestSurroundWithSession();  // Show 'surrounds with' code snippets
​editor.ActiveView.IntelliPrompt.RequestInsertSnippetSession()  ' Show 'expansion' code snippets
' editor.ActiveView.IntelliPrompt.RequestSurroundWithSession()  ' Show 'surrounds with' code snippets

Both of these helper methods wrap a call to the ICodeSnippetProvider.RequestSelectionSession method.

Opening Template Sessions

Code snippets are generally inserted into SyntaxEditor and activated into a template session by one of these methods:

  • Selection made via a selection session.
  • End user types a code snippet's registered shortcut (defined in the source XML file) into SyntaxEditor and presses the Tab key.
  • Programmatic template session creation.

Pressing Tab After a Code Snippet Shortcut

Each code snippet has a shortcut that can be typed into the editor. When the Tab key is pressed after the shortcut, an ICodeSnippetProvider language service will look at the word before the caret to see if it matches any registered code snippets. If a match is found, the shortcut text is removed from the document, and a code snippet template session is opened.

This mechanism depends on a ICodeSnippetProvider service being registered on the current language. Please see the sections below for more information on code snippet providers.

Programmatic Session Creation

Assuming that an ICodeSnippet has been loaded into the snippet variable via some means, a session can be programmatically opened like this:

C#
VB
Copy
​CodeSnippetTemplateSession session = new CodeSnippetTemplateSession();
session.CodeSnippet = snippet;
session.Open(editor.ActiveView);
​Dim session As New CodeSnippetTemplateSession()
session.CodeSnippet = snippet
session.Open(editor.ActiveView)

Template Sessions at Run-Time

When a template session is opened, the code snippet's text is inserted into the document. Some code snippets indicate a location within their text where the current view's selected text should be inserted. In this scenario, the selected text prior to the session being opened is appropriately indented and injected within the code snippet text.

If one or more fields were declared in the code snippet, then fields will display in the editor. Fields are highlighted replacement regions that represent the regions of text that need to be edited to complete the code snippet. While the caret is in a field, the Tab key can be used to navigate to the next field. Likewise, Shift+Tab navigates to the previous field.

Editable fields are drawn with a background behind them. Sometimes a field refers to a declaration that is used in multiple places within the code snippet. In that case, only the first field is designated as editable. When its value changes, the other fields that are dependent upon it automatically update. The dependent fields are drawn with a dotted line around them.

Once all the fields have been updated, pressing Enter while in a field completes the code snippet and closes the session. At this point, if the code snippet designated a target offset for the caret to end up at, the caret will move to that offset.

Template Session Event Sink

Any object that implements the ICodeSnippetTemplateSessionEventSink interface can be registered on a language to handle events related to code snippet template sessions.

These methods on the event sink receive the event notifications:

Member | Description
NotifyDeclarationActivated Method | Notifies when a new declaration in the session's code snippet is activated.
NotifyDeclarationDeactivated Method | Notifies when a declaration in the session's code snippet is deactivated.
NotifyDeclarationTextChanged Method | Notifies when the text value of the active declaration in the session's code snippet is changed.
NotifySessionClosed Method | Notifies when a session is closed.
NotifySessionOpened Method | Notifies when a session is opened.

See the Event Sinks topic for more information on event sinks in general.

Code Snippets

Code snippets are represented by the ICodeSnippet interface.

Here are the important members of the CodeSnippet class, which implements ICodeSnippet:

Member | Description
Author Property | Gets or sets the name of the code snippet author.
CodeDelimiter Property | Gets or sets the character used to describe literals and objects in the code.
CodeKind Property | Gets or sets a CodeSnippetKind indicating the kind of code contained by the snippet.
CodeLanguage Property | Gets or sets the language in which the snippet's code is written.
CodeText Property | Gets or sets the code that is inserted when the code snippet is activated.
Declarations Property | Gets the collection of declarations.
Description Property | Gets or sets descriptive information about the code snippet contents.
HelpUrl Property | Gets or sets a URL that provides more information about the code snippet.
ImportedNamespaces Property | Gets the collection of imported namespaces.
Keywords Property | Gets the collection of keywords that describe the code snippet.
References Property | Gets the collection of assembly references.
Shortcut Property | Gets or sets the shortcut text used to insert the code snippet.
SnippetTypes Property | Gets the types of actions that can be performed by the code snippet.
Tag Property | Gets or sets the object that contains user-defined data about the object.
Title Property | Gets or sets the code snippet title.

Code Snippet Serialization

ICodeSnippet objects can be saved to and loaded from an XML format via the use of a CodeSnippetSerializer. In fact, it's the same XML format that Visual Studio uses to store code snippet data. That means that any code snippets created for Visual Studio can be used directly within SyntaxEditor as well.

Please see the Visual Studio documentation for more information on the XML schema for code snippet files.

Loading a Code Snippet

Code snippets can be loaded from a Stream via the CodeSnippetSerializer.LoadFromStream method. They can be loaded from a file via the CodeSnippetSerializer.LoadFromFile method.

The return value is an enumerable of ICodeSnippet objects, since each code snippet file can contain more than one code snippet per Microsoft's specifications.

Saving a Code Snippet

Code snippets can be saved to a Stream via the CodeSnippetSerializer.SaveToStream method. They can be saved to a file via the CodeSnippetSerializer.SaveToFile method.

A parameter array of ICodeSnippet objects is used as a parameter, since each code snippet file can contain more than one code snippet per Microsoft's specifications.

Code Snippet Folders and Metadata

The ICodeSnippetFolder interface, implemented by the CodeSnippetFolder class, represents a folder that can reference code snippets. Each folder has a Name property that is usually the value of the real file system folder it represents.

A folder has a Items collection, where each item is an object of type ICodeSnippetMetadata. The ICodeSnippetMetadata interface specifies a subset of the properties found on the ICodeSnippet interface, and is used to store minimal descriptive information about a particular code snippet, such as its title, shortcut, and description. The metadata also has a GetCodeSnippet method that can be called to dynamically load the referenced full code snippet.

Nested folders can be created as well. Each folder has a Folders collection that lists the child folders of the current folder.

A helper FindItemByShortcut method is included that recursively searches an ICodeSnippetFolder hierarchy for a contained code snippet that has a particular shortcut.

Loading a Code Snippet Folder

An ICodeSnippetFolder can be created and initialized programmatically, or fully-loaded from a file system path.

To create and initialize an ICodeSnippetFolder from a file system path, call the static CodeSnippetFolder.LoadFrom method.

C#
VB
Copy
​ICodeSnippetFolder folder = CodeSnippetFolder.LoadFrom(path, "CSharp");
​Dim folder As ICodeSnippetFolder = CodeSnippetFolder.LoadFrom(path, "VB")

This method will recursively examine folders and load any code snippets located that are for the designated language.

Code Snippet Providers

The ICodeSnippetProvider interface, and related CodeSnippetProvider implementation class, is very important since it is the service that should be registered on a language to make code snippet functionality available. It is used to store available code snippet metadata, watch keypresses, and manage the adornments for fields in any template sessions.

Its RootFolder property needs to be set to an ICodeSnippetFolder instance that has loaded code snippet metadata into itself or one of its nested folders. Its IsCaseSensitive property can also be set to false for case-insensitive languages.

This code registers a provider on a language using the folder from the previous section's sample:

C#
VB
Copy
​language.RegisterService(new CodeSnippetProvider() { RootFolder = folder });
​language.RegisterService(New CodeSnippetProvider() With {.RootFolder = folder})
This code is also required to be called once per application instance since it registers the classification types and related styles for any fields that will be visible during a template session. If it is not called, then field backgrounds and borders might not display.
C#
VB
Copy
​new DisplayItemClassificationTypeProvider().RegisterAll();
​CType(New DisplayItemClassificationTypeProvider(), DisplayItemClassificationTypeProvider).RegisterAll()

Once the provider has been registered on a language, it will watch for Tab key presses. If a shortcut for a known code snippet appears before the caret, then that code snippet will be activated into a new template session.

Customizing Code Snippet Providers

Some languages may wish to only allow shortcuts to trigger code snippet template sessions when in certain portions of code. For instance, a language generally doesn't want a code snippet shortcut to trigger when the shortcut is in a comment or a string literal.

This can be achieved by creating a class that inherits CodeSnippetProvider. Then override the GetPossibleShortcutSnapshotRange method and in that code, first call the base method. If a snapshot range is returned that is not zero-length, get a snapshot reader and see what sort of token is at the snapshot range. If it is a comment or literal, return TextSnapshotRange.Deleted. Otherwise, return the result from the base method call.

Code Snippets in Completion Lists

Languages that wish to include code snippet support may wish to list code snippet metadata items in the Ctrl+Space completion lists. The .NET Languages Add-on languages include this feature.

When a code snippet is selected in the completion list, its shortcut is inserted into the editor. Then if the user presses the Tab key next, and assuming a code snippet provider is registered on the language (see above), the related code snippet is inserted.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Content Providers

Content providers are classes that provide content on demand to IntelliPrompt sessions that display popups. An example of their usage is providing content for quick info and completion item description tip popups.

This topic contains these sections:

  • The IContentProvider Interface
  • The DirectContentProvider Class
  • The PlainTextContentProvider Class
  • The HtmlContentProvider Class
  • Custom Content Providers

The IContentProvider Interface

All content providers implement the IContentProvider interface. There are several built-in provider implementations described below.

The DirectContentProvider Class

The DirectContentProvider is the simplest way to provide content. Its constructor takes an object instance and that is what is returned by the provider.

The downside to using this provider is that the content must be loaded prior to creation of the provider. If a large number of providers are needed (such as for a completion list), then it is better to use another provider or build a custom one.

This code creates a DirectContentProvider using the TextBlock control that is already loaded in a textBlock variable:

C#
VB
Copy
​DirectContentProvider provider = new DirectContentProvider(textBlock);
​Dim provider As DirectContentProvider = New DirectContentProvider(textBlock)

The PlainTextContentProvider Class

The PlainTextContentProvider is very similar to the DirectContentProvider except that it takes a String value instead of an object.

Behind the scenes a TextBlock with word wrap capabilities is created that renders the String value and the TextBlock is returned as the content.

The HtmlContentProvider Class

The HtmlContentProvider is a really nice way to spruce up IntelliPrompt popups because it supports a mini-HTML markup format, allowing multiple fonts, colors, etc. to be used.

As with PlainTextContentProvider, a word wrap capable TextBlock is created behind the scenes but here, the String passed into the provider is parsed for markup instead of being treated as plain text.

Markup Tags

The markup text is specified using lowercase HTML-like formatting tags. All tags must be well-formed must be in XML-compliant syntax.

These tags are supported:

Tag | Description
a | Creates a hyperlink over the enclosed text. The href attribute indicates the target. See the special notes for this tag below.
b | Renders the enclosed text in a bold face.
br | Adds a line break.
em | Renders the enclosed text using emphasis. The default style renders in italics.
i | Renders the enclosed text in an italic style.
img | Renders an image. The src specifies the image and the the align tag controls alignment. See the special notes for this tag below.
span | Changes the formatting of the enclosed text. This tag should be used with the style attribute to specify formatting such as color, font, etc.
strong | Renders the enclosed text using a strong face. The default style renders in bold face.
u | Renders the enclosed text with an underline.

The style Attribute

The style attribute can be applied to any tag listed above. It accepts a subset of CSS (cascading style sheets) properites as input.

The supported properties are:

Property | Description
background-color | The background color of the text. This value can be specified using HTML format (e.g. #RRGGBB) or by referencing standard web colors by name (e.g. Red).
color | The foreground color of the text. This value can be specified using HTML format (e.g. #RRGGBB) or by referencing standard web colors by name (e.g. Red).
font-family | The font family of the text. This can be any valid font family name (e.g. Tahoma), even in quotes (e.g. "Courier New"). It can also be one of the generic family names (Monospace, Serif, or Sans-Serif).
font-size | The font size of the text. This is currently always specified in points (e.g. 10pt).
font-weight | The font weight, or boldness, of the text. These values map to a normal font: normal, lighter, 100, 200, 300, 400, 500. These values map to a bold font: bold, bolder, 600, 700, 800, 900.
font-style | The font style of the text. The values italic and oblique map to an italic font. The value normal map to a normal font.
text-decoration | The decoration for the text. The value none uses no decoration. The value underline draws a line under the text. The value line-through draws a line through the middle of the text (strike-through).

Adding Horizontal Whitespace

You can use the &nbsp; character to add a non-breaking space to the text. Use multiple &nbsp; characters in a row to create a horizontal spacer.

Working With the 'a' (Hyperlink) Tag

The href attribute of an a tag specifies the target of the hyperlink. When the link is clicked, the IntelliPrompt session usually provides an event that is raised, such as IQuickInfoSession.RequestNavigate. A property in the event arguments indicates the HREF that was clicked so that you can take appropriate action. One sample action would be to open a web browser to a URL passed in the HREF.

Working With the 'img' (Image) Tag

Since there is no way to pass binary image data in the XML markup itself, the HtmlContentProvider.GetImage method is called when an img tag is encountered. The src attribute value is passed in and the method returns an Image. This method must be overridden in a custom class that inherits HtmlContentProvider, otherwise a null reference is always returned.

The align attribute accepts values of baseline and absbottom. The default is baseline.

Specifying the Background Color

It is recommended that the HtmlContentProvider.BackgroundColorHint property is set when the content will be used in quick info or parameter info tips. Both of those tips use the editor's syntax highlighting. Since the editor's highlighting styles might not match the light/dark nature of the application's theme, supplying the background color hint from the ITextView.DefaultBackgroundColor value will ensure that the appropriate light or dark Metro image set is used for optimal rendering if Metro images are active via the CommonImageSourceProvider.DefaultImageSet property.

Syntax Example

This is an example of markup text that can be used with HtmlContentProvider:

XML
Copy
​<span style="font-size: 16pt; font-weight: bold;">Actipro SyntaxEditor</span>
<br/><i>The ultimate syntax-highlighting code editor control.</i>

Escaping Markup Text

HtmlContentProvider provides an XML escape method for ensuring that "plain text" can be used in it without having to worry about possible malformed XML errors. Situations where this is useful are generally those where the text comes from an external data source that could have & or other XML control characters in the text.

The HtmlContentProvider.Escape static method will escape all XML control characters such as <, >, &, etc. and will also convert line feed characters to <br /> tags.

This is an example of escaping the markup text that without an escape, would have raised a bad XML exception:

C#
VB
Copy
​string text = "Line 1 &" + Environment.NewLine + "Line 2";
text = HtmlContentProvider.Escape(text);
​Dim text As String = "Line 1 &" & Environment.NewLine & "Line 2"
text = HtmlContentProvider.Escape(text)

Custom Content Providers

It's easy to write your own custom content provider if none of the implementations above work for your scenario. Simply create a class that implements IContentProvider.

The GetContent method that must be implemented as part of that interface returns an object. You could have it be pulled from a storage mechanism or could dynamically generate it.

Since the method is called on-demand, the content doesn't need to be loaded up front. When creating a custom provider, the provider generally stores some object that contains data that should be described by the generated content. Then in the GetContent method, the data object is examined in order to generate the appropriate content.

It is common to use the HtmlContentProvider to aid in dynamically generating content in custom content providers. In this example of a GetContent implementation, there is a Type field in the custom content provider class called targetType. A HtmlContentProvider is used to help provide nicely-formatted markup content describing the type.

C#
VB
Copy
​string htmlSnippet = String.Format("Type: <b>{0}</b>",
    HtmlContentProvider.Escape(targetType.FullName));
return new HtmlContentProvider(htmlSnippet).GetContent();
​Dim htmlSnippet As String = String.Format("Type: <b>{0}</b>", _
    HtmlContentProvider.Escape(targetType.FullName))
return New HtmlContentProvider(htmlSnippet).GetContent()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Image Source Providers

Image source providers are classes that provide ImageSource objects on demand to IntelliPrompt sessions. An example of their usage is providing image sources for completion list items.

This topic contains these sections:

  • The IImageSourceProvider Interface
  • The DirectImageSourceProvider Class
  • The CommonImageSourceProvider Class
  • Custom Image Source Providers

The IImageSourceProvider Interface

All image source providers implement the IImageSourceProvider interface. There are a couple built-in provider implementations described below.

The DirectImageSourceProvider Class

The DirectImageSourceProvider is the simplest way to provide image sources. Its constructor takes an ImageSource instance and that is what is returned by the provider.

The downside to using this provider is that the image source must be loaded prior to creation of the provider. If a large number of providers are needed (such as for a completion list), then it is better to use another provider or build a custom one.

This code creates a DirectImageSourceProvider using the ImageSource that is already loaded in a source variable:

C#
VB
Copy
​DirectImageSourceProvider provider = new DirectImageSourceProvider(source);
​Dim provider As DirectImageSourceProvider = New DirectImageSourceProvider(source)

The CommonImageSourceProvider Class

The CommonImageSourceProvider is a handy image source provider that comes pre-packaged with some of the most common 16x16 icons used in features like completion lists.

Its constructor takes a single parameter of type CommonImageKind, which is an enumeration that specifies one of many built-in images. This image source provider works on-demand and only pulls the image from assembly resources as needed.

This code creates a CommonImageSourceProvider that returns a 16x16 public method icon:

C#
VB
Copy
​CommonImageSourceProvider provider = new CommonImageSourceProvider(CommonImageKind.MethodPublic);
​Dim provider As CommonImageSourceProvider = New CommonImageSourceProvider(CommonImageKind.MethodPublic)

Image Set Selection

There are several image sets that are included with SyntaxEditor:

  • Classic - Best for non-Metro themes.
  • MetroLight (default) - Best for most Metro themes.
  • MetroDark - Best for the MetroDark theme.

The MetroLight and MetroDark image sets are implemented with vector graphics, enabling the best clarity when used on high DPI systems.

To change the image set that is currently in effect, set the CommonImageSourceProvider.DefaultImageSet property to a CommonImageSet value. Note that some UI, such as for the NavigableSymbolSelector, may need to be reloaded following a change to this property.

Custom Image Source Providers

It's easy to write your own custom image source provider if none of the implementations above work for your scenario. Simply create a class that implements IImageSourceProvider.

The GetImageSource method that must be implemented as part of that interface returns an ImageSource object. You could have it be pulled from a resource, database, or any other storage mechanism.

Since the method is called on-demand, the image source doesn't need to be loaded up front.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Navigable Symbol Selector

The NavigableSymbolSelector control displays two side-by-side drop-downs similar to the type/member drop-downs above the code editor in Visual Studio. One drop-down shows all available root symbols (generally types), and the other shows all available member symbols within the currently selected root symbol.

As the caret in a bound SyntaxEditor instance is moved, the selections in the NavigableSymbolSelector update to indicate the enclosing symbols (types/members). The end user can also select a different symbol from the drop-downs to navigate directly to the related symbol declaration.

This topic contains these sections:

  • Attaching to a SyntaxEditor Instance
  • Populating the NavigableSymbolSelector
  • Symbol Selection Logic
  • Rool Symbol-Only Display
  • Member Symbol-Only Display

Attaching to a SyntaxEditor Instance

NavigableSymbolSelector controls must be bound to a single SyntaxEditor control instance. The selector will watch for various events on the bound editor and will respond accordingly.

For instance, when the caret moves, the selector will find the appropriate symbols to select in its drop-downs based on which ones most closely enclose or are near the caret. Likewise, when the end user picks another symbol from one of the drop-downs, the bound editor's caret will move to its declaration.

NavigableSymbolSelector controls generally appear directly above the bound SyntaxEditor control like in this example within a Grid:

XAML
Copy
​<Grid>
    <Grid.RowDefinitions>
        <RowDefinition Height="Auto" />
        <RowDefinition Height="*" />
    </Grid.RowDefinitions>
    <editor:NavigableSymbolSelector SyntaxEditor="{Binding ElementName=editor}" />
    <editor:SyntaxEditor x:Name="editor" Grid.Row="1" />
</Grid>

Populating the NavigableSymbolSelector

While it's extremely simple to get a NavigableSymbolSelector working in an app per binding it to an editor (as above), the current syntax language needs to support telling the selector what symbols are available in the document.

The Navigable Symbol Provider topic describes the special language service that must be implemented so that a selector knows how to populate its drop-downs with symbols.

Symbol Selection Logic

As mentioned above, the selector watches editor events and updates the symbols that are selected in the drop-downs according to the current editor caret location. If the caret is within a symbol, the closest enclosing symbol is selected in the drop-down. If the caret is not within a symbol, but there is one after the caret, it is selected in the drop-down. Or if there are no symbols after the caret, the previous symbol is selected.

The selector has an additional feature where the selected symbol grays out when the symbol doesn't enclose the caret. This provides a nice visual indicator for when the caret is actually within or just near the selected symbol.

Rool Symbol-Only Display

Some languages may not support members and may only need to have a single drop-down to display root symbols, instead of an additional drop-down to display member symbols.

For these scenarios, set the NavigableSymbolSelector.AreMemberSymbolsSupported property to false.

Member Symbol-Only Display

Some languages may wish to only show members and have a single drop-down to display member symbols, instead of an additional drop-down to display root symbols.

For these scenarios, set the NavigableSymbolSelector.AreRootSymbolsSupported property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Highlighting styles govern how SyntaxEditor text is rendered and can be used to create entire themes for various languages.

This topic contains these sections:

  • Highlighting Styles
  • Highlighting Style Registries
  • TextStylePreview Control

Highlighting Styles

Highlighting styles store information about how text should be rendered within a SyntaxEditor, including fore/background, font styles, and more.

See the Highlighting Styles topic for more information.

Highlighting Style Registries

Highlighting style registries provide a mapping from classification types to highlighting styles. They tell SyntaxEditor how the various ranges of classified text should appear within the text area.

See the Highlighting Style Registries topic for more information.

TextStylePreview Control

The TextStylePreview control is a small control that is used on options dialogs to show the end user a preview of how an IHighlightingStyle will render.

See the TextStylePreview Control topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Highlighting Styles

Highlighting styles store information about how text should be rendered within a SyntaxEditor, including fore/background, font styles, and more.

Styles have the capability of altering these formatting options:

  • Foreground
  • Background
  • Border
  • Bold
  • Italic
  • Font family
  • Font size
  • Strike-through
  • Underline

This topic contains these sections:

  • Basic Concepts
  • Relationship Between Classifications and Styles
  • Formatting Options
  • Editable Properties

Basic Concepts

Interface and Implementation

Highlighting styles are instances of the IHighlightingStyle interface. The HighlightingStyle class implements this interface and provides for the easiest way to create highlighting styles.

This code creates a simple highlighting style with a foreground color of maroon:

C#
VB
Copy
​IHighlightingStyle style = new HighlightingStyle(Colors.Maroon);
​Dim style As IHighlightingStyle = New HighlightingStyle(Colors.Maroon)

Default Values and Inheritance

All the properties in HighlightingStyle are initially set to "default" values. These default values are set up to not change formatting in any way.

In the code example above however, we have assigned a Maroon foreground Color to the style. This means that the style defined above will only change the foreground of text that it is applied against. It will not alter the bold weight, font size, etc.

There are scenarios in SyntaxEditor where two or more styles may be merged together to create resolved formatting options. For instance, if the special DisplayItemClassificationTypeProvider.PlainText classification type is used (see the Highlighting Style Registries topic for more information), then the style associated with that classification type is the default style for the text area. Classifications made by an ITagger<IClassificationTag> may apply their own styles to specific ranges of text. SyntaxEditor resolves the two styles together to get resolved formatting options for the text in the editor.

During the resolution process, any non-default property settings on the higher-priority style will be applied and will override any property settings on the lower-priority style. If the higher-priority style doesn't set a property value but the lower-priority style does, the lower-priority style's value will be used, thereby establishing inheritance.

Relationship Between Classifications and Styles

Taggers are objects that provide data (in the form of tags) over ranges of text. One such tag is the IClassificationTag, which is a tag that indicates an IClassificationType. Thus these tags can provide logical classifications of text ranges. All this functionality is built into the text/parsing framework.

Highlighting styles on the other hand purely deal with the user interface and how text is formatted.

There is a strong relationship that ties together classifications and highlighting styles, and that tie is made via highlighting style registries. These registries provide a mapping from classification types to highlighting styles.

As a SyntaxEditor prepares to draw text, it examines the logical classifications that have been on the text. Then it uses highlighting style registries to determine which highlighting styles apply. After that, it resolves styles (see above) and returns a list of resolved styles to the code that renders the text.

Formatting Options

Highlighting styles have a lot of options for changing the formatting of text.

Foreground and Background

The Foreground and Background properties are used to designate nullable Color objects that should be used to render the foreground and background of text.

It is recommended to generally use Color instances that have no transparency.

A null reference value is considered the "default" value and will not alter formatting.

Background Spans Virtual Whitespace

The BackgroundSpansVirtualSpace property specifies whether the background should span virtual space when the styled range includes a line terminator. When set to true, the background will be rendered to the right edge of the view, thereby covering virtual space.

It is a Boolean type, where the default is false. Since backgrounds are rendered in a layered fashion, a null reference value is not needed for this property.

Bold and Italic

The Bold and Italic properties are used to designate whether the text should be bold and/or italic.

It is a nullable Boolean type, where a null reference value is considered the "default" value and will not alter formatting.

Border

Optional borders can be applied to text via highlighting styles. The BorderKind property can be used to indicate the style (solid, dotted, etc.) to use for the border.

The BorderColor property specifies the color to use for rendering the border. If it is not specified, then the foreground is used.

Borders render with square corners by default but the BorderCornerKind property can be set to change to rounded corners instead.

Font Family

The FontFamilyName property can be used to specify the font family name in which to render text.

A null reference value is considered the "default" value and will not alter formatting.

Font Size

The FontSize property can be used to specify the font size (in points) in which to render text.

A value of 0.0 is considered the "default" value and will not alter formatting.

Strike-through

The StrikethroughKind, StrikethroughColor, and StrikethroughWeight properties are used to designate how a text strike-through should render.

The default value is LineKind.None, which will not render a strike-through line.

Underline

Properties like UnderlineKind, UnderlineColor, and UnderlineWeight can be used to designate how a text underline should render.

The default value is LineKind.None, which will not render an underline.

Editable Properties

SyntaxEditor highlighting styles are designed to be editable by the end user via an options dialog. Therefore, styles include several options for designating which of the most common properties may be edited by the end user.

The IsForegroundEditable, IsBackgroundEditable, IsBoldEditable, IsBorderEditable, and IsItalicEditable properties all indicate which of the related properties are editable. By default, all properties except for the border one are editable.

There are a number of cases however where certain properties don't make sense to be editable. As an example, the style for the special DisplayItemClassificationTypeProvider.CollapsibleRegion shouldn't allow bold or italic to be editable. That style only needs its foreground and background to be editable.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Highlighting Style Registries

Highlighting style registries provide a mapping from classification types to highlighting styles. They tell SyntaxEditor how the various ranges of classified text should appear within the text area.

This topic contains these sections:

  • Basic Concepts
  • The Ambient Registry
  • Registering and Unregistering Entries
  • Enumerating Classification Types and Highlighting Styles
  • Classification Type Sort Order
  • Special Classification Types (Plain Text, Line Numbers, Indicator Margin, etc.)
  • Highlighting Styles Options Dialog
  • Importing Visual Studio Settings
  • Defining and Using an Alternate Default Registry
  • Classification Tags Providing an Alternate Registry
  • Switching to a Dark Theme

Basic Concepts

A classification type (which could represent an identifier, comment, etc.) is a logical category that can be assigned to ranges of text via a tagger for the IClassificationTag type. Classifications are made within the text/parsing framework and therefore are not tied to the user interface.

A highlighting style registry takes these classification types and maps them to highlighting styles. Highlighting styles define formatting options that should be applied to text. Therefore via the use of highlighting style registries allows the editor to determine how classified text should be rendered.

Highlighting style registries are implementations of the IHighlightingStyleRegistry interface. The HighlightingStyleRegistry class implements this interface.

The Ambient Registry

The ambient registry is a static registry that is always available and is generally what is used by the editor. It is available via the AmbientHighlightingStyleRegistry class.

This code shows how to get an instance of the ambient registry:

C#
VB
Copy
​IHighlightingStyleRegistry registry = AmbientHighlightingStyleRegistry.Instance;
​Dim registry As IHighlightingStyleRegistry = AmbientHighlightingStyleRegistry.Instance

Registering and Unregistering Entries

A registry entry consists of an IClassificationType and IHighlightingStyle pair.

Registrations can be made by calling the IHighlightingStyleRegistry.Register method. Registrations can be removed by calling the IHighlightingStyleRegistry.Unregister method.

This code registers a highlighting style in the style variable for the common Comment classification type in the ambient registry:

C#
VB
Copy
​AmbientHighlightingStyleRegistry.Instance.Register(ClassificationTypes.Comment, style);
​AmbientHighlightingStyleRegistry.Instance.Register(ClassificationTypes.Comment, style)

An overload for the Register method indicates whether any existing entry for the IClassificationType should be overwritten. The overload in the sample code above will not override an existing entry if one is found.

Enumerating Classification Types and Highlighting Styles

The IHighlightingStyleRegistry.ClassificationTypes property returns the collection of IClassificationType objects that are currently registered.

The IHighlightingStyleRegistry.HighlightingStyles property returns the collection of IHighlightingStyle objects that are currently registered.

Classification Type Sort Order

The IHighlightingStyleRegistry.ClassificationTypes collection is sorted in a special order. This allows you to be able to bind the collection to a list in an application options dialog.

The base sorting is performed on the IClassificationType.Description property. If a IClassificationType implements IOrderable, it is sorted before any IClassificationType that doesn't implement IOrderable. The IOrderable implementation can be used to indicate the keys of other IClassificationType after which the classification type should be sorted.

Special Classification Types (Plain Text, Line Numbers, Indicator Margin, etc.)

There are several classification types that have special meaning for SyntaxEditor, all of which are available as properties on the DisplayItemClassificationTypeProvider class. These classification types are special cased to allow for end user customization of things such as the default text format, line number margin, indicator margin, visible whitespace, etc.

The classification types on DisplayItemClassificationTypeProvider are not used unless they are registered.

Registration into the ambient highlighting style registry can be performed with this code:

C#
VB
Copy
​new DisplayItemClassificationTypeProvider().RegisterAll();
​New DisplayItemClassificationTypeProvider().RegisterAll()

These are the special IClassificationType properties on DisplayItemClassificationTypeProvider:

Member | Description
BreakpointDisabled Property | Gets the IClassificationType to use for a disabled breakpoint. Only the border is editable in the default IHighlightingStyle that is registered for this classification type.
BreakpointEnabled Property | Gets the IClassificationType to use for an enabled breakpoint. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
CodeSnippetDependentField Property | Gets the IClassificationType to use for a code snippet dependent field. Only the border is editable in the default IHighlightingStyle that is registered for this classification type.
CodeSnippetField Property | Gets the IClassificationType to use for a code snippet field. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
CollapsedText Property | Gets the IClassificationType to use for collapsed text. Only the foreground is editable in the default IHighlightingStyle that is registered for this classification type.
CollapsibleRegion Property | Gets the IClassificationType to use for collapsible regions. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
CurrentLine Property | Gets the IClassificationType to use for the current line highlight. Only the background and border are editable in the default IHighlightingStyle that is registered for this classification type.
CurrentStatement Property | Gets the IClassificationType to use for a current statement. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
DelimiterMatching Property | Gets the IClassificationType to use for the delimiter matching highlight. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
FindMatchHighlight Property | Gets the IClassificationType to use for a find match highlight. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
IndentationGuides Property | Gets the IClassificationType to use for indentation guides. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
IndicatorMargin Property | Gets the IClassificationType to use for the indicator margin. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
LineNumbers Property | Gets the IClassificationType to use for the line number margin. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
OutliningMarginSquare Property | Gets the IClassificationType to use for outlining margin squares. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
OutliningMarginVerticalRule Property | Gets the IClassificationType to use for outlining margin vertical rules. Only the foreground is editable in the default IHighlightingStyle that is registered for this classification type.
PlainText Property | Gets the IClassificationType to use for default text in the text area. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
RevertedChangesMark Property | Gets the IClassificationType to use for reverted changes marks. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
SavedChangesMark Property | Gets the IClassificationType to use for saved changes marks. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
UnsavedChangesMark Property | Gets the IClassificationType to use for unsaved changes marks. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
VisibleWhitespace Property | Gets the IClassificationType to use for visible whitespace. Only the foreground is editable in the default IHighlightingStyle that is registered for this classification type.

Highlighting Styles Options Dialog

Please see the samples for a QuickStart on how to create a highlighting styles options dialog that allows the end user to customize all aspects of the editor's display.

Importing Visual Studio Settings

The AmbientHighlightingStyleRegistry allows for importing of Visual Studio settings files (.vssettings) to theme SyntaxEditor.

SyntaxEditor after importing some custom VS settings

You can see in the screenshot above that everything from basic text to the line number margin is themed. This is all done using the highlighting style registry and the special classification types in DisplayItemClassificationTypeProvider (see above). All of these colors, etc. can be configured by the end user as well.

This code imports a .vssettings file (pre-loaded in a Stream variable named stream) to theme the control:

C#
VB
Copy
​AmbientHighlightingStyleRegistry.Instance.ImportHighlightingStyles(stream);
​AmbientHighlightingStyleRegistry.Instance.ImportHighlightingStyles(stream)

Defining and Using an Alternate Default Registry

In most cases, the AmbientHighlightingStyleRegistry is the only registry you need to use. However in some scenarios, you may wish to support more than one highlighting style registry, for instance one for text editors and one for console windows. Each registry can have different style settings for its known classification types. In these scenarios, you can use the ambient registry for text editors and can create a custom HighlightingStyleRegistry to use for console windows. In fact, any number of custom registries can be created as needed.

The SyntaxEditor.HighlightingStyleRegistry property is used to indicate which IHighlightingStyleRegistry to use when mapping classification types to highlighting styles. If the property is left unassigned, then the AmbientHighlightingStyleRegistry is used.

Back to the example scenario, for any SyntaxEditor that will be used as a console window, you would assign the custom IHighlightingStyleRegistry for console windows to that editor instance.

This code creates a custom registry and assigns it to a console window SyntaxEditor:

C#
VB
Copy
​SyntaxEditor console = new SyntaxEditor();
IHighlightingStyleRegistry consoleWindowRegistry = new HighlightingStyleRegistry();
consoleWindowRegistry.Description = "Console Window";
console.DefaultHighlightingStyleRegistry = consoleWindowRegistry;
​Dim console As New SyntaxEditor()
Dim consoleWindowRegistry As IHighlightingStyleRegistry = New HighlightingStyleRegistry()
consoleWindowRegistry.Description = "Console Window"
console.DefaultHighlightingStyleRegistry = consoleWindowRegistry

You must populate the entries into the custom registry.

Note that the SyntaxLanguageDefinitionSerializer class has a HighlightingStyleRegistry property where the registry it should use can be specified. A TextExporterFactory (used when exporting text) constructor overload also accepts a custom IHighlightingStyleRegistry. In all cases, if no custom registry is specified, the AmbientHighlightingStyleRegistry is used.

Another alternate registry can be designated for use in printer output only. See the Print Options topic for more information.

Classification Tags Providing an Alternate Registry

Although most of the time, the classification types used by classification taggers are registered into the IHighlightingStyleRegistry instance used by the editor, there are cases where you may wish to not add certain classification types into that registry.

One possible scenario is if you wish to have some classification types that should not be included in the list of classification types that are configuarable by the end user. Another is if your classification tagger just keeps its types private.

In these scenarios, it's possible to have an IClassificationTag specify an alternate IHighlightingStyleRegistry to use. This is done by having the IClassificationTag implement the IHighlightingStyleRegistryProvider interface. The classification tag returns the custom registry via the HighlightingStyleRegistry property. Classification taggers can use the StyleRegistryClassificationTag class for this purpose. When the normal highlighting style registry is fine for use, use the smaller ClassificationTag class instead.

Switching to a Dark Theme

All of the default styles registered by DisplayItemClassificationTypeProvider and the built-in language implementations are intended to be used on an editor with a light background. However in cases where a dark application theme has been applied, these default styles will not be very appealing.

The Actipro Themes system supports dark themes, such as Metro Dark. You can attach to the ThemeManager.CurrentThemeChanged event to know when the current theme is changed by the end user. In this case, add some detection for whether the current theme has changed from a light to dark, or dark to light one. If a theme is changing but both the old and new themes were light background themes, nothing needs to be done.

Let's see an example of how to reset the AmbientHighlightingStyleRegistry instance. In cases where the end user is changing to a light theme from a dark theme, or vice versa, add this in the CurrentThemeChanged event handler:

C#
VB
Copy
​// Unregister all classification types
var classificationTypes = AmbientHighlightingStyleRegistry.Instance.ClassificationTypes.ToArray();
foreach (var classificationType in classificationTypes)
    AmbientHighlightingStyleRegistry.Instance.Unregister(classificationType);

// Re-register common classification types
new DisplayItemClassificationTypeProvider().RegisterAll();

// NOTE: Possibly load up syntax language instances you use so their various customized styles get registered
​' Unregister all classification types
Dim classificationTypes = AmbientHighlightingStyleRegistry.Instance.ClassificationTypes.ToArray()
For Each classificationType In classificationTypes
    AmbientHighlightingStyleRegistry.Instance.Unregister(classificationType)
Next classificationType

' Re-register common classification types
CType(New DisplayItemClassificationTypeProvider(), DisplayItemClassificationTypeProvider).RegisterAll()

' NOTE: Possibly load up syntax language instances you use so their various customized styles get registered

The above code unregisters all the registered classification tyeps from the ambient registry. Then it re-registers the display item classification types and optionally loads up syntax languages that are used by the app so their customized classification types and styles get re-registered. At this point, the registry is ready to go for light themes.

If a dark theme is becoming active, there is some additional work to do. Each of the styles that have been registered into the registry needs to be altered to look good on a dark background.

One way to do this is to enumerate through the registered styles and update the foreground and background colors as appropriate. You could have stored some pre-defined colors in a custom data structure and used that to know how to update the styles.

Alternatively, you could use the feature described in the "Importing Visual Studio Settings" section above. The Sample Browser shows an example of this. It has a pre-defined "Dark.vssettings" file that includes a number of style definitions that render well on dark editor backgrounds. After the code above is executed, this "Dark.vssettings" file is loaded and it will update the styles of any styles that have already been registered on the registry.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TextStylePreview Control

The TextStylePreview control is a small control that is used on options dialogs to show the end user a preview of how an IHighlightingStyle will render.

The TextStylePreview showing a preview of a keyword style

This topic contains these sections:

  • Capabilities
  • Usage

Capabilities

The control can display a preview of these highlighting style properties:

  • Foreground
  • Background
  • Bold
  • Italic
  • Font family
  • Font size
  • Strike-through
  • Underline

Usage

The control is extremely simple to use. Simply place a TextStylePreview control in your application and set its HighlightingStyle property to the IHighlightingStyle that should be previewed.

The HighlightingStyle property supports data binding so it can be bound to a Selector's selected item or other data source.

The HighlightingStyleRegistry property can be set if you are using an alternate IHighlightingStyleRegistry, meaning one that is not the default AmbientHighlightingStyleRegistry. That ensures that it displays resolved values properly.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor has a fully-extensible adornment layer framework that allows for any sort of custom content to be inserted within a view's text area. This can include everything from alternating row highlights, to animated text decorations, or anything else you can imagine.

All the built-in text area rendering is done using adornment layers, such as the text itself, selection, caret, and more.

This topic contains these sections:

  • Adornment Layers
  • Syntax Highlighting
  • Squiggle Lines
  • Intra-Text Adornments
  • Intra-Line Adornments

Adornment Layers

Adornment layers are panels that are stacked within a view's text area. Each layer can be ordered to appear before or after other specified layers. Layers can contain any sort of adornment element.

See the Adornment Layers topic for more information.

Syntax Highlighting

The document text rendered within a view is drawn using two adornment layers, one for the text itself and normal decorations (underlines, etc.), and one for any text backgrounds. Classification taggers can be applied to a document (via language services) to override the default syntax highlighting provided by a language's lexer. This adds support for features like changing the foreground color of certain words, marking search result ranges in a different background color, etc.

See the Syntax Highlighting topic for more information.

Squiggle Lines

There is a built-in adornment layer that can render squiggle lines. Squiggle lines are generally displayed under parse errors or spelling mistakes.

A built-in tagger can also be installed to watch for errors in the parse data returned by a parser, and automatically render squiggle lines based on those ranges.

See the Squiggle Lines topic for more information.

Intra-Text Adornments

SyntaxEditor supports the ability to insert intra-text spacers, or space between text characters, and have adornments render within the space that was created.

This feature can be used to insert any sort of UI element in-line with the text of a view, and is different than normal adornments in that normal adornments don't alter text positioning. This feature allows for inserting in-line images, in-line buttons that can be used to take action on nearby document text, etc.

See the Intra-Text Adornments topic for more information.

Intra-Line Adornments

SyntaxEditor supports the ability to insert intra-line spacers, or margin space around view lines, and have adornments render within the space that was created.

This feature can be used to insert any sort of UI element in-line with a view line, and is different than normal adornments in that normal adornments don't alter text positioning. This feature allows for functionality similar to Code Lens and Peek Definition within the Visual Studio code editor.

See the Intra-Line Adornments topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Adornment Layers

Adornment layers are panels that are stacked within a view's text area. Each layer can be ordered to appear before or after other specified layers. Layers can contain any sort of adornment element.

This topic contains these sections:

  • Adornment Layers and Definitions
  • Built-In Adornment Layers
  • Working With the Adornments on a Layer
  • Tagging Interaction
  • Adornment Managers
  • Adornment Manager Providers
  • Registering with a Syntax Language

Adornment Layers and Definitions

Adornment layers, represented by the IAdornmentLayer interface, are panels that can contain adornment elements. Typically related adornment elements are grouped into a single adornment layer. For instance, a squiggle lines are in one adornment layer, however selection is rendered in a separate layer.

Adornment Layer Definitions

An adornment layer is retrieved by using an adornment layer definition. This definition, represented by the AdornmentLayerDefinition class, holds the string-based key used to identify the layer, along with information about how the layer should be ordered relative to other layers.

Ordering

Each AdornmentLayerDefinition can be passed an optional set of Ordering objects. Each Ordering object allows you to indicate a string-based target layer key along with whether this layer should appear before or after the target layer.

Therefore, you could easily indicate that a custom layer should appear before the text foreground layer, etc.

Important Note About Duplicate Keys Important Note About Duplicate Keys
Always be sure to use unique keys for each of your adornment layers, unique even from the built-in adornment layer names. If layers don't have unique keys, the item with a duplicate key may not sort correctly.

This code shows how to create an adornment layer definition that renders adornments in front of the text foreground layer:

C#
VB
Copy
​AdornmentLayerDefinition def = new AdornmentLayerDefinition("CustomLayer",
    new Ordering(AdornmentLayerDefinitions.TextForeground, OrderPlacement.Before));
​Dim def As AdornmentLayerDefinition = New AdornmentLayerDefinition("CustomLayer", _
    New Ordering(AdornmentLayerDefinitions.TextForeground, OrderPlacement.Before))

Using a Definition to Retrieve a Layer

The ITextView implementations manage the available adornment layers. This means that you can have custom adornment layers in both editor views and printer views, or even just one of those types.

The ITextView.GetAdornmentLayer method can be called to return an adornment layer. It is passed an AdornmentLayerDefinition instance (see previous sub-section) and uses that to see if an adornment layer with the specified key has already been created. If not, it creates a layer with the key and uses the ordering information to reorder the layers.

This code gets an adornment layer using the definition created above:

C#
VB
Copy
​IAdornmentLayer layer = view.GetAdornmentLayer(def);
​Dim layer As IAdornmentLayer = view.GetAdornmentLayer(def)

Adornment Layer Opacity

The IAdornmentLayer.Opacity property allows you to alter the opacity for adornments displayed within a certain layer.

Built-In Adornment Layers

SyntaxEditor includes a number of built-in adornment layers. Each of these built-in adornment layers has their definitions available via static properties on the AdornmentLayerDefinitions class.

Custom adornments should not be added to the built-in adornment layers. Instead, add your own adornment layer and put custom adornments in there. You can use the AdornmentLayerDefinitions class to help with the keys used when ordering your adornment layer.

The stack of built-in adornments layers

This table shows the built-in adornment layers, listed in order by which the layers are stacked (top to bottom):

Adornment Layer | Description
Caret | Renders the blinking caret.
Text Foreground | Renders the syntax-highlighted document text and built-in decorations such as underlines.
Squiggle | Renders any squiggle lines.
Collapsed Region | Renders any collapsed region indicators.
Selection | Renders the selection.
Highlight | Renders any background highlights, such as when mouse hovering over expanded outlining nodes in the outlining margin.
Guides | Renders any background guide lines, such as indentation guides.
Text Background | Renders the syntax highlighting background for any text highlighting styles that have a background set.

Working With the Adornments on a Layer

Adding Adornments

Adornments, represented by the IAdornment interface, are created by calling the IAdornmentLayer.AddAdornment method. There are two sets of overloads for this method where each set has an element-based variation and a draw-based variation. One set takes information for more general adornments and the other has a couple extra parameters that allow the adornment to be tied with a TextSnapshotRange, which is useful for adornments like text decorations.

Both methods have four common parameters:

  • reason - An AdornmentChangeReason indicating the add reason.
  • visualElement - For element-based adornments, the actual UIElement used to visually render the adornment. It is commonly a shape but could be any element type.
  • drawCallback - For draw-based adornments, a DrawAdornmentCallback method that is invoked to draw the adornment.
  • location - The initial location of the adornment, in text area-relative coordinates. Methods like ITextView.TransformToTextArea can be used to transform coordinates from view-relative to text area-relative.
  • tag - An object that contains user-defined data about the adornment. The tag can optionally later be used to find specific adornments that have been created.
  • removedCallback - The callback method that is invoked when the adornment is removed from its parent IAdornmentLayer.

If the adornment should be tracked with text, it will automatically be removed when the related text range is scrolled out of the view. These parameters apply to this AddAdornment overload:

  • viewLine - The ITextViewLine with which the adornment is associated, if any.
  • snapshotRange - The TextSnapshotRange that indicates the range of the adornment.
  • trackingModes - A TextRangeTrackingModes indicating the tracking modes to use.

Finding Existing Adornments

The IAdornmentLayer.Adornments property is a read-only collection of all the adornments in the layer.

A number of methods are also available that make it easy to find certain adornments. The FindAdornment method returns the adornment with the specified visual element. The overloaded FindAdornments methods return the adornments that match criteria, including:

  • Intersection with a certain snapshot range
  • An object that is stored in the adornment's Tag property
  • A predicate that allows for custom matching

Removing Adornments

The IAdornmentLayer.RemoveAdornment method removes a specific IAdornment instance from the layer.

The RemoveAdornments method removes an enumerable list of IAdornment instances from the layer. The enumerable is generally constructed using the results of the various "find" methods described above.

All adornments in a layer can be removed by a call to the RemoveAllAdornments method.

Tagging Interaction

The text/parsing framework's tagging mechanism is usually integrated with adornments, especially in scenarios where the adornments are based on document text. In these scenarios, taggers are responsible for logically marking the ranges of text that require adornments, most often with some sort of custom ITag class. Then an adornment manager (see below) monitors tags of that type and adds/removes adornments as appropriate.

Tagging can also be used to drive some of the built in adornment layers such as customized syntax highlighting and squiggle lines.

Adornment Managers

Adornment managers are objects that manage the adornments placed on a certain adornment layer. When the adornments are based on document text, the tagging mechanism is leveraged.

There are two base classes that can be used for adornment managers: AdornmentManagerBase`1 and DecorationAdornmentManagerBase`2.

The AdornmentManagerBase<T> Class

The AdornmentManagerBase`1 class is the lowest-level class that should be used for adornment managers. It automatically retrieves an appropriate adornment layer, auto-closes when the attached view is closed, and supports an "active" state concept.

The type parameter for the class indicates the type of view to support. To support editor views only, use IEditorView. To support printer views only, use IPrinterView. To support both types of views, use ITextView.

The constructor accepts up to three parameters:

  • view - The view to which the manager will be attached.
  • layerDefinition - The AdornmentLayerDefinition that indicates the definition for the adornment layer to use. The layer is available via the AdornmentLayer property.
  • isForLanguage - Optional. When true, indicates that the manager is something installed by a syntax language and that if the view's document or its language are changed, the managers should auto-close itself. Otherwise the manager will not close unless the view is closed or it is closed explicitly via the Close method.

The View property provides access to the view that contains the adornment layer. The AdornmentLayer property specifies the IAdornmentLayer that is used by this manager.

The Close method can be called to detach the manager from the view. Whenever the manager is closed, the OnClosed method is called. Inherited classes can override this method to clean up any event handlers created in the constructor.

The IsActive property is optionally used but provides a handy way to indicate whether the manager's adornments should be displayed or not. When its value changes, the OnIsActiveChanged method is called. Inherited classes can override this method to add/update/remove adornments as appropriate.

Adornment managers typically link up to various document and view events in their constructor and detach from the events when the manager is closed. While open, when the events occur, adornments are added to and removed from the managed adornment layer. A common event that is attached to is the ITextView.TextAreaLayout event. This event's arguments pass the list of view lines that are added/updated/removed/translated in the layout, if any. Thus you can adjust your adornments appropriately using the add/remove methods of the IAdornmentLayer. IAdornment instances also have Location properties that can be set to move them. If you wish to move an adornment by a certain delta amount, it can use the Translate event instead.

The DecorationAdornmentManagerBase<T,U> Class

The DecorationAdornmentManagerBase`2 class inherits AdornmentManagerBase`1 and provides extensive additional functionality for managing adornments that are related to tagged text ranges. Specifically, this base class creates a tag aggregator for the tag type indicated as the second type parameter to the class.

The base class is notified whenever tags are changed or when the text area layout occurs. It automatically determines when to add and remove tags based on what is currently visible in the editor.

Whenever a new adornment needs to be created for a tagged range, the abstract AddAdornment method is called. This method has these parameters:

  • reason - An AdornmentChangeReason indicating the add reason.
  • viewLine - The ITextViewLine upon which the adornment will be placed.
  • tagRange - A TagSnapshotRange`1 indicating the tag and snapshot range for which an adornment is needed on this line. Note that the tag range could extend outside of the view line's range if the tag covers more than one view line.
  • bounds - The text bounds in which to render the adornment.

Inheritors of this class should override the AddAdornment method and in there, have it create a visual element (such as a shape) that will be rendered, then call the IAdornmentLayer.AddAdornment method to add the element into the adornment layer and create an IAdornment.

This base class makes it very easy to add adornments to text ranges via the use of a tagger.

Adornment Manager Providers

Adornment manager providers, represented by the IAdornmentManagerProvider interface, are objects that can create/retrieve adornment managers for a particular view. Adornment manager providers are called on-demand when a view is created or the view's document/language are changed.

The IAdornmentManagerProvider interface has a GetAdornmentManager method that returns an adornment manager instance to use for the specified view.

The AdornmentManagerProvider`1 class is an implementation of the IAdornmentManagerProvider interface that makes it easy to return instances of the adornment manager type indicated as a type parameter.

A constructor overload accepts a "singleton" object key that can be used to persist any created adornment manager into the ITextView.Properties dictionary using the key. In this case, if the view's document or the document's language changes, the adornment manager is automatically closed and removed from the properties dictionary. The adornment manager associated with the view can be retrieved via the properties dictionary while it is open.

If no "singleton" object is is passed to the adornment manager provider, a new adornment manager class instance will be created each time the provider used.

Registering with a Syntax Language

As described above, AdornmentManagerProvider`1 objects can be used as language services to provide adornment managers to any text views that request them.

This code shows how to register an adornment manager provider language service that returns AlternatingRowsAdornmentManager objects (defined in a QuickStart to provide alternating row highlights). for views that use the language. Note that we are also passing a "singleton" key so that the adornment manager that is created for any view using the language is persisted in the views's Properties dictionary while it is active.

C#
VB
Copy
​language.RegisterService(new AdornmentManagerProvider<AlternatingRowsAdornmentManager>(typeof(AlternatingRowsAdornmentManager)));
​language.RegisterService(New AdornmentManagerProvider(Of AlternatingRowsAdornmentManager)(GetType(AlternatingRowsAdornmentManager)))

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Syntax Highlighting

The document text rendered within a view is drawn using two adornment layers, one for the text itself and normal decorations (underlines, etc.), and one for any text backgrounds. Classification taggers can be applied to a document (via language services) to override the default syntax highlighting provided by a language's lexer. This adds support for features like changing the foreground color of certain words, marking search result ranges in a different background color, etc.

This topic contains these sections:

  • Text Rendering Layers
  • Lexer-Based Syntax Highlighting
  • Overriding Syntax Highlighting

Text Rendering Layers

Syntax highlighting is divided into two adornment layers, a foreground and a background. A reference to the text foreground can be obtained via the AdornmentLayerDefinitions.TextForeground property and a reference to the text background can be obtained via the AdornmentLayerDefinitions.TextBackground property.

The background is separated out so that the selection layer can overlay the text background when the selection extends to text ranges that have a background set.

Note Note
The two text rendering layers cannot be returned via the ITextView.GetAdornmentLayer method. If you wish to add custom adornments around text, you should make your own adornment layer and order it relative to the built-in adornment layers.

Lexer-Based Syntax Highlighting

Syntax languages almost always have a lexer in place that is able to tokenize text. A token tagger can then be used to provide classification tag ranges for the lexer's tokens, where the classification tags indicate a logical IClassificationType for the contained text. The text rendering layers watch the classification tags that are provided by the token tagger.

Each IClassificationType can be paired with a highlighting style, via a highlighting style registry. Once there is a mapping between classification types and highlighting styles, the text rendering layers know how each classified range should be rendered.

Thus with the pieces above in place, lexer-based syntax highlighting is achieved.

Overriding Syntax Highlighting

Sometimes it is desirable to override default lexer-based highlighting. Instances of this could be where certain text ranges should be rendered in a specific foreground, such as when highlighting type names in C# code. Or perhaps changing the background color of certain ranges to indicate breakpoints or find results.

As mentioned above, the text rendering layers already use a tag aggregator to watch for updates to IClassificationTag ranges. When update occur, the text is repainted. Classification taggers (implementations of ITagger<IClassificationTag>) can be ordered. It is very important that classification taggers are set to be ordered before the TaggerKeys.Token tagger, which is the key for the lexer-based syntax highlighting. Otherwise the syntax highlighting derived from the classification tag ranges will appear under the lexer-based syntax highlighting, where it likely would not be seen.

Several QuickStarts show how to implement taggers that alter syntax highlighting.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Squiggle Lines

There is a built-in adornment layer that can render squiggle lines. Squiggle lines are generally displayed under parse errors or spelling mistakes.

A built-in tagger can also be installed to watch for errors in the parse data returned by a parser, and automatically render squiggle lines based on those ranges.

This topic contains these sections:

  • Squiggle Lines Adornment Layer
  • Automated Squiggle Lines for Parse Errors

Squiggle Lines Adornment Layer

The built-in squiggle lines adornment layer uses a tag aggregator for the ISquiggleTag type. When a tagger is applied to a document via a tagger provider language service, the ISquiggleTag ranges that it returns are rendered as squiggle lines in text views.

Squiggle lines showing a syntax error

The ISquiggleTag interface has a ClassificationType property that allows an IClassificationType to be set. When left null, the squiggle line will be rendered in red. If the classification type has a highlighting style mapped to it via the ambient highlighting style registry, the foreground of the style will be used to render the squiggle line.

Automated Squiggle Lines for Parse Errors

If you are using a parser your language, it will return resulting parse data to the ICodeDocument.ParseData property. If the parse data object implements the IParseErrorProvider interface then parse errors can be retrieved from it.

There is a built-in tagger called ParseErrorTagger that can be attached to a document via a document-oriented tagger provider service. See the Tagger Provider topic for details on making tagger provider services.

When this parse error tagger is attached to a document, it will monitor the document's parse data for changes. If the parse data is updated, it will automatically get the list of parse errors from it (assuming the parse data implements IParseErrorProvider) and will return ISquiggleTag tags for each one. This automatically drives the squiggle line display when used in an editor.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Intra-Text Adornments

SyntaxEditor supports the ability to insert intra-text spacers, or space between text characters, and have adornments render within the space that was created.

This feature can be used to insert any sort of UI element in-line with the text of a view, and is different than normal adornments in that normal adornments don't alter text positioning. This feature allows for inserting in-line images, in-line buttons that can be used to take action on nearby document text, etc.

A popup button adornment added into an intra-text spacer

There are two things that must be done to create intra-text adornments.

  • First, an intra-text spacer must be created, which tells the text formatting engine to reserve extra space between two characters.
  • Second, adornments must be added within the space that was created so that they are visible to the end user.

This topic contains these sections:

  • Tagging Intra-Text Spacers
  • Getting Data About Intra-Text Spacers
  • Creating an Intra-Text Adornment Manager

Tagging Intra-Text Spacers

Intra-text spacers can be created via the tagging mechanism that is used throughout the product. The IIntraTextSpacerTag is a dedicated tag type that the SyntaxEditor text formatting engine aggregates. As it formats lines, it watches for tags of this type that intersect the line's offset range, and when found knows to insert an appropriate amount of space at the tag's start offset location.

The IIntraTextSpacerTag has these members:

Member | Description
Baseline | Gets the baseline of the spacer, which is the distance from the top of the spacer to the text baseline. This property can return the height of the spacer to sit the spacer on top of the text baseline.
Key | Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
Size | Gets the size of the spacer. This must be a fixed size.

Therefore to reserve space within text characters, all you need to do is create a tagger for the IIntraTextSpacerTag type and return appropriate tag ranges when requested. You can create a custom class that implements IIntraTextSpacerTag and use that in your tagger results. The tagger can in installed by your language via a tagger provider service.

At this point if your tagger is in use by your language, you should see extra whitespace at any tagged offsets, with the width and height designated by your tag.

Getting Data About Intra-Text Spacers

There are several members that can be useful for working with intra-text spacers, although they are generally only used internally:

Member | Description
GetIntraTextSpacerBounds | Returns a TextBounds representing the bounds of the specified intra-text spacer. The object passed as an argument is the value of the desired tag's Key property.
GetIntraTextSpacerTag | Returns the intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer. Spacer characters are embedded in between other real text characters. While spacer characters do take up a character index, they do not have a corresponding real character in a document.
GetIntraTextSpacerTags | Returns a collection of intra-text spacer tag ranges on the line that are of the specified type.

Creating an Intra-Text Adornment Manager

Now that intra-text spacers have been created, it's time to fill their space with adornments. SyntaxEditor includes a handy base class called IntraTextAdornmentManagerBase`2 that makes it very easy to fill your pre-defined intra-text spacers with adornments.

Note Note
It is important to understand the core concepts for adornments and adornment layers described in the Adornment Layers topic, since many of them apply here.

To make an intra-text adornment manager, create a new class that inherits IntraTextAdornmentManagerBase`2. The first type parameter you pass the base class is the type of view to support, such as IEditorView. The second type parameter you pass the base class is the type of tag to aggregate. For instance if your intra-text spacer tagger returns an IconTag, which for this discussion we will assume that IconTag implements IIntraTextSpacerTag, you would pass the IconTag type to the base class.

Next, have the intra-text adornment manager class constructor pass the target view instance and AdornmentLayerDefinition to use to the base class constructor.

Then override the base class' AddAdornment method. That method passes the view line being examined, the tag and its range for which to create an adornment, and the bounds in which a related intra-text spacer has been placed. Your implementation of the method should create the appropriate adornment, whether it be an image or other shape/control. Then add it to the adornment layer via the layer's AddAdornment method, being sure to pass the IIntraTextSpacerTag.Key value in the "tag" argument to that method. The adornment layer can be retrieved using the AdornmentLayer property on the base class.

Finally register an adornment manager provider (described in the Adornment Layers topic) as a language service. Your views should now be rendering adornments in your intra-text spacers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Intra-Line Adornments

SyntaxEditor supports the ability to insert intra-line spacers, or margin space around view lines, and have adornments render within the space that was created.

This feature can be used to insert any sort of UI element in-line with a view line, and is different than normal adornments in that normal adornments don't alter text positioning. This feature allows for functionality similar to Code Lens and Peek Definition within the Visual Studio code editor.

Code lens adornments with hyperlinks added above view lines

There are two things that must be done to create intra-line adornments.

  • First, an intra-line spacer must be created, which tells the text formatting engine to reserve extra space between two view lines.
  • Second, adornments must be added within the space that was created so that they are visible to the end user.

This topic contains these sections:

  • Tagging Intra-Line Spacers
  • Getting Data About Intra-Line Spacers
  • Creating an Intra-Line Adornment Manager
  • Usage Tips

Tagging Intra-Line Spacers

Intra-line spacers can be created via the tagging mechanism that is used throughout the product. The IIntraLineSpacerTag is a dedicated tag type that the SyntaxEditor text formatting engine aggregates. As it formats lines, it watches for tags of this type that intersect the line's offset range, and when found knows to insert an appropriate amount of top and/or bottom margin space around the view line.

The IIntraLineSpacerTag has these members:

Member | Description
BottomMargin | Gets the baseline of the spacer, which the amount of additional vertical space needed below the view line.
Key | Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
TopMargin | Gets the top margin of the spacer, which the amount of additional vertical space needed above the view line.

Therefore to reserve space around view lines, all you need to do is create a tagger for the IIntraLineSpacerTag type and return appropriate tag ranges when requested. You can create a custom class that implements IIntraLineSpacerTag and use that in your tagger results. The tagger can in installed by your language via a tagger provider service.

At this point if your tagger is in use by your language, you should see extra whitespace around view lines with any tagged offsets, with the top and/or bottom margin designated by your tag.

Getting Data About Intra-Line Spacers

There is a member that can be useful for working with intra-line spacers, although it is generally only used internally:

Member | Description
GetIntraLineSpacerTags | Returns a collection of intra-line spacer tag ranges on the line that are of the specified type.

Creating an Intra-Line Adornment Manager

Now that intra-line spacers have been created, it's time to fill their space with adornments. SyntaxEditor includes a handy base class called IntraLineAdornmentManagerBase`2 that makes it very easy to fill your pre-defined intra-line spacers with adornments.

Note Note
It is important to understand the core concepts for adornments and adornment layers described in the Adornment Layers topic, since many of them apply here.

To make an intra-line adornment manager, create a new class that inherits IntraLineAdornmentManagerBase`2. The first type parameter you pass the base class is the type of view to support, such as IEditorView. The second type parameter you pass the base class is the type of tag to aggregate. For instance if your intra-line spacer tagger returns a CodeLensTag, which for this discussion we will assume that CodeLensTag implements IIntraLineSpacerTag, you would pass the CodeLensTag type to the base class.

Next, have the intra-line adornment manager class constructor pass the target view instance and AdornmentLayerDefinition to use to the base class constructor.

Then override the base class' AddAdornment method. That method passes the view line being examined, and the tag and its range for which to create an adornment. Your implementation of the method should create the appropriate adornment, whether it be a hyperlink or other shape/control. Then add it to the adornment layer via the layer's AddAdornment method, being sure to pass the IIntraLineSpacerTag.Key value in the "tag" argument to that method. The adornment layer can be retrieved using the AdornmentLayer property on the base class.

Finally register an adornment manager provider (described in the Adornment Layers topic) as a language service. Your views should now be rendering adornments in your intra-line spacers.

Usage Tips

Due to the nature of how editor views' scrollbars work (where each scroll notch is a line), it is generally recommended to try and keep the height of intra-line adornments as short as possible to ensure the smoothest scrolling experience.

A viewport adornment containing another SyntaxEditor instance, added below a line

In some cases, such as in the screenshot above where another SyntaxEditor instance is embedded as an adornment within the view, instead of using a fixed height editor, it is recommended to scale the editor instance no larger than roughly 1/3 the height of the text area in which it is contained, with a minimum height also applied. The viewport adornment sample demonstrates how view size change events can be monitored to dynamically adjust the height of the tag's margin, and thus the adornment.

Since intra-line adornments tend to have interactive elements (especially in the viewport sample where a full embedded editor control is added), it is sometimes ideal to cache the UI element added in the adornment when the adornment gets removed from the view. If the adornment is removed from the view due to scrolling, then this allows the same UI element and its full state to be reused later on as the view line is scrolled back into view. If the adornment is removed due to its tag being removed, then it no longer needs to be cached. The viewport adornment sample demonstrates one way of performing UI element caching.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor fully supports automatic (language-driven) and manual (user-driven) code outlining/folding features similar to those found in Visual Studio.

Various text regions can even be collapsed (hidden) independent of the outlining features.

This topic contains these sections:

  • Code Outlining (Folding)
  • Outlining Nodes and Definitions
  • Outlining Sources and Outliners
  • Collapsing Regions without Outlining

Code Outlining (Folding)

Code outlining, also commonly referred to as code folding, is a mechanism by which a hierarchy of outlining nodes is maintained and visually rendered in an outlining margin. Nodes can be expanded and collapsed by the end user.

Automatic outlining mode is used when a syntax language defines an outlining source that tells the outlining manager how to incrementally update nodes as text is changed. Manual outlining mode is used when the end user wishes to define where outlining nodes occur.

A number of built-in commands provide easy access to all the outlining functionality found in products like Visual Studio.

See the Code Outlining (Folding) topic for more information.

Outlining Nodes and Definitions

Outlining nodes are part of a nested hierarchy of text ranges, stored within an outlining manager for a document. They can each be assigned various characteristics via outlining node definitions, such as what they render when collapsed, if they are collapsed automatically when a document is loaded, etc.

See the Outlining Nodes and Definitions topic for more information.

Outlining Sources and Outliners

Outlining sources are objects that an outlining manager can call upon to direct language-specific automatic outlining updates when document text changes. Several helpful base classes are included to make the creation of a syntax language's outlining source a simple task.

An outliner is a language service that returns a language-specific outlining source for a particular ITextSnapshot. Having an outliner service registered on a language is what tells SyntaxEditor that the language supports automatic outlining.

See the Outlining Sources and Outliners topic for more information.

Collapsing Regions without Outlining

The code outlining feature decribed in earlier topics supports the collapsing of outlining nodes, where contained text becomes hidden. SyntaxEditor's low-level collapsed region management feature is harnessed to achieve this functionality. This same collapsed regions mechanism can be used independently of code outlining too.

Various text regions can be collapsed (hidden) independent of the outlining features. And in these cases you can even optionally replace the collapsed region with an adornment.

See the Collapsing Regions without Outlining topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Outlining (Folding)

Code outlining, also commonly referred to as code folding, is a mechanism by which a hierarchy of outlining nodes is maintained and visually rendered in an outlining margin. Nodes can be expanded and collapsed by the end user.

Automatic outlining mode is used when a syntax language defines an outlining source that tells the outlining manager how to incrementally update nodes as text is changed. Manual outlining mode is used when the end user wishes to define where outlining nodes occur.

A number of built-in commands provide easy access to all the outlining functionality found in products like Visual Studio.

This topic contains these sections:

  • Run-Time Features
  • Outlining Mode (Automatic, Manual, etc.)
  • Outlining Manager
  • Outlining Edit Actions and Commands
  • Collapsed Node Quick Info Tips

Run-Time Features

SyntaxEditor's run-time code outlining features match those found in popular code editors.

A SyntaxEditor control with Javascript code being outlined

A margin on the left of the text area visually renders the outlining structure for text within the view. Small "+" (meaning collapsed) and "-" (meaning expanded) boxes show where outlining nodes start. Clicking these boxes allows the related outlining node(s) to toggle their collapsed state. When a node is expanded, a vertical line extending from the node's start box shows view lines that are included in the node's range. A small horizontal line appears on the view line where the node ends.

Hovering the mouse over a vertical line in the margin will cause a highlight to appear that shows the lines contained by the related outlining node. The vertical line can be double-clicked to collapse the node.

Once collapsed, the node's text content is hidden and a small adornment appears in its place. By default this adornment renders "..." text, however that can be customized via the node's definition. Hovering the mouse over the collapsed node adornment will provide a quick info tip displaying the node's contents, if the proper service is registered (see below). Single-clicking the collapsed node adornment will select the node's text range. Double-clicking the collapsed node adornment will expand the node.

Outlining Mode (Automatic, Manual, etc.)

There are two primary ways to supply outlining node data, which are referred to as automatic outlining and manual outlining.

Automatic outlining is language-specific and uses an outlining source to tell the outlining manager how to update the nodes. Manual outlining is where the end user, not the language, dictates the which nodes are present.

The IEditorDocument.OutliningMode property dictates which outlining modes are permitted:

  • Default - Automatic or manual are permitted and the end user may switch between them at any time.
  • Automatic - Only automatic is permitted.
  • Manual - Only manual is permitted.
  • None - No outlining is permitted.

The currently "active" mode is always available in the IOutliningManager.ActiveMode property. This property will never return a value of OutliningMode.Default, since it always is a resolved result.

Outlining Manager

An outlining manager, represented by the IOutliningManager interface, maintains the outlining node hierarchy for a particular document. It can be retrieved via the IEditorDocument.OutliningManager property.

The outlining manager tracks outlining data based on its ActiveMode property. When automatic outlining mode is active, the manager coordinates with an outlining source provided by the current language to determine how to update the outlining node hierarchy when text changes occur. These sorts of updates are generally syntax-driven based on the code in the editor. When manual outlining mode is active, the end user typically indicates which outlining nodes are present by making a text selections and choosing to create outlining nodes from them.

Getting Started with Automatic Outlining

The current syntax language must be capable of providing IOutliningSource objects that can be used by the outlining manager, if automatic outlining is to be supported.

See the Outlining Sources and Providers topic for details on how to add automatic outlining support to a syntax language.

Getting Started with Manual Outlining

Manual nodes can be created programmatic via the IOutliningManager.AddManualNode method and can be removed via the RemoveManualNode or RemoveAllManualNodes methods.

However in most cases the functionality provided by the HideSelectionAction (and related EditorCommands.HideSelection command) should be exposed directly to the end user via a menu/button. This functionality allows the end user to create manual nodes based on the current selection.

Other commands, all of which are described below, are also used when performing manual outlining.

Outlining Edit Actions and Commands

These edit actions and related commands deal with code outlining.

Action, Command | Description
ApplyDefaultOutliningExpansionAction, EditorCommands.ApplyDefaultOutliningExpansion | Applies the default outlining expansion, such that only outlining nodes with an IOutliningNodeDefinition.IsDefaultCollapsed value of true are collapsed.
CollapseToDefinitionsAction, EditorCommands.CollapseToDefinitions | Collapses all outlining nodes that have an IOutliningNodeDefinition.IsImplementation value of true.
ExpandAllOutliningAction, EditorCommands.ExpandAllOutlining | Expands all outlining nodes.
HideSelectionAction, EditorCommands.HideSelection | Collapses the current selection.
StartAutomaticOutliningAction, EditorCommands.StartAutomaticOutlining | Starts automatic outlining.
StopHidingCurrentAction, EditorCommands.StopHidingCurrent | Stops hiding the outlining node that currently contains the caret, if any.
StopOutliningAction, EditorCommands.StopOutlining | Stops outlining.
ToggleAllOutliningExpansionAction, EditorCommands.ToggleAllOutliningExpansion | Toggles the collapsed state of all outlining nodes.
ToggleOutliningExpansionAction, EditorCommands.ToggleOutliningExpansion | Toggles the collapsed state of the outlining node that contains the caret, if any.

The commands can be easily wired up to any button or menu item.

Collapsed Node Quick Info Tips

By default no quick info tips will appear when hovering the mouse over a collapsed node adornment. However a CollapsedRegionQuickInfoProvider instance can be registered as a language service to automatically build quick info for collapsed node adornments.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Outlining Nodes and Definitions

Outlining nodes are part of a nested hierarchy of text ranges, stored within an outlining manager for a document. They can each be assigned various characteristics via outlining node definitions, such as what they render when collapsed, if they are collapsed automatically when a document is loaded, etc.

This topic contains these sections:

  • Outlining Nodes
  • Outlining Node Definitions
  • Advanced Collapsed Content

Outlining Nodes

The IOutliningManager for a document stores a complete hierarchy of outlining nodes. Nodes are created either by a language (when in automatic mode) or by the end user (when in manual mode). Each node is created using an outlining node definition, which provides some characteristics for the node. Node definitions are described in detail below.

Outlining nodes are represented by the IOutliningNode interface. This interface gives access to various node data properties and also lets you traverse to other nodes.

Root Node

The root node, which is never visible and always contains the entire document, can be retrieved via the IOutliningManager.RootNode property. The IsRoot property of any node returns whether it is the root node or not.

Node Definition

The Definition property returns the IOutliningNodeDefinition used to create the node. See below for more information on node definitions.

Collapsed State

The IsCollapsed property returns whether the node is collapsed. It can be toggled to expand or collapse the node.

Snapshot Range and Open/Closed Nodes

The SnapshotRange property returns the TextSnapshotRange that is covered by the node.

If a node is "closed", it has a definite end at the end offset specified in the snapshot range. If a node is "open", it does not have an end and inherits the end offset of the nearest "closed" ancestor node. The IsOpen property indicates if a node is open.

Traversing Nodes

The Count property indicates how many child nodes are in the node, and the Item (indexer) property provides access to the child nodes. The ParentNode property provides access to the parent node.

The FindNodeRecursive method does a recursive search to find the lowest level node that contains the specified offset. This should generally only be called from the root node.

Note Note
The IOutliningNode instances are just wrappers around the core data structure used to track outlining node data. Therefore doing a reference equality check on two nodes that should be the same will always return false, since a new IOutliningNode instance is created each time you traverse to a new node.

Outlining Node Definitions

Outlining node definitions, represented by the IOutliningNodeDefinition interface, are used to define the characteristics of an outlining node. Node definitions are used by outlining sources when in automatic outlining mode, and can optionally be passed to the IOutliningManager.AddManualNode when adding a manual node.

Tip Tip
You can create static instances of your outlining node definitions and reuse them when creating outlining nodes. For example you may wish to support curly brace and multi-line comment outlining nodes in your language. In this scenario, just define two static outlining node definitions (one for curly braces and one for multi-line comments), and use the appropriate one as you create outlining nodes.

OutliningNodeDefinition Class

The OutliningNodeDefinition class implements the IOutliningNodeDefinition interface and is generally used wherever an IOutliningNodeDefinition is needed.

Collapsed Content

The IOutliningNodeDefinition.GetCollapsedContent method allows you to return some content to render when an outlining node is collapsed. Right now, only text strings can be returned by that method. If a null value is returned, the text "..." will be rendered in collapsed nodes. Comment nodes may wish to return a default of "/**/" instead.

The OutliningNodeDefinition class defines an additional DefaultCollapsedContent property that can be set to the content to return in the GetCollapsedContent method. This makes it so that for most cases, inheriting OutliningNodeDefinition is not necessary.

Is Default Collapsed

Sometimes certain node types should be collapsed by default when a document is loaded. #region nodes are good examples of this sort of node.

The IsDefaultCollapsed property should return true if nodes created using the definition should be collapsed by default.

Is Implementation

There is a common edit action called "Collapse to Definitions" that can be executed by the end user. In this scenario, the outlining tree is searched for any nodes with definitions that return true from their IsImplementation property. These nodes are then collapsed.

Is Collapsible

Sometimes you may wish to define nodes that do not allow the end user to alter their state from the UI. In these scenarios, a definition's IsCollapsible property should return false.

Advanced Collapsed Content

As mentioned above, collapsed content can be set on a node definition so that collapsed nodes can render something other than the default "..." when collapsed. Once you get automatic outlining working for your language, you may wish to have certain node types some alternate content that dynamically changes based on the content of the node. For instance, a collapsed #region node may wish to show the text label that follows the #region preprocessor keyword.

This can be achieved by creating a class that inherits OutliningNodeDefinition. Use this new node definition wherever you wish to have this advanced collapse content. In the new node definition class, override the GetCollapsedContent method. The method is passed an IOutliningNode instance. This instance is a node that was created using the definition.

The IOutliningNode.SnapshotRange property returns the TextSnapshotRange covered by the node. Snapshot ranges provide access to the complete text snapshot, via their Snapshot property. Then from that, an ITextSnapshotReader can be obtained so that scanning through text and tokens can be performed.

Thus by using the properties on the TextSnapshotRange and/or by using an ITextSnapshotReader, you can gather text/token data and display customized content for any nodes that use this definition.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Outlining Sources and Outliners

Outlining sources are objects that an outlining manager can call upon to direct language-specific automatic outlining updates when document text changes. Several helpful base classes are included to make the creation of a syntax language's outlining source a simple task.

An outliner is a language service that returns a language-specific outlining source for a particular ITextSnapshot. Having an outliner service registered on a language is what tells SyntaxEditor that the language supports automatic outlining.

This topic contains these sections:

  • Outlining Source Basics
  • Outliners
  • Registering with a Syntax Language
  • Token-Based Outlining Sources
  • Range-Based Outlining Sources
  • Performance Optimizations

Outlining Source Basics

Outlining sources are represented by the IOutliningSource interface. This interface defines a single GetNodeAction method that is called by the IOutliningManager.

When a text change occurs and the outlining node hierarchy needs to be incrementally updated, the manager iterates through the existing nodes and compares them to the actions indicated by an IOutliningSource at the same offset. For each offset that is examined, the manager calls the GetNodeAction method and passes it by reference the offset to examine. It expects the outlining source to return the OutliningNodeAction to take (None, Start, or End) at that offset. None means that no outlining node should start or end at this offset. Start means that an outlining node should start at this offset. And likewise, End means that an outlining node should end at this offset. If the action is Start or End, then an IOutliningNodeDefinition needs to be returned via an out parameter. The node definition helps the manager to create new nodes and match ends to existing nodes. Also for an optimization, the offset passed can be moved ahead to indicate the next meaningful offset for the outlining source. When used properly this can result in a lot less calls to GetNodeAction while still returning the same accurate data.

SyntaxEditor comes with two built-in base classes that make it easier to construct an outlining source. One typically executes in the main thread, uses simple token pairs to determine how to create outlining nodes, and is very quick to set up. The other generally executes in a worker thread by a parser and is better suited for potential large documents, but requires a bit more code to get working. Both are described in detail below.

Outliners

Outliners, represented by the IOutliner interface, are objects that can create/retrieve an IOutliningSource for use by an outlining manager when it needs to update its outlining node hierarchy. The presence of an outliner service on a language tells the outlining manager that the language supports automatic outlining.

The IOutliner interface has two members. The first member is the UpdateTrigger property, that returns an AutomaticOutliningUpdateTrigger enumeration value indicating what event should trigger an automatic outlining update. If the outlining source is to be used in the main thread, such as with the token-based outlining source, then a TextChanged update trigger should be returned. This tells the outlining manager to update outlining data whenever a text change occurs. If the outlining source is to be generated by a parser, such as with a range-based outlining source, then a ParseDataChanged update trigger should be used. This tells the outlining manager to update outlining data whenever the ICodeDocument.ParseData property is changed.

The second member defined by IOutliner is the GetOutliningSource method, which returns an IOutliningSource to use for a given ITextSnapshot.

If you will be using an outlining source that derives from TokenOutliningSourceBase, you can use the built-in TokenOutliner`1 class to create your outlining source as needed. The TokenOutliner`1 class implements IOutliner and is able to create instances of the outlining source type indicated as a type parameter, assuming the outlining source type accepts a single ITextSnapshot constructor parameter.

Registering with a Syntax Language

As described above, IOutliner objects can be used as language services to provide outlining sources to any outlining manager that requests them.

This code shows how to register an outliner language service, assuming JavascriptOutliner implements IOutliner.

C#
VB
Copy
​language.RegisterService<IOutliner>(new JavascriptOutliner());
​language.RegisterService(Of IOutliner)(New JavascriptOutliner())

Token-Based Outlining Sources

A token-based outlining source executes in the main UI thread immediately after any text change occurs. It examines tokens from the language's lexer and returns whether a token indicates a start or end of an outlining node, or neither. For instance, a token for an open curly brace would generally indicate an outlining node start. A token for a close curly brace would generally indicate an outlining node end.

Benefits and Drawbacks

The benefits of this sort of outlining source are that it's extremely fast to get up and running with, and the outlining UI is always up-to-date with the document.

The drawbacks are that there is limited customization for when nodes are created, and since it's updating in the main thread, it has the potential to slow down typing speed when used on a very large document. For small to medium size documents, it should perform well though.

Implementation

A token-based outlining source can be created by inheriting the abstract TokenOutliningSourceBase class. The inherited class you create simply needs to override its GetNodeActionForToken method. That method is passed an IToken and expects an OutliningNodeAction returned. If the action is Start or End, then an appropriate IOutliningNodeDefinition must be returned via the "out" parameter. The outlining manager uses this information to determine how to sync up its outlining node hierarchy with your outlining source.

This code shows a sample token-based outlining source for the Javascript language:

C#
VB
Copy
​public class JavascriptOutliningSource : TokenOutliningSourceBase {

    private static OutliningNodeDefinition curlyBraceDefinition;
    private static OutliningNodeDefinition multiLineCommentDefinition;

    static JavascriptOutliningSource() {
        curlyBraceDefinition = new OutliningNodeDefinition("CurlyBrace");
        curlyBraceDefinition.IsImplementation = true;

        multiLineCommentDefinition = new OutliningNodeDefinition("MultiLineComment");
        multiLineCommentDefinition.DefaultCollapsedContent = "/**/";
        multiLineCommentDefinition.IsImplementation = true;
    }

    public JavascriptOutliningSource(ITextSnapshot snapshot) : base(snapshot) {}

    protected override OutliningNodeAction GetNodeActionForToken(IToken token,
        out IOutliningNodeDefinition definition) {

        switch (token.Key) {
            case "MultiLineCommentStartDelimiter":
                definition = multiLineCommentDefinition;
                return OutliningNodeAction.Start;
            case "MultiLineCommentEndDelimiter":
                definition = multiLineCommentDefinition;
                return OutliningNodeAction.End;
            case "OpenCurlyBrace":
                definition = curlyBraceDefinition;
                return OutliningNodeAction.Start;
            case "CloseCurlyBrace":
                definition = curlyBraceDefinition;
                return OutliningNodeAction.End;
            default:
                definition = null;
                return OutliningNodeAction.None;
        }
    }
}
​Public Class JavascriptOutliningSource
    Inherits TokenOutliningSourceBase

    Private Shared curlyBraceDefinition As OutliningNodeDefinition
    Private Shared multiLineCommentDefinition As OutliningNodeDefinition

    Shared Sub New()
        curlyBraceDefinition = New OutliningNodeDefinition("CurlyBrace")
        curlyBraceDefinition.IsImplementation = True

        multiLineCommentDefinition = New OutliningNodeDefinition("MultiLineComment")
        multiLineCommentDefinition.DefaultCollapsedContent = "/**/"
        multiLineCommentDefinition.IsImplementation = True
    End Sub

    Public Sub New(ByVal snapshot As ITextSnapshot)
        MyBase.New(snapshot)
    End Sub

    Protected Overrides Function GetNodeActionForToken(ByVal token As IToken, _
        <System.Runtime.InteropServices.Out()> ByRef definition As IOutliningNodeDefinition) _
        As OutliningNodeAction

        Select Case token.Key
            Case "MultiLineCommentStartDelimiter"
                definition = multiLineCommentDefinition
                Return OutliningNodeAction.Start
            Case "MultiLineCommentEndDelimiter"
                definition = multiLineCommentDefinition
                Return OutliningNodeAction.End
            Case "OpenCurlyBrace"
                definition = curlyBraceDefinition
                Return OutliningNodeAction.Start
            Case "CloseCurlyBrace"
                definition = curlyBraceDefinition
                Return OutliningNodeAction.End
            Case Else
                definition = Nothing
                Return OutliningNodeAction.None
        End Select
    End Function
End Class

The outlining source could be used by a language by registering a TokenOutliner`1 service:

C#
VB
Copy
​language.RegisterService<IOutliner>(
    new TokenOutliner<JavascriptOutliningSource>());
​language.RegisterService(Of IOutliner)( _
    New TokenOutliner(Of JavascriptOutliningSource)())

Range-Based Outlining Sources

A range-based outlining source is generated by an IParser in a worker thread. The parser scans and provides outlining data for the entire document in the form of text ranges and corresponding outlining node definitions. This could be done via simple token scanning or by examining an AST (abstract syntax tree) that is constructed by the parser immediately beforehand. Since a majority of the work is done in a separate thread, there is almost no impact to the UI thread.

Benefits and Drawbacks

The benefits of this sort of outlining source are that it doesn't slow down the main UI thread (even for relatively large documents) when typing, and allows for complete customization of what text ranges become outlining nodes. For example, you can choose to only make outlining nodes for top-level curly braces, instead of curly braces at all levels.

The drawbacks are that it is slightly more complex than the simpler token-based outlining source mechanism, and there can be a brief delay between when typing and when outlining node UI pops into the margin, due to the multi-threading.

Note Note
Since this sort of outlining source is executed within a parser, be sure to read up on parsers and configuring a dispatcher. Failing to set up a parse request dispatcher properly will prevent worker threads from being used.

Using Abstract Syntax Trees

Advanced syntax language developers will want to build an IParser to construct an AST of their document, and use that AST data to create the appropriate outlining node ranges for their outlining source. Say your syntax language is for C# and assume you have a parser that makes an AST of the document. Your AST knows which text ranges are namespaces, which are classes, etc. Therefore that sort of AST node data can be used to construct related outlining node data.

Implementation

A range-based outlining source can be created by inheriting the abstract RangeOutliningSourceBase class. The inherited class you create should configure the outlining node ranges in its constructor. The constructor can be passed an ITextSnapshot and/or AST data if available.

Regardless of which method will be used to determine where outlining node ranges are, the concept remains the same. Some sort of iteration/recursion should take place and when an outlining node range is found, it can be configured by calling the AddNode method. This method takes a TextRange (relative to the ITextSnapshot passed in) and the IOutliningNodeDefinition to use for that range.

Sometimes certain nodes may not have an end. This could happen in VB if a Namespace ... End Namespace block contains a Class declaration however no End Class has yet been typed. In this case the outlining node for the Class is considered "open". It can be added by calling the AddOpenNode method. That method accepts a start offset instead of a TextRange.

Here is some sample code showing how a range-based Javascript outlining source could be made that only creates outlining nodes for multi-line comments and top-level curly braces. This sample does token scanning in the ITextSnapshot. However if you already have built an AST of the document, that would be more preferable for use.

C#
VB
Copy
​public class JavascriptOutliningSource : RangeOutliningSourceBase {

    private static OutliningNodeDefinition curlyBraceDefinition;
    private static OutliningNodeDefinition multiLineCommentDefinition;

    static JavascriptOutliningSource() {
        curlyBraceDefinition = new OutliningNodeDefinition("CurlyBrace");
        curlyBraceDefinition.IsImplementation = true;

        multiLineCommentDefinition = new OutliningNodeDefinition("MultiLineComment");
        multiLineCommentDefinition.DefaultCollapsedContent = "/**/";
        multiLineCommentDefinition.IsImplementation = true;
    }

    public JavascriptOutliningSource(ITextSnapshot snapshot) : base(snapshot) {
        int curlyBraceStartOffset = -1;
        int curlyBraceLevel = 0;
        int commentStartOffset = -1;
        IToken token;

        // Get a text snapshot reader so that we can read tokens
        ITextSnapshotReader reader = snapshot.GetReader(0);

        // Read through the entire snapshot
        while (!reader.IsAtSnapshotEnd) {
            // Get the next token
            token = reader.ReadToken();
            if (token != null) {
                switch (token.Key) {
                    case "MultiLineCommentStartDelimiter":
                        // A multi-line comment is starting... save its start offset
                        if (commentStartOffset == -1)
                            commentStartOffset = token.StartOffset;
                        break;
                    case "MultiLineCommentEndDelimiter":
                        // A multi-line comment is ending... add its range to the outlining source
                        if (commentStartOffset != -1) {
                            this.AddNode(new TextRange(commentStartOffset, token.EndOffset), multiLineCommentDefinition);
                            commentStartOffset = -1;
                        }
                        break;
                    case "OpenCurlyBrace":
                        // An open curly brace... save its start offset if it's a top-level brace
                        if (curlyBraceLevel++ == 0) {
                            if (curlyBraceStartOffset == -1)
                                curlyBraceStartOffset = token.StartOffset;
                        }
                        break;
                    case "CloseCurlyBrace":
                        // A close curly brace... add its range to the outlining source if it's a top-level brace
                        if (curlyBraceLevel > 0) {
                            curlyBraceLevel--;
                            if (curlyBraceLevel == 0) {
                                this.AddNode(new TextRange(curlyBraceStartOffset, token.EndOffset), curlyBraceDefinition);
                                curlyBraceStartOffset = -1;
                            }
                        }
                        break;
                }
            }
            else
                break;
        }

        // If there are any "open" nodes (never found a matching end), add them too
        if (commentStartOffset != -1)
            this.AddOpenNode(commentStartOffset, multiLineCommentDefinition);
        if (curlyBraceStartOffset != -1)
            this.AddOpenNode(curlyBraceStartOffset, curlyBraceDefinition);
    }
}
​Public Class JavascriptOutliningSource
    Inherits RangeOutliningSourceBase

    Private Shared curlyBraceDefinition As OutliningNodeDefinition
    Private Shared multiLineCommentDefinition As OutliningNodeDefinition

    Shared Sub New()
        curlyBraceDefinition = New OutliningNodeDefinition("CurlyBrace")
        curlyBraceDefinition.IsImplementation = True

        multiLineCommentDefinition = New OutliningNodeDefinition("MultiLineComment")
        multiLineCommentDefinition.DefaultCollapsedContent = "/**/"
        multiLineCommentDefinition.IsImplementation = True
    End Sub

    Public Sub New(ByVal snapshot As ITextSnapshot)
        MyBase.New(snapshot)
        Dim curlyBraceStartOffset As Integer = -1
        Dim curlyBraceLevel As Integer = 0
        Dim commentStartOffset As Integer = -1
        Dim token As IToken

        ' Get a text snapshot reader so that we can read tokens
        Dim reader As ITextSnapshotReader = snapshot.GetReader(0)

        ' Read through the entire snapshot
        Do While Not reader.IsAtSnapshotEnd
            ' Get the next token
            token = reader.ReadToken()
            If token IsNot Nothing Then
                Select Case token.Key
                    Case "MultiLineCommentStartDelimiter"
                        ' A multi-line comment is starting... save its start offset
                        If commentStartOffset = -1 Then
                            commentStartOffset = token.StartOffset
                        End If
                    Case "MultiLineCommentEndDelimiter"
                        ' A multi-line comment is ending... add its range to the outlining source
                        If commentStartOffset <> -1 Then
                            Me.AddNode(New TextRange(commentStartOffset, token.EndOffset), multiLineCommentDefinition)
                            commentStartOffset = -1
                        End If
                    Case "OpenCurlyBrace"
                        ' An open curly brace... save its start offset if it's a top-level brace
                        curlyBraceLevel += 1
                        If curlyBraceLevel = 1 Then
                            If curlyBraceStartOffset = -1 Then
                                curlyBraceStartOffset = token.StartOffset
                            End If
                        End If
                    Case "CloseCurlyBrace"
                        ' A close curly brace... add its range to the outlining source if it's a top-level brace
                        If curlyBraceLevel > 0 Then
                            curlyBraceLevel -= 1
                            If curlyBraceLevel = 0 Then
                                Me.AddNode(New TextRange(curlyBraceStartOffset, token.EndOffset), curlyBraceDefinition)
                                curlyBraceStartOffset = -1
                            End If
                        End If
                End Select
            Else
                Exit Do
            End If
        Loop

        ' If there are any "open" nodes (never found a matching end), add them too
        If commentStartOffset <> -1 Then
            Me.AddOpenNode(commentStartOffset, multiLineCommentDefinition)
        End If
        If curlyBraceStartOffset <> -1 Then
            Me.AddOpenNode(curlyBraceStartOffset, curlyBraceDefinition)
        End If
    End Sub
End Class

This code shows a sample outliner for the outlining source above. Note that since much of the outlining work is occuring in a worker thread, the editor control may already be on a new text snapshot by the time the parsing completes. Therefore we do a quick call to TranslateTo to ensure the data in the outlining source that will be used by the outlining manager are up-to-date with the current snapshot in the editor.

C#
VB
Copy
​public class JavascriptOutliner : IOutliner {

    public IOutliningSource GetOutliningSource(ITextSnapshot snapshot) {
        ICodeDocument document = snapshot.Document as ICodeDocument;
        if (document != null) {
            // Get the outlining source, which should be passed back by the IParser in the parse data
            JavacriptParseData parseData = document.ParseData as JavacriptParseData;
            if ((parseData != null) && (parseData.OutliningSource != null)) {
                // Translate the data to the desired snapshot,
                //   which could be slightly newer than the parsed source
                parseData.OutliningSource.TranslateTo(snapshot);
                return parseData.OutliningSource;
            }
        }
        return null;
    }

    public AutomaticOutliningUpdateTrigger UpdateTrigger {
        get {
            return AutomaticOutliningUpdateTrigger.ParseDataChanged;
        }
    }
}
​Public Class JavascriptOutliner
    Implements IOutliner

    Public Function GetOutliningSource(ByVal snapshot As ITextSnapshot) As IOutliningSource
        Dim document As ICodeDocument = TryCast(snapshot.Document, ICodeDocument)
        If document IsNot Nothing Then
            ' Get the outlining source, which should be passed back by the IParser in the parse data
            Dim parseData As JavacriptParseData = TryCast(document.ParseData, JavacriptParseData)
            If (parseData IsNot Nothing) AndAlso (parseData.OutliningSource IsNot Nothing) Then
                ' Translate the data to the desired snapshot,
                '   which could be slightly newer than the parsed source
                parseData.OutliningSource.TranslateTo(snapshot)
                Return parseData.OutliningSource
            End If
        End If
        Return Nothing
    End Function

    Public ReadOnly Property UpdateTrigger() As AutomaticOutliningUpdateTrigger
        Get
            Return AutomaticOutliningUpdateTrigger.ParseDataChanged
        End Get
    End Property
End Class

The outlining source could be used by a language by registering a custom outliner service:

C#
VB
Copy
​language.RegisterService<IOutliner>(
    new JavascriptOutliner());
​language.RegisterService(Of IOutliner)( _
    New JavascriptOutliner())

Performance Optimizations

Remeber that token-based outlining sources are generally used in the main UI thread and thus can block the UI temporarily if editing a large document and a large incremental outlining update is being made. In cases where this becomes noticable, a range-based outlining source should be used instead. Range-based outlining sources are generally built in a worker thread by a parser, and only cause a minimal UI thread hit when merging the data into the outlining hierarchy.

Code outlining has a lot of dependence on a language's lexer. Therefore a faster lexer can make a huge difference in outlining performance when compared to a slower lexer. Keep this in mind when looking for ways to speed up outlining performance. For instance, if you started off using a dynamic lexer for your language, you should note that while dynamic lexers are great ways to get started, they are the slowest of the lexer types. You can probably achieve a 2-300% code outlining speed increase by switching your language to a programmatic lexer instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Collapsing Regions without Outlining

The code outlining feature decribed in earlier topics supports the collapsing of outlining nodes, where contained text becomes hidden. SyntaxEditor's low-level collapsed region management feature is harnessed to achieve this functionality. This same collapsed regions mechanism can be used independently of code outlining too.

Various text regions can be collapsed (hidden) independent of the outlining features. And in these cases you can even optionally replace the collapsed region with an adornment.

This topic contains these sections:

  • Collapsed Region Manager
  • Tagging Collapsed Regions
  • Rendering Intra-Text Adornments in Place of Collapsed Regions

Collapsed Region Manager

The ICollapsedRegionManager is the object that tracks all the collapsed regions for a particular view. A view's collapsed region manager is accessible via the ITextView.CollapsedRegionManager property.

When the view's text formatting engine builds up layout data for a view line, it consults the collapsed region manager to see if there are any collapsed regions that it needs to be aware of. When one is found, it ignores the contained text and moves onto the remaining text that should be rendered on the view line.

The ICollapsedRegionManager has two main functions:

  • Raise an event when the collapsed regions change
  • Allow consumers to return collapsed regions that contain an offset or interset a text range

RegionsChanged Event

The manager watches all document text changes and also changes published by ICollapsedRegionTag taggers. When any of those changes occur, the manager updates its collapsed regions accordingly. If any regions are added or removed, the RegionsChanged event is raised, passing along the TextSnapshotRange that was changed.

Returning Intersecting Collapsed Regions

The ICollapsedRegionManager.GetCollapsedRange returns the TextSnapshotRange, if any, that contains the specified offset.

The GetCollapsedRanges method returns a NormalizedTextSnapshotRangeCollection of collapsed snapshot ranges that intersect the specified range, if any.

Tagging Collapsed Regions

The ICollapsedRegionTag is a dedicated tag type that the ICollapsedRegionManager watches for and uses to determine which regions are collapsed. SyntaxEditor's text formatting engine then consults the collapsed region manager and uses its data to determine when text should be rendered as collapsed (hidden).

Therefore to collapse a region of text without using code outlining, all you need to do is create a tagger for the ICollapsedRegionTag type and return appropriate tag ranges when requested. You can create a custom class that implements ICollapsedRegionTag and use that in your tagger results. The tagger can in installed by your language via a tagger provider service.

At this point if your tagger is in use by your language, you should notice hidden text wherever your tagger designates.

Rendering Intra-Text Adornments in Place of Collapsed Regions

Collapsed regions by default will not render anything in their place. However there is an option to render an adornment in place of the collapsed region. The code outlining feature uses this option to render the "..." sort of adornments wherever an outlining node is collapsed.

Since the adornments that are inserted in place of collapsed regions should be inserted in between the surrounding text characters, intra-text adornments are used.

Note Note
See the Intra-Text Adornments topic for details on how to create intra-text adornments.

What you do is have an IIntraTextSpacerTag tagger return the same tag ranges as the ICollapsedRegionTag ranges that need adornments. The text formatter will look for intra-text spacers that match the same range as collapsed ranges and will render space in those locations. Then an intra-text adornment manager can place an adornment in that space.

To sum up, an ICollapsedRegionTag is returned by a tagger over a certain range. An IIntraTextSpacerTag is also returned by a tagger over the same range. An intra-text adornment manager places an adornment in the space that has been reserved.

Tip Tip
For this mechanism, you can have a single tagger return both the ICollapsedRegionTag and IIntraTextSpacerTag ranges. Just create the tagger for ICollapsedRegionTag and explicitly implement the interface of ITagger`1 for IIntraTextSpacerTag.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor has full support for editing bi-directional Unicode text, is completely localizable, and implements UI automation.

This topic contains these sections:

  • IME (Input Method Editor) Support
  • Bi-Directional Input Support
  • Localization
  • UI Automation

IME (Input Method Editor) Support

SyntaxEditor has complete support for editing text using IME (Input Method Editor).

IME is a Window feature that allows users to enter characters and symbols not found on their input device. It allows Western keyboards to enter Chinese, Japanese, etc. characters.

See the IME (Input Method Editor) Support topic for more information.

Bi-Directional Input Support

SyntaxEditor is fully natively compatible with extended Unicode characters and even supports bi-directional editing.

See the Bi-Directional Input Support topic for more information.

Localization

All of the strings that are displayed in the user interface can be customized and localized.

See the Localization topic for more information.

UI Automation

SyntaxEditor follows the Microsoft accessibility model for UI automation.

See the UI Automation topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IME (Input Method Editor) Support

SyntaxEditor has complete support for editing text using IME (Input Method Editor).

IME is a Window feature that allows users to enter characters and symbols not found on their input device. It allows Western keyboards to enter Chinese, Japanese, etc. characters.

Note Note
SyntaxEditor's IME features are not available in XBAP applications since they require the use of Windows API calls.

IME support is enabled by default. To disable it for any reason, set the SyntaxEditor.IsImeEnabled property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Bi-Directional Input Support

SyntaxEditor is fully natively compatible with extended Unicode characters and even supports bi-directional editing.

Bi-directional display of text is a tricky thing because as soon as you enter a sequence of right-to-left characters such as Arabic or Hebrew, the entire sequence is flipped over and directional left/right arrow keys move the caret in the opposite direction.

SyntaxEditor showing the partial selection of some Arabic text

In the screenshot above, say you have the caret at the left quote on line 3. If you press your right arrow, the caret moves to column 2, which is considered "before" the Arabic sequence of characters. If you press right arrow again, the caret jumps to "before" the second Arabic character, which visually is to the left of the character left of the rightmost quote. If you press right arrow again, it continues moving one character to the left within the Arabic section. This continues until you reach the leftmost side of the Arabic sequence, where the caret next moves past the right quote. From that point on, right arrow moves to the right since it is back in left-to-right mode.

In the screenshot, the selection was anchored at the start of the "SyntaxEditor" word and then the caret was moved down to the next line into the Arabic sequence of characters. You can see how the selection properly splits to show the contiguous sequence of characters that are selected.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Localization

All of the strings that are displayed in the user interface can be customized and localized.

This topic contains these sections:

  • Customizing String Resources

Customizing String Resources

All strings that are displayed in the user interface are available from static methods on the ActiproSoftware.Products.SyntaxEditor.SR and ActiproSoftware.Products.Text.SR classes. The optional add-on products have their own related SR classes too.

Note Note
String resource customization is described in great detail in the general Customizing String Resources topic. Please see that topic for in-depth information related to localization of string resources.

An enumation named SRName includes a list of all the string resource names. A XAML markup extension named SRExtension is available for use within XAML templates to access string resources.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UI Automation

SyntaxEditor follows the Microsoft accessibility model for UI automation.

What is UI Automation?

Microsoft UI Automation is the new accessibility framework for Microsoft Windows. It addresses the needs of assistive technology products and automated test frameworks by providing programmatic access to information about the user interface (UI).

SyntaxEditor implements automation peers for the following classes:

  • The SyntaxEditor class, which provides access to the current document text, current selection, and various other abilities.
  • The EditorView class, which provides simple scrolling abilities.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

This guide walks through the steps needed to build and use your own syntax languages with SyntaxEditor. Syntax languages are a key part of the SyntaxEditor control product because they are part of the flow that enables syntax highlighting and other features in SyntaxEditor.

To better illustrate, lets examine the flow that occurs when text is typed into a SyntaxEditor to see how a language is involved in determining how the typed text gets rendered.

A diagram that illustrates the general flow of logic from input through to display

A SyntaxEditor control is a code editor that accept input. When typing occurs, it creates a text change and applies it on the attached IEditorDocument. This creates a new immutable snapshot. The snapshot text is analyzed by a lexer and tokens are generated. These tokens are "tagged" by a token tagger and back in the UI layer, the classifications are translated to related highlighting styles via a highlighting style registry. These highlighting styles are then used to tell SyntaxEditor how to render text.

This topic contains these sections:

  • Step-by-Step Walkthrough
  • Creating an ISyntaxLanguage
  • Loading a Language Definition (.langdef File)
  • Service Locator Architecture
  • Feature Services
  • Provider Services
  • Event Sink Services
  • Using a Language

Step-by-Step Walkthrough

Don't know where to get started building a custom syntax language? This walkthrough is the perfect place to go because it gives the steps that should be followed, along with links to many other helpful topics in this documentation.

See the Step-by-Step Walkthrough topic for more information.

Creating an ISyntaxLanguage

The first step in building a language is the creation of a class that implements ISyntaxLanguage.

See the Creating an ISyntaxLanguage topic for more information.

Loading a Language Definition (.langdef File)

The Language Designer application can be used to optionally create files with .langdef file extensions, which are language definitions. These language definition files can be distributed with your application, often in file form or as an embedded resource. They contain information about a language and can be loaded at run-time to automatically create and initialize a language.

See the Loading a Language Definition (.langdef File) topic for details on how to load one of these files at run-time.

Service Locator Architecture

Syntax languages are architected using the Service Locator design pattern, which keeps the ISyntaxLanguage interface small while still allowing for powerful extensibility of features.

Language features such as lexing, token tagger providers, line commenters, etc. can be registered as services on each language instance. Certain service types are well known and extension methods provide easy access to the built-in feature services. Any sort of custom service can be registered with a language and retrieved later as well.

See the Service Locator Architecture topic for more information.

Feature Services

Syntax languages have a wide array of optional features that can be implemented to enhance their capabilities when used with SyntaxEditor.

See the Feature Services topic for more information.

Provider Services

Syntax languages can register multiple instances of service objects implementing provider interfaces. These provider interfaces can help drive features like tagging, adornments, and IntelliPrompt.

See the Provider Services topic for more information.

Event Sink Services

Event sinks are interfaces that allow a language to be notified of events that occur to a SyntaxEditor or IEditorDocument. This could be anything from input events to text change events. The language can choose to process these events and optionally block editor views from receiving them.

See the Event Sinks topic for more information.

Using a Language

Once your syntax language has been configured properly, it's ready for use.

See the Using a Language topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Step-by-Step Walkthrough

Don't know where to get started building a custom syntax language? This walkthrough is the perfect place to go because it gives the steps that should be followed, along with links to many other helpful topics in this documentation.

This walkthough gives you a sequence of concepts to understand when working with syntax languages. Each section in the walkthough provides a brief overview along with links to other documentation topics that give detailed information about the related subject.

This topic contains these sections:

  • Understanding Language Concepts
  • Gathering Language Specifications
  • Using the Language Designer Tool
  • Loading and Using a Language at Run-time
  • Adding Support for Services / Event Sinks
  • Functionality to Language Service Mapping Table
  • Moving Forward

Understanding Language Concepts

A syntax language is an object implementing ISyntaxLanguage that can be assigned to an ICodeDocument to provide language-specific functionality for the document. This functionality can be anything from word-break finding to lexing/parsing, all available via registered services. Multiple syntax languages can be created so that different documents can each receive different functionality.

For instance, the C# language uses different word-break and tokenizing rules than the CSS language does. By having different syntax languages defined for C# and CSS, different functionality can be applied to a document based on the language it currently is using.

  • The Syntax Languages topic talks at a high-level about syntax languages and what they do.
  • The Service Locator Architecture topic talks in-depth about the service locator architecture utilized by syntax languages and how it provides an open and extensible framework for plugging in language features. It also describes the available built-in service types. We will get more into implementing services later in this topic.
  • The Feature Services, Provider Services, and Event Sink Services topics give details on the various built-in service types that are available, but more on that below.

Gathering Language Specifications

Once you understand the basic concepts of what syntax languages do, it's time to think about implementing a custom syntax language for the language(s) you wish to support in your application. Syntax languages are best used in conjunction with SyntaxEditor controls since they provide a full-featured editing experience much like what is found in Visual Studio.

A number of free syntax language samples are included in the sample project. Be sure to check those out since we may have already created a syntax language for the language you wish to support. If one is available, feel free to copy and use it in your application. You can extend or modify it using the concepts we describe below.

If no existing syntax language is available for your target language, you can create one yourself. You will need to go on the Internet and find a language specification for your language. Language specifications generally describe the lexical and semantic structure of a language. They are very important because they tell us the language's keywords, the syntax of comments, etc.

Once you have examined your language's specifications, it's time to use the Language Designer tool.

Using the Language Designer Tool

The Language Designer application was built with the goal of making it easy to get started building a language. You essentially input information about your language and it generates code for you that can be included in your project to use your syntax language.

  • Run through the entire Language Designer documentation section since it discusses the functionality of the application, what pieces of a language can be defined in a language project, how to output code, etc.

Our recommendations for using the application are to follow these steps:

  • Run the application and create a new language project.
  • Set the General Properties for the language.
  • Create a Lexer for the language. A dynamic lexer is the fastest way to get started if you are new to the product.
  • Define the classification types that will be used.
  • Build the language project.
  • Fix any errors that are found.
  • Use the Live Test feature (if the lexer type you use is supported) and test that your lexer is operating correctly.
  • Use the Code Generation feature to output code for the language.

Loading and Using a Language at Run-time

At this point, we assume we have some code for our syntax language. It could have been code generated by the Language Designer application (described above). Or we could have followed the steps in the Creating an ISyntaxLanguage topic to do it by hand.

We are ready to load the language. If we have created a dedicated code-based syntax language class, we create an instance of it. If instead we used the Language Designer to output a language definition (.langdef) file, the Loading a Language Definition topic talks about how to load it.

In either case we now have a variable reference to an ISyntaxLanguage instance. The Using a Language topic talks about how to assign the syntax language to a document to enable its features to be used by the document and related view controls, such as a SyntaxEditor.

We now can run our application and use the language.

Adding Support for Services / Event Sinks

As mentioned in the Service Locator Architecture topic, there are quite a number of other features that can be added to languages via services.

The Feature Services topic lists the various services that implement features for a syntax language. Features can include things like lexers, parsers, line commenters, etc.

Provider Services are services that provide some sort of data upon request. Any language service that implements one of the provider interfaces is automatically called as needed. These services drive features like tagging, adornments, and IntelliPrompt.

Event Sink Services are a category of service types that can be registered with a language and are used to listen to events that take place in a document or an editor control that uses the document. For instance, you can listen to document text change events, key/mouse input events, view selection change events, etc. In each of these events you have the option to handle them within the language. As an example, this provides the ideal place for a syntax language such as HTML to watch for the < character being typed in a SyntaxEditor so that it can show a completion list containing the available HTML tags.

By using the service locator design pattern, syntax languages are very open and extensible. You can further customize a pre-built syntax language by adding your own service implementations.

Functionality to Language Service Mapping Table

There is an enormous amount of functionality available to be implemented via language services, and with this flexibility can understandably come some confusion. This table maps the services that are typically used in a language to implement the specified functionality.

Functionality Notes
Lexer-based syntax highlighting

This functionality is the ability for a lexer to tokenize text and use that information to drive syntax highlighting within a SyntaxEditor.

Requires an ILexer feature service and a token tagger provider service. The token tagger (created for each document by the provider service) tags ranges of text as tokens with a certain IClassificationType.

The classification types that are tagged by the token tagger must be mapped to highlighting styles in a highlighting style registry. Generally the AmbientHighlightingStyleRegistry is used for the mappings.

To sum up, the lexer tokenizes text, the token tagger flags ranges of text with tokens/classification types, and the highlighting style registry tells SyntaxEditor how to convert tagged ranges to syntax highlighted markup.

When loading a syntax language from a language definition (.langdef) file, everything described above is configured for you.

Customized syntax highlighting

While lexers generally provide the core syntax highlighting (via the functionality described above), sometimes you may wish to override the syntax highlighting for certain text ranges, add underlines, change background colors, etc.

To accomplish this a tagger provider service must be used that creates a tagger for IClassificationTag objects. The IClassificationTag interface specifies a IClassificationType. The tagger needs to be set up to be ordered before the TaggerKeys.Token tagger, accomplished via the IOrderable interface, so that its classification types merge into and can override the lexer's existing classifications.

Similar to above, the classification types that are tagged by the tagger must be mapped to highlighting styles in a highlighting style registry. Generally the AmbientHighlightingStyleRegistry is used for the mappings.

The result is that syntax highlighting can be overridden. Multiple layers of customized syntax highlighting can be achieved using this same mechanism.

Parsing (syntax and/or semantic analysis)

Syntax and semantic analysis generally include the parsing of tokens to ensure that code is syntactically correct and valid. Parsing kicks off following text changes. Some form of parse data (which can include an AST, error list, etc.) is returned to the document when the parsing completes. The parsing options can be automatically offloaded into a worker thread so that the complex parsing doesn't cause any locking of the main UI thread.

The first step in setting up parsing is to ensure an ambient parse request dispatcher is installed right at your application's startup. This is vital because it is what allows the parsing to occur in a separate worker thread. If no ambient parse request dispatcher is installed, parsing will occur in the main UI thread. This could cause the editor user interface to slow down, depending on how much work the parser does. Therefore, make sure it is installed to prevent any slowdowns.

Next, register an IParser feature service. Now the parser will be called in a worker thread whenever text changes occur to a document that uses the language.

Actipro offers a very robust LL(*) Parser Framework that makes it simple to build IParser-based parsers using EBNF-like notation in C# and VB. It is free to use, has AST construction, error handling, callbacks, and a lot of other features that make it integrate nicely with our core text/parsing framework.

Alternatively, since a parser just has to implement the IParser interface, any sort of custom parsing can be performed with our generic parsing mechanism.

There are free add-ons that come with SyntaxEditor that make it easy to integrate with popular third-party parsers:

  • ANTLR Add-on
  • Irony Add-on
Automatic outlining support

Automatic outlining is where the document text is scanned and an outlining node hierarchy is constructed based on its contents. The outlining node tree is rendered visually in the editor's outlining margin and end users can expand/collapse nodes. As further text changes occur, the outlining node tree is incrementally updated.

The IOutliningManager is the object that maintains the outlining node hierarhcy. When a language has an IOutliner service registered, the outlining manager knows that the language is capable of performing automatic outlining. The outlining manager uses the outliner service to retrieve an IOutliningSource whenever it needs to update. The outlining source is capable of examining an offset and returning whether an outlining node should start or end there, or neither. There are several base classes included with SyntaxEditor that make it easy to create an outlining source.

An Outliner service is required for automatic outlining support. The Outlining and Collapsing Features series of topics talk about how create outlining sources and define nodes.

Quick info tips for mouse hovers over collapsed regions

The built-in CollapsedRegionQuickInfoProvider service can be registered on a language to allow quick info tips to be automatically displayed when the end user hovers over a collapsed outlining node adornment, such as the "..." blocks.

Line commenting

Line commenting is the ability for SyntaxEditor to comment and uncomment lines with language-specific text. For instance, C# syntax languages can be set up to use // single line comments for line commenting. Or they could be set up to use /* ... */ multi-line comments instead.

This feature requires that an ILineCommenter service be registered with the language.

Text statistics

Text statistics can be quickly constructed for any language. The statistics can include everything from word counts to readability scores. Custom statistics can be be built for each language.

This feature requires that an ITextStatisticsFactory service be registered with the language.

Word break finding

While many syntax languages use the same patterns for determining line breaks, there are some syntax languages that require further customization. For instance, the CSS syntax language needs hyphen (-) characters to be considered word characters.

Custom word break finding functionality can be configured for a language by registering an IWordBreakFinder service with the language.

Automated IntelliPrompt completion (auto-complete and popup list)

IntelliPrompt Completion is an extremely helpful way for end users to maximize their productivity when writing code. Completion sessions support auto-complete via keys like Ctrl+Space and will show a completion list popup when no single auto-completion can be determined.

The IntelliPrompt Completion topic walks through the very extensive list of features available with completion sessions.

Syntax languages have several ways they can be set up to provide automated IntelliPrompt completion.

One or more ICompletionProvider services may be registered on the language. These provider services can be ordered. When a completion provider service is on the language, any Ctrl+Space keys typed by the end user will call the first completion provider to see if it can open a completion session. If it can't, the next provider is checked, and so on. When opening a session, the completion providers determine if auto-complete is allowed, what features are enabled (filtering, auto-shrink, text matching algorithms, etc). The completion provider must also populate the items in the completion session prior to opening it. Completion providers often use a mix of looking at any available document ParseData and token scanning to detemine which sort of items should be in the session, based on the current editor view caret location.

Completion sessions can also be requested when the end user begins to type a new word. This involves having the language register an IEditorDocumentTextChangeEventSink service and in the text changed event notification, check a helper property on the event args that indicates if a new word is being typed. If so, request a completion session. A full sample of this is included in the "Opening a Session in Response to a Typed Character" section of the Completion List topic.

Automated IntelliPrompt quick info

IntelliPrompt Quick Info is the ability to render helpful tooltips related to end user mouse hovers, or related to what is under the caret. The content of a quick info tip can be plain text, formatted text (using an HTML-like markup), or any UIElement.

The IntelliPrompt Quick Info topic walks through the list of features available with quick info sessions.

One or more IQuickInfoProvider services may be registered on the language. These provider services can be ordered. When a quick info provider service is on the language, any mouse hovers by the end user will call the first quick info provider to see if it can open a quick info session. If it can't, the next provider is checked, and so on. The quick info provider populates content in the quick info session prior to it opening. Similar to completion providers, quick info providers often use a mix of looking at any available document ParseData and token scanning to detemine the content that should be presented in the session.

Navigable symbol (type/member) selector support

A Navigable Symbol Selector control is included that can be bound to a SyntaxEditor and supports listing accessible symbols (such as types and members) within a document. The selections within the control update as the editor caret is moved. When a symbol is selected from a dropdown, the caret navigates directly to the related symbol declaration.

The control requires that a feature service is implemented on the language that returns accessible symbols. The IntelliPrompt Navigable Symbol Provider topic walks through how to create such a service.

Code snippet support

IntelliPrompt Code Snippets allow small snippets of code to be inserted into a document. Selection sessions display all available code snippets and allow the end user to easily pick one to activate. Template sessions occur when a code snippet is activated and alllow the end user to tab between pre-defined fields within the code snippet to customize the text that is inserted.

Code snippet features require that an IntelliPrompt code snippet provider is registered on the language, with one or more code snippets loaded into it.

Creating a custom tagger for a document

A custom tagger can be installed into a document by using a tagger provider language service. Once the tagger is installed into the document, tag aggregators for the tag type returned by the tagger will be collected from the tagger and combined with results from other similar taggers.

Custom taggers are often used to drive features like customized syntax highlighting, squiggle line display, adornments, etc.

Automatically render squiggle lines for parse errors with quick info tips

If you are using an IParser feature service on your language, it will return resulting parse data to the ICodeDocument.ParseData property. If the parse data object implements the IParseErrorProvider interface then parse errors can be retrieved from it.

There is a built-in tagger called ParseErrorTagger that can be attached to a document via a document-oriented tagger provider service. See the Tagger Provider topic for details on making tagger provider services.

When this parse error tagger is attached to a document, it will monitor the document's parse data for changes. If the parse data is updated, it will automatically get the list of parse errors from it (assuming the parse data implements IParseErrorProvider) and will return ISquiggleTag tags for each one. This automatically drives the squiggle line display when used in an editor.

The SquiggleTagQuickInfoProvider is an IQuickInfoProvider that presents a Quick Info popup with the contents of ISquiggleTag.ContentProvider. When registered with a language along with a ParseErrorTagger, it will provide the description of a parsing error when you hover the mouse over a text range that is tagged by an ISquiggleTag.

Add custom adornments to a view's text area

An example of adornments that are not related directly to document text content are alternating row highlights. To implement this sort of feature, a custom adornment manager is created that inherits AdornmentManagerBase`1. The manager attaches to the view's TextAreaLayout event and updates its Rectangle higlight adornments based on the document line numbers of the view lines that need adornments.

An adornment manager provider service is required to create adornment manager instances for each view that should use them.

Add custom decoration adornments to specific text ranges

An example of adornments that are related directly to text spans are borders around certain text ranges that indicate find operation results. For scenarios like this, a custom adornment manager is created that inherits DecorationAdornmentManagerBase`2. The base class handles the determination of when to add/update/remove adornments. When a new adornment needs to be added, the AddAdornment method is called. This method is overridden in your inheriting class and the code you implement calls IAdornmentLayer.AddAdornment to add an adornment to the layer.

An adornment manager provider service is required to create adornment manager instances for each view that should use them.

Add custom adornments in between text characters

Any sort of content can be inserted in-line with text, right between text characters. This feature is known as intra-text adornments. The content could be images, controls, or any other UI element.

See the Intra-Text Adornments topic for details on how to use this feature.

Hide text regions (without outlining)

Sometimes you may wish to hide a region of text within a SyntaxEditor view but still keep it in the document. This sort of feature can be attained by "tagging" the desired ranges to hide with ICollapsedRegionTag instances. This feature can be used independently from code outlining. In fact the code outlining feature does use this behind the scenes for collapsed nodes. If you tag the same collapsed regions with an IIntraTextSpacerTag, you can insert an adornment in place of the collapsed region.

See the Collapsing Regions without Outlining topic for details on how to use this feature.

Event notifications

There are a large number of events to which languages can be attached, everything from document text changes to end user input. Events are logically grouped into various event sink services.

Any service registered on a language that implements one of the event sink interfaces is automatically notified whenever a related event occurs.

Auto-indentation

Auto-indent is the ability for SyntaxEditor to automatically indent a new line when the Enter key is pressed. The default behavior is to indent a new line to the same level as the preceeding line.

To override the default behavior, an IIndentProvider service must be registered with the language.

Text formatting

Text formatting is the ability for SyntaxEditor to format the text in a specified range where whitespace and other symbols such as braces are adjusted to make code more readable.

See the Text Formatter topic for more information.

Structure matching (move to matching bracket, etc.)

Structure matching is the ability for SyntaxEditor to find a bracket or other text delimiter that is related to the delimiter that is next to the caret.

See the Structure Matcher topic for more information.

Delimiter highlighting (bracket highlighting)

Delimiter highlighting renders highlights behind delimiter pairs that are currently next to the caret, also known as bracket highlighting.

While the delimiter highlighting feature requires the use of a structure matcher (see above), it also requires that another language service is registered that can tag delimiter highlight ranges.

See the Delimiter Highlighting topic for more information.

Code block selection

Code block selection adjusts the view's selection by expanding it to include containing code blocks and contracting all the way back down to the caret as appropriate.

See the Code Block Selection topic for more information.

Auto-correct, and case correction

An auto-corrector can perform additional edits after text changes, such as auto-case correcting language keywords.

See the Auto-Corrector topic for more information.

Delimiter auto-completion

Delimiter auto-completion is where the user types a start delimiter and a related end delimiter is auto-inserted after the caret.

See the Delimiter Auto-Completer topic for more information.

Moving Forward

This walkthrough should point you in the right direction towards building a custom language. If at any time you find some of the documentation confusing, please contact us and let us know so that we may improve it in the future.

As next steps, look around at the other documentation for the product and examine the sample projects. We provide numerous language samples that you can freely copy and modify.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Creating an ISyntaxLanguage

The first step in building a language is the creation of a class that implements ISyntaxLanguage.

There are three main options for doing this, each of which are described below.

This topic contains these sections:

  • Option 1: Building a SyntaxLanguage Externally
  • Option 2: Creating a Custom Class that Inherits SyntaxLanguage
  • Option 3: Loading a Language Definition (.langdef File)

Option 1: Building a SyntaxLanguage Externally

For languages that only require a couple simple property settings, you may wish to construct the language on the fly. The SyntaxLanguage class implements the ISyntaxLanguage and can be used to accomplish this.

This code creates a language that uses a line commenter which can comment and uncomment lines with the text //.

C#
VB
Copy
​SyntaxLanguage language = new SyntaxLanguage("Dynamic");
// NOTE: Register lexer, parser, or other language services here
language.RegisterLineCommenter(new LineBasedLineCommenter() { StartDelimiter = "//" });
​Dim language As SyntaxLanguage = New SyntaxLanguage("Dynamic")
' NOTE: Register lexer, parser, or other language services here
language.RegisterLineCommenter(New LineBasedLineCommenter() With {.StartDelimiter = "//"})

Note Note
The SyntaxLanguageExtensions.RegisterLineCommenter method in the code snippet above is a helper extension method that get added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Since this language only has a couple options set, there is nothing wrong with defining it this way and using it. Generally, it is better design to use option 2 (below) for more complex languages.

Option 2: Creating a Custom Class that Inherits SyntaxLanguage

Many times language implementations are more complex that the sample illustrated in the previous option. It could be a case of additional configuration/processing needed or you may simply want to have your language completely encapsulated with a dedicated class.

Note Note
The Language Designer tool allows you to quickly configure information about your language. It can generate a lot of the C#/VB code needed to have a dedicated syntax language class and related features. Use of that application is the fastest way to get started making a syntax language.

In any event, if those scenarios apply to you, making a custom language class that inherits SyntaxLanguage is what you'd want to do. SyntaxLanguage implements ISyntaxLanguage and is a perfect base class for any custom language implementation.

This code defines a custom language class that inherits SyntaxLanguage:

C#
VB
Copy
​public class MyCustomSyntaxLanguage : SyntaxLanguage {
    public MyCustomSyntaxLanguage() : base("My Custom Language") {}
}
​Public Class MyCustomSyntaxLanguage
    Inherits SyntaxLanguage
    Public Sub New()
        MyBase.New("My Custom Language")
    End Sub
End Class

The next step would be to add code into your constructor that registers all the language services you wish for you language to provide (lexer, token tagger, line commenter, etc.).

C#
VB
Copy
​public class MyCustomSyntaxLanguage : SyntaxLanguage {
    public MyCustomSyntaxLanguage() : base("My Custom Language") {
        this.RegisterLexer(new MyCustomLexer());
        this.RegisterService(new TokenTaggerProvider<MyCustomTokenTagger>());
        this.RegisterLineCommenter(new LineBasedLineCommenter() { StartDelimiter = "//" });
    }
}
​Public Class MyCustomSyntaxLanguage
    Inherits SyntaxLanguage
    Public Sub New()
        MyBase.New("My Custom Language")

        Me.RegisterLexer(New MyCustomLexer())
        Me.RegisterService(New TokenTaggerProvider(Of MyCustomTokenTagger)())
        Me.RegisterLineCommenter(New LineBasedLineCommenter() With {.StartDelimiter = "//"})
    End Sub
End Class

Note Note
The SyntaxLanguageExtensions.RegisterLexer and SyntaxLanguageExtensions.RegisterLineCommenter methods in the code snippet above are helper extension methods that get added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

After that is complete, the language can be completely instantiated in one line of code:

C#
VB
Copy
​MyCustomSyntaxLanguage language = new MyCustomSyntaxLanguage();
​Dim language As MyCustomSyntaxLanguage = New MyCustomSyntaxLanguage()

Option 3: Loading a Language Definition (.langdef File)

The Language Designer application can be used to optionally create files with .langdef file extensions, which are language definitions. These language definition files can be distributed with your application, often in file form or as an embedded resource. They contain information about a language and can be loaded at run-time to automatically create and initialize a language.

Language definitions can be used to either:

  • Create a new ISyntaxLanguage from scratch that is initialized with data from the language definition, which is focus of this Option 3.
  • Initialize an existing ISyntaxLanguage, which means it can be used in both Option 1 and 2 scenarios listed above to supply the lexer, etc. instead of manually registering code-based ones

See the Loading a Language Definition (.langdef File) topic for details on how to load one of these files at run-time.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Loading a Language Definition (.langdef File)

The Language Designer application can be used to optionally create files with .langdef file extensions, which are language definitions. These language definition files can be distributed with your application, often in file form or as an embedded resource. They contain information about a language and can be loaded at run-time to automatically create and initialize a language.

Read the Language Designer's Getting Started topic for more information on language definitions and when to use them.

Language definition files may be loaded directly from a file, or from a Stream.

This topic contains these sections:

  • Option 1: Loading from a File
  • Option 2: Loading from a Stream
  • Initializing an Existing ISyntaxLanguage Instead

Option 1: Loading from a File

The benefit of distributing the language definition as a file with your application is that end users can modify the language definition if necessary.

This code creates a syntax language object based on a ECMAScript.langdef file:

C#
VB
Copy
​SyntaxLanguageDefinitionSerializer serializer = new SyntaxLanguageDefinitionSerializer();
string path = @"C:\ECMAScript.langdef";
ISyntaxLanguage language = serializer.LoadFromFile(path);
​Dim serializer As SyntaxLanguageDefinitionSerializer = New SyntaxLanguageDefinitionSerializer()
Dim path As String = "C:\ECMAScript.langdef"
Dim language As ISyntaxLanguage = serializer.LoadFromFile(path)

Now that an ISyntaxLanguage object has been created based on the language definition, it can be used.

Option 2: Loading from a Stream

A language definition can also be distributed in any other form, such as an embedded resource, or in a database. Once you have a Stream pointing to the language definition data, it can be loaded.

This code creates a syntax language object based on a Stream in the variable stream:

C#
VB
Copy
​SyntaxLanguageDefinitionSerializer serializer = new SyntaxLanguageDefinitionSerializer();
ISyntaxLanguage language = serializer.LoadFromStream(stream);
​Dim serializer As SyntaxLanguageDefinitionSerializer = New SyntaxLanguageDefinitionSerializer()
Dim language As ISyntaxLanguage = serializer.LoadFromStream(stream)

Now that an ISyntaxLanguage object has been created based on the language definition, it can be used.

Initializing an Existing ISyntaxLanguage Instead

The two loading methods described above load a language definition file and use it to create a new ISyntaxLanguage. However there could be scenarios where you already have an ISyntaxLanguage created but wish to initialize it with language definition data. An example of this is that maybe you wish to ship .langdef files with your app so that end users can customize them. However you have several additional language services (such as a parser) that need to get used on this language as well. In this scenario, you'd want the best of both worlds: to load the lexer, token tagger, and classification types from the .langdef and register your additional services for use as well.

This code snippet shows how a custom language class can be created that both initializes itself based on a .langdef file and also adds additional services.

C#
VB
Copy
​public class EcmaScriptSyntaxLanguage : SyntaxLanguage {
    public EcmaScriptSyntaxLanguage() : base("ECMAScript") {
        // Use a SyntaxLanguageDefinitionSerializer to load a lexer, token tagger, etc. from a .langdef file
        new SyntaxLanguageDefinitionSerializer().InitializeFromFile("C:\ECMAScript.langdef");

        // Register additional services
        this.RegisterParser(new EcmaScriptParser());
        this.RegisterService(new CodeDocumentTaggerProvider<ParseErrorTagger>(typeof(ParseErrorTagger)));
    }
}
​Public Class EcmaScriptSyntaxLanguage
    Inherits SyntaxLanguage
    Public Sub New()
        MyBase.New("ECMAScript")
        ' Use a SyntaxLanguageDefinitionSerializer to load a lexer, token tagger, etc. from a .langdef file
        CType(New SyntaxLanguageDefinitionSerializer(), SyntaxLanguageDefinitionSerializer).InitializeFromFile("C:\ECMAScript.langdef")

        ' Register additional services
        Me.RegisterParser(New EcmaScriptParser())
        Me.RegisterService(New CodeDocumentTaggerProvider(Of ParseErrorTagger)(GetType(ParseErrorTagger)))
    End Sub
End Class

The language can then be instantiated like this:

C#
VB
Copy
​EcmaScriptSyntaxLanguage language = new EcmaScriptSyntaxLanguage();
​Dim language As EcmaScriptSyntaxLanguage = New EcmaScriptSyntaxLanguage()

The SyntaxLanguageDefinitionSerializer class has:

  • An InitializeFromFile method for initializing an existing syntax language from a file, and
  • An InitializeFromStream method for initializing an existing syntax language from a Stream, and

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Service Locator Architecture

Syntax languages are architected using the Service Locator design pattern, which keeps the ISyntaxLanguage interface small while still allowing for powerful extensibility of features.

Language features such as lexing, token tagger providers, line commenters, etc. can be registered as services on each language instance. Certain service types are well known and extension methods provide easy access to the built-in feature services. Any sort of custom service can be registered with a language and retrieved later as well.

This topic contains these sections:

  • What is the Service Locator Design Pattern?
  • Built-In Service Types
  • Helper Extension Methods, and Requirements for Usage
  • Service Add/Remove Events
  • Sample: Registering a Lexer
  • Sample: Retrieving a Lexer
  • Sample: Registering a Completion Provider
  • Sample: Retrieving a Completion Provider

What is the Service Locator Design Pattern?

Our implementation of the Service Locator designer pattern contains four types of methods, two types for registering and unregistering services with a language, and two types for retrieving registered services from a language.

The ISyntaxLanguage.RegisterService and UnregisterService methods are used to register and unregister services with a language. Once a service has been registered with a language, it can be retrieved via the GetService method. That method requires you to pass the service type you are trying to retrieve (see built-in service types table below). To get a collection of all service types that have been registered with a language, use the GetAllServiceTypes method.

The methods described above are generic and allow for any sort of service to be registered with a language. Helper extension methods are available that wrap these generic calls and make it easy to work with the built-in feature service types. Examples of both the extension method calls and generic service method calls are included later in this topic.

Note Note
If no type parameter is passed to the RegisterService method, then the service being registered will be registered under its own Type as the key.

Built-In Service Types

While you can customize a syntax language with any custom services you like, there are a number of built-in service types are that recognized, and they come in three varieties.

Feature Service Types

Many service types require that a service providing a certain function are registered using a specific Type key. These service types are referred to as "feature services", and only one instance of these service types can be registered on a language.

For instance, in order for our code to locate the lexer for the language, we require that the service implementing ILexer is registered with the service Type key ILexer. If the service is registered under any other key, then our code can't locate it.

This table lists the built-in single-instance service types that can be used when adding features to an ISyntaxLanguage. The Service Type column indicates the service Type key that must be used when registering them. Only one of these services may be registered per language instance.

Service Type | Description
IAutoCorrector | Designates the auto-corrector that can perform additional edits after text changes, such as auto-case correcting language keywords.
IDelimiterAutoCompleter | Designates the delimiter auto-completer that can insert end delimiters when a start delimiter is typed by the end user.
IExampleTextProvider | Designates the example text provider that returns a code snippet which can be displayed in an application to show sample code syntax.
IIndentProvider | Designates the indent provider that performs automatic indentation of text when the Enter key is pressed.
ILexer | Designates the lexer that tokenizes text for the language.
ILineCommenter | Designates the line commenter that is capable of commenting and uncommenting lines or a range of text.
INavigableSymbolProvider | Designates the navigable symbol provider that lists the accessible symbols within a document.
IOutliner | Designates the outliner that allows a language to provide automatic outlining (code folding) for a document.
IParser | Designates the parser that performs syntax and/or semantic analysis on code and often returns parse data such as an abstract syntax tree (AST), list of syntax errors, symbol table, etc.
IStructureMatcher | Designates the structure matcher that can locate matching structural text delimiters, such as brackets.
ITextFormatter | Designates the text formatter that adjusts whitespace and other symbols such as braces on a specified text range to make code more readable.
ITextStatisticsFactory | Designates the text statistics factory that is capable of creating customized ITextStatistics objects for a language.
IWordBreakFinder | Designates the word break finder that locates word starts and ends for the language.

Provider Service Types

The next variety of service types is related to being able to provide data for a language. Unlike "feature" services, more than one "provider" service can be registered on a language.

It doesn't matter which service Type key a service is registered under. Therefore if any registered service implements one of these interfaces, it will be used. But be careful to not register more than one service with the same Type key, or else the existing service that with Type key will be removed.

This table lists the built-in multiple-instance service types that can be used when adding providers to an ISyntaxLanguage. The Service Type column indicates the interface that must be implemented by the service for it to be used, however as mentioned above, the service can be registered using any Type key.

Service Type | Description
ICodeSnippetProvider | Designates the code snippet provider that can open display available code snippets for selection and activate a code snippet template session within an editor view.
ICompletionProvider | Designates the completion provider that can open an IntelliPrompt completion session within an editor view, generally initiated by a Ctrl+Space.
IParameterInfoProvider | Designates the parameter info provider that can open an IntelliPrompt parameter info session within an editor view.
IQuickInfoProvider | Designates the quick info provider that can open an IntelliPrompt quick info session within an editor view, generally initiated by mouse hovering.

Event Sink Service Types

The final variety of service types is called "event sinks" and these service types receive various event notifications and process them. Events could be anything from editor view input events to document text change events.

Event sink service types are registered similarly to the rules described in the Provider Service Types section above, where multiple event sinks that have the same interfaces can be registered on a language. To sum up, if any object registered as a service implements one or more of the event sink interfaces, it will be notified when related events occur.

Note Note
See the Event Sinks topic for a list of the built-in event sink service types and what each can do.

Helper Extension Methods, and Requirements for Usage

The SyntaxLanguageExtensions static class contains numerous extension methods that are available on any ISyntaxLanguage instance when the ActiproSoftware.Text namespace is imported. These extension methods wrap the generic service locator methods and implement Register, Unregister, and Get methods for each of the built-in "feature" service types described above.

While it is not necessary to use them since you can just use the core generic service locator methods, they keep your code cleaner and give you some prompting via the Visual Studio member list for which service types are available.

Service Add/Remove Events

The ISyntaxLanguage interface defines two events that provide notifications of when services are added to or removed from a language.

The ServiceAdded event fires whenever a service is added to the language. Likewise the ServiceRemoved event fires whenever a service is removed from the language.

Sample: Registering a Lexer

This section shows some examples of registering a lexer feature service with a language, both via an extension method and generically.

This code registers a lexer in the myLexer variable with a language using a helper extension method:

C#
VB
Copy
​language.RegisterLexer(myLexer);
​language.RegisterLexer(myLexer)

This code registers a lexer in the myLexer variable with a language generically:

C#
VB
Copy
​language.RegisterService<ILexer>(myLexer);
​language.RegisterService(Of ILexer)(myLexer)

Sample: Retrieving a Lexer

This section shows some examples of retrieving a registered lexer service from a language, both via an extension method and generically.

This code retrieves a lexer from a language using a helper extension method:

C#
VB
Copy
​ILexer lexer = language.GetLexer();
​Dim lexer As ILexer = language.GetLexer()

This code retrieves a lexer from a language generically:

C#
VB
Copy
​ILexer lexer = language.GetService<ILexer>();
​Dim lexer As ILexer = language.GetService(Of ILexer)()

Sample: Registering a Completion Provider

This section shows how to register an object as a service that implements ICompletionProvider. Note that since languages can have mutiple objects registered that implement this interface, we will register the service using the object's type.

This code registers an object of type CustomCompletionProvider in the myCompletionProvider variable with a language, using its type:

C#
VB
Copy
​language.RegisterService<CustomCompletionProvider>(myCompletionProvider);
​language.RegisterService(Of CustomCompletionProvider)(myCompletionProvider)

This code does the same thing but the Type key is automatically pulled via reflection, based on the Type of the object referenced by myCompletionProvider. Note that this shortcut cannot be used with "feature" services because those must be registered using the specific interface types described in the table above.

C#
VB
Copy
​language.RegisterService(myCompletionProvider);
​language.RegisterService(myCompletionProvider)

Sample: Retrieving a Completion Provider

This section shows how to retrieve the CustomCompletionProvider class instance that was registered in the previous sample.

C#
VB
Copy
​CustomCompletionProvider provider = language.GetService<CustomCompletionProvider>();
​Dim provider As CustomCompletionProvider = language.GetService(Of CustomCompletionProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Syntax languages have a wide array of optional features that can be implemented to enhance their capabilities when used with SyntaxEditor.

This topic contains these sections:

  • Lexer
  • Parser
  • Outliner
  • Line Commenter
  • Example Text
  • Text Statistics
  • Word Break Finder
  • Indent Provider (Auto-Indent)
  • Text Formatter
  • IntelliPrompt Navigable Symbol Provider
  • Structure Matcher
  • Code Block Finder
  • Auto-Corrector
  • Delimiter Auto-Completer
  • Line Number Provider

Lexer

A lexer is the lowest-level key piece of a syntax language. It examines a stream of text and parses it into tokens that give text ranges meaning. Tokens are then used to support many other language features such as classification.

See the Lexer topic for more information.

Parser

A parser is something that performs syntax and/or semantic analysis on code and often returns parse data such as an abstract syntax tree (AST), list of syntax errors, symbol table, etc. Syntax languages can have parsers registered with them that get called automatically via worker threads when text changes in code documents occur.

See the Parser topic for more information.

Outliner

An outliner returns a language-specific outlining source for a particular ITextSnapshot when requested by an outlining manager. Having an outliner service registered on a language is what tells SyntaxEditor that the language supports automatic outlining.

See the Outliner topic for more information.

Line Commenter

Syntax languages support line commenters, which provide built-in functionality for commenting and uncommenting text based on language-specific delimiters.

See the Line Commenter topic for more information.

Example Text

Syntax languages have to ability to expose a small code snippet showing many of the constructs in the language.

See the Example Text topic for more information.

Text Statistics

While the text/parsing framework includes an implementation of text statistics that provides the most common statistics for text, sometimes it's useful to create custom statistics classes that are tailored to a particular language and can return additional statistics such as comment coverage.

See the Text Statistics topic for more information.

Word Break Finder

While most languages use the same criteria for locating word breaks, some languages like may wish to include a @ character as the start of a word.

See the Word Break Finder topic for more information.

Indent Provider (Auto-Indent)

Syntax languages support indent providers, which provide functionality for auto-indentation of the code when the Enter key is pressed.

See the Indent Provider (Auto-Indent) topic for more information.

Text Formatter

Syntax languages support text formatters, which provide functionality for formatting the layout of whitespace and symbols such as braces to make code more readable.

See the Text Formatter topic for more information.

IntelliPrompt Navigable Symbol Provider

Languages can choose to support an IntelliPrompt navigable symbol provider that lists the accessible symbols within an editor's document. Once a language implements this provider service, the Navigable Symbol Selector control can be paired with a SyntaxEditor to provide VS type/member dropdown-like functionality.

See the IntelliPrompt Navigable Symbol Provider topic for more information.

Structure Matcher

Syntax languages support structure matchers, which provide functionality for locating matching structural text delimiters, such as brackets.

See the Structure Matcher topic for more information.

Code Block Finder

A code block finder finds the snapshot range of a logical code block that contains a specified snapshot range. This service is used to drive the Code Block Selection feature.

See the Code Block Finder topic for more information.

Auto-Corrector

An auto-corrector is a language service that typically occurs after text changes and can fix up things like character casing.

A pre-built class is available that can help add automatic case correction to a language.

See the Auto-Corrector topic for more information.

Delimiter Auto-Completer

A delimiter auto-completer is a language service that can insert an end delimiter when its related start delimiter is typed.

A pre-built class is available that performs nearly all the work of this feature.

See the Delimiter Auto-Completer topic for more information.

Line Number Provider

A line number provider allows the line numbers displayed in a line number margin to be customized. While any string value can be displayed for each view line, one-based integers are most commonly used.

See the Line Number Provider topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lexer

A lexer is the lowest-level key piece of a syntax language. It examines a stream of text and parses it into tokens that give text ranges meaning. Tokens are then used to support many other language features such as classification.

This topic contains these sections:

  • Creating a Lexer for a Language
  • Registering a Lexer with a Language

Creating a Lexer for a Language

The first step when creating a syntax language is to create its lexer.

Please see the text/parsing framework's Lexing series of topics for details on the various types of lexers and the benefits/drawbacks of each.

Once a lexer has been written, it needs to be associated with the language.

Registering a Lexer with a Language

Associating a lexer with a language is done by registering the lexer instance as an ILexer service on the language.

This code, called from a syntax language constructor, assigns a programmatic lexer named MyLexer to the language:

C#
VB
Copy
​public MySyntaxLanguage() {
    this.RegisterLexer(new MyLexer());
}
​Public Sub New()
    Me.RegisterLexer(New MyLexer())
End Sub

Note Note
The SyntaxLanguageExtensions.RegisterLexer method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parser

A parser is something that performs syntax and/or semantic analysis on code and often returns parse data such as an abstract syntax tree (AST), list of syntax errors, symbol table, etc. Syntax languages can have parsers registered with them that get called automatically via worker threads when text changes in code documents occur.

This topic contains these sections:

  • Creating a Parser for a Language
  • Registering a Parser with a Language

Creating a Parser for a Language

Please see the text/parsing framework's Parsing series of topics for details on how to create a parser.

Once a parser has been written, it needs to be associated with the language.

Registering a Parser with a Language

Associating a parser with a language is done by registering the parser instance as an IParser service on the language.

This code, called from a syntax language constructor, assigns a parser named MyParser to the language:

C#
VB
Copy
​public MySyntaxLanguage() {
    this.RegisterParser(new MyParser());
}
​Public Sub New()
    Me.RegisterParser(New MyParser())
End Sub

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Outliner

An outliner returns a language-specific outlining source for a particular ITextSnapshot when requested by an outlining manager. Having an outliner service registered on a language is what tells SyntaxEditor that the language supports automatic outlining.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Outliners are classes implementing IOutliner that provide outlining manager with IOutliningSource objects upon request. Each outliner designated whether the automatic outlining should be performed in the main UI thread when any text change occurs, or if it should be performed in response to a parse data update.

See the Outlining Sources and Outliners topic for details on how to create and work with outlining sources and outliners.

When an outliner is associated with a syntax language, SyntaxEditor knows that the language supports automatic outlining.

Registering with a Language

Any object that implements IOutliner can be associated with a syntax language by registering it as an IOutliner service on the language.

This code creates an outliner for a TokenOutliningSourceBase-based outlining source named JavascriptOutliningSource, and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​TokenOutliner<JavascriptOutliningSource> source = new TokenOutliner<JavascriptOutliningSource>();
language.RegisterOutliner(source);
​Dim source As TokenOutliner(Of JavascriptOutliningSource) = New TokenOutliner(Of JavascriptOutliningSource)()
language.RegisterOutliner(source)

Note Note
The SyntaxLanguageExtensions.RegisterOutliner method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line Commenter

Syntax languages support line commenters, which provide built-in functionality for commenting and uncommenting text based on language-specific delimiters.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Line commenters are classes implementing ILineCommenter that can comment or comment a range of text. The text/parsing framework includes two implementations of line commenters: one that comments out a specific line (like C#'s //) and one that comments out a specific range of text (like XML's <!-- -->).

See the Line Commenting topic for details on how to create and work with line commenter classes.

When a line commenter is associated with a syntax language, SyntaxEditor can take advantage of it to implement its comment and uncomment lines feature.

Registering with a Language

Any object that implements ILineCommenter can be associated with a syntax language by registering it as an ILineCommenter service on the language.

This code creates a line commenter for C# style comments and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​LineBasedLineCommenter commenter = new LineBasedLineCommenter();
commenter.StartDelimiter = "//";
language.RegisterLineCommenter(commenter);
​Dim commenter As LineBasedLineCommenter = New LineBasedLineCommenter()
commenter.StartDelimiter = "//"
language.RegisterLineCommenter(commenter)

Note Note
The SyntaxLanguageExtensions.RegisterLineCommenter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Example Text

Syntax languages have to ability to expose a small code snippet showing many of the constructs in the language.

This can be used in options dialogs to show the current classifications / syntax highlighting settings affect a particular language. In this case, it is best to use code the shows all the various classifications and related highlighting styles.

Basic Concepts

The IExampleTextProvider interface is a simple interface that describes an ExampleText property. The property simply returns a code snippet that can be used by a language for example text purposes.

The ExampleTextProvider class implements the IExampleTextProvider interface and provides an easy way to associate example text with your languages.

Registering with a Language

Any object that implements IExampleTextProvider can be associated with a syntax language by registering it as an IExampleTextProvider service on the language.

This code creates XML example text and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterExampleTextProvider(new ExampleTextProvider("<xml></xml>"));
​language.RegisterExampleTextProvider(New ExampleTextProvider("<xml></xml>"))

Note Note
The SyntaxLanguageExtensions.RegisterExampleTextProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Statistics

While the text/parsing framework includes an implementation of text statistics that provides the most common statistics for text, sometimes it's useful to create custom statistics classes that are tailored to a particular language and can return additional statistics such as comment coverage.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Text statistics are classes that implement ITextStatistics and return numerous statistics about text such as character/line counts, whitespace percentage, etc. The TextStatistics class provides the default implementation of that interface.

See the text/parsing framework's Text Statistics topic for details on how to create and work with text statistics classes.

Registering with a Language

Any object that implements ITextStatisticsFactory can be associated with a syntax language by registering it as an ITextStatisticsFactory service on the language.

Normally a custom factory that creates custom statistics does not need to be implemented. The exception would be if you created a custom ITextStatistics class for your language and would like to use that instead of the default statistics.

This code registers a make-believe custom text statistics factory named CustomTextStatisticsFactory (that creates a make-believe CustomTextStatistics class) with a syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextStatisticsFactory(new CustomTextStatisticsFactory());
​language.RegisterTextStatisticsFactory(New CustomTextStatisticsFactory())

Note Note
The SyntaxLanguageExtensions.RegisterTextStatisticsFactory method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Word Break Finder

While most languages use the same criteria for locating word breaks, some languages like may wish to include a @ character as the start of a word.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Word break finders are classes that implement IWordBreakFinder and navigate text to locate word breaks. The text/parsing framework includes a DefaultWordBreakFinder class that implements IWordBreakFinder using the most common word break finding logic that suits most languages fine.

When making a custom word break finder, the members of IWordBreakFinder must be implemented. The FindCurrentWordStart, FindCurrentWordEnd, FindPreviousWordStart, and FindNextWordStart methods each accept a TextSnapshotOffset that indicates the ITextSnapshot and offset within that snapshot at which to begin scanning. Those methods all return an integer indicating the offset within the same snapshot at which the appropriate word break was found.

Registering with a Language

Any object that implements IWordBreakFinder can be associated with a syntax language by registering it as an IWordBreakFinder service on the language.

The SyntaxLanguage class automatically registers a DefaultWordBreakFinder with itself when it is created, so normally word break finders never need to be set on a language unless a custom one is made.

This code creates a custom word break finder (defined in a make-believe CustomWordBreakFinder class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterWordBreakFinder(new CustomWordBreakFinder());
​language.RegisterWordBreakFinder(New CustomWordBreakFinder())

Note Note
The SyntaxLanguageExtensions.RegisterWordBreakFinder method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider (Auto-Indent)

Syntax languages support indent providers, which provide functionality for auto-indentation of the code when the Enter key is pressed.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Indent providers are classes that implement IIndentProvider that can automatically indent text when the Enter key is pressed.

See the Indent Providers topic for details on how to create and work with indent provider classes.

When an indent provider is associated with a syntax language, SyntaxEditor can take advantage of it to implement its auto-indentation feature.

Registering with a Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

This code creates an XML indent provider and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​XmlIndentProvider indentProvider = new XmlIndentProvider();
language.RegisterIndentProvider(indentProvider);
​Dim indentProvider As XmlIndentProvider = New XmlIndentProvider()
language.RegisterIndentProvider(indentProvider)

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

Syntax languages support text formatters, which provide functionality for formatting the layout of whitespace and symbols such as braces to make code more readable.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Text formatters are classes implementing ITextFormatter that can format a specified range of text. Formatting involves adjusting the layout of whitespace and symbols such as braces to make code more readable.

See the Text Formatting topic for details on how to create and work with text formatter classes.

Registering with a Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

This code creates an XML text formatter and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​XmlFormatter textFormatter = new XmlFormatter();
language.RegisterTextFormatter(textFormatter);
​Dim textFormatter As XmlFormatter = New XmlFormatter()
language.RegisterTextFormatter(textFormatter)

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Navigable Symbol Provider

Languages can choose to support an IntelliPrompt navigable symbol provider that lists the accessible symbols within an editor's document. Once a language implements this provider service, the Navigable Symbol Selector control can be paired with a SyntaxEditor to provide VS type/member dropdown-like functionality.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Navigable Symbols

Navigable symbols are any object that implements the INavigableSymbol interface. The NavigableSymbol class is a default implementation. Symbols represents a type or member within a document's text. They each provide these bits of information:

Member | Description
ContentProvider Property | Gets a Content Provider that creates the content to render for the symbol within UI.
NavigationSnapshotOffset Property | Gets the TextSnapshotOffset within the symbol's source file to navigate when the symbol is selected.
SnapshotRange Property | Gets a TextSnapshotRange indicating the offset range of the symbol within its source file.

So for instance in a C# language, a symbol that represented a class declaration would have a content provider that listed the name of the class, a navigation snapshot offset that was the offset of the class name within the document, and a snapshot range that covered everything from the type's XML comments through to its closing curly brace.

Navigable Request Contexts

When an INavigableSymbolProvider is called to obtain accessible symbols, it is passed an INavigableRequestContext object. This object provides additional information about what is requesting the symbols.

The NavigableRequestContexts.NavigableSymbolSelector is currently the only pre-defined request context, and indicates that a Navigable Symbol Selector control is making the request.

Navigable Symbol Provider

The INavigableSymbolProvider interface is the language service used to return accessible symbols to callers. It has a single GetSymbols method that takes in:

  • An INavigableRequestContext indicating the source of the request.
  • An ITextSnapshot that is the snapshot to examine.
  • An optional parent INavigableSymbol to examine.

If the parent symbol is a null value, it means the request is for all root symbols within the document. If a parent symbol is specified, then the request is for the members of that root symbol.

The ITextSnapshot provides access to its container ICodeDocument, and via that, the document's parse data, which usually contains information such as an AST. That is assuming that the language has a parser that constructs an AST.

The GetSymbols method implementation should use information such as the AST to create INavigableSymbol objects based on the parameters passed in, and then return those symbols. By doing so, controls such as Navigable Symbol Selector can consume this information and provide an advanced editing experience for end users.

This code shows a sample GetSymbols implementation. It assumes that whatever type you use for parse data (in this case our ILLParseData type) has an AST available. Then it calls a AddTypeSymbolsFromAst or AddMemberSymbolsFromAst method (both would need implementation based on your language) and passes along the relevant information needed to build the symbol list.

C#
VB
Copy
​public IEnumerable<INavigableSymbol> GetSymbols(INavigableRequestContext context, ITextSnapshot snapshot, INavigableSymbol parentSymbol) {
    if (context == NavigableRequestContexts.NavigableSymbolSelector) {
        var document = snapshot.Document as ICodeDocument;
        if (document != null) {
            // If there is AST data...
            var parseData = document.ParseData as ILLParseData;
            if ((parseData != null) && (parseData.Ast != null)) {
                // Recurse into the AST
                var symbols = new List<INavigableSymbol>();
                if (parentSymbol != null)
                    this.AddMemberSymbolsFromAst(symbols, parseData.Snapshot ?? snapshot, parseData.Ast, parentSymbol);
                else
                    this.AddTypeSymbolsFromAst(symbols, parseData.Snapshot ?? snapshot, parseData.Ast);

                // Sort (navigationSymbolComparer is a cached NavigableSymbolContentProviderComparer instance)
                symbols.Sort(navigationSymbolComparer);

                return new NavigableSymbolSet(symbols);
            }
        }
    }

    // No results
    return new NavigableSymbolSet(null);
}
​Public Function GetSymbols(ByVal context As INavigableRequestContext, ByVal snapshot As ITextSnapshot, ByVal parentSymbol As INavigableSymbol) As IEnumerable(Of INavigableSymbol)
    If context Is NavigableRequestContexts.NavigableSymbolSelector Then
        Dim document = TryCast(snapshot.Document, ICodeDocument)
        If document IsNot Nothing Then
            ' If there is AST data...
            Dim parseData = TryCast(document.ParseData, ILLParseData)
            If (parseData IsNot Nothing) AndAlso (parseData.Ast IsNot Nothing) Then
                ' Recurse into the AST
                Dim symbols = New List(Of INavigableSymbol)()
                If parentSymbol IsNot Nothing Then
                    Me.AddMemberSymbolsFromAst(symbols, If(parseData.Snapshot, snapshot), parseData.Ast, parentSymbol)
                Else
                    Me.AddTypeSymbolsFromAst(symbols, If(parseData.Snapshot, snapshot), parseData.Ast)
                End If

                ' Sort (navigationSymbolComparer is a cached NavigableSymbolContentProviderComparer instance)
                symbols.Sort(navigationSymbolComparer)

                Return New NavigableSymbolSet(symbols)
            End If
        End If
    End If

    ' No results
    Return New NavigableSymbolSet(Nothing)
End Function

Registering with a Language

Any object that implements INavigableSymbolProvider can be associated with a syntax language by registering it as an INavigableSymbolProvider service on the language.

This code creates a custom navigable symbol provider and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​INavigableSymbolProvider provider = new CustomNavigableSymbolProvider();
language.RegisterNavigableSymbolProvider(provider);
​Dim provider As INavigableSymbolProvider = New CustomNavigableSymbolProvider()
language.RegisterNavigableSymbolProvider(provider)

Note Note
The SyntaxLanguageExtensions.RegisterNavigableSymbolProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Structure Matcher

Syntax languages support structure matchers, which provide functionality for locating matching structural text delimiters, such as brackets.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Structure matchers are classes implementing IStructureMatcher that can scan through text and tokens to find a pair or set of related text delimiters, most often brackets. Once the language service is implemented for structure matching, SyntaxEditor features such as move to matching bracket and select to matching bracket are automatically supported.

See the Structure Matching topic for details on how to create and work with structure matcher classes.

Registering with a Language

Any object that implements IStructureMatcher can be associated with a syntax language by registering it as an IStructureMatcher service on the language.

This code creates a StructureMatcher object and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​StructureMatcher matcher = new StructureMatcher();
language.RegisterStructureMatcher(matcher);
​Dim matcher As StructureMatcher = New StructureMatcher()
language.RegisterStructureMatcher(matcher)

Note Note
The SyntaxLanguageExtensions.RegisterStructureMatcher method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Block Finder

A code block finder finds the snapshot range of a logical code block that contains a specified snapshot range. This service is used to drive the Code Block Selection feature.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Code block finders are classes implementing ICodeBlockFinder that can scan through text, tokens, or AST data to locate the snapshot range of a code block that contains the specified snapshot range. Once the code block finder language service is implemented, SyntaxEditor's Code Block Selection feature can be used.

Registering with a Language

Any object that implements ICodeBlockFinder can be associated with a syntax language by registering it as an ICodeBlockFinder service on the language.

This code creates a LLParseDataCodeBlockFinder object and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​LLParseDataCodeBlockFinder finder = new LLParseDataCodeBlockFinder();
language.RegisterCodeBlockFinder(matcher);
​Dim finder As LLParseDataCodeBlockFinder = New LLParseDataCodeBlockFinder()
language.RegisterCodeBlockFinder(finder)

Note Note
The SyntaxLanguageExtensions.RegisterCodeBlockFinder method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Auto-Corrector

An auto-corrector is a language service that typically occurs after text changes and can fix up things like character casing.

A pre-built class is available that can help add automatic case correction to a language.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language
  • Disabling Auto-Correct

Basic Concepts

Auto-correctors are classes implementing IAutoCorrector with an AutoCorrect method that performs some modification of text over the specified range.

AutoCorrectorBase Class

An abstract AutoCorrectorBase class is available that implements IAutoCorrector, providing a great starting point for an auto-corrector. This class watches for document text changes and caret moves. If a document text change spans multiple lines, auto-correct is immediately called for the affected lines. If a document text change occurs on a single line, a flag is set. When the caret moves to a new line, auto-correct is called for the previously modified line.

All the an inheritor class needs to implement is an override for the AutoCorrect method to perform the actual auto-correct logic.

AutoCaseCorrector Class

The AutoCaseCorrector class inherits AutoCorrectorBase and implements auto-correct behavior to cycle over the tokens in the specified range.

The GetCaseCorrectText method is passed the current ITextSnapshot and the IToken to examine. It returns a string value if there is some auto-correction of text that should be made. It can return null to indicate no auto-correct change is necessary.

The method is virtual and its default implementation looks to see if the token is an IMergableToken. If so, it checks to see if the token didn't match its source lexical pattern in a case sensitive way. In that scenario, it returns the IMergableToken.AutoCaseCorrectText value.

Thus the AutoCaseCorrector can be registered on any language that uses a dynamic lexer and it will work out of the box to provide case correction functionality. Note that the lexer must have some lexical patterns' case sensitivities marked as auto-correct.

For more advanced programmatic lexers, as long as they are mergable, this class can still provide a good base for an auto-case corrector. Simply override the GetCaseCorrectText method and implement logic to determine if the token was a case sensitive match. If it wasn't, return the auto-case corrected text to use.

Registering with a Language

Any object that implements IAutoCorrector can be associated with a syntax language by registering it as an IAutoCorrector service on the language.

This code creates an AutoCaseCorrector object and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​AutoCaseCorrector corrector = new AutoCaseCorrector();
language.RegisterAutoCorrector(corrector);
​Dim corrector As AutoCaseCorrector = New AutoCaseCorrector()
language.RegisterAutoCorrector(corrector)

Note Note
The SyntaxLanguageExtensions.RegisterAutoCorrector method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling Auto-Correct

Auto-correct can be disabled within a SyntaxEditor instance by setting the SyntaxEditor.IsAutoCorrectEnabled property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Delimiter Auto-Completer

A delimiter auto-completer can insert an end delimiter when its related start delimiter is typed. This service is used to drive the Delimiter Auto-Completion feature.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Delimiter auto-completers are classes implementing IDelimiterAutoCompleter that can auto-complete an end delimiter when a start delimiter is typed by the end user. See the Delimiter Auto-Completion topic for details on this feature and how the built-in DelimiterAutoCompleter works.

Registering with a Language

Any object that implements IDelimiterAutoCompleter can be associated with a syntax language by registering it as an IDelimiterAutoCompleter service on the language.

This code creates a DelimiterAutoCompleter object and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​DelimiterAutoCompleter completer = new DelimiterAutoCompleter();
language.RegisterDelimiterAutoCompleter(completer);
​Dim completer As DelimiterAutoCompleter = New DelimiterAutoCompleter()
language.RegisterDelimiterAutoCompleter(completer)

Note Note
The SyntaxLanguageExtensions.RegisterDelimiterAutoCompleter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line Number Provider

A line number provider allows the line numbers displayed in a line number margin to be customized. While any string value can be displayed for each view line, one-based integers are most commonly used.

This topic contains these sections:

  • Basic Concepts
  • Setting the Line Number Origin
  • Registering with a Language

Basic Concepts

Line number providers are classes implementing ITextViewLineNumberProvider that can return the display text for each view line that should appear in the line number margin. The GetLineNumberText method is called for each view line and a string is returned containing the line number display text. This typically is a one-based integer number converted to a string.

The language service also defines a GetLargestLineNumberText that returns the known longest line number text, used for measuring purposes.

The DefaultTextViewLineNumberProvider class implements the ITextViewLineNumberProvider interface and provides a default implementation for one-based integer line numbers. It has several virtual methods that can be overridden to customize results. An instance of DefaultTextViewLineNumberProvider is used if no custom line number provider language service is set.

Setting the Line Number Origin

The IEditorDocument.LineNumberOrigin property is the origin line number to use as the base for the first view line. It defaults to 1, but can be set to any other number as needed. The DefaultTextViewLineNumberProvider implementation uses this origin value for the first view line.

For instance if the first view line in a document is meant to represent the 400th line in some code snippet, set the origin to 400.

Registering with a Language

Any object that implements ITextViewLineNumberProvider can be associated with a syntax language by registering it as an ITextViewLineNumberProvider service on the language.

This code creates a DefaultTextViewLineNumberProvider object and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​DefaultTextViewLineNumberProvider lineNumberProvider = new DefaultTextViewLineNumberProvider();
language.RegisterTextViewLineNumberProvider(lineNumberProvider);
​Dim lineNumberProvider As DefaultTextViewLineNumberProvider = New DefaultTextViewLineNumberProvider()
language.RegisterTextViewLineNumberProvider(lineNumberProvider)

Note Note
The SyntaxLanguageExtensions.RegisterTextViewLineNumberProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Syntax languages can register multiple instances of service objects implementing provider interfaces. These provider interfaces can help drive features like tagging, adornments, and IntelliPrompt.

This topic contains these sections:

  • Tagger Provider
  • Adornment Manager Provider
  • IntelliPrompt Completion Provider
  • IntelliPrompt Quick Info Provider
  • IntelliPrompt Parameter Info Provider
  • IntelliPrompt Code Snippet Provider

Tagger Provider

Tagger provider services allow taggers to be created for a document or view. Each language should provide a token tagger for documents using the language. Token taggers read tokens from the language's lexer and marks them with a logical categorization such as Identifier, Keyword, Comment, or anything else. These classifications can then be translated to highlighting styles, thereby achieving syntax highlighting in SyntaxEditor.

See the Tagger Provider topic for more information.

Adornment Manager Provider

Adornment manager provider services allow adornment layers to be created for a view.

See the Adornment Manager Provider topic for more information.

IntelliPrompt Completion Provider

Languages can choose to support IntelliPrompt completion lists and respond to Ctrl+Space.

See the IntelliPrompt Completion Provider topic for more information.

IntelliPrompt Quick Info Provider

Languages can choose to support IntelliPrompt quick info popups that are automatically displayed when the pointer moves over text and/or other parts of the editor, such as margins.

See the IntelliPrompt Quick Info Provider topic for more information.

IntelliPrompt Parameter Info Provider

Languages can choose to support IntelliPrompt parameter info popups that are automatically displayed when the end user types an invocation, and can provide additional information about the current parameter.

See the IntelliPrompt Parameter Info Provider topic for more information.

IntelliPrompt Code Snippet Provider

Languages can choose to support IntelliPrompt code snippets that provide a way to insert pre-defined fragments of text into the editor. Each code snippet can declare multiple fields of text, and when a code snippet template session is activated in SyntaxEditor, the text is inserted and the end user can tab between the fields to edit their values.

See the IntelliPrompt Code Snippet Provider topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tagger Provider

Tagger provider services allow taggers to be created for a document or view. Each language should provide a token tagger for documents using the language. Token taggers read tokens from the language's lexer and marks them with a logical categorization such as Identifier, Keyword, Comment, or anything else. These classifications can then be translated to highlighting styles, thereby achieving syntax highlighting in SyntaxEditor.

This topic contains these sections:

  • What are Taggers?
  • Token Taggers and Syntax Highlighting
  • Registering with a Syntax Language

What are Taggers?

Taggers are objects that can apply data (in the form of tags) over various text ranges. This data could be anything from classifications, to squiggle tags, and more. Since each tagger can only be associated with a single document or view, tagger provider services are used to create taggers for documents/views upon request.

See the Taggers and Tagger Providers topic for details on how taggers and providers work.

Taggers are used for many features of SyntaxEditor including being involved in:

  • Classification
  • Syntax highlighting
  • Snapshot reading by token
  • Squiggle lines
  • Adornment layer managers

Token Taggers and Syntax Highlighting

As mentioned above, token taggers are special classes that are used to provide classification and token tags. When working with an editor like SyntaxEditor, the token tagger reads tags from the language's lexer and can return associated classifications, that are mapped to highlighting styles and used to achieve syntax highlighting.

Therefore if you need syntax highlighting, your language must have a lexer service, a token tagger provider service, and must have set up classification types to have mapped to highlighting styles in the ambient highlighting style registry.

Registering with a Syntax Language

As described in the Taggers and Tagger Providers topic, CodeDocumentTaggerProvider`1, TextViewTaggerProvider`1, and TokenTaggerProvider`1 objects can be used as language services to provide taggers to any tag aggregator that request them.

This code shows how to register a document-oriented tagger provider language service that provides ParseErrorTagger objects for documents that use the language. Note that we are also passing a "singleton" key so that the tagger that is created for any document using the language is persisted in the document's Properties dictionary while it is active.

C#
VB
Copy
​language.RegisterService(new CodeDocumentTaggerProvider<ParseErrorTagger>(typeof(ParseErrorTagger)));
​language.RegisterService(New CodeDocumentTaggerProvider(Of ParseErrorTagger)(GetType(ParseErrorTagger)))

This code shows how to register a document-oriented token tagger provider language service. Token taggers automatically persist themselves in the document's Properties dictionary while they are active. Only one token tagger provider service should ever be registered on a language instance at a time.

C#
VB
Copy
​language.RegisterService(new TokenTaggerProvider<TokenTagger>());
​language.RegisterService(New TokenTaggerProvider(Of TokenTagger)())

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Adornment Manager Provider

Adornment manager provider services allow adornment layers to be created for a view.

This topic contains these sections:

  • What are Adornment Managers?
  • Registering with a Syntax Language

What are Adornment Managers?

Adornment managers are objects that create an adornment layer and add/update/remove adornment objects within the layer. Layers can be ordered around any other layer (text foreground, selection, etc.) and adornments can consist of any element. This allows for any sort of custom content to be rendered within the text area. Since each adornment manager can only be associated with a single view, adornment manager provider services are used to create adornment managers for views upon request.

See the Adornment Layers topic for details on how adornments, adornment layers, and providers work.

Adornment managers are used for rendering many built-in features of SyntaxEditor such as:

  • Caret
  • Selection
  • Squiggle lines

Registering with a Syntax Language

As described in the Adornment Layers topic, AdornmentManagerProvider`1 objects can be used as language services to provide adornment managers to any text view that requests them.

This code shows how to register an adornment manager provider language service that returns AlternatingRowsAdornmentManager objects (defined in a QuickStart to provide alternating row highlights). for views that use the language. Note that we are also passing a "singleton" key so that the adornment manager that is created for any view using the language is persisted in the views's Properties dictionary while it is active.

C#
VB
Copy
​language.RegisterService(new AdornmentManagerProvider<AlternatingRowsAdornmentManager>(typeof(AlternatingRowsAdornmentManager)));
​language.RegisterService(New AdornmentManagerProvider(Of AlternatingRowsAdornmentManager)(GetType(AlternatingRowsAdornmentManager)))

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Completion Provider

Languages can choose to support IntelliPrompt completion lists and respond to Ctrl+Space.

This topic contains these sections:

  • Basic Concepts
  • The CompletionProviderBase Base Class
  • Registering with a Language
  • Ordering Providers

Basic Concepts

The ICompletionProvider interface defines a single method: RequestSession. This method has a parameter that indicates the IEditorView in which to open the session and a boolean parameter that indicates whether to auto-complete if a single match is found.

SyntaxEditor is wired up to automatically call this method if a completion provider is registered as a service on the current language when Ctrl+Space is typed by the end user.

RequestSession can also be called directly in your code if you wish to generically initiate a completion session, assuming the language supports it.

Implementors of the method should use code to examine the context of the caret in the view. This may involve token scanning and/or AST examination if available. Based on the context (in a method declaration, in a type declaration, in a documentation comment, etc.), a completion session should be opened if appropriate.

The CompletionProviderBase Base Class

The easiest way to implement an ICompletionProvider for a language is to inherit the CompletionProviderBase class. Then just override its abstract RequestSession method.

Registering with a Language

Any object that implements ICompletionProvider can be associated with a syntax language by registering it as an ICompletionProvider service on the language.

This code registers a completion provider in the completionProvider variable with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(completionProvider);
​language.RegisterService(completionProvider)

It is a common practice for a language itself to implement the ICompletionProvider interface and register itself as a completion provider service.

Ordering Providers

The ICompletionProvider interface inherits the IOrderable interface. When multiple language services are registered that implement ICompletionProvider, they can be ordered. The highest priority provider will be used first. If it indicates that a session was opened, no other providers will be used. If it indicates that a session was not opened, the next provider is checked, and so on. This allows for layering of multiple providers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Quick Info Provider

Languages can choose to support IntelliPrompt quick info popups that are automatically displayed when the pointer moves over text and/or other parts of the editor, such as margins.

This topic contains these sections:

  • Basic Concepts
  • The QuickInfoProviderBase Base Class
  • Registering with a Language
  • Ordering Providers
  • Showing Quick Info Based on a Button Click
  • Built-In Quick Info Provider for Collapsed Outlining Nodes
  • Built-In Quick Info Provider for Squiggle Tags

Basic Concepts

Context Retrieval

The IQuickInfoProvider defines two GetContext method overloads, both of quick are expected to return a context object given a certain parameter. One overload accepts an IHitTestResult (from a pointer event) and the other overload accepts a zero-based text offset.

A context object can be anything, but it should be some custom type that gives enough information to provide to the RequestSession method later and have that method be able to create a quick info session based on the context. It also must implement value equality via an Equals method override.

Implementors of these methods should use code to examine the context of the hit test result or offset in the view. This may involve token scanning and/or AST examination if available. The context data (in a method declaration, in a type declaration, in a documentation comment, etc.) should be wrapped within the context object retuned by the GetContext methods.

How Contexts Are Used

Context objects should always be stored in the IQuickInfoSession.Context property. As pointer movements occur, a quick info provider repeatedly calls the GetContext method with related pointer hit test results. If the context of an open quick info session matches (value equality) the GetContext return value, the provider knows that no new quick info session needs to be displayed. If GetContext returns a null value, then any existing open quick info session should be closed. If GetContext returns a context that doesn't match the existing session's context, or there is no existing open session, the RequestSession method is called, passing along the new context to use.

Note Note
All context objects must implement an Equals method override so that value equality functions properly.

Requesting a Session

The final method in the IQuickInfoProvider interface is RequestSession. This method is automatically called whenever a new context object has been retrieved that should be used to create and open a new quick info session.

Implementations of this method should create a new quick info session, store the passed context in its Context property, build its content based on the data in the context object, and open the quick info session (show it).

The QuickInfoProviderBase Base Class

The IQuickInfoProvider interface implements IEditorViewPointerInputEventSink and thus is able to process pointer (e.g. pointer) input from within a SyntaxEditor. There is some complicated code needed to do this processing, which is wrapped up in the handy abstract QuickInfoProviderBase class.

The easiest way to implement an IQuickInfoProvider for a language is to inherit the QuickInfoProviderBase class. Then just override its abstract members.

By default its virtual GetContext overload that takes an IHitTestResult is designed to see if the hit is over a character in the text area and if so, call the other abstract GetContext overload that accepts an offset. This is done since most of the time, a quick info provider will be used for showing quick info popups related to text content. To support quick info popups for other parts of the editor, override the GetContext overload that takes an IHitTestResult.

A QuickInfoProviderBase-based provider will automatically close a quick info session it created when appropriate. However to do this, it needs to know which Type of context objects can be returned by its GetContext methods. The ContextTypes property must be implemented to provide this information. For instance, if a quick info provider can return a context object of type KeywordQuickInfoContext from GetContext, then the ContextTypes should return the KeywordQuickInfoContext type.

Registering with a Language

Any object that implements IQuickInfoProvider can be associated with a syntax language by registering it as an IQuickInfoProvider service on the language.

This code registers a quick info provider in the quickInfoProvider variable with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(quickInfoProvider);
​language.RegisterService(quickInfoProvider)

Ordering Providers

The IQuickInfoProvider interface inherits the IOrderable interface. When multiple language services are registered that implement IQuickInfoProvider, they can be ordered. The highest priority provider will be used first. If it indicates that a session was opened, no other providers will be used. If it indicates that a session was not opened, the next provider is checked, and so on. This allows for layering of multiple providers.

Showing Quick Info Based on a Button Click

Many applications provide some sort of Display Quick Info button in their application toolbar. When displaying quick info popups in this mode, pointer move/hover input should be ignored until the next quick info session is requested.

This code handles a button click event and shows how to properly focus the editor, get the current IQuickInfoProvider, create a context based on the offset of the caret, and request a quick info session:

C#
VB
Copy
​private void OnShowQuickInfoButtonClick(object sender, RoutedEventArgs e) {
    // Focus the editor
    editor.Focus();

    // Get the IQuickInfoProvider that is registered with the language
    IQuickInfoProvider provider = editor.Document.Language.GetService<IQuickInfoProvider>();
    if (provider != null) {
        // Create a context
        object context = provider.GetContext(editor.ActiveView, editor.Caret.Offset);

        if (context != null) {
            // Request that a session is created based on the context, and disable pointer tracking since
            //   this request is initiated from a button click
            provider.RequestSession(editor.ActiveView, context, false);
        }
    }
}
​Private Sub OnShowQuickInfoButtonClick(ByVal sender As Object, ByVal e As RoutedEventArgs)
    ' Focus the editor
    editor.Focus()

    ' Get the IQuickInfoProvider that is registered with the language
    Dim provider As IQuickInfoProvider = editor.Document.Language.GetService(Of IQuickInfoProvider)()
    If provider IsNot Nothing Then
        ' Create a context
        Dim context As Object = provider.GetContext(editor.ActiveView, editor.Caret.Offset)

        If context IsNot Nothing Then
            ' Request that a session is created based on the context, and disable pointer tracking since
            '   this request is initiated from a button click
            provider.RequestSession(editor.ActiveView, context, False)
        End If
    End If
End Sub

Built-In Quick Info Provider for Collapsed Outlining Nodes

When using the code outlining features, sometimes the end user will collapse outlining nodes. By default, nothing happens when the pointer is hovered over a collapsed outlining node adornment (normally a box with "..." in it). However there is a built-in IQuickInfoProvider implementation called CollapsedRegionQuickInfoProvider that watches for pointer hovers over collapsed regions and will automatically show a quick info tip with the contained content on pointer hovers.

To enable this feature simply register a CollapsedRegionQuickInfoProvider instance as a service on your language. Note that if you register other IQuickInfoProvider services, make sure they are not handling scenarios that would normally be picked up by the CollapsedRegionQuickInfoProvider. You could order them after the CollapsedRegionQuickInfoProvider (see Ordering Providers section above) to ensure they occur after it is already checked.

This code registers the built-in CollapsedRegionQuickInfoProvider service with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(new CollapsedRegionQuickInfoProvider());
​language.RegisterService(New CollapsedRegionQuickInfoProvider())

If you wish to customize the content of the popup from its default, create a class that inherits CollapsedRegionQuickInfoProvider and override its GetContent method. That method is passed a TextSnapshotRange and returns the content to display for that range. Then register an instance of this custom class as the service instead.

Built-In Quick Info Provider for Squiggle Tags

When using the parsing framework and the ParseErrorTagger (or other custom tagger that uses SquiggleTag tags), there will be squiggle adornments in the document window. By default, nothing happens when the pointer is hovered over these adornments. However, there is a built-in IQuickInfoProvider implementation called SquiggleTagQuickInfoProvider that watches for pointer hovers over squiggle adorned regions and will automatically show a quick info tip with the parse error description on pointer hovers.

To enable this feature, simple register a SquiggleTagQuickInfoProvider instance as a service on your language. Note that if you register other IQuickInfoProvider services, make sure they are not handling scenarios that would normally be picked up by the SquiggleTagQuickInfoProvider. You could order them after the SquiggleTagQuickInfoProvider (see Ordering Providers section above) to ensure they occur after it is already checked.

This code registers the built-in SquiggleTagQuickInfoProvider service with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(new SquiggleTagQuickInfoProvider());
​language.RegisterService(New SquiggleTagQuickInfoProvider())

Implementation Notes

SquiggleTagQuickInfoProvider works by looking for any tags that are at the text offset under the pointer when a pointer hover event is detected. It uses an ITagAggregator`1 for tag type ISquiggleTag that queries each appropriate tagger with a single snapshot range containing the target offset.

Since nothing within SyntaxEditor caches displayed squiggle tags, taggers must return at least one tag that contains the target offset for quick info to show.

Collection taggers are often a good choice for marking errors. They work like a collection where you can add/remove tags like SquiggleTag. In fact, our very own ParseErrorTagger is a CollectionTagger`1. Collection taggers are described in detail in the Taggers and Tagger Providers topic and support the SquiggleTagQuickInfoProvider requirements well.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Parameter Info Provider

Languages can choose to support IntelliPrompt parameter info popups that are automatically displayed when the end user types an invocation, and can provide additional information about the current parameter.

This topic contains these sections:

  • Basic Concepts
  • The ParameterInfoProviderBase Base Class
  • Registering with a Language
  • Ordering Providers

Basic Concepts

The concepts described below are overviews of how to implement a parameter info provider. Please pair this information with the QuickStarts in the Sample Browser for IntelliPrompt Parameter Info and the Getting Started series sample that implements parameter info to see fully-implemented examples.

Requesting a Session

The IParameterInfoProvider interface defines a single method: RequestSession. This method has a parameter that indicates the IEditorView in which to open the session.

RequestSession can be called directly in your code if you wish to generically initiate a parameter info session, assuming the language supports it. A common usage of this is to have the provider implement the IEditorDocumentTextChangeEventSink interface and watch for typing events where the user enters ( or , characters.

Implementors of the RequestSession method should use code to examine the context of the caret in the view. This may involve token scanning and/or AST examination if available, and the resulting context should indicate if the caret is in an invocation of some sort, such as a method call. If it is, the argument index and argument list's start offset should also be specified in the context data, as this information is important for the tracking of parameter info sessions.

Assuming that the context indicates that the caret is within an invocation, the provider should gather information about the invoked member (including overloads when appropriate), create a parameter info session, and add those as signature items to the session being created, as described in the IntelliPrompt parameter info topic. Finally, the session should be opened with the argument list start offset used as the text range.

Watching the Caret

The next task a parameter info provider needs to do is watch the caret to determine if it moves to another argument index, nested invocation, or outside of a valid invocation range altogether. This can be achieved by having the parameter info provider implement the IEditorViewSelectionChangeEventSink interface.

In the selection change notification, if there is a parameter info session already open, a new context object should be retrieved (similar to the context retrieval when requesting a session) for the caret's location. If the argument list's start offset has changed, the open session should be closed and a request for a new session should be made in the event the caret has moved into a nested invocation.

Bolding the Current Parameter

If the content providers used in the session's signature items implement the IParameterizedContentProvider interface, the current parameter index can be specified to them. This allows them to alter the content that they display so that the current parameter has attention drawn to it, such as by a boldface font.

In this scenario, a method should be added to the parameter info provider that can examine a context and enumerate through a session's signature items to update the IParameterizedContentProvider.ParameterIndex property of each item's content provider, based on which argument index the context indicates that the caret is currently in. If the session is already open and any updates are made to the current argument index, the IParameterInfoSession.Refresh method should be called to force an update to the displayed content.

The method to update the current parameters should be called in two places. First is immediately before the a session is first opened, in RequestSession. Second is in the selection change handler, if it is detected that the caret is still within the same argument list. This can be determined by if the context's argument list start offset matches the currently-open session's snapshot range start offset.

The ParameterInfoProviderBase Base Class

The easiest way to implement an IParameterInfoProvider for a language is to inherit the ParameterInfoProviderBase class. Then just override its abstract RequestSession method.

Registering with a Language

Any object that implements IParameterInfoProvider can be associated with a syntax language by registering it as an IParameterInfoProvider service on the language.

This code registers a parameter info provider in the parameterInfoProvider variable with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(parameterInfoProvider);
​language.RegisterService(parameterInfoProvider)

Ordering Providers

The IParameterInfoProvider interface inherits the IOrderable interface. When multiple language services are registered that implement IParameterInfoProvider, they can be ordered. The highest priority provider will be used first. If it indicates that a session was opened, no other providers will be used. If it indicates that a session was not opened, the next provider is checked, and so on. This allows for layering of multiple providers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Code Snippet Provider

Languages can choose to support IntelliPrompt code snippets that provide a way to insert pre-defined fragments of text into the editor. Each code snippet can declare multiple fields of text, and when a code snippet template session is activated in SyntaxEditor, the text is inserted and the end user can tab between the fields to edit their values.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language
  • Ordering Providers

Basic Concepts

Code snippet providers, represented by the ICodeSnippetProvider interface and implemented by the CodeSnippetProvider class, serve several purposes when registered as a service on a language:

  • They let other code know that code snippets are supported for the language.
  • They make the available code snippets accessible.
  • They allow for selection sessions to be opened.
  • They watch for Tab to be pressed after a code snippet shortcut, and open a template session in response.
  • They allow for the various template session adornments to be displayed.

A CodeSnippetProvider class instance can be used directly as the service.

Loading a Root Folder

The ICodeSnippetProvider.RootFolder property needs to be set to an ICodeSnippetFolder instance that has loaded code snippet metadata into itself or one of its nested folders. This is required for certain functionality to be enabled.

The IntelliPrompt code snippets topic discusses ways to populate a folder, including the ability to recursively load from a file system folder.

Setting Case Sensitivity

The ICodeSnippetProvider.IsCaseSensitive property can be set to false for languages that don't require that code snippet shortcuts be matched with exact case.

Registering with a Language

Any object that implements ICodeSnippetProvider can be associated with a syntax language by registering it as an ICodeSnippetProvider service on the language.

This code registers a code snippet provider in the codeSnippetProvider variable with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(codeSnippetProvider);
​language.RegisterService(codeSnippetProvider)

Ordering Providers

The ICodeSnippetProvider interface inherits the IOrderable interface. When multiple language services are registered that implement ICodeSnippetProvider, they can be ordered. The highest priority provider will be used first. If it indicates that a session was opened, no other providers will be used. If it indicates that a session was not opened, the next provider is checked, and so on. This allows for layering of multiple providers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Event Sink Services

Event sinks are interfaces that allow a language to be notified of events that occur to a SyntaxEditor or IEditorDocument. This could be anything from input events to text change events. The language can choose to process these events and optionally block editor views from receiving them.

Event sinks use the service locator architecture and thus are managed as services. This design has several benefits:

  • Event notifications can be prioritized (IntelliPrompt sessions receive events before languages, etc.)
  • Custom event sink handlers can be externally swapped in without inheriting a language class
  • There are no extra ties between a SyntaxEditor, IEditorDocument, or ISyntaxLanguage meaning less chance for memory leaks
  • Languages continue to use basic .NET 2.0-based techniques for event handling, keeping their code platform independent

Note Note
The Service Locator Architecture topic contains a lot of information that is necessary to understand when working with event sinks.

This topic contains these sections:

  • Built-In Event Sink Service Types
  • Sample: Implementing an Event Sink for Listening to Text Changes

Built-In Event Sink Service Types

This table lists the built-in event sink service types that can be used with ISyntaxLanguage. Note that multiple objects implementing these interfaces can be registered as language services, as long as they are registered using separate Type keys.

Service Type | Description
IActiveEditorViewChangeEventSink | An object that can be notified of SyntaxEditor.ActiveView change events.
ICodeDocumentLifecycleEventSink | An object that can be notified of when an ICodeDocument becomes associated and disassociated with a language, via events such as a language change.
ICodeDocumentPropertyChangeEventSink | An object that can be notified of when attached ICodeDocument properties, such as ParseData or FileName, are changed.
ICodeSnippetTemplateSessionEventSink | An object that can be notified of various events occur related to a code snippet template session. See the Code Snippets documentation for more information.
IEditorDocumentTextChangeEventSink | An object that can be notified of IEditorDocument text change events, both before and after a text change occurs.
IEditorViewKeyInputEventSink | An object that can be notified of IEditorView keyboard input events, both key down and up. These input events can be intercepted before the editor view ever receives them.
IEditorViewPointerInputEventSink | An object that can be notified of IEditorView pointer input events, including all standard mouse events. These input events can be intercepted before the editor view ever receives them.
IEditorViewSelectionChangeEventSink | An object that can be notified of IEditorView selection change events.
IEditorViewTextInputEventSink | An object that can be notified of IEditorView text input events. These input events can be intercepted before the editor view ever receives them.
ITextViewLifecycleEventSink | An object that can be notified of when an ITextView becomes associated and disassociated with a language, via events such as view open/close, document change, or language change.

Sample: Implementing an Event Sink for Listening to Text Changes

For this sample, assume that you are implementing an HTML language and wish to watch for < being typed so that you know when to show a completion list of HTML tags. To do this, we'll work with the IEditorDocumentTextChangeEventSink, which notifies after text changes occur. We examine typed text to look for < characters.

Registering the Event Sink

As mentioned above, event sinks use the service locator architecture. In this sample, we'll have our language class itself implement the IEditorDocumentTextChangeEventSink interface and in the language's constructor, we'll register itself as a service for that service type.

This code registers the language itself as an IEditorDocumentTextChangeEventSink service:

C#
VB
Copy
​public class HtmlSyntaxLanguage : SyntaxLanguage, IEditorDocumentTextChangeEventSink }
    public HtmlSyntaxLanguage() : base("HTML") {
        // Other initialization here
        this.RegisterService<IEditorDocumentTextChangeEventSink>(this);
    }
}
​Public Class HtmlSyntaxLanguage
    Inherits SyntaxLanguage
    Implements IEditorDocumentTextChangeEventSink

    Public Sub New()
        MyBase.New("HTML")
        ' Other initialization here
        Me.RegisterService(Of IEditorDocumentTextChangeEventSink)(Me);
    End Sub
End Class

Note Note
See the Service Locator Architecture topic for details on registering and retrieving various service object instances.

Implementing the IEditorDocumentTextChangeEventSink Interface

Next we implement the interface on the language. Again, we could have implemented this interface on any other object and registered that instead but for simplicity, we have chosen to implement it on the language itself.

This code shows the two methods on the interface, added into the language class:

C#
VB
Copy
​void IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanged(SyntaxEditor editor, EditorSnapshotChangedEventArgs e) {
    // The e.TypedText is not null only when a Typing change occurs with a single operation that inserts text,
    //   so we can check that to display the completion list when "<" is typed
    if (e.TypedText == "<") {
        // Show completion list containing tags here
    }
}

void IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanging(SyntaxEditor editor, EditorSnapshotChangingEventArgs e) {
    // Nothing needs to be done here
}
​Private Sub NotifyDocumentTextChanged(ByVal editor As SyntaxEditor, ByVal e As EditorSnapshotChangedEventArgs) _
    Implements IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanged

    ' The e.TypedText is not null only when a Typing change occurs with a single operation that inserts text,
    '   so we can check that to display the completion list when "<" is typed
    If e.TypedText = "<" Then
        ' Show completion list containing tags here
    End If
End Sub

Private Sub NotifyDocumentTextChanging(ByVal editor As SyntaxEditor, ByVal e As EditorSnapshotChangedEventArgs) _
    Implements IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanging
    ' Nothing needs to be done here
End Sub

Note that in the text changed handler, we look to see if text that was typed was the < character. If that scenario occurred, we'd call code to display a completion list.

Of course we may also wish to add code to ensure we didn't type within a comment, etc. This logic could be added by getting an ITextSnapshotReader and examining the token that was typed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Using a Language

Once your syntax language has been configured properly, it's ready for use.

This topic contains these sections:

  • Using with an ICodeDocument or SyntaxEditor
  • Packaging Options

Using with an ICodeDocument or SyntaxEditor

Using with an ICodeDocument

The ICodeDocument interface designates the requirements for a document that can by parsed by a syntax language. It defines a Language property that accepts any ISyntaxLanguage instance. Therefore, to have a document use a syntax language, simply assign it to that property.

This code creates a new IEditorDocument (which inherits ICodeDocument) and assigns an ISyntaxLanguage that is already defined in the language variable:

C#
VB
Copy
​IEditorDocument document = new EditorDocument();
document.Language = language;
​Dim document As IEditorDocument = New EditorDocument()
document.Language = language

The ICodeDocument.LanguageChanged event fires whenever the document's Language property changes. Its event arguments pass the old and newly-assigned languages.

Using with a SyntaxEditor

Since IEditorDocument is the property type for the SyntaxEditor.Document property, assigning an ISyntaxLanguage to be used for a SyntaxEditor control is done the same way.

In that scenario, the SyntaxEditor's document is assigned the language like this:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

The SyntaxEditor.DocumentLanguageChanged event wraps the ICodeDocument.LanguageChanged event and is an easy way to be notified whenever a new language is assigned to the document currently being edited in a SyntaxEditor.

Packaging Options

There are a few options for packaging the custom languages you've created with your application. It is completely up to you as to how you package things, since any of these options work fine.

Included in Application Assembly

The easiest way is to include a custom language and its related classes right in your main application assembly.

Included in Library Assembly

For languages that tend to be more complex and use a lot of optional features, it's probably better design to separate them out into a single library assembly. This allows you to maintain your language in a project that is independent of your UI project.

Included in Library Assemblies with Text/UI Separation

This option is similar to the previous one where the language is in its own assembly, however in this option the language and its classes are split into two assemblies: one for text/parsing and one for UI. This option is how we deploy our optional language add-ons. It is generally only used in scenarios where you plan on using the same text/parsing code across multiple platforms (WPF, WinForms, etc.).

The first assembly contains only the core text and parsing related classes. This keeps it truly platform independent since there are no references to any UI platforms (WPF, WinForms, etc.) in the code.

The second assembly is platform dependent and includes code specifically for working with SyntaxEditor for WPF, etc. Language functionality that interacts with IntelliPrompt would be included here.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The Language Designer tool is an application that has many helpful features for quickly developing language definitions. It is an option when installing the WPF controls.

This application uses several of the WPF Studio control products, such as Ribbon, Docking & MDI, Editors, Navigation, PropertyGrid, and SyntaxEditor, and is a nice showcase of what you can do with our products.

Its main goal is to provide you with a user interface for creating a language project, which is essentially a profile about a syntax language. Various language features such as a lexer and classification types can be configured and in some cases tested right within the application. Then code generation can be performed to output code files that allow for a related syntax language to be used in your own applications with the SyntaxEditor control.

This topic contains these sections:

  • Getting Started
  • Lexer Configuration Pane
  • AST Nodes Configuration Pane
  • Other Configuration Panes
  • Building a Project
  • Live Test
  • Code Generation
  • LL Parser Debugger

Getting Started

This topic covers essential information about using the application, such as how to start it, what is a language project, how to open/save language projects, use the ribbon user interface and Properties tool window, and get started defining the general properties for a language.

See the Getting Started topic for more information.

Lexer Configuration Pane

The lexer for a language is very important since it is a building block for supporting many language features such as tokenization, syntax highlighting, and more.

See the Lexer Configuration Pane topic for more information.

AST Nodes Configuration Pane

The AST Nodes configuration pane is used to design the type-specific AST node classes that can be code generated by the Language Designer, and used with the LL(*) Parser Framework.

See the AST Nodes Configuration Pane topic for more information.

Other Configuration Panes

The Language Designer has several other configuration panes that are described in this topic.

See the Other Configuration Panes topic for more information.

Building a Project

Once you have configured your language project and are ready to start testing it or generating code, it's time to build the project. Building a project examines the project and reports whether there are any errors, warnings, or messages that you should be aware of.

See the Building a Project topic for more information.

Live Test

The Language Designer Live Test pane allows you to try various aspects of your language out before performing any code generation.

See the Live Test topic for more information.

Code Generation

The Language Designer's main purpose is to generate code that allows you to load custom syntax languages at run-time in your applications.

See the Code Generation topic for more information.

LL Parser Debugger

The Language Designer LL Parser Debugger pane allows you to load an assembly which contains a non-abstract ILLParser implementation class and debug the grammar.

See the LL Parser Debugger topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

This topic covers essential information about using the application, such as how to start it, what is a language project, how to open/save language projects, use the ribbon user interface and Properties tool window, and get started defining the general properties for a language.

This topic contains these sections:

  • Running the Application
  • Language Projects vs. Language Definitions
  • Language Project File Operations
  • Importing a SyntaxEditor 4.0 for WinForms Dynamic Language XML Definition
  • The Ribbon User Interface
  • The Properties Tool Window
  • General Properties Configuration Pane

Running the Application

Go to your Windows' Programs menu group for the WPF controls and click the Run SyntaxEditor Language Designer menu item. This will run the application. If the application previously had a language project open, it will be reopened. Otherwise a Start Actions task pane will be visible with several options for creating a new language project or opening an existing one.

Note Note
If you do not see the menu item to run the application, ensure that you kept the option to install it checked during the WPF controls setup process.

Language Projects vs. Language Definitions

It is important to understand the difference between language project files (.langproj) and language definition files (.langdef). Language project files are what can be loaded and edited by the Language Designer application. The language project stores a lot of information about your language such as lexer configuration, classification types, etc. Based on the information about your language stored in a language project, you are able to generate language-related code that can be included in your application's project. Language projects themselves are not intended to be distributed with your application, only the code generated by them is.

Language definitions on the other hand are one output option when performing code generation, the other option being the generation of pure C#/VB language-related code. Language definitions are essentially a subset of the data stored in the language project and are can be distributed with an application and loaded at run-time to instantly configure a language. Again, language definitions are just one option for working with a language at run-time with your code. They are nice because they are portable and can easily be shared or tweaked. More information on language definitions and the difference between them and pure C#/VB code generation is given in the Code Generation topic.

Language Project File Operations

The Language Designer supports all the basic file operations for working with language projects. These file operations are always available on the ribbon's application menu, and also on the Start Actions task pane when no project is currently open.

The New action (Ctrl+N) creates a new language project and opens the General Properties configuration pane. The Open action (Ctrl+O) opens an existing language project that you have already created. The Save action (Ctrl+S) saves the currently-open language project. The Save As action saves the currently-open language project, but as a different file. The Close action closes the currently-open language project.

A list of recently-opened projects is also available. Click on a recently-opened project to reopen it.

Whenever an action is taken that will close a currently-open language project, you will be prompted as to whether you wish to save the project or not before continuing.

Importing a SyntaxEditor 4.0 for WinForms Dynamic Language XML Definition

To help aid in the transition of some of our WinForms customers to newer platforms, we have added a feature that allows you to import a SyntaxEditor 4.0 for WinForms dynamic language XML definition. Most of the data in the definition will be converted over and imported into a new language project.

To access this feature, choose the Import SE4 Definition action.

The Ribbon User Interface

The ribbon user interface in the Language Designer provides access to all of the application's features.

The Language Designer's ribbon user interface

The Actions group contains numerous actions that can be used whenever lists are presented in a configuration pane. Certain actions enable/disable based on the selection within the list.

The Project Windows group contains actions that when clicked will open up the various configuration panes used to store data about your language.

The Code Generation group has actions that are related to building your project (error checking), performing code generation, and doing a live test.

The Properties Tool Window

The Properties tool window is used throughout the application. It will auto-populate when focus enters many of the configuration panes. In the scenario where configuration panes contain a list, it will often show the properties of the selected list item. Most lists support multi-selection, and in this case you can see/change the properties of more than one object at a time.

General Properties Configuration Pane

The General Properties configuration pane can be opened by clicking General Properties on the ribbon. This configuration pane allows you to set some high-level properties for your language. All language projects should set this data first.

The language key is the name of the language that will be used in type names, etc. So it must conform to identifier naming requirements for C# and VB. This means that say we were making a language project for C#, we would set the language key to be CSharp.

The language description is only used in comments so if we were developing a C# language, here is where we would put C#.

The creator indicates the name of the company that created the language project. The copyright is a place to put a copyright line for the language project data. Both of these items, if included, are output during the code generation phase and help protect your intellectual property.

The example text is where you can paste in a code snippet for the language that is used in the Language Designer application when performing a Live Test. It can also be loaded nad used at run-time if desired for previewing how a language is syntax highlighted.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lexer Configuration Pane

The lexer for a language is very important since it is a building block for supporting many language features such as tokenization, syntax highlighting, and more.

The Lexer configuration pane can be opened by clicking Lexer on the ribbon. This configuration pane allows you to define the lexer used by the language.

This topic contains these sections:

  • Choosing a Lexer Type
  • The New Dynamic Lexer Wizard
  • Modifying a Dynamic Lexer
  • Modifying a Programmatic Lexer

Choosing a Lexer Type

Although any sort of lexer is supported by SyntaxEditor via the ILexer interface, the Language Designer directly supports these types of lexers:

  • None - No lexer is used with the language.
  • Dynamic - A dynamic lexer is used with the language. This lexer type is mergable and is the fastest way to get going. It uses regular expression patterns to define how text is tokenized.
  • Programmatic (mergable) - A mergable programmatic lexer is used with the language. This lexer type is mergable and uses a handwritten code-based lexer to tokenize text. It is faster than a dynamic lexer.
  • Programmatic (non-mergable) - A non-mergable programmatic lexer is used with the language. This lexer type is not mergable and uses a handwritten code-based lexer to tokenize text. It provides the fastest performance.

The Language Designer allowing a lexer type to be chosen

To select a new lexer type, choose the lexer type in the radio button list and click the Change Lexer Type button below the list. In some cases the lexer type will change instantly and in other cases, you may be presented with a wizard.

The New Dynamic Lexer Wizard

The New Dynamic Lexer Wizard appears when you choose to use a dynamic lexer. The first page provides you with two options. The first option allows you to continue using the wizard, which will subsequently ask you a number of questions about the lexical structure of your language and then will automatically configure a number of states and pattern groups to get you started. The second option allows you to quit the wizard and start with a blank dynamic lexer.

The New Dynamic Lexer Wizard asking whether to help you create the basics for a code oriented language.

The first option is best for code-oriented languages like C#, Java, VB, etc. It asks you series of questions about your language's lexical structure such as the keywords, operators, comment, number, and string syntax, etc.

The New Dynamic Lexer Wizard asks for you to define whether line terminators are significant in your langauge. The Python language would be an example of a language where line terminators are significant. It also asks for you to select one of 3 options that define the characters that are allowed in an identifier.

The New Dynamic Lexer Wizard allowing for configuration of line terminators and identifiers.

After configuring line terminators and identifiers, you will be prompted to define the language's keywords and whether they are case-sensitive. Note that if you are creating this Dynamic language for use with the LL(*) Parser Framework, keywords will each need to be defined as separate tokens. This is discussed in the Lexer Preparation topic.

The New Dynamic Lexer Wizard allowing for configuration of language keywords.

After configuring keywords, you will be prompted to configure the language's operators and delimiters. Many languages share a similar set of operators. You have the option to initialize the list with the most common operators, then edit it to your liking.

The New Dynamic Lexer Wizard allowing for configuration of operators and delimiters.

Many languages support defining string literals in more than one way. For this reason, the wizard will prompt you for a primary and an alternate string syntax. If you only need to define one type of string, leave the first radio button group selection on "None" when you are presented with the alternate syntax configuration. If your langauge does not support strings at all, use the "None" selection on the primary and alternate syntax pages.

The New Dynamic Lexer Wizard allowing for configuration of strings.

The next wizard screen will allow you to configure number tokens for your language. You can allow for exponent notation and hexadecimal notation, both of which are supported in many, but not all, languages.

The New Dynamic Lexer Wizard allowing for configuration of numbers.

The last wizard screen allows you to configure comments in your language. You can configure it to support single line comments, multiline comments, neither, or both. You can also customize the comment delimiters.

The New Dynamic Lexer Wizard allowing for configuration of comments.

Upon wizard completion, a dynamic lexer is created for you that is prepopulated with states and patterns. For many languages, this wizard can help to get you up and running in minutes.

Modifying a Dynamic Lexer

Once a dynamic lexer has been created, it can be modified via the Lexer configuration pane. The treeview on the left of the application has nodes for accessing the lexical macro list, lexical state list, and for each state, the scopes, child states, and pattern groups. Click on a treeview node to view its related pane.

Dynamic Lexical Macros

Lexical macros are optional regular expression patterns that can be defined for reuse elsewhere within the lexer. For instance, if you have a pattern snippet that appears in many patterns, define it here and reuse it in other regular expression patterns via {LexicalMacroKey} syntax.

To add macros, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new macros. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new macro is created for each key that you enter.

Once added, use the Properties tool window to update the pattern for each macro. Macros can be removed, cleared, and reordered via the ribbon.

Dynamic Lexical States

Lexical states specify the patterns that can be recognized to tokenize text when the state is active.

To add states, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new states. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new state is created for each key that you enter.

Once added, use the Properties tool window to update the properties for each state. States can be removed, cleared, and reordered via the ribbon.

A state description can be set, which is a more verbose name for the state. Also an ID value can be assigned to the state, which is ideal for best performance when scanning through text at run-time. A number of default properties that apply to the pattern groups in the state (such as case sensitivity) are available to be set.

Dynamic Lexical Scopes

Lexical scopes contain a start and end pattern group and determine how a state is entered and exited via a parent state that references it.

To add a scope, click the Add button in the ribbon. A new scope is created.

Once added, use the Properties tool window to update the properties for the scope. Scopes can be removed and cleared via the ribbon.

Each scope should have a start and end pattern group defined. See the Dynamic Lexical Pattern Groups sub-section below for more information on defining pattern groups.

Dynamic Child Lexical States

Child lexical states provide the list of states that can be transitioned into from a state. When a child state's start scope pattern group is recognized, a transition into that state will be made.

To add a child state reference, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new child states. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A child state reference is created for each key that you enter.

Once added, use the Properties tool window to update the properties for each child state reference. Child state references can be removed, cleared, and reordered via the ribbon.

Dynamic Lexical Pattern Groups

Pattern groups define one or more patterns that are used to tokenize text. Patterns can be explicit or can use regular expressions.

To add a pattern group, click the Add button in the ribbon. A new pattern group is created.

Once added, use the Properties tool window to update the properties for each pattern group. Pattern groups can be removed, cleared, and reordered via the ribbon.

Pattern groups can be assigned a pattern type (explicit or regular expression), various case sensitivity settings, a token ID (for optimal performance when scanning tokenized text), and a token key (which must conform to standard identifier syntax). A classification type key indicates the key of the classification type to use for tokens created using this pattern group.

Pattern groups have a collection of patterns. Patterns can be entered by clicking the ellipses button in the property grid or by right-clicking on the pattern group in the list. Enter one pattern per line on the dialog that appears. A pattern group look-behind and look-ahead pattern can also be defined. These patterns, if specified, must evaluation to true for any of the patterns in the group to match successfully.

Modifying a Programmatic Lexer

This type of lexer is handwritten via code but a couple helpful classes can be generated to help.

Lexical States

Lexical states specify a mdoe in which patterns can be recognized to tokenize text when the state is active. Since lexers often have multiple lexical states, it is useful to have a lexical state ID class that provides constants for all the possible lexical state IDs used by the lexer. This lexical state ID class can be code generated by the Language Designer.

To add states, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new states. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new state is created for each key that you enter.

Once added, use the Properties tool window to update the properties for each state. States can be removed, cleared, and reordered via the ribbon.

A state description can be set, which is a more verbose name for the state. Also an ID value can be assigned to the state, but it is recommended to leave it empty so that it can be auto-generated.

Tip Tip
If you plan on eventually merging the lexer with another lexer it is a good idea to ensure that the lexical state IDs for the two lexers don't overlap. By setting a base ID value on the first lexical state and leaving the rest of the IDs empty, the code generator will auto-generate the remaining IDs to 1-up after the base ID. Thus you could specify ID 1000 on the first lexical state. The code generator will make the next lexical state with an empty ID value have an ID of 1001, and so on.

Token Declarations

The output of lexers is tokenized text. Each token needs to have an ID value to identify it. It is useful to have a token ID class that provides constants for all the possible token IDs used by the lexer. This token ID class can be code generated by the Language Designer.

To add token declarations, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new token declarations. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new token declaration is created for each key that you enter.

Once added, use the Properties tool window to update the properties for each token declaration. States can be removed, cleared, and reordered via the ribbon.

A token declaration description can be set, which is a more verbose name for the token declaration. Also an ID value can be assigned to the token declaration, but it is recommended to leave it empty so that it can be auto-generated.

Tip Tip
If you plan on eventually merging the lexer with another lexer it is a good idea to ensure that the token declaration IDs for the two lexers don't overlap. By setting a base ID value on the first token declaration and leaving the rest of the IDs empty, the code generator will auto-generate the remaining IDs to 1-up after the base ID. Thus you could specify ID 1000 on the first token declaration. The code generator will make the next token declaration with an empty ID value have an ID of 1001, and so on.

A classification type key can be set on the token declaration, indicating the classification type with which the token should be associated. When one is specified, a method is generated on the token ID class that returns whether a specified token ID uses the classification type.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AST Nodes Configuration Pane

The AST Nodes configuration pane is used to design the type-specific AST node classes that can be code generated by the Language Designer, and used with the LL(*) Parser Framework.

Type-specific AST nodes, described in more detail in the general AST nodes topic, are distinct classes designed to represent each type of AST node that a language grammar can create. The features described in this topic make it easy to configure type-specific AST nodes for a language grammar, and fully code generate those node classes.

This topic contains these sections:

  • Pane Layout
  • AST Node Configuration
  • AST Node Property Configuration
  • Code Generation

Pane Layout

The AST Nodes configuration pane contains two lists, one above the other. The upper list displays the AST node classes defined for the language, which can be code generated. The lower list displays the properties that will be code generated for the selected AST node in the upper list.

The Properties tool window is heavily used with this pane, since it allows for the changing of configuration settings for the nodes and their properties. Whichever list was focused last is the one that the Properties tool window considers active.

Note that multiple items can be selected in either list and the Properties window allows you to change common values among all the selected instances. This is useful when changing the base type of multiple AST nodes, etc.

AST Node Configuration

AST node configuration is done by modifying items in the upper list.

Adding AST Nodes

To add AST nodes, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new AST nodes. Enter one key per line, where each key conforms to standard identifier syntax since they will be used as the class name in code generation. A new AST node is created for each key that you enter.

Updating AST Nodes

Select one or more AST nodes in the upper list and use the Properties tool window to modify their properties. You can double-click an AST node in the list to open the Properties tool window.

A description is a text description of the node, used in code generation comments.

The inherits property indicates the base class for the AST node. If left blank, the default AST node base class will be used. A drop-down is provided, allowing for quick selection of any AST node already defined for the language.

Removing AST Nodes

AST nodes can be removed by either selecting the items in the upper list and clicking the ribbon's Remove button (after focusing the list), or by clicking the ribbon's Clear button, which will remove all of them.

AST Node Property Configuration

AST node property configuration is done by modifying items in the lower list. The lower list displays the properties to code generate for the selected AST node in the upper list.

Adding Properties

To add properties, first select the target AST node in the upper list, then click the lower list to focus it, and click the Add button in the ribbon. A dialog will appear asking you for the keys of the new properties. Enter one key per line, where each key conforms to standard identifier syntax since they will be used as the property name in code generation. A new property is created for each key that you enter.

Updating Properties

Select one or more properties in the lower list and use the Properties tool window to modify their properties. You can double-click a property in the list to open the Properties tool window.

A description is a text description of the property, used in code generation comments.

The property type property indicates the kind of property to generate, which is one of these options:

  • Simple – Gets or sets a simple CLR type object. Supported types are strings, ints, bools, enums, and flags enums.
  • SimpleList – Gets an IList<T> containing a collection of strings, ints, bools, or enums.
  • AstNode – Gets or sets an AST node object.
  • AstNodeList – Gets an IList<T> containing a collection of AST nodes.

The property types that relate to child AST nodes are separated out since code generation will add special code to generated AST node classes to allow those to be enumerated through as child nodes.

The type property specifies the Type returned by the property, which can be an AST node type name, a string, etc.

Removing Properties

Properties can be removed by either selecting the items in the lower list and clicking the ribbon's Remove button (after focusing the list), or by clicking the ribbon's Clear button, which will remove all of them.

Code Generation

Any AST nodes defined in this pane will show in the list of files that can be code generated.

The generated classes for AST nodes fully implement IAstNode and can be used with the LL(*) Parser Framework's tree construction mechanism.

The classes are output with a partial modifier so that they can be extended as needed with other partial classes in the same project.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Other Configuration Panes

The Language Designer has several other configuration panes that are described in this topic.

This topic contains these sections:

  • General Properties
  • Classification Types

General Properties

The General Properties configuration pane is where several high-level language properties are defined.

Please see the Getting Started topic for details, as this configuration pane is described in that topic.

Classification Types

The Classification Types configuration pane can be opened by clicking Classification Types on the ribbon. This configuration pane allows you to set which classification types are used by the language.

Classifications provide the foundation for syntax highlighting. Ranges in text are classified with various logical classification types. These classification types are mapped to highlighting styles, which SyntaxEditor uses to determine how to highlight code. The end user is able to customize the styles for each classification type too.

The Language Designer showing classification types being edited

Classification types are used in conjunction with a lexer. Be sure to define a Lexer as well since classifications are assigned to the various tokens generated by the lexer.

Common classification types are:

  • Comment
  • Delimiter
  • Identifier
  • Keyword
  • Number
  • Operator
  • String

Adding Classification Types

To add classification types, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new classification types. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new classification type is created for each key that you enter.

Updating Classification Types

Select one or more classification types in the list and use the Properties tool window to modify their properties. You can double-click a classification type in the list to open the Properties tool window.

A description is a verbose way of describing the classification type that is displayed in user interfaces (such as options dialogs). If no description is provided, the key is used instead. In most scenarios, keys will look fine in UI. However consider something like a C# XmlDocumentationTag. In this case, we'd want to assign a description of XML Doc Tag, since that will look better in UI.

The default style indicates the default highlighting style that should be used for syntax highlighting any text in SyntaxEditor that is classified with the classification type. Null values for the style attributes will inherit whatever the default editor text style is. These style attributes can be edited:

  • Foreground
  • Bold
  • Italic

Previewing Classification Types

A box below the list shows a preview of the classification type and its default style.

Removing Classification Types

Classification types can be removed by either selecting the items in the list and clicking the ribbon's Remove button, or by clicking the ribbon's Clear button, which will remove all of them.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Building a Project

Once you have configured your language project and are ready to start testing it or generating code, it's time to build the project. Building a project examines the project and reports whether there are any errors, warnings, or messages that you should be aware of.

Project builds can be initiated from the ribbon, or by pressing the shortcut Ctrl+Shift+B.

This topic contains these sections:

  • Error List and Status Bar
  • Fixing Errors
  • Notes Related to Live Test
  • Notes Related to Code Generation

Error List and Status Bar

The Error List tool window indicates the errors, warnings, and messages from the last build. Each item in the list shows a general category, which relates to a configuration pane, along with a description.

In addition, the status bar will show a project build result summary and at what time the last build succeeded or failed.

Fixing Errors

In the event that there are errors or warnings that appear, you can double-click the item in the Error List and the related configuration pane should open. In most cases, the appropriate item will be selected or focused as well.

This makes it easy for you to quickly jump to the problem location and get the issue resolved.

Notes Related to Live Test

Project builds are what trigger updates to the language used in the Live Test pane. If there are any build errors, no update to the live test language are made.

Notes Related to Code Generation

Project builds are what update the list of code files that can be generated in the Code Generation Configuration pane. No code previewing or generation can occur if there are build errors.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Live Test

The Language Designer Live Test pane allows you to try various aspects of your language out before performing any code generation.

Click the Live Test button in the ribbon to open the Live Test pane.

This topic contains these sections:

  • Features and Limitations
  • Status Bar Information
  • Updating the Live Test

Features and Limitations

The Live Test can show syntax highlighting for a language that has a dynamic lexer and classification types defined. It does not yet work with other lexer types. There are a number of enhancements planned for this pane in the future.

Status Bar Information

Assuming a supported lexer type is available (see above), as the caret moves through text, the status bar indicates the current lexical state and token keys. An asterisk (*) appears next to the token key if the caret is at the start of a token.

The right side of the status bar indicates the current line, column, and character positions of the caret.

Updating the Live Test

You can build the language project to update the language used in the Live Test pane. Changes made to the other configuration panes will not be picked up in Live Test until a project build occurs.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Generation

The Language Designer's main purpose is to generate code that allows you to load custom syntax languages at run-time in your applications.

This topic contains these sections:

  • Configuration
  • Language Definition vs. Code File Output
  • Selecting the Output Language
  • Previewing Generated File
  • Saving Generated Files
  • Usage of Generated Files

Configuration

Click the Configuration button in the Code Generation ribbon group to open the code generation configuration pane.

On this pane, two fields must be entered. Output namespace indicates the namespace in which any generated C#/VB code is placed. Output folder path indicates the folder in which code files are written when generated. It can be any valid path on your hard drive.

Language Definition vs. Code File Output

A checkbox provides an option for generating a language definition instead of C#/VB code files.

Language definitions are intended to be portable XML files that can be distributed with an application and loaded on the fly to configure a language. Use these if you plan on allowing end users to modify language definitions, or if you simply don't wish to deal with dedicated C#/VB code files.

The other option is to generate dedicated C#/VB code files for the language. In this scenario, you create a language at run-time simply by creating a new instance of the generated language class.

Selecting the Output Language

Code file output can occur in C# or VB, and is generated using CodeDOM. Use the Options tab in the ribbon to switch between the various output language options.

Previewing Generated File

If there are no project build errors, you can preview any of the generated code files by double clicking on the item in the code files list. This opens a new document tab with a complete preview of the code that will be generated. Selecting one or more code files and pressing the Preview Selected button also works.

Saving Generated Files

If there are no project build errors, you can select one or more files and press the Generated Selected or Generate All buttons to save files to the hard drive in the output folder path. Please note that generated files will overwrite any existing files with the same name.

Usage of Generated Files

If you are generating a language definition (.langdef) file, you can either include the file in a folder under your application's main folder or can include the file as an embedded resource in your application project. Then at run-time, create a SyntaxLanguageDefinitionSerializer object, and use its LoadFromFile orLoadFromStream method to create a SyntaxLanguage-based class that is initialized with all the information in the language definition.

If you are generating code files instead, copy all the generated C#/VB code files to your application project and include them as compilable code. To begin using a language, just create an instance of the syntax language class that was generated. The constructor for the language class has all the information in it to configure itself. All generated classes are marked as partial classes so you can further extend them in other files without worrying about your code customizations being wiped out when code is generated again.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


LL Parser Debugger

The LL Parser Debugger allows you to load an assembly which contains a non-abstract ILLParser implementation class and debug the grammar.

Opening the LL Parser Debugger pane shows a new contextual tab group on the ribbon.

This topic contains these sections:

  • Important Silverlight Assembly Notes
  • Debugger Layout
  • Opening a Parser
  • Debugging
  • Hotkeys

Important Silverlight Assembly Notes

Before digging into the debugger UI, there are some important things to know about its ability to load various assemblies. Since the Language Designer is written in WPF and runs on the core .NET framework, it is unable to load Silverlight assemblies for debugging in the LL Parser Debugger.

Silverlight Assemblies

When you wish to debug a Silverlight-based language parser written using the LL(*) Parser Framework, you must clone the classes to a native .NET class library (non-Silverlight-based) and compile a .dll of them. Then load that assembly instead of the Silverlight-based one. This way you can debug the grammar as you are no longer trying to load Silverlight assemblies into a native .NET framework application. The Silverlight version's LL(*) Parser Framework is object model compatible with the WPF version of SyntaxEditor, thus making this possible.

Debugger Layout

The debugger comes with a number of panels that contain useful information about your grammar. Some of them are only used when stepping through the process of parsing the example text.

The LL Parser Debugger

EBNF Rules Pane

The main part of the debugger window is taken up by the EBNF representation of your grammar. Each production that you defined in your grammar class should show up in this window, expressed in standard EBNF notation.

If you find that you are having trouble with one of your productions, this window is a good place to look to see if the production is being interpreted as you expected.

Input Tab

At the bottom of the debugger pane, there is an Input tab. This tab is populated with the example code from the Language Project that Language Designer currently has loaded.

The text entered in this tab is used as input for the parser for debugging.

You can edit the text in this input if you want to test something specific, but changes to the contents of this box are not preserved for future debugging sessions.

Parse Errors Tab

The Parse Errors tab will report any parsing errors encountered while debugging.

If an error is reported while debugging, either the example input text is incorrectly formed, or the grammar is not correct.

Terminals Tab

The Terminals tab reports all the terminals that are defined in the Grammar.

Non-Terminal Stack Tab

The Non-Terminal Stack tab reports the stack from the parser, as you are single-stepping through a parse operation.

Matches Tab

The Matches tool reports the matched results from each production as you are stepping through a parse operation. This can be very helpful in debugging a grammar as you can see the immediate results from a specific production as it completes.

Conditions Tab

The Conditions tool lists all the possible next tokens that are valid for the current production. This information is used to determine whether the parser can attempt a match within a production by comparing the list with the look-ahead token.

Opening a Parser

Clicking the Open Parser button launches a file browser dialog. Navigate to and select an assembly that contains a non-abstract ILLParser implementation. Note that the parser implementation class must have a parameterless constructor.

If there are two or more non-abstract ILLParser implementations in the same assembly, the LL Parser Debugger will prompt and ask which parser it should load.

There are a number of grammar-related exceptions that can occur when loading an assembly for debugging. The exception message should be helpful in solving the issue that is causing the exception, and the issue(s) must be resolved before the debugger can load the exception and debug the grammar.

Once the parser is loaded, you should see the main area of the debugger populate with EBNF rules that represent your grammar. This will be described in further detail below.

Debugging

The LL Parser Debugger controls.

If you would like to see the complete results of parsing the example text without stepping through, you can simply click the Start button. The Parse Errors tab will populate with any generated error messages. The Matches tool will populate with the AST result of the parsing operation.

If there is an issue in the complete parse tree that you would like to debug, it can be very informative to step through the grammar. You can begin this by pressing the Step Into button instead of the Start button. Each time you click Step Into, you will drill deeper into the production rules, following the parser's path. If you want to skip over a production rule that you are not interested in, you can click Step Over. Or, if you would like to leave a production rule that you no longer need additional information about, you can click Step Out, and the debugger will continue from the next element of the parent production.

If you know the exact production you would like to debug, you can place a breakpoint on that production by clicking within the production and clickin the Toggle Breakpoint button. You can then press Start and the debugger will run until it hits that breakpoint.

You can stop the debugger at any time by clicking the Stop button.

If you would like to see the next Term that the debugger will evaluate, click the Show Next Term button. The next term is usually in view already by default, but if you scrolled the view away from that location, the Show Next Term button provides a convenient way to relocate the debugger's position in the grammar.

Hotkeys

The LL Parser Debugger supports the same main debugging hotkeys as Visual Studio.

Hotkey Combination | Action
F5 | Start Debugging
Shift+F5 | Stop Debugging
F11 | Step Into
F10 | Step Over
Shift+F11 | Step Out
F9 | Toggle Breakpoint

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Free Languages

SyntaxEditor includes over 20 free syntax language implementations that can be used in your applications, everything from C# and VB, to HTML, CSS, Java, and more.

This topic contains these sections:

  • Plain Text Language
  • Open Source Languages with a Dynamic Lexer
  • Creating a New Language

Plain Text Language

The plain text language is included as a syntax language to use when no other language is applicable. Since the ICodeDocument.Language property cannot be set to a null value, the plain text language is the ideal language to use when a document doesn't need a language implementation assigned.

The plain text language can be retrieved via the SyntaxLanguage.PlainText property.

Open Source Languages with a Dynamic Lexer

There are a number of open source languages included that use a dynamic lexer.

The languages each have a language project that can be opened and edited using the Language Designer tool. That tool allows you to modify information about a language in a language project, and generate code for the language based the project. Language project files are located in this folder relative to the Sample Browser project's root:

\ProductSamples\SyntaxEditorSamples\Languages\Projects

Note Note
The language projects all specify a code generation output path that is valid on our development machines. The Language Designer will warn you with an error when building the language projects if the path does not exist on your machine. In that case, simply change to the code generation output path to another location that is valid for your machine.

Each of the languages that have language projects in the folder above have had a language definition file code-generated by the Language Designer tool. The language definition files can be distributed with your applications and loaded at run-time. Language definition files are located in this folder relative to the Sample Browser project's root:

\ProductSamples\SyntaxEditorSamples\Languages\Definitions

This is the list of languages included:

Language Name | Project Filename | Definition Filename
Assembly | Assembly.langproj | Assembly.langdef
Batch File | BatchFile.langproj | BatchFile.langdef
C | C.langproj | C.langdef
C# | CSharp.langproj | CSharp.langdef
C++ | Cpp.langproj | Cpp.langdef
CSS | Css.langproj | Css.langdef
HTML | Html.langproj | Html.langdef
INI File | IniFile.langproj | IniFile.langdef
Java | Java.langproj | Java.langdef
JavaScript | JavaScript.langproj | JavaScript.langdef
Lua | Lua.langproj | Lua.langdef
Markdown | Markdown.langproj | Markdown.langdef
MSIL | Msil.langproj | Msil.langdef
Pascal | Pascal.langproj | Pascal.langdef
Perl | Perl.langproj | Perl.langdef
PHP | Php.langproj | Php.langdef
PowerShell | PowerShell.langproj | PowerShell.langdef
Python | Python.langproj | Python.langdef
RTF | Rtf.langproj | Rtf.langdef
Ruby | Ruby.langproj | Ruby.langdef
SQL | Sql.langproj | Sql.langdef
VB | VB.langproj | VB.langdef
VBScript | VBScript.langproj | VBScript.langdef
XAML | Xaml.langproj | Xaml.langdef
XML | Xml.langproj | Xml.langdef

Creating a New Language

Don't see a language listed above that fits your needs? No problem!

One option if one of the languages above is close to your language syntactically, is to copy the related language project file, and open your copied language project in the Language Designer tool to change its lexer configuration and other features appropriately.

Another option is to use the Language Designer tool to create a new language project from scratch. It has a bunch of helpful features to get you up and running quickly with a custom syntax language implementation.

Be sure to read through the Language Creation Guide for details on what a syntax language is and what features are available to be added to a language. That is essential information for building your own syntax language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


The 'Simple' Language (used in samples)

The 'Simple' language is a very basic sort of language that we created to help demonstrate how to implement language-related features with SyntaxEditor and the text/parsing framework. It is used in several samples.

The Simple language supports statements, expressions, and function/variable declarations.

This topic contains these sections:

  • Code Sample
  • Lexical Structure
  • Semantic Structure (in EBNF)

Code Sample

This snippet shows some sample Simple language code:

Simple
Copy
/*
    The Simple language demonstrates a C-like
    language that only knows several keywords and
    operators.  All variables are integer numbers.
*/

function Add(x, y) {
    return x + y;
}

function Increment(x) {
    return (x + 1);
}

function IncrementAndMultiply(x, y) {
    // This function calls another function
    var result;
    result = Increment(x);
    return result * y;
}

Lexical Structure

The Simple language is case sensitive, similar to C.

Identifiers must start with a letter or underscore, and can only contain letters, digits, and underscore characters.

Only integer numbers are supported.

Keywords include:

  • function - Declares a function
  • return - Returns a value
  • var - Declares a variable

Operators include:

  • = - Assignment
  • == - Equality
  • != - Inequality
  • + - Addition
  • - - Subtraction
  • * - Multiplication
  • / - Division

Delimiters include:

  • { - Scope start
  • } - Scope end
  • ( - Group start
  • ) - Group end
  • , - Comma
  • ; - Statement end

Comments include:

  • // Single-line comment
  • /* Range comment */

Semantic Structure (in EBNF)

This EBNF describes the semantic structure of the Simple language:

Code Snippet
Copy
CompilationUnit:
    FunctionDeclarationList?

FunctionDeclarationList:
    FunctionDeclaration
    FunctionDeclarationList FunctionDeclaration

FunctionDeclaration:
    "function" "identifier" "(" FunctionParameterList? ")" Block

FunctionParameterList:
    "identifier"
    FunctionParameterList "," "identifier"

StatementList:
    Statement
    StatementList Statement

Statement:
    Block
    EmptyStatement
    VariableDeclarationStatement
    AssignmentStatement
    ReturnStatement

Block:
    "{" StatementList? "}"

EmptyStatement:
    ";"

VariableDeclarationStatement:
    "var" "identifier" ";"

AssignmentStatement:
    "identifier" "=" Expression ";"

ReturnStatement:
    "return" Expression ";"

Expression:
    EqualityExpression

EqualityExpression:
    AdditiveExpression
    AdditiveExpression "==" EqualityExpression
    AdditiveExpression "!=" EqualityExpression

AdditiveExpression:
    MultiplicativeExpression
    MultiplicativeExpression "+" AdditiveExpression
    MultiplicativeExpression "-" AdditiveExpression

MultiplicativeExpression:
    PrimaryExpression
    PrimaryExpression "*" MultiplicativeExpression
    PrimaryExpression "/" MultiplicativeExpression

PrimaryExpression:
    NumberExpression
    SimpleName
    FunctionAccessExpression
    ParenthesizedExpression

NumberExpression:
    "number"

SimpleName:
    "identifier"

FunctionAccessExpression:
    "identifier" "(" FunctionArgumentList? ")"

FunctionArgumentList:
    FunctionArgument
    FunctionArgumentList "," FunctionArgument

FunctionArgument:
    Expression

ParenthesizedExpression:
    "(" Expression ")"

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The text/parsing framework includes a custom traditional backtracking Nondeterministic Finite Automation (NFA) regular expression engine. Other products that use a similar engine are the .NET framework, Perl, Python, Emacs, and Tcl. This regular expression engine is used by features such as the search object model, allowing for regular expression searching.

The regular expression engine also is the core for performing lexing and tokenization with a dynamic lexer. The engine is very robust and is capable of parsing even the most complicated of languages.

This topic contains these sections:

  • Language Elements
  • Dynamic Lexical Macros
  • Invalid Regular Expressions

Language Elements

The text/parsing framework contains a regular expression engine that accepts an extensive set of regular expression elements, enabling you to efficiently search for text patterns. This topic details the set of characters, operators, and constructs that you can use to define regular expressions.

See the Language Elements topic for more information.

Dynamic Lexical Macros

The built-in regular expression engine, when used with dynamic lexers, allows for the definition of macros that represent regular expression elements. These macros are valid for use in any regular expression within a dynamic lexer and promote reusability of common patterns.

See the Dynamic Lexical Macros topic for more information.

Invalid Regular Expressions

If you enter an invalid regular expression pattern that the regular expression engine cannot parse, an InvalidRegexPatternException is raised with a message describing the problem.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Language Elements

The text/parsing framework contains a regular expression engine that accepts an extensive set of regular expression elements, enabling you to efficiently search for text patterns. This topic details the set of characters, operators, and constructs that you can use to define regular expressions.

Whitespace characters are ignored in all regular expression patterns. Use the \s character class to indicate whitespace matching.

This topic contains these sections:

  • Character Escapes
  • Character Classes
  • Supported Unicode General Categories
  • Quantifiers
  • Atomic Zero-Width Assertions
  • Grouping Constructs
  • Substitutions
  • Other Constructs

Character Escapes

Most of the important regular expression language operators are unescaped single characters. The escape character \ (a single backslash) signals to the regular expression parser that the character following the backslash is not an operator. For example, the parser treats an asterisk (*) as a repeating quantifier and a backslash followed by an asterisk (\*) as the Unicode character \u002A.

Escaped Character | Description
(Ordinary characters) | Characters other than . $ ^ { [ ( | ) * + ? \ match themselves.
\a | Matches a bell (alarm) \u0007.
\t | Matches a tab \u0009.
\r | Matches a carriage return \u000D.
\v | Matches a vertical tab \u000B.
\f | Matches a form feed \u000C.
\n | Matches a new line \u000A.
\e | Matches an escape \u001B.
\040 | Matches an ASCII character as octal (exactly three digits). The character \040 represents a space.
\x20 | Matches an ASCII character using hexadecimal representation (exactly two digits).
\u0020 | Matches a Unicode character using hexadecimal representation (exactly four digits).
\ | When followed by a character that is not recognized as an escaped character, matches that character. For example, \* is the same as \x2A.

Character Classes

The following table summarizes character matching syntax.

Character Class | Description
. | Matches any character except \n. When within a character class, the . will be treated as a period character.
[aeiou] | Matches any single character included in the specified set of characters.
[^aeiou] | Matches any single character not in the specified set of characters.
[0-9a-fA-F] | Use of a hyphen (–) allows specification of contiguous character ranges.
\p{name} | Matches any character in the Unicode general category specified by name (for example, Ll, Nd, Z).
\P{name} | Matches any character not in Unicode general category specified in name.
\w | Matches any word character, which includes letters, digits, and underscores.
\W | Matches any non-word character.
\s | Matches any whitespace character.
\S | Matches any non-whitespace character.
\d | Matches any decimal digit.
\D | Matches any non-digit.
[.\w\s] | Escaped built-in character classes such as \w and \s may be used in a character class. This example matches any period, word or whitespace character.

Supported Unicode General Categories

Unicode defines the general categories and descriptions listed in the following table. These categories can be used with the \p and \P character classes described above.

Category | Description
Lu | Letter, Uppercase
Ll | Letter, Lowercase
Lt | Letter, Titlecase
Lm | Letter, Modifier
Lo | Letter, Other
Mn | Mark, Nonspacing
Mc | Mark, Spacing Combining
Me | Mark, Enclosing
Nd | Number, Decimal Digit
Nl | Number, Letter
No | Number, Other
Pc | Punctuation, Connector
Pd | Punctuation, Dash
Ps | Punctuation, Open
Pe | Punctuation, Close
Pi | Punctuation, Initial quote
Pf | Punctuation, Final quote
Po | Punctuation, Other
Sm | Symbol, Math
Sc | Symbol, Currency
Sk | Symbol, Modifier
So | Symbol, Other
Zs | Separator, Space
Zl | Separator, Line
Zp | Separator, Paragraph
Cc | Other, Control
Cf | Other, Format
Cs | Other, Surrogate
Co | Other, Private Use
Cn | Other, Not Assigned

Additional special categories are supported that represent a set of Unicode character categories, as shown in the following table:

Category | Description
C | (All control characters) Cc, Cf, Cs, Co, and Cn.
L | (All letters) Lu, Ll, Lt, Lm, and Lo.
M | (All diacritic marks) Mm, Mc, and Me.
N | (All numbers) Nd, Nl, and No.
P | (All punctuation) Pc, Pd, Ps, Pe, Pi, Pf and Po.
S | (All symbols) Sm, Sc, Sk, and So.
Z | (All separators) Zs, Zl, and Zp.

Quantifiers

Quantifiers add optional quantity data to a regular expression. A quantifier expression applies to the character, group, or character class that immediately precedes it.

The following table describes the metacharacters that affect matching quantity.

Quantifier | Description
* | Specifies zero or more matches; for example, \w* or (abc)*. Same as {0,}.
+ | Specifies one or more matches; for example, \w+ or (abc)+. Same as {1,}.
? | Specifies zero or one matches; for example, \w? or (abc)?. Same as {0,1}.
{n} | Specifies exactly n matches; for example, (pizza){2}.
{n,} | Specifies at least n matches; for example, (abc){2,}.
{n,m} | Specifies at least n, but no more than m, matches.

Atomic Zero-Width Assertions

The metacharacters described in the following table do not cause the engine to advance through the string or consume characters. They simply cause a match to succeed or fail depending on the current position in the string. For instance, ^ specifies that the current position is at the beginning of a line or string. Thus, the regular expression ^#region returns only those occurrences of the character string #region that occur at the beginning of a line.

Assertion | Description
^ | Specifies that the match must occur at the beginning of the document or the beginning of the line.
$ | Specifies that the match must occur at the end of the string, before \n at the end of the string, or at the end of the line.
\A | Specifies that the match must occur at the beginning of the document.
\z | Specifies that the match must occur at the end of the document.
\b | Specifies that the match must occur on a boundary between \w (alphanumeric) and \W (nonalphanumeric) characters.
\B | Specifies that the match must not occur on a \b boundary.

Grouping Constructs

Grouping constructs allow you to capture groups of subexpressions and to increase the efficiency of regular expressions with noncapturing lookahead and lookbehind modifiers.

( ) | Captures the matched substring if used in a find/replace operation. In lexing, provides non-captured grouping. Find/replace captures using ( ) are numbered automatically based on the order of the opening parenthesis, starting from one. The first capture, capture element number zero, is the text matched by the whole regular expression pattern.
(?= ) | Zero-width positive lookahead assertion. Continues match only if the subexpression matches at this position on the right. For example, _(?=\w) matches an underscore followed by a word character, without matching the word character.
(?! ) | Zero-width negative lookahead assertion. Continues match only if the subexpression does not match at this position on the right. For example, \b(?!un)\w+\b matches words that do not begin with un.
(?<= ) | Zero-width positive lookbehind assertion. Continues match only if the subexpression matches at this position on the left. For example, (?<=19)99 matches instances of 99 that follow 19.
(?<! ) | Zero-width negative lookbehind assertion. Continues match only if the subexpression does not match at this position on the left.

Substitutions

Substitutions are allowed only within find/replace replacement patterns.

Character escapes and substitutions are the only special constructs recognized in a replacement pattern. For example, the replacement pattern a*$1b inserts the string a* followed by the substring matched by the first capturing group, if any, followed by the string b. The * character is not recognized as a metacharacter within a replacement pattern. Similarly, $ patterns are not recognized within regular expression matching patterns. Within regular expressions, $ designates the end of the string.

The following table shows how to define named and numbered replacement patterns.

Construct | Description
$1 | Substitutes the last substring matched by group number 1 (decimal). The second group is number 2 ($2), and so on.
$0 | Substitutes a copy of the entire match itself.
$& | Substitutes a copy of the entire match itself.
$$ | Substitutes a single $ literal.

Other Constructs

The following table lists other regular expression constructs.

Construct | Description
" " | Encapsulates a fixed string of characters.
{ } | Provides a call to a lexical macro. The use of a WordMacro (which is similar to \w) would appear as {WordMacro}.
(?# ) | Inline comment inserted within a regular expression. The comment terminates at the first closing parenthesis character.
| | Provides an alternation construct that matches any one of the terms separated by the | (vertical bar) character. For example, cat|dog|tiger. The leftmost successful match wins.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Dynamic Lexical Macros

The built-in regular expression engine, when used with dynamic lexers, allows for the definition of macros that represent regular expression elements. These macros are valid for use in any regular expression within a dynamic lexer and promotes reusability of common patterns.

This topic contains these sections:

  • Usage
  • Built-In Macros

Usage

Using defined macros is easy. To reference a macro, simply type its name within curly braces ({ ... }).

This regular expression uses a macro that represents the character class [0-9] to build a decimal number regular expression.

{Digit}+ (\. {Digit}+)?

This regular expression builds a C# identifier using two macros.

(_ | {Alpha})({Word})*

Built-In Macros

The regular expression engine recognizes a number of built-in macros. If a dynamic lexer defines a lexical macro of the same key as a built-in lexical macro, the user's definition will override the system definition.

The following table summarizes all of the built-in macros:

Name | Description
All | Contains all Unicode characters. This is the same as: [\u0000-\uFFFF].
Alpha | Contains all Unicode alphabetic digits. This is the same as \p{L} (all letters).
Digit | Contains all Unicode decimal digits. This is the same as \d and \p{Nd}.
HexDigit | Contains all Unicode hexidecimal digits. This is the same as [0-9a-fA-F].
LineTerminator | Contains all Unicode line terminators. This is the same as [\n\r\p{Zl}\p{Zp}].
LineTerminatorWhitespace | Contains all Unicode line terminators and whitespace characters. This is the same as \s or [\f\n\r\t\v\x85\p{Z}].
NonAlpha | Contains the inverse of Alpha.
NonDigit | Contains the inverse of Digit.
None | Contains no characters.
NonHexDigit | Contains the inverse of HexDigit.
NonLineTerminator | Contains the inverse of LineTerminator.
NonLineTerminatorWhitespace | Contains the inverse of LineTerminatorWhitespace.
NonWhitespace | Contains the inverse of Whitespace.
NonWord | Contains the inverse of Word.
Whitespace | Contains all Unicode whitespace characters. This is the same as [\f\t\v\x85\p{Zs}].
Word | Contains all Unicode word characters. This is the same as \w and [\p{L}\p{Nd}\p{Pc}] (all letters, decimal digits, and connectors like underscore).

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The LL(*) Parser Framework is Actipro's own framework for constructing robust text parsers that work standalone or with code editor controls like SyntaxEditor. The framework features grammars that are written in C#/VB using EBNF-like notation, customizable AST construction, advanced error handling/reporting, easy code injection, a complete debugger UI, and much more.

A parsing framework is the key to enhancing a SyntaxEditor editing experience because it gives us meaningful information about what is contained in the document. This not only can be used to provide contextual information to the end user (what method is the caret in), but is used to help drive features like automated IntelliPrompt completion lists, parameter info, and quick info.

This topic contains these sections:

  • Parser Type
  • Feature Summary
  • Getting Started
  • Lexer Preparation
  • Parser Infrastructure
  • Symbols and EBNF Terms
  • Walkthrough: Symbols and EBNF Terms
  • Tree Constructors
  • Walkthrough: Tree Constructors
  • Callbacks and Error Handling
  • Walkthrough: Callbacks and Error Handling
  • Custom Data

Parser Type

The parser in our framework is LL(*), meaning it is a top-down parser that can run on a subset of context-free grammars. It parses input from left to right, traces leftmost derivation, and by default uses one symbol of look-ahead. This normally would mean LL(1), however can-match callbacks allow infinite symbol look-ahead, thus making it LL(*).

LL parsers do not support left recursion however grammars can generally be refactored to eliminate left recursion and turn it into right recursion instead. Ambiguity can be resolved using can-match callbacks. Examples of handling both scenarios are given in this framework's documentation.

Feature Summary

There are many types of parsers, each with their pros and cons. Actipro's LL(*) Parser Framework was carefully designed to be easy-to-use, provide an enormous feature set, and address the most common shortcomings encountered with other third-party parsers.

The frameworks features include:

  • A top-down LL parser that supports infinite symbol look-ahead.
  • Grammars built directly in C#/VB code using EBNF-like syntax, made possible via operator overloading, implicit type conversion, and delegates.
  • No code generation, everything is interpreted.
  • Pre-existing grammars can be programmatically altered before they are compiled and used.
  • Can-match callbacks can provide code-based determination of whether a non-terminal can match with the parser's current state.
  • Custom code callbacks can be injected anywhere in the grammar before/after an EBNF term is parsed, or on success/error.
  • Automated parse error reporting and recovery options, with the ability to customize.
  • All productions support customized AST (abstract syntax tree) construction rules using numerous built-in tree constructor options, and ability to create custom tree constructors.
  • Generated AST nodes are automatically assigned the proper text offsets.
  • Re-use ILexer implementations that have already been made for a language.
  • Filter out tokens that are meaningless to the parser (comments, etc.).
  • Designed to integrate easily with SyntaxEditor.
  • Complete debugger UI in the Language Designer tool that allows you to step through a parser to see exactly how it is matching and building results.

Getting Started

There are five steps involved in using the LL(*) Parser Framework to create a parser for a language.

See the Getting Started topic for more information.

Lexer Preparation

The core parser in the LL(*) Parser Framework depends on an ILexer to provide tokens for consumption. This topic discusses how to properly prepare a lexer for use with a parser.

See the Lexer Preparation topic for more information.

Parser Infrastructure

There are several classes that will need to be created and connected in order to use the LL(*) Parser Framework. This topic makes the process easy by guiding you through each step that is required.

See the Parser Infrastructure topic for more information.

Symbols and EBNF Terms

A grammar is a set of symbols, both terminals or non-terminals, along with production rules that determine how to parse text for a formal language, where there is a single starting symbol from which parsing should begin.

See the Symbols and EBNF Terms topic for more information.

Walkthrough: Symbols and EBNF Terms

In this walkthrough, we are going to write a grammar for a language called Simple. The Simple language is basically a small subset of a Javascript-like language. When we're done, we'll load it up into a SyntaxEditor and we'll look at the AST results that are generated for us based on some input code.

See the Walkthrough: Symbols and EBNF Terms topic for more information.

Tree Constructors

Non-terminal productions will by default produce a very verbose AST that generally contains much more information than is useful for later consumption. The LL(*) Parser Framework has an extremely powerful tree construction mechanism with numerous built-in helper methods to do common tree construction tasks. You also have the ability to create completely custom tree construction nodes via C#/VB code if you like.

See the Tree Constructors topic for more information.

Walkthrough: Tree Constructors

In this walkthrough, we are going to revisit the Simple language and will enhance our grammar productions with tree constructors so that we make the resulting AST very concise.

See the Walkthrough: Tree Constructors topic for more information.

Callbacks and Error Handling

The next step in building a grammar is to make sure that it properly handles errors. After all, since this grammar framework is intended to be used with SyntaxEditor, we have to assume that most of the time the document’s code passed to our grammar parser will be in an invalid state. The user is continuously typing and modifying it.

In this topic, we will look at the various callbacks that are available to you, probably the most important of which are the error handling callbacks. We'll also dig into error handling options.

See the Callbacks and Error Handling topic for more information.

Walkthrough: Callbacks and Error Handling

In this topic we’ll examine the importance of adding error handling. We’ll enhance our Simple language grammar to properly recover from nearly any invalid syntax in a document so that it can continue parsing the rest of the document.

See the Walkthrough: Callbacks and Error Handling topic for more information.

Custom Data

The IParserState object passed to each callback in the parser framework has a property on it where custom data can be tracked and updated throughout each parsing operation.

Anything can be placed in this custom data store. It could be used to help perform semantic validation, construct name tables, and more.

See the Custom Data topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

There are five steps involved in using the LL(*) Parser Framework to create a parser for a language.

Check out the sections in this topic for more information on each of these steps.

  • Assembly Requirements
  • Step 1: Constructing a Lexer
  • Step 2: Creating the Core Classes
  • Step 3: Set Up Symbols and Non-Terminal Productions
  • Step 4: Add Customized Tree Constructors
  • Step 5: Add Error Handling and Advanced Error Reporting

Assembly Requirements

The following list indicates the assemblies that are used with the LL(*) Parser Framework.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Wpf.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for SyntaxEditor
ActiproSoftware.Text.LLParser.Wpf.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Wpf.dll | No * | Actipro | SyntaxEditor | Core framework for all Actipro WPF controls
ActiproSoftware.SyntaxEditor.Wpf.dll | No * | Actipro | SyntaxEditor | SyntaxEditor for WPF control

* Not required however is used to integrate parsers made with the framework with a SyntaxEditor control.

Step 1: Constructing a Lexer

The core parser in the LL(*) Parser Framework depends on an ILexer to provide tokens for consumption.

The easiest and recommended way to fulfill this need is to use the Language Designer to create a new language. Once you have a language designed, you can generate source files which you can then include in your project. One of the generated source files will contain a class that implements the ILexer interface.

The new language's lexer can more often than not be reused for the syntax highlighting engine. Or if you have already created a lexer for your language, you can probably reuse it here.

In some cases, a lexer used to drive syntax highlighting may have different tokenization requirements than the lexer used to feed tokens to the parser framework. In this scenario, a second lexer with different logic can be created for use with the parser framework.

For more information on constructing a lexer for the parsing framework, view the Lexer Preparation topic.

Step 2: Creating the Core Classes

There are a few classes which you will need to create in order to use the LL(*) Parser Framework.

The most important one, the Grammar class, contains the core of the whole setup. Its constructor will set up the productions that tell the LL(*) Parser Framework how to interpret the syntax of your language.

An ILLParser-based class (you should generally inherit from LLParserBase) is registered as a service to the SyntaxLanguage that is associated with the SyntaxEditor.

An ITokenReader-based class is necessary to provide tokens to the parsing framework. For some languages with mergable lexers, it is sufficient to use the existing MergableTokenReader class. However in non-mergable lexer scenarios or scenarios where you wish to filter the tokens being supplied to the parser, you may need to subclass TokenReaderBase or MergableTokenReader for more control.

For more information on creating the core classes, view the Parser Infrastructure topic.

Step 3: Set Up Symbols and Non-Terminal Productions

Your grammar class will need to define the rules for how the core parser will interpret input. This is done by defining all the symbols that are in your language and defining a number of productions which reference the symbols.

There are two types of symbols: terminals and non-terminals. Terminals are the lowest-level fixed-input lexical element used in a grammar production rule. In the case of Actipros text framework, terminals equate to tokens that are read in from a lexer. Non-terminals each have a production rule that is comprised of some combination of terminal and non-terminal symbol references.

For more information on setting up the symbols and non-terminal productions, view the Symbols and EBNF Terms topic.

Step 4: Add Customized Tree Constructors

The default tree constructors will output nearly everything that is parsed. You will probably want to customize the tree construction to generate a cleaner tree.

There are a number of built-in tree construction nodes that should handle nearly all your tree construction needs. These nodes are created by method calls on the Grammar class. If you require special tree construction logic, there are provisions available.

For more information on adding customized tree constructors, view the Tree Constructors topic.

Step 5: Add Error Handling and Advanced Error Reporting

When building a grammar, it is important to cleanly handle errors and report helpful messages to the user. This framework is intended to be used with SyntaxEditor, so we have to assume that the code passed to our parser will often be in an invalid state. This is because the user is continuously typing and modifying it.

Error handling can be performed automatically, or manually via the use of error callbacks. There are a number of built-in error callbacks that can be utilized, and you can also create custom error callbacks.

It is possible to assign an ErrorAlias to any Terminal and NonTerminal instance, which gives you greater control over what automated messages are reported and when.

For more information on adding error handling and advanced error reporting, view the Callbacks and Error Handling topic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lexer Preparation

The core parser in the LL(*) Parser Framework depends on an ILexer to provide tokens for consumption. This topic discusses how to properly prepare a lexer for use with a parser.

The easiest and recommended way to fulfill this need is to use the Language Designer to create a new language. Once you have a language designed, you can generate source files which you can then include in your project. One of the generated source files will contain a class that implements the ILexer interface.

As mentioned above, any ILexer-based object will work with the LL(*) parser. Thus you don't have to use the Language Designer to create your lexer. All the techniques described in the Lexing portion of the documentation apply.

This topic contains these sections:

  • Designing A Parser-Friendly Dynamic Language
  • Generate Source Files
  • Advanced Languages

Designing A Parser-Friendly Dynamic Language

A lexer that is to be used with the parser framework has to take into account some special considerations. This section assumes you are already familiar with the Language Designer tool and understand the basic terminology.

Keywords for your language should each be defined with a separate token ID and key. This is because your parser will need to know which keyword was used in a particular location, not just that it is a keyword that was used.

It is best to avoid token rules that capture compound constructs. If you leave that sort of thing to the parser to handle, you will get more useful error messages and handling. Make tokens for the lowest possible level of constructs, such as individual symbols and punctuation, identifiers, numbers, etc.

It can be good practice to make a comment state and a string state for languages that have comments and strings. This allows for better handling of unterminated strings and comments and makes it easy to generate tokens for text that is within a string or comment.

Generate Source Files

You may be used to loading a language definition file (.langdef) into your application to provide a SyntaxLanguage for use with your SyntaxEditor, but the parsing framework's needs are more granular. For this reason, you need to generate source files for the language instead of the .langdef file. This will ensure that ILexer, ITokenIdProvider, and other classes are built that can be used by the parser.

See the Parser Infrastucture topic for more information on how to set up your SyntaxLanguage.

Advanced Languages

In some cases, a lexer used to drive syntax highlighting may have different tokenization requirements than the lexer used to feed tokens to the parser framework. In this scenario, a second lexer with different logic can be created for use with the parser framework.

The lexer used to drive syntax highlighting should always be registered on your syntax language as a lexer service, while the lexer used to provide tokens to the parser framework can optionally be different.

See the Parser Infrastructure topic for more information on how to set a different lexer up for the parser.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parser Infrastructure

There are several classes that will need to be created and connected in order to use the LL(*) Parser Framework. This topic makes the process easy by guiding you through each step that is required.

By the end of this topic, you should have a system built that can compile without errors. However, there are additional things you will need to do in the next topic and beyond before your parser will operate properly, such as adding grammar productions.

This topic contains these sections:

  • Grammar Class
  • ITokenReader Interface
  • ILLParser Interface
  • ILLParseData Interface
  • ISyntaxLanguage Interface

Grammar Class

The Grammar class contains the meat of the whole setup. To quickly sum up, a grammar is a set of parsing rules defined via EBNF for how to derive structure from text. It is used to tell the ILLParser how to parse text.

The grammar class constructor will do four tasks:

  1. Create terminals
  2. Create non-terminals
  3. Configure non-terminal productions
  4. Configure non-terminal can-match callbacks
We will explain these further in the Symbols and EBNF Terms and Walkthrough: Adding Symbols and Productions topics.

For now, all you need to do is create the class and the empty constructor. Here is an example of the Grammar derived class we've created for our Simple language:

C#
VB
Copy
​/// <summary>
/// Represents a <see cref="Grammar" /> for the <c>Simple</c> language.
/// </summary>
public class SimpleGrammar : Grammar {

    /// <summary>
    /// Initializes a new instance of the <c>SimpleGrammar</c> class.
    /// </summary>
    public SimpleGrammar() : base("Simple") {

        // More code will be added here in the next several topics

    }
}
​''' <summary>
''' Represents a <see cref="Grammar" /> for the <c>Simple</c> language.
''' </summary>
Public Class SimpleGrammar
    Inherits Grammar

    ''' <summary>
    ''' Initializes a new instance of the <c>SimpleGrammar</c> class.
    ''' </summary>
    Public Sub New()
        MyBase.New("Simple")

        ' More code will be added here in the next several topics

    End Sub
End Class

ITokenReader Interface

An ITokenReader provides tokens to the parsing framework. A token reader is an intermediate class that is created for each parse request and sits between the ILexer that will be used to tokenize text for the parser, and the parser itself. This means that it can also be used to filter out certain tokens that the parser won't care about.

For instance, many parsers don't care about comments so those tokens can be skipped over by the token reader as it passes tokens up to the parser. Many parsers find that whitespace is insignificant as well. Thus whitespace can also generally be skipped over. There may be other token types that are desirable to be skipped by the token reader as it iterates and passes tokens to the parser.

If you are using a mergable lexer to supply tokens to the parser, it may be sufficient to use the built-in MergableTokenReader class since it fully implements ITokenReader. The MergableTokenReader class will by default provide every token from a mergable lexer to the parser. If you have a mergable lexer but would like to filter out certain token types, such as whitespace in a whitespace insensitive language, you can subclass MergableTokenReader as shown in sample below.

If you are using a non-mergable lexer then you should inherit TokenReaderBase instead and implement its abstract GetNextToken method, which simply returns the next token that will be consumed by the parser.

If you inherit from MergableTokenReader, your token reader class will need two things. First, you will need a public constructor which takes an ITextBufferReader and an IMergableLexer as arguments. Pass these along to the base constructor. Second, you will need to override the GetNextToken member.

Here is an example token reader, based on MergableTokenReader, which discards all whitespace tokens. The concepts here show how to filter tokens regardless of whether you inherit MergableTokenReader or TokenReaderBase. The SimpleParsingTokenId class contains token ID constants and was generated by the Language Designer tool using our Simple language project. You should have an equivalent class that was generated for your language. This also makes the assumption that you have a Whitespace token defined in the language that was used to generate the SimpleParsingTokenId class.

C#
VB
Copy
​/// <summary>
/// Represents an object that can provide tokens to a <see cref="ILLParser"/> in a forward-only direction for the <c>Simple</c> language.
/// </summary>
public class SimpleTokenReader : MergableTokenReader {

    /// <summary>
    /// Initializes a new instance of the <c>SimpleTokenReader</c> class.
    /// </summary>
    /// <param name="reader">The <see cref="ITextBufferReader"/> to use for consuming text.</param>
    /// <param name="rootLexer">The root <see cref="IMergableLexer"/>.</param>
    public SimpleTokenReader(ITextBufferReader reader, IMergableLexer rootLexer) : base(reader, rootLexer) {}

    /// <summary>
    /// Returns the next <see cref="IToken"/> that will be consumed by the token reader.
    /// </summary>
    /// <returns>The next <see cref="IToken"/> that will be consumed by the token reader.</returns>
    protected override IToken GetNextToken() {
        // Call the base method
        IToken token = base.GetNextToken();

        // Loop to skip over tokens that are insignificant to the parser
        while (!this.IsAtEnd) {
            switch (token.Id) {
                case SimpleParsingTokenId.Whitespace:
                    // Skip
                    token = base.GetNextToken();
                    break;
                default:
                    return token;
            }
        }

        return token;
    }
}
​/// <summary>
/// Represents an object that can provide tokens to a <see cref="ILLParser"/> in a forward-only direction for the <c>Simple</c> language.
/// </summary>
public class SimpleTokenReader : MergableTokenReader {

    /// <summary>
    /// Initializes a new instance of the <c>SimpleTokenReader</c> class.
    /// </summary>
    /// <param name="reader">The <see cref="ITextBufferReader"/> to use for consuming text.</param>
    /// <param name="rootLexer">The root <see cref="IMergableLexer"/>.</param>
    public SimpleTokenReader(ITextBufferReader reader, IMergableLexer rootLexer) : base(reader, rootLexer) {}

    /// <summary>
    /// Returns the next <see cref="IToken"/> that will be consumed by the token reader.
    /// </summary>
    /// <returns>The next <see cref="IToken"/> that will be consumed by the token reader.</returns>
    protected override IToken GetNextToken() {
        // Call the base method
        IToken token = base.GetNextToken();

        // Loop to skip over tokens that are insignificant to the parser
        while (!this.IsAtEnd) {
            switch (token.Id) {
                case SimpleParsingTokenId.Whitespace:
                    // Skip
                    token = base.GetNextToken();
                    break;
                default:
                    return token;
            }
        }

        return token;
    }
}

ILLParser Interface

You must create a parser class to register as a service with your language. This class will implement the ILLParser interface. Generally, you will want to inherit from LLParserBase class, which takes care of implementing most of the interface.

Your parser class must have a minimum of two things:

  1. It should declare a public constructor which passes a new instance of your grammar class to the base constructor.
  2. You must override the CreateTokenReader method, because it is declared abstract.

The CreateTokenReader override returns a new ITokenReader instance to provide tokens to the parsing framework. This method is called each time parsing is started, so it is important to make a new instance of the token reader to be used with each call.

In this example code, we will create and return a MergableTokenReader instance, but you could just as easily return a new instance of your own ITokenReader implementation. The SimpleLexer and SimpleClassificationTypeProvider classes were generated by the Language Designer tool using our Simple language project. You should have equivalent classes that were generated for your language.

C#
VB
Copy
​/// <summary>
/// Represents a parser for the <c>Simple</c> language.
/// </summary>
public class SimpleParser : LLParserBase {

    /// <summary>
    /// Initializes a new instance of the <c>SimpleParser</c> class.
    /// </summary>
    public SimpleParser() : base(new SimpleGrammar()) {}

    /// <summary>
    /// Creates an <see cref="ITokenReader"/> that is used by the parser to read through tokens.
    /// </summary>
    /// <param name="reader">The <see cref="ITextBufferReader"/> that provides access to the text buffer.</param>
    /// <returns>An <see cref="ITokenReader"/> that is used by the parser to read through tokens.</returns>
    public override ITokenReader CreateTokenReader(ITextBufferReader reader) {
        return new MergableTokenReader(reader, new SimpleLexer(new SimpleClassificationTypeProvider()));
    }
}
​''' <summary>
''' Represents a parser for the <c>Simple</c> language.
''' </summary>
Public Class SimpleParser
    Inherits LLParserBase

    ''' <summary>
    ''' Initializes a new instance of the <c>SimpleParser</c> class.
    ''' </summary>
    Public Sub New()
        MyBase.New(New SimpleGrammar())
    End Sub

    ''' <summary>
    ''' Creates an <see cref="ITokenReader"/> that is used by the parser to read through tokens.
    ''' </summary>
    ''' <param name="reader">The <see cref="ITextBufferReader"/> that provides access to the text buffer.</param>
    ''' <returns>An <see cref="ITokenReader"/> that is used by the parser to read through tokens.</returns>
    Public Overrides Function CreateTokenReader(ByVal reader As ITextBufferReader) As ITokenReader
        Return New MergableTokenReader(reader, New SimpleLexer(New SimpleClassificationTypeProvider()))
    End Function
End Class

ILLParseData Interface

By default, a parser will generate an LLParseData object. This object implements the ILLParseData interface, which returns data containing the IAstNode that was parsed, IParseError objects that were reported, and the ITextSnapshot that was used, if known. ILLParseData implements IParseErrorProvider, meaning that it can easily be wired up to show squiggle lines where parse errors occur.

It is possible that you will want to retain additional information from the parsing process than what is provisioned with this type. For instance, an XML language may wish to store a boolean flag indicating whether the document is well-formed. If this is the case, you can create a new parse data class that inherits from LLParseData. You can then add any additional properties you wish to be available.

If you do create a new parse data type, you will need to override the CreateParseData member. This override should look something like the following code. The SimpleParseData type represents the custom parse data type that you would create for your language.

C#
VB
Copy
​/// <summary>
/// Creates an <see cref="IParseData"/> for the specified <see cref="IParserState"/>.
/// </summary>
/// <param name="request">The <see cref="IParseRequest"/> that contains data about the requested parsing operation.</param>
/// <param name="state">The <see cref="IParserState"/> to examine.</param>
/// <returns>The <see cref="IParseData"/> that was created.</returns>
protected virtual IParseData CreateParseData(IParseRequest request, IParserState state) {
    SimpleParseData parseData = new SimpleParseData();
    this.InitializeParseData(parseData, state);

    // Add custom parse data to the parseData object

    return parseData;
}
​''' <summary>
''' Creates an <see cref="IParseData"/> for the specified <see cref="IParserState"/>.
''' </summary>
''' <param name="request">The <see cref="IParseRequest"/> that contains data about the requested parsing operation.</param>
''' <param name="state">The <see cref="IParserState"/> to examine.</param>
''' <returns>The <see cref="IParseData"/> that was created.</returns>
Protected Overridable Function CreateParseData(ByVal request As IParseRequest, ByVal state As IParserState) As IParseData
    Dim parseData As New SimpleParseData()
    Me.InitializeParseData(parseData, state)

    ' Add custom parse data to the parseData object

    Return parseData
End Function

ISyntaxLanguage Interface

Finally, you will need to register your parser class as a service with an ISyntaxLanguage for the parsing system to operate. You may also want to associate the ISyntaxLanguage with a SyntaxEditor instance.

If you used the Language Designer tool to generate source files for your language, you should have a source file which contains a syntax language class that inherits from SyntaxLanguage. You will have to register additional services than what is included in the generated class constructor. While you could simply add the additional registrations to the generated constructor, odds are you will need to regenerate those files at a later time. Rather than risk losing your changes to this class constructor if you overwrite it with the Language Designer's source code generator, we recommend creating a new class which inherits from the generated class. You can perform your additional registrations in the constructor of your derived class, and if you have to regenerate the base class, no changes are lost.

In addition to registering your parser class as a service, you might also want to register a ParseErrorTagger. This will cause parsing errors to be automatically marked with red squiggly underlines once everything is set up correctly.

Your new syntax language class should look something like the following code. The SimpleSyntaxLanguage class was generated by the Language Designer tool using our Simple language project. You should have an equivalent class that was generated for your language. The SimpleParser type is equivalent to the custom parser class that you would create for your language.

C#
VB
Copy
​/// <summary>
/// Represents a <c>Simple</c> syntax language definition.
/// </summary>
public class ExtendedSimpleSyntaxLanguage : SimpleSyntaxLanguage {

    /// <summary>
    /// Initializes a new instance of the <see cref="ExtendedSimpleSyntaxLanguage"/> class.
    /// </summary>
    public ExtendedSimpleSyntaxLanguage() {
        // Register a parser with the language
        this.RegisterService<IParser>(new SimpleParser());

        // Register a ParseErrorTagger so errors get squiggles
        this.RegisterService(new CodeDocumentTaggerProvider<ParseErrorTagger>(typeof(ParseErrorTagger)));
    }
}
​''' <summary>
''' Represents a <c>Simple</c> syntax language definition.
''' </summary>
Public Class ExtendedSimpleSyntaxLanguage
    Inherits SimpleSyntaxLanguage

    ''' <summary>
    ''' Initializes a new instance of the <see cref="ExtendedSimpleSyntaxLanguage"/> class.
    ''' </summary>
    Public Sub New()
        ' Register a parser with the language
        Me.RegisterService(Of IParser)(New SimpleParser())

        ' Register a ParseErrorTagger so errors get squiggles
        Me.RegisterService(New CodeDocumentTaggerProvider(Of ParseErrorTagger)(GetType(ParseErrorTagger)))
    End Sub
End Class

As mentioned in the Lexer Preparation topic, there are some rare cases where you might want a separate lexer defined for your syntax highlighting and for your parsing. This scenario can occur if the tokenization required to support your parser is different than the tokenization of text needed to support syntax highlighting.

In this scenario, set up your syntax language like normal. However when creating your ITokenReader in your ILLParser class, make sure it is using a new instance of your alternate lexer that should be generating tokens for the parser. The alternate ILexer you use for parsing can be created using a second language project in the Language Designer or you can create it using other techniques described in the lexing portion of the Text/Parsing Framework documentation.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Symbols and EBNF Terms

A grammar is a set of symbols, both terminals or non-terminals, along with production rules that determine how to parse text for a formal language, where there is a single starting symbol from which parsing should begin.

Terminals are the lowest-level fixed-input lexical element used in a grammar production rule. In the case of the LL(*) Parser Framework, terminals equate to tokens that are read in from a lexer.

Non-terminals each have a production rule that is comprised of some combination of EBNF-like terminal and non-terminal symbol references.

This topic contains these sections:

  • What is EBNF?
  • EBNF Terms
  • Steps to Initialize a Grammar
  • Step 1: Create Terminals
  • Step 2: Create Non-Terminals
  • Step 3: Configure Non-Terminal Productions
  • Step 4: Configure Non-Terminal Can-Match Callbacks
  • Document End Terminal
  • Next Steps

What is EBNF?

Extended Backus–Naur Form (EBNF) is a meta-syntax notation used for expressing context-free grammars. Nearly all programming languages have some form of EBNF grammar specification available for reference on the Internet, so that compilers and other products know how to read the code and interpret it.

EBNF supports concatenation, alternation (options), quantifiers (optional, zero-or-more, one-or-more, etc.), and symbol (terminal and non-terminal) references.

Sample EBNF

Take this EBNF for a Simple language FunctionDeclaration non-terminal:

Code Snippet
Copy
FunctionDeclaration:
        "function" "identifier" "(" FunctionParameterList? ")" Block

That is saying the non-terminal’s name is FunctionDeclaration and a function declaration is built by a concatenation of a function terminal, followed by an identifier terminal, followed by an open parenthesis terminal, followed by an optional FunctionParameterList non-terminal, followed by a close parenthesis terminal, and ending with a Block non-terminal.

EBNF Terms

In the LL(*) Parser Framework, we have the concept of EBNF terms, all of which inherit an EbnfTerm base class. There are multiple classes use to represent various types of EBNF terms, each of which can be used within a production rule for a non-terminal:

  • EbnfProduction
  • EbnfTerminal
  • EbnfNonTerminal
  • EbnfQuantifier
  • EbnfConcatenation
  • EbnfAlternation

EbnfProduction

An EbnfProduction represents a production rule. Each NonTerminal has exactly one EbnfProduction associated with it that defines the EBNF for that non-terminal.

EbnfProduction objects have one child EbnfTerm that provides the EBNF pattern to match for the production rule. Productions can also optionally be assigned custom tree constructors, but we’ll get into that more in the Tree Constructors topic.

EbnfTerminal

An EbnfTerminal represents the usage of a pre-defined Terminal instance within a production rule.

For instance, a Terminal for an Identifier is likely to be used many places in a grammar. The Terminal for an Identifier is defined once at the top of the grammar declaration and each usage of it within a production is made via separate EbnfTerminal instances that reference the Terminal.

EbnfNonTerminal

An EbnfNonTerminal is the same as an EbnfTerminal except that instead of referencing a Terminal, it is referencing a NonTerminal.

EbnfQuantifier

An EbnfQuantifier wraps a child EbnfTerm and allows you to specify the minimum and maximum number of matches that can be made of the child term.

There are pre-defined helpers for standard Kleene operators such as optional (?), zero-or-more (*), and one-or-more (+).

EbnfConcatenation

An EbnfConcatenation is a sequence of other EbnfTerm objects that are matched at the same scope level when performing tree construction.

EbnfAlternation

An EbnfAlternation is a way for one of multiple supplied EbnfTerm options to match. In standard EBNF notation, alternations are typically represented with a vertical bar (|).

Steps to Initialize a Grammar

Now that we’ve covered the basics, let’s dig in and see how it works. We’ll write some grammar creation code that builds the FunctionDeclaration non-terminal example above.

A grammar is generally initialized in its constructor with four steps:

  1. Create terminals
  2. Create non-terminals
  3. Configure non-terminal productions
  4. Configure non-terminal can-match callbacks

Step 1: Create Terminals

The first step is where we simply declare Terminal variables, one for each token that will be supplied to us by a lexer and used in our non-terminal productions.

For the above example EBNF, we have four terminals, so let's declare them:

C#
VB
Copy
​var @closeParenthesis = new Terminal(SimpleTokenId.CloseParenthesis, "CloseParenthesis")
    { ErrorAlias = "')'" };
var @function = new Terminal(SimpleTokenId.Function, "Function")
    { ErrorAlias = "'function'" };
var @identifier = new Terminal(SimpleTokenId.Identifier, "Identifier");
var @openParenthesis = new Terminal(SimpleTokenId.OpenParenthesis, "OpenParenthesis")
    { ErrorAlias = "'('" };
​Dim closeParenthesis = New Terminal(SimpleTokenId.CloseParenthesis, "CloseParenthesis") With {.ErrorAlias = "')'"}
Dim [function] = New Terminal(SimpleTokenId.Function, "Function") With {.ErrorAlias = "'function'"}
Dim identifier = New Terminal(SimpleTokenId.Identifier, "Identifier")
Dim openParenthesis = New Terminal(SimpleTokenId.OpenParenthesis, "OpenParenthesis") With {.ErrorAlias = "'('"}

You’ll notice that each variable has a @ in front of it in the C# snippet. In C#, the @ character is simply an escape character in case the identifier is a keyword. In our case, we’re going to use it just so later in our non-terminal productions, we can easily tell which variables are terminals and which are non-terminals. Similar notation could be done in VB if desired using the square brace escape for identifiers as seen in the function variable declaration.

The Terminal constructor takes a token ID and the string key that identifies the terminal. Note that the SimpleTokenId class contains const token ID values and was generated for us by the Language Designer application. Token IDs are how the grammar parser matches terminals with tokens that are being read. The tokens come from the ITokenReader that was created by the ILLParser in use. See the Parser Infrastructure topic for more information on those types.

Some of the Terminal objects are also assigned an ErrorAlias. When parsing, if a terminal is expected, but the current token doesn’t match, a parse error will be reported that will use the error alias if it is specified. If not specified, it will fall back to using the terminal’s key.

Now that our four terminals are defined, let’s create our non-terminals.

Step 2: Create Non-Terminals

We now declare NonTerminal variables, one for each non-terminal in our grammar.

For this introduction we will just declare one non-terminal variable even though a real grammar would have a lot more and we are even referencing other non-terminals for FunctionParameterList and Block in our production below.

C#
VB
Copy
​var functionDeclaraion = new NonTerminal("FunctionDeclaration");
​Dim functionDeclaraion = New NonTerminal("FunctionDeclaration")

Step 3: Configure Non-Terminal Productions

Finally we come to the meat of the grammar. All terminals and non-terminal variables have been declared and we’re ready to get into some EBNF-like notation for our non-terminal production rules that consists of various EbnfTerm instances.

This is where the real magic of our grammar framework happens. The object model has a lot of operator overloads, methods, indexers, and implicit casts so that you can define production rules with a minimal amount of C#/VB code.

Let’s define our example non-terminal production rule now:

C#
VB
Copy
​functionDeclaration.Production = @function + @identifier + @openParenthesis +
    functionParameterList.Optional() + @closeParenthesis + block;
​functionDeclaration.Production = [function] + identifier + openParenthesis + _
    functionParameterList.Optional() + closeParenthesis + block

In C#, it is our convention to have @ characters at the start of our terminal variables so they stand out differently than non-terminal variables. The + operator means concatenation. Even though we are referencing Terminal and NonTerminal-based variables here, operator overloading is actually converting each Terminal reference to an EbnfTerminal and each NonTerminal reference to an EbnfNonTerminal behind the scenes. Finally note the Optional method call which wraps the EbnfNonTerminal for FunctionParameterList with an EbnfQuantifier that has a minimum of 0 and a maximum of 1.

Step 4: Configure Non-Terminal Can-Match Callbacks

Some grammars have more than one non-terminal that start with the same terminal and since our grammar is LL-based that defaults to one token of look-ahead, it is not allowed to have two or more non-terminals starting with the same terminal in an alternation together. If that was allowed, then the parser would never have the possibility of matching anything but the first non-terminal in the alternation that started with that terminal. This is called ambiguity and the grammar automatically detects it for you and warns you about it when it is found.

You can easily resolve ambiguity by setting a can-match callback on non-terminals that require it. In that case, your custom callback code is executed to determine if a non-terminal can match rather than the normal "first set" way (one token of look-ahead) that is ambiguous. Since the custom callback has access to all the remaining tokens in the text being parsed, it has infinite look-ahead. Thus the grammar as a whole can be considered LL(*).

This is a confusing concept but the Walkthrough: Symbols and EBNF Terms topic shows an example of why and when to do this.

Document End Terminal

Some languages like Visual Basic use line terminators to mark the end of statements. Problems could arise if at the end of a document there was a line containing a statement, and was immediately followed by the document end without a required line terminator in place. Since line terminators are significant to completing the statement, but there was a document end in place of the line terminator, a parse error would be reported.

To handle this scenario, the framework supports matching against document end. The document end terminal must use the standard document end token ID specified in the static DocumentEnd property.

Once a document end terminal has been defined, it can be used in a production like this, which correctly handles the scenario mentioned above:

C#
VB
Copy
​statement.Production = statementBody + (@lineTerminator | @documentEnd);
​statement.Production = statementBody + (@lineTerminator | @documentEnd)

Important Notes

When matching against the document end terminal, it is very important to realize that the parser is already at the document end, so no text is consumed when the match is made. This is unlike normal terminal matches in which case the matched text is consumed.

Thus if the document end terminal is referenced in a scenario where it can be repeatedly matched (such as in a quantifier) without any other required terminal matches in between, the parser could enter an infinite loop scenario.

This example code shows what NOT to do. Note the OneOrMore quantifier that could enter infinite looping at document end:

C#
VB
Copy
​statement.Production = statementBody + (@lineTerminator | @documentEnd).OneOrMore();
​statement.Production = statementBody + (@lineTerminator | @documentEnd).OneOrMore()

In languages like VB where there could be empty statements (effectively just a line terminator), make sure you only have the empty statement production reference the line terminator terminal, and not the document end terminal.

Next Steps

Wasn’t that easy? Of course a real grammar would have a lot more terminals, non-terminals, and production rules but you just follow the same process for them too.

There is one more thing to mention. Let’s assume we have the following input to the parser for this grammar:

Code Snippet
Copy
function Add() {}

The default tree constructors will build a full AST for you without you needing to do anything. Of course it includes much more information than is practical, which is why we’ll show in Tree Constructors topic how to optimize tree construction. Anyhow, here is a text representation of the AST node output for that function using the default tree constructor:

Code Snippet
Copy
FunctionDeclaration[
    "function"
    "Add"
    "("
    []
    ")"
    Block[
        "{"
        []
        "}"
    ]
]

Each AST node in the output automatically stores the proper start/end offsets for you too making it possible to query which node contains an offset later on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Walkthrough: Symbols and EBNF Terms

In this walkthrough, we are going to write a grammar for a language called Simple. The Simple language is basically a small subset of a Javascript-like language. When we're done, we'll load it up into a SyntaxEditor and we'll look at the AST results that are generated for us based on some input code.

This topic contains these sections:

  • Finding the Language Specification and EBNF
  • Grammar Initialization Overview
  • Step 1: Create Terminals
  • Step 2: Create Non-Terminals
  • Step 3: Configure Non-Terminal Productions
  • Step 3a: Elimination of Left Recursion
  • Step 3b: Elimination of Ambiguity
  • Step 4: Configure Non-Terminal Can-Match Callbacks
  • Default Tree Constructor Output

Finding the Language Specification and EBNF

The first thing to do when building a grammar for a language is to locate the language specification for the language. Nearly all programming languages have some sort of formal EBNF specification that tell parsers and compilers how to interpret their code.

This walkthrough series will use the Simple language. The complete EBNF for the Simple language is given in the Simple Language topic.

Grammar Initialization Overview

In the Parser Infrastructure topic, we discussed the creation of a Grammar-derived class. We also discussed that the class constructor will do four tasks:

  1. Create terminals
  2. Create non-teminals
  3. Configure non-terminal productions
  4. Configure non-terminal can-match productions

In the Symbols and EBNF Terms topic, we explained these steps and showed some quick examples. Now let's implement them for the entire language.

Step 1: Create Terminals

In the Simple language's EBNF specification, the terminals are quoted. We’ll now insert Terminal variable declarations for each of the terminals in our language into the constructor for our SimpleGrammar class.

C#
VB
Copy
​var @addition = new Terminal(SimpleTokenId.Addition, "Addition")
    { ErrorAlias = "'+'" };
var @assignment = new Terminal(SimpleTokenId.Assignment, "Assignment")
    { ErrorAlias = "'='" };
var @closeCurlyBrace = new Terminal(SimpleTokenId.CloseCurlyBrace, "CloseCurlyBrace")
    { ErrorAlias = "'}'" };
var @closeParenthesis = new Terminal(SimpleTokenId.CloseParenthesis, "CloseParenthesis")
    { ErrorAlias = "')'" };
var @comma = new Terminal(SimpleTokenId.Comma, "Comma")
    { ErrorAlias = "','" };
var @division = new Terminal(SimpleTokenId.Division, "Division")
    { ErrorAlias = "'/'" };
var @equality = new Terminal(SimpleTokenId.Equality, "Equality")
    { ErrorAlias = "'=='" };
var @function = new Terminal(SimpleTokenId.Function, "Function")
    { ErrorAlias = "'function'" };
var @identifier = new Terminal(SimpleTokenId.Identifier, "Identifier");
var @inequality = new Terminal(SimpleTokenId.Inequality, "Inequality")
    { ErrorAlias = "'!='" };
var @multiplication = new Terminal(SimpleTokenId.Multiplication, "Multiplication")
    { ErrorAlias = "'*'" };
var @number = new Terminal(SimpleTokenId.Number, "Number");
var @openCurlyBrace = new Terminal(SimpleTokenId.OpenCurlyBrace, "OpenCurlyBrace")
    { ErrorAlias = "'{'" };
var @openParenthesis = new Terminal(SimpleTokenId.OpenParenthesis, "OpenParenthesis")
    { ErrorAlias = "'('" };
var @return = new Terminal(SimpleTokenId.Return, "Return")
    { ErrorAlias = "'return'" };
var @semiColon = new Terminal(SimpleTokenId.SemiColon, "SemiColon")
    { ErrorAlias = "';'" };
var @subtraction = new Terminal(SimpleTokenId.Subtraction, "Subtraction")
    { ErrorAlias = "'-'" };
var @var = new Terminal(SimpleTokenId.Var, "Var")
    { ErrorAlias = "'var'" };
​Dim addition = New Terminal(SimpleTokenId.Addition, "Addition") With {.ErrorAlias = "'+'"}
Dim assignment = New Terminal(SimpleTokenId.Assignment, "Assignment") With {.ErrorAlias = "'='"}
Dim closeCurlyBrace = New Terminal(SimpleTokenId.CloseCurlyBrace, "CloseCurlyBrace") With {.ErrorAlias = "'}'"}
Dim closeParenthesis = New Terminal(SimpleTokenId.CloseParenthesis, "CloseParenthesis") With {.ErrorAlias = "')'"}
Dim comma = New Terminal(SimpleTokenId.Comma, "Comma") With {.ErrorAlias = "','"}
Dim division = New Terminal(SimpleTokenId.Division, "Division") With {.ErrorAlias = "'/'"}
Dim equality = New Terminal(SimpleTokenId.Equality, "Equality") With {.ErrorAlias = "'=='"}
Dim [function] = New Terminal(SimpleTokenId.Function, "Function") With {.ErrorAlias = "'function'"}
Dim identifier = New Terminal(SimpleTokenId.Identifier, "Identifier")
Dim inequality = New Terminal(SimpleTokenId.Inequality, "Inequality") With {.ErrorAlias = "'!='"}
Dim multiplication = New Terminal(SimpleTokenId.Multiplication, "Multiplication") With {.ErrorAlias = "'*'"}
Dim number = New Terminal(SimpleTokenId.Number, "Number")
Dim openCurlyBrace = New Terminal(SimpleTokenId.OpenCurlyBrace, "OpenCurlyBrace") With {.ErrorAlias = "'{'"}
Dim openParenthesis = New Terminal(SimpleTokenId.OpenParenthesis, "OpenParenthesis") With {.ErrorAlias = "'('"}
Dim [return] = New Terminal(SimpleTokenId.Return, "Return") With {.ErrorAlias = "'return'"}
Dim semiColon = New Terminal(SimpleTokenId.SemiColon, "SemiColon") With {.ErrorAlias = "';'"}
Dim subtraction = New Terminal(SimpleTokenId.Subtraction, "Subtraction") With {.ErrorAlias = "'-'"}
Dim var = New Terminal(SimpleTokenId.Var, "Var") With {.ErrorAlias = "'var'"}

As mentioned in the Symbols and EBNF Terms topic, it is helpful to prefix terminal variables with a @ character so they can be distinguished from non-terminals in the productions.

The SimpleTokenId class was generated by the Language Designer application and provides constant fields for each token ID produced by the Simple language’s lexer. The second parameter to the Terminal constructor is the terminal key, which is used to identify it.

When errors occur, the key is used in the error message unless an error alias is used. If an error alias is provided, it is used instead. For instance telling the user == expected is a much nicer error message than Equality expected.

Step 2: Create Non-Terminals

Now we’ll declare NonTerminal variables for each non-terminal in the grammar.

C#
VB
Copy
​this.Root = new NonTerminal("CompilationUnit");
var functionDeclaration = new NonTerminal("FunctionDeclaration");
var functionParameterList = new NonTerminal("FunctionParameterList");
var statement = new NonTerminal("Statement");
var block = new NonTerminal("Block");
var emptyStatement = new NonTerminal("EmptyStatement");
var variableDeclarationStatement = new NonTerminal("VariableDeclarationStatement");
var assignmentStatement = new NonTerminal("AssignmentStatement");
var returnStatement = new NonTerminal("ReturnStatement");
var expression = new NonTerminal("Expression");
var equalityExpression = new NonTerminal("EqualityExpression");
var additiveExpression = new NonTerminal("AdditiveExpression");
var multiplicativeExpression = new NonTerminal("MultiplicativeExpression");
var primaryExpression = new NonTerminal("PrimaryExpression");
var numberExpression = new NonTerminal("NumberExpression");
var simpleName = new NonTerminal("SimpleName");
var functionAccessExpression = new NonTerminal("FunctionAccessExpression");
var functionArgumentList = new NonTerminal("FunctionArgumentList");
var parenthesizedExpression = new NonTerminal("ParenthesizedExpression");
​Me.Root = New NonTerminal("CompilationUnit")
Dim functionDeclaration = New NonTerminal("FunctionDeclaration")
Dim functionParameterList = New NonTerminal("FunctionParameterList")
Dim statement = New NonTerminal("Statement")
Dim block = New NonTerminal("Block")
Dim emptyStatement = New NonTerminal("EmptyStatement")
Dim variableDeclarationStatement = New NonTerminal("VariableDeclarationStatement")
Dim assignmentStatement = New NonTerminal("AssignmentStatement")
Dim returnStatement = New NonTerminal("ReturnStatement")
Dim expression = New NonTerminal("Expression")
Dim equalityExpression = New NonTerminal("EqualityExpression")
Dim additiveExpression = New NonTerminal("AdditiveExpression")
Dim multiplicativeExpression = New NonTerminal("MultiplicativeExpression")
Dim primaryExpression = New NonTerminal("PrimaryExpression")
Dim numberExpression = New NonTerminal("NumberExpression")
Dim simpleName = New NonTerminal("SimpleName")
Dim functionAccessExpression = New NonTerminal("FunctionAccessExpression")
Dim functionArgumentList = New NonTerminal("FunctionArgumentList")
Dim parenthesizedExpression = New NonTerminal("ParenthesizedExpression")

Note how the grammar’s Root property is set to the root non-terminal.

Step 3: Configure Non-Terminal Productions

Next is the more interesting part. We’ll configure the production rules for each non-terminal. As explained in the Symbols and EBNF Terms topic, the LL(*) Parser Framework makes heavy use of operator overloads, methods, indexers, and implicit casts so that production rules can be created with minimal C#/VB code.

Here are the productions:

C#
VB
Copy
​this.Root.Production = functionDeclaration.ZeroOrMore();

functionDeclaration.Production = @function + @identifier + @openParenthesis +
    functionParameterList.Optional() + @closeParenthesis + block;

functionParameterList.Production = @identifier + (@comma + @identifier).ZeroOrMore();

statement.Production = block
    | emptyStatement
    | variableDeclarationStatement
    | assignmentStatement
    | returnStatement;

block.Production = @openCurlyBrace + statement.ZeroOrMore() + @closeCurlyBrace;

emptyStatement.Production = semiColon.ToTerm().ToProduction();

variableDeclarationStatement.Production = @var + @identifier + @semiColon;

assignmentStatement.Production = @identifier + @assignment + expression + @semiColon;

returnStatement.Production = @return + expression + @semiColon;

expression.Production = equalityExpression.ToTerm().ToProduction();

equalityExpression.Production = additiveExpression +
    ((@equality | @inequality) + equalityExpression).Optional();

additiveExpression.Production = multiplicativeExpression +
    ((@addition | @subtraction) + additiveExpression).Optional();

multiplicativeExpression.Production = primaryExpression +
    ((@multiplication | @division) + multiplicativeExpression).Optional();

primaryExpression.Production = numberExpression
    | simpleName
    | functionAccessExpression
    | parenthesizedExpression;

numberExpression.Production = @number.ToTerm().ToProduction();

simpleName.Production = @identifier.ToTerm().ToProduction();

functionAccessExpression.Production = @identifier + @openParenthesis +
    functionArgumentList.Optional() + @closeParenthesis;

functionArgumentList.Production = expression + (@comma + expression).ZeroOrMore();

parenthesizedExpression.Production = @openParenthesis + expression + @closeParenthesis;
​Me.Root.Production = functionDeclaration.ZeroOrMore()

functionDeclaration.Production = [function] + identifier + openParenthesis + functionParameterList.Optional() + closeParenthesis + block

functionParameterList.Production = identifier + (comma + identifier).ZeroOrMore()

statement.Production = block Or emptyStatement Or variableDeclarationStatement Or assignmentStatement Or returnStatement

block.Production = openCurlyBrace + statement.ZeroOrMore() + closeCurlyBrace

emptyStatement.Production = semiColon.ToTerm().ToProduction()

variableDeclarationStatement.Production = var + identifier + semiColon

assignmentStatement.Production = identifier + assignment + expression + semiColon

returnStatement.Production = [return] + expression + semiColon

expression.Production = equalityExpression.ToTerm().ToProduction()

equalityExpression.Production = additiveExpression + ((equality Or inequality) + equalityExpression).Optional()

additiveExpression.Production = multiplicativeExpression + ((addition Or subtraction) + additiveExpression).Optional()

multiplicativeExpression.Production = primaryExpression + ((multiplication Or division) + multiplicativeExpression).Optional()

primaryExpression.Production = numberExpression Or simpleName Or functionAccessExpression Or parenthesizedExpression

numberExpression.Production = number.ToTerm().ToProduction()

simpleName.Production = identifier.ToTerm().ToProduction()

functionAccessExpression.Production = identifier + openParenthesis + functionArgumentList.Optional() + closeParenthesis

functionArgumentList.Production = expression + (comma + expression).ZeroOrMore()

parenthesizedExpression.Production = openParenthesis + expression + closeParenthesis

Not so hard, is it? Let’s review some details about what we just did during our translation from the EBNF language specification to these production rules.

Step 3a: Elimination of Left Recursion

The FunctionParameterList, EqualityExpression, AdditiveExpression, MultiplicativeExpression, and FunctionArgumentList all have left recursion in the EBNF specification. Since our grammar is LL-based, that is not permitted.

It’s easy to rearrange our rules to handle this though. First look at how we changed FunctionParameterList. Its EBNF specification says:

Code Snippet
Copy
FunctionParameterList:
    "identifier"
    FunctionParameterList "," identifier

We wrote that in our grammar as:

C#
VB
Copy
​functionParameterList.Production = @identifier + (@comma + @identifier).ZeroOrMore();
​functionParameterList.Production = identifier + (comma + identifier).ZeroOrMore()

Next, let's look at EqualityExpression:

Code Snippet
Copy
EqualityExpression:
    AdditiveExpression
    AdditiveExpression "==" EqualityExpression
    AdditiveExpression "!=" EqualityExpression

We wrote that in our grammar as:

C#
VB
Copy
​equalityExpression.Production = additiveExpression +
    ((@equality | @inequality) + equalityExpression).Optional();
​equalityExpression.Production = additiveExpression + _
    ((equality Or inequality) + equalityExpression).Optional()

The remaining left recursion instances were handled in a similar fashion.

Step 3b: Elimination of Ambiguity

Now let’s try running our grammar within SyntaxEditor. When we do so, we get an exception:

Multiple productions within a NonTerminal 'PrimaryExpression' alternation start with the terminal 'Identifier' either directly or indirectly. The second production that contains a reference to the terminal is: FunctionAccessDeclaration

PrimaryExpression’s EBNF specification says:

Code Snippet
Copy
PrimaryExpression:
    NumberExpression
    SimpleName
    FunctionAccessExpression
    ParenthesizedExpression

The productions of both SimpleName and FunctionAccessExpression start with an Identifier terminal. That means they are ambiguous and the grammar framework detected it for us.

This is where we need to add a can-match callback for one of the non-terminals. In this scenario SimpleName only matches an Identifier while FunctionAccessExpression matches an Identifier followed by an OpenParenthesis. Therefore we’ll put our can-match callback on the FunctionAccessExpression.

First though, let’s move the FunctionAccessExpression in the alternation before the SimpleName. This ensures that its can-match callback will occur before the ambiguity.

C#
VB
Copy
​primaryExpression.Production = numberExpression
    | functionAccessExpression  // This was moved up
    | simpleName
    | parenthesizedExpression;
​primaryExpression.Production = numberExpression _
    Or functionAccessExpression  ' This was moved up _
    Or simpleName _
    Or parenthesizedExpression

Step 4: Configure Non-Terminal Can-Match Callbacks

Let’s make the can-match callback for the FunctionAccessExpression to resolve ambiguity between it and SimpleName:

C#
VB
Copy
​/// <summary>
/// Returns whether the <c>FunctionAccessExpression</c> non-terminal can match.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information
/// about the parser's current state.</param>
/// <returns>
/// <c>true</c> if the <see cref="NonTerminal"/> can match with the current state;
/// otherwise, <c>false</c>.
/// </returns>
private bool CanMatchFunctionAccessExpression(IParserState state) {
    return (state.TokenReader.LookAheadToken.Id == SimpleTokenId.Identifier) &&
        (state.TokenReader.GetLookAheadToken(2).Id == SimpleTokenId.OpenParenthesis);
}
​''' <summary>
''' Returns whether the <c>FunctionAccessExpression</c> non-terminal can match.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information
''' about the parser's current state.</param>
''' <returns>
''' <c>true</c> if the <see cref="NonTerminal"/> can match with the current state;
''' otherwise, <c>false</c>.
''' </returns>
Private Function CanMatchFunctionAccessExpression(ByVal state As IParserState) As Boolean
    Return (state.TokenReader.LookAheadToken.Id = SimpleTokenId.Identifier) AndAlso (state.TokenReader.GetLookAheadToken(2).Id = SimpleTokenId.OpenParenthesis)
End Function

Can-match callbacks are passed an IParserState object. The state gives access to everything from the look-ahead tokens to AST match data and even custom data. The callback returns true if the non-terminal can match with the current state.

In our situation we want to indicate FunctionAccessExpression can match if the next two tokens are Identifier and OpenParenthesis. The above code returns whether that condition is met.

We then wire up the can-match callback to the non-terminal like this:

C#
VB
Copy
​functionAccessExpression.CanMatchCallback = CanMatchFunctionAccessExpression;
​functionAccessExpression.CanMatchCallback = AddressOf CanMatchFunctionAccessExpression

Now we're done with the grammar for this topic's sample.

Default Tree Constructor Output

The LL(*) Parser Framework will automatically generate an AST for you, just based on what we’ve written so far. It will contain AST nodes for each terminal, non-terminal, and quantifier.

Let’s first see what output we get as-is. The input we’ll type in our SyntaxEditor is:

Code Snippet
Copy
function IncrementAndMultiply(x, y) {
    var result;
    result = Increment(x);
    return result * y;
}

Here is the text representation of the AST that was generated:

Code Snippet
Copy
CompilationUnit[
    [
        FunctionDeclaration[
            "function"
            "IncrementAndMultiply"
            "("
            FunctionParameterList[
                "x"
                [
                    ","
                    "y"
                ]
            ]
            ")"
            Block[
                "{"
                [
                    Statement[
                        VariableDeclarationStatement[
                            "var"
                            "result"
                            ";"
                        ]
                    ]
                    Statement[
                        AssignmentStatement[
                            "result"
                            "="
                            Expression[
                                EqualityExpression[
                                    AdditiveExpression[
                                        MultiplicativeExpression[
                                            PrimaryExpression[
                                                FunctionAccessExpression[
                                                    "Increment"
                                                    "("
                                                    FunctionArgumentList[
                                                        Expression[
                                                            EqualityExpression[
                                                                AdditiveExpression[
                                                                    MultiplicativeExpression[
                                                                        PrimaryExpression[
                                                                            SimpleName[
                                                                                "x"
                                                                            ]
                                                                        ]
                                                                        []
                                                                    ]
                                                                    []
                                                                ]
                                                                []
                                                            ]
                                                        ]
                                                        []
                                                    ]
                                                    ")"
                                                ]
                                            ]
                                            []
                                        ]
                                        []
                                    ]
                                    []
                                ]
                            ]
                            ";"
                        ]
                    ]
                    Statement[
                        ReturnStatement[
                            "return"
                            Expression[
                                EqualityExpression[
                                    AdditiveExpression[
                                        MultiplicativeExpression[
                                            PrimaryExpression[
                                                SimpleName[
                                                    "result"
                                                ]
                                            ]
                                            [
                                                "*"
                                            ]
                                            MultiplicativeExpression[
                                                PrimaryExpression[
                                                    SimpleName[
                                                        "y"
                                                    ]
                                                ]
                                                []
                                            ]
                                        ]
                                        []
                                    ]
                                    []
                                ]
                            ]
                            ";"
                        ]
                    ]
                ]
                "}"
            ]
        ]
    ]
]

Obviously this is much more data than is useful and in the Tree Constructors topic we’ll show features for creating a concise AST that only contains the useful data and in a meaningful structure.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tree Constructors

Non-terminal productions will by default produce a very verbose AST that generally contains much more information than is useful for later consumption. The LL(*) Parser Framework has an extremely powerful tree construction mechanism with numerous built-in helper methods to do common tree construction tasks. You also have the ability to create completely custom tree construction nodes via C#/VB code if you like.

In the previous walkthrough topic, we stepped through how to create a grammar for the Simple language (which is similar to a Javascript subset). We showed how easy it was to write the grammar using EBNF-like notation but completely from within your native C#/VB code. We also showed how the grammar automatically generates an AST of the parsed document for you.

This topic will show how to completely customize the AST output so that it focuses only on the information we care about.

This topic contains these sections:

  • Default Tree Construction
  • Scopes and Labels
  • Customizing Tree Constructors
  • Tree Construction Type Summary and Comparison
  • Core Built-in Tree Construction Nodes
  • Type-Specific Built-in Tree Construction Nodes
  • Creating Custom Tree Construction Nodes
  • Left Associativity

Default Tree Construction

The default tree constructors will output nearly everything that is parsed. Each AST node that is generated automatically contains the offset range of the text that created it.

AST nodes generated by the default tree constructors implement IAstNode and are of type DefaultAstNode.

Productions

Any EBNF production will create a scope and will output a new hierarchy level node in an AST. The AST node that is created can have zero to many children, depending on what was matched within the production.

If the production is the root production for a non-terminal, then the AST node that is output for the production will have a value that is the non-terminal’s key. Note that productions can be used within other productions. In that case, the nested productions generate an AST node that has children but no value.

Terminals

Terminals, which match tokens, will output an AST node with no children that has a value of the text that was read.

Quantifiers

“Optional” quantifiers will output the tree construction results for the quantifier’s child term if the term matched successfully. Otherwise an empty structural AST node will be output.

For any other quantifier (“zero-or-more”, “one-or-more”, etc.), a new scope is created within the quantifier. The quantifier will output a new hierarchy level node in the AST. The AST node that is created can have zero to many children, depending on what was matched in the quantifier.

Scopes and Labels

A couple places in the previous section mentioned where scopes are created. Namely, scopes occur in productions and in quantifiers (ones other than "optional" quantifiers).

Any EBNF term, other than EbnfConcatenation, can be assigned a label. A label is a way for a tree constructor to identify something that was matched in its scope. Labels are only useful when creating custom tree constructors.

Terminals and non-terminals, represented by the Terminal and NonTerminal classes can be auto-converted to their EBNF term equivalents (EbnfTerminal and EbnfNonTerminal) by calling their indexer and passing the label as a string parameter.

So say we have a terminal within a production for an identifier and we want to apply a name label to it. We can do so like this:

C#
VB
Copy
​@identifier["name"]
​identifier("name")

For any object that is EbnfTerm-based, there is a SetLabel method you can call instead like:

C#
VB
Copy
​statement.ZeroOrMore().SetLabel("stmt")
​statement.ZeroOrMore().SetLabel("stmt")

In that example, statement is a NonTerminal, its ZeroOrMore method call converted it to an EbnfNonTerminal and wrapped it with an EbnfQuantifier. Finally we set the label stmt on the quantifier via the SetLabel method.

Note Note
Labels cannot be set on EbnfConcatenation objects, but can be set on any other EbnfTerm-based object.

Customizing Tree Constructors

Adding tree constructors to a production is easy. So far we’ve only seen how to indicate the EBNF pattern expression for a production. A tree constructor can be added to this by using the > operator followed by an ITreeConstructionNode instance like this:

C#
VB
Copy
​expression.Production = equalityExpression["exp"] > AstFrom("exp");
​expression.Production = equalityExpression["exp"] > AstFrom("exp")

In the above sample code, a production was created for an Expression non-terminal, which simply calls into an EqualityExpression non-terminal. It applies a label to that non-terminal’s results so that the tree constructor can work with them. The AstFrom tree constructor simply looks for a match with the specified label and returns its value.

Thus the result of a match with this production is the result of the EqualityExpression non-terminal. If we didn’t include the tree constructor portion of the above production, the result would be an Expression AST node whose child was the result of the EqualityExpression non-terminal.

Tree Construction Type Summary and Comparison

There are numerous built-in tree construction node types that should handle nearly all your tree construction needs. In extreme cases where the built-in functionality isn't enough, it is possible to create your own custom tree construction nodes.

Note Note
Sections below discuss DefaultAstNode and type-specific AST nodes. For more information on the difference between these types of AST nodes, see the AST Nodes topic. The Language Designer also has features that allow you to code generate classes for type-specific AST nodes.

Type Summary

There are several types of tree construction:

Type Description
Default (built-in)

Automatically used when no tree constructors are specified in a production and output nearly everything that is parsed using DefaultAstNode instances.

The default tree constructors are good to use when first writing a grammar's EBNF productions since they give you immediate feedback on what is parsed without having to take time to write tree constructors. However they are certainly not idea for production use since they include much more information than what is desired or needed.

Core (built-in)

Manually added to the tree constructor portion of productions via the use of the various non-generic AstXX methods found on the Grammar class.

AST nodes created using these methods are DefaultAstNode instances. These nodes are fine to use in production since they should be optimized to contain only meaningful data based on how how you specified the tree constructor portion of the productions.

Type-Specific (built-in)

Manually added to the tree constructor portion of productions via the use of the various generic AstXX methods found on the Grammar class.

AST nodes created using these methods are of the type passed into the method as a generic argument, and can have various properties on the type set. Since the AST nodes used are dedicated .NET partial classes, they can easily be extended with helper methods. These nodes are the most ideal for production, since they have a more efficient AST structure. As an example, for simple cases where the AST needs to store a string value, a string property on the AST node can be set, as opposed to how DefaultAstNode would need to create an AST node to store the value and likely wrap it with another contextual AST node.

The downside of type-specific nodes is that they require a bit more work since many new classes need to be created, one for each AST node type. That being said, the Language Designer has features that can code generate the classes for you based on some quick configuration settings.

Custom

Manually added to the tree construction portion of productions via the instantiation of the custom class used to implement the tree construction node.

Custom nodes are used in scenarios where there is custom processing needed to properly handle matches made in a production, that the built-in tree construction nodes can't handle.

Comparison

To best illustrate the differences between the various built-in node types, let's make a production for a C# if-statement. Its EBNF is stated as:

Code Snippet
Copy
if-statement:
"if" "(" boolean-expression ")" embedded-statement
"if" "(" boolean-expression ")" embedded-statement "else" embedded-statement

For these samples, we'll use the same input code:

Code Snippet
Copy
if (isTrue) return 1 else return 0;

This comparison is just an introduction to the various built-in node types. Details on how to work with each is included in other sections below.

First is the default tree constructors, where no tree constructor is specified in a production:

C#
VB
Copy
​ifStatement.Production = @keywordIf + @openParenthesis + booleanExpression +
    @closeParenthesis + embeddedStatement + (@keywordElse + embeddedStatement).Optional();
​ifStatement.Production = keywordIf + openParenthesis + booleanExpression + _
    closeParenthesis + embeddedStatement + (keywordElse + embeddedStatement).Optional()

The output from the default tree constructors would be similar to this, which includes nodes for everything, even the punctuation:

Code Snippet
Copy
IfStatement[
    "If",
    "(",
    SimpleName[
        "isTrue"
    ],
    ")"
    ReturnStatement[
        LiteralExpression[
            "1"
        ]
    ],
    "Else",
    ReturnStatement[
        LiteralExpression[
            "0"
        ]
    ]
]

Now let's use the core tree construction nodes:

C#
VB
Copy
​ifStatement.Production = @keywordIf + @openParenthesis +
    booleanExpression["conditionexp"].OnErrorContinue() +
    @closeParenthesis.OnErrorContinue() + embeddedStatement["truestmt"].OnErrorContinue() +
    (@keywordElse + embeddedStatement["falsestmt"].OnErrorContinue()).Optional()
    > Ast("IfStatement",
        Ast("ConditionExpression", AstFrom("conditionexp")),
        Ast("TrueStatement", AstFrom("truestmt")),
        Ast("FalseStatement", AstFrom("falsestmt")));
​ifStatement.Production = keywordIf + openParenthesis + _
    booleanExpression("conditionexp").OnErrorContinue() + _
    closeParenthesis.OnErrorContinue() + embeddedStatement("truestmt").OnErrorContinue() + _
    (keywordElse + embeddedStatement("falsestmt").OnErrorContinue()).Optional() _
    > Ast("IfStatement", _
        Ast("ConditionExpression", AstFrom("conditionexp")), _
        Ast("TrueStatement", AstFrom("truestmt")), _
        Ast("FalseStatement", AstFrom("falsestmt")))

The output from the core tree constructors would be similar to this, which is much more concise than the default tree constructors:

Code Snippet
Copy
IfStatement[
    ConditionExpression [
        SimpleName[
            "isTrue"
        ]
    ],
    TrueStatement[
        ReturnStatement[
            LiteralExpression[
                "1"
            ]
        ]
    ],
    FalseExpression[
        ReturnStatement[
            LiteralExpression[
                "0"
            ]
        ]
    ]
]

For the final comparison, we'll use type-specific tree constructors:

C#
VB
Copy
​ifStatement.Production = @keywordIf + @openParenthesis +
    booleanExpression["conditionexp"].OnErrorContinue() +
    @closeParenthesis.OnErrorContinue() +
    embeddedStatement["truestmt"].OnErrorContinue() +
    (@keywordElse + embeddedStatement["falsestmt"].OnErrorContinue()).Optional()
    > Ast<IfStatement>()
        .SetProperty(s => s.ConditionExpression, AstFrom("conditionexp"))
        .SetProperty(s => s.TrueStatement, AstFrom("truestmt"))
        .SetProperty(s => s.FalseStatement, AstFrom("falsestmt"));
​ifStatement.Production = keywordIf + openParenthesis + _
    booleanExpression("conditionexp").OnErrorContinue() + _
    closeParenthesis.OnErrorContinue() + _
    embeddedStatement("truestmt").OnErrorContinue() + _
    (keywordElse + embeddedStatement("falsestmt").OnErrorContinue()).Optional() _
    > Ast(Of IfStatement)() _
        .SetProperty(Function(s) s.ConditionExpression, AstFrom("conditionexp")) _
        .SetProperty(Function(s) s.TrueStatement, AstFrom("truestmt")) _
        .SetProperty(Function(s) s.FalseStatement, AstFrom("falsestmt"))

The output from this is an instance of the IfStatement class, along with various other classes that represent each type of AST node.

Code Snippet
Copy
new IfStatement {
    ConditionExpression = new SimpleName {
        Text = "isTrue"
    },
    TrueStatement = new ReturnStatement {
        Expression = new LiteralExpression() {
            Value = 1
        }
    },
    FalseStatement = new ReturnStatement {
        Expression = new LiteralExpression() {
            Value = 0
        }
    }
}

From this comparison, it's easy to see how either the core or type-specific tree construction types are good for production use. The type-specific tree construction type takes a bit more work simply because classes need to be created for each AST node type, but in the end you get a nicer and more flexible AST model.

Core Built-in Tree Construction Nodes

There are a number of core built-in tree construction nodes that should handle nearly all your tree construction needs. These nodes are created by method calls on the Grammar class.

Ast(string value, params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the Ast method will create a DefaultAstNode with the specified value and optional child nodes.

This tree construction node is the most basic building block used in tree construction, as it allows you to wrap other AST nodes with an AST node that has a specific value, generally the name of the containing non-terminal.

This example creates an AST node with value ReturnStatement that has a child node resulting from an EBNF term match whose label is exp:

C#
VB
Copy
​returnStatement.Production = @return + expression["exp"] + @semiColon
    > Ast("ReturnStatement", AstFrom("exp"));
​returnStatement.Production = [return] + expression("exp") + semiColon _
    > Ast("ReturnStatement", AstFrom("exp"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
return 1;

The first parameter passed to Ast method, ReturnStatement, becomes the value of the root AST node returned by the tree constructor. The result of the Expression match, in this case 1, is returned directly as a child of the ReturnStatement node via the AstFrom method. Note that the Return and SemiColon terminals are discarded since they are not important for our AST.

AstValueOf(ITreeConstructionNode valueOfNode, params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the AstValueOf method works the same way as Ast except that the root node created will have the value of the valueOfNode tree construction node result’s value.

This tree construction node is used when your resulting AST node's value is based on some match's value, instead of a fixed value such as what is provided to the Ast method.

This example for an XML attribute name and value shows how a parent AST node can be created whose value is the attribute name and the child AST node will be the attribute value:

C#
VB
Copy
​xmlAttribute.Production = @startTagAttrName["attrName"] + @startTagAttrValStart + @startTagAttrValText["attrValue"] + @startTagAttrValEnd
    > AstValueOf(AstFrom("attrName"), AstFrom("attrValue"))
​xmlAttribute.Production = startTagAttrName("attrName") + startTagAttrValStart + startTagAttrValText("attrValue") + startTagAttrValEnd _
    > AstValueOf(AstFrom("attrName"), AstFrom("attrValue"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
Language="English"

Note how the the root AST node's value is the value of a match, in this case Language.

AstFrom(string label)

The ITreeConstructionNode generated by the AstFrom method will create an AST node from an EBNF term match with the specified label.

This tree construction node is useful when merging resulting AST nodes within another container AST node, such as one generated by a call to the Ast method. See the Ast method example above for a sample showing one typical use of the AstFrom method.

Another common use of this tree construction node is to "promote" a child match node up without wrapping it by another node. This example shows how a generalized Statement production can match a certain kind of statement (a Block) and have the BlockStatement result bubble up without it being wrapped by a Statement node. For a real language, normally there would be other similar statement types in an alternation with the Block term.

C#
VB
Copy
​statement.Production = block["stmt"]
    > AstFrom("stmt")
​statement.Production = block("stmt") _
    > AstFrom("stmt")

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
{ ... }

Note how the results of the Block term are directly returned without being wrapped by another AST node.

AstChildFrom(string label)

The ITreeConstructionNode generated by the AstChildFrom method will create an AST node from the first child of an EBNF term match with the specified label.

This tree construction node is similar to AstFrom however instead of returning the resulting AST node of the specified match, it is returning the first child AST node within that resulting AST node, thus skipping a level.

Note Note
An overload of this method allows for specification of a particular child node index. The default child index is 0, meaning the first child.

This example for a binary operator expression shows how the operator used will be the value of the root node created, but only if the leftexp and rightexp returned matches. If only one match occurred (no operator was used), then that match will be directly passed up. The operator portion of this production is actually a nested child production, thus its result is wrapped by an AST node with no value by default. The use of AstChildFrom allows us to retrieve the matched operator value, while discarding the wrapper AST node.

C#
VB
Copy
​additiveExp.Production = multiplicativeExp["leftexp"] + ((@addition | @subtraction).SetLabel("op") + additiveExp["rightexp"]).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));
​additiveExp.Production = multiplicativeExp("leftexp") + ((addition Or subtraction).SetLabel("op") + additiveExp("rightexp")).Optional() _
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
1 + 2

This production uses the powerful AstValueOfConditional method, which contains conditional logic. The value of the operator nested production becomes the value of the root AST node and the values of the left and right expressions become the values of child AST nodes.

In an alternate scenario if the input was just 1 then AstValueOfConditional would just promote the left expression AST node with value 1 up without wrapping it by an operator AST node.

AstChildrenFrom(string label)

The ITreeConstructionNode generated by the AstChildrenFrom method will create an AST node from the children of an EBNF term match with the specified label.

Since the result of this particular tree construction node is a list, it can never be used as the root return value of a production.

This example creates an AST node with value CompilationUnit that contains the children of an EBNF term match whose label is decl:

C#
VB
Copy
​compilationUnit.Production = functionDeclaration.ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));
​compilationUnit.Production = functionDeclaration.ZeroOrMore().SetLabel("decl") _
    > Ast("CompilationUnit", AstChildrenFrom("decl"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
function Foo() {}
function Bar() {}

The root AST node returned has value CompilationUnit, and has child AST nodes that represent the AST node results of the FunctionDeclaration non-terminal calls.

An overload of AstChildrenFrom accepts a nesting level parameter, which allows for retrieval of nodes two or more levels deep. A value of 0 passed to this overload means take the direct children, same as the functionality described above. A value of 1 passed as the nesting level means return grandchildren nodes instead. This functionality is helpful in scenarios where the desired list of results are wrapped by another AST node.

AstConditionalFrom(string value, string label)

The ITreeConstructionNode generated by the AstConditionalFrom method will create a DefaultAstNode with the specified value whose child nodes come from the children of the specified labeled EBNF term match, but only if at least one child node is available. If no child nodes are available, nothing is created.

This tree construction node is very handy when there are things such as optional parameter or argument lists in a grammar and you don’t want to clutter up the resulting AST when a particular member doesn’t have parameters or arguments.

This example creates a FunctionAccessExpression AST node whose first child comes from an EBNF term match with label name. The next child will be an Arguments node but only if there was at least one child within an EBNF term match with label args.

C#
VB
Copy
​functionAccessExp.Production = @identifier["name"] + @openParenthesis + functionArgumentList["args"].Optional() + @closeParenthesis
    > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"));
​functionAccessExp.Production = identifier("name") + openParenthesis + functionArgumentList("args").Optional() + closeParenthesis _
    > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
Foo(1, 2)

The root FunctionAccessExpression AST node's first child node has the value of the name match, in this case Foo. Since there was more than one argument passed, AstConditionalFrom injects a second child node called Arguments, whose children are the argument AST nodes.

Alternatively if the input was Foo(), the Arguments node and its children would not have been in the result.

AstConditional(string value, params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the AstConditional method will create a DefaultAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.

This behavior is very similar to the logic for the AstConditionalFrom method, except that the arguments to AstConditional can be individual tree constructors or the special AstChildrenFrom tree constructor that can return zero to many results.

This example creates an AST node with value Parameters that has child nodes from the union of the children of EBNF term matches params1 and params2:

C#
VB
Copy
​functionParameters.Production = AstConditional("Parameters", AstChildrenFrom("params1"), AstChildrenFrom("params2"))
​AstConditional("Parameters", AstChildrenFrom("params1"), AstChildrenFrom("params2"))

Note that if only one result came from the union of params1 and params2 children, that single result would be returned and would not be wrapped by a Parameters node.

AstValueOfConditional(ITreeConstructionNode valueOfNode, params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the AstValueOfConditional method works the same way as AstConditional except that the root node created when there is more than one child available will have the value of the valueOfNode tree construction node result’s value.

A sample usage for this tree construction node is included in the AstChildFrom sample above.

AstCount(params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the AstCount method will create an AST node whose value is the count of IAstNode objects generated by contained nodes.

This tree construction node is useful in scenarios where you need a count of matched objects.

This example counts the number of dimensions in an array rank specifier. Note that since it counts commas, an additional result is included to make the result one-based instead of zero-based:

C#
VB
Copy
​rankSpecifier.Production = @openSquareBrace + @comma.ZeroOrMore().SetLabel("dims") + @closeSquareBrace.OnErrorContinue()
    > AstCount(Ast("FirstDim"), AstChildrenFrom("dims"));
​rankSpecifier.Production = openSquareBrace + comma.ZeroOrMore().SetLabel("dims") + closeSquareBrace.OnErrorContinue() _
    > AstCount(Ast("FirstDim"), AstChildrenFrom("dims"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
[,,]

The resulting AST node has a value of 3, which is 1 (from the hardcoded node) added to 2 (the number of commas).

Type-Specific Built-in Tree Construction Nodes

Type-specific tree construction nodes can be used when you have type-specific AST nodes, which can easily be code generated by the Language Designer.

There are several type-specific built-in tree construction nodes which are similar to their non-generic core counterparts. These nodes are created by generic method calls on the Grammar class.

Each of the type-specific tree construction nodes implement the ITypedTreeConstructionNode`1 interface, which has methods on it that allow for altering of properties on the type. These properties are described in more detail below.

Type-Specific Tree Construction Nodes

The following generic methods are available on the Grammar class to create type-specific tree construction nodes. In each case, the generic type argument passed to the method indicates the Type of AST node to create. Since they work similarly to their core non-generic counterparts, please see the documentation above for more details on how and when to use them.

Method | Description
Ast<T>() | This node works similarly to the core non-generic Ast method in that it creates a new instance of an AST node. However instead of a DefaultAstNode being created with a certain value, the AST node instance created is of the type passed as a generic type argument, and properties can be set on it.
AstFrom<T>(string label) | This node works exactly the same as the core non-generic AstFrom method in that it returns the node that was matched using the specified label. The only difference is that the node instance is cast to the type passed as a generic type argument and properties can be set on the instance.
AstConditional<T>(params ITreeConstructionNode[] childNodes) | This node works similarly to the core non-generic AstConditional method in that it creates a new AST node instance only if two or more child AST nodes are passed in. The type created in this instance is the type passed as a generic type argument, and properties can be set on the created isntance. If instead only one child AST node is passed in, it is directly returned and no new AST node is created or properties assigned.
AstLeftAssociativity<T, U>(ITreeConstructionNode childNode, ...) | This node provides special advanced functionality to update the AST tree such that left associativity is supported when appropriate. See the section below on Left Associativity for more information on what it means.

Modifying AST Node Properties

All of the three tree constructor generic methods described above return an ITypedTreeConstructionNode`1 instance, which has several methods on it for describing how to update properties on the related type-specific AST node.

Note that all of these methods use one or more lambda expressions that indicate the property to update. This enables type checking and validation by the C#/VB compiler.

SetProperty

The SetProperty method is the most-used mechanism to update properties. It calls a setter for the specified property to set it to a new value. Depending on the property’s return type, different logic is used for how to obtain its value. Strings, integers, booleans, enums, flags enums, and AST node properties are supported.

Multiple instances of these values can be passed to the method for a single property too, which is especially useful for things like type modifiers. Generally there are zero or more type modifiers allowed on a type. So we end up with a list of them. But say our type-specific AST node for type declarations has a Modifiers property where the Modifiers enum value is a flags enum. In this case SetProperty will automatically OR all the flags found together and set the resulting value to the property.

Similar logic is available for strings (which get concatenated), ints (which get added together), and bools (which get OR’ed together). Generally though, only a single AST node result is passed to SetProperty for examination.

This sample shows the use of SetProperty. Note that even though a type-specific AST node is being created, we can still use core tree construction node to obtain property values.

C#
VB
Copy
​constantDeclarator.Production = simpleNameWithoutTypeArguments["name"] +
    @operatorAssignment.OnErrorContinue() + constantExpression["exp"].OnErrorContinue()
    > Ast<VariableDeclarator>()
        .SetProperty(d => d.Name, AstFrom("name"))
        .SetProperty(d => d.Initializer, AstFrom("exp"))
        .SetProperty(d => d.Kind, VariableDeclaratorKind.Constant);
​constantDeclarator.Production = simpleNameWithoutTypeArguments("name") + _
    operatorAssignment.OnErrorContinue() + constantExpression("exp").OnErrorContinue() _
    > Ast(Of VariableDeclarator)() _
        .SetProperty(Function(d) d.Name, AstFrom("name")) _
        .SetProperty(Function(d) d.Initializer, AstFrom("exp")) _
        .SetProperty(Function(d) d.Kind, VariableDeclaratorKind.Constant)

Another overload of SetProperty allows a literal value to be assigned as the value like the above production where a constant declarator should always have its Kind property set to a specific enumeration value.

AppendToProperty

The AppendToProperty method works the same as SetProperty. The only difference is that instead of wiping out any previous property value, the previous value is included in the OR/concatenation/addition logic described above for SetProperty when multiple AST node values are passed.

This sample shows the use of AppendToProperty.

C#
VB
Copy
​typeDeclaration.Production = attributeSection.OnErrorContinue().ZeroOrMore().SetLabel("attrs") +
    modifier.OnErrorContinue().ZeroOrMore().SetLabel("modifiers") + typeDeclarationCore["decl"]
    > AstFrom<IDecoratedMember>("decl")
        .AddToCollectionProperty(d => d.AttributeSections, AstChildrenFrom("attrs"))
        .AppendToProperty(d => d.Modifiers, AstChildrenFrom("modifiers"));
​typeDeclaration.Production = attributeSection.OnErrorContinue().ZeroOrMore().SetLabel("attrs") + _
    modifier.OnErrorContinue().ZeroOrMore().SetLabel("modifiers") + typeDeclarationCore("decl") _
    > AstFrom(Of IDecoratedMember)("decl") _
        .AddToCollectionProperty(Function(d) d.AttributeSections, AstChildrenFrom("attrs")) _
        .AppendToProperty(Function(d) d.Modifiers, AstChildrenFrom("modifiers"))

The above production shows usage of AppendToProperty and how it will not wipe out any existing modifiers values that came in from the declaration AST node returned in label decl. Instead it will take the existing property value and OR in any matched modifiers. The result is set as the new Modifiers property value.

AddToCollectionProperty

The AddToCollectionProperty method appends one or more AST node result values to a collection property. In the production above, any attribute section AST nodes that are matched are added to the the AttributeSections list property.

SetCollectionItemProperties

The SetCollectionItemProperties method works just like SetProperty except that instead of setting the property value on the target AST node, it sets the properties of all items in a collection property on the target AST node.

This sample shows the use of SetCollectionItemProperties.

C#
VB
Copy
​constantDeclaration.Production = @keywordConst + type["type"] + constantDeclarator["decl"].OnErrorContinue() +
    (@comma + constantDeclarator["decl"] > AstFrom("decl")).OnErrorContinue().ZeroOrMore().SetLabel("moredecls") + @semiColon.OnErrorContinue()
    > Ast<FieldDeclaration>()
        .AddToCollectionProperty(d => d.Declarators, AstFrom("decl"), AstChildrenFrom("moredecls"))
        .SetCollectionItemProperties(d => d.Declarators, v => v.Type, AstFrom("type"));
​constantDeclaration.Production = keywordConst + type("type") + constantDeclarator("decl").OnErrorContinue() + _
    (comma + constantDeclarator("decl") > AstFrom("decl")).OnErrorContinue().ZeroOrMore().SetLabel("moredecls") + semiColon.OnErrorContinue() _
    > Ast(Of FieldDeclaration)() _
        .AddToCollectionProperty(Function(d) d.Declarators, AstFrom("decl"), AstChildrenFrom("moredecls")) _
        .SetCollectionItemProperties(Function(d) d.Declarators, Function(v) v.Type, AstFrom("type"))

Take the above production as an example. First a FieldDeclaration AST node is created and any declarators that were matched are added to its Declarators property. Then since in C# the type is defined before the declarators, we need a way to push the type down to each VariableDeclarator instance in the Declarators collection. This is where SetCollectionItemProperties comes in to save the day.

Creating Custom Tree Construction Nodes

The built-in tree construction nodes should handle nearly all the tree construction scenarios you have. But what if there is something that requires some additional programmatic logic? No problem, you can simply create a class that implements ITreeConstructionNode and inject it anywhere just like you do with the results of the above methods.

The abstract TreeConstructionNodeBase class implements ITreeConstructionNode and is provided to be used as base class for any custom tree construction nodes that do not have any child tree construction nodes. The abstract ParentTreeConstructionNodeBase class, which inherits TreeConstructionNodeBase, is provided to be used as a base class for any custom tree construction nodes that do have other child tree construction nodes.

To better illustrate how this works, let's consider a scenario with the C# language grammar we encountered when working on the .NET Languages Add-on. When building a C# type name, it is possible to have a namespace alias at the start. global:: is a special one, meaning start at the root empty namespace. Normally we capture the alias before the double colons in an Alias property of our QualifiedName class. However if the alias global was used, we wanted to clear that and mark a special flag instead. To do this, we made a custom tree constructor like this:

C#
VB
Copy
​/// <summary>
/// Implements a tree constructor for the <c>QualifiedName</c> non-terminal.
/// </summary>
/// <remarks>
/// Converts a "global::" from an alias to an <c>IsGlobal</c> flag.
/// </remarks>
private class QualifiedNameTreeConstructionNode : ParentTreeConstructionNodeBase {

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // OBJECT
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Initializes a new instance of the <c>QualifiedNameTreeConstructionNode</c> class.
    /// </summary>
    /// <param name="childNode">The child node containing the declaration.</param>
    public QualifiedNameTreeConstructionNode(ITreeConstructionNode childNode) : base(childNode) {}

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // PUBLIC PROCEDURES
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Returns the <see cref="IAstNode"/> that is created for this tree construction node.
    /// </summary>
    /// <param name="matches">The collection of matched <see cref="IAstNode"/> objects within the current <see cref="IAstNodeBuilder"/> scope.</param>
    /// <returns>The <see cref="IAstNode"/> that is created for this tree construction node.</returns>
    public override IAstNode CreateNode(IAstNodeMatchCollection matches) {
        var childNode = this.Children.FirstOrDefault();
        if (childNode != null) {
            var qualifiedNameAstNode = childNode.CreateNode(matches) as QualifiedName;
            if (qualifiedNameAstNode != null) {
                if (qualifiedNameAstNode.Alias == "global") {
                    // Switch access type
                    qualifiedNameAstNode.IsGlobal = true;
                    qualifiedNameAstNode.Alias = null;
                }

                return qualifiedNameAstNode;
            }
        }

        return null;
    }

}
​''' <summary>
''' Implements a tree constructor for the <c>QualifiedName</c> non-terminal.
''' </summary>
''' <remarks>
''' Converts a "global::" from an alias to an <c>IsGlobal</c> flag.
''' </remarks>
Private Class QualifiedNameTreeConstructionNode
    Inherits ParentTreeConstructionNodeBase

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' OBJECT
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Initializes a new instance of the <c>QualifiedNameTreeConstructionNode</c> class.
    ''' </summary>
    ''' <param name="childNode">The child node containing the declaration.</param>
    Public Sub New(ByVal childNode As ITreeConstructionNode)
        MyBase.New(childNode)
    End Sub

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' PUBLIC PROCEDURES
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Returns the <see cref="IAstNode"/> that is created for this tree construction node.
    ''' </summary>
    ''' <param name="matches">The collection of matched <see cref="IAstNode"/> objects within the current <see cref="IAstNodeBuilder"/> scope.</param>
    ''' <returns>The <see cref="IAstNode"/> that is created for this tree construction node.</returns>
    Public Overrides Function CreateNode(ByVal matches As IAstNodeMatchCollection) As IAstNode
        Dim childNode = Me.Children.FirstOrDefault()
        If childNode IsNot Nothing Then
            Dim qualifiedNameAstNode = TryCast(childNode.CreateNode(matches), QualifiedName)
            If qualifiedNameAstNode IsNot Nothing Then
                If qualifiedNameAstNode.Alias = "global" Then
                    ' Switch access type
                    qualifiedNameAstNode.IsGlobal = True
                    qualifiedNameAstNode.Alias = Nothing
                End If

                Return qualifiedNameAstNode
            End If
        End If

        Return Nothing
    End Function

End Class

This code shows how it can be used from within a grammar:

C#
VB
Copy
​qualifiedAliasMember.Production = identifierOrContextualKeyword["lefti"] + @namespaceAliasQualifier + simpleName["righti"].OnErrorContinue()
    > new QualifiedNameTreeConstructionNode(
        Ast<QualifiedName>()
            .SetProperty(qn => qn.Alias, AstFrom("lefti"))
            .AddToCollectionProperty(qn => qn.Identifiers, AstFrom("righti"))
        );
​qualifiedAliasMember.Production = identifierOrContextualKeyword("lefti") + namespaceAliasQualifier + simpleName("righti").OnErrorContinue() _
    > New QualifiedNameTreeConstructionNode( _
        Ast(Of QualifiedName)() _
            .SetProperty(Function(qn) qn.Alias, AstFrom("lefti")) _
            .AddToCollectionProperty(Function(qn) qn.Identifiers, AstFrom("righti")) _
        )

Left Associativity

Most languages have left associativity within them, in the form of binary operators. This is best explained in an example with a diagram. Assume we have normal math expressions such as subtraction in a language, and in the code we write 8 - 5 - 2.

The left side shows how an AST is constructed for that expression with left associativity. The right side shows how an AST is constructed for that expression with right associativity (how the LL(*) parser works). When reading through AST nodes later, you can see how a different result can be obtained from one way or the other.

Note that the correct result can be reached if the AST consumer recognizes this kind of AST scenario where binary operator nodes recurse off to the right and in those cases treats all the nodes as being at the same level, and interprets the leaf nodes in sequence, left-to-right. Most languages also feature some form of parenthesized expression node, which also can be used to identify points where the code really did want right associativity.

Since the Actipro grammar is LL(*) based and doesn't allow left recursion, left associativity is not normally an option in tree constructors. There are three solutions available to make a left associative result.

1: Don't Use Binary Operators

Instead of having a binary operator expression node that only takes two children, use an operator expression node that supports any number of child expressions. Then populate it with child expression nodes at the same level that use operators of a similar precedence level. This way when your AST consumer reaches the operator node, it just reads through all the children left-to-right.

2: Use a Custom Tree Constructor to Alter the AST Results

For grammars using default generic tree constructors, a custom tree construction node can be written per information in the section above to watch for this scenario and alter the AST results approprately.

3: Use the AstLeftAssociativity Method

For grammars using default type-specific tree constructors, there is a built-in Grammar.AstLeftAssociativity method that does all the heavy lifting of altering the AST tree for you. Say a language has a BinaryOperatorExpression AST node type which inherits an Expression node type. The BinaryOperatorExpression has LeftExpression, RightExpression, and Operator properties, where the operator property uses an OperatorKind enumeration.

This code shows how it can be used from within a grammar:

C#
VB
Copy
​additiveExpression.Production = multiplicativeExpression["leftexp"] + (
        (
            @operatorAddition > Ast(OperatorKind.Addition.ToString())
            | @operatorSubtraction > Ast(OperatorKind.Subtraction.ToString())
        ).SetLabel("op") + additiveExpression["rightexp"]).Optional()
    > AstLeftAssociativity<Expression, BinaryOperatorExpression>(
        AstConditional<BinaryOperatorExpression>(AstFrom("leftexp"), AstFrom("rightexp"))
            .SetProperty(e => e.Operator, AstFrom("op"))
            .SetProperty(e => e.LeftExpression, AstFrom("leftexp"))
            .SetProperty(e => e.RightExpression, AstFrom("rightexp")),
        n => n.LeftExpression,
        n => n.RightExpression,
        (n1, n2) => BinaryOperatorKindCheck(n1, n2, OperatorKind.Addition, OperatorKind.Subtraction));
​additiveExpression.Production = multiplicativeExpression("leftexp") + ( _
        ( _
            operatorAddition > Ast(OperatorKind.Addition.ToString()) _
            Or operatorSubtraction > Ast(OperatorKind.Subtraction.ToString()) _
        ).SetLabel("op") + additiveExpression("rightexp")).Optional() _
    > AstLeftAssociativity(Of Expression, BinaryOperatorExpression)( _
        AstConditional(Of BinaryOperatorExpression)(AstFrom("leftexp"), AstFrom("rightexp")) _
            .SetProperty(Function(e) e.Operator, AstFrom("op")) _
            .SetProperty(Function(e) e.LeftExpression, AstFrom("leftexp")) _
            .SetProperty(Function(e) e.RightExpression, AstFrom("rightexp")), _
        Function(n) n.LeftExpression, _
        Function(n) n.RightExpression, _
        Function(n1, n2) BinaryOperatorKindCheck(n1, n2, OperatorKind.Addition, OperatorKind.Subtraction))

There are two generic type arguments to the method. The first is the more generic type that we know is being bubbled up. The second is the derived type that can optionally be created by the production, in this case BinaryOperatorExpression

For method arguments, the first is the other tree constructor whose AST node result will be examined. The second and third arguments specify how to access the left and right side properties on a BinaryOperatorExpression. The final parameter is an optional condition predicate that returns true if the associativity should be changed.

The BinaryOperatorKindCheck method used in the predicate is a simple method that looks at the Operator property of each node and ensures that it is one of the supplied values. This ensures that operator precedence is properly maintained, since other higher-precedence operators like division should not be affected by the AstLeftAssociativity tree constructor for this particular additive expression production.

C#
VB
Copy
​private bool BinaryOperatorKindCheck(BinaryOperatorExpression expr1, BinaryOperatorExpression expr2, params OperatorKind[] operators) {
    if ((expr1 != null) && (expr2 != null) && (operators != null)) {
        // Ensure the expressions both contain one of the desired operators (to ensure proper operator precedence)
        return ((operators.Contains(expr1.Operator)) && (operators.Contains(expr2.Operator)));
    }
    return false;
}
​Private Function BinaryOperatorKindCheck(ByVal expr1 As BinaryOperatorExpression, ByVal expr2 As BinaryOperatorExpression, ParamArray ByVal operators() As OperatorKind) As Boolean
    If (expr1 IsNot Nothing) AndAlso (expr2 IsNot Nothing) AndAlso (operators IsNot Nothing) Then
        ' Ensure the expressions both contain one of the desired operators (to ensure proper operator precedence)
        Return ((operators.Contains(expr1.Operator)) AndAlso (operators.Contains(expr2.Operator)))
    End If
    Return False
End Function

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Walkthrough: Tree Constructors

In the Tree Constructors topic, we gave an introduction to the powerful tree construction mechanism that is built into the LL(*) Parser Framework and talked about each of the built-in tree construction nodes that are available.

In this walkthrough, we are going to revisit the Simple language and will enhance our grammar productions with core tree constructors so that we make the resulting AST very concise.

This topic contains these sections:

  • Simple Language Grammar Review
  • Grammar Tree Constructor Enhancements
  • Elimination of Empty Value Nodes
  • Elimination of Unimportant Terminal Nodes
  • Elimination of Expression Nodes That Don’t Apply
  • More Conditional Output

Simple Language Grammar Review

The grammar productions we set up in the Walkthrough: Symbols and EBNF Terms topic all use the default tree constructors, so the AST output when parsing documents is extremely verbose.

When we look at the output, we see lots of empty nodes that contain other nodes, nodes for tokens such as ( that we don't care about, and lots of extra nodes for various expressions (like AdditiveExpression) that don't really apply here, but which are inserted due to how expressions are defined.

Let's fix all these problems right now by modifying out grammar productions to add tree constructors.

Grammar Tree Constructor Enhancements

Here is the modified set of grammar productions we’ll use. Note the tree constructors that are now present in nearly all of the productions as compared to our original grammar productions listed above.

C#
VB
Copy
​// Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
//   which is zero or more FunctionDeclarations
this.Root.Production = functionDeclaration.ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));

// Outputs a 'FunctionDeclaration' node with children:
//   1) The function declaration name value
//   2) A 'Parameters' node that contains each parameter name; or nothing gets inserted
//      if there are no parameters
//   3) The Block statement result
functionDeclaration.Production = @function + @identifier["name"] + @openParenthesis + functionParameterList["params"].Optional() + @closeParenthesis + block["block"]
    > Ast("FunctionDeclaration", AstFrom("name"), AstConditionalFrom("Parameters", "params"), AstFrom("block"));

// Outputs a 'FunctionParameterList' node whose children are parameter name values...
//   Is an excellent sample of how to build node for a delimited list
functionParameterList.Production = @identifier["param"] + (@comma + @identifier["param"] > AstFrom("param")).ZeroOrMore().SetLabel("moreparams")
    > Ast("FunctionParameterList", AstFrom("param"), AstChildrenFrom("moreparams"));

// Outputs the result that came from the appropriate statement type that was matched...
//   We don't want to wrap the results with a 'Statement' node so we use AstFrom
statement.Production = block["stmt"] > AstFrom("stmt")
    | emptyStatement > null
    | variableDeclarationStatement["stmt"] > AstFrom("stmt")
    | assignmentStatement["stmt"] > AstFrom("stmt")
    | returnStatement["stmt"] > AstFrom("stmt");

// Outputs a 'Block' node whose children are the contained statements
block.Production = @openCurlyBrace + statement.ZeroOrMore().SetLabel("stmt") + @closeCurlyBrace
    > Ast("Block", AstChildrenFrom("stmt"));

// Don't output anything since we don't care about empty statements
emptyStatement.Production = semiColon > null;

// Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = @var + @identifier["name"] + @semiColon
    > Ast("VariableDeclarationStatement", AstFrom("name"));

// Outputs a 'AssignmentStatement' node whose children are the variable name and the assigned expression
assignmentStatement.Production = @identifier["varname"] + @assignment + expression["exp"] + @semiColon
    > Ast("AssignmentStatement", AstFrom("varname"), AstFrom("exp"));

// Outputs a 'ReturnStatement' node whose child is the expression to return
returnStatement.Production = @return + expression["exp"] + @semiColon
    > Ast("ReturnStatement", AstFrom("exp"));

// Outputs the resulting node from the EqualityExpression
expression.Production = equalityExpression["exp"] > AstFrom("exp");

// Outputs the resulting node from the AdditiveExpression; or if an equality operator is found,
//   outputs a '==' or '!=' node whose children are the left and right child expressions of the operator
equalityExpression.Production = additiveExpression["leftexp"] + ((@equality | @inequality).SetLabel("op") + equalityExpression["rightexp"]).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the resulting node from the MultiplicativeExpression; or if an additive operator is found,
//   outputs a '+' or '-' node whose children are the left and right child expressions of the operator
additiveExpression.Production = multiplicativeExpression["leftexp"] + ((@addition | @subtraction).SetLabel("op") + additiveExpression["rightexp"]).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the resulting node from the PrimaryExpression; or if an multiplicative operator is found,
//   outputs a '*' or '/' node whose children are the left and right child expressions of the operator
multiplicativeExpression.Production = primaryExpression["leftexp"] + ((@multiplication | @division).SetLabel("op") + multiplicativeExpression["rightexp"]).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the result that came from the appropriate expression type that was matched...
//   We don't want to wrap the results with a 'Expression' node so we use AstFrom
primaryExpression.Production = numberExpression["exp"] > AstFrom("exp")
    | functionAccessExpression["exp"] > AstFrom("exp")
    | simpleName["exp"] > AstFrom("exp")
    | parenthesizedExpression["exp"] > AstFrom("exp");

// Outputs the numeric value
numberExpression.Production = @number.ToTerm().ToProduction();

// Outputs the name value
simpleName.Production = @identifier.ToTerm().ToProduction();

// Outputs a 'FunctionAccessExpression' node with children:
//   1) The function name
//   2) An 'Arguments' node that contains each argument name; or nothing gets inserted
//      if there are no arguments
functionAccessExpression.Production = @identifier["name"] + @openParenthesis + functionArgumentList["args"].Optional() + @closeParenthesis
    > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"));

// Outputs a 'FunctionArgumentList' node whose children are argument expressions...
//   Is an excellent sample of how to build node for a delimited list
functionArgumentList.Production = expression["exp"] + (@comma + expression["exp"] > AstFrom("exp")).ZeroOrMore().SetLabel("moreexps")
    > Ast("FunctionArgumentList", AstFrom("exp"), AstChildrenFrom("moreexps"));

// Outputs a 'ParenthesizedExpression' node whose child is the contained expression
parenthesizedExpression.Production = @openParenthesis + expression["exp"] + @closeParenthesis
    > Ast("ParenthesizedExpression", AstFrom("exp"));
​' Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
'   which is zero or more FunctionDeclarations
Me.Root.Production = functionDeclaration.ZeroOrMore().SetLabel("decl") > Ast("CompilationUnit", AstChildrenFrom("decl"))

' Outputs a 'FunctionDeclaration' node with children:
'   1) The function declaration name value
'   2) A 'Parameters' node that contains each parameter name; or nothing gets inserted
'      if there are no parameters
'   3) The Block statement result
functionDeclaration.Production = [function] + identifier("name") + openParenthesis + functionParameterList("params").Optional() + closeParenthesis + block("block") > Ast("FunctionDeclaration", AstFrom("name"), AstConditionalFrom("Parameters", "params"), AstFrom("block"))

' Outputs a 'FunctionParameterList' node whose children are parameter name values...
'   Is an excellent sample of how to build node for a delimited list
functionParameterList.Production = identifier("param") + (comma + identifier("param") > AstFrom("param")).ZeroOrMore().SetLabel("moreparams") > Ast("FunctionParameterList", AstFrom("param"), AstChildrenFrom("moreparams"))

' Outputs the result that came from the appropriate statement type that was matched...
'   We don't want to wrap the results with a 'Statement' node so we use AstFrom
statement.Production = block("stmt") > AstFrom("stmt") Or emptyStatement > Nothing Or variableDeclarationStatement("stmt") > AstFrom("stmt") Or assignmentStatement("stmt") > AstFrom("stmt") Or returnStatement("stmt") > AstFrom("stmt")

' Outputs a 'Block' node whose children are the contained statements
block.Production = openCurlyBrace + statement.ZeroOrMore().SetLabel("stmt") + closeCurlyBrace > Ast("Block", AstChildrenFrom("stmt"))

' Don't output anything since we don't care about empty statements
emptyStatement.Production = semiColon > Nothing

' Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = var + identifier("name") + semiColon > Ast("VariableDeclarationStatement", AstFrom("name"))

' Outputs a 'AssignmentStatement' node whose children are the variable name and the assigned expression
assignmentStatement.Production = identifier("varname") + assignment + expression("exp") + semiColon > Ast("AssignmentStatement", AstFrom("varname"), AstFrom("exp"))

' Outputs a 'ReturnStatement' node whose child is the expression to return
returnStatement.Production = [return] + expression("exp") + semiColon > Ast("ReturnStatement", AstFrom("exp"))

' Outputs the resulting node from the EqualityExpression
expression.Production = equalityExpression("exp") > AstFrom("exp")

' Outputs the resulting node from the AdditiveExpression; or if an equality operator is found,
'   outputs a '==' or '!=' node whose children are the left and right child expressions of the operator
equalityExpression.Production = additiveExpression("leftexp") + ((equality Or inequality).SetLabel("op") + equalityExpression("rightexp")).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the resulting node from the MultiplicativeExpression; or if an additive operator is found,
'   outputs a '+' or '-' node whose children are the left and right child expressions of the operator
additiveExpression.Production = multiplicativeExpression("leftexp") + ((addition Or subtraction).SetLabel("op") + additiveExpression("rightexp")).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the resulting node from the PrimaryExpression; or if an multiplicative operator is found,
'   outputs a '*' or '/' node whose children are the left and right child expressions of the operator
multiplicativeExpression.Production = primaryExpression("leftexp") + ((multiplication Or division).SetLabel("op") + multiplicativeExpression("rightexp")).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the result that came from the appropriate expression type that was matched...
'   We don't want to wrap the results with a 'Expression' node so we use AstFrom
primaryExpression.Production = numberExpression("exp") > AstFrom("exp") Or functionAccessExpression("exp") > AstFrom("exp") Or simpleName("exp") > AstFrom("exp") Or parenthesizedExpression("exp") > AstFrom("exp")

' Outputs the numeric value
numberExpression.Production = number.ToTerm().ToProduction()

' Outputs the name value
simpleName.Production = identifier.ToTerm().ToProduction()

' Outputs a 'FunctionAccessExpression' node with children:
'   1) The function name
'   2) An 'Arguments' node that contains each argument name; or nothing gets inserted
'      if there are no arguments
functionAccessExpression.Production = identifier("name") + openParenthesis + functionArgumentList("args").Optional() + closeParenthesis > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"))

' Outputs a 'FunctionArgumentList' node whose children are argument expressions...
'   Is an excellent sample of how to build node for a delimited list
functionArgumentList.Production = expression("exp") + (comma + expression("exp") > AstFrom("exp")).ZeroOrMore().SetLabel("moreexps") > Ast("FunctionArgumentList", AstFrom("exp"), AstChildrenFrom("moreexps"))

' Outputs a 'ParenthesizedExpression' node whose child is the contained expression
parenthesizedExpression.Production = openParenthesis + expression("exp") + closeParenthesis > Ast("ParenthesizedExpression", AstFrom("exp"))

You can see we’re now making use of labels and all the various Ast* methods described in the Tree Constructors topic. Let’s use the same input as we did at the end of the Walkthrough: Symbols and EBNF Terms topic and see how our AST now looks:

Code Snippet
Copy
CompilationUnit[
    FunctionDeclaration[
        "IncrementAndMultiply"
        Parameters[
            "x"
            "y"
        ]
        Block[
            VariableDeclarationStatement[
                "result"
            ]
            AssignmentStatement[
                "result"
                FunctionAccessExpression[
                    "Increment"
                    Arguments[
                        SimpleName[
                            "x"
                        ]
                    ]
                ]
            ]
            ReturnStatement[
                *[
                    SimpleName[
                        "result"
                    ]
                    SimpleName[
                        "y"
                    ]
                ]
            ]
        ]
    ]
]

Now that’s a big improvement. We only have nodes for information that is important to us. And as mentioned in the past, each AST node that is generated automatically adds which start/end offsets it occurs over, which is invaluable information for consuming the AST later on.

Elimination of Empty Value Nodes

You’ll note that we completely eliminated all empty value nodes that are generated by quantifiers. An example is where in the root non-terminal’s production, we create a CompilationUnit whose child nodes come directly from the child nodes of the ZeroOrMore quantifier.

Elimination of Unimportant Terminal Nodes

We no longer have any AST nodes that relate to unimportant terminals such as ( or {. We now only have AST nodes for terminals that are meaningful to the code structure.

Elimination of Expression Nodes That Don’t Apply

Due to how expressions must be defined to properly set up operator precedence, the default tree constructors would create a lot of nodes such as AdditiveExpression that didn’t apply for this input. With our modifications, we’ve completely eliminated those extra expressions. You’ll note our return statement at the end generates an AST node whose value is * (the operator used) and whose two children are the left and right child expressions to be multiplied. This functionality is achieved via the tree construction node provided by the AstValueOfConditional method.

More Conditional Output

Although the above input doesn’t show it, say IncrementAndMultiply didn’t have any parameters. Via use of the tree construction node created by AstConditionalFrom, the Parameters node would have been left out of the AST output in that case.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Callbacks and Error Handling

The next step in building a grammar is to make sure that it properly handles errors. After all, since this grammar framework is intended to be used with SyntaxEditor, our code editor control, we have to assume that most of the time the document’s code passed to our grammar parser will be in an invalid state. The user is continuously typing and modifying it.

In this topic, we will look at the various callbacks that are available to you, probably the most important of which are the error handling callbacks. We'll also dig into error handling options.

This topic contains these sections:

  • What is a Callback?
  • EbnfTerm Callbacks
  • Important Notes on Callback Assignments
  • Built-in Error Callbacks
  • Advanced Error Handling
  • Error Precedence
  • Non-Terminal Can-Match Callbacks
  • Terminal Can-Match Callbacks
  • Proper Design of Iterative Productions
  • Best Practices for Error Handling

What is a Callback?

As we’ve seen previously, our entire grammar is built directly in C# or VB code. We do not do code generation like a lot of other parser generators do. A benefit of this is that you can interact directly with objects in the grammar.

One way to interact with objects is to assign callbacks to them. All EbnfTerm-based objects support four callbacks:

  • Initialize
  • Success
  • Error
  • Complete

And as shown in other topics, NonTerminal objects can be assigned a can-match callback.

Callbacks are simply delegates that get called when certain events occur. You can point them to methods you declare or can inject lambda expressions as well.

Let’s look at each of the five callbacks.

EbnfTerm Callbacks

Initialize and Complete callbacks

The Initialize callback is called right before an EbnfTerm is about to be parsed. The Complete callback is called right after an EbnfTerm has been parsed. Thus they are always paired.

It is important to note that Complete is called regardless of whether the term’s parsing succeeded or failed.

Success and Error callbacks

The Success callback is called right after an EbnfTerm is parsed successfully. Alternatively, if the EbnfTerm was not parsed successfully, the Error callback is called. Thus each term that is attempted to be parsed will either have its Success or Error callbacks fired.

The Success and Error callbacks occur immediately before the Complete callback does.

Summary of EbnfTerm Callbacks

A term that is successfully parsed will offer this sequence of callbacks:

  • Initialize
  • (parsing attempt here)
  • Success
  • Complete

A term that is not successfully parsed will offer this sequence of callbacks:

  • Initialize
  • (parsing attempt here)
  • Error
  • Complete

Definitions

The Initialize, Success, and Complete callbacks have this definition:

C#
VB
Copy
​public delegate void ParserCallback(IParserState state);
​Public Delegate Sub ParserCallback(ByVal state As IParserState)

It is passed an IParserState that gives you access to look-ahead tokens, custom data, and the matches that have been made at the current scope level. You can update custom data, or even modify the matches collection if you wish in any of these callbacks.

Custom data can be anything you wish. Perhaps as you traverse through certain non-terminals, you want to maintain a stack of which ones you’ve visited. Your custom data could contain such a stack. In the Initialize callback for the non-terminals you wish to track, you could push an item on the stack. In the Complete callback for the non-terminals you wish to track, you could pop an item off the stack.

The Error callback has this definition:

C#
VB
Copy
​public delegate IParserErrorResult ParserErrorCallback(IParserState state);
​Public Delegate Function ParserErrorCallback(ByVal state As IParserState) As IParserErrorResult

The Error callback also gets an IParserState passed to it. However it differs from the others in that it expects an IParserErrorResult object returned. Since the Error callback is called when an error occurs, this result tells the parser how to proceed. There are options for preventing any errors from being reported and options for whether to continue on as if no error occurred.

The standard set of options are provided in the ParserErrorResults object via static properties:

  • Default – Potentially report errors and return a match failure.
  • Continue – Potentially report errors but continue on.
  • Ignore – Never report errors and continue on.
  • NoReport – Never report errors and return a match failure.

Sample callback

Callbacks can be assigned with the OnInitialize, OnSuccess, OnError, and OnComplete methods.

This root production shows how an Error callback can be assigned by calling the OnError method and passing it the delegate to use. In this case the method that will be called is AdvanceToDefaultState.

C#
VB
Copy
​this.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));
​Me.Root.Production = functionDeclaration.OnError(AddressOf AdvanceToDefaultState).ZeroOrMore().SetLabel("decl") _
    > Ast("CompilationUnit", AstChildrenFrom("decl"))

What happens is that if an error occurs while parsing FunctionDeclaration, the AdvanceToDefaultState method is called, which does this:

C#
VB
Copy
​/// <summary>
/// Advances the token reader to the next 'function' token from where parsing
/// can resume.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information
/// about the parser's current state.</param>
/// <returns>An <see cref="IParserErrorResult"/> value indicating a result.</returns>
private IParserErrorResult AdvanceToDefaultState(IParserState state) {
    state.TokenReader.AdvanceTo(SimpleTokenId.Function);
    return ParserErrorResults.Continue;
}
​''' <summary>
''' Advances the token reader to the next 'function' token from where parsing
''' can resume.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information
''' about the parser's current state.</param>
''' <returns>An <see cref="IParserErrorResult"/> value indicating a result.</returns>
Private Function AdvanceToDefaultState(ByVal state As IParserState) As IParserErrorResult
    state.TokenReader.AdvanceTo(SimpleTokenId.Function)
    Return ParserErrorResults.Continue
End Function

You can see how it tells the token reader to advance to the next Function token. We have skipped over any potentially “bad” tokens and have gone right to the next token that we know will successfully start a FunctionDeclaration.

The callback returns ParserErrorResults.Continue, which means potentially report an error, but continue on instead of breaking out of the ZeroOrMore quantifier that contains the FunctionDeclaration non-terminal.

Important Notes on Callback Assignments

Both the Symbol (terminals and non-terminals) and the various EbnfTerm-based classes have methods to be able to assign the callbacks above, along with the built-in error callbacks described below in this topic.

If the callback assign method is called on a Symbol-based class then a related EbnfTerm-based class (either EbnfTerminal or EbnfNonTerminal) is created, assigned the callback, and is returned by the method. It is important to note that the callback is not assigned on the Symbol instance itself, only on the EbnfTerm class that is returned by the method.

On the other hand, if the callback assign method is called on an EbnfTerm-based class, the callback is directly assigned to it and the EbnfTerm same instance is returned.

Say that you want to assign a Complete callback onto a CompilationUnit non-terminal so you can examine the AST that was created by the parse and report any additional parse errors as needed. You may be tempted to do this:

C#
VB
Copy
​compilationUnit.Production = [your EBNF production here];
compilationUnit.OnComplete(CompilationUnitComplete);
​compilationUnit.Production = [your EBNF production here]
compilationUnit.OnComplete(AddressOf CompilationUnitComplete)

Per above, the various OnXX calls on a symbol like NonTerminal will create an EbnfNonTerminal instance and will assign the callback to that. Since we're not capturing the return value of the OnComplete call here within a production, the EBNF term is discarded and the callback is never used.

One way to do what was intended is to do this instead:

C#
VB
Copy
​compilationUnit.Production = [your EBNF production here];
compilationUnit.Production.CompleteCallback = CompilationUnitComplete;
​compilationUnit.Production = [your EBNF production here]
compilationUnit.Production.CompleteCallback = AddressOf CompilationUnitComplete

This code assigns the callback to the EbnfProduction for the CompilationUnit non-terminal, and will thus always get called properly.

Another way to accomplish the same thing is inline like this:

C#
VB
Copy
​compilationUnit.Production = ([your EBNF production here]).OnComplete(CompilationUnitComplete);
​compilationUnit.Production = ([your EBNF production here]).OnComplete(AddressOf CompilationUnitComplete)

Built-in Error Callbacks

There are also some built-in Error callbacks that you can assign. They don’t do anything other than return the various related ParserErrorResults values:

  • OnErrorContinue – Returns ParserErrorResults.Continue.
  • OnErrorIgnore – Returns ParserErrorResults.Ignore.
  • OnErrorNoReport – Returns ParserErrorResults.NoReport.

This example shows the use of OnErrorContinue, where we will report an error if the semi-colon isn’t matched, but we’ll continue on with parsing as if it was there:

C#
VB
Copy
​variableDeclarationStatement.Production = @var + @identifier["name"] + @semiColon.OnErrorContinue()
    > Ast("VariableDeclarationStatement", AstFrom("name"));
​variableDeclarationStatement.Production = var + identifier("name") + semiColon.OnErrorContinue() _
    > Ast("VariableDeclarationStatement", AstFrom("name"))

Advanced Error Handling

Sometimes errors will occur where a non-terminal is referenced however that non-terminal is capable of starting with multiple different terminals. In that case, the parser doesn’t report an error by default since it doesn’t know what it should say. Here’s a perfect example:

C#
VB
Copy
​returnStatement.Production = @return + expression["exp"].OnErrorContinue() + @semiColon.OnErrorContinue()
    > Ast("ReturnStatement", AstFrom("exp"));
​returnStatement.Production = [return] + expression("exp").OnErrorContinue() + semiColon.OnErrorContinue() _
    > Ast("ReturnStatement", AstFrom("exp"))

Say the input for this production was return return. Obviously that is invalid as the second return keyword doesn’t fit into an expression. Expression can start with numerous terminals so an error occurs but no parse error is reported into the parse errors collection since the parser doesn’t know what to tell the UI.

We have two options for handling this scenario.

Option 1 - Use an Error Alias

When a NonTerminal is assigned an ErrorAlias, it will report an error by default if it fails to match. You only want to set error aliases on higher-level non-terminals such as Expression or Statement non-terminals. You can do so like this:

C#
VB
Copy
​var expression = new NonTerminal("Expression") { ErrorAlias = "Expression" };
​Dim expression = New NonTerminal("Expression") With {.ErrorAlias = "Expression"}

That will tell the parser to automatically report an Expression expected parse error if Expression fails to match. This is the easiest way to handle this scenario.

Option 2 - Custom Error Callback

The second option that can be used if we need to customize the error message more is to use an error callback:

C#
VB
Copy
​returnStatement.Production = @return + expression["exp"].OnError(ExpressionExpected) + @semiColon.OnErrorContinue()
    > Ast("ReturnStatement", AstFrom("exp"));
​returnStatement.Production = [return] + expression("exp").OnError(AddressOf ExpressionExpected) + semiColon.OnErrorContinue() _
    > Ast("ReturnStatement", AstFrom("exp"))

The error callback can be implemented like this:

C#
VB
Copy
​/// <summary>
/// Occurs when an expression is expected but not found.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information
/// about the parser's current state.</param>
/// <returns>An <see cref="IParserErrorResult"/> value indicating a result.</returns>
private IParserErrorResult ExpressionExpected(IParserState state) {
    // Report a custom error, and return a value telling the parser to not report
    // errors and continue on
    state.ReportError(ParseErrorLevel.Error, "Expression should have been here.");
    return ParserErrorResults.Ignore;
}
​''' <summary>
''' Occurs when an expression is expected but not found.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information
''' about the parser's current state.</param>
''' <returns>An <see cref="IParserErrorResult"/> value indicating a result.</returns>
Private Function ExpressionExpected(ByVal state As IParserState) As IParserErrorResult
    ' Report a custom error, and return a value telling the parser to not report
    ' errors and continue on
    state.ReportError(ParseErrorLevel.Error, "Expression should have been here.")
    Return ParserErrorResults.Ignore
End Function

Note that here we report an error Expression should have been here instead of the Expression expected message that comes from option #1. We also return ParserErrorResults.Ignore to ensure that no other error message is reported, and tell the parser to continue on.

Note Note
The IParserState interface defines multiple methods that can be used to report parse errors within callbacks.

Error Precedence

We've now seen how both terminals and non-terminals are capable of reporting parse errors that can be displayed in the user interface. In some scenarios, multiple errors may be reported for a given text offset. Allowing this can really confuse the end user. The grammar framework has built in functionality such that it will only report the first parse error for a given offset, since that is the most important one.

The parse error collection returned in the parse data result back to the document will also be sorted by each error’s location in the document.

Non-Terminal Can-Match Callbacks

Can-match callbacks can optionally be assigned to any NonTerminal. Since our grammar is LL-based, each NonTerminal maintains a set of terminals that it knows are able to start it. This is called the "first set". For instance a Simple language FunctionDeclaration production always starts with a Function terminal. Thus the FunctionDeclaration’s first set consists of a single Function terminal.

Sometimes you may have an alternation EBNF term with two or more non-terminal references that have intersecting first sets. We see this in the Simple language where both the SimpleName and FunctionAccessExpression non-terminal productions start with Identifier terminals, and the PrimaryExpression non-terminal production is an alternation that contains both of them. This situation is called ambiguity and the grammar will warn you when it detects the scenario so that you can fix it.

When a can-match callback is specified, it effectively overrides the "first set" of the non-terminal. Thus in the Simple language where the ambiguity occurred, the ambiguity is resolved by applying a can-match callback to one of the ambiguous non-terminals.

Note Note
The NonTerminal.CanMatch method can be used to determine if a specified IParserState's look-ahead token can start to match the NonTerminal. The method examines the non-terminal's "first set" as well as its can-match callbacks to determine the result.

Definition

A can-match callback has this definition:

C#
VB
Copy
​public delegate bool ParserCanMatchCallback(IParserState state);
​Public Delegate Function ParserCanMatchCallback(ByVal state As IParserState) As Boolean

It is passed an IParserState and the result is a boolean value indicating whether the non-terminal can match with the current state. Logic in the callback is generally implemented such that it examines look-ahead tokens to see what the next several tokens are. Since you are able to look ahead all the way to the end of the document if you wish, that is the reason our grammar is LL(*). The * means infinite look-ahead.

Sample callback

The Simple language grammar’s FunctionAccessExpression has a can-match callback. This code can be used to assign the callback:

C#
VB
Copy
​functionAccessExpression.CanMatchCallback = CanMatchFunctionAccessExpression;
​functionAccessExpression.CanMatchCallback = AddressOf CanMatchFunctionAccessExpression

And here is the callback implementation:

C#
VB
Copy
​/// <summary>
/// Returns whether the <c>FunctionAccessExpression</c> non-terminal can match.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information
/// about the parser's current state.</param>
/// <returns>
/// <c>true</c> if the <see cref="NonTerminal"/> can match with the current state;
/// otherwise, <c>false</c>.
/// </returns>
private bool CanMatchFunctionAccessExpression(IParserState state) {
    return (state.TokenReader.LookAheadToken.Id == SimpleTokenId.Identifier) &&
        (state.TokenReader.GetLookAheadToken(2).Id == SimpleTokenId.OpenParenthesis);
}
​''' <summary>
''' Returns whether the <c>FunctionAccessExpression</c> non-terminal can match.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information
''' about the parser's current state.</param>
''' <returns>
''' <c>true</c> if the <see cref="NonTerminal"/> can match with the current state;
''' otherwise, <c>false</c>.
''' </returns>
Private Function CanMatchFunctionAccessExpression(ByVal state As IParserState) As Boolean
    Return (state.TokenReader.LookAheadToken.Id = SimpleTokenId.Identifier) AndAlso (state.TokenReader.GetLookAheadToken(2).Id = SimpleTokenId.OpenParenthesis)
End Function

Smaller callback implementations can be entered directly in a single statement via lambdas like this:

C#
VB
Copy
​functionAccessExpression.CanMatchCallback = (state =>
    (state.TokenReader.LookAheadToken.Id == SimpleTokenId.Identifier) &&
    (state.TokenReader.GetLookAheadToken(2).Id == SimpleTokenId.OpenParenthesis) );
​functionAccessExpression.CanMatchCallback = (Function(state) _
    (state.TokenReader.LookAheadToken.Id = SimpleTokenId.Identifier) AndAlso _
    (state.TokenReader.GetLookAheadToken(2).Id = SimpleTokenId.OpenParenthesis))

Token Reader AreNext Helper Method

A lot of times, can-match callbacks just involve checking for a specific sequence of two or more tokens such as in the example above. The ITokenReader.AreNext helper method is available for these scenarios. It accepts two or more token IDs and the returns if that exact sequence of tokens is next.

The previous example could therefore be simplified to:

C#
VB
Copy
​functionAccessExpression.CanMatchCallback = (state =>
    state.TokenReader.AreNext(SimpleTokenId.Identifier, SimpleTokenId.OpenParenthesis));
​functionAccessExpression.CanMatchCallback = (Function(state) _
    state.TokenReader.AreNext(SimpleTokenId.Identifier, SimpleTokenId.OpenParenthesis))

Token Reader Push/Pop Methods

Sometimes a can-match callback may require multiple token look-ahead, where special conditions are checked along the way. Special ITokenReader.Push and related Pop methods are available for this scenario.

Normally reading ahead through tokens in a can-match callback would consume the token, preventing it from later being parsed. By calling Push, the state of the token reader is saved. You then can advance through as many tokens as you wish and then Pop the old state back into place.

Here is an example of their usage for a C# language grammar that checks to see if a local variable declaration can start:

C#
VB
Copy
​private bool CanMatchLocalVariableDeclaration(IParserState state) {
    state.TokenReader.Push();
    try {
        if (state.TokenReader.LookAheadToken.Id == CSharpTokenId.Var) {
            // Advance past 'var'
            state.TokenReader.Advance();
        }
        else if (!this.IsType(state))
            return false;

        // Ensure that an identifier or contextual keyword can match at this point
        return identifierOrContextualKeyword.CanMatch(state);
    }
    finally {
        state.TokenReader.Pop();
    }
}
​Private Function CanMatchLocalVariableDeclaration(ByVal state As IParserState) As Boolean
    state.TokenReader.Push()
    Try
        If state.TokenReader.LookAheadToken.Id = CSharpTokenId.Var Then
            ' Advance past 'var'
            state.TokenReader.Advance()
        ElseIf Not Me.IsType(state) Then
            Return False
        End If

        ' Ensure that an identifier or contextual keyword can match at this point
        Return identifierOrContextualKeyword.CanMatch(state)
    Finally
        state.TokenReader.Pop()
    End Try
End Function

Note we are able to freely advance through tokens and do other calls (like to the IsType method) that also advance through more tokens to tell us if the conditions to start this non-terminal are met.

CanAlwaysMatch Callback

There is a built-in method called Grammar.CanAlwaysMatch which is a can-match callback that always returns true. This callback is useful as described in the next section.

Terminal Can-Match Callbacks

Although a lesser-used feature, terminals can also support can-match callbacks, similar to non-terminals. Normally when no can-match callback is specified on a terminal, the terminal's first set is considered the token ID value associated with it.

An example use for this feature is say that you have some contextual keywords, meaning identifiers that turn into keywords but only in certain parser contexts. The lexer in use may always mark them as identifiers but in certain grammar productions you want to look for these identifiers that have a certain value. In this case you would define a terminal that had a can-match callback to first make sure the look-ahead token is an identifier. If so, it would check its text value to see if it matches the contextual keyword text. That is one way to handle contextual keywords like var or from in C#.

Proper Design of Iterative Productions

Very often a root compilation unit has some other set of non-terminals that repeat within it. In this case we set up a non-terminal EBNF term with an error handler and place it in a ZeroOrMore quantifier like this:

C#
VB
Copy
​this.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));
​Me.Root.Production = functionDeclaration.OnError(AddressOf AdvanceToDefaultState).ZeroOrMore().SetLabel("decl") _
    > Ast("CompilationUnit", AstChildrenFrom("decl"))

What happens here is that if an error occurs in FunctionDeclaration it will advance to the next function token (per above) and will continue on with the next FunctionDeclaration match.

But what happens if at the start of the document we have an invalid token instead, such as an Identifier? FunctionDeclaration doesn’t start with an Identifier terminal. It only starts with a Function terminal. Thus the entire ZeroOrMore quantifier will never be entered and your CompilationUnit AST node output will be empty, even if there are a lot of valid function declarations after that initial Identifier.

We can easily handle this scenario by using the Grammar.CanAlwaysMatch callback on FunctionDeclaration:

C#
VB
Copy
​// Make sure FunctionDeclaration will always be examined,
// even if the next token is not 'function'
functionDeclaration.CanMatchCallback = CanAlwaysMatch;
​' Make sure FunctionDeclaration will always be examined,
' even if the next token is not 'function'
functionDeclaration.CanMatchCallback = AddressOf CanAlwaysMatch

Thus we have forced the "first set" of FunctionDeclaration to be overridden and even tokens like Identifier will cause us to enter FunctionDeclaration. In that scenario, Identifier won’t match with the Function terminal and an error will be reported that indicates 'function' expected. This scenario is now properly handled.

Advanced Implementations

What about languages such as C# where you could have a using statement, namespace, or type declaration at the root compilation unit level? We’ll apply the same concepts.

Make a new non-terminal called CompilationUnitContent that has an alternation between those other non-terminals. Make the root production call CompilationUnitContent in the same way FunctionDeclaration was called above, with an error handler. Then likewise, we set the CanAlwaysMatch callback on the CompilationUnitContent non-terminal.

The AdvanceToDefaultState method that we use needs to be designed to advance to the next Using, Namespace, etc. token. This is easy as the AdvanceTo method we provide on ITokenReader can accept any number of token ID values.

Finally we can use one of the two options listed in the Advanced Error Handling section above to report a helpful parse error to the end user.

Best Practices for Error Handling

This section discusses some best practices to use when implementing error handling in a grammar.

Looping

When looping on a child non-terminal, it is advisable to have an error handler on the inside of the ZeroOrMore/OneOrMore so that if an error occurs inside the loop, it can continue on when appropriate.

This sample shows a production that includes an error handler within the quantifier loop. The custom CompilationUnitError error handler has code in it that advances the token reader to the next token that can start a CompilationUnitContent non-terminal.

C#
VB
Copy
​compilationUnit.Production = compilationUnitContent.OnError(CompilationUnitError).ZeroOrMore();
​compilationUnit.Production = compilationUnitContent.OnError(AddressOf CompilationUnitError).ZeroOrMore()

Consuming Minimum Important Terms

Don't add error handling that always continues on until a minimum number of EBNF terms have been matched to justify an AST result.

In this case, we need a namespace name before it makes sense to build an AST result.

C#
VB
Copy
​namespaceDeclaration.Production = @keywordNamespace + qualifiedIdentifier["name"] + namespaceBody["body"].OnErrorContinue() + @semiColon.Optional();
​namespaceDeclaration.Production = keywordNamespace + qualifiedIdentifier("name") + namespaceBody("body").OnErrorContinue() + semiColon.Optional()

Don't Add Error Handlers to Everything

Don't put error handlers on all EBNF terms, thus forcing the parser to continue through all productions. Sometimes it's better to let a bad production fail due to a syntax error and bubble up to a container that has a generalized handler.

No Error Handling on Optional Terminals

Never add error handling on an optional terminal since there is no way it can error.

In this sample, the semiColon terminal doesn't have an error handler on it since it is optional.

C#
VB
Copy
​namespaceDeclaration.Production = @keywordNamespace + qualifiedIdentifier["name"] + namespaceBody["body"].OnErrorContinue() + @semiColon.Optional();
​namespaceDeclaration.Production = keywordNamespace + qualifiedIdentifier("name") + namespaceBody("body").OnErrorContinue() + semiColon.Optional()

No Error Handling on First Terminal in a Production

Don't put error handlers on a first single terminal in a production.

In this sample, the keywordNamespace terminal doesn't have an error handler on it since in order for this non-terminal to be called, a namespace keyword must have been present.

C#
VB
Copy
​namespaceDeclaration.Production = @keywordNamespace + qualifiedIdentifier["name"] + namespaceBody["body"].OnErrorContinue() + @semiColon.Optional();
​namespaceDeclaration.Production = keywordNamespace + qualifiedIdentifier("name") + namespaceBody("body").OnErrorContinue() + semiColon.Optional()

Add Error Handling to Insignificant Terminals at a Production End

Required terminals that end non-terminal productions like ), } or ; should always have an OnErrorContinue on them since they are insignificant to the meaning of what is in the document. A parse error will still be reported for them if they are not present in the code.

In this sample, the semiColon terminal has an error handler on it.

C#
VB
Copy
​usingNamespaceDirective.Production = @keywordUsing + namespaceName["name"] + @semiColon.OnErrorContinue();
​usingNamespaceDirective.Production = keywordUsing + namespaceName("name") + semiColon.OnErrorContinue()

Watch For .OnErrorContinue().OneOrMore() Infinite Loop Possibilities

Be careful of .OnErrorContinue().OneOrMore() scenarios. Since at least one match is required, if it doesn't perform any token consumption (due to a syntax error), then an infinite loop can occur due to the error handler. Any OneOrMore calls with inner error handlers need to have the error handlers ensure that at least one token is consumed to void the possibility of infinite loops.

Watch For Can-Match Callback Infinite Loop Possibilities

Similar to the previous tip, when setting a can-match that forces a non-terminal to match (such as is described in the Proper Design of Iterative Productions section above), callers of that non-terminal need to have a custom error handler that will force at least one token to be consumed, or else an infinite loop can occur if there is a syntax error.

Break Out Alternation Options to Separate Non-Terminals

For improved error reporting, break out alternations to their own non-terminal productions and give each new non-terminal an ErrorAlias as appropriate.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Walkthrough: Callbacks and Error Handling

In the Callbacks and Error Handling topic, we saw how the grammar framework supports callbacks nearly everywhere in the EBNF terms. You are able to inject custom code before and after any term is matched. One of the most important injection points is the Error callback since that allows you to tell the parser how to handle errors.

In this topic we’ll examine the importance of adding error handling. We’ll enhance our Simple language grammar to properly recover from nearly any invalid syntax in a document so that it can continue parsing the rest of the document.

This topic contains these sections:

  • Why Add Error Handling?
  • Enhancing the Simple Language Grammar with Error Handling
  • Final Grammar Productions for the Simple Language
  • Error Handling in Action
  • Conclusion

Why Add Error Handling?

An error occurs when one or more terminals is expected by the parser (per the grammar) but a different token is found at the current location in the document.

By default when this scenario occurs, the parser will report a parse error if a single terminal is expected. If there is more than one terminal that could be next, and if the containing non-terminal has an error alias set, it will report a parse error instead. This behavior is described in the Callbacks and Error Handling topic.

Following any possible error reporting, the parser will immediately exit the current non-terminal and will continue up the non-terminal stack, exiting each one as it goes until the root non-terminal is reached and exited itself.

Thus the result is that if any invalid syntax is found in a document, parsing stops at that point and no AST will be built. That’s definitely not good since we expect code being parsed from our SyntaxEditor control editing to be invalid most of the time. End users are continuously typing in it.

As shown in the Callbacks and Error Handling topic, the grammar framework has a lot ways to recover from errors, and they are easy to add.

Enhancing the Simple Language Grammar with Error Handling

Adding an Error Alias to Some Non-Terminals

The first step in adding error handling is to identify which non-terminals should get error aliases (described in the Callbacks and Error Handling topic). When a non-terminal has an error alias and an error occurs within it, it will report a parse error.

In the Simple language grammar, we’ll add an error alias to the Statement and PrimaryExpression non-terminals like this:

C#
VB
Copy
​var statement = new NonTerminal("Statement") { ErrorAlias = "Statement" };
var primaryExpression = new NonTerminal("PrimaryExpression") { ErrorAlias = "Expression" };
​Dim statement = New NonTerminal("Statement") With {.ErrorAlias = "Statement"}
Dim primaryExpression = New NonTerminal("PrimaryExpression") With {.ErrorAlias = "Expression"}

Now say we are parsing and an Expression is expected next but our look-ahead token is Var. The Terminal for Var doesn’t start any expressions, so this is an error. Thus an Expression expected error will be reported since we assigned an error alias to the PrimaryExpression non-terminal, which is indirectly required by the Expression non-terminal.

Adding Iterative Error Handling in the Root Production

As described in the Callbacks and Error Handling topic, when you have a scenario where some child non-terminal is being repeated, which often is the case in the root non-terminal, we want to force the child non-terminal being repeated to get parsed. We do this, even if the look-ahead token doesn’t match the child non-terminal’s "first set."

Otherwise if some token was first in the document that didn’t match with the "first set" of the child non-terminal, the parsing would exit immediately, which is not good.

We can force a non-terminal to ignore its "first set" and always be matched by setting its can-match callback to the built in CanAlwaysMatch method on Grammar:

C#
VB
Copy
​// NOTE: Next line added so that FunctionDeclaration will always be examined,
//   even if the next token is not 'function'... This ensures that a non-function
//   token at the start of the document will not prevent the rest of the document
//   from being parsed
functionDeclaration.CanMatchCallback = CanAlwaysMatch;
​' NOTE: Next line added so that FunctionDeclaration will always be examined,
'   even if the next token is not 'function'... This ensures that a non-function
'   token at the start of the document will not prevent the rest of the document
'   from being parsed
functionDeclaration.CanMatchCallback = AddressOf CanAlwaysMatch

The next step is to add an error callback to the FunctionDeclaration EBNF non-terminal:

C#
VB
Copy
​// Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
//   which is zero or more FunctionDeclarations...
// If an error occurs in a FunctionDeclaration we will call the AdvanceToDefaultState method,
//   that is defined below... it advances to the next 'Function' token and flags to continue parsing
this.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));
​' Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
'   which is zero or more FunctionDeclarations...
' If an error occurs in a FunctionDeclaration we will call the AdvanceToDefaultState method,
'   that is defined below... it advances to the next 'Function' token and flags to continue parsing
Me.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl") _
    > Ast("CompilationUnit", AstChildrenFrom("decl"))

The AdvanceToDefaultState method is called when an unhandled error occurs in FunctionDeclaration. It advances to the next Function token, which is what properly starts a FunctionDeclaration, thus skipping over any other tokens that would cause more parse errors. It then tells the parser to continue on.

C#
VB
Copy
​/// <summary>
/// Advances the token reader to the next 'function' token from where
/// parsing can resume.
/// </summary>
/// <param name="state">An <c>IParserState</c> that provides information
/// about the parser's current state.</param>
/// <returns>An <c>IParserErrorResult</c> value indicating a result.</returns>
private IParserErrorResult AdvanceToDefaultState(IParserState state) {
    state.TokenReader.AdvanceTo(SimpleTokenId.Function);
    return ParserErrorResults.Continue;
}
​''' <summary>
''' Advances the token reader to the next 'function' token from where
''' parsing can resume.
''' </summary>
''' <param name="state">An <c>IParserState</c> that provides information
''' about the parser's current state.</param>
''' <returns>An <c>IParserErrorResult</c> value indicating a result.</returns>
Private Function AdvanceToDefaultState(ByVal state As IParserState) As IParserErrorResult
    state.TokenReader.AdvanceTo(SimpleTokenId.Function)
    Return ParserErrorResults.Continue
End Function

Let’s walk through what happens now. Say there is an invalid look-ahead token while parsing in the middle of a FunctionDeclaration. An error will occur and possibly be reported. The error will bubble up to the root non-terminal, where the error callback will execute AdvanceToDefaultState. That moves to the next Function token and then tells the parser to continue on. Thus the ZeroOrMore quantifier in the root non-terminal will not be exited and the FunctionDeclaration non-terminal will be entered again.

This design is very important because it allows us recover from invalid syntax and to continue on parsing a document.

Adding Iterative Error Handling for Statements

In block statements, we'll want to force the next token to be parsed as a statement as long as we aren't at the document end or if the token isn't a '}' character. This ensures that any tokens that don't start a statement will be flagged as an error and skipped over. To accomplish this, we add a new BlockChildStatement non-terminal and set a can-match callback:

C#
VB
Copy
​var blockChildStatement = new NonTerminal("BlockChildStatement");
blockChildStatement.CanMatchCallback = CanMatchBlockChildStatement;

// Forces a child statement to try to match via the CanMatch callback, unless the next token is a '}'
blockChildStatement.Production = statement["stmt"] > AstFrom("stmt");
​Dim blockChildStatement = New NonTerminal("BlockChildStatement")
blockChildStatement.CanMatchCallback = AddressOf CanMatchBlockChildStatement

' Forces a child statement to try to match via the CanMatch callback, unless the next token Is a '}'
blockChildStatement.Production = statement("stmt") > AstFrom("stmt")

C#
VB
Copy
​/// <summary>
/// Returns whether the <c>BlockChildStatement</c> non-terminal can match.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information about the parser's current state.</param>
/// <returns>
/// <c>true</c> if the <see cref="NonTerminal"/> can match with the current state; otherwise, <c>false</c>.
/// </returns>
private bool CanMatchBlockChildStatement(IParserState state) {
    // Match as long as we aren't at the document end or at a curly brace
    return (!state.TokenReader.IsAtEnd) && (state.TokenReader.LookAheadToken.Id != SimpleTokenId.CloseCurlyBrace);
}
​''' <summary>
''' Returns whether the <c>BlockChildStatement</c> non-terminal can match.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information about the parser's current state.</param>
''' <returns>
''' <c>true</c> if the <see cref="NonTerminal"/> can match with the current state; otherwise, <c>false</c>.
''' </returns>
Private Function CanMatchBlockChildStatement(ByVal state As IParserState) As Boolean
    ' Match as long as we aren't at the document end or at a curly brace
    Return (Not state.TokenReader.IsAtEnd) AndAlso (state.TokenReader.LookAheadToken.Id <> SimpleTokenId.CloseCurlyBrace)
End Function

The Block production changes its Statement non-terminal reference to be the new BlockChildStatement non-terminal instead. Finally, we need to inject a custom error handler so that when a child statement fails to match, the token reader is advanced to the next token that can start a statement or is the block close ('}'). The Block production is updated to call a custom AdvanceToStatementOrBlockEnd callback if an error occurs while parsing a child statement.

C#
VB
Copy
​// Outputs a 'Block' node whose children are the contained statements
block.Production = @openCurlyBrace + blockChildStatement.OnError(AdvanceToStatementOrBlockEnd).ZeroOrMore().SetLabel("stmt") + @closeCurlyBrace.OnErrorContinue()
    > Ast("Block", AstChildrenFrom("stmt"));
​' Outputs a 'Block' node whose children are the contained statements
block.Production = openCurlyBrace + blockChildStatement.OnError(AddressOf AdvanceToStatementOrBlockEnd).ZeroOrMore().SetLabel("stmt") + closeCurlyBrace.OnErrorContinue() _
    > Ast("Block", AstChildrenFrom("stmt"))

AdvanceToStatementOrBlockEnd is set up to advance through tokens until the next one is reached that can either close the block or start a new statement. Note that part of this code requires the direct use of the Statement non-terminal, so the statement variable in the constructor has been changed to a class field instead.

C#
VB
Copy
​/// <summary>
/// Advances the token reader to the next statement or block end from where parsing can resume.
/// </summary>
/// <param name="state">An <c>IParserState</c> that provides information
/// about the parser's current state.</param>
/// <returns>An <c>IParserErrorResult</c> value indicating a result.</returns>
private IParserErrorResult AdvanceToStatementOrBlockEnd(IParserState state) {
    while (!state.TokenReader.IsAtEnd) {
        // Quit when a statement or block end is reached
        if (
            (state.TokenReader.LookAheadToken.Id == SimpleTokenId.CloseCurlyBrace) ||
            (statement.CanMatch(state))
            )
            return ParserErrorResults.Continue;

        // Advance a token
        state.TokenReader.Advance();
    }

    return ParserErrorResults.Continue;
}
​''' <summary>
''' Advances the token reader to the next statement or block end from where parsing can resume.
''' </summary>
''' <param name="state">An <c>IParserState</c> that provides information
''' about the parser's current state.</param>
''' <returns>An <c>IParserErrorResult</c> value indicating a result.</returns>
Private Function AdvanceToStatementOrBlockEnd(ByVal state As IParserState) As IParserErrorResult
    Do While Not state.TokenReader.IsAtEnd
        ' Quit when a statement or block end is reached
        If (state.TokenReader.LookAheadToken.Id = SimpleTokenId.CloseCurlyBrace) OrElse (statement.CanMatch(state)) Then
            Return ParserErrorResults.Continue
        End If

        ' Advance a token
        state.TokenReader.Advance()
    Loop

    Return ParserErrorResults.Continue
End Function

Adding More Inline Error Handling to Productions

The last step we’ll do to add error handling to the Simple language grammar is to insert OnErrorContinue handlers in various places throughout the productions.

It’s good to insert them on Terminal objects that are generally insignificant we don’t want things like a missing semi-colon to prevent an entire function declaration from being parsed. Here’s an example:

C#
VB
Copy
​// Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = @var + @identifier["name"] + @semiColon.OnErrorContinue()
    > Ast("VariableDeclarationStatement", AstFrom("name"));
​' Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = var + identifier("name") + semiColon.OnErrorContinue() _
    > Ast("VariableDeclarationStatement", AstFrom("name"))

It’s up to you to determine when you think a parser should just continue on (by specifying OnErrorContinue) and when it should bubble up to the calling non-terminal. The grammar framework gives you complete flexibility in how you wish to process things.

Final Grammar Productions for the Simple Language

Here is our finalized set of grammar productions for the Simple language. It completely parses Simple code, builds a concise AST, and properly recovers from syntax errors.

C#
VB
Copy
​// Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
//   which is zero or more FunctionDeclarations...
// If an error occurs in a FunctionDeclaration we will call the AdvanceToDefaultState method,
//   that is defined below... it advances to the next 'Function' token and flags to continue parsing
this.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));

// Outputs a 'FunctionDeclaration' node with children:
//   1) The function declaration name value
//   2) A 'Parameters' node that contains each parameter name; or nothing gets inserted
//      if there are no parameters
//   3) The Block statement result
functionDeclaration.Production = @function + @identifier["name"] + @openParenthesis.OnErrorContinue() + functionParameterList["params"].Optional() + @closeParenthesis.OnErrorContinue() + block["block"].OnErrorContinue()
    > Ast("FunctionDeclaration", AstFrom("name"), AstConditionalFrom("Parameters", "params"), AstFrom("block"));

// Outputs a 'FunctionParameterList' node whose children are parameter name values...
//   Is an excellent sample of how to build node for a delimited list
functionParameterList.Production = @identifier["param"] + (@comma + @identifier["param"].OnErrorContinue() > AstFrom("param")).ZeroOrMore().SetLabel("moreparams")
    > Ast("FunctionParameterList", AstFrom("param"), AstChildrenFrom("moreparams"));

// Outputs the result that came from the appropriate statement type that was matched...
//   We don't want to wrap the results with a 'Statement' node so we use AstFrom
statement.Production = block["stmt"] > AstFrom("stmt")
    | emptyStatement > null
    | variableDeclarationStatement["stmt"] > AstFrom("stmt")
    | assignmentStatement["stmt"] > AstFrom("stmt")
    | returnStatement["stmt"] > AstFrom("stmt");

// Outputs a 'Block' node whose children are the contained statements
block.Production = @openCurlyBrace + blockChildStatement.OnError(AdvanceToStatementOrBlockEnd).ZeroOrMore().SetLabel("stmt") + @closeCurlyBrace.OnErrorContinue()
    > Ast("Block", AstChildrenFrom("stmt"));

// Forces a child statement to try to match via the CanMatch callback, unless the next token is a '}'
blockChildStatement.Production = statement["stmt"] > AstFrom("stmt");

// Don't output anything since we don't care about empty statements
emptyStatement.Production = semiColon > null;

// Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = @var + @identifier["name"] + @semiColon.OnErrorContinue()
    > Ast("VariableDeclarationStatement", AstFrom("name"));

// Outputs a 'AssignmentStatement' node whose children are the variable name and the assigned expression
assignmentStatement.Production = @identifier["varname"] + @assignment + expression["exp"].OnErrorContinue() + @semiColon.OnErrorContinue()
    > Ast("AssignmentStatement", AstFrom("varname"), AstFrom("exp"));

// Outputs a 'ReturnStatement' node whose child is the expression to return
returnStatement.Production = @return + expression["exp"].OnErrorContinue() + @semiColon.OnErrorContinue()
    > Ast("ReturnStatement", AstFrom("exp"));

// Outputs the resulting node from the EqualityExpression
expression.Production = equalityExpression["exp"] > AstFrom("exp");

// Outputs the resulting node from the AdditiveExpression; or if an equality operator is found,
//   outputs a '==' or '!=' node whose children are the left and right child expressions of the operator
equalityExpression.Production = additiveExpression["leftexp"] + ((@equality | @inequality).SetLabel("op") + equalityExpression["rightexp"].OnErrorContinue()).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the resulting node from the MultiplicativeExpression; or if an additive operator is found,
//   outputs a '+' or '-' node whose children are the left and right child expressions of the operator
additiveExpression.Production = multiplicativeExpression["leftexp"] + ((@addition | @subtraction).SetLabel("op") + additiveExpression["rightexp"].OnErrorContinue()).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the resulting node from the PrimaryExpression; or if an multiplicative operator is found,
//   outputs a '*' or '/' node whose children are the left and right child expressions of the operator
multiplicativeExpression.Production = primaryExpression["leftexp"] + ((@multiplication | @division).SetLabel("op") + multiplicativeExpression["rightexp"].OnErrorContinue()).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the result that came from the appropriate expression type that was matched...
//   We don't want to wrap the results with a 'Expression' node so we use AstFrom
primaryExpression.Production = numberExpression["exp"] > AstFrom("exp")
    | functionAccessExpression["exp"] > AstFrom("exp")
    | simpleName["exp"] > AstFrom("exp")
    | parenthesizedExpression["exp"] > AstFrom("exp");

// Outputs the numeric value
numberExpression.Production = @number.ToTerm().ToProduction();

// Outputs the name value
simpleName.Production = @identifier.ToTerm().ToProduction();

// Outputs a 'FunctionAccessExpression' node with children:
//   1) The function name
//   2) An 'Arguments' node that contains each argument name; or nothing gets inserted
//      if there are no arguments
functionAccessExpression.Production = @identifier["name"] + @openParenthesis + functionArgumentList["args"].Optional() + @closeParenthesis.OnErrorContinue()
    > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"));

// Outputs a 'FunctionArgumentList' node whose children are argument expressions...
//   Is an excellent sample of how to build node for a delimited list
functionArgumentList.Production = expression["exp"] + (@comma + expression["exp"].OnErrorContinue() > AstFrom("exp")).ZeroOrMore().SetLabel("moreexps")
    > Ast("FunctionArgumentList", AstFrom("exp"), AstChildrenFrom("moreexps"));

// Outputs a 'ParenthesizedExpression' node whose child is the contained expression
parenthesizedExpression.Production = @openParenthesis + expression["exp"] + @closeParenthesis.OnErrorContinue()
    > Ast("ParenthesizedExpression", AstFrom("exp"));
​' Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
'   which is zero or more FunctionDeclarations...
' If an error occurs in a FunctionDeclaration we will call the AdvanceToDefaultState method,
'   that is defined below... it advances to the next 'Function' token and flags to continue parsing
Me.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl") > Ast("CompilationUnit", AstChildrenFrom("decl"))

' Outputs a 'FunctionDeclaration' node with children:
'   1) The function declaration name value
'   2) A 'Parameters' node that contains each parameter name; or nothing gets inserted
'      if there are no parameters
'   3) The Block statement result
functionDeclaration.Production = [function] + identifier("name") + openParenthesis.OnErrorContinue() + functionParameterList("params").Optional() + closeParenthesis.OnErrorContinue() + block("block").OnErrorContinue() > Ast("FunctionDeclaration", AstFrom("name"), AstConditionalFrom("Parameters", "params"), AstFrom("block"))

' Outputs a 'FunctionParameterList' node whose children are parameter name values...
'   Is an excellent sample of how to build node for a delimited list
functionParameterList.Production = identifier("param") + (comma + identifier("param").OnErrorContinue() > AstFrom("param")).ZeroOrMore().SetLabel("moreparams") > Ast("FunctionParameterList", AstFrom("param"), AstChildrenFrom("moreparams"))

' Outputs the result that came from the appropriate statement type that was matched...
'   We don't want to wrap the results with a 'Statement' node so we use AstFrom
statement.Production = block("stmt") > AstFrom("stmt") Or emptyStatement > Nothing Or variableDeclarationStatement("stmt") > AstFrom("stmt") Or assignmentStatement("stmt") > AstFrom("stmt") Or returnStatement("stmt") > AstFrom("stmt")

' Outputs a 'Block' node whose children are the contained statements
block.Production = openCurlyBrace + blockChildStatement.OnError(AddressOf AdvanceToStatementOrBlockEnd).ZeroOrMore().SetLabel("stmt") + closeCurlyBrace.OnErrorContinue() > Ast("Block", AstChildrenFrom("stmt"))

' Forces a child statement to try to match via the CanMatch callback, unless the next token Is a '}'
blockChildStatement.Production = statement("stmt") > AstFrom("stmt")

' Don't output anything since we don't care about empty statements
emptyStatement.Production = semiColon > Nothing

' Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = var + identifier("name") + semiColon.OnErrorContinue() > Ast("VariableDeclarationStatement", AstFrom("name"))

' Outputs a 'AssignmentStatement' node whose children are the variable name and the assigned expression
assignmentStatement.Production = identifier("varname") + assignment + expression("exp").OnErrorContinue() + semiColon.OnErrorContinue() > Ast("AssignmentStatement", AstFrom("varname"), AstFrom("exp"))

' Outputs a 'ReturnStatement' node whose child is the expression to return
returnStatement.Production = [return] + expression("exp").OnErrorContinue() + semiColon.OnErrorContinue() > Ast("ReturnStatement", AstFrom("exp"))

' Outputs the resulting node from the EqualityExpression
expression.Production = equalityExpression("exp") > AstFrom("exp")

' Outputs the resulting node from the AdditiveExpression; or if an equality operator is found,
'   outputs a '==' or '!=' node whose children are the left and right child expressions of the operator
equalityExpression.Production = additiveExpression("leftexp") + ((equality Or inequality).SetLabel("op") + equalityExpression("rightexp").OnErrorContinue()).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the resulting node from the MultiplicativeExpression; or if an additive operator is found,
'   outputs a '+' or '-' node whose children are the left and right child expressions of the operator
additiveExpression.Production = multiplicativeExpression("leftexp") + ((addition Or subtraction).SetLabel("op") + additiveExpression("rightexp").OnErrorContinue()).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the resulting node from the PrimaryExpression; or if an multiplicative operator is found,
'   outputs a '*' or '/' node whose children are the left and right child expressions of the operator
multiplicativeExpression.Production = primaryExpression("leftexp") + ((multiplication Or division).SetLabel("op") + multiplicativeExpression("rightexp").OnErrorContinue()).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the result that came from the appropriate expression type that was matched...
'   We don't want to wrap the results with a 'Expression' node so we use AstFrom
primaryExpression.Production = numberExpression("exp") > AstFrom("exp") Or functionAccessExpression("exp") > AstFrom("exp") Or simpleName("exp") > AstFrom("exp") Or parenthesizedExpression("exp") > AstFrom("exp")

' Outputs the numeric value
numberExpression.Production = number.ToTerm().ToProduction()

' Outputs the name value
simpleName.Production = identifier.ToTerm().ToProduction()

' Outputs a 'FunctionAccessExpression' node with children:
'   1) The function name
'   2) An 'Arguments' node that contains each argument name; or nothing gets inserted
'      if there are no arguments
functionAccessExpression.Production = identifier("name") + openParenthesis + functionArgumentList("args").Optional() + closeParenthesis.OnErrorContinue() > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"))

' Outputs a 'FunctionArgumentList' node whose children are argument expressions...
'   Is an excellent sample of how to build node for a delimited list
functionArgumentList.Production = expression("exp") + (comma + expression("exp").OnErrorContinue() > AstFrom("exp")).ZeroOrMore().SetLabel("moreexps") > Ast("FunctionArgumentList", AstFrom("exp"), AstChildrenFrom("moreexps"))

' Outputs a 'ParenthesizedExpression' node whose child is the contained expression
parenthesizedExpression.Production = openParenthesis + expression("exp") + closeParenthesis.OnErrorContinue() > Ast("ParenthesizedExpression", AstFrom("exp"))

Error Handling in Action

Now let’s see our error handling in action. We’ll use this input code:

Code Snippet
Copy
function Add(x, y {
    return x + y;
}

Note that there is a ) missing in the function declaration and a ')' expected error is reported. But we still get this complete AST, as if there were no syntax error:

Code Snippet
Copy
CompilationUnit[
    FunctionDeclaration[
        "Add"
        Parameters[
            "x"
            "y"
        ]
        Block[
            ReturnStatement[
                +[
                    SimpleName[
                        "x"
                    ]
                    SimpleName[
                        "y"
                    ]
                ]
            ]
        ]
    ]
]

Let’s create some more complex syntax errors now:

Code Snippet
Copy
invalid
function Add(x,) {
    return x +
}

Here we have three syntax errors:

  1. 'function' expected that highlights the invalid word
  2. Identifier expected that highlights the )
  3. 'Expression' expected that highlights the }

Even with three syntax errors, we still get an AST:

Code Snippet
Copy
CompilationUnit[
    FunctionDeclaration[
        "Add"
        Parameters[
            "x"
        ]
        Block[
            ReturnStatement[
                SimpleName[
                    "x"
                ]
            ]
        ]
    ]
]

Conclusion

In this topic, we've seen how to enhance a grammar to properly support robust error handling. Really, this is about the last thing you generally need to do when designing a grammar.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Custom Data

The IParserState object passed to each callback in the parser framework has a property on it where custom data can be tracked and updated throughout each parsing operation.

Anything can be placed in this custom data store. It could be used to help perform semantic validation, construct name tables, and more.

This topic contains these sections:

  • Usage Scenarios
  • Bad Ways to Track Custom Data
  • Initializing Custom Data
  • Updating the Custom Data While Parsing
  • Performing Semantic Validation with Custom Data
  • Returning and Consuming the Custom Data

Usage Scenarios

Although there are many things that can be tracked in custom data, here are a couple examples.

XML Element Hierarchy Validation

In the advanced XML syntax language in the Web Languages Add-on we maintain a stack of elements in this custom data. Any time we enter a new element, we push it on the stack. When we exit an element we pop it off. If the end tag name doesn't match the start tag name, we can intelligently report errors.

Name Tables

Many parser implementations may wish to construct a name table. The table could be stored in the custom data and then updated as a new type or variable name is encountered.

Bad Ways to Track Custom Data

One way you may be tempted to track custom data during a parse is to put a member variable on your grammar class. You would initialize it at some point and updated it in your callbacks.

The problem is that if more than one document is using the language, the grammar is potentially operating on multiple documents at the same time. This of course means that each parser working on the documents could be modifying the member variable while the other is working with the variable, thus leading to invalid data and possible exceptions.

The use of member variables is not recommended and for this reason, we recommend the use of techniques described below to store and update custom data instead.

Initializing Custom Data

The IParserState.CustomData property is the right place to store custom data for a parsing operation since it and its containing IParserState are specific to each parse request. The IParserState object for a parsing operation is created interally by the LL(*) Parser Framework and then is passed to each callback in your grammar. This begs the question, how can the custom data be initialized at the parsing operation start?

We recommend initializing the custom data in an initialize callback of the root production since that is the very first part of your grammar to be entered.

This example show how to add initialize and complete callbacks to the root production. Note that ellipses (...) indicate where the normal production terms and tree constructors would go.

C#
VB
Copy
​this.Root.Production = (...).OnInitialize(CompilationUnitInitialize).OnComplete(CompilationUnitComplete);
​Me.Root.Production = (...).OnInitialize(AddressOf CompilationUnitInitialize).OnComplete(AddressOf CompilationUnitComplete)

A CompilationUnitInitialize implementation could look like this, where MyParserContext is a class with various properties to help track custom data for this particular parsing operation:

C#
VB
Copy
​private void CompilationUnitInitialize(IParserState state) {
    // Initialize the state's custom data with a parser context
    state.CustomData = new MyParserContext();
}
​Private Sub CompilationUnitInitialize(ByVal state As IParserState)
    ' Initialize the state's custom data with a parser context
    state.CustomData = New MyParserContext()
End Sub

Updating the Custom Data While Parsing

Any callback has access to the IParserState.CustomData property, and therefore can access the object created during initialization.

Properties on the object can be updated as needed. If the custom data is tracking a name table, any variable declarations should add an entry into the name table.

A stack property can be added to the custom data object so that you can track scopes entered/exited as code is parsed. That way you can know what sort of scope you are in when each callback is called. A stack item would be pushed onto the stack by you from a callback whenever a scope is entered, and then popped when the scope is existed.

These are just a couple ideas. Really the custom data can be used to track anything while the parsing operation is active.

Performing Semantic Validation with Custom Data

We've seen how to initialize the custom data for a parsing operation. The corresponding complete callback for the root production is an ideal place to examine the custom data to see if any further syntax or semantic errors should be reported.

For instance, in XML you may wish to report if not all tags were closed properly, assuming the custom data had data in it to indicate this scenario.

A CompilationUnitComplete implementation could look like this:

C#
VB
Copy
​private void CompilationUnitComplete(IParserState state) {
    MyParserContext context = state.CustomData as MyParserContext;
    if (context != null) {
        // Report any semantic errors here with state.ReportError() based on data in the parser context
    }
}
​Private Sub CompilationUnitComplete(ByVal state As IParserState)
    Dim context As MyParserContext = TryCast(state.CustomData, MyParserContext)
    If context IsNot Nothing Then
        ' Report any semantic errors here with state.ReportError() based on data in the parser context
    End If
End Sub

Returning and Consuming the Custom Data

Since the LL(*) Parser Framework is being used, the IParser for the language should inherit LLParserBase. This base class has a virtual CreateParseData method that creates the IParseData returned by the parser.

By creating a language-specific IParseData object, you can get data from your CustomData object, store it in the IParseData, and it will be returned to the document. Thus it is available to consume by other language services such as IntelliPrompt since it is part of the parse data.

This code sample shows a possible implementation of a CreateParseData override that moves data from the MyParserContext object to the MyParseData object that is returned to the document:

C#
VB
Copy
​protected override IParseData CreateParseData(IParseRequest request, IParserState state) {
    if (request == null)
        throw new ArgumentNullException("request");
    if (state == null)
        throw new ArgumentNullException("state");

    MyParseData parseData = new MyParseData();

    // Initialize
    this.InitializeParseData(parseData, state);

    // Pass on parser context data
    MyParserContext context = state.CustomData as MyParserContext;
    if (context != null)
        parseData.SomeData = context.SomeData;

    return parseData;
}
​Protected Overrides Function CreateParseData(ByVal request As IParseRequest, ByVal state As IParserState) As IParseData
    If request Is Nothing Then
        Throw New ArgumentNullException("request")
    End If
    If state Is Nothing Then
        Throw New ArgumentNullException("state")
    End If

    Dim parseData As New MyParseData()

    ' Initialize
    Me.InitializeParseData(parseData, state)

    ' Pass on parser context data
    Dim context As MyParserContext = TryCast(state.CustomData, MyParserContext)
    If context IsNot Nothing Then
        parseData.SomeData = context.SomeData
    End If

    Return parseData
End Function

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

ANTLR, ANother Tool for Language Recognition, was created by Terence Parr and is one of the most widely-used parsing frameworks available. ANTLR is a framework for constructing recognizers, interpreters, compilers, and translators from grammatical descriptions containing actions in a variety of target languages. ANTLR provides excellent support for tree construction, tree walking, translation, error recovery, and error reporting.

While ANTLR can do advanced parsing and abstract syntax tree construction for the text in the editor (via calls to our multi-threaded parsing framework), it unfortunately doesn't support incremental lexing and therefore cannot be used to drive syntax highlighting in the editor.

The Actipro ANTLR Add-on provides a bridge between an ANTLR parser and the SyntaxEditor control. Namely, if you have created a parser with ANTLR, you can use it to perform syntax and semantic parsing within SyntaxEditor.

The best part is that all this can be done in 3 lines of code!

Other Options Other Options
While SyntaxEditor integrates with ANTLR parsers via this add-on, we also offer our own advanced LL(*) Parser Framework that features grammars that are written in C#/VB using EBNF-like notation, customizable AST construction, advanced error handling/reporting, easy code injection, a complete debugger UI, and much more.

This topic contains these sections:

  • Getting Started

Getting Started

The ANTLR Add-on makes it possible in just a few lines of code to create a syntax language that can automatically call an ANTLR parser whenever document text is modified and asynchronously return its AST result to the document. This topic walks through the basic concepts involved, the requirements, and includes a complete sample of how to pull everything together.

Not Installed by Default Not Installed by Default
This optional add-on is not installed by default. When running the WPF Controls installer, on the "Custom Setup" step, you must expand the "Optional SyntaxEditor Add-ons" node and set the "SyntaxEditor ANTLR Add-on" node to install.

See the Getting Started topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

The ANTLR Add-on makes it possible in just a few lines of code to create a syntax language that can automatically call an ANTLR parser whenever document text is modified and asynchronously return its AST result to the document. This topic walks through the basic concepts involved, the requirements, and includes a complete sample of how to pull everything together.

Not Installed by Default Not Installed by Default
This optional add-on is not installed by default. When running the WPF Controls installer, on the "Custom Setup" step, you must expand the "Optional SyntaxEditor Add-ons" node and set the "SyntaxEditor ANTLR Add-on" node to install.

This topic contains these sections:

  • Basic Concepts
  • Requirements
  • Sample: Creating an ISyntaxLanguage that Uses an ANTLR Parser
  • Adding Syntax Highlighting

Basic Concepts

The ANTLR Add-on exposes two main types that allow you to easily support automated calls to ANTLR for a SyntaxEditor control. This section talks about the types. See the sample section later in this topic for a walkthrough of creating an ISyntaxLanguage that uses the classes.

About Core ANTLR Lexers/Parsers

Both the Actipro text/parsing framework and ANTLR use the industry standard terms "lexer" and "parser", where a lexer tokenizes text and a parser performs syntax/semantic parsing on the text, generally producing an AST (abstract syntax tree) result.

Unfortunately since ANTLR doesn't support incremental lexing, we can't harness ANTLR to drive syntax highlighting features in SyntaxEditor. Alternative options are described in sections below. We can still use ANTLR to perform syntax/semantic parsing though.

ANTLR grammars, generally via the ANTLRWorks application, can be edited and used to generate what for our purposes will be called "core" ANTLR lexer and parser classes. Since these classes are external to the Actipro text/parsing framework, we need to "wrap" so that they can be called. That is exactly what this add-on helps you to do.

The ANTLR Parser

The AntlrParser class by Actipro implements an IParser that constructs a core ANTLR lexer and parser behind the scenes and uses it to perform parsing in any document using a language that has the parser registered as a service.

The AntlrParser constructor has four parameters that enable it to wrap the core ANTLR lexer/parser. The first parameter is string-based key that idenfities the parser, generally the same as the language's key. The second parameter is a Type indicating the core ANTLR lexer type. The third parameter is a Type indicating the core ANTLR parser type. The add-on uses reflection to look for constructors on those types so that it can instantiate them as needed. Again these two types are what is output from ANTLR. The final parameter is a string indicating the name of the root rule in your ANTLR grammar to execute on the parser. For instance, if the root rule was called program then you would pass that as the name, since ANTLR would have generated a method named program on its parser class.

Once the AntlrParser has been instantiated, it is registered with your ISyntaxLanguage. This allows the syntax language to use the AntlrParser to call ANTLR for parsing.

The ANTLR Parse Data

Since parsing is performed asynchronously on a worker thread to prevent the UI thread from blocking (assuming you have created an ambient parser request dispatcher per the steps in the Parse Requests and Dispatchers topic), the result of the parse is returned upon completion to the document's ICodeDocument.ParseData property.

The AntlrParser implementation returns an object of type IAntlrParseData to this property. IAntlrParseData defines a property that contains the root AST node returned by the core ANTLR parser, which is of the ANTLR type ITree.

Requirements

Application Development Language

Since ANTLR only has a C# target option and not a VB target output option, this add-on is only useful with applications being developed in C#. However if you are using VB and still wish to use the add-on, you could target the output of the core ANTLR lexer/parser to C#, put the classes in a standalone library .dll and reference that library from your VB application project.

To enable C# target output by ANTLR, set the language=CSharp3; option in your ANTLR grammar file.

Assemblies Required for the Add-on

The ANTLR Add-on references and thus requires one external assembly not written by Actipro, Antlr3.Runtime.dll, which interfaces with the ANTLR framework. This assembly is freely available on the ANTLR C# runtime download page.

The following list indicates the assemblies that are required by the add-on.

Assembly | Required | Author | Distributed With | Description
ActiproSoftware.Shared.Wpf.dll | Yes | Actipro | WPF Studio | Core framework for all Actipro WPF controls
ActiproSoftware.Text.Wpf.dll | Yes | Actipro | WPF Studio | Core text/parsing framework for SyntaxEditor
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | Actipro | WPF Studio | SyntaxEditor for WPF control
ActiproSoftware.Text.Addons.Antlr.Wpf.dll | Yes | Actipro | WPF Studio | Integrates ANTLR-based parsers with syntax languages
Antlr3.Runtime.dll | Yes | Terence Parr / Sam Harwell | ANTLR Web Site | Contains the framework used to work with ANTLR parsers from .NET applications

Sample: Creating an ISyntaxLanguage that Uses an ANTLR Parser

This sample will show how to create an ISyntaxLanguage that does not have syntax highlighting (see section below for more info on this) but can automatically call ANTLR asynchronously when text changes occur on documents using the language.

In the sample we will assume the language is for a simple calculator language called "Calc". We will assume that ANTLR generated a class named AntlrCalcLexer that is its core lexer and a class named AntlrCalcParser that is its core parser. Also we will assume that the root rule in the core ANTLR parser that should be called is named expr.

Creating an Ambient Parse Request Dispatcher

The first step when working with parsers is to ensure that the parsing operations can be executed in a separate worker thread so that they don't block the UI thread. The Actipro text/parsing framework has features to accommodate this.

Follow the instructions in the Parse Requests and Dispatchers topic to learn how to enable asynchronous parsing by setting a property in your application startup code.

Create the AntlrParser

Since this add-on relies on an AntlrParser to make the appropriate calls to the core ANTLR lexer/parser, we first need to create an instance of it.

This code creates the AntlrParser, passing it a string key that identifies the parser's language, the Type of core ANTLR lexer and parser, and the root rule name in the core ANTLR parser to execute:

C#
VB
Copy
​AntlrParser parser = new AntlrParser("Calc", typeof(AntlrCalcLexer), typeof(AntlrCalcParser), "expr");
​Dim parser As New AntlrParser("Calc", GetType(AntlrCalcLexer), GetType(AntlrCalcParser), "expr")

Create and Assemble the Syntax Language

Now we need to create the ISyntaxLanguage and assemble everything together. The AntlrParser created above will be registered with the language.

This code creates and assembles the syntax language:

C#
VB
Copy
​SyntaxLanguage language = new SyntaxLanguage("Calc");
language.RegisterParser(parser);
​Dim language As SyntaxLanguage = New SyntaxLanguage("Calc")
language.RegisterParser(parser)

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that get added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Attach to a SyntaxEditor's Document to Provide ANTLR Parsing

The final step is to use the ISyntaxLanguage that was created above with a SyntaxEditor.

This code applies the language that was created to a document being edited by a SyntaxEditor declared in the variable editor:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

That's all there is to it. In a few lines of code we have SyntaxEditor automatically calling an ANTLR parser whenever its document text changes. The parse data result in the form of an IAntlrParseData object is passed back asynchronously to the document's ICodeDocument.ParseData property when parsing is complete. This triggers the document's ParseDataChanged event.

Adding Syntax Highlighting

As mentioned above, the ANTLR lexer doesn't support incremental lexing, meaning that we can't have it pick up at a certain point and just give us a range of tokens. These features are necessary to get syntax highlighting working within a SyntaxEditor. The previous sample shows how to intergrate with ANTLR parsers to provide parse results for a document as it is changed. But how can we get syntax highlighting working for the language too?

There are two main options. Both involve creating a lexer for your language, either a programmatic lexer or a dynamic lexer. Once a lexer has been registered with the language, a token tagger provider must be registered as well so that the tokens read from the lexer can be converted into styles, and syntax highlighting can be achieved.

To sum up, you'd need to implement syntax highlighting the normal way using a custom lexer and token tagger. Then harness the ANTLR parsers you've generated to do the AST building.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Irony is a framework for constructing recognizers, interpreters, compilers, and translators from grammatical descriptions containing actions. Irony provides excellent support for tree construction, tree walking, translation, error recovery, and error reporting.

While Irony can do advanced parsing and abstract syntax tree construction for the text in the editor (via calls to our multi-threaded parsing framework), it unfortunately doesn't support incremental lexing and therefore cannot be used to drive syntax highlighting in the editor.

The Actipro Irony Add-on provides a bridge between an Irony parser and the SyntaxEditor control. Namely, if you have created a grammar with Irony, you can use it to perform syntax and semantic parsing within SyntaxEditor.

The best part is that all this can be done in only a few lines of code!

Other Options Other Options
While SyntaxEditor integrates with Irony via this add-on, we also offer our own advanced LL(*) Parser Framework that features grammars that are written in C#/VB using EBNF-like notation, customizable AST construction, advanced error handling/reporting, easy code injection, a complete debugger UI, and much more.

This topic contains these sections:

  • Getting Started

Getting Started

The Irony Add-on makes it possible in just a few lines of code to create a syntax language that can automatically call an Irony parser whenever document text is modified and asynchronously return its parse tree or AST result to the document. This topic walks through the basic concepts involved, the requirements, and includes a complete sample of how to pull everything together.

Not Installed by Default Not Installed by Default
This optional add-on is not installed by default. When running the WPF Controls installer, on the "Custom Setup" step, you must expand the "Optional SyntaxEditor Add-ons" node and set the "SyntaxEditor Irony Add-on" node to install.

See the Getting Started topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

The Irony Add-on makes it possible in just a few lines of code to create a syntax language that can automatically call an Irony parser whenever document text is modified and asynchronously return its parse tree or AST result to the document. This topic walks through the basic concepts involved, the requirements, and includes a complete sample of how to pull everything together.

Not Installed by Default Not Installed by Default
This optional add-on is not installed by default. When running the WPF Controls installer, on the "Custom Setup" step, you must expand the "Optional SyntaxEditor Add-ons" node and set the "SyntaxEditor Irony Add-on" node to install.

This topic contains these sections:

  • Basic Concepts
  • Assembly Requirements
  • Sample: Creating an ISyntaxLanguage that Uses an Irony Parser
  • Adding Syntax Highlighting
  • Error Reporting

Basic Concepts

The Irony Add-on exposes two main types that allow you to easily support automated calls to Irony for a SyntaxEditor control. This section talks about the types. See the sample section later in this topic for a walkthrough of creating an ISyntaxLanguage that uses the classes.

About Core Irony Lexers/Parsers

Both the Actipro text/parsing framework and Irony use the industry standard terms "lexer" and "parser", where a lexer tokenizes text and a parser performs syntax/semantic parsing on the text, generally producing a parse tree or an AST (abstract syntax tree) result.

Unfortunately since Irony doesn't support incremental lexing, we can't harness Irony to drive syntax highlighting features in SyntaxEditor. Alternative options are described in sections below. We can still use Irony to perform syntax/semantic parsing though.

Irony grammar classes and some framework code needs to be "wrapped" so that they can be used for parsing. That is exactly what this add-on helps you to do.

The Irony Parser

The IronyParser class by Actipro implements an IParser that constructs an Irony lexer and parser behind the scenes and uses it to perform parsing in any document using a language that has the parser registered as a service.

The IronyParser constructor has one parameter, an Irony Grammar.

Once the IronyParser has been instantiated, it is registered with your ISyntaxLanguage. This allows the syntax language to use the IronyParser to call Irony for parsing.

The Irony Parse Data

Since parsing is performed asynchronously on a worker thread to prevent the UI thread from blocking (assuming you have created an ambient parser request dispatcher per the steps in the Parse Requests and Dispatchers topic), the result of the parse is returned upon completion to the document's ICodeDocument.ParseData property.

The IronyParser implementation returns an object of type IIronyParseData to this property. IIronyParseData defines a property that contains the parse tree returned by the Irony parser, which is of the Irony type ParseTree.

Assembly Requirements

The Irony Add-on references and thus requires one external assembly not written by Actipro, Irony.dll. This assembly is freely available on the Irony download page.

The following list indicates the assemblies that are required by the add-on.

Assembly | Required | Author | Distributed With | Description
ActiproSoftware.Shared.Wpf.dll | Yes | Actipro | WPF Studio | Core framework for all Actipro WPF controls
ActiproSoftware.Text.Wpf.dll | Yes | Actipro | WPF Studio | Core text/parsing framework for SyntaxEditor
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | Actipro | WPF Studio | SyntaxEditor for WPF control
ActiproSoftware.Text.Addons.Irony.Wpf.dll | Yes | Actipro | WPF Studio | Integrates Irony-based parsers with syntax languages
Irony.dll | Yes | Roman Ivantsov | Irony Web Site | Contains the framework used to work with Irony parsers from .NET applications

Sample: Creating an ISyntaxLanguage that Uses an Irony Parser

This sample will show how to create an ISyntaxLanguage that does not have syntax highlighting (see section below for more info on this) but can automatically call Irony asynchronously when text changes occur on documents using the language.

In the sample we use an example language called "SimpleLanguage". The grammar class is named SimpleLanguageGrammar.

Creating an Ambient Parse Request Dispatcher

The first step when working with parsers is to ensure that the parsing operations can be executed in a separate worker thread so that they don't block the UI thread. The Actipro text/parsing framework has features to accommodate this.

Follow the instructions in the Parse Requests and Dispatchers topic to learn how to enable asynchronous parsing by setting a property in your application startup code.

Create the IronyParser

Since this add-on relies on an IronyParser to make the appropriate calls to the Irony lexer/parser, we first need to create an instance of it.

This code creates the IronyParser, passing it an Irony grammar object:

C#
VB
Copy
​IronyParser parser = new IronyParser(new SimpleLanguageGrammar());
​Dim parser As New IronyParser(New SimpleLanguageGrammar())

Create and Assemble the Syntax Language

Now we need to create the ISyntaxLanguage and assemble everything together. The IronyParser created above will be registered with the language.

This code creates and assembles the syntax language:

C#
VB
Copy
​SyntaxLanguage language = new SyntaxLanguage("SimpleLanguage");
language.RegisterParser(parser);
​Dim language As SyntaxLanguage = New SyntaxLanguage("SimpleLanguage")
language.RegisterParser(parser)

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that get added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Attach to a SyntaxEditor's Document to Provide Irony Parsing

The final step is to use the ISyntaxLanguage that was created above with a SyntaxEditor.

This code applies the language that was created to a document being edited by a SyntaxEditor declared in the variable editor:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

That's all there is to it. In a few lines of code we have SyntaxEditor automatically calling an Irony parser whenever its document text changes. The parse data result in the form of an IIronyParseData object is passed back asynchronously to the document's ICodeDocument.ParseData property when parsing is complete. This triggers the document's ParseDataChanged event.

Adding Syntax Highlighting

As mentioned above, the Irony lexer doesn't support incremental lexing, meaning that we can't have it pick up at a certain point and just give us a range of tokens. These features are necessary to get syntax highlighting working within a SyntaxEditor. The previous sample shows how to intergrate with Irony parsers to provide parse results for a document as it is changed. But how can we get syntax highlighting working for the language too?

There are two main options. Both involve creating a lexer for your language, either a programmatic lexer or a dynamic lexer. Once a lexer has been registered with the language, a token tagger provider must be registered as well so that the tokens read from the lexer can be converted into styles, and syntax highlighting can be achieved.

To sum up, you'd need to implement syntax highlighting the normal way using a custom lexer and token tagger. Then harness the Irony parser to do the parse tree and/or AST building.

Error Reporting

The Irony Add-on produces an IParseData, which can be retrieved from the editor document's ParseData property. This data can be used to populate an output window, or if you have a ParseErrorTagger registered with the language, the error(s) will be marked in the editor.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The .NET Languages Add-on is an optional premium extra for SyntaxEditor customers that includes advanced implementations of C# and Visual Basic syntax languages.

The add-on has been built from the ground up by Actipro to take advantage of best practices for syntax language design. While it is already packed with innovative features, the design is completely extensible and can be enhanced or modified as much as you like.

Note Note
Be sure to read through each language's "Getting Started" topics and follow each step in them exactly to ensure that the add-on's features will operate properly. While it only takes several lines of code to get up and running, those lines are very important and may prevent the add-on from working correctly if they are not present.

Although the add-on is distributed and demoed with the WPF controls, it is sold separately.

This topic contains these sections:

  • Assemblies
  • Reflection Data
  • Assembly Documentation
  • Resolver
  • C# Language
  • Visual Basic Language
  • Troubleshooting

Assemblies

Assemblies are objects implementing IAssembly that can track reflection data from binary .NET assemblies or source code files. This reflection data is then used by other add-on features such as the resolver and automated IntelliPrompt. It is critical to configure assemblies correctly to use the advanced features offered by this add-on.

See the Assemblies topic for more information.

Reflection Data

A large object model is included in the add-on for managing reflection data for both .NET assemblies as well as source code files. All of this data, which consists of everything from namespaces down to member parameters, is stored in a common set of interfaces so that it may easily be queried and used by features like the resolver, thus helping to populate automated IntelliPrompt.

See the Reflection Data topic for more information.

Assembly Documentation

Each IAssembly is able to provide documentation for the types and members that it contains. This documentation generally originates from XML documentation comments.

See the Assembly Documentation topic for more information.

Resolver

The resolver is an object that examines an expression and its containing contextual information. It uses language-specific rules to investigate what is returned by the expression, such as a namespace, type, member, variable, etc. This information is often passed to automated IntelliPrompt for display.

See the Resolver topic for more information.

C# Language

The advanced C# syntax language implementation in the SyntaxEditor .NET Languages Add-on includes everything from automated IntelliPrompt and code outlining to syntax error reporting.

See the C# Language topics for more information.

Visual Basic Language

The advanced Visual Basic syntax language implementation in the SyntaxEditor .NET Languages Add-on includes everything from automated IntelliPrompt and code outlining to syntax error reporting.

See the Visual Basic Language topics for more information.

Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

See the Troubleshooting topics for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Assemblies

Assemblies are objects implementing IAssembly that can track reflection data from binary .NET assemblies or source code files. This reflection data is then used by other add-on features such as the resolver and automated IntelliPrompt. It is critical to configure assemblies correctly to use the advanced features offered by this add-on.

An ambient assembly repository can be installed to manage reuse of binary assemblies in scenarios where multiple project assemblies are active, and can also cache assembly data to improve future load performance.

This topic contains these sections:

  • What is an Assembly?
  • Project Assemblies
  • Registering with a Syntax Language
  • Managing Assembly References
  • Assembly Reference Cleanup
  • Performance Impact of Adding References
  • Source Files
  • Binary Assemblies
  • Loading Binary Assemblies with Roslyn Extensions
  • Assembly Repositories
  • The FileBasedAssemblyRepository Class
  • Ambient Assembly Repository
  • Loading Pre-Defined Binary Assembly Cache Data

What is an Assembly?

There are two main types of assemblies: project assemblies and binary assemblies.

Project assemblies are similar in concept to a Visual Studio project in that they can track reflection data for source code files and can maintain a list of other IAssembly references related to the project. These references can be to other project assemblies (similar to Visual Studio when a solution hosts multiple projects that are dependent upon each other) or can be to binary assemblies.

Binary assemblies store reflection data for pre-compiled binary .dll files such as mscorlib.dll.

Since IAssembly and the rest of the types used for reflection in this add-on are all implemented as interfaces, it is possible to create other custom assembly types when there are special need scenarios.

All assemblies have a name, provide a flat list of namespaces defined within type, and provide access to a namespace hierarchy that is rooted at the global namespace. Each namespace can contain other nested namespaces or types, types can contain members, and so on. This design is described in more detail in the Reflection topic.

Project Assemblies

Project assemblies, classes that implement IProjectAssembly, can track source code files and references to other assemblies. They also can return an IResolver class that is used to resolve expressions to a namespace, type, member, etc.

Different project assembly types are available for each language, since there are some language-specific rules that need to be followed by the resolver. For instance, a C# resolver should ignore standard modules, while a VB resolver should handle standard modules and use case insensitive name matching.

The built-in project assembly types are:

  • CSharpProjectAssembly - for C# languages
  • VBProjectAssembly - for Visual Basic languages

This diagram shows the general structure of a project assembly:

In the diagram, there are three source files loaded: Foo1.cs, Foo2.cs, and Bar.cs. The first two files contain a partial class named Foo, so the two class declarations are merged together in the reflection data tracked by the project assembly. The last file contains a Bar class along with a nested type named Nested. The diagram also shows that there are references made to other assemblies such as mscorlib.dll, System.dll, etc. All of this data is tracked live and can be updated on-the-fly as code changes or references need to be added/removed.

When the resolver executes, it uses all of the above information along with language-specific rules to try and find the best match for a type, member, etc., even if that match is in a referenced assembly.

Registering with a Syntax Language

Any object that implements IProjectAssembly, such as the built-in CSharpProjectAssembly and VBProjectAssembly classes, can be associated with a syntax language by registering it as an IProjectAssembly service on the language.

Note Note
Due to language-specific rules that project assemblies use, only register CSharpProjectAssembly instances on a CSharpSyntaxLanguage, and VBProjectAssembly instances on a VBSyntaxLanguage.

Appropriate default IProjectAssembly instances are pre-registered on the built-in C#/VB syntax languages but need to be configured with source files and/or assembly references to be useful. Alternatively, you can create and configure a new project assembly instance and then register it on the language.

This code creates a new C# project assembly, uses a BackgroundWorker to adds some references asynchronously (see following sections for more information on why), and registers it with the CSharpSyntaxLanguage that is already declared in the language variable:

C#
VB
Copy
​CSharpProjectAssembly project = new CSharpProjectAssembly("Sample");
BackgroundWorker assemblyLoader = new BackgroundWorker();
assemblyLoader.DoWork += (sender, e) => {
    project.AssemblyReferences.AddMsCorLib();
    project.AssemblyReferences.Add("System");
};
assemblyLoader.RunWorkerAsync();
language.RegisterProjectAssembly(project);
​Dim project As New CSharpProjectAssembly("Sample")
Dim assemblyLoader As New BackgroundWorker()
AddHandler assemblyLoader.DoWork, Sub(sender, e)
    project.AssemblyReferences.AddMsCorLib()
    project.AssemblyReferences.Add("System")
End Sub
assemblyLoader.RunWorkerAsync()
language.RegisterProjectAssembly(project)

Note Note
The DotNetSyntaxLanguageExtensions.RegisterProjectAssembly method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.DotNet namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Managing Assembly References

For the resolver and automated IntelliPrompt features to work properly, the appropriate assembly references must be added to the project assembly. At a minimum, a reference to mscorlib.dll should always be added since that is where native types like Int32, String, etc. are defined. The resolver only knows about the assemblies that are referenced by the project, so if a reference is made to a type Foo but there is no source file or referenced assembly that defines Foo, the resolution of that reference will fail.

Always think about project assemblies in terms of being equivalient to Visual Studio projects. If an assembly reference would be needed to support a type or member in code, then a reference to the assembly should be made in the project assembly.

There are numerous methods and overloads for adding a reference to a project assembly. These methods are located on the IProjectAssembly.AssemblyReferences collection, which also allows enumeration and removal of references.

These methods can add references to a project assembly:

Member | Description
Add(IAssembly) Method | Adds a new reference for the specified IAssembly, which can be an already-loaded project or binary assembly.
Add(Assembly) Method | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.
Add(Assembly, IAssemblyName) Method | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.
Add(string) Method | Adds a new reference to an IBinaryAssembly for the specified assembly name. While using the simple assembly name may work in some simple cases (such as System), it is highly recommended to pass the fully-qualified assembly name to this method (such as System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089) since the probing code will have a better chance of successfully finding it.
AddFrom(string) Method | Adds a new reference to an IBinaryAssembly for the assembly at the specified path. The application must have access privileges to the path.
AddAllInAppDomain() Method | Adds new references to IBinaryAssembly objects for all assemblies currently loaded in the AppDomain. This method is only recommended for testing purposes since a properly-designed application should pick and choose which exact assembly references to have on a project assembly.
AddMsCorLib() Method | Adds a new reference to an IBinaryAssembly for mscorlib. This should always be added.

This code shows how to add assembly references to an IProjectAssembly in the project variable using a variety of methods:

C#
VB
Copy
​// Add mscorlib (should always add at a minimum)
project.AssemblyReferences.AddMsCorLib();

// Add 'System.dll' via a direct Assembly
project.AssemblyReferences.Add(typeof(System.Uri).Assembly);

// Add 'System.Core.dll' via its full name
project.AssemblyReferences.Add("System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089");

// Add another IProjectAssembly that was previously loaded elsewhere
project.AssemblyReferences.Add(anotherProject);
​' Add mscorlib (should always add at a minimum)
project.AssemblyReferences.AddMsCorLib()

' Add 'System.dll' via a direct Assembly
project.AssemblyReferences.Add(GetType(System.Uri).Assembly)

' Add 'System.Core.dll' via its full name
project.AssemblyReferences.Add("System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")

' Add another IProjectAssembly that was previously loaded elsewhere
project.AssemblyReferences.Add(anotherProject)

This code shows a couple other ways to add assembly references to an IProjectAssembly in the project variable:

C#
VB
Copy
​// Add a custom assembly from a file path (app must have access to the path)
project.AssemblyReferences.AddFrom(@"C:\MyAssembly.dll");

// Only for testing - add all assemblies in the current AppDomain
// project.AssemblyReferences.AddAllInAppDomain();
​' Add a custom assembly from a file path (app must have access to the path)
project.AssemblyReferences.AddFrom("C:\MyAssembly.dll")

' Only for testing - add all assemblies in the current AppDomain
' project.AssemblyReferences.AddAllInAppDomain()

Assembly Reference Cleanup

When an IProjectAssembly is no longer needed in your application, it is a good idea to its AssemblyReferences collection. When an assembly repository is used (described later in this topic), it will often track the reference count of an assembly. While that reference count remains above zero, it will track data for the assembly. When the reference count returns to zero, it will close up any open cache files or other resources that it may have open for the assembly.

Thus it is very important to clear the assembly references collection on a project assembly prior to the project assembly going out of scope, so that memory and resources for its referenced assemblies can be reclaimed when appropriate.

Performance Impact of Adding References

When a new IBinaryAssembly needs to be created using reflection on a System.Reflection.Assembly (regardless of if the Assembly is passed directly or via a full name or file path), there is processing that must take place to gather the data needed to construct the resulting IBinaryAssembly. This processing uses .NET reflection and thus can take some time to complete. For instance, if 20 new assembly references are being added to a project assembly, it might take several seconds to load.

This is the reason why in the sample code earlier in this topic, we used a System.ComponentModel.BackgroundWorker to execute the loading code. That allows the code to execute asynchronously, thus preventing the UI from slowing down or being blocked. .NET 4.0 and later includes other features such as tasks that can be used in a similar fashion instead.

Note that there are features built in to cache the IBinaryAssembly data constructed from an Assembly. These features are part of the "Assembly Repositories" object model described later in this topic, and can help speed up assembly loading by ten times or more when properly used.

Source Files

Source files, represented by the ISourceFile interface, have a string-based key and a collection of ITypeDefinition objects that are defined in the file.

Source file objects can be added to and removed from the IProjectAssembly.SourceFiles collection. This is similar in concept to the adding/removing of code files to a Visual Studio project. When a source file is included in a project, its types, members, etc. can be used by the resolver.

Automatic Source File Creation by Documents

As long as the following conditions are met, documents will automatically update a project assembly whenever the document is altered (such as when typing is performed in a SyntaxEditor):

  1. The document must have a ITextDocument.FileName property value set. The value of this property is used as the ISourceFile.Key. No source file can be created without it as a key.
  2. The document is using a .NET syntax language (CSharpSyntaxLanguage or VBSyntaxLanguage).
  3. The .NET syntax language in use must have an IProjectAssembly service registered. The ISourceFile created for the document will be added to this project assembly.

Behind the scenes, the .NET syntax languages watch any attached document for ICodeDocument.ParseData changes. When they detect a change, they translate the document's AST to ITypeDefinition instances, and an ISourceFile instance is created to contain the type definitions with the document's FileName as its key. The ISourceFile is added to the project assembly and replaces any prior source files with the same key.

Programmatically Adding Source Files

There are several ways to programmatically append source files to a project assembly, all available from the IProjectAssembly.SourceFiles collection. One way is to add an ISourceFile instance directly with the Add method. Here are the other ways:

Member Description
Add Method

Adds an ISourceFile for the specified AST CompilationUnit to the collection.

This method allows the source file key to be specified, and it translates the compilation unit's contents to a set of ITypeDefinition objects.

QueueCode Method

Queues parsing for the specified source code using an indicated language, and adds an ISourceFile for the result.

The parsing operation will occur in a worker thread and will not block the calling thread as long as an ambient parse request dispatcher is set up.

QueueFile Method

Queues parsing for the specified file using an indicated language, and adds an ISourceFile for the result.

The parsing operation will occur in a worker thread and will not block the calling thread as long as an ambient parse request dispatcher is set up.

This code shows how to queue up parsing to create source files for a project assembly defined in project:

C#
VB
Copy
​project.SourceFiles.QueueCode(cSharpSyntaxLanguage, "MyFile1.cs", "class Foo { public void Bar() {} }");
project.SourceFiles.QueueFile(cSharpSyntaxLanguage, @"C:\MyFile2.cs");
​project.SourceFiles.QueueCode(cSharpSyntaxLanguage, "MyFile1.cs", "class Foo { public void Bar() {} }")
project.SourceFiles.QueueFile(cSharpSyntaxLanguage, "C:\MyFile2.cs")

Again, make sure an ambient parse request dispatcher is set up so parsing occurs in a worker thread.

Programmatic Source File Creation

The SourceFile class implements ISourceFile and can be used to programmatically add a set of ITypeDefinition objects to a project assembly.

Binary Assemblies

Binary assemblies, represented by the IBinaryAssembly interface, store reflection data for pre-compiled binary .dll files such as mscorlib.dll. They can be created for any System.Reflection.Assembly instance, one in memory or one on disk.

Similar to project assemblies, binary assemblies also have their own references to other assemblies. However in binary assemblies, the references are more informational.

IBinaryAssembly instances can be created for an Assembly using any of the methods described in the 'Managing Assembly References' section earlier in this topic. Similar loading methods are available on IAssemblyRepository that can be used to load an IBinaryAssembly without adding it as a reference to a project. The assembly reference add methods internally call these various IAssemblyRepository load methods.

Limitations of .NET Reflection

While using .NET reflection to load binary assembly data is fast, there are some circumstances where problems can occur. .NET reflection requires that referenced assemblies are able to be resolved and loaded. There might be other cases where .NET reflection data for an assembly was already loaded into a binary assembly from a location, the file assembly was rebuilt, and the binary assembly data tried to reload but couldn't. .NET reflection locks the file and only allows it to be loaded once.

In scenarios like this, it might be useful to take advantage of the optional Roslyn extensions we provide that ship in the ActiproSoftware.Text.Addons.DotNet.Roslyn.Wpf assembly. Roslyn is a set of assemblies produced by Microsoft that can examine .NET assemblies for reflection data without many of the restrictions of using normal .NET reflection. For instance, references don't need to be loaded and assembly files aren't locked.

Loading Binary Assemblies with Roslyn Extensions

Our optional Roslyn extensions are fully capable of loading IBinaryAssembly data for a particular file system assembly file. This binary assembly can then be referenced by a project assembly as described in the 'Managing Assembly References' section earlier in this topic. The only requirements are that your app uses .NET 4.6.1 or later, references our ActiproSoftware.Text.Addons.DotNet.Roslyn.Wpf assembly, and has a NuGet package reference to 'Microsoft.CodeAnalysis'.

This code shows how to load a binary assembly with our Roslyn extensions and then add it as a reference to a project assembly:

C#
VB
Copy
​var loader = new ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.RoslynBinaryAssemblyLoader();
var binaryAssembly = loader.LoadFrom(pathToAssemblyFile);
project.AssemblyReferences.Add(binaryAssembly);
​Dim loader = New ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.RoslynBinaryAssemblyLoader()
Dim binaryAssembly = loader.LoadFrom(pathToAssemblyFile)
project.AssemblyReferences.Add(binaryAssembly)

Assembly Repositories

Assembly repositories provide a way to store loaded binary assemblies and possibly cache their data so that it can be retrieved much faster in the future. They are represented by the IAssemblyRepository interface and the FileBasedAssemblyRepository class provides the implementation used by most applications.

Assembly repositories have several Load methods for loading an IBinaryAssembly from a reflection Assembly. If the assembly repository implementation supports caching, the loaded assembly data is cached from these load method calls. The various methods for adding references to project assemblies mentioned in previous sections call these load methods.

Pruning the Cache

The assembly repository's cache may write to files or some other mechanism depending on the implementation. Regardless it is important to call the IAssemblyRepository.PruneCache method to prune invalid data from the cache upon application shutdown.

Note Note
Since assemblies can change over time (when a .dll is recompiled or deleted), it is important to make sure the cache removes data that is no longer valid via a call to IAssemblyRepository.PruneCache when the application is shut down.

Reference Tracking

The default implementation of IProjectAssembly will call the IAssemblyRepository.Add method when a binary assembly is added as a reference. The assembly repository keeps a pointer to the binary assembly and tracks a reference count for it. Likewise, the IAssemblyRepository.Remove method is called when a binary assembly is removed as a project assembly reference. If the reference count for the binary assembly reaches zero, the assembly repository will discard its pointer to the assembly.

The FileBasedAssemblyRepository Class

The FileBasedAssemblyRepository is the main IAssemblyRepository implementation provided with the add-on. It supports caching of assembly data out to files in a folder, as long as the application's security allows for write access to the folder specified in its cache path. This often requires full/elevated trust by the application. These cache files can be reloaded in the next application session, dramatically reducing binary assembly load times.

Use of this repository type as the ambient assembly repository is recommended since its caching mechanism can load its cached assembly data for an assembly about ten times faster than creating a new IBinaryAssembly via the use of .NET reflection.

If no cache path is set on the repository then it will not attempt to save or load any assembly data cache files. However it still will perform reference tracking, which significantly helps performance when multiple project assemblies are used.

This table illustrates the preferred catch path settings for FileBasedAssemblyRepository based on the type of application and its trust level.

Platform | Trust Level | Notes
WPF (application) | Full | Use a cache path that is accessible for read/write by the application, such as in a subfolder within the Environment.SpecialFolder.LocalApplicationData special folder.
WPF (XBAP) | Sandboxed | Sandboxed XBAPs don't support file I/O features that are needed for caching so just pass null as the cache path.
WPF (XBAP) | Full | Use a cache path that is accessible for read/write by the application, such as in a subfolder within the Environment.SpecialFolder.LocalApplicationData special folder.

Ambient Assembly Repository

There are often scenarios where multiple project assemblies are used at the same time. This is similar to scenarios in Visual Studio when a solution has multiple projects open. Each one of these projects probably references some of the same binary assemblies, like mscorlib.

By using an ambient assembly repository, the loaded binary assembly instances are reused among the various project assemblies, thus saving on memory. As mentioned in the previous section, assembly repositories also are capable of caching data, thus sometimes improving loading speeds by ten times or more.

Important Note Important Note
By default, no ambient IAssemblyRepository is installed meaning that more than one project assembly will use unncessary extra memory when referencing various binary assemblies, since those instances will not be shared among the project assemblies. Also, no caching will occur for binary assemblies if there is no ambient assembly repository, thus affecting application performance when adding references to project assemblies.

This code is executed at application startup and creates a FileBasedAssemblyRepository for use as the ambient assembly repository. Note that it uses an application-specific data folder path that you should update as appropriate for your application.

C#
VB
Copy
​string appDataPath = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData),
    @"YourCompanyName\YourApplicationName\Assembly Repository");
AmbientAssemblyRepositoryProvider.Repository = new FileBasedAssemblyRepository(appDataPath);
​Dim appDataPath As String = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), _
    "YourCompanyName\YourApplicationName\Assembly Repository")
AmbientAssemblyRepositoryProvider.Repository = New FileBasedAssemblyRepository(appDataPath)

At application shutdown, this code can be used to prune cache data that is no longer valid.

C#
VB
Copy
​var repository = AmbientAssemblyRepositoryProvider.Repository;
if (repository != null)
    repository.PruneCache();
​Dim repository = AmbientAssemblyRepositoryProvider.Repository
If repository IsNot Nothing Then
    repository.PruneCache()
End If

Loading Pre-Defined Binary Assembly Cache Data

Many of the add reference methods described above in the "Managing Assembly References" section will load the assemblies for the current platform version. Say that your application is a Silverlight application and you call the IProjectAssemblyReferenceCollection.AddMsCorLib method. In this case, the Silverlight MsCorLib assembly will be added.

But what if you are developing a Silverlight application that is for a .NET 2.0 WinForms development IDE? First, Silverlight's MsCorLib has slightly different API than .NET 2.0's MsCorLib does. Second, you can't load .NET 2.0 assemblies into Silverlight applications for reflection. Luckily the .NET Languages Add-on has a mechanism to support this scenario.

When using the FileBasedAssemblyRepository as the ambient assembly repository, as described in previous sections, you can set a cache path. After loading the appropriate assembly once, you can go to this cache folder and find the related cache file for the assembly.

The following code is a snippet you can paste in a new Visual Studio WPF application project (we'll assume it's called 'WpfApplication1'). In the application project, add references to the .NET Languages Add-on and SyntaxEditor assemblies. The WPF version of these Actipro assemblies can be found in the Language Designer tool's folder, since it uses them. Then paste this code in your application startup section:

C#
VB
Copy
​var appPath = Directory.GetCurrentDirectory();
var cachePath = Path.Combine(appPath, "Cache");
AmbientAssemblyRepositoryProvider.Repository = new FileBasedAssemblyRepository(cachePath);
var project = new CSharpProjectAssembly("Loader");

// Customize these based on which .NET assemblies you wish to load
project.AssemblyReferences.AddMsCorLib();
project.AssemblyReferences.AddFrom(Path.Combine(appPath, "WpfApplication1.exe"));
​Dim appPath = Directory.GetCurrentDirectory()
Dim cachePath = Path.Combine(appPath, "Cache")
AmbientAssemblyRepositoryProvider.Repository = New FileBasedAssemblyRepository(cachePath)
Dim project = New CSharpProjectAssembly("Loader")

' Customize these based on which .NET assemblies you wish to load
project.AssemblyReferences.AddMsCorLib()
project.AssemblyReferences.AddFrom(Path.Combine(appPath, "WpfApplication1.exe"))

After running the application, in the 'bin/Debug' folder there should now be a 'Cache' folder. That folder will contain files named something like 'mscorlib-v2.0-d7ffa534.Reflection.dat'. Each '...Reflection.dat' file is the reflection data file for an assembly.

If you copy a '...Reflection.dat' file to your application and make it accessible as a Stream (perhaps by making it an Embedded Resource), it can be loaded to create an IBinaryAssembly instance, even if it was created on a completely different platform (WPF vs. Silverlight, etc.).

This code creates a BinaryAssemblySerializer and loads an IBinaryAssembly from a Stream located in the resourceStreamName resource path.

C#
VB
Copy
​var serializer = new BinaryAssemblySerializer();
using (var stream = Assembly.GetExecutingAssembly().GetManifestResourceStream(resourceStreamName)) {
    var assembly = serializer.LoadFromStream(null, stream);
    if (assembly != null)
        project.AssemblyReferences.Add(assembly);
}
​Dim serializer = New BinaryAssemblySerializer()
Using stream = System.Reflection.Assembly.GetExecutingAssembly().GetManifestResourceStream(resourceStreamName)
    Dim [assembly] = serializer.LoadFromStream(Nothing, stream)
    If [assembly] IsNot Nothing Then
        project.AssemblyReferences.Add([assembly])
    End If
End Using

Note Note
Assembly cache files all contain version numbers. While these version numbers generally remain constant, they are incremented when there are additions/changes made to the serialized data so that it can be properly loaded. Trying to load a cache file with an older version into a newer BinaryAssemblySerializer will result in no IBinaryAssembly being created. The Language Designer's .NET Languages Add-on assemblies should always be in sync with this version in regards to codebases. So for Silverlight and WinRT XAML controls, it is best to use the Language Designer's WPF assemblies to generate the reflection data files.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Reflection Data

A large object model is included in the add-on for managing reflection data for both .NET assemblies as well as source code files. All of this data, which consists of everything from namespaces down to member parameters, is stored in a common set of interfaces so that it may easily be queried and used by features like the resolver, thus helping to populate automated IntelliPrompt.

This topic contains these sections:

  • Assemblies
  • Namespaces
  • Types
  • Members
  • Parameters
  • LINQ Queryable

Assemblies

Similar to real .NET assemblies, assemblies in this add-on, represented by the IAssembly interface, store information about contained types and members. Assemblies can be created for real pre-compiled .NET assemblies, or can be like Visual Studio projects where they are containers of source code files with references to other assemblies. Assemblies provide access to type/member information via namespaces.

Note Note
See the Assemblies topic for detailed information on the types of assemblies and how to load them.

Assembly Names

While each IAssembly has a Name property that returns its simple name, there also is a GetAssemblyName method that returns an IAssemblyName object. This object stores the simple name as well as some other information such as version. It supports comparison using the Equals method.

Namespaces Property

The IAssembly.Namespaces collection provides a flat list of the namespaces defined in the assembly. Each item in the collection is a INamespaceDefinition. The key of the collection used for the indexer is the full name of the namespace.

This code accesses the INamespaceDefinition for System.Linq within the IAssembly in the assembly variable:

C#
VB
Copy
​var namespaceDef = assembly.Namespaces["System.Linq", true];
​Dim namespaceDef = assembly.Namespaces("System.Linq", True)

GlobalNamespace Property

The IAssembly.GlobalNamespace property provides hierarchical access to the tree of namespaces defined in the assembly. The INamespaceDefinition returned by GlobalNamespace is always the global namespace whose name is an empty string.

This code accesses the global (root) INamespaceDefinition within the IAssembly in the assembly variable:

C#
VB
Copy
​var namespaceDef = assembly.GlobalNamespace;
​Dim namespaceDef = assembly.GlobalNamespace

Namespaces

Namespaces defined within an assembly are represented by the INamespaceDefinition interface. As described above, the main entry point to these objects is via IAssembly.Namespaces or IAssembly.GlobalNamespace.

Each namespace definition within an assembly has a unique full name (e.g. System.Collections.Generic) and contains all the types that are defined within it. The INamespaceDefinition.FullName property returns the namespace's full name, and its Name property returns the simple name (last identifier of the full name).

Nested Namespaces

Namespaces often contain other nested namespaces. For instance the global namespace whose name is an empty string often contains a nested namespace named System. These nested namespaces are available from the INamespaceDefinition.Children collection, which is indexed using the simple names of each nested namespace.

This code accesses the INamespaceDefinition for System within the IAssembly in the assembly variable:

C#
VB
Copy
​var namespaceDef = assembly.GlobalNamespace.Children["System", true];
​Dim namespaceDef = assembly.GlobalNamespace.Children("System", True)

Types

Namespaces contain zero or more ITypeDefinition object that specify the types defined within the namespace.

This code accesses the ITypeDefinition for System.Int32 within the IAssembly in the assembly variable:

C#
VB
Copy
​var typeDef = assembly.Namespaces["System", true].Types["Int32", true];
​Dim typeDef = assembly.Namespaces("System", True).Types("Int32", True)

Other Collections

Namespace definitions provide access to a couple other helper collections.

First is the INamespaceDefinition.ExtensionMethods property. This property is a collection of ITypeMemberDefinition objects where each member definition is for an extension method defined on a type which is contained by the namespace.

Second is the INamespaceDefinition.StandardModules property. This property is a collection of ITypeDefinition objects where each type definition is a standard module (only used by VB). The collection of standard modules is effectively a subset of the Types collection.

Types

There are three main categories of types used in the reflection data.

An ITypeReference is simply a pointer to another type. The referenced type may be defined in the same assembly or within another. A resolver can examine its qualified name and the general context in which it is located, and uses that information to try and convert the type reference to a type definition.

An ITypeDefinition is the definition of a type within an assembly. The ITypeDefinition interface inherits ITypeReference. Type definitions can potentially define nested types and members.

A type definition contains all sorts of information about a type, such as its access (public, private, etc.), its kind (class, structure, etc.), its namespace, and whether it is abstract, sealed, etc. It has a NestedTypes collection that lists all of the nested type definitions within the type. Its TypeParameters and TypeArguments collections indicate the generic parameters and any related generic arguments (if a generic type has been constructed). The Members collection contains the list of members within the type.

This code accesses the ITypeMemberDefinition overloads for ToString within the ITypeDefinition in the typeDef variable:

C#
VB
Copy
​var memberDefs = typeDef.Members["ToString", true];
​Dim memberDefs = typeDef.Members("ToString", True)

An ITypeParameter represents a generic parameter for a generic type definition or a generic method. The ITypeParameter interface inherits ITypeDefinition. Type parameters include several properties that describe their constraints and variance (covariant/contravariant) modifiers. The list of type constraints is indicated via the BaseTypes collection.

Members

Type members, represented by the ITypeMemberDefinition interface, can be a method, property, field, operator, etc. A type member stores information such as its access (public, private, etc.), kind (method, property, etc.), return type (if any), parameters (if any), type parameters (for generic methods), and other flag properties indicating whether it is abstract, static, etc.

This code accesses the first IParameterDefinition within the ITypeMemberDefinition in the memberDef variable:

C#
VB
Copy
​var firstParamDef = memberDef.Parameters[0];
​Dim firstParamDef = memberDef.Parameters(0)

Parameters

Parameter definitions, represented by the IParameterDefinition interface, store information about parameters in members, such as their name, type, whether they are optional, by-reference, are a parameter array, etc.

LINQ Queryable

Reflection data is fully LINQ queryable. For instance, this query looks in the IProjectAssembly for an ITypeDefinition named Foo:

C#
VB
Copy
​var fooType = (from ns in project.Namespaces
    let types = ns.Types["Foo", true]
    where types != null
    select types).FirstOrDefault();
​Dim fooType = ( _
    From ns In project.Namespaces _
    Let types = ns.Types("Foo", False) _
    Where types IsNot Nothing _
    Select types).FirstOrDefault()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Assembly Documentation

Each IAssembly is able to provide documentation for the types and members that it contains. This documentation generally originates from XML documentation comments.

This topic contains these sections:

  • Assembly Documentation
  • Project Assembly Documentation
  • Binary Assembly Documentation
  • Manually Loading Binary Assembly Documentation
  • Custom Assembly Documentation

Assembly Documentation

The IAssembly.Documentation property provides access to the assembly's documentation. It returns an object of type IAssemblyDocumentation that has GetDocumentation method overloads, capable of returning an IDocumentationProvider for a specific type or member.

The IDocumentationProvider makes it easy to get the documentation summary, type parameter info, or parameter info for the target type/member. This data is generally used in IntelliPrompt display.

Project Assembly Documentation

Project assemblies, or types implementing IProjectAssembly, automatically create a special IAssemblyDocumentation instance that provides the documentation for types/members defined in the project's source files. This class is wired up by default onto the IProjectAssembly.Documentation property.

Binary Assembly Documentation

Binary assemblies, or types implementing IBinaryAssembly, will automatically attempt to probe and look for .xml documentation files of the same name as the .dll in certain file system locations. This attempt will not succeed in cases such as in non-full trust XBAPs or Silverlight where security prohibits access to certain file paths. If the attempt does succeed and an appropriate .xml documentation file is located, it will be loaded up into a FileAssemblyDocumentation instance that gets assigned to the IBinaryAssembly.Documentation property. If that property is null, then no documentation was able to be automatically loaded for the assembly.

Probing Logic

When probing for .xml files, it will first examine the folder that contained the .dll file, if that is known. Within this folder, it will search for a localization child folder named by the current culture. If a file is not found there, it will look in the folder that contains the .dll. If a file is not found there, it will start searching through various known .NET 'Reference Assemblies' folder for the file.

Manually Loading Binary Assembly Documentation

For scenarios where the automatic probing for .xml documentation comment files was unsuccessful (generally because of security restrictions or the files simply not being in a known location), but you know where the .xml file is located, it is possible to manually create a FileAssemblyDocumentation instance and pass the file path in its constructor. Then set that instance to the IBinaryAssembly.Documentation property.

As long as security permits access to the path, the documentation will be loaded properly as needed.

Custom Assembly Documentation

Custom IAssemblyDocumentation implementations can also be built if you would prefer to access type/member documentation in another fashion (web service, etc.).

For instance, a class inheriting StreamAssemblyDocumentationBase could be made to access .xml documentation files stored as a manifest resource in the application's .exe. In this case, simply override the GetStream method to return a Stream to the .xml file, and the base class will do the rest.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Resolver

The resolver is an object that examines an expression and its containing contextual information. It uses language-specific rules to investigate what is returned by the expression, such as a namespace, type, member, variable, etc. This information is often passed to automated IntelliPrompt for display.

This topic contains these sections:

  • Obtaining a Resolver
  • Creating a Request
  • Performing a Resolve Operation
  • A Resolve Sample
  • Enumerating Members for an Offset

Obtaining a Resolver

The resolver for a language, represented by the IResolver interface, can be obtained from the IProjectAssembly.Resolver property. As described in the Assemblies topic, an IProjectAssembly is registered as a service on the .NET syntax languages in this add-on.

Creating a Request

The first step in using the resolver is to create an IResolverRequest. An implementation of this interface is in the ResolverRequest This class can accept an AST Expression or a qualified name as parameters into its constructor. The argument passed in will be what is resolved by the resolver.

The request's IResolverRequest.Context property can be set to an IDotNetContext object to provide contextual information about the request. This is very useful information for the resolver. Say that a simple name foo is trying to be resolved. If the context of the request occurs within a method, the resolver will first look for variables named foo within the method, then parameters, etc. Context objects can be retrieved via the information in the C# Context and Visual Basic Context topics.

Performing a Resolve Operation

The resolver has a Resolve method that accepts an IResolverRequest parameter and returns an IResolverResultSet.

The result set consists of zero or more IResolverResult objects. There can be more than one result in the set if there is ambiguity of the resolution result, such as when there are multiple overloads of a method that can match the expression to resolve. In this scenario, the results are sorted by which match best. So the first result is always the best match.

Each IResolverResult includes a string Name property and a Type property that returns the resulting ITypeDefinition of the result if one is available (not applicable for namespaces). For instance, if the result is for a type, this property returns the type. If the result is for a member, this property returns the member's return type.

The kinds of resolver results include:

  • INamespaceResolverResult - Specifies the full name of a namespace that was matched and includes the INamespaceDeclaration objects from the various loaded assemblies that match that full name.
  • ITypeResolverResult - Specifies the ITypeDefinition that was matched.
  • ITypeMemberResolverResult - Specifies the ITypeMemberDefinition that was matched.
  • IParameterResolverResult - Specifies the IParameterDefinition that was matched.
  • IVariableResolverResult - Specifies the IVariableDefinition that was matched.

A Resolve Sample

This code gets the current caret offset in a SyntaxEditor that is using a CSharpSyntaxLanguage, creates a context for it, builds a new resolver request, and calls the resolver to get a result set for what is under the caret:

C#
VB
Copy
​// Create a context
var snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
var context = new CSharpContextFactory().CreateContext(snapshotOffset);

if (context.ProjectAssembly != null) {
    // Create a request
    var request = new ResolverRequest(context.TargetExpression);
    request.Context = context;

    // Resolve
    var resolver = context.ProjectAssembly.Resolver;
    var resultSet = resolver.Resolve(request);
}
​' Create a context
Dim snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context = New CSharpContextFactory().CreateContext(snapshotOffset)

If context.ProjectAssembly IsNot Nothing Then
    ' Create a request
    Dim request = New ResolverRequest(context.TargetExpression)
    request.Context = context

    ' Resolve
    Dim resolver = context.ProjectAssembly.Resolver
    Dim resultSet = resolver.Resolve(request)
End If

This code does the same thing as above but uses a IDotNetContext.Resolve helper method to perform a bulk of the work:

C#
VB
Copy
​var snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
var context = new CSharpContextFactory().CreateContext(snapshotOffset);
var resultSet = context.Resolve();
​Dim snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context = New CSharpContextFactory().CreateContext(snapshotOffset)
Dim resultSet = context.Resolve()

Enumerating Members for an Offset

The resolver is normally used to tell what is at an offset but it also can enumerate accessible namespaces, types, etc. for a given offset. To do this, simply create the context whose kind is DotNetContextKind.SelfAndSiblings.

This code shows how to obtain a result set that includes all of the accessible namespaces, types, etc. for the current caret offset in a SyntaxEditor that is using a CSharpSyntaxLanguage:

C#
VB
Copy
​var snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
var context = new CSharpContextFactory().CreateContext(snapshotOffset, DotNetContextKind.SelfAndSiblings);
var resultSet = context.Resolve();
​Dim snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context = New CSharpContextFactory().CreateContext(snapshotOffset, DotNetContextKind.SelfAndSiblings)
Dim resultSet = context.Resolve()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The advanced C# syntax language implementation in the SyntaxEditor .NET Languages Add-on includes everything from automated IntelliPrompt and code outlining to syntax error reporting.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider
  • Text Formatter
  • Context
  • Automated IntelliPrompt
  • Documentation Comment Auto-Completer

Features

The C# language is packed with features, including:

  • Automated IntelliPrompt completion list, parameter info, and quick info.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Over 130 distinct AST node classes.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Stub documentation comment auto-generation.
  • Code snippet support.
  • Line commenting.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.
  • Code fragment editing with full IntelliPrompt, such as editing a method body.
  • Optionally change the parser to parse expressions, statements, etc. instead of compilation units.
  • Project assemblies that manage a project's code files and external references to other assemblies.
  • Assembly repository that stores and caches reflection information for binary .NET assemblies.
  • Support for navigable symbol selector (type/member drop-downs).

Licensing

Even though the .NET Languages Add-on is distributed and demoed with the WPF controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the C# language from the .NET Languages Add-on, implemented by the CSharpSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The C# language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

See the Text Formatter topic for more information.

Context

The C# language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

See the Context topic for more information.

Automated IntelliPrompt

The C# language has built-in automated IntelliPrompt completion list, parameter info, quick info, and code snippet features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Documentation Comment Auto-Completer

A documentation comment auto-completer is an object that can attempt to auto-generate stub documentation comments for a type or member when /// is typed by the end user, can auto-complete end tags, and can insert continuation delimiters when pressing Enter in a documentation comment.

See the Documentation Comment Auto-Completer topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

This topic covers how to get started using the C# language from the .NET Languages Add-on, implemented by the CSharpSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the Ambient Assembly Repository
  • Configure the CSharpSyntaxLanguage and CSharpProjectAssembly
  • Use the CSharpSyntaxLanguage
  • Documents Should Have an Appropriate FileName
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new ThreadedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New ThreadedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the Ambient Assembly Repository

An ambient assembly repository should always be set up to ensure that the application reuses binary assembly reflection data whenever appropriate and that binary assembly references added to a project assembly are cached for future loading performance gains.

The ambient assembly repository should be set up in your application startup code as described in the Assemblies topic. The FileBasedAssemblyRepository class is the default implementation of an assembly repository, which supports the writing of binary assembly data to a cache folder specified in its constructor, as long as the application has read/write permissions to that folder (usually requires full trust). If the application is a sandboxed XBAP, it can pass null as the cache path instead.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    // Use a path like this if in full trust; otherwise, pass null
    string appDataPath = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData),
        @"YourCompanyName\YourApplicationName\Assembly Repository");
    AmbientAssemblyRepositoryProvider.Repository = new FileBasedAssemblyRepository(appDataPath);
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    ' Use a path like this if in full trust; otherwise, pass Nothing
    Dim appDataPath As String = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), _
        "YourCompanyName\YourApplicationName\Assembly Repository")
    AmbientAssemblyRepositoryProvider.Repository = New FileBasedAssemblyRepository(appDataPath)
    ...
End Sub

Likewise on application exit, the assembly repository's cache should be pruned, also as described in the Assemblies topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var repository = AmbientAssemblyRepositoryProvider.Repository;
    if (repository != null)
        repository.PruneCache();
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim repository = AmbientAssemblyRepositoryProvider.Repository
    If repository IsNot Nothing Then
        repository.PruneCache()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient assembly repository provider may result in unnecessary increased memory usages and slowdown when loading assembly references.

Configure the CSharpSyntaxLanguage and CSharpProjectAssembly

The next step is to create an instance of the CSharpSyntaxLanguage class and configure its project assembly.

This code creates a CSharpSyntaxLanguage, gets its default project assembly, and uses a background worker (for asynchronous execution) to add some assembly references, and queue up a source file to be included:

C#
VB
Copy
​var language = new CSharpSyntaxLanguage();
var project = language.GetService<IProjectAssembly>();
var assemblyLoader = new BackgroundWorker();
assemblyLoader.DoWork += (sender, e) => {
    project.AssemblyReferences.AddMsCorLib();  // MsCorLib should always be added at a minimum
    project.AssemblyReferences.Add("System");
    project.AssemblyReferences.AddFrom(@"C:\MyAssembly.dll");
    project.SourceFiles.QueueFile(language, @"C:\MyFile.cs");
};
assemblyLoader.RunWorkerAsync();
​Dim language As New CSharpSyntaxLanguage()
Dim project As IProjectAssembly = language.GetService(Of IProjectAssembly)()
Dim assemblyLoader As New BackgroundWorker()
AddHandler assemblyLoader.DoWork, Sub(sender, e)
    project.AssemblyReferences.AddMsCorLib()  ' MsCorLib should always be added at a minimum
    project.AssemblyReferences.Add("System")
    project.AssemblyReferences.AddFrom("C:\MyAssembly.dll")
    project.SourceFiles.QueueFile(language, "C:\MyFile.cs")
End Sub
assemblyLoader.RunWorkerAsync()

Note Note
The Assemblies topic contains detailed information on the multiple ways (some not shown above) to add assembly references and source files to a project assembly.

Note that the IProjectAssembly.AssemblyReferences collection should be cleared when the project assembly will no longer be used. This cleans up any memory or resources in use by the assembly repository for loaded assemblies.

C#
VB
Copy
​project.AssemblyReferences.Clear();
​project.AssemblyReferences.Clear()

Use the CSharpSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing C# code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your CSharpSyntaxLanguage instance among all the documents in your application that are editing C# code. This saves on overall memory usage and reduces load times.

Documents Should Have an Appropriate FileName

It is a good practice to set the FileName on any document using the language to an appropriate value that uniquely identifies the document's contents. The filename is used as a key to register the types defined in the document with the language's IProjectAssembly.

If the filename is left empty, the add-on will fall back to using the document's unique ID (a GUID value) to identify its contents in the project assembly.

This code sets the filename for a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.FileName = @"C:\Code.cs";
​editor.Document.FileName = "C:\Code.cs"

Assembly Requirements

The following list indicates the assemblies that are used with the C# syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Wpf.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for SyntaxEditor
ActiproSoftware.Text.LLParser.Wpf.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Wpf.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro WPF controls
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for WPF control
ActiproSoftware.Text.Addons.DotNet.Wpf.dll | Yes | Actipro | .NET Languages Add-on | Core text/parsing for the C# language
ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll | Yes | Actipro | .NET Languages Add-on | SyntaxEditor for WPF advanced C# syntax language implementation

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

The C# language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String
  • Grammar Options

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

The CSharpParser class also has a special helper static method named ParseExpression that takes a string containing a C# expression and returns the IDotNetParseData parse results.

Grammar Options

The C# grammar (CSharpGrammar class) constructor can be passed an ICSharpGrammarOptions object that indicates options for the grammar's creation. The CSharpGrammarOptions class implements this interface.

Root Non-Terminal

The default options indicate that compilation unit should be the root non-terminal for the grammar. However this can be altered via the ICSharpGrammarOptions.RootNonTerminal property. The DotNetGrammarRootNonTerminal enumeration has a number of options for a root non-terminal, everything from expressions to statements.

Use this code to alter the root non-terminal for the grammar so that it tries to parse a single expression instead of a compilation unit:

C#
VB
Copy
​CSharpSyntaxLanguage language = new CSharpSyntaxLanguage();

CSharpGrammarOptions grammarOptions = new CSharpGrammarOptions();
grammarOptions.RootNonTerminal = DotNetGrammarRootNonTerminal.Expression;

CSharpGrammar grammar = new CSharpGrammar(grammarOptions);
language.RegisterParser(new CSharpParser(grammar));
​Dim language As New CSharpSyntaxLanguage()

Dim grammarOptions As New CSharpGrammarOptions()
grammarOptions.RootNonTerminal = DotNetGrammarRootNonTerminal.Expression

Dim grammar As New CSharpGrammar(grammarOptions)
language.RegisterParser(New CSharpParser(grammar))

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The CSharpIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope. For instance, pressing ENTER after a { will cause the next line to be indented by one tab stop. Pressing ENTER while still typing a statement will also attempt to indent the next line by one tab stop.

Typed Characters

When certain characters such as {, }, or : are typed, the line will be examined to see if it should be indented/outdented.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The CSharpSyntaxLanguage class automatically registers a CSharpIndentProvider with itself when it is created, so normally indent providers never need to be set on a C# language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomCSharpIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomCSharpIndentProvider());
​language.RegisterIndentProvider(New CustomCSharpIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on CSharpSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The CSharpTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality
  • Opening Curly Braces on New Line

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The CSharpSyntaxLanguage class automatically registers a CSharpTextFormatter with itself when it is created, so normally text formatters never need to be set on a Visual Basic language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomCSharpTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomCSharpTextFormatter());
​language.RegisterTextFormatter(New CustomCSharpTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on CSharpSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Opening Curly Braces on New Line

The CSharpTextFormatter.IsOpeningBraceOnNewLine property can be used to determine whether opening curly braces appear on a new line.

It defaults to false, but can be changed to true to cause opening curly braces to move to the next line.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context

The C# language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

This topic contains these sections:

  • Obtaining Context Information
  • .NET Context

Obtaining Context Information

Context information can be retrieved via the use of the CSharpContextFactory class. Its CreateContext method accepts a TextSnapshotOffset and returns the IDotNetContext for that offset.

This code retrieves an IDotNetContext for the caret's offset (the end selection offset in the active view):

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
IDotNetContext context = new CSharpContextFactory().CreateContext(snapshotOffset);
​Dim snapshotOffset As TextSnapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context As IDotNetContext = New CSharpContextFactory().CreateContext(snapshotOffset)

A context kind (via the DotNetContextKind enumeration) can also be passed to a CreateContext method overload. The default value is Self but you can also pass SelfAndSiblings to indicate that alternate logic should be used when building the context. When SelfAndSiblings is passed, the context factory will return a context object that focuses on the "parent" of the offset. This allows resolver operations that use the context to enumerate a list of accessible members.

.NET Context

IDotNetContext objects provide .NET language-related context information for a specific snapshot offset, such as the containing AST node, target expression, and more.

These IDotNetContext members are important:

Member | Description
ContainingAstNode Property | Gets the IAstNode that contains the TextSnapshotOffset.
ContainingAstTypeDeclaration Property | Gets the AST TypeDeclaration that contains the TextSnapshotOffset, if any.
InitializationSnapshotRange Property | Gets the TextSnapshotRange with which the context was initialized.
ProjectAssembly Property | Gets the IProjectAssembly with which this context is associated.
SnapshotOffset Property | Gets the TextSnapshotOffset for which this context was created.
TargetExpression Property | Gets the target AST Expression for the context, if known.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

The C# language has built-in automated IntelliPrompt completion list, parameter info, quick info, code snippet, and navigable symbol selector features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Completion List
  • Parameter Info
  • Quick Info
  • Code Snippets
  • Navigable Symbol Selector
  • Disabling Automated IntelliPrompt

Completion List

IntelliPrompt completion lists are used to present end users with a list of accessible members from the code editor's current caret location. In many cases, the completion list is triggered by key events such as pressing Ctrl+Space or typing a . character after an identifier.

There are two types of completion list scenarios when typing in code blocks. First is when listing members of something. This can occur when typing a . character after an identifier. The second type is when showing all accessible members based on the current context. This can occur when starting to type a new sequence of identifiers.

When typing a < character in documentation comments, a list of appropriate documentation comment tags is displayed.

In cases where a completion list is triggered via Ctrl+Space, if there is a single match for the text that has been typed, it will not show the list but will auto-complete the match. This saves the user from having to type the entire identifier/keyword that was matched.

The completion list features are implemented by the CSharpCompletionProvider class.

Disabling Auto-Show On Typed Word Start

The CSharpCompletionProvider class has a CanShowOnTypedWordStart property that defaults to true. When true, the completion provider will attempt to automatically show a completion list as the user starts to type a new word, but only in certain contexts. Set the property to false to disable this behavior.

Parameter Info

IntelliPrompt parameter info is the ability to display helpful tooltips when typing an invocation that presents all of the signature overloads, along with information on the current parameter being typed.

Parameter info is displayed for method, indexer, and constructor invocations.

IntelliPrompt quick info features are implemented by the CSharpParameterInfoProvider language service.

Quick Info

IntelliPrompt quick info is the ability to display helpful tooltips when hovering over various identifiers and some language keywords in the code editor. When hovering over an identifier, the resolver attempts to determine what the identifier means, and the resulting information is presented in a quick info tip.

Detailed information is shown for namespaces, types, members, parameters, and variables. Appropriate documentation comments are displayed when available.

IntelliPrompt quick info features are implemented by the CSharpQuickInfoProvider language service.

Code Snippets

IntelliPrompt code snippets provide the ability to insert pre-defined text fragments and for the end user to edit fields declared within the text. When a code snippet provider with code snippets is registered as a service on the language, the automated completion list will list code snippets at appropriate times. Typing a code snippet's shortcut, which is also inserted by selecting a code snippet from the completion list, and pressing Tab will activate a code snippet template session.

The ICodeSnippetProvider service that is registered needs to have a root ICodeSnippetFolder set on it, with at least code snippet within it or its child folders. A folder can be created programmatically. Or it can be loaded recursively via the CodeSnippetFolder.LoadFrom method.

This code creates a CSharpSyntaxLanguage and registers a CSharpCodeSnippetProvider service on it, which is a code snippet provider that is optimized for this language. The provider has a root ICodeSnippetFolder assigned that contains all the snippets recursively found within the file system path specified by the path variable. Note that CSharp is passed as a language name parameter when loading the folder. This ensures that only code snippets designed for the C# language will be loaded.

C#
VB
Copy
​var language = new CSharpSyntaxLanguage();

ICodeSnippetFolder snippetFolder = CodeSnippetFolder.LoadFrom(path, "CSharp");
language.RegisterService(new CSharpCodeSnippetProvider() { RootFolder = snippetFolder });
​Dim language = New CSharpSyntaxLanguage()

Dim snippetFolder As ICodeSnippetFolder = CodeSnippetFolder.LoadFrom(path, "CSharp")
language.RegisterService(New CSharpCodeSnippetProvider() With {.RootFolder = snippetFolder})

Navigable Symbol Selector

The Navigable Symbol Selector is a control that generally sits above and is bound to a SyntaxEditor. It shows the types and members that currently enclose or are nearest the caret, and allows the end user to select other types/members within the same document via a dropdown, and to navigate to those members upon selection.

This control populates its symbol lists by the CSharpNavigableSymbolProvider language service.

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the CSharpSyntaxLanguage that is created:

C#
VB
Copy
​var language = new CSharpSyntaxLanguage();

// Disable completion lists
language.UnregisterService<CSharpCompletionProvider>();

// Disable parameter info
language.UnregisterService<CSharpParameterInfoProvider>();

// Disable quick info
language.UnregisterService<CSharpQuickInfoProvider>();

// Disable navigable symbol provider
language.UnregisterService<INavigableSymbolProvider>();
​Dim language = New CSharpSyntaxLanguage()

' Disable completion lists
language.UnregisterService(Of CSharpCompletionProvider)()

' Disable parameter info
language.UnregisterService(Of CSharpParameterInfoProvider)()

' Disable quick info
language.UnregisterService(Of CSharpQuickInfoProvider)()

' Disable navigable symbol provider
language.UnregisterService(Of INavigableSymbolProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Documentation Comment Auto-Completer

A documentation comment auto-completer is an object that can attempt to auto-generate stub documentation comments for a type or member when /// is typed by the end user, can auto-complete end tags, and can insert continuation delimiters when pressing Enter in a documentation comment.

The IDocumentationCommentAutoCompleter interface provides the base requirements for this functionality. It is installed into a language as a "feature" language service.

The CSharpDocumentationCommentAutoCompleter class is the default implementation of the IDocumentationCommentAutoCompleter interface.

This topic contains these sections:

  • Capabilities
  • Registering with a Syntax Language
  • Disabling the Functionality

Capabilities

Auto-generation of stub documentation comments is made when /// is typed by the end user as long as the CSharpDocumentationCommentAutoCompleter.IsStubGenerationEnabled property is set to true. Depending on which type or member follows, the generated comments will contain summary, typeparam, param, and returns tags as appropriate.

When a > character is typed by the end user to end a documentation comment start tag, the appropriate end tag will be inserted as long as the CSharpDocumentationCommentAutoCompleter.IsEndTagCompletionEnabled property is set to true.

When the end user presses Enter while in a documentation comment, /// is added to the next line as long as the CSharpDocumentationCommentAutoCompleter.IsNewLineGenerationEnabled property is set to true.

Registering with a Syntax Language

Any object that implements IDocumentationCommentAutoCompleter can be associated with a syntax language by registering it as an IDocumentationCommentAutoCompleter service on the language.

The CSharpSyntaxLanguage class automatically registers a CSharpDocumentationCommentAutoCompleter with itself when it is created, so normally documentation comment auto-completers never need to be set on an C# language unless a custom one is made.

This code creates a custom documentation comment auto-completer (defined in a make-believe CustomDocumentationCommentAutoCompleter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterDocumentationCommentAutoCompleter(new CustomDocumentationCommentAutoCompleter());
​language.RegisterDocumentationCommentAutoCompleter(New CustomDocumentationCommentAutoCompleter())

Note Note
The DotNetSyntaxLanguageExtensions.RegisterDocumentationCommentAutoCompleter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.DotNet namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on CSharpSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The advanced Visual Basic syntax language implementation in the SyntaxEditor .NET Languages Add-on includes everything from automated IntelliPrompt and code outlining to syntax error reporting.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider
  • Text Formatter
  • Context
  • Automated IntelliPrompt
  • Documentation Comment Auto-Completer

Features

The Visual Basic language is packed with features, including:

  • Automated IntelliPrompt completion list, parameter info, and quick info.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Over 130 distinct AST node classes.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Stub documentation comment auto-generation.
  • Code snippet support.
  • Line commenting.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.
  • Code fragment editing with full IntelliPrompt, such as editing a method body.
  • Optionally change the parser to parse expressions, statements, etc. instead of compilation units.
  • Project assemblies that manage a project's code files and external references to other assemblies.
  • Assembly repository that stores and caches reflection information for binary .NET assemblies.
  • Support for navigable symbol selector (type/member drop-downs).

Licensing

Even though the .NET Languages Add-on is distributed and demoed with the WPF controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the Visual Basic language from the .NET Languages Add-on, implemented by the VBSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The Visual Basic language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

See the Text Formatter topic for more information.

Context

The Visual Basic language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

See the Context topic for more information.

Automated IntelliPrompt

The Visual Basic language has built-in automated IntelliPrompt completion list, parameter info, quick info, and code snippet features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Documentation Comment Auto-Completer

A documentation comment auto-completer is an object that can attempt to auto-generate stub documentation comments for a type or member when ''' is typed by the end user, can auto-complete end tags, and can insert continuation delimiters when pressing Enter in a documentation comment.

See the Documentation Comment Auto-Completer topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

This topic covers how to get started using the Visual Basic language from the .NET Languages Add-on, implemented by the VBSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the Ambient Assembly Repository
  • Configure the VBSyntaxLanguage and VBProjectAssembly
  • Use the VBSyntaxLanguage
  • Documents Should Have an Appropriate FileName
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new ThreadedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New ThreadedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the Ambient Assembly Repository

An ambient assembly repository should always be set up to ensure that the application reuses binary assembly reflection data whenever appropriate and that binary assembly references added to a project assembly are cached for future loading performance gains.

The ambient assembly repository should be set up in your application startup code as described in the Assemblies topic. The FileBasedAssemblyRepository class is the default implementation of an assembly repository, which supports the writing of binary assembly data to a cache folder specified in its constructor, as long as the application has read/write permissions to that folder (usually requires full trust). If the application is a sandboxed XBAP, it can pass null as the cache path instead.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    // Use a path like this if in full trust; otherwise, pass null
    string appDataPath = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData),
        @"YourCompanyName\YourApplicationName\Assembly Repository");
    AmbientAssemblyRepositoryProvider.Repository = new FileBasedAssemblyRepository(appDataPath);
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    ' Use a path like this if in full trust; otherwise, pass Nothing
    Dim appDataPath As String = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), _
        "YourCompanyName\YourApplicationName\Assembly Repository")
    AmbientAssemblyRepositoryProvider.Repository = New FileBasedAssemblyRepository(appDataPath)
    ...
End Sub

Likewise on application exit, the assembly repository's cache should be pruned, also as described in the Assemblies topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var repository = AmbientAssemblyRepositoryProvider.Repository;
    if (repository != null)
        repository.PruneCache();
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim repository = AmbientAssemblyRepositoryProvider.Repository
    If repository IsNot Nothing Then
        repository.PruneCache()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient assembly repository provider may result in unnecessary increased memory usages and slowdown when loading assembly references.

Configure the VBSyntaxLanguage and VBProjectAssembly

The next step is to create an instance of the VBSyntaxLanguage class and configure its project assembly.

This code creates a VBSyntaxLanguage, gets its default project assembly, and uses a background worker (for asynchronous execution) to add some assembly references, and queue up a source file to be included:

C#
VB
Copy
​var language = new VBSyntaxLanguage();
var project = language.GetService<IProjectAssembly>();
var assemblyLoader = new BackgroundWorker();
assemblyLoader.DoWork += (sender, e) => {
    project.AssemblyReferences.AddMsCorLib();  // MsCorLib should always be added at a minimum
    project.AssemblyReferences.Add("System");
    project.AssemblyReferences.AddFrom(@"C:\MyAssembly.dll");
    project.SourceFiles.QueueFile(language, @"C:\MyFile.vb");
};
assemblyLoader.RunWorkerAsync();
​Dim language As New VBSyntaxLanguage()
Dim project As IProjectAssembly = language.GetService(Of IProjectAssembly)()
Dim assemblyLoader As New BackgroundWorker()
AddHandler assemblyLoader.DoWork, Sub(sender, e)
    project.AssemblyReferences.AddMsCorLib()  ' MsCorLib should always be added at a minimum
    project.AssemblyReferences.Add("System")
    project.AssemblyReferences.AddFrom("C:\MyAssembly.dll")
    project.SourceFiles.QueueFile(language, "C:\MyFile.vb")
End Sub
assemblyLoader.RunWorkerAsync()

Note Note
The Assemblies topic contains detailed information on the multiple ways (some not shown above) to add assembly references and source files to a project assembly.

Note that the IProjectAssembly.AssemblyReferences collection should be cleared when the project assembly will no longer be used. This cleans up any memory or resources in use by the assembly repository for loaded assemblies.

C#
VB
Copy
​project.AssemblyReferences.Clear();
​project.AssemblyReferences.Clear()

Use the VBSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing Visual Basic code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your VBSyntaxLanguage instance among all the documents in your application that are editing Visual Basic code. This saves on overall memory usage and reduces load times.

Documents Should Have an Appropriate FileName

It is a good practice to set the FileName on any document using the language to an appropriate value that uniquely identifies the document's contents. The filename is used as a key to register the types defined in the document with the language's IProjectAssembly.

If the filename is left empty, the add-on will fall back to using the document's unique ID (a GUID value) to identify its contents in the project assembly.

This code sets the filename for a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.FileName = @"C:\Code.cs";
​editor.Document.FileName = "C:\Code.cs"

Assembly Requirements

The following list indicates the assemblies that are used with the Visual Basic syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Wpf.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for SyntaxEditor
ActiproSoftware.Text.LLParser.Wpf.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Wpf.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro WPF controls
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for WPF control
ActiproSoftware.Text.Addons.DotNet.Wpf.dll | Yes | Actipro | .NET Languages Add-on | Core text/parsing for the Visual Basic language
ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll | Yes | Actipro | .NET Languages Add-on | SyntaxEditor for WPF advanced Visual Basic syntax language implementation

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

The Visual Basic language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String
  • Grammar Options

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

The VBParser class also has a special helper static method named ParseExpression that takes a string containing a Visual Basic expression and returns the IDotNetParseData parse results.

Grammar Options

The Visual Basic grammar (VBGrammar class) constructor can be passed an IVBGrammarOptions object that indicates options for the grammar's creation. The VBGrammarOptions class implements this interface.

Root Non-Terminal

The default options indicate that compilation unit should be the root non-terminal for the grammar. However this can be altered via the IVBGrammarOptions.RootNonTerminal property. The DotNetGrammarRootNonTerminal enumeration has a number of options for a root non-terminal, everything from expressions to statements.

Use this code to alter the root non-terminal for the grammar so that it tries to parse a single expression instead of a compilation unit:

C#
VB
Copy
​VBSyntaxLanguage language = new VBSyntaxLanguage();

VBGrammarOptions grammarOptions = new VBGrammarOptions();
grammarOptions.RootNonTerminal = DotNetGrammarRootNonTerminal.Expression;

VBGrammar grammar = new VBGrammar(grammarOptions);
language.RegisterParser(new VBParser(grammar));
​Dim language As New VBSyntaxLanguage()

Dim grammarOptions As New VBGrammarOptions()
grammarOptions.RootNonTerminal = DotNetGrammarRootNonTerminal.Expression

Dim grammar As New VBGrammar(grammarOptions)
language.RegisterParser(New VBParser(grammar))

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The VBIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope. For instance, pressing ENTER after a Sub signature will cause the next line to be indented by one tab stop.

Typed Characters

When a space is typed after certain keywords such as End, Next, etc., the line will be examined to see if it should be outdented.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The VBSyntaxLanguage class automatically registers a VBIndentProvider with itself when it is created, so normally indent providers never need to be set on a Visual Basic language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomVBIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomVBIndentProvider());
​language.RegisterIndentProvider(New CustomVBIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on VBSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The VBTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The VBSyntaxLanguage class automatically registers a VBTextFormatter with itself when it is created, so normally text formatters never need to be set on a VB language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomVBTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomVBTextFormatter());
​language.RegisterTextFormatter(New CustomVBTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on VBSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context

The Visual Basic language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

This topic contains these sections:

  • Obtaining Context Information
  • .NET Context

Obtaining Context Information

Context information can be retrieved via the use of the VBContextFactory class. Its CreateContext method accepts a TextSnapshotOffset and returns the IDotNetContext for that offset.

This code retrieves an IDotNetContext for the caret's offset (the end selection offset in the active view):

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
IDotNetContext context = new VBContextFactory().CreateContext(snapshotOffset);
​Dim snapshotOffset As TextSnapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context As IDotNetContext = New VBContextFactory().CreateContext(snapshotOffset)

A context kind (via the DotNetContextKind enumeration) can also be passed to a CreateContext method overload. The default value is Self but you can also pass SelfAndSiblings to indicate that alternate logic should be used when building the context. When SelfAndSiblings is passed, the context factory will return a context object that focuses on the "parent" of the offset. This allows resolver operations that use the context to enumerate a list of accessible members.

.NET Context

IDotNetContext objects provide .NET language-related context information for a specific snapshot offset, such as the containing AST node, target expression, and more.

These IDotNetContext members are important:

Member | Description
ContainingAstNode Property | Gets the IAstNode that contains the TextSnapshotOffset.
ContainingAstTypeDeclaration Property | Gets the AST TypeDeclaration that contains the TextSnapshotOffset, if any.
InitializationSnapshotRange Property | Gets the TextSnapshotRange with which the context was initialized.
ProjectAssembly Property | Gets the IProjectAssembly with which this context is associated.
SnapshotOffset Property | Gets the TextSnapshotOffset for which this context was created.
TargetExpression Property | Gets the target AST Expression for the context, if known.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

The Visual Basic language has built-in automated IntelliPrompt completion list, parameter info, quick info, code snippet, and navigable symbol selector features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Completion List
  • Parameter Info
  • Quick Info
  • Code Snippets
  • Navigable Symbol Selector
  • Disabling Automated IntelliPrompt

Completion List

IntelliPrompt completion lists are used to present end users with a list of accessible members from the code editor's current caret location. In many cases, the completion list is triggered by key events such as pressing Ctrl+Space or typing a . character after an identifier.

There are two types of completion list scenarios when typing in code blocks. First is when listing members of something. This can occur when typing a . character after an identifier. The second type is when showing all accessible members based on the current context. This can occur when starting to type a new sequence of identifiers.

When typing a < character in documentation comments, a list of appropriate documentation comment tags is displayed.

In cases where a completion list is triggered via Ctrl+Space, if there is a single match for the text that has been typed, it will not show the list but will auto-complete the match. This saves the user from having to type the entire identifier/keyword that was matched.

The completion list features are implemented by the VBCompletionProvider class.

Disabling Auto-Show On Typed Word Start

The VBCompletionProvider class has a CanShowOnTypedWordStart property that defaults to true. When true, the completion provider will attempt to automatically show a completion list as the user starts to type a new word, but only in certain contexts. Set the property to false to disable this behavior.

Parameter Info

IntelliPrompt parameter info is the ability to display helpful tooltips when typing an invocation that presents all of the signature overloads, along with information on the current parameter being typed.

Parameter info is displayed for method, indexer, and constructor invocations.

IntelliPrompt quick info features are implemented by the VBParameterInfoProvider language service.

Quick Info

IntelliPrompt quick info is the ability to display helpful tooltips when hovering over various identifiers and some language keywords in the code editor. When hovering over an identifier, the resolver attempts to determine what the identifier means, and the resulting information is presented in a quick info tip.

Detailed information is shown for namespaces, types, members, parameters, and variables. Appropriate documentation comments are displayed when available.

IntelliPrompt quick info features are implemented by the VBQuickInfoProvider language service.

Code Snippets

IntelliPrompt code snippets provide the ability to insert pre-defined text fragments and for the end user to edit fields declared within the text. When a code snippet provider with code snippets is registered as a service on the language, the automated completion list will list code snippets at appropriate times. Typing a code snippet's shortcut, which is also inserted by selecting a code snippet from the completion list, and pressing Tab will activate a code snippet template session.

The ICodeSnippetProvider service that is registered needs to have a root ICodeSnippetFolder set on it, with at least code snippet within it or its child folders. A folder can be created programmatically. Or it can be loaded recursively via the CodeSnippetFolder.LoadFrom method.

This code creates a VBSyntaxLanguage and registers a VBCodeSnippetProvider service on it, which is a code snippet provider that is optimized for this language. The provider has a root ICodeSnippetFolder assigned that contains all the snippets recursively found within the file system path specified by the path variable. Note that VB is passed as a language name parameter when loading the folder. This ensures that only code snippets designed for the Visual Basic language will be loaded.

C#
VB
Copy
​var language = new VBSyntaxLanguage();

ICodeSnippetFolder snippetFolder = CodeSnippetFolder.LoadFrom(path, "VB");
language.RegisterService(new VBCodeSnippetProvider() { RootFolder = snippetFolder });
​Dim language = New VBSyntaxLanguage()

Dim snippetFolder As ICodeSnippetFolder = CodeSnippetFolder.LoadFrom(path, "VB")
language.RegisterService(New VBCodeSnippetProvider() With {.RootFolder = snippetFolder})

Navigable Symbol Selector

The Navigable Symbol Selector is a control that generally sits above and is bound to a SyntaxEditor. It shows the types and members that currently enclose or are nearest the caret, and allows the end user to select other types/members within the same document via a dropdown, and to navigate to those members upon selection.

This control populates its symbol lists by the VBNavigableSymbolProvider language service.

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the VBSyntaxLanguage that is created:

C#
VB
Copy
​var language = new VBSyntaxLanguage();

// Disable completion lists
language.UnregisterService<VBCompletionProvider>();

// Disable parameter info
language.UnregisterService<VBParameterInfoProvider>();

// Disable quick info
language.UnregisterService<VBQuickInfoProvider>();

// Disable navigable symbol provider
language.UnregisterService<INavigableSymbolProvider>();
​Dim language = New VBSyntaxLanguage()

' Disable completion lists
language.UnregisterService(Of VBCompletionProvider)()

' Disable parameter info
language.UnregisterService(Of VBParameterInfoProvider)()

' Disable quick info
language.UnregisterService(Of VBQuickInfoProvider)()

' Disable navigable symbol provider
language.UnregisterService(Of INavigableSymbolProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Documentation Comment Auto-Completer

A documentation comment auto-completer is an object that can attempt to auto-generate stub documentation comments for a type or member when ''' is typed by the end user, can auto-complete end tags, and can insert continuation delimiters when pressing Enter in a documentation comment.

The IDocumentationCommentAutoCompleter interface provides the base requirements for this functionality. It is installed into a language as a "feature" language service.

The VBDocumentationCommentAutoCompleter class is the default implementation of the IDocumentationCommentAutoCompleter interface.

This topic contains these sections:

  • Capabilities
  • Registering with a Syntax Language
  • Disabling the Functionality

Capabilities

Auto-generation of stub documentation comments is made when ''' is typed by the end user as long as the VBDocumentationCommentAutoCompleter.IsStubGenerationEnabled property is set to true. Depending on which type or member follows, the generated comments will contain summary, typeparam, param, and returns tags as appropriate.

When a > character is typed by the end user to end a documentation comment start tag, the appropriate end tag will be inserted as long as the VBDocumentationCommentAutoCompleter.IsEndTagCompletionEnabled property is set to true.

When the end user presses Enter while in a documentation comment, ''' is added to the next line as long as the VBDocumentationCommentAutoCompleter.IsNewLineGenerationEnabled property is set to true.

Registering with a Syntax Language

Any object that implements IDocumentationCommentAutoCompleter can be associated with a syntax language by registering it as an IDocumentationCommentAutoCompleter service on the language.

The VBSyntaxLanguage class automatically registers a VBDocumentationCommentAutoCompleter with itself when it is created, so normally documentation comment auto-completers never need to be set on an Visual Basic language unless a custom one is made.

This code creates a custom documentation comment auto-completer (defined in a make-believe CustomDocumentationCommentAutoCompleter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterDocumentationCommentAutoCompleter(new CustomDocumentationCommentAutoCompleter());
​language.RegisterDocumentationCommentAutoCompleter(New CustomDocumentationCommentAutoCompleter())

Note Note
The DotNetSyntaxLanguageExtensions.RegisterDocumentationCommentAutoCompleter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.DotNet namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on VBSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

This topic contains these sections:

  • How Do I Get Started With C# / Visual Basic Languages?
  • Typing Is Slow
  • Loading of Binary Assembly References Blocks the UI Thread
  • No IntelliPrompt For System Types

How Do I Get Started With C# / Visual Basic Languages?

The C# Getting Started topic walks through all the requirements for using the C# language. Be sure to follow all the steps in that topic so that the syntax language operates correctly.

The Visual Basic Getting Started topic walks through all the requirements for using the Visual Basic language. Be sure to follow all the steps in that topic so that the syntax language operates correctly.

Typing Is Slow

If you notice a lag when typing, it is likely due to an ambient parse request dispatcher not being set up. Each time text changes occur, such as while typing, a parse request is fired off for the parser to parse the document. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up an ambient parse request dispatcher for your application.

When no ambient parse request dispatcher has been configured for your application, the parsing will occur in the main UI thread, thus severely affecting typing performance, especially in larger documents.

See the C# Getting Started or Visual Basic Getting Started topics for more information on how to set up an ambient parse request dispatcher for your application.

Loading of Binary Assembly References Blocks the UI Thread

When .NET assemblies are added to a project assembly as references, we use reflection to iterate over all the namespaces, types, members, etc. in the assembly to build up our own reflection data model for the assembly. Using .NET reflection does take time so referencing assemblies will block the UI if it is done in the main UI thread.

A project assembly's references should be loaded using a BackgroundWorker or another similar asynchronous mechanism. That way, it will not block the UI while loading.

The add-on also supports caching of binary assembly data, so that the second and later times that the same assembly is loaded (even in future application sessions), it will load ten or more times faster than its initial load. This feature is implemented via an ambient assembly repository, which helps reduce overall memory and improves performance.

See the C# Getting Started or Visual Basic Getting Started topics for more information on how to load project assembly references in a worker thread and configure an ambient assembly repository for caching.

No IntelliPrompt For System Types

If automated IntelliPrompt features like quick info are not working for system types or for the language's native keywords, make sure that the project assembly in use has the proper assembly references to allow those types to be resolved. For instance, at a minimum the MsCorLib assembly should always be added as a reference.

See the C# Getting Started or Visual Basic Getting Started topics for more information on how load project assembly references.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The Python Language Add-on is an optional premium extra for SyntaxEditor customers that includes an advanced implementation of the Python syntax language.

The add-on has been built from the ground up by Actipro to take advantage of best practices for syntax language design. While it is already packed with innovative features, the design is completely extensible and can be enhanced or modified as much as you like.

Note Note
Be sure to read through the language's "Getting Started" topic and follow each step in it exactly to ensure that the add-on's features will operate properly. While it only takes several lines of code to get up and running, those lines are very important and may prevent the add-on from working correctly if they are not present.

Although the add-on is distributed and demoed with the WPF controls, it is sold separately.

This topic contains these sections:

  • Python Language
  • Troubleshooting

Python Language

The advanced Python syntax language implementation in the SyntaxEditor Python Language Add-on includes everything from code outlining to syntax error reporting.

See the Python Language topics for more information.

Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

See the Troubleshooting topics for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The advanced Python syntax language implementation in the SyntaxEditor Python Language Add-on includes everything from code outlining to syntax error reporting.

Note Note
The syntax language supports both the Python v3.x and Python v2.x syntax, toggleable via a flag when creating the syntax language.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider
  • Context
  • Resolver
  • Automated IntelliPrompt

Features

The Python language is packed with features, including:

  • Automated IntelliPrompt completion list, parameter info, and quick info.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Line commenting.
  • Smart indent.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.
  • Project that manage a project's code files and references to external libraries, such as the Python standard library.
  • Package repository that stores and caches reflection information for Python packages.
  • Support for navigable symbol selector (contextual drop-down).

Licensing

Even though the Python Languages Add-on is distributed and demoed with the WPF controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the Python language from the Python Language Add-on, implemented by the PythonSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The Python language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Context

The Python language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

See the Context topic for more information.

Resolver

Each Python IProject has an IResolver that can examine a Python context and AST expression and return the results associated with that expression. The resolver is used by the automated IntelliPrompt features to determine what to show in the UI for various scenarios.

See the Resolver topic for more information.

Automated IntelliPrompt

The Python language has built-in automated IntelliPrompt completion list, parameter info, and quick info features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

This topic covers how to get started using the Python language from the Python Language Add-on, implemented by the PythonSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the Ambient Package Repository
  • Create the PythonSyntaxLanguage
  • Configure the Python Project
  • Use the PythonSyntaxLanguage
  • Documents Should Have an Appropriate FileName and Tab Settings
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new ThreadedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New ThreadedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the Ambient Package Repository

An ambient package repository should always be set up to ensure that the application is able to use and cache package data from all packages within the Python project's search paths. A Python project (see below) normally adds search paths for the root of your project's .py files, along with external libraries such as the Python standard library's Lib folder. When a search path is added to a project, it will search the cache path to see if the cached data there is up-to-date with the related source package. If not, cache data is added to the package repository via a worker thread.

The ambient package repository should be set up in your application startup code. The FileBasedPackageRepository class is the default implementation of a package repository, which supports the writing of binary package data to a cache folder specified in its constructor, as long as the application has read/write permissions to that folder (usually requires full trust).

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    // Use a path like this if in full trust
    string appDataPath = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData),
        @"YourCompanyName\YourApplicationName\Package Repository");
    AmbientPackageRepositoryProvider.Repository = new FileBasedPackageRepository(appDataPath);
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    ' Use a path like this if in full trust
    Dim appDataPath As String = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), _
        "YourCompanyName\YourApplicationName\Package Repository")
    AmbientPackageRepositoryProvider.Repository = New FileBasedPackageRepository(appDataPath)
    ...
End Sub

Note Note
Failure to set up an ambient package repository provider will result in IntelliPrompt features not working for module internals.

Create the PythonSyntaxLanguage

The next step is to create an instance of the PythonSyntaxLanguage class and configure its project.

Note Note
Since Python v3.x has breaking syntax changes from v2.x, you can pass a PythonVersion parameter into the language constructor to designate which version should be supported.

This code creates a PythonSyntaxLanguage for editing Python v3.x code:

C#
VB
Copy
​var language = new PythonSyntaxLanguage(PythonVersion.Version3);
​Dim language As New PythonSyntaxLanguage(PythonVersion.Version3)

Alternatively, this code creates a PythonSyntaxLanguage for editing Python v2.x code:

C#
VB
Copy
​var language = new PythonSyntaxLanguage(PythonVersion.Version2);
​Dim language As New PythonSyntaxLanguage(PythonVersion.Version2)

Configure the Python Project

Each language has a IProject registered as a service on it that provides information such as which modules are actively being edited in a SyntaxEditor, the collection of paths to search for external packages, and the Python version.

If you wish to support automated IntelliPrompt for external modules, it is important to add search paths to the project. This tells the resolver where to look for .py files. Note that the resolver will recursively search through child folders of specified paths as long as the folder names are valid Python identifiers.

It is common practice to specify these paths:

  • The root path of your Python project code
  • The path to the Python standard library Lib folder
  • The path to the Python standard library's Lib\site-packages folder
  • The path to any other folders that contain external libraries that are used by code in your project

This code gets the language's default project, and adds several search paths to where external packages can be located and used for IntelliPrompt:

C#
VB
Copy
​var project = language.GetService<IProject>();
project.SearchPaths.Add(@"C:\Python\Projects\MyProject");
project.SearchPaths.Add(@"C:\Python\Platform34\Lib");
project.SearchPaths.Add(@"C:\Python\Platform34\Lib\site-packages");
​Dim project As IProject = language.GetService(Of IProject)()
project.SearchPaths.Add("C:\Python\Projects\MyProject")
project.SearchPaths.Add("C:\Python\Platform34\Lib")
project.SearchPaths.Add("C:\Python\Platform34\Lib\site-packages")

Use the PythonSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing Python code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your PythonSyntaxLanguage instance among all the documents in your application that are editing Python code. This saves on overall memory usage and reduces load times.

Documents Should Have an Appropriate FileName and Tab Settings

It is a good practice to set the FileName on any document using the language to an appropriate value that uniquely identifies the document's contents. The filename is used as a key to register the module defined in the document with the language's IProject.

Note Note
If the filename is left empty, relative paths can't be used in from...import statements and some other IntelliPrompt feature might not work properly.

Python also generally prefers that spaces are used in place of tabs for indentation. Set the ITextDocument.AutoConvertTabsToSpaces property to true to force the use of spaces.

This code sets the filename and tab options for a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.FileName = @"C:\mymodule.py";
editor.Document.TabSize = 4";
editor.Document.AutoConvertTabsToSpaces = true
​editor.Document.FileName = "C:\mymodule.py
editor.Document.TabSize = 4
editor.Document.AutoConvertTabsToSpaces = True"

Assembly Requirements

The following list indicates the assemblies that are used with the Python syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Wpf.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for WPF
ActiproSoftware.Text.LLParser.Wpf.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Wpf.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro WPF controls
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for WPF control
ActiproSoftware.Text.Addons.Python.Wpf.dll | Yes | Actipro | Python Language Add-on | Core text/parsing for the Python languages
ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll | Yes | Actipro | Python Language Add-on | SyntaxEditor for WPF advanced Python syntax language implementations

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

The Python language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The PythonIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope.

For instance, pressing ENTER after a : will cause the next line to be indented by one tab stop. Pressing ENTER after a statement such as a return statement will outdent by one tab stop.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The PythonSyntaxLanguage class automatically registers a PythonIndentProvider with itself when it is created, so normally indent providers never need to be set on a Python language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomPythonIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomPythonIndentProvider());
​language.RegisterIndentProvider(New CustomPythonIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on PythonSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context

The Python language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

This topic contains these sections:

  • Obtaining Context Information
  • .NET Context

Obtaining Context Information

Context information can be retrieved via the use of the PythonContextFactory class. Its CreateContext method accepts a TextSnapshotOffset and returns the IPythonContext for that offset.

This code retrieves an IPythonContext for the caret's offset (the end selection offset in the active view):

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
IPythonContext context = new PythonContextFactory().CreateContext(snapshotOffset);
​Dim snapshotOffset As TextSnapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context As IPythonContext = New PythonContextFactory().CreateContext(snapshotOffset)

A context kind (via the PythonContextKind enumeration) can also be passed to a CreateContext method overload. The default value is Self but you can also pass SelfAndSiblings to indicate that alternate logic should be used when building the context. When SelfAndSiblings is passed, the context factory will return a context object that focuses on the "parent" of the offset. This allows resolver operations that use the context to enumerate a list of accessible members.

.NET Context

IPythonContext objects provide .NET language-related context information for a specific snapshot offset, such as the containing AST node, target expression, and more.

These IPythonContext members are important:

Member | Description
ContainingAstNode Property | Gets the IAstNode that contains the TextSnapshotOffset.
InitializationSnapshotRange Property | Gets the TextSnapshotRange with which the context was initialized.
Project Property | Gets the IProject with which this context is associated.
SnapshotOffset Property | Gets the TextSnapshotOffset for which this context was created.
TargetExpression Property | Gets the target AST Expression for the context, if known.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Resolver

Each Python IProject has an IResolver that can examine a Python context and AST expression and return the results associated with that expression. The resolver is used by the automated IntelliPrompt features to determine what to show in the UI for various scenarios.

An IResolver instance is automatically created by the Python Project when it is instantiated.

While it's not normally necessary to directly use the resolver (since it internally helps drive the built-in automated IntelliPrompt features), there are several ways to externally adjust how it functions. These are described below.

This topic contains these sections:

  • Unknown Return Type Reference Callback
  • Maximum Import Recursion Level

Unknown Return Type Reference Callback

Since the Python add-on doesn't have a full interpreter to run, sometimes the return types of functions will be unknown to it. When the resolver is unable to determine the type that is returned by a function, variable, etc., it will call the IResolver.UnknownReturnTypeReferenceCallback if one has been specified.

This code shows how a callback can be created to return types for functions, variables, etc. in scenarios where the resolver couldn't determine the type.

C#
VB
Copy
​...
project.Resolver.UnknownReturnTypeReferenceCallback = MyUnknownReturnTypeReferenceCallback;
...
private static ITypeReference MyUnknownReturnTypeReferenceCallback(IReflectionDefinition refDef) {
    var funcDef = refDef as IFunctionDefinition;
    if (funcDef != null) {
        if (funcDef.DeclaringModule != null) {
            // Examine the name of the declaring module
            switch (funcDef.DeclaringModule.Name) {
                case "somemodule":
                    if (funcDef.DeclaringType != null) {
                        // Examine the name of the declaring type
                        switch (funcDef.DeclaringType.Name) {
                            case "SomeClass":
                                // Examine the name of the method
                                switch (funcDef.Name) {
                                    case "somemethod":
                                        // Return a 'SomeOtherClass' type defined in a 'someotherclass.py' module
                                        return new TypeReference(Path.Combine(pathToTheReturnTypeModule, "someotherclass.py"), "SomeOtherClass");
                                }
                                break;
                    }
                    else {
                        // Examine the name of the function (not a method since there is no DeclaringType)
                        switch (funcDef.Name) {
                            case "somefunction":
                                // Return the built-in 'int' type
                                return new TypeReference(null, "int");
                        }
                    }
                    break;
            }
        }
    }

    return null;
}
​...
project.Resolver.UnknownReturnTypeReferenceCallback = AddressOf(MyUnknownReturnTypeReferenceCallback)
...
Private Shared Function MyUnknownReturnTypeReferenceCallback(ByVal refDef As IReflectionDefinition) As ITypeReference
    Dim funcDef = TryCast(refDef, IFunctionDefinition)
    If funcDef IsNot Nothing Then
        If funcDef.DeclaringModule IsNot Nothing Then
            ' Examine the name of the declaring module
            Select Case funcDef.DeclaringModule.Name
                Case "somemodule"
                    If funcDef.DeclaringType IsNot Nothing Then
                        ' Examine the name of the declaring type
                        Select Case funcDef.DeclaringType.Name
                            Case "SomeClass"
                                ' Examine the name of the method
                                Select Case funcDef.Name
                                    Case "somemethod"
                                        ' Return a 'SomeOtherClass' type defined in a 'someotherclass.py' module
                                        Return New TypeReference(Path.Combine(pathToTheReturnTypeModule, "someotherclass.py"), "SomeOtherClass")
                                End Select
                        End Select
                    Else
                        ' Examine the name of the function (not a method since there is no DeclaringType)
                        Select Case funcDef.Name
                            Case "somefunction"
                                ' Return the built-in 'int' type
                                Return New TypeReference(Nothing, "int")
                        End Select
                    End If
            End Select
        End If
    End If

    Return Nothing
End Function

Maximum Import Recursion Level

Some very large external Python packages involve lots of import recursions, where certain modules import other modules/packages, which in turn import other modules/packages down the line. While the Python resolver has a lot of optimizations and caching mechanisms to make examination of those imports as quick as possible, packages with many hundreds of interconnected modules might experience a brief slowdown as the resolver processes. This may manifest itself as a brief pause while bringing up an IntelliPrompt completion list, etc.

There is an option via the IResolver.MaximumImportRecursionLevel property that can be changed to limit how many import recursions deep the resolver can go. The default value is 10. If the root module has an import statement, as the resolver navigates down to the imported module/package, that is the first recursion. If that imported module/package has another import that would affect the resolver results, navigating into this other import would be the second recursion. By making the MaximumImportRecursionLevel a smaller value, it prevents the resolver from going too deeply into import recursions (thus possibly improving resolution speed), but also may cause only a subset of the real resolver results to be returned.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

The Python language has built-in automated IntelliPrompt completion list, parameter info, quick info, and navigable symbol selector features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Completion List
  • Parameter Info
  • Quick Info
  • Navigable Symbol Selector
  • Showing Full Docstrings
  • Disabling Automated IntelliPrompt

Completion List

IntelliPrompt completion lists are used to present end users with a list of accessible members from the code editor's current caret location. In many cases, the completion list is triggered by key events such as pressing Ctrl+Space or typing a . character after an identifier.

There are two types of completion list scenarios when typing in code blocks. First is when listing members of something. This can occur when typing a . character after an identifier. The second type is when showing all accessible members based on the current context. This can occur when starting to type a new sequence of identifiers.

In cases where a completion list is triggered via Ctrl+Space, if there is a single match for the text that has been typed, it will not show the list but will auto-complete the match. This saves the user from having to type the entire identifier/keyword that was matched.

The completion list features are implemented by the PythonCompletionProvider class.

Parameter Info

IntelliPrompt parameter info is the ability to display helpful tooltips when typing an invocation that presents all of the signature overloads, along with information on the current parameter being typed.

Parameter info is displayed for function and method invocations.

IntelliPrompt quick info features are implemented by the PythonParameterInfoProvider language service.

Quick Info

IntelliPrompt quick info is the ability to display helpful tooltips when hovering over various identifiers and some language keywords in the code editor. When hovering over an identifier, the resolver attempts to determine what the identifier means, and the resulting information is presented in a quick info tip.

Detailed information is shown for packages, modules, types, functions/methods, parameters, and variables. Appropriate docstring comments are displayed when available.

IntelliPrompt quick info features are implemented by the PythonQuickInfoProvider language service.

Navigable Symbol Selector

The Navigable Symbol Selector is a control that generally sits above and is bound to a SyntaxEditor. It shows the types and attributes that currently enclose or are nearest the caret, and allows the end user to select other types/attributes within the same document via a dropdown.

The NavigableSymbolSelector.AreMemberSymbolsSupported property should be set to false when working with Python since only one drop-down is used.

This control populates its symbol lists by the PythonNavigableSymbolProvider language service.

Showing Full Docstrings

By default, any docstrings that show in IntelliPrompt popups will only be the summary line. The summary line is the text up through the first whitespace line within docstring. This behavior can be altered for various IntelliPrompt providers so that the entire docstring is displayed instead.

This code tells each IntelliPrompt provider to display the entire docstring:

C#
VB
Copy
​language.RegisterService(new PythonCompletionProvider() { DocstringDisplayMode = PythonDocstringDisplayMode.All });
language.RegisterService(new PythonParameterInfoProvider() { DocstringDisplayMode = PythonDocstringDisplayMode.All });
language.RegisterService(new PythonQuickInfoProvider() { DocstringDisplayMode = PythonDocstringDisplayMode.All });
​language.RegisterService(New PythonCompletionProvider() With {.DocstringDisplayMode = PythonDocstringDisplayMode.All})
language.RegisterService(New PythonParameterInfoProvider() With {.DocstringDisplayMode = PythonDocstringDisplayMode.All})
language.RegisterService(New PythonQuickInfoProvider() With {.DocstringDisplayMode = PythonDocstringDisplayMode.All})

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the PythonSyntaxLanguage that is created:

C#
VB
Copy
​var language = new PythonSyntaxLanguage();

// Disable completion lists
language.UnregisterService<PythonCompletionProvider>();

// Disable parameter info
language.UnregisterService<PythonParameterInfoProvider>();

// Disable quick info
language.UnregisterService<PythonQuickInfoProvider>();

// Disable navigable symbol provider
language.UnregisterService<INavigableSymbolProvider>();
​Dim language = New PythonSyntaxLanguage()

' Disable completion lists
language.UnregisterService(Of PythonCompletionProvider)()

' Disable parameter info
language.UnregisterService(Of PythonParameterInfoProvider)()

' Disable quick info
language.UnregisterService(Of PythonQuickInfoProvider)()

' Disable navigable symbol provider
language.UnregisterService(Of INavigableSymbolProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

This topic contains these sections:

  • How Do I Get Started With Python Language?
  • Typing Is Slow

How Do I Get Started With Python Language?

The Getting Started topic walks through all the requirements for using the Python language. Be sure to follow all the steps in that topic so that the syntax language operates correctly.

Typing Is Slow

If you notice a lag when typing, it is likely due to an ambient parse request dispatcher not being set up. Each time text changes occur, such as while typing, a parse request is fired off for the parser to parse the document. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up an ambient parse request dispatcher for your application.

When no ambient parse request dispatcher has been configured for your application, the parsing will occur in the main UI thread, thus severely affecting typing performance, especially in larger documents.

See the Getting Started topic for more information on how to set up an ambient parse request dispatcher for your application.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The Web Languages Add-on is an optional premium extra for SyntaxEditor customers that includes an advanced implementation of the XML, JavaScript, and JSON syntax languages.

The add-on has been built from the ground up by Actipro to take advantage of best practices for syntax language design. While it is already packed with innovative features, the design is completely extensible and can be enhanced or modified as much as you like.

Note Note
Be sure to read through the language's "Getting Started" topic and follow each step in it exactly to ensure that the add-on's features will operate properly. While it only takes several lines of code to get up and running, those lines are very important and may prevent the add-on from working correctly if they are not present.

Although the add-on is distributed and demoed with the WPF controls, it is sold separately.

This topic contains these sections:

  • XML Language
  • JavaScript Language
  • JSON Language
  • Troubleshooting

XML Language

The advanced XML syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from automated IntelliPrompt and code outlining to validation, and provides a best-of-breed XML editing experience for end users.

See the XML Language topics for more information.

JavaScript Language

The advanced JavaScript syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from code outlining to syntax error reporting.

See the JavaScript Language topics for more information.

JSON Language

The advanced JSON syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from code outlining to syntax error reporting.

See the JSON Language topics for more information.

Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

See the Troubleshooting topics for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The advanced XML syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from automated IntelliPrompt and code outlining to validation, and provides a best-of-breed XML editing experience for end users.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Schema Resolver
  • Validator
  • End Tag Auto-Completer
  • Indent Provider
  • Text Formatter
  • Context
  • Automated IntelliPrompt

Features

The XML language is packed with features, including:

  • Automated IntelliPrompt completion lists and quick info for elements, attributes, and values based on one or more loaded .XSD files.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Automatic code outlining based on XML element structure.
  • Reporting and automatic squiggle display of errors for invalid XML syntax and non-conformance to schema/DTD.
  • Default namespace settings in cases where xmlns attributes are not specified on the root element.
  • Mouse hover quick info for syntax/validation errors.
  • Easily obtain full XML contextual information for any offset.
  • End tag auto-complete.
  • Line commenting.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Support for navigable symbol selector (element/attribute drop-downs).

Licensing

Even though the Web Languages Add-on is distributed and demoed with the WPF controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the XML language from the Web Languages Add-on, implemented by the XmlSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The XML language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The IXmlParseData results returned by this parser are consumed by multiple other features of the language, such as automated IntelliPrompt, code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Schema Resolver

The schema resolver is an essential piece of the XML language since it is what loads the XML schema data that is used to drive features such as automated IntelliPrompt and validation.

See the Schema Resolver topic for more information.

Validator

A Validator executes immediately after the main XML parser runs (still in the parser worker thread) if there are no parser syntax errors found. The validator then scans the XML to ensure that it adheres to the loaded schemas and/or DTDs, and places any validation errors in the IXmlParseData.Errors collection that is returned by the parser.

See the Validator topic for more information.

End Tag Auto-Completer

An end-tag auto-completer is an object that can be called to attempt to insert an end tag such as when > is typed by the end user.

See the End Tag Auto-Completer topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Text Formatter

The built-in XML text formatter can adjust whitespace between elements and attributes to make code more readable.

See the Text Formatter topic for more information.

Context

The XML language can return detailed context information about any offset in a document. The context includes data such as declared namespaces, containing element hierarchy, current element/attribute, and more. This sort of information is essential in determining what to display in automated IntelliPrompt.

See the Context topic for more information.

Automated IntelliPrompt

The XML language has built-in automated IntelliPrompt completion list and quick info features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

This topic covers how to get started using the XML language from the Web Languages Add-on, implemented by the XmlSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the XmlSchemaResolver
  • Configure DTD Support
  • Configure the XmlSyntaxLanguage
  • Use the XmlSyntaxLanguage
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new ThreadedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New ThreadedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the XmlSchemaResolver

Next, create a XmlSchemaResolver instance and use the methods described in the Schema Resolver topic to initialize it with one or more .XSD files. If you use DTDs for validation instead, you can ignore this step.

The XmlSchemaResolver is used to provide data consumed for supporting automated IntelliPrompt and validation, so it is essential that you configure it with a schema data that describes the XML that will be edited.

.XSD files can be found on the Internet for common XML formats, and custom .XSD's can be created for any other XML format. The Internet has a lot of great information on how to create .XSD files. Please do Internet searches if you need assistance building your own .XSD files.

This code creates a XmlSchemaResolver and loads an .XSD file that is located on the hard drive at the path specified by the path variable:

C#
VB
Copy
​XmlSchemaResolver resolver = new XmlSchemaResolver();
resolver.LoadSchemaFromFile(path);
​Dim resolver As New XmlSchemaResolver()
resolver.LoadSchemaFromFile(path)

Configure DTD Support

We recommend that if you have the option, you use XML schemas (.XSD files) instead of DTDs to provide validation for your XML. XML schemas also enable automated IntelliPrompt features like completion lists that aren't available when using DTDs.

If you do wish to support DTDs for validation, you must set an option on the XmlValidator language service and then register it on the language. It is not enabled by default since DTDs can sometimes attempt to access external resources.

This code creates a XmlValidator that allows DTD validation support:

C#
VB
Copy
​XmlValidator validator = new XmlValidator();
validator.Mode = XmlValidatorMode.Dtd;
​Dim validator As New XmlValidator()
validator.Mode = XmlValidatorMode.Dtd

Note Note
A XmlValidator language service is registered on XmlSyntaxLanguage by default but it has the default Mode property value of XmlValidatorMode.Schema.

Configure the XmlSyntaxLanguage

The next step is to create an instance of the XmlSyntaxLanguage class and register the XmlSchemaResolver as a "feature" service on it so that other language services can consume the schema data. If DTD validation support is desired, you can also register the XmlValidator as a "feature" service.

This code creates a XmlSyntaxLanguage and registers the XmlSchemaResolver service:

C#
VB
Copy
​XmlSyntaxLanguage language = new XmlSyntaxLanguage();
language.RegisterXmlSchemaResolver(resolver);  // If XML schema support is desired
language.RegisterXmlValidator(validator);  // If DTD validation support is desired
​Dim language As New XmlSyntaxLanguage()
language.RegisterXmlSchemaResolver(resolver)  ' If XML schema support is desired
language.RegisterXmlValidator(validator)  ' If DTD validation support is desired

Note Note
The XmlSyntaxLanguageExtensions.RegisterXmlSchemaResolver and XmlSyntaxLanguageExtensions.RegisterXmlValidator methods in the code snippet above are helper extension methods that get added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.Xml namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Use the XmlSyntaxLanguage

The final step is to use the language on the ICodeDocument instances that will be editing XML.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Assembly Requirements

The following list indicates the assemblies that are used with the XML syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Wpf.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for WPF
ActiproSoftware.Text.LLParser.Wpf.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Wpf.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro WPF controls
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for WPF control
ActiproSoftware.Text.Addons.Xml.Wpf.dll | Yes | Actipro | Web Languages Add-on | Core text/parsing for the XML language
ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll | Yes | Actipro | Web Languages Add-on | SyntaxEditor for WPF advanced XML syntax language implementation

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

The XML language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The IXmlParseData results returned by this parser are consumed by multiple other features of the language, such as automated IntelliPrompt, code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Well-Formed Flag
  • Retrieving Parse Data
  • Parsing a Text String

AST Construction

A complete AST of parsed documents is generated by the parser, with structured element nodes and lists of the attributes on each element. It is passed back in the IXmlParseData.Ast property.

This information is used when building the context for an offset.

Parse Errors

Parse errors are reported from the parser and the validator. They are passed back in the IXmlParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text. The validator for the language can also report errors when the XML doesn't conform to the schemas loaded in the schema resolver.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Well-Formed Flag

The IXmlParseData.IsWellFormed property indicates whether the XML is well-formed.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the IXmlParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Schema Resolver

The schema resolver is an essential piece of the XML language since it is what loads the XML schema data that is used to drive features such as automated IntelliPrompt and validation.

The IXmlSchemaResolver interface provides the base requirements for this functionality. It is installed into a language as a "feature" language service.

The XmlSchemaResolver class is the default implementation of the IXmlSchemaResolver interface.

This topic contains these sections:

  • Managing the .XSD Schemas Used
  • Using Default Namespace Prefix Mappings
  • Schema Data Helper Methods
  • Registering with a Syntax Language
  • Disabling the Functionality

Managing the .XSD Schemas Used

The schema resolver can manage one to many .XSD schemas at a time. These .XSD's are used to provide automated IntelliPrompt completion lists and quick info, and are also used to validate XML documents.

The XmlSchemaResolver class has numerous methods for loading XML schema data directly, or from files, streams, strings, etc.

Member | Description
AddSchema Method | Adds another XmlSchema to the existing SchemaSet.
AddSchemaFromFile Method | Adds another XmlSchema from a file to the existing SchemaSet.
AddSchemaFromStream Method | Adds another XmlSchema from a Stream to the existing SchemaSet.
AddSchemaFromString Method | Adds another XmlSchema from a string to the existing SchemaSet.
LoadSchema Method | Clears any existing SchemaSet and loads a new single XmlSchema.
LoadSchemaFromFile Method | Clears any existing SchemaSet and loads a new single XmlSchema from a file.
LoadSchemaFromStream Method | Clears any existing SchemaSet and loads a new single XmlSchema from a Stream.
LoadSchemaFromString Method | Clears any existing SchemaSet and loads a new single XmlSchema from a string.
SchemaSet Method | Gets or sets the XmlSchemaSet to use. This property can be set if you already have a XmlSchemaSet loaded that should directly be used.

Using Default Namespace Prefix Mappings

The IXmlSchemaResolver.DefaultNamespace property gets or sets the default namespace to use for any XML documents where the root element doesn't have an xmlns specified. The result of specifying a default namespace is the same as if a xmlns attribute was set on the document's root element. Automated IntelliPrompt, validation, etc. will treat it as such.

The DefaultNamespace property actually just gets/sets the entry in the DefaultNamespacePrefixMappings dictionary property for an empty string, meaning default namespace prefix.

Other namespace prefixes can be mapped by default in the DefaultNamespacePrefixMappings property too, and similar to the processing of the DefaultNamespace property, automated IntelliPrompt, validation, etc. will use these mappings.

This code creates a schema resolver, sets the default namespace to XHTML and also maps a foo namespace prefix, similar to if the root element had xmlns="http://www.w3.org/1999/xhtml" xmlns:foo="http://tempuri.org/bar.xsd" :

C#
VB
Copy
​XmlSchemaResolver resolver = new XmlSchemaResolver();
resolver.DefaultNamespace = "http://www.w3.org/1999/xhtml";
resolver.DefaultNamespacePrefixMappings.Add("foo", "http://tempuri.org/bar.xsd");
​Dim resolver As New XmlSchemaResolver()
resolver.DefaultNamespace = "http://www.w3.org/1999/xhtml"
resolver.DefaultNamespacePrefixMappings.Add("foo", "http://tempuri.org/bar.xsd")

Use of these properties is entirely optional and should only be used in cases where xmlns attributes are not required to be specified in the document's root element. xmlns attribute settings in the XML that have the same namespace prefixes as keys in the DefaultNamespacePrefixMappings property will take precedence over the default mappings.

Schema Data Helper Methods

Schema resolvers have a number of helper methods that provide data based on the XML schemas that are loaded. This data is consumed by other language services such as the built-in functionality and services that provide context and automated IntelliPrompt, and do not typically need to be consumed in your code.

Registering with a Syntax Language

Any object that implements IXmlSchemaResolver can be associated with a syntax language by registering it as an IXmlSchemaResolver service on the language.

Note Note
No IXmlSchemaResolver is installed on XmlSyntaxLanguage by default. To enable support of automated IntelliPrompt and validation, an IXmlSchemaResolver instance must be configured and registered on the language.

This code creates a schema resolver, initializes it with a schema from the file specified in the path variable and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​XmlSchemaResolver resolver = new XmlSchemaResolver();
resolver.LoadSchemaFromFile(path);
language.RegisterXmlSchemaResolver(resolver);
​Dim resolver As New XmlSchemaResolver()
resolver.LoadSchemaFromFile(path)
language.RegisterXmlSchemaResolver(resolver)

Note Note
The XmlSyntaxLanguageExtensions.RegisterXmlSchemaResolver method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.Xml namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on XmlSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Validator

A Validator executes immediately after the main XML parser runs (still in the parser worker thread) if there are no parser syntax errors found. The validator then scans the XML to ensure that it adheres to the loaded schemas and/or DTDs, and places any validation errors in the IXmlParseData.Errors collection that is returned by the parser.

The IXmlValidator interface provides the base requirements for this functionality. It is installed into a language as a "feature" language service.

The XmlValidator class is the default implementation of the IXmlValidator interface. By default it is not set up to allow DTD-based validation since DTDs sometimes access external resources.

This topic contains these sections:

  • Integration with Schema Resolver
  • Enabling DTD Validation
  • Registering with a Syntax Language
  • Disabling the Functionality

Integration with Schema Resolver

The default validator is set up to use the XML schema data in the schema resolver to ensure that the XML conforms to the schemas.

Enabling DTD Validation

As mentioned above, the XmlValidator doesn't allow DTD validation by default since DTD validation can sometimes access external resources. To enable support for DTDs, set the XmlValidator.Mode property to XmlValidationMode.Dtd to only use DTDs (no schemas) or to XmlValidationMode.SchemaWithDtd to use schemas but allow DTDs for entities, and register the updated validator object on the language as a "feature" service (see example below).

DTD Path

Sometimes DTDs attempt to look for files in the current application folder. The XmlValidator.DtdPath property can optionally be set to a folder that contains DTD-referenced files.

When this property is set, prior to validation and if DTDs are allowed, the current directory will be changed to the path. When validation is complete, the current directory will be restored.

Registering with a Syntax Language

Any object that implements IXmlValidator can be associated with a syntax language by registering it as an IXmlValidator service on the language.

The XmlSyntaxLanguage class automatically registers a XmlValidator with itself when it is created, so normally validators never need to be set on an XML language unless a custom one is made or DTD validation support is desired.

This code adds DTD validation support to the language that is already declared in the language variable by registering a new XmlValidator language service with the Mode property set to XmlValidationMode.Dtd:

C#
VB
Copy
​XmlValidator validator = new XmlValidator();
validator.Mode = XmlValidationMode.Dtd;
language.RegisterXmlValidator(validator);
​Dim validator As XmlValidator = New XmlValidator();
validator.Mode = XmlValidationMode.Dtd
language.RegisterXmlValidator(New CustomXmlValidator())

Note Note
The XmlSyntaxLanguageExtensions.RegisterXmlValidator method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.Xml namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on XmlSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


End Tag Auto-Completer

An end-tag auto-completer is an object that can be called to attempt to insert an end tag such as when > is typed by the end user.

The IXmlEndTagAutoCompleter interface provides the base requirements for this functionality. It is installed into a language as a "feature" language service.

The XmlEndTagAutoCompleter class is the default implementation of the IXmlEndTagAutoCompleter interface.

This topic contains these sections:

  • Integration with Schema Resolver
  • Registering with a Syntax Language
  • Disabling the Functionality

Integration with Schema Resolver

The auto-completer uses contextual information to determine whether an element should be closed without content or whether an end tag is appropriate. This contextual information is found by examining resolved schema element data passed in the XML context. Therefore a schema resolver should be configured and installed on the lanugage to achieve proper results.

If not schema data is found for the current element being closed, then an end tag will insert.

Registering with a Syntax Language

Any object that implements IXmlEndTagAutoCompleter can be associated with a syntax language by registering it as an IXmlEndTagAutoCompleter service on the language.

The XmlSyntaxLanguage class automatically registers a XmlEndTagAutoCompleter with itself when it is created, so normally end tag auto-completers never need to be set on an XML language unless a custom one is made.

This code creates a custom end tag auto-completer (defined in a make-believe CustomXmlEndTagAutoCompleter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterXmlEndTagAutoCompleter(new CustomXmlEndTagAutoCompleter());
​language.RegisterXmlEndTagAutoCompleter(New CustomXmlEndTagAutoCompleter())

Note Note
The XmlSyntaxLanguageExtensions.RegisterXmlEndTagAutoCompleter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.Xml namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on XmlSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The XmlIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will normally use block indent (same indent level as the previous line) except when it detects that ENTER is pressed on a line that ends with a start tag. In this case, the caret is indented another level on the next line.

Block Element Handling

Also consider this scenario, where the caret is at |:

XML
Copy
​<tag>|</tag>

If the end user presses ENTER, the indent provider will make this the result:

XML
Copy
​<tag>
    |
</tag>

Note how the end tag is moved to the line below the caret and is properly indented to the same indent level of the start tag. However the caret is indented on the line in the middle of the tags.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The XmlSyntaxLanguage class automatically registers a XmlIndentProvider with itself when it is created, so normally indent providers never need to be set on an XML language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomXmlIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomXmlIndentProvider());
​language.RegisterIndentProvider(New CustomXmlIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on XmlSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

The built-in XML text formatter can adjust whitespace between elements and attributes to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The XmlTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality
  • Attribute Spacing Mode
  • Element Spacing Mode
  • Tag Wrap Length

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The XmlSyntaxLanguage class automatically registers a XmlTextFormatter with itself when it is created, so normally text formatters never need to be set on a XML language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomXmlTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomXmlTextFormatter());
​language.RegisterTextFormatter(New CustomXmlTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on XmlSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Attribute Spacing Mode

The XmlTextFormatter has an AttributeSpacingMode property that can be set to alter the behavior of the formatter when dealing with whitespace around attributes within an element. None of the modes affect the TagWrapLength feature (described below). The XmlAttributeSpacingMode enumeration defines these three mode options:

Mode | Formatter Behavior
Preserve | The formatter will not make changes to the whitespace around attributes. This is the default mode.
NormalizeWhitespace | The formatter will adjust any whitespace around attributes to be exactly one space.
SeparateLines | The formatter will adjust any whitespace such that each attribute is on a separate line.

Element Spacing Mode

The XmlTextFormatter has an ElementSpacingMode property that can be set to alter the behavior of the formatter when dealing with whitespace in element content. The XmlElementSpacingMode enumeration defines these three mode options:

Mode | Formatter Behavior
Preserve | The formatter will not make changes to the whitespace in element content. This is the default mode.
NormalizeEmptyLines | The formatter will adjust any whitespace around element content so that there is no more than a single empty line between the content and the containing element.
RemoveEmptyLines | The formatter will remove extra whitespace around element content. The actual result depends on the type of content, which can be text-only, one or more elements, or mixed content.

Tag Wrap Length

The XmlTextFormatter has a TagWrapLength property that can be set to cause the formatter to wrap an attribute to the next line when the element length on a particular line exceeds the specified length. This feature will operate regardless of the AttributeSpacingMode.

Setting the value to 0 (zero) will disable the feature, which is the default value. When enabling this wrap feature, a common setting is 120.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context

The XML language can return detailed context information about any offset in a document. The context includes data such as declared namespaces, containing element hierarchy, current element/attribute, and more. This sort of information is essential in determining what to display in automated IntelliPrompt.

This topic contains these sections:

  • Obtaining Context Information
  • XML Context
  • Element Context
  • Attribute Context

Obtaining Context Information

Context information can be retrieved via the use of the XmlContextFactory class. Its CreateContext method accepts a TextSnapshotOffset and returns the IXmlContext for that offset.

This code retrieves an IXmlContext for the caret's offset (the end selection offset in the active view):

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
IXmlContext context = new XmlContextFactory().CreateContext(snapshotOffset);
​Dim snapshotOffset As TextSnapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context As IXmlContext = New XmlContextFactory().CreateContext(snapshotOffset)

XML Context

IXmlContext objects provide XML-related context information for a specific snapshot offset, such as the element hierarchy that contains the offset, the available namespace declarations, current element/attribute, and more.

These IXmlContext members are important:

Member | Description
ElementHierarchy Property | Gets a read-only list of IXmlElementContext objects that describes the element hierarchy. The element hierarchy is the list of parent elements that contain the current offset.
InitializationSnapshotRange Property | Gets the TextSnapshotRange with which the context was initialized.
NamespaceDeclarations Property | Gets the mapping dictionary of namespace to namespace prefixes that are declared at the context. The dictionary keys are namespaces and the values are namespace prefixes.
SchemaResolver Property | Gets the IXmlSchemaResolver to use.
SnapshotOffset Property | Gets the TextSnapshotOffset for which this context was created.
TargetAttribute Property | Gets the IXmlAttributeContext that contains context information related to the target attribute. This property is only populated if the context is related to an attribute.
TargetElement Property | Gets the IXmlElementContext that contains context information related to the target element. This property is only populated if the context is related to an element or attribute.
Type Property | Gets an XmlContextType that specifies the type of context.

Element Context

IXmlContext objects can return contextual data about XML elements via their ElementHierarchy and TargetElement properties. Both of these properties return objects of type IXmlElementContext that have element contextual information.

Element contexts contain their namespace/name information, included attributes, resolved schema element data, and various snapshot ranges.

These IXmlElementContext members are important:

Member | Description
Attributes Property | Gets the dictionary of attributes for this element. The dictionary keys are the attribute qualified names and the values are IXmlAttributeContext objects.
EndTagSnapshotRange Property | Gets the nullable TextSnapshotRange that specifies the range of the end tag, if there is one.
Name Property | Gets the name of the element.
Namespace Property | Gets the namespace that defines the element.
NamespacePrefix Property | Gets the prefix of the namespace that defines the element.
QualifiedName Property | Gets the XmlQualifiedName that contains the element's qualified name.
SchemaElement Property | Gets the resolved XmlSchemaElement for this element, if known.
StartTagNameSnapshotRange Property | Gets the TextSnapshotRange that specifies the range of the start tag name.

Attribute Context

IXmlAttributeContext objects specify contextual information about XML attributes. Instances are returned by the IXmlContext.TargetAttribute and IXmlElementContext.Attributes properties.

Attribute contexts contain their namespace/name information, owner element, resolved schema attribute data and name snapshot range.

These IXmlAttributeContext members are important:

Member | Description
Element Property | Gets the IXmlElementContext upon which this attribute is located.
Name Property | Gets the name of the attribute.
NameSnapshotRange Property | Gets the TextSnapshotRange that specifies the range of the attribute name.
Namespace Property | Gets the namespace that defines the attribute.
NamespacePrefix Property | Gets the prefix of the namespace that defines the attribute.
QualifiedName Property | Gets the XmlQualifiedName that contains the attribute's qualified name.
SchemaAttribute Property | Gets the resolved XmlSchemaAttribute for this attribute, if known.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

The XML language has built-in automated IntelliPrompt completion list and quick info features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Completion List
  • Quick Info
  • Navigable Symbol Selector
  • Disabling Automated IntelliPrompt

Completion List

IntelliPrompt completion lists are used to present end users with a list of accessible elements, attributes, and attribute values from the code editor's current caret location. In many cases, the completion list is triggered by key events such as pressing Ctrl+Space or typing a < character, etc.

In cases where a completion list is triggered via Ctrl+Space, if there is a single match for the text that has been typed, it will not show the list but will auto-complete the match. This saves the user from having to type the entire name/value that was matched.

The completion list features are implemented by the XmlCompletionProvider class.

Quick Info

IntelliPrompt quick info is the ability to display helpful tooltips when hovering over various identifiers in the code editor. When hovering over an identifier, the resolver attempts to determine what the identifier means, and the resulting information is presented in a quick info tip.

Detailed information is shown for elements, attributes, and attribute values.

IntelliPrompt quick info features are implemented by the XmlQuickInfoProvider language service.

Navigable Symbol Selector

The Navigable Symbol Selector is a control that generally sits above and is bound to a SyntaxEditor. It shows the elements and attributes that currently enclose or are nearest the caret, and allows the end user to select other elements/attributes within the same document via a dropdown, and to navigate to those members upon selection.

This control populates its symbol lists by the XmlNavigableSymbolProvider language service.

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the XmlSyntaxLanguage that is created:

C#
VB
Copy
​var language = new XmlSyntaxLanguage();

// Disable completion lists
language.UnregisterService<XmlCompletionProvider>()

// Disable quick info
language.UnregisterService<XmlQuickInfoProvider>();

// Disable navigable symbol provider
language.UnregisterService<INavigableSymbolProvider>();
​Dim language = New XmlSyntaxLanguage()

' Disable completion lists
language.UnregisterService(Of XmlCompletionProvider)()

' Disable quick info
language.UnregisterService(Of XmlQuickInfoProvider)()

' Disable navigable symbol provider
language.UnregisterService(Of INavigableSymbolProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The advanced JavaScript syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from code outlining to syntax error reporting.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider
  • Text Formatter
  • Automated IntelliPrompt

Features

The JavaScript language is packed with features, including:

  • Automated IntelliPrompt completion list.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Over 45 distinct AST node classes.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Line commenting.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.
  • Code fragment editing with full IntelliPrompt, such as editing a function body.
  • Optionally change the parser to parse expressions, statements, etc. instead of compilation units.

Licensing

Even though the Web Languages Add-on is distributed and demoed with the WPF controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the JavaScript language from the Web Languages Add-on, implemented by the JavaScriptSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The JavaScript language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

See the Text Formatter topic for more information.

Automated IntelliPrompt

The JavaScript language has built-in automated IntelliPrompt completion list features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

This topic covers how to get started using the JavaScript language from the Web Languages Add-on, implemented by the JavaScriptSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and code outlining.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the JavaScriptSyntaxLanguage
  • Use the JavaScriptSyntaxLanguage
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new ThreadedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New ThreadedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the JavaScriptSyntaxLanguage

The next step is to create an instance of the JavaScriptSyntaxLanguage class.

This code creates a JavaScriptSyntaxLanguage:

C#
VB
Copy
​var language = new JavaScriptSyntaxLanguage();
​Dim language As New JavaScriptSyntaxLanguage()

Use the JavaScriptSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing JavaScript code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your JavaScriptSyntaxLanguage instance among all the documents in your application that are editing JavaScript code. This saves on overall memory usage and reduces load times.

Assembly Requirements

The following list indicates the assemblies that are used with the JavaScript syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Wpf.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for WPF
ActiproSoftware.Text.LLParser.Wpf.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Wpf.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro WPF controls
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for WPF control
ActiproSoftware.Text.Addons.JavaScript.Wpf.dll | Yes | Actipro | Web Languages Add-on | Core text/parsing for the JavaScript and JSON languages
ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll | Yes | Actipro | Web Languages Add-on | SyntaxEditor for WPF advanced JavaScript and JSON syntax language implementations

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

The JavaScript language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String
  • Grammar Options

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

Grammar Options

The JavaScript grammar (JavaScriptGrammar class) constructor can be passed an IJavaScriptGrammarOptions object that indicates options for the grammar's creation. The JavaScriptGrammarOptions class implements this interface.

Root Non-Terminal

The default options indicate that compilation unit should be the root non-terminal for the grammar. However this can be altered via the IJavaScriptGrammarOptions.RootNonTerminal property. The JavaScriptGrammarRootNonTerminal enumeration has a number of options for a root non-terminal, everything from expressions to statements.

Use this code to alter the root non-terminal for the grammar so that it tries to parse a single expression instead of a compilation unit:

C#
VB
Copy
​JavaScriptSyntaxLanguage language = new JavaScriptSyntaxLanguage();

JavaScriptGrammarOptions grammarOptions = new JavaScriptGrammarOptions();
grammarOptions.RootNonTerminal = JavaScriptGrammarRootNonTerminal.Expression;

JavaScriptGrammar grammar = new JavaScriptGrammar(grammarOptions);
language.RegisterParser(new JavaScriptParser(grammar));
​Dim language As New JavaScriptSyntaxLanguage()

Dim grammarOptions As New JavaScriptGrammarOptions()
grammarOptions.RootNonTerminal = JavaScriptGrammarRootNonTerminal.Expression

Dim grammar As New JavaScriptGrammar(grammarOptions)
language.RegisterParser(New JavaScriptParser(grammar))

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The JavaScriptIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope. For instance, pressing ENTER after a { will cause the next line to be indented by one tab stop. Pressing ENTER while still typing a statement will also attempt to indent the next line by one tab stop.

Typed Characters

When certain characters such as {, }, or : are typed, the line will be examined to see if it should be indented/outdented.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The JavaScriptSyntaxLanguage class automatically registers a JavaScriptIndentProvider with itself when it is created, so normally indent providers never need to be set on a JavaScript language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomJavaScriptIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomJavaScriptIndentProvider());
​language.RegisterIndentProvider(New CustomJavaScriptIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on JavaScriptSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The JavaScriptTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality
  • Opening Curly Braces on New Line

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The JavaScriptSyntaxLanguage class automatically registers a JavaScriptTextFormatter with itself when it is created, so normally text formatters never need to be set on a JavaScript language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomJavaScriptTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomJavaScriptTextFormatter());
​language.RegisterTextFormatter(New CustomJavaScriptTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on JavaScriptSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Opening Curly Braces on New Line

The JavaScriptTextFormatter.IsOpeningBraceOnNewLine property can be used to determine whether opening curly braces appear on a new line.

It defaults to false, but can be changed to true to cause opening curly braces to move to the next line.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

The JavaScript language has built-in automated IntelliPrompt completion list features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Completion List
  • Disabling Automated IntelliPrompt

Completion List

IntelliPrompt completion lists are used to present end users with a list of accessible members from the code editor's current caret location. The completion list is triggered by key events such as pressing Ctrl+Space.

The JavaScript completion list is relatively simplistic in its implementation. It will present a list of JavaScript keywords, along with identifiers that have been defined in the document. Note that the identifiers listed do not account for their scope within the document. As the end user types, the list is filtered down to only show matched items. Both acronym and shorthand item matchers are enabled.

The completion list features are implemented by the JavaScriptCompletionProvider class.

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the JavaScriptSyntaxLanguage that is created:

C#
VB
Copy
​var language = new JavaScriptSyntaxLanguage();

// Disable completion lists
language.UnregisterService<JavaScriptCompletionProvider>();
​Dim language = New JavaScriptSyntaxLanguage()

' Disable completion lists
language.UnregisterService(Of JavaScriptCompletionProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The advanced JSON syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from code outlining to syntax error reporting.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider

Features

The JSON language is packed with features, including:

  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.

Licensing

Even though the Web Languages Add-on is distributed and demoed with the WPF controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the JSON language from the Web Languages Add-on, implemented by the JsonSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The JSON language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

This topic covers how to get started using the JSON language from the Web Languages Add-on, implemented by the JsonSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and code outlining.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the JsonSyntaxLanguage
  • Use the JsonSyntaxLanguage
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new ThreadedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New ThreadedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the JsonSyntaxLanguage

The next step is to create an instance of the JsonSyntaxLanguage class.

This code creates a JsonSyntaxLanguage:

C#
VB
Copy
​var language = new JsonSyntaxLanguage();
​Dim language As New JsonSyntaxLanguage()

Use the JsonSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing JSON code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your JsonSyntaxLanguage instance among all the documents in your application that are editing JSON code. This saves on overall memory usage and reduces load times.

Assembly Requirements

The following list indicates the assemblies that are used with the JSON syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Wpf.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for WPF
ActiproSoftware.Text.LLParser.Wpf.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Wpf.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro WPF controls
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for WPF control
ActiproSoftware.Text.Addons.JavaScript.Wpf.dll | Yes | Actipro | Web Languages Add-on | Core text/parsing for the JavaScript and JSON languages
ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll | Yes | Actipro | Web Languages Add-on | SyntaxEditor for WPF advanced JavaScript and JSON syntax language implementations

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

The JSON language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The JsonIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope. For instance, pressing ENTER after a { will cause the next line to be indented by one tab stop.

Typed Characters

When certain characters such as {, }, [ or ] are typed, the line will be examined to see if it should be indented/outdented.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The JsonSyntaxLanguage class automatically registers a JsonIndentProvider with itself when it is created, so normally indent providers never need to be set on a JSON language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomJsonIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomJsonIndentProvider());
​language.RegisterIndentProvider(New CustomJsonIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on JsonSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The JsonTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality
  • Opening Braces on New Line

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The JsonSyntaxLanguage class automatically registers a JsonTextFormatter with itself when it is created, so normally text formatters never need to be set on a JSON language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomJsonTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomJsonTextFormatter());
​language.RegisterTextFormatter(New CustomJsonTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on JsonSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Opening Braces on New Line

The JsonTextFormatter.IsOpeningBraceOnNewLine property can be used to determine whether opening braces appear on a new line after a colon.

It defaults to false, but can be changed to true to cause opening braces to move to the next line after a colon.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

This topic contains these sections:

  • How Do I Get Started With XML Language?
  • Typing Is Slow
  • No IntelliPrompt Completion List

How Do I Get Started With XML Language?

The Getting Started topic walks through all the requirements for using the XML language. Be sure to follow all the steps in that topic so that the syntax language operates correctly.

Typing Is Slow

If you notice a lag when typing, it is likely due to an ambient parse request dispatcher not being set up. Each time text changes occur, such as while typing, a parse request is fired off for the parser to parse the document. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up an ambient parse request dispatcher for your application.

When no ambient parse request dispatcher has been configured for your application, the parsing will occur in the main UI thread, thus severely affecting typing performance, especially in larger documents.

See the Getting Started topic for more information on how to set up an ambient parse request dispatcher for your application.

No IntelliPrompt Completion List

The XML language supports automated IntelliPrompt completion lists and extended information in IntelliPrompt quick info as long as an XML schema has been properly loaded.

If you are not seeing these extended features working, make sure you have created a schema resolver, loaded schemas into it, and have registered it as a language service.

See the Getting Started topic for more information on how to load an XmlSchemaResolver and register it as a language service.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

SyntaxEditor has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to setup the SyntaxEditor.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • Task Pane Introduction
  • SyntaxEditor Task Pane
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

Task Pane Introduction

Whenever you select a SyntaxEditor control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

SyntaxEditor Task Pane

The SyntaxEditor task pane allows you to quickly configure many of the most common options, which are orgnaized into three categories.

Tip Tip
Several items include a blue information icon, which uses a tool-tip to provide more information about the associated item.

General

The general settings affect the behavior or feel of the control. Several options are available in the expandable sections at the bottom.

The General tab of the task pane for the SyntaxEditor

View

The general settings affect the view or look of the control. Several options are available in the expandable sections at the bottom.

The View tab of the task pane for the SyntaxEditor

Document

The general settings affect the document, or underlying data, of the control. Several options are available in the expandable sections at the bottom.

Note Note
When using the "Create new document" link, you must manually add xml:space="preserve" to the EditorDocument element, if setting the initial text/content. Addtionally, the text should be wrapped with a CDATA element to further preserve the whitespace.

The Document tab of the task pane for the SyntaxEditor

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to 2009.2 topic contains information on converting to 2009.2 from 2009.1.
  • The Converting to 2010.2 topic contains information on converting to 2010.2 from 2010.1.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from 2011.1.
  • The Converting to 2019.1 topic contains information on converting to 2019.1 from 2011.2 or later.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2009.2

The 2009.2 version introduced several breaking changes from 2009.1. Several are very minor and even the major breaking change area will likely not affect more than a couple lines of code.

The amount of work on your end needed to upgrade from 2009.1 to 2009.2 code should generally be very minimal.

This topic contains these sections:

  • Classification Mechanism Changed to Use New Tagging Mechanism
  • Syntax Language and Services Changes
  • Other Minor Changes

Classification Mechanism Changed to Use New Tagging Mechanism

In SyntaxEditor 2009.1 there were "classifier" features that worked similarly to the new tagging mechanism but were specifically for classification purposes. In 2009.2, the classification mechanism was changed to use the tagging mechanism since it is more generic and can be used for many other features too.

If you load your languages from language definition (.langdef) files then no changes are likely needed in your code. If you programmatically configure your language, based on code generated by the Language Designer application, open your language project there and regenerate code to have it work with the code updates.

If you programmatically configure your language via hand-written code you may have to switch this:

C#
VB
Copy
​language.RegisterClassifierFactory(new TokenClassifierFactory(typeof(MergableLexerClassifier)));
​language.RegisterClassifierFactory(New TokenClassifierFactory(GetType(MergableLexerClassifier)))
or this:
C#
VB
Copy
​language.RegisterService<ITokenClassifierFactory>(new TokenClassifierFactory(typeof(MergableLexerClassifier)));
​language.RegisterService(Of ITokenClassifierFactory)(New TokenClassifierFactory(GetType(MergableLexerClassifier)))
to this:
C#
VB
Copy
​language.RegisterService(new TokenTaggerProvider<TokenTagger>(typeof(TokenTagger)));
​language.RegisterService(New TokenTaggerProvider<TokenTagger>(GetType(TokenTagger)))

If your language uses a non-mergable lexer, then you will need to make a class that inherits TokenTagger and overrides its ClassifyToken method. This method maps an IToken to the IClassificationType it should use, and is similar to the logic in the VirtualizedTokenClassifierBase.ClassifyToken override you would have done in 2009.1. In this scenario you'd also specify your custom token tagger's class name in place of TokenTagger in the register service code sample above.

ActiproSoftware.Text.Classification Namespace Removed

Nearly all of the types related to classification are no longer needed, since the more generic tagging mechanism can be used in their place. The unnecessary types were removed along with the Classification namespace. Still several types were kept but moved up a level.

These types are now in the ActiproSoftware.Text namespace:

  • IClassificationType
  • IClassificationTypeRegistry
  • ClassificationTypes

This type are now in the ActiproSoftware.Text.Implementation namespace:

  • ClassificationType

Classifiers and Samples

All the functionality available before with classifiers is still available, just via tagging instead. The two classification QuickStarts have been updated to use the new logic.

Classifiers in 2009.1 map to token taggers in 2009.2. Classifier factories in 2009.1 map to token tagger providers in 2009.2.

Removed the ICodeDocument.Classifier Property

The Classifier property in 2009.1 used to store the token classifier that was installed for the document by the language. Since classifiers are now gone, this property has been removed. The new token tagger that is installed instead is stored in the document's Properties collection, but should not really ever need to be accessed by you.

Removed the SyntaxEditor.Classifiers Property

In 2009.1, the Classifiers property allowed you to install custom classifiers that would get applied to a document in a certain SyntaxEditor. Now that mulitple taggers can be used in 2009.2, custom classification tagger (objects implementing ITagger<IClassificationTag>) providers can be registered as language services. The tagger providers return taggers on-demand to SyntaxEditor.

Syntax Language and Services Changes

SyntaxLanguageDefinitionSerializer.LoadXX Changed to Return ISyntaxLanguage

The various load methods on SyntaxLanguageDefinitionSerializer used to return SyntaxLanguage but now return ISyntaxLanguage instead.

Removed Provider and Event Sink Service Helper Extension Methods

In 2009.1 there were some Get/Register/Unregister extension methods on the SyntaxLanguageExtensions class (currently in the Sample Browser's code) that wrapped the generic ISyntaxLanguage.RegisterService, etc. method calls with type-specific helpers. In 2009.2 these are no longer valid since multiple provider and event sink services may be registered on a language that have the same interface implementations, instead of only one being allowed. Therefore the helper extension methods for these items have been removed:

  • IActiveEditorViewChangeEventSink
  • ICompletionProvider
  • IEditorDocumentTextChangeEventSink
  • IEditorViewKeyInputEventSink
  • IEditorViewPointerInputEventSink
  • IEditorViewSelectionChangeEventSink
  • IEditorViewTextInputEventSink
  • IQuickInfoProvider
  • ITextViewLifecycleEventSink

Use the general RegisterService etc. methods instead of the extension methods for service types listed above.

ICompletionProvider and IQuickInfoProvider RequestSession Methods

The return value of the RequestSession method on the ICompletionProvider and IQuickInfoProvider interfaces has been changed to return a bool instead of being a void. The QuickInfoProviderBase class was also updated accordingly. Have your code return true if a session was opened; false if not.

ICompletionProvider and IQuickInfoProvider Inherit IOrderable

The ICompletionProvider and IQuickInfoProvider interfaces have been updated to inherit IOrderable. This means that any instances of them now need a Key and Orderings property. The CompletionProviderBase and QuickInfoProviderBase base classes provide this functionality.

The QuickInfoProviderBase constructor now requires the string Key to be specified.

Other Minor Changes

ICodeDocument.LanguageChanged Event Arguments

The ICodeDocument.LanguageChanged event has been changed to use the new SyntaxLanguageChangedEventArgs type.

ITextView.TextAreaLayout Event Arguments

The ITextView.TextAreaLayout event has been changed to use the new TextViewTextAreaLayoutEventArgs type.

ITextView.VisibleViewLines Returns New ITextViewLineCollection

The ITextView.VisibleViewLines property now returns the new ITextViewLineCollection type.

Renamed Margin Names Classes to Margin Keys For Consistency

  • EditorViewMarginNames renamed as EditorViewMarginKeys. PrinterViewMarginNames renamed as PrinterViewMarginKeys.

Changed IOrderable.After Property

To make IOrderable more flexible and allow for before and after specifications, its After property was changed to Orderings, which is a collection of new Ordering classes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2010.2

The 2010.2 version introduced several breaking changes from 2010.1.

This topic contains these sections:

  • Switch of Text Assemblies to Target .NET 3.5 SP1 or Later
  • Changed ParseError Namespace
  • Changed Several Events to Not Be Routed

Switch of Text Assemblies to Target .NET 3.5 SP1 or Later

WPF Studio 2010.2 switches all SyntaxEditor Text assemblies to target .NET 3.5 SP1 instead of .NET 2.0. We did this so that we can take advantage of newer features found in the .NET framework.

The Text assemblies do not have any dependencies on UI platforms such as WPF or Silverlight.

Assembly Name Changes

Note that this change also means that all Actipro Text assembly names have been updated since the assembly name indicates the minimum target framework version. The name changes include:

  • ActiproSoftware.Text.Addons.Antlr.Net20.dll became ActiproSoftware.Text.Addons.Antlr.Wpf.dll
  • ActiproSoftware.Text.Addons.DotNet.Net20.dll became ActiproSoftware.Text.Addons.DotNet.Wpf.dll
  • ActiproSoftware.Text.Addons.Xml.Net20.dll became ActiproSoftware.Text.Addons.Xml.Wpf.dll
  • ActiproSoftware.Text.Net20.dll became ActiproSoftware.Text.Wpf.dll

XAML Changes

Since some of assembly names have changed, you'll want to scan you XAML xmlns attributes for instances like this:

XAML
Copy
​xmlns:text="clr-namespace:ActiproSoftware.Text;assembly=ActiproSoftware.Text.Net20"

We recommend doing a solution-wide search for .Net20 or for the full assembly names like ActiproSoftware.Text.Net20 to make sure any instances are found.

In the case of the above example, it should be modified to:

XAML
Copy
​xmlns:text="clr-namespace:ActiproSoftware.Text;assembly=ActiproSoftware.Text.Wpf"

Changed ParseError Namespace

The ParseError was previously incorrectly located in the ActiproSoftware.Text.Parsing namespace and has been moved to its intended ActiproSoftware.Text.Parsing.Implementation namespace instead.

Changed Several Events to Not Be Routed

The IEditorView.HasFocusChanged, ITextView.Closed, and ITextView.MarginsDestroyed events have been updated to be "normal" .NET events instead of routed events. This change was made to be more consistent with other events on those types and increase speed.

This change should not affect your code unless you have implemented a custom margin or adornment manager, and even then not in all cases.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2019.1

Much of the SyntaxEditor product's internals were refactored in 2019.1 so that a common codebase could be shared among the WPF, UWP, and WinForms versions of the product. This enables the products to stay in sync more easily moving forward.

A number of new feature areas were added, described in the Sample Browser's Release History.

This documentation topic lists specifics on the breaking changes that were made and how to handle them.

This topic contains these sections:

  • New Feature Details
  • Highlighting Style Changes
  • Selection and Caret Changes
  • IntelliPrompt Changes
  • Adornments Changes
  • Vertical View Split Option Removed
  • IEditorView Scroll State Changes
  • Indicator Changes
  • View Line Changes
  • Selection Brush Property Changes
  • Searching Changes
  • Input Changes
  • Line Commenter Changes
  • Text Formatter Changes
  • DuplicateLine Edit Action Changed to Duplicate
  • ANTLR And Irony Add-ons Not Installed By Default
  • TextStylePreview and NavigableSymbolSelector Namespace Changed
  • Other Miscellaneous Changes

New Feature Details

Many new features were added in the 2019.1 version. Please see the "Release History" in the Sample Browser for a list of all new features.

Highlighting Style Changes

To simplify the highlighting style API and make it more cross-platform compatible, brushes have been replaced by color values. Some light refactoring of naming was made for better compatibility with XAML terminology.

Brushes Replaced by Colors

The IHighlightingStyle.BorderBrush, StrikethroughBrush, and UnderlineBrush properties were renamed to IHighlightingStyle.BorderColor, StrikethroughColor, and UnderlineColor respectively. The Brush property values were replaced by Color.

Highlighting Style Viewer QuickStart Updated

The "Highlighting Style Viewer" QuickStart has been updated to use controls for editing Color values instead of the previously-used Brush values in highlighting styles. Please reference the updated QuickStart when migrating any similar dialogs in your own apps.

Enumeration Changes

The new cross-platform rendering framework used by SyntaxEditor has LineKind and TextLineWeight enumerations, both defined in the Shared Library. The HighlightingStyleLineStyle enumeration was replaced with LineKind. Please use the LineKind.None value in scenarios where HighlightingStyleLineStyle.Default was previously used. Likewise, the HighlightingStyleLineWeight enumeration was replaced with TextLineWeight.

The IHighlightingStyle.BorderStyle, StrikethroughStyle, and UnderlineStyle properties were renamed to IHighlightingStyle.BorderKind, StrikethroughKind, and UnderlineKind respectively and updated to use the LineKind property.

The HighlightingStyleBorderCornerStyle enumeration was renamed to HighlightingStyleBorderCornerKind, and the SinglePixelRounded value was renamed to Rounded. The IHighlightingStyle.BorderCornerStyle property was renamed to IHighlightingStyle.BorderCornerKind.

Selection and Caret Changes

The caret is always at the "end" of an editor view selection. Prior SyntaxEditor versions had a single selection, but the 2019.1 version allows multiple selections.

Caret Object Removed

The SyntaxEditor.Caret property has been removed and caret location-related information is now available via the selection API.

The SyntaxEditor.Caret.CharacterColumn, DisplayCharacterColumn, Offset, and Position properties have moved to the IEditorViewSelection.CaretCharacterColumn, the CaretDisplayCharacterColumn, the CaretOffset, and the CaretPosition properties respectively, accessible via editor.ActiveView.Selection.

The properties above return the primary selection/caret's information. Multiple selections can be enumerated via the view's IEditorViewSelection.Ranges collection property. There is one entry for each selection within that collection, and the entries give the position ranges of the selections. The "end" position is where the caret is for each selection.

The SyntaxEditor.Caret.BlinkInterval, InsertStyle, InsertWidth, OverwriteStyle, and OverwriteWidth properties have moved to the SyntaxEditor.CaretBlinkInterval, the CaretInsertKind, the CaretInsertWidth, the CaretOverwriteKind, and the CaretOverwriteWidth properties respectively,

The CaretStyle enumeration was renamed to CaretKind for better compatibility with XAML terminology.

Selection Changes for Multiple Selections

The IEditorViewSelection.PreferredHorizontalLocation property was changed to a IEditorViewSelection.GetPreferredCaretHorizontalLocations method. The IEditorViewSelection.SelectRange method overloads that take an "updatePreferredHorizontalLocation" parameter have been removed since this information is pulled on-demand now based on IEditorViewSelection.CreateBatch method options.

The IEditorViewSelection.GetCharacterIndexRanges method was removed. Use the IEditorView.GetCharacterIndexRanges method instead, which has had its "allowWholeLines" parameter removed.

Selection Changes for Batches

A new IEditorViewSelection.CreateBatch method has been added that allows for passing options and grouping multiple selection changes into a single transaction.

The IEditorView.ScrollToCaretOnSelectionChange property was removed. A batch option for preventing scroll-to-caret can be specified when creating a batch.

The new IEditorViewSelection.CreateBatch method can wrap multiple selection changes to ensure that only one selection change event occurs, as the outermost batch is completed. Related to this, the old IEditorView.AreSelectionEventsSuspended, ResumeSelectionEvents, and SuspendSelectionEvents members have been removed.

Text Change Selections

The ITextChange.SelectionPositionRange property was replaced with ITextChange.PreSelectionPositionRanges and PostSelectionPositionRanges properties that store the selections for the active view before/after the text change is applied.

The IUndoableTextChange.SelectionPositionRange and PostSelectionPositionRange properties were replaced with IUndoableTextChange.PreSelectionPositionRanges and PostSelectionPositionRanges properties that store the selections for the active view before/after the text change is applied.

The UndoHistory.ApplySelectionPositionRange method was removed and can be replaced by setting the ITextChange.PostSelectionPositionRanges property directly.

Event Arguments

The EditorViewSelectionEventArgs.LastCaretPosition property was renamed to EditorViewSelectionEventArgs.PreviousCaretPosition.

IntelliPrompt Changes

For improving the clarity of the property result, the CommonImage enumeration was renamed to CommonImageKind, and the CommonImageSourceProvider.ImageType property was renamed to CommonImageSourceProvider.ImageKind.

The QuickInfoProviderBase.CanTrackMouseInput property was renamed to QuickInfoProviderBase.CanTrackPointerInput.

The ICompletionItemCollection interface was updated to implement INotifyCollectionChanged.

The ICompletionFilter.Filter method and the CompletionFilterPredicate delegate were updated to use a new CompletionFilterResult enumeration so that the intended result is clearer.

Quick Info and Parameter Info Theme Support

Quick info and parameter info tips now render their backgrounds based on the current theme. In particular, when the application is in a Metro Dark theme, the info tips will now have a dark background. This allows images on the info tips to render better. New AssetResourceKeys.IntelliPromptToolTip* brush resources are used for the theme-oriented info tips.

To support this change, it is recommended that foreground colors used in Content Providers are based on the current theme in the SyntaxEditor control (assuming SyntaxEditor is rendering in a theme similar to the application theme), or at least are set to render well in the current application theme.

The HtmlContentProvider class has several static properties for common foreground colors such as neutral, comment, keyword, and type names. These properties access the related classification type entries in the ambient highlighting style registry and return the foreground color.

Adornments Changes

Change Reasons

A new AdornmentChangeReason enumeration has been added, allowing add/remove adornment calls to indicate the reason behind the change.

The IAdornmentLayer.AddAdornment, RemoveAdornment, RemoveAdornments, and RemoveAllAdornments methods have all been updated with a reason parameter.

The IntraTextAdornmentManagerBase`2 and DecorationAdornmentManagerBase`2's AddAdornment methods were updated with a reason parameter.

Adornment View Line Associations

The IAdornmentLayer.AddAdornment overload that accepts a snapshot range has been updated with a new ITextViewLine parameter that can be specified if the adornment is associated with a certain view line. The value flows into the new IAdornment.ViewLine property.

Vertical View Split Option Removed

With the advent of advanced tabbed docking windows, we simplified our internal structures by removing support for vertical splits. Horizontal splits are still supported.

The EditorViewPlacement enumeration now only has Lower and Upper values. The SyntaxEditor.CanSplitVertically, HasVerticalSplit, and VerticalSplitPercentage properties were removed.

IEditorView Scroll State Changes

The IEditorView.FirstVisibleX and FirstVisiblePosition properties were removed and replaced with a new read-only ITextView.ScrollState property that returns a TextViewScrollState object. To set the scroll state, use the new IEditorViewScroller.ScrollTo method, accessible via editor.ActiveView.Scroller.ScrollTo.

Indicator Changes

The IIndicatorTag interface has been updated to use the fast new rendering mechanism for drawing glyphs instead of making UI elements. Accordingly the CreateGlyph method has been removed and replaced with a DrawGlyph method.

See the "CustomIndicatorTag" class in the "Indicators - Custom" QuickStart for an example implementation of the DrawGlyph method.

View Line Changes

IEditorViewLine and IPrinterViewLine Interfaces Merged Into ITextViewLine

The former IEditorViewLine and IPrinterViewLine interfaces have been merged into their base ITextViewLine interface.

The same is true of the IEditorViewLineCollection and IPrinterViewLineCollection interfaces being merged into their base ITextViewLineCollection interface.

Bounds and Size Properties Changed

For better clarity, the ITextViewLine.Bounds and Size properties have been updated to include the height of the top/bottom intra-line adornment margins.

New TextBounds and TextSize properties were added, with the former return values of the Bounds and Size properties that exclude adornment margin space.

VisibleStartPosition Property Added

A new ITextViewLine.VisibleStartPosition property was added that returns the first visible position on the view line. Replace any prior ITextViewLine.DisplayLineNumber property call with the new ITextViewLine.VisibleStartPosition.DisplayLine property.

Selection Brush Property Changes

The SyntaxEditor.SelectionBackgroundActive and SelectionBackgroundInactive properties were renamed to SyntaxEditor.SelectedTextBackground and InactiveSelectedTextBackground respectively.

The SyntaxEditor.SelectionBorderActiveBrush and SelectionBorderInactiveBrush properties were removed since selection borders are no longer supported.

Searching Changes

The SyntaxEditor.IsIncrementalSearchResultHighlightingEnabled property was renamed to SyntaxEditor.IsSearchResultHighlightingEnabled.

The EditorSearchView.IsModeToolBarVisible property was renamed to CanToggleReplace, and the Mode property was renamed to IsReplaceVisible. The boolean property is easier to bind with. The EditorSearchMode enumeration was removed.

Input Changes

The IEditorViewMouseInputEventSink interface was renamed to IEditorViewPointerInputEventSink, and the interface members were updated to use a more generic naming convention along with cross-platform compatible event arguments.

The IEditorView.StartMouseSelection method was renamed to IEditorView.StartPointerSelection and its parameter type was changed.

The SyntaxEditor.CanMoveCaretOnMouseRightClick property was renamed to SyntaxEditor.CanMoveCaretForSecondaryPointerButton.

Code block selection features (available in some languages) changed keyboard shortcuts from Ctrl++ to Ctrl+Shift++ for expansion, and Ctrl+- to Ctrl+Shift+- for contraction.

Line Commenter Changes

The ILineCommenter.Comment and Uncomment methods were updated to have snapshot and ITextPositionRangeCollection parameters instead of a single TextSnapshotRange. These changes allow line commenters to facilitate multiple selections. The built-in line commenter implementations were updated to support multiple selections.

Note Note
An ITextPositionRangeCollection can be created via the static TextPositionRange.CreateCollection method overloads.

Text Formatter Changes

The ITextFormatter.Format method was updated to have snapshot, ITextPositionRangeCollection, and TextFormatMode (All or Ranges options) parameters instead of a single TextSnapshotRange to facilitate multiple selections. The built-in text formatter implementations were updated to support multiple selections.

See the "Getting Started #13" QuickStart for an example of a text formatter using the newer API.

Note Note
An ITextPositionRangeCollection can be created via the static TextPositionRange.CreateCollection method overloads.

This code shows general logic that can be used for an ITextFormatter.Format method. It calls into a FormatCore method that is where you'd implement the actual text modification logic for the specified snapshot range.

C#
VB
Copy
​public void Format(ITextSnapshot snapshot, ITextPositionRangeCollection selectionPositionRanges, TextFormatMode mode) {
    if (snapshot == null)
        throw new ArgumentNullException("snapshot");
    if ((selectionPositionRanges == null) || (selectionPositionRanges.Count == 0))
        throw new ArgumentNullException("selectionPositionRanges");

    // Changes must occur sequentially so that we can use unmodified offsets while looping over the document
    var options = new TextChangeOptions();
    options.OffsetDelta = TextChangeOffsetDelta.SequentialOnly;
    options.RetainSelection = true;
    var change = snapshot.Document.CreateTextChange(TextChangeTypes.AutoFormat, options);

    // Get the snapshot ranges to format
    var snapshotRanges = (mode == TextFormatMode.All ?
        new TextSnapshotRange[] { snapshot.SnapshotRange } :
        selectionPositionRanges.Select(pr => new TextSnapshotRange(snapshot, snapshot.PositionRangeToTextRange(pr))).ToArray()
        );

    // Loop through the snapshot ranges
    foreach (var snapshotRange in snapshotRanges)
        this.FormatCore(change, snapshotRange);

    // Apply the changes
    if (change.Operations.Count > 0)
        change.Apply();
}
​Public Sub Format(ByVal snapshot As ITextSnapshot, ByVal selectionPositionRanges As ITextPositionRangeCollection, Optional ByVal mode As TextFormatMode) Implements ITextFormatter.Format
    If snapshot Is Nothing Then
        Throw New ArgumentNullException("snapshot")
    End If
    If (selectionPositionRanges Is Nothing) OrElse (selectionPositionRanges.Count = 0) Then
        Throw New ArgumentNullException("selectionPositionRanges")
    End If

    ' Changes must occur sequentially so that we can use unmodified offsets while looping over the document
    Dim options = New TextChangeOptions()
    options.OffsetDelta = TextChangeOffsetDelta.SequentialOnly
    options.RetainSelection = True
    Dim change = snapshot.Document.CreateTextChange(TextChangeTypes.AutoFormat, options)

    ' Get the snapshot ranges to format
    Dim snapshotRanges = (If(mode = TextFormatMode.All, New TextSnapshotRange() {snapshot.SnapshotRange}, selectionPositionRanges.Select(Function(pr) New TextSnapshotRange(snapshot, snapshot.PositionRangeToTextRange(pr))).ToArray()))

    ' Loop through the snapshot ranges
    For Each snapshotRange In snapshotRanges
        Me.FormatCore(change, snapshotRange)
    Next snapshotRange

    ' Apply the changes
    If change.Operations.Count > 0 Then
        change.Apply()
    End If
End Sub

New methods make it easy to call the current syntax language's text formatter, if one is available.

C#
VB
Copy
​editor.ActiveView.TextChangeActions.FormatDocument();
editor.ActiveView.TextChangeActions.FormatSelection();
​editor.ActiveView.TextChangeActions.FormatDocument()
editor.ActiveView.TextChangeActions.FormatSelection()

DuplicateLine Edit Action Changed to Duplicate

The old DuplicateLine edit action has been updated to work with selected text and has been renamed to Duplicate. If there is no selection, the entire document line will be duplicated. If there is a selection, it will be inserted and selected immediately after the previous selection.

The TextChangeTypes.DuplicateLine property was renamed to TextChangeTypes.Duplicate.

The EditorCommands.DuplicateLine property was renamed to EditorCommands.Duplicate.

The DuplicateLineAction class was renamed to DuplicateAction and the corresponding IEditorViewTextChangeActions.DuplicateLine method was renamed to IEditorViewTextChangeActions.Duplicate.

ANTLR And Irony Add-ons Not Installed By Default

The optional add-ons that integrate ANTLR v3 And Irony parsers with SyntaxEditor are no longer installed by default. The ANTLR Add-on and Irony Add-on topics give more detail on the options to pick during WPF Controls setup to install those.

TextStylePreview and NavigableSymbolSelector Namespace Changed

The TextStylePreview and NavigableSymbolSelector controls have been moved from the SyntaxEditor.Primitives namespace up to primary SyntaxEditor namespace where the SyntaxEditor control is located.

Other Miscellaneous Changes

The SyntaxEditor.CharacterWidth, LineHeight, and SpaceWidth properties were replaced with ITextView.DefaultCharacterWidth, DefaultLineHeight, and DefaultSpaceWidth properties respectively.

The SyntaxEditor.IsOverwriteModeActiveChanged event arguments were updated.

The SyntaxEditor.CanScrollPastDocumentEnd property was removed since all views now require scroll past document end due to lines supporting variable heights via font options and intra-line adornments.

The SyntaxEditor.IsMouseWheelZoomEnabled property was removed in favor of the new ZoomModesAllowed property.

The SyntaxEditor.LineNumberMarginFontSize property's default was changed to 0. When 0, it will use the same font size as SyntaxEditor.FontSize.

The SyntaxEditor.ZoomLevelIndicatorTemplate property and default indicator were removed since zoom level is usually indicated in external UI.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Themes is a complete framework for managing run-time selection of the themes of Actipro and native WPF controls, but can also be used for your own custom controls as well. Not only can you change an application-wide theme with a single line of code, you can make custom themes, you can reuse theme brushes, and can tint all or part of any theme towards a certain color. All of this is possible with Actipro's themes framework.

Also included are styles and templates for all native WPF controls that have been given a more modernized appearance, and mesh perfectly with Actipro's custom control products. Like the application-wide theme, this can be configured with a single line of code.

Note Note
Actipro Themes is built right into the Actipro Shared Library, which means it may be freely used by any developer who has a license for one of our WPF control products.

Features

General Features

  • Over 25 professionally-designed themes, including all system themes, Office themes, and Metro themes.
  • An entire themes management framework that makes it simple to register themes and swap them in and out at run-time.
  • Facilities for tinting sets of brushes and pens in resource dictionaries, or entire themes, towards any color.
  • Consolidated and centralized collection of assets, such as brushes, that are used across all our WPF products.
  • Easily build a completely custom theme or tweak individual aspects of existing themes without having re-style or re-template controls.
  • Define custom resources that will be loaded based on the current theme.
  • Quickly integrate custom controls into the theme management framework.
  • Reusable styles/templates for common scenarios such as embedded buttons and glyphs.
  • A WindowChrome class that supports rendering any normal WPF window with a custom chrome that matches the current theme.

Native Controls Features

  • Enhanced and integrated styles/templates for native WPF controls, such as Button and CheckBox.
  • Styles can be used explicitly on individual controls or applied across your entire application implicitly with a single setting.
  • Leverages the same assets, such as brushes, as our other WPF products which means they can be tinted or switched dynamically.

Code and Requirements

  • Includes detailed documentation and a sample project that demos nearly every feature.
  • Written in 100% pure C# and is based on the Windows Presentation Foundation framework.
  • Requires the .NET 4.0 or later run-time framework.
  • Full XAML support and XBAP compatibility.
  • Visual Studio and/or Expression Blend are recommended development tools for this product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Leveraging Actipro Themes in your applications is as simple as setting a few properties.

Ribbon in the MetroLightRoyal theme

This topic contains these sections:

  • Pre-Built Themes and Descriptions
  • Add Assembly References
  • Setting an Application-Wide Theme
  • Windows System Theme Mappings
  • Setting a Theme on a Specific Control Hierarchy
  • Enabling Application-Wide Native Theme Support
  • Enabling Native Theme Support on a Specific Control Hierarchy
  • Optimization
  • Consolidating Theme Settings
  • Using the High Contrast Theme
  • Applying Theme-Based Custom Chrome on Any Window

Pre-Built Themes and Descriptions

Actipro Themes includes these pre-built themes:

  • MetroLight - System default theme for Windows 10 and 8.x
  • MetroLightBlue - Office-like blue accented version of MetroLight, similar to Outlook's Colorful theme
  • MetroLightCyan - Office-like cyan accented version of MetroLight, similar to Publisher's Colorful theme
  • MetroLightGreen - Office-like green accented version of MetroLight, similar to Excel's Colorful theme
  • MetroLightOrange - Office-like orange accented version of MetroLight, similar to PowerPoint's Colorful theme
  • MetroLightPurple - Office-like purple accented version of MetroLight, similar to OneNote's Colorful theme
  • MetroLightRed - Office-like red accented version of MetroLight, similar to Access' Colorful theme
  • MetroLightRoyal - Office-like royal accented version of MetroLight, similar to Word's Colorful theme
  • MetroWhite - Similar to MetroLight, except has a white title bar area
  • MetroWhiteBlue - Office-like blue accented version of MetroWhite, similar to Outlook's White theme
  • MetroWhiteCyan - Office-like cyan accented version of MetroWhite, similar to Publisher's White theme
  • MetroWhiteGreen - Office-like green accented version of MetroWhite, similar to Excel's White theme
  • MetroWhiteOrange - Office-like orange accented version of MetroWhite, similar to PowerPoint's White theme
  • MetroWhitePurple - Office-like purple accented version of MetroWhite, similar to OneNote's White theme
  • MetroWhiteRed - Office-like red accented version of MetroWhite, similar to Access' White theme
  • MetroWhiteRoyal - Office-like royal accented version of MetroWhite, similar to Word's White theme
  • MetroDark - A very dark variation of MetroLight, similar to the Visual Studio dark theme
  • AeroNormalColor - System default theme for Windows 7 and Vista
  • Classic - System default theme for Windows XP or earlier, and classic system themes
  • OfficeBlack * - Office 2010-like black theme
  • OfficeBlue * - Office 2010-like blue theme
  • OfficeSilver * - Office 2010-like silver theme
  • LunaNormalColor ** - XP-like blue theme
  • LunaHomestead ** - XP-like green theme
  • LunaMetallic ** - XP-like silver theme
  • RoyaleNormalColor ** - XP-like royale theme

* These theme render like Office 2010's themes and require the ActiproSoftware.Themes.Office.Wpf.dll assembly, along with special registration as described below.

** These theme render like Window XP's themes and require the ActiproSoftware.Themes.Luna.Wpf.dll assembly, along with special registration as described below.

The Office-like themes that feature accent colors match the accent colors used in the various Office applications. For instance, Word has a royal blue accent and MetroLightRoyal (similar to Office's Colorful theme) or MetroWhiteRoyal (similar to Office's White theme) will match it. PowerPoint has an orange accent and MetroLightOrange (similar to Office's Colorful theme) or MetroWhiteOrange (similar to Office's White theme) will match it.

Add Assembly References

To get started, add a reference to the ActiproSoftware.Shared.Wpf.dll assembly, which should have been installed in the GAC during the control installation process. However it also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Office Theme Registration

If you'd like to leverage the three supported Office 2010-like themes, you'll need to add a reference to the ActiproSoftware.Themes.Office.Wpf.dll assembly. Only add this reference if these older-style themes are required for your application. Once the reference has been added, the Office theme catalog must be registered with the theme manager:

C#
VB
Copy
​ThemesOfficeThemeCatalogRegistrar.Register();
​ThemesOfficeThemeCatalogRegistrar.Register()

Note Note
The Office themes in this assembly are similar to the Office 2010 themes. For support of themes similar to newer Office versions, use the Metro accented themes instead (see above).

Available Office 2010-like theme names include:

  • OfficeBlack
  • OfficeBlue
  • OfficeSilver

Luna Theme Registration

If you'd like to leverage the four supported Luna-like themes, you'll need to add a reference to the ActiproSoftware.Themes.Luna.Wpf.dll assembly. Only add this reference if these older-style themes are required for your application. Once the reference has been added, the Luna theme catalog must be registered with the theme manager:

C#
VB
Copy
​ThemesLunaThemeCatalogRegistrar.Register();
​ThemesLunaThemeCatalogRegistrar.Register()

Note Note
The Luna themes in this assembly are similar to the Windows XP system themes, but are no longer directly included in the Shared Library because Windows XP is past its Microsoft-supported lifetime. If the registration above is not made, apps run on Windows XP will default to Classic theme.

Available Luna-like theme names include:

  • LunaNormalColor
  • LunaHomestead
  • LunaMetallic
  • RoyaleNormalColor

Setting an Application-Wide Theme

The application-wide theme can be changed by setting the ThemeManager.CurrentTheme property to the name of a registered theme. By default, no theme will be set and controls will use their normal WPF theme loading behavior based on system appearance settings.

To change the application-wide theme, set the CurrentTheme to the theme desired name. When you do so, any themes that have been registered with that name will be loaded.

The list of built-in non-accented themes are defined in the ThemeName enumeration, but additional custom themes can be registered and used as well.

This sample code shows how to make the application use the the Aero theme:

C#
VB
Copy
​ThemeManager.CurrentTheme = ThemeName.AeroNormalColor.ToString();
​ThemeManager.CurrentTheme = ThemeName.AeroNormalColor.ToString()

Windows System Theme Mappings

This list indicates how various systems map to Actipro themes defined in the Shared Library:

  • Windows 10 => MetroLight
  • Windows 8.x => MetroLight
  • Windows 7 => AeroNormalColor
  • Windows Vista => AeroNormalColor
  • Windows XP or earlier => Classic
  • Any Windows system in Classic theme => Classic

Setting a Theme on a Specific Control Hierarchy

Themes can also be loaded within a specified control hierarchy. The ThemeManager.ThemeProperty attached property can be assigned to any DependencyObject. It functions the same way that the CurrentTheme property does, except that the themes are applied to that control and its children instead of to the entire application.

Note Note
It is not generally recommended to use this feature since it will increase memory usage. Applications typically should only ever need to set the ThemeManager.CurrentTheme property.

This sample code shows how to make a UserControl named myUserControl use the the Office blue theme:

C#
VB
Copy
​ThemeManager.SetTheme(myUserControl, ThemeName.OfficeBlue.ToString());
​ThemeManager.SetTheme(myUserControl, ThemeName.OfficeBlue.ToString())

There also is a ThemeManager.DesignModeThemeProperty attached property that works the same as above however only affects design-mode and not run-time. This is very useful for when developing an application and testing themes in the designer because if you forget to remove the attached property setting, no problem. It won't affect run-time in any way like the ThemeManager.ThemeProperty property would.

Enabling Application-Wide Native Theme Support

By default, the native WPF controls will not be implicitly themed. To enable this behavior for your application, the ThemeManager.AreNativeThemesEnabled must be set to true. This ensures that your entire application consisting of Actipro and native WPF controls renders with a similar professional appearance.

This sample code shows how to enable native WPF control theming:

C#
VB
Copy
​ThemeManager.AreNativeThemesEnabled = true;
​ThemeManager.AreNativeThemesEnabled = True

Enabling Native Theme Support on a Specific Control Hierarchy

Like the current theme, native theme suppoort can be enabled on a specified control hierarchy. The ThemeManager.AreNativeThemesEnabledProperty attached property can be assigned to any DependencyObject.

Note Note
It is not generally recommended to use this feature since it will increase memory usage. Applications typically should only ever need to set the ThemeManager.AreNativeThemesEnabled property.

This sample code shows how to enable native theme support on a UserControl named myUserControl:

C#
VB
Copy
​ThemeManager.SetAreNativeThemesEnabled(myUserControl, true);
​ThemeManager.SetAreNativeThemesEnabled(myUserControl, True)

There also is a ThemeManager.DesignModeAreNativeThemesEnabledProperty attached property that works the same as above however only affects design-mode and not run-time. Again, this is useful when designing your application, as it will be ignored during runtime.

Optimization

Theme Catalog Registrations

Each Actipro control library that has themed controls has a special theme catalog registrar class in the Themes namespace. When a themed control from a control library is first used in your app, it will check to see if the theme catalog has been registered yet. If not, it will register itself. This causes the Actipro themes of all controls to be reapplied, which could lead to templates being reapplied. Normally this is not much of an issue, but in some cases with MVVM-oriented apps, it could trigger bindings to be re-evaluated.

If that causes problems, the theme catalogs for Actipro control libraries you use can be registered upfront in your application startup code. For instance, if your app only uses our Docking/MDI control library, you could add these two calls in your application startup:

C#
VB
Copy
​SharedThemeCatalogRegistrar.Register();
DockingThemeCatalogRegistrar.Register();
​SharedThemeCatalogRegistrar.Register()
DockingThemeCatalogRegistrar.Register()

These effectively ensure that the theme catalogs for the Shared Library and Docking/MDI are pre-registered and won't trigger any theme/template updates later on when controls from those libraries are first used. The only downside to doing this is that calling those Register methods will fully load the related control library, and will add that assembly load time to your application startup time. If your application always uses the controls in the main window immediately anyhow, it is recommended to do this.

Application StartupUri vs. Programmatic Window Show

When using Actipro themes, using the Application.StartupUri in the application's XAML is the recommended way to open your main window. Our themes get applied via a Dispatcher.BeginInvoke and thus if you created your main window in code and immediately showed it within your application startup, the templates for Actipro controls will get applied a second time after the BeginInvoke call applies the themes. If you do need to show your main window via code, you could Dispatcher.BeginInvoke the show code as well to work around this issue. Otherwise, using Application.StartupUri will take care of that for you.

Consolidating Theme Settings

Theme settings should generally be configured when the application is starting. In addition, they can be consolidated and applied as a single change.

This sample code shows how to change several theme settings as a single unit and ensures the application renders in a green Metro accented theme, similar to Excel.

C#
VB
Copy
​public partial class App : Application {

    protected override void OnStartup(StartupEventArgs e) {
        ThemeManager.BeginUpdate();
        try {
            // The Office 2010 and Luna themes are in separate assemblies and must be registered if you will use them in the application
            // ThemesOfficeThemeCatalogRegistrar.Register();
            // ThemesLunaThemeCatalogRegistrar.Register();

            // Use the Actipro styles for native WPF controls that look great with Actipro's control products
            ThemeManager.AreNativeThemesEnabled = true;

            // Always force a Metro accented green theme (similar to Excel)
            ThemeManager.CurrentTheme = "MetroLightGreen";
        }
        finally {
            ThemeManager.EndUpdate();
        }

        // ...

        // Call the base method
        base.OnStartup(e);
    }

}
​Partial Public Class App
    Inherits Application

    Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
        ThemeManager.BeginUpdate()
        Try
            ' The Office 2010 and Luna themes are in separate assemblies and must be registered if you will use them in the application
            ' ThemesOfficeThemeCatalogRegistrar.Register()
            ' ThemesLunaThemeCatalogRegistrar.Register()

            ' Use the Actipro styles for native WPF controls that look great with Actipro's control products
            ThemeManager.AreNativeThemesEnabled = True

            ' Always force a Metro accented green theme (similar to Excel)
            ThemeManager.CurrentTheme = "MetroLightGreen"
        Finally
            ThemeManager.EndUpdate()
        End Try

        ' Call the base method
        MyBase.OnStartup(e)
    End Sub

End Class

Using the High Contrast Theme

The HighContrast theme will not be automatically loaded by WPF, this is something that must be done manually. WPF does provide the SystemParameters.HighContrast static property to indicate whether the system is currently running with a high contrast theme. This flag can be used to load the appropriate theme as needed during applications startup.

This sample code shows how to enable native theme support on a UserControl named myUserControl:

C#
VB
Copy
​if (SystemParameters.HighContrast)
    ThemeManager.CurrentTheme = ThemeName.HighContrast.ToString();
​If (SystemParameters.HighContrast) Then
    ThemeManager.CurrentTheme = ThemeName.HighContrast.ToString()
End If

Applying Theme-Based Custom Chrome on Any Window

Actipro Themes includes a special WindowChrome class that is capable of rendering any WPF Window in a custom chrome that matches the current theme.

See the Window Chrome topic for more information on how it works and how to apply it.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Architecture

Actipro Themes contains a complete framework for managing run-time selection of the themes of both Actipro and native controls, but can also be used for your own custom controls as well.

Not only can you change an application-wide theme with a single line of code, you can make custom themes for both Actipro's and your own controls, you can reuse theme assets, and can tint all or part of any theme towards a certain color. All of this is possible with Actipro's themes framework.

This topic contains these sections:

  • What are Themes?
  • An Introduction to How WPF Themes Work (System-Based Switching)
  • Theme Catalogs
  • Theme Folders/Files

What are Themes?

Themes are resource dictionaries that define styles and templates for a group of controls. Each "theme" has its own visual appearance that it creates. For instance, there are numerous themes defined for NavigationBar, anything from an Office blue theme to a Windows "classic" theme.

Some resource dictionaries may be used to provide the styles and templates for controls, while others may simply define assets, such as brushes and pens. Still others may tie those combinations together to provide a complete theme implementation.

If you choose to do nothing with ThemeManager, many Actipro controls will use default WPF behavior of switching themes based on Windows system settings. However the use of the ThemeManager allows you to specify a particular theme to use and override the defaults, as explained below.

An Introduction to How WPF Themes Work (System-Based Switching)

There are many resources on the web describing how WPF's themes system works but here is a brief overview. You can optionally define a number of XAML resource dictionary files in a Themes folder off of your project root. Special filenames include:

  • Generic.xaml - The default resources that are always loaded but can be overridden by other ones below
  • Classic.xaml - "Classic" Windows 9x/2000 look
  • Luna.NormalColor.xaml - Windows XP default blue theme
  • Luna.Homestead.xaml - Windows XP olive green theme
  • Luna.Metallic.xaml - Windows XP silver theme
  • Royale.NormalColor.xaml - Windows XP Media Center Edition theme
  • Aero.NormalColor.xaml - Windows Vista/7 default theme
  • Aero2.NormalColor.xaml - Windows 8.x/10 default theme
  • AeroLite.NormalColor.xaml - Windows Server 2012 default theme

Basically if the user is running Windows XP with the olive green theme active, the Luna.Homestead.xaml file, if found, will be loaded so that anything in the application can use its resources (styles, brushes, etc.). These resources are loaded like this on demand, when WPF encounters the first control or ComponentResourceKey lookup corresponding to the given assembly. Also note that the System.Windows.ThemeInfoAttribute must be assigned to your assembly context indicating that themed-resources are in the assembly. See the MSDN for documentation on this attribute.

Now those are the basics of the built-in features of WPF. Let's get more advanced and start to use Actipro's enhancements which let you dynamically switch to specific themes and make other custom themes.

Theme Catalogs

Theme catalogs are used to indicate what resource dictionaries should be loaded for any given theme. There are two types of theme catalogs: custom and system. System theme catalogs are by custom controls, whose default styles are loaded by WPF, but still want to support dynamic theme changing. All other types of theme catalogs are considered custom, as they are not implicilty tied to the WPF system theme architecture.

The theme catalogs contains zero or more resource dictionary references, which map a resource dictionary to one or more themes by name. When the current theme is changed, the theme manager will then query each registered theme catalog to find the resource dictionaries that must be loaded for the given theme.

These references are represented by instances of ThemedResourceDictionaryReference, which include a Uri to the XAML file for the ResourceDictionary and a list of associated theme names. Therefore, a single reference can indicate a single XAML file should be loaded for multiple themes.

Registration

Theme catalogs can be manually registered using the ThemeManager.RegisterThemeCatalog method. They can also be unregistered using the ThemeManager.UnregisterThemeCatalog method. A key can be used to uniquely identify a theme catalog during registration, so it can be more easily removed later.

Custom registrars, which derive from ThemeCatalogRegistrarBase`1, can be used to automatically register a system theme catalog with the theme manager when WPF loads the system themes for an assembly.

To accomplish this, a custom ThemeCatalogRegistrarBase`1 is created that passes the desired theme catalog type as the type parameter. This registrar can then be included in the XAML files loaded by WPF and it will automatically register the theme catalog when loaded.

Note Note
While the Actipro control libraries that contain themed controls will automatically register their theme catalog the first time a themed control is instantiated for use, it can be better to register the catalogs upfront in the application startup code. The tradeoff is that registering a theme catalog at app startup will force that assembly to load immediately, and will incur the time cost of loading the assembly, but will prevent templates from being reapplied later during app usage when a themed control from a control library is first used. The Getting Started topic discusses this in further detail in its optimization section.

Theme Folders/Files

WPF expects any theme-related resource dictionaries to be located in the Themes folder in root of your project, as described in the section earlier. Extending this concept, Actipro has built a standard for organizing theme-related resource dictionaries so that they can easily be leveraged both by WPF's theme framework, as well as our theme manager.

The following sections will start with the lowest level and work up.

Assets and Styles Folders

The Themes\Includes\Assets and Themes\Includes\Styles folders can contain the various assets, such as brushes, and styles/templates in individual files. For example, if we have a control named CustomControl, we can create a CustomControl.xaml file in the Styles folder. This file would contain the Style and ControlTemplate for the control, as well as any supporting styles/templates.

Note Note
In many cases, the Assets folder is not needed as our common pool of assets can be leveraged.

In most cases a single file is sufficent for theming a control, but there are times were different styles per theme are required. If our CustomControl required multiple styles, then we would create multiple files. For example, we could create a CustomControl.Classic.xaml file that would be loaded when the Classic theme is loaded, or a CustomControl.HighContrast.xaml file for the HighContrast theme.

In an effort to reduce duplication, a "Default" file can be used. In our example, this would result in the files CustomControl.Default.xaml, CustomControl.Classic.xaml, and CustomControl.HighContrast.xaml. The first file would be loaded if the current theme is set to anything but Classic or HighConstrast, which are covered by the latter two files.

Includes Folder

The Themes\Includes folder contains resource dictionaries that aggregate the Assets and Styles, and it broken up into two categories. The first category contains things that are common across all things, while the second contains things that can change based on the current theme. These categories are generally termed "Common" and "Differences", respectively.

The common resources are merged into a Common.xaml file in the Includes folder. Anything can be placed in this file, but in general it should just merge in the resource dictionaries from the Assets and Styles folders.

Note Note
One exception to this rule is defining a theme catalog registrar, which is described earlier in this topic.

The non-common resources are merged into "difference" files. Continuing the example from above, we would need Default.xaml, Classic.xaml, and HighContrast.xaml files. Each of these files would merge in the appropriate file from the Styles folder.

Note Note
Common.xaml and Default.xaml can be confusing at first, but there is a difference. Entries in Common.xaml are the same across all themes. While, entries in Default.xaml may be the same across most themes, there are some themes to which it does not apply.

From the theme manager and theme catalog's point of view, only the difference files are of concern. Since the Common.xaml will always be loaded for all WPF system themes, it does not need to be loaded by the theme manager. The difference files will be loaded as needed, which effectively overlay or override the default assets and styles/templates.

Themes Folder

The root Theme folder contains XAML files for ResourceDictionary objects that will be loaded by WPF for the current system theme. Each of these files must contain everything need to load and display the associated controls.

The XAML files in folder should merge in the Common.xaml include file, if any, as well as its associated difference file, if any. For example, the Classic.xaml root theme file should merge in the Common.xaml include file and the Classic.xaml include file. The Aero.NormalColor.xaml root theme file should merge in the Common.xaml include file and the Default.xaml include file.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Native Controls

Actipro Themes includes styles and templates for all native WPF controls that have been given a more modernized appearance, and mesh perfectly with Actipro's custom control products.

The native WPF control styles use the same common asset (brush, thickness, etc.) pool as with our other custom WPF controls. Thus no matter which native or Actipro controls you use together, the appearance will consistently look great.

This topic contains these sections:

  • Using Native Styles and Templates
  • Style Keys for Native Controls
  • Embedded Style Keys for Native Controls

Using Native Styles and Templates

The Style for each native control can be applied either explicitly or implicitly. In most situations, applying the styles implicitly is the best approach, as this provides consistency across your application.

Implicit Styles

The native control styles can be applied implicitly by simply setting ThemeManager.AreNativeThemesEnabled to true. The theme manager will automatically load the necessary implicit styles into the application resources, which will therefore be used by your entire application.

Note Note
See the Getting Started topic for a complete example of how to use this setting, as well as how to combine it with other settings.

It is also possible to implicitly apply the native control styles to part of the visual tree. This sample code shows how to enable native for myControl and its descendents only:

C#
VB
Copy
​ThemeManager.SetAreNativeThemesEnabled(myControl, true);
​ThemeManager.SetAreNativeThemesEnabled(myControl, True)

Explicit Styles

The native control styles can also be applied explicitly on each individual control, using an associated ComponentResourceKey defined in the SharedResourceKeys class.

For example, the SharedResourceKeys.ButtonBaseStyleKey can be applied a RepeatButton like so:

XAML
Copy
​xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"
...
<RepeatButton Content="Click Me" Style="{DynamicResource {x:Static themes:SharedResourceKeys.ButtonBaseStyleKey}" />

For a complete list of the support native control styles, see the table in the following section.

Style Keys for Native Controls

This list shows the style resource keys that are available in SharedResourceKeys for use with native controls:

Style Resource Key | Description
ButtonBaseStyleKey | Applies to ButtonBase controls and its derivations, which includes Button, RepeatButton, and ToggleButton.
CheckBoxStyleKey | Applies to CheckBox controls.
ComboBoxStyleKey | Applies to ComboBox controls.
ComboBoxItemStyleKey | Applies to ComboBoxItem controls.
ContextMenuStyleKey | Applies to ContextMenu controls.
DocumentViewerStyleKey | Applies to DocumentViewer controls.
ExpanderStyleKey | Applies to Expander controls.
GridSplitterStyleKey | Applies to GridSplitter controls.
GridViewColumnHeaderStyleKey | Applies to GridViewColumnHeader controls.
GroupBoxStyleKey | Applies to GroupBox controls.
HyperlinkStyleKey | Applies to Hyperlink controls.
LabelStyleKey | Applies to Label.
ListBoxStyleKey | Applies to ListBox controls.
ListBoxItemStyleKey | Applies to ListBoxItem controls.
ListViewStyleKey | Applies to ListView controls.
ListViewItemStyleKey | Applies to ListViewItem controls.
MenuStyleKey | Applies to Menu controls.
MenuItemStyleKey Applies to MenuItem controls. In addition, there are several keys that reference control templates for the various types of menu items:
  • MenuItemTopLevelHeaderTemplateKey
  • MenuItemTopLevelItemTemplateKey
  • MenuItemSubmenuContentTemplateKey
  • MenuItemSubmenuHeaderTemplateKey
  • MenuItemSubmenuItemTemplateKey
PasswordBoxStyleKey | Applies to PasswordBox controls.
ProgressBarStyleKey | Applies to ProgressBar controls.
RadioButtonStyleKey | Applies to RadioButton controls.
ResizeGripStyleKey | Applies to ResizeGrip controls.
ScrollBarStyleKey | Applies to ScrollBar controls.
ScrollViewerStyleKey | Applies to ScrollViewer controls.
SeparatorStyleKey | Applies to Separator controls.
SliderStyleKey | Applies to Slider controls.
StatusBarStyleKey | Applies to StatusBar controls.
StatusBarItemStyleKey | Applies to StatusBarItem controls.
TabControlStyleKey | Applies to TabControl controls.
TabItemStyleKey | Applies to TabItem controls.
TextBoxBaseStyleKey | Applies to TextBoxBase controls and its derivations, which includes TextBox and RichTextBox.
ThumbStyleKey | Applies to Thumb controls.
ToolBarStyleKey | Applies to ToolBar controls.
ToolBarTrayStyleKey | Applies to ToolBarTray controls.
ToolTipStyleKey | Applies to ToolTip controls.
TreeViewStyleKey | Applies to TreeView controls.
TreeViewItemStyleKey | Applies to TreeViewItem controls and its derivations.
WindowStyleKey | Applies to Window controls.

Embedded Style Keys for Native Controls

Several native controls, such as ToolBar, require different styles for controls hosted or "embedded" inside it.

Menu

This list shows the embedded style resource keys that are available in SharedResourceKeys for use with Menu controls:

Style Resource Key | Description
MenuEmbeddedScrollViewerStyleKey | Applies to ScrollViewer controls.
MenuEmbeddedSeparatorStyleKey | Applies to Separator controls.

StatusBar

This list shows the embedded style resource keys that are available in SharedResourceKeys for use with StatusBar controls:

Style Resource Key | Description
StatusBarEmbeddedResizeGripStyleKey | Applies to ResizeGrip controls.
StatusBarEmbeddedSeparatorStyleKey | Applies to Separator controls.
StatusBarEmbeddedSliderDecreaseButtonBaseStyleKey | Applies to ButtonBase controls and its derivations, which includes Button, RepeatButton, and ToggleButton.
StatusBarEmbeddedSliderIncreaseButtonBaseStyleKey | Applies to ButtonBase controls and its derivations, which includes Button, RepeatButton, and ToggleButton.
StatusBarEmbeddedSliderStyleKey | Applies to Slider controls.

ToolBar

This list shows the embedded style resource keys that are available in SharedResourceKeys for use with ToolBar controls:

Style Resource Key | Description
ToolBarEmbeddedButtonBaseStyleKey | Applies to ButtonBase controls and its derivations, which includes Button, RepeatButton, and ToggleButton.
ToolBarEmbeddedComboBoxStyleKey | Applies to ComboBox controls.
ToolBarEmbeddedMenuStyleKey | Applies to Menu controls.
ToolBarEmbeddedPopupButtonStyleKey | Applies to PopupButton controls.
ToolBarEmbeddedSeparatorStyleKey | Applies to Separator controls.
ToolBarEmbeddedTextBoxStyleKey | Applies to TextBox controls.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Reusable Styles and Templates

Actipro Themes includes several reusable styles and templates for use in various parts of your application, to maintain a consistent look.

This topic contains these sections:

  • Reusable Styles
  • Reusable Glyphs

Reusable Styles

There are several miscellaneous styles for use with Actipro and native controls. This list shows the style resource keys that are available in SharedResourceKeys:

Style Resource Key | Description
EmbeddedButtonBaseStyleKey | Applies to ButtonBase controls and its derivations, which includes Button, RepeatButton, and ToggleButton. This style should be used for buttons embedded inside other controls.
EmbeddedButtonBaseOverrideStyleKey | This style is identical to EmbeddedButtonBaseStyleKey, but also sets OverridesDefaultStyle to true.
EmbeddedPopupButtonStyleKey | Applies to PopupButton controls. This style should be used for popup buttons embedded inside other controls.
EmbeddedPopupButtonOverrideStyleKey | This style is identical to EmbeddedPopupButtonStyleKey, but also sets OverridesDefaultStyle to true.
ToolWindowTitleBarButtonBaseStyleKey | Applies to ButtonBase controls and its derivations, which includes Button, RepeatButton, and ToggleButton. This style should be used for buttons inside the title bar of a tool window.
ToolWindowTitleBarButtonBaseAlternateStyleKey | This style is identical to ToolWindowTitleBarButtonBaseStyleKey, but uses a slightly different look to distinguish the button.
WindowTitleBarButtonBaseStyleKey | Applies to ButtonBase controls and its derivations, which includes Button, RepeatButton, and ToggleButton. This style should be used for buttons inside the title bar of a window.
WindowTitleBarButtonBaseAlternateStyleKey | This style is identical to WindowTitleBarButtonBaseStyleKey, but uses a slightly different look to distinguish the button.

Reusable Glyphs

There are several reusable glyphs, defined as DataTemplate resources, available for use in your application.

General

This list shows general glyph template resource keys that are available in SharedResourceKeys:

DataTemplate Resource Key | Description
CloseGlyphTemplateKey | Represents a glyph for use on a generic close button.
DropDownArrowGlyphTemplateKey | Represents a glyph for use on a drop-down button.
MaximizeGlyphTemplateKey | Represents a glyph for use on a generic maximize button.
MinimizeGlyphTemplateKey | Represents a glyph for use on a generic minimize button.
OverflowDropDownArrowGlyphTemplateKey | Represents a glyph for use on a drop-down button, to indicate there are hidden items.
PinGlyphTemplateKey | Represents a glyph for use on a pin button, such as for auto-hiding tool windows.
RestoreGlyphTemplateKey | Represents a glyph for use on a generic restore button.
UnpinGlyphTemplateKey | Represents a glyph for use on an unpin button, such as for sauto-hiding tool windows.

Tool Windows

This list shows glyph template resource keys that are available in SharedResourceKeys for use in Window title bars, with a WindowStyle of ToolWindow:

DataTemplate Resource Key | Description
ToolWindowTitleBarButtonCloseGlyphTemplateKey | Represents a glyph for use on a tool window's close button.
ToolWindowTitleBarButtonMaximizeGlyphTemplateKey | Represents a glyph for use on a tool window's maximize button.
ToolWindowTitleBarButtonMinimizeGlyphTemplateKey | Represents a glyph for use on a tool window's minimize button.
ToolWindowTitleBarButtonRestoreGlyphTemplateKey | Represents a glyph for use on a tool window's restore button.

Windows

This list shows glyph template resource keys that are available in SharedResourceKeys for use in Window title bars:

DataTemplate Resource Key | Description
WindowTitleBarButtonCloseGlyphTemplateKey | Represents a glyph for use on a window's close button.
WindowTitleBarButtonMaximizeGlyphTemplateKey | Represents a glyph for use on a window's maximize button.
WindowTitleBarButtonMinimizeGlyphTemplateKey | Represents a glyph for use on a window's minimize button.
WindowTitleBarButtonRestoreGlyphTemplateKey | Represents a glyph for use on a window's restore button.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Reusable Assets

Actipro Themes includes several reusable assets, such as brushes, for use in various parts of your application, to maintain a consistent look.

This topic contains these sections:

  • What is an Asset?
  • Browsing the Built-In Theme Assets
  • Reusing Theme Assets
  • Customizing Theme Assets

What is an Asset?

Assets are primitive resources such as Boolean, CornerRadius, Thickness, as well as SolidColorBrush, LinearGradientBrush, and RadialGradientBrush. Actipro Themes uses the same common asset (brush, thickness, etc.) pool for its native WPF control styles and custom control styles. Thus no matter which native or Actipro controls you use together, the appearance will consistently look great.

The keys for the assets in this common pool are defined in the AssetResourceKeys class, which includes over 800 assets.

Browsing the Built-In Theme Assets

The Sample Browser includes a utility called the Theme Browser, which lets you view all of the of the asset resources defined available for use.

Reusing Theme Assets

Any of theme assets used in the Actipro and native control themes can be used in your application, or for any custom controls you may have. Once you know which assets from AssetResourceKeys that you'd like to use, it's just a matter of setting up an appropriate DynamicResource.

The first step in reusing assets in XAML is to declare the proper namespace:

XAML
Copy
​xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"

This sample code shows how to use a dark container brush in a Border element:

XAML
Copy
​<Border Background="{DynamicResource {x:Static themes:AssetResourceKeys.ContainerDarkBackgroundNormalBrushKey}}" />

Note Note
Use the Theme Browser in the Sample Browser to quickly generate the DynamicResource references for any built-in asset.

Customizing Theme Assets

The theme assets can easily be customized to fit your exact requirements. Once you know which assets from AssetResourceKeys that you'd like to customize, you simply need to define a resource of the associated type and set the key appropriately.

The first step in customizing assets in XAML is to declare the proper namespace:

XAML
Copy
​xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"

This sample code shows how to customize a dark container brush in a Border element:

XAML
Copy
​<Application.Resources>
    <SolidColorBrush x:Key="{x:Static themes:AssetResourceKeys.ContainerDarkBackgroundNormalBrushKey}" Color="Red" />
</Application.Resources>

This will change the ContainerDarkBackgroundNormalBrushKey brush for you entire application. Alternatively, the brush above can be defined in the resources of an WPF element to only affect that control hierarchy.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The Actipro Themes architecture can be leverage by your own custom controls to provide dynamic theme switching.

This topic contains these sections:

  • Overview
  • Single-Style Custom Controls
  • Multiple-Style Custom Controls

Overview

In most cases, custom controls can define a single default Style for use with theming. When switching themes, the associated assets are changed resulting in a visual change to the control. There are some times when a separate control Style is needed for a specifc theme or themes.

Single-Style Custom Controls

For controls that only require one default Style, please see the Single Style topic for more information.

Multiple-Style Custom Controls

For controls that need to change the default Style based on the current theme, please see the Multiple Styles topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Single-Style Controls

This topic shows how the Actipro Themes architecture can be leverage by your own custom controls that only require a single style and contains these sections:

  • Overview
  • Step 1 - Initialize Default Style Key
  • Step 2 - Setup WPF Themes Folder
  • Step 3 - Setup Themes Includes Folder
  • Step 4 - Setup Themes Styles Folder
  • Step 5 - Define the Default Style
  • Completed

Overview

This tutorial will describe how to apply theming to the StaticThemedCustomControl custom control. This control, as well as its theming support files, can be found in our Sample Browser.

Note Note
See the Architecture topics for more information on each step.

Step 1 - Initialize Default Style Key

The control must tell WPF what key to use when looking for it's default Style. Typically, the key is the type of the control to avoid any confusion and allow WPF to more easily find the style.

This sample code shows how to define the default Style key:

C#
VB
Copy
​public class StaticThemedCustomControl : ContentControl {

    static StaticThemedCustomControl() {
        // Override default properties
        DefaultStyleKeyProperty.OverrideMetadata(typeof(StaticThemedCustomControl),
            new FrameworkPropertyMetadata(typeof(StaticThemedCustomControl)));
    }

}
​Public Class StaticThemedCustomControl
    Inherits ContentControl

    Shared Sub New()
        ' Override default properties
        DefaultStyleKeyProperty.OverrideMetadata(GetType(StaticThemedCustomControl),
            New FrameworkPropertyMetadata(GetType(StaticThemedCustomControl)))
    End Sub

End Class

Step 2 - Setup WPF Themes Folder

WPF requires that we define a number of XAML resource dictionary files in a Themes folder off of your project root. Once this folder is created, we can create simply a Generic.xaml resource dictionary file because our control does not need to change based on the current theme.

This sample code shows how the Generic.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >

    <!-- Merge in includes here -->

</ResourceDictionary>

Step 3 - Setup Themes Includes Folder

Following Actipro's file/folder organization, we next create a Themes\Includes folder. Inside this folder, we can create simply a Common.xaml resource dictionary file, again because our control does not need to change based on the current theme. We can now go back to our Generic.xaml file, and merge in our Common.xaml file.

This sample code shows how the Generic.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >
    <ResourceDictionary.MergedDictionaries>
        <ResourceDictionary Source="/SampleBrowser;component/Themes/Includes/Common.xaml" />
    </ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

Step 4 - Setup Themes Styles Folder

Next, we create a Themes\Includes\Styles folder, which will contains all the XAML resource dictionaires for control styles/templates. Since we have a single default Style, we will create the StaticThemedCustomControl.xaml which contains our style. Again, we must go back up to our Common.xaml file, and merge in our StaticThemedCustomControl.xaml file.

This sample code shows how the Common.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >
    <ResourceDictionary.MergedDictionaries>
        <ResourceDictionary Source="Styles/StaticThemedCustomControl.xaml" />
    </ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

Step 5 - Define the Default Style

We can now create our default Style in the StaticThemedCustomControl.xaml resource dictionary.

This sample code shows how the StaticThemedCustomControl.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"
        xmlns:sample="clr-namespace:ActiproSoftware.Windows.ProductSamples.ThemesSamples.QuickStart.ThemedCustomControl"
        >

    <Style x:Key="{x:Type sample:StaticThemedCustomControl}" TargetType="{x:Type sample:StaticThemedCustomControl}">
        <Setter Property="Background" Value="{DynamicResource {x:Static themes:AssetResourceKeys.ControlBackgroundNormalBrushKey}}" />
        <Setter Property="BorderBrush" Value="{DynamicResource {x:Static themes:AssetResourceKeys.ContainerBorderNormalBrushKey}}" />
        <Setter Property="BorderThickness" Value="1" />
        <Setter Property="themes:ThemeProperties.CornerRadius" Value="5" />

        <Setter Property="Content" Value="StaticThemedCustomControl with common theme" />
        <Setter Property="Padding" Value="10" />

        <Setter Property="Template">
            <Setter.Value>
                <ControlTemplate TargetType="{x:Type sample:StaticThemedCustomControl}">

                    <Border BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="{TemplateBinding BorderThickness}" Background="{TemplateBinding Background}"
                            Padding="{TemplateBinding Padding}" CornerRadius="{TemplateBinding themes:ThemeProperties.CornerRadius}" SnapsToDevicePixels="True">
                        <ContentPresenter />
                    </Border>

                </ControlTemplate>
            </Setter.Value>
        </Setter>
    </Style>

</ResourceDictionary>

Completed

We have now completed theming the StaticThemedCustomControl. Because it leverages the brushes from our common pool of assets, it's look will change as the current theme is changed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Multiple-Style Controls

This topic shows how the Actipro Themes architecture can be leverage by your own custom controls that only require multiple styles and contains these sections:

  • Overview
  • Step 1 - Initialize Default Style Key
  • Step 2 - Setup WPF Themes Folder
  • Step 3 - Setup Themes Includes Folder
  • Step 4 - Setup Themes Styles Folder
  • Step 5 - Define the Default Styles
  • Step 6 - Creating the Theme Catalog
  • Step 7 - Registering the Theme Catalog
  • Completed

Overview

This tutorial will describe how to apply theming to the DynamicThemedCustomControl custom control. This control, as well as its theming support files, can be found in our Sample Browser.

Note Note
See the Architecture topics for more information on each step.

Step 1 - Initialize Default Style Key

The control must tell WPF what key to use when looking for it's default Style. Typically, the key is the type of the control to avoid any confusion and allow WPF to more easily find the style.

This sample code shows how to define the default Style key:

C#
VB
Copy
​public class DynamicThemedCustomControl : ContentControl {

    static DynamicThemedCustomControl() {
        // Override default properties
        DefaultStyleKeyProperty.OverrideMetadata(typeof(DynamicThemedCustomControl),
            new FrameworkPropertyMetadata(typeof(DynamicThemedCustomControl)));
    }

}
​Public Class DynamicThemedCustomControl
    Inherits ContentControl

    Shared Sub New()
        ' Override default properties
        DefaultStyleKeyProperty.OverrideMetadata(GetType(DynamicThemedCustomControl),
            New FrameworkPropertyMetadata(GetType(DynamicThemedCustomControl)))
    End Sub

End Class

Step 2 - Setup WPF Themes Folder

WPF requires that we define a number of XAML resource dictionary files in a Themes folder off of your project root. We want to our DynamicThemedCustomControl to have two "looks", one when the AeroNormalColor theme is being used and one for all other cases. Therefore, we need create atleast two files in the Themes folder, which are Aero.NormalColor.xaml and Generic.xaml.

This sample code shows how bothe the Aero.NormalColor.xaml and Generic.xaml files should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >

    <!-- Merge in includes here -->

</ResourceDictionary>

Step 3 - Setup Themes Includes Folder

Following Actipro's file/folder organization, we next create a Themes\Includes folder. Inside this folder, we need to create AeroNormalColor.xaml file and a Default.xaml file. We can now go back to our root theme files, and merge in our "includes" files.

This sample code shows how the Aero.NormalColor.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >
    <ResourceDictionary.MergedDictionaries>
        <ResourceDictionary Source="/SampleBrowser;component/Themes/Includes/AeroNormalColor.xaml" />
    </ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

This sample code shows how the Generic.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >
    <ResourceDictionary.MergedDictionaries>
        <ResourceDictionary Source="/SampleBrowser;component/Themes/Includes/Default.xaml" />
    </ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

Step 4 - Setup Themes Styles Folder

Next, we create a Themes\Includes\Styles folder, which will contains all the XAML resource dictionaires for control styles/templates. In this folder, we will create the DynamicThemedCustomControl.AeroNormalColor.xaml and DynamicThemedCustomControl.Default.xaml files, one for each of our "looks". Again, we must go back up to our includes files, and merge in our style files.

This sample code shows how the AeroNormalColor.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >
    <ResourceDictionary.MergedDictionaries>
        <ResourceDictionary Source="Styles/DynamicThemedCustomControl.AeroNormalColor.xaml" />
    </ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

This sample code shows how the Default.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >
    <ResourceDictionary.MergedDictionaries>
        <ResourceDictionary Source="Styles/DynamicThemedCustomControl.Default.xaml" />
    </ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

Step 5 - Define the Default Styles

We can now create our default Styles in the DynamicThemedCustomControl.AeroNormalColor.xaml and DynamicThemedCustomControl.Default.xaml resource dictionaries.

This sample code shows how the DynamicThemedCustomControl.AeroNormalColor.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"
        xmlns:sample="clr-namespace:ActiproSoftware.Windows.ProductSamples.ThemesSamples.QuickStart.ThemedCustomControl"
        >

    <Style x:Key="{x:Type sample:DynamicThemedCustomControl}" TargetType="{x:Type sample:DynamicThemedCustomControl}">
        <Setter Property="Background">
            <Setter.Value>
                <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                    <GradientStop Color="#F1F3F3" />
                    <GradientStop Color="#F0F2F2" Offset="0.4" />
                    <GradientStop Color="#E7EAEE" Offset="0.4" />
                    <GradientStop Color="#F6F7F8" Offset="1" />
                </LinearGradientBrush>
            </Setter.Value>
        </Setter>
        <Setter Property="BorderBrush" Value="{DynamicResource {x:Static themes:AssetResourceKeys.ContainerBorderNormalBrushKey}}" />
        <Setter Property="BorderThickness" Value="1" />
        <Setter Property="themes:ThemeProperties.CornerRadius" Value="10" />

        <Setter Property="Content" Value="DynamicThemedCustomControl with Aero theme" />
        <Setter Property="Padding" Value="20" />

        <Setter Property="Template">
            <Setter.Value>
                <ControlTemplate TargetType="{x:Type sample:DynamicThemedCustomControl}">

                    <Border BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="{TemplateBinding BorderThickness}" Background="{TemplateBinding Background}"
                            Padding="{TemplateBinding Padding}" CornerRadius="{TemplateBinding themes:ThemeProperties.CornerRadius}" SnapsToDevicePixels="True">
                        <ContentPresenter />
                    </Border>

                </ControlTemplate>
            </Setter.Value>
        </Setter>
    </Style>

</ResourceDictionary>

This sample code shows how the DynamicThemedCustomControl.Default.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"
        xmlns:sample="clr-namespace:ActiproSoftware.Windows.ProductSamples.ThemesSamples.QuickStart.ThemedCustomControl"
        >

    <Style x:Key="{x:Type sample:DynamicThemedCustomControl}" TargetType="{x:Type sample:DynamicThemedCustomControl}">
        <Setter Property="Background" Value="{DynamicResource {x:Static themes:AssetResourceKeys.ControlBackgroundNormalBrushKey}}" />
        <Setter Property="BorderBrush" Value="{DynamicResource {x:Static themes:AssetResourceKeys.ContainerBorderNormalBrushKey}}" />
        <Setter Property="BorderThickness" Value="1" />

        <Setter Property="Content" Value="DynamicThemedCustomControl with Default theme" />
        <Setter Property="Padding" Value="10" />

        <Setter Property="Template">
            <Setter.Value>
                <ControlTemplate TargetType="{x:Type sample:DynamicThemedCustomControl}">

                    <Border BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="{TemplateBinding BorderThickness}" Background="{TemplateBinding Background}"
                            Padding="{TemplateBinding Padding}" CornerRadius="{TemplateBinding themes:ThemeProperties.CornerRadius}" SnapsToDevicePixels="True">
                        <ContentPresenter />
                    </Border>

                </ControlTemplate>
            </Setter.Value>
        </Setter>
    </Style>

</ResourceDictionary>

Step 6 - Creating the Theme Catalog

At this point, our control is all setup to switch between it's themes when the application is run. WPF will load the AeroNormalColor look when the application is run on Windows Vista/7 and the Aero theme is loaded, otherwise it will load the other default look. In order to support dynamic theme switching during runtime, we must setup and register a custom theme catalog.

We will call our theme catalog CustomThemeCatalog, which will link our two files with their associated themes.

This sample code shows how the CustomThemeCatalog class should look:

C#
VB
Copy
​public class CustomThemeCatalog : ThemeCatalogBase {

    private static IEnumerable<ThemedResourceDictionaryReference> dictionaryReferences;

    public override IEnumerable<ThemedResourceDictionaryReference> DictionaryReferences {
        get {
            if (dictionaryReferences == null) {
                string baseUri = ResourceHelper.GetLocationUriStringBase(Assembly.GetExecutingAssembly()) + "Themes/Includes/";

                dictionaryReferences = new ThemedResourceDictionaryReference[] {
                    new ThemedResourceDictionaryReference() {
                        LocationUri = new Uri(baseUri + "AeroNormalColor.xaml", UriKind.RelativeOrAbsolute),
                        Themes = new string[] {
                            ThemeName.AeroNormalColor.ToString(),
                        },
                    },
                    new ThemedResourceDictionaryReference() {
                        LocationUri = new Uri(baseUri + "Default.xaml", UriKind.RelativeOrAbsolute),
                        Themes = new string[] {
                            ThemeName.Classic.ToString(),
                            ThemeName.HighContrast.ToString(),
                            ThemeName.LunaHomestead.ToString(),
                            ThemeName.LunaMetallic.ToString(),
                            ThemeName.LunaNormalColor.ToString(),
                            ThemeName.MetroLight.ToString(),
                            ThemeName.MetroWhite.ToString(),
                            ThemeName.OfficeBlack.ToString(),
                            ThemeName.OfficeBlue.ToString(),
                            ThemeName.OfficeSilver.ToString(),
                            ThemeName.RoyaleNormalColor.ToString(),
                        },
                    },
                };

            }
            return dictionaryReferences;
        }
    }

}
​Public Class CustomThemeCatalog
    Inherits ThemeCatalogBase

    Private Shared dictionaryReferences_Renamed As IEnumerable(Of ThemedResourceDictionaryReference)

    Public Overrides ReadOnly Property DictionaryReferences() As IEnumerable(Of ThemedResourceDictionaryReference)
        Get
            If dictionaryReferences_Renamed Is Nothing Then
                Dim baseUri As String = ResourceHelper.GetLocationUriStringBase(System.Reflection.Assembly.GetExecutingAssembly()) & "Themes/Includes/"

                dictionaryReferences_Renamed = New ThemedResourceDictionaryReference() { _
                 New ThemedResourceDictionaryReference() With { _
                  .LocationUri = New Uri(baseUri & "AeroNormalColor.xaml", UriKind.RelativeOrAbsolute), _
                  .Themes = New String() {ThemeName.AeroNormalColor.ToString()}}, _
                 New ThemedResourceDictionaryReference() With { _
                  .LocationUri = New Uri(baseUri & "Default.xaml", UriKind.RelativeOrAbsolute), _
                  .Themes = New String() {ThemeName.Classic.ToString(), ThemeName.HighContrast.ToString(), ThemeName.LunaHomestead.ToString(), ThemeName.LunaMetallic.ToString(), ThemeName.LunaNormalColor.ToString(), ThemeName.MetroLight.ToString(), ThemeName.MetroWhite.ToString(), ThemeName.OfficeBlack.ToString(), ThemeName.OfficeBlue.ToString(), ThemeName.OfficeSilver.ToString(), ThemeName.RoyaleNormalColor.ToString()}}}

            End If
            Return dictionaryReferences_Renamed
        End Get
    End Property

End Class

Step 7 - Registering the Theme Catalog

Once the theme catalog has been created, it must be registered with the ThemeManager. This can be done manually by calling the RegisterThemeCatalog method and pass an instance of our CustomThemeCatalog. Alternatively, we can have the theme catalog automatically register itself when WPF loads the related system theme files.

To accomplish this, we will first create CustomThemeCatalogRegistrar, which derives from ThemeCatalogRegistrarBase`1.

This sample code shows how the CustomThemeCatalogRegistrar class should look:

C#
VB
Copy
​public class CustomThemeCatalogRegistrar : ThemeCatalogRegistrarBase<CustomThemeCatalog> {
}
​Public Class CustomThemeCatalogRegistrar
    Inherits ThemeCatalogRegistrarBase(Of CustomThemeCatalog)
End Class

Next we go back to our Themes\Includes folder and add a Common.xaml file. This file will be shared across all the various themes.

This sample code shows how the Common.xaml file should look:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:sample="clr-namespace:ActiproSoftware.Windows.ProductSamples.ThemesSamples.QuickStart.ThemedCustomControl"
        >
    <ResourceDictionary.MergedDictionaries>

        <sample:CustomThemeCatalogRegistrar />

    </ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

Finally, we go back our Themes folder and merge our new Common.xaml file into our root theme files.

This sample code shows how the Aero.NormalColor.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >
    <ResourceDictionary.MergedDictionaries>
        <ResourceDictionary Source="/SampleBrowser;component/Themes/Includes/AeroNormalColor.xaml" />
        <ResourceDictionary Source="/SampleBrowser;component/Themes/Includes/Common.xaml" />
    </ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

This sample code shows how the Generic.xaml file should look at this point:

XAML
Copy
​<ResourceDictionary
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        >
    <ResourceDictionary.MergedDictionaries>
        <ResourceDictionary Source="/SampleBrowser;component/Themes/Includes/Default.xaml" />
        <ResourceDictionary Source="/SampleBrowser;component/Themes/Includes/Common.xaml" />
    </ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

When WPF loads the root theme files, it will ultimately load the registrar which will in turn register the theme catalog with the theme manager.

Completed

We have now completed theming the DynamicThemedCustomControl. When the current theme is switch to AeroNormalColor, the theme manager will ensure that the DynamicThemedCustomControl.AeroNormalColor.xaml file is loaded. Otherwise, it will ensure the DynamicThemedCustomControl.Default.xaml file is loaded.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tinting

Actipro Themes fully supports tinting any of its built-in themes towards one or more colors to achieve a custom look. It is very easy to get started with tinting, as this topic describes.

This topic contains these sections:

  • What is Tinting?
  • Tint Groups
  • Tinting a Built-in Theme

What is Tinting?

Tinting entails cloning brushes and pens and adjusting their associate color(s) based on a "tint" color. The brushes and pens will still maintain similar saturation and lightness levels, but it's hue will be adjust based on the tint color. This allows a group of brushes to be tinted towards a single color, while maintaining their distinct look.

Tint Groups

Each asset in our common pool has an associated tint group name associated with it. This allows brushes/pens to be tinted towards a desired tint color, while not affecting "state" brushes, such as toolbar button hover brushes. Everything it setup by default, to make tinting easy to use and provide the best look out of the box.

Additionally, each group can be tinted towards a different color to achieve some really unique looks.

Note Note
Use Colors.Transparent to indicate that no tinting should be performed.

The built-in tint group names are defined in the TintGroupNames class.

Tinting a Built-in Theme

A entire built-in theme can be tinted towards a single color with a single line of code, by leveraging our TintedThemeCatalog class.

This sample code shows how to define the default Style key:

C#
VB
Copy
​ThemeManager.RegisterThemeCatalog(new TintedThemeCatalog("CustomDarkRed", ThemeName.OfficeBlue.ToString(), Colors.DarkRed));
​ThemeManager.RegisterThemeCatalog(New TintedThemeCatalog("CustomDarkRed", ThemeName.OfficeBlue.ToString(), Colors.DarkRed))

The TintedThemeCatalog class takes a new custom theme name, a base theme name, and a tint color. Once registered, we can set ThemeManager.CurrentTheme to "CustomDarkRed" at any time to load our custom tinted theme.

The TintedThemeCatalog.TintGroups collection can be used to indicated tint colors for individual groups.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Window Chrome

Actipro Themes includes a special class that is capable of rendering any WPF Window in a custom chrome that matches the current theme. For instance if the Metro Light theme is active, the window chrome will appear similar to Visual Studio and Office.

A sample usage of WindowChrome in a Metro-themed app

This topic contains these sections:

  • What is WindowChrome?
  • Applying Window Chrome
  • Supporting Multiple Themes
  • Aero Glass Support
  • Icon Display
  • Title Bar Button Display
  • Title Bar Text Alignment
  • Injecting Additional Content in the Title Bar

What is WindowChrome?

The WindowChrome class is a special class that is capable of applying a custom chrome to any normal WPF Window. It effectively hooks into a window and assumes all control of its rendering for the non-client area.

Features include:

  • Matches current application theme
  • Metro style appearance support
  • Aero glass support
  • Capability of showing custom size icons
  • Ability to set the margin around the icon
  • Ability to hide the icon
  • Ability to determine which title bar buttons are visible
  • Change the alignment of the title text (optionally center it)
  • Ability to inject additional UI next to title bar buttons
  • Normal border, or single pixel-border with outer glow effects
  • Outer glow areas support window resizing
  • Full Aero-snap support
  • Full interop (WinForms, etc.) and ClearType support

The ability to use semi-transparent border outer glow effects and still have full support for interop controls is rather unique, since normally windows with transparent backgrounds don't render interop controls in WPF. We have created special code to work around this. By default only the Metro themes activate the outer glow effects.

It is highly recommended that native control themes are activated when using window chrome, so that everything blends well together.

Applying Window Chrome

If your app will be using our Metro theme, you may apply the chrome to any existing Window via XAML or dynamically via code.

Note Note
Do not apply the chrome onto RibbonWindow instances. RibbonWindow instances already have a pre-installed WindowChrome that they use for backend Windows API interop logic. You can get that instance programmatically and alter its properties as needed via a call to WindowChrome.GetChrome.

Applying Via XAML

This code sample shows how to set a WindowChrome instance onto a Window and update the window to use a custom 24x24 icon (instead of the standard 16x16 icon). It also updates the margin around the icon.

XAML
Copy
​<Window xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"
    ...
    >
    <themes:WindowChrome.Chrome>
        <!-- This WindowChrome updates a Window so that it renders in a Metro style... custom-sized icons can even be used -->
        <themes:WindowChrome IconMargin="10,4,10,4" IconSource="/Resources/Images/ActiproMetro24.png" />
    </themes:WindowChrome.Chrome>
    ...
</Window>

You could also apply the chrome to windows in an app by defining the chrome in your Application.Resources with an x:Key. Then reference that chrome in each Window's XAML like:

XAML
Copy
​<Window xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"
    ...
    themes:WindowChrome.Chrome="{StaticResource YourWindowChromeKeyHere}">
    ...
</Window>

Note that if you choose to reuse a chrome instance among multiple windows, be sure to remove the instance from each window if the window is closed and will no longer be referenced.

This code sample shows how the chrome can be removed from within an OnClosed override of the Window.
C#
VB
Copy
​WindowChrome.SetChrome(this, null);
​WindowChrome.SetChrome(Me, Nothing)

The code above will prevent any possible memory leaks due to the chrome instance remaining alive.

Important Warning Important Warning
WindowChrome installs a new Style onto the window instances that use it. Therefore, custom window styles cannot be assigned to a window that will be chromed. And thus, the window chrome cannot be assigned via a style setter since as soon as it would be assigned, our built-in style would end up getting applied (which didn't have the chrome setter) and the chrome would then be removed. Set the chrome on each window instance as described above instead.

Applying Via Code

This code sample shows how to set a WindowChrome instance onto a Window programmatically instead, which can be done at run-time, such as after the Window's InitializeComponent call.
C#
VB
Copy
​WindowChrome.SetChrome(this, new WindowChrome());
​WindowChrome.SetChrome(Me, New WindowChrome())

Removing Via Code

The custom WindowChrome can also be removed at run-time if needed, with a call such as this on the Window.
C#
VB
Copy
​WindowChrome.SetChrome(this, null);
​WindowChrome.SetChrome(Me, Nothing)

Once removed, the window will render using system defaults again.

Supporting Multiple Themes

As mentioned above, the window chrome currently only works properly for Metro-themed apps. If your app needs to support other themes as well, it's easy to do.

Per the code above, you can programmatically apply or remove the window chrome from all your windows as appropriate based on whether Metro theme is currently active in your app.

Aero Glass Support

Aero glass support is disabled by default, but can be enabled by setting the IsGlassEnabled property to true. On Windows Vista or later machines, this will activate Aero glass mode if allowed by Windows.

Icon Display

By default, the WindowChrome will render the window's 16x16 icon.

However if a custom-sized icon is desired (such as a 24x24 icon), its ImageSource can be set to the IconSource property. The IconSource property is ignored when Aero glass is active. The margin around the icon can be adjusted with the IconMargin property.

The HasIcon property can be set to false to hide the icon in the title bar altogether.

Title Bar Button Display

These properties on the WindowChrome instance govern which title bar buttons display:

  • HasMinimizeButton
  • HasRestoreButton
  • HasMaximizeButton
  • HasCloseButton

Title Bar Text Alignment

The WindowChrome.TitleBarTextAlignment property allows a TextAlignment to be specified that changes the horizontal alignment of the title text. While it defaults to Left, it can be changed to a value like Center to center-align the title text.

Injecting Additional Content in the Title Bar

The WindowChrome.TitleBarContentTemplate property allows a DataTemplate to be specified that contains UI content. This content is injected in the title bar area, next to the caption (minimize, restore, etc.) buttons.

This feature could be used to insert another title bar button, or a app-wide search textbox.

This example shows how to create a template for an additional title bar button, sized for the Metro Light theme:

XAML
Copy
​<DataTemplate x:Key="TitleBarContentTemplate">
    <Button
        Style="{DynamicResource {x:Static themes:SharedResourceKeys.WindowTitleBarButtonBaseStyleKey}}"
        themes:ThemeProperties.IsActive="{Binding RelativeSource={RelativeSource AncestorType={x:Type Window}}, Path=IsActive}"
        ToolTip="Custom TitleBar Button" ToolTipService.InitialShowDelay="500">
        <Button.ContentTemplate>
            <DataTemplate>
                <Canvas Width="26" Height="18">
                    <Path Canvas.Left="8" Canvas.Top="12"
                            Fill="{Binding RelativeSource={RelativeSource Self}, Path=(TextElement.Foreground)}"
                            Data="M 0,0 L 2,0 L 2,2 L 0,2 Z M 4,0 L 6,0 L 6,2 L 4,2 Z M 8,0 L 10,0 L 10,2 L 8,2 Z"/>
                </Canvas>
            </DataTemplate>
        </Button.ContentTemplate>
    </Button>
</DataTemplate>

Assume then that the template is located in the application's resources and is referenced by a StaticResource to the WindowChrome.TitleBarContentTemplate property.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

This topic contains troubleshooting data specific to the Actipro Themes product.

Note Note
For some more troubleshooting information that relates both to this product as well as other WPF Studio products, please see the more general TroubleShooting topic.

This topic contains these sections:

  • Office or Metro Themes Are Not Working
  • Windows 8 Systems Render in Classic Theme By Default
  • ListView Controls are Displaying Items Incorrectly
  • Themes Do Not Work When Hosted in WinForms Application

Office or Metro Themes Are Not Working

There are two steps that must be performed in order to leverage the Office and Metro themes in your application. So if you try to set the current theme to one of the supported Office/Metro themes, but the colors do not update accordingly, then please ensure the following steps have been performed.

Note Note
Tinted themes that are based on one of the Office or Metro themes can also be affected, if the source theme is not registered correctly.

The Office and Metro themes are located in a separate assembly, to help reduce the install base size for customers that do not use it. Therefore, you must first ensure that your application has a reference to the ActiproSoftware.Themes.Office.Wpf.dll assembly for Office themes, and/or a reference to the ActiproSoftware.Themes.Metro.Wpf.dll assembly for Metro themes.

Once the reference has been added, the Office and/or Metro theme catalog must be manually registered with the theme manager during application startup:

C#
VB
Copy
​ThemesOfficeThemeCatalogRegistrar.Register();  // Only needed for Office theme support
ThemesMetroThemeCatalogRegistrar.Register();  // Only needed for Metro theme support
​ThemesOfficeThemeCatalogRegistrar.Register()  ' Only needed for Office theme support
ThemesMetroThemeCatalogRegistrar.Register()  ' Only needed for Metro theme support

Note Note
See the Getting Started topic for a complete example of how to register the Office and Metro theme catalogs, as well as how to combine them with other settings.

Windows 8 Systems Render in Classic Theme By Default

Unfortunately there doesn't appear to be a built-in way in WPF to support the Aero Lite theme introduced in Windows 8, and WPF applications in Windows 8 will use Classic theme by default.

See the Getting Started topic for information on how to get Windows 8 systems to render in a Metro theme by explicitly assigning it as the current theme.

ListView Controls are Displaying Items Incorrectly

The native WPF ListView control comes in two forms. In it's simplest form, it acts just like a ListBox, which is its base class. To display tabular data, a ListView can be assigned a GridView which contains one or more column definitions. Our native theme support for the ListView is limited to this latter form, due to the style extensibility of the ListView.

Therefore, in cases where a ListView is being used without an associated GridView would need to be replaced with an instance of ListBox. There should be no loss of functionality by making this change.

Themes Do Not Work When Hosted in WinForms Application

Actipro's theme manager requires access to the WPF Application.Current object. When hosting WPF controls in a WinForms application, the Application.Current object will always be null. This effectively prevents the theme manager from dynamically changing the current theme.

It is possible to work around this issue by artifically creating a WPF application object, like so:

C#
VB
Copy
​public static void CreateWpfApplication() {
    if (System.Windows.Application.Current == null) {
        var app = new System.Windows.Application();
        app.ShutdownMode = ShutdownMode.OnExplicitShutdown;
    }
}
​Private Shared Sub CreateWpfApplication()
    If (System.Windows.Application.Current Is Nothing) Then
        Dim app = New System.Windows.Application()
        app.ShutdownMode = ShutdownMode.OnExplicitShutdown
    End If
End Sub

This method would then need to be called when your WinForms application is starting.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Views is a suite of controls and panels that supports fluid animations of the child elements arrangement. Built for the Windows Presentation Foundation (WPF), the controls are highly configurable and designed to follow WPF best practices.

The controls offer stunning effects and life like interaction, and are highly configurable.

Different animations can be applied to elements entering or leaving the panels, as well as elements simply moving to a new location or changing size. Several built-in animations are provided that allow elements to be smoothly moved, sized, faded, scaled, rotated, or translated.

The Actipro Views panels can be added to any application to give it a little more pizazz.

Features

Controls

  • Book - An ItemsControl that presents the items as pages in a book.
  • InertiaScrollViewer - A smooth-scrolling ScrollViewer-like control that reacts to touch and continues gliding to a stop when flicked.
  • TaskBoard - Provides a board of reorderable columns and cards.

Built-in Panels

  • AnimatedCanvas - Represents a panel that positions child elements using explicit coordinates that are relative to the panel.
  • AnimatedDockPanel - Represents a panel that positions child elements either horizontally or vertically, relative to each other.
  • AnimatedStackPanel - Represents a panel that positions child elements in sequential order, either horizontally or vertically.
  • AnimatedWrapPanel - Represents a panel that positions child elements in sequential order, breaking content to the next row or column at the edge of the containing box.
  • FanPanel - Represents a panel that positions child elements along the z-axis, while keeping a focal item centered in the view.
  • SwitchPanel - Represents a panel that delegates the positioning of the child elements to one or more child panels.
  • ZapPanel - Represents a panel that positions child elements in sequential order, while keeping a focal item centered in the view.

General Features

  • Several built-in panels can be used as drop-in replacements for native WPF panels.
  • Custom panels can be built which automatically support animation and can be used in AnimatedSwitchPanel.
  • SwitchPanel can be used to dynamically change the measure/arrange logic without moving child elements.
  • AnimatedWrapPanel allows empty space to be evenly distributed along the oriented axis.
  • Code base is largely compatible between WPF and Silverlight.

Animation Features

  • Several built-in animations including moving, sizing, fading, scaling, rotating, translating.
  • Supports custom animations which can extend or completely replace built-in animations.
  • Different animations can be applied to elements entering, leaving, or updating position in the panel.
  • Quickly customize the animation settings, such as setting an acceleration or deceleration ratio.

Layout, Globalization, and Accessibility Features

  • Right-to-left support is fully integrated for languages such as Hebrew or Arabic.
  • Follows the WPF accessibility model for UI automation.

Code and Requirements

  • Includes detailed documentation and a sample project that demos nearly every feature.
  • Written in 100% pure C# and is based on the Windows Presentation Foundation framework.
  • Requires the .NET 4.0 or later run-time framework.
  • Full XAML support and XBAP compatibility.
  • Extensive Visual Studio and Expression Blend designer capabilities.
  • Visual Studio and/or Expression Blend are recommended development tools for this product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Getting up and running with the panels is extremely easy.

This topic's information will assume you are using Visual Studio to write your XAML code for a WPF Window that will contain one of the panels.

This topic contains these sections:

  • Add Assembly References
  • Getting Started with Views
  • Further Study

Add Assembly References

First, add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.Views.Wpf.dll assemblies. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

Getting Started with Views

This code shows the base XAML that you can use to create a simple AnimatedStackPanel:

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
...
<views:AnimatedStackPanel>
    <Button Content="One" \>
    <Button Content="Two" \>
</views:AnimatedStackPanel>

This code shows the base XAML that you can use to use a AnimatedStackPanel in a ListBox:

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
...
<ListBox ...>
    <ListBox.ItemsPanel>
        <ItemsPanelTemplate>
            <views:AnimatedStackPanel />
        </ItemsPanelTemplate>
    </ListBox.ItemsPanel>
</ListBox>

Further Study

It's very easy to use the various panels and there are probably a lot of great features that you aren't aware of.

Run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of the controls.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

This topic covers the controls available in the Views product and contains these sections:

  • Book
  • InertiaScrollViewer
  • TaskBoard

Book

The Book control is an ItemsControl that presents the items as pages in a book.

See the Book topic for more information.

InertiaScrollViewer

The InertiaScrollViewer is a smooth-scrolling ScrollViewer-like control that reacts to touch and continues gliding to a stop when flicked.

See the InertiaScrollViewer topic for more information.

TaskBoard

The TaskBoard control makes it easy to add interactive task scheduling and prioritization to your apps. A task board consists of zero to many columns, each of which can contain zero to many cards. Columns and cards can be dragged around and reordered, all using pleasing sway animations.

See the TaskBoard topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Book

The Book control is an ItemsControl that presents the items as pages in a book.

This topic contains these sections:

  • Overview
  • Orientation
  • First Page Placement
  • Populating the Book
  • Turning Pages
  • Commands and Methods
  • Events
  • Virtualization
  • Transparency

Overview

The Book control can be used to recreate a real-world book, including support for page turn animations. The pages can be turned by clicking and/or dragging the corners from one side to the other, or programmatically using routed commands or public methods. Includes support for horizontal and vertical orientations and several other options.

All the items presented in a Book are wrapped in an instance of BookPage, just like a ListBox wraps items with a ListBoxItem.

Orientation

The Book control supports Horizontal and Vertical orientations. This parameter refers to the way the pages turn and is perpendicular to the spine of the Book.

The horizontal (left) and vertical (right) orientations of the Book

In both orientations shown above, the '1' page (left/top) is considered a Back page, and the '2' page (right/bottom) is considered a Front page. Each sheet of page has a front and a back. In the examples above, the sheet of paper on the right/bottom has '2' on the front and its back is not visible. If the sheet on the right/bottom was turned, then its back would be visible and its front would not.

Each BookPage has a Face property to indicate which side or face of the sheet it is on.

First Page Placement

The first page of a Book can either be on the front or back of the first sheet of paper. When oriented horizontally, this effectively determines whether the first page is on the left (back) or right (front) side of the book. The IsFirstPageFront property controls which side (Front or Back) the first page is placed on.

Populating the Book

A Book can be populated with content by adding content to the Items collection, or by setting the ItemsSource property. The ItemsSource property can be data-bound to a collection, just like any other ItemsControl. The Book can be populated with any type of object.

The Book control supports UI virtualization when the underlying items are not instances of BookPage. See the "Virtualization" section below for more information.

Applying a Custom DataTemplate

When the Book is populated with objects that are not instances of BookPage, a custom DataTemplate is generally needed to properly present the data. The Book.ItemTemplate property can be used to apply a custom DataTemplate to all generated pages. Or, you can achieve more granular control using the by utilizing a BookPageTemplateSelector.

Alternatively, more granular control can be achieved using the Book.ItemTemplateSelector property. This allows the DataTemplate to be chosen dynamically based on the item being presented and it's associated BookPage. For convenience, BookPageTemplateSelector can be used to set the DataTemplate for the first, last, back-facing, and front-facing pages.

Note Note
ItemTemplate or ItemTemplateSelector are only applied if the BookPage is an automatically generated container.

Applying a Custom Style

A custom look can be achieved by styling the Book and/or BookPage. This may include adding page accents, margins, rounded corners, etc.

A Book can be styled by setting the Style property explicitly or using an implicit Style.

One or more instances of BookPage can also be styled by setting the Style properties explicitly or using an implicit Style. The latter approach is automatically applied to all pages and makes styling a bit easier, as any new pages will automatically pick up the new style. One drawback to this approach, is that it doesn't allow the Style to be selected based on whether the page is the first or last, or whether it's back or front facing.

The Book.ItemContainerStyle property can be used to explicitly set the BookPage.Style property for all the pages in a book. But this again, doesn't allow dynamic selection of the Style based on the page's properties.

More granular control can be achieved using the Book.ItemContainerStyleSelector property. This allows the page's Style to be chosen dynamically based on the item being presented and it's associated BookPage. For convenience, BookPageStyleSelector can be used to set the Style differently based on whether the page is the frist or last page, or whether it's back or front facing.

Note Note
ItemContainerStyle and ItemContainerStyleSelector are applied to all instances of BookPage in a book, regardless of whether they were automatically generated or not, and will override any implicit styles.

Turning Pages

Using the Mouse

There are two ways of turning the page with the mouse. The four outermost corners of the Book are hotspots. You can either click in a hotspot to turn the page, or you can click and drag the corner to the opposite side of the Book. Clicking the hotspot will invoke an automated page flipping animation. Dragging the hotspot allows you to turn the page at your own pace. You can complete the page flip by releasing the drag on the opposite side of the Book or cancel the page flip by releasing the drag on the original side of the Book.

The HotspotExtent property allows you to specify the size of the hotspot. The property is of the Unit type, allowing plenty of flexibility in how you specify the size of the hotspot.

The hotpots of a Book control

Using the Keyboard

The Book control supports keyboard navigation. Here are the shortcuts that are supported by default:

Key(s) | Action
Home | First page
End | Last page
Right | Next page
Left | Previous page
Down | Next page
Up | Previous page

The Book control's keyboard navigation can be customized two ways. First, the ResetInputBindings member function can be completely overridden with custom input bindings. The base method can be optionally called, depending on whether the bindings are being customized or completely replaced. Second, the InputBindings collection can be manually updated to remove or add specific items.

See the "Commands and Methods" section below for more information on the commands that are used by the Book control.

Tip Tip
Events (discussed below) are fired in the same sequence when turning a page using the keyboard as when using the mouse, eventhough no page curl actually occurs. The page curl/flip can still be cancelled in the same way as with mouse navigation.

Commands and Methods

Pages can be programatically turned using several routed command or public methods. By default, support for the following NavigationCommands commands is included:

  • FirstPage
  • GoToPage
  • LastPage
  • PreviousPage
  • NextPage

The following Book methods can also be used directly:

  • GoToFirstPage
  • GoToLastPage
  • GoToNextPage
  • GoToPreviousPage
  • GoToPage

Events

PageCurlActivating

The PageCurlActivating event is fired when the mouse hovers over a hotspot. A handler of this event will receive a CancelBookPageRoutedEventArgs instance, which indicates the corner being curled and it's associated face. In addition, the Cancel property can be used to cancel the event.

Canceling the PageCurlActivating event prevents the page curl from occuring, therefore the end-user will not receive any visual feedback as to whether the mouse is hovering the hotspot.

PageCurlActivated

The PageCurlActivated event is fired when a page corner has curled. A handler of this event will receive a BookPageRoutedEventArgs instance, which indicates the corner being curled and it's associated face.

PageCurlDeactivated

The PageCurlDeactivated event is fired when a page corner has stopped being curled. A handler of this event will receive a BookPageRoutedEventArgs instance, which indicates the corner was previously curled and it's associated face.

PageFlipping

The PageFlipping event is fired when a page is about to flip. A handler of this event will receive a CancelBookPageRoutedEventArgs instance, which indicates the corner being curled and it's associated face. In addition, the Cancel property can be used to cancel the event.

Canceling the PageFlipping event prevents the page flip from occuring, therefore preventing the end-user from navigating away from a page.

SelectedViewChanged

The SelectedViewChanged event is fired when the selected view has changed. A pair of visible page faces is referred to as a view. A handler of this event will receive a PropertyChangedRoutedEventArgs<int> instance, which indicates the old and new view indexes.

PageFlipped

The PageFlipped event is fired when a page has flipped. A handler of this event will receive a BookPageRoutedEventArgs instance, which indicates the corner being curled and it's associated face.

Virtualization

The Book control includes UI virtualization to allow a large number of pages to be presented. BookPage container objects are only realized for pages that are close to the selected view index. By minimizing the number of realized container objects at any given time, the Book control runs faster and uses less memory.

The number of pages that are realized at any given time is determined by the PageDepth property. This value indicates the number of pages realized on each side of the book. Typically with opaque pages, the default value can be left untouched. This value is only useful when using transparent pages, as pages that are not realized will not be visible.

Keep in mind that all pages on either side count towards the PageDepth. This includes opposing faces, which are not visible until the page is being turned, so these need to be accounted for.

Transparency

The BookPage.Background can be set to a transparent or semi-transparent brush, thus making the page itself transparent/semi-transparent.

As mentioned in the "Virtualization" section above, the PageDepth property is very important when using pages with transparency. The pages behind the transparency need to be realized to avoid "popping" when the page is turned. In general, the PageDepth should be high enough to accomodate the largest number of consecutive transparent pages that will occur in the entire Book.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


InertiaScrollViewer

The InertiaScrollViewer is a smooth-scrolling ScrollViewer-like control that reacts to touch and continues gliding to a stop when flicked.

This topic contains these sections:

  • Overview
  • Scroll Bar Visibility
  • Adjusting Inertia Scrolling

Overview

The InertiaScrollViewer is a ContentControl that scrolls its content. Like a ScrollViewer, it will display whatever UIElement you set the Content property to.

Note Note
When scrolling with a mouse wheel, vertical scrolling will always take priority. If vertical scrolling is not possible, InertiaScrollViewer will attempt to scroll horizontally instead.
Scroll Bar Visibility

The direction of scrolling can be controlled using InertiaScrollViewer.HorizontalScrollBarVisibility and InertiaScrollViewer.VerticalScrollBarVisibility.

  • ScrollBarVisibility.Auto will show a scrollbar if the Content size is larger than the size of the viewport.
  • ScrollBarVisibility.Disabled will not show a scrollbar, regardless of whether or not Content fits in the viewport. Scrolling in this direction will be disabled.
  • ScrollBarVisibility.Hidden will not show a scrollbar, regardless of whether or not Content fits in the viewport, however scrolling in this direction will still be possible.
  • ScrollBarVisibility.Visible will always show a scrollbar, regardless of whether or not Content fits in the viewport. If content is larger than the viewport, scrolling will be possible.

Adjusting Inertia Scrolling

Inertia scrolling (how scrolling continues to glide after a flick gesture) can be adjusted using several properties.

  • InertiaScrollViewer.EasingFunction is the easing function that determines the curve of the scrolling. It defaults to QuarticEase, but can be set to any System.Windows.Media.Animation.EasingFunctionBase. There are several available in the System.Windows.Media.Animation namespace, such as QuadraticEase, BounceEase, and more.
  • InertiaScrollViewer.VelocityDistanceRatio is the ratio of distance to velocity that determines the distance travelled when scrolling. A smaller number means less travel when scrolling with inertia, while a larger number means more travel.
  • InertiaScrollViewer.VelocityTimeRatio is the ratio of time to velocity that determines the duration of the scrolling animation. A smaller number means the scrolling animation will be faster, while a larger number means the animation will be slower.
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TaskBoard

The TaskBoard control makes it easy to add interactive task scheduling and prioritization to your apps. A task board consists of zero to many columns, each of which can contain zero to many cards. Columns and cards can be dragged around and reordered, all using pleasing sway animations.

This topic contains these sections:

  • Data Binding
  • Customizing the Appearance
  • Animated Drag Reordering
  • Card Tap Notifications
  • Hit Testing
  • Sample Usage

Data Binding

The task board has been designed specifically to work with MVVM environments. The root TaskBoard control is an ItemsControl, and thus its ItemsSource property should be bound to a collection property, which will be used to generate the board's columns.

The TaskColumn control is also an ItemsControl, and its ItemsSource should be bound to a collection property on the data item used for each column. This collection property will be used to generate the column's cards. Since the column is nested within the board as a second-level control, the property to bind to for card data can be set via the TaskBoard.ColumnItemsSourcePath property. This is a string value that indicates the property name on the data item.

Customizing the Appearance

As described above, the task board is meant to be data-driven. It provides a number of Style, DataTemplate, etc. properties that allow for complete customization of how the board renders and what UI is available. Any interactive controls, such as buttons, can be placed within a DataTemplate to support advanced functionality like popups within the cards. By using a DataTemplateSelector, different appearances can be supplied for cards depending on the data item.

Each task board renders its columns in a horizontal layout, followed by an optional board footer. A task planning app might put an "Add a list" button in the board footer template. Each column renders a header at the top, typically displaying a bold title. The vertical list of cards within the column renders under the header. This is followed by an optional column footer. A task planning app mgiht put an "Add a task" button in the column footer template.

These properties on TaskBoard allow for appearance customization:

Member | Description
CardContainerStyle Property | The Style to use for card containers.
CardContainerStyleSelector Property | The StyleSelector to use for card containers.
CardCornerRadius Property | The card corner radius. The default value is 3.0.
CardSpacing Property | The spacing between cards. The default value is 7.0.
CardTemplate Property | The DataTemplate to use for cards.
CardTemplateSelector Property | The DataTemplateSelector to use for cards.
ColumnCornerRadius Property | The column corner radius. The default value is 3.0.
ColumnPadding Property | The column padding. The default value is 7.0.
ColumnSpacing Property | The spacing between columns. The default value is 10.0.
FooterTemplate Property | The DataTemplate to use for a footer.
ItemFooterTemplate Property | The DataTemplate to use for column footers.
ItemFooterTemplateSelector Property | The DataTemplateSelector to use for column footers.
ItemHeaderTemplate Property | The DataTemplate to use for column headers.
ItemHeaderTemplateSelector Property | The DataTemplateSelector to use for column headers.

Animated Drag Reordering

The task board uses smooth sway animations to help convey that a column or card is dragging. The maximum degrees that a column or card can rotate is based on the TaskBoard.ColumnDragRotationAngle and CardDragRotationAngle properties respectively. Both default to 3.0 but can be altered as needed. Set them to 0.0 to prevent swaying.

Column and card dragging to reorder is enabled by default as long as the source data item collections implement IList. Set the TaskBoard.CanColumnsDrag and CanCardsDrag properties to false to prevent dragging of columns/cards altogether.

Note that when using touch to drag a column or card, you must first hold your finger down on the column/card for at least a quarter second before moving it. Otherwise, if you touch down and immediately drag, the control will think you are trying to scroll the control.

When dragging is enabled, an event is raised whenever a drag is initiated. Columns raise the TaskBoard.ColumnDragging event and cards raise the CardDragging event. Both of these events support blocking the drag by setting the event arguments' e.Cancel property to true. Logic for setting it can be done on an individual data item basis via these events.

When a drag is completed, columns raise the TaskBoard.ColumnDropped event and cards raise the CardDropped event. The event includes arguments that tell the old and new locations of the droped column/card. The drop can also be canceled by setting e.Cancel to true on the event arguments.

Selectively Blocking Drop Targets

When dragging a column or card over another target column/card, the TaskBoard.ColumnDragOver and CardDragOver events will be raised when appropriate. These events provide arguments with the source and target information. Set e.Cancel to true to prevent a certain target from being allowed. These events are where complex logic can be added to determine if certain column/card drops are permitted.

Card Tap Notifications

When a card is tapped, the TaskBoard.CardTapped event is raised.

Hit Testing

Sometimes it's handy to be able to hit test for a card or column that is at a certain location. Perhaps the app is watching for certain hotkeys to be pressed and needs to know which card is under the mouse. This is a scenario where hit testing is needed.

The TaskBoard.HitTestForColumn method takes a TaskBoard-relative location and returns the TaskColumn under that location, if any.

The TaskColumn.HitTestForCard method takes a TaskColumn-relative location and returns the TaskCard under that location, if any.

By using both those methods, it's possible to determine which card is at a certain point location.

Sample Usage

This basic XAML shows how to create the basic appearance for the Task Planning demo, whose complete source is in the sample project.

XAML
Copy
​<views:TaskBoard x:Name="taskBoard" ItemsSource="{Binding Lists}" ColumnItemsSourcePath="Tasks"
                    Padding="15" ColumnSpacing="15" ColumnPadding="10" FontSize="14">
    <views:TaskBoard.ItemContainerStyle>
        <Style TargetType="views:TaskColumn">
            <Setter Property="Background" Value="#80ffffff" />
            <Setter Property="BorderThickness" Value="0" />
            <Setter Property="Foreground" Value="#202020" />
            <Setter Property="Width" Value="260" />
        </Style>
    </views:TaskBoard.ItemContainerStyle>
    <views:TaskBoard.ItemHeaderTemplate>
        <DataTemplate>
            <sample:ColumnHeaderControl />
        </DataTemplate>
    </views:TaskBoard.ItemHeaderTemplate>
    <views:TaskBoard.CardContainerStyle>
        <Style TargetType="views:TaskCard">
            <Setter Property="Background" Value="#ffffff" />
            <Setter Property="BorderThickness" Value="0" />
            <Setter Property="Foreground" Value="#404040" />
        </Style>
    </views:TaskBoard.CardContainerStyle>
    <views:TaskBoard.CardTemplate>
        <DataTemplate>
            <sample:CardContentControl />
        </DataTemplate>
    </views:TaskBoard.CardTemplate>
    <views:TaskBoard.ItemFooterTemplate>
        <DataTemplate>
            <sample:AddTaskControl />
        </DataTemplate>
    </views:TaskBoard.ItemFooterTemplate>
    <views:TaskBoard.FooterTemplate>
        <DataTemplate>
            <sample:AddListControl Width="260" VerticalAlignment="Top" />
        </DataTemplate>
    </views:TaskBoard.FooterTemplate>
</views:TaskBoard>

Some of the data templates above reference other UserControl objects that are defined in the full sample source.

In this example, the root DataContext is a TaskBoardModel instance, which has a Lists collection property used to define the columns. The TaskListModel class has a Tasks collection property (referenced by the ColumnItemsSourcePath property in the XAML) used to define the cards in each column.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

There are several panels provided, with some that replicate and enhance the layout logic provided by native WPF panels and others that provide unique layout logic. This topic briefly describes the panels.

This topic contains these sections:

  • PanelBase
  • AnimatedCanvas
  • AnimatedDockPanel
  • AnimatedStackPanel
  • AnimatedWrapPanel
  • SwitchPanel
  • ZapPanel
  • Building a Custom Panel

PanelBase

All animated panels derive from PanelBase. This includes most of the animation framework, leaving the derived classes to simply implement their layout logic.

See the PanelBase topic for more information.

AnimatedCanvas

Allows child elements to be precisely positioned using coordinates that are relative to the panel's bounds. This panel can be used as a drop-in replacement for the native Canvas panel.

See the AnimatedCanvas topic for more information.

AnimatedDockPanel

Allows child elements to be positioned either horizontally or vertically, relative to each other. This panel can be used as a drop-in replacement for the native WPF DockPanel panel.

See the AnimatedDockPanel topic for more information.

AnimatedStackPanel

Allows child elements to be positioned in sequential order, either horizontally or vertically. This panel can be used as a drop-in replacement for the native StackPanel panel.

See the AnimatedStackPanel topic for more information.

AnimatedWrapPanel

Allows child elements to be positioned in sequential order, breaking content to the next row or column at the edge of the panels bounds. Subsequent ordering happens sequentially from top to bottom or from right to left, depending on the orientation. This panel can be used as a drop-in replacement for the native WPF WrapPanel panel.

See the AnimatedWrapPanel topic for more information.

SwitchPanel

Delegates the positioning of child elements to one or more child panels, which allows the layout logic to be dynamically changed during runtime.

See the SwitchPanel topic for more information.

ZapPanel

Allows child elements to be positioned in sequential order, either horizontally or vertically, while keeping a focal item centered in the view. Includes support for wrapping items around, to produce a circular effect.

See the ZapPanel topic for more information.

Building a Custom Panel

Custom panels can easily be created that support animations and can be used in SwitchPanel.

See the Building a Custom Panel topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PanelBase

This is the base class for all the panels provided by the Views product. It allows custom panels to be built that animate the arrangement of the child elements, and can be used in the SwitchPanel.

This topic contains these sections:

  • Overview
  • Arrange State
  • Disabling Animations Per Element
  • Important Members

Overview

The PanelBase provides base functionality of all animated panels. It provides attached properties for storing state information, as well as the current animation rectangle.

When building a custom panel that derives from the native Panel, the ArrangeOverride and MeasureOverride methods are overridden. Similarly, when building a custom panel that derives from the PanelBase, the ArrangeElements and MeasureElements methods should be overridden. Additionally, the panel should not reference the Children collection, but instead arrange the list of elements specified. This allows the panel's layout logic to be leveraged by the SwitchPanel.

See the Building a Custom Panel topic for more information.

Arrange State

The PanelBase uses the ArrangeStateProperty attached property to storage state information about its child elements. The state is represented by an instance of ArrangeState, and captures the current status, current arrange rectangle, previous arrange rectangle, and an optional "from" point.

The ArrangeState.ArrangeStatus indicates the current status of the element. The valid statuses are: Entering, Leaving, ArrangeUpdating, and LayoutUpdating.

Member | Description
Entering Field | Indicates that the element was just added to the panel and is "entering" the view.
Leaving Field | Indicates that the element was just removed from the panel and is "leaving" the view.
ArrangeUpdating Field | Indicates that the element is changing position or size in the panel due to the standard arrange phase.
LayoutUpdating Field | Indicates that the element is changing position or size because the layout logic of the panel changed (e.g. the orientation is changed).

The current and previous arrange rectangels are captured in the ArrangeRect and PreviousArrangeRect properties, respectively.

Finally, the ArrangeFromPoint can be used to optionally change the location that an element starts it's "move" animation from. This is usually leveraged by custom panels to customize the movement of elements.

Disabling Animations Per Element

Using the PanelBase.IsAnimatedProperty attached property, animations can be selectively disabled for individual elements. This property defaults to true and is supported by all panels that derive from PanelBase.

Important Members

The following PanelBase members are key to its use:

Member | Description
ArrangeAnimation Property | Gets or sets the IArrangeAnimation that controls the animation of elements when arranging.
ArrangeElement Method Arranges the specified element using the current arrange state.

This can be used to force an element to arrange using it's current arrange location, but does not typically need to be called directly.
ArrangeElements Method Positions the specified elements and determines a size for a FrameworkElement-derived class.

This method must be implemented by derivations of PanelBase, and determines the arrangement logic of the panel.
ArrangeHeightAnimatedProperty Attached Property Gets or sets the height used when arranging the associated element.
Note Note
Typically, the property should never be set directly, as it is animated when the state of the element is changed.
ArrangeStateProperty Attached Property | Gets or sets the current state of the associated element, which can include an updated arrange rectangle.
ArrangeWidthAnimatedProperty Attached Property Gets or sets the width used when arranging the associated element.
Note Note
Typically, the property should never be set directly, as it is animated when the state of the element is changed.
ArrangeXAnimatedProperty Attached Property Gets or sets the position along the X-axis of the parent panel used when arranging the associated element.
Note Note
Typically, the property should never be set directly, as it is animated when the state of the element is changed.
ArrangeYAnimatedProperty Attached Property Gets or sets the position along the Y-axis of the parent panel used when arranging the associated element.
Note Note
Typically, the property should never be set directly, as it is animated when the state of the element is changed.
IsLayoutUpdatePending Property Gets a value indicating whether a change to the layout logic has changed and the elements have yet to be arranged.

This is typically used to distingush between the ArrangeStatus.ArrangeUpdating and ArrangeStatus.LayoutUpdating statues, where the latter is due to a change in the logical layout (i.e. changing the orientation).
MeasureElements Method Measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

This method must be implemented by derivations of PanelBase, and determines the measurement logic of the panel.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AnimatedCanvas

This panel allows child elements to be precisely positioned using coordinates that are relative to the panel's bounds.

Note Note
This panel can be used as a drop-in replacement for the native Canvas panel.

This topic contains these sections:

  • Overview
  • Getting Started with AnimatedCanvas
  • Important Members

Overview

The AnimatedCanvas does not have any inherent layout logic. Child elements are positioned at the specified loctaions, and are always allotted their desired size.

The Panel.ZIndex property is used to determine the order of child elements that overlap. Elements with a higher ZIndex will appear on top of elements with a lower value.

Child elements are positioned using the attached properties AnimatedCanvas.LeftProperty, AnimatedCanvas.TopProperty, AnimatedCanvas.RightProperty, and/or AnimatedCanvas.BottomProperty. The LeftProperty indicates the offset of the element from the left edge of the panel, using either a positive (moving to the right) or a negative (moving offscreen to the left) value. The TopProperty indicates the offset of the element from the top edge of the panel, using either a positive (moving downwards) or a negative (moving upwards and offscreen) value. Likewise, the RightProperty and BottomProperty specify the offset of the element from the right and bottom edges, respectively.

Note Note
If both the LeftProperty and RightProperty are specified on an element, then the LeftProperty takes precedence and the RightProperty is ignored. Similarly, the TopProperty takes precedence over the BottomProperty.

Getting Started with AnimatedCanvas

This code shows typical XAML code used to position elements in an AnimatedCanvas:

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
...
<views:AnimatedCanvas>
    <!-- Positioned 10 pixels to the right and 10 pixels down from the top-left corner of the panel. -->
    <Button Content="One" views:AnimatedCanvas.Left="10" views:AnimatedCanvas.Top="10" \>
    <!-- Positioned 10 pixels to the left and 10 pixels up from the bottom-right corner of the panel. -->
    <Button Content="Two" views:AnimatedCanvas.Right="10" views:AnimatedCanvas.Bottom="10" \>
</views:AnimatedCanvas>

Important Members

The following AnimatedCanvas members are key to its use:

Member | Description
BottomProperty Attached Property | Gets or sets the offset of the element from the bottom edge of the panel.
LeftProperty Attached Property | Gets or sets the offset of the element from the left edge of the panel.
RightProperty Attached Property | Gets or sets the offset of the element from the right edge of the panel.
TopProperty Attached Property | Gets or sets the offset of the element from the top edge of the panel.
ZIndex Attached Property (defined on Panel) | Gets or sets the z-order of the element in the panel.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AnimatedDockPanel

This panel allows child elements to be positioned either horizontally or vertically, relative to each other.

Note Note
This panel can be used as a drop-in replacement for the native WPF DockPanel panel.

This topic contains these sections:

  • Overview
  • Getting Started with AnimatedDockPanel
  • Important Members

Overview

Child elements are positioned or "docked" to a specified edge, and relative to other child elements. The AnimatedDockPanel.DockProperty attached property is used to specify the edge to which the element should be docked.

If two child elements are docked to the left side of the panel, the first element will be aligned with the left edge of the panel, while the second element will be aligned with the right edge of the first element. As elements are docked, their allotted space is reserved and any remaining child elements will be docked around them.

Special handling can be applied to the last child element. It can either be set to fill any remaining space, which is the default behavior. Alternatively, it can be docked like other elements. This behavior can be customized using the AnimatedDockPanel.LastChildFill property. When LastChildFill is set to true, the DockProperty on the last element is ignored.

Getting Started with AnimatedDockPanel

This code shows typical XAML code used to position elements in an AnimatedDockPanel:

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
...
<views:AnimatedDockPanel LastChildFill="True">
    <!-- Docked to the left side of the panel -->
    <Button Content="One" views:AnimatedDockPanel.Dock="Left" \>
    <!-- Fills the remaining space of the panel -->
    <Button Content="Two" \>
</views:AnimatedDockPanel>

Important Members

The following AnimatedDockPanel members are key to its use:

Member | Description
DockProperty Attached Property | Gets or sets the edge of the panel to which the element will be docked.
LastChildFill Property | Gets or sets a value that indicates whether the last child element within the panel stretches to fill the remaining available space.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AnimatedStackPanel

This panel allows child elements to be positioned in sequential order, either horizontally or vertically.

Note Note
This panel can be used as a drop-in replacement for the native StackPanel panel.

This topic contains these sections:

  • Overview
  • Getting Started with AnimatedStackPanel
  • Important Members

Overview

Child elements are positioned or "stacked" based on the order that the elements were added to the panel, or more specifically, their position in the Children collection. Elements can be stacked either vertically or horizontally, which is determined by the AnimatedStackPanel.Orientation property.

AnimatedStackPanel with the elements stacked vertically (left) and horizontally (right)

Like the native WPF StackPanel, the AnimatedStackPanel implents IScrollInfo to support logical scrolling. Physical scrolling is based on the size of the element being scrolled and can be thought of as "pixel-based" scrolling. Logical scrolling is based on the number of elements in the AnimatedStackPanel, so it effectively moves a given element completely into the view (when possible). If ScrollViewer.CanContentScroll is set to false, then logical scrolling will be disabled and physical scrolling will be used.

Getting Started with AnimatedStackPanel

This code shows typical XAML code used to position elements in an AnimatedStackPanel:

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
...
<views:AnimatedStackPanel Orientation="Vertical">
    <Button Content="One" \>
    <!-- Positioned just below the button above -->
    <Button Content="Two" \>
</views:AnimatedStackPanel>

Important Members

The following AnimatedStackPanel members are key to its use:

Member | Description
Orientation Property | Gets or sets the orientation that the child elements are arranged.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AnimatedWrapPanel

This panel allows child elements to be positioned in sequential order, either horizontally or vertically, breaking content to the next row or column at the edge of the containing box. Subsequent ordering happens sequentially from top to bottom or from right to left, depending on the orientation.

Note Note
This panel can be used as a drop-in replacement for the native WPF WrapPanel panel.

This topic contains these sections:

  • Overview
  • Item Size
  • Empty Space
  • Use in ScrollViewer
  • Getting Started with AnimatedWrapPanel
  • Important Members

Overview

Child elements are positioned or "stacked" based on the order that the elements were added to the panel, or more specifically, their position in the Children collection. Elements can be stacked either vertically or horizontally, which is determined by the AnimatedWrapPanel.Orientation property.

AnimatedWrapPanel with the elements stacked horizontally (left) and vertically (right)

Item Size

Elements will be given as much, or as little, space as they request during the measure phase. The height and/or width of the elements can be fixed using the AnimatedWrapPanel.ItemHeight and/or AnimatedWrapPanel.ItemWidth properties. When one or both of these properties are set to a valid number, then the elements will be restricted to the specified size.

Empty Space

By default, elements will be stacked next to each other and wrap to the next row/column when needed. This can leave a lot of extra space in each row/column. The AnimatedWrapPanel can be configured to evenly distribute the empty space along the oriented axis.

By setting the AnimatedWrapPanel.IsEmptySpaceEvenlyDistributed property to true, the space will be divided up evenly between the items.

AnimatedWrapPanel with the elements stacked horizontally and evenly spaced

Use in ScrollViewer

If an AnimatedWrapPanel is used in a ScrollViewer, which typically includes ListBox and other ItemsControl-derived controls, then special consideration is needed. Scrolling needs to be disabled in the same orientation as the AnimatedWrapPanel. Otherwise, the ScrollViewer will give the AnimatedWrapPanel unlimited space in which to arrange it's children, which effectively disables the "wrapping" feature.

To disabled scrolling, the ScrollViewer.HorizontalScrollBarVisibility or ScrollViewer.VerticalScrollBarVisibility property can be set to Disabled. When using a ListBox, the scrollbar visibility properties can be set directly on the ListBox, as it's an attached property.

Getting Started with AnimatedWrapPanel

This code shows typical XAML code used to position elements in an AnimatedWrapPanel:

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
...
<views:AnimatedWrapPanel Orientation="Horizontal">
    <Button Content="One" \>
    <!-- Positioned to the right or below the button above, depending on the width of the panel. -->
    <Button Content="Two" \>
</views:AnimatedWrapPanel>

Important Members

The following AnimatedWrapPanel members are key to its use:

Member | Description
IsEmptySpaceEvenlyDistributed Property | Gets or sets a value indicating whether any empty space in a row/column will be evenly distributed around the elements.
ItemHeight Property | Gets or sets a value that specifies the height of all items.
ItemWidth Property | Gets or sets a value that specifies the width of all items.
Orientation Property | Gets or sets the orientation that the child elements are arranged.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


FanPanel

This panel allows child elements to be positioned in sequential order along the z-axis, while keeping a focal item centered in the view.

This topic contains these sections:

  • Overview
  • Fore and Back Elements
  • Offsetting Elements
  • Rotating Elements
  • Fading Elements
  • Getting Started with FanPanel
  • Important Members

Overview

Child elements are positioned or "stacked" along the z-axis based on the order that the elements were added to the panel, or more specifically, their position in the Children collection.

A focal item (or an item of interest) is centered in the view, which is specified by the FanPanel.FocalIndex property. By default, the focal element will have a higher z-index and will be on top of the other elements. This can be tied to the selected index of an associated ListBox, or any other control such as a Slider.

FanPanel with give elements and the default settings

The FanPanel implements IScrollInfo to support logical scrolling. Physical scrolling is based on the size of the element being scrolled and can be thought of as "pixel-based" scrolling. Logical scrolling is based on the number of elements in the FanPanel, so it effectively moves a given element completely into the view (when possible). If ScrollViewer.CanContentScroll is set to false, then logical scrolling will be disabled and physical scrolling will be used. This causes a problem as the FanPanel centers the focal item, so the physical scrolling will be offset. Therefore, physical scrolling cannot be used with the FanPanel.

Fore and Back Elements

Elements that are defined in the Children collection before the focal element are considered "fore" elements. Therefore, elements that are defined in the Children collection after the focal element are considered "back" elements. The various settings below can be set separately for the fore and back elements.

By default, fore elements are hidden from view. This behavior can be changed using the FanPanel.ForeElementLayoutPlacement property. The fore elements can be placed above or below the focal element along the z-axis using the Above or Below setting, respectively. When using these settings, the fore elements can be offset, faded, or rotated so that the focal element is still visible.

The Wrap setting will wrap the fore elements so they are stacked below any back elements. When using this setting, the ForeAngleStep, ForeOffsetStep, and ForeOpacityStep properties are not used. Instead the associated back properties are applied to every element, except the focal element.

Offsetting Elements

The FanPanel.BackOffsetStep and FanPanel.ForeOffsetStep properties configure an incremental offsets along the X axis and Y axis for the fore and back elements. The focal element will always be centered in the view.

FanPanel with a back and fore offset of "100,0"

Rotating Elements

The FanPanel.BackAngleStep and FanPanel.ForeAngleStep properties configure an incremental angle rotation for the fore and back elements. The focal element will always use an angle of 0, so it is never rotated.

Fading Elements

The FanPanel.BackOpacityStep and FanPanel.ForeOpacityStep properties configure an incremental opacity value for the fore and back elements. The focal element will always use an opacity of 1, so it is never rotated.

Note Note
When FanPanel.ForeElementLayoutPlacement is set to Hidden the fore elements are always faded to 0 when hidden.

Getting Started with FanPanel

This code shows typical XAML code used to position elements in an FanPanel:

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
...
<views:FanPanel>
    <!-- Positioned in the center of the view, as it's considered the focal item by default -->
    <Button Content="One" \>
    <!-- Positioned just below the button above in the z-order -->
    <Button Content="Two" \>
</views:FanPanel>

Important Members

The following FanPanel members are key to its use:

Member | Description
BackAngleStep Property | Gets or sets a value used to increment the angle of elements after the focal element based on their distance.
BackOffsetStep Property | Gets or sets a value used to increment the X and Y coordinate of the elements after the focal element based on their distance.
BackOpacityStep Property | Gets or sets a value used to decrement the opacity of the elements after the focal element based on their distance.
FocalIndex Property | Gets or sets the index of the focal child, which should be centered in the panel.
ForeAngleStep Property | Gets or sets a value used to increment the angle of elements before the focal element based on their distance.
ForeElementLayoutPlacement Property | Gets or sets the placement of any elements before the focal element in the panel.
ForeOffsetStep Property | Gets or sets a value used to increment the X and Y coordinate of the elements before the focal element based on their distance.
ForeOpacityStep Property | Gets or sets a value used to decrement the opacity of the elements before the focal element based on their distance.
IsFocalIndexAutoBound Property | Gets or sets a value indicating whether the FocalIndex property is automatically bound to the associated Selector.SelectedIndex property when used as an items host.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SwitchPanel

This panel delegates the positioning of child elements to one or more child panels, which allows the layout logic to be dynamically changed during runtime.

This topic contains these sections:

  • Overview
  • Getting Started with SwitchPanel
  • Important Members

Overview

The SwitchPanel relies on one or more PanelBase-derived panels to provide the current layout logic. These delegate panels are specified in the Panels collection. The active delegate panel is determined by the ActiveIndex property, which specifies an index into the Panels collection.

Once configured, the layout logic of the SwitchPanel can be quickly altered by updating the ActiveIndex property.

SwitchPanel with the elements arranged by an AnimatedCanvas (left) and an AnimatedWrapPanel (right)

Getting Started with SwitchPanel

This code shows typical XAML code used to position elements in an SwitchPanel:

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
...
<views:SwitchPanel>
    <views:SwitchPanel.Panels>
        <views:AnimatedCanvas />
        <views:AnimatedWrapPanel IsEmptySpaceEvenlyDistributed="True" />
    </views:SwitchPanel.Panels>
    <!-- Positioned is top-left corner, since the AnimatedCanvas is active -->
    <Button Content="One" views:AnimatedCanvas.Left="0" views:AnimatedCanvas.Top="0"  \>
    <!-- Positioned is bottom-right corner, since the AnimatedCanvas is active -->
    <Button Content="Two" views:AnimatedCanvas.Right="0" views:AnimatedCanvas.Bottom="0" \>
</views:SwitchPanel>

Important Members

The following SwitchPanel members are key to its use:

Member | Description
ActiveIndex Property | Gets or sets the index of the PanelBase from the Panels collection that is active.
ActivePanel Property | Gets the PanelBase from the Panels collection that is active. collection that is active.
Panels Property | Gets or sets the panels that can be used to layout the children.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ZapPanel

This panel allows child elements to be positioned in sequential order, either horizontally or vertically, while keeping a focal item centered in the view. Includes support for wrapping items around, to produce a circular effect.

This topic contains these sections:

  • Overview
  • Wrapping
  • Getting Started with ZapPanel
  • Important Members

Overview

Child elements are positioned or "stacked" based on the order that the elements were added to the panel, or more specifically, their position in the Children collection. Elements can be stacked either vertically or horizontally, which is determined by the ZapPanel.Orientation property.

Unlike an AnimatedStackPanel, a focal item (or an item of interest) is centered in the view. This can be tied to the selected index of an associated ListBox, or any other control such as a Slider.

ZapPanel with the first element selected (left) and the second element selected (right)

The ZapPanel implements IScrollInfo to support logical scrolling. Physical scrolling is based on the size of the element being scrolled and can be thought of as "pixel-based" scrolling. Logical scrolling is based on the number of elements in the ZapPanel, so it effectively moves a given element completely into the view (when possible). If ScrollViewer.CanContentScroll is set to false, then logical scrolling will be disabled and physical scrolling will be used. This causes a problem as the ZapPanel centers the focal item, so the physical scrolling will be offset. Therefore, physical scrolling cannot be used with the ZapPanel, and instead an AnimatedStackPanel should be used.

In general, the width of the ZapPanel should be restricted when oriented horizontally, and height should be restricted when oriented vertically. If the ZapPanel is given unlimited width/height when oriented horizontally/vertically then it will not be able to center the focal item.

Wrapping

By default, the child elements are stacked in order from beginning to end. The ZapPanel can wrap elements around to the opposing side to produce a circular effect. This feature can be enabled by setting ZapPanel.AreChildrenWrapped to true.

ZapPanel using wrapping with the first element selected (left) and the second element selected (right)

Getting Started with ZapPanel

This code shows typical XAML code used to position elements in an ZapPanel:

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
...
<views:ZapPanel Orientation="Vertical">
    <!-- Positioned in the center of the view, as it's considered the focal item by default -->
    <Button Content="One" \>
    <!-- Positioned just below the button above -->
    <Button Content="Two" \>
</views:ZapPanel>

Important Members

The following ZapPanel members are key to its use:

Member | Description
AreChildrenWrapped Property | Gets or sets a value indicating whether the child items are wrapped around the item currently centered.
FocalIndex Property | Gets or sets the index of the focal child, which should be centered in the panel.
IsFocalIndexAutoBound Property | Gets or sets a value indicating whether the FocalIndex property is automatically bound to the associated Selector.SelectedIndex property when used as an items host.
Orientation Property | Gets or sets the orientation that the child elements are arranged.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Building a Custom Panel

This topic describes step-by-step how to create a custom panel that supports animation and SwitchPanel. Specifically, the panel created in this tutorial will randomly arrange its child elements.

Note Note
The complete source code for this tutorial can be found in the associated Sample Browser.

This topic contains these sections:

  • Step 1: Class Declaration
  • Step 2: Random Field
  • Step 3: Override MeasureElements
  • Step 4: Measurement Logic
  • Step 5: Override ArrangeElements
  • Step 6: Arrangement Logic - Check IsLayoutUpdatePending
  • Step 7: Arrangement Logic - Determine Location
  • Step 8: Arrangement Logic - Update ArrangeState
  • Step 9: Use RandomPanel
  • Step 10: Custom Animations

Step 1: Class Declaration

The panel will be named RandomPanel and needs to derive from PanelBase.

The using statements listed below have been included as they will all be needed to complete this tutorial. But, Visual Studio can be used to automatically add the appropriate using statements for unknown types. Since this panel can be found in the associated samples, the same namespace is used here.

C#
VB
Copy
​using System;
using System.Collections.Generic;
using System.Windows;
using ActiproSoftware.Windows.Controls.Views;
using ActiproSoftware.Windows.Controls.Views.Primitives;

namespace ActiproSoftware.Windows.ProductSamples.ViewsSamples.QuickStart.CustomPanelRandom {

    /// <summary>
    /// Represents a custom panel that randomly arranges it's child elements.
    /// </summary>
    public class RandomPanel : PanelBase {

        // SEE BELOW

    }
}
​Imports System
Imports System.Collections.Generic
Imports System.Windows
Imports ActiproSoftware.Windows.Controls.Views
Imports ActiproSoftware.Windows.Controls.Views.Primitives

Namespace ActiproSoftware.Windows.ProductSamples.ViewsSamples.QuickStart.CustomPanelRandom

    ''' <summary>
    ''' Represents a custom panel that randomly arranges it's child elements.
    ''' </summary>
    Public Class RandomPanel
        Inherits PanelBase

        ' SEE BELOW

    End Class
End Namespace

Step 2: Random Field

An instance of the Random class will be needed to randomly generate the locations of the elements.

Add the following inside the Random class:

C#
VB
Copy
​private Random random = new Random(Environment.TickCount);
​Private random As New Random(Environment.TickCount)

Step 3: Override MeasureElements

The PanelBase.MeasureElements method must be overridden to measure the associated elements.

Typically, a Panel will measure/arrange the elements found in the Children collection. In order to support SwitchPanel, the panel must measure/arrange the list of elements provided as a method parameter. When the RandomPanel is used by a SwitchPanel, the list includes the elements contained in the SwitchPanel. When the RandomPanel is used independently, the list simply references the Children collection.

Add the following inside the Random class:

C#
VB
Copy
​/// <summary>
/// Measures the size in layout required for the specified elements and determines a size for the <see cref="FrameworkElement"/>-derived class.
/// </summary>
/// <param name="elements">The elements to be measured.</param>
/// <param name="availableSize">The available size that this element can give to the specified elements. Infinity can be specified as a value to indicate that
/// the element will size to whatever content is available.</param>
/// <returns>
/// The size that this element determines it needs during layout, based on its calculations of the specified elements.
/// </returns>
public override Size MeasureElements(IList<UIElement> elements, Size availableSize) {

    // SEE BELOW

}
​''' <summary>
''' Measures the size in layout required for the specified elements and determines a size for the <see cref="FrameworkElement"/>-derived class.
''' </summary>
''' <param name="elements">The elements to be measured.</param>
''' <param name="availableSize">The available size that this element can give to the specified elements. Infinity can be specified as a value to indicate that
''' the element will size to whatever content is available.</param>
''' <returns>
''' The size that this element determines it needs during layout, based on its calculations of the specified elements.
''' </returns>
Public Overrides Function MeasureElements(ByVal elements As IList(Of UIElement), ByVal availableSize As Size) As Size

    ' SEE BELOW

End Function

Step 4: Measurement Logic

The measurement logic of the RandomPanel simply passes the given available size to the elements. It returns a desired size that will fit the largest element, both horizontally and vertically.

Add the following inside the MeasureElements method:

C#
VB
Copy
​// Measure each element, and return the largest width and height needed
Size desiredSize = new Size();
foreach (UIElement element in elements) {
    if (null != element) {
        element.Measure(availableSize);

        desiredSize.Width = Math.Max(element.DesiredSize.Width, desiredSize.Width);
        desiredSize.Height = Math.Max(element.DesiredSize.Height, desiredSize.Height);
    }
}
return desiredSize;
​' Measure each element, and return the largest width and height needed
Dim desiredSize As New Size()
For Each element As UIElement In elements
    If Nothing IsNot element Then
        element.Measure(availableSize)

        desiredSize.Width = Math.Max(element.DesiredSize.Width, desiredSize.Width)
        desiredSize.Height = Math.Max(element.DesiredSize.Height, desiredSize.Height)
    End If
Next element
Return desiredSize

Step 5: Override ArrangeElements

The PanelBase.ArrangeElements method must be overridden to arrange the associated elements.

Just like the measure phase, the specified list of elements should be arranged, not the elements in the Children collection. The RandomPanel will always take as much space as it's given, since it returns finalSize unaltered.

Add the following inside the Random class:

C#
VB
Copy
​/// <summary>
/// Positions the specified elements and determines a size for a <see cref="FrameworkElement"/>-derived class.
/// </summary>
/// <param name="elements">The elements to be arranged.</param>
/// <param name="finalSize">
/// The final area within the parent that this element should use to arrange itself and the specified elements.
/// </param>
/// <returns>The actual size used.</returns>
public override Size ArrangeElements(IList<UIElement> elements, Size finalSize) {

    // SEE BELOW

    return finalSize;
}
​''' <summary>
''' Positions the specified elements and determines a size for a <see cref="FrameworkElement"/>-derived class.
''' </summary>
''' <param name="elements">The elements to be arranged.</param>
''' <param name="finalSize">
''' The final area within the parent that this element should use to arrange itself and the specified elements.
''' </param>
''' <returns>The actual size used.</returns>
Public Overrides Function ArrangeElements(ByVal elements As IList(Of UIElement), ByVal finalSize As Size) As Size

    ' SEE BELOW

    Return finalSize
End Function

Step 6: Arrangement Logic - Check IsLayoutUpdatePending

The PanelBase.IsLayoutUpdatePending property is used to flag when the layout logic of the RandomPanel, or the associated SwitchPanel, has changed. The animations used for a change in a layout logic change can be configured differently than standard arrange rectangle changes. These two distinct states are represented by ArrangeStatus.LayoutUpdating and ArrangeStatus.ArrangeUpdating, respectively.

Derived panels are responsible for checking and using the IsLayoutUpdatePending flag, so both statuses are correctly applied.

Note Note
If the flag is not properly used, then the "layout updating" animations and settings will not be used. Instead, the "arrange updating" animations and settings will always be used.

Add the following inside the ArrangeElements method above the SEE BELOW marker:

C#
VB
Copy
​// Cache and reset layout pending flag
bool isLayoutUpdatePending = this.IsLayoutUpdatePending;
this.IsLayoutUpdatePending = false;
​' Cache and reset layout pending flag
Dim isLayoutUpdatePending As Boolean = Me.IsLayoutUpdatePending
Me.IsLayoutUpdatePending = False

Step 7: Arrangement Logic - Determine Location

Using the random field, a unique x and y coordinate will be calculated for each element. Determining an x and y coordinate is similar to how the native WPF Canvas works, but can actually be applied to any panel. In reality, the final rectangle of the element is being determined.

In addition to randomly placing the elements, this logic will ensure that the element is fully visible inside the panel, when possible.

Add the following inside the ArrangeElements method in place of the SEE BELOW marker:

C#
VB
Copy
​// Iterate over the elements and arrange
foreach (UIElement element in elements) {
    if (element != null) {
        Size desiredSize = element.DesiredSize;

        // Calculate a random x/y position that keeps the element in the view
        double x = Math.Max(random.NextDouble() * (finalSize.Width - desiredSize.Width), 0);
        double y = Math.Max(random.NextDouble() * (finalSize.Height - desiredSize.Height), 0);

        // SEE BELOW
    }
}
​' Iterate over the elements and arrange
For Each element As UIElement In elements
    If element IsNot Nothing Then
        Dim desiredSize As Size = element.DesiredSize

        ' Calculate a random x/y position that keeps the element in the view
        Dim x As Double = Math.Max(random.NextDouble() * (finalSize.Width - desiredSize.Width), 0)
        Dim y As Double = Math.Max(random.NextDouble() * (finalSize.Height - desiredSize.Height), 0)

        ' SEE BELOW
    End If
Next element

Step 8: Arrangement Logic - Update ArrangeState

Instead of directly arranging elements, derivations of PanelBase update the "arrange state". This information is captured in an instance of ArrangeState and is set on an element via an attached property.

The PanelBase will then watch for state changes and animate an element based on its state (i.e. entering the view, leaving the view, updating location, etc) and the current animation settings.

This logic will also prevent elements from moving when one or more sibling elements are leaving the scene.

Add the following inside the ArrangeElements method in place of the SEE BELOW marker:

C#
VB
Copy
​// Update the arrange state with the new arrange rect, but if there are leaving elements then don't move
//   the element
ArrangeState state = new ArrangeState(element, false, isLayoutUpdatePending);
if (!this.HasLeavingChildren)
    state.ArrangeRect = new Rect(x, y, desiredSize.Width, desiredSize.Height);
else
    state.ArrangeRect = state.PreviousArrangeRect;

PanelBase.SetArrangeState(element, state);
​' Update the arrange state with the new arrange rect, but if there are leaving elements then don't move
'   the element
Dim state As New ArrangeState(element, False, isLayoutUpdatePending)
If Not Me.HasLeavingChildren Then
    state.ArrangeRect = New Rect(x, y, desiredSize.Width, desiredSize.Height)
Else
    state.ArrangeRect = state.PreviousArrangeRect
End If

PanelBase.SetArrangeState(element, state)

Step 9: Use RandomPanel

The RandomPanel is completed and ready to be used in your applications.

XAML
Copy
​xmlns:sample="clr-namespace:ActiproSoftware.Windows.ProductSamples.ViewsSamples.QuickStart.CustomPanelRandom"
...
<sample:RandomPanel>
    <!-- Both buttons will be randomly placed -->
    <Button Content="One" \>
    <Button Content="Two" \>
</sample:RandomPanel>

Step 10: Custom Animations

The RandomPanel supports all same the built-in animations and settings as the built-in panels, as well as any custom animations created. The following will change will have elements entering the scene fly in from random locations, and leaving elements will fly out.

XAML
Copy
​xmlns:views="http://schemas.actiprosoftware.com/winfx/xaml/views"
xmlns:sample="clr-namespace:ActiproSoftware.Windows.ProductSamples.ViewsSamples.QuickStart.CustomPanelRandom"
...
<sample:RandomPanel>
    <sample:RandomPanel.ArrangeAnimation>
        <views:ArrangeAnimation EnterAnimation="Fade,Rotate,Scale,Translate" LeaveAnimation="Fade,Rotate,Scale,Translate"
                ScaleEnterUniformScale="0" ScaleLeaveUniformScale="5" />
    </sample:RandomPanel.ArrangeAnimation>
    <!-- Both buttons will be randomly placed -->
    <Button Content="One" \>
    <Button Content="Two" \>
</sample:RandomPanel>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The animation of the child elements of a PanelBase is delegated to an instance of IArrangeAnimation. The PanelBase.ArrangeAnimation property determines the IArrangeAnimation used. By default, this property is initialized to an instance of ArrangeAnimation.

This topic contains these sections:

  • IArrangeAnimation
  • ArrangeAnimation

IArrangeAnimation

The IArrangeAnimation interface defines the base requirements for an object that can animate the arrangement of a PanelBase's children. The interface defines a single method, GetStoryboard, which is used to get a Storyboard used to animate one or more properties.

The ArrangeAnimation, described below, provides a default implementation of the IArrangeAnimation.

ArrangeAnimation

Represents a default implementation of IArrangeAnimation that allows the animation to be easily configured and/or customized.

See the ArrangeAnimation topic for more information.

Note Note
ArrangeAnimation is a dependency object and uses dependency properties, so it's properties can participate in bindings.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ArrangeAnimation

ArrangeAnimation represents a default implementation of IArrangeAnimation that allows the animation of a panel's child elements to be easily configured and/or customized.

This topic contains these sections:

  • Overview
  • Animation Settings
  • Fade Animation
  • Move Animation
  • Rotate Animation
  • Scale Animation
  • Size Animation
  • Translate Animation

Overview

ArrangeAnimation provides several built-in animations and exposes several configuration options. ArrangeAnimation can be used directly, as the basis for a custom class, or completely replaced.

Elements can have one of several arrange status in its current state, represented by ArrangeStatus. The properties on ArrangeAnimation used to create a Storyboard for an element vary based on its status. Such as the duration of the storyboard, which is controlled by one of the following properties:

Member | Description
EnterDuration Property | Gets or sets the duration of the storyboard applied to elements entering the panel (i.e. ArrangeStatus.Entering)
LeaveDuration Property | Gets or sets the duration of the storyboard applied to elements leaving the panel (i.e. ArrangeStatus.Leaving)
ArrangeUpdateDuration Property | Gets or sets the duration of the storyboard applied to elements changing position/size in the panel due to rearrangement (i.e. ArrangeStatus.ArrangeUpdating)
LayoutUpdateAnimation Property | Gets or sets the duration of the storyboard applied to elements changing position/size in the panel due to a layout logic change (i.e. ArrangeStatus.LayoutUpdating)

There are several animations that apply to certain arrange statuses, which are described in detail below and include:

Animation | Arrange Status
 | Entering | Leaving | ArrangeUpdating | LayoutUpdating
Fade | Yes | Yes | - | -
Move | Yes | Yes | Yes | Yes
Rotate | Yes | Yes | - | -
Scale | Yes | Yes | - | -
Size | - | - | Yes | Yes
Translate | Yes | Yes | - | -

The animations that are applied to each arrange status are configured using the following properties. Each property can be set to zero or more enumeration flag values as defined by ArrangeAnimations. For example, the EnterAnimation can be set to "Fade,Scale" in XAML to have elements entering the panel to fade and scale in.

If one of the following properties includes a flag that is not supported (per the table above), then it will simply be ignored.

Member | Description
EnterAnimation Property | Gets or sets a value indicating the animation that should be applied to elements entering the panel.
LeaveAnimation Property | Gets or sets a value indicating the animation that should be applied to elements leaving the panel.
ArrangeUpdateAnimation Property | Gets or sets a value indicating the animation that should be applied to elements changing position/size in the panel due to rearrangement.
LayoutUpdateAnimation Property | Gets or sets a value indicating the animation that should be applied to elements changing position/size in the panel due to a layout logic change.

Animation Settings

Several "animation settings" properties are provided, which can be used to set properties directly on the DoubleAnimation (or similar) objects created. Represented by the ArrangeAnimationSettings class, it currently allows the acceleration and deceleration ratios to be set.

Fade Animation

The ArrangeAnimations.Fade flag supports animating the Opacity value of the child elements that are entering or leaving the panel. The following properties can be used to configure the resulting animation:

Member | Description
FadeEnterAnimationSettings Property | Gets or sets the fade animation settings used for elements entering the panel.
FadeEnterOpacity Property | Gets or sets the fade animation starting opacity for elements entering the panel.
FadeLeaveAnimationSettings Property | Gets or sets the fade animation settings used for elements leaving the panel.
FadeLeaveOpacity Property | Gets or sets the fade animation ending opacity for elements leaving the panel.

Move Animation

The ArrangeAnimations.Move flag supports animating the X and Y values of the arrange rectangle of the child elements. The following properties can be used to configure the resulting animation:

Member | Description
MoveArrangeUpdateAnimationSettings Property | Gets or sets the move animation settings used for elements updating in the panel due to rearrangement.
MoveEnterAnimationSettings Property | Gets or sets the move animation settings used for elements entering the panel.
MoveEnterPoint Property | Gets or sets the move animation starting point for elements entering the panel. If this property is set to , then the starting point will not be animated. When non-null, the X and Y values determine the starting point using values relative to the panels bounds. If X and Y have a value of -1, then the starting point will be the top-left corner of the panel. If X and Y have a value of 0, then the starting point will be the center of the panel. If X and Y have a value of 1, then the starting point will be the bottom-right corner of the panel. If the values are greater than 1 or less than -1, then the starting point will be off screen by the relative difference. If X or Y are set to double.NaN, then that value will not be animated. For example, this can be used to slide items in from the left by specifying a point of 1.2,NaN. Finally, if X or Y are set to double.PositiveInfinity or double.NegativeInfinity, then that starting value will be determined randomly.
MoveLayoutUpdateAnimationSettings Property | Gets or sets the move animation settings used for elements updating in the panel due to a layout logic change.
MoveLeaveAnimationSettings Property | Gets or sets the move animation settings used for elements leaving the panel.
MoveLeavePoint Property | Gets or sets the move animation starting point for elements leaving the panel. If this property is set to null, then the ending point will not be animated. When non-null, the X and Y values determine the ending point using values relative to the panels bounds. If X and Y have a value of -1, then the ending point will be the top-left corner of the panel. If X and Y have a value of 0, then the ending point will be the center of the panel. If X and Y have a value of 1, then the ending point will be the bottom-right corner of the panel. If the values are greater than 1 or less than -1, then the ending point will be off screen by the relative difference. If X or Y are set to double.NaN, then that value will not be animated. For example, this can be used to slide items in from the left by specifying a point of 1.2,NaN. Finally, if X or Y are set to double.PositiveInfinity or double.NegativeInfinity, then that ending value will be determined randomly.

Rotate Animation

The ArrangeAnimations.Rotate flag supports animating the RotateTransform.Angle value in the RenderTransform of the child elements that are entering or leaving the panel. If the RenderTransform was explicitly set outside of the panel, it will be maintained as the rotation angle is animated. The following properties can be used to configure the resulting animation:

Member | Description
RotateEnterAnimationSettings Property | Gets or sets the rotation animation settings used for elements entering the panel.
RotateEnterTotalAngle Property | Gets or sets the animation's total angle of rotation for elements entering the panel.
RotateLeaveAnimationSettings Property | Gets or sets the rotation animation settings used for elements leaving the panel.
RotateLeaveTotalAngle Property | Gets or sets the animation's total angle of rotation for elements leaving the panel.

Scale Animation

The ArrangeAnimations.Scale flag supports animating the ScaleTransform.ScaleX and ScaleTransform.ScaleY values in the RenderTransform of the child elements that are entering or leaving the panel. If the RenderTransform was explicitly set outside of the panel, it will be maintained as the scale is animated. The following properties can be used to configure the resulting animation:

Member | Description
ScaleEnterAnimationSettings Property | Gets or sets the scale animation settings used for elements entering the panel.
ScaleEnterUniformScale Property | Gets or sets the scale animation starting value for elements entering the panel.
ScaleLeaveAnimationSettings Property | Gets or sets the scale animation settings used for elements leaving the panel.
ScaleLeaveUniformScale Property | Gets or sets the scale animation ending value for elements leaving the panel.

Size Animation

The ArrangeAnimations.Size flag supports animating the Width and Height values of the arrange rectangle of the child elements. The following properties can be used to configure the resulting animation:

Member | Description
SizeArrangeUpdateAnimationSettings Property | Gets or sets the size animation settings used for elements updating in the panel due to rearrangement.
SizeLayoutUpdateAnimationSettings Property | Gets or sets the size animation settings used for elements updating in the panel due to a layout logic change.

Translate Animation

The ArrangeAnimations.Translate flag supports animating the TranslateTransform.X and TranslateTransform.Y values in the RenderTransform of the child elements that are entering or leaving the panel. If the RenderTransform was explicitly set outside of the panel, it will be maintained as the translation is animated. The following properties can be used to configure the resulting animation:

Member | Description
TranslateEnterAnimationSettings Property | Gets or sets the translate animation settings used for elements entering the panel.
TranslateEnterPoint Property | Gets or sets the translate animation starting point for elements entering the panel. The X and Y values determine the starting point using values relative to the panels bounds. If X and Y have a value of -1, then the starting point will be the top-left corner of the panel. If X and Y have a value of 0, then the starting point will be the center of the panel. If X and Y have a value of 1, then the starting point will be the bottom-right corner of the panel. If the values are greater than 1 or less than -1, then the starting point will be off screen by the relative difference. If X or Y are set to double.NaN, then that value will not be animated. For example, this can be used to slide items in from the left by specifying a point of 1.2,NaN. Finally, if X or Y are set to double.PositiveInfinity or double.NegativeInfinity, then that starting value will be determined randomly.
TranslateLeaveAnimationSettings Property | Gets or sets the translate animation settings used for elements leaving the panel.
TranslateLeavePoint Property | Gets or sets the translate animation ending point for elements leaving the panel. The X and Y values determine the ending point using values relative to the panels bounds. If X and Y have a value of -1, then the ending point will be the top-left corner of the panel. If X and Y have a value of 0, then the ending point will be the center of the panel. If X and Y have a value of 1, then the ending point will be the bottom-right corner of the panel. If the values are greater than 1 or less than -1, then the ending point will be off screen by the relative difference. If X or Y are set to double.NaN, then that value will not be animated. For example, this can be used to slide items in from the left by specifying a point of 1.2,NaN. Finally, if X or Y are set to double.PositiveInfinity or double.NegativeInfinity, then that ending value will be determined randomly.

Both TranslateEnterPoint and TranslateLeavePoint leverage a custom type converter that supports common terms. For example, instead of specifying the enter point a "0,0" (or the center), the string "Center,Center" can be used. The following table lists common values and their associated names:

Value | Supported Names
double.NaN | None, Fixed, NaN
double.PositiveInfinity | Random, PositiveInfinity, +Infinity
double.NegativeInfinity | Random, NegativeInfinity, -Infinity

The following table lists common values and their associated names that are valid for the X value:

Value | Supported Names
-1.5 | FarLeft
-1.0 | Left
0 | Center
1.0 | Right
1.5 | FarRight

The following table lists common values and their associated names that are valid for the Y value:

Value | Supported Names
-1.5 | FarTop
-1.0 | Top
0 | Center
1.0 | Bottom
1.5 | FarBottom

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Views follows WPF best practices for areas such as layout, globalization and accessibility.

Some of the more major features include:

  • Right-to-left support is fully integrated for languages such as Hebrew or Arabic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Flow Direction

Views panels supports both left-to-right and right-to-left layouts via a simple property switch.

By default, the controls will use the flow direction designated by the system.

What is Flow Direction?

The flow direction of content typically corresponds to the innate flow direction of the language being represented. English, German, and Russian provide examples of languages that naturally flow from left-to-right. Hebrew and Arabic provide examples of languages that naturally flow from right-to-left.

When a right-to-left flow direction is applied to a user interface control, all contained content is essentially "flipped" over to align to the opposite side as displayed below:

AnimatedStackPanel using left-to-right (top) and right-to-left (bottom) flow directions

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Views has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to quickly create and add items to your panels.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • Book / BookPage Context Menus
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

Book / BookPage Context Menus

Context menus for both the Book and BookPage types are provided. You can right click on either of those controls in the designer to display the related context menu.

Both variations of the context menu include items for:

  • Adding a new page
  • Navigating to the first page
  • Navigating to the previous page
  • Navigating to the next page
  • Navigating to the last page

The context menu for BookPage controls includes an additional menu item for removing that particular page.

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Wizard is the premiere control for building wizard dialogs in WPF (Windows Presentation Foundation) that conforms to the Aero Wizard and Wizard97 specifications.

Wizard has been designed from the ground up to follow WPF best practices, be extremely configurable, and dramatically cut down on the time needed to implement a robust wizard dialog. From simple linear sequences of pages to more advanced decision-based page execution paths, Wizard can handle it all. It provides an amazing number of features that make the design and run-time experience for the developer and end user a positive one.

To get started using the control, read through this documentation and study the many QuickStarts in the sample project. The sample includes live demos of many of Wizard's features.

What is a Wizard Dialog?

Wizards are one of the best ways to simplify the user experience of applications. They allow developers to take complex tasks and break them up into a series of simple steps. Each step in a wizard is represented by a page that provides specialized explanations and controls related to that step.

A sample Wizard97-style welcome page and a sample Aero-style page

Wizard dialogs are used in many scenarios, such as for collecting data from the end user or guiding the end user through the configuration of some feature of an application.

In a wizard dialog, pages are visited in a developer-specified order to ensure that steps are completed in a certain sequence. The end user clicks Back and Next buttons to navigate through the wizard pages. Upon reaching the finish page for a set of steps, a Finish button can be clicked to complete the wizard.

Features

Page and Button Features

  • Multiple built-in page types:
    • Exterior - Welcome/finish with left watermark area.
    • Interior - Step with top header area.
    • Blank - Customizable for a unique user interface.
  • Page captions and descriptions that display in the header area of the page.
  • Page titles that can be used to update the title bar of the containing Window.
  • Multiple options for automated updating of the containing Window title bar text.
  • Global default settings for all button visibility and enabled states that can be overridden by page-specific settings.
  • Toggle button visibility and enabled states at run-time via code.
  • Uses WPF command model for handling all button clicks.
  • Multiple options for setting the default and cancel buttons on the containing Window to wizard buttons.
  • The Cancel and Finish buttons can set the appropriate Window.DialogResult and close the containing Window. This behavior can be changed.
  • Lazily initialize pages if needed.

Appearance Features

  • Numerous built-in animated page transition effect options including:
    • None - Instant page change.
    • Barn door wipe - A wipe transition between two pages that uses two straight bars with a configurable gradient spread.
    • Bar wipe - A wipe transition between two pages that uses a straight bar with a configurable gradient spread.
    • Box wipe - A wipe transition between two pages that uses a box.
    • Fade - The old selected page fades into the new one with optional blur effect.
    • Faded zoom - A crossfade transition between two elements that zooms the new content in as well.
    • Four box wipe - A wipe transition between two pages that uses four boxes.
    • Slide - A slide transition between two pages that moves one page over the other.
    • Push - A slide transition between two pages that pushes one page out of the way for the other.
    • Wedge wipe - A wipe transition between two pages that uses a wedge shape.
  • Ability to create custom page transition effects.
  • Randomly choose between multiple transitions or write custom logic to choose transitions for each page change.
  • Page transition duration and effect direction options.
  • Page transitions capable of reversing for backwards progress through pages.
  • An Aero Wizard style that mimics the wizards found in Windows Vista.
  • Vista-like command buttons that can be used in Aero wizards or anywhere else.
  • Built-in default styles and templates for exterior and interior pages.
  • Ability to create custom styles and templates for any page as well as override defaults.
  • Ability to create custom styles and templates for the button container area to completely change its look and/or contents.
  • Ability to use custom button container templates to do things like align the Help button on the right side, or show the Finish button in the same space as the Next button.
  • Create completely custom page designs.
  • Create WPF-based slide show presentations using Wizard.

Navigation Features

  • WPF commands defined for going to the next or previous pages.
  • WPF commands for jumping forward to or backwards to a specific page, as indicated by its direct reference, name, or index.
  • Any wizard command can be assigned to custom controls such as Buttons, Hyperlinks, or MenuItems.
  • Default page sequencing which visits pages in their order by index can be overridden to support decision-based branching of page execution paths.
  • The next and previous pages for each page can be explcitly set by a direct reference, name, or index.
  • Two types of backwards progress page sequencing, normal and stack-based.
  • Disable pages to have Wizard skip over them when using default page sequencing.
  • Ability to programmatically get/set the selected page by reference or index.
  • Process selection changing/changed events at the general Wizard or WizardPage-specific levels.
  • Selection change events specify what caused the change, which pages are changing, and allow you to cancel the change or choose a new destination page.
  • Validate data on a page in the selection changing event.
  • Differentiation between forward and backward progress through wizard pages.
  • Easily navigate through pages using the mouse and/or keyboard forward/back buttons.

Layout, Globalization, and Accessibility Features

  • Adheres to the Wizard97 and Aero Wizard specifications.
  • Easily create wizard user interfaces in XAML markup.
  • All parts of the wizard use automatic layout so that they are capable of growing as needed.
  • Right-to-left support is fully integrated for languages such as Hebrew or Arabic.
  • All text properties use localization attributes.
  • Follows the WPF accessibility model for UI automation.

Code and Requirements

  • Includes detailed documentation and a sample project that demos nearly every feature.
  • Written in 100% pure C# and is based on the Windows Presentation Foundation framework.
  • Requires the .NET 4.0 or later run-time framework.
  • Full XAML support and XBAP compatibility.
  • Extensive Visual Studio and Expression Blend designer capabilities.
  • Visual Studio and/or Expression Blend are recommended development tools for this product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Getting up and running with Wizard is extremely easy. Wizard provides all the wizard-related user interface features right out of the box, saving you hours of work.

This topic's information will assume you are using Visual Studio to write your XAML code for a WPF Window that will contain a Wizard control.

This topic contains these sections:

  • Add Assembly References
  • The Visual Studio Item Templates (Wizard, Aero Wizard)
  • Create a WPF Window
  • Declare the Wizard XML Namespace
  • Add a Wizard Control
  • Add a Welcome Page
  • Add an Interior Page
  • Customize These Pages and Add More Pages
  • The "Getting Started" QuickStart
  • Further Study

Add Assembly References

First, add references to the ActiproSoftware.Shared.Wpf.dll and ActiproSoftware.Wizard.Wpf.dll assemblies. They should have been installed in the GAC during the control installation process. However they also will be located in the appropriate Program Files folders. See the product's Readme for details on those locations.

The Visual Studio Item Templates (Wizard, Aero Wizard)

If you have Visual Studio, item templates named Wizard Window (WPF) and Aero Wizard Window (WPF) should have been installed during the WPF Studio installation procedure.

When you wish to create a new Window containing a Wizard or AeroWizard in your application, simply choose Add New Item in Visual Studio and select the appropriate item template. A Window with a Wizard and a couple pages already on it will be added to your project and opened.

The use of item templates is the fastest way to get started with our products in your own applications.

Create a WPF Window

Next, create a new empty WPF Window that looks like this:

XAML
Copy
​<Window x:Name="window" x:Class="Sample.Application.Window"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    Width="600" SizeToContent="Height" ResizeMode="CanResize"
    >

</Window>

Note that by using those Width, SizeToContent, and ResizeMode settings, the Window will keep a fixed width of 600 pixels but will grow vertically as needed to fit the contents of the Wizard we will add next.

Declare the Wizard XML Namespace

Now in the root Window tag, add an xmlns declaration for the wizard namespace like this:

XAML
Copy
​<Window x:Name="window" x:Class="Sample.Application.Window"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
    xmlns:wizard="http://schemas.actiprosoftware.com/winfx/xaml/wizard"
    Width="600" SizeToContent="Height" ResizeMode="CanResize"
    >

</Window>

The xmlns attribute declares that the use of the wizard namespace in this Window refers to types in the ActiproSoftware.Windows.Controls.Wizard namespace within the ActiproSoftware.Wizard.Wpf assembly.

Add a Wizard Control

Next, add a Wizard control as the sole child of the Window:

XAML
Copy
​<wizard:Wizard x:Name="wizard" WindowTitleBehavior="PageTitle" WindowTitleBaseText="Wizard Sample" PageSequenceType="Stack"
    BackwardProgressTransitionDuration="0:0:0.5" ForwardProgressTransitionDuration="0:0:0.5">
    <wizard:Wizard.TransitionSelector>
        <shared:MultiTransitionSelector>
            <!-- This adds a single bar wipe transition -->
            <shared:BarWipeTransition />
        </shared:MultiTransitionSelector>
    </wizard:Wizard.TransitionSelector>

</wizard:Wizard>

Note that several optional attributes were also added, making the Wizard add the current page's Title property to the Window's title, setting up stack-based page sequencing, and activating half-second wipe transition effects.

Add a Welcome Page

Next, add a welcome WizardPage as an item of the Wizard control:

XAML
Copy
​<wizard:WizardPage x:Name="welcomePage" PageType="Exterior"
                Caption="Welcome to the Wizard Sample Application"
                Description="Thank you for downloading the Actipro Wizard control.">
            <Grid>
                <Grid.RowDefinitions>
                    <RowDefinition Height="*" />
                    <RowDefinition Height="Auto" />
                </Grid.RowDefinitions>

                <TextBlock Grid.Row="1" TextWrapping="Wrap">To continue, click Next.</TextBlock>
            </Grid>
        </wizard:WizardPage>

The welcome page is an exterior page, which means it has a watermark area on the left side. It can be further customized to add header images and backgrounds later but for now we will stick with the default.

Add an Interior Page

Next, add an interior WizardPage as an item of the Wizard control after the existing welcome page:

XAML
Copy
​<wizard:WizardPage x:Name="interiorPage"
        Caption="Interior Page Sample"
        Description="This is a sample interior page that represents a step in your wizard."
        Title="Interior Page">
    <TextBlock TextWrapping="Wrap">Add your content here.</TextBlock>
</wizard:WizardPage>

Customize These Pages and Add More Pages

Now simply customize these pages by adding more content and perhaps some images. Then continue adding more pages as needed to complete your wizard.

As the sample currently stands, it will iterate through the pages in sequential order and will enable the Finish button on the final page.

The complete sample code is:

XAML
Copy
​<Window x:Name="window" x:Class="Sample.Application.Window"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
    xmlns:wizard="http://schemas.actiprosoftware.com/winfx/xaml/wizard"
    Width="600" SizeToContent="Height" ResizeMode="CanResize"
    >

    <wizard:Wizard x:Name="wizard" WindowTitleBehavior="PageTitle" WindowTitleBaseText="Wizard Sample" PageSequenceType="Stack"
        BackwardProgressTransitionDuration="0:0:0.5" ForwardProgressTransitionDuration="0:0:0.5">
        <wizard:Wizard.TransitionSelector>
            <shared:MultiTransitionSelector>
                <!-- This adds a single bar wipe transition -->
                <shared:BarWipeTransition />
            </shared:MultiTransitionSelector>
        </wizard:Wizard.TransitionSelector>

        <wizard:WizardPage x:Name="welcomePage" PageType="Exterior"
                Caption="Welcome to the Wizard Sample Application"
                Description="Thank you for downloading the Actipro Wizard control.">
            <Grid>
                <Grid.RowDefinitions>
                    <RowDefinition Height="*" />
                    <RowDefinition Height="Auto" />
                </Grid.RowDefinitions>

                <TextBlock Grid.Row="1" TextWrapping="Wrap">To continue, click Next.</TextBlock>
            </Grid>
        </wizard:WizardPage>

        <wizard:WizardPage x:Name="interiorPage"
                Caption="Interior Page Sample"
                Description="This is a sample interior page that represents a step in your wizard."
                Title="Interior Page">
            <TextBlock TextWrapping="Wrap">Add your content here.</TextBlock>
        </wizard:WizardPage>

    </wizard:Wizard>

</Window>

The "Getting Started" QuickStart

The "Getting Started" QuickStart for Wizard (source code is in the sample project) has implemented the full source for this topic and is a great place to copy code from to start on your own wizards.

To use the source code files for the "Getting Started" QuickStart, run the Sample Browser and navigate to the "Getting Started" QuickStart. Then click the Open Folder button above it to open an explorer window in the folder that contains the source code. You can copy those files to your own project. Alternatively, just use the Visual Studio item template we've created (described above).

Further Study

It's very easy to use Wizard and there are probably a lot of great features that you aren't aware of.

Run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of Wizard.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Wizard defines several types of pages and makes it easy to work with the wizard buttons.

Some of the more major features include:

  • Multiple built-in page types:
    • Exterior - Welcome/finish with left watermark area.
    • Interior - Step with top header area.
    • Blank - Customizable for a unique user interface.
  • Page captions and descriptions that display in the header area of the page.
  • Page titles that can be used to update the title bar of the containing Window.
  • Multiple options for automated updating of the containing Window title bar text.
  • Global default settings for all button visibility and enabled states that can be overridden by page-specific settings.
  • Toggle button visibility and enabled states at run-time via code.
  • Uses WPF command model for handling all button clicks.
  • Multiple options for setting the default and cancel buttons on the containing Window to wizard buttons.
  • The Cancel and Finish buttons can set the appropriate Window.DialogResult and close the containing Window. This behavior can be changed.
  • Lazily initialize pages if needed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Page Types

Wizard defines three distinct page types: Exterior, Interior, and Blank.

Page types are only used in determining which default style will be applied the page and do not affect the wizard behavior in any other way.

This topic contains these sections:

  • Setting the Page Type
  • Exterior Pages
  • Interior Pages
  • Blank Pages

Setting the Page Type

The WizardPage.PageType property designates the type of page. It can be set to a value of the WizardPageType enumeration.

The default page type is Interior. Therefore interior pages do not need the page type to be set.

This XAML code shows how the page type can be set declaratively:

XAML
Copy
​<wizard:WizardPage x:Name="welcomePage" PageType="Exterior"></wizard:WizardPage>

Exterior Pages

Exterior pages typically come at the beginning and end of the wizard. In those scenarios, they are termed Welcome pages and Completion/Finish pages, respectively.

An exterior page

Exterior pages have a watermark area that appears on the left side of the page. By default this area is filled with the system highlight color but it is encouraged that some sort of fancy graphic or gradient background be placed there. The WizardPage.HeaderBackground property designates the Brush that is used to fill the background of the watermark area. The watermark area also typically includes a small page image near the upper right of the watermark area. This image can be set via the WizardPage.HeaderImage property. The margin around the image is set via the WizardPage.HeaderImageMargin property.

The right side of an exterior page is filled with the system window color by default. A large header label near the top of this content area displays the value of the WizardPage.Caption property. Another label is placed under the header and is used to provide an extended description, which is pulled from the WizardPage.Description property. Set either of the two properties to null to prevent them from displaying.

Interior Pages

Interior pages typically appear as the "inner" pages of the wizard.

An interior page

Interior pages have a header area that stretches across the top of the page that displays the page's caption in bold, and its description underneath it. These are controlled by the values of the WizardPage.Caption and WizardPage.Description properties respectively. By default the header background is filled with the system window color. The WizardPage.HeaderBackground property designates the Brush that is used to fill the background of the header. Additionally, an image appears at the right side of the header. This image can be set via the WizardPage.HeaderImage property. The margin around the image is set via the WizardPage.HeaderImageMargin property.

The content area of the page, filled with the system control color by default, appears underneath the header.

Blank Pages

Blank pages have no real template applied to them other than their content filling the page. Therefore it is up to the developer to design the contents of a blank page.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Page Captions, Descriptions, and Titles

Wizard pages all have a unique a caption, description, and title. Each property is designed for a certain purpose.

Wizard also makes it simple to automatically update the containing Window's title based on the current page selection. There are even numerous options for formatting the title.

This topic contains these sections:

  • Page Captions and Descriptions
  • Page Titles
  • Modifying the Containing Window's Title

Page Captions and Descriptions

Each page has WizardPage.Caption and WizardPage.Description properties. A page's caption is a small phrase that is typically displayed in a bold or large font as header text for the page. A page's description is one or more sentences that gives a brief description of the page. The description typically appears directly under the page's caption.

See the Page Types topic for details on where the page's caption and description appear in the interior and exterior page templates.

Page Titles

Each page also has a WizardPage.Title property. The title of a wizard page typically is not directly visible within a page, however it can be used to construct the title for the containing Window.

See the section below on modifying Window titles for more information on how to use the page's title.

Modifying the Containing Window's Title

Wizard has numerous features to automatically update the containing Window's title based on the selected page.

The first step in choosing how to automatically modify the Window title is to choose the title behavior. The Wizard.WindowTitleBehavior property gets and sets an enumeration value of type WizardWindowTitleBehavior that determines the title behavior. These are the values of that enumeration:

Value | Description
None | Do not modify the containing Window control's title.
PageTitle | Displays the text in the Wizard.WindowTitleBaseText property appended by a dash and the text in the current page's Title property.
PageCaption | Displays the text in the Wizard.WindowTitleBaseText property appended by a dash and the text in the current page's Caption property.
Custom | Displays the text in the Wizard.WindowTitleBaseText property appended by the text in the Wizard.WindowTitleCustomPageText property, which defaults to - Step {0} of {1}. If using step numbers, this title behavior is only useful for Wizards that do not have multiple execution paths. See below for more information on the various settings for the Wizard.WindowTitleCustomPageText property.

Note that several of the title behaviors append some text onto the base text in the Wizard.WindowTitleBaseText property. Therefore the text you normally would have set to the Window.Title property should be set to this property.

When a Custom title behavior is chosen, the Wizard.WindowTitleCustomPageText is used. It is passed as the format string to a String.Format call. Multiple format items are passed in as parameters to this String.Format call:

Index | Description
0 | The current page index incremented by 1 for display purposes. This item is only useful for wizard that have a single linear execution path.
1 | The total number of pages. This item is only useful for wizard that have a single linear execution path.
2 | The page title.
3 | The page caption.
4 | The page description.

Say that you were designing a SQL connection wizard and you wanted your wizard's containing Window title to display a title in this format: SQL Connection Wizard : (WizardPage Title) - Step (Page #) of (Page Count). To achieve that you would use these settings:

Member | Value
Wizard.WindowTitleBehavior Property | Custom
Wizard.WindowTitleBaseText Property | SQL Connection Wizard
Wizard.WindowTitleCustomPageText Property | : {2} - Step {0} of {1}

This XAML code shows how to use simple page title-based Window titles for a registration wizard:

XAML
Copy
​<wizard:Wizard x:Name="wizard" WindowTitleBehavior="PageTitle" WindowTitleBaseText="Registration Wizard"></wizard:Wizard>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Button States

Wizard allows total control over its button visibility and enabled states at both a global wizard level and at a page-specific override level.

Global settings made on the Wizard control are default settings for all contained pages. Settings made on a WizardPage can choose to inherit the global Wizard settings or override them with page-specific settings. The page-specific settings take effect while that particular page is selected.

These settings are used by the Wizard command model to determine whether the associated commands should be enabled. See that topic for more information on how to use the commands.

This topic contains these sections:

  • Wizard Global Default Button State Settings
  • WizardPage Instance Button State Settings
  • Setting At Run-Time

Wizard Global Default Button State Settings

These Wizard properties are used as the default settings for all pages within the Wizard:

Member | Description
HelpButtonVisible Property | A Boolean that indicates whether the Help button is visible.
CancelButtonVisible Property | A Boolean that indicates whether the Cancel button is visible.
BackButtonVisible Property | A Boolean that indicates whether the Back button is visible.
NextButtonVisible Property | A Boolean that indicates whether the Next button is visible.
FinishButtonVisible Property | A Boolean that indicates whether the Finish button is visible.
HelpButtonEnabled Property | A Boolean that indicates whether the Help button is enabled.
CancelButtonEnabled Property | A Boolean that indicates whether the Cancel button is enabled.
BackButtonEnabled Property | A nullable Boolean that indicates whether the Back button is enabled. A true or false value sets the Wizard default. Specifying null uses the enabled logic for the PreviousPage command as described in the command model topic.
NextButtonEnabled Property | A nullable Boolean that indicates whether the Next button is enabled. A true or false value sets the Wizard default. Specifying null uses the enabled logic for the NextPage command as described in the command model topic.
FinishButtonEnabled Property | A nullable Boolean that indicates whether the Finish button is enabled. A true or false value sets the Wizard default. Specifying null uses the enabled logic for the Finish command as described in the command model topic.

WizardPage Instance Button State Settings

These WizardPage properties are used as page-specific settings that may override the Wizard global settings:

Member | Description
HelpButtonVisible Property | A nullable Boolean that indicates whether the Help button is visible. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.
CancelButtonVisible Property | A nullable Boolean that indicates whether the Cancel button is visible. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.
BackButtonVisible Property | A nullable Boolean that indicates whether the Back button is visible. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.
NextButtonVisible Property | A nullable Boolean that indicates whether the Next button is visible. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.
FinishButtonVisible Property | A nullable Boolean that indicates whether the Finish button is visible. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.
HelpButtonEnabled Property | A nullable Boolean that indicates whether the Help button is enabled. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.
CancelButtonEnabled Property | A nullable Boolean that indicates whether the Cancel button is enabled. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.
BackButtonEnabled Property | A nullable Boolean that indicates whether the Back button is enabled. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.
NextButtonEnabled Property | A nullable Boolean that indicates whether the Next button is enabled. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.
FinishButtonEnabled Property | A nullable Boolean that indicates whether the Finish button is enabled. A true or false value overrides the Wizard default. Specifying null uses the Wizard default.

Setting At Run-Time

All of these properties may be changed at run-time programmatically to update the user interface button states.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Window Default/Cancel Buttons

Wizard makes it easy to set the default or cancel buttons of a containing Window to one of the wizard's buttons.

This topic contains these sections:

  • Window Default Button
  • Window Cancel Button

Window Default Button

The Window's default button is clicked whenever the Enter key is pressed on the keyboard.

The default button can be set to one of the wizard buttons by setting the Wizard.WindowDefaultButton property to one of these WizardWindowDefaultButton values:

Value | Description
None | No wizard button is the default button.
Next | The Next button is the default button.
Finish | The Finish button is the default button.
FinishThenNext | The Finish button is the default button if the Finish button is visible and enabled. Otherwise, the Next button is the default button.
NextThenFinish | The Next button is the default button if the Next button is visible and enabled. Otherwise, the Finish button is the default button.

The default value is FinishThenNext.

This XAML code shows how to turn off the automatic wizard default button so that another Button may be set as the default button on the containing Window:

XAML
Copy
​<wizard:Wizard WizardWindowDefaultButton="None"></wizard:Wizard>

Window Cancel Button

The Window's cancel button is clicked whenever the Escape key is pressed on the keyboard.

The cancel button can be set to one of the wizard buttons by setting the Wizard.WindowCancelButton property to one of these WizardWindowCancelButton values:

Value | Description
None | No wizard button is the cancel button.
Cancel | The Cancel button is the cancel button.

The default value is Cancel.

This XAML code shows how to turn off the automatic wizard cancel button so that another Button may be set as the cancel button on the containing Window:

XAML
Copy
​<wizard:Wizard WizardWindowCancelButton="None"></wizard:Wizard>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Window Close On Finish/Cancel Button Clicks

By default, Wizard will attempt to close the containing Window when the Finish or Cancel buttons are clicked.

Wizard can also be configured to set the DialogResult of the Window before it is closed (not enabled by default).

This topic contains these sections:

  • Preventing The Finish/Cancel Buttons From Performing Their Default Behavior
  • Setting the Window DialogResult

Preventing The Finish/Cancel Buttons From Performing Their Default Behavior

Both the Finish and Cancel buttons raise numerous events when they are clicked.

The Finish button raises these cancellable events in sequential order:

  • Wizard.PreviewFinish
  • WizardPage.Finish on the selected page
  • Wizard.Finish

If at the end of those events the Wizard.FinishButtonClosesWindow property is set to true, the containing Window's DialogResult will be set to true and the Window will be closed.

The Cancel button raises these cancellable events in sequential order:

  • Wizard.PreviewCancel
  • WizardPage.Cancel on the selected page
  • Wizard.Cancel

If at the end of those events the Wizard.CancelButtonClosesWindow property is set to true, the containing Window's DialogResult will be set to false and the Window will be closed.

Setting the Window DialogResult

By default, no DialogResult will be set on the parent Window when the Finish or Cancel buttons are clicked. However by changing the Wizard.IsWindowDialogResultUpdatingEnabled property to true, the Finish button will set the DialogResult to true and the Cancel button will set it to false.

This feature should only be enabled when the wizard is on a modal Window.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Wizard supports complete user interface customization and has some special effects like animated page transitions.

Some of the more major features include:

  • Numerous built-in animated page transition effect options including:
    • None - Instant page change.
    • Barn door wipe - A wipe transition between two pages that uses two straight bars with a configurable gradient spread.
    • Bar wipe - A wipe transition between two pages that uses a straight bar with a configurable gradient spread.
    • Box wipe - A wipe transition between two pages that uses a box.
    • Fade - The old selected page fades into the new one with optional blur effect.
    • Four box wipe - A wipe transition between two pages that uses four boxes.
    • Slide - A slide transition between two pages that moves one page over the other.
    • Push - A slide transition between two pages that pushes one page out of the way for the other.
    • Wedge wipe - A wipe transition between two pages that uses a wedge shape.
  • Ability to create custom page transition effects.
  • Randomly choose between multiple transitions or write custom logic to choose transitions for each page change.
  • Page transition duration and effect direction options.
  • Page transitions capable of reversing for backwards progress through pages.
  • An Aero Wizard style that mimics the wizards found in Windows Vista.
  • Vista-like command buttons that can be used in Aero wizards or anywhere else.
  • Built-in default styles and templates for exterior and interior pages.
  • Ability to create custom styles and templates for any page as well as override defaults.
  • Ability to create custom styles and templates for the button container area to completely change its look and/or contents.
  • Ability to use custom button container templates to do things like align the Help button on the right side, or show the Finish button in the same space as the Next button.
  • Create completely custom page designs.
  • Create WPF-based slide show presentations using Wizard.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Transition Effects

Wizard supports numerous types of animated transition effects to add some extra dazzle to your wizard dialogs during selected page changes.

Different transitions may be applied to forward progress page changes and backward progress page changes. This allows you to maybe perform a certain transition effect in one direction for forward movement through pages, and apply it in the opposite direction for backward movement through pages.

This topic contains these sections:

  • Transition Types (Built-In and Custom)
  • Wizard Transition Settings
  • Using a Single Transition Effect
  • Using a Random Transition Effect
  • Adding Custom Logic for Transition Selection
  • Transition Performance When In Debug Mode

Transition Types (Built-In and Custom)

There are numerous built-in transitions that are available for use.

See the Shared Library Animation topic for a detailed list of the transition classes that are available, their options, and even how to create your own custom transitions.

This table shows several of the most popular built-in transitions operating on a wizard page change. Note that there are numerous other built-in transitions available than the ones displayed below.

Transition | Description
FadeTransition | Fades in the new selected page.
SlideTransition | Slides in the new selected page to hide the old one behind it. Slide transitions use a direction parameter.
BarWipeTransition | Wipes from the old selected page to the new. Wipe transitions use a direction parameter.

Wizard Transition Settings

These Wizard properties are used to configure the transition effects:

Member | Description
BackwardProgressTransitionDuration Property | Gets or sets a Duration indicating the duration of backward progress page transitions.
ForwardProgressTransitionDuration Property | Gets or sets a Duration indicating the duration of forward progress page transitions.
TransitionDefaultDirection Property | Gets or sets a TransitionDirection that specifies the default direction for a transition between two pages. Most transitions do make use of a TransitionDirection, however not all do.
TransitionSelector Property | Gets or sets a TransitionSelector that is used to select the Transition to use between two pages. By default, no transition is performed. Add a MultiTransitionSelector with one child Transition to only use one transition. Add a MultiTransitionSelector with more than one child Transition to randomly choose a transition to use.

Each transition uses a Duration to determine how long the effect animates. Many transitions also support the concept of effect directions and other options that can be configured.

Using a Single Transition Effect

This XAML code shows how to use a single diagonal BarWipeTransition for page transitions:

XAML
Copy
​<Window x:Class="Sample.Application.Window"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
    xmlns:wizard="http://schemas.actiprosoftware.com/winfx/xaml/wizard"
    >
    <wizard:Wizard TransitionDefaultDirection="ForwardDown">
        <wizard:Wizard.TransitionSelector>
            <shared:MultiTransitionSelector>
                <shared:BarWipeTransition />
            </shared:MultiTransitionSelector>
        </wizard:Wizard.TransitionSelector>
    </wizard:Wizard>
</Window>

Using a Random Transition Effect

This XAML code shows how to have a Transition randomly selected at run-time for each page change from a supplied list of transitions:

XAML
Copy
​<Window x:Class="Sample.Application.Window"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
    xmlns:wizard="http://schemas.actiprosoftware.com/winfx/xaml/wizard"
    >
    <wizard:Wizard TransitionDefaultDirection="ForwardDown">
        <wizard:Wizard.TransitionSelector>
            <shared:MultiTransitionSelector>
                <shared:FadeTransition TextSearch.Text="Fade" />
                <shared:BarWipeTransition TextSearch.Text="Bar wipe" />
                <shared:BarWipeTransition TextSearch.Text="Bar wipe w/no spread" Spread="0" />
                <shared:BarWipeTransition TextSearch.Text="Bar wipe w/full spread" Spread="1" />
                <shared:BarnDoorWipeTransition TextSearch.Text="Barn door wipe" />
                <shared:BarnDoorWipeTransition TextSearch.Text="Barn door wipe w/no spread" Spread="0" />
                <shared:BarnDoorWipeTransition TextSearch.Text="Barn door wipe w/full spread" Spread="1" />
                <shared:BoxWipeTransition TextSearch.Text="Box wipe" />
                <shared:FourBoxWipeTransition TextSearch.Text="Four box wipe" />
                <shared:WedgeWipeTransition TextSearch.Text="Wedge wipe" />
                <shared:SlideTransition TextSearch.Text="Slide" />
                <shared:SlideTransition TextSearch.Text="Push" IsFromContentPushed="True" />
                <shared:FadedZoomTransition TextSearch.Text="Faded zoom" />
                <shared:FadedZoomTransition TextSearch.Text="Faded zoom w/clip" ClipToBounds="True" />
            </shared:MultiTransitionSelector>
        </wizard:Wizard.TransitionSelector>
    </wizard:Wizard>
</Window>

Adding Custom Logic for Transition Selection

Although the MultiTransitionSelector generally provides the transition selection functionality you need, sometimes there may be cases where you would like to write more robust code to select transitions. To do this, create a class that inherits TransitionSelector and implement its SelectTransition method. Then assign your custom selector to the Wizard.TransitionSelector property.

Transition Performance When In Debug Mode

When running an application in debug mode from Visual Studio, sometimes animation performance is affected and the transitions will not appear to render smoothly. However when running the application outside of the Visual Studio debug process, this should not be an issue.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Aero Wizards

Wizard includes a couple special classes that are used for the creation of wizards the conform to the Aero Wizard standard, like the wizards found in Windows Vista.

Tip Tip
To get started in seconds with an Aero Wizard, use the Aero Wizard Window (WPF) new item template in Visual Studio.

This topic contains these sections:

  • Aero Wizard Style Introduction
  • The AeroWizardWindow and AeroWizard Controls
  • Command Buttons

Aero Wizard Style Introduction

Aero Wizards have a large title area that is Aero glass with the Back button for the wizard appearing in the upper left corner of the window. This provides for consistency with the other explorer-like dialogs in Windows Vista. The window icon and title appear to the right of the Back button.

An Aero Wizard that mimics the Vista Add Printer wizard

Since the Back button is located in the title area, there is no Back button in the button container at the bottom of the wizard.

There is no concept of exterior pages in Aero wizards. Instead, all pages are treated more like interior pages since they have their caption displayed at the top of the client area of the window.

The AeroWizardWindow and AeroWizard Controls

The AeroWizardWindow class that inherits GlassWindow, which in turn inherits the native WPF Window. Its function is provide a proper container for an AeroWizard control.

When an AeroWizardWindow contains an AeroWizard, the wizard will have the style displayed in the screenshot above.

Note that all of the glass rendering and title bar area is handled for you. You can interact with the expanded title bar region just like you would in the true non-client title bar area of the window. This means that double-click to toggle maximization, click and drag to move the window, right click to display the system menu, etc. all work.

Configuring the AeroWizardWindow

When creating an AeroWizardWindow, you will want to set its Icon and Title properties like you would for a normal window, however these will not be used in the traditional sense. Due to the title being drawn in the wizard control, those properties will also need to be set on the wizard control as explained below. However setting them on the AeroWizardWindow is still necessary because that tells Windows which icon and title to display in the Windows task bar for the window.

Configuring the AeroWizard

The AeroWizard class inherits Wizard directly and as such, inherits all of the great features found in wizard that are described in this documentation.

The title bar text should be assigned with the AeroWizard.WindowTitleBaseText property as described in the Page Captions, Descriptions, and Titles topic.

AeroWizard also defines an Icon property that is used to indicate the icon that appears in the title area. These properties are required to be located on the wizard control since its template is what draws the extended title bar area. This also allows the Aero wizard to be used in XBAP and show its icon and title.

That's all that is needed to configure an Aero Wizard. Just use the information in the rest of the Wizard documentation to harness the power of Wizard's large feature set.

Command Buttons

The screenshot above shows two CommandButton controls in the wizard's page. These are special buttons with a title and content. They have smooth animations that change state when the mouse moves over them or when they are clicked.

They usually are presented on pages where large branching choices must be made. In this scenario, disable the Next button for that page and allow the command buttons to choose the wizard's path instead.

The CommandButton.Title property lets you specify the large title for the button and the button's Content is what appears below the title.

The CommandButton.BulletTemplate property will contain an arrow by default, but can be changed.

Use the BackgroundHover and BackgroundPressed properties to further customize the backgrounds that are faded in and out during mouse hover and press events.

You can reuse the command buttons outside of wizard if you wish. This is great in case you want to place them on a custom task dialog.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Themes

This product includes multiple built-in themes for all Office themes and Windows system themes. It is fully extensible so that other product themes can be custom developed. Themes can be tinted towards any color or set of colors, and brush resources from them may be reused.

Note Note
Be sure to read the Actipro Themes product documentation too since that explains in great detail how the themes management works with Actipro controls.

This topic contains these sections:

  • Built-In Themes
  • Theme Catalog
  • Tinting Themes

Built-In Themes

Wizard includes built-in themes for Office blue/black/silver, Aero, Luna blue/olive/silver, Royale, classic, and high-contrast that match the real Office and Windows themes.

Several built-in Wizard themes

Theme Catalog

The WizardThemeCatalog is used to provide dynamic theme-switching to this product, and is automatically registered when WPF loads the system themes from the associated assembly.

To explicitly load and register the theme catalog, call the Register staic method on WizardThemeCatalogRegistrar.

Tinting Themes

Any theme can be completely or partially tinted towards a color or set of colors. The general Tinting topic explains how to perform tinting in detail.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Styles and Templates

Wizard makes extensive use of the style and template features provided in the WPF framework.

Everything from pages to the button container can be completely customized on multiple levels. You may choose to apply certain types of images and backgrounds to pages via our simple WizardPage-level properties. You may wish to define more of a theme for all the pages in your wizard. Or you may even want to redefine the way the pages or the button container look via templates. By doing this, you can determine which controls are in a page's header or in the button container and add your own as needed.

This topic contains these sections:

  • WizardPage Properties
  • Applying Styles
  • Styling the Button Container
  • Templates
  • Changing Button Positions (Next/Finish Button Shared Space)

WizardPage Properties

The WizardPage has a couple properties that control the visual style of the header on the page. For an interior page, the header is the area that is at the top of the page. For an exterior page, the header is the watermark area on the left side of the page.

Member | Description
HeaderBackground Property | Gets or sets the Brush used to draw the background that is displayed in the page header.
HeaderImage Property | Gets or sets the ImageSource that is displayed at the right side of the page header.

This XAML code shows how to load a header image and header background for a page. Both images are specified using pack:// syntax (see the WPF documentation for more info). In this code snippet, the image HatLogo.png is a resource in an assembly named Sample and is in an Images folder. The image WelcomeBG.png is located in the same folder as a resource.

XAML
Copy
​<wizard:WizardPage x:Name="welcomePage" HeaderImage="/Sample;component/Images/HatLogo.png">
    <wizard:WizardPage.HeaderBackground>
        <ImageBrush TileMode="Tile" Stretch="None" Viewport="0,0,164,450"
            ViewportUnits="Absolute" ImageSource="/Sample;component/Images/WelcomeBG.png" />
    </wizard:WizardPage.HeaderBackground>
</wizard:WizardPage>

Since the header background needs a Brush, the sample above says to tile the image if needed and to not stretch it. It also specifies the absolute size of the image, which is 164x450 so that tiling performs correctly.

Applying Styles

The next level of customization is to apply styles to the parts of the wizard. The wizard parts that can be customized are the exterior page style, the interior page style, and the button container style.

Of course, the default styles of any other type of control can be updated. For instance you may wish to apply a new style to any Button in the button container that matches the new style you apply to the button container.

Styles allow for easy application of custom themes

The WPF documentation does a great job of explaining how styles may be applied to controls. In a nutshell, styles may be applied anywhere within a control hierarchy, at an application-level, or in a Generic.xaml resource dictionary.

Additionally you can create a Wizard "theme" containing brushes and styles to use for your wizard. You can register it with the Themes framework and have it automatically be applied when you set the application's current theme to the theme name.

Styling the Button Container

It's a little easier to style the button container. For that control, simply target the WizardButtonContainer type.

This XAML code shows a style for the button container to apply a gradient background and a new border:

XAML
Copy
​<Style TargetType="{x:Type wizard:WizardButtonContainer}">
    <Setter Property="Background">
        <Setter.Value>
            <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                <GradientStop Offset="0" Color="#EBEEFA" />
                <GradientStop Offset="0.4" Color="#D6DAE4" />
                <GradientStop Offset="0.41" Color="#C5C7D1" />
                <GradientStop Offset="1" Color="#D4D8E2" />
            </LinearGradientBrush>
        </Setter.Value>
    </Setter>
    <Setter Property="BorderBrush" Value="#6F7074" />
    <Setter Property="BorderThickness" Value="0,1,0,0" />
</Style>

Templates

Custom templates may be applied via styles for the wizard, pages or the button container.

The sample project contains numerous style/template examples in the Themes child folder. You may use those samples as a base for your own templates.

The real power of templates becomes apparent when you start rearranging where template child controls appear and add your own controls. For instance, perhaps you wish to have a Hyperlink back to your web site in the left part of the button container. No problem... just make a custom button container template.

Changing Button Positions (Next/Finish Button Shared Space)

Some developers prefer to have the Help button on the right side or the button container and others prefer to have the Next and Finish buttons share the same space. In this scenario, the Finish button is only visible on a finish page.

An alternate button container template

Both of these scenarios are perfect situations for a custom button container template. The full source for the alternate button container template used in the screen above is located in the sample project.

Here are some tips for the Next/Finish button sharing space feature. Apply a custom button container template that makes the Next and Finish buttons either share the same space (as in a Grid) or stack them directly next to each other, perhaps with a StackPanel. Set the Wizard. FinishButtonVisible property to false, which means the Finish button will be hidden by default. Then on the finish page for the wizard, set WizardPage. FinishButtonVisible property to true to override the default value and set the WizardPage. NextButtonVisible property to false to hide the Next button on that page. That's it!

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Custom Pages

While Wizard has some built-in page types, exterior and interior pages, there also is a blank page type. By using this page type you can completely create your own visual design for a page.

Creating a Custom Page

A custom page can be created by setting the WizardPage.PageType property to Blank.

This XAML code shows how the Blank page type can be set declaratively:

XAML
Copy
​<wizard:WizardPage x:Name="customPage" PageType="Blank"></wizard:WizardPage>

A blank page has no margin so it allows you to built its contents from scratch, while still being able to take advantage of standard WizardPage features such as button control, etc.

The following sample uses a Grid root element with some shapes to fill in the background. Then some TextBlock elements are added.

A custom page that looks similar to Word 2007

With custom pages, you are only limited by your imagination as far as what you can create.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Slide Shows

Since Actipro Wizard can completely be restyled and templated, it is possible to harness it for many non-traditional uses. One great sample is for making a WPF-based slide show presentation.

A Wizard with a custom template that allows it to function property for a slide show presentation

The screenshot above was made by applying custom styles to the Wizard and WizardPage classes. The WizardButtonContainer was also retemplated so that the back and next buttons appear as arrows, are the only ones present in the wizard, and hide when disabled. The back button is hidden in the screenshot since that is the first "title" slide in the slide show.

The Shared Library's ReflectionContentControl is used to provide the reflection effect for the slide title.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Wizard makes is so easy to navigate between pages, with both declarative settings and the ability to modify navigation programmatically at run-time.

Some of the more major features include:

  • WPF commands defined for going to the next or previous pages.
  • WPF commands for jumping forward to or backwards to a specific page, as indicated by its direct reference, name, or index.
  • Any wizard command can be assigned to custom controls such as Buttons, Hyperlinks, or MenuItems.
  • Default page sequencing which visits pages in their order by index can be overridden to support decision-based branching of page execution paths.
  • The next and previous pages for each page can be explcitly set by a direct reference, name, or index.
  • Two types of backwards progress page sequencing, normal and stack-based.
  • Disable pages to have Wizard skip over them when using default page sequencing.
  • Ability to programmatically get/set the selected page by reference or index.
  • Process selection changing/changed events at the general Wizard or WizardPage-specific levels.
  • Selection change events specify what caused the change, which pages are changing, and allow you to cancel the change or choose a new destination page.
  • Validate data on a page in the selection changing event.
  • Differentiation between forward and backward progress through wizard pages.
  • Easily navigate through pages using the mouse and/or keyboard forward/back buttons.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Command Model

Wizard is designed to use the WPF command model for all wizard functions, which separates the action implementation from the user interface control that executes it. This allows for multiple and disparate sources to invoke the same centralized command logic.

All of the wizard buttons are hooked up to the appropriate command. For instance the Next button uses the NextPage.

This topic contains these sections:

  • Command List
  • NextPage and PreviousPage
  • Finish and Cancel
  • Help
  • GoToPage and BacktrackToPage

Command List

All of these commands are available via static properties on the WizardCommands class:

Member | Description
BacktrackToPage Property | Gets the command that is used to backtrack to the specified page. The Wizard.BacktrackToPage method provides a wrapper for executing this command.
Cancel Property | Gets the command that is used to cancel the wizard. The Wizard.ExecuteCancel method provides a wrapper for executing this command.
Finish Property | Gets the command that is used to finish the wizard. The Wizard.ExecuteFinish method provides a wrapper for executing this command.
GoToPage Property | Gets the command that is used to go directly to the specified page. The Wizard.GoToPage method provides a wrapper for executing this command.
Help Property | Gets the command that is used to display help for the wizard. The Wizard.ExecuteHelp method provides a wrapper for executing this command.
NextPage Property | Gets the command that is used to advance to the next wizard page. The Wizard.GoToNextPage method provides a wrapper for executing this command.
PreviousPage Property | Gets the command that is used to backtrack to the previous wizard page. The Wizard.BacktrackToPreviousPage method provides a wrapper for executing this command.

NextPage and PreviousPage

These commands are used by the wizard's Next and Back buttons.

The next page command follows these execution steps:

  • If a WizardPage.NextPage value is set on the selected page, that page is navigated to using forward progress and the command logic quits.
  • Otherwise, the next enabled sequential page, if any, will be navigated to using forward progress.

The next page command examines the page-specific WizardPage.NextButtonEnabled property to determine whether it is enabled. If that property is null, the WizardPage.NextPage property of the selected page will be examined to see if a specified next page is available. If that property is null, a check will be made to see if there is another enabled wizard page in sequential order after the selected page.

The previous page command follows these execution steps:

  • If a WizardPage.PreviousPage value is set on the selected page, that page is navigated to using backward progress and the command logic quits.
  • Otherwise, the previous enabled sequential page, if any, will be navigated to using backward progress.

The previous page command examines the page-specific WizardPage.BackButtonEnabled property to determine whether it is enabled. If that property is null, the WizardPage.PreviousPage property of the selected page will be examined to see if a specified previous page is available. If that property is null, a check will be made to see if there is another enabled wizard page in sequential order before the selected page.

Both commands raise the appropriate selection changed events when a page change occurs.

This XAML code shows how to use the NextPage command on a Button:

XAML
Copy
​<Button Command="wizard:WizardCommands.Next">Next</Button>

Finish and Cancel

These commands are used by the wizard's Finish and Cancel buttons.

The finish command follows these execution steps:

  • Raises the Wizard.PreviewFinish event.
  • Raises the WizardPage.Finish event on the selected page.
  • Raises the Wizard.Finish event.
  • If the event was not cancelled, the DialogResult of the containing Window will attempt to be set to true, and the Window will attempt to close.

The finish command resolves between the page-specific WizardPage.FinishButtonEnabled property and the wizard-default Wizard.FinishButtonEnabled property to determine whether it is enabled.

The cancel command follows these execution steps:

  • Raises the Wizard.PreviewCancel event.
  • Raises the WizardPage.Cancel event on the selected page.
  • Raises the Wizard.Cancel event.
  • If the event was not cancelled, the DialogResult of the containing Window will attempt to be set to false, and the Window will attempt to close.

The cancel command resolves between the page-specific WizardPage.CancelButtonEnabled property and the wizard-default Wizard.CancelButtonEnabled property to determine whether it is enabled.

This XAML code shows how to use the Finish command on a Button:

XAML
Copy
​<Button Command="wizard:WizardCommands.Finish">Finish</Button>

Help

This command is used by the wizard's Help button.

The help command follows these execution steps:

  • Raises the Wizard.PreviewHelp event.
  • Raises the WizardPage.Help event on the selected page.
  • Raises the Wizard.Help event.

The help command resolves between the page-specific WizardPage.HelpButtonEnabled property and the wizard-default Wizard.HelpButtonEnabled property to determine whether it is enabled.

This XAML code shows how to use the Help command on a Button:

XAML
Copy
​<Button Command="wizard:WizardCommands.Help">Help</Button>

GoToPage and BacktrackToPage

These commands make it extremely easy to navigate directly to a specific page by using forward or backward progress.

The go to page and backtrack to page commands both use a command parameter. The command's parameter may be set to three different types of data:

  • A reference to a WizardPage within the parent Wizard.
  • The name of another WizardPage within the parent Wizard.
  • An integer indicating the index of a WizardPage within the parent Wizard.

The go to page command follows these execution steps:

  • If a valid command parameter has been passed that indicates a page (see above), that page is navigated to using forward progress.

The go to page command examines the supplied command parameter to determine whether it is enabled. See above for a description of the allowed command parameter values.

The backtrack to page command follows these execution steps:

  • If a valid command parameter has been passed that indicates a page (see above), that page is navigated to using backward progress.

The backtrack to page command examines the supplied command parameter to determine whether it is enabled. See above for a description of the allowed command parameter values.

Both commands raise the appropriate selection changed events when a page change occurs.

This XAML code shows how to use the GoToPage command on a Hyperlink to automatically jump to a page with a Name of targetPage:

XAML
Copy
​<TextBlock><Hyperlink Command="wizard:WizardCommands.GoToPage" CommandParameter="targetPage">Go to the target page</Hyperlink></TextBlock>
This XAML code shows how to use the BacktrackToPage command on a Hyperlink to automatically jump back to the first page in the wizard:
XAML
Copy
​<TextBlock><Hyperlink Command="wizard:WizardCommands.BacktrackToPage" CommandParameter="0">Go to the first page</Hyperlink></TextBlock>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Page Sequencing

Wizard has many helpful features for setting up the sequence in which pages will be visited.

The simplest way to set up page sequencing is declaratively in XAML. In addition, default page sequencing may be overridden and page changes can be initiated programmatically.

This topic describes declarative page sequencing. See the Selection Changes topic for more help on cancelling page changes and programmatically overriding page sequence.

This topic contains these sections:

  • Page Sequence Types
  • Setting a Page's Next or Previous Page
  • Disable Pages to Skip Over Them

Page Sequence Types

At the root level, Wizard has two modes of default page sequencing, which are specified by the WizardPageSequenceType enumeration and can be set to the Wizard.PageSequenceType property:

Value | Description
Normal | Normal page sequencing, in which pages are visited in the order in which they appear in the pages collection. Diagram showing how normal page sequencing functions
Stack | Normal page sequencing occurs when the Next button is pressed. Each page visited is stored in an internal stack. Back button presses move backwards through the stack. This feature requires each WizardPage's Name property to be set. The WizardPage.PreviousPage property is ignored when using stack sequencing. Diagram showing how stack page sequencing functions

This XAML code shows how to turn on stack page sequencing for a Wizard:

XAML
Copy
​<wizard:Wizard PageSequenceType="Stack"></wizard:Wizard>

Setting a Page's Next or Previous Page

The WizardPage class has NextPage and PreviousPage properties. These allow you to declaratively override the default page sequencing.

Both properties are of type Object and can accept four types of values:

Value | Description
null | By setting a null value (the default) to those properties, you indicate that the default page sequence type (see above) should be used.
Page Index By setting an integer number value to those properties, you indicate that the next or previous page for the page should be the page at the specified numeric index within the parent Wizard's page collection.

This XAML code shows how to set the explicit next page for a WizardPage to the fifth page in the parent Wizard's pages collection:

XAML
Copy
​<wizard:WizardPage NextPage="4"></wizard:WizardPage>
Page Name By setting a String value to those properties, you indicate that the next or previous page for the page should be the page with the specified name within the parent Wizard's pages collection.

This XAML code shows how to set the explicit previous page for a WizardPage to the page with Name "welcomePage" in the parent Wizard's pages collection:

Code Snippet
Copy
<wizard:WizardPage PreviousPage="welcomePage"></wizard:WizardPage>
Page Reference By setting an explicit WizardPage reference to those properties, you indicate that the next or previous page for the page should be the specified page.

This XAML code shows how to set the explicit next page for a WizardPage to the page with Name "finishPage" in the parent Wizard's pages collection:

XAML
Copy
​<wizard:WizardPage NextPage="{Binding ElementName=finishPage}"></wizard:WizardPage>

Note that in the default page sequence diagrams above, the first page in the diagram, index 0, has a WizardPage.NextPage value of 2, meaning when the Next button is clicked, jump to the third page (since page indices are zero-based) in the Wizard.

It is important to note that when stack-based page sequencing is used, the WizardPage.PreviousPage property will be ignored since the stack will be used in determining which pages to visit on backwards progress.

Disable Pages to Skip Over Them

Default page sequencing will skip over any WizardPage whose IsEnabled property is set to false.

This makes it easy to "turn off" pages temporarily.

Diagram showing how a disabled page is skipped in default page sequencing

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Selection Changes

The selected page in the Wizard can be changed programmatically and numerous cancelable selection changed events fire whenever a page change occurs.

This topic contains these sections:

  • Programmatically Getting or Setting the Selected Page
  • Page Change Event Sequence
  • Page Selection Flags
  • Forward and Backward Progress
  • Overriding Selected Page Changes to a Select a Different Page
  • Canceling Selected Page Changes / Validation

Programmatically Getting or Setting the Selected Page

Wizard has several members that are essential for getting or setting the currently selected page programmatically:

Member | Description
BacktrackToPage Method | Selects the specified page using backward progress.
BacktrackToPreviousPage Method | Selects the previous page using backward progress.
GoToNextPage Method | Selects the next page using forward progress.
GoToPage Method | Selects the specified page using forward progress.
SelectedIndex Property | Gets or sets the index of the selected page within the Items collection. Setting this property uses a WizardPageSelectionFlags value of Default.
SelectedPage Property | Gets or sets the WizardPage that is currently selected. Setting this property uses a WizardPageSelectionFlags value of Default.
SetSelectedIndex Method | Sets the Wizard.SelectedIndex property using the specified WizardPageSelectionFlags value.
SetSelectedPage Method | Sets the Wizard.SelectedPage property using the specified WizardPageSelectionFlags value.

Page Change Event Sequence

Whenever a selected page change occurs, regardless of what caused it, numerous events fire. The event sequence is designed so that you can process the selection change events at either the wizard or page-specific levels.

All of the events receive an informative event argument of type WizardSelectedPageChangeEventArgs that has these important members:

Member | Description
Cancel Property | Gets or sets whether to cancel the selected page change. This property is only useful in the page changing events that fire before the page change occurs.
NewSelectedPage Property | Gets the WizardPage that is about to be selected.
OldSelectedPage Property | Gets the WizardPage that is currently selected.
SelectionFlags Property | Gets a WizardPageSelectionFlags indicating information about the page selection.

The first events that fire upon a page change request are page changing events. These are cancellable events and if the Cancel property is set in these, then the page change will be cancelled and no new selected page will be set.

Page changing events fire in this order:

  • Wizard.PreviewSelectedPageChanging
  • WizardPage.Unselecting on the old selected page
  • WizardPage.Selecting on the new selected page
  • Wizard.SelectedPageChanging

If the page change is not cancelled, then the actual page change will occur and a series of page changed events fire.

Page changed events fire in this order:

  • Wizard.PreviewSelectedPageChanged
  • WizardPage.Unselected on the old selected page
  • WizardPage.Selected on the new selected page
  • Wizard.SelectedPageChanged

Page changed events are a great place to add code to initialize a page that is about to be displayed.

Page Selection Flags

The WizardSelectedPageChangeEventArgs.SelectionFlags property of the event arguments gives you a lot of information about why the selected page change occurred. This lets you better determine whether you may want to take some sort of programmatic action to override or cancel a page change.

The WizardPageSelectionFlags flags enumeration has these values:

Value | Description
BackwardProgress | The page selection is backward progress.
ForwardProgress | The page selection is forward progress.
Programmatic | The page selection was made programmatically.
NextPageCommand | The page selection was made via the WizardCommands.NextPage command.
PreviousPageCommand | The page selection was made via the WizardCommands.PreviousPage command.
GoToPageCommand | The page selection was made via the WizardCommands.GoToPage command.
BacktrackToPageCommand | The page selection was made via the WizardCommands.BacktrackToPage command.
Default | The default flags of Programmatic and ForwardProgress.

Forward and Backward Progress

Wizard tracks a notion of forward and backward progress. This is used in several internal areas such as stack-based page sequencing and for transition effects.

When moving "forward" through pages, it is assumed you are doing things like clicking the Next button. When moving "backward" through pages, it is assumed you are doing things like clicking the Back button.

Transitions use this information so that they can be set to perform their effects in one direction when moving forward, or in another direction when moving backward.

Overriding Selected Page Changes to a Select a Different Page

Sometimes you may wish to abort default page sequencing and provide your own decision-based sequencing instead.

This code shows how to alter the page that will be selected next when a specific page is set and a CheckBox is checked. The new selected page will be programmatically set in this scenario. Note that if the CheckBox is not checked, the default page sequencing will be used.

C#
VB
Copy
​private void wizard_SelectedPageChanging(object sender, WizardSelectedPageChangeEventArgs e) {
    if (e.OldSelectedPage == decisionBasedPage) {
        if (alternatePathCheckBox.IsChecked == true) {
            e.NewSelectedPage = alternatePage;
        }
    }
}
​Private Sub wizard_SelectedPageChanging(ByVal sender As Object, ByVal e As WizardSelectedPageChangeEventArgs)
    If (e.OldSelectedPage Is decisionBasedPage) Then
        If (alternatePathCheckBox.IsChecked = True) Then
            e.NewSelectedPage = alternatePage
        End If
    End If
End Sub

Canceling Selected Page Changes / Validation

As mentioned above, selected page changes may be canceled in any of the page changing events. Functionality of cancelling and not moving to a new page is generally used for data validation purposes.

This code shows how to cancel a page change at the wizard level when a specific page is set and a name TextBox is empty.

C#
VB
Copy
​private void wizard_SelectedPageChanging(object sender, WizardSelectedPageChangeEventArgs e) {
    if (e.OldSelectedPage == dataEntryPage) {
        if (nameTextBox.Text.Length == 0) {
            MessageBox.Show("Please enter a name.");
            e.Cancel = true;
        }
    }
}
​Private Sub wizard_SelectedPageChanging(ByVal sender As Object, ByVal e As WizardSelectedPageChangeEventArgs)
    If (e.OldSelectedPage Is dataEntryPage) Then
        If (nameTextBox.Text.Length = 0) Then
            MessageBox.Show("Please enter a name.")
            e.Cancel = True
        End If
    End If
End Sub

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Navigation Commands

Many of today's computer mice have two extended buttons on them, one for a "forward" action and one for a "backward" action. These are extremely useful for web browsing.

One of the great Microsoft mice with forward/back thumb buttons

Many modern keyboards also have forward and back keyboard buttons that are used for the same purpose.

Windows is set up by default to fire the WPF NavigationCommands.BrowseForward and NavigationCommands.BrowseBack commands when either of those buttons are pressed.

Enabling Mouse/Keyboard Forward/Back Button Navigation

Wizard has a property that controls whether the navigation commands are intercepted and processed. When this property is true and if Wizard intercepts these unhandled commands, it will raise the WizardCommands.NextPage command and WizardCommands.PreviousPage command as appropriate.

By default, Wizard will process the navigation commands. To disable this functionality, set the Wizard.NavigationCommandsEnabled property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Wizard follows WPF best practices for areas such as layout, globalization and accessibility.

Some of the more major features include:

  • Adheres to the Wizard97 and Aero Wizard specifications.
  • Easily create wizard user interfaces in XAML markup.
  • All parts of the wizard use automatic layout so that they are capable of growing as needed.
  • Right-to-left support is fully integrated for languages such as Hebrew or Arabic.
  • All text properties use localization attributes.
  • Follows the WPF accessibility model for UI automation.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automatic Layout

Wizard does not use any fixed sizes for control parts and makes use of automatic layout best practices.

This topic contains these sections:

  • What is Automatic Layout?
  • Best Usability

What is Automatic Layout?

Automatic layout is the ability for a control to resize to its contents. This is very important when an end user uses different fonts than the developer, or in applications that are localized to multiple languages since each language's text may take up more or less room than the same text translated to another language.

When the size of text content, or any other content within Wizard for that matter, does increase, Wizard automatically expands or contracts to fit it. This way you can ensure that long headers are always displayed. Also, if you make visible at run-time a control that is in a layout, Wizard will expand as needed to display the new control. The opposite will occur when hiding a control that is in a layout.

Wizard accomplishes automatic layout by using stack- and grid-based layouts, and never specifying absolute widths or heights. Instead, minimum width and height values are used.

Best Usability

We've found that these settings make for the most ideal end user experience:

  • Set Window.Width on the containing Window to a fixed value like 600, or at least give it a MinWidth and MaxWidth range.
  • Set Window.SizeToContent on the containing Window to Height.

With those settings in place, a consistent wizard width will be used for each page that is displayed. Also, the wizard will maintain a consistent height that is large enough to fit the tallest of pages in the wizard. This means that the buttons in the wizard button container will always appear in the same location for each page, making navigation easier for the end user.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Flow Direction

Wizard supports both left-to-right and right-to-left layouts via a simple property switch.

By default, Wizard will use the flow direction designated by the system.

What is Flow Direction?

The flow direction of content typically corresponds to the innate flow direction of the language being represented. English, German, and Russian provide examples of languages that naturally flow from left-to-right. Hebrew and Arabic provide examples of languages that naturally flow from right-to-left.

When a right-to-left flow direction is applied to a user interface control, all contained content is essentially "flipped" over to align to the opposite side as displayed below:

Wizard switching from left-to-right to right-to-left flow direction

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Localization

All of Wizard's text properties have the Localizability attribute applied to them.

This topic contains these sections:

  • Localizable Wizard Properties
  • Localizable WizardPage Properties

Localizable Wizard Properties

The following properties on the Wizard control are localizable:

  • BackButtonText
  • CancelButtonText
  • FinishButtonText
  • HelpButtonText
  • NextButtonText
  • WindowTitleBaseText
  • WindowTitleCustomPageText

Localizable WizardPage Properties

The following properties on the WizardPage control are localizable:

  • Caption
  • Description
  • Title

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UI Automation

Wizard follows the WPF accessibility model for UI automation.

What is UI Automation?

Microsoft UI Automation is the new accessibility framework for Microsoft Windows. It addresses the needs of assistive technology products and automated test frameworks by providing programmatic access to information about the user interface (UI).

Wizard implements automation peers for the Wizard, WizardPage, and WizardButtonContainer controls. These automation peers allow for programmatic access to those UI elements and their child controls.

Wizard implements a selection control pattern and WizardPage implements a selection item pattern. Selection change events raise the appropriate events on the automation peers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Wizard has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to quickly create and navigate through your wizards.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • Wizard / WizardPage Context Menus
  • Task Pane Introduction
  • Wizard Task Pane
  • WizardPage Task Pane
  • Changing the Selected Page
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

Wizard / WizardPage Context Menus

Context menus for both the Wizard and WizardPage types are provided. You can right click on either of those controls in the designer to display the related context menu.

A WizardPage context menu in the Visual Studio designer

Both variations of the context menu include items for:

  • Adding a new exterior page
  • Adding a new interior page
  • Adding a new blank page
  • Navigating to a specific page
  • Navigating to the first page
  • Navigating to the previous page
  • Navigating to the next page
  • Navigating to the last page

The Go To Page menu item has a sub-menu that lists all the pages in the wizard along with their index number and caption. Click on a page's menu item to jump directly to it.

The context menu for WizardPage controls includes an additional menu item for removing that particular page.

Task Pane Introduction

Whenever you select a Wizard or WizardPage control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

Wizard Task Pane

The Wizard task pane provides quick access to many of the context menu options described above. It also has options for changing global button settings, page sequencing, and several other miscellaneous options.

The task pane for the Wizard control in the Visual Studio designer

A list at the bottom of the task pane shows all of the pages in the wizard. Click on a page to navigate to it in the wizard. Use the mover buttons (up/down) of the selected item in the list to reorder the pages in the wizard.

WizardPage Task Pane

The WizardPage task pane is similar to the Wizard's task page in that it provides access to several of the context menu commands and allows for altering page-specific button settings along with the page type.

The task pane for the WizardPage control in the Visual Studio designer

The WizardPage task pane lets you directly enter the caption, description and title for the page.

Changing the Selected Page

In addition to the methods described above for selecting pages, the Wizard.SelectedPage property in the Properties window has a special drop-down list that allows for visual selection of a page within the Wizard. This allows you to jump directly to a specific page by clicking on it.

The Wizard.SelectedPage drop-down in the Visual Studio designer

The drop-down shows a thumbnail of the page, its index, and name. By hovering the mouse over the thumbnail, you can also see the page's caption and description.

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to v2.0 topic contains information on converting to v2.0 from v1.0.
  • The Converting to v3.0 topic contains information on converting to v3.0 from v2.0.
  • The Converting to v4.0 topic contains information on converting to v4.0 from v3.0 or later.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from an older version.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to v2.0

Changes from Wizard v1.0 to v2.0 included two sets of breaking changes. The first set of changes were made due to reimplementation of the transition effect model to make it much more robust and allow for total customization. The second set of changes were made to rename the properties on the WizardCommands class to be more standardized.

The amount of work on your end needed to upgrade from v1.0 to v2.0 code is very minimal.

This topic contains these sections:

  • Transition Effect Changes
  • WizardCommands Property Renaming

Transition Effect Changes

For v2.0 we reimplemented the transition framework to include many more built-in transition type options, be more customizable, and allow for the creation of any custom transition type.

In v1.0, only three transitions were supported but in v2.0 you now have access to many more built-in transitions, the ability to make your own, and multiple options for selecting which transitions to use.

The breaking changes in this area from v1.0 to v2.0 are:

  • Renamed the AnimationEffectDirection enumeration to TransitionDirection.
  • Removed the BackwardProgressTransitionDirection, BackwardProgressTransitionType, ForwardProgressTransitionDirection, and ForwardProgressTransitionType properties from the Wizard class since they are now replaced by the more customizable TransitionSelector property.
  • Removed the WizardPageTransitionType enumeration since it is no longer needed for the new transition framework.

See the Transition Effects topic for updated information on using the new transition effect framework.

The Shared Library Animation topic also contains details on the built-in transitions that are available, their options, and how to create your own transitions.

WizardCommands Property Renaming

All public ICommand properties on the WizardCommands class have been renamed to not have "Command" in the names since it is redundant and doesn't match Microsoft standards.

For instance WizardCommands.NextPageCommand is now WizardCommands.NextPage, and WizardCommands.CancelCommand is now WizardCommands.Cancel.

These changes should only affect custom button area styles or buttons in your wizards that used the commands.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to v3.0

Changes from Wizard v2.0 to v3.0 had several breaking changes however all but one should be transparent to any wizards developed in v2.0.

This topic contains these sections:

  • Wizard.IsWindowDialogResultUpdatingEnabled Added
  • Enhanced WizardPage Styles
  • Automation Peers Namespace Changed

Wizard.IsWindowDialogResultUpdatingEnabled Added

in v3.0, we added the Wizard.IsWindowDialogResultUpdatingEnabled property, which when set to true will set the DialogResult of the containing Window based on Cancel/Finish button clicks. The default value is false.

In v2.0, this behavior occurred by default so set this property to true where needed.

This is the only breaking change that should affect your code at all. The reason it was changed was that in many scenarios (like in XBAPs or non-modal windows), trying to set the DialogResult will result in an exception. While we had try...catch code around this before, now the exception no longer occurs.

Enhanced WizardPage Styles

In v3.0 we removed the WizardPageStyleSelector class and Wizard.ApplyStyleSelector method since the updated WizardPage's default style does what they used to do.

Automation Peers Namespace Changed

In v3.0 for better namespace management, we moved the objects in the ActiproSoftware.Windows.Automation.Peers namespace to the ActiproSoftware.Windows.Controls.Wizard.Automation.Peers namespace instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to v4.0

During the development of v4.0, we made a commitment to ensure that all our WPF product assemblies are scanned using Visual Studio Code Analysis, and that all warnings are handled appropriately. Code Analysis helps make sure that code is kept up to the highest standards and we are proud to now support it. All of the breaking changes below were made to properly handle Code Analysis warnings.

This topic contains these sections:

  • Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll
  • Removed WizardSelectedPageChangedEventHandler, replace with EventHandler<WizardSelectedPageChangedEventArgs>

Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll

Per Code Analysis guidelines, the WPF portion of the assembly names was renamed to Wpf. If you have any problems with existing references to the assemblies, just remove the old references in your project and new ones. Also be sure your licenses.licx file is up to date with the info listed in the Licensing topic.

Removed WizardSelectedPageChangedEventHandler, replace with EventHandler<WizardSelectedPageChangedEventArgs>

Per Code Analysis, all usage of WizardSelectedPageChangedEventHandler should be replaced with EventHandler<WizardSelectedPageChangedEventArgs>.

The event handler listed above was removed per Code Analysis recommendation and replaced with EventHandler<T> usage. This will probably only affect you if you have created class-based event handlers since those reference the delegates. The base event args classes remain the same.

Instances of usage were:

  • Wizard.PreviewSelectedPageChangedEvent event
  • Wizard.PreviewSelectedPageChangingEvent event
  • Wizard.SelectedPageChangedEvent event
  • Wizard.SelectedPageChangingEvent event
  • WizardPage.Selected event
  • WizardPage.Selecting event
  • WizardPage.Unselected event
  • WizardPage.Unselecting event

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

This topic contains troubleshooting data specific to the Wizard product.

Note Note
For some more troubleshooting information that relates both to this product as well as other WPF Studio products, please see the more general TroubleShooting topic.

This topic contains these sections:

  • Page Transition Animation is Choppy

Page Transition Animation is Choppy

When you are running a project in debug mode from Visual Studio, the debug process affects WPF's performance for things like animations and layouts. Therefore, the page transition animation effects may appear slightly choppy when running the application in debug mode.

If you run a standalone compiled application without any attached debugger you will notice a dramatic increase in performance.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The Actipro WPF Shared library may be freely used by any developer who has a license for one of our WPF control products. It contains a number of useful controls and components that can be reused in your applications.

ActiproSoftware.Windows Namespace (Miscellaneous Useful Classes and Event Arguments)

This namespace contains numerous useful classes and event argument types that may be used in WPF.

See the Windows topic for information on the miscellaneous classes.

ActiproSoftware.Windows.Controls Namespace (Miscellaneous Controls)

This namespace contains various user interface controls that may be used in your applications.

See the Controls topic for information on the controls.

ActiproSoftware.Windows.Controls.ColorSelection Namespace (Color Picker)

This namespace contains several controls for performing color selection similar to that found in Adobe Photoshop or Microsoft Expression Blend.

See the Color Selection topic for information on the color selection controls.

ActiproSoftware.Windows.Data Namespace (Value Converters and Data-Related)

This namespace contains several classes that are helpful for working with data.

See the Data topic for information on the data-related classes.

ActiproSoftware.Windows.DocumentManagement Namespace (Document Management)

This namespace contains several classes that can be used for storing document references and maintaining recent document lists.

See the Document Management topic for information on the document management classes.

ActiproSoftware.Windows.Media Namespace (UIColor, VisualTreeHelperExtended)

This namespace has a UIColor structure that has a lot of helper methods for working with colors and a VisualTreeHelperExtended class that adds some useful methods that aren't in the core VisualTreeHelper class.

See the Media topic for information on these helper classes.

ActiproSoftware.Windows.Media.Animation Namespace (Transition Effects)

This namespace has a number of classes that support animated transitions between two objects. These can be anything from a simple fade to a complex wipe. The transition classes are extensible and provide the foundation for page transitions in our Actipro Wizard for WPF product.

See the Animation topic for information on implementing transition effects.

ActiproSoftware.Windows.Serialization Namespace (Object Serialization)

This namespace contains several classes that are helpful for serializing objects to XAML and persisting hierarchies of data (such as for control layouts) in XML.

See the Serialization topic for information on object serialization.

ActiproSoftware.Windows.Shapes Namespace (Shapes)

This namespace contains various primitive shapes that may be used in your UI.

See the Shapes topic for information on the shapes.

Value Converters

The Shared Library comes packed with numerous useful value converters that can be used with XAML bindings.

See the Value Converters topic for information on the value converters.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Windows

The Windows namespace contains numerous useful classes and event argument types that may be used in WPF.

This topic contains these sections:

  • General
  • Collections
  • Event Arguments

General

These general types are found in the namespace:

Type | Description
DisposableObjectBase | A simple object that implements IDisposable.
ILogicalParent Provides the base requirements for an element that can add and remove logical child elements.
Note Note
This interface is used in conjunction with LogicalChildrenCollection`1.
LogicalTreeHelperExtended | Contains static methods that are useful for performing common tasks with nodes in a logical tree.
ObservableObjectBase | A simple object that implements INotifyPropertyChanged.
Unit | Represents a length measurement in either pixels, inches, centimeters, points, or as a percentage.
UnitType | Specifies the unit of measurement represented by an instance of Unit.

Collections

These collection types are found in the namespace:

Type | Description
DeferrableObservableCollection`1 | Provides an ObservableCollection that is capable of suspending its property change notifications until a bulk update is complete.
EnumerableView`1 | Represents a read-only view on top of an IEnumerable<T> with support for filtering, sorting, and change notifications.
LogicalChildrenCollection`1 | Provides a DeferrableObservableCollection that is capable of adding/removing the logical parent, and optionally the visual parent, of the items in the collection.

Event Arguments

These event argument types are found in the namespace:

Type | Description
CancelRoutedEventArgs | Provides event arguments for a cancelable routed event.
ItemRoutedEventArgs`1 Provides event arguments for an item-related routed event.

The Shared Library also includes some constructed implementations of this generic type:

  • ContextMenuItemRoutedEventArgs
  • DependencyObjectItemRoutedEventArgs
  • ObjectItemRoutedEventArgs
PropertyChangedRoutedEventArgs`1 Provides event arguments for a property change routed event, indicating the old and new values.

The Shared Library also includes some constructed implementations of this generic type:

  • BooleanPropertyChangedRoutedEventArgs
  • DateTimePropertyChangedRoutedEventArgs
  • DoublePropertyChangedRoutedEventArgs
  • NullableDateTimePropertyChangedRoutedEventArgs
  • ObjectPropertyChangedRoutedEventArgs
  • StringPropertyChangedRoutedEventArgs
PropertyChangingRoutedEventArgs`1 Provides event arguments for a cancelable property change routed event, indicating the old and new values.

The Shared Library also includes some constructed implementations of this generic type:

  • StringPropertyChangingRoutedEventArgs

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The Controls namespace contains various user interface controls that may be used in your applications.

The AdvancedTextBlock Control

The AdvancedTextBlock control can show a tooltip when overflowed, and can highlight spans of text based on captured text ranges (i.e. filter match results).

The AnimatedExpander Control

The AnimatedExpander control is a regular Expander that provides optional animated expansion functionality. The animation consists of crossfade and slide behavior.

The AnimatedProgressBar Control

The AnimatedProgressBar control includes all the features of the native WPF ProgressBar, additional features such as animated value updates, animated highlights, and multiple states.

The CustomDrawElement FrameworkElement

The CustomDrawElement element is a simple FrameworkElement that provides a CustomDraw event, allowing for easy, event-based custom rendering.

The DropShadowChrome Decorator

The DropShadowChrome decorator draws a drop-shadow around its content.

The DynamicImage Control

The DynamicImage control is a drop-in replacement for Image that renders the content in grayscale when the control is disabled.

The EditableContentControl Control

The EditableContentControl control is a standard ContentControl, which also features an alternate editing mode that can be toggled to display a TextBox for editing a string.

The GlassWindow Decorator

The GlassWindow control is a Window that allows Vista's Aero glass effects to be extended into the client area of the window.

The HorizontalListBox Control

The HorizontalListBox control is a restyled native ListBox that arranges its items in a uniform width horizontally, and without a ScrollBar.

The ImageTextInfo Class

The ImageTextInfo class is a simple helper class that can be used to store image and text data for databinding.

The PixelSnapper Decorator

The PixelSnapper decorator snaps the measurement of its child content to integer values, thereby helping to prevent blurry images and borders that may appear after it.

The PopupButton Control

The PopupButton control supports showing a ContextMenu or custom content in a Popup. Multiple display options are available.

The RadialSlider Control

The RadialSlider control is a circular slider that allows for quick selection of a degree value, which can easily be converted to some form of scalar value.

The RadioButtonList Control

The RadioButtonList control directly inherits ListBox and changes the template of items to look like radio buttons.

The ReflectionContentControl Control

The ReflectionContentControl control is a regular ContentControl however it also renders a reflection effect of the content below the actual content.

The ResizableContentControl Control

The ResizableContentControl control is a regular ContentControl that contains a gripper on one of its sides or corners. When it is dragged by the mouse, the content is resized. The gripper may be double-clicked to reset its size back to the content's desired size.

The RingSlice Control

The RingSlice control renders a portion (or the entire circle) of a ring shape. Its start/end angles, radius, thickness, and other stroke properties can be set.

The ZeroSizeContentControl Control

The ZeroSizeContentControl control is a regular ContentControl that can return a zero width or height during its measuring pass. This is useful in scenarios where the content should take up some space but you don't want the WPF layout routines to consider the space that it will take up during its measuring pass.

Progress Spinners

Progress Spinners are used when some form of processing is occurring to tell the end user that something is happening.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AdvancedTextBlock

The AdvancedTextBlock control can show a tooltip when overflowed, and can highlight spans of text based on captured text ranges (i.e. filter match results).

This topic contains these sections:

  • Setting the Text
  • Overflow and ToolTips
  • Highlighting Captured (Matched) Text Ranges

Setting the Text

The Text property specifies the text to render in the text block. This property fully supports bindings.

Overflow and ToolTips

The text block determines when it is overflowed, meaning not all of the text is visible within the control. When this situation occurs, the IsOverflowed property returns true.

The TextTrimming property, which defaults to CharacterEllipsis, indicates how the text block will visually trim overflow text.

A nice feature of the text block is that it will automatically set a tooltip on itself with its full text when overflowed. This feature is on by default but can be disabled by setting the HasToolTipOnOverflow property to false.

Highlighting Captured (Matched) Text Ranges

A really powerful feature of the control is the ability to specify an ordered list of captured text ranges that should be highlighted. These captures often come from filter match results. The Captures property accepts an enumerable containing StringFilterCapture results. Each StringFilterCapture is a pair of character index and length text ranges, and must be provided in non-overlapping ascending order.

When one or more captured text ranges are specified, those ranges will be highlighted within the text block. The highlight will be perfromed in bold font weight by default. The HighlightBackground, HighlightFontWeight, and HighlightForeground properties determine how the highlights render.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AnimatedExpander

The AnimatedExpander is a regular Expander that provides optional animated expansion functionality. The animation consists of crossfade and slide behavior.

The AnimatedExpander class has these important members:

Member | Description
CanMeasureCollapsedContent Property | Gets or sets whether the expander will use the width measurement of collapsed content when calculating its own width. The default value is true. When true, a consistent width will be maintained when collapsed. When false, the expander will load faster (if collapsed) since less measuring is taking place.
CollapseDuration Property | Gets or sets the Duration of the collapse animation. The default value is 250 milliseconds.
ExpandDirection Property | Gets or sets the ExpandDirection of the expand animation. The default value is ExpandDirection.Down.
ExpandDuration Property | Gets or sets the Duration of the expand animation. The default value is 250 milliseconds.
HeaderContextMenu Property | Gets or sets the context menu used for the header.
HeaderCornerRadius Property | Gets or sets the corner radius used by the header.
HeaderPadding Property | Gets or sets the Thickness of the padding around header content.
IsAutoCollapseOnBlurEnabled Property | Gets or sets whether the expander will auto-collapse when focus leaves it. The default value is false.
IsAutoExpandOnFocusEnabled Property | Gets or sets whether the expander will auto-expand when focus enters it. The default value is false.
IsAutoFocusOnExpandEnabled Property | Gets or sets whether focus will attempt to be set in the content of the expander following the completion of the expansion animation. The default value is false.

The AnimatedExpanderDecorator decorator is used in the template for the AnimatedExpander to provide the actual animation behavior.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AnimatedProgressBar

The AnimatedProgressBar includes all the features of the native WPF ProgressBar, plus the following features:

  • Support for multiple states
  • Smooth animation of value changes
  • Support for a continuous indicator (in themes that normally use a segmented indicator)

The AnimatedProgressBar control using the Aero theme in the three possible states, Normal, Paused, and Error

The AnimatedProgressBar control using the Luna NormalColor theme showing a segmented indicator and a continuous indicator

The OperationState enumeration holds all the valid states, each of which is rendered using a distinct color.

By default, the AnimatedProgressBar will animate Value changes. This differs from the native WPF ProgressBar, which "jumps" to the new Value. The smooth animation of the AnimatedProgressBar can be disabled by setting IsAnimationEnabled to false. In which case, the AnimatedProgressBar will also "jump" to the new Value.

The AnimatedProgressBar class has these important members:

Member | Description
DecreaseDuration Property | Gets or sets the Duration of the decrease animation. The default value is 500 milliseconds.
IncreaseDuration Property | Gets or sets the Duration of the increase animation. The default value is 500 milliseconds.
IsAnimationEnabled Property | Gets or sets value indicating whether the progress bar should animate Value changes. The default value is true.
IsContinuous Property | Gets or sets value indicating whether the progress bar should render a continuous or segmented indicator. The default value is false. Note: This is not supported in the Aero theme
State Property | Gets or sets the state of the progress bar. The default value is Normal.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CustomDrawElement

The CustomDrawElement class inherits FrameworkElement and provides a CustomDraw event.

By handling this event, you can draw the content of the element as if you had created a subclass of FrameworkElement and overrode the OnRender method.

This element is useful for placement in item templates where you may wish to custom draw items in an event handler.

This element is recommended for use in the Ribbon product when wanting to programmatically draw RibbonGallery or PopupGallery items.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DropShadowChrome

The DropShadowChrome decorator draws a drop-shadow around its content.

Two examples of the use of DropShadowChrome

This topic contains these sections:

  • Important Members
  • Creating an Offset Drop Shadow
  • Creating an Outer Glow

Important Members

The DropShadowChrome class has these important members:

Member | Description
BorderThickness Property | Gets or sets the Thickness of the drop shadow borders. The default value is 5.
Color Property | Gets or sets the color of the drop shadow. The default value is #71000000.
CornerRadius Property | Gets or sets the CornerRadius of the drop shadow borders. The default value is 0. When setting a non-zero corner radius, please use a uniform value and also use a uniform BorderThickness value as well.
XOffset Property | Gets or sets the horizontal offset of the drop shadow behind its content. The default value is 5.
YOffset Property | Gets or sets the vertical offset of the drop shadow behind its content. The default value is 5.
ZOffset Property | Gets or sets the z-offset of the drop shadow behind its content. The default value is 0.

Creating an Offset Drop Shadow

The standard type of drop shadow is an offset shadow. This effect is shown in the top screenshot above.

To accomplish this, use the XOffset and YOffset properties, and keep ZOffset = 0.

Creating an Outer Glow

An alternate type of drop shadow is an outer glow. This effect is shown in the bottom screenshot above.

To accomplish this, keep both XOffset and YOffset properties = 0. Then set the ZOffset to a value greater than 0.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DynamicImage

The DynamicImage control is a drop-in replacement for Image that renders the content in grayscale when the control is disabled.

Nothing needs to be configured for using this control. Simply replace your Image control instances with DynamicImage and anytime the control becomes disabled, the image content will render as grayscale.

This topic contains these sections:

  • Important Members
  • Handling FileNotFoundException or DirectoryNotFoundException

Important Members

The DynamicImage class has these important members:

Member | Description
IsEnabled Property | When set to false, the image content will render in grayscale. Inherited from Image.
Source Property | The source of the image content. Inherited from Image.

Handling FileNotFoundException or DirectoryNotFoundException

If you use relative paths for your bitmap image sources, you might encounter a FileNotFoundException or DirectoryNotFoundException in some cases when using DynamicImage, or any control that uses DynamicImage in its template, such as the Ribbon button controls. This exception can occur behind the scenes where the image is being reloaded outside of its original XAML context and thus can lose its contextual information for determining a relative path. Using an absolute path via standard WPF pack syntax allows the image to be loaded properly in any scenario.

The full exception message would be something like one of these:

  • "Could not find file 'C:\Paste16.png'." when the original image source was "/Paste16.png" (a FileNotFoundException).
  • "Could not find a part of the path 'C:\Resources\Images\Paste16.png'." when the original image source was "/Resources/Images/Paste16.png" (a DirectoryNotFoundException).

To resolve this exception, use the Pack syntax for specifying URIs (MSDN).

This example shows how to use an absolute URI to fully specify an image that is located in the "/Resources/Images" subfolder of a "SampleBrowser" project:

pack://application:,,,/SampleBrowser;component/Resources/Images/Paste16.png

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EditableContentControl

The EditableContentControl control is a standard ContentControl, which also features an alternate editing mode that can be toggled to display a TextBox for editing a string.

When entering edit mode, the Content property value is copied to the EditableContent property, and the UI switches to a TextBox for editing the editable content. Note that an alternate template could be provided for the control to support an editor other than a TextBox.

After the TextBox is displayed, the SelectText method is called, which selects all text by default. This method is passed the TextBox and can be overridden to select nothing or a certain range of text. An example usage scenario is when editing a filename and you only wish to update the name portion without the extension being selected.

While in editing mode, pressing Enter or moving focus out of the control will commit the value. This has the effect of copying the EditableContent property value back over to Content, which is done in the SetContentAfterEditing method. That method passes in the edited content and by default sets that value to the Content. The method can be overridden to coerce the edited content, or can choose to not set Content, which has the effect of canceling the edit. The IsEditing can even be set back to true if you wish for focus to remain in the TextBox, such as when there's an invalid value.

If Esc is pressed while editing, the value is not committed.

The EditableContentControl class has these important members:

Member | Description
EditableContent Property | Gets or sets the content being edited. This property is for internal use only.
IsEditing Property | Gets or sets whether the content is currently being edited. This property toggles the UI of the control between display and edit modes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


GlassWindow

The GlassWindow control is a Window that allows Vista's Aero glass effects to be extended into the client area of the window.

A GlassWindow with Aero glass extended into the client area of the window

The GlassWindow class has these important members:

Member | Description
GlassThickness Property | The Thickness of the glass frame into the client area. The default value is 0,0,0,0.
IsGlassActive Property | Gets whether Windows Vista glass transparency effects are currently active.
IsGlassEnabled Property | Gets or sets whether Windows Vista glass transparency effects are currently enabled. The default value is true.
IsIconVisible Property | Gets whether the title bar icon is visible. You may set this property to false in the constructor of a derived class to hide the window's icon in Vista only.
IsMaximizeButtonVisible Property | Gets or sets whether the maximize button is visible.
IsMinimizeButtonVisible Property | Gets or sets whether the minimize button is visible.
IsTitleVisible Property | Gets whether the title bar caption is visible. You may set this property to false in the constructor of a derived class to hide the window's caption in Vista only.
ShowSystemMenu Method | Displays the window's system menu.
ToggleMaximizedState Method | Toggles the window's maximized state.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


HorizontalListBox

The HorizontalListBox control is a restyled native ListBox that arranges its items in a uniform width horizontally, and without a ScrollBar.

A HorizontalListBox providing selection between two options.

Since the control inherits ListBox, all features found on the native ListBox can also be used, such as single or multiple selection modes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ImageTextInfo

The ImageTextInfo class is a simple DependencyObject that has Text, ImageSourceLarge, ImageSourceSmall, and Tag properties defined.

This object can be set to the Header of an Expander when the expander has a data template that can work with it to show the related text and images.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PixelSnapper

The PixelSnapper decorator snaps the measurement of its child content to integer values, thereby helping to prevent blurry images and borders that may appear after it.

This topic contains these sections:

  • The Issue: Blurry Images and Lines in WPF
  • A Visual Sample
  • Effective Use of PixelSnapper
  • Important Members
  • RoundMode Enumeration
  • Centering Within a Parent

The Issue: Blurry Images and Lines in WPF

A problem in WPF is that images and borders can become very blurry when they are positioned on non-pixel boundaries. This makes the application appear to be poorly designed to end users even though technically, the developer did nothing wrong.

How does this scenario occur? Very easily in fact. Say you have a standard WPF Menu at the top of your Window. The text in the menu items may measure to 12.5 pixels high. Then lets assume that we have 2 pixels of padding. Now we have a Menu that is 16.5 pixels high and the problem has been introduced.

The control directly under the Menu will start at vertical location 16.5. If this control is an Image, all the pixels in the image will appear blurry in the vertical direction since each lies half on one pixel and half on the one below it. Even setting SnapsToDevicePixels to true does nothing to correct the issue.

A Visual Sample

In the screenshot below, we have a Border with a PixelSnapper surrounding it. In the left sample, the PixelSnapper has snapped its contents to integers, the default behavior. In the right sample, the PixelSnapper functionality has been disabled.

A demonstration of the differences between using and not using PixelSnapper

Note how the images, which are laid out after the Border, are blurry when not using PixelSnapper functionality due to the decimal size of the Border.

Effective Use of PixelSnapper

Where should you use PixelSnapper? Generally, text elements like TextBlock controls are the only ones that will measure to decimal values. So any time you have a text control in your UI and that control will affect the layout of other controls, we recommend you surround it with a PixelSnapper. This will keep everything in your UI on pixel boundaries, enabling images and lines to remain crisp and clear.

Important Members

The PixelSnapper class has these important members:

Member | Description
HorizontalRoundMode Property | Gets or sets a RoundMode indicating how to round the horizontal measurement of the child content. The default value is RoundMode.Ceiling.
VerticalRoundMode Property | Gets or sets a RoundMode indicating how to round the vertical measurement of the child content. The default value is RoundMode.Ceiling.

RoundMode Enumeration

The RoundMode enumeration has these values:

Value | Description
None | No rounding is applied.
Floor | The largest integer less than or equal to the value is returned.
FloorToEven | The largest even integer less than or equal to the value is returned.
FloorToOdd | The largest odd integer less than or equal to the value is returned.
Ceiling | The smallest integer greater than or equal to the value is returned.
CeilingToEven | The smallest even integer greater than or equal to the value is returned.
CeilingToOdd | The smallest odd integer greater than or equal to the value is returned.
Round | The closest integer to the value is returned.
RoundToEven | The closest even integer to the value is returned.
RoundToOdd | The closest odd integer to the value is returned.

Centering Within a Parent

Say that you are trying to horizontally center an Image that is 32x32 pixels within a parent StackPanel that also has a TextBlock in it. The TextBlock could lead to a fractional width. By wrapping the TextBlock with a PixelSnapper and using a CeilingToEven horizontal round mode, you ensure that the entire contents of the TextBlock is visible, and that it forces the StackPanel's width to an even number, allowing the Image to be centered horizontally directly on integer boundaries within the StackPanel.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PopupButton

The PopupButton supports showing a ContextMenu or custom content in a Popup, as well as optionally provide standard button functionality.

This topic contains these sections:

  • Display Mode
  • Popup Content/Context Menu
  • Events
  • Transparency Mode
  • DataContext for Popup ContextMenu
  • Placement Target
  • Important Members

Display Mode

The PopupButton supports four display modes available in DisplayMode, which are:

DisplayMode | Description
Split | Represents a split button capable of showing either a ContextMenu or custom content in a Popup when the popup indicator area is clicked. The content area functions like a native WPF Button and can be clicked independently.
Merged | Represents a drop down button capable of showing either a ContextMenu or custom content in a Popup when the button is clicked. This display mode can only be used to show the associated popup and cannot be "clicked" like a native WPF Button.
ButtonOnly | Represents a normal button, which cannot show the associated popup. When in this display mode, the PopupButton functions exactly like a native WPF Button.
PopupOnly | Represents a drop down button capable of showing either a ContextMenu or custom content in a Popup when the button is clicked. This display mode can only be used to show the associated popup and cannot be "clicked" like a native WPF Button. This display mode differs from Merged because it ignores the Content property and only displays the PopupIndicator.

Popup Content/Context Menu

The PopupButton.PopupContent and/or PopupButton.PopupContentTemplate can be used to display custom popup content. The PopupButton.PopupMenu can be used to set the associated ContextMenu. When PopupContent or PopupContentTemplate is set, then the PopupMenu property is ignored.

The popup content can be automatically focused when opened by setting the IsAutoFocusOnOpenEnabled property to true.

Events

The PopupButton.PopupOpened and PopupButton.PopupClosed events are raised when the associated ContextMenu/Popup is opened and closed, respectively. In addition, the PopupButton.PopupOpening event will be raised before the associated ContextMenu/Popup is opened. Handlers for this event can customize the popup menu or content before it is displayed.

Transparency Mode

The PopupButton also supports a transparency mode, which indicates that the background, borders, and/or shades should not be rendered when the button is inactive. A button is considered inactive when it is not defaulted, does not have the keyboard focus, does not have the mouse over it, and is not pressed.

The PopupButton with the transparency mode enabled and with the mouse hovered over the button.

DataContext for Popup ContextMenu

Because ContextMenu elements are not part of the same visual tree as the associated PopupButton, it does not inherit the DataContext. The PopupButton has been designed to pass it's DataContext on to the ContextMenu specified by the PopupMenu. This allows data binding to be used without having to add any additional work-arounds.

The data context passed to the context menu is specified by the PopupMenuDataContext property, which is bound to the DataContext by default. This in effect, extends the current data context to the context menu, while still allowing it to be customzied easily as needed.

Placement Target

The placement of the popup depends on the display mode being used. The control template for the PopupButton uses 1 (for Merged, ButtonOnly, and PopupOnly display modes) or 2 (for Split display mode) inner "buttons", or elements. For the Split, Merged, and PopupOnly display modes, the inner indicator element is used as the PlacementTarget.

Important Members

The PopupButton class has these important members:

Member | Description
DisplayMode Property | Gets or sets the PopupButtonDisplayMode. The default value is Split.
HasDropShadow Property Gets or sets whether the popup will display a drop-shadow effect. The default value is true.
Note Note
Setting this property to true has no effect if the SystemParameters.DropShadow property is false.
IsAutoFocusOnOpenEnabled Property | Gets or sets a value indicating whether the popup content will be automatically focused when the popup is opened. The default value is false.
IsPopupOpen Property | Gets or sets whether the popup is currently displayed. The default value is false.
IsRounded Property | Gets or sets a value indicating whether the button should be drawn with round corners, if the selected theme supports rounded corners. The default value is true.
IsTransparencyModeEnabled Property | Gets or sets a value indicating whether transparency mode is enabled. The default value is false.
PopupAllowsTransparency Property Gets or sets the value assigned to the popup's AllowsTransparency property. The default value is true.

When this property is set to false, interop content will be able to render on the popup.
PopupContent Property Gets or sets the content that is displayed on the popup for the button. The default value is null.

This property takes precedence over the PopupMenu property. Therefore, if this property is set then the PopupMenu property is ignored.
PopupContentTemplate Property | Gets or sets the DataTemplate to use for the PopupContent. The default value is null.
PopupContentTemplateSelector Property | Gets or sets the DataTemplateSelector to use for the PopupContent. The default value is null.
PopupHorizontalOffset Property | Gets or sets the horizontal distance between the target origin and the popup alignment point. The default value is 0.
PopupIndicator Property | Gets or sets the UIElement used in the indicator portion of the button. The default value is null.
PopupIndicatorTemplate Property | Gets or sets the DataTemplate used to present the indicator portion of the button. The default value is null.
PopupIndicatorToolTip Property | Gets or sets the tool-tip object that is displayed for the popup indicator element. The default value is null, which indicates that the standard ToolTip object will be used for the entire button.
PopupMenu Property Gets or sets the ContextMenu that is displayed as the popup for the button. The default value is null.

The PopupContent property takes precedence over this property. Therefore, if PopupContent is set then this property is ignored.
PopupVerticalOffset Property | Gets or sets the vertical distance between the target origin and the popup alignment point. The default value is 0.
StaysOpen Property Gets or sets a value that indicates whether the Popup closes when the control is no longer in focus. The default value is false.
Note Note
This property has no effect when using PopupMenu.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RadialSlider

The RadialSlider control is a circular slider that allows for quick selection of a degree value, which can easily be converted to some form of scalar value.

Radial sliders function just like normal linear sliders however instead of moving the slider thumb in a straight line, the thumb can move in a circular fashion around the slider's center point. This sort of UI allows for additional precision when compared to linear sliders, especially with touch interaction.

Radial sliders are often paired with RingSlice controls, which are designed to render the main UI for radial slider tracks and values.

A RadialSlider that uses RingSlice controls for rendering of the track and value.

RadialSlider supports minimum/maximum ranges, infinite wrapping mode, customizable thumb styles, and more. While the control is ideal for touch-based input, it also fully accepts mouse and keyboard input. Combine two RadialSlider controls on top of each other to enable range-based selection.

This topic contains these sections:

  • Values
  • Input and Value Snapping
  • Conversion to Scalar Values
  • Range Constraints and Wrapping
  • Radius
  • Customizing the Thumb
  • Combining Multiple Sliders

Values

Values in the RadialSlider are expressed in terms of degrees, where 0 is upward and the degree values increase as they go clockwise, meaning 90 degrees is to the right.

There are two value properties exposed by this control. The first is the Value property, which inherits from RangeBase. This property contains the final 'snapped' degree value as the radial slider is interacted with by the end user. The second is IntermediateValue, which is the exact degree value as the radial slider is interacted with by the end user. They generally will be the same value however they can be different in cases where the user is dragging the slider's thumb off of a snap point (see below).

Input and Value Snapping

The slider is designed to accept all forms of input (touch, mouse, and keyboard). The SmallChange and LargeChange properties (inherited from RangeBase) specify degree values and dictate the interaction behavior with the slider.

A RadialSlider that has snapping enabled and makes use of multiple RingSlice controls to render the snap points.

Dragging

When dragging the slider's thumb via touch or mouse, the Value property will snap to the closest SmallChange interval, while the IntermediateValue will be directly under the drag location. When the thumb is released, it will animate IntermediateValue over to the Value property.

Mouse Wheel

When turning the mouse wheel, the slider's value will increment/decrement by the LargeChange value.

Keyboard

These keys are supported for keyboard input:

  • Up - Increment by SmallChange.
  • Down - Decrement by SmallChange.
  • PageUp - Increment by LargeChange.
  • PageDown - Decrement by LargeChange.
  • Home - Change directly to Minimum.
  • End - Change directly to Maximum.

Conversion to Scalar Values

While the slider's value are always represented in degrees, they can easily be converted to any scalar value via the use of a value converter.

In this example, a slider is set to snap at 30 degree increments and a TextBlock in the middle of it is bound to the value. But instead of displaying a degree value, the value converter divides the degree value by the degree increment (30) and displays the result, which is a value in the range of 0 to 11.

XAML
Copy
​<controls:RadialSlider x:Name="snappingSlider2" Radius="100" Value="120" LargeChange="30" SmallChange="30" />
<TextBlock FontSize="28" HorizontalAlignment="Center" VerticalAlignment="Center"
    Text="{Binding ElementName=snappingSlider2, Path=Value, Converter={StaticResource DegreeToScalarConverter}, ConverterParameter=30.0}" />

While the converter above is a simple example, the degree value could be converted to a percentage or even a text label instead.

Range Constraints and Wrapping

The Minimum and Maximum properties (inherited from RangeBase) can be used to designate a degree range that can contain the Value. For instance, to achieve a semi-circle range that bows upward, you would specify a Minimum of 270 (leftward) and a Maximum of 450 (rightward). The slider values will not be allowed to pass outside of that range.

The default Minimum is 0 and Maximum is 360. These settings enable a special mode where the slider's value can wrap infinitely.

A RadialSlider that is constrained to a semi-circle.

Other ranges can allow for creative input scenarios too. A Minimum of -360 and a Maximum of 360 allow for a full circle rotation negative or positive. A Minimum of 0 and a Maximum of 1080 allow for three full circle rotations positive.

Radius

The RadialSlider.Radius property indicates the radius of the invisible track over which the thumb will rotate. A radius of 40 means the circle will be 80x80 in size.

Customizing the Thumb

The thumb, represented by the CircularThumb primitive control, is the only visible portion of the slider. It is what the end user interacts with and drags to change the slider's value.

These members on RadialSlider are related to altering the appearance of the thumb:

Member | Description
ThumbArrowAngle Property | Gets or sets the thumb's arrow angle. The default value is 180, meaning it will face down when up at 0 degrees in the slider.
ThumbBackground Property | Gets or sets the background Brush to render when the thumb is in a normal state.
ThumbPressedBackground Property | Gets or sets the background Brush to render when the thumb is pressed.
ThumbStyle Property | Gets or sets the Style to use for the thumb. Use this property if a custom thumb Style is desired.

Combining Multiple Sliders

Two RadialSlider controls that overlay each other.

Multiple sliders can be overlayed on top of each other. The sliders themselves are transparent and only their thumbs allow for interaction. This means that two sliders would render two separate thumbs, each of which can be interacted with separately, and can therefore be used to specify a range of values by the end user.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RadioButtonList

The RadioButtonList control directly inherits ListBox and changes the template of items to look like radio buttons.

The RadioButtonList control bounds to the Dock enumeration

The selected item in the list will appear as a checked radio button.

This topic contains these sections:

  • Orientation
  • Bullet Layout
  • Auto-Disable Non-Selected Item Content

Orientation

By default, radio button items are displayed vertically. The Orientation property can be set to Orientation.Horizontal to allow the items to be displayed horizontally instead.

When adding items horizontally, it's best to ensure there is some margin space at the tail end of the item content so that the radio button items appear visually separated.

Bullet Layout

There are two properties that allow you to control the location of the bullet relative to the content.

The BulletVerticalAlignment property is a VerticalAlignment that indicates how the bullet is vertically aligned. By default, it is set to Center.

The BulletMargin property is a Thickness that specifies the margin around the bullet.

By using these two properties you can alter now the bullet is positioned relative to the content.

Auto-Disable Non-Selected Item Content

If your items have child controls in them, sometimes it's ideal to disable the child controls for all but the selected radio button item.

Set the AutoDisableNonSelectedItemContent property to true to activate this behavior.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ReflectionContentControl

The ReflectionContentControl is a regular ContentControl however it also renders a reflection effect of the content below the actual content. This reflection effect has become quite popular in recent user interfaces.

The ReflectionContentControl control providing reflection effects on the Actipro logo

You have total control over the size, distance and visual characteristics of the reflection. You can even skew the reflection to an angle.

Tip Tip
Animate the ReflectionMargin property along with the RenderTransform of the ReflectionContentControl to create a bounce effect. This is demoed in the sample project.

A reflection effect like what is provided in this control can be implemented from scratch in XAML however it takes many lines of code to do so. Instead, just wrap your content with a ReflectionContentControl and you're done.

The ReflectionContentControl class has these important members:

Member | Description
ReflectionEndOffset Property | Gets or sets the offset at which the end opacity (least opaque) is located in the reflection. The default value is 0.9.
ReflectionEndOpacity Property | Gets or sets the opacity of the reflection at its ending (least opaque) point. The default value is 0.0, meaning transparent.
ReflectionHeight Property | Gets or sets the height of the reflection. The default value is NaN, meaning that the height will be the same height as the content.
ReflectionMargin Property | Gets or sets the margin distance between the content and the reflection. The default value is 0.
ReflectionSkewAngleX Property | Gets or sets the skew angle of the reflection in the x-plane. The default value is 0, meaning no skew is applied.
ReflectionStartOpacity Property | Gets or sets the opacity of the reflection at its starting (most opaque) point. The default value is 0.4, meaning 40% opaque.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ResizableContentControl

The ResizableContentControl is a regular ContentControl that contains a gripper on one of its sides or corners. When it is dragged by the mouse, the content is resized. The gripper may be double-clicked to reset its size back to the content's desired size.

The ResizableContentControl control adding a gripper that allows for horizontal and vertical resizing

Resizing direction options are None, Horizontal, Vertical, or Both. The functionality provided by this control is especially useful within popups.

Tip Tip
You can provide a custom template for the ResizableContentControl to position the gripper in a custom location if the default options don't meet your needs. You also can make a custom Style for the Thumb control (gripper) that it contains to draw the gripper however you like.

The resize gripper is shown on top of the content associated with the ResizableContentControl. Problems can arise when the content uses a ScrollViewer, that is displaying a vertical scrollbar but not a horizontal scrollbar. The gripper will overlap the vertical scrollbar, which prevents the down button from being clicked (as well as an undesireable look).

The ResizableContentControl with a ScrollViewer using the native WPF Style

There are two methods for working around this issue. The first method requires that the Padding property be set on the ResizableContentControl so that the content is pushed up a sufficent amount. The height of the gripper is determined by the SystemParameters.HorizontalScrollBarHeight property.

Alternatively, the UseAlternateScrollViewerStyleProperty attached property can be set to true on the ResizableContentControl, the parent element of the ResizableContentControl, or any child elements of the ResizableContentControl. This applies a Style to the ScrollViewer elements that reserves sufficent space for the gripper.

The ResizableContentControl with UseAlternateScrollViewerStyleProperty set to true on the TextBox

The ResizableContentControl class has these important members:

Member | Description
AutoSize Method | Auto-sizes the content control to the desired size of its content.
CanAutoSize Property | Gets or sets whether the gripper auto-sizes to its content when it is double-clicked. The default value is true.
GripperBackground Property | Gets or sets the Brush to use for the gripper background.
GripperForeground Property | Gets or sets the Brush to use for the gripper foreground.
Padding Property | Gets or sets the distance between the ResizableContentControl and its content.
ResizeMode Property | Gets or sets a ControlResizeMode indicating the resizing capabilities of the gripper. The default value is ControlResizeMode.Both. Use the ControlResizeMode.None value to hide the gripper.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RingSlice

The RingSlice control renders a portion (or the entire circle) of a ring shape. Its start/end angles, radius, thickness, and other stroke properties can be set.

Several RingSlice controls combined to create an appealing radial graph.

Ring slice controls can be combined in many interesting ways within UI, including being used to represent the 'track' or value of a RadialSlider, used to create segmented progress indicators, etc.

This topic contains these sections:

  • Angles, Radius, and Thickness
  • Other Stroke Properties
  • Entire Circle

Angles, Radius, and Thickness

The control renders a ring slice between two angles, specified in degrees, where 0 is upward and the degree values increase as they go clockwise, meaning 90 degrees is to the right. To render a quarter circle ring from the top to the right, use a StartAngle of 0 and an EndAngle of 90.

Several RingSlice controls used to render a four-step circular progress indicator.

The control also has two properties that control its radius and thickness. The Radius property specifies the outer radius of the ring. The StrokeThickness property specifies the thickness of the ring, extending inward from the outer radius.

Tip Tip
Use a StrokeThickness value that is the same as the Radius to render a pie slice.

Other Stroke Properties

RingSlice also supports all of the standard stroke properties found on a shape control. This includes setting start/end/dash caps to achieve circular, triangle, etc. line ends, or setting properties to renders dashed lines.

Entire Circle

When the StartAngle and EndAngle are the same value, the ring slice will by default render a full circular ring. the IsRenderedWhenFullCircle property can be set to false to disable this behavior. When set to false and the angles are the same, nothing will be rendered.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ZeroSizeContentControl

The ZeroSizeContentControl is a regular ContentControl that can return a zero width or height during its measuring pass. This is useful in scenarios where the content should take up some space but you don't want the WPF layout routines to consider the space that it will take up during its measuring pass.

The ZeroSizeContentControl class has these important members:

Member | Description
HasHeight Property | Gets or sets whether the content's height should be used in the measuring pass. The default value is true.
HasWidth Property | Gets or sets whether the content's width should be used in the measuring pass. The default value is true.
IdealSize Property | Gets the ideal Size of the control, since the DesiredSize will not represent the true desired size.

Use the HorizontalContentAlignment and VerticalContentAlignment properties to determine how content is aligned when arranged.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Progress Spinners

Progress spinners are used when some form of processing is occurring to tell the end user that something is happening.

A large RingSpinner control.

This topic contains these sections:

  • RingSpinner Overview

RingSpinner Overview

The RingSpinner control renders an animated ring where the two ring segment ends chase each other around the circle.

A couple RingSpinner controls.

The IsSpinning property must be set to true to activate animated spinning.

The outer radius of the ring will be auto-calculated based on the Width and Height of the control. They always should be set. For instance if Width and Height are 16 and there is no Padding set, the ring's radius will be 8.

The BorderBrush and BorderThickness properties specify the brush and thickness of the ring, extending inward from the outer radius.

Tip Tip
Use a BorderThickness value that is the same as the Radius to render a pie. The LineCap property (defaults to Round) should be set to Flat when rendering as a pie.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Color Selection

The ColorSelection namespace contains several controls for performing color selection similar to that found in Adobe Photoshop or Microsoft Expression Blend.

This topic contains these sections:

  • The SpectrumColorPicker Control
  • The SpectrumSlice Control
  • The SpectrumSlider Control
  • The ColorComponentSlider Control
  • The GradientBrushSlider Control

The SpectrumColorPicker Control

The SpectrumColorPicker is a control that allows for visual color selection. It uses the SpectrumSlice and SpectrumSlider controls that are also included in the Shared libary.

The SpectrumColorPicker control with some TextBoxes bound to its selected color

This control has these important properties:

Member | Description
A Property | Gets or sets the ARGB alpha component of the SelectedColor.
B Property | Gets or sets the RGB blue component of the SelectedColor.
DisabledOpacity Property | Gets or sets the opacity used when the control is disabled.
G Property | Gets or sets the RGB green component of the SelectedColor.
InitialColor Property | Gets or sets the Color that was initially selected in the picker and is displayed in the lower left box.
IsInitialColorVisible Property | Gets or sets whether the initial color swatch is visible in the color picker.
R Property | Gets or sets the RGB red component of the SelectedColor.
SelectedColor Property | Gets or sets the Color that is selected in the picker and is displayed in the lower right box. The lower middle box also generally displays the selected color, except when the mouse is being used to select a new color. In that case, the color under the mouse is displayed in the lower middle box instead.

TextBox controls can be bound to the SpectrumColorPicker to provide text entry of the various color values. For web color entry (e.g. #FF0000), we have supplied a ColorToStringConverter class that can be used in a binding.

This XAML code shows how to create the color picker displayed above with all the bounds TextBox controls:

XAML
Copy
​<Window x:Class="Sample.Application.Window"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
    >
    <Grid>
        <Grid.Resources>
            <shared:ColorToStringConverter x:Key="ColorToStringConverter" />
        </Grid.Resources>
        <Grid.RowDefinitions>
            <RowDefinition Height="Auto" />
            <RowDefinition Height="Auto" />
            <RowDefinition Height="Auto" />
            <RowDefinition Height="*" />
            <RowDefinition Height="Auto" />
        </Grid.RowDefinitions>
        <Grid.ColumnDefinitions>
            <ColumnDefinition Width="Auto" />
            <ColumnDefinition Width="Auto" />
            <ColumnDefinition Width="Auto" />
        </Grid.ColumnDefinitions>

        <shared:SpectrumColorPicker x:Name="spectrumColorPicker" Grid.RowSpan="5" Margin="0,0,10,0" InitialColor="Red" SelectedColor="Purple" />

        <Label Grid.Row="0" Grid.Column="1" HorizontalAlignment="Right" VerticalAlignment="Center">R:</Label>
        <TextBox Grid.Row="0" Grid.Column="2" HorizontalAlignment="Left" VerticalAlignment="Center" MinWidth="30" MaxLength="3"
            Text="{Binding ElementName=spectrumColorPicker, Path=R}" />
        <Label Grid.Row="1" Grid.Column="1" HorizontalAlignment="Right" VerticalAlignment="Center">G:</Label>
        <TextBox Grid.Row="1" Grid.Column="2" HorizontalAlignment="Left" VerticalAlignment="Center" MinWidth="30" MaxLength="3"
            Text="{Binding ElementName=spectrumColorPicker, Path=G}" />
        <Label Grid.Row="2" Grid.Column="1" HorizontalAlignment="Right" VerticalAlignment="Center">B:</Label>
        <TextBox Grid.Row="2" Grid.Column="2" HorizontalAlignment="Left" VerticalAlignment="Center" MinWidth="30" MaxLength="3"
            Text="{Binding ElementName=spectrumColorPicker, Path=B}"></TextBox>
        <TextBox Grid.Row="4" Grid.Column="1" Grid.ColumnSpan="2" HorizontalAlignment="Left" VerticalAlignment="Center"
            Margin="0,0,0,21" MinWidth="70" MaxLength="9"
            Text="{Binding ElementName=spectrumColorPicker, Path=SelectedColor, Converter={StaticResource ColorToStringConverter}, ConverterParameter=False}" />

    </Grid>
</Window>

The SpectrumSlice Control

The SpectrumSlice control is part of the SpectrumColorPicker control and is used to display a slice of saturation/brightness colors for a particular hue on the left side of the color picker. However this control may be used on its own.

This control has these important properties:

Member | Description
BaseColor Property | Gets or sets the Color that is used to construct the slice. Only the HSB hue component is used from this color.
MarkedColor Property | Gets or sets the Color that the marker is over in the slice. When the mouse is used to drag the marker, this color is set to the SelectedColor property upon the release of the mouse button.
SelectedColor Property | Gets or sets the Color that is selected in the slice.

The SpectrumSlider Control

The SpectrumSlider control is part of the SpectrumColorPicker control and is used to display a hue spectrum on the right side of the color picker. However this control may be used on its own.

The Value of the control may be in the range of 0 to 360 and specifies the hue component in the HSB color space.

The ColorComponentSlider Control

The ColorComponentSlider control can be used in conjunction with or independently of the SpectrumColorPicker control to modify a single component of the ARGB color.

Four instances of ColorComponentSlider each bound to a different component of the same color

The Value of the control may be in the range of 0 to 255 and specifies the component value based on the ColorComponentSlider.Component property. The ColorComponentSlider.SelectedColor property can be used to set or get the selected color of the slider.

The GradientBrushSlider Control

The GradientBrushSlider control can be used to modify the offsets of the gradient stops of a LinearGradientBrush or RadialGradientBrush. Each gradient stop is represented by a thumb, which can be selected by the user. The selected gradient stop is represented by the SelectedStop property can allows it's color to be bound to an editor, such as the SpectrumColorPicker.

This control has these important members:

Member | Description
AddStop Method | Adds a gradient stop to the selected brush. The first overload will add a stop between the first two stops, if any. The second overload will add a stop at a specified offset. The color of the stop will be automatically calculated based on the specified offset.
CanAddStops Property | Gets or sets whether stops can be added.
CanRemoveStops Property | Gets or sets whether stops can be removed.
Orientation Property | Gets or sets the orientation of the slider, which can be either horizontal or vertical.
RemoveSelectedStop Method | Removes the selected gradient stop from the selected brush.
ReverseStops Method | Reverses the stops of the selected brush. Gradient stops at offset 1.0 will be moved to offset 0.0 gradient stops at offset 0.0 will be moved to offset 1.0. Gradient stops at offset 0.5 will not be changed.
SelectedBrush Property | Gets or sets the selected brush presented and modified by the slider.
SelectedStop Property | Gets the selected gradient stop in the slider.

Mouse Interaction

The offsets of the gradient stops can be adjusted by dragging the associated thumb along the slider. New gradient stops can be added by clicking on the slider background. Finally, gradient stops can be removed by dragging the thumb below (horizontal) or to the right (vertical) the slider.

Commands

The GradientBrushSlider.AddStopCommand routed command can be executed on the GradientBrushSlider to add a gradient stop. Similarly, the GradientBrushSlider.RemoveStopCommand routed command can be used to remove the selected stop.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data

The Data namespace contains several classes that are helpful for working with data.

This topic contains these sections:

  • Value Converters
  • The MathHelper Class
  • The NullableExtension Class
  • The ValidationHelper Class

Value Converters

There are numerous value converter classes in this namespace.

All of the available value converters from this namespace and others in the Shared Library are described in the Value Converters topic.

The MathHelper Class

The MathHelper class provides static methods that provide additional math operations not found in the Math class.

Member | Description
Max Method | Returns the largest value from the specified numbers.
Min Method | Returns the smallest value from the specified numbers.
Range Method | Returns the specified value constrained to the specified minimum and maximum values.
Round Method | Rounds a double value based on the specified RoundMode, which supports several methods of rounding the value.

The NullableExtension Class

The NullableExtension class is a markup extension that can be used to define an instance of Nullable<T> in XAML.

The ValidationHelper Class

The ValidationHelper class provides a number of static methods that can be called in the validation argument of a dependency property registration.

Member | Description
ValidateDoubleIsBetweenInclusive Method | Validates that the object is a Double whose value is inclusively between two numbers.
ValidateDoubleIsGreaterThan Method | Validates that the object is a Double greater than the specified number.
ValidateDoubleIsGreaterThanOrEqual Method | Validates that the object is a Double greater than or equal to the specified number.
ValidateDoubleIsNumber Method | Validates that the object is a Double is not NaN or infinity.
ValidateDoubleIsNumberOrNaN Method | Validates that the object is a Double is not infinity.
ValidateDoubleIsPercentage Method | Validates that the object is a Double between 0 and 1 inclusive.
ValidateDoubleIsPositive Method | Validates that the object is a Double greater than or equal to 0.
ValidateDoubleIsPositiveOrNaN Method | Validates that the object is a Double greater than or equal to 0 or NaN.
ValidateDurationIsPositiveTimeSpan Method | Validates that the object is a Duration is a positive TimeSpan.
ValidateInt32IsBetweenInclusive Method | Validates that the object is an Int32 whose value is inclusively between two numbers.
ValidateInt32IsGreaterThanOrEqual Method | Validates that the object is an Int32 greater than or equal to the specified number.
ValidateInt32IsPositive Method | Validates that the object is an Int32 greater than or equal to 0.
ValidateInt64IsBetweenInclusive Method | Validates that the object is an Int64 whose value is inclusively between two numbers.
ValidateInt64IsGreaterThanOrEqual Method | Validates that the object is an Int64 greater than or equal to the specified number.
ValidateInt64IsPositive Method | Validates that the object is an Int64 greater than or equal to 0.

This sample code shows how to use the ValidateDoubleIsPercentage method to validate that the dependency property value is a valid percentage.

C#
VB
Copy
​public static DependencyProperty PercentProperty =
    DependencyProperty.Register("Percent", typeof(double), typeof(MyClass), new FrameworkPropertyMetadata(0.0),
    new ValidateValueCallback(ValidationHelper.ValidateDoubleIsPercentage));
​Public Shared PercentProperty As DependencyProperty =
    DependencyProperty.Register("Percent", GetType(double), GetType(MyClass), New FrameworkPropertyMetadata(0.0),
    New ValidateValueCallback(ValidationHelper.ValidateDoubleIsPercentage))

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Document Management

The DocumentManagement namespace contains several classes that can be used for storing document references and maintaining recent document lists.

These classes are used in our Ribbon product to manage recent documents within the ribbon application menu's optional RecentDocumentMenu control.

This topic contains these sections:

  • Document References
  • Recent Document Management
  • Persisting Recent Document Lists

Document References

The IDocumentReference interface provides the base requirements for a document reference. A document reference is simply a reference to a document that contains the Uri to the document, along with the document's display name, the DateTime that it was last opened, and whether it is a pinned recent document.

Some extended properties are also available for specifying icons (large/small) and a description of the reference. These properties may be used by products such as Ribbon's RecentDocumentMenu when on a Backstage menu.

The DocumentReference class is a simple implementation of the IDocumentReference class.

Recent Document Management

The RecentDocumentManager is a class that can manage a list of document references that point to recently-opened documents.

The manager class filters down the contained document references from its Documents collection into its FilteredDocuments collection.

The filtered collection will contain up to a maximum number of document references that you specify. That collection will also be sorted in reverse date/time of the last time the document was opened, by examining the IDocumentReference.LastOpenedDateTime property. Further logic is applied so that if the document reference's IsPinnedRecentDocument property is true, it will have higher priority for staying on the list and not being filtered out, even if another more recently-opened document reference would normally cause it to be filtered out.

The RecentDocumentManager class has these important members:

Member | Description
Deserialize Method | Deserializes the Documents collection from the data in an XML string. The XML string must have been created by a previous call to Serialize.
Documents Property | Gets the collection of IDocumentReference objects that are being managed. Add/remove the document references to be managed via this collection.
FilteredDocuments Property | Gets the read-only collection of filtered documents that should be used for a recent documents list. The collection sorts the contained documents by date/time and pinned states and returns up to MaxFilteredDocumentCount documents.
GetDocumentReference Method | Returns an existing IDocumentReference from the Documents collection, if any, that matches the specified Uri.
MaxDocumentCount Property | Gets or sets the maximum number of documents to return in the Documents collection. This collection is how many documents total are being tracked.
MaxFilteredDocumentCount Property | Gets or sets the maximum number of documents to return in the FilteredDocuments collection.
NotifyDocumentOpened Method | Provides a helper method for easily updating an existing document reference's last-opened date/time. If no existing document reference with the specified Uri exists, a new DocumentReference is created. There are three overloads for this method, which each take incrementally more information for populating a new DocumentReference if needed.
RebindFilteredDocuments Method | Rebinds the FilteredDocuments collection. The FilteredDocuments collection is automatically re-bound when the Documents collection is changed. However if you update the last-opened date/time or pinned flag for an IDocumentReference, you must call this method manually to rebind the FilteredDocuments collection.
Serialize Method | Serializes the Documents collection to an XML string. Use the Deserialize method to load the serialized data later.

In many cases where a simple DocumentReference is used to track a document or if you don't wish to track the reference at all and just let the RecentDocumentManager do it completely for you, the use of the NotifyDocumentOpened method is recommended. That method provides a way to update the last-opened date time for a document in one line of code and will create a new reference as needed.

Persisting Recent Document Lists

The recent document list managed by a RecentDocumentManager can be easily persisted to an XML string. This XML string in turn can be saved to a settings file or database or whatever other sort of storage mechanism you use for keeping user data.

Call RecentDocumentManager.Serialize to obtain the serialized data and later on, call RecentDocumentManager.Deserialize to restore the serialized data.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Input

The Input namespace contains several classes that are helpful for working with input.

This topic contains these sections:

  • Mouse Wheel Gesture

Mouse Wheel Gesture

The MouseWheelGesture can be used to bind mouse wheel movement to a command using the InputBindings collection. The gesture supports positive or negative deltas (i.e. up or down scrolling of the mouse wheel), with optional modifier keys.

The MouseWheelBinding can be used from XAML to easily add a mouse wheel gesture.

This code shows how to add a mouse wheel gesture in XAML:

XAML
Copy
​xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
...
<MyControl>
    <MyControl.InputBindings>
        <shared:MouseWheelBinding Command="{x:Static ScrollBar.LineUpCommand}" Gesture="PositiveDelta" />
        <shared:MouseWheelBinding Command="{x:Static ScrollBar.LineDownCommand}" Gesture="NegativeDelta" />
        <shared:MouseWheelBinding Command="{x:Static ScrollBar.LineLeftCommand}" Gesture="Shift+PositiveDelta" />
        <shared:MouseWheelBinding Command="{x:Static ScrollBar.LineRightCommand}" Gesture="Shift+NegativeDelta" />
    </MyControl.InputBindings>
</MyControl>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Media

The Media namespace has a UIColor structure that has a lot of helper methods for working with colors and a VisualTreeHelperExtended class that adds some useful methods that aren't in the core VisualTreeHelper class.

This topic contains these sections:

  • General
  • BrushOpacityConverter Class
  • ColorInterpolationConverter Class
  • IconFrameConverter Class
  • IconFrameSelector Class
  • LinearGradientBrushExtension Class
  • UIColor Structure
  • VisualTreeHelperExtended Class

General

These general types are found in the namespace:

Type | Description
IVisualParent Provides the base requirements for an element that can add and remove visual child elements.
Note Note
This interface is used in conjunction with LogicalChildrenCollection`1.
LinearGradientType | Specifies the type of LinearGradientBrush to be created by LinearGradientBrushExtension.

BrushOpacityConverter Class

BrushOpacityConverter value converter can be used in XAML bindings to return a clone of a Brush with it's opacity set to a specified value.

See the Value Converters topic for more information on this class.

ColorInterpolationConverter Class

ColorInterpolationConverter value converter can be used in XAML bindings to return the linear Color value that is the specified percentage between the value of two Color objects.

See the Value Converters topic for more information on this class.

IconFrameConverter Class

IconFrameConverter value converter can be used in binding statements to select an image frame based on its size from an icon (.ICO) file. Normally, the first frame from icon file is returned which may not be the desired size. Using this value converter, a different size frame can be selected regardless of whether it's the first frame.

By default, IconFrameConverter will return the first 32x32 image frame. The desired size can be set using DesiredHeight and DesiredWidth. If no image of the desired size is found, then the passed value is returned.

IconFrameSelector Class

IconFrameSelector markup extension can be used in XAML to select an image frame based on its size from an icon (.ICO) file. Normally, the first frame from icon file is returned which may not be the desired size. Using this markup extension, a different size frame can be selected regardless of whether it's the first frame.

By default, IconFrameSelector will return the first 32x32 image frame. The desired size can be set using DesiredHeight and DesiredWidth. If no image of the desired size is found, then the default ImageSource is returned.

LinearGradientBrushExtension Class

The LinearGradientBrushExtension class implements a markup extension that returns a LinearGradientBrush based on the specified parameters.

These instance members are found in the class:

Member | Description
AdditionalStopCount Property Gets or sets the additional stops used when creating a LinearGradientBrush.
Note Note
When using additional stops, the start and end color will be alternated at each stop. Therefore if 1 additional stop is used, then the LinearGradientBrush will have 3 stops with the colors: start color, end color, start color.
Angle Property | Gets or sets the angle used when creating a LinearGradientBrush. This value is only used when the GradientType is set to CustomAngle.
EndColor Property | Gets or sets the end color of the gradient.
GradientType Property | Gets or sets the type of gradient.
StartColor Property | Gets or sets the start color of the gradient.

These static members are found in the class:

Member | Description
CreateBrush Method | Creates a LinearGradientBrush based on the specified parameters.

UIColor Structure

The UIColor structure provides an enhanced representation of a Color object that supports the RGB, HSB, and HLS color models, conversion between models, and numerous other color helper methods. Static methods on the structure are used to create an instance of it.

These instance members are found in the structure:

Member | Description
A Property | Gets or sets the alpha component value of this UIColor structure.
B Property | Gets or sets the RGB blue component value of this UIColor structure.
ExceedsW3CBrightnessThreshold Property | Gets whether the color exceeds the W3C threshold for brightness.
G Property | Gets or sets the RGB green component value of this UIColor structure.
Grayscale Method | Converts the color to grayscale.
HlsHue Property | Gets or sets the HLS hue component value of this UIColor structure.
HlsLightness Property | Gets or sets the HLS lightness component value of this UIColor structure.
HlsSaturation Property | Gets or sets the HLS saturation component value of this UIColor structure.
HsbBrightness Property | Gets or sets the HSB brightness component value of this UIColor structure.
HsbHue Property | Gets or sets the HSB hue component value of this UIColor structure.
HsbSaturation Property | Gets or sets the HSB saturation component value of this UIColor structure.
IsGrayscale Property | Gets whether the color is grayscale.
Luminance Property | Gets the luminance of the color.
R Property | Gets or sets the RGB red component value of this UIColor structure.
Tint Method | Tints this color towards the specified tint Color.
ToColor Method | Gets the Color value of this UIColor structure.
ToWebColor Method | Converts the color to a web color string (e.g. #FF0000 for Red).
W3CBrightness Property | Gets the brightness of the color, based on the W3C formula for calculating brightness.

These static members are found in the structure, many of which are used to create a UIColor:

Member | Description
FromAhls Method | Creates a UIColor structure from an alpha value and the specified HLS color values (hue, lightness, and saturation).
FromAhsb Method | Creates a UIColor structure from an alpha value and the specified HSB color values (hue, saturation, and brightness).
FromArgb Method | Creates a UIColor structure from an alpha value and the specified RGB color values (red, green, and blue).
FromColor Method | Creates a UIColor structure from the specified Color.
FromColorComplement Method | Creates a UIColor structure from the complement of the specified Color.
FromHls Method | Creates a UIColor structure from the specified HLS color values (hue, lightness, and saturation).
FromHsb Method | Creates a UIColor structure from the specified HSB color values (hue, saturation, and brightness).
FromMix Method | Creates a UIColor structure that is the specified percentage between the value of two Color objects.
FromName Method | Creates a UIColor structure from the specified name of a pre-defined color.
FromRgb Method | Creates a UIColor structure from the specified RGB color values (red, green, and blue).
FromWebColor Method | Creates a UIColor structure from the specified web color. This method can process HTML color specifications (e.g. #FF00FF) and known color names.
GetStandardCustomColors Method | Returns a Color array containing all of the standard custom values.
GetSystemColors Method | Returns a Color array containing all of the SystemColors values.
GetTintedColor Method | Returns the custom tinted color for the specified base color.
GetWebColors Method | Returns an array containing all of the web color values.

VisualTreeHelperExtended Class

The VisualTreeHelperExtended class has several static methods that are useful for performing common tasks with nodes in a visual tree. This class provides some advanced functionality that is not found in the VisualTreeHelper class.

These static members are found in the class:

Member | Description
GetAllDescendants Method | Returns a list of DependencyObject values that includes all the descendant visual objects that are of the specified Type.
GetAncestor Method | Returns a DependencyObject value that represents an ancestor of the visual object that is of the specified Type.
GetAncestorPopup Method | Returns a Popup value that represents an ancestor of the visual object.
GetChild Method | Returns a DependencyObject value that represents the first child visual object that is of the specified Type.
GetCurrentOrAncestor Method | Returns a DependencyObject value that represents the visual object, or an ancestor of the visual object, that is of the specified Type.
GetDescendant Method | Includes several overloads that allow a descendent visual to be returned from a specified object using various criteria.
GetFirstDescendant Method | Returns a DependencyObject value that represents the first descendant visual object that is of the specified Type.
GetFirstFocusableDescendant Method | Returns a UIElement value that represents the first descendant visual object that is focusable.
GetNextFocusable Method | Returns a UIElement value that represents the next visual object that is focusable.
GetPreviousFocusable Method | Returns a UIElement value that represents the previous visual object that is focusable.
GetRoot Method | Returns the root DependencyObject in the visual tree.
IsMouseOver Method | Returns whether the bounds of the specified DependencyObject contains the mouse without using a call to IsMouseOver, which can provide inaccurate results in mouse capture scenarios.
IsVisual Method | Returns whether the specified DependencyObject is a Visual or Visual3D.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Media Animation

The Animation namespace has a number of classes that support animated transitions between two objects. These can be anything from a simple fade to a complex wipe. The transition classes are extensible and provide the foundation for page transitions in our Wizard product.

This topic contains these sections:

  • Using the TransitionPresenter Control
  • Using the ToggleTransitionPresenter Control
  • Built-In Transitions
  • Creating Custom Transitions
  • Integrating the WPF Pixel Shader Effects Library

Using the TransitionPresenter Control

The TransitionPresenter control coordinates transitions between two contents, a "from" content and a "to" content. The contents may be any object type and can optionally use a DataTemplate or a DataTemplateSelector to build the user interface for the objects.

Wizard for WPF using the transition presenter with a bar wipe transition to switch between pages

This XAML code shows how to create a TransitionPresenter:

XAML
Copy
​<Window x:Class="Sample.Application.Window"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
    >
    <shared:TransitionPresenter x:Name="Presenter" />
</Window>

Only one content can be displayed in the transition presenter, although as a new content is selected, it is transitioned in based on the transition that is currently assigned to the transition presenter.

This XAML code shows how to assign a specific Transition to the transition presenter via the TransitionPresenter.Transition property:

XAML
Copy
​<shared:TransitionPresenter x:Name="Presenter">
    <shared:TransitionPresenter.Transition>
        <shared:FadeTransition />
    </shared:TransitionPresenter.Transition>
</shared:TransitionPresenter>

That code assigned a FadeTransition to the transition presenter. If you would like to use logic to pick a transition you can write a class that inherits TransitionSelector and implement its SelectTransition method. When using a TransitionSelector, be sure that you clear the TransitionPresenter.Transition property though since if that is specified, the TransitionSelector will not be used.

The DelegateTransitionSelector can be used to quickly implement custom transition selection logic, without the need to create additional classes. It uses a custom method or delegate, which is called when a new transition is needed.

This XAML code shows how to assign a specific Transition to the transition presenter via the TransitionPresenter.Transition property:

C#
VB
Copy
​transitionPresenter.TransitionSelector = new DelegateTransitionSelector() {
    Callback = delegate(TransitionPresenter presenter, object fromContent, object toContent) {
        // Implement custom logic that returns a Transition here
        return null;
    }
};
​transitionPresenter.TransitionSelector = New DelegateTransitionSelector(AddressOf SelectTransition)

...

Private Function SelectTransition(ByVal transitionPresenter As TransitionPresenter, ByVal fromObject As Object, ByVal toObject As Object) As Transition
    ' Implement custom logic that returns a Transition here
    Return Nothing
End Function

A class called MultiTransitionSelector is included in the Shared library. Its Transitions collection can contain one or more Transition instances. When this selector is used, it randomly picks one of the child transitions. Additionally if the TransitionPresenter.DefaultMode is Out, then it will return an opposite variation of the picked transition (if the transition supports it). This makes it easy to show different directions of transitions for forward and backward progress, such as in Wizard for WPF.

The currently visible content in the transition presenter is set via the TransitionPresenter.Content property. When a new object is set to that property, the transition presenter performs a transition from the "from" content (existing property value) to the "to" content (new property value). You can use the ContentTemplate or ContentTemplateSelector properties to set a DataTemplate or a DataTemplateSelector for the "to" content. Of course you can bind all this properties in XAML too.

You can specify a default TransitionDirection for transitions that support directions. This is done via the TransitionPresenter.DefaultDirection property.

You can also specify a default Duration for transitions that support defaultable durations. This is done via the TransitionPresenter.DefaultDuration property.

The TransitionPresenter.DefaultMode property is used to indicate to a TransitionSelector whether selected transitions that support the mode concept should be In (the default) or Out transitions.

The TransitionPresenter.IsFirstContentTransitionEnabled property indicates whether when transitioning from a null Content to an object, a transition is enabled. If set to false, an instant display of the "to" content will occur.

The TransitionPresenter.IsPostTransitionFocusEnabled property indicates whether focus will be set to the "to" content upon transition completion.

The TransitionPresenter.IsTransitioningSuspended property can be used to temporarily suspend transitions. This allows several updates to the TransitionPresenter to be applied and batched into a single update/transition.

Using the ToggleTransitionPresenter Control

Unlike the TransitionPresenter, which transitions changes to the Content property, the ToggleTransitionPresenter control coordinates transitions between Content and "alternate" content. The alternate content is specified by the AlternateContent property, which is shown when IsAlternateContentVisible is set to true. In all other respects, the ToggleTransitionPresenter works identically to the TransitionPresenter.

Built-In Transitions

The Shared library includes a number of built-in transitions. Many of the built-in transitions support multiple directions and have an in/out mode concept. This table shows the built-in transitions:

Type | Description
BarnDoorWipeTransition | A wipe transition between two elements that uses two straight bars with a configurable gradient spread. The transition supports BeginTime, Direction, Duration, and Mode properties. It also has a configurable Spread property that indicates how wide of a gradient to use for the bar. A value of 0 means a straight line and a value of 1 means a very large gradient. The default is 0.25.
BarWipeTransition | A wipe transition between two elements that uses a straight bar with a configurable gradient spread. The transition supports BeginTime, Direction, Duration, and Mode properties. It also has a configurable Spread property that indicates how wide of a gradient to use for the bar. A value of 0 means a straight line and a value of 1 means a very large gradient. The default is 0.25.
BoxWipeTransition | A wipe transition between two elements that uses a box. The transition supports BeginTime, Direction, Duration, and Mode properties.
FadedZoomTransition | A crossfade transition between two elements that zooms the new content in as well. The transition supports BeginTime, Duration, and Mode properties. It also has configurable ZoomInPercentage and ZoomOutPercentage properties that indicate the percentage by which zoomed in and out content is scaled. The default is 0.2. The values must be between 0 and 0.5.
FadeTransition | A crossfade transition between two elements. The transition supports BeginTime, Duration, and Mode properties. It also has a configurable BlurRadius property that indicates an optional radius of a blur effect to apply to the fade. The default is 0. Since setting this property to non-zero uses a bitmap effect, do not set this property when used in an XBAP (due to security restrictions).
FourBoxWipeTransition | A wipe transition between two elements that uses four boxes. The transition supports BeginTime, Duration, and Mode properties.
SlideTransition | A slide transition between two elements that moves one element over the other, or alternatively pushes the other. The transition supports BeginTime, Direction, Duration, and Mode properties. It also has a IsFromContentPushed property that indicates whether the "from" content is pushed offscreen or if the "to" content simply slides over it. The default is false.
WedgeWipeTransition | A wipe transition between two elements that uses a wedge shape. The transition supports BeginTime, Direction, and Duration, and Mode properties. Although this transition supports a direction, it one works for horizontal or vertical directions. Diagonal directions will be converted to a horizontal direction.

Creating Custom Transitions

Custom transitions can be created in multiple ways. Any custom transition must inherit the Transition class or one of its subclasses.

When inheriting Transition directly, implement the OnStarted method to begin the transtion and the OnCompleted method to clean up the transtion once it has ended. The transition must call the and the EndTransition method when the transition is complete. That method in turn calls OnCompleted for you and also lets the transition presenter know that the transition is complete. If your transition supports a concept of an opposite variant, you can have the GetOppositeTransition method return a new instance of the transition in an opposite variant. Otherwise, have it return the current instance.

An easier way to create custom transitions is via XAML using the StoryboardTransition class. It has four important properties: FromContentStyle, ToContentStyle, FromContentStoryboard, and ToContentStoryboard. The two style properties optionally set a Style to the "from" and "to" content while a transition is occurring. The two storyboard properties optionally set a Storyboard to animate properties on the "from" and "to" contents.

This XAML code shows how to create a custom transition based on a StoryboardTransition that fades in the "to" content while it spins in:

XAML
Copy
​<shared:StoryboardTransition TextSearch.Text="Custom (Spin fade in)" ClipToBounds="True">
    <shared:StoryboardTransition.ToContentStyle>
        <Style TargetType="FrameworkElement">
            <Setter Property="RenderTransform">
                <Setter.Value>
                    <RotateTransform />
                </Setter.Value>
            </Setter>
        </Style>
    </shared:StoryboardTransition.ToContentStyle>
    <shared:StoryboardTransition.ToContentStoryboard>
        <Storyboard>
            <DoubleAnimation Storyboard.TargetProperty="Opacity" From="0" To="1" Duration="0:0:1" />
            <DoubleAnimation Storyboard.TargetProperty="RenderTransform.Angle" From="90" To="0" Duration="0:0:1" />
        </Storyboard>
    </shared:StoryboardTransition.ToContentStoryboard>
</shared:StoryboardTransition>

Many of our built-in transitions a programmatically created and inherit the StoryboardTransitionBase class. By implementing them programmatically, they support Storyboard-based animation but also support the more advanced concepts of multiple directions, modes, etc.

Integrating the WPF Pixel Shader Effects Library

The WPF Pixel Shader Effects Library, which can be found on CodePlex (external), includes several transition effects that leverage the UIElement.Effect property, which is included in .NET 3.5 SP1. These effects are written using Microsoft's High Level Shader Language (HLSL), which provide alot of control over what is rendered.

The TransitionPreview control using banded swirl and cloud reveal transitions

The transitions in the WPF Pixel Shader Effects Library can be easily integrated into the TransitionPresenter and Wizard controls, through the use of a custom transition (described above). The sample application includes a custom transition called EffectTransition, which can be used in your own applications.

This XAML code shows how to utilize the BandedSwirlTransitionEffect in a TransitionPresenter using the EffectTransition class from the sample application:

XAML
Copy
​xmlns:sampleCommon="clr-namespace:ActiproSoftware.Windows.ProductSamples.SharedSamples.Common"
xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"
xmlns:transitionEffects="clr-namespace:TransitionEffects;assembly=TransitionEffects"

...

<shared:TransitionPresenter ... >
    <shared:TransitionPresenter.Transition>
        <sampleCommon:EffectTransition>
            <sampleCommon:EffectTransition.Effect>
                <transitionEffects:BandedSwirlTransitionEffect />
            </sampleCommon:EffectTransition.Effect>
        </sampleCommon:EffectTransition>
    </shared:TransitionPresenter.Transition>
</shared:TransitionPresenter>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Shapes

The Shapes namespace contains shapes that can be used in XAML.

It can be imported with this XML namespace import:

XAML
Copy
​xmlns:shared="http://schemas.actiprosoftware.com/winfx/xaml/shared"

Available Shapes

Type Description
SemiEllipse

A half ellipse shape.

These properties are important:

  • ApexSide - The side upon which the semi-ellipse apex appears.
  • IsClosed - Whether the side opposite the apex is closed.

XAML
Copy
​<shared:SemiEllipse Width="40" Height="20" ApexSide="Top" Fill="Red" />
Triangle

A triangle shape.

These properties are important:

  • ApexSide - The side upon which the triangle apex appears.
  • IsClosed - Whether the side opposite the apex is closed.

XAML
Copy
​<shared:Triangle Width="20" Height="20" ApexSide="Top" Fill="Red" />
Wave

A wave shape.

These properties are important:

  • ApexCount - The number of apexes in the wave.
  • ApexSide - The side upon which the wave apex appears.
  • IsInverted - Whether the 'inside' of the shape occurs on the same side as the apex.

XAML
Copy
​<shared:Wave Width="200" Height="10" ApexSide="Top" ApexCount="10" Stroke="Red" StrokeThickness="1" />
ZigZag

A zig-zag shape.

These properties are important:

  • ApexCount - The number of apexes in the zig-zag.
  • ApexSide - The side upon which the zig-zag apex appears.
  • IsInverted - Whether the 'inside' of the shape occurs on the same side as the apex.

XAML
Copy
​<shared:ZigZag Width="200" Height="10" ApexSide="Top" ApexCount="10" Stroke="Red" StrokeThickness="1" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Serialization

The Serialization namespace contains several classes that are helpful for serializing objects to XAML and persisting hierarchies of data (such as for control layouts) in XML.

This topic contains these sections:

  • Using XamlSerializer to Save/Load Objects from XAML
  • Saving/Loading Object Hierarchies from XML

Using XamlSerializer to Save/Load Objects from XAML

The XamlSerializer class provides helper methods for easily serializing objects to and deserializing objects from XAML.

The XamlSerializer class has these important members:

Member | Description
LoadFromFile Method | Deserializes an object from the specified file.
LoadFromStream Method | Deserializes an object from the specified Stream.
LoadFromString Method | Deserializes an object from the specified XAML string.
LoadFromXmlReader Method | Deserializes an object from the specified XmlReader.
SaveToFile Method | Serializes the specified object to XAML within a file.
SaveToStream Method | Serializes the specified object to XAML within a Stream.
SaveToString Method | Serializes the specified object to a XAML string.
SaveToXmlWriter Method | Serializes the specified object to XAML by using an XmlWriter.

This sample code shows how to use the SaveToString method to serialize an object named myobject to XAML:

C#
VB
Copy
​string xaml = new XamlSerializer().SaveToString(myobject);
​Dim xaml As String = New XamlSerializer().SaveToString(myobject)

This sample code shows how to use the LoadFromString method to later deserialize the from the XAML string:

C#
VB
Copy
​object myobject = new XamlSerializer().LoadFromString(xaml);
​Dim myobject As Object = New XamlSerializer().LoadFromString(xaml)

Saving/Loading Object Hierarchies from XML

There are countless cases where it is useful to persist a hierarchy of data to XML that can be saved and reloaded later.

One example of this is storing the layout of a customizable control such as a NavigationBar, where the end user can reorder and show/hide panes. The layout needs to be saved and restored between application sessions so that their customizations are kept in tact.

The Shared Library has a complete framework for supporting easy serialization and deserialization of a hierarchy of objects (such as layout data) to XML. The framework uses a standard XmlSerializer to do the actual conversion to and from XML but the framework numerous extra features, such as that ability to save/load to various targets like Streams, strings, etc. It also can fire an event any time an object is serialized or deserialized, allowing you to easily store and retrieve custom data anywhere in the serialized output.

Creating the Root Serializer

The first step in creating a serializable hierarchy is making the root serializer class.

This class should inherit the base generic XmlSerializerBase`2 class. The first type parameter indicates the Type of target object represented by the second type parameter's object Type. The second type parameter indicates the Type of the root object that will be serialized, and must inherit XmlObjectBase.

For instance NavigationBar's layout serialization class, NavigationBarLayoutSerializer, is defined as:

Code Snippet
Copy
public class NavigationBarLayoutSerializer : XmlSerializerBase<NavigationBar, XmlNavigationBarLayout> { ... }

The type NavigationBar is the first type parameter since it is the "real" object affected by the layout, and the type XmlNavigationBarLayout is the second type parameter since it is the root object that is serialized.

Next there are three methods to override. First, override GetXmlSerializer to return a standard XmlSerializer that specifies the Types that will be serialized/deserialized.

Second, override ApplyTo with code that examines the RootNode property value and updates the passed object (like a NavigationBar instance.

Third, override CreateRootNodeFor to create the root XML node that will be serialized (like a XmlNavigationBarLayout) for the passed object.

Creating the Serializable Objects

Next, create the objects that will be part of the hierarchy to serialize. The objects must inherit XmlObjectBase. This base class provides several helper methods like converting Point, Size, and Rect objects to and from strings. It also defines a Tag property, useful for persisting custom data via the serialization and deserialization events that fire (see below).

The serializable objects should start with Xml as a naming convention and be located within a Serialization child namespace.

Do use the standard XML serialization attributes on the types and members you define, such as XmlType, XmlElement, XmlAttribute, etc. These attributes help control the XML output during serialization. Remember that all public properties will be serialized.

Serializing and Deserializing

The XmlSerializerBase`2 class defines a number of methods that have the similar definitions as those described above for XamlSerializer. This means that you can save/load from a Stream, string, file, etc. in one line of code.

A difference is that many of the XmlSerializerBase`2 methods get and set its RootNode property, which stores the root XmlObjectBase object that is serialized and deserialized.

This sample code shows how to save a NavigationBar layout to an XML string:

C#
VB
Copy
​string layout = new NavigationBarLayoutSerializer().SaveToString(navBar);
​Dim layout As String = New NavigationBarLayoutSerializer().SaveToString(navBar)

This sample code shows how to load a NavigationBar layout from the XML string:

C#
VB
Copy
​new NavigationBarLayoutSerializer().LoadFromString(layout, navBar);
​New NavigationBarLayoutSerializer().LoadFromString(layout, navBar)

Serializing/Deserializing Custom Data

A key benefit of using the Shared Library's XML serialization framework is that custom data can be inserted anywhere within the serialized data via the handling of an event in the application that calls for the serialization.

This is particularly useful when the developer calling the serialization code didn't write it and doesn't have access to change its code.

To enable insertion of custom data, create an event handler that accepts an ItemSerializationEventArgs argument. Then attach the event handler to the XmlSerializerBase`2.ObjectSerialized event. When you go to serialize data, your method will be called after each object in the hierarchy is serialized.

The Node property in the event arguments provides the XmlObjectBase that is being serialized, and that represents the serializable data for the object indicated in the Item property. You can set the Tag property of the Node to save any custom data with the serialized data.

Deserialization is the same process. Create an event handler with the same argument type and attach it to the XmlSerializerBase`2.ObjectDeserialized event. Your method will be called, passing the same sort of arguments, whenever an object is deserialized. So here you can read your custom data back in.

Note Note
For a good example of serializing custom data, see the NavigationBar Layout Save/Load QuickStart.

Custom Data Types

Sometimes you may be using custom data types in the data that is serialized and deserialized. The XML serializer needs to know about custom data types so that it can properly map XML tags to .NET types. The XmlSerializerBase`2 has a CustomTypes property that allows you to specify custom data types, thereby preventing any exceptions such as:

Code Snippet
Copy
The type YourTypeHere was not expected. Use the XmlInclude or SoapInclude attribute to specify types that are not known statically.

This sample code shows how to register a CustomData type with the serializer, thereby preventing the above exception when performing serialization:

C#
VB
Copy
​serializer.CustomTypes.Add(typeof(CustomData));
​serializer.CustomTypes.Add(GetType(CustomData))

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the product.

Read the following topics that are appropriate for your scenario if you are converting this product from an older version to the latest version.

  • The Converting to v4.0 topic contains information on converting to v4.0 from an older version.
  • The Converting to 2010.2 topic contains information on converting to 2010.2 from an older version.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from an older version.
  • The Converting to 2016.1 topic contains information on converting to 2016.1 from an older version.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to v4.0

During the development of v4.0, we made a commitment to ensure that all our WPF product assemblies are scanned using Visual Studio Code Analysis, and that all warnings are handled appropriately. Code Analysis helps make sure that code is kept up to the highest standards and we are proud to now support it. All of the breaking changes below were made to properly handle Code Analysis warnings.

Many of the changes are related to using EventHandler<>, and will probably only affect you if you have created class-based event handlers since those reference the delegates. The base event args classes remain the same.

This topic contains these sections:

  • Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll
  • Removed CancelRoutedEventHandler, replace with EventHandler<CancelRoutedEventArgs>
  • Removed CustomDrawEventHandler<T>, replace with EventHandler<CustomDrawEventArgs<T>>
  • Removed ItemRoutedEventHandler<T>, replace with EventHandler<ItemRoutedEventArgs<T>>
  • Removed PropertyChangedRoutedEventHandler<T>, replace with EventHandler<PropertyChangedRoutedEventArgs<T>>
  • Removed PropertyChangingRoutedEventHandler<T>, replace with EventHandler<PropertyChangingRoutedEventArgs<T>>
  • DateTimeToStringPattern.RFC1123 Renamed to Rfc1123

Assemblies Renamed ActiproSoftware.*.WPF30.*.dll to ActiproSoftware.*.Wpf30.*.dll

Per Code Analysis guidelines, the WPF portion of the assembly names was renamed to Wpf. If you have any problems with existing references to the assemblies, just remove the old references in your project and new ones. Also be sure your licenses.licx file is up to date with the info listed in the Licensing topic.

Removed CancelRoutedEventHandler, replace with EventHandler<CancelRoutedEventArgs>

Per Code Analysis, all usage of CancelRoutedEventHandler should be replaced with EventHandler<CancelRoutedEventArgs>.

Doing a find/replace on CancelRoutedEventHandler to EventHandler<CancelRoutedEventArgs> should handle all instances of its use.

Instances of usage were:

  • (Ribbon) Group.PopupOpening event
  • (Ribbon) PopupButtonBase.PopupOpeningEvent event
  • (Ribbon) PopupControlService.PopupOpeningEvent event
  • (Ribbon) Ribbon.ApplicationButtonMouseDoubleClickEvent event
  • (Ribbon) RibbonGallery.PopupOpeningEvent event
  • (Shared Library) PopupButton.PopupOpeningEvent event

Removed CustomDrawEventHandler<T>, replace with EventHandler<CustomDrawEventArgs<T>>

Per Code Analysis, all usage of CustomDrawEventHandler<T> should be replaced with EventHandler<CustomDrawEventArgs<T>>.

CustomDrawElementCustomDrawEventArgs has been added as a constructed type for CustomDrawEventArgs<T>.

Instances of usage were:

  • (Shared Library) CustomDrawElement.CustomDrawEvent event - replace signature with EventHandler<CustomDrawElementCustomDrawEventArgs>

Removed ItemRoutedEventHandler<T>, replace with EventHandler<ItemRoutedEventArgs<T>>

Per Code Analysis, all usage of ItemRoutedEventHandler<T> should be replaced with EventHandler<ItemRoutedEventArgs<T>>.

ContextMenuItemRoutedEventArgs, DependencyObjectItemRoutedEventArgs, and ObjectItemRoutedEventArgs have been added as constructed types for ItemRoutedEventArgs<T>.

Instances of usage were:

  • (Navigation) Breadcrumb.OverflowButtonClickEvent event - replace signature with EventHandler<ContextMenuItemRoutedEventArgs>
  • (Navigation) BreadcrumbItem.NavigateButtonClickEvent event - replace signature with EventHandler<ContextMenuItemRoutedEventArgs>
  • (Navigation) NavigationBar.CustomizeButtonClickEvent event - replace signature with EventHandler<ContextMenuItemRoutedEventArgs>
  • (Ribbon) GalleryBase.ItemClickEvent event - replace signature with EventHandler<ObjectItemRoutedEventArgs>
  • (Ribbon) CloneService.CloneCreatedEvent event - replace signature with EventHandler<DependencyObjectItemRoutedEventArgs>
  • (Ribbon) CloneService.CloneCreatingEvent event - replace signature with EventHandler<DependencyObjectItemRoutedEventArgs>
  • (Ribbon) CloneService.CloneDisposedEvent event - replace signature with EventHandler<DependencyObjectItemRoutedEventArgs>
  • (Ribbon) RibbonControlService.ItemClickEvent event - replace signature with EventHandler<ObjectItemRoutedEventArgs>

Removed PropertyChangedRoutedEventHandler<T>, replace with EventHandler<PropertyChangedRoutedEventArgs<T>>

Per Code Analysis, all usage of PropertyChangedRoutedEventHandler<T> should be replaced with EventHandler<PropertyChangedRoutedEventArgs<T>>.

BooleanPropertyChangedRoutedEventArgs, BreadcrumbItemPropertyChangedRoutedEventArgs, DateTimePropertyChangedRoutedEventArgs, NullableDateTimePropertyChangedRoutedEventArgs, ObjectPropertyChangedRoutedEventArgs, OperationStatePropertyChangedRoutedEventArgs, StringPropertyChangedRoutedEventArgs, TabPropertyChangedRoutedEventArgs, have been added as constructed types for ItemRoutedEventArgs<T>.

Instances of usage were:

  • (Navigation) Breadcrumb.RootContainerChangedEvent event - replace signature with EventHandler<BreadcrumbItemPropertyChangedRoutedEventArgs>
  • (Navigation) Breadcrumb.RootItemChangedEvent event - replace signature with EventHandler<ObjectPropertyChangedRoutedEventArgs>
  • (Navigation) Breadcrumb.SelectedContainerChangedEvent event - replace signature with EventHandler<BreadcrumbItemPropertyChangedRoutedEventArgs>
  • (Navigation) Breadcrumb.SelectedItemChangedEvent event - replace signature with EventHandler<ObjectPropertyChangedRoutedEventArgs>
  • (Navigation) Breadcrumb.SelectedPathChangedEvent event - replace signature with EventHandler<StringPropertyChangedRoutedEventArgs>
  • (Ribbon) ComboBox.ActiveItemChangedEvent event - replace signature with EventHandler<ObjectPropertyChangedRoutedEventArgs>
  • (Ribbon) GalleryBase.ActiveItemChangedEvent event - replace signature with EventHandler<ObjectPropertyChangedRoutedEventArgs>
  • (Ribbon) GalleryBase.SelectedItemChangedEvent event - replace signature with EventHandler<ObjectPropertyChangedRoutedEventArgs>
  • (Ribbon) Ribbon.IsCollapsedChangedEvent event - replace signature with EventHandler<BooleanPropertyChangedRoutedEventArgs>
  • (Ribbon) Ribbon.IsMinimizedChangedEvent event - replace signature with EventHandler<BooleanPropertyChangedRoutedEventArgs>
  • (Ribbon) Ribbon.SelectedTabChangedEvent event - replace signature with EventHandler<TabPropertyChangedRoutedEventArgs>
  • (Ribbon) RibbonControlService.ActiveItemChangedEvent event - replace signature with EventHandler<ObjectPropertyChangedRoutedEventArgs>
  • (Shared Library) AnimatedProgressBar.StateChangedEvent event - replace signature with EventHandler<OperationStatePropertyChangedRoutedEventArgs>
  • (Shared Library) ActiproSoftware.Windows.Controls.Calendar.DateTimeControlBase.ActiproSoftware.Windows.Controls.Calendar.DateTimeControlBase.DateTimeChangedEvent event - replace signature with EventHandler<DateTimePropertyChangedRoutedEventArgs>
  • (Shared Library) ActiproSoftware.Windows.Controls.Calendar.MonthCalendar.ActiproSoftware.Windows.Controls.Calendar.MonthCalendar.SelectedDateChangedEvent event - replace signature with EventHandler<NullableDateTimePropertyChangedRoutedEventArgs>
  • (Shared Library) ActiproSoftware.Windows.Controls.ValueEditBox`1.ActiproSoftware.Windows.Controls.ValueEditBox`1.ValueChangedEvent event

Removed PropertyChangingRoutedEventHandler<T>, replace with EventHandler<PropertyChangingRoutedEventArgs<T>>

Per Code Analysis, all usage of PropertyChangingRoutedEventHandler<T> should be replaced with EventHandler<PropertyChangingRoutedEventArgs<T>>.

TabPropertyChangingRoutedEventArgs has been added as a constructed type for PropertyChangingRoutedEventArgs<T>.

Instances of usage were:

  • (Ribbon) Ribbon.SelectedTabChangingEvent event - replace signature with EventHandler<TabPropertyChangingRoutedEventArgs>

DateTimeToStringPattern.RFC1123 Renamed to Rfc1123

This enumeration value was renamed to comply with proper .NET naming conventions.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2010.2

Any breaking changes made to the Shared Library are described below.

This topic contains these sections:

  • Replaced XmlSerializerBase Notification Handlers

Replaced XmlSerializerBase Notification Handlers

The XmlSerializerBase`2 class included two properties, called ObjectDeserializedHandler and ObjectSerializedHandler, which were called every time an object was deserialized or serialized, respectively. These two properties were replaced with proper events called ObjectDeserialized and ObjectSerialized, respectively.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.2

Any breaking changes made to the Shared Library are described below.

This topic contains these sections:

  • Theming Architectural and Style Changes
  • Calendar Controls Moved to Legacy Assembly
  • Chromes Moved to Legacy Assembly
  • Consolidated Converters
  • ThemedResourceDictionary's GetLocationUri Method Moved
  • Removed State-Oriented Properties
  • Removed Theme-Related Properties
  • Removed CommonProgressBarBrushConverter

Theming Architectural and Style Changes

See unified conversion topic for details on breaking changes made to the theming architecture, which affects control styles and related dictionaries.

Calendar Controls Moved to Legacy Assembly

The ActiproSoftware.Windows.Controls.Calendar.DateTimePicker and ActiproSoftware.Windows.Controls.Calendar.MonthCalendar controls, as well any supporting classes/controls, have been deprecated in favor of the DateTimeEditBox and MonthCalendar controls found in our Editors for WPF product. As such, these controls have been removed from the Shared Library.

In order to alleviate any issues our customers may have upgrading and transitioning to the new controls, these controls are still available in our Legacy assembly. The controls will still be located in the same CLR And XAML namespaces.

Upgrade Instructions Upgrade Instructions
Add a reference to ActiproSoftware.Legacy.Wpf.dll to your project.

Chromes Moved to Legacy Assembly

The ActiproSoftware.Windows.Controls.Primitives.AeroButtonChrome, ActiproSoftware.Windows.Controls.Primitives.LunaButtonChrome, and ActiproSoftware.Windows.Controls.Primitives.RoyaleButtonChrome controls have been deprecated in favor of the ElementChrome control. As such, these controls have been removed from the Shared Library.

In order to alleviate any issues our customers may have upgrading and transitioning to the new controls, these controls are still available in our Legacy assembly. The controls will still be located in the same CLR And XAML namespaces.

In addition, the LunaButtonChrome has been updated to use the ActiproSoftware.Windows.Controls.Primitives.LunaThemeColor enumeration, instead of the ThemeColor enumeration from the PresentationFramework.Luna.dll assembly. This change allows us to remove any dependencies on the PresentationFramework.Luna.dll assembly.

Upgrade Instructions Upgrade Instructions
  1. Add a reference to ActiproSoftware.Legacy.Wpf.dll to your project.
  2. All references to ThemeColor must be replaced with LunaThemeColor.

Consolidated Converters

The ActiproSoftware.Windows.Controls.Calendar.DateTimePicker and ActiproSoftware.Windows.Controls.Calendar.MonthCalendar controls (which are now located in our Legacy assembly) and the DateTimeEditBox and MonthCalendar controls found in our Editors for WPF product used identical IValueConverters to convert certain date types to strings. These converters have been consolidated to reduce duplication and confusion.

The DateTimeToStringConverter and DateTimeToStringPattern types were replaced with DateTimeFormatPatternConverter and DateTimeFormatPattern, respectively. In addition, the DateTimeToStringPattern.Default was replaced with DateTimeFormatPattern.ShortDateTime.

The DayOfWeekToStringConverter and DayOfWeekToStringPattern types were replaced with DayOfWeekFormatPatternConverter and DayOfWeekFormatPattern, respectively. In addition, the DayOfWeekToStringPattern.Default was replaced with DayOfWeekFormatPattern.Full.

Upgrade Instructions Upgrade Instructions
  1. All references to DateTimeToStringConverter must be replaced with DateTimeFormatPatternConverter. For XAML files, shared:DateTimeToStringConverter must be replaced with shared:DateTimeFormatPatternConverter.
  2. All references to DateTimeToStringPattern must be replaced with DateTimeFormatPattern. For XAML files, shared:DateTimeToStringPattern must be replaced with shared:DateTimeFormatPattern.
  3. All references to DayOfWeekToStringConverter must be replaced with DayOfWeekFormatPatternConverter. For XAML files, shared:DayOfWeekToStringConverter must be replaced with shared:DayOfWeekFormatPatternConverter.
  4. All references to DayOfWeekToStringPattern must be replaced with DayOfWeekFormatPattern. For XAML files, shared:DayOfWeekToStringPattern must be replaced with shared:DayOfWeekFormatPattern.
  5. All references to DayOfWeekToStringPattern.Default must be replaced with DayOfWeekFormatPattern.Full. For XAML files, any assignments that use "Default" must be replaced with "Full".

ThemedResourceDictionary's GetLocationUri Method Moved

The ThemedResourceDictionary.GetLocationUri method has been moved to ResourceHelper, which provides several other helpful overloads.

Upgrade Instructions Upgrade Instructions
All references to ThemedResourceDictionary.GetLocationUri must be replaced with ResourceHelper.GetLocationUri.

Removed State-Oriented Properties

Various state-oriented brush properties were removed to make control styles more consistent. These brushes can be customized by redefining the associated resource or using custom styles/triggers.

note note
See the Reusable Assets topic for more information on redefining asset resources.

  1. Removed the following properties from AnimatedExpander:
    • HeaderBackgroundHover
    • HeaderBackgroundNormal
    • HeaderBackgroundPressed
    • HeaderBorderBrushHover
    • HeaderBorderBrushNormal
    • HeaderBorderBrushPressed
    • HeaderBorderThickness
    • HeaderForegroundHover
    • HeaderForegroundNormal
    • HeaderForegroundPressed
  2. Removed the following properties from AnimatedProgressBar:
    • ForegroundError
    • ForegroundNormal
    • ForegroundPaused
    • HighlightError
    • HighlightPaused
    • HighlightNormal
  3. Removed the following properties from RadioButtonList:
    • BackgroundDisabled

Upgrade Instructions Upgrade Instructions
All references to these properties would need to be removed. In order to custom the various brushes, the associated resource would need to be customized.

Removed Theme-Related Properties

Various theme-related properties were removed as they were no longer needed.

  1. Removed the following properties from ThemeProperties:
    • AreAnimationsEnabled (renamed to IsAnimationEnabled)
    • BackgroundHover
    • BackgroundNormal
    • BackgroundPressed
    • BackgroundSelected
    • BackgroundHighlightHover
    • BackgroundHighlightNormal
    • BackgroundHighlightPressed
    • BackgroundHighlightSelected
    • DecorationDark
    • DecorationLight
    • ForegroundHover
    • ForegroundNormal
    • ForegroundPressed
    • ForegroundSelected
    • InnerBorderHover
    • InnerBorderNormal
    • InnerBorderPressed
    • InnerBorderSelected
    • OuterBorderHover
    • OuterBorderNormal
    • OuterBorderPressed
    • OuterBorderSelected

Upgrade Instructions Upgrade Instructions
All references to these properties would need to be removed/updated

Removed CommonProgressBarBrushConverter

The deprecated value converter CommonProgressBarBrushConverter was replaced by ProgressBarSegmentedBrushConverter.

Upgrade Instructions Upgrade Instructions
All references to CommonProgressBarBrushConverter can be replaced with ProgressBarSegmentedBrushConverter.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2016.1

Any breaking changes made to the Shared Library and Themes are described below.

This topic contains these sections:

  • Metro Themes Merged Into Shared Library
  • Luna/Royale Themes Split Into Separate Library
  • WindowChrome Updated to Only Allow Aero Glass on Windows 7 and Vista

Metro Themes Merged Into Shared Library

With the rise in popularity of Metro-like themes in general due to Windows 10/8.x adoption, we have merged the Metro themes from what used to be in the ActiproSoftware.Themes.Metro.Wpf.dll and placed them directly within the Shared Library. There is no more ActiproSoftware.Themes.Metro.Wpf.dll assembly packaged with the WPF Controls.

Since they are located directly in the Shared Library now, Metro themes no longer need to be explicitly registered via a call to the ThemesMetroThemeCatalogRegistrar.Register method.

Also, now Windows 10 and 8.x systems will default to Metro Light theme unless otherwise overridden by setting the ThemeManager.CurrentTheme property. This ensures that a theme will be used on those operating systems that matches overall appearance.

To handle the breaking changes above:

  • Remove any references to the ActiproSoftware.Themes.Metro.Wpf.dll assembly.
  • Remove any calls to the ThemesMetroThemeCatalogRegistrar.Register method.
  • Continue setting the ThemeManager.CurrentTheme property to any Metro theme listed in the Themes Getting Started topic as appropriate. Or specifically set the current theme to another non-Metro theme if you always wish for a non-Metro theme to be used on Windows 10/8.x systems.

The updates for 2016.1 also include multiple new Metro Light and Metro White accent themes that render similar to the Office 2016 apps.

Luna/Royale Themes Split Into Separate Library

Now that Windows XP is past its Microsoft support lifetime, we have removed the XP-related themes (LunaNormalColor, LunaHomestead, LunaMetallic, and RoyaleNormalColor) from the Shared Library and placed them in a new ActiproSoftware.Themes.Luna.Wpf.dll assembly.

If you wish to use these deprecated XP-like themes in your application, you must perform these steps:

  • Add a reference to the ActiproSoftware.Themes.Luna.Wpf.dll assembly.
  • Call the ThemesLunaThemeCatalogRegistrar.Register method during app startup.
  • Set the ThemeManager.CurrentTheme property to an appropriate Luna theme.

It is recommended that most applications move to one of the Metro themes from Luna, since those provide a more modern appearance.

Note Note
Now that the Luna themes are in a separate assembly, they will no longer be automatically applied to applications running on Windows XP when ThemeManager.CurrentTheme hasn't been explicitly set. Instead, the Classic theme will be invoked in Windows XP in that scenario. You must write code in your application startup to see if the application is running on Windows XP, and then set ThemeManager.CurrentTheme to the appropriate Luna theme.

WindowChrome Updated to Only Allow Aero Glass on Windows 7 and Vista

In the previous version, Aero glass effects were allowed on Windows 8.x and 10. However in Windows 10, they don't render correctly. Unfortunately .NET prevents you from detecting if your app is running in Windows 10, unless you specifically add a special app.manifest. Since Aero glass isn't really used on Windows 8.x, we updated WindowChrome to only allow Aero glass to be enabled on Windows 7 and Vista, regardless of what the WindowChrome.IsGlassEnabled property value is.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Value Converters

The Data, Controls, Media namespaces contain numerous value converters that can be used in XAML for working with data.

Type | Description
BooleanAndConverter | Represents a multi-value converter that performs a logical AND (&&) operation on one or more Boolean values passed to the associated MultiBinding object.
BooleanNotConverter | Represents a value converter that performs a NOT (!) operation on a specified Boolean value.
BooleanOrConverter | Represents a multi-value converter that performs a logical OR (||) operation on one or more Boolean values passed to the associated MultiBinding object.
BrushOpacityConverter | Represents a value converter that clones a specified Brush and updates the Brush.Opacity property based on the converter's parameter.
CoalesceConverter | Represents a value converter that returns the value if it is non-null; otherwise, the value of the converter's parameter. This converter can also be used in a MultiBinding, in which case the first non-null value is returned; otherwise, the converter's parameter is returned.
ColorInterpolationConverter

This converter can be used in XAML bindings to return the linear Color value that is the specified percentage between the value of two Color objects.

The optional percentage is indicated in the converter parameter. If not specified, the default of 0.5 (50%) will be used.

Exactly two Color objects must be passed into the converter using a MultiBinding.

This XAML shows how to use the converter to find a color that is between the system control and window colors but 90% towards the window color:

XAML
Copy
​<MultiBinding Converter="{StaticResource ColorInterpolationConverter}" ConverterParameter="0.9">
    <Binding Source="{x:Static SystemColors.ControlColor}" />
    <Binding Source="{x:Static SystemColors.WindowColor}" />
</MultiBinding>
ConditionalConverter Represents a value and multi-value converter that provides if-else functionality for Binding and MultiBinding objects.

This converter expects the following source values to be specified:

  1. Condition - A boolean value indicating whether the true or false value should be returned.
  2. TrueValue - An object that is returned when the Condition is true. This can be omitted if the FalseValue parameter is also omitted, in which case the value of the TrueValue property will be used.
  3. FalseValue - An object that is returned when the Condition is false. This can be omitted, in which case the value of the FalseValue property will be used.

This sample code shows how to use the converter in a MultiBinding in XAML:

XAML
Copy
​<MultiBinding Converter="{StaticResource ConditionalConverter}">
    <Binding Path="IfConditionValue" />
    <Binding Path="TrueValue" />
    <Binding Path="FalseValue" />
</MultiBinding>

This sample code shows how to use the converter in a Binding in XAML:

XAML
Copy
​<shared:ConditionalConverter x:Key="ConditionalConverter" TrueValue="The Value is true" FalseValue="The Value is false" />
...
<TextBlock Text="{Binding Path=BooleanProperty, Converter={StaticResource ConditionalConverter}}" />
CornerRadiusConverter Represents a value converter that converts between a CornerRadius and a number.

XAML
Copy
​... Value="{Binding Path=Number, Converter={StaticResource CornerRadiusConverter}}" ...
DelegateConverter | Represents a value converter that uses delegates to perform the underlying conversion to/from the source. Set the ConvertCallback and ConvertBackCallback properties to the delegates to use for conversion and back conversion respectively.
DurationToMillisecondConverter | Represents a value converter that converts between a Duration and a number of milliseconds.
EnumDescriptionConverter | Represents a value converter that uses the DescriptionAttribute for the string representation of the enumeration values, when available.
ImageConverter Represents a value converter that returns a new DynamicImage (inherits Image) control instance created using a specified URI or BitmapSource.

This converter expects the source value to be a Uri, a URI String, or a BitmapSource that can be used to create a new DynamicImage instance. A prefix can be defined in UriPrefix which will be prepended to all source values of type String before the DynamicImage is created.

ImageSourceContentConverter Represents a value converter that converts an image source's content to a grayscale or monochrome version of the image.

The Mode property specifies the conversion mode, which can be Grayscale (default) or Monochrome.

InverseConverter | Represents a value converter that inverts another value converter. Set an instance of the IValueConverter to invert in the Converter property.
IsEnumFlagSetConverter | Represents a value converter that returns whether the specified enumeration value has the flag, specified by the converter's parameter, set.
IsNullOrEmptyConverter | Represents a value converter that returns whether the specified value is null, and if it is a string, also if it is null or empty.
IsTypeConverter | Represents a value converter that returns whether the specified object is the Type indicated in the converter's parameter.
MultiplicationConverter | Represents a single and multi-value converter that multiplies all the source values provided, and optionally the converter's parameter.
NoOpConverter Represents a value converter that does not alter the value in any way (e.g. no operation).

This converter can be used to bypass an issue that arises from an optimization present in the WPF binding system.
ParallaxConverter Represents a value converter that can be used to create a parallax background scrolling effect.

Use the converter in a binding on a background element's RenderTransform's TranslateTransform.X or Y property, and bind to a related ScrollViewer.HorizontalOffset or VerticalOffset property.
PercentageConverter | Represents a value converter that converts between a number and a percentage. The percentage is simply the number multiplied by 100.
StringFormatConverter Represents a multi-value converter that provides String.Format functionality for both simple Binding and MultiBinding objects.

Pass the format string in the converter's parameter. Since { characters are normally interpreted as markup extension starts, you can escape them by placing {} before the format string like this:

XAML
Copy
​<MultiBinding Converter="{StaticResource StringFormatConverter}" ConverterParameter="{}{0} of {1}">...
ThicknessConverter Represents a value converter that converts between a Thickness and a number.

By default, the Thickness returned will have all four sides (Thickness.Left, Thickness.Top, Thickness.Right, and Thickness.Bottom) set to the specified number. An optional parameter of type Sides can be specified, which can be used to customize the sides that are set.

XAML
Copy
​<!-- Set all four sides -->
... Value="{Binding Path=Number, Converter={StaticResource ThicknessConverter}}" ...

<!-- Only set the Left and Right sides -->
... Value="{Binding Path=Number, Converter={StaticResource ThicknessConverter}, ConverterParameter='Left,Right'}" ...
TypeNameConverter | Represents a value converter that converts a value to a String of its short type name.
UnitToDoubleConverter Represents a value converter that converts between a Unit and a Double.

This converter needs additional information in order to convert a Double into a Unit. Specifically, it needs to the know whether the value is measured in pixels or as a percentage. To accommodate this need, the property Type is used to specify the type of measurement.

UriConverter Represents a value converter that returns a new Uri instance created using the specified URI string combined with an optional URI prefix.

This converter expects the source value to be a String which, when combined with the UriPrefix, can be used to create a new Uri instance.

ZoomLevelToTextFormattingModeConverter Represents a value converter that alters the TextFormattingMode based on the specified zoom level.

Display mode is used when the zoom level is 1.0. Ideal mode is used when the zoom level is increased.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Customizing String Resources

This topic contains these sections:

  • What is a String Resource?
  • Localization
  • Getting/Setting Custom Strings with the SR Class
  • The SRName Enumeration
  • The SRExtension XAML Markup Extension

What is a String Resource?

A string resource is a text string that generally can be displayed in the user interface of our products.

For instance, when hovering the mouse over the NavigationBar control's customize button, a tooltip whose default text is Configure Buttons is displayed. The string Configure Buttons is defined as a string resource in the Navigation product's assembly.

All WPF Studio products that have displayable strings have string resources defined for those items. You can view all the string resources in our products with the String Resource Browser.

Localization

The default string resources in our products are defined in US English.

Our products have a nice framework that offers you the ability to alter any string resource to use custom text. This feature can be used in two main cases: simple changing of various strings to other strings that you prefer instead, and for localization.

In the first case, maybe you are building a US English-based application but wish to change one or two of the items to alternate text.

In the second case, you may wish to provide localization on the strings for any language based on the current culture that is running your application. Here you would want to customize the full set of string resources for each product that has string resources.

Note Note
In addition to the string resource customization capabilities, all string properties in the WPF Studio products have the appropriate Localizability attributes set.

Getting/Setting Custom Strings with the SR Class

Products that have string resources have a class named SR (string resource) in their ActiproSoftware.Products.[ProductName] namespace. For instance, the Navigation product has the ActiproSoftware.Products.Navigation.SR class.

The SR class contains static methods allowing you to customize any string resources and return the resolved value of a string resource between its default value and any customizations you may have made. Even if you haven't made any customizations, the SR class is ideal for returning the default string resource values via a call to its GetString method.

Important Note Important Note
Any string resource customizations must be performed at application startup such as in Application.OnStartup, before any UI or controls have been referenced. This must be done since some string resources are used by static class initializers. Therefore your customizations may not be picked up if not set immediately upon application startup before UI classes are referenced.

These are the important members on any SR class implementation:

Member | Description
ClearCustomStrings Method | Removes all custom strings.
ContainsCustomString Method | Returns whether a custom string is defined for the specified string resource.
GetCustomString Method | Returns the custom string that is stored for the specified string resource, if any.
GetString Method | Returns the resolved value of the specified string resource. There is an overload that takes an optional argument list. This overload returns the resolved value of the specified string resource, by calling String.Format using the supplied arguments.
RemoveCustomString Method | Removes any custom string that is defined for the specified string resource
SetCustomString Method | Sets a custom string value for the specified string resource.

This code shows how to set a custom string for the NavigationBar's customize button tooltip:

C#
VB
Copy
​SR.SetCustomString(SRName.UINavigationBarCustomizeButtonToolTip.ToString(), "Custom Tooltip Text");
​SR.SetCustomString(SRName.UINavigationBarCustomizeButtonToolTip.ToString(), "Custom Tooltip Text")

This code shows how to retrieve the resolved value of a string resource (including any customizations):

C#
VB
Copy
​string text = SR.GetString(SRName.UINavigationBarCustomizeButtonToolTip);
​Dim text As String = SR.GetString(SRName.UINavigationBarCustomizeButtonToolTip)

Note Note
Use the String Resource Browser in the Sample Browser to browse all available string resources and easily generate string resource customization code.

The SRName Enumeration

To make discovery and verification of string resource names even easier, each product that has string resources will also have an enumeration named SRName defined in the same namespace as SR.

The SRName enumeration has one value for each string resource name in the product. You can call ToString on a value to convert it to a string when working with various methods on SR.

The SRExtension XAML Markup Extension

While the SR class makes it simple to access any resolved string resource value from code, we also wanted to provide an easy way to use resolved string resources in XAML, such as in templates for controls. To accomplish this, we created the SRExtension class that is available in any product that has string resources.

The first step in using the markup extension in your XAML is to declare a namespace in your XAML root tag. The namespace should be declared for the product whose string resources you will be accessing. For this sample, we will access a string resource for a Navigation control:

XAML
Copy
​xmlns:productsNavigation="clr-namespace:ActiproSoftware.Products.Navigation;assembly=ActiproSoftware.Navigation.Wpf"

Now lets use the UINavigationBarCustomizeButtonToolTip resource's text as a Button's content:

XAML
Copy
​<Button Content="{productsNavigation:SRExtension UINavigationBarCustomizeButtonToolTip}" />

That's all there is to it!

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


XBAP Support

An XBAP is a compiled application that can be deployed to a web server and launched via ClickOnce from within the Internet Explorer web browser. The benefits of an XBAP are that they provide Windows application-like user interface features within a browser window.

This topic contains these sections:

  • WPF Studio XBAP Product Support
  • Deploying WPF Studio Controls with an XBAP Project
  • Licensing WPF Studio Controls in an XBAP Project
  • Evaluation XBAP Licenses
  • Product-Specific Notes: Actipro Docking & MDI
  • Product-Specific Notes: Actipro Editors
  • Product-Specific Notes: Actipro Ribbon
  • Product-Specific Notes: Actipro Wizard
  • Product-Specific Notes: Actipro Shared Library

WPF Studio XBAP Product Support

All of the controls in WPF Studio are fully capable of being used within XBAP browser-based applications.

We've specifically engineered them to work with the tight browser security restrictions that are placed on XBAP applications.

Ribbon in an XBAP

Deploying WPF Studio Controls with an XBAP Project

There are several things that need to be done to properly deploy an XBAP application that uses WPF Studio controls.

Assembly References

First ensure that all Actipro assemblies that you use are referenced by your XBAP project. All our control assemblies reference the ActiproSoftware.Shared.Wpf assembly too so even if you don't directly use anything in there, that assembly must be referenced as well.

Copy Local

Be sure that your Actipro assembly references are all set to Copy Local. This ensures that they will be properly copied when you go to deploy your XBAP.

If you deploy an XBAP and the Actipro assemblies are not included, your end users will receive an error message like this one:

Code Snippet
Copy
Platform Requirements Not Met
Unale to install or run the application. The application requires that assembly ActiproSoftware.Shared.WPF be installed in the Global Asembly Cache (GAC) first.

This message is misleading because as long as you deploy our assemblies with your XBAP, our assemblies do NOT need to be in the GAC. Also, you should NEVER install our assemblies into an end user's GAC.

Licensing

Due to a Microsoft oversight when assigning the security restrictions to XBAPs, both the evaluation and full releases of the WPF Studio controls can't do licensing the "normal" way. Please read the following sections to learn more about getting licenses for the WPF Studio controls working in an XBAP so that your end users don't see any "unlicensed" popups.

Licensing WPF Studio Controls in an XBAP Project

Unfortunately Microsoft didn't consider licensed controls when developing the partial trust model for XBAP. This means that as third-party control developers, we are unable to read licenses the "normal" way you would for a Windows application because if we try, partial trust security exceptions fire. We have alerted them to this issue and they have a bug filed.

The good news is that we developed an alternative licensing approach that can be used for XBAP scenarios only. Please log into your Actipro account on the Actipro web site and navigate to your organization account page's 'Purchases and Licenses' tab. There will be a link next to the WPF product for generating an XBAP license. Follow the steps on that page to generate a .licenses file that can be used in your XBAP project.

Once you have the .licenses file, follow these steps:

  • Save the .licenses File to a Folder in Your XBAP Project: Save the .licenses file that is generated to a folder in your XBAP project.
  • Change the .licenses File's Build Action to Embedded Resource: Next include the .licenses file as an Embedded Resource by right clicking it in Visual Studio's Solution Explorer, selecting Properties, and on that tool window, changing the Build Action to Embedded Resource.
  • Rebuild Solution: Finally, rebuild your solution and your XBAP project should be licensed.

Please note that the XBAP project MUST output an assembly with the assembly name you used to request a license or licensing will fail. If you need to use our WPF Studio controls in more than one XBAP project, then multiple license requests must be made.

Invalid or expired evaluation licenses will display a license message on top of the controls and may restrict some run-time and designer functionality. We apologize for this separate licensing process for XBAP but our hands are a bit tied on this.

Evaluation XBAP Licenses

Licenses for evaluating WPF Studio products in an XBAP can be requested from us via e-mail and will expire after a certain point. To make a request for an evaluation XBAP license, send support@actiprosoftware.com an e-mail with this information (fill in as appropriate):

Copy
I would like the WPF Studio XBAP license key.  Please use the following information for the license and e-mail it back to me:

Licensee:  [your organization name]
License Type:  Evaluation
Calling Assembly:  [the name of the assembly that will call the WPF Studio controls]

Once you receive an evaluation .licenses file from Actipro, follow the steps listed above to use it.

Product-Specific Notes: Actipro Docking & MDI

Docking & MDI can be used in an XBAP, just like as in a Windows application. The only difference is that instead of placing the DockSite control in a Window, you would place it in a Page instead.

Floating Windows

Since normal floating windows inherit Window and Window types are not supported in XBAP, hosted floating windows are automatically used in an XBAP. They provide similar functionality to normal rafting windows and even have additional inactivity fade out animation.

Product-Specific Notes: Actipro Editors

Editors can be used in an XBAP, just like as in a Windows application, with any differences described below.

Clipboard

The Editors controls will use the system clipboard for copy/cut/paste operations when it has sufficent permissions to do so. When running in a partial-trust XBAP, clipboard operations are typically restricted. Therefore, the Editors controls will use an internal clipboard when it cannot access the system clipboard, in order to provide copy/cut/paste functionality between Editors controls. The permission UIPermissionClipboard.AllClipboard is checked to determine if the system clipboard can be accessed.

Product-Specific Notes: Actipro Ribbon

Ribbon can be used in an XBAP, just like as in a Windows application. The only difference is that instead of placing the Ribbon control in a Window, you would place it in a Page instead.

RibbonWindow

Since RibbonWindow inherits Window and Window types are not supported in XBAP, you cannot use RibbonWindow in an XBAP. Add your Ribbon controls directly to a Page instead.

Popup Transparency

Popup transparency is not supported in XBAP. However this should not be an issue because we've designed our control styles to look fine without it when used in an XBAP.

Mini-ToolBar

Due to XBAPs not being capable of supporting transparency in popups, the Mini-ToolBar is not supported in XBAP.

Product-Specific Notes: Actipro Wizard

Wizard can be used in an XBAP, just like as in a Windows application. The only difference is that instead of placing the Wizard control in a Window, you would place it in a Page instead.

AeroWizardWindow

Since AeroWizardWindow inherits Window and Window types are not supported in XBAP, you cannot use AeroWizardWindow in an XBAP. Add your AeroWizard controls directly to a Page instead.

Page's ShowsNavigationUI

A setting you may wish to make on the Page is to set the ShowsNavigationUI property to false since the navigation is handled by the Wizard control instead.

Product-Specific Notes: Actipro Shared Library

GlassWindow

Since GlassWindow inherits Window and Window types are not supported in XBAP, you cannot use GlassWindow in an XBAP.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Licensing

This topic talks about the various product licensing options available, and walks through how to apply licensing when both evaluating and after a purchase.

Note Note
Starting in v2017.1, we simplified the licenses.licx file entries that are required. Now a single entry is used, and all older entries should be removed. Please see the information below for details on the new entry.

This topic contains these sections:

  • License Types
  • Free Subscriptions and Free New Products
  • No Runtime, Server, Distribution Royalties
  • Purchasing Licenses
  • Steps to Install and Apply Licenses
  • Licenses.licx Files and Valid Entries
  • Notes on Build Machines
  • Troubleshooting
  • Licensing Questions?

License Types

Evaluation License

Under the Evaluation License, you may only use the product for evaluation purposes for a period of 30 days, after which you must either remove all files associated with the product or purchase a Single Developer License for each individual developer on a project that uses the product.

Evaluation versions of the products may include some background watermarks or other means of displaying they are not licensed versions, all of which are removed once licenses are purchased.

Single Developer License

Single Developer Licenses must be purchased for each individual developer on a project using a product and may NOT be transferred between developers. This license grants each developer the right to use the purchased products in production applications and to include any files marked as redistributable with their applications.

Site License

Site licenses may be purchased, automatically giving all developers at a physical location a Single Developer License.

Enterprise License

Enterprise licenses may be purchased, automatically giving all developers in your entire organization and at all sites a Single Developer License.

Blueprint License (Source Code)

Blueprint licenses enable access to product source code. The term of Blueprint licenses must be kept in sync with product subscriptions. Please read the EULA to see the Blueprint license terms and conditions.

Free Subscriptions and Free New Products

All of the non-evaluation licenses described above for our WPF products include one full year of free upgrades to any new versions that are released within that timeframe.

In addition, customers with active WPF Studio subscriptions will receive any new products added to the suite for free while the subscription is active.

No Runtime, Server, Distribution Royalties

Actipro Software control products have NO runtime, server, or distribution royalties if you own the proper amount of developer licenses for your development team (see above).

Purchasing Licenses

Licenses may be purchased directly from the Actipro web site. After a purchase has been made and the purchase has been processed, you will be e-mailed information on how to log into your Actipro account on our web site. Use the login information contained within the e-mail to log into the site.

Once you are within your account on our web site, download the latest release and e-mail yourself your license key. Then be sure to follow the instructions in the following sections to properly license the product for use in your applications.

Steps to Install and Apply Licenses

Although there are several steps involved in licensing your Actipro WPF controls after a purchase, it really is very simple and fast to complete them.

Special Note for XBAP Licensing Special Note for XBAP Licensing
XBAPs require a different method of licensing due to security restrictions. See the XBAP Support for information on how to apply licenses for our products when used in XBAP projects.

The summary of the steps is that you enter your Licensee and License Key during install, compile our sample project to see if you entered them correctly, update your project's licenses.licx file and you should be done.

The following detailed steps indicate how to install and license Actipro products for both fresh install and upgrade situations.

  1. First, obtain the licensing information (Licensee and License Key) to use.
    1. If you have purchased licenses for the product, e-mail yourself the licensing information for the product from your Actipro account's page for your organization.
    2. If you are evaluating, the Actipro products should already be pre-configured for evaluation and may show nag screens. No further action is needed by you to register an evaluation license.
  2. If you don't already have the latest product build installed, or if you need to enter your license information...
    1. Download the latest build of the product from your Actipro account's page for your organization.
    2. Uninstall any old version of the product that is on your machine.
    3. Install the latest build on your machine.
    4. Choose whether you are evaluating or have already licensed the product.
      1. If you have chosen the already licensed the product, an installer step will prompt for customer information. Enter your name along with the Licensee and License Key exactly as specified in the e-mail you sent to yourself in an earlier step.
    5. On the Custom Setup installer step, review the options that you'd like to install. For build servers, the documentation, samples, and designer integration install options may be turned off.
    6. Complete the install.
  3. After completing the installation, we highly recommend that you open one of our sample projects for the product and try to rebuild its solution and run it. If it runs without any license popup window displaying, then you installed the control correctly. If it displays a license popup window, then you most likely did not enter the Licensee or License Key correctly in the previous step and need to reinstall. Again, ensure both of them match exactly with what is in our license e-mail.
  4. When adding products to your application the first time...
    1. Add references to the Actipro product assemblies that are being used. Default assembly install paths are indicated in the Readme file. Please note that the ActiproSoftware.Shared.Wpf.dll assembly is always required since all products depend on it.
  5. When upgrading products to new versions in an application that used old versions...
    1. Ensure the references to the Actipro product assemblies are correctly pointing to the new version's assemblies you installed. Default assembly install paths are indicated in the Readme file. Update the references as needed to make sure the versions are correct.
  6. If you have licensed the product, configure the licenses.licx file in the projects that reference the product.
    1. Open your project in Visual Studio and ensure that there is a licenses.licx file in it. If your project does not contain a licenses.licx file, follow the steps in the Troubleshooting / No licenses.licx file exists in my project section below to create a licenses.licx file manually.
    2. Ensure that the licenses.licx has a correct entry for Actipro's WPF control products. The valid entry is listed below in this topic. Ensure the version numbers in the entry always match the deployed assembly version, especially after upgrading to a new version or build.
  7. In Visual Studio, execute Clean Solution and then Rebuild Solution.

After following these steps, licensing will be properly applied to your application.

Licenses.licx Files and Valid Entries

A licenses.licx file is a file that Visual Studio maintains to know what third-party licensed components and controls are included in a project. Visual Studio then uses that information to know what license data it needs to include in the output assembly for your project. Therefore, if you use a third-party component and don't have the proper entries in your project's licenses.licx file, no licensing information will be included in your project's output assembly and licensing popup windows will display when your application is run on end user computers.

The contents of a licenses.licx file are pretty simple. It needs a single line that supplies license information to all Actipro WPF control products for which you are licensed. Version numbers in this file should always be entered in "short" form (i.e. 10.1.501) as opposed to the "long" form (i.e. 10.1.0501) that we generally display on About windows. Make sure that the version numbers, including build, match exactly with the version number of the control that is installed.

This single line should be added to the licenses.licx file in any project that uses Actipro WPF control or SyntaxEditor add-on products:

licenses.licx File
Copy
ActiproSoftware.Products.ActiproLicenseToken, ActiproSoftware.Shared.Wpf, Version=19.1.682.0, Culture=neutral, PublicKeyToken=36ff2196ab5654b9

Notes on Build Machines

Just like when compiling on developer machines, build machines need to be able to locate license information, so that Visual Studio and/or MSBuild can embed it in your application. Therefore after licensing the product, it must be installed using the already licensed option at least once on any build machine that will be compiling your application. This process installs the license information into the machine's registry. The install can be done with minimal options and can be uninstalled immediately after. The license information will remain in the machine's registry.

This process is only necessary once per major/minor version (e.g. 2011.1). It doesn't need to be repeated for maintenance releases.

We do not charge additional licensing fees for build machines.

Troubleshooting

I've purchased licenses and followed the steps above but a license popup window says 'Error: The licensee or license key that was entered is invalid'.
This means that you didn't enter the Licensee and License Key exactly as specified in our license e-mail. Reinstall the product and be sure that both of those items match exactly with what is in our license e-mail. The most common licensing mistake is when the Licensee (organization name) doesn't match what is in the license e-mail.
No licenses.licx file exists in my project.
If you don't see a licenses.licx file in your Visual Studio project (generally in the Properties folder), first ensure that the Show All Files option is set. The Show All Files command is in the Visual Studio Solution Explorer tool window's toolbar. If you still don't see one, follow these steps:
  1. Right click on your project and select Add -> Add New Item.
  2. Select a Text File and name it licenses.licx.
  3. Ensure its Build Action is set to Embedded Resource. This can be done in the Visual Studio Properties tool window when the licenses.licx file is selected.
  4. Copy the line from the sample licenses.licx file above into it.
A licenses.licx file exists but there is no entry for the Actipro Software product I purchased.
You can add the necessary line manually to the file. Copy the line into your application's licenses.licx file from the sample licenses.licx file above.
A licenses.licx file exists and I've copied the entry above, but I still get a license popup window.
Make sure the licenses.licx file is included as an Embedded Resource in your project. The license popup window should bold the product name that caused it to show, and icons next to each product indicate if they are covered under your license. Also note that the SyntaxEditor language add-ons are sold separately from SyntaxEditor and WPF Studio.
A licenses.licx file exists and there is an entry for the Actipro Software products, however the version number is wrong.
This situation can occur if you upgraded to a new version. Be sure that you update the version number in the licenses.licx in every project that uses the product. The version number should be the same as the version number of the product that is used. Also ensure that the PublicKeyToken entry matches with the entry in the sample licenses.licx file above.
I've purchased licenses, installed using the 'already licensed' option, and followed the steps above but a license popup window says 'Evaluation Release'.
Vista has a "feature" where it may virtualize registry entries that are made by the evaluation release of our products post-installation. This is called the VirtualStore. What happens is that an evaluation registry gets cached in the virtual store and Visual Studio may choose to use that instead of a full release license key that you installed in the setup program. To clear this up, use regedit, go to this key and remove it:
HKEY_CURRENT_USER\Software\Classes\VirtualStore\MACHINE\SOFTWARE\[Wow6432Node]\Actipro Software\WPF Controls\[Version]
The Wow6432Node part of the path above is only used on 64-bit machines, leave it out on 32-bit machines. Then rebuild your project and it should pull in the correct license key you entered during installation.

Licensing Questions?

If you have any further questions regarding purchasing or licensing, please contact us. We're happy to help.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Deployment
Deployment Overview

To deploy an application that uses this product, simply copy the redistributable assemblies described below to the same folder as your application's executable. Nothing else needs to be deployed.

Your license information will be compiled into your application by Visual Studio. For more information on how your license is embedded into your application and how to set it up, please read the Licensing topic.

Redistributable Files

When you own a license for WPF Studio (our large control bundle), WPF Essentials (our smaller control bundle), or one of their individual products, you are licensed to redistribute certain files with your application. This chart shows the product assemblies that may be redistributed based on the product for which you own licenses:

Redistributable Files | Products Licensed
 | WPF Studio | WPF Essentials | Bar Code | Charts | Docking & MDI | Editors | Gauge | Grids | Micro Charts | Navigation | Ribbon | Shell | SyntaxEditor | Views | Wizard
ActiproSoftware.BarCode.Wpf.dll | Yes | - | Yes | - | - | - | - | - | - | - | - | - | - | - | -
ActiproSoftware.Charts.Wpf.dll | Yes | - | - | Yes | - | - | - | - | - | - | - | - | - | - | -
ActiproSoftware.DataGrid.Contrib.Wpf.dll | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes
ActiproSoftware.Docking.Wpf.dll | Yes | Yes | - | - | Yes | - | - | - | - | - | - | - | - | - | -
ActiproSoftware.Editors.Wpf.dll | Yes | Yes | - | - | - | Yes | - | - | - | - | - | - | - | - | -
ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll | Yes | Yes | - | - | - | Yes | - | - | - | - | - | - | - | - | -
ActiproSoftware.Editors.Interop.Grids.Wpf.dll | Yes | Yes | - | - | - | Yes | - | Yes | - | - | - | - | - | - | -
ActiproSoftware.Gauge.Wpf.dll | Yes | - | - | - | - | - | Yes | - | - | - | - | - | - | - | -
ActiproSoftware.Grids.Wpf.dll | Yes | - | - | - | - | - | - | Yes | - | - | - | - | - | - | -
ActiproSoftware.MicroCharts.Wpf.dll | Yes | - | - | - | - | - | - | - | Yes | - | - | - | - | - | -
ActiproSoftware.Navigation.Wpf.dll | Yes | Yes | - | - | - | - | - | - | - | Yes | - | - | - | - | -
ActiproSoftware.Ribbon.Wpf.dll | Yes | Yes | - | - | - | - | - | - | - | - | Yes | - | - | - | -
ActiproSoftware.Shell.Wpf.dll | Yes | - | - | - | - | - | - | Yes | - | - | - | Yes | - | - | -
ActiproSoftware.Text.Wpf.dll | Yes | - | - | - | - | - | - | - | - | - | - | - | Yes | - | -
ActiproSoftware.Text.LLParser.Wpf.dll | Yes | - | - | - | - | - | - | - | - | - | - | - | Yes | - | -
ActiproSoftware.SyntaxEditor.Wpf.dll | Yes | - | - | - | - | - | - | - | - | - | - | - | Yes | - | -
ActiproSoftware.Text.Addons.Antlr.Wpf.dll | Yes | - | - | - | - | - | - | - | - | - | - | - | Yes | - | -
ActiproSoftware.Text.Addons.Dataflow.Oslo10.dll | Yes | - | - | - | - | - | - | - | - | - | - | - | Yes | - | -
ActiproSoftware.Text.Addons.Irony.Wpf.dll | Yes | - | - | - | - | - | - | - | - | - | - | - | Yes | - | -
ActiproSoftware.Text.Addons.DotNet.Wpf.dll | No * | - | - | - | - | - | - | - | - | - | - | - | No * | - | -
ActiproSoftware.Text.Addons.DotNet.Roslyn.Wpf.dll | No * | - | - | - | - | - | - | - | - | - | - | - | No * | - | -
ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll | No * | - | - | - | - | - | - | - | - | - | - | - | No * | - | -
ActiproSoftware.Text.Addons.JavaScript.Wpf.dll | No * | - | - | - | - | - | - | - | - | - | - | - | No * | - | -
ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll | No * | - | - | - | - | - | - | - | - | - | - | - | No * | - | -
ActiproSoftware.Text.Addons.Xml.Wpf.dll | No * | - | - | - | - | - | - | - | - | - | - | - | No * | - | -
ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll | No * | - | - | - | - | - | - | - | - | - | - | - | No * | - | -
ActiproSoftware.Views.Wpf.dll | Yes | - | - | - | - | - | - | - | - | - | - | - | - | Yes | -
ActiproSoftware.Wizard.Wpf.dll | Yes | Yes | - | - | - | - | - | - | - | - | - | - | - | - | Yes
ActiproSoftware.Themes.Luna.Wpf.dll | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes
ActiproSoftware.Themes.Office.Wpf.dll | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes
ActiproSoftware.Shared.Wpf.dll | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes

* Add-ons marked with an asterisk are sold separately from SyntaxEditor and its containing bundles. See the documentation for more details on licensing these add-ons.

The redistributable assemblies all installed to this folder by default:

[Drive]:\Program Files\Actipro Software\WPF-Controls\[Version]\Assemblies\

If you require code-signed versions of the assemblies, they are located in a CodeSigned child folder. If you require .NET Standard 2.0 versions of the Text and Text.LLParser assemblies (which can be used on servers), they are located in a Net-Standard-2.0 child folder.

There are several legacy assemblies optionally included that contain old deprecated code that is intended for backwards compatibility only. It is encouraged to not use these assemblies and switch to the current assemblies listed in the table above instead.

  • The "ActiproSoftware.Legacy.Wpf.dll" assembly is licensed for all licensed customers, similar to the Shared Library.
  • The "ActiproSoftware.Docking.Legacy.Wpf.dll" and "ActiproSoftware.Docking.Interop.Prism.Legacy.Wpf.dll" assemblies are licensed for customers who have licensed Docking/MDI individually or via a bundle, as they contain the old Docking/MDI codebase prior to the 2016.1 version.
  • The "ActiproSoftware.Editors.Legacy.Wpf.dll", "ActiproSoftware.Editors.Interop.DataGrid.Legacy.Wpf.dll", "ActiproSoftware.Editors.Interop.PropertyGrid.Legacy.Wpf.dll", and "ActiproSoftware.Editors.Interop.Ribbon.Legacy.Wpf.dll" assemblies are licensed for customers who have licensed Editors individually or via a bundle, as they contain the old Editors codebase prior to the 2017.1 version.
  • The "ActiproSoftware.PropertyGrid.Legacy.Wpf.dll" and "ActiproSoftware.PropertyGrid.Interop.WinForms.Legacy.Wpf.dll" assemblies are licensed for customers who have licensed PropertyGrid individually or via a bundle, as they contain the old PropertyGrid codebase prior to the 2017.1 version.

Other Deployment Notes

No Run-time Royalties

There are no run-time royalties or other distribution charges for our WPF control products. We only require that you have the proper of licenses for each developer on your project.

See the Licensing topic for more information on licensing requirements.

Do Not Use Our Product Installers on End User Machines

You do NOT need to use our product installers to place our controls on end user machines, nor are you permitted to apply your license key on end user machines.

Instead, Visual Studio and/or MSBuild will compile your license key into your application's executable at build time so the only thing you need to do is xcopy our product assemblies into the same folder as your application on end user machines.

No other steps need to be done to apply your licenses. If you are getting license popups on end user machines, your licensing configuration is incorrect on your build machine. Read the Licensing topic to troubleshoot the issue.

Do Not Install Our Controls to End User GACs (Global Assembly Cache)

We ask that you do not place our control assemblies in the GACs of end user machines. Our controls should only be in the GACs of developer machines, which is done by our product installer.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Sample Code and QuickStarts

Actipro WPF Studio includes many demos and QuickStarts in the sample project.

We pride ourselves in providing more full-source samples than our competition, allowing you to learn our products easier and avoid having to rewrite common logic and design patterns.

This topic contains these sections:

  • What is a Demo?
  • What is a QuickStart?
  • Reusing Sample Source Code
  • Visual Studio Item Templates

What is a Demo?

A demo is a large sample that shows the combination of many product features together to create a finished product.

Demos are intended to show some ideas of what you can do with our products when you use them in your own applications.

What is a QuickStart?

A QuickStart is a small sample that is focused on a particular feature area or how to perform a certain task.

QuickStarts are the place to go to quickly learn how to get a specific feature working without having to navigate around unrelated code needed to support other features.

Reusing Sample Source Code

The full source for all samples is located in the sample project and you are free to reuse the sample source code as you wish.

We encourage you to copy what you need to help you get started with using the product in your own applications.

Visual Studio Item Templates

Many of our WPF Studio products also come with packed with item templates for Visual Studio. When getting started using our products in your own applications, use the item templates to get up and running quickly.

Each product's Getting Started topic discusses any Visual Studio item templates that are available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

The WPF Studio Sample Browser includes several utilities that we developed to help aid our customers in working with our products.

These utilities are available on the General tab within the Sample Browser.

This topic contains these sections:

  • The Color Browser
  • The String Resource Browser
  • The Theme Browser

The Color Browser

The Color Browser is a helpful utility that displays all the current Color values found in the static Colors and SystemColors class properties.

See the Color Browser topic for information on this utility.

The String Resource Browser

The String Resource Browser can be used to view all the string resources that are used in Actipro's WPF control products. It even helps you generate C# and VB code that lets you customize or localize the string resources.

See the String Resource Browser topic for information on this utility.

The Theme Browser

The Theme Browser lets you view all of the brush resources that are used throughout Actipro's WPF Control products. You can view the brushes for each control theme and can copy a DynamicResource string to the clipboard, which can be pasted into your application. This allows for easy brush reuse.

See the Theme Browser topic for information on this utility.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Color Browser

The Color Browser is a helpful utility that displays all the current Color values found in the static Colors and SystemColors class properties.

It is available on the General tab within the Sample Browser.

The Color Browser examining the current Windows color scheme

This topic contains these sections:

  • Using the Color Browser

Using the Color Browser

You can right-click on the items in either of the lists to be presented with several useful copy to clipboard options.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


String Resource Browser

The String Resource Browser allows you to view all the string resources that are defined for the various Actipro WPF control products. It generates code in C# and VB to customize or localize any of the string resources in our products.

It is available on the General tab within the Sample Browser.

The String Resource Browser looking at Docking & MDI's string resources

This topic contains these sections:

  • Using the String Resource Browser
  • Customizing String Resources

Using the String Resource Browser

Simply select the desired product in the Product drop-down to view the string resources for a product.

The list of resources shows the resource name and its default value.

Customizing String Resources

You may wish to change the default text to your own text, and in many other cases, you may simply wish to create localized versions of our default text.

The String Resource Browser can create C# and VB statements that override our default text for a specific string resource. To do this, select the target string resource in the list, enter some customized text, and click either C#'s Copy button or VB's Copy button depending on which language your code needs to be in.

The copied value looks like this:

C#
VB
Copy
​ActiproSoftware.Products.Docking.SR.SetCustomString(ActiproSoftware.Products.Docking.SRName.UICommandActivateNextDocumentText.ToString(), "Customized Text");
​ActiproSoftware.Products.Docking.SR.SetCustomString(ActiproSoftware.Products.Docking.SRName.UICommandActivateNextDocumentText.ToString(), "Customized Text")

Note Note
You should paste this code in your application startup so that it is run before any user interface has been loaded.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SystemParameters Browser

The SystemParameters Browser is a helpful utility that displays all the values found in the static SystemParameters class properties.

It is available on the General tab within the Sample Browser.

The SystemParameters Browser examining the current Windows settings

This topic contains these sections:

  • Using the SystemParameters Browser

Using the SystemParameters Browser

The browser can be used to view the system parameters of the current system.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Theme Browser

The Theme Browser allows you to view all the brush resources that are defined for the various Actipro WPF control products. You even can copy a DynamicResource string that can be pasted into your XAML to reuse a selected brush.

It is available on the General tab within the Sample Browser.

The Theme Browser looking at Ribbon's Office blue theme resources

This topic contains these sections:

  • Using the Theme Browser
  • Reusing Brush Resources in Your Application

Using the Theme Browser

Using the Theme Browser is very easy. Simply select the theme and product group to view, then the list at the bottom will populate with the related brush resources.

The list shows a small preview of the brush, its name, type, and how to reference it. There is a larger preview of the selected brush in the upper right as well.

Reusing Brush Resources in Your Application

If you would like to reuse a certain brush in your own application, we have provided a copy to clipboard button at the bottom of the Theme Browser. Select the brush to reuse, press the copy button, and paste the generated DynamicResource string into any XAML Brush-based property value.

The copied value looks like this:
{DynamicResource {x:Static themes:RibbonCommonDictionary.GroupCollapsedBackgroundPressedBrushKey}}

The themes XML namespace is defined as:
xmlns:themes="http://schemas.actiprosoftware.com/winfx/xaml/themes"

Note Note
The same brush resource key is used throughout the various themes for a given product group. So the resulting brush may change depending on which theme is currently loaded for the related product group.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Occasionally during large updates to a product, some breaking changes are necessary to either add enhanced functionality or improve the overall design of the various products.

Read the following topics that are appropriate for your scenario if you are converting from an older version to the latest version.

  • The Converting to 2009.2 topic contains information on converting to 2009.2 from an older version.
  • The Converting to 2010.1 topic contains information on converting to 2010.1 from 2009.2.
  • The Converting to 2010.2 topic contains information on converting to 2010.2 from 2010.1.
  • The Converting to 2011.1 topic contains information on converting to 2011.1 from 2010.2.
  • The Converting to 2011.2 topic contains information on converting to 2011.2 from 2011.1.
  • The Converting to 2012.1 topic contains information on converting to 2012.1 from 2011.2.
  • The Converting to 2012.2 topic contains information on converting to 2012.2 from 2012.1.
  • The Converting to 2016.1 topic contains information on converting to 2016.1 from an older version through 2012.2.
  • The Converting to 2017.1 topic contains information on converting to 2017.1 from 2016.2.
  • The Converting to 2019.1 topic contains information on converting to 2019.1 from an older version through 2017.1.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2009.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Docking & MDI
  • SyntaxEditor
  • Removed Theme Property

Docking & MDI

See the Docking & MDI's conversion topic for details on breaking changes made to that product.

SyntaxEditor

See the SyntaxEditor's conversion topic for details on breaking changes made to that product.

Removed Theme Property

The ThemeManager can change the current theme for an application using the CurrentTheme property. In addition, the ThemeManager offers the ThemeProperty attached property, which allows the theme to be changed for a specific element (and it's descendents). This latter method is only recommended for testing purposes, such as for demos and prototypes.

See the Themes documentation for more information.

Previously, several controls exposed the ThemeProperty property, making it much easier to set the theme for the given control. Because this attached property is only intended for testing purposes, these helper properties have been removed. The theme can still be changed for a specific element by referencing the ThemeManager.ThemeProperty attached property directly.

The following controls, as well as any derivations, were affected by this change:

  • Docking & MDI: DockSite
  • Navigation: Breadcrumb
  • Navigation: ExpanderBar
  • Ribbon: RibbonWindow
  • Shared Library: AnimatedProgressBar
  • Shared Library: PopupButton

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2010.1

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Switch to Target .NET 3.5 SP1 or Later
  • Editors
  • Ribbon

Switch to Target .NET 3.5 SP1 or Later

Since .NET 4.0 has released, WPF Studio 2010.1 has switched to target .NET 3.5 SP1 as its base framework instead of .NET 3.0 so that we may take advantage of some more recent .NET framework functionality. Make sure that any applications using WPF Studio products also target .NET 3.5 SP1 or later (.NET 4.0, etc.).

Also note that all Actipro product assembly names have been updated. For instance, what was ActiproSoftware.Ribbon.Wpf30.dll is now ActiproSoftware.Ribbon.Wpf351.dll. This change was made since the assembly name indicates the minimum target framework version.

Editors

See the Editors' conversion topic for details on breaking changes made to that product.

Ribbon

See the Ribbon's conversion topic for details on breaking changes made to that product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2010.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • SyntaxEditor
  • Docking & MDI
  • Navigation
  • PropertyGrid
  • Shared Library

SyntaxEditor

WPF Studio 2010.2 switches all SyntaxEditor Text assemblies to target .NET 3.5 SP1 instead of .NET 2.0 so that we can take advantage of newer features found in the .NET framework. This change involved some assembly name changes.

See SyntaxEditor's conversion topic for details on this and some other minor breaking changes made to that product.

Docking & MDI

See Docking & MDI's conversion topic for details on breaking changes made to that product.

Navigation

See Navigation's conversion topic for details on breaking changes made to that product.

PropertyGrid

See PropertyGrid's conversion topic for details on breaking changes made to that product.

Shared Library

See Shared Library's conversion topic for details on breaking changes made to that product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.1

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Docking & MDI
  • PropertyGrid

Docking & MDI

See Docking & MDI's conversion topic for details on breaking changes made to that product.

PropertyGrid

See PropertyGrid's conversion topic for details on breaking changes made to that product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2011.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Updated Assembly Names
  • Theming Architectural and Style Changes
  • DataGrid
  • Docking & MDI
  • Editors
  • Navigation
  • PropertyGrid
  • Ribbon
  • Wizard
  • Shared Library

Updated Assembly Names

All Actipro product assembly names have been updated to more generic naming schema. For instance, what was ActiproSoftware.Ribbon.Wpf351.dll is now ActiproSoftware.Ribbon.Wpf.dll. This change was made to remove the need for customers to update their references as the minimum target framework version changes.

Upgrade Instructions Upgrade Instructions
Update all assembly references in your projects.

Theming Architectural and Style Changes

Introduction

The largest change made in this release was to our theming architecture, which affects all the control styles as well as their supporting dictionaries. The overall concept is the same as before, provide an intuitive and simple way to provide multiple themes for WPF controls, but the design is different.

In previous versions, each product was responsible for defining all the brushes for every support theme. If two products shared similar controls (such as a title bar button in Ribbon and Docking), then the brushes would have to be duplicated in each product. Even when two products may not be similar in function, their colors needed to look good together if they were to be used in the same window. Over time as our product line grew, it has become more and more cumbersome and difficult to theme the controls with all the disparate assets (such as brushes). There were some additional issues with some controls having multiple styles defined, with very little differences.

In order to reduce the overall number of assets and styles and make it easier to create new and exicting themes, we have consolidated all the resources into a common pool for use by all our products. We have also added theming support for the native WPF controls, with enhanced and updated styles. This has also allowed us to greatly simplify the styles for the various products.

Built-In Themes

The enumeration that defines the built-in themes has been changed from CommonThemeName to ThemeName. The current theme can still be changed using the ThemeManager.CurrentTheme property, in the same manner as in previous releases.

Support for the Office 2007 themes has been fully replaced with support for the latest Office theme. There are still some aspects of the Office 2007 theme that will always remain, such as the application orb button, but the overall color scheme has an updated look. The Office 2010 themes are still present, but the "2010" designator has been removed. This allows us to target the latest and greatest Office theme as Microsoft releases new versions.

In addition, the Office themes (Black, Blue, and Silver) have been moved to a separate assembly, so customers that do not use those themes can reduce the size of their installer. If your application uses the Office themes, then you'd need to add a reference to ActiproSoftware.Themes.Office.Wpf.dll and ensure this assembly is distributed with your application. You will also need to register the Office theme by calling the Register static method on ThemesOfficeThemeCatalogRegistrar when your application starts.

Upgrade Instructions Upgrade Instructions
  1. All references to CommonThemeName must be replaced with ThemeName.
  2. Replace (or remove) any uses of the Office2010Black/Office2007Black, Office2010Blue/Office2007Blue, or Office2010Silver/Office2007Silver with OfficeBlack, OfficeBlue, or OfficeSilver, respectively.
  3. If using the Office themes, add a reference to ActiproSoftware.Themes.Office.Wpf.dll to your project and call the Register static method on ThemesOfficeThemeCatalogRegistrar when your application starts.

Product Theme Dictionaries

In the previous theming architecture, each product included a named ResourceDictionary that included all the required resources to theme the associated control for the given theme (i.e. RibbonAeroNormalColorDictionary). There was also a "common" dictionary (i.e. RibbonCommonDictionary) which defined numerous ComponentResourceKeys for assets (such as brushes) and associated styles. These dictionaries have been removed, in favor of a more flexible theme catalog.

A theme catalog keeps a list of the registered themes and what XAML files to load when that theme is being used. In addition, non-brush related ComponentResourceKeys are defined in classes such as SharedResourceKeys and ActiproSoftware.Windows.Themes.DockingResourceKeys, where needed. The brush related ComponentResourceKeys have been consolidated into a single pool of assets defined in the AssetResourceKeys class.

Upgrade Instructions Upgrade Instructions

All references to the previous theme dictionaries (i.e. RibbonCommonDictionary) must be removed.

Any brush keys from the deprecated "common" dictionaries should be updated to use a new asset from the common pool, which is available in the AssetResourceKeys class. In some cases, due to making assets more generic and reusable in nature, an asset's name may have been renamed. For instance, what was RibbonCommonDictionary.TabContentOuterBorderBrushKey is now AssetResourceKeys.RibbonTabControlBorderNormalBrushKey. Many of the former RibbonControl* assets are now named a more generic ToolBar*. Docking/MDI uses assets named like DockingWindow*, ToolWindow*, TabbedMdi*, and StandardMdi*.

The new locations of any style keys from the former "common" dictionaries should be documented in the "Converting to 2011.2" topic for the individual product. Ribbon used to have a RibbonStyles class as well that defined some styles for native WPF controls. The RibbonStyles class has been removed and all styles moved to the SharedResourceKeys class. The new SharedResourceKeys defines styles for all native WPF controls that are fully themed.

RibbonCommonDictionary used to define several colors for contextual tab groups such as ContextualTabGroupStockColorCyan. These colors are now defined on a new class such as ContextualTabGroupColors.Cyan.

Tinting Support

Previously, each of the numerous named ResourceDictionary (such as RibbonAeroNormalColorDictionary) would have to be tinted individually and registered with the ThemeManager. In this release, an entire asset pool can be tinted to a given color at once.

Upgrade Instructions Upgrade Instructions
Update any tinting options to use the new approach (as shown in our sample application).

DataGrid

See DataGrid's conversion topic for details on breaking changes made to that product.

Docking & MDI

See Docking & MDI's conversion topic for details on breaking changes made to that product.

Editors

See Editors's conversion topic for details on breaking changes made to that product.

Navigation

See Nagivation's conversion topic for details on breaking changes made to that product.

PropertyGrid

See PropertyGrid's conversion topic for details on breaking changes made to that product.

Ribbon

See Ribbon's conversion topic for details on breaking changes made to that product.

Wizard

See Wizard's conversion topic for details on breaking changes made to that product.

Shared Library

See Shared Library's conversion topic for details on breaking changes made to that product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2012.1

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • .NET 4.0 Client Profile Is Minimum Framework
  • VS 2008 No Longer Supported
  • Docking/MDI and Prism Interop Upgraded to v4.1
  • DataGrid Add-on Updated to Use .NET 4.0
  • Removal of Several Shared Proxy Classes
  • Removal of AllowPartiallyTrustedCallers Attribute

.NET 4.0 Client Profile Is Minimum Framework

We've had many requests to migrate to .NET 4.0 and that change has occurred in 2012.1. The minimum required .NET framework to use our products is now .NET 4.0.

Please note that both the full and the client profile variations of .NET 4.0 are fully-supported, as are future versions of .NET, such as .NET 4.5.

Upgrade Instructions Upgrade Instructions
Ensure that projects using our products target .NET 4.0, .NET 4.0 Client Profile, or a later .NET version.

VS 2008 No Longer Supported

Visual Studio 2008 doesn't support .NET 4.0 and only supports prior .NET versions. Thus, it is no longer supported and no sample projects are included for it.

Upgrade Instructions Upgrade Instructions
Convert old VS 2008 projects to VS 2010 or later.

Docking/MDI and Prism Interop Upgraded to v4.1

The interop assembly for using our Docking/MDI product with Prism has been updated to use Prism's latest v4.1.

Upgrade Instructions Upgrade Instructions
Convert to using Prism v4.1.

DataGrid Add-on Updated to Use .NET 4.0

The DataGrid add-on has been updated to reference the native .NET 4.0 version instead of the one from the WPF Toolkit.

Upgrade Instructions Upgrade Instructions
Convert to using the native .NET 4.0 DataGrid instead of the WPF Toolkit one.

Removal of Several Shared Proxy Classes

The Shared Library previously included a couple classes (ScrollViewerProxy and RenderOptionsProxy) that were previously used internally to access .NET 4.0 features from the .NET 3.5 framework. Since our codebase has moved to .NET 4.0, these are no longer necessary and all code that used them has been updated to use the appropriate .NET 4.0 API.

Removal of AllowPartiallyTrustedCallers Attribute

The upgrade to .NET 4.0 allowed our assemblies to move to the newer security model in .NET 4.0. To accommodate this move, we removed the use of the AllowPartiallyTrustedCallers assembly attribute.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2012.2

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Using the New Metro Themes
  • Renamed Assets

Using the New Metro Themes

New Metro Light and Metro White themes have been added in this version. Similar to the Office themes, they are implemented in a separate optional assembly that must be referenced and initialized.

The Themes' Getting Started topic walks through how to do this.

Renamed Assets

These AssetResourceKeys have been renamed:

  • RaftingWindowBorderNormalBrushKey renamed to RaftingWindowBorderInactiveBrushKey.

Upgrade Instructions Upgrade Instructions
Convert any references to the old name to use the new name instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2016.1

All of the breaking changes are detailed or linked below.

This topic contains these sections:

  • Massive Updates to Docking and MDI
  • ActiproSoftware.Legacy.Wpf.dll No Longer Installed By Default
  • Metro Themes Merged Into Shared Library
  • Luna/Royale Themes Split Into Separate Library
  • RibbonWindow.IsGlassEnabled Property Changes
  • Ribbon Button Images Auto-Convert To White Monochrome When Appropriate

Massive Updates to Docking and MDI

For the 2016.1 version, we completely rewrote the entire Docking/MDI product from the ground up based on our years of experience in this area. Along the way, we added nearly all of the major features our customers have requested and the result is the most feature-rich docking window and MDI product of its kind.

While we fully encourage you to upgrade your existing applications that use the older Docking/MDI product to the new version so that you can continue to receive the latest feature additions and bug fixes, we are also shipping a legacy version of the old assembly that can temporarily be used in the interim for full backward compatibility.

The Converting to 2016.1 topic discusses all the updates, including breaking changes.

ActiproSoftware.Legacy.Wpf.dll No Longer Installed By Default

The very old ActiproSoftware.Legacy.Wpf.dll assembly that contains deprecated controls replaced by others is no longer installed by default. We encourage you to port any code that used its controls to newer supported ones instead, as this assembly will cease to be included in the WPF Controls installer sometime in the future.

If you still need to use this assembly in the meantime, you must check the 'Control Assemblies / Legacy' option in the installer to install it. Once you do so, the assembly will appear in a 'Legacy' subfolder of the Actipro assembly install folder (see the Deployment topic for the default location), but will not appear in the GAC.

Metro Themes Merged Into Shared Library

For the 2016.1 version, the Metro themes were merged right into the Shared Library and Metro Light was made the default theme for Windows 10 and 8.x.

The Converting to 2016.1 topic discusses all the updates, including breaking changes.

Luna/Royale Themes Split Into Separate Library

For the 2016.1 version, the Luna (XP-like) themes were split into a separate library and now must be programmatically registered and activated if they are desired for usage in an application.

The Converting to 2016.1 topic discusses all the updates, including breaking changes.

RibbonWindow.IsGlassEnabled Property Changes

For the 2016.1 version, the RibbonWindow.IsGlassEnabled property is no longer nullable and it now defaults to false.

The Converting to 2016.1 topic discusses all the updates, including breaking changes.

Ribbon Button Images Auto-Convert To White Monochrome When Appropriate

Several Metro themes require that buttons in the QAT, tab panel, or status bar have white monochrome images. New features have been added in the 2016.1 version to automatically perform this conversion for you so that additional image sets aren't required for these usage scenarios.

See the Monochrome Images topic for details on when this auto-conversion occurs.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2017.1

The 2017.1 version has new lightweight implementations of the Editors and PropertyGrid controls created that are much more performant, use less memory, and still provide a wide array of features. These infrastructure changes did require some breaking changes and some API cleanup was performed at the same time. All of the breaking changes are detailed in the linked topics below.

licenses.licx File Changes licenses.licx File Changes
Please read through the Licensing topic's section on "licenses.licx" files. In the 2017.1 version we improved the "licenses.licx" file licensing mechanism to only use a single entry that covers all Actipro products you've licensed. Now a single new entry is used, and all older Actipro entries should be removed.

This topic contains these sections:

  • Massive Updates to Editors
  • Massive Updates to PropertyGrid, Moved Into Grids Assembly

Massive Updates to Editors

The old versions of the edit boxes in Editors, while providing many features, were very complex and used many UI elements to support their functionality. This meant that windows with a lot of editors (such as when used in property grids or grids) could be very memory intensive and take a while to load.

For the 2017.1 version, we reimplemented them with a design that is code-compatible with the Universal Windows variations of Editors. These new edit boxes are now lightweight controls that harness a native TextBox control in their templates. They use far fewer elements and bindings than before and load very quickly. New edit boxes, pickers, and other miscellaneous controls have been added as well.

While we fully encourage you to upgrade your existing applications that use the older Editors product to the new version so that you can continue to receive the latest feature additions and bug fixes, we are also shipping a legacy version of the old assembly that can temporarily be used in the interim for full backward compatibility.

The Converting to 2017.1 topic discusses all the updates, including breaking changes.

Massive Updates to PropertyGrid, Moved Into Grids Assembly

The old PropertyGrid control was very feature-rich and was very customizable. The downside of it was that it was relatively slow to load objects and didn't make the best use of virtualization.

For the 2017.1 version, we are introducing a new Grids product that replaces the old PropertyGrid product. Customers who have active PropertyGrid license subscriptions will get Grids for free, and Grids is included in WPF Studio similar to how PropertyGrid was. Grids first started off with implementations of tree controls (TreeListBox and TreeListView) that were built from the ground up to render tree structures in a highly-performant way, making full use of virtualization. The new PropertyGrid extends these controls and loads large complex objects instantly, even in cases where the old PropertyGrid may have taken several seconds to load. The entire data model and data factory design has been rewritten to be simpler and easier than ever to customize, while retaining all of the abilities found in the old PropertyGrid. Integration with the new Editors controls continues to be fully supported.

While we fully encourage you to upgrade your existing applications that use the older PropertyGrid product to the new Grids version so that you can continue to receive the latest feature additions and bug fixes, we are also shipping a legacy version of the old assembly that can temporarily be used in the interim for full backward compatibility.

The Converting to 2017.1 topic discusses all the updates, including breaking changes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Converting to 2019.1

The 2019.1 version made some large updates and improvements to the SyntaxEditor product for better cross-platform support. The infrastructure changes required some breaking changes and some API cleanup was performed at the same time. All of the breaking changes are detailed in the linked topics below.

This topic contains these sections:

  • Massive Updates to SyntaxEditor

Massive Updates to SyntaxEditor

Much of the SyntaxEditor product's internals were refactored so that a common codebase could be shared among the WPF, UWP, and WinForms versions of the product. This enables the products to stay in sync more easily moving forward.

The optional add-ons that integrate ANTLR v3 And Irony parsers with SyntaxEditor are no longer installed by default. The ANTLR Add-on and Irony Add-on topics give more detail on the options to pick during WPF Controls setup to install those.

The Converting to 2019.1 topic discusses the updates.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting (General)

This topic provides several tips on common questions or issues that you may encounter on the products included in WPF Studio.

There also are some product-specific troubleshooting topics that provide information related to individual products:

  • PropertyGrid Troubleshooting
  • Ribbon Troubleshooting
  • Themes Troubleshooting
  • Wizard Troubleshooting

This topic contains these sections:

  • First Time Running the Sample Browser Results in 'SampleBrowser/MainWindow not found' Error
  • Designer Doesn't Load When Opening XAML File in Sample Browser
  • Designer Errors Reported That Don't Occur At Run-Time
  • 'Task failed because LC.exe was not found' Error When Compiling Visual Studio Project
  • ClickOnce Deployment Error Saying Actipro Assemblies Must Be in the GAC
  • Some String Resource Customizations Don't Take Effect in UI
  • Data Binding Errors at Run-Time
  • Using WPF Controls in Windows Forms Applications
  • Expression Blend Doesn't Copy Styles and Templates Properly
  • Expression Blend Locks Up When Assemblies Referenced
  • Expression Blend 3 Designer Throws Exception

First Time Running the Sample Browser Results in 'SampleBrowser/MainWindow not found' Error

If this error message occurs the first time you attempt to compile and run the Sample Browser project in Visual Studio, simply Clean the solution and then Rebuild it. That should resolve the problem.

Designer Doesn't Load When Opening XAML File in Sample Browser

The first time you open the sample browser project and try to open a XAML file, you may encounter designer errors where the designer doesn't load properly. This is due to the Sample Browser never being compiled on your system yet.

To resolve this issue, simply close the XAML files, rebuild the Sample Browser solution, and reopen them. Everything should work fine from that point on.

Designer Errors Reported That Don't Occur At Run-Time

If the Visual Studio designer is reporting errors that aren't errors that occur at run-time, such as "The member 'Foo' is not recognized or is not accessible.", it could be that you haven't referenced the ActiproSoftware.Shared.Wpf.dll assembly, which is the Shared Library. This core assembly is referenced by all our product assemblies and is required to be referenced and deployed with your app when using any of our control products.

Once you've ensured you have a reference to that assembly in your project, please rebuild the project and then reopen the designer.

'Task failed because LC.exe was not found' Error When Compiling Visual Studio Project

The symptom of this problem is the error message below shows when compiling a project in Visual Studio that is using Actipro components.

Task failed because "LC.exe" was not found, or the correct Microsoft Windows SDK is not installed."

That error may show up if your Visual Studio SDK installation is not correct or is missing on your machine. When Visual Studio tries to compile a project that uses a licensed component (like ours or any other third party developer that makes licensed controls), it looks for LC.exe. LC.exe is the license compiler application it uses to embed license data in the assembly it creates for your project.

You should be able to resolve this by running your Visual Studio installer and making sure you install the SDK option it provides.

Alternatively, you could look at the path indicated by the registry key indicated by this error message. Then go to that path and make sure LC.exe is there. You'd have to copy it from another similar SDK folder.

But to restate, this error is not something our product has caused. It's due to an invalid Visual Studio SDK installation. Compiling a project with any other third party licensed component would cause the same error to show in Visual Studio if the SDK is missing or invalid.

ClickOnce Deployment Error Saying Actipro Assemblies Must Be in the GAC

If a message similar to the following appears when you attempt to run a ClickOnce-deployed application, you have not configured your project references correctly.

Unable to install or run the application. The application requires that assembly ActiproSoftware.???.Wpf Version ?.?.????.0 be installed in the Global Assembly Cache (GAC) first.

You must ensure that all Actipro assemblies that are needed by your project have their references set so Copy Local is true. That will allow them to be deployed and copied to the client machine properly, making this error message disappear.

If you don't do this, the end user machine is unable to locate the Actipro assemblies and therefore throws this exception.

Some String Resource Customizations Don't Take Effect in UI

If you run into a scenario where some string resource customizations do take effect in the UI but others don't, the problem is most likely the location of your string customization code.

As indicated by a note in the Customizing String Resources topic, all string resources should be customized immediately at application startup (such as in Application.OnStartUp) and before any UI or control classes are even referenced. The note in the topic gives more detail on why this is necessary.

Data Binding Errors at Run-Time

Sometimes there may be some data binding errors that show up in the Visual Studio console window when executing an application that uses a WPF Studio product. WPF Studio has some very large and complex templates for its products' controls and these error messages may show up in the VS console due to the timing between data binding resolution and visual tree creation.

It is very important to not that the data binding errors are NOT problems in our code. If they were, the bindings would not work at all at run-time and you would see broken UI functionality. This is not the case, everything works correctly at run-time after the visual tree has been fully constructed and the bindings have been re-evaluated by WPF.

We wanted to get more information on this issue for a customer who wrote us, so we asked Dr. WPF (a WPF expert) for an explanation. Here's what he had to say:

You can reassure your customer that the binding trace output is merely there to help developers debug unresolved bindings. It does not indicate an error in your code.

There are several levels at which a binding may be resolved. Most bindings are resolved when they are first parsed. However, for templates and some other specific cases (like generated item containers), the elements may be parsed as they are added to a partial tree or while under a different parser context. In such a case, a perfectly good binding may fail to resolve on the first try.

If a binding fails to resolve, it is marked as such with an internal flag and a later attempt will be made to resolve the binding. Additionally, for a RelativeSource binding of FindAncestor, any change in the ancestor tree will cause the binding expression to be re-resolved.

Unfortunately, there is no way to turn off the trace output when running under the debugger. If a debugger is present, all errors and warnings will be issued. If a debugger is not present, the trace output will only be generated if a specific key in the registry is set.

As for how you convince your customer that this is not a real problem, I'd start by pointing out that the messages are coming through the "trace" pipeline... not the "debug" pipeline. Second, I'd reemphasize that if there was indeed a problem, you would see it in the UI.

So just to reiterate, the data binding error messages are not problems with our code, and are simple warnings due to data bindings trying to resolve themselves before WPF has created their targets' visual trees. You may safely ignore these error messages.

Using WPF Controls in Windows Forms Applications

Some customers embed controls like the WPF SyntaxEditor in their Windows Forms applications. In cases where Image embedded resources are used (such as in SyntaxEditor IntelliPrompt popups), the pack:// URI syntax will fail with a NotSupportedException and message "The URI prefix is not recognized."

This is due to no WPF Application object being created by default in Windows Forms applications and thus the pack:// syntax isn't supported. The WPF Application object can be programmatically created in your application startup before any UI is created like this:

C#
Copy
​if (System.Windows.Application.Current == null) {
    wpfApplication = new System.Windows.Application();
    wpfApplication.ShutdownMode = System.Windows.ShutdownMode.OnExplicitShutdown;
}

The wpfApplication variable should be stored at your static Windows Forms application level and in your application shutdown code, the wpfApplication.Shutdown() method should be called to explicitly close the WPF Application.

The reason we need to use ShutdownMode.OnExplicitShutdown above is that by default, the last WPF window that closes will shut down the WPF application and it will be as if no application was created, breaking pack:// syntax and causing the NotSupportedException exception. If you are still in evaluation mode, the Actipro evaluation dialog for the WPF Controls could trigger this when it closes. By explicitly controlling the lifetime of the WPF application, you prevent that scenario from occurring.

Expression Blend Doesn't Copy Styles and Templates Properly

Expression Blend has features to create copies (clones) of the default styles and templates for controls. Unfortunately it doesn't always work properly with third party controls such as ours.

It is highly recommended that instead of using Blend's built-in features to get a copy of a default style or template, you download the default styles/templates from your account. If you are a WPF Studio customer, there is a link to download the default styles/templates on the Purchases tab of your organization account page. If you have licensed individual products instead, please write our support team to send you the default styles/templates for the products you've licensed.

Expression Blend Locks Up When Assemblies Referenced

Expression Blend seems to lock up when attempting to load the ActiproSoftware.Docking.Interop.Prism.Wpf.dll assembly as a reference. At the current time, we are unsure of why this happens. There shouldn't be any issues referencing other Actipro assemblies.

Expression Blend 3 Designer Throws Exception

There is an issue with Expression Blend 3, where it will throw an exception when using the designer with Actipro controls. The underlying issue has to do with the way Expression Blend 3 loads the Actipro design assemblies. This issue has been reported to Microsoft and they have indicated that it will be fixed in an upcoming release.

Specifically, the designer will show the following exception when an Actipro control is selected:

To work around this issue, the references in the project file must be manually modified. Specifically, the ActiproSoftware.Shared.Wpf assembly must be referenced before any other Actipro assembly. For example, the following references must be swapped, so that the shared assembly comes first.

Tip Tip
Regardless of the order that the references are added, Blend 3 will always sort the references alphabetically. So you must manually edit the project file using a text editor, such as Notepad.

This code will result in the exception seen above:

XML
Copy
​<Reference Include="ActiproSoftware.PropertyGrid.Wpf, Version=9.2.510.0, Culture=neutral, PublicKeyToken=36ff2196ab5654b9, processorArchitecture=MSIL" />
<Reference Include="ActiproSoftware.Shared.Wpf, Version=9.2.510.0, Culture=neutral, PublicKeyToken=36ff2196ab5654b9, processorArchitecture=MSIL" />

This code will not result in the exception seen above:

XML
Copy
​<Reference Include="ActiproSoftware.Shared.Wpf, Version=9.2.510.0, Culture=neutral, PublicKeyToken=36ff2196ab5654b9, processorArchitecture=MSIL" />
<Reference Include="ActiproSoftware.PropertyGrid.Wpf, Version=9.2.510.0, Culture=neutral, PublicKeyToken=36ff2196ab5654b9, processorArchitecture=MSIL" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Support

This topic contains these sections:

  • Licensing Support
  • General Product Support
  • WPFpedia.com

Licensing Support

If you are experiencing a problem with the licensing of a purchased product, please read the Licensing topic. It has valuable information on licensing and how to resolve any issues you may encounter.

If after reading that topic and following its directions you still cannot resolve the licensing issue, please contact us at support@actiprosoftware.com.

General Product Support

If you need to obtain support on one of our products, you have two options:

  1. Post a message in the Actipro Software support forums.
  2. E-mail support@actiprosoftware.com for assistance.

We highly recommend the first support option since it will enable other users to participate in the discussion.

Licensed customers of our products will receive the highest priority of support.

Please visit the Actipro Software web site to sign up for our .NET newsletter or to see our other .NET products.

WPFpedia.com

WPFpedia.com is a free community resource that was created to provide an organized one-stop resource guide for Windows Presentation Foundation (WPF) developers.

There is a lot of great WPF-related information out on the web that developers have posted. However the problem used to be finding it. The WPFpedia.com resource guide solves this problem by providing a categorized list of links to various articles, blog posts, tools, and other resources throughout the web.

While the resource guide is updated by Actipro almost daily, we encourage you to add your own links as well. The resource guide currently contains over 900 resource links.

Visit http://www.WPFpedia.com often or subscribe to the RSS newsfeed to keep on top of the latest WPF resources on the Internet.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Class Library

Namespaces
Namespace | Description
ActiproSoftware.Shell | Contains types related to interaction with shell folders and files, such as those in the Windows shell.
ActiproSoftware.Text | Contains types related to text.
ActiproSoftware.Text.Analysis | Contains types related to code structural analysis.
ActiproSoftware.Text.Analysis.Implementation | Contains the implementation types related to code structural analysis.
ActiproSoftware.Text.Exporters | Contains types related to the export of text to other markup formats..
ActiproSoftware.Text.Implementation | Contains implementation types related to text.
ActiproSoftware.Text.Languages.CSharp | Contains the classes related to implementing a C# syntax language.
ActiproSoftware.Text.Languages.CSharp.Implementation | Contains the core classes related to implementing a C# syntax language.
ActiproSoftware.Text.Languages.DotNet | Contains the classes related to implementing a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Ast | Contains the types related to ASTs for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation | Contains the implementation types related to ASTs for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Implementation | Contains the core classes related to implementing a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Reflection | Contains the types related to reflection for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation | Contains the implementation types related to reflection for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Resolution | Contains the types related to resolution for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation | Contains the implementation types related to resolution for a .NET syntax language.
ActiproSoftware.Text.Languages.JavaScript | Contains the classes related to implementing a JavaScript syntax language.
ActiproSoftware.Text.Languages.JavaScript.Ast | Contains the types related to ASTs for a JavaScript syntax language.
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation | Contains the implementation types related to ASTs for a JavaScript syntax language.
ActiproSoftware.Text.Languages.JavaScript.Implementation | Contains the core classes related to implementing a JavaScript syntax language.
ActiproSoftware.Text.Languages.Python | Contains the classes related to implementing a Python syntax language.
ActiproSoftware.Text.Languages.Python.Ast | Contains the types related to ASTs for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Ast.Implementation | Contains the implementation types related to ASTs for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Implementation | Contains the core classes related to implementing a Python syntax language.
ActiproSoftware.Text.Languages.Python.Reflection | Contains the types related to reflection for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Reflection.Implementation | Contains the implementation types related to reflection for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Resolution | Contains the types related to resolution for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Resolution.Implementation | Contains the implementation types related to resolution for a Python syntax language.
ActiproSoftware.Text.Languages.VB | Contains the classes related to implementing a VB syntax language.
ActiproSoftware.Text.Languages.VB.Implementation | Contains the core classes related to implementing a VB syntax language.
ActiproSoftware.Text.Languages.Xml | Contains the classes related to implementing an XML syntax language.
ActiproSoftware.Text.Languages.Xml.Ast.Implementation | Contains the implementation types related to ASTs for a XML syntax language.
ActiproSoftware.Text.Languages.Xml.Implementation | Contains the core classes related to implementing an XML syntax language.
ActiproSoftware.Text.Lexing | Contains types related to lexing.
ActiproSoftware.Text.Lexing.Implementation | Contains implementation types related to lexing.
ActiproSoftware.Text.Parsing | Contains types related to parsing.
ActiproSoftware.Text.Parsing.Implementation | Contains implementation types related to parsing.
ActiproSoftware.Text.Parsing.LLParser | Contains types related to the creation of an LL parser.
ActiproSoftware.Text.Parsing.LLParser.Debugging | Contains types related to the debugging of an LL parser.
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation | Contains implementation types related to the debugging of an LL parser.
ActiproSoftware.Text.Parsing.LLParser.Implementation | Contains implementation types related to the creation of an LL parser.
ActiproSoftware.Text.RegularExpressions | Contains types related to working with regular expressions.
ActiproSoftware.Text.Searching | Contains types related to searching within text documents.
ActiproSoftware.Text.Searching.Implementation | Contains implementation types related to searching within text documents.
ActiproSoftware.Text.Tagging | Contains types related to tagging text ranges with custom data.
ActiproSoftware.Text.Tagging.Implementation | Contains implementation types related to tagging text ranges with custom data.
ActiproSoftware.Text.Undo | Contains types related to managing the undo/redo stacks of text documents.
ActiproSoftware.Text.Utility | Contains utility classes.
ActiproSoftware.Windows | Contains some core classes used throughout various products.
ActiproSoftware.Windows.Controls | Contains some core controls and related classes.
ActiproSoftware.Windows.Controls.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.BarCode | Contains the implementation of the BarCode control and its available symbologies.
ActiproSoftware.Windows.Controls.BarCode.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.BarCode.ValidationRules | Contains ValidationRule classes that can be used in bindings to validate input values for a bar code symbology.
ActiproSoftware.Windows.Controls.Charts | Contains classes that support implementing chart controls for WPF.
ActiproSoftware.Windows.Controls.Charts.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.Charts.Palettes | Contains types related to chart palettes.
ActiproSoftware.Windows.Controls.Charts.Primitives | Contains the primitive classes used for charts.
ActiproSoftware.Windows.Controls.ColorSelection | Contains several controls for performing color selection similar to that found in Adobe Photoshop or Microsoft Expression Blend.
ActiproSoftware.Windows.Controls.ColorSelection.Primitives | Contains the primitive types related to color selection.
ActiproSoftware.Windows.Controls.DataGrid | Contains classes that provide enhancements for the Microsoft DataGrid.
ActiproSoftware.Windows.Controls.Docking | Contains classes that support implementing docking windows & MDI for WPF.
ActiproSoftware.Windows.Controls.Docking.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.Docking.Primitives | Contains primitive classes used for Docking & MDI controls.
ActiproSoftware.Windows.Controls.Docking.Serialization | Contains classes that are used to serialize layout data for the DockSite control.
ActiproSoftware.Windows.Controls.Editors | Contains classes that support implementing embeddable and standalone masked/part-based editor controls for WPF.
ActiproSoftware.Windows.Controls.Editors.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid | Contains classes that support integration of Editors with DataGrid.
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives | Contains primitive classes that support integration of Editors with DataGrid.
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors | Contains property editor classes that support integration of Editors with PropertyGrid.
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives | Contains property editor primitive classes that support integration of Editors with PropertyGrid.
ActiproSoftware.Windows.Controls.Editors.Primitives | Contains primitive classes used for Editors controls.
ActiproSoftware.Windows.Controls.Gauge | Contains classes that support implementing gauge controls for WPF.
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.Gauge.Primitives | Contains the primitive classes used for Gauge product controls.
ActiproSoftware.Windows.Controls.Grids | Contains classes that support implementing tree and grid controls.
ActiproSoftware.Windows.Controls.Grids.Automation.Peers |
ActiproSoftware.Windows.Controls.Grids.Primitives | Contains the primitive classes used for Grids product controls.
ActiproSoftware.Windows.Controls.Grids.PropertyData | Contains the classes used for PropertyGrid model data.
ActiproSoftware.Windows.Controls.Grids.PropertyEditors | Contains the classes used for PropertyGrid property editors.
ActiproSoftware.Windows.Controls.MicroCharts | Contains classes that support implementing micro chart controls for WPF.
ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.MicroCharts.Palettes | Contains types related to micro chart palettes.
ActiproSoftware.Windows.Controls.MicroCharts.Primitives | Contains the primitive classes used for micro charts.
ActiproSoftware.Windows.Controls.Navigation | Contains classes that support implementing the controls in the Navigation product.
ActiproSoftware.Windows.Controls.Navigation.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.Navigation.Primitives | Contains the primitive classes used for Navigation product controls.
ActiproSoftware.Windows.Controls.Navigation.Serialization | Contains classes that are used to serialize layout data for the NavigationBar control.
ActiproSoftware.Windows.Controls.Primitives | Contains some primitive classes used for the Shared Library controls.
ActiproSoftware.Windows.Controls.Rendering |
ActiproSoftware.Windows.Controls.Ribbon | Contains classes that support implementing a ribbon control for WPF.
ActiproSoftware.Windows.Controls.Ribbon.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.Ribbon.Collections | Contains collection types that are used with the ribbon.
ActiproSoftware.Windows.Controls.Ribbon.Controls | Contains controls that can be added to a Ribbon control.
ActiproSoftware.Windows.Controls.Ribbon.Controls.Primitives | Contains the primitive classes used for Ribbon child controls.
ActiproSoftware.Windows.Controls.Ribbon.Customization | Contains classes for Ribbon that relate to run-time QAT customization.
ActiproSoftware.Windows.Controls.Ribbon.Input | Contains classes that are used to support a command-driven user interface for the ribbon.
ActiproSoftware.Windows.Controls.Ribbon.UI | Contains supporting classes for a ribbon user interface.
ActiproSoftware.Windows.Controls.Shell | Contains types related to the Shell product.
ActiproSoftware.Windows.Controls.Shell.Primitives |
ActiproSoftware.Windows.Controls.SyntaxEditor | Contains types related to the SyntaxEditor product.
ActiproSoftware.Windows.Controls.SyntaxEditor.Adornments | Contains types related to adornments.
ActiproSoftware.Windows.Controls.SyntaxEditor.Adornments.Implementation | Contains implementation types related to adornments.
ActiproSoftware.Windows.Controls.SyntaxEditor.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Controls.SyntaxEditor.Dialogs | Contains dialogs related to the SyntaxEditor product.
ActiproSoftware.Windows.Controls.SyntaxEditor.EditActions | Contains IEditAction implementation types.
ActiproSoftware.Windows.Controls.SyntaxEditor.Highlighting | Contains types related to highlighting.
ActiproSoftware.Windows.Controls.SyntaxEditor.Highlighting.Implementation | Contains implementation types related to highlighting.
ActiproSoftware.Windows.Controls.SyntaxEditor.Implementation | Contains implementation types related to SyntaxEditor.
ActiproSoftware.Windows.Controls.SyntaxEditor.Indicators | Contains types related to working with indicators.
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt | Contains IntelliPrompt-related types for the SyntaxEditor product.
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.Implementation | Contains implementation types related to SyntaxEditor IntelliPrompt.
ActiproSoftware.Windows.Controls.SyntaxEditor.Margins | Contains margin-related types for the SyntaxEditor product.
ActiproSoftware.Windows.Controls.SyntaxEditor.Margins.Implementation | Contains implementation types related to SyntaxEditor margins.
ActiproSoftware.Windows.Controls.SyntaxEditor.Outlining | Contains code outlining-related types for the SyntaxEditor product.
ActiproSoftware.Windows.Controls.SyntaxEditor.Outlining.Implementation | Contains implementation types related to SyntaxEditor code outlining.
ActiproSoftware.Windows.Controls.SyntaxEditor.Primitives | Contains primitive types for the SyntaxEditor product.
ActiproSoftware.Windows.Controls.Views | Contains types related to the Views product.
ActiproSoftware.Windows.Controls.Views.Primitives | Contains primitive types related to the Views product.
ActiproSoftware.Windows.Controls.Wizard | Contains classes that support implementing wizards for WPF.
ActiproSoftware.Windows.Controls.Wizard.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.Windows.Data | Provides classes for working with data.
ActiproSoftware.Windows.Data.Filtering | Provides classes for filtering data.
ActiproSoftware.Windows.DocumentManagement | Contains classes for working with documents and maintaining recent document histories.
ActiproSoftware.Windows.Extensions | Contains extension methods for common types.
ActiproSoftware.Windows.Input | Contains classes for working with user input.
ActiproSoftware.Windows.Media | Contains several helper classes for working with colors and visual trees.
ActiproSoftware.Windows.Media.Animation | Contains a number of classes that support animated transitions between two objects. These can be anything from a simple fade to a complex wipe.
ActiproSoftware.Windows.Serialization | Contains classes that are used to serialize objects to XAML, or serialize a hierarchy of objects to XML.
ActiproSoftware.Windows.Shapes | Contains primitive shapes that can be used in UI.
ActiproSoftware.Windows.Themes | Contains classes that support run-time management of control themes.
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2007-2019 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com


ActiproSoftware.Shell Namespace

Contains types related to interaction with shell folders and files, such as those in the Windows shell.
Classes
 | Class | Description
Public class | ShellObjectBase | Provides an abstract base class for an IShellObject implementation.
Public class | ShellObjectChangedEventArgs | Provides notification event args for an IShellObject.
Public class | ShellObjectWrapper | Provides an abstract base class that wraps another IShellObject implementation, allowing for easy customization.
Public class | ShellPropertyCollection | Implements a collection of IShellProperty objects.
Public class | WindowsShellMenuItemCommand | Represents an ICommand to be used on a menu item for one or more Windows shell objects.
Public class | WindowsShellService | A IShellService implementation for the Windows shell.
Interfaces
 | Interface | Description
Public interface | IShellObject | Provides the requirements for a shell object.
Public interface | IShellProperty | Provides the requirements for a property that can be applied to a shell object.
Public interface | IShellService | Provides the requirements for an object that can create and manage shell objects and properties.
Enumerations
 | Enumeration | Description
Public enumeration | ShellObjectChangeKind | Specifies the kind of IShellObject change notification.
Public enumeration | ShellObjectKind | Specifies the kind of shell object.
Public enumeration | ShellPropertyRequestKind | Specifies the kind of IShellProperty objects to request.
Public enumeration | SpecialFolderKind | Specifies the kind of special Windows shell folder.


IShellObject Interface

Provides the requirements for a shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IShellObject : INotifyPropertyChanged
Public Interface IShellObject
    Inherits INotifyPropertyChanged

The IShellObject type exposes the following members.

Properties
 | Name | Description
Public property | AreChildrenLoaded | Gets whether the Children collection is loaded.
Public property | CanCreateChildFolder | Gets whether the shell object can create a child folder.
Public property | CanHaveChildFolders | Gets whether the shell object may have child folders.
Public property | CanRename | Gets whether the shell object may be renamed.
Public property | Children | Gets the collection of child shell objects.
Public property | EditingName | Gets the full user-friendly editing name of the shell object, if available.
Public property | ExtraLargeIcon | Gets or sets the extra-large icon.
Public property | ExtraLargeIconOverlay | Gets or sets the extra-large icon overlay.
Public property | ExtraLargeThumbnail | Gets or sets the extra-large thumbnail.
Public property | FileSystemPath | Gets the file system path of the shell object, if available.
Public property | IsFolder | Gets whether the shell object is a folder, which is anything that can contain other shell objects.
Public property | IsLink | Gets whether the shell object is a link, meaning a shortcut to another shell object.
Public property | IsRemovable | Gets whether the shell object is on removable media or is a removable device.
Public property | IsVirtual | Gets whether the shell object is not part of the file system (files, directories, or root directories).
Public property | IsWatching | Gets whether the shell object's tree hierarchy is currently watching for change notifications.
Public property | Kind | Gets a ShellObjectKind that specifies the kind of this shell object.
Public property | LargeIcon | Gets or sets the large icon.
Public property | LargeIconOverlay | Gets or sets the large icon overlay.
Public property | LargeThumbnail | Gets or sets the large thumbnail.
Public property | MediumIcon | Gets or sets the medium icon.
Public property | MediumIconOverlay | Gets or sets the medium icon overlay.
Public property | MediumThumbnail | Gets or sets the medium thumbnail.
Public property | Name | Gets or sets the name of the shell object.
Public property | ParsingName | Gets the full parsing name of the shell object, if available.
Public property | RelativeParsingName | Gets the parent-relative parsing name of the shell object, if available.
Public property | ShellService | Gets the IShellService used to return this shell object's children.
Public property | SmallIcon | Gets or sets the small icon.
Public property | SmallIconOverlay | Gets or sets the small icon overlay.
Public property | SortOrder | Gets or sets a numeric sort order for sorting the shell object within other shell objects.
Public property | SpecialFolderKind | Gets a SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this shell object in the user interface (UI).
Top
Methods
 | Name | Description
Public method | CreateChildFolder | Creates a child folder with the specified name.
Public method | RefreshChildren | Refreshes the Children collection.
Public method | StartWatching | Starts watching the shell object's tree hierarchy for change notifications.
Public method | StopWatching | Stops watching the shell object's tree hierarchy for change notifications.
Top
Events
 | Name | Description
Public event | Changed | Occurs when the shell object has changed.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ActiproSoftware.Shell Namespace


IShellObject Properties

The IShellObject type exposes the following members.

Properties
 | Name | Description
Public property | AreChildrenLoaded | Gets whether the Children collection is loaded.
Public property | CanCreateChildFolder | Gets whether the shell object can create a child folder.
Public property | CanHaveChildFolders | Gets whether the shell object may have child folders.
Public property | CanRename | Gets whether the shell object may be renamed.
Public property | Children | Gets the collection of child shell objects.
Public property | EditingName | Gets the full user-friendly editing name of the shell object, if available.
Public property | ExtraLargeIcon | Gets or sets the extra-large icon.
Public property | ExtraLargeIconOverlay | Gets or sets the extra-large icon overlay.
Public property | ExtraLargeThumbnail | Gets or sets the extra-large thumbnail.
Public property | FileSystemPath | Gets the file system path of the shell object, if available.
Public property | IsFolder | Gets whether the shell object is a folder, which is anything that can contain other shell objects.
Public property | IsLink | Gets whether the shell object is a link, meaning a shortcut to another shell object.
Public property | IsRemovable | Gets whether the shell object is on removable media or is a removable device.
Public property | IsVirtual | Gets whether the shell object is not part of the file system (files, directories, or root directories).
Public property | IsWatching | Gets whether the shell object's tree hierarchy is currently watching for change notifications.
Public property | Kind | Gets a ShellObjectKind that specifies the kind of this shell object.
Public property | LargeIcon | Gets or sets the large icon.
Public property | LargeIconOverlay | Gets or sets the large icon overlay.
Public property | LargeThumbnail | Gets or sets the large thumbnail.
Public property | MediumIcon | Gets or sets the medium icon.
Public property | MediumIconOverlay | Gets or sets the medium icon overlay.
Public property | MediumThumbnail | Gets or sets the medium thumbnail.
Public property | Name | Gets or sets the name of the shell object.
Public property | ParsingName | Gets the full parsing name of the shell object, if available.
Public property | RelativeParsingName | Gets the parent-relative parsing name of the shell object, if available.
Public property | ShellService | Gets the IShellService used to return this shell object's children.
Public property | SmallIcon | Gets or sets the small icon.
Public property | SmallIconOverlay | Gets or sets the small icon overlay.
Public property | SortOrder | Gets or sets a numeric sort order for sorting the shell object within other shell objects.
Public property | SpecialFolderKind | Gets a SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this shell object in the user interface (UI).
Top
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.AreChildrenLoaded Property

Actipro WPF Studio Documentation

IShellObjectAreChildrenLoaded Property

Gets whether the Children collection is loaded.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AreChildrenLoaded { get; }
ReadOnly Property AreChildrenLoaded As Boolean
    Get

Property Value

Type: Boolean
true if the Children collection is loaded; otherwise, false.
Remarks
Since the Children collection is lazy-loaded when called, this property returns whether it has been loaded without triggering a load.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.CanCreateChildFolder Property

IShellObjectCanCreateChildFolder Property

Gets whether the shell object can create a child folder.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanCreateChildFolder { get; }
ReadOnly Property CanCreateChildFolder As Boolean
    Get

Property Value

Type: Boolean
true if the shell object can create a child folder; otherwise, false.
Remarks
Only shell folders can create child folders.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.CanHaveChildFolders Property

IShellObjectCanHaveChildFolders Property

Gets whether the shell object may have child folders.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanHaveChildFolders { get; }
ReadOnly Property CanHaveChildFolders As Boolean
    Get

Property Value

Type: Boolean
true if the shell object may have child folders; otherwise, false.
Remarks
Some shell objects can immediately return that they don't have any child folders, whereas others might require a query to determine if there are any.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.CanRename Property

IShellObjectCanRename Property

Gets whether the shell object may be renamed.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanRename { get; }
ReadOnly Property CanRename As Boolean
    Get

Property Value

Type: Boolean
true if the shell object may be renamed; otherwise, false.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.Children Property

IShellObjectChildren Property

Gets the collection of child shell objects.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IShellObject> Children { get; }
ReadOnly Property Children As IList(Of IShellObject)
    Get

Property Value

Type: IList IShellObject
The collection of child shell objects.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.EditingName Property

IShellObjectEditingName Property

Gets the full user-friendly editing name of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string EditingName { get; }
ReadOnly Property EditingName As String
    Get

Property Value

Type: String
The full user-friendly editing name of the shell object, if available.
Remarks
This value is usually the same as FileSystemPath, except that it can also return a special value to identify special shell objects.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.ExtraLargeIcon Property

IShellObjectExtraLargeIcon Property

Gets or sets the extra-large icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource ExtraLargeIcon { get; set; }
Property ExtraLargeIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The extra-large icon.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.ExtraLargeIconOverlay Property

IShellObjectExtraLargeIconOverlay Property

Gets or sets the extra-large icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource ExtraLargeIconOverlay { get; set; }
Property ExtraLargeIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The extra-large icon overlay.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.ExtraLargeThumbnail Property

IShellObjectExtraLargeThumbnail Property

Gets or sets the extra-large thumbnail.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource ExtraLargeThumbnail { get; set; }
Property ExtraLargeThumbnail As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The extra-large thumbnail.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.FileSystemPath Property

IShellObjectFileSystemPath Property

Gets the file system path of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FileSystemPath { get; }
ReadOnly Property FileSystemPath As String
    Get

Property Value

Type: String
The file system path of the shell object, if available.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.IsFolder Property

IShellObjectIsFolder Property

Gets whether the shell object is a folder, which is anything that can contain other shell objects.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsFolder { get; }
ReadOnly Property IsFolder As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is a folder, which is anything that can contain other shell objects; otherwise, false.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.IsLink Property

IShellObjectIsLink Property

Gets whether the shell object is a link, meaning a shortcut to another shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsLink { get; }
ReadOnly Property IsLink As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is a link, meaning a shortcut to another shell object; otherwise, false.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.IsRemovable Property

IShellObjectIsRemovable Property

Gets whether the shell object is on removable media or is a removable device.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsRemovable { get; }
ReadOnly Property IsRemovable As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is on removable media or is a removable device; otherwise, false.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.IsVirtual Property

IShellObjectIsVirtual Property

Gets whether the shell object is not part of the file system (files, directories, or root directories).

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsVirtual { get; }
ReadOnly Property IsVirtual As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is not part of the file system (files, directories, or root directories); otherwise, false.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.IsWatching Property

IShellObjectIsWatching Property

Gets whether the shell object's tree hierarchy is currently watching for change notifications.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsWatching { get; }
ReadOnly Property IsWatching As Boolean
    Get

Property Value

Type: Boolean
true if the shell object's tree hierarchy is currently watching for change notifications; otherwise, false.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.Kind Property

IShellObjectKind Property

Gets a ShellObjectKind that specifies the kind of this shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ShellObjectKind Kind { get; }
ReadOnly Property Kind As ShellObjectKind
    Get

Property Value

Type: ShellObjectKind
A ShellObjectKind that specifies the kind of this shell object.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.LargeIcon Property

IShellObjectLargeIcon Property

Gets or sets the large icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource LargeIcon { get; set; }
Property LargeIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The large icon.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.LargeIconOverlay Property

IShellObjectLargeIconOverlay Property

Gets or sets the large icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource LargeIconOverlay { get; set; }
Property LargeIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The large icon overlay.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.LargeThumbnail Property

IShellObjectLargeThumbnail Property

Gets or sets the large thumbnail.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource LargeThumbnail { get; set; }
Property LargeThumbnail As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The large thumbnail.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.MediumIcon Property

IShellObjectMediumIcon Property

Gets or sets the medium icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource MediumIcon { get; set; }
Property MediumIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The medium icon.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.MediumIconOverlay Property

IShellObjectMediumIconOverlay Property

Gets or sets the medium icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource MediumIconOverlay { get; set; }
Property MediumIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The medium icon overlay.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.MediumThumbnail Property

IShellObjectMediumThumbnail Property

Gets or sets the medium thumbnail.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource MediumThumbnail { get; set; }
Property MediumThumbnail As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The medium thumbnail.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.Name Property

IShellObjectName Property

Gets or sets the name of the shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String
The name of the shell object.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.ParsingName Property

IShellObjectParsingName Property

Gets the full parsing name of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ParsingName { get; }
ReadOnly Property ParsingName As String
    Get

Property Value

Type: String
The full parsing name of the shell object, if available.
Remarks
This value is usually the same as FileSystemPath, except that it can also return a special syntax to identify special shell objects.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.RelativeParsingName Property

IShellObjectRelativeParsingName Property

Gets the parent-relative parsing name of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string RelativeParsingName { get; }
ReadOnly Property RelativeParsingName As String
    Get

Property Value

Type: String
The parent-relative parsing name of the shell object, if available.
Remarks
This value is usually the same as Name, except that it can also return a special syntax to identify special shell objects.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.ShellService Property

IShellObjectShellService Property

Gets the IShellService used to return this shell object's children.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IShellService ShellService { get; }
ReadOnly Property ShellService As IShellService
    Get

Property Value

Type: IShellService
The IShellService used to return this shell object's children.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.SmallIcon Property

IShellObjectSmallIcon Property

Gets or sets the small icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource SmallIcon { get; set; }
Property SmallIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The small icon.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.SmallIconOverlay Property

IShellObjectSmallIconOverlay Property

Gets or sets the small icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ImageSource SmallIconOverlay { get; set; }
Property SmallIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The small icon overlay.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.SortOrder Property

IShellObjectSortOrder Property

Gets or sets a numeric sort order for sorting the shell object within other shell objects.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int SortOrder { get; set; }
Property SortOrder As Integer
    Get
    Set

Property Value

Type: Int32
A numeric sort order for sorting the shell object within other shell objects. The default value is 0.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.SpecialFolderKind Property

IShellObjectSpecialFolderKind Property

Gets a SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
SpecialFolderKind SpecialFolderKind { get; }
ReadOnly Property SpecialFolderKind As SpecialFolderKind
    Get

Property Value

Type: SpecialFolderKind
A SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.ToolTip Property

IShellObjectToolTip Property

Gets or sets the tool-tip object that is displayed for this shell object in the user interface (UI).

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object ToolTip { get; set; }
Property ToolTip As Object
    Get
    Set

Property Value

Type: Object
The tool-tip object.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject Methods

The IShellObject type exposes the following members.

Methods
 | Name | Description
Public method | CreateChildFolder | Creates a child folder with the specified name.
Public method | RefreshChildren | Refreshes the Children collection.
Public method | StartWatching | Starts watching the shell object's tree hierarchy for change notifications.
Public method | StopWatching | Stops watching the shell object's tree hierarchy for change notifications.
Top
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.CreateChildFolder Method

IShellObjectCreateChildFolder Method

Creates a child folder with the specified name.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CreateChildFolder(
    string name
)
Function CreateChildFolder (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the child folder.

Return Value

Type: Boolean
true if the child folder was created; otherwise, false.
Remarks
Only shell folders can create child folders.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.RefreshChildren Method

IShellObjectRefreshChildren Method

Refreshes the Children collection.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void RefreshChildren()
Sub RefreshChildren
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.StartWatching Method

IShellObjectStartWatching Method

Starts watching the shell object's tree hierarchy for change notifications.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool StartWatching()
Function StartWatching As Boolean

Return Value

Type: Boolean
true if the shell object is watching its tree hierarchy; otherwise, false.
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.StopWatching Method

IShellObjectStopWatching Method

Stops watching the shell object's tree hierarchy for change notifications.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void StopWatching()
Sub StopWatching
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject Events

The IShellObject type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the shell object has changed.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellObject.Changed Event

IShellObjectChanged Event

Occurs when the shell object has changed.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<ShellObjectChangedEventArgs> Changed
Event Changed As EventHandler(Of ShellObjectChangedEventArgs)

Value

Type: SystemEventHandler ShellObjectChangedEventArgs
See Also

Reference

IShellObject Interface
ActiproSoftware.Shell Namespace


IShellProperty Interface

Provides the requirements for a property that can be applied to a shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IShellProperty
Public Interface IShellProperty

The IShellProperty type exposes the following members.

Properties
 | Name | Description
Public property | CanonicalName | Gets the case-sensitive name by which a property is known to the system, regardless of its localized name.
Public property | ColumnDefaultSortDirection | Gets the default sort direction of a column created for this property.
Public property | ColumnHorizontalAlignment | Gets the horizontal alignment of a column created for this property.
Public property | DefaultColumnWidth | Gets the default column width for this property.
Public property | IsNameProperty | Gets whether this property is the primary property that returns the name of a shell object.
Public property | Key | Gets the key that uniquely identifies the property.
Public property | Name | Gets the display name, which is a localized property name.
Top
See Also

Reference

ActiproSoftware.Shell Namespace


IShellProperty Properties

The IShellProperty type exposes the following members.

Properties
 | Name | Description
Public property | CanonicalName | Gets the case-sensitive name by which a property is known to the system, regardless of its localized name.
Public property | ColumnDefaultSortDirection | Gets the default sort direction of a column created for this property.
Public property | ColumnHorizontalAlignment | Gets the horizontal alignment of a column created for this property.
Public property | DefaultColumnWidth | Gets the default column width for this property.
Public property | IsNameProperty | Gets whether this property is the primary property that returns the name of a shell object.
Public property | Key | Gets the key that uniquely identifies the property.
Public property | Name | Gets the display name, which is a localized property name.
Top
See Also

Reference

IShellProperty Interface
ActiproSoftware.Shell Namespace


IShellProperty.CanonicalName Property

IShellPropertyCanonicalName Property

Gets the case-sensitive name by which a property is known to the system, regardless of its localized name.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string CanonicalName { get; }
ReadOnly Property CanonicalName As String
    Get

Property Value

Type: String
The case-sensitive name by which a property is known to the system, regardless of its localized name.
See Also

Reference

IShellProperty Interface
ActiproSoftware.Shell Namespace


IShellProperty.ColumnDefaultSortDirection Property

IShellPropertyColumnDefaultSortDirection Property

Gets the default sort direction of a column created for this property.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ColumnSortDirection ColumnDefaultSortDirection { get; }
ReadOnly Property ColumnDefaultSortDirection As ColumnSortDirection
    Get

Property Value

Type: ColumnSortDirection
A ColumnSortDirection specifying the default sort direction of a column created for this property.
See Also

Reference

IShellProperty Interface
ActiproSoftware.Shell Namespace


IShellProperty.ColumnHorizontalAlignment Property

IShellPropertyColumnHorizontalAlignment Property

Gets the horizontal alignment of a column created for this property.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
HorizontalAlignment ColumnHorizontalAlignment { get; }
ReadOnly Property ColumnHorizontalAlignment As HorizontalAlignment
    Get

Property Value

Type: HorizontalAlignment
The horizontal alignment of a column created for this property.
See Also

Reference

IShellProperty Interface
ActiproSoftware.Shell Namespace


IShellProperty.DefaultColumnWidth Property

IShellPropertyDefaultColumnWidth Property

Gets the default column width for this property.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double DefaultColumnWidth { get; }
ReadOnly Property DefaultColumnWidth As Double
    Get

Property Value

Type: Double
The default column width for this property.
See Also

Reference

IShellProperty Interface
ActiproSoftware.Shell Namespace


IShellProperty.IsNameProperty Property

IShellPropertyIsNameProperty Property

Gets whether this property is the primary property that returns the name of a shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsNameProperty { get; }
ReadOnly Property IsNameProperty As Boolean
    Get

Property Value

Type: Boolean
true if this property is the primary property that returns the name of a shell object; otherwise, false.
See Also

Reference

IShellProperty Interface
ActiproSoftware.Shell Namespace


IShellProperty.Key Property

IShellPropertyKey Property

Gets the key that uniquely identifies the property.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Key { get; }
ReadOnly Property Key As Object
    Get

Property Value

Type: Object
The key that uniquely identifies the property.
See Also

Reference

IShellProperty Interface
ActiproSoftware.Shell Namespace


IShellProperty.Name Property

IShellPropertyName Property

Gets the display name, which is a localized property name.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The display name, which is a localized property name.
See Also

Reference

IShellProperty Interface
ActiproSoftware.Shell Namespace


IShellService Interface

Provides the requirements for an object that can create and manage shell objects and properties.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IShellService
Public Interface IShellService

The IShellService type exposes the following members.

Methods
 | Name | Description
Public method | CompareObjectsUsingProperty | Compares two IShellObject instances using the specified IShellProperty.
Public method | CreateObjectChildren | Creates the child IShellObject collection for the specified parent IShellObject.
Public method | CreateObjectForParsingName | Creates the IShellObject for the specified full parsing name (commonly the same as the file system path).
Public method | CreateProperties | Creates a collection of IShellProperty objects.
Public method | GetFullPath | Returns the full path of the specified IShellObject.
Public method | GetPropertyValue | Returns the property value on the specified IShellObject.
Top
See Also

Reference

ActiproSoftware.Shell Namespace


IShellService Methods

The IShellService type exposes the following members.

Methods
 | Name | Description
Public method | CompareObjectsUsingProperty | Compares two IShellObject instances using the specified IShellProperty.
Public method | CreateObjectChildren | Creates the child IShellObject collection for the specified parent IShellObject.
Public method | CreateObjectForParsingName | Creates the IShellObject for the specified full parsing name (commonly the same as the file system path).
Public method | CreateProperties | Creates a collection of IShellProperty objects.
Public method | GetFullPath | Returns the full path of the specified IShellObject.
Public method | GetPropertyValue | Returns the property value on the specified IShellObject.
Top
See Also

Reference

IShellService Interface
ActiproSoftware.Shell Namespace


IShellService.CompareObjectsUsingProperty Method

IShellServiceCompareObjectsUsingProperty Method

Compares two IShellObject instances using the specified IShellProperty.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int CompareObjectsUsingProperty(
    IShellObject shellObject1,
    IShellObject shellObject2,
    IShellProperty shellProperty
)
Function CompareObjectsUsingProperty (
    shellObject1 As IShellObject,
    shellObject2 As IShellObject,
    shellProperty As IShellProperty
) As Integer

Parameters

shellObject1
Type: ActiproSoftware.ShellIShellObject
The first IShellObject.
shellObject2
Type: ActiproSoftware.ShellIShellObject
The second IShellObject.
shellProperty
Type: ActiproSoftware.ShellIShellProperty
The IShellProperty to use for comparison.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.
See Also

Reference

IShellService Interface
ActiproSoftware.Shell Namespace


IShellService.CreateObjectChildren Method

IShellServiceCreateObjectChildren Method

Creates the child IShellObject collection for the specified parent IShellObject.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IShellObject> CreateObjectChildren(
    IShellObject parentShellObject
)
Function CreateObjectChildren (
    parentShellObject As IShellObject
) As IList(Of IShellObject)

Parameters

parentShellObject
Type: ActiproSoftware.ShellIShellObject
The parent IShellObject to examine.

Return Value

Type: IList IShellObject
The child IShellObject collection for the specified parent IShellObject.
See Also

Reference

IShellService Interface
ActiproSoftware.Shell Namespace


IShellService.CreateObjectForParsingName Method

IShellServiceCreateObjectForParsingName Method

Creates the IShellObject for the specified full parsing name (commonly the same as the file system path).

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IShellObject CreateObjectForParsingName(
    string path
)
Function CreateObjectForParsingName (
    path As String
) As IShellObject

Parameters

path
Type: SystemString
The parsing name to examine.

Return Value

Type: IShellObject
The IShellObject for the specified full parsing name.
See Also

Reference

IShellService Interface
ActiproSoftware.Shell Namespace


IShellService.CreateProperties Method

IShellServiceCreateProperties Method

Creates a collection of IShellProperty objects.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ShellPropertyCollection CreateProperties(
    IList<IShellObject> shellObjects,
    ShellPropertyRequestKind kind
)
Function CreateProperties (
    shellObjects As IList(Of IShellObject),
    kind As ShellPropertyRequestKind
) As ShellPropertyCollection

Parameters

shellObjects
Type: System.Collections.GenericIList IShellObject
One or more IShellObject objects to examine.
kind
Type: ActiproSoftware.ShellShellPropertyRequestKind
The kind of properties to request.

Return Value

Type: ShellPropertyCollection
A ShellPropertyCollection that contains the results.
See Also

Reference

IShellService Interface
ActiproSoftware.Shell Namespace


IShellService.GetFullPath Method

IShellServiceGetFullPath Method

Returns the full path of the specified IShellObject.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetFullPath(
    IShellObject shellObject,
    string pathSeparator
)
Function GetFullPath (
    shellObject As IShellObject,
    pathSeparator As String
) As String

Parameters

shellObject
Type: ActiproSoftware.ShellIShellObject
The IShellObject to examine.
pathSeparator
Type: SystemString
The path separator.

Return Value

Type: String
The full path of the specified IShellObject.
See Also

Reference

IShellService Interface
ActiproSoftware.Shell Namespace


IShellService.GetPropertyValue Method

IShellServiceGetPropertyValue Method

Returns the property value on the specified IShellObject.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object GetPropertyValue(
    IShellObject shellObject,
    IShellProperty shellProperty
)
Function GetPropertyValue (
    shellObject As IShellObject,
    shellProperty As IShellProperty
) As Object

Parameters

shellObject
Type: ActiproSoftware.ShellIShellObject
The IShellObject to examine.
shellProperty
Type: ActiproSoftware.ShellIShellProperty
The IShellProperty whose value should be returned.

Return Value

Type: Object
The property value on the specified IShellObject.
See Also

Reference

IShellService Interface
ActiproSoftware.Shell Namespace


ShellObjectBase Class

Provides an abstract base class for an IShellObject implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsDisposableObjectBase
ActiproSoftware.ShellShellObjectBase
ActiproSoftware.ShellShellObjectWrapper

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class ShellObjectBase : DisposableObjectBase,
    INotifyPropertyChanged, IShellObject
Public MustInherit Class ShellObjectBase
    Inherits DisposableObjectBase
    Implements INotifyPropertyChanged, IShellObject

The ShellObjectBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ShellObjectBase | Initializes an instance of the ShellObjectBase class.
Top
Properties
 | Name | Description
Public property | AreChildrenLoaded | Gets whether the Children collection is loaded.
Public property | CanCreateChildFolder | Gets whether the shell object can create a child folder.
Public property | CanHaveChildFolders | Gets whether the shell object may have child folders.
Public property | CanRename | Gets whether the shell object may be renamed.
Public property | Children | Gets the collection of child shell objects using lazy-loading.
Public property | EditingName | Gets the full user-friendly editing name of the shell object, if available.
Public property | ExtraLargeIcon | Gets or sets the extra-large icon.
Public property | ExtraLargeIconOverlay | Gets or sets the extra-large icon overlay.
Public property | ExtraLargeThumbnail | Gets or sets the extra-large thumbnail.
Public property | FileSystemPath | Gets the file system path of the shell object, if available.
Public property | IsFolder | Gets whether the shell object is a folder, which is anything that can contain other shell objects.
Public property | IsLink | Gets whether the shell object is a link, meaning a shortcut to another shell object.
Public property | IsRemovable | Gets whether the shell object is on removable media or is a removable device.
Public property | IsVirtual | Gets whether the shell object is not part of the file system (files, directories, or root directories).
Public property | IsWatching | Gets whether the shell object's tree hierarchy is currently watching for change notifications.
Public property | Kind | Gets a ShellObjectKind that specifies the kind of this shell object.
Public property | LargeIcon | Gets or sets the large icon.
Public property | LargeIconOverlay | Gets or sets the large icon overlay.
Public property | LargeThumbnail | Gets or sets the large thumbnail.
Public property | MediumIcon | Gets or sets the medium icon.
Public property | MediumIconOverlay | Gets or sets the medium icon overlay.
Public property | MediumThumbnail | Gets or sets the medium thumbnail.
Public property | Name | Gets or sets the name of the shell object.
Public property | ParsingName | Gets the full parsing name of the shell object, if available.
Public property | RelativeParsingName | Gets the parent-relative parsing name of the shell object, if available.
Public property | ShellService | Gets the IShellService used to return this shell object's children.
Public property | SmallIcon | Gets or sets the small icon.
Public property | SmallIconOverlay | Gets or sets the small icon overlay.
Public property | SortOrder | Gets or sets a numeric sort order for sorting the shell object within other shell objects.
Public property | SpecialFolderKind | Gets a SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this shell object in the user interface (UI).
Top
Methods
 | Name | Description
Public method | CreateChildFolder | Creates a child folder with the specified name.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObjectBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObjectBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | RaiseChangedEvent | Raises the Changed event.
Protected method | RaisePropertyChangedEvent | Raises the PropertyChanged event.
Public method | RefreshChildren | Refreshes the Children collection.
Public method | StartWatching | Starts watching the shell object's tree hierarchy for change notifications.
Public method | StopWatching | Stops watching the shell object's tree hierarchy for change notifications.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the shell object has changed.
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ActiproSoftware.Shell Namespace


ShellObjectBase Constructor

Initializes an instance of the ShellObjectBase class.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ShellObjectBase(
    IShellService shellService
)
Protected Sub New (
    shellService As IShellService
)

Parameters

shellService
Type: ActiproSoftware.ShellIShellService
The IShellService used to return this shell object's children.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase Properties

The ShellObjectBase type exposes the following members.

Properties
 | Name | Description
Public property | AreChildrenLoaded | Gets whether the Children collection is loaded.
Public property | CanCreateChildFolder | Gets whether the shell object can create a child folder.
Public property | CanHaveChildFolders | Gets whether the shell object may have child folders.
Public property | CanRename | Gets whether the shell object may be renamed.
Public property | Children | Gets the collection of child shell objects using lazy-loading.
Public property | EditingName | Gets the full user-friendly editing name of the shell object, if available.
Public property | ExtraLargeIcon | Gets or sets the extra-large icon.
Public property | ExtraLargeIconOverlay | Gets or sets the extra-large icon overlay.
Public property | ExtraLargeThumbnail | Gets or sets the extra-large thumbnail.
Public property | FileSystemPath | Gets the file system path of the shell object, if available.
Public property | IsFolder | Gets whether the shell object is a folder, which is anything that can contain other shell objects.
Public property | IsLink | Gets whether the shell object is a link, meaning a shortcut to another shell object.
Public property | IsRemovable | Gets whether the shell object is on removable media or is a removable device.
Public property | IsVirtual | Gets whether the shell object is not part of the file system (files, directories, or root directories).
Public property | IsWatching | Gets whether the shell object's tree hierarchy is currently watching for change notifications.
Public property | Kind | Gets a ShellObjectKind that specifies the kind of this shell object.
Public property | LargeIcon | Gets or sets the large icon.
Public property | LargeIconOverlay | Gets or sets the large icon overlay.
Public property | LargeThumbnail | Gets or sets the large thumbnail.
Public property | MediumIcon | Gets or sets the medium icon.
Public property | MediumIconOverlay | Gets or sets the medium icon overlay.
Public property | MediumThumbnail | Gets or sets the medium thumbnail.
Public property | Name | Gets or sets the name of the shell object.
Public property | ParsingName | Gets the full parsing name of the shell object, if available.
Public property | RelativeParsingName | Gets the parent-relative parsing name of the shell object, if available.
Public property | ShellService | Gets the IShellService used to return this shell object's children.
Public property | SmallIcon | Gets or sets the small icon.
Public property | SmallIconOverlay | Gets or sets the small icon overlay.
Public property | SortOrder | Gets or sets a numeric sort order for sorting the shell object within other shell objects.
Public property | SpecialFolderKind | Gets a SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this shell object in the user interface (UI).
Top
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.AreChildrenLoaded Property

ShellObjectBaseAreChildrenLoaded Property

Gets whether the Children collection is loaded.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool AreChildrenLoaded { get; }
Public Overridable ReadOnly Property AreChildrenLoaded As Boolean
    Get

Property Value

Type: Boolean
true if the Children collection is loaded; otherwise, false.

Implements

IShellObjectAreChildrenLoaded
Remarks
Since the Children collection is lazy-loaded when called, this property returns whether it has been loaded without triggering a load.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.CanCreateChildFolder Property

ShellObjectBaseCanCreateChildFolder Property

Gets whether the shell object can create a child folder.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanCreateChildFolder { get; }
Public Overridable ReadOnly Property CanCreateChildFolder As Boolean
    Get

Property Value

Type: Boolean
true if the shell object can create a child folder; otherwise, false. The default implementation of this property returns false.

Implements

IShellObjectCanCreateChildFolder
Remarks
Only shell folders can create child folders.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.CanHaveChildFolders Property

ShellObjectBaseCanHaveChildFolders Property

Gets whether the shell object may have child folders.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanHaveChildFolders { get; }
Public Overridable ReadOnly Property CanHaveChildFolders As Boolean
    Get

Property Value

Type: Boolean
true if the shell object may have child folders; otherwise, false. The default implementation of this property returns the IsFolder property value.

Implements

IShellObjectCanHaveChildFolders
Remarks
Some shell objects can immediately return that they don't have any child folders, whereas others might require a query to determine if there are any.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.CanRename Property

ShellObjectBaseCanRename Property

Gets whether the shell object may be renamed.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanRename { get; }
Public Overridable ReadOnly Property CanRename As Boolean
    Get

Property Value

Type: Boolean
true if the shell object may be renamed; otherwise, false. The default implementation of this property returns false.

Implements

IShellObjectCanRename
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.Children Property

ShellObjectBaseChildren Property

Gets the collection of child shell objects using lazy-loading.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IList<IShellObject> Children { get; }
Public Overridable ReadOnly Property Children As IList(Of IShellObject)
    Get

Property Value

Type: IList IShellObject
The collection of child shell objects using lazy-loading.

Implements

IShellObjectChildren
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.EditingName Property

ShellObjectBaseEditingName Property

Gets the full user-friendly editing name of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string EditingName { get; }
Public Overridable ReadOnly Property EditingName As String
    Get

Property Value

Type: String
The full user-friendly editing name of the shell object, if available.

Implements

IShellObjectEditingName
Remarks
This value is usually the same as FileSystemPath, except that it can also return a special value to identify special shell objects.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.ExtraLargeIcon Property

ShellObjectBaseExtraLargeIcon Property

Gets or sets the extra-large icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource ExtraLargeIcon { get; set; }
Public MustOverride Property ExtraLargeIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The extra-large icon.

Implements

IShellObjectExtraLargeIcon
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.ExtraLargeIconOverlay Property

ShellObjectBaseExtraLargeIconOverlay Property

Gets or sets the extra-large icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource ExtraLargeIconOverlay { get; set; }
Public MustOverride Property ExtraLargeIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The extra-large icon overlay.

Implements

IShellObjectExtraLargeIconOverlay
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.ExtraLargeThumbnail Property

ShellObjectBaseExtraLargeThumbnail Property

Gets or sets the extra-large thumbnail.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource ExtraLargeThumbnail { get; set; }
Public MustOverride Property ExtraLargeThumbnail As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The extra-large thumbnail.

Implements

IShellObjectExtraLargeThumbnail
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.FileSystemPath Property

ShellObjectBaseFileSystemPath Property

Gets the file system path of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string FileSystemPath { get; }
Public Overridable ReadOnly Property FileSystemPath As String
    Get

Property Value

Type: String
The file system path of the shell object, if available. The default implementation of this property returns .

Implements

IShellObjectFileSystemPath
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.IsFolder Property

ShellObjectBaseIsFolder Property

Gets whether the shell object is a folder, which is anything that can contain other shell objects.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsFolder { get; }
Public Overridable ReadOnly Property IsFolder As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is a folder, which is anything that can contain other shell objects; otherwise, false. The default implementation of this property returns true based on an applicable Kind property value.

Implements

IShellObjectIsFolder
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.IsLink Property

ShellObjectBaseIsLink Property

Gets whether the shell object is a link, meaning a shortcut to another shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsLink { get; }
Public Overridable ReadOnly Property IsLink As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is a link, meaning a shortcut to another shell object; otherwise, false. The default implementation of this property returns true based on an applicable Kind property value.

Implements

IShellObjectIsLink
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.IsRemovable Property

ShellObjectBaseIsRemovable Property

Gets whether the shell object is on removable media or is a removable device.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsRemovable { get; }
Public Overridable ReadOnly Property IsRemovable As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is on removable media or is a removable device; otherwise, false. The default implementation of this property returns false.

Implements

IShellObjectIsRemovable
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.IsVirtual Property

ShellObjectBaseIsVirtual Property

Gets whether the shell object is not part of the file system (files, directories, or root directories).

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsVirtual { get; }
Public Overridable ReadOnly Property IsVirtual As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is not part of the file system (files, directories, or root directories); otherwise, false. The default implementation of this property returns true.

Implements

IShellObjectIsVirtual
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.IsWatching Property

ShellObjectBaseIsWatching Property

Gets whether the shell object's tree hierarchy is currently watching for change notifications.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsWatching { get; }
Public Overridable ReadOnly Property IsWatching As Boolean
    Get

Property Value

Type: Boolean
true if the shell object's tree hierarchy is currently watching for change notifications; otherwise, false. The default implementation of this property returns false.

Implements

IShellObjectIsWatching
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.Kind Property

ShellObjectBaseKind Property

Gets a ShellObjectKind that specifies the kind of this shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ShellObjectKind Kind { get; }
Public MustOverride ReadOnly Property Kind As ShellObjectKind
    Get

Property Value

Type: ShellObjectKind
A ShellObjectKind that specifies the kind of this shell object.

Implements

IShellObjectKind
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.LargeIcon Property

ShellObjectBaseLargeIcon Property

Gets or sets the large icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource LargeIcon { get; set; }
Public MustOverride Property LargeIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The large icon.

Implements

IShellObjectLargeIcon
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.LargeIconOverlay Property

ShellObjectBaseLargeIconOverlay Property

Gets or sets the large icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource LargeIconOverlay { get; set; }
Public MustOverride Property LargeIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The large icon overlay.

Implements

IShellObjectLargeIconOverlay
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.LargeThumbnail Property

ShellObjectBaseLargeThumbnail Property

Gets or sets the large thumbnail.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource LargeThumbnail { get; set; }
Public MustOverride Property LargeThumbnail As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The large thumbnail.

Implements

IShellObjectLargeThumbnail
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.MediumIcon Property

ShellObjectBaseMediumIcon Property

Gets or sets the medium icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource MediumIcon { get; set; }
Public MustOverride Property MediumIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The medium icon.

Implements

IShellObjectMediumIcon
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.MediumIconOverlay Property

ShellObjectBaseMediumIconOverlay Property

Gets or sets the medium icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource MediumIconOverlay { get; set; }
Public MustOverride Property MediumIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The medium icon overlay.

Implements

IShellObjectMediumIconOverlay
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.MediumThumbnail Property

ShellObjectBaseMediumThumbnail Property

Gets or sets the medium thumbnail.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource MediumThumbnail { get; set; }
Public MustOverride Property MediumThumbnail As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The medium thumbnail.

Implements

IShellObjectMediumThumbnail
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.Name Property

ShellObjectBaseName Property

Gets or sets the name of the shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract string Name { get; set; }
Public MustOverride Property Name As String
    Get
    Set

Property Value

Type: String
The name of the shell object.

Implements

IShellObjectName
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.ParsingName Property

ShellObjectBaseParsingName Property

Gets the full parsing name of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string ParsingName { get; }
Public Overridable ReadOnly Property ParsingName As String
    Get

Property Value

Type: String
The full parsing name of the shell object, if available. The default implementation of this property returns the FileSystemPath property value.

Implements

IShellObjectParsingName
Remarks
This value is usually the same as FileSystemPath, except that it can also return a special syntax to identify special shell objects.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.RelativeParsingName Property

ShellObjectBaseRelativeParsingName Property

Gets the parent-relative parsing name of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string RelativeParsingName { get; }
Public Overridable ReadOnly Property RelativeParsingName As String
    Get

Property Value

Type: String
The parent-relative parsing name of the shell object, if available.

Implements

IShellObjectRelativeParsingName
Remarks
This value is usually the same as Name, except that it can also return a special syntax to identify special shell objects.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.ShellService Property

ShellObjectBaseShellService Property

Gets the IShellService used to return this shell object's children.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IShellService ShellService { get; }
Public ReadOnly Property ShellService As IShellService
    Get

Property Value

Type: IShellService
The IShellService used to return this shell object's children.

Implements

IShellObjectShellService
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.SmallIcon Property

ShellObjectBaseSmallIcon Property

Gets or sets the small icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource SmallIcon { get; set; }
Public MustOverride Property SmallIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The small icon.

Implements

IShellObjectSmallIcon
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.SmallIconOverlay Property

ShellObjectBaseSmallIconOverlay Property

Gets or sets the small icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ImageSource SmallIconOverlay { get; set; }
Public MustOverride Property SmallIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The small icon overlay.

Implements

IShellObjectSmallIconOverlay
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.SortOrder Property

ShellObjectBaseSortOrder Property

Gets or sets a numeric sort order for sorting the shell object within other shell objects.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual int SortOrder { get; set; }
Public Overridable Property SortOrder As Integer
    Get
    Set

Property Value

Type: Int32
A numeric sort order for sorting the shell object within other shell objects. The default value is 0.

Implements

IShellObjectSortOrder
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.SpecialFolderKind Property

ShellObjectBaseSpecialFolderKind Property

Gets a SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual SpecialFolderKind SpecialFolderKind { get; }
Public Overridable ReadOnly Property SpecialFolderKind As SpecialFolderKind
    Get

Property Value

Type: SpecialFolderKind
A SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable. The default implementation of this property returns None.

Implements

IShellObjectSpecialFolderKind
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.ToolTip Property

ShellObjectBaseToolTip Property

Gets or sets the tool-tip object that is displayed for this shell object in the user interface (UI).

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract Object ToolTip { get; set; }
Public MustOverride Property ToolTip As Object
    Get
    Set

Property Value

Type: Object
The tool-tip object.

Implements

IShellObjectToolTip
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase Methods

The ShellObjectBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateChildFolder | Creates a child folder with the specified name.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObjectBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObjectBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | RaiseChangedEvent | Raises the Changed event.
Protected method | RaisePropertyChangedEvent | Raises the PropertyChanged event.
Public method | RefreshChildren | Refreshes the Children collection.
Public method | StartWatching | Starts watching the shell object's tree hierarchy for change notifications.
Public method | StopWatching | Stops watching the shell object's tree hierarchy for change notifications.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.CreateChildFolder Method

ShellObjectBaseCreateChildFolder Method

Creates a child folder with the specified name.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CreateChildFolder(
    string name
)
Public Overridable Function CreateChildFolder (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the child folder.

Return Value

Type: Boolean
true if the child folder was created; otherwise, false.

Implements

IShellObjectCreateChildFolder(String)
Remarks
Only shell folders can create child folders. The default implementation of this method does nothing and returns false.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.Dispose Method

ShellObjectBaseDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObjectBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectBaseDispose(Boolean).)
Top
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.Dispose Method (Boolean)

ShellObjectBaseDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

ShellObjectBase Class
Dispose Overload
ActiproSoftware.Shell Namespace


ShellObjectBase.NotifyPropertyChanged Method

ShellObjectBaseNotifyPropertyChanged Method

Notifies that a property has changed.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.RaiseChangedEvent Method

ShellObjectBaseRaiseChangedEvent Method

Raises the Changed event.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaiseChangedEvent(
    ShellObjectChangedEventArgs e
)
Protected Sub RaiseChangedEvent (
    e As ShellObjectChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.ShellShellObjectChangedEventArgs
The ShellObjectChangedEventArgs that contains the event data.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.RaisePropertyChangedEvent Method

ShellObjectBaseRaisePropertyChangedEvent Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaisePropertyChangedEvent(
    PropertyChangedEventArgs e
)
Protected Sub RaisePropertyChangedEvent (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.RefreshChildren Method

ShellObjectBaseRefreshChildren Method

Refreshes the Children collection.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void RefreshChildren()
Public Overridable Sub RefreshChildren

Implements

IShellObjectRefreshChildren
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.StartWatching Method

ShellObjectBaseStartWatching Method

Starts watching the shell object's tree hierarchy for change notifications.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool StartWatching()
Public Overridable Function StartWatching As Boolean

Return Value

Type: Boolean
true if the shell object is watching its tree hierarchy; otherwise, false.

Implements

IShellObjectStartWatching
Remarks
The default implementation of this method does nothing, and returns false.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.StopWatching Method

ShellObjectBaseStopWatching Method

Stops watching the shell object's tree hierarchy for change notifications.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void StopWatching()
Public Overridable Sub StopWatching

Implements

IShellObjectStopWatching
Remarks
The default implementation of this method does nothing.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.ToString Method

ShellObjectBaseToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase Events

The ShellObjectBase type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the shell object has changed.
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.Changed Event

ShellObjectBaseChanged Event

Occurs when the shell object has changed.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<ShellObjectChangedEventArgs> Changed
Public Event Changed As EventHandler(Of ShellObjectChangedEventArgs)

Value

Type: SystemEventHandler ShellObjectChangedEventArgs

Implements

IShellObjectChanged
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectBase.PropertyChanged Event

ShellObjectBasePropertyChanged Event

Occurs when a property has been changed.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ShellObjectBase Class
ActiproSoftware.Shell Namespace


ShellObjectChangedEventArgs Class

Provides notification event args for an IShellObject.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.ShellShellObjectChangedEventArgs

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ShellObjectChangedEventArgs : EventArgs
Public Class ShellObjectChangedEventArgs
    Inherits EventArgs

The ShellObjectChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ShellObjectChangedEventArgs | Initializes an instance of the ShellObjectChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | ChildShellObject | Gets the child IShellObject if the change event is related to a child.
Public property | Kind | Gets the ShellObjectChangeKind that indicates the kind of change notification.
Top
See Also

Reference

ActiproSoftware.Shell Namespace


ShellObjectChangedEventArgs Constructor

Initializes an instance of the ShellObjectChangedEventArgs class.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ShellObjectChangedEventArgs(
    ShellObjectChangeKind kind,
    IShellObject childShellObject
)
Public Sub New (
    kind As ShellObjectChangeKind,
    childShellObject As IShellObject
)

Parameters

kind
Type: ActiproSoftware.ShellShellObjectChangeKind
The ShellObjectChangeKind that indicates the kind of change notification.
childShellObject
Type: ActiproSoftware.ShellIShellObject
The child IShellObject if the change event is related to a child.
See Also

Reference

ShellObjectChangedEventArgs Class
ActiproSoftware.Shell Namespace


ShellObjectChangedEventArgs Properties

The ShellObjectChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChildShellObject | Gets the child IShellObject if the change event is related to a child.
Public property | Kind | Gets the ShellObjectChangeKind that indicates the kind of change notification.
Top
See Also

Reference

ShellObjectChangedEventArgs Class
ActiproSoftware.Shell Namespace


ShellObjectChangedEventArgs.ChildShellObject Property

ShellObjectChangedEventArgsChildShellObject Property

Gets the child IShellObject if the change event is related to a child.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IShellObject ChildShellObject { get; }
Public ReadOnly Property ChildShellObject As IShellObject
    Get

Property Value

Type: IShellObject
The child IShellObject if the change event is related to a child.
See Also

Reference

ShellObjectChangedEventArgs Class
ActiproSoftware.Shell Namespace


ShellObjectChangedEventArgs.Kind Property

ShellObjectChangedEventArgsKind Property

Gets the ShellObjectChangeKind that indicates the kind of change notification.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ShellObjectChangeKind Kind { get; }
Public ReadOnly Property Kind As ShellObjectChangeKind
    Get

Property Value

Type: ShellObjectChangeKind
The ShellObjectChangeKind that indicates the kind of change notification.
See Also

Reference

ShellObjectChangedEventArgs Class
ActiproSoftware.Shell Namespace


ShellObjectChangeKind Enumeration

Specifies the kind of IShellObject change notification.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ShellObjectChangeKind
Public Enumeration ShellObjectChangeKind
Members
Member name | Value | Description
ChildAdded | 0 | A child shell object was added.
ChildRemoved | 1 | A child shell object was removed.
SortRequested | 2 | A sort is requested.
See Also

Reference

ActiproSoftware.Shell Namespace


ShellObjectKind Enumeration

Specifies the kind of shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ShellObjectKind
Public Enumeration ShellObjectKind
Members
Member name | Value | Description
Unknown | 0 | An unknown kind of object.
File | 1 | A file in the file system.
Folder | 2 | A file system folder, such as a directory on a hard drive.
SpecialFolder | 3 | A special file system folder, such as "Desktop" or "OneDrive".
VirtualSpecialFolder | 4 | A special non-file system folder, such as "This PC" or "Recycle Bin".
Library | 5 | A library folder, which is a collection of shell objects, potentially from multiple locations.
Link | 6 | A link to another object.
VirtualObject | 7 | A virtual object, which is a non-folder and non-file system object, such as "Network" computers.
See Also

Reference

ActiproSoftware.Shell Namespace


ShellObjectWrapper Class

Provides an abstract base class that wraps another IShellObject implementation, allowing for easy customization.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsDisposableObjectBase
ActiproSoftware.ShellShellObjectBase
ActiproSoftware.ShellShellObjectWrapper

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class ShellObjectWrapper : ShellObjectBase
Public MustInherit Class ShellObjectWrapper
    Inherits ShellObjectBase

The ShellObjectWrapper type exposes the following members.

Constructors
 | Name | Description
Protected method | ShellObjectWrapper | Initializes an instance of the ShellObjectWrapper class.
Top
Properties
 | Name | Description
Public property | AreChildrenLoaded | Gets whether the Children collection is loaded. (Overrides ShellObjectBaseAreChildrenLoaded.)
Public property | CanCreateChildFolder | Gets whether the shell object can create a child folder. (Overrides ShellObjectBaseCanCreateChildFolder.)
Public property | CanHaveChildFolders | Gets whether the shell object may have child folders. (Overrides ShellObjectBaseCanHaveChildFolders.)
Public property | CanRename | Gets whether the shell object may be renamed. (Overrides ShellObjectBaseCanRename.)
Public property | Children | Gets the collection of child shell objects using lazy-loading. (Overrides ShellObjectBaseChildren.)
Public property | EditingName | Gets the full user-friendly editing name of the shell object, if available. (Overrides ShellObjectBaseEditingName.)
Public property | ExtraLargeIcon | Gets or sets the extra-large icon. (Overrides ShellObjectBaseExtraLargeIcon.)
Public property | ExtraLargeIconOverlay | Gets or sets the extra-large icon overlay. (Overrides ShellObjectBaseExtraLargeIconOverlay.)
Public property | ExtraLargeThumbnail | Gets or sets the extra-large thumbnail. (Inherited from ShellObjectBase.)
Public property | FileSystemPath | Gets the file system path of the shell object, if available. (Overrides ShellObjectBaseFileSystemPath.)
Public property | IsFolder | Gets whether the shell object is a folder, which is anything that can contain other shell objects. (Overrides ShellObjectBaseIsFolder.)
Public property | IsLink | Gets whether the shell object is a link, meaning a shortcut to another shell object. (Overrides ShellObjectBaseIsLink.)
Public property | IsRemovable | Gets whether the shell object is on removable media or is a removable device. (Overrides ShellObjectBaseIsRemovable.)
Public property | IsVirtual | Gets whether the shell object is not part of the file system (files, directories, or root directories). (Overrides ShellObjectBaseIsVirtual.)
Public property | IsWatching | Gets whether the shell object's tree hierarchy is currently watching for change notifications. (Overrides ShellObjectBaseIsWatching.)
Public property | Kind | Gets a ShellObjectKind that specifies the kind of this shell object. (Overrides ShellObjectBaseKind.)
Public property | LargeIcon | Gets or sets the large icon. (Overrides ShellObjectBaseLargeIcon.)
Public property | LargeIconOverlay | Gets or sets the large icon overlay. (Overrides ShellObjectBaseLargeIconOverlay.)
Public property | LargeThumbnail | Gets or sets the large thumbnail. (Inherited from ShellObjectBase.)
Public property | MediumIcon | Gets or sets the medium icon. (Overrides ShellObjectBaseMediumIcon.)
Public property | MediumIconOverlay | Gets or sets the medium icon overlay. (Overrides ShellObjectBaseMediumIconOverlay.)
Public property | MediumThumbnail | Gets or sets the medium thumbnail. (Inherited from ShellObjectBase.)
Public property | Name | Gets or sets the name of the shell object. (Overrides ShellObjectBaseName.)
Public property | ParsingName | Gets the full parsing name of the shell object, if available. (Overrides ShellObjectBaseParsingName.)
Public property | RelativeParsingName | Gets the parent-relative parsing name of the shell object, if available. (Overrides ShellObjectBaseRelativeParsingName.)
Public property | ShellService | Gets the IShellService used to return this shell object's children. (Inherited from ShellObjectBase.)
Public property | SmallIcon | Gets or sets the small icon. (Overrides ShellObjectBaseSmallIcon.)
Public property | SmallIconOverlay | Gets or sets the small icon overlay. (Overrides ShellObjectBaseSmallIconOverlay.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the shell object within other shell objects. (Overrides ShellObjectBaseSortOrder.)
Public property | SpecialFolderKind | Gets a SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable. (Overrides ShellObjectBaseSpecialFolderKind.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this shell object in the user interface (UI). (Overrides ShellObjectBaseToolTip.)
Public property | WrappedShellObject | Gets the IShellObject that is wrapped by this class.
Top
Methods
 | Name | Description
Public method | CreateChildFolder | Creates a child folder with the specified name. (Overrides ShellObjectBaseCreateChildFolder(String).)
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObjectBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides ShellObjectBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObjectBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ShellObjectBase.)
Protected method | RaiseChangedEvent | Raises the Changed event. (Inherited from ShellObjectBase.)
Protected method | RaisePropertyChangedEvent | Raises the PropertyChanged event. (Inherited from ShellObjectBase.)
Public method | RefreshChildren | Refreshes the Children collection. (Overrides ShellObjectBaseRefreshChildren.)
Public method | StartWatching | Starts watching the shell object's tree hierarchy for change notifications. (Overrides ShellObjectBaseStartWatching.)
Public method | StopWatching | Stops watching the shell object's tree hierarchy for change notifications. (Overrides ShellObjectBaseStopWatching.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ShellObjectBase.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the shell object has changed. (Inherited from ShellObjectBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ShellObjectBase.)
Top
See Also

Reference

ActiproSoftware.Shell Namespace


ShellObjectWrapper Constructor

Initializes an instance of the ShellObjectWrapper class.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ShellObjectWrapper(
    IShellService shellService,
    IShellObject wrappedShellObject
)
Protected Sub New (
    shellService As IShellService,
    wrappedShellObject As IShellObject
)

Parameters

shellService
Type: ActiproSoftware.ShellIShellService
The IShellService used to return this shell object's children.
wrappedShellObject
Type: ActiproSoftware.ShellIShellObject
The IShellObject to be wrapped by this class.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper Properties

The ShellObjectWrapper type exposes the following members.

Properties
 | Name | Description
Public property | AreChildrenLoaded | Gets whether the Children collection is loaded. (Overrides ShellObjectBaseAreChildrenLoaded.)
Public property | CanCreateChildFolder | Gets whether the shell object can create a child folder. (Overrides ShellObjectBaseCanCreateChildFolder.)
Public property | CanHaveChildFolders | Gets whether the shell object may have child folders. (Overrides ShellObjectBaseCanHaveChildFolders.)
Public property | CanRename | Gets whether the shell object may be renamed. (Overrides ShellObjectBaseCanRename.)
Public property | Children | Gets the collection of child shell objects using lazy-loading. (Overrides ShellObjectBaseChildren.)
Public property | EditingName | Gets the full user-friendly editing name of the shell object, if available. (Overrides ShellObjectBaseEditingName.)
Public property | ExtraLargeIcon | Gets or sets the extra-large icon. (Overrides ShellObjectBaseExtraLargeIcon.)
Public property | ExtraLargeIconOverlay | Gets or sets the extra-large icon overlay. (Overrides ShellObjectBaseExtraLargeIconOverlay.)
Public property | ExtraLargeThumbnail | Gets or sets the extra-large thumbnail. (Inherited from ShellObjectBase.)
Public property | FileSystemPath | Gets the file system path of the shell object, if available. (Overrides ShellObjectBaseFileSystemPath.)
Public property | IsFolder | Gets whether the shell object is a folder, which is anything that can contain other shell objects. (Overrides ShellObjectBaseIsFolder.)
Public property | IsLink | Gets whether the shell object is a link, meaning a shortcut to another shell object. (Overrides ShellObjectBaseIsLink.)
Public property | IsRemovable | Gets whether the shell object is on removable media or is a removable device. (Overrides ShellObjectBaseIsRemovable.)
Public property | IsVirtual | Gets whether the shell object is not part of the file system (files, directories, or root directories). (Overrides ShellObjectBaseIsVirtual.)
Public property | IsWatching | Gets whether the shell object's tree hierarchy is currently watching for change notifications. (Overrides ShellObjectBaseIsWatching.)
Public property | Kind | Gets a ShellObjectKind that specifies the kind of this shell object. (Overrides ShellObjectBaseKind.)
Public property | LargeIcon | Gets or sets the large icon. (Overrides ShellObjectBaseLargeIcon.)
Public property | LargeIconOverlay | Gets or sets the large icon overlay. (Overrides ShellObjectBaseLargeIconOverlay.)
Public property | LargeThumbnail | Gets or sets the large thumbnail. (Inherited from ShellObjectBase.)
Public property | MediumIcon | Gets or sets the medium icon. (Overrides ShellObjectBaseMediumIcon.)
Public property | MediumIconOverlay | Gets or sets the medium icon overlay. (Overrides ShellObjectBaseMediumIconOverlay.)
Public property | MediumThumbnail | Gets or sets the medium thumbnail. (Inherited from ShellObjectBase.)
Public property | Name | Gets or sets the name of the shell object. (Overrides ShellObjectBaseName.)
Public property | ParsingName | Gets the full parsing name of the shell object, if available. (Overrides ShellObjectBaseParsingName.)
Public property | RelativeParsingName | Gets the parent-relative parsing name of the shell object, if available. (Overrides ShellObjectBaseRelativeParsingName.)
Public property | ShellService | Gets the IShellService used to return this shell object's children. (Inherited from ShellObjectBase.)
Public property | SmallIcon | Gets or sets the small icon. (Overrides ShellObjectBaseSmallIcon.)
Public property | SmallIconOverlay | Gets or sets the small icon overlay. (Overrides ShellObjectBaseSmallIconOverlay.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the shell object within other shell objects. (Overrides ShellObjectBaseSortOrder.)
Public property | SpecialFolderKind | Gets a SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable. (Overrides ShellObjectBaseSpecialFolderKind.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this shell object in the user interface (UI). (Overrides ShellObjectBaseToolTip.)
Public property | WrappedShellObject | Gets the IShellObject that is wrapped by this class.
Top
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.AreChildrenLoaded Property

ShellObjectWrapperAreChildrenLoaded Property

Gets whether the Children collection is loaded.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool AreChildrenLoaded { get; }
Public Overrides ReadOnly Property AreChildrenLoaded As Boolean
    Get

Property Value

Type: Boolean
true if the Children collection is loaded; otherwise, false.

Implements

IShellObjectAreChildrenLoaded
Remarks
Since the Children collection is lazy-loaded when called, this property returns whether it has been loaded without triggering a load.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.CanCreateChildFolder Property

ShellObjectWrapperCanCreateChildFolder Property

Gets whether the shell object can create a child folder.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanCreateChildFolder { get; }
Public Overrides ReadOnly Property CanCreateChildFolder As Boolean
    Get

Property Value

Type: Boolean
true if the shell object can create a child folder; otherwise, false. The default implementation of this property returns false.

Implements

IShellObjectCanCreateChildFolder
Remarks
Only shell folders can create child folders.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.CanHaveChildFolders Property

ShellObjectWrapperCanHaveChildFolders Property

Gets whether the shell object may have child folders.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanHaveChildFolders { get; }
Public Overrides ReadOnly Property CanHaveChildFolders As Boolean
    Get

Property Value

Type: Boolean
true if the shell object may have child folders; otherwise, false. The default implementation of this property returns the IsFolder property value.

Implements

IShellObjectCanHaveChildFolders
Remarks
Some shell objects can immediately return that they don't have any child folders, whereas others might require a query to determine if there are any.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.CanRename Property

ShellObjectWrapperCanRename Property

Gets whether the shell object may be renamed.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanRename { get; }
Public Overrides ReadOnly Property CanRename As Boolean
    Get

Property Value

Type: Boolean
true if the shell object may be renamed; otherwise, false. The default implementation of this property returns false.

Implements

IShellObjectCanRename
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.Children Property

ShellObjectWrapperChildren Property

Gets the collection of child shell objects using lazy-loading.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IList<IShellObject> Children { get; }
Public Overrides ReadOnly Property Children As IList(Of IShellObject)
    Get

Property Value

Type: IList IShellObject
The collection of child shell objects using lazy-loading.

Implements

IShellObjectChildren
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.EditingName Property

ShellObjectWrapperEditingName Property

Gets the full user-friendly editing name of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string EditingName { get; }
Public Overrides ReadOnly Property EditingName As String
    Get

Property Value

Type: String
The full user-friendly editing name of the shell object, if available.

Implements

IShellObjectEditingName
Remarks
This value is usually the same as FileSystemPath, except that it can also return a special value to identify special shell objects.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.ExtraLargeIcon Property

ShellObjectWrapperExtraLargeIcon Property

Gets or sets the extra-large icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ImageSource ExtraLargeIcon { get; set; }
Public Overrides Property ExtraLargeIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The extra-large icon.

Implements

IShellObjectExtraLargeIcon
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.ExtraLargeIconOverlay Property

ShellObjectWrapperExtraLargeIconOverlay Property

Gets or sets the extra-large icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ImageSource ExtraLargeIconOverlay { get; set; }
Public Overrides Property ExtraLargeIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The extra-large icon overlay.

Implements

IShellObjectExtraLargeIconOverlay
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.FileSystemPath Property

ShellObjectWrapperFileSystemPath Property

Gets the file system path of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string FileSystemPath { get; }
Public Overrides ReadOnly Property FileSystemPath As String
    Get

Property Value

Type: String
The file system path of the shell object, if available. The default implementation of this property returns .

Implements

IShellObjectFileSystemPath
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.IsFolder Property

ShellObjectWrapperIsFolder Property

Gets whether the shell object is a folder, which is anything that can contain other shell objects.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool IsFolder { get; }
Public Overrides ReadOnly Property IsFolder As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is a folder, which is anything that can contain other shell objects; otherwise, false. The default implementation of this property returns true based on an applicable Kind property value.

Implements

IShellObjectIsFolder
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.IsLink Property

ShellObjectWrapperIsLink Property

Gets whether the shell object is a link, meaning a shortcut to another shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool IsLink { get; }
Public Overrides ReadOnly Property IsLink As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is a link, meaning a shortcut to another shell object; otherwise, false. The default implementation of this property returns true based on an applicable Kind property value.

Implements

IShellObjectIsLink
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.IsRemovable Property

ShellObjectWrapperIsRemovable Property

Gets whether the shell object is on removable media or is a removable device.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool IsRemovable { get; }
Public Overrides ReadOnly Property IsRemovable As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is on removable media or is a removable device; otherwise, false. The default implementation of this property returns false.

Implements

IShellObjectIsRemovable
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.IsVirtual Property

ShellObjectWrapperIsVirtual Property

Gets whether the shell object is not part of the file system (files, directories, or root directories).

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool IsVirtual { get; }
Public Overrides ReadOnly Property IsVirtual As Boolean
    Get

Property Value

Type: Boolean
true if the shell object is not part of the file system (files, directories, or root directories); otherwise, false. The default implementation of this property returns true.

Implements

IShellObjectIsVirtual
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.IsWatching Property

ShellObjectWrapperIsWatching Property

Gets whether the shell object's tree hierarchy is currently watching for change notifications.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool IsWatching { get; }
Public Overrides ReadOnly Property IsWatching As Boolean
    Get

Property Value

Type: Boolean
true if the shell object's tree hierarchy is currently watching for change notifications; otherwise, false. The default implementation of this property returns false.

Implements

IShellObjectIsWatching
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.Kind Property

ShellObjectWrapperKind Property

Gets a ShellObjectKind that specifies the kind of this shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ShellObjectKind Kind { get; }
Public Overrides ReadOnly Property Kind As ShellObjectKind
    Get

Property Value

Type: ShellObjectKind
A ShellObjectKind that specifies the kind of this shell object.

Implements

IShellObjectKind
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.LargeIcon Property

ShellObjectWrapperLargeIcon Property

Gets or sets the large icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ImageSource LargeIcon { get; set; }
Public Overrides Property LargeIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The large icon.

Implements

IShellObjectLargeIcon
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.LargeIconOverlay Property

ShellObjectWrapperLargeIconOverlay Property

Gets or sets the large icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ImageSource LargeIconOverlay { get; set; }
Public Overrides Property LargeIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The large icon overlay.

Implements

IShellObjectLargeIconOverlay
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.MediumIcon Property

ShellObjectWrapperMediumIcon Property

Gets or sets the medium icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ImageSource MediumIcon { get; set; }
Public Overrides Property MediumIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The medium icon.

Implements

IShellObjectMediumIcon
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.MediumIconOverlay Property

ShellObjectWrapperMediumIconOverlay Property

Gets or sets the medium icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ImageSource MediumIconOverlay { get; set; }
Public Overrides Property MediumIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The medium icon overlay.

Implements

IShellObjectMediumIconOverlay
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.Name Property

ShellObjectWrapperName Property

Gets or sets the name of the shell object.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set

Property Value

Type: String
The name of the shell object.

Implements

IShellObjectName
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.ParsingName Property

ShellObjectWrapperParsingName Property

Gets the full parsing name of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ParsingName { get; }
Public Overrides ReadOnly Property ParsingName As String
    Get

Property Value

Type: String
The full parsing name of the shell object, if available. The default implementation of this property returns the FileSystemPath property value.

Implements

IShellObjectParsingName
Remarks
This value is usually the same as FileSystemPath, except that it can also return a special syntax to identify special shell objects.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.RelativeParsingName Property

ShellObjectWrapperRelativeParsingName Property

Gets the parent-relative parsing name of the shell object, if available.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string RelativeParsingName { get; }
Public Overrides ReadOnly Property RelativeParsingName As String
    Get

Property Value

Type: String
The parent-relative parsing name of the shell object, if available.

Implements

IShellObjectRelativeParsingName
Remarks
This value is usually the same as Name, except that it can also return a special syntax to identify special shell objects.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.SmallIcon Property

ShellObjectWrapperSmallIcon Property

Gets or sets the small icon.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ImageSource SmallIcon { get; set; }
Public Overrides Property SmallIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The small icon.

Implements

IShellObjectSmallIcon
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.SmallIconOverlay Property

ShellObjectWrapperSmallIconOverlay Property

Gets or sets the small icon overlay.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ImageSource SmallIconOverlay { get; set; }
Public Overrides Property SmallIconOverlay As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The small icon overlay.

Implements

IShellObjectSmallIconOverlay
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.SortOrder Property

ShellObjectWrapperSortOrder Property

Gets or sets a numeric sort order for sorting the shell object within other shell objects.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int SortOrder { get; set; }
Public Overrides Property SortOrder As Integer
    Get
    Set

Property Value

Type: Int32
A numeric sort order for sorting the shell object within other shell objects. The default value is 0.

Implements

IShellObjectSortOrder
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.SpecialFolderKind Property

ShellObjectWrapperSpecialFolderKind Property

Gets a SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override SpecialFolderKind SpecialFolderKind { get; }
Public Overrides ReadOnly Property SpecialFolderKind As SpecialFolderKind
    Get

Property Value

Type: SpecialFolderKind
A SpecialFolderKind that specifies kind of special folder represented by this shell object, if applicable. The default implementation of this property returns None.

Implements

IShellObjectSpecialFolderKind
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.ToolTip Property

ShellObjectWrapperToolTip Property

Gets or sets the tool-tip object that is displayed for this shell object in the user interface (UI).

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ToolTip { get; set; }
Public Overrides Property ToolTip As Object
    Get
    Set

Property Value

Type: Object
The tool-tip object.

Implements

IShellObjectToolTip
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.WrappedShellObject Property

ShellObjectWrapperWrappedShellObject Property

Gets the IShellObject that is wrapped by this class.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IShellObject WrappedShellObject { get; }
Public ReadOnly Property WrappedShellObject As IShellObject
    Get

Property Value

Type: IShellObject
The IShellObject that is wrapped by this class.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper Methods

The ShellObjectWrapper type exposes the following members.

Methods
 | Name | Description
Public method | CreateChildFolder | Creates a child folder with the specified name. (Overrides ShellObjectBaseCreateChildFolder(String).)
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObjectBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides ShellObjectBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObjectBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ShellObjectBase.)
Protected method | RaiseChangedEvent | Raises the Changed event. (Inherited from ShellObjectBase.)
Protected method | RaisePropertyChangedEvent | Raises the PropertyChanged event. (Inherited from ShellObjectBase.)
Public method | RefreshChildren | Refreshes the Children collection. (Overrides ShellObjectBaseRefreshChildren.)
Public method | StartWatching | Starts watching the shell object's tree hierarchy for change notifications. (Overrides ShellObjectBaseStartWatching.)
Public method | StopWatching | Stops watching the shell object's tree hierarchy for change notifications. (Overrides ShellObjectBaseStopWatching.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ShellObjectBase.)
Top
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.CreateChildFolder Method

ShellObjectWrapperCreateChildFolder Method

Creates a child folder with the specified name.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CreateChildFolder(
    string name
)
Public Overrides Function CreateChildFolder (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the child folder.

Return Value

Type: Boolean
true if the child folder was created; otherwise, false.

Implements

IShellObjectCreateChildFolder(String)
Remarks
Only shell folders can create child folders. The default implementation of this method does nothing and returns false.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.Dispose Method

ShellObjectWrapperDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObjectBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides ShellObjectBaseDispose(Boolean).)
Top
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.Dispose Method (Boolean)

ShellObjectWrapperDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

ShellObjectWrapper Class
Dispose Overload
ActiproSoftware.Shell Namespace


ShellObjectWrapper.RefreshChildren Method

ShellObjectWrapperRefreshChildren Method

Refreshes the Children collection.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void RefreshChildren()
Public Overrides Sub RefreshChildren

Implements

IShellObjectRefreshChildren
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.StartWatching Method

ShellObjectWrapperStartWatching Method

Starts watching the shell object's tree hierarchy for change notifications.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool StartWatching()
Public Overrides Function StartWatching As Boolean

Return Value

Type: Boolean
true if the shell object is watching its tree hierarchy; otherwise, false.

Implements

IShellObjectStartWatching
Remarks
The default implementation of this method does nothing, and returns false.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper.StopWatching Method

ShellObjectWrapperStopWatching Method

Stops watching the shell object's tree hierarchy for change notifications.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void StopWatching()
Public Overrides Sub StopWatching

Implements

IShellObjectStopWatching
Remarks
The default implementation of this method does nothing.
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellObjectWrapper Events

The ShellObjectWrapper type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the shell object has changed. (Inherited from ShellObjectBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ShellObjectBase.)
Top
See Also

Reference

ShellObjectWrapper Class
ActiproSoftware.Shell Namespace


ShellPropertyCollection Class

Implements a collection of IShellProperty objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IShellProperty
System.Collections.ObjectModelObservableCollection IShellProperty
ActiproSoftware.ShellShellPropertyCollection

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ShellPropertyCollection : ObservableCollection<IShellProperty>
Public Class ShellPropertyCollection
    Inherits ObservableCollection(Of IShellProperty)

The ShellPropertyCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ShellPropertyCollection | Initializes a new instance of the ShellPropertyCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IShellProperty .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection IShellProperty .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IShellProperty .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IShellProperty .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection IShellProperty .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection IShellProperty .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IShellProperty .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection IShellProperty .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IShellProperty .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IShellProperty .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IShellProperty .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IShellProperty .)
Public method | IndexOfKey | Returns the index of the property with the specified key.
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IShellProperty .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection IShellProperty .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IShellProperty .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IShellProperty .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection IShellProperty .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection IShellProperty .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IShellProperty .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IShellProperty .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection IShellProperty .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection IShellProperty .)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection IShellProperty .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection IShellProperty .)
Top
See Also

Reference

ActiproSoftware.Shell Namespace


ShellPropertyCollection Constructor

Initializes a new instance of the ShellPropertyCollection class

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ShellPropertyCollection()
Public Sub New
See Also

Reference

ShellPropertyCollection Class
ActiproSoftware.Shell Namespace


ShellPropertyCollection Properties

The ShellPropertyCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IShellProperty .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection IShellProperty .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IShellProperty .)
Top
See Also

Reference

ShellPropertyCollection Class
ActiproSoftware.Shell Namespace


ShellPropertyCollection Methods

The ShellPropertyCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IShellProperty .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection IShellProperty .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection IShellProperty .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IShellProperty .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection IShellProperty .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IShellProperty .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IShellProperty .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IShellProperty .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IShellProperty .)
Public method | IndexOfKey | Returns the index of the property with the specified key.
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IShellProperty .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection IShellProperty .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IShellProperty .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IShellProperty .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection IShellProperty .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection IShellProperty .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IShellProperty .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IShellProperty .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection IShellProperty .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection IShellProperty .)
Top
See Also

Reference

ShellPropertyCollection Class
ActiproSoftware.Shell Namespace


ShellPropertyCollection.IndexOfKey Method

ShellPropertyCollectionIndexOfKey Method

Returns the index of the property with the specified key.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOfKey(
    Object key
)
Public Function IndexOfKey (
    key As Object
) As Integer

Parameters

key
Type: SystemObject
The key for which to search.

Return Value

Type: Int32
The index of the property with the specified key.
See Also

Reference

ShellPropertyCollection Class
ActiproSoftware.Shell Namespace


ShellPropertyCollection Events

The ShellPropertyCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection IShellProperty .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection IShellProperty .)
Top
See Also

Reference

ShellPropertyCollection Class
ActiproSoftware.Shell Namespace


ShellPropertyRequestKind Enumeration

Specifies the kind of IShellProperty objects to request.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ShellPropertyRequestKind
Public Enumeration ShellPropertyRequestKind
Members
Member name | Value | Description
DefaultColumns | 0 | The properties that make up the default columns in a details list.
AllColumns | 1 | The properties that make up all possible columns in a details list.
See Also

Reference

ActiproSoftware.Shell Namespace


SpecialFolderKind Enumeration

Specifies the kind of special Windows shell folder.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SpecialFolderKind
Public Enumeration SpecialFolderKind
Members
Member name | Value | Description
None | 0 | No special folder.
Default | 1 | Special-cased folder whose contents are similar to Windows Explorer's roots.
CameraRoll | 2 | Camera roll.
CameraRollLibrary | 3 | Camera roll library.
Captures | 4 | Captures.
Computer | 5 | Computer (a.k.a. My Computer).
Desktop | 6 | The desktop, which is the computer root.
Documents | 7 | Documents (a.k.a. My Documents).
DocumentsLibrary | 8 | Documents library.
Downloads | 9 | Downloads (a.k.a. My Downloads).
HomeGroup | 10 | Home group.
Libraries | 11 | Libraries.
LocalDocuments | 12 | Local documents.
LocalDownloads | 13 | Local downloads.
LocalMusic | 14 | Local music.
LocalPictures | 15 | Local pictures.
LocalVideos | 16 | Local videos.
Music | 17 | Music (a.k.a. My Music).
MusicLibrary | 18 | Music library.
Network | 19 | Network.
OneDrive | 20 | OneDrive.
Pictures | 21 | Pictures (a.k.a. My Pictures).
PicturesLibrary | 22 | Pictures library.
Printers | 23 | Printers.
Public | 24 | Public folders.
PublicDesktop | 25 | Public desktop.
PublicDocuments | 26 | Public documents.
PublicDownloads | 27 | Public downloads.
PublicMusic | 28 | Public music.
PublicPictures | 29 | Public pictures.
PublicVideos | 30 | Public videos.
QuickAccess | 31 | Quick access.
Recent | 32 | Recent.
RecordedCalls | 33 | Recorded calls.
RecycleBin | 34 | Recycle bin.
SavedPictures | 35 | Saved pictures.
SavedPicturesLibrary | 36 | Saved pictures library.
Screenshots | 37 | Screenshots.
ThisPCDesktop | 38 | This PC's desktop.
ThreeDObjects | 39 | 3D objects.
UsersFiles | 40 | User files.
UsersLibraries | 41 | User libraries.
Videos | 42 | Videos (a.k.a. My Videos).
VideosLibrary | 43 | Videos library.
See Also

Reference

ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand Class

Represents an ICommand to be used on a menu item for one or more Windows shell objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.ShellWindowsShellMenuItemCommand

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WindowsShellMenuItemCommand : ICommand
Public Class WindowsShellMenuItemCommand
    Implements ICommand

The WindowsShellMenuItemCommand type exposes the following members.

Properties
 | Name | Description
Public property | TargetViewModels | Gets the collection of target ShellObjectViewModel objects that are affected by the command.
Public property | Verb | Gets the string verb related to the command, if known.
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the command can execute.
Public method | Execute | Executes the command.
Public method | RaiseCanExecuteChanged | Raises the CanExecuteChanged event.
Top
Events
 | Name | Description
Public event | CanExecuteChanged | Occurs after the can-execute state has changed.
Top
Remarks
The command parameter is of type UInt32, which passes the related Windows shell context menu command ID.
See Also

Reference

ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand Properties

The WindowsShellMenuItemCommand type exposes the following members.

Properties
 | Name | Description
Public property | TargetViewModels | Gets the collection of target ShellObjectViewModel objects that are affected by the command.
Public property | Verb | Gets the string verb related to the command, if known.
Top
See Also

Reference

WindowsShellMenuItemCommand Class
ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand.TargetViewModels Property

WindowsShellMenuItemCommandTargetViewModels Property

Gets the collection of target ShellObjectViewModel objects that are affected by the command.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ShellObjectViewModel> TargetViewModels { get; }
Public ReadOnly Property TargetViewModels As IList(Of ShellObjectViewModel)
    Get

Property Value

Type: IList ShellObjectViewModel
The collection of target ShellObjectViewModel objects that are affected by the command.
See Also

Reference

WindowsShellMenuItemCommand Class
ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand.Verb Property

WindowsShellMenuItemCommandVerb Property

Gets the string verb related to the command, if known.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Verb { get; }
Public ReadOnly Property Verb As String
    Get

Property Value

Type: String
The string verb related to the command, if known.
See Also

Reference

WindowsShellMenuItemCommand Class
ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand Methods

The WindowsShellMenuItemCommand type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the command can execute.
Public method | Execute | Executes the command.
Public method | RaiseCanExecuteChanged | Raises the CanExecuteChanged event.
Top
See Also

Reference

WindowsShellMenuItemCommand Class
ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand.CanExecute Method

WindowsShellMenuItemCommandCanExecute Method

Returns whether the command can execute.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanExecute(
    Object parameter
)
Public Function CanExecute (
    parameter As Object
) As Boolean

Parameters

parameter
Type: SystemObject
The parameter to examine.

Return Value

Type: Boolean
true if the command can execute; otherwise, false.

Implements

ICommandCanExecute(Object)
See Also

Reference

WindowsShellMenuItemCommand Class
ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand.Execute Method

WindowsShellMenuItemCommandExecute Method

Executes the command.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Execute(
    Object parameter
)
Public Sub Execute (
    parameter As Object
)

Parameters

parameter
Type: SystemObject
The parameter to examine.

Implements

ICommandExecute(Object)
See Also

Reference

WindowsShellMenuItemCommand Class
ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand.RaiseCanExecuteChanged Method

WindowsShellMenuItemCommandRaiseCanExecuteChanged Method

Raises the CanExecuteChanged event.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RaiseCanExecuteChanged()
Public Sub RaiseCanExecuteChanged
See Also

Reference

WindowsShellMenuItemCommand Class
ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand Events

The WindowsShellMenuItemCommand type exposes the following members.

Events
 | Name | Description
Public event | CanExecuteChanged | Occurs after the can-execute state has changed.
Top
See Also

Reference

WindowsShellMenuItemCommand Class
ActiproSoftware.Shell Namespace


WindowsShellMenuItemCommand.CanExecuteChanged Event

WindowsShellMenuItemCommandCanExecuteChanged Event

Occurs after the can-execute state has changed.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler CanExecuteChanged
Public Event CanExecuteChanged As EventHandler

Value

Type: SystemEventHandler

Implements

ICommandCanExecuteChanged
See Also

Reference

WindowsShellMenuItemCommand Class
ActiproSoftware.Shell Namespace


WindowsShellService Class

A IShellService implementation for the Windows shell.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsDisposableObjectBase
ActiproSoftware.ShellWindowsShellService

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WindowsShellService : DisposableObjectBase,
    IShellService
Public Class WindowsShellService
    Inherits DisposableObjectBase
    Implements IShellService

The WindowsShellService type exposes the following members.

Constructors
 | Name | Description
Public method | WindowsShellService | Initializes a new instance of the WindowsShellService class
Top
Methods
 | Name | Description
Public method | CompareObjectsUsingProperty | Compares two IShellObject instances using the specified IShellProperty.
Public method | CreateObjectChildren | Creates the child IShellObject collection for the specified parent IShellObject.
Public method | CreateObjectForParsingName | Creates the IShellObject for the specified full parsing name (commonly the same as the file system path).
Public method | CreateProperties | Creates a collection of IShellProperty objects.
Public method | CreateSpecialFolder | Creates the IShellObject for the specified special folder kind.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObjectBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObjectBase.)
Public method | GetFullPath | Returns the full path of the specified IShellObject.
Public method | GetPropertyValue | Returns the property value on the specified IShellObject.
Top
See Also

Reference

ActiproSoftware.Shell Namespace


WindowsShellService Constructor

Initializes a new instance of the WindowsShellService class

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WindowsShellService()
Public Sub New
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


WindowsShellService Methods

The WindowsShellService type exposes the following members.

Methods
 | Name | Description
Public method | CompareObjectsUsingProperty | Compares two IShellObject instances using the specified IShellProperty.
Public method | CreateObjectChildren | Creates the child IShellObject collection for the specified parent IShellObject.
Public method | CreateObjectForParsingName | Creates the IShellObject for the specified full parsing name (commonly the same as the file system path).
Public method | CreateProperties | Creates a collection of IShellProperty objects.
Public method | CreateSpecialFolder | Creates the IShellObject for the specified special folder kind.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObjectBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObjectBase.)
Public method | GetFullPath | Returns the full path of the specified IShellObject.
Public method | GetPropertyValue | Returns the property value on the specified IShellObject.
Top
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


WindowsShellService.CompareObjectsUsingProperty Method

WindowsShellServiceCompareObjectsUsingProperty Method

Compares two IShellObject instances using the specified IShellProperty.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual int CompareObjectsUsingProperty(
    IShellObject shellObject1,
    IShellObject shellObject2,
    IShellProperty shellProperty
)
Public Overridable Function CompareObjectsUsingProperty (
    shellObject1 As IShellObject,
    shellObject2 As IShellObject,
    shellProperty As IShellProperty
) As Integer

Parameters

shellObject1
Type: ActiproSoftware.ShellIShellObject
The first IShellObject.
shellObject2
Type: ActiproSoftware.ShellIShellObject
The second IShellObject.
shellProperty
Type: ActiproSoftware.ShellIShellProperty
The IShellProperty to use for comparison.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.

Implements

IShellServiceCompareObjectsUsingProperty(IShellObject, IShellObject, IShellProperty)
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


WindowsShellService.CreateObjectChildren Method

WindowsShellServiceCreateObjectChildren Method

Creates the child IShellObject collection for the specified parent IShellObject.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IList<IShellObject> CreateObjectChildren(
    IShellObject parentShellObject
)
Public Overridable Function CreateObjectChildren (
    parentShellObject As IShellObject
) As IList(Of IShellObject)

Parameters

parentShellObject
Type: ActiproSoftware.ShellIShellObject
The parent IShellObject to examine.

Return Value

Type: IList IShellObject
The child IShellObject collection for the specified parent IShellObject.

Implements

IShellServiceCreateObjectChildren(IShellObject)
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


WindowsShellService.CreateObjectForParsingName Method

WindowsShellServiceCreateObjectForParsingName Method

Creates the IShellObject for the specified full parsing name (commonly the same as the file system path).

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IShellObject CreateObjectForParsingName(
    string path
)
Public Overridable Function CreateObjectForParsingName (
    path As String
) As IShellObject

Parameters

path
Type: SystemString
The parsing name to examine.

Return Value

Type: IShellObject
The IShellObject for the specified full parsing name.

Implements

IShellServiceCreateObjectForParsingName(String)
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


WindowsShellService.CreateProperties Method

WindowsShellServiceCreateProperties Method

Creates a collection of IShellProperty objects.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual ShellPropertyCollection CreateProperties(
    IList<IShellObject> shellObjects,
    ShellPropertyRequestKind kind
)
Public Overridable Function CreateProperties (
    shellObjects As IList(Of IShellObject),
    kind As ShellPropertyRequestKind
) As ShellPropertyCollection

Parameters

shellObjects
Type: System.Collections.GenericIList IShellObject
One or more IShellObject objects to examine.
kind
Type: ActiproSoftware.ShellShellPropertyRequestKind
The kind of properties to request.

Return Value

Type: ShellPropertyCollection
A ShellPropertyCollection that contains the results.

Implements

IShellServiceCreateProperties(IListIShellObject, ShellPropertyRequestKind)
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


WindowsShellService.CreateSpecialFolder Method

WindowsShellServiceCreateSpecialFolder Method

Creates the IShellObject for the specified special folder kind.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IShellObject CreateSpecialFolder(
    SpecialFolderKind kind
)
Public Overridable Function CreateSpecialFolder (
    kind As SpecialFolderKind
) As IShellObject

Parameters

kind
Type: ActiproSoftware.ShellSpecialFolderKind
A SpecialFolderKind that indicates the special folder kind.

Return Value

Type: IShellObject
The IShellObject for the specified special folder kind.
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


WindowsShellService.Dispose Method

WindowsShellServiceDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObjectBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectBaseDispose(Boolean).)
Top
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


WindowsShellService.Dispose Method (Boolean)

WindowsShellServiceDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

WindowsShellService Class
Dispose Overload
ActiproSoftware.Shell Namespace


WindowsShellService.GetFullPath Method

WindowsShellServiceGetFullPath Method

Returns the full path of the specified IShellObject.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string GetFullPath(
    IShellObject shellObject,
    string pathSeparator
)
Public Overridable Function GetFullPath (
    shellObject As IShellObject,
    pathSeparator As String
) As String

Parameters

shellObject
Type: ActiproSoftware.ShellIShellObject
The IShellObject to examine.
pathSeparator
Type: SystemString
The path separator.

Return Value

Type: String
The full path of the specified IShellObject.

Implements

IShellServiceGetFullPath(IShellObject, String)
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


WindowsShellService.GetPropertyValue Method

WindowsShellServiceGetPropertyValue Method

Returns the property value on the specified IShellObject.

Namespace: ActiproSoftware.Shell
Assembly: ActiproSoftware.Shell.Wpf (in ActiproSoftware.Shell.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Object GetPropertyValue(
    IShellObject shellObject,
    IShellProperty shellProperty
)
Public Overridable Function GetPropertyValue (
    shellObject As IShellObject,
    shellProperty As IShellProperty
) As Object

Parameters

shellObject
Type: ActiproSoftware.ShellIShellObject
The IShellObject to examine.
shellProperty
Type: ActiproSoftware.ShellIShellProperty
The IShellProperty whose value should be returned.

Return Value

Type: Object
The property value on the specified IShellObject.

Implements

IShellServiceGetPropertyValue(IShellObject, IShellProperty)
See Also

Reference

WindowsShellService Class
ActiproSoftware.Shell Namespace


ActiproSoftware.Text Namespace

Contains types related to text.
Classes
 | Class | Description
Public class | ClassificationTypes | Provides access to the built-in IClassificationType instances.
Public class | NormalizedTextSnapshotRangeCollection | Represents a read-only normalized text snapshot range collection.
Public class | SyntaxLanguageChangedEventArgs | Event arguments for the ICodeDocument.LanguageChanged event.
Public class | SyntaxLanguageExtensions | Contains extension methods that make it easier to work with ISyntaxLanguage objects.
Public class | TextChangeTypes | Provides access to the built-in ITextChangeType instances, that indicate the type of ITextChange made.
Public class | TextSnapshotChangedEventArgs | Event arguments for the ITextDocument.TextChanged event.
Public class | TextSnapshotChangingEventArgs | Event arguments for the ITextDocument.TextChanging event.
Public class | TextSnapshotRangeEventArgs | Event arguments used when a change notification is needed for a TextSnapshotRange.
Public class | TextSnapshotReaderOptions | Represents options that are applied to an ITextSnapshotReader.
Structures
 | Structure | Description
Public structure | TextPosition | Represents an ordered pair of zero-based line and character index values that defines a position within the lines of an ITextSnapshot.
Public structure | TextPositionRange | Represents a range of two TextPosition values within the lines of an ITextSnapshot.
Public structure | TextRange | Represents a zero-based range of two offset values within a text document.
Public structure | TextSnapshotOffset | Represents a zero-based offset value within a certain ITextSnapshot.
Public structure | TextSnapshotRange | Represents a zero-based range of two normalized offset values within a certain ITextSnapshot.
Interfaces
 | Interface | Description
Public interface | IClassificationType | Provides the base requirements for an object that represents a classification type.
Public interface | IClassificationTypeRegistry | Provides the base requirements for an object that provides a registry of IClassificationType data.
Public interface | ICodeDocument | Provides the base requirements for a text document with some advanced features that relate to syntax highlighting and code parsing.
Public interface | ICodeDocumentLifecycleEventSink | Provides the base requirements for an object that can be notified of when an ICodeDocument becomes associated and disassociated with a language, via events such as a language change.
Public interface | ICodeDocumentPropertyChangeEventSink | Provides the base requirements for an object that can be notified of when an ICodeDocument's properties, such as ParseData or FileName, are changed.
Public interface | IEditorDocument | Provides the base requirements for a code document that has advanced functionality when edited in a code editor.
Public interface | IExampleTextProvider | Provides the base requirements for an object that returns example text, which can be displayed in an application to show how a language's code snippet is syntax-highlighted.
Public interface | IIdProvider | Provides the base requirements for a class that provides ID's.
Public interface | IIndexedTextRangeProviderCollection | Provides the base requirements for a collection of ITextRangeProvider objects.
Public interface | ILineCommenter | Provides the base requirements for an object that can comment and uncomment lines for a particular language.
Public interface | ISyntaxLanguage | Provides the base requirements for a syntax language that provides parsing and other functionality for a text document via registered services.
Public interface | ITextBufferReader | Provides the base requirements for an object that reads characters from a fixed text buffer.
Public interface | ITextChange | Provides the base requirements for a text change, which contains one or more ITextChangeOperation objects.
Public interface | ITextChangeOperation | Provides the base requirements for a single replace operations within a text change.
Public interface | ITextChangeOptions | Provides the base requirements for options that are applied to an ITextChange.
Public interface | ITextChangeRangedOperation | Provides the base requirements for a single replace operations within a text change, but without storing the actual text inserted/deleted.
Public interface | ITextChangeType | Provides the base requirements for an object that indicates the type of change made by an ITextChange.
Public interface | ITextDocument | Provides the base requirements for a text document that provides access to the ITextSnapshot (via CurrentSnapshot) that contains the current text of the document, and allows for text modification.
Public interface | ITextFormatter | Provides the base requirements of a language formatter that can adjust the whitespace layout of text for better readability.
Public interface | ITextPositionRangeCollection | Provides the base requirements for a sorted TextPositionRange collection, with one of the entries marked as primary.
Public interface | ITextPositionRangeProvider | Provides the base requirements for an object that has range of two TextPosition values within a text document.
Public interface | ITextRangeProvider | Provides the base requirements for an object that has range of two offset values within a text document.
Public interface | ITextSnapshot | Provides the base requirements for an immutable snapshot of an ITextDocument for a certain ITextVersion of that document.
Public interface | ITextSnapshotLine | Provides the base requirements for a line in an ITextSnapshot.
Public interface | ITextSnapshotLineCollection | Encapsulates a collection of ITextSnapshotLine objects.
Public interface | ITextSnapshotReader | Provides the base requirements for an object that reads through characters and tokens from an ITextSnapshot.
Public interface | ITextSnapshotReaderOptions | Provides the base requirements for options that are applied to an ITextSnapshotReader.
Public interface | ITextStatistic | Provides the base requirements for a text statistic that is returned by an ITextStatistics.
Public interface | ITextStatistics | Provides the base requirements for a class that contains numerous statistics such as line, word, character counts, and readability scores for text.
Public interface | ITextStatisticsFactory | Provides the base requirements for a factory capable of creating ITextStatistics objects.
Public interface | ITextVersion | Provides the base requirements for a version of an ITextDocument.
Public interface | ITextVersionRange | Provides the base requirements for a zero-based range of two normalized offset values within a text document that can be translated from one version of the document to another.
Public interface | IWordBreakFinder | Provides the base requirements for an object that finds word breaks within an ITextSnapshot.
Enumerations
 | Enumeration | Description
Public enumeration | CaseSensitivity | Represents the type of case sensitivity to apply.
Public enumeration | CharacterCasing | Specifies the target case of text characters.
Public enumeration | LineTerminator | Specifies a type of line terminator.
Public enumeration | TextChangeOffsetDelta | Specifies how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public enumeration | TextFormatMode | Specifies whether to format text over an entire snapshot or only for specified ranges.
Public enumeration | TextOffsetTrackingMode | Specifies how a text offset is updated by text change operations that occur around it.
Public enumeration | TextRangeTrackingModes | Specifies how a text range is updated by text change operations that occur at its edges.
Public enumeration | TextScanDirection | Specifies a direction in which text will be scanned.
Public enumeration | WhitespaceTrimModes | Specifies the modes by which whitespace is trimmed.


CaseSensitivity Enumeration

Represents the type of case sensitivity to apply.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CaseSensitivity
Public Enumeration CaseSensitivity
Members
Member name | Value | Description
Sensitive | 0 | Case sensitive - exact letter case is matched.
Insensitive | 1 | Case insensitive - upper and lower case of a letter is matched.
AutoCorrect | 2 | Treated the same as Insensitive however the text is converted to the exact pattern if not already equal to it. This is useful for languages like VB.NET where keywords should be forced to be certain combinations of mixed case letters.
See Also

Reference

ActiproSoftware.Text Namespace


CharacterCasing Enumeration

Specifies the target case of text characters.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CharacterCasing
Public Enumeration CharacterCasing
Members
Member name | Value | Description
Normal | 0 | The case of characters is left unchanged.
Upper | 1 | Converts all characters to uppercase.
Lower | 2 | Converts all characters to lowercase.
See Also

Reference

ActiproSoftware.Text Namespace


ClassificationTypes Class

Provides access to the built-in IClassificationType instances.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextClassificationTypes

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class ClassificationTypes
Public NotInheritable Class ClassificationTypes

The ClassificationTypes type exposes the following members.

Properties
Name | Description
Comment | Gets the IClassificationType for a general comment.
CompilerError | Gets the IClassificationType for a compiler error.
Identifier | Gets the IClassificationType for a general identifier.
Keyword | Gets the IClassificationType for a general keyword.
Number | Gets the IClassificationType for a general number.
OtherError | Gets the IClassificationType for an other error.
PreprocessorKeyword | Gets the IClassificationType for a general preprocessor keyword.
ReadOnlyRegion | Gets the IClassificationType for a read-only region.
String | Gets the IClassificationType for a general string.
SyntaxError | Gets the IClassificationType for a syntax error.
Warning | Gets the IClassificationType for a warning.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ClassificationTypes Properties

The ClassificationTypes type exposes the following members.

Properties
Name | Description
Comment | Gets the IClassificationType for a general comment.
CompilerError | Gets the IClassificationType for a compiler error.
Identifier | Gets the IClassificationType for a general identifier.
Keyword | Gets the IClassificationType for a general keyword.
Number | Gets the IClassificationType for a general number.
OtherError | Gets the IClassificationType for an other error.
PreprocessorKeyword | Gets the IClassificationType for a general preprocessor keyword.
ReadOnlyRegion | Gets the IClassificationType for a read-only region.
String | Gets the IClassificationType for a general string.
SyntaxError | Gets the IClassificationType for a syntax error.
Warning | Gets the IClassificationType for a warning.
Top
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Comment Property

ClassificationTypesComment Property

Gets the IClassificationType for a general comment.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType Comment { get; }
Public Shared ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general comment.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.CompilerError Property

ClassificationTypesCompilerError Property

Gets the IClassificationType for a compiler error.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType CompilerError { get; }
Public Shared ReadOnly Property CompilerError As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a compiler error.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Identifier Property

ClassificationTypesIdentifier Property

Gets the IClassificationType for a general identifier.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType Identifier { get; }
Public Shared ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general identifier.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Keyword Property

ClassificationTypesKeyword Property

Gets the IClassificationType for a general keyword.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType Keyword { get; }
Public Shared ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general keyword.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Number Property

ClassificationTypesNumber Property

Gets the IClassificationType for a general number.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType Number { get; }
Public Shared ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general number.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.OtherError Property

ClassificationTypesOtherError Property

Gets the IClassificationType for an other error.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType OtherError { get; }
Public Shared ReadOnly Property OtherError As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for an other error.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.PreprocessorKeyword Property

ClassificationTypesPreprocessorKeyword Property

Gets the IClassificationType for a general preprocessor keyword.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType PreprocessorKeyword { get; }
Public Shared ReadOnly Property PreprocessorKeyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general preprocessor keyword.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.ReadOnlyRegion Property

ClassificationTypesReadOnlyRegion Property

Gets the IClassificationType for a read-only region.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType ReadOnlyRegion { get; }
Public Shared ReadOnly Property ReadOnlyRegion As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a read-only region.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.String Property

ClassificationTypesString Property

Gets the IClassificationType for a general string.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType String { get; }
Public Shared ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general string.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.SyntaxError Property

ClassificationTypesSyntaxError Property

Gets the IClassificationType for a syntax error.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType SyntaxError { get; }
Public Shared ReadOnly Property SyntaxError As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a syntax error.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Warning Property

ClassificationTypesWarning Property

Gets the IClassificationType for a warning.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IClassificationType Warning { get; }
Public Shared ReadOnly Property Warning As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a warning.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


IClassificationType Interface

Provides the base requirements for an object that represents a classification type.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IClassificationType : IKeyedObject
Public Interface IClassificationType
    Inherits IKeyedObject

The IClassificationType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the classification type, which is displayed in the user interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationClassificationType


IClassificationType Properties

The IClassificationType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the classification type, which is displayed in the user interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

IClassificationType Interface
ActiproSoftware.Text Namespace


IClassificationType.Description Property

IClassificationTypeDescription Property

Gets the description of the classification type, which is displayed in the user interface.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the classification type, which is displayed in the user interface.
See Also

Reference

IClassificationType Interface
ActiproSoftware.Text Namespace


IClassificationTypeRegistry Interface

Provides the base requirements for an object that provides a registry of IClassificationType data.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IClassificationTypeRegistry : IEnumerable<IClassificationType>,
    IEnumerable
Public Interface IClassificationTypeRegistry
    Inherits IEnumerable(Of IClassificationType), IEnumerable

The IClassificationTypeRegistry type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entries in the registry.
Public property | Item | Gets the IClassificationType with the specified key. [C#] In C#, this property is the indexer for the IClassificationTypeRegistry interface.
Top
Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IClassificationType .)
Top
See Also

Reference

ActiproSoftware.Text Namespace


IClassificationTypeRegistry Properties

The IClassificationTypeRegistry type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entries in the registry.
Public property | Item | Gets the IClassificationType with the specified key. [C#] In C#, this property is the indexer for the IClassificationTypeRegistry interface.
Top
See Also

Reference

IClassificationTypeRegistry Interface
ActiproSoftware.Text Namespace


IClassificationTypeRegistry.Count Property

IClassificationTypeRegistryCount Property

Gets the number of entries in the registry.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of entries in the registry.
See Also

Reference

IClassificationTypeRegistry Interface
ActiproSoftware.Text Namespace


IClassificationTypeRegistry.Item Property

IClassificationTypeRegistryItem Property

Gets the IClassificationType with the specified key.

[C#] In C#, this property is the indexer for the IClassificationTypeRegistry interface.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType this[
    string key
] { get; }
ReadOnly Default Property Item (
    key As String
) As IClassificationType
    Get

Parameters

key
Type: SystemString
The key of the IClassificationType to return.

Property Value

Type: IClassificationType
The IClassificationType with the specified key.
See Also

Reference

IClassificationTypeRegistry Interface
ActiproSoftware.Text Namespace


IClassificationTypeRegistry Methods

The IClassificationTypeRegistry type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IClassificationType .)
Top
See Also

Reference

IClassificationTypeRegistry Interface
ActiproSoftware.Text Namespace


ICodeDocument Interface

Provides the base requirements for a text document with some advanced features that relate to syntax highlighting and code parsing.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICodeDocument : IParseTarget,
    ITextDocument
Public Interface ICodeDocument
    Inherits IParseTarget, ITextDocument

The ICodeDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from ITextDocument.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from ITextDocument.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from ITextDocument.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from ITextDocument.)
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from ITextDocument.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from ITextDocument.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded.
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from ITextDocument.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from ITextDocument.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from IParseTarget.)
Top
Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level.
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from ITextDocument.)
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding. (Inherited from ITextDocument.)
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding. (Inherited from ITextDocument.)
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result. (Inherited from IParseTarget.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher.
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file. (Inherited from ITextDocument.)
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding. (Inherited from ITextDocument.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from ITextDocument.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from ITextDocument.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from ITextDocument.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from ITextDocument.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed.
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from ITextDocument.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from ITextDocument.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from ITextDocument.)
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationCodeDocument


ICodeDocument Properties

The ICodeDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from ITextDocument.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from ITextDocument.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from ITextDocument.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from ITextDocument.)
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from ITextDocument.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from ITextDocument.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded.
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from ITextDocument.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from ITextDocument.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from IParseTarget.)
Top
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.Language Property

ICodeDocumentLanguage Property

Gets or sets the ISyntaxLanguage that is currently loaded.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISyntaxLanguage Language { get; set; }
Property Language As ISyntaxLanguage
    Get
    Set

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that is currently loaded.
Remarks
The default value is a plain text language.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.LanguageData Property

ICodeDocumentLanguageData Property

Gets or sets an object that specifies document-specific data for the Language that is loaded.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object LanguageData { get; set; }
Property LanguageData As Object
    Get
    Set

Property Value

Type: Object
An object that specifies document-specific data for the Language that is loaded.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.ParseData Property

ICodeDocumentParseData Property

Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseData ParseData { get; set; }
Property ParseData As IParseData
    Get
    Set

Property Value

Type: IParseData
The syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.Properties Property

ICodeDocumentProperties Property

Gets the dictionary containing custom properties for this object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PropertyDictionary Properties { get; }
ReadOnly Property Properties As PropertyDictionary
    Get

Property Value

Type: PropertyDictionary
The dictionary containing custom properties for this object.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument Methods

The ICodeDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level.
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from ITextDocument.)
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding. (Inherited from ITextDocument.)
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding. (Inherited from ITextDocument.)
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result. (Inherited from IParseTarget.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher.
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file. (Inherited from ITextDocument.)
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding. (Inherited from ITextDocument.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from ITextDocument.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Top
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.AddLanguageChangedEventHandler Method

ICodeDocumentAddLanguageChangedEventHandler Method

Adds an event handler for the LanguageChanged event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void AddLanguageChangedEventHandler(
    EventHandler<SyntaxLanguageChangedEventArgs> handler,
    EventHandlerPriority priority
)
Sub AddLanguageChangedEventHandler (
    handler As EventHandler(Of SyntaxLanguageChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler SyntaxLanguageChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.CreateTagAggregator(T) Method

ICodeDocumentCreateTagAggregatorT Method

Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITagAggregator<T> CreateTagAggregator<T>()
where T : ITag

Function CreateTagAggregator(Of T As ITag) As ITagAggregator(Of T)

Type Parameters

T
The type of ITag associated with this aggregator.

Return Value

Type: ITagAggregator T
The ITagAggregatorT that was created.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.GetServices(TService) Method

ICodeDocumentGetServicesTService Method

Returns a list of available services of the specified type.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<TService> GetServices<TService>()
where TService : class

Function GetServices(Of TService As Class) As IList(Of TService)

Type Parameters

TService
The type of service.

Return Value

Type: IList TService
The list of available services of the specified type.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.QueueParseRequest Method

ICodeDocumentQueueParseRequest Method

Queues up a parse request for the document with the ambient dispatcher.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void QueueParseRequest()
Sub QueueParseRequest
Remarks
If AmbientParseRequestDispatcherProvider does not provide a dispatcher, the parsing operation is completed immediately in the calling thread.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.RemoveLanguageChangedEventHandler Method

ICodeDocumentRemoveLanguageChangedEventHandler Method

Removes an event handler for the LanguageChanged event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void RemoveLanguageChangedEventHandler(
    EventHandler<SyntaxLanguageChangedEventArgs> handler,
    EventHandlerPriority priority
)
Sub RemoveLanguageChangedEventHandler (
    handler As EventHandler(Of SyntaxLanguageChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler SyntaxLanguageChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument Events

The ICodeDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from ITextDocument.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from ITextDocument.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from ITextDocument.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed.
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from ITextDocument.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from ITextDocument.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from ITextDocument.)
Top
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.LanguageChanged Event

ICodeDocumentLanguageChanged Event

Occurs after the value of the Language property has changed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<SyntaxLanguageChangedEventArgs> LanguageChanged
Event LanguageChanged As EventHandler(Of SyntaxLanguageChangedEventArgs)

Value

Type: SystemEventHandler SyntaxLanguageChangedEventArgs
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.ParseDataChanged Event

ICodeDocumentParseDataChanged Event

Occurs after the value of the ParseData property has changed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<ParseDataPropertyChangedEventArgs> ParseDataChanged
Event ParseDataChanged As EventHandler(Of ParseDataPropertyChangedEventArgs)

Value

Type: SystemEventHandler ParseDataPropertyChangedEventArgs
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocumentLifecycleEventSink Interface

Provides the base requirements for an object that can be notified of when an ICodeDocument becomes associated and disassociated with a language, via events such as a language change.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICodeDocumentLifecycleEventSink
Public Interface ICodeDocumentLifecycleEventSink

The ICodeDocumentLifecycleEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyDocumentAttached | Occurs when the specified ICodeDocument is attached to a language.
Public method | NotifyDocumentDetached | Occurs when the specified ICodeDocument is detached from a language.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.Text Namespace


ICodeDocumentLifecycleEventSink Methods

The ICodeDocumentLifecycleEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyDocumentAttached | Occurs when the specified ICodeDocument is attached to a language.
Public method | NotifyDocumentDetached | Occurs when the specified ICodeDocument is detached from a language.
Top
See Also

Reference

ICodeDocumentLifecycleEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentLifecycleEventSink.NotifyDocumentAttached Method

ICodeDocumentLifecycleEventSinkNotifyDocumentAttached Method

Occurs when the specified ICodeDocument is attached to a language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void NotifyDocumentAttached(
    ICodeDocument document
)
Sub NotifyDocumentAttached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

ICodeDocumentLifecycleEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentLifecycleEventSink.NotifyDocumentDetached Method

ICodeDocumentLifecycleEventSinkNotifyDocumentDetached Method

Occurs when the specified ICodeDocument is detached from a language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void NotifyDocumentDetached(
    ICodeDocument document
)
Sub NotifyDocumentDetached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is detached.
See Also

Reference

ICodeDocumentLifecycleEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentPropertyChangeEventSink Interface

Provides the base requirements for an object that can be notified of when an ICodeDocument's properties, such as ParseData or FileName, are changed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICodeDocumentPropertyChangeEventSink
Public Interface ICodeDocumentPropertyChangeEventSink

The ICodeDocumentPropertyChangeEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyFileNameChanged | Occurs after the value of the FileName property has changed.
Public method | NotifyParseDataChanged | Occurs after the value of the ParseData property has changed.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.Text Namespace


ICodeDocumentPropertyChangeEventSink Methods

The ICodeDocumentPropertyChangeEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyFileNameChanged | Occurs after the value of the FileName property has changed.
Public method | NotifyParseDataChanged | Occurs after the value of the ParseData property has changed.
Top
See Also

Reference

ICodeDocumentPropertyChangeEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentPropertyChangeEventSink.NotifyFileNameChanged Method

ICodeDocumentPropertyChangeEventSinkNotifyFileNameChanged Method

Occurs after the value of the FileName property has changed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void NotifyFileNameChanged(
    ICodeDocument document,
    StringPropertyChangedEventArgs e
)
Sub NotifyFileNameChanged (
    document As ICodeDocument,
    e As StringPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose FileName property is changed.
e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
The StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

ICodeDocumentPropertyChangeEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentPropertyChangeEventSink.NotifyParseDataChanged Method

ICodeDocumentPropertyChangeEventSinkNotifyParseDataChanged Method

Occurs after the value of the ParseData property has changed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void NotifyParseDataChanged(
    ICodeDocument document,
    ParseDataPropertyChangedEventArgs e
)
Sub NotifyParseDataChanged (
    document As ICodeDocument,
    e As ParseDataPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose ParseData property is changed.
e
Type: ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
The ParseDataPropertyChangedEventArgs that contains the event data.
See Also

Reference

ICodeDocumentPropertyChangeEventSink Interface
ActiproSoftware.Text Namespace


IEditorDocument Interface

Provides the base requirements for a code document that has advanced functionality when edited in a code editor.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IEditorDocument : ICodeDocument,
    IParseTarget, ITextDocument
Public Interface IEditorDocument
    Inherits ICodeDocument, IParseTarget, ITextDocument

The IEditorDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from ITextDocument.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from ITextDocument.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from ITextDocument.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from ITextDocument.)
Public property | IndicatorManager | Gets the IIndicatorManager that manages indicators for the document.
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from ITextDocument.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from ITextDocument.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded. (Inherited from ICodeDocument.)
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded. (Inherited from ICodeDocument.)
Public property | LineNumberOrigin | Gets or sets the origin line number to use as the base for the first view line.
Public property | OutliningManager | Gets the IOutliningManager that manages outlining nodes for the document.
Public property | OutliningMode | Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation. (Inherited from ICodeDocument.)
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from ICodeDocument.)
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from ITextDocument.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from ITextDocument.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from IParseTarget.)
Public property | WhitespaceTrimModes | Gets or sets the modes in which whitespace should be automatically trimmed.
Top
Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level. (Inherited from ICodeDocument.)
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document. (Inherited from ICodeDocument.)
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type. (Inherited from ICodeDocument.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from ITextDocument.)
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding. (Inherited from ITextDocument.)
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding. (Inherited from ITextDocument.)
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result. (Inherited from IParseTarget.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher. (Inherited from ICodeDocument.)
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level. (Inherited from ICodeDocument.)
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file. (Inherited from ITextDocument.)
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding. (Inherited from ITextDocument.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from ITextDocument.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from ITextDocument.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from ITextDocument.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from ITextDocument.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed. (Inherited from ICodeDocument.)
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed. (Inherited from ICodeDocument.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from ITextDocument.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from ITextDocument.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from ITextDocument.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


IEditorDocument Properties

The IEditorDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from ITextDocument.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from ITextDocument.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from ITextDocument.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from ITextDocument.)
Public property | IndicatorManager | Gets the IIndicatorManager that manages indicators for the document.
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from ITextDocument.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from ITextDocument.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded. (Inherited from ICodeDocument.)
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded. (Inherited from ICodeDocument.)
Public property | LineNumberOrigin | Gets or sets the origin line number to use as the base for the first view line.
Public property | OutliningManager | Gets the IOutliningManager that manages outlining nodes for the document.
Public property | OutliningMode | Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation. (Inherited from ICodeDocument.)
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from ICodeDocument.)
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from ITextDocument.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from ITextDocument.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from IParseTarget.)
Public property | WhitespaceTrimModes | Gets or sets the modes in which whitespace should be automatically trimmed.
Top
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument.IndicatorManager Property

IEditorDocumentIndicatorManager Property

Gets the IIndicatorManager that manages indicators for the document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IIndicatorManager IndicatorManager { get; }
ReadOnly Property IndicatorManager As IIndicatorManager
    Get

Property Value

Type: IIndicatorManager
The IIndicatorManager that manages indicators for the document.
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument.LineNumberOrigin Property

IEditorDocumentLineNumberOrigin Property

Gets or sets the origin line number to use as the base for the first view line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int LineNumberOrigin { get; set; }
Property LineNumberOrigin As Integer
    Get
    Set

Property Value

Type: Int32
The origin line number to use as the base for the first view line. The default value is 1.
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument.OutliningManager Property

IEditorDocumentOutliningManager Property

Gets the IOutliningManager that manages outlining nodes for the document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IOutliningManager OutliningManager { get; }
ReadOnly Property OutliningManager As IOutliningManager
    Get

Property Value

Type: IOutliningManager
The IOutliningManager that manages outlining nodes for the document.
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument.OutliningMode Property

IEditorDocumentOutliningMode Property

Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
OutliningMode OutliningMode { get; set; }
Property OutliningMode As OutliningMode
    Get
    Set

Property Value

Type: OutliningMode
The OutliningMode for the document that determines what type of code outlining (folding) is supported. The default value is OutliningMode.Default.
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument.WhitespaceTrimModes Property

IEditorDocumentWhitespaceTrimModes Property

Gets or sets the modes in which whitespace should be automatically trimmed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
WhitespaceTrimModes WhitespaceTrimModes { get; set; }
Property WhitespaceTrimModes As WhitespaceTrimModes
    Get
    Set

Property Value

Type: WhitespaceTrimModes
A WhitespaceTrimModes indicating the modes in which whitespace should be automatically trimmed. The default value is None.
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument Methods

The IEditorDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level. (Inherited from ICodeDocument.)
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document. (Inherited from ICodeDocument.)
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type. (Inherited from ICodeDocument.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from ITextDocument.)
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding. (Inherited from ITextDocument.)
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding. (Inherited from ITextDocument.)
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result. (Inherited from IParseTarget.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher. (Inherited from ICodeDocument.)
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level. (Inherited from ICodeDocument.)
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file. (Inherited from ITextDocument.)
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding. (Inherited from ITextDocument.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from ITextDocument.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Top
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument Events

The IEditorDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from ITextDocument.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from ITextDocument.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from ITextDocument.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed. (Inherited from ICodeDocument.)
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed. (Inherited from ICodeDocument.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from ITextDocument.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from ITextDocument.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from ITextDocument.)
Top
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IExampleTextProvider Interface

Provides the base requirements for an object that returns example text, which can be displayed in an application to show how a language's code snippet is syntax-highlighted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IExampleTextProvider
Public Interface IExampleTextProvider

The IExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationExampleTextProvider


IExampleTextProvider Properties

The IExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

IExampleTextProvider Interface
ActiproSoftware.Text Namespace


IExampleTextProvider.ExampleText Property

IExampleTextProviderExampleText Property

Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ExampleText { get; }
ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text.
See Also

Reference

IExampleTextProvider Interface
ActiproSoftware.Text Namespace


IIdProvider Interface

Provides the base requirements for a class that provides ID's.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IIdProvider
Public Interface IIdProvider

The IIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
See Also

Reference

ActiproSoftware.Text Namespace


IIdProvider Properties

The IIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.MaxId Property

IIdProviderMaxId Property

Gets the maximum ID returned by this provider.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int MaxId { get; }
ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum ID returned by this provider.
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.MinId Property

IIdProviderMinId Property

Gets the minimum ID returned by this provider.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int MinId { get; }
ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum ID returned by this provider.
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider Methods

The IIdProvider type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.ContainsId Method

IIdProviderContainsId Method

Returns whether the specified ID value is valid for this ID provider.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ContainsId(
    int id
)
Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.GetDescription Method

IIdProviderGetDescription Method

Returns the actual string representation for the specified ID.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetDescription(
    int id
)
Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The actual string representation for the specified ID.
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.GetKey Method

IIdProviderGetKey Method

Returns the string-based key for the specified ID.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetKey(
    int id
)
Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The string-based key for the specified ID.
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIndexedTextRangeProviderCollection Interface

Provides the base requirements for a collection of ITextRangeProvider objects.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IIndexedTextRangeProviderCollection
Public Interface IIndexedTextRangeProviderCollection

The IIndexedTextRangeProviderCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetCount | Returns the number of ITextRangeProvider objects in the collection.
Public method | GetItem | Returns the ITextRangeProvider at the specified index.
Top
See Also

Reference

ActiproSoftware.Text Namespace


IIndexedTextRangeProviderCollection Methods

The IIndexedTextRangeProviderCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetCount | Returns the number of ITextRangeProvider objects in the collection.
Public method | GetItem | Returns the ITextRangeProvider at the specified index.
Top
See Also

Reference

IIndexedTextRangeProviderCollection Interface
ActiproSoftware.Text Namespace


IIndexedTextRangeProviderCollection.GetCount Method

IIndexedTextRangeProviderCollectionGetCount Method

Returns the number of ITextRangeProvider objects in the collection.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int GetCount()
Function GetCount As Integer

Return Value

Type: Int32
The number of ITextRangeProvider objects in the collection.
See Also

Reference

IIndexedTextRangeProviderCollection Interface
ActiproSoftware.Text Namespace


IIndexedTextRangeProviderCollection.GetItem Method

IIndexedTextRangeProviderCollectionGetItem Method

Returns the ITextRangeProvider at the specified index.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextRangeProvider GetItem(
    int index
)
Function GetItem (
    index As Integer
) As ITextRangeProvider

Parameters

index
Type: SystemInt32
The index of the ITextRangeProvider to return.

Return Value

Type: ITextRangeProvider
The ITextRangeProvider at the specified index.
See Also

Reference

IIndexedTextRangeProviderCollection Interface
ActiproSoftware.Text Namespace


ILineCommenter Interface

Provides the base requirements for an object that can comment and uncomment lines for a particular language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILineCommenter
Public Interface ILineCommenter

The ILineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified position ranges.
Public method | Uncomment | Uncomments the lines of code in the specified position ranges.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationLineBasedLineCommenter
ActiproSoftware.Text.ImplementationRangeLineCommenter


ILineCommenter Methods

The ILineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified position ranges.
Public method | Uncomment | Uncomments the lines of code in the specified position ranges.
Top
See Also

Reference

ILineCommenter Interface
ActiproSoftware.Text Namespace


ILineCommenter.Comment Method

ILineCommenterComment Method

Comments out the lines of code in the specified position ranges.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Comment(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection positionRanges,
    ITextChangeOptions options
)
Sub Comment (
    snapshot As ITextSnapshot,
    positionRanges As ITextPositionRangeCollection,
    options As ITextChangeOptions
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
positionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the position ranges over which to comment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.
See Also

Reference

ILineCommenter Interface
ActiproSoftware.Text Namespace


ILineCommenter.Uncomment Method

ILineCommenterUncomment Method

Uncomments the lines of code in the specified position ranges.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Uncomment(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection positionRanges,
    ITextChangeOptions options
)
Sub Uncomment (
    snapshot As ITextSnapshot,
    positionRanges As ITextPositionRangeCollection,
    options As ITextChangeOptions
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
positionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the position ranges over which to uncomment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.
See Also

Reference

ILineCommenter Interface
ActiproSoftware.Text Namespace


ISyntaxLanguage Interface

Provides the base requirements for a syntax language that provides parsing and other functionality for a text document via registered services.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISyntaxLanguage : IKeyedObject,
    IServiceLocator
Public Interface ISyntaxLanguage
    Inherits IKeyedObject, IServiceLocator

The ISyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from IServiceLocator.)
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLexer | Returns the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetParser | Returns the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetProject | Returns the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | GetProjectAssembly | Returns the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextViewLineNumberProvider | Returns the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlValidator | Returns the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | Parse | Parses text using the specified language's IParser service and returns the IParseData result. (Defined by SyntaxLanguageParsingExtensions.)
Public Extension Method | RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLexer | Registers the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterParser | Registers the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterProject | Registers the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextViewLineNumberProvider | Registers the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlValidator | Registers the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterParser | Unregisters the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterProject | Unregisters the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextViewLineNumberProvider | Unregisters the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationSyntaxLanguage


ISyntaxLanguage Properties

The ISyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from IServiceLocator.)
Top
See Also

Reference

ISyntaxLanguage Interface
ActiproSoftware.Text Namespace


ISyntaxLanguage Methods

The ISyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLexer | Returns the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetParser | Returns the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetProject | Returns the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | GetProjectAssembly | Returns the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextViewLineNumberProvider | Returns the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlValidator | Returns the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | Parse | Parses text using the specified language's IParser service and returns the IParseData result. (Defined by SyntaxLanguageParsingExtensions.)
Public Extension Method | RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLexer | Registers the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterParser | Registers the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterProject | Registers the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextViewLineNumberProvider | Registers the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlValidator | Registers the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterParser | Unregisters the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterProject | Unregisters the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextViewLineNumberProvider | Unregisters the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Top
See Also

Reference

ISyntaxLanguage Interface
ActiproSoftware.Text Namespace


ISyntaxLanguage Events

The ISyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ISyntaxLanguage Interface
ActiproSoftware.Text Namespace


ITextBufferReader Interface

Provides the base requirements for an object that reads characters from a fixed text buffer.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextBufferReader
Public Interface ITextBufferReader

The ITextBufferReader type exposes the following members.

Properties
 | Name | Description
Public property | HasStackEntries | Gets whether there are entries on the stack.
Public property | IsAtEnd | Gets whether the current Offset is at the end of the text buffer.
Public property | IsAtStart | Gets whether the current Offset is at the start of the text buffer.
Public property | IsWhitespaceOnlyAfterOnLine | Gets whether only whitespace characters appear at and after the Offset on the current line.
Public property | IsWhitespaceOnlyBeforeOnLine | Gets whether only whitespace characters appear before the Offset on the current line.
Public property | Length | Gets the number of characters in the text buffer.
Public property | Offset | Gets or sets the current reader offset in the text buffer.
Public property | OffsetDelta | Gets the amount by which to alter the offset values that are parsed.
Public property | Position | Gets the current reader TextPosition in the text buffer.
Public property | PositionDelta | Gets the amount by which to alter the Position values that are parsed.
Top
Methods
 | Name | Description
Public method | AsTextReader | Returns a TextReader wrapper for this reader.
Public method | GetSubstring | Returns a substring from the text buffer using Newline for line ends.
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Public method | PeekReverse | Reverse peeks at a single character from the text buffer without seeking past it.
Public method | Pop | Pops the top offset from the stack and moves the Offset to that offset.
Public method | PopAll | Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.
Public method | Push | Pushes the Offset onto the stack for later restoration.
Public method | Read | Reads a single character from the text buffer and seeks forward one offset.
Public method | ReadReverse | Reverse reads a single character from the text buffer and seeks backward one offset.
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationStringTextBufferReader


ITextBufferReader Properties

The ITextBufferReader type exposes the following members.

Properties
 | Name | Description
Public property | HasStackEntries | Gets whether there are entries on the stack.
Public property | IsAtEnd | Gets whether the current Offset is at the end of the text buffer.
Public property | IsAtStart | Gets whether the current Offset is at the start of the text buffer.
Public property | IsWhitespaceOnlyAfterOnLine | Gets whether only whitespace characters appear at and after the Offset on the current line.
Public property | IsWhitespaceOnlyBeforeOnLine | Gets whether only whitespace characters appear before the Offset on the current line.
Public property | Length | Gets the number of characters in the text buffer.
Public property | Offset | Gets or sets the current reader offset in the text buffer.
Public property | OffsetDelta | Gets the amount by which to alter the offset values that are parsed.
Public property | Position | Gets the current reader TextPosition in the text buffer.
Public property | PositionDelta | Gets the amount by which to alter the Position values that are parsed.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.HasStackEntries Property

ITextBufferReaderHasStackEntries Property

Gets whether there are entries on the stack.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasStackEntries { get; }
ReadOnly Property HasStackEntries As Boolean
    Get

Property Value

Type: Boolean
true if there are entries on the stack; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.IsAtEnd Property

ITextBufferReaderIsAtEnd Property

Gets whether the current Offset is at the end of the text buffer.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAtEnd { get; }
ReadOnly Property IsAtEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the end of the text buffer; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.IsAtStart Property

ITextBufferReaderIsAtStart Property

Gets whether the current Offset is at the start of the text buffer.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAtStart { get; }
ReadOnly Property IsAtStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of the text buffer; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.IsWhitespaceOnlyAfterOnLine Property

ITextBufferReaderIsWhitespaceOnlyAfterOnLine Property

Gets whether only whitespace characters appear at and after the Offset on the current line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsWhitespaceOnlyAfterOnLine { get; }
ReadOnly Property IsWhitespaceOnlyAfterOnLine As Boolean
    Get

Property Value

Type: Boolean
true if only whitespace characters appear at and after the Offset on the current line; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.IsWhitespaceOnlyBeforeOnLine Property

ITextBufferReaderIsWhitespaceOnlyBeforeOnLine Property

Gets whether only whitespace characters appear before the Offset on the current line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsWhitespaceOnlyBeforeOnLine { get; }
ReadOnly Property IsWhitespaceOnlyBeforeOnLine As Boolean
    Get

Property Value

Type: Boolean
true if only whitespace characters appear before the Offset on the current line; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Length Property

ITextBufferReaderLength Property

Gets the number of characters in the text buffer.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters in the text buffer.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Offset Property

ITextBufferReaderOffset Property

Gets or sets the current reader offset in the text buffer.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Offset { get; set; }
Property Offset As Integer
    Get
    Set

Property Value

Type: Int32
The current reader offset in the text buffer.
Remarks
For performance reasons there is no bounds check on the setter.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.OffsetDelta Property

ITextBufferReaderOffsetDelta Property

Gets the amount by which to alter the offset values that are parsed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int OffsetDelta { get; }
ReadOnly Property OffsetDelta As Integer
    Get

Property Value

Type: Int32
The amount by which to alter the offset values that are parsed.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Position Property

ITextBufferReaderPosition Property

Gets the current reader TextPosition in the text buffer.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition Position { get; }
ReadOnly Property Position As TextPosition
    Get

Property Value

Type: TextPosition
The current reader TextPosition in the text buffer.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.PositionDelta Property

ITextBufferReaderPositionDelta Property

Gets the amount by which to alter the Position values that are parsed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition PositionDelta { get; }
ReadOnly Property PositionDelta As TextPosition
    Get

Property Value

Type: TextPosition
The amount by which to alter the Position values that are parsed.
Remarks
The Character portion only affects character offset of the line after the Line count.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader Methods

The ITextBufferReader type exposes the following members.

Methods
 | Name | Description
Public method | AsTextReader | Returns a TextReader wrapper for this reader.
Public method | GetSubstring | Returns a substring from the text buffer using Newline for line ends.
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Public method | PeekReverse | Reverse peeks at a single character from the text buffer without seeking past it.
Public method | Pop | Pops the top offset from the stack and moves the Offset to that offset.
Public method | PopAll | Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.
Public method | Push | Pushes the Offset onto the stack for later restoration.
Public method | Read | Reads a single character from the text buffer and seeks forward one offset.
Public method | ReadReverse | Reverse reads a single character from the text buffer and seeks backward one offset.
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.AsTextReader Method

ITextBufferReaderAsTextReader Method

Returns a TextReader wrapper for this reader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextReader AsTextReader()
Function AsTextReader As TextReader

Return Value

Type: TextReader
A TextReader wrapper for this reader.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.GetSubstring Method

ITextBufferReaderGetSubstring Method

Returns a substring from the text buffer using Newline for line ends.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetSubstring(
    int offset,
    int length
)
Function GetSubstring (
    offset As Integer,
    length As Integer
) As String

Parameters

offset
Type: SystemInt32
The offset at which to retrieve the text.
length
Type: SystemInt32
The number of characters to return.

Return Value

Type: String
The substring from the text buffer using Newline for line ends.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Peek Method

ITextBufferReaderPeek Method

Overload List
 | Name | Description
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Peek Method

ITextBufferReaderPeek Method

Peeks at a single character from the text buffer without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char Peek()
Function Peek As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
Peek Overload
ActiproSoftware.Text Namespace


ITextBufferReader.Peek Method (Int32)

ITextBufferReaderPeek Method (Int32)

Peeks at a certain character from the text buffer after the current Offset without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char Peek(
    int count
)
Function Peek (
    count As Integer
) As Char

Parameters

count
Type: SystemInt32
The number of characters away from the current Offset at which to peek.

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
Peek Overload
ActiproSoftware.Text Namespace


ITextBufferReader.PeekReverse Method

ITextBufferReaderPeekReverse Method

Reverse peeks at a single character from the text buffer without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char PeekReverse()
Function PeekReverse As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Pop Method

ITextBufferReaderPop Method

Pops the top offset from the stack and moves the Offset to that offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Pop()
Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.PopAll Method

ITextBufferReaderPopAll Method

Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool PopAll()
Function PopAll As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Push Method

ITextBufferReaderPush Method

Pushes the Offset onto the stack for later restoration.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Push()
Sub Push
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Read Method

ITextBufferReaderRead Method

Reads a single character from the text buffer and seeks forward one offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char Read()
Function Read As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.ReadReverse Method

ITextBufferReaderReadReverse Method

Reverse reads a single character from the text buffer and seeks backward one offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char ReadReverse()
Function ReadReverse As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.ReadReverseThrough Method

ITextBufferReaderReadReverseThrough Method

Overload List
 | Name | Description
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.ReadReverseThrough Method (Char)

ITextBufferReaderReadReverseThrough Method (Char)

Reverse reads characters from the text buffer until the specified character is read through.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReadReverseThrough(
    char ch
)
Function ReadReverseThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the start of the text buffer was reached.
See Also

Reference

ITextBufferReader Interface
ReadReverseThrough Overload
ActiproSoftware.Text Namespace


ITextBufferReader.ReadReverseThrough Method (Char, Int32)

ITextBufferReaderReadReverseThrough Method (Char, Int32)

Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReadReverseThrough(
    char ch,
    int minOffset
)
Function ReadReverseThrough (
    ch As Char,
    minOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
minOffset
Type: SystemInt32
The minimum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.
See Also

Reference

ITextBufferReader Interface
ReadReverseThrough Overload
ActiproSoftware.Text Namespace


ITextBufferReader.ReadThrough Method

ITextBufferReaderReadThrough Method

Overload List
 | Name | Description
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.ReadThrough Method (Char)

ITextBufferReaderReadThrough Method (Char)

Reads characters from the text buffer until the specified character is read through.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReadThrough(
    char ch
)
Function ReadThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the end of the text buffer was reached.
See Also

Reference

ITextBufferReader Interface
ReadThrough Overload
ActiproSoftware.Text Namespace


ITextBufferReader.ReadThrough Method (Char, Int32)

ITextBufferReaderReadThrough Method (Char, Int32)

Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReadThrough(
    char ch,
    int maxOffset
)
Function ReadThrough (
    ch As Char,
    maxOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
maxOffset
Type: SystemInt32
The maximum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.
See Also

Reference

ITextBufferReader Interface
ReadThrough Overload
ActiproSoftware.Text Namespace


ITextChange Interface

Provides the base requirements for a text change, which contains one or more ITextChangeOperation objects.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextChange
Public Interface ITextChange

The ITextChange type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets whether this text change can merge into the previous text change in the undo stack.
Public property | CheckReadOnly | Gets whether to prevent the text change from occurring if any text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | IsMerged | Gets whether this text change is the result of a merge of two or more text changes.
Public property | IsRedo | Gets whether the text change is for a redo.
Public property | IsUndo | Gets whether the text change is for an undo.
Public property | LastTextReplacementOperationIndex | Gets the index of the last operation within the text change in which the entire document text was replaced, if any.
Public property | Operations | Gets the read-only list of ITextChangeOperation objects that make up this text change.
Public property | PostSelectionPositionRanges | Gets or sets the collection of sorted non-overlapping TextPositionRange objects that should be selected in the source view after the text change is applied.
Public property | PreSelectionPositionRanges | Gets or sets the collection of sorted non-overlapping TextPositionRange objects that were selected in the source view before the text change is applied.
Public property | RetainSelection | Gets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Snapshot | Gets the ITextSnapshot against which all operations in this text change should be based.
Public property | Source | Gets the optional source of the text change, which is most often an editor view if specified.
Public property | Type | Gets an ITextChangeType indicating the type of change that was made.
Top
Methods
 | Name | Description
Public method | AppendText | Adds an ITextChangeOperation that appends text to the end of the Snapshot.
Public method | Apply | Applies the text change and all of its Operations in sequential order.
Public method | Apply(ITextPositionRangeCollection, TextRangeTrackingModes) | Applies the text change and all of its Operations in sequential order, also designating the position ranges that should be translated and set to the PostSelectionPositionRanges property after the text change is applied.
Public method | Apply(IListTextRange, Int32, NullableTextRangeTrackingModes) | Applies the text change and all of its Operations in sequential order, also designating the text ranges that should be converted and set to the PostSelectionPositionRanges property after the text change is applied.
Public method | DeleteText(TextRange) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | DeleteText(Int32, Int32) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | InsertText | Adds an ITextChangeOperation that inserts text in the Snapshot.
Public method | ReplaceText(TextRange, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | ReplaceText(Int32, Int32, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | SetText(String) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and marks the operation as a programmatic replacement.
Public method | SetText(String, Boolean) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and optionally marks the operation as a programmatic replacement.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextChange Properties

The ITextChange type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets whether this text change can merge into the previous text change in the undo stack.
Public property | CheckReadOnly | Gets whether to prevent the text change from occurring if any text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | IsMerged | Gets whether this text change is the result of a merge of two or more text changes.
Public property | IsRedo | Gets whether the text change is for a redo.
Public property | IsUndo | Gets whether the text change is for an undo.
Public property | LastTextReplacementOperationIndex | Gets the index of the last operation within the text change in which the entire document text was replaced, if any.
Public property | Operations | Gets the read-only list of ITextChangeOperation objects that make up this text change.
Public property | PostSelectionPositionRanges | Gets or sets the collection of sorted non-overlapping TextPositionRange objects that should be selected in the source view after the text change is applied.
Public property | PreSelectionPositionRanges | Gets or sets the collection of sorted non-overlapping TextPositionRange objects that were selected in the source view before the text change is applied.
Public property | RetainSelection | Gets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Snapshot | Gets the ITextSnapshot against which all operations in this text change should be based.
Public property | Source | Gets the optional source of the text change, which is most often an editor view if specified.
Public property | Type | Gets an ITextChangeType indicating the type of change that was made.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.CanMergeIntoPreviousChange Property

ITextChangeCanMergeIntoPreviousChange Property

Gets whether this text change can merge into the previous text change in the undo stack.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanMergeIntoPreviousChange { get; }
ReadOnly Property CanMergeIntoPreviousChange As Boolean
    Get

Property Value

Type: Boolean
true if this text change can merge into the previous text change in the undo stack; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.CheckReadOnly Property

ITextChangeCheckReadOnly Property

Gets whether to prevent the text change from occurring if any text range to modify is flagged as read-only.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CheckReadOnly { get; }
ReadOnly Property CheckReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the read-only state should be checked; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.CustomData Property

ITextChangeCustomData Property

Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object CustomData { get; set; }
Property CustomData As Object
    Get
    Set

Property Value

Type: Object
The custom data.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.IsMerged Property

ITextChangeIsMerged Property

Gets whether this text change is the result of a merge of two or more text changes.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsMerged { get; }
ReadOnly Property IsMerged As Boolean
    Get

Property Value

Type: Boolean
true if this text change is the result of a merge of two or more text changes; otherwise, false.
Remarks
A merge can occur when a text change is created with CanMergeIntoPreviousChange.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.IsRedo Property

ITextChangeIsRedo Property

Gets whether the text change is for a redo.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsRedo { get; }
ReadOnly Property IsRedo As Boolean
    Get

Property Value

Type: Boolean
true if the text change is for a redo; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.IsUndo Property

ITextChangeIsUndo Property

Gets whether the text change is for an undo.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsUndo { get; }
ReadOnly Property IsUndo As Boolean
    Get

Property Value

Type: Boolean
true if the text change is for an undo; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.LastTextReplacementOperationIndex Property

ITextChangeLastTextReplacementOperationIndex Property

Gets the index of the last operation within the text change in which the entire document text was replaced, if any.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int LastTextReplacementOperationIndex { get; }
ReadOnly Property LastTextReplacementOperationIndex As Integer
    Get

Property Value

Type: Int32
The index of the last text replacement operation within the text change; otherwise, -1 if there are no such operations.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.Operations Property

ITextChangeOperations Property

Gets the read-only list of ITextChangeOperation objects that make up this text change.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<ITextChangeOperation> Operations { get; }
ReadOnly Property Operations As IList(Of ITextChangeOperation)
    Get

Property Value

Type: IList ITextChangeOperation
The read-only list of ITextChangeOperation objects that make up this text change.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.PostSelectionPositionRanges Property

ITextChangePostSelectionPositionRanges Property

Gets or sets the collection of sorted non-overlapping TextPositionRange objects that should be selected in the source view after the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextPositionRangeCollection PostSelectionPositionRanges { get; set; }
Property PostSelectionPositionRanges As ITextPositionRangeCollection
    Get
    Set

Property Value

Type: ITextPositionRangeCollection
The collection of sorted non-overlapping TextPositionRange objects that should be selected in the source view after the text change is applied.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.PreSelectionPositionRanges Property

ITextChangePreSelectionPositionRanges Property

Gets or sets the collection of sorted non-overlapping TextPositionRange objects that were selected in the source view before the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextPositionRangeCollection PreSelectionPositionRanges { get; set; }
Property PreSelectionPositionRanges As ITextPositionRangeCollection
    Get
    Set

Property Value

Type: ITextPositionRangeCollection
The collection of sorted non-overlapping TextPositionRange objects that were selected in the source view before the text change is applied.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.RetainSelection Property

ITextChangeRetainSelection Property

Gets whether to prevent the caret from moving to the end of the text change in the active view.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool RetainSelection { get; }
ReadOnly Property RetainSelection As Boolean
    Get

Property Value

Type: Boolean
true if the caret move should be prevented; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.Snapshot Property

ITextChangeSnapshot Property

Gets the ITextSnapshot against which all operations in this text change should be based.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot against which all operations in this text change should be based.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.Source Property

ITextChangeSource Property

Gets the optional source of the text change, which is most often an editor view if specified.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Source { get; }
ReadOnly Property Source As Object
    Get

Property Value

Type: Object
The optional source of the text change, which is most often an editor view if specified.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.Type Property

ITextChangeType Property

Gets an ITextChangeType indicating the type of change that was made.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextChangeType Type { get; }
ReadOnly Property Type As ITextChangeType
    Get

Property Value

Type: ITextChangeType
An ITextChangeType indicating the type of change that was made.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange Methods

The ITextChange type exposes the following members.

Methods
 | Name | Description
Public method | AppendText | Adds an ITextChangeOperation that appends text to the end of the Snapshot.
Public method | Apply | Applies the text change and all of its Operations in sequential order.
Public method | Apply(ITextPositionRangeCollection, TextRangeTrackingModes) | Applies the text change and all of its Operations in sequential order, also designating the position ranges that should be translated and set to the PostSelectionPositionRanges property after the text change is applied.
Public method | Apply(IListTextRange, Int32, NullableTextRangeTrackingModes) | Applies the text change and all of its Operations in sequential order, also designating the text ranges that should be converted and set to the PostSelectionPositionRanges property after the text change is applied.
Public method | DeleteText(TextRange) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | DeleteText(Int32, Int32) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | InsertText | Adds an ITextChangeOperation that inserts text in the Snapshot.
Public method | ReplaceText(TextRange, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | ReplaceText(Int32, Int32, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | SetText(String) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and marks the operation as a programmatic replacement.
Public method | SetText(String, Boolean) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and optionally marks the operation as a programmatic replacement.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.AppendText Method

ITextChangeAppendText Method

Adds an ITextChangeOperation that appends text to the end of the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void AppendText(
    string text
)
Sub AppendText (
    text As String
)

Parameters

text
Type: SystemString
The text to append to the end of the Snapshot.
Remarks
This method is simply a wrapper for a call to InsertText(Int32, String).
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace
ITextChangeDeleteText(Int32, Int32)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(Int32, Int32, String)
ITextChangeSetText(String)


ITextChange.Apply Method

ITextChangeApply Method

Overload List
 | Name | Description
Public method | Apply | Applies the text change and all of its Operations in sequential order.
Public method | Apply(ITextPositionRangeCollection, TextRangeTrackingModes) | Applies the text change and all of its Operations in sequential order, also designating the position ranges that should be translated and set to the PostSelectionPositionRanges property after the text change is applied.
Public method | Apply(IListTextRange, Int32, NullableTextRangeTrackingModes) | Applies the text change and all of its Operations in sequential order, also designating the text ranges that should be converted and set to the PostSelectionPositionRanges property after the text change is applied.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.Apply Method

ITextChangeApply Method

Applies the text change and all of its Operations in sequential order.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Apply()
Function Apply As Boolean

Return Value

Type: Boolean
true if all the operations were applied successfully; otherwise, false.
See Also

Reference

ITextChange Interface
Apply Overload
ActiproSoftware.Text Namespace


ITextChange.Apply Method (ITextPositionRangeCollection, TextRangeTrackingModes)

ITextChangeApply Method (ITextPositionRangeCollection, TextRangeTrackingModes)

Applies the text change and all of its Operations in sequential order, also designating the position ranges that should be translated and set to the PostSelectionPositionRanges property after the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Apply(
    ITextPositionRangeCollection pendingSelectionPositionRanges,
    TextRangeTrackingModes translationTrackingModes
)
Function Apply (
    pendingSelectionPositionRanges As ITextPositionRangeCollection,
    translationTrackingModes As TextRangeTrackingModes
) As Boolean

Parameters

pendingSelectionPositionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The collection of position ranges that should be converted following the text change.
translationTrackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes value indicating the translation tracking modes to use.

Return Value

Type: Boolean
true if all the operations were applied successfully; otherwise, false.
See Also

Reference

ITextChange Interface
Apply Overload
ActiproSoftware.Text Namespace


ITextChange.Apply Method (IList(TextRange), Int32, Nullable(TextRangeTrackingModes))

ITextChangeApply Method (IListTextRange, Int32, NullableTextRangeTrackingModes)

Applies the text change and all of its Operations in sequential order, also designating the text ranges that should be converted and set to the PostSelectionPositionRanges property after the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Apply(
    IList<TextRange> pendingSelectionTextRanges,
    int primaryIndex,
    Nullable<TextRangeTrackingModes> translationTrackingModes
)
Function Apply (
    pendingSelectionTextRanges As IList(Of TextRange),
    primaryIndex As Integer,
    translationTrackingModes As Nullable(Of TextRangeTrackingModes)
) As Boolean

Parameters

pendingSelectionTextRanges
Type: System.Collections.GenericIList TextRange
The collection of text ranges that should be converted following the text change.
primaryIndex
Type: SystemInt32
The index of the primary selection range.
translationTrackingModes
Type: SystemNullable TextRangeTrackingModes
When the text range offsets are relative to the previous snapshot and need to be translated to the new snapshot, this parameter should be set to a non-null TextRangeTrackingModes value indicating the translation tracking modes to use. A null value indicates no translation is necessary since the text range offsets are relative to the new snapshot.

Return Value

Type: Boolean
true if all the operations were applied successfully; otherwise, false.
See Also

Reference

ITextChange Interface
Apply Overload
ActiproSoftware.Text Namespace


ITextChange.DeleteText Method

ITextChangeDeleteText Method

Overload List
 | Name | Description
Public method | DeleteText(TextRange) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | DeleteText(Int32, Int32) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.DeleteText Method (TextRange)

ITextChangeDeleteText Method (TextRange)

Adds an ITextChangeOperation that deletes text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void DeleteText(
    TextRange textRange
)
Sub DeleteText (
    textRange As TextRange
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
See Also

Reference

ITextChange Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(TextRange, String)
ITextChangeSetText(String)


ITextChange.DeleteText Method (Int32, Int32)

ITextChangeDeleteText Method (Int32, Int32)

Adds an ITextChangeOperation that deletes text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void DeleteText(
    int offset,
    int deleteLength
)
Sub DeleteText (
    offset As Integer,
    deleteLength As Integer
)

Parameters

offset
Type: SystemInt32
The starting offset at which to delete.
deleteLength
Type: SystemInt32
The number of characters to delete.
See Also

Reference

ITextChange Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(Int32, Int32, String)
ITextChangeSetText(String)


ITextChange.InsertText Method

ITextChangeInsertText Method

Adds an ITextChangeOperation that inserts text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void InsertText(
    int offset,
    string text
)
Sub InsertText (
    offset As Integer,
    text As String
)

Parameters

offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(Int32, Int32)
ITextChangeReplaceText(Int32, Int32, String)
ITextChangeSetText(String)


ITextChange.ReplaceText Method

ITextChangeReplaceText Method

Overload List
 | Name | Description
Public method | ReplaceText(TextRange, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | ReplaceText(Int32, Int32, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.ReplaceText Method (TextRange, String)

ITextChangeReplaceText Method (TextRange, String)

Adds an ITextChangeOperation that replaces text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void ReplaceText(
    TextRange textRange,
    string insertText
)
Sub ReplaceText (
    textRange As TextRange,
    insertText As String
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
insertText
Type: SystemString
The text to insert.
See Also

Reference

ITextChange Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(TextRange)
ITextChangeInsertText(Int32, String)
ITextChangeSetText(String)


ITextChange.ReplaceText Method (Int32, Int32, String)

ITextChangeReplaceText Method (Int32, Int32, String)

Adds an ITextChangeOperation that replaces text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void ReplaceText(
    int offset,
    int deleteLength,
    string insertText
)
Sub ReplaceText (
    offset As Integer,
    deleteLength As Integer,
    insertText As String
)

Parameters

offset
Type: SystemInt32
The offset at which to insert.
deleteLength
Type: SystemInt32
The number of characters to delete before inserting the text.
insertText
Type: SystemString
The text to insert.
See Also

Reference

ITextChange Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(Int32, Int32)
ITextChangeInsertText(Int32, String)
ITextChangeSetText(String)


ITextChange.SetText Method

ITextChangeSetText Method

Overload List
 | Name | Description
Public method | SetText(String) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and marks the operation as a programmatic replacement.
Public method | SetText(String, Boolean) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and optionally marks the operation as a programmatic replacement.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.SetText Method (String)

ITextChangeSetText Method (String)

Adds an ITextChangeOperation that replaces all the text in the Snapshot and marks the operation as a programmatic replacement.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void SetText(
    string text
)
Sub SetText (
    text As String
)

Parameters

text
Type: SystemString
The text to insert. Pass an empty string to "clear" the document.
Remarks
A programmatic text replacement means that the undo history will be cleared, and any attached editors will reset the caret to offset 0.
See Also

Reference

ITextChange Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(Int32, Int32)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(Int32, Int32, String)


ITextChange.SetText Method (String, Boolean)

ITextChangeSetText Method (String, Boolean)

Adds an ITextChangeOperation that replaces all the text in the Snapshot and optionally marks the operation as a programmatic replacement.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void SetText(
    string text,
    bool isProgrammatic
)
Sub SetText (
    text As String,
    isProgrammatic As Boolean
)

Parameters

text
Type: SystemString
The text to insert. Pass an empty string to "clear" the document.
isProgrammatic
Type: SystemBoolean
Whether the operation is considered a programmatic replacement.
Remarks
A programmatic text replacement means that the undo history will be cleared, and any attached editors will reset the caret to offset 0.
See Also

Reference

ITextChange Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(Int32, Int32)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(Int32, Int32, String)


ITextChangeOperation Interface

Provides the base requirements for a single replace operations within a text change.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextChangeOperation : ITextChangeRangedOperation
Public Interface ITextChangeOperation
    Inherits ITextChangeRangedOperation

The ITextChangeOperation type exposes the following members.

Properties
 | Name | Description
Public property | DeletedText | Gets the text that was deleted by the operation.
Public property | DeletionEndOffset | Gets the offset at which the deletion ended. (Inherited from ITextChangeRangedOperation.)
Public property | DeletionEndPosition | Gets the TextPosition at which the deletion ended. (Inherited from ITextChangeRangedOperation.)
Public property | DeletionLength | Gets the number of characters that were deleted. (Inherited from ITextChangeRangedOperation.)
Public property | HasDeletion | Gets whether the operation deleted any text. (Inherited from ITextChangeRangedOperation.)
Public property | HasInsertion | Gets whether the operation inserted any text. (Inherited from ITextChangeRangedOperation.)
Public property | InsertedText | Gets the text that was inserted by the operation.
Public property | InsertionEndOffset | Gets the offset at which the insertion ended. (Inherited from ITextChangeRangedOperation.)
Public property | InsertionEndPosition | Gets the TextPosition at which the insertion ended. (Inherited from ITextChangeRangedOperation.)
Public property | InsertionLength | Gets the number of characters that were inserted. (Inherited from ITextChangeRangedOperation.)
Public property | IsIgnoredForTranslation | Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation. (Inherited from ITextChangeRangedOperation.)
Public property | IsProgrammaticTextReplacement | Gets whether the operation completely replaces the document's text, and is only caused by using the SetText(String) method.
Public property | IsTextReplacement | Gets whether the operation completely replaces the document's text.
Public property | LengthDelta | Gets the net change in length to the document after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesDeleted | Gets the number of document lines deleted after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesDelta | Gets the net change in document lines after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesInserted | Gets the number of lines inserted after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | StartOffset | Gets the offset at which the operation occurred. (Inherited from ITextChangeRangedOperation.)
Public property | StartPosition | Gets the TextPosition at which the operation occurred. (Inherited from ITextChangeRangedOperation.)
Top
Remarks
All text change operations are represented in terms of a replace operation. The StartOffset and StartPosition properties both indicate where the operations occurred. For delete operations, the InsertionLength is 0. For insert operations that have no selection of text to be replaced, the DeletionLength is 0.
See Also

Reference

ActiproSoftware.Text Namespace


ITextChangeOperation Properties

The ITextChangeOperation type exposes the following members.

Properties
 | Name | Description
Public property | DeletedText | Gets the text that was deleted by the operation.
Public property | DeletionEndOffset | Gets the offset at which the deletion ended. (Inherited from ITextChangeRangedOperation.)
Public property | DeletionEndPosition | Gets the TextPosition at which the deletion ended. (Inherited from ITextChangeRangedOperation.)
Public property | DeletionLength | Gets the number of characters that were deleted. (Inherited from ITextChangeRangedOperation.)
Public property | HasDeletion | Gets whether the operation deleted any text. (Inherited from ITextChangeRangedOperation.)
Public property | HasInsertion | Gets whether the operation inserted any text. (Inherited from ITextChangeRangedOperation.)
Public property | InsertedText | Gets the text that was inserted by the operation.
Public property | InsertionEndOffset | Gets the offset at which the insertion ended. (Inherited from ITextChangeRangedOperation.)
Public property | InsertionEndPosition | Gets the TextPosition at which the insertion ended. (Inherited from ITextChangeRangedOperation.)
Public property | InsertionLength | Gets the number of characters that were inserted. (Inherited from ITextChangeRangedOperation.)
Public property | IsIgnoredForTranslation | Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation. (Inherited from ITextChangeRangedOperation.)
Public property | IsProgrammaticTextReplacement | Gets whether the operation completely replaces the document's text, and is only caused by using the SetText(String) method.
Public property | IsTextReplacement | Gets whether the operation completely replaces the document's text.
Public property | LengthDelta | Gets the net change in length to the document after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesDeleted | Gets the number of document lines deleted after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesDelta | Gets the net change in document lines after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesInserted | Gets the number of lines inserted after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | StartOffset | Gets the offset at which the operation occurred. (Inherited from ITextChangeRangedOperation.)
Public property | StartPosition | Gets the TextPosition at which the operation occurred. (Inherited from ITextChangeRangedOperation.)
Top
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOperation.DeletedText Property

ITextChangeOperationDeletedText Property

Gets the text that was deleted by the operation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string DeletedText { get; }
ReadOnly Property DeletedText As String
    Get

Property Value

Type: String
The text that was deleted by the operation.
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOperation.InsertedText Property

ITextChangeOperationInsertedText Property

Gets the text that was inserted by the operation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string InsertedText { get; }
ReadOnly Property InsertedText As String
    Get

Property Value

Type: String
The text that was inserted by the operation.
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOperation.IsProgrammaticTextReplacement Property

ITextChangeOperationIsProgrammaticTextReplacement Property

Gets whether the operation completely replaces the document's text, and is only caused by using the SetText(String) method.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsProgrammaticTextReplacement { get; }
ReadOnly Property IsProgrammaticTextReplacement As Boolean
    Get

Property Value

Type: Boolean
true if the operation completely replaces the document's text, and is only caused by using the SetText(String) method; otherwise, false.
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOperation.IsTextReplacement Property

ITextChangeOperationIsTextReplacement Property

Gets whether the operation completely replaces the document's text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsTextReplacement { get; }
ReadOnly Property IsTextReplacement As Boolean
    Get

Property Value

Type: Boolean
true if the operation completely replaces the document's text; otherwise, false.
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOptions Interface

Provides the base requirements for options that are applied to an ITextChange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextChangeOptions
Public Interface ITextChangeOptions

The ITextChangeOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack, assuming one is available.
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextChangeOptions Properties

The ITextChangeOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack, assuming one is available.
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified.
Top
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.CanMergeIntoPreviousChange Property

ITextChangeOptionsCanMergeIntoPreviousChange Property

Gets or sets whether this text change can merge into the previous text change in the undo stack, assuming one is available.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanMergeIntoPreviousChange { get; set; }
Property CanMergeIntoPreviousChange As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this text change can merge into the previous text change in the undo stack; otherwise, false.
Remarks
When true, if an undo occurs after this text change, this text change's operations along with those of the previous text change would occur as a single undoable text change.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.CheckReadOnly Property

ITextChangeOptionsCheckReadOnly Property

Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CheckReadOnly { get; set; }
Property CheckReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the read-only state should be checked; otherwise, false.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.CustomData Property

ITextChangeOptionsCustomData Property

Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object CustomData { get; set; }
Property CustomData As Object
    Get
    Set

Property Value

Type: Object
The custom data.
Remarks
This custom data is only persisted for the root text change of a set of operations.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.OffsetDelta Property

ITextChangeOptionsOffsetDelta Property

Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextChangeOffsetDelta OffsetDelta { get; set; }
Property OffsetDelta As TextChangeOffsetDelta
    Get
    Set

Property Value

Type: TextChangeOffsetDelta
A TextChangeOffsetDelta value indicating how to apply offset deltas, if at all.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.RetainSelection Property

ITextChangeOptionsRetainSelection Property

Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool RetainSelection { get; set; }
Property RetainSelection As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the caret move should be prevented; otherwise, false.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.Source Property

ITextChangeOptionsSource Property

Gets or sets the optional source of the text change, which is most often an editor view if specified.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Source { get; set; }
Property Source As Object
    Get
    Set

Property Value

Type: Object
The optional source of the text change, which is most often an editor view if specified.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation Interface

Provides the base requirements for a single replace operations within a text change, but without storing the actual text inserted/deleted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextChangeRangedOperation
Public Interface ITextChangeRangedOperation

The ITextChangeRangedOperation type exposes the following members.

Properties
 | Name | Description
Public property | DeletionEndOffset | Gets the offset at which the deletion ended.
Public property | DeletionEndPosition | Gets the TextPosition at which the deletion ended.
Public property | DeletionLength | Gets the number of characters that were deleted.
Public property | HasDeletion | Gets whether the operation deleted any text.
Public property | HasInsertion | Gets whether the operation inserted any text.
Public property | InsertionEndOffset | Gets the offset at which the insertion ended.
Public property | InsertionEndPosition | Gets the TextPosition at which the insertion ended.
Public property | InsertionLength | Gets the number of characters that were inserted.
Public property | IsIgnoredForTranslation | Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation.
Public property | LengthDelta | Gets the net change in length to the document after performing the operation.
Public property | LinesDeleted | Gets the number of document lines deleted after performing the operation.
Public property | LinesDelta | Gets the net change in document lines after performing the operation.
Public property | LinesInserted | Gets the number of lines inserted after performing the operation.
Public property | StartOffset | Gets the offset at which the operation occurred.
Public property | StartPosition | Gets the TextPosition at which the operation occurred.
Top
Remarks
All text change operations are represented in terms of a replace operation. The StartOffset and StartPosition properties both indicate where the operations occurred. For delete operations, the InsertionLength is 0. For insert operations that have no selection of text to be replaced, the DeletionLength is 0.
See Also

Reference

ActiproSoftware.Text Namespace


ITextChangeRangedOperation Properties

The ITextChangeRangedOperation type exposes the following members.

Properties
 | Name | Description
Public property | DeletionEndOffset | Gets the offset at which the deletion ended.
Public property | DeletionEndPosition | Gets the TextPosition at which the deletion ended.
Public property | DeletionLength | Gets the number of characters that were deleted.
Public property | HasDeletion | Gets whether the operation deleted any text.
Public property | HasInsertion | Gets whether the operation inserted any text.
Public property | InsertionEndOffset | Gets the offset at which the insertion ended.
Public property | InsertionEndPosition | Gets the TextPosition at which the insertion ended.
Public property | InsertionLength | Gets the number of characters that were inserted.
Public property | IsIgnoredForTranslation | Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation.
Public property | LengthDelta | Gets the net change in length to the document after performing the operation.
Public property | LinesDeleted | Gets the number of document lines deleted after performing the operation.
Public property | LinesDelta | Gets the net change in document lines after performing the operation.
Public property | LinesInserted | Gets the number of lines inserted after performing the operation.
Public property | StartOffset | Gets the offset at which the operation occurred.
Public property | StartPosition | Gets the TextPosition at which the operation occurred.
Top
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.DeletionEndOffset Property

ITextChangeRangedOperationDeletionEndOffset Property

Gets the offset at which the deletion ended.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int DeletionEndOffset { get; }
ReadOnly Property DeletionEndOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the deletion ended.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.DeletionEndPosition Property

ITextChangeRangedOperationDeletionEndPosition Property

Gets the TextPosition at which the deletion ended.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition DeletionEndPosition { get; }
ReadOnly Property DeletionEndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition at which the deletion ended.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.DeletionLength Property

ITextChangeRangedOperationDeletionLength Property

Gets the number of characters that were deleted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int DeletionLength { get; }
ReadOnly Property DeletionLength As Integer
    Get

Property Value

Type: Int32
The number of characters that were deleted.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.HasDeletion Property

ITextChangeRangedOperationHasDeletion Property

Gets whether the operation deleted any text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasDeletion { get; }
ReadOnly Property HasDeletion As Boolean
    Get

Property Value

Type: Boolean
true if any text was deleted; otherwise, false.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.HasInsertion Property

ITextChangeRangedOperationHasInsertion Property

Gets whether the operation inserted any text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasInsertion { get; }
ReadOnly Property HasInsertion As Boolean
    Get

Property Value

Type: Boolean
true if any text was inserted; otherwise, false.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.InsertionEndOffset Property

ITextChangeRangedOperationInsertionEndOffset Property

Gets the offset at which the insertion ended.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int InsertionEndOffset { get; }
ReadOnly Property InsertionEndOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the insertion ended.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.InsertionEndPosition Property

ITextChangeRangedOperationInsertionEndPosition Property

Gets the TextPosition at which the insertion ended.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition InsertionEndPosition { get; }
ReadOnly Property InsertionEndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition at which the insertion ended.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.InsertionLength Property

ITextChangeRangedOperationInsertionLength Property

Gets the number of characters that were inserted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int InsertionLength { get; }
ReadOnly Property InsertionLength As Integer
    Get

Property Value

Type: Int32
The number of characters that were inserted.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.IsIgnoredForTranslation Property

ITextChangeRangedOperationIsIgnoredForTranslation Property

Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsIgnoredForTranslation { get; }
ReadOnly Property IsIgnoredForTranslation As Boolean
    Get

Property Value

Type: Boolean
true if the operation is a simple replace such as a character casing update that should be ignored for translation; otherwise, false.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.LengthDelta Property

ITextChangeRangedOperationLengthDelta Property

Gets the net change in length to the document after performing the operation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int LengthDelta { get; }
ReadOnly Property LengthDelta As Integer
    Get

Property Value

Type: Int32
The net change in length to the document after performing the operation.
Remarks
This value is the InsertionLength minus the DeletionLength.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.LinesDeleted Property

ITextChangeRangedOperationLinesDeleted Property

Gets the number of document lines deleted after performing the operation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int LinesDeleted { get; }
ReadOnly Property LinesDeleted As Integer
    Get

Property Value

Type: Int32
The number of document lines deleted after performing the operation.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.LinesDelta Property

ITextChangeRangedOperationLinesDelta Property

Gets the net change in document lines after performing the operation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int LinesDelta { get; }
ReadOnly Property LinesDelta As Integer
    Get

Property Value

Type: Int32
The net change in document lines after performing the operation.
Remarks
This value is the LinesInserted value minus the LinesDeleted value.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.LinesInserted Property

ITextChangeRangedOperationLinesInserted Property

Gets the number of lines inserted after performing the operation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int LinesInserted { get; }
ReadOnly Property LinesInserted As Integer
    Get

Property Value

Type: Int32
The number of lines inserted after performing the operation.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.StartOffset Property

ITextChangeRangedOperationStartOffset Property

Gets the offset at which the operation occurred.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int StartOffset { get; }
ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the operation occurred.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.StartPosition Property

ITextChangeRangedOperationStartPosition Property

Gets the TextPosition at which the operation occurred.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition StartPosition { get; }
ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition at which the operation occurred.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeType Interface

Provides the base requirements for an object that indicates the type of change made by an ITextChange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextChangeType : IKeyedObject
Public Interface ITextChangeType
    Inherits IKeyedObject

The ITextChangeType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the change type, which is displayed in the user interface in undo lists.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextChangeType Properties

The ITextChangeType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the change type, which is displayed in the user interface in undo lists.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ITextChangeType Interface
ActiproSoftware.Text Namespace


ITextChangeType.Description Property

ITextChangeTypeDescription Property

Gets the description of the change type, which is displayed in the user interface in undo lists.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the change type, which is displayed in the user interface in undo lists.
See Also

Reference

ITextChangeType Interface
ActiproSoftware.Text Namespace


ITextDocument Interface

Provides the base requirements for a text document that provides access to the ITextSnapshot (via CurrentSnapshot) that contains the current text of the document, and allows for text modification.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextDocument
Public Interface ITextDocument

The ITextDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document.
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document.
Public property | FileName | Gets or sets the name of the file currently loaded in the document.
Public property | IsModified | Gets or sets whether the document has been modified.
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only.
Public property | TabSize | Gets or sets the distance in spaces between tab stops.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document.
Top
Methods
 | Name | Description
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level.
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level.
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only.
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding.
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding.
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level.
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level.
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file.
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding.
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding.
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results.
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed.
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed.
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed.
Public event | TextChanged | Occurs after a text change occurs to this document.
Public event | TextChanging | Occurs before a text change occurs to this document.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextDocument Properties

The ITextDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document.
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document.
Public property | FileName | Gets or sets the name of the file currently loaded in the document.
Public property | IsModified | Gets or sets whether the document has been modified.
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only.
Public property | TabSize | Gets or sets the distance in spaces between tab stops.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AutoCharacterCasing Property

ITextDocumentAutoCharacterCasing Property

Gets or sets how to modify the case of text that is inserted into the document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
CharacterCasing AutoCharacterCasing { get; set; }
Property AutoCharacterCasing As CharacterCasing
    Get
    Set

Property Value

Type: CharacterCasing
A CharacterCasing indicating the desired case of inserted text.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AutoConvertTabsToSpaces Property

ITextDocumentAutoConvertTabsToSpaces Property

Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AutoConvertTabsToSpaces { get; set; }
Property AutoConvertTabsToSpaces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs should be converted to spaces when the Tab key is pressed or indenting occurs; otherwise, false. The default value is false.
Remarks
The number of spaces inserted is indicated by the TabSize property.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.CurrentSnapshot Property

ITextDocumentCurrentSnapshot Property

Gets the ITextSnapshot that contains the current text of the document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshot CurrentSnapshot { get; }
ReadOnly Property CurrentSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the current text of the document.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.FileName Property

ITextDocumentFileName Property

Gets or sets the name of the file currently loaded in the document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set

Property Value

Type: String
The name of the file currently loaded in the document.
Remarks
This property is automatically set whenever a LoadFile(String) overload is called that accepts a file path.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.IsModified Property

ITextDocumentIsModified Property

Gets or sets whether the document has been modified.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsModified { get; set; }
Property IsModified As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document has been modified; otherwise, false.
Remarks
This flag is reset to false when the ActiproSoftware.Text property is set, or when a SaveFile(String, LineTerminator) overload is used that accepts a path matching the current FileName property value.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.IsReadOnly Property

ITextDocumentIsReadOnly Property

Gets or sets whether the entire document is flagged as read-only.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsReadOnly { get; set; }
Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the entire document is flagged as read-only; otherwise, false. The default value is false.
Remarks
When read-only, the document's contents should not be editable.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.TabSize Property

ITextDocumentTabSize Property

Gets or sets the distance in spaces between tab stops.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int TabSize { get; set; }
Property TabSize As Integer
    Get
    Set

Property Value

Type: Int32
The distance in spaces between tab stops. The default value is 4 spaces.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.UndoHistory Property

ITextDocumentUndoHistory Property

Gets an IUndoHistory that provides access to undo and redo functionality for the document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IUndoHistory UndoHistory { get; }
ReadOnly Property UndoHistory As IUndoHistory
    Get

Property Value

Type: IUndoHistory
An IUndoHistory that provides access to undo and redo functionality for the document.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument Methods

The ITextDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level.
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level.
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only.
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding.
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding.
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level.
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level.
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file.
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding.
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding.
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results.
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AddTextChangedEventHandler Method

ITextDocumentAddTextChangedEventHandler Method

Adds an event handler for the TextChanged event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void AddTextChangedEventHandler(
    EventHandler<TextSnapshotChangedEventArgs> handler,
    EventHandlerPriority priority
)
Sub AddTextChangedEventHandler (
    handler As EventHandler(Of TextSnapshotChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AddTextChangingEventHandler Method

ITextDocumentAddTextChangingEventHandler Method

Adds an event handler for the TextChanging event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void AddTextChangingEventHandler(
    EventHandler<TextSnapshotChangingEventArgs> handler,
    EventHandlerPriority priority
)
Sub AddTextChangingEventHandler (
    handler As EventHandler(Of TextSnapshotChangingEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangingEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AppendText Method

ITextDocumentAppendText Method

Overload List
 | Name | Description
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AppendText Method (ITextChangeType, String)

ITextDocumentAppendText Method (ITextChangeType, String)

Appends text to the end of the CurrentSnapshot text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AppendText(
    ITextChangeType type,
    string text
)
Function AppendText (
    type As ITextChangeType,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to append to the current contents of the snapshot.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds an append operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
AppendText Overload
ActiproSoftware.Text Namespace
ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.AppendText Method (ITextChangeType, String, ITextChangeOptions)

ITextDocumentAppendText Method (ITextChangeType, String, ITextChangeOptions)

Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AppendText(
    ITextChangeType type,
    string text,
    ITextChangeOptions options
)
Function AppendText (
    type As ITextChangeType,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to append to the current contents of the snapshot.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds an append operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
AppendText Overload
ActiproSoftware.Text Namespace
ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.CreateTextChange Method

ITextDocumentCreateTextChange Method

Overload List
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.CreateTextChange Method (ITextChangeType)

ITextDocumentCreateTextChange Method (ITextChangeType)

Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextChange CreateTextChange(
    ITextChangeType type
)
Function CreateTextChange (
    type As ITextChangeType
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.

Return Value

Type: ITextChange
The ITextChange that was created.
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

ITextDocument Interface
CreateTextChange Overload
ActiproSoftware.Text Namespace


ITextDocument.CreateTextChange Method (ITextChangeType, ITextChangeOptions)

ITextDocumentCreateTextChange Method (ITextChangeType, ITextChangeOptions)

Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextChange CreateTextChange(
    ITextChangeType type,
    ITextChangeOptions options
)
Function CreateTextChange (
    type As ITextChangeType,
    options As ITextChangeOptions
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: ITextChange
The ITextChange that was created.
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

ITextDocument Interface
CreateTextChange Overload
ActiproSoftware.Text Namespace


ITextDocument.DeleteText Method

ITextDocumentDeleteText Method

Overload List
 | Name | Description
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.DeleteText Method (ITextChangeType, TextRange)

ITextDocumentDeleteText Method (ITextChangeType, TextRange)

Performs a delete text change in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool DeleteText(
    ITextChangeType type,
    TextRange textRange
)
Function DeleteText (
    type As ITextChangeType,
    textRange As TextRange
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentReplaceText(ITextChangeType, TextRange, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.DeleteText Method (ITextChangeType, TextRange, ITextChangeOptions)

ITextDocumentDeleteText Method (ITextChangeType, TextRange, ITextChangeOptions)

Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool DeleteText(
    ITextChangeType type,
    TextRange textRange,
    ITextChangeOptions options
)
Function DeleteText (
    type As ITextChangeType,
    textRange As TextRange,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.DeleteText Method (ITextChangeType, Int32, Int32)

ITextDocumentDeleteText Method (ITextChangeType, Int32, Int32)

Performs a delete text change in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool DeleteText(
    ITextChangeType type,
    int offset,
    int length
)
Function DeleteText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The starting offset at which to delete.
length
Type: SystemInt32
The number of characters to delete.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.DeleteText Method (ITextChangeType, Int32, Int32, ITextChangeOptions)

ITextDocumentDeleteText Method (ITextChangeType, Int32, Int32, ITextChangeOptions)

Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool DeleteText(
    ITextChangeType type,
    int offset,
    int length,
    ITextChangeOptions options
)
Function DeleteText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The starting offset at which to delete.
length
Type: SystemInt32
The number of characters to delete.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.InsertText Method

ITextDocumentInsertText Method

Overload List
 | Name | Description
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.InsertText Method (ITextChangeType, Int32, String)

ITextDocumentInsertText Method (ITextChangeType, Int32, String)

Performs an insert text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool InsertText(
    ITextChangeType type,
    int offset,
    string text
)
Function InsertText (
    type As ITextChangeType,
    offset As Integer,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds an insert operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
InsertText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)


ITextDocument.InsertText Method (ITextChangeType, Int32, String, ITextChangeOptions)

ITextDocumentInsertText Method (ITextChangeType, Int32, String, ITextChangeOptions)

Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool InsertText(
    ITextChangeType type,
    int offset,
    string text,
    ITextChangeOptions options
)
Function InsertText (
    type As ITextChangeType,
    offset As Integer,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds an insert operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
InsertText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.IsTextRangeReadOnly Method

ITextDocumentIsTextRangeReadOnly Method

Returns whether any character in the specified TextRange is flagged as read-only.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsTextRangeReadOnly(
    TextRange textRange
)
Function IsTextRangeReadOnly (
    textRange As TextRange
) As Boolean

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if any character in the specified TextRange is flagged as read-only; otherwise, false.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.LoadFile Method

ITextDocumentLoadFile Method

Overload List
 | Name | Description
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding.
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding.
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.LoadFile Method (String)

ITextDocumentLoadFile Method (String)

Loads document text from a file, using the default UTF-8 character encoding.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
LineTerminator LoadFile(
    string path
)
Function LoadFile (
    path As String
) As LineTerminator

Parameters

path
Type: SystemString
The full path of the file from which to load.

Return Value

Type: LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.
Remarks
This method updates the value of the FileName property.
See Also

Reference

ITextDocument Interface
LoadFile Overload
ActiproSoftware.Text Namespace


ITextDocument.LoadFile Method (Stream, Encoding)

ITextDocumentLoadFile Method (Stream, Encoding)

Loads document text from a Stream using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
LineTerminator LoadFile(
    Stream stream,
    Encoding encoding
)
Function LoadFile (
    stream As Stream,
    encoding As Encoding
) As LineTerminator

Parameters

stream
Type: System.IOStream
The Stream from which to load.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.

Return Value

Type: LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.
See Also

Reference

ITextDocument Interface
LoadFile Overload
ActiproSoftware.Text Namespace


ITextDocument.LoadFile Method (String, Encoding)

ITextDocumentLoadFile Method (String, Encoding)

Loads document text from a file using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
LineTerminator LoadFile(
    string path,
    Encoding encoding
)
Function LoadFile (
    path As String,
    encoding As Encoding
) As LineTerminator

Parameters

path
Type: SystemString
The full path of the file from which to load.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.

Return Value

Type: LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.
Remarks
This method updates the value of the FileName property.
See Also

Reference

ITextDocument Interface
LoadFile Overload
ActiproSoftware.Text Namespace


ITextDocument.RemoveTextChangedEventHandler Method

ITextDocumentRemoveTextChangedEventHandler Method

Removes an event handler for the TextChanged event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void RemoveTextChangedEventHandler(
    EventHandler<TextSnapshotChangedEventArgs> handler,
    EventHandlerPriority priority
)
Sub RemoveTextChangedEventHandler (
    handler As EventHandler(Of TextSnapshotChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.RemoveTextChangingEventHandler Method

ITextDocumentRemoveTextChangingEventHandler Method

Removes an event handler for the TextChanging event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void RemoveTextChangingEventHandler(
    EventHandler<TextSnapshotChangingEventArgs> handler,
    EventHandlerPriority priority
)
Sub RemoveTextChangingEventHandler (
    handler As EventHandler(Of TextSnapshotChangingEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangingEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.ReplaceAll Method

ITextDocumentReplaceAll Method

Overload List
 | Name | Description
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.ReplaceAll Method (ISearchOptions)

ITextDocumentReplaceAll Method (ISearchOptions)

Performs a replace all operation in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceAll(
    ISearchOptions options
)
Function ReplaceAll (
    options As ISearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextDocument Interface
ReplaceAll Overload
ActiproSoftware.Text Namespace


ITextDocument.ReplaceAll Method (ISearchOptions, TextRange[])

ITextDocumentReplaceAll Method (ISearchOptions, TextRange)

Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceAll(
    ISearchOptions options,
    params TextRange[] searchTextRanges
)
Function ReplaceAll (
    options As ISearchOptions,
    ParamArray searchTextRanges As TextRange()
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRanges
Type: ActiproSoftware.TextTextRange
The TextRange array of offsets to search. If everything should be searched, specify the range 0 to the length of the document's current snapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextDocument Interface
ReplaceAll Overload
ActiproSoftware.Text Namespace


ITextDocument.ReplaceNext Method

ITextDocumentReplaceNext Method

Overload List
 | Name | Description
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.ReplaceNext Method (ISearchOptions, Int32, Boolean)

ITextDocumentReplaceNext Method (ISearchOptions, Int32, Boolean)

Performs a replace next operation in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap
)
Function ReplaceNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextDocument Interface
ReplaceNext Overload
ActiproSoftware.Text Namespace


ITextDocument.ReplaceNext Method (ISearchOptions, Int32, Boolean, TextRange)

ITextDocumentReplaceNext Method (ISearchOptions, Int32, Boolean, TextRange)

Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Function ReplaceNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextDocument Interface
ReplaceNext Overload
ActiproSoftware.Text Namespace


ITextDocument.ReplaceText Method

ITextDocumentReplaceText Method

Overload List
 | Name | Description
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.ReplaceText Method (ITextChangeType, TextRange, String)

ITextDocumentReplaceText Method (ITextChangeType, TextRange, String)

Performs a replace text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReplaceText(
    ITextChangeType type,
    TextRange textRange,
    string text
)
Function ReplaceText (
    type As ITextChangeType,
    textRange As TextRange,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentDeleteText(ITextChangeType, TextRange)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.ReplaceText Method (ITextChangeType, TextRange, String, ITextChangeOptions)

ITextDocumentReplaceText Method (ITextChangeType, TextRange, String, ITextChangeOptions)

Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReplaceText(
    ITextChangeType type,
    TextRange textRange,
    string text,
    ITextChangeOptions options
)
Function ReplaceText (
    type As ITextChangeType,
    textRange As TextRange,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentDeleteText(ITextChangeType, TextRange, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.ReplaceText Method (ITextChangeType, Int32, Int32, String)

ITextDocumentReplaceText Method (ITextChangeType, Int32, Int32, String)

Performs a replace text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReplaceText(
    ITextChangeType type,
    int offset,
    int length,
    string text
)
Function ReplaceText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
length
Type: SystemInt32
The number of characters to delete before inserting the text.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.ReplaceText Method (ITextChangeType, Int32, Int32, String, ITextChangeOptions)

ITextDocumentReplaceText Method (ITextChangeType, Int32, Int32, String, ITextChangeOptions)

Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReplaceText(
    ITextChangeType type,
    int offset,
    int length,
    string text,
    ITextChangeOptions options
)
Function ReplaceText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
length
Type: SystemInt32
The number of characters to delete before inserting the text.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.SaveFile Method

ITextDocumentSaveFile Method

Overload List
 | Name | Description
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file.
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding.
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.SaveFile Method (String, LineTerminator)

ITextDocumentSaveFile Method (String, LineTerminator)

Saves document text to a UTF-8 encoded file.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void SaveFile(
    string path,
    LineTerminator lineTerminator
)
Sub SaveFile (
    path As String,
    lineTerminator As LineTerminator
)

Parameters

path
Type: SystemString
The full path of the file of which to save.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.
Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

ITextDocument Interface
SaveFile Overload
ActiproSoftware.Text Namespace


ITextDocument.SaveFile Method (Stream, Encoding, LineTerminator)

ITextDocumentSaveFile Method (Stream, Encoding, LineTerminator)

Saves document text to a Stream using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void SaveFile(
    Stream stream,
    Encoding encoding,
    LineTerminator lineTerminator
)
Sub SaveFile (
    stream As Stream,
    encoding As Encoding,
    lineTerminator As LineTerminator
)

Parameters

stream
Type: System.IOStream
The Stream to write to.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.
See Also

Reference

ITextDocument Interface
SaveFile Overload
ActiproSoftware.Text Namespace


ITextDocument.SaveFile Method (String, Encoding, LineTerminator)

ITextDocumentSaveFile Method (String, Encoding, LineTerminator)

Saves document text to a file using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void SaveFile(
    string path,
    Encoding encoding,
    LineTerminator lineTerminator
)
Sub SaveFile (
    path As String,
    encoding As Encoding,
    lineTerminator As LineTerminator
)

Parameters

path
Type: SystemString
The full path of the file of which to save.
encoding
Type: System.TextEncoding
The Encoding to use when saving the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.
Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

ITextDocument Interface
SaveFile Overload
ActiproSoftware.Text Namespace


ITextDocument.SetHeaderAndFooterText Method

ITextDocumentSetHeaderAndFooterText Method

Sets the HeaderText and FooterText, and creates a new snapshot with the results.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool SetHeaderAndFooterText(
    string headerText,
    string footerText
)
Function SetHeaderAndFooterText (
    headerText As String,
    footerText As String
) As Boolean

Parameters

headerText
Type: SystemString
The new header text value.
footerText
Type: SystemString
The new footer text value.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.SetText Method

ITextDocumentSetText Method

Overload List
 | Name | Description
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.SetText Method (String)

ITextDocumentSetText Method (String)

Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool SetText(
    string text
)
Function SetText (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
A programmatic text replacement means that the undo history will be cleared, and any attached editors will reset the caret to offset 0.

This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.

See Also

Reference

ITextDocument Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextDocumentSetText(ITextChangeType, String)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.SetText Method (ITextChangeType, String)

ITextDocumentSetText Method (ITextChangeType, String)

Replaces all the text in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool SetText(
    ITextChangeType type,
    string text
)
Function SetText (
    type As ITextChangeType,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)


ITextDocument.SetText Method (ITextChangeType, String, ITextChangeOptions)

ITextDocumentSetText Method (ITextChangeType, String, ITextChangeOptions)

Replaces all the text in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool SetText(
    ITextChangeType type,
    string text,
    ITextChangeOptions options
)
Function SetText (
    type As ITextChangeType,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)


ITextDocument Events

The ITextDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed.
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed.
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed.
Public event | TextChanged | Occurs after a text change occurs to this document.
Public event | TextChanging | Occurs before a text change occurs to this document.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.FileNameChanged Event

ITextDocumentFileNameChanged Event

Occurs after the value of the FileName property has changed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<StringPropertyChangedEventArgs> FileNameChanged
Event FileNameChanged As EventHandler(Of StringPropertyChangedEventArgs)

Value

Type: SystemEventHandler StringPropertyChangedEventArgs
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.IsModifiedChanged Event

ITextDocumentIsModifiedChanged Event

Occurs after the value of the IsModified property has changed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler IsModifiedChanged
Event IsModifiedChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.IsReadOnlyChanged Event

ITextDocumentIsReadOnlyChanged Event

Occurs after the value of the IsReadOnly property has changed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler IsReadOnlyChanged
Event IsReadOnlyChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.TabSizeChanged Event

ITextDocumentTabSizeChanged Event

Occurs after the value of the TabSize property has changed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler TabSizeChanged
Event TabSizeChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.TextChanged Event

ITextDocumentTextChanged Event

Occurs after a text change occurs to this document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<TextSnapshotChangedEventArgs> TextChanged
Event TextChanged As EventHandler(Of TextSnapshotChangedEventArgs)

Value

Type: SystemEventHandler TextSnapshotChangedEventArgs
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.TextChanging Event

ITextDocumentTextChanging Event

Occurs before a text change occurs to this document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<TextSnapshotChangingEventArgs> TextChanging
Event TextChanging As EventHandler(Of TextSnapshotChangingEventArgs)

Value

Type: SystemEventHandler TextSnapshotChangingEventArgs
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextFormatter Interface

Provides the base requirements of a language formatter that can adjust the whitespace layout of text for better readability.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextFormatter
Public Interface ITextFormatter

The ITextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace


ITextFormatter Methods

The ITextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
See Also

Reference

ITextFormatter Interface
ActiproSoftware.Text Namespace


ITextFormatter.Format Method

ITextFormatterFormat Method

Applies text formatting to part or all of a snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Format(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection selectionPositionRanges,
    TextFormatMode mode = TextFormatMode.Ranges
)
Sub Format (
    snapshot As ITextSnapshot,
    selectionPositionRanges As ITextPositionRangeCollection,
    Optional mode As TextFormatMode = TextFormatMode.Ranges
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
selectionPositionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the selection position ranges. These are used to translate the current selection to the new snapshot that is created, even when formatting the entire snapshot.
mode (Optional)
Type: ActiproSoftware.TextTextFormatMode
A TextFormatMode indicating whether to format part or all of the snapshot. The default value is Ranges.
Remarks
The containing ITextDocument is accessible via the ITextSnapshot.
See Also

Reference

ITextFormatter Interface
ActiproSoftware.Text Namespace


ITextPositionRangeCollection Interface

Provides the base requirements for a sorted TextPositionRange collection, with one of the entries marked as primary.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextPositionRangeCollection : IEnumerable<TextPositionRange>,
    IEnumerable
Public Interface ITextPositionRangeCollection
    Inherits IEnumerable(Of TextPositionRange), IEnumerable

The ITextPositionRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of ranges in the collection.
Public property | IsBlock | Gets whether the ranges in the collection designate a special rectangular block.
Public property | Item | Gets the child TextPositionRange at the specified index.
Public property | Primary | Gets the TextPositionRange that is the primary one.
Public property | PrimaryIndex | Gets the index of the primary TextPositionRange within the collection.
Top
Methods
 | Name | Description
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable TextPositionRange .)
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextPositionRangeCollection Properties

The ITextPositionRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of ranges in the collection.
Public property | IsBlock | Gets whether the ranges in the collection designate a special rectangular block.
Public property | Item | Gets the child TextPositionRange at the specified index.
Public property | Primary | Gets the TextPositionRange that is the primary one.
Public property | PrimaryIndex | Gets the index of the primary TextPositionRange within the collection.
Top
See Also

Reference

ITextPositionRangeCollection Interface
ActiproSoftware.Text Namespace


ITextPositionRangeCollection.Count Property

ITextPositionRangeCollectionCount Property

Gets the number of ranges in the collection.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of ranges in the collection.
See Also

Reference

ITextPositionRangeCollection Interface
ActiproSoftware.Text Namespace


ITextPositionRangeCollection.IsBlock Property

ITextPositionRangeCollectionIsBlock Property

Gets whether the ranges in the collection designate a special rectangular block.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsBlock { get; }
ReadOnly Property IsBlock As Boolean
    Get

Property Value

Type: Boolean
true if the ranges in the collection designate a special rectangular block; otherwise, false.
See Also

Reference

ITextPositionRangeCollection Interface
ActiproSoftware.Text Namespace


ITextPositionRangeCollection.Item Property

ITextPositionRangeCollectionItem Property

Gets the child TextPositionRange at the specified index.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPositionRange this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As TextPositionRange
    Get

Parameters

index
Type: SystemInt32
The zero-based index of the child TextPositionRange.

Property Value

Type: TextPositionRange
The child TextPositionRange at the specified index.
See Also

Reference

ITextPositionRangeCollection Interface
ActiproSoftware.Text Namespace


ITextPositionRangeCollection.Primary Property

ITextPositionRangeCollectionPrimary Property

Gets the TextPositionRange that is the primary one.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPositionRange Primary { get; }
ReadOnly Property Primary As TextPositionRange
    Get

Property Value

Type: TextPositionRange
The TextPositionRange that is the primary one.
See Also

Reference

ITextPositionRangeCollection Interface
ActiproSoftware.Text Namespace


ITextPositionRangeCollection.PrimaryIndex Property

ITextPositionRangeCollectionPrimaryIndex Property

Gets the index of the primary TextPositionRange within the collection.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int PrimaryIndex { get; }
ReadOnly Property PrimaryIndex As Integer
    Get

Property Value

Type: Int32
The index of the primary TextPositionRange within the collection.
See Also

Reference

ITextPositionRangeCollection Interface
ActiproSoftware.Text Namespace


ITextPositionRangeCollection Methods

The ITextPositionRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable TextPositionRange .)
Top
See Also

Reference

ITextPositionRangeCollection Interface
ActiproSoftware.Text Namespace


ITextPositionRangeCollection.BinarySearch Method

ITextPositionRangeCollectionBinarySearch Method

Performs a binary search for the specified value.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int BinarySearch(
    TextPosition value
)
Function BinarySearch (
    value As TextPosition
) As Integer

Parameters

value
Type: ActiproSoftware.TextTextPosition
The value for which to search.

Return Value

Type: Int32
The index of the specified value in the specified array, if value is found. If value is not found and value is less than one or more elements in array, a negative number which is the bitwise complement of the index of the first element that is larger than value. If value is not found and value is greater than any of the elements in array, a negative number which is the bitwise complement of (the index of the last element plus 1).
See Also

Reference

ITextPositionRangeCollection Interface
ActiproSoftware.Text Namespace


ITextPositionRangeProvider Interface

Provides the base requirements for an object that has range of two TextPosition values within a text document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextPositionRangeProvider
Public Interface ITextPositionRangeProvider

The ITextPositionRangeProvider type exposes the following members.

Properties
 | Name | Description
Public property | PositionRange | Gets or sets a TextPositionRange that specifies the text position range of the object.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextPositionRangeProvider Properties

The ITextPositionRangeProvider type exposes the following members.

Properties
 | Name | Description
Public property | PositionRange | Gets or sets a TextPositionRange that specifies the text position range of the object.
Top
See Also

Reference

ITextPositionRangeProvider Interface
ActiproSoftware.Text Namespace


ITextPositionRangeProvider.PositionRange Property

ITextPositionRangeProviderPositionRange Property

Gets or sets a TextPositionRange that specifies the text position range of the object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPositionRange PositionRange { get; set; }
Property PositionRange As TextPositionRange
    Get
    Set

Property Value

Type: TextPositionRange
A TextPositionRange that specifies the text position range of the object.
Remarks
Note that not all objects implement a setter for this property and in the cases of those who don't, an exception may be thrown.
See Also

Reference

ITextPositionRangeProvider Interface
ActiproSoftware.Text Namespace


ITextRangeProvider Interface

Provides the base requirements for an object that has range of two offset values within a text document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextRangeProvider
Public Interface ITextRangeProvider

The ITextRangeProvider type exposes the following members.

Properties
 | Name | Description
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextRangeProvider Properties

The ITextRangeProvider type exposes the following members.

Properties
 | Name | Description
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object.
Top
See Also

Reference

ITextRangeProvider Interface
ActiproSoftware.Text Namespace


ITextRangeProvider.TextRange Property

ITextRangeProviderTextRange Property

Gets or sets a TextRange that specifies the text range of the object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange TextRange { get; set; }
Property TextRange As TextRange
    Get
    Set

Property Value

Type: TextRange
A TextRange that specifies the text range of the object.
Remarks
Note that not all objects implement a setter for this property and in the cases of those who don't, an exception may be thrown.
See Also

Reference

ITextRangeProvider Interface
ActiproSoftware.Text Namespace


ITextSnapshot Interface

Provides the base requirements for an immutable snapshot of an ITextDocument for a certain ITextVersion of that document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextSnapshot : ITextRangeProvider
Public Interface ITextSnapshot
    Inherits ITextRangeProvider

The ITextSnapshot type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this snapshot applies.
Public property | FooterText | Gets the footer text to append to the end of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.
Public property | HasContent | Gets whether there is content in the snapshot.
Public property | HeaderText | Gets the header text to append to the start of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.
Public property | Item | Gets a character in the snapshot.
Public property | Length | Gets the number of characters in the snapshot, excluding any carriage-returns but including newlines.
Public property | Lines | Gets the collection of ITextSnapshotLine objects, each of which represents a line in the snapshot.
Public property | SnapshotRange | Gets a TextSnapshotRange that contains the entire text snapshot.
Public property | Text | Gets the entire text of the snapshot using CarriageReturnNewline for line ends, which is not intended to be used for parsing for classification reasons.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | Version | Gets the ITextVersion that specifies the text version represented by the snapshot.
Top
Methods
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | Export | Exports the contents of the snapshot to another text format, such as HTML or RTF.
Public method | ExportToFile | Exports the contents of the snapshot to a file in another text format, such as HTML or RTF.
Public method | FindAll(ISearchOptions) | Performs a find all operation.
Public method | FindAll(ISearchOptions, TextRange) | Performs a find all operation over a specific range of the snapshot.
Public method | FindNext(ISearchOptions, Int32, Boolean) | Performs a find next operation.
Public method | FindNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a find next operation over a specific range of the snapshot.
Public method | GetMergedBufferReader | Returns an ITextBufferReader that allows scanning over a union of the HeaderText, Text, and FooterText.
Public method | GetReader(Int32) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetReader(TextPosition) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetSubstring(TextRange) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(Int32, Int32) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(TextRange, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetSubstring(Int32, Int32, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetText | Returns the entire text of the snapshot using the specified LineTerminator for line ends.
Public method | GetTextStatistics | Returns an ITextStatistics for the snapshot's text, which provides numerous statistics about the text such as word, sentence, character counts as well as readability scores.
Public method | GetWordText | Gets the text of the word at the specified offset.
Public method | GetWordTextRange | Gets a TextRange of offsets that contain the word at the specified offset.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | PositionRangeToTextRange | Returns the TextRange that represents the specified TextPositionRange within the snapshot.
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the text lines.
Public method | TextRangeToPositionRange | Returns the TextPositionRange that represents the specified TextRange within the snapshot.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextSnapshot Properties

The ITextSnapshot type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this snapshot applies.
Public property | FooterText | Gets the footer text to append to the end of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.
Public property | HasContent | Gets whether there is content in the snapshot.
Public property | HeaderText | Gets the header text to append to the start of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.
Public property | Item | Gets a character in the snapshot.
Public property | Length | Gets the number of characters in the snapshot, excluding any carriage-returns but including newlines.
Public property | Lines | Gets the collection of ITextSnapshotLine objects, each of which represents a line in the snapshot.
Public property | SnapshotRange | Gets a TextSnapshotRange that contains the entire text snapshot.
Public property | Text | Gets the entire text of the snapshot using CarriageReturnNewline for line ends, which is not intended to be used for parsing for classification reasons.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | Version | Gets the ITextVersion that specifies the text version represented by the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Document Property

ITextSnapshotDocument Property

Gets the ITextDocument for which this snapshot applies.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextDocument Document { get; }
ReadOnly Property Document As ITextDocument
    Get

Property Value

Type: ITextDocument
The ITextDocument for which this snapshot applies.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.FooterText Property

ITextSnapshotFooterText Property

Gets the footer text to append to the end of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FooterText { get; }
ReadOnly Property FooterText As String
    Get

Property Value

Type: String
The footer text to append to the end of the snapshot's Text.
Remarks
The use of this property, along with HeaderText, allows for editing 'fragments' of code. The header and footer sections provide the outer code that surrounds the 'fragment' being edited in the snapshot's Text property.

An example is when editing a method body in a language like C#. The HeaderText would contain the namespace, class, and member declaration starts. The FooterText would contain the namespace, class, and member declaration ends. The document would edit the 'fragment' of statements within the header and footer, and all of them would be combined for parsing purposes.

See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace
ITextSnapshotGetMergedBufferReader
ITextSnapshotHeaderText
ITextSnapshotText


ITextSnapshot.HasContent Property

ITextSnapshotHasContent Property

Gets whether there is content in the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasContent { get; }
ReadOnly Property HasContent As Boolean
    Get

Property Value

Type: Boolean
true if there is content in the snapshot; otherwise, false.
Remarks
This property simply checks whether the snapshot has a length greater than 0.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.HeaderText Property

ITextSnapshotHeaderText Property

Gets the header text to append to the start of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string HeaderText { get; }
ReadOnly Property HeaderText As String
    Get

Property Value

Type: String
The header text to append to the start of the snapshot's Text.
Remarks
The use of this property, along with FooterText, allows for editing 'fragments' of code. The header and footer sections provide the outer code that surrounds the 'fragment' being edited in the snapshot's Text property.

An example is when editing a method body in a language like C#. The HeaderText would contain the namespace, class, and member declaration starts. The FooterText would contain the namespace, class, and member declaration ends. The document would edit the 'fragment' of statements within the header and footer, and all of them would be combined for parsing purposes.

See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace
ITextSnapshotGetMergedBufferReader
ITextSnapshotHeaderText
ITextSnapshotText


ITextSnapshot.Item Property

ITextSnapshotItem Property

Gets a character in the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As Char
    Get

Parameters

index
Type: SystemInt32
The index of the character to return.

Property Value

Type: Char
A character in the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Length Property

ITextSnapshotLength Property

Gets the number of characters in the snapshot, excluding any carriage-returns but including newlines.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters in the snapshot, excluding any carriage-returns but including newlines.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Lines Property

ITextSnapshotLines Property

Gets the collection of ITextSnapshotLine objects, each of which represents a line in the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshotLineCollection Lines { get; }
ReadOnly Property Lines As ITextSnapshotLineCollection
    Get

Property Value

Type: ITextSnapshotLineCollection
A ITextSnapshotLineCollection containing the lines in the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.SnapshotRange Property

ITextSnapshotSnapshotRange Property

Gets a TextSnapshotRange that contains the entire text snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the entire text snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Text Property

ITextSnapshotText Property

Gets the entire text of the snapshot using CarriageReturnNewline for line ends, which is not intended to be used for parsing for classification reasons.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The entire text of the snapshot using CarriageReturnNewline for line ends.
Remarks
This property should not be used as input for language parsers or taggers since internally for performance reasons, text is stored with newlines-only as line terminators. Instead, call GetText(LineTerminator) with the Newline parameter when needing the text for parsing or tagging reasons.

The GetText(LineTerminator) method can be used to obtain text using any of the LineTerminator options.

See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Version Property

ITextSnapshotVersion Property

Gets the ITextVersion that specifies the text version represented by the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextVersion Version { get; }
ReadOnly Property Version As ITextVersion
    Get

Property Value

Type: ITextVersion
The ITextVersion that specifies the text version represented by the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot Methods

The ITextSnapshot type exposes the following members.

Methods
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | Export | Exports the contents of the snapshot to another text format, such as HTML or RTF.
Public method | ExportToFile | Exports the contents of the snapshot to a file in another text format, such as HTML or RTF.
Public method | FindAll(ISearchOptions) | Performs a find all operation.
Public method | FindAll(ISearchOptions, TextRange) | Performs a find all operation over a specific range of the snapshot.
Public method | FindNext(ISearchOptions, Int32, Boolean) | Performs a find next operation.
Public method | FindNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a find next operation over a specific range of the snapshot.
Public method | GetMergedBufferReader | Returns an ITextBufferReader that allows scanning over a union of the HeaderText, Text, and FooterText.
Public method | GetReader(Int32) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetReader(TextPosition) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetSubstring(TextRange) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(Int32, Int32) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(TextRange, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetSubstring(Int32, Int32, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetText | Returns the entire text of the snapshot using the specified LineTerminator for line ends.
Public method | GetTextStatistics | Returns an ITextStatistics for the snapshot's text, which provides numerous statistics about the text such as word, sentence, character counts as well as readability scores.
Public method | GetWordText | Gets the text of the word at the specified offset.
Public method | GetWordTextRange | Gets a TextRange of offsets that contain the word at the specified offset.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | PositionRangeToTextRange | Returns the TextRange that represents the specified TextPositionRange within the snapshot.
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the text lines.
Public method | TextRangeToPositionRange | Returns the TextPositionRange that represents the specified TextRange within the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.CreateTextChange Method

ITextSnapshotCreateTextChange Method

Overload List
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.CreateTextChange Method (ITextChangeType)

ITextSnapshotCreateTextChange Method (ITextChangeType)

Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextChange CreateTextChange(
    ITextChangeType type
)
Function CreateTextChange (
    type As ITextChangeType
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.

Return Value

Type: ITextChange
The ITextChange that was created.
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

ITextSnapshot Interface
CreateTextChange Overload
ActiproSoftware.Text Namespace


ITextSnapshot.CreateTextChange Method (ITextChangeType, ITextChangeOptions)

ITextSnapshotCreateTextChange Method (ITextChangeType, ITextChangeOptions)

Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextChange CreateTextChange(
    ITextChangeType type,
    ITextChangeOptions options
)
Function CreateTextChange (
    type As ITextChangeType,
    options As ITextChangeOptions
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: ITextChange
The ITextChange that was created.
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

ITextSnapshot Interface
CreateTextChange Overload
ActiproSoftware.Text Namespace


ITextSnapshot.Export Method

ITextSnapshotExport Method

Exports the contents of the snapshot to another text format, such as HTML or RTF.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Export(
    ITextExporter exporter
)
Function Export (
    exporter As ITextExporter
) As String

Parameters

exporter
Type: ActiproSoftware.Text.ExportersITextExporter
The ITextExporter to use for the export operation.

Return Value

Type: String
The exported text.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.ExportToFile Method

ITextSnapshotExportToFile Method

Exports the contents of the snapshot to a file in another text format, such as HTML or RTF.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void ExportToFile(
    ITextExporter exporter,
    string path
)
Sub ExportToFile (
    exporter As ITextExporter,
    path As String
)

Parameters

exporter
Type: ActiproSoftware.Text.ExportersITextExporter
The ITextExporter to use for the export operation.
path
Type: SystemString
The full path of the file of which to save.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.FindAll Method

ITextSnapshotFindAll Method

Overload List
 | Name | Description
Public method | FindAll(ISearchOptions) | Performs a find all operation.
Public method | FindAll(ISearchOptions, TextRange) | Performs a find all operation over a specific range of the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.FindAll Method (ISearchOptions)

ITextSnapshotFindAll Method (ISearchOptions)

Performs a find all operation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchResultSet FindAll(
    ISearchOptions options
)
Function FindAll (
    options As ISearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextSnapshot Interface
FindAll Overload
ActiproSoftware.Text Namespace


ITextSnapshot.FindAll Method (ISearchOptions, TextRange)

ITextSnapshotFindAll Method (ISearchOptions, TextRange)

Performs a find all operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchResultSet FindAll(
    ISearchOptions options,
    TextRange searchTextRange
)
Function FindAll (
    options As ISearchOptions,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the snapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextSnapshot Interface
FindAll Overload
ActiproSoftware.Text Namespace


ITextSnapshot.FindNext Method

ITextSnapshotFindNext Method

Overload List
 | Name | Description
Public method | FindNext(ISearchOptions, Int32, Boolean) | Performs a find next operation.
Public method | FindNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a find next operation over a specific range of the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.FindNext Method (ISearchOptions, Int32, Boolean)

ITextSnapshotFindNext Method (ISearchOptions, Int32, Boolean)

Performs a find next operation.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchResultSet FindNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap
)
Function FindNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextSnapshot Interface
FindNext Overload
ActiproSoftware.Text Namespace


ITextSnapshot.FindNext Method (ISearchOptions, Int32, Boolean, TextRange)

ITextSnapshotFindNext Method (ISearchOptions, Int32, Boolean, TextRange)

Performs a find next operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchResultSet FindNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Function FindNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextSnapshot Interface
FindNext Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetMergedBufferReader Method

ITextSnapshotGetMergedBufferReader Method

Returns an ITextBufferReader that allows scanning over a union of the HeaderText, Text, and FooterText.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextBufferReader GetMergedBufferReader()
Function GetMergedBufferReader As ITextBufferReader

Return Value

Type: ITextBufferReader
An ITextBufferReader that allows scanning over a union of the HeaderText, Text, and FooterText.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace
ITextSnapshotFooterText
ITextSnapshotHeaderText
ITextSnapshotText


ITextSnapshot.GetReader Method

ITextSnapshotGetReader Method

Overload List
 | Name | Description
Public method | GetReader(Int32) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetReader(TextPosition) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetReader Method (Int32)

ITextSnapshotGetReader Method (Int32)

Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshotReader GetReader(
    int offset
)
Function GetReader (
    offset As Integer
) As ITextSnapshotReader

Parameters

offset
Type: SystemInt32
The offset at which to initalize the reader.

Return Value

Type: ITextSnapshotReader
An ITextBufferReader that can be used to navigate through the text and token contents of the snapshot.
See Also

Reference

ITextSnapshot Interface
GetReader Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetReader Method (TextPosition)

ITextSnapshotGetReader Method (TextPosition)

Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshotReader GetReader(
    TextPosition position
)
Function GetReader (
    position As TextPosition
) As ITextSnapshotReader

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition at which to initalize the reader.

Return Value

Type: ITextSnapshotReader
An ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
See Also

Reference

ITextSnapshot Interface
GetReader Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method

ITextSnapshotGetSubstring Method

Overload List
 | Name | Description
Public method | GetSubstring(TextRange) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(Int32, Int32) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(TextRange, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetSubstring(Int32, Int32, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method (TextRange)

ITextSnapshotGetSubstring Method (TextRange)

Returns a substring from the snapshot text using CarriageReturnNewline for line ends.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetSubstring(
    TextRange textRange
)
Function GetSubstring (
    textRange As TextRange
) As String

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text to retrieve.

Return Value

Type: String
The substring from the snapshot text using CarriageReturnNewline for line ends.
See Also

Reference

ITextSnapshot Interface
GetSubstring Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method (Int32, Int32)

ITextSnapshotGetSubstring Method (Int32, Int32)

Returns a substring from the snapshot text using CarriageReturnNewline for line ends.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetSubstring(
    int offset,
    int length
)
Function GetSubstring (
    offset As Integer,
    length As Integer
) As String

Parameters

offset
Type: SystemInt32
The offset at which to retrieve the text.
length
Type: SystemInt32
The number of characters to return.

Return Value

Type: String
The substring from the snapshot text using CarriageReturnNewline for line ends.
See Also

Reference

ITextSnapshot Interface
GetSubstring Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method (TextRange, LineTerminator)

ITextSnapshotGetSubstring Method (TextRange, LineTerminator)

Returns a substring from the snapshot text using the specified LineTerminator for line ends.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetSubstring(
    TextRange textRange,
    LineTerminator lineTerminator
)
Function GetSubstring (
    textRange As TextRange,
    lineTerminator As LineTerminator
) As String

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text to retrieve.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the type of line terminators to use.

Return Value

Type: String
The substring from the snapshot text using the specified LineTerminator for line ends.
See Also

Reference

ITextSnapshot Interface
GetSubstring Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method (Int32, Int32, LineTerminator)

ITextSnapshotGetSubstring Method (Int32, Int32, LineTerminator)

Returns a substring from the snapshot text using the specified LineTerminator for line ends.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetSubstring(
    int offset,
    int length,
    LineTerminator lineTerminator
)
Function GetSubstring (
    offset As Integer,
    length As Integer,
    lineTerminator As LineTerminator
) As String

Parameters

offset
Type: SystemInt32
The offset at which to retrieve the text.
length
Type: SystemInt32
The number of characters to return.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the type of line terminators to use.

Return Value

Type: String
The substring from the snapshot text using the specified LineTerminator for line ends.
See Also

Reference

ITextSnapshot Interface
GetSubstring Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetText Method

ITextSnapshotGetText Method

Returns the entire text of the snapshot using the specified LineTerminator for line ends.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetText(
    LineTerminator lineTerminator
)
Function GetText (
    lineTerminator As LineTerminator
) As String

Parameters

lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the type of line terminators to use.

Return Value

Type: String
The entire text of the snapshot using the specified LineTerminator for line ends.
Remarks
To retrieve the text in the format expected by a language parser or tagger, pass Newline as the lineTerminator parameter.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetTextStatistics Method

ITextSnapshotGetTextStatistics Method

Returns an ITextStatistics for the snapshot's text, which provides numerous statistics about the text such as word, sentence, character counts as well as readability scores.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextStatistics GetTextStatistics()
Function GetTextStatistics As ITextStatistics

Return Value

Type: ITextStatistics
An ITextStatistics for the snapshot's text.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetWordText Method

ITextSnapshotGetWordText Method

Gets the text of the word at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetWordText(
    int offset
)
Function GetWordText (
    offset As Integer
) As String

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: String
The text of the word at the specified offset.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetWordTextRange Method

ITextSnapshotGetWordTextRange Method

Gets a TextRange of offsets that contain the word at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange GetWordTextRange(
    int offset
)
Function GetWordTextRange (
    offset As Integer
) As TextRange

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: TextRange
A TextRange containing a range of offsets that contain the word at the specified offset.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.OffsetToPosition Method

ITextSnapshotOffsetToPosition Method

Returns the TextPosition that represents the specified offset within the text lines.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition OffsetToPosition(
    int offset
)
Function OffsetToPosition (
    offset As Integer
) As TextPosition

Parameters

offset
Type: SystemInt32
The offset of a character within the snapshot.

Return Value

Type: TextPosition
The TextPosition that represents the specified offset within the text lines.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.PositionRangeToTextRange Method

ITextSnapshotPositionRangeToTextRange Method

Returns the TextRange that represents the specified TextPositionRange within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange PositionRangeToTextRange(
    TextPositionRange positionRange
)
Function PositionRangeToTextRange (
    positionRange As TextPositionRange
) As TextRange

Parameters

positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange within the snapshot.

Return Value

Type: TextRange
The TextRange that represents the specified TextPositionRange within the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.PositionToOffset Method

ITextSnapshotPositionToOffset Method

Returns the offset for the specified TextPosition within the text lines.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int PositionToOffset(
    TextPosition position
)
Function PositionToOffset (
    position As TextPosition
) As Integer

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition of a character within the text lines.

Return Value

Type: Int32
The offset for the specified TextPosition within the text lines.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.TextRangeToPositionRange Method

ITextSnapshotTextRangeToPositionRange Method

Returns the TextPositionRange that represents the specified TextRange within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPositionRange TextRangeToPositionRange(
    TextRange textRange
)
Function TextRangeToPositionRange (
    textRange As TextRange
) As TextPositionRange

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange within the snapshot.

Return Value

Type: TextPositionRange
The TextPositionRange that represents the specified TextRange within the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine Interface

Provides the base requirements for a line in an ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextSnapshotLine : ITextRangeProvider
Public Interface ITextSnapshotLine
    Inherits ITextRangeProvider

The ITextSnapshotLine type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset at which the line ends, excluding the line terminator.
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line.
Public property | FirstNonWhitespaceCharacterOffset | Gets the offset of the first non-whitespace character in the line.
Public property | IndentAmount | Gets or sets the indent amount, in columns, of the line.
Public property | Index | Gets the index of the line within the ITextSnapshot.
Public property | IsLastLine | Gets whether the line contains the last offset of the document.
Public property | Length | Gets the length of the line, excluding the line terminator.
Public property | Snapshot | Gets the ITextSnapshot that contains the line.
Public property | SnapshotRange | Gets a TextSnapshotRange that contains the text of the line, excluding the line terminator.
Public property | StartOffset | Gets the offset at which the line starts.
Public property | Text | Gets the text of the line, excluding the line terminator.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the line contains the specified offset.
Public method | GetIndentAmountBefore | Returns indent amount, in columns, of the line before the specified offset.
Public method | IsLineEnd | Returns whether the specified offset ends the line.
Public method | IsLineStart | Returns whether the specified offset starts the line.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextSnapshotLine Properties

The ITextSnapshotLine type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset at which the line ends, excluding the line terminator.
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line.
Public property | FirstNonWhitespaceCharacterOffset | Gets the offset of the first non-whitespace character in the line.
Public property | IndentAmount | Gets or sets the indent amount, in columns, of the line.
Public property | Index | Gets the index of the line within the ITextSnapshot.
Public property | IsLastLine | Gets whether the line contains the last offset of the document.
Public property | Length | Gets the length of the line, excluding the line terminator.
Public property | Snapshot | Gets the ITextSnapshot that contains the line.
Public property | SnapshotRange | Gets a TextSnapshotRange that contains the text of the line, excluding the line terminator.
Public property | StartOffset | Gets the offset at which the line starts.
Public property | Text | Gets the text of the line, excluding the line terminator.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.
Top
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.EndOffset Property

ITextSnapshotLineEndOffset Property

Gets the offset at which the line ends, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int EndOffset { get; }
ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the line ends, excluding the line terminator.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.EndOffsetIncludingLineTerminator Property

ITextSnapshotLineEndOffsetIncludingLineTerminator Property

Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int EndOffsetIncludingLineTerminator { get; }
ReadOnly Property EndOffsetIncludingLineTerminator As Integer
    Get

Property Value

Type: Int32
The offset at which the line ends, including the line terminator if there is a hard line break on the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.FirstNonWhitespaceCharacterOffset Property

ITextSnapshotLineFirstNonWhitespaceCharacterOffset Property

Gets the offset of the first non-whitespace character in the line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int FirstNonWhitespaceCharacterOffset { get; }
ReadOnly Property FirstNonWhitespaceCharacterOffset As Integer
    Get

Property Value

Type: Int32
The offset of the first non-whitespace character in the line.
Remarks
If no non-whitespace character is found, the value of EndOffset is returned.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.IndentAmount Property

ITextSnapshotLineIndentAmount Property

Gets or sets the indent amount, in columns, of the line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int IndentAmount { get; set; }
Property IndentAmount As Integer
    Get
    Set

Property Value

Type: Int32
The indent amount, in columns, of the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Index Property

ITextSnapshotLineIndex Property

Gets the index of the line within the ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the line within the ITextSnapshot.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.IsLastLine Property

ITextSnapshotLineIsLastLine Property

Gets whether the line contains the last offset of the document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsLastLine { get; }
ReadOnly Property IsLastLine As Boolean
    Get

Property Value

Type: Boolean
true if the line contains the last offset of the document; otherwise, false.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Length Property

ITextSnapshotLineLength Property

Gets the length of the line, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The length of the line, excluding the line terminator.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Snapshot Property

ITextSnapshotLineSnapshot Property

Gets the ITextSnapshot that contains the line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.SnapshotRange Property

ITextSnapshotLineSnapshotRange Property

Gets a TextSnapshotRange that contains the text of the line, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the text of the line, excluding the line terminator.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.StartOffset Property

ITextSnapshotLineStartOffset Property

Gets the offset at which the line starts.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int StartOffset { get; }
ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the line starts.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Text Property

ITextSnapshotLineText Property

Gets the text of the line, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The text of the line, excluding the line terminator.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.TextRangeIncludingLineTerminator Property

ITextSnapshotLineTextRangeIncludingLineTerminator Property

Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange TextRangeIncludingLineTerminator { get; }
ReadOnly Property TextRangeIncludingLineTerminator As TextRange
    Get

Property Value

Type: TextRange
The TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine Methods

The ITextSnapshotLine type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the line contains the specified offset.
Public method | GetIndentAmountBefore | Returns indent amount, in columns, of the line before the specified offset.
Public method | IsLineEnd | Returns whether the specified offset ends the line.
Public method | IsLineStart | Returns whether the specified offset starts the line.
Top
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Contains Method

ITextSnapshotLineContains Method

Returns whether the line contains the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Contains(
    int offset
)
Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: Boolean
true if the line contains the offset; otherwise, false.
Remarks
This method returns false if the offset falls on the line terminator of the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.GetIndentAmountBefore Method

ITextSnapshotLineGetIndentAmountBefore Method

Returns indent amount, in columns, of the line before the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int GetIndentAmountBefore(
    int offset
)
Function GetIndentAmountBefore (
    offset As Integer
) As Integer

Parameters

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:ActiproSoftware.Text.ITextSnapshotLine.GetIndentAmountBefore(System.Int32)"]

Field Value

Type: Int32
The indent amount, in columns, of the line before the specified offset.

Return Value

Type: Int32

[Missing <returns> documentation for "M:ActiproSoftware.Text.ITextSnapshotLine.GetIndentAmountBefore(System.Int32)"]

See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.IsLineEnd Method

ITextSnapshotLineIsLineEnd Method

Returns whether the specified offset ends the line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsLineEnd(
    int offset
)
Function IsLineEnd (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: Boolean
true if the offset ends the line; otherwise, false.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.IsLineStart Method

ITextSnapshotLineIsLineStart Method

Returns whether the specified offset starts the line.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsLineStart(
    int offset
)
Function IsLineStart (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: Boolean
true if the offset starts the line; otherwise, false.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection Interface

Encapsulates a collection of ITextSnapshotLine objects.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextSnapshotLineCollection : IEnumerable,
    ICollection
Public Interface ITextSnapshotLineCollection
    Inherits IEnumerable, ICollection

The ITextSnapshotLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection. (Inherited from ICollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ICollection.)
Public property | Item | Gets the ITextSnapshotLine at the specified index. [C#] In C#, this property is the indexer for the ITextSnapshotLineCollection class.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ICollection.)
Top
Methods
 | Name | Description
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ICollection.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetLineTextRange | Returns the TextRange of the specified line, excluding the line terminator.
Public method | IndexOf | Finds the index of the ITextSnapshotLine that contains the specified offset.
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.TextITextSnapshotLine


ITextSnapshotLineCollection Properties

The ITextSnapshotLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection. (Inherited from ICollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ICollection.)
Public property | Item | Gets the ITextSnapshotLine at the specified index. [C#] In C#, this property is the indexer for the ITextSnapshotLineCollection class.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ICollection.)
Top
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection.Item Property

ITextSnapshotLineCollectionItem Property

Gets the ITextSnapshotLine at the specified index.

[C#] In C#, this property is the indexer for the ITextSnapshotLineCollection class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshotLine this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As ITextSnapshotLine
    Get

Parameters

index
Type: SystemInt32
The index of the ITextSnapshotLine to return.

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine at the specified index.
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection Methods

The ITextSnapshotLineCollection type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ICollection.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetLineTextRange | Returns the TextRange of the specified line, excluding the line terminator.
Public method | IndexOf | Finds the index of the ITextSnapshotLine that contains the specified offset.
Top
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection.GetLineTextRange Method

ITextSnapshotLineCollectionGetLineTextRange Method

Returns the TextRange of the specified line, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange GetLineTextRange(
    int index
)
Function GetLineTextRange (
    index As Integer
) As TextRange

Parameters

index
Type: SystemInt32
The index of the line to examine.

Return Value

Type: TextRange
The TextRange of the specified line, excluding the line terminator.
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection.IndexOf Method

ITextSnapshotLineCollectionIndexOf Method

Finds the index of the ITextSnapshotLine that contains the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int IndexOf(
    int offset
)
Function IndexOf (
    offset As Integer
) As Integer

Parameters

offset
Type: SystemInt32
The offset to look for.

Return Value

Type: Int32
The index of the ITextSnapshotLine that contains the specified offset.
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader Interface

Provides the base requirements for an object that reads through characters and tokens from an ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextSnapshotReader
Public Interface ITextSnapshotReader

The ITextSnapshotReader type exposes the following members.

Properties
 | Name | Description
Public property | BufferReader | Gets the ITextBufferReader that is wrapped by this reader and can be used for performing fast low-level text scanning on the snapshot.
Public property | Character | Gets the character at the Offset.
Public property | IsAtSnapshotEnd | Gets whether the current Offset is at the end of the snapshot.
Public property | IsAtSnapshotLineEnd | Gets whether the current Offset is at the end of an ITextSnapshotLine.
Public property | IsAtSnapshotLineStart | Gets whether the current Offset is at the start of an ITextSnapshotLine.
Public property | IsAtSnapshotStart | Gets whether the current Offset is at the start of the snapshot.
Public property | IsAtTokenStart | Gets whether the current Offset is at the start of the Token.
Public property | IsCharacterLineTerminator | Gets whether the Character is a newline character.
Public property | IsCharacterWhitespace | Gets whether the Character is categorized as a whitespace character.
Public property | Language | Gets the ISyntaxLanguage that contains the current offset within the snapshot.
Public property | Length | Gets the length of the snapshot.
Public property | Offset | Gets or sets the current offset within the snapshot.
Public property | Options | Gets the ITextSnapshotReaderOptions that contains optimization options for the reader.
Public property | Position | Gets the current TextPosition within the snapshot.
Public property | Snapshot | Gets the core ITextSnapshot that is examined by this reader.
Public property | SnapshotLine | Gets the ITextSnapshotLine that contains the Offset.
Public property | Token | Gets the IToken that contains the offset indicated by Offset.
Public property | TokenText | Gets the snapshot text contained by the Token.
Top
Methods
 | Name | Description
Public method | GoToCurrentSnapshotLineEnd | Moves the Offset to the end of the snapshot line that contains the Offset.
Public method | GoToCurrentSnapshotLineStart | Moves the Offset to the start of the snapshot line that contains the Offset.
Public method | GoToCurrentTokenStart | Moves the Offset to the start of the IToken that contains the Offset.
Public method | GoToCurrentWordEnd | Moves to the current word's end offset.
Public method | GoToCurrentWordStart | Moves to the current word's start offset.
Public method | GoToNextMatchingTokenById | Moves the Offset to the next matching token where there can be nested token pairs.
Public method | GoToNextSnapshotLineStart | Moves the Offset to the start of the snapshot line after the snapshot line that contains the Offset.
Public method | GoToNextToken | Moves to the next token's start offset.
Public method | GoToNextToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToNextToken(PredicateIToken) | Continues forward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches the specified ID.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches any of the specified IDs.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches the specified key.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches any of the specified keys.
Public method | GoToNextWordStart | Moves to the next word's start offset.
Public method | GoToPreviousMatchingTokenById | Moves the Offset to the previous matching token where there can be nested token pairs.
Public method | GoToPreviousSnapshotLineEnd | Moves the Offset to the end of the snapshot line before the snapshot line that contains the Offset.
Public method | GoToPreviousToken | Moves to the previous token's start offset.
Public method | GoToPreviousToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToPreviousToken(PredicateIToken) | Continues backward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches the specified ID.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches any of the specified IDs.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches the specified key.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches any of the specified keys.
Public method | GoToPreviousWordStart | Moves to the previous word's start character.
Public method | GoToSnapshotEnd | Moves the Offset to the end of the Snapshot.
Public method | GoToSnapshotStart | Moves the Offset to the start of the Snapshot.
Public method | PeekCharacter | Peeks at a single character without seeking past it.
Public method | PeekCharacterReverse | Reverse peeks at a single character without seeking past it.
Public method | PeekText | Peeks at a string without seeking past it.
Public method | PeekTextReverse | Reverse peeks at a string without seeking past it.
Public method | PeekToken | Peeks at a single IToken from the snapshot without seeking past it.
Public method | PeekTokenReverse | Reverse peeks at a single IToken from the snapshot without seeking past it.
Public method | ReadCharacter | Reads a single character and seeks forward one offset.
Public method | ReadCharacterReverse | Reverse reads a single character and seeks backward one offset.
Public method | ReadCharacterReverseThrough(Char) | Reverse reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterReverseThrough(Char, Int32) | Reverse reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Public method | ReadCharacterThrough(Char) | Reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterThrough(Char, Int32) | Reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Public method | ReadText | Reads a string and seeks forward to the end of it.
Public method | ReadTextReverse | Reverse reads a string and seeks backward to the start of it.
Public method | ReadToken | Reads a single IToken from the snapshot and seeks forward one IToken.
Public method | ReadTokenReverse | Reverse reads a single IToken from the snapshot and seeks backward one IToken.
Public method | SeekCharacter | Moves the Offset by the specified amount.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextSnapshotReader Properties

The ITextSnapshotReader type exposes the following members.

Properties
 | Name | Description
Public property | BufferReader | Gets the ITextBufferReader that is wrapped by this reader and can be used for performing fast low-level text scanning on the snapshot.
Public property | Character | Gets the character at the Offset.
Public property | IsAtSnapshotEnd | Gets whether the current Offset is at the end of the snapshot.
Public property | IsAtSnapshotLineEnd | Gets whether the current Offset is at the end of an ITextSnapshotLine.
Public property | IsAtSnapshotLineStart | Gets whether the current Offset is at the start of an ITextSnapshotLine.
Public property | IsAtSnapshotStart | Gets whether the current Offset is at the start of the snapshot.
Public property | IsAtTokenStart | Gets whether the current Offset is at the start of the Token.
Public property | IsCharacterLineTerminator | Gets whether the Character is a newline character.
Public property | IsCharacterWhitespace | Gets whether the Character is categorized as a whitespace character.
Public property | Language | Gets the ISyntaxLanguage that contains the current offset within the snapshot.
Public property | Length | Gets the length of the snapshot.
Public property | Offset | Gets or sets the current offset within the snapshot.
Public property | Options | Gets the ITextSnapshotReaderOptions that contains optimization options for the reader.
Public property | Position | Gets the current TextPosition within the snapshot.
Public property | Snapshot | Gets the core ITextSnapshot that is examined by this reader.
Public property | SnapshotLine | Gets the ITextSnapshotLine that contains the Offset.
Public property | Token | Gets the IToken that contains the offset indicated by Offset.
Public property | TokenText | Gets the snapshot text contained by the Token.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.BufferReader Property

ITextSnapshotReaderBufferReader Property

Gets the ITextBufferReader that is wrapped by this reader and can be used for performing fast low-level text scanning on the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextBufferReader BufferReader { get; }
ReadOnly Property BufferReader As ITextBufferReader
    Get

Property Value

Type: ITextBufferReader
The ITextBufferReader that can be used for performing fast low-level text scanning on the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Character Property

ITextSnapshotReaderCharacter Property

Gets the character at the Offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char Character { get; }
ReadOnly Property Character As Char
    Get

Property Value

Type: Char
The character at the Offset.
Remarks
This value is the same as the return value of the PeekCharacter method.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtSnapshotEnd Property

ITextSnapshotReaderIsAtSnapshotEnd Property

Gets whether the current Offset is at the end of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAtSnapshotEnd { get; }
ReadOnly Property IsAtSnapshotEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the end of the snapshot; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtSnapshotLineEnd Property

ITextSnapshotReaderIsAtSnapshotLineEnd Property

Gets whether the current Offset is at the end of an ITextSnapshotLine.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAtSnapshotLineEnd { get; }
ReadOnly Property IsAtSnapshotLineEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the end of an ITextSnapshotLine; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtSnapshotLineStart Property

ITextSnapshotReaderIsAtSnapshotLineStart Property

Gets whether the current Offset is at the start of an ITextSnapshotLine.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAtSnapshotLineStart { get; }
ReadOnly Property IsAtSnapshotLineStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of an ITextSnapshotLine; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtSnapshotStart Property

ITextSnapshotReaderIsAtSnapshotStart Property

Gets whether the current Offset is at the start of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAtSnapshotStart { get; }
ReadOnly Property IsAtSnapshotStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of the snapshot; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtTokenStart Property

ITextSnapshotReaderIsAtTokenStart Property

Gets whether the current Offset is at the start of the Token.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAtTokenStart { get; }
ReadOnly Property IsAtTokenStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of the Token; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsCharacterLineTerminator Property

ITextSnapshotReaderIsCharacterLineTerminator Property

Gets whether the Character is a newline character.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsCharacterLineTerminator { get; }
ReadOnly Property IsCharacterLineTerminator As Boolean
    Get

Property Value

Type: Boolean
true if the Character is a newline character; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsCharacterWhitespace Property

ITextSnapshotReaderIsCharacterWhitespace Property

Gets whether the Character is categorized as a whitespace character.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsCharacterWhitespace { get; }
ReadOnly Property IsCharacterWhitespace As Boolean
    Get

Property Value

Type: Boolean
true if the Character is categorized as a whitespace character; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Language Property

ITextSnapshotReaderLanguage Property

Gets the ISyntaxLanguage that contains the current offset within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISyntaxLanguage Language { get; }
ReadOnly Property Language As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that contains the current offset within the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Length Property

ITextSnapshotReaderLength Property

Gets the length of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The length of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Offset Property

ITextSnapshotReaderOffset Property

Gets or sets the current offset within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Offset { get; set; }
Property Offset As Integer
    Get
    Set

Property Value

Type: Int32
The current offset within the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Options Property

ITextSnapshotReaderOptions Property

Gets the ITextSnapshotReaderOptions that contains optimization options for the reader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshotReaderOptions Options { get; }
ReadOnly Property Options As ITextSnapshotReaderOptions
    Get

Property Value

Type: ITextSnapshotReaderOptions
The ITextSnapshotReaderOptions that contains optimization options for the reader.
Remarks
Configure the options before accessing any members on this reader instance.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Position Property

ITextSnapshotReaderPosition Property

Gets the current TextPosition within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition Position { get; }
ReadOnly Property Position As TextPosition
    Get

Property Value

Type: TextPosition
The current TextPosition within the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Snapshot Property

ITextSnapshotReaderSnapshot Property

Gets the core ITextSnapshot that is examined by this reader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The core ITextSnapshot that is examined by this reader.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.SnapshotLine Property

ITextSnapshotReaderSnapshotLine Property

Gets the ITextSnapshotLine that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshotLine SnapshotLine { get; }
ReadOnly Property SnapshotLine As ITextSnapshotLine
    Get

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine that contains the Offset.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Token Property

ITextSnapshotReaderToken Property

Gets the IToken that contains the offset indicated by Offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken Token { get; }
ReadOnly Property Token As IToken
    Get

Property Value

Type: IToken
The IToken that contains the offset indicated by Offset.
Remarks
This value is the same as the return value of the PeekToken method.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.TokenText Property

ITextSnapshotReaderTokenText Property

Gets the snapshot text contained by the Token.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string TokenText { get; }
ReadOnly Property TokenText As String
    Get

Property Value

Type: String
The snapshot text contained by the Token.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader Methods

The ITextSnapshotReader type exposes the following members.

Methods
 | Name | Description
Public method | GoToCurrentSnapshotLineEnd | Moves the Offset to the end of the snapshot line that contains the Offset.
Public method | GoToCurrentSnapshotLineStart | Moves the Offset to the start of the snapshot line that contains the Offset.
Public method | GoToCurrentTokenStart | Moves the Offset to the start of the IToken that contains the Offset.
Public method | GoToCurrentWordEnd | Moves to the current word's end offset.
Public method | GoToCurrentWordStart | Moves to the current word's start offset.
Public method | GoToNextMatchingTokenById | Moves the Offset to the next matching token where there can be nested token pairs.
Public method | GoToNextSnapshotLineStart | Moves the Offset to the start of the snapshot line after the snapshot line that contains the Offset.
Public method | GoToNextToken | Moves to the next token's start offset.
Public method | GoToNextToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToNextToken(PredicateIToken) | Continues forward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches the specified ID.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches any of the specified IDs.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches the specified key.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches any of the specified keys.
Public method | GoToNextWordStart | Moves to the next word's start offset.
Public method | GoToPreviousMatchingTokenById | Moves the Offset to the previous matching token where there can be nested token pairs.
Public method | GoToPreviousSnapshotLineEnd | Moves the Offset to the end of the snapshot line before the snapshot line that contains the Offset.
Public method | GoToPreviousToken | Moves to the previous token's start offset.
Public method | GoToPreviousToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToPreviousToken(PredicateIToken) | Continues backward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches the specified ID.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches any of the specified IDs.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches the specified key.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches any of the specified keys.
Public method | GoToPreviousWordStart | Moves to the previous word's start character.
Public method | GoToSnapshotEnd | Moves the Offset to the end of the Snapshot.
Public method | GoToSnapshotStart | Moves the Offset to the start of the Snapshot.
Public method | PeekCharacter | Peeks at a single character without seeking past it.
Public method | PeekCharacterReverse | Reverse peeks at a single character without seeking past it.
Public method | PeekText | Peeks at a string without seeking past it.
Public method | PeekTextReverse | Reverse peeks at a string without seeking past it.
Public method | PeekToken | Peeks at a single IToken from the snapshot without seeking past it.
Public method | PeekTokenReverse | Reverse peeks at a single IToken from the snapshot without seeking past it.
Public method | ReadCharacter | Reads a single character and seeks forward one offset.
Public method | ReadCharacterReverse | Reverse reads a single character and seeks backward one offset.
Public method | ReadCharacterReverseThrough(Char) | Reverse reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterReverseThrough(Char, Int32) | Reverse reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Public method | ReadCharacterThrough(Char) | Reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterThrough(Char, Int32) | Reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Public method | ReadText | Reads a string and seeks forward to the end of it.
Public method | ReadTextReverse | Reverse reads a string and seeks backward to the start of it.
Public method | ReadToken | Reads a single IToken from the snapshot and seeks forward one IToken.
Public method | ReadTokenReverse | Reverse reads a single IToken from the snapshot and seeks backward one IToken.
Public method | SeekCharacter | Moves the Offset by the specified amount.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentSnapshotLineEnd Method

ITextSnapshotReaderGoToCurrentSnapshotLineEnd Method

Moves the Offset to the end of the snapshot line that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void GoToCurrentSnapshotLineEnd()
Sub GoToCurrentSnapshotLineEnd
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentSnapshotLineStart Method

ITextSnapshotReaderGoToCurrentSnapshotLineStart Method

Moves the Offset to the start of the snapshot line that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void GoToCurrentSnapshotLineStart()
Sub GoToCurrentSnapshotLineStart
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentTokenStart Method

ITextSnapshotReaderGoToCurrentTokenStart Method

Moves the Offset to the start of the IToken that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void GoToCurrentTokenStart()
Sub GoToCurrentTokenStart
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentWordEnd Method

ITextSnapshotReaderGoToCurrentWordEnd Method

Moves to the current word's end offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToCurrentWordEnd()
Function GoToCurrentWordEnd As Boolean

Return Value

Type: Boolean
true if the word end is found; otherwise, false.
Remarks
If a proper word end is not found, the reader's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentWordStart Method

ITextSnapshotReaderGoToCurrentWordStart Method

Moves to the current word's start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToCurrentWordStart()
Function GoToCurrentWordStart As Boolean

Return Value

Type: Boolean
true if the word start is found; otherwise, false.
Remarks
If a proper word start is not found, the reader's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextMatchingTokenById Method

ITextSnapshotReaderGoToNextMatchingTokenById Method

Moves the Offset to the next matching token where there can be nested token pairs.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextMatchingTokenById(
    int startTokenId,
    int endTokenId
)
Function GoToNextMatchingTokenById (
    startTokenId As Integer,
    endTokenId As Integer
) As Boolean

Parameters

startTokenId
Type: SystemInt32
The ID of the start IToken.
endTokenId
Type: SystemInt32
The ID of the related end IToken for which to search.

Return Value

Type: Boolean
true if the next matching token is found; otherwise, false.
Remarks
This method is useful for bracket matching.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextSnapshotLineStart Method

ITextSnapshotReaderGoToNextSnapshotLineStart Method

Moves the Offset to the start of the snapshot line after the snapshot line that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void GoToNextSnapshotLineStart()
Sub GoToNextSnapshotLineStart
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextToken Method

ITextSnapshotReaderGoToNextToken Method

Overload List
 | Name | Description
Public method | GoToNextToken | Moves to the next token's start offset.
Public method | GoToNextToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToNextToken(PredicateIToken) | Continues forward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextToken Method

ITextSnapshotReaderGoToNextToken Method

Moves to the next token's start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextToken()
Function GoToNextToken As Boolean

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextToken Method (Int32)

ITextSnapshotReaderGoToNextToken Method (Int32)

Moves backward the specified number of tokens.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextToken(
    int count
)
Function GoToNextToken (
    count As Integer
) As Boolean

Parameters

count
Type: SystemInt32
The number of tokens to move.

Return Value

Type: Boolean
true if a token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextToken Method (Predicate(IToken))

ITextSnapshotReaderGoToNextToken Method (PredicateIToken)

Continues forward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextToken(
    Predicate<IToken> predicate
)
Function GoToNextToken (
    predicate As Predicate(Of IToken)
) As Boolean

Parameters

predicate
Type: SystemPredicate IToken
The predicate to use. Return true to stop scanning; otherwise, false to continue scanning.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithId Method

ITextSnapshotReaderGoToNextTokenWithId Method

Overload List
 | Name | Description
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches the specified ID.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches any of the specified IDs.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithId Method (Int32)

ITextSnapshotReaderGoToNextTokenWithId Method (Int32)

Moves to the next token's start offset whose token ID matches the specified ID.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextTokenWithId(
    int id
)
Function GoToNextTokenWithId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextTokenWithId Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithId Method (Int32[])

ITextSnapshotReaderGoToNextTokenWithId Method (Int32)

Moves to the next token's start offset whose token ID matches any of the specified IDs.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextTokenWithId(
    params int[] ids
)
Function GoToNextTokenWithId (
    ParamArray ids As Integer()
) As Boolean

Parameters

ids
Type: SystemInt32
An array of token IDs to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextTokenWithId Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithKey Method

ITextSnapshotReaderGoToNextTokenWithKey Method

Overload List
 | Name | Description
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches the specified key.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches any of the specified keys.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithKey Method (String)

ITextSnapshotReaderGoToNextTokenWithKey Method (String)

Moves to the next token's start offset whose token key matches the specified key.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextTokenWithKey(
    string key
)
Function GoToNextTokenWithKey (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The token key to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextTokenWithKey Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithKey Method (String[])

ITextSnapshotReaderGoToNextTokenWithKey Method (String)

Moves to the next token's start offset whose token key matches any of the specified keys.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextTokenWithKey(
    params string[] keys
)
Function GoToNextTokenWithKey (
    ParamArray keys As String()
) As Boolean

Parameters

keys
Type: SystemString
An array of token keys to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextTokenWithKey Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextWordStart Method

ITextSnapshotReaderGoToNextWordStart Method

Moves to the next word's start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextWordStart()
Function GoToNextWordStart As Boolean

Return Value

Type: Boolean
true if the word start is found; otherwise, false.
Remarks
If a proper word start is not found, the reader's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousMatchingTokenById Method

ITextSnapshotReaderGoToPreviousMatchingTokenById Method

Moves the Offset to the previous matching token where there can be nested token pairs.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousMatchingTokenById(
    int endTokenId,
    int startTokenId
)
Function GoToPreviousMatchingTokenById (
    endTokenId As Integer,
    startTokenId As Integer
) As Boolean

Parameters

endTokenId
Type: SystemInt32
The ID of the end IToken.
startTokenId
Type: SystemInt32
The ID of the related start IToken for which to search.

Return Value

Type: Boolean
true if the previous matching token is found; otherwise, false.
Remarks
This method is useful for bracket matching.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousSnapshotLineEnd Method

ITextSnapshotReaderGoToPreviousSnapshotLineEnd Method

Moves the Offset to the end of the snapshot line before the snapshot line that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void GoToPreviousSnapshotLineEnd()
Sub GoToPreviousSnapshotLineEnd
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousToken Method

ITextSnapshotReaderGoToPreviousToken Method

Overload List
 | Name | Description
Public method | GoToPreviousToken | Moves to the previous token's start offset.
Public method | GoToPreviousToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToPreviousToken(PredicateIToken) | Continues backward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousToken Method

ITextSnapshotReaderGoToPreviousToken Method

Moves to the previous token's start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousToken()
Function GoToPreviousToken As Boolean

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousToken Method (Int32)

ITextSnapshotReaderGoToPreviousToken Method (Int32)

Moves backward the specified number of tokens.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousToken(
    int count
)
Function GoToPreviousToken (
    count As Integer
) As Boolean

Parameters

count
Type: SystemInt32
The number of tokens to move.

Return Value

Type: Boolean
true if a token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousToken Method (Predicate(IToken))

ITextSnapshotReaderGoToPreviousToken Method (PredicateIToken)

Continues backward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousToken(
    Predicate<IToken> predicate
)
Function GoToPreviousToken (
    predicate As Predicate(Of IToken)
) As Boolean

Parameters

predicate
Type: SystemPredicate IToken
The predicate to use. Return true to stop scanning; otherwise, false to continue scanning.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithId Method

ITextSnapshotReaderGoToPreviousTokenWithId Method

Overload List
 | Name | Description
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches the specified ID.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches any of the specified IDs.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithId Method (Int32)

ITextSnapshotReaderGoToPreviousTokenWithId Method (Int32)

Moves to the previous token's start offset whose token ID matches the specified ID.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousTokenWithId(
    int id
)
Function GoToPreviousTokenWithId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousTokenWithId Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithId Method (Int32[])

ITextSnapshotReaderGoToPreviousTokenWithId Method (Int32)

Moves to the previous token's start offset whose token ID matches any of the specified IDs.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousTokenWithId(
    params int[] ids
)
Function GoToPreviousTokenWithId (
    ParamArray ids As Integer()
) As Boolean

Parameters

ids
Type: SystemInt32
An array of token IDs to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousTokenWithId Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithKey Method

ITextSnapshotReaderGoToPreviousTokenWithKey Method

Overload List
 | Name | Description
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches the specified key.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches any of the specified keys.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithKey Method (String)

ITextSnapshotReaderGoToPreviousTokenWithKey Method (String)

Moves to the previous token's start offset whose token key matches the specified key.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousTokenWithKey(
    string key
)
Function GoToPreviousTokenWithKey (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The token key to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousTokenWithKey Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithKey Method (String[])

ITextSnapshotReaderGoToPreviousTokenWithKey Method (String)

Moves to the previous token's start offset whose token key matches any of the specified keys.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousTokenWithKey(
    params string[] keys
)
Function GoToPreviousTokenWithKey (
    ParamArray keys As String()
) As Boolean

Parameters

keys
Type: SystemString
An array of token keys to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousTokenWithKey Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousWordStart Method

ITextSnapshotReaderGoToPreviousWordStart Method

Moves to the previous word's start character.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousWordStart()
Function GoToPreviousWordStart As Boolean

Return Value

Type: Boolean
true if the word start is found; otherwise, false.
Remarks
If a proper word start is not found, the reader's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToSnapshotEnd Method

ITextSnapshotReaderGoToSnapshotEnd Method

Moves the Offset to the end of the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void GoToSnapshotEnd()
Sub GoToSnapshotEnd
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToSnapshotStart Method

ITextSnapshotReaderGoToSnapshotStart Method

Moves the Offset to the start of the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void GoToSnapshotStart()
Sub GoToSnapshotStart
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekCharacter Method

ITextSnapshotReaderPeekCharacter Method

Peeks at a single character without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char PeekCharacter()
Function PeekCharacter As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekCharacterReverse Method

ITextSnapshotReaderPeekCharacterReverse Method

Reverse peeks at a single character without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char PeekCharacterReverse()
Function PeekCharacterReverse As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekText Method

ITextSnapshotReaderPeekText Method

Peeks at a string without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string PeekText(
    int maxCharCount
)
Function PeekText (
    maxCharCount As Integer
) As String

Parameters

maxCharCount
Type: SystemInt32
The maximum number of characters to read, if the end of the snapshot is not reached beforehand.

Return Value

Type: String
The string that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekTextReverse Method

ITextSnapshotReaderPeekTextReverse Method

Reverse peeks at a string without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string PeekTextReverse(
    int maxCharCount
)
Function PeekTextReverse (
    maxCharCount As Integer
) As String

Parameters

maxCharCount
Type: SystemInt32
The maximum number of characters to read, if the start of the snapshot is not reached beforehand.

Return Value

Type: String
The string that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekToken Method

ITextSnapshotReaderPeekToken Method

Peeks at a single IToken from the snapshot without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken PeekToken()
Function PeekToken As IToken

Return Value

Type: IToken
The IToken that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekTokenReverse Method

ITextSnapshotReaderPeekTokenReverse Method

Reverse peeks at a single IToken from the snapshot without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken PeekTokenReverse()
Function PeekTokenReverse As IToken

Return Value

Type: IToken
The IToken that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacter Method

ITextSnapshotReaderReadCharacter Method

Reads a single character and seeks forward one offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char ReadCharacter()
Function ReadCharacter As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterReverse Method

ITextSnapshotReaderReadCharacterReverse Method

Reverse reads a single character and seeks backward one offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
char ReadCharacterReverse()
Function ReadCharacterReverse As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterReverseThrough Method

ITextSnapshotReaderReadCharacterReverseThrough Method

Overload List
 | Name | Description
Public method | ReadCharacterReverseThrough(Char) | Reverse reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterReverseThrough(Char, Int32) | Reverse reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterReverseThrough Method (Char)

ITextSnapshotReaderReadCharacterReverseThrough Method (Char)

Reverse reads characters from the snapshot until the specified character is read through.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReadCharacterReverseThrough(
    char ch
)
Function ReadCharacterReverseThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the start of the snapshot was reached.
See Also

Reference

ITextSnapshotReader Interface
ReadCharacterReverseThrough Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterReverseThrough Method (Char, Int32)

ITextSnapshotReaderReadCharacterReverseThrough Method (Char, Int32)

Reverse reads characters from the snapshot until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReadCharacterReverseThrough(
    char ch,
    int minOffset
)
Function ReadCharacterReverseThrough (
    ch As Char,
    minOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
minOffset
Type: SystemInt32
The minimum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.
See Also

Reference

ITextSnapshotReader Interface
ReadCharacterReverseThrough Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterThrough Method

ITextSnapshotReaderReadCharacterThrough Method

Overload List
 | Name | Description
Public method | ReadCharacterThrough(Char) | Reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterThrough(Char, Int32) | Reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterThrough Method (Char)

ITextSnapshotReaderReadCharacterThrough Method (Char)

Reads characters from the snapshot until the specified character is read through.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReadCharacterThrough(
    char ch
)
Function ReadCharacterThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the end of the snapshot was reached.
See Also

Reference

ITextSnapshotReader Interface
ReadCharacterThrough Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterThrough Method (Char, Int32)

ITextSnapshotReaderReadCharacterThrough Method (Char, Int32)

Reads characters from the snapshot until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ReadCharacterThrough(
    char ch,
    int maxOffset
)
Function ReadCharacterThrough (
    ch As Char,
    maxOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
maxOffset
Type: SystemInt32
The maximum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.
See Also

Reference

ITextSnapshotReader Interface
ReadCharacterThrough Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadText Method

ITextSnapshotReaderReadText Method

Reads a string and seeks forward to the end of it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ReadText(
    int maxCharCount
)
Function ReadText (
    maxCharCount As Integer
) As String

Parameters

maxCharCount
Type: SystemInt32
The maximum number of characters to read, if the end of the snapshot is not reached beforehand.

Return Value

Type: String
The string that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadTextReverse Method

ITextSnapshotReaderReadTextReverse Method

Reverse reads a string and seeks backward to the start of it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ReadTextReverse(
    int maxCharCount
)
Function ReadTextReverse (
    maxCharCount As Integer
) As String

Parameters

maxCharCount
Type: SystemInt32
The maximum number of characters to read, if the start of the snapshot is not reached beforehand.

Return Value

Type: String
The string that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadToken Method

ITextSnapshotReaderReadToken Method

Reads a single IToken from the snapshot and seeks forward one IToken.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken ReadToken()
Function ReadToken As IToken

Return Value

Type: IToken
The IToken that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadTokenReverse Method

ITextSnapshotReaderReadTokenReverse Method

Reverse reads a single IToken from the snapshot and seeks backward one IToken.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken ReadTokenReverse()
Function ReadTokenReverse As IToken

Return Value

Type: IToken
The IToken that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.SeekCharacter Method

ITextSnapshotReaderSeekCharacter Method

Moves the Offset by the specified amount.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void SeekCharacter(
    int delta
)
Sub SeekCharacter (
    delta As Integer
)

Parameters

delta
Type: SystemInt32
The amount of characters to move. This value may be negative.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReaderOptions Interface

Provides the base requirements for options that are applied to an ITextSnapshotReader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextSnapshotReaderOptions
Public Interface ITextSnapshotReaderOptions

The ITextSnapshotReaderOptions type exposes the following members.

Properties
 | Name | Description
Public property | DefaultTokenLoadBufferLength | Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | InitialTokenLoadBufferLength | Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | PrimaryScanDirection | Gets or sets the primary direction in which text scanning will take place with the reader.
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.TextTextSnapshotReaderOptions


ITextSnapshotReaderOptions Properties

The ITextSnapshotReaderOptions type exposes the following members.

Properties
 | Name | Description
Public property | DefaultTokenLoadBufferLength | Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | InitialTokenLoadBufferLength | Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | PrimaryScanDirection | Gets or sets the primary direction in which text scanning will take place with the reader.
Top
See Also

Reference

ITextSnapshotReaderOptions Interface
ActiproSoftware.Text Namespace


ITextSnapshotReaderOptions.DefaultTokenLoadBufferLength Property

ITextSnapshotReaderOptionsDefaultTokenLoadBufferLength Property

Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int DefaultTokenLoadBufferLength { get; set; }
Property DefaultTokenLoadBufferLength As Integer
    Get
    Set

Property Value

Type: Int32
The number of characters for which to load tokens. The default value is 700.
Remarks
This property governs each load of tokens following the first load.
See Also

Reference

ITextSnapshotReaderOptions Interface
ActiproSoftware.Text Namespace
ITextSnapshotReaderOptionsInitialTokenLoadBufferLength


ITextSnapshotReaderOptions.InitialTokenLoadBufferLength Property

ITextSnapshotReaderOptionsInitialTokenLoadBufferLength Property

Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int InitialTokenLoadBufferLength { get; set; }
Property InitialTokenLoadBufferLength As Integer
    Get
    Set

Property Value

Type: Int32
The number of characters for which to load tokens. The default value is 100.
Remarks
This property only governs the first load of tokens.
See Also

Reference

ITextSnapshotReaderOptions Interface
ActiproSoftware.Text Namespace
ITextSnapshotReaderOptionsDefaultTokenLoadBufferLength


ITextSnapshotReaderOptions.PrimaryScanDirection Property

ITextSnapshotReaderOptionsPrimaryScanDirection Property

Gets or sets the primary direction in which text scanning will take place with the reader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextScanDirection> PrimaryScanDirection { get; set; }
Property PrimaryScanDirection As Nullable(Of TextScanDirection)
    Get
    Set

Property Value

Type: Nullable TextScanDirection
The primary direction in which text scanning will take place with the reader. The default value is .
Remarks
A value of means indeterminate. This property is simply used for optimization of the initial token load and in no way restricts which way you are permitted to scan with the reader.
See Also

Reference

ITextSnapshotReaderOptions Interface
ActiproSoftware.Text Namespace


ITextStatistic Interface

Provides the base requirements for a text statistic that is returned by an ITextStatistics.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextStatistic : IKeyedObject
Public Interface ITextStatistic
    Inherits IKeyedObject

The ITextStatistic type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the statistic, generally displayed in the user interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | StringValue | Gets the string value of the statistic.
Public property | Value | Gets the value of the statistic.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextStatistic Properties

The ITextStatistic type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the statistic, generally displayed in the user interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | StringValue | Gets the string value of the statistic.
Public property | Value | Gets the value of the statistic.
Top
See Also

Reference

ITextStatistic Interface
ActiproSoftware.Text Namespace


ITextStatistic.Description Property

ITextStatisticDescription Property

Gets the description of the statistic, generally displayed in the user interface.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the statistic, generally displayed in the user interface.
See Also

Reference

ITextStatistic Interface
ActiproSoftware.Text Namespace


ITextStatistic.StringValue Property

ITextStatisticStringValue Property

Gets the string value of the statistic.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string StringValue { get; }
ReadOnly Property StringValue As String
    Get

Property Value

Type: String
The string value of the statistic.
See Also

Reference

ITextStatistic Interface
ActiproSoftware.Text Namespace


ITextStatistic.Value Property

ITextStatisticValue Property

Gets the value of the statistic.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Value { get; }
ReadOnly Property Value As Object
    Get

Property Value

Type: Object
The value of the statistic.
See Also

Reference

ITextStatistic Interface
ActiproSoftware.Text Namespace


ITextStatistics Interface

Provides the base requirements for a class that contains numerous statistics such as line, word, character counts, and readability scores for text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextStatistics
Public Interface ITextStatistics

The ITextStatistics type exposes the following members.

Properties
 | Name | Description
Public property | AverageLettersPerWord | Gets the average number of letters per word.
Public property | AverageSyllablesPerWord | Gets the average number of syllables per word.
Public property | AverageWordsPerSentence | Gets the average number of words per sentence.
Public property | Characters | Gets the number of characters in the text.
Public property | Consonants | Gets the number of consonants in the text.
Public property | FleschKincaidGradeLevel | Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.
Public property | FleschReadingEaseScore | Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.
Public property | Letters | Gets the number of letters in the text.
Public property | Lines | Gets the number of lines in the text.
Public property | NonWhitespaceCharacters | Gets the number of non-whitespace characters in the text.
Public property | NonWhitespaceLines | Gets the number of non-whitespace lines in the text.
Public property | Sentences | Gets the number of sentences in the text.
Public property | Syllables | Gets the number of syllables in the text.
Public property | Vowels | Gets the number of vowels in the text.
Public property | WhitespaceCharacters | Gets the number of whitespace characters in the text.
Public property | WhitespaceLines | Gets the number of whitespace lines in the text.
Public property | Words | Gets the number of words in the text.
Top
Methods
 | Name | Description
Public method | GetRawStatistics | Returns the list of ITextStatistic objects that contain the statistic results.
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationTextStatistics


ITextStatistics Properties

The ITextStatistics type exposes the following members.

Properties
 | Name | Description
Public property | AverageLettersPerWord | Gets the average number of letters per word.
Public property | AverageSyllablesPerWord | Gets the average number of syllables per word.
Public property | AverageWordsPerSentence | Gets the average number of words per sentence.
Public property | Characters | Gets the number of characters in the text.
Public property | Consonants | Gets the number of consonants in the text.
Public property | FleschKincaidGradeLevel | Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.
Public property | FleschReadingEaseScore | Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.
Public property | Letters | Gets the number of letters in the text.
Public property | Lines | Gets the number of lines in the text.
Public property | NonWhitespaceCharacters | Gets the number of non-whitespace characters in the text.
Public property | NonWhitespaceLines | Gets the number of non-whitespace lines in the text.
Public property | Sentences | Gets the number of sentences in the text.
Public property | Syllables | Gets the number of syllables in the text.
Public property | Vowels | Gets the number of vowels in the text.
Public property | WhitespaceCharacters | Gets the number of whitespace characters in the text.
Public property | WhitespaceLines | Gets the number of whitespace lines in the text.
Public property | Words | Gets the number of words in the text.
Top
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.AverageLettersPerWord Property

ITextStatisticsAverageLettersPerWord Property

Gets the average number of letters per word.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double AverageLettersPerWord { get; }
ReadOnly Property AverageLettersPerWord As Double
    Get

Property Value

Type: Double
The average number of letters per word.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.AverageSyllablesPerWord Property

ITextStatisticsAverageSyllablesPerWord Property

Gets the average number of syllables per word.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double AverageSyllablesPerWord { get; }
ReadOnly Property AverageSyllablesPerWord As Double
    Get

Property Value

Type: Double
The average number of syllables per word.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.AverageWordsPerSentence Property

ITextStatisticsAverageWordsPerSentence Property

Gets the average number of words per sentence.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double AverageWordsPerSentence { get; }
ReadOnly Property AverageWordsPerSentence As Double
    Get

Property Value

Type: Double
The average number of words per sentence.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Characters Property

ITextStatisticsCharacters Property

Gets the number of characters in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Characters { get; }
ReadOnly Property Characters As Integer
    Get

Property Value

Type: Int32
The number of characters in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Consonants Property

ITextStatisticsConsonants Property

Gets the number of consonants in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Consonants { get; }
ReadOnly Property Consonants As Integer
    Get

Property Value

Type: Int32
The number of consonants in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.FleschKincaidGradeLevel Property

ITextStatisticsFleschKincaidGradeLevel Property

Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double FleschKincaidGradeLevel { get; }
ReadOnly Property FleschKincaidGradeLevel As Double
    Get

Property Value

Type: Double
Remarks
A grade level of 7.1 indicates that an individual with about 7 years of education could understand the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.FleschReadingEaseScore Property

ITextStatisticsFleschReadingEaseScore Property

Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double FleschReadingEaseScore { get; }
ReadOnly Property FleschReadingEaseScore As Double
    Get

Property Value

Type: Double
Remarks
Scores of 90-100 are considered easily understandable by an average 5th grader. Scores of 60-70 are considered easily understandable by 8th and 9th grade students. Scores of 0-30 are best understood by college graduates.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Letters Property

ITextStatisticsLetters Property

Gets the number of letters in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Letters { get; }
ReadOnly Property Letters As Integer
    Get

Property Value

Type: Int32
The number of letters in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Lines Property

ITextStatisticsLines Property

Gets the number of lines in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Lines { get; }
ReadOnly Property Lines As Integer
    Get

Property Value

Type: Int32
The number of lines in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.NonWhitespaceCharacters Property

ITextStatisticsNonWhitespaceCharacters Property

Gets the number of non-whitespace characters in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int NonWhitespaceCharacters { get; }
ReadOnly Property NonWhitespaceCharacters As Integer
    Get

Property Value

Type: Int32
The number of non-whitespace characters in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.NonWhitespaceLines Property

ITextStatisticsNonWhitespaceLines Property

Gets the number of non-whitespace lines in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int NonWhitespaceLines { get; }
ReadOnly Property NonWhitespaceLines As Integer
    Get

Property Value

Type: Int32
The number of non-whitespace lines in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Sentences Property

ITextStatisticsSentences Property

Gets the number of sentences in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Sentences { get; }
ReadOnly Property Sentences As Integer
    Get

Property Value

Type: Int32
The number of sentences in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Syllables Property

ITextStatisticsSyllables Property

Gets the number of syllables in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Syllables { get; }
ReadOnly Property Syllables As Integer
    Get

Property Value

Type: Int32
The number of syllables in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Vowels Property

ITextStatisticsVowels Property

Gets the number of vowels in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Vowels { get; }
ReadOnly Property Vowels As Integer
    Get

Property Value

Type: Int32
The number of vowels in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.WhitespaceCharacters Property

ITextStatisticsWhitespaceCharacters Property

Gets the number of whitespace characters in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int WhitespaceCharacters { get; }
ReadOnly Property WhitespaceCharacters As Integer
    Get

Property Value

Type: Int32
The number of whitespace characters in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.WhitespaceLines Property

ITextStatisticsWhitespaceLines Property

Gets the number of whitespace lines in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int WhitespaceLines { get; }
ReadOnly Property WhitespaceLines As Integer
    Get

Property Value

Type: Int32
The number of whitespace lines in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Words Property

ITextStatisticsWords Property

Gets the number of words in the text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Words { get; }
ReadOnly Property Words As Integer
    Get

Property Value

Type: Int32
The number of words in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics Methods

The ITextStatistics type exposes the following members.

Methods
 | Name | Description
Public method | GetRawStatistics | Returns the list of ITextStatistic objects that contain the statistic results.
Top
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.GetRawStatistics Method

ITextStatisticsGetRawStatistics Method

Returns the list of ITextStatistic objects that contain the statistic results.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<ITextStatistic> GetRawStatistics()
Function GetRawStatistics As IList(Of ITextStatistic)

Return Value

Type: IList ITextStatistic
The list of ITextStatistic objects that contain the statistic results.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatisticsFactory Interface

Provides the base requirements for a factory capable of creating ITextStatistics objects.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextStatisticsFactory
Public Interface ITextStatisticsFactory

The ITextStatisticsFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateStatistics | Creates an ITextStatistics for the specified text.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace


ITextStatisticsFactory Methods

The ITextStatisticsFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateStatistics | Creates an ITextStatistics for the specified text.
Top
See Also

Reference

ITextStatisticsFactory Interface
ActiproSoftware.Text Namespace


ITextStatisticsFactory.CreateStatistics Method

ITextStatisticsFactoryCreateStatistics Method

Creates an ITextStatistics for the specified text.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextStatistics CreateStatistics(
    string text
)
Function CreateStatistics (
    text As String
) As ITextStatistics

Parameters

text
Type: SystemString
The text to examine.

Return Value

Type: ITextStatistics
The ITextStatistics that was created.
See Also

Reference

ITextStatisticsFactory Interface
ActiproSoftware.Text Namespace


ITextVersion Interface

Provides the base requirements for a version of an ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextVersion
Public Interface ITextVersion

The ITextVersion type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this version applies.
Public property | Length | Gets the number of characters in the version, excluding any carriage-returns but including newlines.
Public property | Next | Gets the next ITextVersion that occurs after this one.
Public property | Number | Gets the integer version number associated with this instance.
Public property | Operations | Gets the read-only list of ITextChangeRangedOperation objects that can be applied to this text version to generate the next version.
Top
Methods
 | Name | Description
Public method | CreateRange(TextRange) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, FuncTextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextVersion Properties

The ITextVersion type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this version applies.
Public property | Length | Gets the number of characters in the version, excluding any carriage-returns but including newlines.
Public property | Next | Gets the next ITextVersion that occurs after this one.
Public property | Number | Gets the integer version number associated with this instance.
Public property | Operations | Gets the read-only list of ITextChangeRangedOperation objects that can be applied to this text version to generate the next version.
Top
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Document Property

ITextVersionDocument Property

Gets the ITextDocument for which this version applies.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextDocument Document { get; }
ReadOnly Property Document As ITextDocument
    Get

Property Value

Type: ITextDocument
The ITextDocument for which this version applies.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Length Property

ITextVersionLength Property

Gets the number of characters in the version, excluding any carriage-returns but including newlines.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters in the version, excluding any carriage-returns but including newlines.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Next Property

ITextVersionNext Property

Gets the next ITextVersion that occurs after this one.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextVersion Next { get; }
ReadOnly Property Next As ITextVersion
    Get

Property Value

Type: ITextVersion
The next ITextVersion that occurs after this one.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Number Property

ITextVersionNumber Property

Gets the integer version number associated with this instance.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Number { get; }
ReadOnly Property Number As Integer
    Get

Property Value

Type: Int32
The integer version number associated with this instance.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Operations Property

ITextVersionOperations Property

Gets the read-only list of ITextChangeRangedOperation objects that can be applied to this text version to generate the next version.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<ITextChangeRangedOperation> Operations { get; }
ReadOnly Property Operations As IList(Of ITextChangeRangedOperation)
    Get

Property Value

Type: IList ITextChangeRangedOperation
The read-only list of ITextChangeRangedOperation objects that can be applied to this text version to generate the next version.
Remarks
This property returns for the most current version of a document.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion Methods

Methods
 | Name | Description
Public method | CreateRange(TextRange) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, FuncTextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Top
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method

ITextVersionCreateRange Method

Overload List
 | Name | Description
Public method | CreateRange(TextRange) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, FuncTextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Top
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (TextRange)

ITextVersionCreateRange Method (TextRange)

Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    TextRange textRange
)
Function CreateRange (
    textRange As TextRange
) As ITextVersionRange

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text within this version.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (Int32, Int32)

ITextVersionCreateRange Method (Int32, Int32)

Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    int startOffset,
    int length
)
Function CreateRange (
    startOffset As Integer,
    length As Integer
) As ITextVersionRange

Parameters

startOffset
Type: SystemInt32
The start offset in the range.
length
Type: SystemInt32
The length of the range.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (TextRange, TextRangeTrackingModes)

ITextVersionCreateRange Method (TextRange, TextRangeTrackingModes)

Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    TextRange textRange,
    TextRangeTrackingModes trackingModes
)
Function CreateRange (
    textRange As TextRange,
    trackingModes As TextRangeTrackingModes
) As ITextVersionRange

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text within this version.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (TextRange, Func(TextRangeTrackingModes))

ITextVersionCreateRange Method (TextRange, FuncTextRangeTrackingModes)

Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    TextRange textRange,
    Func<TextRangeTrackingModes> trackingModesFunc
)
Function CreateRange (
    textRange As TextRange,
    trackingModesFunc As Func(Of TextRangeTrackingModes)
) As ITextVersionRange

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text within this version.
trackingModesFunc
Type: SystemFunc TextRangeTrackingModes
A function that dynamically returns a TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (Int32, Int32, TextRangeTrackingModes)

ITextVersionCreateRange Method (Int32, Int32, TextRangeTrackingModes)

Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    int startOffset,
    int length,
    TextRangeTrackingModes trackingModes
)
Function CreateRange (
    startOffset As Integer,
    length As Integer,
    trackingModes As TextRangeTrackingModes
) As ITextVersionRange

Parameters

startOffset
Type: SystemInt32
The start offset in the range.
length
Type: SystemInt32
The length of the range.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersionRange Interface

Provides the base requirements for a zero-based range of two normalized offset values within a text document that can be translated from one version of the document to another.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextVersionRange
Public Interface ITextVersionRange

The ITextVersionRange type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this text range applies.
Public property | TrackingModes | Gets a TextRangeTrackingModes indicating the tracking modes to use.
Top
Methods
 | Name | Description
Public method | Translate(ITextSnapshot) | Gets a TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.
Public method | Translate(ITextVersion) | Gets a TextRange that indicates the text range within the specified target ITextVersion.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextVersionRange Properties

The ITextVersionRange type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this text range applies.
Public property | TrackingModes | Gets a TextRangeTrackingModes indicating the tracking modes to use.
Top
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange.Document Property

ITextVersionRangeDocument Property

Gets the ITextDocument for which this text range applies.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextDocument Document { get; }
ReadOnly Property Document As ITextDocument
    Get

Property Value

Type: ITextDocument
The ITextDocument for which this text range applies.
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange.TrackingModes Property

ITextVersionRangeTrackingModes Property

Gets a TextRangeTrackingModes indicating the tracking modes to use.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRangeTrackingModes TrackingModes { get; }
ReadOnly Property TrackingModes As TextRangeTrackingModes
    Get

Property Value

Type: TextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange Methods

Methods
 | Name | Description
Public method | Translate(ITextSnapshot) | Gets a TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.
Public method | Translate(ITextVersion) | Gets a TextRange that indicates the text range within the specified target ITextVersion.
Top
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange.Translate Method

ITextVersionRangeTranslate Method

Overload List
 | Name | Description
Public method | Translate(ITextSnapshot) | Gets a TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.
Public method | Translate(ITextVersion) | Gets a TextRange that indicates the text range within the specified target ITextVersion.
Top
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange.Translate Method (ITextSnapshot)

ITextVersionRangeTranslate Method (ITextSnapshot)

Gets a TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotRange Translate(
    ITextSnapshot toSnapshot
)
Function Translate (
    toSnapshot As ITextSnapshot
) As TextSnapshotRange

Parameters

toSnapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.

Return Value

Type: TextSnapshotRange
A TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.
See Also

Reference

ITextVersionRange Interface
Translate Overload
ActiproSoftware.Text Namespace


ITextVersionRange.Translate Method (ITextVersion)

ITextVersionRangeTranslate Method (ITextVersion)

Gets a TextRange that indicates the text range within the specified target ITextVersion.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange Translate(
    ITextVersion toVersion
)
Function Translate (
    toVersion As ITextVersion
) As TextRange

Parameters

toVersion
Type: ActiproSoftware.TextITextVersion
The target ITextVersion.

Return Value

Type: TextRange
A TextRange that indicates the text range within the specified target ITextVersion.
See Also

Reference

ITextVersionRange Interface
Translate Overload
ActiproSoftware.Text Namespace


IWordBreakFinder Interface

Provides the base requirements for an object that finds word breaks within an ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IWordBreakFinder
Public Interface IWordBreakFinder

The IWordBreakFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindCurrentWordEnd | Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
Public method | FindCurrentWordStart | Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
Public method | FindNextWordStart | Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.
Public method | FindPreviousWordStart | Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationDefaultWordBreakFinder


IWordBreakFinder Methods

The IWordBreakFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindCurrentWordEnd | Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
Public method | FindCurrentWordStart | Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
Public method | FindNextWordStart | Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.
Public method | FindPreviousWordStart | Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.
Top
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


IWordBreakFinder.FindCurrentWordEnd Method

IWordBreakFinderFindCurrentWordEnd Method

Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int FindCurrentWordEnd(
    TextSnapshotOffset snapshotOffset
)
Function FindCurrentWordEnd (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


IWordBreakFinder.FindCurrentWordStart Method

IWordBreakFinderFindCurrentWordStart Method

Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int FindCurrentWordStart(
    TextSnapshotOffset snapshotOffset
)
Function FindCurrentWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


IWordBreakFinder.FindNextWordStart Method

IWordBreakFinderFindNextWordStart Method

Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int FindNextWordStart(
    TextSnapshotOffset snapshotOffset
)
Function FindNextWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs after the specified start offset.
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


IWordBreakFinder.FindPreviousWordStart Method

IWordBreakFinderFindPreviousWordStart Method

Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int FindPreviousWordStart(
    TextSnapshotOffset snapshotOffset
)
Function FindPreviousWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs before the specified start offset.
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


LineTerminator Enumeration

Specifies a type of line terminator.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LineTerminator
Public Enumeration LineTerminator
Members
Member name | Value | Description
Newline | 0 | A single newline character (ASCII value 10). This format is typically used on UNIX machines.
CarriageReturn | 1 | A single carriage return character (ASCII value 13). This format is typically used on Macintosh machines.
CarriageReturnNewline | 2 | A carriage return character (ASCII value 13) followed by a newline character (ASCII value 10). This format is typically used on Windows machines.
See Also

Reference

ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Class

Represents a read-only normalized text snapshot range collection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextNormalizedTextSnapshotRangeCollection

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NormalizedTextSnapshotRangeCollection : IEnumerable,
    IList<TextSnapshotRange>, ICollection<TextSnapshotRange>, IEnumerable<TextSnapshotRange>
Public Class NormalizedTextSnapshotRangeCollection
    Implements IEnumerable, IList(Of TextSnapshotRange),
    ICollection(Of TextSnapshotRange), IEnumerable(Of TextSnapshotRange)

The NormalizedTextSnapshotRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | NormalizedTextSnapshotRangeCollection | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(TextSnapshotRange) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(IEnumerableTextSnapshotRange) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(IEnumerableTextSnapshotRange, Boolean) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets or sets the item at the specified index. [C#] In C#, this property is the indexer for the NormalizedTextSnapshotRangeCollection class.
Top
Methods
 | Name | Description
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetInverse | Gets a NormalizedTextSnapshotRangeCollection that contains the inverse ranges contained in this instance.
Public method | IndexOf | Returns the index of the specified item in the collection.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeTextSnapshotRange | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeTextSnapshotRange | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllTextSnapshotRange | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor

Overload List
 | Name | Description
Public method | NormalizedTextSnapshotRangeCollection | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(TextSnapshotRange) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(IEnumerableTextSnapshotRange) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(IEnumerableTextSnapshotRange, Boolean) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Top
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor

Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection()
Public Sub New
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
NormalizedTextSnapshotRangeCollection Overload
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor (TextSnapshotRange[])

NormalizedTextSnapshotRangeCollection Constructor (TextSnapshotRange)

Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection(
    params TextSnapshotRange[] snapshotRanges
)
Public Sub New (
    ParamArray snapshotRanges As TextSnapshotRange()
)

Parameters

snapshotRanges
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange objects to add to the collection.
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
NormalizedTextSnapshotRangeCollection Overload
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor (IEnumerable(TextSnapshotRange))

NormalizedTextSnapshotRangeCollection Constructor (IEnumerableTextSnapshotRange)

Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection(
    IEnumerable<TextSnapshotRange> snapshotRanges
)
Public Sub New (
    snapshotRanges As IEnumerable(Of TextSnapshotRange)
)

Parameters

snapshotRanges
Type: System.Collections.GenericIEnumerable TextSnapshotRange
The TextSnapshotRange objects to add to the collection.
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
NormalizedTextSnapshotRangeCollection Overload
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor (IEnumerable(TextSnapshotRange), Boolean)

NormalizedTextSnapshotRangeCollection Constructor (IEnumerableTextSnapshotRange, Boolean)

Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection(
    IEnumerable<TextSnapshotRange> snapshotRanges,
    bool mergeSequentialRanges
)
Public Sub New (
    snapshotRanges As IEnumerable(Of TextSnapshotRange),
    mergeSequentialRanges As Boolean
)

Parameters

snapshotRanges
Type: System.Collections.GenericIEnumerable TextSnapshotRange
The TextSnapshotRange objects to add to the collection.
mergeSequentialRanges
Type: SystemBoolean
Whether to merge sequential ranges.
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
NormalizedTextSnapshotRangeCollection Overload
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Properties

The NormalizedTextSnapshotRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets or sets the item at the specified index. [C#] In C#, this property is the indexer for the NormalizedTextSnapshotRangeCollection class.
Top
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.Count Property

NormalizedTextSnapshotRangeCollectionCount Property

Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.

Implements

ICollectionTCount
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.Item Property

NormalizedTextSnapshotRangeCollectionItem Property

Gets or sets the item at the specified index.

[C#] In C#, this property is the indexer for the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As TextSnapshotRange
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the item to return.

Property Value

Type: TextSnapshotRange
The item at the specified index.

Implements

IListTItemInt32
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Methods

The NormalizedTextSnapshotRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetInverse | Gets a NormalizedTextSnapshotRangeCollection that contains the inverse ranges contained in this instance.
Public method | IndexOf | Returns the index of the specified item in the collection.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeTextSnapshotRange | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeTextSnapshotRange | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllTextSnapshotRange | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.Contains Method

NormalizedTextSnapshotRangeCollectionContains Method

Determines whether the collection contains a specific value.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    TextSnapshotRange item
)
Public Function Contains (
    item As TextSnapshotRange
) As Boolean

Parameters

item
Type: ActiproSoftware.TextTextSnapshotRange
The object to locate in the collection.

Return Value

Type: Boolean
true if the item is found in the collection; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.CopyTo Method

NormalizedTextSnapshotRangeCollectionCopyTo Method

Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyTo(
    TextSnapshotRange[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As TextSnapshotRange(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.TextTextSnapshotRange
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.GetEnumerator Method

NormalizedTextSnapshotRangeCollectionGetEnumerator Method

Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<TextSnapshotRange> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TextSnapshotRange)

Return Value

Type: IEnumerator TextSnapshotRange
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.GetInverse Method

NormalizedTextSnapshotRangeCollectionGetInverse Method

Gets a NormalizedTextSnapshotRangeCollection that contains the inverse ranges contained in this instance.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection GetInverse(
    TextSnapshotRange targetSnapshotRange
)
Public Function GetInverse (
    targetSnapshotRange As TextSnapshotRange
) As NormalizedTextSnapshotRangeCollection

Parameters

targetSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which to return ranges.

Return Value

Type: NormalizedTextSnapshotRangeCollection
A NormalizedTextSnapshotRangeCollection that contains the inverse ranges contained in this instance.
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.IndexOf Method

NormalizedTextSnapshotRangeCollectionIndexOf Method

Returns the index of the specified item in the collection.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    TextSnapshotRange item
)
Public Function IndexOf (
    item As TextSnapshotRange
) As Integer

Parameters

item
Type: ActiproSoftware.TextTextSnapshotRange
The item to look for.

Return Value

Type: Int32
If found, the index where the item is in the collection; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs Class

Event arguments for the ICodeDocument.LanguageChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.TextSyntaxLanguageChangedEventArgs

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SyntaxLanguageChangedEventArgs : EventArgs
Public Class SyntaxLanguageChangedEventArgs
    Inherits EventArgs

The SyntaxLanguageChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxLanguageChangedEventArgs | Initializes a new instance of the SyntaxLanguageChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewLanguage | Gets the ISyntaxLanguage is in use after the change.
Public property | OldLanguage | Gets the ISyntaxLanguage that was in use before the change.
Top
See Also

Reference

ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs Constructor

Initializes a new instance of the SyntaxLanguageChangedEventArgs class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SyntaxLanguageChangedEventArgs(
    ISyntaxLanguage oldLanguage,
    ISyntaxLanguage newLanguage
)
Public Sub New (
    oldLanguage As ISyntaxLanguage,
    newLanguage As ISyntaxLanguage
)

Parameters

oldLanguage
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage that was in use before the change.
newLanguage
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage that is in use after the change.
See Also

Reference

SyntaxLanguageChangedEventArgs Class
ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs Properties

The SyntaxLanguageChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewLanguage | Gets the ISyntaxLanguage is in use after the change.
Public property | OldLanguage | Gets the ISyntaxLanguage that was in use before the change.
Top
See Also

Reference

SyntaxLanguageChangedEventArgs Class
ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs.NewLanguage Property

SyntaxLanguageChangedEventArgsNewLanguage Property

Gets the ISyntaxLanguage is in use after the change.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISyntaxLanguage NewLanguage { get; }
Public ReadOnly Property NewLanguage As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage is in use after the change.
See Also

Reference

SyntaxLanguageChangedEventArgs Class
ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs.OldLanguage Property

SyntaxLanguageChangedEventArgsOldLanguage Property

Gets the ISyntaxLanguage that was in use before the change.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISyntaxLanguage OldLanguage { get; }
Public ReadOnly Property OldLanguage As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that was in use before the change.
See Also

Reference

SyntaxLanguageChangedEventArgs Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions Class

Contains extension methods that make it easier to work with ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextSyntaxLanguageExtensions

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class SyntaxLanguageExtensions
<ExtensionAttribute>
Public NotInheritable Class SyntaxLanguageExtensions

The SyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction.
GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range.
GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language.
GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed.
GetLexer | Returns the ILexer that can be used for lexing of the language.
GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language.
GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language.
GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
GetParser | Returns the IParser that can be used for parsing of the language.
GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language.
GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language.
GetTextViewLineNumberProvider | Returns the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin.
GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language.
RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction.
RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range.
RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language.
RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed.
RegisterLexer | Registers the ILexer that can be used for lexing of the language.
RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language.
RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language.
RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
RegisterParser | Registers the IParser that can be used for parsing of the language.
RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language.
RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language.
RegisterTextViewLineNumberProvider | Registers the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin.
RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language.
UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction.
UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range.
UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language.
UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed.
UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language.
UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language.
UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language.
UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
UnregisterParser | Unregisters the IParser that can be used for parsing of the language.
UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language.
UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language.
UnregisterTextViewLineNumberProvider | Unregisters the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin.
UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language.
Top
See Also

Reference

ActiproSoftware.Text Namespace


SyntaxLanguageExtensions Methods

The SyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction.
GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range.
GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language.
GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed.
GetLexer | Returns the ILexer that can be used for lexing of the language.
GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language.
GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language.
GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
GetParser | Returns the IParser that can be used for parsing of the language.
GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language.
GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language.
GetTextViewLineNumberProvider | Returns the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin.
GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language.
RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction.
RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range.
RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language.
RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed.
RegisterLexer | Registers the ILexer that can be used for lexing of the language.
RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language.
RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language.
RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
RegisterParser | Registers the IParser that can be used for parsing of the language.
RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language.
RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language.
RegisterTextViewLineNumberProvider | Registers the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin.
RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language.
UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction.
UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range.
UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language.
UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed.
UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language.
UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language.
UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language.
UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
UnregisterParser | Unregisters the IParser that can be used for parsing of the language.
UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language.
UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language.
UnregisterTextViewLineNumberProvider | Unregisters the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin.
UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language.
Top
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetAutoCorrector Method

SyntaxLanguageExtensionsGetAutoCorrector Method

Returns the IAutoCorrector that can perform auto-correction.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IAutoCorrector GetAutoCorrector(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetAutoCorrector (
    language As ISyntaxLanguage
) As IAutoCorrector

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IAutoCorrector
The IAutoCorrector instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetCodeBlockFinder Method

SyntaxLanguageExtensionsGetCodeBlockFinder Method

Returns the ICodeBlockFinder that can find the containing code block for a text range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ICodeBlockFinder GetCodeBlockFinder(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetCodeBlockFinder (
    language As ISyntaxLanguage
) As ICodeBlockFinder

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ICodeBlockFinder
The ICodeBlockFinder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetDelimiterAutoCompleter Method

SyntaxLanguageExtensionsGetDelimiterAutoCompleter Method

Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDelimiterAutoCompleter GetDelimiterAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetDelimiterAutoCompleter (
    language As ISyntaxLanguage
) As IDelimiterAutoCompleter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IDelimiterAutoCompleter
The IDelimiterAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetExampleTextProvider Method

SyntaxLanguageExtensionsGetExampleTextProvider Method

Returns the IExampleTextProvider that can generate example text for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IExampleTextProvider GetExampleTextProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetExampleTextProvider (
    language As ISyntaxLanguage
) As IExampleTextProvider

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IExampleTextProvider
The IExampleTextProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetIndentProvider Method

SyntaxLanguageExtensionsGetIndentProvider Method

Returns the IIndentProvider that can indent text for the language when the Enter key pressed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IIndentProvider GetIndentProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetIndentProvider (
    language As ISyntaxLanguage
) As IIndentProvider

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IIndentProvider
The IIndentProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetLexer Method

SyntaxLanguageExtensionsGetLexer Method

Returns the ILexer that can be used for lexing of the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ILexer GetLexer(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetLexer (
    language As ISyntaxLanguage
) As ILexer

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ILexer
The ILexer instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetLineCommenter Method

SyntaxLanguageExtensionsGetLineCommenter Method

Returns the ILineCommenter that can comment and uncomment lines for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ILineCommenter GetLineCommenter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetLineCommenter (
    language As ISyntaxLanguage
) As ILineCommenter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ILineCommenter
The ILineCommenter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetNavigableSymbolProvider Method

SyntaxLanguageExtensionsGetNavigableSymbolProvider Method

Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static INavigableSymbolProvider GetNavigableSymbolProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetNavigableSymbolProvider (
    language As ISyntaxLanguage
) As INavigableSymbolProvider

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: INavigableSymbolProvider
The INavigableSymbolProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetOutliner Method

SyntaxLanguageExtensionsGetOutliner Method

Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IOutliner GetOutliner(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetOutliner (
    language As ISyntaxLanguage
) As IOutliner

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IOutliner
The IOutliner instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetParser Method

SyntaxLanguageExtensionsGetParser Method

Returns the IParser that can be used for parsing of the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IParser GetParser(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetParser (
    language As ISyntaxLanguage
) As IParser

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IParser
The IParser instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetStructureMatcher Method

SyntaxLanguageExtensionsGetStructureMatcher Method

Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IStructureMatcher GetStructureMatcher(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetStructureMatcher (
    language As ISyntaxLanguage
) As IStructureMatcher

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IStructureMatcher
The IStructureMatcher instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetTextFormatter Method

SyntaxLanguageExtensionsGetTextFormatter Method

Returns the ITextFormatter that can improve the readability of code for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextFormatter GetTextFormatter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetTextFormatter (
    language As ISyntaxLanguage
) As ITextFormatter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ITextFormatter
The ITextFormatter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetTextStatisticsFactory Method

SyntaxLanguageExtensionsGetTextStatisticsFactory Method

Returns the ITextStatisticsFactory that can generate customized text statistics for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextStatisticsFactory GetTextStatisticsFactory(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetTextStatisticsFactory (
    language As ISyntaxLanguage
) As ITextStatisticsFactory

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ITextStatisticsFactory
The ITextStatisticsFactory instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetTextViewLineNumberProvider Method

SyntaxLanguageExtensionsGetTextViewLineNumberProvider Method

Returns the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextViewLineNumberProvider GetTextViewLineNumberProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetTextViewLineNumberProvider (
    language As ISyntaxLanguage
) As ITextViewLineNumberProvider

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ITextViewLineNumberProvider
The ITextViewLineNumberProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetWordBreakFinder Method

SyntaxLanguageExtensionsGetWordBreakFinder Method

Returns the IWordBreakFinder that is capable of locating word breaks for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IWordBreakFinder GetWordBreakFinder(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetWordBreakFinder (
    language As ISyntaxLanguage
) As IWordBreakFinder

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IWordBreakFinder
The IWordBreakFinder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterAutoCorrector Method

SyntaxLanguageExtensionsRegisterAutoCorrector Method

Registers the IAutoCorrector that can perform auto-correction.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterAutoCorrector(
    this ISyntaxLanguage language,
    IAutoCorrector value
)
<ExtensionAttribute>
Public Shared Sub RegisterAutoCorrector (
    language As ISyntaxLanguage,
    value As IAutoCorrector
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.AnalysisIAutoCorrector
The IAutoCorrector instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterCodeBlockFinder Method

SyntaxLanguageExtensionsRegisterCodeBlockFinder Method

Registers the ICodeBlockFinder that can find the containing code block for a text range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterCodeBlockFinder(
    this ISyntaxLanguage language,
    ICodeBlockFinder value
)
<ExtensionAttribute>
Public Shared Sub RegisterCodeBlockFinder (
    language As ISyntaxLanguage,
    value As ICodeBlockFinder
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.AnalysisICodeBlockFinder
The ICodeBlockFinder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterDelimiterAutoCompleter Method

SyntaxLanguageExtensionsRegisterDelimiterAutoCompleter Method

Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterDelimiterAutoCompleter(
    this ISyntaxLanguage language,
    IDelimiterAutoCompleter value
)
<ExtensionAttribute>
Public Shared Sub RegisterDelimiterAutoCompleter (
    language As ISyntaxLanguage,
    value As IDelimiterAutoCompleter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.AnalysisIDelimiterAutoCompleter
The IDelimiterAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterExampleTextProvider Method

SyntaxLanguageExtensionsRegisterExampleTextProvider Method

Registers the IExampleTextProvider that can generate example text for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterExampleTextProvider(
    this ISyntaxLanguage language,
    IExampleTextProvider value
)
<ExtensionAttribute>
Public Shared Sub RegisterExampleTextProvider (
    language As ISyntaxLanguage,
    value As IExampleTextProvider
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextIExampleTextProvider
The IExampleTextProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterIndentProvider Method

SyntaxLanguageExtensionsRegisterIndentProvider Method

Registers the IIndentProvider that can indent text for the language when the Enter key pressed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterIndentProvider(
    this ISyntaxLanguage language,
    IIndentProvider value
)
<ExtensionAttribute>
Public Shared Sub RegisterIndentProvider (
    language As ISyntaxLanguage,
    value As IIndentProvider
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIIndentProvider
The IIndentProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterLexer Method

SyntaxLanguageExtensionsRegisterLexer Method

Registers the ILexer that can be used for lexing of the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterLexer(
    this ISyntaxLanguage language,
    ILexer value
)
<ExtensionAttribute>
Public Shared Sub RegisterLexer (
    language As ISyntaxLanguage,
    value As ILexer
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.LexingILexer
The ILexer instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterLineCommenter Method

SyntaxLanguageExtensionsRegisterLineCommenter Method

Registers the ILineCommenter that can comment and uncomment lines for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterLineCommenter(
    this ISyntaxLanguage language,
    ILineCommenter value
)
<ExtensionAttribute>
Public Shared Sub RegisterLineCommenter (
    language As ISyntaxLanguage,
    value As ILineCommenter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextILineCommenter
The ILineCommenter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterNavigableSymbolProvider Method

SyntaxLanguageExtensionsRegisterNavigableSymbolProvider Method

Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterNavigableSymbolProvider(
    this ISyntaxLanguage language,
    INavigableSymbolProvider value
)
<ExtensionAttribute>
Public Shared Sub RegisterNavigableSymbolProvider (
    language As ISyntaxLanguage,
    value As INavigableSymbolProvider
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptINavigableSymbolProvider
The INavigableSymbolProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterOutliner Method

SyntaxLanguageExtensionsRegisterOutliner Method

Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterOutliner(
    this ISyntaxLanguage language,
    IOutliner value
)
<ExtensionAttribute>
Public Shared Sub RegisterOutliner (
    language As ISyntaxLanguage,
    value As IOutliner
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.OutliningIOutliner
The IOutliner instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterParser Method

SyntaxLanguageExtensionsRegisterParser Method

Registers the IParser that can be used for parsing of the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterParser(
    this ISyntaxLanguage language,
    IParser value
)
<ExtensionAttribute>
Public Shared Sub RegisterParser (
    language As ISyntaxLanguage,
    value As IParser
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.ParsingIParser
The IParser instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterStructureMatcher Method

SyntaxLanguageExtensionsRegisterStructureMatcher Method

Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterStructureMatcher(
    this ISyntaxLanguage language,
    IStructureMatcher value
)
<ExtensionAttribute>
Public Shared Sub RegisterStructureMatcher (
    language As ISyntaxLanguage,
    value As IStructureMatcher
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.AnalysisIStructureMatcher
The IStructureMatcher instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterTextFormatter Method

SyntaxLanguageExtensionsRegisterTextFormatter Method

Registers the ITextFormatter that can improve the readability of code for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterTextFormatter(
    this ISyntaxLanguage language,
    ITextFormatter value
)
<ExtensionAttribute>
Public Shared Sub RegisterTextFormatter (
    language As ISyntaxLanguage,
    value As ITextFormatter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextITextFormatter
The ITextFormatter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterTextStatisticsFactory Method

SyntaxLanguageExtensionsRegisterTextStatisticsFactory Method

Registers the ITextStatisticsFactory that can generate customized text statistics for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterTextStatisticsFactory(
    this ISyntaxLanguage language,
    ITextStatisticsFactory value
)
<ExtensionAttribute>
Public Shared Sub RegisterTextStatisticsFactory (
    language As ISyntaxLanguage,
    value As ITextStatisticsFactory
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextITextStatisticsFactory
The ITextStatisticsFactory instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterTextViewLineNumberProvider Method

SyntaxLanguageExtensionsRegisterTextViewLineNumberProvider Method

Registers the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterTextViewLineNumberProvider(
    this ISyntaxLanguage language,
    ITextViewLineNumberProvider value
)
<ExtensionAttribute>
Public Shared Sub RegisterTextViewLineNumberProvider (
    language As ISyntaxLanguage,
    value As ITextViewLineNumberProvider
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Windows.Controls.SyntaxEditorITextViewLineNumberProvider
The ITextViewLineNumberProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterWordBreakFinder Method

SyntaxLanguageExtensionsRegisterWordBreakFinder Method

Registers the IWordBreakFinder that is capable of locating word breaks for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterWordBreakFinder(
    this ISyntaxLanguage language,
    IWordBreakFinder value
)
<ExtensionAttribute>
Public Shared Sub RegisterWordBreakFinder (
    language As ISyntaxLanguage,
    value As IWordBreakFinder
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextIWordBreakFinder
The IWordBreakFinder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterAutoCorrector Method

SyntaxLanguageExtensionsUnregisterAutoCorrector Method

Unregisters the IAutoCorrector that can perform auto-correction.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterAutoCorrector(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterAutoCorrector (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterCodeBlockFinder Method

SyntaxLanguageExtensionsUnregisterCodeBlockFinder Method

Unregisters the ICodeBlockFinder that can find the containing code block for a text range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterCodeBlockFinder(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterCodeBlockFinder (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterDelimiterAutoCompleter Method

SyntaxLanguageExtensionsUnregisterDelimiterAutoCompleter Method

Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterDelimiterAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterDelimiterAutoCompleter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterExampleTextProvider Method

SyntaxLanguageExtensionsUnregisterExampleTextProvider Method

Unregisters the IExampleTextProvider that can generate example text for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterExampleTextProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterExampleTextProvider (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterIndentProvider Method

SyntaxLanguageExtensionsUnregisterIndentProvider Method

Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterIndentProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterIndentProvider (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterLexer Method

SyntaxLanguageExtensionsUnregisterLexer Method

Unregisters the ILexer that can be used for lexing of the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterLexer(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterLexer (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterLineCommenter Method

SyntaxLanguageExtensionsUnregisterLineCommenter Method

Unregisters the ILineCommenter that can comment and uncomment lines for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterLineCommenter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterLineCommenter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterNavigableSymbolProvider Method

SyntaxLanguageExtensionsUnregisterNavigableSymbolProvider Method

Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterNavigableSymbolProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterNavigableSymbolProvider (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterOutliner Method

SyntaxLanguageExtensionsUnregisterOutliner Method

Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterOutliner(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterOutliner (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterParser Method

SyntaxLanguageExtensionsUnregisterParser Method

Unregisters the IParser that can be used for parsing of the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterParser(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterParser (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterStructureMatcher Method

SyntaxLanguageExtensionsUnregisterStructureMatcher Method

Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterStructureMatcher(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterStructureMatcher (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterTextFormatter Method

SyntaxLanguageExtensionsUnregisterTextFormatter Method

Unregisters the ITextFormatter that can improve the readability of code for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterTextFormatter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterTextFormatter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterTextStatisticsFactory Method

SyntaxLanguageExtensionsUnregisterTextStatisticsFactory Method

Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterTextStatisticsFactory(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterTextStatisticsFactory (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterTextViewLineNumberProvider Method

SyntaxLanguageExtensionsUnregisterTextViewLineNumberProvider Method

Unregisters the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterTextViewLineNumberProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterTextViewLineNumberProvider (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterWordBreakFinder Method

SyntaxLanguageExtensionsUnregisterWordBreakFinder Method

Unregisters the IWordBreakFinder that is capable of locating word breaks for the language.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterWordBreakFinder(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterWordBreakFinder (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


TextChangeOffsetDelta Enumeration

Specifies how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TextChangeOffsetDelta
Public Enumeration TextChangeOffsetDelta
Members
Member name | Value | Description
None | 0 | No offset delta is applied to operations.
SequentialOnly 1 An offset delta is tracked based on the net length change of previously-added operations. This offset delta is applied to the start offset of any newly-added operation.

It is important to note that this option cannot be used if any newly-added operation will be made before a previously-added operation.

This option is extremely handy when sequentially adding operations based on the original snapshot's offsets since it automatically applies the offset delta to ensure that operations are updating the correct text range.

See Also

Reference

ActiproSoftware.Text Namespace


TextChangeTypes Class

Provides access to the built-in ITextChangeType instances, that indicate the type of ITextChange made.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextTextChangeTypes

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class TextChangeTypes
Public NotInheritable Class TextChangeTypes

The TextChangeTypes type exposes the following members.

Properties
Name | Description
AutoComplete | Gets the ITextChangeType for an IntelliPrompt auto-complete action.
AutoCorrect | Gets the ITextChangeType for an auto-correct action.
AutoFormat | Gets the ITextChangeType for an auto-format action.
AutoIndent | Gets the ITextChangeType for an auto-indent action.
AutoReplace | Gets the ITextChangeType for an auto-replace action.
Backspace | Gets the ITextChangeType for the press of the Backspace key.
ChangeCase | Gets the ITextChangeType for a character casing change action.
CommentLines | Gets the ITextChangeType for a comment lines action.
ConvertSpacesToTabs | Gets the ITextChangeType for a convert spaces to tabs action.
ConvertTabsToSpaces | Gets the ITextChangeType for a convert tabs to spaces action.
Custom | Gets the ITextChangeType for a custom change type.
Cut | Gets the ITextChangeType for a cut to the clipboard action.
Delete | Gets the ITextChangeType for a deletion action.
DragAndDrop | Gets the ITextChangeType for a drag and drop action.
Duplicate | Gets the ITextChangeType for a duplicating a selection.
Enter | Gets the ITextChangeType for the press of the Enter key.
HeaderAndFooterChange | Gets the ITextChangeType for the change of a snapshot's header and footer.
Indent | Gets the ITextChangeType for an indent action.
InsertCodeSnippetTemplate | Gets the ITextChangeType for a code snippet template insertion action.
InsertFile | Gets the ITextChangeType for an insert file action.
MoveSelectedLinesDown | Gets the ITextChangeType for a move selected lines down action.
MoveSelectedLinesUp | Gets the ITextChangeType for a move selected lines up action.
OpenLine | Gets the ITextChangeType for an open line action.
Outdent | Gets the ITextChangeType for an outdent action.
Paste | Gets the ITextChangeType for a paste from the clipboard action.
Replace | Gets the ITextChangeType for a replace action.
ReplaceAll | Gets the ITextChangeType for a replace all action.
SpellingChange | Gets the ITextChangeType for a spelling change action.
TextReplacement | Gets the ITextChangeType for a text replacement action.
ToggleCase | Gets the ITextChangeType for a toggle case action.
TransposeCharacters | Gets the ITextChangeType for a transpose characters action.
TransposeLines | Gets the ITextChangeType for a transpose lines action.
TransposeWords | Gets the ITextChangeType for a transpose words action.
TrimTrailingWhitespace | Gets the ITextChangeType for a trim trailing whitespace action.
Typing | Gets the ITextChangeType for a typing action.
UncommentLines | Gets the ITextChangeType for an uncomment lines action.
UpdateCodeSnippetTemplateFields | Gets the ITextChangeType for a code snippet template update fields action.
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextChangeTypes Properties

The TextChangeTypes type exposes the following members.

Properties
Name | Description
AutoComplete | Gets the ITextChangeType for an IntelliPrompt auto-complete action.
AutoCorrect | Gets the ITextChangeType for an auto-correct action.
AutoFormat | Gets the ITextChangeType for an auto-format action.
AutoIndent | Gets the ITextChangeType for an auto-indent action.
AutoReplace | Gets the ITextChangeType for an auto-replace action.
Backspace | Gets the ITextChangeType for the press of the Backspace key.
ChangeCase | Gets the ITextChangeType for a character casing change action.
CommentLines | Gets the ITextChangeType for a comment lines action.
ConvertSpacesToTabs | Gets the ITextChangeType for a convert spaces to tabs action.
ConvertTabsToSpaces | Gets the ITextChangeType for a convert tabs to spaces action.
Custom | Gets the ITextChangeType for a custom change type.
Cut | Gets the ITextChangeType for a cut to the clipboard action.
Delete | Gets the ITextChangeType for a deletion action.
DragAndDrop | Gets the ITextChangeType for a drag and drop action.
Duplicate | Gets the ITextChangeType for a duplicating a selection.
Enter | Gets the ITextChangeType for the press of the Enter key.
HeaderAndFooterChange | Gets the ITextChangeType for the change of a snapshot's header and footer.
Indent | Gets the ITextChangeType for an indent action.
InsertCodeSnippetTemplate | Gets the ITextChangeType for a code snippet template insertion action.
InsertFile | Gets the ITextChangeType for an insert file action.
MoveSelectedLinesDown | Gets the ITextChangeType for a move selected lines down action.
MoveSelectedLinesUp | Gets the ITextChangeType for a move selected lines up action.
OpenLine | Gets the ITextChangeType for an open line action.
Outdent | Gets the ITextChangeType for an outdent action.
Paste | Gets the ITextChangeType for a paste from the clipboard action.
Replace | Gets the ITextChangeType for a replace action.
ReplaceAll | Gets the ITextChangeType for a replace all action.
SpellingChange | Gets the ITextChangeType for a spelling change action.
TextReplacement | Gets the ITextChangeType for a text replacement action.
ToggleCase | Gets the ITextChangeType for a toggle case action.
TransposeCharacters | Gets the ITextChangeType for a transpose characters action.
TransposeLines | Gets the ITextChangeType for a transpose lines action.
TransposeWords | Gets the ITextChangeType for a transpose words action.
TrimTrailingWhitespace | Gets the ITextChangeType for a trim trailing whitespace action.
Typing | Gets the ITextChangeType for a typing action.
UncommentLines | Gets the ITextChangeType for an uncomment lines action.
UpdateCodeSnippetTemplateFields | Gets the ITextChangeType for a code snippet template update fields action.
Top
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoComplete Property

TextChangeTypesAutoComplete Property

Gets the ITextChangeType for an IntelliPrompt auto-complete action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoComplete { get; }
Public Shared ReadOnly Property AutoComplete As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an IntelliPrompt auto-complete action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoCorrect Property

TextChangeTypesAutoCorrect Property

Gets the ITextChangeType for an auto-correct action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoCorrect { get; }
Public Shared ReadOnly Property AutoCorrect As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an auto-correct action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoFormat Property

TextChangeTypesAutoFormat Property

Gets the ITextChangeType for an auto-format action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoFormat { get; }
Public Shared ReadOnly Property AutoFormat As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an auto-format action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoIndent Property

TextChangeTypesAutoIndent Property

Gets the ITextChangeType for an auto-indent action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoIndent { get; }
Public Shared ReadOnly Property AutoIndent As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an auto-indent action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoReplace Property

TextChangeTypesAutoReplace Property

Gets the ITextChangeType for an auto-replace action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoReplace { get; }
Public Shared ReadOnly Property AutoReplace As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an auto-replace action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Backspace Property

TextChangeTypesBackspace Property

Gets the ITextChangeType for the press of the Backspace key.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Backspace { get; }
Public Shared ReadOnly Property Backspace As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for the press of the Backspace key.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ChangeCase Property

TextChangeTypesChangeCase Property

Gets the ITextChangeType for a character casing change action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType ChangeCase { get; }
Public Shared ReadOnly Property ChangeCase As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a character casing change action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.CommentLines Property

TextChangeTypesCommentLines Property

Gets the ITextChangeType for a comment lines action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType CommentLines { get; }
Public Shared ReadOnly Property CommentLines As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a comment lines action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ConvertSpacesToTabs Property

TextChangeTypesConvertSpacesToTabs Property

Gets the ITextChangeType for a convert spaces to tabs action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType ConvertSpacesToTabs { get; }
Public Shared ReadOnly Property ConvertSpacesToTabs As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a convert spaces to tabs action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ConvertTabsToSpaces Property

TextChangeTypesConvertTabsToSpaces Property

Gets the ITextChangeType for a convert tabs to spaces action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType ConvertTabsToSpaces { get; }
Public Shared ReadOnly Property ConvertTabsToSpaces As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a convert tabs to spaces action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Custom Property

TextChangeTypesCustom Property

Gets the ITextChangeType for a custom change type.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Custom { get; }
Public Shared ReadOnly Property Custom As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a custom change type.
Remarks
Instead of using this ITextChangeType, it really is best to create your own custom ITextChangeType with the proper name.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Cut Property

TextChangeTypesCut Property

Gets the ITextChangeType for a cut to the clipboard action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Cut { get; }
Public Shared ReadOnly Property Cut As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a cut to the clipboard action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Delete Property

TextChangeTypesDelete Property

Gets the ITextChangeType for a deletion action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Delete { get; }
Public Shared ReadOnly Property Delete As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a deletion action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.DragAndDrop Property

TextChangeTypesDragAndDrop Property

Gets the ITextChangeType for a drag and drop action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType DragAndDrop { get; }
Public Shared ReadOnly Property DragAndDrop As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a drag and drop action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Duplicate Property

TextChangeTypesDuplicate Property

Gets the ITextChangeType for a duplicating a selection.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Duplicate { get; }
Public Shared ReadOnly Property Duplicate As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a duplicating a selection.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Enter Property

TextChangeTypesEnter Property

Gets the ITextChangeType for the press of the Enter key.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Enter { get; }
Public Shared ReadOnly Property Enter As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for the press of the Enter key.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.HeaderAndFooterChange Property

TextChangeTypesHeaderAndFooterChange Property

Gets the ITextChangeType for the change of a snapshot's header and footer.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType HeaderAndFooterChange { get; }
Public Shared ReadOnly Property HeaderAndFooterChange As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for the change of a snapshot's header and footer.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Indent Property

TextChangeTypesIndent Property

Gets the ITextChangeType for an indent action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Indent { get; }
Public Shared ReadOnly Property Indent As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an indent action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.InsertCodeSnippetTemplate Property

TextChangeTypesInsertCodeSnippetTemplate Property

Gets the ITextChangeType for a code snippet template insertion action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType InsertCodeSnippetTemplate { get; }
Public Shared ReadOnly Property InsertCodeSnippetTemplate As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a code snippet template insertion action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.InsertFile Property

TextChangeTypesInsertFile Property

Gets the ITextChangeType for an insert file action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType InsertFile { get; }
Public Shared ReadOnly Property InsertFile As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an insert file action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.MoveSelectedLinesDown Property

TextChangeTypesMoveSelectedLinesDown Property

Gets the ITextChangeType for a move selected lines down action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType MoveSelectedLinesDown { get; }
Public Shared ReadOnly Property MoveSelectedLinesDown As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a move selected lines down action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.MoveSelectedLinesUp Property

TextChangeTypesMoveSelectedLinesUp Property

Gets the ITextChangeType for a move selected lines up action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType MoveSelectedLinesUp { get; }
Public Shared ReadOnly Property MoveSelectedLinesUp As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a move selected lines up action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.OpenLine Property

TextChangeTypesOpenLine Property

Gets the ITextChangeType for an open line action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType OpenLine { get; }
Public Shared ReadOnly Property OpenLine As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an open line action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Outdent Property

TextChangeTypesOutdent Property

Gets the ITextChangeType for an outdent action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Outdent { get; }
Public Shared ReadOnly Property Outdent As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an outdent action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Paste Property

TextChangeTypesPaste Property

Gets the ITextChangeType for a paste from the clipboard action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Paste { get; }
Public Shared ReadOnly Property Paste As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a paste from the clipboard action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Replace Property

TextChangeTypesReplace Property

Gets the ITextChangeType for a replace action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Replace { get; }
Public Shared ReadOnly Property Replace As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a replace action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ReplaceAll Property

TextChangeTypesReplaceAll Property

Gets the ITextChangeType for a replace all action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType ReplaceAll { get; }
Public Shared ReadOnly Property ReplaceAll As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a replace all action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.SpellingChange Property

TextChangeTypesSpellingChange Property

Gets the ITextChangeType for a spelling change action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType SpellingChange { get; }
Public Shared ReadOnly Property SpellingChange As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a spelling change action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TextReplacement Property

TextChangeTypesTextReplacement Property

Gets the ITextChangeType for a text replacement action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType TextReplacement { get; }
Public Shared ReadOnly Property TextReplacement As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a text replacement action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ToggleCase Property

TextChangeTypesToggleCase Property

Gets the ITextChangeType for a toggle case action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType ToggleCase { get; }
Public Shared ReadOnly Property ToggleCase As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a toggle case action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TransposeCharacters Property

TextChangeTypesTransposeCharacters Property

Gets the ITextChangeType for a transpose characters action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType TransposeCharacters { get; }
Public Shared ReadOnly Property TransposeCharacters As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a transpose characters action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TransposeLines Property

TextChangeTypesTransposeLines Property

Gets the ITextChangeType for a transpose lines action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType TransposeLines { get; }
Public Shared ReadOnly Property TransposeLines As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a transpose lines action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TransposeWords Property

TextChangeTypesTransposeWords Property

Gets the ITextChangeType for a transpose words action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType TransposeWords { get; }
Public Shared ReadOnly Property TransposeWords As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a transpose words action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TrimTrailingWhitespace Property

TextChangeTypesTrimTrailingWhitespace Property

Gets the ITextChangeType for a trim trailing whitespace action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType TrimTrailingWhitespace { get; }
Public Shared ReadOnly Property TrimTrailingWhitespace As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a trim trailing whitespace action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Typing Property

TextChangeTypesTyping Property

Gets the ITextChangeType for a typing action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType Typing { get; }
Public Shared ReadOnly Property Typing As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a typing action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.UncommentLines Property

TextChangeTypesUncommentLines Property

Gets the ITextChangeType for an uncomment lines action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType UncommentLines { get; }
Public Shared ReadOnly Property UncommentLines As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an uncomment lines action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.UpdateCodeSnippetTemplateFields Property

TextChangeTypesUpdateCodeSnippetTemplateFields Property

Gets the ITextChangeType for a code snippet template update fields action.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextChangeType UpdateCodeSnippetTemplateFields { get; }
Public Shared ReadOnly Property UpdateCodeSnippetTemplateFields As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a code snippet template update fields action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextFormatMode Enumeration

Specifies whether to format text over an entire snapshot or only for specified ranges.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TextFormatMode
Public Enumeration TextFormatMode
Members
Member name | Value | Description
All | 0 | Format the entire snapshot.
Ranges | 1 | Format the specified ranges, which generally correspond to a view's selection.
See Also

Reference

ActiproSoftware.Text Namespace


TextOffsetTrackingMode Enumeration

Specifies how a text offset is updated by text change operations that occur around it.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TextOffsetTrackingMode
Public Enumeration TextOffsetTrackingMode
Members
Member name Value Description
Negative 0 The text offset tends to move in a negative (towards document start) direction when text change operations occur next to it.

If the text offset is 3, and a single character is inserted at offset 2, the text offset slides forward a character and becomes 4.

If the text offset is 3, and a single character is inserted at offset 3, the text offset remains 3.

If the text offset is 3, and the text range {2,4} is replaced with text Foo, the text offset moves to 2, which is the start of the text change operation.

Positive 1 The text offset tends to move in a positive (towards document end) direction when text change operations occur next to it.

If the text offset is 3, and a single character is inserted at offset 2, the text offset slides forward a character and becomes 4.

If the text offset is 3, and a single character is inserted at offset 3, the text offset slides forward a character and becomes 4.

If the text offset is 3, and the text range {2,4} is replaced with text Foo, the text offset moves to 5, which is the end of the text change operation's insertion.

See Also

Reference

ActiproSoftware.Text Namespace


TextPosition Structure

Represents an ordered pair of zero-based line and character index values that defines a position within the lines of an ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct TextPosition
<SerializableAttribute>
Public Structure TextPosition

The TextPosition type exposes the following members.

Constructors
 | Name | Description
Public method | TextPosition(TextPosition, Boolean) | Initializes a new instance of the TextPosition class with the specified TextPosition values.
Public method | TextPosition(Int32, Int32, Boolean) | Initializes a new instance of the TextPosition class with the specified line and character values.
Top
Properties
 | Name | Description
Public property | Character | Gets the zero-based character of this TextPosition.
Public property | DisplayCharacter | Gets the one-based character of this TextPosition, which is better for display than use of the Character property.
Public property | DisplayLine | Gets the one-based line of this TextPosition, which is better for display than use of the Line property.
Public property | HasFarAffinity | Gets whether the position has affinity for the far side.
Public property | IsEmpty | Returns whether the TextPosition is empty.
Public property | Line | Gets the zero-based line of this TextPosition.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of this TextPosition object.
Public method | CompareTo(Object) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextPosition) | Compares the current instance with another TextPosition.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
 | First | Returns the TextPosition that comes first.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
 | Last | Returns the TextPosition that comes last.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Top
Fields
Name | Description
Empty | Returns an empty TextPosition.
MaxCharacter | Gets the maximum character value for a position.
MaxLine | Gets the maximum line value for a position.
Zero | Returns a TextPosition with line and character values of 0.
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextPosition Constructor

Overload List
 | Name | Description
Public method | TextPosition(TextPosition, Boolean) | Initializes a new instance of the TextPosition class with the specified TextPosition values.
Public method | TextPosition(Int32, Int32, Boolean) | Initializes a new instance of the TextPosition class with the specified line and character values.
Top
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition Constructor (TextPosition, Boolean)

Initializes a new instance of the TextPosition class with the specified TextPosition values.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition(
    TextPosition position,
    bool hasFarAffinity = false
)
Public Sub New (
    position As TextPosition,
    Optional hasFarAffinity As Boolean = false
)

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition specifying line and character values.
hasFarAffinity (Optional)
Type: SystemBoolean
Whether the position has affinity for the far side, which is used when the position specifies the place where a view line is wrapped to a second view line. The default value is false.
See Also

Reference

TextPosition Structure
TextPosition Overload
ActiproSoftware.Text Namespace


TextPosition Constructor (Int32, Int32, Boolean)

Initializes a new instance of the TextPosition class with the specified line and character values.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition(
    int line,
    int character,
    bool hasFarAffinity = false
)
Public Sub New (
    line As Integer,
    character As Integer,
    Optional hasFarAffinity As Boolean = false
)

Parameters

line
Type: SystemInt32
The line of the position.
character
Type: SystemInt32
The character of the position.
hasFarAffinity (Optional)
Type: SystemBoolean
Whether the position has affinity for the far side, which is used when the position specifies the place where a view line is wrapped to a second view line. The default value is false.
See Also

Reference

TextPosition Structure
TextPosition Overload
ActiproSoftware.Text Namespace


TextPosition Properties

The TextPosition type exposes the following members.

Properties
 | Name | Description
Public property | Character | Gets the zero-based character of this TextPosition.
Public property | DisplayCharacter | Gets the one-based character of this TextPosition, which is better for display than use of the Character property.
Public property | DisplayLine | Gets the one-based line of this TextPosition, which is better for display than use of the Line property.
Public property | HasFarAffinity | Gets whether the position has affinity for the far side.
Public property | IsEmpty | Returns whether the TextPosition is empty.
Public property | Line | Gets the zero-based line of this TextPosition.
Top
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.Character Property

TextPositionCharacter Property

Gets the zero-based character of this TextPosition.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Character { get; }
Public ReadOnly Property Character As Integer
    Get

Property Value

Type: Int32
The zero-based character of this TextPosition.
Remarks
This property is zero-based. When displaying the value in UI, use the DisplayCharacter property instead, which adds 1 to this value to make it one-based.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.DisplayCharacter Property

TextPositionDisplayCharacter Property

Gets the one-based character of this TextPosition, which is better for display than use of the Character property.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int DisplayCharacter { get; }
Public ReadOnly Property DisplayCharacter As Integer
    Get

Property Value

Type: Int32
The one-based character of this TextPosition, which is better for display than use of the Character property.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.DisplayLine Property

TextPositionDisplayLine Property

Gets the one-based line of this TextPosition, which is better for display than use of the Line property.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int DisplayLine { get; }
Public ReadOnly Property DisplayLine As Integer
    Get

Property Value

Type: Int32
The one-based line of this TextPosition, which is better for display than use of the Line property.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.HasFarAffinity Property

TextPositionHasFarAffinity Property

Gets whether the position has affinity for the far side.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasFarAffinity { get; }
Public ReadOnly Property HasFarAffinity As Boolean
    Get

Property Value

Type: Boolean
true if the position has affinity for the far side; otherwise, false. The default value is false.
Remarks
This property is used in word wrap scenarios where the position is the last position in a view line that gets wrapped to another view line. In that scenario, the position could refer to both the end of the first line and the beginning of the second line. When this property is true, the position will refer to the beginning of the second line.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.IsEmpty Property

TextPositionIsEmpty Property

Returns whether the TextPosition is empty.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the TextPosition is empty; otherwise, false.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.Line Property

TextPositionLine Property

Gets the zero-based line of this TextPosition.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Line { get; }
Public ReadOnly Property Line As Integer
    Get

Property Value

Type: Int32
The zero-based line of this TextPosition.
Remarks
This property is zero-based. When displaying the value in UI, use the DisplayCharacter property instead, which adds 1 to this value to make it one-based.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition Methods

The TextPosition type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of this TextPosition object.
Public method | CompareTo(Object) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextPosition) | Compares the current instance with another TextPosition.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
 | First | Returns the TextPosition that comes first.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
 | Last | Returns the TextPosition that comes last.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.Clone Method

TextPositionClone Method

Creates a copy of this TextPosition object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
The TextPosition object that this method creates.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.CompareTo Method

TextPositionCompareTo Method

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextPosition) | Compares the current instance with another TextPosition.
Top
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.CompareTo Method (Object)

TextPositionCompareTo Method (Object)

Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer

Parameters

obj
Type: SystemObject
An object to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextPosition Structure
CompareTo Overload
ActiproSoftware.Text Namespace


TextPosition.CompareTo Method (TextPosition)

TextPositionCompareTo Method (TextPosition)

Compares the current instance with another TextPosition.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextPosition position
)
Public Function CompareTo (
    position As TextPosition
) As Integer

Parameters

position
Type: ActiproSoftware.TextTextPosition
A TextPosition to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextPosition Structure
CompareTo Overload
ActiproSoftware.Text Namespace


TextPosition.Equals Method

TextPositionEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.First Method

TextPositionFirst Method

Returns the TextPosition that comes first.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextPosition First(
    TextPosition position1,
    TextPosition position2
)
Public Shared Function First (
    position1 As TextPosition,
    position2 As TextPosition
) As TextPosition

Parameters

position1
Type: ActiproSoftware.TextTextPosition
The first TextPosition to compare.
position2
Type: ActiproSoftware.TextTextPosition
The second TextPosition to compare.

Return Value

Type: TextPosition
The TextPosition that comes first.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.GetHashCode Method

TextPositionGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.Last Method

TextPositionLast Method

Returns the TextPosition that comes last.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextPosition Last(
    TextPosition position1,
    TextPosition position2
)
Public Shared Function Last (
    position1 As TextPosition,
    position2 As TextPosition
) As TextPosition

Parameters

position1
Type: ActiproSoftware.TextTextPosition
The first TextPosition to compare.
position2
Type: ActiproSoftware.TextTextPosition
The second TextPosition to compare.

Return Value

Type: TextPosition
The TextPosition that comes last.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.ToString Method

TextPositionToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition Operators

The TextPosition type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Top
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.Equality Operator

TextPositionEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_Equality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextPosition left,
    TextPosition right
)
Public Shared Operator = (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_Equality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_Equality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_Equality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.GreaterThan Operator

TextPositionGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator >(
    TextPosition left,
    TextPosition right
)
Public Shared Operator > (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.GreaterThanOrEqual Operator

TextPositionGreaterThanOrEqual Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator >=(
    TextPosition left,
    TextPosition right
)
Public Shared Operator >= (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.Inequality Operator

TextPositionInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_Inequality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextPosition left,
    TextPosition right
)
Public Shared Operator <> (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_Inequality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_Inequality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_Inequality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.LessThan Operator

TextPositionLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator <(
    TextPosition left,
    TextPosition right
)
Public Shared Operator < (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.LessThanOrEqual Operator

TextPositionLessThanOrEqual Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator <=(
    TextPosition left,
    TextPosition right
)
Public Shared Operator <= (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition Fields

The TextPosition type exposes the following members.

Fields
Name | Description
Empty | Returns an empty TextPosition.
MaxCharacter | Gets the maximum character value for a position.
MaxLine | Gets the maximum line value for a position.
Zero | Returns a TextPosition with line and character values of 0.
Top
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.Empty Field

TextPositionEmpty Field

Returns an empty TextPosition.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly TextPosition Empty
Public Shared ReadOnly Empty As TextPosition

Field Value

Type: TextPosition
A TextPosition that is empty.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.MaxCharacter Field

TextPositionMaxCharacter Field

Gets the maximum character value for a position.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int MaxCharacter = 2147483647
Public Const MaxCharacter As Integer = 2147483647

Field Value

Type: Int32
The maximum character value for a position.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.MaxLine Field

TextPositionMaxLine Field

Gets the maximum line value for a position.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int MaxLine = 2147483647
Public Const MaxLine As Integer = 2147483647

Field Value

Type: Int32
The maximum line value for a position.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPosition.Zero Field

TextPositionZero Field

Returns a TextPosition with line and character values of 0.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly TextPosition Zero
Public Shared ReadOnly Zero As TextPosition

Field Value

Type: TextPosition
A TextPosition with line and character values of 0.
See Also

Reference

TextPosition Structure
ActiproSoftware.Text Namespace


TextPositionRange Structure

Represents a range of two TextPosition values within the lines of an ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct TextPositionRange
<SerializableAttribute>
Public Structure TextPositionRange

The TextPositionRange type exposes the following members.

Constructors
 | Name | Description
Public method | TextPositionRange(TextPosition) | Initializes a new instance of the TextPositionRange class with the specified TextPosition value for both start and end.
Public method | TextPositionRange(TextPosition, TextPosition) | Initializes a new instance of the TextPositionRange class with the specified TextPosition values.
Public method | TextPositionRange(Int32, Int32, Int32, Int32) | Initializes a new instance of the TextPositionRange class with the specified TextPosition values.
Top
Properties
 | Name | Description
 | Empty | Returns an empty TextPositionRange.
Public property | EndPosition | Gets the end TextPosition in the range.
Public property | FirstPosition | Gets the first TextPosition in the range.
Public property | IsEmpty | Returns whether the TextPositionRange is empty.
Public property | IsNormalized | Gets whether the range is normalized (StartPosition occurs at or before the EndPosition).
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | LastPosition | Gets the last TextPosition in the range.
Public property | Lines | Gets the number of lines encompassed by the TextPositionRange.
Public property | NormalizedTextPositionRange | Gets a normalized version of this TextPositionRange without actually modifying this instance.
Public property | StartPosition | Gets the start TextPosition in the range.
Top
Methods
 | Name | Description
Public method | BordersOn(TextPosition) | Returns whether the TextPositionRange borders on the specified TextPosition.
Public method | BordersOn(TextPositionRange) | Returns whether the TextPositionRange borders on, but does not overlap the specified TextPositionRange.
Public method | Clone | Creates a copy of this TextPositionRange object.
Public method | Contains(TextPosition) | Returns whether the TextPositionRange contains the specified TextPosition.
Public method | Contains(TextPositionRange) | Returns whether the TextPositionRange contains the specified TextPositionRange.
 | CreateCollection(TextPositionRange, Boolean) | Creates a collection containing a single TextPositionRange object.
 | CreateCollection(IEnumerableTextPositionRange, Int32) | Creates a collection of TextPositionRange objects.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | IntersectsWith(TextPosition) | Returns whether the TextPositionRange intersects with the specified TextPosition.
Public method | IntersectsWith(TextPositionRange) | Returns whether the TextPositionRange intersects with the specified TextPositionRange.
Public method | Normalize | Normalizes the range and ensures that the StartPosition occurs at or before the EndPosition TextPosition.
Public method | OverlapsWith | Returns whether the TextPositionRange overlaps with, or crosses, the specified TextPositionRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
 | Union | Returns the normalized union of two TextPositionRange objects.
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextPositionRange Constructor

Overload List
 | Name | Description
Public method | TextPositionRange(TextPosition) | Initializes a new instance of the TextPositionRange class with the specified TextPosition value for both start and end.
Public method | TextPositionRange(TextPosition, TextPosition) | Initializes a new instance of the TextPositionRange class with the specified TextPosition values.
Public method | TextPositionRange(Int32, Int32, Int32, Int32) | Initializes a new instance of the TextPositionRange class with the specified TextPosition values.
Top
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange Constructor (TextPosition)

Initializes a new instance of the TextPositionRange class with the specified TextPosition value for both start and end.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPositionRange(
    TextPosition position
)
Public Sub New (
    position As TextPosition
)

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to use as the start and end of the range.
See Also

Reference

TextPositionRange Structure
TextPositionRange Overload
ActiproSoftware.Text Namespace


TextPositionRange Constructor (TextPosition, TextPosition)

Initializes a new instance of the TextPositionRange class with the specified TextPosition values.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPositionRange(
    TextPosition startPosition,
    TextPosition endPosition
)
Public Sub New (
    startPosition As TextPosition,
    endPosition As TextPosition
)

Parameters

startPosition
Type: ActiproSoftware.TextTextPosition
The start TextPosition in the range.
endPosition
Type: ActiproSoftware.TextTextPosition
The end TextPositionin the range.
See Also

Reference

TextPositionRange Structure
TextPositionRange Overload
ActiproSoftware.Text Namespace


TextPositionRange Constructor (Int32, Int32, Int32, Int32)

Initializes a new instance of the TextPositionRange class with the specified TextPosition values.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPositionRange(
    int startLine,
    int startCharacter,
    int endLine,
    int endCharacter
)
Public Sub New (
    startLine As Integer,
    startCharacter As Integer,
    endLine As Integer,
    endCharacter As Integer
)

Parameters

startLine
Type: SystemInt32
The line of the start TextPositionin the range.
startCharacter
Type: SystemInt32
The character of the start TextPositionin the range.
endLine
Type: SystemInt32
The line of the end TextPositionin the range.
endCharacter
Type: SystemInt32
The character of the end TextPositionin the range.
See Also

Reference

TextPositionRange Structure
TextPositionRange Overload
ActiproSoftware.Text Namespace


TextPositionRange Properties

The TextPositionRange type exposes the following members.

Properties
 | Name | Description
 | Empty | Returns an empty TextPositionRange.
Public property | EndPosition | Gets the end TextPosition in the range.
Public property | FirstPosition | Gets the first TextPosition in the range.
Public property | IsEmpty | Returns whether the TextPositionRange is empty.
Public property | IsNormalized | Gets whether the range is normalized (StartPosition occurs at or before the EndPosition).
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | LastPosition | Gets the last TextPosition in the range.
Public property | Lines | Gets the number of lines encompassed by the TextPositionRange.
Public property | NormalizedTextPositionRange | Gets a normalized version of this TextPositionRange without actually modifying this instance.
Public property | StartPosition | Gets the start TextPosition in the range.
Top
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.Empty Property

TextPositionRangeEmpty Property

Returns an empty TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextPositionRange Empty { get; }
Public Shared ReadOnly Property Empty As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A TextPositionRange that is empty.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.EndPosition Property

TextPositionRangeEndPosition Property

Gets the end TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition EndPosition { get; }
Public ReadOnly Property EndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The end TextPosition in the range.
Remarks
The end TextPosition may occur before the start TextPosition if the range is not normalized. The IsNormalized property indicates if the range is normalized. To get the normalized first TextPosition in the range, use the FirstPosition property. To get the normalized last TextPosition in the range, use the LastPosition property.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.FirstPosition Property

TextPositionRangeFirstPosition Property

Gets the first TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition FirstPosition { get; }
Public ReadOnly Property FirstPosition As TextPosition
    Get

Property Value

Type: TextPosition
The first TextPosition in the range.
Remarks
This property returns either the StartPosition or EndPosition property, whichever comes first.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.IsEmpty Property

TextPositionRangeIsEmpty Property

Returns whether the TextPositionRange is empty.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the TextPositionRange is empty; otherwise, false.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.IsNormalized Property

TextPositionRangeIsNormalized Property

Gets whether the range is normalized (StartPosition occurs at or before the EndPosition).

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNormalized { get; }
Public ReadOnly Property IsNormalized As Boolean
    Get

Property Value

Type: Boolean
true if the range is normalized; otherwise, false.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.IsZeroLength Property

TextPositionRangeIsZeroLength Property

Gets whether the range has a zero length.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsZeroLength { get; }
Public ReadOnly Property IsZeroLength As Boolean
    Get

Property Value

Type: Boolean
true if the range has a zero length; otherwise, false.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.LastPosition Property

TextPositionRangeLastPosition Property

Gets the last TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition LastPosition { get; }
Public ReadOnly Property LastPosition As TextPosition
    Get

Property Value

Type: TextPosition
The last TextPosition in the range.
Remarks
This property returns either the StartPosition or EndPosition property, whichever comes last.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.Lines Property

TextPositionRangeLines Property

Gets the number of lines encompassed by the TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Lines { get; }
Public ReadOnly Property Lines As Integer
    Get

Property Value

Type: Int32
The number of lines encompassed by the TextPositionRange.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.NormalizedTextPositionRange Property

TextPositionRangeNormalizedTextPositionRange Property

Gets a normalized version of this TextPositionRange without actually modifying this instance.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPositionRange NormalizedTextPositionRange { get; }
Public ReadOnly Property NormalizedTextPositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A normalized version of this TextPositionRange without actually modifying this instance.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.StartPosition Property

TextPositionRangeStartPosition Property

Gets the start TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition StartPosition { get; }
Public ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The start TextPosition in the range.
Remarks
The start TextPosition may occur after the end TextPosition if the range is not normalized. The IsNormalized property indicates if the range is normalized. To get the normalized first TextPosition in the range, use the FirstPosition property. To get the normalized last TextPosition in the range, use the LastPosition property.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange Methods

The TextPositionRange type exposes the following members.

Methods
 | Name | Description
Public method | BordersOn(TextPosition) | Returns whether the TextPositionRange borders on the specified TextPosition.
Public method | BordersOn(TextPositionRange) | Returns whether the TextPositionRange borders on, but does not overlap the specified TextPositionRange.
Public method | Clone | Creates a copy of this TextPositionRange object.
Public method | Contains(TextPosition) | Returns whether the TextPositionRange contains the specified TextPosition.
Public method | Contains(TextPositionRange) | Returns whether the TextPositionRange contains the specified TextPositionRange.
 | CreateCollection(TextPositionRange, Boolean) | Creates a collection containing a single TextPositionRange object.
 | CreateCollection(IEnumerableTextPositionRange, Int32) | Creates a collection of TextPositionRange objects.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | IntersectsWith(TextPosition) | Returns whether the TextPositionRange intersects with the specified TextPosition.
Public method | IntersectsWith(TextPositionRange) | Returns whether the TextPositionRange intersects with the specified TextPositionRange.
Public method | Normalize | Normalizes the range and ensures that the StartPosition occurs at or before the EndPosition TextPosition.
Public method | OverlapsWith | Returns whether the TextPositionRange overlaps with, or crosses, the specified TextPositionRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
 | Union | Returns the normalized union of two TextPositionRange objects.
Top
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.BordersOn Method

TextPositionRangeBordersOn Method

Overload List
 | Name | Description
Public method | BordersOn(TextPosition) | Returns whether the TextPositionRange borders on the specified TextPosition.
Public method | BordersOn(TextPositionRange) | Returns whether the TextPositionRange borders on, but does not overlap the specified TextPositionRange.
Top
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.BordersOn Method (TextPosition)

TextPositionRangeBordersOn Method (TextPosition)

Returns whether the TextPositionRange borders on the specified TextPosition.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextPosition position
)
Public Function BordersOn (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the TextPositionRange borders on the specified TextPosition; otherwise, false.
Remarks
This method checks to see if the specified TextPosition is either the StartPosition or EndPosition.
See Also

Reference

TextPositionRange Structure
BordersOn Overload
ActiproSoftware.Text Namespace


TextPositionRange.BordersOn Method (TextPositionRange)

TextPositionRangeBordersOn Method (TextPositionRange)

Returns whether the TextPositionRange borders on, but does not overlap the specified TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextPositionRange range
)
Public Function BordersOn (
    range As TextPositionRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange to examine.

Return Value

Type: Boolean
true if the TextPositionRange borders on, but does not overlap the specified TextPositionRange; otherwise, false.
See Also

Reference

TextPositionRange Structure
BordersOn Overload
ActiproSoftware.Text Namespace


TextPositionRange.Clone Method

TextPositionRangeClone Method

Creates a copy of this TextPositionRange object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
The TextPositionRange object that this method creates.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.Contains Method

TextPositionRangeContains Method

Overload List
 | Name | Description
Public method | Contains(TextPosition) | Returns whether the TextPositionRange contains the specified TextPosition.
Public method | Contains(TextPositionRange) | Returns whether the TextPositionRange contains the specified TextPositionRange.
Top
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.Contains Method (TextPosition)

TextPositionRangeContains Method (TextPosition)

Returns whether the TextPositionRange contains the specified TextPosition.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    TextPosition position
)
Public Function Contains (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the TextPositionRange contains the specified TextPosition; otherwise, false.
Remarks
This method returns false if the TextPosition falls on the LastPosition TextPosition since this method indicates if the TextPosition is encompassed by the TextPositionRange.
See Also

Reference

TextPositionRange Structure
Contains Overload
ActiproSoftware.Text Namespace


TextPositionRange.Contains Method (TextPositionRange)

TextPositionRangeContains Method (TextPositionRange)

Returns whether the TextPositionRange contains the specified TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    TextPositionRange range
)
Public Function Contains (
    range As TextPositionRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange to examine.

Return Value

Type: Boolean
true if the TextPositionRange contains the specified TextPositionRange; otherwise, false.
See Also

Reference

TextPositionRange Structure
Contains Overload
ActiproSoftware.Text Namespace


TextPositionRange.CreateCollection Method

TextPositionRangeCreateCollection Method

Overload List
Name | Description
CreateCollection(TextPositionRange, Boolean) | Creates a collection containing a single TextPositionRange object.
CreateCollection(IEnumerableTextPositionRange, Int32) | Creates a collection of TextPositionRange objects.
Top
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.CreateCollection Method (TextPositionRange, Boolean)

TextPositionRangeCreateCollection Method (TextPositionRange, Boolean)

Creates a collection containing a single TextPositionRange object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextPositionRangeCollection CreateCollection(
    TextPositionRange positionRange,
    bool isBlock
)
Public Shared Function CreateCollection (
    positionRange As TextPositionRange,
    isBlock As Boolean
) As ITextPositionRangeCollection

Parameters

positionRange
Type: ActiproSoftware.TextTextPositionRange
The single position range.
isBlock
Type: SystemBoolean
Whether the position range is a special rectangular block.

Return Value

Type: ITextPositionRangeCollection
The collection that was created.
See Also

Reference

TextPositionRange Structure
CreateCollection Overload
ActiproSoftware.Text Namespace


TextPositionRange.CreateCollection Method (IEnumerable(TextPositionRange), Int32)

TextPositionRangeCreateCollection Method (IEnumerableTextPositionRange, Int32)

Creates a collection of TextPositionRange objects.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextPositionRangeCollection CreateCollection(
    IEnumerable<TextPositionRange> positionRanges,
    int primaryIndex
)
Public Shared Function CreateCollection (
    positionRanges As IEnumerable(Of TextPositionRange),
    primaryIndex As Integer
) As ITextPositionRangeCollection

Parameters

positionRanges
Type: System.Collections.GenericIEnumerable TextPositionRange
The non-overlapping position ranges, in sorted order.
primaryIndex
Type: SystemInt32
The primary range index.

Return Value

Type: ITextPositionRangeCollection
The collection that was created.
See Also

Reference

TextPositionRange Structure
CreateCollection Overload
ActiproSoftware.Text Namespace


TextPositionRange.Equals Method

TextPositionRangeEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.GetHashCode Method

TextPositionRangeGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.IntersectsWith Method

TextPositionRangeIntersectsWith Method

Overload List
 | Name | Description
Public method | IntersectsWith(TextPosition) | Returns whether the TextPositionRange intersects with the specified TextPosition.
Public method | IntersectsWith(TextPositionRange) | Returns whether the TextPositionRange intersects with the specified TextPositionRange.
Top
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.IntersectsWith Method (TextPosition)

TextPositionRangeIntersectsWith Method (TextPosition)

Returns whether the TextPositionRange intersects with the specified TextPosition.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextPosition position
)
Public Function IntersectsWith (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the TextPositionRange intersects with the specified TextPosition; otherwise, false.
See Also

Reference

TextPositionRange Structure
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextPositionRange.IntersectsWith Method (TextPositionRange)

TextPositionRangeIntersectsWith Method (TextPositionRange)

Returns whether the TextPositionRange intersects with the specified TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextPositionRange range
)
Public Function IntersectsWith (
    range As TextPositionRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange to examine.

Return Value

Type: Boolean
true if the TextPositionRange intersects with the specified TextPositionRange; otherwise, false.
See Also

Reference

TextPositionRange Structure
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextPositionRange.Normalize Method

TextPositionRangeNormalize Method

Normalizes the range and ensures that the StartPosition occurs at or before the EndPosition TextPosition.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Normalize()
Public Sub Normalize
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.OverlapsWith Method

TextPositionRangeOverlapsWith Method

Returns whether the TextPositionRange overlaps with, or crosses, the specified TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    TextPositionRange range
)
Public Function OverlapsWith (
    range As TextPositionRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange to examine.

Return Value

Type: Boolean
true if the TextPositionRange overlaps with, or crosses, the specified TextPositionRange; otherwise, false.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.ToString Method

TextPositionRangeToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.Union Method

TextPositionRangeUnion Method

Returns the normalized union of two TextPositionRange objects.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextPositionRange Union(
    TextPositionRange range1,
    TextPositionRange range2
)
Public Shared Function Union (
    range1 As TextPositionRange,
    range2 As TextPositionRange
) As TextPositionRange

Parameters

range1
Type: ActiproSoftware.TextTextPositionRange
The first TextPositionRange to examine.
range2
Type: ActiproSoftware.TextTextPositionRange
The second TextPositionRange to examine.

Return Value

Type: TextPositionRange
The normalized union of two TextPositionRange objects.
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange Operators

The TextPositionRange type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.Equality Operator

TextPositionRangeEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Equality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextPositionRange left,
    TextPositionRange right
)
Public Shared Operator = (
    left As TextPositionRange,
    right As TextPositionRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPositionRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Equality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

right
Type: ActiproSoftware.TextTextPositionRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Equality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Equality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextPositionRange.Inequality Operator

TextPositionRangeInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Inequality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextPositionRange left,
    TextPositionRange right
)
Public Shared Operator <> (
    left As TextPositionRange,
    right As TextPositionRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPositionRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Inequality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

right
Type: ActiproSoftware.TextTextPositionRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Inequality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Inequality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

See Also

Reference

TextPositionRange Structure
ActiproSoftware.Text Namespace


TextRange Structure

Represents a zero-based range of two offset values within a text document.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct TextRange : ITextRangeProvider
<SerializableAttribute>
Public Structure TextRange
    Implements ITextRangeProvider

The TextRange type exposes the following members.

Constructors
 | Name | Description
Public method | TextRange(Int32) | Initializes a new instance of the TextRange class using the specified offset for both the start and end values.
Public method | TextRange(Int32, Int32) | Initializes a new instance of the TextRange class with the specified offset values.
Top
Properties
 | Name | Description
Public property | AbsoluteLength | Gets the absolute number of characters encompassed by the TextRange.
 | Deleted | Gets a TextRange that is flagged as deleted.
Public property | EndOffset | Gets the end offset in the range.
Public property | FirstOffset | Gets the first offset in the range.
Public property | IsDeleted | Gets whether the range has been flagged as deleted.
Public property | IsNormalized | Gets whether the range is normalized (StartOffset occurs at or before the EndOffset).
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | LastOffset | Gets the last offset in the range.
Public property | Length | Gets the number of characters encompassed by the TextRange.
Public property | NormalizedTextRange | Gets a normalized version of this TextRange without actually modifying this instance.
Public property | StartOffset | Gets the start offset in the range.
Top
Methods
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextRange borders on, but does not overlap the specified TextRange.
Public method | Clone | Creates a copy of this TextRange object.
Public method | CompareTo | Compares the current instance with another object of the same type.
Public method | Contains(Int32) | Returns whether the TextRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextRange contains the specified TextRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
 | FromSpan | Returns a TextRange that covers the specified offset and length.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
 | Intersect | Returns the intersection of two TextRange objects.
Public method | IntersectsWith(Int32) | Returns whether the TextRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextRange intersects with the specified TextRange.
Public method | IntersectsWith(TextRange, Boolean, Boolean) | Returns whether the TextRange intersects with the specified TextRange.
Public method | Normalize | Normalizes the range and ensures that the StartOffset occurs at or before the EndOffset offset.
Public method | OverlapsWith | Returns whether the TextRange overlaps with, or crosses, the specified TextRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | Translate(ITextSnapshot, ITextSnapshot, TextRangeTrackingModes) | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Public method | Translate(ITextVersion, ITextVersion, TextRangeTrackingModes) | Translates this text range from one ITextVersion to another in the same ITextDocument.
 | Union | Returns the normalized union of two TextRange objects.
Top
Operators
Name | Description
Equality |
GreaterThan |
Inequality |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextRange Constructor

Overload List
 | Name | Description
Public method | TextRange(Int32) | Initializes a new instance of the TextRange class using the specified offset for both the start and end values.
Public method | TextRange(Int32, Int32) | Initializes a new instance of the TextRange class with the specified offset values.
Top
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange Constructor (Int32)

Initializes a new instance of the TextRange class using the specified offset for both the start and end values.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextRange(
    int offset
)
Public Sub New (
    offset As Integer
)

Parameters

offset
Type: SystemInt32
The start and end offset in the range.
See Also

Reference

TextRange Structure
TextRange Overload
ActiproSoftware.Text Namespace


TextRange Constructor (Int32, Int32)

Initializes a new instance of the TextRange class with the specified offset values.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextRange(
    int startOffset,
    int endOffset
)
Public Sub New (
    startOffset As Integer,
    endOffset As Integer
)

Parameters

startOffset
Type: SystemInt32
The start offset in the range.
endOffset
Type: SystemInt32
The end offset in the range.
See Also

Reference

TextRange Structure
TextRange Overload
ActiproSoftware.Text Namespace


TextRange Properties

The TextRange type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteLength | Gets the absolute number of characters encompassed by the TextRange.
 | Deleted | Gets a TextRange that is flagged as deleted.
Public property | EndOffset | Gets the end offset in the range.
Public property | FirstOffset | Gets the first offset in the range.
Public property | IsDeleted | Gets whether the range has been flagged as deleted.
Public property | IsNormalized | Gets whether the range is normalized (StartOffset occurs at or before the EndOffset).
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | LastOffset | Gets the last offset in the range.
Public property | Length | Gets the number of characters encompassed by the TextRange.
Public property | NormalizedTextRange | Gets a normalized version of this TextRange without actually modifying this instance.
Public property | StartOffset | Gets the start offset in the range.
Top
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.AbsoluteLength Property

TextRangeAbsoluteLength Property

Gets the absolute number of characters encompassed by the TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int AbsoluteLength { get; }
Public ReadOnly Property AbsoluteLength As Integer
    Get

Property Value

Type: Int32
The absolute number of characters encompassed by the TextRange.
Remarks
This value will always return a positive length, even if the range is not normalized.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.Deleted Property

TextRangeDeleted Property

Gets a TextRange that is flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextRange Deleted { get; }
Public Shared ReadOnly Property Deleted As TextRange
    Get

Property Value

Type: TextRange
A TextRange that is flagged as deleted.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.EndOffset Property

TextRangeEndOffset Property

Gets the end offset in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int EndOffset { get; }
Public ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The end offset in the range.
Remarks
The end offset may occur before the start offset if the range is not normalized. The IsNormalized property indicates if the range is normalized. To get the normalized first offset in the range, use the FirstOffset property. To get the normalized last offset in the range, use the LastOffset property.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.FirstOffset Property

TextRangeFirstOffset Property

Gets the first offset in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int FirstOffset { get; }
Public ReadOnly Property FirstOffset As Integer
    Get

Property Value

Type: Int32
The first offset in the range.
Remarks
This property returns either the StartOffset or EndOffset property, whichever comes first.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.IsDeleted Property

TextRangeIsDeleted Property

Gets whether the range has been flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDeleted { get; }
Public ReadOnly Property IsDeleted As Boolean
    Get

Property Value

Type: Boolean
true if the range has been flagged as deleted; otherwise, false.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.IsNormalized Property

TextRangeIsNormalized Property

Gets whether the range is normalized (StartOffset occurs at or before the EndOffset).

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNormalized { get; }
Public ReadOnly Property IsNormalized As Boolean
    Get

Property Value

Type: Boolean
true if the range is normalized; otherwise, false.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.IsZeroLength Property

TextRangeIsZeroLength Property

Gets whether the range has a zero length.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsZeroLength { get; }
Public ReadOnly Property IsZeroLength As Boolean
    Get

Property Value

Type: Boolean
true if the range has a zero length; otherwise, false.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.LastOffset Property

TextRangeLastOffset Property

Gets the last offset in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int LastOffset { get; }
Public ReadOnly Property LastOffset As Integer
    Get

Property Value

Type: Int32
The last offset in the range.
Remarks
This property returns either the StartOffset or EndOffset property, whichever comes last.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.Length Property

TextRangeLength Property

Gets the number of characters encompassed by the TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters encompassed by the TextRange.
Remarks
This value will return a negative length if the range is not normalized.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.NormalizedTextRange Property

TextRangeNormalizedTextRange Property

Gets a normalized version of this TextRange without actually modifying this instance.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextRange NormalizedTextRange { get; }
Public ReadOnly Property NormalizedTextRange As TextRange
    Get

Property Value

Type: TextRange
A normalized version of this TextRange without actually modifying this instance.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.StartOffset Property

TextRangeStartOffset Property

Gets the start offset in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int StartOffset { get; }
Public ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The start offset in the range.
Remarks
The start offset may occur after the end offset if the range is not normalized. The IsNormalized property indicates if the range is normalized. To get the normalized first offset in the range, use the FirstOffset property. To get the normalized last offset in the range, use the LastOffset property.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange Methods

The TextRange type exposes the following members.

Methods
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextRange borders on, but does not overlap the specified TextRange.
Public method | Clone | Creates a copy of this TextRange object.
Public method | CompareTo | Compares the current instance with another object of the same type.
Public method | Contains(Int32) | Returns whether the TextRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextRange contains the specified TextRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
 | FromSpan | Returns a TextRange that covers the specified offset and length.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
 | Intersect | Returns the intersection of two TextRange objects.
Public method | IntersectsWith(Int32) | Returns whether the TextRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextRange intersects with the specified TextRange.
Public method | IntersectsWith(TextRange, Boolean, Boolean) | Returns whether the TextRange intersects with the specified TextRange.
Public method | Normalize | Normalizes the range and ensures that the StartOffset occurs at or before the EndOffset offset.
Public method | OverlapsWith | Returns whether the TextRange overlaps with, or crosses, the specified TextRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | Translate(ITextSnapshot, ITextSnapshot, TextRangeTrackingModes) | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Public method | Translate(ITextVersion, ITextVersion, TextRangeTrackingModes) | Translates this text range from one ITextVersion to another in the same ITextDocument.
 | Union | Returns the normalized union of two TextRange objects.
Top
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.BordersOn Method

TextRangeBordersOn Method

Overload List
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextRange borders on, but does not overlap the specified TextRange.
Top
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.BordersOn Method (Int32)

TextRangeBordersOn Method (Int32)

Returns whether the TextRange borders on the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool BordersOn(
    int offset
)
Public Function BordersOn (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextRange borders on the specified offset; otherwise, false.
Remarks
This method checks to see if the specified offset is either the StartOffset or EndOffset.
See Also

Reference

TextRange Structure
BordersOn Overload
ActiproSoftware.Text Namespace


TextRange.BordersOn Method (TextRange)

TextRangeBordersOn Method (TextRange)

Returns whether the TextRange borders on, but does not overlap the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextRange range
)
Public Function BordersOn (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextRange borders on, but does not overlap the specified TextRange; otherwise, false.
See Also

Reference

TextRange Structure
BordersOn Overload
ActiproSoftware.Text Namespace


TextRange.Clone Method

TextRangeClone Method

Creates a copy of this TextRange object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
The TextRange object that this method creates.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.CompareTo Method

TextRangeCompareTo Method

Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextRange textRange
)
Public Function CompareTo (
    textRange As TextRange
) As Integer

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.Contains Method

TextRangeContains Method

Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the TextRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextRange contains the specified TextRange.
Top
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.Contains Method (Int32)

TextRangeContains Method (Int32)

Returns whether the TextRange contains the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextRange contains the specified offset; otherwise, false.
Remarks
This method returns false if the offset falls on the LastOffset offset since this method indicates if the offset is encompassed by the TextRange.
See Also

Reference

TextRange Structure
Contains Overload
ActiproSoftware.Text Namespace


TextRange.Contains Method (TextRange)

TextRangeContains Method (TextRange)

Returns whether the TextRange contains the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    TextRange range
)
Public Function Contains (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextRange contains the specified TextRange; otherwise, false.
See Also

Reference

TextRange Structure
Contains Overload
ActiproSoftware.Text Namespace


TextRange.Equals Method

TextRangeEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.FromSpan Method

TextRangeFromSpan Method

Returns a TextRange that covers the specified offset and length.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextRange FromSpan(
    int offset,
    int length
)
Public Shared Function FromSpan (
    offset As Integer,
    length As Integer
) As TextRange

Parameters

offset
Type: SystemInt32
The start offset.
length
Type: SystemInt32
The length of the range.

Return Value

Type: TextRange
The TextRange that was created.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.GetHashCode Method

TextRangeGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.Intersect Method

TextRangeIntersect Method

Returns the intersection of two TextRange objects.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextRange Intersect(
    TextRange range1,
    TextRange range2
)
Public Shared Function Intersect (
    range1 As TextRange,
    range2 As TextRange
) As TextRange

Parameters

range1
Type: ActiproSoftware.TextTextRange
The first TextRange to examine.
range2
Type: ActiproSoftware.TextTextRange
The second TextRange to examine.

Return Value

Type: TextRange
The intersection of two TextRange objects.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.IntersectsWith Method

TextRangeIntersectsWith Method

Overload List
 | Name | Description
Public method | IntersectsWith(Int32) | Returns whether the TextRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextRange intersects with the specified TextRange.
Public method | IntersectsWith(TextRange, Boolean, Boolean) | Returns whether the TextRange intersects with the specified TextRange.
Top
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.IntersectsWith Method (Int32)

TextRangeIntersectsWith Method (Int32)

Returns whether the TextRange intersects with the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    int offset
)
Public Function IntersectsWith (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextRange intersects with the specified offset; otherwise, false.
Remarks
This method returns whether the specified offset borders on or lies within the TextRange.
See Also

Reference

TextRange Structure
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextRange.IntersectsWith Method (TextRange)

TextRangeIntersectsWith Method (TextRange)

Returns whether the TextRange intersects with the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextRange range
)
Public Function IntersectsWith (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextRange intersects with the specified TextRange; otherwise, false.
Remarks
This method returns whether the specified TextRange borders on or overlaps the TextRange.
See Also

Reference

TextRange Structure
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextRange.IntersectsWith Method (TextRange, Boolean, Boolean)

TextRangeIntersectsWith Method (TextRange, Boolean, Boolean)

Returns whether the TextRange intersects with the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextRange range,
    bool includeFirstEdge,
    bool includeLastEdge
)
Public Function IntersectsWith (
    range As TextRange,
    includeFirstEdge As Boolean,
    includeLastEdge As Boolean
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.
includeFirstEdge
Type: SystemBoolean
Whether to return true if the specified TextSnapshotRange borders on the leading (first) edge of this TextSnapshotRange.
includeLastEdge
Type: SystemBoolean
Whether to return true if the specified TextSnapshotRange borders on the trailing (last) edge of this TextSnapshotRange.

Return Value

Type: Boolean
true if the TextRange intersects with the specified TextRange; otherwise, false.
Remarks
This method returns whether the specified TextRange borders on or overlaps the TextRange.
See Also

Reference

TextRange Structure
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextRange.Normalize Method

TextRangeNormalize Method

Normalizes the range and ensures that the StartOffset occurs at or before the EndOffset offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Normalize()
Public Sub Normalize
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.OverlapsWith Method

TextRangeOverlapsWith Method

Returns whether the TextRange overlaps with, or crosses, the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    TextRange range
)
Public Function OverlapsWith (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextRange overlaps with, or crosses, the specified TextRange; otherwise, false.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.ToString Method

TextRangeToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.Translate Method

TextRangeTranslate Method

Overload List
 | Name | Description
Public method | Translate(ITextSnapshot, ITextSnapshot, TextRangeTrackingModes) | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Public method | Translate(ITextVersion, ITextVersion, TextRangeTrackingModes) | Translates this text range from one ITextVersion to another in the same ITextDocument.
Top
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.Translate Method (ITextSnapshot, ITextSnapshot, TextRangeTrackingModes)

TextRangeTranslate Method (ITextSnapshot, ITextSnapshot, TextRangeTrackingModes)

Translates this text range from one ITextSnapshot to another in the same ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextRange Translate(
    ITextSnapshot fromSnapshot,
    ITextSnapshot toSnapshot,
    TextRangeTrackingModes trackingModes
)
Public Function Translate (
    fromSnapshot As ITextSnapshot,
    toSnapshot As ITextSnapshot,
    trackingModes As TextRangeTrackingModes
) As TextRange

Parameters

fromSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to which to text range belongs.
toSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is the target of the translation.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: TextRange
The translated TextRange.
See Also

Reference

TextRange Structure
Translate Overload
ActiproSoftware.Text Namespace


TextRange.Translate Method (ITextVersion, ITextVersion, TextRangeTrackingModes)

TextRangeTranslate Method (ITextVersion, ITextVersion, TextRangeTrackingModes)

Translates this text range from one ITextVersion to another in the same ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextRange Translate(
    ITextVersion fromVersion,
    ITextVersion toVersion,
    TextRangeTrackingModes trackingModes
)
Public Function Translate (
    fromVersion As ITextVersion,
    toVersion As ITextVersion,
    trackingModes As TextRangeTrackingModes
) As TextRange

Parameters

fromVersion
Type: ActiproSoftware.TextITextVersion
The ITextVersion to which to text range belongs.
toVersion
Type: ActiproSoftware.TextITextVersion
The ITextVersion that is the target of the translation.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: TextRange
The translated TextRange.
See Also

Reference

TextRange Structure
Translate Overload
ActiproSoftware.Text Namespace


TextRange.Union Method

TextRangeUnion Method

Returns the normalized union of two TextRange objects.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextRange Union(
    TextRange range1,
    TextRange range2
)
Public Shared Function Union (
    range1 As TextRange,
    range2 As TextRange
) As TextRange

Parameters

range1
Type: ActiproSoftware.TextTextRange
The first TextRange to examine.
range2
Type: ActiproSoftware.TextTextRange
The second TextRange to examine.

Return Value

Type: TextRange
The normalized union of two TextRange objects.
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange Operators

The TextRange type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
Inequality |
LessThan |
Top
See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.Equality Operator

TextRangeEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextRange.op_Equality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextRange left,
    TextRange right
)
Public Shared Operator = (
    left As TextRange,
    right As TextRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextRange.op_Equality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

right
Type: ActiproSoftware.TextTextRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextRange.op_Equality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextRange.op_Equality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.GreaterThan Operator

TextRangeGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextRange.op_GreaterThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator >(
    TextRange left,
    TextRange right
)
Public Shared Operator > (
    left As TextRange,
    right As TextRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextRange.op_GreaterThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

right
Type: ActiproSoftware.TextTextRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextRange.op_GreaterThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextRange.op_GreaterThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.Inequality Operator

TextRangeInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextRange.op_Inequality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextRange left,
    TextRange right
)
Public Shared Operator <> (
    left As TextRange,
    right As TextRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextRange.op_Inequality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

right
Type: ActiproSoftware.TextTextRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextRange.op_Inequality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextRange.op_Inequality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRange.LessThan Operator

TextRangeLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextRange.op_LessThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator <(
    TextRange left,
    TextRange right
)
Public Shared Operator < (
    left As TextRange,
    right As TextRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextRange.op_LessThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

right
Type: ActiproSoftware.TextTextRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextRange.op_LessThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextRange.op_LessThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

See Also

Reference

TextRange Structure
ActiproSoftware.Text Namespace


TextRangeTrackingModes Enumeration

Specifies how a text range is updated by text change operations that occur at its edges.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TextRangeTrackingModes
Public Enumeration TextRangeTrackingModes
Members
Member name | Value | Description
Default 0 The text range doesn't get deleted by deletion operations that cross it, instead is slides to the deletion start. The text range doesn't expand when insertion operations occur at its edges.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range slides forward a character and becomes {3,5}.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range remains {2,4}.

ExpandFirstEdge 1 Alters expansion behavior such that the text range expands when insertion operations occur at its leading (first) edge.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range expands to become {2,5}.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range remains {2,4}.

ExpandLastEdge 2 Alters expansion behavior such that the text range expands when insertion operations occur at its trailing (last) edge.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range slides forward a character and becomes {3,5}.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range expands to become {2,5}.

ExpandBothEdges 3 Alters expansion behavior such that the text range expands when insertion operations occur at either of its edges.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range expands to become {2,5}.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range expands to become {2,5}.

This value is the combination of the ExpandFirstEdge and ExpandLastEdge values.

ExpandMask | 3 | The mask value for all expansion-related values.
DeleteWhenSurrounded | 4 | Alters deletion behavior such that the text range is deleted if a deletion operation occurs that completely surrounds it. A deletion operation that collapses the text range to zero-length will not delete it.
DeleteWhenZeroLength 12 Alters deletion behavior such that the text range is deleted if a deletion operation occurs that surrounds it or collapses it to zero-length.

This value includes the DeleteWhenSurrounded value.

DeleteMask | 12 | The mask value for all delete-related values.
LineBased 16 The text range follows the text on the line to which it is attached. This option is useful for line-based tracking, such as for bookmarks.

Inserting a line terminator in the line will move the text range to the next line, unless the line terminator is inserted at the very end of the line.

Remarks
Combine various flags to achieve different tracking behavior.
See Also

Reference

ActiproSoftware.Text Namespace


TextScanDirection Enumeration

Specifies a direction in which text will be scanned.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TextScanDirection
Public Enumeration TextScanDirection
Members
Member name | Value | Description
Forward | 0 | Forward-oriented text scanning.
Backward | 1 | Backward-oriented text scanning.
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs Class

Event arguments for the ITextDocument.TextChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.TextTextSnapshotChangedEventArgs

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TextSnapshotChangedEventArgs : EventArgs
Public Class TextSnapshotChangedEventArgs
    Inherits EventArgs

The TextSnapshotChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotChangedEventArgs | Initializes a new instance of the TextSnapshotChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | ChangedSnapshotRange | Gets a TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs Constructor

Initializes a new instance of the TextSnapshotChangedEventArgs class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotChangedEventArgs(
    ITextSnapshot oldSnapshot,
    ITextSnapshot newSnapshot,
    ITextChange textChange
)
Public Sub New (
    oldSnapshot As ITextSnapshot,
    newSnapshot As ITextSnapshot,
    textChange As ITextChange
)

Parameters

oldSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
newSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
textChange
Type: ActiproSoftware.TextITextChange
The ITextChange that is made.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs Properties

The TextSnapshotChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChangedSnapshotRange | Gets a TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Top
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs.ChangedSnapshotRange Property

TextSnapshotChangedEventArgsChangedSnapshotRange Property

Gets a TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange ChangedSnapshotRange { get; }
Public ReadOnly Property ChangedSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs.NewSnapshot Property

TextSnapshotChangedEventArgsNewSnapshot Property

Gets the ITextSnapshot that is in effect after the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot NewSnapshot { get; }
Public ReadOnly Property NewSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
Remarks
This property value may be before the text change actually occurs.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs.OldSnapshot Property

TextSnapshotChangedEventArgsOldSnapshot Property

Gets the ITextSnapshot that is in effect before the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot OldSnapshot { get; }
Public ReadOnly Property OldSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs.TextChange Property

TextSnapshotChangedEventArgsTextChange Property

Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextChange TextChange { get; }
Public ReadOnly Property TextChange As ITextChange
    Get

Property Value

Type: ITextChange
The ITextChange that is made to the document.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs Class

Event arguments for the ITextDocument.TextChanging event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
ActiproSoftware.TextTextSnapshotChangingEventArgs

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TextSnapshotChangingEventArgs : CancelEventArgs
Public Class TextSnapshotChangingEventArgs
    Inherits CancelEventArgs

The TextSnapshotChangingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotChangingEventArgs | Initializes a new instance of the TextSnapshotChangingEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs Constructor

Initializes a new instance of the TextSnapshotChangingEventArgs class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotChangingEventArgs(
    ITextSnapshot oldSnapshot,
    ITextSnapshot newSnapshot,
    ITextChange textChange
)
Public Sub New (
    oldSnapshot As ITextSnapshot,
    newSnapshot As ITextSnapshot,
    textChange As ITextChange
)

Parameters

oldSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
newSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
textChange
Type: ActiproSoftware.TextITextChange
The ITextChange that is made.
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs Properties

The TextSnapshotChangingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Top
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs.NewSnapshot Property

TextSnapshotChangingEventArgsNewSnapshot Property

Gets the ITextSnapshot that is in effect after the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot NewSnapshot { get; }
Public ReadOnly Property NewSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
Remarks
This property value may be before the text change actually occurs.
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs.OldSnapshot Property

TextSnapshotChangingEventArgsOldSnapshot Property

Gets the ITextSnapshot that is in effect before the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot OldSnapshot { get; }
Public ReadOnly Property OldSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs.TextChange Property

TextSnapshotChangingEventArgsTextChange Property

Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextChange TextChange { get; }
Public ReadOnly Property TextChange As ITextChange
    Get

Property Value

Type: ITextChange
The ITextChange that is made to the document.
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotOffset Structure

Represents a zero-based offset value within a certain ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public struct TextSnapshotOffset : ITextRangeProvider
Public Structure TextSnapshotOffset
    Implements ITextRangeProvider

The TextSnapshotOffset type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotOffset | Initializes a new instance of the TextSnapshotOffset class with the specified offset.
Top
Properties
 | Name | Description
Public property | Column | Gets the zero-based column value, which accounts for the document's tab size.
 | Deleted | Gets a TextSnapshotOffset that has no Snapshot and is flagged as deleted.
Public property | IsDeleted | Gets whether the offset has been flagged as deleted.
Public property | Line | Gets the ITextSnapshotLine that contains the offset.
Public property | Offset | Gets the zero-based offset value.
Public property | Position | Gets the TextPosition for the offset.
Public property | Snapshot | Gets the ITextSnapshot that contains the offset.
Top
Methods
 | Name | Description
Public method | CompareTo(Int32) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotOffset) | Compares the current instance with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | TranslateTo | Translates this offset from one ITextSnapshot to another in the same ITextDocument.
Top
Operators
Name | Description
Equality |
GreaterThan |
(TextSnapshotOffset to Int32) |
Inequality |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotOffset Constructor

Initializes a new instance of the TextSnapshotOffset class with the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotOffset(
    ITextSnapshot snapshot,
    int offset
)
Public Sub New (
    snapshot As ITextSnapshot,
    offset As Integer
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the offset.
offset
Type: SystemInt32
The zero-based offset.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset Properties

The TextSnapshotOffset type exposes the following members.

Properties
 | Name | Description
Public property | Column | Gets the zero-based column value, which accounts for the document's tab size.
 | Deleted | Gets a TextSnapshotOffset that has no Snapshot and is flagged as deleted.
Public property | IsDeleted | Gets whether the offset has been flagged as deleted.
Public property | Line | Gets the ITextSnapshotLine that contains the offset.
Public property | Offset | Gets the zero-based offset value.
Public property | Position | Gets the TextPosition for the offset.
Public property | Snapshot | Gets the ITextSnapshot that contains the offset.
Top
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.Column Property

TextSnapshotOffsetColumn Property

Gets the zero-based column value, which accounts for the document's tab size.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Column { get; }
Public ReadOnly Property Column As Integer
    Get

Property Value

Type: Int32
The zero-based column value, which accounts for the document's tab size.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.Deleted Property

TextSnapshotOffsetDeleted Property

Gets a TextSnapshotOffset that has no Snapshot and is flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextSnapshotOffset Deleted { get; }
Public Shared ReadOnly Property Deleted As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
A TextSnapshotOffset that has no Snapshot and is flagged as deleted.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.IsDeleted Property

TextSnapshotOffsetIsDeleted Property

Gets whether the offset has been flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDeleted { get; }
Public ReadOnly Property IsDeleted As Boolean
    Get

Property Value

Type: Boolean
true if the offset has been flagged as deleted; otherwise, false.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.Line Property

TextSnapshotOffsetLine Property

Gets the ITextSnapshotLine that contains the offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshotLine Line { get; }
Public ReadOnly Property Line As ITextSnapshotLine
    Get

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine that contains the offset.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.Offset Property

TextSnapshotOffsetOffset Property

Gets the zero-based offset value.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Offset { get; }
Public ReadOnly Property Offset As Integer
    Get

Property Value

Type: Int32
The zero-based offset value.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.Position Property

TextSnapshotOffsetPosition Property

Gets the TextPosition for the offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition Position { get; }
Public ReadOnly Property Position As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition for the offset.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.Snapshot Property

TextSnapshotOffsetSnapshot Property

Gets the ITextSnapshot that contains the offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; }
Public ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the offset.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset Methods

The TextSnapshotOffset type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Int32) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotOffset) | Compares the current instance with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | TranslateTo | Translates this offset from one ITextSnapshot to another in the same ITextDocument.
Top
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.CompareTo Method

TextSnapshotOffsetCompareTo Method

Overload List
 | Name | Description
Public method | CompareTo(Int32) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotOffset) | Compares the current instance with another object of the same type.
Top
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.CompareTo Method (Int32)

TextSnapshotOffsetCompareTo Method (Int32)

Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CompareTo(
    int value
)
Public Function CompareTo (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
An offset to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextSnapshotOffset Structure
CompareTo Overload
ActiproSoftware.Text Namespace


TextSnapshotOffset.CompareTo Method (TextSnapshotOffset)

TextSnapshotOffsetCompareTo Method (TextSnapshotOffset)

Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextSnapshotOffset snapshotOffset
)
Public Function CompareTo (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
A TextSnapshotOffset to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextSnapshotOffset Structure
CompareTo Overload
ActiproSoftware.Text Namespace


TextSnapshotOffset.Equals Method

TextSnapshotOffsetEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.GetHashCode Method

TextSnapshotOffsetGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.ToString Method

TextSnapshotOffsetToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.TranslateTo Method

TextSnapshotOffsetTranslateTo Method

Translates this offset from one ITextSnapshot to another in the same ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotOffset TranslateTo(
    ITextSnapshot toSnapshot,
    TextOffsetTrackingMode trackingMode
)
Public Function TranslateTo (
    toSnapshot As ITextSnapshot,
    trackingMode As TextOffsetTrackingMode
) As TextSnapshotOffset

Parameters

toSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is the target of the translation.
trackingMode
Type: ActiproSoftware.TextTextOffsetTrackingMode
A TextOffsetTrackingMode indicating the tracking mode to use.

Return Value

Type: TextSnapshotOffset
The translated TextSnapshotOffset.
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset Operators and Type Conversions

The TextSnapshotOffset type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
(TextSnapshotOffset to Int32) |
Inequality |
LessThan |
Top
See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.Equality Operator

TextSnapshotOffsetEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Equality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextSnapshotOffset left,
    TextSnapshotOffset right
)
Public Shared Operator = (
    left As TextSnapshotOffset,
    right As TextSnapshotOffset
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Equality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

right
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Equality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Equality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.GreaterThan Operator

TextSnapshotOffsetGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_GreaterThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator >(
    TextSnapshotOffset left,
    TextSnapshotOffset right
)
Public Shared Operator > (
    left As TextSnapshotOffset,
    right As TextSnapshotOffset
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_GreaterThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

right
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_GreaterThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_GreaterThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset Implicit Conversion (TextSnapshotOffset to Int32)

TextSnapshotOffset Conversion (TextSnapshotOffset to Int32)

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Implicit(ActiproSoftware.Text.TextSnapshotOffset)~System.Int32"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static implicit operator int (
    TextSnapshotOffset snapshotOffset
)
Public Shared Widening Operator CType (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="snapshotOffset"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Implicit(ActiproSoftware.Text.TextSnapshotOffset)~System.Int32"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Implicit(ActiproSoftware.Text.TextSnapshotOffset)~System.Int32"]

See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.Inequality Operator

TextSnapshotOffsetInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Inequality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextSnapshotOffset left,
    TextSnapshotOffset right
)
Public Shared Operator <> (
    left As TextSnapshotOffset,
    right As TextSnapshotOffset
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Inequality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

right
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Inequality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Inequality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotOffset.LessThan Operator

TextSnapshotOffsetLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_LessThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator <(
    TextSnapshotOffset left,
    TextSnapshotOffset right
)
Public Shared Operator < (
    left As TextSnapshotOffset,
    right As TextSnapshotOffset
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_LessThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

right
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_LessThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_LessThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

See Also

Reference

TextSnapshotOffset Structure
ActiproSoftware.Text Namespace


TextSnapshotRange Structure

Represents a zero-based range of two normalized offset values within a certain ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public struct TextSnapshotRange : ITextPositionRangeProvider,
    ITextRangeProvider
Public Structure TextSnapshotRange
    Implements ITextPositionRangeProvider, ITextRangeProvider

The TextSnapshotRange type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotRange(TextSnapshotOffset) | Initializes a new instance of the TextSnapshotRange class using the specified TextSnapshotOffset for both the start and end values.
Public method | TextSnapshotRange(ITextSnapshot, TextRange) | Initializes a new instance of the TextSnapshotRange class with the specified TextRange.
Public method | TextSnapshotRange(ITextSnapshot, Int32) | Initializes a new instance of the TextSnapshotRange class using the specified offset for both the start and end values.
Public method | TextSnapshotRange(ITextSnapshot, Int32, Int32) | Initializes a new instance of the TextSnapshotRange class with the specified offset values.
Top
Properties
 | Name | Description
Public property | AbsoluteLength | Gets the absolute number of characters encompassed by the TextSnapshotRange.
 | Deleted | Gets a TextSnapshotRange that has no Snapshot and is flagged as deleted.
Public property | EndLine | Gets the ITextSnapshotLine that contains the end offset in the text range.
Public property | EndOffset | Gets the end offset in the range.
Public property | EndPosition | Gets the end TextPosition in the range.
Public property | IsDeleted | Gets whether the range has been flagged as deleted.
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | Length | Gets the number of characters encompassed by the TextSnapshotRange.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the object.
Public property | Snapshot | Gets the ITextSnapshot that contains the text range.
Public property | StartLine | Gets the ITextSnapshotLine that contains the start offset in the text range.
Public property | StartOffset | Gets the start offset in the range.
Public property | StartPosition | Gets the start TextPosition in the range.
Public property | Text | Gets the snapshot text substring encompassed by this range, using CarriageReturnNewline for line ends.
Public property | TextRange | Gets a TextRange that specifies the text range of the object.
Top
Methods
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextSnapshotRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextRange.
Public method | BordersOn(TextSnapshotRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange.
Public method | CompareTo(TextRange) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotRange) | Compares the current instance with another object of the same type.
Public method | Contains(Int32) | Returns whether the TextSnapshotRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextSnapshotRange contains the specified TextRange.
Public method | Contains(TextSnapshotRange) | Returns whether the TextSnapshotRange contains the specified TextSnapshotRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
 | FromSpan | Returns a TextSnapshotRange that covers the specified offset and length.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetText | Returns the snapshot text substring encompassed by this range, using the specified LineTerminator for line ends.
Public method | IntersectsWith(Int32) | Returns whether the TextSnapshotRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextSnapshotRange intersects with the specified TextRange.
Public method | IntersectsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.
Public method | IntersectsWith(TextSnapshotRange, Boolean, Boolean) | Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.
Public method | OverlapsWith(TextRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextRange.
Public method | OverlapsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | ToVersionRange(TextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | ToVersionRange(FuncTextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | TranslateTo | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Top
Operators
Name | Description
Equality |
GreaterThan |
(TextSnapshotRange to TextRange) |
Inequality |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotRange Constructor

Overload List
 | Name | Description
Public method | TextSnapshotRange(TextSnapshotOffset) | Initializes a new instance of the TextSnapshotRange class using the specified TextSnapshotOffset for both the start and end values.
Public method | TextSnapshotRange(ITextSnapshot, TextRange) | Initializes a new instance of the TextSnapshotRange class with the specified TextRange.
Public method | TextSnapshotRange(ITextSnapshot, Int32) | Initializes a new instance of the TextSnapshotRange class using the specified offset for both the start and end values.
Public method | TextSnapshotRange(ITextSnapshot, Int32, Int32) | Initializes a new instance of the TextSnapshotRange class with the specified offset values.
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange Constructor (TextSnapshotOffset)

Initializes a new instance of the TextSnapshotRange class using the specified TextSnapshotOffset for both the start and end values.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange(
    TextSnapshotOffset snapshotOffset
)
Public Sub New (
    snapshotOffset As TextSnapshotOffset
)

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The start and end offset in the range.
See Also

Reference

TextSnapshotRange Structure
TextSnapshotRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange Constructor (ITextSnapshot, TextRange)

Initializes a new instance of the TextSnapshotRange class with the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange(
    ITextSnapshot snapshot,
    TextRange textRange
)
Public Sub New (
    snapshot As ITextSnapshot,
    textRange As TextRange
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the text range.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of the range.
See Also

Reference

TextSnapshotRange Structure
TextSnapshotRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange Constructor (ITextSnapshot, Int32)

Initializes a new instance of the TextSnapshotRange class using the specified offset for both the start and end values.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange(
    ITextSnapshot snapshot,
    int offset
)
Public Sub New (
    snapshot As ITextSnapshot,
    offset As Integer
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the text range.
offset
Type: SystemInt32
The start and end offset in the range.
See Also

Reference

TextSnapshotRange Structure
TextSnapshotRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange Constructor (ITextSnapshot, Int32, Int32)

Initializes a new instance of the TextSnapshotRange class with the specified offset values.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange(
    ITextSnapshot snapshot,
    int startOffset,
    int endOffset
)
Public Sub New (
    snapshot As ITextSnapshot,
    startOffset As Integer,
    endOffset As Integer
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the text range.
startOffset
Type: SystemInt32
The start offset in the range.
endOffset
Type: SystemInt32
The end offset in the range.
See Also

Reference

TextSnapshotRange Structure
TextSnapshotRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange Properties

The TextSnapshotRange type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteLength | Gets the absolute number of characters encompassed by the TextSnapshotRange.
 | Deleted | Gets a TextSnapshotRange that has no Snapshot and is flagged as deleted.
Public property | EndLine | Gets the ITextSnapshotLine that contains the end offset in the text range.
Public property | EndOffset | Gets the end offset in the range.
Public property | EndPosition | Gets the end TextPosition in the range.
Public property | IsDeleted | Gets whether the range has been flagged as deleted.
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | Length | Gets the number of characters encompassed by the TextSnapshotRange.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the object.
Public property | Snapshot | Gets the ITextSnapshot that contains the text range.
Public property | StartLine | Gets the ITextSnapshotLine that contains the start offset in the text range.
Public property | StartOffset | Gets the start offset in the range.
Public property | StartPosition | Gets the start TextPosition in the range.
Public property | Text | Gets the snapshot text substring encompassed by this range, using CarriageReturnNewline for line ends.
Public property | TextRange | Gets a TextRange that specifies the text range of the object.
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.AbsoluteLength Property

TextSnapshotRangeAbsoluteLength Property

Gets the absolute number of characters encompassed by the TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int AbsoluteLength { get; }
Public ReadOnly Property AbsoluteLength As Integer
    Get

Property Value

Type: Int32
The absolute number of characters encompassed by the TextSnapshotRange.
Remarks
This value will always return a positive length, even if the range is not normalized.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.Deleted Property

TextSnapshotRangeDeleted Property

Gets a TextSnapshotRange that has no Snapshot and is flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextSnapshotRange Deleted { get; }
Public Shared ReadOnly Property Deleted As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that has no Snapshot and is flagged as deleted.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.EndLine Property

TextSnapshotRangeEndLine Property

Gets the ITextSnapshotLine that contains the end offset in the text range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshotLine EndLine { get; }
Public ReadOnly Property EndLine As ITextSnapshotLine
    Get

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine that contains the end offset in the text range.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.EndOffset Property

TextSnapshotRangeEndOffset Property

Gets the end offset in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int EndOffset { get; }
Public ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The end offset in the range.
Remarks
Since snapshot ranges are normalized, this property returns the last offset in the range.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.EndPosition Property

TextSnapshotRangeEndPosition Property

Gets the end TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition EndPosition { get; }
Public ReadOnly Property EndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The end TextPosition in the range.
Remarks
Since snapshot ranges are normalized, this property returns the last TextPosition in the range.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.IsDeleted Property

TextSnapshotRangeIsDeleted Property

Gets whether the range has been flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDeleted { get; }
Public ReadOnly Property IsDeleted As Boolean
    Get

Property Value

Type: Boolean
true if the range has been flagged as deleted; otherwise, false.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.IsZeroLength Property

TextSnapshotRangeIsZeroLength Property

Gets whether the range has a zero length.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsZeroLength { get; }
Public ReadOnly Property IsZeroLength As Boolean
    Get

Property Value

Type: Boolean
true if the range has a zero length; otherwise, false.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.Length Property

TextSnapshotRangeLength Property

Gets the number of characters encompassed by the TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters encompassed by the TextSnapshotRange.
Remarks
This value will return a negative length if the range is not normalized.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.PositionRange Property

TextSnapshotRangePositionRange Property

Gets a TextPositionRange that specifies the text position range of the object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPositionRange PositionRange { get; }
Public ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A TextPositionRange that specifies the text position range of the object.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.Snapshot Property

TextSnapshotRangeSnapshot Property

Gets the ITextSnapshot that contains the text range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; }
Public ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the text range.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.StartLine Property

TextSnapshotRangeStartLine Property

Gets the ITextSnapshotLine that contains the start offset in the text range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshotLine StartLine { get; }
Public ReadOnly Property StartLine As ITextSnapshotLine
    Get

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine that contains the start offset in the text range.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.StartOffset Property

TextSnapshotRangeStartOffset Property

Gets the start offset in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int StartOffset { get; }
Public ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The start offset in the range.
Remarks
Since snapshot ranges are normalized, this property returns the first offset in the range.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.StartPosition Property

TextSnapshotRangeStartPosition Property

Gets the start TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition StartPosition { get; }
Public ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The start TextPosition in the range.
Remarks
Since snapshot ranges are normalized, this property returns the first TextPosition in the range.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.Text Property

TextSnapshotRangeText Property

Gets the snapshot text substring encompassed by this range, using CarriageReturnNewline for line ends.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The snapshot text substring encompassed by this range, using CarriageReturnNewline for line ends.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.TextRange Property

TextSnapshotRangeTextRange Property

Gets a TextRange that specifies the text range of the object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextRange TextRange { get; }
Public ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
A TextRange that specifies the text range of the object.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange Methods

The TextSnapshotRange type exposes the following members.

Methods
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextSnapshotRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextRange.
Public method | BordersOn(TextSnapshotRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange.
Public method | CompareTo(TextRange) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotRange) | Compares the current instance with another object of the same type.
Public method | Contains(Int32) | Returns whether the TextSnapshotRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextSnapshotRange contains the specified TextRange.
Public method | Contains(TextSnapshotRange) | Returns whether the TextSnapshotRange contains the specified TextSnapshotRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
 | FromSpan | Returns a TextSnapshotRange that covers the specified offset and length.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetText | Returns the snapshot text substring encompassed by this range, using the specified LineTerminator for line ends.
Public method | IntersectsWith(Int32) | Returns whether the TextSnapshotRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextSnapshotRange intersects with the specified TextRange.
Public method | IntersectsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.
Public method | IntersectsWith(TextSnapshotRange, Boolean, Boolean) | Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.
Public method | OverlapsWith(TextRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextRange.
Public method | OverlapsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | ToVersionRange(TextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | ToVersionRange(FuncTextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | TranslateTo | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.BordersOn Method

TextSnapshotRangeBordersOn Method

Overload List
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextSnapshotRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextRange.
Public method | BordersOn(TextSnapshotRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange.
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.BordersOn Method (Int32)

TextSnapshotRangeBordersOn Method (Int32)

Returns whether the TextSnapshotRange borders on the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool BordersOn(
    int offset
)
Public Function BordersOn (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange borders on the specified offset; otherwise, false.
Remarks
This method checks to see if the specified offset is either the StartOffset or EndOffset.
See Also

Reference

TextSnapshotRange Structure
BordersOn Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.BordersOn Method (TextRange)

TextSnapshotRangeBordersOn Method (TextRange)

Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextRange range
)
Public Function BordersOn (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange borders on, but does not overlap the specified TextRange; otherwise, false.
See Also

Reference

TextSnapshotRange Structure
BordersOn Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.BordersOn Method (TextSnapshotRange)

TextSnapshotRangeBordersOn Method (TextSnapshotRange)

Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextSnapshotRange range
)
Public Function BordersOn (
    range As TextSnapshotRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange; otherwise, false.
See Also

Reference

TextSnapshotRange Structure
BordersOn Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.CompareTo Method

TextSnapshotRangeCompareTo Method

Overload List
 | Name | Description
Public method | CompareTo(TextRange) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotRange) | Compares the current instance with another object of the same type.
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.CompareTo Method (TextRange)

TextSnapshotRangeCompareTo Method (TextRange)

Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextRange range
)
Public Function CompareTo (
    range As TextRange
) As Integer

Parameters

range
Type: ActiproSoftware.TextTextRange
A TextRange to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextSnapshotRange Structure
CompareTo Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.CompareTo Method (TextSnapshotRange)

TextSnapshotRangeCompareTo Method (TextSnapshotRange)

Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextSnapshotRange range
)
Public Function CompareTo (
    range As TextSnapshotRange
) As Integer

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextSnapshotRange Structure
CompareTo Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.Contains Method

TextSnapshotRangeContains Method

Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the TextSnapshotRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextSnapshotRange contains the specified TextRange.
Public method | Contains(TextSnapshotRange) | Returns whether the TextSnapshotRange contains the specified TextSnapshotRange.
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.Contains Method (Int32)

TextSnapshotRangeContains Method (Int32)

Returns whether the TextSnapshotRange contains the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange contains the specified offset; otherwise, false.
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the TextSnapshotRange.
See Also

Reference

TextSnapshotRange Structure
Contains Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.Contains Method (TextRange)

TextSnapshotRangeContains Method (TextRange)

Returns whether the TextSnapshotRange contains the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    TextRange range
)
Public Function Contains (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange contains the specified TextRange; otherwise, false.
See Also

Reference

TextSnapshotRange Structure
Contains Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.Contains Method (TextSnapshotRange)

TextSnapshotRangeContains Method (TextSnapshotRange)

Returns whether the TextSnapshotRange contains the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    TextSnapshotRange range
)
Public Function Contains (
    range As TextSnapshotRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange contains the specified TextSnapshotRange; otherwise, false.
See Also

Reference

TextSnapshotRange Structure
Contains Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.Equals Method

TextSnapshotRangeEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.FromSpan Method

TextSnapshotRangeFromSpan Method

Returns a TextSnapshotRange that covers the specified offset and length.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextSnapshotRange FromSpan(
    ITextSnapshot snapshot,
    int offset,
    int length
)
Public Shared Function FromSpan (
    snapshot As ITextSnapshot,
    offset As Integer,
    length As Integer
) As TextSnapshotRange

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the text range.
offset
Type: SystemInt32
The start offset.
length
Type: SystemInt32
The length of the range.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange that was created.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.GetHashCode Method

TextSnapshotRangeGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.GetText Method

TextSnapshotRangeGetText Method

Returns the snapshot text substring encompassed by this range, using the specified LineTerminator for line ends.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string GetText(
    LineTerminator lineTerminator
)
Public Function GetText (
    lineTerminator As LineTerminator
) As String

Parameters

lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the type of line terminators to use.

Return Value

Type: String
The snapshot text substring encompassed by this range, using the specified LineTerminator for line ends.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.IntersectsWith Method

TextSnapshotRangeIntersectsWith Method

Overload List
 | Name | Description
Public method | IntersectsWith(Int32) | Returns whether the TextSnapshotRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextSnapshotRange intersects with the specified TextRange.
Public method | IntersectsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.
Public method | IntersectsWith(TextSnapshotRange, Boolean, Boolean) | Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.IntersectsWith Method (Int32)

TextSnapshotRangeIntersectsWith Method (Int32)

Returns whether the TextSnapshotRange intersects with the specified offset.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    int offset
)
Public Function IntersectsWith (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange intersects with the specified offset; otherwise, false.
Remarks
This method returns whether the specified offset borders on or lies within the TextSnapshotRange.
See Also

Reference

TextSnapshotRange Structure
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.IntersectsWith Method (TextRange)

TextSnapshotRangeIntersectsWith Method (TextRange)

Returns whether the TextSnapshotRange intersects with the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextRange range
)
Public Function IntersectsWith (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange intersects with the specified TextRange; otherwise, false.
Remarks
This method returns whether the specified TextRange borders on or overlaps the TextSnapshotRange.
See Also

Reference

TextSnapshotRange Structure
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.IntersectsWith Method (TextSnapshotRange)

TextSnapshotRangeIntersectsWith Method (TextSnapshotRange)

Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextSnapshotRange range
)
Public Function IntersectsWith (
    range As TextSnapshotRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange intersects with the specified TextSnapshotRange; otherwise, false.
Remarks
This method returns whether the specified TextSnapshotRange borders on or overlaps the TextSnapshotRange.
See Also

Reference

TextSnapshotRange Structure
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.IntersectsWith Method (TextSnapshotRange, Boolean, Boolean)

TextSnapshotRangeIntersectsWith Method (TextSnapshotRange, Boolean, Boolean)

Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextSnapshotRange range,
    bool includeFirstEdge,
    bool includeLastEdge
)
Public Function IntersectsWith (
    range As TextSnapshotRange,
    includeFirstEdge As Boolean,
    includeLastEdge As Boolean
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.
includeFirstEdge
Type: SystemBoolean
Whether to return true if the specified TextSnapshotRange borders on the leading (first) edge of this TextSnapshotRange.
includeLastEdge
Type: SystemBoolean
Whether to return true if the specified TextSnapshotRange borders on the trailing (last) edge of this TextSnapshotRange.

Return Value

Type: Boolean
true if the TextSnapshotRange intersects with the specified TextSnapshotRange; otherwise, false.
Remarks
This method returns whether the specified TextSnapshotRange borders on or overlaps the TextSnapshotRange.
See Also

Reference

TextSnapshotRange Structure
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.OverlapsWith Method

TextSnapshotRangeOverlapsWith Method

Overload List
 | Name | Description
Public method | OverlapsWith(TextRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextRange.
Public method | OverlapsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange.
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.OverlapsWith Method (TextRange)

TextSnapshotRangeOverlapsWith Method (TextRange)

Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    TextRange range
)
Public Function OverlapsWith (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange overlaps with, or crosses, the specified TextRange; otherwise, false.
See Also

Reference

TextSnapshotRange Structure
OverlapsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.OverlapsWith Method (TextSnapshotRange)

TextSnapshotRangeOverlapsWith Method (TextSnapshotRange)

Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    TextSnapshotRange range
)
Public Function OverlapsWith (
    range As TextSnapshotRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange; otherwise, false.
See Also

Reference

TextSnapshotRange Structure
OverlapsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.ToString Method

TextSnapshotRangeToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.ToVersionRange Method

TextSnapshotRangeToVersionRange Method

Overload List
 | Name | Description
Public method | ToVersionRange(TextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | ToVersionRange(FuncTextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.ToVersionRange Method (TextRangeTrackingModes)

TextSnapshotRangeToVersionRange Method (TextRangeTrackingModes)

Converts this text range into an ITextVersionRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextVersionRange ToVersionRange(
    TextRangeTrackingModes trackingModes
)
Public Function ToVersionRange (
    trackingModes As TextRangeTrackingModes
) As ITextVersionRange

Parameters

trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
The ITextVersionRange that was created.
See Also

Reference

TextSnapshotRange Structure
ToVersionRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.ToVersionRange Method (Func(TextRangeTrackingModes))

TextSnapshotRangeToVersionRange Method (FuncTextRangeTrackingModes)

Converts this text range into an ITextVersionRange.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextVersionRange ToVersionRange(
    Func<TextRangeTrackingModes> trackingModesFunc
)
Public Function ToVersionRange (
    trackingModesFunc As Func(Of TextRangeTrackingModes)
) As ITextVersionRange

Parameters

trackingModesFunc
Type: SystemFunc TextRangeTrackingModes
A function that dynamically returns a TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
The ITextVersionRange that was created.
See Also

Reference

TextSnapshotRange Structure
ToVersionRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.TranslateTo Method

TextSnapshotRangeTranslateTo Method

Translates this text range from one ITextSnapshot to another in the same ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange TranslateTo(
    ITextSnapshot toSnapshot,
    TextRangeTrackingModes trackingModes
)
Public Function TranslateTo (
    toSnapshot As ITextSnapshot,
    trackingModes As TextRangeTrackingModes
) As TextSnapshotRange

Parameters

toSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is the target of the translation.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: TextSnapshotRange
The translated TextSnapshotRange.
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange Operators and Type Conversions

The TextSnapshotRange type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
(TextSnapshotRange to TextRange) |
Inequality |
LessThan |
Top
See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.Equality Operator

TextSnapshotRangeEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Equality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextSnapshotRange left,
    TextSnapshotRange right
)
Public Shared Operator = (
    left As TextSnapshotRange,
    right As TextSnapshotRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Equality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

right
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Equality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Equality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.GreaterThan Operator

TextSnapshotRangeGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_GreaterThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator >(
    TextSnapshotRange left,
    TextSnapshotRange right
)
Public Shared Operator > (
    left As TextSnapshotRange,
    right As TextSnapshotRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_GreaterThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

right
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_GreaterThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_GreaterThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange Implicit Conversion (TextSnapshotRange to TextRange)

TextSnapshotRange Conversion (TextSnapshotRange to TextRange)

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Implicit(ActiproSoftware.Text.TextSnapshotRange)~ActiproSoftware.Text.TextRange"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static implicit operator TextRange (
    TextSnapshotRange range
)
Public Shared Widening Operator CType (
    range As TextSnapshotRange
) As TextRange

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="range"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Implicit(ActiproSoftware.Text.TextSnapshotRange)~ActiproSoftware.Text.TextRange"]

Return Value

Type: TextRange

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Implicit(ActiproSoftware.Text.TextSnapshotRange)~ActiproSoftware.Text.TextRange"]

See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.Inequality Operator

TextSnapshotRangeInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Inequality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextSnapshotRange left,
    TextSnapshotRange right
)
Public Shared Operator <> (
    left As TextSnapshotRange,
    right As TextSnapshotRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Inequality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

right
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Inequality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Inequality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRange.LessThan Operator

TextSnapshotRangeLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_LessThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator <(
    TextSnapshotRange left,
    TextSnapshotRange right
)
Public Shared Operator < (
    left As TextSnapshotRange,
    right As TextSnapshotRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_LessThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

right
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_LessThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_LessThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

See Also

Reference

TextSnapshotRange Structure
ActiproSoftware.Text Namespace


TextSnapshotRangeEventArgs Class

Event arguments used when a change notification is needed for a TextSnapshotRange.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.TextTextSnapshotRangeEventArgs
ActiproSoftware.Text.TaggingTagsChangedEventArgs

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TextSnapshotRangeEventArgs : EventArgs
Public Class TextSnapshotRangeEventArgs
    Inherits EventArgs

The TextSnapshotRangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotRangeEventArgs | Initializes a new instance of the TextSnapshotRangeEventArgs class.
Top
Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange of the change.
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotRangeEventArgs Constructor

Initializes a new instance of the TextSnapshotRangeEventArgs class.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRangeEventArgs(
    TextSnapshotRange snapshotRange
)
Public Sub New (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange of the change.
See Also

Reference

TextSnapshotRangeEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotRangeEventArgs Properties

The TextSnapshotRangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange of the change.
Top
See Also

Reference

TextSnapshotRangeEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotRangeEventArgs.SnapshotRange Property

TextSnapshotRangeEventArgsSnapshotRange Property

Gets the TextSnapshotRange of the change.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange SnapshotRange { get; }
Public ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange of the change.
See Also

Reference

TextSnapshotRangeEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotReaderOptions Class

Represents options that are applied to an ITextSnapshotReader.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextTextSnapshotReaderOptions

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TextSnapshotReaderOptions : ITextSnapshotReaderOptions
Public Class TextSnapshotReaderOptions
    Implements ITextSnapshotReaderOptions

The TextSnapshotReaderOptions type exposes the following members.

Properties
 | Name | Description
Public property | DefaultTokenLoadBufferLength | Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | InitialTokenLoadBufferLength | Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | PrimaryScanDirection | Gets or sets the primary direction in which text scanning will take place with the reader.
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotReaderOptions Properties

The TextSnapshotReaderOptions type exposes the following members.

Properties
 | Name | Description
Public property | DefaultTokenLoadBufferLength | Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | InitialTokenLoadBufferLength | Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | PrimaryScanDirection | Gets or sets the primary direction in which text scanning will take place with the reader.
Top
See Also

Reference

TextSnapshotReaderOptions Class
ActiproSoftware.Text Namespace


TextSnapshotReaderOptions.DefaultTokenLoadBufferLength Property

TextSnapshotReaderOptionsDefaultTokenLoadBufferLength Property

Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int DefaultTokenLoadBufferLength { get; set; }
Public Property DefaultTokenLoadBufferLength As Integer
    Get
    Set

Property Value

Type: Int32
The number of characters for which to load tokens. The default value is 700.

Implements

ITextSnapshotReaderOptionsDefaultTokenLoadBufferLength
Remarks
This property governs each load of tokens following the first load.
See Also

Reference

TextSnapshotReaderOptions Class
ActiproSoftware.Text Namespace
TextSnapshotReaderOptionsInitialTokenLoadBufferLength


TextSnapshotReaderOptions.InitialTokenLoadBufferLength Property

TextSnapshotReaderOptionsInitialTokenLoadBufferLength Property

Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int InitialTokenLoadBufferLength { get; set; }
Public Property InitialTokenLoadBufferLength As Integer
    Get
    Set

Property Value

Type: Int32
The number of characters for which to load tokens. The default value is 100.

Implements

ITextSnapshotReaderOptionsInitialTokenLoadBufferLength
Remarks
This property only governs the first load of tokens.
See Also

Reference

TextSnapshotReaderOptions Class
ActiproSoftware.Text Namespace
TextSnapshotReaderOptionsDefaultTokenLoadBufferLength


TextSnapshotReaderOptions.PrimaryScanDirection Property

TextSnapshotReaderOptionsPrimaryScanDirection Property

Gets or sets the primary direction in which text scanning will take place with the reader.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<TextScanDirection> PrimaryScanDirection { get; set; }
Public Property PrimaryScanDirection As Nullable(Of TextScanDirection)
    Get
    Set

Property Value

Type: Nullable TextScanDirection
The primary direction in which text scanning will take place with the reader. The default value is .

Implements

ITextSnapshotReaderOptionsPrimaryScanDirection
Remarks
A value of means indeterminate. This property is simply used for optimization of the initial token load and in no way restricts which way you are permitted to scan with the reader.
See Also

Reference

TextSnapshotReaderOptions Class
ActiproSoftware.Text Namespace


WhitespaceTrimModes Enumeration

Specifies the modes by which whitespace is trimmed.

Namespace: ActiproSoftware.Text
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum WhitespaceTrimModes
Public Enumeration WhitespaceTrimModes
Members
Member name | Value | Description
None | 0 | Whitespace is not auto-trimmed.
TrailingOnPaste | 1 | Trailing whitespace is trimmed on text pasted into the document.
TrailingOnTextReplacement | 2 | Trailing whitespace is trimmed when the entire contents of the document are replaced, such as via a document open.
See Also

Reference

ActiproSoftware.Text Namespace


ActiproSoftware.Text.Analysis Namespace

Contains types related to code structural analysis.
Interfaces
 | Interface | Description
Public interface | IAutoCorrector | Provides the base requirements for a class that can perform auto-correction.
Public interface | ICodeBlockFinder | Provides the base requirements for a class that can find containing code blocks, generally used for code block selection expansion in an editor.
Public interface | IDelimiterAutoCompleter | Provides the base requirements for a class that can perform delimiter auto-completion.
Public interface | IStructureMatcher | Provides the base requirements for a class that can locate matching structural text ranges for an offset, such as finding matching brackets.
Public interface | IStructureMatchOptions | Provides the base requirements for a class that stores options for a structure match operation.
Public interface | IStructureMatchResult | Provides the base requirements for a class that stores a single result of a structure match operation.
Public interface | IStructureMatchResultCollection | Provides the base requirements for a collection of IStructureMatchResult objects.
Public interface | IStructureMatchResultSet | Provides the base requirements for a class that stores the results of a structure match operation.
Enumerations
 | Enumeration | Description
Public enumeration | StructureMatchEdges | Specifies which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.


IAutoCorrector Interface

Provides the base requirements for a class that can perform auto-correction.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAutoCorrector
Public Interface IAutoCorrector

The IAutoCorrector type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IAutoCorrector Methods

The IAutoCorrector type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange.
Top
See Also

Reference

IAutoCorrector Interface
ActiproSoftware.Text.Analysis Namespace


IAutoCorrector.AutoCorrect Method

IAutoCorrectorAutoCorrect Method

Auto-corrects over the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void AutoCorrect(
    TextSnapshotRange snapshotRange
)
Sub AutoCorrect (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.
See Also

Reference

IAutoCorrector Interface
ActiproSoftware.Text.Analysis Namespace


ICodeBlockFinder Interface

Provides the base requirements for a class that can find containing code blocks, generally used for code block selection expansion in an editor.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICodeBlockFinder
Public Interface ICodeBlockFinder

The ICodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


ICodeBlockFinder Methods

The ICodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block.
Top
See Also

Reference

ICodeBlockFinder Interface
ActiproSoftware.Text.Analysis Namespace


ICodeBlockFinder.FindContaining Method

ICodeBlockFinderFindContaining Method

Returns the TextSnapshotRange of the containing code block.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotRange FindContaining(
    TextSnapshotRange snapshotRange
)
Function FindContaining (
    snapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange from which to begin the search.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange of the containing code block.
See Also

Reference

ICodeBlockFinder Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter Interface

Provides the base requirements for a class that can perform delimiter auto-completion.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDelimiterAutoCompleter
Public Interface IDelimiterAutoCompleter

The IDelimiterAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed.
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed.
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed.
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter Properties

The IDelimiterAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed.
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed.
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed.
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed.
Top
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter.CanCompleteAngleBraces Property

IDelimiterAutoCompleterCanCompleteAngleBraces Property

Gets or sets whether angle braces can be completed.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanCompleteAngleBraces { get; set; }
Property CanCompleteAngleBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if angle braces can be completed; otherwise, false. The default value is false.
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter.CanCompleteCurlyBraces Property

IDelimiterAutoCompleterCanCompleteCurlyBraces Property

Gets or sets whether curly braces can be completed.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanCompleteCurlyBraces { get; set; }
Property CanCompleteCurlyBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if curly braces can be completed; otherwise, false. The default value is true.
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter.CanCompleteParentheses Property

IDelimiterAutoCompleterCanCompleteParentheses Property

Gets or sets whether parentheses can be completed.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanCompleteParentheses { get; set; }
Property CanCompleteParentheses As Boolean
    Get
    Set

Property Value

Type: Boolean
true if parentheses can be completed; otherwise, false. The default value is true.
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter.CanCompleteSquareBraces Property

IDelimiterAutoCompleterCanCompleteSquareBraces Property

Gets or sets whether square braces can be completed.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanCompleteSquareBraces { get; set; }
Property CanCompleteSquareBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if square braces can be completed; otherwise, false. The default value is true.
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatcher Interface

Provides the base requirements for a class that can locate matching structural text ranges for an offset, such as finding matching brackets.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IStructureMatcher
Public Interface IStructureMatcher

The IStructureMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Match | Attempts to locate structural text, such as bracket pairs, at the specified offset.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatcher Methods

The IStructureMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Match | Attempts to locate structural text, such as bracket pairs, at the specified offset.
Top
See Also

Reference

IStructureMatcher Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatcher.Match Method

IStructureMatcherMatch Method

Attempts to locate structural text, such as bracket pairs, at the specified offset.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IStructureMatchResultSet Match(
    TextSnapshotOffset snapshotOffset,
    IStructureMatchOptions options
)
Function Match (
    snapshotOffset As TextSnapshotOffset,
    options As IStructureMatchOptions
) As IStructureMatchResultSet

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.
options
Type: ActiproSoftware.Text.AnalysisIStructureMatchOptions
The IStructureMatchOptions to use.

Return Value

Type: IStructureMatchResultSet
An IStructureMatchResultSet that contains the results that were found, if any.
Remarks
When the result set is empty, no structural delimiter was next to the specified offset. When the result set contains a single result, a structural delimiter such as a bracket was found next to the specified offset, but no matching structural delimiter was found. The result set may contain multiple entries in cases such as when a language wishes to flag #if...#else...#endif blocks as a structure.
See Also

Reference

IStructureMatcher Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchOptions Interface

Provides the base requirements for a class that stores options for a structure match operation.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IStructureMatchOptions
Public Interface IStructureMatchOptions

The IStructureMatchOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsNavigationRequest | Gets or sets whether the structure match is being performed for a navigation request.
Top
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatchOptions Properties

The IStructureMatchOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsNavigationRequest | Gets or sets whether the structure match is being performed for a navigation request.
Top
See Also

Reference

IStructureMatchOptions Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchOptions.IsNavigationRequest Property

IStructureMatchOptionsIsNavigationRequest Property

Gets or sets whether the structure match is being performed for a navigation request.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsNavigationRequest { get; set; }
Property IsNavigationRequest As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the structure match is being performed for a navigation request; otherwise, false.
Remarks
When the operating is being performed for a navigation request, the match algorithm may want to be more liberal with its match algorithm.
See Also

Reference

IStructureMatchOptions Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult Interface

Provides the base requirements for a class that stores a single result of a structure match operation.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IStructureMatchResult : ITextRangeProvider
Public Interface IStructureMatchResult
    Inherits ITextRangeProvider

The IStructureMatchResult type exposes the following members.

Properties
 | Name | Description
Public property | IsSource | Gets whether this result is the match that occurred from the source offset.
Public property | MatchEdges | Gets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Public property | NavigationSnapshotOffset | Gets the TextSnapshotOffset to navigate for the match, if one is available.
Public property | SnapshotRange | Gets a TextSnapshotRange indicating the offset range of the match.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult Properties

The IStructureMatchResult type exposes the following members.

Properties
 | Name | Description
Public property | IsSource | Gets whether this result is the match that occurred from the source offset.
Public property | MatchEdges | Gets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Public property | NavigationSnapshotOffset | Gets the TextSnapshotOffset to navigate for the match, if one is available.
Public property | SnapshotRange | Gets a TextSnapshotRange indicating the offset range of the match.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult.IsSource Property

IStructureMatchResultIsSource Property

Gets whether this result is the match that occurred from the source offset.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsSource { get; }
ReadOnly Property IsSource As Boolean
    Get

Property Value

Type: Boolean
true if the result is the match that occurred from the source offset; otherwise, false.
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult.MatchEdges Property

IStructureMatchResultMatchEdges Property

Gets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
StructureMatchEdges MatchEdges { get; }
ReadOnly Property MatchEdges As StructureMatchEdges
    Get

Property Value

Type: StructureMatchEdges
A StructureMatchEdges that specifies the valid edges.
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult.NavigationSnapshotOffset Property

IStructureMatchResultNavigationSnapshotOffset Property

Gets the TextSnapshotOffset to navigate for the match, if one is available.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> NavigationSnapshotOffset { get; }
ReadOnly Property NavigationSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset to navigate for the match, if one is available.
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult.SnapshotRange Property

IStructureMatchResultSnapshotRange Property

Gets a TextSnapshotRange indicating the offset range of the match.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange indicating the offset range of the match.
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultCollection Interface

Provides the base requirements for a collection of IStructureMatchResult objects.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IStructureMatchResultCollection : IEnumerable,
    IList<IStructureMatchResult>, ICollection<IStructureMatchResult>, IEnumerable<IStructureMatchResult>
Public Interface IStructureMatchResultCollection
    Inherits IEnumerable, IList(Of IStructureMatchResult), ICollection(Of IStructureMatchResult),
    IEnumerable(Of IStructureMatchResult)

The IStructureMatchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IStructureMatchResult .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IStructureMatchResult .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IStructureMatchResult .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IStructureMatchResult .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IStructureMatchResult .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IStructureMatchResult .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IStructureMatchResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IStructureMatchResult .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IStructureMatchResult .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IStructureMatchResult .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IStructureMatchResult .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIStructureMatchResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIStructureMatchResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIStructureMatchResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultCollection Properties

The IStructureMatchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IStructureMatchResult .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IStructureMatchResult .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IStructureMatchResult .)
Top
See Also

Reference

IStructureMatchResultCollection Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultCollection Methods

The IStructureMatchResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IStructureMatchResult .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IStructureMatchResult .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IStructureMatchResult .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IStructureMatchResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IStructureMatchResult .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IStructureMatchResult .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IStructureMatchResult .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IStructureMatchResult .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIStructureMatchResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIStructureMatchResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIStructureMatchResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IStructureMatchResultCollection Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultSet Interface

Provides the base requirements for a class that stores the results of a structure match operation.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IStructureMatchResultSet
Public Interface IStructureMatchResultSet

The IStructureMatchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of IStructureMatchResult objects.
Top
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultSet Properties

The IStructureMatchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of IStructureMatchResult objects.
Top
See Also

Reference

IStructureMatchResultSet Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultSet.Results Property

IStructureMatchResultSetResults Property

Gets the collection of IStructureMatchResult objects.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IStructureMatchResultCollection Results { get; }
ReadOnly Property Results As IStructureMatchResultCollection
    Get

Property Value

Type: IStructureMatchResultCollection
The collection of IStructureMatchResult objects.
See Also

Reference

IStructureMatchResultSet Interface
ActiproSoftware.Text.Analysis Namespace


StructureMatchEdges Enumeration

Specifies which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.

Namespace: ActiproSoftware.Text.Analysis
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum StructureMatchEdges
Public Enumeration StructureMatchEdges
Members
Member name | Value | Description
None | 0 | Only the inside of the match result range can cause the matcher to match the result again; no outer edges will match.
Start | 1 | Only the start offset of the match result's range can cause the matcher to match the result again.
End | 2 | Only the end offset of the match result's range can cause the matcher to match the result again.
Both | 3 | Both the match result range's start and end offsets can cause the matcher to match the result again.
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


ActiproSoftware.Text.Analysis.Implementation Namespace

Contains the implementation types related to code structural analysis.
Classes
 | Class | Description
Public class | AutoCaseCorrector | Provides a default implementation of an IAutoCorrector that examines tokens for case-insensitive matches and auto-corrects them to proper case.
Public class | AutoCorrectorBase | Provides an abstract base class for an IAutoCorrector whose AutoCorrect(TextSnapshotRange) method is called at appropriate times following text changes or caret moves.
Public class | DelimiterAutoCompleter | Provides a default implementation for an IDelimiterAutoCompleter that can perform delimiter auto-completion.
Public class | LLParseDataCodeBlockFinder | Represents a default implementation of an ICodeBlockFinder that is capable of returning containing code blocks based on AST parse data from an ILLParser.
Public class | StructureMatcher | Represents a default implementation of an IStructureMatcher that is capable of matching common bracket delimiters.
Public class | StructureMatchOptions | Represents options for a structure match operation.
Public class | StructureMatchResult | Stores a single result of a structure match operation.
Public class | StructureMatchResultCollection | Represents a collection of an IStructureMatchResult objects.
Public class | StructureMatchResultSet | Stores the results of a structure match operation.


AutoCaseCorrector Class

Provides a default implementation of an IAutoCorrector that examines tokens for case-insensitive matches and auto-corrects them to proper case.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationAutoCorrectorBase
ActiproSoftware.Text.Analysis.ImplementationAutoCaseCorrector
ActiproSoftware.Text.Languages.VB.ImplementationVBAutoCaseCorrector

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutoCaseCorrector : AutoCorrectorBase
Public Class AutoCaseCorrector
    Inherits AutoCorrectorBase

The AutoCaseCorrector type exposes the following members.

Constructors
 | Name | Description
Public method | AutoCaseCorrector | Initializes a new instance of the AutoCaseCorrector class
Top
Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange. (Overrides AutoCorrectorBaseAutoCorrect(TextSnapshotRange).)
Protected method | GetCaseCorrectText | Returns the case-corrected text for the specified IToken.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from AutoCorrectorBase.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IAutoCorrector interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCaseCorrector Constructor

Initializes a new instance of the AutoCaseCorrector class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoCaseCorrector()
Public Sub New
See Also

Reference

AutoCaseCorrector Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCaseCorrector Methods

The AutoCaseCorrector type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange. (Overrides AutoCorrectorBaseAutoCorrect(TextSnapshotRange).)
Protected method | GetCaseCorrectText | Returns the case-corrected text for the specified IToken.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from AutoCorrectorBase.)
Top
See Also

Reference

AutoCaseCorrector Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCaseCorrector.AutoCorrect Method

AutoCaseCorrectorAutoCorrect Method

Auto-corrects over the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void AutoCorrect(
    TextSnapshotRange snapshotRange
)
Public Overrides Sub AutoCorrect (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Implements

IAutoCorrectorAutoCorrect(TextSnapshotRange)
See Also

Reference

AutoCaseCorrector Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCaseCorrector.GetCaseCorrectText Method

AutoCaseCorrectorGetCaseCorrectText Method

Returns the case-corrected text for the specified IToken.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string GetCaseCorrectText(
    ITextSnapshot snapshot,
    IToken token
)
Protected Overridable Function GetCaseCorrectText (
    snapshot As ITextSnapshot,
    token As IToken
) As String

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The source ITextSnapshot.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: String
The case-corrected text for the specified IToken. Returns if no case-correction is required.
See Also

Reference

AutoCaseCorrector Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase Class

Provides an abstract base class for an IAutoCorrector whose AutoCorrect(TextSnapshotRange) method is called at appropriate times following text changes or caret moves.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationAutoCorrectorBase
ActiproSoftware.Text.Analysis.ImplementationAutoCaseCorrector

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class AutoCorrectorBase : IEditorDocumentTextChangeEventSink,
    IEditorViewSelectionChangeEventSink, IAutoCorrector
Public MustInherit Class AutoCorrectorBase
    Implements IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink, IAutoCorrector

The AutoCorrectorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AutoCorrectorBase | Initializes a new instance of the AutoCorrectorBase class
Top
Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IAutoCorrector interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase Constructor

Initializes a new instance of the AutoCorrectorBase class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected AutoCorrectorBase()
Protected Sub New
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase Methods

The AutoCorrectorBase type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Top
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase.AutoCorrect Method

AutoCorrectorBaseAutoCorrect Method

Auto-corrects over the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void AutoCorrect(
    TextSnapshotRange snapshotRange
)
Public MustOverride Sub AutoCorrect (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Implements

IAutoCorrectorAutoCorrect(TextSnapshotRange)
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase.OnDocumentTextChanged Method

AutoCorrectorBaseOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase.OnDocumentTextChanging Method

AutoCorrectorBaseOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase.OnViewSelectionChanged Method

AutoCorrectorBaseOnViewSelectionChanged Method

Occurs when the selection is changed in the specified IEditorView.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnViewSelectionChanged(
    IEditorView view,
    EditorViewSelectionEventArgs e
)
Protected Overridable Sub OnViewSelectionChanged (
    view As IEditorView,
    e As EditorViewSelectionEventArgs
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorViewSelectionEventArgs
The EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter Class

Provides a default implementation for an IDelimiterAutoCompleter that can perform delimiter auto-completion.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationDelimiterAutoCompleter
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpDelimiterAutoCompleter
ActiproSoftware.Text.Languages.VB.ImplementationVBDelimiterAutoCompleter

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DelimiterAutoCompleter : IEditorDocumentTextChangeEventSink,
    IEditorViewSelectionChangeEventSink, IEditorViewTextInputEventSink, IDelimiterAutoCompleter
Public Class DelimiterAutoCompleter
    Implements IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink, IEditorViewTextInputEventSink, IDelimiterAutoCompleter

The DelimiterAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | DelimiterAutoCompleter | Initializes a new instance of the DelimiterAutoCompleter class.
Top
Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed.
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed.
Public property | CanCompleteDoubleQuotes | Gets or sets whether double quotes can be completed.
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed.
Public property | CanCompleteSingleQuotes | Gets or sets whether single quotes can be completed.
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed.
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion.
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion.
Public property | OpenDoubleQuoteTokenId | Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion.
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion.
Public property | OpenSingleQuoteTokenId | Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion.
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion.
Top
Methods
 | Name | Description
Protected method | IsValidForEndDelimiterAutoComplete | Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset.
Protected method | IsValidStartDelimiter(ITextSnapshotReader, Char) | Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter.
Protected method | IsValidStartDelimiter(IToken, Char) | Returns whether an IToken represents the specified start delimiter.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IDelimiterAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter Constructor

Initializes a new instance of the DelimiterAutoCompleter class.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DelimiterAutoCompleter()
Public Sub New
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter Properties

The DelimiterAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed.
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed.
Public property | CanCompleteDoubleQuotes | Gets or sets whether double quotes can be completed.
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed.
Public property | CanCompleteSingleQuotes | Gets or sets whether single quotes can be completed.
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed.
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion.
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion.
Public property | OpenDoubleQuoteTokenId | Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion.
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion.
Public property | OpenSingleQuoteTokenId | Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion.
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion.
Top
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteAngleBraces Property

DelimiterAutoCompleterCanCompleteAngleBraces Property

Gets or sets whether angle braces can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompleteAngleBraces { get; set; }
Public Property CanCompleteAngleBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if angle braces can be completed; otherwise, false. The default value is false.

Implements

IDelimiterAutoCompleterCanCompleteAngleBraces
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteCurlyBraces Property

DelimiterAutoCompleterCanCompleteCurlyBraces Property

Gets or sets whether curly braces can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompleteCurlyBraces { get; set; }
Public Property CanCompleteCurlyBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if curly braces can be completed; otherwise, false. The default value is true.

Implements

IDelimiterAutoCompleterCanCompleteCurlyBraces
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteDoubleQuotes Property

DelimiterAutoCompleterCanCompleteDoubleQuotes Property

Gets or sets whether double quotes can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompleteDoubleQuotes { get; set; }
Public Property CanCompleteDoubleQuotes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if double quotes can be completed; otherwise, false. The default value is true.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteParentheses Property

DelimiterAutoCompleterCanCompleteParentheses Property

Gets or sets whether parentheses can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompleteParentheses { get; set; }
Public Property CanCompleteParentheses As Boolean
    Get
    Set

Property Value

Type: Boolean
true if parentheses can be completed; otherwise, false. The default value is true.

Implements

IDelimiterAutoCompleterCanCompleteParentheses
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteSingleQuotes Property

DelimiterAutoCompleterCanCompleteSingleQuotes Property

Gets or sets whether single quotes can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompleteSingleQuotes { get; set; }
Public Property CanCompleteSingleQuotes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if single quotes can be completed; otherwise, false. The default value is false.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteSquareBraces Property

DelimiterAutoCompleterCanCompleteSquareBraces Property

Gets or sets whether square braces can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompleteSquareBraces { get; set; }
Public Property CanCompleteSquareBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if square braces can be completed; otherwise, false. The default value is true.

Implements

IDelimiterAutoCompleterCanCompleteSquareBraces
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenAngleBraceTokenId Property

DelimiterAutoCompleterOpenAngleBraceTokenId Property

Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenAngleBraceTokenId { get; set; }
Public Property OpenAngleBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open angle brace character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for angle braces.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenCurlyBraceTokenId Property

DelimiterAutoCompleterOpenCurlyBraceTokenId Property

Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenCurlyBraceTokenId { get; set; }
Public Property OpenCurlyBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open curly brace character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for curly braces.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenDoubleQuoteTokenId Property

DelimiterAutoCompleterOpenDoubleQuoteTokenId Property

Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenDoubleQuoteTokenId { get; set; }
Public Property OpenDoubleQuoteTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open double quote character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for double quotes.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenParenthesisTokenId Property

DelimiterAutoCompleterOpenParenthesisTokenId Property

Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenParenthesisTokenId { get; set; }
Public Property OpenParenthesisTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open parenthesis character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for parentheses.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenSingleQuoteTokenId Property

DelimiterAutoCompleterOpenSingleQuoteTokenId Property

Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenSingleQuoteTokenId { get; set; }
Public Property OpenSingleQuoteTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open single quote character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for single quotes.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenSquareBraceTokenId Property

DelimiterAutoCompleterOpenSquareBraceTokenId Property

Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenSquareBraceTokenId { get; set; }
Public Property OpenSquareBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open square brace character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for square braces.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter Methods

The DelimiterAutoCompleter type exposes the following members.

Methods
 | Name | Description
Protected method | IsValidForEndDelimiterAutoComplete | Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset.
Protected method | IsValidStartDelimiter(ITextSnapshotReader, Char) | Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter.
Protected method | IsValidStartDelimiter(IToken, Char) | Returns whether an IToken represents the specified start delimiter.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView.
Top
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.IsValidForEndDelimiterAutoComplete Method

DelimiterAutoCompleterIsValidForEndDelimiterAutoComplete Method

Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsValidForEndDelimiterAutoComplete(
    TextSnapshotOffset snapshotOffset,
    char endDelimiter
)
Protected Overridable Function IsValidForEndDelimiterAutoComplete (
    snapshotOffset As TextSnapshotOffset,
    endDelimiter As Char
) As Boolean

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset at which to possibly auto-insert the delimiter.
endDelimiter
Type: SystemChar
The end delimiter.

Return Value

Type: Boolean
true if the end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset; otherwise, false.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.IsValidStartDelimiter Method

DelimiterAutoCompleterIsValidStartDelimiter Method

Overload List
 | Name | Description
Protected method | IsValidStartDelimiter(ITextSnapshotReader, Char) | Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter.
Protected method | IsValidStartDelimiter(IToken, Char) | Returns whether an IToken represents the specified start delimiter.
Top
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.IsValidStartDelimiter Method (ITextSnapshotReader, Char)

DelimiterAutoCompleterIsValidStartDelimiter Method (ITextSnapshotReader, Char)

Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsValidStartDelimiter(
    ITextSnapshotReader reader,
    char startDelimiter
)
Protected Overridable Function IsValidStartDelimiter (
    reader As ITextSnapshotReader,
    startDelimiter As Char
) As Boolean

Parameters

reader
Type: ActiproSoftware.TextITextSnapshotReader
The ITextSnapshotReader to examine.
startDelimiter
Type: SystemChar
The start delimiter.

Return Value

Type: Boolean
true if the ITextSnapshotReader's current offset is immediately after the specified start delimiter; otherwise, false.
See Also

Reference

DelimiterAutoCompleter Class
IsValidStartDelimiter Overload
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.IsValidStartDelimiter Method (IToken, Char)

DelimiterAutoCompleterIsValidStartDelimiter Method (IToken, Char)

Returns whether an IToken represents the specified start delimiter.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsValidStartDelimiter(
    IToken token,
    char startDelimiter
)
Protected Overridable Function IsValidStartDelimiter (
    token As IToken,
    startDelimiter As Char
) As Boolean

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.
startDelimiter
Type: SystemChar
The start delimiter.

Return Value

Type: Boolean
true if the IToken represents the specified start delimiter; otherwise, false.
Remarks
The default implementation of this method compares the token ID to the IDs specified in the OpenAngleBraceTokenId, OpenCurlyBraceTokenId, OpenParenthesisTokenId, and OpenSquareBraceTokenId properties. This method is called by the default implementation of the IsValidForEndDelimiterAutoComplete(TextSnapshotOffset, Char) method.
See Also

Reference

DelimiterAutoCompleter Class
IsValidStartDelimiter Overload
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OnDocumentTextChanged Method

DelimiterAutoCompleterOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OnDocumentTextChanging Method

DelimiterAutoCompleterOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OnViewSelectionChanged Method

DelimiterAutoCompleterOnViewSelectionChanged Method

Occurs when the selection is changed in the specified IEditorView.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnViewSelectionChanged(
    IEditorView view,
    EditorViewSelectionEventArgs e
)
Protected Overridable Sub OnViewSelectionChanged (
    view As IEditorView,
    e As EditorViewSelectionEventArgs
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorViewSelectionEventArgs
The EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OnViewTextInput Method

DelimiterAutoCompleterOnViewTextInput Method

Occurs before text is input to the specified IEditorView.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnViewTextInput(
    IEditorView view,
    TextCompositionEventArgs e
)
Protected Overridable Sub OnViewTextInput (
    view As IEditorView,
    e As TextCompositionEventArgs
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: System.Windows.InputTextCompositionEventArgs
The TextCompositionEventArgs that contains the event data.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder Class

Represents a default implementation of an ICodeBlockFinder that is capable of returning containing code blocks based on AST parse data from an ILLParser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCodeBlockFinderBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptCodeBlockFinder
ActiproSoftware.Text.Languages.Python.ImplementationPythonCodeBlockFinder
ActiproSoftware.Text.Languages.Xml.ImplementationXmlCodeBlockFinder

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LLParseDataCodeBlockFinder : ICodeBlockFinder
Public Class LLParseDataCodeBlockFinder
    Implements ICodeBlockFinder

The LLParseDataCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | LLParseDataCodeBlockFinder | Initializes a new instance of the LLParseDataCodeBlockFinder class
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid.
Top
Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block.
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ICodeBlockFinder interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder Constructor

Initializes a new instance of the LLParseDataCodeBlockFinder class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LLParseDataCodeBlockFinder()
Public Sub New
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder Properties

The LLParseDataCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid.
Top
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder.Filter Property

LLParseDataCodeBlockFinderFilter Property

Gets or sets the optional callback used to determine if a potential IAstNode result is valid.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Predicate<IAstNode> Filter { get; set; }
Public Property Filter As Predicate(Of IAstNode)
    Get
    Set

Property Value

Type: Predicate IAstNode
The optional callback used to determine if a potential IAstNode result is valid.
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder Methods

The LLParseDataCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block.
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder.FindContaining Method

LLParseDataCodeBlockFinderFindContaining Method

Returns the TextSnapshotRange of the containing code block.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual TextSnapshotRange FindContaining(
    TextSnapshotRange snapshotRange
)
Public Overridable Function FindContaining (
    snapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange from which to begin the search.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange of the containing code block.

Implements

ICodeBlockFinderFindContaining(TextSnapshotRange)
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder.GetSnapshotRange Method

LLParseDataCodeBlockFinderGetSnapshotRange Method

Returns a TextSnapshotRange for the specified IAstNode.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotRange GetSnapshotRange(
    TextSnapshotRange searchSnapshotRange,
    IAstNode astNode,
    TextSnapshotRange astNodeSnapshotRange
)
Protected Overridable Function GetSnapshotRange (
    searchSnapshotRange As TextSnapshotRange,
    astNode As IAstNode,
    astNodeSnapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

searchSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange from which to begin the search.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode that was found to contain the search snapshot range.
astNodeSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The full snapshot range of the IAstNode.

Return Value

Type: TextSnapshotRange
A TextSnapshotRange for the specified IAstNode.
Remarks
The default implementation of this method returns the astNodeSnapshotRange value. This method can optionally be used to adjust the snapshot range for an AST node as necessary.
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder.TranslateToParseDataSnapshot Method

LLParseDataCodeBlockFinderTranslateToParseDataSnapshot Method

Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotOffset TranslateToParseDataSnapshot(
    ILLParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Overridable Function TranslateToParseDataSnapshot (
    parseData As ILLParseData,
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotOffset

Parameters

parseData
Type: ActiproSoftware.Text.Parsing.LLParserILLParseData
The ILLParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to translate.

Return Value

Type: TextSnapshotOffset
The translated offset.
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher Class

Represents a default implementation of an IStructureMatcher that is capable of matching common bracket delimiters.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationStructureMatcher

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StructureMatcher : IStructureMatcher
Public Class StructureMatcher
    Implements IStructureMatcher

The StructureMatcher type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatcher | Initializes a new instance of the StructureMatcher class.
Top
Properties
 | Name | Description
Public property | CanMatchAngleBraces | Gets or sets whether angle braces can be matched.
Public property | CanMatchCurlyBraces | Gets or sets whether curly braces can be matched.
Public property | CanMatchParentheses | Gets or sets whether parentheses can be matched.
Public property | CanMatchSquareBraces | Gets or sets whether square braces can be matched.
Public property | CloseAngleBraceTokenId | Gets the optional token ID value used to ensure that a close angle brace character is valid for structure matching.
Public property | CloseCurlyBraceTokenId | Gets the optional token ID value used to ensure that a close curly brace character is valid for structure matching.
Public property | CloseParenthesisTokenId | Gets the optional token ID value used to ensure that a close parenthesis character is valid for structure matching.
Public property | CloseSquareBraceTokenId | Gets the optional token ID value used to ensure that a close square brace character is valid for structure matching.
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for structure matching.
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for structure matching.
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for structure matching.
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for structure matching.
Top
Methods
 | Name | Description
Public method | Match | Attempts to locate structural text, such as bracket pairs, at the specified offset.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IStructureMatcher interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher Constructor

Initializes a new instance of the StructureMatcher class.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StructureMatcher()
Public Sub New
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher Properties

The StructureMatcher type exposes the following members.

Properties
 | Name | Description
Public property | CanMatchAngleBraces | Gets or sets whether angle braces can be matched.
Public property | CanMatchCurlyBraces | Gets or sets whether curly braces can be matched.
Public property | CanMatchParentheses | Gets or sets whether parentheses can be matched.
Public property | CanMatchSquareBraces | Gets or sets whether square braces can be matched.
Public property | CloseAngleBraceTokenId | Gets the optional token ID value used to ensure that a close angle brace character is valid for structure matching.
Public property | CloseCurlyBraceTokenId | Gets the optional token ID value used to ensure that a close curly brace character is valid for structure matching.
Public property | CloseParenthesisTokenId | Gets the optional token ID value used to ensure that a close parenthesis character is valid for structure matching.
Public property | CloseSquareBraceTokenId | Gets the optional token ID value used to ensure that a close square brace character is valid for structure matching.
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for structure matching.
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for structure matching.
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for structure matching.
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for structure matching.
Top
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CanMatchAngleBraces Property

StructureMatcherCanMatchAngleBraces Property

Gets or sets whether angle braces can be matched.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMatchAngleBraces { get; set; }
Public Property CanMatchAngleBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if angle braces can be matched; otherwise, false. The default value is false.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CanMatchCurlyBraces Property

StructureMatcherCanMatchCurlyBraces Property

Gets or sets whether curly braces can be matched.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMatchCurlyBraces { get; set; }
Public Property CanMatchCurlyBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if curly braces can be matched; otherwise, false. The default value is true.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CanMatchParentheses Property

StructureMatcherCanMatchParentheses Property

Gets or sets whether parentheses can be matched.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMatchParentheses { get; set; }
Public Property CanMatchParentheses As Boolean
    Get
    Set

Property Value

Type: Boolean
true if parentheses can be matched; otherwise, false. The default value is true.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CanMatchSquareBraces Property

StructureMatcherCanMatchSquareBraces Property

Gets or sets whether square braces can be matched.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMatchSquareBraces { get; set; }
Public Property CanMatchSquareBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if square braces can be matched; otherwise, false. The default value is true.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CloseAngleBraceTokenId Property

StructureMatcherCloseAngleBraceTokenId Property

Gets the optional token ID value used to ensure that a close angle brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> CloseAngleBraceTokenId { get; set; }
Public Property CloseAngleBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close angle brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for angle braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CloseCurlyBraceTokenId Property

StructureMatcherCloseCurlyBraceTokenId Property

Gets the optional token ID value used to ensure that a close curly brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> CloseCurlyBraceTokenId { get; set; }
Public Property CloseCurlyBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close curly brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for curly braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CloseParenthesisTokenId Property

StructureMatcherCloseParenthesisTokenId Property

Gets the optional token ID value used to ensure that a close parenthesis character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> CloseParenthesisTokenId { get; set; }
Public Property CloseParenthesisTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close parenthesis character is valid for structure matching.
Remarks
Leave the value if token validation is not required for parentheses.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CloseSquareBraceTokenId Property

StructureMatcherCloseSquareBraceTokenId Property

Gets the optional token ID value used to ensure that a close square brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> CloseSquareBraceTokenId { get; set; }
Public Property CloseSquareBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close square brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for square braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.OpenAngleBraceTokenId Property

StructureMatcherOpenAngleBraceTokenId Property

Gets the optional token ID value used to ensure that an open angle brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenAngleBraceTokenId { get; set; }
Public Property OpenAngleBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open angle brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for angle braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.OpenCurlyBraceTokenId Property

StructureMatcherOpenCurlyBraceTokenId Property

Gets the optional token ID value used to ensure that an open curly brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenCurlyBraceTokenId { get; set; }
Public Property OpenCurlyBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open curly brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for curly braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.OpenParenthesisTokenId Property

StructureMatcherOpenParenthesisTokenId Property

Gets the optional token ID value used to ensure that an open parenthesis character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenParenthesisTokenId { get; set; }
Public Property OpenParenthesisTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open parenthesis character is valid for structure matching.
Remarks
Leave the value if token validation is not required for parentheses.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.OpenSquareBraceTokenId Property

StructureMatcherOpenSquareBraceTokenId Property

Gets the optional token ID value used to ensure that an open square brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> OpenSquareBraceTokenId { get; set; }
Public Property OpenSquareBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open square brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for square braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher Methods

The StructureMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Match | Attempts to locate structural text, such as bracket pairs, at the specified offset.
Top
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.Match Method

StructureMatcherMatch Method

Attempts to locate structural text, such as bracket pairs, at the specified offset.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IStructureMatchResultSet Match(
    TextSnapshotOffset snapshotOffset,
    IStructureMatchOptions options
)
Public Overridable Function Match (
    snapshotOffset As TextSnapshotOffset,
    options As IStructureMatchOptions
) As IStructureMatchResultSet

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.
options
Type: ActiproSoftware.Text.AnalysisIStructureMatchOptions
The IStructureMatchOptions to use.

Return Value

Type: IStructureMatchResultSet
An IStructureMatchResultSet that contains the results that were found, if any.

Implements

IStructureMatcherMatch(TextSnapshotOffset, IStructureMatchOptions)
Remarks
When the result set is empty, no structural delimiter was next to the specified offset. When the result set contains a single result, a structural delimiter such as a bracket was found next to the specified offset, but no matching structural delimiter was found. The result set may contain multiple entries in cases such as when a language wishes to flag #if...#else...#endif blocks as a structure.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchOptions Class

Represents options for a structure match operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationStructureMatchOptions

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StructureMatchOptions : IStructureMatchOptions
Public Class StructureMatchOptions
    Implements IStructureMatchOptions

The StructureMatchOptions type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatchOptions | Initializes a new instance of the StructureMatchOptions class
Top
Properties
 | Name | Description
Public property | IsNavigationRequest | Gets or sets whether the structure match is being performed for a navigation request.
Top
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchOptions Constructor

Initializes a new instance of the StructureMatchOptions class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StructureMatchOptions()
Public Sub New
See Also

Reference

StructureMatchOptions Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchOptions Properties

The StructureMatchOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsNavigationRequest | Gets or sets whether the structure match is being performed for a navigation request.
Top
See Also

Reference

StructureMatchOptions Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchOptions.IsNavigationRequest Property

StructureMatchOptionsIsNavigationRequest Property

Gets or sets whether the structure match is being performed for a navigation request.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNavigationRequest { get; set; }
Public Property IsNavigationRequest As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the structure match is being performed for a navigation request; otherwise, false.

Implements

IStructureMatchOptionsIsNavigationRequest
Remarks
When the operating is being performed for a navigation request, the match algorithm may want to be more liberal with its match algorithm.
See Also

Reference

StructureMatchOptions Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult Class

Stores a single result of a structure match operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationStructureMatchResult

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StructureMatchResult : ITextRangeProvider,
    IStructureMatchResult
Public Class StructureMatchResult
    Implements ITextRangeProvider, IStructureMatchResult

The StructureMatchResult type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatchResult | Initializes a new instance of the StructureMatchResult class.
Top
Properties
 | Name | Description
Public property | IsSource | Gets or sets whether this result is the match that occurred from the source offset.
Public property | MatchEdges | Gets or sets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Public property | NavigationSnapshotOffset | Gets or sets the TextSnapshotOffset to navigate for the match, if one is available.
Public property | SnapshotRange | Gets or sets a TextSnapshotRange indicating the offset range of the match.
Top
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult Constructor

Initializes a new instance of the StructureMatchResult class.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StructureMatchResult(
    TextSnapshotRange snapshotRange
)
Public Sub New (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange indicating the offset range of the match.
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult Properties

The StructureMatchResult type exposes the following members.

Properties
 | Name | Description
Public property | IsSource | Gets or sets whether this result is the match that occurred from the source offset.
Public property | MatchEdges | Gets or sets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Public property | NavigationSnapshotOffset | Gets or sets the TextSnapshotOffset to navigate for the match, if one is available.
Public property | SnapshotRange | Gets or sets a TextSnapshotRange indicating the offset range of the match.
Top
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult.IsSource Property

StructureMatchResultIsSource Property

Gets or sets whether this result is the match that occurred from the source offset.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSource { get; set; }
Public Property IsSource As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the result is the match that occurred from the source offset; otherwise, false.

Implements

IStructureMatchResultIsSource
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult.MatchEdges Property

StructureMatchResultMatchEdges Property

Gets or sets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StructureMatchEdges MatchEdges { get; set; }
Public Property MatchEdges As StructureMatchEdges
    Get
    Set

Property Value

Type: StructureMatchEdges
A StructureMatchEdges that specifies the valid edges.

Implements

IStructureMatchResultMatchEdges
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult.NavigationSnapshotOffset Property

StructureMatchResultNavigationSnapshotOffset Property

Gets or sets the TextSnapshotOffset to navigate for the match, if one is available.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<TextSnapshotOffset> NavigationSnapshotOffset { get; set; }
Public Property NavigationSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get
    Set

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset to navigate for the match, if one is available.

Implements

IStructureMatchResultNavigationSnapshotOffset
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult.SnapshotRange Property

StructureMatchResultSnapshotRange Property

Gets or sets a TextSnapshotRange indicating the offset range of the match.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange SnapshotRange { get; set; }
Public Property SnapshotRange As TextSnapshotRange
    Get
    Set

Property Value

Type: TextSnapshotRange
A TextSnapshotRange indicating the offset range of the match.

Implements

IStructureMatchResultSnapshotRange
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Class

Represents a collection of an IStructureMatchResult objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IStructureMatchResult
ActiproSoftware.Text.UtilitySimpleObservableCollection IStructureMatchResult
ActiproSoftware.Text.Analysis.ImplementationStructureMatchResultCollection

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StructureMatchResultCollection : SimpleObservableCollection<IStructureMatchResult>,
    IEnumerable, IList<IStructureMatchResult>, ICollection<IStructureMatchResult>,
    IEnumerable<IStructureMatchResult>, IStructureMatchResultCollection
Public Class StructureMatchResultCollection
    Inherits SimpleObservableCollection(Of IStructureMatchResult)
    Implements IEnumerable, IList(Of IStructureMatchResult),
    ICollection(Of IStructureMatchResult), IEnumerable(Of IStructureMatchResult), IStructureMatchResultCollection

The StructureMatchResultCollection type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatchResultCollection | Initializes a new instance of the StructureMatchResultCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IStructureMatchResult .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Overrides SimpleObservableCollectionTIsReadOnly.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection IStructureMatchResult .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IStructureMatchResult .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IStructureMatchResult .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IStructureMatchResult .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IStructureMatchResult .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IStructureMatchResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IStructureMatchResult .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IStructureMatchResult .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IStructureMatchResult .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IStructureMatchResult .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IStructureMatchResult .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIStructureMatchResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIStructureMatchResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIStructureMatchResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Constructor

Initializes a new instance of the StructureMatchResultCollection class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StructureMatchResultCollection()
Public Sub New
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Properties

The StructureMatchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IStructureMatchResult .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Overrides SimpleObservableCollectionTIsReadOnly.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection IStructureMatchResult .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IStructureMatchResult .)
Top
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection.IsReadOnly Property

StructureMatchResultCollectionIsReadOnly Property

Gets whether the collection is allowed to be modified.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the collection is allowed to be modified; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Methods

The StructureMatchResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IStructureMatchResult .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IStructureMatchResult .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IStructureMatchResult .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IStructureMatchResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IStructureMatchResult .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IStructureMatchResult .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IStructureMatchResult .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IStructureMatchResult .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IStructureMatchResult .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIStructureMatchResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIStructureMatchResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIStructureMatchResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Events

The StructureMatchResultCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultSet Class

Stores the results of a structure match operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationStructureMatchResultSet

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StructureMatchResultSet : IStructureMatchResultSet
Public Class StructureMatchResultSet
    Implements IStructureMatchResultSet

The StructureMatchResultSet type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatchResultSet | Initializes a new instance of the StructureMatchResultSet class.
Top
Properties
 | Name | Description
Public property | Results | Gets the collection of IStructureMatchResult objects.
Top
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultSet Constructor

Initializes a new instance of the StructureMatchResultSet class.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StructureMatchResultSet(
    IStructureMatchResultCollection results
)
Public Sub New (
    results As IStructureMatchResultCollection
)

Parameters

results
Type: ActiproSoftware.Text.AnalysisIStructureMatchResultCollection
The collection of IStructureMatchResult objects.
See Also

Reference

StructureMatchResultSet Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultSet Properties

The StructureMatchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of IStructureMatchResult objects.
Top
See Also

Reference

StructureMatchResultSet Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultSet.Results Property

StructureMatchResultSetResults Property

Gets the collection of IStructureMatchResult objects.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IStructureMatchResultCollection Results { get; }
Public ReadOnly Property Results As IStructureMatchResultCollection
    Get

Property Value

Type: IStructureMatchResultCollection
The collection of IStructureMatchResult objects.

Implements

IStructureMatchResultSetResults
See Also

Reference

StructureMatchResultSet Class
ActiproSoftware.Text.Analysis.Implementation Namespace


ActiproSoftware.Text.Exporters Namespace

Contains types related to the export of text to other markup formats..
Classes
 | Class | Description
Public class | TextExporterFactory | Provides access to the built-in ITextExporter instances, that export text to other formats such as HTML or RTF markup.
Interfaces
 | Interface | Description
Public interface | IHtmlTextExporter | Provides the base requirements for a class that can export text to HTML markup.
Public interface | IRtfTextExporter | Provides the base requirements for a class that can export text to RTF markup.
Public interface | ITextExporter | Provides the base requirements for a class that can export text to some other format, such as HTML or RTF markup.


IHtmlTextExporter Interface

Provides the base requirements for a class that can export text to HTML markup.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IHtmlTextExporter : ITextExporter
Public Interface IHtmlTextExporter
    Inherits ITextExporter

The IHtmlTextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates. (Inherited from ITextExporter.)
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use. (Inherited from ITextExporter.)
Public property | Title | Gets or sets the title for the exported HTML.
Top
Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format. (Inherited from ITextExporter.)
Top
See Also

Reference

ActiproSoftware.Text.Exporters Namespace


IHtmlTextExporter Properties

The IHtmlTextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates. (Inherited from ITextExporter.)
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use. (Inherited from ITextExporter.)
Public property | Title | Gets or sets the title for the exported HTML.
Top
See Also

Reference

IHtmlTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IHtmlTextExporter.Title Property

IHtmlTextExporterTitle Property

Gets or sets the title for the exported HTML.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Title { get; set; }
Property Title As String
    Get
    Set

Property Value

Type: String
The title for the exported HTML.
See Also

Reference

IHtmlTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IHtmlTextExporter Methods

The IHtmlTextExporter type exposes the following members.

Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format. (Inherited from ITextExporter.)
Top
See Also

Reference

IHtmlTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter Interface

Provides the base requirements for a class that can export text to RTF markup.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IRtfTextExporter : ITextExporter
Public Interface IRtfTextExporter
    Inherits ITextExporter

The IRtfTextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates. (Inherited from ITextExporter.)
Public property | FontFamily | Gets or sets the font family name to use for the RTF.
Public property | FontSizeInPoints | Gets or sets the font size in points to use for the RTF.
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use. (Inherited from ITextExporter.)
Top
Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format. (Inherited from ITextExporter.)
Top
See Also

Reference

ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter Properties

The IRtfTextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates. (Inherited from ITextExporter.)
Public property | FontFamily | Gets or sets the font family name to use for the RTF.
Public property | FontSizeInPoints | Gets or sets the font size in points to use for the RTF.
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use. (Inherited from ITextExporter.)
Top
See Also

Reference

IRtfTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter.FontFamily Property

IRtfTextExporterFontFamily Property

Gets or sets the font family name to use for the RTF.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FontFamily { get; set; }
Property FontFamily As String
    Get
    Set

Property Value

Type: String
The font family name to use for the RTF.
See Also

Reference

IRtfTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter.FontSizeInPoints Property

IRtfTextExporterFontSizeInPoints Property

Gets or sets the font size in points to use for the RTF.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double FontSizeInPoints { get; set; }
Property FontSizeInPoints As Double
    Get
    Set

Property Value

Type: Double
The font size in points to use for the RTF.
See Also

Reference

IRtfTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter Methods

The IRtfTextExporter type exposes the following members.

Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format. (Inherited from ITextExporter.)
Top
See Also

Reference

IRtfTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter Interface

Provides the base requirements for a class that can export text to some other format, such as HTML or RTF markup.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextExporter
Public Interface ITextExporter

The ITextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates.
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use.
Top
Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format.
Top
See Also

Reference

ActiproSoftware.Text.Exporters Namespace


ITextExporter Properties

The ITextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates.
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use.
Top
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter.DataFormat Property

ITextExporterDataFormat Property

Gets a string that describes the data format this exporter creates.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string DataFormat { get; }
ReadOnly Property DataFormat As String
    Get

Property Value

Type: String
A string that describes the data format this exporter creates.
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter.LineTerminator Property

ITextExporterLineTerminator Property

Gets or sets the LineTerminator specifying the type of line terminators to use.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
LineTerminator LineTerminator { get; set; }
Property LineTerminator As LineTerminator
    Get
    Set

Property Value

Type: LineTerminator
The LineTerminator specifying the type of line terminators to use.
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter Methods

The ITextExporter type exposes the following members.

Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format.
Top
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter.Export Method

ITextExporterExport Method

Exports the specified ITextSnapshot ranges to another text format.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Export(
    ITextSnapshot snapshot,
    ICollection<TextRange> textRanges
)
Function Export (
    snapshot As ITextSnapshot,
    textRanges As ICollection(Of TextRange)
) As String

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which to export.
textRanges
Type: System.Collections.GenericICollection TextRange
The collection of text ranges in the snapshot for which to export.

Return Value

Type: String
The string that was created to represent the text ranges.
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Class

Provides access to the built-in ITextExporter instances, that export text to other formats such as HTML or RTF markup.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ExportersTextExporterFactory

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TextExporterFactory
Public Class TextExporterFactory

The TextExporterFactory type exposes the following members.

Constructors
 | Name | Description
Public method | TextExporterFactory | Initializes a new instance of the TextExporterFactory class.
Public method | TextExporterFactory(IHighlightingStyleRegistry) | Initializes a new instance of the TextExporterFactory class.
Top
Methods
 | Name | Description
Public method | CreateHtmlClassBased | Returns an IHtmlTextExporter that can export text to HTML, using CSS classes for syntax highlighting.
Public method | CreateHtmlClipboard | Returns an IHtmlTextExporter that can export text to HTML, in a format that is compatible with the Windows clipboard HTML data format.
Public method | CreateHtmlInline | Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting.
Public method | CreateHtmlInlineFragment | Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting and no root HTML or BODY tags.
Public method | CreateRtf | Returns an IRtfTextExporter that can export text to RTF.
Top
See Also

Reference

ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Constructor

Overload List
 | Name | Description
Public method | TextExporterFactory | Initializes a new instance of the TextExporterFactory class.
Public method | TextExporterFactory(IHighlightingStyleRegistry) | Initializes a new instance of the TextExporterFactory class.
Top
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Constructor

Initializes a new instance of the TextExporterFactory class.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextExporterFactory()
Public Sub New
See Also

Reference

TextExporterFactory Class
TextExporterFactory Overload
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Constructor (IHighlightingStyleRegistry)

Initializes a new instance of the TextExporterFactory class.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextExporterFactory(
    IHighlightingStyleRegistry registry
)
Public Sub New (
    registry As IHighlightingStyleRegistry
)

Parameters

registry
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The custom IHighlightingStyleRegistry that should be used.
See Also

Reference

TextExporterFactory Class
TextExporterFactory Overload
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Methods

The TextExporterFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateHtmlClassBased | Returns an IHtmlTextExporter that can export text to HTML, using CSS classes for syntax highlighting.
Public method | CreateHtmlClipboard | Returns an IHtmlTextExporter that can export text to HTML, in a format that is compatible with the Windows clipboard HTML data format.
Public method | CreateHtmlInline | Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting.
Public method | CreateHtmlInlineFragment | Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting and no root HTML or BODY tags.
Public method | CreateRtf | Returns an IRtfTextExporter that can export text to RTF.
Top
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateHtmlClassBased Method

TextExporterFactoryCreateHtmlClassBased Method

Returns an IHtmlTextExporter that can export text to HTML, using CSS classes for syntax highlighting.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHtmlTextExporter CreateHtmlClassBased()
Public Function CreateHtmlClassBased As IHtmlTextExporter

Return Value

Type: IHtmlTextExporter
An IHtmlTextExporter that can export text to HTML.
Remarks
CSS class references will be used for highlighting. This type adds a STYLE tag block to the exported HTML where CSS classes are defined. The text in the code block references these CSS classes, therefore allowing color settings to easily be altered for each highlighting style (i.e. keywords, comments, etc.). Root HTML, BODY and other tags will be added to the output.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateHtmlClipboard Method

TextExporterFactoryCreateHtmlClipboard Method

Returns an IHtmlTextExporter that can export text to HTML, in a format that is compatible with the Windows clipboard HTML data format.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHtmlTextExporter CreateHtmlClipboard()
Public Function CreateHtmlClipboard As IHtmlTextExporter

Return Value

Type: IHtmlTextExporter
An IHtmlTextExporter that can export text to HTML.
Remarks
The output of this exporter is the same as CreateHtmlInlineFragment, except that some additional information is added to make the exported text compatible with the Windows clipboard HTML data format.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateHtmlInline Method

TextExporterFactoryCreateHtmlInline Method

Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHtmlTextExporter CreateHtmlInline()
Public Function CreateHtmlInline As IHtmlTextExporter

Return Value

Type: IHtmlTextExporter
An IHtmlTextExporter that can export text to HTML.
Remarks
Inline CSS styles will be used for highlighting. This type allows for the code block to be directly copied out of the exported document and pasted into another. Root HTML, BODY and other tags will be added to the output.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateHtmlInlineFragment Method

TextExporterFactoryCreateHtmlInlineFragment Method

Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting and no root HTML or BODY tags.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHtmlTextExporter CreateHtmlInlineFragment()
Public Function CreateHtmlInlineFragment As IHtmlTextExporter

Return Value

Type: IHtmlTextExporter
An IHtmlTextExporter that can export text to HTML.
Remarks
Inline CSS styles will be used for highlighting. This type allows for the code block to be directly copied out of the exported document and pasted into another. Root HTML, BODY and other tags will not be added to the output.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateRtf Method

TextExporterFactoryCreateRtf Method

Returns an IRtfTextExporter that can export text to RTF.

Namespace: ActiproSoftware.Text.Exporters
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IRtfTextExporter CreateRtf()
Public Function CreateRtf As IRtfTextExporter

Return Value

Type: IRtfTextExporter
An IRtfTextExporter that can export text to RTF.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


ActiproSoftware.Text.Implementation Namespace

Contains implementation types related to text.
Classes
 | Class | Description
Public class | ClassificationType | Represents the default implementation of a class that represents a classification type.
Public class | CodeDocument | Represents a text document with some advanced features that relate to syntax highlighting and code parsing.
Public class | DefaultWordBreakFinder | Provides the default implementation of an object that finds word breaks within an ITextSnapshot.
Public class | EditorDocument | Represents a text document that can be used in an editor.
Public class | ExampleTextProvider | Implements an object that returns example text, which can be displayed in an application to show how a language's code snippet is syntax-highlighted.
Public class | LineBasedLineCommenter | Represents an object that can comment and uncomment lines on a per-line basis.
Public class | RangeLineCommenter | Represents an object that can comment and uncomment lines over a particular range.
Public class | StringTextBufferReader | Represents an ITextBufferReader implementation for a String.
Public class | SyntaxLanguage | Implements a syntax-highlighting language definition that can be used to parse an ICodeDocument and provide additional functionality via registered services.
Public class | SyntaxLanguageDefinitionSerializer | Provides a class that can deserialize a SyntaxLanguage from XML.
Public class | TextChangeOptions | Represents options that are applied to an ITextChange.
Public class | TextDocumentBase | Represents a text document.
Public class | TextStatistics | Provides numerous statistics such as line, word, character counts, and readability scores for text.


ClassificationType Class

Represents the default implementation of a class that represents a classification type.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationClassificationType

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ClassificationType : IClassificationType,
    IKeyedObject
Public Class ClassificationType
    Implements IClassificationType, IKeyedObject

The ClassificationType type exposes the following members.

Constructors
 | Name | Description
Public method | ClassificationType(String) | Initializes a new instance of the ClassificationType class.
Public method | ClassificationType(String, String) | Initializes a new instance of the ClassificationType class.
Top
Properties
 | Name | Description
Public property | Description | Gets the description of the classification type, which is displayed in the user interface.
Public property | Key | Gets the string key that uniquely identifies the classification type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


ClassificationType Constructor

Overload List
 | Name | Description
Public method | ClassificationType(String) | Initializes a new instance of the ClassificationType class.
Public method | ClassificationType(String, String) | Initializes a new instance of the ClassificationType class.
Top
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType Constructor (String)

Initializes a new instance of the ClassificationType class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ClassificationType(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
The string key that uniquely identifies the classification type.
See Also

Reference

ClassificationType Class
ClassificationType Overload
ActiproSoftware.Text.Implementation Namespace


ClassificationType Constructor (String, String)

Initializes a new instance of the ClassificationType class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ClassificationType(
    string key,
    string description
)
Public Sub New (
    key As String,
    description As String
)

Parameters

key
Type: SystemString
The string key that uniquely identifies the classification type.
description
Type: SystemString
The description of the classification type.
See Also

Reference

ClassificationType Class
ClassificationType Overload
ActiproSoftware.Text.Implementation Namespace


ClassificationType Properties

The ClassificationType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the classification type, which is displayed in the user interface.
Public property | Key | Gets the string key that uniquely identifies the classification type.
Top
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.Description Property

ClassificationTypeDescription Property

Gets the description of the classification type, which is displayed in the user interface.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the classification type, which is displayed in the user interface.

Implements

IClassificationTypeDescription
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.Key Property

ClassificationTypeKey Property

Gets the string key that uniquely identifies the classification type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The string key that uniquely identifies the classification type.

Implements

IKeyedObjectKey
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType Methods

The ClassificationType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.Equals Method

ClassificationTypeEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.GetHashCode Method

ClassificationTypeGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.ToString Method

ClassificationTypeToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument Class

Represents a text document with some advanced features that relate to syntax highlighting and code parsing.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextDocumentBase
ActiproSoftware.Text.ImplementationCodeDocument
ActiproSoftware.Text.ImplementationEditorDocument

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CodeDocument : TextDocumentBase,
    ICodeDocument, IParseTarget, ITextDocument
Public Class CodeDocument
    Inherits TextDocumentBase
    Implements ICodeDocument, IParseTarget, ITextDocument

The CodeDocument type exposes the following members.

Constructors
 | Name | Description
Public method | CodeDocument | Initializes a new instance of the CodeDocument class.
Top
Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from TextDocumentBase.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from TextDocumentBase.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from TextDocumentBase.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from TextDocumentBase.)
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from TextDocumentBase.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from TextDocumentBase.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded.
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from TextDocumentBase.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from TextDocumentBase.)
Top
Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level.
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | CreateParseRequest | Creates an IParseRequest that will be used by calls to QueueParseRequest.
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges. (Overrides TextDocumentBaseGetReadOnlyRegions(TextRange).)
Public method | GetServicesTService | Returns a list of available services of the specified type.
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from TextDocumentBase.)
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding. (Inherited from TextDocumentBase.)
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding. (Inherited from TextDocumentBase.)
Protected method | NotifyParseComplete | Called when a parsing operation has completed for this document, and passes the original request along with the result.
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed. (Inherited from TextDocumentBase.)
Protected method | OnFileNameChanged | Raises the FileNameChanged event. (Overrides TextDocumentBaseOnFileNameChanged(StringPropertyChangedEventArgs).)
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event. (Inherited from TextDocumentBase.)
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event. (Inherited from TextDocumentBase.)
Protected method | OnLanguageChanged | Raises the LanguageChanged event.
Protected method | OnParseDataChanged | Raises the ParseDataChanged event.
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event. (Inherited from TextDocumentBase.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides TextDocumentBaseOnTextChanged(TextSnapshotChangedEventArgs).)
Protected method | OnTextChanging | Raises the TextChanging event. (Inherited from TextDocumentBase.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher.
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file. (Inherited from TextDocumentBase.)
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from TextDocumentBase.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from TextDocumentBase.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from TextDocumentBase.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from TextDocumentBase.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed.
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed.
Public event | PropertyChanged | Occurs when a property value is changed. (Inherited from TextDocumentBase.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from TextDocumentBase.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from TextDocumentBase.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


CodeDocument Constructor

Initializes a new instance of the CodeDocument class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CodeDocument()
Public Sub New
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument Properties

The CodeDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from TextDocumentBase.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from TextDocumentBase.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from TextDocumentBase.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from TextDocumentBase.)
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from TextDocumentBase.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from TextDocumentBase.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded.
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from TextDocumentBase.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.Language Property

CodeDocumentLanguage Property

Gets or sets the ISyntaxLanguage that is currently loaded.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISyntaxLanguage Language { get; set; }
Public Property Language As ISyntaxLanguage
    Get
    Set

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that is currently loaded.

Implements

ICodeDocumentLanguage
Remarks
The default value is a plain text language.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.LanguageData Property

CodeDocumentLanguageData Property

Gets or sets an object that specifies document-specific data for the Language that is loaded.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object LanguageData { get; set; }
Public Property LanguageData As Object
    Get
    Set

Property Value

Type: Object
An object that specifies document-specific data for the Language that is loaded.

Implements

ICodeDocumentLanguageData
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.ParseData Property

CodeDocumentParseData Property

Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseData ParseData { get; set; }
Public Property ParseData As IParseData
    Get
    Set

Property Value

Type: IParseData
The syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.

Implements

ICodeDocumentParseData
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.Properties Property

CodeDocumentProperties Property

Gets the dictionary containing custom properties for this object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyDictionary Properties { get; }
Public ReadOnly Property Properties As PropertyDictionary
    Get

Property Value

Type: PropertyDictionary
The dictionary containing custom properties for this object.

Implements

ICodeDocumentProperties
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument Methods

The CodeDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level.
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | CreateParseRequest | Creates an IParseRequest that will be used by calls to QueueParseRequest.
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges. (Overrides TextDocumentBaseGetReadOnlyRegions(TextRange).)
Public method | GetServicesTService | Returns a list of available services of the specified type.
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from TextDocumentBase.)
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding. (Inherited from TextDocumentBase.)
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding. (Inherited from TextDocumentBase.)
Protected method | NotifyParseComplete | Called when a parsing operation has completed for this document, and passes the original request along with the result.
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed. (Inherited from TextDocumentBase.)
Protected method | OnFileNameChanged | Raises the FileNameChanged event. (Overrides TextDocumentBaseOnFileNameChanged(StringPropertyChangedEventArgs).)
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event. (Inherited from TextDocumentBase.)
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event. (Inherited from TextDocumentBase.)
Protected method | OnLanguageChanged | Raises the LanguageChanged event.
Protected method | OnParseDataChanged | Raises the ParseDataChanged event.
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event. (Inherited from TextDocumentBase.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides TextDocumentBaseOnTextChanged(TextSnapshotChangedEventArgs).)
Protected method | OnTextChanging | Raises the TextChanging event. (Inherited from TextDocumentBase.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher.
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file. (Inherited from TextDocumentBase.)
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from TextDocumentBase.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Top
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.AddLanguageChangedEventHandler Method

CodeDocumentAddLanguageChangedEventHandler Method

Adds an event handler for the LanguageChanged event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddLanguageChangedEventHandler(
    EventHandler<SyntaxLanguageChangedEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub AddLanguageChangedEventHandler (
    handler As EventHandler(Of SyntaxLanguageChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler SyntaxLanguageChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ICodeDocumentAddLanguageChangedEventHandler(EventHandlerSyntaxLanguageChangedEventArgs, EventHandlerPriority)
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.CreateParseRequest Method

CodeDocumentCreateParseRequest Method

Creates an IParseRequest that will be used by calls to QueueParseRequest.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IParseRequest CreateParseRequest()
Protected Overridable Function CreateParseRequest As IParseRequest

Return Value

Type: IParseRequest
The IParseRequest that was created.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.CreateTagAggregator(T) Method

CodeDocumentCreateTagAggregatorT Method

Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITagAggregator<T> CreateTagAggregator<T>()
where T : ITag

Public Function CreateTagAggregator(Of T As ITag) As ITagAggregator(Of T)

Type Parameters

T
The type of ITag associated with this aggregator.

Return Value

Type: ITagAggregator T
The ITagAggregatorT that was created.

Implements

ICodeDocumentCreateTagAggregatorT
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.GetReadOnlyRegions Method

CodeDocumentGetReadOnlyRegions Method

Returns the collection of read-only region tag snapshot ranges.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerable<TagSnapshotRange<IReadOnlyRegionTag>> GetReadOnlyRegions(
    TextRange textRange
)
Protected Overrides Function GetReadOnlyRegions (
    textRange As TextRange
) As IEnumerable(Of TagSnapshotRange(Of IReadOnlyRegionTag))

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The text range relative to the current snapshot for which to locate read-only regions.

Return Value

Type: IEnumerable TagSnapshotRange IReadOnlyRegionTag
The collection of read-only region tag snapshot ranges.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.GetServices(TService) Method

CodeDocumentGetServicesTService Method

Returns a list of available services of the specified type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<TService> GetServices<TService>()
where TService : class

Public Function GetServices(Of TService As Class) As IList(Of TService)

Type Parameters

TService
The type of service.

Return Value

Type: IList TService
The list of available services of the specified type.

Implements

ICodeDocumentGetServicesTService
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.NotifyParseComplete Method

CodeDocumentNotifyParseComplete Method

Called when a parsing operation has completed for this document, and passes the original request along with the result.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void NotifyParseComplete(
    IParseRequest request,
    IParseData result
)
Protected Overridable Sub NotifyParseComplete (
    request As IParseRequest,
    result As IParseData
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
An IParseRequest that contains information about the parsing operation that was requested.
result
Type: ActiproSoftware.Text.ParsingIParseData
An IParseData that is the result of the parsing operation.
Remarks
The default implementation of this method assigns result to the ParseData property.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.OnFileNameChanged Method

CodeDocumentOnFileNameChanged Method

Raises the FileNameChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnFileNameChanged(
    StringPropertyChangedEventArgs e
)
Protected Overrides Sub OnFileNameChanged (
    e As StringPropertyChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
An StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.OnLanguageChanged Method

CodeDocumentOnLanguageChanged Method

Raises the LanguageChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnLanguageChanged(
    SyntaxLanguageChangedEventArgs e
)
Protected Overridable Sub OnLanguageChanged (
    e As SyntaxLanguageChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.TextSyntaxLanguageChangedEventArgs
An SyntaxLanguageChangedEventArgs that contains the event data.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.OnParseDataChanged Method

CodeDocumentOnParseDataChanged Method

Raises the ParseDataChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnParseDataChanged(
    ParseDataPropertyChangedEventArgs e
)
Protected Overridable Sub OnParseDataChanged (
    e As ParseDataPropertyChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
An ParseDataPropertyChangedEventArgs that contains the event data.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.OnTextChanged Method

CodeDocumentOnTextChanged Method

Raises the TextChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnTextChanged(
    TextSnapshotChangedEventArgs e
)
Protected Overrides Sub OnTextChanged (
    e As TextSnapshotChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.TextTextSnapshotChangedEventArgs
A TextSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.QueueParseRequest Method

CodeDocumentQueueParseRequest Method

Queues up a parse request for the document with the ambient dispatcher.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void QueueParseRequest()
Public Sub QueueParseRequest

Implements

ICodeDocumentQueueParseRequest
Remarks
If AmbientParseRequestDispatcherProvider does not provide a dispatcher, the parsing operation is completed immediately in the calling thread.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.RemoveLanguageChangedEventHandler Method

CodeDocumentRemoveLanguageChangedEventHandler Method

Removes an event handler for the LanguageChanged event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveLanguageChangedEventHandler(
    EventHandler<SyntaxLanguageChangedEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub RemoveLanguageChangedEventHandler (
    handler As EventHandler(Of SyntaxLanguageChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler SyntaxLanguageChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ICodeDocumentRemoveLanguageChangedEventHandler(EventHandlerSyntaxLanguageChangedEventArgs, EventHandlerPriority)
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument Events

The CodeDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from TextDocumentBase.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from TextDocumentBase.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from TextDocumentBase.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed.
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed.
Public event | PropertyChanged | Occurs when a property value is changed. (Inherited from TextDocumentBase.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from TextDocumentBase.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from TextDocumentBase.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.LanguageChanged Event

CodeDocumentLanguageChanged Event

Occurs after the value of the Language property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<SyntaxLanguageChangedEventArgs> LanguageChanged
Public Event LanguageChanged As EventHandler(Of SyntaxLanguageChangedEventArgs)

Value

Type: SystemEventHandler SyntaxLanguageChangedEventArgs

Implements

ICodeDocumentLanguageChanged
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.ParseDataChanged Event

CodeDocumentParseDataChanged Event

Occurs after the value of the ParseData property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<ParseDataPropertyChangedEventArgs> ParseDataChanged
Public Event ParseDataChanged As EventHandler(Of ParseDataPropertyChangedEventArgs)

Value

Type: SystemEventHandler ParseDataPropertyChangedEventArgs

Implements

ICodeDocumentParseDataChanged
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder Class

Provides the default implementation of an object that finds word breaks within an ITextSnapshot.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationDefaultWordBreakFinder

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DefaultWordBreakFinder : IWordBreakFinder
Public Class DefaultWordBreakFinder
    Implements IWordBreakFinder

The DefaultWordBreakFinder type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultWordBreakFinder | Initializes a new instance of the DefaultWordBreakFinder class.
Top
Properties
 | Name | Description
 | DefaultWordContainsAdditionalCharacters | Gets the default CharClass for the WordContainsAdditionalCharacters property.
 | DefaultWordStandaloneCharacters | Gets the default CharClass for the WordStandaloneCharacters property.
Public property | WordContainsAdditionalCharacters | Gets or sets the set of additional characters that can constitute the inside of a word, other than letters and digits.
Public property | WordStandaloneCharacters | Gets or sets the set of characters that are intended to be single character words.
Top
Methods
 | Name | Description
Public method | FindCurrentWordEnd | Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
Public method | FindCurrentWordStart | Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
Public method | FindNextWordStart | Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.
Public method | FindPreviousWordStart | Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IWordBreakFinder interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder Constructor

Initializes a new instance of the DefaultWordBreakFinder class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DefaultWordBreakFinder()
Public Sub New
Remarks
The default constructor initializes all fields to their default values.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder Properties

The DefaultWordBreakFinder type exposes the following members.

Properties
 | Name | Description
 | DefaultWordContainsAdditionalCharacters | Gets the default CharClass for the WordContainsAdditionalCharacters property.
 | DefaultWordStandaloneCharacters | Gets the default CharClass for the WordStandaloneCharacters property.
Public property | WordContainsAdditionalCharacters | Gets or sets the set of additional characters that can constitute the inside of a word, other than letters and digits.
Public property | WordStandaloneCharacters | Gets or sets the set of characters that are intended to be single character words.
Top
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.DefaultWordContainsAdditionalCharacters Property

DefaultWordBreakFinderDefaultWordContainsAdditionalCharacters Property

Gets the default CharClass for the WordContainsAdditionalCharacters property.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass DefaultWordContainsAdditionalCharacters { get; }
Public Shared ReadOnly Property DefaultWordContainsAdditionalCharacters As CharClass
    Get

Property Value

Type: CharClass
The default CharClass for the WordContainsAdditionalCharacters property.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.DefaultWordStandaloneCharacters Property

DefaultWordBreakFinderDefaultWordStandaloneCharacters Property

Gets the default CharClass for the WordStandaloneCharacters property.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass DefaultWordStandaloneCharacters { get; }
Public Shared ReadOnly Property DefaultWordStandaloneCharacters As CharClass
    Get

Property Value

Type: CharClass
The default CharClass for the WordStandaloneCharacters property.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.WordContainsAdditionalCharacters Property

DefaultWordBreakFinderWordContainsAdditionalCharacters Property

Gets or sets the set of additional characters that can constitute the inside of a word, other than letters and digits.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass WordContainsAdditionalCharacters { get; set; }
Public Property WordContainsAdditionalCharacters As CharClass
    Get
    Set

Property Value

Type: CharClass
The set of additional characters that can constitute the inside of a word, other than letters and digits.
Remarks
The default value is the _ character.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.WordStandaloneCharacters Property

DefaultWordBreakFinderWordStandaloneCharacters Property

Gets or sets the set of characters that are intended to be single character words.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass WordStandaloneCharacters { get; set; }
Public Property WordStandaloneCharacters As CharClass
    Get
    Set

Property Value

Type: CharClass
The set of characters that are intended to be single character words.
Remarks
The default value is the set of .,()<>[]{}?!\/:;'" characters.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder Methods

The DefaultWordBreakFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindCurrentWordEnd | Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
Public method | FindCurrentWordStart | Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
Public method | FindNextWordStart | Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.
Public method | FindPreviousWordStart | Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.
Top
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.FindCurrentWordEnd Method

DefaultWordBreakFinderFindCurrentWordEnd Method

Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int FindCurrentWordEnd(
    TextSnapshotOffset snapshotOffset
)
Public Function FindCurrentWordEnd (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word end character that occurs at or after the specified start offset.

Implements

IWordBreakFinderFindCurrentWordEnd(TextSnapshotOffset)
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.FindCurrentWordStart Method

DefaultWordBreakFinderFindCurrentWordStart Method

Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int FindCurrentWordStart(
    TextSnapshotOffset snapshotOffset
)
Public Function FindCurrentWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs at or before the specified start offset.

Implements

IWordBreakFinderFindCurrentWordStart(TextSnapshotOffset)
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.FindNextWordStart Method

DefaultWordBreakFinderFindNextWordStart Method

Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int FindNextWordStart(
    TextSnapshotOffset snapshotOffset
)
Public Function FindNextWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs after the specified start offset.

Implements

IWordBreakFinderFindNextWordStart(TextSnapshotOffset)
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.FindPreviousWordStart Method

DefaultWordBreakFinderFindPreviousWordStart Method

Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int FindPreviousWordStart(
    TextSnapshotOffset snapshotOffset
)
Public Function FindPreviousWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs before the specified start offset.

Implements

IWordBreakFinderFindPreviousWordStart(TextSnapshotOffset)
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument Class

Represents a text document that can be used in an editor.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextDocumentBase
ActiproSoftware.Text.ImplementationCodeDocument
ActiproSoftware.Text.ImplementationEditorDocument

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EditorDocument : CodeDocument,
    ICodeDocument, IParseTarget, ITextDocument, IEditorDocument
Public Class EditorDocument
    Inherits CodeDocument
    Implements ICodeDocument, IParseTarget, ITextDocument, IEditorDocument

The EditorDocument type exposes the following members.

Constructors
 | Name | Description
Public method | EditorDocument | Initializes a new instance of the EditorDocument class.
Top
Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from TextDocumentBase.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from TextDocumentBase.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from TextDocumentBase.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from TextDocumentBase.)
Public property | IndicatorManager | Gets the IIndicatorManager that manages indicators for the document.
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from TextDocumentBase.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from TextDocumentBase.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded. (Inherited from CodeDocument.)
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded. (Inherited from CodeDocument.)
Public property | LineNumberOrigin | Gets or sets the origin line number to use as the base for the first view line.
Public property | OutliningManager | Gets the IOutliningManager that manages outlining nodes for the document.
Public property | OutliningMode | Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation. (Inherited from CodeDocument.)
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from CodeDocument.)
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from TextDocumentBase.)
Public property | Text | Gets or sets the text in the document.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from TextDocumentBase.)
Public property | WhitespaceTrimModes | Gets or sets the modes in which whitespace should be automatically trimmed.
Top
Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level. (Inherited from CodeDocument.)
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | CreateParseRequest | Creates an IParseRequest that will be used by calls to QueueParseRequest. (Inherited from CodeDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document. (Inherited from CodeDocument.)
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges. (Inherited from CodeDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type. (Inherited from CodeDocument.)
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation. (Overrides TextDocumentBaseGetTextReplacementInsertText(ITextChangeOperation).)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from TextDocumentBase.)
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding. (Inherited from TextDocumentBase.)
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding. (Inherited from TextDocumentBase.)
Protected method | NotifyParseComplete | Called when a parsing operation has completed for this document, and passes the original request along with the result. (Inherited from CodeDocument.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed. (Inherited from TextDocumentBase.)
Protected method | OnFileNameChanged | Raises the FileNameChanged event. (Inherited from CodeDocument.)
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event. (Inherited from TextDocumentBase.)
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event. (Inherited from TextDocumentBase.)
Protected method | OnLanguageChanged | Raises the LanguageChanged event. (Inherited from CodeDocument.)
Protected method | OnParseDataChanged | Raises the ParseDataChanged event. (Inherited from CodeDocument.)
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event. (Inherited from TextDocumentBase.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from CodeDocument.)
Protected method | OnTextChanging | Raises the TextChanging event. (Inherited from TextDocumentBase.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher. (Inherited from CodeDocument.)
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level. (Inherited from CodeDocument.)
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file. (Inherited from TextDocumentBase.)
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from TextDocumentBase.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from TextDocumentBase.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from TextDocumentBase.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from TextDocumentBase.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed. (Inherited from CodeDocument.)
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed. (Inherited from CodeDocument.)
Public event | PropertyChanged | Occurs when a property value is changed. (Inherited from TextDocumentBase.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from TextDocumentBase.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from TextDocumentBase.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


EditorDocument Constructor

Initializes a new instance of the EditorDocument class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EditorDocument()
Public Sub New
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument Properties

The EditorDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from TextDocumentBase.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from TextDocumentBase.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from TextDocumentBase.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from TextDocumentBase.)
Public property | IndicatorManager | Gets the IIndicatorManager that manages indicators for the document.
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from TextDocumentBase.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from TextDocumentBase.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded. (Inherited from CodeDocument.)
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded. (Inherited from CodeDocument.)
Public property | LineNumberOrigin | Gets or sets the origin line number to use as the base for the first view line.
Public property | OutliningManager | Gets the IOutliningManager that manages outlining nodes for the document.
Public property | OutliningMode | Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation. (Inherited from CodeDocument.)
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from CodeDocument.)
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from TextDocumentBase.)
Public property | Text | Gets or sets the text in the document.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from TextDocumentBase.)
Public property | WhitespaceTrimModes | Gets or sets the modes in which whitespace should be automatically trimmed.
Top
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.IndicatorManager Property

EditorDocumentIndicatorManager Property

Gets the IIndicatorManager that manages indicators for the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IIndicatorManager IndicatorManager { get; }
Public ReadOnly Property IndicatorManager As IIndicatorManager
    Get

Property Value

Type: IIndicatorManager
The IIndicatorManager that manages indicators for the document.

Implements

IEditorDocumentIndicatorManager
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.LineNumberOrigin Property

EditorDocumentLineNumberOrigin Property

Gets or sets the origin line number to use as the base for the first view line.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int LineNumberOrigin { get; set; }
Public Property LineNumberOrigin As Integer
    Get
    Set

Property Value

Type: Int32
The origin line number to use as the base for the first view line. The default value is 1.

Implements

IEditorDocumentLineNumberOrigin
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.OutliningManager Property

EditorDocumentOutliningManager Property

Gets the IOutliningManager that manages outlining nodes for the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IOutliningManager OutliningManager { get; }
Public ReadOnly Property OutliningManager As IOutliningManager
    Get

Property Value

Type: IOutliningManager
The IOutliningManager that manages outlining nodes for the document. The default value is OutliningMode.Default.

Implements

IEditorDocumentOutliningManager
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.OutliningMode Property

EditorDocumentOutliningMode Property

Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OutliningMode OutliningMode { get; set; }
Public Property OutliningMode As OutliningMode
    Get
    Set

Property Value

Type: OutliningMode
The OutliningMode for the document that determines what type of code outlining (folding) is supported.

Implements

IEditorDocumentOutliningMode
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.Text Property

EditorDocumentText Property

Gets or sets the text in the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text in the document.
Remarks
This property is only intended to be used when deserializing text content from XAML.
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.WhitespaceTrimModes Property

EditorDocumentWhitespaceTrimModes Property

Gets or sets the modes in which whitespace should be automatically trimmed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WhitespaceTrimModes WhitespaceTrimModes { get; set; }
Public Property WhitespaceTrimModes As WhitespaceTrimModes
    Get
    Set

Property Value

Type: WhitespaceTrimModes
A WhitespaceTrimModes indicating the modes in which whitespace should be automatically trimmed. The default value is None.

Implements

IEditorDocumentWhitespaceTrimModes
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument Methods

The EditorDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level. (Inherited from CodeDocument.)
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | CreateParseRequest | Creates an IParseRequest that will be used by calls to QueueParseRequest. (Inherited from CodeDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document. (Inherited from CodeDocument.)
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges. (Inherited from CodeDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type. (Inherited from CodeDocument.)
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation. (Overrides TextDocumentBaseGetTextReplacementInsertText(ITextChangeOperation).)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from TextDocumentBase.)
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding. (Inherited from TextDocumentBase.)
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding. (Inherited from TextDocumentBase.)
Protected method | NotifyParseComplete | Called when a parsing operation has completed for this document, and passes the original request along with the result. (Inherited from CodeDocument.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed. (Inherited from TextDocumentBase.)
Protected method | OnFileNameChanged | Raises the FileNameChanged event. (Inherited from CodeDocument.)
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event. (Inherited from TextDocumentBase.)
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event. (Inherited from TextDocumentBase.)
Protected method | OnLanguageChanged | Raises the LanguageChanged event. (Inherited from CodeDocument.)
Protected method | OnParseDataChanged | Raises the ParseDataChanged event. (Inherited from CodeDocument.)
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event. (Inherited from TextDocumentBase.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from CodeDocument.)
Protected method | OnTextChanging | Raises the TextChanging event. (Inherited from TextDocumentBase.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher. (Inherited from CodeDocument.)
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level. (Inherited from CodeDocument.)
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file. (Inherited from TextDocumentBase.)
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from TextDocumentBase.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Top
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.GetTextReplacementInsertText Method

EditorDocumentGetTextReplacementInsertText Method

Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetTextReplacementInsertText(
    ITextChangeOperation operation
)
Protected Overrides Function GetTextReplacementInsertText (
    operation As ITextChangeOperation
) As String

Parameters

operation
Type: ActiproSoftware.TextITextChangeOperation
The ITextChangeOperation containing default text to insert.

Return Value

Type: String
The text to insert.
Remarks
This method can be overridden to scrub the text to insert, such as remove trailing whitespace, etc.
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument Events

The EditorDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from TextDocumentBase.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from TextDocumentBase.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from TextDocumentBase.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed. (Inherited from CodeDocument.)
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed. (Inherited from CodeDocument.)
Public event | PropertyChanged | Occurs when a property value is changed. (Inherited from TextDocumentBase.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from TextDocumentBase.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from TextDocumentBase.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


ExampleTextProvider Class

Implements an object that returns example text, which can be displayed in an application to show how a language's code snippet is syntax-highlighted.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationExampleTextProvider

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExampleTextProvider : IExampleTextProvider
Public Class ExampleTextProvider
    Implements IExampleTextProvider

The ExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ExampleTextProvider | Initializes a new instance of the ExampleTextProvider class.
Top
Properties
 | Name | Description
Public property | ExampleText | Gets or sets the example text, a code snippet of the related language.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IExampleTextProvider interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


ExampleTextProvider Constructor

Initializes a new instance of the ExampleTextProvider class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExampleTextProvider(
    string exampleText
)
Public Sub New (
    exampleText As String
)

Parameters

exampleText
Type: SystemString
The example text, a code snippet of the related language.
See Also

Reference

ExampleTextProvider Class
ActiproSoftware.Text.Implementation Namespace


ExampleTextProvider Properties

The ExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets or sets the example text, a code snippet of the related language.
Top
See Also

Reference

ExampleTextProvider Class
ActiproSoftware.Text.Implementation Namespace


ExampleTextProvider.ExampleText Property

ExampleTextProviderExampleText Property

Gets or sets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ExampleText { get; set; }
Public Property ExampleText As String
    Get
    Set

Property Value

Type: String
The example text.

Implements

IExampleTextProviderExampleText
See Also

Reference

ExampleTextProvider Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter Class

Represents an object that can comment and uncomment lines on a per-line basis.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationLineBasedLineCommenter

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LineBasedLineCommenter : ILineCommenter
Public Class LineBasedLineCommenter
    Implements ILineCommenter

The LineBasedLineCommenter type exposes the following members.

Constructors
 | Name | Description
Public method | LineBasedLineCommenter | Initializes a new instance of the LineBasedLineCommenter class
Top
Properties
 | Name | Description
Public property | CanCommentEmptyLines | Gets or sets a value indicating whether to comment empty lines, when the target range includes more than one line.
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.
Top
Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified position ranges.
Public method | Uncomment | Uncomments the lines of code in the specified position ranges.
Top
Remarks
The StartDelimiter is required.

The start delimiter is added/removed from each line in the range.

Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ILineCommenter interface type, its features can be used by the language.

See Also

Reference

ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter Constructor

Initializes a new instance of the LineBasedLineCommenter class

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LineBasedLineCommenter()
Public Sub New
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter Properties

The LineBasedLineCommenter type exposes the following members.

Properties
 | Name | Description
Public property | CanCommentEmptyLines | Gets or sets a value indicating whether to comment empty lines, when the target range includes more than one line.
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.
Top
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter.CanCommentEmptyLines Property

LineBasedLineCommenterCanCommentEmptyLines Property

Gets or sets a value indicating whether to comment empty lines, when the target range includes more than one line.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCommentEmptyLines { get; set; }
Public Property CanCommentEmptyLines As Boolean
    Get
    Set

Property Value

Type: Boolean
true if empty lines are to be commented, when the target range includes more than one line; otherwise, false.
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter.StartDelimiter Property

LineBasedLineCommenterStartDelimiter Property

Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string StartDelimiter { get; set; }
Public Property StartDelimiter As String
    Get
    Set

Property Value

Type: String
The start delimiter text that is added or removed during comment/uncomment operations.
Remarks
In C#, the start delimiter would be //.
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter Methods

The LineBasedLineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified position ranges.
Public method | Uncomment | Uncomments the lines of code in the specified position ranges.
Top
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter.Comment Method

LineBasedLineCommenterComment Method

Comments out the lines of code in the specified position ranges.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Comment(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection positionRanges,
    ITextChangeOptions options
)
Public Overridable Sub Comment (
    snapshot As ITextSnapshot,
    positionRanges As ITextPositionRangeCollection,
    options As ITextChangeOptions
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
positionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the position ranges over which to comment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Implements

ILineCommenterComment(ITextSnapshot, ITextPositionRangeCollection, ITextChangeOptions)
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter.Uncomment Method

LineBasedLineCommenterUncomment Method

Uncomments the lines of code in the specified position ranges.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Uncomment(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection positionRanges,
    ITextChangeOptions options
)
Public Overridable Sub Uncomment (
    snapshot As ITextSnapshot,
    positionRanges As ITextPositionRangeCollection,
    options As ITextChangeOptions
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
positionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the position ranges over which to uncomment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Implements

ILineCommenterUncomment(ITextSnapshot, ITextPositionRangeCollection, ITextChangeOptions)
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter Class

Represents an object that can comment and uncomment lines over a particular range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationRangeLineCommenter
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLineCommenter

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RangeLineCommenter : ILineCommenter
Public Class RangeLineCommenter
    Implements ILineCommenter

The RangeLineCommenter type exposes the following members.

Constructors
 | Name | Description
Public method | RangeLineCommenter | Initializes a new instance of the RangeLineCommenter class
Top
Properties
 | Name | Description
Public property | CommentTokenId | Gets or sets the comment token ID.
Public property | EndDelimiter | Gets or sets the end delimiter text that is added or removed during comment/uncomment operations.
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.
Top
Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified position ranges.
Protected method | FindCommentTextRange | Returns the full text range of the comment that surrounds the specified snapshot range, if any.
Public method | Uncomment | Uncomments the lines of code in the specified position ranges.
Top
Remarks
The StartDelimiter and EndDelimiter properties are both required.

The start delimiter is added/removed from the start of the range. The end delimiter is added/removed from the end of the range.

Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ILineCommenter interface type, its features can be used by the language.

See Also

Reference

ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter Constructor

Initializes a new instance of the RangeLineCommenter class

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeLineCommenter()
Public Sub New
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter Properties

The RangeLineCommenter type exposes the following members.

Properties
 | Name | Description
Public property | CommentTokenId | Gets or sets the comment token ID.
Public property | EndDelimiter | Gets or sets the end delimiter text that is added or removed during comment/uncomment operations.
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.
Top
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.CommentTokenId Property

RangeLineCommenterCommentTokenId Property

Gets or sets the comment token ID.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> CommentTokenId { get; set; }
Public Property CommentTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The comment token ID.
Remarks
If a token ID is specified for the comment, it can be used to help locate a surrounding comment when uncommenting.
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.EndDelimiter Property

RangeLineCommenterEndDelimiter Property

Gets or sets the end delimiter text that is added or removed during comment/uncomment operations.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string EndDelimiter { get; set; }
Public Property EndDelimiter As String
    Get
    Set

Property Value

Type: String
The end delimiter text that is added or removed during comment/uncomment operations.
Remarks
For instance, in XML the end delimiter would be -->.
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.StartDelimiter Property

RangeLineCommenterStartDelimiter Property

Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string StartDelimiter { get; set; }
Public Property StartDelimiter As String
    Get
    Set

Property Value

Type: String
The start delimiter text that is added or removed during comment/uncomment operations.
Remarks
For instance, in XML the start delimiter would be <!--.
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter Methods

The RangeLineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified position ranges.
Protected method | FindCommentTextRange | Returns the full text range of the comment that surrounds the specified snapshot range, if any.
Public method | Uncomment | Uncomments the lines of code in the specified position ranges.
Top
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.Comment Method

RangeLineCommenterComment Method

Comments out the lines of code in the specified position ranges.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Comment(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection positionRanges,
    ITextChangeOptions options
)
Public Overridable Sub Comment (
    snapshot As ITextSnapshot,
    positionRanges As ITextPositionRangeCollection,
    options As ITextChangeOptions
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
positionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the position ranges over which to comment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Implements

ILineCommenterComment(ITextSnapshot, ITextPositionRangeCollection, ITextChangeOptions)
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.FindCommentTextRange Method

RangeLineCommenterFindCommentTextRange Method

Returns the full text range of the comment that surrounds the specified snapshot range, if any.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Nullable<TextRange> FindCommentTextRange(
    TextSnapshotRange snapshotRange
)
Protected Overridable Function FindCommentTextRange (
    snapshotRange As TextSnapshotRange
) As Nullable(Of TextRange)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Nullable TextRange
The full text range of the comment that surrounds the specified snapshot range, if any.
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.Uncomment Method

RangeLineCommenterUncomment Method

Uncomments the lines of code in the specified position ranges.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Uncomment(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection positionRanges,
    ITextChangeOptions options
)
Public Overridable Sub Uncomment (
    snapshot As ITextSnapshot,
    positionRanges As ITextPositionRangeCollection,
    options As ITextChangeOptions
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
positionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the position ranges over which to uncomment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Implements

ILineCommenterUncomment(ITextSnapshot, ITextPositionRangeCollection, ITextChangeOptions)
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Class

Represents an ITextBufferReader implementation for a String.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationStringTextBufferReader

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StringTextBufferReader : ITextBufferReader
Public Class StringTextBufferReader
    Implements ITextBufferReader

The StringTextBufferReader type exposes the following members.

Constructors
 | Name | Description
Public method | StringTextBufferReader(String) | Initializes a new instance of the StringTextBufferReader class.
Public method | StringTextBufferReader(String, TextPosition, Int32) | Initializes a new instance of the StringTextBufferReader class.
Top
Properties
 | Name | Description
Public property | HasStackEntries | Gets whether there are entries on the stack.
Public property | IsAtEnd | Gets whether the current Offset is at the end of the text buffer.
Public property | IsAtStart | Gets whether the current Offset is at the start of the text buffer.
Public property | IsWhitespaceOnlyAfterOnLine | Gets whether only whitespace characters appear at and after the Offset on the current line.
Public property | IsWhitespaceOnlyBeforeOnLine | Gets whether only whitespace characters appear before the Offset on the current line.
Public property | Length | Gets the number of characters in the text buffer.
Public property | Offset | Gets or sets the current reader offset in the text buffer.
Public property | OffsetDelta | Gets the amount by which to alter the offset values that are parsed.
Public property | Position | Gets the current reader TextPosition in the text buffer.
Public property | PositionDelta | Gets the amount by which to alter the Position values that are parsed.
Top
Methods
 | Name | Description
Public method | AsTextReader | Returns a TextReader wrapper for this reader.
Public method | GetSubstring | Returns a substring from the text buffer using Newline for line ends.
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Public method | PeekReverse | Reverse peeks at a single character from the text buffer without seeking past it.
Public method | Pop | Pops the top offset from the stack and moves the Offset to that offset.
Public method | PopAll | Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.
Public method | Push | Pushes the Offset onto the stack for later restoration.
Public method | Read | Reads a single character from the text buffer and seeks forward one offset.
Public method | ReadReverse | Reverse reads a single character from the text buffer and seeks backward one offset.
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Constructor

Overload List
 | Name | Description
Public method | StringTextBufferReader(String) | Initializes a new instance of the StringTextBufferReader class.
Public method | StringTextBufferReader(String, TextPosition, Int32) | Initializes a new instance of the StringTextBufferReader class.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Constructor (String)

Initializes a new instance of the StringTextBufferReader class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StringTextBufferReader(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text to store in the text buffer.
See Also

Reference

StringTextBufferReader Class
StringTextBufferReader Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Constructor (String, TextPosition, Int32)

Initializes a new instance of the StringTextBufferReader class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StringTextBufferReader(
    string text,
    TextPosition position,
    int offset
)
Public Sub New (
    text As String,
    position As TextPosition,
    offset As Integer
)

Parameters

text
Type: SystemString
The text to store in the text buffer.
position
Type: ActiproSoftware.TextTextPosition
The initial TextPosition of the reader.
offset
Type: SystemInt32
The initial offset of the reader.
See Also

Reference

StringTextBufferReader Class
StringTextBufferReader Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Properties

The StringTextBufferReader type exposes the following members.

Properties
 | Name | Description
Public property | HasStackEntries | Gets whether there are entries on the stack.
Public property | IsAtEnd | Gets whether the current Offset is at the end of the text buffer.
Public property | IsAtStart | Gets whether the current Offset is at the start of the text buffer.
Public property | IsWhitespaceOnlyAfterOnLine | Gets whether only whitespace characters appear at and after the Offset on the current line.
Public property | IsWhitespaceOnlyBeforeOnLine | Gets whether only whitespace characters appear before the Offset on the current line.
Public property | Length | Gets the number of characters in the text buffer.
Public property | Offset | Gets or sets the current reader offset in the text buffer.
Public property | OffsetDelta | Gets the amount by which to alter the offset values that are parsed.
Public property | Position | Gets the current reader TextPosition in the text buffer.
Public property | PositionDelta | Gets the amount by which to alter the Position values that are parsed.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.HasStackEntries Property

StringTextBufferReaderHasStackEntries Property

Gets whether there are entries on the stack.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStackEntries { get; }
Public ReadOnly Property HasStackEntries As Boolean
    Get

Property Value

Type: Boolean
true if there are entries on the stack; otherwise, false.

Implements

ITextBufferReaderHasStackEntries
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.IsAtEnd Property

StringTextBufferReaderIsAtEnd Property

Gets whether the current Offset is at the end of the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAtEnd { get; }
Public ReadOnly Property IsAtEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the end of the text buffer; otherwise, false.

Implements

ITextBufferReaderIsAtEnd
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.IsAtStart Property

StringTextBufferReaderIsAtStart Property

Gets whether the current Offset is at the start of the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAtStart { get; }
Public ReadOnly Property IsAtStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of the text buffer; otherwise, false.

Implements

ITextBufferReaderIsAtStart
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.IsWhitespaceOnlyAfterOnLine Property

StringTextBufferReaderIsWhitespaceOnlyAfterOnLine Property

Gets whether only whitespace characters appear at and after the Offset on the current line.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsWhitespaceOnlyAfterOnLine { get; }
Public ReadOnly Property IsWhitespaceOnlyAfterOnLine As Boolean
    Get

Property Value

Type: Boolean
true if only whitespace characters appear at and after the Offset on the current line; otherwise, false.

Implements

ITextBufferReaderIsWhitespaceOnlyAfterOnLine
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.IsWhitespaceOnlyBeforeOnLine Property

StringTextBufferReaderIsWhitespaceOnlyBeforeOnLine Property

Gets whether only whitespace characters appear before the Offset on the current line.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsWhitespaceOnlyBeforeOnLine { get; }
Public ReadOnly Property IsWhitespaceOnlyBeforeOnLine As Boolean
    Get

Property Value

Type: Boolean
true if only whitespace characters appear before the Offset on the current line; otherwise, false.

Implements

ITextBufferReaderIsWhitespaceOnlyBeforeOnLine
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Length Property

StringTextBufferReaderLength Property

Gets the number of characters in the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters in the text buffer.

Implements

ITextBufferReaderLength
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Offset Property

StringTextBufferReaderOffset Property

Gets or sets the current reader offset in the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Offset { get; set; }
Public Property Offset As Integer
    Get
    Set

Property Value

Type: Int32
The current reader offset in the text buffer.

Implements

ITextBufferReaderOffset
Remarks
For performance reasons there is no bounds check on the setter.
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.OffsetDelta Property

StringTextBufferReaderOffsetDelta Property

Gets the amount by which to alter the offset values that are parsed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int OffsetDelta { get; }
Public ReadOnly Property OffsetDelta As Integer
    Get

Property Value

Type: Int32
The amount by which to alter the offset values that are parsed.

Implements

ITextBufferReaderOffsetDelta
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Position Property

StringTextBufferReaderPosition Property

Gets the current reader TextPosition in the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition Position { get; }
Public ReadOnly Property Position As TextPosition
    Get

Property Value

Type: TextPosition
The current reader TextPosition in the text buffer.

Implements

ITextBufferReaderPosition
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.PositionDelta Property

StringTextBufferReaderPositionDelta Property

Gets the amount by which to alter the Position values that are parsed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition PositionDelta { get; }
Public ReadOnly Property PositionDelta As TextPosition
    Get

Property Value

Type: TextPosition
The amount by which to alter the Position values that are parsed.

Implements

ITextBufferReaderPositionDelta
Remarks
The Character portion only affects character offset of the line after the Line count.
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Methods

The StringTextBufferReader type exposes the following members.

Methods
 | Name | Description
Public method | AsTextReader | Returns a TextReader wrapper for this reader.
Public method | GetSubstring | Returns a substring from the text buffer using Newline for line ends.
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Public method | PeekReverse | Reverse peeks at a single character from the text buffer without seeking past it.
Public method | Pop | Pops the top offset from the stack and moves the Offset to that offset.
Public method | PopAll | Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.
Public method | Push | Pushes the Offset onto the stack for later restoration.
Public method | Read | Reads a single character from the text buffer and seeks forward one offset.
Public method | ReadReverse | Reverse reads a single character from the text buffer and seeks backward one offset.
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.AsTextReader Method

StringTextBufferReaderAsTextReader Method

Returns a TextReader wrapper for this reader.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextReader AsTextReader()
Public Function AsTextReader As TextReader

Return Value

Type: TextReader
A TextReader wrapper for this reader.

Implements

ITextBufferReaderAsTextReader
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.GetSubstring Method

StringTextBufferReaderGetSubstring Method

Returns a substring from the text buffer using Newline for line ends.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string GetSubstring(
    int startOffset,
    int substringLength
)
Public Function GetSubstring (
    startOffset As Integer,
    substringLength As Integer
) As String

Parameters

startOffset
Type: SystemInt32
The offset at which to retrieve the text.
substringLength
Type: SystemInt32
The number of characters to return.

Return Value

Type: String
The substring from the text buffer using Newline for line ends.

Implements

ITextBufferReaderGetSubstring(Int32, Int32)
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Peek Method

StringTextBufferReaderPeek Method

Overload List
 | Name | Description
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Peek Method

StringTextBufferReaderPeek Method

Peeks at a single character from the text buffer without seeking past it.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char Peek()
Public Function Peek As Char

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderPeek
See Also

Reference

StringTextBufferReader Class
Peek Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Peek Method (Int32)

StringTextBufferReaderPeek Method (Int32)

Peeks at a certain character from the text buffer after the current Offset without seeking past it.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char Peek(
    int count
)
Public Function Peek (
    count As Integer
) As Char

Parameters

count
Type: SystemInt32
The number of characters away from the current Offset at which to peek.

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderPeek(Int32)
See Also

Reference

StringTextBufferReader Class
Peek Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.PeekReverse Method

StringTextBufferReaderPeekReverse Method

Reverse peeks at a single character from the text buffer without seeking past it.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char PeekReverse()
Public Function PeekReverse As Char

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderPeekReverse
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Pop Method

StringTextBufferReaderPop Method

Pops the top offset from the stack and moves the Offset to that offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Pop()
Public Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITextBufferReaderPop
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.PopAll Method

StringTextBufferReaderPopAll Method

Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool PopAll()
Public Function PopAll As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITextBufferReaderPopAll
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Push Method

StringTextBufferReaderPush Method

Pushes the Offset onto the stack for later restoration.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Push()
Public Sub Push

Implements

ITextBufferReaderPush
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Read Method

StringTextBufferReaderRead Method

Reads a single character from the text buffer and seeks forward one offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char Read()
Public Function Read As Char

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderRead
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadReverse Method

StringTextBufferReaderReadReverse Method

Reverse reads a single character from the text buffer and seeks backward one offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char ReadReverse()
Public Function ReadReverse As Char

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderReadReverse
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadReverseThrough Method

StringTextBufferReaderReadReverseThrough Method

Overload List
 | Name | Description
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadReverseThrough Method (Char)

StringTextBufferReaderReadReverseThrough Method (Char)

Reverse reads characters from the text buffer until the specified character is read through.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ReadReverseThrough(
    char ch
)
Public Function ReadReverseThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the start of the text buffer was reached.

Implements

ITextBufferReaderReadReverseThrough(Char)
See Also

Reference

StringTextBufferReader Class
ReadReverseThrough Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadReverseThrough Method (Char, Int32)

StringTextBufferReaderReadReverseThrough Method (Char, Int32)

Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ReadReverseThrough(
    char ch,
    int minOffset
)
Public Function ReadReverseThrough (
    ch As Char,
    minOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
minOffset
Type: SystemInt32
The minimum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.

Implements

ITextBufferReaderReadReverseThrough(Char, Int32)
See Also

Reference

StringTextBufferReader Class
ReadReverseThrough Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadThrough Method

StringTextBufferReaderReadThrough Method

Overload List
 | Name | Description
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadThrough Method (Char)

StringTextBufferReaderReadThrough Method (Char)

Reads characters from the text buffer until the specified character is read through.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ReadThrough(
    char ch
)
Public Function ReadThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the end of the text buffer was reached.

Implements

ITextBufferReaderReadThrough(Char)
See Also

Reference

StringTextBufferReader Class
ReadThrough Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadThrough Method (Char, Int32)

StringTextBufferReaderReadThrough Method (Char, Int32)

Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ReadThrough(
    char ch,
    int maxOffset
)
Public Function ReadThrough (
    ch As Char,
    maxOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
maxOffset
Type: SystemInt32
The maximum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.

Implements

ITextBufferReaderReadThrough(Char, Int32)
See Also

Reference

StringTextBufferReader Class
ReadThrough Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ToString Method

StringTextBufferReaderToString Method

Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Class

Implements a syntax-highlighting language definition that can be used to parse an ICodeDocument and provide additional functionality via registered services.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetSyntaxLanguageBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSyntaxLanguage
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonSyntaxLanguage
ActiproSoftware.Text.Languages.Python.ImplementationPythonSyntaxLanguage
ActiproSoftware.Text.Languages.Xml.ImplementationXmlSyntaxLanguage

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SyntaxLanguage : IKeyedObject,
    ISyntaxLanguage, IServiceLocator
Public Class SyntaxLanguage
    Implements IKeyedObject, ISyntaxLanguage, IServiceLocator

The SyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxLanguage | Initializes a new instance of the SyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language.
 | PlainText | Gets a SyntaxLanguage that implements a default plain text parser.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services.
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Protected method | OnServiceAdded | Raises the ServiceAdded event.
Protected method | OnServiceRemoved | Raises the ServiceRemoved event.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object.
Public event | ServiceRemoved | Occurs after a service is removed from the object.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLexer | Returns the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetParser | Returns the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetProject | Returns the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | GetProjectAssembly | Returns the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextViewLineNumberProvider | Returns the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlValidator | Returns the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | Parse | Parses text using the specified language's IParser service and returns the IParseData result. (Defined by SyntaxLanguageParsingExtensions.)
Public Extension Method | RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLexer | Registers the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterParser | Registers the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterProject | Registers the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextViewLineNumberProvider | Registers the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlValidator | Registers the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterParser | Unregisters the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterProject | Unregisters the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextViewLineNumberProvider | Unregisters the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Constructor

Initializes a new instance of the SyntaxLanguage class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SyntaxLanguage(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the language.
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Properties

The SyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language.
 | PlainText | Gets a SyntaxLanguage that implements a default plain text parser.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.Key Property

SyntaxLanguageKey Property

Gets a string that identifies the language.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; protected set; }
Public Property Key As String
    Get
    Protected Set

Property Value

Type: String
A string that identifies the language.

Implements

IKeyedObjectKey
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.PlainText Property

SyntaxLanguagePlainText Property

Gets a SyntaxLanguage that implements a default plain text parser.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static SyntaxLanguage PlainText { get; }
Public Shared ReadOnly Property PlainText As SyntaxLanguage
    Get

Property Value

Type: SyntaxLanguage
A SyntaxLanguage that implements a default plain text parser.
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.SyncRoot Property

SyntaxLanguageSyncRoot Property

Gets an object that can be used to synchronize access to the services.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object
An object that can be used to synchronize access to the services.

Implements

IServiceLocatorSyncRoot
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Methods

The SyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Protected method | OnServiceAdded | Raises the ServiceAdded event.
Protected method | OnServiceRemoved | Raises the ServiceRemoved event.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLexer | Returns the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetParser | Returns the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetProject | Returns the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | GetProjectAssembly | Returns the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextViewLineNumberProvider | Returns the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlValidator | Returns the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | Parse | Parses text using the specified language's IParser service and returns the IParseData result. (Defined by SyntaxLanguageParsingExtensions.)
Public Extension Method | RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLexer | Registers the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterParser | Registers the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterProject | Registers the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextViewLineNumberProvider | Registers the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlValidator | Registers the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterParser | Unregisters the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterProject | Unregisters the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextViewLineNumberProvider | Unregisters the ITextViewLineNumberProvider that determines the number text to display in a text view's line number margin. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.GetAllServiceTypes Method

SyntaxLanguageGetAllServiceTypes Method

Returns a collection of all the service types that have been registered.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<Object> GetAllServiceTypes()
Public Function GetAllServiceTypes As IEnumerable(Of Object)

Return Value

Type: IEnumerable Object
A collection of all the service types that have been registered.

Implements

IServiceLocatorGetAllServiceTypes
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.GetService Method

SyntaxLanguageGetService Method

Overload List
 | Name | Description
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.GetService(T) Method

SyntaxLanguageGetServiceT Method

Returns the service that has been registered with the specified type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T GetService<T>()

Public Function GetService(Of T) As T

Type Parameters

T
The type of service to return.

Return Value

Type: T
The service that has been registered with the specified type.

Implements

IServiceLocatorGetServiceT
See Also

Reference

SyntaxLanguage Class
GetService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.GetService Method (Object)

SyntaxLanguageGetService Method (Object)

Returns the service that has been registered with the specified type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object GetService(
    Object serviceType
)
Public Function GetService (
    serviceType As Object
) As Object

Parameters

serviceType
Type: SystemObject
The type of service to return.

Return Value

Type: Object
The service that has been registered with the specified type.

Implements

IServiceLocatorGetService(Object)
See Also

Reference

SyntaxLanguage Class
GetService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.OnServiceAdded Method

SyntaxLanguageOnServiceAdded Method

Raises the ServiceAdded event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnServiceAdded(
    CollectionChangeEventArgs<Object> e
)
Protected Overridable Sub OnServiceAdded (
    e As CollectionChangeEventArgs(Of Object)
)

Parameters

e
Type: ActiproSoftware.Text.UtilityCollectionChangeEventArgs Object
A CollectionChangeEventArgs{object} that contains the event data.
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.OnServiceRemoved Method

SyntaxLanguageOnServiceRemoved Method

Raises the ServiceRemoved event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnServiceRemoved(
    CollectionChangeEventArgs<Object> e
)
Protected Overridable Sub OnServiceRemoved (
    e As CollectionChangeEventArgs(Of Object)
)

Parameters

e
Type: ActiproSoftware.Text.UtilityCollectionChangeEventArgs Object
A CollectionChangeEventArgs{object} that contains the event data.
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.RegisterService Method

SyntaxLanguageRegisterService Method

Overload List
 | Name | Description
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.RegisterService(T) Method (T)

SyntaxLanguageRegisterServiceT Method (T)

Registers a service instance for the specified service type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RegisterService<T>(
    T service
)

Public Sub RegisterService(Of T) (
    service As T
)

Parameters

service
Type: T
The service object instance.

Type Parameters

T
The type of service.

Implements

IServiceLocatorRegisterServiceT(T)
See Also

Reference

SyntaxLanguage Class
RegisterService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.RegisterService Method (Object, Object)

SyntaxLanguageRegisterService Method (Object, Object)

Registers a service instance for the specified service type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RegisterService(
    Object serviceType,
    Object service
)
Public Sub RegisterService (
    serviceType As Object,
    service As Object
)

Parameters

serviceType
Type: SystemObject
The type of service.
service
Type: SystemObject
The service object instance.

Implements

IServiceLocatorRegisterService(Object, Object)
See Also

Reference

SyntaxLanguage Class
RegisterService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.UnregisterService Method

SyntaxLanguageUnregisterService Method

Overload List
 | Name | Description
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.UnregisterService(T) Method

SyntaxLanguageUnregisterServiceT Method

Unregisters a service of the specified service type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void UnregisterService<T>()

Public Sub UnregisterService(Of T)

Type Parameters

T
The type of service.

Implements

IServiceLocatorUnregisterServiceT
See Also

Reference

SyntaxLanguage Class
UnregisterService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.UnregisterService Method (Object)

SyntaxLanguageUnregisterService Method (Object)

Unregisters a service of the specified service type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void UnregisterService(
    Object serviceType
)
Public Sub UnregisterService (
    serviceType As Object
)

Parameters

serviceType
Type: SystemObject
The type of service.

Implements

IServiceLocatorUnregisterService(Object)
See Also

Reference

SyntaxLanguage Class
UnregisterService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Events

The SyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object.
Public event | ServiceRemoved | Occurs after a service is removed from the object.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.ServiceAdded Event

SyntaxLanguageServiceAdded Event

Occurs after a service is added to the object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<Object>> ServiceAdded
Public Event ServiceAdded As EventHandler(Of CollectionChangeEventArgs(Of Object))

Value

Type: SystemEventHandler CollectionChangeEventArgs Object

Implements

IServiceLocatorServiceAdded
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.ServiceRemoved Event

SyntaxLanguageServiceRemoved Event

Occurs after a service is removed from the object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<Object>> ServiceRemoved
Public Event ServiceRemoved As EventHandler(Of CollectionChangeEventArgs(Of Object))

Value

Type: SystemEventHandler CollectionChangeEventArgs Object

Implements

IServiceLocatorServiceRemoved
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer Class

Provides a class that can deserialize a SyntaxLanguage from XML.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguageDefinitionSerializer

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SyntaxLanguageDefinitionSerializer
Public Class SyntaxLanguageDefinitionSerializer

The SyntaxLanguageDefinitionSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxLanguageDefinitionSerializer | Initializes a new instance of the SyntaxLanguageDefinitionSerializer class
Top
Properties
 | Name | Description
Public property | HighlightingStyleRegistry | Gets or sets the custom IHighlightingStyleRegistry that should be used.
Top
Methods
 | Name | Description
Public method | InitializeFromFile | Initializes an existing ISyntaxLanguage from a language definition file.
Public method | InitializeFromStream | Initializes an existing ISyntaxLanguage from a language definition Stream.
Public method | LoadFromFile | Loads an ISyntaxLanguage from a language definition file.
Public method | LoadFromStream | Loads an ISyntaxLanguage from a language definition Stream.
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer Constructor

Initializes a new instance of the SyntaxLanguageDefinitionSerializer class

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SyntaxLanguageDefinitionSerializer()
Public Sub New
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer Properties

The SyntaxLanguageDefinitionSerializer type exposes the following members.

Properties
 | Name | Description
Public property | HighlightingStyleRegistry | Gets or sets the custom IHighlightingStyleRegistry that should be used.
Top
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer.HighlightingStyleRegistry Property

SyntaxLanguageDefinitionSerializerHighlightingStyleRegistry Property

Gets or sets the custom IHighlightingStyleRegistry that should be used.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry HighlightingStyleRegistry { get; set; }
Public Property HighlightingStyleRegistry As IHighlightingStyleRegistry
    Get
    Set

Property Value

Type: IHighlightingStyleRegistry
The custom IHighlightingStyleRegistry that should be used.
Remarks
If this property is , the AmbientHighlightingStyleRegistry will be used.
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer Methods

The SyntaxLanguageDefinitionSerializer type exposes the following members.

Methods
 | Name | Description
Public method | InitializeFromFile | Initializes an existing ISyntaxLanguage from a language definition file.
Public method | InitializeFromStream | Initializes an existing ISyntaxLanguage from a language definition Stream.
Public method | LoadFromFile | Loads an ISyntaxLanguage from a language definition file.
Public method | LoadFromStream | Loads an ISyntaxLanguage from a language definition Stream.
Top
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer.InitializeFromFile Method

SyntaxLanguageDefinitionSerializerInitializeFromFile Method

Initializes an existing ISyntaxLanguage from a language definition file.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void InitializeFromFile(
    ISyntaxLanguage language,
    string path
)
Public Sub InitializeFromFile (
    language As ISyntaxLanguage,
    path As String
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The existing ISyntaxLanguage to initialize.
path
Type: SystemString
The full path to the file.
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer.InitializeFromStream Method

SyntaxLanguageDefinitionSerializerInitializeFromStream Method

Initializes an existing ISyntaxLanguage from a language definition Stream.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void InitializeFromStream(
    ISyntaxLanguage language,
    Stream stream
)
Public Sub InitializeFromStream (
    language As ISyntaxLanguage,
    stream As Stream
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The existing ISyntaxLanguage to initialize.
stream
Type: System.IOStream
The Stream from which to load.
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer.LoadFromFile Method

SyntaxLanguageDefinitionSerializerLoadFromFile Method

Loads an ISyntaxLanguage from a language definition file.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISyntaxLanguage LoadFromFile(
    string path
)
Public Function LoadFromFile (
    path As String
) As ISyntaxLanguage

Parameters

path
Type: SystemString
The full path to the file.

Return Value

Type: ISyntaxLanguage
The ISyntaxLanguage that was loaded.
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer.LoadFromStream Method

SyntaxLanguageDefinitionSerializerLoadFromStream Method

Loads an ISyntaxLanguage from a language definition Stream.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISyntaxLanguage LoadFromStream(
    Stream stream
)
Public Function LoadFromStream (
    stream As Stream
) As ISyntaxLanguage

Parameters

stream
Type: System.IOStream
The Stream from which to load.

Return Value

Type: ISyntaxLanguage
The ISyntaxLanguage that was loaded.
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions Class

Represents options that are applied to an ITextChange.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextChangeOptions
ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationEditorViewTextChangeOptions

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TextChangeOptions : ITextChangeOptions
Public Class TextChangeOptions
    Implements ITextChangeOptions

The TextChangeOptions type exposes the following members.

Constructors
 | Name | Description
Public method | TextChangeOptions | Initializes a new instance of the TextChangeOptions class.
Top
Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack.
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified.
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


TextChangeOptions Constructor

Initializes a new instance of the TextChangeOptions class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextChangeOptions()
Public Sub New
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions Properties

The TextChangeOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack.
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified.
Top
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.CanMergeIntoPreviousChange Property

TextChangeOptionsCanMergeIntoPreviousChange Property

Gets or sets whether this text change can merge into the previous text change in the undo stack.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMergeIntoPreviousChange { get; set; }
Public Property CanMergeIntoPreviousChange As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this text change can merge into the previous text change in the undo stack; otherwise, false.

Implements

ITextChangeOptionsCanMergeIntoPreviousChange
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.CheckReadOnly Property

TextChangeOptionsCheckReadOnly Property

Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CheckReadOnly { get; set; }
Public Property CheckReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the read-only state should be checked; otherwise, false.

Implements

ITextChangeOptionsCheckReadOnly
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.CustomData Property

TextChangeOptionsCustomData Property

Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object CustomData { get; set; }
Public Property CustomData As Object
    Get
    Set

Property Value

Type: Object
The custom data.

Implements

ITextChangeOptionsCustomData
Remarks
This custom data is only persisted for the root text change of a set of operations.
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.OffsetDelta Property

TextChangeOptionsOffsetDelta Property

Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextChangeOffsetDelta OffsetDelta { get; set; }
Public Property OffsetDelta As TextChangeOffsetDelta
    Get
    Set

Property Value

Type: TextChangeOffsetDelta
A TextChangeOffsetDelta value indicating how to apply offset deltas, if at all.

Implements

ITextChangeOptionsOffsetDelta
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.RetainSelection Property

TextChangeOptionsRetainSelection Property

Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool RetainSelection { get; set; }
Public Property RetainSelection As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the caret move should be prevented; otherwise, false.

Implements

ITextChangeOptionsRetainSelection
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.Source Property

TextChangeOptionsSource Property

Gets or sets the optional source of the text change, which is most often an editor view if specified.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Source { get; set; }
Public Property Source As Object
    Get
    Set

Property Value

Type: Object
The optional source of the text change, which is most often an editor view if specified.

Implements

ITextChangeOptionsSource
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase Class

Represents a text document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextDocumentBase
ActiproSoftware.Text.ImplementationCodeDocument

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TextDocumentBase : ITextDocument,
    INotifyPropertyChanged
Public MustInherit Class TextDocumentBase
    Implements ITextDocument, INotifyPropertyChanged

The TextDocumentBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TextDocumentBase | Initializes a new instance of the TextDocumentBase class.
Top
Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document.
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document.
Public property | FileName | Gets or sets the name of the file currently loaded in the document.
Public property | IsModified | Gets or sets whether the document has been modified.
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only.
Public property | TabSize | Gets or sets the distance in spaces between tab stops.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document.
Top
Methods
 | Name | Description
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level.
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level.
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges.
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only.
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding.
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding.
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding.
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed.
Protected method | OnFileNameChanged | Raises the FileNameChanged event.
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event.
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event.
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event.
Protected method | OnTextChanged | Raises the TextChanged event.
Protected method | OnTextChanging | Raises the TextChanging event.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level.
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level.
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file.
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding.
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding.
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results.
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed.
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed.
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed.
Public event | PropertyChanged | Occurs when a property value is changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed.
Public event | TextChanged | Occurs after a text change occurs to this document.
Public event | TextChanging | Occurs before a text change occurs to this document.
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


TextDocumentBase Constructor

Initializes a new instance of the TextDocumentBase class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TextDocumentBase()
Protected Sub New
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase Properties

The TextDocumentBase type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document.
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document.
Public property | FileName | Gets or sets the name of the file currently loaded in the document.
Public property | IsModified | Gets or sets whether the document has been modified.
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only.
Public property | TabSize | Gets or sets the distance in spaces between tab stops.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AutoCharacterCasing Property

TextDocumentBaseAutoCharacterCasing Property

Gets or sets how to modify the case of text that is inserted into the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharacterCasing AutoCharacterCasing { get; set; }
Public Property AutoCharacterCasing As CharacterCasing
    Get
    Set

Property Value

Type: CharacterCasing
A CharacterCasing indicating the desired case of inserted text.

Implements

ITextDocumentAutoCharacterCasing
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AutoConvertTabsToSpaces Property

TextDocumentBaseAutoConvertTabsToSpaces Property

Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AutoConvertTabsToSpaces { get; set; }
Public Property AutoConvertTabsToSpaces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs should be converted to spaces when the Tab key is pressed or indenting occurs; otherwise, false. The default value is false.

Implements

ITextDocumentAutoConvertTabsToSpaces
Remarks
The number of spaces inserted is indicated by the TabSize property.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.CurrentSnapshot Property

TextDocumentBaseCurrentSnapshot Property

Gets the ITextSnapshot that contains the current text of the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot CurrentSnapshot { get; }
Public ReadOnly Property CurrentSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the current text of the document.

Implements

ITextDocumentCurrentSnapshot
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.FileName Property

TextDocumentBaseFileName Property

Gets or sets the name of the file currently loaded in the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The name of the file currently loaded in the document.

Implements

ITextDocumentFileName
Remarks
This property is automatically set whenever a LoadFile(String) overload is called that accepts a file path.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.IsModified Property

TextDocumentBaseIsModified Property

Gets or sets whether the document has been modified.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsModified { get; set; }
Public Property IsModified As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document has been modified; otherwise, false.

Implements

ITextDocumentIsModified
Remarks
This flag is reset to false when the ActiproSoftware.Text property is set, or when a SaveFile(String, LineTerminator) overload is used that accepts a path matching the current FileName property value.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.IsReadOnly Property

TextDocumentBaseIsReadOnly Property

Gets or sets whether the entire document is flagged as read-only.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the entire document is flagged as read-only; otherwise, false. The default value is false.

Implements

ITextDocumentIsReadOnly
Remarks
When read-only, the document's contents should not be editable.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.TabSize Property

TextDocumentBaseTabSize Property

Gets or sets the distance in spaces between tab stops.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int TabSize { get; set; }
Public Property TabSize As Integer
    Get
    Set

Property Value

Type: Int32
The distance in spaces between tab stops. The default value is 4 spaces.

Implements

ITextDocumentTabSize
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.UndoHistory Property

TextDocumentBaseUndoHistory Property

Gets an IUndoHistory that provides access to undo and redo functionality for the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IUndoHistory UndoHistory { get; }
Public ReadOnly Property UndoHistory As IUndoHistory
    Get

Property Value

Type: IUndoHistory
An IUndoHistory that provides access to undo and redo functionality for the document.

Implements

ITextDocumentUndoHistory
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase Methods

The TextDocumentBase type exposes the following members.

Methods
 | Name | Description
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level.
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level.
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges.
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only.
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding.
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding.
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding.
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed.
Protected method | OnFileNameChanged | Raises the FileNameChanged event.
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event.
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event.
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event.
Protected method | OnTextChanged | Raises the TextChanged event.
Protected method | OnTextChanging | Raises the TextChanging event.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level.
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level.
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file.
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding.
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding.
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results.
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AddTextChangedEventHandler Method

TextDocumentBaseAddTextChangedEventHandler Method

Adds an event handler for the TextChanged event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddTextChangedEventHandler(
    EventHandler<TextSnapshotChangedEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub AddTextChangedEventHandler (
    handler As EventHandler(Of TextSnapshotChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ITextDocumentAddTextChangedEventHandler(EventHandlerTextSnapshotChangedEventArgs, EventHandlerPriority)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AddTextChangingEventHandler Method

TextDocumentBaseAddTextChangingEventHandler Method

Adds an event handler for the TextChanging event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddTextChangingEventHandler(
    EventHandler<TextSnapshotChangingEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub AddTextChangingEventHandler (
    handler As EventHandler(Of TextSnapshotChangingEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangingEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ITextDocumentAddTextChangingEventHandler(EventHandlerTextSnapshotChangingEventArgs, EventHandlerPriority)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AppendText Method

TextDocumentBaseAppendText Method

Overload List
 | Name | Description
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AppendText Method (ITextChangeType, String)

TextDocumentBaseAppendText Method (ITextChangeType, String)

Appends text to the end of the CurrentSnapshot text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AppendText(
    ITextChangeType type,
    string text
)
Public Function AppendText (
    type As ITextChangeType,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to append to the current contents of the snapshot.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentAppendText(ITextChangeType, String)
Remarks
This method creates an ITextChange for the current snapshot, adds an append operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
AppendText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.AppendText Method (ITextChangeType, String, ITextChangeOptions)

TextDocumentBaseAppendText Method (ITextChangeType, String, ITextChangeOptions)

Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AppendText(
    ITextChangeType type,
    string text,
    ITextChangeOptions options
)
Public Function AppendText (
    type As ITextChangeType,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to append to the current contents of the snapshot.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds an append operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
AppendText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.CreateTextChange Method

TextDocumentBaseCreateTextChange Method

Overload List
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.CreateTextChange Method (ITextChangeType)

TextDocumentBaseCreateTextChange Method (ITextChangeType)

Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextChange CreateTextChange(
    ITextChangeType type
)
Public Function CreateTextChange (
    type As ITextChangeType
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.

Return Value

Type: ITextChange
The ITextChange that was created.

Implements

ITextDocumentCreateTextChange(ITextChangeType)
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

TextDocumentBase Class
CreateTextChange Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.CreateTextChange Method (ITextChangeType, ITextChangeOptions)

TextDocumentBaseCreateTextChange Method (ITextChangeType, ITextChangeOptions)

Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextChange CreateTextChange(
    ITextChangeType type,
    ITextChangeOptions options
)
Public Function CreateTextChange (
    type As ITextChangeType,
    options As ITextChangeOptions
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: ITextChange
The ITextChange that was created.

Implements

ITextDocumentCreateTextChange(ITextChangeType, ITextChangeOptions)
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

TextDocumentBase Class
CreateTextChange Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.DeleteText Method

TextDocumentBaseDeleteText Method

Overload List
 | Name | Description
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.DeleteText Method (ITextChangeType, TextRange)

TextDocumentBaseDeleteText Method (ITextChangeType, TextRange)

Performs a delete text change in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool DeleteText(
    ITextChangeType type,
    TextRange textRange
)
Public Function DeleteText (
    type As ITextChangeType,
    textRange As TextRange
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentDeleteText(ITextChangeType, TextRange)
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
DeleteText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseReplaceText(ITextChangeType, TextRange, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.DeleteText Method (ITextChangeType, TextRange, ITextChangeOptions)

TextDocumentBaseDeleteText Method (ITextChangeType, TextRange, ITextChangeOptions)

Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool DeleteText(
    ITextChangeType type,
    TextRange textRange,
    ITextChangeOptions options
)
Public Function DeleteText (
    type As ITextChangeType,
    textRange As TextRange,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentDeleteText(ITextChangeType, TextRange, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
DeleteText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.DeleteText Method (ITextChangeType, Int32, Int32)

TextDocumentBaseDeleteText Method (ITextChangeType, Int32, Int32)

Performs a delete text change in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool DeleteText(
    ITextChangeType type,
    int offset,
    int length
)
Public Function DeleteText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The starting offset at which to delete.
length
Type: SystemInt32
The number of characters to delete.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
DeleteText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.DeleteText Method (ITextChangeType, Int32, Int32, ITextChangeOptions)

TextDocumentBaseDeleteText Method (ITextChangeType, Int32, Int32, ITextChangeOptions)

Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool DeleteText(
    ITextChangeType type,
    int offset,
    int length,
    ITextChangeOptions options
)
Public Function DeleteText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The starting offset at which to delete.
length
Type: SystemInt32
The number of characters to delete.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
DeleteText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.GetReadOnlyRegions Method

TextDocumentBaseGetReadOnlyRegions Method

Returns the collection of read-only region tag snapshot ranges.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IEnumerable<TagSnapshotRange<IReadOnlyRegionTag>> GetReadOnlyRegions(
    TextRange textRange
)
Protected Overridable Function GetReadOnlyRegions (
    textRange As TextRange
) As IEnumerable(Of TagSnapshotRange(Of IReadOnlyRegionTag))

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The text range relative to the current snapshot for which to locate read-only regions.

Return Value

Type: IEnumerable TagSnapshotRange IReadOnlyRegionTag
The collection of read-only region tag snapshot ranges.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.GetTextReplacementInsertText Method

TextDocumentBaseGetTextReplacementInsertText Method

Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string GetTextReplacementInsertText(
    ITextChangeOperation operation
)
Protected Overridable Function GetTextReplacementInsertText (
    operation As ITextChangeOperation
) As String

Parameters

operation
Type: ActiproSoftware.TextITextChangeOperation
The ITextChangeOperation contanining default text to insert.

Return Value

Type: String
The text to insert.
Remarks
This method can be overridden to scrub the text to insert, such as remove trailing whitespace, etc. By default it returns a , meaning to use the unscrubbed InsertedText value.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.InsertText Method

TextDocumentBaseInsertText Method

Overload List
 | Name | Description
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.InsertText Method (ITextChangeType, Int32, String)

TextDocumentBaseInsertText Method (ITextChangeType, Int32, String)

Performs an insert text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool InsertText(
    ITextChangeType type,
    int offset,
    string text
)
Public Function InsertText (
    type As ITextChangeType,
    offset As Integer,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentInsertText(ITextChangeType, Int32, String)
Remarks
This method creates an ITextChange for the current snapshot, adds an insert operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
InsertText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.InsertText Method (ITextChangeType, Int32, String, ITextChangeOptions)

TextDocumentBaseInsertText Method (ITextChangeType, Int32, String, ITextChangeOptions)

Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool InsertText(
    ITextChangeType type,
    int offset,
    string text,
    ITextChangeOptions options
)
Public Function InsertText (
    type As ITextChangeType,
    offset As Integer,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds an insert operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
InsertText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.IsTextRangeReadOnly Method

TextDocumentBaseIsTextRangeReadOnly Method

Returns whether any character in the specified TextRange is flagged as read-only.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTextRangeReadOnly(
    TextRange textRange
)
Public Function IsTextRangeReadOnly (
    textRange As TextRange
) As Boolean

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if any character in the specified TextRange is flagged as read-only; otherwise, false.

Implements

ITextDocumentIsTextRangeReadOnly(TextRange)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.LoadFile Method

TextDocumentBaseLoadFile Method

Overload List
 | Name | Description
Public method | LoadFile(String) | Loads document text from a file, using the default UTF-8 character encoding.
Public method | LoadFile(Stream, Encoding) | Loads document text from a Stream using the specified encoding.
Public method | LoadFile(String, Encoding) | Loads document text from a file using the specified encoding.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.LoadFile Method (String)

TextDocumentBaseLoadFile Method (String)

Loads document text from a file, using the default UTF-8 character encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LineTerminator LoadFile(
    string path
)
Public Function LoadFile (
    path As String
) As LineTerminator

Parameters

path
Type: SystemString
The full path of the file from which to load.

Return Value

Type: LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.

Implements

ITextDocumentLoadFile(String)
Remarks
This method updates the value of the FileName property.
See Also

Reference

TextDocumentBase Class
LoadFile Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.LoadFile Method (Stream, Encoding)

TextDocumentBaseLoadFile Method (Stream, Encoding)

Loads document text from a Stream using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LineTerminator LoadFile(
    Stream stream,
    Encoding encoding
)
Public Function LoadFile (
    stream As Stream,
    encoding As Encoding
) As LineTerminator

Parameters

stream
Type: System.IOStream
The Stream from which to load.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.

Return Value

Type: LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.

Implements

ITextDocumentLoadFile(Stream, Encoding)
See Also

Reference

TextDocumentBase Class
LoadFile Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.LoadFile Method (String, Encoding)

TextDocumentBaseLoadFile Method (String, Encoding)

Loads document text from a file using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LineTerminator LoadFile(
    string path,
    Encoding encoding
)
Public Function LoadFile (
    path As String,
    encoding As Encoding
) As LineTerminator

Parameters

path
Type: SystemString
The full path of the file from which to load.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.

Return Value

Type: LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.

Implements

ITextDocumentLoadFile(String, Encoding)
Remarks
This method updates the value of the FileName property.
See Also

Reference

TextDocumentBase Class
LoadFile Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.NotifyPropertyChanged Method

TextDocumentBaseNotifyPropertyChanged Method

Notifies that a property's value has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string name
)
Protected Sub NotifyPropertyChanged (
    name As String
)

Parameters

name
Type: SystemString
The name of the property.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnFileNameChanged Method

TextDocumentBaseOnFileNameChanged Method

Raises the FileNameChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnFileNameChanged(
    StringPropertyChangedEventArgs e
)
Protected Overridable Sub OnFileNameChanged (
    e As StringPropertyChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
An StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnIsModifiedChanged Method

TextDocumentBaseOnIsModifiedChanged Method

Raises the IsModifiedChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnIsModifiedChanged(
    EventArgs e
)
Protected Overridable Sub OnIsModifiedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnIsReadOnlyChanged Method

TextDocumentBaseOnIsReadOnlyChanged Method

Raises the IsReadOnlyChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnIsReadOnlyChanged(
    EventArgs e
)
Protected Overridable Sub OnIsReadOnlyChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnTabSizeChanged Method

TextDocumentBaseOnTabSizeChanged Method

Raises the TabSizeChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnTabSizeChanged(
    EventArgs e
)
Protected Overridable Sub OnTabSizeChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnTextChanged Method

TextDocumentBaseOnTextChanged Method

Raises the TextChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnTextChanged(
    TextSnapshotChangedEventArgs e
)
Protected Overridable Sub OnTextChanged (
    e As TextSnapshotChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.TextTextSnapshotChangedEventArgs
A TextSnapshotChangedEventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnTextChanging Method

TextDocumentBaseOnTextChanging Method

Raises the TextChanging event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnTextChanging(
    TextSnapshotChangingEventArgs e
)
Protected Overridable Sub OnTextChanging (
    e As TextSnapshotChangingEventArgs
)

Parameters

e
Type: ActiproSoftware.TextTextSnapshotChangingEventArgs
A TextSnapshotChangingEventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.RemoveTextChangedEventHandler Method

TextDocumentBaseRemoveTextChangedEventHandler Method

Removes an event handler for the TextChanged event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveTextChangedEventHandler(
    EventHandler<TextSnapshotChangedEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub RemoveTextChangedEventHandler (
    handler As EventHandler(Of TextSnapshotChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ITextDocumentRemoveTextChangedEventHandler(EventHandlerTextSnapshotChangedEventArgs, EventHandlerPriority)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.RemoveTextChangingEventHandler Method

TextDocumentBaseRemoveTextChangingEventHandler Method

Removes an event handler for the TextChanging event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveTextChangingEventHandler(
    EventHandler<TextSnapshotChangingEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub RemoveTextChangingEventHandler (
    handler As EventHandler(Of TextSnapshotChangingEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangingEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ITextDocumentRemoveTextChangingEventHandler(EventHandlerTextSnapshotChangingEventArgs, EventHandlerPriority)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceAll Method

TextDocumentBaseReplaceAll Method

Overload List
 | Name | Description
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceAll Method (ISearchOptions)

TextDocumentBaseReplaceAll Method (ISearchOptions)

Performs a replace all operation in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISearchResultSet ReplaceAll(
    ISearchOptions options
)
Public Function ReplaceAll (
    options As ISearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.

Implements

ITextDocumentReplaceAll(ISearchOptions)
See Also

Reference

TextDocumentBase Class
ReplaceAll Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceAll Method (ISearchOptions, TextRange[])

TextDocumentBaseReplaceAll Method (ISearchOptions, TextRange)

Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISearchResultSet ReplaceAll(
    ISearchOptions options,
    params TextRange[] searchTextRanges
)
Public Function ReplaceAll (
    options As ISearchOptions,
    ParamArray searchTextRanges As TextRange()
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRanges
Type: ActiproSoftware.TextTextRange
The TextRange array of offsets to search. If everything should be searched, specify the range 0 to the length of the document's current snapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.

Implements

ITextDocumentReplaceAll(ISearchOptions, TextRange)
See Also

Reference

TextDocumentBase Class
ReplaceAll Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceNext Method

TextDocumentBaseReplaceNext Method

Overload List
 | Name | Description
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceNext Method (ISearchOptions, Int32, Boolean)

TextDocumentBaseReplaceNext Method (ISearchOptions, Int32, Boolean)

Performs a replace next operation in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISearchResultSet ReplaceNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap
)
Public Function ReplaceNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.

Implements

ITextDocumentReplaceNext(ISearchOptions, Int32, Boolean)
See Also

Reference

TextDocumentBase Class
ReplaceNext Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceNext Method (ISearchOptions, Int32, Boolean, TextRange)

TextDocumentBaseReplaceNext Method (ISearchOptions, Int32, Boolean, TextRange)

Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISearchResultSet ReplaceNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Public Function ReplaceNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.

Implements

ITextDocumentReplaceNext(ISearchOptions, Int32, Boolean, TextRange)
See Also

Reference

TextDocumentBase Class
ReplaceNext Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceText Method

TextDocumentBaseReplaceText Method

Overload List
 | Name | Description
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceText Method (ITextChangeType, TextRange, String)

TextDocumentBaseReplaceText Method (ITextChangeType, TextRange, String)

Performs a replace text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ReplaceText(
    ITextChangeType type,
    TextRange textRange,
    string text
)
Public Function ReplaceText (
    type As ITextChangeType,
    textRange As TextRange,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentReplaceText(ITextChangeType, TextRange, String)
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
ReplaceText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseDeleteText(ITextChangeType, TextRange)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.ReplaceText Method (ITextChangeType, TextRange, String, ITextChangeOptions)

TextDocumentBaseReplaceText Method (ITextChangeType, TextRange, String, ITextChangeOptions)

Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ReplaceText(
    ITextChangeType type,
    TextRange textRange,
    string text,
    ITextChangeOptions options
)
Public Function ReplaceText (
    type As ITextChangeType,
    textRange As TextRange,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
ReplaceText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseDeleteText(ITextChangeType, TextRange, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.ReplaceText Method (ITextChangeType, Int32, Int32, String)

TextDocumentBaseReplaceText Method (ITextChangeType, Int32, Int32, String)

Performs a replace text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ReplaceText(
    ITextChangeType type,
    int offset,
    int length,
    string text
)
Public Function ReplaceText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
length
Type: SystemInt32
The number of characters to delete before inserting the text.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
ReplaceText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.ReplaceText Method (ITextChangeType, Int32, Int32, String, ITextChangeOptions)

TextDocumentBaseReplaceText Method (ITextChangeType, Int32, Int32, String, ITextChangeOptions)

Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ReplaceText(
    ITextChangeType type,
    int offset,
    int length,
    string text,
    ITextChangeOptions options
)
Public Function ReplaceText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
length
Type: SystemInt32
The number of characters to delete before inserting the text.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
ReplaceText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.SaveFile Method

TextDocumentBaseSaveFile Method

Overload List
 | Name | Description
Public method | SaveFile(String, LineTerminator) | Saves document text to a UTF-8 encoded file.
Public method | SaveFile(Stream, Encoding, LineTerminator) | Saves document text to a Stream using the specified encoding.
Public method | SaveFile(String, Encoding, LineTerminator) | Saves document text to a file using the specified encoding.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SaveFile Method (String, LineTerminator)

TextDocumentBaseSaveFile Method (String, LineTerminator)

Saves document text to a UTF-8 encoded file.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SaveFile(
    string path,
    LineTerminator lineTerminator
)
Public Sub SaveFile (
    path As String,
    lineTerminator As LineTerminator
)

Parameters

path
Type: SystemString
The full path of the file of which to save.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Implements

ITextDocumentSaveFile(String, LineTerminator)
Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

TextDocumentBase Class
SaveFile Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SaveFile Method (Stream, Encoding, LineTerminator)

TextDocumentBaseSaveFile Method (Stream, Encoding, LineTerminator)

Saves document text to a Stream using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SaveFile(
    Stream stream,
    Encoding encoding,
    LineTerminator lineTerminator
)
Public Sub SaveFile (
    stream As Stream,
    encoding As Encoding,
    lineTerminator As LineTerminator
)

Parameters

stream
Type: System.IOStream
The Stream to write to.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Implements

ITextDocumentSaveFile(Stream, Encoding, LineTerminator)
See Also

Reference

TextDocumentBase Class
SaveFile Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SaveFile Method (String, Encoding, LineTerminator)

TextDocumentBaseSaveFile Method (String, Encoding, LineTerminator)

Saves document text to a file using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SaveFile(
    string path,
    Encoding encoding,
    LineTerminator lineTerminator
)
Public Sub SaveFile (
    path As String,
    encoding As Encoding,
    lineTerminator As LineTerminator
)

Parameters

path
Type: SystemString
The full path of the file of which to save.
encoding
Type: System.TextEncoding
The Encoding to use when saving the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Implements

ITextDocumentSaveFile(String, Encoding, LineTerminator)
Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

TextDocumentBase Class
SaveFile Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SetHeaderAndFooterText Method

TextDocumentBaseSetHeaderAndFooterText Method

Sets the HeaderText and FooterText, and creates a new snapshot with the results.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool SetHeaderAndFooterText(
    string headerText,
    string footerText
)
Public Function SetHeaderAndFooterText (
    headerText As String,
    footerText As String
) As Boolean

Parameters

headerText
Type: SystemString
The new header text value.
footerText
Type: SystemString
The new footer text value.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentSetHeaderAndFooterText(String, String)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SetText Method

TextDocumentBaseSetText Method

Overload List
 | Name | Description
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SetText Method (String)

TextDocumentBaseSetText Method (String)

Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool SetText(
    string text
)
Public Function SetText (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentSetText(String)
Remarks
A programmatic text replacement means that the undo history will be cleared, and any attached editors will reset the caret to offset 0.

This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.

See Also

Reference

TextDocumentBase Class
SetText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseSetText(ITextChangeType, String)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.SetText Method (ITextChangeType, String)

TextDocumentBaseSetText Method (ITextChangeType, String)

Replaces all the text in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool SetText(
    ITextChangeType type,
    string text
)
Public Function SetText (
    type As ITextChangeType,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentSetText(ITextChangeType, String)
Remarks
This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
SetText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String)


TextDocumentBase.SetText Method (ITextChangeType, String, ITextChangeOptions)

TextDocumentBaseSetText Method (ITextChangeType, String, ITextChangeOptions)

Replaces all the text in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool SetText(
    ITextChangeType type,
    string text,
    ITextChangeOptions options
)
Public Function SetText (
    type As ITextChangeType,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
SetText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)


TextDocumentBase Events

The TextDocumentBase type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed.
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed.
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed.
Public event | PropertyChanged | Occurs when a property value is changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed.
Public event | TextChanged | Occurs after a text change occurs to this document.
Public event | TextChanging | Occurs before a text change occurs to this document.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.FileNameChanged Event

TextDocumentBaseFileNameChanged Event

Occurs after the value of the FileName property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<StringPropertyChangedEventArgs> FileNameChanged
Public Event FileNameChanged As EventHandler(Of StringPropertyChangedEventArgs)

Value

Type: SystemEventHandler StringPropertyChangedEventArgs

Implements

ITextDocumentFileNameChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.IsModifiedChanged Event

TextDocumentBaseIsModifiedChanged Event

Occurs after the value of the IsModified property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler IsModifiedChanged
Public Event IsModifiedChanged As EventHandler

Value

Type: SystemEventHandler

Implements

ITextDocumentIsModifiedChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.IsReadOnlyChanged Event

TextDocumentBaseIsReadOnlyChanged Event

Occurs after the value of the IsReadOnly property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler IsReadOnlyChanged
Public Event IsReadOnlyChanged As EventHandler

Value

Type: SystemEventHandler

Implements

ITextDocumentIsReadOnlyChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.PropertyChanged Event

TextDocumentBasePropertyChanged Event

Occurs when a property value is changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.TabSizeChanged Event

TextDocumentBaseTabSizeChanged Event

Occurs after the value of the TabSize property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler TabSizeChanged
Public Event TabSizeChanged As EventHandler

Value

Type: SystemEventHandler

Implements

ITextDocumentTabSizeChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.TextChanged Event

TextDocumentBaseTextChanged Event

Occurs after a text change occurs to this document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TextSnapshotChangedEventArgs> TextChanged
Public Event TextChanged As EventHandler(Of TextSnapshotChangedEventArgs)

Value

Type: SystemEventHandler TextSnapshotChangedEventArgs

Implements

ITextDocumentTextChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.TextChanging Event

TextDocumentBaseTextChanging Event

Occurs before a text change occurs to this document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TextSnapshotChangingEventArgs> TextChanging
Public Event TextChanging As EventHandler(Of TextSnapshotChangingEventArgs)

Value

Type: SystemEventHandler TextSnapshotChangingEventArgs

Implements

ITextDocumentTextChanging
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics Class

Provides numerous statistics such as line, word, character counts, and readability scores for text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextStatistics

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TextStatistics : ITextStatistics
Public Class TextStatistics
    Implements ITextStatistics

The TextStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | TextStatistics | Initializes a new instance of the TextStatistics class.
Top
Properties
 | Name | Description
Public property | AverageLettersPerWord | Gets the average number of letters per word.
Public property | AverageSyllablesPerWord | Gets the average number of syllables per word.
Public property | AverageWordsPerSentence | Gets the average number of words per sentence.
Public property | Characters | Gets the number of characters in the text.
Public property | Consonants | Gets the number of consonants in the text.
Public property | FleschKincaidGradeLevel | Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.
Public property | FleschReadingEaseScore | Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.
Public property | Letters | Gets the number of letters in the text.
Public property | Lines | Gets the number of lines in the text.
Public property | NonWhitespaceCharacters | Gets the number of non-whitespace characters in the text.
Public property | NonWhitespaceLines | Gets the number of non-whitespace lines in the text.
Public property | Sentences | Gets the number of sentences in the text.
Public property | Syllables | Gets the number of syllables in the text.
Public property | Vowels | Gets the number of vowels in the text.
Public property | WhitespaceCharacters | Gets the number of whitespace characters in the text.
Public property | WhitespaceLines | Gets the number of whitespace lines in the text.
Public property | Words | Gets the number of words in the text.
Top
Methods
 | Name | Description
 | CreateStatistic | Creates an ITextStatistic with the specified key and value.
Public method | GetRawStatistics | Returns the list of ITextStatistic objects that contain the statistic results.
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


TextStatistics Constructor

Initializes a new instance of the TextStatistics class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextStatistics(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text to examine and create statistics data.
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics Properties

The TextStatistics type exposes the following members.

Properties
 | Name | Description
Public property | AverageLettersPerWord | Gets the average number of letters per word.
Public property | AverageSyllablesPerWord | Gets the average number of syllables per word.
Public property | AverageWordsPerSentence | Gets the average number of words per sentence.
Public property | Characters | Gets the number of characters in the text.
Public property | Consonants | Gets the number of consonants in the text.
Public property | FleschKincaidGradeLevel | Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.
Public property | FleschReadingEaseScore | Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.
Public property | Letters | Gets the number of letters in the text.
Public property | Lines | Gets the number of lines in the text.
Public property | NonWhitespaceCharacters | Gets the number of non-whitespace characters in the text.
Public property | NonWhitespaceLines | Gets the number of non-whitespace lines in the text.
Public property | Sentences | Gets the number of sentences in the text.
Public property | Syllables | Gets the number of syllables in the text.
Public property | Vowels | Gets the number of vowels in the text.
Public property | WhitespaceCharacters | Gets the number of whitespace characters in the text.
Public property | WhitespaceLines | Gets the number of whitespace lines in the text.
Public property | Words | Gets the number of words in the text.
Top
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.AverageLettersPerWord Property

TextStatisticsAverageLettersPerWord Property

Gets the average number of letters per word.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AverageLettersPerWord { get; }
Public ReadOnly Property AverageLettersPerWord As Double
    Get

Property Value

Type: Double
The average number of letters per word.

Implements

ITextStatisticsAverageLettersPerWord
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.AverageSyllablesPerWord Property

TextStatisticsAverageSyllablesPerWord Property

Gets the average number of syllables per word.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AverageSyllablesPerWord { get; }
Public ReadOnly Property AverageSyllablesPerWord As Double
    Get

Property Value

Type: Double
The average number of syllables per word.

Implements

ITextStatisticsAverageSyllablesPerWord
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.AverageWordsPerSentence Property

TextStatisticsAverageWordsPerSentence Property

Gets the average number of words per sentence.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AverageWordsPerSentence { get; }
Public ReadOnly Property AverageWordsPerSentence As Double
    Get

Property Value

Type: Double
The average number of words per sentence.

Implements

ITextStatisticsAverageWordsPerSentence
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Characters Property

TextStatisticsCharacters Property

Gets the number of characters in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Characters { get; }
Public ReadOnly Property Characters As Integer
    Get

Property Value

Type: Int32
The number of characters in the text.

Implements

ITextStatisticsCharacters
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Consonants Property

TextStatisticsConsonants Property

Gets the number of consonants in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Consonants { get; }
Public ReadOnly Property Consonants As Integer
    Get

Property Value

Type: Int32
The number of consonants in the text.

Implements

ITextStatisticsConsonants
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.FleschKincaidGradeLevel Property

TextStatisticsFleschKincaidGradeLevel Property

Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double FleschKincaidGradeLevel { get; }
Public ReadOnly Property FleschKincaidGradeLevel As Double
    Get

Property Value

Type: Double

Implements

ITextStatisticsFleschKincaidGradeLevel
Remarks
A grade level of 7.1 indicates that an individual with about 7 years of education could understand the text.
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.FleschReadingEaseScore Property

TextStatisticsFleschReadingEaseScore Property

Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double FleschReadingEaseScore { get; }
Public ReadOnly Property FleschReadingEaseScore As Double
    Get

Property Value

Type: Double

Implements

ITextStatisticsFleschReadingEaseScore
Remarks
Scores of 90-100 are considered easily understandable by an average 5th grader. Scores of 60-70 are considered easily understandable by 8th and 9th grade students. Scores of 0-30 are best understood by college graduates.
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Letters Property

TextStatisticsLetters Property

Gets the number of letters in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Letters { get; }
Public ReadOnly Property Letters As Integer
    Get

Property Value

Type: Int32
The number of letters in the text.

Implements

ITextStatisticsLetters
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Lines Property

TextStatisticsLines Property

Gets the number of lines in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Lines { get; }
Public ReadOnly Property Lines As Integer
    Get

Property Value

Type: Int32
The number of lines in the text.

Implements

ITextStatisticsLines
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.NonWhitespaceCharacters Property

TextStatisticsNonWhitespaceCharacters Property

Gets the number of non-whitespace characters in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int NonWhitespaceCharacters { get; }
Public ReadOnly Property NonWhitespaceCharacters As Integer
    Get

Property Value

Type: Int32
The number of non-whitespace characters in the text.

Implements

ITextStatisticsNonWhitespaceCharacters
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.NonWhitespaceLines Property

TextStatisticsNonWhitespaceLines Property

Gets the number of non-whitespace lines in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int NonWhitespaceLines { get; }
Public ReadOnly Property NonWhitespaceLines As Integer
    Get

Property Value

Type: Int32
The number of non-whitespace lines in the text.

Implements

ITextStatisticsNonWhitespaceLines
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Sentences Property

TextStatisticsSentences Property

Gets the number of sentences in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Sentences { get; }
Public ReadOnly Property Sentences As Integer
    Get

Property Value

Type: Int32
The number of sentences in the text.

Implements

ITextStatisticsSentences
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Syllables Property

TextStatisticsSyllables Property

Gets the number of syllables in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Syllables { get; }
Public ReadOnly Property Syllables As Integer
    Get

Property Value

Type: Int32
The number of syllables in the text.

Implements

ITextStatisticsSyllables
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Vowels Property

TextStatisticsVowels Property

Gets the number of vowels in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Vowels { get; }
Public ReadOnly Property Vowels As Integer
    Get

Property Value

Type: Int32
The number of vowels in the text.

Implements

ITextStatisticsVowels
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.WhitespaceCharacters Property

TextStatisticsWhitespaceCharacters Property

Gets the number of whitespace characters in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int WhitespaceCharacters { get; }
Public ReadOnly Property WhitespaceCharacters As Integer
    Get

Property Value

Type: Int32
The number of whitespace characters in the text.

Implements

ITextStatisticsWhitespaceCharacters
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.WhitespaceLines Property

TextStatisticsWhitespaceLines Property

Gets the number of whitespace lines in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int WhitespaceLines { get; }
Public ReadOnly Property WhitespaceLines As Integer
    Get

Property Value

Type: Int32
The number of whitespace lines in the text.

Implements

ITextStatisticsWhitespaceLines
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Words Property

TextStatisticsWords Property

Gets the number of words in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Words { get; }
Public ReadOnly Property Words As Integer
    Get

Property Value

Type: Int32
The number of words in the text.

Implements

ITextStatisticsWords
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics Methods

The TextStatistics type exposes the following members.

Methods
 | Name | Description
 | CreateStatistic | Creates an ITextStatistic with the specified key and value.
Public method | GetRawStatistics | Returns the list of ITextStatistic objects that contain the statistic results.
Top
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.CreateStatistic Method

TextStatisticsCreateStatistic Method

Creates an ITextStatistic with the specified key and value.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITextStatistic CreateStatistic(
    string key,
    string description,
    Object value
)
Public Shared Function CreateStatistic (
    key As String,
    description As String,
    value As Object
) As ITextStatistic

Parameters

key
Type: SystemString
The key of the statistic.
description
Type: SystemString
The description of the statistic, generally displayed in the user interface.
value
Type: SystemObject
The value of the statistic.

Return Value

Type: ITextStatistic
The ITextStatistic that was created.
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.GetRawStatistics Method

TextStatisticsGetRawStatistics Method

Returns the list of ITextStatistic objects that contain the statistic results.

Namespace: ActiproSoftware.Text.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IList<ITextStatistic> GetRawStatistics()
Public Overridable Function GetRawStatistics As IList(Of ITextStatistic)

Return Value

Type: IList ITextStatistic
The list of ITextStatistic objects that contain the statistic results.

Implements

ITextStatisticsGetRawStatistics
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


ActiproSoftware.Text.Languages.CSharp Namespace

Contains the classes related to implementing a C# syntax language.
Classes
 | Class | Description
Public class | CSharpContextLocations | Contains common context locations for a C# language.
Interfaces
 | Interface | Description
Public interface | ICSharpGrammarOptions | Contains options for a C# grammar.


CSharpContextLocations Class

Contains common context locations for a C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.CSharpCSharpContextLocations

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class CSharpContextLocations
Public NotInheritable Class CSharpContextLocations

The CSharpContextLocations type exposes the following members.

Properties
Name | Description
Attribute | Gets the IDotNetContextLocation that represents an attribute specification.
Comment | Gets the IDotNetContextLocation that represents a comment specification.
DocumentationComment | Gets the IDotNetContextLocation that represents a documentation comment specification.
ExpressionStart | Gets the IDotNetContextLocation that represents an expression start specification.
ImplicitLocalVariableType | Gets the IDotNetContextLocation that represents an implicit local variable type.
LiteralCharacter | Gets the IDotNetContextLocation that represents a literal character specification.
LiteralString | Gets the IDotNetContextLocation that represents a literal string specification.
LocalVariableType | Gets the IDotNetContextLocation that represents a local variable type name specification.
ObjectCreationExpressionMemberName | Gets the IDotNetContextLocation that represents a member name target within an object creation expression.
ObjectCreationExpressionType | Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.
PreprocessorDirective | Gets the IDotNetContextLocation that represents a preprocessor directive specification.
ReturnType | Gets the IDotNetContextLocation that represents a return type name specification.
Type | Gets the IDotNetContextLocation that represents a type name specification.
UsingDirectiveAliasedNamespaceOrType | Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.
UsingDirectiveNamespace | Gets the IDotNetContextLocation that represents a namespace specification within a using directive.
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations Properties

The CSharpContextLocations type exposes the following members.

Properties
Name | Description
Attribute | Gets the IDotNetContextLocation that represents an attribute specification.
Comment | Gets the IDotNetContextLocation that represents a comment specification.
DocumentationComment | Gets the IDotNetContextLocation that represents a documentation comment specification.
ExpressionStart | Gets the IDotNetContextLocation that represents an expression start specification.
ImplicitLocalVariableType | Gets the IDotNetContextLocation that represents an implicit local variable type.
LiteralCharacter | Gets the IDotNetContextLocation that represents a literal character specification.
LiteralString | Gets the IDotNetContextLocation that represents a literal string specification.
LocalVariableType | Gets the IDotNetContextLocation that represents a local variable type name specification.
ObjectCreationExpressionMemberName | Gets the IDotNetContextLocation that represents a member name target within an object creation expression.
ObjectCreationExpressionType | Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.
PreprocessorDirective | Gets the IDotNetContextLocation that represents a preprocessor directive specification.
ReturnType | Gets the IDotNetContextLocation that represents a return type name specification.
Type | Gets the IDotNetContextLocation that represents a type name specification.
UsingDirectiveAliasedNamespaceOrType | Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.
UsingDirectiveNamespace | Gets the IDotNetContextLocation that represents a namespace specification within a using directive.
Top
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.Attribute Property

CSharpContextLocationsAttribute Property

Gets the IDotNetContextLocation that represents an attribute specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Attribute { get; }
Public Shared ReadOnly Property Attribute As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.Comment Property

CSharpContextLocationsComment Property

Gets the IDotNetContextLocation that represents a comment specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Comment { get; }
Public Shared ReadOnly Property Comment As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.DocumentationComment Property

CSharpContextLocationsDocumentationComment Property

Gets the IDotNetContextLocation that represents a documentation comment specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation DocumentationComment { get; }
Public Shared ReadOnly Property DocumentationComment As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.ExpressionStart Property

CSharpContextLocationsExpressionStart Property

Gets the IDotNetContextLocation that represents an expression start specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ExpressionStart { get; }
Public Shared ReadOnly Property ExpressionStart As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.ImplicitLocalVariableType Property

CSharpContextLocationsImplicitLocalVariableType Property

Gets the IDotNetContextLocation that represents an implicit local variable type.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ImplicitLocalVariableType { get; }
Public Shared ReadOnly Property ImplicitLocalVariableType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.LiteralCharacter Property

CSharpContextLocationsLiteralCharacter Property

Gets the IDotNetContextLocation that represents a literal character specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LiteralCharacter { get; }
Public Shared ReadOnly Property LiteralCharacter As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.LiteralString Property

CSharpContextLocationsLiteralString Property

Gets the IDotNetContextLocation that represents a literal string specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LiteralString { get; }
Public Shared ReadOnly Property LiteralString As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.LocalVariableType Property

CSharpContextLocationsLocalVariableType Property

Gets the IDotNetContextLocation that represents a local variable type name specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LocalVariableType { get; }
Public Shared ReadOnly Property LocalVariableType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.ObjectCreationExpressionMemberName Property

CSharpContextLocationsObjectCreationExpressionMemberName Property

Gets the IDotNetContextLocation that represents a member name target within an object creation expression.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ObjectCreationExpressionMemberName { get; }
Public Shared ReadOnly Property ObjectCreationExpressionMemberName As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.ObjectCreationExpressionType Property

CSharpContextLocationsObjectCreationExpressionType Property

Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ObjectCreationExpressionType { get; }
Public Shared ReadOnly Property ObjectCreationExpressionType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.PreprocessorDirective Property

CSharpContextLocationsPreprocessorDirective Property

Gets the IDotNetContextLocation that represents a preprocessor directive specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation PreprocessorDirective { get; }
Public Shared ReadOnly Property PreprocessorDirective As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.ReturnType Property

CSharpContextLocationsReturnType Property

Gets the IDotNetContextLocation that represents a return type name specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ReturnType { get; }
Public Shared ReadOnly Property ReturnType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.Type Property

CSharpContextLocationsType Property

Gets the IDotNetContextLocation that represents a type name specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Type { get; }
Public Shared ReadOnly Property Type As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.UsingDirectiveAliasedNamespaceOrType Property

CSharpContextLocationsUsingDirectiveAliasedNamespaceOrType Property

Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation UsingDirectiveAliasedNamespaceOrType { get; }
Public Shared ReadOnly Property UsingDirectiveAliasedNamespaceOrType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.UsingDirectiveNamespace Property

CSharpContextLocationsUsingDirectiveNamespace Property

Gets the IDotNetContextLocation that represents a namespace specification within a using directive.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation UsingDirectiveNamespace { get; }
Public Shared ReadOnly Property UsingDirectiveNamespace As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


ICSharpGrammarOptions Interface

Contains options for a C# grammar.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICSharpGrammarOptions
Public Interface ICSharpGrammarOptions

The ICSharpGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp Namespace


ICSharpGrammarOptions Properties

The ICSharpGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ICSharpGrammarOptions Interface
ActiproSoftware.Text.Languages.CSharp Namespace


ICSharpGrammarOptions.RootNonTerminal Property

ICSharpGrammarOptionsRootNonTerminal Property

Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DotNetGrammarRootNonTerminal RootNonTerminal { get; }
ReadOnly Property RootNonTerminal As DotNetGrammarRootNonTerminal
    Get

Property Value

Type: DotNetGrammarRootNonTerminal
A DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

ICSharpGrammarOptions Interface
ActiproSoftware.Text.Languages.CSharp Namespace


ActiproSoftware.Text.Languages.CSharp.Implementation Namespace

Contains the core classes related to implementing a C# syntax language.
Classes
 | Class | Description
Public class | CSharpCodeBlockFinder | Provides a C# language code block finder service.
Public class | CSharpCodeSnippetProvider | Provides a C# language code snippet provider that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.
Public class | CSharpCompletionProvider | Provides IntelliPrompt completion data for the C# language.
Public class | CSharpContextFactory | Creates C# language IDotNetContext objects for a TextSnapshotOffset.
Public class | CSharpDelimiterAutoCompleter | Provides a C# language delimiter auto-completer service.
Public class | CSharpDocumentationCommentAutoCompleter | Provides a class that can auto-complete C# language documentation comments when appropriate.
Public class | CSharpExampleTextProvider | Represents a example text provider for the C# language.
Public class | CSharpGrammar | Represents a Grammar for the C# language.
Public class | CSharpGrammarOptions | Contains options for a C# grammar.
Public class | CSharpIndentProvider | Provides a C# language indent provider service.
Public class | CSharpLexer | Represents a C# lexer (lexical analyzer) implementation.
Public class | CSharpLexicalStateId | Contains the lexical state IDs for the C# language.
Public class | CSharpNavigableSymbolProvider | Represents a navigable symbol provider for the C# language.
Public class | CSharpOutliner | Provides a C# language outliner service.
Public class | CSharpOutliningSource | Represents a C# language range-based outlining source.
Public class | CSharpParameterInfoProvider | Provides IntelliPrompt parameter info data for the C# language.
Public class | CSharpParser | Represents a parser for the C# language.
Public class | CSharpProjectAssembly | Represents a C# project (source code-based) assembly.
Public class | CSharpQuickInfoProvider | Provides IntelliPrompt quick info data for the C# language.
Public class | CSharpSyntaxLanguage | Represents a C# syntax language definition.
Public class | CSharpTextFormatter | Provides a C# language text formatter service.
Public class | CSharpTokenId | Contains the token IDs for the C# language.
Public class | CSharpTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the C# language.
Public class | CSharpTokenTagger | Represents an ITaggerT for the C# language.
Public class | CSharpTokenTaggerProvider | Represents a provider of CSharpTokenTagger objects for documents that use the CSharpTokenTagger language.
Public class | CSharpTokenTaggerProviderTaggerFactory | Implements a factory that can creates CSharpTokenTagger objects for a document.


CSharpCodeBlockFinder Class

Provides a C# language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCodeBlockFinderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpCodeBlockFinder : DotNetCodeBlockFinderBase
Public Class CSharpCodeBlockFinder
    Inherits DotNetCodeBlockFinderBase

The CSharpCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpCodeBlockFinder | Initializes a new instance of the CSharpCodeBlockFinder class
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeBlockFinder Constructor

Initializes a new instance of the CSharpCodeBlockFinder class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpCodeBlockFinder()
Public Sub New
See Also

Reference

CSharpCodeBlockFinder Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeBlockFinder Properties

The CSharpCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

CSharpCodeBlockFinder Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeBlockFinder Methods

The CSharpCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

CSharpCodeBlockFinder Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider Class

Provides a C# language code snippet provider that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationCodeSnippetProvider
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCodeSnippetProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpCodeSnippetProvider : CodeSnippetProvider
Public Class CSharpCodeSnippetProvider
    Inherits CodeSnippetProvider

The CSharpCodeSnippetProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpCodeSnippetProvider | Initializes a new instance of the CSharpCodeSnippetProvider class.
Top
Properties
 | Name | Description
Public property | IsCaseSensitive | Gets or sets whether code snippet shortcut matching requires a case-sensitive match. (Inherited from CodeSnippetProvider.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CodeSnippetProvider.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CodeSnippetProvider.)
Public property | RootFolder | Gets or sets the root ICodeSnippetFolder containing code snippets that are accessible by this provider. (Inherited from CodeSnippetProvider.)
Top
Methods
 | Name | Description
Protected method | CheckForShortcut | Checks for a code snippet shortcut before the caret and opens a template session if one was found. (Inherited from CodeSnippetProvider.)
Protected method | CreateSelectionSession | Creates an ICodeSnippetSelectionSession for use with a RequestSelectionSession(IEditorView, CodeSnippetTypes) call. (Inherited from CodeSnippetProvider.)
Protected method | GetPossibleShortcutSnapshotRange | Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset. (Overrides CodeSnippetProviderGetPossibleShortcutSnapshotRange(TextSnapshotOffset).)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider Constructor

Initializes a new instance of the CSharpCodeSnippetProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpCodeSnippetProvider()
Public Sub New
See Also

Reference

CSharpCodeSnippetProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider Properties

The CSharpCodeSnippetProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsCaseSensitive | Gets or sets whether code snippet shortcut matching requires a case-sensitive match. (Inherited from CodeSnippetProvider.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CodeSnippetProvider.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CodeSnippetProvider.)
Public property | RootFolder | Gets or sets the root ICodeSnippetFolder containing code snippets that are accessible by this provider. (Inherited from CodeSnippetProvider.)
Top
See Also

Reference

CSharpCodeSnippetProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider Methods

The CSharpCodeSnippetProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CheckForShortcut | Checks for a code snippet shortcut before the caret and opens a template session if one was found. (Inherited from CodeSnippetProvider.)
Protected method | CreateSelectionSession | Creates an ICodeSnippetSelectionSession for use with a RequestSelectionSession(IEditorView, CodeSnippetTypes) call. (Inherited from CodeSnippetProvider.)
Protected method | GetPossibleShortcutSnapshotRange | Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset. (Overrides CodeSnippetProviderGetPossibleShortcutSnapshotRange(TextSnapshotOffset).)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Top
See Also

Reference

CSharpCodeSnippetProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider.GetPossibleShortcutSnapshotRange Method

CSharpCodeSnippetProviderGetPossibleShortcutSnapshotRange Method

Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override TextSnapshotRange GetPossibleShortcutSnapshotRange(
    TextSnapshotOffset snapshotOffset
)
Protected Overrides Function GetPossibleShortcutSnapshotRange (
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotRange

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange of the possible shortcut; or TextSnapshotRange.Deleted if there is no possible shortcut.
Remarks
Language implementations may wish to inherit this class and override this method to ensure the shortcut is not within a comment or other literal.
See Also

Reference

CSharpCodeSnippetProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider Class

Provides IntelliPrompt completion data for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCompletionProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCompletionProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpCompletionProvider : DotNetCompletionProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class CSharpCompletionProvider
    Inherits DotNetCompletionProviderBase
    Implements IEditorDocumentTextChangeEventSink

The CSharpCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpCompletionProvider | Initializes a new instance of the CSharpCompletionProvider class.
Top
Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word. (Inherited from DotNetCompletionProviderBase.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetCompletionProviderBaseCreateContext(IEditorView).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetCompletionProviderBase.)
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location. (Overrides DotNetCompletionProviderBaseShouldShowForTypedWordStart(IEditorView).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider Constructor

Initializes a new instance of the CSharpCompletionProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpCompletionProvider()
Public Sub New
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider Properties

The CSharpCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word. (Inherited from DotNetCompletionProviderBase.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider Methods

The CSharpCompletionProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetCompletionProviderBaseCreateContext(IEditorView).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetCompletionProviderBase.)
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location. (Overrides DotNetCompletionProviderBaseShouldShowForTypedWordStart(IEditorView).)
Top
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.CreateContext Method

CSharpCompletionProviderCreateContext Method

Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IDotNetContext CreateContext(
    IEditorView view
)
Protected Overrides Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.OnDocumentTextChanged Method

CSharpCompletionProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.OnDocumentTextChanging Method

CSharpCompletionProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.RequestSession Method

CSharpCompletionProviderRequestSession Method

Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Public Overrides Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

ICompletionProviderRequestSession(IEditorView, Boolean)
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.ShouldShowForTypedWordStart Method

CSharpCompletionProviderShouldShowForTypedWordStart Method

Returns whether the specified IEditorView supports automatic completion list display at its current caret location.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ShouldShowForTypedWordStart(
    IEditorView view
)
Public Overrides Function ShouldShowForTypedWordStart (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if automatic completion list display is supported; otherwise, false.
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory Class

Creates C# language IDotNetContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetContextFactoryBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpContextFactory

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpContextFactory : DotNetContextFactoryBase
Public Class CSharpContextFactory
    Inherits DotNetContextFactoryBase

The CSharpContextFactory type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpContextFactory | Initializes a new instance of the CSharpContextFactory class
Top
Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset. (Inherited from DotNetContextFactoryBase.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name. (Inherited from DotNetContextFactoryBase.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DotNetContextFactoryBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory Constructor

Initializes a new instance of the CSharpContextFactory class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpContextFactory()
Public Sub New
See Also

Reference

CSharpContextFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory Methods

The CSharpContextFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset. (Inherited from DotNetContextFactoryBase.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name. (Inherited from DotNetContextFactoryBase.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DotNetContextFactoryBase.)
Top
See Also

Reference

CSharpContextFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory.CreateContext Method

CSharpContextFactoryCreateContext Method

Overload List
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Top
See Also

Reference

CSharpContextFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory.CreateContext Method (TextSnapshotOffset, DotNetContextKind)

CSharpContextFactoryCreateContext Method (TextSnapshotOffset, DotNetContextKind)

Creates an IDotNetContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IDotNetContext CreateContext(
    TextSnapshotOffset snapshotOffset,
    DotNetContextKind kind
)
Public Overrides Function CreateContext (
    snapshotOffset As TextSnapshotOffset,
    kind As DotNetContextKind
) As IDotNetContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.
kind
Type: ActiproSoftware.Text.Languages.DotNetDotNetContextKind
A DotNetContextKind indicating the kind of context.

Return Value

Type: IDotNetContext
The IDotNetContext that was created.
See Also

Reference

CSharpContextFactory Class
CreateContext Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDelimiterAutoCompleter Class

Provides a C# language delimiter auto-completer service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationDelimiterAutoCompleter
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpDelimiterAutoCompleter

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpDelimiterAutoCompleter : DelimiterAutoCompleter
Public Class CSharpDelimiterAutoCompleter
    Inherits DelimiterAutoCompleter

The CSharpDelimiterAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpDelimiterAutoCompleter | Initializes a new instance of the CSharpDelimiterAutoCompleter class.
Top
Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteDoubleQuotes | Gets or sets whether double quotes can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteSingleQuotes | Gets or sets whether single quotes can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenDoubleQuoteTokenId | Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenSingleQuoteTokenId | Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Top
Methods
 | Name | Description
Protected method | IsValidForEndDelimiterAutoComplete | Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset. (Inherited from DelimiterAutoCompleter.)
Protected method | IsValidStartDelimiter(ITextSnapshotReader, Char) | Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter. (Overrides DelimiterAutoCompleterIsValidStartDelimiter(ITextSnapshotReader, Char).)
Protected method | IsValidStartDelimiter(IToken, Char) | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterAutoCompleter.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterAutoCompleter.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterAutoCompleter.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DelimiterAutoCompleter.)
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView. (Inherited from DelimiterAutoCompleter.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDelimiterAutoCompleter Constructor

Initializes a new instance of the CSharpDelimiterAutoCompleter class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpDelimiterAutoCompleter()
Public Sub New
See Also

Reference

CSharpDelimiterAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDelimiterAutoCompleter Properties

The CSharpDelimiterAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteDoubleQuotes | Gets or sets whether double quotes can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteSingleQuotes | Gets or sets whether single quotes can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenDoubleQuoteTokenId | Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenSingleQuoteTokenId | Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Top
See Also

Reference

CSharpDelimiterAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDelimiterAutoCompleter Methods

The CSharpDelimiterAutoCompleter type exposes the following members.

Methods
 | Name | Description
Protected method | IsValidForEndDelimiterAutoComplete | Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset. (Inherited from DelimiterAutoCompleter.)
Protected method | IsValidStartDelimiter(ITextSnapshotReader, Char) | Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter. (Overrides DelimiterAutoCompleterIsValidStartDelimiter(ITextSnapshotReader, Char).)
Protected method | IsValidStartDelimiter(IToken, Char) | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterAutoCompleter.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterAutoCompleter.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterAutoCompleter.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DelimiterAutoCompleter.)
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView. (Inherited from DelimiterAutoCompleter.)
Top
See Also

Reference

CSharpDelimiterAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDelimiterAutoCompleter.IsValidStartDelimiter Method

CSharpDelimiterAutoCompleterIsValidStartDelimiter Method

Overload List
 | Name | Description
Protected method | IsValidStartDelimiter(ITextSnapshotReader, Char) | Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter. (Overrides DelimiterAutoCompleterIsValidStartDelimiter(ITextSnapshotReader, Char).)
Protected method | IsValidStartDelimiter(IToken, Char) | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterAutoCompleter.)
Top
See Also

Reference

CSharpDelimiterAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDelimiterAutoCompleter.IsValidStartDelimiter Method (ITextSnapshotReader, Char)

CSharpDelimiterAutoCompleterIsValidStartDelimiter Method (ITextSnapshotReader, Char)

Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidStartDelimiter(
    ITextSnapshotReader reader,
    char startDelimiter
)
Protected Overrides Function IsValidStartDelimiter (
    reader As ITextSnapshotReader,
    startDelimiter As Char
) As Boolean

Parameters

reader
Type: ActiproSoftware.TextITextSnapshotReader
The ITextSnapshotReader to examine.
startDelimiter
Type: SystemChar
The start delimiter.

Return Value

Type: Boolean
true if the ITextSnapshotReader's current offset is immediately after the specified start delimiter; otherwise, false.
See Also

Reference

CSharpDelimiterAutoCompleter Class
IsValidStartDelimiter Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter Class

Provides a class that can auto-complete C# language documentation comments when appropriate.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDocumentationCommentAutoCompleterBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpDocumentationCommentAutoCompleter

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpDocumentationCommentAutoCompleter : DocumentationCommentAutoCompleterBase,
    IEditorDocumentTextChangeEventSink
Public Class CSharpDocumentationCommentAutoCompleter
    Inherits DocumentationCommentAutoCompleterBase
    Implements IEditorDocumentTextChangeEventSink

The CSharpDocumentationCommentAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpDocumentationCommentAutoCompleter | Initializes a new instance of the CSharpDocumentationCommentAutoCompleter class
Top
Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
Methods
 | Name | Description
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location. (Inherited from DocumentationCommentAutoCompleterBase.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IDocumentationCommentAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter Constructor

Initializes a new instance of the CSharpDocumentationCommentAutoCompleter class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpDocumentationCommentAutoCompleter()
Public Sub New
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter Properties

The CSharpDocumentationCommentAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter Methods

The CSharpDocumentationCommentAutoCompleter type exposes the following members.

Methods
 | Name | Description
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location. (Inherited from DocumentationCommentAutoCompleterBase.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter.OnDocumentTextChanged Method

CSharpDocumentationCommentAutoCompleterOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter.OnDocumentTextChanging Method

CSharpDocumentationCommentAutoCompleterOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpExampleTextProvider Class

Represents a example text provider for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpExampleTextProvider : IExampleTextProvider
Public Class CSharpExampleTextProvider
    Implements IExampleTextProvider

The CSharpExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpExampleTextProvider | Initializes a new instance of the CSharpExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Remarks
This type was generated by the Actipro Language Designer tool v10.2.530.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpExampleTextProvider Constructor

Initializes a new instance of the CSharpExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpExampleTextProvider()
Public Sub New
See Also

Reference

CSharpExampleTextProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpExampleTextProvider Properties

The CSharpExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

CSharpExampleTextProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpExampleTextProvider.ExampleText Property

CSharpExampleTextProviderExampleText Property

Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

CSharpExampleTextProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Class

Represents a Grammar for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpGrammar

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpGrammar : DotNetGrammarBase
Public Class CSharpGrammar
    Inherits DotNetGrammarBase

The CSharpGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpGrammar | Initializes a new instance of the CSharpGrammar class using default options.
Public method | CSharpGrammar(ICSharpGrammarOptions) | Initializes a new instance of the CSharpGrammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Constructor

Overload List
 | Name | Description
Public method | CSharpGrammar | Initializes a new instance of the CSharpGrammar class using default options.
Public method | CSharpGrammar(ICSharpGrammarOptions) | Initializes a new instance of the CSharpGrammar class.
Top
See Also

Reference

CSharpGrammar Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Constructor

Initializes a new instance of the CSharpGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpGrammar()
Public Sub New
See Also

Reference

CSharpGrammar Class
CSharpGrammar Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Constructor (ICSharpGrammarOptions)

Initializes a new instance of the CSharpGrammar class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpGrammar(
    ICSharpGrammarOptions options
)
Public Sub New (
    options As ICSharpGrammarOptions
)

Parameters

options
Type: ActiproSoftware.Text.Languages.CSharpICSharpGrammarOptions
An ICSharpGrammarOptions that contains options for the grammar.
See Also

Reference

CSharpGrammar Class
CSharpGrammar Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Properties

The CSharpGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

CSharpGrammar Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Methods

The CSharpGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

CSharpGrammar Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammarOptions Class

Contains options for a C# grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarOptionsBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpGrammarOptions

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpGrammarOptions : DotNetGrammarOptionsBase,
    ICSharpGrammarOptions
Public Class CSharpGrammarOptions
    Inherits DotNetGrammarOptionsBase
    Implements ICSharpGrammarOptions

The CSharpGrammarOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpGrammarOptions | Initializes a new instance of the CSharpGrammarOptions class
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. (Inherited from DotNetGrammarOptionsBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammarOptions Constructor

Initializes a new instance of the CSharpGrammarOptions class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpGrammarOptions()
Public Sub New
See Also

Reference

CSharpGrammarOptions Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammarOptions Properties

The CSharpGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. (Inherited from DotNetGrammarOptionsBase.)
Top
See Also

Reference

CSharpGrammarOptions Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider Class

Provides a C# language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationDelimiterIndentProvider
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpIndentProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpIndentProvider : DelimiterIndentProvider
Public Class CSharpIndentProvider
    Inherits DelimiterIndentProvider

The CSharpIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpIndentProvider | Initializes a new instance of the CSharpIndentProvider class.
Top
Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider Constructor

Initializes a new instance of the CSharpIndentProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpIndentProvider()
Public Sub New
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider Properties

The CSharpIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider.Mode Property

CSharpIndentProviderMode Property

Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IndentMode Mode { get; }
Public Overrides ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider Methods

The CSharpIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Top
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider.GetIndentAmount Method

CSharpIndentProviderGetIndentAmount Method

Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Overrides Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider.OnDocumentTextChanged Method

CSharpIndentProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overrides Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider.OnDocumentTextChanging Method

CSharpIndentProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overrides Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Class

Represents a C# lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpLexer

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpLexer : MergableLexerBase
Public Class CSharpLexer
    Inherits MergableLexerBase

The CSharpLexer type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpLexer | Initializes a new instance of the CSharpLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Constructor

Initializes a new instance of the CSharpLexer class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpLexer()
Public Sub New
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Properties

The CSharpLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer.LexicalStates Property

CSharpLexerLexicalStates Property

Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Methods

The CSharpLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer.GetAllLexicalStateTransitions Method

CSharpLexerGetAllLexicalStateTransitions Method

Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer.GetNextToken Method

CSharpLexerGetNextToken Method

Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Events

The CSharpLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Class

Contains the lexical state IDs for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpLexicalStateId

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpLexicalStateId : LexicalStateIdProviderBase
Public Class CSharpLexicalStateId
    Inherits LexicalStateIdProviderBase

The CSharpLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpLexicalStateId | Initializes a new instance of the CSharpLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
Fields
Name | Description
Default | Gets the Default lexical state ID.
DocumentationComment | Gets the DocumentationComment lexical state ID.
PreprocessorDirective | Gets the PreprocessorDirective lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.2.590.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Constructor

Initializes a new instance of the CSharpLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpLexicalStateId()
Public Sub New
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Properties

The CSharpLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.MaxId Property

CSharpLexicalStateIdMaxId Property

Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.MinId Property

CSharpLexicalStateIdMinId Property

Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Methods

The CSharpLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.ContainsId Method

CSharpLexicalStateIdContainsId Method

Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.GetDescription Method

CSharpLexicalStateIdGetDescription Method

Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.GetKey Method

CSharpLexicalStateIdGetKey Method

Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Fields

The CSharpLexicalStateId type exposes the following members.

Fields
Name | Description
Default | Gets the Default lexical state ID.
DocumentationComment | Gets the DocumentationComment lexical state ID.
PreprocessorDirective | Gets the PreprocessorDirective lexical state ID.
Top
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.Default Field

CSharpLexicalStateIdDefault Field

Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Default = 10000
Public Const Default As Integer = 10000

Field Value

Type: Int32
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.DocumentationComment Field

CSharpLexicalStateIdDocumentationComment Field

Gets the DocumentationComment lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentationComment = 10001
Public Const DocumentationComment As Integer = 10001

Field Value

Type: Int32
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.PreprocessorDirective Field

CSharpLexicalStateIdPreprocessorDirective Field

Gets the PreprocessorDirective lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirective = 10002
Public Const PreprocessorDirective As Integer = 10002

Field Value

Type: Int32
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider Class

Represents a navigable symbol provider for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetNavigableSymbolProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpNavigableSymbolProvider : DotNetNavigableSymbolProviderBase
Public Class CSharpNavigableSymbolProvider
    Inherits DotNetNavigableSymbolProviderBase

The CSharpNavigableSymbolProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpNavigableSymbolProvider | Initializes a new instance of the CSharpNavigableSymbolProvider class
Top
Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol(TypeMemberDeclaration, ITextSnapshot).)
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeSymbol(TypeDeclaration, ITextSnapshot).)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol. (Inherited from DotNetNavigableSymbolProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider Constructor

Initializes a new instance of the CSharpNavigableSymbolProvider class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpNavigableSymbolProvider()
Public Sub New
See Also

Reference

CSharpNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider Methods

The CSharpNavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol(TypeMemberDeclaration, ITextSnapshot).)
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeSymbol(TypeDeclaration, ITextSnapshot).)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol. (Inherited from DotNetNavigableSymbolProviderBase.)
Top
See Also

Reference

CSharpNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider.CreateTypeMemberSymbol Method

CSharpNavigableSymbolProviderCreateTypeMemberSymbol Method

Creates an INavigableSymbol for a TypeMemberDeclaration.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override INavigableSymbol CreateTypeMemberSymbol(
    TypeMemberDeclaration memberDecl,
    ITextSnapshot snapshot
)
Protected Overrides Function CreateTypeMemberSymbol (
    memberDecl As TypeMemberDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

memberDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
The TypeMemberDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

CSharpNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider.CreateTypeSymbol Method

CSharpNavigableSymbolProviderCreateTypeSymbol Method

Creates an INavigableSymbol for a TypeDeclaration.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override INavigableSymbol CreateTypeSymbol(
    TypeDeclaration typeDecl,
    ITextSnapshot snapshot
)
Protected Overrides Function CreateTypeSymbol (
    typeDecl As TypeDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

typeDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
The TypeDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

CSharpNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner Class

Provides a C# language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpOutliner

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpOutliner : IOutliner
Public Class CSharpOutliner
    Implements IOutliner

The CSharpOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpOutliner | Initializes a new instance of the CSharpOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner Constructor

Initializes a new instance of the CSharpOutliner class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpOutliner()
Public Sub New
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner Properties

The CSharpOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner.UpdateTrigger Property

CSharpOutlinerUpdateTrigger Property

Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner Methods

The CSharpOutliner type exposes the following members.

Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner.GetOutliningSource Method

CSharpOutlinerGetOutliningSource Method

Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource Class

Represents a C# language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpOutliningSource

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpOutliningSource : RangeOutliningSourceBase
Public Class CSharpOutliningSource
    Inherits RangeOutliningSourceBase

The CSharpOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpOutliningSource | Initializes a new instance of the CSharpOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource Constructor

Initializes a new instance of the CSharpOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

CSharpOutliningSource Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource Methods

The CSharpOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

CSharpOutliningSource Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource.AddNodesFromParseData Method

CSharpOutliningSourceAddNodesFromParseData Method

Overload List
 | Name | Description
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

CSharpOutliningSource Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource.AddNodesFromParseData Method (IDotNetParseData)

CSharpOutliningSourceAddNodesFromParseData Method (IDotNetParseData)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IDotNetParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IDotNetParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData containing AST data.
See Also

Reference

CSharpOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource.AddNodesFromParseData Method (IDotNetParseData, ITextBufferReader)

CSharpOutliningSourceAddNodesFromParseData Method (IDotNetParseData, ITextBufferReader)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IDotNetParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IDotNetParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

CSharpOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource.AddNodesRecursive Method

CSharpOutliningSourceAddNodesRecursive Method

Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

CSharpOutliningSource Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider Class

Provides IntelliPrompt parameter info data for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationParameterInfoProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParameterInfoProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpParameterInfoProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpParameterInfoProvider : DotNetParameterInfoProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class CSharpParameterInfoProvider
    Inherits DotNetParameterInfoProviderBase
    Implements IEditorDocumentTextChangeEventSink

The CSharpParameterInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpParameterInfoProvider | Initializes a new instance of the CSharpParameterInfoProvider class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetParameterInfoProviderBaseCreateContext(IEditorView).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetParameterInfoProviderBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DotNetParameterInfoProviderBase.)
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext. (Inherited from DotNetParameterInfoProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider Constructor

Initializes a new instance of the CSharpParameterInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpParameterInfoProvider()
Public Sub New
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider Properties

The CSharpParameterInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider Methods

The CSharpParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetParameterInfoProviderBaseCreateContext(IEditorView).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetParameterInfoProviderBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DotNetParameterInfoProviderBase.)
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext. (Inherited from DotNetParameterInfoProviderBase.)
Top
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider.CreateContext Method

CSharpParameterInfoProviderCreateContext Method

Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IDotNetContext CreateContext(
    IEditorView view
)
Protected Overrides Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider.OnDocumentTextChanged Method

CSharpParameterInfoProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider.OnDocumentTextChanging Method

CSharpParameterInfoProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider.RequestSession Method

CSharpParameterInfoProviderRequestSession Method

Requests that an IParameterInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view
)
Public Overrides Function RequestSession (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

IParameterInfoProviderRequestSession(IEditorView)
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Class

Represents a parser for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParserBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpParser

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpParser : DotNetParserBase
Public Class CSharpParser
    Inherits DotNetParserBase

The CSharpParser type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpParser | Initializes a new instance of the CSharpParser class.
Public method | CSharpParser(Grammar) | Initializes a new instance of the CSharpParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from DotNetParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Overrides LLParserBaseInitializeParseData(LLParseData, IParserState).)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Constructor

Overload List
 | Name | Description
Public method | CSharpParser | Initializes a new instance of the CSharpParser class.
Public method | CSharpParser(Grammar) | Initializes a new instance of the CSharpParser class.
Top
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Constructor

Initializes a new instance of the CSharpParser class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpParser()
Public Sub New
See Also

Reference

CSharpParser Class
CSharpParser Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Constructor (Grammar)

Initializes a new instance of the CSharpParser class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

CSharpParser Class
CSharpParser Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Properties

The CSharpParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Methods

The CSharpParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from DotNetParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Overrides LLParserBaseInitializeParseData(LLParseData, IParserState).)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Top
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser.CreateTokenReader Method

CSharpParserCreateTokenReader Method

Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser.InitializeParseData Method

CSharpParserInitializeParseData Method

Initializes a LLParseData using the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InitializeParseData(
    LLParseData parseData,
    IParserState state
)
Protected Overrides Sub InitializeParseData (
    parseData As LLParseData,
    state As IParserState
)

Parameters

parseData
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
The LLParseData to initialize.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.
Remarks
This method is called by default from the CreateParseData(IParseRequest, IParserState) method.
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser.InitializeParserState Method

CSharpParserInitializeParserState Method

Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser.ParseExpression Method

CSharpParserParseExpression Method

Parses the specified expression text.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetParseData ParseExpression(
    string text
)
Public Shared Function ParseExpression (
    text As String
) As IDotNetParseData

Parameters

text
Type: SystemString
The expression text to parse.

Return Value

Type: IDotNetParseData
The IDotNetParseData that contains the parse results.
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Class

Represents a C# project (source code-based) assembly.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationProjectAssembly
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpProjectAssembly

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpProjectAssembly : ProjectAssembly
Public Class CSharpProjectAssembly
    Inherits ProjectAssembly

The CSharpProjectAssembly type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpProjectAssembly(String) | Initializes a new instance of the CSharpProjectAssembly class.
Public method | CSharpProjectAssembly(IAssemblyName) | Initializes a new instance of the CSharpProjectAssembly class.
Top
Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly. (Inherited from ProjectAssembly.)
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from ProjectAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from ProjectAssembly.)
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive. (Overrides ProjectAssemblyIsLanguageCaseSensitive.)
Public property | Name | Gets the simple name of the assembly. (Inherited from ProjectAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from ProjectAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly. (Overrides ProjectAssemblyResolver.)
Public property | SourceFiles | Gets the collection of source files in this project assembly. (Inherited from ProjectAssembly.)
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from ProjectAssembly.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ProjectAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from ProjectAssembly.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Constructor

Overload List
 | Name | Description
Public method | CSharpProjectAssembly(String) | Initializes a new instance of the CSharpProjectAssembly class.
Public method | CSharpProjectAssembly(IAssemblyName) | Initializes a new instance of the CSharpProjectAssembly class.
Top
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Constructor (String)

Initializes a new instance of the CSharpProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpProjectAssembly(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The simple name of the assembly.
See Also

Reference

CSharpProjectAssembly Class
CSharpProjectAssembly Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Constructor (IAssemblyName)

Initializes a new instance of the CSharpProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpProjectAssembly(
    IAssemblyName assemblyName
)
Public Sub New (
    assemblyName As IAssemblyName
)

Parameters

assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
An IAssemblyName that contains assembly name information.
See Also

Reference

CSharpProjectAssembly Class
CSharpProjectAssembly Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Properties

The CSharpProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly. (Inherited from ProjectAssembly.)
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from ProjectAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from ProjectAssembly.)
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive. (Overrides ProjectAssemblyIsLanguageCaseSensitive.)
Public property | Name | Gets the simple name of the assembly. (Inherited from ProjectAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from ProjectAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly. (Overrides ProjectAssemblyResolver.)
Public property | SourceFiles | Gets the collection of source files in this project assembly. (Inherited from ProjectAssembly.)
Top
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly.IsLanguageCaseSensitive Property

CSharpProjectAssemblyIsLanguageCaseSensitive Property

Gets whether the language associated with this project assembly is case-sensitive.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsLanguageCaseSensitive { get; }
Protected Overrides ReadOnly Property IsLanguageCaseSensitive As Boolean
    Get

Property Value

Type: Boolean
true if the language associated with this project assembly is case-sensitive; otherwise, false.
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly.Resolver Property

CSharpProjectAssemblyResolver Property

Gets the IResolver to use for this project assembly.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IResolver Resolver { get; }
Public Overrides ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project assembly.

Implements

IProjectAssemblyResolver
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Methods

The CSharpProjectAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from ProjectAssembly.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ProjectAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from ProjectAssembly.)
Top
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider Class

Provides IntelliPrompt quick info data for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationQuickInfoProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpQuickInfoProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpQuickInfoProvider : QuickInfoProviderBase
Public Class CSharpQuickInfoProvider
    Inherits QuickInfoProviderBase

The CSharpQuickInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpQuickInfoProvider | Initializes a new instance of the CSharpQuickInfoProvider class.
Top
Properties
 | Name | Description
Protected property | CanTrackPointerInput | Gets whether to track pointer input and allow pointer movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider Constructor

Initializes a new instance of the CSharpQuickInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpQuickInfoProvider()
Public Sub New
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider Properties

The CSharpQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Protected property | CanTrackPointerInput | Gets whether to track pointer input and allow pointer movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.ContextTypes Property

CSharpQuickInfoProviderContextTypes Property

Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerable<Type> ContextTypes { get; }
Protected Overrides ReadOnly Property ContextTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The context Type objects that are supported by this provider.
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider Methods

The CSharpQuickInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.GetContext Method

CSharpQuickInfoProviderGetContext Method

Overload List
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Top
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.GetContext Method (IEditorView, Int32)

CSharpQuickInfoProviderGetContext Method (IEditorView, Int32)

Returns an object describing the quick info context for the specified text offset, if any.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetContext(
    IEditorView view,
    int offset
)
Public Overrides Function GetContext (
    view As IEditorView,
    offset As Integer
) As Object

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView in which the offset is located.
offset
Type: SystemInt32
The text offset to examine.

Return Value

Type: Object
An object describing the quick info context for the specified text offset, if any. A value indicates that no context is available.

Implements

IQuickInfoProviderGetContext(IEditorView, Int32)
Remarks
This method is called in response to keyboard events.
See Also

Reference

CSharpQuickInfoProvider Class
GetContext Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.OnSessionOpening Method

CSharpQuickInfoProviderOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IQuickInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IQuickInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIQuickInfoSession
The IQuickInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.RequestSession Method

CSharpQuickInfoProviderRequestSession Method

Overload List
 | Name | Description
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.RequestSession Method (IEditorView, Object)

CSharpQuickInfoProviderRequestSession Method (IEditorView, Object)

Requests that an IQuickInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool RequestSession(
    IEditorView view,
    Object context
)
Protected Overrides Function RequestSession (
    view As IEditorView,
    context As Object
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
context
Type: SystemObject
A context object returned by GetContext(IEditorView, Int32).

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

CSharpQuickInfoProvider Class
RequestSession Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Class

Represents a C# syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetSyntaxLanguageBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpSyntaxLanguage : DotNetSyntaxLanguageBase
Public Class CSharpSyntaxLanguage
    Inherits DotNetSyntaxLanguageBase

The CSharpSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpSyntaxLanguage | Initializes a new instance of the CSharpSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Constructor

Initializes a new instance of the CSharpSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpSyntaxLanguage()
Public Sub New
See Also

Reference

CSharpSyntaxLanguage Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Properties

The CSharpSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

CSharpSyntaxLanguage Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Methods

The CSharpSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

CSharpSyntaxLanguage Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Events

The CSharpSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

CSharpSyntaxLanguage Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter Class

Provides a C# language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetTextFormatterBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTextFormatter

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpTextFormatter : DotNetTextFormatterBase
Public Class CSharpTextFormatter
    Inherits DotNetTextFormatterBase

The CSharpTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTextFormatter | Initializes a new instance of the CSharpTextFormatter class
Top
Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot. (Overrides DotNetTextFormatterBaseFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter Constructor

Initializes a new instance of the CSharpTextFormatter class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpTextFormatter()
Public Sub New
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter Properties

The CSharpTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter.IsOpeningBraceOnNewLine Property

CSharpTextFormatterIsOpeningBraceOnNewLine Property

Gets or sets a value indicating whether opening braces are on new lines.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOpeningBraceOnNewLine { get; set; }
Public Property IsOpeningBraceOnNewLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the opening braces are on new lines; otherwise, false.
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter Methods

The CSharpTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot. (Overrides DotNetTextFormatterBaseFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode).)
Top
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter.Format Method

CSharpTextFormatterFormat Method

Applies text formatting to part or all of a snapshot.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Format(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection selectionPositionRanges,
    TextFormatMode mode = TextFormatMode.Ranges
)
Public Overrides Sub Format (
    snapshot As ITextSnapshot,
    selectionPositionRanges As ITextPositionRangeCollection,
    Optional mode As TextFormatMode = TextFormatMode.Ranges
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
selectionPositionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the selection position ranges. These are used to translate the current selection to the new snapshot that is created, even when formatting the entire snapshot.
mode (Optional)
Type: ActiproSoftware.TextTextFormatMode
A TextFormatMode indicating whether to format part or all of the snapshot. The default value is Ranges.

Implements

ITextFormatterFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode)
Remarks
The containing ITextDocument is accessible via the ITextSnapshot.
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Class

Contains the token IDs for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenId

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpTokenId : TokenIdProviderBase
Public Class CSharpTokenId
    Inherits TokenIdProviderBase

The CSharpTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTokenId | Initializes a new instance of the CSharpTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsCSharpVerbatimStringClassificationType | Returns whether the specified ID value is part of the CSharpVerbatimString.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPreprocessorKeywordClassificationType | Returns whether the specified ID value is part of the PreprocessorKeyword.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
 | IsXmlDocumentationCommentClassificationType | Returns whether the specified ID value is part of the XmlDocumentationComment.
 | IsXmlDocumentationTagClassificationType | Returns whether the specified ID value is part of the XmlDocumentationTag.
Top
Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentMultiLine | Gets the CommentMultiLine token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
ContextualKeywordAdd | Gets the ContextualKeywordAdd token ID.
ContextualKeywordAscending | Gets the ContextualKeywordAscending token ID.
ContextualKeywordAsync | Gets the ContextualKeywordAsync token ID.
ContextualKeywordAwait | Gets the ContextualKeywordAwait token ID.
ContextualKeywordBy | Gets the ContextualKeywordBy token ID.
ContextualKeywordDescending | Gets the ContextualKeywordDescending token ID.
ContextualKeywordEquals | Gets the ContextualKeywordEquals token ID.
ContextualKeywordFrom | Gets the ContextualKeywordFrom token ID.
ContextualKeywordGet | Gets the ContextualKeywordGet token ID.
ContextualKeywordGroup | Gets the ContextualKeywordGroup token ID.
ContextualKeywordInto | Gets the ContextualKeywordInto token ID.
ContextualKeywordJoin | Gets the ContextualKeywordJoin token ID.
ContextualKeywordLet | Gets the ContextualKeywordLet token ID.
ContextualKeywordNameOf | Gets the ContextualKeywordNameOf token ID.
ContextualKeywordOn | Gets the ContextualKeywordOn token ID.
ContextualKeywordOrderBy | Gets the ContextualKeywordOrderBy token ID.
ContextualKeywordPartial | Gets the ContextualKeywordPartial token ID.
ContextualKeywordRemove | Gets the ContextualKeywordRemove token ID.
ContextualKeywordSelect | Gets the ContextualKeywordSelect token ID.
ContextualKeywordSet | Gets the ContextualKeywordSet token ID.
ContextualKeywordVar | Gets the ContextualKeywordVar token ID.
ContextualKeywordWhen | Gets the ContextualKeywordWhen token ID.
ContextualKeywordWhere | Gets the ContextualKeywordWhere token ID.
ContextualKeywordYield | Gets the ContextualKeywordYield token ID.
DocumentationCommentDelimiter | Gets the DocumentationCommentDelimiter token ID.
DocumentationCommentTag | Gets the DocumentationCommentTag token ID.
DocumentationCommentText | Gets the DocumentationCommentText token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
KeywordAbstract | Gets the KeywordAbstract token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordBase | Gets the KeywordBase token ID.
KeywordBool | Gets the KeywordBool token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordByte | Gets the KeywordByte token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordChar | Gets the KeywordChar token ID.
KeywordChecked | Gets the KeywordChecked token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordConst | Gets the KeywordConst token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDecimal | Gets the KeywordDecimal token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelegate | Gets the KeywordDelegate token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordDouble | Gets the KeywordDouble token ID.
KeywordDynamic | Gets the KeywordDynamic token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordEnum | Gets the KeywordEnum token ID.
KeywordEvent | Gets the KeywordEvent token ID.
KeywordExplicit | Gets the KeywordExplicit token ID.
KeywordExtern | Gets the KeywordExtern token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFixed | Gets the KeywordFixed token ID.
KeywordFloat | Gets the KeywordFloat token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordForEach | Gets the KeywordForEach token ID.
KeywordGoto | Gets the KeywordGoto token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImplicit | Gets the KeywordImplicit token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInt | Gets the KeywordInt token ID.
KeywordInterface | Gets the KeywordInterface token ID.
KeywordInternal | Gets the KeywordInternal token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordLock | Gets the KeywordLock token ID.
KeywordLong | Gets the KeywordLong token ID.
KeywordNamespace | Gets the KeywordNamespace token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNull | Gets the KeywordNull token ID.
KeywordObject | Gets the KeywordObject token ID.
KeywordOperator | Gets the KeywordOperator token ID.
KeywordOut | Gets the KeywordOut token ID.
KeywordOverride | Gets the KeywordOverride token ID.
KeywordParams | Gets the KeywordParams token ID.
KeywordPrivate | Gets the KeywordPrivate token ID.
KeywordProtected | Gets the KeywordProtected token ID.
KeywordPublic | Gets the KeywordPublic token ID.
KeywordReadOnly | Gets the KeywordReadOnly token ID.
KeywordRef | Gets the KeywordRef token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSByte | Gets the KeywordSByte token ID.
KeywordSealed | Gets the KeywordSealed token ID.
KeywordShort | Gets the KeywordShort token ID.
KeywordSizeOf | Gets the KeywordSizeOf token ID.
KeywordStackAlloc | Gets the KeywordStackAlloc token ID.
KeywordStatic | Gets the KeywordStatic token ID.
KeywordString | Gets the KeywordString token ID.
KeywordStruct | Gets the KeywordStruct token ID.
KeywordSwitch | Gets the KeywordSwitch token ID.
KeywordThis | Gets the KeywordThis token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordUInt | Gets the KeywordUInt token ID.
KeywordULong | Gets the KeywordULong token ID.
KeywordUnchecked | Gets the KeywordUnchecked token ID.
KeywordUnsafe | Gets the KeywordUnsafe token ID.
KeywordUShort | Gets the KeywordUShort token ID.
KeywordUsing | Gets the KeywordUsing token ID.
KeywordVirtual | Gets the KeywordVirtual token ID.
KeywordVoid | Gets the KeywordVoid token ID.
KeywordVolatile | Gets the KeywordVolatile token ID.
KeywordWhile | Gets the KeywordWhile token ID.
Lambda | Gets the Lambda token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralCharacter | Gets the LiteralCharacter token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralInterpolatedString | Gets the LiteralInterpolatedString token ID.
LiteralInterpolatedVerbatimString | Gets the LiteralInterpolatedVerbatimString token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralString | Gets the LiteralString token ID.
LiteralVerbatimString | Gets the LiteralVerbatimString token ID.
NamespaceAliasQualifier | Gets the NamespaceAliasQualifier token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorConditionalAnd | Gets the OperatorConditionalAnd token ID.
OperatorConditionalOr | Gets the OperatorConditionalOr token ID.
OperatorDecrement | Gets the OperatorDecrement token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorIncrement | Gets the OperatorIncrement token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorNegation | Gets the OperatorNegation token ID.
OperatorNullCoalescing | Gets the OperatorNullCoalescing token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorPointerDereference | Gets the OperatorPointerDereference token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
PreprocessorDirectiveKeywordDefine | Gets the PreprocessorDirectiveKeywordDefine token ID.
PreprocessorDirectiveKeywordElIf | Gets the PreprocessorDirectiveKeywordElIf token ID.
PreprocessorDirectiveKeywordElse | Gets the PreprocessorDirectiveKeywordElse token ID.
PreprocessorDirectiveKeywordEndIf | Gets the PreprocessorDirectiveKeywordEndIf token ID.
PreprocessorDirectiveKeywordEndRegion | Gets the PreprocessorDirectiveKeywordEndRegion token ID.
PreprocessorDirectiveKeywordError | Gets the PreprocessorDirectiveKeywordError token ID.
PreprocessorDirectiveKeywordIf | Gets the PreprocessorDirectiveKeywordIf token ID.
PreprocessorDirectiveKeywordLine | Gets the PreprocessorDirectiveKeywordLine token ID.
PreprocessorDirectiveKeywordPragma | Gets the PreprocessorDirectiveKeywordPragma token ID.
PreprocessorDirectiveKeywordRegion | Gets the PreprocessorDirectiveKeywordRegion token ID.
PreprocessorDirectiveKeywordUndef | Gets the PreprocessorDirectiveKeywordUndef token ID.
PreprocessorDirectiveKeywordWarning | Gets the PreprocessorDirectiveKeywordWarning token ID.
PreprocessorDirectiveText | Gets the PreprocessorDirectiveText token ID.
QuestionMark | Gets the QuestionMark token ID.
SemiColon | Gets the SemiColon token ID.
Whitespace | Gets the Whitespace token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v17.1.651.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Constructor

Initializes a new instance of the CSharpTokenId class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpTokenId()
Public Sub New
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Properties

The CSharpTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.MaxId Property

CSharpTokenIdMaxId Property

Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.MinId Property

CSharpTokenIdMinId Property

Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Methods

The CSharpTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsCSharpVerbatimStringClassificationType | Returns whether the specified ID value is part of the CSharpVerbatimString.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPreprocessorKeywordClassificationType | Returns whether the specified ID value is part of the PreprocessorKeyword.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
 | IsXmlDocumentationCommentClassificationType | Returns whether the specified ID value is part of the XmlDocumentationComment.
 | IsXmlDocumentationTagClassificationType | Returns whether the specified ID value is part of the XmlDocumentationTag.
Top
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContainsId Method

CSharpTokenIdContainsId Method

Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.GetDescription Method

CSharpTokenIdGetDescription Method

Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.GetKey Method

CSharpTokenIdGetKey Method

Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsCommentClassificationType Method

CSharpTokenIdIsCommentClassificationType Method

Returns whether the specified ID value is part of the Comment.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsCommentClassificationType(
    int id
)
Public Shared Function IsCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsCSharpVerbatimStringClassificationType Method

CSharpTokenIdIsCSharpVerbatimStringClassificationType Method

Returns whether the specified ID value is part of the CSharpVerbatimString.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsCSharpVerbatimStringClassificationType(
    int id
)
Public Shared Function IsCSharpVerbatimStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsIdentifierClassificationType Method

CSharpTokenIdIsIdentifierClassificationType Method

Returns whether the specified ID value is part of the Identifier.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsIdentifierClassificationType(
    int id
)
Public Shared Function IsIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsKeywordClassificationType Method

CSharpTokenIdIsKeywordClassificationType Method

Returns whether the specified ID value is part of the Keyword.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsKeywordClassificationType(
    int id
)
Public Shared Function IsKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsNumberClassificationType Method

CSharpTokenIdIsNumberClassificationType Method

Returns whether the specified ID value is part of the Number.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsNumberClassificationType(
    int id
)
Public Shared Function IsNumberClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsOperatorClassificationType Method

CSharpTokenIdIsOperatorClassificationType Method

Returns whether the specified ID value is part of the Operator.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsOperatorClassificationType(
    int id
)
Public Shared Function IsOperatorClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsPreprocessorKeywordClassificationType Method

CSharpTokenIdIsPreprocessorKeywordClassificationType Method

Returns whether the specified ID value is part of the PreprocessorKeyword.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsPreprocessorKeywordClassificationType(
    int id
)
Public Shared Function IsPreprocessorKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsStringClassificationType Method

CSharpTokenIdIsStringClassificationType Method

Returns whether the specified ID value is part of the String.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsStringClassificationType(
    int id
)
Public Shared Function IsStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsXmlDocumentationCommentClassificationType Method

CSharpTokenIdIsXmlDocumentationCommentClassificationType Method

Returns whether the specified ID value is part of the XmlDocumentationComment.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlDocumentationCommentClassificationType(
    int id
)
Public Shared Function IsXmlDocumentationCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsXmlDocumentationTagClassificationType Method

CSharpTokenIdIsXmlDocumentationTagClassificationType Method

Returns whether the specified ID value is part of the XmlDocumentationTag.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlDocumentationTagClassificationType(
    int id
)
Public Shared Function IsXmlDocumentationTagClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Fields

The CSharpTokenId type exposes the following members.

Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentMultiLine | Gets the CommentMultiLine token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
ContextualKeywordAdd | Gets the ContextualKeywordAdd token ID.
ContextualKeywordAscending | Gets the ContextualKeywordAscending token ID.
ContextualKeywordAsync | Gets the ContextualKeywordAsync token ID.
ContextualKeywordAwait | Gets the ContextualKeywordAwait token ID.
ContextualKeywordBy | Gets the ContextualKeywordBy token ID.
ContextualKeywordDescending | Gets the ContextualKeywordDescending token ID.
ContextualKeywordEquals | Gets the ContextualKeywordEquals token ID.
ContextualKeywordFrom | Gets the ContextualKeywordFrom token ID.
ContextualKeywordGet | Gets the ContextualKeywordGet token ID.
ContextualKeywordGroup | Gets the ContextualKeywordGroup token ID.
ContextualKeywordInto | Gets the ContextualKeywordInto token ID.
ContextualKeywordJoin | Gets the ContextualKeywordJoin token ID.
ContextualKeywordLet | Gets the ContextualKeywordLet token ID.
ContextualKeywordNameOf | Gets the ContextualKeywordNameOf token ID.
ContextualKeywordOn | Gets the ContextualKeywordOn token ID.
ContextualKeywordOrderBy | Gets the ContextualKeywordOrderBy token ID.
ContextualKeywordPartial | Gets the ContextualKeywordPartial token ID.
ContextualKeywordRemove | Gets the ContextualKeywordRemove token ID.
ContextualKeywordSelect | Gets the ContextualKeywordSelect token ID.
ContextualKeywordSet | Gets the ContextualKeywordSet token ID.
ContextualKeywordVar | Gets the ContextualKeywordVar token ID.
ContextualKeywordWhen | Gets the ContextualKeywordWhen token ID.
ContextualKeywordWhere | Gets the ContextualKeywordWhere token ID.
ContextualKeywordYield | Gets the ContextualKeywordYield token ID.
DocumentationCommentDelimiter | Gets the DocumentationCommentDelimiter token ID.
DocumentationCommentTag | Gets the DocumentationCommentTag token ID.
DocumentationCommentText | Gets the DocumentationCommentText token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
KeywordAbstract | Gets the KeywordAbstract token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordBase | Gets the KeywordBase token ID.
KeywordBool | Gets the KeywordBool token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordByte | Gets the KeywordByte token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordChar | Gets the KeywordChar token ID.
KeywordChecked | Gets the KeywordChecked token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordConst | Gets the KeywordConst token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDecimal | Gets the KeywordDecimal token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelegate | Gets the KeywordDelegate token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordDouble | Gets the KeywordDouble token ID.
KeywordDynamic | Gets the KeywordDynamic token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordEnum | Gets the KeywordEnum token ID.
KeywordEvent | Gets the KeywordEvent token ID.
KeywordExplicit | Gets the KeywordExplicit token ID.
KeywordExtern | Gets the KeywordExtern token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFixed | Gets the KeywordFixed token ID.
KeywordFloat | Gets the KeywordFloat token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordForEach | Gets the KeywordForEach token ID.
KeywordGoto | Gets the KeywordGoto token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImplicit | Gets the KeywordImplicit token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInt | Gets the KeywordInt token ID.
KeywordInterface | Gets the KeywordInterface token ID.
KeywordInternal | Gets the KeywordInternal token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordLock | Gets the KeywordLock token ID.
KeywordLong | Gets the KeywordLong token ID.
KeywordNamespace | Gets the KeywordNamespace token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNull | Gets the KeywordNull token ID.
KeywordObject | Gets the KeywordObject token ID.
KeywordOperator | Gets the KeywordOperator token ID.
KeywordOut | Gets the KeywordOut token ID.
KeywordOverride | Gets the KeywordOverride token ID.
KeywordParams | Gets the KeywordParams token ID.
KeywordPrivate | Gets the KeywordPrivate token ID.
KeywordProtected | Gets the KeywordProtected token ID.
KeywordPublic | Gets the KeywordPublic token ID.
KeywordReadOnly | Gets the KeywordReadOnly token ID.
KeywordRef | Gets the KeywordRef token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSByte | Gets the KeywordSByte token ID.
KeywordSealed | Gets the KeywordSealed token ID.
KeywordShort | Gets the KeywordShort token ID.
KeywordSizeOf | Gets the KeywordSizeOf token ID.
KeywordStackAlloc | Gets the KeywordStackAlloc token ID.
KeywordStatic | Gets the KeywordStatic token ID.
KeywordString | Gets the KeywordString token ID.
KeywordStruct | Gets the KeywordStruct token ID.
KeywordSwitch | Gets the KeywordSwitch token ID.
KeywordThis | Gets the KeywordThis token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordUInt | Gets the KeywordUInt token ID.
KeywordULong | Gets the KeywordULong token ID.
KeywordUnchecked | Gets the KeywordUnchecked token ID.
KeywordUnsafe | Gets the KeywordUnsafe token ID.
KeywordUShort | Gets the KeywordUShort token ID.
KeywordUsing | Gets the KeywordUsing token ID.
KeywordVirtual | Gets the KeywordVirtual token ID.
KeywordVoid | Gets the KeywordVoid token ID.
KeywordVolatile | Gets the KeywordVolatile token ID.
KeywordWhile | Gets the KeywordWhile token ID.
Lambda | Gets the Lambda token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralCharacter | Gets the LiteralCharacter token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralInterpolatedString | Gets the LiteralInterpolatedString token ID.
LiteralInterpolatedVerbatimString | Gets the LiteralInterpolatedVerbatimString token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralString | Gets the LiteralString token ID.
LiteralVerbatimString | Gets the LiteralVerbatimString token ID.
NamespaceAliasQualifier | Gets the NamespaceAliasQualifier token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorConditionalAnd | Gets the OperatorConditionalAnd token ID.
OperatorConditionalOr | Gets the OperatorConditionalOr token ID.
OperatorDecrement | Gets the OperatorDecrement token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorIncrement | Gets the OperatorIncrement token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorNegation | Gets the OperatorNegation token ID.
OperatorNullCoalescing | Gets the OperatorNullCoalescing token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorPointerDereference | Gets the OperatorPointerDereference token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
PreprocessorDirectiveKeywordDefine | Gets the PreprocessorDirectiveKeywordDefine token ID.
PreprocessorDirectiveKeywordElIf | Gets the PreprocessorDirectiveKeywordElIf token ID.
PreprocessorDirectiveKeywordElse | Gets the PreprocessorDirectiveKeywordElse token ID.
PreprocessorDirectiveKeywordEndIf | Gets the PreprocessorDirectiveKeywordEndIf token ID.
PreprocessorDirectiveKeywordEndRegion | Gets the PreprocessorDirectiveKeywordEndRegion token ID.
PreprocessorDirectiveKeywordError | Gets the PreprocessorDirectiveKeywordError token ID.
PreprocessorDirectiveKeywordIf | Gets the PreprocessorDirectiveKeywordIf token ID.
PreprocessorDirectiveKeywordLine | Gets the PreprocessorDirectiveKeywordLine token ID.
PreprocessorDirectiveKeywordPragma | Gets the PreprocessorDirectiveKeywordPragma token ID.
PreprocessorDirectiveKeywordRegion | Gets the PreprocessorDirectiveKeywordRegion token ID.
PreprocessorDirectiveKeywordUndef | Gets the PreprocessorDirectiveKeywordUndef token ID.
PreprocessorDirectiveKeywordWarning | Gets the PreprocessorDirectiveKeywordWarning token ID.
PreprocessorDirectiveText | Gets the PreprocessorDirectiveText token ID.
QuestionMark | Gets the QuestionMark token ID.
SemiColon | Gets the SemiColon token ID.
Whitespace | Gets the Whitespace token ID.
Top
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CloseCurlyBrace Field

CSharpTokenIdCloseCurlyBrace Field

Gets the CloseCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseCurlyBrace = 10003
Public Const CloseCurlyBrace As Integer = 10003

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CloseParenthesis Field

CSharpTokenIdCloseParenthesis Field

Gets the CloseParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseParenthesis = 10007
Public Const CloseParenthesis As Integer = 10007

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CloseSquareBrace Field

CSharpTokenIdCloseSquareBrace Field

Gets the CloseSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseSquareBrace = 10005
Public Const CloseSquareBrace As Integer = 10005

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Colon Field

CSharpTokenIdColon Field

Gets the Colon token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Colon = 10010
Public Const Colon As Integer = 10010

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Comma Field

CSharpTokenIdComma Field

Gets the Comma token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Comma = 10009
Public Const Comma As Integer = 10009

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CommentMultiLine Field

CSharpTokenIdCommentMultiLine Field

Gets the CommentMultiLine token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentMultiLine = 10016
Public Const CommentMultiLine As Integer = 10016

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CommentSingleLine Field

CSharpTokenIdCommentSingleLine Field

Gets the CommentSingleLine token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentSingleLine = 10015
Public Const CommentSingleLine As Integer = 10015

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordAdd Field

CSharpTokenIdContextualKeywordAdd Field

Gets the ContextualKeywordAdd token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAdd = 10108
Public Const ContextualKeywordAdd As Integer = 10108

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordAscending Field

CSharpTokenIdContextualKeywordAscending Field

Gets the ContextualKeywordAscending token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAscending = 10107
Public Const ContextualKeywordAscending As Integer = 10107

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordAsync Field

CSharpTokenIdContextualKeywordAsync Field

Gets the ContextualKeywordAsync token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAsync = 10109
Public Const ContextualKeywordAsync As Integer = 10109

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordAwait Field

CSharpTokenIdContextualKeywordAwait Field

Gets the ContextualKeywordAwait token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAwait = 10110
Public Const ContextualKeywordAwait As Integer = 10110

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordBy Field

CSharpTokenIdContextualKeywordBy Field

Gets the ContextualKeywordBy token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordBy = 10111
Public Const ContextualKeywordBy As Integer = 10111

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordDescending Field

CSharpTokenIdContextualKeywordDescending Field

Gets the ContextualKeywordDescending token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordDescending = 10112
Public Const ContextualKeywordDescending As Integer = 10112

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordEquals Field

CSharpTokenIdContextualKeywordEquals Field

Gets the ContextualKeywordEquals token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordEquals = 10113
Public Const ContextualKeywordEquals As Integer = 10113

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordFrom Field

CSharpTokenIdContextualKeywordFrom Field

Gets the ContextualKeywordFrom token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordFrom = 10114
Public Const ContextualKeywordFrom As Integer = 10114

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordGet Field

CSharpTokenIdContextualKeywordGet Field

Gets the ContextualKeywordGet token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordGet = 10115
Public Const ContextualKeywordGet As Integer = 10115

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordGroup Field

CSharpTokenIdContextualKeywordGroup Field

Gets the ContextualKeywordGroup token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordGroup = 10116
Public Const ContextualKeywordGroup As Integer = 10116

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordInto Field

CSharpTokenIdContextualKeywordInto Field

Gets the ContextualKeywordInto token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordInto = 10117
Public Const ContextualKeywordInto As Integer = 10117

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordJoin Field

CSharpTokenIdContextualKeywordJoin Field

Gets the ContextualKeywordJoin token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordJoin = 10118
Public Const ContextualKeywordJoin As Integer = 10118

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordLet Field

CSharpTokenIdContextualKeywordLet Field

Gets the ContextualKeywordLet token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordLet = 10119
Public Const ContextualKeywordLet As Integer = 10119

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordNameOf Field

CSharpTokenIdContextualKeywordNameOf Field

Gets the ContextualKeywordNameOf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordNameOf = 10120
Public Const ContextualKeywordNameOf As Integer = 10120

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordOn Field

CSharpTokenIdContextualKeywordOn Field

Gets the ContextualKeywordOn token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordOn = 10121
Public Const ContextualKeywordOn As Integer = 10121

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordOrderBy Field

CSharpTokenIdContextualKeywordOrderBy Field

Gets the ContextualKeywordOrderBy token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordOrderBy = 10122
Public Const ContextualKeywordOrderBy As Integer = 10122

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordPartial Field

CSharpTokenIdContextualKeywordPartial Field

Gets the ContextualKeywordPartial token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordPartial = 10123
Public Const ContextualKeywordPartial As Integer = 10123

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordRemove Field

CSharpTokenIdContextualKeywordRemove Field

Gets the ContextualKeywordRemove token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordRemove = 10124
Public Const ContextualKeywordRemove As Integer = 10124

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordSelect Field

CSharpTokenIdContextualKeywordSelect Field

Gets the ContextualKeywordSelect token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordSelect = 10125
Public Const ContextualKeywordSelect As Integer = 10125

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordSet Field

CSharpTokenIdContextualKeywordSet Field

Gets the ContextualKeywordSet token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordSet = 10126
Public Const ContextualKeywordSet As Integer = 10126

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordVar Field

CSharpTokenIdContextualKeywordVar Field

Gets the ContextualKeywordVar token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordVar = 10129
Public Const ContextualKeywordVar As Integer = 10129

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordWhen Field

CSharpTokenIdContextualKeywordWhen Field

Gets the ContextualKeywordWhen token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordWhen = 10127
Public Const ContextualKeywordWhen As Integer = 10127

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordWhere Field

CSharpTokenIdContextualKeywordWhere Field

Gets the ContextualKeywordWhere token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordWhere = 10128
Public Const ContextualKeywordWhere As Integer = 10128

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordYield Field

CSharpTokenIdContextualKeywordYield Field

Gets the ContextualKeywordYield token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordYield = 10130
Public Const ContextualKeywordYield As Integer = 10130

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.DocumentationCommentDelimiter Field

CSharpTokenIdDocumentationCommentDelimiter Field

Gets the DocumentationCommentDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentationCommentDelimiter = 10017
Public Const DocumentationCommentDelimiter As Integer = 10017

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.DocumentationCommentTag Field

CSharpTokenIdDocumentationCommentTag Field

Gets the DocumentationCommentTag token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentationCommentTag = 10018
Public Const DocumentationCommentTag As Integer = 10018

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.DocumentationCommentText Field

CSharpTokenIdDocumentationCommentText Field

Gets the DocumentationCommentText token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentationCommentText = 10019
Public Const DocumentationCommentText As Integer = 10019

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Dot Field

CSharpTokenIdDot Field

Gets the Dot token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Dot = 10008
Public Const Dot As Integer = 10008

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Identifier Field

CSharpTokenIdIdentifier Field

Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Identifier = 10028
Public Const Identifier As Integer = 10028

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordAbstract Field

CSharpTokenIdKeywordAbstract Field

Gets the KeywordAbstract token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAbstract = 10029
Public Const KeywordAbstract As Integer = 10029

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordAs Field

CSharpTokenIdKeywordAs Field

Gets the KeywordAs token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAs = 10030
Public Const KeywordAs As Integer = 10030

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordBase Field

CSharpTokenIdKeywordBase Field

Gets the KeywordBase token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordBase = 10031
Public Const KeywordBase As Integer = 10031

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordBool Field

CSharpTokenIdKeywordBool Field

Gets the KeywordBool token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordBool = 10032
Public Const KeywordBool As Integer = 10032

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordBreak Field

CSharpTokenIdKeywordBreak Field

Gets the KeywordBreak token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordBreak = 10033
Public Const KeywordBreak As Integer = 10033

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordByte Field

CSharpTokenIdKeywordByte Field

Gets the KeywordByte token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordByte = 10034
Public Const KeywordByte As Integer = 10034

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordCase Field

CSharpTokenIdKeywordCase Field

Gets the KeywordCase token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCase = 10035
Public Const KeywordCase As Integer = 10035

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordCatch Field

CSharpTokenIdKeywordCatch Field

Gets the KeywordCatch token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCatch = 10036
Public Const KeywordCatch As Integer = 10036

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordChar Field

CSharpTokenIdKeywordChar Field

Gets the KeywordChar token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordChar = 10037
Public Const KeywordChar As Integer = 10037

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordChecked Field

CSharpTokenIdKeywordChecked Field

Gets the KeywordChecked token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordChecked = 10038
Public Const KeywordChecked As Integer = 10038

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordClass Field

CSharpTokenIdKeywordClass Field

Gets the KeywordClass token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordClass = 10039
Public Const KeywordClass As Integer = 10039

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordConst Field

CSharpTokenIdKeywordConst Field

Gets the KeywordConst token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordConst = 10040
Public Const KeywordConst As Integer = 10040

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordContinue Field

CSharpTokenIdKeywordContinue Field

Gets the KeywordContinue token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordContinue = 10041
Public Const KeywordContinue As Integer = 10041

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDecimal Field

CSharpTokenIdKeywordDecimal Field

Gets the KeywordDecimal token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDecimal = 10042
Public Const KeywordDecimal As Integer = 10042

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDefault Field

CSharpTokenIdKeywordDefault Field

Gets the KeywordDefault token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDefault = 10043
Public Const KeywordDefault As Integer = 10043

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDelegate Field

CSharpTokenIdKeywordDelegate Field

Gets the KeywordDelegate token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDelegate = 10044
Public Const KeywordDelegate As Integer = 10044

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDo Field

CSharpTokenIdKeywordDo Field

Gets the KeywordDo token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDo = 10045
Public Const KeywordDo As Integer = 10045

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDouble Field

CSharpTokenIdKeywordDouble Field

Gets the KeywordDouble token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDouble = 10046
Public Const KeywordDouble As Integer = 10046

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDynamic Field

CSharpTokenIdKeywordDynamic Field

Gets the KeywordDynamic token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDynamic = 10047
Public Const KeywordDynamic As Integer = 10047

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordElse Field

CSharpTokenIdKeywordElse Field

Gets the KeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordElse = 10048
Public Const KeywordElse As Integer = 10048

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordEnum Field

CSharpTokenIdKeywordEnum Field

Gets the KeywordEnum token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordEnum = 10049
Public Const KeywordEnum As Integer = 10049

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordEvent Field

CSharpTokenIdKeywordEvent Field

Gets the KeywordEvent token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordEvent = 10050
Public Const KeywordEvent As Integer = 10050

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordExplicit Field

CSharpTokenIdKeywordExplicit Field

Gets the KeywordExplicit token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordExplicit = 10051
Public Const KeywordExplicit As Integer = 10051

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordExtern Field

CSharpTokenIdKeywordExtern Field

Gets the KeywordExtern token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordExtern = 10052
Public Const KeywordExtern As Integer = 10052

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFalse Field

CSharpTokenIdKeywordFalse Field

Gets the KeywordFalse token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFalse = 10053
Public Const KeywordFalse As Integer = 10053

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFinally Field

CSharpTokenIdKeywordFinally Field

Gets the KeywordFinally token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFinally = 10054
Public Const KeywordFinally As Integer = 10054

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFixed Field

CSharpTokenIdKeywordFixed Field

Gets the KeywordFixed token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFixed = 10055
Public Const KeywordFixed As Integer = 10055

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFloat Field

CSharpTokenIdKeywordFloat Field

Gets the KeywordFloat token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFloat = 10056
Public Const KeywordFloat As Integer = 10056

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFor Field

CSharpTokenIdKeywordFor Field

Gets the KeywordFor token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFor = 10057
Public Const KeywordFor As Integer = 10057

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordForEach Field

CSharpTokenIdKeywordForEach Field

Gets the KeywordForEach token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordForEach = 10058
Public Const KeywordForEach As Integer = 10058

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordGoto Field

CSharpTokenIdKeywordGoto Field

Gets the KeywordGoto token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordGoto = 10059
Public Const KeywordGoto As Integer = 10059

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordIf Field

CSharpTokenIdKeywordIf Field

Gets the KeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIf = 10060
Public Const KeywordIf As Integer = 10060

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordImplicit Field

CSharpTokenIdKeywordImplicit Field

Gets the KeywordImplicit token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordImplicit = 10061
Public Const KeywordImplicit As Integer = 10061

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordIn Field

CSharpTokenIdKeywordIn Field

Gets the KeywordIn token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIn = 10062
Public Const KeywordIn As Integer = 10062

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordInt Field

CSharpTokenIdKeywordInt Field

Gets the KeywordInt token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordInt = 10063
Public Const KeywordInt As Integer = 10063

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordInterface Field

CSharpTokenIdKeywordInterface Field

Gets the KeywordInterface token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordInterface = 10064
Public Const KeywordInterface As Integer = 10064

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordInternal Field

CSharpTokenIdKeywordInternal Field

Gets the KeywordInternal token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordInternal = 10065
Public Const KeywordInternal As Integer = 10065

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordIs Field

CSharpTokenIdKeywordIs Field

Gets the KeywordIs token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIs = 10066
Public Const KeywordIs As Integer = 10066

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordLock Field

CSharpTokenIdKeywordLock Field

Gets the KeywordLock token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordLock = 10067
Public Const KeywordLock As Integer = 10067

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordLong Field

CSharpTokenIdKeywordLong Field

Gets the KeywordLong token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordLong = 10068
Public Const KeywordLong As Integer = 10068

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordNamespace Field

CSharpTokenIdKeywordNamespace Field

Gets the KeywordNamespace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNamespace = 10069
Public Const KeywordNamespace As Integer = 10069

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordNew Field

CSharpTokenIdKeywordNew Field

Gets the KeywordNew token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNew = 10070
Public Const KeywordNew As Integer = 10070

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordNull Field

CSharpTokenIdKeywordNull Field

Gets the KeywordNull token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNull = 10071
Public Const KeywordNull As Integer = 10071

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordObject Field

CSharpTokenIdKeywordObject Field

Gets the KeywordObject token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordObject = 10072
Public Const KeywordObject As Integer = 10072

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordOperator Field

CSharpTokenIdKeywordOperator Field

Gets the KeywordOperator token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOperator = 10073
Public Const KeywordOperator As Integer = 10073

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordOut Field

CSharpTokenIdKeywordOut Field

Gets the KeywordOut token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOut = 10074
Public Const KeywordOut As Integer = 10074

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordOverride Field

CSharpTokenIdKeywordOverride Field

Gets the KeywordOverride token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOverride = 10075
Public Const KeywordOverride As Integer = 10075

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordParams Field

CSharpTokenIdKeywordParams Field

Gets the KeywordParams token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordParams = 10076
Public Const KeywordParams As Integer = 10076

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordPrivate Field

CSharpTokenIdKeywordPrivate Field

Gets the KeywordPrivate token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordPrivate = 10077
Public Const KeywordPrivate As Integer = 10077

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordProtected Field

CSharpTokenIdKeywordProtected Field

Gets the KeywordProtected token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordProtected = 10078
Public Const KeywordProtected As Integer = 10078

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordPublic Field

CSharpTokenIdKeywordPublic Field

Gets the KeywordPublic token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordPublic = 10079
Public Const KeywordPublic As Integer = 10079

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordReadOnly Field

CSharpTokenIdKeywordReadOnly Field

Gets the KeywordReadOnly token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordReadOnly = 10080
Public Const KeywordReadOnly As Integer = 10080

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordRef Field

CSharpTokenIdKeywordRef Field

Gets the KeywordRef token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordRef = 10081
Public Const KeywordRef As Integer = 10081

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordReturn Field

CSharpTokenIdKeywordReturn Field

Gets the KeywordReturn token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordReturn = 10082
Public Const KeywordReturn As Integer = 10082

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordSByte Field

CSharpTokenIdKeywordSByte Field

Gets the KeywordSByte token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSByte = 10083
Public Const KeywordSByte As Integer = 10083

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordSealed Field

CSharpTokenIdKeywordSealed Field

Gets the KeywordSealed token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSealed = 10084
Public Const KeywordSealed As Integer = 10084

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordShort Field

CSharpTokenIdKeywordShort Field

Gets the KeywordShort token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordShort = 10085
Public Const KeywordShort As Integer = 10085

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordSizeOf Field

CSharpTokenIdKeywordSizeOf Field

Gets the KeywordSizeOf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSizeOf = 10086
Public Const KeywordSizeOf As Integer = 10086

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordStackAlloc Field

CSharpTokenIdKeywordStackAlloc Field

Gets the KeywordStackAlloc token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordStackAlloc = 10087
Public Const KeywordStackAlloc As Integer = 10087

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordStatic Field

CSharpTokenIdKeywordStatic Field

Gets the KeywordStatic token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordStatic = 10088
Public Const KeywordStatic As Integer = 10088

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordString Field

CSharpTokenIdKeywordString Field

Gets the KeywordString token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordString = 10089
Public Const KeywordString As Integer = 10089

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordStruct Field

CSharpTokenIdKeywordStruct Field

Gets the KeywordStruct token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordStruct = 10090
Public Const KeywordStruct As Integer = 10090

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordSwitch Field

CSharpTokenIdKeywordSwitch Field

Gets the KeywordSwitch token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSwitch = 10091
Public Const KeywordSwitch As Integer = 10091

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordThis Field

CSharpTokenIdKeywordThis Field

Gets the KeywordThis token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordThis = 10092
Public Const KeywordThis As Integer = 10092

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordThrow Field

CSharpTokenIdKeywordThrow Field

Gets the KeywordThrow token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordThrow = 10093
Public Const KeywordThrow As Integer = 10093

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordTrue Field

CSharpTokenIdKeywordTrue Field

Gets the KeywordTrue token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTrue = 10094
Public Const KeywordTrue As Integer = 10094

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordTry Field

CSharpTokenIdKeywordTry Field

Gets the KeywordTry token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTry = 10095
Public Const KeywordTry As Integer = 10095

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordTypeOf Field

CSharpTokenIdKeywordTypeOf Field

Gets the KeywordTypeOf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTypeOf = 10096
Public Const KeywordTypeOf As Integer = 10096

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUInt Field

CSharpTokenIdKeywordUInt Field

Gets the KeywordUInt token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordUInt = 10097
Public Const KeywordUInt As Integer = 10097

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordULong Field

CSharpTokenIdKeywordULong Field

Gets the KeywordULong token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordULong = 10098
Public Const KeywordULong As Integer = 10098

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUnchecked Field

CSharpTokenIdKeywordUnchecked Field

Gets the KeywordUnchecked token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordUnchecked = 10099
Public Const KeywordUnchecked As Integer = 10099

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUnsafe Field

CSharpTokenIdKeywordUnsafe Field

Gets the KeywordUnsafe token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordUnsafe = 10100
Public Const KeywordUnsafe As Integer = 10100

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUShort Field

CSharpTokenIdKeywordUShort Field

Gets the KeywordUShort token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordUShort = 10101
Public Const KeywordUShort As Integer = 10101

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUsing Field

CSharpTokenIdKeywordUsing Field

Gets the KeywordUsing token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordUsing = 10102
Public Const KeywordUsing As Integer = 10102

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordVirtual Field

CSharpTokenIdKeywordVirtual Field

Gets the KeywordVirtual token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordVirtual = 10103
Public Const KeywordVirtual As Integer = 10103

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordVoid Field

CSharpTokenIdKeywordVoid Field

Gets the KeywordVoid token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordVoid = 10104
Public Const KeywordVoid As Integer = 10104

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordVolatile Field

CSharpTokenIdKeywordVolatile Field

Gets the KeywordVolatile token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordVolatile = 10105
Public Const KeywordVolatile As Integer = 10105

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordWhile Field

CSharpTokenIdKeywordWhile Field

Gets the KeywordWhile token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWhile = 10106
Public Const KeywordWhile As Integer = 10106

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Lambda Field

CSharpTokenIdLambda Field

Gets the Lambda token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Lambda = 10014
Public Const Lambda As Integer = 10014

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LineTerminator Field

CSharpTokenIdLineTerminator Field

Gets the LineTerminator token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LineTerminator = 10001
Public Const LineTerminator As Integer = 10001

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralCharacter Field

CSharpTokenIdLiteralCharacter Field

Gets the LiteralCharacter token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralCharacter = 10023
Public Const LiteralCharacter As Integer = 10023

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralDecimalInteger Field

CSharpTokenIdLiteralDecimalInteger Field

Gets the LiteralDecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralDecimalInteger = 10020
Public Const LiteralDecimalInteger As Integer = 10020

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralHexadecimalInteger Field

CSharpTokenIdLiteralHexadecimalInteger Field

Gets the LiteralHexadecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralHexadecimalInteger = 10021
Public Const LiteralHexadecimalInteger As Integer = 10021

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralInterpolatedString Field

CSharpTokenIdLiteralInterpolatedString Field

Gets the LiteralInterpolatedString token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralInterpolatedString = 10025
Public Const LiteralInterpolatedString As Integer = 10025

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralInterpolatedVerbatimString Field

CSharpTokenIdLiteralInterpolatedVerbatimString Field

Gets the LiteralInterpolatedVerbatimString token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralInterpolatedVerbatimString = 10027
Public Const LiteralInterpolatedVerbatimString As Integer = 10027

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralReal Field

CSharpTokenIdLiteralReal Field

Gets the LiteralReal token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralReal = 10022
Public Const LiteralReal As Integer = 10022

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralString Field

CSharpTokenIdLiteralString Field

Gets the LiteralString token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralString = 10024
Public Const LiteralString As Integer = 10024

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralVerbatimString Field

CSharpTokenIdLiteralVerbatimString Field

Gets the LiteralVerbatimString token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralVerbatimString = 10026
Public Const LiteralVerbatimString As Integer = 10026

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.NamespaceAliasQualifier Field

CSharpTokenIdNamespaceAliasQualifier Field

Gets the NamespaceAliasQualifier token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int NamespaceAliasQualifier = 10013
Public Const NamespaceAliasQualifier As Integer = 10013

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OpenCurlyBrace Field

CSharpTokenIdOpenCurlyBrace Field

Gets the OpenCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenCurlyBrace = 10002
Public Const OpenCurlyBrace As Integer = 10002

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OpenParenthesis Field

CSharpTokenIdOpenParenthesis Field

Gets the OpenParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenParenthesis = 10006
Public Const OpenParenthesis As Integer = 10006

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OpenSquareBrace Field

CSharpTokenIdOpenSquareBrace Field

Gets the OpenSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenSquareBrace = 10004
Public Const OpenSquareBrace As Integer = 10004

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorAddition Field

CSharpTokenIdOperatorAddition Field

Gets the OperatorAddition token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAddition = 10131
Public Const OperatorAddition As Integer = 10131

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorAdditionAssignment Field

CSharpTokenIdOperatorAdditionAssignment Field

Gets the OperatorAdditionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAdditionAssignment = 10153
Public Const OperatorAdditionAssignment As Integer = 10153

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorAssignment Field

CSharpTokenIdOperatorAssignment Field

Gets the OperatorAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAssignment = 10141
Public Const OperatorAssignment As Integer = 10141

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorBitwiseAnd Field

CSharpTokenIdOperatorBitwiseAnd Field

Gets the OperatorBitwiseAnd token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAnd = 10136
Public Const OperatorBitwiseAnd As Integer = 10136

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorBitwiseAndAssignment Field

CSharpTokenIdOperatorBitwiseAndAssignment Field

Gets the OperatorBitwiseAndAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAndAssignment = 10158
Public Const OperatorBitwiseAndAssignment As Integer = 10158

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorBitwiseOr Field

CSharpTokenIdOperatorBitwiseOr Field

Gets the OperatorBitwiseOr token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOr = 10137
Public Const OperatorBitwiseOr As Integer = 10137

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorBitwiseOrAssignment Field

CSharpTokenIdOperatorBitwiseOrAssignment Field

Gets the OperatorBitwiseOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOrAssignment = 10159
Public Const OperatorBitwiseOrAssignment As Integer = 10159

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorConditionalAnd Field

CSharpTokenIdOperatorConditionalAnd Field

Gets the OperatorConditionalAnd token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorConditionalAnd = 10146
Public Const OperatorConditionalAnd As Integer = 10146

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorConditionalOr Field

CSharpTokenIdOperatorConditionalOr Field

Gets the OperatorConditionalOr token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorConditionalOr = 10147
Public Const OperatorConditionalOr As Integer = 10147

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorDecrement Field

CSharpTokenIdOperatorDecrement Field

Gets the OperatorDecrement token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorDecrement = 10145
Public Const OperatorDecrement As Integer = 10145

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorDivision Field

CSharpTokenIdOperatorDivision Field

Gets the OperatorDivision token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorDivision = 10134
Public Const OperatorDivision As Integer = 10134

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorDivisionAssignment Field

CSharpTokenIdOperatorDivisionAssignment Field

Gets the OperatorDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorDivisionAssignment = 10156
Public Const OperatorDivisionAssignment As Integer = 10156

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorEquality Field

CSharpTokenIdOperatorEquality Field

Gets the OperatorEquality token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorEquality = 10149
Public Const OperatorEquality As Integer = 10149

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorExclusiveOr Field

CSharpTokenIdOperatorExclusiveOr Field

Gets the OperatorExclusiveOr token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOr = 10138
Public Const OperatorExclusiveOr As Integer = 10138

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorExclusiveOrAssignment Field

CSharpTokenIdOperatorExclusiveOrAssignment Field

Gets the OperatorExclusiveOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOrAssignment = 10160
Public Const OperatorExclusiveOrAssignment As Integer = 10160

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorGreaterThan Field

CSharpTokenIdOperatorGreaterThan Field

Gets the OperatorGreaterThan token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThan = 10143
Public Const OperatorGreaterThan As Integer = 10143

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorGreaterThanOrEqual Field

CSharpTokenIdOperatorGreaterThanOrEqual Field

Gets the OperatorGreaterThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThanOrEqual = 10152
Public Const OperatorGreaterThanOrEqual As Integer = 10152

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorIncrement Field

CSharpTokenIdOperatorIncrement Field

Gets the OperatorIncrement token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorIncrement = 10144
Public Const OperatorIncrement As Integer = 10144

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorInequality Field

CSharpTokenIdOperatorInequality Field

Gets the OperatorInequality token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorInequality = 10150
Public Const OperatorInequality As Integer = 10150

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorLeftShift Field

CSharpTokenIdOperatorLeftShift Field

Gets the OperatorLeftShift token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLeftShift = 10148
Public Const OperatorLeftShift As Integer = 10148

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorLeftShiftAssignment Field

CSharpTokenIdOperatorLeftShiftAssignment Field

Gets the OperatorLeftShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLeftShiftAssignment = 10161
Public Const OperatorLeftShiftAssignment As Integer = 10161

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorLessThan Field

CSharpTokenIdOperatorLessThan Field

Gets the OperatorLessThan token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLessThan = 10142
Public Const OperatorLessThan As Integer = 10142

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorLessThanOrEqual Field

CSharpTokenIdOperatorLessThanOrEqual Field

Gets the OperatorLessThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLessThanOrEqual = 10151
Public Const OperatorLessThanOrEqual As Integer = 10151

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorModulus Field

CSharpTokenIdOperatorModulus Field

Gets the OperatorModulus token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorModulus = 10135
Public Const OperatorModulus As Integer = 10135

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorModulusAssignment Field

CSharpTokenIdOperatorModulusAssignment Field

Gets the OperatorModulusAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorModulusAssignment = 10157
Public Const OperatorModulusAssignment As Integer = 10157

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorMultiplication Field

CSharpTokenIdOperatorMultiplication Field

Gets the OperatorMultiplication token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorMultiplication = 10133
Public Const OperatorMultiplication As Integer = 10133

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorMultiplicationAssignment Field

CSharpTokenIdOperatorMultiplicationAssignment Field

Gets the OperatorMultiplicationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorMultiplicationAssignment = 10155
Public Const OperatorMultiplicationAssignment As Integer = 10155

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorNegation Field

CSharpTokenIdOperatorNegation Field

Gets the OperatorNegation token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorNegation = 10139
Public Const OperatorNegation As Integer = 10139

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorNullCoalescing Field

CSharpTokenIdOperatorNullCoalescing Field

Gets the OperatorNullCoalescing token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorNullCoalescing = 10163
Public Const OperatorNullCoalescing As Integer = 10163

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorOnesComplement Field

CSharpTokenIdOperatorOnesComplement Field

Gets the OperatorOnesComplement token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorOnesComplement = 10140
Public Const OperatorOnesComplement As Integer = 10140

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorPointerDereference Field

CSharpTokenIdOperatorPointerDereference Field

Gets the OperatorPointerDereference token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorPointerDereference = 10162
Public Const OperatorPointerDereference As Integer = 10162

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorSubtraction Field

CSharpTokenIdOperatorSubtraction Field

Gets the OperatorSubtraction token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorSubtraction = 10132
Public Const OperatorSubtraction As Integer = 10132

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorSubtractionAssignment Field

CSharpTokenIdOperatorSubtractionAssignment Field

Gets the OperatorSubtractionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorSubtractionAssignment = 10154
Public Const OperatorSubtractionAssignment As Integer = 10154

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordDefine Field

CSharpTokenIdPreprocessorDirectiveKeywordDefine Field

Gets the PreprocessorDirectiveKeywordDefine token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordDefine = 10168
Public Const PreprocessorDirectiveKeywordDefine As Integer = 10168

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordElIf Field

CSharpTokenIdPreprocessorDirectiveKeywordElIf Field

Gets the PreprocessorDirectiveKeywordElIf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordElIf = 10166
Public Const PreprocessorDirectiveKeywordElIf As Integer = 10166

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordElse Field

CSharpTokenIdPreprocessorDirectiveKeywordElse Field

Gets the PreprocessorDirectiveKeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordElse = 10165
Public Const PreprocessorDirectiveKeywordElse As Integer = 10165

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordEndIf Field

CSharpTokenIdPreprocessorDirectiveKeywordEndIf Field

Gets the PreprocessorDirectiveKeywordEndIf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndIf = 10167
Public Const PreprocessorDirectiveKeywordEndIf As Integer = 10167

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordEndRegion Field

CSharpTokenIdPreprocessorDirectiveKeywordEndRegion Field

Gets the PreprocessorDirectiveKeywordEndRegion token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndRegion = 10174
Public Const PreprocessorDirectiveKeywordEndRegion As Integer = 10174

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordError Field

CSharpTokenIdPreprocessorDirectiveKeywordError Field

Gets the PreprocessorDirectiveKeywordError token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordError = 10171
Public Const PreprocessorDirectiveKeywordError As Integer = 10171

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordIf Field

CSharpTokenIdPreprocessorDirectiveKeywordIf Field

Gets the PreprocessorDirectiveKeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordIf = 10164
Public Const PreprocessorDirectiveKeywordIf As Integer = 10164

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordLine Field

CSharpTokenIdPreprocessorDirectiveKeywordLine Field

Gets the PreprocessorDirectiveKeywordLine token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordLine = 10172
Public Const PreprocessorDirectiveKeywordLine As Integer = 10172

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordPragma Field

CSharpTokenIdPreprocessorDirectiveKeywordPragma Field

Gets the PreprocessorDirectiveKeywordPragma token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordPragma = 10175
Public Const PreprocessorDirectiveKeywordPragma As Integer = 10175

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordRegion Field

CSharpTokenIdPreprocessorDirectiveKeywordRegion Field

Gets the PreprocessorDirectiveKeywordRegion token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordRegion = 10173
Public Const PreprocessorDirectiveKeywordRegion As Integer = 10173

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordUndef Field

CSharpTokenIdPreprocessorDirectiveKeywordUndef Field

Gets the PreprocessorDirectiveKeywordUndef token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordUndef = 10169
Public Const PreprocessorDirectiveKeywordUndef As Integer = 10169

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordWarning Field

CSharpTokenIdPreprocessorDirectiveKeywordWarning Field

Gets the PreprocessorDirectiveKeywordWarning token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordWarning = 10170
Public Const PreprocessorDirectiveKeywordWarning As Integer = 10170

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveText Field

CSharpTokenIdPreprocessorDirectiveText Field

Gets the PreprocessorDirectiveText token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveText = 10176
Public Const PreprocessorDirectiveText As Integer = 10176

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.QuestionMark Field

CSharpTokenIdQuestionMark Field

Gets the QuestionMark token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int QuestionMark = 10012
Public Const QuestionMark As Integer = 10012

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.SemiColon Field

CSharpTokenIdSemiColon Field

Gets the SemiColon token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SemiColon = 10011
Public Const SemiColon As Integer = 10011

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Whitespace Field

CSharpTokenIdWhitespace Field

Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Whitespace = 10000
Public Const Whitespace As Integer = 10000

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader Class

Represents an object that can provide tokens to a ILLParser in a forward-only direction for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenReader

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpTokenReader : MergableTokenReader
Public Class CSharpTokenReader
    Inherits MergableTokenReader

The CSharpTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTokenReader | Initializes a new instance of the CSharpTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader Constructor

Initializes a new instance of the CSharpTokenReader class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

CSharpTokenReader Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader Properties

The CSharpTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

CSharpTokenReader Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader Methods

The CSharpTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Top
See Also

Reference

CSharpTokenReader Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader.GetNextToken Method

CSharpTokenReaderGetNextToken Method

Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

CSharpTokenReader Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Class

Represents an ITaggerT for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTagger

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpTokenTagger : TokenTagger
Public Class CSharpTokenTagger
    Inherits TokenTagger

The CSharpTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTokenTagger | Initializes a new instance of the CSharpTokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Constructor

Initializes a new instance of the CSharpTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpTokenTagger(
    ICodeDocument document,
    IDotNetClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    document As ICodeDocument,
    classificationTypeProvider As IDotNetClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypeProvider
Type: ActiproSoftware.Text.Languages.DotNetIDotNetClassificationTypeProvider
A IDotNetClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Properties

The CSharpTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Methods

The CSharpTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger.ClassifyToken Method

CSharpTokenTaggerClassifyToken Method

Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IClassificationType ClassifyToken(
    IToken token
)
Public Overrides Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Events

The CSharpTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider Class

Represents a provider of CSharpTokenTagger objects for documents that use the CSharpTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase CSharpTokenTagger
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CSharpTokenTaggerProvider : TaggerProviderBase<CSharpTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class CSharpTokenTaggerProvider
    Inherits TaggerProviderBase(Of CSharpTokenTagger)
    Implements ICodeDocumentTaggerProvider

The CSharpTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTokenTaggerProvider | Initializes a new instance of the CSharpTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.2.590.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider Constructor

Initializes a new instance of the CSharpTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpTokenTaggerProvider(
    IDotNetClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IDotNetClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.DotNetIDotNetClassificationTypeProvider
A IDotNetClassificationTypeProvider that provides classification types.
See Also

Reference

CSharpTokenTaggerProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider Properties

The CSharpTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

CSharpTokenTaggerProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider Methods

The CSharpTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
See Also

Reference

CSharpTokenTaggerProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider.GetTagger(T) Method

CSharpTokenTaggerProviderGetTaggerT Method

Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

CSharpTokenTaggerProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider.TaggerFactory Class

CSharpTokenTaggerProviderTaggerFactory Class

Implements a factory that can creates CSharpTokenTagger objects for a document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTaggerProviderTaggerFactory

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TaggerFactory
Public Class TaggerFactory

The CSharpTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an CSharpTokenTagger for the ICodeDocument.
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


TaggerFactory Methods

The CSharpTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an CSharpTokenTagger for the ICodeDocument.
Top
See Also

Reference

CSharpTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider.TaggerFactory.CreateTagger Method

CSharpTokenTaggerProviderTaggerFactoryCreateTagger Method

Creates an CSharpTokenTagger for the ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CSharpTokenTagger CreateTagger()
Public Function CreateTagger As CSharpTokenTagger

Return Value

Type: CSharpTokenTagger
An CSharpTokenTagger for the ICodeDocument.
See Also

Reference

CSharpTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


ActiproSoftware.Text.Languages.DotNet Namespace

Contains the classes related to implementing a .NET syntax language.
Classes
 | Class | Description
Public class | DotNetSyntaxLanguageExtensions | Contains extension methods that make it easier to work with .NET ISyntaxLanguage objects.
Interfaces
 | Interface | Description
Public interface | IDocumentationCommentAutoCompleter | Provides the base requirements for a class that can auto-complete .NET language documentation comments when appropriate.
Public interface | IDotNetClassificationTypeProvider | Provides the base requirements of an object that provides IClassificationType objects for a .NET language.
Public interface | IDotNetContext | Provides the base requirements for information about a .NET language context of a certain offset within an ITextSnapshot.
Public interface | IDotNetContextLocation | Provides the base requirements for an IDotNetContext location, that determines what sort of resolver results are permitted.
Public interface | IDotNetParseData | Provides the base requirements of an object that stores the results of a .NET language parsing operation.
Enumerations
 | Enumeration | Description
Public enumeration | DotNetContextKind | Specifies the kind of context.
Public enumeration | DotNetGrammarRootNonTerminal | Specifies the root non-terminal to use for a .NET grammar.


DotNetContextKind Enumeration

Specifies the kind of context.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DotNetContextKind
Public Enumeration DotNetContextKind
Members
Member name | Value | Description
Self | 0 | The context and its resolve operations work on the existing member referenced at the offset.
SelfAndSiblings | 1 | The context and its resolve operations work on the existing member and its siblings referenced at the offset.
NullConditionalSelfAndSiblings | 2 | Similar to SelfAndSiblings but uses special null-conditional handling logic.
ContainingInvocation | 3 | The context and its resolve operations work on the invocation that contains the offset, if any.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal Enumeration

Specifies the root non-terminal to use for a .NET grammar.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DotNetGrammarRootNonTerminal
Public Enumeration DotNetGrammarRootNonTerminal
Members
Member name | Value | Description
CompilationUnit | 0 | Compilation unit (the default).
StatementList | 1 | Statement list.
Statement | 2 | Statement.
Expression | 3 | Expression.
QueryExpression | 4 | Query expression.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions Class

Contains extension methods that make it easier to work with .NET ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNetDotNetSyntaxLanguageExtensions

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class DotNetSyntaxLanguageExtensions
<ExtensionAttribute>
Public NotInheritable Class DotNetSyntaxLanguageExtensions

The DotNetSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML.
GetProjectAssembly | Returns the IProjectAssembly that can validate XML.
RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML.
RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML.
UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML.
UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions Methods

The DotNetSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML.
GetProjectAssembly | Returns the IProjectAssembly that can validate XML.
RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML.
RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML.
UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML.
UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML.
Top
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.GetDocumentationCommentAutoCompleter Method

DotNetSyntaxLanguageExtensionsGetDocumentationCommentAutoCompleter Method

Returns the IDocumentationCommentAutoCompleter that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDocumentationCommentAutoCompleter GetDocumentationCommentAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetDocumentationCommentAutoCompleter (
    language As ISyntaxLanguage
) As IDocumentationCommentAutoCompleter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IDocumentationCommentAutoCompleter
The IDocumentationCommentAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.GetProjectAssembly Method

DotNetSyntaxLanguageExtensionsGetProjectAssembly Method

Returns the IProjectAssembly that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IProjectAssembly GetProjectAssembly(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetProjectAssembly (
    language As ISyntaxLanguage
) As IProjectAssembly

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IProjectAssembly
The IProjectAssembly instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.RegisterDocumentationCommentAutoCompleter Method

DotNetSyntaxLanguageExtensionsRegisterDocumentationCommentAutoCompleter Method

Registers the IDocumentationCommentAutoCompleter that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterDocumentationCommentAutoCompleter(
    this ISyntaxLanguage language,
    IDocumentationCommentAutoCompleter value
)
<ExtensionAttribute>
Public Shared Sub RegisterDocumentationCommentAutoCompleter (
    language As ISyntaxLanguage,
    value As IDocumentationCommentAutoCompleter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.DotNetIDocumentationCommentAutoCompleter
The IDocumentationCommentAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.RegisterProjectAssembly Method

DotNetSyntaxLanguageExtensionsRegisterProjectAssembly Method

Registers the IProjectAssembly that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterProjectAssembly(
    this ISyntaxLanguage language,
    IProjectAssembly value
)
<ExtensionAttribute>
Public Shared Sub RegisterProjectAssembly (
    language As ISyntaxLanguage,
    value As IProjectAssembly
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIProjectAssembly
The IProjectAssembly instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.UnregisterDocumentationCommentAutoCompleter Method

DotNetSyntaxLanguageExtensionsUnregisterDocumentationCommentAutoCompleter Method

Unregisters the IDocumentationCommentAutoCompleter that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterDocumentationCommentAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterDocumentationCommentAutoCompleter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.UnregisterProjectAssembly Method

DotNetSyntaxLanguageExtensionsUnregisterProjectAssembly Method

Unregisters the IProjectAssembly that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterProjectAssembly(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterProjectAssembly (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


IDocumentationCommentAutoCompleter Interface

Provides the base requirements for a class that can auto-complete .NET language documentation comments when appropriate.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDocumentationCommentAutoCompleter
Public Interface IDocumentationCommentAutoCompleter

The IDocumentationCommentAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets whether documentation comment end tag completion is enabled.
Public property | IsNewLineGenerationEnabled | Gets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.
Public property | IsStubGenerationEnabled | Gets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IDocumentationCommentAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpDocumentationCommentAutoCompleter
ActiproSoftware.Text.Languages.VB.ImplementationVBDocumentationCommentAutoCompleter


IDocumentationCommentAutoCompleter Properties

The IDocumentationCommentAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets whether documentation comment end tag completion is enabled.
Public property | IsNewLineGenerationEnabled | Gets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.
Public property | IsStubGenerationEnabled | Gets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.
Top
See Also

Reference

IDocumentationCommentAutoCompleter Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDocumentationCommentAutoCompleter.IsEndTagCompletionEnabled Property

IDocumentationCommentAutoCompleterIsEndTagCompletionEnabled Property

Gets whether documentation comment end tag completion is enabled.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsEndTagCompletionEnabled { get; }
ReadOnly Property IsEndTagCompletionEnabled As Boolean
    Get

Property Value

Type: Boolean
true if documentation comment end tag completion is enabled; otherwise, false.
See Also

Reference

IDocumentationCommentAutoCompleter Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDocumentationCommentAutoCompleter.IsNewLineGenerationEnabled Property

IDocumentationCommentAutoCompleterIsNewLineGenerationEnabled Property

Gets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsNewLineGenerationEnabled { get; }
ReadOnly Property IsNewLineGenerationEnabled As Boolean
    Get

Property Value

Type: Boolean
true if documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment; otherwise, false.
See Also

Reference

IDocumentationCommentAutoCompleter Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDocumentationCommentAutoCompleter.IsStubGenerationEnabled Property

IDocumentationCommentAutoCompleterIsStubGenerationEnabled Property

Gets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsStubGenerationEnabled { get; }
ReadOnly Property IsStubGenerationEnabled As Boolean
    Get

Property Value

Type: Boolean
true if stub documentation comment auto-generation is enabled when starting to type new documentation comments; otherwise, false.
See Also

Reference

IDocumentationCommentAutoCompleter Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider Interface

Provides the base requirements of an object that provides IClassificationType objects for a .NET language.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDotNetClassificationTypeProvider
Public Interface IDotNetClassificationTypeProvider

The IDotNetClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | CSharpVerbatimString | Gets the CSharpVerbatimString classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PreprocessorKeyword | Gets the PreprocessorKeyword classification type.
Public property | String | Gets the String classification type.
Public property | VBXmlLiteral | Gets the VBXmlLiteral classification type.
Public property | XmlDocumentationComment | Gets the XmlDocumentationComment classification type.
Public property | XmlDocumentationTag | Gets the XmlDocumentationTag classification type.
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.540.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider Properties

The IDotNetClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | CSharpVerbatimString | Gets the CSharpVerbatimString classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PreprocessorKeyword | Gets the PreprocessorKeyword classification type.
Public property | String | Gets the String classification type.
Public property | VBXmlLiteral | Gets the VBXmlLiteral classification type.
Public property | XmlDocumentationComment | Gets the XmlDocumentationComment classification type.
Public property | XmlDocumentationTag | Gets the XmlDocumentationTag classification type.
Top
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Comment Property

IDotNetClassificationTypeProviderComment Property

Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Comment { get; }
ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.CSharpVerbatimString Property

IDotNetClassificationTypeProviderCSharpVerbatimString Property

Gets the CSharpVerbatimString classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType CSharpVerbatimString { get; }
ReadOnly Property CSharpVerbatimString As IClassificationType
    Get

Property Value

Type: IClassificationType
The CSharpVerbatimString classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Identifier Property

IDotNetClassificationTypeProviderIdentifier Property

Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Identifier { get; }
ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Keyword Property

IDotNetClassificationTypeProviderKeyword Property

Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Keyword { get; }
ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Number Property

IDotNetClassificationTypeProviderNumber Property

Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Number { get; }
ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Operator Property

IDotNetClassificationTypeProviderOperator Property

Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Operator { get; }
ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.PreprocessorKeyword Property

IDotNetClassificationTypeProviderPreprocessorKeyword Property

Gets the PreprocessorKeyword classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType PreprocessorKeyword { get; }
ReadOnly Property PreprocessorKeyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The PreprocessorKeyword classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.String Property

IDotNetClassificationTypeProviderString Property

Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType String { get; }
ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.VBXmlLiteral Property

IDotNetClassificationTypeProviderVBXmlLiteral Property

Gets the VBXmlLiteral classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType VBXmlLiteral { get; }
ReadOnly Property VBXmlLiteral As IClassificationType
    Get

Property Value

Type: IClassificationType
The VBXmlLiteral classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.XmlDocumentationComment Property

IDotNetClassificationTypeProviderXmlDocumentationComment Property

Gets the XmlDocumentationComment classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlDocumentationComment { get; }
ReadOnly Property XmlDocumentationComment As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDocumentationComment classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.XmlDocumentationTag Property

IDotNetClassificationTypeProviderXmlDocumentationTag Property

Gets the XmlDocumentationTag classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlDocumentationTag { get; }
ReadOnly Property XmlDocumentationTag As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDocumentationTag classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext Interface

Provides the base requirements for information about a .NET language context of a certain offset within an ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDotNetContext
Public Interface IDotNetContext

The IDotNetContext type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentIndex | Gets the index of the current argument, if known, when the context is for the containing invocation.
Public property | ArgumentListSnapshotOffset | Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
Public property | ArgumentSnapshotOffset | Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
Public property | ContainingAstNode | Gets the IAstNode that contains the SnapshotOffset.
Public property | ContainingAstTypeDeclaration | Gets the AST TypeDeclaration that contains the SnapshotOffset, if any.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | Kind | Gets the DotNetContextKind indicating the kind of context.
Public property | Location | Gets an optional IDotNetContextLocation that provides more location information about the context.
Public property | ProjectAssembly | Gets the IProjectAssembly with which this context is associated.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetExpression | Gets the target AST Expression for the context, if known.
Public property | TargetSnapshotOffset | Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.
Top
Methods
 | Name | Description
Public method | Resolve | Uses the IResolver on the ProjectAssembly to return an IResolverResultSet.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext Properties

The IDotNetContext type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentIndex | Gets the index of the current argument, if known, when the context is for the containing invocation.
Public property | ArgumentListSnapshotOffset | Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
Public property | ArgumentSnapshotOffset | Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
Public property | ContainingAstNode | Gets the IAstNode that contains the SnapshotOffset.
Public property | ContainingAstTypeDeclaration | Gets the AST TypeDeclaration that contains the SnapshotOffset, if any.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | Kind | Gets the DotNetContextKind indicating the kind of context.
Public property | Location | Gets an optional IDotNetContextLocation that provides more location information about the context.
Public property | ProjectAssembly | Gets the IProjectAssembly with which this context is associated.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetExpression | Gets the target AST Expression for the context, if known.
Public property | TargetSnapshotOffset | Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.
Top
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ArgumentIndex Property

IDotNetContextArgumentIndex Property

Gets the index of the current argument, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<int> ArgumentIndex { get; }
ReadOnly Property ArgumentIndex As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The index of the current argument, if known, when the context is for the containing invocation.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ArgumentListSnapshotOffset Property

IDotNetContextArgumentListSnapshotOffset Property

Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> ArgumentListSnapshotOffset { get; }
ReadOnly Property ArgumentListSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ArgumentSnapshotOffset Property

IDotNetContextArgumentSnapshotOffset Property

Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> ArgumentSnapshotOffset { get; }
ReadOnly Property ArgumentSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ContainingAstNode Property

IDotNetContextContainingAstNode Property

Gets the IAstNode that contains the SnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode ContainingAstNode { get; }
ReadOnly Property ContainingAstNode As IAstNode
    Get

Property Value

Type: IAstNode
The IAstNode that contains the SnapshotOffset.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ContainingAstTypeDeclaration Property

IDotNetContextContainingAstTypeDeclaration Property

Gets the AST TypeDeclaration that contains the SnapshotOffset, if any.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TypeDeclaration ContainingAstTypeDeclaration { get; }
ReadOnly Property ContainingAstTypeDeclaration As TypeDeclaration
    Get

Property Value

Type: TypeDeclaration
The AST TypeDeclaration that contains the SnapshotOffset, if any.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.InitializationSnapshotRange Property

IDotNetContextInitializationSnapshotRange Property

Gets the TextSnapshotRange with which the context was initialized.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotRange> InitializationSnapshotRange { get; }
ReadOnly Property InitializationSnapshotRange As Nullable(Of TextSnapshotRange)
    Get

Property Value

Type: Nullable TextSnapshotRange
The TextSnapshotRange with which the context was initialized.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.Kind Property

IDotNetContextKind Property

Gets the DotNetContextKind indicating the kind of context.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DotNetContextKind Kind { get; }
ReadOnly Property Kind As DotNetContextKind
    Get

Property Value

Type: DotNetContextKind
The DotNetContextKind indicating the kind of context.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.Location Property

IDotNetContextLocation Property

Gets an optional IDotNetContextLocation that provides more location information about the context.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDotNetContextLocation Location { get; }
ReadOnly Property Location As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
An optional IDotNetContextLocation that provides more location information about the context.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ProjectAssembly Property

IDotNetContextProjectAssembly Property

Gets the IProjectAssembly with which this context is associated.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssembly ProjectAssembly { get; }
ReadOnly Property ProjectAssembly As IProjectAssembly
    Get

Property Value

Type: IProjectAssembly
The IProjectAssembly with which this context is associated.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.SnapshotOffset Property

IDotNetContextSnapshotOffset Property

Gets the TextSnapshotOffset for which this context was created.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotOffset SnapshotOffset { get; }
ReadOnly Property SnapshotOffset As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
The TextSnapshotOffset for which this context was created.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.TargetExpression Property

IDotNetContextTargetExpression Property

Gets the target AST Expression for the context, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Expression TargetExpression { get; }
ReadOnly Property TargetExpression As Expression
    Get

Property Value

Type: Expression
The target AST Expression for the context, if known.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.TargetSnapshotOffset Property

IDotNetContextTargetSnapshotOffset Property

Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> TargetSnapshotOffset { get; }
ReadOnly Property TargetSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset, if known, against which to use as context for the resolver.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext Methods

The IDotNetContext type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Uses the IResolver on the ProjectAssembly to return an IResolverResultSet.
Top
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.Resolve Method

IDotNetContextResolve Method

Uses the IResolver on the ProjectAssembly to return an IResolverResultSet.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IResolverResultSet Resolve()
Function Resolve As IResolverResultSet

Return Value

Type: IResolverResultSet
The IResolverResultSet that was returned by the resolver.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContextLocation Interface

Provides the base requirements for an IDotNetContext location, that determines what sort of resolver results are permitted.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDotNetContextLocation
Public Interface IDotNetContextLocation

The IDotNetContextLocation type exposes the following members.

Methods
 | Name | Description
Public method | IsAllowed | Returns whether the specified IResolverResult is allowed within the context location.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContextLocation Methods

The IDotNetContextLocation type exposes the following members.

Methods
 | Name | Description
Public method | IsAllowed | Returns whether the specified IResolverResult is allowed within the context location.
Top
See Also

Reference

IDotNetContextLocation Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContextLocation.IsAllowed Method

IDotNetContextLocationIsAllowed Method

Returns whether the specified IResolverResult is allowed within the context location.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAllowed(
    IResolverResult result
)
Function IsAllowed (
    result As IResolverResult
) As Boolean

Parameters

result
Type: ActiproSoftware.Text.Languages.DotNet.ResolutionIResolverResult
The IResolverResult to examine.

Return Value

Type: Boolean
true if the specified IResolverResult is allowed within the context location; otherwise, false.
See Also

Reference

IDotNetContextLocation Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetParseData Interface

Provides the base requirements of an object that stores the results of a .NET language parsing operation.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDotNetParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IDotNetParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IDotNetParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | PreprocessorDirectives | Gets the collection of preprocessor directives.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParseData


IDotNetParseData Properties

The IDotNetParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | PreprocessorDirectives | Gets the collection of preprocessor directives.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

IDotNetParseData Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetParseData.PreprocessorDirectives Property

IDotNetParseDataPreprocessorDirectives Property

Gets the collection of preprocessor directives.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<PreprocessorDirective> PreprocessorDirectives { get; }
ReadOnly Property PreprocessorDirectives As IList(Of PreprocessorDirective)
    Get

Property Value

Type: IList PreprocessorDirective
The collection of preprocessor directives.
See Also

Reference

IDotNetParseData Interface
ActiproSoftware.Text.Languages.DotNet Namespace


ActiproSoftware.Text.Languages.DotNet.Ast Namespace

Contains the types related to ASTs for a .NET syntax language.
Interfaces
 | Interface | Description
Public interface | IDecoratedMember | Provides the base requirements for a type or type member that has attributes and modifiers.
Public interface | INamedTypeMember | Provides the base requirements for a type member that has a name.
Enumerations
 | Enumeration | Description
Public enumeration | AccessorKind | Specifies the kind of accessor.
Public enumeration | AttributeTargetKind | Specifies the kind of attribute target.
Public enumeration | ConstructorInitializerKind | Specifies the type of constructor initializer.
Public enumeration | ContinueKind | Specifies the type of block to continue within an ContinueStatement.
Public enumeration | ExitKind | Specifies the type of block to exit within an ExitStatement.
Public enumeration | InvocationExpressionKind | Specifies the kind of an invocation expression.
Public enumeration | LiteralExpressionKind | Specifies the type of literal expression.
Public enumeration | MemberAccessKind | Specifies the kind of a member access.
Public enumeration | Modifiers | Specifies the modifiers for a type or member.
Public enumeration | OperatorKind | Specifies the kind of an operator.
Public enumeration | OrderingDirection | Specifies a sort order for an query expression ordering.
Public enumeration | ParameterModifiers | Specifies the modifiers for a parameter.
Public enumeration | TypeDeclarationKind | Specifies the kind of TypeDeclaration.
Public enumeration | TypeMemberDeclarationKind | Specifies the kind of TypeMemberDeclaration.
Public enumeration | VariableDeclaratorKind | Specifies the kind of VariableDeclarator.
Public enumeration | VarianceAnnotation | Specifies the variance annotation for a type parameter.


AccessorKind Enumeration

Specifies the kind of accessor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum AccessorKind
Public Enumeration AccessorKind
Members
Member name | Value | Description
Get | 0 | A get property accessor.
Set | 1 | A set property accessor.
Add | 2 | An add handler event accessor.
Remove | 3 | A remove handler event accessor.
Raise | 4 | A raise event accessor.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind Enumeration

Specifies the kind of attribute target.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum AttributeTargetKind
Public Enumeration AttributeTargetKind
Members
Member name | Value | Description
Default | 0 | No specific attribute target.
Assembly | 1 | An assembly.
Module | 2 | A module.
Field | 3 | A field.
Event | 4 | An event.
Method | 5 | A method.
Parameter | 6 | A parameter.
Property | 7 | A property.
Return | 8 | A return value.
Type | 9 | A type.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ConstructorInitializerKind Enumeration

Specifies the type of constructor initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ConstructorInitializerKind
Public Enumeration ConstructorInitializerKind
Members
Member name | Value | Description
None | 0 | No constructor initializer.
This | 1 | This reference.
Base | 2 | Base reference.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ContinueKind Enumeration

Specifies the type of block to continue within an ContinueStatement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ContinueKind
Public Enumeration ContinueKind
Members
Member name | Value | Description
Default | 0 | The direct containing block.
Do | 1 | Do loop.
For | 2 | For loop.
While | 3 | While loop.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind Enumeration

Specifies the type of block to exit within an ExitStatement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ExitKind
Public Enumeration ExitKind
Members
Member name | Value | Description
Default | 0 | The direct containing block.
Do | 1 | Do loop.
For | 2 | For loop.
While | 3 | While loop.
Switch | 4 | Switch (Select in VB) statement.
Try | 5 | Try statement.
TypeMember | 6 | Method or property.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember Interface

Provides the base requirements for a type or type member that has attributes and modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDecoratedMember : IAstNode
Public Interface IDecoratedMember
    Inherits IAstNode

The IDecoratedMember type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from IAstNode.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from IAstNode.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from IAstNode.)
Public property | Id | Gets an integer value that identifies the type of AST node, if known. (Inherited from IAstNode.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from IAstNode.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from IAstNode.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from IAstNode.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from IAstNode.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from IAstNode.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from IAstNode.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember Properties

The IDecoratedMember type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from IAstNode.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from IAstNode.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from IAstNode.)
Public property | Id | Gets an integer value that identifies the type of AST node, if known. (Inherited from IAstNode.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from IAstNode.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from IAstNode.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from IAstNode.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from IAstNode.)
Top
See Also

Reference

IDecoratedMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember.AttributeSections Property

IDecoratedMemberAttributeSections Property

Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<AttributeSection> AttributeSections { get; }
ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

IDecoratedMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember.Modifiers Property

IDecoratedMemberModifiers Property

Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Modifiers Modifiers { get; set; }
Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.
See Also

Reference

IDecoratedMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember Methods

The IDecoratedMember type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from IAstNode.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from IAstNode.)
Top
See Also

Reference

IDecoratedMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


INamedTypeMember Interface

Provides the base requirements for a type member that has a name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface INamedTypeMember : IAstNode
Public Interface INamedTypeMember
    Inherits IAstNode

The INamedTypeMember type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from IAstNode.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from IAstNode.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from IAstNode.)
Public property | Id | Gets an integer value that identifies the type of AST node, if known. (Inherited from IAstNode.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from IAstNode.)
Public property | Name | Gets or sets the member name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from IAstNode.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from IAstNode.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from IAstNode.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from IAstNode.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from IAstNode.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


INamedTypeMember Properties

The INamedTypeMember type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from IAstNode.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from IAstNode.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from IAstNode.)
Public property | Id | Gets an integer value that identifies the type of AST node, if known. (Inherited from IAstNode.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from IAstNode.)
Public property | Name | Gets or sets the member name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from IAstNode.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from IAstNode.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from IAstNode.)
Top
See Also

Reference

INamedTypeMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


INamedTypeMember.Name Property

INamedTypeMemberName Property

Gets or sets the member name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
SimpleName Name { get; set; }
Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The member name.
See Also

Reference

INamedTypeMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


INamedTypeMember Methods

The INamedTypeMember type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from IAstNode.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from IAstNode.)
Top
See Also

Reference

INamedTypeMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


InvocationExpressionKind Enumeration

Specifies the kind of an invocation expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum InvocationExpressionKind
Public Enumeration InvocationExpressionKind
Members
Member name | Value | Description
Default | 0 | The standard type of invocation.
NullConditional | 1 | A null-conditional check is made on the target expression, and if it passes, a standard type of invocation is used.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind Enumeration

Specifies the type of literal expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LiteralExpressionKind
Public Enumeration LiteralExpressionKind
Members
Member name | Value | Description
None | 0 | No kind indicated.
Null | 1 | A null value.
Boolean | 2 | A boolean.
DecimalInteger | 3 | A decimal integer.
HexadecimalInteger | 4 | A hexadecimal integer.
OctalInteger | 5 | An octal integer.
Real | 6 | A real number.
Character | 7 | A character.
String | 8 | A string of characters.
VerbatimString | 9 | A verbatim string.
InterpolatedString | 10 | An interpolated string.
InterpolatedVerbatimString | 11 | An interpolated verbatim string.
DateTime | 12 | A date/time.
Xml | 13 | A XML fragment.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind Enumeration

Specifies the kind of a member access.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MemberAccessKind
Public Enumeration MemberAccessKind
Members
Member name | Value | Description
Default | 0 | The standard type of access. When used on VB's XML elements, this also indicates element access.
NullConditional | 1 | A null-conditional check is made on the target expression, and if it passes, a standard type of access is used.
ThisType | 2 | The member is on the current instance's type, and overridden/shadowed members in derived classes are ignored. In VB: MyClass
BaseType | 3 | The member is on the current instance's base type, and overridden/shadowed members in derived classes are ignored. In C#: base; In VB: MyBase
Global | 4 | Accesses the root global namespace. In VB: Global
PointerDereference | 5 | Pointer dereference (C# only).
Dictionary | 6 | Dictionary. In VB: element!param
XmlAttribute | 7 | XML attribute access. In VB: element.@attributename
XmlDescendant | 8 | XML descendant access. In VB: element...<childelement>
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers Enumeration

Specifies the modifiers for a type or member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum Modifiers
Public Enumeration Modifiers
Members
Member name | Value | Description
None | 0 | No modifier.
Private | 1 | Private access. Code within the type that declares a private element, including code within contained types, can access the element.
Assembly | 2 | Internal (also known as Internal or Friend) access. Code within the assembly that declares an assembly element can access it.
Family | 4 | Protected access. Code within the class that declares a family (also known as Protected) element, or a class derived from it, can access the element.
Public | 8 | Public access. Any code that can see a public element can access it.
FamilyOrAssembly | 6 | Family or assembly access. This is a union of Family and Assembly access. Code within the same class or the same assembly as the element, or within any class derived from the element's class, can access it.
AccessMask | 15 | The bitmask for access modifiers.
Abstract | 256 | Defines a class or member that must be inherited. Represents MustOverride and MustInherit in Visual Basic.
Async | 512 | Specifies that the target procedure is asynchronously executed.
Default | 1024 | Identifies a property as the default property of its class, structure, or interface. Used in Visual Basic only.
External | 2048 | Defines a method that is implemented externally.
Final | 4096 | Defines a class or member that cannot be overridden (also known as Sealed). Represents NotInheritable and NotOverridable in Visual Basic.
Iterator | 8192 | Specifies that a property or procedure that contains an iterator. Used in Visual Basic only.
Narrowing | 16384 | Indicates that a conversion operator (CType) converts a class or structure to a type that might not be able to hold some of the possible values of the original class or structure. Used in Visual Basic only.
New | 32768 | Hides a defined member in a base class. Represents Shadows in Visual Basic.
Partial | 65536 | Defines the type as a partial type which is defined in multiple parts.
Overloads | 131072 | Specifies that a property or procedure redeclares one or more existing properties or procedures with the same name. Used in Visual Basic only.
Override | 262144 | Defines a member that overrides a base abstract or virtual implementation. Represents Overrides in Visual Basic.
ReadOnly | 524288 | Defines a read-only member.
Static | 1048576 | Defines a static member. Represents Shared in Visual Basic.
Unsafe | 2097152 | Defines an unsafe context. Used in C# only.
Virtual | 4194304 | Defines a member that can be overridden. Represents Overridable in Visual Basic.
Volatile | 8388608 | Defines a field that can be modified by multiple concurrently executing threads. Used in C# only.
Widening | 16777216 | Indicates that a conversion operator (CType) converts a class or structure to a type that can hold all possible values of the original class or structure. Used in Visual Basic only.
WithEvents | 33554432 | Specifies that one or more declared member variables refer to an instance of a class that can raise events. Used in Visual Basic only.
WriteOnly | 67108864 | Specifies that a property can be written but not read. Used in Visual Basic only.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind Enumeration

Specifies the kind of an operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum OperatorKind
Public Enumeration OperatorKind
Members
Member name | Value | Description
None | 0 | No valid operator kind.
Addition | 1 | An addition operator.
Subtraction | 2 | A subtraction operator.
Multiplication | 3 | A multiplication operator.
Division | 4 | A division operator.
Modulus | 5 | A modulus operator.
BitwiseAnd | 6 | A bitwise AND operator.
BitwiseOr | 7 | A bitwise OR operator.
ExclusiveOr | 8 | A bitwise XOR operator.
Negation | 9 | A negation operator.
OnesComplement | 10 | A bitwise complement operator.
LessThan | 11 | A less than operator.
GreaterThan | 12 | A greater than operator.
PreIncrement | 13 | An pre-increment operator.
PreDecrement | 14 | An pre-decrement operator.
PostIncrement | 15 | An post-increment operator.
PostDecrement | 16 | An post-decrement operator.
LeftShift | 17 | A left shift operator.
RightShift | 18 | A right shift operator.
ValueEquality | 19 | A value equality operator.
ValueInequality | 20 | A value inequality operator.
LessThanOrEqual | 21 | A less than or equal operator.
GreaterThanOrEqual | 22 | A greater than or equal operator.
IsTrue | 23 | A true operator.
IsFalse | 24 | A false operator.
ImplicitCast | 25 | An implicit cast operator.
ExplicitCast | 26 | An explicit cast operator.
ConditionalOr | 27 | A conditional OR binary operator.
ConditionalAnd | 28 | A conditional AND binary operator.
PointerIndirection | 29 | A pointer indirection operator.
AddressOf | 30 | An address-of operator.
NullCoalescing | 31 | A null coalescing operator.
ReferenceEquality | 32 | A reference equality operator. Used in Visual Basic only (Is).
ReferenceInequality | 33 | A reference inequality operator. Used in Visual Basic only (IsNot).
WildcardPatternMatch | 34 | A string wildcard pattern match operator. Used in Visual Basic only (Like).
StringConcatenation | 35 | A concatenation operator (&). Used in Visual Basic only.
IntegerDivision | 36 | An integer division operator. Used in Visual Basic only (\).
Exponentiation | 37 | An exponentiation operator. Used in Visual Basic only (^).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OrderingDirection Enumeration

Specifies a sort order for an query expression ordering.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum OrderingDirection
Public Enumeration OrderingDirection
Members
Member name | Value | Description
Ascending | 0 | Ascending order.
Descending | 1 | Descending order.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers Enumeration

Specifies the modifiers for a parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ParameterModifiers
Public Enumeration ParameterModifiers
Members
Member name | Value | Description
None | 0 | No modifier.
ByReference | 1 | A pass-by-reference parameter.
Output | 2 | An output parameter.
ParameterArray | 4 | The parameter is a parameter array.
Optional | 8 | The parameter is optional.
Extension | 16 | An extension method target parameter.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind Enumeration

Specifies the kind of TypeDeclaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TypeDeclarationKind
Public Enumeration TypeDeclarationKind
Members
Member name | Value | Description
Class | 0 | A class.
Delegate | 1 | A delegate.
Enumeration | 2 | An enumeration.
Interface | 3 | An interface.
Structure | 4 | A structure.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind Enumeration

Specifies the kind of TypeMemberDeclaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TypeMemberDeclarationKind
Public Enumeration TypeMemberDeclarationKind
Members
Member name | Value | Description
Constructor | 0 | A constructor.
EnumerationMember | 1 | An enumeration member.
Event | 2 | An event.
Field | 3 | A field.
FixedSizeBuffer | 4 | A fixed-size buffer.
InterfaceEvent | 5 | An interface event.
InterfaceMethod | 6 | An interface method.
InterfaceProperty | 7 | An interface property.
Method | 8 | A method.
Operator | 9 | An operator.
Property | 10 | A property.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VariableDeclaratorKind Enumeration

Specifies the kind of VariableDeclarator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum VariableDeclaratorKind
Public Enumeration VariableDeclaratorKind
Members
Member name | Value | Description
Default | 0 | A normal variable.
Constant | 1 | A constant variable.
Static | 2 | A static variable that retains its value between containing member invocations (VB only).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VarianceAnnotation Enumeration

Specifies the variance annotation for a type parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum VarianceAnnotation
Public Enumeration VarianceAnnotation
Members
Member name | Value | Description
Invariant | 0 | No variance annotation, the default value.
Covariant | 1 | The matching type can be more derived than what is defined (marked in C# via out and VB via Out).
Contravariant | 2 | The matching type can be less derived than what is defined (marked in C# via in and VB via In).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace

Contains the implementation types related to ASTs for a .NET syntax language.
Classes
 | Class | Description
Public class | AccessorBody | Represents an accessor body.
Public class | AccessorDeclaration | Represents an accessor declaration.
Public class | AddressOfExpression | Represents an address of expression (VB only).
Public class | AggregateQueryOperator | Represents an aggregate query operator (VB only).
Public class | AnonymousMethodExpression | Represents an anonymous method expression.
Public class | Argument | Represents an argument.
Public class | ArrayEraseStatement | Represents an array erase statement.
Public class | ArrayReallocateClause | Represents an array reallocate clause.
Public class | ArrayReallocateStatement | Represents an array reallocate statement.
Public class | AssignmentExpression | Represents an assignment expression.
Public class | Attribute | Represents an attribute.
Public class | AttributeArgument | Represents an attribute argument.
Public class | AttributeSection | Represents an attribute section.
Public class | AwaitExpression | Represents an await expression.
Public class | BinaryOperatorExpression | Represents a binary operator expression.
Public class | BlockStatement | Represents a block statement.
Public class | BreakStatement | Represents a break statement.
Public class | CastExpression | Represents a cast expression.
Public class | CatchClause | Represents a catch clause.
Public class | CheckedExpression | Represents a checked expression.
Public class | CheckedStatement | Represents a checked statement.
Public class | ClassBody | Represents a class body.
Public class | ClassDeclaration | Represents a class declaration.
Public class | CompilationUnit | Represents a compilation unit.
Public class | CompilationUnitOption | Represents a compilation unit option.
Public class | ConditionalExpression | Represents a conditional expression.
Public class | ConstructorBody | Represents a constructor body.
Public class | ConstructorDeclaration | Represents a constructor declaration.
Public class | ContinueStatement | Represents a continue statement.
Public class | DefaultValueExpression | Represents a default value expression.
Public class | DelegateDeclaration | Represents a delegate declaration.
Public class | DistinctQueryOperator | Represents a distinct query operator (VB only).
Public class | DocumentationComment | Represents a documentation comment.
Public class | DoStatement | Represents a do statement.
Public class | DotNetAstNodeId | Contains the AST node IDs for the .NET language.
Public class | ElseIfSection | Represents an else if section (VB only).
Public class | EndStatement | Represents an end statement.
Public class | EnumerationBody | Represents an enumeration body.
Public class | EnumerationDeclaration | Represents an enumeration declaration.
Public class | EnumerationMemberDeclaration | Represents an enumeration member declaration.
Public class | EventBody | Represents an event body.
Public class | EventDeclaration | Represents an event declaration.
Public class | ExitStatement | Represents an exit statement.
Public class | Expression | Represents an expression.
Public class | ExpressionStatement | Represents an expression statement.
Public class | ExternalAliasDirective | Represents an external alias directive.
Public class | ExternalAliasDirectiveSection | Represents an external alias directive section.
Public class | FieldDeclaration | Represents a field declaration.
Public class | FixedSizeBufferDeclaration | Represents a fixed size buffer declaration.
Public class | FixedSizeBufferDeclarator | Represents a fixed size buffer declarator.
Public class | FixedStatement | Represents a fixed statement.
Public class | ForEachStatement | Represents a for each statement.
Public class | ForStatement | Represents a for statement.
Public class | FromQueryOperator | Represents a from query operator.
Public class | GoToStatement | Represents a go to statement.
Public class | GroupQueryOperator | Represents a group query operator.
Public class | IfStatement | Represents an if statement.
Public class | InitializerExpression | Represents an initializer expression.
Public class | InstanceExpression | Represents an instance expression.
Public class | InterfaceAccessorDeclaration | Represents an interface accessor declaration.
Public class | InterfaceBody | Represents an interface body.
Public class | InterfaceDeclaration | Represents an interface declaration.
Public class | InterfaceEventDeclaration | Represents an interface event declaration.
Public class | InterfaceMemberDeclaration | Represents an interface member declaration.
Public class | InterfaceMethodDeclaration | Represents an interface method declaration.
Public class | InterfacePropertyDeclaration | Represents an interface property declaration.
Public class | InvocationExpression | Represents an invocation expression.
Public class | IsTypeOfExpression | Represents an is type of expression.
Public class | JoinQueryOperator | Represents a join query operator.
Public class | LabeledStatement | Represents a labeled statement.
Public class | LambdaExpression | Represents a lambda expression.
Public class | LetQueryOperator | Represents a let query operator.
Public class | LiteralExpression | Represents a literal expression.
Public class | LocalVariableDeclaration | Represents a local variable declaration.
Public class | LockStatement | Represents a lock statement.
Public class | MemberAccess | Represents a member access.
Public class | MethodBody | Represents a method body.
Public class | MethodDeclaration | Represents a method declaration.
Public class | NameOfExpression | Represents a name of expression.
Public class | NamespaceBody | Represents a namespace body.
Public class | NamespaceDeclaration | Represents a namespace declaration.
Public class | ObjectCreationExpression | Represents an object creation expression.
Public class | OperatorBody | Represents an operator body.
Public class | OperatorDeclaration | Represents an operator declaration.
Public class | OrderByQueryOperator | Represents an order by query operator.
Public class | Ordering | Represents an ordering.
Public class | ParameterDeclaration | Represents a parameter declaration.
Public class | ParenthesizedExpression | Represents a parenthesized expression.
Public class | PreprocessorDirective | Represents a preprocessor directive.
Public class | PropertyBody | Represents a property body.
Public class | PropertyDeclaration | Represents a property declaration.
Public class | QualifiedName | Represents a qualified name.
Public class | QueryExpression | Represents a query expression.
Public class | QueryOperator | Represents a query operator.
Public class | RangeVariableDeclaration | Represents a range variable declaration.
Public class | RangeVariableDeclarator | Represents a range variable declarator.
Public class | RegionPreprocessorDirective | Represents a region preprocessor directive.
Public class | ReturnStatement | Represents a return statement.
Public class | ReturnTypeDeclaration | Represents a return type declaration.
Public class | ReturnTypeExpression | Represents a return type expression (used by resolver).
Public class | SelectQueryOperator | Represents a select query operator.
Public class | SimpleName | Represents a simple name.
Public class | SizeOfExpression | Represents a size of expression.
Public class | SkipQueryOperator | Represents a skip query operator (VB only).
Public class | SkipWhileQueryOperator | Represents a skip while query operator (VB only).
Public class | StackAllocationInitializer | Represents a stack allocation initializer.
Public class | Statement | Represents a statement.
Public class | StopStatement | Represents a stop statement.
Public class | StructureBody | Represents a structure body.
Public class | StructureDeclaration | Represents a structure declaration.
Public class | SwitchSection | Represents a switch section.
Public class | SwitchStatement | Represents a switch statement.
Public class | TakeQueryOperator | Represents a take query operator (VB only).
Public class | TakeWhileQueryOperator | Represents a take while query operator (VB only).
Public class | ThrowStatement | Represents a throw statement.
Public class | TryCastExpression | Represents a try cast expression.
Public class | TryStatement | Represents a try statement.
Public class | TypeDeclaration | Represents a type declaration.
Public class | TypeMemberDeclaration | Represents a type member declaration.
Public class | TypeOfExpression | Represents a type of expression.
Public class | TypeParameter | Represents a type parameter.
Public class | UnaryOperatorExpression | Represents an unary operator expression.
Public class | UncheckedExpression | Represents an unchecked expression.
Public class | UncheckedStatement | Represents an unchecked statement.
Public class | UnsafeStatement | Represents an unsafe statement.
Public class | UnstructuredErrorHandlerStatement | Represents an unstructured error handler statement.
Public class | UnstructuredErrorResumeStatement | Represents an unstructured error resume statement.
Public class | UnstructuredErrorThrowStatement | Represents an unstructured error throw statement.
Public class | UsingDirective | Represents an using directive.
Public class | UsingDirectiveSection | Represents an using directive section.
Public class | UsingStatement | Represents an using statement.
Public class | VariableDeclarationExpression | Represents a variable declaration expression.
Public class | VariableDeclarator | Represents a variable declarator.
Public class | WhereQueryOperator | Represents a where query operator.
Public class | WhileStatement | Represents a while statement.
Public class | WithStatement | Represents a with statement (VB only).
Public class | WithTargetExpression | Represents a with target expression (VB only).
Public class | XmlNamespaceExpression | Represents a xml namespace expression (VB only).
Public class | YieldStatement | Represents a yield statement.


AccessorBody Class

Represents an accessor body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAccessorBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AccessorBody : AstNodeBase
Public Class AccessorBody
    Inherits AstNodeBase

The AccessorBody type exposes the following members.

Constructors
 | Name | Description
Public method | AccessorBody | Initializes a new instance of the AccessorBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody Constructor

Initializes a new instance of the AccessorBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AccessorBody()
Public Sub New
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody Properties

The AccessorBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody.HasStatements Property

AccessorBodyHasStatements Property

Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody.Id Property

AccessorBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody.Statements Property

AccessorBodyStatements Property

Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody Methods

The AccessorBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody.GetChildrenEnumerator Method

AccessorBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration Class

Represents an accessor declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAccessorDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AccessorDeclaration : AstNodeBase
Public Class AccessorDeclaration
    Inherits AstNodeBase

The AccessorDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | AccessorDeclaration | Initializes a new instance of the AccessorDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration Constructor

Initializes a new instance of the AccessorDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AccessorDeclaration()
Public Sub New
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration Properties

The AccessorDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.AttributeSections Property

AccessorDeclarationAttributeSections Property

Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Body Property

AccessorDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AccessorBody Body { get; set; }
Public Property Body As AccessorBody
    Get
    Set

Property Value

Type: AccessorBody
The body.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.HasAttributeSections Property

AccessorDeclarationHasAttributeSections Property

Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.HasParameters Property

AccessorDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Id Property

AccessorDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Kind Property

AccessorDeclarationKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AccessorKind Kind { get; set; }
Public Property Kind As AccessorKind
    Get
    Set

Property Value

Type: AccessorKind
The kind.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Modifiers Property

AccessorDeclarationModifiers Property

Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Parameters Property

AccessorDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration Methods

The AccessorDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.GetChildrenEnumerator Method

AccessorDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression Class

Represents an address of expression (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAddressOfExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AddressOfExpression : Expression
Public Class AddressOfExpression
    Inherits Expression

The AddressOfExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AddressOfExpression | Initializes a new instance of the AddressOfExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression Constructor

Initializes a new instance of the AddressOfExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AddressOfExpression()
Public Sub New
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression Properties

The AddressOfExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression.ChildExpression Property

AddressOfExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression.Id Property

AddressOfExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression Methods

The AddressOfExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression.GetChildrenEnumerator Method

AddressOfExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator Class

Represents an aggregate query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAggregateQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AggregateQueryOperator : QueryOperator
Public Class AggregateQueryOperator
    Inherits QueryOperator

The AggregateQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | AggregateQueryOperator | Initializes a new instance of the AggregateQueryOperator class
Top
Properties
 | Name | Description
Public property | ChildQueryOperators | Gets the child query operators.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarator | Gets or sets the declarator.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildQueryOperators | Returns whether the ChildQueryOperators collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator Constructor

Initializes a new instance of the AggregateQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AggregateQueryOperator()
Public Sub New
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator Properties

The AggregateQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | ChildQueryOperators | Gets the child query operators.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarator | Gets or sets the declarator.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildQueryOperators | Returns whether the ChildQueryOperators collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.ChildQueryOperators Property

AggregateQueryOperatorChildQueryOperators Property

Gets the child query operators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QueryOperator> ChildQueryOperators { get; }
Public ReadOnly Property ChildQueryOperators As IList(Of QueryOperator)
    Get

Property Value

Type: IList QueryOperator
The child query operators.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.Declarator Property

AggregateQueryOperatorDeclarator Property

Gets or sets the declarator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclarator Declarator { get; set; }
Public Property Declarator As RangeVariableDeclarator
    Get
    Set

Property Value

Type: RangeVariableDeclarator
The declarator.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.HasChildQueryOperators Property

AggregateQueryOperatorHasChildQueryOperators Property

Returns whether the ChildQueryOperators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasChildQueryOperators { get; }
Public ReadOnly Property HasChildQueryOperators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.Id Property

AggregateQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.Projection Property

AggregateQueryOperatorProjection Property

Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator Methods

The AggregateQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.GetChildrenEnumerator Method

AggregateQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression Class

Represents an anonymous method expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAnonymousMethodExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AnonymousMethodExpression : Expression
Public Class AnonymousMethodExpression
    Inherits Expression

The AnonymousMethodExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AnonymousMethodExpression | Initializes a new instance of the AnonymousMethodExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression Constructor

Initializes a new instance of the AnonymousMethodExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AnonymousMethodExpression()
Public Sub New
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression Properties

The AnonymousMethodExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.HasParameters Property

AnonymousMethodExpressionHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.HasStatements Property

AnonymousMethodExpressionHasStatements Property

Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.Id Property

AnonymousMethodExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.Modifiers Property

AnonymousMethodExpressionModifiers Property

Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.Parameters Property

AnonymousMethodExpressionParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.Statements Property

AnonymousMethodExpressionStatements Property

Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression Methods

The AnonymousMethodExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.GetChildrenEnumerator Method

AnonymousMethodExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Class

Represents an argument.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArgument

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Argument : AstNodeBase
Public Class Argument
    Inherits AstNodeBase

The Argument type exposes the following members.

Constructors
 | Name | Description
Public method | Argument | Initializes a new instance of the Argument class.
Public method | Argument(Expression) | Initializes a new instance of the Argument class.
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Constructor

Overload List
 | Name | Description
Public method | Argument | Initializes a new instance of the Argument class.
Public method | Argument(Expression) | Initializes a new instance of the Argument class.
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Constructor

Initializes a new instance of the Argument class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Argument()
Public Sub New
See Also

Reference

Argument Class
Argument Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Constructor (Expression)

Initializes a new instance of the Argument class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Argument(
    Expression expression
)
Public Sub New (
    expression As Expression
)

Parameters

expression
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
The expression.
See Also

Reference

Argument Class
Argument Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Properties

The Argument type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.Expression Property

ArgumentExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.Id Property

ArgumentId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.Modifiers Property

ArgumentModifiers Property

Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParameterModifiers Modifiers { get; set; }
Public Property Modifiers As ParameterModifiers
    Get
    Set

Property Value

Type: ParameterModifiers
The modifiers.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.Name Property

ArgumentName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Methods

The Argument type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.GetChildrenEnumerator Method

ArgumentGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement Class

Represents an array erase statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayEraseStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ArrayEraseStatement : Statement
Public Class ArrayEraseStatement
    Inherits Statement

The ArrayEraseStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayEraseStatement | Initializes a new instance of the ArrayEraseStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasVariableNames | Returns whether the VariableNames collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableNames | Gets the variable names.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement Constructor

Initializes a new instance of the ArrayEraseStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ArrayEraseStatement()
Public Sub New
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement Properties

The ArrayEraseStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasVariableNames | Returns whether the VariableNames collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableNames | Gets the variable names.
Top
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement.HasVariableNames Property

ArrayEraseStatementHasVariableNames Property

Returns whether the VariableNames collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasVariableNames { get; }
Public ReadOnly Property HasVariableNames As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement.Id Property

ArrayEraseStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement.VariableNames Property

ArrayEraseStatementVariableNames Property

Gets the variable names.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> VariableNames { get; }
Public ReadOnly Property VariableNames As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The variable names.
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement Methods

The ArrayEraseStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement.GetChildrenEnumerator Method

ArrayEraseStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause Class

Represents an array reallocate clause.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayReallocateClause

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ArrayReallocateClause : AstNodeBase
Public Class ArrayReallocateClause
    Inherits AstNodeBase

The ArrayReallocateClause type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayReallocateClause | Initializes a new instance of the ArrayReallocateClause class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasArrayRankSpecifiers | Returns whether the ArrayRankSpecifiers collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableName | Gets or sets the variable name.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause Constructor

Initializes a new instance of the ArrayReallocateClause class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ArrayReallocateClause()
Public Sub New
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause Properties

The ArrayReallocateClause type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasArrayRankSpecifiers | Returns whether the ArrayRankSpecifiers collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableName | Gets or sets the variable name.
Top
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.Arguments Property

ArrayReallocateClauseArguments Property

Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The arguments.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.ArrayRankSpecifiers Property

ArrayReallocateClauseArrayRankSpecifiers Property

Gets the array rank specifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<int> ArrayRankSpecifiers { get; }
Public ReadOnly Property ArrayRankSpecifiers As IList(Of Integer)
    Get

Property Value

Type: IList Int32
The array rank specifiers.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.HasArguments Property

ArrayReallocateClauseHasArguments Property

Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.HasArrayRankSpecifiers Property

ArrayReallocateClauseHasArrayRankSpecifiers Property

Returns whether the ArrayRankSpecifiers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArrayRankSpecifiers { get; }
Public ReadOnly Property HasArrayRankSpecifiers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.Id Property

ArrayReallocateClauseId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.VariableName Property

ArrayReallocateClauseVariableName Property

Gets or sets the variable name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression VariableName { get; set; }
Public Property VariableName As Expression
    Get
    Set

Property Value

Type: Expression
The variable name.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause Methods

The ArrayReallocateClause type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.GetChildrenEnumerator Method

ArrayReallocateClauseGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement Class

Represents an array reallocate statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayReallocateStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ArrayReallocateStatement : Statement
Public Class ArrayReallocateStatement
    Inherits Statement

The ArrayReallocateStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayReallocateStatement | Initializes a new instance of the ArrayReallocateStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Clauses | Gets the clauses.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasClauses | Returns whether the Clauses collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | PreserveData | Gets or sets the preserve data.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement Constructor

Initializes a new instance of the ArrayReallocateStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ArrayReallocateStatement()
Public Sub New
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement Properties

The ArrayReallocateStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Clauses | Gets the clauses.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasClauses | Returns whether the Clauses collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | PreserveData | Gets or sets the preserve data.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.Clauses Property

ArrayReallocateStatementClauses Property

Gets the clauses.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ArrayReallocateClause> Clauses { get; }
Public ReadOnly Property Clauses As IList(Of ArrayReallocateClause)
    Get

Property Value

Type: IList ArrayReallocateClause
The clauses.
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.HasClauses Property

ArrayReallocateStatementHasClauses Property

Returns whether the Clauses collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasClauses { get; }
Public ReadOnly Property HasClauses As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.Id Property

ArrayReallocateStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.PreserveData Property

ArrayReallocateStatementPreserveData Property

Gets or sets the preserve data.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool PreserveData { get; set; }
Public Property PreserveData As Boolean
    Get
    Set

Property Value

Type: Boolean
The preserve data.
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement Methods

The ArrayReallocateStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.GetChildrenEnumerator Method

ArrayReallocateStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression Class

Represents an assignment expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAssignmentExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AssignmentExpression : Expression
Public Class AssignmentExpression
    Inherits Expression

The AssignmentExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AssignmentExpression | Initializes a new instance of the AssignmentExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression Constructor

Initializes a new instance of the AssignmentExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AssignmentExpression()
Public Sub New
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression Properties

The AssignmentExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.Id Property

AssignmentExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.LeftExpression Property

AssignmentExpressionLeftExpression Property

Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.Operator Property

AssignmentExpressionOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.RightExpression Property

AssignmentExpressionRightExpression Property

Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression Methods

The AssignmentExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.GetChildrenEnumerator Method

AssignmentExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute Class

Represents an attribute.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttribute

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Attribute : AstNodeBase
Public Class Attribute
    Inherits AstNodeBase

The Attribute type exposes the following members.

Constructors
 | Name | Description
Public method | Attribute | Initializes a new instance of the Attribute class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Target | Gets or sets the target.
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute Constructor

Initializes a new instance of the Attribute class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Attribute()
Public Sub New
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute Properties

The Attribute type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Target | Gets or sets the target.
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.Arguments Property

AttributeArguments Property

Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AttributeArgument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of AttributeArgument)
    Get

Property Value

Type: IList AttributeArgument
The arguments.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.HasArguments Property

AttributeHasArguments Property

Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.Id Property

AttributeId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.Target Property

AttributeTarget Property

Gets or sets the target.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AttributeTargetKind Target { get; set; }
Public Property Target As AttributeTargetKind
    Get
    Set

Property Value

Type: AttributeTargetKind
The target.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.Type Property

AttributeType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute Methods

The Attribute type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.GetChildrenEnumerator Method

AttributeGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument Class

Represents an attribute argument.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttributeArgument

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AttributeArgument : AstNodeBase
Public Class AttributeArgument
    Inherits AstNodeBase

The AttributeArgument type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeArgument | Initializes a new instance of the AttributeArgument class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument Constructor

Initializes a new instance of the AttributeArgument class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AttributeArgument()
Public Sub New
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument Properties

The AttributeArgument type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument.Expression Property

AttributeArgumentExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument.Id Property

AttributeArgumentId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument.Name Property

AttributeArgumentName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument Methods

The AttributeArgument type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument.GetChildrenEnumerator Method

AttributeArgumentGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection Class

Represents an attribute section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttributeSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AttributeSection : AstNodeBase
Public Class AttributeSection
    Inherits AstNodeBase

The AttributeSection type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeSection | Initializes a new instance of the AttributeSection class
Top
Properties
 | Name | Description
Public property | Attributes | Gets the attributes.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributes | Returns whether the Attributes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection Constructor

Initializes a new instance of the AttributeSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AttributeSection()
Public Sub New
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection Properties

The AttributeSection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets the attributes.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributes | Returns whether the Attributes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection.Attributes Property

AttributeSectionAttributes Property

Gets the attributes.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Attribute> Attributes { get; }
Public ReadOnly Property Attributes As IList(Of Attribute)
    Get

Property Value

Type: IList Attribute
The attributes.
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection.HasAttributes Property

AttributeSectionHasAttributes Property

Returns whether the Attributes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAttributes { get; }
Public ReadOnly Property HasAttributes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection.Id Property

AttributeSectionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection Methods

The AttributeSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection.GetChildrenEnumerator Method

AttributeSectionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression Class

Represents an await expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAwaitExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AwaitExpression : Expression
Public Class AwaitExpression
    Inherits Expression

The AwaitExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AwaitExpression | Initializes a new instance of the AwaitExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression Constructor

Initializes a new instance of the AwaitExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AwaitExpression()
Public Sub New
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression Properties

The AwaitExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression.ChildExpression Property

AwaitExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression.Id Property

AwaitExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression Methods

The AwaitExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression.GetChildrenEnumerator Method

AwaitExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression Class

Represents a binary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBinaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BinaryOperatorExpression : Expression
Public Class BinaryOperatorExpression
    Inherits Expression

The BinaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryOperatorExpression | Initializes a new instance of the BinaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression Constructor

Initializes a new instance of the BinaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BinaryOperatorExpression()
Public Sub New
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression Properties

The BinaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.Id Property

BinaryOperatorExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.LeftExpression Property

BinaryOperatorExpressionLeftExpression Property

Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.Operator Property

BinaryOperatorExpressionOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.RightExpression Property

BinaryOperatorExpressionRightExpression Property

Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression Methods

The BinaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.GetChildrenEnumerator Method

BinaryOperatorExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement Class

Represents a block statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBlockStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BlockStatement : Statement
Public Class BlockStatement
    Inherits Statement

The BlockStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BlockStatement | Initializes a new instance of the BlockStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement Constructor

Initializes a new instance of the BlockStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement()
Public Sub New
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement Properties

The BlockStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement.ChildStatements Property

BlockStatementChildStatements Property

Gets the child statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> ChildStatements { get; }
Public ReadOnly Property ChildStatements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The child statements.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement.HasChildStatements Property

BlockStatementHasChildStatements Property

Returns whether the ChildStatements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasChildStatements { get; }
Public ReadOnly Property HasChildStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement.Id Property

BlockStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement Methods

The BlockStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement.GetChildrenEnumerator Method

BlockStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement Class

Represents a break statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBreakStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BreakStatement : Statement
Public Class BreakStatement
    Inherits Statement

The BreakStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BreakStatement | Initializes a new instance of the BreakStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement Constructor

Initializes a new instance of the BreakStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BreakStatement()
Public Sub New
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement Properties

The BreakStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement.Id Property

BreakStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement Methods

The BreakStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression Class

Represents a cast expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCastExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CastExpression : Expression
Public Class CastExpression
    Inherits Expression

The CastExpression type exposes the following members.

Constructors
 | Name | Description
Public method | CastExpression | Initializes a new instance of the CastExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression Constructor

Initializes a new instance of the CastExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CastExpression()
Public Sub New
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression Properties

The CastExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression.ChildExpression Property

CastExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression.Id Property

CastExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression.Type Property

CastExpressionType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression Methods

The CastExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression.GetChildrenEnumerator Method

CastExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause Class

Represents a catch clause.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCatchClause

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CatchClause : AstNodeBase
Public Class CatchClause
    Inherits AstNodeBase

The CatchClause type exposes the following members.

Constructors
 | Name | Description
Public method | CatchClause | Initializes a new instance of the CatchClause class
Top
Properties
 | Name | Description
Public property | CatchBlock | Gets or sets the catch block.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclarator | Gets or sets the variable declarator.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause Constructor

Initializes a new instance of the CatchClause class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CatchClause()
Public Sub New
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause Properties

The CatchClause type exposes the following members.

Properties
 | Name | Description
Public property | CatchBlock | Gets or sets the catch block.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclarator | Gets or sets the variable declarator.
Top
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.CatchBlock Property

CatchClauseCatchBlock Property

Gets or sets the catch block.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement CatchBlock { get; set; }
Public Property CatchBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The catch block.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.ConditionExpression Property

CatchClauseConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.Id Property

CatchClauseId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.VariableDeclarator Property

CatchClauseVariableDeclarator Property

Gets or sets the variable declarator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VariableDeclarator VariableDeclarator { get; set; }
Public Property VariableDeclarator As VariableDeclarator
    Get
    Set

Property Value

Type: VariableDeclarator
The variable declarator.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause Methods

The CatchClause type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.GetChildrenEnumerator Method

CatchClauseGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression Class

Represents a checked expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCheckedExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CheckedExpression : Expression
Public Class CheckedExpression
    Inherits Expression

The CheckedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | CheckedExpression | Initializes a new instance of the CheckedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression Constructor

Initializes a new instance of the CheckedExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CheckedExpression()
Public Sub New
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression Properties

The CheckedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression.ChildExpression Property

CheckedExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression.Id Property

CheckedExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression Methods

The CheckedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression.GetChildrenEnumerator Method

CheckedExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement Class

Represents a checked statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCheckedStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CheckedStatement : Statement
Public Class CheckedStatement
    Inherits Statement

The CheckedStatement type exposes the following members.

Constructors
 | Name | Description
Public method | CheckedStatement | Initializes a new instance of the CheckedStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement Constructor

Initializes a new instance of the CheckedStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CheckedStatement()
Public Sub New
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement Properties

The CheckedStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement.ChildStatement Property

CheckedStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement.Id Property

CheckedStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement Methods

The CheckedStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement.GetChildrenEnumerator Method

CheckedStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody Class

Represents a class body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationClassBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ClassBody : AstNodeBase
Public Class ClassBody
    Inherits AstNodeBase

The ClassBody type exposes the following members.

Constructors
 | Name | Description
Public method | ClassBody | Initializes a new instance of the ClassBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody Constructor

Initializes a new instance of the ClassBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ClassBody()
Public Sub New
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody Properties

The ClassBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody.HasMembers Property

ClassBodyHasMembers Property

Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody.Id Property

ClassBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody.Members Property

ClassBodyMembers Property

Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody Methods

The ClassBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody.GetChildrenEnumerator Method

ClassBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration Class

Represents a class declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationClassDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ClassDeclaration : TypeDeclaration
Public Class ClassDeclaration
    Inherits TypeDeclaration

The ClassDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ClassDeclaration | Initializes a new instance of the ClassDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | IsStandardModule | Gets whether this class is a standard module.
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration Constructor

Initializes a new instance of the ClassDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ClassDeclaration()
Public Sub New
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration Properties

The ClassDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | IsStandardModule | Gets whether this class is a standard module.
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.BaseTypes Property

ClassDeclarationBaseTypes Property

Gets the base types.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QualifiedName> BaseTypes { get; }
Public ReadOnly Property BaseTypes As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The base types.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.Body Property

ClassDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ClassBody Body { get; set; }
Public Property Body As ClassBody
    Get
    Set

Property Value

Type: ClassBody
The body.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.HasBaseTypes Property

ClassDeclarationHasBaseTypes Property

Returns whether the BaseTypes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasBaseTypes { get; }
Public ReadOnly Property HasBaseTypes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.HasTypeParameters Property

ClassDeclarationHasTypeParameters Property

Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.Id Property

ClassDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.IsStandardModule Property

ClassDeclarationIsStandardModule Property

Gets whether this class is a standard module.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsStandardModule { get; }
Public ReadOnly Property IsStandardModule As Boolean
    Get

Property Value

Type: Boolean
true if this class is a standard module; otherwise, false.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.Kind Property

ClassDeclarationKind Property

Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.TypeParameters Property

ClassDeclarationTypeParameters Property

Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration Methods

The ClassDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.GetChildrenEnumerator Method

ClassDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit Class

Represents a compilation unit.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnit

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CompilationUnit : AstNodeBase
Public Class CompilationUnit
    Inherits AstNodeBase

The CompilationUnit type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnit | Initializes a new instance of the CompilationUnit class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit Constructor

Initializes a new instance of the CompilationUnit class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CompilationUnit()
Public Sub New
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit Properties

The CompilationUnit type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit.HasMembers Property

CompilationUnitHasMembers Property

Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit.Id Property

CompilationUnitId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit.Members Property

CompilationUnitMembers Property

Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit Methods

The CompilationUnit type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit.GetChildrenEnumerator Method

CompilationUnitGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption Class

Represents a compilation unit option.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnitOption

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CompilationUnitOption : AstNodeBase
Public Class CompilationUnitOption
    Inherits AstNodeBase

The CompilationUnitOption type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnitOption | Initializes a new instance of the CompilationUnitOption class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption Constructor

Initializes a new instance of the CompilationUnitOption class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CompilationUnitOption()
Public Sub New
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption Properties

The CompilationUnitOption type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the value.
Top
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption.Id Property

CompilationUnitOptionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption.Name Property

CompilationUnitOptionName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption.Value Property

CompilationUnitOptionValue Property

Gets or sets the value.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The value.
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption Methods

The CompilationUnitOption type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression Class

Represents a conditional expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConditionalExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ConditionalExpression : Expression
Public Class ConditionalExpression
    Inherits Expression

The ConditionalExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ConditionalExpression | Initializes a new instance of the ConditionalExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression Constructor

Initializes a new instance of the ConditionalExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ConditionalExpression()
Public Sub New
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression Properties

The ConditionalExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.ConditionExpression Property

ConditionalExpressionConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.FalseExpression Property

ConditionalExpressionFalseExpression Property

Gets or sets the false expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression FalseExpression { get; set; }
Public Property FalseExpression As Expression
    Get
    Set

Property Value

Type: Expression
The false expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.Id Property

ConditionalExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.TrueExpression Property

ConditionalExpressionTrueExpression Property

Gets or sets the true expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TrueExpression { get; set; }
Public Property TrueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The true expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression Methods

The ConditionalExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.GetChildrenEnumerator Method

ConditionalExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody Class

Represents a constructor body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConstructorBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ConstructorBody : AstNodeBase
Public Class ConstructorBody
    Inherits AstNodeBase

The ConstructorBody type exposes the following members.

Constructors
 | Name | Description
Public method | ConstructorBody | Initializes a new instance of the ConstructorBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody Constructor

Initializes a new instance of the ConstructorBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ConstructorBody()
Public Sub New
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody Properties

The ConstructorBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody.HasStatements Property

ConstructorBodyHasStatements Property

Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody.Id Property

ConstructorBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody.Statements Property

ConstructorBodyStatements Property

Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody Methods

The ConstructorBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody.GetChildrenEnumerator Method

ConstructorBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration Class

Represents a constructor declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConstructorDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ConstructorDeclaration : TypeMemberDeclaration
Public Class ConstructorDeclaration
    Inherits TypeMemberDeclaration

The ConstructorDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ConstructorDeclaration | Initializes a new instance of the ConstructorDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializerArguments | Returns whether the InitializerArguments collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | InitializerArguments | Gets the initializer arguments.
Public property | InitializerKind | Gets or sets the initializer kind.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration Constructor

Initializes a new instance of the ConstructorDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ConstructorDeclaration()
Public Sub New
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration Properties

The ConstructorDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializerArguments | Returns whether the InitializerArguments collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | InitializerArguments | Gets the initializer arguments.
Public property | InitializerKind | Gets or sets the initializer kind.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Body Property

ConstructorDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ConstructorBody Body { get; set; }
Public Property Body As ConstructorBody
    Get
    Set

Property Value

Type: ConstructorBody
The body.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.HasInitializerArguments Property

ConstructorDeclarationHasInitializerArguments Property

Returns whether the InitializerArguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasInitializerArguments { get; }
Public ReadOnly Property HasInitializerArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.HasParameters Property

ConstructorDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Id Property

ConstructorDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.InitializerArguments Property

ConstructorDeclarationInitializerArguments Property

Gets the initializer arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Argument> InitializerArguments { get; }
Public ReadOnly Property InitializerArguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The initializer arguments.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.InitializerKind Property

ConstructorDeclarationInitializerKind Property

Gets or sets the initializer kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ConstructorInitializerKind InitializerKind { get; set; }
Public Property InitializerKind As ConstructorInitializerKind
    Get
    Set

Property Value

Type: ConstructorInitializerKind
The initializer kind.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Kind Property

ConstructorDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Name Property

ConstructorDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Parameters Property

ConstructorDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration Methods

The ConstructorDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.GetChildrenEnumerator Method

ConstructorDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement Class

Represents a continue statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationContinueStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ContinueStatement : Statement
Public Class ContinueStatement
    Inherits Statement

The ContinueStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ContinueStatement | Initializes a new instance of the ContinueStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement Constructor

Initializes a new instance of the ContinueStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContinueStatement()
Public Sub New
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement Properties

The ContinueStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement.Id Property

ContinueStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement.Kind Property

ContinueStatementKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContinueKind Kind { get; set; }
Public Property Kind As ContinueKind
    Get
    Set

Property Value

Type: ContinueKind
The kind.
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement Methods

The ContinueStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression Class

Represents a default value expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDefaultValueExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DefaultValueExpression : Expression
Public Class DefaultValueExpression
    Inherits Expression

The DefaultValueExpression type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultValueExpression | Initializes a new instance of the DefaultValueExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression Constructor

Initializes a new instance of the DefaultValueExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DefaultValueExpression()
Public Sub New
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression Properties

The DefaultValueExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression.Id Property

DefaultValueExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression.Type Property

DefaultValueExpressionType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression Methods

The DefaultValueExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression.GetChildrenEnumerator Method

DefaultValueExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration Class

Represents a delegate declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDelegateDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DelegateDeclaration : TypeDeclaration
Public Class DelegateDeclaration
    Inherits TypeDeclaration

The DelegateDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | DelegateDeclaration | Initializes a new instance of the DelegateDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration Constructor

Initializes a new instance of the DelegateDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DelegateDeclaration()
Public Sub New
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration Properties

The DelegateDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.HasParameters Property

DelegateDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.HasTypeParameters Property

DelegateDeclarationHasTypeParameters Property

Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.Id Property

DelegateDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.Kind Property

DelegateDeclarationKind Property

Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.Parameters Property

DelegateDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.ReturnType Property

DelegateDeclarationReturnType Property

Gets or sets the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration ReturnType { get; set; }
Public Property ReturnType As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The return type.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.TypeParameters Property

DelegateDeclarationTypeParameters Property

Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration Methods

The DelegateDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.GetChildrenEnumerator Method

DelegateDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator Class

Represents a distinct query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDistinctQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DistinctQueryOperator : QueryOperator
Public Class DistinctQueryOperator
    Inherits QueryOperator

The DistinctQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | DistinctQueryOperator | Initializes a new instance of the DistinctQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator Constructor

Initializes a new instance of the DistinctQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DistinctQueryOperator()
Public Sub New
See Also

Reference

DistinctQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator Properties

The DistinctQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DistinctQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator.Id Property

DistinctQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DistinctQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator Methods

The DistinctQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DistinctQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment Class

Represents a documentation comment.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDocumentationComment

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DocumentationComment : AstNodeBase
Public Class DocumentationComment
    Inherits AstNodeBase

The DocumentationComment type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentationComment | Initializes a new instance of the DocumentationComment class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the comment text.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment Constructor

Initializes a new instance of the DocumentationComment class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentationComment()
Public Sub New
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment Properties

The DocumentationComment type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the comment text.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment.Id Property

DocumentationCommentId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment.Text Property

DocumentationCommentText Property

Gets or sets the comment text.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The comment text.
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment Methods

The DocumentationComment type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement Class

Represents a do statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDoStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoStatement : Statement
Public Class DoStatement
    Inherits Statement

The DoStatement type exposes the following members.

Constructors
 | Name | Description
Public method | DoStatement | Initializes a new instance of the DoStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement Constructor

Initializes a new instance of the DoStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoStatement()
Public Sub New
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement Properties

The DoStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement.ChildStatement Property

DoStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement.ConditionExpression Property

DoStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement.Id Property

DoStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement Methods

The DoStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement.GetChildrenEnumerator Method

DoStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Class

Contains the AST node IDs for the .NET language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDotNetAstNodeId

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DotNetAstNodeId : AstNodeIdProviderBase
Public Class DotNetAstNodeId
    Inherits AstNodeIdProviderBase

The DotNetAstNodeId type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetAstNodeId | Initializes a new instance of the DotNetAstNodeId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Top
Fields
Name | Description
AccessorBody | Gets the AccessorBody AST node ID.
AccessorDeclaration | Gets the AccessorDeclaration AST node ID.
AddressOfExpression | Gets the AddressOfExpression AST node ID.
AggregateQueryOperator | Gets the AggregateQueryOperator AST node ID.
AnonymousMethodExpression | Gets the AnonymousMethodExpression AST node ID.
Argument | Gets the Argument AST node ID.
ArrayEraseStatement | Gets the ArrayEraseStatement AST node ID.
ArrayReallocateClause | Gets the ArrayReallocateClause AST node ID.
ArrayReallocateStatement | Gets the ArrayReallocateStatement AST node ID.
AssignmentExpression | Gets the AssignmentExpression AST node ID.
Attribute | Gets the Attribute AST node ID.
AttributeArgument | Gets the AttributeArgument AST node ID.
AttributeSection | Gets the AttributeSection AST node ID.
AwaitExpression | Gets the AwaitExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
CastExpression | Gets the CastExpression AST node ID.
CatchClause | Gets the CatchClause AST node ID.
CheckedExpression | Gets the CheckedExpression AST node ID.
CheckedStatement | Gets the CheckedStatement AST node ID.
ClassBody | Gets the ClassBody AST node ID.
ClassDeclaration | Gets the ClassDeclaration AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
CompilationUnitOption | Gets the CompilationUnitOption AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ConstructorBody | Gets the ConstructorBody AST node ID.
ConstructorDeclaration | Gets the ConstructorDeclaration AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DefaultValueExpression | Gets the DefaultValueExpression AST node ID.
DelegateDeclaration | Gets the DelegateDeclaration AST node ID.
DistinctQueryOperator | Gets the DistinctQueryOperator AST node ID.
DocumentationComment | Gets the DocumentationComment AST node ID.
DoStatement | Gets the DoStatement AST node ID.
ElseIfSection | Gets the ElseIfSection AST node ID.
EndStatement | Gets the EndStatement AST node ID.
EnumerationBody | Gets the EnumerationBody AST node ID.
EnumerationDeclaration | Gets the EnumerationDeclaration AST node ID.
EnumerationMemberDeclaration | Gets the EnumerationMemberDeclaration AST node ID.
EventBody | Gets the EventBody AST node ID.
EventDeclaration | Gets the EventDeclaration AST node ID.
ExitStatement | Gets the ExitStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ExternalAliasDirective | Gets the ExternalAliasDirective AST node ID.
ExternalAliasDirectiveSection | Gets the ExternalAliasDirectiveSection AST node ID.
FieldDeclaration | Gets the FieldDeclaration AST node ID.
FixedSizeBufferDeclaration | Gets the FixedSizeBufferDeclaration AST node ID.
FixedSizeBufferDeclarator | Gets the FixedSizeBufferDeclarator AST node ID.
FixedStatement | Gets the FixedStatement AST node ID.
ForEachStatement | Gets the ForEachStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FromQueryOperator | Gets the FromQueryOperator AST node ID.
GoToStatement | Gets the GoToStatement AST node ID.
GroupQueryOperator | Gets the GroupQueryOperator AST node ID.
IfStatement | Gets the IfStatement AST node ID.
InitializerExpression | Gets the InitializerExpression AST node ID.
InstanceExpression | Gets the InstanceExpression AST node ID.
InterfaceAccessorDeclaration | Gets the InterfaceAccessorDeclaration AST node ID.
InterfaceBody | Gets the InterfaceBody AST node ID.
InterfaceDeclaration | Gets the InterfaceDeclaration AST node ID.
InterfaceEventDeclaration | Gets the InterfaceEventDeclaration AST node ID.
InterfaceMemberDeclaration | Gets the InterfaceMemberDeclaration AST node ID.
InterfaceMethodDeclaration | Gets the InterfaceMethodDeclaration AST node ID.
InterfacePropertyDeclaration | Gets the InterfacePropertyDeclaration AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
IsTypeOfExpression | Gets the IsTypeOfExpression AST node ID.
JoinQueryOperator | Gets the JoinQueryOperator AST node ID.
LabeledStatement | Gets the LabeledStatement AST node ID.
LambdaExpression | Gets the LambdaExpression AST node ID.
LetQueryOperator | Gets the LetQueryOperator AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
LocalVariableDeclaration | Gets the LocalVariableDeclaration AST node ID.
LockStatement | Gets the LockStatement AST node ID.
MemberAccess | Gets the MemberAccess AST node ID.
MethodBody | Gets the MethodBody AST node ID.
MethodDeclaration | Gets the MethodDeclaration AST node ID.
NameOfExpression | Gets the NameOfExpression AST node ID.
NamespaceBody | Gets the NamespaceBody AST node ID.
NamespaceDeclaration | Gets the NamespaceDeclaration AST node ID.
ObjectCreationExpression | Gets the ObjectCreationExpression AST node ID.
OperatorBody | Gets the OperatorBody AST node ID.
OperatorDeclaration | Gets the OperatorDeclaration AST node ID.
OrderByQueryOperator | Gets the OrderByQueryOperator AST node ID.
Ordering | Gets the Ordering AST node ID.
ParameterDeclaration | Gets the ParameterDeclaration AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PreprocessorDirective | Gets the PreprocessorDirective AST node ID.
PropertyBody | Gets the PropertyBody AST node ID.
PropertyDeclaration | Gets the PropertyDeclaration AST node ID.
QualifiedName | Gets the QualifiedName AST node ID.
QueryExpression | Gets the QueryExpression AST node ID.
QueryOperator | Gets the QueryOperator AST node ID.
RangeVariableDeclaration | Gets the RangeVariableDeclaration AST node ID.
RangeVariableDeclarator | Gets the RangeVariableDeclarator AST node ID.
RegionPreprocessorDirective | Gets the RegionPreprocessorDirective AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
ReturnTypeDeclaration | Gets the ReturnTypeDeclaration AST node ID.
ReturnTypeExpression | Gets the ReturnTypeExpression AST node ID.
SelectQueryOperator | Gets the SelectQueryOperator AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SizeOfExpression | Gets the SizeOfExpression AST node ID.
SkipQueryOperator | Gets the SkipQueryOperator AST node ID.
SkipWhileQueryOperator | Gets the SkipWhileQueryOperator AST node ID.
StackAllocationInitializer | Gets the StackAllocationInitializer AST node ID.
Statement | Gets the Statement AST node ID.
StopStatement | Gets the StopStatement AST node ID.
StructureBody | Gets the StructureBody AST node ID.
StructureDeclaration | Gets the StructureDeclaration AST node ID.
SwitchSection | Gets the SwitchSection AST node ID.
SwitchStatement | Gets the SwitchStatement AST node ID.
TakeQueryOperator | Gets the TakeQueryOperator AST node ID.
TakeWhileQueryOperator | Gets the TakeWhileQueryOperator AST node ID.
ThrowStatement | Gets the ThrowStatement AST node ID.
TryCastExpression | Gets the TryCastExpression AST node ID.
TryStatement | Gets the TryStatement AST node ID.
TypeDeclaration | Gets the TypeDeclaration AST node ID.
TypeMemberDeclaration | Gets the TypeMemberDeclaration AST node ID.
TypeOfExpression | Gets the TypeOfExpression AST node ID.
TypeParameter | Gets the TypeParameter AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
UncheckedExpression | Gets the UncheckedExpression AST node ID.
UncheckedStatement | Gets the UncheckedStatement AST node ID.
UnsafeStatement | Gets the UnsafeStatement AST node ID.
UnstructuredErrorHandlerStatement | Gets the UnstructuredErrorHandlerStatement AST node ID.
UnstructuredErrorResumeStatement | Gets the UnstructuredErrorResumeStatement AST node ID.
UnstructuredErrorThrowStatement | Gets the UnstructuredErrorThrowStatement AST node ID.
UsingDirective | Gets the UsingDirective AST node ID.
UsingDirectiveSection | Gets the UsingDirectiveSection AST node ID.
UsingStatement | Gets the UsingStatement AST node ID.
VariableDeclarationExpression | Gets the VariableDeclarationExpression AST node ID.
VariableDeclarator | Gets the VariableDeclarator AST node ID.
WhereQueryOperator | Gets the WhereQueryOperator AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
WithTargetExpression | Gets the WithTargetExpression AST node ID.
XmlNamespaceExpression | Gets the XmlNamespaceExpression AST node ID.
YieldStatement | Gets the YieldStatement AST node ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v17.1.651.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Constructor

Initializes a new instance of the DotNetAstNodeId class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DotNetAstNodeId()
Public Sub New
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Properties

The DotNetAstNodeId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MaxId Property

DotNetAstNodeIdMaxId Property

Gets the maximum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum AST node ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MinId Property

DotNetAstNodeIdMinId Property

Gets the minimum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum AST node ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Methods

The DotNetAstNodeId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Top
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ContainsId Method

DotNetAstNodeIdContainsId Method

Returns whether the specified ID value is valid for this AST node ID provider.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.GetDescription Method

DotNetAstNodeIdGetDescription Method

Returns the actual string representation for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The actual string representation for the specified AST node ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.GetKey Method

DotNetAstNodeIdGetKey Method

Returns the string-based key for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The string-based key for the specified AST node ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Fields

The DotNetAstNodeId type exposes the following members.

Fields
Name | Description
AccessorBody | Gets the AccessorBody AST node ID.
AccessorDeclaration | Gets the AccessorDeclaration AST node ID.
AddressOfExpression | Gets the AddressOfExpression AST node ID.
AggregateQueryOperator | Gets the AggregateQueryOperator AST node ID.
AnonymousMethodExpression | Gets the AnonymousMethodExpression AST node ID.
Argument | Gets the Argument AST node ID.
ArrayEraseStatement | Gets the ArrayEraseStatement AST node ID.
ArrayReallocateClause | Gets the ArrayReallocateClause AST node ID.
ArrayReallocateStatement | Gets the ArrayReallocateStatement AST node ID.
AssignmentExpression | Gets the AssignmentExpression AST node ID.
Attribute | Gets the Attribute AST node ID.
AttributeArgument | Gets the AttributeArgument AST node ID.
AttributeSection | Gets the AttributeSection AST node ID.
AwaitExpression | Gets the AwaitExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
CastExpression | Gets the CastExpression AST node ID.
CatchClause | Gets the CatchClause AST node ID.
CheckedExpression | Gets the CheckedExpression AST node ID.
CheckedStatement | Gets the CheckedStatement AST node ID.
ClassBody | Gets the ClassBody AST node ID.
ClassDeclaration | Gets the ClassDeclaration AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
CompilationUnitOption | Gets the CompilationUnitOption AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ConstructorBody | Gets the ConstructorBody AST node ID.
ConstructorDeclaration | Gets the ConstructorDeclaration AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DefaultValueExpression | Gets the DefaultValueExpression AST node ID.
DelegateDeclaration | Gets the DelegateDeclaration AST node ID.
DistinctQueryOperator | Gets the DistinctQueryOperator AST node ID.
DocumentationComment | Gets the DocumentationComment AST node ID.
DoStatement | Gets the DoStatement AST node ID.
ElseIfSection | Gets the ElseIfSection AST node ID.
EndStatement | Gets the EndStatement AST node ID.
EnumerationBody | Gets the EnumerationBody AST node ID.
EnumerationDeclaration | Gets the EnumerationDeclaration AST node ID.
EnumerationMemberDeclaration | Gets the EnumerationMemberDeclaration AST node ID.
EventBody | Gets the EventBody AST node ID.
EventDeclaration | Gets the EventDeclaration AST node ID.
ExitStatement | Gets the ExitStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ExternalAliasDirective | Gets the ExternalAliasDirective AST node ID.
ExternalAliasDirectiveSection | Gets the ExternalAliasDirectiveSection AST node ID.
FieldDeclaration | Gets the FieldDeclaration AST node ID.
FixedSizeBufferDeclaration | Gets the FixedSizeBufferDeclaration AST node ID.
FixedSizeBufferDeclarator | Gets the FixedSizeBufferDeclarator AST node ID.
FixedStatement | Gets the FixedStatement AST node ID.
ForEachStatement | Gets the ForEachStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FromQueryOperator | Gets the FromQueryOperator AST node ID.
GoToStatement | Gets the GoToStatement AST node ID.
GroupQueryOperator | Gets the GroupQueryOperator AST node ID.
IfStatement | Gets the IfStatement AST node ID.
InitializerExpression | Gets the InitializerExpression AST node ID.
InstanceExpression | Gets the InstanceExpression AST node ID.
InterfaceAccessorDeclaration | Gets the InterfaceAccessorDeclaration AST node ID.
InterfaceBody | Gets the InterfaceBody AST node ID.
InterfaceDeclaration | Gets the InterfaceDeclaration AST node ID.
InterfaceEventDeclaration | Gets the InterfaceEventDeclaration AST node ID.
InterfaceMemberDeclaration | Gets the InterfaceMemberDeclaration AST node ID.
InterfaceMethodDeclaration | Gets the InterfaceMethodDeclaration AST node ID.
InterfacePropertyDeclaration | Gets the InterfacePropertyDeclaration AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
IsTypeOfExpression | Gets the IsTypeOfExpression AST node ID.
JoinQueryOperator | Gets the JoinQueryOperator AST node ID.
LabeledStatement | Gets the LabeledStatement AST node ID.
LambdaExpression | Gets the LambdaExpression AST node ID.
LetQueryOperator | Gets the LetQueryOperator AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
LocalVariableDeclaration | Gets the LocalVariableDeclaration AST node ID.
LockStatement | Gets the LockStatement AST node ID.
MemberAccess | Gets the MemberAccess AST node ID.
MethodBody | Gets the MethodBody AST node ID.
MethodDeclaration | Gets the MethodDeclaration AST node ID.
NameOfExpression | Gets the NameOfExpression AST node ID.
NamespaceBody | Gets the NamespaceBody AST node ID.
NamespaceDeclaration | Gets the NamespaceDeclaration AST node ID.
ObjectCreationExpression | Gets the ObjectCreationExpression AST node ID.
OperatorBody | Gets the OperatorBody AST node ID.
OperatorDeclaration | Gets the OperatorDeclaration AST node ID.
OrderByQueryOperator | Gets the OrderByQueryOperator AST node ID.
Ordering | Gets the Ordering AST node ID.
ParameterDeclaration | Gets the ParameterDeclaration AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PreprocessorDirective | Gets the PreprocessorDirective AST node ID.
PropertyBody | Gets the PropertyBody AST node ID.
PropertyDeclaration | Gets the PropertyDeclaration AST node ID.
QualifiedName | Gets the QualifiedName AST node ID.
QueryExpression | Gets the QueryExpression AST node ID.
QueryOperator | Gets the QueryOperator AST node ID.
RangeVariableDeclaration | Gets the RangeVariableDeclaration AST node ID.
RangeVariableDeclarator | Gets the RangeVariableDeclarator AST node ID.
RegionPreprocessorDirective | Gets the RegionPreprocessorDirective AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
ReturnTypeDeclaration | Gets the ReturnTypeDeclaration AST node ID.
ReturnTypeExpression | Gets the ReturnTypeExpression AST node ID.
SelectQueryOperator | Gets the SelectQueryOperator AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SizeOfExpression | Gets the SizeOfExpression AST node ID.
SkipQueryOperator | Gets the SkipQueryOperator AST node ID.
SkipWhileQueryOperator | Gets the SkipWhileQueryOperator AST node ID.
StackAllocationInitializer | Gets the StackAllocationInitializer AST node ID.
Statement | Gets the Statement AST node ID.
StopStatement | Gets the StopStatement AST node ID.
StructureBody | Gets the StructureBody AST node ID.
StructureDeclaration | Gets the StructureDeclaration AST node ID.
SwitchSection | Gets the SwitchSection AST node ID.
SwitchStatement | Gets the SwitchStatement AST node ID.
TakeQueryOperator | Gets the TakeQueryOperator AST node ID.
TakeWhileQueryOperator | Gets the TakeWhileQueryOperator AST node ID.
ThrowStatement | Gets the ThrowStatement AST node ID.
TryCastExpression | Gets the TryCastExpression AST node ID.
TryStatement | Gets the TryStatement AST node ID.
TypeDeclaration | Gets the TypeDeclaration AST node ID.
TypeMemberDeclaration | Gets the TypeMemberDeclaration AST node ID.
TypeOfExpression | Gets the TypeOfExpression AST node ID.
TypeParameter | Gets the TypeParameter AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
UncheckedExpression | Gets the UncheckedExpression AST node ID.
UncheckedStatement | Gets the UncheckedStatement AST node ID.
UnsafeStatement | Gets the UnsafeStatement AST node ID.
UnstructuredErrorHandlerStatement | Gets the UnstructuredErrorHandlerStatement AST node ID.
UnstructuredErrorResumeStatement | Gets the UnstructuredErrorResumeStatement AST node ID.
UnstructuredErrorThrowStatement | Gets the UnstructuredErrorThrowStatement AST node ID.
UsingDirective | Gets the UsingDirective AST node ID.
UsingDirectiveSection | Gets the UsingDirectiveSection AST node ID.
UsingStatement | Gets the UsingStatement AST node ID.
VariableDeclarationExpression | Gets the VariableDeclarationExpression AST node ID.
VariableDeclarator | Gets the VariableDeclarator AST node ID.
WhereQueryOperator | Gets the WhereQueryOperator AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
WithTargetExpression | Gets the WithTargetExpression AST node ID.
XmlNamespaceExpression | Gets the XmlNamespaceExpression AST node ID.
YieldStatement | Gets the YieldStatement AST node ID.
Top
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AccessorBody Field

DotNetAstNodeIdAccessorBody Field

Gets the AccessorBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AccessorBody = 10000
Public Const AccessorBody As Integer = 10000

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AccessorDeclaration Field

DotNetAstNodeIdAccessorDeclaration Field

Gets the AccessorDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AccessorDeclaration = 10001
Public Const AccessorDeclaration As Integer = 10001

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AddressOfExpression Field

DotNetAstNodeIdAddressOfExpression Field

Gets the AddressOfExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AddressOfExpression = 10002
Public Const AddressOfExpression As Integer = 10002

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AggregateQueryOperator Field

DotNetAstNodeIdAggregateQueryOperator Field

Gets the AggregateQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AggregateQueryOperator = 10003
Public Const AggregateQueryOperator As Integer = 10003

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AnonymousMethodExpression Field

DotNetAstNodeIdAnonymousMethodExpression Field

Gets the AnonymousMethodExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AnonymousMethodExpression = 10004
Public Const AnonymousMethodExpression As Integer = 10004

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Argument Field

DotNetAstNodeIdArgument Field

Gets the Argument AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Argument = 10005
Public Const Argument As Integer = 10005

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ArrayEraseStatement Field

DotNetAstNodeIdArrayEraseStatement Field

Gets the ArrayEraseStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ArrayEraseStatement = 10006
Public Const ArrayEraseStatement As Integer = 10006

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ArrayReallocateClause Field

DotNetAstNodeIdArrayReallocateClause Field

Gets the ArrayReallocateClause AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ArrayReallocateClause = 10007
Public Const ArrayReallocateClause As Integer = 10007

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ArrayReallocateStatement Field

DotNetAstNodeIdArrayReallocateStatement Field

Gets the ArrayReallocateStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ArrayReallocateStatement = 10008
Public Const ArrayReallocateStatement As Integer = 10008

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AssignmentExpression Field

DotNetAstNodeIdAssignmentExpression Field

Gets the AssignmentExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AssignmentExpression = 10009
Public Const AssignmentExpression As Integer = 10009

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Attribute Field

DotNetAstNodeIdAttribute Field

Gets the Attribute AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Attribute = 10010
Public Const Attribute As Integer = 10010

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AttributeArgument Field

DotNetAstNodeIdAttributeArgument Field

Gets the AttributeArgument AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AttributeArgument = 10011
Public Const AttributeArgument As Integer = 10011

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AttributeSection Field

DotNetAstNodeIdAttributeSection Field

Gets the AttributeSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AttributeSection = 10012
Public Const AttributeSection As Integer = 10012

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AwaitExpression Field

DotNetAstNodeIdAwaitExpression Field

Gets the AwaitExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AwaitExpression = 10013
Public Const AwaitExpression As Integer = 10013

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.BinaryOperatorExpression Field

DotNetAstNodeIdBinaryOperatorExpression Field

Gets the BinaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BinaryOperatorExpression = 10014
Public Const BinaryOperatorExpression As Integer = 10014

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.BlockStatement Field

DotNetAstNodeIdBlockStatement Field

Gets the BlockStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BlockStatement = 10015
Public Const BlockStatement As Integer = 10015

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.BreakStatement Field

DotNetAstNodeIdBreakStatement Field

Gets the BreakStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BreakStatement = 10016
Public Const BreakStatement As Integer = 10016

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CastExpression Field

DotNetAstNodeIdCastExpression Field

Gets the CastExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CastExpression = 10017
Public Const CastExpression As Integer = 10017

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CatchClause Field

DotNetAstNodeIdCatchClause Field

Gets the CatchClause AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CatchClause = 10018
Public Const CatchClause As Integer = 10018

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CheckedExpression Field

DotNetAstNodeIdCheckedExpression Field

Gets the CheckedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CheckedExpression = 10019
Public Const CheckedExpression As Integer = 10019

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CheckedStatement Field

DotNetAstNodeIdCheckedStatement Field

Gets the CheckedStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CheckedStatement = 10020
Public Const CheckedStatement As Integer = 10020

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ClassBody Field

DotNetAstNodeIdClassBody Field

Gets the ClassBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ClassBody = 10021
Public Const ClassBody As Integer = 10021

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ClassDeclaration Field

DotNetAstNodeIdClassDeclaration Field

Gets the ClassDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ClassDeclaration = 10022
Public Const ClassDeclaration As Integer = 10022

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CompilationUnit Field

DotNetAstNodeIdCompilationUnit Field

Gets the CompilationUnit AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CompilationUnit = 10023
Public Const CompilationUnit As Integer = 10023

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CompilationUnitOption Field

DotNetAstNodeIdCompilationUnitOption Field

Gets the CompilationUnitOption AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CompilationUnitOption = 10024
Public Const CompilationUnitOption As Integer = 10024

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ConditionalExpression Field

DotNetAstNodeIdConditionalExpression Field

Gets the ConditionalExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ConditionalExpression = 10025
Public Const ConditionalExpression As Integer = 10025

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ConstructorBody Field

DotNetAstNodeIdConstructorBody Field

Gets the ConstructorBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ConstructorBody = 10026
Public Const ConstructorBody As Integer = 10026

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ConstructorDeclaration Field

DotNetAstNodeIdConstructorDeclaration Field

Gets the ConstructorDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ConstructorDeclaration = 10027
Public Const ConstructorDeclaration As Integer = 10027

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ContinueStatement Field

DotNetAstNodeIdContinueStatement Field

Gets the ContinueStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContinueStatement = 10028
Public Const ContinueStatement As Integer = 10028

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DefaultValueExpression Field

DotNetAstNodeIdDefaultValueExpression Field

Gets the DefaultValueExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DefaultValueExpression = 10029
Public Const DefaultValueExpression As Integer = 10029

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DelegateDeclaration Field

DotNetAstNodeIdDelegateDeclaration Field

Gets the DelegateDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DelegateDeclaration = 10030
Public Const DelegateDeclaration As Integer = 10030

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DistinctQueryOperator Field

DotNetAstNodeIdDistinctQueryOperator Field

Gets the DistinctQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DistinctQueryOperator = 10031
Public Const DistinctQueryOperator As Integer = 10031

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DocumentationComment Field

DotNetAstNodeIdDocumentationComment Field

Gets the DocumentationComment AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentationComment = 10032
Public Const DocumentationComment As Integer = 10032

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DoStatement Field

DotNetAstNodeIdDoStatement Field

Gets the DoStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DoStatement = 10033
Public Const DoStatement As Integer = 10033

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ElseIfSection Field

DotNetAstNodeIdElseIfSection Field

Gets the ElseIfSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ElseIfSection = 10034
Public Const ElseIfSection As Integer = 10034

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EndStatement Field

DotNetAstNodeIdEndStatement Field

Gets the EndStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EndStatement = 10035
Public Const EndStatement As Integer = 10035

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EnumerationBody Field

DotNetAstNodeIdEnumerationBody Field

Gets the EnumerationBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EnumerationBody = 10036
Public Const EnumerationBody As Integer = 10036

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EnumerationDeclaration Field

DotNetAstNodeIdEnumerationDeclaration Field

Gets the EnumerationDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EnumerationDeclaration = 10037
Public Const EnumerationDeclaration As Integer = 10037

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EnumerationMemberDeclaration Field

DotNetAstNodeIdEnumerationMemberDeclaration Field

Gets the EnumerationMemberDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EnumerationMemberDeclaration = 10038
Public Const EnumerationMemberDeclaration As Integer = 10038

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EventBody Field

DotNetAstNodeIdEventBody Field

Gets the EventBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EventBody = 10039
Public Const EventBody As Integer = 10039

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EventDeclaration Field

DotNetAstNodeIdEventDeclaration Field

Gets the EventDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EventDeclaration = 10040
Public Const EventDeclaration As Integer = 10040

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ExitStatement Field

DotNetAstNodeIdExitStatement Field

Gets the ExitStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ExitStatement = 10041
Public Const ExitStatement As Integer = 10041

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Expression Field

DotNetAstNodeIdExpression Field

Gets the Expression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Expression = 10042
Public Const Expression As Integer = 10042

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ExpressionStatement Field

DotNetAstNodeIdExpressionStatement Field

Gets the ExpressionStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ExpressionStatement = 10043
Public Const ExpressionStatement As Integer = 10043

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ExternalAliasDirective Field

DotNetAstNodeIdExternalAliasDirective Field

Gets the ExternalAliasDirective AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ExternalAliasDirective = 10044
Public Const ExternalAliasDirective As Integer = 10044

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ExternalAliasDirectiveSection Field

DotNetAstNodeIdExternalAliasDirectiveSection Field

Gets the ExternalAliasDirectiveSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ExternalAliasDirectiveSection = 10045
Public Const ExternalAliasDirectiveSection As Integer = 10045

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FieldDeclaration Field

DotNetAstNodeIdFieldDeclaration Field

Gets the FieldDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FieldDeclaration = 10046
Public Const FieldDeclaration As Integer = 10046

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FixedSizeBufferDeclaration Field

DotNetAstNodeIdFixedSizeBufferDeclaration Field

Gets the FixedSizeBufferDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FixedSizeBufferDeclaration = 10047
Public Const FixedSizeBufferDeclaration As Integer = 10047

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FixedSizeBufferDeclarator Field

DotNetAstNodeIdFixedSizeBufferDeclarator Field

Gets the FixedSizeBufferDeclarator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FixedSizeBufferDeclarator = 10048
Public Const FixedSizeBufferDeclarator As Integer = 10048

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FixedStatement Field

DotNetAstNodeIdFixedStatement Field

Gets the FixedStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FixedStatement = 10049
Public Const FixedStatement As Integer = 10049

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ForEachStatement Field

DotNetAstNodeIdForEachStatement Field

Gets the ForEachStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ForEachStatement = 10050
Public Const ForEachStatement As Integer = 10050

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ForStatement Field

DotNetAstNodeIdForStatement Field

Gets the ForStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ForStatement = 10051
Public Const ForStatement As Integer = 10051

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FromQueryOperator Field

DotNetAstNodeIdFromQueryOperator Field

Gets the FromQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FromQueryOperator = 10052
Public Const FromQueryOperator As Integer = 10052

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.GoToStatement Field

DotNetAstNodeIdGoToStatement Field

Gets the GoToStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int GoToStatement = 10053
Public Const GoToStatement As Integer = 10053

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.GroupQueryOperator Field

DotNetAstNodeIdGroupQueryOperator Field

Gets the GroupQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int GroupQueryOperator = 10054
Public Const GroupQueryOperator As Integer = 10054

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.IfStatement Field

DotNetAstNodeIdIfStatement Field

Gets the IfStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int IfStatement = 10055
Public Const IfStatement As Integer = 10055

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InitializerExpression Field

DotNetAstNodeIdInitializerExpression Field

Gets the InitializerExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InitializerExpression = 10056
Public Const InitializerExpression As Integer = 10056

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InstanceExpression Field

DotNetAstNodeIdInstanceExpression Field

Gets the InstanceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InstanceExpression = 10057
Public Const InstanceExpression As Integer = 10057

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceAccessorDeclaration Field

DotNetAstNodeIdInterfaceAccessorDeclaration Field

Gets the InterfaceAccessorDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InterfaceAccessorDeclaration = 10058
Public Const InterfaceAccessorDeclaration As Integer = 10058

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceBody Field

DotNetAstNodeIdInterfaceBody Field

Gets the InterfaceBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InterfaceBody = 10059
Public Const InterfaceBody As Integer = 10059

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceDeclaration Field

DotNetAstNodeIdInterfaceDeclaration Field

Gets the InterfaceDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InterfaceDeclaration = 10060
Public Const InterfaceDeclaration As Integer = 10060

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceEventDeclaration Field

DotNetAstNodeIdInterfaceEventDeclaration Field

Gets the InterfaceEventDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InterfaceEventDeclaration = 10061
Public Const InterfaceEventDeclaration As Integer = 10061

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceMemberDeclaration Field

DotNetAstNodeIdInterfaceMemberDeclaration Field

Gets the InterfaceMemberDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InterfaceMemberDeclaration = 10062
Public Const InterfaceMemberDeclaration As Integer = 10062

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceMethodDeclaration Field

DotNetAstNodeIdInterfaceMethodDeclaration Field

Gets the InterfaceMethodDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InterfaceMethodDeclaration = 10063
Public Const InterfaceMethodDeclaration As Integer = 10063

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfacePropertyDeclaration Field

DotNetAstNodeIdInterfacePropertyDeclaration Field

Gets the InterfacePropertyDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InterfacePropertyDeclaration = 10064
Public Const InterfacePropertyDeclaration As Integer = 10064

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InvocationExpression Field

DotNetAstNodeIdInvocationExpression Field

Gets the InvocationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InvocationExpression = 10065
Public Const InvocationExpression As Integer = 10065

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.IsTypeOfExpression Field

DotNetAstNodeIdIsTypeOfExpression Field

Gets the IsTypeOfExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int IsTypeOfExpression = 10066
Public Const IsTypeOfExpression As Integer = 10066

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.JoinQueryOperator Field

DotNetAstNodeIdJoinQueryOperator Field

Gets the JoinQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int JoinQueryOperator = 10067
Public Const JoinQueryOperator As Integer = 10067

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LabeledStatement Field

DotNetAstNodeIdLabeledStatement Field

Gets the LabeledStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LabeledStatement = 10068
Public Const LabeledStatement As Integer = 10068

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LambdaExpression Field

DotNetAstNodeIdLambdaExpression Field

Gets the LambdaExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LambdaExpression = 10069
Public Const LambdaExpression As Integer = 10069

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LetQueryOperator Field

DotNetAstNodeIdLetQueryOperator Field

Gets the LetQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LetQueryOperator = 10070
Public Const LetQueryOperator As Integer = 10070

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LiteralExpression Field

DotNetAstNodeIdLiteralExpression Field

Gets the LiteralExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralExpression = 10071
Public Const LiteralExpression As Integer = 10071

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LocalVariableDeclaration Field

DotNetAstNodeIdLocalVariableDeclaration Field

Gets the LocalVariableDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LocalVariableDeclaration = 10072
Public Const LocalVariableDeclaration As Integer = 10072

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LockStatement Field

DotNetAstNodeIdLockStatement Field

Gets the LockStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LockStatement = 10073
Public Const LockStatement As Integer = 10073

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MemberAccess Field

DotNetAstNodeIdMemberAccess Field

Gets the MemberAccess AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int MemberAccess = 10074
Public Const MemberAccess As Integer = 10074

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MethodBody Field

DotNetAstNodeIdMethodBody Field

Gets the MethodBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int MethodBody = 10075
Public Const MethodBody As Integer = 10075

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MethodDeclaration Field

DotNetAstNodeIdMethodDeclaration Field

Gets the MethodDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int MethodDeclaration = 10076
Public Const MethodDeclaration As Integer = 10076

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.NameOfExpression Field

DotNetAstNodeIdNameOfExpression Field

Gets the NameOfExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int NameOfExpression = 10077
Public Const NameOfExpression As Integer = 10077

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.NamespaceBody Field

DotNetAstNodeIdNamespaceBody Field

Gets the NamespaceBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int NamespaceBody = 10078
Public Const NamespaceBody As Integer = 10078

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.NamespaceDeclaration Field

DotNetAstNodeIdNamespaceDeclaration Field

Gets the NamespaceDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int NamespaceDeclaration = 10079
Public Const NamespaceDeclaration As Integer = 10079

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ObjectCreationExpression Field

DotNetAstNodeIdObjectCreationExpression Field

Gets the ObjectCreationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ObjectCreationExpression = 10080
Public Const ObjectCreationExpression As Integer = 10080

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.OperatorBody Field

DotNetAstNodeIdOperatorBody Field

Gets the OperatorBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBody = 10081
Public Const OperatorBody As Integer = 10081

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.OperatorDeclaration Field

DotNetAstNodeIdOperatorDeclaration Field

Gets the OperatorDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorDeclaration = 10082
Public Const OperatorDeclaration As Integer = 10082

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.OrderByQueryOperator Field

DotNetAstNodeIdOrderByQueryOperator Field

Gets the OrderByQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OrderByQueryOperator = 10083
Public Const OrderByQueryOperator As Integer = 10083

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Ordering Field

DotNetAstNodeIdOrdering Field

Gets the Ordering AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Ordering = 10084
Public Const Ordering As Integer = 10084

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ParameterDeclaration Field

DotNetAstNodeIdParameterDeclaration Field

Gets the ParameterDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ParameterDeclaration = 10085
Public Const ParameterDeclaration As Integer = 10085

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ParenthesizedExpression Field

DotNetAstNodeIdParenthesizedExpression Field

Gets the ParenthesizedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ParenthesizedExpression = 10086
Public Const ParenthesizedExpression As Integer = 10086

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.PreprocessorDirective Field

DotNetAstNodeIdPreprocessorDirective Field

Gets the PreprocessorDirective AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirective = 10087
Public Const PreprocessorDirective As Integer = 10087

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.PropertyBody Field

DotNetAstNodeIdPropertyBody Field

Gets the PropertyBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PropertyBody = 10088
Public Const PropertyBody As Integer = 10088

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.PropertyDeclaration Field

DotNetAstNodeIdPropertyDeclaration Field

Gets the PropertyDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PropertyDeclaration = 10089
Public Const PropertyDeclaration As Integer = 10089

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.QualifiedName Field

DotNetAstNodeIdQualifiedName Field

Gets the QualifiedName AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int QualifiedName = 10090
Public Const QualifiedName As Integer = 10090

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.QueryExpression Field

DotNetAstNodeIdQueryExpression Field

Gets the QueryExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int QueryExpression = 10091
Public Const QueryExpression As Integer = 10091

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.QueryOperator Field

DotNetAstNodeIdQueryOperator Field

Gets the QueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int QueryOperator = 10092
Public Const QueryOperator As Integer = 10092

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.RangeVariableDeclaration Field

DotNetAstNodeIdRangeVariableDeclaration Field

Gets the RangeVariableDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int RangeVariableDeclaration = 10093
Public Const RangeVariableDeclaration As Integer = 10093

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.RangeVariableDeclarator Field

DotNetAstNodeIdRangeVariableDeclarator Field

Gets the RangeVariableDeclarator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int RangeVariableDeclarator = 10094
Public Const RangeVariableDeclarator As Integer = 10094

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.RegionPreprocessorDirective Field

DotNetAstNodeIdRegionPreprocessorDirective Field

Gets the RegionPreprocessorDirective AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int RegionPreprocessorDirective = 10095
Public Const RegionPreprocessorDirective As Integer = 10095

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ReturnStatement Field

DotNetAstNodeIdReturnStatement Field

Gets the ReturnStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReturnStatement = 10096
Public Const ReturnStatement As Integer = 10096

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ReturnTypeDeclaration Field

DotNetAstNodeIdReturnTypeDeclaration Field

Gets the ReturnTypeDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReturnTypeDeclaration = 10097
Public Const ReturnTypeDeclaration As Integer = 10097

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ReturnTypeExpression Field

DotNetAstNodeIdReturnTypeExpression Field

Gets the ReturnTypeExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReturnTypeExpression = 10098
Public Const ReturnTypeExpression As Integer = 10098

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SelectQueryOperator Field

DotNetAstNodeIdSelectQueryOperator Field

Gets the SelectQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SelectQueryOperator = 10099
Public Const SelectQueryOperator As Integer = 10099

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SimpleName Field

DotNetAstNodeIdSimpleName Field

Gets the SimpleName AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SimpleName = 10100
Public Const SimpleName As Integer = 10100

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SizeOfExpression Field

DotNetAstNodeIdSizeOfExpression Field

Gets the SizeOfExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SizeOfExpression = 10101
Public Const SizeOfExpression As Integer = 10101

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SkipQueryOperator Field

DotNetAstNodeIdSkipQueryOperator Field

Gets the SkipQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SkipQueryOperator = 10102
Public Const SkipQueryOperator As Integer = 10102

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SkipWhileQueryOperator Field

DotNetAstNodeIdSkipWhileQueryOperator Field

Gets the SkipWhileQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SkipWhileQueryOperator = 10103
Public Const SkipWhileQueryOperator As Integer = 10103

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.StackAllocationInitializer Field

DotNetAstNodeIdStackAllocationInitializer Field

Gets the StackAllocationInitializer AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StackAllocationInitializer = 10104
Public Const StackAllocationInitializer As Integer = 10104

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Statement Field

DotNetAstNodeIdStatement Field

Gets the Statement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Statement = 10105
Public Const Statement As Integer = 10105

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.StopStatement Field

DotNetAstNodeIdStopStatement Field

Gets the StopStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StopStatement = 10106
Public Const StopStatement As Integer = 10106

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.StructureBody Field

DotNetAstNodeIdStructureBody Field

Gets the StructureBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StructureBody = 10107
Public Const StructureBody As Integer = 10107

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.StructureDeclaration Field

DotNetAstNodeIdStructureDeclaration Field

Gets the StructureDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StructureDeclaration = 10108
Public Const StructureDeclaration As Integer = 10108

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SwitchSection Field

DotNetAstNodeIdSwitchSection Field

Gets the SwitchSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SwitchSection = 10109
Public Const SwitchSection As Integer = 10109

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SwitchStatement Field

DotNetAstNodeIdSwitchStatement Field

Gets the SwitchStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SwitchStatement = 10110
Public Const SwitchStatement As Integer = 10110

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TakeQueryOperator Field

DotNetAstNodeIdTakeQueryOperator Field

Gets the TakeQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TakeQueryOperator = 10111
Public Const TakeQueryOperator As Integer = 10111

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TakeWhileQueryOperator Field

DotNetAstNodeIdTakeWhileQueryOperator Field

Gets the TakeWhileQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TakeWhileQueryOperator = 10112
Public Const TakeWhileQueryOperator As Integer = 10112

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ThrowStatement Field

DotNetAstNodeIdThrowStatement Field

Gets the ThrowStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ThrowStatement = 10113
Public Const ThrowStatement As Integer = 10113

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TryCastExpression Field

DotNetAstNodeIdTryCastExpression Field

Gets the TryCastExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TryCastExpression = 10114
Public Const TryCastExpression As Integer = 10114

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TryStatement Field

DotNetAstNodeIdTryStatement Field

Gets the TryStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TryStatement = 10115
Public Const TryStatement As Integer = 10115

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TypeDeclaration Field

DotNetAstNodeIdTypeDeclaration Field

Gets the TypeDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TypeDeclaration = 10116
Public Const TypeDeclaration As Integer = 10116

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TypeMemberDeclaration Field

DotNetAstNodeIdTypeMemberDeclaration Field

Gets the TypeMemberDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TypeMemberDeclaration = 10117
Public Const TypeMemberDeclaration As Integer = 10117

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TypeOfExpression Field

DotNetAstNodeIdTypeOfExpression Field

Gets the TypeOfExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TypeOfExpression = 10118
Public Const TypeOfExpression As Integer = 10118

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TypeParameter Field

DotNetAstNodeIdTypeParameter Field

Gets the TypeParameter AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TypeParameter = 10119
Public Const TypeParameter As Integer = 10119

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnaryOperatorExpression Field

DotNetAstNodeIdUnaryOperatorExpression Field

Gets the UnaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UnaryOperatorExpression = 10120
Public Const UnaryOperatorExpression As Integer = 10120

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UncheckedExpression Field

DotNetAstNodeIdUncheckedExpression Field

Gets the UncheckedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UncheckedExpression = 10121
Public Const UncheckedExpression As Integer = 10121

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UncheckedStatement Field

DotNetAstNodeIdUncheckedStatement Field

Gets the UncheckedStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UncheckedStatement = 10122
Public Const UncheckedStatement As Integer = 10122

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnsafeStatement Field

DotNetAstNodeIdUnsafeStatement Field

Gets the UnsafeStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UnsafeStatement = 10123
Public Const UnsafeStatement As Integer = 10123

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnstructuredErrorHandlerStatement Field

DotNetAstNodeIdUnstructuredErrorHandlerStatement Field

Gets the UnstructuredErrorHandlerStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UnstructuredErrorHandlerStatement = 10124
Public Const UnstructuredErrorHandlerStatement As Integer = 10124

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnstructuredErrorResumeStatement Field

DotNetAstNodeIdUnstructuredErrorResumeStatement Field

Gets the UnstructuredErrorResumeStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UnstructuredErrorResumeStatement = 10125
Public Const UnstructuredErrorResumeStatement As Integer = 10125

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnstructuredErrorThrowStatement Field

DotNetAstNodeIdUnstructuredErrorThrowStatement Field

Gets the UnstructuredErrorThrowStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UnstructuredErrorThrowStatement = 10126
Public Const UnstructuredErrorThrowStatement As Integer = 10126

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UsingDirective Field

DotNetAstNodeIdUsingDirective Field

Gets the UsingDirective AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UsingDirective = 10127
Public Const UsingDirective As Integer = 10127

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UsingDirectiveSection Field

DotNetAstNodeIdUsingDirectiveSection Field

Gets the UsingDirectiveSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UsingDirectiveSection = 10128
Public Const UsingDirectiveSection As Integer = 10128

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UsingStatement Field

DotNetAstNodeIdUsingStatement Field

Gets the UsingStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UsingStatement = 10129
Public Const UsingStatement As Integer = 10129

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.VariableDeclarationExpression Field

DotNetAstNodeIdVariableDeclarationExpression Field

Gets the VariableDeclarationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int VariableDeclarationExpression = 10130
Public Const VariableDeclarationExpression As Integer = 10130

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.VariableDeclarator Field

DotNetAstNodeIdVariableDeclarator Field

Gets the VariableDeclarator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int VariableDeclarator = 10131
Public Const VariableDeclarator As Integer = 10131

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.WhereQueryOperator Field

DotNetAstNodeIdWhereQueryOperator Field

Gets the WhereQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int WhereQueryOperator = 10132
Public Const WhereQueryOperator As Integer = 10132

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.WhileStatement Field

DotNetAstNodeIdWhileStatement Field

Gets the WhileStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int WhileStatement = 10133
Public Const WhileStatement As Integer = 10133

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.WithStatement Field

DotNetAstNodeIdWithStatement Field

Gets the WithStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int WithStatement = 10134
Public Const WithStatement As Integer = 10134

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.WithTargetExpression Field

DotNetAstNodeIdWithTargetExpression Field

Gets the WithTargetExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int WithTargetExpression = 10135
Public Const WithTargetExpression As Integer = 10135

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.XmlNamespaceExpression Field

DotNetAstNodeIdXmlNamespaceExpression Field

Gets the XmlNamespaceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int XmlNamespaceExpression = 10136
Public Const XmlNamespaceExpression As Integer = 10136

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.YieldStatement Field

DotNetAstNodeIdYieldStatement Field

Gets the YieldStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int YieldStatement = 10137
Public Const YieldStatement As Integer = 10137

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection Class

Represents an else if section (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationElseIfSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ElseIfSection : AstNodeBase
Public Class ElseIfSection
    Inherits AstNodeBase

The ElseIfSection type exposes the following members.

Constructors
 | Name | Description
Public method | ElseIfSection | Initializes a new instance of the ElseIfSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection Constructor

Initializes a new instance of the ElseIfSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ElseIfSection()
Public Sub New
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection Properties

The ElseIfSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection.ConditionExpression Property

ElseIfSectionConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection.Id Property

ElseIfSectionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection.Statement Property

ElseIfSectionStatement Property

Gets or sets the statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement Statement { get; set; }
Public Property Statement As Statement
    Get
    Set

Property Value

Type: Statement
The statement.
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection Methods

The ElseIfSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection.GetChildrenEnumerator Method

ElseIfSectionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement Class

Represents an end statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEndStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EndStatement : Statement
Public Class EndStatement
    Inherits Statement

The EndStatement type exposes the following members.

Constructors
 | Name | Description
Public method | EndStatement | Initializes a new instance of the EndStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement Constructor

Initializes a new instance of the EndStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EndStatement()
Public Sub New
See Also

Reference

EndStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement Properties

The EndStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EndStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement.Id Property

EndStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

EndStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement Methods

The EndStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EndStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody Class

Represents an enumeration body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumerationBody : AstNodeBase
Public Class EnumerationBody
    Inherits AstNodeBase

The EnumerationBody type exposes the following members.

Constructors
 | Name | Description
Public method | EnumerationBody | Initializes a new instance of the EnumerationBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody Constructor

Initializes a new instance of the EnumerationBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerationBody()
Public Sub New
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody Properties

The EnumerationBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody.HasMembers Property

EnumerationBodyHasMembers Property

Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody.Id Property

EnumerationBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody.Members Property

EnumerationBodyMembers Property

Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<EnumerationMemberDeclaration> Members { get; }
Public ReadOnly Property Members As IList(Of EnumerationMemberDeclaration)
    Get

Property Value

Type: IList EnumerationMemberDeclaration
The members.
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody Methods

The EnumerationBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody.GetChildrenEnumerator Method

EnumerationBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration Class

Represents an enumeration declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumerationDeclaration : TypeDeclaration
Public Class EnumerationDeclaration
    Inherits TypeDeclaration

The EnumerationDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | EnumerationDeclaration | Initializes a new instance of the EnumerationDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseType | Gets or sets the base type.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration Constructor

Initializes a new instance of the EnumerationDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerationDeclaration()
Public Sub New
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration Properties

The EnumerationDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseType | Gets or sets the base type.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.BaseType Property

EnumerationDeclarationBaseType Property

Gets or sets the base type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName BaseType { get; set; }
Public Property BaseType As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The base type.
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.Body Property

EnumerationDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerationBody Body { get; set; }
Public Property Body As EnumerationBody
    Get
    Set

Property Value

Type: EnumerationBody
The body.
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.Id Property

EnumerationDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.Kind Property

EnumerationDeclarationKind Property

Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration Methods

The EnumerationDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.GetChildrenEnumerator Method

EnumerationDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration Class

Represents an enumeration member declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationMemberDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumerationMemberDeclaration : TypeMemberDeclaration,
    IAstNode, INamedTypeMember
Public Class EnumerationMemberDeclaration
    Inherits TypeMemberDeclaration
    Implements IAstNode, INamedTypeMember

The EnumerationMemberDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | EnumerationMemberDeclaration | Initializes a new instance of the EnumerationMemberDeclaration class.
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration Constructor

Initializes a new instance of the EnumerationMemberDeclaration class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerationMemberDeclaration()
Public Sub New
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration Properties

The EnumerationMemberDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.Id Property

EnumerationMemberDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.Initializer Property

EnumerationMemberDeclarationInitializer Property

Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.Kind Property

EnumerationMemberDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.Name Property

EnumerationMemberDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration Methods

The EnumerationMemberDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.GetChildrenEnumerator Method

EnumerationMemberDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody Class

Represents an event body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEventBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EventBody : AstNodeBase
Public Class EventBody
    Inherits AstNodeBase

The EventBody type exposes the following members.

Constructors
 | Name | Description
Public method | EventBody | Initializes a new instance of the EventBody class
Top
Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody Constructor

Initializes a new instance of the EventBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EventBody()
Public Sub New
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody Properties

The EventBody type exposes the following members.

Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody.Accessors Property

EventBodyAccessors Property

Gets the accessors.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AccessorDeclaration> Accessors { get; }
Public ReadOnly Property Accessors As IList(Of AccessorDeclaration)
    Get

Property Value

Type: IList AccessorDeclaration
The accessors.
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody.HasAccessors Property

EventBodyHasAccessors Property

Returns whether the Accessors collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAccessors { get; }
Public ReadOnly Property HasAccessors As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody.Id Property

EventBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody Methods

The EventBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody.GetChildrenEnumerator Method

EventBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration Class

Represents an event declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEventDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EventDeclaration : TypeMemberDeclaration
Public Class EventDeclaration
    Inherits TypeMemberDeclaration

The EventDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | EventDeclaration | Initializes a new instance of the EventDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DelegateDeclaration | Gets or sets the delegate declaration.
Public property | DelegateType | Gets or sets the delegate type.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration Constructor

Initializes a new instance of the EventDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EventDeclaration()
Public Sub New
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration Properties

The EventDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DelegateDeclaration | Gets or sets the delegate declaration.
Public property | DelegateType | Gets or sets the delegate type.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Body Property

EventDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EventBody Body { get; set; }
Public Property Body As EventBody
    Get
    Set

Property Value

Type: EventBody
The body.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Declarators Property

EventDeclarationDeclarators Property

Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The declarators.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.DelegateDeclaration Property

EventDeclarationDelegateDeclaration Property

Gets or sets the delegate declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DelegateDeclaration DelegateDeclaration { get; set; }
Public Property DelegateDeclaration As DelegateDeclaration
    Get
    Set

Property Value

Type: DelegateDeclaration
The delegate declaration.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.DelegateType Property

EventDeclarationDelegateType Property

Gets or sets the delegate type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName DelegateType { get; set; }
Public Property DelegateType As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The delegate type.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.HasDeclarators Property

EventDeclarationHasDeclarators Property

Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.HasImplements Property

EventDeclarationHasImplements Property

Returns whether the Implements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasImplements { get; }
Public ReadOnly Property HasImplements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Id Property

EventDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Implements Property

EventDeclarationImplements Property

Gets the implements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QualifiedName> Implements { get; }
Public ReadOnly Property Implements As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The implements.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Kind Property

EventDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration Methods

The EventDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.GetChildrenEnumerator Method

EventDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement Class

Represents an exit statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExitStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExitStatement : Statement
Public Class ExitStatement
    Inherits Statement

The ExitStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExitStatement | Initializes a new instance of the ExitStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement Constructor

Initializes a new instance of the ExitStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExitStatement()
Public Sub New
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement Properties

The ExitStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement.Id Property

ExitStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement.Kind Property

ExitStatementKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExitKind Kind { get; set; }
Public Property Kind As ExitKind
    Get
    Set

Property Value

Type: ExitKind
The kind.
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement Methods

The ExitStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression Class

Represents an expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
More...

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Expression : AstNodeBase
Public Class Expression
    Inherits AstNodeBase

The Expression type exposes the following members.

Constructors
 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
 | FromQualifiedName(IQualifiedName) | Creates an AST Expression from an IQualifiedName.
 | FromQualifiedName(QualifiedName) | Creates an AST Expression from an AST QualifiedName.
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAddressOfExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAnonymousMethodExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAssignmentExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAwaitExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBinaryOperatorExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCastExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCheckedExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConditionalExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDefaultValueExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInitializerExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInstanceExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInvocationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationIsTypeOfExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLambdaExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLiteralExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMemberAccess
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNameOfExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationObjectCreationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationParenthesizedExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnTypeExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSimpleName
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSizeOfExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStackAllocationInitializer
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTryCastExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeOfExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnaryOperatorExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUncheckedExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationVariableDeclarationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWithTargetExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationXmlNamespaceExpression


Expression Constructor

Initializes a new instance of the Expression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression()
Public Sub New
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression Properties

The Expression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression.Id Property

ExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression Methods

The Expression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
 | FromQualifiedName(IQualifiedName) | Creates an AST Expression from an IQualifiedName.
 | FromQualifiedName(QualifiedName) | Creates an AST Expression from an AST QualifiedName.
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression.FromQualifiedName Method

ExpressionFromQualifiedName Method

Overload List
Name | Description
FromQualifiedName(IQualifiedName) | Creates an AST Expression from an IQualifiedName.
FromQualifiedName(QualifiedName) | Creates an AST Expression from an AST QualifiedName.
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression.FromQualifiedName Method (IQualifiedName)

ExpressionFromQualifiedName Method (IQualifiedName)

Creates an AST Expression from an IQualifiedName.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Expression FromQualifiedName(
    IQualifiedName qualifiedName
)
Public Shared Function FromQualifiedName (
    qualifiedName As IQualifiedName
) As Expression

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIQualifiedName
The IQualifiedName to examine.

Return Value

Type: Expression
The AST Expression that was created.
See Also

Reference

Expression Class
FromQualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression.FromQualifiedName Method (QualifiedName)

ExpressionFromQualifiedName Method (QualifiedName)

Creates an AST Expression from an AST QualifiedName.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Expression FromQualifiedName(
    QualifiedName qualifiedName
)
Public Shared Function FromQualifiedName (
    qualifiedName As QualifiedName
) As Expression

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
The AST QualifiedName to examine.

Return Value

Type: Expression
The AST Expression that was created.
See Also

Reference

Expression Class
FromQualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement Class

Represents an expression statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpressionStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExpressionStatement : Statement
Public Class ExpressionStatement
    Inherits Statement

The ExpressionStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionStatement | Initializes a new instance of the ExpressionStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement Constructor

Initializes a new instance of the ExpressionStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpressionStatement()
Public Sub New
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement Properties

The ExpressionStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement.Expression Property

ExpressionStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement.Id Property

ExpressionStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement Methods

The ExpressionStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement.GetChildrenEnumerator Method

ExpressionStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective Class

Represents an external alias directive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExternalAliasDirective

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExternalAliasDirective : AstNodeBase
Public Class ExternalAliasDirective
    Inherits AstNodeBase

The ExternalAliasDirective type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalAliasDirective | Initializes a new instance of the ExternalAliasDirective class
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective Constructor

Initializes a new instance of the ExternalAliasDirective class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExternalAliasDirective()
Public Sub New
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective Properties

The ExternalAliasDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective.Alias Property

ExternalAliasDirectiveAlias Property

Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective.Id Property

ExternalAliasDirectiveId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective Methods

The ExternalAliasDirective type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection Class

Represents an external alias directive section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExternalAliasDirectiveSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExternalAliasDirectiveSection : AstNodeBase
Public Class ExternalAliasDirectiveSection
    Inherits AstNodeBase

The ExternalAliasDirectiveSection type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalAliasDirectiveSection | Initializes a new instance of the ExternalAliasDirectiveSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Directives | Gets the directives.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDirectives | Returns whether the Directives collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection Constructor

Initializes a new instance of the ExternalAliasDirectiveSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExternalAliasDirectiveSection()
Public Sub New
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection Properties

The ExternalAliasDirectiveSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Directives | Gets the directives.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDirectives | Returns whether the Directives collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection.Directives Property

ExternalAliasDirectiveSectionDirectives Property

Gets the directives.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ExternalAliasDirective> Directives { get; }
Public ReadOnly Property Directives As IList(Of ExternalAliasDirective)
    Get

Property Value

Type: IList ExternalAliasDirective
The directives.
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection.HasDirectives Property

ExternalAliasDirectiveSectionHasDirectives Property

Returns whether the Directives collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDirectives { get; }
Public ReadOnly Property HasDirectives As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection.Id Property

ExternalAliasDirectiveSectionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection Methods

The ExternalAliasDirectiveSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection.GetChildrenEnumerator Method

ExternalAliasDirectiveSectionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration Class

Represents a field declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFieldDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FieldDeclaration : TypeMemberDeclaration
Public Class FieldDeclaration
    Inherits TypeMemberDeclaration

The FieldDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | FieldDeclaration | Initializes a new instance of the FieldDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration Constructor

Initializes a new instance of the FieldDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FieldDeclaration()
Public Sub New
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration Properties

The FieldDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.Declarators Property

FieldDeclarationDeclarators Property

Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The declarators.
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.HasDeclarators Property

FieldDeclarationHasDeclarators Property

Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.Id Property

FieldDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.Kind Property

FieldDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration Methods

The FieldDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.GetChildrenEnumerator Method

FieldDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration Class

Represents a fixed size buffer declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedSizeBufferDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FixedSizeBufferDeclaration : TypeMemberDeclaration
Public Class FixedSizeBufferDeclaration
    Inherits TypeMemberDeclaration

The FixedSizeBufferDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | FixedSizeBufferDeclaration | Initializes a new instance of the FixedSizeBufferDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration Constructor

Initializes a new instance of the FixedSizeBufferDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FixedSizeBufferDeclaration()
Public Sub New
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration Properties

The FixedSizeBufferDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.Declarators Property

FixedSizeBufferDeclarationDeclarators Property

Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<FixedSizeBufferDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of FixedSizeBufferDeclarator)
    Get

Property Value

Type: IList FixedSizeBufferDeclarator
The declarators.
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.HasDeclarators Property

FixedSizeBufferDeclarationHasDeclarators Property

Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.Id Property

FixedSizeBufferDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.Kind Property

FixedSizeBufferDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration Methods

The FixedSizeBufferDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.GetChildrenEnumerator Method

FixedSizeBufferDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator Class

Represents a fixed size buffer declarator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedSizeBufferDeclarator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FixedSizeBufferDeclarator : AstNodeBase
Public Class FixedSizeBufferDeclarator
    Inherits AstNodeBase

The FixedSizeBufferDeclarator type exposes the following members.

Constructors
 | Name | Description
Public method | FixedSizeBufferDeclarator | Initializes a new instance of the FixedSizeBufferDeclarator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | SizeExpression | Gets or sets the size expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator Constructor

Initializes a new instance of the FixedSizeBufferDeclarator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FixedSizeBufferDeclarator()
Public Sub New
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator Properties

The FixedSizeBufferDeclarator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | SizeExpression | Gets or sets the size expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.Id Property

FixedSizeBufferDeclaratorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.Name Property

FixedSizeBufferDeclaratorName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.SizeExpression Property

FixedSizeBufferDeclaratorSizeExpression Property

Gets or sets the size expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression SizeExpression { get; set; }
Public Property SizeExpression As Expression
    Get
    Set

Property Value

Type: Expression
The size expression.
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.Type Property

FixedSizeBufferDeclaratorType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator Methods

The FixedSizeBufferDeclarator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.GetChildrenEnumerator Method

FixedSizeBufferDeclaratorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement Class

Represents a fixed statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FixedStatement : Statement
Public Class FixedStatement
    Inherits Statement

The FixedStatement type exposes the following members.

Constructors
 | Name | Description
Public method | FixedStatement | Initializes a new instance of the FixedStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasVariableDeclarators | Returns whether the VariableDeclarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclarators | Gets the variable declarators.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement Constructor

Initializes a new instance of the FixedStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FixedStatement()
Public Sub New
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement Properties

The FixedStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasVariableDeclarators | Returns whether the VariableDeclarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclarators | Gets the variable declarators.
Top
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.ChildStatement Property

FixedStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.HasVariableDeclarators Property

FixedStatementHasVariableDeclarators Property

Returns whether the VariableDeclarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasVariableDeclarators { get; }
Public ReadOnly Property HasVariableDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.Id Property

FixedStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.VariableDeclarators Property

FixedStatementVariableDeclarators Property

Gets the variable declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> VariableDeclarators { get; }
Public ReadOnly Property VariableDeclarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The variable declarators.
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement Methods

The FixedStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.GetChildrenEnumerator Method

FixedStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement Class

Represents a for each statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationForEachStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ForEachStatement : Statement
Public Class ForEachStatement
    Inherits Statement

The ForEachStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForEachStatement | Initializes a new instance of the ForEachStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement Constructor

Initializes a new instance of the ForEachStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ForEachStatement()
Public Sub New
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement Properties

The ForEachStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.ChildStatement Property

ForEachStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.ElementExpression Property

ForEachStatementElementExpression Property

Gets or sets the element expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ElementExpression { get; set; }
Public Property ElementExpression As Expression
    Get
    Set

Property Value

Type: Expression
The element expression.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.EnumerableExpression Property

ForEachStatementEnumerableExpression Property

Gets or sets the enumerable expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression EnumerableExpression { get; set; }
Public Property EnumerableExpression As Expression
    Get
    Set

Property Value

Type: Expression
The enumerable expression.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.Id Property

ForEachStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement Methods

The ForEachStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.GetChildrenEnumerator Method

ForEachStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement Class

Represents a for statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationForStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ForStatement : Statement
Public Class ForStatement
    Inherits Statement

The ForStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForStatement | Initializes a new instance of the ForStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializerExpressions | Returns whether the InitializerExpressions collection property contains at least one item.
Public property | HasIteratorExpressions | Returns whether the IteratorExpressions collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | InitializerExpressions | Gets the initializer expressions.
Public property | IteratorExpressions | Gets the iterator expressions.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement Constructor

Initializes a new instance of the ForStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ForStatement()
Public Sub New
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement Properties

The ForStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializerExpressions | Returns whether the InitializerExpressions collection property contains at least one item.
Public property | HasIteratorExpressions | Returns whether the IteratorExpressions collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | InitializerExpressions | Gets the initializer expressions.
Public property | IteratorExpressions | Gets the iterator expressions.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.ChildStatement Property

ForStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.ConditionExpression Property

ForStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.HasInitializerExpressions Property

ForStatementHasInitializerExpressions Property

Returns whether the InitializerExpressions collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasInitializerExpressions { get; }
Public ReadOnly Property HasInitializerExpressions As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.HasIteratorExpressions Property

ForStatementHasIteratorExpressions Property

Returns whether the IteratorExpressions collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasIteratorExpressions { get; }
Public ReadOnly Property HasIteratorExpressions As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.Id Property

ForStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.InitializerExpressions Property

ForStatementInitializerExpressions Property

Gets the initializer expressions.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> InitializerExpressions { get; }
Public ReadOnly Property InitializerExpressions As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The initializer expressions.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.IteratorExpressions Property

ForStatementIteratorExpressions Property

Gets the iterator expressions.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> IteratorExpressions { get; }
Public ReadOnly Property IteratorExpressions As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The iterator expressions.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement Methods

The ForStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.GetChildrenEnumerator Method

ForStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator Class

Represents a from query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFromQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FromQueryOperator : QueryOperator
Public Class FromQueryOperator
    Inherits QueryOperator

The FromQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | FromQueryOperator | Initializes a new instance of the FromQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator Constructor

Initializes a new instance of the FromQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FromQueryOperator()
Public Sub New
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator Properties

The FromQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator.Declarators Property

FromQueryOperatorDeclarators Property

Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<RangeVariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of RangeVariableDeclarator)
    Get

Property Value

Type: IList RangeVariableDeclarator
The declarators.
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator.HasDeclarators Property

FromQueryOperatorHasDeclarators Property

Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator.Id Property

FromQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator Methods

The FromQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator.GetChildrenEnumerator Method

FromQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement Class

Represents a go to statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationGoToStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GoToStatement : Statement
Public Class GoToStatement
    Inherits Statement

The GoToStatement type exposes the following members.

Constructors
 | Name | Description
Public method | GoToStatement | Initializes a new instance of the GoToStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement Constructor

Initializes a new instance of the GoToStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GoToStatement()
Public Sub New
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement Properties

The GoToStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement.Id Property

GoToStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement.Label Property

GoToStatementLabel Property

Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Label { get; set; }
Public Property Label As Expression
    Get
    Set

Property Value

Type: Expression
The label.
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement Methods

The GoToStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement.GetChildrenEnumerator Method

GoToStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator Class

Represents a group query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationGroupQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GroupQueryOperator : QueryOperator
Public Class GroupQueryOperator
    Inherits QueryOperator

The GroupQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | GroupQueryOperator | Initializes a new instance of the GroupQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Key | Gets or sets the key.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | Source | Gets or sets the source.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator Constructor

Initializes a new instance of the GroupQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GroupQueryOperator()
Public Sub New
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator Properties

The GroupQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Key | Gets or sets the key.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | Source | Gets or sets the source.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.Id Property

GroupQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.Key Property

GroupQueryOperatorKey Property

Gets or sets the key.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Key { get; set; }
Public Property Key As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The key.
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.Projection Property

GroupQueryOperatorProjection Property

Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.Source Property

GroupQueryOperatorSource Property

Gets or sets the source.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Source { get; set; }
Public Property Source As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The source.
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator Methods

The GroupQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.GetChildrenEnumerator Method

GroupQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement Class

Represents an if statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationIfStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class IfStatement : Statement
Public Class IfStatement
    Inherits Statement

The IfStatement type exposes the following members.

Constructors
 | Name | Description
Public method | IfStatement | Initializes a new instance of the IfStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | ElseIfSections | Gets the else if sections.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseStatement | Gets or sets the false statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasElseIfSections | Returns whether the ElseIfSections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueStatement | Gets or sets the true statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement Constructor

Initializes a new instance of the IfStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IfStatement()
Public Sub New
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement Properties

The IfStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | ElseIfSections | Gets the else if sections.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseStatement | Gets or sets the false statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasElseIfSections | Returns whether the ElseIfSections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueStatement | Gets or sets the true statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.ConditionExpression Property

IfStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.ElseIfSections Property

IfStatementElseIfSections Property

Gets the else if sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ElseIfSection> ElseIfSections { get; }
Public ReadOnly Property ElseIfSections As IList(Of ElseIfSection)
    Get

Property Value

Type: IList ElseIfSection
The else if sections.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.FalseStatement Property

IfStatementFalseStatement Property

Gets or sets the false statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement FalseStatement { get; set; }
Public Property FalseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The false statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.HasElseIfSections Property

IfStatementHasElseIfSections Property

Returns whether the ElseIfSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasElseIfSections { get; }
Public ReadOnly Property HasElseIfSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.Id Property

IfStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.TrueStatement Property

IfStatementTrueStatement Property

Gets or sets the true statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement TrueStatement { get; set; }
Public Property TrueStatement As Statement
    Get
    Set

Property Value

Type: Statement
The true statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement Methods

The IfStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.GetChildrenEnumerator Method

IfStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression Class

Represents an initializer expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInitializerExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InitializerExpression : Expression
Public Class InitializerExpression
    Inherits Expression

The InitializerExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InitializerExpression | Initializes a new instance of the InitializerExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializers | Returns whether the Initializers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializers | Gets the initializers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression Constructor

Initializes a new instance of the InitializerExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InitializerExpression()
Public Sub New
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression Properties

The InitializerExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializers | Returns whether the Initializers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializers | Gets the initializers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression.HasInitializers Property

InitializerExpressionHasInitializers Property

Returns whether the Initializers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasInitializers { get; }
Public ReadOnly Property HasInitializers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression.Id Property

InitializerExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression.Initializers Property

InitializerExpressionInitializers Property

Gets the initializers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Initializers { get; }
Public ReadOnly Property Initializers As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The initializers.
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression Methods

The InitializerExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression.GetChildrenEnumerator Method

InitializerExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression Class

Represents an instance expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInstanceExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InstanceExpression : Expression
Public Class InstanceExpression
    Inherits Expression

The InstanceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InstanceExpression | Initializes a new instance of the InstanceExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression Constructor

Initializes a new instance of the InstanceExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InstanceExpression()
Public Sub New
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression Properties

The InstanceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression.Id Property

InstanceExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression Methods

The InstanceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration Class

Represents an interface accessor declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceAccessorDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InterfaceAccessorDeclaration : AstNodeBase
Public Class InterfaceAccessorDeclaration
    Inherits AstNodeBase

The InterfaceAccessorDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceAccessorDeclaration | Initializes a new instance of the InterfaceAccessorDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration Constructor

Initializes a new instance of the InterfaceAccessorDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InterfaceAccessorDeclaration()
Public Sub New
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration Properties

The InterfaceAccessorDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.AttributeSections Property

InterfaceAccessorDeclarationAttributeSections Property

Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.HasAttributeSections Property

InterfaceAccessorDeclarationHasAttributeSections Property

Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.Id Property

InterfaceAccessorDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.Kind Property

InterfaceAccessorDeclarationKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AccessorKind Kind { get; set; }
Public Property Kind As AccessorKind
    Get
    Set

Property Value

Type: AccessorKind
The kind.
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration Methods

The InterfaceAccessorDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.GetChildrenEnumerator Method

InterfaceAccessorDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody Class

Represents an interface body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InterfaceBody : AstNodeBase
Public Class InterfaceBody
    Inherits AstNodeBase

The InterfaceBody type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceBody | Initializes a new instance of the InterfaceBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody Constructor

Initializes a new instance of the InterfaceBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InterfaceBody()
Public Sub New
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody Properties

The InterfaceBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody.HasMembers Property

InterfaceBodyHasMembers Property

Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody.Id Property

InterfaceBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody.Members Property

InterfaceBodyMembers Property

Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody Methods

The InterfaceBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody.GetChildrenEnumerator Method

InterfaceBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration Class

Represents an interface declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InterfaceDeclaration : TypeDeclaration
Public Class InterfaceDeclaration
    Inherits TypeDeclaration

The InterfaceDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceDeclaration | Initializes a new instance of the InterfaceDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration Constructor

Initializes a new instance of the InterfaceDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InterfaceDeclaration()
Public Sub New
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration Properties

The InterfaceDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.BaseTypes Property

InterfaceDeclarationBaseTypes Property

Gets the base types.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QualifiedName> BaseTypes { get; }
Public ReadOnly Property BaseTypes As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The base types.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.Body Property

InterfaceDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InterfaceBody Body { get; set; }
Public Property Body As InterfaceBody
    Get
    Set

Property Value

Type: InterfaceBody
The body.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.HasBaseTypes Property

InterfaceDeclarationHasBaseTypes Property

Returns whether the BaseTypes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasBaseTypes { get; }
Public ReadOnly Property HasBaseTypes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.HasTypeParameters Property

InterfaceDeclarationHasTypeParameters Property

Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.Id Property

InterfaceDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.Kind Property

InterfaceDeclarationKind Property

Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.TypeParameters Property

InterfaceDeclarationTypeParameters Property

Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration Methods

The InterfaceDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.GetChildrenEnumerator Method

InterfaceDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration Class

Represents an interface event declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceEventDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InterfaceEventDeclaration : InterfaceMemberDeclaration,
    IAstNode, INamedTypeMember
Public Class InterfaceEventDeclaration
    Inherits InterfaceMemberDeclaration
    Implements IAstNode, INamedTypeMember

The InterfaceEventDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceEventDeclaration | Initializes a new instance of the InterfaceEventDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DelegateDeclaration | Gets or sets the delegate declaration.
Public property | DelegateType | Gets or sets the delegate type.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration Constructor

Initializes a new instance of the InterfaceEventDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InterfaceEventDeclaration()
Public Sub New
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration Properties

The InterfaceEventDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DelegateDeclaration | Gets or sets the delegate declaration.
Public property | DelegateType | Gets or sets the delegate type.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.DelegateDeclaration Property

InterfaceEventDeclarationDelegateDeclaration Property

Gets or sets the delegate declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DelegateDeclaration DelegateDeclaration { get; set; }
Public Property DelegateDeclaration As DelegateDeclaration
    Get
    Set

Property Value

Type: DelegateDeclaration
The delegate declaration.
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.DelegateType Property

InterfaceEventDeclarationDelegateType Property

Gets or sets the delegate type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName DelegateType { get; set; }
Public Property DelegateType As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The delegate type.
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.Id Property

InterfaceEventDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.Kind Property

InterfaceEventDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.Name Property

InterfaceEventDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration Methods

The InterfaceEventDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.GetChildrenEnumerator Method

InterfaceEventDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration Class

Represents an interface member declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceEventDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMethodDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfacePropertyDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class InterfaceMemberDeclaration : TypeMemberDeclaration
Public MustInherit Class InterfaceMemberDeclaration
    Inherits TypeMemberDeclaration

The InterfaceMemberDeclaration type exposes the following members.

Constructors
 | Name | Description
Protected method | InterfaceMemberDeclaration | Initializes a new instance of the InterfaceMemberDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Inherited from TypeMemberDeclaration.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from TypeMemberDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration Constructor

Initializes a new instance of the InterfaceMemberDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected InterfaceMemberDeclaration()
Protected Sub New
See Also

Reference

InterfaceMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration Properties

The InterfaceMemberDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Inherited from TypeMemberDeclaration.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration.Id Property

InterfaceMemberDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

InterfaceMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration Methods

The InterfaceMemberDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from TypeMemberDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration Class

Represents an interface method declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMethodDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InterfaceMethodDeclaration : InterfaceMemberDeclaration,
    IAstNode, INamedTypeMember
Public Class InterfaceMethodDeclaration
    Inherits InterfaceMemberDeclaration
    Implements IAstNode, INamedTypeMember

The InterfaceMethodDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceMethodDeclaration | Initializes a new instance of the InterfaceMethodDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration Constructor

Initializes a new instance of the InterfaceMethodDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InterfaceMethodDeclaration()
Public Sub New
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration Properties

The InterfaceMethodDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.HasParameters Property

InterfaceMethodDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.HasTypeParameters Property

InterfaceMethodDeclarationHasTypeParameters Property

Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.Id Property

InterfaceMethodDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.Kind Property

InterfaceMethodDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.Name Property

InterfaceMethodDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.Parameters Property

InterfaceMethodDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.ReturnType Property

InterfaceMethodDeclarationReturnType Property

Gets or sets the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration ReturnType { get; set; }
Public Property ReturnType As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The return type.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.TypeParameters Property

InterfaceMethodDeclarationTypeParameters Property

Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration Methods

The InterfaceMethodDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.GetChildrenEnumerator Method

InterfaceMethodDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration Class

Represents an interface property declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfacePropertyDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InterfacePropertyDeclaration : InterfaceMemberDeclaration,
    IAstNode, INamedTypeMember
Public Class InterfacePropertyDeclaration
    Inherits InterfaceMemberDeclaration
    Implements IAstNode, INamedTypeMember

The InterfacePropertyDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfacePropertyDeclaration | Initializes a new instance of the InterfacePropertyDeclaration class
Top
Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration Constructor

Initializes a new instance of the InterfacePropertyDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InterfacePropertyDeclaration()
Public Sub New
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration Properties

The InterfacePropertyDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Accessors Property

InterfacePropertyDeclarationAccessors Property

Gets the accessors.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<InterfaceAccessorDeclaration> Accessors { get; }
Public ReadOnly Property Accessors As IList(Of InterfaceAccessorDeclaration)
    Get

Property Value

Type: IList InterfaceAccessorDeclaration
The accessors.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.HasAccessors Property

InterfacePropertyDeclarationHasAccessors Property

Returns whether the Accessors collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAccessors { get; }
Public ReadOnly Property HasAccessors As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.HasParameters Property

InterfacePropertyDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Id Property

InterfacePropertyDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Kind Property

InterfacePropertyDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Name Property

InterfacePropertyDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Parameters Property

InterfacePropertyDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Type Property

InterfacePropertyDeclarationType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration Type { get; set; }
Public Property Type As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The type.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration Methods

The InterfacePropertyDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.GetChildrenEnumerator Method

InterfacePropertyDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression Class

Represents an invocation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInvocationExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InvocationExpression : Expression
Public Class InvocationExpression
    Inherits Expression

The InvocationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InvocationExpression | Initializes a new instance of the InvocationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v17.1.651.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression Constructor

Initializes a new instance of the InvocationExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvocationExpression()
Public Sub New
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression Properties

The InvocationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.Arguments Property

InvocationExpressionArguments Property

Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.HasArguments Property

InvocationExpressionHasArguments Property

Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.Id Property

InvocationExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.Kind Property

InvocationExpressionKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvocationExpressionKind Kind { get; set; }
Public Property Kind As InvocationExpressionKind
    Get
    Set

Property Value

Type: InvocationExpressionKind
The kind.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.TargetExpression Property

InvocationExpressionTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression Methods

The InvocationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.GetChildrenEnumerator Method

InvocationExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression Class

Represents an is type of expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationIsTypeOfExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class IsTypeOfExpression : Expression
Public Class IsTypeOfExpression
    Inherits Expression

The IsTypeOfExpression type exposes the following members.

Constructors
 | Name | Description
Public method | IsTypeOfExpression | Initializes a new instance of the IsTypeOfExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression Constructor

Initializes a new instance of the IsTypeOfExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IsTypeOfExpression()
Public Sub New
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression Properties

The IsTypeOfExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression.ChildExpression Property

IsTypeOfExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression.Id Property

IsTypeOfExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression.Type Property

IsTypeOfExpressionType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression Methods

The IsTypeOfExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression.GetChildrenEnumerator Method

IsTypeOfExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator Class

Represents a join query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationJoinQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JoinQueryOperator : QueryOperator
Public Class JoinQueryOperator
    Inherits QueryOperator

The JoinQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | JoinQueryOperator | Initializes a new instance of the JoinQueryOperator class
Top
Properties
 | Name | Description
Public property | ChildJoin | Gets or sets the child join.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarator | Gets or sets the declarator.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | LeftKeyExpression | Gets or sets the left key expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | RightKeyExpression | Gets or sets the right key expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator Constructor

Initializes a new instance of the JoinQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JoinQueryOperator()
Public Sub New
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator Properties

The JoinQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | ChildJoin | Gets or sets the child join.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarator | Gets or sets the declarator.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | LeftKeyExpression | Gets or sets the left key expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | RightKeyExpression | Gets or sets the right key expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.ChildJoin Property

JoinQueryOperatorChildJoin Property

Gets or sets the child join.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JoinQueryOperator ChildJoin { get; set; }
Public Property ChildJoin As JoinQueryOperator
    Get
    Set

Property Value

Type: JoinQueryOperator
The child join.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.Declarator Property

JoinQueryOperatorDeclarator Property

Gets or sets the declarator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclarator Declarator { get; set; }
Public Property Declarator As RangeVariableDeclarator
    Get
    Set

Property Value

Type: RangeVariableDeclarator
The declarator.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.Id Property

JoinQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.LeftKeyExpression Property

JoinQueryOperatorLeftKeyExpression Property

Gets or sets the left key expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression LeftKeyExpression { get; set; }
Public Property LeftKeyExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left key expression.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.Projection Property

JoinQueryOperatorProjection Property

Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.RightKeyExpression Property

JoinQueryOperatorRightKeyExpression Property

Gets or sets the right key expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression RightKeyExpression { get; set; }
Public Property RightKeyExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right key expression.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator Methods

The JoinQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.GetChildrenEnumerator Method

JoinQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement Class

Represents a labeled statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLabeledStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LabeledStatement : Statement
Public Class LabeledStatement
    Inherits Statement

The LabeledStatement type exposes the following members.

Constructors
 | Name | Description
Public method | LabeledStatement | Initializes a new instance of the LabeledStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement Constructor

Initializes a new instance of the LabeledStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LabeledStatement()
Public Sub New
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement Properties

The LabeledStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement.ChildStatement Property

LabeledStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement.Id Property

LabeledStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement.Label Property

LabeledStatementLabel Property

Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Label { get; set; }
Public Property Label As Expression
    Get
    Set

Property Value

Type: Expression
The label.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement Methods

The LabeledStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement.GetChildrenEnumerator Method

LabeledStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression Class

Represents a lambda expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLambdaExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LambdaExpression : Expression
Public Class LambdaExpression
    Inherits Expression

The LambdaExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LambdaExpression | Initializes a new instance of the LambdaExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression Constructor

Initializes a new instance of the LambdaExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LambdaExpression()
Public Sub New
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression Properties

The LambdaExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.HasParameters Property

LambdaExpressionHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.HasStatements Property

LambdaExpressionHasStatements Property

Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.Id Property

LambdaExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.Modifiers Property

LambdaExpressionModifiers Property

Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.Parameters Property

LambdaExpressionParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.Statements Property

LambdaExpressionStatements Property

Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression Methods

The LambdaExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.GetChildrenEnumerator Method

LambdaExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator Class

Represents a let query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLetQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LetQueryOperator : QueryOperator
Public Class LetQueryOperator
    Inherits QueryOperator

The LetQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | LetQueryOperator | Initializes a new instance of the LetQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator Constructor

Initializes a new instance of the LetQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LetQueryOperator()
Public Sub New
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator Properties

The LetQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator.Id Property

LetQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator.Projection Property

LetQueryOperatorProjection Property

Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator Methods

The LetQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator.GetChildrenEnumerator Method

LetQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression Class

Represents a literal expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLiteralExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LiteralExpression : Expression
Public Class LiteralExpression
    Inherits Expression

The LiteralExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LiteralExpression | Initializes a new instance of the LiteralExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind of literal.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression Constructor

Initializes a new instance of the LiteralExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LiteralExpression()
Public Sub New
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression Properties

The LiteralExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind of literal.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression.Id Property

LiteralExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression.Kind Property

LiteralExpressionKind Property

Gets or sets the kind of literal.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LiteralExpressionKind Kind { get; set; }
Public Property Kind As LiteralExpressionKind
    Get
    Set

Property Value

Type: LiteralExpressionKind
The kind of literal.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression.StringValue Property

LiteralExpressionStringValue Property

Gets or sets the string value.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string StringValue { get; set; }
Public Property StringValue As String
    Get
    Set

Property Value

Type: String
The string value.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression Methods

The LiteralExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration Class

Represents a local variable declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLocalVariableDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LocalVariableDeclaration : Statement
Public Class LocalVariableDeclaration
    Inherits Statement

The LocalVariableDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | LocalVariableDeclaration | Initializes a new instance of the LocalVariableDeclaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration Constructor

Initializes a new instance of the LocalVariableDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LocalVariableDeclaration()
Public Sub New
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration Properties

The LocalVariableDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration.Declarators Property

LocalVariableDeclarationDeclarators Property

Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The declarators.
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration.HasDeclarators Property

LocalVariableDeclarationHasDeclarators Property

Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration.Id Property

LocalVariableDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration Methods

The LocalVariableDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration.GetChildrenEnumerator Method

LocalVariableDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement Class

Represents a lock statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLockStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LockStatement : Statement
Public Class LockStatement
    Inherits Statement

The LockStatement type exposes the following members.

Constructors
 | Name | Description
Public method | LockStatement | Initializes a new instance of the LockStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement Constructor

Initializes a new instance of the LockStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LockStatement()
Public Sub New
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement Properties

The LockStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement.ChildStatement Property

LockStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement.Expression Property

LockStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement.Id Property

LockStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement Methods

The LockStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement.GetChildrenEnumerator Method

LockStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess Class

Represents a member access.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMemberAccess

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MemberAccess : Expression
Public Class MemberAccess
    Inherits Expression

The MemberAccess type exposes the following members.

Constructors
 | Name | Description
Public method | MemberAccess | Initializes a new instance of the MemberAccess class
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess Constructor

Initializes a new instance of the MemberAccess class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MemberAccess()
Public Sub New
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess Properties

The MemberAccess type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.Alias Property

MemberAccessAlias Property

Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.Id Property

MemberAccessId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.Kind Property

MemberAccessKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MemberAccessKind Kind { get; set; }
Public Property Kind As MemberAccessKind
    Get
    Set

Property Value

Type: MemberAccessKind
The kind.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.Name Property

MemberAccessName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.TargetExpression Property

MemberAccessTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess Methods

The MemberAccess type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.GetChildrenEnumerator Method

MemberAccessGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody Class

Represents a method body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMethodBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MethodBody : AstNodeBase
Public Class MethodBody
    Inherits AstNodeBase

The MethodBody type exposes the following members.

Constructors
 | Name | Description
Public method | MethodBody | Initializes a new instance of the MethodBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody Constructor

Initializes a new instance of the MethodBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MethodBody()
Public Sub New
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody Properties

The MethodBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody.HasStatements Property

MethodBodyHasStatements Property

Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody.Id Property

MethodBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody.Statements Property

MethodBodyStatements Property

Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody Methods

The MethodBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody.GetChildrenEnumerator Method

MethodBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration Class

Represents a method declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMethodDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MethodDeclaration : TypeMemberDeclaration,
    IAstNode, INamedTypeMember
Public Class MethodDeclaration
    Inherits TypeMemberDeclaration
    Implements IAstNode, INamedTypeMember

The MethodDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | MethodDeclaration | Initializes a new instance of the MethodDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Handles | Gets the handles.
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasHandles | Returns whether the Handles collection property contains at least one item.
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration Constructor

Initializes a new instance of the MethodDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MethodDeclaration()
Public Sub New
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration Properties

The MethodDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Handles | Gets the handles.
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasHandles | Returns whether the Handles collection property contains at least one item.
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Body Property

MethodDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MethodBody Body { get; set; }
Public Property Body As MethodBody
    Get
    Set

Property Value

Type: MethodBody
The body.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Handles Property

MethodDeclarationHandles Property

Gets the handles.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QualifiedName> Handles { get; }
Public ReadOnly Property Handles As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The handles.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.HasHandles Property

MethodDeclarationHasHandles Property

Returns whether the Handles collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasHandles { get; }
Public ReadOnly Property HasHandles As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.HasImplements Property

MethodDeclarationHasImplements Property

Returns whether the Implements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasImplements { get; }
Public ReadOnly Property HasImplements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.HasParameters Property

MethodDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.HasTypeParameters Property

MethodDeclarationHasTypeParameters Property

Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Id Property

MethodDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Implements Property

MethodDeclarationImplements Property

Gets the implements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QualifiedName> Implements { get; }
Public ReadOnly Property Implements As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The implements.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Kind Property

MethodDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Name Property

MethodDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Parameters Property

MethodDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.ReturnType Property

MethodDeclarationReturnType Property

Gets or sets the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration ReturnType { get; set; }
Public Property ReturnType As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The return type.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.TypeParameters Property

MethodDeclarationTypeParameters Property

Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration Methods

The MethodDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.GetChildrenEnumerator Method

MethodDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NameOfExpression Class

Represents a name of expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNameOfExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NameOfExpression : Expression
Public Class NameOfExpression
    Inherits Expression

The NameOfExpression type exposes the following members.

Constructors
 | Name | Description
Public method | NameOfExpression | Initializes a new instance of the NameOfExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v17.1.651.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NameOfExpression Constructor

Initializes a new instance of the NameOfExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NameOfExpression()
Public Sub New
See Also

Reference

NameOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NameOfExpression Properties

The NameOfExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

NameOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NameOfExpression.ChildExpression Property

NameOfExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

NameOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NameOfExpression.Id Property

NameOfExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

NameOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NameOfExpression Methods

The NameOfExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

NameOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NameOfExpression.GetChildrenEnumerator Method

NameOfExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

NameOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody Class

Represents a namespace body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNamespaceBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NamespaceBody : AstNodeBase
Public Class NamespaceBody
    Inherits AstNodeBase

The NamespaceBody type exposes the following members.

Constructors
 | Name | Description
Public method | NamespaceBody | Initializes a new instance of the NamespaceBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody Constructor

Initializes a new instance of the NamespaceBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NamespaceBody()
Public Sub New
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody Properties

The NamespaceBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody.HasMembers Property

NamespaceBodyHasMembers Property

Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody.Id Property

NamespaceBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody.Members Property

NamespaceBodyMembers Property

Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody Methods

The NamespaceBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody.GetChildrenEnumerator Method

NamespaceBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration Class

Represents a namespace declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNamespaceDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NamespaceDeclaration : AstNodeBase
Public Class NamespaceDeclaration
    Inherits AstNodeBase

The NamespaceDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | NamespaceDeclaration | Initializes a new instance of the NamespaceDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration Constructor

Initializes a new instance of the NamespaceDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NamespaceDeclaration()
Public Sub New
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration Properties

The NamespaceDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration.Body Property

NamespaceDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NamespaceBody Body { get; set; }
Public Property Body As NamespaceBody
    Get
    Set

Property Value

Type: NamespaceBody
The body.
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration.Id Property

NamespaceDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration.Name Property

NamespaceDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Name { get; set; }
Public Property Name As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The name.
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration Methods

The NamespaceDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration.GetChildrenEnumerator Method

NamespaceDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression Class

Represents an object creation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationObjectCreationExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ObjectCreationExpression : Expression
Public Class ObjectCreationExpression
    Inherits Expression

The ObjectCreationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectCreationExpression | Initializes a new instance of the ObjectCreationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression Constructor

Initializes a new instance of the ObjectCreationExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObjectCreationExpression()
Public Sub New
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression Properties

The ObjectCreationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.Arguments Property

ObjectCreationExpressionArguments Property

Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.HasArguments Property

ObjectCreationExpressionHasArguments Property

Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.Id Property

ObjectCreationExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.Initializer Property

ObjectCreationExpressionInitializer Property

Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InitializerExpression Initializer { get; set; }
Public Property Initializer As InitializerExpression
    Get
    Set

Property Value

Type: InitializerExpression
The initializer.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.Type Property

ObjectCreationExpressionType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression Methods

The ObjectCreationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.GetChildrenEnumerator Method

ObjectCreationExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody Class

Represents an operator body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOperatorBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class OperatorBody : AstNodeBase
Public Class OperatorBody
    Inherits AstNodeBase

The OperatorBody type exposes the following members.

Constructors
 | Name | Description
Public method | OperatorBody | Initializes a new instance of the OperatorBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody Constructor

Initializes a new instance of the OperatorBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorBody()
Public Sub New
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody Properties

The OperatorBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody.HasStatements Property

OperatorBodyHasStatements Property

Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody.Id Property

OperatorBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody.Statements Property

OperatorBodyStatements Property

Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody Methods

The OperatorBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody.GetChildrenEnumerator Method

OperatorBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration Class

Represents an operator declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOperatorDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class OperatorDeclaration : TypeMemberDeclaration
Public Class OperatorDeclaration
    Inherits TypeMemberDeclaration

The OperatorDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | OperatorDeclaration | Initializes a new instance of the OperatorDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Operator | Gets or sets the operator.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration Constructor

Initializes a new instance of the OperatorDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorDeclaration()
Public Sub New
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration Properties

The OperatorDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Operator | Gets or sets the operator.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Body Property

OperatorDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorBody Body { get; set; }
Public Property Body As OperatorBody
    Get
    Set

Property Value

Type: OperatorBody
The body.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.HasParameters Property

OperatorDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Id Property

OperatorDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Kind Property

OperatorDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Operator Property

OperatorDeclarationOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Parameters Property

OperatorDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.ReturnType Property

OperatorDeclarationReturnType Property

Gets or sets the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration ReturnType { get; set; }
Public Property ReturnType As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The return type.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration Methods

The OperatorDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.GetChildrenEnumerator Method

OperatorDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator Class

Represents an order by query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOrderByQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class OrderByQueryOperator : QueryOperator
Public Class OrderByQueryOperator
    Inherits QueryOperator

The OrderByQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | OrderByQueryOperator | Initializes a new instance of the OrderByQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasOrderings | Returns whether the Orderings collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Orderings | Gets the orderings.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator Constructor

Initializes a new instance of the OrderByQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OrderByQueryOperator()
Public Sub New
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator Properties

The OrderByQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasOrderings | Returns whether the Orderings collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Orderings | Gets the orderings.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator.HasOrderings Property

OrderByQueryOperatorHasOrderings Property

Returns whether the Orderings collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasOrderings { get; }
Public ReadOnly Property HasOrderings As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator.Id Property

OrderByQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator.Orderings Property

OrderByQueryOperatorOrderings Property

Gets the orderings.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Ordering> Orderings { get; }
Public ReadOnly Property Orderings As IList(Of Ordering)
    Get

Property Value

Type: IList Ordering
The orderings.
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator Methods

The OrderByQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator.GetChildrenEnumerator Method

OrderByQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering Class

Represents an ordering.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOrdering

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Ordering : AstNodeBase
Public Class Ordering
    Inherits AstNodeBase

The Ordering type exposes the following members.

Constructors
 | Name | Description
Public method | Ordering | Initializes a new instance of the Ordering class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Direction | Gets or sets the direction.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering Constructor

Initializes a new instance of the Ordering class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Ordering()
Public Sub New
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering Properties

The Ordering type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Direction | Gets or sets the direction.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering.Direction Property

OrderingDirection Property

Gets or sets the direction.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OrderingDirection Direction { get; set; }
Public Property Direction As OrderingDirection
    Get
    Set

Property Value

Type: OrderingDirection
The direction.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering.Expression Property

OrderingExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering.Id Property

OrderingId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering Methods

The Ordering type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering.GetChildrenEnumerator Method

OrderingGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration Class

Represents a parameter declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationParameterDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParameterDeclaration : AstNodeBase
Public Class ParameterDeclaration
    Inherits AstNodeBase

The ParameterDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterDeclaration | Initializes a new instance of the ParameterDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration Constructor

Initializes a new instance of the ParameterDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParameterDeclaration()
Public Sub New
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration Properties

The ParameterDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.AttributeSections Property

ParameterDeclarationAttributeSections Property

Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.HasAttributeSections Property

ParameterDeclarationHasAttributeSections Property

Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Id Property

ParameterDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Initializer Property

ParameterDeclarationInitializer Property

Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Modifiers Property

ParameterDeclarationModifiers Property

Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParameterModifiers Modifiers { get; set; }
Public Property Modifiers As ParameterModifiers
    Get
    Set

Property Value

Type: ParameterModifiers
The modifiers.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Name Property

ParameterDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Type Property

ParameterDeclarationType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration Methods

The ParameterDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.GetChildrenEnumerator Method

ParameterDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression Class

Represents a parenthesized expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationParenthesizedExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParenthesizedExpression : Expression
Public Class ParenthesizedExpression
    Inherits Expression

The ParenthesizedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ParenthesizedExpression | Initializes a new instance of the ParenthesizedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression Constructor

Initializes a new instance of the ParenthesizedExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParenthesizedExpression()
Public Sub New
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression Properties

The ParenthesizedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression.ChildExpression Property

ParenthesizedExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression.Id Property

ParenthesizedExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression Methods

The ParenthesizedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression.GetChildrenEnumerator Method

ParenthesizedExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective Class

Represents a preprocessor directive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPreprocessorDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRegionPreprocessorDirective

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PreprocessorDirective : AstNodeBase
Public Class PreprocessorDirective
    Inherits AstNodeBase

The PreprocessorDirective type exposes the following members.

Constructors
 | Name | Description
Public method | PreprocessorDirective | Initializes a new instance of the PreprocessorDirective class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective Constructor

Initializes a new instance of the PreprocessorDirective class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PreprocessorDirective()
Public Sub New
See Also

Reference

PreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective Properties

The PreprocessorDirective type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective.Id Property

PreprocessorDirectiveId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective Methods

The PreprocessorDirective type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody Class

Represents a property body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPropertyBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyBody : AstNodeBase
Public Class PropertyBody
    Inherits AstNodeBase

The PropertyBody type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyBody | Initializes a new instance of the PropertyBody class
Top
Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody Constructor

Initializes a new instance of the PropertyBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyBody()
Public Sub New
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody Properties

The PropertyBody type exposes the following members.

Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody.Accessors Property

PropertyBodyAccessors Property

Gets the accessors.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AccessorDeclaration> Accessors { get; }
Public ReadOnly Property Accessors As IList(Of AccessorDeclaration)
    Get

Property Value

Type: IList AccessorDeclaration
The accessors.
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody.HasAccessors Property

PropertyBodyHasAccessors Property

Returns whether the Accessors collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAccessors { get; }
Public ReadOnly Property HasAccessors As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody.Id Property

PropertyBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody Methods

The PropertyBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody.GetChildrenEnumerator Method

PropertyBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration Class

Represents a property declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPropertyDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyDeclaration : TypeMemberDeclaration,
    IAstNode, INamedTypeMember
Public Class PropertyDeclaration
    Inherits TypeMemberDeclaration
    Implements IAstNode, INamedTypeMember

The PropertyDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDeclaration | Initializes a new instance of the PropertyDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration Constructor

Initializes a new instance of the PropertyDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyDeclaration()
Public Sub New
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration Properties

The PropertyDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Body Property

PropertyDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyBody Body { get; set; }
Public Property Body As PropertyBody
    Get
    Set

Property Value

Type: PropertyBody
The body.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.HasImplements Property

PropertyDeclarationHasImplements Property

Returns whether the Implements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasImplements { get; }
Public ReadOnly Property HasImplements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.HasParameters Property

PropertyDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Id Property

PropertyDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Implements Property

PropertyDeclarationImplements Property

Gets the implements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QualifiedName> Implements { get; }
Public ReadOnly Property Implements As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The implements.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Initializer Property

PropertyDeclarationInitializer Property

Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Kind Property

PropertyDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Name Property

PropertyDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Parameters Property

PropertyDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Type Property

PropertyDeclarationType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration Type { get; set; }
Public Property Type As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The type.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration Methods

The PropertyDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.GetChildrenEnumerator Method

PropertyDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Class

Represents a qualified name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class QualifiedName : AstNodeBase,
    IQualifiedName
Public Class QualifiedName
    Inherits AstNodeBase
    Implements IQualifiedName

The QualifiedName type exposes the following members.

Constructors
 | Name | Description
Public method | QualifiedName | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, SimpleName) | Initializes a new instance of the QualifiedName class.
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArrayRankSpecifiers | Returns whether the ArrayRankSpecifiers collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasIdentifiers | Returns whether the Identifiers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Identifiers | Gets the identifiers.
Public property | IsDynamic | Gets whether the qualified name is for a dynamic object.
Public property | IsGlobal | Gets or sets the is global.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | PointerLevel | Gets or sets the pointer level.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
 | CreateDynamic | Creates a qualified name for a dynamic object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Constructor

Overload List
 | Name | Description
Public method | QualifiedName | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, SimpleName) | Initializes a new instance of the QualifiedName class.
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Constructor

Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName()
Public Sub New
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Constructor (String, Boolean, SimpleName[])

QualifiedName Constructor (String, Boolean, SimpleName)

Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName(
    string alias,
    bool isGlobal,
    params SimpleName[] identifiers
)
Public Sub New (
    alias As String,
    isGlobal As Boolean,
    ParamArray identifiers As SimpleName()
)

Parameters

alias
Type: SystemString
The optional alias that indicates the root of the qualified name.
isGlobal
Type: SystemBoolean
Whether the qualified name is rooted at the default global namespace.
identifiers
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSimpleName
The collection of identifiers for the qualified name.
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Properties

The QualifiedName type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArrayRankSpecifiers | Returns whether the ArrayRankSpecifiers collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasIdentifiers | Returns whether the Identifiers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Identifiers | Gets the identifiers.
Public property | IsDynamic | Gets whether the qualified name is for a dynamic object.
Public property | IsGlobal | Gets or sets the is global.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | PointerLevel | Gets or sets the pointer level.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Alias Property

QualifiedNameAlias Property

Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.

Implements

IQualifiedNameAlias
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.ArrayRankSpecifiers Property

QualifiedNameArrayRankSpecifiers Property

Gets the array rank specifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<int> ArrayRankSpecifiers { get; }
Public ReadOnly Property ArrayRankSpecifiers As IList(Of Integer)
    Get

Property Value

Type: IList Int32
The array rank specifiers.

Implements

IQualifiedNameArrayRankSpecifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.HasArrayRankSpecifiers Property

QualifiedNameHasArrayRankSpecifiers Property

Returns whether the ArrayRankSpecifiers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArrayRankSpecifiers { get; }
Public ReadOnly Property HasArrayRankSpecifiers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.

Implements

IQualifiedNameHasArrayRankSpecifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.HasIdentifiers Property

QualifiedNameHasIdentifiers Property

Returns whether the Identifiers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasIdentifiers { get; }
Public ReadOnly Property HasIdentifiers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.

Implements

IQualifiedNameHasIdentifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Id Property

QualifiedNameId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Identifiers Property

QualifiedNameIdentifiers Property

Gets the identifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<SimpleName> Identifiers { get; }
Public ReadOnly Property Identifiers As IList(Of SimpleName)
    Get

Property Value

Type: IList SimpleName
The identifiers.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.IsDynamic Property

QualifiedNameIsDynamic Property

Gets whether the qualified name is for a dynamic object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDynamic { get; }
Public ReadOnly Property IsDynamic As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name is for a dynamic object; otherwise, false.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.IsGlobal Property

QualifiedNameIsGlobal Property

Gets or sets the is global.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGlobal { get; set; }
Public Property IsGlobal As Boolean
    Get
    Set

Property Value

Type: Boolean
The is global.

Implements

IQualifiedNameIsGlobal
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.PointerLevel Property

QualifiedNamePointerLevel Property

Gets or sets the pointer level.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int PointerLevel { get; set; }
Public Property PointerLevel As Integer
    Get
    Set

Property Value

Type: Int32
The pointer level.

Implements

IQualifiedNamePointerLevel
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Value Property

QualifiedNameValue Property

Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Methods

The QualifiedName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
 | CreateDynamic | Creates a qualified name for a dynamic object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Clone Method

QualifiedNameClone Method

Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Clone()
Public Function Clone As QualifiedName

Return Value

Type: QualifiedName
The object that was created.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.CreateDynamic Method

QualifiedNameCreateDynamic Method

Creates a qualified name for a dynamic object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static QualifiedName CreateDynamic()
Public Shared Function CreateDynamic As QualifiedName

Return Value

Type: QualifiedName
A qualified name for a dynamic object.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Equals Method

QualifiedNameEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.GetChildrenEnumerator Method

QualifiedNameGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.GetHashCode Method

QualifiedNameGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.ToString Method

QualifiedNameToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression Class

Represents a query expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class QueryExpression : Expression
Public Class QueryExpression
    Inherits Expression

The QueryExpression type exposes the following members.

Constructors
 | Name | Description
Public method | QueryExpression | Initializes a new instance of the QueryExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasQueryOperators | Returns whether the QueryOperators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | QueryOperators | Gets the query operators.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression Constructor

Initializes a new instance of the QueryExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QueryExpression()
Public Sub New
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression Properties

The QueryExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasQueryOperators | Returns whether the QueryOperators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | QueryOperators | Gets the query operators.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression.HasQueryOperators Property

QueryExpressionHasQueryOperators Property

Returns whether the QueryOperators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasQueryOperators { get; }
Public ReadOnly Property HasQueryOperators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression.Id Property

QueryExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression.QueryOperators Property

QueryExpressionQueryOperators Property

Gets the query operators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QueryOperator> QueryOperators { get; }
Public ReadOnly Property QueryOperators As IList(Of QueryOperator)
    Get

Property Value

Type: IList QueryOperator
The query operators.
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression Methods

The QueryExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression.GetChildrenEnumerator Method

QueryExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryOperator Class

Represents a query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
More...

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class QueryOperator : AstNodeBase
Public Class QueryOperator
    Inherits AstNodeBase

The QueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | QueryOperator | Initializes a new instance of the QueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAggregateQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDistinctQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFromQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationGroupQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationJoinQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLetQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOrderByQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSelectQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSkipQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSkipWhileQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTakeQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTakeWhileQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWhereQueryOperator


QueryOperator Constructor

Initializes a new instance of the QueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QueryOperator()
Public Sub New
See Also

Reference

QueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryOperator Properties

The QueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

QueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryOperator.Id Property

QueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

QueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryOperator Methods

The QueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

QueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration Class

Represents a range variable declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRangeVariableDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RangeVariableDeclaration : AstNodeBase
Public Class RangeVariableDeclaration
    Inherits AstNodeBase

The RangeVariableDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | RangeVariableDeclaration | Initializes a new instance of the RangeVariableDeclaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration Constructor

Initializes a new instance of the RangeVariableDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration()
Public Sub New
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration Properties

The RangeVariableDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration.Declarators Property

RangeVariableDeclarationDeclarators Property

Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<RangeVariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of RangeVariableDeclarator)
    Get

Property Value

Type: IList RangeVariableDeclarator
The declarators.
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration.HasDeclarators Property

RangeVariableDeclarationHasDeclarators Property

Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration.Id Property

RangeVariableDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration Methods

The RangeVariableDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration.GetChildrenEnumerator Method

RangeVariableDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator Class

Represents a range variable declarator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRangeVariableDeclarator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RangeVariableDeclarator : AstNodeBase
Public Class RangeVariableDeclarator
    Inherits AstNodeBase

The RangeVariableDeclarator type exposes the following members.

Constructors
 | Name | Description
Public method | RangeVariableDeclarator | Initializes a new instance of the RangeVariableDeclarator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | Source | Gets or sets the source.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator Constructor

Initializes a new instance of the RangeVariableDeclarator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclarator()
Public Sub New
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator Properties

The RangeVariableDeclarator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | Source | Gets or sets the source.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.Id Property

RangeVariableDeclaratorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.Name Property

RangeVariableDeclaratorName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.Source Property

RangeVariableDeclaratorSource Property

Gets or sets the source.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Source { get; set; }
Public Property Source As Expression
    Get
    Set

Property Value

Type: Expression
The source.
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.Type Property

RangeVariableDeclaratorType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator Methods

The RangeVariableDeclarator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.GetChildrenEnumerator Method

RangeVariableDeclaratorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective Class

Represents a region preprocessor directive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPreprocessorDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRegionPreprocessorDirective

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RegionPreprocessorDirective : PreprocessorDirective
Public Class RegionPreprocessorDirective
    Inherits PreprocessorDirective

The RegionPreprocessorDirective type exposes the following members.

Constructors
 | Name | Description
Public method | RegionPreprocessorDirective | Initializes a new instance of the RegionPreprocessorDirective class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides PreprocessorDirectiveId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective Constructor

Initializes a new instance of the RegionPreprocessorDirective class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RegionPreprocessorDirective()
Public Sub New
See Also

Reference

RegionPreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective Properties

The RegionPreprocessorDirective type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides PreprocessorDirectiveId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

RegionPreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective.Id Property

RegionPreprocessorDirectiveId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

RegionPreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective Methods

The RegionPreprocessorDirective type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

RegionPreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement Class

Represents a return statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReturnStatement : Statement
Public Class ReturnStatement
    Inherits Statement

The ReturnStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnStatement | Initializes a new instance of the ReturnStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement Constructor

Initializes a new instance of the ReturnStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnStatement()
Public Sub New
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement Properties

The ReturnStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement.Expression Property

ReturnStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement.Id Property

ReturnStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement Methods

The ReturnStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement.GetChildrenEnumerator Method

ReturnStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration Class

Represents a return type declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnTypeDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReturnTypeDeclaration : AstNodeBase
Public Class ReturnTypeDeclaration
    Inherits AstNodeBase

The ReturnTypeDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnTypeDeclaration | Initializes a new instance of the ReturnTypeDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration Constructor

Initializes a new instance of the ReturnTypeDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration()
Public Sub New
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration Properties

The ReturnTypeDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.AttributeSections Property

ReturnTypeDeclarationAttributeSections Property

Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.HasAttributeSections Property

ReturnTypeDeclarationHasAttributeSections Property

Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.Id Property

ReturnTypeDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.Type Property

ReturnTypeDeclarationType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration Methods

The ReturnTypeDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.GetChildrenEnumerator Method

ReturnTypeDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression Class

Represents a return type expression (used by resolver).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnTypeExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReturnTypeExpression : Expression
Public Class ReturnTypeExpression
    Inherits Expression

The ReturnTypeExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnTypeExpression | Initializes a new instance of the ReturnTypeExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression Constructor

Initializes a new instance of the ReturnTypeExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnTypeExpression()
Public Sub New
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression Properties

The ReturnTypeExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression.ChildExpression Property

ReturnTypeExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression.Id Property

ReturnTypeExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression Methods

The ReturnTypeExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression.GetChildrenEnumerator Method

ReturnTypeExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator Class

Represents a select query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSelectQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SelectQueryOperator : QueryOperator
Public Class SelectQueryOperator
    Inherits QueryOperator

The SelectQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | SelectQueryOperator | Initializes a new instance of the SelectQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator Constructor

Initializes a new instance of the SelectQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SelectQueryOperator()
Public Sub New
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator Properties

The SelectQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator.Id Property

SelectQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator.Projection Property

SelectQueryOperatorProjection Property

Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator Methods

The SelectQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator.GetChildrenEnumerator Method

SelectQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Class

Represents a simple name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSimpleName

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SimpleName : Expression, ISimpleName
Public Class SimpleName
    Inherits Expression
    Implements ISimpleName

The SimpleName type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String, QualifiedName) | Initializes a new instance of the SimpleName class.
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeArguments | Returns whether the TypeArguments collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text value of the identifier.
Public property | TypeArguments | Gets the generic type arguments.
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Constructor

Overload List
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String, QualifiedName) | Initializes a new instance of the SimpleName class.
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Constructor

Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName()
Public Sub New
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Constructor (String, QualifiedName[])

SimpleName Constructor (String, QualifiedName)

Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName(
    string text,
    params QualifiedName[] typeArguments
)
Public Sub New (
    text As String,
    ParamArray typeArguments As QualifiedName()
)

Parameters

text
Type: SystemString
The text value of the identifier.
typeArguments
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
The collection of optional generic type arguments for the identifier.
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Properties

The SimpleName type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeArguments | Returns whether the TypeArguments collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text value of the identifier.
Public property | TypeArguments | Gets the generic type arguments.
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.HasTypeArguments Property

SimpleNameHasTypeArguments Property

Returns whether the TypeArguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTypeArguments { get; }
Public ReadOnly Property HasTypeArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.

Implements

ISimpleNameHasTypeArguments
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Id Property

SimpleNameId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Text Property

SimpleNameText Property

Gets or sets the text value of the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text value of the identifier.

Implements

ISimpleNameText
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.TypeArguments Property

SimpleNameTypeArguments Property

Gets the generic type arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QualifiedName> TypeArguments { get; }
Public ReadOnly Property TypeArguments As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The generic type arguments.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Value Property

SimpleNameValue Property

Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Methods

The SimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Clone Method

SimpleNameClone Method

Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Clone()
Public Function Clone As SimpleName

Return Value

Type: SimpleName
The object that was created.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Equals Method

SimpleNameEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.GetChildrenEnumerator Method

SimpleNameGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.GetHashCode Method

SimpleNameGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.ToString Method

SimpleNameToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression Class

Represents a size of expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSizeOfExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SizeOfExpression : Expression
Public Class SizeOfExpression
    Inherits Expression

The SizeOfExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SizeOfExpression | Initializes a new instance of the SizeOfExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression Constructor

Initializes a new instance of the SizeOfExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SizeOfExpression()
Public Sub New
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression Properties

The SizeOfExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression.Id Property

SizeOfExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression.Type Property

SizeOfExpressionType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression Methods

The SizeOfExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression.GetChildrenEnumerator Method

SizeOfExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator Class

Represents a skip query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSkipQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SkipQueryOperator : QueryOperator
Public Class SkipQueryOperator
    Inherits QueryOperator

The SkipQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | SkipQueryOperator | Initializes a new instance of the SkipQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CountExpression | Gets or sets the count expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator Constructor

Initializes a new instance of the SkipQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SkipQueryOperator()
Public Sub New
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator Properties

The SkipQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CountExpression | Gets or sets the count expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator.CountExpression Property

SkipQueryOperatorCountExpression Property

Gets or sets the count expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression CountExpression { get; set; }
Public Property CountExpression As Expression
    Get
    Set

Property Value

Type: Expression
The count expression.
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator.Id Property

SkipQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator Methods

The SkipQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator.GetChildrenEnumerator Method

SkipQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator Class

Represents a skip while query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSkipWhileQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SkipWhileQueryOperator : QueryOperator
Public Class SkipWhileQueryOperator
    Inherits QueryOperator

The SkipWhileQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | SkipWhileQueryOperator | Initializes a new instance of the SkipWhileQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator Constructor

Initializes a new instance of the SkipWhileQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SkipWhileQueryOperator()
Public Sub New
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator Properties

The SkipWhileQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator.ConditionExpression Property

SkipWhileQueryOperatorConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator.Id Property

SkipWhileQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator Methods

The SkipWhileQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator.GetChildrenEnumerator Method

SkipWhileQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer Class

Represents a stack allocation initializer.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStackAllocationInitializer

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StackAllocationInitializer : Expression
Public Class StackAllocationInitializer
    Inherits Expression

The StackAllocationInitializer type exposes the following members.

Constructors
 | Name | Description
Public method | StackAllocationInitializer | Initializes a new instance of the StackAllocationInitializer class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | SizeExpression | Gets or sets the size expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer Constructor

Initializes a new instance of the StackAllocationInitializer class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StackAllocationInitializer()
Public Sub New
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer Properties

The StackAllocationInitializer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | SizeExpression | Gets or sets the size expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer.Id Property

StackAllocationInitializerId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer.SizeExpression Property

StackAllocationInitializerSizeExpression Property

Gets or sets the size expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression SizeExpression { get; set; }
Public Property SizeExpression As Expression
    Get
    Set

Property Value

Type: Expression
The size expression.
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer.Type Property

StackAllocationInitializerType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer Methods

The StackAllocationInitializer type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer.GetChildrenEnumerator Method

StackAllocationInitializerGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Statement Class

Represents a statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
More...

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Statement : AstNodeBase
Public Class Statement
    Inherits AstNodeBase

The Statement type exposes the following members.

Constructors
 | Name | Description
Public method | Statement | Initializes a new instance of the Statement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayEraseStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayReallocateStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBlockStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBreakStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCheckedStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationContinueStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDoStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEndStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExitStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpressionStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationForEachStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationForStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationGoToStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationIfStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLabeledStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLocalVariableDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLockStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStopStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSwitchStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationThrowStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTryStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUncheckedStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnsafeStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorHandlerStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorResumeStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorThrowStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWhileStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWithStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationYieldStatement


Statement Constructor

Initializes a new instance of the Statement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement()
Public Sub New
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Statement Properties

The Statement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Statement.Id Property

StatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Statement Methods

The Statement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement Class

Represents a stop statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStopStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StopStatement : Statement
Public Class StopStatement
    Inherits Statement

The StopStatement type exposes the following members.

Constructors
 | Name | Description
Public method | StopStatement | Initializes a new instance of the StopStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement Constructor

Initializes a new instance of the StopStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StopStatement()
Public Sub New
See Also

Reference

StopStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement Properties

The StopStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StopStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement.Id Property

StopStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StopStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement Methods

The StopStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StopStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody Class

Represents a structure body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStructureBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StructureBody : AstNodeBase
Public Class StructureBody
    Inherits AstNodeBase

The StructureBody type exposes the following members.

Constructors
 | Name | Description
Public method | StructureBody | Initializes a new instance of the StructureBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody Constructor

Initializes a new instance of the StructureBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StructureBody()
Public Sub New
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody Properties

The StructureBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody.HasMembers Property

StructureBodyHasMembers Property

Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody.Id Property

StructureBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody.Members Property

StructureBodyMembers Property

Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody Methods

The StructureBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody.GetChildrenEnumerator Method

StructureBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration Class

Represents a structure declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStructureDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StructureDeclaration : TypeDeclaration
Public Class StructureDeclaration
    Inherits TypeDeclaration

The StructureDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | StructureDeclaration | Initializes a new instance of the StructureDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration Constructor

Initializes a new instance of the StructureDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StructureDeclaration()
Public Sub New
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration Properties

The StructureDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.BaseTypes Property

StructureDeclarationBaseTypes Property

Gets the base types.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QualifiedName> BaseTypes { get; }
Public ReadOnly Property BaseTypes As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The base types.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.Body Property

StructureDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StructureBody Body { get; set; }
Public Property Body As StructureBody
    Get
    Set

Property Value

Type: StructureBody
The body.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.HasBaseTypes Property

StructureDeclarationHasBaseTypes Property

Returns whether the BaseTypes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasBaseTypes { get; }
Public ReadOnly Property HasBaseTypes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.HasTypeParameters Property

StructureDeclarationHasTypeParameters Property

Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.Id Property

StructureDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.Kind Property

StructureDeclarationKind Property

Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.TypeParameters Property

StructureDeclarationTypeParameters Property

Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration Methods

The StructureDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.GetChildrenEnumerator Method

StructureDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection Class

Represents a switch section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSwitchSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SwitchSection : AstNodeBase
Public Class SwitchSection
    Inherits AstNodeBase

The SwitchSection type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchSection | Initializes a new instance of the SwitchSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasLabels | Returns whether the Labels collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Labels | Gets the labels.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection Constructor

Initializes a new instance of the SwitchSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SwitchSection()
Public Sub New
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection Properties

The SwitchSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasLabels | Returns whether the Labels collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Labels | Gets the labels.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.HasLabels Property

SwitchSectionHasLabels Property

Returns whether the Labels collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasLabels { get; }
Public ReadOnly Property HasLabels As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.HasStatements Property

SwitchSectionHasStatements Property

Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.Id Property

SwitchSectionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.Labels Property

SwitchSectionLabels Property

Gets the labels.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Labels { get; }
Public ReadOnly Property Labels As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The labels.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.Statements Property

SwitchSectionStatements Property

Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection Methods

The SwitchSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.GetChildrenEnumerator Method

SwitchSectionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement Class

Represents a switch statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSwitchStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SwitchStatement : Statement
Public Class SwitchStatement
    Inherits Statement

The SwitchStatement type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchStatement | Initializes a new instance of the SwitchStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSections | Returns whether the Sections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | Sections | Gets the sections.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement Constructor

Initializes a new instance of the SwitchStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SwitchStatement()
Public Sub New
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement Properties

The SwitchStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSections | Returns whether the Sections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | Sections | Gets the sections.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.Expression Property

SwitchStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.HasSections Property

SwitchStatementHasSections Property

Returns whether the Sections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSections { get; }
Public ReadOnly Property HasSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.Id Property

SwitchStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.Sections Property

SwitchStatementSections Property

Gets the sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<SwitchSection> Sections { get; }
Public ReadOnly Property Sections As IList(Of SwitchSection)
    Get

Property Value

Type: IList SwitchSection
The sections.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement Methods

The SwitchStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.GetChildrenEnumerator Method

SwitchStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator Class

Represents a take query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTakeQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TakeQueryOperator : QueryOperator
Public Class TakeQueryOperator
    Inherits QueryOperator

The TakeQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | TakeQueryOperator | Initializes a new instance of the TakeQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CountExpression | Gets or sets the count expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator Constructor

Initializes a new instance of the TakeQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TakeQueryOperator()
Public Sub New
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator Properties

The TakeQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CountExpression | Gets or sets the count expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator.CountExpression Property

TakeQueryOperatorCountExpression Property

Gets or sets the count expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression CountExpression { get; set; }
Public Property CountExpression As Expression
    Get
    Set

Property Value

Type: Expression
The count expression.
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator.Id Property

TakeQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator Methods

The TakeQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator.GetChildrenEnumerator Method

TakeQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator Class

Represents a take while query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTakeWhileQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TakeWhileQueryOperator : QueryOperator
Public Class TakeWhileQueryOperator
    Inherits QueryOperator

The TakeWhileQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | TakeWhileQueryOperator | Initializes a new instance of the TakeWhileQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator Constructor

Initializes a new instance of the TakeWhileQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TakeWhileQueryOperator()
Public Sub New
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator Properties

The TakeWhileQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator.ConditionExpression Property

TakeWhileQueryOperatorConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator.Id Property

TakeWhileQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator Methods

The TakeWhileQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator.GetChildrenEnumerator Method

TakeWhileQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement Class

Represents a throw statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationThrowStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ThrowStatement : Statement
Public Class ThrowStatement
    Inherits Statement

The ThrowStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ThrowStatement | Initializes a new instance of the ThrowStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement Constructor

Initializes a new instance of the ThrowStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ThrowStatement()
Public Sub New
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement Properties

The ThrowStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement.Expression Property

ThrowStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement.Id Property

ThrowStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement Methods

The ThrowStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement.GetChildrenEnumerator Method

ThrowStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression Class

Represents a try cast expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTryCastExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TryCastExpression : Expression
Public Class TryCastExpression
    Inherits Expression

The TryCastExpression type exposes the following members.

Constructors
 | Name | Description
Public method | TryCastExpression | Initializes a new instance of the TryCastExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression Constructor

Initializes a new instance of the TryCastExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TryCastExpression()
Public Sub New
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression Properties

The TryCastExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression.ChildExpression Property

TryCastExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression.Id Property

TryCastExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression.Type Property

TryCastExpressionType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression Methods

The TryCastExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression.GetChildrenEnumerator Method

TryCastExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement Class

Represents a try statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTryStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TryStatement : Statement
Public Class TryStatement
    Inherits Statement

The TryStatement type exposes the following members.

Constructors
 | Name | Description
Public method | TryStatement | Initializes a new instance of the TryStatement class
Top
Properties
 | Name | Description
Public property | CatchClauses | Gets the catch clauses.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FinallyBlock | Gets or sets the finally block.
Public property | HasCatchClauses | Returns whether the CatchClauses collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TryBlock | Gets or sets the try block.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement Constructor

Initializes a new instance of the TryStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TryStatement()
Public Sub New
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement Properties

The TryStatement type exposes the following members.

Properties
 | Name | Description
Public property | CatchClauses | Gets the catch clauses.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FinallyBlock | Gets or sets the finally block.
Public property | HasCatchClauses | Returns whether the CatchClauses collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TryBlock | Gets or sets the try block.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.CatchClauses Property

TryStatementCatchClauses Property

Gets the catch clauses.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<CatchClause> CatchClauses { get; }
Public ReadOnly Property CatchClauses As IList(Of CatchClause)
    Get

Property Value

Type: IList CatchClause
The catch clauses.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.FinallyBlock Property

TryStatementFinallyBlock Property

Gets or sets the finally block.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement FinallyBlock { get; set; }
Public Property FinallyBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The finally block.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.HasCatchClauses Property

TryStatementHasCatchClauses Property

Returns whether the CatchClauses collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasCatchClauses { get; }
Public ReadOnly Property HasCatchClauses As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.Id Property

TryStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.TryBlock Property

TryStatementTryBlock Property

Gets or sets the try block.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement TryBlock { get; set; }
Public Property TryBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The try block.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement Methods

The TryStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.GetChildrenEnumerator Method

TryStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration Class

Represents a type declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationClassDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDelegateDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStructureDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TypeDeclaration : AstNodeBase,
    IAstNode, IDecoratedMember
Public MustInherit Class TypeDeclaration
    Inherits AstNodeBase
    Implements IAstNode, IDecoratedMember

The TypeDeclaration type exposes the following members.

Constructors
 | Name | Description
Protected method | TypeDeclaration | Initializes a new instance of the TypeDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration Constructor

Initializes a new instance of the TypeDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TypeDeclaration()
Protected Sub New
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration Properties

The TypeDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.AttributeSections Property

TypeDeclarationAttributeSections Property

Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.

Implements

IDecoratedMemberAttributeSections
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.DocumentationComment Property

TypeDeclarationDocumentationComment Property

Gets or sets the documentation comment.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentationComment DocumentationComment { get; set; }
Public Property DocumentationComment As DocumentationComment
    Get
    Set

Property Value

Type: DocumentationComment
The documentation comment.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.HasAttributeSections Property

TypeDeclarationHasAttributeSections Property

Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.Id Property

TypeDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.Kind Property

TypeDeclarationKind Property

Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract TypeDeclarationKind Kind { get; }
Public MustOverride ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.Modifiers Property

TypeDeclarationModifiers Property

Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.

Implements

IDecoratedMemberModifiers
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.Name Property

TypeDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration Methods

The TypeDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.GetChildrenEnumerator Method

TypeDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration Class

Represents a type member declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
More...

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TypeMemberDeclaration : AstNodeBase,
    IAstNode, IDecoratedMember
Public MustInherit Class TypeMemberDeclaration
    Inherits AstNodeBase
    Implements IAstNode, IDecoratedMember

The TypeMemberDeclaration type exposes the following members.

Constructors
 | Name | Description
Protected method | TypeMemberDeclaration | Initializes a new instance of the TypeMemberDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConstructorDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEventDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFieldDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedSizeBufferDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMethodDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOperatorDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPropertyDeclaration


TypeMemberDeclaration Constructor

Initializes a new instance of the TypeMemberDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TypeMemberDeclaration()
Protected Sub New
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration Properties

The TypeMemberDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.AttributeSections Property

TypeMemberDeclarationAttributeSections Property

Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.

Implements

IDecoratedMemberAttributeSections
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.DocumentationComment Property

TypeMemberDeclarationDocumentationComment Property

Gets or sets the documentation comment.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentationComment DocumentationComment { get; set; }
Public Property DocumentationComment As DocumentationComment
    Get
    Set

Property Value

Type: DocumentationComment
The documentation comment.
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.HasAttributeSections Property

TypeMemberDeclarationHasAttributeSections Property

Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.Id Property

TypeMemberDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.Kind Property

TypeMemberDeclarationKind Property

Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract TypeMemberDeclarationKind Kind { get; }
Public MustOverride ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.Modifiers Property

TypeMemberDeclarationModifiers Property

Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.

Implements

IDecoratedMemberModifiers
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration Methods

The TypeMemberDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.GetChildrenEnumerator Method

TypeMemberDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression Class

Represents a type of expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeOfExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TypeOfExpression : Expression
Public Class TypeOfExpression
    Inherits Expression

The TypeOfExpression type exposes the following members.

Constructors
 | Name | Description
Public method | TypeOfExpression | Initializes a new instance of the TypeOfExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression Constructor

Initializes a new instance of the TypeOfExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TypeOfExpression()
Public Sub New
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression Properties

The TypeOfExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression.Id Property

TypeOfExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression.Type Property

TypeOfExpressionType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression Methods

The TypeOfExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression.GetChildrenEnumerator Method

TypeOfExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter Class

Represents a type parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeParameter

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TypeParameter : AstNodeBase
Public Class TypeParameter
    Inherits AstNodeBase

The TypeParameter type exposes the following members.

Constructors
 | Name | Description
Public method | TypeParameter | Initializes a new instance of the TypeParameter class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDefaultConstructorConstraint | Gets or sets the has default constructor constraint.
Public property | HasNotNullableValueTypeConstraint | Gets or sets the has not-nullable value type constraint.
Public property | HasReferenceTypeConstraint | Gets or sets the has reference type constraint.
Public property | HasTypeConstraints | Returns whether the TypeConstraints collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeConstraints | Gets the type constraints.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VarianceAnnotation | Gets or sets the variance annotation.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter Constructor

Initializes a new instance of the TypeParameter class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TypeParameter()
Public Sub New
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter Properties

The TypeParameter type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDefaultConstructorConstraint | Gets or sets the has default constructor constraint.
Public property | HasNotNullableValueTypeConstraint | Gets or sets the has not-nullable value type constraint.
Public property | HasReferenceTypeConstraint | Gets or sets the has reference type constraint.
Public property | HasTypeConstraints | Returns whether the TypeConstraints collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeConstraints | Gets the type constraints.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VarianceAnnotation | Gets or sets the variance annotation.
Top
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.AttributeSections Property

TypeParameterAttributeSections Property

Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasAttributeSections Property

TypeParameterHasAttributeSections Property

Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasDefaultConstructorConstraint Property

TypeParameterHasDefaultConstructorConstraint Property

Gets or sets the has default constructor constraint.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDefaultConstructorConstraint { get; set; }
Public Property HasDefaultConstructorConstraint As Boolean
    Get
    Set

Property Value

Type: Boolean
The has default constructor constraint.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasNotNullableValueTypeConstraint Property

TypeParameterHasNotNullableValueTypeConstraint Property

Gets or sets the has not-nullable value type constraint.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasNotNullableValueTypeConstraint { get; set; }
Public Property HasNotNullableValueTypeConstraint As Boolean
    Get
    Set

Property Value

Type: Boolean
The has not-nullable value type constraint.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasReferenceTypeConstraint Property

TypeParameterHasReferenceTypeConstraint Property

Gets or sets the has reference type constraint.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasReferenceTypeConstraint { get; set; }
Public Property HasReferenceTypeConstraint As Boolean
    Get
    Set

Property Value

Type: Boolean
The has reference type constraint.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasTypeConstraints Property

TypeParameterHasTypeConstraints Property

Returns whether the TypeConstraints collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTypeConstraints { get; }
Public ReadOnly Property HasTypeConstraints As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.Id Property

TypeParameterId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.Name Property

TypeParameterName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.TypeConstraints Property

TypeParameterTypeConstraints Property

Gets the type constraints.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<QualifiedName> TypeConstraints { get; }
Public ReadOnly Property TypeConstraints As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The type constraints.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.VarianceAnnotation Property

TypeParameterVarianceAnnotation Property

Gets or sets the variance annotation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VarianceAnnotation VarianceAnnotation { get; set; }
Public Property VarianceAnnotation As VarianceAnnotation
    Get
    Set

Property Value

Type: VarianceAnnotation
The variance annotation.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter Methods

The TypeParameter type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.GetChildrenEnumerator Method

TypeParameterGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression Class

Represents an unary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UnaryOperatorExpression : Expression
Public Class UnaryOperatorExpression
    Inherits Expression

The UnaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | UnaryOperatorExpression | Initializes a new instance of the UnaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression Constructor

Initializes a new instance of the UnaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UnaryOperatorExpression()
Public Sub New
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression Properties

The UnaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression.ChildExpression Property

UnaryOperatorExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression.Id Property

UnaryOperatorExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression.Operator Property

UnaryOperatorExpressionOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression Methods

The UnaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression.GetChildrenEnumerator Method

UnaryOperatorExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression Class

Represents an unchecked expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUncheckedExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UncheckedExpression : Expression
Public Class UncheckedExpression
    Inherits Expression

The UncheckedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | UncheckedExpression | Initializes a new instance of the UncheckedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression Constructor

Initializes a new instance of the UncheckedExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UncheckedExpression()
Public Sub New
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression Properties

The UncheckedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression.ChildExpression Property

UncheckedExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression.Id Property

UncheckedExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression Methods

The UncheckedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression.GetChildrenEnumerator Method

UncheckedExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement Class

Represents an unchecked statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUncheckedStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UncheckedStatement : Statement
Public Class UncheckedStatement
    Inherits Statement

The UncheckedStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UncheckedStatement | Initializes a new instance of the UncheckedStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement Constructor

Initializes a new instance of the UncheckedStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UncheckedStatement()
Public Sub New
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement Properties

The UncheckedStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement.ChildStatement Property

UncheckedStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement.Id Property

UncheckedStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement Methods

The UncheckedStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement.GetChildrenEnumerator Method

UncheckedStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement Class

Represents an unsafe statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnsafeStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UnsafeStatement : Statement
Public Class UnsafeStatement
    Inherits Statement

The UnsafeStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UnsafeStatement | Initializes a new instance of the UnsafeStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement Constructor

Initializes a new instance of the UnsafeStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UnsafeStatement()
Public Sub New
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement Properties

The UnsafeStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement.ChildStatement Property

UnsafeStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement.Id Property

UnsafeStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement Methods

The UnsafeStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement.GetChildrenEnumerator Method

UnsafeStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement Class

Represents an unstructured error handler statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorHandlerStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UnstructuredErrorHandlerStatement : Statement
Public Class UnstructuredErrorHandlerStatement
    Inherits Statement

The UnstructuredErrorHandlerStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UnstructuredErrorHandlerStatement | Initializes a new instance of the UnstructuredErrorHandlerStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement Constructor

Initializes a new instance of the UnstructuredErrorHandlerStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UnstructuredErrorHandlerStatement()
Public Sub New
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement Properties

The UnstructuredErrorHandlerStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement.Id Property

UnstructuredErrorHandlerStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement.Label Property

UnstructuredErrorHandlerStatementLabel Property

Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Label { get; set; }
Public Property Label As Expression
    Get
    Set

Property Value

Type: Expression
The label.
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement Methods

The UnstructuredErrorHandlerStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement.GetChildrenEnumerator Method

UnstructuredErrorHandlerStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement Class

Represents an unstructured error resume statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorResumeStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UnstructuredErrorResumeStatement : Statement
Public Class UnstructuredErrorResumeStatement
    Inherits Statement

The UnstructuredErrorResumeStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UnstructuredErrorResumeStatement | Initializes a new instance of the UnstructuredErrorResumeStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement Constructor

Initializes a new instance of the UnstructuredErrorResumeStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UnstructuredErrorResumeStatement()
Public Sub New
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement Properties

The UnstructuredErrorResumeStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement.Id Property

UnstructuredErrorResumeStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement.Label Property

UnstructuredErrorResumeStatementLabel Property

Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Label { get; set; }
Public Property Label As Expression
    Get
    Set

Property Value

Type: Expression
The label.
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement Methods

The UnstructuredErrorResumeStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement.GetChildrenEnumerator Method

UnstructuredErrorResumeStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement Class

Represents an unstructured error throw statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorThrowStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UnstructuredErrorThrowStatement : Statement
Public Class UnstructuredErrorThrowStatement
    Inherits Statement

The UnstructuredErrorThrowStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UnstructuredErrorThrowStatement | Initializes a new instance of the UnstructuredErrorThrowStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement Constructor

Initializes a new instance of the UnstructuredErrorThrowStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UnstructuredErrorThrowStatement()
Public Sub New
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement Properties

The UnstructuredErrorThrowStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement.Expression Property

UnstructuredErrorThrowStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement.Id Property

UnstructuredErrorThrowStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement Methods

The UnstructuredErrorThrowStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement.GetChildrenEnumerator Method

UnstructuredErrorThrowStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective Class

Represents an using directive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingDirective

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UsingDirective : AstNodeBase
Public Class UsingDirective
    Inherits AstNodeBase

The UsingDirective type exposes the following members.

Constructors
 | Name | Description
Public method | UsingDirective | Initializes a new instance of the UsingDirective class
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the type or namespace name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | XmlNamespace | Gets or sets the xml namespace.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v17.1.651.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective Constructor

Initializes a new instance of the UsingDirective class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UsingDirective()
Public Sub New
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective Properties

The UsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the type or namespace name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | XmlNamespace | Gets or sets the xml namespace.
Top
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.Alias Property

UsingDirectiveAlias Property

Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.Id Property

UsingDirectiveId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.Modifiers Property

UsingDirectiveModifiers Property

Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.Name Property

UsingDirectiveName Property

Gets or sets the type or namespace name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Name { get; set; }
Public Property Name As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type or namespace name.
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.XmlNamespace Property

UsingDirectiveXmlNamespace Property

Gets or sets the xml namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string XmlNamespace { get; set; }
Public Property XmlNamespace As String
    Get
    Set

Property Value

Type: String
The xml namespace.
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective Methods

The UsingDirective type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.GetChildrenEnumerator Method

UsingDirectiveGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection Class

Represents an using directive section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingDirectiveSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UsingDirectiveSection : AstNodeBase
Public Class UsingDirectiveSection
    Inherits AstNodeBase

The UsingDirectiveSection type exposes the following members.

Constructors
 | Name | Description
Public method | UsingDirectiveSection | Initializes a new instance of the UsingDirectiveSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Directives | Gets the directives.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDirectives | Returns whether the Directives collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection Constructor

Initializes a new instance of the UsingDirectiveSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UsingDirectiveSection()
Public Sub New
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection Properties

The UsingDirectiveSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Directives | Gets the directives.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDirectives | Returns whether the Directives collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection.Directives Property

UsingDirectiveSectionDirectives Property

Gets the directives.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<UsingDirective> Directives { get; }
Public ReadOnly Property Directives As IList(Of UsingDirective)
    Get

Property Value

Type: IList UsingDirective
The directives.
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection.HasDirectives Property

UsingDirectiveSectionHasDirectives Property

Returns whether the Directives collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDirectives { get; }
Public ReadOnly Property HasDirectives As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection.Id Property

UsingDirectiveSectionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection Methods

The UsingDirectiveSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection.GetChildrenEnumerator Method

UsingDirectiveSectionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement Class

Represents an using statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UsingStatement : Statement
Public Class UsingStatement
    Inherits Statement

The UsingStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UsingStatement | Initializes a new instance of the UsingStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ResourceAcquisition | Gets or sets the resource acquisition.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement Constructor

Initializes a new instance of the UsingStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UsingStatement()
Public Sub New
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement Properties

The UsingStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ResourceAcquisition | Gets or sets the resource acquisition.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement.ChildStatement Property

UsingStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement.Id Property

UsingStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement.ResourceAcquisition Property

UsingStatementResourceAcquisition Property

Gets or sets the resource acquisition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ResourceAcquisition { get; set; }
Public Property ResourceAcquisition As Expression
    Get
    Set

Property Value

Type: Expression
The resource acquisition.
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement Methods

The UsingStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement.GetChildrenEnumerator Method

UsingStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression Class

Represents a variable declaration expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationVariableDeclarationExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VariableDeclarationExpression : Expression
Public Class VariableDeclarationExpression
    Inherits Expression

The VariableDeclarationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | VariableDeclarationExpression | Initializes a new instance of the VariableDeclarationExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression Constructor

Initializes a new instance of the VariableDeclarationExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VariableDeclarationExpression()
Public Sub New
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression Properties

The VariableDeclarationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression.Declarators Property

VariableDeclarationExpressionDeclarators Property

Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The declarators.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression.HasDeclarators Property

VariableDeclarationExpressionHasDeclarators Property

Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression.Id Property

VariableDeclarationExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression Methods

The VariableDeclarationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression.GetChildrenEnumerator Method

VariableDeclarationExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator Class

Represents a variable declarator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationVariableDeclarator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VariableDeclarator : AstNodeBase
Public Class VariableDeclarator
    Inherits AstNodeBase

The VariableDeclarator type exposes the following members.

Constructors
 | Name | Description
Public method | VariableDeclarator | Initializes a new instance of the VariableDeclarator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator Constructor

Initializes a new instance of the VariableDeclarator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VariableDeclarator()
Public Sub New
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator Properties

The VariableDeclarator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Id Property

VariableDeclaratorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Initializer Property

VariableDeclaratorInitializer Property

Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Kind Property

VariableDeclaratorKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VariableDeclaratorKind Kind { get; set; }
Public Property Kind As VariableDeclaratorKind
    Get
    Set

Property Value

Type: VariableDeclaratorKind
The kind.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Name Property

VariableDeclaratorName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Type Property

VariableDeclaratorType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator Methods

The VariableDeclarator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.GetChildrenEnumerator Method

VariableDeclaratorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator Class

Represents a where query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWhereQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WhereQueryOperator : QueryOperator
Public Class WhereQueryOperator
    Inherits QueryOperator

The WhereQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | WhereQueryOperator | Initializes a new instance of the WhereQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression..
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator Constructor

Initializes a new instance of the WhereQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WhereQueryOperator()
Public Sub New
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator Properties

The WhereQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression..
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator.ConditionExpression Property

WhereQueryOperatorConditionExpression Property

Gets or sets the condition expression..

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression..
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator.Id Property

WhereQueryOperatorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator Methods

The WhereQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator.GetChildrenEnumerator Method

WhereQueryOperatorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement Class

Represents a while statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWhileStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WhileStatement : Statement
Public Class WhileStatement
    Inherits Statement

The WhileStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WhileStatement | Initializes a new instance of the WhileStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement Constructor

Initializes a new instance of the WhileStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WhileStatement()
Public Sub New
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement Properties

The WhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement.ChildStatement Property

WhileStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement.ConditionExpression Property

WhileStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement.Id Property

WhileStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement Methods

The WhileStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement.GetChildrenEnumerator Method

WhileStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement Class

Represents a with statement (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWithStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WithStatement : Statement
Public Class WithStatement
    Inherits Statement

The WithStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WithStatement | Initializes a new instance of the WithStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement Constructor

Initializes a new instance of the WithStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WithStatement()
Public Sub New
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement Properties

The WithStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement.ChildStatement Property

WithStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement.Expression Property

WithStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement.Id Property

WithStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement Methods

The WithStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement.GetChildrenEnumerator Method

WithStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression Class

Represents a with target expression (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWithTargetExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WithTargetExpression : Expression
Public Class WithTargetExpression
    Inherits Expression

The WithTargetExpression type exposes the following members.

Constructors
 | Name | Description
Public method | WithTargetExpression | Initializes a new instance of the WithTargetExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression Constructor

Initializes a new instance of the WithTargetExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WithTargetExpression()
Public Sub New
See Also

Reference

WithTargetExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression Properties

The WithTargetExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithTargetExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression.Id Property

WithTargetExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WithTargetExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression Methods

The WithTargetExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithTargetExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression Class

Represents a xml namespace expression (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationXmlNamespaceExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlNamespaceExpression : Expression
Public Class XmlNamespaceExpression
    Inherits Expression

The XmlNamespaceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | XmlNamespaceExpression | Initializes a new instance of the XmlNamespaceExpression class
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression Constructor

Initializes a new instance of the XmlNamespaceExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlNamespaceExpression()
Public Sub New
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression Properties

The XmlNamespaceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression.Alias Property

XmlNamespaceExpressionAlias Property

Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression.Id Property

XmlNamespaceExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression Methods

The XmlNamespaceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement Class

Represents a yield statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationYieldStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class YieldStatement : Statement
Public Class YieldStatement
    Inherits Statement

The YieldStatement type exposes the following members.

Constructors
 | Name | Description
Public method | YieldStatement | Initializes a new instance of the YieldStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement Constructor

Initializes a new instance of the YieldStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public YieldStatement()
Public Sub New
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement Properties

The YieldStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement.Expression Property

YieldStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement.Id Property

YieldStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement Methods

The YieldStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement.GetChildrenEnumerator Method

YieldStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ActiproSoftware.Text.Languages.DotNet.Implementation Namespace

Contains the core classes related to implementing a .NET syntax language.
Classes
 | Class | Description
Public class | DocumentationCommentAutoCompleterBase | Provides an abstract base class for performing auto-complete of .NET language documentation comments when appropriate.
Public class | DotNetClassificationTypeProvider | Represents a provider of IClassificationType objects for a .NET language.
Public class | DotNetCodeBlockFinderBase | Provides an abstract base class for a .NET language code block finder service.
Public class | DotNetCompletionProviderBase | Provides an abstract base class for providing IntelliPrompt completion data for .NET languages.
Public class | DotNetContextFactoryBase | Provides an abstract base class that can create IDotNetContext objects for a TextSnapshotOffset.
Public class | DotNetGrammarBase | Provides an abstract base class for .NET grammars.
Public class | DotNetGrammarOptionsBase | Provides an abstract base class that contains options for a .NET grammar.
Public class | DotNetNavigableSymbolProviderBase | Provides a base class for the navigable symbol provider of a .NET language.
Public class | DotNetParameterInfoProviderBase | Provides an abstract base class for providing IntelliPrompt parameter info popups for .NET languages.
Public class | DotNetParseData | Stores the results of a .NET language parsing operation.
Public class | DotNetParserBase | Provides the abstract base class of a .NET language parser.
Public class | DotNetSyntaxLanguageBase | Provides an abstract base class for a .NET syntax language definition.
Public class | DotNetTextFormatterBase | Provides an abstract base class for text formatting a .NET language.


DocumentationCommentAutoCompleterBase Class

Provides an abstract base class for performing auto-complete of .NET language documentation comments when appropriate.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDocumentationCommentAutoCompleterBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpDocumentationCommentAutoCompleter
ActiproSoftware.Text.Languages.VB.ImplementationVBDocumentationCommentAutoCompleter

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DocumentationCommentAutoCompleterBase : IDocumentationCommentAutoCompleter
Public MustInherit Class DocumentationCommentAutoCompleterBase
    Implements IDocumentationCommentAutoCompleter

The DocumentationCommentAutoCompleterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DocumentationCommentAutoCompleterBase | Initializes a new instance of the DocumentationCommentAutoCompleterBase class
Top
Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled.
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.
Top
Methods
 | Name | Description
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase Constructor

Initializes a new instance of the DocumentationCommentAutoCompleterBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DocumentationCommentAutoCompleterBase()
Protected Sub New
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase Properties

The DocumentationCommentAutoCompleterBase type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled.
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.
Top
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.IsEndTagCompletionEnabled Property

DocumentationCommentAutoCompleterBaseIsEndTagCompletionEnabled Property

Gets or sets whether documentation comment end tag completion is enabled.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEndTagCompletionEnabled { get; set; }
Public Property IsEndTagCompletionEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documentation comment end tag completion is enabled; otherwise, false.

Implements

IDocumentationCommentAutoCompleterIsEndTagCompletionEnabled
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.IsNewLineGenerationEnabled Property

DocumentationCommentAutoCompleterBaseIsNewLineGenerationEnabled Property

Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNewLineGenerationEnabled { get; set; }
Public Property IsNewLineGenerationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment; otherwise, false.

Implements

IDocumentationCommentAutoCompleterIsNewLineGenerationEnabled
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.IsStubGenerationEnabled Property

DocumentationCommentAutoCompleterBaseIsStubGenerationEnabled Property

Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsStubGenerationEnabled { get; set; }
Public Property IsStubGenerationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if stub documentation comment auto-generation is enabled when starting to type new documentation comments; otherwise, false.

Implements

IDocumentationCommentAutoCompleterIsStubGenerationEnabled
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase Methods

The DocumentationCommentAutoCompleterBase type exposes the following members.

Methods
 | Name | Description
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.InsertStubDocumentationComment Method

DocumentationCommentAutoCompleterBaseInsertStubDocumentationComment Method

Attempts to insert a stub documentation comment at the caret's location.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void InsertStubDocumentationComment(
    IEditorView view,
    TextSnapshotOffset targetSnapshotOffset,
    string delimiter
)
Protected Overridable Sub InsertStubDocumentationComment (
    view As IEditorView,
    targetSnapshotOffset As TextSnapshotOffset,
    delimiter As String
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.
targetSnapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
A TextSnapshotOffset indicating the offset at which the target type/member is located.
delimiter
Type: SystemString
The documentation comment delimiter.
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.TranslateToParseDataSnapshot Method

DocumentationCommentAutoCompleterBaseTranslateToParseDataSnapshot Method

Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotOffset TranslateToParseDataSnapshot(
    IDotNetParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Overridable Function TranslateToParseDataSnapshot (
    parseData As IDotNetParseData,
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotOffset

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to translate.

Return Value

Type: TextSnapshotOffset
The translated offset.
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Class

Represents a provider of IClassificationType objects for a .NET language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetClassificationTypeProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DotNetClassificationTypeProvider : IDotNetClassificationTypeProvider
Public Class DotNetClassificationTypeProvider
    Implements IDotNetClassificationTypeProvider

The DotNetClassificationTypeProvider type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetClassificationTypeProvider | Initializes a new instance of the DotNetClassificationTypeProvider class.
Public method | DotNetClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the DotNetClassificationTypeProvider class.
Top
Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | CSharpVerbatimString | Gets the CSharpVerbatimString classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PreprocessorKeyword | Gets the PreprocessorKeyword classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Public property | VBXmlLiteral | Gets the VBXmlLiteral classification type.
Public property | XmlDocumentationComment | Gets the XmlDocumentationComment classification type.
Public property | XmlDocumentationTag | Gets the XmlDocumentationTag classification type.
Top
Methods
 | Name | Description
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.540.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Constructor

Overload List
 | Name | Description
Public method | DotNetClassificationTypeProvider | Initializes a new instance of the DotNetClassificationTypeProvider class.
Public method | DotNetClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the DotNetClassificationTypeProvider class.
Top
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Constructor

Initializes a new instance of the DotNetClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DotNetClassificationTypeProvider()
Public Sub New
See Also

Reference

DotNetClassificationTypeProvider Class
DotNetClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Constructor (IHighlightingStyleRegistry)

Initializes a new instance of the DotNetClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DotNetClassificationTypeProvider(
    IHighlightingStyleRegistry targetRegistry
)
Public Sub New (
    targetRegistry As IHighlightingStyleRegistry
)

Parameters

targetRegistry
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

DotNetClassificationTypeProvider Class
DotNetClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Properties

The DotNetClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | CSharpVerbatimString | Gets the CSharpVerbatimString classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PreprocessorKeyword | Gets the PreprocessorKeyword classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Public property | VBXmlLiteral | Gets the VBXmlLiteral classification type.
Public property | XmlDocumentationComment | Gets the XmlDocumentationComment classification type.
Public property | XmlDocumentationTag | Gets the XmlDocumentationTag classification type.
Top
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Comment Property

DotNetClassificationTypeProviderComment Property

Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Comment { get; }
Public ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.

Implements

IDotNetClassificationTypeProviderComment
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.CSharpVerbatimString Property

DotNetClassificationTypeProviderCSharpVerbatimString Property

Gets the CSharpVerbatimString classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType CSharpVerbatimString { get; }
Public ReadOnly Property CSharpVerbatimString As IClassificationType
    Get

Property Value

Type: IClassificationType
The CSharpVerbatimString classification type.

Implements

IDotNetClassificationTypeProviderCSharpVerbatimString
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Identifier Property

DotNetClassificationTypeProviderIdentifier Property

Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Identifier { get; }
Public ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.

Implements

IDotNetClassificationTypeProviderIdentifier
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Keyword Property

DotNetClassificationTypeProviderKeyword Property

Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Keyword { get; }
Public ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.

Implements

IDotNetClassificationTypeProviderKeyword
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Number Property

DotNetClassificationTypeProviderNumber Property

Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Number { get; }
Public ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.

Implements

IDotNetClassificationTypeProviderNumber
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Operator Property

DotNetClassificationTypeProviderOperator Property

Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Operator { get; }
Public ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.

Implements

IDotNetClassificationTypeProviderOperator
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.PreprocessorKeyword Property

DotNetClassificationTypeProviderPreprocessorKeyword Property

Gets the PreprocessorKeyword classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType PreprocessorKeyword { get; }
Public ReadOnly Property PreprocessorKeyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The PreprocessorKeyword classification type.

Implements

IDotNetClassificationTypeProviderPreprocessorKeyword
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Registry Property

DotNetClassificationTypeProviderRegistry Property

Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry Registry { get; }
Public ReadOnly Property Registry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.String Property

DotNetClassificationTypeProviderString Property

Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType String { get; }
Public ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.

Implements

IDotNetClassificationTypeProviderString
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.VBXmlLiteral Property

DotNetClassificationTypeProviderVBXmlLiteral Property

Gets the VBXmlLiteral classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType VBXmlLiteral { get; }
Public ReadOnly Property VBXmlLiteral As IClassificationType
    Get

Property Value

Type: IClassificationType
The VBXmlLiteral classification type.

Implements

IDotNetClassificationTypeProviderVBXmlLiteral
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.XmlDocumentationComment Property

DotNetClassificationTypeProviderXmlDocumentationComment Property

Gets the XmlDocumentationComment classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlDocumentationComment { get; }
Public ReadOnly Property XmlDocumentationComment As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDocumentationComment classification type.

Implements

IDotNetClassificationTypeProviderXmlDocumentationComment
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.XmlDocumentationTag Property

DotNetClassificationTypeProviderXmlDocumentationTag Property

Gets the XmlDocumentationTag classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlDocumentationTag { get; }
Public ReadOnly Property XmlDocumentationTag As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDocumentationTag classification type.

Implements

IDotNetClassificationTypeProviderXmlDocumentationTag
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Methods

The DotNetClassificationTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Top
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.RegisterAll Method

DotNetClassificationTypeProviderRegisterAll Method

Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<IClassificationType> RegisterAll()
Public Function RegisterAll As IEnumerable(Of IClassificationType)

Return Value

Type: IEnumerable IClassificationType
The collection of IClassificationType objects that were registered.
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCodeBlockFinderBase Class

Provides an abstract base class for a .NET language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCodeBlockFinderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCodeBlockFinder
ActiproSoftware.Text.Languages.VB.ImplementationVBCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetCodeBlockFinderBase : LLParseDataCodeBlockFinder
Public MustInherit Class DotNetCodeBlockFinderBase
    Inherits LLParseDataCodeBlockFinder

The DotNetCodeBlockFinderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetCodeBlockFinderBase | Initializes a new instance of the DotNetCodeBlockFinderBase class.
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCodeBlockFinderBase Constructor

Initializes a new instance of the DotNetCodeBlockFinderBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetCodeBlockFinderBase()
Protected Sub New
See Also

Reference

DotNetCodeBlockFinderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCodeBlockFinderBase Properties

The DotNetCodeBlockFinderBase type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

DotNetCodeBlockFinderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCodeBlockFinderBase Methods

The DotNetCodeBlockFinderBase type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

DotNetCodeBlockFinderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase Class

Provides an abstract base class for providing IntelliPrompt completion data for .NET languages.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCompletionProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCompletionProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBCompletionProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetCompletionProviderBase : CompletionProviderBase
Public MustInherit Class DotNetCompletionProviderBase
    Inherits CompletionProviderBase

The DotNetCompletionProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetCompletionProviderBase | Initializes a new instance of the DotNetCompletionProviderBase class.
Top
Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Inherited from CompletionProviderBase.)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase Constructor

Initializes a new instance of the DotNetCompletionProviderBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetCompletionProviderBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
The string-based key that identifies the provider.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase Properties

The DotNetCompletionProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase.CanShowOnTypedWordStart Property

DotNetCompletionProviderBaseCanShowOnTypedWordStart Property

Gets or sets whether a completion list can auto-show when typing a new word.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanShowOnTypedWordStart { get; set; }
Public Property CanShowOnTypedWordStart As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a completion list can auto-show when typing a new word; otherwise, false.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase Methods

The DotNetCompletionProviderBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Inherited from CompletionProviderBase.)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location.
Top
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase.CreateContext Method

DotNetCompletionProviderBaseCreateContext Method

Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract IDotNetContext CreateContext(
    IEditorView view
)
Protected MustOverride Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase.OnSessionOpening Method

DotNetCompletionProviderBaseOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    ICompletionSession session
)
Protected Overridable Function OnSessionOpening (
    session As ICompletionSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
Remarks
The default implementation of this method sorts the items in the session.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase.ShouldShowForTypedWordStart Method

DotNetCompletionProviderBaseShouldShowForTypedWordStart Method

Returns whether the specified IEditorView supports automatic completion list display at its current caret location.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract bool ShouldShowForTypedWordStart(
    IEditorView view
)
Public MustOverride Function ShouldShowForTypedWordStart (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if automatic completion list display is supported; otherwise, false.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase Class

Provides an abstract base class that can create IDotNetContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetContextFactoryBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpContextFactory
ActiproSoftware.Text.Languages.VB.ImplementationVBContextFactory

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetContextFactoryBase
Public MustInherit Class DotNetContextFactoryBase

The DotNetContextFactoryBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetContextFactoryBase | Initializes a new instance of the DotNetContextFactoryBase class
Top
Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset.
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase Constructor

Initializes a new instance of the DotNetContextFactoryBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetContextFactoryBase()
Protected Sub New
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase Methods

The DotNetContextFactoryBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset.
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.CreateContext Method

DotNetContextFactoryBaseCreateContext Method

Overload List
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Top
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.CreateContext Method (TextSnapshotOffset)

DotNetContextFactoryBaseCreateContext Method (TextSnapshotOffset)

Creates an IDotNetContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDotNetContext CreateContext(
    TextSnapshotOffset snapshotOffset
)
Public Function CreateContext (
    snapshotOffset As TextSnapshotOffset
) As IDotNetContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.

Return Value

Type: IDotNetContext
The IDotNetContext that was created.
See Also

Reference

DotNetContextFactoryBase Class
CreateContext Overload
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.CreateContext Method (TextSnapshotOffset, DotNetContextKind)

DotNetContextFactoryBaseCreateContext Method (TextSnapshotOffset, DotNetContextKind)

Creates an IDotNetContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract IDotNetContext CreateContext(
    TextSnapshotOffset snapshotOffset,
    DotNetContextKind kind
)
Public MustOverride Function CreateContext (
    snapshotOffset As TextSnapshotOffset,
    kind As DotNetContextKind
) As IDotNetContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.
kind
Type: ActiproSoftware.Text.Languages.DotNetDotNetContextKind
A DotNetContextKind indicating the kind of context.

Return Value

Type: IDotNetContext
The IDotNetContext that was created.
See Also

Reference

DotNetContextFactoryBase Class
CreateContext Overload
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.GetContainingAstNode Method

DotNetContextFactoryBaseGetContainingAstNode Method

Returns the IAstNode that contains the specified offset.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IAstNode GetContainingAstNode(
    IDotNetParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Function GetContainingAstNode (
    parseData As IDotNetParseData,
    snapshotOffset As TextSnapshotOffset
) As IAstNode

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.

Return Value

Type: IAstNode
The IAstNode that contains the specified offset.
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.IsQualifiedName Method

DotNetContextFactoryBaseIsQualifiedName Method

Returns whether the specified Expression can equate to a qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool IsQualifiedName(
    Expression expression
)
Protected Function IsQualifiedName (
    expression As Expression
) As Boolean

Parameters

expression
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
The Expression to examine.

Return Value

Type: Boolean
true if the specified Expression can equate to a qualified name; otherwise, false.
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.TranslateToParseDataSnapshot Method

DotNetContextFactoryBaseTranslateToParseDataSnapshot Method

Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotOffset TranslateToParseDataSnapshot(
    IDotNetParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Overridable Function TranslateToParseDataSnapshot (
    parseData As IDotNetParseData,
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotOffset

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to translate.

Return Value

Type: TextSnapshotOffset
The translated offset.
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarBase Class

Provides an abstract base class for .NET grammars.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpGrammar
ActiproSoftware.Text.Languages.VB.ImplementationVBGrammar

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetGrammarBase : Grammar
Public MustInherit Class DotNetGrammarBase
    Inherits Grammar

The DotNetGrammarBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetGrammarBase | Initializes a new instance of the DotNetGrammarBase class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarBase Constructor

Initializes a new instance of the DotNetGrammarBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetGrammarBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the grammar, generally the related language name.
See Also

Reference

DotNetGrammarBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarBase Properties

The DotNetGrammarBase type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

DotNetGrammarBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarBase Methods

The DotNetGrammarBase type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

DotNetGrammarBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarOptionsBase Class

Provides an abstract base class that contains options for a .NET grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarOptionsBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpGrammarOptions
ActiproSoftware.Text.Languages.VB.ImplementationVBGrammarOptions

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetGrammarOptionsBase
Public MustInherit Class DotNetGrammarOptionsBase

The DotNetGrammarOptionsBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetGrammarOptionsBase | Initializes a new instance of the DotNetGrammarOptionsBase class.
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarOptionsBase Constructor

Initializes a new instance of the DotNetGrammarOptionsBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetGrammarOptionsBase()
Protected Sub New
See Also

Reference

DotNetGrammarOptionsBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarOptionsBase Properties

The DotNetGrammarOptionsBase type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

DotNetGrammarOptionsBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarOptionsBase.RootNonTerminal Property

DotNetGrammarOptionsBaseRootNonTerminal Property

Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DotNetGrammarRootNonTerminal RootNonTerminal { get; set; }
Public Property RootNonTerminal As DotNetGrammarRootNonTerminal
    Get
    Set

Property Value

Type: DotNetGrammarRootNonTerminal
A DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

DotNetGrammarOptionsBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase Class

Provides a base class for the navigable symbol provider of a .NET language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetNavigableSymbolProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpNavigableSymbolProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetNavigableSymbolProviderBase : INavigableSymbolProvider
Public MustInherit Class DotNetNavigableSymbolProviderBase
    Implements INavigableSymbolProvider

The DotNetNavigableSymbolProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetNavigableSymbolProviderBase | Initializes a new instance of the DotNetNavigableSymbolProviderBase class
Top
Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration.
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration.
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase Constructor

Initializes a new instance of the DotNetNavigableSymbolProviderBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetNavigableSymbolProviderBase()
Protected Sub New
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase Methods

The DotNetNavigableSymbolProviderBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration.
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration.
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Top
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase.CreateTypeMemberSymbol Method

DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol Method

Creates an INavigableSymbol for a TypeMemberDeclaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract INavigableSymbol CreateTypeMemberSymbol(
    TypeMemberDeclaration memberDecl,
    ITextSnapshot snapshot
)
Protected MustOverride Function CreateTypeMemberSymbol (
    memberDecl As TypeMemberDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

memberDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
The TypeMemberDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase.CreateTypeSymbol Method

DotNetNavigableSymbolProviderBaseCreateTypeSymbol Method

Creates an INavigableSymbol for a TypeDeclaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract INavigableSymbol CreateTypeSymbol(
    TypeDeclaration typeDecl,
    ITextSnapshot snapshot
)
Protected MustOverride Function CreateTypeSymbol (
    typeDecl As TypeDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

typeDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
The TypeDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase.GetSymbols Method

DotNetNavigableSymbolProviderBaseGetSymbols Method

Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual INavigableSymbolSet GetSymbols(
    INavigableRequestContext context,
    TextSnapshotOffset snapshotOffset,
    INavigableSymbol parentSymbol
)
Public Overridable Function GetSymbols (
    context As INavigableRequestContext,
    snapshotOffset As TextSnapshotOffset,
    parentSymbol As INavigableSymbol
) As INavigableSymbolSet

Parameters

context
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptINavigableRequestContext
An INavigableRequestContext that provides the context of the request.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset that contains the ITextSnapshot to examine, along with a contextual offset.
parentSymbol
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptINavigableSymbol
The optional parent INavigableSymbol to examine, or a null value if the root symbols are requested.

Return Value

Type: INavigableSymbolSet
An INavigableSymbolSet containing the INavigableSymbol objects that were located.

Implements

INavigableSymbolProviderGetSymbols(INavigableRequestContext, TextSnapshotOffset, INavigableSymbol)
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase Class

Provides an abstract base class for providing IntelliPrompt parameter info popups for .NET languages.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationParameterInfoProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParameterInfoProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpParameterInfoProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBParameterInfoProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetParameterInfoProviderBase : ParameterInfoProviderBase,
    IEditorViewSelectionChangeEventSink
Public MustInherit Class DotNetParameterInfoProviderBase
    Inherits ParameterInfoProviderBase
    Implements IEditorViewSelectionChangeEventSink

The DotNetParameterInfoProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetParameterInfoProviderBase | Initializes a new instance of the DotNetParameterInfoProviderBase class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Inherited from ParameterInfoProviderBase.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase Constructor

Initializes a new instance of the DotNetParameterInfoProviderBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetParameterInfoProviderBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
The string-based key that identifies the provider.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase Properties

The DotNetParameterInfoProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase Methods

The DotNetParameterInfoProviderBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Inherited from ParameterInfoProviderBase.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext.
Top
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase.CreateContext Method

DotNetParameterInfoProviderBaseCreateContext Method

Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract IDotNetContext CreateContext(
    IEditorView view
)
Protected MustOverride Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase.OnSessionOpening Method

DotNetParameterInfoProviderBaseOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IParameterInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IParameterInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIParameterInfoSession
The IParameterInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase.OnViewSelectionChanged Method

DotNetParameterInfoProviderBaseOnViewSelectionChanged Method

Occurs when the selection is changed in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnViewSelectionChanged(
    IEditorView view,
    EditorViewSelectionEventArgs e
)
Protected Overridable Sub OnViewSelectionChanged (
    view As IEditorView,
    e As EditorViewSelectionEventArgs
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorViewSelectionEventArgs
The EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase.UpdateCurrentParameter Method

DotNetParameterInfoProviderBaseUpdateCurrentParameter Method

Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool UpdateCurrentParameter(
    IParameterInfoSession session,
    IDotNetContext context
)
Protected Overridable Function UpdateCurrentParameter (
    session As IParameterInfoSession,
    context As IDotNetContext
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIParameterInfoSession
The IParameterInfoSession to update.
context
Type: ActiproSoftware.Text.Languages.DotNetIDotNetContext
The IDotNetContext to examine.

Return Value

Type: Boolean
true if an update was made; otherwise, false.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParseData Class

Stores the results of a .NET language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParseData

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DotNetParseData : LLParseData,
    ILLParseData, IParseData, IParseErrorProvider, IDotNetParseData
Public Class DotNetParseData
    Inherits LLParseData
    Implements ILLParseData, IParseData, IParseErrorProvider, IDotNetParseData

The DotNetParseData type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetParseData | Initializes a new instance of the DotNetParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | PreprocessorDirectives | Gets the collection of preprocessor directives.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParseData Constructor

Initializes a new instance of the DotNetParseData class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DotNetParseData()
Public Sub New
See Also

Reference

DotNetParseData Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParseData Properties

The DotNetParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | PreprocessorDirectives | Gets the collection of preprocessor directives.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

DotNetParseData Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParseData.PreprocessorDirectives Property

DotNetParseDataPreprocessorDirectives Property

Gets the collection of preprocessor directives.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<PreprocessorDirective> PreprocessorDirectives { get; }
Public ReadOnly Property PreprocessorDirectives As IList(Of PreprocessorDirective)
    Get

Property Value

Type: IList PreprocessorDirective
The collection of preprocessor directives.

Implements

IDotNetParseDataPreprocessorDirectives
See Also

Reference

DotNetParseData Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase Class

Provides the abstract base class of a .NET language parser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParserBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpParser
ActiproSoftware.Text.Languages.VB.ImplementationVBParser

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetParserBase : LLParserBase
Public MustInherit Class DotNetParserBase
    Inherits LLParserBase

The DotNetParserBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetParserBase | Initializes a new instance of the DotNetParserBase class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Inherited from LLParserBase.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Inherited from LLParserBase.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase Constructor

Initializes a new instance of the DotNetParserBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetParserBase(
    Grammar grammar
)
Protected Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

DotNetParserBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase Properties

The DotNetParserBase type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

DotNetParserBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase Methods

The DotNetParserBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Inherited from LLParserBase.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Inherited from LLParserBase.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Top
See Also

Reference

DotNetParserBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase.CreateParseData Method

DotNetParserBaseCreateParseData Method

Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

DotNetParserBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Class

Provides an abstract base class for a .NET syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetSyntaxLanguageBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpSyntaxLanguage
ActiproSoftware.Text.Languages.VB.ImplementationVBSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetSyntaxLanguageBase : SyntaxLanguage,
    ICodeDocumentLifecycleEventSink, ICodeDocumentPropertyChangeEventSink
Public MustInherit Class DotNetSyntaxLanguageBase
    Inherits SyntaxLanguage
    Implements ICodeDocumentLifecycleEventSink, ICodeDocumentPropertyChangeEventSink

The DotNetSyntaxLanguageBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetSyntaxLanguageBase | Initializes a new instance of the DotNetSyntaxLanguageBase class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language.
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language.
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language.
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Constructor

Initializes a new instance of the DotNetSyntaxLanguageBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetSyntaxLanguageBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
The language key.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Properties

The DotNetSyntaxLanguageBase type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Methods

The DotNetSyntaxLanguageBase type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language.
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language.
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language.
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase.OnDocumentAttached Method

DotNetSyntaxLanguageBaseOnDocumentAttached Method

Occurs when the specified ICodeDocument is attached to the language.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentAttached(
    ICodeDocument document
)
Protected Overridable Sub OnDocumentAttached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase.OnDocumentDetached Method

DotNetSyntaxLanguageBaseOnDocumentDetached Method

Occurs when the specified ICodeDocument is detached from the language.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentDetached(
    ICodeDocument document
)
Protected Overridable Sub OnDocumentDetached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase.OnDocumentFileNameChanged Method

DotNetSyntaxLanguageBaseOnDocumentFileNameChanged Method

Occurs after the FileName property is changed on an ICodeDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentFileNameChanged(
    ICodeDocument document,
    StringPropertyChangedEventArgs e
)
Protected Overridable Sub OnDocumentFileNameChanged (
    document As ICodeDocument,
    e As StringPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose FileName property is changed.
e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
The StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase.OnDocumentParseDataChanged Method

DotNetSyntaxLanguageBaseOnDocumentParseDataChanged Method

Occurs after the ParseData property is changed on an ICodeDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentParseDataChanged(
    ICodeDocument document,
    ParseDataPropertyChangedEventArgs e
)
Protected Overridable Sub OnDocumentParseDataChanged (
    document As ICodeDocument,
    e As ParseDataPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose ParseData property is changed.
e
Type: ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
The ParseDataPropertyChangedEventArgs that contains the event data.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Events

The DotNetSyntaxLanguageBase type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetTextFormatterBase Class

Provides an abstract base class for text formatting a .NET language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetTextFormatterBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTextFormatter
ActiproSoftware.Text.Languages.VB.ImplementationVBTextFormatter

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DotNetTextFormatterBase : ITextFormatter
Public MustInherit Class DotNetTextFormatterBase
    Implements ITextFormatter

The DotNetTextFormatterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetTextFormatterBase | Initializes a new instance of the DotNetTextFormatterBase class
Top
Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetTextFormatterBase Constructor

Initializes a new instance of the DotNetTextFormatterBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DotNetTextFormatterBase()
Protected Sub New
See Also

Reference

DotNetTextFormatterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetTextFormatterBase Methods

The DotNetTextFormatterBase type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
See Also

Reference

DotNetTextFormatterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetTextFormatterBase.Format Method

DotNetTextFormatterBaseFormat Method

Applies text formatting to part or all of a snapshot.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void Format(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection selectionPositionRanges,
    TextFormatMode mode = TextFormatMode.Ranges
)
Public MustOverride Sub Format (
    snapshot As ITextSnapshot,
    selectionPositionRanges As ITextPositionRangeCollection,
    Optional mode As TextFormatMode = TextFormatMode.Ranges
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
selectionPositionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the selection position ranges. These are used to translate the current selection to the new snapshot that is created, even when formatting the entire snapshot.
mode (Optional)
Type: ActiproSoftware.TextTextFormatMode
A TextFormatMode indicating whether to format part or all of the snapshot. The default value is Ranges.

Implements

ITextFormatterFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode)
Remarks
The containing ITextDocument is accessible via the ITextSnapshot.
See Also

Reference

DotNetTextFormatterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


ActiproSoftware.Text.Languages.DotNet.Reflection Namespace

Contains the types related to reflection for a .NET syntax language.
Classes
 | Class | Description
Public class | AmbientAssemblyRepositoryProvider | Implements a class that can be used to provide a static IAssemblyRepository that is used for managing and caching assemblies by default.
Interfaces
 | Interface | Description
Public interface | IAliasedUsingDirective | Provides the base requirements of an using directive with an alias.
Public interface | IAssembly | Provides the base requirements of an assembly.
Public interface | IAssemblyDocumentation | Provides the base requirements of an object that can access documentation for the types and members defined in an assembly.
Public interface | IAssemblyName | Provides the base requirements of an assembly name.
Public interface | IAssemblyReference | Provides the base requirements of an assembly reference.
Public interface | IAssemblyRepository | Provides the base requirements for a class that manages IAssembly instances and caching of data as appropriate.
Public interface | IBinaryAssembly | Provides the base requirements of a binary assembly.
Public interface | IBinaryAssemblyMetadata | Provides the base requirements for storing metadata of an IBinaryAssembly, generally used with serialization.
Public interface | IBinaryAssemblyReference | Provides the base requirements of an assembly reference within an IBinaryAssembly.
Public interface | IBinaryAssemblyReferenceCollection | Provides the base requirements for a collection of IBinaryAssemblyReference objects.
Public interface | IDocumentationProvider | Provides the base requirements of an object that can return documentation for a .NET type or member definition.
Public interface | IExternalAliasDirective | Provides the base requirements of an external alias directive.
Public interface | INamespaceDeclaration | Provides the base requirements of a namespace declaration that encloses types declared in a source file.
Public interface | INamespaceDefinition | Provides the base requirements of a namespace that can contain types and other nested namespaces.
Public interface | INamespaceDefinitionCollection | Provides the base requirements for a collection of INamespaceDefinition objects.
Public interface | IParameterDefinition | Provides the base requirements of a parameter definition.
Public interface | IParameterDefinitionCollection | Provides the base requirements for a collection of IParameterDefinition objects.
Public interface | IProjectAssembly | Provides the base requirements of a project (source code-based) assembly.
Public interface | IProjectAssemblyReference | Provides the base requirements of an assembly reference within an IProjectAssembly.
Public interface | IProjectAssemblyReferenceCollection | Provides the base requirements for a collection of IProjectAssemblyReference objects.
Public interface | IQualifiedName | Provides the base requirements of a qualified name.
Public interface | IReflectionDefinition | Provides the base requirements of a reflection definition.
Public interface | ISimpleName | Provides the base requirements of a simple name with optional type arguments, which is a component of an IQualifiedName.
Public interface | ISourceFile | Provides the base requirements of a source code file that can be loaded by an IProjectAssembly.
Public interface | ISourceFileCollection | Provides the base requirements for a collection of ISourceFile objects.
Public interface | ISourceFileLocation | Provides the base requirements of a source code file reference and related offsets within that file, generally used to denote where a type/member was defined.
Public interface | ISourceFileLocationCollection | Provides the base requirements for a collection of ISourceFileLocation objects.
Public interface | ITypeDefinition | Provides the base requirements of a type definition.
Public interface | ITypeDefinitionCollection | Provides the base requirements for a collection of ITypeDefinition objects.
Public interface | ITypeMemberDefinition | Provides the base requirements of a type member (method, property, etc.) definition.
Public interface | ITypeMemberDefinitionCollection | Provides the base requirements for a collection of ITypeMemberDefinition objects.
Public interface | ITypeMemberReference | Provides the base requirements of a type member (method, property, etc.) reference.
Public interface | ITypeParameter | Provides the base requirements of a generic type parameter.
Public interface | ITypeParameterCollection | Provides the base requirements for a collection of ITypeParameter objects.
Public interface | ITypeReference | Provides the base requirements of a type reference.
Public interface | ITypeReferenceCollection | Provides the base requirements for a collection of ITypeReference objects.
Public interface | IUsingDirective | Provides the base requirements of an using directive.
Public interface | IVariableDefinition | Provides the base requirements of a variable definition.
Enumerations
 | Enumeration | Description
Public enumeration | TypeAccess | Specifies the type of access visibility for an ITypeDefinition.
Public enumeration | TypeDefinitionKind | Specifies the kind of ITypeDefinition.
Public enumeration | TypeMemberAccess | Specifies the type of access visibility for an ITypeMemberDefinition.
Public enumeration | TypeMemberDefinitionKind | Specifies the kind of ITypeMemberDefinition.


AmbientAssemblyRepositoryProvider Class

Implements a class that can be used to provide a static IAssemblyRepository that is used for managing and caching assemblies by default.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ReflectionAmbientAssemblyRepositoryProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class AmbientAssemblyRepositoryProvider
Public NotInheritable Class AmbientAssemblyRepositoryProvider

The AmbientAssemblyRepositoryProvider type exposes the following members.

Properties
Name | Description
Repository | Gets or sets the default IAssemblyRepository to use.
Top
Remarks
Set the Repository property to an IAssemblyRepository instance to register the default assembly respository.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


AmbientAssemblyRepositoryProvider Properties

The AmbientAssemblyRepositoryProvider type exposes the following members.

Properties
Name | Description
Repository | Gets or sets the default IAssemblyRepository to use.
Top
See Also

Reference

AmbientAssemblyRepositoryProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


AmbientAssemblyRepositoryProvider.Repository Property

AmbientAssemblyRepositoryProviderRepository Property

Gets or sets the default IAssemblyRepository to use.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IAssemblyRepository Repository { get; set; }
Public Shared Property Repository As IAssemblyRepository
    Get
    Set

Property Value

Type: IAssemblyRepository
The default IAssemblyRepository to use.
See Also

Reference

AmbientAssemblyRepositoryProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAliasedUsingDirective Interface

Provides the base requirements of an using directive with an alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAliasedUsingDirective : IUsingDirective
Public Interface IAliasedUsingDirective
    Inherits IUsingDirective

The IAliasedUsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias that is defined by the directive.
Public property | IsStatic | Gets whether this using directive is flagged as static. (Inherited from IUsingDirective.)
Public property | Name | Gets the qualified name of the namespace imported by the using directive. (Inherited from IUsingDirective.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAliasedUsingDirective Properties

The IAliasedUsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias that is defined by the directive.
Public property | IsStatic | Gets whether this using directive is flagged as static. (Inherited from IUsingDirective.)
Public property | Name | Gets the qualified name of the namespace imported by the using directive. (Inherited from IUsingDirective.)
Top
See Also

Reference

IAliasedUsingDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAliasedUsingDirective.Alias Property

IAliasedUsingDirectiveAlias Property

Gets the alias that is defined by the directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Alias { get; }
ReadOnly Property Alias As String
    Get

Property Value

Type: String
The alias that is defined by the directive.
See Also

Reference

IAliasedUsingDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly Interface

Provides the base requirements of an assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAssembly
Public Interface IAssembly

The IAssembly type exposes the following members.

Properties
 | Name | Description
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly Properties

The IAssembly type exposes the following members.

Properties
 | Name | Description
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Top
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.Documentation Property

IAssemblyDocumentation Property

Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAssemblyDocumentation Documentation { get; set; }
Property Documentation As IAssemblyDocumentation
    Get
    Set

Property Value

Type: IAssemblyDocumentation
The IAssemblyDocumentation that provides access to this assembly's type and member documentation.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.GlobalNamespace Property

IAssemblyGlobalNamespace Property

Gets the entry point into the INamespaceDefinition tree defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
INamespaceDefinition GlobalNamespace { get; }
ReadOnly Property GlobalNamespace As INamespaceDefinition
    Get

Property Value

Type: INamespaceDefinition
The entry point into the INamespaceDefinition tree defined in this assembly.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.Name Property

IAssemblyName Property

Gets the simple name of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The simple name of the assembly.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.Namespaces Property

IAssemblyNamespaces Property

Gets the collection of INamespaceDefinition objects defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
INamespaceDefinitionCollection Namespaces { get; }
ReadOnly Property Namespaces As INamespaceDefinitionCollection
    Get

Property Value

Type: INamespaceDefinitionCollection
The collection of INamespaceDefinition objects defined in this assembly.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly Methods

The IAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.GetAssemblyName Method

IAssemblyGetAssemblyName Method

Returns an IAssemblyName that contains assembly name information.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAssemblyName GetAssemblyName()
Function GetAssemblyName As IAssemblyName

Field Value

Type: IAssemblyName
An IAssemblyName that contains assembly name information.

Return Value

Type: IAssemblyName

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.IAssembly.GetAssemblyName"]

See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.ToTreeString Method

IAssemblyToTreeString Method

Outputs the contents of the assembly in tree form.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ToTreeString()
Function ToTreeString As String

Return Value

Type: String
A string that indicates the contents of the assembly.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation Interface

Provides the base requirements of an object that can access documentation for the types and members defined in an assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAssemblyDocumentation
Public Interface IAssemblyDocumentation
Methods
 | Name | Description
Public method | GetDocumentation(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentation(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation Methods

Methods
 | Name | Description
Public method | GetDocumentation(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentation(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Top
See Also

Reference

IAssemblyDocumentation Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation.GetDocumentation Method

IAssemblyDocumentationGetDocumentation Method

Overload List
 | Name | Description
Public method | GetDocumentation(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentation(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Top
See Also

Reference

IAssemblyDocumentation Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation.GetDocumentation Method (ITypeDefinition)

IAssemblyDocumentationGetDocumentation Method (ITypeDefinition)

Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDocumentationProvider GetDocumentation(
    ITypeDefinition typeDef
)
Function GetDocumentation (
    typeDef As ITypeDefinition
) As IDocumentationProvider

Parameters

typeDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeDefinition
The ITypeDefinition for which to search.

Return Value

Type: IDocumentationProvider
The IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
See Also

Reference

IAssemblyDocumentation Interface
GetDocumentation Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation.GetDocumentation Method (ITypeMemberDefinition)

IAssemblyDocumentationGetDocumentation Method (ITypeMemberDefinition)

Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDocumentationProvider GetDocumentation(
    ITypeMemberDefinition typeMemberDef
)
Function GetDocumentation (
    typeMemberDef As ITypeMemberDefinition
) As IDocumentationProvider

Parameters

typeMemberDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeMemberDefinition
The ITypeMemberDefinition for which to search.

Return Value

Type: IDocumentationProvider
The IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
See Also

Reference

IAssemblyDocumentation Interface
GetDocumentation Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName Interface

Provides the base requirements of an assembly name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAssemblyName
Public Interface IAssemblyName

The IAssemblyName type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets the full name of the assembly, also known as the display name.
Public property | Name | Gets the simple name of the assembly.
Public property | Version | Gets the major, minor, build, and revision numbers of the assembly.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName Properties

The IAssemblyName type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets the full name of the assembly, also known as the display name.
Public property | Name | Gets the simple name of the assembly.
Public property | Version | Gets the major, minor, build, and revision numbers of the assembly.
Top
See Also

Reference

IAssemblyName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName.FullName Property

IAssemblyNameFullName Property

Gets the full name of the assembly, also known as the display name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the assembly, also known as the display name.
See Also

Reference

IAssemblyName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName.Name Property

IAssemblyNameName Property

Gets the simple name of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The simple name of the assembly.
See Also

Reference

IAssemblyName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName.Version Property

IAssemblyNameVersion Property

Gets the major, minor, build, and revision numbers of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Version Version { get; }
ReadOnly Property Version As Version
    Get

Property Value

Type: Version
the major, minor, build, and revision numbers of the assembly.
See Also

Reference

IAssemblyName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyReference Interface

Provides the base requirements of an assembly reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAssemblyReference
Public Interface IAssemblyReference

The IAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyReference Properties

The IAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information.
Top
See Also

Reference

IAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyReference.AssemblyName Property

IAssemblyReferenceAssemblyName Property

Gets an IAssemblyName that contains assembly name information.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAssemblyName AssemblyName { get; }
ReadOnly Property AssemblyName As IAssemblyName
    Get

Property Value

Type: IAssemblyName
An IAssemblyName that contains assembly name information.
See Also

Reference

IAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository Interface

Provides the base requirements for a class that manages IAssembly instances and caching of data as appropriate.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAssemblyRepository
Public Interface IAssemblyRepository

The IAssemblyRepository type exposes the following members.

Properties
 | Name | Description
Public property | SyncRoot | Gets an object that can be used to synchronize access to the repository.
Top
Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly.
Public method | Load(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | Load(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | Load(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Public method | LoadFrom | Creates a new IBinaryAssembly instance from the Assembly at the specified path.
Public method | PruneCache | Deletes any cache data that is no longer valid.
Public method | Remove | Removes a reference to an IBinaryAssembly.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository Properties

The IAssemblyRepository type exposes the following members.

Properties
 | Name | Description
Public property | SyncRoot | Gets an object that can be used to synchronize access to the repository.
Top
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.SyncRoot Property

IAssemblyRepositorySyncRoot Property

Gets an object that can be used to synchronize access to the repository.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object SyncRoot { get; }
ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object
An object that can be used to synchronize access to the repository.
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository Methods

The IAssemblyRepository type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly.
Public method | Load(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | Load(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | Load(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Public method | LoadFrom | Creates a new IBinaryAssembly instance from the Assembly at the specified path.
Public method | PruneCache | Deletes any cache data that is no longer valid.
Public method | Remove | Removes a reference to an IBinaryAssembly.
Top
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.Add Method

IAssemblyRepositoryAdd Method

Adds a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Add(
    IBinaryAssembly assembly
)
Sub Add (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is referenced.
Remarks
The specified assembly will be tracked while there are remaining references to it. While tracked, the various Load(String) methods will return the already-loaded instance when appropriate.
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.Load Method

IAssemblyRepositoryLoad Method

Overload List
 | Name | Description
Public method | Load(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | Load(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | Load(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Top
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.Load Method (Assembly)

IAssemblyRepositoryLoad Method (Assembly)

Creates a new IBinaryAssembly instance from the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IBinaryAssembly Load(
    Assembly assembly
)
Function Load (
    assembly As Assembly
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was created.
See Also

Reference

IAssemblyRepository Interface
Load Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.Load Method (String)

IAssemblyRepositoryLoad Method (String)

Creates a new IBinaryAssembly instance from the specified Assembly name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IBinaryAssembly Load(
    string fullName
)
Function Load (
    fullName As String
) As IBinaryAssembly

Parameters

fullName
Type: SystemString
The Assembly full name for which to load.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was created.
See Also

Reference

IAssemblyRepository Interface
Load Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.Load Method (Assembly, IAssemblyName)

IAssemblyRepositoryLoad Method (Assembly, IAssemblyName)

Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IBinaryAssembly Load(
    Assembly assembly,
    IAssemblyName assemblyName
)
Function Load (
    assembly As Assembly,
    assemblyName As IAssemblyName
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The alternate AssemblyName to use.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was created.
See Also

Reference

IAssemblyRepository Interface
Load Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.LoadFrom Method

IAssemblyRepositoryLoadFrom Method

Creates a new IBinaryAssembly instance from the Assembly at the specified path.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IBinaryAssembly LoadFrom(
    string path
)
Function LoadFrom (
    path As String
) As IBinaryAssembly

Parameters

path
Type: SystemString
The path to the Assembly file to load.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was created.
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.PruneCache Method

IAssemblyRepositoryPruneCache Method

Deletes any cache data that is no longer valid.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void PruneCache()
Sub PruneCache
Remarks
Call this method upon the shutdown of your application to ensure out-of-date cache data isn't retained.
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.Remove Method

IAssemblyRepositoryRemove Method

Removes a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Remove(
    IBinaryAssembly assembly
)
Sub Remove (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is no longer referenced.
Remarks
When no references remain for the assembly, it will no longer be tracked.
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly Interface

Provides the base requirements of a binary assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IBinaryAssembly : IAssembly,
    IBinaryAssemblyMetadata
Public Interface IBinaryAssembly
    Inherits IAssembly, IBinaryAssemblyMetadata

The IBinaryAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from IAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from IAssembly.)
Public property | HasLoadErrors | Gets whether load errors were encountered when using reflection on the related .NET assembly.
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known. (Inherited from IBinaryAssemblyMetadata.)
Public property | Location | Gets the location of the assembly, if known. (Inherited from IBinaryAssemblyMetadata.)
Public property | Name | Gets the simple name of the assembly. (Inherited from IAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from IAssembly.)
Public property | Size | Gets the size of the assembly, if known. (Inherited from IBinaryAssemblyMetadata.)
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from IAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from IAssembly.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly Properties

The IBinaryAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from IAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from IAssembly.)
Public property | HasLoadErrors | Gets whether load errors were encountered when using reflection on the related .NET assembly.
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known. (Inherited from IBinaryAssemblyMetadata.)
Public property | Location | Gets the location of the assembly, if known. (Inherited from IBinaryAssemblyMetadata.)
Public property | Name | Gets the simple name of the assembly. (Inherited from IAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from IAssembly.)
Public property | Size | Gets the size of the assembly, if known. (Inherited from IBinaryAssemblyMetadata.)
Top
See Also

Reference

IBinaryAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly.AssemblyReferences Property

IBinaryAssemblyAssemblyReferences Property

Gets the collection of assembly references for this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IBinaryAssemblyReferenceCollection AssemblyReferences { get; }
ReadOnly Property AssemblyReferences As IBinaryAssemblyReferenceCollection
    Get

Property Value

Type: IBinaryAssemblyReferenceCollection
The collection of assembly references for this assembly.
See Also

Reference

IBinaryAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly.HasLoadErrors Property

IBinaryAssemblyHasLoadErrors Property

Gets whether load errors were encountered when using reflection on the related .NET assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasLoadErrors { get; }
ReadOnly Property HasLoadErrors As Boolean
    Get

Property Value

Type: Boolean
true if load errors were encountered; otherwise, false.
See Also

Reference

IBinaryAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly Methods

The IBinaryAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from IAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from IAssembly.)
Top
See Also

Reference

IBinaryAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata Interface

Provides the base requirements for storing metadata of an IBinaryAssembly, generally used with serialization.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IBinaryAssemblyMetadata
Public Interface IBinaryAssemblyMetadata

The IBinaryAssemblyMetadata type exposes the following members.

Properties
 | Name | Description
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known.
Public property | Location | Gets the location of the assembly, if known.
Public property | Size | Gets the size of the assembly, if known.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata Properties

The IBinaryAssemblyMetadata type exposes the following members.

Properties
 | Name | Description
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known.
Public property | Location | Gets the location of the assembly, if known.
Public property | Size | Gets the size of the assembly, if known.
Top
See Also

Reference

IBinaryAssemblyMetadata Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata.LastModifiedDateTime Property

IBinaryAssemblyMetadataLastModifiedDateTime Property

Gets the DateTime at which the assembly was last modified, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<DateTime> LastModifiedDateTime { get; }
ReadOnly Property LastModifiedDateTime As Nullable(Of DateTime)
    Get

Property Value

Type: Nullable DateTime
The DateTime at which the assembly was last modified, if known.
See Also

Reference

IBinaryAssemblyMetadata Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata.Location Property

IBinaryAssemblyMetadataLocation Property

Gets the location of the assembly, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Location { get; }
ReadOnly Property Location As String
    Get

Property Value

Type: String
The location of the assembly, if known.
See Also

Reference

IBinaryAssemblyMetadata Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata.Size Property

IBinaryAssemblyMetadataSize Property

Gets the size of the assembly, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<long> Size { get; }
ReadOnly Property Size As Nullable(Of Long)
    Get

Property Value

Type: Nullable Int64
The size of the assembly, if known.
See Also

Reference

IBinaryAssemblyMetadata Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReference Interface

Provides the base requirements of an assembly reference within an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IBinaryAssemblyReference : IAssemblyReference
Public Interface IBinaryAssemblyReference
    Inherits IAssemblyReference

The IBinaryAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information. (Inherited from IAssemblyReference.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReference Properties

The IBinaryAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information. (Inherited from IAssemblyReference.)
Top
See Also

Reference

IBinaryAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection Interface

Provides the base requirements for a collection of IBinaryAssemblyReference objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IBinaryAssemblyReferenceCollection : IObservableCollection<IBinaryAssemblyReference>,
    IList<IBinaryAssemblyReference>, ICollection<IBinaryAssemblyReference>, IEnumerable<IBinaryAssemblyReference>,
    IEnumerable
Public Interface IBinaryAssemblyReferenceCollection
    Inherits IObservableCollection(Of IBinaryAssemblyReference), IList(Of IBinaryAssemblyReference),
    ICollection(Of IBinaryAssemblyReference), IEnumerable(Of IBinaryAssemblyReference), IEnumerable

The IBinaryAssemblyReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IBinaryAssemblyReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IBinaryAssemblyReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IBinaryAssemblyReference .)
Public property | ItemString | Gets the IBinaryAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IBinaryAssemblyReferenceCollection class.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IBinaryAssemblyReference .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IBinaryAssemblyReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IBinaryAssemblyReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IBinaryAssemblyReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIBinaryAssemblyReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIBinaryAssemblyReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIBinaryAssemblyReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection Properties

The IBinaryAssemblyReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IBinaryAssemblyReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IBinaryAssemblyReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IBinaryAssemblyReference .)
Public property | ItemString | Gets the IBinaryAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IBinaryAssemblyReferenceCollection class.
Top
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection.Item Property

IBinaryAssemblyReferenceCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IBinaryAssemblyReference .)
Public property | ItemString | Gets the IBinaryAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IBinaryAssemblyReferenceCollection class.
Top
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection.Item Property (String)

IBinaryAssemblyReferenceCollectionItem Property (String)

Gets the IBinaryAssemblyReference for the assembly with the specified full name.

[C#] In C#, this property is the indexer for the IBinaryAssemblyReferenceCollection class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IBinaryAssemblyReference this[
    string fullName
] { get; }
ReadOnly Default Property Item (
    fullName As String
) As IBinaryAssemblyReference
    Get

Parameters

fullName
Type: SystemString
The full name of the IBinaryAssemblyReference to return.

Property Value

Type: IBinaryAssemblyReference
The IBinaryAssemblyReference for the assembly with the specified full name.
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection Methods

The IBinaryAssemblyReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IBinaryAssemblyReference .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IBinaryAssemblyReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IBinaryAssemblyReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IBinaryAssemblyReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IBinaryAssemblyReference .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIBinaryAssemblyReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIBinaryAssemblyReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIBinaryAssemblyReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection Events

The IBinaryAssemblyReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider Interface

Provides the base requirements of an object that can return documentation for a .NET type or member definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDocumentationProvider
Public Interface IDocumentationProvider

The IDocumentationProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetParameter | Returns the documentation for the parameter with the specified name.
Public method | GetSummary | Returns the summary documentation.
Public method | GetTypeParameter | Returns the documentation for the type parameter with the specified name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider Methods

The IDocumentationProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetParameter | Returns the documentation for the parameter with the specified name.
Public method | GetSummary | Returns the summary documentation.
Public method | GetTypeParameter | Returns the documentation for the type parameter with the specified name.
Top
See Also

Reference

IDocumentationProvider Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider.GetParameter Method

IDocumentationProviderGetParameter Method

Returns the documentation for the parameter with the specified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetParameter(
    string name
)
Function GetParameter (
    name As String
) As String

Parameters

name
Type: SystemString
The parameter name.

Return Value

Type: String
The documentation for the parameter with the specified name.
See Also

Reference

IDocumentationProvider Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider.GetSummary Method

IDocumentationProviderGetSummary Method

Returns the summary documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetSummary()
Function GetSummary As String

Return Value

Type: String
The summary documentation.
See Also

Reference

IDocumentationProvider Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider.GetTypeParameter Method

IDocumentationProviderGetTypeParameter Method

Returns the documentation for the type parameter with the specified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetTypeParameter(
    string name
)
Function GetTypeParameter (
    name As String
) As String

Parameters

name
Type: SystemString
The parameter name.

Return Value

Type: String
The documentation for the type parameter with the specified name.
See Also

Reference

IDocumentationProvider Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IExternalAliasDirective Interface

Provides the base requirements of an external alias directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IExternalAliasDirective
Public Interface IExternalAliasDirective

The IExternalAliasDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias that is defined by the directive.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IExternalAliasDirective Properties

The IExternalAliasDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias that is defined by the directive.
Top
See Also

Reference

IExternalAliasDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IExternalAliasDirective.Alias Property

IExternalAliasDirectiveAlias Property

Gets the alias that is defined by the directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Alias { get; }
ReadOnly Property Alias As String
    Get

Property Value

Type: String
The alias that is defined by the directive.
See Also

Reference

IExternalAliasDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration Interface

Provides the base requirements of a namespace declaration that encloses types declared in a source file.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface INamespaceDeclaration
Public Interface INamespaceDeclaration

The INamespaceDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AliasedUsingDirectives | Gets the collection of aliased using directives within the namespace declaration.
Public property | ExternalAliasDirectives | Gets the collection of external alias directives within the namespace declaration.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Name | Gets the name of the namespace.
Public property | Parent | Gets the INamespaceDeclaration that contains this namespace declaration.
Public property | UsingDirectives | Gets the collection of using directives within the namespace declaration.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration Properties

The INamespaceDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AliasedUsingDirectives | Gets the collection of aliased using directives within the namespace declaration.
Public property | ExternalAliasDirectives | Gets the collection of external alias directives within the namespace declaration.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Name | Gets the name of the namespace.
Public property | Parent | Gets the INamespaceDeclaration that contains this namespace declaration.
Public property | UsingDirectives | Gets the collection of using directives within the namespace declaration.
Top
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.AliasedUsingDirectives Property

INamespaceDeclarationAliasedUsingDirectives Property

Gets the collection of aliased using directives within the namespace declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IAliasedUsingDirective> AliasedUsingDirectives { get; }
ReadOnly Property AliasedUsingDirectives As IList(Of IAliasedUsingDirective)
    Get

Property Value

Type: IList IAliasedUsingDirective
The collection of aliased using directives within the namespace declaration.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.ExternalAliasDirectives Property

INamespaceDeclarationExternalAliasDirectives Property

Gets the collection of external alias directives within the namespace declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IExternalAliasDirective> ExternalAliasDirectives { get; }
ReadOnly Property ExternalAliasDirectives As IList(Of IExternalAliasDirective)
    Get

Property Value

Type: IList IExternalAliasDirective
The collection of external alias directives within the namespace declaration.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.FullName Property

INamespaceDeclarationFullName Property

Gets the full name of the namespace, which includes the names of ancestor namespaces.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the namespace, which includes the names of ancestor namespaces.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.Name Property

INamespaceDeclarationName Property

Gets the name of the namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the namespace.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.Parent Property

INamespaceDeclarationParent Property

Gets the INamespaceDeclaration that contains this namespace declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
INamespaceDeclaration Parent { get; }
ReadOnly Property Parent As INamespaceDeclaration
    Get

Property Value

Type: INamespaceDeclaration
The INamespaceDeclaration that contains this namespace declaration.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.UsingDirectives Property

INamespaceDeclarationUsingDirectives Property

Gets the collection of using directives within the namespace declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IUsingDirective> UsingDirectives { get; }
ReadOnly Property UsingDirectives As IList(Of IUsingDirective)
    Get

Property Value

Type: IList IUsingDirective
The collection of using directives within the namespace declaration.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition Interface

Provides the base requirements of a namespace that can contain types and other nested namespaces.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface INamespaceDefinition : IReflectionDefinition
Public Interface INamespaceDefinition
    Inherits IReflectionDefinition

The INamespaceDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of child INamespaceDefinition objects within this namespace.
Public property | ExtensionMethods | Gets the collection of extension methods that are contained in the namespace.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | StandardModules | Gets the collection of standard modules that are contained in the namespace.
Public property | Types | Gets the collection of ITypeDefinition objects within this namespace.
Top
Methods
 | Name | Description
Public method | ToTreeString | Outputs the contents of the namespace in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition Properties

The INamespaceDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of child INamespaceDefinition objects within this namespace.
Public property | ExtensionMethods | Gets the collection of extension methods that are contained in the namespace.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | StandardModules | Gets the collection of standard modules that are contained in the namespace.
Public property | Types | Gets the collection of ITypeDefinition objects within this namespace.
Top
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.Children Property

INamespaceDefinitionChildren Property

Gets the collection of child INamespaceDefinition objects within this namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
INamespaceDefinitionCollection Children { get; }
ReadOnly Property Children As INamespaceDefinitionCollection
    Get

Property Value

Type: INamespaceDefinitionCollection
The collection of child INamespaceDefinition objects within this namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.ExtensionMethods Property

INamespaceDefinitionExtensionMethods Property

Gets the collection of extension methods that are contained in the namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeMemberDefinitionCollection ExtensionMethods { get; }
ReadOnly Property ExtensionMethods As ITypeMemberDefinitionCollection
    Get

Property Value

Type: ITypeMemberDefinitionCollection
The collection of extension methods that are contained in the namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.FullName Property

INamespaceDefinitionFullName Property

Gets the full name of the namespace, which includes the names of ancestor namespaces.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the namespace, which includes the names of ancestor namespaces.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.StandardModules Property

INamespaceDefinitionStandardModules Property

Gets the collection of standard modules that are contained in the namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection StandardModules { get; }
ReadOnly Property StandardModules As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of standard modules that are contained in the namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.Types Property

INamespaceDefinitionTypes Property

Gets the collection of ITypeDefinition objects within this namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection Types { get; }
ReadOnly Property Types As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of ITypeDefinition objects within this namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition Methods

The INamespaceDefinition type exposes the following members.

Methods
 | Name | Description
Public method | ToTreeString | Outputs the contents of the namespace in tree form.
Top
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.ToTreeString Method

INamespaceDefinitionToTreeString Method

Outputs the contents of the namespace in tree form.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ToTreeString(
    int indentLevel
)
Function ToTreeString (
    indentLevel As Integer
) As String

Parameters

indentLevel
Type: SystemInt32
The indentation level.

Return Value

Type: String
A string containing the tree form of the namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection Interface

Provides the base requirements for a collection of INamespaceDefinition objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface INamespaceDefinitionCollection : IObservableCollection<INamespaceDefinition>,
    IList<INamespaceDefinition>, ICollection<INamespaceDefinition>, IEnumerable<INamespaceDefinition>,
    IEnumerable
Public Interface INamespaceDefinitionCollection
    Inherits IObservableCollection(Of INamespaceDefinition), IList(Of INamespaceDefinition),
    ICollection(Of INamespaceDefinition), IEnumerable(Of INamespaceDefinition), IEnumerable

The INamespaceDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection INamespaceDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection INamespaceDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList INamespaceDefinition .)
Public property | ItemString, Boolean | Gets the INamespaceDefinition with the specified name. [C#] In C#, this property is the indexer for the INamespaceDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection INamespaceDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection INamespaceDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection INamespaceDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection INamespaceDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable INamespaceDefinition .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList INamespaceDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList INamespaceDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection INamespaceDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList INamespaceDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeINamespaceDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeINamespaceDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllINamespaceDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection Properties

The INamespaceDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection INamespaceDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection INamespaceDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList INamespaceDefinition .)
Public property | ItemString, Boolean | Gets the INamespaceDefinition with the specified name. [C#] In C#, this property is the indexer for the INamespaceDefinitionCollection interface.
Top
See Also

Reference

INamespaceDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection.Item Property

INamespaceDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList INamespaceDefinition .)
Public property | ItemString, Boolean | Gets the INamespaceDefinition with the specified name. [C#] In C#, this property is the indexer for the INamespaceDefinitionCollection interface.
Top
See Also

Reference

INamespaceDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection.Item Property (String, Boolean)

INamespaceDefinitionCollectionItem Property (String, Boolean)

Gets the INamespaceDefinition with the specified name.

[C#] In C#, this property is the indexer for the INamespaceDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
INamespaceDefinition this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Default Property Item (
    name As String,
    caseSensitive As Boolean
) As INamespaceDefinition
    Get

Parameters

name
Type: SystemString
The name of the INamespaceDefinition to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: INamespaceDefinition
The INamespaceDefinition with the specified name.
See Also

Reference

INamespaceDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection Methods

The INamespaceDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection INamespaceDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection INamespaceDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection INamespaceDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection INamespaceDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable INamespaceDefinition .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList INamespaceDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList INamespaceDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection INamespaceDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList INamespaceDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeINamespaceDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeINamespaceDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllINamespaceDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

INamespaceDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection Events

The INamespaceDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

INamespaceDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition Interface

Provides the base requirements of a parameter definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParameterDefinition : IReflectionDefinition
Public Interface IParameterDefinition
    Inherits IReflectionDefinition

The IParameterDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringMember | Gets the type member that declares the current parameter.
Public property | IsByReference | Gets whether this is a pass by-reference parameter.
Public property | IsDynamicType | Gets whether the parameter type is a dynamic type.
Public property | IsExtension | Gets whether this is the first parameter to an extension method.
Public property | IsOptional | Gets whether this is an optional parameter.
Public property | IsOutput | Gets whether this is an output parameter.
Public property | IsParameterArray | Gets whether this is a parameter array.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets an ITypeReference for the parameter type.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition Properties

The IParameterDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringMember | Gets the type member that declares the current parameter.
Public property | IsByReference | Gets whether this is a pass by-reference parameter.
Public property | IsDynamicType | Gets whether the parameter type is a dynamic type.
Public property | IsExtension | Gets whether this is the first parameter to an extension method.
Public property | IsOptional | Gets whether this is an optional parameter.
Public property | IsOutput | Gets whether this is an output parameter.
Public property | IsParameterArray | Gets whether this is a parameter array.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets an ITypeReference for the parameter type.
Top
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.DeclaringMember Property

IParameterDefinitionDeclaringMember Property

Gets the type member that declares the current parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeMemberDefinition DeclaringMember { get; }
ReadOnly Property DeclaringMember As ITypeMemberDefinition
    Get

Property Value

Type: ITypeMemberDefinition
An ITypeMemberDefinition object representing the type member that declares the current parameter.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsByReference Property

IParameterDefinitionIsByReference Property

Gets whether this is a pass by-reference parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsByReference { get; }
ReadOnly Property IsByReference As Boolean
    Get

Property Value

Type: Boolean
true if this is a pass by-reference parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsDynamicType Property

IParameterDefinitionIsDynamicType Property

Gets whether the parameter type is a dynamic type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsDynamicType { get; }
ReadOnly Property IsDynamicType As Boolean
    Get

Property Value

Type: Boolean
true if the parameter type is a dynamic type; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsExtension Property

IParameterDefinitionIsExtension Property

Gets whether this is the first parameter to an extension method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsExtension { get; }
ReadOnly Property IsExtension As Boolean
    Get

Property Value

Type: Boolean
true if this is the first parameter to an extension method; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsOptional Property

IParameterDefinitionIsOptional Property

Gets whether this is an optional parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsOptional { get; }
ReadOnly Property IsOptional As Boolean
    Get

Property Value

Type: Boolean
true if this is an optional parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsOutput Property

IParameterDefinitionIsOutput Property

Gets whether this is an output parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsOutput { get; }
ReadOnly Property IsOutput As Boolean
    Get

Property Value

Type: Boolean
true if this is an output parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsParameterArray Property

IParameterDefinitionIsParameterArray Property

Gets whether this is a parameter array.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsParameterArray { get; }
ReadOnly Property IsParameterArray As Boolean
    Get

Property Value

Type: Boolean
true if this is a parameter array; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.Type Property

IParameterDefinitionType Property

Gets an ITypeReference for the parameter type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReference Type { get; }
ReadOnly Property Type As ITypeReference
    Get

Property Value

Type: ITypeReference
An ITypeReference for the parameter type.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection Interface

Provides the base requirements for a collection of IParameterDefinition objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParameterDefinitionCollection : IObservableCollection<IParameterDefinition>,
    IList<IParameterDefinition>, ICollection<IParameterDefinition>, IEnumerable<IParameterDefinition>,
    IEnumerable
Public Interface IParameterDefinitionCollection
    Inherits IObservableCollection(Of IParameterDefinition), IList(Of IParameterDefinition),
    ICollection(Of IParameterDefinition), IEnumerable(Of IParameterDefinition), IEnumerable

The IParameterDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IParameterDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IParameterDefinition .)
Public property | ItemString, Boolean | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IParameterDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IParameterDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IParameterDefinition .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IParameterDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IParameterDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IParameterDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIParameterDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIParameterDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIParameterDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection Properties

The IParameterDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IParameterDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IParameterDefinition .)
Public property | ItemString, Boolean | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection.Item Property

IParameterDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IParameterDefinition .)
Public property | ItemString, Boolean | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection.Item Property (String, Boolean)

IParameterDefinitionCollectionItem Property (String, Boolean)

Gets the IParameterDefinition with the specified name.

[C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParameterDefinition this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Default Property Item (
    name As String,
    caseSensitive As Boolean
) As IParameterDefinition
    Get

Parameters

name
Type: SystemString
The name of the IParameterDefinition to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: IParameterDefinition
The IParameterDefinition with the specified name.
See Also

Reference

IParameterDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection Methods

The IParameterDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IParameterDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IParameterDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IParameterDefinition .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IParameterDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IParameterDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IParameterDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIParameterDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIParameterDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIParameterDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection Events

The IParameterDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly Interface

Provides the base requirements of a project (source code-based) assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IProjectAssembly : IAssembly
Public Interface IProjectAssembly
    Inherits IAssembly

The IProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from IAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from IAssembly.)
Public property | Name | Gets the simple name of the assembly. (Inherited from IAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from IAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly.
Public property | SourceFiles | Gets the collection of source files in this project assembly.
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from IAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from IAssembly.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly Properties

The IProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from IAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from IAssembly.)
Public property | Name | Gets the simple name of the assembly. (Inherited from IAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from IAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly.
Public property | SourceFiles | Gets the collection of source files in this project assembly.
Top
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly.AssemblyReferences Property

IProjectAssemblyAssemblyReferences Property

Gets the collection of assembly references for this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssemblyReferenceCollection AssemblyReferences { get; }
ReadOnly Property AssemblyReferences As IProjectAssemblyReferenceCollection
    Get

Property Value

Type: IProjectAssemblyReferenceCollection
The collection of assembly references for this assembly.
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly.Resolver Property

IProjectAssemblyResolver Property

Gets the IResolver to use for this project assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IResolver Resolver { get; }
ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project assembly.
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly.SourceFiles Property

IProjectAssemblySourceFiles Property

Gets the collection of source files in this project assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISourceFileCollection SourceFiles { get; }
ReadOnly Property SourceFiles As ISourceFileCollection
    Get

Property Value

Type: ISourceFileCollection
The collection of source files in this project assembly.
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly Methods

The IProjectAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from IAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from IAssembly.)
Top
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReference Interface

Provides the base requirements of an assembly reference within an IProjectAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IProjectAssemblyReference : IAssemblyReference
Public Interface IProjectAssemblyReference
    Inherits IAssemblyReference

The IProjectAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets the IAssembly that is referenced.
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information. (Inherited from IAssemblyReference.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReference Properties

The IProjectAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets the IAssembly that is referenced.
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information. (Inherited from IAssemblyReference.)
Top
See Also

Reference

IProjectAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReference.Assembly Property

IProjectAssemblyReferenceAssembly Property

Gets the IAssembly that is referenced.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAssembly Assembly { get; }
ReadOnly Property Assembly As IAssembly
    Get

Property Value

Type: IAssembly
The IAssembly that is referenced.
See Also

Reference

IProjectAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection Interface

Provides the base requirements for a collection of IProjectAssemblyReference objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IProjectAssemblyReferenceCollection : IObservableCollection<IProjectAssemblyReference>,
    IList<IProjectAssemblyReference>, ICollection<IProjectAssemblyReference>, IEnumerable<IProjectAssemblyReference>,
    IEnumerable
Public Interface IProjectAssemblyReferenceCollection
    Inherits IObservableCollection(Of IProjectAssemblyReference), IList(Of IProjectAssemblyReference),
    ICollection(Of IProjectAssemblyReference), IEnumerable(Of IProjectAssemblyReference), IEnumerable

The IProjectAssemblyReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IProjectAssemblyReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IProjectAssemblyReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IProjectAssemblyReference .)
Public property | ItemString | Gets the IProjectAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Public property | ItemIAssemblyName | Gets the IProjectAssemblyReference for the assembly with the specified name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Top
Methods
 | Name | Description
Public method | Add(Assembly) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.
Public method | Add(String) | Adds a new reference to an IBinaryAssembly for the specified assembly name.
Public method | Add(IAssembly) | Adds a new reference for the specified IAssembly.
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection IProjectAssemblyReference .)
Public method | Add(Assembly, IAssemblyName) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.
Public method | AddAllInAppDomain | Adds new references to IBinaryAssembly objects for all assemblies currently loaded in the AppDomain.
Public method | AddFrom | Adds a new reference to an IBinaryAssembly for the assembly at the specified path.
Public method | AddMsCorLib | Adds a new reference to an IBinaryAssembly for mscorlib.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IProjectAssemblyReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IProjectAssemblyReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IProjectAssemblyReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IProjectAssemblyReference .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IProjectAssemblyReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IProjectAssemblyReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IProjectAssemblyReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IProjectAssemblyReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIProjectAssemblyReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIProjectAssemblyReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIProjectAssemblyReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection Properties

The IProjectAssemblyReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IProjectAssemblyReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IProjectAssemblyReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IProjectAssemblyReference .)
Public property | ItemString | Gets the IProjectAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Public property | ItemIAssemblyName | Gets the IProjectAssemblyReference for the assembly with the specified name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Item Property

IProjectAssemblyReferenceCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IProjectAssemblyReference .)
Public property | ItemString | Gets the IProjectAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Public property | ItemIAssemblyName | Gets the IProjectAssemblyReference for the assembly with the specified name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Item Property (String)

IProjectAssemblyReferenceCollectionItem Property (String)

Gets the IProjectAssemblyReference for the assembly with the specified full name.

[C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssemblyReference this[
    string fullName
] { get; }
ReadOnly Default Property Item (
    fullName As String
) As IProjectAssemblyReference
    Get

Parameters

fullName
Type: SystemString
The full name of the IProjectAssemblyReference to return.

Property Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference for the assembly with the specified full name.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Item Property (IAssemblyName)

IProjectAssemblyReferenceCollectionItem Property (IAssemblyName)

Gets the IProjectAssemblyReference for the assembly with the specified name.

[C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssemblyReference this[
    IAssemblyName assemblyName
] { get; }
ReadOnly Default Property Item (
    assemblyName As IAssemblyName
) As IProjectAssemblyReference
    Get

Parameters

assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName of the assembly to return.

Property Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference for the assembly with the specified name.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection Methods

The IProjectAssemblyReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(Assembly) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.
Public method | Add(String) | Adds a new reference to an IBinaryAssembly for the specified assembly name.
Public method | Add(IAssembly) | Adds a new reference for the specified IAssembly.
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection IProjectAssemblyReference .)
Public method | Add(Assembly, IAssemblyName) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.
Public method | AddAllInAppDomain | Adds new references to IBinaryAssembly objects for all assemblies currently loaded in the AppDomain.
Public method | AddFrom | Adds a new reference to an IBinaryAssembly for the assembly at the specified path.
Public method | AddMsCorLib | Adds a new reference to an IBinaryAssembly for mscorlib.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IProjectAssemblyReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IProjectAssemblyReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IProjectAssemblyReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IProjectAssemblyReference .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IProjectAssemblyReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IProjectAssemblyReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IProjectAssemblyReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IProjectAssemblyReference .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIProjectAssemblyReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIProjectAssemblyReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIProjectAssemblyReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Add Method

IProjectAssemblyReferenceCollectionAdd Method

Overload List
 | Name | Description
Public method | Add(Assembly) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.
Public method | Add(String) | Adds a new reference to an IBinaryAssembly for the specified assembly name.
Public method | Add(IAssembly) | Adds a new reference for the specified IAssembly.
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection IProjectAssemblyReference .)
Public method | Add(Assembly, IAssemblyName) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Add Method (Assembly)

IProjectAssemblyReferenceCollectionAdd Method (Assembly)

Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssemblyReference Add(
    Assembly assembly
)
Function Add (
    assembly As Assembly
) As IProjectAssemblyReference

Parameters

assembly
Type: System.ReflectionAssembly
The reflection Assembly to reference.

Return Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference that was created.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
Add Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Add Method (String)

IProjectAssemblyReferenceCollectionAdd Method (String)

Adds a new reference to an IBinaryAssembly for the specified assembly name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssemblyReference Add(
    string fullName
)
Function Add (
    fullName As String
) As IProjectAssemblyReference

Parameters

fullName
Type: SystemString
The full name of the assembly to reference.

Return Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference that was created.
Remarks
While using the simple assembly name may work in some simple cases (such as System), it is highly recommended to pass the fully-qualified assembly name to this method (such as System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089) since the probing code will have a better chance of successfully finding it.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
Add Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Add Method (IAssembly)

IProjectAssemblyReferenceCollectionAdd Method (IAssembly)

Adds a new reference for the specified IAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssemblyReference Add(
    IAssembly assembly
)
Function Add (
    assembly As IAssembly
) As IProjectAssemblyReference

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssembly
The IAssembly to reference.

Return Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference that was created.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
Add Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Add Method (Assembly, IAssemblyName)

IProjectAssemblyReferenceCollectionAdd Method (Assembly, IAssemblyName)

Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssemblyReference Add(
    Assembly assembly,
    IAssemblyName assemblyName
)
Function Add (
    assembly As Assembly,
    assemblyName As IAssemblyName
) As IProjectAssemblyReference

Parameters

assembly
Type: System.ReflectionAssembly
The reflection Assembly to reference.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The alternate IAssemblyName to use.

Return Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference that was created.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
Add Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.AddAllInAppDomain Method

IProjectAssemblyReferenceCollectionAddAllInAppDomain Method

Adds new references to IBinaryAssembly objects for all assemblies currently loaded in the AppDomain.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<IProjectAssemblyReference> AddAllInAppDomain()
Function AddAllInAppDomain As IEnumerable(Of IProjectAssemblyReference)

Return Value

Type: IEnumerable IProjectAssemblyReference
The collection of IProjectAssemblyReference objects that were created.
Remarks
This method is only recommended for testing purposes since a properly-designed application should pick and choose which exact assembly references to have on a project assembly.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.AddFrom Method

IProjectAssemblyReferenceCollectionAddFrom Method

Adds a new reference to an IBinaryAssembly for the assembly at the specified path.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssemblyReference AddFrom(
    string path
)
Function AddFrom (
    path As String
) As IProjectAssemblyReference

Parameters

path
Type: SystemString
The path to the Assembly file to reference.

Return Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference that was created.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.AddMsCorLib Method

IProjectAssemblyReferenceCollectionAddMsCorLib Method

Adds a new reference to an IBinaryAssembly for mscorlib.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProjectAssemblyReference AddMsCorLib()
Function AddMsCorLib As IProjectAssemblyReference

Return Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference that was created.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection Events

The IProjectAssemblyReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName Interface

Provides the base requirements of a qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IQualifiedName
Public Interface IQualifiedName

The IQualifiedName type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the optional alias that indicates the root of the qualified name.
Public property | ArrayRankSpecifiers | Gets the collection of array rank specifiers.
Public property | HasArrayRankSpecifiers | Gets whether the qualified name has at least one array rank specifier.
Public property | HasIdentifiers | Gets whether the qualified name has at least one identifier.
Public property | Identifiers | Gets the collection of identifiers for the qualified name.
Public property | IsGlobal | Gets whether the qualified name is rooted at the default global namespace.
Public property | PointerLevel | Gets the pointer level.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName Properties

The IQualifiedName type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the optional alias that indicates the root of the qualified name.
Public property | ArrayRankSpecifiers | Gets the collection of array rank specifiers.
Public property | HasArrayRankSpecifiers | Gets whether the qualified name has at least one array rank specifier.
Public property | HasIdentifiers | Gets whether the qualified name has at least one identifier.
Public property | Identifiers | Gets the collection of identifiers for the qualified name.
Public property | IsGlobal | Gets whether the qualified name is rooted at the default global namespace.
Public property | PointerLevel | Gets the pointer level.
Top
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.Alias Property

IQualifiedNameAlias Property

Gets the optional alias that indicates the root of the qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Alias { get; }
ReadOnly Property Alias As String
    Get

Property Value

Type: String
The optional alias that indicates the root of the qualified name.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.ArrayRankSpecifiers Property

IQualifiedNameArrayRankSpecifiers Property

Gets the collection of array rank specifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<int> ArrayRankSpecifiers { get; }
ReadOnly Property ArrayRankSpecifiers As IList(Of Integer)
    Get

Property Value

Type: IList Int32
The collection of array rank specifiers.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.HasArrayRankSpecifiers Property

IQualifiedNameHasArrayRankSpecifiers Property

Gets whether the qualified name has at least one array rank specifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasArrayRankSpecifiers { get; }
ReadOnly Property HasArrayRankSpecifiers As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name has at least one array rank specifier; otherwise, false.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.HasIdentifiers Property

IQualifiedNameHasIdentifiers Property

Gets whether the qualified name has at least one identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasIdentifiers { get; }
ReadOnly Property HasIdentifiers As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name has at least one identifier; otherwise, false.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.Identifiers Property

IQualifiedNameIdentifiers Property

Gets the collection of identifiers for the qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<ISimpleName> Identifiers { get; }
ReadOnly Property Identifiers As IList(Of ISimpleName)
    Get

Property Value

Type: IList ISimpleName
The collection of identifiers for the qualified name.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.IsGlobal Property

IQualifiedNameIsGlobal Property

Gets whether the qualified name is rooted at the default global namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsGlobal { get; }
ReadOnly Property IsGlobal As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name is rooted at the default global namespace; otherwise, false.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.PointerLevel Property

IQualifiedNamePointerLevel Property

Gets the pointer level.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int PointerLevel { get; }
ReadOnly Property PointerLevel As Integer
    Get

Property Value

Type: Int32
The pointer level.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName Methods

The IQualifiedName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Top
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.Clone Method

IQualifiedNameClone Method

Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IQualifiedName Clone()
Function Clone As IQualifiedName

Return Value

Type: IQualifiedName
The object that was created.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IReflectionDefinition Interface

Provides the base requirements of a reflection definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IReflectionDefinition
Public Interface IReflectionDefinition

The IReflectionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IReflectionDefinition Properties

The IReflectionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name.
Top
See Also

Reference

IReflectionDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IReflectionDefinition.Name Property

IReflectionDefinitionName Property

Gets the definition's name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The definition's name.
See Also

Reference

IReflectionDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName Interface

Provides the base requirements of a simple name with optional type arguments, which is a component of an IQualifiedName.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISimpleName
Public Interface ISimpleName

The ISimpleName type exposes the following members.

Properties
 | Name | Description
Public property | HasTypeArguments | Gets whether the identifier has at least one type argument.
Public property | Text | Gets the text value of the identifier.
Public property | TypeArguments | Gets the collection of optional generic type arguments for the identifier.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName Properties

The ISimpleName type exposes the following members.

Properties
 | Name | Description
Public property | HasTypeArguments | Gets whether the identifier has at least one type argument.
Public property | Text | Gets the text value of the identifier.
Public property | TypeArguments | Gets the collection of optional generic type arguments for the identifier.
Top
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName.HasTypeArguments Property

ISimpleNameHasTypeArguments Property

Gets whether the identifier has at least one type argument.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasTypeArguments { get; }
ReadOnly Property HasTypeArguments As Boolean
    Get

Property Value

Type: Boolean
true if the identifier has at least one type argument; otherwise, false.
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName.Text Property

ISimpleNameText Property

Gets the text value of the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The text value of the identifier.
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName.TypeArguments Property

ISimpleNameTypeArguments Property

Gets the collection of optional generic type arguments for the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IQualifiedName> TypeArguments { get; }
ReadOnly Property TypeArguments As IList(Of IQualifiedName)
    Get

Property Value

Type: IList IQualifiedName
The collection of optional generic type arguments for the identifier.
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName Methods

The ISimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Top
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName.Clone Method

ISimpleNameClone Method

Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISimpleName Clone()
Function Clone As ISimpleName

Return Value

Type: ISimpleName
The object that was created.
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFile Interface

Provides the base requirements of a source code file that can be loaded by an IProjectAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISourceFile : IKeyedObject
Public Interface ISourceFile
    Inherits IKeyedObject

The ISourceFile type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | TypeDefinitions | Gets the collection of ITypeDefinition objects contained in the source file.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFile Properties

The ISourceFile type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | TypeDefinitions | Gets the collection of ITypeDefinition objects contained in the source file.
Top
See Also

Reference

ISourceFile Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFile.TypeDefinitions Property

ISourceFileTypeDefinitions Property

Gets the collection of ITypeDefinition objects contained in the source file.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection TypeDefinitions { get; }
ReadOnly Property TypeDefinitions As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of ITypeDefinition objects contained in the source file.
See Also

Reference

ISourceFile Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection Interface

Provides the base requirements for a collection of ISourceFile objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISourceFileCollection : IEnumerable,
    IKeyedObservableCollection<ISourceFile>, IObservableCollection<ISourceFile>, IList<ISourceFile>,
    ICollection<ISourceFile>, IEnumerable<ISourceFile>
Public Interface ISourceFileCollection
    Inherits IEnumerable, IKeyedObservableCollection(Of ISourceFile), IObservableCollection(Of ISourceFile),
    IList(Of ISourceFile), ICollection(Of ISourceFile), IEnumerable(Of ISourceFile)

The ISourceFileCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ISourceFile .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ISourceFile .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ISourceFile .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection ISourceFile .)
Public method | Add(String, CompilationUnit) | Adds an ISourceFile for the specified CompilationUnit to the collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ISourceFile .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISourceFile .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISourceFile .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList ISourceFile .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ISourceFile .)
Public method | QueueCode | Queues parsing for the specified source code, and adds an ISourceFile for the result.
Public method | QueueFile | Queues parsing for the specified file, and adds an ISourceFile for the result.
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISourceFile .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ISourceFile .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISourceFile | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISourceFile | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISourceFile | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection Properties

The ISourceFileCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ISourceFile .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ISourceFile .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ISourceFile .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection Methods

The ISourceFileCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection ISourceFile .)
Public method | Add(String, CompilationUnit) | Adds an ISourceFile for the specified CompilationUnit to the collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ISourceFile .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISourceFile .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISourceFile .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList ISourceFile .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ISourceFile .)
Public method | QueueCode | Queues parsing for the specified source code, and adds an ISourceFile for the result.
Public method | QueueFile | Queues parsing for the specified file, and adds an ISourceFile for the result.
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISourceFile .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ISourceFile .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISourceFile | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISourceFile | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISourceFile | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection.Add Method

ISourceFileCollectionAdd Method

Overload List
 | Name | Description
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection ISourceFile .)
Public method | Add(String, CompilationUnit) | Adds an ISourceFile for the specified CompilationUnit to the collection.
Top
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection.Add Method (String, CompilationUnit)

ISourceFileCollectionAdd Method (String, CompilationUnit)

Adds an ISourceFile for the specified CompilationUnit to the collection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISourceFile Add(
    string sourceFileKey,
    CompilationUnit compilationUnit
)
Function Add (
    sourceFileKey As String,
    compilationUnit As CompilationUnit
) As ISourceFile

Parameters

sourceFileKey
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
compilationUnit
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnit
The CompilationUnit to examine.

Return Value

Type: ISourceFile
The ISourceFile that was added.
See Also

Reference

ISourceFileCollection Interface
Add Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection.QueueCode Method

ISourceFileCollectionQueueCode Method

Queues parsing for the specified source code, and adds an ISourceFile for the result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void QueueCode(
    ISyntaxLanguage language,
    string sourceFileKey,
    string text
)
Sub QueueCode (
    language As ISyntaxLanguage,
    sourceFileKey As String,
    text As String
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage containing an IParser service that will be used to parse the source code.
sourceFileKey
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
text
Type: SystemString
A string containing the source code to parse.
Remarks
The parsing operation will occur in a worker thread and will not block the calling thread as long as an Dispatcher has been configured.
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection.QueueFile Method

ISourceFileCollectionQueueFile Method

Queues parsing for the specified file, and adds an ISourceFile for the result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void QueueFile(
    ISyntaxLanguage language,
    string path
)
Sub QueueFile (
    language As ISyntaxLanguage,
    path As String
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage containing an IParser service that will be used to parse the file.
path
Type: SystemString
The absolute path of the file to load.
Remarks
The parsing operation will occur in a worker thread and will not block the calling thread as long as an Dispatcher has been configured.
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection Events

The ISourceFileCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileLocation Interface

Provides the base requirements of a source code file reference and related offsets within that file, generally used to denote where a type/member was defined.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISourceFileLocation : IKeyedObject
Public Interface ISourceFileLocation
    Inherits IKeyedObject

The ISourceFileLocation type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | NavigationOffset | Gets the optional offset within the source code file where navigations to the definition should occur, generally the start of the type/member name.
Public property | TextRange | Gets the offset range within the source code file of the type/member definition.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileLocation Properties

The ISourceFileLocation type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | NavigationOffset | Gets the optional offset within the source code file where navigations to the definition should occur, generally the start of the type/member name.
Public property | TextRange | Gets the offset range within the source code file of the type/member definition.
Top
See Also

Reference

ISourceFileLocation Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileLocation.NavigationOffset Property

ISourceFileLocationNavigationOffset Property

Gets the optional offset within the source code file where navigations to the definition should occur, generally the start of the type/member name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<int> NavigationOffset { get; }
ReadOnly Property NavigationOffset As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The optional offset within the source code file where navigations to the definition should occur, generally the start of the type/member name.
See Also

Reference

ISourceFileLocation Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileLocation.TextRange Property

ISourceFileLocationTextRange Property

Gets the offset range within the source code file of the type/member definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange TextRange { get; }
ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
The offset range within the source code file of the type/member definition.
See Also

Reference

ISourceFileLocation Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileLocationCollection Interface

Provides the base requirements for a collection of ISourceFileLocation objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISourceFileLocationCollection : IEnumerable,
    IObservableCollection<ISourceFileLocation>, IList<ISourceFileLocation>, ICollection<ISourceFileLocation>,
    IEnumerable<ISourceFileLocation>
Public Interface ISourceFileLocationCollection
    Inherits IEnumerable, IObservableCollection(Of ISourceFileLocation), IList(Of ISourceFileLocation),
    ICollection(Of ISourceFileLocation), IEnumerable(Of ISourceFileLocation)

The ISourceFileLocationCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ISourceFileLocation .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ISourceFileLocation .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList ISourceFileLocation .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ISourceFileLocation .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ISourceFileLocation .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISourceFileLocation .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISourceFileLocation .)
Public method | Encloses | Returns whether any source file location encloses the specified location.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ISourceFileLocation .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ISourceFileLocation .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISourceFileLocation .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ISourceFileLocation .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISourceFileLocation | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISourceFileLocation | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISourceFileLocation | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileLocationCollection Properties

The ISourceFileLocationCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ISourceFileLocation .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ISourceFileLocation .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList ISourceFileLocation .)
Top
See Also

Reference

ISourceFileLocationCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileLocationCollection Methods

The ISourceFileLocationCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ISourceFileLocation .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ISourceFileLocation .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISourceFileLocation .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISourceFileLocation .)
Public method | Encloses | Returns whether any source file location encloses the specified location.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ISourceFileLocation .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ISourceFileLocation .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISourceFileLocation .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ISourceFileLocation .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISourceFileLocation | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISourceFileLocation | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISourceFileLocation | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ISourceFileLocationCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileLocationCollection.Encloses Method

ISourceFileLocationCollectionEncloses Method

Returns whether any source file location encloses the specified location.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Encloses(
    ISourceFileLocation location
)
Function Encloses (
    location As ISourceFileLocation
) As Boolean

Parameters

location
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionISourceFileLocation
The ISourceFileLocation to examine.

Return Value

Type: Boolean
true if any source file location encloses the specified location; otherwise, false.
See Also

Reference

ISourceFileLocationCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileLocationCollection Events

The ISourceFileLocationCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ISourceFileLocationCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition Interface

Provides the base requirements of a type definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeDefinition : IReflectionDefinition,
    ITypeReference
Public Interface ITypeDefinition
    Inherits IReflectionDefinition, ITypeReference

The ITypeDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeAccess indicating the current type's access visibility.
Public property | ArrayRank | Gets the number of dimensions in the current type, if the type is an array.
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known. (Inherited from ITypeReference.)
Public property | BaseTypes | Gets the collection of base types inherited/implemented by the current type.
Public property | DeclaringType | Gets the type that declares the current type, if it is nested.
Public property | DocumentationComment | Gets the optional documentation comment, if the current type is defined in source code.
Public property | ElementType | Gets the type of the object encompassed or referred to by the current array, pointer or reference type.
Public property | FullName | Gets the fully qualified name of the type, including the namespace of the type but not the assembly.
Public property | IsAbstract | Gets whether the current type is abstract and must be overridden.
Public property | IsAdvanced | Gets whether the current type is decorated such that it should only be visible to advanced users within an editor.
Public property | IsAnonymous | Gets whether the current type is an anonymous type.
Public property | IsArray | Gets whether the current type is an array.
Public property | IsByReference | Gets whether the current type is passed by reference.
Public property | IsExtension | Gets whether the current type is decorated as a static class that can contain extension methods.
Public property | IsGenericType | Gets whether the current type is a generic type. (Inherited from ITypeReference.)
Public property | IsGenericTypeDefinition | Gets whether the current type is a generic type definition, from which other generic types can be constructed.
Public property | IsHidden | Gets whether the current type is decorated such that it should never be visible within an editor.
Public property | IsNested | Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type.
Public property | IsObsolete | Gets whether the current type is decorated as obsolete.
Public property | IsPointer | Gets whether the current type is a pointer.
Public property | IsSealed | Gets whether the current type is declared sealed.
Public property | IsStandardModule | Gets whether the current type is decorated as a standard module class.
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed. (Inherited from ITypeReference.)
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter. (Inherited from ITypeReference.)
Public property | Kind | Gets a TypeDefinitionKind that indicates the kind of type definition.
Public property | Members | Gets the collection of members that are defined within the current type.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Namespace | Gets the namespace of the type.
Public property | NestedTypes | Gets the collection of nested types that are defined within the current type.
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type. (Inherited from ITypeReference.)
Public property | SourceFileLocations | Gets the collection of source file locations that contain the current type's declarations.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type. (Inherited from ITypeReference.)
Public property | TypeParameters | Gets the collection of generic type parameters, when the current type is a generic type definition.
Top
Methods
 | Name | Description
Public method | GetNamespaceDeclaration | Returns the INamespaceDeclaration that declared the current type, if the type came from a parsed source file.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition Properties

The ITypeDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeAccess indicating the current type's access visibility.
Public property | ArrayRank | Gets the number of dimensions in the current type, if the type is an array.
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known. (Inherited from ITypeReference.)
Public property | BaseTypes | Gets the collection of base types inherited/implemented by the current type.
Public property | DeclaringType | Gets the type that declares the current type, if it is nested.
Public property | DocumentationComment | Gets the optional documentation comment, if the current type is defined in source code.
Public property | ElementType | Gets the type of the object encompassed or referred to by the current array, pointer or reference type.
Public property | FullName | Gets the fully qualified name of the type, including the namespace of the type but not the assembly.
Public property | IsAbstract | Gets whether the current type is abstract and must be overridden.
Public property | IsAdvanced | Gets whether the current type is decorated such that it should only be visible to advanced users within an editor.
Public property | IsAnonymous | Gets whether the current type is an anonymous type.
Public property | IsArray | Gets whether the current type is an array.
Public property | IsByReference | Gets whether the current type is passed by reference.
Public property | IsExtension | Gets whether the current type is decorated as a static class that can contain extension methods.
Public property | IsGenericType | Gets whether the current type is a generic type. (Inherited from ITypeReference.)
Public property | IsGenericTypeDefinition | Gets whether the current type is a generic type definition, from which other generic types can be constructed.
Public property | IsHidden | Gets whether the current type is decorated such that it should never be visible within an editor.
Public property | IsNested | Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type.
Public property | IsObsolete | Gets whether the current type is decorated as obsolete.
Public property | IsPointer | Gets whether the current type is a pointer.
Public property | IsSealed | Gets whether the current type is declared sealed.
Public property | IsStandardModule | Gets whether the current type is decorated as a standard module class.
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed. (Inherited from ITypeReference.)
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter. (Inherited from ITypeReference.)
Public property | Kind | Gets a TypeDefinitionKind that indicates the kind of type definition.
Public property | Members | Gets the collection of members that are defined within the current type.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Namespace | Gets the namespace of the type.
Public property | NestedTypes | Gets the collection of nested types that are defined within the current type.
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type. (Inherited from ITypeReference.)
Public property | SourceFileLocations | Gets the collection of source file locations that contain the current type's declarations.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type. (Inherited from ITypeReference.)
Public property | TypeParameters | Gets the collection of generic type parameters, when the current type is a generic type definition.
Top
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.Access Property

ITypeDefinitionAccess Property

Gets a TypeAccess indicating the current type's access visibility.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TypeAccess Access { get; }
ReadOnly Property Access As TypeAccess
    Get

Property Value

Type: TypeAccess
A TypeAccess indicating the current type's access visibility.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.ArrayRank Property

ITypeDefinitionArrayRank Property

Gets the number of dimensions in the current type, if the type is an array.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int ArrayRank { get; }
ReadOnly Property ArrayRank As Integer
    Get

Property Value

Type: Int32
The number of dimensions in the current type, if the type is an array.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.BaseTypes Property

ITypeDefinitionBaseTypes Property

Gets the collection of base types inherited/implemented by the current type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReferenceCollection BaseTypes { get; }
ReadOnly Property BaseTypes As ITypeReferenceCollection
    Get

Property Value

Type: ITypeReferenceCollection
The collection of base types inherited/implemented by the current type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.DeclaringType Property

ITypeDefinitionDeclaringType Property

Gets the type that declares the current type, if it is nested.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition DeclaringType { get; }
ReadOnly Property DeclaringType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
An ITypeDefinition object representing the enclosing type, if the current type is a nested type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.DocumentationComment Property

ITypeDefinitionDocumentationComment Property

Gets the optional documentation comment, if the current type is defined in source code.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string DocumentationComment { get; }
ReadOnly Property DocumentationComment As String
    Get

Property Value

Type: String
The optional documentation comment, if the current type is defined in source code.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.ElementType Property

ITypeDefinitionElementType Property

Gets the type of the object encompassed or referred to by the current array, pointer or reference type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition ElementType { get; }
ReadOnly Property ElementType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
The type of the object encompassed or referred to by the current array, pointer, or reference type, or if the current type is not an array or a pointer, or is not passed by reference, or represents a generic type or a type parameter in the definition of a generic type or generic method.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.FullName Property

ITypeDefinitionFullName Property

Gets the fully qualified name of the type, including the namespace of the type but not the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The fully qualified name of the type, including the namespace of the type but not the assembly.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsAbstract Property

ITypeDefinitionIsAbstract Property

Gets whether the current type is abstract and must be overridden.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAbstract { get; }
ReadOnly Property IsAbstract As Boolean
    Get

Property Value

Type: Boolean
true if the current type is abstract and must be overridden; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsAdvanced Property

ITypeDefinitionIsAdvanced Property

Gets whether the current type is decorated such that it should only be visible to advanced users within an editor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAdvanced { get; }
ReadOnly Property IsAdvanced As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated such that it should only be visible to advanced users within an editor; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsAnonymous Property

ITypeDefinitionIsAnonymous Property

Gets whether the current type is an anonymous type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAnonymous { get; }
ReadOnly Property IsAnonymous As Boolean
    Get

Property Value

Type: Boolean
true if the current type is an anonymous type; otherwise, False.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsArray Property

ITypeDefinitionIsArray Property

Gets whether the current type is an array.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsArray { get; }
ReadOnly Property IsArray As Boolean
    Get

Property Value

Type: Boolean
true if the current type is an array; otherwise, False.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsByReference Property

ITypeDefinitionIsByReference Property

Gets whether the current type is passed by reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsByReference { get; }
ReadOnly Property IsByReference As Boolean
    Get

Property Value

Type: Boolean
true if the current type is passed by reference; otherwise, False.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsExtension Property

ITypeDefinitionIsExtension Property

Gets whether the current type is decorated as a static class that can contain extension methods.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsExtension { get; }
ReadOnly Property IsExtension As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated as a static class that can contain extension methods; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsGenericTypeDefinition Property

ITypeDefinitionIsGenericTypeDefinition Property

Gets whether the current type is a generic type definition, from which other generic types can be constructed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsGenericTypeDefinition { get; }
ReadOnly Property IsGenericTypeDefinition As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a generic type definition, from which other generic types can be constructed; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsHidden Property

ITypeDefinitionIsHidden Property

Gets whether the current type is decorated such that it should never be visible within an editor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsHidden { get; }
ReadOnly Property IsHidden As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated such that it should never be visible within an editor; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsNested Property

ITypeDefinitionIsNested Property

Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsNested { get; }
ReadOnly Property IsNested As Boolean
    Get

Property Value

Type: Boolean
true if the Type is nested inside another type; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsObsolete Property

ITypeDefinitionIsObsolete Property

Gets whether the current type is decorated as obsolete.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsObsolete { get; }
ReadOnly Property IsObsolete As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated as obsolete; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsPointer Property

ITypeDefinitionIsPointer Property

Gets whether the current type is a pointer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsPointer { get; }
ReadOnly Property IsPointer As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a pointer; otherwise, False.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsSealed Property

ITypeDefinitionIsSealed Property

Gets whether the current type is declared sealed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsSealed { get; }
ReadOnly Property IsSealed As Boolean
    Get

Property Value

Type: Boolean
true if the current type is declared sealed; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsStandardModule Property

ITypeDefinitionIsStandardModule Property

Gets whether the current type is decorated as a standard module class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsStandardModule { get; }
ReadOnly Property IsStandardModule As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated as a standard module class; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.Kind Property

ITypeDefinitionKind Property

Gets a TypeDefinitionKind that indicates the kind of type definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TypeDefinitionKind Kind { get; }
ReadOnly Property Kind As TypeDefinitionKind
    Get

Property Value

Type: TypeDefinitionKind
A TypeDefinitionKind that indicates the kind of type definition.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.Members Property

ITypeDefinitionMembers Property

Gets the collection of members that are defined within the current type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeMemberDefinitionCollection Members { get; }
ReadOnly Property Members As ITypeMemberDefinitionCollection
    Get

Property Value

Type: ITypeMemberDefinitionCollection
The collection of members that are defined within the current type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.Namespace Property

ITypeDefinitionNamespace Property

Gets the namespace of the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Namespace { get; }
ReadOnly Property Namespace As String
    Get

Property Value

Type: String
The namespace of the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.NestedTypes Property

ITypeDefinitionNestedTypes Property

Gets the collection of nested types that are defined within the current type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection NestedTypes { get; }
ReadOnly Property NestedTypes As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of nested types that are defined within the current type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.SourceFileLocations Property

ITypeDefinitionSourceFileLocations Property

Gets the collection of source file locations that contain the current type's declarations.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISourceFileLocationCollection SourceFileLocations { get; }
ReadOnly Property SourceFileLocations As ISourceFileLocationCollection
    Get

Property Value

Type: ISourceFileLocationCollection
The collection of source file locations that contain the current type's declarations.
Remarks
This property only knows source file locations for type definitions loaded from code.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.TypeParameters Property

ITypeDefinitionTypeParameters Property

Gets the collection of generic type parameters, when the current type is a generic type definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeParameterCollection TypeParameters { get; }
ReadOnly Property TypeParameters As ITypeParameterCollection
    Get

Property Value

Type: ITypeParameterCollection
The collection of generic type parameters, when the current type is a generic type definition.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition Methods

The ITypeDefinition type exposes the following members.

Methods
 | Name | Description
Public method | GetNamespaceDeclaration | Returns the INamespaceDeclaration that declared the current type, if the type came from a parsed source file.
Top
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.GetNamespaceDeclaration Method

ITypeDefinitionGetNamespaceDeclaration Method

Returns the INamespaceDeclaration that declared the current type, if the type came from a parsed source file.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
INamespaceDeclaration GetNamespaceDeclaration(
    ISourceFileLocation location
)
Function GetNamespaceDeclaration (
    location As ISourceFileLocation
) As INamespaceDeclaration

Parameters

location
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionISourceFileLocation
The optional ISourceFileLocation that provides contextual information, used when this is a merged type definition to select the most appropriate namespace declaration result.

Return Value

Type: INamespaceDeclaration
The INamespaceDeclaration that declared the current type, if the type came from a parsed source file.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection Interface

Provides the base requirements for a collection of ITypeDefinition objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeDefinitionCollection : IEnumerable,
    IObservableCollection<ITypeDefinition>, IList<ITypeDefinition>, ICollection<ITypeDefinition>,
    IEnumerable<ITypeDefinition>
Public Interface ITypeDefinitionCollection
    Inherits IEnumerable, IObservableCollection(Of ITypeDefinition), IList(Of ITypeDefinition),
    ICollection(Of ITypeDefinition), IEnumerable(Of ITypeDefinition)

The ITypeDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeDefinition .)
Public property | ItemString, Boolean | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection Properties

The ITypeDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeDefinition .)
Public property | ItemString, Boolean | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection.Item Property

ITypeDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeDefinition .)
Public property | ItemString, Boolean | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection.Item Property (String, Boolean)

ITypeDefinitionCollectionItem Property (String, Boolean)

Gets the ITypeDefinition with the specified name.

[C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Default Property Item (
    name As String,
    caseSensitive As Boolean
) As ITypeDefinition
    Get

Parameters

name
Type: SystemString
The name of the ITypeDefinition to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: ITypeDefinition
The ITypeDefinition with the specified name.
See Also

Reference

ITypeDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection Methods

The ITypeDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection Events

The ITypeDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition Interface

Provides the base requirements of a type member (method, property, etc.) definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeMemberDefinition : IReflectionDefinition,
    ITypeMemberReference
Public Interface ITypeMemberDefinition
    Inherits IReflectionDefinition, ITypeMemberReference

The ITypeMemberDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeMemberAccess indicating the current member's access visibility.
Public property | DeclaringType | Gets the type that declares the current member.
Public property | DocumentationComment | Gets the optional documentation comment, if the current member is defined in source code.
Public property | ExtensionType | Gets the type that is implicitly used as a first argument, when an extension method is invoked.
Public property | GetterAccess | Gets a TypeMemberAccess indicating the getter access visibility if this member is a property.
Public property | IsAbstract | Gets whether the current member is abstract and must be overridden.
Public property | IsAdvanced | Gets whether the current member is decorated such that it should only be visible to advanced users within an editor.
Public property | IsAsync | Gets whether the current member is designated as having an asynchronous result.
Public property | IsDefault | Gets whether the current member is the default member for the declaring type.
Public property | IsDynamicReturnType | Gets whether the return type is a dynamic type.
Public property | IsExtension | Gets whether the current member is decorated as an extension method.
Public property | IsFinal | Gets whether the current member is declared final.
Public property | IsGenericMethod | Gets whether the current member is a generic method. (Inherited from ITypeMemberReference.)
Public property | IsGenericMethodDefinition | Gets whether the current member is a generic method definition, from which other generic methods can be constructed. (Inherited from ITypeMemberReference.)
Public property | IsHidden | Gets whether the current member is decorated such that it should never be visible within an editor.
Public property | IsImplicitDefaultConstructor | Gets whether the current member is an implicit default constructor.
Public property | IsLiteral | Gets whether the current member's value is written at compile time and cannot be changed.
Public property | IsObsolete | Gets whether the current member is decorated as obsolete.
Public property | IsReadOnly | Gets whether the current member is read-only.
Public property | IsStatic | Gets whether the current member is declared static.
Public property | IsVirtual | Gets whether the current member is virtual and can be overridden.
Public property | IsWriteOnly | Gets whether the current member is write-only.
Public property | Kind | Gets a TypeMemberDefinitionKind that indicates the kind of type member definition.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Parameters | Gets the collection of parameters to the current member.
Public property | ReturnType | Gets the type that is returned by the current member.
Public property | SetterAccess | Gets a TypeMemberAccess indicating the setter access visibility if this member is a property.
Public property | SourceFileLocation | Gets the source file location that contain the current member's declarations.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current member is a constructed generic method. (Inherited from ITypeMemberReference.)
Public property | TypeParameters | Gets the collection of generic type parameters, when the current member is a generic method definition.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition Properties

The ITypeMemberDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeMemberAccess indicating the current member's access visibility.
Public property | DeclaringType | Gets the type that declares the current member.
Public property | DocumentationComment | Gets the optional documentation comment, if the current member is defined in source code.
Public property | ExtensionType | Gets the type that is implicitly used as a first argument, when an extension method is invoked.
Public property | GetterAccess | Gets a TypeMemberAccess indicating the getter access visibility if this member is a property.
Public property | IsAbstract | Gets whether the current member is abstract and must be overridden.
Public property | IsAdvanced | Gets whether the current member is decorated such that it should only be visible to advanced users within an editor.
Public property | IsAsync | Gets whether the current member is designated as having an asynchronous result.
Public property | IsDefault | Gets whether the current member is the default member for the declaring type.
Public property | IsDynamicReturnType | Gets whether the return type is a dynamic type.
Public property | IsExtension | Gets whether the current member is decorated as an extension method.
Public property | IsFinal | Gets whether the current member is declared final.
Public property | IsGenericMethod | Gets whether the current member is a generic method. (Inherited from ITypeMemberReference.)
Public property | IsGenericMethodDefinition | Gets whether the current member is a generic method definition, from which other generic methods can be constructed. (Inherited from ITypeMemberReference.)
Public property | IsHidden | Gets whether the current member is decorated such that it should never be visible within an editor.
Public property | IsImplicitDefaultConstructor | Gets whether the current member is an implicit default constructor.
Public property | IsLiteral | Gets whether the current member's value is written at compile time and cannot be changed.
Public property | IsObsolete | Gets whether the current member is decorated as obsolete.
Public property | IsReadOnly | Gets whether the current member is read-only.
Public property | IsStatic | Gets whether the current member is declared static.
Public property | IsVirtual | Gets whether the current member is virtual and can be overridden.
Public property | IsWriteOnly | Gets whether the current member is write-only.
Public property | Kind | Gets a TypeMemberDefinitionKind that indicates the kind of type member definition.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Parameters | Gets the collection of parameters to the current member.
Public property | ReturnType | Gets the type that is returned by the current member.
Public property | SetterAccess | Gets a TypeMemberAccess indicating the setter access visibility if this member is a property.
Public property | SourceFileLocation | Gets the source file location that contain the current member's declarations.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current member is a constructed generic method. (Inherited from ITypeMemberReference.)
Public property | TypeParameters | Gets the collection of generic type parameters, when the current member is a generic method definition.
Top
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.Access Property

ITypeMemberDefinitionAccess Property

Gets a TypeMemberAccess indicating the current member's access visibility.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TypeMemberAccess Access { get; }
ReadOnly Property Access As TypeMemberAccess
    Get

Property Value

Type: TypeMemberAccess
A TypeMemberAccess indicating the current member's access visibility.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.DeclaringType Property

ITypeMemberDefinitionDeclaringType Property

Gets the type that declares the current member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition DeclaringType { get; }
ReadOnly Property DeclaringType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
An ITypeDefinition object representing the enclosing type.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.DocumentationComment Property

ITypeMemberDefinitionDocumentationComment Property

Gets the optional documentation comment, if the current member is defined in source code.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string DocumentationComment { get; }
ReadOnly Property DocumentationComment As String
    Get

Property Value

Type: String
The optional documentation comment, if the current member is defined in source code.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.ExtensionType Property

ITypeMemberDefinitionExtensionType Property

Gets the type that is implicitly used as a first argument, when an extension method is invoked.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition ExtensionType { get; }
ReadOnly Property ExtensionType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
The type that is implicitly used as a first argument, when an extension method is invoked.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.GetterAccess Property

ITypeMemberDefinitionGetterAccess Property

Gets a TypeMemberAccess indicating the getter access visibility if this member is a property.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TypeMemberAccess GetterAccess { get; }
ReadOnly Property GetterAccess As TypeMemberAccess
    Get

Property Value

Type: TypeMemberAccess
A TypeMemberAccess indicating the getter access visibility if this member is a property.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsAbstract Property

ITypeMemberDefinitionIsAbstract Property

Gets whether the current member is abstract and must be overridden.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAbstract { get; }
ReadOnly Property IsAbstract As Boolean
    Get

Property Value

Type: Boolean
true if the current member is abstract and must be overridden; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsAdvanced Property

ITypeMemberDefinitionIsAdvanced Property

Gets whether the current member is decorated such that it should only be visible to advanced users within an editor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAdvanced { get; }
ReadOnly Property IsAdvanced As Boolean
    Get

Property Value

Type: Boolean
true if the current member is decorated such that it should only be visible to advanced users within an editor; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsAsync Property

ITypeMemberDefinitionIsAsync Property

Gets whether the current member is designated as having an asynchronous result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAsync { get; }
ReadOnly Property IsAsync As Boolean
    Get

Property Value

Type: Boolean
true if the current member is designated as having an asynchronous result; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsDefault Property

ITypeMemberDefinitionIsDefault Property

Gets whether the current member is the default member for the declaring type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsDefault { get; }
ReadOnly Property IsDefault As Boolean
    Get

Property Value

Type: Boolean
true if the current member is the default member for the declaring type; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsDynamicReturnType Property

ITypeMemberDefinitionIsDynamicReturnType Property

Gets whether the return type is a dynamic type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsDynamicReturnType { get; }
ReadOnly Property IsDynamicReturnType As Boolean
    Get

Property Value

Type: Boolean
true if the return type is a dynamic type; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsExtension Property

ITypeMemberDefinitionIsExtension Property

Gets whether the current member is decorated as an extension method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsExtension { get; }
ReadOnly Property IsExtension As Boolean
    Get

Property Value

Type: Boolean
true if the current member is decorated as an extension method; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsFinal Property

ITypeMemberDefinitionIsFinal Property

Gets whether the current member is declared final.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsFinal { get; }
ReadOnly Property IsFinal As Boolean
    Get

Property Value

Type: Boolean
true if the current member is declared final; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsHidden Property

ITypeMemberDefinitionIsHidden Property

Gets whether the current member is decorated such that it should never be visible within an editor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsHidden { get; }
ReadOnly Property IsHidden As Boolean
    Get

Property Value

Type: Boolean
true if the current member is decorated such that it should never be visible within an editor; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsImplicitDefaultConstructor Property

ITypeMemberDefinitionIsImplicitDefaultConstructor Property

Gets whether the current member is an implicit default constructor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsImplicitDefaultConstructor { get; }
ReadOnly Property IsImplicitDefaultConstructor As Boolean
    Get

Property Value

Type: Boolean
true if the current member is an implicit default constructor; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsLiteral Property

ITypeMemberDefinitionIsLiteral Property

Gets whether the current member's value is written at compile time and cannot be changed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsLiteral { get; }
ReadOnly Property IsLiteral As Boolean
    Get

Property Value

Type: Boolean
true if the current member's value is written at compile time and cannot be changed; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsObsolete Property

ITypeMemberDefinitionIsObsolete Property

Gets whether the current member is decorated as obsolete.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsObsolete { get; }
ReadOnly Property IsObsolete As Boolean
    Get

Property Value

Type: Boolean
true if the current member is decorated as obsolete; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsReadOnly Property

ITypeMemberDefinitionIsReadOnly Property

Gets whether the current member is read-only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the current member is read-only; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsStatic Property

ITypeMemberDefinitionIsStatic Property

Gets whether the current member is declared static.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsStatic { get; }
ReadOnly Property IsStatic As Boolean
    Get

Property Value

Type: Boolean
true if the current member is declared static; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsVirtual Property

ITypeMemberDefinitionIsVirtual Property

Gets whether the current member is virtual and can be overridden.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsVirtual { get; }
ReadOnly Property IsVirtual As Boolean
    Get

Property Value

Type: Boolean
true if the current member is virtual and can be overridden; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsWriteOnly Property

ITypeMemberDefinitionIsWriteOnly Property

Gets whether the current member is write-only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsWriteOnly { get; }
ReadOnly Property IsWriteOnly As Boolean
    Get

Property Value

Type: Boolean
true if the current member is write-only; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.Kind Property

ITypeMemberDefinitionKind Property

Gets a TypeMemberDefinitionKind that indicates the kind of type member definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TypeMemberDefinitionKind Kind { get; }
ReadOnly Property Kind As TypeMemberDefinitionKind
    Get

Property Value

Type: TypeMemberDefinitionKind
A TypeMemberDefinitionKind that indicates the kind of type member definition.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.Parameters Property

ITypeMemberDefinitionParameters Property

Gets the collection of parameters to the current member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParameterDefinitionCollection Parameters { get; }
ReadOnly Property Parameters As IParameterDefinitionCollection
    Get

Property Value

Type: IParameterDefinitionCollection
The collection of parameters to the current member.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.ReturnType Property

ITypeMemberDefinitionReturnType Property

Gets the type that is returned by the current member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReference ReturnType { get; }
ReadOnly Property ReturnType As ITypeReference
    Get

Property Value

Type: ITypeReference
The type that is returned by the current member.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.SetterAccess Property

ITypeMemberDefinitionSetterAccess Property

Gets a TypeMemberAccess indicating the setter access visibility if this member is a property.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TypeMemberAccess SetterAccess { get; }
ReadOnly Property SetterAccess As TypeMemberAccess
    Get

Property Value

Type: TypeMemberAccess
A TypeMemberAccess indicating the setter access visibility if this member is a property.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.SourceFileLocation Property

ITypeMemberDefinitionSourceFileLocation Property

Gets the source file location that contain the current member's declarations.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISourceFileLocation SourceFileLocation { get; }
ReadOnly Property SourceFileLocation As ISourceFileLocation
    Get

Property Value

Type: ISourceFileLocation
The source file location that contain the current member's declarations.
Remarks
This property only knows the source file location for member definitions loaded from code.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.TypeParameters Property

ITypeMemberDefinitionTypeParameters Property

Gets the collection of generic type parameters, when the current member is a generic method definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeParameterCollection TypeParameters { get; }
ReadOnly Property TypeParameters As ITypeParameterCollection
    Get

Property Value

Type: ITypeParameterCollection
The collection of generic type parameters, when the current member is a generic method definition.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection Interface

Provides the base requirements for a collection of ITypeMemberDefinition objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeMemberDefinitionCollection : IEnumerable,
    IObservableCollection<ITypeMemberDefinition>, IList<ITypeMemberDefinition>, ICollection<ITypeMemberDefinition>,
    IEnumerable<ITypeMemberDefinition>
Public Interface ITypeMemberDefinitionCollection
    Inherits IEnumerable, IObservableCollection(Of ITypeMemberDefinition), IList(Of ITypeMemberDefinition),
    ICollection(Of ITypeMemberDefinition), IEnumerable(Of ITypeMemberDefinition)

The ITypeMemberDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeMemberDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeMemberDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeMemberDefinition .)
Public property | ItemString, Boolean | Gets the collection of ITypeMemberDefinition objects with the specified name, since there may potentially be member overloads with the same name. [C#] In C#, this property is the indexer for the ITypeMemberDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeMemberDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeMemberDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeMemberDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeMemberDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeMemberDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeMemberDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeMemberDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeMemberDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeMemberDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeMemberDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeMemberDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection Properties

The ITypeMemberDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeMemberDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeMemberDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeMemberDefinition .)
Public property | ItemString, Boolean | Gets the collection of ITypeMemberDefinition objects with the specified name, since there may potentially be member overloads with the same name. [C#] In C#, this property is the indexer for the ITypeMemberDefinitionCollection interface.
Top
See Also

Reference

ITypeMemberDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection.Item Property

ITypeMemberDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeMemberDefinition .)
Public property | ItemString, Boolean | Gets the collection of ITypeMemberDefinition objects with the specified name, since there may potentially be member overloads with the same name. [C#] In C#, this property is the indexer for the ITypeMemberDefinitionCollection interface.
Top
See Also

Reference

ITypeMemberDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection.Item Property (String, Boolean)

ITypeMemberDefinitionCollectionItem Property (String, Boolean)

Gets the collection of ITypeMemberDefinition objects with the specified name, since there may potentially be member overloads with the same name.

[C#] In C#, this property is the indexer for the ITypeMemberDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<ITypeMemberDefinition> this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Default Property Item (
    name As String,
    caseSensitive As Boolean
) As IEnumerable(Of ITypeMemberDefinition)
    Get

Parameters

name
Type: SystemString
The name of the ITypeMemberDefinition objects to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: IEnumerable ITypeMemberDefinition
The collection of ITypeMemberDefinition objects with the specified name.
See Also

Reference

ITypeMemberDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection Methods

The ITypeMemberDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeMemberDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeMemberDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeMemberDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeMemberDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeMemberDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeMemberDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeMemberDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeMemberDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeMemberDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeMemberDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeMemberDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ITypeMemberDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection Events

The ITypeMemberDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeMemberDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference Interface

Provides the base requirements of a type member (method, property, etc.) reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeMemberReference : IReflectionDefinition
Public Interface ITypeMemberReference
    Inherits IReflectionDefinition

The ITypeMemberReference type exposes the following members.

Properties
 | Name | Description
Public property | IsGenericMethod | Gets whether the current member is a generic method.
Public property | IsGenericMethodDefinition | Gets whether the current member is a generic method definition, from which other generic methods can be constructed.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current member is a constructed generic method.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference Properties

The ITypeMemberReference type exposes the following members.

Properties
 | Name | Description
Public property | IsGenericMethod | Gets whether the current member is a generic method.
Public property | IsGenericMethodDefinition | Gets whether the current member is a generic method definition, from which other generic methods can be constructed.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current member is a constructed generic method.
Top
See Also

Reference

ITypeMemberReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference.IsGenericMethod Property

ITypeMemberReferenceIsGenericMethod Property

Gets whether the current member is a generic method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsGenericMethod { get; }
ReadOnly Property IsGenericMethod As Boolean
    Get

Property Value

Type: Boolean
true if the current member is a generic method; otherwise, false.
See Also

Reference

ITypeMemberReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference.IsGenericMethodDefinition Property

ITypeMemberReferenceIsGenericMethodDefinition Property

Gets whether the current member is a generic method definition, from which other generic methods can be constructed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsGenericMethodDefinition { get; }
ReadOnly Property IsGenericMethodDefinition As Boolean
    Get

Property Value

Type: Boolean
true if the current member is a generic method definition, from which other generic methods can be constructed; otherwise, false.
See Also

Reference

ITypeMemberReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference.TypeArguments Property

ITypeMemberReferenceTypeArguments Property

Gets the collection of generic type arguments, when the current member is a constructed generic method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReferenceCollection TypeArguments { get; }
ReadOnly Property TypeArguments As ITypeReferenceCollection
    Get

Property Value

Type: ITypeReferenceCollection
The collection of generic type arguments, when the current member is a constructed generic method.
See Also

Reference

ITypeMemberReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter Interface

Provides the base requirements of a generic type parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeParameter : IReflectionDefinition,
    ITypeDefinition, ITypeReference
Public Interface ITypeParameter
    Inherits IReflectionDefinition, ITypeDefinition, ITypeReference

The ITypeParameter type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeAccess indicating the current type's access visibility. (Inherited from ITypeDefinition.)
Public property | ArrayRank | Gets the number of dimensions in the current type, if the type is an array. (Inherited from ITypeDefinition.)
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known. (Inherited from ITypeReference.)
Public property | BaseTypes | Gets the collection of base types inherited/implemented by the current type. (Inherited from ITypeDefinition.)
Public property | DeclaringMember | Gets the type member that declares the current type parameter.
Public property | DeclaringType | Gets the type that declares the current type, if it is nested. (Inherited from ITypeDefinition.)
Public property | DocumentationComment | Gets the optional documentation comment, if the current type is defined in source code. (Inherited from ITypeDefinition.)
Public property | ElementType | Gets the type of the object encompassed or referred to by the current array, pointer or reference type. (Inherited from ITypeDefinition.)
Public property | FullName | Gets the fully qualified name of the type, including the namespace of the type but not the assembly. (Inherited from ITypeDefinition.)
Public property | HasDefaultConstructorConstraint | Gets whether a public parameterless constructor constraint is present.
Public property | HasNotNullableValueTypeConstraint | Gets whether a non-nullable value type constraint is present.
Public property | HasReferenceTypeConstraint | Gets whether a reference type constraint is present.
Public property | IsAbstract | Gets whether the current type is abstract and must be overridden. (Inherited from ITypeDefinition.)
Public property | IsAdvanced | Gets whether the current type is decorated such that it should only be visible to advanced users within an editor. (Inherited from ITypeDefinition.)
Public property | IsAnonymous | Gets whether the current type is an anonymous type. (Inherited from ITypeDefinition.)
Public property | IsArray | Gets whether the current type is an array. (Inherited from ITypeDefinition.)
Public property | IsByReference | Gets whether the current type is passed by reference. (Inherited from ITypeDefinition.)
Public property | IsContravariant | Gets whether the type can be less derived than what is defined (in).
Public property | IsCovariant | Gets whether the type can be more derived than what is defined (out).
Public property | IsExtension | Gets whether the current type is decorated as a static class that can contain extension methods. (Inherited from ITypeDefinition.)
Public property | IsGenericType | Gets whether the current type is a generic type. (Inherited from ITypeReference.)
Public property | IsGenericTypeDefinition | Gets whether the current type is a generic type definition, from which other generic types can be constructed. (Inherited from ITypeDefinition.)
Public property | IsHidden | Gets whether the current type is decorated such that it should never be visible within an editor. (Inherited from ITypeDefinition.)
Public property | IsNested | Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type. (Inherited from ITypeDefinition.)
Public property | IsObsolete | Gets whether the current type is decorated as obsolete. (Inherited from ITypeDefinition.)
Public property | IsPointer | Gets whether the current type is a pointer. (Inherited from ITypeDefinition.)
Public property | IsSealed | Gets whether the current type is declared sealed. (Inherited from ITypeDefinition.)
Public property | IsStandardModule | Gets whether the current type is decorated as a standard module class. (Inherited from ITypeDefinition.)
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed. (Inherited from ITypeReference.)
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter. (Inherited from ITypeReference.)
Public property | Kind | Gets a TypeDefinitionKind that indicates the kind of type definition. (Inherited from ITypeDefinition.)
Public property | Members | Gets the collection of members that are defined within the current type. (Inherited from ITypeDefinition.)
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Namespace | Gets the namespace of the type. (Inherited from ITypeDefinition.)
Public property | NestedTypes | Gets the collection of nested types that are defined within the current type. (Inherited from ITypeDefinition.)
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type. (Inherited from ITypeReference.)
Public property | SourceFileLocations | Gets the collection of source file locations that contain the current type's declarations. (Inherited from ITypeDefinition.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type. (Inherited from ITypeReference.)
Public property | TypeParameterPosition | Gets the zero-based index of the generic type parameter.
Public property | TypeParameters | Gets the collection of generic type parameters, when the current type is a generic type definition. (Inherited from ITypeDefinition.)
Top
Methods
 | Name | Description
Public method | GetNamespaceDeclaration | Returns the INamespaceDeclaration that declared the current type, if the type came from a parsed source file. (Inherited from ITypeDefinition.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter Properties

The ITypeParameter type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeAccess indicating the current type's access visibility. (Inherited from ITypeDefinition.)
Public property | ArrayRank | Gets the number of dimensions in the current type, if the type is an array. (Inherited from ITypeDefinition.)
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known. (Inherited from ITypeReference.)
Public property | BaseTypes | Gets the collection of base types inherited/implemented by the current type. (Inherited from ITypeDefinition.)
Public property | DeclaringMember | Gets the type member that declares the current type parameter.
Public property | DeclaringType | Gets the type that declares the current type, if it is nested. (Inherited from ITypeDefinition.)
Public property | DocumentationComment | Gets the optional documentation comment, if the current type is defined in source code. (Inherited from ITypeDefinition.)
Public property | ElementType | Gets the type of the object encompassed or referred to by the current array, pointer or reference type. (Inherited from ITypeDefinition.)
Public property | FullName | Gets the fully qualified name of the type, including the namespace of the type but not the assembly. (Inherited from ITypeDefinition.)
Public property | HasDefaultConstructorConstraint | Gets whether a public parameterless constructor constraint is present.
Public property | HasNotNullableValueTypeConstraint | Gets whether a non-nullable value type constraint is present.
Public property | HasReferenceTypeConstraint | Gets whether a reference type constraint is present.
Public property | IsAbstract | Gets whether the current type is abstract and must be overridden. (Inherited from ITypeDefinition.)
Public property | IsAdvanced | Gets whether the current type is decorated such that it should only be visible to advanced users within an editor. (Inherited from ITypeDefinition.)
Public property | IsAnonymous | Gets whether the current type is an anonymous type. (Inherited from ITypeDefinition.)
Public property | IsArray | Gets whether the current type is an array. (Inherited from ITypeDefinition.)
Public property | IsByReference | Gets whether the current type is passed by reference. (Inherited from ITypeDefinition.)
Public property | IsContravariant | Gets whether the type can be less derived than what is defined (in).
Public property | IsCovariant | Gets whether the type can be more derived than what is defined (out).
Public property | IsExtension | Gets whether the current type is decorated as a static class that can contain extension methods. (Inherited from ITypeDefinition.)
Public property | IsGenericType | Gets whether the current type is a generic type. (Inherited from ITypeReference.)
Public property | IsGenericTypeDefinition | Gets whether the current type is a generic type definition, from which other generic types can be constructed. (Inherited from ITypeDefinition.)
Public property | IsHidden | Gets whether the current type is decorated such that it should never be visible within an editor. (Inherited from ITypeDefinition.)
Public property | IsNested | Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type. (Inherited from ITypeDefinition.)
Public property | IsObsolete | Gets whether the current type is decorated as obsolete. (Inherited from ITypeDefinition.)
Public property | IsPointer | Gets whether the current type is a pointer. (Inherited from ITypeDefinition.)
Public property | IsSealed | Gets whether the current type is declared sealed. (Inherited from ITypeDefinition.)
Public property | IsStandardModule | Gets whether the current type is decorated as a standard module class. (Inherited from ITypeDefinition.)
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed. (Inherited from ITypeReference.)
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter. (Inherited from ITypeReference.)
Public property | Kind | Gets a TypeDefinitionKind that indicates the kind of type definition. (Inherited from ITypeDefinition.)
Public property | Members | Gets the collection of members that are defined within the current type. (Inherited from ITypeDefinition.)
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Namespace | Gets the namespace of the type. (Inherited from ITypeDefinition.)
Public property | NestedTypes | Gets the collection of nested types that are defined within the current type. (Inherited from ITypeDefinition.)
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type. (Inherited from ITypeReference.)
Public property | SourceFileLocations | Gets the collection of source file locations that contain the current type's declarations. (Inherited from ITypeDefinition.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type. (Inherited from ITypeReference.)
Public property | TypeParameterPosition | Gets the zero-based index of the generic type parameter.
Public property | TypeParameters | Gets the collection of generic type parameters, when the current type is a generic type definition. (Inherited from ITypeDefinition.)
Top
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.DeclaringMember Property

ITypeParameterDeclaringMember Property

Gets the type member that declares the current type parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeMemberDefinition DeclaringMember { get; }
ReadOnly Property DeclaringMember As ITypeMemberDefinition
    Get

Property Value

Type: ITypeMemberDefinition
An ITypeMemberDefinition object representing the type member that declares the current type parameter.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.HasDefaultConstructorConstraint Property

ITypeParameterHasDefaultConstructorConstraint Property

Gets whether a public parameterless constructor constraint is present.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasDefaultConstructorConstraint { get; }
ReadOnly Property HasDefaultConstructorConstraint As Boolean
    Get

Property Value

Type: Boolean
true if a public parameterless constructor constraint is present; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.HasNotNullableValueTypeConstraint Property

ITypeParameterHasNotNullableValueTypeConstraint Property

Gets whether a non-nullable value type constraint is present.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasNotNullableValueTypeConstraint { get; }
ReadOnly Property HasNotNullableValueTypeConstraint As Boolean
    Get

Property Value

Type: Boolean
true if a non-nullable value type constraint is present; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.HasReferenceTypeConstraint Property

ITypeParameterHasReferenceTypeConstraint Property

Gets whether a reference type constraint is present.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasReferenceTypeConstraint { get; }
ReadOnly Property HasReferenceTypeConstraint As Boolean
    Get

Property Value

Type: Boolean
true if a reference type constraint is present; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.IsContravariant Property

ITypeParameterIsContravariant Property

Gets whether the type can be less derived than what is defined (in).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsContravariant { get; }
ReadOnly Property IsContravariant As Boolean
    Get

Property Value

Type: Boolean
true if the type can be less derived than what is defined; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.IsCovariant Property

ITypeParameterIsCovariant Property

Gets whether the type can be more derived than what is defined (out).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsCovariant { get; }
ReadOnly Property IsCovariant As Boolean
    Get

Property Value

Type: Boolean
true if the type can be more derived than what is defined; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.TypeParameterPosition Property

ITypeParameterTypeParameterPosition Property

Gets the zero-based index of the generic type parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int TypeParameterPosition { get; }
ReadOnly Property TypeParameterPosition As Integer
    Get

Property Value

Type: Int32
The zero-based index of the generic type parameter.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter Methods

The ITypeParameter type exposes the following members.

Methods
 | Name | Description
Public method | GetNamespaceDeclaration | Returns the INamespaceDeclaration that declared the current type, if the type came from a parsed source file. (Inherited from ITypeDefinition.)
Top
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection Interface

Provides the base requirements for a collection of ITypeParameter objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeParameterCollection : IEnumerable,
    IObservableCollection<ITypeParameter>, IList<ITypeParameter>, ICollection<ITypeParameter>,
    IEnumerable<ITypeParameter>
Public Interface ITypeParameterCollection
    Inherits IEnumerable, IObservableCollection(Of ITypeParameter), IList(Of ITypeParameter),
    ICollection(Of ITypeParameter), IEnumerable(Of ITypeParameter)

The ITypeParameterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeParameter .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeParameter .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeParameter .)
Public property | ItemString, Boolean | Gets the ITypeParameter with the specified name. [C#] In C#, this property is the indexer for the ITypeParameterCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeParameter .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeParameter .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeParameter .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeParameter .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeParameter .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeParameter .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeParameter .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeParameter .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeParameter | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeParameter | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeParameter | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection Properties

The ITypeParameterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeParameter .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeParameter .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeParameter .)
Public property | ItemString, Boolean | Gets the ITypeParameter with the specified name. [C#] In C#, this property is the indexer for the ITypeParameterCollection interface.
Top
See Also

Reference

ITypeParameterCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection.Item Property

ITypeParameterCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeParameter .)
Public property | ItemString, Boolean | Gets the ITypeParameter with the specified name. [C#] In C#, this property is the indexer for the ITypeParameterCollection interface.
Top
See Also

Reference

ITypeParameterCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection.Item Property (String, Boolean)

ITypeParameterCollectionItem Property (String, Boolean)

Gets the ITypeParameter with the specified name.

[C#] In C#, this property is the indexer for the ITypeParameterCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeParameter this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Default Property Item (
    name As String,
    caseSensitive As Boolean
) As ITypeParameter
    Get

Parameters

name
Type: SystemString
The name of the ITypeParameter to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: ITypeParameter
The ITypeParameter with the specified name.
See Also

Reference

ITypeParameterCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection Methods

The ITypeParameterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeParameter .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeParameter .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeParameter .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeParameter .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeParameter .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeParameter .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeParameter .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeParameter .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeParameter | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeParameter | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeParameter | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ITypeParameterCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection Events

The ITypeParameterCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeParameterCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference Interface

Provides the base requirements of a type reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeReference
Public Interface ITypeReference

The ITypeReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known.
Public property | IsGenericType | Gets whether the current type is a generic type.
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed.
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter.
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference Properties

The ITypeReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known.
Public property | IsGenericType | Gets whether the current type is a generic type.
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed.
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter.
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type.
Top
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.AssemblyName Property

ITypeReferenceAssemblyName Property

Gets the IAssemblyName of the assembly in which this type is defined, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAssemblyName AssemblyName { get; }
ReadOnly Property AssemblyName As IAssemblyName
    Get

Property Value

Type: IAssemblyName
The IAssemblyName of the assembly in which this type is defined, if known.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.IsGenericType Property

ITypeReferenceIsGenericType Property

Gets whether the current type is a generic type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsGenericType { get; }
ReadOnly Property IsGenericType As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a generic type; otherwise, false.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.IsTypeDefinition Property

ITypeReferenceIsTypeDefinition Property

Gets whether the current type is a type definition, from which other types can be constructed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsTypeDefinition { get; }
ReadOnly Property IsTypeDefinition As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a type definition, from which other types can be constructed; otherwise, false.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.IsTypeParameter Property

ITypeReferenceIsTypeParameter Property

Gets whether the current type is a generic type parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsTypeParameter { get; }
ReadOnly Property IsTypeParameter As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a generic type parameter; otherwise, False.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.QualifiedName Property

ITypeReferenceQualifiedName Property

Gets the IQualifiedName that indicates the qualified name of the current type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IQualifiedName QualifiedName { get; }
ReadOnly Property QualifiedName As IQualifiedName
    Get

Property Value

Type: IQualifiedName
The IQualifiedName that indicates the qualified name of the current type.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.TypeArguments Property

ITypeReferenceTypeArguments Property

Gets the collection of generic type arguments, when the current type is a constructed generic type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReferenceCollection TypeArguments { get; }
ReadOnly Property TypeArguments As ITypeReferenceCollection
    Get

Property Value

Type: ITypeReferenceCollection
The collection of generic type arguments, when the current type is a constructed generic type.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection Interface

Provides the base requirements for a collection of ITypeReference objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeReferenceCollection : IEnumerable,
    IObservableCollection<ITypeReference>, IList<ITypeReference>, ICollection<ITypeReference>,
    IEnumerable<ITypeReference>
Public Interface ITypeReferenceCollection
    Inherits IEnumerable, IObservableCollection(Of ITypeReference), IList(Of ITypeReference),
    ICollection(Of ITypeReference), IEnumerable(Of ITypeReference)

The ITypeReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeReference .)
Public property | ItemString, Boolean | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection Properties

The ITypeReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeReference .)
Public property | ItemString, Boolean | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection.Item Property

ITypeReferenceCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeReference .)
Public property | ItemString, Boolean | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection.Item Property (String, Boolean)

ITypeReferenceCollectionItem Property (String, Boolean)

Gets the ITypeReference with the specified name.

[C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReference this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Default Property Item (
    name As String,
    caseSensitive As Boolean
) As ITypeReference
    Get

Parameters

name
Type: SystemString
The name of the ITypeReference to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: ITypeReference
The ITypeReference with the specified name.
See Also

Reference

ITypeReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection Methods

The ITypeReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeReference .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection Events

The ITypeReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IUsingDirective Interface

Provides the base requirements of an using directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IUsingDirective
Public Interface IUsingDirective

The IUsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | IsStatic | Gets whether this using directive is flagged as static.
Public property | Name | Gets the qualified name of the namespace imported by the using directive.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IUsingDirective Properties

The IUsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | IsStatic | Gets whether this using directive is flagged as static.
Public property | Name | Gets the qualified name of the namespace imported by the using directive.
Top
See Also

Reference

IUsingDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IUsingDirective.IsStatic Property

IUsingDirectiveIsStatic Property

Gets whether this using directive is flagged as static.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsStatic { get; }
ReadOnly Property IsStatic As Boolean
    Get

Property Value

Type: Boolean
true if this using directive is flagged as static; otherwise, false.
See Also

Reference

IUsingDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IUsingDirective.Name Property

IUsingDirectiveName Property

Gets the qualified name of the namespace imported by the using directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IQualifiedName Name { get; }
ReadOnly Property Name As IQualifiedName
    Get

Property Value

Type: IQualifiedName
The qualified name of the namespace imported by the using directive.
See Also

Reference

IUsingDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition Interface

Provides the base requirements of a variable definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IVariableDefinition : IReflectionDefinition
Public Interface IVariableDefinition
    Inherits IReflectionDefinition

The IVariableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringMember | Gets the type member that declares the current variable.
Public property | IsDynamicType | Gets whether the variable type is a dynamic type.
Public property | IsRangeVariable | Gets whether the variable is a LINQ range variable.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets an ITypeReference for the variable type.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition Properties

The IVariableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringMember | Gets the type member that declares the current variable.
Public property | IsDynamicType | Gets whether the variable type is a dynamic type.
Public property | IsRangeVariable | Gets whether the variable is a LINQ range variable.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets an ITypeReference for the variable type.
Top
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition.DeclaringMember Property

IVariableDefinitionDeclaringMember Property

Gets the type member that declares the current variable.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeMemberDefinition DeclaringMember { get; }
ReadOnly Property DeclaringMember As ITypeMemberDefinition
    Get

Property Value

Type: ITypeMemberDefinition
An ITypeMemberDefinition object representing the type member that declares the current variable.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition.IsDynamicType Property

IVariableDefinitionIsDynamicType Property

Gets whether the variable type is a dynamic type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsDynamicType { get; }
ReadOnly Property IsDynamicType As Boolean
    Get

Property Value

Type: Boolean
true if the variable type is a dynamic type; otherwise, false.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition.IsRangeVariable Property

IVariableDefinitionIsRangeVariable Property

Gets whether the variable is a LINQ range variable.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsRangeVariable { get; }
ReadOnly Property IsRangeVariable As Boolean
    Get

Property Value

Type: Boolean
true if the variable is a LINQ range variable; otherwise, false.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition.Type Property

IVariableDefinitionType Property

Gets an ITypeReference for the variable type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReference Type { get; }
ReadOnly Property Type As ITypeReference
    Get

Property Value

Type: ITypeReference
An ITypeReference for the variable type.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess Enumeration

Specifies the type of access visibility for an ITypeDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TypeAccess
Public Enumeration TypeAccess
Members
Member name | Value | Description
Private | 1 | Visible only within its declaring type.
Assembly | 2 | Visible only within its own assembly (internal).
Family | 4 | Visible only within its own declaring type family (protected).
FamilyOrAssembly | 8 | Visible only to types that belong to either its own declaring type family or to its own assembly (protected internal).
Public | 16 | Visible to all.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind Enumeration

Specifies the kind of ITypeDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TypeDefinitionKind
Public Enumeration TypeDefinitionKind
Members
Member name | Value | Description
Unknown | 0 | An unknown kind.
Class | 1 | A class.
Delegate | 2 | A delegate.
Enumeration | 3 | An enumeration.
Interface | 4 | An interface.
Structure | 5 | A structure.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess Enumeration

Specifies the type of access visibility for an ITypeMemberDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TypeMemberAccess
Public Enumeration TypeMemberAccess
Members
Member name | Value | Description
Private | 1 | Visible only within its declaring type.
Assembly | 2 | Visible only within its own assembly (internal).
Family | 4 | Visible only within its own declaring type family (protected).
FamilyOrAssembly | 8 | Visible only to types that belong to either its own declaring type family or to its own assembly (protected internal).
Public | 16 | Visible to all.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind Enumeration

Specifies the kind of ITypeMemberDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TypeMemberDefinitionKind
Public Enumeration TypeMemberDefinitionKind
Members
Member name | Value | Description
Unknown | 0 | An unknown kind.
Constructor | 1 | A constructor.
Event | 2 | An event.
Field | 3 | A field.
Method | 4 | A method.
Operator | 5 | An operator.
Property | 6 | A property.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace

Contains the implementation types related to reflection for a .NET syntax language.
Classes
 | Class | Description
Public class | AssemblyName | Stores an IAssembly name.
Public class | AssemblyRepositoryBase | Provides the abstract base class for an IAssemblyRepository implementation.
Public class | BinaryAssembly | Represents a binary (source code-based) assembly.
Public class | BinaryAssemblySerializer | Serializes and deserializes IBinaryAssembly objects.
Public class | DocumentationProvider | Returns documentation for a .NET type or member definition.
Public class | FileAssemblyDocumentation | Provides an assembly documentation source from a file on the hard drive.
Public class | FileBasedAssemblyRepository | Represents an IAssemblyRepository that can cache data in the file system.
Public class | ProjectAssembly | Represents a project (source code-based) assembly.
Public class | QualifiedName | Represents a qualified name.
Public class | ReflectionBinaryAssemblyLoader | Loads data for a binary assembly using .NET reflection.
Public class | SimpleName | Represents a simple name with optional type arguments, which is a component of an IQualifiedName.
Public class | SourceFile | Represents a source code file that can be loaded by an IProjectAssembly.
Public class | SourceFileLocation | Represents a source code file location, consisting of a file reference and related offsets within that file, generally used to denote where a type/member was defined.
Public class | StreamAssemblyDocumentationBase | Provides an abstract base class for a Stream-based assembly documentation source.


AssemblyName Class

Stores an IAssembly name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationAssemblyName

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AssemblyName : IAssemblyName
Public Class AssemblyName
    Implements IAssemblyName

The AssemblyName type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyName(AssemblyName) | Initializes a new instance of the AssemblyName class.
Public method | AssemblyName(String) | Initializes a new instance of the AssemblyName class.
Public method | AssemblyName(String, Version) | Initializes a new instance of the AssemblyName class.
Top
Properties
 | Name | Description
Public property | FullName | Gets the full name of the assembly, also known as the display name.
Public property | Name | Gets the simple name of the assembly.
Public property | Version | Gets the major, minor, build, and revision numbers of the assembly.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
 | ParseFullName | Creates a new instance of the AssemblyName class based on the specified assembly full name.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Constructor

Overload List
 | Name | Description
Public method | AssemblyName(AssemblyName) | Initializes a new instance of the AssemblyName class.
Public method | AssemblyName(String) | Initializes a new instance of the AssemblyName class.
Public method | AssemblyName(String, Version) | Initializes a new instance of the AssemblyName class.
Top
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Constructor (AssemblyName)

Initializes a new instance of the AssemblyName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AssemblyName(
    AssemblyName assemblyName
)
Public Sub New (
    assemblyName As AssemblyName
)

Parameters

assemblyName
Type: System.ReflectionAssemblyName
The system reflection AssemblyName to examine.
See Also

Reference

AssemblyName Class
AssemblyName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Constructor (String)

Initializes a new instance of the AssemblyName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AssemblyName(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The simple name of the assembly.
See Also

Reference

AssemblyName Class
AssemblyName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Constructor (String, Version)

Initializes a new instance of the AssemblyName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AssemblyName(
    string name,
    Version version
)
Public Sub New (
    name As String,
    version As Version
)

Parameters

name
Type: SystemString
The simple name of the assembly.
version
Type: SystemVersion
The major, minor, build, and revision numbers of the assembly.
See Also

Reference

AssemblyName Class
AssemblyName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Properties

The AssemblyName type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets the full name of the assembly, also known as the display name.
Public property | Name | Gets the simple name of the assembly.
Public property | Version | Gets the major, minor, build, and revision numbers of the assembly.
Top
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.FullName Property

AssemblyNameFullName Property

Gets the full name of the assembly, also known as the display name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string FullName { get; }
Public ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the assembly, also known as the display name.

Implements

IAssemblyNameFullName
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.Name Property

AssemblyNameName Property

Gets the simple name of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The simple name of the assembly.

Implements

IAssemblyNameName
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.Version Property

AssemblyNameVersion Property

Gets the major, minor, build, and revision numbers of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Version Version { get; }
Public ReadOnly Property Version As Version
    Get

Property Value

Type: Version
The major, minor, build, and revision numbers of the assembly.

Implements

IAssemblyNameVersion
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Methods

The AssemblyName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
 | ParseFullName | Creates a new instance of the AssemblyName class based on the specified assembly full name.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.Equals Method

AssemblyNameEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.GetHashCode Method

AssemblyNameGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.ParseFullName Method

AssemblyNameParseFullName Method

Creates a new instance of the AssemblyName class based on the specified assembly full name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static AssemblyName ParseFullName(
    string fullName
)
Public Shared Function ParseFullName (
    fullName As String
) As AssemblyName

Parameters

fullName
Type: SystemString
The assembly full name to examine.

Return Value

Type: AssemblyName

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.AssemblyName.ParseFullName(System.String)"]

See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.ToString Method

AssemblyNameToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase Class

Provides the abstract base class for an IAssemblyRepository implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationAssemblyRepositoryBase
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationFileBasedAssemblyRepository

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class AssemblyRepositoryBase : IAssemblyRepository
Public MustInherit Class AssemblyRepositoryBase
    Implements IAssemblyRepository

The AssemblyRepositoryBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AssemblyRepositoryBase | Initializes a new instance of the AssemblyRepositoryBase class
Top
Properties
 | Name | Description
Public property | SyncRoot | Gets an object that can be used to synchronize access to the repository.
Top
Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly.
Protected method | Create | Creates a new IBinaryAssembly for the specified Assembly.
Protected method | GetOrCreate | Gets an existing or creates a new IBinaryAssembly for the specified Assembly.
Public method | Load(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | Load(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | Load(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Public method | LoadFrom | Creates a new IBinaryAssembly instance from the Assembly at the specified path.
Public method | PruneCache | Deletes any cache data that is no longer valid.
Public method | Remove | Removes a reference to an IBinaryAssembly.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase Constructor

Initializes a new instance of the AssemblyRepositoryBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected AssemblyRepositoryBase()
Protected Sub New
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase Properties

The AssemblyRepositoryBase type exposes the following members.

Properties
 | Name | Description
Public property | SyncRoot | Gets an object that can be used to synchronize access to the repository.
Top
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.SyncRoot Property

AssemblyRepositoryBaseSyncRoot Property

Gets an object that can be used to synchronize access to the repository.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract Object SyncRoot { get; }
Public MustOverride ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object
An object that can be used to synchronize access to the repository.

Implements

IAssemblyRepositorySyncRoot
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase Methods

The AssemblyRepositoryBase type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly.
Protected method | Create | Creates a new IBinaryAssembly for the specified Assembly.
Protected method | GetOrCreate | Gets an existing or creates a new IBinaryAssembly for the specified Assembly.
Public method | Load(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | Load(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | Load(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Public method | LoadFrom | Creates a new IBinaryAssembly instance from the Assembly at the specified path.
Public method | PruneCache | Deletes any cache data that is no longer valid.
Public method | Remove | Removes a reference to an IBinaryAssembly.
Top
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Add Method

AssemblyRepositoryBaseAdd Method

Adds a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void Add(
    IBinaryAssembly assembly
)
Public MustOverride Sub Add (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is referenced.

Implements

IAssemblyRepositoryAdd(IBinaryAssembly)
Remarks
The specified assembly will be tracked while there are remaining references to it. While tracked, the various Load(String) methods will return the already-loaded instance when appropriate.
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Create Method

AssemblyRepositoryBaseCreate Method

Creates a new IBinaryAssembly for the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IBinaryAssembly Create(
    Assembly assembly,
    IAssemblyName assemblyName,
    IBinaryAssemblyMetadata metadata
)
Protected Overridable Function Create (
    assembly As Assembly,
    assemblyName As IAssemblyName,
    metadata As IBinaryAssemblyMetadata
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName to use.
metadata
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssemblyMetadata
The assembly metadata.

Return Value

Type: IBinaryAssembly

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.AssemblyRepositoryBase.Create(System.Reflection.Assembly,ActiproSoftware.Text.Languages.DotNet.Reflection.IAssemblyName,ActiproSoftware.Text.Languages.DotNet.Reflection.IBinaryAssemblyMetadata)"]

See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.GetOrCreate Method

AssemblyRepositoryBaseGetOrCreate Method

Gets an existing or creates a new IBinaryAssembly for the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract IBinaryAssembly GetOrCreate(
    Assembly assembly,
    IAssemblyName assemblyName,
    string location
)
Protected MustOverride Function GetOrCreate (
    assembly As Assembly,
    assemblyName As IAssemblyName,
    location As String
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName to use.
location
Type: SystemString
The assembly location, if known.

Return Value

Type: IBinaryAssembly

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.AssemblyRepositoryBase.GetOrCreate(System.Reflection.Assembly,ActiproSoftware.Text.Languages.DotNet.Reflection.IAssemblyName,System.String)"]

See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Load Method

AssemblyRepositoryBaseLoad Method

Overload List
 | Name | Description
Public method | Load(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | Load(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | Load(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Top
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Load Method (Assembly)

AssemblyRepositoryBaseLoad Method (Assembly)

Creates a new IBinaryAssembly instance from the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IBinaryAssembly Load(
    Assembly assembly
)
Public Function Load (
    assembly As Assembly
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was created.

Implements

IAssemblyRepositoryLoad(Assembly)
See Also

Reference

AssemblyRepositoryBase Class
Load Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Load Method (String)

AssemblyRepositoryBaseLoad Method (String)

Creates a new IBinaryAssembly instance from the specified Assembly name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IBinaryAssembly Load(
    string fullName
)
Public Function Load (
    fullName As String
) As IBinaryAssembly

Parameters

fullName
Type: SystemString
The Assembly full name for which to load.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was created.

Implements

IAssemblyRepositoryLoad(String)
See Also

Reference

AssemblyRepositoryBase Class
Load Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Load Method (Assembly, IAssemblyName)

AssemblyRepositoryBaseLoad Method (Assembly, IAssemblyName)

Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IBinaryAssembly Load(
    Assembly assembly,
    IAssemblyName assemblyName
)
Public Function Load (
    assembly As Assembly,
    assemblyName As IAssemblyName
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The alternate AssemblyName to use.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was created.

Implements

IAssemblyRepositoryLoad(Assembly, IAssemblyName)
See Also

Reference

AssemblyRepositoryBase Class
Load Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.LoadFrom Method

AssemblyRepositoryBaseLoadFrom Method

Creates a new IBinaryAssembly instance from the Assembly at the specified path.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IBinaryAssembly LoadFrom(
    string path
)
Public Function LoadFrom (
    path As String
) As IBinaryAssembly

Parameters

path
Type: SystemString
The path to the Assembly file to load.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was created.

Implements

IAssemblyRepositoryLoadFrom(String)
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.PruneCache Method

AssemblyRepositoryBasePruneCache Method

Deletes any cache data that is no longer valid.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void PruneCache()
Public MustOverride Sub PruneCache

Implements

IAssemblyRepositoryPruneCache
Remarks
Call this method upon the shutdown of your application to ensure out-of-date cache data isn't retained.
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Remove Method

AssemblyRepositoryBaseRemove Method

Removes a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void Remove(
    IBinaryAssembly assembly
)
Public MustOverride Sub Remove (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is no longer referenced.

Implements

IAssemblyRepositoryRemove(IBinaryAssembly)
Remarks
When no references remain for the assembly, it will no longer be tracked.
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly Class

Represents a binary (source code-based) assembly.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationBinaryAssembly

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BinaryAssembly : IAssembly,
    IBinaryAssembly, IBinaryAssemblyMetadata
Public Class BinaryAssembly
    Implements IAssembly, IBinaryAssembly, IBinaryAssemblyMetadata

The BinaryAssembly type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryAssembly | Initializes a new instance of the BinaryAssembly class.
Top
Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Public property | HasLoadErrors | Gets whether load errors were encountered when using reflection on the related .NET assembly.
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known.
Public property | Location | Gets the location of the assembly, if known.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Public property | Size | Gets the size of the assembly, if known.
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly Constructor

Initializes a new instance of the BinaryAssembly class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BinaryAssembly(
    IAssemblyName assemblyName,
    IBinaryAssemblyMetadata metadata,
    IBinaryAssemblyReferenceCollection assemblyRefs,
    IEnumerable<ITypeDefinition> typeDefs,
    bool hasLoadErrors
)
Public Sub New (
    assemblyName As IAssemblyName,
    metadata As IBinaryAssemblyMetadata,
    assemblyRefs As IBinaryAssemblyReferenceCollection,
    typeDefs As IEnumerable(Of ITypeDefinition),
    hasLoadErrors As Boolean
)

Parameters

assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName to use.
metadata
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssemblyMetadata
The assembly metadata.
assemblyRefs
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssemblyReferenceCollection
The collection of assembly references for this assembly.
typeDefs
Type: System.Collections.GenericIEnumerable ITypeDefinition
The exported type definitions.
hasLoadErrors
Type: SystemBoolean
Whether load errors were encountered when using reflection on the related .NET assembly.
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly Properties

The BinaryAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Public property | HasLoadErrors | Gets whether load errors were encountered when using reflection on the related .NET assembly.
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known.
Public property | Location | Gets the location of the assembly, if known.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Public property | Size | Gets the size of the assembly, if known.
Top
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.AssemblyReferences Property

BinaryAssemblyAssemblyReferences Property

Gets the collection of assembly references for this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IBinaryAssemblyReferenceCollection AssemblyReferences { get; }
Public ReadOnly Property AssemblyReferences As IBinaryAssemblyReferenceCollection
    Get

Property Value

Type: IBinaryAssemblyReferenceCollection
The collection of assembly references for this assembly.

Implements

IBinaryAssemblyAssemblyReferences
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.Documentation Property

BinaryAssemblyDocumentation Property

Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAssemblyDocumentation Documentation { get; set; }
Public Property Documentation As IAssemblyDocumentation
    Get
    Set

Property Value

Type: IAssemblyDocumentation
The IAssemblyDocumentation that provides access to this assembly's type and member documentation.

Implements

IAssemblyDocumentation
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.GlobalNamespace Property

BinaryAssemblyGlobalNamespace Property

Gets the entry point into the INamespaceDefinition tree defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public INamespaceDefinition GlobalNamespace { get; }
Public ReadOnly Property GlobalNamespace As INamespaceDefinition
    Get

Property Value

Type: INamespaceDefinition
The entry point into the INamespaceDefinition tree defined in this assembly.

Implements

IAssemblyGlobalNamespace
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.HasLoadErrors Property

BinaryAssemblyHasLoadErrors Property

Gets whether load errors were encountered when using reflection on the related .NET assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasLoadErrors { get; }
Public ReadOnly Property HasLoadErrors As Boolean
    Get

Property Value

Type: Boolean
true if load errors were encountered; otherwise, false.

Implements

IBinaryAssemblyHasLoadErrors
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.LastModifiedDateTime Property

BinaryAssemblyLastModifiedDateTime Property

Gets the DateTime at which the assembly was last modified, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<DateTime> LastModifiedDateTime { get; }
Public ReadOnly Property LastModifiedDateTime As Nullable(Of DateTime)
    Get

Property Value

Type: Nullable DateTime
The DateTime at which the assembly was last modified, if known.

Implements

IBinaryAssemblyMetadataLastModifiedDateTime
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.Location Property

BinaryAssemblyLocation Property

Gets the location of the assembly, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Location { get; }
Public ReadOnly Property Location As String
    Get

Property Value

Type: String
The location of the assembly, if known.

Implements

IBinaryAssemblyMetadataLocation
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.Name Property

BinaryAssemblyName Property

Gets the simple name of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The simple name of the assembly.

Implements

IAssemblyName
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.Namespaces Property

BinaryAssemblyNamespaces Property

Gets the collection of INamespaceDefinition objects defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public INamespaceDefinitionCollection Namespaces { get; }
Public ReadOnly Property Namespaces As INamespaceDefinitionCollection
    Get

Property Value

Type: INamespaceDefinitionCollection
The collection of INamespaceDefinition objects defined in this assembly.

Implements

IAssemblyNamespaces
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.Size Property

BinaryAssemblySize Property

Gets the size of the assembly, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<long> Size { get; }
Public ReadOnly Property Size As Nullable(Of Long)
    Get

Property Value

Type: Nullable Int64
The size of the assembly, if known.

Implements

IBinaryAssemblyMetadataSize
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly Methods

The BinaryAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.GetAssemblyName Method

BinaryAssemblyGetAssemblyName Method

Returns an IAssemblyName that contains assembly name information.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAssemblyName GetAssemblyName()
Public Function GetAssemblyName As IAssemblyName

Field Value

Type: IAssemblyName
An IAssemblyName that contains assembly name information.

Return Value

Type: IAssemblyName

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.BinaryAssembly.GetAssemblyName"]

Implements

IAssemblyGetAssemblyName
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.ToString Method

BinaryAssemblyToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssembly.ToTreeString Method

BinaryAssemblyToTreeString Method

Outputs the contents of the assembly in tree form.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ToTreeString()
Public Function ToTreeString As String

Return Value

Type: String
A string that indicates the contents of the assembly.

Implements

IAssemblyToTreeString
See Also

Reference

BinaryAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer Class

Serializes and deserializes IBinaryAssembly objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationBinaryAssemblySerializer

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BinaryAssemblySerializer
Public Class BinaryAssemblySerializer

The BinaryAssemblySerializer type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryAssemblySerializer | Initializes a new instance of the BinaryAssemblySerializer class
Top
Methods
 | Name | Description
Public method | LoadFromStream | Loads an IBinaryAssembly from a cache Stream.
Public method | LoadMetadataFromStream | Loads an IBinaryAssemblyMetadata from a cache Stream.
Public method | SaveToStream | Saves an IBinaryAssembly to a cache Stream.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer Constructor

Initializes a new instance of the BinaryAssemblySerializer class

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BinaryAssemblySerializer()
Public Sub New
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer Methods

The BinaryAssemblySerializer type exposes the following members.

Methods
 | Name | Description
Public method | LoadFromStream | Loads an IBinaryAssembly from a cache Stream.
Public method | LoadMetadataFromStream | Loads an IBinaryAssemblyMetadata from a cache Stream.
Public method | SaveToStream | Saves an IBinaryAssembly to a cache Stream.
Top
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer.LoadFromStream Method

BinaryAssemblySerializerLoadFromStream Method

Loads an IBinaryAssembly from a cache Stream.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IBinaryAssembly LoadFromStream(
    IBinaryAssemblyMetadata metadata,
    Stream stream
)
Public Function LoadFromStream (
    metadata As IBinaryAssemblyMetadata,
    stream As Stream
) As IBinaryAssembly

Parameters

metadata
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssemblyMetadata
The assembly metadata, if known, to compare to the stream's data for validation.
stream
Type: System.IOStream
The Stream from which to load.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was loaded.
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer.LoadMetadataFromStream Method

BinaryAssemblySerializerLoadMetadataFromStream Method

Loads an IBinaryAssemblyMetadata from a cache Stream.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IBinaryAssemblyMetadata LoadMetadataFromStream(
    Stream stream
)
Public Function LoadMetadataFromStream (
    stream As Stream
) As IBinaryAssemblyMetadata

Parameters

stream
Type: System.IOStream
The Stream from which to load.

Return Value

Type: IBinaryAssemblyMetadata
The IBinaryAssemblyMetadata that was loaded.
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer.SaveToStream Method

BinaryAssemblySerializerSaveToStream Method

Saves an IBinaryAssembly to a cache Stream.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SaveToStream(
    IBinaryAssembly assembly,
    Stream stream
)
Public Sub SaveToStream (
    assembly As IBinaryAssembly,
    stream As Stream
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly to serialize.
stream
Type: System.IOStream
The Stream into which serialization should occur.
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider Class

Returns documentation for a .NET type or member definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationDocumentationProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DocumentationProvider : IDocumentationProvider
Public Class DocumentationProvider
    Implements IDocumentationProvider

The DocumentationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentationProvider | Initializes a new instance of the DocumentationProvider class.
Top
Methods
 | Name | Description
 | GetDocumentationKey(ITypeDefinition) | Returns the documentation key for the specified ITypeDefinition.
 | GetDocumentationKey(ITypeMemberDefinition, Boolean) | Returns the documentation key for the specified ITypeMemberDefinition.
Public method | GetParameter | Returns the documentation for the parameter with the specified name.
Public method | GetSummary | Returns the summary documentation.
Public method | GetTypeParameter | Returns the documentation for the type parameter with the specified name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider Constructor

Initializes a new instance of the DocumentationProvider class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentationProvider(
    string documentation
)
Public Sub New (
    documentation As String
)

Parameters

documentation
Type: SystemString
The XML documentation.
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider Methods

The DocumentationProvider type exposes the following members.

Methods
 | Name | Description
 | GetDocumentationKey(ITypeDefinition) | Returns the documentation key for the specified ITypeDefinition.
 | GetDocumentationKey(ITypeMemberDefinition, Boolean) | Returns the documentation key for the specified ITypeMemberDefinition.
Public method | GetParameter | Returns the documentation for the parameter with the specified name.
Public method | GetSummary | Returns the summary documentation.
Public method | GetTypeParameter | Returns the documentation for the type parameter with the specified name.
Top
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetDocumentationKey Method

DocumentationProviderGetDocumentationKey Method

Overload List
Name | Description
GetDocumentationKey(ITypeDefinition) | Returns the documentation key for the specified ITypeDefinition.
GetDocumentationKey(ITypeMemberDefinition, Boolean) | Returns the documentation key for the specified ITypeMemberDefinition.
Top
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetDocumentationKey Method (ITypeDefinition)

DocumentationProviderGetDocumentationKey Method (ITypeDefinition)

Returns the documentation key for the specified ITypeDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string GetDocumentationKey(
    ITypeDefinition typeDef
)
Public Shared Function GetDocumentationKey (
    typeDef As ITypeDefinition
) As String

Parameters

typeDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeDefinition
The ITypeDefinition to examine.

Return Value

Type: String
The documentation key for the specified ITypeDefinition.
See Also

Reference

DocumentationProvider Class
GetDocumentationKey Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetDocumentationKey Method (ITypeMemberDefinition, Boolean)

DocumentationProviderGetDocumentationKey Method (ITypeMemberDefinition, Boolean)

Returns the documentation key for the specified ITypeMemberDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string GetDocumentationKey(
    ITypeMemberDefinition typeMemberDef,
    bool includeDeclaringType
)
Public Shared Function GetDocumentationKey (
    typeMemberDef As ITypeMemberDefinition,
    includeDeclaringType As Boolean
) As String

Parameters

typeMemberDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeMemberDefinition
The ITypeMemberDefinition to examine.
includeDeclaringType
Type: SystemBoolean
Whether to include the declaring type.

Return Value

Type: String
The documentation key for the specified ITypeMemberDefinition.
See Also

Reference

DocumentationProvider Class
GetDocumentationKey Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetParameter Method

DocumentationProviderGetParameter Method

Returns the documentation for the parameter with the specified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string GetParameter(
    string name
)
Public Function GetParameter (
    name As String
) As String

Parameters

name
Type: SystemString
The parameter name.

Return Value

Type: String
The documentation for the parameter with the specified name.

Implements

IDocumentationProviderGetParameter(String)
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetSummary Method

DocumentationProviderGetSummary Method

Returns the summary documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string GetSummary()
Public Function GetSummary As String

Return Value

Type: String
The summary documentation.

Implements

IDocumentationProviderGetSummary
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetTypeParameter Method

DocumentationProviderGetTypeParameter Method

Returns the documentation for the type parameter with the specified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string GetTypeParameter(
    string name
)
Public Function GetTypeParameter (
    name As String
) As String

Parameters

name
Type: SystemString
The parameter name.

Return Value

Type: String
The documentation for the type parameter with the specified name.

Implements

IDocumentationProviderGetTypeParameter(String)
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileAssemblyDocumentation Class

Provides an assembly documentation source from a file on the hard drive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationStreamAssemblyDocumentationBase
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationFileAssemblyDocumentation

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FileAssemblyDocumentation : StreamAssemblyDocumentationBase
Public Class FileAssemblyDocumentation
    Inherits StreamAssemblyDocumentationBase

The FileAssemblyDocumentation type exposes the following members.

Constructors
 | Name | Description
Public method | FileAssemblyDocumentation | Initializes a new instance of the FileAssemblyDocumentation class.
Top
Methods
 | Name | Description
Public method | GetDocumentation(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition. (Inherited from StreamAssemblyDocumentationBase.)
Public method | GetDocumentation(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition. (Inherited from StreamAssemblyDocumentationBase.)
Protected method | GetStream | Returns the Stream to use for reading documentation. (Overrides StreamAssemblyDocumentationBaseGetStream.)
Public method | Refresh | Clears all index and cache data, allowing the documentation to refresh itself on the next request. (Inherited from StreamAssemblyDocumentationBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileAssemblyDocumentation Constructor

Initializes a new instance of the FileAssemblyDocumentation class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FileAssemblyDocumentation(
    string path
)
Public Sub New (
    path As String
)

Parameters

path
Type: SystemString
The path to the file on the local hard drive.
See Also

Reference

FileAssemblyDocumentation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileAssemblyDocumentation Methods

The FileAssemblyDocumentation type exposes the following members.

Methods
 | Name | Description
Public method | GetDocumentation(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition. (Inherited from StreamAssemblyDocumentationBase.)
Public method | GetDocumentation(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition. (Inherited from StreamAssemblyDocumentationBase.)
Protected method | GetStream | Returns the Stream to use for reading documentation. (Overrides StreamAssemblyDocumentationBaseGetStream.)
Public method | Refresh | Clears all index and cache data, allowing the documentation to refresh itself on the next request. (Inherited from StreamAssemblyDocumentationBase.)
Top
See Also

Reference

FileAssemblyDocumentation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileAssemblyDocumentation.GetStream Method

FileAssemblyDocumentationGetStream Method

Returns the Stream to use for reading documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Stream GetStream()
Protected Overrides Function GetStream As Stream

Return Value

Type: Stream
The Stream to use for reading documentation.
Remarks
The Stream must support seeking.
See Also

Reference

FileAssemblyDocumentation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository Class

Represents an IAssemblyRepository that can cache data in the file system.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationAssemblyRepositoryBase
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationFileBasedAssemblyRepository

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FileBasedAssemblyRepository : AssemblyRepositoryBase
Public Class FileBasedAssemblyRepository
    Inherits AssemblyRepositoryBase

The FileBasedAssemblyRepository type exposes the following members.

Constructors
 | Name | Description
Public method | FileBasedAssemblyRepository | Initializes a new instance of the FileBasedAssemblyRepository class.
Top
Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to use for assembly and documentation cache files.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the repository. (Overrides AssemblyRepositoryBaseSyncRoot.)
Top
Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly. (Overrides AssemblyRepositoryBaseAdd(IBinaryAssembly).)
Protected method | Create | Creates a new IBinaryAssembly for the specified Assembly. (Overrides AssemblyRepositoryBaseCreate(Assembly, IAssemblyName, IBinaryAssemblyMetadata).)
Protected method | GetOrCreate | Gets an existing or creates a new IBinaryAssembly for the specified Assembly. (Overrides AssemblyRepositoryBaseGetOrCreate(Assembly, IAssemblyName, String).)
Public method | Load(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly. (Inherited from AssemblyRepositoryBase.)
Public method | Load(String) | Creates a new IBinaryAssembly instance from the specified Assembly name. (Inherited from AssemblyRepositoryBase.)
Public method | Load(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies. (Inherited from AssemblyRepositoryBase.)
Public method | LoadFrom | Creates a new IBinaryAssembly instance from the Assembly at the specified path. (Inherited from AssemblyRepositoryBase.)
Public method | PruneCache | Deletes any cache-related files in the CachePath that are no longer valid. (Overrides AssemblyRepositoryBasePruneCache.)
Public method | Remove | Removes a reference to an IBinaryAssembly. (Overrides AssemblyRepositoryBaseRemove(IBinaryAssembly).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository Constructor

Initializes a new instance of the FileBasedAssemblyRepository class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FileBasedAssemblyRepository(
    string cachePath
)
Public Sub New (
    cachePath As String
)

Parameters

cachePath
Type: SystemString
The path to use for assembly and documentation cache files.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository Properties

The FileBasedAssemblyRepository type exposes the following members.

Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to use for assembly and documentation cache files.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the repository. (Overrides AssemblyRepositoryBaseSyncRoot.)
Top
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.CachePath Property

FileBasedAssemblyRepositoryCachePath Property

Gets or sets the path to use for assembly and documentation cache files.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string CachePath { get; set; }
Public Property CachePath As String
    Get
    Set

Property Value

Type: String
The path to use for assembly and documentation cache files.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.SyncRoot Property

FileBasedAssemblyRepositorySyncRoot Property

Gets an object that can be used to synchronize access to the repository.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object SyncRoot { get; }
Public Overrides ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object
An object that can be used to synchronize access to the repository.

Implements

IAssemblyRepositorySyncRoot
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository Methods

The FileBasedAssemblyRepository type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly. (Overrides AssemblyRepositoryBaseAdd(IBinaryAssembly).)
Protected method | Create | Creates a new IBinaryAssembly for the specified Assembly. (Overrides AssemblyRepositoryBaseCreate(Assembly, IAssemblyName, IBinaryAssemblyMetadata).)
Protected method | GetOrCreate | Gets an existing or creates a new IBinaryAssembly for the specified Assembly. (Overrides AssemblyRepositoryBaseGetOrCreate(Assembly, IAssemblyName, String).)
Public method | Load(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly. (Inherited from AssemblyRepositoryBase.)
Public method | Load(String) | Creates a new IBinaryAssembly instance from the specified Assembly name. (Inherited from AssemblyRepositoryBase.)
Public method | Load(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies. (Inherited from AssemblyRepositoryBase.)
Public method | LoadFrom | Creates a new IBinaryAssembly instance from the Assembly at the specified path. (Inherited from AssemblyRepositoryBase.)
Public method | PruneCache | Deletes any cache-related files in the CachePath that are no longer valid. (Overrides AssemblyRepositoryBasePruneCache.)
Public method | Remove | Removes a reference to an IBinaryAssembly. (Overrides AssemblyRepositoryBaseRemove(IBinaryAssembly).)
Top
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.Add Method

FileBasedAssemblyRepositoryAdd Method

Adds a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Add(
    IBinaryAssembly assembly
)
Public Overrides Sub Add (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is referenced.

Implements

IAssemblyRepositoryAdd(IBinaryAssembly)
Remarks
The specified assembly will be tracked while there are remaining references to it. While tracked, the various Load(String) methods will return the already-loaded instance when appropriate.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.Create Method

FileBasedAssemblyRepositoryCreate Method

Creates a new IBinaryAssembly for the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IBinaryAssembly Create(
    Assembly assembly,
    IAssemblyName assemblyName,
    IBinaryAssemblyMetadata metadata
)
Protected Overrides Function Create (
    assembly As Assembly,
    assemblyName As IAssemblyName,
    metadata As IBinaryAssemblyMetadata
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName to use.
metadata
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssemblyMetadata
The assembly metadata.

Return Value

Type: IBinaryAssembly

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.FileBasedAssemblyRepository.Create(System.Reflection.Assembly,ActiproSoftware.Text.Languages.DotNet.Reflection.IAssemblyName,ActiproSoftware.Text.Languages.DotNet.Reflection.IBinaryAssemblyMetadata)"]

See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.GetOrCreate Method

FileBasedAssemblyRepositoryGetOrCreate Method

Gets an existing or creates a new IBinaryAssembly for the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IBinaryAssembly GetOrCreate(
    Assembly assembly,
    IAssemblyName assemblyName,
    string location
)
Protected Overrides Function GetOrCreate (
    assembly As Assembly,
    assemblyName As IAssemblyName,
    location As String
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName to use.
location
Type: SystemString
The assembly location, if known.

Return Value

Type: IBinaryAssembly

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.FileBasedAssemblyRepository.GetOrCreate(System.Reflection.Assembly,ActiproSoftware.Text.Languages.DotNet.Reflection.IAssemblyName,System.String)"]

See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.PruneCache Method

FileBasedAssemblyRepositoryPruneCache Method

Deletes any cache-related files in the CachePath that are no longer valid.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void PruneCache()
Public Overrides Sub PruneCache

Implements

IAssemblyRepositoryPruneCache
Remarks
Call this method upon the shutdown of your application to ensure out-of-date cache files aren't retained.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.Remove Method

FileBasedAssemblyRepositoryRemove Method

Removes a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Remove(
    IBinaryAssembly assembly
)
Public Overrides Sub Remove (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is no longer referenced.

Implements

IAssemblyRepositoryRemove(IBinaryAssembly)
Remarks
When no references remain for the assembly, it will no longer be tracked.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Class

Represents a project (source code-based) assembly.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationProjectAssembly
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpProjectAssembly
ActiproSoftware.Text.Languages.VB.ImplementationVBProjectAssembly

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class ProjectAssembly : IProjectAssembly,
    IAssembly
Public MustInherit Class ProjectAssembly
    Implements IProjectAssembly, IAssembly

The ProjectAssembly type exposes the following members.

Constructors
 | Name | Description
Protected method | ProjectAssembly(String) | Initializes a new instance of the ProjectAssembly class.
Protected method | ProjectAssembly(IAssemblyName) | Initializes a new instance of the ProjectAssembly class.
Top
Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Public property | Resolver | Gets the IResolver to use for this project assembly.
Public property | SourceFiles | Gets the collection of source files in this project assembly.
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Constructor

Overload List
 | Name | Description
Protected method | ProjectAssembly(String) | Initializes a new instance of the ProjectAssembly class.
Protected method | ProjectAssembly(IAssemblyName) | Initializes a new instance of the ProjectAssembly class.
Top
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Constructor (String)

Initializes a new instance of the ProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ProjectAssembly(
    string name
)
Protected Sub New (
    name As String
)

Parameters

name
Type: SystemString
The simple name of the assembly.
See Also

Reference

ProjectAssembly Class
ProjectAssembly Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Constructor (IAssemblyName)

Initializes a new instance of the ProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ProjectAssembly(
    IAssemblyName assemblyName
)
Protected Sub New (
    assemblyName As IAssemblyName
)

Parameters

assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
An IAssemblyName that contains assembly name information.
See Also

Reference

ProjectAssembly Class
ProjectAssembly Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Properties

The ProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Public property | Resolver | Gets the IResolver to use for this project assembly.
Public property | SourceFiles | Gets the collection of source files in this project assembly.
Top
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.AssemblyReferences Property

ProjectAssemblyAssemblyReferences Property

Gets the collection of assembly references for this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IProjectAssemblyReferenceCollection AssemblyReferences { get; }
Public ReadOnly Property AssemblyReferences As IProjectAssemblyReferenceCollection
    Get

Property Value

Type: IProjectAssemblyReferenceCollection
The collection of assembly references for this assembly.

Implements

IProjectAssemblyAssemblyReferences
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.Documentation Property

ProjectAssemblyDocumentation Property

Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAssemblyDocumentation Documentation { get; set; }
Public Property Documentation As IAssemblyDocumentation
    Get
    Set

Property Value

Type: IAssemblyDocumentation
The IAssemblyDocumentation that provides access to this assembly's type and member documentation.

Implements

IAssemblyDocumentation
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.GlobalNamespace Property

ProjectAssemblyGlobalNamespace Property

Gets the entry point into the INamespaceDefinition tree defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public INamespaceDefinition GlobalNamespace { get; }
Public ReadOnly Property GlobalNamespace As INamespaceDefinition
    Get

Property Value

Type: INamespaceDefinition
The entry point into the INamespaceDefinition tree defined in this assembly.

Implements

IAssemblyGlobalNamespace
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.IsLanguageCaseSensitive Property

ProjectAssemblyIsLanguageCaseSensitive Property

Gets whether the language associated with this project assembly is case-sensitive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool IsLanguageCaseSensitive { get; }
Protected MustOverride ReadOnly Property IsLanguageCaseSensitive As Boolean
    Get

Property Value

Type: Boolean
true if the language associated with this project assembly is case-sensitive; otherwise, false.
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.Name Property

ProjectAssemblyName Property

Gets the simple name of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The simple name of the assembly.

Implements

IAssemblyName
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.Namespaces Property

ProjectAssemblyNamespaces Property

Gets the collection of INamespaceDefinition objects defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public INamespaceDefinitionCollection Namespaces { get; }
Public ReadOnly Property Namespaces As INamespaceDefinitionCollection
    Get

Property Value

Type: INamespaceDefinitionCollection
The collection of INamespaceDefinition objects defined in this assembly.

Implements

IAssemblyNamespaces
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.Resolver Property

ProjectAssemblyResolver Property

Gets the IResolver to use for this project assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract IResolver Resolver { get; }
Public MustOverride ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project assembly.

Implements

IProjectAssemblyResolver
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.SourceFiles Property

ProjectAssemblySourceFiles Property

Gets the collection of source files in this project assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISourceFileCollection SourceFiles { get; }
Public ReadOnly Property SourceFiles As ISourceFileCollection
    Get

Property Value

Type: ISourceFileCollection
The collection of source files in this project assembly.

Implements

IProjectAssemblySourceFiles
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Methods

The ProjectAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.GetAssemblyName Method

ProjectAssemblyGetAssemblyName Method

Returns an IAssemblyName that contains assembly name information.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAssemblyName GetAssemblyName()
Public Function GetAssemblyName As IAssemblyName

Field Value

Type: IAssemblyName
An IAssemblyName that contains assembly name information.

Return Value

Type: IAssemblyName

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.ProjectAssembly.GetAssemblyName"]

Implements

IAssemblyGetAssemblyName
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.ToString Method

ProjectAssemblyToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.ToTreeString Method

ProjectAssemblyToTreeString Method

Outputs the contents of the assembly in tree form.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ToTreeString()
Public Function ToTreeString As String

Return Value

Type: String
A string that indicates the contents of the assembly.

Implements

IAssemblyToTreeString
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Class

Represents a qualified name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationQualifiedName

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class QualifiedName : IQualifiedName
Public Class QualifiedName
    Implements IQualifiedName

The QualifiedName type exposes the following members.

Constructors
 | Name | Description
Public method | QualifiedName(QualifiedName) | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, ISimpleName) | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, Int32, Int32, ISimpleName) | Initializes a new instance of the QualifiedName class.
Top
Properties
 | Name | Description
Public property | Alias | Gets the optional alias that indicates the root of the qualified name.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | HasArrayRankSpecifiers | Gets whether the qualified name has at least one array rank specifier.
Public property | HasIdentifiers | Gets whether the qualified name has at least one identifier.
Public property | Identifiers | Gets the collection of identifiers for the qualified name.
Public property | IsGlobal | Gets whether the qualified name is rooted at the default global namespace.
Public property | PointerLevel | Gets the pointer level.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Constructor

Overload List
 | Name | Description
Public method | QualifiedName(QualifiedName) | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, ISimpleName) | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, Int32, Int32, ISimpleName) | Initializes a new instance of the QualifiedName class.
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Constructor (QualifiedName)

Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName(
    QualifiedName qualifiedName
)
Public Sub New (
    qualifiedName As QualifiedName
)

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
The AST qualified name to examine.
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Constructor (String, Boolean, ISimpleName[])

QualifiedName Constructor (String, Boolean, ISimpleName)

Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName(
    string alias,
    bool isGlobal,
    params ISimpleName[] identifiers
)
Public Sub New (
    alias As String,
    isGlobal As Boolean,
    ParamArray identifiers As ISimpleName()
)

Parameters

alias
Type: SystemString
The optional alias that indicates the root of the qualified name.
isGlobal
Type: SystemBoolean
Whether the qualified name is rooted at the default global namespace.
identifiers
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionISimpleName
The collection of identifiers for the qualified name.
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Constructor (String, Boolean, Int32[], Int32, ISimpleName[])

QualifiedName Constructor (String, Boolean, Int32, Int32, ISimpleName)

Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QualifiedName(
    string alias,
    bool isGlobal,
    int[] arrayRankSpecifiers,
    int pointerLevel,
    params ISimpleName[] identifiers
)
Public Sub New (
    alias As String,
    isGlobal As Boolean,
    arrayRankSpecifiers As Integer(),
    pointerLevel As Integer,
    ParamArray identifiers As ISimpleName()
)

Parameters

alias
Type: SystemString
The optional alias that indicates the root of the qualified name.
isGlobal
Type: SystemBoolean
Whether the qualified name is rooted at the default global namespace.
arrayRankSpecifiers
Type: SystemInt32
The array rank specifiers.
pointerLevel
Type: SystemInt32
The pointer level.
identifiers
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionISimpleName
The collection of identifiers for the qualified name.
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Properties

The QualifiedName type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the optional alias that indicates the root of the qualified name.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | HasArrayRankSpecifiers | Gets whether the qualified name has at least one array rank specifier.
Public property | HasIdentifiers | Gets whether the qualified name has at least one identifier.
Public property | Identifiers | Gets the collection of identifiers for the qualified name.
Public property | IsGlobal | Gets whether the qualified name is rooted at the default global namespace.
Public property | PointerLevel | Gets the pointer level.
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.Alias Property

QualifiedNameAlias Property

Gets the optional alias that indicates the root of the qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Alias { get; }
Public ReadOnly Property Alias As String
    Get

Property Value

Type: String
The optional alias that indicates the root of the qualified name.

Implements

IQualifiedNameAlias
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.ArrayRankSpecifiers Property

QualifiedNameArrayRankSpecifiers Property

Gets the array rank specifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<int> ArrayRankSpecifiers { get; }
Public ReadOnly Property ArrayRankSpecifiers As IList(Of Integer)
    Get

Property Value

Type: IList Int32
The array rank specifiers.

Implements

IQualifiedNameArrayRankSpecifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.HasArrayRankSpecifiers Property

QualifiedNameHasArrayRankSpecifiers Property

Gets whether the qualified name has at least one array rank specifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArrayRankSpecifiers { get; }
Public ReadOnly Property HasArrayRankSpecifiers As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name has at least one array rank specifier; otherwise, false.

Implements

IQualifiedNameHasArrayRankSpecifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.HasIdentifiers Property

QualifiedNameHasIdentifiers Property

Gets whether the qualified name has at least one identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasIdentifiers { get; }
Public ReadOnly Property HasIdentifiers As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name has at least one identifier; otherwise, false.

Implements

IQualifiedNameHasIdentifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.Identifiers Property

QualifiedNameIdentifiers Property

Gets the collection of identifiers for the qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ISimpleName> Identifiers { get; }
Public ReadOnly Property Identifiers As IList(Of ISimpleName)
    Get

Property Value

Type: IList ISimpleName
The collection of identifiers for the qualified name.

Implements

IQualifiedNameIdentifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.IsGlobal Property

QualifiedNameIsGlobal Property

Gets whether the qualified name is rooted at the default global namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGlobal { get; }
Public ReadOnly Property IsGlobal As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name is rooted at the default global namespace; otherwise, false.

Implements

IQualifiedNameIsGlobal
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.PointerLevel Property

QualifiedNamePointerLevel Property

Gets the pointer level.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int PointerLevel { get; }
Public ReadOnly Property PointerLevel As Integer
    Get

Property Value

Type: Int32
The pointer level.

Implements

IQualifiedNamePointerLevel
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Methods

The QualifiedName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.Clone Method

QualifiedNameClone Method

Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IQualifiedName Clone()
Public Function Clone As IQualifiedName

Return Value

Type: IQualifiedName
The object that was created.

Implements

IQualifiedNameClone
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.Equals Method

QualifiedNameEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.GetHashCode Method

QualifiedNameGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.ToString Method

QualifiedNameToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ReflectionBinaryAssemblyLoader Class

Loads data for a binary assembly using .NET reflection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationReflectionBinaryAssemblyLoader

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReflectionBinaryAssemblyLoader
Public Class ReflectionBinaryAssemblyLoader

The ReflectionBinaryAssemblyLoader type exposes the following members.

Constructors
 | Name | Description
Public method | ReflectionBinaryAssemblyLoader | Initializes a new instance of the ReflectionBinaryAssemblyLoader class
Top
Methods
 | Name | Description
Public method | LoadFrom | Creates a new IBinaryAssembly instance from the Assembly at the specified path.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ReflectionBinaryAssemblyLoader Constructor

Initializes a new instance of the ReflectionBinaryAssemblyLoader class

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReflectionBinaryAssemblyLoader()
Public Sub New
See Also

Reference

ReflectionBinaryAssemblyLoader Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ReflectionBinaryAssemblyLoader Methods

The ReflectionBinaryAssemblyLoader type exposes the following members.

Methods
 | Name | Description
Public method | LoadFrom | Creates a new IBinaryAssembly instance from the Assembly at the specified path.
Top
See Also

Reference

ReflectionBinaryAssemblyLoader Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ReflectionBinaryAssemblyLoader.LoadFrom Method

ReflectionBinaryAssemblyLoaderLoadFrom Method

Creates a new IBinaryAssembly instance from the Assembly at the specified path.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IBinaryAssembly LoadFrom(
    string path
)
Public Function LoadFrom (
    path As String
) As IBinaryAssembly

Parameters

path
Type: SystemString
The path to the Assembly file to load.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was created.
See Also

Reference

ReflectionBinaryAssemblyLoader Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Class

Represents a simple name with optional type arguments, which is a component of an IQualifiedName.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationSimpleName

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SimpleName : ISimpleName
Public Class SimpleName
    Implements ISimpleName

The SimpleName type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleName(SimpleName) | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String, IQualifiedName) | Initializes a new instance of the SimpleName class.
Top
Properties
 | Name | Description
Public property | HasTypeArguments | Gets whether the identifier has at least one type argument.
Public property | Text | Gets the text value of the identifier.
Public property | TypeArguments | Gets the collection of optional generic type arguments for the identifier.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Constructor

Overload List
 | Name | Description
Public method | SimpleName(SimpleName) | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String, IQualifiedName) | Initializes a new instance of the SimpleName class.
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Constructor (SimpleName)

Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName(
    SimpleName simpleName
)
Public Sub New (
    simpleName As SimpleName
)

Parameters

simpleName
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSimpleName
The AST simple name to examine.
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Constructor (String, IQualifiedName[])

SimpleName Constructor (String, IQualifiedName)

Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName(
    string text,
    params IQualifiedName[] typeArguments
)
Public Sub New (
    text As String,
    ParamArray typeArguments As IQualifiedName()
)

Parameters

text
Type: SystemString
The text value of the identifier.
typeArguments
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIQualifiedName
The collection of optional generic type arguments for the identifier.
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Properties

The SimpleName type exposes the following members.

Properties
 | Name | Description
Public property | HasTypeArguments | Gets whether the identifier has at least one type argument.
Public property | Text | Gets the text value of the identifier.
Public property | TypeArguments | Gets the collection of optional generic type arguments for the identifier.
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.HasTypeArguments Property

SimpleNameHasTypeArguments Property

Gets whether the identifier has at least one type argument.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTypeArguments { get; }
Public ReadOnly Property HasTypeArguments As Boolean
    Get

Property Value

Type: Boolean
true if the identifier has at least one type argument; otherwise, false.

Implements

ISimpleNameHasTypeArguments
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.Text Property

SimpleNameText Property

Gets the text value of the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The text value of the identifier.

Implements

ISimpleNameText
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.TypeArguments Property

SimpleNameTypeArguments Property

Gets the collection of optional generic type arguments for the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IQualifiedName> TypeArguments { get; }
Public ReadOnly Property TypeArguments As IList(Of IQualifiedName)
    Get

Property Value

Type: IList IQualifiedName
The collection of optional generic type arguments for the identifier.

Implements

ISimpleNameTypeArguments
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Methods

The SimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.Clone Method

SimpleNameClone Method

Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISimpleName Clone()
Public Function Clone As ISimpleName

Return Value

Type: ISimpleName
The object that was created.

Implements

ISimpleNameClone
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.Equals Method

SimpleNameEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.GetHashCode Method

SimpleNameGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.ToString Method

SimpleNameToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Class

Represents a source code file that can be loaded by an IProjectAssembly.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationSourceFile

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SourceFile : IKeyedObject, ISourceFile
Public Class SourceFile
    Implements IKeyedObject, ISourceFile

The SourceFile type exposes the following members.

Constructors
 | Name | Description
Public method | SourceFile(String, ITypeDefinition) | Initializes a new instance of the SourceFile class.
Public method | SourceFile(String, IEnumerableITypeDefinition) | Initializes a new instance of the SourceFile class.
Top
Properties
 | Name | Description
Public property | Key | Gets the unique key that identifies the source file, which is generally a full file path or GUID.
Public property | TypeDefinitions | Gets the collection of ITypeDefinition objects contained in the source file.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Constructor

Overload List
 | Name | Description
Public method | SourceFile(String, ITypeDefinition) | Initializes a new instance of the SourceFile class.
Public method | SourceFile(String, IEnumerableITypeDefinition) | Initializes a new instance of the SourceFile class.
Top
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Constructor (String, ITypeDefinition[])

SourceFile Constructor (String, ITypeDefinition)

Initializes a new instance of the SourceFile class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SourceFile(
    string key,
    params ITypeDefinition[] typeDefs
)
Public Sub New (
    key As String,
    ParamArray typeDefs As ITypeDefinition()
)

Parameters

key
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
typeDefs
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeDefinition
The collection of ITypeDefinition objects contained in the source file.
See Also

Reference

SourceFile Class
SourceFile Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Constructor (String, IEnumerable(ITypeDefinition))

SourceFile Constructor (String, IEnumerableITypeDefinition)

Initializes a new instance of the SourceFile class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SourceFile(
    string key,
    IEnumerable<ITypeDefinition> typeDefs
)
Public Sub New (
    key As String,
    typeDefs As IEnumerable(Of ITypeDefinition)
)

Parameters

key
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
typeDefs
Type: System.Collections.GenericIEnumerable ITypeDefinition
The collection of ITypeDefinition objects contained in the source file.
See Also

Reference

SourceFile Class
SourceFile Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Properties

The SourceFile type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the unique key that identifies the source file, which is generally a full file path or GUID.
Public property | TypeDefinitions | Gets the collection of ITypeDefinition objects contained in the source file.
Top
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile.Key Property

SourceFileKey Property

Gets the unique key that identifies the source file, which is generally a full file path or GUID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The unique key that identifies the source file, which is generally a full file path or GUID.

Implements

IKeyedObjectKey
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile.TypeDefinitions Property

SourceFileTypeDefinitions Property

Gets the collection of ITypeDefinition objects contained in the source file.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITypeDefinitionCollection TypeDefinitions { get; }
Public ReadOnly Property TypeDefinitions As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of ITypeDefinition objects contained in the source file.

Implements

ISourceFileTypeDefinitions
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Methods

The SourceFile type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile.ToString Method

SourceFileToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFileLocation Class

Represents a source code file location, consisting of a file reference and related offsets within that file, generally used to denote where a type/member was defined.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationSourceFileLocation

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SourceFileLocation : IKeyedObject,
    ISourceFileLocation
Public Class SourceFileLocation
    Implements IKeyedObject, ISourceFileLocation

The SourceFileLocation type exposes the following members.

Constructors
 | Name | Description
Public method | SourceFileLocation | Initializes a new instance of the SourceFileLocation class.
Top
Properties
 | Name | Description
Public property | Key | Gets the unique key that identifies the source file, which is generally a full file path or GUID.
Public property | NavigationOffset | Gets the optional offset within the source code file where navigations to the definition should occur, generally the start of the type/member name.
Public property | TextRange | Gets the offset range within the source code file of the type/member definition.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFileLocation Constructor

Initializes a new instance of the SourceFileLocation class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SourceFileLocation(
    string key,
    TextRange textRange,
    Nullable<int> navigationOffset
)
Public Sub New (
    key As String,
    textRange As TextRange,
    navigationOffset As Nullable(Of Integer)
)

Parameters

key
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
textRange
Type: ActiproSoftware.TextTextRange
The offset range within the source code file of the type/member definition.
navigationOffset
Type: SystemNullable Int32
The optional offset within the source code file where navigations to the definition should occur, generally the start of the type/member name.
See Also

Reference

SourceFileLocation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFileLocation Properties

The SourceFileLocation type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the unique key that identifies the source file, which is generally a full file path or GUID.
Public property | NavigationOffset | Gets the optional offset within the source code file where navigations to the definition should occur, generally the start of the type/member name.
Public property | TextRange | Gets the offset range within the source code file of the type/member definition.
Top
See Also

Reference

SourceFileLocation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFileLocation.Key Property

SourceFileLocationKey Property

Gets the unique key that identifies the source file, which is generally a full file path or GUID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The unique key that identifies the source file, which is generally a full file path or GUID.

Implements

IKeyedObjectKey
See Also

Reference

SourceFileLocation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFileLocation.NavigationOffset Property

SourceFileLocationNavigationOffset Property

Gets the optional offset within the source code file where navigations to the definition should occur, generally the start of the type/member name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> NavigationOffset { get; }
Public ReadOnly Property NavigationOffset As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The optional offset within the source code file where navigations to the definition should occur, generally the start of the type/member name.

Implements

ISourceFileLocationNavigationOffset
See Also

Reference

SourceFileLocation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFileLocation.TextRange Property

SourceFileLocationTextRange Property

Gets the offset range within the source code file of the type/member definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextRange TextRange { get; }
Public ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
The offset range within the source code file of the type/member definition.

Implements

ISourceFileLocationTextRange
See Also

Reference

SourceFileLocation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFileLocation Methods

The SourceFileLocation type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

SourceFileLocation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFileLocation.ToString Method

SourceFileLocationToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SourceFileLocation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase Class

Provides an abstract base class for a Stream-based assembly documentation source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationStreamAssemblyDocumentationBase
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationFileAssemblyDocumentation

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class StreamAssemblyDocumentationBase : IAssemblyDocumentation
Public MustInherit Class StreamAssemblyDocumentationBase
    Implements IAssemblyDocumentation

The StreamAssemblyDocumentationBase type exposes the following members.

Constructors
 | Name | Description
Protected method | StreamAssemblyDocumentationBase | Initializes a new instance of the StreamAssemblyDocumentationBase class
Top
Methods
 | Name | Description
Public method | GetDocumentation(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentation(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Protected method | GetStream | Returns the Stream to use for reading documentation.
Public method | Refresh | Clears all index and cache data, allowing the documentation to refresh itself on the next request.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase Constructor

Initializes a new instance of the StreamAssemblyDocumentationBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected StreamAssemblyDocumentationBase()
Protected Sub New
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase Methods

The StreamAssemblyDocumentationBase type exposes the following members.

Methods
 | Name | Description
Public method | GetDocumentation(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentation(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Protected method | GetStream | Returns the Stream to use for reading documentation.
Public method | Refresh | Clears all index and cache data, allowing the documentation to refresh itself on the next request.
Top
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.GetDocumentation Method

StreamAssemblyDocumentationBaseGetDocumentation Method

Overload List
 | Name | Description
Public method | GetDocumentation(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentation(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Top
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.GetDocumentation Method (ITypeDefinition)

StreamAssemblyDocumentationBaseGetDocumentation Method (ITypeDefinition)

Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDocumentationProvider GetDocumentation(
    ITypeDefinition typeDef
)
Public Function GetDocumentation (
    typeDef As ITypeDefinition
) As IDocumentationProvider

Parameters

typeDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeDefinition
The ITypeDefinition for which to search.

Return Value

Type: IDocumentationProvider
The IDocumentationProvider, if any, that is available for the specified ITypeDefinition.

Implements

IAssemblyDocumentationGetDocumentation(ITypeDefinition)
See Also

Reference

StreamAssemblyDocumentationBase Class
GetDocumentation Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.GetDocumentation Method (ITypeMemberDefinition)

StreamAssemblyDocumentationBaseGetDocumentation Method (ITypeMemberDefinition)

Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDocumentationProvider GetDocumentation(
    ITypeMemberDefinition typeMemberDef
)
Public Function GetDocumentation (
    typeMemberDef As ITypeMemberDefinition
) As IDocumentationProvider

Parameters

typeMemberDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeMemberDefinition
The ITypeMemberDefinition for which to search.

Return Value

Type: IDocumentationProvider
The IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.

Implements

IAssemblyDocumentationGetDocumentation(ITypeMemberDefinition)
See Also

Reference

StreamAssemblyDocumentationBase Class
GetDocumentation Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.GetStream Method

StreamAssemblyDocumentationBaseGetStream Method

Returns the Stream to use for reading documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Stream GetStream()
Protected MustOverride Function GetStream As Stream

Return Value

Type: Stream
The Stream to use for reading documentation.
Remarks
The Stream must support seeking.
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.Refresh Method

StreamAssemblyDocumentationBaseRefresh Method

Clears all index and cache data, allowing the documentation to refresh itself on the next request.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ActiproSoftware.Text.Languages.DotNet.Resolution Namespace

Contains the types related to resolution for a .NET syntax language.
Interfaces
 | Interface | Description
Public interface | INamespaceResolverResult | Provides the base requirements of a namespace result from an IResolver resolution operation.
Public interface | IParameterResolverResult | Provides the base requirements of a parameter result from an IResolver resolution operation.
Public interface | IResolver | Provides the base requirements of a .NET language resolver.
Public interface | IResolverRequest | Provides the base requirements of a request for a .NET language resolve operation.
Public interface | IResolverResult | Provides the base requirements of a single result from an IResolver resolution operation.
Public interface | IResolverResultCollection | Provides the base requirements for a collection of IResolverResult objects.
Public interface | IResolverResultSet | Provides the base requirements of a result set from an IResolver resolution operation.
Public interface | ITypeMemberResolverResult | Provides the base requirements of a type member result from an IResolver resolution operation.
Public interface | ITypeResolverResult | Provides the base requirements of a type result from an IResolver resolution operation.
Public interface | IVariableResolverResult | Provides the base requirements of a local variable result from an IResolver resolution operation.
Enumerations
 | Enumeration | Description
Public enumeration | ResolverResultKind | Specifies the kind of resolver result.


INamespaceResolverResult Interface

Provides the base requirements of a namespace result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface INamespaceResolverResult : IResolverResult
Public Interface INamespaceResolverResult
    Inherits IResolverResult

The INamespaceResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Definitions | Get the collection of accessible INamespaceDefinition objects for this namespace.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


INamespaceResolverResult Properties

The INamespaceResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Definitions | Get the collection of accessible INamespaceDefinition objects for this namespace.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

INamespaceResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


INamespaceResolverResult.Definitions Property

INamespaceResolverResultDefinitions Property

Get the collection of accessible INamespaceDefinition objects for this namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
INamespaceDefinitionCollection Definitions { get; }
ReadOnly Property Definitions As INamespaceDefinitionCollection
    Get

Property Value

Type: INamespaceDefinitionCollection
The collection of accessible INamespaceDefinition objects for this namespace.
See Also

Reference

INamespaceResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


INamespaceResolverResult.FullName Property

INamespaceResolverResultFullName Property

Gets the full name of the namespace, which includes the names of ancestor namespaces.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the namespace, which includes the names of ancestor namespaces.
See Also

Reference

INamespaceResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IParameterResolverResult Interface

Provides the base requirements of a parameter result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParameterResolverResult : IResolverResult
Public Interface IParameterResolverResult
    Inherits IResolverResult

The IParameterResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Parameter | Gets a IParameterDefinition indicating the parameter.
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IParameterResolverResult Properties

The IParameterResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Parameter | Gets a IParameterDefinition indicating the parameter.
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IParameterResolverResult.Parameter Property

IParameterResolverResultParameter Property

Gets a IParameterDefinition indicating the parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParameterDefinition Parameter { get; }
ReadOnly Property Parameter As IParameterDefinition
    Get

Property Value

Type: IParameterDefinition
A IParameterDefinition indicating the parameter.
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolver Interface

Provides the base requirements of a .NET language resolver.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolver
Public Interface IResolver

The IResolver type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolver Methods

The IResolver type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.
Top
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolver.Resolve Method

IResolverResolve Method

Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IResolverResultSet Resolve(
    IResolverRequest request
)
Function Resolve (
    request As IResolverRequest
) As IResolverResultSet

Parameters

request
Type: ActiproSoftware.Text.Languages.DotNet.ResolutionIResolverRequest
The IResolverRequest to process.

Return Value

Type: IResolverResultSet
An IResolverResultSet containing the results.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverRequest Interface

Provides the base requirements of a request for a .NET language resolve operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolverRequest
Public Interface IResolverRequest

The IResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets the IDotNetContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverRequest Properties

The IResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets the IDotNetContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverRequest.Context Property

IResolverRequestContext Property

Gets the IDotNetContext in which the request is based, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDotNetContext Context { get; }
ReadOnly Property Context As IDotNetContext
    Get

Property Value

Type: IDotNetContext
The IDotNetContext in which the request is based, if known.
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverRequest.Expression Property

IResolverRequestExpression Property

Gets the Expression to resolve.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Expression Expression { get; }
ReadOnly Property Expression As Expression
    Get

Property Value

Type: Expression
The Expression to resolve.
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult Interface

Provides the base requirements of a single result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolverResult
Public Interface IResolverResult

The IResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result.
Public property | Name | Gets a name identifying the result.
Public property | Type | Gets a ITypeReference indicating the return type.
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult Properties

The IResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result.
Public property | Name | Gets a name identifying the result.
Public property | Type | Gets a ITypeReference indicating the return type.
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type.
Top
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult.Kind Property

IResolverResultKind Property

Gets the ResolverResultKind indicating the kind of resolver result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ResolverResultKind Kind { get; }
ReadOnly Property Kind As ResolverResultKind
    Get

Property Value

Type: ResolverResultKind
The ResolverResultKind indicating the kind of resolver result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult.Name Property

IResolverResultName Property

Gets a name identifying the result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
A name identifying the result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult.Type Property

IResolverResultType Property

Gets a ITypeReference indicating the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReference Type { get; }
ReadOnly Property Type As ITypeReference
    Get

Property Value

Type: ITypeReference
A ITypeReference indicating the return type.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult.TypeIsInstance Property

IResolverResultTypeIsInstance Property

Gets whether the return Type reference designates an instance of the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool TypeIsInstance { get; }
ReadOnly Property TypeIsInstance As Boolean
    Get

Property Value

Type: Boolean
true if the return Type reference designates an instance of the type; otherwise, false indicating that the reference designates the static type.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultCollection Interface

Provides the base requirements for a collection of IResolverResult objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolverResultCollection : IList<IResolverResult>,
    ICollection<IResolverResult>, IEnumerable<IResolverResult>, IEnumerable
Public Interface IResolverResultCollection
    Inherits IList(Of IResolverResult), ICollection(Of IResolverResult),
    IEnumerable(Of IResolverResult), IEnumerable

The IResolverResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IResolverResult .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IResolverResult .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IResolverResult .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IResolverResult .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IResolverResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IResolverResult .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IResolverResult .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IResolverResult .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IResolverResult .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIResolverResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIResolverResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIResolverResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace
ActiproSoftware.Text.Languages.DotNet.ResolutionIResolverResult


IResolverResultCollection Properties

The IResolverResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IResolverResult .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IResolverResult .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IResolverResult .)
Top
See Also

Reference

IResolverResultCollection Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultCollection Methods

The IResolverResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IResolverResult .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IResolverResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IResolverResult .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IResolverResult .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IResolverResult .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IResolverResult .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIResolverResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIResolverResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIResolverResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IResolverResultCollection Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultSet Interface

Provides the base requirements of a result set from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolverResultSet
Public Interface IResolverResultSet

The IResolverResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of results from the resolution operation.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultSet Properties

The IResolverResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of results from the resolution operation.
Top
See Also

Reference

IResolverResultSet Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultSet.Results Property

IResolverResultSetResults Property

Gets the collection of results from the resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IResolverResultCollection Results { get; }
ReadOnly Property Results As IResolverResultCollection
    Get

Property Value

Type: IResolverResultCollection
The collection of results from the resolution operation.
See Also

Reference

IResolverResultSet Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeMemberResolverResult Interface

Provides the base requirements of a type member result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeMemberResolverResult : IResolverResult
Public Interface ITypeMemberResolverResult
    Inherits IResolverResult

The ITypeMemberResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Member | Gets a ITypeMemberDefinition indicating the member.
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeMemberResolverResult Properties

The ITypeMemberResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Member | Gets a ITypeMemberDefinition indicating the member.
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ITypeMemberResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeMemberResolverResult.Member Property

ITypeMemberResolverResultMember Property

Gets a ITypeMemberDefinition indicating the member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeMemberDefinition Member { get; }
ReadOnly Property Member As ITypeMemberDefinition
    Get

Property Value

Type: ITypeMemberDefinition
A ITypeMemberDefinition indicating the member.
See Also

Reference

ITypeMemberResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeResolverResult Interface

Provides the base requirements of a type result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeResolverResult : IResolverResult
Public Interface ITypeResolverResult
    Inherits IResolverResult

The ITypeResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsBaseTypeReference | Gets whether the type is from a base type reference (e.g. C# 'base' keyword).
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeResolverResult Properties

The ITypeResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsBaseTypeReference | Gets whether the type is from a base type reference (e.g. C# 'base' keyword).
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ITypeResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeResolverResult.TypeIsBaseTypeReference Property

ITypeResolverResultTypeIsBaseTypeReference Property

Gets whether the type is from a base type reference (e.g. C# 'base' keyword).

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool TypeIsBaseTypeReference { get; }
ReadOnly Property TypeIsBaseTypeReference As Boolean
    Get

Property Value

Type: Boolean
true if the type is from a base type reference; otherwise, false.
See Also

Reference

ITypeResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IVariableResolverResult Interface

Provides the base requirements of a local variable result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IVariableResolverResult : IResolverResult
Public Interface IVariableResolverResult
    Inherits IResolverResult

The IVariableResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Public property | Variable | Gets a IVariableDefinition indicating the variable.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IVariableResolverResult Properties

The IVariableResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Public property | Variable | Gets a IVariableDefinition indicating the variable.
Top
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IVariableResolverResult.Variable Property

IVariableResolverResultVariable Property

Gets a IVariableDefinition indicating the variable.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IVariableDefinition Variable { get; }
ReadOnly Property Variable As IVariableDefinition
    Get

Property Value

Type: IVariableDefinition
A IVariableDefinition indicating the variable.
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind Enumeration

Specifies the kind of resolver result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ResolverResultKind
Public Enumeration ResolverResultKind
Members
Member name | Value | Description
Namespace | 0 | The result is an INamespaceResolverResult.
Type | 1 | The result is an ITypeResolverResult.
TypeMember | 2 | The result is an ITypeMemberResolverResult.
Parameter | 3 | The result is an IParameterResolverResult.
Variable | 4 | The result is an IVariableResolverResult.
Other | 5 | The result is an other kind of IResolverResult.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace

Contains the implementation types related to resolution for a .NET syntax language.
Classes
 | Class | Description
Public class | ResolverRequest | Represents a request for a .NET language resolve operation.


ResolverRequest Class

Represents a request for a .NET language resolve operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Resolution.ImplementationResolverRequest

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ResolverRequest : IResolverRequest
Public Class ResolverRequest
    Implements IResolverRequest

The ResolverRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ResolverRequest(Expression) | Initializes a new instance of the ResolverRequest class.
Public method | ResolverRequest(IQualifiedName) | Initializes a new instance of the ResolverRequest class.
Public method | ResolverRequest(QualifiedName) | Initializes a new instance of the ResolverRequest class.
Top
Properties
 | Name | Description
Public property | Context | Gets or sets the IDotNetContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Constructor

Overload List
 | Name | Description
Public method | ResolverRequest(Expression) | Initializes a new instance of the ResolverRequest class.
Public method | ResolverRequest(IQualifiedName) | Initializes a new instance of the ResolverRequest class.
Public method | ResolverRequest(QualifiedName) | Initializes a new instance of the ResolverRequest class.
Top
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Constructor (Expression)

Initializes a new instance of the ResolverRequest class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ResolverRequest(
    Expression expression
)
Public Sub New (
    expression As Expression
)

Parameters

expression
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
The Expression to resolve.
See Also

Reference

ResolverRequest Class
ResolverRequest Overload
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Constructor (IQualifiedName)

Initializes a new instance of the ResolverRequest class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ResolverRequest(
    IQualifiedName qualifiedName
)
Public Sub New (
    qualifiedName As IQualifiedName
)

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIQualifiedName
The IQualifiedName to resolve.
See Also

Reference

ResolverRequest Class
ResolverRequest Overload
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Constructor (QualifiedName)

Initializes a new instance of the ResolverRequest class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ResolverRequest(
    QualifiedName qualifiedName
)
Public Sub New (
    qualifiedName As QualifiedName
)

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
The AST QualifiedName to resolve.
See Also

Reference

ResolverRequest Class
ResolverRequest Overload
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Properties

The ResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets or sets the IDotNetContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest.Context Property

ResolverRequestContext Property

Gets or sets the IDotNetContext in which the request is based, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDotNetContext Context { get; set; }
Public Property Context As IDotNetContext
    Get
    Set

Property Value

Type: IDotNetContext
The IDotNetContext in which the request is based, if known.

Implements

IResolverRequestContext
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest.Expression Property

ResolverRequestExpression Property

Gets the Expression to resolve.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; }
Public ReadOnly Property Expression As Expression
    Get

Property Value

Type: Expression
The Expression to resolve.

Implements

IResolverRequestExpression
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ActiproSoftware.Text.Languages.JavaScript Namespace

Contains the classes related to implementing a JavaScript syntax language.
Interfaces
 | Interface | Description
Public interface | IJavaScriptClassificationTypeProvider | Provides the base requirements of an object that provides IClassificationType objects for the JavaScript language.
Public interface | IJavaScriptGrammarOptions | Contains options for a JavaScript grammar.
Public interface | IJavaScriptParseData | Provides the base requirements of an object that stores the results of a JavaScript language parsing operation.
Public interface | IJavaScriptSymbol | Provides the base requirements of an object that represents a JavaScript symbol.
Public interface | IJavaScriptSymbolTable | Provides the base requirements of an object that represents a JavaScript symbol.
Public interface | IJsonParseData | Provides the base requirements of an object that stores the results of a JSON language parsing operation.
Enumerations
 | Enumeration | Description
Public enumeration | JavaScriptGrammarRootNonTerminal | Specifies the root non-terminal to use for a JavaScript grammar.


IJavaScriptClassificationTypeProvider Interface

Provides the base requirements of an object that provides IClassificationType objects for the JavaScript language.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IJavaScriptClassificationTypeProvider
Public Interface IJavaScriptClassificationTypeProvider

The IJavaScriptClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | String | Gets the String classification type.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider Properties

The IJavaScriptClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | String | Gets the String classification type.
Top
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Comment Property

IJavaScriptClassificationTypeProviderComment Property

Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Comment { get; }
ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Identifier Property

IJavaScriptClassificationTypeProviderIdentifier Property

Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Identifier { get; }
ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Keyword Property

IJavaScriptClassificationTypeProviderKeyword Property

Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Keyword { get; }
ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Number Property

IJavaScriptClassificationTypeProviderNumber Property

Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Number { get; }
ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Operator Property

IJavaScriptClassificationTypeProviderOperator Property

Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Operator { get; }
ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.String Property

IJavaScriptClassificationTypeProviderString Property

Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType String { get; }
ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptGrammarOptions Interface

Contains options for a JavaScript grammar.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IJavaScriptGrammarOptions
Public Interface IJavaScriptGrammarOptions

The IJavaScriptGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptGrammarOptions Properties

The IJavaScriptGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

IJavaScriptGrammarOptions Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptGrammarOptions.RootNonTerminal Property

IJavaScriptGrammarOptionsRootNonTerminal Property

Gets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
JavaScriptGrammarRootNonTerminal RootNonTerminal { get; }
ReadOnly Property RootNonTerminal As JavaScriptGrammarRootNonTerminal
    Get

Property Value

Type: JavaScriptGrammarRootNonTerminal
A JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

IJavaScriptGrammarOptions Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptParseData Interface

Provides the base requirements of an object that stores the results of a JavaScript language parsing operation.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IJavaScriptParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IJavaScriptParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IJavaScriptParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Public property | SymbolTable | Gets the table of symbols located within the document.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParseData


IJavaScriptParseData Properties

The IJavaScriptParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Public property | SymbolTable | Gets the table of symbols located within the document.
Top
See Also

Reference

IJavaScriptParseData Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptParseData.SymbolTable Property

IJavaScriptParseDataSymbolTable Property

Gets the table of symbols located within the document.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IJavaScriptSymbolTable SymbolTable { get; }
ReadOnly Property SymbolTable As IJavaScriptSymbolTable
    Get

Property Value

Type: IJavaScriptSymbolTable
The table of symbols located within the document.
See Also

Reference

IJavaScriptParseData Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbol Interface

Provides the base requirements of an object that represents a JavaScript symbol.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IJavaScriptSymbol
Public Interface IJavaScriptSymbol

The IJavaScriptSymbol type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the symbol name.
Public property | UsageCount | Gets or sets the usage count.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSymbol


IJavaScriptSymbol Properties

The IJavaScriptSymbol type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the symbol name.
Public property | UsageCount | Gets or sets the usage count.
Top
See Also

Reference

IJavaScriptSymbol Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbol.Name Property

IJavaScriptSymbolName Property

Gets the symbol name.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The symbol name.
See Also

Reference

IJavaScriptSymbol Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbol.UsageCount Property

IJavaScriptSymbolUsageCount Property

Gets or sets the usage count.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int UsageCount { get; set; }
Property UsageCount As Integer
    Get
    Set

Property Value

Type: Int32
The usage count.
See Also

Reference

IJavaScriptSymbol Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbolTable Interface

Provides the base requirements of an object that represents a JavaScript symbol.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IJavaScriptSymbolTable
Public Interface IJavaScriptSymbolTable

The IJavaScriptSymbolTable type exposes the following members.

Properties
 | Name | Description
Public property | Symbols | Gets the collection of symbols located within the document.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSymbol


IJavaScriptSymbolTable Properties

The IJavaScriptSymbolTable type exposes the following members.

Properties
 | Name | Description
Public property | Symbols | Gets the collection of symbols located within the document.
Top
See Also

Reference

IJavaScriptSymbolTable Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbolTable.Symbols Property

IJavaScriptSymbolTableSymbols Property

Gets the collection of symbols located within the document.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<IJavaScriptSymbol> Symbols { get; }
ReadOnly Property Symbols As IEnumerable(Of IJavaScriptSymbol)
    Get

Property Value

Type: IEnumerable IJavaScriptSymbol
The collection of symbols located within the document.
See Also

Reference

IJavaScriptSymbolTable Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJsonParseData Interface

Provides the base requirements of an object that stores the results of a JSON language parsing operation.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IJsonParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IJsonParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IJsonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParseData


IJsonParseData Properties

The IJsonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

IJsonParseData Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


JavaScriptGrammarRootNonTerminal Enumeration

Specifies the root non-terminal to use for a JavaScript grammar.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum JavaScriptGrammarRootNonTerminal
Public Enumeration JavaScriptGrammarRootNonTerminal
Members
Member name | Value | Description
CompilationUnit | 0 | Compilation unit (the default).
StatementList | 1 | Statement list.
Statement | 2 | Statement.
Expression | 3 | Expression.
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace


ActiproSoftware.Text.Languages.JavaScript.Ast Namespace

Contains the types related to ASTs for a JavaScript syntax language.
Enumerations
 | Enumeration | Description
Public enumeration | LiteralExpressionKind | Specifies the type of literal expression.
Public enumeration | OperatorKind | Specifies the kind of an operator.


LiteralExpressionKind Enumeration

Specifies the type of literal expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LiteralExpressionKind
Public Enumeration LiteralExpressionKind
Members
Member name | Value | Description
None | 0 | No kind indicated.
Null | 1 | A null value.
Boolean | 2 | A boolean.
DecimalInteger | 3 | A decimal integer.
HexadecimalInteger | 4 | A hexadecimal integer.
Real | 5 | A real number.
SingleQuoteString | 6 | A string of characters.
DoubleQuoteString | 7 | A string of characters.
RegularExpression | 8 | A regular expression.
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind Enumeration

Specifies the kind of an operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum OperatorKind
Public Enumeration OperatorKind
Members
Member name | Value | Description
None | 0 | No valid operator kind.
Addition | 1 | An addition operator.
Subtraction | 2 | A subtraction operator.
Multiplication | 3 | A multiplication operator.
Division | 4 | A division operator.
Modulus | 5 | A modulus operator.
BitwiseAnd | 6 | A bitwise AND operator.
BitwiseOr | 7 | A bitwise OR operator.
ExclusiveOr | 8 | A bitwise XOR operator.
Negation | 9 | A negation operator.
OnesComplement | 10 | A bitwise complement operator.
LessThan | 11 | A less than operator.
GreaterThan | 12 | A greater than operator.
PreIncrement | 13 | An pre-increment operator.
PreDecrement | 14 | An pre-decrement operator.
PostIncrement | 15 | An post-increment operator.
PostDecrement | 16 | An post-decrement operator.
LeftShift | 17 | A left shift operator.
RightShift | 18 | A right shift operator.
ZeroFillRightShift | 19 | A zero fill right shift operator.
ValueEquality | 20 | A value equality operator.
ValueInequality | 21 | A value inequality operator.
StrictValueEquality | 22 | A strict value equality operator.
StrictValueInequality | 23 | A strict value inequality operator.
LessThanOrEqual | 24 | A less than or equal operator.
GreaterThanOrEqual | 25 | A greater than or equal operator.
ConditionalOr | 26 | A conditional OR binary operator.
ConditionalAnd | 27 | A conditional AND binary operator.
InstanceOf | 28 | An operator indicating if an object is of the specified type.
In | 29 | An operator indicating if a property is in an object.
Delete | 30 | An operator that deletes an object, an object's property, or an element at a specified index in an array.
Void | 31 | An operator that specifies an expression to be evaluated without returning a value.
TypeOf | 32 | An operator that returns a string indicating the type of the unevaluated operand.
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace

Contains the implementation types related to ASTs for a JavaScript syntax language.
Classes
 | Class | Description
Public class | Argument | Represents an argument.
Public class | ArrayInitializerExpression | Represents an array initializer expression.
Public class | AssignmentExpression | Represents an assignment expression.
Public class | BinaryOperatorExpression | Represents a binary operator expression.
Public class | BlockStatement | Represents a block statement.
Public class | BreakStatement | Represents a break statement.
Public class | CatchClause | Represents a catch clause.
Public class | CompilationUnit | Represents a compilation unit.
Public class | ConditionalExpression | Represents a conditional expression.
Public class | ContinueStatement | Represents a continue statement.
Public class | DebuggerStatement | Represents a debugger statement.
Public class | DoStatement | Represents a do statement.
Public class | Expression | Represents an expression.
Public class | ExpressionStatement | Represents an expression statement.
Public class | ForEachStatement | Represents a for each statement.
Public class | ForStatement | Represents a for statement.
Public class | FunctionBody | Represents a function body.
Public class | FunctionDeclaration | Represents a function declaration.
Public class | FunctionExpression | Represents a function expression.
Public class | IfStatement | Represents an if statement.
Public class | InstanceExpression | Represents an instance expression.
Public class | InvocationExpression | Represents an invocation expression.
Public class | JavaScriptAstNodeId | Contains the AST node IDs for the JavaScript language.
Public class | LabeledStatement | Represents a labeled statement.
Public class | LiteralExpression | Represents a literal expression.
Public class | MemberAccess | Represents a member access.
Public class | ObjectCreationExpression | Represents an object creation expression.
Public class | ObjectInitializerExpression | Represents an object initializer expression.
Public class | ParameterDeclaration | Represents a parameter declaration.
Public class | ParenthesizedExpression | Represents a parenthesized expression.
Public class | PropertyDeclaration | Represents a property declaration.
Public class | ReturnStatement | Represents a return statement.
Public class | SequenceExpression | Represents a sequence expression.
Public class | SimpleName | Represents a simple name.
Public class | SourceElement | Represents a source element.
Public class | Statement | Represents a statement.
Public class | SwitchSection | Represents a switch section.
Public class | SwitchStatement | Represents a switch statement.
Public class | ThrowStatement | Represents a throw statement.
Public class | TryStatement | Represents a try statement.
Public class | UnaryOperatorExpression | Represents an unary operator expression.
Public class | VariableDeclaration | Represents a variable declaration.
Public class | VariableDeclarationExpression | Represents a variable declaration expression.
Public class | VariableStatement | Represents a variable statement.
Public class | WhileStatement | Represents a while statement.
Public class | WithStatement | Represents a with statement.


Argument Class

Represents an argument.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationArgument

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Argument : AstNodeBase
Public Class Argument
    Inherits AstNodeBase

The Argument type exposes the following members.

Constructors
 | Name | Description
Public method | Argument | Initializes a new instance of the Argument class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument Constructor

Initializes a new instance of the Argument class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Argument()
Public Sub New
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument Properties

The Argument type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument.Expression Property

ArgumentExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument.Id Property

ArgumentId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument Methods

The Argument type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument.GetChildrenEnumerator Method

ArgumentGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression Class

Represents an array initializer expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationArrayInitializerExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ArrayInitializerExpression : Expression
Public Class ArrayInitializerExpression
    Inherits Expression

The ArrayInitializerExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayInitializerExpression | Initializes a new instance of the ArrayInitializerExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializers | Returns whether the Initializers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializers | Gets the initializers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression Constructor

Initializes a new instance of the ArrayInitializerExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ArrayInitializerExpression()
Public Sub New
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression Properties

The ArrayInitializerExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializers | Returns whether the Initializers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializers | Gets the initializers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression.HasInitializers Property

ArrayInitializerExpressionHasInitializers Property

Returns whether the Initializers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasInitializers { get; }
Public ReadOnly Property HasInitializers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression.Id Property

ArrayInitializerExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression.Initializers Property

ArrayInitializerExpressionInitializers Property

Gets the initializers.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Initializers { get; }
Public ReadOnly Property Initializers As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The initializers.
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression Methods

The ArrayInitializerExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression.GetChildrenEnumerator Method

ArrayInitializerExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression Class

Represents an assignment expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationAssignmentExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AssignmentExpression : Expression
Public Class AssignmentExpression
    Inherits Expression

The AssignmentExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AssignmentExpression | Initializes a new instance of the AssignmentExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression Constructor

Initializes a new instance of the AssignmentExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AssignmentExpression()
Public Sub New
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression Properties

The AssignmentExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.Id Property

AssignmentExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.LeftExpression Property

AssignmentExpressionLeftExpression Property

Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.Operator Property

AssignmentExpressionOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.RightExpression Property

AssignmentExpressionRightExpression Property

Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression Methods

The AssignmentExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.GetChildrenEnumerator Method

AssignmentExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression Class

Represents a binary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBinaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BinaryOperatorExpression : Expression
Public Class BinaryOperatorExpression
    Inherits Expression

The BinaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryOperatorExpression | Initializes a new instance of the BinaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression Constructor

Initializes a new instance of the BinaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BinaryOperatorExpression()
Public Sub New
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression Properties

The BinaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.Id Property

BinaryOperatorExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.LeftExpression Property

BinaryOperatorExpressionLeftExpression Property

Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.Operator Property

BinaryOperatorExpressionOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.RightExpression Property

BinaryOperatorExpressionRightExpression Property

Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression Methods

The BinaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.GetChildrenEnumerator Method

BinaryOperatorExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement Class

Represents a block statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBlockStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BlockStatement : Statement
Public Class BlockStatement
    Inherits Statement

The BlockStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BlockStatement | Initializes a new instance of the BlockStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement Constructor

Initializes a new instance of the BlockStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement()
Public Sub New
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement Properties

The BlockStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement.ChildStatements Property

BlockStatementChildStatements Property

Gets the child statements.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> ChildStatements { get; }
Public ReadOnly Property ChildStatements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The child statements.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement.HasChildStatements Property

BlockStatementHasChildStatements Property

Returns whether the ChildStatements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasChildStatements { get; }
Public ReadOnly Property HasChildStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement.Id Property

BlockStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement Methods

The BlockStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement.GetChildrenEnumerator Method

BlockStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement Class

Represents a break statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBreakStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BreakStatement : Statement
Public Class BreakStatement
    Inherits Statement

The BreakStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BreakStatement | Initializes a new instance of the BreakStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement Constructor

Initializes a new instance of the BreakStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BreakStatement()
Public Sub New
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement Properties

The BreakStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement.Id Property

BreakStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement.Label Property

BreakStatementLabel Property

Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Label { get; set; }
Public Property Label As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The label.
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement Methods

The BreakStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement.GetChildrenEnumerator Method

BreakStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause Class

Represents a catch clause.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationCatchClause

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CatchClause : AstNodeBase
Public Class CatchClause
    Inherits AstNodeBase

The CatchClause type exposes the following members.

Constructors
 | Name | Description
Public method | CatchClause | Initializes a new instance of the CatchClause class
Top
Properties
 | Name | Description
Public property | CatchBlock | Gets or sets the catch block.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclaration | Gets or sets the variable declaration.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause Constructor

Initializes a new instance of the CatchClause class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CatchClause()
Public Sub New
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause Properties

The CatchClause type exposes the following members.

Properties
 | Name | Description
Public property | CatchBlock | Gets or sets the catch block.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclaration | Gets or sets the variable declaration.
Top
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause.CatchBlock Property

CatchClauseCatchBlock Property

Gets or sets the catch block.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement CatchBlock { get; set; }
Public Property CatchBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The catch block.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause.Id Property

CatchClauseId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause.VariableDeclaration Property

CatchClauseVariableDeclaration Property

Gets or sets the variable declaration.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VariableDeclaration VariableDeclaration { get; set; }
Public Property VariableDeclaration As VariableDeclaration
    Get
    Set

Property Value

Type: VariableDeclaration
The variable declaration.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause Methods

The CatchClause type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause.GetChildrenEnumerator Method

CatchClauseGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit Class

Represents a compilation unit.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationCompilationUnit

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CompilationUnit : AstNodeBase
Public Class CompilationUnit
    Inherits AstNodeBase

The CompilationUnit type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnit | Initializes a new instance of the CompilationUnit class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSourceElements | Returns whether the SourceElements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | SourceElements | Gets the source elements.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit Constructor

Initializes a new instance of the CompilationUnit class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CompilationUnit()
Public Sub New
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit Properties

The CompilationUnit type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSourceElements | Returns whether the SourceElements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | SourceElements | Gets the source elements.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit.HasSourceElements Property

CompilationUnitHasSourceElements Property

Returns whether the SourceElements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSourceElements { get; }
Public ReadOnly Property HasSourceElements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit.Id Property

CompilationUnitId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit.SourceElements Property

CompilationUnitSourceElements Property

Gets the source elements.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<SourceElement> SourceElements { get; }
Public ReadOnly Property SourceElements As IList(Of SourceElement)
    Get

Property Value

Type: IList SourceElement
The source elements.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit Methods

The CompilationUnit type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit.GetChildrenEnumerator Method

CompilationUnitGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression Class

Represents a conditional expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationConditionalExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ConditionalExpression : Expression
Public Class ConditionalExpression
    Inherits Expression

The ConditionalExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ConditionalExpression | Initializes a new instance of the ConditionalExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression Constructor

Initializes a new instance of the ConditionalExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ConditionalExpression()
Public Sub New
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression Properties

The ConditionalExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.ConditionExpression Property

ConditionalExpressionConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.FalseExpression Property

ConditionalExpressionFalseExpression Property

Gets or sets the false expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression FalseExpression { get; set; }
Public Property FalseExpression As Expression
    Get
    Set

Property Value

Type: Expression
The false expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.Id Property

ConditionalExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.TrueExpression Property

ConditionalExpressionTrueExpression Property

Gets or sets the true expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TrueExpression { get; set; }
Public Property TrueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The true expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression Methods

The ConditionalExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.GetChildrenEnumerator Method

ConditionalExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement Class

Represents a continue statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationContinueStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ContinueStatement : Statement
Public Class ContinueStatement
    Inherits Statement

The ContinueStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ContinueStatement | Initializes a new instance of the ContinueStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement Constructor

Initializes a new instance of the ContinueStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContinueStatement()
Public Sub New
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement Properties

The ContinueStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement.Id Property

ContinueStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement.Label Property

ContinueStatementLabel Property

Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Label { get; set; }
Public Property Label As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The label.
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement Methods

The ContinueStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement.GetChildrenEnumerator Method

ContinueStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement Class

Represents a debugger statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationDebuggerStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DebuggerStatement : Statement
Public Class DebuggerStatement
    Inherits Statement

The DebuggerStatement type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerStatement | Initializes a new instance of the DebuggerStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement Constructor

Initializes a new instance of the DebuggerStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DebuggerStatement()
Public Sub New
See Also

Reference

DebuggerStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement Properties

The DebuggerStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DebuggerStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement.Id Property

DebuggerStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DebuggerStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement Methods

The DebuggerStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DebuggerStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement Class

Represents a do statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationDoStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoStatement : Statement
Public Class DoStatement
    Inherits Statement

The DoStatement type exposes the following members.

Constructors
 | Name | Description
Public method | DoStatement | Initializes a new instance of the DoStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement Constructor

Initializes a new instance of the DoStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoStatement()
Public Sub New
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement Properties

The DoStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement.ChildStatement Property

DoStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement.ConditionExpression Property

DoStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement.Id Property

DoStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement Methods

The DoStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement.GetChildrenEnumerator Method

DoStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Expression Class

Represents an expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
More...

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Expression : AstNodeBase
Public Class Expression
    Inherits AstNodeBase

The Expression type exposes the following members.

Constructors
 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationArrayInitializerExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationAssignmentExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBinaryOperatorExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationConditionalExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationInstanceExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationInvocationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationLiteralExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationMemberAccess
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationObjectCreationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationObjectInitializerExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationParenthesizedExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSequenceExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSimpleName
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationUnaryOperatorExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableDeclarationExpression


Expression Constructor

Initializes a new instance of the Expression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression()
Public Sub New
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Expression Properties

The Expression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Expression.Id Property

ExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Expression Methods

The Expression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement Class

Represents an expression statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpressionStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExpressionStatement : Statement
Public Class ExpressionStatement
    Inherits Statement

The ExpressionStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionStatement | Initializes a new instance of the ExpressionStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement Constructor

Initializes a new instance of the ExpressionStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpressionStatement()
Public Sub New
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement Properties

The ExpressionStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement.Expression Property

ExpressionStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement.Id Property

ExpressionStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement Methods

The ExpressionStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement.GetChildrenEnumerator Method

ExpressionStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement Class

Represents a for each statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationForEachStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ForEachStatement : Statement
Public Class ForEachStatement
    Inherits Statement

The ForEachStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForEachStatement | Initializes a new instance of the ForEachStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement Constructor

Initializes a new instance of the ForEachStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ForEachStatement()
Public Sub New
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement Properties

The ForEachStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.ChildStatement Property

ForEachStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.ElementExpression Property

ForEachStatementElementExpression Property

Gets or sets the element expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ElementExpression { get; set; }
Public Property ElementExpression As Expression
    Get
    Set

Property Value

Type: Expression
The element expression.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.EnumerableExpression Property

ForEachStatementEnumerableExpression Property

Gets or sets the enumerable expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression EnumerableExpression { get; set; }
Public Property EnumerableExpression As Expression
    Get
    Set

Property Value

Type: Expression
The enumerable expression.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.Id Property

ForEachStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement Methods

The ForEachStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.GetChildrenEnumerator Method

ForEachStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement Class

Represents a for statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationForStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ForStatement : Statement
Public Class ForStatement
    Inherits Statement

The ForStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForStatement | Initializes a new instance of the ForStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | InitializerExpression | Gets or sets the initializer expression.
Public property | IteratorExpression | Gets or sets the iterator expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement Constructor

Initializes a new instance of the ForStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ForStatement()
Public Sub New
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement Properties

The ForStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | InitializerExpression | Gets or sets the initializer expression.
Public property | IteratorExpression | Gets or sets the iterator expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.ChildStatement Property

ForStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.ConditionExpression Property

ForStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.Id Property

ForStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.InitializerExpression Property

ForStatementInitializerExpression Property

Gets or sets the initializer expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression InitializerExpression { get; set; }
Public Property InitializerExpression As Expression
    Get
    Set

Property Value

Type: Expression
The initializer expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.IteratorExpression Property

ForStatementIteratorExpression Property

Gets or sets the iterator expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression IteratorExpression { get; set; }
Public Property IteratorExpression As Expression
    Get
    Set

Property Value

Type: Expression
The iterator expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement Methods

The ForStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.GetChildrenEnumerator Method

ForStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody Class

Represents a function body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionBody

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FunctionBody : AstNodeBase
Public Class FunctionBody
    Inherits AstNodeBase

The FunctionBody type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionBody | Initializes a new instance of the FunctionBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSourceElements | Returns whether the SourceElements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | SourceElements | Gets the source elements.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody Constructor

Initializes a new instance of the FunctionBody class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FunctionBody()
Public Sub New
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody Properties

The FunctionBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSourceElements | Returns whether the SourceElements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | SourceElements | Gets the source elements.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody.HasSourceElements Property

FunctionBodyHasSourceElements Property

Returns whether the SourceElements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSourceElements { get; }
Public ReadOnly Property HasSourceElements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody.Id Property

FunctionBodyId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody.SourceElements Property

FunctionBodySourceElements Property

Gets the source elements.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<SourceElement> SourceElements { get; }
Public ReadOnly Property SourceElements As IList(Of SourceElement)
    Get

Property Value

Type: IList SourceElement
The source elements.
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody Methods

The FunctionBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody.GetChildrenEnumerator Method

FunctionBodyGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration Class

Represents a function declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionDeclaration

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FunctionDeclaration : SourceElement
Public Class FunctionDeclaration
    Inherits SourceElement

The FunctionDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionDeclaration | Initializes a new instance of the FunctionDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides SourceElementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration Constructor

Initializes a new instance of the FunctionDeclaration class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FunctionDeclaration()
Public Sub New
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration Properties

The FunctionDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides SourceElementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.Body Property

FunctionDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FunctionBody Body { get; set; }
Public Property Body As FunctionBody
    Get
    Set

Property Value

Type: FunctionBody
The body.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.HasParameters Property

FunctionDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.Id Property

FunctionDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.Name Property

FunctionDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.Parameters Property

FunctionDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration Methods

The FunctionDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.GetChildrenEnumerator Method

FunctionDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression Class

Represents a function expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FunctionExpression : Expression
Public Class FunctionExpression
    Inherits Expression

The FunctionExpression type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionExpression | Initializes a new instance of the FunctionExpression class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression Constructor

Initializes a new instance of the FunctionExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FunctionExpression()
Public Sub New
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression Properties

The FunctionExpression type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.Body Property

FunctionExpressionBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FunctionBody Body { get; set; }
Public Property Body As FunctionBody
    Get
    Set

Property Value

Type: FunctionBody
The body.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.HasParameters Property

FunctionExpressionHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.Id Property

FunctionExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.Name Property

FunctionExpressionName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.Parameters Property

FunctionExpressionParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression Methods

The FunctionExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.GetChildrenEnumerator Method

FunctionExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement Class

Represents an if statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationIfStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class IfStatement : Statement
Public Class IfStatement
    Inherits Statement

The IfStatement type exposes the following members.

Constructors
 | Name | Description
Public method | IfStatement | Initializes a new instance of the IfStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseStatement | Gets or sets the false statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueStatement | Gets or sets the true statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement Constructor

Initializes a new instance of the IfStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IfStatement()
Public Sub New
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement Properties

The IfStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseStatement | Gets or sets the false statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueStatement | Gets or sets the true statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.ConditionExpression Property

IfStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.FalseStatement Property

IfStatementFalseStatement Property

Gets or sets the false statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement FalseStatement { get; set; }
Public Property FalseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The false statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.Id Property

IfStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.TrueStatement Property

IfStatementTrueStatement Property

Gets or sets the true statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement TrueStatement { get; set; }
Public Property TrueStatement As Statement
    Get
    Set

Property Value

Type: Statement
The true statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement Methods

The IfStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.GetChildrenEnumerator Method

IfStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression Class

Represents an instance expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationInstanceExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InstanceExpression : Expression
Public Class InstanceExpression
    Inherits Expression

The InstanceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InstanceExpression | Initializes a new instance of the InstanceExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression Constructor

Initializes a new instance of the InstanceExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InstanceExpression()
Public Sub New
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression Properties

The InstanceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression.Id Property

InstanceExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression Methods

The InstanceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression Class

Represents an invocation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationInvocationExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InvocationExpression : Expression
Public Class InvocationExpression
    Inherits Expression

The InvocationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InvocationExpression | Initializes a new instance of the InvocationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression Constructor

Initializes a new instance of the InvocationExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvocationExpression()
Public Sub New
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression Properties

The InvocationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.Arguments Property

InvocationExpressionArguments Property

Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.HasArguments Property

InvocationExpressionHasArguments Property

Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.Id Property

InvocationExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.TargetExpression Property

InvocationExpressionTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression Methods

The InvocationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.GetChildrenEnumerator Method

InvocationExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Class

Contains the AST node IDs for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationJavaScriptAstNodeId

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptAstNodeId : AstNodeIdProviderBase
Public Class JavaScriptAstNodeId
    Inherits AstNodeIdProviderBase

The JavaScriptAstNodeId type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptAstNodeId | Initializes a new instance of the JavaScriptAstNodeId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Top
Fields
Name | Description
Argument | Gets the Argument AST node ID.
ArrayInitializerExpression | Gets the ArrayInitializerExpression AST node ID.
AssignmentExpression | Gets the AssignmentExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
CatchClause | Gets the CatchClause AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DebuggerStatement | Gets the DebuggerStatement AST node ID.
DoStatement | Gets the DoStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ForEachStatement | Gets the ForEachStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FunctionBody | Gets the FunctionBody AST node ID.
FunctionDeclaration | Gets the FunctionDeclaration AST node ID.
FunctionExpression | Gets the FunctionExpression AST node ID.
IfStatement | Gets the IfStatement AST node ID.
InstanceExpression | Gets the InstanceExpression AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
LabeledStatement | Gets the LabeledStatement AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
MemberAccess | Gets the MemberAccess AST node ID.
ObjectCreationExpression | Gets the ObjectCreationExpression AST node ID.
ObjectInitializerExpression | Gets the ObjectInitializerExpression AST node ID.
ParameterDeclaration | Gets the ParameterDeclaration AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PropertyDeclaration | Gets the PropertyDeclaration AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
SequenceExpression | Gets the SequenceExpression AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SourceElement | Gets the SourceElement AST node ID.
Statement | Gets the Statement AST node ID.
SwitchSection | Gets the SwitchSection AST node ID.
SwitchStatement | Gets the SwitchStatement AST node ID.
ThrowStatement | Gets the ThrowStatement AST node ID.
TryStatement | Gets the TryStatement AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
VariableDeclaration | Gets the VariableDeclaration AST node ID.
VariableDeclarationExpression | Gets the VariableDeclarationExpression AST node ID.
VariableStatement | Gets the VariableStatement AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Constructor

Initializes a new instance of the JavaScriptAstNodeId class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptAstNodeId()
Public Sub New
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Properties

The JavaScriptAstNodeId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.MaxId Property

JavaScriptAstNodeIdMaxId Property

Gets the maximum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum AST node ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.MinId Property

JavaScriptAstNodeIdMinId Property

Gets the minimum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum AST node ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Methods

The JavaScriptAstNodeId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Top
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ContainsId Method

JavaScriptAstNodeIdContainsId Method

Returns whether the specified ID value is valid for this AST node ID provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.GetDescription Method

JavaScriptAstNodeIdGetDescription Method

Returns the actual string representation for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The actual string representation for the specified AST node ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.GetKey Method

JavaScriptAstNodeIdGetKey Method

Returns the string-based key for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The string-based key for the specified AST node ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Fields

The JavaScriptAstNodeId type exposes the following members.

Fields
Name | Description
Argument | Gets the Argument AST node ID.
ArrayInitializerExpression | Gets the ArrayInitializerExpression AST node ID.
AssignmentExpression | Gets the AssignmentExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
CatchClause | Gets the CatchClause AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DebuggerStatement | Gets the DebuggerStatement AST node ID.
DoStatement | Gets the DoStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ForEachStatement | Gets the ForEachStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FunctionBody | Gets the FunctionBody AST node ID.
FunctionDeclaration | Gets the FunctionDeclaration AST node ID.
FunctionExpression | Gets the FunctionExpression AST node ID.
IfStatement | Gets the IfStatement AST node ID.
InstanceExpression | Gets the InstanceExpression AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
LabeledStatement | Gets the LabeledStatement AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
MemberAccess | Gets the MemberAccess AST node ID.
ObjectCreationExpression | Gets the ObjectCreationExpression AST node ID.
ObjectInitializerExpression | Gets the ObjectInitializerExpression AST node ID.
ParameterDeclaration | Gets the ParameterDeclaration AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PropertyDeclaration | Gets the PropertyDeclaration AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
SequenceExpression | Gets the SequenceExpression AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SourceElement | Gets the SourceElement AST node ID.
Statement | Gets the Statement AST node ID.
SwitchSection | Gets the SwitchSection AST node ID.
SwitchStatement | Gets the SwitchStatement AST node ID.
ThrowStatement | Gets the ThrowStatement AST node ID.
TryStatement | Gets the TryStatement AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
VariableDeclaration | Gets the VariableDeclaration AST node ID.
VariableDeclarationExpression | Gets the VariableDeclarationExpression AST node ID.
VariableStatement | Gets the VariableStatement AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
Top
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.Argument Field

JavaScriptAstNodeIdArgument Field

Gets the Argument AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Argument = 13001
Public Const Argument As Integer = 13001

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ArrayInitializerExpression Field

JavaScriptAstNodeIdArrayInitializerExpression Field

Gets the ArrayInitializerExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ArrayInitializerExpression = 13002
Public Const ArrayInitializerExpression As Integer = 13002

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.AssignmentExpression Field

JavaScriptAstNodeIdAssignmentExpression Field

Gets the AssignmentExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AssignmentExpression = 13000
Public Const AssignmentExpression As Integer = 13000

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.BinaryOperatorExpression Field

JavaScriptAstNodeIdBinaryOperatorExpression Field

Gets the BinaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BinaryOperatorExpression = 13003
Public Const BinaryOperatorExpression As Integer = 13003

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.BlockStatement Field

JavaScriptAstNodeIdBlockStatement Field

Gets the BlockStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BlockStatement = 13004
Public Const BlockStatement As Integer = 13004

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.BreakStatement Field

JavaScriptAstNodeIdBreakStatement Field

Gets the BreakStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BreakStatement = 13005
Public Const BreakStatement As Integer = 13005

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.CatchClause Field

JavaScriptAstNodeIdCatchClause Field

Gets the CatchClause AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CatchClause = 13006
Public Const CatchClause As Integer = 13006

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.CompilationUnit Field

JavaScriptAstNodeIdCompilationUnit Field

Gets the CompilationUnit AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CompilationUnit = 13007
Public Const CompilationUnit As Integer = 13007

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ConditionalExpression Field

JavaScriptAstNodeIdConditionalExpression Field

Gets the ConditionalExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ConditionalExpression = 13008
Public Const ConditionalExpression As Integer = 13008

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ContinueStatement Field

JavaScriptAstNodeIdContinueStatement Field

Gets the ContinueStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContinueStatement = 13009
Public Const ContinueStatement As Integer = 13009

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.DebuggerStatement Field

JavaScriptAstNodeIdDebuggerStatement Field

Gets the DebuggerStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DebuggerStatement = 13010
Public Const DebuggerStatement As Integer = 13010

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.DoStatement Field

JavaScriptAstNodeIdDoStatement Field

Gets the DoStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DoStatement = 13011
Public Const DoStatement As Integer = 13011

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.Expression Field

JavaScriptAstNodeIdExpression Field

Gets the Expression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Expression = 13012
Public Const Expression As Integer = 13012

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ExpressionStatement Field

JavaScriptAstNodeIdExpressionStatement Field

Gets the ExpressionStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ExpressionStatement = 13013
Public Const ExpressionStatement As Integer = 13013

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ForEachStatement Field

JavaScriptAstNodeIdForEachStatement Field

Gets the ForEachStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ForEachStatement = 13014
Public Const ForEachStatement As Integer = 13014

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ForStatement Field

JavaScriptAstNodeIdForStatement Field

Gets the ForStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ForStatement = 13015
Public Const ForStatement As Integer = 13015

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.FunctionBody Field

JavaScriptAstNodeIdFunctionBody Field

Gets the FunctionBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FunctionBody = 13016
Public Const FunctionBody As Integer = 13016

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.FunctionDeclaration Field

JavaScriptAstNodeIdFunctionDeclaration Field

Gets the FunctionDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FunctionDeclaration = 13017
Public Const FunctionDeclaration As Integer = 13017

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.FunctionExpression Field

JavaScriptAstNodeIdFunctionExpression Field

Gets the FunctionExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FunctionExpression = 13018
Public Const FunctionExpression As Integer = 13018

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.IfStatement Field

JavaScriptAstNodeIdIfStatement Field

Gets the IfStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int IfStatement = 13019
Public Const IfStatement As Integer = 13019

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.InstanceExpression Field

JavaScriptAstNodeIdInstanceExpression Field

Gets the InstanceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InstanceExpression = 13020
Public Const InstanceExpression As Integer = 13020

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.InvocationExpression Field

JavaScriptAstNodeIdInvocationExpression Field

Gets the InvocationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InvocationExpression = 13021
Public Const InvocationExpression As Integer = 13021

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.LabeledStatement Field

JavaScriptAstNodeIdLabeledStatement Field

Gets the LabeledStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LabeledStatement = 13022
Public Const LabeledStatement As Integer = 13022

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.LiteralExpression Field

JavaScriptAstNodeIdLiteralExpression Field

Gets the LiteralExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralExpression = 13023
Public Const LiteralExpression As Integer = 13023

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.MemberAccess Field

JavaScriptAstNodeIdMemberAccess Field

Gets the MemberAccess AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int MemberAccess = 13024
Public Const MemberAccess As Integer = 13024

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ObjectCreationExpression Field

JavaScriptAstNodeIdObjectCreationExpression Field

Gets the ObjectCreationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ObjectCreationExpression = 13025
Public Const ObjectCreationExpression As Integer = 13025

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ObjectInitializerExpression Field

JavaScriptAstNodeIdObjectInitializerExpression Field

Gets the ObjectInitializerExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ObjectInitializerExpression = 13026
Public Const ObjectInitializerExpression As Integer = 13026

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ParameterDeclaration Field

JavaScriptAstNodeIdParameterDeclaration Field

Gets the ParameterDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ParameterDeclaration = 13027
Public Const ParameterDeclaration As Integer = 13027

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ParenthesizedExpression Field

JavaScriptAstNodeIdParenthesizedExpression Field

Gets the ParenthesizedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ParenthesizedExpression = 13028
Public Const ParenthesizedExpression As Integer = 13028

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.PropertyDeclaration Field

JavaScriptAstNodeIdPropertyDeclaration Field

Gets the PropertyDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PropertyDeclaration = 13029
Public Const PropertyDeclaration As Integer = 13029

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ReturnStatement Field

JavaScriptAstNodeIdReturnStatement Field

Gets the ReturnStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReturnStatement = 13030
Public Const ReturnStatement As Integer = 13030

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SequenceExpression Field

JavaScriptAstNodeIdSequenceExpression Field

Gets the SequenceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SequenceExpression = 13031
Public Const SequenceExpression As Integer = 13031

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SimpleName Field

JavaScriptAstNodeIdSimpleName Field

Gets the SimpleName AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SimpleName = 13032
Public Const SimpleName As Integer = 13032

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SourceElement Field

JavaScriptAstNodeIdSourceElement Field

Gets the SourceElement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SourceElement = 13033
Public Const SourceElement As Integer = 13033

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.Statement Field

JavaScriptAstNodeIdStatement Field

Gets the Statement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Statement = 13034
Public Const Statement As Integer = 13034

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SwitchSection Field

JavaScriptAstNodeIdSwitchSection Field

Gets the SwitchSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SwitchSection = 13035
Public Const SwitchSection As Integer = 13035

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SwitchStatement Field

JavaScriptAstNodeIdSwitchStatement Field

Gets the SwitchStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SwitchStatement = 13036
Public Const SwitchStatement As Integer = 13036

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ThrowStatement Field

JavaScriptAstNodeIdThrowStatement Field

Gets the ThrowStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ThrowStatement = 13037
Public Const ThrowStatement As Integer = 13037

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.TryStatement Field

JavaScriptAstNodeIdTryStatement Field

Gets the TryStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TryStatement = 13038
Public Const TryStatement As Integer = 13038

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.UnaryOperatorExpression Field

JavaScriptAstNodeIdUnaryOperatorExpression Field

Gets the UnaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UnaryOperatorExpression = 13039
Public Const UnaryOperatorExpression As Integer = 13039

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.VariableDeclaration Field

JavaScriptAstNodeIdVariableDeclaration Field

Gets the VariableDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int VariableDeclaration = 13040
Public Const VariableDeclaration As Integer = 13040

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.VariableDeclarationExpression Field

JavaScriptAstNodeIdVariableDeclarationExpression Field

Gets the VariableDeclarationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int VariableDeclarationExpression = 13041
Public Const VariableDeclarationExpression As Integer = 13041

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.VariableStatement Field

JavaScriptAstNodeIdVariableStatement Field

Gets the VariableStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int VariableStatement = 13042
Public Const VariableStatement As Integer = 13042

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.WhileStatement Field

JavaScriptAstNodeIdWhileStatement Field

Gets the WhileStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int WhileStatement = 13043
Public Const WhileStatement As Integer = 13043

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.WithStatement Field

JavaScriptAstNodeIdWithStatement Field

Gets the WithStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int WithStatement = 13044
Public Const WithStatement As Integer = 13044

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement Class

Represents a labeled statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationLabeledStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LabeledStatement : Statement
Public Class LabeledStatement
    Inherits Statement

The LabeledStatement type exposes the following members.

Constructors
 | Name | Description
Public method | LabeledStatement | Initializes a new instance of the LabeledStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement Constructor

Initializes a new instance of the LabeledStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LabeledStatement()
Public Sub New
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement Properties

The LabeledStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement.ChildStatement Property

LabeledStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement.Id Property

LabeledStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement.Label Property

LabeledStatementLabel Property

Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Label { get; set; }
Public Property Label As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The label.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement Methods

The LabeledStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement.GetChildrenEnumerator Method

LabeledStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression Class

Represents a literal expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationLiteralExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LiteralExpression : Expression
Public Class LiteralExpression
    Inherits Expression

The LiteralExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LiteralExpression | Initializes a new instance of the LiteralExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind of literal.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression Constructor

Initializes a new instance of the LiteralExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LiteralExpression()
Public Sub New
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression Properties

The LiteralExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind of literal.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression.Id Property

LiteralExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression.Kind Property

LiteralExpressionKind Property

Gets or sets the kind of literal.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LiteralExpressionKind Kind { get; set; }
Public Property Kind As LiteralExpressionKind
    Get
    Set

Property Value

Type: LiteralExpressionKind
The kind of literal.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression.StringValue Property

LiteralExpressionStringValue Property

Gets or sets the string value.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string StringValue { get; set; }
Public Property StringValue As String
    Get
    Set

Property Value

Type: String
The string value.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression Methods

The LiteralExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess Class

Represents a member access.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationMemberAccess

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MemberAccess : Expression
Public Class MemberAccess
    Inherits Expression

The MemberAccess type exposes the following members.

Constructors
 | Name | Description
Public method | MemberAccess | Initializes a new instance of the MemberAccess class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess Constructor

Initializes a new instance of the MemberAccess class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MemberAccess()
Public Sub New
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess Properties

The MemberAccess type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess.Id Property

MemberAccessId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess.Name Property

MemberAccessName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Name { get; set; }
Public Property Name As Expression
    Get
    Set

Property Value

Type: Expression
The name.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess.TargetExpression Property

MemberAccessTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess Methods

The MemberAccess type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess.GetChildrenEnumerator Method

MemberAccessGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression Class

Represents an object creation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationObjectCreationExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ObjectCreationExpression : Expression
Public Class ObjectCreationExpression
    Inherits Expression

The ObjectCreationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectCreationExpression | Initializes a new instance of the ObjectCreationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression Constructor

Initializes a new instance of the ObjectCreationExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObjectCreationExpression()
Public Sub New
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression Properties

The ObjectCreationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.Arguments Property

ObjectCreationExpressionArguments Property

Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.HasArguments Property

ObjectCreationExpressionHasArguments Property

Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.Id Property

ObjectCreationExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.Type Property

ObjectCreationExpressionType Property

Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Type { get; set; }
Public Property Type As Expression
    Get
    Set

Property Value

Type: Expression
The type.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression Methods

The ObjectCreationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.GetChildrenEnumerator Method

ObjectCreationExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression Class

Represents an object initializer expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationObjectInitializerExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ObjectInitializerExpression : Expression
Public Class ObjectInitializerExpression
    Inherits Expression

The ObjectInitializerExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectInitializerExpression | Initializes a new instance of the ObjectInitializerExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression Constructor

Initializes a new instance of the ObjectInitializerExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObjectInitializerExpression()
Public Sub New
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression Properties

The ObjectInitializerExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression.HasMembers Property

ObjectInitializerExpressionHasMembers Property

Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression.Id Property

ObjectInitializerExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression.Members Property

ObjectInitializerExpressionMembers Property

Gets the members.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<PropertyDeclaration> Members { get; }
Public ReadOnly Property Members As IList(Of PropertyDeclaration)
    Get

Property Value

Type: IList PropertyDeclaration
The members.
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression Methods

The ObjectInitializerExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression.GetChildrenEnumerator Method

ObjectInitializerExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration Class

Represents a parameter declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationParameterDeclaration

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParameterDeclaration : AstNodeBase
Public Class ParameterDeclaration
    Inherits AstNodeBase

The ParameterDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterDeclaration | Initializes a new instance of the ParameterDeclaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration Constructor

Initializes a new instance of the ParameterDeclaration class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParameterDeclaration()
Public Sub New
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration Properties

The ParameterDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration.Id Property

ParameterDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration.Name Property

ParameterDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration Methods

The ParameterDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration.GetChildrenEnumerator Method

ParameterDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression Class

Represents a parenthesized expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationParenthesizedExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParenthesizedExpression : Expression
Public Class ParenthesizedExpression
    Inherits Expression

The ParenthesizedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ParenthesizedExpression | Initializes a new instance of the ParenthesizedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression Constructor

Initializes a new instance of the ParenthesizedExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParenthesizedExpression()
Public Sub New
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression Properties

The ParenthesizedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression.ChildExpression Property

ParenthesizedExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression.Id Property

ParenthesizedExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression Methods

The ParenthesizedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression.GetChildrenEnumerator Method

ParenthesizedExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration Class

Represents a property declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationPropertyDeclaration

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyDeclaration : AstNodeBase
Public Class PropertyDeclaration
    Inherits AstNodeBase

The PropertyDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDeclaration | Initializes a new instance of the PropertyDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration Constructor

Initializes a new instance of the PropertyDeclaration class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyDeclaration()
Public Sub New
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration Properties

The PropertyDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Body Property

PropertyDeclarationBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FunctionBody Body { get; set; }
Public Property Body As FunctionBody
    Get
    Set

Property Value

Type: FunctionBody
The body.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.HasParameters Property

PropertyDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Id Property

PropertyDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Initializer Property

PropertyDeclarationInitializer Property

Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Name Property

PropertyDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Name { get; set; }
Public Property Name As Expression
    Get
    Set

Property Value

Type: Expression
The name.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Parameters Property

PropertyDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration Methods

The PropertyDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.GetChildrenEnumerator Method

PropertyDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement Class

Represents a return statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationReturnStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReturnStatement : Statement
Public Class ReturnStatement
    Inherits Statement

The ReturnStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnStatement | Initializes a new instance of the ReturnStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement Constructor

Initializes a new instance of the ReturnStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnStatement()
Public Sub New
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement Properties

The ReturnStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement.Expression Property

ReturnStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement.Id Property

ReturnStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement Methods

The ReturnStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement.GetChildrenEnumerator Method

ReturnStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression Class

Represents a sequence expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSequenceExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SequenceExpression : Expression
Public Class SequenceExpression
    Inherits Expression

The SequenceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SequenceExpression | Initializes a new instance of the SequenceExpression class
Top
Properties
 | Name | Description
Public property | ChildExpressions | Gets the child expressions.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildExpressions | Returns whether the ChildExpressions collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression Constructor

Initializes a new instance of the SequenceExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SequenceExpression()
Public Sub New
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression Properties

The SequenceExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpressions | Gets the child expressions.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildExpressions | Returns whether the ChildExpressions collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression.ChildExpressions Property

SequenceExpressionChildExpressions Property

Gets the child expressions.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> ChildExpressions { get; }
Public ReadOnly Property ChildExpressions As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The child expressions.
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression.HasChildExpressions Property

SequenceExpressionHasChildExpressions Property

Returns whether the ChildExpressions collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasChildExpressions { get; }
Public ReadOnly Property HasChildExpressions As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression.Id Property

SequenceExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression Methods

The SequenceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression.GetChildrenEnumerator Method

SequenceExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Class

Represents a simple name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSimpleName

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SimpleName : Expression
Public Class SimpleName
    Inherits Expression

The SimpleName type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String) | Initializes a new instance of the SimpleName class.
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text value of the identifier.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Constructor

Overload List
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String) | Initializes a new instance of the SimpleName class.
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Constructor

Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName()
Public Sub New
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Constructor (String)

Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text value of the identifier.
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Properties

The SimpleName type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text value of the identifier.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName.Id Property

SimpleNameId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName.Text Property

SimpleNameText Property

Gets or sets the text value of the identifier.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text value of the identifier.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Methods

The SimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement Class

Represents a source element.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionDeclaration
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SourceElement : AstNodeBase
Public Class SourceElement
    Inherits AstNodeBase

The SourceElement type exposes the following members.

Constructors
 | Name | Description
Public method | SourceElement | Initializes a new instance of the SourceElement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement Constructor

Initializes a new instance of the SourceElement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SourceElement()
Public Sub New
See Also

Reference

SourceElement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement Properties

The SourceElement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SourceElement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement.Id Property

SourceElementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SourceElement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement Methods

The SourceElement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SourceElement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Statement Class

Represents a statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
More...

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Statement : SourceElement
Public Class Statement
    Inherits SourceElement

The Statement type exposes the following members.

Constructors
 | Name | Description
Public method | Statement | Initializes a new instance of the Statement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides SourceElementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBlockStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBreakStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationContinueStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationDebuggerStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationDoStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpressionStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationForEachStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationForStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationIfStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationLabeledStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationReturnStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSwitchStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationThrowStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationTryStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationWhileStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationWithStatement


Statement Constructor

Initializes a new instance of the Statement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement()
Public Sub New
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Statement Properties

The Statement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides SourceElementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Statement.Id Property

StatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Statement Methods

The Statement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection Class

Represents a switch section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSwitchSection

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SwitchSection : AstNodeBase
Public Class SwitchSection
    Inherits AstNodeBase

The SwitchSection type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchSection | Initializes a new instance of the SwitchSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasLabels | Returns whether the Labels collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Labels | Gets the labels.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection Constructor

Initializes a new instance of the SwitchSection class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SwitchSection()
Public Sub New
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection Properties

The SwitchSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasLabels | Returns whether the Labels collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Labels | Gets the labels.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.HasLabels Property

SwitchSectionHasLabels Property

Returns whether the Labels collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasLabels { get; }
Public ReadOnly Property HasLabels As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.HasStatements Property

SwitchSectionHasStatements Property

Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.Id Property

SwitchSectionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.Labels Property

SwitchSectionLabels Property

Gets the labels.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Labels { get; }
Public ReadOnly Property Labels As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The labels.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.Statements Property

SwitchSectionStatements Property

Gets the statements.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection Methods

The SwitchSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.GetChildrenEnumerator Method

SwitchSectionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement Class

Represents a switch statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSwitchStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SwitchStatement : Statement
Public Class SwitchStatement
    Inherits Statement

The SwitchStatement type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchStatement | Initializes a new instance of the SwitchStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSections | Returns whether the Sections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | Sections | Gets the sections.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement Constructor

Initializes a new instance of the SwitchStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SwitchStatement()
Public Sub New
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement Properties

The SwitchStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSections | Returns whether the Sections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | Sections | Gets the sections.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.Expression Property

SwitchStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.HasSections Property

SwitchStatementHasSections Property

Returns whether the Sections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSections { get; }
Public ReadOnly Property HasSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.Id Property

SwitchStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.Sections Property

SwitchStatementSections Property

Gets the sections.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<SwitchSection> Sections { get; }
Public ReadOnly Property Sections As IList(Of SwitchSection)
    Get

Property Value

Type: IList SwitchSection
The sections.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement Methods

The SwitchStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.GetChildrenEnumerator Method

SwitchStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement Class

Represents a throw statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationThrowStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ThrowStatement : Statement
Public Class ThrowStatement
    Inherits Statement

The ThrowStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ThrowStatement | Initializes a new instance of the ThrowStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement Constructor

Initializes a new instance of the ThrowStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ThrowStatement()
Public Sub New
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement Properties

The ThrowStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement.Expression Property

ThrowStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement.Id Property

ThrowStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement Methods

The ThrowStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement.GetChildrenEnumerator Method

ThrowStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement Class

Represents a try statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationTryStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TryStatement : Statement
Public Class TryStatement
    Inherits Statement

The TryStatement type exposes the following members.

Constructors
 | Name | Description
Public method | TryStatement | Initializes a new instance of the TryStatement class
Top
Properties
 | Name | Description
Public property | CatchClauses | Gets the catch clauses.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FinallyBlock | Gets or sets the finally block.
Public property | HasCatchClauses | Returns whether the CatchClauses collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TryBlock | Gets or sets the try block.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement Constructor

Initializes a new instance of the TryStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TryStatement()
Public Sub New
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement Properties

The TryStatement type exposes the following members.

Properties
 | Name | Description
Public property | CatchClauses | Gets the catch clauses.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FinallyBlock | Gets or sets the finally block.
Public property | HasCatchClauses | Returns whether the CatchClauses collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TryBlock | Gets or sets the try block.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.CatchClauses Property

TryStatementCatchClauses Property

Gets the catch clauses.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<CatchClause> CatchClauses { get; }
Public ReadOnly Property CatchClauses As IList(Of CatchClause)
    Get

Property Value

Type: IList CatchClause
The catch clauses.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.FinallyBlock Property

TryStatementFinallyBlock Property

Gets or sets the finally block.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement FinallyBlock { get; set; }
Public Property FinallyBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The finally block.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.HasCatchClauses Property

TryStatementHasCatchClauses Property

Returns whether the CatchClauses collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasCatchClauses { get; }
Public ReadOnly Property HasCatchClauses As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.Id Property

TryStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.TryBlock Property

TryStatementTryBlock Property

Gets or sets the try block.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement TryBlock { get; set; }
Public Property TryBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The try block.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement Methods

The TryStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.GetChildrenEnumerator Method

TryStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression Class

Represents an unary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationUnaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UnaryOperatorExpression : Expression
Public Class UnaryOperatorExpression
    Inherits Expression

The UnaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | UnaryOperatorExpression | Initializes a new instance of the UnaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression Constructor

Initializes a new instance of the UnaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UnaryOperatorExpression()
Public Sub New
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression Properties

The UnaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression.ChildExpression Property

UnaryOperatorExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression.Id Property

UnaryOperatorExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression.Operator Property

UnaryOperatorExpressionOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression Methods

The UnaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression.GetChildrenEnumerator Method

UnaryOperatorExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration Class

Represents a variable declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableDeclaration

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VariableDeclaration : AstNodeBase
Public Class VariableDeclaration
    Inherits AstNodeBase

The VariableDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | VariableDeclaration | Initializes a new instance of the VariableDeclaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration Constructor

Initializes a new instance of the VariableDeclaration class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VariableDeclaration()
Public Sub New
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration Properties

The VariableDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration.Id Property

VariableDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration.Initializer Property

VariableDeclarationInitializer Property

Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration.Name Property

VariableDeclarationName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration Methods

The VariableDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration.GetChildrenEnumerator Method

VariableDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression Class

Represents a variable declaration expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableDeclarationExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VariableDeclarationExpression : Expression
Public Class VariableDeclarationExpression
    Inherits Expression

The VariableDeclarationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | VariableDeclarationExpression | Initializes a new instance of the VariableDeclarationExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarations | Gets the declarations.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarations | Returns whether the Declarations collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression Constructor

Initializes a new instance of the VariableDeclarationExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VariableDeclarationExpression()
Public Sub New
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression Properties

The VariableDeclarationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarations | Gets the declarations.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarations | Returns whether the Declarations collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression.Declarations Property

VariableDeclarationExpressionDeclarations Property

Gets the declarations.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<VariableDeclaration> Declarations { get; }
Public ReadOnly Property Declarations As IList(Of VariableDeclaration)
    Get

Property Value

Type: IList VariableDeclaration
The declarations.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression.HasDeclarations Property

VariableDeclarationExpressionHasDeclarations Property

Returns whether the Declarations collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDeclarations { get; }
Public ReadOnly Property HasDeclarations As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression.Id Property

VariableDeclarationExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression Methods

The VariableDeclarationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression.GetChildrenEnumerator Method

VariableDeclarationExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement Class

Represents a variable statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VariableStatement : Statement
Public Class VariableStatement
    Inherits Statement

The VariableStatement type exposes the following members.

Constructors
 | Name | Description
Public method | VariableStatement | Initializes a new instance of the VariableStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarations | Gets the declarations.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarations | Returns whether the Declarations collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement Constructor

Initializes a new instance of the VariableStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VariableStatement()
Public Sub New
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement Properties

The VariableStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarations | Gets the declarations.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarations | Returns whether the Declarations collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement.Declarations Property

VariableStatementDeclarations Property

Gets the declarations.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<VariableDeclaration> Declarations { get; }
Public ReadOnly Property Declarations As IList(Of VariableDeclaration)
    Get

Property Value

Type: IList VariableDeclaration
The declarations.
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement.HasDeclarations Property

VariableStatementHasDeclarations Property

Returns whether the Declarations collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDeclarations { get; }
Public ReadOnly Property HasDeclarations As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement.Id Property

VariableStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement Methods

The VariableStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement.GetChildrenEnumerator Method

VariableStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement Class

Represents a while statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationWhileStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WhileStatement : Statement
Public Class WhileStatement
    Inherits Statement

The WhileStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WhileStatement | Initializes a new instance of the WhileStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement Constructor

Initializes a new instance of the WhileStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WhileStatement()
Public Sub New
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement Properties

The WhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement.ChildStatement Property

WhileStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement.ConditionExpression Property

WhileStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement.Id Property

WhileStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement Methods

The WhileStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement.GetChildrenEnumerator Method

WhileStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement Class

Represents a with statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationWithStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WithStatement : Statement
Public Class WithStatement
    Inherits Statement

The WithStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WithStatement | Initializes a new instance of the WithStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement Constructor

Initializes a new instance of the WithStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WithStatement()
Public Sub New
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement Properties

The WithStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement.ChildStatement Property

WithStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement.Expression Property

WithStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement.Id Property

WithStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement Methods

The WithStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement.GetChildrenEnumerator Method

WithStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace

Contains the core classes related to implementing a JavaScript syntax language.
Classes
 | Class | Description
Public class | JavaScriptClassificationTypeProvider | Represents a provider of IClassificationType objects for the JavaScript language.
Public class | JavaScriptCodeBlockFinder | Provides a JavaScript language code block finder service.
Public class | JavaScriptCompletionProvider | Provides IntelliPrompt completion data for the JavaScript language.
Public class | JavaScriptExampleTextProvider | Represents a example text provider for the JavaScript language.
Public class | JavaScriptGrammar | Represents a Grammar for the JavaScript language.
Public class | JavaScriptGrammarOptions | Contains options for a JavaScript grammar.
Public class | JavaScriptIndentProvider | Provides a JavaScript language indent provider service.
Public class | JavaScriptLexer | Represents a JavaScript lexer (lexical analyzer) implementation.
Public class | JavaScriptLexicalStateId | Contains the lexical state IDs for the JavaScript language.
Public class | JavaScriptOutliner | Provides a JavaScript language outliner service.
Public class | JavaScriptOutliningSource | Represents a JavaScript language range-based outlining source.
Public class | JavaScriptParseData | Stores the results of a JavaScript language parsing operation.
Public class | JavaScriptParser | Represents a parser for the JavaScript language.
Public class | JavaScriptSymbol | Represents a JavaScript symbol, located during parsing.
Public class | JavaScriptSymbolTable | Provides a JavaScript symbol table.
Public class | JavaScriptSyntaxLanguage | Represents a JavaScript syntax language definition.
Public class | JavaScriptTextFormatter | Provides a JavaScript language text formatter service.
Public class | JavaScriptTokenId | Contains the token IDs for the JavaScript language.
Public class | JavaScriptTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the JavaScript language.
Public class | JavaScriptTokenTagger | Represents an ITaggerT for the JavaScript language.
Public class | JavaScriptTokenTaggerProvider | Represents a provider of JavaScriptTokenTagger objects for documents that use the JavaScriptTokenTagger language.
Public class | JavaScriptTokenTaggerProviderTaggerFactory | Implements a factory that can creates JavaScriptTokenTagger objects for a document.
Public class | JsonExampleTextProvider | Represents a example text provider for the JSON language.
Public class | JsonGrammar | Represents a Grammar for the JSON language.
Public class | JsonIndentProvider | Provides a JSON language indent provider service.
Public class | JsonLexer | Represents a JSON lexer (lexical analyzer) implementation.
Public class | JsonOutliner | Provides a JSON language outliner service.
Public class | JsonOutliningSource | Represents a JSON language range-based outlining source.
Public class | JsonParseData | Stores the results of a JSON language parsing operation.
Public class | JsonParser | Represents a parser for the JSON language.
Public class | JsonSyntaxLanguage | Represents a JSON syntax language definition.
Public class | JsonTextFormatter | Provides a JSON language text formatter service.


JavaScriptClassificationTypeProvider Class

Represents a provider of IClassificationType objects for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptClassificationTypeProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptClassificationTypeProvider : IJavaScriptClassificationTypeProvider
Public Class JavaScriptClassificationTypeProvider
    Implements IJavaScriptClassificationTypeProvider

The JavaScriptClassificationTypeProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptClassificationTypeProvider | Initializes a new instance of the JavaScriptClassificationTypeProvider class.
Public method | JavaScriptClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the JavaScriptClassificationTypeProvider class.
Top
Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Top
Methods
 | Name | Description
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Constructor

Overload List
 | Name | Description
Public method | JavaScriptClassificationTypeProvider | Initializes a new instance of the JavaScriptClassificationTypeProvider class.
Public method | JavaScriptClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the JavaScriptClassificationTypeProvider class.
Top
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Constructor

Initializes a new instance of the JavaScriptClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptClassificationTypeProvider()
Public Sub New
See Also

Reference

JavaScriptClassificationTypeProvider Class
JavaScriptClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Constructor (IHighlightingStyleRegistry)

Initializes a new instance of the JavaScriptClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptClassificationTypeProvider(
    IHighlightingStyleRegistry targetRegistry
)
Public Sub New (
    targetRegistry As IHighlightingStyleRegistry
)

Parameters

targetRegistry
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

JavaScriptClassificationTypeProvider Class
JavaScriptClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Properties

The JavaScriptClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Top
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Comment Property

JavaScriptClassificationTypeProviderComment Property

Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Comment { get; }
Public ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.

Implements

IJavaScriptClassificationTypeProviderComment
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Identifier Property

JavaScriptClassificationTypeProviderIdentifier Property

Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Identifier { get; }
Public ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.

Implements

IJavaScriptClassificationTypeProviderIdentifier
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Keyword Property

JavaScriptClassificationTypeProviderKeyword Property

Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Keyword { get; }
Public ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.

Implements

IJavaScriptClassificationTypeProviderKeyword
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Number Property

JavaScriptClassificationTypeProviderNumber Property

Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Number { get; }
Public ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.

Implements

IJavaScriptClassificationTypeProviderNumber
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Operator Property

JavaScriptClassificationTypeProviderOperator Property

Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Operator { get; }
Public ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.

Implements

IJavaScriptClassificationTypeProviderOperator
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Registry Property

JavaScriptClassificationTypeProviderRegistry Property

Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry Registry { get; }
Public ReadOnly Property Registry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.String Property

JavaScriptClassificationTypeProviderString Property

Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType String { get; }
Public ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.

Implements

IJavaScriptClassificationTypeProviderString
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Methods

The JavaScriptClassificationTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Top
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.RegisterAll Method

JavaScriptClassificationTypeProviderRegisterAll Method

Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<IClassificationType> RegisterAll()
Public Function RegisterAll As IEnumerable(Of IClassificationType)

Return Value

Type: IEnumerable IClassificationType
The collection of IClassificationType objects that were registered.
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCodeBlockFinder Class

Provides a JavaScript language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptCodeBlockFinder : LLParseDataCodeBlockFinder
Public Class JavaScriptCodeBlockFinder
    Inherits LLParseDataCodeBlockFinder

The JavaScriptCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptCodeBlockFinder | Initializes a new instance of the JavaScriptCodeBlockFinder class.
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCodeBlockFinder Constructor

Initializes a new instance of the JavaScriptCodeBlockFinder class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptCodeBlockFinder()
Public Sub New
See Also

Reference

JavaScriptCodeBlockFinder Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCodeBlockFinder Properties

The JavaScriptCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

JavaScriptCodeBlockFinder Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCodeBlockFinder Methods

The JavaScriptCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

JavaScriptCodeBlockFinder Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider Class

Provides IntelliPrompt completion data for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptCompletionProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptCompletionProvider : CompletionProviderBase
Public Class JavaScriptCompletionProvider
    Inherits CompletionProviderBase

The JavaScriptCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptCompletionProvider | Initializes a new instance of the JavaScriptCompletionProvider class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider Constructor

Initializes a new instance of the JavaScriptCompletionProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptCompletionProvider()
Public Sub New
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider Properties

The JavaScriptCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider Methods

The JavaScriptCompletionProvider type exposes the following members.

Methods
 | Name | Description
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Top
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider.OnSessionOpening Method

JavaScriptCompletionProviderOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    ICompletionSession session
)
Protected Overridable Function OnSessionOpening (
    session As ICompletionSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
Remarks
The default implementation of this method sorts the items in the session.
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider.RequestSession Method

JavaScriptCompletionProviderRequestSession Method

Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Public Overrides Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

ICompletionProviderRequestSession(IEditorView, Boolean)
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptExampleTextProvider Class

Represents a example text provider for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptExampleTextProvider : IExampleTextProvider
Public Class JavaScriptExampleTextProvider
    Implements IExampleTextProvider

The JavaScriptExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptExampleTextProvider | Initializes a new instance of the JavaScriptExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptExampleTextProvider Constructor

Initializes a new instance of the JavaScriptExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptExampleTextProvider()
Public Sub New
See Also

Reference

JavaScriptExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptExampleTextProvider Properties

The JavaScriptExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

JavaScriptExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptExampleTextProvider.ExampleText Property

JavaScriptExampleTextProviderExampleText Property

Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

JavaScriptExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Class

Represents a Grammar for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptGrammar

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptGrammar : Grammar
Public Class JavaScriptGrammar
    Inherits Grammar

The JavaScriptGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptGrammar | Initializes a new instance of the JavaScriptGrammar class using default options.
Public method | JavaScriptGrammar(IJavaScriptGrammarOptions) | Initializes a new instance of the JavaScriptGrammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Constructor

Overload List
 | Name | Description
Public method | JavaScriptGrammar | Initializes a new instance of the JavaScriptGrammar class using default options.
Public method | JavaScriptGrammar(IJavaScriptGrammarOptions) | Initializes a new instance of the JavaScriptGrammar class.
Top
See Also

Reference

JavaScriptGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Constructor

Initializes a new instance of the JavaScriptGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptGrammar()
Public Sub New
See Also

Reference

JavaScriptGrammar Class
JavaScriptGrammar Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Constructor (IJavaScriptGrammarOptions)

Initializes a new instance of the JavaScriptGrammar class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptGrammar(
    IJavaScriptGrammarOptions options
)
Public Sub New (
    options As IJavaScriptGrammarOptions
)

Parameters

options
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptGrammarOptions
An IJavaScriptGrammarOptions that contains options for the grammar.
See Also

Reference

JavaScriptGrammar Class
JavaScriptGrammar Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Properties

The JavaScriptGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

JavaScriptGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Methods

The JavaScriptGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

JavaScriptGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammarOptions Class

Contains options for a JavaScript grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptGrammarOptions

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptGrammarOptions : IJavaScriptGrammarOptions
Public Class JavaScriptGrammarOptions
    Implements IJavaScriptGrammarOptions

The JavaScriptGrammarOptions type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptGrammarOptions | Initializes a new instance of the JavaScriptGrammarOptions class.
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammarOptions Constructor

Initializes a new instance of the JavaScriptGrammarOptions class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptGrammarOptions()
Public Sub New
See Also

Reference

JavaScriptGrammarOptions Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammarOptions Properties

The JavaScriptGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

JavaScriptGrammarOptions Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammarOptions.RootNonTerminal Property

JavaScriptGrammarOptionsRootNonTerminal Property

Gets or sets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptGrammarRootNonTerminal RootNonTerminal { get; set; }
Public Property RootNonTerminal As JavaScriptGrammarRootNonTerminal
    Get
    Set

Property Value

Type: JavaScriptGrammarRootNonTerminal
A JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.

Implements

IJavaScriptGrammarOptionsRootNonTerminal
See Also

Reference

JavaScriptGrammarOptions Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider Class

Provides a JavaScript language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationDelimiterIndentProvider
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptIndentProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptIndentProvider : DelimiterIndentProvider
Public Class JavaScriptIndentProvider
    Inherits DelimiterIndentProvider

The JavaScriptIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptIndentProvider | Initializes a new instance of the JavaScriptIndentProvider class.
Top
Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider Constructor

Initializes a new instance of the JavaScriptIndentProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptIndentProvider()
Public Sub New
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider Properties

The JavaScriptIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider.Mode Property

JavaScriptIndentProviderMode Property

Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IndentMode Mode { get; }
Public Overrides ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider Methods

The JavaScriptIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Top
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider.GetIndentAmount Method

JavaScriptIndentProviderGetIndentAmount Method

Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Overrides Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider.OnDocumentTextChanged Method

JavaScriptIndentProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overrides Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider.OnDocumentTextChanging Method

JavaScriptIndentProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overrides Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Class

Represents a JavaScript lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptLexer

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptLexer : MergableLexerBase
Public Class JavaScriptLexer
    Inherits MergableLexerBase

The JavaScriptLexer type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptLexer | Initializes a new instance of the JavaScriptLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
 | IsIdentifierPartCharacter | Returns whether the specified character is an identifier part character.
 | IsIdentifierStartCharacter | Returns whether the specified character is an identifier start character.
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Constructor

Initializes a new instance of the JavaScriptLexer class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptLexer()
Public Sub New
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Properties

The JavaScriptLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.LexicalStates Property

JavaScriptLexerLexicalStates Property

Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Methods

The JavaScriptLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
 | IsIdentifierPartCharacter | Returns whether the specified character is an identifier part character.
 | IsIdentifierStartCharacter | Returns whether the specified character is an identifier start character.
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.GetAllLexicalStateTransitions Method

JavaScriptLexerGetAllLexicalStateTransitions Method

Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.GetNextToken Method

JavaScriptLexerGetNextToken Method

Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.IsIdentifierPartCharacter Method

JavaScriptLexerIsIdentifierPartCharacter Method

Returns whether the specified character is an identifier part character.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsIdentifierPartCharacter(
    char ch
)
Public Shared Function IsIdentifierPartCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is an identifier part character; otherwise, false.
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.IsIdentifierStartCharacter Method

JavaScriptLexerIsIdentifierStartCharacter Method

Returns whether the specified character is an identifier start character.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsIdentifierStartCharacter(
    char ch
)
Public Shared Function IsIdentifierStartCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is an identifier start character; otherwise, false.
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Events

The JavaScriptLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Class

Contains the lexical state IDs for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptLexicalStateId

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptLexicalStateId : LexicalStateIdProviderBase
Public Class JavaScriptLexicalStateId
    Inherits LexicalStateIdProviderBase

The JavaScriptLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptLexicalStateId | Initializes a new instance of the JavaScriptLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
Fields
Name | Description
Default | Gets the Default lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Constructor

Initializes a new instance of the JavaScriptLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptLexicalStateId()
Public Sub New
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Properties

The JavaScriptLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.MaxId Property

JavaScriptLexicalStateIdMaxId Property

Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.MinId Property

JavaScriptLexicalStateIdMinId Property

Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Methods

The JavaScriptLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.ContainsId Method

JavaScriptLexicalStateIdContainsId Method

Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.GetDescription Method

JavaScriptLexicalStateIdGetDescription Method

Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.GetKey Method

JavaScriptLexicalStateIdGetKey Method

Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Fields

The JavaScriptLexicalStateId type exposes the following members.

Fields
Name | Description
Default | Gets the Default lexical state ID.
Top
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.Default Field

JavaScriptLexicalStateIdDefault Field

Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Default = 13000
Public Const Default As Integer = 13000

Field Value

Type: Int32
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner Class

Provides a JavaScript language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptOutliner

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptOutliner : IOutliner
Public Class JavaScriptOutliner
    Implements IOutliner

The JavaScriptOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptOutliner | Initializes a new instance of the JavaScriptOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner Constructor

Initializes a new instance of the JavaScriptOutliner class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptOutliner()
Public Sub New
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner Properties

The JavaScriptOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner.UpdateTrigger Property

JavaScriptOutlinerUpdateTrigger Property

Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner Methods

The JavaScriptOutliner type exposes the following members.

Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner.GetOutliningSource Method

JavaScriptOutlinerGetOutliningSource Method

Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource Class

Represents a JavaScript language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptOutliningSource

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptOutliningSource : RangeOutliningSourceBase
Public Class JavaScriptOutliningSource
    Inherits RangeOutliningSourceBase

The JavaScriptOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptOutliningSource | Initializes a new instance of the JavaScriptOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IJavaScriptParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJavaScriptParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource Constructor

Initializes a new instance of the JavaScriptOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

JavaScriptOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource Methods

The JavaScriptOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IJavaScriptParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJavaScriptParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

JavaScriptOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource.AddNodesFromParseData Method

JavaScriptOutliningSourceAddNodesFromParseData Method

Overload List
 | Name | Description
Public method | AddNodesFromParseData(IJavaScriptParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJavaScriptParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

JavaScriptOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource.AddNodesFromParseData Method (IJavaScriptParseData)

JavaScriptOutliningSourceAddNodesFromParseData Method (IJavaScriptParseData)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IJavaScriptParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IJavaScriptParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptParseData
The IJavaScriptParseData containing AST data.
See Also

Reference

JavaScriptOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource.AddNodesFromParseData Method (IJavaScriptParseData, ITextBufferReader)

JavaScriptOutliningSourceAddNodesFromParseData Method (IJavaScriptParseData, ITextBufferReader)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IJavaScriptParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IJavaScriptParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptParseData
The IJavaScriptParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

JavaScriptOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource.AddNodesRecursive Method

JavaScriptOutliningSourceAddNodesRecursive Method

Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

JavaScriptOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParseData Class

Stores the results of a JavaScript language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParseData

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptParseData : LLParseData,
    ILLParseData, IParseData, IParseErrorProvider, IJavaScriptParseData
Public Class JavaScriptParseData
    Inherits LLParseData
    Implements ILLParseData, IParseData, IParseErrorProvider, IJavaScriptParseData

The JavaScriptParseData type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptParseData | Initializes a new instance of the JavaScriptParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Public property | SymbolTable | Gets or sets the table of symbols located within the document.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParseData Constructor

Initializes a new instance of the JavaScriptParseData class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptParseData()
Public Sub New
See Also

Reference

JavaScriptParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParseData Properties

The JavaScriptParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Public property | SymbolTable | Gets or sets the table of symbols located within the document.
Top
See Also

Reference

JavaScriptParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParseData.SymbolTable Property

JavaScriptParseDataSymbolTable Property

Gets or sets the table of symbols located within the document.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IJavaScriptSymbolTable SymbolTable { get; set; }
Public Property SymbolTable As IJavaScriptSymbolTable
    Get
    Set

Property Value

Type: IJavaScriptSymbolTable
The table of symbols located within the document.

Implements

IJavaScriptParseDataSymbolTable
See Also

Reference

JavaScriptParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Class

Represents a parser for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParser

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptParser : LLParserBase
Public Class JavaScriptParser
    Inherits LLParserBase

The JavaScriptParser type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptParser | Initializes a new instance of the JavaScriptParser class.
Public method | JavaScriptParser(Grammar) | Initializes a new instance of the JavaScriptParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Constructor

Overload List
 | Name | Description
Public method | JavaScriptParser | Initializes a new instance of the JavaScriptParser class.
Public method | JavaScriptParser(Grammar) | Initializes a new instance of the JavaScriptParser class.
Top
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Constructor

Initializes a new instance of the JavaScriptParser class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptParser()
Public Sub New
See Also

Reference

JavaScriptParser Class
JavaScriptParser Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Constructor (Grammar)

Initializes a new instance of the JavaScriptParser class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

JavaScriptParser Class
JavaScriptParser Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Properties

The JavaScriptParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Methods

The JavaScriptParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Top
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser.CreateParseData Method

JavaScriptParserCreateParseData Method

Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser.CreateTokenReader Method

JavaScriptParserCreateTokenReader Method

Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser.InitializeParserState Method

JavaScriptParserInitializeParserState Method

Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol Class

Represents a JavaScript symbol, located during parsing.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSymbol

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptSymbol : IJavaScriptSymbol
Public Class JavaScriptSymbol
    Implements IJavaScriptSymbol

The JavaScriptSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptSymbol | Initializes a new instance of the JavaScriptSymbol class.
Top
Properties
 | Name | Description
Public property | Name | Gets the symbol name.
Public property | UsageCount | Gets or sets the usage count.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol Constructor

Initializes a new instance of the JavaScriptSymbol class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptSymbol(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The symbol name.
See Also

Reference

JavaScriptSymbol Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol Properties

The JavaScriptSymbol type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the symbol name.
Public property | UsageCount | Gets or sets the usage count.
Top
See Also

Reference

JavaScriptSymbol Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol.Name Property

JavaScriptSymbolName Property

Gets the symbol name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The symbol name.

Implements

IJavaScriptSymbolName
See Also

Reference

JavaScriptSymbol Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol.UsageCount Property

JavaScriptSymbolUsageCount Property

Gets or sets the usage count.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int UsageCount { get; set; }
Public Property UsageCount As Integer
    Get
    Set

Property Value

Type: Int32
The usage count.

Implements

IJavaScriptSymbolUsageCount
See Also

Reference

JavaScriptSymbol Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbolTable Class

Provides a JavaScript symbol table.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSymbolTable

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptSymbolTable : IJavaScriptSymbolTable
Public Class JavaScriptSymbolTable
    Implements IJavaScriptSymbolTable

The JavaScriptSymbolTable type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptSymbolTable | Initializes a new instance of the JavaScriptSymbolTable class
Top
Properties
 | Name | Description
Public property | Symbols | Gets the collection of symbols located within the document.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbolTable Constructor

Initializes a new instance of the JavaScriptSymbolTable class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptSymbolTable()
Public Sub New
See Also

Reference

JavaScriptSymbolTable Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbolTable Properties

The JavaScriptSymbolTable type exposes the following members.

Properties
 | Name | Description
Public property | Symbols | Gets the collection of symbols located within the document.
Top
See Also

Reference

JavaScriptSymbolTable Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbolTable.Symbols Property

JavaScriptSymbolTableSymbols Property

Gets the collection of symbols located within the document.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<IJavaScriptSymbol> Symbols { get; }
Public ReadOnly Property Symbols As IEnumerable(Of IJavaScriptSymbol)
    Get

Property Value

Type: IEnumerable IJavaScriptSymbol
The collection of symbols located within the document.

Implements

IJavaScriptSymbolTableSymbols
See Also

Reference

JavaScriptSymbolTable Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Class

Represents a JavaScript syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptSyntaxLanguage : SyntaxLanguage
Public Class JavaScriptSyntaxLanguage
    Inherits SyntaxLanguage

The JavaScriptSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptSyntaxLanguage | Initializes a new instance of the JavaScriptSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Constructor

Initializes a new instance of the JavaScriptSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptSyntaxLanguage()
Public Sub New
See Also

Reference

JavaScriptSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Properties

The JavaScriptSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JavaScriptSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Methods

The JavaScriptSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JavaScriptSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Events

The JavaScriptSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JavaScriptSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter Class

Provides a JavaScript language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTextFormatter

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptTextFormatter : ITextFormatter
Public Class JavaScriptTextFormatter
    Implements ITextFormatter

The JavaScriptTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTextFormatter | Initializes a new instance of the JavaScriptTextFormatter class
Top
Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter Constructor

Initializes a new instance of the JavaScriptTextFormatter class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptTextFormatter()
Public Sub New
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter Properties

The JavaScriptTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter.IsOpeningBraceOnNewLine Property

JavaScriptTextFormatterIsOpeningBraceOnNewLine Property

Gets or sets a value indicating whether opening braces are on new lines.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOpeningBraceOnNewLine { get; set; }
Public Property IsOpeningBraceOnNewLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the opening braces are on new lines; otherwise, false.
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter Methods

The JavaScriptTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter.Format Method

JavaScriptTextFormatterFormat Method

Applies text formatting to part or all of a snapshot.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Format(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection selectionPositionRanges,
    TextFormatMode mode = TextFormatMode.Ranges
)
Public Sub Format (
    snapshot As ITextSnapshot,
    selectionPositionRanges As ITextPositionRangeCollection,
    Optional mode As TextFormatMode = TextFormatMode.Ranges
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
selectionPositionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the selection position ranges. These are used to translate the current selection to the new snapshot that is created, even when formatting the entire snapshot.
mode (Optional)
Type: ActiproSoftware.TextTextFormatMode
A TextFormatMode indicating whether to format part or all of the snapshot. The default value is Ranges.

Implements

ITextFormatterFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode)
Remarks
The containing ITextDocument is accessible via the ITextSnapshot.
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Class

Contains the token IDs for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenId

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptTokenId : TokenIdProviderBase
Public Class JavaScriptTokenId
    Inherits TokenIdProviderBase

The JavaScriptTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTokenId | Initializes a new instance of the JavaScriptTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
Top
Fields
Name | Description
Backslash | Gets the Backslash token ID.
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentMultiLine | Gets the CommentMultiLine token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDebugger | Gets the KeywordDebugger token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelete | Gets the KeywordDelete token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFunction | Gets the KeywordFunction token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInstanceOf | Gets the KeywordInstanceOf token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNull | Gets the KeywordNull token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSwitch | Gets the KeywordSwitch token ID.
KeywordThis | Gets the KeywordThis token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordVar | Gets the KeywordVar token ID.
KeywordVoid | Gets the KeywordVoid token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWith | Gets the KeywordWith token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralDoubleQuoteString | Gets the LiteralDoubleQuoteString token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralRegularExpression | Gets the LiteralRegularExpression token ID.
LiteralSingleQuoteString | Gets the LiteralSingleQuoteString token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorConditionalAnd | Gets the OperatorConditionalAnd token ID.
OperatorConditionalOr | Gets the OperatorConditionalOr token ID.
OperatorDecrement | Gets the OperatorDecrement token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorIncrement | Gets the OperatorIncrement token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorNegation | Gets the OperatorNegation token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorStrictEquality | Gets the OperatorStrictEquality token ID.
OperatorStrictInequality | Gets the OperatorStrictInequality token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
OperatorZeroFillRightShift | Gets the OperatorZeroFillRightShift token ID.
OperatorZeroFillRightShiftAssignment | Gets the OperatorZeroFillRightShiftAssignment token ID.
QuestionMark | Gets the QuestionMark token ID.
ReservedKeywordClass | Gets the ReservedKeywordClass token ID.
ReservedKeywordConst | Gets the ReservedKeywordConst token ID.
ReservedKeywordEnum | Gets the ReservedKeywordEnum token ID.
ReservedKeywordExport | Gets the ReservedKeywordExport token ID.
ReservedKeywordExtends | Gets the ReservedKeywordExtends token ID.
ReservedKeywordImplements | Gets the ReservedKeywordImplements token ID.
ReservedKeywordImport | Gets the ReservedKeywordImport token ID.
ReservedKeywordInterface | Gets the ReservedKeywordInterface token ID.
ReservedKeywordLet | Gets the ReservedKeywordLet token ID.
ReservedKeywordPackage | Gets the ReservedKeywordPackage token ID.
ReservedKeywordPrivate | Gets the ReservedKeywordPrivate token ID.
ReservedKeywordProtected | Gets the ReservedKeywordProtected token ID.
ReservedKeywordPublic | Gets the ReservedKeywordPublic token ID.
ReservedKeywordStatic | Gets the ReservedKeywordStatic token ID.
ReservedKeywordSuper | Gets the ReservedKeywordSuper token ID.
ReservedKeywordYield | Gets the ReservedKeywordYield token ID.
SemiColon | Gets the SemiColon token ID.
Whitespace | Gets the Whitespace token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Constructor

Initializes a new instance of the JavaScriptTokenId class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptTokenId()
Public Sub New
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Properties

The JavaScriptTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.MaxId Property

JavaScriptTokenIdMaxId Property

Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.MinId Property

JavaScriptTokenIdMinId Property

Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Methods

The JavaScriptTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
Top
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ContainsId Method

JavaScriptTokenIdContainsId Method

Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.GetDescription Method

JavaScriptTokenIdGetDescription Method

Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.GetKey Method

JavaScriptTokenIdGetKey Method

Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsCommentClassificationType Method

JavaScriptTokenIdIsCommentClassificationType Method

Returns whether the specified ID value is part of the Comment.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsCommentClassificationType(
    int id
)
Public Shared Function IsCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsIdentifierClassificationType Method

JavaScriptTokenIdIsIdentifierClassificationType Method

Returns whether the specified ID value is part of the Identifier.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsIdentifierClassificationType(
    int id
)
Public Shared Function IsIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsKeywordClassificationType Method

JavaScriptTokenIdIsKeywordClassificationType Method

Returns whether the specified ID value is part of the Keyword.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsKeywordClassificationType(
    int id
)
Public Shared Function IsKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsNumberClassificationType Method

JavaScriptTokenIdIsNumberClassificationType Method

Returns whether the specified ID value is part of the Number.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsNumberClassificationType(
    int id
)
Public Shared Function IsNumberClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsOperatorClassificationType Method

JavaScriptTokenIdIsOperatorClassificationType Method

Returns whether the specified ID value is part of the Operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsOperatorClassificationType(
    int id
)
Public Shared Function IsOperatorClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsStringClassificationType Method

JavaScriptTokenIdIsStringClassificationType Method

Returns whether the specified ID value is part of the String.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsStringClassificationType(
    int id
)
Public Shared Function IsStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Fields

The JavaScriptTokenId type exposes the following members.

Fields
Name | Description
Backslash | Gets the Backslash token ID.
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentMultiLine | Gets the CommentMultiLine token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDebugger | Gets the KeywordDebugger token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelete | Gets the KeywordDelete token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFunction | Gets the KeywordFunction token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInstanceOf | Gets the KeywordInstanceOf token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNull | Gets the KeywordNull token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSwitch | Gets the KeywordSwitch token ID.
KeywordThis | Gets the KeywordThis token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordVar | Gets the KeywordVar token ID.
KeywordVoid | Gets the KeywordVoid token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWith | Gets the KeywordWith token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralDoubleQuoteString | Gets the LiteralDoubleQuoteString token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralRegularExpression | Gets the LiteralRegularExpression token ID.
LiteralSingleQuoteString | Gets the LiteralSingleQuoteString token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorConditionalAnd | Gets the OperatorConditionalAnd token ID.
OperatorConditionalOr | Gets the OperatorConditionalOr token ID.
OperatorDecrement | Gets the OperatorDecrement token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorIncrement | Gets the OperatorIncrement token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorNegation | Gets the OperatorNegation token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorStrictEquality | Gets the OperatorStrictEquality token ID.
OperatorStrictInequality | Gets the OperatorStrictInequality token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
OperatorZeroFillRightShift | Gets the OperatorZeroFillRightShift token ID.
OperatorZeroFillRightShiftAssignment | Gets the OperatorZeroFillRightShiftAssignment token ID.
QuestionMark | Gets the QuestionMark token ID.
ReservedKeywordClass | Gets the ReservedKeywordClass token ID.
ReservedKeywordConst | Gets the ReservedKeywordConst token ID.
ReservedKeywordEnum | Gets the ReservedKeywordEnum token ID.
ReservedKeywordExport | Gets the ReservedKeywordExport token ID.
ReservedKeywordExtends | Gets the ReservedKeywordExtends token ID.
ReservedKeywordImplements | Gets the ReservedKeywordImplements token ID.
ReservedKeywordImport | Gets the ReservedKeywordImport token ID.
ReservedKeywordInterface | Gets the ReservedKeywordInterface token ID.
ReservedKeywordLet | Gets the ReservedKeywordLet token ID.
ReservedKeywordPackage | Gets the ReservedKeywordPackage token ID.
ReservedKeywordPrivate | Gets the ReservedKeywordPrivate token ID.
ReservedKeywordProtected | Gets the ReservedKeywordProtected token ID.
ReservedKeywordPublic | Gets the ReservedKeywordPublic token ID.
ReservedKeywordStatic | Gets the ReservedKeywordStatic token ID.
ReservedKeywordSuper | Gets the ReservedKeywordSuper token ID.
ReservedKeywordYield | Gets the ReservedKeywordYield token ID.
SemiColon | Gets the SemiColon token ID.
Whitespace | Gets the Whitespace token ID.
Top
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Backslash Field

JavaScriptTokenIdBackslash Field

Gets the Backslash token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Backslash = 13014
Public Const Backslash As Integer = 13014

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CloseCurlyBrace Field

JavaScriptTokenIdCloseCurlyBrace Field

Gets the CloseCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseCurlyBrace = 13004
Public Const CloseCurlyBrace As Integer = 13004

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CloseParenthesis Field

JavaScriptTokenIdCloseParenthesis Field

Gets the CloseParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseParenthesis = 13008
Public Const CloseParenthesis As Integer = 13008

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CloseSquareBrace Field

JavaScriptTokenIdCloseSquareBrace Field

Gets the CloseSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseSquareBrace = 13006
Public Const CloseSquareBrace As Integer = 13006

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Colon Field

JavaScriptTokenIdColon Field

Gets the Colon token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Colon = 13011
Public Const Colon As Integer = 13011

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Comma Field

JavaScriptTokenIdComma Field

Gets the Comma token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Comma = 13010
Public Const Comma As Integer = 13010

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CommentMultiLine Field

JavaScriptTokenIdCommentMultiLine Field

Gets the CommentMultiLine token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentMultiLine = 13016
Public Const CommentMultiLine As Integer = 13016

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CommentSingleLine Field

JavaScriptTokenIdCommentSingleLine Field

Gets the CommentSingleLine token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentSingleLine = 13015
Public Const CommentSingleLine As Integer = 13015

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Dot Field

JavaScriptTokenIdDot Field

Gets the Dot token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Dot = 13009
Public Const Dot As Integer = 13009

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Identifier Field

JavaScriptTokenIdIdentifier Field

Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Identifier = 13023
Public Const Identifier As Integer = 13023

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordBreak Field

JavaScriptTokenIdKeywordBreak Field

Gets the KeywordBreak token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordBreak = 13024
Public Const KeywordBreak As Integer = 13024

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordCase Field

JavaScriptTokenIdKeywordCase Field

Gets the KeywordCase token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCase = 13025
Public Const KeywordCase As Integer = 13025

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordCatch Field

JavaScriptTokenIdKeywordCatch Field

Gets the KeywordCatch token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCatch = 13026
Public Const KeywordCatch As Integer = 13026

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordContinue Field

JavaScriptTokenIdKeywordContinue Field

Gets the KeywordContinue token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordContinue = 13027
Public Const KeywordContinue As Integer = 13027

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordDebugger Field

JavaScriptTokenIdKeywordDebugger Field

Gets the KeywordDebugger token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDebugger = 13028
Public Const KeywordDebugger As Integer = 13028

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordDefault Field

JavaScriptTokenIdKeywordDefault Field

Gets the KeywordDefault token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDefault = 13029
Public Const KeywordDefault As Integer = 13029

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordDelete Field

JavaScriptTokenIdKeywordDelete Field

Gets the KeywordDelete token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDelete = 13030
Public Const KeywordDelete As Integer = 13030

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordDo Field

JavaScriptTokenIdKeywordDo Field

Gets the KeywordDo token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDo = 13031
Public Const KeywordDo As Integer = 13031

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordElse Field

JavaScriptTokenIdKeywordElse Field

Gets the KeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordElse = 13032
Public Const KeywordElse As Integer = 13032

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordFalse Field

JavaScriptTokenIdKeywordFalse Field

Gets the KeywordFalse token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFalse = 13033
Public Const KeywordFalse As Integer = 13033

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordFinally Field

JavaScriptTokenIdKeywordFinally Field

Gets the KeywordFinally token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFinally = 13034
Public Const KeywordFinally As Integer = 13034

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordFor Field

JavaScriptTokenIdKeywordFor Field

Gets the KeywordFor token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFor = 13035
Public Const KeywordFor As Integer = 13035

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordFunction Field

JavaScriptTokenIdKeywordFunction Field

Gets the KeywordFunction token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFunction = 13036
Public Const KeywordFunction As Integer = 13036

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordIf Field

JavaScriptTokenIdKeywordIf Field

Gets the KeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIf = 13037
Public Const KeywordIf As Integer = 13037

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordIn Field

JavaScriptTokenIdKeywordIn Field

Gets the KeywordIn token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIn = 13038
Public Const KeywordIn As Integer = 13038

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordInstanceOf Field

JavaScriptTokenIdKeywordInstanceOf Field

Gets the KeywordInstanceOf token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordInstanceOf = 13039
Public Const KeywordInstanceOf As Integer = 13039

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordNew Field

JavaScriptTokenIdKeywordNew Field

Gets the KeywordNew token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNew = 13040
Public Const KeywordNew As Integer = 13040

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordNull Field

JavaScriptTokenIdKeywordNull Field

Gets the KeywordNull token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNull = 13041
Public Const KeywordNull As Integer = 13041

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordReturn Field

JavaScriptTokenIdKeywordReturn Field

Gets the KeywordReturn token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordReturn = 13042
Public Const KeywordReturn As Integer = 13042

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordSwitch Field

JavaScriptTokenIdKeywordSwitch Field

Gets the KeywordSwitch token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSwitch = 13043
Public Const KeywordSwitch As Integer = 13043

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordThis Field

JavaScriptTokenIdKeywordThis Field

Gets the KeywordThis token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordThis = 13044
Public Const KeywordThis As Integer = 13044

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordThrow Field

JavaScriptTokenIdKeywordThrow Field

Gets the KeywordThrow token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordThrow = 13045
Public Const KeywordThrow As Integer = 13045

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordTrue Field

JavaScriptTokenIdKeywordTrue Field

Gets the KeywordTrue token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTrue = 13046
Public Const KeywordTrue As Integer = 13046

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordTry Field

JavaScriptTokenIdKeywordTry Field

Gets the KeywordTry token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTry = 13047
Public Const KeywordTry As Integer = 13047

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordTypeOf Field

JavaScriptTokenIdKeywordTypeOf Field

Gets the KeywordTypeOf token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTypeOf = 13048
Public Const KeywordTypeOf As Integer = 13048

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordVar Field

JavaScriptTokenIdKeywordVar Field

Gets the KeywordVar token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordVar = 13049
Public Const KeywordVar As Integer = 13049

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordVoid Field

JavaScriptTokenIdKeywordVoid Field

Gets the KeywordVoid token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordVoid = 13050
Public Const KeywordVoid As Integer = 13050

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordWhile Field

JavaScriptTokenIdKeywordWhile Field

Gets the KeywordWhile token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWhile = 13051
Public Const KeywordWhile As Integer = 13051

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordWith Field

JavaScriptTokenIdKeywordWith Field

Gets the KeywordWith token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWith = 13052
Public Const KeywordWith As Integer = 13052

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LineContinuation Field

JavaScriptTokenIdLineContinuation Field

Gets the LineContinuation token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LineContinuation = 13002
Public Const LineContinuation As Integer = 13002

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LineTerminator Field

JavaScriptTokenIdLineTerminator Field

Gets the LineTerminator token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LineTerminator = 13001
Public Const LineTerminator As Integer = 13001

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralDecimalInteger Field

JavaScriptTokenIdLiteralDecimalInteger Field

Gets the LiteralDecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralDecimalInteger = 13017
Public Const LiteralDecimalInteger As Integer = 13017

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralDoubleQuoteString Field

JavaScriptTokenIdLiteralDoubleQuoteString Field

Gets the LiteralDoubleQuoteString token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralDoubleQuoteString = 13018
Public Const LiteralDoubleQuoteString As Integer = 13018

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralHexadecimalInteger Field

JavaScriptTokenIdLiteralHexadecimalInteger Field

Gets the LiteralHexadecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralHexadecimalInteger = 13019
Public Const LiteralHexadecimalInteger As Integer = 13019

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralReal Field

JavaScriptTokenIdLiteralReal Field

Gets the LiteralReal token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralReal = 13020
Public Const LiteralReal As Integer = 13020

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralRegularExpression Field

JavaScriptTokenIdLiteralRegularExpression Field

Gets the LiteralRegularExpression token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralRegularExpression = 13021
Public Const LiteralRegularExpression As Integer = 13021

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralSingleQuoteString Field

JavaScriptTokenIdLiteralSingleQuoteString Field

Gets the LiteralSingleQuoteString token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralSingleQuoteString = 13022
Public Const LiteralSingleQuoteString As Integer = 13022

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OpenCurlyBrace Field

JavaScriptTokenIdOpenCurlyBrace Field

Gets the OpenCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenCurlyBrace = 13003
Public Const OpenCurlyBrace As Integer = 13003

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OpenParenthesis Field

JavaScriptTokenIdOpenParenthesis Field

Gets the OpenParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenParenthesis = 13007
Public Const OpenParenthesis As Integer = 13007

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OpenSquareBrace Field

JavaScriptTokenIdOpenSquareBrace Field

Gets the OpenSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenSquareBrace = 13005
Public Const OpenSquareBrace As Integer = 13005

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorAddition Field

JavaScriptTokenIdOperatorAddition Field

Gets the OperatorAddition token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAddition = 13077
Public Const OperatorAddition As Integer = 13077

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorAdditionAssignment Field

JavaScriptTokenIdOperatorAdditionAssignment Field

Gets the OperatorAdditionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAdditionAssignment = 13095
Public Const OperatorAdditionAssignment As Integer = 13095

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorAssignment Field

JavaScriptTokenIdOperatorAssignment Field

Gets the OperatorAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAssignment = 13094
Public Const OperatorAssignment As Integer = 13094

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorBitwiseAnd Field

JavaScriptTokenIdOperatorBitwiseAnd Field

Gets the OperatorBitwiseAnd token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAnd = 13087
Public Const OperatorBitwiseAnd As Integer = 13087

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorBitwiseAndAssignment Field

JavaScriptTokenIdOperatorBitwiseAndAssignment Field

Gets the OperatorBitwiseAndAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAndAssignment = 13103
Public Const OperatorBitwiseAndAssignment As Integer = 13103

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorBitwiseOr Field

JavaScriptTokenIdOperatorBitwiseOr Field

Gets the OperatorBitwiseOr token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOr = 13088
Public Const OperatorBitwiseOr As Integer = 13088

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorBitwiseOrAssignment Field

JavaScriptTokenIdOperatorBitwiseOrAssignment Field

Gets the OperatorBitwiseOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOrAssignment = 13104
Public Const OperatorBitwiseOrAssignment As Integer = 13104

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorConditionalAnd Field

JavaScriptTokenIdOperatorConditionalAnd Field

Gets the OperatorConditionalAnd token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorConditionalAnd = 13092
Public Const OperatorConditionalAnd As Integer = 13092

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorConditionalOr Field

JavaScriptTokenIdOperatorConditionalOr Field

Gets the OperatorConditionalOr token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorConditionalOr = 13093
Public Const OperatorConditionalOr As Integer = 13093

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorDecrement Field

JavaScriptTokenIdOperatorDecrement Field

Gets the OperatorDecrement token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorDecrement = 13083
Public Const OperatorDecrement As Integer = 13083

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorDivision Field

JavaScriptTokenIdOperatorDivision Field

Gets the OperatorDivision token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorDivision = 13080
Public Const OperatorDivision As Integer = 13080

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorDivisionAssignment Field

JavaScriptTokenIdOperatorDivisionAssignment Field

Gets the OperatorDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorDivisionAssignment = 13098
Public Const OperatorDivisionAssignment As Integer = 13098

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorEquality Field

JavaScriptTokenIdOperatorEquality Field

Gets the OperatorEquality token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorEquality = 13073
Public Const OperatorEquality As Integer = 13073

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorExclusiveOr Field

JavaScriptTokenIdOperatorExclusiveOr Field

Gets the OperatorExclusiveOr token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOr = 13089
Public Const OperatorExclusiveOr As Integer = 13089

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorExclusiveOrAssignment Field

JavaScriptTokenIdOperatorExclusiveOrAssignment Field

Gets the OperatorExclusiveOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOrAssignment = 13105
Public Const OperatorExclusiveOrAssignment As Integer = 13105

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorGreaterThan Field

JavaScriptTokenIdOperatorGreaterThan Field

Gets the OperatorGreaterThan token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThan = 13070
Public Const OperatorGreaterThan As Integer = 13070

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorGreaterThanOrEqual Field

JavaScriptTokenIdOperatorGreaterThanOrEqual Field

Gets the OperatorGreaterThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThanOrEqual = 13072
Public Const OperatorGreaterThanOrEqual As Integer = 13072

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorIncrement Field

JavaScriptTokenIdOperatorIncrement Field

Gets the OperatorIncrement token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorIncrement = 13082
Public Const OperatorIncrement As Integer = 13082

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorInequality Field

JavaScriptTokenIdOperatorInequality Field

Gets the OperatorInequality token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorInequality = 13074
Public Const OperatorInequality As Integer = 13074

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorLeftShift Field

JavaScriptTokenIdOperatorLeftShift Field

Gets the OperatorLeftShift token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLeftShift = 13084
Public Const OperatorLeftShift As Integer = 13084

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorLeftShiftAssignment Field

JavaScriptTokenIdOperatorLeftShiftAssignment Field

Gets the OperatorLeftShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLeftShiftAssignment = 13100
Public Const OperatorLeftShiftAssignment As Integer = 13100

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorLessThan Field

JavaScriptTokenIdOperatorLessThan Field

Gets the OperatorLessThan token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLessThan = 13069
Public Const OperatorLessThan As Integer = 13069

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorLessThanOrEqual Field

JavaScriptTokenIdOperatorLessThanOrEqual Field

Gets the OperatorLessThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLessThanOrEqual = 13071
Public Const OperatorLessThanOrEqual As Integer = 13071

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorModulus Field

JavaScriptTokenIdOperatorModulus Field

Gets the OperatorModulus token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorModulus = 13081
Public Const OperatorModulus As Integer = 13081

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorModulusAssignment Field

JavaScriptTokenIdOperatorModulusAssignment Field

Gets the OperatorModulusAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorModulusAssignment = 13099
Public Const OperatorModulusAssignment As Integer = 13099

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorMultiplication Field

JavaScriptTokenIdOperatorMultiplication Field

Gets the OperatorMultiplication token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorMultiplication = 13079
Public Const OperatorMultiplication As Integer = 13079

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorMultiplicationAssignment Field

JavaScriptTokenIdOperatorMultiplicationAssignment Field

Gets the OperatorMultiplicationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorMultiplicationAssignment = 13097
Public Const OperatorMultiplicationAssignment As Integer = 13097

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorNegation Field

JavaScriptTokenIdOperatorNegation Field

Gets the OperatorNegation token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorNegation = 13090
Public Const OperatorNegation As Integer = 13090

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorOnesComplement Field

JavaScriptTokenIdOperatorOnesComplement Field

Gets the OperatorOnesComplement token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorOnesComplement = 13091
Public Const OperatorOnesComplement As Integer = 13091

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorRightShift Field

JavaScriptTokenIdOperatorRightShift Field

Gets the OperatorRightShift token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorRightShift = 13085
Public Const OperatorRightShift As Integer = 13085

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorRightShiftAssignment Field

JavaScriptTokenIdOperatorRightShiftAssignment Field

Gets the OperatorRightShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorRightShiftAssignment = 13101
Public Const OperatorRightShiftAssignment As Integer = 13101

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorStrictEquality Field

JavaScriptTokenIdOperatorStrictEquality Field

Gets the OperatorStrictEquality token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorStrictEquality = 13075
Public Const OperatorStrictEquality As Integer = 13075

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorStrictInequality Field

JavaScriptTokenIdOperatorStrictInequality Field

Gets the OperatorStrictInequality token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorStrictInequality = 13076
Public Const OperatorStrictInequality As Integer = 13076

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorSubtraction Field

JavaScriptTokenIdOperatorSubtraction Field

Gets the OperatorSubtraction token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorSubtraction = 13078
Public Const OperatorSubtraction As Integer = 13078

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorSubtractionAssignment Field

JavaScriptTokenIdOperatorSubtractionAssignment Field

Gets the OperatorSubtractionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorSubtractionAssignment = 13096
Public Const OperatorSubtractionAssignment As Integer = 13096

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorZeroFillRightShift Field

JavaScriptTokenIdOperatorZeroFillRightShift Field

Gets the OperatorZeroFillRightShift token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorZeroFillRightShift = 13086
Public Const OperatorZeroFillRightShift As Integer = 13086

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorZeroFillRightShiftAssignment Field

JavaScriptTokenIdOperatorZeroFillRightShiftAssignment Field

Gets the OperatorZeroFillRightShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorZeroFillRightShiftAssignment = 13102
Public Const OperatorZeroFillRightShiftAssignment As Integer = 13102

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.QuestionMark Field

JavaScriptTokenIdQuestionMark Field

Gets the QuestionMark token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int QuestionMark = 13013
Public Const QuestionMark As Integer = 13013

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordClass Field

JavaScriptTokenIdReservedKeywordClass Field

Gets the ReservedKeywordClass token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordClass = 13053
Public Const ReservedKeywordClass As Integer = 13053

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordConst Field

JavaScriptTokenIdReservedKeywordConst Field

Gets the ReservedKeywordConst token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordConst = 13054
Public Const ReservedKeywordConst As Integer = 13054

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordEnum Field

JavaScriptTokenIdReservedKeywordEnum Field

Gets the ReservedKeywordEnum token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordEnum = 13055
Public Const ReservedKeywordEnum As Integer = 13055

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordExport Field

JavaScriptTokenIdReservedKeywordExport Field

Gets the ReservedKeywordExport token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordExport = 13056
Public Const ReservedKeywordExport As Integer = 13056

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordExtends Field

JavaScriptTokenIdReservedKeywordExtends Field

Gets the ReservedKeywordExtends token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordExtends = 13057
Public Const ReservedKeywordExtends As Integer = 13057

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordImplements Field

JavaScriptTokenIdReservedKeywordImplements Field

Gets the ReservedKeywordImplements token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordImplements = 13058
Public Const ReservedKeywordImplements As Integer = 13058

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordImport Field

JavaScriptTokenIdReservedKeywordImport Field

Gets the ReservedKeywordImport token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordImport = 13059
Public Const ReservedKeywordImport As Integer = 13059

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordInterface Field

JavaScriptTokenIdReservedKeywordInterface Field

Gets the ReservedKeywordInterface token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordInterface = 13060
Public Const ReservedKeywordInterface As Integer = 13060

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordLet Field

JavaScriptTokenIdReservedKeywordLet Field

Gets the ReservedKeywordLet token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordLet = 13061
Public Const ReservedKeywordLet As Integer = 13061

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordPackage Field

JavaScriptTokenIdReservedKeywordPackage Field

Gets the ReservedKeywordPackage token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordPackage = 13062
Public Const ReservedKeywordPackage As Integer = 13062

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordPrivate Field

JavaScriptTokenIdReservedKeywordPrivate Field

Gets the ReservedKeywordPrivate token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordPrivate = 13063
Public Const ReservedKeywordPrivate As Integer = 13063

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordProtected Field

JavaScriptTokenIdReservedKeywordProtected Field

Gets the ReservedKeywordProtected token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordProtected = 13064
Public Const ReservedKeywordProtected As Integer = 13064

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordPublic Field

JavaScriptTokenIdReservedKeywordPublic Field

Gets the ReservedKeywordPublic token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordPublic = 13065
Public Const ReservedKeywordPublic As Integer = 13065

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordStatic Field

JavaScriptTokenIdReservedKeywordStatic Field

Gets the ReservedKeywordStatic token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordStatic = 13066
Public Const ReservedKeywordStatic As Integer = 13066

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordSuper Field

JavaScriptTokenIdReservedKeywordSuper Field

Gets the ReservedKeywordSuper token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordSuper = 13067
Public Const ReservedKeywordSuper As Integer = 13067

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordYield Field

JavaScriptTokenIdReservedKeywordYield Field

Gets the ReservedKeywordYield token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReservedKeywordYield = 13068
Public Const ReservedKeywordYield As Integer = 13068

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.SemiColon Field

JavaScriptTokenIdSemiColon Field

Gets the SemiColon token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SemiColon = 13012
Public Const SemiColon As Integer = 13012

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Whitespace Field

JavaScriptTokenIdWhitespace Field

Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Whitespace = 13000
Public Const Whitespace As Integer = 13000

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader Class

Represents an object that can provide tokens to a ILLParser in a forward-only direction for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenReader

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptTokenReader : MergableTokenReader
Public Class JavaScriptTokenReader
    Inherits MergableTokenReader

The JavaScriptTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTokenReader | Initializes a new instance of the JavaScriptTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader Constructor

Initializes a new instance of the JavaScriptTokenReader class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

JavaScriptTokenReader Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader Properties

The JavaScriptTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

JavaScriptTokenReader Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader Methods

The JavaScriptTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Top
See Also

Reference

JavaScriptTokenReader Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader.GetNextToken Method

JavaScriptTokenReaderGetNextToken Method

Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

JavaScriptTokenReader Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Class

Represents an ITaggerT for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTagger

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptTokenTagger : TokenTagger
Public Class JavaScriptTokenTagger
    Inherits TokenTagger

The JavaScriptTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTokenTagger | Initializes a new instance of the JavaScriptTokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Constructor

Initializes a new instance of the JavaScriptTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptTokenTagger(
    ICodeDocument document,
    IJavaScriptClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    document As ICodeDocument,
    classificationTypeProvider As IJavaScriptClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypeProvider
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptClassificationTypeProvider
A IJavaScriptClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Properties

The JavaScriptTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Methods

The JavaScriptTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger.ClassifyToken Method

JavaScriptTokenTaggerClassifyToken Method

Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IClassificationType ClassifyToken(
    IToken token
)
Public Overrides Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Events

The JavaScriptTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider Class

Represents a provider of JavaScriptTokenTagger objects for documents that use the JavaScriptTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase JavaScriptTokenTagger
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JavaScriptTokenTaggerProvider : TaggerProviderBase<JavaScriptTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class JavaScriptTokenTaggerProvider
    Inherits TaggerProviderBase(Of JavaScriptTokenTagger)
    Implements ICodeDocumentTaggerProvider

The JavaScriptTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTokenTaggerProvider | Initializes a new instance of the JavaScriptTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider Constructor

Initializes a new instance of the JavaScriptTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptTokenTaggerProvider(
    IJavaScriptClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IJavaScriptClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptClassificationTypeProvider
A IJavaScriptClassificationTypeProvider that provides classification types.
See Also

Reference

JavaScriptTokenTaggerProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider Properties

The JavaScriptTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

JavaScriptTokenTaggerProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider Methods

The JavaScriptTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
See Also

Reference

JavaScriptTokenTaggerProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider.GetTagger(T) Method

JavaScriptTokenTaggerProviderGetTaggerT Method

Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

JavaScriptTokenTaggerProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider.TaggerFactory Class

JavaScriptTokenTaggerProviderTaggerFactory Class

Implements a factory that can creates JavaScriptTokenTagger objects for a document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTaggerProviderTaggerFactory

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TaggerFactory
Public Class TaggerFactory

The JavaScriptTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an JavaScriptTokenTagger for the ICodeDocument.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


TaggerFactory Methods

The JavaScriptTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an JavaScriptTokenTagger for the ICodeDocument.
Top
See Also

Reference

JavaScriptTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider.TaggerFactory.CreateTagger Method

JavaScriptTokenTaggerProviderTaggerFactoryCreateTagger Method

Creates an JavaScriptTokenTagger for the ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JavaScriptTokenTagger CreateTagger()
Public Function CreateTagger As JavaScriptTokenTagger

Return Value

Type: JavaScriptTokenTagger
An JavaScriptTokenTagger for the ICodeDocument.
See Also

Reference

JavaScriptTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonExampleTextProvider Class

Represents a example text provider for the JSON language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonExampleTextProvider : IExampleTextProvider
Public Class JsonExampleTextProvider
    Implements IExampleTextProvider

The JsonExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JsonExampleTextProvider | Initializes a new instance of the JsonExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonExampleTextProvider Constructor

Initializes a new instance of the JsonExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonExampleTextProvider()
Public Sub New
See Also

Reference

JsonExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonExampleTextProvider Properties

The JsonExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

JsonExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonExampleTextProvider.ExampleText Property

JsonExampleTextProviderExampleText Property

Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

JsonExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonGrammar Class

Represents a Grammar for the JSON language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonGrammar

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonGrammar : Grammar
Public Class JsonGrammar
    Inherits Grammar

The JsonGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | JsonGrammar | Initializes a new instance of the JsonGrammar class using default options.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonGrammar Constructor

Initializes a new instance of the JsonGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonGrammar()
Public Sub New
See Also

Reference

JsonGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonGrammar Properties

The JsonGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

JsonGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonGrammar Methods

The JsonGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

JsonGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider Class

Provides a JSON language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationDelimiterIndentProvider
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonIndentProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonIndentProvider : DelimiterIndentProvider
Public Class JsonIndentProvider
    Inherits DelimiterIndentProvider

The JsonIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JsonIndentProvider | Initializes a new instance of the JsonIndentProvider class.
Top
Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider Constructor

Initializes a new instance of the JsonIndentProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonIndentProvider()
Public Sub New
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider Properties

The JsonIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider.Mode Property

JsonIndentProviderMode Property

Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IndentMode Mode { get; }
Public Overrides ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider Methods

The JsonIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Top
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider.GetIndentAmount Method

JsonIndentProviderGetIndentAmount Method

Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Overrides Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider.OnDocumentTextChanged Method

JsonIndentProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overrides Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider.OnDocumentTextChanging Method

JsonIndentProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overrides Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Class

Represents a JSON lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonLexer

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonLexer : MergableLexerBase
Public Class JsonLexer
    Inherits MergableLexerBase

The JsonLexer type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLexer | Initializes a new instance of the JsonLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Constructor

Initializes a new instance of the JsonLexer class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonLexer()
Public Sub New
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Properties

The JsonLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer.LexicalStates Property

JsonLexerLexicalStates Property

Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Methods

The JsonLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer.GetAllLexicalStateTransitions Method

JsonLexerGetAllLexicalStateTransitions Method

Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer.GetNextToken Method

JsonLexerGetNextToken Method

Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Events

The JsonLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner Class

Provides a JSON language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonOutliner

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonOutliner : IOutliner
Public Class JsonOutliner
    Implements IOutliner

The JsonOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | JsonOutliner | Initializes a new instance of the JsonOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner Constructor

Initializes a new instance of the JsonOutliner class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonOutliner()
Public Sub New
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner Properties

The JsonOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner.UpdateTrigger Property

JsonOutlinerUpdateTrigger Property

Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner Methods

The JsonOutliner type exposes the following members.

Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner.GetOutliningSource Method

JsonOutlinerGetOutliningSource Method

Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource Class

Represents a JSON language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonOutliningSource

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonOutliningSource : RangeOutliningSourceBase
Public Class JsonOutliningSource
    Inherits RangeOutliningSourceBase

The JsonOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | JsonOutliningSource | Initializes a new instance of the JsonOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IJsonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJsonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource Constructor

Initializes a new instance of the JsonOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

JsonOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource Methods

The JsonOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IJsonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJsonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

JsonOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource.AddNodesFromParseData Method

JsonOutliningSourceAddNodesFromParseData Method

Overload List
 | Name | Description
Public method | AddNodesFromParseData(IJsonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJsonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

JsonOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource.AddNodesFromParseData Method (IJsonParseData)

JsonOutliningSourceAddNodesFromParseData Method (IJsonParseData)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IJsonParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IJsonParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.JavaScriptIJsonParseData
The IJsonParseData containing AST data.
See Also

Reference

JsonOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource.AddNodesFromParseData Method (IJsonParseData, ITextBufferReader)

JsonOutliningSourceAddNodesFromParseData Method (IJsonParseData, ITextBufferReader)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IJsonParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IJsonParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.JavaScriptIJsonParseData
The IJsonParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

JsonOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource.AddNodesRecursive Method

JsonOutliningSourceAddNodesRecursive Method

Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

JsonOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParseData Class

Stores the results of a JSON language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParseData

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonParseData : LLParseData,
    ILLParseData, IParseData, IParseErrorProvider, IJsonParseData
Public Class JsonParseData
    Inherits LLParseData
    Implements ILLParseData, IParseData, IParseErrorProvider, IJsonParseData

The JsonParseData type exposes the following members.

Constructors
 | Name | Description
Public method | JsonParseData | Initializes a new instance of the JsonParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParseData Constructor

Initializes a new instance of the JsonParseData class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonParseData()
Public Sub New
See Also

Reference

JsonParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParseData Properties

The JsonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

JsonParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Class

Represents a parser for the JSON language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParser

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonParser : LLParserBase
Public Class JsonParser
    Inherits LLParserBase

The JsonParser type exposes the following members.

Constructors
 | Name | Description
Public method | JsonParser | Initializes a new instance of the JsonParser class.
Public method | JsonParser(Grammar) | Initializes a new instance of the JsonParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Constructor

Overload List
 | Name | Description
Public method | JsonParser | Initializes a new instance of the JsonParser class.
Public method | JsonParser(Grammar) | Initializes a new instance of the JsonParser class.
Top
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Constructor

Initializes a new instance of the JsonParser class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonParser()
Public Sub New
See Also

Reference

JsonParser Class
JsonParser Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Constructor (Grammar)

Initializes a new instance of the JsonParser class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

JsonParser Class
JsonParser Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Properties

The JsonParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Methods

The JsonParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Top
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser.CreateParseData Method

JsonParserCreateParseData Method

Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser.CreateTokenReader Method

JsonParserCreateTokenReader Method

Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser.InitializeParserState Method

JsonParserInitializeParserState Method

Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.Text.Addons.JavaScript.Wpf (in ActiproSoftware.Text.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Class

Represents a JSON syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonSyntaxLanguage : SyntaxLanguage
Public Class JsonSyntaxLanguage
    Inherits SyntaxLanguage

The JsonSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | JsonSyntaxLanguage | Initializes a new instance of the JsonSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Constructor

Initializes a new instance of the JsonSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonSyntaxLanguage()
Public Sub New
See Also

Reference

JsonSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Properties

The JsonSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JsonSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Methods

The JsonSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JsonSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Events

The JsonSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JsonSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter Class

Provides a JSON language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonTextFormatter

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class JsonTextFormatter : ITextFormatter
Public Class JsonTextFormatter
    Implements ITextFormatter

The JsonTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | JsonTextFormatter | Initializes a new instance of the JsonTextFormatter class
Top
Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter Constructor

Initializes a new instance of the JsonTextFormatter class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public JsonTextFormatter()
Public Sub New
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter Properties

The JsonTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter.IsOpeningBraceOnNewLine Property

JsonTextFormatterIsOpeningBraceOnNewLine Property

Gets or sets a value indicating whether opening braces are on new lines.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOpeningBraceOnNewLine { get; set; }
Public Property IsOpeningBraceOnNewLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the opening braces are on new lines; otherwise, false.
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter Methods

The JsonTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter.Format Method

JsonTextFormatterFormat Method

Applies text formatting to part or all of a snapshot.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf (in ActiproSoftware.SyntaxEditor.Addons.JavaScript.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Format(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection selectionPositionRanges,
    TextFormatMode mode = TextFormatMode.Ranges
)
Public Sub Format (
    snapshot As ITextSnapshot,
    selectionPositionRanges As ITextPositionRangeCollection,
    Optional mode As TextFormatMode = TextFormatMode.Ranges
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
selectionPositionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the selection position ranges. These are used to translate the current selection to the new snapshot that is created, even when formatting the entire snapshot.
mode (Optional)
Type: ActiproSoftware.TextTextFormatMode
A TextFormatMode indicating whether to format part or all of the snapshot. The default value is Ranges.

Implements

ITextFormatterFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode)
Remarks
The containing ITextDocument is accessible via the ITextSnapshot.
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


ActiproSoftware.Text.Languages.Python Namespace

Contains the classes related to implementing a Python syntax language.
Classes
 | Class | Description
Public class | PythonContextLocations | Contains common context locations for a Python language.
Public class | PythonSyntaxLanguageExtensions | Contains extension methods that make it easier to work with Python ISyntaxLanguage objects.
Interfaces
 | Interface | Description
Public interface | IPythonClassificationTypeProvider | Provides the base requirements of an object that provides IClassificationType objects for the Python language.
Public interface | IPythonContext | Provides the base requirements for information about a Python language context of a certain offset within an ITextSnapshot.
Public interface | IPythonContextLocation | Provides the base requirements for an IPythonContext location, that determines what sort of resolver results are permitted.
Public interface | IPythonGrammarOptions | Contains options for a Python grammar.
Public interface | IPythonParseData | Provides the base requirements of an object that stores the results of a Python language parsing operation.
Enumerations
 | Enumeration | Description
Public enumeration | PythonContextKind | Specifies the kind of context.
Public enumeration | PythonDocstringDisplayMode | Indicates the display mode for Python docstring comments.
Public enumeration | PythonGrammarRootNonTerminal | Specifies the root non-terminal to use for a Python grammar.
Public enumeration | PythonVersion | Specifies the version of Python.


IPythonClassificationTypeProvider Interface

Provides the base requirements of an object that provides IClassificationType objects for the Python language.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPythonClassificationTypeProvider
Public Interface IPythonClassificationTypeProvider

The IPythonClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PythonSystemIdentifier | Gets the PythonSystemIdentifier classification type.
Public property | String | Gets the String classification type.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider Properties

The IPythonClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PythonSystemIdentifier | Gets the PythonSystemIdentifier classification type.
Public property | String | Gets the String classification type.
Top
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Comment Property

IPythonClassificationTypeProviderComment Property

Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Comment { get; }
ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Identifier Property

IPythonClassificationTypeProviderIdentifier Property

Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Identifier { get; }
ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Keyword Property

IPythonClassificationTypeProviderKeyword Property

Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Keyword { get; }
ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Number Property

IPythonClassificationTypeProviderNumber Property

Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Number { get; }
ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Operator Property

IPythonClassificationTypeProviderOperator Property

Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType Operator { get; }
ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.PythonSystemIdentifier Property

IPythonClassificationTypeProviderPythonSystemIdentifier Property

Gets the PythonSystemIdentifier classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType PythonSystemIdentifier { get; }
ReadOnly Property PythonSystemIdentifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The PythonSystemIdentifier classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.String Property

IPythonClassificationTypeProviderString Property

Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType String { get; }
ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext Interface

Provides the base requirements for information about a Python language context of a certain offset within an ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPythonContext
Public Interface IPythonContext

The IPythonContext type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentIndex | Gets the index of the current argument, if known, when the context is for the containing invocation.
Public property | ArgumentListSnapshotOffset | Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
Public property | ArgumentSnapshotOffset | Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
Public property | ContainingAstNode | Gets the IAstNode that contains the SnapshotOffset.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | Kind | Gets the PythonContextKind indicating the kind of context.
Public property | Location | Gets an optional IPythonContextLocation that provides more location information about the context.
Public property | Project | Gets the IProject with which this context is associated.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetExpression | Gets the target AST Expression for the context, if known.
Public property | TargetSnapshotOffset | Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.
Public property | Version | Gets the PythonVersion that indicates the Python version for which this context was created.
Top
Methods
 | Name | Description
Public method | Resolve | Uses the IResolver on the Project to return an IResolverResultSet.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


IPythonContext Properties

The IPythonContext type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentIndex | Gets the index of the current argument, if known, when the context is for the containing invocation.
Public property | ArgumentListSnapshotOffset | Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
Public property | ArgumentSnapshotOffset | Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
Public property | ContainingAstNode | Gets the IAstNode that contains the SnapshotOffset.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | Kind | Gets the PythonContextKind indicating the kind of context.
Public property | Location | Gets an optional IPythonContextLocation that provides more location information about the context.
Public property | Project | Gets the IProject with which this context is associated.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetExpression | Gets the target AST Expression for the context, if known.
Public property | TargetSnapshotOffset | Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.
Public property | Version | Gets the PythonVersion that indicates the Python version for which this context was created.
Top
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.ArgumentIndex Property

IPythonContextArgumentIndex Property

Gets the index of the current argument, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<int> ArgumentIndex { get; }
ReadOnly Property ArgumentIndex As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The index of the current argument, if known, when the context is for the containing invocation.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.ArgumentListSnapshotOffset Property

IPythonContextArgumentListSnapshotOffset Property

Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> ArgumentListSnapshotOffset { get; }
ReadOnly Property ArgumentListSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.ArgumentSnapshotOffset Property

IPythonContextArgumentSnapshotOffset Property

Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> ArgumentSnapshotOffset { get; }
ReadOnly Property ArgumentSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.ContainingAstNode Property

IPythonContextContainingAstNode Property

Gets the IAstNode that contains the SnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode ContainingAstNode { get; }
ReadOnly Property ContainingAstNode As IAstNode
    Get

Property Value

Type: IAstNode
The IAstNode that contains the SnapshotOffset.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.InitializationSnapshotRange Property

IPythonContextInitializationSnapshotRange Property

Gets the TextSnapshotRange with which the context was initialized.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotRange> InitializationSnapshotRange { get; }
ReadOnly Property InitializationSnapshotRange As Nullable(Of TextSnapshotRange)
    Get

Property Value

Type: Nullable TextSnapshotRange
The TextSnapshotRange with which the context was initialized.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Kind Property

IPythonContextKind Property

Gets the PythonContextKind indicating the kind of context.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PythonContextKind Kind { get; }
ReadOnly Property Kind As PythonContextKind
    Get

Property Value

Type: PythonContextKind
The PythonContextKind indicating the kind of context.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Location Property

IPythonContextLocation Property

Gets an optional IPythonContextLocation that provides more location information about the context.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IPythonContextLocation Location { get; }
ReadOnly Property Location As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
An optional IPythonContextLocation that provides more location information about the context.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Project Property

IPythonContextProject Property

Gets the IProject with which this context is associated.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProject Project { get; }
ReadOnly Property Project As IProject
    Get

Property Value

Type: IProject
The IProject with which this context is associated.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.SnapshotOffset Property

IPythonContextSnapshotOffset Property

Gets the TextSnapshotOffset for which this context was created.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotOffset SnapshotOffset { get; }
ReadOnly Property SnapshotOffset As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
The TextSnapshotOffset for which this context was created.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.TargetExpression Property

IPythonContextTargetExpression Property

Gets the target AST Expression for the context, if known.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Expression TargetExpression { get; }
ReadOnly Property TargetExpression As Expression
    Get

Property Value

Type: Expression
The target AST Expression for the context, if known.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.TargetSnapshotOffset Property

IPythonContextTargetSnapshotOffset Property

Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> TargetSnapshotOffset { get; }
ReadOnly Property TargetSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset, if known, against which to use as context for the resolver.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Version Property

IPythonContextVersion Property

Gets the PythonVersion that indicates the Python version for which this context was created.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PythonVersion Version { get; }
ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version for which this context was created.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext Methods

The IPythonContext type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Uses the IResolver on the Project to return an IResolverResultSet.
Top
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Resolve Method

IPythonContextResolve Method

Uses the IResolver on the Project to return an IResolverResultSet.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IResolverResultSet Resolve()
Function Resolve As IResolverResultSet

Return Value

Type: IResolverResultSet
The IResolverResultSet that was returned by the resolver.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContextLocation Interface

Provides the base requirements for an IPythonContext location, that determines what sort of resolver results are permitted.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPythonContextLocation
Public Interface IPythonContextLocation

The IPythonContextLocation type exposes the following members.

Methods
 | Name | Description
Public method | IsAllowed | Returns whether the specified IResolverResult is allowed within the context location.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


IPythonContextLocation Methods

The IPythonContextLocation type exposes the following members.

Methods
 | Name | Description
Public method | IsAllowed | Returns whether the specified IResolverResult is allowed within the context location.
Top
See Also

Reference

IPythonContextLocation Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContextLocation.IsAllowed Method

IPythonContextLocationIsAllowed Method

Returns whether the specified IResolverResult is allowed within the context location.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAllowed(
    IResolverResult result
)
Function IsAllowed (
    result As IResolverResult
) As Boolean

Parameters

result
Type: ActiproSoftware.Text.Languages.Python.ResolutionIResolverResult
The IResolverResult to examine.

Return Value

Type: Boolean
true if the specified IResolverResult is allowed within the context location; otherwise, false.
See Also

Reference

IPythonContextLocation Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonGrammarOptions Interface

Contains options for a Python grammar.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPythonGrammarOptions
Public Interface IPythonGrammarOptions

The IPythonGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


IPythonGrammarOptions Properties

The IPythonGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this grammar.
Top
See Also

Reference

IPythonGrammarOptions Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonGrammarOptions.RootNonTerminal Property

IPythonGrammarOptionsRootNonTerminal Property

Gets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PythonGrammarRootNonTerminal RootNonTerminal { get; }
ReadOnly Property RootNonTerminal As PythonGrammarRootNonTerminal
    Get

Property Value

Type: PythonGrammarRootNonTerminal
A PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

IPythonGrammarOptions Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonGrammarOptions.Version Property

IPythonGrammarOptionsVersion Property

Gets the PythonVersion that indicates the Python version supported by this grammar.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PythonVersion Version { get; }
ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this grammar.
See Also

Reference

IPythonGrammarOptions Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonParseData Interface

Provides the base requirements of an object that stores the results of a Python language parsing operation.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPythonParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IPythonParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IPythonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace
ActiproSoftware.Text.Languages.Python.ImplementationPythonParseData


IPythonParseData Properties

The IPythonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

IPythonParseData Interface
ActiproSoftware.Text.Languages.Python Namespace


PythonContextKind Enumeration

Specifies the kind of context.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PythonContextKind
Public Enumeration PythonContextKind
Members
Member name | Value | Description
Self | 0 | The context and its resolve operations work on the existing attribute referenced at the offset.
SelfAndSiblings | 1 | The context and its resolve operations work on the existing attribute and its siblings referenced at the offset.
ContainingInvocation | 2 | The context and its resolve operations work on the invocation that contains the offset, if any.
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations Class

Contains common context locations for a Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.PythonPythonContextLocations

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class PythonContextLocations
Public NotInheritable Class PythonContextLocations

The PythonContextLocations type exposes the following members.

Properties
Name | Description
BoundName | Gets the IPythonContextLocation that represents a bound name specification.
Comment | Gets the IPythonContextLocation that represents a comment specification.
FromImportIdentifier | Gets the IPythonContextLocation that represents an imported identifier of a from...import statement.
FromImportName | Gets the IPythonContextLocation that represents the name of a from...import statement.
ImportName | Gets the IPythonContextLocation that represents the name of an import statement.
LiteralString | Gets the IPythonContextLocation that represents a literal string specification.
Unknown | Gets the IPythonContextLocation that represents an unknown specification.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations Properties

The PythonContextLocations type exposes the following members.

Properties
Name | Description
BoundName | Gets the IPythonContextLocation that represents a bound name specification.
Comment | Gets the IPythonContextLocation that represents a comment specification.
FromImportIdentifier | Gets the IPythonContextLocation that represents an imported identifier of a from...import statement.
FromImportName | Gets the IPythonContextLocation that represents the name of a from...import statement.
ImportName | Gets the IPythonContextLocation that represents the name of an import statement.
LiteralString | Gets the IPythonContextLocation that represents a literal string specification.
Unknown | Gets the IPythonContextLocation that represents an unknown specification.
Top
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.BoundName Property

PythonContextLocationsBoundName Property

Gets the IPythonContextLocation that represents a bound name specification.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IPythonContextLocation BoundName { get; }
Public Shared ReadOnly Property BoundName As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.Comment Property

PythonContextLocationsComment Property

Gets the IPythonContextLocation that represents a comment specification.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IPythonContextLocation Comment { get; }
Public Shared ReadOnly Property Comment As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.FromImportIdentifier Property

PythonContextLocationsFromImportIdentifier Property

Gets the IPythonContextLocation that represents an imported identifier of a from...import statement.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IPythonContextLocation FromImportIdentifier { get; }
Public Shared ReadOnly Property FromImportIdentifier As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.FromImportName Property

PythonContextLocationsFromImportName Property

Gets the IPythonContextLocation that represents the name of a from...import statement.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IPythonContextLocation FromImportName { get; }
Public Shared ReadOnly Property FromImportName As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.ImportName Property

PythonContextLocationsImportName Property

Gets the IPythonContextLocation that represents the name of an import statement.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IPythonContextLocation ImportName { get; }
Public Shared ReadOnly Property ImportName As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.LiteralString Property

PythonContextLocationsLiteralString Property

Gets the IPythonContextLocation that represents a literal string specification.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IPythonContextLocation LiteralString { get; }
Public Shared ReadOnly Property LiteralString As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.Unknown Property

PythonContextLocationsUnknown Property

Gets the IPythonContextLocation that represents an unknown specification.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IPythonContextLocation Unknown { get; }
Public Shared ReadOnly Property Unknown As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonDocstringDisplayMode Enumeration

Indicates the display mode for Python docstring comments.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PythonDocstringDisplayMode
Public Enumeration PythonDocstringDisplayMode
Members
Member name | Value | Description
Summary | 0 | Only the summary (text before the first empty line) is displayed.
All | 1 | The entire docstring is displayed.
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonGrammarRootNonTerminal Enumeration

Specifies the root non-terminal to use for a Python grammar.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PythonGrammarRootNonTerminal
Public Enumeration PythonGrammarRootNonTerminal
Members
Member name | Value | Description
CompilationUnit | 0 | Compilation unit (the default).
Expression | 1 | Expression.
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions Class

Contains extension methods that make it easier to work with Python ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.PythonPythonSyntaxLanguageExtensions

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class PythonSyntaxLanguageExtensions
<ExtensionAttribute>
Public NotInheritable Class PythonSyntaxLanguageExtensions

The PythonSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetProject | Returns the IProject that can validate XML.
RegisterProject | Registers the IProject that can validate XML.
UnregisterProject | Unregisters the IProject that can validate XML.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions Methods

The PythonSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetProject | Returns the IProject that can validate XML.
RegisterProject | Registers the IProject that can validate XML.
UnregisterProject | Unregisters the IProject that can validate XML.
Top
See Also

Reference

PythonSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions.GetProject Method

PythonSyntaxLanguageExtensionsGetProject Method

Returns the IProject that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IProject GetProject(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetProject (
    language As ISyntaxLanguage
) As IProject

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IProject
The IProject instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions.RegisterProject Method

PythonSyntaxLanguageExtensionsRegisterProject Method

Registers the IProject that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterProject(
    this ISyntaxLanguage language,
    IProject value
)
<ExtensionAttribute>
Public Shared Sub RegisterProject (
    language As ISyntaxLanguage,
    value As IProject
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.Python.ReflectionIProject
The IProject instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions.UnregisterProject Method

PythonSyntaxLanguageExtensionsUnregisterProject Method

Unregisters the IProject that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterProject(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterProject (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Python Namespace


PythonVersion Enumeration

Specifies the version of Python.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PythonVersion
Public Enumeration PythonVersion
Members
Member name | Value | Description
Version2 | 0 | Python version 2 compatibility.
Version3 | 1 | Python version 3 compatibility.
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


ActiproSoftware.Text.Languages.Python.Ast Namespace

Contains the types related to ASTs for a Python syntax language.
Enumerations
 | Enumeration | Description
Public enumeration | ArgumentKind | Specifies the type of argument.
Public enumeration | LiteralExpressionKind | Specifies the type of literal expression.
Public enumeration | OperatorKind | Specifies the kind of an operator.
Public enumeration | ParameterKind | Specifies the type of parameter.


ArgumentKind Enumeration

Specifies the type of argument.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ArgumentKind
Public Enumeration ArgumentKind
Members
Member name | Value | Description
Normal | 0 | Normal.
Tuple | 1 | Tuple.
Dictionary | 2 | Dictionary.
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind Enumeration

Specifies the type of literal expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LiteralExpressionKind
Public Enumeration LiteralExpressionKind
Members
Member name | Value | Description
None | 0 | No kind indicated.
BinaryInteger | 1 | A binary integer.
Bytes | 2 | Bytes.
ConcatenatedString | 3 | A concatenated string.
DecimalInteger | 4 | A decimal integer.
DoubleQuoteLongString | 5 | A string of characters.
DoubleQuoteString | 6 | A string of characters.
HexadecimalInteger | 7 | A hexadecimal integer.
Imaginary | 8 | An imaginary number.
OctalInteger | 9 | An octal integer.
Real | 10 | A real number.
SingleQuoteLongString | 11 | A string of characters.
SingleQuoteString | 12 | A string of characters.
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind Enumeration

Specifies the kind of an operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum OperatorKind
Public Enumeration OperatorKind
Members
Member name | Value | Description
None | 0 | No valid operator kind.
Addition | 1 | An addition operator.
Subtraction | 2 | A subtraction operator.
Multiplication | 3 | A multiplication operator.
Power | 4 | A multiplication operator.
Division | 5 | A division operator.
FloorDivision | 6 | A floor division operator.
Modulus | 7 | A modulus operator.
BitwiseAnd | 8 | A bitwise AND operator.
BitwiseOr | 9 | A bitwise OR operator.
ExclusiveOr | 10 | A bitwise XOR operator.
Negation | 11 | A negation operator.
OnesComplement | 12 | A bitwise complement operator.
LessThan | 13 | A less than operator.
GreaterThan | 14 | A greater than operator.
LeftShift | 15 | A left shift operator.
RightShift | 16 | A right shift operator.
ValueEquality | 17 | A value equality operator.
ValueInequality | 18 | A value inequality operator.
ReferenceEquality | 19 | A reference equality operator.
ReferenceInequality | 20 | A reference inequality operator.
LessThanOrEqual | 21 | A less than or equal operator.
GreaterThanOrEqual | 22 | A greater than or equal operator.
ConditionalOr | 23 | A conditional OR binary operator.
ConditionalAnd | 24 | A conditional AND binary operator.
In | 25 | Contains operator.
NotIn | 26 | Opposite of contains operation.
MatrixMultiplication | 27 | Matrix multiplication operator.
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast Namespace


ParameterKind Enumeration

Specifies the type of parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ParameterKind
Public Enumeration ParameterKind
Members
Member name | Value | Description
Normal | 0 | Normal.
Tuple | 1 | Tuple.
Dictionary | 2 | Dictionary.
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast Namespace


ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace

Contains the implementation types related to ASTs for a Python syntax language.
Classes
 | Class | Description
Public class | Argument | Represents an argument.
Public class | AssertStatement | Represents an assert statement.
Public class | AssignmentStatement | Represents an assignment statement.
Public class | AttributeReferenceExpression | Represents an attribute reference expression.
Public class | BinaryOperatorExpression | Represents a binary operator expression.
Public class | BlockStatement | Represents a block statement.
Public class | BoundName | Represents a bound name.
Public class | BreakStatement | Represents a break statement.
Public class | ClassDeclaration | Represents a class declaration.
Public class | CompilationUnit | Represents a compilation unit.
Public class | ComprehensionClauseBase | Represents a comprehension clause base.
Public class | ComprehensionExpression | Represents a comprehension expression.
Public class | ComprehensionFor | Represents a comprehension for.
Public class | ComprehensionIf | Represents a comprehension if.
Public class | ConditionalExpression | Represents a conditional expression.
Public class | ContinueStatement | Represents a continue statement.
Public class | DeclarationBase | Represents a declaration base.
Public class | Decorator | Represents a decorator.
Public class | DeleteStatement | Represents a delete statement.
Public class | DictionaryExpression | Represents a dictionary expression.
Public class | Ellipsis | Represents an ellipsis.
Public class | ExecuteStatement | Represents an execute statement.
Public class | Expression | Represents an expression.
Public class | ExpressionStatement | Represents an expression statement.
Public class | ForStatement | Represents a for statement.
Public class | FromImportStatement | Represents a from import statement.
Public class | FunctionDeclaration | Represents a function declaration.
Public class | GeneratorExpression | Represents a generator expression.
Public class | GlobalStatement | Represents a global statement.
Public class | IfStatement | Represents an if statement.
Public class | IfStatementCondition | Represents an if statement condition.
Public class | ImportStatement | Represents an import statement.
Public class | InvocationExpression | Represents an invocation expression.
Public class | KeyValueExpression | Represents a key value expression.
Public class | LambdaExpression | Represents a lambda expression.
Public class | ListExpression | Represents a list expression.
Public class | LiteralExpression | Represents a literal expression.
Public class | NonLocalStatement | Represents a non local statement.
Public class | Parameter | Represents a parameter.
Public class | ParenthesizedExpression | Represents a parenthesized expression.
Public class | PassStatement | Represents a pass statement.
Public class | PrintStatement | Represents a print statement.
Public class | PythonAstNodeId | Contains the AST node IDs for the Python language.
Public class | RaiseStatement | Represents a raise statement.
Public class | ReturnStatement | Represents a return statement.
Public class | SetExpression | Represents a set expression.
Public class | SimpleName | Represents a simple name.
Public class | SliceExpression | Represents a slice expression.
Public class | SliceItem | Represents a slice item.
Public class | StarExpression | Represents a star expression.
Public class | Statement | Represents a statement.
Public class | StringConversionExpression | Represents a string conversion expression.
Public class | SubscriptionExpression | Represents a subscription expression.
Public class | TryStatement | Represents a try statement.
Public class | TryStatementExceptClause | Represents a try statement except clause.
Public class | TupleExpression | Represents a tuple expression.
Public class | UnaryOperatorExpression | Represents an unary operator expression.
Public class | WhileStatement | Represents a while statement.
Public class | WithStatement | Represents a with statement.
Public class | YieldExpression | Represents a yield expression.


Argument Class

Represents an argument.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationArgument

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Argument : AstNodeBase
Public Class Argument
    Inherits AstNodeBase

The Argument type exposes the following members.

Constructors
 | Name | Description
Public method | Argument | Initializes a new instance of the Argument class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument Constructor

Initializes a new instance of the Argument class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Argument()
Public Sub New
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument Properties

The Argument type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.Expression Property

ArgumentExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.Id Property

ArgumentId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.Kind Property

ArgumentKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ArgumentKind Kind { get; set; }
Public Property Kind As ArgumentKind
    Get
    Set

Property Value

Type: ArgumentKind
The kind.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.Name Property

ArgumentName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument Methods

The Argument type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.GetChildrenEnumerator Method

ArgumentGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement Class

Represents an assert statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAssertStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AssertStatement : Statement
Public Class AssertStatement
    Inherits Statement

The AssertStatement type exposes the following members.

Constructors
 | Name | Description
Public method | AssertStatement | Initializes a new instance of the AssertStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | MessageExpression | Gets or sets the message expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement Constructor

Initializes a new instance of the AssertStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AssertStatement()
Public Sub New
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement Properties

The AssertStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | MessageExpression | Gets or sets the message expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement.ConditionExpression Property

AssertStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement.Id Property

AssertStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement.MessageExpression Property

AssertStatementMessageExpression Property

Gets or sets the message expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression MessageExpression { get; set; }
Public Property MessageExpression As Expression
    Get
    Set

Property Value

Type: Expression
The message expression.
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement Methods

The AssertStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement.GetChildrenEnumerator Method

AssertStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement Class

Represents an assignment statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAssignmentStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AssignmentStatement : Statement
Public Class AssignmentStatement
    Inherits Statement

The AssignmentStatement type exposes the following members.

Constructors
 | Name | Description
Public method | AssignmentStatement | Initializes a new instance of the AssignmentStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement Constructor

Initializes a new instance of the AssignmentStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AssignmentStatement()
Public Sub New
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement Properties

The AssignmentStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.Id Property

AssignmentStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.LeftExpression Property

AssignmentStatementLeftExpression Property

Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.Operator Property

AssignmentStatementOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.RightExpression Property

AssignmentStatementRightExpression Property

Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement Methods

The AssignmentStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.GetChildrenEnumerator Method

AssignmentStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression Class

Represents an attribute reference expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAttributeReferenceExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AttributeReferenceExpression : Expression
Public Class AttributeReferenceExpression
    Inherits Expression

The AttributeReferenceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeReferenceExpression | Initializes a new instance of the AttributeReferenceExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression Constructor

Initializes a new instance of the AttributeReferenceExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AttributeReferenceExpression()
Public Sub New
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression Properties

The AttributeReferenceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression.Id Property

AttributeReferenceExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression.Name Property

AttributeReferenceExpressionName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression.TargetExpression Property

AttributeReferenceExpressionTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression Methods

The AttributeReferenceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression.GetChildrenEnumerator Method

AttributeReferenceExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression Class

Represents a binary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBinaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BinaryOperatorExpression : Expression
Public Class BinaryOperatorExpression
    Inherits Expression

The BinaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryOperatorExpression | Initializes a new instance of the BinaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression Constructor

Initializes a new instance of the BinaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BinaryOperatorExpression()
Public Sub New
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression Properties

The BinaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.Id Property

BinaryOperatorExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.LeftExpression Property

BinaryOperatorExpressionLeftExpression Property

Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.Operator Property

BinaryOperatorExpressionOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.RightExpression Property

BinaryOperatorExpressionRightExpression Property

Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression Methods

The BinaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.GetChildrenEnumerator Method

BinaryOperatorExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement Class

Represents a block statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBlockStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BlockStatement : Statement
Public Class BlockStatement
    Inherits Statement

The BlockStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BlockStatement | Initializes a new instance of the BlockStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement Constructor

Initializes a new instance of the BlockStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement()
Public Sub New
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement Properties

The BlockStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement.ChildStatements Property

BlockStatementChildStatements Property

Gets the child statements.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> ChildStatements { get; }
Public ReadOnly Property ChildStatements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The child statements.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement.HasChildStatements Property

BlockStatementHasChildStatements Property

Returns whether the ChildStatements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasChildStatements { get; }
Public ReadOnly Property HasChildStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement.Id Property

BlockStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement Methods

The BlockStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement.GetChildrenEnumerator Method

BlockStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName Class

Represents a bound name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBoundName

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BoundName : Expression
Public Class BoundName
    Inherits Expression

The BoundName type exposes the following members.

Constructors
 | Name | Description
Public method | BoundName | Initializes a new instance of the BoundName class
Top
Properties
 | Name | Description
Public property | Binding | Gets or sets the binding.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Original | Gets or sets the original.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ResolvedBinding | Gets the resolved binding name.
Public property | ResolvedFirstName | Gets the resolved first name.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName Constructor

Initializes a new instance of the BoundName class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BoundName()
Public Sub New
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName Properties

The BoundName type exposes the following members.

Properties
 | Name | Description
Public property | Binding | Gets or sets the binding.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Original | Gets or sets the original.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ResolvedBinding | Gets the resolved binding name.
Public property | ResolvedFirstName | Gets the resolved first name.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.Binding Property

BoundNameBinding Property

Gets or sets the binding.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Binding { get; set; }
Public Property Binding As String
    Get
    Set

Property Value

Type: String
The binding.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.Id Property

BoundNameId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.Original Property

BoundNameOriginal Property

Gets or sets the original.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Original { get; set; }
Public Property Original As String
    Get
    Set

Property Value

Type: String
The original.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.ResolvedBinding Property

BoundNameResolvedBinding Property

Gets the resolved binding name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedBinding { get; }
Public ReadOnly Property ResolvedBinding As String
    Get

Property Value

Type: String
The resolved binding name.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.ResolvedFirstName Property

BoundNameResolvedFirstName Property

Gets the resolved first name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFirstName { get; }
Public ReadOnly Property ResolvedFirstName As String
    Get

Property Value

Type: String
The resolved first name.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.Value Property

BoundNameValue Property

Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName Methods

The BoundName type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.ToString Method

BoundNameToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement Class

Represents a break statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBreakStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BreakStatement : Statement
Public Class BreakStatement
    Inherits Statement

The BreakStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BreakStatement | Initializes a new instance of the BreakStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement Constructor

Initializes a new instance of the BreakStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BreakStatement()
Public Sub New
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement Properties

The BreakStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement.Id Property

BreakStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement Methods

The BreakStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration Class

Represents a class declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeclarationBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationClassDeclaration

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ClassDeclaration : DeclarationBase
Public Class ClassDeclaration
    Inherits DeclarationBase

The ClassDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ClassDeclaration | Initializes a new instance of the ClassDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body. (Inherited from DeclarationBase.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Decorators | Gets the decorators. (Inherited from DeclarationBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item. (Inherited from DeclarationBase.)
Public property | HasInheritance | Returns whether the Inheritance collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides DeclarationBaseId.)
Public property | Inheritance | Gets the inheritance.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name. (Inherited from DeclarationBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides DeclarationBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration Constructor

Initializes a new instance of the ClassDeclaration class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ClassDeclaration()
Public Sub New
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration Properties

The ClassDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body. (Inherited from DeclarationBase.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Decorators | Gets the decorators. (Inherited from DeclarationBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item. (Inherited from DeclarationBase.)
Public property | HasInheritance | Returns whether the Inheritance collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides DeclarationBaseId.)
Public property | Inheritance | Gets the inheritance.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name. (Inherited from DeclarationBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration.HasInheritance Property

ClassDeclarationHasInheritance Property

Returns whether the Inheritance collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasInheritance { get; }
Public ReadOnly Property HasInheritance As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration.Id Property

ClassDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration.Inheritance Property

ClassDeclarationInheritance Property

Gets the inheritance.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Inheritance { get; }
Public ReadOnly Property Inheritance As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The inheritance.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration Methods

The ClassDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides DeclarationBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration.GetChildrenEnumerator Method

ClassDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit Class

Represents a compilation unit.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationCompilationUnit

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CompilationUnit : AstNodeBase
Public Class CompilationUnit
    Inherits AstNodeBase

The CompilationUnit type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnit | Initializes a new instance of the CompilationUnit class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit Constructor

Initializes a new instance of the CompilationUnit class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CompilationUnit()
Public Sub New
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit Properties

The CompilationUnit type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit.HasStatements Property

CompilationUnitHasStatements Property

Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit.Id Property

CompilationUnitId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit.Statements Property

CompilationUnitStatements Property

Gets the statements.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit Methods

The CompilationUnit type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit.GetChildrenEnumerator Method

CompilationUnitGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase Class

Represents a comprehension clause base.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionClauseBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionFor
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionIf

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ComprehensionClauseBase : AstNodeBase
Public Class ComprehensionClauseBase
    Inherits AstNodeBase

The ComprehensionClauseBase type exposes the following members.

Constructors
 | Name | Description
Public method | ComprehensionClauseBase | Initializes a new instance of the ComprehensionClauseBase class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase Constructor

Initializes a new instance of the ComprehensionClauseBase class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ComprehensionClauseBase()
Public Sub New
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase Properties

The ComprehensionClauseBase type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase.Id Property

ComprehensionClauseBaseId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase.NextClause Property

ComprehensionClauseBaseNextClause Property

Gets or sets the next clause.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ComprehensionClauseBase NextClause { get; set; }
Public Property NextClause As ComprehensionClauseBase
    Get
    Set

Property Value

Type: ComprehensionClauseBase
The next clause.
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase Methods

The ComprehensionClauseBase type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase.GetChildrenEnumerator Method

ComprehensionClauseBaseGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression Class

Represents a comprehension expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ComprehensionExpression : Expression
Public Class ComprehensionExpression
    Inherits Expression

The ComprehensionExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ComprehensionExpression | Initializes a new instance of the ComprehensionExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Clause | Gets or sets the clause.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression Constructor

Initializes a new instance of the ComprehensionExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ComprehensionExpression()
Public Sub New
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression Properties

The ComprehensionExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Clause | Gets or sets the clause.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression.ChildExpression Property

ComprehensionExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression.Clause Property

ComprehensionExpressionClause Property

Gets or sets the clause.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ComprehensionClauseBase Clause { get; set; }
Public Property Clause As ComprehensionClauseBase
    Get
    Set

Property Value

Type: ComprehensionClauseBase
The clause.
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression.Id Property

ComprehensionExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression Methods

The ComprehensionExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression.GetChildrenEnumerator Method

ComprehensionExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor Class

Represents a comprehension for.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionClauseBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionFor

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ComprehensionFor : ComprehensionClauseBase
Public Class ComprehensionFor
    Inherits ComprehensionClauseBase

The ComprehensionFor type exposes the following members.

Constructors
 | Name | Description
Public method | ComprehensionFor | Initializes a new instance of the ComprehensionFor class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ComprehensionClauseBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause. (Inherited from ComprehensionClauseBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides ComprehensionClauseBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor Constructor

Initializes a new instance of the ComprehensionFor class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ComprehensionFor()
Public Sub New
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor Properties

The ComprehensionFor type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ComprehensionClauseBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause. (Inherited from ComprehensionClauseBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor.ElementExpression Property

ComprehensionForElementExpression Property

Gets or sets the element expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ElementExpression { get; set; }
Public Property ElementExpression As Expression
    Get
    Set

Property Value

Type: Expression
The element expression.
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor.EnumerableExpression Property

ComprehensionForEnumerableExpression Property

Gets or sets the enumerable expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression EnumerableExpression { get; set; }
Public Property EnumerableExpression As Expression
    Get
    Set

Property Value

Type: Expression
The enumerable expression.
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor.Id Property

ComprehensionForId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor Methods

The ComprehensionFor type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides ComprehensionClauseBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor.GetChildrenEnumerator Method

ComprehensionForGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf Class

Represents a comprehension if.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionClauseBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionIf

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ComprehensionIf : ComprehensionClauseBase
Public Class ComprehensionIf
    Inherits ComprehensionClauseBase

The ComprehensionIf type exposes the following members.

Constructors
 | Name | Description
Public method | ComprehensionIf | Initializes a new instance of the ComprehensionIf class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ComprehensionClauseBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause. (Inherited from ComprehensionClauseBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides ComprehensionClauseBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf Constructor

Initializes a new instance of the ComprehensionIf class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ComprehensionIf()
Public Sub New
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf Properties

The ComprehensionIf type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ComprehensionClauseBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause. (Inherited from ComprehensionClauseBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf.ConditionExpression Property

ComprehensionIfConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf.Id Property

ComprehensionIfId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf Methods

The ComprehensionIf type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides ComprehensionClauseBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf.GetChildrenEnumerator Method

ComprehensionIfGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression Class

Represents a conditional expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationConditionalExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ConditionalExpression : Expression
Public Class ConditionalExpression
    Inherits Expression

The ConditionalExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ConditionalExpression | Initializes a new instance of the ConditionalExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression Constructor

Initializes a new instance of the ConditionalExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ConditionalExpression()
Public Sub New
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression Properties

The ConditionalExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.ConditionExpression Property

ConditionalExpressionConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.FalseExpression Property

ConditionalExpressionFalseExpression Property

Gets or sets the false expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression FalseExpression { get; set; }
Public Property FalseExpression As Expression
    Get
    Set

Property Value

Type: Expression
The false expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.Id Property

ConditionalExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.TrueExpression Property

ConditionalExpressionTrueExpression Property

Gets or sets the true expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TrueExpression { get; set; }
Public Property TrueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The true expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression Methods

The ConditionalExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.GetChildrenEnumerator Method

ConditionalExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement Class

Represents a continue statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationContinueStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ContinueStatement : Statement
Public Class ContinueStatement
    Inherits Statement

The ContinueStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ContinueStatement | Initializes a new instance of the ContinueStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement Constructor

Initializes a new instance of the ContinueStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContinueStatement()
Public Sub New
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement Properties

The ContinueStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement.Id Property

ContinueStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement Methods

The ContinueStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase Class

Represents a declaration base.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeclarationBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationClassDeclaration
ActiproSoftware.Text.Languages.Python.Ast.ImplementationFunctionDeclaration

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DeclarationBase : Statement
Public Class DeclarationBase
    Inherits Statement

The DeclarationBase type exposes the following members.

Constructors
 | Name | Description
Public method | DeclarationBase | Initializes a new instance of the DeclarationBase class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Decorators | Gets the decorators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase Constructor

Initializes a new instance of the DeclarationBase class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DeclarationBase()
Public Sub New
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase Properties

The DeclarationBase type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Decorators | Gets the decorators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.Body Property

DeclarationBaseBody Property

Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BlockStatement Body { get; set; }
Public Property Body As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The body.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.Decorators Property

DeclarationBaseDecorators Property

Gets the decorators.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Decorator> Decorators { get; }
Public ReadOnly Property Decorators As IList(Of Decorator)
    Get

Property Value

Type: IList Decorator
The decorators.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.HasDecorators Property

DeclarationBaseHasDecorators Property

Returns whether the Decorators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDecorators { get; }
Public ReadOnly Property HasDecorators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.Id Property

DeclarationBaseId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.Name Property

DeclarationBaseName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase Methods

The DeclarationBase type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.GetChildrenEnumerator Method

DeclarationBaseGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator Class

Represents a decorator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDecorator

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Decorator : AstNodeBase
Public Class Decorator
    Inherits AstNodeBase

The Decorator type exposes the following members.

Constructors
 | Name | Description
Public method | Decorator | Initializes a new instance of the Decorator class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator Constructor

Initializes a new instance of the Decorator class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Decorator()
Public Sub New
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator Properties

The Decorator type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.Arguments Property

DecoratorArguments Property

Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.HasArguments Property

DecoratorHasArguments Property

Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.Id Property

DecoratorId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.Name Property

DecoratorName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator Methods

The Decorator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.GetChildrenEnumerator Method

DecoratorGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement Class

Represents a delete statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeleteStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DeleteStatement : Statement
Public Class DeleteStatement
    Inherits Statement

The DeleteStatement type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteStatement | Initializes a new instance of the DeleteStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement Constructor

Initializes a new instance of the DeleteStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DeleteStatement()
Public Sub New
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement Properties

The DeleteStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement.Expression Property

DeleteStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement.Id Property

DeleteStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement Methods

The DeleteStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement.GetChildrenEnumerator Method

DeleteStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression Class

Represents a dictionary expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDictionaryExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DictionaryExpression : Expression
Public Class DictionaryExpression
    Inherits Expression

The DictionaryExpression type exposes the following members.

Constructors
 | Name | Description
Public method | DictionaryExpression | Initializes a new instance of the DictionaryExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression Constructor

Initializes a new instance of the DictionaryExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DictionaryExpression()
Public Sub New
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression Properties

The DictionaryExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression.HasItems Property

DictionaryExpressionHasItems Property

Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression.Id Property

DictionaryExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression.Items Property

DictionaryExpressionItems Property

Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Items { get; }
Public ReadOnly Property Items As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The items.
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression Methods

The DictionaryExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression.GetChildrenEnumerator Method

DictionaryExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis Class

Represents an ellipsis.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationEllipsis

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Ellipsis : Expression
Public Class Ellipsis
    Inherits Expression

The Ellipsis type exposes the following members.

Constructors
 | Name | Description
Public method | Ellipsis | Initializes a new instance of the Ellipsis class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis Constructor

Initializes a new instance of the Ellipsis class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Ellipsis()
Public Sub New
See Also

Reference

Ellipsis Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis Properties

The Ellipsis type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Ellipsis Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis.Id Property

EllipsisId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Ellipsis Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis Methods

The Ellipsis type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Ellipsis Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement Class

Represents an execute statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExecuteStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExecuteStatement : Statement
Public Class ExecuteStatement
    Inherits Statement

The ExecuteStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExecuteStatement | Initializes a new instance of the ExecuteStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CodeExpression | Gets or sets the code expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | GlobalsExpression | Gets or sets the globals expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LocalsExpression | Gets or sets the locals expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement Constructor

Initializes a new instance of the ExecuteStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExecuteStatement()
Public Sub New
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement Properties

The ExecuteStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CodeExpression | Gets or sets the code expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | GlobalsExpression | Gets or sets the globals expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LocalsExpression | Gets or sets the locals expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.CodeExpression Property

ExecuteStatementCodeExpression Property

Gets or sets the code expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression CodeExpression { get; set; }
Public Property CodeExpression As Expression
    Get
    Set

Property Value

Type: Expression
The code expression.
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.GlobalsExpression Property

ExecuteStatementGlobalsExpression Property

Gets or sets the globals expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression GlobalsExpression { get; set; }
Public Property GlobalsExpression As Expression
    Get
    Set

Property Value

Type: Expression
The globals expression.
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.Id Property

ExecuteStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.LocalsExpression Property

ExecuteStatementLocalsExpression Property

Gets or sets the locals expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression LocalsExpression { get; set; }
Public Property LocalsExpression As Expression
    Get
    Set

Property Value

Type: Expression
The locals expression.
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement Methods

The ExecuteStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.GetChildrenEnumerator Method

ExecuteStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Expression Class

Represents an expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
More...

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Expression : AstNodeBase
Public Class Expression
    Inherits AstNodeBase

The Expression type exposes the following members.

Constructors
 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAttributeReferenceExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBinaryOperatorExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBoundName
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationConditionalExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDictionaryExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationEllipsis
ActiproSoftware.Text.Languages.Python.Ast.ImplementationGeneratorExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationInvocationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationKeyValueExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationLambdaExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationListExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationLiteralExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationParenthesizedExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSetExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSimpleName
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSliceExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStarExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStringConversionExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSubscriptionExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTupleExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationUnaryOperatorExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationYieldExpression


Expression Constructor

Initializes a new instance of the Expression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression()
Public Sub New
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Expression Properties

The Expression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Expression.Id Property

ExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Expression Methods

The Expression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement Class

Represents an expression statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpressionStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExpressionStatement : Statement
Public Class ExpressionStatement
    Inherits Statement

The ExpressionStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionStatement | Initializes a new instance of the ExpressionStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement Constructor

Initializes a new instance of the ExpressionStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpressionStatement()
Public Sub New
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement Properties

The ExpressionStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement.Expression Property

ExpressionStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement.Id Property

ExpressionStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement Methods

The ExpressionStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement.GetChildrenEnumerator Method

ExpressionStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement Class

Represents a for statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationForStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ForStatement : Statement
Public Class ForStatement
    Inherits Statement

The ForStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForStatement | Initializes a new instance of the ForStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElementExpression | Gets or sets the element expression.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LoopStatement | Gets or sets the loop statement.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement Constructor

Initializes a new instance of the ForStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ForStatement()
Public Sub New
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement Properties

The ForStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElementExpression | Gets or sets the element expression.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LoopStatement | Gets or sets the loop statement.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.ElementExpression Property

ForStatementElementExpression Property

Gets or sets the element expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ElementExpression { get; set; }
Public Property ElementExpression As Expression
    Get
    Set

Property Value

Type: Expression
The element expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.ElseStatement Property

ForStatementElseStatement Property

Gets or sets the else statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ElseStatement { get; set; }
Public Property ElseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The else statement.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.EnumerableExpression Property

ForStatementEnumerableExpression Property

Gets or sets the enumerable expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression EnumerableExpression { get; set; }
Public Property EnumerableExpression As Expression
    Get
    Set

Property Value

Type: Expression
The enumerable expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.Id Property

ForStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.LoopStatement Property

ForStatementLoopStatement Property

Gets or sets the loop statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement LoopStatement { get; set; }
Public Property LoopStatement As Statement
    Get
    Set

Property Value

Type: Statement
The loop statement.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement Methods

The ForStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.GetChildrenEnumerator Method

ForStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement Class

Represents a from import statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationFromImportStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FromImportStatement : Statement
Public Class FromImportStatement
    Inherits Statement

The FromImportStatement type exposes the following members.

Constructors
 | Name | Description
Public method | FromImportStatement | Initializes a new instance of the FromImportStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasIdentifiers | Returns whether the Identifiers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Identifiers | Gets the identifiers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ModuleName | Gets or sets the module name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement Constructor

Initializes a new instance of the FromImportStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FromImportStatement()
Public Sub New
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement Properties

The FromImportStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasIdentifiers | Returns whether the Identifiers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Identifiers | Gets the identifiers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ModuleName | Gets or sets the module name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.HasIdentifiers Property

FromImportStatementHasIdentifiers Property

Returns whether the Identifiers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasIdentifiers { get; }
Public ReadOnly Property HasIdentifiers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.Id Property

FromImportStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.Identifiers Property

FromImportStatementIdentifiers Property

Gets the identifiers.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<BoundName> Identifiers { get; }
Public ReadOnly Property Identifiers As IList(Of BoundName)
    Get

Property Value

Type: IList BoundName
The identifiers.
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.ModuleName Property

FromImportStatementModuleName Property

Gets or sets the module name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BoundName ModuleName { get; set; }
Public Property ModuleName As BoundName
    Get
    Set

Property Value

Type: BoundName
The module name.
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement Methods

The FromImportStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.GetChildrenEnumerator Method

FromImportStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration Class

Represents a function declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeclarationBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationFunctionDeclaration

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FunctionDeclaration : DeclarationBase
Public Class FunctionDeclaration
    Inherits DeclarationBase

The FunctionDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionDeclaration | Initializes a new instance of the FunctionDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body. (Inherited from DeclarationBase.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DeclaringClass | Gets the declaring class, if the function is a method.
Public property | Decorators | Gets the decorators. (Inherited from DeclarationBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item. (Inherited from DeclarationBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides DeclarationBaseId.)
Public property | IsClassMethod | Gets whether this definition is a class method.
Public property | IsMethod | Gets whether this definition is a method.
Public property | IsStaticMethod | Gets whether this definition is a static method.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name. (Inherited from DeclarationBase.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnAnnotationExpression | Gets or sets the return annotation expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides DeclarationBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration Constructor

Initializes a new instance of the FunctionDeclaration class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FunctionDeclaration()
Public Sub New
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration Properties

The FunctionDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body. (Inherited from DeclarationBase.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DeclaringClass | Gets the declaring class, if the function is a method.
Public property | Decorators | Gets the decorators. (Inherited from DeclarationBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item. (Inherited from DeclarationBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides DeclarationBaseId.)
Public property | IsClassMethod | Gets whether this definition is a class method.
Public property | IsMethod | Gets whether this definition is a method.
Public property | IsStaticMethod | Gets whether this definition is a static method.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name. (Inherited from DeclarationBase.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnAnnotationExpression | Gets or sets the return annotation expression.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.DeclaringClass Property

FunctionDeclarationDeclaringClass Property

Gets the declaring class, if the function is a method.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ClassDeclaration DeclaringClass { get; }
Public ReadOnly Property DeclaringClass As ClassDeclaration
    Get

Property Value

Type: ClassDeclaration
The declaring class, if the function is a method.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.HasParameters Property

FunctionDeclarationHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.Id Property

FunctionDeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.IsClassMethod Property

FunctionDeclarationIsClassMethod Property

Gets whether this definition is a class method.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsClassMethod { get; }
Public ReadOnly Property IsClassMethod As Boolean
    Get

Property Value

Type: Boolean
true if this definition is a class method; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.IsMethod Property

FunctionDeclarationIsMethod Property

Gets whether this definition is a method.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMethod { get; }
Public ReadOnly Property IsMethod As Boolean
    Get

Property Value

Type: Boolean
true if this definition is a method; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.IsStaticMethod Property

FunctionDeclarationIsStaticMethod Property

Gets whether this definition is a static method.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsStaticMethod { get; }
Public ReadOnly Property IsStaticMethod As Boolean
    Get

Property Value

Type: Boolean
true if this definition is a static method; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.Parameters Property

FunctionDeclarationParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Parameter> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of Parameter)
    Get

Property Value

Type: IList Parameter
The parameters.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.ReturnAnnotationExpression Property

FunctionDeclarationReturnAnnotationExpression Property

Gets or sets the return annotation expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ReturnAnnotationExpression { get; set; }
Public Property ReturnAnnotationExpression As Expression
    Get
    Set

Property Value

Type: Expression
The return annotation expression.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration Methods

The FunctionDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides DeclarationBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.GetChildrenEnumerator Method

FunctionDeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression Class

Represents a generator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationGeneratorExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GeneratorExpression : Expression
Public Class GeneratorExpression
    Inherits Expression

The GeneratorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | GeneratorExpression | Initializes a new instance of the GeneratorExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression Constructor

Initializes a new instance of the GeneratorExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GeneratorExpression()
Public Sub New
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression Properties

The GeneratorExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression.ChildExpression Property

GeneratorExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression.Id Property

GeneratorExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression Methods

The GeneratorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression.GetChildrenEnumerator Method

GeneratorExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement Class

Represents a global statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationGlobalStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GlobalStatement : Statement
Public Class GlobalStatement
    Inherits Statement

The GlobalStatement type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalStatement | Initializes a new instance of the GlobalStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNames | Returns whether the Names collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Names | Gets the names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement Constructor

Initializes a new instance of the GlobalStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GlobalStatement()
Public Sub New
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement Properties

The GlobalStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNames | Returns whether the Names collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Names | Gets the names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement.HasNames Property

GlobalStatementHasNames Property

Returns whether the Names collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasNames { get; }
Public ReadOnly Property HasNames As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement.Id Property

GlobalStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement.Names Property

GlobalStatementNames Property

Gets the names.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<SimpleName> Names { get; }
Public ReadOnly Property Names As IList(Of SimpleName)
    Get

Property Value

Type: IList SimpleName
The names.
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement Methods

The GlobalStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement.GetChildrenEnumerator Method

GlobalStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement Class

Represents an if statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationIfStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class IfStatement : Statement
Public Class IfStatement
    Inherits Statement

The IfStatement type exposes the following members.

Constructors
 | Name | Description
Public method | IfStatement | Initializes a new instance of the IfStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Conditions | Gets the conditions.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasConditions | Returns whether the Conditions collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement Constructor

Initializes a new instance of the IfStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IfStatement()
Public Sub New
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement Properties

The IfStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Conditions | Gets the conditions.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasConditions | Returns whether the Conditions collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.Conditions Property

IfStatementConditions Property

Gets the conditions.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IfStatementCondition> Conditions { get; }
Public ReadOnly Property Conditions As IList(Of IfStatementCondition)
    Get

Property Value

Type: IList IfStatementCondition
The conditions.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.ElseStatement Property

IfStatementElseStatement Property

Gets or sets the else statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ElseStatement { get; set; }
Public Property ElseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The else statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.HasConditions Property

IfStatementHasConditions Property

Returns whether the Conditions collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasConditions { get; }
Public ReadOnly Property HasConditions As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.Id Property

IfStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement Methods

The IfStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.GetChildrenEnumerator Method

IfStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition Class

Represents an if statement condition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationIfStatementCondition

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class IfStatementCondition : AstNodeBase
Public Class IfStatementCondition
    Inherits AstNodeBase

The IfStatementCondition type exposes the following members.

Constructors
 | Name | Description
Public method | IfStatementCondition | Initializes a new instance of the IfStatementCondition class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition Constructor

Initializes a new instance of the IfStatementCondition class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IfStatementCondition()
Public Sub New
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition Properties

The IfStatementCondition type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition.ConditionExpression Property

IfStatementConditionConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition.Id Property

IfStatementConditionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition.Statement Property

IfStatementConditionStatement Property

Gets or sets the statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement Statement { get; set; }
Public Property Statement As Statement
    Get
    Set

Property Value

Type: Statement
The statement.
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition Methods

The IfStatementCondition type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition.GetChildrenEnumerator Method

IfStatementConditionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement Class

Represents an import statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationImportStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ImportStatement : Statement
Public Class ImportStatement
    Inherits Statement

The ImportStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ImportStatement | Initializes a new instance of the ImportStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasModuleNames | Returns whether the ModuleNames collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ModuleNames | Gets the module names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement Constructor

Initializes a new instance of the ImportStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImportStatement()
Public Sub New
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement Properties

The ImportStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasModuleNames | Returns whether the ModuleNames collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ModuleNames | Gets the module names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement.HasModuleNames Property

ImportStatementHasModuleNames Property

Returns whether the ModuleNames collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasModuleNames { get; }
Public ReadOnly Property HasModuleNames As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement.Id Property

ImportStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement.ModuleNames Property

ImportStatementModuleNames Property

Gets the module names.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<BoundName> ModuleNames { get; }
Public ReadOnly Property ModuleNames As IList(Of BoundName)
    Get

Property Value

Type: IList BoundName
The module names.
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement Methods

The ImportStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement.GetChildrenEnumerator Method

ImportStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression Class

Represents an invocation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationInvocationExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InvocationExpression : Expression
Public Class InvocationExpression
    Inherits Expression

The InvocationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InvocationExpression | Initializes a new instance of the InvocationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression Constructor

Initializes a new instance of the InvocationExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvocationExpression()
Public Sub New
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression Properties

The InvocationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.Arguments Property

InvocationExpressionArguments Property

Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.HasArguments Property

InvocationExpressionHasArguments Property

Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.Id Property

InvocationExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.TargetExpression Property

InvocationExpressionTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression Methods

The InvocationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.GetChildrenEnumerator Method

InvocationExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression Class

Represents a key value expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationKeyValueExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class KeyValueExpression : Expression
Public Class KeyValueExpression
    Inherits Expression

The KeyValueExpression type exposes the following members.

Constructors
 | Name | Description
Public method | KeyValueExpression | Initializes a new instance of the KeyValueExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | KeyExpression | Gets or sets the key expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | ValueExpression | Gets or sets the value expression.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression Constructor

Initializes a new instance of the KeyValueExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public KeyValueExpression()
Public Sub New
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression Properties

The KeyValueExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | KeyExpression | Gets or sets the key expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | ValueExpression | Gets or sets the value expression.
Top
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression.Id Property

KeyValueExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression.KeyExpression Property

KeyValueExpressionKeyExpression Property

Gets or sets the key expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression KeyExpression { get; set; }
Public Property KeyExpression As Expression
    Get
    Set

Property Value

Type: Expression
The key expression.
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression.ValueExpression Property

KeyValueExpressionValueExpression Property

Gets or sets the value expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ValueExpression { get; set; }
Public Property ValueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The value expression.
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression Methods

The KeyValueExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression.GetChildrenEnumerator Method

KeyValueExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression Class

Represents a lambda expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationLambdaExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LambdaExpression : Expression
Public Class LambdaExpression
    Inherits Expression

The LambdaExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LambdaExpression | Initializes a new instance of the LambdaExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression Constructor

Initializes a new instance of the LambdaExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LambdaExpression()
Public Sub New
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression Properties

The LambdaExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.ChildExpression Property

LambdaExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.HasParameters Property

LambdaExpressionHasParameters Property

Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.Id Property

LambdaExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.Parameters Property

LambdaExpressionParameters Property

Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Parameter> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of Parameter)
    Get

Property Value

Type: IList Parameter
The parameters.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression Methods

The LambdaExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.GetChildrenEnumerator Method

LambdaExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression Class

Represents a list expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationListExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ListExpression : Expression
Public Class ListExpression
    Inherits Expression

The ListExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ListExpression | Initializes a new instance of the ListExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression Constructor

Initializes a new instance of the ListExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ListExpression()
Public Sub New
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression Properties

The ListExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression.HasItems Property

ListExpressionHasItems Property

Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression.Id Property

ListExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression.Items Property

ListExpressionItems Property

Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Items { get; }
Public ReadOnly Property Items As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The items.
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression Methods

The ListExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression.GetChildrenEnumerator Method

ListExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression Class

Represents a literal expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationLiteralExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LiteralExpression : Expression
Public Class LiteralExpression
    Inherits Expression

The LiteralExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LiteralExpression | Initializes a new instance of the LiteralExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression Constructor

Initializes a new instance of the LiteralExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LiteralExpression()
Public Sub New
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression Properties

The LiteralExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression.Id Property

LiteralExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression.Kind Property

LiteralExpressionKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LiteralExpressionKind Kind { get; set; }
Public Property Kind As LiteralExpressionKind
    Get
    Set

Property Value

Type: LiteralExpressionKind
The kind.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression.StringValue Property

LiteralExpressionStringValue Property

Gets or sets the string value.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string StringValue { get; set; }
Public Property StringValue As String
    Get
    Set

Property Value

Type: String
The string value.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression Methods

The LiteralExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement Class

Represents a non local statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationNonLocalStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NonLocalStatement : Statement
Public Class NonLocalStatement
    Inherits Statement

The NonLocalStatement type exposes the following members.

Constructors
 | Name | Description
Public method | NonLocalStatement | Initializes a new instance of the NonLocalStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNames | Returns whether the Names collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Names | Gets the names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement Constructor

Initializes a new instance of the NonLocalStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NonLocalStatement()
Public Sub New
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement Properties

The NonLocalStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNames | Returns whether the Names collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Names | Gets the names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement.HasNames Property

NonLocalStatementHasNames Property

Returns whether the Names collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasNames { get; }
Public ReadOnly Property HasNames As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement.Id Property

NonLocalStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement.Names Property

NonLocalStatementNames Property

Gets the names.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<SimpleName> Names { get; }
Public ReadOnly Property Names As IList(Of SimpleName)
    Get

Property Value

Type: IList SimpleName
The names.
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement Methods

The NonLocalStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement.GetChildrenEnumerator Method

NonLocalStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter Class

Represents a parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationParameter

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Parameter : AstNodeBase
Public Class Parameter
    Inherits AstNodeBase

The Parameter type exposes the following members.

Constructors
 | Name | Description
Public method | Parameter | Initializes a new instance of the Parameter class
Top
Properties
 | Name | Description
Public property | AnnotationExpression | Gets or sets the annotation expression.
Public property | ChildParameters | Gets the child parameters.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildParameters | Returns whether the ChildParameters collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | InitializerExpression | Gets or sets the initializer expression.
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter Constructor

Initializes a new instance of the Parameter class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Parameter()
Public Sub New
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter Properties

The Parameter type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationExpression | Gets or sets the annotation expression.
Public property | ChildParameters | Gets the child parameters.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildParameters | Returns whether the ChildParameters collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | InitializerExpression | Gets or sets the initializer expression.
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.AnnotationExpression Property

ParameterAnnotationExpression Property

Gets or sets the annotation expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression AnnotationExpression { get; set; }
Public Property AnnotationExpression As Expression
    Get
    Set

Property Value

Type: Expression
The annotation expression.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.ChildParameters Property

ParameterChildParameters Property

Gets the child parameters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Parameter> ChildParameters { get; }
Public ReadOnly Property ChildParameters As IList(Of Parameter)
    Get

Property Value

Type: IList Parameter
The child parameters.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.HasChildParameters Property

ParameterHasChildParameters Property

Returns whether the ChildParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasChildParameters { get; }
Public ReadOnly Property HasChildParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.Id Property

ParameterId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.InitializerExpression Property

ParameterInitializerExpression Property

Gets or sets the initializer expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression InitializerExpression { get; set; }
Public Property InitializerExpression As Expression
    Get
    Set

Property Value

Type: Expression
The initializer expression.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.Kind Property

ParameterKind Property

Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParameterKind Kind { get; set; }
Public Property Kind As ParameterKind
    Get
    Set

Property Value

Type: ParameterKind
The kind.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.Name Property

ParameterName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter Methods

The Parameter type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.GetChildrenEnumerator Method

ParameterGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression Class

Represents a parenthesized expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationParenthesizedExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParenthesizedExpression : Expression
Public Class ParenthesizedExpression
    Inherits Expression

The ParenthesizedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ParenthesizedExpression | Initializes a new instance of the ParenthesizedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression Constructor

Initializes a new instance of the ParenthesizedExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParenthesizedExpression()
Public Sub New
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression Properties

The ParenthesizedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression.ChildExpression Property

ParenthesizedExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression.Id Property

ParenthesizedExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression Methods

The ParenthesizedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression.GetChildrenEnumerator Method

ParenthesizedExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement Class

Represents a pass statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPassStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PassStatement : Statement
Public Class PassStatement
    Inherits Statement

The PassStatement type exposes the following members.

Constructors
 | Name | Description
Public method | PassStatement | Initializes a new instance of the PassStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement Constructor

Initializes a new instance of the PassStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PassStatement()
Public Sub New
See Also

Reference

PassStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement Properties

The PassStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PassStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement.Id Property

PassStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PassStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement Methods

The PassStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PassStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement Class

Represents a print statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPrintStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PrintStatement : Statement
Public Class PrintStatement
    Inherits Statement

The PrintStatement type exposes the following members.

Constructors
 | Name | Description
Public method | PrintStatement | Initializes a new instance of the PrintStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | OutputExpression | Gets or sets the output expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement Constructor

Initializes a new instance of the PrintStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PrintStatement()
Public Sub New
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement Properties

The PrintStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | OutputExpression | Gets or sets the output expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement.Id Property

PrintStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement.OutputExpression Property

PrintStatementOutputExpression Property

Gets or sets the output expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression OutputExpression { get; set; }
Public Property OutputExpression As Expression
    Get
    Set

Property Value

Type: Expression
The output expression.
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement.TargetExpression Property

PrintStatementTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement Methods

The PrintStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement.GetChildrenEnumerator Method

PrintStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Class

Contains the AST node IDs for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPythonAstNodeId

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonAstNodeId : AstNodeIdProviderBase
Public Class PythonAstNodeId
    Inherits AstNodeIdProviderBase

The PythonAstNodeId type exposes the following members.

Constructors
 | Name | Description
Public method | PythonAstNodeId | Initializes a new instance of the PythonAstNodeId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Top
Fields
Name | Description
Argument | Gets the Argument AST node ID.
AssertStatement | Gets the AssertStatement AST node ID.
AssignmentStatement | Gets the AssignmentStatement AST node ID.
AttributeReferenceExpression | Gets the AttributeReferenceExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BoundName | Gets the BoundName AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
ClassDeclaration | Gets the ClassDeclaration AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
ComprehensionClauseBase | Gets the ComprehensionClauseBase AST node ID.
ComprehensionExpression | Gets the ComprehensionExpression AST node ID.
ComprehensionFor | Gets the ComprehensionFor AST node ID.
ComprehensionIf | Gets the ComprehensionIf AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DeclarationBase | Gets the DeclarationBase AST node ID.
Decorator | Gets the Decorator AST node ID.
DeleteStatement | Gets the DeleteStatement AST node ID.
DictionaryExpression | Gets the DictionaryExpression AST node ID.
Ellipsis | Gets the Ellipsis AST node ID.
ExecuteStatement | Gets the ExecuteStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FromImportStatement | Gets the FromImportStatement AST node ID.
FunctionDeclaration | Gets the FunctionDeclaration AST node ID.
GeneratorExpression | Gets the GeneratorExpression AST node ID.
GlobalStatement | Gets the GlobalStatement AST node ID.
IfStatement | Gets the IfStatement AST node ID.
IfStatementCondition | Gets the IfStatementCondition AST node ID.
ImportStatement | Gets the ImportStatement AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
KeyValueExpression | Gets the KeyValueExpression AST node ID.
LambdaExpression | Gets the LambdaExpression AST node ID.
ListExpression | Gets the ListExpression AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
NonLocalStatement | Gets the NonLocalStatement AST node ID.
Parameter | Gets the Parameter AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PassStatement | Gets the PassStatement AST node ID.
PrintStatement | Gets the PrintStatement AST node ID.
RaiseStatement | Gets the RaiseStatement AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
SetExpression | Gets the SetExpression AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SliceExpression | Gets the SliceExpression AST node ID.
SliceItem | Gets the SliceItem AST node ID.
StarExpression | Gets the StarExpression AST node ID.
Statement | Gets the Statement AST node ID.
StringConversionExpression | Gets the StringConversionExpression AST node ID.
SubscriptionExpression | Gets the SubscriptionExpression AST node ID.
TryStatement | Gets the TryStatement AST node ID.
TryStatementExceptClause | Gets the TryStatementExceptClause AST node ID.
TupleExpression | Gets the TupleExpression AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
YieldExpression | Gets the YieldExpression AST node ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Constructor

Initializes a new instance of the PythonAstNodeId class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonAstNodeId()
Public Sub New
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Properties

The PythonAstNodeId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.MaxId Property

PythonAstNodeIdMaxId Property

Gets the maximum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum AST node ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.MinId Property

PythonAstNodeIdMinId Property

Gets the minimum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum AST node ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Methods

The PythonAstNodeId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Top
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ContainsId Method

PythonAstNodeIdContainsId Method

Returns whether the specified ID value is valid for this AST node ID provider.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.GetDescription Method

PythonAstNodeIdGetDescription Method

Returns the actual string representation for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The actual string representation for the specified AST node ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.GetKey Method

PythonAstNodeIdGetKey Method

Returns the string-based key for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The string-based key for the specified AST node ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Fields

The PythonAstNodeId type exposes the following members.

Fields
Name | Description
Argument | Gets the Argument AST node ID.
AssertStatement | Gets the AssertStatement AST node ID.
AssignmentStatement | Gets the AssignmentStatement AST node ID.
AttributeReferenceExpression | Gets the AttributeReferenceExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BoundName | Gets the BoundName AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
ClassDeclaration | Gets the ClassDeclaration AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
ComprehensionClauseBase | Gets the ComprehensionClauseBase AST node ID.
ComprehensionExpression | Gets the ComprehensionExpression AST node ID.
ComprehensionFor | Gets the ComprehensionFor AST node ID.
ComprehensionIf | Gets the ComprehensionIf AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DeclarationBase | Gets the DeclarationBase AST node ID.
Decorator | Gets the Decorator AST node ID.
DeleteStatement | Gets the DeleteStatement AST node ID.
DictionaryExpression | Gets the DictionaryExpression AST node ID.
Ellipsis | Gets the Ellipsis AST node ID.
ExecuteStatement | Gets the ExecuteStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FromImportStatement | Gets the FromImportStatement AST node ID.
FunctionDeclaration | Gets the FunctionDeclaration AST node ID.
GeneratorExpression | Gets the GeneratorExpression AST node ID.
GlobalStatement | Gets the GlobalStatement AST node ID.
IfStatement | Gets the IfStatement AST node ID.
IfStatementCondition | Gets the IfStatementCondition AST node ID.
ImportStatement | Gets the ImportStatement AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
KeyValueExpression | Gets the KeyValueExpression AST node ID.
LambdaExpression | Gets the LambdaExpression AST node ID.
ListExpression | Gets the ListExpression AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
NonLocalStatement | Gets the NonLocalStatement AST node ID.
Parameter | Gets the Parameter AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PassStatement | Gets the PassStatement AST node ID.
PrintStatement | Gets the PrintStatement AST node ID.
RaiseStatement | Gets the RaiseStatement AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
SetExpression | Gets the SetExpression AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SliceExpression | Gets the SliceExpression AST node ID.
SliceItem | Gets the SliceItem AST node ID.
StarExpression | Gets the StarExpression AST node ID.
Statement | Gets the Statement AST node ID.
StringConversionExpression | Gets the StringConversionExpression AST node ID.
SubscriptionExpression | Gets the SubscriptionExpression AST node ID.
TryStatement | Gets the TryStatement AST node ID.
TryStatementExceptClause | Gets the TryStatementExceptClause AST node ID.
TupleExpression | Gets the TupleExpression AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
YieldExpression | Gets the YieldExpression AST node ID.
Top
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Argument Field

PythonAstNodeIdArgument Field

Gets the Argument AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Argument = 14001
Public Const Argument As Integer = 14001

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.AssertStatement Field

PythonAstNodeIdAssertStatement Field

Gets the AssertStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AssertStatement = 14002
Public Const AssertStatement As Integer = 14002

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.AssignmentStatement Field

PythonAstNodeIdAssignmentStatement Field

Gets the AssignmentStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AssignmentStatement = 14003
Public Const AssignmentStatement As Integer = 14003

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.AttributeReferenceExpression Field

PythonAstNodeIdAttributeReferenceExpression Field

Gets the AttributeReferenceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int AttributeReferenceExpression = 14004
Public Const AttributeReferenceExpression As Integer = 14004

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.BinaryOperatorExpression Field

PythonAstNodeIdBinaryOperatorExpression Field

Gets the BinaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BinaryOperatorExpression = 14005
Public Const BinaryOperatorExpression As Integer = 14005

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.BlockStatement Field

PythonAstNodeIdBlockStatement Field

Gets the BlockStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BlockStatement = 14006
Public Const BlockStatement As Integer = 14006

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.BoundName Field

PythonAstNodeIdBoundName Field

Gets the BoundName AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BoundName = 14007
Public Const BoundName As Integer = 14007

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.BreakStatement Field

PythonAstNodeIdBreakStatement Field

Gets the BreakStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int BreakStatement = 14008
Public Const BreakStatement As Integer = 14008

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ClassDeclaration Field

PythonAstNodeIdClassDeclaration Field

Gets the ClassDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ClassDeclaration = 14009
Public Const ClassDeclaration As Integer = 14009

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.CompilationUnit Field

PythonAstNodeIdCompilationUnit Field

Gets the CompilationUnit AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CompilationUnit = 14000
Public Const CompilationUnit As Integer = 14000

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ComprehensionClauseBase Field

PythonAstNodeIdComprehensionClauseBase Field

Gets the ComprehensionClauseBase AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ComprehensionClauseBase = 14010
Public Const ComprehensionClauseBase As Integer = 14010

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ComprehensionExpression Field

PythonAstNodeIdComprehensionExpression Field

Gets the ComprehensionExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ComprehensionExpression = 14011
Public Const ComprehensionExpression As Integer = 14011

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ComprehensionFor Field

PythonAstNodeIdComprehensionFor Field

Gets the ComprehensionFor AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ComprehensionFor = 14012
Public Const ComprehensionFor As Integer = 14012

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ComprehensionIf Field

PythonAstNodeIdComprehensionIf Field

Gets the ComprehensionIf AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ComprehensionIf = 14013
Public Const ComprehensionIf As Integer = 14013

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ConditionalExpression Field

PythonAstNodeIdConditionalExpression Field

Gets the ConditionalExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ConditionalExpression = 14014
Public Const ConditionalExpression As Integer = 14014

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ContinueStatement Field

PythonAstNodeIdContinueStatement Field

Gets the ContinueStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContinueStatement = 14015
Public Const ContinueStatement As Integer = 14015

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.DeclarationBase Field

PythonAstNodeIdDeclarationBase Field

Gets the DeclarationBase AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DeclarationBase = 14017
Public Const DeclarationBase As Integer = 14017

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Decorator Field

PythonAstNodeIdDecorator Field

Gets the Decorator AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Decorator = 14016
Public Const Decorator As Integer = 14016

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.DeleteStatement Field

PythonAstNodeIdDeleteStatement Field

Gets the DeleteStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DeleteStatement = 14018
Public Const DeleteStatement As Integer = 14018

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.DictionaryExpression Field

PythonAstNodeIdDictionaryExpression Field

Gets the DictionaryExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DictionaryExpression = 14019
Public Const DictionaryExpression As Integer = 14019

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Ellipsis Field

PythonAstNodeIdEllipsis Field

Gets the Ellipsis AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Ellipsis = 14020
Public Const Ellipsis As Integer = 14020

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ExecuteStatement Field

PythonAstNodeIdExecuteStatement Field

Gets the ExecuteStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ExecuteStatement = 14021
Public Const ExecuteStatement As Integer = 14021

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Expression Field

PythonAstNodeIdExpression Field

Gets the Expression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Expression = 14022
Public Const Expression As Integer = 14022

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ExpressionStatement Field

PythonAstNodeIdExpressionStatement Field

Gets the ExpressionStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ExpressionStatement = 14023
Public Const ExpressionStatement As Integer = 14023

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ForStatement Field

PythonAstNodeIdForStatement Field

Gets the ForStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ForStatement = 14024
Public Const ForStatement As Integer = 14024

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.FromImportStatement Field

PythonAstNodeIdFromImportStatement Field

Gets the FromImportStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FromImportStatement = 14025
Public Const FromImportStatement As Integer = 14025

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.FunctionDeclaration Field

PythonAstNodeIdFunctionDeclaration Field

Gets the FunctionDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int FunctionDeclaration = 14026
Public Const FunctionDeclaration As Integer = 14026

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.GeneratorExpression Field

PythonAstNodeIdGeneratorExpression Field

Gets the GeneratorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int GeneratorExpression = 14027
Public Const GeneratorExpression As Integer = 14027

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.GlobalStatement Field

PythonAstNodeIdGlobalStatement Field

Gets the GlobalStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int GlobalStatement = 14028
Public Const GlobalStatement As Integer = 14028

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.IfStatement Field

PythonAstNodeIdIfStatement Field

Gets the IfStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int IfStatement = 14029
Public Const IfStatement As Integer = 14029

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.IfStatementCondition Field

PythonAstNodeIdIfStatementCondition Field

Gets the IfStatementCondition AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int IfStatementCondition = 14030
Public Const IfStatementCondition As Integer = 14030

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ImportStatement Field

PythonAstNodeIdImportStatement Field

Gets the ImportStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ImportStatement = 14031
Public Const ImportStatement As Integer = 14031

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.InvocationExpression Field

PythonAstNodeIdInvocationExpression Field

Gets the InvocationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InvocationExpression = 14032
Public Const InvocationExpression As Integer = 14032

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.KeyValueExpression Field

PythonAstNodeIdKeyValueExpression Field

Gets the KeyValueExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeyValueExpression = 14033
Public Const KeyValueExpression As Integer = 14033

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.LambdaExpression Field

PythonAstNodeIdLambdaExpression Field

Gets the LambdaExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LambdaExpression = 14034
Public Const LambdaExpression As Integer = 14034

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ListExpression Field

PythonAstNodeIdListExpression Field

Gets the ListExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ListExpression = 14035
Public Const ListExpression As Integer = 14035

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.LiteralExpression Field

PythonAstNodeIdLiteralExpression Field

Gets the LiteralExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralExpression = 14036
Public Const LiteralExpression As Integer = 14036

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.NonLocalStatement Field

PythonAstNodeIdNonLocalStatement Field

Gets the NonLocalStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int NonLocalStatement = 14037
Public Const NonLocalStatement As Integer = 14037

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Parameter Field

PythonAstNodeIdParameter Field

Gets the Parameter AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Parameter = 14038
Public Const Parameter As Integer = 14038

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ParenthesizedExpression Field

PythonAstNodeIdParenthesizedExpression Field

Gets the ParenthesizedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ParenthesizedExpression = 14039
Public Const ParenthesizedExpression As Integer = 14039

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.PassStatement Field

PythonAstNodeIdPassStatement Field

Gets the PassStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PassStatement = 14040
Public Const PassStatement As Integer = 14040

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.PrintStatement Field

PythonAstNodeIdPrintStatement Field

Gets the PrintStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PrintStatement = 14041
Public Const PrintStatement As Integer = 14041

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.RaiseStatement Field

PythonAstNodeIdRaiseStatement Field

Gets the RaiseStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int RaiseStatement = 14042
Public Const RaiseStatement As Integer = 14042

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ReturnStatement Field

PythonAstNodeIdReturnStatement Field

Gets the ReturnStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReturnStatement = 14043
Public Const ReturnStatement As Integer = 14043

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SetExpression Field

PythonAstNodeIdSetExpression Field

Gets the SetExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SetExpression = 14044
Public Const SetExpression As Integer = 14044

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SimpleName Field

PythonAstNodeIdSimpleName Field

Gets the SimpleName AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SimpleName = 14045
Public Const SimpleName As Integer = 14045

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SliceExpression Field

PythonAstNodeIdSliceExpression Field

Gets the SliceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SliceExpression = 14046
Public Const SliceExpression As Integer = 14046

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SliceItem Field

PythonAstNodeIdSliceItem Field

Gets the SliceItem AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SliceItem = 14047
Public Const SliceItem As Integer = 14047

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.StarExpression Field

PythonAstNodeIdStarExpression Field

Gets the StarExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StarExpression = 14048
Public Const StarExpression As Integer = 14048

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Statement Field

PythonAstNodeIdStatement Field

Gets the Statement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Statement = 14049
Public Const Statement As Integer = 14049

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.StringConversionExpression Field

PythonAstNodeIdStringConversionExpression Field

Gets the StringConversionExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StringConversionExpression = 14050
Public Const StringConversionExpression As Integer = 14050

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SubscriptionExpression Field

PythonAstNodeIdSubscriptionExpression Field

Gets the SubscriptionExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SubscriptionExpression = 14051
Public Const SubscriptionExpression As Integer = 14051

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.TryStatement Field

PythonAstNodeIdTryStatement Field

Gets the TryStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TryStatement = 14052
Public Const TryStatement As Integer = 14052

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.TryStatementExceptClause Field

PythonAstNodeIdTryStatementExceptClause Field

Gets the TryStatementExceptClause AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TryStatementExceptClause = 14053
Public Const TryStatementExceptClause As Integer = 14053

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.TupleExpression Field

PythonAstNodeIdTupleExpression Field

Gets the TupleExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TupleExpression = 14054
Public Const TupleExpression As Integer = 14054

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.UnaryOperatorExpression Field

PythonAstNodeIdUnaryOperatorExpression Field

Gets the UnaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int UnaryOperatorExpression = 14055
Public Const UnaryOperatorExpression As Integer = 14055

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.WhileStatement Field

PythonAstNodeIdWhileStatement Field

Gets the WhileStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int WhileStatement = 14056
Public Const WhileStatement As Integer = 14056

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.WithStatement Field

PythonAstNodeIdWithStatement Field

Gets the WithStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int WithStatement = 14057
Public Const WithStatement As Integer = 14057

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.YieldExpression Field

PythonAstNodeIdYieldExpression Field

Gets the YieldExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int YieldExpression = 14058
Public Const YieldExpression As Integer = 14058

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement Class

Represents a raise statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationRaiseStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RaiseStatement : Statement
Public Class RaiseStatement
    Inherits Statement

The RaiseStatement type exposes the following members.

Constructors
 | Name | Description
Public method | RaiseStatement | Initializes a new instance of the RaiseStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ExceptionTypeExpression | Gets or sets the exception type expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TracebackExpression | Gets or sets the traceback expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | ValueExpression | Gets or sets the value expression.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement Constructor

Initializes a new instance of the RaiseStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RaiseStatement()
Public Sub New
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement Properties

The RaiseStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ExceptionTypeExpression | Gets or sets the exception type expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TracebackExpression | Gets or sets the traceback expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | ValueExpression | Gets or sets the value expression.
Top
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.ExceptionTypeExpression Property

RaiseStatementExceptionTypeExpression Property

Gets or sets the exception type expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ExceptionTypeExpression { get; set; }
Public Property ExceptionTypeExpression As Expression
    Get
    Set

Property Value

Type: Expression
The exception type expression.
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.Id Property

RaiseStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.TracebackExpression Property

RaiseStatementTracebackExpression Property

Gets or sets the traceback expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TracebackExpression { get; set; }
Public Property TracebackExpression As Expression
    Get
    Set

Property Value

Type: Expression
The traceback expression.
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.ValueExpression Property

RaiseStatementValueExpression Property

Gets or sets the value expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ValueExpression { get; set; }
Public Property ValueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The value expression.
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement Methods

The RaiseStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.GetChildrenEnumerator Method

RaiseStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement Class

Represents a return statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationReturnStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReturnStatement : Statement
Public Class ReturnStatement
    Inherits Statement

The ReturnStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnStatement | Initializes a new instance of the ReturnStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement Constructor

Initializes a new instance of the ReturnStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReturnStatement()
Public Sub New
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement Properties

The ReturnStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement.Expression Property

ReturnStatementExpression Property

Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement.Id Property

ReturnStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement Methods

The ReturnStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement.GetChildrenEnumerator Method

ReturnStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression Class

Represents a set expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSetExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SetExpression : Expression
Public Class SetExpression
    Inherits Expression

The SetExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SetExpression | Initializes a new instance of the SetExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression Constructor

Initializes a new instance of the SetExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SetExpression()
Public Sub New
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression Properties

The SetExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression.HasItems Property

SetExpressionHasItems Property

Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression.Id Property

SetExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression.Items Property

SetExpressionItems Property

Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Items { get; }
Public ReadOnly Property Items As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The items.
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression Methods

The SetExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression.GetChildrenEnumerator Method

SetExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName Class

Represents a simple name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSimpleName

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SimpleName : Expression
Public Class SimpleName
    Inherits Expression

The SimpleName type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text.
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName Constructor

Initializes a new instance of the SimpleName class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleName()
Public Sub New
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName Properties

The SimpleName type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text.
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName.Id Property

SimpleNameId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName.Text Property

SimpleNameText Property

Gets or sets the text.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName.Value Property

SimpleNameValue Property

Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName Methods

The SimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName.ToString Method

SimpleNameToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression Class

Represents a slice expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSliceExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SliceExpression : Expression
Public Class SliceExpression
    Inherits Expression

The SliceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SliceExpression | Initializes a new instance of the SliceExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression Constructor

Initializes a new instance of the SliceExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SliceExpression()
Public Sub New
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression Properties

The SliceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.HasItems Property

SliceExpressionHasItems Property

Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.Id Property

SliceExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.Items Property

SliceExpressionItems Property

Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<SliceItem> Items { get; }
Public ReadOnly Property Items As IList(Of SliceItem)
    Get

Property Value

Type: IList SliceItem
The items.
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.TargetExpression Property

SliceExpressionTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression Methods

The SliceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.GetChildrenEnumerator Method

SliceExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem Class

Represents a slice item.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSliceItem

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SliceItem : AstNodeBase
Public Class SliceItem
    Inherits AstNodeBase

The SliceItem type exposes the following members.

Constructors
 | Name | Description
Public method | SliceItem | Initializes a new instance of the SliceItem class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasFirstColon | Gets or sets the has first colon.
Public property | HasSecondColon | Gets or sets the has second colon.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LowerBoundExpression | Gets or sets the lower bound expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StrideExpression | Gets or sets the stride expression.
Public property | UpperBoundExpression | Gets or sets the upper bound expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem Constructor

Initializes a new instance of the SliceItem class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SliceItem()
Public Sub New
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem Properties

The SliceItem type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasFirstColon | Gets or sets the has first colon.
Public property | HasSecondColon | Gets or sets the has second colon.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LowerBoundExpression | Gets or sets the lower bound expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StrideExpression | Gets or sets the stride expression.
Public property | UpperBoundExpression | Gets or sets the upper bound expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.HasFirstColon Property

SliceItemHasFirstColon Property

Gets or sets the has first colon.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasFirstColon { get; set; }
Public Property HasFirstColon As Boolean
    Get
    Set

Property Value

Type: Boolean
The has first colon.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.HasSecondColon Property

SliceItemHasSecondColon Property

Gets or sets the has second colon.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSecondColon { get; set; }
Public Property HasSecondColon As Boolean
    Get
    Set

Property Value

Type: Boolean
The has second colon.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.Id Property

SliceItemId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.LowerBoundExpression Property

SliceItemLowerBoundExpression Property

Gets or sets the lower bound expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression LowerBoundExpression { get; set; }
Public Property LowerBoundExpression As Expression
    Get
    Set

Property Value

Type: Expression
The lower bound expression.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.StrideExpression Property

SliceItemStrideExpression Property

Gets or sets the stride expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression StrideExpression { get; set; }
Public Property StrideExpression As Expression
    Get
    Set

Property Value

Type: Expression
The stride expression.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.UpperBoundExpression Property

SliceItemUpperBoundExpression Property

Gets or sets the upper bound expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression UpperBoundExpression { get; set; }
Public Property UpperBoundExpression As Expression
    Get
    Set

Property Value

Type: Expression
The upper bound expression.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem Methods

The SliceItem type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.GetChildrenEnumerator Method

SliceItemGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression Class

Represents a star expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStarExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StarExpression : Expression
Public Class StarExpression
    Inherits Expression

The StarExpression type exposes the following members.

Constructors
 | Name | Description
Public method | StarExpression | Initializes a new instance of the StarExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression Constructor

Initializes a new instance of the StarExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StarExpression()
Public Sub New
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression Properties

The StarExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression.ChildExpression Property

StarExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression.Id Property

StarExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression Methods

The StarExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression.GetChildrenEnumerator Method

StarExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Statement Class

Represents a statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
More...

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Statement : AstNodeBase
Public Class Statement
    Inherits AstNodeBase

The Statement type exposes the following members.

Constructors
 | Name | Description
Public method | Statement | Initializes a new instance of the Statement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAssertStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAssignmentStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBlockStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBreakStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationContinueStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeclarationBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeleteStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExecuteStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpressionStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationForStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationFromImportStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationGlobalStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationIfStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationImportStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationNonLocalStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPassStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPrintStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationRaiseStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationReturnStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTryStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationWhileStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationWithStatement


Statement Constructor

Initializes a new instance of the Statement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement()
Public Sub New
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Statement Properties

The Statement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Statement.Id Property

StatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Statement Methods

The Statement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression Class

Represents a string conversion expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStringConversionExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StringConversionExpression : Expression
Public Class StringConversionExpression
    Inherits Expression

The StringConversionExpression type exposes the following members.

Constructors
 | Name | Description
Public method | StringConversionExpression | Initializes a new instance of the StringConversionExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression Constructor

Initializes a new instance of the StringConversionExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StringConversionExpression()
Public Sub New
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression Properties

The StringConversionExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression.ChildExpression Property

StringConversionExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression.Id Property

StringConversionExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression Methods

The StringConversionExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression.GetChildrenEnumerator Method

StringConversionExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression Class

Represents a subscription expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSubscriptionExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SubscriptionExpression : Expression
Public Class SubscriptionExpression
    Inherits Expression

The SubscriptionExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SubscriptionExpression | Initializes a new instance of the SubscriptionExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | IndexExpression | Gets or sets the index expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression Constructor

Initializes a new instance of the SubscriptionExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SubscriptionExpression()
Public Sub New
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression Properties

The SubscriptionExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | IndexExpression | Gets or sets the index expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression.Id Property

SubscriptionExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression.IndexExpression Property

SubscriptionExpressionIndexExpression Property

Gets or sets the index expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression IndexExpression { get; set; }
Public Property IndexExpression As Expression
    Get
    Set

Property Value

Type: Expression
The index expression.
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression.TargetExpression Property

SubscriptionExpressionTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression Methods

The SubscriptionExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression.GetChildrenEnumerator Method

SubscriptionExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement Class

Represents a try statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTryStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TryStatement : Statement
Public Class TryStatement
    Inherits Statement

The TryStatement type exposes the following members.

Constructors
 | Name | Description
Public method | TryStatement | Initializes a new instance of the TryStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ExceptClauses | Gets the except clauses.
Public property | ExecutedStatement | Gets or sets the executed statement.
Public property | FinallyStatement | Gets or sets the finally statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasExceptClauses | Returns whether the ExceptClauses collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement Constructor

Initializes a new instance of the TryStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TryStatement()
Public Sub New
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement Properties

The TryStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ExceptClauses | Gets the except clauses.
Public property | ExecutedStatement | Gets or sets the executed statement.
Public property | FinallyStatement | Gets or sets the finally statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasExceptClauses | Returns whether the ExceptClauses collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.ElseStatement Property

TryStatementElseStatement Property

Gets or sets the else statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ElseStatement { get; set; }
Public Property ElseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The else statement.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.ExceptClauses Property

TryStatementExceptClauses Property

Gets the except clauses.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<TryStatementExceptClause> ExceptClauses { get; }
Public ReadOnly Property ExceptClauses As IList(Of TryStatementExceptClause)
    Get

Property Value

Type: IList TryStatementExceptClause
The except clauses.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.ExecutedStatement Property

TryStatementExecutedStatement Property

Gets or sets the executed statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ExecutedStatement { get; set; }
Public Property ExecutedStatement As Statement
    Get
    Set

Property Value

Type: Statement
The executed statement.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.FinallyStatement Property

TryStatementFinallyStatement Property

Gets or sets the finally statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement FinallyStatement { get; set; }
Public Property FinallyStatement As Statement
    Get
    Set

Property Value

Type: Statement
The finally statement.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.HasExceptClauses Property

TryStatementHasExceptClauses Property

Returns whether the ExceptClauses collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasExceptClauses { get; }
Public ReadOnly Property HasExceptClauses As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.Id Property

TryStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement Methods

The TryStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.GetChildrenEnumerator Method

TryStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause Class

Represents a try statement except clause.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTryStatementExceptClause

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TryStatementExceptClause : AstNodeBase
Public Class TryStatementExceptClause
    Inherits AstNodeBase

The TryStatementExceptClause type exposes the following members.

Constructors
 | Name | Description
Public method | TryStatementExceptClause | Initializes a new instance of the TryStatementExceptClause class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause Constructor

Initializes a new instance of the TryStatementExceptClause class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TryStatementExceptClause()
Public Sub New
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause Properties

The TryStatementExceptClause type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.ConditionExpression Property

TryStatementExceptClauseConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.Id Property

TryStatementExceptClauseId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.Statement Property

TryStatementExceptClauseStatement Property

Gets or sets the statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement Statement { get; set; }
Public Property Statement As Statement
    Get
    Set

Property Value

Type: Statement
The statement.
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.TargetExpression Property

TryStatementExceptClauseTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause Methods

The TryStatementExceptClause type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.GetChildrenEnumerator Method

TryStatementExceptClauseGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression Class

Represents a tuple expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTupleExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TupleExpression : Expression
Public Class TupleExpression
    Inherits Expression

The TupleExpression type exposes the following members.

Constructors
 | Name | Description
Public method | TupleExpression | Initializes a new instance of the TupleExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression Constructor

Initializes a new instance of the TupleExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TupleExpression()
Public Sub New
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression Properties

The TupleExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression.HasItems Property

TupleExpressionHasItems Property

Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression.Id Property

TupleExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression.Items Property

TupleExpressionItems Property

Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Expression> Items { get; }
Public ReadOnly Property Items As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The items.
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression Methods

The TupleExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression.GetChildrenEnumerator Method

TupleExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression Class

Represents an unary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationUnaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UnaryOperatorExpression : Expression
Public Class UnaryOperatorExpression
    Inherits Expression

The UnaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | UnaryOperatorExpression | Initializes a new instance of the UnaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression Constructor

Initializes a new instance of the UnaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UnaryOperatorExpression()
Public Sub New
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression Properties

The UnaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression.ChildExpression Property

UnaryOperatorExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression.Id Property

UnaryOperatorExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression.Operator Property

UnaryOperatorExpressionOperator Property

Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression Methods

The UnaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression.GetChildrenEnumerator Method

UnaryOperatorExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement Class

Represents a while statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationWhileStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WhileStatement : Statement
Public Class WhileStatement
    Inherits Statement

The WhileStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WhileStatement | Initializes a new instance of the WhileStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LoopStatement | Gets or sets the loop statement.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement Constructor

Initializes a new instance of the WhileStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WhileStatement()
Public Sub New
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement Properties

The WhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LoopStatement | Gets or sets the loop statement.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.ConditionExpression Property

WhileStatementConditionExpression Property

Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.ElseStatement Property

WhileStatementElseStatement Property

Gets or sets the else statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ElseStatement { get; set; }
Public Property ElseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The else statement.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.Id Property

WhileStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.LoopStatement Property

WhileStatementLoopStatement Property

Gets or sets the loop statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement LoopStatement { get; set; }
Public Property LoopStatement As Statement
    Get
    Set

Property Value

Type: Statement
The loop statement.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement Methods

The WhileStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.GetChildrenEnumerator Method

WhileStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement Class

Represents a with statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationWithStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WithStatement : Statement
Public Class WithStatement
    Inherits Statement

The WithStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WithStatement | Initializes a new instance of the WithStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ContextExpression | Gets or sets the context expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement Constructor

Initializes a new instance of the WithStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WithStatement()
Public Sub New
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement Properties

The WithStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ContextExpression | Gets or sets the context expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.ChildStatement Property

WithStatementChildStatement Property

Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.ContextExpression Property

WithStatementContextExpression Property

Gets or sets the context expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ContextExpression { get; set; }
Public Property ContextExpression As Expression
    Get
    Set

Property Value

Type: Expression
The context expression.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.Id Property

WithStatementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.TargetExpression Property

WithStatementTargetExpression Property

Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement Methods

The WithStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.GetChildrenEnumerator Method

WithStatementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression Class

Represents a yield expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationYieldExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class YieldExpression : Expression
Public Class YieldExpression
    Inherits Expression

The YieldExpression type exposes the following members.

Constructors
 | Name | Description
Public method | YieldExpression | Initializes a new instance of the YieldExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | UseSubiterator | Gets or sets the use subiterator.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression Constructor

Initializes a new instance of the YieldExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public YieldExpression()
Public Sub New
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression Properties

The YieldExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | UseSubiterator | Gets or sets the use subiterator.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression.ChildExpression Property

YieldExpressionChildExpression Property

Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression.Id Property

YieldExpressionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression.UseSubiterator Property

YieldExpressionUseSubiterator Property

Gets or sets the use subiterator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseSubiterator { get; set; }
Public Property UseSubiterator As Boolean
    Get
    Set

Property Value

Type: Boolean
The use subiterator.
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression Methods

The YieldExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression.GetChildrenEnumerator Method

YieldExpressionGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ActiproSoftware.Text.Languages.Python.Implementation Namespace

Contains the core classes related to implementing a Python syntax language.
Classes
 | Class | Description
Public class | PythonClassificationTypeProvider | Represents a provider of IClassificationType objects for the Python language.
Public class | PythonCodeBlockFinder | Provides a Python language code block finder service.
Public class | PythonCompletionProvider | Provides IntelliPrompt completion data for the Python language.
Public class | PythonContextFactory | Creates Python language IPythonContext objects for a TextSnapshotOffset.
Public class | PythonExampleTextProvider | Represents a example text provider for the Python language.
Public class | PythonGrammar | Represents a Grammar for the Python language.
Public class | PythonGrammarOptions | Contains options for a Python grammar.
Public class | PythonIndentProvider | Provides a Python language indent provider service.
Public class | PythonLexer | Represents a Python lexer (lexical analyzer) implementation.
Public class | PythonLexicalStateId | Contains the lexical state IDs for the Python language.
Public class | PythonNavigableSymbolProvider | Represents a navigable symbol provider for the Python language.
Public class | PythonOutliner | Provides a Python language outliner service.
Public class | PythonOutliningSource | Represents a Python language range-based outlining source.
Public class | PythonParameterInfoProvider | Provides IntelliPrompt parameter info data for the Python language.
Public class | PythonParseData | Stores the results of a Python language parsing operation.
Public class | PythonParser | Represents a parser for the Python language.
Public class | PythonQuickInfoProvider | Provides IntelliPrompt quick info data for the Python language.
Public class | PythonSyntaxLanguage | Represents a Python syntax language definition.
Public class | PythonTokenId | Contains the token IDs for the Python language.
Public class | PythonTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the Python language.
Public class | PythonTokenTagger | Represents an ITaggerT for the Python language.
Public class | PythonTokenTaggerProvider | Represents a provider of PythonTokenTagger objects for documents that use the PythonTokenTagger language.
Public class | PythonTokenTaggerProviderTaggerFactory | Implements a factory that can creates PythonTokenTagger objects for a document.


PythonClassificationTypeProvider Class

Represents a provider of IClassificationType objects for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonClassificationTypeProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonClassificationTypeProvider : IPythonClassificationTypeProvider
Public Class PythonClassificationTypeProvider
    Implements IPythonClassificationTypeProvider

The PythonClassificationTypeProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonClassificationTypeProvider | Initializes a new instance of the PythonClassificationTypeProvider class.
Public method | PythonClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the PythonClassificationTypeProvider class.
Top
Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PythonSystemIdentifier | Gets the PythonSystemIdentifier classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Top
Methods
 | Name | Description
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Constructor

Overload List
 | Name | Description
Public method | PythonClassificationTypeProvider | Initializes a new instance of the PythonClassificationTypeProvider class.
Public method | PythonClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the PythonClassificationTypeProvider class.
Top
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Constructor

Initializes a new instance of the PythonClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonClassificationTypeProvider()
Public Sub New
See Also

Reference

PythonClassificationTypeProvider Class
PythonClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Constructor (IHighlightingStyleRegistry)

Initializes a new instance of the PythonClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonClassificationTypeProvider(
    IHighlightingStyleRegistry targetRegistry
)
Public Sub New (
    targetRegistry As IHighlightingStyleRegistry
)

Parameters

targetRegistry
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

PythonClassificationTypeProvider Class
PythonClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Properties

The PythonClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PythonSystemIdentifier | Gets the PythonSystemIdentifier classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Top
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Comment Property

PythonClassificationTypeProviderComment Property

Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Comment { get; }
Public ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.

Implements

IPythonClassificationTypeProviderComment
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Identifier Property

PythonClassificationTypeProviderIdentifier Property

Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Identifier { get; }
Public ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.

Implements

IPythonClassificationTypeProviderIdentifier
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Keyword Property

PythonClassificationTypeProviderKeyword Property

Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Keyword { get; }
Public ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.

Implements

IPythonClassificationTypeProviderKeyword
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Number Property

PythonClassificationTypeProviderNumber Property

Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Number { get; }
Public ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.

Implements

IPythonClassificationTypeProviderNumber
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Operator Property

PythonClassificationTypeProviderOperator Property

Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType Operator { get; }
Public ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.

Implements

IPythonClassificationTypeProviderOperator
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.PythonSystemIdentifier Property

PythonClassificationTypeProviderPythonSystemIdentifier Property

Gets the PythonSystemIdentifier classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType PythonSystemIdentifier { get; }
Public ReadOnly Property PythonSystemIdentifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The PythonSystemIdentifier classification type.

Implements

IPythonClassificationTypeProviderPythonSystemIdentifier
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Registry Property

PythonClassificationTypeProviderRegistry Property

Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry Registry { get; }
Public ReadOnly Property Registry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.String Property

PythonClassificationTypeProviderString Property

Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType String { get; }
Public ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.

Implements

IPythonClassificationTypeProviderString
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Methods

The PythonClassificationTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Top
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.RegisterAll Method

PythonClassificationTypeProviderRegisterAll Method

Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<IClassificationType> RegisterAll()
Public Function RegisterAll As IEnumerable(Of IClassificationType)

Return Value

Type: IEnumerable IClassificationType
The collection of IClassificationType objects that were registered.
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCodeBlockFinder Class

Provides a Python language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.Python.ImplementationPythonCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonCodeBlockFinder : LLParseDataCodeBlockFinder
Public Class PythonCodeBlockFinder
    Inherits LLParseDataCodeBlockFinder

The PythonCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | PythonCodeBlockFinder | Initializes a new instance of the PythonCodeBlockFinder class.
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCodeBlockFinder Constructor

Initializes a new instance of the PythonCodeBlockFinder class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonCodeBlockFinder()
Public Sub New
See Also

Reference

PythonCodeBlockFinder Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCodeBlockFinder Properties

The PythonCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

PythonCodeBlockFinder Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCodeBlockFinder Methods

The PythonCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

PythonCodeBlockFinder Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider Class

Provides IntelliPrompt completion data for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonCompletionProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonCompletionProvider : CompletionProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class PythonCompletionProvider
    Inherits CompletionProviderBase
    Implements IEditorDocumentTextChangeEventSink

The PythonCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonCompletionProvider | Initializes a new instance of the PythonCompletionProvider class.
Top
Properties
 | Name | Description
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within description tips.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IPythonContext for the caret's offset in the specified IEditorView.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider Constructor

Initializes a new instance of the PythonCompletionProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonCompletionProvider()
Public Sub New
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider Properties

The PythonCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within description tips.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.DocstringDisplayMode Property

PythonCompletionProviderDocstringDisplayMode Property

Gets or sets the docstring display mode within description tips.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonDocstringDisplayMode DocstringDisplayMode { get; set; }
Public Property DocstringDisplayMode As PythonDocstringDisplayMode
    Get
    Set

Property Value

Type: PythonDocstringDisplayMode
A PythonDocstringDisplayMode that indicates the docstring display mode within description tips.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider Methods

The PythonCompletionProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IPythonContext for the caret's offset in the specified IEditorView.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Top
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.CreateContext Method

PythonCompletionProviderCreateContext Method

Creates an IPythonContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IPythonContext CreateContext(
    IEditorView view
)
Protected Overridable Function CreateContext (
    view As IEditorView
) As IPythonContext

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IPythonContext
An IPythonContext for the caret's offset in the specified IEditorView.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.OnDocumentTextChanged Method

PythonCompletionProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.OnDocumentTextChanging Method

PythonCompletionProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.OnSessionOpening Method

PythonCompletionProviderOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    ICompletionSession session
)
Protected Overridable Function OnSessionOpening (
    session As ICompletionSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
Remarks
The default implementation of this method sorts the items in the session.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.RequestSession Method

PythonCompletionProviderRequestSession Method

Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Public Overrides Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

ICompletionProviderRequestSession(IEditorView, Boolean)
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory Class

Creates Python language IPythonContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonContextFactory

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonContextFactory
Public Class PythonContextFactory

The PythonContextFactory type exposes the following members.

Constructors
 | Name | Description
Public method | PythonContextFactory | Initializes a new instance of the PythonContextFactory class
Top
Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IPythonContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, PythonContextKind) | Creates an IPythonContext for the specified TextSnapshotOffset.
 | FindIntersectingChildNode | Searches through the child nodes for a node that intersects the specified offset.
 | FindIntersectingDescendantNode | Recursively searches through the descendant nodes for a node that intersects with the specified offset.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory Constructor

Initializes a new instance of the PythonContextFactory class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonContextFactory()
Public Sub New
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory Methods

The PythonContextFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IPythonContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, PythonContextKind) | Creates an IPythonContext for the specified TextSnapshotOffset.
 | FindIntersectingChildNode | Searches through the child nodes for a node that intersects the specified offset.
 | FindIntersectingDescendantNode | Recursively searches through the descendant nodes for a node that intersects with the specified offset.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.CreateContext Method

PythonContextFactoryCreateContext Method

Overload List
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IPythonContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, PythonContextKind) | Creates an IPythonContext for the specified TextSnapshotOffset.
Top
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.CreateContext Method (TextSnapshotOffset)

PythonContextFactoryCreateContext Method (TextSnapshotOffset)

Creates an IPythonContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IPythonContext CreateContext(
    TextSnapshotOffset snapshotOffset
)
Public Function CreateContext (
    snapshotOffset As TextSnapshotOffset
) As IPythonContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.

Return Value

Type: IPythonContext
The IPythonContext that was created.
See Also

Reference

PythonContextFactory Class
CreateContext Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.CreateContext Method (TextSnapshotOffset, PythonContextKind)

PythonContextFactoryCreateContext Method (TextSnapshotOffset, PythonContextKind)

Creates an IPythonContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IPythonContext CreateContext(
    TextSnapshotOffset snapshotOffset,
    PythonContextKind kind
)
Public Function CreateContext (
    snapshotOffset As TextSnapshotOffset,
    kind As PythonContextKind
) As IPythonContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.
kind
Type: ActiproSoftware.Text.Languages.PythonPythonContextKind
A PythonContextKind indicating the kind of context.

Return Value

Type: IPythonContext
The IPythonContext that was created.
See Also

Reference

PythonContextFactory Class
CreateContext Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.FindIntersectingChildNode Method

PythonContextFactoryFindIntersectingChildNode Method

Searches through the child nodes for a node that intersects the specified offset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IAstNode FindIntersectingChildNode(
    IAstNode node,
    int offset
)
Public Shared Function FindIntersectingChildNode (
    node As IAstNode,
    offset As Integer
) As IAstNode

Parameters

node
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to exmaine.
offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The child IAstNode that intersects with the specified offset, if any.
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.FindIntersectingDescendantNode Method

PythonContextFactoryFindIntersectingDescendantNode Method

Recursively searches through the descendant nodes for a node that intersects with the specified offset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IAstNode FindIntersectingDescendantNode(
    IAstNode node,
    int offset
)
Public Shared Function FindIntersectingDescendantNode (
    node As IAstNode,
    offset As Integer
) As IAstNode

Parameters

node
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The descendant IAstNode that intersects with the specified offset, if any.
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.TranslateToParseDataSnapshot Method

PythonContextFactoryTranslateToParseDataSnapshot Method

Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotOffset TranslateToParseDataSnapshot(
    IPythonParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Overridable Function TranslateToParseDataSnapshot (
    parseData As IPythonParseData,
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotOffset

Parameters

parseData
Type: ActiproSoftware.Text.Languages.PythonIPythonParseData
The IPythonParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to translate.

Return Value

Type: TextSnapshotOffset
The translated offset.
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonExampleTextProvider Class

Represents a example text provider for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonExampleTextProvider : IExampleTextProvider
Public Class PythonExampleTextProvider
    Implements IExampleTextProvider

The PythonExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonExampleTextProvider | Initializes a new instance of the PythonExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonExampleTextProvider Constructor

Initializes a new instance of the PythonExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonExampleTextProvider()
Public Sub New
See Also

Reference

PythonExampleTextProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonExampleTextProvider Properties

The PythonExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

PythonExampleTextProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonExampleTextProvider.ExampleText Property

PythonExampleTextProviderExampleText Property

Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

PythonExampleTextProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Class

Represents a Grammar for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.Python.ImplementationPythonGrammar

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonGrammar : Grammar
Public Class PythonGrammar
    Inherits Grammar

The PythonGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | PythonGrammar | Initializes a new instance of the PythonGrammar class using default options.
Public method | PythonGrammar(IPythonGrammarOptions) | Initializes a new instance of the PythonGrammar class using default options.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Constructor

Overload List
 | Name | Description
Public method | PythonGrammar | Initializes a new instance of the PythonGrammar class using default options.
Public method | PythonGrammar(IPythonGrammarOptions) | Initializes a new instance of the PythonGrammar class using default options.
Top
See Also

Reference

PythonGrammar Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Constructor

Initializes a new instance of the PythonGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonGrammar()
Public Sub New
See Also

Reference

PythonGrammar Class
PythonGrammar Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Constructor (IPythonGrammarOptions)

Initializes a new instance of the PythonGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonGrammar(
    IPythonGrammarOptions options
)
Public Sub New (
    options As IPythonGrammarOptions
)

Parameters

options
Type: ActiproSoftware.Text.Languages.PythonIPythonGrammarOptions
An IPythonGrammarOptions that contains options for the grammar.
See Also

Reference

PythonGrammar Class
PythonGrammar Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Properties

The PythonGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

PythonGrammar Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Methods

The PythonGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

PythonGrammar Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions Class

Contains options for a Python grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonGrammarOptions

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonGrammarOptions : IPythonGrammarOptions
Public Class PythonGrammarOptions
    Implements IPythonGrammarOptions

The PythonGrammarOptions type exposes the following members.

Constructors
 | Name | Description
Public method | PythonGrammarOptions | Initializes a new instance of the PythonGrammarOptions class.
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Public property | Version | Gets or sets the PythonVersion that indicates the Python version supported by this grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions Constructor

Initializes a new instance of the PythonGrammarOptions class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonGrammarOptions()
Public Sub New
See Also

Reference

PythonGrammarOptions Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions Properties

The PythonGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Public property | Version | Gets or sets the PythonVersion that indicates the Python version supported by this grammar.
Top
See Also

Reference

PythonGrammarOptions Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions.RootNonTerminal Property

PythonGrammarOptionsRootNonTerminal Property

Gets or sets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonGrammarRootNonTerminal RootNonTerminal { get; set; }
Public Property RootNonTerminal As PythonGrammarRootNonTerminal
    Get
    Set

Property Value

Type: PythonGrammarRootNonTerminal
A PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.

Implements

IPythonGrammarOptionsRootNonTerminal
See Also

Reference

PythonGrammarOptions Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions.Version Property

PythonGrammarOptionsVersion Property

Gets or sets the PythonVersion that indicates the Python version supported by this grammar.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; set; }
Public Property Version As PythonVersion
    Get
    Set

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this grammar.

Implements

IPythonGrammarOptionsVersion
See Also

Reference

PythonGrammarOptions Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider Class

Provides a Python language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationDelimiterIndentProvider
ActiproSoftware.Text.Languages.Python.ImplementationPythonIndentProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonIndentProvider : DelimiterIndentProvider
Public Class PythonIndentProvider
    Inherits DelimiterIndentProvider

The PythonIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonIndentProvider | Initializes a new instance of the PythonIndentProvider class.
Top
Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider Constructor

Initializes a new instance of the PythonIndentProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonIndentProvider()
Public Sub New
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider Properties

The PythonIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider.Mode Property

PythonIndentProviderMode Property

Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IndentMode Mode { get; }
Public Overrides ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider Methods

The PythonIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider.GetIndentAmount Method

PythonIndentProviderGetIndentAmount Method

Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Overrides Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Class

Represents a Python lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonLexer

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonLexer : MergableLexerBase
Public Class PythonLexer
    Inherits MergableLexerBase

The PythonLexer type exposes the following members.

Constructors
 | Name | Description
Public method | PythonLexer | Initializes a new instance of the PythonLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language service.
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
 | IsIdentifierPartCharacter | Returns whether the specified character is an identifier part character.
 | IsIdentifierStartCharacter | Returns whether the specified character is an identifier start character.
 | IsValidIdentifier | Returns whether the specified text is a valid identifier.
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Constructor

Initializes a new instance of the PythonLexer class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonLexer(
    PythonVersion version
)
Public Sub New (
    version As PythonVersion
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version supported by this language service.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Properties

The PythonLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language service.
Top
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.LexicalStates Property

PythonLexerLexicalStates Property

Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.Version Property

PythonLexerVersion Property

Gets the PythonVersion that indicates the Python version supported by this language service.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; }
Public ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this language service.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Methods

The PythonLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
 | IsIdentifierPartCharacter | Returns whether the specified character is an identifier part character.
 | IsIdentifierStartCharacter | Returns whether the specified character is an identifier start character.
 | IsValidIdentifier | Returns whether the specified text is a valid identifier.
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.GetAllLexicalStateTransitions Method

PythonLexerGetAllLexicalStateTransitions Method

Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.GetNextToken Method

PythonLexerGetNextToken Method

Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.IsIdentifierPartCharacter Method

PythonLexerIsIdentifierPartCharacter Method

Returns whether the specified character is an identifier part character.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsIdentifierPartCharacter(
    char ch
)
Public Shared Function IsIdentifierPartCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is an identifier part character; otherwise, false.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.IsIdentifierStartCharacter Method

PythonLexerIsIdentifierStartCharacter Method

Returns whether the specified character is an identifier start character.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsIdentifierStartCharacter(
    char ch
)
Public Shared Function IsIdentifierStartCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is an identifier start character; otherwise, false.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.IsValidIdentifier Method

PythonLexerIsValidIdentifier Method

Returns whether the specified text is a valid identifier.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsValidIdentifier(
    string text
)
Public Shared Function IsValidIdentifier (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The text to examine.

Return Value

Type: Boolean
true if the specified text is a valid identifier; otherwise, false.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Events

The PythonLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Class

Contains the lexical state IDs for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonLexicalStateId

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonLexicalStateId : LexicalStateIdProviderBase
Public Class PythonLexicalStateId
    Inherits LexicalStateIdProviderBase

The PythonLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | PythonLexicalStateId | Initializes a new instance of the PythonLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
Fields
Name | Description
Default | Gets the Default lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Constructor

Initializes a new instance of the PythonLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonLexicalStateId()
Public Sub New
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Properties

The PythonLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.MaxId Property

PythonLexicalStateIdMaxId Property

Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.MinId Property

PythonLexicalStateIdMinId Property

Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Methods

The PythonLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.ContainsId Method

PythonLexicalStateIdContainsId Method

Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.GetDescription Method

PythonLexicalStateIdGetDescription Method

Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.GetKey Method

PythonLexicalStateIdGetKey Method

Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Fields

The PythonLexicalStateId type exposes the following members.

Fields
Name | Description
Default | Gets the Default lexical state ID.
Top
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.Default Field

PythonLexicalStateIdDefault Field

Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Default = 14000
Public Const Default As Integer = 14000

Field Value

Type: Int32
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonNavigableSymbolProvider Class

Represents a navigable symbol provider for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonNavigableSymbolProvider : INavigableSymbolProvider
Public Class PythonNavigableSymbolProvider
    Implements INavigableSymbolProvider

The PythonNavigableSymbolProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonNavigableSymbolProvider | Initializes a new instance of the PythonNavigableSymbolProvider class
Top
Methods
 | Name | Description
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonNavigableSymbolProvider Constructor

Initializes a new instance of the PythonNavigableSymbolProvider class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonNavigableSymbolProvider()
Public Sub New
See Also

Reference

PythonNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonNavigableSymbolProvider Methods

The PythonNavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Top
See Also

Reference

PythonNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonNavigableSymbolProvider.GetSymbols Method

PythonNavigableSymbolProviderGetSymbols Method

Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual INavigableSymbolSet GetSymbols(
    INavigableRequestContext context,
    TextSnapshotOffset snapshotOffset,
    INavigableSymbol parentSymbol
)
Public Overridable Function GetSymbols (
    context As INavigableRequestContext,
    snapshotOffset As TextSnapshotOffset,
    parentSymbol As INavigableSymbol
) As INavigableSymbolSet

Parameters

context
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptINavigableRequestContext
An INavigableRequestContext that provides the context of the request.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset that contains the ITextSnapshot to examine, along with a contextual offset.
parentSymbol
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptINavigableSymbol
The optional parent INavigableSymbol to examine, or a null value if the root symbols are requested.

Return Value

Type: INavigableSymbolSet
An INavigableSymbolSet containing the INavigableSymbol objects that were located.

Implements

INavigableSymbolProviderGetSymbols(INavigableRequestContext, TextSnapshotOffset, INavigableSymbol)
See Also

Reference

PythonNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner Class

Provides a Python language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonOutliner

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonOutliner : IOutliner
Public Class PythonOutliner
    Implements IOutliner

The PythonOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | PythonOutliner | Initializes a new instance of the PythonOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner Constructor

Initializes a new instance of the PythonOutliner class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonOutliner()
Public Sub New
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner Properties

The PythonOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner.UpdateTrigger Property

PythonOutlinerUpdateTrigger Property

Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner Methods

The PythonOutliner type exposes the following members.

Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner.GetOutliningSource Method

PythonOutlinerGetOutliningSource Method

Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource Class

Represents a Python language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonOutliningSource

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonOutliningSource : RangeOutliningSourceBase
Public Class PythonOutliningSource
    Inherits RangeOutliningSourceBase

The PythonOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | PythonOutliningSource | Initializes a new instance of the PythonOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IPythonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IPythonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource Constructor

Initializes a new instance of the PythonOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

PythonOutliningSource Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource Methods

The PythonOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IPythonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IPythonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

PythonOutliningSource Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource.AddNodesFromParseData Method

PythonOutliningSourceAddNodesFromParseData Method

Overload List
 | Name | Description
Public method | AddNodesFromParseData(IPythonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IPythonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

PythonOutliningSource Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource.AddNodesFromParseData Method (IPythonParseData)

PythonOutliningSourceAddNodesFromParseData Method (IPythonParseData)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IPythonParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IPythonParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.PythonIPythonParseData
The IPythonParseData containing AST data.
See Also

Reference

PythonOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource.AddNodesFromParseData Method (IPythonParseData, ITextBufferReader)

PythonOutliningSourceAddNodesFromParseData Method (IPythonParseData, ITextBufferReader)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IPythonParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IPythonParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.PythonIPythonParseData
The IPythonParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

PythonOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource.AddNodesRecursive Method

PythonOutliningSourceAddNodesRecursive Method

Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

PythonOutliningSource Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider Class

Provides IntelliPrompt parameter info data for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationParameterInfoProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonParameterInfoProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonParameterInfoProvider : ParameterInfoProviderBase,
    IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink
Public Class PythonParameterInfoProvider
    Inherits ParameterInfoProviderBase
    Implements IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink

The PythonParameterInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParameterInfoProvider | Initializes a new instance of the PythonParameterInfoProvider class.
Top
Properties
 | Name | Description
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within parameter info.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IPythonContext for the caret's offset in the specified IEditorView.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IPythonContext.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider Constructor

Initializes a new instance of the PythonParameterInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonParameterInfoProvider()
Public Sub New
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider Properties

The PythonParameterInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within parameter info.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.DocstringDisplayMode Property

PythonParameterInfoProviderDocstringDisplayMode Property

Gets or sets the docstring display mode within parameter info.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonDocstringDisplayMode DocstringDisplayMode { get; set; }
Public Property DocstringDisplayMode As PythonDocstringDisplayMode
    Get
    Set

Property Value

Type: PythonDocstringDisplayMode
A PythonDocstringDisplayMode that indicates the docstring display mode within parameter info.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider Methods

The PythonParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IPythonContext for the caret's offset in the specified IEditorView.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IPythonContext.
Top
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.CreateContext Method

PythonParameterInfoProviderCreateContext Method

Creates an IPythonContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IPythonContext CreateContext(
    IEditorView view
)
Protected Overridable Function CreateContext (
    view As IEditorView
) As IPythonContext

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IPythonContext
An IPythonContext for the caret's offset in the specified IEditorView.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.OnDocumentTextChanged Method

PythonParameterInfoProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.OnDocumentTextChanging Method

PythonParameterInfoProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.OnSessionOpening Method

PythonParameterInfoProviderOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IParameterInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IParameterInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIParameterInfoSession
The IParameterInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.OnViewSelectionChanged Method

PythonParameterInfoProviderOnViewSelectionChanged Method

Occurs when the selection is changed in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnViewSelectionChanged(
    IEditorView view,
    EditorViewSelectionEventArgs e
)
Protected Overridable Sub OnViewSelectionChanged (
    view As IEditorView,
    e As EditorViewSelectionEventArgs
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorViewSelectionEventArgs
The EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.RequestSession Method

PythonParameterInfoProviderRequestSession Method

Requests that an IParameterInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view
)
Public Overrides Function RequestSession (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

IParameterInfoProviderRequestSession(IEditorView)
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.UpdateCurrentParameter Method

PythonParameterInfoProviderUpdateCurrentParameter Method

Updates the current parameter in the session's signatures, based on information in the specified IPythonContext.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool UpdateCurrentParameter(
    IParameterInfoSession session,
    IPythonContext context
)
Protected Overridable Function UpdateCurrentParameter (
    session As IParameterInfoSession,
    context As IPythonContext
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIParameterInfoSession
The IParameterInfoSession to update.
context
Type: ActiproSoftware.Text.Languages.PythonIPythonContext
The IPythonContext to examine.

Return Value

Type: Boolean
true if an update was made; otherwise, false.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParseData Class

Stores the results of a Python language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.Python.ImplementationPythonParseData

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonParseData : LLParseData,
    ILLParseData, IParseData, IParseErrorProvider, IPythonParseData
Public Class PythonParseData
    Inherits LLParseData
    Implements ILLParseData, IParseData, IParseErrorProvider, IPythonParseData

The PythonParseData type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParseData | Initializes a new instance of the PythonParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParseData Constructor

Initializes a new instance of the PythonParseData class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonParseData()
Public Sub New
See Also

Reference

PythonParseData Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParseData Properties

The PythonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

PythonParseData Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Class

Represents a parser for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonParser

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonParser : LLParserBase
Public Class PythonParser
    Inherits LLParserBase

The PythonParser type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParser | Initializes a new instance of the PythonParser class.
Public method | PythonParser(PythonVersion) | Initializes a new instance of the PythonParser class.
Public method | PythonParser(PythonVersion, Grammar) | Initializes a new instance of the PythonParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language service.
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Constructor

Overload List
 | Name | Description
Public method | PythonParser | Initializes a new instance of the PythonParser class.
Public method | PythonParser(PythonVersion) | Initializes a new instance of the PythonParser class.
Public method | PythonParser(PythonVersion, Grammar) | Initializes a new instance of the PythonParser class.
Top
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Constructor

Initializes a new instance of the PythonParser class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonParser()
Public Sub New
See Also

Reference

PythonParser Class
PythonParser Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Constructor (PythonVersion)

Initializes a new instance of the PythonParser class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonParser(
    PythonVersion version
)
Public Sub New (
    version As PythonVersion
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version supported by this language service.
See Also

Reference

PythonParser Class
PythonParser Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Constructor (PythonVersion, Grammar)

Initializes a new instance of the PythonParser class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonParser(
    PythonVersion version,
    Grammar grammar
)
Public Sub New (
    version As PythonVersion,
    grammar As Grammar
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version supported by this language service.
grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

PythonParser Class
PythonParser Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Properties

The PythonParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language service.
Top
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.Version Property

PythonParserVersion Property

Gets the PythonVersion that indicates the Python version supported by this language service.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; }
Public ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this language service.
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Methods

The PythonParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Top
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.CreateParseData Method

PythonParserCreateParseData Method

Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.CreateTokenReader Method

PythonParserCreateTokenReader Method

Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.InitializeParserState Method

PythonParserInitializeParserState Method

Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.ParseExpression Method

PythonParserParseExpression Method

Parses the specified expression text.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IPythonParseData ParseExpression(
    PythonVersion version,
    string text
)
Public Shared Function ParseExpression (
    version As PythonVersion,
    text As String
) As IPythonParseData

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version to use.
text
Type: SystemString
The expression text to parse.

Return Value

Type: IPythonParseData
The IPythonParseData that contains the parse results.
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider Class

Provides IntelliPrompt quick info data for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationQuickInfoProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonQuickInfoProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonQuickInfoProvider : QuickInfoProviderBase
Public Class PythonQuickInfoProvider
    Inherits QuickInfoProviderBase

The PythonQuickInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonQuickInfoProvider | Initializes a new instance of the PythonQuickInfoProvider class.
Top
Properties
 | Name | Description
Protected property | CanTrackPointerInput | Gets whether to track pointer input and allow pointer movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within quick info.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider Constructor

Initializes a new instance of the PythonQuickInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonQuickInfoProvider()
Public Sub New
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider Properties

The PythonQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Protected property | CanTrackPointerInput | Gets whether to track pointer input and allow pointer movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within quick info.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.ContextTypes Property

PythonQuickInfoProviderContextTypes Property

Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerable<Type> ContextTypes { get; }
Protected Overrides ReadOnly Property ContextTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The context Type objects that are supported by this provider.
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.DocstringDisplayMode Property

PythonQuickInfoProviderDocstringDisplayMode Property

Gets or sets the docstring display mode within quick info.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonDocstringDisplayMode DocstringDisplayMode { get; set; }
Public Property DocstringDisplayMode As PythonDocstringDisplayMode
    Get
    Set

Property Value

Type: PythonDocstringDisplayMode
A PythonDocstringDisplayMode that indicates the docstring display mode within quick info.
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider Methods

The PythonQuickInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.GetContext Method

PythonQuickInfoProviderGetContext Method

Overload List
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Top
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.GetContext Method (IEditorView, Int32)

PythonQuickInfoProviderGetContext Method (IEditorView, Int32)

Returns an object describing the quick info context for the specified text offset, if any.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetContext(
    IEditorView view,
    int offset
)
Public Overrides Function GetContext (
    view As IEditorView,
    offset As Integer
) As Object

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView in which the offset is located.
offset
Type: SystemInt32
The text offset to examine.

Return Value

Type: Object
An object describing the quick info context for the specified text offset, if any. A value indicates that no context is available.

Implements

IQuickInfoProviderGetContext(IEditorView, Int32)
Remarks
This method is called in response to keyboard events.
See Also

Reference

PythonQuickInfoProvider Class
GetContext Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.OnSessionOpening Method

PythonQuickInfoProviderOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IQuickInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IQuickInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIQuickInfoSession
The IQuickInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.RequestSession Method

PythonQuickInfoProviderRequestSession Method

Overload List
 | Name | Description
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.RequestSession Method (IEditorView, Object)

PythonQuickInfoProviderRequestSession Method (IEditorView, Object)

Requests that an IQuickInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool RequestSession(
    IEditorView view,
    Object context
)
Protected Overrides Function RequestSession (
    view As IEditorView,
    context As Object
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
context
Type: SystemObject
A context object returned by GetContext(IEditorView, Int32).

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

PythonQuickInfoProvider Class
RequestSession Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Class

Represents a Python syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.Python.ImplementationPythonSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonSyntaxLanguage : SyntaxLanguage,
    ICodeDocumentLifecycleEventSink, ICodeDocumentPropertyChangeEventSink
Public Class PythonSyntaxLanguage
    Inherits SyntaxLanguage
    Implements ICodeDocumentLifecycleEventSink, ICodeDocumentPropertyChangeEventSink

The PythonSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | PythonSyntaxLanguage | Initializes a new instance of the PythonSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language.
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language.
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language.
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language.
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Constructor

Initializes a new instance of the PythonSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonSyntaxLanguage(
    PythonVersion version = PythonVersion.Version3
)
Public Sub New (
    Optional version As PythonVersion = PythonVersion.Version3
)

Parameters

version (Optional)
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version supported by this language.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Properties

The PythonSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language.
Top
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.Version Property

PythonSyntaxLanguageVersion Property

Gets the PythonVersion that indicates the Python version supported by this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; }
Public ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this language.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Methods

The PythonSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language.
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language.
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language.
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.OnDocumentAttached Method

PythonSyntaxLanguageOnDocumentAttached Method

Occurs when the specified ICodeDocument is attached to the language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentAttached(
    ICodeDocument document
)
Protected Overridable Sub OnDocumentAttached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.OnDocumentDetached Method

PythonSyntaxLanguageOnDocumentDetached Method

Occurs when the specified ICodeDocument is detached from the language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentDetached(
    ICodeDocument document
)
Protected Overridable Sub OnDocumentDetached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.OnDocumentFileNameChanged Method

PythonSyntaxLanguageOnDocumentFileNameChanged Method

Occurs after the FileName property is changed on an ICodeDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentFileNameChanged(
    ICodeDocument document,
    StringPropertyChangedEventArgs e
)
Protected Overridable Sub OnDocumentFileNameChanged (
    document As ICodeDocument,
    e As StringPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose FileName property is changed.
e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
The StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.OnDocumentParseDataChanged Method

PythonSyntaxLanguageOnDocumentParseDataChanged Method

Occurs after the ParseData property is changed on an ICodeDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Python.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentParseDataChanged(
    ICodeDocument document,
    ParseDataPropertyChangedEventArgs e
)
Protected Overridable Sub OnDocumentParseDataChanged (
    document As ICodeDocument,
    e As ParseDataPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose ParseData property is changed.
e
Type: ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
The ParseDataPropertyChangedEventArgs that contains the event data.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Events

The PythonSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Class

Contains the token IDs for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenId

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonTokenId : TokenIdProviderBase
Public Class PythonTokenId
    Inherits TokenIdProviderBase

The PythonTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTokenId | Initializes a new instance of the PythonTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPythonSystemIdentifierClassificationType | Returns whether the specified ID value is part of the PythonSystemIdentifier.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
Top
Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
DecoratorDelimiter | Gets the DecoratorDelimiter token ID.
Dedent | Gets the Dedent token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
Indent | Gets the Indent token ID.
KeywordAnd | Gets the KeywordAnd token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordAssert | Gets the KeywordAssert token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDef | Gets the KeywordDef token ID.
KeywordDel | Gets the KeywordDel token ID.
KeywordElIf | Gets the KeywordElIf token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordExcept | Gets the KeywordExcept token ID.
KeywordExec | Gets the KeywordExec token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFrom | Gets the KeywordFrom token ID.
KeywordGlobal | Gets the KeywordGlobal token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImport | Gets the KeywordImport token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordLambda | Gets the KeywordLambda token ID.
KeywordNone | Gets the KeywordNone token ID.
KeywordNonLocal | Gets the KeywordNonLocal token ID.
KeywordNot | Gets the KeywordNot token ID.
KeywordOr | Gets the KeywordOr token ID.
KeywordPass | Gets the KeywordPass token ID.
KeywordPrint | Gets the KeywordPrint token ID.
KeywordRaise | Gets the KeywordRaise token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWith | Gets the KeywordWith token ID.
KeywordYield | Gets the KeywordYield token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralBinaryInteger | Gets the LiteralBinaryInteger token ID.
LiteralBytes | Gets the LiteralBytes token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralDoubleQuoteLongString | Gets the LiteralDoubleQuoteLongString token ID.
LiteralDoubleQuoteString | Gets the LiteralDoubleQuoteString token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralImaginary | Gets the LiteralImaginary token ID.
LiteralOctalInteger | Gets the LiteralOctalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralSingleQuoteLongString | Gets the LiteralSingleQuoteLongString token ID.
LiteralSingleQuoteString | Gets the LiteralSingleQuoteString token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorFloorDivision | Gets the OperatorFloorDivision token ID.
OperatorFloorDivisionAssignment | Gets the OperatorFloorDivisionAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorPower | Gets the OperatorPower token ID.
OperatorPowerAssignment | Gets the OperatorPowerAssignment token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
ReverseQuote | Gets the ReverseQuote token ID.
RightArrow | Gets the RightArrow token ID.
SemiColon | Gets the SemiColon token ID.
SystemIdentifier | Gets the SystemIdentifier token ID.
Whitespace | Gets the Whitespace token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Constructor

Initializes a new instance of the PythonTokenId class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonTokenId()
Public Sub New
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Properties

The PythonTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.MaxId Property

PythonTokenIdMaxId Property

Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.MinId Property

PythonTokenIdMinId Property

Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Methods

The PythonTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPythonSystemIdentifierClassificationType | Returns whether the specified ID value is part of the PythonSystemIdentifier.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
Top
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.ContainsId Method

PythonTokenIdContainsId Method

Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.GetDescription Method

PythonTokenIdGetDescription Method

Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.GetKey Method

PythonTokenIdGetKey Method

Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsCommentClassificationType Method

PythonTokenIdIsCommentClassificationType Method

Returns whether the specified ID value is part of the Comment.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsCommentClassificationType(
    int id
)
Public Shared Function IsCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsIdentifierClassificationType Method

PythonTokenIdIsIdentifierClassificationType Method

Returns whether the specified ID value is part of the Identifier.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsIdentifierClassificationType(
    int id
)
Public Shared Function IsIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsKeywordClassificationType Method

PythonTokenIdIsKeywordClassificationType Method

Returns whether the specified ID value is part of the Keyword.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsKeywordClassificationType(
    int id
)
Public Shared Function IsKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsNumberClassificationType Method

PythonTokenIdIsNumberClassificationType Method

Returns whether the specified ID value is part of the Number.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsNumberClassificationType(
    int id
)
Public Shared Function IsNumberClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsOperatorClassificationType Method

PythonTokenIdIsOperatorClassificationType Method

Returns whether the specified ID value is part of the Operator.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsOperatorClassificationType(
    int id
)
Public Shared Function IsOperatorClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsPythonSystemIdentifierClassificationType Method

PythonTokenIdIsPythonSystemIdentifierClassificationType Method

Returns whether the specified ID value is part of the PythonSystemIdentifier.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsPythonSystemIdentifierClassificationType(
    int id
)
Public Shared Function IsPythonSystemIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsStringClassificationType Method

PythonTokenIdIsStringClassificationType Method

Returns whether the specified ID value is part of the String.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsStringClassificationType(
    int id
)
Public Shared Function IsStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Fields

The PythonTokenId type exposes the following members.

Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
DecoratorDelimiter | Gets the DecoratorDelimiter token ID.
Dedent | Gets the Dedent token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
Indent | Gets the Indent token ID.
KeywordAnd | Gets the KeywordAnd token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordAssert | Gets the KeywordAssert token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDef | Gets the KeywordDef token ID.
KeywordDel | Gets the KeywordDel token ID.
KeywordElIf | Gets the KeywordElIf token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordExcept | Gets the KeywordExcept token ID.
KeywordExec | Gets the KeywordExec token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFrom | Gets the KeywordFrom token ID.
KeywordGlobal | Gets the KeywordGlobal token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImport | Gets the KeywordImport token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordLambda | Gets the KeywordLambda token ID.
KeywordNone | Gets the KeywordNone token ID.
KeywordNonLocal | Gets the KeywordNonLocal token ID.
KeywordNot | Gets the KeywordNot token ID.
KeywordOr | Gets the KeywordOr token ID.
KeywordPass | Gets the KeywordPass token ID.
KeywordPrint | Gets the KeywordPrint token ID.
KeywordRaise | Gets the KeywordRaise token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWith | Gets the KeywordWith token ID.
KeywordYield | Gets the KeywordYield token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralBinaryInteger | Gets the LiteralBinaryInteger token ID.
LiteralBytes | Gets the LiteralBytes token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralDoubleQuoteLongString | Gets the LiteralDoubleQuoteLongString token ID.
LiteralDoubleQuoteString | Gets the LiteralDoubleQuoteString token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralImaginary | Gets the LiteralImaginary token ID.
LiteralOctalInteger | Gets the LiteralOctalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralSingleQuoteLongString | Gets the LiteralSingleQuoteLongString token ID.
LiteralSingleQuoteString | Gets the LiteralSingleQuoteString token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorFloorDivision | Gets the OperatorFloorDivision token ID.
OperatorFloorDivisionAssignment | Gets the OperatorFloorDivisionAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorPower | Gets the OperatorPower token ID.
OperatorPowerAssignment | Gets the OperatorPowerAssignment token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
ReverseQuote | Gets the ReverseQuote token ID.
RightArrow | Gets the RightArrow token ID.
SemiColon | Gets the SemiColon token ID.
SystemIdentifier | Gets the SystemIdentifier token ID.
Whitespace | Gets the Whitespace token ID.
Top
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.CloseCurlyBrace Field

PythonTokenIdCloseCurlyBrace Field

Gets the CloseCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseCurlyBrace = 14008
Public Const CloseCurlyBrace As Integer = 14008

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.CloseParenthesis Field

PythonTokenIdCloseParenthesis Field

Gets the CloseParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseParenthesis = 14004
Public Const CloseParenthesis As Integer = 14004

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.CloseSquareBrace Field

PythonTokenIdCloseSquareBrace Field

Gets the CloseSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseSquareBrace = 14006
Public Const CloseSquareBrace As Integer = 14006

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Colon Field

PythonTokenIdColon Field

Gets the Colon token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Colon = 14010
Public Const Colon As Integer = 14010

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Comma Field

PythonTokenIdComma Field

Gets the Comma token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Comma = 14009
Public Const Comma As Integer = 14009

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.CommentSingleLine Field

PythonTokenIdCommentSingleLine Field

Gets the CommentSingleLine token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentSingleLine = 14016
Public Const CommentSingleLine As Integer = 14016

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.DecoratorDelimiter Field

PythonTokenIdDecoratorDelimiter Field

Gets the DecoratorDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DecoratorDelimiter = 14013
Public Const DecoratorDelimiter As Integer = 14013

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Dedent Field

PythonTokenIdDedent Field

Gets the Dedent token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Dedent = 14098
Public Const Dedent As Integer = 14098

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Dot Field

PythonTokenIdDot Field

Gets the Dot token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Dot = 14011
Public Const Dot As Integer = 14011

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Identifier Field

PythonTokenIdIdentifier Field

Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Identifier = 14060
Public Const Identifier As Integer = 14060

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Indent Field

PythonTokenIdIndent Field

Gets the Indent token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Indent = 14097
Public Const Indent As Integer = 14097

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordAnd Field

PythonTokenIdKeywordAnd Field

Gets the KeywordAnd token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAnd = 14062
Public Const KeywordAnd As Integer = 14062

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordAs Field

PythonTokenIdKeywordAs Field

Gets the KeywordAs token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAs = 14063
Public Const KeywordAs As Integer = 14063

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordAssert Field

PythonTokenIdKeywordAssert Field

Gets the KeywordAssert token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAssert = 14064
Public Const KeywordAssert As Integer = 14064

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordBreak Field

PythonTokenIdKeywordBreak Field

Gets the KeywordBreak token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordBreak = 14065
Public Const KeywordBreak As Integer = 14065

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordClass Field

PythonTokenIdKeywordClass Field

Gets the KeywordClass token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordClass = 14066
Public Const KeywordClass As Integer = 14066

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordContinue Field

PythonTokenIdKeywordContinue Field

Gets the KeywordContinue token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordContinue = 14067
Public Const KeywordContinue As Integer = 14067

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordDef Field

PythonTokenIdKeywordDef Field

Gets the KeywordDef token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDef = 14068
Public Const KeywordDef As Integer = 14068

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordDel Field

PythonTokenIdKeywordDel Field

Gets the KeywordDel token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDel = 14069
Public Const KeywordDel As Integer = 14069

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordElIf Field

PythonTokenIdKeywordElIf Field

Gets the KeywordElIf token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordElIf = 14070
Public Const KeywordElIf As Integer = 14070

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordElse Field

PythonTokenIdKeywordElse Field

Gets the KeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordElse = 14071
Public Const KeywordElse As Integer = 14071

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordExcept Field

PythonTokenIdKeywordExcept Field

Gets the KeywordExcept token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordExcept = 14072
Public Const KeywordExcept As Integer = 14072

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordExec Field

PythonTokenIdKeywordExec Field

Gets the KeywordExec token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordExec = 14073
Public Const KeywordExec As Integer = 14073

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordFalse Field

PythonTokenIdKeywordFalse Field

Gets the KeywordFalse token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFalse = 14074
Public Const KeywordFalse As Integer = 14074

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordFinally Field

PythonTokenIdKeywordFinally Field

Gets the KeywordFinally token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFinally = 14075
Public Const KeywordFinally As Integer = 14075

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordFor Field

PythonTokenIdKeywordFor Field

Gets the KeywordFor token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFor = 14076
Public Const KeywordFor As Integer = 14076

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordFrom Field

PythonTokenIdKeywordFrom Field

Gets the KeywordFrom token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFrom = 14077
Public Const KeywordFrom As Integer = 14077

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordGlobal Field

PythonTokenIdKeywordGlobal Field

Gets the KeywordGlobal token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordGlobal = 14078
Public Const KeywordGlobal As Integer = 14078

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordIf Field

PythonTokenIdKeywordIf Field

Gets the KeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIf = 14079
Public Const KeywordIf As Integer = 14079

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordImport Field

PythonTokenIdKeywordImport Field

Gets the KeywordImport token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordImport = 14080
Public Const KeywordImport As Integer = 14080

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordIn Field

PythonTokenIdKeywordIn Field

Gets the KeywordIn token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIn = 14081
Public Const KeywordIn As Integer = 14081

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordIs Field

PythonTokenIdKeywordIs Field

Gets the KeywordIs token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIs = 14082
Public Const KeywordIs As Integer = 14082

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordLambda Field

PythonTokenIdKeywordLambda Field

Gets the KeywordLambda token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordLambda = 14083
Public Const KeywordLambda As Integer = 14083

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordNone Field

PythonTokenIdKeywordNone Field

Gets the KeywordNone token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNone = 14085
Public Const KeywordNone As Integer = 14085

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordNonLocal Field

PythonTokenIdKeywordNonLocal Field

Gets the KeywordNonLocal token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNonLocal = 14084
Public Const KeywordNonLocal As Integer = 14084

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordNot Field

PythonTokenIdKeywordNot Field

Gets the KeywordNot token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNot = 14086
Public Const KeywordNot As Integer = 14086

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordOr Field

PythonTokenIdKeywordOr Field

Gets the KeywordOr token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOr = 14087
Public Const KeywordOr As Integer = 14087

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordPass Field

PythonTokenIdKeywordPass Field

Gets the KeywordPass token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordPass = 14088
Public Const KeywordPass As Integer = 14088

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordPrint Field

PythonTokenIdKeywordPrint Field

Gets the KeywordPrint token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordPrint = 14089
Public Const KeywordPrint As Integer = 14089

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordRaise Field

PythonTokenIdKeywordRaise Field

Gets the KeywordRaise token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordRaise = 14090
Public Const KeywordRaise As Integer = 14090

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordReturn Field

PythonTokenIdKeywordReturn Field

Gets the KeywordReturn token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordReturn = 14091
Public Const KeywordReturn As Integer = 14091

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordTrue Field

PythonTokenIdKeywordTrue Field

Gets the KeywordTrue token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTrue = 14092
Public Const KeywordTrue As Integer = 14092

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordTry Field

PythonTokenIdKeywordTry Field

Gets the KeywordTry token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTry = 14093
Public Const KeywordTry As Integer = 14093

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordWhile Field

PythonTokenIdKeywordWhile Field

Gets the KeywordWhile token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWhile = 14094
Public Const KeywordWhile As Integer = 14094

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordWith Field

PythonTokenIdKeywordWith Field

Gets the KeywordWith token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWith = 14095
Public Const KeywordWith As Integer = 14095

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordYield Field

PythonTokenIdKeywordYield Field

Gets the KeywordYield token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordYield = 14096
Public Const KeywordYield As Integer = 14096

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LineContinuation Field

PythonTokenIdLineContinuation Field

Gets the LineContinuation token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LineContinuation = 14002
Public Const LineContinuation As Integer = 14002

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LineTerminator Field

PythonTokenIdLineTerminator Field

Gets the LineTerminator token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LineTerminator = 14001
Public Const LineTerminator As Integer = 14001

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralBinaryInteger Field

PythonTokenIdLiteralBinaryInteger Field

Gets the LiteralBinaryInteger token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralBinaryInteger = 14050
Public Const LiteralBinaryInteger As Integer = 14050

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralBytes Field

PythonTokenIdLiteralBytes Field

Gets the LiteralBytes token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralBytes = 14049
Public Const LiteralBytes As Integer = 14049

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralDecimalInteger Field

PythonTokenIdLiteralDecimalInteger Field

Gets the LiteralDecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralDecimalInteger = 14051
Public Const LiteralDecimalInteger As Integer = 14051

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralDoubleQuoteLongString Field

PythonTokenIdLiteralDoubleQuoteLongString Field

Gets the LiteralDoubleQuoteLongString token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralDoubleQuoteLongString = 14053
Public Const LiteralDoubleQuoteLongString As Integer = 14053

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralDoubleQuoteString Field

PythonTokenIdLiteralDoubleQuoteString Field

Gets the LiteralDoubleQuoteString token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralDoubleQuoteString = 14052
Public Const LiteralDoubleQuoteString As Integer = 14052

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralHexadecimalInteger Field

PythonTokenIdLiteralHexadecimalInteger Field

Gets the LiteralHexadecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralHexadecimalInteger = 14054
Public Const LiteralHexadecimalInteger As Integer = 14054

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralImaginary Field

PythonTokenIdLiteralImaginary Field

Gets the LiteralImaginary token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralImaginary = 14055
Public Const LiteralImaginary As Integer = 14055

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralOctalInteger Field

PythonTokenIdLiteralOctalInteger Field

Gets the LiteralOctalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralOctalInteger = 14056
Public Const LiteralOctalInteger As Integer = 14056

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralReal Field

PythonTokenIdLiteralReal Field

Gets the LiteralReal token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralReal = 14057
Public Const LiteralReal As Integer = 14057

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralSingleQuoteLongString Field

PythonTokenIdLiteralSingleQuoteLongString Field

Gets the LiteralSingleQuoteLongString token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralSingleQuoteLongString = 14059
Public Const LiteralSingleQuoteLongString As Integer = 14059

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralSingleQuoteString Field

PythonTokenIdLiteralSingleQuoteString Field

Gets the LiteralSingleQuoteString token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralSingleQuoteString = 14058
Public Const LiteralSingleQuoteString As Integer = 14058

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OpenCurlyBrace Field

PythonTokenIdOpenCurlyBrace Field

Gets the OpenCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenCurlyBrace = 14007
Public Const OpenCurlyBrace As Integer = 14007

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OpenParenthesis Field

PythonTokenIdOpenParenthesis Field

Gets the OpenParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenParenthesis = 14003
Public Const OpenParenthesis As Integer = 14003

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OpenSquareBrace Field

PythonTokenIdOpenSquareBrace Field

Gets the OpenSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenSquareBrace = 14005
Public Const OpenSquareBrace As Integer = 14005

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorAddition Field

PythonTokenIdOperatorAddition Field

Gets the OperatorAddition token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAddition = 14017
Public Const OperatorAddition As Integer = 14017

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorAdditionAssignment Field

PythonTokenIdOperatorAdditionAssignment Field

Gets the OperatorAdditionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAdditionAssignment = 14037
Public Const OperatorAdditionAssignment As Integer = 14037

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorAssignment Field

PythonTokenIdOperatorAssignment Field

Gets the OperatorAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAssignment = 14036
Public Const OperatorAssignment As Integer = 14036

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorBitwiseAnd Field

PythonTokenIdOperatorBitwiseAnd Field

Gets the OperatorBitwiseAnd token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAnd = 14026
Public Const OperatorBitwiseAnd As Integer = 14026

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorBitwiseAndAssignment Field

PythonTokenIdOperatorBitwiseAndAssignment Field

Gets the OperatorBitwiseAndAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAndAssignment = 14044
Public Const OperatorBitwiseAndAssignment As Integer = 14044

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorBitwiseOr Field

PythonTokenIdOperatorBitwiseOr Field

Gets the OperatorBitwiseOr token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOr = 14027
Public Const OperatorBitwiseOr As Integer = 14027

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorBitwiseOrAssignment Field

PythonTokenIdOperatorBitwiseOrAssignment Field

Gets the OperatorBitwiseOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOrAssignment = 14045
Public Const OperatorBitwiseOrAssignment As Integer = 14045

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorDivision Field

PythonTokenIdOperatorDivision Field

Gets the OperatorDivision token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorDivision = 14021
Public Const OperatorDivision As Integer = 14021

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorDivisionAssignment Field

PythonTokenIdOperatorDivisionAssignment Field

Gets the OperatorDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorDivisionAssignment = 14041
Public Const OperatorDivisionAssignment As Integer = 14041

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorEquality Field

PythonTokenIdOperatorEquality Field

Gets the OperatorEquality token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorEquality = 14034
Public Const OperatorEquality As Integer = 14034

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorExclusiveOr Field

PythonTokenIdOperatorExclusiveOr Field

Gets the OperatorExclusiveOr token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOr = 14028
Public Const OperatorExclusiveOr As Integer = 14028

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorExclusiveOrAssignment Field

PythonTokenIdOperatorExclusiveOrAssignment Field

Gets the OperatorExclusiveOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOrAssignment = 14046
Public Const OperatorExclusiveOrAssignment As Integer = 14046

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorFloorDivision Field

PythonTokenIdOperatorFloorDivision Field

Gets the OperatorFloorDivision token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorFloorDivision = 14022
Public Const OperatorFloorDivision As Integer = 14022

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorFloorDivisionAssignment Field

PythonTokenIdOperatorFloorDivisionAssignment Field

Gets the OperatorFloorDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorFloorDivisionAssignment = 14042
Public Const OperatorFloorDivisionAssignment As Integer = 14042

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorGreaterThan Field

PythonTokenIdOperatorGreaterThan Field

Gets the OperatorGreaterThan token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThan = 14031
Public Const OperatorGreaterThan As Integer = 14031

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorGreaterThanOrEqual Field

PythonTokenIdOperatorGreaterThanOrEqual Field

Gets the OperatorGreaterThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThanOrEqual = 14033
Public Const OperatorGreaterThanOrEqual As Integer = 14033

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorInequality Field

PythonTokenIdOperatorInequality Field

Gets the OperatorInequality token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorInequality = 14035
Public Const OperatorInequality As Integer = 14035

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorLeftShift Field

PythonTokenIdOperatorLeftShift Field

Gets the OperatorLeftShift token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLeftShift = 14024
Public Const OperatorLeftShift As Integer = 14024

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorLeftShiftAssignment Field

PythonTokenIdOperatorLeftShiftAssignment Field

Gets the OperatorLeftShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLeftShiftAssignment = 14047
Public Const OperatorLeftShiftAssignment As Integer = 14047

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorLessThan Field

PythonTokenIdOperatorLessThan Field

Gets the OperatorLessThan token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLessThan = 14030
Public Const OperatorLessThan As Integer = 14030

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorLessThanOrEqual Field

PythonTokenIdOperatorLessThanOrEqual Field

Gets the OperatorLessThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLessThanOrEqual = 14032
Public Const OperatorLessThanOrEqual As Integer = 14032

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorModulus Field

PythonTokenIdOperatorModulus Field

Gets the OperatorModulus token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorModulus = 14023
Public Const OperatorModulus As Integer = 14023

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorModulusAssignment Field

PythonTokenIdOperatorModulusAssignment Field

Gets the OperatorModulusAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorModulusAssignment = 14043
Public Const OperatorModulusAssignment As Integer = 14043

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorMultiplication Field

PythonTokenIdOperatorMultiplication Field

Gets the OperatorMultiplication token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorMultiplication = 14019
Public Const OperatorMultiplication As Integer = 14019

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorMultiplicationAssignment Field

PythonTokenIdOperatorMultiplicationAssignment Field

Gets the OperatorMultiplicationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorMultiplicationAssignment = 14039
Public Const OperatorMultiplicationAssignment As Integer = 14039

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorOnesComplement Field

PythonTokenIdOperatorOnesComplement Field

Gets the OperatorOnesComplement token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorOnesComplement = 14029
Public Const OperatorOnesComplement As Integer = 14029

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorPower Field

PythonTokenIdOperatorPower Field

Gets the OperatorPower token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorPower = 14020
Public Const OperatorPower As Integer = 14020

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorPowerAssignment Field

PythonTokenIdOperatorPowerAssignment Field

Gets the OperatorPowerAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorPowerAssignment = 14040
Public Const OperatorPowerAssignment As Integer = 14040

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorRightShift Field

PythonTokenIdOperatorRightShift Field

Gets the OperatorRightShift token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorRightShift = 14025
Public Const OperatorRightShift As Integer = 14025

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorRightShiftAssignment Field

PythonTokenIdOperatorRightShiftAssignment Field

Gets the OperatorRightShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorRightShiftAssignment = 14048
Public Const OperatorRightShiftAssignment As Integer = 14048

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorSubtraction Field

PythonTokenIdOperatorSubtraction Field

Gets the OperatorSubtraction token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorSubtraction = 14018
Public Const OperatorSubtraction As Integer = 14018

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorSubtractionAssignment Field

PythonTokenIdOperatorSubtractionAssignment Field

Gets the OperatorSubtractionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorSubtractionAssignment = 14038
Public Const OperatorSubtractionAssignment As Integer = 14038

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.ReverseQuote Field

PythonTokenIdReverseQuote Field

Gets the ReverseQuote token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ReverseQuote = 14014
Public Const ReverseQuote As Integer = 14014

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.RightArrow Field

PythonTokenIdRightArrow Field

Gets the RightArrow token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int RightArrow = 14015
Public Const RightArrow As Integer = 14015

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.SemiColon Field

PythonTokenIdSemiColon Field

Gets the SemiColon token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SemiColon = 14012
Public Const SemiColon As Integer = 14012

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.SystemIdentifier Field

PythonTokenIdSystemIdentifier Field

Gets the SystemIdentifier token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int SystemIdentifier = 14061
Public Const SystemIdentifier As Integer = 14061

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Whitespace Field

PythonTokenIdWhitespace Field

Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Whitespace = 14000
Public Const Whitespace As Integer = 14000

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader Class

Represents an object that can provide tokens to a ILLParser in a forward-only direction for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenReader

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonTokenReader : MergableTokenReader
Public Class PythonTokenReader
    Inherits MergableTokenReader

The PythonTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTokenReader | Initializes a new instance of the PythonTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | TabSize | Gets or sets the tab size, used when watching for indent and dedent tokens.
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Overrides MergableTokenReaderPop.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Overrides MergableTokenReaderPush.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader Constructor

Initializes a new instance of the PythonTokenReader class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader Properties

The PythonTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | TabSize | Gets or sets the tab size, used when watching for indent and dedent tokens.
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader.TabSize Property

PythonTokenReaderTabSize Property

Gets or sets the tab size, used when watching for indent and dedent tokens.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int TabSize { get; set; }
Public Property TabSize As Integer
    Get
    Set

Property Value

Type: Int32
The tab size, used when watching for indent and dedent tokens.
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader Methods

The PythonTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Overrides MergableTokenReaderPop.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Overrides MergableTokenReaderPush.)
Top
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader.GetNextToken Method

PythonTokenReaderGetNextToken Method

Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader.Pop Method

PythonTokenReaderPop Method

Pops the top token reader state from the stack and restores the token reader to that state.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Pop()
Public Overrides Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITokenReaderPop
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader.Push Method

PythonTokenReaderPush Method

Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Push()
Public Overrides Sub Push

Implements

ITokenReaderPush
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Class

Represents an ITaggerT for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTagger

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonTokenTagger : TokenTagger
Public Class PythonTokenTagger
    Inherits TokenTagger

The PythonTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTokenTagger | Initializes a new instance of the PythonTokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Constructor

Initializes a new instance of the PythonTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonTokenTagger(
    ICodeDocument document,
    IPythonClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    document As ICodeDocument,
    classificationTypeProvider As IPythonClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypeProvider
Type: ActiproSoftware.Text.Languages.PythonIPythonClassificationTypeProvider
A IPythonClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Properties

The PythonTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Methods

The PythonTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger.ClassifyToken Method

PythonTokenTaggerClassifyToken Method

Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IClassificationType ClassifyToken(
    IToken token
)
Public Overrides Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Events

The PythonTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider Class

Represents a provider of PythonTokenTagger objects for documents that use the PythonTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase PythonTokenTagger
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PythonTokenTaggerProvider : TaggerProviderBase<PythonTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class PythonTokenTaggerProvider
    Inherits TaggerProviderBase(Of PythonTokenTagger)
    Implements ICodeDocumentTaggerProvider

The PythonTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTokenTaggerProvider | Initializes a new instance of the PythonTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider Constructor

Initializes a new instance of the PythonTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonTokenTaggerProvider(
    IPythonClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IPythonClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.PythonIPythonClassificationTypeProvider
A IPythonClassificationTypeProvider that provides classification types.
See Also

Reference

PythonTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider Properties

The PythonTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

PythonTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider Methods

The PythonTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
See Also

Reference

PythonTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider.GetTagger(T) Method

PythonTokenTaggerProviderGetTaggerT Method

Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

PythonTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider.TaggerFactory Class

PythonTokenTaggerProviderTaggerFactory Class

Implements a factory that can creates PythonTokenTagger objects for a document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTaggerProviderTaggerFactory

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TaggerFactory
Public Class TaggerFactory

The PythonTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an PythonTokenTagger for the ICodeDocument.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


TaggerFactory Methods

The PythonTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an PythonTokenTagger for the ICodeDocument.
Top
See Also

Reference

PythonTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider.TaggerFactory.CreateTagger Method

PythonTokenTaggerProviderTaggerFactoryCreateTagger Method

Creates an PythonTokenTagger for the ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonTokenTagger CreateTagger()
Public Function CreateTagger As PythonTokenTagger

Return Value

Type: PythonTokenTagger
An PythonTokenTagger for the ICodeDocument.
See Also

Reference

PythonTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


ActiproSoftware.Text.Languages.Python.Reflection Namespace

Contains the types related to reflection for a Python syntax language.
Classes
 | Class | Description
Public class | AmbientPackageRepositoryProvider | Implements a class that can be used to provide a static IPackageRepository that is used for managing and caching packages by default.
Interfaces
 | Interface | Description
Public interface | IActiveModuleCollection | Provides the base requirements for a collection of active IModuleDefinition objects.
Public interface | IAliasedText | Provides the base requirements of possibly-aliased text.
Public interface | IAliasedTextCollection | Provides the base requirements for a collection of IAliasedText objects.
Public interface | IFieldDefinition | Provides the base requirements of a field definition.
Public interface | IFieldDefinitionCollection | Provides the base requirements for a collection of IFieldDefinition objects.
Public interface | IFunctionDefinition | Provides the base requirements of a function definition.
Public interface | IFunctionDefinitionCollection | Provides the base requirements for a collection of IFunctionDefinition objects.
Public interface | IImportDefinition | Provides the base requirements of an import definition.
Public interface | IImportDefinitionCollection | Provides the base requirements for a collection of IImportDefinition objects.
Public interface | IModuleDefinition | Provides the base requirements of a module definition.
Public interface | IModuleDefinitionCollection | Provides the base requirements for a collection of IModuleDefinition objects.
Public interface | IModuleReference | Provides the base requirements of a module.
Public interface | IPackageDefinition | Provides the base requirements of a package definition.
Public interface | IPackageReference | Provides the base requirements of a package.
Public interface | IPackageReferenceCollection | Provides the base requirements for a collection of IPackageReference objects.
Public interface | IPackageRepository | Provides the base requirements for a class that manages package instances and caching of data as appropriate.
Public interface | IParameterDefinition | Provides the base requirements of a parameter definition.
Public interface | IParameterDefinitionCollection | Provides the base requirements for a collection of IParameterDefinition objects.
Public interface | IProject | Represents a Python project.
Public interface | IReflectionDefinition | Provides the base requirements of a reflection definition.
Public interface | ITypeDefinition | Provides the base requirements of a type definition.
Public interface | ITypeDefinitionCollection | Provides the base requirements for a collection of ITypeDefinition objects.
Public interface | ITypeReference | Provides the base requirements of a type reference.
Public interface | ITypeReferenceCollection | Provides the base requirements for a collection of ITypeReference objects.
Public interface | IVariableDefinition | Provides the base requirements of a variable definition.
Public interface | IVariableDefinitionCollection | Provides the base requirements for a collection of IVariableDefinition objects.


AmbientPackageRepositoryProvider Class

Implements a class that can be used to provide a static IPackageRepository that is used for managing and caching packages by default.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ReflectionAmbientPackageRepositoryProvider

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class AmbientPackageRepositoryProvider
Public NotInheritable Class AmbientPackageRepositoryProvider

The AmbientPackageRepositoryProvider type exposes the following members.

Properties
Name | Description
Repository | Gets or sets the default IPackageRepository to use.
Top
Remarks
Set the Repository property to an IPackageRepository instance to register the default package respository.
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


AmbientPackageRepositoryProvider Properties

The AmbientPackageRepositoryProvider type exposes the following members.

Properties
Name | Description
Repository | Gets or sets the default IPackageRepository to use.
Top
See Also

Reference

AmbientPackageRepositoryProvider Class
ActiproSoftware.Text.Languages.Python.Reflection Namespace


AmbientPackageRepositoryProvider.Repository Property

AmbientPackageRepositoryProviderRepository Property

Gets or sets the default IPackageRepository to use.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IPackageRepository Repository { get; set; }
Public Shared Property Repository As IPackageRepository
    Get
    Set

Property Value

Type: IPackageRepository
The default IPackageRepository to use.
See Also

Reference

AmbientPackageRepositoryProvider Class
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection Interface

Provides the base requirements for a collection of active IModuleDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IActiveModuleCollection : IKeyedObservableCollection<IModuleDefinition>,
    IObservableCollection<IModuleDefinition>, IList<IModuleDefinition>, ICollection<IModuleDefinition>,
    IEnumerable<IModuleDefinition>, IEnumerable
Public Interface IActiveModuleCollection
    Inherits IKeyedObservableCollection(Of IModuleDefinition), IObservableCollection(Of IModuleDefinition),
    IList(Of IModuleDefinition), ICollection(Of IModuleDefinition), IEnumerable(Of IModuleDefinition),
    IEnumerable

The IActiveModuleCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IModuleDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | Add(String, CompilationUnit) | Adds an IModuleDefinition for the specified CompilationUnit to the collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IModuleDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IModuleDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IModuleDefinition .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList IModuleDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IModuleDefinition .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IModuleDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIModuleDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIModuleDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIModuleDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection Properties

The IActiveModuleCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IModuleDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

IActiveModuleCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection Methods

The IActiveModuleCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | Add(String, CompilationUnit) | Adds an IModuleDefinition for the specified CompilationUnit to the collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IModuleDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IModuleDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IModuleDefinition .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList IModuleDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IModuleDefinition .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IModuleDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIModuleDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIModuleDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIModuleDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IActiveModuleCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection.Add Method

IActiveModuleCollectionAdd Method

Overload List
 | Name | Description
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | Add(String, CompilationUnit) | Adds an IModuleDefinition for the specified CompilationUnit to the collection.
Top
See Also

Reference

IActiveModuleCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection.Add Method (String, CompilationUnit)

IActiveModuleCollectionAdd Method (String, CompilationUnit)

Adds an IModuleDefinition for the specified CompilationUnit to the collection.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IModuleDefinition Add(
    string sourceFileKey,
    CompilationUnit compilationUnit
)
Function Add (
    sourceFileKey As String,
    compilationUnit As CompilationUnit
) As IModuleDefinition

Parameters

sourceFileKey
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
compilationUnit
Type: ActiproSoftware.Text.Languages.Python.Ast.ImplementationCompilationUnit
The CompilationUnit to examine.

Return Value

Type: IModuleDefinition
The IModuleDefinition that was added.
See Also

Reference

IActiveModuleCollection Interface
Add Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection Events

The IActiveModuleCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IActiveModuleCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedText Interface

Provides the base requirements of possibly-aliased text.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAliasedText
Public Interface IAliasedText

The IAliasedText type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias.
Public property | Text | Gets the text.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedText Properties

The IAliasedText type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias.
Public property | Text | Gets the text.
Top
See Also

Reference

IAliasedText Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedText.Alias Property

IAliasedTextAlias Property

Gets the alias.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Alias { get; }
ReadOnly Property Alias As String
    Get

Property Value

Type: String
The alias.
See Also

Reference

IAliasedText Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedText.Text Property

IAliasedTextText Property

Gets the text.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The text.
See Also

Reference

IAliasedText Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedTextCollection Interface

Provides the base requirements for a collection of IAliasedText objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAliasedTextCollection : IEnumerable,
    IObservableCollection<IAliasedText>, IList<IAliasedText>, ICollection<IAliasedText>,
    IEnumerable<IAliasedText>
Public Interface IAliasedTextCollection
    Inherits IEnumerable, IObservableCollection(Of IAliasedText), IList(Of IAliasedText),
    ICollection(Of IAliasedText), IEnumerable(Of IAliasedText)

The IAliasedTextCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IAliasedText .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IAliasedText .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IAliasedText .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IAliasedText .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IAliasedText .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IAliasedText .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IAliasedText .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IAliasedText .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IAliasedText .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IAliasedText .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IAliasedText .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIAliasedText | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIAliasedText | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIAliasedText | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedTextCollection Properties

The IAliasedTextCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IAliasedText .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IAliasedText .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IAliasedText .)
Top
See Also

Reference

IAliasedTextCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedTextCollection Methods

The IAliasedTextCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IAliasedText .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IAliasedText .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IAliasedText .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IAliasedText .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IAliasedText .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IAliasedText .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IAliasedText .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IAliasedText .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIAliasedText | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIAliasedText | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIAliasedText | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IAliasedTextCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedTextCollection Events

The IAliasedTextCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IAliasedTextCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition Interface

Provides the base requirements of a field definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IFieldDefinition : IReflectionDefinition
Public Interface IFieldDefinition
    Inherits IReflectionDefinition

The IFieldDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the field is declared.
Public property | DeclaringType | Gets the declaring type.
Public property | Docstring | Gets the docstring for the field.
Public property | IsPublic | Gets whether the field is public.
Public property | IsStatic | Gets whether the field is static.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the field type, if known.
Public property | TypeExpressionTextRange | Gets the field type expression TextRange.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition Properties

The IFieldDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the field is declared.
Public property | DeclaringType | Gets the declaring type.
Public property | Docstring | Gets the docstring for the field.
Public property | IsPublic | Gets whether the field is public.
Public property | IsStatic | Gets whether the field is static.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the field type, if known.
Public property | TypeExpressionTextRange | Gets the field type expression TextRange.
Top
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.DeclaringModule Property

IFieldDefinitionDeclaringModule Property

Gets the reference to the module in which the field is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IModuleReference DeclaringModule { get; }
ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the field is declared.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.DeclaringType Property

IFieldDefinitionDeclaringType Property

Gets the declaring type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition DeclaringType { get; }
ReadOnly Property DeclaringType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
The declaring type.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.Docstring Property

IFieldDefinitionDocstring Property

Gets the docstring for the field.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Docstring { get; }
ReadOnly Property Docstring As String
    Get

Property Value

Type: String
The docstring for the field.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.IsPublic Property

IFieldDefinitionIsPublic Property

Gets whether the field is public.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsPublic { get; }
ReadOnly Property IsPublic As Boolean
    Get

Property Value

Type: Boolean
true if the field is public; otherwise, false.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.IsStatic Property

IFieldDefinitionIsStatic Property

Gets whether the field is static.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsStatic { get; }
ReadOnly Property IsStatic As Boolean
    Get

Property Value

Type: Boolean
true if the field is static; otherwise, false.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.Type Property

IFieldDefinitionType Property

Gets a ITypeDefinition indicating the field type, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition Type { get; }
ReadOnly Property Type As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the field type, if known.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.TypeExpressionTextRange Property

IFieldDefinitionTypeExpressionTextRange Property

Gets the field type expression TextRange.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange TypeExpressionTextRange { get; }
ReadOnly Property TypeExpressionTextRange As TextRange
    Get

Property Value

Type: TextRange
The field type expression TextRange.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection Interface

Provides the base requirements for a collection of IFieldDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IFieldDefinitionCollection : IEnumerable,
    IObservableCollection<IFieldDefinition>, IList<IFieldDefinition>, ICollection<IFieldDefinition>,
    IEnumerable<IFieldDefinition>
Public Interface IFieldDefinitionCollection
    Inherits IEnumerable, IObservableCollection(Of IFieldDefinition), IList(Of IFieldDefinition),
    ICollection(Of IFieldDefinition), IEnumerable(Of IFieldDefinition)

The IFieldDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IFieldDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IFieldDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IFieldDefinition .)
Public property | ItemString | Gets the IFieldDefinition with the specified name. [C#] In C#, this property is the indexer for the IFieldDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IFieldDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IFieldDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IFieldDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IFieldDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IFieldDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IFieldDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IFieldDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IFieldDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIFieldDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIFieldDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIFieldDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection Properties

The IFieldDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IFieldDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IFieldDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IFieldDefinition .)
Public property | ItemString | Gets the IFieldDefinition with the specified name. [C#] In C#, this property is the indexer for the IFieldDefinitionCollection interface.
Top
See Also

Reference

IFieldDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection.Item Property

IFieldDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IFieldDefinition .)
Public property | ItemString | Gets the IFieldDefinition with the specified name. [C#] In C#, this property is the indexer for the IFieldDefinitionCollection interface.
Top
See Also

Reference

IFieldDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection.Item Property (String)

IFieldDefinitionCollectionItem Property (String)

Gets the IFieldDefinition with the specified name.

[C#] In C#, this property is the indexer for the IFieldDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IFieldDefinition this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As IFieldDefinition
    Get

Parameters

name
Type: SystemString
The name of the IFieldDefinition to return.

Property Value

Type: IFieldDefinition
The IFieldDefinition with the specified name.
See Also

Reference

IFieldDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection Methods

The IFieldDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IFieldDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IFieldDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IFieldDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IFieldDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IFieldDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IFieldDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IFieldDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IFieldDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIFieldDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIFieldDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIFieldDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IFieldDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection Events

The IFieldDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IFieldDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition Interface

Provides the base requirements of a function definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IFunctionDefinition : IReflectionDefinition
Public Interface IFunctionDefinition
    Inherits IReflectionDefinition

The IFunctionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the function is declared.
Public property | DeclaringType | Gets the declaring type, if the function is a method.
Public property | Docstring | Gets the docstring for the type.
Public property | IsClassMethod | Gets whether the function is a class method.
Public property | IsMethod | Gets whether the function is a method.
Public property | IsPublic | Gets whether the function is public.
Public property | IsStaticMethod | Gets whether the function is a static method.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Parameters | Gets the collection of parameters to the current function.
Public property | ReturnType | Gets a ITypeDefinition indicating the return type, if known.
Public property | ReturnTypeExpressionTextRange | Gets the return type expression TextRange, if known.
Public property | TextRange | Gets the TextRange of the function definition, if known.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition Properties

The IFunctionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the function is declared.
Public property | DeclaringType | Gets the declaring type, if the function is a method.
Public property | Docstring | Gets the docstring for the type.
Public property | IsClassMethod | Gets whether the function is a class method.
Public property | IsMethod | Gets whether the function is a method.
Public property | IsPublic | Gets whether the function is public.
Public property | IsStaticMethod | Gets whether the function is a static method.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Parameters | Gets the collection of parameters to the current function.
Public property | ReturnType | Gets a ITypeDefinition indicating the return type, if known.
Public property | ReturnTypeExpressionTextRange | Gets the return type expression TextRange, if known.
Public property | TextRange | Gets the TextRange of the function definition, if known.
Top
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.DeclaringModule Property

IFunctionDefinitionDeclaringModule Property

Gets the reference to the module in which the function is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IModuleReference DeclaringModule { get; }
ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the function is declared.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.DeclaringType Property

IFunctionDefinitionDeclaringType Property

Gets the declaring type, if the function is a method.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition DeclaringType { get; }
ReadOnly Property DeclaringType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
The declaring type, if the function is a method.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.Docstring Property

IFunctionDefinitionDocstring Property

Gets the docstring for the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Docstring { get; }
ReadOnly Property Docstring As String
    Get

Property Value

Type: String
The docstring for the type.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.IsClassMethod Property

IFunctionDefinitionIsClassMethod Property

Gets whether the function is a class method.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsClassMethod { get; }
ReadOnly Property IsClassMethod As Boolean
    Get

Property Value

Type: Boolean
true if the function is a class method; otherwise, false.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.IsMethod Property

IFunctionDefinitionIsMethod Property

Gets whether the function is a method.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsMethod { get; }
ReadOnly Property IsMethod As Boolean
    Get

Property Value

Type: Boolean
true if the function is a method; otherwise, false.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.IsPublic Property

IFunctionDefinitionIsPublic Property

Gets whether the function is public.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsPublic { get; }
ReadOnly Property IsPublic As Boolean
    Get

Property Value

Type: Boolean
true if the function is public; otherwise, false.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.IsStaticMethod Property

IFunctionDefinitionIsStaticMethod Property

Gets whether the function is a static method.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsStaticMethod { get; }
ReadOnly Property IsStaticMethod As Boolean
    Get

Property Value

Type: Boolean
true if the function is a static method; otherwise, false.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.Parameters Property

IFunctionDefinitionParameters Property

Gets the collection of parameters to the current function.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParameterDefinitionCollection Parameters { get; }
ReadOnly Property Parameters As IParameterDefinitionCollection
    Get

Property Value

Type: IParameterDefinitionCollection
The collection of parameters to the current function.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.ReturnType Property

IFunctionDefinitionReturnType Property

Gets a ITypeDefinition indicating the return type, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition ReturnType { get; }
ReadOnly Property ReturnType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the return type, if known.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.ReturnTypeExpressionTextRange Property

IFunctionDefinitionReturnTypeExpressionTextRange Property

Gets the return type expression TextRange, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange ReturnTypeExpressionTextRange { get; }
ReadOnly Property ReturnTypeExpressionTextRange As TextRange
    Get

Property Value

Type: TextRange
The return type expression TextRange, if known.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.TextRange Property

IFunctionDefinitionTextRange Property

Gets the TextRange of the function definition, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange TextRange { get; }
ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
The TextRange of the function definition, if known.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection Interface

Provides the base requirements for a collection of IFunctionDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IFunctionDefinitionCollection : IEnumerable,
    IObservableCollection<IFunctionDefinition>, IList<IFunctionDefinition>, ICollection<IFunctionDefinition>,
    IEnumerable<IFunctionDefinition>
Public Interface IFunctionDefinitionCollection
    Inherits IEnumerable, IObservableCollection(Of IFunctionDefinition), IList(Of IFunctionDefinition),
    ICollection(Of IFunctionDefinition), IEnumerable(Of IFunctionDefinition)

The IFunctionDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IFunctionDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IFunctionDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IFunctionDefinition .)
Public property | ItemString | Gets the IFunctionDefinition with the specified name. [C#] In C#, this property is the indexer for the IFunctionDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IFunctionDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IFunctionDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IFunctionDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IFunctionDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IFunctionDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IFunctionDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IFunctionDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IFunctionDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIFunctionDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIFunctionDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIFunctionDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection Properties

The IFunctionDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IFunctionDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IFunctionDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IFunctionDefinition .)
Public property | ItemString | Gets the IFunctionDefinition with the specified name. [C#] In C#, this property is the indexer for the IFunctionDefinitionCollection interface.
Top
See Also

Reference

IFunctionDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection.Item Property

IFunctionDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IFunctionDefinition .)
Public property | ItemString | Gets the IFunctionDefinition with the specified name. [C#] In C#, this property is the indexer for the IFunctionDefinitionCollection interface.
Top
See Also

Reference

IFunctionDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection.Item Property (String)

IFunctionDefinitionCollectionItem Property (String)

Gets the IFunctionDefinition with the specified name.

[C#] In C#, this property is the indexer for the IFunctionDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IFunctionDefinition this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As IFunctionDefinition
    Get

Parameters

name
Type: SystemString
The name of the IFunctionDefinition to return.

Property Value

Type: IFunctionDefinition
The IFunctionDefinition with the specified name.
See Also

Reference

IFunctionDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection Methods

The IFunctionDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IFunctionDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IFunctionDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IFunctionDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IFunctionDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IFunctionDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IFunctionDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IFunctionDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IFunctionDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIFunctionDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIFunctionDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIFunctionDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IFunctionDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection Events

The IFunctionDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IFunctionDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinition Interface

Provides the base requirements of an import definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IImportDefinition
Public Interface IImportDefinition

The IImportDefinition type exposes the following members.

Properties
 | Name | Description
Public property | MergedNames | Gets the collection of names from the source to import into the current namespace.
Public property | Source | Gets the import source.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinition Properties

The IImportDefinition type exposes the following members.

Properties
 | Name | Description
Public property | MergedNames | Gets the collection of names from the source to import into the current namespace.
Public property | Source | Gets the import source.
Top
See Also

Reference

IImportDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinition.MergedNames Property

IImportDefinitionMergedNames Property

Gets the collection of names from the source to import into the current namespace.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAliasedTextCollection MergedNames { get; }
ReadOnly Property MergedNames As IAliasedTextCollection
    Get

Property Value

Type: IAliasedTextCollection
The collection of names from the source to import into the current namespace.
See Also

Reference

IImportDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinition.Source Property

IImportDefinitionSource Property

Gets the import source.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAliasedText Source { get; }
ReadOnly Property Source As IAliasedText
    Get

Property Value

Type: IAliasedText
The import source.
See Also

Reference

IImportDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinitionCollection Interface

Provides the base requirements for a collection of IImportDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IImportDefinitionCollection : IEnumerable,
    IObservableCollection<IImportDefinition>, IList<IImportDefinition>, ICollection<IImportDefinition>,
    IEnumerable<IImportDefinition>
Public Interface IImportDefinitionCollection
    Inherits IEnumerable, IObservableCollection(Of IImportDefinition), IList(Of IImportDefinition),
    ICollection(Of IImportDefinition), IEnumerable(Of IImportDefinition)

The IImportDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IImportDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IImportDefinition .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IImportDefinition .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IImportDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IImportDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IImportDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IImportDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IImportDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IImportDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IImportDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IImportDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIImportDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIImportDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIImportDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinitionCollection Properties

The IImportDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IImportDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IImportDefinition .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IImportDefinition .)
Top
See Also

Reference

IImportDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinitionCollection Methods

The IImportDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IImportDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IImportDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IImportDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IImportDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IImportDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IImportDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IImportDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IImportDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIImportDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIImportDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIImportDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IImportDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinitionCollection Events

The IImportDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IImportDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition Interface

Provides the base requirements of a module definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IModuleDefinition : IKeyedObject,
    IModuleReference, IReflectionDefinition
Public Interface IModuleDefinition
    Inherits IKeyedObject, IModuleReference, IReflectionDefinition

The IModuleDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ExternalPublicNameReferences | Gets the optional collection of externally referenced child packages and/or modules whose public names should be combined with the PublicNames.
Public property | FileLastModifiedDateTime | Gets or sets the last modified date/time of the module file, if known.
Public property | FileSize | Gets or sets the size of the module file, if known.
Public property | Functions | Gets the collection of functions defined in the module.
Public property | Imports | Gets the collection of imports defined in the module.
Public property | IsBuiltin | Gets whether the module is built-in. (Inherited from IModuleReference.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | PackagePath | Gets the file system path of the package that contains the module. (Inherited from IModuleReference.)
Public property | Path | Gets the full file system path to the module. (Inherited from IModuleReference.)
Public property | PublicNames | Gets the optional collection of names publicly exposed by the module, which generally is specified by an __all__ variable.
Public property | Types | Gets the collection of types defined in the module.
Public property | Variables | Gets the collection of variables defined in the module.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition Properties

The IModuleDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ExternalPublicNameReferences | Gets the optional collection of externally referenced child packages and/or modules whose public names should be combined with the PublicNames.
Public property | FileLastModifiedDateTime | Gets or sets the last modified date/time of the module file, if known.
Public property | FileSize | Gets or sets the size of the module file, if known.
Public property | Functions | Gets the collection of functions defined in the module.
Public property | Imports | Gets the collection of imports defined in the module.
Public property | IsBuiltin | Gets whether the module is built-in. (Inherited from IModuleReference.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | PackagePath | Gets the file system path of the package that contains the module. (Inherited from IModuleReference.)
Public property | Path | Gets the full file system path to the module. (Inherited from IModuleReference.)
Public property | PublicNames | Gets the optional collection of names publicly exposed by the module, which generally is specified by an __all__ variable.
Public property | Types | Gets the collection of types defined in the module.
Public property | Variables | Gets the collection of variables defined in the module.
Top
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.ExternalPublicNameReferences Property

IModuleDefinitionExternalPublicNameReferences Property

Gets the optional collection of externally referenced child packages and/or modules whose public names should be combined with the PublicNames.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<string> ExternalPublicNameReferences { get; }
ReadOnly Property ExternalPublicNameReferences As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The optional collection of externally referenced child packages and/or modules whose public names should be combined with the PublicNames.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.FileLastModifiedDateTime Property

IModuleDefinitionFileLastModifiedDateTime Property

Gets or sets the last modified date/time of the module file, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<DateTime> FileLastModifiedDateTime { get; set; }
Property FileLastModifiedDateTime As Nullable(Of DateTime)
    Get
    Set

Property Value

Type: Nullable DateTime
The last modified date/time of the module file, if known.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.FileSize Property

IModuleDefinitionFileSize Property

Gets or sets the size of the module file, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<long> FileSize { get; set; }
Property FileSize As Nullable(Of Long)
    Get
    Set

Property Value

Type: Nullable Int64
The size of the module file, if known.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.Functions Property

IModuleDefinitionFunctions Property

Gets the collection of functions defined in the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IFunctionDefinitionCollection Functions { get; }
ReadOnly Property Functions As IFunctionDefinitionCollection
    Get

Property Value

Type: IFunctionDefinitionCollection
The collection of functions defined in the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.Imports Property

IModuleDefinitionImports Property

Gets the collection of imports defined in the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IImportDefinitionCollection Imports { get; }
ReadOnly Property Imports As IImportDefinitionCollection
    Get

Property Value

Type: IImportDefinitionCollection
The collection of imports defined in the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.PublicNames Property

IModuleDefinitionPublicNames Property

Gets the optional collection of names publicly exposed by the module, which generally is specified by an __all__ variable.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<string> PublicNames { get; }
ReadOnly Property PublicNames As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The optional collection of names publicly exposed by the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.Types Property

IModuleDefinitionTypes Property

Gets the collection of types defined in the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection Types { get; }
ReadOnly Property Types As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of types defined in the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.Variables Property

IModuleDefinitionVariables Property

Gets the collection of variables defined in the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IVariableDefinitionCollection Variables { get; }
ReadOnly Property Variables As IVariableDefinitionCollection
    Get

Property Value

Type: IVariableDefinitionCollection
The collection of variables defined in the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection Interface

Provides the base requirements for a collection of IModuleDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IModuleDefinitionCollection : IObservableCollection<IModuleDefinition>,
    IList<IModuleDefinition>, ICollection<IModuleDefinition>, IEnumerable<IModuleDefinition>,
    IEnumerable
Public Interface IModuleDefinitionCollection
    Inherits IObservableCollection(Of IModuleDefinition), IList(Of IModuleDefinition),
    ICollection(Of IModuleDefinition), IEnumerable(Of IModuleDefinition), IEnumerable

The IModuleDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IModuleDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the IModuleDefinition with the specified name. [C#] In C#, this property is the indexer for the IModuleDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IModuleDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IModuleDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IModuleDefinition .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IModuleDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IModuleDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IModuleDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIModuleDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIModuleDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIModuleDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection Properties

The IModuleDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IModuleDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the IModuleDefinition with the specified name. [C#] In C#, this property is the indexer for the IModuleDefinitionCollection interface.
Top
See Also

Reference

IModuleDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection.Item Property

IModuleDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the IModuleDefinition with the specified name. [C#] In C#, this property is the indexer for the IModuleDefinitionCollection interface.
Top
See Also

Reference

IModuleDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection.Item Property (String)

IModuleDefinitionCollectionItem Property (String)

Gets the IModuleDefinition with the specified name.

[C#] In C#, this property is the indexer for the IModuleDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IModuleDefinition this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As IModuleDefinition
    Get

Parameters

name
Type: SystemString
The name of the IModuleDefinition to return.

Property Value

Type: IModuleDefinition
The IModuleDefinition with the specified name.
See Also

Reference

IModuleDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection Methods

The IModuleDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IModuleDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IModuleDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IModuleDefinition .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IModuleDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IModuleDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IModuleDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IModuleDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIModuleDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIModuleDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIModuleDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IModuleDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection Events

The IModuleDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IModuleDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference Interface

Provides the base requirements of a module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IModuleReference : IReflectionDefinition
Public Interface IModuleReference
    Inherits IReflectionDefinition

The IModuleReference type exposes the following members.

Properties
 | Name | Description
Public property | IsBuiltin | Gets whether the module is built-in.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | PackagePath | Gets the file system path of the package that contains the module.
Public property | Path | Gets the full file system path to the module.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference Properties

The IModuleReference type exposes the following members.

Properties
 | Name | Description
Public property | IsBuiltin | Gets whether the module is built-in.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | PackagePath | Gets the file system path of the package that contains the module.
Public property | Path | Gets the full file system path to the module.
Top
See Also

Reference

IModuleReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference.IsBuiltin Property

IModuleReferenceIsBuiltin Property

Gets whether the module is built-in.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsBuiltin { get; }
ReadOnly Property IsBuiltin As Boolean
    Get

Property Value

Type: Boolean
true if the module is built-in; otherwise, false.
See Also

Reference

IModuleReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference.PackagePath Property

IModuleReferencePackagePath Property

Gets the file system path of the package that contains the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string PackagePath { get; }
ReadOnly Property PackagePath As String
    Get

Property Value

Type: String
The file system path of the package that contains the module.
See Also

Reference

IModuleReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference.Path Property

IModuleReferencePath Property

Gets the full file system path to the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Path { get; }
ReadOnly Property Path As String
    Get

Property Value

Type: String
The full file system path to the module.
See Also

Reference

IModuleReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition Interface

Provides the base requirements of a package definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPackageDefinition : IKeyedObject,
    IReflectionDefinition, IPackageReference
Public Interface IPackageDefinition
    Inherits IKeyedObject, IReflectionDefinition, IPackageReference

The IPackageDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ChildPackages | Gets the collection of child packages in the package.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Modules | Gets the collection of modules defined in the package.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Path | Gets the full file system path to the package. (Inherited from IPackageReference.)
Public property | Version | Gets the PythonVersion used to parse the package.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition Properties

The IPackageDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ChildPackages | Gets the collection of child packages in the package.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Modules | Gets the collection of modules defined in the package.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Path | Gets the full file system path to the package. (Inherited from IPackageReference.)
Public property | Version | Gets the PythonVersion used to parse the package.
Top
See Also

Reference

IPackageDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition.ChildPackages Property

IPackageDefinitionChildPackages Property

Gets the collection of child packages in the package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IPackageReferenceCollection ChildPackages { get; }
ReadOnly Property ChildPackages As IPackageReferenceCollection
    Get

Property Value

Type: IPackageReferenceCollection
The collection of child packages in the package.
See Also

Reference

IPackageDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition.Modules Property

IPackageDefinitionModules Property

Gets the collection of modules defined in the package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IModuleDefinitionCollection Modules { get; }
ReadOnly Property Modules As IModuleDefinitionCollection
    Get

Property Value

Type: IModuleDefinitionCollection
The collection of modules defined in the package.
See Also

Reference

IPackageDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition.Version Property

IPackageDefinitionVersion Property

Gets the PythonVersion used to parse the package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PythonVersion Version { get; }
ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion used to parse the package.
See Also

Reference

IPackageDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReference Interface

Provides the base requirements of a package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPackageReference : IReflectionDefinition
Public Interface IPackageReference
    Inherits IReflectionDefinition

The IPackageReference type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Path | Gets the full file system path to the package.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReference Properties

The IPackageReference type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Path | Gets the full file system path to the package.
Top
See Also

Reference

IPackageReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReference.Path Property

IPackageReferencePath Property

Gets the full file system path to the package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Path { get; }
ReadOnly Property Path As String
    Get

Property Value

Type: String
The full file system path to the package.
See Also

Reference

IPackageReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection Interface

Provides the base requirements for a collection of IPackageReference objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPackageReferenceCollection : IEnumerable,
    IObservableCollection<IPackageReference>, IList<IPackageReference>, ICollection<IPackageReference>,
    IEnumerable<IPackageReference>
Public Interface IPackageReferenceCollection
    Inherits IEnumerable, IObservableCollection(Of IPackageReference), IList(Of IPackageReference),
    ICollection(Of IPackageReference), IEnumerable(Of IPackageReference)

The IPackageReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IPackageReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IPackageReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IPackageReference .)
Public property | ItemString | Gets the IPackageReference with the specified name. [C#] In C#, this property is the indexer for the IPackageReferenceCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IPackageReference .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IPackageReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IPackageReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IPackageReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IPackageReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IPackageReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IPackageReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IPackageReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIPackageReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIPackageReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIPackageReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection Properties

The IPackageReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IPackageReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IPackageReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IPackageReference .)
Public property | ItemString | Gets the IPackageReference with the specified name. [C#] In C#, this property is the indexer for the IPackageReferenceCollection interface.
Top
See Also

Reference

IPackageReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection.Item Property

IPackageReferenceCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IPackageReference .)
Public property | ItemString | Gets the IPackageReference with the specified name. [C#] In C#, this property is the indexer for the IPackageReferenceCollection interface.
Top
See Also

Reference

IPackageReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection.Item Property (String)

IPackageReferenceCollectionItem Property (String)

Gets the IPackageReference with the specified name.

[C#] In C#, this property is the indexer for the IPackageReferenceCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IPackageReference this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As IPackageReference
    Get

Parameters

name
Type: SystemString
The name of the IPackageReference to return.

Property Value

Type: IPackageReference
The IPackageReference with the specified name.
See Also

Reference

IPackageReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection Methods

The IPackageReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IPackageReference .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IPackageReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IPackageReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IPackageReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IPackageReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IPackageReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IPackageReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IPackageReference .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIPackageReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIPackageReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIPackageReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IPackageReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection Events

The IPackageReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IPackageReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageRepository Interface

Provides the base requirements for a class that manages package instances and caching of data as appropriate.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPackageRepository
Public Interface IPackageRepository

The IPackageRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetPackageDefinition | Returns an IPackageDefinition based on cached package data, if it is available.
Public method | QueuePackageCacheUpdate | Queues a package cache update operation, optionally recursing into child packages.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageRepository Methods

The IPackageRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetPackageDefinition | Returns an IPackageDefinition based on cached package data, if it is available.
Public method | QueuePackageCacheUpdate | Queues a package cache update operation, optionally recursing into child packages.
Top
See Also

Reference

IPackageRepository Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageRepository.GetPackageDefinition Method

IPackageRepositoryGetPackageDefinition Method

Returns an IPackageDefinition based on cached package data, if it is available.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IPackageDefinition GetPackageDefinition(
    PythonVersion version,
    string path
)
Function GetPackageDefinition (
    version As PythonVersion,
    path As String
) As IPackageDefinition

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
path
Type: SystemString
The root package path to examine.

Return Value

Type: IPackageDefinition
The cached IPackageDefinition data.
See Also

Reference

IPackageRepository Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageRepository.QueuePackageCacheUpdate Method

IPackageRepositoryQueuePackageCacheUpdate Method

Queues a package cache update operation, optionally recursing into child packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void QueuePackageCacheUpdate(
    PythonVersion version,
    string path,
    bool isRootPath,
    bool recurse
)
Sub QueuePackageCacheUpdate (
    version As PythonVersion,
    path As String,
    isRootPath As Boolean,
    recurse As Boolean
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
path
Type: SystemString
The root package path to examine.
isRootPath
Type: SystemBoolean
Whether this is a root path.
recurse
Type: SystemBoolean
Whether to recurse into child packages.
See Also

Reference

IPackageRepository Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition Interface

Provides the base requirements of a parameter definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParameterDefinition : IReflectionDefinition
Public Interface IParameterDefinition
    Inherits IReflectionDefinition

The IParameterDefinition type exposes the following members.

Properties
 | Name | Description
Public property | IsDictionary | Gets whether this is a dictionary parameter.
Public property | IsOptional | Gets whether this is an optional parameter.
Public property | IsTuple | Gets whether this is a tuple parameter.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the parameter type, if known.
Public property | TypeExpressionTextRange | Gets the parameter type expression TextRange.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition Properties

The IParameterDefinition type exposes the following members.

Properties
 | Name | Description
Public property | IsDictionary | Gets whether this is a dictionary parameter.
Public property | IsOptional | Gets whether this is an optional parameter.
Public property | IsTuple | Gets whether this is a tuple parameter.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the parameter type, if known.
Public property | TypeExpressionTextRange | Gets the parameter type expression TextRange.
Top
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.IsDictionary Property

IParameterDefinitionIsDictionary Property

Gets whether this is a dictionary parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsDictionary { get; }
ReadOnly Property IsDictionary As Boolean
    Get

Property Value

Type: Boolean
true if this is a dictionary parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.IsOptional Property

IParameterDefinitionIsOptional Property

Gets whether this is an optional parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsOptional { get; }
ReadOnly Property IsOptional As Boolean
    Get

Property Value

Type: Boolean
true if this is an optional parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.IsTuple Property

IParameterDefinitionIsTuple Property

Gets whether this is a tuple parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsTuple { get; }
ReadOnly Property IsTuple As Boolean
    Get

Property Value

Type: Boolean
true if this is a tuple parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.Type Property

IParameterDefinitionType Property

Gets a ITypeDefinition indicating the parameter type, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition Type { get; }
ReadOnly Property Type As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the parameter type, if known.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.TypeExpressionTextRange Property

IParameterDefinitionTypeExpressionTextRange Property

Gets the parameter type expression TextRange.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange TypeExpressionTextRange { get; }
ReadOnly Property TypeExpressionTextRange As TextRange
    Get

Property Value

Type: TextRange
The parameter type expression TextRange.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection Interface

Provides the base requirements for a collection of IParameterDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParameterDefinitionCollection : IEnumerable,
    IObservableCollection<IParameterDefinition>, IList<IParameterDefinition>, ICollection<IParameterDefinition>,
    IEnumerable<IParameterDefinition>
Public Interface IParameterDefinitionCollection
    Inherits IEnumerable, IObservableCollection(Of IParameterDefinition), IList(Of IParameterDefinition),
    ICollection(Of IParameterDefinition), IEnumerable(Of IParameterDefinition)

The IParameterDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IParameterDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IParameterDefinition .)
Public property | ItemString | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IParameterDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IParameterDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IParameterDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IParameterDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IParameterDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIParameterDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIParameterDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIParameterDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection Properties

The IParameterDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IParameterDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IParameterDefinition .)
Public property | ItemString | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection.Item Property

IParameterDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IParameterDefinition .)
Public property | ItemString | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection.Item Property (String)

IParameterDefinitionCollectionItem Property (String)

Gets the IParameterDefinition with the specified name.

[C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParameterDefinition this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As IParameterDefinition
    Get

Parameters

name
Type: SystemString
The name of the IParameterDefinition to return.

Property Value

Type: IParameterDefinition
The IParameterDefinition with the specified name.
See Also

Reference

IParameterDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection Methods

The IParameterDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IParameterDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IParameterDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IParameterDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IParameterDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IParameterDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IParameterDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIParameterDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIParameterDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIParameterDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection Events

The IParameterDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject Interface

Represents a Python project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IProject
Public Interface IProject

The IProject type exposes the following members.

Properties
 | Name | Description
Public property | ActiveModules | Gets the collection of active modules in this project.
Public property | Resolver | Gets the IResolver to use for this project.
Public property | SearchPaths | Gets the list of paths (in priority order) to search when looking for packages.
Public property | Version | Gets the PythonVersion used to parse packages.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject Properties

The IProject type exposes the following members.

Properties
 | Name | Description
Public property | ActiveModules | Gets the collection of active modules in this project.
Public property | Resolver | Gets the IResolver to use for this project.
Public property | SearchPaths | Gets the list of paths (in priority order) to search when looking for packages.
Public property | Version | Gets the PythonVersion used to parse packages.
Top
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject.ActiveModules Property

IProjectActiveModules Property

Gets the collection of active modules in this project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IActiveModuleCollection ActiveModules { get; }
ReadOnly Property ActiveModules As IActiveModuleCollection
    Get

Property Value

Type: IActiveModuleCollection
The collection of active modules in this project.
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject.Resolver Property

IProjectResolver Property

Gets the IResolver to use for this project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IResolver Resolver { get; }
ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project.
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject.SearchPaths Property

IProjectSearchPaths Property

Gets the list of paths (in priority order) to search when looking for packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<string> SearchPaths { get; }
ReadOnly Property SearchPaths As IList(Of String)
    Get

Property Value

Type: IList String
The list of paths (in priority order) to search when looking for packages.
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject.Version Property

IProjectVersion Property

Gets the PythonVersion used to parse packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PythonVersion Version { get; }
ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion used to parse packages.
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IReflectionDefinition Interface

Provides the base requirements of a reflection definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IReflectionDefinition
Public Interface IReflectionDefinition

The IReflectionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IReflectionDefinition Properties

The IReflectionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name.
Top
See Also

Reference

IReflectionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IReflectionDefinition.Name Property

IReflectionDefinitionName Property

Gets the definition's name.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The definition's name.
See Also

Reference

IReflectionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition Interface

Provides the base requirements of a type definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeDefinition : IReflectionDefinition,
    ITypeReference
Public Interface ITypeDefinition
    Inherits IReflectionDefinition, ITypeReference

The ITypeDefinition type exposes the following members.

Properties
 | Name | Description
Public property | BaseTypes | Gets the collection of base type references.
Public property | DeclaringModule | Gets the reference to the module in which the type is declared. (Inherited from ITypeReference.)
Public property | Docstring | Gets the docstring for the type.
Public property | Fields | Gets the collection of fields defined in the type.
Public property | IsPublic | Gets whether the type is public.
Public property | Methods | Gets the collection of methods defined in the type.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | NestedTypes | Gets the collection of nested types defined in the type.
Public property | TextRange | Gets the TextRange of the type definition, if known.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition Properties

The ITypeDefinition type exposes the following members.

Properties
 | Name | Description
Public property | BaseTypes | Gets the collection of base type references.
Public property | DeclaringModule | Gets the reference to the module in which the type is declared. (Inherited from ITypeReference.)
Public property | Docstring | Gets the docstring for the type.
Public property | Fields | Gets the collection of fields defined in the type.
Public property | IsPublic | Gets whether the type is public.
Public property | Methods | Gets the collection of methods defined in the type.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | NestedTypes | Gets the collection of nested types defined in the type.
Public property | TextRange | Gets the TextRange of the type definition, if known.
Top
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.BaseTypes Property

ITypeDefinitionBaseTypes Property

Gets the collection of base type references.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReferenceCollection BaseTypes { get; }
ReadOnly Property BaseTypes As ITypeReferenceCollection
    Get

Property Value

Type: ITypeReferenceCollection
The collection of base type references.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.Docstring Property

ITypeDefinitionDocstring Property

Gets the docstring for the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Docstring { get; }
ReadOnly Property Docstring As String
    Get

Property Value

Type: String
The docstring for the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.Fields Property

ITypeDefinitionFields Property

Gets the collection of fields defined in the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IFieldDefinitionCollection Fields { get; }
ReadOnly Property Fields As IFieldDefinitionCollection
    Get

Property Value

Type: IFieldDefinitionCollection
The collection of fields defined in the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.IsPublic Property

ITypeDefinitionIsPublic Property

Gets whether the type is public.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsPublic { get; }
ReadOnly Property IsPublic As Boolean
    Get

Property Value

Type: Boolean
true if the type is public; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.Methods Property

ITypeDefinitionMethods Property

Gets the collection of methods defined in the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IFunctionDefinitionCollection Methods { get; }
ReadOnly Property Methods As IFunctionDefinitionCollection
    Get

Property Value

Type: IFunctionDefinitionCollection
The collection of methods defined in the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.NestedTypes Property

ITypeDefinitionNestedTypes Property

Gets the collection of nested types defined in the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection NestedTypes { get; }
ReadOnly Property NestedTypes As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of nested types defined in the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.TextRange Property

ITypeDefinitionTextRange Property

Gets the TextRange of the type definition, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange TextRange { get; }
ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
The TextRange of the type definition, if known.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection Interface

Provides the base requirements for a collection of ITypeDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeDefinitionCollection : IEnumerable,
    IObservableCollection<ITypeDefinition>, IList<ITypeDefinition>, ICollection<ITypeDefinition>,
    IEnumerable<ITypeDefinition>
Public Interface ITypeDefinitionCollection
    Inherits IEnumerable, IObservableCollection(Of ITypeDefinition), IList(Of ITypeDefinition),
    ICollection(Of ITypeDefinition), IEnumerable(Of ITypeDefinition)

The ITypeDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeDefinition .)
Public property | ItemString | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection Properties

The ITypeDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeDefinition .)
Public property | ItemString | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection.Item Property

ITypeDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeDefinition .)
Public property | ItemString | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection.Item Property (String)

ITypeDefinitionCollectionItem Property (String)

Gets the ITypeDefinition with the specified name.

[C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As ITypeDefinition
    Get

Parameters

name
Type: SystemString
The name of the ITypeDefinition to return.

Property Value

Type: ITypeDefinition
The ITypeDefinition with the specified name.
See Also

Reference

ITypeDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection Methods

The ITypeDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection Events

The ITypeDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReference Interface

Provides the base requirements of a type reference.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeReference : IReflectionDefinition
Public Interface ITypeReference
    Inherits IReflectionDefinition

The ITypeReference type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the type is declared.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReference Properties

The ITypeReference type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the type is declared.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Top
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReference.DeclaringModule Property

ITypeReferenceDeclaringModule Property

Gets the reference to the module in which the type is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IModuleReference DeclaringModule { get; }
ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the type is declared.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection Interface

Provides the base requirements for a collection of ITypeReference objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeReferenceCollection : IEnumerable,
    IObservableCollection<ITypeReference>, IList<ITypeReference>, ICollection<ITypeReference>,
    IEnumerable<ITypeReference>
Public Interface ITypeReferenceCollection
    Inherits IEnumerable, IObservableCollection(Of ITypeReference), IList(Of ITypeReference),
    ICollection(Of ITypeReference), IEnumerable(Of ITypeReference)

The ITypeReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeReference .)
Public property | ItemString | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection Properties

The ITypeReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ITypeReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ITypeReference .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeReference .)
Public property | ItemString | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection.Item Property

ITypeReferenceCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ITypeReference .)
Public property | ItemString | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection.Item Property (String)

ITypeReferenceCollectionItem Property (String)

Gets the ITypeReference with the specified name.

[C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeReference this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As ITypeReference
    Get

Parameters

name
Type: SystemString
The name of the ITypeReference to return.

Property Value

Type: ITypeReference
The ITypeReference with the specified name.
See Also

Reference

ITypeReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection Methods

The ITypeReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ITypeReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ITypeReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ITypeReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ITypeReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ITypeReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ITypeReference .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeITypeReference | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeITypeReference | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllITypeReference | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection Events

The ITypeReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition Interface

Provides the base requirements of a variable definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IVariableDefinition : IReflectionDefinition
Public Interface IVariableDefinition
    Inherits IReflectionDefinition

The IVariableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the variable is declared.
Public property | IsConstant | Gets whether the variable is a constant.
Public property | IsPublic | Gets whether the variable is public.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the variable type, if known.
Public property | TypeExpressionTextRange | Gets the variable type expression TextRange.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition Properties

The IVariableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the variable is declared.
Public property | IsConstant | Gets whether the variable is a constant.
Public property | IsPublic | Gets whether the variable is public.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the variable type, if known.
Public property | TypeExpressionTextRange | Gets the variable type expression TextRange.
Top
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.DeclaringModule Property

IVariableDefinitionDeclaringModule Property

Gets the reference to the module in which the variable is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IModuleReference DeclaringModule { get; }
ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the variable is declared.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.IsConstant Property

IVariableDefinitionIsConstant Property

Gets whether the variable is a constant.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsConstant { get; }
ReadOnly Property IsConstant As Boolean
    Get

Property Value

Type: Boolean
true if the variable is a constant; otherwise, false.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.IsPublic Property

IVariableDefinitionIsPublic Property

Gets whether the variable is public.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsPublic { get; }
ReadOnly Property IsPublic As Boolean
    Get

Property Value

Type: Boolean
true if the variable is public; otherwise, false.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.Type Property

IVariableDefinitionType Property

Gets a ITypeDefinition indicating the variable type, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition Type { get; }
ReadOnly Property Type As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the variable type, if known.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.TypeExpressionTextRange Property

IVariableDefinitionTypeExpressionTextRange Property

Gets the variable type expression TextRange.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange TypeExpressionTextRange { get; }
ReadOnly Property TypeExpressionTextRange As TextRange
    Get

Property Value

Type: TextRange
The variable type expression TextRange.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection Interface

Provides the base requirements for a collection of IVariableDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IVariableDefinitionCollection : IEnumerable,
    IObservableCollection<IVariableDefinition>, IList<IVariableDefinition>, ICollection<IVariableDefinition>,
    IEnumerable<IVariableDefinition>
Public Interface IVariableDefinitionCollection
    Inherits IEnumerable, IObservableCollection(Of IVariableDefinition), IList(Of IVariableDefinition),
    ICollection(Of IVariableDefinition), IEnumerable(Of IVariableDefinition)

The IVariableDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IVariableDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IVariableDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IVariableDefinition .)
Public property | ItemString | Gets the IVariableDefinition with the specified name. [C#] In C#, this property is the indexer for the IVariableDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IVariableDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IVariableDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IVariableDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IVariableDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IVariableDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IVariableDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IVariableDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IVariableDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIVariableDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIVariableDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIVariableDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection Properties

The IVariableDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IVariableDefinition .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IVariableDefinition .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IVariableDefinition .)
Public property | ItemString | Gets the IVariableDefinition with the specified name. [C#] In C#, this property is the indexer for the IVariableDefinitionCollection interface.
Top
See Also

Reference

IVariableDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection.Item Property

IVariableDefinitionCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList IVariableDefinition .)
Public property | ItemString | Gets the IVariableDefinition with the specified name. [C#] In C#, this property is the indexer for the IVariableDefinitionCollection interface.
Top
See Also

Reference

IVariableDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection.Item Property (String)

IVariableDefinitionCollectionItem Property (String)

Gets the IVariableDefinition with the specified name.

[C#] In C#, this property is the indexer for the IVariableDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IVariableDefinition this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As IVariableDefinition
    Get

Parameters

name
Type: SystemString
The name of the IVariableDefinition to return.

Property Value

Type: IVariableDefinition
The IVariableDefinition with the specified name.
See Also

Reference

IVariableDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection Methods

The IVariableDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IVariableDefinition .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IVariableDefinition .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IVariableDefinition .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IVariableDefinition .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IVariableDefinition .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IVariableDefinition .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IVariableDefinition .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IVariableDefinition .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIVariableDefinition | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIVariableDefinition | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIVariableDefinition | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IVariableDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection Events

The IVariableDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IVariableDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace

Contains the implementation types related to reflection for a Python syntax language.
Classes
 | Class | Description
Public class | FileBasedPackageRepository | Represents an IPackageRepository that can cache data in the file system.
Public class | Project | Represents a Python project.
Public class | TypeReference | Represents a type reference.


FileBasedPackageRepository Class

Represents an IPackageRepository that can cache data in the file system.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.Reflection.ImplementationFileBasedPackageRepository

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FileBasedPackageRepository : IPackageRepository
Public Class FileBasedPackageRepository
    Implements IPackageRepository

The FileBasedPackageRepository type exposes the following members.

Constructors
 | Name | Description
Public method | FileBasedPackageRepository | Initializes a new instance of the FileBasedPackageRepository class.
Top
Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to use for assembly and documentation cache files.
Top
Methods
 | Name | Description
Public method | GetPackageDefinition | Returns an IPackageDefinition based on cached package data, if it is available.
Public method | QueuePackageCacheUpdate | Queues a package cache update operation, optionally recursing into child packages.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository Constructor

Initializes a new instance of the FileBasedPackageRepository class.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FileBasedPackageRepository(
    string cachePath
)
Public Sub New (
    cachePath As String
)

Parameters

cachePath
Type: SystemString
The path to use for package cache files.
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository Properties

The FileBasedPackageRepository type exposes the following members.

Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to use for assembly and documentation cache files.
Top
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository.CachePath Property

FileBasedPackageRepositoryCachePath Property

Gets or sets the path to use for assembly and documentation cache files.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string CachePath { get; set; }
Public Property CachePath As String
    Get
    Set

Property Value

Type: String
The path to use for assembly and documentation cache files.
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository Methods

The FileBasedPackageRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetPackageDefinition | Returns an IPackageDefinition based on cached package data, if it is available.
Public method | QueuePackageCacheUpdate | Queues a package cache update operation, optionally recursing into child packages.
Top
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository.GetPackageDefinition Method

FileBasedPackageRepositoryGetPackageDefinition Method

Returns an IPackageDefinition based on cached package data, if it is available.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IPackageDefinition GetPackageDefinition(
    PythonVersion version,
    string path
)
Public Function GetPackageDefinition (
    version As PythonVersion,
    path As String
) As IPackageDefinition

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
path
Type: SystemString
The root package path to examine.

Return Value

Type: IPackageDefinition
The cached IPackageDefinition data.

Implements

IPackageRepositoryGetPackageDefinition(PythonVersion, String)
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository.QueuePackageCacheUpdate Method

FileBasedPackageRepositoryQueuePackageCacheUpdate Method

Queues a package cache update operation, optionally recursing into child packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void QueuePackageCacheUpdate(
    PythonVersion version,
    string path,
    bool isRootPath,
    bool recurse
)
Public Sub QueuePackageCacheUpdate (
    version As PythonVersion,
    path As String,
    isRootPath As Boolean,
    recurse As Boolean
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
path
Type: SystemString
The package path to examine.
isRootPath
Type: SystemBoolean
Whether this is a root path.
recurse
Type: SystemBoolean
Whether to recurse into child packages.

Implements

IPackageRepositoryQueuePackageCacheUpdate(PythonVersion, String, Boolean, Boolean)
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project Class

Represents a Python project.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.Reflection.ImplementationProject

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Project : IProject
Public Class Project
    Implements IProject

The Project type exposes the following members.

Constructors
 | Name | Description
Public method | Project | Initializes a new instance of the Project class.
Top
Properties
 | Name | Description
Public property | ActiveModules | Gets the collection of active modules in this project.
Public property | Resolver | Gets the IResolver to use for this project.
Public property | SearchPaths | Gets the list of paths (in priority order) to search when looking for packages.
Public property | Version | Gets the PythonVersion used to parse packages.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project Constructor

Initializes a new instance of the Project class.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Project(
    PythonVersion version
)
Public Sub New (
    version As PythonVersion
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project Properties

The Project type exposes the following members.

Properties
 | Name | Description
Public property | ActiveModules | Gets the collection of active modules in this project.
Public property | Resolver | Gets the IResolver to use for this project.
Public property | SearchPaths | Gets the list of paths (in priority order) to search when looking for packages.
Public property | Version | Gets the PythonVersion used to parse packages.
Top
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project.ActiveModules Property

ProjectActiveModules Property

Gets the collection of active modules in this project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IActiveModuleCollection ActiveModules { get; }
Public ReadOnly Property ActiveModules As IActiveModuleCollection
    Get

Property Value

Type: IActiveModuleCollection
The collection of active modules in this project.

Implements

IProjectActiveModules
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project.Resolver Property

ProjectResolver Property

Gets the IResolver to use for this project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IResolver Resolver { get; }
Public ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project.

Implements

IProjectResolver
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project.SearchPaths Property

ProjectSearchPaths Property

Gets the list of paths (in priority order) to search when looking for packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<string> SearchPaths { get; }
Public ReadOnly Property SearchPaths As IList(Of String)
    Get

Property Value

Type: IList String
The list of paths (in priority order) to search when looking for packages.

Implements

IProjectSearchPaths
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project.Version Property

ProjectVersion Property

Gets the PythonVersion used to parse packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; }
Public ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion used to parse packages.

Implements

IProjectVersion
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference Class

Represents a type reference.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.Reflection.ImplementationTypeReference

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TypeReference : IReflectionDefinition,
    ITypeReference
Public Class TypeReference
    Implements IReflectionDefinition, ITypeReference

The TypeReference type exposes the following members.

Constructors
 | Name | Description
Public method | TypeReference | Initializes a new instance of the TypeReference class.
Top
Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the type is declared.
Public property | Name | Gets the references's name.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference Constructor

Initializes a new instance of the TypeReference class.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TypeReference(
    string modulePath,
    string typeName
)
Public Sub New (
    modulePath As String,
    typeName As String
)

Parameters

modulePath
Type: SystemString
The path to the declaring module.
typeName
Type: SystemString
The type name.
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference Properties

The TypeReference type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the type is declared.
Public property | Name | Gets the references's name.
Top
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference.DeclaringModule Property

TypeReferenceDeclaringModule Property

Gets the reference to the module in which the type is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IModuleReference DeclaringModule { get; }
Public ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the type is declared.

Implements

ITypeReferenceDeclaringModule
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference.Name Property

TypeReferenceName Property

Gets the references's name.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The references's name.

Implements

IReflectionDefinitionName
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference Methods

The TypeReference type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference.ToString Method

TypeReferenceToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


ActiproSoftware.Text.Languages.Python.Resolution Namespace

Contains the types related to resolution for a Python syntax language.
Interfaces
 | Interface | Description
Public interface | IFieldResolverResult | Provides the base requirements of a field result from an IResolver resolution operation.
Public interface | IFunctionResolverResult | Provides the base requirements of a function result from an IResolver resolution operation.
Public interface | IModuleResolverResult | Provides the base requirements of a module result from an IResolver resolution operation.
Public interface | IPackageResolverResult | Provides the base requirements of a package result from an IResolver resolution operation.
Public interface | IParameterResolverResult | Provides the base requirements of a parameter result from an IResolver resolution operation.
Public interface | IResolver | Provides the base requirements of a Python language resolver.
Public interface | IResolverRequest | Provides the base requirements of a request for a Python language resolve operation.
Public interface | IResolverResult | Provides the base requirements of a single result from an IResolver resolution operation.
Public interface | IResolverResultCollection | Provides the base requirements for a collection of IResolverResult objects.
Public interface | IResolverResultSet | Provides the base requirements of a result set from an IResolver resolution operation.
Public interface | ITypeResolverResult | Provides the base requirements of a type result from an IResolver resolution operation.
Public interface | IVariableResolverResult | Provides the base requirements of a variable result from an IResolver resolution operation.
Enumerations
 | Enumeration | Description
Public enumeration | FunctionReferenceKind | Specifies the kind of function reference.
Public enumeration | ResolverResultKind | Specifies the kind of resolver result.


FunctionReferenceKind Enumeration

Specifies the kind of function reference.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum FunctionReferenceKind
Public Enumeration FunctionReferenceKind
Members
Member name | Value | Description
FunctionReference | 0 | A function reference.
FunctionInvocation | 1 | A function invocation.
MethodReference | 2 | A method reference, where the first argument is the target type instance.
MethodInvocation | 3 | A method invocation, where the first argument is the target type instance.
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFieldResolverResult Interface

Provides the base requirements of a field result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IFieldResolverResult : IResolverResult
Public Interface IFieldResolverResult
    Inherits IResolverResult

The IFieldResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets a IFieldDefinition indicating the field.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFieldResolverResult Properties

The IFieldResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets a IFieldDefinition indicating the field.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IFieldResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFieldResolverResult.Field Property

IFieldResolverResultField Property

Gets a IFieldDefinition indicating the field.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IFieldDefinition Field { get; }
ReadOnly Property Field As IFieldDefinition
    Get

Property Value

Type: IFieldDefinition
A IFieldDefinition indicating the field.
See Also

Reference

IFieldResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFieldResolverResult Methods

The IFieldResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IFieldResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult Interface

Provides the base requirements of a function result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IFunctionResolverResult : IResolverResult
Public Interface IFunctionResolverResult
    Inherits IResolverResult

The IFunctionResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Function | Gets a IFunctionDefinition indicating the function.
Public property | InvocationArguments | Gets the list of invocation arguments passed into the function.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | ReferenceKind | Gets a FunctionReferenceKind specifying the kind of reference.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult Properties

The IFunctionResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Function | Gets a IFunctionDefinition indicating the function.
Public property | InvocationArguments | Gets the list of invocation arguments passed into the function.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | ReferenceKind | Gets a FunctionReferenceKind specifying the kind of reference.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult.Function Property

IFunctionResolverResultFunction Property

Gets a IFunctionDefinition indicating the function.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IFunctionDefinition Function { get; }
ReadOnly Property Function As IFunctionDefinition
    Get

Property Value

Type: IFunctionDefinition
A IFunctionDefinition indicating the function.
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult.InvocationArguments Property

IFunctionResolverResultInvocationArguments Property

Gets the list of invocation arguments passed into the function.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<Argument> InvocationArguments { get; }
ReadOnly Property InvocationArguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The list of invocation arguments passed into the function.
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult.ReferenceKind Property

IFunctionResolverResultReferenceKind Property

Gets a FunctionReferenceKind specifying the kind of reference.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
FunctionReferenceKind ReferenceKind { get; }
ReadOnly Property ReferenceKind As FunctionReferenceKind
    Get

Property Value

Type: FunctionReferenceKind
A FunctionReferenceKind specifying the kind of reference.
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult Methods

The IFunctionResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult Interface

Provides the base requirements of a module result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IModuleResolverResult : IResolverResult
Public Interface IModuleResolverResult
    Inherits IResolverResult

The IModuleResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | FilterByPublicNames | Gets whether module members should be filtered by the module's public names (__all__).
Public property | IsWithinImportStatement | Gets whether the module is within an import statement.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Module | Gets a IModuleReference indicating the module.
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult Properties

The IModuleResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | FilterByPublicNames | Gets whether module members should be filtered by the module's public names (__all__).
Public property | IsWithinImportStatement | Gets whether the module is within an import statement.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Module | Gets a IModuleReference indicating the module.
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult.FilterByPublicNames Property

IModuleResolverResultFilterByPublicNames Property

Gets whether module members should be filtered by the module's public names (__all__).

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool FilterByPublicNames { get; }
ReadOnly Property FilterByPublicNames As Boolean
    Get

Property Value

Type: Boolean
true if module members should be filtered by the module's public names; otherwise, false.
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult.IsWithinImportStatement Property

IModuleResolverResultIsWithinImportStatement Property

Gets whether the module is within an import statement.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsWithinImportStatement { get; }
ReadOnly Property IsWithinImportStatement As Boolean
    Get

Property Value

Type: Boolean
true if the module is within an import statement; otherwise, false.
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult.Module Property

IModuleResolverResultModule Property

Gets a IModuleReference indicating the module.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IModuleReference Module { get; }
ReadOnly Property Module As IModuleReference
    Get

Property Value

Type: IModuleReference
A IModuleReference indicating the module.
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult Methods

The IModuleResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult Interface

Provides the base requirements of a package result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPackageResolverResult : IResolverResult
Public Interface IPackageResolverResult
    Inherits IResolverResult

The IPackageResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | FilterByPublicNames | Gets whether package members should be filtered by the package's public names (__all__).
Public property | IsWithinImportStatement | Gets whether the package is within an import statement.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Package | Gets a IPackageReference indicating the package.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult Properties

The IPackageResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | FilterByPublicNames | Gets whether package members should be filtered by the package's public names (__all__).
Public property | IsWithinImportStatement | Gets whether the package is within an import statement.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Package | Gets a IPackageReference indicating the package.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult.FilterByPublicNames Property

IPackageResolverResultFilterByPublicNames Property

Gets whether package members should be filtered by the package's public names (__all__).

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool FilterByPublicNames { get; }
ReadOnly Property FilterByPublicNames As Boolean
    Get

Property Value

Type: Boolean
true if package members should be filtered by the package's public names; otherwise, false.
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult.IsWithinImportStatement Property

IPackageResolverResultIsWithinImportStatement Property

Gets whether the package is within an import statement.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsWithinImportStatement { get; }
ReadOnly Property IsWithinImportStatement As Boolean
    Get

Property Value

Type: Boolean
true if the package is within an import statement; otherwise, false.
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult.Package Property

IPackageResolverResultPackage Property

Gets a IPackageReference indicating the package.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IPackageReference Package { get; }
ReadOnly Property Package As IPackageReference
    Get

Property Value

Type: IPackageReference
A IPackageReference indicating the package.
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult Methods

The IPackageResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IParameterResolverResult Interface

Provides the base requirements of a parameter result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParameterResolverResult : IResolverResult
Public Interface IParameterResolverResult
    Inherits IResolverResult

The IParameterResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Parameter | Gets a IParameterDefinition indicating the parameter.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IParameterResolverResult Properties

The IParameterResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Parameter | Gets a IParameterDefinition indicating the parameter.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IParameterResolverResult.Parameter Property

IParameterResolverResultParameter Property

Gets a IParameterDefinition indicating the parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParameterDefinition Parameter { get; }
ReadOnly Property Parameter As IParameterDefinition
    Get

Property Value

Type: IParameterDefinition
A IParameterDefinition indicating the parameter.
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IParameterResolverResult Methods

The IParameterResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver Interface

Provides the base requirements of a Python language resolver.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolver
Public Interface IResolver

The IResolver type exposes the following members.

Properties
 | Name | Description
Public property | MaximumImportRecursionLevel | Gets the maximum number of recursions that can be made when examining imports into other packages/modules.
Public property | Project | Gets the IProject for which this resolver was created.
Public property | UnknownReturnTypeReferenceCallback | Gets or sets a callback that is invoked when examining an IReflectionDefinition with an unknown return type.
Top
Methods
 | Name | Description
Public method | LoadAndResolveModule | Loads a module and attempts to resolve the return types of its members.
Public method | Resolve | Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver Properties

The IResolver type exposes the following members.

Properties
 | Name | Description
Public property | MaximumImportRecursionLevel | Gets the maximum number of recursions that can be made when examining imports into other packages/modules.
Public property | Project | Gets the IProject for which this resolver was created.
Public property | UnknownReturnTypeReferenceCallback | Gets or sets a callback that is invoked when examining an IReflectionDefinition with an unknown return type.
Top
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.MaximumImportRecursionLevel Property

IResolverMaximumImportRecursionLevel Property

Gets the maximum number of recursions that can be made when examining imports into other packages/modules.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int MaximumImportRecursionLevel { get; set; }
Property MaximumImportRecursionLevel As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of recursions that can be made when examining imports into other packages/modules. The default value is 10.
Remarks
Reducing this level can improve the time required to examine large packages that involve a lot import recursions, however it could also then lead to a subset of the real resolver results.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.Project Property

IResolverProject Property

Gets the IProject for which this resolver was created.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IProject Project { get; }
ReadOnly Property Project As IProject
    Get

Property Value

Type: IProject
The IProject for which this resolver was created.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.UnknownReturnTypeReferenceCallback Property

IResolverUnknownReturnTypeReferenceCallback Property

Gets or sets a callback that is invoked when examining an IReflectionDefinition with an unknown return type.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Func<IReflectionDefinition, ITypeReference> UnknownReturnTypeReferenceCallback { get; set; }
Property UnknownReturnTypeReferenceCallback As Func(Of IReflectionDefinition, ITypeReference)
    Get
    Set

Property Value

Type: Func IReflectionDefinition, ITypeReference
A callback that is invoked when examining an IReflectionDefinition with an unknown return type.
Remarks
Callback implementations should examine the IReflectionDefinition and return an appropriate ITypeReference that references the return type, if the return type is known.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver Methods

The IResolver type exposes the following members.

Methods
 | Name | Description
Public method | LoadAndResolveModule | Loads a module and attempts to resolve the return types of its members.
Public method | Resolve | Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.
Top
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.LoadAndResolveModule Method

IResolverLoadAndResolveModule Method

Loads a module and attempts to resolve the return types of its members.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IModuleDefinition LoadAndResolveModule(
    string path,
    CompilationUnit compUnit,
    bool allowExternalModuleLookup
)
Function LoadAndResolveModule (
    path As String,
    compUnit As CompilationUnit,
    allowExternalModuleLookup As Boolean
) As IModuleDefinition

Parameters

path
Type: SystemString
The path to the module file.
compUnit
Type: ActiproSoftware.Text.Languages.Python.Ast.ImplementationCompilationUnit
The CompilationUnit to examine.
allowExternalModuleLookup
Type: SystemBoolean
Whether external module lookup is allowed during resolution.

Return Value

Type: IModuleDefinition
The IModuleDefinition that was loaded.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.Resolve Method

IResolverResolve Method

Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IResolverResultSet Resolve(
    IResolverRequest request
)
Function Resolve (
    request As IResolverRequest
) As IResolverResultSet

Parameters

request
Type: ActiproSoftware.Text.Languages.Python.ResolutionIResolverRequest
The IResolverRequest to process.

Return Value

Type: IResolverResultSet
An IResolverResultSet containing the results.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverRequest Interface

Provides the base requirements of a request for a Python language resolve operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolverRequest
Public Interface IResolverRequest

The IResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets the IPythonContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverRequest Properties

The IResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets the IPythonContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverRequest.Context Property

IResolverRequestContext Property

Gets the IPythonContext in which the request is based, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IPythonContext Context { get; }
ReadOnly Property Context As IPythonContext
    Get

Property Value

Type: IPythonContext
The IPythonContext in which the request is based, if known.
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverRequest.Expression Property

IResolverRequestExpression Property

Gets the Expression to resolve.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Expression Expression { get; }
ReadOnly Property Expression As Expression
    Get

Property Value

Type: Expression
The Expression to resolve.
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult Interface

Provides the base requirements of a single result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolverResult
Public Interface IResolverResult

The IResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result.
Public property | Name | Gets a name identifying the result.
Public property | Type | Gets a ITypeDefinition indicating the type.
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type.
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult Properties

The IResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result.
Public property | Name | Gets a name identifying the result.
Public property | Type | Gets a ITypeDefinition indicating the type.
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type.
Top
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.Kind Property

IResolverResultKind Property

Gets the ResolverResultKind indicating the kind of resolver result.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ResolverResultKind Kind { get; }
ReadOnly Property Kind As ResolverResultKind
    Get

Property Value

Type: ResolverResultKind
The ResolverResultKind indicating the kind of resolver result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.Name Property

IResolverResultName Property

Gets a name identifying the result.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
A name identifying the result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.Type Property

IResolverResultType Property

Gets a ITypeDefinition indicating the type.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypeDefinition Type { get; }
ReadOnly Property Type As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the type.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.TypeIsInstance Property

IResolverResultTypeIsInstance Property

Gets whether the return Type reference designates an instance of the type.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool TypeIsInstance { get; }
ReadOnly Property TypeIsInstance As Boolean
    Get

Property Value

Type: Boolean
true if the return Type reference designates an instance of the type; otherwise, false indicating that the reference designates the static type.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult Methods

The IResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name.
Top
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.Clone Method

IResolverResultClone Method

Deep clones the resolver result using the specified alias as the name.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IResolverResult Clone(
    string alias
)
Function Clone (
    alias As String
) As IResolverResult

Parameters

alias
Type: SystemString
The alias.

Return Value

Type: IResolverResult
The cloned result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultCollection Interface

Provides the base requirements for a collection of IResolverResult objects.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolverResultCollection : IList<IResolverResult>,
    ICollection<IResolverResult>, IEnumerable<IResolverResult>, IEnumerable
Public Interface IResolverResultCollection
    Inherits IList(Of IResolverResult), ICollection(Of IResolverResult),
    IEnumerable(Of IResolverResult), IEnumerable

The IResolverResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IResolverResult .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IResolverResult .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IResolverResult .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IResolverResult .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IResolverResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IResolverResult .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IResolverResult .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IResolverResult .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IResolverResult .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIResolverResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIResolverResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIResolverResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace
ActiproSoftware.Text.Languages.Python.ResolutionIResolverResult


IResolverResultCollection Properties

The IResolverResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IResolverResult .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IResolverResult .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IResolverResult .)
Top
See Also

Reference

IResolverResultCollection Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultCollection Methods

The IResolverResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IResolverResult .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IResolverResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IResolverResult .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IResolverResult .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IResolverResult .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IResolverResult .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IResolverResult .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIResolverResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIResolverResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIResolverResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IResolverResultCollection Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultSet Interface

Provides the base requirements of a result set from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IResolverResultSet
Public Interface IResolverResultSet

The IResolverResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of results from the resolution operation.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultSet Properties

The IResolverResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of results from the resolution operation.
Top
See Also

Reference

IResolverResultSet Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultSet.Results Property

IResolverResultSetResults Property

Gets the collection of results from the resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IResolverResultCollection Results { get; }
ReadOnly Property Results As IResolverResultCollection
    Get

Property Value

Type: IResolverResultCollection
The collection of results from the resolution operation.
See Also

Reference

IResolverResultSet Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ITypeResolverResult Interface

Provides the base requirements of a type result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypeResolverResult : IResolverResult
Public Interface ITypeResolverResult
    Inherits IResolverResult

The ITypeResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


ITypeResolverResult Properties

The ITypeResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ITypeResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ITypeResolverResult Methods

The ITypeResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ITypeResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IVariableResolverResult Interface

Provides the base requirements of a variable result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IVariableResolverResult : IResolverResult
Public Interface IVariableResolverResult
    Inherits IResolverResult

The IVariableResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Public property | Variable | Gets a IVariableDefinition indicating the variable.
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IVariableResolverResult Properties

The IVariableResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Public property | Variable | Gets a IVariableDefinition indicating the variable.
Top
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IVariableResolverResult.Variable Property

IVariableResolverResultVariable Property

Gets a IVariableDefinition indicating the variable.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IVariableDefinition Variable { get; }
ReadOnly Property Variable As IVariableDefinition
    Get

Property Value

Type: IVariableDefinition
A IVariableDefinition indicating the variable.
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IVariableResolverResult Methods

The IVariableResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind Enumeration

Specifies the kind of resolver result.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ResolverResultKind
Public Enumeration ResolverResultKind
Members
Member name | Value | Description
Package | 0 | A package.
Module | 1 | A module.
Type | 2 | A type.
Field | 3 | A field.
Function | 4 | A function or method.
Parameter | 5 | A parameter.
Variable | 6 | A variable.
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace

Contains the implementation types related to resolution for a Python syntax language.
Classes
 | Class | Description
Public class | ResolverRequest | Represents a request for a Python language resolve operation.


ResolverRequest Class

Represents a request for a Python language resolve operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.Resolution.ImplementationResolverRequest

Namespace: ActiproSoftware.Text.Languages.Python.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ResolverRequest : IResolverRequest
Public Class ResolverRequest
    Implements IResolverRequest

The ResolverRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ResolverRequest | Initializes a new instance of the ResolverRequest class.
Top
Properties
 | Name | Description
Public property | Context | Gets or sets the IPythonContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ResolverRequest Constructor

Initializes a new instance of the ResolverRequest class.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ResolverRequest(
    Expression expression
)
Public Sub New (
    expression As Expression
)

Parameters

expression
Type: ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
The Expression to resolve.
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ResolverRequest Properties

The ResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets or sets the IPythonContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ResolverRequest.Context Property

ResolverRequestContext Property

Gets or sets the IPythonContext in which the request is based, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IPythonContext Context { get; set; }
Public Property Context As IPythonContext
    Get
    Set

Property Value

Type: IPythonContext
The IPythonContext in which the request is based, if known.

Implements

IResolverRequestContext
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ResolverRequest.Expression Property

ResolverRequestExpression Property

Gets the Expression to resolve.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution.Implementation
Assembly: ActiproSoftware.Text.Addons.Python.Wpf (in ActiproSoftware.Text.Addons.Python.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Expression Expression { get; }
Public ReadOnly Property Expression As Expression
    Get

Property Value

Type: Expression
The Expression to resolve.

Implements

IResolverRequestExpression
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ActiproSoftware.Text.Languages.VB Namespace

Contains the classes related to implementing a VB syntax language.
Classes
 | Class | Description
Public class | VBContextLocations | Contains common context locations for a Visual Basic language.
Interfaces
 | Interface | Description
Public interface | IVBGrammarOptions | Contains options for a Visual Basic grammar.


IVBGrammarOptions Interface

Contains options for a Visual Basic grammar.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IVBGrammarOptions
Public Interface IVBGrammarOptions

The IVBGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB Namespace


IVBGrammarOptions Properties

The IVBGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

IVBGrammarOptions Interface
ActiproSoftware.Text.Languages.VB Namespace


IVBGrammarOptions.RootNonTerminal Property

IVBGrammarOptionsRootNonTerminal Property

Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DotNetGrammarRootNonTerminal RootNonTerminal { get; }
ReadOnly Property RootNonTerminal As DotNetGrammarRootNonTerminal
    Get

Property Value

Type: DotNetGrammarRootNonTerminal
A DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

IVBGrammarOptions Interface
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations Class

Contains common context locations for a Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.VBVBContextLocations

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class VBContextLocations
Public NotInheritable Class VBContextLocations

The VBContextLocations type exposes the following members.

Properties
Name | Description
Attribute | Gets the IDotNetContextLocation that represents an attribute specification.
Comment | Gets the IDotNetContextLocation that represents a comment specification.
DocumentationComment | Gets the IDotNetContextLocation that represents a documentation comment specification.
ExpressionStart | Gets the IDotNetContextLocation that represents an expression start specification.
ImplicitLocalVariableType | Gets the IDotNetContextLocation that represents an implicit local variable type.
LiteralCharacter | Gets the IDotNetContextLocation that represents a literal character specification.
LiteralString | Gets the IDotNetContextLocation that represents a literal string specification.
ObjectCreationExpressionMemberName | Gets the IDotNetContextLocation that represents a member name target within an object creation expression.
ObjectCreationExpressionType | Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.
PreprocessorDirective | Gets the IDotNetContextLocation that represents a preprocessor directive specification.
Select | Gets the IDotNetContextLocation that represents an select specification.
Type | Gets the IDotNetContextLocation that represents a type name specification.
UsingDirectiveAliasedNamespaceOrType | Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.
UsingDirectiveNamespaceOrType | Gets the IDotNetContextLocation that represents a namespace/type specification within a using directive.
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations Properties

The VBContextLocations type exposes the following members.

Properties
Name | Description
Attribute | Gets the IDotNetContextLocation that represents an attribute specification.
Comment | Gets the IDotNetContextLocation that represents a comment specification.
DocumentationComment | Gets the IDotNetContextLocation that represents a documentation comment specification.
ExpressionStart | Gets the IDotNetContextLocation that represents an expression start specification.
ImplicitLocalVariableType | Gets the IDotNetContextLocation that represents an implicit local variable type.
LiteralCharacter | Gets the IDotNetContextLocation that represents a literal character specification.
LiteralString | Gets the IDotNetContextLocation that represents a literal string specification.
ObjectCreationExpressionMemberName | Gets the IDotNetContextLocation that represents a member name target within an object creation expression.
ObjectCreationExpressionType | Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.
PreprocessorDirective | Gets the IDotNetContextLocation that represents a preprocessor directive specification.
Select | Gets the IDotNetContextLocation that represents an select specification.
Type | Gets the IDotNetContextLocation that represents a type name specification.
UsingDirectiveAliasedNamespaceOrType | Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.
UsingDirectiveNamespaceOrType | Gets the IDotNetContextLocation that represents a namespace/type specification within a using directive.
Top
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.Attribute Property

VBContextLocationsAttribute Property

Gets the IDotNetContextLocation that represents an attribute specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Attribute { get; }
Public Shared ReadOnly Property Attribute As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.Comment Property

VBContextLocationsComment Property

Gets the IDotNetContextLocation that represents a comment specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Comment { get; }
Public Shared ReadOnly Property Comment As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.DocumentationComment Property

VBContextLocationsDocumentationComment Property

Gets the IDotNetContextLocation that represents a documentation comment specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation DocumentationComment { get; }
Public Shared ReadOnly Property DocumentationComment As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.ExpressionStart Property

VBContextLocationsExpressionStart Property

Gets the IDotNetContextLocation that represents an expression start specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ExpressionStart { get; }
Public Shared ReadOnly Property ExpressionStart As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.ImplicitLocalVariableType Property

VBContextLocationsImplicitLocalVariableType Property

Gets the IDotNetContextLocation that represents an implicit local variable type.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ImplicitLocalVariableType { get; }
Public Shared ReadOnly Property ImplicitLocalVariableType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.LiteralCharacter Property

VBContextLocationsLiteralCharacter Property

Gets the IDotNetContextLocation that represents a literal character specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LiteralCharacter { get; }
Public Shared ReadOnly Property LiteralCharacter As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.LiteralString Property

VBContextLocationsLiteralString Property

Gets the IDotNetContextLocation that represents a literal string specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LiteralString { get; }
Public Shared ReadOnly Property LiteralString As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.ObjectCreationExpressionMemberName Property

VBContextLocationsObjectCreationExpressionMemberName Property

Gets the IDotNetContextLocation that represents a member name target within an object creation expression.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ObjectCreationExpressionMemberName { get; }
Public Shared ReadOnly Property ObjectCreationExpressionMemberName As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.ObjectCreationExpressionType Property

VBContextLocationsObjectCreationExpressionType Property

Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ObjectCreationExpressionType { get; }
Public Shared ReadOnly Property ObjectCreationExpressionType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.PreprocessorDirective Property

VBContextLocationsPreprocessorDirective Property

Gets the IDotNetContextLocation that represents a preprocessor directive specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation PreprocessorDirective { get; }
Public Shared ReadOnly Property PreprocessorDirective As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.Select Property

VBContextLocationsSelect Property

Gets the IDotNetContextLocation that represents an select specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Select { get; }
Public Shared ReadOnly Property Select As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.Type Property

VBContextLocationsType Property

Gets the IDotNetContextLocation that represents a type name specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Type { get; }
Public Shared ReadOnly Property Type As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.UsingDirectiveAliasedNamespaceOrType Property

VBContextLocationsUsingDirectiveAliasedNamespaceOrType Property

Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation UsingDirectiveAliasedNamespaceOrType { get; }
Public Shared ReadOnly Property UsingDirectiveAliasedNamespaceOrType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.UsingDirectiveNamespaceOrType Property

VBContextLocationsUsingDirectiveNamespaceOrType Property

Gets the IDotNetContextLocation that represents a namespace/type specification within a using directive.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation UsingDirectiveNamespaceOrType { get; }
Public Shared ReadOnly Property UsingDirectiveNamespaceOrType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


ActiproSoftware.Text.Languages.VB.Implementation Namespace

Contains the core classes related to implementing a VB syntax language.
Classes
 | Class | Description
Public class | VBAutoCaseCorrector | Provides a Visual Basic language auto case-correction service.
Public class | VBCodeBlockFinder | Provides a Visual Basic language code block finder service.
Public class | VBCodeSnippetProvider | Provides a Visual Basic language code snippet provider that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.
Public class | VBCompletionProvider | Provides IntelliPrompt completion data for the Visual Basic language.
Public class | VBContextFactory | Creates Visual Basic language IDotNetContext objects for a TextSnapshotOffset.
Public class | VBDelimiterAutoCompleter | Provides a Visual Basic language delimiter auto-completer service.
Public class | VBDocumentationCommentAutoCompleter | Provides a class that can auto-complete Visual Basic language documentation comments when appropriate.
Public class | VBExampleTextProvider | Represents a example text provider for the VB language.
Public class | VBGrammar | Represents a Grammar for the Visual Basic language.
Public class | VBGrammarOptions | Contains options for a Visual Basic grammar.
Public class | VBIndentProvider | Provides a Visual Basic language indent provider service.
Public class | VBLexer | Represents a Visual Basic lexer (lexical analyzer) implementation.
Public class | VBLexicalStateId | Contains the lexical state IDs for the Visual Basic language.
Public class | VBNavigableSymbolProvider | Represents a navigable symbol provider for the Visual Basic language.
Public class | VBOutliner | Provides a Visual Basic language outliner service.
Public class | VBOutliningSource | Represents a Visual Basic language range-based outlining source.
Public class | VBParameterInfoProvider | Provides IntelliPrompt parameter info data for the Visual Basic language.
Public class | VBParser | Represents a parser for the Visual Basic language.
Public class | VBProjectAssembly | Represents a Visual Basic project (source code-based) assembly.
Public class | VBQuickInfoProvider | Provides IntelliPrompt quick info data for the Visual Basic language.
Public class | VBSyntaxLanguage | Represents a Visual Basic syntax language definition.
Public class | VBTextFormatter | Provides a Visual Basic language text formatter service.
Public class | VBTokenId | Contains the token IDs for the Visual Basic language.
Public class | VBTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the Visual Basic language.
Public class | VBTokenTagger | Represents an ITaggerT for the Visual Basic language.
Public class | VBTokenTaggerProvider | Represents a provider of VBTokenTagger objects for documents that use the VBTokenTagger language.


VBAutoCaseCorrector Class

Provides a Visual Basic language auto case-correction service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationAutoCorrectorBase
ActiproSoftware.Text.Analysis.ImplementationAutoCaseCorrector
ActiproSoftware.Text.Languages.VB.ImplementationVBAutoCaseCorrector

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBAutoCaseCorrector : AutoCaseCorrector
Public Class VBAutoCaseCorrector
    Inherits AutoCaseCorrector

The VBAutoCaseCorrector type exposes the following members.

Constructors
 | Name | Description
Public method | VBAutoCaseCorrector | Initializes a new instance of the VBAutoCaseCorrector class
Top
Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange. (Inherited from AutoCaseCorrector.)
Protected method | GetCaseCorrectText | Returns the case-corrected text for the specified IToken. (Overrides AutoCaseCorrectorGetCaseCorrectText(ITextSnapshot, IToken).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from AutoCorrectorBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBAutoCaseCorrector Constructor

Initializes a new instance of the VBAutoCaseCorrector class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBAutoCaseCorrector()
Public Sub New
See Also

Reference

VBAutoCaseCorrector Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBAutoCaseCorrector Methods

The VBAutoCaseCorrector type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange. (Inherited from AutoCaseCorrector.)
Protected method | GetCaseCorrectText | Returns the case-corrected text for the specified IToken. (Overrides AutoCaseCorrectorGetCaseCorrectText(ITextSnapshot, IToken).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from AutoCorrectorBase.)
Top
See Also

Reference

VBAutoCaseCorrector Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBAutoCaseCorrector.GetCaseCorrectText Method

VBAutoCaseCorrectorGetCaseCorrectText Method

Returns the case-corrected text for the specified IToken.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetCaseCorrectText(
    ITextSnapshot snapshot,
    IToken token
)
Protected Overrides Function GetCaseCorrectText (
    snapshot As ITextSnapshot,
    token As IToken
) As String

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The source ITextSnapshot.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: String
The case-corrected text for the specified IToken. Returns if no case-correction is required.
See Also

Reference

VBAutoCaseCorrector Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeBlockFinder Class

Provides a Visual Basic language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCodeBlockFinderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBCodeBlockFinder : DotNetCodeBlockFinderBase
Public Class VBCodeBlockFinder
    Inherits DotNetCodeBlockFinderBase

The VBCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | VBCodeBlockFinder | Initializes a new instance of the VBCodeBlockFinder class
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeBlockFinder Constructor

Initializes a new instance of the VBCodeBlockFinder class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBCodeBlockFinder()
Public Sub New
See Also

Reference

VBCodeBlockFinder Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeBlockFinder Properties

The VBCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

VBCodeBlockFinder Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeBlockFinder Methods

The VBCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

VBCodeBlockFinder Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider Class

Provides a Visual Basic language code snippet provider that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationCodeSnippetProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBCodeSnippetProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBCodeSnippetProvider : CodeSnippetProvider
Public Class VBCodeSnippetProvider
    Inherits CodeSnippetProvider

The VBCodeSnippetProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBCodeSnippetProvider | Initializes a new instance of the VBCodeSnippetProvider class.
Top
Properties
 | Name | Description
Public property | IsCaseSensitive | Gets or sets whether code snippet shortcut matching requires a case-sensitive match. (Inherited from CodeSnippetProvider.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CodeSnippetProvider.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CodeSnippetProvider.)
Public property | RootFolder | Gets or sets the root ICodeSnippetFolder containing code snippets that are accessible by this provider. (Inherited from CodeSnippetProvider.)
Top
Methods
 | Name | Description
Protected method | CheckForShortcut | Checks for a code snippet shortcut before the caret and opens a template session if one was found. (Inherited from CodeSnippetProvider.)
Protected method | CreateSelectionSession | Creates an ICodeSnippetSelectionSession for use with a RequestSelectionSession(IEditorView, CodeSnippetTypes) call. (Inherited from CodeSnippetProvider.)
Protected method | GetPossibleShortcutSnapshotRange | Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset. (Overrides CodeSnippetProviderGetPossibleShortcutSnapshotRange(TextSnapshotOffset).)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider Constructor

Initializes a new instance of the VBCodeSnippetProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBCodeSnippetProvider()
Public Sub New
See Also

Reference

VBCodeSnippetProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider Properties

The VBCodeSnippetProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsCaseSensitive | Gets or sets whether code snippet shortcut matching requires a case-sensitive match. (Inherited from CodeSnippetProvider.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CodeSnippetProvider.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CodeSnippetProvider.)
Public property | RootFolder | Gets or sets the root ICodeSnippetFolder containing code snippets that are accessible by this provider. (Inherited from CodeSnippetProvider.)
Top
See Also

Reference

VBCodeSnippetProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider Methods

The VBCodeSnippetProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CheckForShortcut | Checks for a code snippet shortcut before the caret and opens a template session if one was found. (Inherited from CodeSnippetProvider.)
Protected method | CreateSelectionSession | Creates an ICodeSnippetSelectionSession for use with a RequestSelectionSession(IEditorView, CodeSnippetTypes) call. (Inherited from CodeSnippetProvider.)
Protected method | GetPossibleShortcutSnapshotRange | Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset. (Overrides CodeSnippetProviderGetPossibleShortcutSnapshotRange(TextSnapshotOffset).)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Top
See Also

Reference

VBCodeSnippetProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider.GetPossibleShortcutSnapshotRange Method

VBCodeSnippetProviderGetPossibleShortcutSnapshotRange Method

Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override TextSnapshotRange GetPossibleShortcutSnapshotRange(
    TextSnapshotOffset snapshotOffset
)
Protected Overrides Function GetPossibleShortcutSnapshotRange (
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotRange

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange of the possible shortcut; or TextSnapshotRange.Deleted if there is no possible shortcut.
Remarks
Language implementations may wish to inherit this class and override this method to ensure the shortcut is not within a comment or other literal.
See Also

Reference

VBCodeSnippetProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider Class

Provides IntelliPrompt completion data for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCompletionProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBCompletionProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBCompletionProvider : DotNetCompletionProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class VBCompletionProvider
    Inherits DotNetCompletionProviderBase
    Implements IEditorDocumentTextChangeEventSink

The VBCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBCompletionProvider | Initializes a new instance of the VBCompletionProvider class.
Top
Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word. (Inherited from DotNetCompletionProviderBase.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetCompletionProviderBaseCreateContext(IEditorView).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetCompletionProviderBase.)
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location. (Overrides DotNetCompletionProviderBaseShouldShowForTypedWordStart(IEditorView).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider Constructor

Initializes a new instance of the VBCompletionProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBCompletionProvider()
Public Sub New
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider Properties

The VBCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word. (Inherited from DotNetCompletionProviderBase.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider Methods

The VBCompletionProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetCompletionProviderBaseCreateContext(IEditorView).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetCompletionProviderBase.)
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location. (Overrides DotNetCompletionProviderBaseShouldShowForTypedWordStart(IEditorView).)
Top
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.CreateContext Method

VBCompletionProviderCreateContext Method

Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IDotNetContext CreateContext(
    IEditorView view
)
Protected Overrides Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.OnDocumentTextChanged Method

VBCompletionProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.OnDocumentTextChanging Method

VBCompletionProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.RequestSession Method

VBCompletionProviderRequestSession Method

Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Public Overrides Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

ICompletionProviderRequestSession(IEditorView, Boolean)
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.ShouldShowForTypedWordStart Method

VBCompletionProviderShouldShowForTypedWordStart Method

Returns whether the specified IEditorView supports automatic completion list display at its current caret location.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ShouldShowForTypedWordStart(
    IEditorView view
)
Public Overrides Function ShouldShowForTypedWordStart (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if automatic completion list display is supported; otherwise, false.
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory Class

Creates Visual Basic language IDotNetContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetContextFactoryBase
ActiproSoftware.Text.Languages.VB.ImplementationVBContextFactory

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBContextFactory : DotNetContextFactoryBase
Public Class VBContextFactory
    Inherits DotNetContextFactoryBase

The VBContextFactory type exposes the following members.

Constructors
 | Name | Description
Public method | VBContextFactory | Initializes a new instance of the VBContextFactory class
Top
Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset. (Inherited from DotNetContextFactoryBase.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name. (Inherited from DotNetContextFactoryBase.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DotNetContextFactoryBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory Constructor

Initializes a new instance of the VBContextFactory class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBContextFactory()
Public Sub New
See Also

Reference

VBContextFactory Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory Methods

The VBContextFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset. (Inherited from DotNetContextFactoryBase.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name. (Inherited from DotNetContextFactoryBase.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DotNetContextFactoryBase.)
Top
See Also

Reference

VBContextFactory Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory.CreateContext Method

VBContextFactoryCreateContext Method

Overload List
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Top
See Also

Reference

VBContextFactory Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory.CreateContext Method (TextSnapshotOffset, DotNetContextKind)

VBContextFactoryCreateContext Method (TextSnapshotOffset, DotNetContextKind)

Creates an IDotNetContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IDotNetContext CreateContext(
    TextSnapshotOffset snapshotOffset,
    DotNetContextKind kind
)
Public Overrides Function CreateContext (
    snapshotOffset As TextSnapshotOffset,
    kind As DotNetContextKind
) As IDotNetContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.
kind
Type: ActiproSoftware.Text.Languages.DotNetDotNetContextKind
A DotNetContextKind indicating the kind of context.

Return Value

Type: IDotNetContext
The IDotNetContext that was created.
See Also

Reference

VBContextFactory Class
CreateContext Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDelimiterAutoCompleter Class

Provides a Visual Basic language delimiter auto-completer service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationDelimiterAutoCompleter
ActiproSoftware.Text.Languages.VB.ImplementationVBDelimiterAutoCompleter

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBDelimiterAutoCompleter : DelimiterAutoCompleter
Public Class VBDelimiterAutoCompleter
    Inherits DelimiterAutoCompleter

The VBDelimiterAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | VBDelimiterAutoCompleter | Initializes a new instance of the VBDelimiterAutoCompleter class.
Top
Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteDoubleQuotes | Gets or sets whether double quotes can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteSingleQuotes | Gets or sets whether single quotes can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenDoubleQuoteTokenId | Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenSingleQuoteTokenId | Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Top
Methods
 | Name | Description
Protected method | IsValidForEndDelimiterAutoComplete | Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset. (Inherited from DelimiterAutoCompleter.)
Protected method | IsValidStartDelimiter(ITextSnapshotReader, Char) | Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter. (Overrides DelimiterAutoCompleterIsValidStartDelimiter(ITextSnapshotReader, Char).)
Protected method | IsValidStartDelimiter(IToken, Char) | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterAutoCompleter.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterAutoCompleter.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterAutoCompleter.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DelimiterAutoCompleter.)
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView. (Inherited from DelimiterAutoCompleter.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDelimiterAutoCompleter Constructor

Initializes a new instance of the VBDelimiterAutoCompleter class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBDelimiterAutoCompleter()
Public Sub New
See Also

Reference

VBDelimiterAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDelimiterAutoCompleter Properties

The VBDelimiterAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteDoubleQuotes | Gets or sets whether double quotes can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteSingleQuotes | Gets or sets whether single quotes can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed. (Inherited from DelimiterAutoCompleter.)
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenDoubleQuoteTokenId | Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenSingleQuoteTokenId | Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion. (Inherited from DelimiterAutoCompleter.)
Top
See Also

Reference

VBDelimiterAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDelimiterAutoCompleter Methods

The VBDelimiterAutoCompleter type exposes the following members.

Methods
 | Name | Description
Protected method | IsValidForEndDelimiterAutoComplete | Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset. (Inherited from DelimiterAutoCompleter.)
Protected method | IsValidStartDelimiter(ITextSnapshotReader, Char) | Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter. (Overrides DelimiterAutoCompleterIsValidStartDelimiter(ITextSnapshotReader, Char).)
Protected method | IsValidStartDelimiter(IToken, Char) | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterAutoCompleter.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterAutoCompleter.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterAutoCompleter.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DelimiterAutoCompleter.)
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView. (Inherited from DelimiterAutoCompleter.)
Top
See Also

Reference

VBDelimiterAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDelimiterAutoCompleter.IsValidStartDelimiter Method

VBDelimiterAutoCompleterIsValidStartDelimiter Method

Overload List
 | Name | Description
Protected method | IsValidStartDelimiter(ITextSnapshotReader, Char) | Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter. (Overrides DelimiterAutoCompleterIsValidStartDelimiter(ITextSnapshotReader, Char).)
Protected method | IsValidStartDelimiter(IToken, Char) | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterAutoCompleter.)
Top
See Also

Reference

VBDelimiterAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDelimiterAutoCompleter.IsValidStartDelimiter Method (ITextSnapshotReader, Char)

VBDelimiterAutoCompleterIsValidStartDelimiter Method (ITextSnapshotReader, Char)

Returns whether an ITextSnapshotReader's current offset is immediately after the specified start delimiter.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidStartDelimiter(
    ITextSnapshotReader reader,
    char startDelimiter
)
Protected Overrides Function IsValidStartDelimiter (
    reader As ITextSnapshotReader,
    startDelimiter As Char
) As Boolean

Parameters

reader
Type: ActiproSoftware.TextITextSnapshotReader
The ITextSnapshotReader to examine.
startDelimiter
Type: SystemChar
The start delimiter.

Return Value

Type: Boolean
true if the ITextSnapshotReader's current offset is immediately after the specified start delimiter; otherwise, false.
See Also

Reference

VBDelimiterAutoCompleter Class
IsValidStartDelimiter Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter Class

Provides a class that can auto-complete Visual Basic language documentation comments when appropriate.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDocumentationCommentAutoCompleterBase
ActiproSoftware.Text.Languages.VB.ImplementationVBDocumentationCommentAutoCompleter

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBDocumentationCommentAutoCompleter : DocumentationCommentAutoCompleterBase,
    IEditorDocumentTextChangeEventSink
Public Class VBDocumentationCommentAutoCompleter
    Inherits DocumentationCommentAutoCompleterBase
    Implements IEditorDocumentTextChangeEventSink

The VBDocumentationCommentAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | VBDocumentationCommentAutoCompleter | Initializes a new instance of the VBDocumentationCommentAutoCompleter class
Top
Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
Methods
 | Name | Description
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location. (Inherited from DocumentationCommentAutoCompleterBase.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IDocumentationCommentAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter Constructor

Initializes a new instance of the VBDocumentationCommentAutoCompleter class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBDocumentationCommentAutoCompleter()
Public Sub New
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter Properties

The VBDocumentationCommentAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter Methods

The VBDocumentationCommentAutoCompleter type exposes the following members.

Methods
 | Name | Description
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location. (Inherited from DocumentationCommentAutoCompleterBase.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter.OnDocumentTextChanged Method

VBDocumentationCommentAutoCompleterOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter.OnDocumentTextChanging Method

VBDocumentationCommentAutoCompleterOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBExampleTextProvider Class

Represents a example text provider for the VB language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.VB.ImplementationVBExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBExampleTextProvider : IExampleTextProvider
Public Class VBExampleTextProvider
    Implements IExampleTextProvider

The VBExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBExampleTextProvider | Initializes a new instance of the VBExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Remarks
This type was generated by the Actipro Language Designer tool v10.2.530.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBExampleTextProvider Constructor

Initializes a new instance of the VBExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBExampleTextProvider()
Public Sub New
See Also

Reference

VBExampleTextProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBExampleTextProvider Properties

The VBExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

VBExampleTextProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBExampleTextProvider.ExampleText Property

VBExampleTextProviderExampleText Property

Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

VBExampleTextProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Class

Represents a Grammar for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarBase
ActiproSoftware.Text.Languages.VB.ImplementationVBGrammar

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBGrammar : DotNetGrammarBase
Public Class VBGrammar
    Inherits DotNetGrammarBase

The VBGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | VBGrammar | Initializes a new instance of the VBGrammar class.
Public method | VBGrammar(IVBGrammarOptions) | Initializes a new instance of the VBGrammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Constructor

Overload List
 | Name | Description
Public method | VBGrammar | Initializes a new instance of the VBGrammar class.
Public method | VBGrammar(IVBGrammarOptions) | Initializes a new instance of the VBGrammar class.
Top
See Also

Reference

VBGrammar Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Constructor

Initializes a new instance of the VBGrammar class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBGrammar()
Public Sub New
See Also

Reference

VBGrammar Class
VBGrammar Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Constructor (IVBGrammarOptions)

Initializes a new instance of the VBGrammar class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBGrammar(
    IVBGrammarOptions options
)
Public Sub New (
    options As IVBGrammarOptions
)

Parameters

options
Type: ActiproSoftware.Text.Languages.VBIVBGrammarOptions
An IVBGrammarOptions that contains options for the grammar.
See Also

Reference

VBGrammar Class
VBGrammar Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Properties

The VBGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

VBGrammar Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Methods

The VBGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

VBGrammar Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammarOptions Class

Contains options for a Visual Basic grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarOptionsBase
ActiproSoftware.Text.Languages.VB.ImplementationVBGrammarOptions

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBGrammarOptions : DotNetGrammarOptionsBase,
    IVBGrammarOptions
Public Class VBGrammarOptions
    Inherits DotNetGrammarOptionsBase
    Implements IVBGrammarOptions

The VBGrammarOptions type exposes the following members.

Constructors
 | Name | Description
Public method | VBGrammarOptions | Initializes a new instance of the VBGrammarOptions class
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. (Inherited from DotNetGrammarOptionsBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammarOptions Constructor

Initializes a new instance of the VBGrammarOptions class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBGrammarOptions()
Public Sub New
See Also

Reference

VBGrammarOptions Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammarOptions Properties

The VBGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. (Inherited from DotNetGrammarOptionsBase.)
Top
See Also

Reference

VBGrammarOptions Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider Class

Provides a Visual Basic language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.VB.ImplementationVBIndentProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBIndentProvider : IEditorDocumentTextChangeEventSink,
    IIndentProvider
Public Class VBIndentProvider
    Implements IEditorDocumentTextChangeEventSink, IIndentProvider

The VBIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBIndentProvider | Initializes a new instance of the VBIndentProvider class
Top
Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider Constructor

Initializes a new instance of the VBIndentProvider class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBIndentProvider()
Public Sub New
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider Properties

The VBIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider.Mode Property

VBIndentProviderMode Property

Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IndentMode Mode { get; }
Public ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider Methods

The VBIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Top
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider.GetIndentAmount Method

VBIndentProviderGetIndentAmount Method

Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider.OnDocumentTextChanged Method

VBIndentProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider.OnDocumentTextChanging Method

VBIndentProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Class

Represents a Visual Basic lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.VB.ImplementationVBLexer

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBLexer : MergableLexerBase
Public Class VBLexer
    Inherits MergableLexerBase

The VBLexer type exposes the following members.

Constructors
 | Name | Description
Public method | VBLexer | Initializes a new instance of the VBLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | IsKeyword | Returns whether the specified identifier is a keyword.
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Constructor

Initializes a new instance of the VBLexer class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBLexer()
Public Sub New
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Properties

The VBLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer.LexicalStates Property

VBLexerLexicalStates Property

Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Methods

The VBLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | IsKeyword | Returns whether the specified identifier is a keyword.
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer.GetAllLexicalStateTransitions Method

VBLexerGetAllLexicalStateTransitions Method

Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer.GetNextToken Method

VBLexerGetNextToken Method

Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating a lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer.IsKeyword Method

VBLexerIsKeyword Method

Returns whether the specified identifier is a keyword.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsKeyword(
    string identifier
)
Public Function IsKeyword (
    identifier As String
) As Boolean

Parameters

identifier
Type: SystemString
The identifier text.

Return Value

Type: Boolean
true if the specified identifier is a keyword; otherwise, false.
Remarks
This method does't return true for contextual keywords.
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Events

The VBLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Class

Contains the lexical state IDs for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBLexicalStateId

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBLexicalStateId : LexicalStateIdProviderBase
Public Class VBLexicalStateId
    Inherits LexicalStateIdProviderBase

The VBLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | VBLexicalStateId | Initializes a new instance of the VBLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
Fields
Name | Description
Default | Gets the Default lexical state ID.
DocumentationComment | Gets the DocumentationComment lexical state ID.
ImportsStatement | Gets the ImportsStatement lexical state ID.
PreprocessorDirective | Gets the PreprocessorDirective lexical state ID.
XmlNamespaceImportsClause | Gets the XmlNamespaceImportsClause lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.2.590.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Constructor

Initializes a new instance of the VBLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBLexicalStateId()
Public Sub New
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Properties

The VBLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.MaxId Property

VBLexicalStateIdMaxId Property

Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.MinId Property

VBLexicalStateIdMinId Property

Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Methods

The VBLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.ContainsId Method

VBLexicalStateIdContainsId Method

Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.GetDescription Method

VBLexicalStateIdGetDescription Method

Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.GetKey Method

VBLexicalStateIdGetKey Method

Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Fields

The VBLexicalStateId type exposes the following members.

Fields
Name | Description
Default | Gets the Default lexical state ID.
DocumentationComment | Gets the DocumentationComment lexical state ID.
ImportsStatement | Gets the ImportsStatement lexical state ID.
PreprocessorDirective | Gets the PreprocessorDirective lexical state ID.
XmlNamespaceImportsClause | Gets the XmlNamespaceImportsClause lexical state ID.
Top
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.Default Field

VBLexicalStateIdDefault Field

Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Default = 11000
Public Const Default As Integer = 11000

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.DocumentationComment Field

VBLexicalStateIdDocumentationComment Field

Gets the DocumentationComment lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentationComment = 11003
Public Const DocumentationComment As Integer = 11003

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.ImportsStatement Field

VBLexicalStateIdImportsStatement Field

Gets the ImportsStatement lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ImportsStatement = 11001
Public Const ImportsStatement As Integer = 11001

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.PreprocessorDirective Field

VBLexicalStateIdPreprocessorDirective Field

Gets the PreprocessorDirective lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirective = 11004
Public Const PreprocessorDirective As Integer = 11004

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.XmlNamespaceImportsClause Field

VBLexicalStateIdXmlNamespaceImportsClause Field

Gets the XmlNamespaceImportsClause lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int XmlNamespaceImportsClause = 11002
Public Const XmlNamespaceImportsClause As Integer = 11002

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider Class

Represents a navigable symbol provider for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetNavigableSymbolProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBNavigableSymbolProvider : DotNetNavigableSymbolProviderBase
Public Class VBNavigableSymbolProvider
    Inherits DotNetNavigableSymbolProviderBase

The VBNavigableSymbolProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBNavigableSymbolProvider | Initializes a new instance of the VBNavigableSymbolProvider class
Top
Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol(TypeMemberDeclaration, ITextSnapshot).)
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeSymbol(TypeDeclaration, ITextSnapshot).)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol. (Inherited from DotNetNavigableSymbolProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider Constructor

Initializes a new instance of the VBNavigableSymbolProvider class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBNavigableSymbolProvider()
Public Sub New
See Also

Reference

VBNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider Methods

The VBNavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol(TypeMemberDeclaration, ITextSnapshot).)
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeSymbol(TypeDeclaration, ITextSnapshot).)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol. (Inherited from DotNetNavigableSymbolProviderBase.)
Top
See Also

Reference

VBNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider.CreateTypeMemberSymbol Method

VBNavigableSymbolProviderCreateTypeMemberSymbol Method

Creates an INavigableSymbol for a TypeMemberDeclaration.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override INavigableSymbol CreateTypeMemberSymbol(
    TypeMemberDeclaration memberDecl,
    ITextSnapshot snapshot
)
Protected Overrides Function CreateTypeMemberSymbol (
    memberDecl As TypeMemberDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

memberDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
The TypeMemberDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

VBNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider.CreateTypeSymbol Method

VBNavigableSymbolProviderCreateTypeSymbol Method

Creates an INavigableSymbol for a TypeDeclaration.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override INavigableSymbol CreateTypeSymbol(
    TypeDeclaration typeDecl,
    ITextSnapshot snapshot
)
Protected Overrides Function CreateTypeSymbol (
    typeDecl As TypeDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

typeDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
The TypeDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

VBNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner Class

Provides a Visual Basic language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.VB.ImplementationVBOutliner

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBOutliner : IOutliner
Public Class VBOutliner
    Implements IOutliner

The VBOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | VBOutliner | Initializes a new instance of the VBOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner Constructor

Initializes a new instance of the VBOutliner class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBOutliner()
Public Sub New
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner Properties

The VBOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner.UpdateTrigger Property

VBOutlinerUpdateTrigger Property

Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner Methods

The VBOutliner type exposes the following members.

Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner.GetOutliningSource Method

VBOutlinerGetOutliningSource Method

Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource Class

Represents a Visual Basic language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.VB.ImplementationVBOutliningSource

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBOutliningSource : RangeOutliningSourceBase
Public Class VBOutliningSource
    Inherits RangeOutliningSourceBase

The VBOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | VBOutliningSource | Initializes a new instance of the VBOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource Constructor

Initializes a new instance of the VBOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

VBOutliningSource Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource Methods

The VBOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

VBOutliningSource Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource.AddNodesFromParseData Method

VBOutliningSourceAddNodesFromParseData Method

Overload List
 | Name | Description
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

VBOutliningSource Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource.AddNodesFromParseData Method (IDotNetParseData)

VBOutliningSourceAddNodesFromParseData Method (IDotNetParseData)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IDotNetParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IDotNetParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData containing AST data.
See Also

Reference

VBOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource.AddNodesFromParseData Method (IDotNetParseData, ITextBufferReader)

VBOutliningSourceAddNodesFromParseData Method (IDotNetParseData, ITextBufferReader)

Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IDotNetParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IDotNetParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

VBOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource.AddNodesRecursive Method

VBOutliningSourceAddNodesRecursive Method

Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

VBOutliningSource Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider Class

Provides IntelliPrompt parameter info data for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationParameterInfoProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParameterInfoProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBParameterInfoProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBParameterInfoProvider : DotNetParameterInfoProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class VBParameterInfoProvider
    Inherits DotNetParameterInfoProviderBase
    Implements IEditorDocumentTextChangeEventSink

The VBParameterInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBParameterInfoProvider | Initializes a new instance of the VBParameterInfoProvider class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetParameterInfoProviderBaseCreateContext(IEditorView).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetParameterInfoProviderBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DotNetParameterInfoProviderBase.)
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext. (Inherited from DotNetParameterInfoProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider Constructor

Initializes a new instance of the VBParameterInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBParameterInfoProvider()
Public Sub New
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider Properties

The VBParameterInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider Methods

The VBParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetParameterInfoProviderBaseCreateContext(IEditorView).)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetParameterInfoProviderBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DotNetParameterInfoProviderBase.)
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext. (Inherited from DotNetParameterInfoProviderBase.)
Top
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider.CreateContext Method

VBParameterInfoProviderCreateContext Method

Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IDotNetContext CreateContext(
    IEditorView view
)
Protected Overrides Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider.OnDocumentTextChanged Method

VBParameterInfoProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider.OnDocumentTextChanging Method

VBParameterInfoProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider.RequestSession Method

VBParameterInfoProviderRequestSession Method

Requests that an IParameterInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view
)
Public Overrides Function RequestSession (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

IParameterInfoProviderRequestSession(IEditorView)
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Class

Represents a parser for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParserBase
ActiproSoftware.Text.Languages.VB.ImplementationVBParser

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBParser : DotNetParserBase
Public Class VBParser
    Inherits DotNetParserBase

The VBParser type exposes the following members.

Constructors
 | Name | Description
Public method | VBParser | Initializes a new instance of the VBParser class.
Public method | VBParser(Grammar) | Initializes a new instance of the VBParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from DotNetParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Overrides LLParserBaseInitializeParseData(LLParseData, IParserState).)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Constructor

Overload List
 | Name | Description
Public method | VBParser | Initializes a new instance of the VBParser class.
Public method | VBParser(Grammar) | Initializes a new instance of the VBParser class.
Top
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Constructor

Initializes a new instance of the VBParser class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBParser()
Public Sub New
See Also

Reference

VBParser Class
VBParser Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Constructor (Grammar)

Initializes a new instance of the VBParser class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

VBParser Class
VBParser Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Properties

The VBParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Methods

The VBParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from DotNetParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Overrides LLParserBaseInitializeParseData(LLParseData, IParserState).)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Top
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser.CreateTokenReader Method

VBParserCreateTokenReader Method

Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser.InitializeParseData Method

VBParserInitializeParseData Method

Initializes a LLParseData using the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InitializeParseData(
    LLParseData parseData,
    IParserState state
)
Protected Overrides Sub InitializeParseData (
    parseData As LLParseData,
    state As IParserState
)

Parameters

parseData
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
The LLParseData to initialize.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.
Remarks
This method is called by default from the CreateParseData(IParseRequest, IParserState) method.
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser.InitializeParserState Method

VBParserInitializeParserState Method

Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser.ParseExpression Method

VBParserParseExpression Method

Parses the specified expression text.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IDotNetParseData ParseExpression(
    string text
)
Public Shared Function ParseExpression (
    text As String
) As IDotNetParseData

Parameters

text
Type: SystemString
The expression text to parse.

Return Value

Type: IDotNetParseData
The IDotNetParseData that contains the parse results.
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Class

Represents a Visual Basic project (source code-based) assembly.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationProjectAssembly
ActiproSoftware.Text.Languages.VB.ImplementationVBProjectAssembly

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBProjectAssembly : ProjectAssembly
Public Class VBProjectAssembly
    Inherits ProjectAssembly

The VBProjectAssembly type exposes the following members.

Constructors
 | Name | Description
Public method | VBProjectAssembly(String) | Initializes a new instance of the VBProjectAssembly class.
Public method | VBProjectAssembly(IAssemblyName) | Initializes a new instance of the VBProjectAssembly class.
Top
Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly. (Inherited from ProjectAssembly.)
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from ProjectAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from ProjectAssembly.)
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive. (Overrides ProjectAssemblyIsLanguageCaseSensitive.)
Public property | Name | Gets the simple name of the assembly. (Inherited from ProjectAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from ProjectAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly. (Overrides ProjectAssemblyResolver.)
Public property | SourceFiles | Gets the collection of source files in this project assembly. (Inherited from ProjectAssembly.)
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from ProjectAssembly.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ProjectAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from ProjectAssembly.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Constructor

Overload List
 | Name | Description
Public method | VBProjectAssembly(String) | Initializes a new instance of the VBProjectAssembly class.
Public method | VBProjectAssembly(IAssemblyName) | Initializes a new instance of the VBProjectAssembly class.
Top
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Constructor (String)

Initializes a new instance of the VBProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBProjectAssembly(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The simple name of the assembly.
See Also

Reference

VBProjectAssembly Class
VBProjectAssembly Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Constructor (IAssemblyName)

Initializes a new instance of the VBProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBProjectAssembly(
    IAssemblyName assemblyName
)
Public Sub New (
    assemblyName As IAssemblyName
)

Parameters

assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
An IAssemblyName that contains assembly name information.
See Also

Reference

VBProjectAssembly Class
VBProjectAssembly Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Properties

The VBProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly. (Inherited from ProjectAssembly.)
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from ProjectAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from ProjectAssembly.)
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive. (Overrides ProjectAssemblyIsLanguageCaseSensitive.)
Public property | Name | Gets the simple name of the assembly. (Inherited from ProjectAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from ProjectAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly. (Overrides ProjectAssemblyResolver.)
Public property | SourceFiles | Gets the collection of source files in this project assembly. (Inherited from ProjectAssembly.)
Top
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly.IsLanguageCaseSensitive Property

VBProjectAssemblyIsLanguageCaseSensitive Property

Gets whether the language associated with this project assembly is case-sensitive.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsLanguageCaseSensitive { get; }
Protected Overrides ReadOnly Property IsLanguageCaseSensitive As Boolean
    Get

Property Value

Type: Boolean
true if the language associated with this project assembly is case-sensitive; otherwise, false.
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly.Resolver Property

VBProjectAssemblyResolver Property

Gets the IResolver to use for this project assembly.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IResolver Resolver { get; }
Public Overrides ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project assembly.

Implements

IProjectAssemblyResolver
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Methods

The VBProjectAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from ProjectAssembly.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ProjectAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from ProjectAssembly.)
Top
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider Class

Provides IntelliPrompt quick info data for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationQuickInfoProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBQuickInfoProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBQuickInfoProvider : QuickInfoProviderBase
Public Class VBQuickInfoProvider
    Inherits QuickInfoProviderBase

The VBQuickInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBQuickInfoProvider | Initializes a new instance of the VBQuickInfoProvider class.
Top
Properties
 | Name | Description
Protected property | CanTrackPointerInput | Gets whether to track pointer input and allow pointer movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider Constructor

Initializes a new instance of the VBQuickInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBQuickInfoProvider()
Public Sub New
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider Properties

The VBQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Protected property | CanTrackPointerInput | Gets whether to track pointer input and allow pointer movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.ContextTypes Property

VBQuickInfoProviderContextTypes Property

Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerable<Type> ContextTypes { get; }
Protected Overrides ReadOnly Property ContextTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The context Type objects that are supported by this provider.
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider Methods

The VBQuickInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.GetContext Method

VBQuickInfoProviderGetContext Method

Overload List
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Top
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.GetContext Method (IEditorView, Int32)

VBQuickInfoProviderGetContext Method (IEditorView, Int32)

Returns an object describing the quick info context for the specified text offset, if any.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetContext(
    IEditorView view,
    int offset
)
Public Overrides Function GetContext (
    view As IEditorView,
    offset As Integer
) As Object

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView in which the offset is located.
offset
Type: SystemInt32
The text offset to examine.

Return Value

Type: Object
An object describing the quick info context for the specified text offset, if any. A value indicates that no context is available.

Implements

IQuickInfoProviderGetContext(IEditorView, Int32)
Remarks
This method is called in response to keyboard events.
See Also

Reference

VBQuickInfoProvider Class
GetContext Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.OnSessionOpening Method

VBQuickInfoProviderOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IQuickInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IQuickInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIQuickInfoSession
The IQuickInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.RequestSession Method

VBQuickInfoProviderRequestSession Method

Overload List
 | Name | Description
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.RequestSession Method (IEditorView, Object)

VBQuickInfoProviderRequestSession Method (IEditorView, Object)

Requests that an IQuickInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool RequestSession(
    IEditorView view,
    Object context
)
Protected Overrides Function RequestSession (
    view As IEditorView,
    context As Object
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
context
Type: SystemObject
A context object returned by GetContext(IEditorView, Int32).

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

VBQuickInfoProvider Class
RequestSession Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Class

Represents a Visual Basic syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetSyntaxLanguageBase
ActiproSoftware.Text.Languages.VB.ImplementationVBSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBSyntaxLanguage : DotNetSyntaxLanguageBase
Public Class VBSyntaxLanguage
    Inherits DotNetSyntaxLanguageBase

The VBSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | VBSyntaxLanguage | Initializes a new instance of the VBSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Constructor

Initializes a new instance of the VBSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBSyntaxLanguage()
Public Sub New
See Also

Reference

VBSyntaxLanguage Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Properties

The VBSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

VBSyntaxLanguage Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Methods

The VBSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

VBSyntaxLanguage Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Events

The VBSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

VBSyntaxLanguage Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter Class

Provides a Visual Basic language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetTextFormatterBase
ActiproSoftware.Text.Languages.VB.ImplementationVBTextFormatter

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBTextFormatter : DotNetTextFormatterBase
Public Class VBTextFormatter
    Inherits DotNetTextFormatterBase

The VBTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | VBTextFormatter | Initializes a new instance of the VBTextFormatter class
Top
Properties
 | Name | Description
Public property | OpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot. (Overrides DotNetTextFormatterBaseFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter Constructor

Initializes a new instance of the VBTextFormatter class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBTextFormatter()
Public Sub New
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter Properties

The VBTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | OpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter.OpeningBraceOnNewLine Property

VBTextFormatterOpeningBraceOnNewLine Property

Gets or sets a value indicating whether opening braces are on new lines.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool OpeningBraceOnNewLine { get; set; }
Public Property OpeningBraceOnNewLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the opening braces are on new lines; otherwise, false.
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter Methods

The VBTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot. (Overrides DotNetTextFormatterBaseFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode).)
Top
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter.Format Method

VBTextFormatterFormat Method

Applies text formatting to part or all of a snapshot.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf (in ActiproSoftware.SyntaxEditor.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Format(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection selectionPositionRanges,
    TextFormatMode mode = TextFormatMode.Ranges
)
Public Overrides Sub Format (
    snapshot As ITextSnapshot,
    selectionPositionRanges As ITextPositionRangeCollection,
    Optional mode As TextFormatMode = TextFormatMode.Ranges
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
selectionPositionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the selection position ranges. These are used to translate the current selection to the new snapshot that is created, even when formatting the entire snapshot.
mode (Optional)
Type: ActiproSoftware.TextTextFormatMode
A TextFormatMode indicating whether to format part or all of the snapshot. The default value is Ranges.

Implements

ITextFormatterFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode)
Remarks
The containing ITextDocument is accessible via the ITextSnapshot.
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Class

Contains the token IDs for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenId

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBTokenId : TokenIdProviderBase
Public Class VBTokenId
    Inherits TokenIdProviderBase

The VBTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | VBTokenId | Initializes a new instance of the VBTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPreprocessorKeywordClassificationType | Returns whether the specified ID value is part of the PreprocessorKeyword.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
 | IsVBXmlLiteralClassificationType | Returns whether the specified ID value is part of the VBXmlLiteral.
 | IsXmlDocumentationCommentClassificationType | Returns whether the specified ID value is part of the XmlDocumentationComment.
 | IsXmlDocumentationTagClassificationType | Returns whether the specified ID value is part of the XmlDocumentationTag.
Top
Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
ColonEquals | Gets the ColonEquals token ID.
Comma | Gets the Comma token ID.
CommentRem | Gets the CommentRem token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
ContextualKeywordAggregate | Gets the ContextualKeywordAggregate token ID.
ContextualKeywordAscending | Gets the ContextualKeywordAscending token ID.
ContextualKeywordAsync | Gets the ContextualKeywordAsync token ID.
ContextualKeywordAwait | Gets the ContextualKeywordAwait token ID.
ContextualKeywordBy | Gets the ContextualKeywordBy token ID.
ContextualKeywordCompare | Gets the ContextualKeywordCompare token ID.
ContextualKeywordCustom | Gets the ContextualKeywordCustom token ID.
ContextualKeywordDescending | Gets the ContextualKeywordDescending token ID.
ContextualKeywordDistinct | Gets the ContextualKeywordDistinct token ID.
ContextualKeywordEquals | Gets the ContextualKeywordEquals token ID.
ContextualKeywordExplicit | Gets the ContextualKeywordExplicit token ID.
ContextualKeywordFrom | Gets the ContextualKeywordFrom token ID.
ContextualKeywordGroup | Gets the ContextualKeywordGroup token ID.
ContextualKeywordIIf | Gets the ContextualKeywordIIf token ID.
ContextualKeywordInfer | Gets the ContextualKeywordInfer token ID.
ContextualKeywordInto | Gets the ContextualKeywordInto token ID.
ContextualKeywordIsFalse | Gets the ContextualKeywordIsFalse token ID.
ContextualKeywordIsTrue | Gets the ContextualKeywordIsTrue token ID.
ContextualKeywordIterator | Gets the ContextualKeywordIterator token ID.
ContextualKeywordJoin | Gets the ContextualKeywordJoin token ID.
ContextualKeywordMid | Gets the ContextualKeywordMid token ID.
ContextualKeywordOff | Gets the ContextualKeywordOff token ID.
ContextualKeywordOrder | Gets the ContextualKeywordOrder token ID.
ContextualKeywordOut | Gets the ContextualKeywordOut token ID.
ContextualKeywordSkip | Gets the ContextualKeywordSkip token ID.
ContextualKeywordStrict | Gets the ContextualKeywordStrict token ID.
ContextualKeywordTake | Gets the ContextualKeywordTake token ID.
ContextualKeywordWhere | Gets the ContextualKeywordWhere token ID.
ContextualKeywordYield | Gets the ContextualKeywordYield token ID.
DocumentationCommentDelimiter | Gets the DocumentationCommentDelimiter token ID.
DocumentationCommentTag | Gets the DocumentationCommentTag token ID.
DocumentationCommentText | Gets the DocumentationCommentText token ID.
Dot | Gets the Dot token ID.
DotAt | Gets the DotAt token ID.
ExclamationPoint | Gets the ExclamationPoint token ID.
Identifier | Gets the Identifier token ID.
KeywordAddHandler | Gets the KeywordAddHandler token ID.
KeywordAddressOf | Gets the KeywordAddressOf token ID.
KeywordAlias | Gets the KeywordAlias token ID.
KeywordAnd | Gets the KeywordAnd token ID.
KeywordAndAlso | Gets the KeywordAndAlso token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordBoolean | Gets the KeywordBoolean token ID.
KeywordByRef | Gets the KeywordByRef token ID.
KeywordByte | Gets the KeywordByte token ID.
KeywordByVal | Gets the KeywordByVal token ID.
KeywordCall | Gets the KeywordCall token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordCBool | Gets the KeywordCBool token ID.
KeywordCByte | Gets the KeywordCByte token ID.
KeywordCChar | Gets the KeywordCChar token ID.
KeywordCDate | Gets the KeywordCDate token ID.
KeywordCDbl | Gets the KeywordCDbl token ID.
KeywordCDec | Gets the KeywordCDec token ID.
KeywordChar | Gets the KeywordChar token ID.
KeywordCInt | Gets the KeywordCInt token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordCLng | Gets the KeywordCLng token ID.
KeywordCObj | Gets the KeywordCObj token ID.
KeywordConst | Gets the KeywordConst token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordCSByte | Gets the KeywordCSByte token ID.
KeywordCShort | Gets the KeywordCShort token ID.
KeywordCSng | Gets the KeywordCSng token ID.
KeywordCStr | Gets the KeywordCStr token ID.
KeywordCType | Gets the KeywordCType token ID.
KeywordCUInt | Gets the KeywordCUInt token ID.
KeywordCULng | Gets the KeywordCULng token ID.
KeywordCUShort | Gets the KeywordCUShort token ID.
KeywordDate | Gets the KeywordDate token ID.
KeywordDecimal | Gets the KeywordDecimal token ID.
KeywordDeclare | Gets the KeywordDeclare token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelegate | Gets the KeywordDelegate token ID.
KeywordDim | Gets the KeywordDim token ID.
KeywordDirectCast | Gets the KeywordDirectCast token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordDouble | Gets the KeywordDouble token ID.
KeywordEach | Gets the KeywordEach token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordElseIf | Gets the KeywordElseIf token ID.
KeywordEnd | Gets the KeywordEnd token ID.
KeywordEndIf | Gets the KeywordEndIf token ID.
KeywordEnum | Gets the KeywordEnum token ID.
KeywordErase | Gets the KeywordErase token ID.
KeywordError | Gets the KeywordError token ID.
KeywordEvent | Gets the KeywordEvent token ID.
KeywordExit | Gets the KeywordExit token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFriend | Gets the KeywordFriend token ID.
KeywordFunction | Gets the KeywordFunction token ID.
KeywordGet | Gets the KeywordGet token ID.
KeywordGetType | Gets the KeywordGetType token ID.
KeywordGetXmlNamespace | Gets the KeywordGetXmlNamespace token ID.
KeywordGlobal | Gets the KeywordGlobal token ID.
KeywordGoSub | Gets the KeywordGoSub token ID.
KeywordGoTo | Gets the KeywordGoTo token ID.
KeywordHandles | Gets the KeywordHandles token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImplements | Gets the KeywordImplements token ID.
KeywordImports | Gets the KeywordImports token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInherits | Gets the KeywordInherits token ID.
KeywordInteger | Gets the KeywordInteger token ID.
KeywordInterface | Gets the KeywordInterface token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordIsNot | Gets the KeywordIsNot token ID.
KeywordLet | Gets the KeywordLet token ID.
KeywordLib | Gets the KeywordLib token ID.
KeywordLike | Gets the KeywordLike token ID.
KeywordLong | Gets the KeywordLong token ID.
KeywordLoop | Gets the KeywordLoop token ID.
KeywordMe | Gets the KeywordMe token ID.
KeywordMod | Gets the KeywordMod token ID.
KeywordModule | Gets the KeywordModule token ID.
KeywordMustInherit | Gets the KeywordMustInherit token ID.
KeywordMustOverride | Gets the KeywordMustOverride token ID.
KeywordMyBase | Gets the KeywordMyBase token ID.
KeywordMyClass | Gets the KeywordMyClass token ID.
KeywordNameOf | Gets the KeywordNameOf token ID.
KeywordNamespace | Gets the KeywordNamespace token ID.
KeywordNarrowing | Gets the KeywordNarrowing token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNext | Gets the KeywordNext token ID.
KeywordNot | Gets the KeywordNot token ID.
KeywordNothing | Gets the KeywordNothing token ID.
KeywordNotInheritable | Gets the KeywordNotInheritable token ID.
KeywordNotOverridable | Gets the KeywordNotOverridable token ID.
KeywordObject | Gets the KeywordObject token ID.
KeywordOf | Gets the KeywordOf token ID.
KeywordOn | Gets the KeywordOn token ID.
KeywordOperator | Gets the KeywordOperator token ID.
KeywordOption | Gets the KeywordOption token ID.
KeywordOptional | Gets the KeywordOptional token ID.
KeywordOr | Gets the KeywordOr token ID.
KeywordOrElse | Gets the KeywordOrElse token ID.
KeywordOverloads | Gets the KeywordOverloads token ID.
KeywordOverridable | Gets the KeywordOverridable token ID.
KeywordOverrides | Gets the KeywordOverrides token ID.
KeywordParamArray | Gets the KeywordParamArray token ID.
KeywordPartial | Gets the KeywordPartial token ID.
KeywordPrivate | Gets the KeywordPrivate token ID.
KeywordProperty | Gets the KeywordProperty token ID.
KeywordProtected | Gets the KeywordProtected token ID.
KeywordPublic | Gets the KeywordPublic token ID.
KeywordRaiseEvent | Gets the KeywordRaiseEvent token ID.
KeywordReadOnly | Gets the KeywordReadOnly token ID.
KeywordReDim | Gets the KeywordReDim token ID.
KeywordREM | Gets the KeywordREM token ID.
KeywordRemoveHandler | Gets the KeywordRemoveHandler token ID.
KeywordResume | Gets the KeywordResume token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSByte | Gets the KeywordSByte token ID.
KeywordSelect | Gets the KeywordSelect token ID.
KeywordSet | Gets the KeywordSet token ID.
KeywordShadows | Gets the KeywordShadows token ID.
KeywordShared | Gets the KeywordShared token ID.
KeywordShort | Gets the KeywordShort token ID.
KeywordSingle | Gets the KeywordSingle token ID.
KeywordStatic | Gets the KeywordStatic token ID.
KeywordStep | Gets the KeywordStep token ID.
KeywordStop | Gets the KeywordStop token ID.
KeywordString | Gets the KeywordString token ID.
KeywordStructure | Gets the KeywordStructure token ID.
KeywordSub | Gets the KeywordSub token ID.
KeywordSyncLock | Gets the KeywordSyncLock token ID.
KeywordThen | Gets the KeywordThen token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTo | Gets the KeywordTo token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTryCast | Gets the KeywordTryCast token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordUInteger | Gets the KeywordUInteger token ID.
KeywordULong | Gets the KeywordULong token ID.
KeywordUntil | Gets the KeywordUntil token ID.
KeywordUShort | Gets the KeywordUShort token ID.
KeywordUsing | Gets the KeywordUsing token ID.
KeywordVariant | Gets the KeywordVariant token ID.
KeywordWend | Gets the KeywordWend token ID.
KeywordWhen | Gets the KeywordWhen token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWidening | Gets the KeywordWidening token ID.
KeywordWith | Gets the KeywordWith token ID.
KeywordWithEvents | Gets the KeywordWithEvents token ID.
KeywordWriteOnly | Gets the KeywordWriteOnly token ID.
KeywordXor | Gets the KeywordXor token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralCharacter | Gets the LiteralCharacter token ID.
LiteralDate | Gets the LiteralDate token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralFloatingPoint | Gets the LiteralFloatingPoint token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralInterpolatedString | Gets the LiteralInterpolatedString token ID.
LiteralOctalInteger | Gets the LiteralOctalInteger token ID.
LiteralString | Gets the LiteralString token ID.
LiteralXml | Gets the LiteralXml token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExponentiation | Gets the OperatorExponentiation token ID.
OperatorExponentiationAssignment | Gets the OperatorExponentiationAssignment token ID.
OperatorFloatingPointDivision | Gets the OperatorFloatingPointDivision token ID.
OperatorFloatingPointDivisionAssignment | Gets the OperatorFloatingPointDivisionAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorIntegerDivision | Gets the OperatorIntegerDivision token ID.
OperatorIntegerDivisionAssignment | Gets the OperatorIntegerDivisionAssignment token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorStringConcatenation | Gets the OperatorStringConcatenation token ID.
OperatorStringConcatenationAssignment | Gets the OperatorStringConcatenationAssignment token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
PreprocessorDirectiveKeywordConst | Gets the PreprocessorDirectiveKeywordConst token ID.
PreprocessorDirectiveKeywordDisableWarning | Gets the PreprocessorDirectiveKeywordDisableWarning token ID.
PreprocessorDirectiveKeywordElse | Gets the PreprocessorDirectiveKeywordElse token ID.
PreprocessorDirectiveKeywordElseIf | Gets the PreprocessorDirectiveKeywordElseIf token ID.
PreprocessorDirectiveKeywordEnableWarning | Gets the PreprocessorDirectiveKeywordEnableWarning token ID.
PreprocessorDirectiveKeywordEndExternalSource | Gets the PreprocessorDirectiveKeywordEndExternalSource token ID.
PreprocessorDirectiveKeywordEndIf | Gets the PreprocessorDirectiveKeywordEndIf token ID.
PreprocessorDirectiveKeywordEndRegion | Gets the PreprocessorDirectiveKeywordEndRegion token ID.
PreprocessorDirectiveKeywordExternalChecksum | Gets the PreprocessorDirectiveKeywordExternalChecksum token ID.
PreprocessorDirectiveKeywordExternalSource | Gets the PreprocessorDirectiveKeywordExternalSource token ID.
PreprocessorDirectiveKeywordIf | Gets the PreprocessorDirectiveKeywordIf token ID.
PreprocessorDirectiveKeywordRegion | Gets the PreprocessorDirectiveKeywordRegion token ID.
PreprocessorDirectiveText | Gets the PreprocessorDirectiveText token ID.
QuestionMark | Gets the QuestionMark token ID.
TripleDot | Gets the TripleDot token ID.
Whitespace | Gets the Whitespace token ID.
XmlAttribute | Gets the XmlAttribute token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v17.2.660.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Constructor

Initializes a new instance of the VBTokenId class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBTokenId()
Public Sub New
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Properties

The VBTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.MaxId Property

VBTokenIdMaxId Property

Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.MinId Property

VBTokenIdMinId Property

Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Methods

The VBTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPreprocessorKeywordClassificationType | Returns whether the specified ID value is part of the PreprocessorKeyword.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
 | IsVBXmlLiteralClassificationType | Returns whether the specified ID value is part of the VBXmlLiteral.
 | IsXmlDocumentationCommentClassificationType | Returns whether the specified ID value is part of the XmlDocumentationComment.
 | IsXmlDocumentationTagClassificationType | Returns whether the specified ID value is part of the XmlDocumentationTag.
Top
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContainsId Method

VBTokenIdContainsId Method

Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.GetDescription Method

VBTokenIdGetDescription Method

Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.GetKey Method

VBTokenIdGetKey Method

Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsCommentClassificationType Method

VBTokenIdIsCommentClassificationType Method

Returns whether the specified ID value is part of the Comment.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsCommentClassificationType(
    int id
)
Public Shared Function IsCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsIdentifierClassificationType Method

VBTokenIdIsIdentifierClassificationType Method

Returns whether the specified ID value is part of the Identifier.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsIdentifierClassificationType(
    int id
)
Public Shared Function IsIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsKeywordClassificationType Method

VBTokenIdIsKeywordClassificationType Method

Returns whether the specified ID value is part of the Keyword.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsKeywordClassificationType(
    int id
)
Public Shared Function IsKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsNumberClassificationType Method

VBTokenIdIsNumberClassificationType Method

Returns whether the specified ID value is part of the Number.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsNumberClassificationType(
    int id
)
Public Shared Function IsNumberClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsOperatorClassificationType Method

VBTokenIdIsOperatorClassificationType Method

Returns whether the specified ID value is part of the Operator.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsOperatorClassificationType(
    int id
)
Public Shared Function IsOperatorClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsPreprocessorKeywordClassificationType Method

VBTokenIdIsPreprocessorKeywordClassificationType Method

Returns whether the specified ID value is part of the PreprocessorKeyword.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsPreprocessorKeywordClassificationType(
    int id
)
Public Shared Function IsPreprocessorKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsStringClassificationType Method

VBTokenIdIsStringClassificationType Method

Returns whether the specified ID value is part of the String.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsStringClassificationType(
    int id
)
Public Shared Function IsStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsVBXmlLiteralClassificationType Method

VBTokenIdIsVBXmlLiteralClassificationType Method

Returns whether the specified ID value is part of the VBXmlLiteral.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsVBXmlLiteralClassificationType(
    int id
)
Public Shared Function IsVBXmlLiteralClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsXmlDocumentationCommentClassificationType Method

VBTokenIdIsXmlDocumentationCommentClassificationType Method

Returns whether the specified ID value is part of the XmlDocumentationComment.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlDocumentationCommentClassificationType(
    int id
)
Public Shared Function IsXmlDocumentationCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsXmlDocumentationTagClassificationType Method

VBTokenIdIsXmlDocumentationTagClassificationType Method

Returns whether the specified ID value is part of the XmlDocumentationTag.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlDocumentationTagClassificationType(
    int id
)
Public Shared Function IsXmlDocumentationTagClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Fields

The VBTokenId type exposes the following members.

Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
ColonEquals | Gets the ColonEquals token ID.
Comma | Gets the Comma token ID.
CommentRem | Gets the CommentRem token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
ContextualKeywordAggregate | Gets the ContextualKeywordAggregate token ID.
ContextualKeywordAscending | Gets the ContextualKeywordAscending token ID.
ContextualKeywordAsync | Gets the ContextualKeywordAsync token ID.
ContextualKeywordAwait | Gets the ContextualKeywordAwait token ID.
ContextualKeywordBy | Gets the ContextualKeywordBy token ID.
ContextualKeywordCompare | Gets the ContextualKeywordCompare token ID.
ContextualKeywordCustom | Gets the ContextualKeywordCustom token ID.
ContextualKeywordDescending | Gets the ContextualKeywordDescending token ID.
ContextualKeywordDistinct | Gets the ContextualKeywordDistinct token ID.
ContextualKeywordEquals | Gets the ContextualKeywordEquals token ID.
ContextualKeywordExplicit | Gets the ContextualKeywordExplicit token ID.
ContextualKeywordFrom | Gets the ContextualKeywordFrom token ID.
ContextualKeywordGroup | Gets the ContextualKeywordGroup token ID.
ContextualKeywordIIf | Gets the ContextualKeywordIIf token ID.
ContextualKeywordInfer | Gets the ContextualKeywordInfer token ID.
ContextualKeywordInto | Gets the ContextualKeywordInto token ID.
ContextualKeywordIsFalse | Gets the ContextualKeywordIsFalse token ID.
ContextualKeywordIsTrue | Gets the ContextualKeywordIsTrue token ID.
ContextualKeywordIterator | Gets the ContextualKeywordIterator token ID.
ContextualKeywordJoin | Gets the ContextualKeywordJoin token ID.
ContextualKeywordMid | Gets the ContextualKeywordMid token ID.
ContextualKeywordOff | Gets the ContextualKeywordOff token ID.
ContextualKeywordOrder | Gets the ContextualKeywordOrder token ID.
ContextualKeywordOut | Gets the ContextualKeywordOut token ID.
ContextualKeywordSkip | Gets the ContextualKeywordSkip token ID.
ContextualKeywordStrict | Gets the ContextualKeywordStrict token ID.
ContextualKeywordTake | Gets the ContextualKeywordTake token ID.
ContextualKeywordWhere | Gets the ContextualKeywordWhere token ID.
ContextualKeywordYield | Gets the ContextualKeywordYield token ID.
DocumentationCommentDelimiter | Gets the DocumentationCommentDelimiter token ID.
DocumentationCommentTag | Gets the DocumentationCommentTag token ID.
DocumentationCommentText | Gets the DocumentationCommentText token ID.
Dot | Gets the Dot token ID.
DotAt | Gets the DotAt token ID.
ExclamationPoint | Gets the ExclamationPoint token ID.
Identifier | Gets the Identifier token ID.
KeywordAddHandler | Gets the KeywordAddHandler token ID.
KeywordAddressOf | Gets the KeywordAddressOf token ID.
KeywordAlias | Gets the KeywordAlias token ID.
KeywordAnd | Gets the KeywordAnd token ID.
KeywordAndAlso | Gets the KeywordAndAlso token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordBoolean | Gets the KeywordBoolean token ID.
KeywordByRef | Gets the KeywordByRef token ID.
KeywordByte | Gets the KeywordByte token ID.
KeywordByVal | Gets the KeywordByVal token ID.
KeywordCall | Gets the KeywordCall token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordCBool | Gets the KeywordCBool token ID.
KeywordCByte | Gets the KeywordCByte token ID.
KeywordCChar | Gets the KeywordCChar token ID.
KeywordCDate | Gets the KeywordCDate token ID.
KeywordCDbl | Gets the KeywordCDbl token ID.
KeywordCDec | Gets the KeywordCDec token ID.
KeywordChar | Gets the KeywordChar token ID.
KeywordCInt | Gets the KeywordCInt token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordCLng | Gets the KeywordCLng token ID.
KeywordCObj | Gets the KeywordCObj token ID.
KeywordConst | Gets the KeywordConst token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordCSByte | Gets the KeywordCSByte token ID.
KeywordCShort | Gets the KeywordCShort token ID.
KeywordCSng | Gets the KeywordCSng token ID.
KeywordCStr | Gets the KeywordCStr token ID.
KeywordCType | Gets the KeywordCType token ID.
KeywordCUInt | Gets the KeywordCUInt token ID.
KeywordCULng | Gets the KeywordCULng token ID.
KeywordCUShort | Gets the KeywordCUShort token ID.
KeywordDate | Gets the KeywordDate token ID.
KeywordDecimal | Gets the KeywordDecimal token ID.
KeywordDeclare | Gets the KeywordDeclare token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelegate | Gets the KeywordDelegate token ID.
KeywordDim | Gets the KeywordDim token ID.
KeywordDirectCast | Gets the KeywordDirectCast token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordDouble | Gets the KeywordDouble token ID.
KeywordEach | Gets the KeywordEach token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordElseIf | Gets the KeywordElseIf token ID.
KeywordEnd | Gets the KeywordEnd token ID.
KeywordEndIf | Gets the KeywordEndIf token ID.
KeywordEnum | Gets the KeywordEnum token ID.
KeywordErase | Gets the KeywordErase token ID.
KeywordError | Gets the KeywordError token ID.
KeywordEvent | Gets the KeywordEvent token ID.
KeywordExit | Gets the KeywordExit token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFriend | Gets the KeywordFriend token ID.
KeywordFunction | Gets the KeywordFunction token ID.
KeywordGet | Gets the KeywordGet token ID.
KeywordGetType | Gets the KeywordGetType token ID.
KeywordGetXmlNamespace | Gets the KeywordGetXmlNamespace token ID.
KeywordGlobal | Gets the KeywordGlobal token ID.
KeywordGoSub | Gets the KeywordGoSub token ID.
KeywordGoTo | Gets the KeywordGoTo token ID.
KeywordHandles | Gets the KeywordHandles token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImplements | Gets the KeywordImplements token ID.
KeywordImports | Gets the KeywordImports token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInherits | Gets the KeywordInherits token ID.
KeywordInteger | Gets the KeywordInteger token ID.
KeywordInterface | Gets the KeywordInterface token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordIsNot | Gets the KeywordIsNot token ID.
KeywordLet | Gets the KeywordLet token ID.
KeywordLib | Gets the KeywordLib token ID.
KeywordLike | Gets the KeywordLike token ID.
KeywordLong | Gets the KeywordLong token ID.
KeywordLoop | Gets the KeywordLoop token ID.
KeywordMe | Gets the KeywordMe token ID.
KeywordMod | Gets the KeywordMod token ID.
KeywordModule | Gets the KeywordModule token ID.
KeywordMustInherit | Gets the KeywordMustInherit token ID.
KeywordMustOverride | Gets the KeywordMustOverride token ID.
KeywordMyBase | Gets the KeywordMyBase token ID.
KeywordMyClass | Gets the KeywordMyClass token ID.
KeywordNameOf | Gets the KeywordNameOf token ID.
KeywordNamespace | Gets the KeywordNamespace token ID.
KeywordNarrowing | Gets the KeywordNarrowing token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNext | Gets the KeywordNext token ID.
KeywordNot | Gets the KeywordNot token ID.
KeywordNothing | Gets the KeywordNothing token ID.
KeywordNotInheritable | Gets the KeywordNotInheritable token ID.
KeywordNotOverridable | Gets the KeywordNotOverridable token ID.
KeywordObject | Gets the KeywordObject token ID.
KeywordOf | Gets the KeywordOf token ID.
KeywordOn | Gets the KeywordOn token ID.
KeywordOperator | Gets the KeywordOperator token ID.
KeywordOption | Gets the KeywordOption token ID.
KeywordOptional | Gets the KeywordOptional token ID.
KeywordOr | Gets the KeywordOr token ID.
KeywordOrElse | Gets the KeywordOrElse token ID.
KeywordOverloads | Gets the KeywordOverloads token ID.
KeywordOverridable | Gets the KeywordOverridable token ID.
KeywordOverrides | Gets the KeywordOverrides token ID.
KeywordParamArray | Gets the KeywordParamArray token ID.
KeywordPartial | Gets the KeywordPartial token ID.
KeywordPrivate | Gets the KeywordPrivate token ID.
KeywordProperty | Gets the KeywordProperty token ID.
KeywordProtected | Gets the KeywordProtected token ID.
KeywordPublic | Gets the KeywordPublic token ID.
KeywordRaiseEvent | Gets the KeywordRaiseEvent token ID.
KeywordReadOnly | Gets the KeywordReadOnly token ID.
KeywordReDim | Gets the KeywordReDim token ID.
KeywordREM | Gets the KeywordREM token ID.
KeywordRemoveHandler | Gets the KeywordRemoveHandler token ID.
KeywordResume | Gets the KeywordResume token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSByte | Gets the KeywordSByte token ID.
KeywordSelect | Gets the KeywordSelect token ID.
KeywordSet | Gets the KeywordSet token ID.
KeywordShadows | Gets the KeywordShadows token ID.
KeywordShared | Gets the KeywordShared token ID.
KeywordShort | Gets the KeywordShort token ID.
KeywordSingle | Gets the KeywordSingle token ID.
KeywordStatic | Gets the KeywordStatic token ID.
KeywordStep | Gets the KeywordStep token ID.
KeywordStop | Gets the KeywordStop token ID.
KeywordString | Gets the KeywordString token ID.
KeywordStructure | Gets the KeywordStructure token ID.
KeywordSub | Gets the KeywordSub token ID.
KeywordSyncLock | Gets the KeywordSyncLock token ID.
KeywordThen | Gets the KeywordThen token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTo | Gets the KeywordTo token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTryCast | Gets the KeywordTryCast token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordUInteger | Gets the KeywordUInteger token ID.
KeywordULong | Gets the KeywordULong token ID.
KeywordUntil | Gets the KeywordUntil token ID.
KeywordUShort | Gets the KeywordUShort token ID.
KeywordUsing | Gets the KeywordUsing token ID.
KeywordVariant | Gets the KeywordVariant token ID.
KeywordWend | Gets the KeywordWend token ID.
KeywordWhen | Gets the KeywordWhen token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWidening | Gets the KeywordWidening token ID.
KeywordWith | Gets the KeywordWith token ID.
KeywordWithEvents | Gets the KeywordWithEvents token ID.
KeywordWriteOnly | Gets the KeywordWriteOnly token ID.
KeywordXor | Gets the KeywordXor token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralCharacter | Gets the LiteralCharacter token ID.
LiteralDate | Gets the LiteralDate token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralFloatingPoint | Gets the LiteralFloatingPoint token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralInterpolatedString | Gets the LiteralInterpolatedString token ID.
LiteralOctalInteger | Gets the LiteralOctalInteger token ID.
LiteralString | Gets the LiteralString token ID.
LiteralXml | Gets the LiteralXml token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExponentiation | Gets the OperatorExponentiation token ID.
OperatorExponentiationAssignment | Gets the OperatorExponentiationAssignment token ID.
OperatorFloatingPointDivision | Gets the OperatorFloatingPointDivision token ID.
OperatorFloatingPointDivisionAssignment | Gets the OperatorFloatingPointDivisionAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorIntegerDivision | Gets the OperatorIntegerDivision token ID.
OperatorIntegerDivisionAssignment | Gets the OperatorIntegerDivisionAssignment token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorStringConcatenation | Gets the OperatorStringConcatenation token ID.
OperatorStringConcatenationAssignment | Gets the OperatorStringConcatenationAssignment token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
PreprocessorDirectiveKeywordConst | Gets the PreprocessorDirectiveKeywordConst token ID.
PreprocessorDirectiveKeywordDisableWarning | Gets the PreprocessorDirectiveKeywordDisableWarning token ID.
PreprocessorDirectiveKeywordElse | Gets the PreprocessorDirectiveKeywordElse token ID.
PreprocessorDirectiveKeywordElseIf | Gets the PreprocessorDirectiveKeywordElseIf token ID.
PreprocessorDirectiveKeywordEnableWarning | Gets the PreprocessorDirectiveKeywordEnableWarning token ID.
PreprocessorDirectiveKeywordEndExternalSource | Gets the PreprocessorDirectiveKeywordEndExternalSource token ID.
PreprocessorDirectiveKeywordEndIf | Gets the PreprocessorDirectiveKeywordEndIf token ID.
PreprocessorDirectiveKeywordEndRegion | Gets the PreprocessorDirectiveKeywordEndRegion token ID.
PreprocessorDirectiveKeywordExternalChecksum | Gets the PreprocessorDirectiveKeywordExternalChecksum token ID.
PreprocessorDirectiveKeywordExternalSource | Gets the PreprocessorDirectiveKeywordExternalSource token ID.
PreprocessorDirectiveKeywordIf | Gets the PreprocessorDirectiveKeywordIf token ID.
PreprocessorDirectiveKeywordRegion | Gets the PreprocessorDirectiveKeywordRegion token ID.
PreprocessorDirectiveText | Gets the PreprocessorDirectiveText token ID.
QuestionMark | Gets the QuestionMark token ID.
TripleDot | Gets the TripleDot token ID.
Whitespace | Gets the Whitespace token ID.
XmlAttribute | Gets the XmlAttribute token ID.
Top
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CloseCurlyBrace Field

VBTokenIdCloseCurlyBrace Field

Gets the CloseCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseCurlyBrace = 11006
Public Const CloseCurlyBrace As Integer = 11006

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CloseParenthesis Field

VBTokenIdCloseParenthesis Field

Gets the CloseParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseParenthesis = 11004
Public Const CloseParenthesis As Integer = 11004

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CloseSquareBrace Field

VBTokenIdCloseSquareBrace Field

Gets the CloseSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CloseSquareBrace = 11008
Public Const CloseSquareBrace As Integer = 11008

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Colon Field

VBTokenIdColon Field

Gets the Colon token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Colon = 11011
Public Const Colon As Integer = 11011

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ColonEquals Field

VBTokenIdColonEquals Field

Gets the ColonEquals token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ColonEquals = 11012
Public Const ColonEquals As Integer = 11012

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Comma Field

VBTokenIdComma Field

Gets the Comma token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Comma = 11009
Public Const Comma As Integer = 11009

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CommentRem Field

VBTokenIdCommentRem Field

Gets the CommentRem token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentRem = 11018
Public Const CommentRem As Integer = 11018

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CommentSingleLine Field

VBTokenIdCommentSingleLine Field

Gets the CommentSingleLine token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentSingleLine = 11017
Public Const CommentSingleLine As Integer = 11017

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordAggregate Field

VBTokenIdContextualKeywordAggregate Field

Gets the ContextualKeywordAggregate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAggregate = 11033
Public Const ContextualKeywordAggregate As Integer = 11033

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordAscending Field

VBTokenIdContextualKeywordAscending Field

Gets the ContextualKeywordAscending token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAscending = 11034
Public Const ContextualKeywordAscending As Integer = 11034

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordAsync Field

VBTokenIdContextualKeywordAsync Field

Gets the ContextualKeywordAsync token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAsync = 11035
Public Const ContextualKeywordAsync As Integer = 11035

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordAwait Field

VBTokenIdContextualKeywordAwait Field

Gets the ContextualKeywordAwait token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAwait = 11036
Public Const ContextualKeywordAwait As Integer = 11036

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordBy Field

VBTokenIdContextualKeywordBy Field

Gets the ContextualKeywordBy token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordBy = 11037
Public Const ContextualKeywordBy As Integer = 11037

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordCompare Field

VBTokenIdContextualKeywordCompare Field

Gets the ContextualKeywordCompare token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordCompare = 11038
Public Const ContextualKeywordCompare As Integer = 11038

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordCustom Field

VBTokenIdContextualKeywordCustom Field

Gets the ContextualKeywordCustom token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordCustom = 11039
Public Const ContextualKeywordCustom As Integer = 11039

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordDescending Field

VBTokenIdContextualKeywordDescending Field

Gets the ContextualKeywordDescending token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordDescending = 11040
Public Const ContextualKeywordDescending As Integer = 11040

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordDistinct Field

VBTokenIdContextualKeywordDistinct Field

Gets the ContextualKeywordDistinct token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordDistinct = 11041
Public Const ContextualKeywordDistinct As Integer = 11041

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordEquals Field

VBTokenIdContextualKeywordEquals Field

Gets the ContextualKeywordEquals token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordEquals = 11042
Public Const ContextualKeywordEquals As Integer = 11042

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordExplicit Field

VBTokenIdContextualKeywordExplicit Field

Gets the ContextualKeywordExplicit token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordExplicit = 11043
Public Const ContextualKeywordExplicit As Integer = 11043

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordFrom Field

VBTokenIdContextualKeywordFrom Field

Gets the ContextualKeywordFrom token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordFrom = 11044
Public Const ContextualKeywordFrom As Integer = 11044

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordGroup Field

VBTokenIdContextualKeywordGroup Field

Gets the ContextualKeywordGroup token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordGroup = 11045
Public Const ContextualKeywordGroup As Integer = 11045

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordIIf Field

VBTokenIdContextualKeywordIIf Field

Gets the ContextualKeywordIIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordIIf = 11046
Public Const ContextualKeywordIIf As Integer = 11046

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordInfer Field

VBTokenIdContextualKeywordInfer Field

Gets the ContextualKeywordInfer token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordInfer = 11047
Public Const ContextualKeywordInfer As Integer = 11047

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordInto Field

VBTokenIdContextualKeywordInto Field

Gets the ContextualKeywordInto token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordInto = 11048
Public Const ContextualKeywordInto As Integer = 11048

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordIsFalse Field

VBTokenIdContextualKeywordIsFalse Field

Gets the ContextualKeywordIsFalse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordIsFalse = 11049
Public Const ContextualKeywordIsFalse As Integer = 11049

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordIsTrue Field

VBTokenIdContextualKeywordIsTrue Field

Gets the ContextualKeywordIsTrue token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordIsTrue = 11050
Public Const ContextualKeywordIsTrue As Integer = 11050

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordIterator Field

VBTokenIdContextualKeywordIterator Field

Gets the ContextualKeywordIterator token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordIterator = 11051
Public Const ContextualKeywordIterator As Integer = 11051

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordJoin Field

VBTokenIdContextualKeywordJoin Field

Gets the ContextualKeywordJoin token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordJoin = 11052
Public Const ContextualKeywordJoin As Integer = 11052

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordMid Field

VBTokenIdContextualKeywordMid Field

Gets the ContextualKeywordMid token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordMid = 11053
Public Const ContextualKeywordMid As Integer = 11053

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordOff Field

VBTokenIdContextualKeywordOff Field

Gets the ContextualKeywordOff token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordOff = 11054
Public Const ContextualKeywordOff As Integer = 11054

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordOrder Field

VBTokenIdContextualKeywordOrder Field

Gets the ContextualKeywordOrder token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordOrder = 11055
Public Const ContextualKeywordOrder As Integer = 11055

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordOut Field

VBTokenIdContextualKeywordOut Field

Gets the ContextualKeywordOut token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordOut = 11056
Public Const ContextualKeywordOut As Integer = 11056

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordSkip Field

VBTokenIdContextualKeywordSkip Field

Gets the ContextualKeywordSkip token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordSkip = 11057
Public Const ContextualKeywordSkip As Integer = 11057

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordStrict Field

VBTokenIdContextualKeywordStrict Field

Gets the ContextualKeywordStrict token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordStrict = 11058
Public Const ContextualKeywordStrict As Integer = 11058

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordTake Field

VBTokenIdContextualKeywordTake Field

Gets the ContextualKeywordTake token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordTake = 11059
Public Const ContextualKeywordTake As Integer = 11059

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordWhere Field

VBTokenIdContextualKeywordWhere Field

Gets the ContextualKeywordWhere token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordWhere = 11060
Public Const ContextualKeywordWhere As Integer = 11060

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordYield Field

VBTokenIdContextualKeywordYield Field

Gets the ContextualKeywordYield token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ContextualKeywordYield = 11061
Public Const ContextualKeywordYield As Integer = 11061

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.DocumentationCommentDelimiter Field

VBTokenIdDocumentationCommentDelimiter Field

Gets the DocumentationCommentDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentationCommentDelimiter = 11019
Public Const DocumentationCommentDelimiter As Integer = 11019

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.DocumentationCommentTag Field

VBTokenIdDocumentationCommentTag Field

Gets the DocumentationCommentTag token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentationCommentTag = 11020
Public Const DocumentationCommentTag As Integer = 11020

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.DocumentationCommentText Field

VBTokenIdDocumentationCommentText Field

Gets the DocumentationCommentText token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentationCommentText = 11021
Public Const DocumentationCommentText As Integer = 11021

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Dot Field

VBTokenIdDot Field

Gets the Dot token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Dot = 11010
Public Const Dot As Integer = 11010

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.DotAt Field

VBTokenIdDotAt Field

Gets the DotAt token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DotAt = 11015
Public Const DotAt As Integer = 11015

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ExclamationPoint Field

VBTokenIdExclamationPoint Field

Gets the ExclamationPoint token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ExclamationPoint = 11013
Public Const ExclamationPoint As Integer = 11013

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Identifier Field

VBTokenIdIdentifier Field

Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Identifier = 11032
Public Const Identifier As Integer = 11032

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAddHandler Field

VBTokenIdKeywordAddHandler Field

Gets the KeywordAddHandler token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAddHandler = 11062
Public Const KeywordAddHandler As Integer = 11062

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAddressOf Field

VBTokenIdKeywordAddressOf Field

Gets the KeywordAddressOf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAddressOf = 11063
Public Const KeywordAddressOf As Integer = 11063

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAlias Field

VBTokenIdKeywordAlias Field

Gets the KeywordAlias token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAlias = 11064
Public Const KeywordAlias As Integer = 11064

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAnd Field

VBTokenIdKeywordAnd Field

Gets the KeywordAnd token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAnd = 11065
Public Const KeywordAnd As Integer = 11065

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAndAlso Field

VBTokenIdKeywordAndAlso Field

Gets the KeywordAndAlso token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAndAlso = 11066
Public Const KeywordAndAlso As Integer = 11066

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAs Field

VBTokenIdKeywordAs Field

Gets the KeywordAs token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordAs = 11067
Public Const KeywordAs As Integer = 11067

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordBoolean Field

VBTokenIdKeywordBoolean Field

Gets the KeywordBoolean token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordBoolean = 11068
Public Const KeywordBoolean As Integer = 11068

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordByRef Field

VBTokenIdKeywordByRef Field

Gets the KeywordByRef token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordByRef = 11069
Public Const KeywordByRef As Integer = 11069

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordByte Field

VBTokenIdKeywordByte Field

Gets the KeywordByte token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordByte = 11070
Public Const KeywordByte As Integer = 11070

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordByVal Field

VBTokenIdKeywordByVal Field

Gets the KeywordByVal token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordByVal = 11071
Public Const KeywordByVal As Integer = 11071

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCall Field

VBTokenIdKeywordCall Field

Gets the KeywordCall token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCall = 11072
Public Const KeywordCall As Integer = 11072

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCase Field

VBTokenIdKeywordCase Field

Gets the KeywordCase token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCase = 11073
Public Const KeywordCase As Integer = 11073

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCatch Field

VBTokenIdKeywordCatch Field

Gets the KeywordCatch token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCatch = 11074
Public Const KeywordCatch As Integer = 11074

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCBool Field

VBTokenIdKeywordCBool Field

Gets the KeywordCBool token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCBool = 11075
Public Const KeywordCBool As Integer = 11075

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCByte Field

VBTokenIdKeywordCByte Field

Gets the KeywordCByte token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCByte = 11076
Public Const KeywordCByte As Integer = 11076

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCChar Field

VBTokenIdKeywordCChar Field

Gets the KeywordCChar token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCChar = 11077
Public Const KeywordCChar As Integer = 11077

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCDate Field

VBTokenIdKeywordCDate Field

Gets the KeywordCDate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCDate = 11078
Public Const KeywordCDate As Integer = 11078

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCDbl Field

VBTokenIdKeywordCDbl Field

Gets the KeywordCDbl token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCDbl = 11079
Public Const KeywordCDbl As Integer = 11079

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCDec Field

VBTokenIdKeywordCDec Field

Gets the KeywordCDec token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCDec = 11080
Public Const KeywordCDec As Integer = 11080

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordChar Field

VBTokenIdKeywordChar Field

Gets the KeywordChar token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordChar = 11081
Public Const KeywordChar As Integer = 11081

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCInt Field

VBTokenIdKeywordCInt Field

Gets the KeywordCInt token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCInt = 11082
Public Const KeywordCInt As Integer = 11082

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordClass Field

VBTokenIdKeywordClass Field

Gets the KeywordClass token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordClass = 11083
Public Const KeywordClass As Integer = 11083

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCLng Field

VBTokenIdKeywordCLng Field

Gets the KeywordCLng token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCLng = 11084
Public Const KeywordCLng As Integer = 11084

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCObj Field

VBTokenIdKeywordCObj Field

Gets the KeywordCObj token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCObj = 11085
Public Const KeywordCObj As Integer = 11085

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordConst Field

VBTokenIdKeywordConst Field

Gets the KeywordConst token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordConst = 11086
Public Const KeywordConst As Integer = 11086

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordContinue Field

VBTokenIdKeywordContinue Field

Gets the KeywordContinue token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordContinue = 11087
Public Const KeywordContinue As Integer = 11087

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCSByte Field

VBTokenIdKeywordCSByte Field

Gets the KeywordCSByte token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCSByte = 11088
Public Const KeywordCSByte As Integer = 11088

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCShort Field

VBTokenIdKeywordCShort Field

Gets the KeywordCShort token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCShort = 11089
Public Const KeywordCShort As Integer = 11089

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCSng Field

VBTokenIdKeywordCSng Field

Gets the KeywordCSng token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCSng = 11090
Public Const KeywordCSng As Integer = 11090

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCStr Field

VBTokenIdKeywordCStr Field

Gets the KeywordCStr token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCStr = 11091
Public Const KeywordCStr As Integer = 11091

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCType Field

VBTokenIdKeywordCType Field

Gets the KeywordCType token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCType = 11092
Public Const KeywordCType As Integer = 11092

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCUInt Field

VBTokenIdKeywordCUInt Field

Gets the KeywordCUInt token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCUInt = 11093
Public Const KeywordCUInt As Integer = 11093

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCULng Field

VBTokenIdKeywordCULng Field

Gets the KeywordCULng token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCULng = 11094
Public Const KeywordCULng As Integer = 11094

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCUShort Field

VBTokenIdKeywordCUShort Field

Gets the KeywordCUShort token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordCUShort = 11095
Public Const KeywordCUShort As Integer = 11095

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDate Field

VBTokenIdKeywordDate Field

Gets the KeywordDate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDate = 11096
Public Const KeywordDate As Integer = 11096

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDecimal Field

VBTokenIdKeywordDecimal Field

Gets the KeywordDecimal token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDecimal = 11097
Public Const KeywordDecimal As Integer = 11097

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDeclare Field

VBTokenIdKeywordDeclare Field

Gets the KeywordDeclare token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDeclare = 11098
Public Const KeywordDeclare As Integer = 11098

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDefault Field

VBTokenIdKeywordDefault Field

Gets the KeywordDefault token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDefault = 11099
Public Const KeywordDefault As Integer = 11099

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDelegate Field

VBTokenIdKeywordDelegate Field

Gets the KeywordDelegate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDelegate = 11100
Public Const KeywordDelegate As Integer = 11100

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDim Field

VBTokenIdKeywordDim Field

Gets the KeywordDim token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDim = 11101
Public Const KeywordDim As Integer = 11101

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDirectCast Field

VBTokenIdKeywordDirectCast Field

Gets the KeywordDirectCast token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDirectCast = 11102
Public Const KeywordDirectCast As Integer = 11102

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDo Field

VBTokenIdKeywordDo Field

Gets the KeywordDo token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDo = 11103
Public Const KeywordDo As Integer = 11103

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDouble Field

VBTokenIdKeywordDouble Field

Gets the KeywordDouble token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordDouble = 11104
Public Const KeywordDouble As Integer = 11104

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEach Field

VBTokenIdKeywordEach Field

Gets the KeywordEach token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordEach = 11105
Public Const KeywordEach As Integer = 11105

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordElse Field

VBTokenIdKeywordElse Field

Gets the KeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordElse = 11106
Public Const KeywordElse As Integer = 11106

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordElseIf Field

VBTokenIdKeywordElseIf Field

Gets the KeywordElseIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordElseIf = 11107
Public Const KeywordElseIf As Integer = 11107

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEnd Field

VBTokenIdKeywordEnd Field

Gets the KeywordEnd token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordEnd = 11108
Public Const KeywordEnd As Integer = 11108

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEndIf Field

VBTokenIdKeywordEndIf Field

Gets the KeywordEndIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordEndIf = 11109
Public Const KeywordEndIf As Integer = 11109

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEnum Field

VBTokenIdKeywordEnum Field

Gets the KeywordEnum token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordEnum = 11110
Public Const KeywordEnum As Integer = 11110

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordErase Field

VBTokenIdKeywordErase Field

Gets the KeywordErase token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordErase = 11111
Public Const KeywordErase As Integer = 11111

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordError Field

VBTokenIdKeywordError Field

Gets the KeywordError token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordError = 11112
Public Const KeywordError As Integer = 11112

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEvent Field

VBTokenIdKeywordEvent Field

Gets the KeywordEvent token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordEvent = 11113
Public Const KeywordEvent As Integer = 11113

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordExit Field

VBTokenIdKeywordExit Field

Gets the KeywordExit token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordExit = 11114
Public Const KeywordExit As Integer = 11114

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFalse Field

VBTokenIdKeywordFalse Field

Gets the KeywordFalse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFalse = 11115
Public Const KeywordFalse As Integer = 11115

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFinally Field

VBTokenIdKeywordFinally Field

Gets the KeywordFinally token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFinally = 11116
Public Const KeywordFinally As Integer = 11116

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFor Field

VBTokenIdKeywordFor Field

Gets the KeywordFor token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFor = 11117
Public Const KeywordFor As Integer = 11117

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFriend Field

VBTokenIdKeywordFriend Field

Gets the KeywordFriend token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFriend = 11118
Public Const KeywordFriend As Integer = 11118

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFunction Field

VBTokenIdKeywordFunction Field

Gets the KeywordFunction token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordFunction = 11119
Public Const KeywordFunction As Integer = 11119

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGet Field

VBTokenIdKeywordGet Field

Gets the KeywordGet token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordGet = 11120
Public Const KeywordGet As Integer = 11120

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGetType Field

VBTokenIdKeywordGetType Field

Gets the KeywordGetType token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordGetType = 11121
Public Const KeywordGetType As Integer = 11121

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGetXmlNamespace Field

VBTokenIdKeywordGetXmlNamespace Field

Gets the KeywordGetXmlNamespace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordGetXmlNamespace = 11122
Public Const KeywordGetXmlNamespace As Integer = 11122

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGlobal Field

VBTokenIdKeywordGlobal Field

Gets the KeywordGlobal token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordGlobal = 11123
Public Const KeywordGlobal As Integer = 11123

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGoSub Field

VBTokenIdKeywordGoSub Field

Gets the KeywordGoSub token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordGoSub = 11124
Public Const KeywordGoSub As Integer = 11124

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGoTo Field

VBTokenIdKeywordGoTo Field

Gets the KeywordGoTo token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordGoTo = 11125
Public Const KeywordGoTo As Integer = 11125

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordHandles Field

VBTokenIdKeywordHandles Field

Gets the KeywordHandles token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordHandles = 11126
Public Const KeywordHandles As Integer = 11126

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordIf Field

VBTokenIdKeywordIf Field

Gets the KeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIf = 11127
Public Const KeywordIf As Integer = 11127

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordImplements Field

VBTokenIdKeywordImplements Field

Gets the KeywordImplements token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordImplements = 11128
Public Const KeywordImplements As Integer = 11128

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordImports Field

VBTokenIdKeywordImports Field

Gets the KeywordImports token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordImports = 11129
Public Const KeywordImports As Integer = 11129

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordIn Field

VBTokenIdKeywordIn Field

Gets the KeywordIn token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIn = 11130
Public Const KeywordIn As Integer = 11130

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordInherits Field

VBTokenIdKeywordInherits Field

Gets the KeywordInherits token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordInherits = 11131
Public Const KeywordInherits As Integer = 11131

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordInteger Field

VBTokenIdKeywordInteger Field

Gets the KeywordInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordInteger = 11132
Public Const KeywordInteger As Integer = 11132

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordInterface Field

VBTokenIdKeywordInterface Field

Gets the KeywordInterface token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordInterface = 11133
Public Const KeywordInterface As Integer = 11133

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordIs Field

VBTokenIdKeywordIs Field

Gets the KeywordIs token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIs = 11134
Public Const KeywordIs As Integer = 11134

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordIsNot Field

VBTokenIdKeywordIsNot Field

Gets the KeywordIsNot token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordIsNot = 11135
Public Const KeywordIsNot As Integer = 11135

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLet Field

VBTokenIdKeywordLet Field

Gets the KeywordLet token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordLet = 11136
Public Const KeywordLet As Integer = 11136

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLib Field

VBTokenIdKeywordLib Field

Gets the KeywordLib token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordLib = 11137
Public Const KeywordLib As Integer = 11137

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLike Field

VBTokenIdKeywordLike Field

Gets the KeywordLike token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordLike = 11138
Public Const KeywordLike As Integer = 11138

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLong Field

VBTokenIdKeywordLong Field

Gets the KeywordLong token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordLong = 11139
Public Const KeywordLong As Integer = 11139

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLoop Field

VBTokenIdKeywordLoop Field

Gets the KeywordLoop token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordLoop = 11140
Public Const KeywordLoop As Integer = 11140

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMe Field

VBTokenIdKeywordMe Field

Gets the KeywordMe token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordMe = 11141
Public Const KeywordMe As Integer = 11141

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMod Field

VBTokenIdKeywordMod Field

Gets the KeywordMod token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordMod = 11142
Public Const KeywordMod As Integer = 11142

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordModule Field

VBTokenIdKeywordModule Field

Gets the KeywordModule token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordModule = 11143
Public Const KeywordModule As Integer = 11143

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMustInherit Field

VBTokenIdKeywordMustInherit Field

Gets the KeywordMustInherit token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordMustInherit = 11144
Public Const KeywordMustInherit As Integer = 11144

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMustOverride Field

VBTokenIdKeywordMustOverride Field

Gets the KeywordMustOverride token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordMustOverride = 11145
Public Const KeywordMustOverride As Integer = 11145

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMyBase Field

VBTokenIdKeywordMyBase Field

Gets the KeywordMyBase token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordMyBase = 11146
Public Const KeywordMyBase As Integer = 11146

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMyClass Field

VBTokenIdKeywordMyClass Field

Gets the KeywordMyClass token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordMyClass = 11147
Public Const KeywordMyClass As Integer = 11147

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNameOf Field

VBTokenIdKeywordNameOf Field

Gets the KeywordNameOf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNameOf = 11148
Public Const KeywordNameOf As Integer = 11148

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNamespace Field

VBTokenIdKeywordNamespace Field

Gets the KeywordNamespace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNamespace = 11149
Public Const KeywordNamespace As Integer = 11149

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNarrowing Field

VBTokenIdKeywordNarrowing Field

Gets the KeywordNarrowing token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNarrowing = 11150
Public Const KeywordNarrowing As Integer = 11150

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNew Field

VBTokenIdKeywordNew Field

Gets the KeywordNew token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNew = 11151
Public Const KeywordNew As Integer = 11151

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNext Field

VBTokenIdKeywordNext Field

Gets the KeywordNext token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNext = 11152
Public Const KeywordNext As Integer = 11152

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNot Field

VBTokenIdKeywordNot Field

Gets the KeywordNot token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNot = 11153
Public Const KeywordNot As Integer = 11153

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNothing Field

VBTokenIdKeywordNothing Field

Gets the KeywordNothing token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNothing = 11154
Public Const KeywordNothing As Integer = 11154

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNotInheritable Field

VBTokenIdKeywordNotInheritable Field

Gets the KeywordNotInheritable token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNotInheritable = 11155
Public Const KeywordNotInheritable As Integer = 11155

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNotOverridable Field

VBTokenIdKeywordNotOverridable Field

Gets the KeywordNotOverridable token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordNotOverridable = 11156
Public Const KeywordNotOverridable As Integer = 11156

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordObject Field

VBTokenIdKeywordObject Field

Gets the KeywordObject token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordObject = 11157
Public Const KeywordObject As Integer = 11157

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOf Field

VBTokenIdKeywordOf Field

Gets the KeywordOf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOf = 11158
Public Const KeywordOf As Integer = 11158

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOn Field

VBTokenIdKeywordOn Field

Gets the KeywordOn token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOn = 11159
Public Const KeywordOn As Integer = 11159

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOperator Field

VBTokenIdKeywordOperator Field

Gets the KeywordOperator token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOperator = 11160
Public Const KeywordOperator As Integer = 11160

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOption Field

VBTokenIdKeywordOption Field

Gets the KeywordOption token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOption = 11161
Public Const KeywordOption As Integer = 11161

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOptional Field

VBTokenIdKeywordOptional Field

Gets the KeywordOptional token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOptional = 11162
Public Const KeywordOptional As Integer = 11162

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOr Field

VBTokenIdKeywordOr Field

Gets the KeywordOr token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOr = 11163
Public Const KeywordOr As Integer = 11163

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOrElse Field

VBTokenIdKeywordOrElse Field

Gets the KeywordOrElse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOrElse = 11164
Public Const KeywordOrElse As Integer = 11164

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOverloads Field

VBTokenIdKeywordOverloads Field

Gets the KeywordOverloads token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOverloads = 11165
Public Const KeywordOverloads As Integer = 11165

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOverridable Field

VBTokenIdKeywordOverridable Field

Gets the KeywordOverridable token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOverridable = 11166
Public Const KeywordOverridable As Integer = 11166

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOverrides Field

VBTokenIdKeywordOverrides Field

Gets the KeywordOverrides token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordOverrides = 11167
Public Const KeywordOverrides As Integer = 11167

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordParamArray Field

VBTokenIdKeywordParamArray Field

Gets the KeywordParamArray token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordParamArray = 11168
Public Const KeywordParamArray As Integer = 11168

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordPartial Field

VBTokenIdKeywordPartial Field

Gets the KeywordPartial token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordPartial = 11169
Public Const KeywordPartial As Integer = 11169

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordPrivate Field

VBTokenIdKeywordPrivate Field

Gets the KeywordPrivate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordPrivate = 11170
Public Const KeywordPrivate As Integer = 11170

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordProperty Field

VBTokenIdKeywordProperty Field

Gets the KeywordProperty token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordProperty = 11171
Public Const KeywordProperty As Integer = 11171

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordProtected Field

VBTokenIdKeywordProtected Field

Gets the KeywordProtected token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordProtected = 11172
Public Const KeywordProtected As Integer = 11172

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordPublic Field

VBTokenIdKeywordPublic Field

Gets the KeywordPublic token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordPublic = 11173
Public Const KeywordPublic As Integer = 11173

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordRaiseEvent Field

VBTokenIdKeywordRaiseEvent Field

Gets the KeywordRaiseEvent token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordRaiseEvent = 11174
Public Const KeywordRaiseEvent As Integer = 11174

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordReadOnly Field

VBTokenIdKeywordReadOnly Field

Gets the KeywordReadOnly token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordReadOnly = 11175
Public Const KeywordReadOnly As Integer = 11175

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordReDim Field

VBTokenIdKeywordReDim Field

Gets the KeywordReDim token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordReDim = 11176
Public Const KeywordReDim As Integer = 11176

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordREM Field

VBTokenIdKeywordREM Field

Gets the KeywordREM token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordREM = 11177
Public Const KeywordREM As Integer = 11177

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordRemoveHandler Field

VBTokenIdKeywordRemoveHandler Field

Gets the KeywordRemoveHandler token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordRemoveHandler = 11178
Public Const KeywordRemoveHandler As Integer = 11178

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordResume Field

VBTokenIdKeywordResume Field

Gets the KeywordResume token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordResume = 11179
Public Const KeywordResume As Integer = 11179

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordReturn Field

VBTokenIdKeywordReturn Field

Gets the KeywordReturn token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordReturn = 11180
Public Const KeywordReturn As Integer = 11180

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSByte Field

VBTokenIdKeywordSByte Field

Gets the KeywordSByte token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSByte = 11181
Public Const KeywordSByte As Integer = 11181

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSelect Field

VBTokenIdKeywordSelect Field

Gets the KeywordSelect token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSelect = 11182
Public Const KeywordSelect As Integer = 11182

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSet Field

VBTokenIdKeywordSet Field

Gets the KeywordSet token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSet = 11183
Public Const KeywordSet As Integer = 11183

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordShadows Field

VBTokenIdKeywordShadows Field

Gets the KeywordShadows token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordShadows = 11184
Public Const KeywordShadows As Integer = 11184

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordShared Field

VBTokenIdKeywordShared Field

Gets the KeywordShared token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordShared = 11185
Public Const KeywordShared As Integer = 11185

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordShort Field

VBTokenIdKeywordShort Field

Gets the KeywordShort token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordShort = 11186
Public Const KeywordShort As Integer = 11186

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSingle Field

VBTokenIdKeywordSingle Field

Gets the KeywordSingle token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSingle = 11187
Public Const KeywordSingle As Integer = 11187

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordStatic Field

VBTokenIdKeywordStatic Field

Gets the KeywordStatic token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordStatic = 11188
Public Const KeywordStatic As Integer = 11188

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordStep Field

VBTokenIdKeywordStep Field

Gets the KeywordStep token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordStep = 11189
Public Const KeywordStep As Integer = 11189

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordStop Field

VBTokenIdKeywordStop Field

Gets the KeywordStop token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordStop = 11190
Public Const KeywordStop As Integer = 11190

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordString Field

VBTokenIdKeywordString Field

Gets the KeywordString token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordString = 11191
Public Const KeywordString As Integer = 11191

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordStructure Field

VBTokenIdKeywordStructure Field

Gets the KeywordStructure token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordStructure = 11192
Public Const KeywordStructure As Integer = 11192

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSub Field

VBTokenIdKeywordSub Field

Gets the KeywordSub token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSub = 11193
Public Const KeywordSub As Integer = 11193

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSyncLock Field

VBTokenIdKeywordSyncLock Field

Gets the KeywordSyncLock token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordSyncLock = 11194
Public Const KeywordSyncLock As Integer = 11194

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordThen Field

VBTokenIdKeywordThen Field

Gets the KeywordThen token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordThen = 11195
Public Const KeywordThen As Integer = 11195

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordThrow Field

VBTokenIdKeywordThrow Field

Gets the KeywordThrow token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordThrow = 11196
Public Const KeywordThrow As Integer = 11196

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTo Field

VBTokenIdKeywordTo Field

Gets the KeywordTo token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTo = 11197
Public Const KeywordTo As Integer = 11197

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTrue Field

VBTokenIdKeywordTrue Field

Gets the KeywordTrue token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTrue = 11198
Public Const KeywordTrue As Integer = 11198

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTry Field

VBTokenIdKeywordTry Field

Gets the KeywordTry token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTry = 11199
Public Const KeywordTry As Integer = 11199

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTryCast Field

VBTokenIdKeywordTryCast Field

Gets the KeywordTryCast token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTryCast = 11200
Public Const KeywordTryCast As Integer = 11200

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTypeOf Field

VBTokenIdKeywordTypeOf Field

Gets the KeywordTypeOf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordTypeOf = 11201
Public Const KeywordTypeOf As Integer = 11201

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordUInteger Field

VBTokenIdKeywordUInteger Field

Gets the KeywordUInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordUInteger = 11202
Public Const KeywordUInteger As Integer = 11202

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordULong Field

VBTokenIdKeywordULong Field

Gets the KeywordULong token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordULong = 11203
Public Const KeywordULong As Integer = 11203

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordUntil Field

VBTokenIdKeywordUntil Field

Gets the KeywordUntil token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordUntil = 11204
Public Const KeywordUntil As Integer = 11204

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordUShort Field

VBTokenIdKeywordUShort Field

Gets the KeywordUShort token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordUShort = 11205
Public Const KeywordUShort As Integer = 11205

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordUsing Field

VBTokenIdKeywordUsing Field

Gets the KeywordUsing token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordUsing = 11206
Public Const KeywordUsing As Integer = 11206

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordVariant Field

VBTokenIdKeywordVariant Field

Gets the KeywordVariant token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordVariant = 11207
Public Const KeywordVariant As Integer = 11207

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWend Field

VBTokenIdKeywordWend Field

Gets the KeywordWend token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWend = 11208
Public Const KeywordWend As Integer = 11208

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWhen Field

VBTokenIdKeywordWhen Field

Gets the KeywordWhen token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWhen = 11209
Public Const KeywordWhen As Integer = 11209

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWhile Field

VBTokenIdKeywordWhile Field

Gets the KeywordWhile token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWhile = 11210
Public Const KeywordWhile As Integer = 11210

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWidening Field

VBTokenIdKeywordWidening Field

Gets the KeywordWidening token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWidening = 11211
Public Const KeywordWidening As Integer = 11211

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWith Field

VBTokenIdKeywordWith Field

Gets the KeywordWith token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWith = 11212
Public Const KeywordWith As Integer = 11212

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWithEvents Field

VBTokenIdKeywordWithEvents Field

Gets the KeywordWithEvents token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWithEvents = 11213
Public Const KeywordWithEvents As Integer = 11213

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWriteOnly Field

VBTokenIdKeywordWriteOnly Field

Gets the KeywordWriteOnly token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordWriteOnly = 11214
Public Const KeywordWriteOnly As Integer = 11214

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordXor Field

VBTokenIdKeywordXor Field

Gets the KeywordXor token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int KeywordXor = 11215
Public Const KeywordXor As Integer = 11215

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LineContinuation Field

VBTokenIdLineContinuation Field

Gets the LineContinuation token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LineContinuation = 11002
Public Const LineContinuation As Integer = 11002

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LineTerminator Field

VBTokenIdLineTerminator Field

Gets the LineTerminator token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LineTerminator = 11001
Public Const LineTerminator As Integer = 11001

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralCharacter Field

VBTokenIdLiteralCharacter Field

Gets the LiteralCharacter token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralCharacter = 11026
Public Const LiteralCharacter As Integer = 11026

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralDate Field

VBTokenIdLiteralDate Field

Gets the LiteralDate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralDate = 11029
Public Const LiteralDate As Integer = 11029

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralDecimalInteger Field

VBTokenIdLiteralDecimalInteger Field

Gets the LiteralDecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralDecimalInteger = 11022
Public Const LiteralDecimalInteger As Integer = 11022

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralFloatingPoint Field

VBTokenIdLiteralFloatingPoint Field

Gets the LiteralFloatingPoint token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralFloatingPoint = 11025
Public Const LiteralFloatingPoint As Integer = 11025

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralHexadecimalInteger Field

VBTokenIdLiteralHexadecimalInteger Field

Gets the LiteralHexadecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralHexadecimalInteger = 11023
Public Const LiteralHexadecimalInteger As Integer = 11023

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralInterpolatedString Field

VBTokenIdLiteralInterpolatedString Field

Gets the LiteralInterpolatedString token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralInterpolatedString = 11028
Public Const LiteralInterpolatedString As Integer = 11028

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralOctalInteger Field

VBTokenIdLiteralOctalInteger Field

Gets the LiteralOctalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralOctalInteger = 11024
Public Const LiteralOctalInteger As Integer = 11024

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralString Field

VBTokenIdLiteralString Field

Gets the LiteralString token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralString = 11027
Public Const LiteralString As Integer = 11027

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralXml Field

VBTokenIdLiteralXml Field

Gets the LiteralXml token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LiteralXml = 11030
Public Const LiteralXml As Integer = 11030

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OpenCurlyBrace Field

VBTokenIdOpenCurlyBrace Field

Gets the OpenCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenCurlyBrace = 11005
Public Const OpenCurlyBrace As Integer = 11005

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OpenParenthesis Field

VBTokenIdOpenParenthesis Field

Gets the OpenParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenParenthesis = 11003
Public Const OpenParenthesis As Integer = 11003

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OpenSquareBrace Field

VBTokenIdOpenSquareBrace Field

Gets the OpenSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OpenSquareBrace = 11007
Public Const OpenSquareBrace As Integer = 11007

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorAddition Field

VBTokenIdOperatorAddition Field

Gets the OperatorAddition token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAddition = 11218
Public Const OperatorAddition As Integer = 11218

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorAdditionAssignment Field

VBTokenIdOperatorAdditionAssignment Field

Gets the OperatorAdditionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorAdditionAssignment = 11233
Public Const OperatorAdditionAssignment As Integer = 11233

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorEquality Field

VBTokenIdOperatorEquality Field

Gets the OperatorEquality token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorEquality = 11224
Public Const OperatorEquality As Integer = 11224

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorExponentiation Field

VBTokenIdOperatorExponentiation Field

Gets the OperatorExponentiation token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorExponentiation = 11222
Public Const OperatorExponentiation As Integer = 11222

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorExponentiationAssignment Field

VBTokenIdOperatorExponentiationAssignment Field

Gets the OperatorExponentiationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorExponentiationAssignment = 11237
Public Const OperatorExponentiationAssignment As Integer = 11237

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorFloatingPointDivision Field

VBTokenIdOperatorFloatingPointDivision Field

Gets the OperatorFloatingPointDivision token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorFloatingPointDivision = 11220
Public Const OperatorFloatingPointDivision As Integer = 11220

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorFloatingPointDivisionAssignment Field

VBTokenIdOperatorFloatingPointDivisionAssignment Field

Gets the OperatorFloatingPointDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorFloatingPointDivisionAssignment = 11235
Public Const OperatorFloatingPointDivisionAssignment As Integer = 11235

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorGreaterThan Field

VBTokenIdOperatorGreaterThan Field

Gets the OperatorGreaterThan token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThan = 11225
Public Const OperatorGreaterThan As Integer = 11225

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorGreaterThanOrEqual Field

VBTokenIdOperatorGreaterThanOrEqual Field

Gets the OperatorGreaterThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThanOrEqual = 11227
Public Const OperatorGreaterThanOrEqual As Integer = 11227

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorInequality Field

VBTokenIdOperatorInequality Field

Gets the OperatorInequality token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorInequality = 11228
Public Const OperatorInequality As Integer = 11228

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorIntegerDivision Field

VBTokenIdOperatorIntegerDivision Field

Gets the OperatorIntegerDivision token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorIntegerDivision = 11221
Public Const OperatorIntegerDivision As Integer = 11221

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorIntegerDivisionAssignment Field

VBTokenIdOperatorIntegerDivisionAssignment Field

Gets the OperatorIntegerDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorIntegerDivisionAssignment = 11236
Public Const OperatorIntegerDivisionAssignment As Integer = 11236

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorLeftShift Field

VBTokenIdOperatorLeftShift Field

Gets the OperatorLeftShift token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLeftShift = 11229
Public Const OperatorLeftShift As Integer = 11229

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorLeftShiftAssignment Field

VBTokenIdOperatorLeftShiftAssignment Field

Gets the OperatorLeftShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLeftShiftAssignment = 11238
Public Const OperatorLeftShiftAssignment As Integer = 11238

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorLessThan Field

VBTokenIdOperatorLessThan Field

Gets the OperatorLessThan token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLessThan = 11223
Public Const OperatorLessThan As Integer = 11223

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorLessThanOrEqual Field

VBTokenIdOperatorLessThanOrEqual Field

Gets the OperatorLessThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorLessThanOrEqual = 11226
Public Const OperatorLessThanOrEqual As Integer = 11226

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorMultiplication Field

VBTokenIdOperatorMultiplication Field

Gets the OperatorMultiplication token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorMultiplication = 11217
Public Const OperatorMultiplication As Integer = 11217

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorMultiplicationAssignment Field

VBTokenIdOperatorMultiplicationAssignment Field

Gets the OperatorMultiplicationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorMultiplicationAssignment = 11232
Public Const OperatorMultiplicationAssignment As Integer = 11232

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorRightShift Field

VBTokenIdOperatorRightShift Field

Gets the OperatorRightShift token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorRightShift = 11230
Public Const OperatorRightShift As Integer = 11230

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorRightShiftAssignment Field

VBTokenIdOperatorRightShiftAssignment Field

Gets the OperatorRightShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorRightShiftAssignment = 11239
Public Const OperatorRightShiftAssignment As Integer = 11239

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorStringConcatenation Field

VBTokenIdOperatorStringConcatenation Field

Gets the OperatorStringConcatenation token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorStringConcatenation = 11216
Public Const OperatorStringConcatenation As Integer = 11216

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorStringConcatenationAssignment Field

VBTokenIdOperatorStringConcatenationAssignment Field

Gets the OperatorStringConcatenationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorStringConcatenationAssignment = 11231
Public Const OperatorStringConcatenationAssignment As Integer = 11231

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorSubtraction Field

VBTokenIdOperatorSubtraction Field

Gets the OperatorSubtraction token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorSubtraction = 11219
Public Const OperatorSubtraction As Integer = 11219

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorSubtractionAssignment Field

VBTokenIdOperatorSubtractionAssignment Field

Gets the OperatorSubtractionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int OperatorSubtractionAssignment = 11234
Public Const OperatorSubtractionAssignment As Integer = 11234

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordConst Field

VBTokenIdPreprocessorDirectiveKeywordConst Field

Gets the PreprocessorDirectiveKeywordConst token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordConst = 11240
Public Const PreprocessorDirectiveKeywordConst As Integer = 11240

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordDisableWarning Field

VBTokenIdPreprocessorDirectiveKeywordDisableWarning Field

Gets the PreprocessorDirectiveKeywordDisableWarning token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordDisableWarning = 11241
Public Const PreprocessorDirectiveKeywordDisableWarning As Integer = 11241

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordElse Field

VBTokenIdPreprocessorDirectiveKeywordElse Field

Gets the PreprocessorDirectiveKeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordElse = 11245
Public Const PreprocessorDirectiveKeywordElse As Integer = 11245

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordElseIf Field

VBTokenIdPreprocessorDirectiveKeywordElseIf Field

Gets the PreprocessorDirectiveKeywordElseIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordElseIf = 11244
Public Const PreprocessorDirectiveKeywordElseIf As Integer = 11244

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordEnableWarning Field

VBTokenIdPreprocessorDirectiveKeywordEnableWarning Field

Gets the PreprocessorDirectiveKeywordEnableWarning token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEnableWarning = 11242
Public Const PreprocessorDirectiveKeywordEnableWarning As Integer = 11242

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordEndExternalSource Field

VBTokenIdPreprocessorDirectiveKeywordEndExternalSource Field

Gets the PreprocessorDirectiveKeywordEndExternalSource token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndExternalSource = 11248
Public Const PreprocessorDirectiveKeywordEndExternalSource As Integer = 11248

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordEndIf Field

VBTokenIdPreprocessorDirectiveKeywordEndIf Field

Gets the PreprocessorDirectiveKeywordEndIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndIf = 11246
Public Const PreprocessorDirectiveKeywordEndIf As Integer = 11246

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordEndRegion Field

VBTokenIdPreprocessorDirectiveKeywordEndRegion Field

Gets the PreprocessorDirectiveKeywordEndRegion token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndRegion = 11250
Public Const PreprocessorDirectiveKeywordEndRegion As Integer = 11250

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordExternalChecksum Field

VBTokenIdPreprocessorDirectiveKeywordExternalChecksum Field

Gets the PreprocessorDirectiveKeywordExternalChecksum token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordExternalChecksum = 11251
Public Const PreprocessorDirectiveKeywordExternalChecksum As Integer = 11251

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordExternalSource Field

VBTokenIdPreprocessorDirectiveKeywordExternalSource Field

Gets the PreprocessorDirectiveKeywordExternalSource token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordExternalSource = 11247
Public Const PreprocessorDirectiveKeywordExternalSource As Integer = 11247

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordIf Field

VBTokenIdPreprocessorDirectiveKeywordIf Field

Gets the PreprocessorDirectiveKeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordIf = 11243
Public Const PreprocessorDirectiveKeywordIf As Integer = 11243

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordRegion Field

VBTokenIdPreprocessorDirectiveKeywordRegion Field

Gets the PreprocessorDirectiveKeywordRegion token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordRegion = 11249
Public Const PreprocessorDirectiveKeywordRegion As Integer = 11249

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveText Field

VBTokenIdPreprocessorDirectiveText Field

Gets the PreprocessorDirectiveText token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveText = 11252
Public Const PreprocessorDirectiveText As Integer = 11252

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.QuestionMark Field

VBTokenIdQuestionMark Field

Gets the QuestionMark token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int QuestionMark = 11014
Public Const QuestionMark As Integer = 11014

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.TripleDot Field

VBTokenIdTripleDot Field

Gets the TripleDot token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int TripleDot = 11016
Public Const TripleDot As Integer = 11016

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Whitespace Field

VBTokenIdWhitespace Field

Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Whitespace = 11000
Public Const Whitespace As Integer = 11000

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.XmlAttribute Field

VBTokenIdXmlAttribute Field

Gets the XmlAttribute token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int XmlAttribute = 11031
Public Const XmlAttribute As Integer = 11031

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader Class

Represents an object that can provide tokens to a ILLParser in a forward-only direction for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenReader

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBTokenReader : MergableTokenReader
Public Class VBTokenReader
    Inherits MergableTokenReader

The VBTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | VBTokenReader | Initializes a new instance of the VBTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader Constructor

Initializes a new instance of the VBTokenReader class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

VBTokenReader Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader Properties

The VBTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

VBTokenReader Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader Methods

The VBTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Top
See Also

Reference

VBTokenReader Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader.GetNextToken Method

VBTokenReaderGetNextToken Method

Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

VBTokenReader Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Class

Represents an ITaggerT for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenTagger

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBTokenTagger : TokenTagger
Public Class VBTokenTagger
    Inherits TokenTagger

The VBTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | VBTokenTagger | Initializes a new instance of the VBTokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Constructor

Initializes a new instance of the VBTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBTokenTagger(
    ICodeDocument document,
    IDotNetClassificationTypeProvider classificationTypes
)
Public Sub New (
    document As ICodeDocument,
    classificationTypes As IDotNetClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypes
Type: ActiproSoftware.Text.Languages.DotNetIDotNetClassificationTypeProvider
A IDotNetClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Properties

The VBTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Methods

The VBTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger.ClassifyToken Method

VBTokenTaggerClassifyToken Method

Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IClassificationType ClassifyToken(
    IToken token
)
Public Overrides Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Events

The VBTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider Class

Represents a provider of VBTokenTagger objects for documents that use the VBTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase VBTokenTagger
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VBTokenTaggerProvider : TaggerProviderBase<VBTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class VBTokenTaggerProvider
    Inherits TaggerProviderBase(Of VBTokenTagger)
    Implements ICodeDocumentTaggerProvider

The VBTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBTokenTaggerProvider | Initializes a new instance of the VBTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
Remarks
This type was generated by the Actipro Language Designer tool v10.2.530.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider Constructor

Initializes a new instance of the VBTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VBTokenTaggerProvider(
    IDotNetClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IDotNetClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.DotNetIDotNetClassificationTypeProvider
A IDotNetClassificationTypeProvider that provides classification types.
See Also

Reference

VBTokenTaggerProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider Properties

The VBTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

VBTokenTaggerProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider Methods

The VBTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
See Also

Reference

VBTokenTaggerProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider.GetTagger(T) Method

VBTokenTaggerProviderGetTaggerT Method

Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: ActiproSoftware.Text.Addons.DotNet.Wpf (in ActiproSoftware.Text.Addons.DotNet.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

VBTokenTaggerProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


ActiproSoftware.Text.Languages.Xml Namespace

Contains the classes related to implementing an XML syntax language.
Classes
 | Class | Description
Public class | XmlSyntaxLanguageExtensions | Contains extension methods that make it easier to work with XML ISyntaxLanguage objects.
Interfaces
 | Interface | Description
Public interface | IXmlAttributeContext | Provides the base requirements for resolved information about a XML attribute related to an IXmlContext.
Public interface | IXmlClassificationTypeProvider | Provides the base requirements of an object that provides IClassificationType objects for the XML language.
Public interface | IXmlContext | Provides the base requirements for information about the XML context of a certain offset within an ITextSnapshot.
Public interface | IXmlElementContext | Provides the base requirements for resolved information about a XML element related to an IXmlContext.
Public interface | IXmlEndTagAutoCompleter | Provides the base requirements for a class that can auto-complete XML end tags when appropriate.
Public interface | IXmlSchemaResolver | Provides the base requirements for a class that can manage XML schema data.
Public interface | IXmlValidator | Provides the base requirements for a class that can validate XML.
Enumerations
 | Enumeration | Description
Public enumeration | XmlAttributeSpacingMode | The attribute spacing modes that an XmlTextFormatter can use.
Public enumeration | XmlContextType | Specifies the type of IXmlContext.
Public enumeration | XmlElementSpacingMode | The element spacing modes that an XmlTextFormatter can use.
Public enumeration | XmlValidationMode | Specifies the validation mode for an IXmlValidator.


IXmlAttributeContext Interface

Provides the base requirements for resolved information about a XML attribute related to an IXmlContext.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IXmlAttributeContext
Public Interface IXmlAttributeContext

The IXmlAttributeContext type exposes the following members.

Properties
 | Name | Description
Public property | Element | Gets the IXmlElementContext upon which this attribute is located.
Public property | Name | Gets the name of the attribute.
Public property | NameSnapshotRange | Gets the TextSnapshotRange that specifies the range of the attribute name.
Public property | Namespace | Gets the namespace that defines the attribute.
Public property | NamespacePrefix | Gets the prefix of the namespace that defines the attribute.
Public property | QualifiedName | Gets the XmlQualifiedName that contains the attribute's qualified name.
Public property | SchemaAttribute | Gets the resolved XmlSchemaAttribute for this attribute, if known.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext Properties

The IXmlAttributeContext type exposes the following members.

Properties
 | Name | Description
Public property | Element | Gets the IXmlElementContext upon which this attribute is located.
Public property | Name | Gets the name of the attribute.
Public property | NameSnapshotRange | Gets the TextSnapshotRange that specifies the range of the attribute name.
Public property | Namespace | Gets the namespace that defines the attribute.
Public property | NamespacePrefix | Gets the prefix of the namespace that defines the attribute.
Public property | QualifiedName | Gets the XmlQualifiedName that contains the attribute's qualified name.
Public property | SchemaAttribute | Gets the resolved XmlSchemaAttribute for this attribute, if known.
Top
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.Element Property

IXmlAttributeContextElement Property

Gets the IXmlElementContext upon which this attribute is located.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IXmlElementContext Element { get; }
ReadOnly Property Element As IXmlElementContext
    Get

Property Value

Type: IXmlElementContext
The IXmlElementContext upon which this attribute is located.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.Name Property

IXmlAttributeContextName Property

Gets the name of the attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the attribute.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.NameSnapshotRange Property

IXmlAttributeContextNameSnapshotRange Property

Gets the TextSnapshotRange that specifies the range of the attribute name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotRange NameSnapshotRange { get; }
ReadOnly Property NameSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that specifies the range of the attribute name.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.Namespace Property

IXmlAttributeContextNamespace Property

Gets the namespace that defines the attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Namespace { get; }
ReadOnly Property Namespace As String
    Get

Property Value

Type: String
The namespace that defines the attribute.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.NamespacePrefix Property

IXmlAttributeContextNamespacePrefix Property

Gets the prefix of the namespace that defines the attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string NamespacePrefix { get; }
ReadOnly Property NamespacePrefix As String
    Get

Property Value

Type: String
The prefix of the namespace that defines the attribute.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.QualifiedName Property

IXmlAttributeContextQualifiedName Property

Gets the XmlQualifiedName that contains the attribute's qualified name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
XmlQualifiedName QualifiedName { get; }
ReadOnly Property QualifiedName As XmlQualifiedName
    Get

Property Value

Type: XmlQualifiedName
The XmlQualifiedName that contains the attribute's qualified name.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.SchemaAttribute Property

IXmlAttributeContextSchemaAttribute Property

Gets the resolved XmlSchemaAttribute for this attribute, if known.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
XmlSchemaAttribute SchemaAttribute { get; }
ReadOnly Property SchemaAttribute As XmlSchemaAttribute
    Get

Property Value

Type: XmlSchemaAttribute
The resolved XmlSchemaAttribute for this attribute, if known.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider Interface

Provides the base requirements of an object that provides IClassificationType objects for the XML language.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IXmlClassificationTypeProvider
Public Interface IXmlClassificationTypeProvider

The IXmlClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | XmlAttribute | Gets the XmlAttribute classification type.
Public property | XmlAttributeValue | Gets the XmlAttributeValue classification type.
Public property | XmlCDataSection | Gets the XmlCDataSection classification type.
Public property | XmlComment | Gets the XmlComment classification type.
Public property | XmlDeclaration | Gets the XmlDeclaration classification type.
Public property | XmlDelimiter | Gets the XmlDelimiter classification type.
Public property | XmlEntity | Gets the XmlEntity classification type.
Public property | XmlName | Gets the XmlName classification type.
Public property | XmlProcessingInstruction | Gets the XmlProcessingInstruction classification type.
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.542.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider Properties

The IXmlClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | XmlAttribute | Gets the XmlAttribute classification type.
Public property | XmlAttributeValue | Gets the XmlAttributeValue classification type.
Public property | XmlCDataSection | Gets the XmlCDataSection classification type.
Public property | XmlComment | Gets the XmlComment classification type.
Public property | XmlDeclaration | Gets the XmlDeclaration classification type.
Public property | XmlDelimiter | Gets the XmlDelimiter classification type.
Public property | XmlEntity | Gets the XmlEntity classification type.
Public property | XmlName | Gets the XmlName classification type.
Public property | XmlProcessingInstruction | Gets the XmlProcessingInstruction classification type.
Top
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlAttribute Property

IXmlClassificationTypeProviderXmlAttribute Property

Gets the XmlAttribute classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlAttribute { get; }
ReadOnly Property XmlAttribute As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlAttribute classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlAttributeValue Property

IXmlClassificationTypeProviderXmlAttributeValue Property

Gets the XmlAttributeValue classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlAttributeValue { get; }
ReadOnly Property XmlAttributeValue As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlAttributeValue classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlCDataSection Property

IXmlClassificationTypeProviderXmlCDataSection Property

Gets the XmlCDataSection classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlCDataSection { get; }
ReadOnly Property XmlCDataSection As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlCDataSection classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlComment Property

IXmlClassificationTypeProviderXmlComment Property

Gets the XmlComment classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlComment { get; }
ReadOnly Property XmlComment As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlComment classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlDeclaration Property

IXmlClassificationTypeProviderXmlDeclaration Property

Gets the XmlDeclaration classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlDeclaration { get; }
ReadOnly Property XmlDeclaration As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDeclaration classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlDelimiter Property

IXmlClassificationTypeProviderXmlDelimiter Property

Gets the XmlDelimiter classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlDelimiter { get; }
ReadOnly Property XmlDelimiter As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDelimiter classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlEntity Property

IXmlClassificationTypeProviderXmlEntity Property

Gets the XmlEntity classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlEntity { get; }
ReadOnly Property XmlEntity As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlEntity classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlName Property

IXmlClassificationTypeProviderXmlName Property

Gets the XmlName classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlName { get; }
ReadOnly Property XmlName As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlName classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlProcessingInstruction Property

IXmlClassificationTypeProviderXmlProcessingInstruction Property

Gets the XmlProcessingInstruction classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType XmlProcessingInstruction { get; }
ReadOnly Property XmlProcessingInstruction As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlProcessingInstruction classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext Interface

Provides the base requirements for information about the XML context of a certain offset within an ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IXmlContext
Public Interface IXmlContext

The IXmlContext type exposes the following members.

Properties
 | Name | Description
Public property | ElementHierarchy | Gets a read-only list of IXmlElementContext objects that describes the element hierarchy.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | NamespaceDeclarations | Gets the mapping dictionary of namespace to namespace prefixes that are declared at the context.
Public property | SchemaResolver | Gets the IXmlSchemaResolver to use.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetAttribute | Gets the IXmlAttributeContext that contains context information related to the target attribute.
Public property | TargetElement | Gets the IXmlElementContext that contains context information related to the target element.
Public property | Type | Gets an XmlContextType that specifies the type of context.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext Properties

The IXmlContext type exposes the following members.

Properties
 | Name | Description
Public property | ElementHierarchy | Gets a read-only list of IXmlElementContext objects that describes the element hierarchy.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | NamespaceDeclarations | Gets the mapping dictionary of namespace to namespace prefixes that are declared at the context.
Public property | SchemaResolver | Gets the IXmlSchemaResolver to use.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetAttribute | Gets the IXmlAttributeContext that contains context information related to the target attribute.
Public property | TargetElement | Gets the IXmlElementContext that contains context information related to the target element.
Public property | Type | Gets an XmlContextType that specifies the type of context.
Top
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.ElementHierarchy Property

IXmlContextElementHierarchy Property

Gets a read-only list of IXmlElementContext objects that describes the element hierarchy.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IXmlElementContext> ElementHierarchy { get; }
ReadOnly Property ElementHierarchy As IList(Of IXmlElementContext)
    Get

Property Value

Type: IList IXmlElementContext
A read-only list of IXmlElementContext objects that describes the element hierarchy.
Remarks
The element hierarchy is the list of parent elements that contain the current offset.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.InitializationSnapshotRange Property

IXmlContextInitializationSnapshotRange Property

Gets the TextSnapshotRange with which the context was initialized.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotRange> InitializationSnapshotRange { get; }
ReadOnly Property InitializationSnapshotRange As Nullable(Of TextSnapshotRange)
    Get

Property Value

Type: Nullable TextSnapshotRange
The TextSnapshotRange with which the context was initialized.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.NamespaceDeclarations Property

IXmlContextNamespaceDeclarations Property

Gets the mapping dictionary of namespace to namespace prefixes that are declared at the context.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDictionary<string, string> NamespaceDeclarations { get; }
ReadOnly Property NamespaceDeclarations As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionary String, String
The mapping dictionary of namespace to namespace prefixes that are declared at the context.
Remarks
The dictionary keys are namespaces and the values are namespace prefixes.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.SchemaResolver Property

IXmlContextSchemaResolver Property

Gets the IXmlSchemaResolver to use.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IXmlSchemaResolver SchemaResolver { get; }
ReadOnly Property SchemaResolver As IXmlSchemaResolver
    Get

Property Value

Type: IXmlSchemaResolver
The IXmlSchemaResolver to use.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.SnapshotOffset Property

IXmlContextSnapshotOffset Property

Gets the TextSnapshotOffset for which this context was created.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotOffset SnapshotOffset { get; }
ReadOnly Property SnapshotOffset As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
The TextSnapshotOffset for which this context was created.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.TargetAttribute Property

IXmlContextTargetAttribute Property

Gets the IXmlAttributeContext that contains context information related to the target attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IXmlAttributeContext TargetAttribute { get; }
ReadOnly Property TargetAttribute As IXmlAttributeContext
    Get

Property Value

Type: IXmlAttributeContext
The IXmlAttributeContext that contains context information related to the target attribute.
Remarks
This property is only populated if the context is related to an attribute.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.TargetElement Property

IXmlContextTargetElement Property

Gets the IXmlElementContext that contains context information related to the target element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IXmlElementContext TargetElement { get; }
ReadOnly Property TargetElement As IXmlElementContext
    Get

Property Value

Type: IXmlElementContext
The IXmlElementContext that contains context information related to the target element.
Remarks
This property is only populated if the context is related to an element or attribute.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.Type Property

IXmlContextType Property

Gets an XmlContextType that specifies the type of context.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
XmlContextType Type { get; }
ReadOnly Property Type As XmlContextType
    Get

Property Value

Type: XmlContextType
An XmlContextType that specifies the type of context.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext Interface

Provides the base requirements for resolved information about a XML element related to an IXmlContext.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IXmlElementContext
Public Interface IXmlElementContext

The IXmlElementContext type exposes the following members.

Properties
 | Name | Description
Public property | AstNode | Gets the IAstNode that defines the element, if known.
Public property | Attributes | Gets the dictionary of attributes for this element.
Public property | EndTagSnapshotRange | Gets the nullable TextSnapshotRange that specifies the range of the end tag, if there is one.
Public property | Name | Gets the name of the element.
Public property | Namespace | Gets the namespace that defines the element.
Public property | NamespacePrefix | Gets the prefix of the namespace that defines the element.
Public property | QualifiedName | Gets the XmlQualifiedName that contains the element's qualified name.
Public property | SchemaElement | Gets the resolved XmlSchemaElement for this element, if known.
Public property | StartTagNameSnapshotRange | Gets the TextSnapshotRange that specifies the range of the start tag name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext Properties

The IXmlElementContext type exposes the following members.

Properties
 | Name | Description
Public property | AstNode | Gets the IAstNode that defines the element, if known.
Public property | Attributes | Gets the dictionary of attributes for this element.
Public property | EndTagSnapshotRange | Gets the nullable TextSnapshotRange that specifies the range of the end tag, if there is one.
Public property | Name | Gets the name of the element.
Public property | Namespace | Gets the namespace that defines the element.
Public property | NamespacePrefix | Gets the prefix of the namespace that defines the element.
Public property | QualifiedName | Gets the XmlQualifiedName that contains the element's qualified name.
Public property | SchemaElement | Gets the resolved XmlSchemaElement for this element, if known.
Public property | StartTagNameSnapshotRange | Gets the TextSnapshotRange that specifies the range of the start tag name.
Top
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.AstNode Property

IXmlElementContextAstNode Property

Gets the IAstNode that defines the element, if known.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode AstNode { get; }
ReadOnly Property AstNode As IAstNode
    Get

Property Value

Type: IAstNode
The IAstNode that defines the element, if known.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.Attributes Property

IXmlElementContextAttributes Property

Gets the dictionary of attributes for this element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDictionary<XmlQualifiedName, IXmlAttributeContext> Attributes { get; }
ReadOnly Property Attributes As IDictionary(Of XmlQualifiedName, IXmlAttributeContext)
    Get

Property Value

Type: IDictionary XmlQualifiedName, IXmlAttributeContext
The dictionary of attributes for this element.
Remarks
The dictionary keys are the attribute qualified names and the values are IXmlAttributeContext objects.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.EndTagSnapshotRange Property

IXmlElementContextEndTagSnapshotRange Property

Gets the nullable TextSnapshotRange that specifies the range of the end tag, if there is one.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotRange> EndTagSnapshotRange { get; }
ReadOnly Property EndTagSnapshotRange As Nullable(Of TextSnapshotRange)
    Get

Property Value

Type: Nullable TextSnapshotRange
The nullable TextSnapshotRange that specifies the range of the end tag, if there is one.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.Name Property

IXmlElementContextName Property

Gets the name of the element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the element.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.Namespace Property

IXmlElementContextNamespace Property

Gets the namespace that defines the element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Namespace { get; }
ReadOnly Property Namespace As String
    Get

Property Value

Type: String
The namespace that defines the element.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.NamespacePrefix Property

IXmlElementContextNamespacePrefix Property

Gets the prefix of the namespace that defines the element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string NamespacePrefix { get; }
ReadOnly Property NamespacePrefix As String
    Get

Property Value

Type: String
The prefix of the namespace that defines the element.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.QualifiedName Property

IXmlElementContextQualifiedName Property

Gets the XmlQualifiedName that contains the element's qualified name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
XmlQualifiedName QualifiedName { get; }
ReadOnly Property QualifiedName As XmlQualifiedName
    Get

Property Value

Type: XmlQualifiedName
The XmlQualifiedName that contains the element's qualified name.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.SchemaElement Property

IXmlElementContextSchemaElement Property

Gets the resolved XmlSchemaElement for this element, if known.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
XmlSchemaElement SchemaElement { get; }
ReadOnly Property SchemaElement As XmlSchemaElement
    Get

Property Value

Type: XmlSchemaElement
The resolved XmlSchemaElement for this element, if known.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.StartTagNameSnapshotRange Property

IXmlElementContextStartTagNameSnapshotRange Property

Gets the TextSnapshotRange that specifies the range of the start tag name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotRange StartTagNameSnapshotRange { get; }
ReadOnly Property StartTagNameSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that specifies the range of the start tag name.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlEndTagAutoCompleter Interface

Provides the base requirements for a class that can auto-complete XML end tags when appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IXmlEndTagAutoCompleter
Public Interface IXmlEndTagAutoCompleter

The IXmlEndTagAutoCompleter type exposes the following members.

Methods
 | Name | Description
Public method | AutoComplete | Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlEndTagAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace
ActiproSoftware.Text.Languages.Xml.ImplementationXmlEndTagAutoCompleter


IXmlEndTagAutoCompleter Methods

The IXmlEndTagAutoCompleter type exposes the following members.

Methods
 | Name | Description
Public method | AutoComplete | Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.
Top
See Also

Reference

IXmlEndTagAutoCompleter Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlEndTagAutoCompleter.AutoComplete Method

IXmlEndTagAutoCompleterAutoComplete Method

Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void AutoComplete(
    IEditorView view
)
Sub AutoComplete (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.
See Also

Reference

IXmlEndTagAutoCompleter Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver Interface

Provides the base requirements for a class that can manage XML schema data.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IXmlSchemaResolver
Public Interface IXmlSchemaResolver

The IXmlSchemaResolver type exposes the following members.

Properties
 | Name | Description
Public property | DefaultNamespace | Gets or sets the default XML namespace to use.
Public property | DefaultNamespacePrefixMappings | Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Public property | SchemaSet | Gets or sets the XmlSchemaSet to use.
Top
Methods
 | Name | Description
Public method | GetChildSchemaElement | Returns the child XmlSchemaElement that has the specified qualified name.
Public method | GetChildSchemaElements | Returns the child XmlSchemaElement objects.
Public method | GetDocumentation | Returns the XSD documentation for the specified source object.
Public method | GetGlobalSchemaElement | Returns the global XmlSchemaElement that has the specified qualified name.
Public method | GetGlobalSchemaElements | Returns the collection of global XmlSchemaElement objects.
Public method | GetSchemaAttributes | Returns the child XmlSchemaAttribute objects.
Public method | ResolveSchemaAttribute | Resolves the specified XmlSchemaAttribute in the event it is a reference to another XmlSchemaAttribute.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlSchemaResolver interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace
ActiproSoftware.Text.Languages.Xml.ImplementationXmlSchemaResolver


IXmlSchemaResolver Properties

The IXmlSchemaResolver type exposes the following members.

Properties
 | Name | Description
Public property | DefaultNamespace | Gets or sets the default XML namespace to use.
Public property | DefaultNamespacePrefixMappings | Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Public property | SchemaSet | Gets or sets the XmlSchemaSet to use.
Top
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.DefaultNamespace Property

IXmlSchemaResolverDefaultNamespace Property

Gets or sets the default XML namespace to use.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string DefaultNamespace { get; set; }
Property DefaultNamespace As String
    Get
    Set

Property Value

Type: String
The default XML namespace to use.
Remarks
The default namespace is used to mimic an xmlns attribute setting on the root element, if no xmlns attribute is present. It sets an empty-string-keyed value into the DefaultNamespacePrefixMappings dictionary.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.DefaultNamespacePrefixMappings Property

IXmlSchemaResolverDefaultNamespacePrefixMappings Property

Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDictionary<string, string> DefaultNamespacePrefixMappings { get; }
ReadOnly Property DefaultNamespacePrefixMappings As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionary String, String
The mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Remarks
The dictionary keys are namespace prefixes and the values are namespaces. The namespace declarations in this dictionary are used to mimic xmlns attribute settings on the root element when no xmlns declaration attributes for the specified namespace prefix keys are present.

The DefaultNamespace property is simply a wrapper for setting an empty-string-keyed value in this dictionary.

See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.SchemaSet Property

IXmlSchemaResolverSchemaSet Property

Gets or sets the XmlSchemaSet to use.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
XmlSchemaSet SchemaSet { get; set; }
Property SchemaSet As XmlSchemaSet
    Get
    Set

Property Value

Type: XmlSchemaSet
The XmlSchemaSet to use.
Remarks
This property can be set if you already have a XmlSchemaSet loaded that should directly be used.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver Methods

The IXmlSchemaResolver type exposes the following members.

Methods
 | Name | Description
Public method | GetChildSchemaElement | Returns the child XmlSchemaElement that has the specified qualified name.
Public method | GetChildSchemaElements | Returns the child XmlSchemaElement objects.
Public method | GetDocumentation | Returns the XSD documentation for the specified source object.
Public method | GetGlobalSchemaElement | Returns the global XmlSchemaElement that has the specified qualified name.
Public method | GetGlobalSchemaElements | Returns the collection of global XmlSchemaElement objects.
Public method | GetSchemaAttributes | Returns the child XmlSchemaAttribute objects.
Public method | ResolveSchemaAttribute | Resolves the specified XmlSchemaAttribute in the event it is a reference to another XmlSchemaAttribute.
Top
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.GetChildSchemaElement Method

IXmlSchemaResolverGetChildSchemaElement Method

Returns the child XmlSchemaElement that has the specified qualified name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
XmlSchemaElement GetChildSchemaElement(
    XmlSchemaElement parentElement,
    XmlQualifiedName name
)
Function GetChildSchemaElement (
    parentElement As XmlSchemaElement,
    name As XmlQualifiedName
) As XmlSchemaElement

Parameters

parentElement
Type: System.Xml.SchemaXmlSchemaElement
The parent XmlSchemaElement.
name
Type: System.XmlXmlQualifiedName
The XmlQualifiedName for which to search.

Return Value

Type: XmlSchemaElement
The child XmlSchemaElement that has the specified qualified name.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.GetChildSchemaElements Method

IXmlSchemaResolverGetChildSchemaElements Method

Returns the child XmlSchemaElement objects.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<XmlSchemaElement> GetChildSchemaElements(
    XmlSchemaElement parentElement
)
Function GetChildSchemaElements (
    parentElement As XmlSchemaElement
) As IEnumerable(Of XmlSchemaElement)

Parameters

parentElement
Type: System.Xml.SchemaXmlSchemaElement
The parent XmlSchemaElement.

Return Value

Type: IEnumerable XmlSchemaElement
The child XmlSchemaElement objects.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.GetDocumentation Method

IXmlSchemaResolverGetDocumentation Method

Returns the XSD documentation for the specified source object.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetDocumentation(
    XmlSchemaAnnotated source
)
Function GetDocumentation (
    source As XmlSchemaAnnotated
) As String

Parameters

source
Type: System.Xml.SchemaXmlSchemaAnnotated
The source XmlSchemaAnnotated for which the documentation is being retrieved.

Return Value

Type: String
The documentation that was retrieved.
Remarks
The default implementation of this method appends the inner text of all the XmlSchemaDocumentation child nodes together, with whitespace in between.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.GetGlobalSchemaElement Method

IXmlSchemaResolverGetGlobalSchemaElement Method

Returns the global XmlSchemaElement that has the specified qualified name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
XmlSchemaElement GetGlobalSchemaElement(
    XmlQualifiedName name
)
Function GetGlobalSchemaElement (
    name As XmlQualifiedName
) As XmlSchemaElement

Parameters

name
Type: System.XmlXmlQualifiedName
The XmlQualifiedName for which to search.

Return Value

Type: XmlSchemaElement
The global XmlSchemaElement that has the specified qualified name.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.GetGlobalSchemaElements Method

IXmlSchemaResolverGetGlobalSchemaElements Method

Returns the collection of global XmlSchemaElement objects.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<XmlSchemaElement> GetGlobalSchemaElements()
Function GetGlobalSchemaElements As IEnumerable(Of XmlSchemaElement)

Return Value

Type: IEnumerable XmlSchemaElement
The collection of global XmlSchemaElement objects.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.GetSchemaAttributes Method

IXmlSchemaResolverGetSchemaAttributes Method

Returns the child XmlSchemaAttribute objects.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<XmlSchemaAttribute> GetSchemaAttributes(
    XmlSchemaElement parentElement
)
Function GetSchemaAttributes (
    parentElement As XmlSchemaElement
) As IEnumerable(Of XmlSchemaAttribute)

Parameters

parentElement
Type: System.Xml.SchemaXmlSchemaElement
The parent XmlSchemaElement.

Return Value

Type: IEnumerable XmlSchemaAttribute
The child XmlSchemaAttribute objects.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.ResolveSchemaAttribute Method

IXmlSchemaResolverResolveSchemaAttribute Method

Resolves the specified XmlSchemaAttribute in the event it is a reference to another XmlSchemaAttribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
XmlSchemaAttribute ResolveSchemaAttribute(
    XmlSchemaAttribute attribute
)
Function ResolveSchemaAttribute (
    attribute As XmlSchemaAttribute
) As XmlSchemaAttribute

Parameters

attribute
Type: System.Xml.SchemaXmlSchemaAttribute
The XmlSchemaAttribute to examine.

Return Value

Type: XmlSchemaAttribute
The resolved XmlSchemaAttribute.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlValidator Interface

Provides the base requirements for a class that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IXmlValidator
Public Interface IXmlValidator

The IXmlValidator type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Validates the XML that is being parsed.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlValidator interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace
ActiproSoftware.Text.Languages.Xml.ImplementationXmlValidator


IXmlValidator Methods

The IXmlValidator type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Validates the XML that is being parsed.
Top
See Also

Reference

IXmlValidator Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlValidator.Validate Method

IXmlValidatorValidate Method

Validates the XML that is being parsed.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<IParseError> Validate(
    IParseRequest request,
    IAstNode ast
)
Function Validate (
    request As IParseRequest,
    ast As IAstNode
) As IEnumerable(Of IParseError)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
ast
Type: ActiproSoftware.Text.ParsingIAstNode
The root IAstNode of the parse result AST, if known.

Return Value

Type: IEnumerable IParseError
The collection of validation errors that were found, if any.
See Also

Reference

IXmlValidator Interface
ActiproSoftware.Text.Languages.Xml Namespace


XmlAttributeSpacingMode Enumeration

The attribute spacing modes that an XmlTextFormatter can use.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum XmlAttributeSpacingMode
Public Enumeration XmlAttributeSpacingMode
Members
Member name | Value | Description
Preserve | 0 | The attribute spacing is not modified.
NormalizeWhitespace | 1 | Attributes will be separated by a single space.
SeparateLines | 2 | Each attribute will be on a separate line.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType Enumeration

Specifies the type of IXmlContext.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum XmlContextType
Public Enumeration XmlContextType
Members
Member name | Value | Description
None | 0 | No context.
Default | 1 | In default area (between elements or in an element block).
StartTagName | 2 | At the name of a start tag.
StartTagDefault | 3 | After the start tag name, and possibly between attributes.
StartTagAttributeName | 4 | At the name of an attribute.
StartTagAttributeValue | 5 | At the value of an attribute.
StartTagOther | 6 | At another part of a start tag.
EndTagName | 7 | At the name of an end tag.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


XmlElementSpacingMode Enumeration

The element spacing modes that an XmlTextFormatter can use.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum XmlElementSpacingMode
Public Enumeration XmlElementSpacingMode
Members
Member name | Value | Description
Preserve | 0 | The element spacing is not modified.
NormalizeEmptyLines | 1 | Elements will be separated by an empty line and extra empty lines will be removed.
RemoveEmptyLines | 2 | Elements will be on their own line an empty lines will be removed.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions Class

Contains extension methods that make it easier to work with XML ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.XmlXmlSyntaxLanguageExtensions

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class XmlSyntaxLanguageExtensions
<ExtensionAttribute>
Public NotInheritable Class XmlSyntaxLanguageExtensions

The XmlSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data.
GetXmlValidator | Returns the IXmlValidator that can validate XML.
RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data.
RegisterXmlValidator | Registers the IXmlValidator that can validate XML.
UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data.
UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions Methods

The XmlSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data.
GetXmlValidator | Returns the IXmlValidator that can validate XML.
RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data.
RegisterXmlValidator | Registers the IXmlValidator that can validate XML.
UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data.
UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML.
Top
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.GetXmlEndTagAutoCompleter Method

XmlSyntaxLanguageExtensionsGetXmlEndTagAutoCompleter Method

Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IXmlEndTagAutoCompleter GetXmlEndTagAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetXmlEndTagAutoCompleter (
    language As ISyntaxLanguage
) As IXmlEndTagAutoCompleter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IXmlEndTagAutoCompleter
The IXmlEndTagAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.GetXmlSchemaResolver Method

XmlSyntaxLanguageExtensionsGetXmlSchemaResolver Method

Returns the IXmlSchemaResolver that can manage XML schema data.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IXmlSchemaResolver GetXmlSchemaResolver(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetXmlSchemaResolver (
    language As ISyntaxLanguage
) As IXmlSchemaResolver

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IXmlSchemaResolver
The IXmlSchemaResolver instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.GetXmlValidator Method

XmlSyntaxLanguageExtensionsGetXmlValidator Method

Returns the IXmlValidator that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IXmlValidator GetXmlValidator(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetXmlValidator (
    language As ISyntaxLanguage
) As IXmlValidator

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IXmlValidator
The IXmlValidator instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.RegisterXmlEndTagAutoCompleter Method

XmlSyntaxLanguageExtensionsRegisterXmlEndTagAutoCompleter Method

Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterXmlEndTagAutoCompleter(
    this ISyntaxLanguage language,
    IXmlEndTagAutoCompleter value
)
<ExtensionAttribute>
Public Shared Sub RegisterXmlEndTagAutoCompleter (
    language As ISyntaxLanguage,
    value As IXmlEndTagAutoCompleter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.XmlIXmlEndTagAutoCompleter
The IXmlEndTagAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.RegisterXmlSchemaResolver Method

XmlSyntaxLanguageExtensionsRegisterXmlSchemaResolver Method

Registers the IXmlSchemaResolver that can manage XML schema data.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterXmlSchemaResolver(
    this ISyntaxLanguage language,
    IXmlSchemaResolver value
)
<ExtensionAttribute>
Public Shared Sub RegisterXmlSchemaResolver (
    language As ISyntaxLanguage,
    value As IXmlSchemaResolver
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.XmlIXmlSchemaResolver
The IXmlSchemaResolver instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.RegisterXmlValidator Method

XmlSyntaxLanguageExtensionsRegisterXmlValidator Method

Registers the IXmlValidator that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void RegisterXmlValidator(
    this ISyntaxLanguage language,
    IXmlValidator value
)
<ExtensionAttribute>
Public Shared Sub RegisterXmlValidator (
    language As ISyntaxLanguage,
    value As IXmlValidator
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.XmlIXmlValidator
The IXmlValidator instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.UnregisterXmlEndTagAutoCompleter Method

XmlSyntaxLanguageExtensionsUnregisterXmlEndTagAutoCompleter Method

Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterXmlEndTagAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterXmlEndTagAutoCompleter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.UnregisterXmlSchemaResolver Method

XmlSyntaxLanguageExtensionsUnregisterXmlSchemaResolver Method

Unregisters the IXmlSchemaResolver that can manage XML schema data.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterXmlSchemaResolver(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterXmlSchemaResolver (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.UnregisterXmlValidator Method

XmlSyntaxLanguageExtensionsUnregisterXmlValidator Method

Unregisters the IXmlValidator that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void UnregisterXmlValidator(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterXmlValidator (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlValidationMode Enumeration

Specifies the validation mode for an IXmlValidator.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum XmlValidationMode
Public Enumeration XmlValidationMode
Members
Member name | Value | Description
None | 0 | No validation.
Schema | 1 | Schema validation, but no DTD support.
Dtd | 2 | DTD validation, but no schema support.
SchemaWithDtd | 3 | Schema validation, with ability to examine DTDs for entities.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace

Contains the implementation types related to ASTs for a XML syntax language.
Classes
 | Class | Description
Public class | CDataSection | Represents a cData section.
Public class | Comment | Represents a comment.
Public class | CompilationUnit | Represents a compilation unit.
Public class | Declaration | Represents a declaration.
Public class | Element | Represents an element.
Public class | ElementAttribute | Represents an element attribute.
Public class | ElementContent | Represents an element content.
Public class | EndTag | Represents an end tag.
Public class | ProcessingInstruction | Represents a processing instruction.
Public class | XmlAstNodeId | Contains the AST node IDs for the XML language.


CDataSection Class

Represents a cData section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationCDataSection

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CDataSection : AstNodeBase
Public Class CDataSection
    Inherits AstNodeBase

The CDataSection type exposes the following members.

Constructors
 | Name | Description
Public method | CDataSection | Initializes a new instance of the CDataSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CDataSection Constructor

Initializes a new instance of the CDataSection class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CDataSection()
Public Sub New
See Also

Reference

CDataSection Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CDataSection Properties

The CDataSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CDataSection Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CDataSection.Id Property

CDataSectionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CDataSection Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CDataSection Methods

The CDataSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CDataSection Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment Class

Represents a comment.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationComment

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Comment : AstNodeBase
Public Class Comment
    Inherits AstNodeBase

The Comment type exposes the following members.

Constructors
 | Name | Description
Public method | Comment | Initializes a new instance of the Comment class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment Constructor

Initializes a new instance of the Comment class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Comment()
Public Sub New
See Also

Reference

Comment Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment Properties

The Comment type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Comment Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment.Id Property

CommentId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Comment Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment Methods

The Comment type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Comment Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit Class

Represents a compilation unit.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationCompilationUnit

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CompilationUnit : AstNodeBase
Public Class CompilationUnit
    Inherits AstNodeBase

The CompilationUnit type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnit | Initializes a new instance of the CompilationUnit class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit Constructor

Initializes a new instance of the CompilationUnit class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CompilationUnit()
Public Sub New
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit Properties

The CompilationUnit type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit.HasNodes Property

CompilationUnitHasNodes Property

Returns whether the Nodes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasNodes { get; }
Public ReadOnly Property HasNodes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit.Id Property

CompilationUnitId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit.Nodes Property

CompilationUnitNodes Property

Gets the nodes.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Nodes { get; }
Public ReadOnly Property Nodes As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The nodes.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit Methods

The CompilationUnit type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit.GetChildrenEnumerator Method

CompilationUnitGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration Class

Represents a declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationDeclaration

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Declaration : AstNodeBase
Public Class Declaration
    Inherits AstNodeBase

The Declaration type exposes the following members.

Constructors
 | Name | Description
Public method | Declaration | Initializes a new instance of the Declaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.611.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration Constructor

Initializes a new instance of the Declaration class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Declaration()
Public Sub New
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration Properties

The Declaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration.HasNodes Property

DeclarationHasNodes Property

Returns whether the Nodes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasNodes { get; }
Public ReadOnly Property HasNodes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration.Id Property

DeclarationId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration.Nodes Property

DeclarationNodes Property

Gets the nodes.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Nodes { get; }
Public ReadOnly Property Nodes As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The nodes.
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration Methods

The Declaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration.GetChildrenEnumerator Method

DeclarationGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element Class

Represents an element.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElement

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Element : AstNodeBase
Public Class Element
    Inherits AstNodeBase

The Element type exposes the following members.

Constructors
 | Name | Description
Public method | Element | Initializes a new instance of the Element class
Top
Properties
 | Name | Description
Public property | Attributes | Gets the attributes.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Content | Gets or sets the content.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EndTag | Gets or sets the end tag.
Public property | HasAttributes | Returns whether the Attributes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element Constructor

Initializes a new instance of the Element class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Element()
Public Sub New
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element Properties

The Element type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets the attributes.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Content | Gets or sets the content.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EndTag | Gets or sets the end tag.
Public property | HasAttributes | Returns whether the Attributes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.Attributes Property

ElementAttributes Property

Gets the attributes.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<ElementAttribute> Attributes { get; }
Public ReadOnly Property Attributes As IList(Of ElementAttribute)
    Get

Property Value

Type: IList ElementAttribute
The attributes.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.Content Property

ElementContent Property

Gets or sets the content.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ElementContent Content { get; set; }
Public Property Content As ElementContent
    Get
    Set

Property Value

Type: ElementContent
The content.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.EndTag Property

ElementEndTag Property

Gets or sets the end tag.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EndTag EndTag { get; set; }
Public Property EndTag As EndTag
    Get
    Set

Property Value

Type: EndTag
The end tag.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.HasAttributes Property

ElementHasAttributes Property

Returns whether the Attributes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasAttributes { get; }
Public ReadOnly Property HasAttributes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.Id Property

ElementId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.Name Property

ElementName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element Methods

The Element type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.GetChildrenEnumerator Method

ElementGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute Class

Represents an element attribute.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementAttribute

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ElementAttribute : AstNodeBase
Public Class ElementAttribute
    Inherits AstNodeBase

The ElementAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ElementAttribute | Initializes a new instance of the ElementAttribute class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TextValue | Gets or sets the text value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute Constructor

Initializes a new instance of the ElementAttribute class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ElementAttribute()
Public Sub New
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute Properties

The ElementAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TextValue | Gets or sets the text value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute.Id Property

ElementAttributeId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute.Name Property

ElementAttributeName Property

Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute.TextValue Property

ElementAttributeTextValue Property

Gets or sets the text value.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TextValue { get; set; }
Public Property TextValue As String
    Get
    Set

Property Value

Type: String
The text value.
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute Methods

The ElementAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent Class

Represents an element content.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementContent

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ElementContent : AstNodeBase
Public Class ElementContent
    Inherits AstNodeBase

The ElementContent type exposes the following members.

Constructors
 | Name | Description
Public method | ElementContent | Initializes a new instance of the ElementContent class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent Constructor

Initializes a new instance of the ElementContent class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ElementContent()
Public Sub New
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent Properties

The ElementContent type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent.HasNodes Property

ElementContentHasNodes Property

Returns whether the Nodes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasNodes { get; }
Public ReadOnly Property HasNodes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent.Id Property

ElementContentId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent.Nodes Property

ElementContentNodes Property

Gets the nodes.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Nodes { get; }
Public ReadOnly Property Nodes As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The nodes.
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent Methods

The ElementContent type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent.GetChildrenEnumerator Method

ElementContentGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag Class

Represents an end tag.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationEndTag

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EndTag : AstNodeBase
Public Class EndTag
    Inherits AstNodeBase

The EndTag type exposes the following members.

Constructors
 | Name | Description
Public method | EndTag | Initializes a new instance of the EndTag class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag Constructor

Initializes a new instance of the EndTag class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EndTag()
Public Sub New
See Also

Reference

EndTag Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag Properties

The EndTag type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EndTag Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag.Id Property

EndTagId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

EndTag Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag Methods

The EndTag type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EndTag Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction Class

Represents a processing instruction.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationProcessingInstruction

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ProcessingInstruction : AstNodeBase
Public Class ProcessingInstruction
    Inherits AstNodeBase

The ProcessingInstruction type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessingInstruction | Initializes a new instance of the ProcessingInstruction class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction Constructor

Initializes a new instance of the ProcessingInstruction class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ProcessingInstruction()
Public Sub New
See Also

Reference

ProcessingInstruction Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction Properties

The ProcessingInstruction type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ProcessingInstruction Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction.Id Property

ProcessingInstructionId Property

Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ProcessingInstruction Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction Methods

The ProcessingInstruction type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ProcessingInstruction Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Class

Contains the AST node IDs for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationXmlAstNodeId

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlAstNodeId : AstNodeIdProviderBase
Public Class XmlAstNodeId
    Inherits AstNodeIdProviderBase

The XmlAstNodeId type exposes the following members.

Constructors
 | Name | Description
Public method | XmlAstNodeId | Initializes a new instance of the XmlAstNodeId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Top
Fields
Name | Description
CDataSection | Gets the CDataSection AST node ID.
Comment | Gets the Comment AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
Declaration | Gets the Declaration AST node ID.
Element | Gets the Element AST node ID.
ElementAttribute | Gets the ElementAttribute AST node ID.
ElementContent | Gets the ElementContent AST node ID.
EndTag | Gets the EndTag AST node ID.
ProcessingInstruction | Gets the ProcessingInstruction AST node ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Constructor

Initializes a new instance of the XmlAstNodeId class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlAstNodeId()
Public Sub New
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Properties

The XmlAstNodeId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.MaxId Property

XmlAstNodeIdMaxId Property

Gets the maximum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum AST node ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.MinId Property

XmlAstNodeIdMinId Property

Gets the minimum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum AST node ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Methods

The XmlAstNodeId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Top
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.ContainsId Method

XmlAstNodeIdContainsId Method

Returns whether the specified ID value is valid for this AST node ID provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.GetDescription Method

XmlAstNodeIdGetDescription Method

Returns the actual string representation for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The actual string representation for the specified AST node ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.GetKey Method

XmlAstNodeIdGetKey Method

Returns the string-based key for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The string-based key for the specified AST node ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Fields

The XmlAstNodeId type exposes the following members.

Fields
Name | Description
CDataSection | Gets the CDataSection AST node ID.
Comment | Gets the Comment AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
Declaration | Gets the Declaration AST node ID.
Element | Gets the Element AST node ID.
ElementAttribute | Gets the ElementAttribute AST node ID.
ElementContent | Gets the ElementContent AST node ID.
EndTag | Gets the EndTag AST node ID.
ProcessingInstruction | Gets the ProcessingInstruction AST node ID.
Top
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.CDataSection Field

XmlAstNodeIdCDataSection Field

Gets the CDataSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CDataSection = 15001
Public Const CDataSection As Integer = 15001

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.Comment Field

XmlAstNodeIdComment Field

Gets the Comment AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Comment = 15002
Public Const Comment As Integer = 15002

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.CompilationUnit Field

XmlAstNodeIdCompilationUnit Field

Gets the CompilationUnit AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CompilationUnit = 15000
Public Const CompilationUnit As Integer = 15000

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.Declaration Field

XmlAstNodeIdDeclaration Field

Gets the Declaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Declaration = 15003
Public Const Declaration As Integer = 15003

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.Element Field

XmlAstNodeIdElement Field

Gets the Element AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Element = 15004
Public Const Element As Integer = 15004

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.ElementAttribute Field

XmlAstNodeIdElementAttribute Field

Gets the ElementAttribute AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ElementAttribute = 15005
Public Const ElementAttribute As Integer = 15005

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.ElementContent Field

XmlAstNodeIdElementContent Field

Gets the ElementContent AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ElementContent = 15006
Public Const ElementContent As Integer = 15006

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.EndTag Field

XmlAstNodeIdEndTag Field

Gets the EndTag AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EndTag = 15007
Public Const EndTag As Integer = 15007

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.ProcessingInstruction Field

XmlAstNodeIdProcessingInstruction Field

Gets the ProcessingInstruction AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ProcessingInstruction = 15008
Public Const ProcessingInstruction As Integer = 15008

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ActiproSoftware.Text.Languages.Xml.Implementation Namespace

Contains the core classes related to implementing an XML syntax language.
Classes
 | Class | Description
Public class | XmlClassificationTypeProvider | Represents a provider of IClassificationType objects for the XML language.
Public class | XmlCodeBlockFinder | Provides a XML language code block finder service.
Public class | XmlCompletionProvider | Provides IntelliPrompt completion data for the XML language.
Public class | XmlCompletionSession | Represents an IntelliPrompt completion session.
Public class | XmlContextFactory | Creates IXmlContext objects for a TextSnapshotOffset.
Public class | XmlEndTagAutoCompleter | Provides a class that can auto-complete XML end tags when appropriate.
Public class | XmlExampleTextProvider | Represents a example text provider for the XML language.
Public class | XmlGrammar | Represents a Grammar for the XML language.
Public class | XmlIndentProvider | Provides a XML language indent provider service.
Public class | XmlLexer | Represents a lexer for the XML language.
Public class | XmlLexicalStateId | Contains the lexical state IDs for the XML language.
Public class | XmlLineCommenter | Provides a XML language line commenter service.
Public class | XmlNavigableSymbolProvider | Represents a navigable symbol provider for the XML language.
Public class | XmlOutliner | Provides a XML language outliner service.
Public class | XmlParseData | Stores the results of a XML language parsing operation.
Public class | XmlParser | Represents a parser for the XML language.
Public class | XmlParserBase | Provides an abstract base class of a parser for the XML language.
Public class | XmlParserContext | Stores parser context information for a XML language grammar parser.
Public class | XmlQuickInfoProvider | Provides IntelliPrompt quick info data for the XML language.
Public class | XmlSchemaResolver | Provides a class that can manage XML schema data.
Public class | XmlSyntaxLanguage | Represents a XML syntax language definition.
Public class | XmlTextFormatter | Provides a XML language text formatter service.
Public class | XmlTokenId | Contains the token IDs for the XML language.
Public class | XmlTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the XML language.
Public class | XmlTokenTagger | Represents a token tagger for the XML language.
Public class | XmlTokenTaggerProvider | Represents a provider of XmlTokenTagger objects for documents that use the XmlTokenTagger language.
Public class | XmlTokenTaggerProviderTaggerFactory | Implements a factory that can creates XmlTokenTagger objects for a document.
Public class | XmlValidator | Provides a class that can validate XML, using the schemas in an IXmlSchemaResolver if available.
Interfaces
 | Interface | Description
Public interface | IXmlParseData | Provides the base requirements of an object that stores the results of a XML language parsing operation.


IXmlParseData Interface

Provides the base requirements of an object that stores the results of a XML language parsing operation.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IXmlParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IXmlParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IXmlParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | IsWellFormed | Gets whether the XML is well-formed.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParseData


IXmlParseData Properties

The IXmlParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | IsWellFormed | Gets whether the XML is well-formed.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

IXmlParseData Interface
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


IXmlParseData.IsWellFormed Property

IXmlParseDataIsWellFormed Property

Gets whether the XML is well-formed.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsWellFormed { get; }
ReadOnly Property IsWellFormed As Boolean
    Get

Property Value

Type: Boolean
true if the XML is well-formed; otherwise, false.
See Also

Reference

IXmlParseData Interface
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Class

Represents a provider of IClassificationType objects for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlClassificationTypeProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlClassificationTypeProvider : IXmlClassificationTypeProvider
Public Class XmlClassificationTypeProvider
    Implements IXmlClassificationTypeProvider

The XmlClassificationTypeProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlClassificationTypeProvider | Initializes a new instance of the XmlClassificationTypeProvider class.
Public method | XmlClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the XmlClassificationTypeProvider class.
Top
Properties
 | Name | Description
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | XmlAttribute | Gets the XmlAttribute classification type.
Public property | XmlAttributeValue | Gets the XmlAttributeValue classification type.
Public property | XmlCDataSection | Gets the XmlCDataSection classification type.
Public property | XmlComment | Gets the XmlComment classification type.
Public property | XmlDeclaration | Gets the XmlDeclaration classification type.
Public property | XmlDelimiter | Gets the XmlDelimiter classification type.
Public property | XmlEntity | Gets the XmlEntity classification type.
Public property | XmlName | Gets the XmlName classification type.
Public property | XmlProcessingInstruction | Gets the XmlProcessingInstruction classification type.
Top
Methods
 | Name | Description
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Top
Remarks
This type was generated by the Actipro Language Designer tool v10.2.530.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Constructor

Overload List
 | Name | Description
Public method | XmlClassificationTypeProvider | Initializes a new instance of the XmlClassificationTypeProvider class.
Public method | XmlClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the XmlClassificationTypeProvider class.
Top
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Constructor

Initializes a new instance of the XmlClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlClassificationTypeProvider()
Public Sub New
See Also

Reference

XmlClassificationTypeProvider Class
XmlClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Constructor (IHighlightingStyleRegistry)

Initializes a new instance of the XmlClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlClassificationTypeProvider(
    IHighlightingStyleRegistry targetRegistry
)
Public Sub New (
    targetRegistry As IHighlightingStyleRegistry
)

Parameters

targetRegistry
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

XmlClassificationTypeProvider Class
XmlClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Properties

The XmlClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | XmlAttribute | Gets the XmlAttribute classification type.
Public property | XmlAttributeValue | Gets the XmlAttributeValue classification type.
Public property | XmlCDataSection | Gets the XmlCDataSection classification type.
Public property | XmlComment | Gets the XmlComment classification type.
Public property | XmlDeclaration | Gets the XmlDeclaration classification type.
Public property | XmlDelimiter | Gets the XmlDelimiter classification type.
Public property | XmlEntity | Gets the XmlEntity classification type.
Public property | XmlName | Gets the XmlName classification type.
Public property | XmlProcessingInstruction | Gets the XmlProcessingInstruction classification type.
Top
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.Registry Property

XmlClassificationTypeProviderRegistry Property

Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry Registry { get; }
Public ReadOnly Property Registry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlAttribute Property

XmlClassificationTypeProviderXmlAttribute Property

Gets the XmlAttribute classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlAttribute { get; }
Public ReadOnly Property XmlAttribute As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlAttribute classification type.

Implements

IXmlClassificationTypeProviderXmlAttribute
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlAttributeValue Property

XmlClassificationTypeProviderXmlAttributeValue Property

Gets the XmlAttributeValue classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlAttributeValue { get; }
Public ReadOnly Property XmlAttributeValue As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlAttributeValue classification type.

Implements

IXmlClassificationTypeProviderXmlAttributeValue
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlCDataSection Property

XmlClassificationTypeProviderXmlCDataSection Property

Gets the XmlCDataSection classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlCDataSection { get; }
Public ReadOnly Property XmlCDataSection As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlCDataSection classification type.

Implements

IXmlClassificationTypeProviderXmlCDataSection
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlComment Property

XmlClassificationTypeProviderXmlComment Property

Gets the XmlComment classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlComment { get; }
Public ReadOnly Property XmlComment As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlComment classification type.

Implements

IXmlClassificationTypeProviderXmlComment
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlDeclaration Property

XmlClassificationTypeProviderXmlDeclaration Property

Gets the XmlDeclaration classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlDeclaration { get; }
Public ReadOnly Property XmlDeclaration As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDeclaration classification type.

Implements

IXmlClassificationTypeProviderXmlDeclaration
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlDelimiter Property

XmlClassificationTypeProviderXmlDelimiter Property

Gets the XmlDelimiter classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlDelimiter { get; }
Public ReadOnly Property XmlDelimiter As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDelimiter classification type.

Implements

IXmlClassificationTypeProviderXmlDelimiter
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlEntity Property

XmlClassificationTypeProviderXmlEntity Property

Gets the XmlEntity classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlEntity { get; }
Public ReadOnly Property XmlEntity As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlEntity classification type.

Implements

IXmlClassificationTypeProviderXmlEntity
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlName Property

XmlClassificationTypeProviderXmlName Property

Gets the XmlName classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlName { get; }
Public ReadOnly Property XmlName As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlName classification type.

Implements

IXmlClassificationTypeProviderXmlName
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlProcessingInstruction Property

XmlClassificationTypeProviderXmlProcessingInstruction Property

Gets the XmlProcessingInstruction classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType XmlProcessingInstruction { get; }
Public ReadOnly Property XmlProcessingInstruction As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlProcessingInstruction classification type.

Implements

IXmlClassificationTypeProviderXmlProcessingInstruction
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Methods

The XmlClassificationTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Top
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.RegisterAll Method

XmlClassificationTypeProviderRegisterAll Method

Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<IClassificationType> RegisterAll()
Public Function RegisterAll As IEnumerable(Of IClassificationType)

Return Value

Type: IEnumerable IClassificationType
The collection of IClassificationType objects that were registered.
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder Class

Provides a XML language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.Xml.ImplementationXmlCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlCodeBlockFinder : LLParseDataCodeBlockFinder
Public Class XmlCodeBlockFinder
    Inherits LLParseDataCodeBlockFinder

The XmlCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeBlockFinder | Initializes a new instance of the XmlCodeBlockFinder class
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Overrides LLParseDataCodeBlockFinderGetSnapshotRange(TextSnapshotRange, IAstNode, TextSnapshotRange).)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder Constructor

Initializes a new instance of the XmlCodeBlockFinder class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlCodeBlockFinder()
Public Sub New
See Also

Reference

XmlCodeBlockFinder Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder Properties

The XmlCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

XmlCodeBlockFinder Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder Methods

The XmlCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Overrides LLParseDataCodeBlockFinderGetSnapshotRange(TextSnapshotRange, IAstNode, TextSnapshotRange).)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

XmlCodeBlockFinder Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder.GetSnapshotRange Method

XmlCodeBlockFinderGetSnapshotRange Method

Returns a TextSnapshotRange for the specified IAstNode.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override TextSnapshotRange GetSnapshotRange(
    TextSnapshotRange searchSnapshotRange,
    IAstNode astNode,
    TextSnapshotRange astNodeSnapshotRange
)
Protected Overrides Function GetSnapshotRange (
    searchSnapshotRange As TextSnapshotRange,
    astNode As IAstNode,
    astNodeSnapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

searchSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange from which to begin the search.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode that was found to contain the search snapshot range.
astNodeSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The full snapshot range of the IAstNode.

Return Value

Type: TextSnapshotRange
A TextSnapshotRange for the specified IAstNode.
Remarks
The default implementation of this method returns the astNodeSnapshotRange value. This method can optionally be used to adjust the snapshot range for an AST node as necessary.
See Also

Reference

XmlCodeBlockFinder Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionProvider Class

Provides IntelliPrompt completion data for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlCompletionProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlCompletionProvider : CompletionProviderBase
Public Class XmlCompletionProvider
    Inherits CompletionProviderBase

The XmlCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCompletionProvider | Initializes a new instance of the XmlCompletionProvider class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IXmlContext for the caret's offset in the specified IEditorView.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionProvider Constructor

Initializes a new instance of the XmlCompletionProvider class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlCompletionProvider()
Public Sub New
See Also

Reference

XmlCompletionProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionProvider Properties

The XmlCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

XmlCompletionProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionProvider Methods

The XmlCompletionProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IXmlContext for the caret's offset in the specified IEditorView.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Top
See Also

Reference

XmlCompletionProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionProvider.CreateContext Method

XmlCompletionProviderCreateContext Method

Creates an IXmlContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IXmlContext CreateContext(
    IEditorView view
)
Protected Overridable Function CreateContext (
    view As IEditorView
) As IXmlContext

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IXmlContext
An IXmlContext for the caret's offset in the specified IEditorView.
See Also

Reference

XmlCompletionProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionProvider.OnSessionOpening Method

XmlCompletionProviderOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    ICompletionSession session
)
Protected Overridable Function OnSessionOpening (
    session As ICompletionSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
Remarks
The default implementation of this method sorts the items in the session.
See Also

Reference

XmlCompletionProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionProvider.RequestSession Method

XmlCompletionProviderRequestSession Method

Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Public Overrides Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

ICompletionProviderRequestSession(IEditorView, Boolean)
See Also

Reference

XmlCompletionProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionSession Class

Represents an IntelliPrompt completion session.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationIntelliPromptSessionBase
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionSession
ActiproSoftware.Text.Languages.Xml.ImplementationXmlCompletionSession

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlCompletionSession : CompletionSession
Public Class XmlCompletionSession
    Inherits CompletionSession

The XmlCompletionSession type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCompletionSession | Initializes a new instance of the XmlCompletionSession class
Top
Properties
 | Name | Description
Public property | AllowedCharacters | Gets or sets the CharClass containing the non-letter/digit characters allowed to be typed while the completion popup is displayed. (Inherited from CompletionSession.)
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from CompletionSession.)
Public property | CanCommitWithoutPopup | Gets or sets whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality. (Inherited from CompletionSession.)
Public property | CanFilterUnmatchedItems | Gets or sets whether to filter out items that don't match the typed text, thereby shrinking the list of visible items. (Inherited from CompletionSession.)
Public property | CanHighlightMatchedText | Gets or sets whether list items show possible matched characters in a highlight color. (Inherited from CompletionSession.)
Protected property | CanOpenForReadOnlyTextRanges | Gets whether the session is able to be opened for read-only text ranges. (Inherited from CompletionSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from CompletionSession.)
Public property | CommitCharacters | Gets or sets the CharClass containing the characters that can be typed when there is a full selection to trigger a Commit. (Inherited from CompletionSession.)
Public property | Context | Gets or sets an object that describes the context in which the completion session is opened. (Inherited from CompletionSession.)
Public property | ControlKeyDownOpacity | Gets or sets the opacity of the popup while the control key is pressed. (Inherited from CompletionSession.)
Public property | DescriptionTipMaxWidth | Gets or sets the description tip popup's maximum width. (Inherited from CompletionSession.)
Public property | DescriptionTipShowDelay | Gets or sets the TimeSpan to wait after the selection is updated before showing the description tip. (Inherited from CompletionSession.)
Public property | FilteredItems | Gets the read-only collection of filtered ICompletionItem objects that are visible within the completion list. (Inherited from CompletionSession.)
Public property | Filters | Gets the collection of ICompletionFilter objects that can be applied to the session. (Inherited from CompletionSession.)
Public property | IsEnterKeyHandledOnCommit | Gets or sets whether the Enter key is handled (not allowed to insert a line feed) when it commits the session. (Inherited from CompletionSession.)
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IntelliPromptSessionBase.)
Public property | ItemMatchers | Gets the collection of ICompletionItemMatcher objects to use when matching items. (Inherited from CompletionSession.)
Public property | Items | Gets the collection of ICompletionItem objects within the completion. (Inherited from CompletionSession.)
Public property | MatchOptions | Gets or sets the CompletionMatchOptions indicating the options to use when matching items. (Inherited from CompletionSession.)
Protected property | PlacementRectangle | Gets the placement Rect, if known, around which the session should be placed. (Inherited from CompletionSession.)
Public property | RequiresFilterOnTextChange | Gets or sets whether to apply filters when a text change occurs. (Inherited from CompletionSession.)
Public property | Selection | Gets a CompletionSelection indicating the current selection within the completion. (Inherited from CompletionSession.)
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from CompletionSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IntelliPromptSessionBase.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from IntelliPromptSessionBase.)
Public property | TypedText | Gets the text that has been used to initialize the session and/or been entered by the end user since the session opened. (Inherited from CompletionSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IntelliPromptSessionBase.)
Top
Methods
 | Name | Description
Public method | ApplyFilters | Re-applies the active filters and rebuilds the FilteredItems collection. (Inherited from CompletionSession.)
Public method | Cancel | Cancels the completion session. (Inherited from CompletionSession.)
Public method | Close | Closes the session. (Inherited from IntelliPromptSessionBase.)
Public method | CloseDescriptionTip | Closes the description tip if it is open. (Inherited from CompletionSession.)
Public method | Commit | Commits the completion session and performs an auto-complete if there is a Selection available. (Inherited from CompletionSession.)
Protected method | CreatePopupContent | Creates an IntelliPromptCompletionList that is to be displayed in a popup. (Inherited from CompletionSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IntelliPromptSessionBase.)
Protected method | GetPopupBounds | Returns the view-relative bounds of the specified Popup. (Inherited from IntelliPromptSessionBase.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IntelliPromptSessionBase.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IntelliPromptSessionBase.)
Protected method | OnClosed | Raises the Closed event. (Inherited from CompletionSession.)
Protected method | OnCommitted | Raises the Committed event. (Overrides CompletionSessionOnCommitted(EventArgs).)
Protected method | OnCommitting | Raises the Committing event. (Inherited from CompletionSession.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from CompletionSession.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from CompletionSession.)
Protected method | OnOpened | Raises the Opened event. (Inherited from CompletionSession.)
Protected method | OnRequestNavigate | Raises the RequestNavigate event. (Inherited from CompletionSession.)
Protected method | OnSelectionChanged | Raises the SelectionChanged event. (Inherited from CompletionSession.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from IntelliPromptSessionBase.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from IntelliPromptSessionBase.)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CompletionSession.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CompletionSession.)
Protected method | OnViewPointerPressed | Occurs when a pointer button is pressed over the specified IEditorView. (Inherited from CompletionSession.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from CompletionSession.)
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView. (Overrides CompletionSessionOnViewTextInput(IEditorView, TextCompositionEventArgs).)
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView. (Inherited from CompletionSession.)
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IntelliPromptSessionBase.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IntelliPromptSessionBase.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IntelliPromptSessionBase.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from CompletionSession.)
Public method | RestartDescriptionTipTimer | Restarts the description tip display timer. (Inherited from CompletionSession.)
Public method | SortItems | Sorts the items in the session using the default sort comparer. (Inherited from CompletionSession.)
Public method | SortItems(IComparerICompletionItem) | Sorts the items in the session using a custom comparer. (Inherited from CompletionSession.)
Protected method | TranslateTrackedSnapshotRange | Translates the TextSnapshotRange that is tracked for replacement to a range in a new ITextSnapshot. (Inherited from CompletionSession.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IntelliPromptSessionBase.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IntelliPromptSessionBase.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IntelliPromptSessionBase.)
Public event | Committed | Occurs after the session is committed. (Inherited from CompletionSession.)
Public event | Committing | Occurs before the session is committed, allowing it to be cancelled. (Inherited from CompletionSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IntelliPromptSessionBase.)
Public event | RequestNavigate | Occurs when a hyperlink on a description tip is clicked that requests navigation. (Inherited from CompletionSession.)
Public event | SelectionChanged | Occurs after the Selection has changed. (Inherited from CompletionSession.)
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IntelliPromptSessionBase.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IntelliPromptSessionBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionSession Constructor

Initializes a new instance of the XmlCompletionSession class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlCompletionSession()
Public Sub New
See Also

Reference

XmlCompletionSession Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionSession Properties

The XmlCompletionSession type exposes the following members.

Properties
 | Name | Description
Public property | AllowedCharacters | Gets or sets the CharClass containing the non-letter/digit characters allowed to be typed while the completion popup is displayed. (Inherited from CompletionSession.)
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from CompletionSession.)
Public property | CanCommitWithoutPopup | Gets or sets whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality. (Inherited from CompletionSession.)
Public property | CanFilterUnmatchedItems | Gets or sets whether to filter out items that don't match the typed text, thereby shrinking the list of visible items. (Inherited from CompletionSession.)
Public property | CanHighlightMatchedText | Gets or sets whether list items show possible matched characters in a highlight color. (Inherited from CompletionSession.)
Protected property | CanOpenForReadOnlyTextRanges | Gets whether the session is able to be opened for read-only text ranges. (Inherited from CompletionSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from CompletionSession.)
Public property | CommitCharacters | Gets or sets the CharClass containing the characters that can be typed when there is a full selection to trigger a Commit. (Inherited from CompletionSession.)
Public property | Context | Gets or sets an object that describes the context in which the completion session is opened. (Inherited from CompletionSession.)
Public property | ControlKeyDownOpacity | Gets or sets the opacity of the popup while the control key is pressed. (Inherited from CompletionSession.)
Public property | DescriptionTipMaxWidth | Gets or sets the description tip popup's maximum width. (Inherited from CompletionSession.)
Public property | DescriptionTipShowDelay | Gets or sets the TimeSpan to wait after the selection is updated before showing the description tip. (Inherited from CompletionSession.)
Public property | FilteredItems | Gets the read-only collection of filtered ICompletionItem objects that are visible within the completion list. (Inherited from CompletionSession.)
Public property | Filters | Gets the collection of ICompletionFilter objects that can be applied to the session. (Inherited from CompletionSession.)
Public property | IsEnterKeyHandledOnCommit | Gets or sets whether the Enter key is handled (not allowed to insert a line feed) when it commits the session. (Inherited from CompletionSession.)
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IntelliPromptSessionBase.)
Public property | ItemMatchers | Gets the collection of ICompletionItemMatcher objects to use when matching items. (Inherited from CompletionSession.)
Public property | Items | Gets the collection of ICompletionItem objects within the completion. (Inherited from CompletionSession.)
Public property | MatchOptions | Gets or sets the CompletionMatchOptions indicating the options to use when matching items. (Inherited from CompletionSession.)
Protected property | PlacementRectangle | Gets the placement Rect, if known, around which the session should be placed. (Inherited from CompletionSession.)
Public property | RequiresFilterOnTextChange | Gets or sets whether to apply filters when a text change occurs. (Inherited from CompletionSession.)
Public property | Selection | Gets a CompletionSelection indicating the current selection within the completion. (Inherited from CompletionSession.)
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from CompletionSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IntelliPromptSessionBase.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from IntelliPromptSessionBase.)
Public property | TypedText | Gets the text that has been used to initialize the session and/or been entered by the end user since the session opened. (Inherited from CompletionSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IntelliPromptSessionBase.)
Top
See Also

Reference

XmlCompletionSession Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionSession Methods

The XmlCompletionSession type exposes the following members.

Methods
 | Name | Description
Public method | ApplyFilters | Re-applies the active filters and rebuilds the FilteredItems collection. (Inherited from CompletionSession.)
Public method | Cancel | Cancels the completion session. (Inherited from CompletionSession.)
Public method | Close | Closes the session. (Inherited from IntelliPromptSessionBase.)
Public method | CloseDescriptionTip | Closes the description tip if it is open. (Inherited from CompletionSession.)
Public method | Commit | Commits the completion session and performs an auto-complete if there is a Selection available. (Inherited from CompletionSession.)
Protected method | CreatePopupContent | Creates an IntelliPromptCompletionList that is to be displayed in a popup. (Inherited from CompletionSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IntelliPromptSessionBase.)
Protected method | GetPopupBounds | Returns the view-relative bounds of the specified Popup. (Inherited from IntelliPromptSessionBase.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IntelliPromptSessionBase.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IntelliPromptSessionBase.)
Protected method | OnClosed | Raises the Closed event. (Inherited from CompletionSession.)
Protected method | OnCommitted | Raises the Committed event. (Overrides CompletionSessionOnCommitted(EventArgs).)
Protected method | OnCommitting | Raises the Committing event. (Inherited from CompletionSession.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from CompletionSession.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from CompletionSession.)
Protected method | OnOpened | Raises the Opened event. (Inherited from CompletionSession.)
Protected method | OnRequestNavigate | Raises the RequestNavigate event. (Inherited from CompletionSession.)
Protected method | OnSelectionChanged | Raises the SelectionChanged event. (Inherited from CompletionSession.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from IntelliPromptSessionBase.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from IntelliPromptSessionBase.)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CompletionSession.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CompletionSession.)
Protected method | OnViewPointerPressed | Occurs when a pointer button is pressed over the specified IEditorView. (Inherited from CompletionSession.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from CompletionSession.)
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView. (Overrides CompletionSessionOnViewTextInput(IEditorView, TextCompositionEventArgs).)
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView. (Inherited from CompletionSession.)
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IntelliPromptSessionBase.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IntelliPromptSessionBase.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IntelliPromptSessionBase.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from CompletionSession.)
Public method | RestartDescriptionTipTimer | Restarts the description tip display timer. (Inherited from CompletionSession.)
Public method | SortItems | Sorts the items in the session using the default sort comparer. (Inherited from CompletionSession.)
Public method | SortItems(IComparerICompletionItem) | Sorts the items in the session using a custom comparer. (Inherited from CompletionSession.)
Protected method | TranslateTrackedSnapshotRange | Translates the TextSnapshotRange that is tracked for replacement to a range in a new ITextSnapshot. (Inherited from CompletionSession.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IntelliPromptSessionBase.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IntelliPromptSessionBase.)
Top
See Also

Reference

XmlCompletionSession Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionSession.OnCommitted Method

XmlCompletionSessionOnCommitted Method

Raises the Committed event.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnCommitted(
    EventArgs e
)
Protected Overrides Sub OnCommitted (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

XmlCompletionSession Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionSession.OnViewTextInput Method

XmlCompletionSessionOnViewTextInput Method

Occurs before text is input to the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnViewTextInput(
    IEditorView view,
    TextCompositionEventArgs e
)
Protected Overrides Sub OnViewTextInput (
    view As IEditorView,
    e As TextCompositionEventArgs
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: System.Windows.InputTextCompositionEventArgs
The TextCompositionEventArgs that contains the event data.
See Also

Reference

XmlCompletionSession Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCompletionSession Events

The XmlCompletionSession type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IntelliPromptSessionBase.)
Public event | Committed | Occurs after the session is committed. (Inherited from CompletionSession.)
Public event | Committing | Occurs before the session is committed, allowing it to be cancelled. (Inherited from CompletionSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IntelliPromptSessionBase.)
Public event | RequestNavigate | Occurs when a hyperlink on a description tip is clicked that requests navigation. (Inherited from CompletionSession.)
Public event | SelectionChanged | Occurs after the Selection has changed. (Inherited from CompletionSession.)
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IntelliPromptSessionBase.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IntelliPromptSessionBase.)
Top
See Also

Reference

XmlCompletionSession Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlContextFactory Class

Creates IXmlContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlContextFactory

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlContextFactory
Public Class XmlContextFactory

The XmlContextFactory type exposes the following members.

Constructors
 | Name | Description
Public method | XmlContextFactory | Initializes a new instance of the XmlContextFactory class
Top
Methods
 | Name | Description
Public method | CreateContext | Creates an IXmlContext for the specified TextSnapshotOffset.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlContextFactory Constructor

Initializes a new instance of the XmlContextFactory class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlContextFactory()
Public Sub New
See Also

Reference

XmlContextFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlContextFactory Methods

The XmlContextFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext | Creates an IXmlContext for the specified TextSnapshotOffset.
Top
See Also

Reference

XmlContextFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlContextFactory.CreateContext Method

XmlContextFactoryCreateContext Method

Creates an IXmlContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IXmlContext CreateContext(
    TextSnapshotOffset snapshotOffset
)
Public Function CreateContext (
    snapshotOffset As TextSnapshotOffset
) As IXmlContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.

Return Value

Type: IXmlContext
The IXmlContext that was created.
See Also

Reference

XmlContextFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlEndTagAutoCompleter Class

Provides a class that can auto-complete XML end tags when appropriate.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlEndTagAutoCompleter

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlEndTagAutoCompleter : IXmlEndTagAutoCompleter
Public Class XmlEndTagAutoCompleter
    Implements IXmlEndTagAutoCompleter

The XmlEndTagAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlEndTagAutoCompleter | Initializes a new instance of the XmlEndTagAutoCompleter class
Top
Methods
 | Name | Description
Public method | AutoComplete | Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlEndTagAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlEndTagAutoCompleter Constructor

Initializes a new instance of the XmlEndTagAutoCompleter class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlEndTagAutoCompleter()
Public Sub New
See Also

Reference

XmlEndTagAutoCompleter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlEndTagAutoCompleter Methods

The XmlEndTagAutoCompleter type exposes the following members.

Methods
 | Name | Description
Public method | AutoComplete | Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.
Top
See Also

Reference

XmlEndTagAutoCompleter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlEndTagAutoCompleter.AutoComplete Method

XmlEndTagAutoCompleterAutoComplete Method

Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AutoComplete(
    IEditorView view
)
Public Sub AutoComplete (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Implements

IXmlEndTagAutoCompleterAutoComplete(IEditorView)
See Also

Reference

XmlEndTagAutoCompleter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlExampleTextProvider Class

Represents a example text provider for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlExampleTextProvider : IExampleTextProvider
Public Class XmlExampleTextProvider
    Implements IExampleTextProvider

The XmlExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlExampleTextProvider | Initializes a new instance of the XmlExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.542.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlExampleTextProvider Constructor

Initializes a new instance of the XmlExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlExampleTextProvider()
Public Sub New
See Also

Reference

XmlExampleTextProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlExampleTextProvider Properties

The XmlExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

XmlExampleTextProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlExampleTextProvider.ExampleText Property

XmlExampleTextProviderExampleText Property

Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

XmlExampleTextProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlGrammar Class

Represents a Grammar for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.Xml.ImplementationXmlGrammar

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlGrammar : Grammar
Public Class XmlGrammar
    Inherits Grammar

The XmlGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | XmlGrammar | Initializes a new instance of the XmlGrammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlGrammar Constructor

Initializes a new instance of the XmlGrammar class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlGrammar()
Public Sub New
See Also

Reference

XmlGrammar Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlGrammar Properties

The XmlGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

XmlGrammar Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlGrammar Methods

The XmlGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

XmlGrammar Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider Class

Provides a XML language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlIndentProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlIndentProvider : IIndentProvider,
    IEditorDocumentTextChangeEventSink
Public Class XmlIndentProvider
    Implements IIndentProvider, IEditorDocumentTextChangeEventSink

The XmlIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlIndentProvider | Initializes a new instance of the XmlIndentProvider class
Top
Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider Constructor

Initializes a new instance of the XmlIndentProvider class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlIndentProvider()
Public Sub New
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider Properties

The XmlIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider.Mode Property

XmlIndentProviderMode Property

Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IndentMode Mode { get; }
Public ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider Methods

The XmlIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Top
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider.GetIndentAmount Method

XmlIndentProviderGetIndentAmount Method

Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider.OnDocumentTextChanged Method

XmlIndentProviderOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider.OnDocumentTextChanging Method

XmlIndentProviderOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Class

Represents a lexer for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexer
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLexer

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlLexer : DynamicLexer
Public Class XmlLexer
    Inherits DynamicLexer

The XmlLexer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexer | Initializes a new instance of the XmlLexer class.
Top
Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered. (Inherited from DynamicLexer.)
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from DynamicLexer.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Public property | LexicalMacros | Gets the collection of lexical macros. (Inherited from DynamicLexer.)
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from DynamicLexer.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states. (Inherited from DynamicLexer.)
Public property | TokenIdProvider | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from DynamicLexer.)
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Inherited from DynamicLexer.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from DynamicLexer.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Inherited from DynamicLexer.)
Protected method | OnChanged | Raises the Changed event. (Inherited from DynamicLexer.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.2.550.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Constructor

Initializes a new instance of the XmlLexer class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlLexer(
    IXmlClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IXmlClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.XmlIXmlClassificationTypeProvider
A IXmlClassificationTypeProvider that provides classification types used by this lexer.
See Also

Reference

XmlLexer Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Properties

The XmlLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered. (Inherited from DynamicLexer.)
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from DynamicLexer.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Public property | LexicalMacros | Gets the collection of lexical macros. (Inherited from DynamicLexer.)
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from DynamicLexer.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states. (Inherited from DynamicLexer.)
Public property | TokenIdProvider | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from DynamicLexer.)
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

XmlLexer Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Methods

The XmlLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Inherited from DynamicLexer.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from DynamicLexer.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Inherited from DynamicLexer.)
Protected method | OnChanged | Raises the Changed event. (Inherited from DynamicLexer.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
See Also

Reference

XmlLexer Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Events

The XmlLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

XmlLexer Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Class

Contains the lexical state IDs for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLexicalStateId

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlLexicalStateId : LexicalStateIdProviderBase
Public Class XmlLexicalStateId
    Inherits LexicalStateIdProviderBase

The XmlLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexicalStateId | Initializes a new instance of the XmlLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
Fields
Name | Description
CDataSection | Gets the CDataSection lexical state ID.
Comment | Gets the Comment lexical state ID.
Declaration | Gets the Declaration lexical state ID.
Default | Gets the Default lexical state ID.
DocTypeDeclaration | Gets the DocTypeDeclaration lexical state ID.
DocTypeDeclarationInternalSubset | Gets the DocTypeDeclarationInternalSubset lexical state ID.
EndTag | Gets the EndTag lexical state ID.
ProcessingInstruction | Gets the ProcessingInstruction lexical state ID.
StartTag | Gets the StartTag lexical state ID.
StartTagAttributeDoubleQuoteValue | Gets the StartTagAttributeDoubleQuoteValue lexical state ID.
StartTagAttributeSingleQuoteValue | Gets the StartTagAttributeSingleQuoteValue lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.543.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Constructor

Initializes a new instance of the XmlLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlLexicalStateId()
Public Sub New
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Properties

The XmlLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.MaxId Property

XmlLexicalStateIdMaxId Property

Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.MinId Property

XmlLexicalStateIdMinId Property

Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Methods

The XmlLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Top
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.ContainsId Method

XmlLexicalStateIdContainsId Method

Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.GetDescription Method

XmlLexicalStateIdGetDescription Method

Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.GetKey Method

XmlLexicalStateIdGetKey Method

Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Fields

The XmlLexicalStateId type exposes the following members.

Fields
Name | Description
CDataSection | Gets the CDataSection lexical state ID.
Comment | Gets the Comment lexical state ID.
Declaration | Gets the Declaration lexical state ID.
Default | Gets the Default lexical state ID.
DocTypeDeclaration | Gets the DocTypeDeclaration lexical state ID.
DocTypeDeclarationInternalSubset | Gets the DocTypeDeclarationInternalSubset lexical state ID.
EndTag | Gets the EndTag lexical state ID.
ProcessingInstruction | Gets the ProcessingInstruction lexical state ID.
StartTag | Gets the StartTag lexical state ID.
StartTagAttributeDoubleQuoteValue | Gets the StartTagAttributeDoubleQuoteValue lexical state ID.
StartTagAttributeSingleQuoteValue | Gets the StartTagAttributeSingleQuoteValue lexical state ID.
Top
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.CDataSection Field

XmlLexicalStateIdCDataSection Field

Gets the CDataSection lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CDataSection = 11
Public Const CDataSection As Integer = 11

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.Comment Field

XmlLexicalStateIdComment Field

Gets the Comment lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Comment = 6
Public Const Comment As Integer = 6

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.Declaration Field

XmlLexicalStateIdDeclaration Field

Gets the Declaration lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Declaration = 10
Public Const Declaration As Integer = 10

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.Default Field

XmlLexicalStateIdDefault Field

Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Default = 1
Public Const Default As Integer = 1

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.DocTypeDeclaration Field

XmlLexicalStateIdDocTypeDeclaration Field

Gets the DocTypeDeclaration lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocTypeDeclaration = 8
Public Const DocTypeDeclaration As Integer = 8

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.DocTypeDeclarationInternalSubset Field

XmlLexicalStateIdDocTypeDeclarationInternalSubset Field

Gets the DocTypeDeclarationInternalSubset lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationInternalSubset = 9
Public Const DocTypeDeclarationInternalSubset As Integer = 9

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.EndTag Field

XmlLexicalStateIdEndTag Field

Gets the EndTag lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EndTag = 5
Public Const EndTag As Integer = 5

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.ProcessingInstruction Field

XmlLexicalStateIdProcessingInstruction Field

Gets the ProcessingInstruction lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ProcessingInstruction = 7
Public Const ProcessingInstruction As Integer = 7

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.StartTag Field

XmlLexicalStateIdStartTag Field

Gets the StartTag lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTag = 2
Public Const StartTag As Integer = 2

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.StartTagAttributeDoubleQuoteValue Field

XmlLexicalStateIdStartTagAttributeDoubleQuoteValue Field

Gets the StartTagAttributeDoubleQuoteValue lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagAttributeDoubleQuoteValue = 3
Public Const StartTagAttributeDoubleQuoteValue As Integer = 3

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.StartTagAttributeSingleQuoteValue Field

XmlLexicalStateIdStartTagAttributeSingleQuoteValue Field

Gets the StartTagAttributeSingleQuoteValue lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagAttributeSingleQuoteValue = 4
Public Const StartTagAttributeSingleQuoteValue As Integer = 4

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter Class

Provides a XML language line commenter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationRangeLineCommenter
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLineCommenter

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlLineCommenter : RangeLineCommenter
Public Class XmlLineCommenter
    Inherits RangeLineCommenter

The XmlLineCommenter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLineCommenter | Initializes a new instance of the XmlLineCommenter class.
Top
Properties
 | Name | Description
Public property | CommentTokenId | Gets or sets the comment token ID. (Inherited from RangeLineCommenter.)
Public property | EndDelimiter | Gets or sets the end delimiter text that is added or removed during comment/uncomment operations. (Inherited from RangeLineCommenter.)
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations. (Inherited from RangeLineCommenter.)
Top
Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified position ranges. (Overrides RangeLineCommenterComment(ITextSnapshot, ITextPositionRangeCollection, ITextChangeOptions).)
Protected method | FindCommentTextRange | Returns the full text range of the comment that surrounds the specified snapshot range, if any. (Overrides RangeLineCommenterFindCommentTextRange(TextSnapshotRange).)
Public method | Uncomment | Uncomments the lines of code in the specified position ranges. (Inherited from RangeLineCommenter.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter Constructor

Initializes a new instance of the XmlLineCommenter class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlLineCommenter()
Public Sub New
See Also

Reference

XmlLineCommenter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter Properties

The XmlLineCommenter type exposes the following members.

Properties
 | Name | Description
Public property | CommentTokenId | Gets or sets the comment token ID. (Inherited from RangeLineCommenter.)
Public property | EndDelimiter | Gets or sets the end delimiter text that is added or removed during comment/uncomment operations. (Inherited from RangeLineCommenter.)
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations. (Inherited from RangeLineCommenter.)
Top
See Also

Reference

XmlLineCommenter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter Methods

The XmlLineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified position ranges. (Overrides RangeLineCommenterComment(ITextSnapshot, ITextPositionRangeCollection, ITextChangeOptions).)
Protected method | FindCommentTextRange | Returns the full text range of the comment that surrounds the specified snapshot range, if any. (Overrides RangeLineCommenterFindCommentTextRange(TextSnapshotRange).)
Public method | Uncomment | Uncomments the lines of code in the specified position ranges. (Inherited from RangeLineCommenter.)
Top
See Also

Reference

XmlLineCommenter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter.Comment Method

XmlLineCommenterComment Method

Comments out the lines of code in the specified position ranges.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Comment(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection positionRanges,
    ITextChangeOptions options
)
Public Overrides Sub Comment (
    snapshot As ITextSnapshot,
    positionRanges As ITextPositionRangeCollection,
    options As ITextChangeOptions
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
positionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the position ranges over which to comment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Implements

ILineCommenterComment(ITextSnapshot, ITextPositionRangeCollection, ITextChangeOptions)
See Also

Reference

XmlLineCommenter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter.FindCommentTextRange Method

XmlLineCommenterFindCommentTextRange Method

Returns the full text range of the comment that surrounds the specified snapshot range, if any.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<TextRange> FindCommentTextRange(
    TextSnapshotRange snapshotRange
)
Protected Overrides Function FindCommentTextRange (
    snapshotRange As TextSnapshotRange
) As Nullable(Of TextRange)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Nullable TextRange
The full text range of the comment that surrounds the specified snapshot range, if any.
See Also

Reference

XmlLineCommenter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider Class

Represents a navigable symbol provider for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlNavigableSymbolProvider : INavigableSymbolProvider
Public Class XmlNavigableSymbolProvider
    Implements INavigableSymbolProvider

The XmlNavigableSymbolProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlNavigableSymbolProvider | Initializes a new instance of the XmlNavigableSymbolProvider class
Top
Methods
 | Name | Description
Protected method | CreateAttributeSymbol | Creates an INavigableSymbol for an attribute.
Protected method | CreateElementSymbol | Creates an INavigableSymbol for an element.
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider Constructor

Initializes a new instance of the XmlNavigableSymbolProvider class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlNavigableSymbolProvider()
Public Sub New
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider Methods

The XmlNavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateAttributeSymbol | Creates an INavigableSymbol for an attribute.
Protected method | CreateElementSymbol | Creates an INavigableSymbol for an element.
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Top
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider.CreateAttributeSymbol Method

XmlNavigableSymbolProviderCreateAttributeSymbol Method

Creates an INavigableSymbol for an attribute.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual INavigableSymbol CreateAttributeSymbol(
    ElementAttribute astNode,
    ITextSnapshot snapshot,
    int hierarchyLevel
)
Protected Overridable Function CreateAttributeSymbol (
    astNode As ElementAttribute,
    snapshot As ITextSnapshot,
    hierarchyLevel As Integer
) As INavigableSymbol

Parameters

astNode
Type: ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementAttribute
The ElementAttribute to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.
hierarchyLevel
Type: SystemInt32
The hierarchy level.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider.CreateElementSymbol Method

XmlNavigableSymbolProviderCreateElementSymbol Method

Creates an INavigableSymbol for an element.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual INavigableSymbol CreateElementSymbol(
    Element astNode,
    ITextSnapshot snapshot,
    int hierarchyLevel
)
Protected Overridable Function CreateElementSymbol (
    astNode As Element,
    snapshot As ITextSnapshot,
    hierarchyLevel As Integer
) As INavigableSymbol

Parameters

astNode
Type: ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElement
The Element to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.
hierarchyLevel
Type: SystemInt32
The hierarchy level.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider.GetSymbols Method

XmlNavigableSymbolProviderGetSymbols Method

Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual INavigableSymbolSet GetSymbols(
    INavigableRequestContext context,
    TextSnapshotOffset snapshotOffset,
    INavigableSymbol parentSymbol
)
Public Overridable Function GetSymbols (
    context As INavigableRequestContext,
    snapshotOffset As TextSnapshotOffset,
    parentSymbol As INavigableSymbol
) As INavigableSymbolSet

Parameters

context
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptINavigableRequestContext
An INavigableRequestContext that provides the context of the request.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset that contains the ITextSnapshot to examine, along with a contextual offset.
parentSymbol
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptINavigableSymbol
The optional parent INavigableSymbol to examine, or a null value if the root symbols are requested.

Return Value

Type: INavigableSymbolSet
An INavigableSymbolSet containing the INavigableSymbol objects that were located.

Implements

INavigableSymbolProviderGetSymbols(INavigableRequestContext, TextSnapshotOffset, INavigableSymbol)
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner Class

Provides a XML language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlOutliner

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlOutliner : IOutliner
Public Class XmlOutliner
    Implements IOutliner

The XmlOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | XmlOutliner | Initializes a new instance of the XmlOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner Constructor

Initializes a new instance of the XmlOutliner class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlOutliner()
Public Sub New
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner Properties

The XmlOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner.UpdateTrigger Property

XmlOutlinerUpdateTrigger Property

Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner Methods

The XmlOutliner type exposes the following members.

Methods
 | Name | Description
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Top
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner.GetOutliningSource Method

XmlOutlinerGetOutliningSource Method

Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParseData Class

Stores the results of a XML language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParseData

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlParseData : LLParseData,
    ILLParseData, IParseData, IParseErrorProvider, IXmlParseData
Public Class XmlParseData
    Inherits LLParseData
    Implements ILLParseData, IParseData, IParseErrorProvider, IXmlParseData

The XmlParseData type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParseData | Initializes a new instance of the XmlParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | IsWellFormed | Gets or sets whether the XML is well-formed.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParseData Constructor

Initializes a new instance of the XmlParseData class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlParseData()
Public Sub New
See Also

Reference

XmlParseData Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParseData Properties

The XmlParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | IsWellFormed | Gets or sets whether the XML is well-formed.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

XmlParseData Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParseData.IsWellFormed Property

XmlParseDataIsWellFormed Property

Gets or sets whether the XML is well-formed.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsWellFormed { get; set; }
Public Property IsWellFormed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the XML is well-formed; otherwise, false.

Implements

IXmlParseDataIsWellFormed
See Also

Reference

XmlParseData Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Class

Represents a parser for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParserBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParser

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlParser : XmlParserBase
Public Class XmlParser
    Inherits XmlParserBase

The XmlParser type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParser | Initializes a new instance of the XmlParser class.
Public method | XmlParser(Grammar) | Initializes a new instance of the XmlParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from XmlParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Inherited from XmlParserBase.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Protected method | Validate | Validates XML if no parse errors were found. (Inherited from XmlParserBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Constructor

Overload List
 | Name | Description
Public method | XmlParser | Initializes a new instance of the XmlParser class.
Public method | XmlParser(Grammar) | Initializes a new instance of the XmlParser class.
Top
See Also

Reference

XmlParser Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Constructor

Initializes a new instance of the XmlParser class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlParser()
Public Sub New
See Also

Reference

XmlParser Class
XmlParser Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Constructor (Grammar)

Initializes a new instance of the XmlParser class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

XmlParser Class
XmlParser Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Properties

The XmlParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

XmlParser Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Methods

The XmlParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from XmlParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Inherited from XmlParserBase.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Protected method | Validate | Validates XML if no parse errors were found. (Inherited from XmlParserBase.)
Top
See Also

Reference

XmlParser Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser.CreateTokenReader Method

XmlParserCreateTokenReader Method

Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

XmlParser Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase Class

Provides an abstract base class of a parser for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParserBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParser

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class XmlParserBase : LLParserBase
Public MustInherit Class XmlParserBase
    Inherits LLParserBase

The XmlParserBase type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlParserBase | Initializes a new instance of the XmlParserBase class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Inherited from LLParserBase.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Protected method | Validate | Validates XML if no parse errors were found.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase Constructor

Initializes a new instance of the XmlParserBase class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected XmlParserBase(
    Grammar grammar
)
Protected Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase Properties

The XmlParserBase type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase Methods

The XmlParserBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Inherited from LLParserBase.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Protected method | Validate | Validates XML if no parse errors were found.
Top
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase.CreateParseData Method

XmlParserBaseCreateParseData Method

Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase.InitializeParserState Method

XmlParserBaseInitializeParserState Method

Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase.Validate Method

XmlParserBaseValidate Method

Validates XML if no parse errors were found.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void Validate(
    IParseRequest request,
    IParserState state
)
Protected Overridable Sub Validate (
    request As IParseRequest,
    state As IParserState
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext Class

Stores parser context information for a XML language grammar parser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParserContext

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlParserContext
Public Class XmlParserContext

The XmlParserContext type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParserContext | Initializes a new instance of the XmlParserContext class.
Top
Properties
 | Name | Description
Public property | ElementStack | Gets the element stack.
Public property | IsWellFormed | Gets or sets whether the XML is well-formed.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext Constructor

Initializes a new instance of the XmlParserContext class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlParserContext()
Public Sub New
See Also

Reference

XmlParserContext Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext Properties

The XmlParserContext type exposes the following members.

Properties
 | Name | Description
Public property | ElementStack | Gets the element stack.
Public property | IsWellFormed | Gets or sets whether the XML is well-formed.
Top
See Also

Reference

XmlParserContext Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext.ElementStack Property

XmlParserContextElementStack Property

Gets the element stack.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Stack<IAstNode> ElementStack { get; }
Public ReadOnly Property ElementStack As Stack(Of IAstNode)
    Get

Property Value

Type: Stack IAstNode
The element stack.
See Also

Reference

XmlParserContext Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext.IsWellFormed Property

XmlParserContextIsWellFormed Property

Gets or sets whether the XML is well-formed.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsWellFormed { get; set; }
Public Property IsWellFormed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the XML is well-formed; otherwise, false.
See Also

Reference

XmlParserContext Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider Class

Provides IntelliPrompt quick info data for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPrompt.ImplementationQuickInfoProviderBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlQuickInfoProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlQuickInfoProvider : QuickInfoProviderBase
Public Class XmlQuickInfoProvider
    Inherits QuickInfoProviderBase

The XmlQuickInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlQuickInfoProvider | Initializes a new instance of the XmlQuickInfoProvider class.
Top
Properties
 | Name | Description
Protected property | CanTrackPointerInput | Gets whether to track pointer input and allow pointer movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider Constructor

Initializes a new instance of the XmlQuickInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlQuickInfoProvider()
Public Sub New
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider Properties

The XmlQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Protected property | CanTrackPointerInput | Gets whether to track pointer input and allow pointer movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.ContextTypes Property

XmlQuickInfoProviderContextTypes Property

Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerable<Type> ContextTypes { get; }
Protected Overrides ReadOnly Property ContextTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The context Type objects that are supported by this provider.
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider Methods

The XmlQuickInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.GetContext Method

XmlQuickInfoProviderGetContext Method

Overload List
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Top
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.GetContext Method (IEditorView, Int32)

XmlQuickInfoProviderGetContext Method (IEditorView, Int32)

Returns an object describing the quick info context for the specified text offset, if any.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetContext(
    IEditorView view,
    int offset
)
Public Overrides Function GetContext (
    view As IEditorView,
    offset As Integer
) As Object

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView in which the offset is located.
offset
Type: SystemInt32
The text offset to examine.

Return Value

Type: Object
An object describing the quick info context for the specified text offset, if any. A value indicates that no context is available.

Implements

IQuickInfoProviderGetContext(IEditorView, Int32)
Remarks
This method is called in response to keyboard events.
See Also

Reference

XmlQuickInfoProvider Class
GetContext Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.OnSessionOpening Method

XmlQuickInfoProviderOnSessionOpening Method

Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IQuickInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IQuickInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIQuickInfoSession
The IQuickInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.RequestSession Method

XmlQuickInfoProviderRequestSession Method

Overload List
 | Name | Description
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.RequestSession Method (IEditorView, Object)

XmlQuickInfoProviderRequestSession Method (IEditorView, Object)

Requests that an IQuickInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool RequestSession(
    IEditorView view,
    Object context
)
Protected Overrides Function RequestSession (
    view As IEditorView,
    context As Object
) As Boolean

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
context
Type: SystemObject
A context object returned by GetContext(IEditorView, Int32).

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

XmlQuickInfoProvider Class
RequestSession Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver Class

Provides a class that can manage XML schema data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlSchemaResolver

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlSchemaResolver : IXmlSchemaResolver
Public Class XmlSchemaResolver
    Implements IXmlSchemaResolver

The XmlSchemaResolver type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSchemaResolver | Initializes a new instance of the XmlSchemaResolver class.
Top
Properties
 | Name | Description
Public property | DefaultNamespace | Gets or sets the default XML namespace to use.
Public property | DefaultNamespacePrefixMappings | Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Public property | SchemaSet | Gets or sets the XmlSchemaSet to use.
Top
Methods
 | Name | Description
Public method | AddSchema | Adds another XmlSchema to the existing SchemaSet.
Public method | AddSchemaFromFile | Adds another XmlSchema from a file to the existing SchemaSet.
Public method | AddSchemaFromStream | Adds another XmlSchema from a Stream to the existing SchemaSet.
Public method | AddSchemaFromString | Adds another XmlSchema from a string to the existing SchemaSet.
Public method | GetChildSchemaElement | Returns the child XmlSchemaElement that has the specified qualified name.
Public method | GetChildSchemaElements | Returns the child XmlSchemaElement objects.
Public method | GetDocumentation | Returns the XSD documentation for the specified source object.
Public method | GetGlobalSchemaElement | Returns the global XmlSchemaElement that has the specified qualified name.
Public method | GetGlobalSchemaElements | Returns the collection of global XmlSchemaElement objects.
Public method | GetSchemaAttributes | Returns the child XmlSchemaAttribute objects.
 | GetSchemaElementContentFacets | Returns the XmlSchemaFacet objects that are allowed as content of the specified XmlSchemaElement.
 | GetSchemaElementContentType | Returns the XmlSchemaContentType for the specified XmlSchemaElement.
Public method | LoadSchema | Clears any existing SchemaSet and loads a new single XmlSchema.
Public method | LoadSchemaFromFile | Clears any existing SchemaSet and loads a new single XmlSchema from a file.
Public method | LoadSchemaFromStream | Clears any existing SchemaSet and loads a new single XmlSchema from a Stream.
Public method | LoadSchemaFromString | Clears any existing SchemaSet and loads a new single XmlSchema from a string.
Public method | ResolveSchemaAttribute | Resolves the specified XmlSchemaAttribute in the event it is a reference to another XmlSchemaAttribute.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlSchemaResolver interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver Constructor

Initializes a new instance of the XmlSchemaResolver class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlSchemaResolver()
Public Sub New
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver Properties

The XmlSchemaResolver type exposes the following members.

Properties
 | Name | Description
Public property | DefaultNamespace | Gets or sets the default XML namespace to use.
Public property | DefaultNamespacePrefixMappings | Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Public property | SchemaSet | Gets or sets the XmlSchemaSet to use.
Top
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.DefaultNamespace Property

XmlSchemaResolverDefaultNamespace Property

Gets or sets the default XML namespace to use.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DefaultNamespace { get; set; }
Public Property DefaultNamespace As String
    Get
    Set

Property Value

Type: String
The default XML namespace to use.

Implements

IXmlSchemaResolverDefaultNamespace
Remarks
The default namespace is used to mimic an xmlns attribute setting on the root element, if no xmlns attribute is present. It sets an empty-string-keyed value into the DefaultNamespacePrefixMappings dictionary.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.DefaultNamespacePrefixMappings Property

XmlSchemaResolverDefaultNamespacePrefixMappings Property

Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDictionary<string, string> DefaultNamespacePrefixMappings { get; }
Public ReadOnly Property DefaultNamespacePrefixMappings As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionary String, String
The mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.

Implements

IXmlSchemaResolverDefaultNamespacePrefixMappings
Remarks
The dictionary keys are namespace prefixes and the values are namespaces. The namespace declarations in this dictionary are used to mimic xmlns attribute settings on the root element when no xmlns declaration attributes for the specified namespace prefix keys are present.

The DefaultNamespace property is simply a wrapper for setting an empty-string-keyed value in this dictionary.

See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.SchemaSet Property

XmlSchemaResolverSchemaSet Property

Gets or sets the XmlSchemaSet to use.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlSchemaSet SchemaSet { get; set; }
Public Property SchemaSet As XmlSchemaSet
    Get
    Set

Property Value

Type: XmlSchemaSet
The XmlSchemaSet to use.

Implements

IXmlSchemaResolverSchemaSet
Remarks
This property can be set if you already have a XmlSchemaSet loaded that should directly be used.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver Methods

The XmlSchemaResolver type exposes the following members.

Methods
 | Name | Description
Public method | AddSchema | Adds another XmlSchema to the existing SchemaSet.
Public method | AddSchemaFromFile | Adds another XmlSchema from a file to the existing SchemaSet.
Public method | AddSchemaFromStream | Adds another XmlSchema from a Stream to the existing SchemaSet.
Public method | AddSchemaFromString | Adds another XmlSchema from a string to the existing SchemaSet.
Public method | GetChildSchemaElement | Returns the child XmlSchemaElement that has the specified qualified name.
Public method | GetChildSchemaElements | Returns the child XmlSchemaElement objects.
Public method | GetDocumentation | Returns the XSD documentation for the specified source object.
Public method | GetGlobalSchemaElement | Returns the global XmlSchemaElement that has the specified qualified name.
Public method | GetGlobalSchemaElements | Returns the collection of global XmlSchemaElement objects.
Public method | GetSchemaAttributes | Returns the child XmlSchemaAttribute objects.
 | GetSchemaElementContentFacets | Returns the XmlSchemaFacet objects that are allowed as content of the specified XmlSchemaElement.
 | GetSchemaElementContentType | Returns the XmlSchemaContentType for the specified XmlSchemaElement.
Public method | LoadSchema | Clears any existing SchemaSet and loads a new single XmlSchema.
Public method | LoadSchemaFromFile | Clears any existing SchemaSet and loads a new single XmlSchema from a file.
Public method | LoadSchemaFromStream | Clears any existing SchemaSet and loads a new single XmlSchema from a Stream.
Public method | LoadSchemaFromString | Clears any existing SchemaSet and loads a new single XmlSchema from a string.
Public method | ResolveSchemaAttribute | Resolves the specified XmlSchemaAttribute in the event it is a reference to another XmlSchemaAttribute.
Top
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.AddSchema Method

XmlSchemaResolverAddSchema Method

Adds another XmlSchema to the existing SchemaSet.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddSchema(
    XmlSchema schema
)
Public Sub AddSchema (
    schema As XmlSchema
)

Parameters

schema
Type: System.Xml.SchemaXmlSchema
The XmlSchema to load.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.AddSchemaFromFile Method

XmlSchemaResolverAddSchemaFromFile Method

Adds another XmlSchema from a file to the existing SchemaSet.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddSchemaFromFile(
    string path
)
Public Sub AddSchemaFromFile (
    path As String
)

Parameters

path
Type: SystemString
The path to the XSD schema file to load.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.AddSchemaFromStream Method

XmlSchemaResolverAddSchemaFromStream Method

Adds another XmlSchema from a Stream to the existing SchemaSet.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddSchemaFromStream(
    Stream stream
)
Public Sub AddSchemaFromStream (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The Stream from which to load.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.AddSchemaFromString Method

XmlSchemaResolverAddSchemaFromString Method

Adds another XmlSchema from a string to the existing SchemaSet.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddSchemaFromString(
    string schemaData
)
Public Sub AddSchemaFromString (
    schemaData As String
)

Parameters

schemaData
Type: SystemString
The XSD schema data.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.GetChildSchemaElement Method

XmlSchemaResolverGetChildSchemaElement Method

Returns the child XmlSchemaElement that has the specified qualified name.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlSchemaElement GetChildSchemaElement(
    XmlSchemaElement parentElement,
    XmlQualifiedName name
)
Public Function GetChildSchemaElement (
    parentElement As XmlSchemaElement,
    name As XmlQualifiedName
) As XmlSchemaElement

Parameters

parentElement
Type: System.Xml.SchemaXmlSchemaElement
The parent XmlSchemaElement.
name
Type: System.XmlXmlQualifiedName
The XmlQualifiedName for which to search.

Return Value

Type: XmlSchemaElement
The child XmlSchemaElement that has the specified qualified name.

Implements

IXmlSchemaResolverGetChildSchemaElement(XmlSchemaElement, XmlQualifiedName)
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.GetChildSchemaElements Method

XmlSchemaResolverGetChildSchemaElements Method

Returns the child XmlSchemaElement objects.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<XmlSchemaElement> GetChildSchemaElements(
    XmlSchemaElement parentElement
)
Public Function GetChildSchemaElements (
    parentElement As XmlSchemaElement
) As IEnumerable(Of XmlSchemaElement)

Parameters

parentElement
Type: System.Xml.SchemaXmlSchemaElement
The parent XmlSchemaElement.

Return Value

Type: IEnumerable XmlSchemaElement
The child XmlSchemaElement objects.

Implements

IXmlSchemaResolverGetChildSchemaElements(XmlSchemaElement)
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.GetDocumentation Method

XmlSchemaResolverGetDocumentation Method

Returns the XSD documentation for the specified source object.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string GetDocumentation(
    XmlSchemaAnnotated source
)
Public Overridable Function GetDocumentation (
    source As XmlSchemaAnnotated
) As String

Parameters

source
Type: System.Xml.SchemaXmlSchemaAnnotated
The source XmlSchemaAnnotated for which the documentation is being retrieved.

Return Value

Type: String
The documentation that was retrieved.

Implements

IXmlSchemaResolverGetDocumentation(XmlSchemaAnnotated)
Remarks
The default implementation of this method appends the inner text of all the XmlSchemaDocumentation child nodes together, with whitespace in between.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.GetGlobalSchemaElement Method

XmlSchemaResolverGetGlobalSchemaElement Method

Returns the global XmlSchemaElement that has the specified qualified name.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlSchemaElement GetGlobalSchemaElement(
    XmlQualifiedName name
)
Public Function GetGlobalSchemaElement (
    name As XmlQualifiedName
) As XmlSchemaElement

Parameters

name
Type: System.XmlXmlQualifiedName
The XmlQualifiedName for which to search.

Return Value

Type: XmlSchemaElement
The global XmlSchemaElement that has the specified qualified name.

Implements

IXmlSchemaResolverGetGlobalSchemaElement(XmlQualifiedName)
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.GetGlobalSchemaElements Method

XmlSchemaResolverGetGlobalSchemaElements Method

Returns the collection of global XmlSchemaElement objects.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<XmlSchemaElement> GetGlobalSchemaElements()
Public Function GetGlobalSchemaElements As IEnumerable(Of XmlSchemaElement)

Return Value

Type: IEnumerable XmlSchemaElement
The collection of global XmlSchemaElement objects.

Implements

IXmlSchemaResolverGetGlobalSchemaElements
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.GetSchemaAttributes Method

XmlSchemaResolverGetSchemaAttributes Method

Returns the child XmlSchemaAttribute objects.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<XmlSchemaAttribute> GetSchemaAttributes(
    XmlSchemaElement parentElement
)
Public Function GetSchemaAttributes (
    parentElement As XmlSchemaElement
) As IEnumerable(Of XmlSchemaAttribute)

Parameters

parentElement
Type: System.Xml.SchemaXmlSchemaElement
The parent XmlSchemaElement.

Return Value

Type: IEnumerable XmlSchemaAttribute
The child XmlSchemaAttribute objects.

Implements

IXmlSchemaResolverGetSchemaAttributes(XmlSchemaElement)
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.GetSchemaElementContentFacets Method

XmlSchemaResolverGetSchemaElementContentFacets Method

Returns the XmlSchemaFacet objects that are allowed as content of the specified XmlSchemaElement.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IEnumerable<XmlSchemaFacet> GetSchemaElementContentFacets(
    XmlSchemaElement element
)
Public Shared Function GetSchemaElementContentFacets (
    element As XmlSchemaElement
) As IEnumerable(Of XmlSchemaFacet)

Parameters

element
Type: System.Xml.SchemaXmlSchemaElement
The XmlSchemaElement to examine.

Return Value

Type: IEnumerable XmlSchemaFacet
The XmlSchemaFacet objects that are allowed as content.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.GetSchemaElementContentType Method

XmlSchemaResolverGetSchemaElementContentType Method

Returns the XmlSchemaContentType for the specified XmlSchemaElement.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static XmlSchemaContentType GetSchemaElementContentType(
    XmlSchemaElement element
)
Public Shared Function GetSchemaElementContentType (
    element As XmlSchemaElement
) As XmlSchemaContentType

Parameters

element
Type: System.Xml.SchemaXmlSchemaElement
The XmlSchemaElement to examine.

Return Value

Type: XmlSchemaContentType
The XmlSchemaContentType for the specified XmlSchemaElement.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.LoadSchema Method

XmlSchemaResolverLoadSchema Method

Clears any existing SchemaSet and loads a new single XmlSchema.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void LoadSchema(
    XmlSchema schema
)
Public Sub LoadSchema (
    schema As XmlSchema
)

Parameters

schema
Type: System.Xml.SchemaXmlSchema
The XmlSchema to load.
Remarks
This method first clears any schemas currently in use and then loads a single specified schema.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.LoadSchemaFromFile Method

XmlSchemaResolverLoadSchemaFromFile Method

Clears any existing SchemaSet and loads a new single XmlSchema from a file.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void LoadSchemaFromFile(
    string path
)
Public Sub LoadSchemaFromFile (
    path As String
)

Parameters

path
Type: SystemString
The path to the XSD schema file to load.
Remarks
This method first clears any schemas currently in use and then loads a single specified schema.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.LoadSchemaFromStream Method

XmlSchemaResolverLoadSchemaFromStream Method

Clears any existing SchemaSet and loads a new single XmlSchema from a Stream.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void LoadSchemaFromStream(
    Stream stream
)
Public Sub LoadSchemaFromStream (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The Stream from which to load.
Remarks
This method first clears any schemas currently in use and then loads a single specified schema.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.LoadSchemaFromString Method

XmlSchemaResolverLoadSchemaFromString Method

Clears any existing SchemaSet and loads a new single XmlSchema from a string.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void LoadSchemaFromString(
    string schemaData
)
Public Sub LoadSchemaFromString (
    schemaData As String
)

Parameters

schemaData
Type: SystemString
The XSD schema data.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.ResolveSchemaAttribute Method

XmlSchemaResolverResolveSchemaAttribute Method

Resolves the specified XmlSchemaAttribute in the event it is a reference to another XmlSchemaAttribute.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlSchemaAttribute ResolveSchemaAttribute(
    XmlSchemaAttribute attribute
)
Public Function ResolveSchemaAttribute (
    attribute As XmlSchemaAttribute
) As XmlSchemaAttribute

Parameters

attribute
Type: System.Xml.SchemaXmlSchemaAttribute
The XmlSchemaAttribute to examine.

Return Value

Type: XmlSchemaAttribute
The resolved XmlSchemaAttribute.

Implements

IXmlSchemaResolverResolveSchemaAttribute(XmlSchemaAttribute)
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Class

Represents a XML syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.Xml.ImplementationXmlSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlSyntaxLanguage : SyntaxLanguage,
    IEditorDocumentTextChangeEventSink
Public Class XmlSyntaxLanguage
    Inherits SyntaxLanguage
    Implements IEditorDocumentTextChangeEventSink

The XmlSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSyntaxLanguage | Initializes a new instance of the XmlSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Constructor

Initializes a new instance of the XmlSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlSyntaxLanguage()
Public Sub New
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Properties

The XmlSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Methods

The XmlSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage.OnDocumentTextChanged Method

XmlSyntaxLanguageOnDocumentTextChanged Method

Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage.OnDocumentTextChanging Method

XmlSyntaxLanguageOnDocumentTextChanging Method

Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf (in ActiproSoftware.SyntaxEditor.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.Windows.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Events

The XmlSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter Class

Provides a XML language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTextFormatter

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlTextFormatter : ITextFormatter
Public Class XmlTextFormatter
    Implements ITextFormatter

The XmlTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTextFormatter | Initializes a new instance of the XmlTextFormatter class
Top
Properties
 | Name | Description
Public property | AttributeSpacingMode | Gets or sets the attribute spacing mode.
Public property | ElementSpacingMode | Gets or sets the element spacing mode.
Public property | TagWrapLength | Gets or sets the tag wrap length.
Top
Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter Constructor

Initializes a new instance of the XmlTextFormatter class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlTextFormatter()
Public Sub New
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter Properties

The XmlTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSpacingMode | Gets or sets the attribute spacing mode.
Public property | ElementSpacingMode | Gets or sets the element spacing mode.
Public property | TagWrapLength | Gets or sets the tag wrap length.
Top
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter.AttributeSpacingMode Property

XmlTextFormatterAttributeSpacingMode Property

Gets or sets the attribute spacing mode.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlAttributeSpacingMode AttributeSpacingMode { get; set; }
Public Property AttributeSpacingMode As XmlAttributeSpacingMode
    Get
    Set

Property Value

Type: XmlAttributeSpacingMode
The attribute spacing mode. The default value is Preserve.
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter.ElementSpacingMode Property

XmlTextFormatterElementSpacingMode Property

Gets or sets the element spacing mode.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlElementSpacingMode ElementSpacingMode { get; set; }
Public Property ElementSpacingMode As XmlElementSpacingMode
    Get
    Set

Property Value

Type: XmlElementSpacingMode
The element spacing mode. The default value is Preserve.
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter.TagWrapLength Property

XmlTextFormatterTagWrapLength Property

Gets or sets the tag wrap length.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int TagWrapLength { get; set; }
Public Property TagWrapLength As Integer
    Get
    Set

Property Value

Type: Int32
The tag wrap length. The default value is 0 which means disabled.
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter Methods

The XmlTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies text formatting to part or all of a snapshot.
Top
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter.Format Method

XmlTextFormatterFormat Method

Applies text formatting to part or all of a snapshot.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Format(
    ITextSnapshot snapshot,
    ITextPositionRangeCollection selectionPositionRanges,
    TextFormatMode mode = TextFormatMode.Ranges
)
Public Sub Format (
    snapshot As ITextSnapshot,
    selectionPositionRanges As ITextPositionRangeCollection,
    Optional mode As TextFormatMode = TextFormatMode.Ranges
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.
selectionPositionRanges
Type: ActiproSoftware.TextITextPositionRangeCollection
The ITextPositionRangeCollection indicating the selection position ranges. These are used to translate the current selection to the new snapshot that is created, even when formatting the entire snapshot.
mode (Optional)
Type: ActiproSoftware.TextTextFormatMode
A TextFormatMode indicating whether to format part or all of the snapshot. The default value is Ranges.

Implements

ITextFormatterFormat(ITextSnapshot, ITextPositionRangeCollection, TextFormatMode)
Remarks
The containing ITextDocument is accessible via the ITextSnapshot.
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Class

Contains the token IDs for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenId

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlTokenId : TokenIdProviderBase
Public Class XmlTokenId
    Inherits TokenIdProviderBase

The XmlTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTokenId | Initializes a new instance of the XmlTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsXmlAttributeClassificationType | Returns whether the specified ID value is part of the XmlAttribute.
 | IsXmlAttributeValueClassificationType | Returns whether the specified ID value is part of the XmlAttributeValue.
 | IsXmlCDataSectionClassificationType | Returns whether the specified ID value is part of the XmlCDataSection.
 | IsXmlCommentClassificationType | Returns whether the specified ID value is part of the XmlComment.
 | IsXmlDeclarationClassificationType | Returns whether the specified ID value is part of the XmlDeclaration.
 | IsXmlDelimiterClassificationType | Returns whether the specified ID value is part of the XmlDelimiter.
 | IsXmlEntityClassificationType | Returns whether the specified ID value is part of the XmlEntity.
 | IsXmlNameClassificationType | Returns whether the specified ID value is part of the XmlName.
 | IsXmlProcessingInstructionClassificationType | Returns whether the specified ID value is part of the XmlProcessingInstruction.
Top
Fields
Name | Description
CDataSectionEndDelimiter | Gets the CDataSectionEndDelimiter token ID.
CDataSectionStartDelimiter | Gets the CDataSectionStartDelimiter token ID.
CDataSectionText | Gets the CDataSectionText token ID.
CommentEndDelimiter | Gets the CommentEndDelimiter token ID.
CommentStartDelimiter | Gets the CommentStartDelimiter token ID.
CommentText | Gets the CommentText token ID.
DeclarationEndDelimiter | Gets the DeclarationEndDelimiter token ID.
DeclarationStartDelimiter | Gets the DeclarationStartDelimiter token ID.
DeclarationText | Gets the DeclarationText token ID.
Default | Gets the Default token ID.
DocTypeDeclarationEndDelimiter | Gets the DocTypeDeclarationEndDelimiter token ID.
DocTypeDeclarationInternalSubsetEndDelimiter | Gets the DocTypeDeclarationInternalSubsetEndDelimiter token ID.
DocTypeDeclarationInternalSubsetStartDelimiter | Gets the DocTypeDeclarationInternalSubsetStartDelimiter token ID.
DocTypeDeclarationInternalSubsetText | Gets the DocTypeDeclarationInternalSubsetText token ID.
DocTypeDeclarationStartDelimiter | Gets the DocTypeDeclarationStartDelimiter token ID.
EndTagEndDelimiter | Gets the EndTagEndDelimiter token ID.
EndTagStartDelimiter | Gets the EndTagStartDelimiter token ID.
EndTagText | Gets the EndTagText token ID.
Entity | Gets the Entity token ID.
Identifier | Gets the Identifier token ID.
InvalidEndTagStartDelimiter | Gets the InvalidEndTagStartDelimiter token ID.
InvalidStartTagStartDelimiter | Gets the InvalidStartTagStartDelimiter token ID.
ProcessingInstructionEndDelimiter | Gets the ProcessingInstructionEndDelimiter token ID.
ProcessingInstructionStartDelimiter | Gets the ProcessingInstructionStartDelimiter token ID.
ProcessingInstructionText | Gets the ProcessingInstructionText token ID.
StartTagAttributeName | Gets the StartTagAttributeName token ID.
StartTagAttributeValueEndDelimiter | Gets the StartTagAttributeValueEndDelimiter token ID.
StartTagAttributeValueStartDelimiter | Gets the StartTagAttributeValueStartDelimiter token ID.
StartTagAttributeValueText | Gets the StartTagAttributeValueText token ID.
StartTagEndDelimiter | Gets the StartTagEndDelimiter token ID.
StartTagName | Gets the StartTagName token ID.
StartTagNextTagStartDelimiter | Gets the StartTagNextTagStartDelimiter token ID.
StartTagStartDelimiter | Gets the StartTagStartDelimiter token ID.
StartTagText | Gets the StartTagText token ID.
Whitespace | Gets the Whitespace token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.611.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Constructor

Initializes a new instance of the XmlTokenId class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlTokenId()
Public Sub New
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Properties

The XmlTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.MaxId Property

XmlTokenIdMaxId Property

Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.MinId Property

XmlTokenIdMinId Property

Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Methods

The XmlTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
 | IsXmlAttributeClassificationType | Returns whether the specified ID value is part of the XmlAttribute.
 | IsXmlAttributeValueClassificationType | Returns whether the specified ID value is part of the XmlAttributeValue.
 | IsXmlCDataSectionClassificationType | Returns whether the specified ID value is part of the XmlCDataSection.
 | IsXmlCommentClassificationType | Returns whether the specified ID value is part of the XmlComment.
 | IsXmlDeclarationClassificationType | Returns whether the specified ID value is part of the XmlDeclaration.
 | IsXmlDelimiterClassificationType | Returns whether the specified ID value is part of the XmlDelimiter.
 | IsXmlEntityClassificationType | Returns whether the specified ID value is part of the XmlEntity.
 | IsXmlNameClassificationType | Returns whether the specified ID value is part of the XmlName.
 | IsXmlProcessingInstructionClassificationType | Returns whether the specified ID value is part of the XmlProcessingInstruction.
Top
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.ContainsId Method

XmlTokenIdContainsId Method

Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.GetDescription Method

XmlTokenIdGetDescription Method

Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.GetKey Method

XmlTokenIdGetKey Method

Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlAttributeClassificationType Method

XmlTokenIdIsXmlAttributeClassificationType Method

Returns whether the specified ID value is part of the XmlAttribute.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlAttributeClassificationType(
    int id
)
Public Shared Function IsXmlAttributeClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlAttributeValueClassificationType Method

XmlTokenIdIsXmlAttributeValueClassificationType Method

Returns whether the specified ID value is part of the XmlAttributeValue.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlAttributeValueClassificationType(
    int id
)
Public Shared Function IsXmlAttributeValueClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlCDataSectionClassificationType Method

XmlTokenIdIsXmlCDataSectionClassificationType Method

Returns whether the specified ID value is part of the XmlCDataSection.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlCDataSectionClassificationType(
    int id
)
Public Shared Function IsXmlCDataSectionClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlCommentClassificationType Method

XmlTokenIdIsXmlCommentClassificationType Method

Returns whether the specified ID value is part of the XmlComment.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlCommentClassificationType(
    int id
)
Public Shared Function IsXmlCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlDeclarationClassificationType Method

XmlTokenIdIsXmlDeclarationClassificationType Method

Returns whether the specified ID value is part of the XmlDeclaration.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlDeclarationClassificationType(
    int id
)
Public Shared Function IsXmlDeclarationClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlDelimiterClassificationType Method

XmlTokenIdIsXmlDelimiterClassificationType Method

Returns whether the specified ID value is part of the XmlDelimiter.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlDelimiterClassificationType(
    int id
)
Public Shared Function IsXmlDelimiterClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlEntityClassificationType Method

XmlTokenIdIsXmlEntityClassificationType Method

Returns whether the specified ID value is part of the XmlEntity.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlEntityClassificationType(
    int id
)
Public Shared Function IsXmlEntityClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlNameClassificationType Method

XmlTokenIdIsXmlNameClassificationType Method

Returns whether the specified ID value is part of the XmlName.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlNameClassificationType(
    int id
)
Public Shared Function IsXmlNameClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlProcessingInstructionClassificationType Method

XmlTokenIdIsXmlProcessingInstructionClassificationType Method

Returns whether the specified ID value is part of the XmlProcessingInstruction.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsXmlProcessingInstructionClassificationType(
    int id
)
Public Shared Function IsXmlProcessingInstructionClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Fields

The XmlTokenId type exposes the following members.

Fields
Name | Description
CDataSectionEndDelimiter | Gets the CDataSectionEndDelimiter token ID.
CDataSectionStartDelimiter | Gets the CDataSectionStartDelimiter token ID.
CDataSectionText | Gets the CDataSectionText token ID.
CommentEndDelimiter | Gets the CommentEndDelimiter token ID.
CommentStartDelimiter | Gets the CommentStartDelimiter token ID.
CommentText | Gets the CommentText token ID.
DeclarationEndDelimiter | Gets the DeclarationEndDelimiter token ID.
DeclarationStartDelimiter | Gets the DeclarationStartDelimiter token ID.
DeclarationText | Gets the DeclarationText token ID.
Default | Gets the Default token ID.
DocTypeDeclarationEndDelimiter | Gets the DocTypeDeclarationEndDelimiter token ID.
DocTypeDeclarationInternalSubsetEndDelimiter | Gets the DocTypeDeclarationInternalSubsetEndDelimiter token ID.
DocTypeDeclarationInternalSubsetStartDelimiter | Gets the DocTypeDeclarationInternalSubsetStartDelimiter token ID.
DocTypeDeclarationInternalSubsetText | Gets the DocTypeDeclarationInternalSubsetText token ID.
DocTypeDeclarationStartDelimiter | Gets the DocTypeDeclarationStartDelimiter token ID.
EndTagEndDelimiter | Gets the EndTagEndDelimiter token ID.
EndTagStartDelimiter | Gets the EndTagStartDelimiter token ID.
EndTagText | Gets the EndTagText token ID.
Entity | Gets the Entity token ID.
Identifier | Gets the Identifier token ID.
InvalidEndTagStartDelimiter | Gets the InvalidEndTagStartDelimiter token ID.
InvalidStartTagStartDelimiter | Gets the InvalidStartTagStartDelimiter token ID.
ProcessingInstructionEndDelimiter | Gets the ProcessingInstructionEndDelimiter token ID.
ProcessingInstructionStartDelimiter | Gets the ProcessingInstructionStartDelimiter token ID.
ProcessingInstructionText | Gets the ProcessingInstructionText token ID.
StartTagAttributeName | Gets the StartTagAttributeName token ID.
StartTagAttributeValueEndDelimiter | Gets the StartTagAttributeValueEndDelimiter token ID.
StartTagAttributeValueStartDelimiter | Gets the StartTagAttributeValueStartDelimiter token ID.
StartTagAttributeValueText | Gets the StartTagAttributeValueText token ID.
StartTagEndDelimiter | Gets the StartTagEndDelimiter token ID.
StartTagName | Gets the StartTagName token ID.
StartTagNextTagStartDelimiter | Gets the StartTagNextTagStartDelimiter token ID.
StartTagStartDelimiter | Gets the StartTagStartDelimiter token ID.
StartTagText | Gets the StartTagText token ID.
Whitespace | Gets the Whitespace token ID.
Top
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CDataSectionEndDelimiter Field

XmlTokenIdCDataSectionEndDelimiter Field

Gets the CDataSectionEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CDataSectionEndDelimiter = 12029
Public Const CDataSectionEndDelimiter As Integer = 12029

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CDataSectionStartDelimiter Field

XmlTokenIdCDataSectionStartDelimiter Field

Gets the CDataSectionStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CDataSectionStartDelimiter = 12028
Public Const CDataSectionStartDelimiter As Integer = 12028

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CDataSectionText Field

XmlTokenIdCDataSectionText Field

Gets the CDataSectionText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CDataSectionText = 12027
Public Const CDataSectionText As Integer = 12027

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CommentEndDelimiter Field

XmlTokenIdCommentEndDelimiter Field

Gets the CommentEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentEndDelimiter = 12020
Public Const CommentEndDelimiter As Integer = 12020

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CommentStartDelimiter Field

XmlTokenIdCommentStartDelimiter Field

Gets the CommentStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentStartDelimiter = 12019
Public Const CommentStartDelimiter As Integer = 12019

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CommentText Field

XmlTokenIdCommentText Field

Gets the CommentText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int CommentText = 12018
Public Const CommentText As Integer = 12018

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DeclarationEndDelimiter Field

XmlTokenIdDeclarationEndDelimiter Field

Gets the DeclarationEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DeclarationEndDelimiter = 12026
Public Const DeclarationEndDelimiter As Integer = 12026

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DeclarationStartDelimiter Field

XmlTokenIdDeclarationStartDelimiter Field

Gets the DeclarationStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DeclarationStartDelimiter = 12025
Public Const DeclarationStartDelimiter As Integer = 12025

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DeclarationText Field

XmlTokenIdDeclarationText Field

Gets the DeclarationText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DeclarationText = 12024
Public Const DeclarationText As Integer = 12024

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.Default Field

XmlTokenIdDefault Field

Gets the Default token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Default = 12000
Public Const Default As Integer = 12000

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationEndDelimiter Field

XmlTokenIdDocTypeDeclarationEndDelimiter Field

Gets the DocTypeDeclarationEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationEndDelimiter = 12031
Public Const DocTypeDeclarationEndDelimiter As Integer = 12031

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationInternalSubsetEndDelimiter Field

XmlTokenIdDocTypeDeclarationInternalSubsetEndDelimiter Field

Gets the DocTypeDeclarationInternalSubsetEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationInternalSubsetEndDelimiter = 12034
Public Const DocTypeDeclarationInternalSubsetEndDelimiter As Integer = 12034

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationInternalSubsetStartDelimiter Field

XmlTokenIdDocTypeDeclarationInternalSubsetStartDelimiter Field

Gets the DocTypeDeclarationInternalSubsetStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationInternalSubsetStartDelimiter = 12033
Public Const DocTypeDeclarationInternalSubsetStartDelimiter As Integer = 12033

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationInternalSubsetText Field

XmlTokenIdDocTypeDeclarationInternalSubsetText Field

Gets the DocTypeDeclarationInternalSubsetText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationInternalSubsetText = 12032
Public Const DocTypeDeclarationInternalSubsetText As Integer = 12032

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationStartDelimiter Field

XmlTokenIdDocTypeDeclarationStartDelimiter Field

Gets the DocTypeDeclarationStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationStartDelimiter = 12030
Public Const DocTypeDeclarationStartDelimiter As Integer = 12030

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.EndTagEndDelimiter Field

XmlTokenIdEndTagEndDelimiter Field

Gets the EndTagEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EndTagEndDelimiter = 12017
Public Const EndTagEndDelimiter As Integer = 12017

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.EndTagStartDelimiter Field

XmlTokenIdEndTagStartDelimiter Field

Gets the EndTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EndTagStartDelimiter = 12016
Public Const EndTagStartDelimiter As Integer = 12016

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.EndTagText Field

XmlTokenIdEndTagText Field

Gets the EndTagText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int EndTagText = 12015
Public Const EndTagText As Integer = 12015

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.Entity Field

XmlTokenIdEntity Field

Gets the Entity token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Entity = 12001
Public Const Entity As Integer = 12001

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.Identifier Field

XmlTokenIdIdentifier Field

Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Identifier = 12002
Public Const Identifier As Integer = 12002

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.InvalidEndTagStartDelimiter Field

XmlTokenIdInvalidEndTagStartDelimiter Field

Gets the InvalidEndTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InvalidEndTagStartDelimiter = 12004
Public Const InvalidEndTagStartDelimiter As Integer = 12004

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.InvalidStartTagStartDelimiter Field

XmlTokenIdInvalidStartTagStartDelimiter Field

Gets the InvalidStartTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int InvalidStartTagStartDelimiter = 12005
Public Const InvalidStartTagStartDelimiter As Integer = 12005

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.ProcessingInstructionEndDelimiter Field

XmlTokenIdProcessingInstructionEndDelimiter Field

Gets the ProcessingInstructionEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ProcessingInstructionEndDelimiter = 12023
Public Const ProcessingInstructionEndDelimiter As Integer = 12023

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.ProcessingInstructionStartDelimiter Field

XmlTokenIdProcessingInstructionStartDelimiter Field

Gets the ProcessingInstructionStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ProcessingInstructionStartDelimiter = 12022
Public Const ProcessingInstructionStartDelimiter As Integer = 12022

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.ProcessingInstructionText Field

XmlTokenIdProcessingInstructionText Field

Gets the ProcessingInstructionText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int ProcessingInstructionText = 12021
Public Const ProcessingInstructionText As Integer = 12021

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagAttributeName Field

XmlTokenIdStartTagAttributeName Field

Gets the StartTagAttributeName token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagAttributeName = 12010
Public Const StartTagAttributeName As Integer = 12010

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagAttributeValueEndDelimiter Field

XmlTokenIdStartTagAttributeValueEndDelimiter Field

Gets the StartTagAttributeValueEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagAttributeValueEndDelimiter = 12014
Public Const StartTagAttributeValueEndDelimiter As Integer = 12014

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagAttributeValueStartDelimiter Field

XmlTokenIdStartTagAttributeValueStartDelimiter Field

Gets the StartTagAttributeValueStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagAttributeValueStartDelimiter = 12013
Public Const StartTagAttributeValueStartDelimiter As Integer = 12013

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagAttributeValueText Field

XmlTokenIdStartTagAttributeValueText Field

Gets the StartTagAttributeValueText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagAttributeValueText = 12012
Public Const StartTagAttributeValueText As Integer = 12012

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagEndDelimiter Field

XmlTokenIdStartTagEndDelimiter Field

Gets the StartTagEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagEndDelimiter = 12008
Public Const StartTagEndDelimiter As Integer = 12008

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagName Field

XmlTokenIdStartTagName Field

Gets the StartTagName token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagName = 12009
Public Const StartTagName As Integer = 12009

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagNextTagStartDelimiter Field

XmlTokenIdStartTagNextTagStartDelimiter Field

Gets the StartTagNextTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagNextTagStartDelimiter = 12011
Public Const StartTagNextTagStartDelimiter As Integer = 12011

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagStartDelimiter Field

XmlTokenIdStartTagStartDelimiter Field

Gets the StartTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagStartDelimiter = 12007
Public Const StartTagStartDelimiter As Integer = 12007

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagText Field

XmlTokenIdStartTagText Field

Gets the StartTagText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int StartTagText = 12006
Public Const StartTagText As Integer = 12006

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.Whitespace Field

XmlTokenIdWhitespace Field

Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Whitespace = 12003
Public Const Whitespace As Integer = 12003

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader Class

Represents an object that can provide tokens to a ILLParser in a forward-only direction for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenReader

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlTokenReader : MergableTokenReader
Public Class XmlTokenReader
    Inherits MergableTokenReader

The XmlTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTokenReader | Initializes a new instance of the XmlTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader Constructor

Initializes a new instance of the XmlTokenReader class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

XmlTokenReader Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader Properties

The XmlTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

XmlTokenReader Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader Methods

The XmlTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Top
See Also

Reference

XmlTokenReader Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader.GetNextToken Method

XmlTokenReaderGetNextToken Method

Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

XmlTokenReader Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Class

Represents a token tagger for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTagger

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlTokenTagger : TokenTagger
Public Class XmlTokenTagger
    Inherits TokenTagger

The XmlTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTokenTagger | Initializes a new instance of the XmlTokenTagger class.
Top
Properties
 | Name | Description
Public property | ClassificationTypeProvider | Gets the IXmlClassificationTypeProvider that provides classification types used by this token tagger.
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Inherited from TokenTagger.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.542.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Constructor

Initializes a new instance of the XmlTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlTokenTagger(
    ICodeDocument document,
    IXmlClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    document As ICodeDocument,
    classificationTypeProvider As IXmlClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypeProvider
Type: ActiproSoftware.Text.Languages.XmlIXmlClassificationTypeProvider
A IXmlClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Properties

The XmlTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationTypeProvider | Gets the IXmlClassificationTypeProvider that provides classification types used by this token tagger.
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger.ClassificationTypeProvider Property

XmlTokenTaggerClassificationTypeProvider Property

Gets the IXmlClassificationTypeProvider that provides classification types used by this token tagger.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IXmlClassificationTypeProvider ClassificationTypeProvider { get; }
Public ReadOnly Property ClassificationTypeProvider As IXmlClassificationTypeProvider
    Get

Property Value

Type: IXmlClassificationTypeProvider
The IXmlClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Methods

The XmlTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Inherited from TokenTagger.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Top
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Events

The XmlTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider Class

Represents a provider of XmlTokenTagger objects for documents that use the XmlTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase XmlTokenTagger
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlTokenTaggerProvider : TaggerProviderBase<XmlTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class XmlTokenTaggerProvider
    Inherits TaggerProviderBase(Of XmlTokenTagger)
    Implements ICodeDocumentTaggerProvider

The XmlTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTokenTaggerProvider | Initializes a new instance of the XmlTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.542.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2019 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider Constructor

Initializes a new instance of the XmlTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlTokenTaggerProvider(
    IXmlClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IXmlClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.XmlIXmlClassificationTypeProvider
A IXmlClassificationTypeProvider that provides classification types.
See Also

Reference

XmlTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider Properties

The XmlTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

XmlTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider Methods

The XmlTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Top
See Also

Reference

XmlTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider.GetTagger(T) Method

XmlTokenTaggerProviderGetTaggerT Method

Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

XmlTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider.TaggerFactory Class

XmlTokenTaggerProviderTaggerFactory Class

Implements a factory that can creates XmlTokenTagger objects for a document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTaggerProviderTaggerFactory

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TaggerFactory
Public Class TaggerFactory

The XmlTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an XmlTokenTagger for the ICodeDocument.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


TaggerFactory Methods

The XmlTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an XmlTokenTagger for the ICodeDocument.
Top
See Also

Reference

XmlTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider.TaggerFactory.CreateTagger Method

XmlTokenTaggerProviderTaggerFactoryCreateTagger Method

Creates an XmlTokenTagger for the ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlTokenTagger CreateTagger()
Public Function CreateTagger As XmlTokenTagger

Return Value

Type: XmlTokenTagger
An XmlTokenTagger for the ICodeDocument.
See Also

Reference

XmlTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlValidator Class

Provides a class that can validate XML, using the schemas in an IXmlSchemaResolver if available.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlValidator

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlValidator : IXmlValidator
Public Class XmlValidator
    Implements IXmlValidator

The XmlValidator type exposes the following members.

Constructors
 | Name | Description
Public method | XmlValidator | Initializes a new instance of the XmlValidator class
Top
Properties
 | Name | Description
Public property | DtdPath | Gets or sets the path to the folder where DTDs are located.
Public property | Mode | Gets or sets the validation mode used by the validator.
Top
Methods
 | Name | Description
Protected method | CreateXmlReader | Creates the XmlReader to use for validation purposes.
Protected method | IsValidationExceptionAllowed | Returns whether the exception specified in the ValidationEventArgs should be reported.
Public method | Validate | Validates the XML that is being parsed.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlValidator interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlValidator Constructor

Initializes a new instance of the XmlValidator class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlValidator()
Public Sub New
See Also

Reference

XmlValidator Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlValidator Properties

The XmlValidator type exposes the following members.

Properties
 | Name | Description
Public property | DtdPath | Gets or sets the path to the folder where DTDs are located.
Public property | Mode | Gets or sets the validation mode used by the validator.
Top
See Also

Reference

XmlValidator Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlValidator.DtdPath Property

XmlValidatorDtdPath Property

Gets or sets the path to the folder where DTDs are located.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DtdPath { get; set; }
Public Property DtdPath As String
    Get
    Set

Property Value

Type: String
The path to the folder where DTDs are located.
Remarks
This property is only used when the Mode property is set to Dtd or SchemaWithDtd. If this property is left , no explicit base path will be set for DTD loading. If this property is set, it should be the path to the folder that contains the DTDs that may be referenced.
See Also

Reference

XmlValidator Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlValidator.Mode Property

XmlValidatorMode Property

Gets or sets the validation mode used by the validator.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlValidationMode Mode { get; set; }
Public Property Mode As XmlValidationMode
    Get
    Set

Property Value

Type: XmlValidationMode
The validation mode used by the validator. The default value is Schema.
See Also

Reference

XmlValidator Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlValidator Methods

The XmlValidator type exposes the following members.

Methods
 | Name | Description
Protected method | CreateXmlReader | Creates the XmlReader to use for validation purposes.
Protected method | IsValidationExceptionAllowed | Returns whether the exception specified in the ValidationEventArgs should be reported.
Public method | Validate | Validates the XML that is being parsed.
Top
See Also

Reference

XmlValidator Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlValidator.CreateXmlReader Method

XmlValidatorCreateXmlReader Method

Creates the XmlReader to use for validation purposes.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual XmlReader CreateXmlReader(
    TextReader reader,
    XmlReaderSettings settings,
    XmlParserContext context
)
Protected Overridable Function CreateXmlReader (
    reader As TextReader,
    settings As XmlReaderSettings,
    context As XmlParserContext
) As XmlReader

Parameters

reader
Type: System.IOTextReader
The base TextReader to use for reading text.
settings
Type: System.XmlXmlReaderSettings
The XmlReaderSettings to use.
context
Type: System.XmlXmlParserContext
The XmlParserContext to use.

Return Value

Type: XmlReader
The XmlReader that was created.
Remarks
Override this method to customize the XmlReader used during XML validation.
See Also

Reference

XmlValidator Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlValidator.IsValidationExceptionAllowed Method

XmlValidatorIsValidationExceptionAllowed Method

Returns whether the exception specified in the ValidationEventArgs should be reported.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsValidationExceptionAllowed(
    ValidationEventArgs e
)
Protected Overridable Function IsValidationExceptionAllowed (
    e As ValidationEventArgs
) As Boolean

Parameters

e
Type: System.Xml.SchemaValidationEventArgs
The ValidationEventArgs to examine.

Return Value

Type: Boolean
true if the exception should be reported; otherwise, false.
See Also

Reference

XmlValidator Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlValidator.Validate Method

XmlValidatorValidate Method

Validates the XML that is being parsed.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: ActiproSoftware.Text.Addons.Xml.Wpf (in ActiproSoftware.Text.Addons.Xml.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<IParseError> Validate(
    IParseRequest request,
    IAstNode ast
)
Public Function Validate (
    request As IParseRequest,
    ast As IAstNode
) As IEnumerable(Of IParseError)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
ast
Type: ActiproSoftware.Text.ParsingIAstNode
The root IAstNode of the parse result AST, if known.

Return Value

Type: IEnumerable IParseError
The collection of validation errors that were found, if any.

Implements

IXmlValidatorValidate(IParseRequest, IAstNode)
See Also

Reference

XmlValidator Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


ActiproSoftware.Text.Lexing Namespace

Contains types related to lexing.
Classes
 | Class | Description
Public class | MergableLexerResult | Provides a lexer result for a token.
Interfaces
 | Interface | Description
Public interface | ILexer | Provides the base requirements of a lexer (lexical analyzer) for a language.
Public interface | ILexerContext | Provides the base requirements for a class that stores lexer context data, allowing a lexer to resume at the point represented by the context.
Public interface | ILexerTarget | Provides the base requirements for an object that should receive parse output from a lexer.
Public interface | ILexicalScope | Provides the base requirements for a lexical scope.
Public interface | ILexicalScopeCollection | Provides the base requirements for a collection of ILexicalScope objects.
Public interface | ILexicalScopeStateNode | Provides the base requirements for a node that stores lexical scope and state information.
Public interface | ILexicalState | Provides the base requirements for a lexical state.
Public interface | ILexicalStateCollection | Provides the base requirements for a collection of ILexicalState objects.
Public interface | ILexicalStateIdProvider | Provides the base requirements for a class that provides lexical state ID's.
Public interface | ILexicalStateTransition | Provides the base requirements for a transition from one lexical state to another.
Public interface | IMergableLexer | Provides the base requirements for a lexer (lexical analyzer) for a language that supports merging with other languages.
Public interface | IMergableToken | Represents the base requirements for a mergable token that has been assigned to a span of text by a mergable lexer.
Public interface | IMergableTokenLexerData | Provides the base requirements for an object that provides lexer data for a IMergableToken.
Public interface | IToken | Represents the base requirements for a token that has been assigned to a span of text by a lexer.
Public interface | ITokenIdProvider | Provides the base requirements for a class that provides token ID's.
Public interface | ITokenSet | Provides the base requirements for a class that stores token data for a range of text.
Enumerations
 | Enumeration | Description
Public enumeration | MergableLexerFlags | Specifies flags for an IMergableToken.


ILexer Interface

Provides the base requirements of a lexer (lexical analyzer) for a language.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexer : IKeyedObject
Public Interface ILexer
    Inherits IKeyedObject

The ILexer type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Top
Methods
 | Name | Description
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexer Properties

The ILexer type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Top
See Also

Reference

ILexer Interface
ActiproSoftware.Text.Lexing Namespace


ILexer.TokenIdProvider Property

ILexerTokenIdProvider Property

Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITokenIdProvider TokenIdProvider { get; }
ReadOnly Property TokenIdProvider As ITokenIdProvider
    Get

Property Value

Type: ITokenIdProvider
The ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
See Also

Reference

ILexer Interface
ActiproSoftware.Text.Lexing Namespace


ILexer Methods

The ILexer type exposes the following members.

Methods
 | Name | Description
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Top
See Also

Reference

ILexer Interface
ActiproSoftware.Text.Lexing Namespace


ILexer.Parse Method

ILexerParse Method

Lexically parses the specified TextRange of the ITextSnapshot.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange Parse(
    TextSnapshotRange snapshotRange,
    ILexerTarget parseTarget
)
Function Parse (
    snapshotRange As TextSnapshotRange,
    parseTarget As ILexerTarget
) As TextRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange indicating the offset range to parse.
parseTarget
Type: ActiproSoftware.Text.LexingILexerTarget
The ILexerTarget that receives the parsing output.

Return Value

Type: TextRange
A TextRange containing the offset range that was modified.
See Also

Reference

ILexer Interface
ActiproSoftware.Text.Lexing Namespace


ILexerContext Interface

Provides the base requirements for a class that stores lexer context data, allowing a lexer to resume at the point represented by the context.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexerContext
Public Interface ILexerContext

The ILexerContext type exposes the following members.

Properties
 | Name | Description
Public property | ScopeState | Gets the ILexicalScopeStateNode that represents the stack of lexical scopes and states in place at where the context is resuming.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexerContext Properties

The ILexerContext type exposes the following members.

Properties
 | Name | Description
Public property | ScopeState | Gets the ILexicalScopeStateNode that represents the stack of lexical scopes and states in place at where the context is resuming.
Top
See Also

Reference

ILexerContext Interface
ActiproSoftware.Text.Lexing Namespace


ILexerContext.ScopeState Property

ILexerContextScopeState Property

Gets the ILexicalScopeStateNode that represents the stack of lexical scopes and states in place at where the context is resuming.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalScopeStateNode ScopeState { get; }
ReadOnly Property ScopeState As ILexicalScopeStateNode
    Get

Property Value

Type: ILexicalScopeStateNode
The ILexicalScopeStateNode that represents the stack of lexical scopes and states in place at where the context is resuming.
See Also

Reference

ILexerContext Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget Interface

Provides the base requirements for an object that should receive parse output from a lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexerTarget
Public Interface ILexerTarget

The ILexerTarget type exposes the following members.

Properties
 | Name | Description
Public property | HasInitialContext | Gets whether an initial context is available, from which incremental parsing can resume.
Top
Methods
 | Name | Description
Public method | OnPostParse | Occurs after lexing ends.
Public method | OnPreParse | Occurs before lexing starts.
Public method | OnTokenParsed | Occurs when an IToken is parsed by the lexer.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexerTarget Properties

The ILexerTarget type exposes the following members.

Properties
 | Name | Description
Public property | HasInitialContext | Gets whether an initial context is available, from which incremental parsing can resume.
Top
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget.HasInitialContext Property

ILexerTargetHasInitialContext Property

Gets whether an initial context is available, from which incremental parsing can resume.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasInitialContext { get; }
ReadOnly Property HasInitialContext As Boolean
    Get

Property Value

Type: Boolean
true if an initial context is available; otherwise, false.
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget Methods

The ILexerTarget type exposes the following members.

Methods
 | Name | Description
Public method | OnPostParse | Occurs after lexing ends.
Public method | OnPreParse | Occurs before lexing starts.
Public method | OnTokenParsed | Occurs when an IToken is parsed by the lexer.
Top
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget.OnPostParse Method

ILexerTargetOnPostParse Method

Occurs after lexing ends.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void OnPostParse(
    int endOffset
)
Sub OnPostParse (
    endOffset As Integer
)

Parameters

endOffset
Type: SystemInt32
The offset at which parsing has stopped.
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget.OnPreParse Method

ILexerTargetOnPreParse Method

Occurs before lexing starts.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexerContext OnPreParse(
    ref int startOffset
)
Function OnPreParse (
    ByRef startOffset As Integer
) As ILexerContext

Parameters

startOffset
Type: SystemInt32
The offset at which parsing will commence.

Return Value

Type: ILexerContext
A ILexerContext that contains information about the starting context.
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget.OnTokenParsed Method

ILexerTargetOnTokenParsed Method

Occurs when an IToken is parsed by the lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool OnTokenParsed(
    IToken newToken,
    ILexicalScopeStateNode scopeStateNode
)
Function OnTokenParsed (
    newToken As IToken,
    scopeStateNode As ILexicalScopeStateNode
) As Boolean

Parameters

newToken
Type: ActiproSoftware.Text.LexingIToken
The IToken that was parsed.
scopeStateNode
Type: ActiproSoftware.Text.LexingILexicalScopeStateNode
The ILexicalScopeStateNode at the start of the token.

Return Value

Type: Boolean
true if the lexing should continue; otherwise, false.
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope Interface

Provides the base requirements for a lexical scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexicalScope
Public Interface ILexicalScope

The ILexicalScope type exposes the following members.

Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets whether ancestor end scope checking is enabled while parsing inside the scope.
Public property | LexicalState | Gets the ILexicalState that defines the lexical scope.
Public property | ParentTransition | Gets the ILexicalStateTransition that is the parent of this scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets the ILexicalStateTransition that this scope performs after ending.
Top
Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexicalScope Properties

The ILexicalScope type exposes the following members.

Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets whether ancestor end scope checking is enabled while parsing inside the scope.
Public property | LexicalState | Gets the ILexicalState that defines the lexical scope.
Public property | ParentTransition | Gets the ILexicalStateTransition that is the parent of this scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets the ILexicalStateTransition that this scope performs after ending.
Top
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.IsAncestorEndScopeCheckEnabled Property

ILexicalScopeIsAncestorEndScopeCheckEnabled Property

Gets whether ancestor end scope checking is enabled while parsing inside the scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAncestorEndScopeCheckEnabled { get; }
ReadOnly Property IsAncestorEndScopeCheckEnabled As Boolean
    Get

Property Value

Type: Boolean
true if ancestor end scope checking is enabled; otherwise, false.
Remarks
When enabled, this allows ancestor scopes to be examined to see a pattern matches their end scope. In the event a match is found, this scope exits as well as the ancestor's scope.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.LexicalState Property

ILexicalScopeLexicalState Property

Gets the ILexicalState that defines the lexical scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalState LexicalState { get; }
ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that defines the lexical scope.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.ParentTransition Property

ILexicalScopeParentTransition Property

Gets the ILexicalStateTransition that is the parent of this scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalStateTransition ParentTransition { get; }
ReadOnly Property ParentTransition As ILexicalStateTransition
    Get

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that is the parent of this scope.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.Tag Property

ILexicalScopeTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.Transition Property

ILexicalScopeTransition Property

Gets the ILexicalStateTransition that this scope performs after ending.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalStateTransition Transition { get; }
ReadOnly Property Transition As ILexicalStateTransition
    Get

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that this scope performs after ending. If the value is , then no state transition is performed when the scope ends.
Remarks
The state transition may be made to a child language.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope Methods

The ILexicalScope type exposes the following members.

Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.
Top
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.IsScopeEnd Method

ILexicalScopeIsScopeEnd Method

Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
MergableLexerResult IsScopeEnd(
    ITextBufferReader reader
)
Function IsScopeEnd (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.IsScopeStart Method

ILexicalScopeIsScopeStart Method

Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
MergableLexerResult IsScopeStart(
    ITextBufferReader reader
)
Function IsScopeStart (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeCollection Interface

Provides the base requirements for a collection of ILexicalScope objects.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexicalScopeCollection : IEnumerable,
    IList<ILexicalScope>, ICollection<ILexicalScope>, IEnumerable<ILexicalScope>
Public Interface ILexicalScopeCollection
    Inherits IEnumerable, IList(Of ILexicalScope), ICollection(Of ILexicalScope),
    IEnumerable(Of ILexicalScope)

The ILexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ILexicalScope .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ILexicalScope .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList ILexicalScope .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ILexicalScope .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ILexicalScope .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ILexicalScope .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ILexicalScope .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ILexicalScope .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ILexicalScope .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ILexicalScope .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ILexicalScope .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeILexicalScope | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeILexicalScope | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllILexicalScope | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeCollection


ILexicalScopeCollection Properties

The ILexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ILexicalScope .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ILexicalScope .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList ILexicalScope .)
Top
See Also

Reference

ILexicalScopeCollection Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeCollection Methods

The ILexicalScopeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ILexicalScope .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ILexicalScope .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ILexicalScope .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ILexicalScope .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ILexicalScope .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ILexicalScope .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ILexicalScope .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ILexicalScope .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeILexicalScope | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeILexicalScope | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllILexicalScope | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ILexicalScopeCollection Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode Interface

Provides the base requirements for a node that stores lexical scope and state information.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexicalScopeStateNode
Public Interface ILexicalScopeStateNode

The ILexicalScopeStateNode type exposes the following members.

Properties
 | Name | Description
Public property | LexicalScope | Gets or sets the ILexicalScope represented by this node.
Public property | LexicalState | Gets or sets the ILexicalState represented by this node.
Public property | Parent | Gets or sets the parent ILexicalScopeStateNode.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode Properties

The ILexicalScopeStateNode type exposes the following members.

Properties
 | Name | Description
Public property | LexicalScope | Gets or sets the ILexicalScope represented by this node.
Public property | LexicalState | Gets or sets the ILexicalState represented by this node.
Public property | Parent | Gets or sets the parent ILexicalScopeStateNode.
Top
See Also

Reference

ILexicalScopeStateNode Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode.LexicalScope Property

ILexicalScopeStateNodeLexicalScope Property

Gets or sets the ILexicalScope represented by this node.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalScope LexicalScope { get; set; }
Property LexicalScope As ILexicalScope
    Get
    Set

Property Value

Type: ILexicalScope
The ILexicalScope represented by this node.
See Also

Reference

ILexicalScopeStateNode Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode.LexicalState Property

ILexicalScopeStateNodeLexicalState Property

Gets or sets the ILexicalState represented by this node.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalState LexicalState { get; set; }
Property LexicalState As ILexicalState
    Get
    Set

Property Value

Type: ILexicalState
The ILexicalState represented by this node.
See Also

Reference

ILexicalScopeStateNode Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode.Parent Property

ILexicalScopeStateNodeParent Property

Gets or sets the parent ILexicalScopeStateNode.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalScopeStateNode Parent { get; set; }
Property Parent As ILexicalScopeStateNode
    Get
    Set

Property Value

Type: ILexicalScopeStateNode
The parent ILexicalScopeStateNode.
See Also

Reference

ILexicalScopeStateNode Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState Interface

Provides the base requirements for a lexical state.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexicalState : IKeyedObject
Public Interface ILexicalState
    Inherits IKeyedObject

The ILexicalState type exposes the following members.

Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns.
Public property | Id | Gets the ID value that identifies the lexical state.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Lexer | Gets the ILexer that contains the state.
Public property | LexicalScopes | Gets the collection of lexical scopes.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexicalState Properties

The ILexicalState type exposes the following members.

Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns.
Public property | Id | Gets the ID value that identifies the lexical state.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Lexer | Gets the ILexer that contains the state.
Public property | LexicalScopes | Gets the collection of lexical scopes.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.
Top
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.ChildLexicalStates Property

ILexicalStateChildLexicalStates Property

Gets the collection of child lexical states.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalStateCollection ChildLexicalStates { get; }
ReadOnly Property ChildLexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
A ILexicalStateCollection containing the child lexical states.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.DefaultTokenId Property

ILexicalStateDefaultTokenId Property

Gets or sets the ID of the default token that this state assigns.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int DefaultTokenId { get; set; }
Property DefaultTokenId As Integer
    Get
    Set

Property Value

Type: Int32
The ID of the default token that this state assigns.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.Id Property

ILexicalStateId Property

Gets the ID value that identifies the lexical state.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Id { get; }
ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The ID value that identifies the lexical state.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.Lexer Property

ILexicalStateLexer Property

Gets the ILexer that contains the state.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexer Lexer { get; }
ReadOnly Property Lexer As ILexer
    Get

Property Value

Type: ILexer
The ILexer that contains the state.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.LexicalScopes Property

ILexicalStateLexicalScopes Property

Gets the collection of lexical scopes.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalScopeCollection LexicalScopes { get; }
ReadOnly Property LexicalScopes As ILexicalScopeCollection
    Get

Property Value

Type: ILexicalScopeCollection
A ILexicalScopeCollection containing the lexical scopes.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.Tag Property

ILexicalStateTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.Transition Property

ILexicalStateTransition Property

Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalStateTransition Transition { get; set; }
Property Transition As ILexicalStateTransition
    Get
    Set

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that is performed immediately after a start scope match.
Remarks
This provides a mechanism to automatically transition to another language when this state's start scope is matched. This state's end scope may be used to exit the child language.

ASP-style tags are an example of when to use this transition.

See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateCollection Interface

Provides the base requirements for a collection of ILexicalState objects.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexicalStateCollection : IEnumerable,
    IList<ILexicalState>, ICollection<ILexicalState>, IEnumerable<ILexicalState>
Public Interface ILexicalStateCollection
    Inherits IEnumerable, IList(Of ILexicalState), ICollection(Of ILexicalState),
    IEnumerable(Of ILexicalState)

The ILexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ILexicalState .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ILexicalState .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList ILexicalState .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ILexicalState .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ILexicalState .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ILexicalState .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ILexicalState .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ILexicalState .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ILexicalState .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ILexicalState .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ILexicalState .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeILexicalState | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeILexicalState | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllILexicalState | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationLexicalStateCollection


ILexicalStateCollection Properties

The ILexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ILexicalState .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ILexicalState .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList ILexicalState .)
Top
See Also

Reference

ILexicalStateCollection Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateCollection Methods

The ILexicalStateCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ILexicalState .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ILexicalState .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ILexicalState .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ILexicalState .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ILexicalState .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ILexicalState .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ILexicalState .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ILexicalState .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeILexicalState | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeILexicalState | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllILexicalState | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ILexicalStateCollection Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateIdProvider Interface

Provides the base requirements for a class that provides lexical state ID's.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexicalStateIdProvider : IIdProvider
Public Interface ILexicalStateIdProvider
    Inherits IIdProvider

The ILexicalStateIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexicalStateIdProvider Properties

The ILexicalStateIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
See Also

Reference

ILexicalStateIdProvider Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateIdProvider Methods

The ILexicalStateIdProvider type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ILexicalStateIdProvider Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition Interface

Provides the base requirements for a transition from one lexical state to another.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILexicalStateTransition
Public Interface ILexicalStateTransition

The ILexicalStateTransition type exposes the following members.

Properties
 | Name | Description
Public property | ChildLanguage | Gets the ISyntaxLanguage that contains the ChildLexicalState.
Public property | ChildLexicalScope | Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
Public property | ChildLexicalState | Gets the ILexicalState into which a transition is made.
Public property | ParentLexicalScope | Gets the ILexicalScope that owns this state transition.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationLexicalStateTransition


ILexicalStateTransition Properties

The ILexicalStateTransition type exposes the following members.

Properties
 | Name | Description
Public property | ChildLanguage | Gets the ISyntaxLanguage that contains the ChildLexicalState.
Public property | ChildLexicalScope | Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
Public property | ChildLexicalState | Gets the ILexicalState into which a transition is made.
Public property | ParentLexicalScope | Gets the ILexicalScope that owns this state transition.
Top
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition.ChildLanguage Property

ILexicalStateTransitionChildLanguage Property

Gets the ISyntaxLanguage that contains the ChildLexicalState.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISyntaxLanguage ChildLanguage { get; }
ReadOnly Property ChildLanguage As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that contains the ChildLexicalState.
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition.ChildLexicalScope Property

ILexicalStateTransitionChildLexicalScope Property

Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalScope ChildLexicalScope { get; }
ReadOnly Property ChildLexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition.ChildLexicalState Property

ILexicalStateTransitionChildLexicalState Property

Gets the ILexicalState into which a transition is made.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalState ChildLexicalState { get; }
ReadOnly Property ChildLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState into which a transition is made.
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition.ParentLexicalScope Property

ILexicalStateTransitionParentLexicalScope Property

Gets the ILexicalScope that owns this state transition.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalScope ParentLexicalScope { get; }
ReadOnly Property ParentLexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope that owns this state transition.
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer Interface

Provides the base requirements for a lexer (lexical analyzer) for a language that supports merging with other languages.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IMergableLexer : IKeyedObject,
    ILexer
Public Interface IMergableLexer
    Inherits IKeyedObject, ILexer

The IMergableLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from ILexer.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document.
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data.
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer.
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from ILexer.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


IMergableLexer Properties

The IMergableLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from ILexer.)
Top
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.DefaultLexicalState Property

IMergableLexerDefaultLexicalState Property

Gets or sets the root ILexicalState for when the language is entered.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalState DefaultLexicalState { get; }
ReadOnly Property DefaultLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The root ILexicalState for when the language is entered.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.LexicalStateIdProvider Property

IMergableLexerLexicalStateIdProvider Property

Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalStateIdProvider LexicalStateIdProvider { get; }
ReadOnly Property LexicalStateIdProvider As ILexicalStateIdProvider
    Get

Property Value

Type: ILexicalStateIdProvider
The ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer Methods

The IMergableLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document.
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data.
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer.
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from ILexer.)
Top
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.CreateChangeBatch Method

IMergableLexerCreateChangeBatch Method

Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDisposable CreateChangeBatch()
Function CreateChangeBatch As IDisposable

Return Value

Type: IDisposable
An IDisposable object. Once disposed, the batch is ended.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.CreateDocumentEndToken Method

IMergableLexerCreateDocumentEndToken Method

Creates an IMergableToken that represents the end of a document.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IMergableToken CreateDocumentEndToken(
    int startOffset,
    TextPosition startPosition,
    ILexicalState lexicalState
)
Function CreateDocumentEndToken (
    startOffset As Integer,
    startPosition As TextPosition,
    lexicalState As ILexicalState
) As IMergableToken

Parameters

startOffset
Type: SystemInt32
The start offset of the IToken.
startPosition
Type: ActiproSoftware.TextTextPosition
The start TextPosition of the IToken.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.

Return Value

Type: IMergableToken
An IMergableToken that represents the end of a document.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.CreateToken Method

IMergableLexerCreateToken Method

Creates an IMergableToken that represents the range of text with the specified lexer data.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IMergableToken CreateToken(
    int startOffset,
    int length,
    TextPosition startPosition,
    TextPosition endPosition,
    MergableLexerFlags lexerFlags,
    ILexicalState lexicalState,
    IMergableTokenLexerData lexerData
)
Function CreateToken (
    startOffset As Integer,
    length As Integer,
    startPosition As TextPosition,
    endPosition As TextPosition,
    lexerFlags As MergableLexerFlags,
    lexicalState As ILexicalState,
    lexerData As IMergableTokenLexerData
) As IMergableToken

Parameters

startOffset
Type: SystemInt32
The start offset of the token.
length
Type: SystemInt32
The length of the token.
startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition of the first character in the token.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition after the last character in the token.
lexerFlags
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags for the token.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.
lexerData
Type: ActiproSoftware.Text.LexingIMergableTokenLexerData
The IMergableTokenLexerData that contains lexer information about the token.

Return Value

Type: IMergableToken
An IMergableToken that represents the range of text with the specified lexer data.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.GetAllLexicalStateTransitions Method

IMergableLexerGetAllLexicalStateTransitions Method

Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.GetDefaultToken Method

IMergableLexerGetDefaultToken Method

Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
MergableLexerResult GetDefaultToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Function GetDefaultToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.GetNextToken Method

IMergableLexerGetNextToken Method

Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer Events

The IMergableLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.
Top
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.Changed Event

IMergableLexerChanged Event

Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler Changed
Event Changed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken Interface

Represents the base requirements for a mergable token that has been assigned to a span of text by a mergable lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IMergableToken : IToken
Public Interface IMergableToken
    Inherits IToken

The IMergableToken type exposes the following members.

Properties
 | Name | Description
Public property | AutoCaseCorrectText | Gets the text that should be used for this IToken when performing an auto case correction operation on it.
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | DeclaringLexicalState | Gets the ILexicalState that declares the pattern that matched the token.
Public property | EndOffset | Gets the offset after the last character in the token. (Inherited from IToken.)
Public property | EndPosition | Gets the TextPosition after the last character in the token. (Inherited from IToken.)
Public property | Id | Gets the ID assigned to the token. (Inherited from IToken.)
Public property | Key | Gets the key assigned to the token. (Inherited from IToken.)
Public property | Length | Gets or sets the absolute length of the token. (Inherited from IToken.)
Public property | Lexer | Gets the IMergableLexer that created the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token. (Inherited from IToken.)
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token. (Inherited from IToken.)
Public property | StartOffset | Gets or sets the offset of the first character in the token. (Inherited from IToken.)
Public property | StartPosition | Gets the TextPosition of the first character in the token. (Inherited from IToken.)
Public property | TextRange | Gets a TextRange that specifies the text range of the token. (Inherited from IToken.)
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset. (Inherited from IToken.)
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition. (Inherited from IToken.)
Public method | HasFlag | Returns whether the parse data has the specified MergableLexerFlags flag.
Public method | SetFlag | Sets or clears the specified MergableLexerFlags flag.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationMergableToken


IMergableToken Properties

The IMergableToken type exposes the following members.

Properties
 | Name | Description
Public property | AutoCaseCorrectText | Gets the text that should be used for this IToken when performing an auto case correction operation on it.
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | DeclaringLexicalState | Gets the ILexicalState that declares the pattern that matched the token.
Public property | EndOffset | Gets the offset after the last character in the token. (Inherited from IToken.)
Public property | EndPosition | Gets the TextPosition after the last character in the token. (Inherited from IToken.)
Public property | Id | Gets the ID assigned to the token. (Inherited from IToken.)
Public property | Key | Gets the key assigned to the token. (Inherited from IToken.)
Public property | Length | Gets or sets the absolute length of the token. (Inherited from IToken.)
Public property | Lexer | Gets the IMergableLexer that created the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token. (Inherited from IToken.)
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token. (Inherited from IToken.)
Public property | StartOffset | Gets or sets the offset of the first character in the token. (Inherited from IToken.)
Public property | StartPosition | Gets the TextPosition of the first character in the token. (Inherited from IToken.)
Public property | TextRange | Gets a TextRange that specifies the text range of the token. (Inherited from IToken.)
Top
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.AutoCaseCorrectText Property

IMergableTokenAutoCaseCorrectText Property

Gets the text that should be used for this IToken when performing an auto case correction operation on it.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string AutoCaseCorrectText { get; }
ReadOnly Property AutoCaseCorrectText As String
    Get

Property Value

Type: String
The text that should be used for this IToken when performing an auto case correction operation on it.
Remarks
Return a value to indicate that there is no auto case correction text available.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.ClassificationType Property

IMergableTokenClassificationType Property

Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; }
ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType assigned to the token.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.DeclaringLexicalState Property

IMergableTokenDeclaringLexicalState Property

Gets the ILexicalState that declares the pattern that matched the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalState DeclaringLexicalState { get; }
ReadOnly Property DeclaringLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that declares the pattern that matched the token.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.Lexer Property

IMergableTokenLexer Property

Gets the IMergableLexer that created the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IMergableLexer Lexer { get; }
ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that created the token.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.LexicalScope Property

IMergableTokenLexicalScope Property

Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalScope LexicalScope { get; }
ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.LexicalState Property

IMergableTokenLexicalState Property

Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalState LexicalState { get; }
ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken Methods

The IMergableToken type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset. (Inherited from IToken.)
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition. (Inherited from IToken.)
Public method | HasFlag | Returns whether the parse data has the specified MergableLexerFlags flag.
Public method | SetFlag | Sets or clears the specified MergableLexerFlags flag.
Top
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.HasFlag Method

IMergableTokenHasFlag Method

Returns whether the parse data has the specified MergableLexerFlags flag.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasFlag(
    MergableLexerFlags flag
)
Function HasFlag (
    flag As MergableLexerFlags
) As Boolean

Parameters

flag
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags to check for.

Return Value

Type: Boolean
true if the parse data has the specified MergableLexerFlags flag; otherwise, false.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.SetFlag Method

IMergableTokenSetFlag Method

Sets or clears the specified MergableLexerFlags flag.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void SetFlag(
    MergableLexerFlags flag,
    bool setBit
)
Sub SetFlag (
    flag As MergableLexerFlags,
    setBit As Boolean
)

Parameters

flag
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags to set or clear.
setBit
Type: SystemBoolean
Whether to set the flag; otherwise, the flag is cleared.
Remarks
This method should only be called by lexers.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData Interface

Provides the base requirements for an object that provides lexer data for a IMergableToken.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IMergableTokenLexerData
Public Interface IMergableTokenLexerData

The IMergableTokenLexerData type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that created the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationLexicalStateTokenData
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeTokenData


IMergableTokenLexerData Properties

The IMergableTokenLexerData type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that created the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.ClassificationType Property

IMergableTokenLexerDataClassificationType Property

Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; }
ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The key of the IClassificationType assigned to the token.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.Lexer Property

IMergableTokenLexerDataLexer Property

Gets the IMergableLexer that created the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IMergableLexer Lexer { get; }
ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that created the token.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.LexicalScope Property

IMergableTokenLexerDataLexicalScope Property

Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalScope LexicalScope { get; }
ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.LexicalState Property

IMergableTokenLexerDataLexicalState Property

Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILexicalState LexicalState { get; }
ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.TokenId Property

IMergableTokenLexerDataTokenId Property

Gets the token ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int TokenId { get; }
ReadOnly Property TokenId As Integer
    Get

Property Value

Type: Int32
The token ID assigned to the token.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.TokenKey Property

IMergableTokenLexerDataTokenKey Property

Gets the token key assigned to the token, if it is known.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string TokenKey { get; }
ReadOnly Property TokenKey As String
    Get

Property Value

Type: String
The token key assigned to the token, if it is known.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IToken Interface

Represents the base requirements for a token that has been assigned to a span of text by a lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IToken
Public Interface IToken

The IToken type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset after the last character in the token.
Public property | EndPosition | Gets the TextPosition after the last character in the token.
Public property | Id | Gets the ID assigned to the token.
Public property | Key | Gets the key assigned to the token.
Public property | Length | Gets or sets the absolute length of the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token.
Public property | StartOffset | Gets or sets the offset of the first character in the token.
Public property | StartPosition | Gets the TextPosition of the first character in the token.
Public property | TextRange | Gets a TextRange that specifies the text range of the token.
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


IToken Properties

The IToken type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset after the last character in the token.
Public property | EndPosition | Gets the TextPosition after the last character in the token.
Public property | Id | Gets the ID assigned to the token.
Public property | Key | Gets the key assigned to the token.
Public property | Length | Gets or sets the absolute length of the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token.
Public property | StartOffset | Gets or sets the offset of the first character in the token.
Public property | StartPosition | Gets the TextPosition of the first character in the token.
Public property | TextRange | Gets a TextRange that specifies the text range of the token.
Top
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.EndOffset Property

ITokenEndOffset Property

Gets the offset after the last character in the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int EndOffset { get; }
ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The offset after the last character in the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.EndPosition Property

ITokenEndPosition Property

Gets the TextPosition after the last character in the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition EndPosition { get; }
ReadOnly Property EndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition after the last character in the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Id Property

ITokenId Property

Gets the ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Id { get; }
ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The ID assigned to the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Key Property

ITokenKey Property

Gets the key assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Key { get; }
ReadOnly Property Key As String
    Get

Property Value

Type: String
The key assigned to the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Length Property

ITokenLength Property

Gets or sets the absolute length of the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Length { get; set; }
Property Length As Integer
    Get
    Set

Property Value

Type: Int32
The absolute length of the token.
Remarks
The setter for this property is for internal use only. Altering its value will corrupt the ITextDocument IToken collection.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.LexicalStateId Property

ITokenLexicalStateId Property

Gets the ID assigned to the lexical state that contains the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int LexicalStateId { get; }
ReadOnly Property LexicalStateId As Integer
    Get

Property Value

Type: Int32
The ID assigned to the lexical state that contains the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.PositionRange Property

ITokenPositionRange Property

Gets a TextPositionRange that specifies the text position range of the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPositionRange PositionRange { get; }
ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A TextPositionRange that specifies the text position range of the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.StartOffset Property

ITokenStartOffset Property

Gets or sets the offset of the first character in the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int StartOffset { get; set; }
Property StartOffset As Integer
    Get
    Set

Property Value

Type: Int32
The offset of the first character in the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.StartPosition Property

ITokenStartPosition Property

Gets the TextPosition of the first character in the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition StartPosition { get; }
ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition of the first character in the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.TextRange Property

ITokenTextRange Property

Gets a TextRange that specifies the text range of the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextRange TextRange { get; }
ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
A TextRange that specifies the text range of the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken Methods

Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Top
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Contains Method

ITokenContains Method

Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Top
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Contains Method (Int32)

ITokenContains Method (Int32)

Returns whether the IToken contains the specified offset.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Contains(
    int offset
)
Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the IToken contains the specified offset; otherwise, false.
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the IToken.
See Also

Reference

IToken Interface
Contains Overload
ActiproSoftware.Text.Lexing Namespace


IToken.Contains Method (TextPosition)

ITokenContains Method (TextPosition)

Returns whether the IToken contains the specified TextPosition.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Contains(
    TextPosition position
)
Function Contains (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the IToken contains the specified TextPosition; otherwise, false.
Remarks
This method returns false if the position falls on the EndPosition position since this method indicates if the position is encompassed by the IToken.
See Also

Reference

IToken Interface
Contains Overload
ActiproSoftware.Text.Lexing Namespace


ITokenIdProvider Interface

Provides the base requirements for a class that provides token ID's.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITokenIdProvider : IIdProvider
Public Interface ITokenIdProvider
    Inherits IIdProvider

The ITokenIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ITokenIdProvider Properties

The ITokenIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
See Also

Reference

ITokenIdProvider Interface
ActiproSoftware.Text.Lexing Namespace


ITokenIdProvider Methods

The ITokenIdProvider type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ITokenIdProvider Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet Interface

Provides the base requirements for a class that stores token data for a range of text.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITokenSet : IEnumerable,
    ITextRangeProvider, IEnumerable<IToken>
Public Interface ITokenSet
    Inherits IEnumerable, ITextRangeProvider, IEnumerable(Of IToken)

The ITokenSet type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count of tokens that are stored in the token set.
Public property | FirstToken | Gets the first IToken in the set.
Public property | FirstTokenExtendsBack | Gets whether the FirstToken extends back to another token set.
Public property | LastToken | Gets the last IToken in the set.
Public property | LastTokenExtendsForward | Gets whether the LastToken extends forward to another token set.
Public property | ParseContext | Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | Tokens | Gets an IToken in the token set.
Top
Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Returns the index of the IToken in the set that contains the specified offset, if any.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationTokenSet


ITokenSet Properties

The ITokenSet type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count of tokens that are stored in the token set.
Public property | FirstToken | Gets the first IToken in the set.
Public property | FirstTokenExtendsBack | Gets whether the FirstToken extends back to another token set.
Public property | LastToken | Gets the last IToken in the set.
Public property | LastTokenExtendsForward | Gets whether the LastToken extends forward to another token set.
Public property | ParseContext | Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | Tokens | Gets an IToken in the token set.
Top
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.Count Property

ITokenSetCount Property

Gets the count of tokens that are stored in the token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of tokens that are stored in the token set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.FirstToken Property

ITokenSetFirstToken Property

Gets the first IToken in the set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken FirstToken { get; }
ReadOnly Property FirstToken As IToken
    Get

Property Value

Type: IToken
The first IToken in the set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.FirstTokenExtendsBack Property

ITokenSetFirstTokenExtendsBack Property

Gets whether the FirstToken extends back to another token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool FirstTokenExtendsBack { get; }
ReadOnly Property FirstTokenExtendsBack As Boolean
    Get

Property Value

Type: Boolean
true if the FirstToken extends back to another token set; otherwise, false.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.LastToken Property

ITokenSetLastToken Property

Gets the last IToken in the set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken LastToken { get; }
ReadOnly Property LastToken As IToken
    Get

Property Value

Type: IToken
The last IToken in the set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.LastTokenExtendsForward Property

ITokenSetLastTokenExtendsForward Property

Gets whether the LastToken extends forward to another token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool LastTokenExtendsForward { get; }
ReadOnly Property LastTokenExtendsForward As Boolean
    Get

Property Value

Type: Boolean
true if the LastToken extends forward to another token set; otherwise, false.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.ParseContext Property

ITokenSetParseContext Property

Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object ParseContext { get; }
ReadOnly Property ParseContext As Object
    Get

Property Value

Type: Object
An optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.Tokens Property

ITokenSetTokens Property

Gets an IToken in the token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken this[
    int index
] { get; }
ReadOnly Default Property Tokens (
    index As Integer
) As IToken
    Get

Parameters

index
Type: SystemInt32
The index of the IToken to return.

Property Value

Type: IToken
An IToken in the token set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet Methods

The ITokenSet type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Returns the index of the IToken in the set that contains the specified offset, if any.
Top
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.IndexOf Method

ITokenSetIndexOf Method

Returns the index of the IToken in the set that contains the specified offset, if any.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int IndexOf(
    int offset,
    int hintIndex
)
Function IndexOf (
    offset As Integer,
    hintIndex As Integer
) As Integer

Parameters

offset
Type: SystemInt32
The offset for which to search.
hintIndex
Type: SystemInt32
The hint index at which to begin searching; otherwise, -1.

Return Value

Type: Int32
The index of the IToken in the set that contains the specified offset; otherwise, -1.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags Enumeration

Specifies flags for an IMergableToken.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MergableLexerFlags
Public Enumeration MergableLexerFlags
Members
Member name | Value | Description
None | 0 | There are no flags set.
LooseMatch | 1 | A loose match was made. This occurs when using a case insensitivity of AutoCorrect and a non-exact match was found.
ScopeStart | 2 | The token starts a scope.
ScopeEnd | 4 | The token ends a scope.
DirectStateTransition | 8 | The token starts a scope which performs a direct lexical state transition.
ScopeStateTransitionStart | 16 | The token ends a scope but performs a scope lexical state transition.
ScopeStateTransitionEnd | 32 | The token ends a scope for a scope lexical state transition.
LanguageStart | 64 | The token marks the start of a child language.
LanguageEnd | 128 | The token marks the end of a child language.
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


MergableLexerResult Class

Provides a lexer result for a token.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.LexingMergableLexerResult

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MergableLexerResult
Public Class MergableLexerResult

The MergableLexerResult type exposes the following members.

Constructors
 | Name | Description
Public method | MergableLexerResult | Initializes a new instance of the MergableLexerResult class.
Top
Properties
 | Name | Description
Public property | LexerData | Gets the IMergableTokenLexerData to use for this token.
Public property | MatchType | Gets a MatchType indicating the type of match that was made.
Top
Fields
Name | Description
NoMatch | Gets a MergableLexerResult that can be used to indicate there was no match.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


MergableLexerResult Constructor

Initializes a new instance of the MergableLexerResult class.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MergableLexerResult(
    MatchType matchType,
    IMergableTokenLexerData lexerData
)
Public Sub New (
    matchType As MatchType,
    lexerData As IMergableTokenLexerData
)

Parameters

matchType
Type: ActiproSoftware.Text.RegularExpressionsMatchType
A MatchType indicating the type of match that was made.
lexerData
Type: ActiproSoftware.Text.LexingIMergableTokenLexerData
The IMergableTokenLexerData to use for this token.
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult Properties

The MergableLexerResult type exposes the following members.

Properties
 | Name | Description
Public property | LexerData | Gets the IMergableTokenLexerData to use for this token.
Public property | MatchType | Gets a MatchType indicating the type of match that was made.
Top
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult.LexerData Property

MergableLexerResultLexerData Property

Gets the IMergableTokenLexerData to use for this token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IMergableTokenLexerData LexerData { get; }
Public ReadOnly Property LexerData As IMergableTokenLexerData
    Get

Property Value

Type: IMergableTokenLexerData
The IMergableTokenLexerData to use for this token.
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult.MatchType Property

MergableLexerResultMatchType Property

Gets a MatchType indicating the type of match that was made.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MatchType MatchType { get; }
Public ReadOnly Property MatchType As MatchType
    Get

Property Value

Type: MatchType
A MatchType indicating the type of match that was made.
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult Fields

The MergableLexerResult type exposes the following members.

Fields
Name | Description
NoMatch | Gets a MergableLexerResult that can be used to indicate there was no match.
Top
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult.NoMatch Field

MergableLexerResultNoMatch Field

Gets a MergableLexerResult that can be used to indicate there was no match.

Namespace: ActiproSoftware.Text.Lexing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly MergableLexerResult NoMatch
Public Shared ReadOnly NoMatch As MergableLexerResult

Field Value

Type: MergableLexerResult
A MergableLexerResult that can be used to indicate there was no match.
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


ActiproSoftware.Text.Lexing.Implementation Namespace

Contains implementation types related to lexing.
Classes
 | Class | Description
Public class | DynamicLexer | Represents a dynamic lexer (lexical analyzer), one that is pattern-based.
Public class | DynamicLexicalMacro | Defines a macro, which is a named regular expression.
Public class | DynamicLexicalPattern | Represents a lexical pattern.
Public class | DynamicLexicalPatternGroup | Encapsulates a collection of DynamicLexicalPattern objects.
Public class | DynamicLexicalScope | Contains information about a lexical scope.
Public class | DynamicLexicalState | Contains information about a lexical state.
Public class | LexicalScopeBase | Provides the abstract base class for a lexical scope.
Public class | LexicalScopeCollection | Represents a collection of lexical scopes.
Public class | LexicalScopeTokenData | Provides IToken lexer data based on a token ID and an ILexicalScope.
Public class | LexicalStateBase | Provides the abstract base class for a lexical state.
Public class | LexicalStateCollection | Represents a collection of lexical states.
Public class | LexicalStateIdProviderBase | Represents an abstract base class for an object that provides static IDs for the lexical states of an ISyntaxLanguage.
Public class | LexicalStateTokenData | Provides IToken lexer data based on a token ID and on an ILexicalState.
Public class | LexicalStateTransition | Contains information about a transition from one lexical state to another.
Public class | MergableLexerBase | Represents the base implementation of a lexer (lexical analyzer) for a language that supports merging with other languages.
Public class | MergableLexerCoordinator | Coordinates lexer and state shifting for one or more mergable lexers.
Public class | MergableToken | Represents the default implementation of an IToken that can be used with an IMergableLexer.
Public class | ProgrammaticLexicalScope | Provides a lexical scope implementation that uses two delegates to perform the IsScopeStart(ITextBufferReader) and IsScopeEnd(ITextBufferReader) checks.
Public class | ProgrammaticLexicalState | Provides a default implementation for a lexical state.
Public class | TokenBase | Represents the base class for an IToken implementation.
Public class | TokenIdProviderBase | Represents an abstract base class for an object that provides static IDs for the tokens of an ISyntaxLanguage.
Public class | TokenSet | Stores token data for a range of text.
Interfaces
 | Interface | Description
Public interface | IDynamicLexer | Provides the base requirements for a dynamic lexer, one that is pattern based.
Public interface | IDynamicLexicalMacroCollection | Provides the base requirements for a collection of DynamicLexicalMacro objects.
Public interface | IDynamicLexicalPatternCollection | Provides the base requirements for a collection of DynamicLexicalPattern objects.
Public interface | IDynamicLexicalPatternGroupCollection | Provides the base requirements for a collection of DynamicLexicalPatternGroup objects.
Public interface | IDynamicLexicalScopeCollection | Provides the base requirements for a collection of DynamicLexicalScope objects.
Public interface | IDynamicLexicalStateCollection | Provides the base requirements for a collection of DynamicLexicalState objects.
Delegates
 | Delegate | Description
Public delegate | ProgrammaticLexicalScopeMatch | Represents the method that will handle token matching callbacks for ProgrammaticLexicalScope objects.
Enumerations
 | Enumeration | Description
Public enumeration | DynamicLexicalPatternType | Specifies the type of lexical pattern.


DynamicLexer Class

Represents a dynamic lexer (lexical analyzer), one that is pattern-based.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexer
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLexer

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DynamicLexer : MergableLexerBase,
    IKeyedObject, ILexer, IMergableLexer, IDynamicLexer
Public Class DynamicLexer
    Inherits MergableLexerBase
    Implements IKeyedObject, ILexer, IMergableLexer, IDynamicLexer

The DynamicLexer type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexer | Initializes a new instance of the DynamicLexer class.
Top
Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name.
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Public property | LexicalMacros | Gets the collection of lexical macros.
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states.
Public property | TokenIdProvider | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Overrides MergableLexerBaseGetDefaultToken(ITextBufferReader, ILexicalState).)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Protected method | OnChanged | Raises the Changed event. (Overrides MergableLexerBaseOnChanged(EventArgs).)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ILexer interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer Constructor

Initializes a new instance of the DynamicLexer class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexer()
Public Sub New
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer Properties

The DynamicLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name.
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Public property | LexicalMacros | Gets the collection of lexical macros.
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states.
Public property | TokenIdProvider | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.DefaultLexicalState Property

DynamicLexerDefaultLexicalState Property

Gets or sets the root ILexicalState for when the language is entered.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalState DefaultLexicalState { get; set; }
Public Property DefaultLexicalState As DynamicLexicalState
    Get
    Set

Property Value

Type: DynamicLexicalState
The root ILexicalState for when the language is entered.

Implements

IDynamicLexerDefaultLexicalState
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.Key Property

DynamicLexerKey Property

Gets or sets a string that identifies the lexer, generally the related language name.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set

Property Value

Type: String
A string that identifies the lexer, generally the related language name.

Implements

IKeyedObjectKey
IDynamicLexerKey
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.LexicalMacros Property

DynamicLexerLexicalMacros Property

Gets the collection of lexical macros.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDynamicLexicalMacroCollection LexicalMacros { get; }
Public ReadOnly Property LexicalMacros As IDynamicLexicalMacroCollection
    Get

Property Value

Type: IDynamicLexicalMacroCollection
A IDynamicLexicalMacroCollection containing the lexical macros.

Implements

IDynamicLexerLexicalMacros
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.LexicalStateIdProvider Property

DynamicLexerLexicalStateIdProvider Property

Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalStateIdProvider LexicalStateIdProvider { get; set; }
Public Property LexicalStateIdProvider As ILexicalStateIdProvider
    Get
    Set

Property Value

Type: ILexicalStateIdProvider
The ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.

Implements

IMergableLexerLexicalStateIdProvider
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.LexicalStates Property

DynamicLexerLexicalStates Property

Gets the collection of lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDynamicLexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As IDynamicLexicalStateCollection
    Get

Property Value

Type: IDynamicLexicalStateCollection
A IDynamicLexicalStateCollection containing the lexical states.

Implements

IDynamicLexerLexicalStates
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.TokenIdProvider Property

DynamicLexerTokenIdProvider Property

Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITokenIdProvider TokenIdProvider { get; set; }
Public Property TokenIdProvider As ITokenIdProvider
    Get
    Set

Property Value

Type: ITokenIdProvider
The ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.

Implements

ILexerTokenIdProvider
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer Methods

The DynamicLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Overrides MergableLexerBaseGetDefaultToken(ITextBufferReader, ILexicalState).)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Protected method | OnChanged | Raises the Changed event. (Overrides MergableLexerBaseOnChanged(EventArgs).)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Top
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.GetAllLexicalStateTransitions Method

DynamicLexerGetAllLexicalStateTransitions Method

Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.GetDefaultToken Method

DynamicLexerGetDefaultToken Method

Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetDefaultToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetDefaultToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetDefaultToken(ITextBufferReader, ILexicalState)
IMergableLexerGetDefaultToken(ITextBufferReader, ILexicalState)
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.GetNextToken Method

DynamicLexerGetNextToken Method

Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.OnChanged Method

DynamicLexerOnChanged Method

Raises the Changed event.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnChanged(
    EventArgs e
)
Protected Overrides Sub OnChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The EventArgs that contains the event data.
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer Events

The DynamicLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro Class

Defines a macro, which is a named regular expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalMacro

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DynamicLexicalMacro : IKeyedObject
Public Class DynamicLexicalMacro
    Implements IKeyedObject

The DynamicLexicalMacro type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalMacro | Initializes a new instance of the LexicalMacro class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string-based key that identifies the object.
Public property | Pattern | Gets the text regular expression source.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro Constructor

Initializes a new instance of the LexicalMacro class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalMacro(
    string key,
    string pattern
)
Public Sub New (
    key As String,
    pattern As String
)

Parameters

key
Type: SystemString
The key of the macro.
pattern
Type: SystemString
The text regular expression source.
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro Properties

The DynamicLexicalMacro type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string-based key that identifies the object.
Public property | Pattern | Gets the text regular expression source.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro.Key Property

DynamicLexicalMacroKey Property

Gets a string-based key that identifies the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
A string-based key that identifies the object.

Implements

IKeyedObjectKey
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro.Pattern Property

DynamicLexicalMacroPattern Property

Gets the text regular expression source.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Pattern { get; }
Public ReadOnly Property Pattern As String
    Get

Property Value

Type: String
The text regular expression source.
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro.Tag Property

DynamicLexicalMacroTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro Methods

The DynamicLexicalMacro type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro.ToString Method

DynamicLexicalMacroToString Method

Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern Class

Represents a lexical pattern.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalPattern

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DynamicLexicalPattern
Public Class DynamicLexicalPattern

The DynamicLexicalPattern type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalPattern | Initializes a new instance of the DynamicLexicalPattern class.
Top
Properties
 | Name | Description
Public property | LexicalPatternGroup | Gets the parent DynamicLexicalPatternGroup.
Public property | Pattern | Gets or sets the text regular expression source.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern Constructor

Initializes a new instance of the DynamicLexicalPattern class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalPattern(
    string pattern
)
Public Sub New (
    pattern As String
)

Parameters

pattern
Type: SystemString
The text regular expression source.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern Properties

The DynamicLexicalPattern type exposes the following members.

Properties
 | Name | Description
Public property | LexicalPatternGroup | Gets the parent DynamicLexicalPatternGroup.
Public property | Pattern | Gets or sets the text regular expression source.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern.LexicalPatternGroup Property

DynamicLexicalPatternLexicalPatternGroup Property

Gets the parent DynamicLexicalPatternGroup.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternGroup LexicalPatternGroup { get; }
Public ReadOnly Property LexicalPatternGroup As DynamicLexicalPatternGroup
    Get

Property Value

Type: DynamicLexicalPatternGroup
The parent DynamicLexicalPatternGroup.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern.Pattern Property

DynamicLexicalPatternPattern Property

Gets or sets the text regular expression source.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Pattern { get; set; }
Public Property Pattern As String
    Get
    Set

Property Value

Type: String
The text regular expression source.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern.Tag Property

DynamicLexicalPatternTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern Methods

The DynamicLexicalPattern type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern.ToString Method

DynamicLexicalPatternToString Method

Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup Class

Encapsulates a collection of DynamicLexicalPattern objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalPatternGroup

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DynamicLexicalPatternGroup : IKeyedObject
Public Class DynamicLexicalPatternGroup
    Implements IKeyedObject

The DynamicLexicalPatternGroup type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalPatternGroup | Initializes a new instance of the DynamicLexicalPatternGroup class.
Top
Properties
 | Name | Description
Public property | CaseSensitivity | Gets or sets a nullable CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the pattern group.
Public property | ClassificationType | Gets or sets the IClassificationType to use for tokens within the pattern group.
Public property | IsCaseSensitive | Gets whether the explicit patterns in the pattern group are case sensitive.
Public property | Key | Gets or sets a string-based key that identifies the object.
Public property | LexicalScope | Gets the DynamicLexicalScope, if any, that defines the pattern group.
Public property | LexicalState | Gets the DynamicLexicalState that defines the pattern group.
Public property | LookAheadPattern | Gets or sets the text regular expression source for the look-ahead.
Public property | LookBehindPattern | Gets or sets the text regular expression source for the look-behind.
Public property | Patterns | Gets the collection of lexical patterns.
Public property | PatternType | Gets or sets a DynamicLexicalPatternType indicating the type of pattern.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | TokenId | Gets or sets a numeric ID that identifies the token that this pattern group assigns.
Public property | TokenKey | Gets the key of the token that this pattern group assigns.
Top
Methods
 | Name | Description
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalPattern


DynamicLexicalPatternGroup Constructor

Initializes a new instance of the DynamicLexicalPatternGroup class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternGroup(
    DynamicLexicalPatternType patternType,
    string tokenKey,
    IClassificationType classificationType
)
Public Sub New (
    patternType As DynamicLexicalPatternType,
    tokenKey As String,
    classificationType As IClassificationType
)

Parameters

patternType
Type: ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalPatternType
A DynamicLexicalPatternType indicating the type of pattern.
tokenKey
Type: SystemString
The key of the token that this pattern group assigns.
classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType that this pattern group uses.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup Properties

The DynamicLexicalPatternGroup type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitivity | Gets or sets a nullable CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the pattern group.
Public property | ClassificationType | Gets or sets the IClassificationType to use for tokens within the pattern group.
Public property | IsCaseSensitive | Gets whether the explicit patterns in the pattern group are case sensitive.
Public property | Key | Gets or sets a string-based key that identifies the object.
Public property | LexicalScope | Gets the DynamicLexicalScope, if any, that defines the pattern group.
Public property | LexicalState | Gets the DynamicLexicalState that defines the pattern group.
Public property | LookAheadPattern | Gets or sets the text regular expression source for the look-ahead.
Public property | LookBehindPattern | Gets or sets the text regular expression source for the look-behind.
Public property | Patterns | Gets the collection of lexical patterns.
Public property | PatternType | Gets or sets a DynamicLexicalPatternType indicating the type of pattern.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | TokenId | Gets or sets a numeric ID that identifies the token that this pattern group assigns.
Public property | TokenKey | Gets the key of the token that this pattern group assigns.
Top
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.CaseSensitivity Property

DynamicLexicalPatternGroupCaseSensitivity Property

Gets or sets a nullable CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the pattern group.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<CaseSensitivity> CaseSensitivity { get; set; }
Public Property CaseSensitivity As Nullable(Of CaseSensitivity)
    Get
    Set

Property Value

Type: Nullable CaseSensitivity
A nullable CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the pattern group.
Remarks
A value indicates that the setting should be inherited from the parent LexicalState
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.ClassificationType Property

DynamicLexicalPatternGroupClassificationType Property

Gets or sets the IClassificationType to use for tokens within the pattern group.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType to use for tokens within the pattern group.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.IsCaseSensitive Property

DynamicLexicalPatternGroupIsCaseSensitive Property

Gets whether the explicit patterns in the pattern group are case sensitive.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCaseSensitive { get; }
Public ReadOnly Property IsCaseSensitive As Boolean
    Get

Property Value

Type: Boolean
true if the explicit patterns in the pattern group are case sensitive; otherwise, false.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.Key Property

DynamicLexicalPatternGroupKey Property

Gets or sets a string-based key that identifies the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set

Property Value

Type: String
A string-based key that identifies the object.

Implements

IKeyedObjectKey
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.LexicalScope Property

DynamicLexicalPatternGroupLexicalScope Property

Gets the DynamicLexicalScope, if any, that defines the pattern group.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalScope LexicalScope { get; }
Public ReadOnly Property LexicalScope As DynamicLexicalScope
    Get

Property Value

Type: DynamicLexicalScope
The DynamicLexicalScope, if any, that defines the pattern group.
Remarks
If this value is , the pattern group was not defined by a lexical scope.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.LexicalState Property

DynamicLexicalPatternGroupLexicalState Property

Gets the DynamicLexicalState that defines the pattern group.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalState LexicalState { get; }
Public ReadOnly Property LexicalState As DynamicLexicalState
    Get

Property Value

Type: DynamicLexicalState
The DynamicLexicalState that defines the pattern group.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.LookAheadPattern Property

DynamicLexicalPatternGroupLookAheadPattern Property

Gets or sets the text regular expression source for the look-ahead.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LookAheadPattern { get; set; }
Public Property LookAheadPattern As String
    Get
    Set

Property Value

Type: String
The text regular expression source for the look-ahead.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.LookBehindPattern Property

DynamicLexicalPatternGroupLookBehindPattern Property

Gets or sets the text regular expression source for the look-behind.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LookBehindPattern { get; set; }
Public Property LookBehindPattern As String
    Get
    Set

Property Value

Type: String
The text regular expression source for the look-behind.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.Patterns Property

DynamicLexicalPatternGroupPatterns Property

Gets the collection of lexical patterns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDynamicLexicalPatternCollection Patterns { get; }
Public ReadOnly Property Patterns As IDynamicLexicalPatternCollection
    Get

Property Value

Type: IDynamicLexicalPatternCollection
A IDynamicLexicalPatternCollection containing the lexical patterns.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.PatternType Property

DynamicLexicalPatternGroupPatternType Property

Gets or sets a DynamicLexicalPatternType indicating the type of pattern.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternType PatternType { get; set; }
Public Property PatternType As DynamicLexicalPatternType
    Get
    Set

Property Value

Type: DynamicLexicalPatternType
A DynamicLexicalPatternType indicating the type of pattern.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.Tag Property

DynamicLexicalPatternGroupTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.TokenId Property

DynamicLexicalPatternGroupTokenId Property

Gets or sets a numeric ID that identifies the token that this pattern group assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int TokenId { get; set; }
Public Property TokenId As Integer
    Get
    Set

Property Value

Type: Int32
A numeric ID that identifies the token that this pattern group assigns.
Remarks
This property is similar to the TokenKey property although TokenKey is a string, while TokenID is a number which can be cast to an enumeration.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.TokenKey Property

DynamicLexicalPatternGroupTokenKey Property

Gets the key of the token that this pattern group assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TokenKey { get; }
Public ReadOnly Property TokenKey As String
    Get

Property Value

Type: String
The key of the token that this pattern group assigns.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup Methods

The DynamicLexicalPatternGroup type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.ToString Method

DynamicLexicalPatternGroupToString Method

Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternType Enumeration

Specifies the type of lexical pattern.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DynamicLexicalPatternType
Public Enumeration DynamicLexicalPatternType
Members
Member name | Value | Description
Explicit | 0 | An explicit pattern in which all pattern characters have no regex meaning.
Regex | 1 | A pattern in which regex characters have special meaning and can control regular expression parsing.
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope Class

Contains information about a lexical scope.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalScope

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DynamicLexicalScope : LexicalScopeBase
Public Class DynamicLexicalScope
    Inherits LexicalScopeBase

The DynamicLexicalScope type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalScope | Initializes a new instance of the DynamicLexicalScope class
Top
Properties
 | Name | Description
Public property | EndLexicalPatternGroup | Gets or sets the lexical pattern group that ends the scope.
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope. (Inherited from LexicalScopeBase.)
Public property | LexicalState | Gets the DynamicLexicalState that defines the lexical scope.
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope. (Inherited from LexicalScopeBase.)
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope. (Inherited from LexicalScopeBase.)
Public property | StartLexicalPatternGroup | Gets or sets the lexical pattern group that starts the scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalScopeBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending. (Inherited from LexicalScopeBase.)
Top
Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope. (Overrides LexicalScopeBaseIsScopeEnd(ITextBufferReader).)
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope. (Overrides LexicalScopeBaseIsScopeStart(ITextBufferReader).)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope Constructor

Initializes a new instance of the DynamicLexicalScope class

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalScope()
Public Sub New
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope Properties

The DynamicLexicalScope type exposes the following members.

Properties
 | Name | Description
Public property | EndLexicalPatternGroup | Gets or sets the lexical pattern group that ends the scope.
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope. (Inherited from LexicalScopeBase.)
Public property | LexicalState | Gets the DynamicLexicalState that defines the lexical scope.
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope. (Inherited from LexicalScopeBase.)
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope. (Inherited from LexicalScopeBase.)
Public property | StartLexicalPatternGroup | Gets or sets the lexical pattern group that starts the scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalScopeBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending. (Inherited from LexicalScopeBase.)
Top
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.EndLexicalPatternGroup Property

DynamicLexicalScopeEndLexicalPatternGroup Property

Gets or sets the lexical pattern group that ends the scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternGroup EndLexicalPatternGroup { get; set; }
Public Property EndLexicalPatternGroup As DynamicLexicalPatternGroup
    Get
    Set

Property Value

Type: DynamicLexicalPatternGroup
The DynamicLexicalPatternGroup that ends the scope.
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.LexicalState Property

DynamicLexicalScopeLexicalState Property

Gets the DynamicLexicalState that defines the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalState LexicalState { get; }
Public ReadOnly Property LexicalState As DynamicLexicalState
    Get

Property Value

Type: DynamicLexicalState
The DynamicLexicalState that defines the lexical scope.
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.StartLexicalPatternGroup Property

DynamicLexicalScopeStartLexicalPatternGroup Property

Gets or sets the lexical pattern group that starts the scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternGroup StartLexicalPatternGroup { get; set; }
Public Property StartLexicalPatternGroup As DynamicLexicalPatternGroup
    Get
    Set

Property Value

Type: DynamicLexicalPatternGroup
The DynamicLexicalPatternGroup that starts the scope.
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope Methods

The DynamicLexicalScope type exposes the following members.

Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope. (Overrides LexicalScopeBaseIsScopeEnd(ITextBufferReader).)
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope. (Overrides LexicalScopeBaseIsScopeStart(ITextBufferReader).)
Top
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.IsScopeEnd Method

DynamicLexicalScopeIsScopeEnd Method

Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult IsScopeEnd(
    ITextBufferReader reader
)
Public Overrides Function IsScopeEnd (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeEnd(ITextBufferReader)
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.IsScopeStart Method

DynamicLexicalScopeIsScopeStart Method

Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult IsScopeStart(
    ITextBufferReader reader
)
Public Overrides Function IsScopeStart (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeStart(ITextBufferReader)
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Class

Contains information about a lexical state.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalState

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DynamicLexicalState : LexicalStateBase
Public Class DynamicLexicalState
    Inherits LexicalStateBase

The DynamicLexicalState type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalState(String) | Initializes a new instance of the DynamicLexicalState class.
Public method | DynamicLexicalState(Int32, String) | Initializes a new instance of the DynamicLexicalState class.
Top
Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states. (Inherited from LexicalStateBase.)
Public property | DefaultCaseSensitivity | Gets or sets a CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the state's pattern groups.
Public property | DefaultClassificationType | Gets or sets the IClassificationType of the default token that this state assigns.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | Id | Gets or sets the ID value that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Key | Gets a string-based key that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Lexer | Gets the IDynamicLexer that contains the state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state. (Inherited from LexicalStateBase.)
Public property | LexicalPatternGroups | Gets the collection of lexical pattern groups.
Public property | LexicalScopes | Gets the collection of lexical scopes.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes. (Inherited from LexicalStateBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalStateBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match. (Inherited from LexicalStateBase.)
Top
Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore. (Overrides LexicalStateBaseCreateChildLexicalStates.)
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore. (Overrides LexicalStateBaseCreateLexicalScopes.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Constructor

Overload List
 | Name | Description
Public method | DynamicLexicalState(String) | Initializes a new instance of the DynamicLexicalState class.
Public method | DynamicLexicalState(Int32, String) | Initializes a new instance of the DynamicLexicalState class.
Top
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Constructor (String)

Initializes a new instance of the DynamicLexicalState class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalState(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
The key of the lexical state.
See Also

Reference

DynamicLexicalState Class
DynamicLexicalState Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Constructor (Int32, String)

Initializes a new instance of the DynamicLexicalState class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicLexicalState(
    int id,
    string key
)
Public Sub New (
    id As Integer,
    key As String
)

Parameters

id
Type: SystemInt32
The ID of the lexical state.
key
Type: SystemString
The key of the lexical state.
See Also

Reference

DynamicLexicalState Class
DynamicLexicalState Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Properties

The DynamicLexicalState type exposes the following members.

Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states. (Inherited from LexicalStateBase.)
Public property | DefaultCaseSensitivity | Gets or sets a CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the state's pattern groups.
Public property | DefaultClassificationType | Gets or sets the IClassificationType of the default token that this state assigns.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | Id | Gets or sets the ID value that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Key | Gets a string-based key that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Lexer | Gets the IDynamicLexer that contains the state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state. (Inherited from LexicalStateBase.)
Public property | LexicalPatternGroups | Gets the collection of lexical pattern groups.
Public property | LexicalScopes | Gets the collection of lexical scopes.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes. (Inherited from LexicalStateBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalStateBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match. (Inherited from LexicalStateBase.)
Top
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.ChildLexicalStates Property

DynamicLexicalStateChildLexicalStates Property

Gets the collection of child lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDynamicLexicalStateCollection ChildLexicalStates { get; }
Public ReadOnly Property ChildLexicalStates As IDynamicLexicalStateCollection
    Get

Property Value

Type: IDynamicLexicalStateCollection
A IDynamicLexicalStateCollection containing the child lexical states.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.DefaultCaseSensitivity Property

DynamicLexicalStateDefaultCaseSensitivity Property

Gets or sets a CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the state's pattern groups.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CaseSensitivity DefaultCaseSensitivity { get; set; }
Public Property DefaultCaseSensitivity As CaseSensitivity
    Get
    Set

Property Value

Type: CaseSensitivity
A CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the state's pattern groups. The default value is CaseSensitivity.Insensitive.
Remarks
This property provides the default value for lexical pattern groups within the state without an explicit case sensitivity option set.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.DefaultClassificationType Property

DynamicLexicalStateDefaultClassificationType Property

Gets or sets the IClassificationType of the default token that this state assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType DefaultClassificationType { get; set; }
Public Property DefaultClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType of the default token that this state assigns.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.Lexer Property

DynamicLexicalStateLexer Property

Gets the IDynamicLexer that contains the state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDynamicLexer Lexer { get; }
Public ReadOnly Property Lexer As IDynamicLexer
    Get

Property Value

Type: IDynamicLexer
The IDynamicLexer that contains the state.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.LexicalPatternGroups Property

DynamicLexicalStateLexicalPatternGroups Property

Gets the collection of lexical pattern groups.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDynamicLexicalPatternGroupCollection LexicalPatternGroups { get; }
Public ReadOnly Property LexicalPatternGroups As IDynamicLexicalPatternGroupCollection
    Get

Property Value

Type: IDynamicLexicalPatternGroupCollection
A IDynamicLexicalPatternGroupCollection containing the lexical pattern groups.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.LexicalScopes Property

DynamicLexicalStateLexicalScopes Property

Gets the collection of lexical scopes.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDynamicLexicalScopeCollection LexicalScopes { get; }
Public ReadOnly Property LexicalScopes As IDynamicLexicalScopeCollection
    Get

Property Value

Type: IDynamicLexicalScopeCollection
A IDynamicLexicalScopeCollection containing the lexical scopes.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Methods

The DynamicLexicalState type exposes the following members.

Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore. (Overrides LexicalStateBaseCreateChildLexicalStates.)
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore. (Overrides LexicalStateBaseCreateLexicalScopes.)
Top
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.CreateChildLexicalStates Method

DynamicLexicalStateCreateChildLexicalStates Method

Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override ILexicalStateCollection CreateChildLexicalStates()
Protected Overrides Function CreateChildLexicalStates As ILexicalStateCollection

Return Value

Type: ILexicalStateCollection
The ILexicalStateCollection that was created.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.CreateLexicalScopes Method

DynamicLexicalStateCreateLexicalScopes Method

Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override ILexicalScopeCollection CreateLexicalScopes()
Protected Overrides Function CreateLexicalScopes As ILexicalScopeCollection

Return Value

Type: ILexicalScopeCollection
The ILexicalScopeCollection that was created.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer Interface

Provides the base requirements for a dynamic lexer, one that is pattern based.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDynamicLexer : IKeyedObject,
    ILexer, IMergableLexer
Public Interface IDynamicLexer
    Inherits IKeyedObject, ILexer, IMergableLexer

The IDynamicLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name.
Public property | LexicalMacros | Gets the collection of lexical macros.
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from IMergableLexer.)
Public property | LexicalStates | Gets the collection of lexical states.
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from ILexer.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from IMergableLexer.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from IMergableLexer.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from IMergableLexer.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Inherited from IMergableLexer.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from IMergableLexer.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Inherited from IMergableLexer.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from ILexer.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from IMergableLexer.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace
ActiproSoftware.Text.Lexing.ImplementationDynamicLexer


IDynamicLexer Properties

The IDynamicLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name.
Public property | LexicalMacros | Gets the collection of lexical macros.
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from IMergableLexer.)
Public property | LexicalStates | Gets the collection of lexical states.
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from ILexer.)
Top
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer.DefaultLexicalState Property

IDynamicLexerDefaultLexicalState Property

Gets or sets the root ILexicalState for when the language is entered.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DynamicLexicalState DefaultLexicalState { get; set; }
Property DefaultLexicalState As DynamicLexicalState
    Get
    Set

Property Value

Type: DynamicLexicalState
The root ILexicalState for when the language is entered.
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer.Key Property

IDynamicLexerKey Property

Gets or sets a string that identifies the lexer, generally the related language name.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Key { get; set; }
Property Key As String
    Get
    Set

Property Value

Type: String
A string that identifies the lexer, generally the related language name.

Implements

IKeyedObjectKey
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer.LexicalMacros Property

IDynamicLexerLexicalMacros Property

Gets the collection of lexical macros.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDynamicLexicalMacroCollection LexicalMacros { get; }
ReadOnly Property LexicalMacros As IDynamicLexicalMacroCollection
    Get

Property Value

Type: IDynamicLexicalMacroCollection
A IDynamicLexicalMacroCollection containing the lexical macros.
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer.LexicalStates Property

IDynamicLexerLexicalStates Property

Gets the collection of lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDynamicLexicalStateCollection LexicalStates { get; }
ReadOnly Property LexicalStates As IDynamicLexicalStateCollection
    Get

Property Value

Type: IDynamicLexicalStateCollection
A IDynamicLexicalStateCollection containing the lexical states.
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer Methods

The IDynamicLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from IMergableLexer.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from IMergableLexer.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from IMergableLexer.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Inherited from IMergableLexer.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from IMergableLexer.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Inherited from IMergableLexer.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from ILexer.)
Top
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer Events

The IDynamicLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from IMergableLexer.)
Top
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalMacroCollection Interface

Provides the base requirements for a collection of DynamicLexicalMacro objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalMacroCollection : IEnumerable,
    IKeyedObservableCollection<DynamicLexicalMacro>, IObservableCollection<DynamicLexicalMacro>, IList<DynamicLexicalMacro>,
    ICollection<DynamicLexicalMacro>, IEnumerable<DynamicLexicalMacro>
Public Interface IDynamicLexicalMacroCollection
    Inherits IEnumerable, IKeyedObservableCollection(Of DynamicLexicalMacro), IObservableCollection(Of DynamicLexicalMacro),
    IList(Of DynamicLexicalMacro), ICollection(Of DynamicLexicalMacro), IEnumerable(Of DynamicLexicalMacro)

The IDynamicLexicalMacroCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalMacro .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalMacro .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalMacro .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalMacro .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalMacro .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalMacro .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalMacro .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalMacro .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalMacro .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalMacro .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalMacro .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalMacro | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalMacro | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalMacro | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalMacroCollection Properties

The IDynamicLexicalMacroCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalMacro .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalMacro .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalMacro .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalMacroCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalMacroCollection Methods

The IDynamicLexicalMacroCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalMacro .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalMacro .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalMacro .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalMacro .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalMacro .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalMacro .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalMacro .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalMacro .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalMacro | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalMacro | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalMacro | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IDynamicLexicalMacroCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalMacroCollection Events

The IDynamicLexicalMacroCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalMacroCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternCollection Interface

Provides the base requirements for a collection of DynamicLexicalPattern objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalPatternCollection : IEnumerable,
    IObservableCollection<DynamicLexicalPattern>, IList<DynamicLexicalPattern>, ICollection<DynamicLexicalPattern>,
    IEnumerable<DynamicLexicalPattern>
Public Interface IDynamicLexicalPatternCollection
    Inherits IEnumerable, IObservableCollection(Of DynamicLexicalPattern), IList(Of DynamicLexicalPattern),
    ICollection(Of DynamicLexicalPattern), IEnumerable(Of DynamicLexicalPattern)

The IDynamicLexicalPatternCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalPattern .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalPattern .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalPattern .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalPattern .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalPattern .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalPattern .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalPattern .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalPattern .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalPattern .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalPattern .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalPattern .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalPattern | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalPattern | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalPattern | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternCollection Properties

The IDynamicLexicalPatternCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalPattern .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalPattern .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalPattern .)
Top
See Also

Reference

IDynamicLexicalPatternCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternCollection Methods

The IDynamicLexicalPatternCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalPattern .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalPattern .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalPattern .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalPattern .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalPattern .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalPattern .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalPattern .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalPattern .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalPattern | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalPattern | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalPattern | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IDynamicLexicalPatternCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternCollection Events

The IDynamicLexicalPatternCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalPatternCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternGroupCollection Interface

Provides the base requirements for a collection of DynamicLexicalPatternGroup objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalPatternGroupCollection : IEnumerable,
    IKeyedObservableCollection<DynamicLexicalPatternGroup>, IObservableCollection<DynamicLexicalPatternGroup>, IList<DynamicLexicalPatternGroup>,
    ICollection<DynamicLexicalPatternGroup>, IEnumerable<DynamicLexicalPatternGroup>
Public Interface IDynamicLexicalPatternGroupCollection
    Inherits IEnumerable, IKeyedObservableCollection(Of DynamicLexicalPatternGroup), IObservableCollection(Of DynamicLexicalPatternGroup),
    IList(Of DynamicLexicalPatternGroup), ICollection(Of DynamicLexicalPatternGroup), IEnumerable(Of DynamicLexicalPatternGroup)

The IDynamicLexicalPatternGroupCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalPatternGroup .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalPatternGroup .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalPatternGroup .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalPatternGroup .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalPatternGroup | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalPatternGroup | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalPatternGroup | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternGroupCollection Properties

The IDynamicLexicalPatternGroupCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalPatternGroup .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalPatternGroupCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternGroupCollection Methods

The IDynamicLexicalPatternGroupCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalPatternGroup .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalPatternGroup .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalPatternGroup .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalPatternGroup | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalPatternGroup | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalPatternGroup | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IDynamicLexicalPatternGroupCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternGroupCollection Events

The IDynamicLexicalPatternGroupCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalPatternGroupCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalScopeCollection Interface

Provides the base requirements for a collection of DynamicLexicalScope objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalScopeCollection : IEnumerable,
    IObservableCollection<DynamicLexicalScope>, IList<DynamicLexicalScope>, ICollection<DynamicLexicalScope>,
    IEnumerable<DynamicLexicalScope>
Public Interface IDynamicLexicalScopeCollection
    Inherits IEnumerable, IObservableCollection(Of DynamicLexicalScope), IList(Of DynamicLexicalScope),
    ICollection(Of DynamicLexicalScope), IEnumerable(Of DynamicLexicalScope)

The IDynamicLexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalScope .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalScope .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalScope .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalScope .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalScope .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalScope .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalScope .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalScope .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalScope .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalScope .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalScope .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalScope | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalScope | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalScope | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalScopeCollection Properties

The IDynamicLexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalScope .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalScope .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalScope .)
Top
See Also

Reference

IDynamicLexicalScopeCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalScopeCollection Methods

The IDynamicLexicalScopeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalScope .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalScope .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalScope .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalScope .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalScope .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalScope .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalScope .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalScope .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalScope | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalScope | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalScope | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IDynamicLexicalScopeCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalScopeCollection Events

The IDynamicLexicalScopeCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalScopeCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalStateCollection Interface

Provides the base requirements for a collection of DynamicLexicalState objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalStateCollection : IEnumerable,
    IKeyedObservableCollection<DynamicLexicalState>, IObservableCollection<DynamicLexicalState>, IList<DynamicLexicalState>,
    ICollection<DynamicLexicalState>, IEnumerable<DynamicLexicalState>
Public Interface IDynamicLexicalStateCollection
    Inherits IEnumerable, IKeyedObservableCollection(Of DynamicLexicalState), IObservableCollection(Of DynamicLexicalState),
    IList(Of DynamicLexicalState), ICollection(Of DynamicLexicalState), IEnumerable(Of DynamicLexicalState)

The IDynamicLexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalState .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalState .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalState .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalState .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalState .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalState .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalState .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalState .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalState .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalState .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalState .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalState | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalState | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalState | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalStateCollection Properties

The IDynamicLexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection DynamicLexicalState .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection DynamicLexicalState .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList DynamicLexicalState .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalStateCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalStateCollection Methods

The IDynamicLexicalStateCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection DynamicLexicalState .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection DynamicLexicalState .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection DynamicLexicalState .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection DynamicLexicalState .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList DynamicLexicalState .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList DynamicLexicalState .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection DynamicLexicalState .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList DynamicLexicalState .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeDynamicLexicalState | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeDynamicLexicalState | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllDynamicLexicalState | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IDynamicLexicalStateCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalStateCollection Events

The IDynamicLexicalStateCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalStateCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase Class

Provides the abstract base class for a lexical scope.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalScope
ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalScope

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LexicalScopeBase : ILexicalScope
Public MustInherit Class LexicalScopeBase
    Implements ILexicalScope

The LexicalScopeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LexicalScopeBase | Initializes a new instance of the LexicalScopeBase class.
Top
Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope.
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope.
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending.
Top
Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase Constructor

Initializes a new instance of the LexicalScopeBase class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LexicalScopeBase()
Protected Sub New
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase Properties

The LexicalScopeBase type exposes the following members.

Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope.
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope.
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending.
Top
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.IsAncestorEndScopeCheckEnabled Property

LexicalScopeBaseIsAncestorEndScopeCheckEnabled Property

Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAncestorEndScopeCheckEnabled { get; set; }
Public Property IsAncestorEndScopeCheckEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ancestor end scope checking is enabled; otherwise, false.

Implements

ILexicalScopeIsAncestorEndScopeCheckEnabled
Remarks
When enabled, this allows ancestor scopes to be examined to see a pattern matches their end scope. In the event a match is found, this scope exits as well as the ancestor's scope.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.LexicalStateCore Property

LexicalScopeBaseLexicalStateCore Property

Gets or sets the ILexicalState that defines the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ILexicalState LexicalStateCore { get; set; }
Protected Property LexicalStateCore As ILexicalState
    Get
    Set

Property Value

Type: ILexicalState
The ILexicalState that defines the lexical scope.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.ParentTransitionCore Property

LexicalScopeBaseParentTransitionCore Property

Gets or sets the ILexicalStateTransition that is the parent of this scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ILexicalStateTransition ParentTransitionCore { get; set; }
Protected Property ParentTransitionCore As ILexicalStateTransition
    Get
    Set

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that is the parent of this scope.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.Tag Property

LexicalScopeBaseTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .

Implements

ILexicalScopeTag
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.Transition Property

LexicalScopeBaseTransition Property

Gets or sets the ILexicalStateTransition that this scope performs after ending.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalStateTransition Transition { get; set; }
Public Property Transition As ILexicalStateTransition
    Get
    Set

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that this scope performs after ending. If the value is , then no state transition is performed when the scope ends.

Implements

ILexicalScopeTransition
Remarks
The state transition may be made to a child language.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase Methods

The LexicalScopeBase type exposes the following members.

Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.
Top
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.IsScopeEnd Method

LexicalScopeBaseIsScopeEnd Method

Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract MergableLexerResult IsScopeEnd(
    ITextBufferReader reader
)
Public MustOverride Function IsScopeEnd (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeEnd(ITextBufferReader)
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.IsScopeStart Method

LexicalScopeBaseIsScopeStart Method

Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract MergableLexerResult IsScopeStart(
    ITextBufferReader reader
)
Public MustOverride Function IsScopeStart (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeStart(ITextBufferReader)
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Class

Represents a collection of lexical scopes.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection LexicalScopeBase
ActiproSoftware.Text.UtilitySimpleObservableCollection LexicalScopeBase
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeCollection

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LexicalScopeCollection : SimpleObservableCollection<LexicalScopeBase>,
    IEnumerable, IList<ILexicalScope>, ICollection<ILexicalScope>,
    IEnumerable<ILexicalScope>, ILexicalScopeCollection
Public Class LexicalScopeCollection
    Inherits SimpleObservableCollection(Of LexicalScopeBase)
    Implements IEnumerable, IList(Of ILexicalScope),
    ICollection(Of ILexicalScope), IEnumerable(Of ILexicalScope), ILexicalScopeCollection

The LexicalScopeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalScopeCollection | Initializes a new instance of the LexicalScopeCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LexicalScopeBase .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LexicalScopeBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LexicalScopeBase .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LexicalScopeBase .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LexicalScopeBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LexicalScopeBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LexicalScopeBase .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LexicalScopeBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LexicalScopeBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LexicalScopeBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Overrides SimpleObservableCollectionTOnItemAdded(Int32, T).)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Overrides SimpleObservableCollectionTOnItemRemoving(Int32, T).)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LexicalScopeBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LexicalScopeBase .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeILexicalScope | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeILexicalScope | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllILexicalScope | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Constructor

Initializes a new instance of the LexicalScopeCollection class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LexicalScopeCollection(
    ILexicalState parentLexicalState
)
Public Sub New (
    parentLexicalState As ILexicalState
)

Parameters

parentLexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The parent ILexicalState that should be assigned to children, if any.
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Properties

The LexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LexicalScopeBase .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LexicalScopeBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LexicalScopeBase .)
Top
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Methods

The LexicalScopeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LexicalScopeBase .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LexicalScopeBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LexicalScopeBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LexicalScopeBase .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LexicalScopeBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LexicalScopeBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LexicalScopeBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Overrides SimpleObservableCollectionTOnItemAdded(Int32, T).)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Overrides SimpleObservableCollectionTOnItemRemoving(Int32, T).)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LexicalScopeBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LexicalScopeBase .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeILexicalScope | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeILexicalScope | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllILexicalScope | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection.OnItemAdded Method

LexicalScopeCollectionOnItemAdded Method

Called after an item as been added into the collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnItemAdded(
    int index,
    LexicalScopeBase value
)
Protected Overrides Sub OnItemAdded (
    index As Integer,
    value As LexicalScopeBase
)

Parameters

index
Type: SystemInt32
The index at which the item is added.
value
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
The item that is added.
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection.OnItemRemoving Method

LexicalScopeCollectionOnItemRemoving Method

Called before an item has been removed from the collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnItemRemoving(
    int index,
    LexicalScopeBase value
)
Protected Overrides Sub OnItemRemoving (
    index As Integer,
    value As LexicalScopeBase
)

Parameters

index
Type: SystemInt32
The index at which the item is removed.
value
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
The item that is removed.
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Events

The LexicalScopeCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData Class

Provides IToken lexer data based on a token ID and an ILexicalScope.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeTokenData

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LexicalScopeTokenData : IMergableTokenLexerData
Public Class LexicalScopeTokenData
    Implements IMergableTokenLexerData

The LexicalScopeTokenData type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalScopeTokenData | Initializes a new instance of the LexicalScopeTokenData class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that contains the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData Constructor

Initializes a new instance of the LexicalScopeTokenData class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LexicalScopeTokenData(
    ILexicalScope lexicalScope,
    int tokenId
)
Public Sub New (
    lexicalScope As ILexicalScope,
    tokenId As Integer
)

Parameters

lexicalScope
Type: ActiproSoftware.Text.LexingILexicalScope
The ILexicalScope that contains the token.
tokenId
Type: SystemInt32
The ID of the token.
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData Properties

The LexicalScopeTokenData type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that contains the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.ClassificationType Property

LexicalScopeTokenDataClassificationType Property

Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; }
Public ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType assigned to the token.

Implements

IMergableTokenLexerDataClassificationType
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.Lexer Property

LexicalScopeTokenDataLexer Property

Gets the IMergableLexer that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IMergableLexer Lexer { get; }
Public ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that contains the token.

Implements

IMergableTokenLexerDataLexer
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.LexicalScope Property

LexicalScopeTokenDataLexicalScope Property

Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalScope LexicalScope { get; }
Public ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.

Implements

IMergableTokenLexerDataLexicalScope
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.LexicalState Property

LexicalScopeTokenDataLexicalState Property

Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalState LexicalState { get; }
Public ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.

Implements

IMergableTokenLexerDataLexicalState
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.TokenId Property

LexicalScopeTokenDataTokenId Property

Gets the token ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int TokenId { get; }
Public ReadOnly Property TokenId As Integer
    Get

Property Value

Type: Int32
The token ID assigned to the token.

Implements

IMergableTokenLexerDataTokenId
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.TokenKey Property

LexicalScopeTokenDataTokenKey Property

Gets the token key assigned to the token, if it is known.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string TokenKey { get; }
Public Overridable ReadOnly Property TokenKey As String
    Get

Property Value

Type: String
The token key assigned to the token, if it is known.

Implements

IMergableTokenLexerDataTokenKey
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData Methods

The LexicalScopeTokenData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.Equals Method

LexicalScopeTokenDataEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.GetHashCode Method

LexicalScopeTokenDataGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase Class

Provides the abstract base class for a lexical state.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalState
ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalState

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LexicalStateBase : IKeyedObject,
    ILexicalState
Public MustInherit Class LexicalStateBase
    Implements IKeyedObject, ILexicalState

The LexicalStateBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LexicalStateBase | Initializes a new instance of the LexicalStateBase class.
Top
Properties
 | Name | Description
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns.
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns.
Public property | Id | Gets or sets the ID value that identifies the lexical state.
Public property | Key | Gets a string-based key that identifies the lexical state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.
Top
Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore.
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore.
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase Constructor

Initializes a new instance of the LexicalStateBase class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LexicalStateBase(
    int id,
    string key
)
Protected Sub New (
    id As Integer,
    key As String
)

Parameters

id
Type: SystemInt32
The ID of the lexical state.
key
Type: SystemString
The key of the lexical state.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase Properties

The LexicalStateBase type exposes the following members.

Properties
 | Name | Description
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns.
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns.
Public property | Id | Gets or sets the ID value that identifies the lexical state.
Public property | Key | Gets a string-based key that identifies the lexical state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.
Top
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.ChildLexicalStatesCore Property

LexicalStateBaseChildLexicalStatesCore Property

Gets the collection of child lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ILexicalStateCollection ChildLexicalStatesCore { get; }
Protected ReadOnly Property ChildLexicalStatesCore As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
A LexicalStateCollection containing the child lexical states.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.DefaultTokenId Property

LexicalStateBaseDefaultTokenId Property

Gets or sets the ID of the default token that this state assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int DefaultTokenId { get; set; }
Public Property DefaultTokenId As Integer
    Get
    Set

Property Value

Type: Int32
The ID of the default token that this state assigns.

Implements

ILexicalStateDefaultTokenId
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.DefaultTokenKey Property

LexicalStateBaseDefaultTokenKey Property

Gets or sets the key of the default token that this state assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DefaultTokenKey { get; set; }
Public Property DefaultTokenKey As String
    Get
    Set

Property Value

Type: String
The key of the default token that this state assigns.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.Id Property

LexicalStateBaseId Property

Gets or sets the ID value that identifies the lexical state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set

Property Value

Type: Int32
The ID value that identifies the lexical state.

Implements

ILexicalStateId
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.Key Property

LexicalStateBaseKey Property

Gets a string-based key that identifies the lexical state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
A string-based key that identifies the lexical state.

Implements

IKeyedObjectKey
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.LexerCore Property

LexicalStateBaseLexerCore Property

Gets or sets the ILexer that contains the state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ILexer LexerCore { get; set; }
Protected Property LexerCore As ILexer
    Get
    Set

Property Value

Type: ILexer
The ILexer that contains the state.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.LexicalScopesCore Property

LexicalStateBaseLexicalScopesCore Property

Gets the collection of lexical scopes.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ILexicalScopeCollection LexicalScopesCore { get; }
Protected ReadOnly Property LexicalScopesCore As ILexicalScopeCollection
    Get

Property Value

Type: ILexicalScopeCollection
A LexicalScopeCollection containing the lexical scopes.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.Tag Property

LexicalStateBaseTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .

Implements

ILexicalStateTag
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.Transition Property

LexicalStateBaseTransition Property

Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalStateTransition Transition { get; set; }
Public Property Transition As ILexicalStateTransition
    Get
    Set

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that is performed immediately after a start scope match.

Implements

ILexicalStateTransition
Remarks
This provides a mechanism to automatically transition to another language when this state's start scope is matched. This state's end scope may be used to exit the child language.

ASP-style tags are an example of when to use this transition.

See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase Methods

The LexicalStateBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore.
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore.
Top
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.CreateChildLexicalStates Method

LexicalStateBaseCreateChildLexicalStates Method

Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual ILexicalStateCollection CreateChildLexicalStates()
Protected Overridable Function CreateChildLexicalStates As ILexicalStateCollection

Return Value

Type: ILexicalStateCollection
The ILexicalStateCollection that was created.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.CreateLexicalScopes Method

LexicalStateBaseCreateLexicalScopes Method

Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual ILexicalScopeCollection CreateLexicalScopes()
Protected Overridable Function CreateLexicalScopes As ILexicalScopeCollection

Return Value

Type: ILexicalScopeCollection
The ILexicalScopeCollection that was created.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Class

Represents a collection of lexical states.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection LexicalStateBase
ActiproSoftware.Text.UtilitySimpleObservableCollection LexicalStateBase
ActiproSoftware.Text.UtilityKeyedObservableCollection LexicalStateBase
ActiproSoftware.Text.Lexing.ImplementationLexicalStateCollection

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LexicalStateCollection : KeyedObservableCollection<LexicalStateBase>,
    IEnumerable, IList<ILexicalState>, ICollection<ILexicalState>,
    IEnumerable<ILexicalState>, ILexicalStateCollection
Public Class LexicalStateCollection
    Inherits KeyedObservableCollection(Of LexicalStateBase)
    Implements IEnumerable, IList(Of ILexicalState),
    ICollection(Of ILexicalState), IEnumerable(Of ILexicalState), ILexicalStateCollection

The LexicalStateCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalStateCollection | Initializes a new instance of the LexicalStateCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LexicalStateBase .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection LexicalStateBase .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from KeyedObservableCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LexicalStateBase .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LexicalStateBase .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LexicalStateBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from KeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection LexicalStateBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LexicalStateBase .)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexical states.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LexicalStateBase .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from KeyedObservableCollectionT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LexicalStateBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LexicalStateBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Overrides SimpleObservableCollectionTOnItemAdded(Int32, T).)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Overrides SimpleObservableCollectionTOnItemRemoving(Int32, T).)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from KeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LexicalStateBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LexicalStateBase .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeILexicalState | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeILexicalState | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllILexicalState | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Constructor

Initializes a new instance of the LexicalStateCollection class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LexicalStateCollection(
    ILexer parentLexer
)
Public Sub New (
    parentLexer As ILexer
)

Parameters

parentLexer
Type: ActiproSoftware.Text.LexingILexer
The parent ILexer that should be assigned to children, if any.
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Properties

The LexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LexicalStateBase .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection LexicalStateBase .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from KeyedObservableCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LexicalStateBase .)
Top
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Methods

The LexicalStateCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LexicalStateBase .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LexicalStateBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from KeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection LexicalStateBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LexicalStateBase .)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexical states.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LexicalStateBase .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from KeyedObservableCollectionT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LexicalStateBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LexicalStateBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Overrides SimpleObservableCollectionTOnItemAdded(Int32, T).)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Overrides SimpleObservableCollectionTOnItemRemoving(Int32, T).)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from KeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LexicalStateBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LexicalStateBase .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeILexicalState | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeILexicalState | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllILexicalState | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection.GetAllLexicalStateTransitions Method

LexicalStateCollectionGetAllLexicalStateTransitions Method

Returns a collection containing all ILexicalStateTransition objects within the lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexical states.
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection.OnItemAdded Method

LexicalStateCollectionOnItemAdded Method

Called after an item as been added into the collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnItemAdded(
    int index,
    LexicalStateBase value
)
Protected Overrides Sub OnItemAdded (
    index As Integer,
    value As LexicalStateBase
)

Parameters

index
Type: SystemInt32
The index at which the item is added.
value
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
The item that is added.
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection.OnItemRemoving Method

LexicalStateCollectionOnItemRemoving Method

Called before an item has been removed from the collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnItemRemoving(
    int index,
    LexicalStateBase value
)
Protected Overrides Sub OnItemRemoving (
    index As Integer,
    value As LexicalStateBase
)

Parameters

index
Type: SystemInt32
The index at which the item is removed.
value
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
The item that is removed.
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Events

The LexicalStateCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase Class

Represents an abstract base class for an object that provides static IDs for the lexical states of an ISyntaxLanguage.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpLexicalStateId
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptLexicalStateId
ActiproSoftware.Text.Languages.Python.ImplementationPythonLexicalStateId
ActiproSoftware.Text.Languages.VB.ImplementationVBLexicalStateId
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLexicalStateId

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LexicalStateIdProviderBase : IIdProvider,
    ILexicalStateIdProvider
Public MustInherit Class LexicalStateIdProviderBase
    Implements IIdProvider, ILexicalStateIdProvider

The LexicalStateIdProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LexicalStateIdProviderBase | Initializes a new instance of the LexicalStateIdProviderBase class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase Constructor

Initializes a new instance of the LexicalStateIdProviderBase class

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LexicalStateIdProviderBase()
Protected Sub New
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase Properties

The LexicalStateIdProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.MaxId Property

LexicalStateIdProviderBaseMaxId Property

Gets the maximum ID returned by this provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract int MaxId { get; }
Public MustOverride ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.MinId Property

LexicalStateIdProviderBaseMinId Property

Gets the minimum ID returned by this provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract int MinId { get; }
Public MustOverride ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase Methods

The LexicalStateIdProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.ContainsId Method

LexicalStateIdProviderBaseContainsId Method

Returns whether the specified ID value is valid for this ID provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract bool ContainsId(
    int id
)
Public MustOverride Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.GetDescription Method

LexicalStateIdProviderBaseGetDescription Method

Returns the actual string representation for the specified ID.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract string GetDescription(
    int id
)
Public MustOverride Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The actual string representation for the specified ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.GetKey Method

LexicalStateIdProviderBaseGetKey Method

Returns the string-based key for the specified ID.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract string GetKey(
    int id
)
Public MustOverride Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The string-based key for the specified ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData Class

Provides IToken lexer data based on a token ID and on an ILexicalState.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateTokenData

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LexicalStateTokenData : IMergableTokenLexerData
Public Class LexicalStateTokenData
    Implements IMergableTokenLexerData

The LexicalStateTokenData type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalStateTokenData | Initializes a new instance of the LexicalStateTokenData class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that contains the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData Constructor

Initializes a new instance of the LexicalStateTokenData class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LexicalStateTokenData(
    ILexicalState lexicalState,
    int tokenId
)
Public Sub New (
    lexicalState As ILexicalState,
    tokenId As Integer
)

Parameters

lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.
tokenId
Type: SystemInt32
The ID of the token.
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData Properties

The LexicalStateTokenData type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that contains the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.ClassificationType Property

LexicalStateTokenDataClassificationType Property

Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; }
Public ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType assigned to the token.

Implements

IMergableTokenLexerDataClassificationType
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.Lexer Property

LexicalStateTokenDataLexer Property

Gets the IMergableLexer that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IMergableLexer Lexer { get; }
Public ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that contains the token.

Implements

IMergableTokenLexerDataLexer
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.LexicalScope Property

LexicalStateTokenDataLexicalScope Property

Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalScope LexicalScope { get; }
Public ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.

Implements

IMergableTokenLexerDataLexicalScope
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.LexicalState Property

LexicalStateTokenDataLexicalState Property

Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalState LexicalState { get; }
Public ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.

Implements

IMergableTokenLexerDataLexicalState
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.TokenId Property

LexicalStateTokenDataTokenId Property

Gets the token ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int TokenId { get; }
Public ReadOnly Property TokenId As Integer
    Get

Property Value

Type: Int32
The token ID assigned to the token.

Implements

IMergableTokenLexerDataTokenId
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.TokenKey Property

LexicalStateTokenDataTokenKey Property

Gets the token key assigned to the token, if it is known.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string TokenKey { get; }
Public Overridable ReadOnly Property TokenKey As String
    Get

Property Value

Type: String
The token key assigned to the token, if it is known.

Implements

IMergableTokenLexerDataTokenKey
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData Methods

The LexicalStateTokenData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.Equals Method

LexicalStateTokenDataEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.GetHashCode Method

LexicalStateTokenDataGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition Class

Contains information about a transition from one lexical state to another.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateTransition

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LexicalStateTransition : ILexicalStateTransition
Public Class LexicalStateTransition
    Implements ILexicalStateTransition

The LexicalStateTransition type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalStateTransition | Initializes a new instance of the LexicalStateTransition class.
Top
Properties
 | Name | Description
Public property | ChildLanguage | Gets the ISyntaxLanguage that contains the ChildLexicalState.
Public property | ChildLexicalScope | Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
Public property | ChildLexicalState | Gets the ILexicalState into which a transition is made.
Public property | ParentLexicalScope | Gets the ILexicalScope that owns this state transition.
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition Constructor

Initializes a new instance of the LexicalStateTransition class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LexicalStateTransition(
    ISyntaxLanguage childLanguage,
    ILexicalState childLexicalState,
    LexicalScopeBase childLexicalScope
)
Public Sub New (
    childLanguage As ISyntaxLanguage,
    childLexicalState As ILexicalState,
    childLexicalScope As LexicalScopeBase
)

Parameters

childLanguage
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage that contains the ChildLexicalState.
childLexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState into which a transition is made.
childLexicalScope
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
The ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition Properties

The LexicalStateTransition type exposes the following members.

Properties
 | Name | Description
Public property | ChildLanguage | Gets the ISyntaxLanguage that contains the ChildLexicalState.
Public property | ChildLexicalScope | Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
Public property | ChildLexicalState | Gets the ILexicalState into which a transition is made.
Public property | ParentLexicalScope | Gets the ILexicalScope that owns this state transition.
Top
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition.ChildLanguage Property

LexicalStateTransitionChildLanguage Property

Gets the ISyntaxLanguage that contains the ChildLexicalState.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISyntaxLanguage ChildLanguage { get; }
Public ReadOnly Property ChildLanguage As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that contains the ChildLexicalState.

Implements

ILexicalStateTransitionChildLanguage
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition.ChildLexicalScope Property

LexicalStateTransitionChildLexicalScope Property

Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalScope ChildLexicalScope { get; }
Public ReadOnly Property ChildLexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.

Implements

ILexicalStateTransitionChildLexicalScope
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition.ChildLexicalState Property

LexicalStateTransitionChildLexicalState Property

Gets the ILexicalState into which a transition is made.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalState ChildLexicalState { get; }
Public ReadOnly Property ChildLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState into which a transition is made.

Implements

ILexicalStateTransitionChildLexicalState
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition.ParentLexicalScope Property

LexicalStateTransitionParentLexicalScope Property

Gets the ILexicalScope that owns this state transition.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalScope ParentLexicalScope { get; }
Public ReadOnly Property ParentLexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope that owns this state transition.

Implements

ILexicalStateTransitionParentLexicalScope
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase Class

Represents the base implementation of a lexer (lexical analyzer) for a language that supports merging with other languages.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
More...

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class MergableLexerBase : IKeyedObject,
    ILexer, IMergableLexer
Public MustInherit Class MergableLexerBase
    Implements IKeyedObject, ILexer, IMergableLexer

The MergableLexerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MergableLexerBase | Initializes a new instance of the MergableLexerBase class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered.
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name.
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document.
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data.
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer.
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested.
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.
Protected method | OnChanged | Raises the Changed event.
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ILexer interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpLexer
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptLexer
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonLexer
ActiproSoftware.Text.Languages.Python.ImplementationPythonLexer
ActiproSoftware.Text.Languages.VB.ImplementationVBLexer
ActiproSoftware.Text.Lexing.ImplementationDynamicLexer


MergableLexerBase Constructor

Initializes a new instance of the MergableLexerBase class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MergableLexerBase()
Protected Sub New
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase Properties

The MergableLexerBase type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered.
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name.
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Top
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.DefaultLexicalStateCore Property

MergableLexerBaseDefaultLexicalStateCore Property

Gets or sets the root ILexicalState for when the language is entered.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ILexicalState DefaultLexicalStateCore { get; set; }
Protected Property DefaultLexicalStateCore As ILexicalState
    Get
    Set

Property Value

Type: ILexicalState
The root ILexicalState for when the language is entered.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.KeyCore Property

MergableLexerBaseKeyCore Property

Gets or sets a string that identifies the lexer, generally the related language name.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected string KeyCore { get; set; }
Protected Property KeyCore As String
    Get
    Set

Property Value

Type: String
A string that identifies the lexer, generally the related language name.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.LexicalStateIdProviderCore Property

MergableLexerBaseLexicalStateIdProviderCore Property

Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ILexicalStateIdProvider LexicalStateIdProviderCore { get; set; }
Protected Property LexicalStateIdProviderCore As ILexicalStateIdProvider
    Get
    Set

Property Value

Type: ILexicalStateIdProvider
The ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.TokenIdProviderCore Property

MergableLexerBaseTokenIdProviderCore Property

Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ITokenIdProvider TokenIdProviderCore { get; set; }
Protected Property TokenIdProviderCore As ITokenIdProvider
    Get
    Set

Property Value

Type: ITokenIdProvider
The ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase Methods

The MergableLexerBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document.
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data.
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer.
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested.
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.
Protected method | OnChanged | Raises the Changed event.
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Top
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.CreateChangeBatch Method

MergableLexerBaseCreateChangeBatch Method

Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDisposable CreateChangeBatch()
Public Function CreateChangeBatch As IDisposable

Return Value

Type: IDisposable
An IDisposable object. Once disposed, the batch is ended.

Implements

IMergableLexerCreateChangeBatch
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.CreateDocumentEndToken Method

MergableLexerBaseCreateDocumentEndToken Method

Creates an IMergableToken that represents the end of a document.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IMergableToken CreateDocumentEndToken(
    int startOffset,
    TextPosition startPosition,
    ILexicalState lexicalState
)
Public Overridable Function CreateDocumentEndToken (
    startOffset As Integer,
    startPosition As TextPosition,
    lexicalState As ILexicalState
) As IMergableToken

Parameters

startOffset
Type: SystemInt32
The start offset of the IToken.
startPosition
Type: ActiproSoftware.TextTextPosition
The start TextPosition of the IToken.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.

Return Value

Type: IMergableToken
An IMergableToken that represents the end of a document.

Implements

IMergableLexerCreateDocumentEndToken(Int32, TextPosition, ILexicalState)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.CreateToken Method

MergableLexerBaseCreateToken Method

Creates an IMergableToken that represents the range of text with the specified lexer data.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IMergableToken CreateToken(
    int startOffset,
    int length,
    TextPosition startPosition,
    TextPosition endPosition,
    MergableLexerFlags lexerFlags,
    ILexicalState lexicalState,
    IMergableTokenLexerData lexerData
)
Public Overridable Function CreateToken (
    startOffset As Integer,
    length As Integer,
    startPosition As TextPosition,
    endPosition As TextPosition,
    lexerFlags As MergableLexerFlags,
    lexicalState As ILexicalState,
    lexerData As IMergableTokenLexerData
) As IMergableToken

Parameters

startOffset
Type: SystemInt32
The start offset of the token.
length
Type: SystemInt32
The length of the token.
startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition of the first character in the token.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition after the last character in the token.
lexerFlags
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags for the token.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.
lexerData
Type: ActiproSoftware.Text.LexingIMergableTokenLexerData
The IMergableTokenLexerData that contains lexer information about the token.

Return Value

Type: IMergableToken
An IMergableToken that represents the range of text with the specified lexer data.

Implements

IMergableLexerCreateToken(Int32, Int32, TextPosition, TextPosition, MergableLexerFlags, ILexicalState, IMergableTokenLexerData)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.GetAllLexicalStateTransitions Method

MergableLexerBaseGetAllLexicalStateTransitions Method

Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public MustOverride Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.GetDefaultToken Method

MergableLexerBaseGetDefaultToken Method

Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual MergableLexerResult GetDefaultToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overridable Function GetDefaultToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetDefaultToken(ITextBufferReader, ILexicalState)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.GetIncrementalParseRange Method

MergableLexerBaseGetIncrementalParseRange Method

Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotRange GetIncrementalParseRange(
    TextSnapshotRange snapshotRange
)
Protected Overridable Function GetIncrementalParseRange (
    snapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The requested TextSnapshotRange to incrementally parse.

Return Value

Type: TextSnapshotRange
The actual TextSnapshotRange to incrementally parse.
Remarks
When performing incremental parsing, a larger snapshot range than the actual modified snapshot range should usually be parsed. For instance, if the end user types text at the end of a word that should make the word a keyword, incremental parsing should start at least at the start of the word or else it won't be recognized as a keyword.

The default implementation of this method starts incremental parsing at the start of the line at which the requested snapshot range begins.

This method is called by the default Parse(TextSnapshotRange, ILexerTarget) implementation to modify the snapshot range to parse.

See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.GetNextToken Method

MergableLexerBaseGetNextToken Method

Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public MustOverride Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.OnChanged Method

MergableLexerBaseOnChanged Method

Raises the Changed event.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnChanged(
    EventArgs e
)
Protected Overridable Sub OnChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The EventArgs that contains the event data.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.Parse Method

MergableLexerBaseParse Method

Lexically parses the specified TextRange of the ITextSnapshot.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual TextRange Parse(
    TextSnapshotRange snapshotRange,
    ILexerTarget parseTarget
)
Public Overridable Function Parse (
    snapshotRange As TextSnapshotRange,
    parseTarget As ILexerTarget
) As TextRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange indicating the offset range to parse.
parseTarget
Type: ActiproSoftware.Text.LexingILexerTarget
The ILexerTarget that receives the parsing output.

Return Value

Type: TextRange
A TextRange containing the offset range that was modified.

Implements

ILexerParse(TextSnapshotRange, ILexerTarget)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase Events

The MergableLexerBase type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.
Top
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.Changed Event

MergableLexerBaseChanged Event

Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler Changed
Public Event Changed As EventHandler

Value

Type: SystemEventHandler

Implements

IMergableLexerChanged
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator Class

Coordinates lexer and state shifting for one or more mergable lexers.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerCoordinator

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MergableLexerCoordinator
Public Class MergableLexerCoordinator

The MergableLexerCoordinator type exposes the following members.

Methods
 | Name | Description
 | Create | Creates an instance of a coordinator for the specified ITextBufferReader and IMergableLexer.
Public method | GetNextToken | Returns the next IMergableToken.
 | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Public method | Pop | Pops the top coordinator state from the stack and restores the coordinator to that state.
Public method | Push | Pushes the coordinator state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Top
Remarks
Features include: Forward-only reading in the ITextBufferReader.Retrieve one token at a time from a starting offset.Possible look-ahead token gathering and caching.Parse through a certain snapshot range and output to an ILexerTarget.
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator Methods

The MergableLexerCoordinator type exposes the following members.

Methods
 | Name | Description
 | Create | Creates an instance of a coordinator for the specified ITextBufferReader and IMergableLexer.
Public method | GetNextToken | Returns the next IMergableToken.
 | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Public method | Pop | Pops the top coordinator state from the stack and restores the coordinator to that state.
Public method | Push | Pushes the coordinator state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Top
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.Create Method

MergableLexerCoordinatorCreate Method

Creates an instance of a coordinator for the specified ITextBufferReader and IMergableLexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static MergableLexerCoordinator Create(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Shared Function Create (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
) As MergableLexerCoordinator

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.

Return Value

Type: MergableLexerCoordinator
The MergableLexerCoordinator that was created.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.GetNextToken Method

MergableLexerCoordinatorGetNextToken Method

Returns the next IMergableToken.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IMergableToken GetNextToken()
Public Function GetNextToken As IMergableToken

Return Value

Type: IMergableToken
The next IMergableToken.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.Parse Method

MergableLexerCoordinatorParse Method

Lexically parses the specified TextRange of the ITextSnapshot.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextRange Parse(
    TextSnapshotRange snapshotRange,
    ILexerTarget lexerTarget
)
Public Shared Function Parse (
    snapshotRange As TextSnapshotRange,
    lexerTarget As ILexerTarget
) As TextRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange indicating the offset range to parse.
lexerTarget
Type: ActiproSoftware.Text.LexingILexerTarget
The ILexerTarget to update.

Return Value

Type: TextRange
A TextRange that was parsed.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.Pop Method

MergableLexerCoordinatorPop Method

Pops the top coordinator state from the stack and restores the coordinator to that state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Pop()
Public Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.Push Method

MergableLexerCoordinatorPush Method

Pushes the coordinator state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Push()
Public Sub Push
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken Class

Represents the default implementation of an IToken that can be used with an IMergableLexer.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenBase
ActiproSoftware.Text.Lexing.ImplementationMergableToken

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MergableToken : TokenBase,
    IMergableToken, IToken
Public Class MergableToken
    Inherits TokenBase
    Implements IMergableToken, IToken

The MergableToken type exposes the following members.

Constructors
 | Name | Description
Public method | MergableToken | Initializes a new instance of the MergableToken class.
Top
Properties
 | Name | Description
Public property | AutoCaseCorrectText | Gets the text that should be used for this IToken when performing an auto case correction operation on it.
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | DeclaringLexicalState | Gets the ILexicalState that declares the pattern that matched the token.
Public property | EndOffset | Gets the offset after the last character in the token. (Inherited from TokenBase.)
Public property | EndPosition | Gets the TextPosition after the last character in the token. (Inherited from TokenBase.)
Public property | Id | Gets the ID assigned to the token. (Overrides TokenBaseId.)
Public property | Key | Gets the key assigned to the token. (Overrides TokenBaseKey.)
Public property | Length | Gets or sets the absolute length of the token. (Inherited from TokenBase.)
Public property | Lexer | Gets the IMergableLexer that created the token.
Protected property | LexerData | Gets an IMergableTokenLexerData that contains lexer information for the token.
Protected property | LexerFlags | Gets a MergableLexerFlags indicating lexer flags for the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state. (Overrides TokenBaseLexicalStateId.)
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token. (Inherited from TokenBase.)
Public property | StartOffset | Gets or sets the offset of the first character in the token. (Inherited from TokenBase.)
Public property | StartPosition | Gets the TextPosition of the first character in the token. (Inherited from TokenBase.)
Public property | TextRange | Gets a TextRange that specifies the text range of the token. (Inherited from TokenBase.)
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset. (Inherited from TokenBase.)
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition. (Inherited from TokenBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from TokenBase.)
Public method | GetHashCode | Returns a hash code for this object. (Inherited from TokenBase.)
Public method | HasFlag | Returns whether the parse data has the specified MergableLexerFlags flag.
Public method | SetFlag | Sets or clears the specified MergableLexerFlags flag.
Public method | ToString | Creates and returns a string representation of the current object. (Inherited from TokenBase.)
Public method | ToString(String) | Creates and returns a string representation of the current object. (Inherited from TokenBase.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken Constructor

Initializes a new instance of the MergableToken class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MergableToken(
    int startOffset,
    int length,
    TextPosition startPosition,
    TextPosition endPosition,
    MergableLexerFlags lexerFlags,
    ILexicalState lexicalState,
    IMergableTokenLexerData lexerData
)
Public Sub New (
    startOffset As Integer,
    length As Integer,
    startPosition As TextPosition,
    endPosition As TextPosition,
    lexerFlags As MergableLexerFlags,
    lexicalState As ILexicalState,
    lexerData As IMergableTokenLexerData
)

Parameters

startOffset
Type: SystemInt32
The start offset of the token.
length
Type: SystemInt32
The length of the token.
startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition of the first character in the token.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition after the last character in the token.
lexerFlags
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags for the token.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.
lexerData
Type: ActiproSoftware.Text.LexingIMergableTokenLexerData
The IMergableTokenLexerData that contains the lexer information about the token.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken Properties

The MergableToken type exposes the following members.

Properties
 | Name | Description
Public property | AutoCaseCorrectText | Gets the text that should be used for this IToken when performing an auto case correction operation on it.
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | DeclaringLexicalState | Gets the ILexicalState that declares the pattern that matched the token.
Public property | EndOffset | Gets the offset after the last character in the token. (Inherited from TokenBase.)
Public property | EndPosition | Gets the TextPosition after the last character in the token. (Inherited from TokenBase.)
Public property | Id | Gets the ID assigned to the token. (Overrides TokenBaseId.)
Public property | Key | Gets the key assigned to the token. (Overrides TokenBaseKey.)
Public property | Length | Gets or sets the absolute length of the token. (Inherited from TokenBase.)
Public property | Lexer | Gets the IMergableLexer that created the token.
Protected property | LexerData | Gets an IMergableTokenLexerData that contains lexer information for the token.
Protected property | LexerFlags | Gets a MergableLexerFlags indicating lexer flags for the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state. (Overrides TokenBaseLexicalStateId.)
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token. (Inherited from TokenBase.)
Public property | StartOffset | Gets or sets the offset of the first character in the token. (Inherited from TokenBase.)
Public property | StartPosition | Gets the TextPosition of the first character in the token. (Inherited from TokenBase.)
Public property | TextRange | Gets a TextRange that specifies the text range of the token. (Inherited from TokenBase.)
Top
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.AutoCaseCorrectText Property

MergableTokenAutoCaseCorrectText Property

Gets the text that should be used for this IToken when performing an auto case correction operation on it.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string AutoCaseCorrectText { get; }
Public Overridable ReadOnly Property AutoCaseCorrectText As String
    Get

Property Value

Type: String
The text that should be used for this IToken when performing an auto case correction operation on it.

Implements

IMergableTokenAutoCaseCorrectText
Remarks
Return a value to indicate that there is no auto case correction text available.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.ClassificationType Property

MergableTokenClassificationType Property

Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IClassificationType ClassificationType { get; }
Public Overridable ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType assigned to the token.

Implements

IMergableTokenClassificationType
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.DeclaringLexicalState Property

MergableTokenDeclaringLexicalState Property

Gets the ILexicalState that declares the pattern that matched the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual ILexicalState DeclaringLexicalState { get; }
Public Overridable ReadOnly Property DeclaringLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that declares the pattern that matched the token.

Implements

IMergableTokenDeclaringLexicalState
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.Id Property

MergableTokenId Property

Gets the ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The ID assigned to the token.

Implements

ITokenId
ITokenId
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.Key Property

MergableTokenKey Property

Gets the key assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string Key { get; }
Public Overrides ReadOnly Property Key As String
    Get

Property Value

Type: String
The key assigned to the token.

Implements

ITokenKey
ITokenKey
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.Lexer Property

MergableTokenLexer Property

Gets the IMergableLexer that created the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IMergableLexer Lexer { get; }
Public ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that created the token.

Implements

IMergableTokenLexer
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexerData Property

MergableTokenLexerData Property

Gets an IMergableTokenLexerData that contains lexer information for the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IMergableTokenLexerData LexerData { get; }
Protected ReadOnly Property LexerData As IMergableTokenLexerData
    Get

Property Value

Type: IMergableTokenLexerData
An IMergableTokenLexerData that contains lexer information for the token.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexerFlags Property

MergableTokenLexerFlags Property

Gets a MergableLexerFlags indicating lexer flags for the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MergableLexerFlags LexerFlags { get; }
Protected ReadOnly Property LexerFlags As MergableLexerFlags
    Get

Property Value

Type: MergableLexerFlags
A MergableLexerFlags indicating lexer flags for the token.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexicalScope Property

MergableTokenLexicalScope Property

Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual ILexicalScope LexicalScope { get; }
Public Overridable ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.

Implements

IMergableTokenLexicalScope
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexicalState Property

MergableTokenLexicalState Property

Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual ILexicalState LexicalState { get; }
Public Overridable ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.

Implements

IMergableTokenLexicalState
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexicalStateId Property

MergableTokenLexicalStateId Property

Gets the ID assigned to the lexical state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int LexicalStateId { get; }
Public Overrides ReadOnly Property LexicalStateId As Integer
    Get

Property Value

Type: Int32
The ID assigned to the lexical state.

Implements

ITokenLexicalStateId
ITokenLexicalStateId
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken Methods

The MergableToken type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset. (Inherited from TokenBase.)
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition. (Inherited from TokenBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from TokenBase.)
Public method | GetHashCode | Returns a hash code for this object. (Inherited from TokenBase.)
Public method | HasFlag | Returns whether the parse data has the specified MergableLexerFlags flag.
Public method | SetFlag | Sets or clears the specified MergableLexerFlags flag.
Public method | ToString | Creates and returns a string representation of the current object. (Inherited from TokenBase.)
Public method | ToString(String) | Creates and returns a string representation of the current object. (Inherited from TokenBase.)
Top
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.HasFlag Method

MergableTokenHasFlag Method

Returns whether the parse data has the specified MergableLexerFlags flag.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool HasFlag(
    MergableLexerFlags flag
)
Public Overridable Function HasFlag (
    flag As MergableLexerFlags
) As Boolean

Parameters

flag
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags to check for.

Return Value

Type: Boolean
true if the parse data has the specified MergableLexerFlags flag; otherwise, false.

Implements

IMergableTokenHasFlag(MergableLexerFlags)
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.SetFlag Method

MergableTokenSetFlag Method

Sets or clears the specified MergableLexerFlags flag.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void SetFlag(
    MergableLexerFlags flag,
    bool setBit
)
Public Overridable Sub SetFlag (
    flag As MergableLexerFlags,
    setBit As Boolean
)

Parameters

flag
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags to set or clear.
setBit
Type: SystemBoolean
Whether to set the flag; otherwise, the flag is cleared.

Implements

IMergableTokenSetFlag(MergableLexerFlags, Boolean)
Remarks
This method should only be called by lexers.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope Class

Provides a lexical scope implementation that uses two delegates to perform the IsScopeStart(ITextBufferReader) and IsScopeEnd(ITextBufferReader) checks.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalScope

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ProgrammaticLexicalScope : LexicalScopeBase
Public Class ProgrammaticLexicalScope
    Inherits LexicalScopeBase

The ProgrammaticLexicalScope type exposes the following members.

Constructors
 | Name | Description
Public method | ProgrammaticLexicalScope | Initializes a new instance of the ProgrammaticLexicalScope class.
Top
Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope. (Inherited from LexicalScopeBase.)
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope. (Inherited from LexicalScopeBase.)
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope. (Inherited from LexicalScopeBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalScopeBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending. (Inherited from LexicalScopeBase.)
Top
Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope. (Overrides LexicalScopeBaseIsScopeEnd(ITextBufferReader).)
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope. (Overrides LexicalScopeBaseIsScopeStart(ITextBufferReader).)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope Constructor

Initializes a new instance of the ProgrammaticLexicalScope class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ProgrammaticLexicalScope(
    ProgrammaticLexicalScopeMatch isScopeStartDelegate,
    ProgrammaticLexicalScopeMatch isScopeEndDelegate
)
Public Sub New (
    isScopeStartDelegate As ProgrammaticLexicalScopeMatch,
    isScopeEndDelegate As ProgrammaticLexicalScopeMatch
)

Parameters

isScopeStartDelegate
Type: ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalScopeMatch
The ProgrammaticLexicalScopeMatch to use for matching the scope's start.
isScopeEndDelegate
Type: ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalScopeMatch
The ProgrammaticLexicalScopeMatch to use for matching the scope's end.
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope Properties

The ProgrammaticLexicalScope type exposes the following members.

Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope. (Inherited from LexicalScopeBase.)
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope. (Inherited from LexicalScopeBase.)
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope. (Inherited from LexicalScopeBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalScopeBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending. (Inherited from LexicalScopeBase.)
Top
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope Methods

The ProgrammaticLexicalScope type exposes the following members.

Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope. (Overrides LexicalScopeBaseIsScopeEnd(ITextBufferReader).)
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope. (Overrides LexicalScopeBaseIsScopeStart(ITextBufferReader).)
Top
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope.IsScopeEnd Method

ProgrammaticLexicalScopeIsScopeEnd Method

Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult IsScopeEnd(
    ITextBufferReader reader
)
Public Overrides Function IsScopeEnd (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeEnd(ITextBufferReader)
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope.IsScopeStart Method

ProgrammaticLexicalScopeIsScopeStart Method

Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override MergableLexerResult IsScopeStart(
    ITextBufferReader reader
)
Public Overrides Function IsScopeStart (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeStart(ITextBufferReader)
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScopeMatch Delegate

Represents the method that will handle token matching callbacks for ProgrammaticLexicalScope objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public delegate MergableLexerResult ProgrammaticLexicalScopeMatch(
    ITextBufferReader reader,
    ILexicalScope lexicalScope
)
Public Delegate Function ProgrammaticLexicalScopeMatch (
    reader As ITextBufferReader,
    lexicalScope As ILexicalScope
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalScope
Type: ActiproSoftware.Text.LexingILexicalScope
The ILexicalScope that specifies the lexical scope to check.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState Class

Provides a default implementation for a lexical state.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalState

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ProgrammaticLexicalState : LexicalStateBase
Public Class ProgrammaticLexicalState
    Inherits LexicalStateBase

The ProgrammaticLexicalState type exposes the following members.

Constructors
 | Name | Description
Public method | ProgrammaticLexicalState | Initializes a new instance of the ProgrammaticLexicalState class.
Top
Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states. (Inherited from LexicalStateBase.)
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | Id | Gets or sets the ID value that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Key | Gets a string-based key that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Lexer | Gets the ILexer that contains the state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state. (Inherited from LexicalStateBase.)
Public property | LexicalScopes | Gets the collection of lexical scopes.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes. (Inherited from LexicalStateBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalStateBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match. (Inherited from LexicalStateBase.)
Top
Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore. (Inherited from LexicalStateBase.)
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore. (Inherited from LexicalStateBase.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState Constructor

Initializes a new instance of the ProgrammaticLexicalState class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ProgrammaticLexicalState(
    int id,
    string key
)
Public Sub New (
    id As Integer,
    key As String
)

Parameters

id
Type: SystemInt32
The ID of the lexical state.
key
Type: SystemString
The key of the lexical state.
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState Properties

The ProgrammaticLexicalState type exposes the following members.

Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states. (Inherited from LexicalStateBase.)
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | Id | Gets or sets the ID value that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Key | Gets a string-based key that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Lexer | Gets the ILexer that contains the state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state. (Inherited from LexicalStateBase.)
Public property | LexicalScopes | Gets the collection of lexical scopes.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes. (Inherited from LexicalStateBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalStateBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match. (Inherited from LexicalStateBase.)
Top
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState.ChildLexicalStates Property

ProgrammaticLexicalStateChildLexicalStates Property

Gets the collection of child lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalStateCollection ChildLexicalStates { get; }
Public ReadOnly Property ChildLexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
A ILexicalStateCollection containing the child lexical states.
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState.Lexer Property

ProgrammaticLexicalStateLexer Property

Gets the ILexer that contains the state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexer Lexer { get; }
Public ReadOnly Property Lexer As ILexer
    Get

Property Value

Type: ILexer
The ILexer that contains the state.
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState.LexicalScopes Property

ProgrammaticLexicalStateLexicalScopes Property

Gets the collection of lexical scopes.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILexicalScopeCollection LexicalScopes { get; }
Public ReadOnly Property LexicalScopes As ILexicalScopeCollection
    Get

Property Value

Type: ILexicalScopeCollection
A ILexicalScopeCollection containing the lexical scopes.
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState Methods

The ProgrammaticLexicalState type exposes the following members.

Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore. (Inherited from LexicalStateBase.)
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore. (Inherited from LexicalStateBase.)
Top
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase Class

Represents the base class for an IToken implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenBase
ActiproSoftware.Text.Lexing.ImplementationMergableToken

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TokenBase : IToken
Public MustInherit Class TokenBase
    Implements IToken

The TokenBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TokenBase | Initializes a new instance of the TokenBase class.
Top
Properties
 | Name | Description
Public property | EndOffset | Gets the offset after the last character in the token.
Public property | EndPosition | Gets the TextPosition after the last character in the token.
Public property | Id | Gets the ID assigned to the token.
Public property | Key | Gets the key assigned to the token.
Public property | Length | Gets or sets the absolute length of the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token.
Public property | StartOffset | Gets or sets the offset of the first character in the token.
Public property | StartPosition | Gets the TextPosition of the first character in the token.
Public property | TextRange | Gets a TextRange that specifies the text range of the token.
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Public method | ToString(String) | Creates and returns a string representation of the current object.
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase Constructor

Initializes a new instance of the TokenBase class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TokenBase(
    int startOffset,
    int length,
    TextPosition startPosition,
    TextPosition endPosition
)
Protected Sub New (
    startOffset As Integer,
    length As Integer,
    startPosition As TextPosition,
    endPosition As TextPosition
)

Parameters

startOffset
Type: SystemInt32
The start offset of the token.
length
Type: SystemInt32
The length of the token.
startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition of the first character in the token.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition after the last character in the token.
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase Properties

The TokenBase type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset after the last character in the token.
Public property | EndPosition | Gets the TextPosition after the last character in the token.
Public property | Id | Gets the ID assigned to the token.
Public property | Key | Gets the key assigned to the token.
Public property | Length | Gets or sets the absolute length of the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token.
Public property | StartOffset | Gets or sets the offset of the first character in the token.
Public property | StartPosition | Gets the TextPosition of the first character in the token.
Public property | TextRange | Gets a TextRange that specifies the text range of the token.
Top
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.EndOffset Property

TokenBaseEndOffset Property

Gets the offset after the last character in the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int EndOffset { get; }
Public ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The offset after the last character in the token.

Implements

ITokenEndOffset
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.EndPosition Property

TokenBaseEndPosition Property

Gets the TextPosition after the last character in the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition EndPosition { get; }
Public ReadOnly Property EndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition after the last character in the token.

Implements

ITokenEndPosition
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Id Property

TokenBaseId Property

Gets the ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract int Id { get; }
Public MustOverride ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The ID assigned to the token.

Implements

ITokenId
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Key Property

TokenBaseKey Property

Gets the key assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string Key { get; }
Public Overridable ReadOnly Property Key As String
    Get

Property Value

Type: String
The key assigned to the token.

Implements

ITokenKey
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Length Property

TokenBaseLength Property

Gets or sets the absolute length of the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set

Property Value

Type: Int32
The absolute length of the token.

Implements

ITokenLength
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.LexicalStateId Property

TokenBaseLexicalStateId Property

Gets the ID assigned to the lexical state that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual int LexicalStateId { get; }
Public Overridable ReadOnly Property LexicalStateId As Integer
    Get

Property Value

Type: Int32
The ID assigned to the lexical state that contains the token.

Implements

ITokenLexicalStateId
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.PositionRange Property

TokenBasePositionRange Property

Gets a TextPositionRange that specifies the text position range of the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPositionRange PositionRange { get; }
Public ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A TextPositionRange that specifies the text position range of the token.

Implements

ITokenPositionRange
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.StartOffset Property

TokenBaseStartOffset Property

Gets or sets the offset of the first character in the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int StartOffset { get; set; }
Public Property StartOffset As Integer
    Get
    Set

Property Value

Type: Int32
The offset of the first character in the token.

Implements

ITokenStartOffset
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.StartPosition Property

TokenBaseStartPosition Property

Gets the TextPosition of the first character in the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition StartPosition { get; }
Public ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition of the first character in the token.

Implements

ITokenStartPosition
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.TextRange Property

TokenBaseTextRange Property

Gets a TextRange that specifies the text range of the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextRange TextRange { get; }
Public ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
A TextRange that specifies the text range of the token.

Implements

ITokenTextRange
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase Methods

The TokenBase type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Public method | ToString(String) | Creates and returns a string representation of the current object.
Top
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Contains Method

TokenBaseContains Method

Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Top
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Contains Method (Int32)

TokenBaseContains Method (Int32)

Returns whether the IToken contains the specified offset.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the IToken contains the specified offset; otherwise, false.

Implements

ITokenContains(Int32)
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the IToken.
See Also

Reference

TokenBase Class
Contains Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Contains Method (TextPosition)

TokenBaseContains Method (TextPosition)

Returns whether the IToken contains the specified TextPosition.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    TextPosition position
)
Public Function Contains (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the IToken contains the specified TextPosition; otherwise, false.

Implements

ITokenContains(TextPosition)
Remarks
This method returns false if the position falls on the EndPosition position since this method indicates if the position is encompassed by the IToken.
See Also

Reference

TokenBase Class
Contains Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Equals Method

TokenBaseEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.GetHashCode Method

TokenBaseGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.ToString Method

TokenBaseToString Method

Overload List
 | Name | Description
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Public method | ToString(String) | Creates and returns a string representation of the current object.
Top
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.ToString Method

TokenBaseToString Method

Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

TokenBase Class
ToString Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.ToString Method (String)

TokenBaseToString Method (String)

Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ToString(
    string tokenDescription
)
Public Function ToString (
    tokenDescription As String
) As String

Parameters

tokenDescription
Type: SystemString
The description of the IToken.

Return Value

Type: String
A string representation of the current object.
See Also

Reference

TokenBase Class
ToString Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Class

Represents an abstract base class for an object that provides static IDs for the tokens of an ISyntaxLanguage.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenId
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenId
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenId
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenId
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenId

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TokenIdProviderBase : IIdProvider,
    ITokenIdProvider
Public MustInherit Class TokenIdProviderBase
    Implements IIdProvider, ITokenIdProvider

The TokenIdProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TokenIdProviderBase | Initializes a new instance of the TokenIdProviderBase class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
Fields
Name | Description
DocumentEnd | Gets the DocumentEnd token ID, which is common among all languages.
Invalid | Gets the Invalid token ID, which is common among all languages.
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Constructor

Initializes a new instance of the TokenIdProviderBase class

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TokenIdProviderBase()
Protected Sub New
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Properties

The TokenIdProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.MaxId Property

TokenIdProviderBaseMaxId Property

Gets the maximum ID returned by this provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract int MaxId { get; }
Public MustOverride ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.MinId Property

TokenIdProviderBaseMinId Property

Gets the minimum ID returned by this provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract int MinId { get; }
Public MustOverride ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Methods

The TokenIdProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.ContainsId Method

TokenIdProviderBaseContainsId Method

Returns whether the specified ID value is valid for this ID provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract bool ContainsId(
    int id
)
Public MustOverride Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.GetDescription Method

TokenIdProviderBaseGetDescription Method

Returns the actual string representation for the specified ID.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract string GetDescription(
    int id
)
Public MustOverride Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The actual string representation for the specified ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.GetKey Method

TokenIdProviderBaseGetKey Method

Returns the string-based key for the specified ID.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract string GetKey(
    int id
)
Public MustOverride Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The string-based key for the specified ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Fields

The TokenIdProviderBase type exposes the following members.

Fields
Name | Description
DocumentEnd | Gets the DocumentEnd token ID, which is common among all languages.
Invalid | Gets the Invalid token ID, which is common among all languages.
Top
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.DocumentEnd Field

TokenIdProviderBaseDocumentEnd Field

Gets the DocumentEnd token ID, which is common among all languages.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int DocumentEnd = -1
Public Const DocumentEnd As Integer = -1

Field Value

Type: Int32
The DocumentEnd token ID.
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.Invalid Field

TokenIdProviderBaseInvalid Field

Gets the Invalid token ID, which is common among all languages.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int Invalid = -2
Public Const Invalid As Integer = -2

Field Value

Type: Int32
The Invalid token ID.
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Class

Stores token data for a range of text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenSet

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TokenSet : IEnumerable, ITextRangeProvider,
    IEnumerable<IToken>, ITokenSet
Public Class TokenSet
    Implements IEnumerable, ITextRangeProvider, IEnumerable(Of IToken),
    ITokenSet

The TokenSet type exposes the following members.

Constructors
 | Name | Description
Public method | TokenSet(TextRange, IEnumerableIToken, Object) | Initializes a new instance of the TokenSet class.
Public method | TokenSet(TextRange, IEnumerableTagSnapshotRangeITokenTag, Object) | Initializes a new instance of the TokenSet class.
Top
Properties
 | Name | Description
Public property | Count | Gets the count of tokens that are stored in the token set.
Public property | FirstToken | Gets the first IToken in the set.
Public property | FirstTokenExtendsBack | Gets whether the FirstToken extends back to another token set.
Public property | LastToken | Gets the last IToken in the set.
Public property | LastTokenExtendsForward | Gets whether the LastToken extends forward to another token set.
Public property | ParseContext | Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
Public property | TextRange | Gets the TextRange for which tokens in this set are available.
Public property | Tokens | Gets an IToken in the token set.
Top
Methods
 | Name | Description
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | IndexOf | Returns the index of the IToken in the set that contains the specified offset, if any.
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Constructor

Overload List
 | Name | Description
Public method | TokenSet(TextRange, IEnumerableIToken, Object) | Initializes a new instance of the TokenSet class.
Public method | TokenSet(TextRange, IEnumerableTagSnapshotRangeITokenTag, Object) | Initializes a new instance of the TokenSet class.
Top
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Constructor (TextRange, IEnumerable(IToken), Object)

TokenSet Constructor (TextRange, IEnumerableIToken, Object)

Initializes a new instance of the TokenSet class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TokenSet(
    TextRange textRange,
    IEnumerable<IToken> tokens,
    Object parseContext
)
Public Sub New (
    textRange As TextRange,
    tokens As IEnumerable(Of IToken),
    parseContext As Object
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange for which tokens in this set are available.
tokens
Type: System.Collections.GenericIEnumerable IToken
The enumerable collection of tokens to add to the set.
parseContext
Type: SystemObject
An optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
See Also

Reference

TokenSet Class
TokenSet Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Constructor (TextRange, IEnumerable(TagSnapshotRange(ITokenTag)), Object)

TokenSet Constructor (TextRange, IEnumerableTagSnapshotRangeITokenTag, Object)

Initializes a new instance of the TokenSet class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TokenSet(
    TextRange textRange,
    IEnumerable<TagSnapshotRange<ITokenTag>> tagRanges,
    Object parseContext
)
Public Sub New (
    textRange As TextRange,
    tagRanges As IEnumerable(Of TagSnapshotRange(Of ITokenTag)),
    parseContext As Object
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange for which tokens in this set are available.
tagRanges
Type: System.Collections.GenericIEnumerable TagSnapshotRange ITokenTag
The enumerable collection of token tag ranges to add to the set.
parseContext
Type: SystemObject
An optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
See Also

Reference

TokenSet Class
TokenSet Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Properties

The TokenSet type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count of tokens that are stored in the token set.
Public property | FirstToken | Gets the first IToken in the set.
Public property | FirstTokenExtendsBack | Gets whether the FirstToken extends back to another token set.
Public property | LastToken | Gets the last IToken in the set.
Public property | LastTokenExtendsForward | Gets whether the LastToken extends forward to another token set.
Public property | ParseContext | Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
Public property | TextRange | Gets the TextRange for which tokens in this set are available.
Public property | Tokens | Gets an IToken in the token set.
Top
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.Count Property

TokenSetCount Property

Gets the count of tokens that are stored in the token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of tokens that are stored in the token set.

Implements

ITokenSetCount
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.FirstToken Property

TokenSetFirstToken Property

Gets the first IToken in the set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IToken FirstToken { get; }
Public ReadOnly Property FirstToken As IToken
    Get

Property Value

Type: IToken
The first IToken in the set.

Implements

ITokenSetFirstToken
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.FirstTokenExtendsBack Property

TokenSetFirstTokenExtendsBack Property

Gets whether the FirstToken extends back to another token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool FirstTokenExtendsBack { get; }
Public ReadOnly Property FirstTokenExtendsBack As Boolean
    Get

Property Value

Type: Boolean
true if the FirstToken extends back to another token set; otherwise, false.

Implements

ITokenSetFirstTokenExtendsBack
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.LastToken Property

TokenSetLastToken Property

Gets the last IToken in the set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IToken LastToken { get; }
Public ReadOnly Property LastToken As IToken
    Get

Property Value

Type: IToken
The last IToken in the set.

Implements

ITokenSetLastToken
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.LastTokenExtendsForward Property

TokenSetLastTokenExtendsForward Property

Gets whether the LastToken extends forward to another token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool LastTokenExtendsForward { get; }
Public ReadOnly Property LastTokenExtendsForward As Boolean
    Get

Property Value

Type: Boolean
true if the LastToken extends forward to another token set; otherwise, false.

Implements

ITokenSetLastTokenExtendsForward
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.ParseContext Property

TokenSetParseContext Property

Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ParseContext { get; }
Public ReadOnly Property ParseContext As Object
    Get

Property Value

Type: Object
An optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.

Implements

ITokenSetParseContext
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.TextRange Property

TokenSetTextRange Property

Gets the TextRange for which tokens in this set are available.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextRange TextRange { get; set; }
Public Property TextRange As TextRange
    Get
    Set

Property Value

Type: TextRange
The TextRange for which tokens in this set are available.

Implements

ITextRangeProviderTextRange
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.Tokens Property

TokenSetTokens Property

Gets an IToken in the token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IToken this[
    int index
] { get; }
Public ReadOnly Default Property Tokens (
    index As Integer
) As IToken
    Get

Parameters

index
Type: SystemInt32
The index of the IToken to return.

Property Value

Type: IToken
An IToken in the token set.

Implements

ITokenSetTokensInt32
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Methods

The TokenSet type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | IndexOf | Returns the index of the IToken in the set that contains the specified offset, if any.
Top
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.GetEnumerator Method

TokenSetGetEnumerator Method

Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<IToken> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IToken)

Return Value

Type: IEnumerator IToken
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.IndexOf Method

TokenSetIndexOf Method

Returns the index of the IToken in the set that contains the specified offset, if any.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    int offset,
    int hintIndex
)
Public Function IndexOf (
    offset As Integer,
    hintIndex As Integer
) As Integer

Parameters

offset
Type: SystemInt32
The offset for which to search.
hintIndex
Type: SystemInt32
The hint index at which to begin searching; otherwise, -1.

Return Value

Type: Int32
The index of the IToken in the set that contains the specified offset; otherwise, -1.

Implements

ITokenSetIndexOf(Int32, Int32)
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ActiproSoftware.Text.Parsing Namespace

Contains types related to parsing.
Classes
 | Class | Description
Public class | AmbientParseRequestDispatcherProvider | Implements a class that can be used to provide a static IParseRequestDispatcher that is used for parsing operations by default.
Public class | ParseDataPropertyChangedEventArgs | Provides event arguments for a property change event, indicating the old and new values.
Public class | SyntaxLanguageParsingExtensions | Contains parsing-related extension methods that make it easier to work with ISyntaxLanguage objects.
Interfaces
 | Interface | Description
Public interface | IAntlrParseData | Provides the base requirements for a class that contains the results of an ANTLR parsing operation.
Public interface | IAstNode | Provides the base requirements for an AST (abstract syntax tree) node.
Public interface | IAstNodeIdProvider | Provides the base requirements for a class that provides AST node ID's.
Public interface | IIronyParseData | Provides the base requirements for a class that contains the results of an Irony parsing operation.
Public interface | IParseData | Provides the base requirements for a class that represents the result of a parsing operation.
Public interface | IParseError | Provides the base requirements for an object that indicates a message, warning or error related to parsing.
Public interface | IParseErrorProvider | Provides the base requirements for an object that returns a list of IParseError objects, and is generally implemented by IParseData instances if they support error reporting.
Public interface | IParser | Provides the base requirements of a parser (syntax/semantic analyzer) for a language.
Public interface | IParseRequest | Provides the base requirements of a parsing operation request.
Public interface | IParseRequestDispatcher | Provides the base requirements for a class that can queue up IParseRequest objects, prioritize and execute them on one or more worker threads, and notify an IParseTarget of the result.
Public interface | IParseTarget | Provides the base requirements for a class that can be notified with the results of a parsing operation.
Enumerations
 | Enumeration | Description
Public enumeration | ParseErrorLevel | Specifies the error level of an IParseError.
Public enumeration | ParseRequestState | Specifies the current state of an IParseRequest.


AmbientParseRequestDispatcherProvider Class

Implements a class that can be used to provide a static IParseRequestDispatcher that is used for parsing operations by default.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ParsingAmbientParseRequestDispatcherProvider

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class AmbientParseRequestDispatcherProvider
Public NotInheritable Class AmbientParseRequestDispatcherProvider

The AmbientParseRequestDispatcherProvider type exposes the following members.

Properties
Name | Description
Dispatcher | Gets or sets the default IParseRequestDispatcher to use when a parsing operation request is made.
Top
Remarks
Set the Dispatcher property to an IParseRequestDispatcher instance to register the default dispatcher.
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


AmbientParseRequestDispatcherProvider Properties

The AmbientParseRequestDispatcherProvider type exposes the following members.

Properties
Name | Description
Dispatcher | Gets or sets the default IParseRequestDispatcher to use when a parsing operation request is made.
Top
See Also

Reference

AmbientParseRequestDispatcherProvider Class
ActiproSoftware.Text.Parsing Namespace


AmbientParseRequestDispatcherProvider.Dispatcher Property

AmbientParseRequestDispatcherProviderDispatcher Property

Gets or sets the default IParseRequestDispatcher to use when a parsing operation request is made.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IParseRequestDispatcher Dispatcher { get; set; }
Public Shared Property Dispatcher As IParseRequestDispatcher
    Get
    Set

Property Value

Type: IParseRequestDispatcher
The default IParseRequestDispatcher to use when a parsing operation request is made.
See Also

Reference

AmbientParseRequestDispatcherProvider Class
ActiproSoftware.Text.Parsing Namespace


IAntlrParseData Interface

Provides the base requirements for a class that contains the results of an ANTLR parsing operation.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Addons.Antlr.Wpf (in ActiproSoftware.Text.Addons.Antlr.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAntlrParseData : IParseData
Public Interface IAntlrParseData
    Inherits IParseData

The IAntlrParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the ITree that contains the abstract syntax tree result.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IAntlrParseData Properties

The IAntlrParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the ITree that contains the abstract syntax tree result.
Top
See Also

Reference

IAntlrParseData Interface
ActiproSoftware.Text.Parsing Namespace


IAntlrParseData.Ast Property

IAntlrParseDataAst Property

Gets the ITree that contains the abstract syntax tree result.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Addons.Antlr.Wpf (in ActiproSoftware.Text.Addons.Antlr.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITree Ast { get; }
ReadOnly Property Ast As ITree
    Get

Property Value

Type: ITree
The ITree that contains the abstract syntax tree result.
See Also

Reference

IAntlrParseData Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode Interface

Provides the base requirements for an AST (abstract syntax tree) node.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAstNode
Public Interface IAstNode

The IAstNode type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IAstNode Properties

The IAstNode type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Children Property

IAstNodeChildren Property

Gets the list containing the child AST nodes of this AST node.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IAstNode> Children { get; }
ReadOnly Property Children As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The list containing the child AST nodes of this AST node.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.EndOffset Property

IAstNodeEndOffset Property

Gets or sets the end offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<int> EndOffset { get; set; }
Property EndOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The end offset of this AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.HasChildren Property

IAstNodeHasChildren Property

Gets whether the AST node contains any child AST nodes.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasChildren { get; }
ReadOnly Property HasChildren As Boolean
    Get

Property Value

Type: Boolean
true if the AST node contains any child AST nodes; otherwise, false.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Id Property

IAstNodeId Property

Gets an integer value that identifies the type of AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Id { get; }
ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
An integer value that identifies the type of AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Length Property

IAstNodeLength Property

Gets the character length of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The character length of this AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Parent Property

IAstNodeParent Property

Gets or sets the parent IAstNode of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode Parent { get; set; }
Property Parent As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The parent IAstNode of this AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.StartOffset Property

IAstNodeStartOffset Property

Gets or sets the start offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<int> StartOffset { get; set; }
Property StartOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The start offset of this AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Value Property

IAstNodeValue Property

Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Value { get; set; }
Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode Methods

The IAstNode type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Contains Method

IAstNodeContains Method

Returns whether the AST node contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Contains(
    int offset
)
Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the AST node contains the specified offset; otherwise, false.
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the AST node. This method also returns false if the AST node doesn't have known offsets.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.FindChildNode Method

IAstNodeFindChildNode Method

Searches through the child nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode FindChildNode(
    int offset
)
Function FindChildNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The child IAstNode that contains the specified offset, if any.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.FindDescendantNode Method

IAstNodeFindDescendantNode Method

Recursively searches through the descendant nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode FindDescendantNode(
    int offset
)
Function FindDescendantNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The descendant IAstNode that contains the specified offset, if any.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.ToTreeString Method

IAstNodeToTreeString Method

Outputs the contents of the AST node in tree form.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ToTreeString(
    int indentLevel
)
Function ToTreeString (
    indentLevel As Integer
) As String

Parameters

indentLevel
Type: SystemInt32
The indentation level.

Return Value

Type: String
A string containing the tree form of the AST node.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNodeIdProvider Interface

Provides the base requirements for a class that provides AST node ID's.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAstNodeIdProvider : IIdProvider
Public Interface IAstNodeIdProvider
    Inherits IIdProvider

The IAstNodeIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IAstNodeIdProvider Properties

The IAstNodeIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
See Also

Reference

IAstNodeIdProvider Interface
ActiproSoftware.Text.Parsing Namespace


IAstNodeIdProvider Methods

The IAstNodeIdProvider type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

IAstNodeIdProvider Interface
ActiproSoftware.Text.Parsing Namespace


IIronyParseData Interface

Provides the base requirements for a class that contains the results of an Irony parsing operation.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Addons.Irony.Wpf (in ActiproSoftware.Text.Addons.Irony.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IIronyParseData : IParseData,
    IParseErrorProvider
Public Interface IIronyParseData
    Inherits IParseData, IParseErrorProvider

The IIronyParseData type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | ParseTree | Gets the object that contains the parse tree result.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IIronyParseData Properties

The IIronyParseData type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | ParseTree | Gets the object that contains the parse tree result.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

IIronyParseData Interface
ActiproSoftware.Text.Parsing Namespace


IIronyParseData.ParseTree Property

IIronyParseDataParseTree Property

Gets the object that contains the parse tree result.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Addons.Irony.Wpf (in ActiproSoftware.Text.Addons.Irony.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object ParseTree { get; }
ReadOnly Property ParseTree As Object
    Get

Property Value

Type: Object
The object that contains the parse tree result.
See Also

Reference

IIronyParseData Interface
ActiproSoftware.Text.Parsing Namespace


IParseData Interface

Provides the base requirements for a class that represents the result of a parsing operation.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParseData
Public Interface IParseData
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IParseError Interface

Provides the base requirements for an object that indicates a message, warning or error related to parsing.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParseError
Public Interface IParseError

The IParseError type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the optional IClassificationType associated with the error.
Public property | Description | Gets the description of the error, which is displayed in the user interface.
Public property | Level | Gets a ParseErrorLevel indicating the error level.
Public property | PositionRange | Gets the TextPositionRange of the error.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace
ActiproSoftware.Text.Parsing.ImplementationParseError


IParseError Properties

The IParseError type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the optional IClassificationType associated with the error.
Public property | Description | Gets the description of the error, which is displayed in the user interface.
Public property | Level | Gets a ParseErrorLevel indicating the error level.
Public property | PositionRange | Gets the TextPositionRange of the error.
Top
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseError.ClassificationType Property

IParseErrorClassificationType Property

Gets the optional IClassificationType associated with the error.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; }
ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The optional IClassificationType associated with the error.
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseError.Description Property

IParseErrorDescription Property

Gets the description of the error, which is displayed in the user interface.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the error, which is displayed in the user interface.
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseError.Level Property

IParseErrorLevel Property

Gets a ParseErrorLevel indicating the error level.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ParseErrorLevel Level { get; }
ReadOnly Property Level As ParseErrorLevel
    Get

Property Value

Type: ParseErrorLevel
A ParseErrorLevel indicating the error level.
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseError.PositionRange Property

IParseErrorPositionRange Property

Gets the TextPositionRange of the error.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPositionRange PositionRange { get; }
ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
The TextPositionRange of the error.
Remarks
If no text position data is available for the error, the value should be TextPositionRange.Empty.
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseErrorProvider Interface

Provides the base requirements for an object that returns a list of IParseError objects, and is generally implemented by IParseData instances if they support error reporting.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParseErrorProvider
Public Interface IParseErrorProvider

The IParseErrorProvider type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Gets the collection of IParseError objects that specify parse errors.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace
ActiproSoftware.Text.ParsingIParseError


IParseErrorProvider Properties

The IParseErrorProvider type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Gets the collection of IParseError objects that specify parse errors.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created.
Top
See Also

Reference

IParseErrorProvider Interface
ActiproSoftware.Text.Parsing Namespace


IParseErrorProvider.Errors Property

IParseErrorProviderErrors Property

Gets the collection of IParseError objects that specify parse errors.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<IParseError> Errors { get; }
ReadOnly Property Errors As IEnumerable(Of IParseError)
    Get

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that specify parse errors.
See Also

Reference

IParseErrorProvider Interface
ActiproSoftware.Text.Parsing Namespace


IParseErrorProvider.Snapshot Property

IParseErrorProviderSnapshot Property

Gets the ITextSnapshot, if known, from which the parse errors were created.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot, if known, from which the parse errors were created.
See Also

Reference

IParseErrorProvider Interface
ActiproSoftware.Text.Parsing Namespace


IParser Interface

Provides the base requirements of a parser (syntax/semantic analyzer) for a language.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParser : IKeyedObject
Public Interface IParser
    Inherits IKeyedObject

The IParser type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IParser Properties

The IParser type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

IParser Interface
ActiproSoftware.Text.Parsing Namespace


IParser Methods

The IParser type exposes the following members.

Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.
Top
See Also

Reference

IParser Interface
ActiproSoftware.Text.Parsing Namespace


IParser.Parse Method

IParserParse Method

Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseData Parse(
    IParseRequest request
)
Function Parse (
    request As IParseRequest
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.

Return Value

Type: IParseData
An IParseData that is the result of the parsing operation.
Remarks
A IParseRequestDispatcher typically calls this method when a queued parse request is ready to be processed.
See Also

Reference

IParser Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest Interface

Provides the base requirements of a parsing operation request.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParseRequest
Public Interface IParseRequest

The IParseRequest type exposes the following members.

Properties
 | Name | Description
Public property | CreatedDateTime | Gets the DateTime at which the parse request was created.
Public property | Language | Gets the ISyntaxLanguage for which this parse request was created.
Public property | ParseHashKey | Gets a hash key that uniquely identifies the parse request for a source/target combination.
Public property | Parser | Gets the IParser that will perform the parsing operation.
Public property | Priority | Gets an integer value describing the priority of the request, where a higher number has a higher priority.
Public property | RepeatedRequestPause | Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.
Public property | Snapshot | Gets the ITextSnapshot, if available, for which the parse request was created.
Public property | SourceKey | Gets a text key, typically a filename, that uniquely identifies the text to parse.
Public property | State | Gets or sets the current state of the request.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Target | Gets the IParseTarget that will be notified once the parsing operation is complete.
Public property | TextBufferReader | Gets the ITextBufferReader used to read the text that should be parsed.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace
ActiproSoftware.Text.Parsing.ImplementationParseRequest


IParseRequest Properties

The IParseRequest type exposes the following members.

Properties
 | Name | Description
Public property | CreatedDateTime | Gets the DateTime at which the parse request was created.
Public property | Language | Gets the ISyntaxLanguage for which this parse request was created.
Public property | ParseHashKey | Gets a hash key that uniquely identifies the parse request for a source/target combination.
Public property | Parser | Gets the IParser that will perform the parsing operation.
Public property | Priority | Gets an integer value describing the priority of the request, where a higher number has a higher priority.
Public property | RepeatedRequestPause | Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.
Public property | Snapshot | Gets the ITextSnapshot, if available, for which the parse request was created.
Public property | SourceKey | Gets a text key, typically a filename, that uniquely identifies the text to parse.
Public property | State | Gets or sets the current state of the request.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Target | Gets the IParseTarget that will be notified once the parsing operation is complete.
Public property | TextBufferReader | Gets the ITextBufferReader used to read the text that should be parsed.
Top
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.CreatedDateTime Property

IParseRequestCreatedDateTime Property

Gets the DateTime at which the parse request was created.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DateTime CreatedDateTime { get; }
ReadOnly Property CreatedDateTime As DateTime
    Get

Property Value

Type: DateTime
The DateTime at which the parse request was created.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Language Property

IParseRequestLanguage Property

Gets the ISyntaxLanguage for which this parse request was created.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISyntaxLanguage Language { get; }
ReadOnly Property Language As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage for which this parse request was created.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.ParseHashKey Property

IParseRequestParseHashKey Property

Gets a hash key that uniquely identifies the parse request for a source/target combination.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ParseHashKey { get; }
ReadOnly Property ParseHashKey As String
    Get

Property Value

Type: String
A hash key that uniquely identifies the parse request for a source/target combination.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Parser Property

IParseRequestParser Property

Gets the IParser that will perform the parsing operation.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParser Parser { get; }
ReadOnly Property Parser As IParser
    Get

Property Value

Type: IParser
The IParser that will perform the parsing operation.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Priority Property

IParseRequestPriority Property

Gets an integer value describing the priority of the request, where a higher number has a higher priority.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Priority { get; }
ReadOnly Property Priority As Integer
    Get

Property Value

Type: Int32
An integer value describing the priority of the request, where a higher number has a higher priority. The default value is ParseRequest.MediumPriority.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.RepeatedRequestPause Property

IParseRequestRepeatedRequestPause Property

Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int RepeatedRequestPause { get; set; }
Property RepeatedRequestPause As Integer
    Get
    Set

Property Value

Type: Int32
The number of milliseconds to pause if there are repeated attempts for this same request. The default value is 250.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Snapshot Property

IParseRequestSnapshot Property

Gets the ITextSnapshot, if available, for which the parse request was created.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot, if available, for which the parse request was created.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.SourceKey Property

IParseRequestSourceKey Property

Gets a text key, typically a filename, that uniquely identifies the text to parse.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string SourceKey { get; }
ReadOnly Property SourceKey As String
    Get

Property Value

Type: String
A text key, typically a filename, that uniquely identifies the text to parse.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.State Property

IParseRequestState Property

Gets or sets the current state of the request.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ParseRequestState State { get; set; }
Property State As ParseRequestState
    Get
    Set

Property Value

Type: ParseRequestState
The current state of the request.
Remarks
This property should only be set by a IParseRequestDispatcher.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Tag Property

IParseRequestTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the control. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Target Property

IParseRequestTarget Property

Gets the IParseTarget that will be notified once the parsing operation is complete.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseTarget Target { get; }
ReadOnly Property Target As IParseTarget
    Get

Property Value

Type: IParseTarget
The IParseTarget that will be notified once the parsing operation is complete.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.TextBufferReader Property

IParseRequestTextBufferReader Property

Gets the ITextBufferReader used to read the text that should be parsed.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextBufferReader TextBufferReader { get; }
ReadOnly Property TextBufferReader As ITextBufferReader
    Get

Property Value

Type: ITextBufferReader
The ITextBufferReader used to read the text that should be parsed.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher Interface

Provides the base requirements for a class that can queue up IParseRequest objects, prioritize and execute them on one or more worker threads, and notify an IParseTarget of the result.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParseRequestDispatcher
Public Interface IParseRequestDispatcher

The IParseRequestDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | IsBusy | Gets whether the multi-threaded parser service is currently busy processing a request.
Public property | PendingRequestCount | Gets the number of pending requests remaining in the parse request queue.
Top
Methods
 | Name | Description
Public method | GetPendingRequests | Gets an array of the pending requests in the parse request queue.
Public method | HasPendingRequest | Returns whether there is currently a pending request with the specified hash key.
Public method | QueueRequest | Adds an IParseRequest to the queue of pending requests.
Public method | RemovePendingRequests | Removes any pending requests in the parse request queue that have the specified hash key.
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace
ActiproSoftware.Text.Parsing.ImplementationThreadedParseRequestDispatcher


IParseRequestDispatcher Properties

The IParseRequestDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | IsBusy | Gets whether the multi-threaded parser service is currently busy processing a request.
Public property | PendingRequestCount | Gets the number of pending requests remaining in the parse request queue.
Top
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.IsBusy Property

IParseRequestDispatcherIsBusy Property

Gets whether the multi-threaded parser service is currently busy processing a request.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsBusy { get; }
ReadOnly Property IsBusy As Boolean
    Get

Property Value

Type: Boolean
true if the multi-threaded parser service is currently busy processing a request; otherwise, false.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.PendingRequestCount Property

IParseRequestDispatcherPendingRequestCount Property

Gets the number of pending requests remaining in the parse request queue.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int PendingRequestCount { get; }
ReadOnly Property PendingRequestCount As Integer
    Get

Property Value

Type: Int32
The number of pending requests remaining in the parse request queue.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher Methods

The IParseRequestDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | GetPendingRequests | Gets an array of the pending requests in the parse request queue.
Public method | HasPendingRequest | Returns whether there is currently a pending request with the specified hash key.
Public method | QueueRequest | Adds an IParseRequest to the queue of pending requests.
Public method | RemovePendingRequests | Removes any pending requests in the parse request queue that have the specified hash key.
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.GetPendingRequests Method

IParseRequestDispatcherGetPendingRequests Method

Gets an array of the pending requests in the parse request queue.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseRequest[] GetPendingRequests()
Function GetPendingRequests As IParseRequest()

Field Value

Type: IParseRequest
An array of the pending requests in the parse request queue.

Return Value

Type: IParseRequest

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.IParseRequestDispatcher.GetPendingRequests"]

See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.HasPendingRequest Method

IParseRequestDispatcherHasPendingRequest Method

Returns whether there is currently a pending request with the specified hash key.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasPendingRequest(
    string parseHashKey
)
Function HasPendingRequest (
    parseHashKey As String
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to search.

Return Value

Type: Boolean
true if there is currently a pending request with the specified hash key; otherwise, false.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.QueueRequest Method

IParseRequestDispatcherQueueRequest Method

Adds an IParseRequest to the queue of pending requests.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void QueueRequest(
    IParseRequest request
)
Sub QueueRequest (
    request As IParseRequest
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that should be processed.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.RemovePendingRequests Method

IParseRequestDispatcherRemovePendingRequests Method

Removes any pending requests in the parse request queue that have the specified hash key.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int RemovePendingRequests(
    string parseHashKey
)
Function RemovePendingRequests (
    parseHashKey As String
) As Integer

Parameters

parseHashKey
Type: SystemString
The parse hash key for which to search.

Return Value

Type: Int32
The number of pending requests that were removed.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.WaitForParse Method

IParseRequestDispatcherWaitForParse Method

Overload List
 | Name | Description
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.WaitForParse Method (String)

IParseRequestDispatcherWaitForParse Method (String)

Waits a maximum of 250 milliseconds for the specified request to complete.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool WaitForParse(
    string parseHashKey
)
Function WaitForParse (
    parseHashKey As String
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to wait.

Return Value

Type: Boolean
true if a wait occurred; otherwise, false.
See Also

Reference

IParseRequestDispatcher Interface
WaitForParse Overload
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.WaitForParse Method (String, Int32)

IParseRequestDispatcherWaitForParse Method (String, Int32)

Waits for the specified request to complete, up to a maximum number of milliseconds.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool WaitForParse(
    string parseHashKey,
    int maximumWaitTime
)
Function WaitForParse (
    parseHashKey As String,
    maximumWaitTime As Integer
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to wait.
maximumWaitTime
Type: SystemInt32
The maximum wait time in milliseconds.

Return Value

Type: Boolean
true if a wait occurred; otherwise, false.
See Also

Reference

IParseRequestDispatcher Interface
WaitForParse Overload
ActiproSoftware.Text.Parsing Namespace


IParseTarget Interface

Provides the base requirements for a class that can be notified with the results of a parsing operation.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParseTarget
Public Interface IParseTarget

The IParseTarget type exposes the following members.

Properties
 | Name | Description
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Top
Methods
 | Name | Description
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IParseTarget Properties

The IParseTarget type exposes the following members.

Properties
 | Name | Description
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Top
See Also

Reference

IParseTarget Interface
ActiproSoftware.Text.Parsing Namespace


IParseTarget.UniqueId Property

IParseTargetUniqueId Property

Gets the Guid that uniquely identifies the control.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Guid UniqueId { get; }
ReadOnly Property UniqueId As Guid
    Get

Property Value

Type: Guid
The Guid that uniquely identifies the control.
See Also

Reference

IParseTarget Interface
ActiproSoftware.Text.Parsing Namespace


IParseTarget Methods

The IParseTarget type exposes the following members.

Methods
 | Name | Description
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result.
Top
See Also

Reference

IParseTarget Interface
ActiproSoftware.Text.Parsing Namespace


IParseTarget.NotifyParseComplete Method

IParseTargetNotifyParseComplete Method

Called when a parsing operation has completed, and passes the original request along with the result.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void NotifyParseComplete(
    IParseRequest request,
    IParseData result
)
Sub NotifyParseComplete (
    request As IParseRequest,
    result As IParseData
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
An IParseRequest that contains information about the parsing operation that was requested.
result
Type: ActiproSoftware.Text.ParsingIParseData
An IParseData that is the result of the parsing operation.
See Also

Reference

IParseTarget Interface
ActiproSoftware.Text.Parsing Namespace


ParseDataPropertyChangedEventArgs Class

Provides event arguments for a property change event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UtilityPropertyChangedEventArgs IParseData
ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParseDataPropertyChangedEventArgs : PropertyChangedEventArgs<IParseData>
Public Class ParseDataPropertyChangedEventArgs
    Inherits PropertyChangedEventArgs(Of IParseData)

The ParseDataPropertyChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ParseDataPropertyChangedEventArgs | Initializes a new instance of the ParseDataPropertyChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


ParseDataPropertyChangedEventArgs Constructor

Initializes a new instance of the ParseDataPropertyChangedEventArgs class.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParseDataPropertyChangedEventArgs(
    IParseData oldValue,
    IParseData newValue
)
Public Sub New (
    oldValue As IParseData,
    newValue As IParseData
)

Parameters

oldValue
Type: ActiproSoftware.Text.ParsingIParseData
The previous value of the property being tracked as reported by an event.
newValue
Type: ActiproSoftware.Text.ParsingIParseData
The new value of the property being tracked as reported by an event.
See Also

Reference

ParseDataPropertyChangedEventArgs Class
ActiproSoftware.Text.Parsing Namespace


ParseDataPropertyChangedEventArgs Properties

The ParseDataPropertyChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
See Also

Reference

ParseDataPropertyChangedEventArgs Class
ActiproSoftware.Text.Parsing Namespace


ParseErrorLevel Enumeration

Specifies the error level of an IParseError.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ParseErrorLevel
Public Enumeration ParseErrorLevel
Members
Member name | Value | Description
Message | 0 | A message.
Warning | 1 | A warning.
Error | 2 | An error.
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


ParseRequestState Enumeration

Specifies the current state of an IParseRequest.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ParseRequestState
Public Enumeration ParseRequestState
Members
Member name | Value | Description
Created | 0 | The request has been created, but has not yet been queued.
Queued | 1 | The request has been queued by an IParseRequestDispatcher.
Processing | 2 | The request is currently being processed by an IParser.
Processed | 3 | The request has been processed.
Aborted | 4 | The request has been aborted, possibly removed for another newer request for the same parse hash key.
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


SyntaxLanguageParsingExtensions Class

Contains parsing-related extension methods that make it easier to work with ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ParsingSyntaxLanguageParsingExtensions

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class SyntaxLanguageParsingExtensions
<ExtensionAttribute>
Public NotInheritable Class SyntaxLanguageParsingExtensions

The SyntaxLanguageParsingExtensions type exposes the following members.

Methods
Name | Description
Parse | Parses text using the specified language's IParser service and returns the IParseData result.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


SyntaxLanguageParsingExtensions Methods

The SyntaxLanguageParsingExtensions type exposes the following members.

Methods
Name | Description
Parse | Parses text using the specified language's IParser service and returns the IParseData result.
Top
See Also

Reference

SyntaxLanguageParsingExtensions Class
ActiproSoftware.Text.Parsing Namespace


SyntaxLanguageParsingExtensions.Parse Method

SyntaxLanguageParsingExtensionsParse Method

Parses text using the specified language's IParser service and returns the IParseData result.

Namespace: ActiproSoftware.Text.Parsing
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IParseData Parse(
    this ISyntaxLanguage language,
    string text
)
<ExtensionAttribute>
Public Shared Function Parse (
    language As ISyntaxLanguage,
    text As String
) As IParseData

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to examine for a parser.
text
Type: SystemString
The text to parse.

Return Value

Type: IParseData
The IParseData returned by the parser.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This method parses text directly in the calling thread.
See Also

Reference

SyntaxLanguageParsingExtensions Class
ActiproSoftware.Text.Parsing Namespace


ActiproSoftware.Text.Parsing.Implementation Namespace

Contains implementation types related to parsing.
Classes
 | Class | Description
Public class | AntlrParser | Represents an IParser (syntax/semantic analyzer) implementation that can be used to call an ANTLR parser.
Public class | AstNodeBase | Represents an abstract AST (abstract syntax tree) node implementation that is intended to be used as a base class for type-specific AST nodes.
Public class | AstNodeIdProviderBase | Represents an abstract base class for an object that provides static IDs for the AST nodes of an ISyntaxLanguage.
Public class | DefaultAstNode | Represents an AST (abstract syntax tree) node implementation that has a string value and optional child nodes.
Public class | IronyParser | Represents an IParser (syntax/semantic analyzer) implementation that can be used to call an Irony Parser.
Public class | ParseError | Represents an object that indicates a message, warning or error related to parsing.
Public class | ParserBase | Represents the base implementation of a parser (syntax/semantic analyzer) for a language.
Public class | ParseRequest | Represents a request for a parsing operation.
Public class | ThreadedParseRequestDispatcher | Implements an IParseRequestDispatcher that uses a worker thread to process parse requests.


AntlrParser Class

Represents an IParser (syntax/semantic analyzer) implementation that can be used to call an ANTLR parser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.ImplementationAntlrParser

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Addons.Antlr.Wpf (in ActiproSoftware.Text.Addons.Antlr.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AntlrParser : ParserBase
Public Class AntlrParser
    Inherits ParserBase

The AntlrParser type exposes the following members.

Constructors
 | Name | Description
Public method | AntlrParser | Initializes a new instance of the AntlrParser class.
Top
Properties
 | Name | Description
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Overrides ParserBaseParse(IParseRequest).)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


AntlrParser Constructor

Initializes a new instance of the AntlrParser class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Addons.Antlr.Wpf (in ActiproSoftware.Text.Addons.Antlr.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AntlrParser(
    string key,
    Type coreLexerType,
    Type coreParserType,
    string defaultParserMethodName
)
Public Sub New (
    key As String,
    coreLexerType As Type,
    coreParserType As Type,
    defaultParserMethodName As String
)

Parameters

key
Type: SystemString
A string that identifies the parser.
coreLexerType
Type: SystemType
The Type of core ANTLR lexer that should be used. This is the lexer Type generated by ANTLR.
coreParserType
Type: SystemType
The Type of core ANTLR parser that should be used. This is the parser Type generated by ANTLR.
defaultParserMethodName
Type: SystemString
The default parser method to call. This is the same as the name of the root rule in your ANTLR grammar.
See Also

Reference

AntlrParser Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AntlrParser Properties

The AntlrParser type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

AntlrParser Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AntlrParser Methods

The AntlrParser type exposes the following members.

Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Overrides ParserBaseParse(IParseRequest).)
Top
See Also

Reference

AntlrParser Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AntlrParser.Parse Method

AntlrParserParse Method

Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Addons.Antlr.Wpf (in ActiproSoftware.Text.Addons.Antlr.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IParseData Parse(
    IParseRequest request
)
Public Overrides Function Parse (
    request As IParseRequest
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.

Return Value

Type: IParseData
An IParseData that is the result of the parsing operation.

Implements

IParserParse(IParseRequest)
Remarks
A IParseRequestDispatcher typically calls this method when a queued parse request is ready to be processed.
See Also

Reference

AntlrParser Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase Class

Represents an abstract AST (abstract syntax tree) node implementation that is intended to be used as a base class for type-specific AST nodes.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
More...

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class AstNodeBase : IAstNode
Public MustInherit Class AstNodeBase
    Implements IAstNode

The AstNodeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AstNodeBase | Initializes a new instance of the AstNodeBase class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAccessorBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAccessorDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArgument
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayReallocateClause
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttribute
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttributeArgument
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttributeSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCatchClause
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationClassBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnit
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnitOption
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConstructorBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDocumentationComment
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationElseIfSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEventBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExternalAliasDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExternalAliasDirectiveSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedSizeBufferDeclarator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceAccessorDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMethodBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNamespaceBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNamespaceDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOperatorBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOrdering
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationParameterDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPreprocessorDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPropertyBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRangeVariableDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRangeVariableDeclarator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStructureBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSwitchSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeParameter
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingDirectiveSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationVariableDeclarator
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationArgument
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationCatchClause
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationCompilationUnit
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionBody
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationParameterDeclaration
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationPropertyDeclaration
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSwitchSection
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableDeclaration
ActiproSoftware.Text.Languages.Python.Ast.ImplementationArgument
ActiproSoftware.Text.Languages.Python.Ast.ImplementationCompilationUnit
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionClauseBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDecorator
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationIfStatementCondition
ActiproSoftware.Text.Languages.Python.Ast.ImplementationParameter
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSliceItem
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTryStatementExceptClause
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationCDataSection
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationComment
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationCompilationUnit
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationDeclaration
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElement
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementAttribute
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementContent
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationEndTag
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationProcessingInstruction


AstNodeBase Constructor

Initializes a new instance of the AstNodeBase class

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected AstNodeBase()
Protected Sub New
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase Properties

The AstNodeBase type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | Root | Gets the root IAstNode of this AST node hierarchy, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Children Property

AstNodeBaseChildren Property

Gets the list containing the child AST nodes of this AST node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Children { get; }
Public ReadOnly Property Children As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The list containing the child AST nodes of this AST node.

Implements

IAstNodeChildren
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.EndOffset Property

AstNodeBaseEndOffset Property

Gets or sets the end offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> EndOffset { get; set; }
Public Property EndOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The end offset of this AST node, if known.

Implements

IAstNodeEndOffset
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.HasChildren Property

AstNodeBaseHasChildren Property

Gets whether the AST node contains any child AST nodes.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasChildren { get; }
Public ReadOnly Property HasChildren As Boolean
    Get

Property Value

Type: Boolean
true if the AST node contains any child AST nodes; otherwise, false.

Implements

IAstNodeHasChildren
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Id Property

AstNodeBaseId Property

Gets an integer value that identifies the type of AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual int Id { get; }
Public Overridable ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
An integer value that identifies the type of AST node, if known.

Implements

IAstNodeId
Remarks
This class' default implementation always returns 0.
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Length Property

AstNodeBaseLength Property

Gets the character length of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The character length of this AST node, if known.

Implements

IAstNodeLength
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Parent Property

AstNodeBaseParent Property

Gets or sets the parent IAstNode of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNode Parent { get; set; }
Public Property Parent As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The parent IAstNode of this AST node, if known.

Implements

IAstNodeParent
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Root Property

AstNodeBaseRoot Property

Gets the root IAstNode of this AST node hierarchy, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNode Root { get; }
Public ReadOnly Property Root As IAstNode
    Get

Property Value

Type: IAstNode
The root IAstNode of this AST node hierarchy, if known.
Remarks
The root node is found by walking up the Parent tree.
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.StartOffset Property

AstNodeBaseStartOffset Property

Gets or sets the start offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> StartOffset { get; set; }
Public Property StartOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The start offset of this AST node, if known.

Implements

IAstNodeStartOffset
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Value Property

AstNodeBaseValue Property

Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string Value { get; set; }
Public Overridable Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase Methods

The AstNodeBase type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Contains Method

AstNodeBaseContains Method

Returns whether the AST node contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the AST node contains the specified offset; otherwise, false.

Implements

IAstNodeContains(Int32)
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the AST node. This method also returns false if the AST node doesn't have known offsets.
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.FindChildNode Method

AstNodeBaseFindChildNode Method

Searches through the child nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNode FindChildNode(
    int offset
)
Public Function FindChildNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The child IAstNode that contains the specified offset, if any.

Implements

IAstNodeFindChildNode(Int32)
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.FindDescendantNode Method

AstNodeBaseFindDescendantNode Method

Recursively searches through the descendant nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNode FindDescendantNode(
    int offset
)
Public Function FindDescendantNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The descendant IAstNode that contains the specified offset, if any.

Implements

IAstNodeFindDescendantNode(Int32)
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.GetChildrenEnumerator Method

AstNodeBaseGetChildrenEnumerator Method

Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overridable Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.ToString Method

AstNodeBaseToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.ToTreeString Method

AstNodeBaseToTreeString Method

Outputs the contents of the AST node in tree form.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ToTreeString(
    int indentLevel
)
Public Function ToTreeString (
    indentLevel As Integer
) As String

Parameters

indentLevel
Type: SystemInt32
The indentation level.

Return Value

Type: String
A string containing the tree form of the AST node.

Implements

IAstNodeToTreeString(Int32)
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase Class

Represents an abstract base class for an object that provides static IDs for the AST nodes of an ISyntaxLanguage.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDotNetAstNodeId
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationJavaScriptAstNodeId
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPythonAstNodeId
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationXmlAstNodeId

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class AstNodeIdProviderBase : IIdProvider,
    IAstNodeIdProvider
Public MustInherit Class AstNodeIdProviderBase
    Implements IIdProvider, IAstNodeIdProvider

The AstNodeIdProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AstNodeIdProviderBase | Initializes a new instance of the AstNodeIdProviderBase class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase Constructor

Initializes a new instance of the AstNodeIdProviderBase class

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected AstNodeIdProviderBase()
Protected Sub New
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase Properties

The AstNodeIdProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.MaxId Property

AstNodeIdProviderBaseMaxId Property

Gets the maximum ID returned by this provider.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract int MaxId { get; }
Public MustOverride ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.MinId Property

AstNodeIdProviderBaseMinId Property

Gets the minimum ID returned by this provider.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract int MinId { get; }
Public MustOverride ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase Methods

The AstNodeIdProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.ContainsId Method

AstNodeIdProviderBaseContainsId Method

Returns whether the specified ID value is valid for this ID provider.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract bool ContainsId(
    int id
)
Public MustOverride Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.GetDescription Method

AstNodeIdProviderBaseGetDescription Method

Returns the actual string representation for the specified ID.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract string GetDescription(
    int id
)
Public MustOverride Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The actual string representation for the specified ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.GetKey Method

AstNodeIdProviderBaseGetKey Method

Returns the string-based key for the specified ID.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract string GetKey(
    int id
)
Public MustOverride Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The string-based key for the specified ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode Class

Represents an AST (abstract syntax tree) node implementation that has a string value and optional child nodes.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationDefaultAstNode

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DefaultAstNode : IAstNode
Public Class DefaultAstNode
    Implements IAstNode

The DefaultAstNode type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultAstNode | Initializes a new instance of the DefaultAstNode class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode Constructor

Initializes a new instance of the DefaultAstNode class

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DefaultAstNode()
Public Sub New
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode Properties

The DefaultAstNode type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Children Property

DefaultAstNodeChildren Property

Gets the list containing the child AST nodes of this AST node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IAstNode> Children { get; }
Public ReadOnly Property Children As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The list containing the child AST nodes of this AST node.

Implements

IAstNodeChildren
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.EndOffset Property

DefaultAstNodeEndOffset Property

Gets or sets the end offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> EndOffset { get; set; }
Public Property EndOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The end offset of this AST node, if known.

Implements

IAstNodeEndOffset
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.HasChildren Property

DefaultAstNodeHasChildren Property

Gets whether the AST node contains any child AST nodes.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasChildren { get; }
Public ReadOnly Property HasChildren As Boolean
    Get

Property Value

Type: Boolean
true if the AST node contains any child AST nodes; otherwise, false.

Implements

IAstNodeHasChildren
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Id Property

DefaultAstNodeId Property

Gets an integer value that identifies the type of AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual int Id { get; }
Public Overridable ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
An integer value that identifies the type of AST node, if known.

Implements

IAstNodeId
Remarks
This class' default implementation always returns 0.
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Length Property

DefaultAstNodeLength Property

Gets the character length of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The character length of this AST node, if known.

Implements

IAstNodeLength
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Parent Property

DefaultAstNodeParent Property

Gets or sets the parent IAstNode of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNode Parent { get; set; }
Public Property Parent As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The parent IAstNode of this AST node, if known.

Implements

IAstNodeParent
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.StartOffset Property

DefaultAstNodeStartOffset Property

Gets or sets the start offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> StartOffset { get; set; }
Public Property StartOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The start offset of this AST node, if known.

Implements

IAstNodeStartOffset
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Value Property

DefaultAstNodeValue Property

Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode Methods

The DefaultAstNode type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Contains Method

DefaultAstNodeContains Method

Returns whether the AST node contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the AST node contains the specified offset; otherwise, false.

Implements

IAstNodeContains(Int32)
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the AST node. This method also returns false if the AST node doesn't have known offsets.
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.FindChildNode Method

DefaultAstNodeFindChildNode Method

Searches through the child nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNode FindChildNode(
    int offset
)
Public Function FindChildNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The child IAstNode that contains the specified offset, if any.

Implements

IAstNodeFindChildNode(Int32)
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.FindDescendantNode Method

DefaultAstNodeFindDescendantNode Method

Recursively searches through the descendant nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNode FindDescendantNode(
    int offset
)
Public Function FindDescendantNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The descendant IAstNode that contains the specified offset, if any.

Implements

IAstNodeFindDescendantNode(Int32)
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.ToString Method

DefaultAstNodeToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.ToTreeString Method

DefaultAstNodeToTreeString Method

Outputs the contents of the AST node in tree form.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ToTreeString(
    int indentLevel
)
Public Function ToTreeString (
    indentLevel As Integer
) As String

Parameters

indentLevel
Type: SystemInt32
The indentation level.

Return Value

Type: String
A string containing the tree form of the AST node.

Implements

IAstNodeToTreeString(Int32)
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


IronyParser Class

Represents an IParser (syntax/semantic analyzer) implementation that can be used to call an Irony Parser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.ImplementationIronyParser

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Addons.Irony.Wpf (in ActiproSoftware.Text.Addons.Irony.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class IronyParser : ParserBase
Public Class IronyParser
    Inherits ParserBase

The IronyParser type exposes the following members.

Constructors
 | Name | Description
Public method | IronyParser | Initializes a new instance of the IronyParser class.
Top
Properties
 | Name | Description
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Public property | Parser | Gets the Irony parser that is used by this class.
Top
Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Overrides ParserBaseParse(IParseRequest).)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


IronyParser Constructor

Initializes a new instance of the IronyParser class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Addons.Irony.Wpf (in ActiproSoftware.Text.Addons.Irony.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IronyParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: Grammar
The Irony Grammar to use.
See Also

Reference

IronyParser Class
ActiproSoftware.Text.Parsing.Implementation Namespace


IronyParser Properties

The IronyParser type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Public property | Parser | Gets the Irony parser that is used by this class.
Top
See Also

Reference

IronyParser Class
ActiproSoftware.Text.Parsing.Implementation Namespace


IronyParser.Parser Property

IronyParserParser Property

Gets the Irony parser that is used by this class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Addons.Irony.Wpf (in ActiproSoftware.Text.Addons.Irony.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Parser Parser { get; }
Public ReadOnly Property Parser As Parser
    Get

Property Value

Type: Parser
The Irony parser that is used by this class.
See Also

Reference

IronyParser Class
ActiproSoftware.Text.Parsing.Implementation Namespace


IronyParser Methods

The IronyParser type exposes the following members.

Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Overrides ParserBaseParse(IParseRequest).)
Top
See Also

Reference

IronyParser Class
ActiproSoftware.Text.Parsing.Implementation Namespace


IronyParser.Parse Method

IronyParserParse Method

Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Addons.Irony.Wpf (in ActiproSoftware.Text.Addons.Irony.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IParseData Parse(
    IParseRequest request
)
Public Overrides Function Parse (
    request As IParseRequest
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.

Return Value

Type: IParseData
An IParseData that is the result of the parsing operation.

Implements

IParserParse(IParseRequest)
Remarks
A IParseRequestDispatcher typically calls this method when a queued parse request is ready to be processed.
See Also

Reference

IronyParser Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Class

Represents an object that indicates a message, warning or error related to parsing.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParseError

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParseError : IParseError
Public Class ParseError
    Implements IParseError

The ParseError type exposes the following members.

Constructors
 | Name | Description
Public method | ParseError | Initializes a new instance of the ParseError class.
Public method | ParseError(ParseErrorLevel, String, TextPositionRange) | Initializes a new instance of the ParseError class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the optional IClassificationType associated with the error.
Public property | Description | Gets or sets the description of the error, which is displayed in the user interface.
Public property | Level | Gets or sets a ParseErrorLevel indicating the error level.
Public property | PositionRange | Gets or sets the TextPositionRange of the error.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Constructor

Overload List
 | Name | Description
Public method | ParseError | Initializes a new instance of the ParseError class.
Public method | ParseError(ParseErrorLevel, String, TextPositionRange) | Initializes a new instance of the ParseError class.
Top
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Constructor

Initializes a new instance of the ParseError class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParseError()
Public Sub New
See Also

Reference

ParseError Class
ParseError Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Constructor (ParseErrorLevel, String, TextPositionRange)

Initializes a new instance of the ParseError class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParseError(
    ParseErrorLevel level,
    string description,
    TextPositionRange positionRange
)
Public Sub New (
    level As ParseErrorLevel,
    description As String,
    positionRange As TextPositionRange
)

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange of the error.
See Also

Reference

ParseError Class
ParseError Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Properties

The ParseError type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the optional IClassificationType associated with the error.
Public property | Description | Gets or sets the description of the error, which is displayed in the user interface.
Public property | Level | Gets or sets a ParseErrorLevel indicating the error level.
Public property | PositionRange | Gets or sets the TextPositionRange of the error.
Top
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.ClassificationType Property

ParseErrorClassificationType Property

Gets or sets the optional IClassificationType associated with the error.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The optional IClassificationType associated with the error.

Implements

IParseErrorClassificationType
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.Description Property

ParseErrorDescription Property

Gets or sets the description of the error, which is displayed in the user interface.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the error, which is displayed in the user interface.

Implements

IParseErrorDescription
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.Level Property

ParseErrorLevel Property

Gets or sets a ParseErrorLevel indicating the error level.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParseErrorLevel Level { get; set; }
Public Property Level As ParseErrorLevel
    Get
    Set

Property Value

Type: ParseErrorLevel
A ParseErrorLevel indicating the error level.

Implements

IParseErrorLevel
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.PositionRange Property

ParseErrorPositionRange Property

Gets or sets the TextPositionRange of the error.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPositionRange PositionRange { get; set; }
Public Property PositionRange As TextPositionRange
    Get
    Set

Property Value

Type: TextPositionRange
The TextPositionRange of the error.

Implements

IParseErrorPositionRange
Remarks
If no text position data is available for the error, the value should be TextPositionRange.Empty.
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Methods

The ParseError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.Equals Method

ParseErrorEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.GetHashCode Method

ParseErrorGetHashCode Method

Serves as a hash function for a particular type.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.ToString Method

ParseErrorToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase Class

Represents the base implementation of a parser (syntax/semantic analyzer) for a language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.ImplementationAntlrParser
ActiproSoftware.Text.Parsing.ImplementationIronyParser
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class ParserBase : IKeyedObject,
    IParser
Public MustInherit Class ParserBase
    Implements IKeyedObject, IParser

The ParserBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ParserBase | Initializes a new instance of the ParserBase class.
Top
Properties
 | Name | Description
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name.
Top
Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase Constructor

Initializes a new instance of the ParserBase class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ParserBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the parser.
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase Properties

The ParserBase type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name.
Top
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase.Key Property

ParserBaseKey Property

Gets or sets a string that identifies the parser, generally the related language name.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; protected set; }
Public Property Key As String
    Get
    Protected Set

Property Value

Type: String
A string that identifies the parser, generally the related language name.

Implements

IKeyedObjectKey
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase Methods

The ParserBase type exposes the following members.

Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.
Top
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase.Parse Method

ParserBaseParse Method

Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract IParseData Parse(
    IParseRequest request
)
Public MustOverride Function Parse (
    request As IParseRequest
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.

Return Value

Type: IParseData
An IParseData that is the result of the parsing operation.

Implements

IParserParse(IParseRequest)
Remarks
A IParseRequestDispatcher typically calls this method when a queued parse request is ready to be processed.
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Class

Represents a request for a parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParseRequest

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParseRequest : IParseRequest
Public Class ParseRequest
    Implements IParseRequest

The ParseRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ParseRequest(String, ITextBufferReader, ISyntaxLanguage, IParseTarget) | Initializes a new instance of the ParseRequest class.
Public method | ParseRequest(String, ITextBufferReader, IParser, IParseTarget) | Initializes a new instance of the ParseRequest class.
Top
Properties
 | Name | Description
Public property | CreatedDateTime | Gets the DateTime at which the parse request was created.
Public property | Language | Gets the ISyntaxLanguage for which this parse request was created.
Public property | ParseHashKey | Gets a hash key that uniquely identifies the parse request for a source/target combination.
Public property | Parser | Gets the IParser that will perform the parsing operation.
Public property | Priority | Gets or sets an integer value describing the priority of the request, where a higher number has a higher priority.
Public property | RepeatedRequestPause | Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.
Public property | Snapshot | Gets or sets the ITextSnapshot, if available, for which the parse request was created.
Public property | SourceKey | Gets a text key, typically a filename, that uniquely identifies the text to parse.
Public property | State | Gets or sets the current state of the request.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Target | Gets the IParseTarget that will be notified once the parsing operation is complete.
Public property | TextBufferReader | Gets the ITextBufferReader used to read the text that should be parsed.
Top
Methods
Name | Description
GetParseHashKey | Returns the ParseHashKey to use for the specified ICodeDocument.
Top
Fields
Name | Description
HighPriority | Specifies a high priority.
LowPriority | Specifies a low priority.
MediumPriority | Specifies a medium priority.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Constructor

Overload List
 | Name | Description
Public method | ParseRequest(String, ITextBufferReader, ISyntaxLanguage, IParseTarget) | Initializes a new instance of the ParseRequest class.
Public method | ParseRequest(String, ITextBufferReader, IParser, IParseTarget) | Initializes a new instance of the ParseRequest class.
Top
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Constructor (String, ITextBufferReader, ISyntaxLanguage, IParseTarget)

Initializes a new instance of the ParseRequest class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParseRequest(
    string sourceKey,
    ITextBufferReader textBufferReader,
    ISyntaxLanguage language,
    IParseTarget parseTarget
)
Public Sub New (
    sourceKey As String,
    textBufferReader As ITextBufferReader,
    language As ISyntaxLanguage,
    parseTarget As IParseTarget
)

Parameters

sourceKey
Type: SystemString
A text key, typically a filename, that uniquely identifies the text to parse.
textBufferReader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that contains the text to parse.
language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage for which this parse request was created.
parseTarget
Type: ActiproSoftware.Text.ParsingIParseTarget
An IParseTarget indicating the object that will receive the results of the parse.
See Also

Reference

ParseRequest Class
ParseRequest Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Constructor (String, ITextBufferReader, IParser, IParseTarget)

Initializes a new instance of the ParseRequest class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParseRequest(
    string sourceKey,
    ITextBufferReader textBufferReader,
    IParser parser,
    IParseTarget parseTarget
)
Public Sub New (
    sourceKey As String,
    textBufferReader As ITextBufferReader,
    parser As IParser,
    parseTarget As IParseTarget
)

Parameters

sourceKey
Type: SystemString
A text key, typically a filename, that uniquely identifies the text to parse.
textBufferReader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that contains the text to parse.
parser
Type: ActiproSoftware.Text.ParsingIParser
The IParser that will perform the parsing operation.
parseTarget
Type: ActiproSoftware.Text.ParsingIParseTarget
An IParseTarget indicating the object that will receive the results of the parse.
See Also

Reference

ParseRequest Class
ParseRequest Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Properties

The ParseRequest type exposes the following members.

Properties
 | Name | Description
Public property | CreatedDateTime | Gets the DateTime at which the parse request was created.
Public property | Language | Gets the ISyntaxLanguage for which this parse request was created.
Public property | ParseHashKey | Gets a hash key that uniquely identifies the parse request for a source/target combination.
Public property | Parser | Gets the IParser that will perform the parsing operation.
Public property | Priority | Gets or sets an integer value describing the priority of the request, where a higher number has a higher priority.
Public property | RepeatedRequestPause | Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.
Public property | Snapshot | Gets or sets the ITextSnapshot, if available, for which the parse request was created.
Public property | SourceKey | Gets a text key, typically a filename, that uniquely identifies the text to parse.
Public property | State | Gets or sets the current state of the request.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Target | Gets the IParseTarget that will be notified once the parsing operation is complete.
Public property | TextBufferReader | Gets the ITextBufferReader used to read the text that should be parsed.
Top
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.CreatedDateTime Property

ParseRequestCreatedDateTime Property

Gets the DateTime at which the parse request was created.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime CreatedDateTime { get; }
Public ReadOnly Property CreatedDateTime As DateTime
    Get

Property Value

Type: DateTime
The DateTime at which the parse request was created.

Implements

IParseRequestCreatedDateTime
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Language Property

ParseRequestLanguage Property

Gets the ISyntaxLanguage for which this parse request was created.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISyntaxLanguage Language { get; }
Public ReadOnly Property Language As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage for which this parse request was created.

Implements

IParseRequestLanguage
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.ParseHashKey Property

ParseRequestParseHashKey Property

Gets a hash key that uniquely identifies the parse request for a source/target combination.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ParseHashKey { get; }
Public ReadOnly Property ParseHashKey As String
    Get

Property Value

Type: String
A hash key that uniquely identifies the parse request for a source/target combination.

Implements

IParseRequestParseHashKey
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Parser Property

ParseRequestParser Property

Gets the IParser that will perform the parsing operation.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParser Parser { get; }
Public ReadOnly Property Parser As IParser
    Get

Property Value

Type: IParser
The IParser that will perform the parsing operation.

Implements

IParseRequestParser
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Priority Property

ParseRequestPriority Property

Gets or sets an integer value describing the priority of the request, where a higher number has a higher priority.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Priority { get; set; }
Public Property Priority As Integer
    Get
    Set

Property Value

Type: Int32
An integer value describing the priority of the request, where a higher number has a higher priority. The default value is ParseRequest.MediumPriority.

Implements

IParseRequestPriority
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.RepeatedRequestPause Property

ParseRequestRepeatedRequestPause Property

Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int RepeatedRequestPause { get; set; }
Public Property RepeatedRequestPause As Integer
    Get
    Set

Property Value

Type: Int32
The number of milliseconds to pause if there are repeated attempts for this same request. The default value is 250.

Implements

IParseRequestRepeatedRequestPause
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Snapshot Property

ParseRequestSnapshot Property

Gets or sets the ITextSnapshot, if available, for which the parse request was created.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; set; }
Public Property Snapshot As ITextSnapshot
    Get
    Set

Property Value

Type: ITextSnapshot
The ITextSnapshot, if available, for which the parse request was created.

Implements

IParseRequestSnapshot
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.SourceKey Property

ParseRequestSourceKey Property

Gets a text key, typically a filename, that uniquely identifies the text to parse.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string SourceKey { get; }
Public ReadOnly Property SourceKey As String
    Get

Property Value

Type: String
A text key, typically a filename, that uniquely identifies the text to parse.

Implements

IParseRequestSourceKey
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.State Property

ParseRequestState Property

Gets or sets the current state of the request.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParseRequestState State { get; set; }
Public Property State As ParseRequestState
    Get
    Set

Property Value

Type: ParseRequestState
The current state of the request.

Implements

IParseRequestState
Remarks
This property should only be set by a IParseRequestDispatcher.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Tag Property

ParseRequestTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the control. The default is .

Implements

IParseRequestTag
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Target Property

ParseRequestTarget Property

Gets the IParseTarget that will be notified once the parsing operation is complete.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseTarget Target { get; }
Public ReadOnly Property Target As IParseTarget
    Get

Property Value

Type: IParseTarget
The IParseTarget that will be notified once the parsing operation is complete.

Implements

IParseRequestTarget
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.TextBufferReader Property

ParseRequestTextBufferReader Property

Gets the ITextBufferReader used to read the text that should be parsed.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextBufferReader TextBufferReader { get; }
Public ReadOnly Property TextBufferReader As ITextBufferReader
    Get

Property Value

Type: ITextBufferReader
The ITextBufferReader used to read the text that should be parsed.

Implements

IParseRequestTextBufferReader
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Methods

The ParseRequest type exposes the following members.

Methods
Name | Description
GetParseHashKey | Returns the ParseHashKey to use for the specified ICodeDocument.
Top
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.GetParseHashKey Method

ParseRequestGetParseHashKey Method

Returns the ParseHashKey to use for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string GetParseHashKey(
    ICodeDocument document
)
Public Shared Function GetParseHashKey (
    document As ICodeDocument
) As String

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument to examine.

Return Value

Type: String
The ParseHashKey to use for the specified ICodeDocument.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Fields

The ParseRequest type exposes the following members.

Fields
Name | Description
HighPriority | Specifies a high priority.
LowPriority | Specifies a low priority.
MediumPriority | Specifies a medium priority.
Top
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.HighPriority Field

ParseRequestHighPriority Field

Specifies a high priority.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int HighPriority = 300
Public Const HighPriority As Integer = 300

Field Value

Type: Int32
The value is 300.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.LowPriority Field

ParseRequestLowPriority Field

Specifies a low priority.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int LowPriority = 100
Public Const LowPriority As Integer = 100

Field Value

Type: Int32
The value is 100.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.MediumPriority Field

ParseRequestMediumPriority Field

Specifies a medium priority.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const int MediumPriority = 200
Public Const MediumPriority As Integer = 200

Field Value

Type: Int32
The value is 200.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher Class

Implements an IParseRequestDispatcher that uses a worker thread to process parse requests.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityDisposableObject
ActiproSoftware.Text.Parsing.ImplementationThreadedParseRequestDispatcher

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ThreadedParseRequestDispatcher : DisposableObject,
    IParseRequestDispatcher
Public Class ThreadedParseRequestDispatcher
    Inherits DisposableObject
    Implements IParseRequestDispatcher

The ThreadedParseRequestDispatcher type exposes the following members.

Constructors
 | Name | Description
Public method | ThreadedParseRequestDispatcher | Initializes a new instance of the ThreadedParseRequestDispatcher class.
Public method | ThreadedParseRequestDispatcher(Int32) | Initializes a new instance of the ThreadedParseRequestDispatcher class.
Top
Properties
 | Name | Description
Public property | IsBusy | Gets whether the multi-threaded parser service is currently busy processing a request.
Public property | PendingRequestCount | Gets the number of pending requests remaining in the parse request queue.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetPendingRequests | Gets an array of the pending requests in the parse request queue.
Public method | HasPendingRequest | Returns whether there is currently a pending request with the specified hash key.
Public method | QueueRequest | Adds an IParseRequest to the queue of pending requests.
Public method | RemovePendingRequests | Removes any pending requests in the parse request queue that have the specified hash key.
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher Constructor

Overload List
 | Name | Description
Public method | ThreadedParseRequestDispatcher | Initializes a new instance of the ThreadedParseRequestDispatcher class.
Public method | ThreadedParseRequestDispatcher(Int32) | Initializes a new instance of the ThreadedParseRequestDispatcher class.
Top
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher Constructor

Initializes a new instance of the ThreadedParseRequestDispatcher class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ThreadedParseRequestDispatcher()
Public Sub New
See Also

Reference

ThreadedParseRequestDispatcher Class
ThreadedParseRequestDispatcher Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher Constructor (Int32)

Initializes a new instance of the ThreadedParseRequestDispatcher class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ThreadedParseRequestDispatcher(
    int maxThreadCount
)
Public Sub New (
    maxThreadCount As Integer
)

Parameters

maxThreadCount
Type: SystemInt32
The maximum number of worker threads to use. Must be at least 1, and should not generally exceed the number of processor cores in the machine.
See Also

Reference

ThreadedParseRequestDispatcher Class
ThreadedParseRequestDispatcher Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher Properties

The ThreadedParseRequestDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | IsBusy | Gets whether the multi-threaded parser service is currently busy processing a request.
Public property | PendingRequestCount | Gets the number of pending requests remaining in the parse request queue.
Top
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.IsBusy Property

ThreadedParseRequestDispatcherIsBusy Property

Gets whether the multi-threaded parser service is currently busy processing a request.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsBusy { get; }
Public ReadOnly Property IsBusy As Boolean
    Get

Property Value

Type: Boolean
true if the multi-threaded parser service is currently busy processing a request; otherwise, false.

Implements

IParseRequestDispatcherIsBusy
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.PendingRequestCount Property

ThreadedParseRequestDispatcherPendingRequestCount Property

Gets the number of pending requests remaining in the parse request queue.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int PendingRequestCount { get; }
Public ReadOnly Property PendingRequestCount As Integer
    Get

Property Value

Type: Int32
The number of pending requests remaining in the parse request queue.

Implements

IParseRequestDispatcherPendingRequestCount
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher Methods

The ThreadedParseRequestDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetPendingRequests | Gets an array of the pending requests in the parse request queue.
Public method | HasPendingRequest | Returns whether there is currently a pending request with the specified hash key.
Public method | QueueRequest | Adds an IParseRequest to the queue of pending requests.
Public method | RemovePendingRequests | Removes any pending requests in the parse request queue that have the specified hash key.
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.Dispose Method

ThreadedParseRequestDispatcherDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Top
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.Dispose Method (Boolean)

ThreadedParseRequestDispatcherDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

ThreadedParseRequestDispatcher Class
Dispose Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.GetPendingRequests Method

ThreadedParseRequestDispatcherGetPendingRequests Method

Gets an array of the pending requests in the parse request queue.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseRequest[] GetPendingRequests()
Public Function GetPendingRequests As IParseRequest()

Field Value

Type: IParseRequest
An array of the pending requests in the parse request queue.

Return Value

Type: IParseRequest

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.Implementation.ThreadedParseRequestDispatcher.GetPendingRequests"]

Implements

IParseRequestDispatcherGetPendingRequests
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.HasPendingRequest Method

ThreadedParseRequestDispatcherHasPendingRequest Method

Returns whether there is currently a pending request with the specified hash key.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasPendingRequest(
    string parseHashKey
)
Public Function HasPendingRequest (
    parseHashKey As String
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to search.

Return Value

Type: Boolean
true if there is currently a pending request with the specified hash key; otherwise, false.

Implements

IParseRequestDispatcherHasPendingRequest(String)
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.QueueRequest Method

ThreadedParseRequestDispatcherQueueRequest Method

Adds an IParseRequest to the queue of pending requests.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void QueueRequest(
    IParseRequest request
)
Public Sub QueueRequest (
    request As IParseRequest
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that should be processed.

Implements

IParseRequestDispatcherQueueRequest(IParseRequest)
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.RemovePendingRequests Method

ThreadedParseRequestDispatcherRemovePendingRequests Method

Removes any pending requests in the parse request queue that have the specified hash key.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int RemovePendingRequests(
    string parseHashKey
)
Public Function RemovePendingRequests (
    parseHashKey As String
) As Integer

Parameters

parseHashKey
Type: SystemString
The parse hash key for which to search.

Return Value

Type: Int32
The number of pending requests that were removed.

Implements

IParseRequestDispatcherRemovePendingRequests(String)
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.WaitForParse Method

ThreadedParseRequestDispatcherWaitForParse Method

Overload List
 | Name | Description
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

ThreadedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.WaitForParse Method (String)

ThreadedParseRequestDispatcherWaitForParse Method (String)

Waits a maximum of 250 milliseconds for the specified request to complete.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool WaitForParse(
    string parseHashKey
)
Public Function WaitForParse (
    parseHashKey As String
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to wait.

Return Value

Type: Boolean
true if a wait occurred; otherwise, false.

Implements

IParseRequestDispatcherWaitForParse(String)
See Also

Reference

ThreadedParseRequestDispatcher Class
WaitForParse Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ThreadedParseRequestDispatcher.WaitForParse Method (String, Int32)

ThreadedParseRequestDispatcherWaitForParse Method (String, Int32)

Waits for the specified request to complete, up to a maximum number of milliseconds.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool WaitForParse(
    string parseHashKey,
    int maximumWaitTime
)
Public Function WaitForParse (
    parseHashKey As String,
    maximumWaitTime As Integer
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to wait.
maximumWaitTime
Type: SystemInt32
The maximum wait time in milliseconds.

Return Value

Type: Boolean
true if a wait occurred; otherwise, false.

Implements

IParseRequestDispatcherWaitForParse(String, Int32)
See Also

Reference

ThreadedParseRequestDispatcher Class
WaitForParse Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ActiproSoftware.Text.Parsing.LLParser Namespace

Contains types related to the creation of an LL parser.
Classes
 | Class | Description
Public class | InvalidGrammarException | An exception that is thrown when a grammar is invalid.
Public class | ParserErrorResults | Provides access to the built-in IParserErrorResult instances, that indicate a result provided by a ParserErrorCallback.
Interfaces
 | Interface | Description
Public interface | IAstNodeBuilder | Provides the base requirements for an object that constructs an AST (abstract syntax tree).
Public interface | IAstNodeMatch | Provides the base requirements for an IAstNode match made within the current IAstNodeBuilder scope.
Public interface | IAstNodeMatchCollection | Provides the base requirements for a collection of IAstNodeMatch objects.
Public interface | ILLParseData | Provides the base requirements for an object that stores the results of a ILLParser parsing operation.
Public interface | ILLParser | Provides the base requirements of an IParser that executes based on a Grammar definition.
Public interface | IMatchCondition | Provides the base requirements for a match condition for an EbnfTerm.
Public interface | IParserErrorResult | Provides the base requirements for the result provided by a ParserErrorCallback.
Public interface | IParserState | Provides the base requirements for an object that tracks the current state of a ILLParser.
Public interface | ITokenReader | Provides the base requirements for an object that can provide tokens to a ILLParser in a forward-only direction.
Public interface | ITreeConstructionNode | Provides the base requirements for tree construction node, used to output an IAstNode for an EbnfProduction.
Public interface | ITypedTreeConstructionNodeTAstNode | Provides the base requirements for tree construction node, used to output a specific type of IAstNode for an EbnfProduction.
Delegates
 | Delegate | Description
Public delegate | ParserCallback | Defines a callback method that can be executed during a parsing operation.
Public delegate | ParserCanMatchCallback | Defines a can-match callback method that can be executed during a parsing operation for a NonTerminal.
Public delegate | ParserErrorCallback | Defines an error callback method that can be executed during a parsing operation.


IAstNodeBuilder Interface

Provides the base requirements for an object that constructs an AST (abstract syntax tree).

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAstNodeBuilder
Public Interface IAstNodeBuilder

The IAstNodeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Matches | Gets the list of IAstNodeMatch objects that indicate the labeled IAstNode matches for the current IAstNodeBuilder scope.
Public property | RootNode | Gets the root IAstNode that has been constructed.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeBuilder Properties

The IAstNodeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Matches | Gets the list of IAstNodeMatch objects that indicate the labeled IAstNode matches for the current IAstNodeBuilder scope.
Public property | RootNode | Gets the root IAstNode that has been constructed.
Top
See Also

Reference

IAstNodeBuilder Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeBuilder.Matches Property

IAstNodeBuilderMatches Property

Gets the list of IAstNodeMatch objects that indicate the labeled IAstNode matches for the current IAstNodeBuilder scope.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNodeMatchCollection Matches { get; }
ReadOnly Property Matches As IAstNodeMatchCollection
    Get

Property Value

Type: IAstNodeMatchCollection
The list of IAstNodeMatch objects that indicate the labeled IAstNode matches for the current IAstNodeBuilder scope.
See Also

Reference

IAstNodeBuilder Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeBuilder.RootNode Property

IAstNodeBuilderRootNode Property

Gets the root IAstNode that has been constructed.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode RootNode { get; }
ReadOnly Property RootNode As IAstNode
    Get

Property Value

Type: IAstNode
The root IAstNode that has been constructed.
See Also

Reference

IAstNodeBuilder Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatch Interface

Provides the base requirements for an IAstNode match made within the current IAstNodeBuilder scope.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAstNodeMatch
Public Interface IAstNodeMatch

The IAstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets or sets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets or sets the IAstNode that was matched.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatch Properties

The IAstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets or sets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets or sets the IAstNode that was matched.
Top
See Also

Reference

IAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatch.Label Property

IAstNodeMatchLabel Property

Gets or sets the optional label applied to the match that can be used for identification during tree construction.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Label { get; set; }
Property Label As String
    Get
    Set

Property Value

Type: String
The optional label applied to the match that can be used for identification during tree construction.
See Also

Reference

IAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatch.Node Property

IAstNodeMatchNode Property

Gets or sets the IAstNode that was matched.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode Node { get; set; }
Property Node As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The IAstNode that was matched.
See Also

Reference

IAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection Interface

Provides the base requirements for a collection of IAstNodeMatch objects.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IAstNodeMatchCollection : IList<IAstNodeMatch>,
    ICollection<IAstNodeMatch>, IEnumerable<IAstNodeMatch>, IEnumerable
Public Interface IAstNodeMatchCollection
    Inherits IList(Of IAstNodeMatch), ICollection(Of IAstNodeMatch),
    IEnumerable(Of IAstNodeMatch), IEnumerable

The IAstNodeMatchCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IAstNodeMatch .)
Public property | EndOffset | Gets the end offset of this match collection.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IAstNodeMatch .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IAstNodeMatch .)
Public property | StartOffset | Gets the end offset of this match collection.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IAstNodeMatch .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IAstNodeMatch .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IAstNodeMatch .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IAstNodeMatch .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IAstNodeMatch .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IAstNodeMatch .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IAstNodeMatch .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IAstNodeMatch .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IAstNodeMatch .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIAstNodeMatch | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIAstNodeMatch | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIAstNodeMatch | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection Properties

The IAstNodeMatchCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IAstNodeMatch .)
Public property | EndOffset | Gets the end offset of this match collection.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IAstNodeMatch .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IAstNodeMatch .)
Public property | StartOffset | Gets the end offset of this match collection.
Top
See Also

Reference

IAstNodeMatchCollection Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection.EndOffset Property

IAstNodeMatchCollectionEndOffset Property

Gets the end offset of this match collection.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int EndOffset { get; }
ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The end offset of this match collection.
See Also

Reference

IAstNodeMatchCollection Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection.StartOffset Property

IAstNodeMatchCollectionStartOffset Property

Gets the end offset of this match collection.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int StartOffset { get; }
ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The end offset of this match collection.
See Also

Reference

IAstNodeMatchCollection Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection Methods

The IAstNodeMatchCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IAstNodeMatch .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IAstNodeMatch .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IAstNodeMatch .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IAstNodeMatch .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IAstNodeMatch .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IAstNodeMatch .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IAstNodeMatch .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IAstNodeMatch .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IAstNodeMatch .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIAstNodeMatch | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeIAstNodeMatch | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllIAstNodeMatch | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IAstNodeMatchCollection Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParseData Interface

Provides the base requirements for an object that stores the results of a ILLParser parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILLParseData : IParseData,
    IParseErrorProvider
Public Interface ILLParseData
    Inherits IParseData, IParseErrorProvider

The ILLParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result.
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParseData Properties

The ILLParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result.
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ILLParseData Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParseData.Ast Property

ILLParseDataAst Property

Gets the object that contains the abstract syntax tree result.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode Ast { get; }
ReadOnly Property Ast As IAstNode
    Get

Property Value

Type: IAstNode
The object that contains the abstract syntax tree result.
See Also

Reference

ILLParseData Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser Interface

Provides the base requirements of an IParser that executes based on a Grammar definition.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILLParser : IParser,
    IKeyedObject
Public Interface ILLParser
    Inherits IParser, IKeyedObject

The ILLParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
Methods
 | Name | Description
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens.
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from IParser.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser Properties

The ILLParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ILLParser Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser.Grammar Property

ILLParserGrammar Property

Gets the Grammar that is used by this parser.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Grammar Grammar { get; }
ReadOnly Property Grammar As Grammar
    Get

Property Value

Type: Grammar
The Grammar that is used by this parser.
See Also

Reference

ILLParser Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser Methods

The ILLParser type exposes the following members.

Methods
 | Name | Description
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens.
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from IParser.)
Top
See Also

Reference

ILLParser Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser.CreateTokenReader Method

ILLParserCreateTokenReader Method

Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.
See Also

Reference

ILLParser Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition Interface

Provides the base requirements for a match condition for an EbnfTerm.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IMatchCondition
Public Interface IMatchCondition

The IMatchCondition type exposes the following members.

Properties
 | Name | Description
Public property | CallbackCount | Gets the number of callbacks.
Top
Methods
 | Name | Description
Public method | GetFirstSet | Returns the collection of terminals that provide the first-set for the match condition.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition Properties

The IMatchCondition type exposes the following members.

Properties
 | Name | Description
Public property | CallbackCount | Gets the number of callbacks.
Top
See Also

Reference

IMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition.CallbackCount Property

IMatchConditionCallbackCount Property

Gets the number of callbacks.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int CallbackCount { get; }
ReadOnly Property CallbackCount As Integer
    Get

Property Value

Type: Int32
The number of callbacks.
See Also

Reference

IMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition Methods

The IMatchCondition type exposes the following members.

Methods
 | Name | Description
Public method | GetFirstSet | Returns the collection of terminals that provide the first-set for the match condition.
Top
See Also

Reference

IMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition.GetFirstSet Method

IMatchConditionGetFirstSet Method

Returns the collection of terminals that provide the first-set for the match condition.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<Terminal> GetFirstSet(
    Grammar grammar
)
Function GetFirstSet (
    grammar As Grammar
) As IEnumerable(Of Terminal)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar

[Missing <param name="grammar"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.IMatchCondition.GetFirstSet(ActiproSoftware.Text.Parsing.LLParser.Implementation.Grammar)"]

Return Value

Type: IEnumerable Terminal
The collection of terminals that provide the first-set for the match condition.
See Also

Reference

IMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Class

An exception that is thrown when a grammar is invalid.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.Text.Parsing.LLParserInvalidGrammarException

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InvalidGrammarException : Exception
<SerializableAttribute>
Public Class InvalidGrammarException
    Inherits Exception
Constructors
 | Name | Description
Public method | InvalidGrammarException | Initializes a new instance of the InvalidGrammarException class.
Public method | InvalidGrammarException(String) | Initializes a new instance of the InvalidGrammarException class with a specified error message.
Protected method | InvalidGrammarException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidGrammarException class with serialized data.
Public method | InvalidGrammarException(String, Exception) | Initializes a new instance of the InvalidGrammarException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Constructor

Overload List
 | Name | Description
Public method | InvalidGrammarException | Initializes a new instance of the InvalidGrammarException class.
Public method | InvalidGrammarException(String) | Initializes a new instance of the InvalidGrammarException class with a specified error message.
Protected method | InvalidGrammarException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidGrammarException class with serialized data.
Public method | InvalidGrammarException(String, Exception) | Initializes a new instance of the InvalidGrammarException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidGrammarException Class
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Constructor

Initializes a new instance of the InvalidGrammarException class.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidGrammarException()
Public Sub New
See Also

Reference

InvalidGrammarException Class
InvalidGrammarException Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Constructor (String)

Initializes a new instance of the InvalidGrammarException class with a specified error message.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidGrammarException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
See Also

Reference

InvalidGrammarException Class
InvalidGrammarException Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InvalidGrammarException class with serialized data.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected InvalidGrammarException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

InvalidGrammarException Class
InvalidGrammarException Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Constructor (String, Exception)

Initializes a new instance of the InvalidGrammarException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidGrammarException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception.
See Also

Reference

InvalidGrammarException Class
InvalidGrammarException Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserErrorResult Interface

Provides the base requirements for the result provided by a ParserErrorCallback.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParserErrorResult
Public Interface IParserErrorResult

The IParserErrorResult type exposes the following members.

Properties
 | Name | Description
Public property | CanContinue | Gets whether to continue parsing and put an error token in place of the term that errored.
Public property | CanReportError | Gets whether the error should still be reported when appropriate.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IParserErrorResult Properties

The IParserErrorResult type exposes the following members.

Properties
 | Name | Description
Public property | CanContinue | Gets whether to continue parsing and put an error token in place of the term that errored.
Public property | CanReportError | Gets whether the error should still be reported when appropriate.
Top
See Also

Reference

IParserErrorResult Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserErrorResult.CanContinue Property

IParserErrorResultCanContinue Property

Gets whether to continue parsing and put an error token in place of the term that errored.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanContinue { get; }
ReadOnly Property CanContinue As Boolean
    Get

Property Value

Type: Boolean
true if the parser should continue and put an error token in place of the term that errored; otherwise, false.
See Also

Reference

IParserErrorResult Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserErrorResult.CanReportError Property

IParserErrorResultCanReportError Property

Gets whether the error should still be reported when appropriate.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanReportError { get; }
ReadOnly Property CanReportError As Boolean
    Get

Property Value

Type: Boolean
true if the error should still be reported when appropriate; otherwise, false.
See Also

Reference

IParserErrorResult Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState Interface

Provides the base requirements for an object that tracks the current state of a ILLParser.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IParserState
Public Interface IParserState

The IParserState type exposes the following members.

Properties
 | Name | Description
Public property | AstNodeBuilder | Gets the IAstNodeBuilder to use for constructing AST node results.
Public property | CustomData | Gets or sets custom data that can be altered during a parsing operation.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | Parser | Gets the ILLParser for which this state is tracking data.
Public property | Snapshot | Gets the ITextSnapshot used to initiate the parsing operation, if known.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Public property | UntargetableParseErrorTokenIds | Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Top
Methods
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState Properties

The IParserState type exposes the following members.

Properties
 | Name | Description
Public property | AstNodeBuilder | Gets the IAstNodeBuilder to use for constructing AST node results.
Public property | CustomData | Gets or sets custom data that can be altered during a parsing operation.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | Parser | Gets the ILLParser for which this state is tracking data.
Public property | Snapshot | Gets the ITextSnapshot used to initiate the parsing operation, if known.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Public property | UntargetableParseErrorTokenIds | Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.AstNodeBuilder Property

IParserStateAstNodeBuilder Property

Gets the IAstNodeBuilder to use for constructing AST node results.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNodeBuilder AstNodeBuilder { get; }
ReadOnly Property AstNodeBuilder As IAstNodeBuilder
    Get

Property Value

Type: IAstNodeBuilder
The IAstNodeBuilder to use for constructing AST node results.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.CustomData Property

IParserStateCustomData Property

Gets or sets custom data that can be altered during a parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object CustomData { get; set; }
Property CustomData As Object
    Get
    Set

Property Value

Type: Object
Custom data that can be altered during a parsing operation.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ParseErrors Property

IParserStateParseErrors Property

Gets the collection of IParseError objects that will be returned in the IParseData parsing result.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<IParseError> ParseErrors { get; }
ReadOnly Property ParseErrors As IEnumerable(Of IParseError)
    Get

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that will be returned in the IParseData parsing result.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.Parser Property

IParserStateParser Property

Gets the ILLParser for which this state is tracking data.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ILLParser Parser { get; }
ReadOnly Property Parser As ILLParser
    Get

Property Value

Type: ILLParser
The ILLParser for which this state is tracking data
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.Snapshot Property

IParserStateSnapshot Property

Gets the ITextSnapshot used to initiate the parsing operation, if known.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot used to initiate the parsing operation, if known.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.TokenReader Property

IParserStateTokenReader Property

Gets the ITokenReader that is used to read tokens during the parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITokenReader TokenReader { get; }
ReadOnly Property TokenReader As ITokenReader
    Get

Property Value

Type: ITokenReader
The ITokenReader that is used to read tokens during the parsing operation.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.UntargetableParseErrorTokenIds Property

IParserStateUntargetableParseErrorTokenIds Property

Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<int> UntargetableParseErrorTokenIds { get; set; }
Property UntargetableParseErrorTokenIds As IEnumerable(Of Integer)
    Get
    Set

Property Value

Type: IEnumerable Int32
The collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Remarks
If a parse error is reported without a target token, the parser will normally place the parse error at the next token. If that token is one of the IDs found in this collection, the parse error will appear after the previous token instead. This property should be set to a collection of any IDs for visually-insignificant tokens that can be passed to the parser such as a line feed, line continuation, document end, etc.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState Methods

Methods
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportError Method

IParserStateReportError Method

Overload List
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportError Method (IParseError)

IParserStateReportError Method (IParseError)

Reports an IParseError.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void ReportError(
    IParseError parseError
)
Sub ReportError (
    parseError As IParseError
)

Parameters

parseError
Type: ActiproSoftware.Text.ParsingIParseError
The IParseError object that contains details about the error.
See Also

Reference

IParserState Interface
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportError Method (ParseErrorLevel, String)

IParserStateReportError Method (ParseErrorLevel, String)

Reports an IParseError, using the look-ahead token for its range.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseError ReportError(
    ParseErrorLevel level,
    string description
)
Function ReportError (
    level As ParseErrorLevel,
    description As String
) As IParseError

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportError Method (ParseErrorLevel, String, IToken)

IParserStateReportError Method (ParseErrorLevel, String, IToken)

Reports an IParseError, using the specified token for its range.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseError ReportError(
    ParseErrorLevel level,
    string description,
    IToken token
)
Function ReportError (
    level As ParseErrorLevel,
    description As String,
    token As IToken
) As IParseError

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine for the error range. If not passed, the look-ahead token is used.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportNonTerminalExpectedError Method

IParserStateReportNonTerminalExpectedError Method

Overload List
 | Name | Description
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportNonTerminalExpectedError Method (NonTerminal)

IParserStateReportNonTerminalExpectedError Method (NonTerminal)

Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal
)
Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportNonTerminalExpectedError Method (NonTerminal, IToken)

IParserStateReportNonTerminalExpectedError Method (NonTerminal, IToken)

Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal,
    IToken token
)
Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal,
    token As IToken
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken at which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportNonTerminalExpectedError Method (NonTerminal, TextPositionRange)

IParserStateReportNonTerminalExpectedError Method (NonTerminal, TextPositionRange)

Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal,
    TextPositionRange positionRange
)
Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal,
    positionRange As TextPositionRange
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange over which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportTerminalExpectedError Method

IParserStateReportTerminalExpectedError Method

Overload List
 | Name | Description
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportTerminalExpectedError Method (Terminal)

IParserStateReportTerminalExpectedError Method (Terminal)

Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseError ReportTerminalExpectedError(
    Terminal terminal
)
Function ReportTerminalExpectedError (
    terminal As Terminal
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportTerminalExpectedError Method (Terminal, IToken)

IParserStateReportTerminalExpectedError Method (Terminal, IToken)

Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseError ReportTerminalExpectedError(
    Terminal terminal,
    IToken token
)
Function ReportTerminalExpectedError (
    terminal As Terminal,
    token As IToken
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken at which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportTerminalExpectedError Method (Terminal, TextPositionRange)

IParserStateReportTerminalExpectedError Method (Terminal, TextPositionRange)

Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IParseError ReportTerminalExpectedError(
    Terminal terminal,
    TextPositionRange positionRange
)
Function ReportTerminalExpectedError (
    terminal As Terminal,
    positionRange As TextPositionRange
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange over which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader Interface

Provides the base requirements for an object that can provide tokens to a ILLParser in a forward-only direction.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITokenReader
Public Interface ITokenReader

The ITokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer.
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state.
Public property | LookAheadToken | Returns the IToken that is immediately after the current token.
Public property | Offset | Gets the current offset, which is offset after the last Token that was read.
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls.
Public property | Token | Gets the current IToken.
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken.
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs.
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token.
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends.
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state.
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader Properties

The ITokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer.
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state.
Public property | LookAheadToken | Returns the IToken that is immediately after the current token.
Public property | Offset | Gets the current offset, which is offset after the last Token that was read.
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls.
Public property | Token | Gets the current IToken.
Top
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.IsAtEnd Property

ITokenReaderIsAtEnd Property

Gets whether the current IToken is at the end of the text buffer.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAtEnd { get; }
ReadOnly Property IsAtEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current IToken is at the end of the text buffer; otherwise, false.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.IsParserInErrorState Property

ITokenReaderIsParserInErrorState Property

Gets or sets whether the parser is currently recovering from an error state.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsParserInErrorState { get; set; }
Property IsParserInErrorState As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the parser is currently recovering from an error state; otherwise, false.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.LookAheadToken Property

ITokenReaderLookAheadToken Property

Returns the IToken that is immediately after the current token.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken LookAheadToken { get; }
ReadOnly Property LookAheadToken As IToken
    Get

Property Value

Type: IToken
The IToken that is immediately after the current token.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Offset Property

ITokenReaderOffset Property

Gets the current offset, which is offset after the last Token that was read.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Offset { get; }
ReadOnly Property Offset As Integer
    Get

Property Value

Type: Int32
The current offset, which is offset after the last Token that was read.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.StackLevel Property

ITokenReaderStackLevel Property

Gets the current stack level from Push calls without corresponding Pop calls.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int StackLevel { get; }
ReadOnly Property StackLevel As Integer
    Get

Property Value

Type: Int32
The current stack level.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Token Property

ITokenReaderToken Property

Gets the current IToken.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken Token { get; }
ReadOnly Property Token As IToken
    Get

Property Value

Type: IToken
The current IToken.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader Methods

The ITokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken.
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs.
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token.
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends.
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state.
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Top
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Advance Method

ITokenReaderAdvance Method

Advances to the next IToken.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Advance()
Sub Advance
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.AdvanceTo Method

ITokenReaderAdvanceTo Method

Overload List
 | Name | Description
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Top
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.AdvanceTo Method (Int32)

ITokenReaderAdvanceTo Method (Int32)

Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AdvanceTo(
    int tokenId
)
Function AdvanceTo (
    tokenId As Integer
) As Boolean

Parameters

tokenId
Type: SystemInt32
The ID of IToken for which to search.

Return Value

Type: Boolean
true if an IToken was found before the end of document; otherwise, false.
Remarks
If this method is successful, the LookAheadToken will be the IToken that was located.
See Also

Reference

ITokenReader Interface
AdvanceTo Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.AdvanceTo Method (Int32[])

ITokenReaderAdvanceTo Method (Int32)

Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AdvanceTo(
    params int[] tokenIds
)
Function AdvanceTo (
    ParamArray tokenIds As Integer()
) As Boolean

Parameters

tokenIds
Type: SystemInt32
The array of IToken IDs for which to search.

Return Value

Type: Boolean
true if an IToken was found before the end of document; otherwise, false.
Remarks
If this method is successful, the LookAheadToken will be the IToken that was located.
See Also

Reference

ITokenReader Interface
AdvanceTo Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.AreNext Method

ITokenReaderAreNext Method

Returns whether the next look-ahead tokens match the specified sequence of token IDs.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AreNext(
    params int[] tokenIds
)
Function AreNext (
    ParamArray tokenIds As Integer()
) As Boolean

Parameters

tokenIds
Type: SystemInt32
The sequence of token IDs for which to search.

Return Value

Type: Boolean
true if the next look-ahead tokens match the specified sequence of token IDs; otherwise, false.
Remarks
This method is very useful within can-match callbacks that require two or more token look-aheads.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.GetLookAheadToken Method

ITokenReaderGetLookAheadToken Method

Returns the IToken that is the specified number of positions past the current token.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken GetLookAheadToken(
    int count
)
Function GetLookAheadToken (
    count As Integer
) As IToken

Parameters

count
Type: SystemInt32
The number of positions past the current token to examine.

Return Value

Type: IToken
The IToken that is the specified number of positions past the current token.
Remarks
A parameter value of 1 will return the value of the LookAheadToken method without actually seeking past the next token.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.GetTokenText Method

ITokenReaderGetTokenText Method

Returns an IToken's encapsulated text from the text buffer using Newline for line ends.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetTokenText(
    IToken targetToken
)
Function GetTokenText (
    targetToken As IToken
) As String

Parameters

targetToken
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: String
The IToken's encapsulated text from the text buffer using Newline for line ends.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Initialize Method

ITokenReaderInitialize Method

Initializes the token reader, which will be called by a ILLParser before the token reader is used.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Initialize()
Sub Initialize
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.OffsetToPosition Method

ITokenReaderOffsetToPosition Method

Returns the TextPosition that represents the specified offset within the text lines.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPosition OffsetToPosition(
    int offset
)
Function OffsetToPosition (
    offset As Integer
) As TextPosition

Parameters

offset
Type: SystemInt32
The offset of a character within the snapshot.

Return Value

Type: TextPosition
The TextPosition that represents the specified offset within the text lines.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Pop Method

ITokenReaderPop Method

Pops the top token reader state from the stack and restores the token reader to that state.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Pop()
Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Push Method

ITokenReaderPush Method

Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Push()
Sub Push
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode Interface

Provides the base requirements for tree construction node, used to output an IAstNode for an EbnfProduction.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITreeConstructionNode
Public Interface ITreeConstructionNode

The ITreeConstructionNode type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.
Top
Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node.
Public method | ToEbnfString | Outputs the contents of the production rule in EBNF form.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode Properties

The ITreeConstructionNode type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.
Top
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode.IsCompiled Property

ITreeConstructionNodeIsCompiled Property

Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsCompiled { get; }
ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode.IsList Property

ITreeConstructionNodeIsList Property

Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsList { get; }
ReadOnly Property IsList As Boolean
    Get

Property Value

Type: Boolean
true if this node creates a list of IAstNode results.
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode Methods

The ITreeConstructionNode type exposes the following members.

Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node.
Public method | ToEbnfString | Outputs the contents of the production rule in EBNF form.
Top
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode.CreateNode Method

ITreeConstructionNodeCreateNode Method

Returns the IAstNode that is created for this tree construction node.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IAstNode CreateNode(
    IAstNodeMatchCollection matches
)
Function CreateNode (
    matches As IAstNodeMatchCollection
) As IAstNode

Parameters

matches
Type: ActiproSoftware.Text.Parsing.LLParserIAstNodeMatchCollection
The collection of matched IAstNode objects within the current IAstNodeBuilder scope.

Return Value

Type: IAstNode
The IAstNode that is created for this tree construction node.
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode.ToEbnfString Method

ITreeConstructionNodeToEbnfString Method

Outputs the contents of the production rule in EBNF form.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ToEbnfString()
Function ToEbnfString As String

Return Value

Type: String
A string containing the EBNF form of the production rule.
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode) Interface

ITypedTreeConstructionNodeTAstNode Interface

Provides the base requirements for tree construction node, used to output a specific type of IAstNode for an EbnfProduction.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITypedTreeConstructionNode<TAstNode> : ITreeConstructionNode
where TAstNode : class, IAstNode

Public Interface ITypedTreeConstructionNode(Of TAstNode As {Class, IAstNode})
    Inherits ITreeConstructionNode

Type Parameters

TAstNode
The type of IAstNode.

The ITypedTreeConstructionNodeTAstNode type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from ITreeConstructionNode.)
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results. (Inherited from ITreeConstructionNode.)
Top
Methods
 | Name | Description
Public method | AddToCollectionPropertyTItem | Creates an ITreePropertyConstructionNode that adds values from one or more specified ITreeConstructionNode constructed nodes to a collection property.
Public method | AppendToPropertyTProperty | Creates an ITreePropertyConstructionNode that appends a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node. (Inherited from ITreeConstructionNode.)
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property on each item in a collection property using the specified ITreeConstructionNode constructed nodes.
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property on each item in a collection property.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property.
Public method | ToEbnfString | Outputs the contents of the production rule in EBNF form. (Inherited from ITreeConstructionNode.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode) Properties

ITypedTreeConstructionNodeTAstNode Properties

The ITypedTreeConstructionNodeTAstNode generic type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from ITreeConstructionNode.)
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results. (Inherited from ITreeConstructionNode.)
Top
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode) Methods

ITypedTreeConstructionNodeTAstNode Methods

The ITypedTreeConstructionNodeTAstNode generic type exposes the following members.

Methods
 | Name | Description
Public method | AddToCollectionPropertyTItem | Creates an ITreePropertyConstructionNode that adds values from one or more specified ITreeConstructionNode constructed nodes to a collection property.
Public method | AppendToPropertyTProperty | Creates an ITreePropertyConstructionNode that appends a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node. (Inherited from ITreeConstructionNode.)
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property on each item in a collection property using the specified ITreeConstructionNode constructed nodes.
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property on each item in a collection property.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property.
Public method | ToEbnfString | Outputs the contents of the production rule in EBNF form. (Inherited from ITreeConstructionNode.)
Top
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).AddToCollectionProperty(TItem) Method

ITypedTreeConstructionNodeTAstNodeAddToCollectionPropertyTItem Method

Creates an ITreePropertyConstructionNode that adds values from one or more specified ITreeConstructionNode constructed nodes to a collection property.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> AddToCollectionProperty<TItem>(
    Expression<Func<TAstNode, ICollection<TItem>>> expression,
    params ITreeConstructionNode[] children
)

Function AddToCollectionProperty(Of TItem) (
    expression As Expression(Of Func(Of TAstNode, ICollection(Of TItem))),
    ParamArray children As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression
Type: System.Linq.ExpressionsExpression Func TAstNode, ICollection TItem
The lambda expression indicating the collection property to update.
children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TItem
The type of collection item.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
Remarks
String, integer, boolean, and AST node (any IAstNode-based class) property types are supported.

Multiple ITreeConstructionNode constructed nodes can be passed to this method. In the case of a string collection property type, the string values of the constructed nodes are added as items to the collection property. In the case of an integer collection property type, the numeric values of the constructed nodes are added as items to the collection property. In the case of a boolean collection property type, the boolean values of the constructed nodes are added as items to the collection property. In the case of an AST node collection type, the nodes are added as items to the collection property.

See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).AppendToProperty(TProperty) Method

ITypedTreeConstructionNodeTAstNodeAppendToPropertyTProperty Method

Creates an ITreePropertyConstructionNode that appends a value to a property using the specified ITreeConstructionNode constructed nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> AppendToProperty<TProperty>(
    Expression<Func<TAstNode, TProperty>> expression,
    params ITreeConstructionNode[] children
)

Function AppendToProperty(Of TProperty) (
    expression As Expression(Of Func(Of TAstNode, TProperty)),
    ParamArray children As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression
Type: System.Linq.ExpressionsExpression Func TAstNode, TProperty
The lambda expression indicating the property to update.
children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
Remarks
String, integer, boolean, and flags enumeration property types are supported.

Multiple ITreeConstructionNode constructed nodes can be passed to this method. In the case of a string property type, the string values of the constructed nodes are concatenated to form the value appended to the property. In the case of an integer property type, the numeric values of the constructed nodes are added together to form the value appended to the property. In the case of a boolean property type, the boolean values of the constructed nodes are or'ed together to form the value appended to the property. In the case of a flags enumeration property type, the constructed node values are matched against enumeration value names, or'ed together, and the result is used as the value appended to the property.

See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetCollectionItemProperties Method

ITypedTreeConstructionNodeTAstNodeSetCollectionItemProperties Method

Overload List
 | Name | Description
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property on each item in a collection property using the specified ITreeConstructionNode constructed nodes.
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property on each item in a collection property.
Top
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetCollectionItemProperties(TItem, TProperty) Method (Expression(Func(TAstNode, ICollection(TItem))), Expression(Func(TItem, TProperty)), ITreeConstructionNode[])

ITypedTreeConstructionNodeTAstNodeSetCollectionItemPropertiesTItem, TProperty Method (ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, ITreeConstructionNode)

Creates an ITreePropertyConstructionNode that sets a value to a property on each item in a collection property using the specified ITreeConstructionNode constructed nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> SetCollectionItemProperties<TItem, TProperty>(
    Expression<Func<TAstNode, ICollection<TItem>>> expression1,
    Expression<Func<TItem, TProperty>> expression2,
    params ITreeConstructionNode[] children
)
where TItem : new(), IAstNode

Function SetCollectionItemProperties(Of TItem As {New, IAstNode}, TProperty) (
    expression1 As Expression(Of Func(Of TAstNode, ICollection(Of TItem))),
    expression2 As Expression(Of Func(Of TItem, TProperty)),
    ParamArray children As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression1
Type: System.Linq.ExpressionsExpression Func TAstNode, ICollection TItem
The lambda expression indicating the collection property to update.
expression2
Type: System.Linq.ExpressionsExpression Func TItem, TProperty
The lambda expression indicating the item property to update.
children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TItem
The type of collection item type.
TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
Remarks
String, integer, boolean, enumeration, and AST node (any IAstNode-based class) property types are supported.

Multiple ITreeConstructionNode constructed nodes can be passed to this method. In the case of a string property type, the string values of the constructed nodes are concatenated to form the value set to the property. In the case of an integer property type, the numeric values of the constructed nodes are added together to form the value set to the property. In the case of a boolean property type, the boolean values of the constructed nodes are or'ed together to form the value set to the property. In the case of an enumeration property type, the first constructed node value is matched against an enumeration value name and is used as the value set to the property. In the case of a flags enumeration property type, the constructed node values are matched against enumeration value names, or'ed together, and the result is used as the value set to the property. In the case of an AST node type, the first constructed node is the value set to the property.

See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
SetCollectionItemProperties Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetCollectionItemProperties(TItem, TProperty) Method (Expression(Func(TAstNode, ICollection(TItem))), Expression(Func(TItem, TProperty)), Object)

ITypedTreeConstructionNodeTAstNodeSetCollectionItemPropertiesTItem, TProperty Method (ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, Object)

Creates an ITreePropertyConstructionNode that sets a single explicit value to a property on each item in a collection property.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> SetCollectionItemProperties<TItem, TProperty>(
    Expression<Func<TAstNode, ICollection<TItem>>> expression1,
    Expression<Func<TItem, TProperty>> expression2,
    Object explicitValue
)
where TItem : new(), IAstNode

Function SetCollectionItemProperties(Of TItem As {New, IAstNode}, TProperty) (
    expression1 As Expression(Of Func(Of TAstNode, ICollection(Of TItem))),
    expression2 As Expression(Of Func(Of TItem, TProperty)),
    explicitValue As Object
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression1
Type: System.Linq.ExpressionsExpression Func TAstNode, ICollection TItem
The lambda expression indicating the collection property to update.
expression2
Type: System.Linq.ExpressionsExpression Func TItem, TProperty
The lambda expression indicating the item property to update.
explicitValue
Type: SystemObject
The explicit value to set.

Type Parameters

TItem
The type of collection item type.
TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
SetCollectionItemProperties Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetProperty Method

ITypedTreeConstructionNodeTAstNodeSetProperty Method

Overload List
 | Name | Description
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property.
Top
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetProperty(TProperty) Method (Expression(Func(TAstNode, TProperty)), ITreeConstructionNode[])

ITypedTreeConstructionNodeTAstNodeSetPropertyTProperty Method (ExpressionFuncTAstNode, TProperty, ITreeConstructionNode)

Creates an ITreePropertyConstructionNode that sets a value to a property using the specified ITreeConstructionNode constructed nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> SetProperty<TProperty>(
    Expression<Func<TAstNode, TProperty>> expression,
    params ITreeConstructionNode[] children
)

Function SetProperty(Of TProperty) (
    expression As Expression(Of Func(Of TAstNode, TProperty)),
    ParamArray children As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression
Type: System.Linq.ExpressionsExpression Func TAstNode, TProperty
The lambda expression indicating the property to update.
children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
Remarks
String, integer, boolean, enumeration, and AST node (any IAstNode-based class) property types are supported.

Multiple ITreeConstructionNode constructed nodes can be passed to this method. In the case of a string property type, the string values of the constructed nodes are concatenated to form the value set to the property. In the case of an integer property type, the numeric values of the constructed nodes are added together to form the value set to the property. In the case of a boolean property type, the boolean values of the constructed nodes are or'ed together to form the value set to the property. In the case of an enumeration property type, the first constructed node value is matched against an enumeration value name and is used as the value set to the property. In the case of a flags enumeration property type, the constructed node values are matched against enumeration value names, or'ed together, and the result is used as the value set to the property. In the case of an AST node type, the first constructed node is the value set to the property.

See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
SetProperty Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetProperty(TProperty) Method (Expression(Func(TAstNode, TProperty)), Object)

ITypedTreeConstructionNodeTAstNodeSetPropertyTProperty Method (ExpressionFuncTAstNode, TProperty, Object)

Creates an ITreePropertyConstructionNode that sets a single explicit value to a property.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> SetProperty<TProperty>(
    Expression<Func<TAstNode, TProperty>> expression,
    Object explicitValue
)

Function SetProperty(Of TProperty) (
    expression As Expression(Of Func(Of TAstNode, TProperty)),
    explicitValue As Object
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression
Type: System.Linq.ExpressionsExpression Func TAstNode, TProperty
The lambda expression indicating the property to update.
explicitValue
Type: SystemObject
The explicit value to set.

Type Parameters

TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
SetProperty Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCallback Delegate

Defines a callback method that can be executed during a parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public delegate void ParserCallback(
    IParserState state
)
Public Delegate Sub ParserCallback (
    state As IParserState
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
A IParserState that provides information about the parser's current state.
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCanMatchCallback Delegate

Defines a can-match callback method that can be executed during a parsing operation for a NonTerminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public delegate bool ParserCanMatchCallback(
    IParserState state
)
Public Delegate Function ParserCanMatchCallback (
    state As IParserState
) As Boolean

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
A IParserState that provides information about the parser's current state.

Return Value

Type: Boolean
true if the NonTerminal can match with the current state; otherwise, false.
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorCallback Delegate

Defines an error callback method that can be executed during a parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public delegate IParserErrorResult ParserErrorCallback(
    IParserState state
)
Public Delegate Function ParserErrorCallback (
    state As IParserState
) As IParserErrorResult

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
A IParserState that provides information about the parser's current state.

Return Value

Type: IParserErrorResult
An IParserErrorResult value indicating a result.
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults Class

Provides access to the built-in IParserErrorResult instances, that indicate a result provided by a ParserErrorCallback.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParserParserErrorResults

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class ParserErrorResults
Public NotInheritable Class ParserErrorResults

The ParserErrorResults type exposes the following members.

Properties
Name | Description
Continue | Gets the IParserErrorResult that indicates to potentially report errors but continue on.
Default | Gets the IParserErrorResult that indicates to potentially report errors and return a match failure.
Ignore | Gets the IParserErrorResult that indicates to never report errors and continue on.
NoReport | Gets the IParserErrorResult that indicates to never report errors and return a match failure.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults Properties

The ParserErrorResults type exposes the following members.

Properties
Name | Description
Continue | Gets the IParserErrorResult that indicates to potentially report errors but continue on.
Default | Gets the IParserErrorResult that indicates to potentially report errors and return a match failure.
Ignore | Gets the IParserErrorResult that indicates to never report errors and continue on.
NoReport | Gets the IParserErrorResult that indicates to never report errors and return a match failure.
Top
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults.Continue Property

ParserErrorResultsContinue Property

Gets the IParserErrorResult that indicates to potentially report errors but continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IParserErrorResult Continue { get; }
Public Shared ReadOnly Property Continue As IParserErrorResult
    Get

Property Value

Type: IParserErrorResult
The IParserErrorResult that indicates to potentially report errors but continue on.
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults.Default Property

ParserErrorResultsDefault Property

Gets the IParserErrorResult that indicates to potentially report errors and return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IParserErrorResult Default { get; }
Public Shared ReadOnly Property Default As IParserErrorResult
    Get

Property Value

Type: IParserErrorResult
The IParserErrorResult that indicates to potentially report errors and return a match failure.
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults.Ignore Property

ParserErrorResultsIgnore Property

Gets the IParserErrorResult that indicates to never report errors and continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IParserErrorResult Ignore { get; }
Public Shared ReadOnly Property Ignore As IParserErrorResult
    Get

Property Value

Type: IParserErrorResult
The IParserErrorResult that indicates to never report errors and continue on.
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults.NoReport Property

ParserErrorResultsNoReport Property

Gets the IParserErrorResult that indicates to never report errors and return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IParserErrorResult NoReport { get; }
Public Shared ReadOnly Property NoReport As IParserErrorResult
    Get

Property Value

Type: IParserErrorResult
The IParserErrorResult that indicates to never report errors and return a match failure.
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace

Contains types related to the debugging of an LL parser.
Interfaces
 | Interface | Description
Public interface | IBreakpoint | Provides the base requirements for a breakpoint within an IDebugger.
Public interface | IDebuggableAstNode | Provides the base requirements for a debuggable IAstNode.
Public interface | IDebuggableAstNodeMatch | Provides the base requirements for a debuggable IAstNodeMatch.
Public interface | IDebuggableEbnfTerm | Provides the base requirements for a debuggable EbnfTerm.
Public interface | IDebuggableMatchCondition | Provides the base requirements for a debuggable IMatchCondition.
Public interface | IDebuggableNonTerminal | Provides the base requirements for a debuggable NonTerminal.
Public interface | IDebuggableSymbol | Provides the base requirements for a debuggable Symbol.
Public interface | IDebuggableTerminal | Provides the base requirements for a debuggable Terminal.
Public interface | IDebugger | Provides the base requirements for a Grammar debugger that can control parser execution and obtain detailed information about parser state.
Public interface | IDebuggerState | Provides the base requirements for an object that contains information about the current IDebugger state.
Enumerations
 | Enumeration | Description
Public enumeration | DebuggerMode | Specifies the mode that an IDebugger is in.


DebuggerMode Enumeration

Specifies the mode that an IDebugger is in.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DebuggerMode
Public Enumeration DebuggerMode
Members
Member name | Value | Description
Stopped | 0 | The debugger is not running.
Running | 1 | The debugger is running.
Paused | 2 | The debugger is paused at a breakpoint.
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IBreakpoint Interface

Provides the base requirements for a breakpoint within an IDebugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IBreakpoint
Public Interface IBreakpoint

The IBreakpoint type exposes the following members.

Properties
 | Name | Description
Public property | Symbol | Gets the IDebuggableSymbol at which to break.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IBreakpoint Properties

The IBreakpoint type exposes the following members.

Properties
 | Name | Description
Public property | Symbol | Gets the IDebuggableSymbol at which to break.
Top
See Also

Reference

IBreakpoint Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IBreakpoint.Symbol Property

IBreakpointSymbol Property

Gets the IDebuggableSymbol at which to break.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDebuggableSymbol Symbol { get; }
ReadOnly Property Symbol As IDebuggableSymbol
    Get

Property Value

Type: IDebuggableSymbol
The IDebuggableSymbol at which to break.
See Also

Reference

IBreakpoint Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode Interface

Provides the base requirements for a debuggable IAstNode.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDebuggableAstNode
Public Interface IDebuggableAstNode

The IDebuggableAstNode type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the end offset of this AST node, if known.
Public property | StartOffset | Gets the start offset of this AST node, if known.
Public property | TreeString | Gets the AST node string representation.
Public property | Value | Gets the AST node value.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode Properties

The IDebuggableAstNode type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the end offset of this AST node, if known.
Public property | StartOffset | Gets the start offset of this AST node, if known.
Public property | TreeString | Gets the AST node string representation.
Public property | Value | Gets the AST node value.
Top
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode.EndOffset Property

IDebuggableAstNodeEndOffset Property

Gets the end offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<int> EndOffset { get; }
ReadOnly Property EndOffset As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The end offset of this AST node, if known.
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode.StartOffset Property

IDebuggableAstNodeStartOffset Property

Gets the start offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<int> StartOffset { get; }
ReadOnly Property StartOffset As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The start offset of this AST node, if known.
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode.TreeString Property

IDebuggableAstNodeTreeString Property

Gets the AST node string representation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string TreeString { get; }
ReadOnly Property TreeString As String
    Get

Property Value

Type: String
The AST node string representation.
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode.Value Property

IDebuggableAstNodeValue Property

Gets the AST node value.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Value { get; }
ReadOnly Property Value As String
    Get

Property Value

Type: String
The AST node value.
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNodeMatch Interface

Provides the base requirements for a debuggable IAstNodeMatch.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDebuggableAstNodeMatch
Public Interface IDebuggableAstNodeMatch

The IDebuggableAstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets the IDebuggableAstNode that was matched.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNodeMatch Properties

The IDebuggableAstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets the IDebuggableAstNode that was matched.
Top
See Also

Reference

IDebuggableAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNodeMatch.Label Property

IDebuggableAstNodeMatchLabel Property

Gets the optional label applied to the match that can be used for identification during tree construction.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Label { get; }
ReadOnly Property Label As String
    Get

Property Value

Type: String
The optional label applied to the match that can be used for identification during tree construction.
See Also

Reference

IDebuggableAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNodeMatch.Node Property

IDebuggableAstNodeMatchNode Property

Gets the IDebuggableAstNode that was matched.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDebuggableAstNode Node { get; }
ReadOnly Property Node As IDebuggableAstNode
    Get

Property Value

Type: IDebuggableAstNode
The IDebuggableAstNode that was matched.
See Also

Reference

IDebuggableAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableEbnfTerm Interface

Provides the base requirements for a debuggable EbnfTerm.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDebuggableEbnfTerm
Public Interface IDebuggableEbnfTerm

The IDebuggableEbnfTerm type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets or sets the compiled TextPositionRange of the node within an EBNF representation of the grammar.
Public property | MatchCondition | Gets the IDebuggableMatchCondition to use for this term.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableEbnfTerm Properties

The IDebuggableEbnfTerm type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets or sets the compiled TextPositionRange of the node within an EBNF representation of the grammar.
Public property | MatchCondition | Gets the IDebuggableMatchCondition to use for this term.
Top
See Also

Reference

IDebuggableEbnfTerm Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableEbnfTerm.EbnfPositionRange Property

IDebuggableEbnfTermEbnfPositionRange Property

Gets or sets the compiled TextPositionRange of the node within an EBNF representation of the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPositionRange EbnfPositionRange { get; }
ReadOnly Property EbnfPositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
The compiled TextPositionRange of the node within an EBNF representation of the grammar.
See Also

Reference

IDebuggableEbnfTerm Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableEbnfTerm.MatchCondition Property

IDebuggableEbnfTermMatchCondition Property

Gets the IDebuggableMatchCondition to use for this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDebuggableMatchCondition MatchCondition { get; }
ReadOnly Property MatchCondition As IDebuggableMatchCondition
    Get

Property Value

Type: IDebuggableMatchCondition
The IDebuggableMatchCondition to use for this term.
See Also

Reference

IDebuggableEbnfTerm Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableMatchCondition Interface

Provides the base requirements for a debuggable IMatchCondition.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDebuggableMatchCondition
Public Interface IDebuggableMatchCondition

The IDebuggableMatchCondition type exposes the following members.

Properties
 | Name | Description
Public property | CallbackCount | Gets the number of callbacks.
Public property | FirstSet | Returns the collection of terminals that provide the first-set for the match condition.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableMatchCondition Properties

The IDebuggableMatchCondition type exposes the following members.

Properties
 | Name | Description
Public property | CallbackCount | Gets the number of callbacks.
Public property | FirstSet | Returns the collection of terminals that provide the first-set for the match condition.
Top
See Also

Reference

IDebuggableMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableMatchCondition.CallbackCount Property

IDebuggableMatchConditionCallbackCount Property

Gets the number of callbacks.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int CallbackCount { get; }
ReadOnly Property CallbackCount As Integer
    Get

Property Value

Type: Int32
The number of callbacks.
See Also

Reference

IDebuggableMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableMatchCondition.FirstSet Property

IDebuggableMatchConditionFirstSet Property

Returns the collection of terminals that provide the first-set for the match condition.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<IDebuggableTerminal> FirstSet { get; }
ReadOnly Property FirstSet As IEnumerable(Of IDebuggableTerminal)
    Get

Return Value

Type: IEnumerable IDebuggableTerminal
The collection of terminals that provide the first-set for the match condition.
See Also

Reference

IDebuggableMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableNonTerminal Interface

Provides the base requirements for a debuggable NonTerminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDebuggableNonTerminal : IDebuggableSymbol
Public Interface IDebuggableNonTerminal
    Inherits IDebuggableSymbol

The IDebuggableNonTerminal type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar. (Inherited from IDebuggableSymbol.)
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors. (Inherited from IDebuggableSymbol.)
Public property | Key | Gets the string that identifies the symbol. (Inherited from IDebuggableSymbol.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableNonTerminal Properties

The IDebuggableNonTerminal type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar. (Inherited from IDebuggableSymbol.)
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors. (Inherited from IDebuggableSymbol.)
Public property | Key | Gets the string that identifies the symbol. (Inherited from IDebuggableSymbol.)
Top
See Also

Reference

IDebuggableNonTerminal Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol Interface

Provides the base requirements for a debuggable Symbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDebuggableSymbol
Public Interface IDebuggableSymbol

The IDebuggableSymbol type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar.
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors.
Public property | Key | Gets the string that identifies the symbol.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol Properties

The IDebuggableSymbol type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar.
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors.
Public property | Key | Gets the string that identifies the symbol.
Top
See Also

Reference

IDebuggableSymbol Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol.EbnfPositionRange Property

IDebuggableSymbolEbnfPositionRange Property

Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextPositionRange EbnfPositionRange { get; }
ReadOnly Property EbnfPositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
The compiled TextPositionRange of the symbol within an EBNF representation of the grammar.
See Also

Reference

IDebuggableSymbol Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol.ErrorAlias Property

IDebuggableSymbolErrorAlias Property

Gets the alias to use for this symbol when reporting errors.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ErrorAlias { get; }
ReadOnly Property ErrorAlias As String
    Get

Property Value

Type: String
The alias to use for this symbol when reporting errors.
Remarks

Terminals always report errors and use their Key if no error alias is specified. Non-terminals will only report errors if an error alias is specified.

See Also

Reference

IDebuggableSymbol Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol.Key Property

IDebuggableSymbolKey Property

Gets the string that identifies the symbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Key { get; }
ReadOnly Property Key As String
    Get

Property Value

Type: String
The string that identifies the symbol.
See Also

Reference

IDebuggableSymbol Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableTerminal Interface

Provides the base requirements for a debuggable Terminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDebuggableTerminal : IDebuggableSymbol
Public Interface IDebuggableTerminal
    Inherits IDebuggableSymbol

The IDebuggableTerminal type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar. (Inherited from IDebuggableSymbol.)
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors. (Inherited from IDebuggableSymbol.)
Public property | Id | Gets the ID that identifies the terminal.
Public property | Key | Gets the string that identifies the symbol. (Inherited from IDebuggableSymbol.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableTerminal Properties

The IDebuggableTerminal type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar. (Inherited from IDebuggableSymbol.)
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors. (Inherited from IDebuggableSymbol.)
Public property | Id | Gets the ID that identifies the terminal.
Public property | Key | Gets the string that identifies the symbol. (Inherited from IDebuggableSymbol.)
Top
See Also

Reference

IDebuggableTerminal Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableTerminal.Id Property

IDebuggableTerminalId Property

Gets the ID that identifies the terminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Nullable<int> Id { get; }
ReadOnly Property Id As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The ID that identifies the terminal.
See Also

Reference

IDebuggableTerminal Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger Interface

Provides the base requirements for a Grammar debugger that can control parser execution and obtain detailed information about parser state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDebugger
Public Interface IDebugger

The IDebugger type exposes the following members.

Properties
 | Name | Description
Public property | IsAttached | Gets whether the debugger is currently attached to an ICodeDocument.
Public property | Mode | Gets the current DebuggerMode of the debugger.
Public property | State | Gets the IDebuggerState that contains information about the current state of the debugger.
Top
Methods
 | Name | Description
Public method | Attach | Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.
Public method | Detach | Detaches from the currently-attached document, if any.
Public method | NotifyBreak | Called by the parser to notify the debugger it has paused execution.
Public method | Pause | Requests that the debugger pause execution if the it is currently running.
Public method | Start | Starts debugging on the attached document.
Public method | StepInto | Steps into the next debuggable location.
Public method | StepOut | Steps out of the current debuggable location.
Public method | StepOver | Steps over the current debuggable location.
Public method | Stop | Stops debugging on the attached document.
Top
Events
 | Name | Description
Public event | ModeChanged | Occurs when the Mode property changes.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger Properties

The IDebugger type exposes the following members.

Properties
 | Name | Description
Public property | IsAttached | Gets whether the debugger is currently attached to an ICodeDocument.
Public property | Mode | Gets the current DebuggerMode of the debugger.
Public property | State | Gets the IDebuggerState that contains information about the current state of the debugger.
Top
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.IsAttached Property

IDebuggerIsAttached Property

Gets whether the debugger is currently attached to an ICodeDocument.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAttached { get; }
ReadOnly Property IsAttached As Boolean
    Get

Property Value

Type: Boolean
true if the debugger is currently attached to an ICodeDocument; otherwise, false.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Mode Property

IDebuggerMode Property

Gets the current DebuggerMode of the debugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DebuggerMode Mode { get; }
ReadOnly Property Mode As DebuggerMode
    Get

Property Value

Type: DebuggerMode
The current DebuggerMode of the debugger.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.State Property

IDebuggerState Property

Gets the IDebuggerState that contains information about the current state of the debugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDebuggerState State { get; }
ReadOnly Property State As IDebuggerState
    Get

Property Value

Type: IDebuggerState
The IDebuggerState that contains information about the current state of the debugger.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger Methods

The IDebugger type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.
Public method | Detach | Detaches from the currently-attached document, if any.
Public method | NotifyBreak | Called by the parser to notify the debugger it has paused execution.
Public method | Pause | Requests that the debugger pause execution if the it is currently running.
Public method | Start | Starts debugging on the attached document.
Public method | StepInto | Steps into the next debuggable location.
Public method | StepOut | Steps out of the current debuggable location.
Public method | StepOver | Steps over the current debuggable location.
Public method | Stop | Stops debugging on the attached document.
Top
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Attach Method

IDebuggerAttach Method

Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Attach(
    ICodeDocument document
)
Function Attach (
    document As ICodeDocument
) As Boolean

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument to debug.

Return Value

Type: Boolean
true if the debugger was attached; otherwise, false.
Remarks
This method will return false if the debugger is already attached to a document, if the document doesn't have an ISyntaxLanguage, or if the syntax language's IParser isn't an ILLParser.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Detach Method

IDebuggerDetach Method

Detaches from the currently-attached document, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Detach()
Sub Detach
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.NotifyBreak Method

IDebuggerNotifyBreak Method

Called by the parser to notify the debugger it has paused execution.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void NotifyBreak()
Sub NotifyBreak
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Pause Method

IDebuggerPause Method

Requests that the debugger pause execution if the it is currently running.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Pause()
Sub Pause
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Start Method

IDebuggerStart Method

Starts debugging on the attached document.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Start()
Function Start As Boolean

Return Value

Type: Boolean
true if debugging started; otherwise, false.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.StepInto Method

IDebuggerStepInto Method

Steps into the next debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void StepInto()
Sub StepInto
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.StepOut Method

IDebuggerStepOut Method

Steps out of the current debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void StepOut()
Sub StepOut
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.StepOver Method

IDebuggerStepOver Method

Steps over the current debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void StepOver()
Sub StepOver
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Stop Method

IDebuggerStop Method

Stops debugging on the attached document.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Stop()
Sub Stop
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger Events

The IDebugger type exposes the following members.

Events
 | Name | Description
Public event | ModeChanged | Occurs when the Mode property changes.
Top
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.ModeChanged Event

IDebuggerModeChanged Event

Occurs when the Mode property changes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler ModeChanged
Event ModeChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState Interface

Provides the base requirements for an object that contains information about the current IDebugger state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDebuggerState
Public Interface IDebuggerState

The IDebuggerState type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Gets the collection of IBreakpoint objects.
Public property | Ebnf | Gets the textual EBNF representation of the grammar.
Public property | IsBreakForCanMatch | Gets whether the current pause is related to a can-match check for an EbnfTerm.
Public property | Matches | Gets the list of IDebuggableAstNodeMatch objects that indicate the labeled AST node matches for the current scope.
Public property | NonTerminals | Gets the read-only list of IDebuggableNonTerminal objects defined in the grammar.
Public property | NonTerminalStack | Gets the stack of IDebuggableNonTerminal objects into which the parser has entered.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | RootNode | Gets the root IDebuggableAstNode that has been constructed.
Public property | Terminals | Gets the read-only list of IDebuggableTerminal objects defined in the grammar.
Public property | TermStack | Gets the stack of IDebuggableEbnfTerm objects into which the parser has entered.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Top
Methods
 | Name | Description
Public method | AddBreakpoint | Adds an IBreakpoint for an IDebuggableSymbol.
Public method | RemoveBreakpoint | Removes an IBreakpoint for an IDebuggableSymbol.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState Properties

The IDebuggerState type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Gets the collection of IBreakpoint objects.
Public property | Ebnf | Gets the textual EBNF representation of the grammar.
Public property | IsBreakForCanMatch | Gets whether the current pause is related to a can-match check for an EbnfTerm.
Public property | Matches | Gets the list of IDebuggableAstNodeMatch objects that indicate the labeled AST node matches for the current scope.
Public property | NonTerminals | Gets the read-only list of IDebuggableNonTerminal objects defined in the grammar.
Public property | NonTerminalStack | Gets the stack of IDebuggableNonTerminal objects into which the parser has entered.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | RootNode | Gets the root IDebuggableAstNode that has been constructed.
Public property | Terminals | Gets the read-only list of IDebuggableTerminal objects defined in the grammar.
Public property | TermStack | Gets the stack of IDebuggableEbnfTerm objects into which the parser has entered.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Top
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.Breakpoints Property

IDebuggerStateBreakpoints Property

Gets the collection of IBreakpoint objects.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IBreakpoint> Breakpoints { get; }
ReadOnly Property Breakpoints As IList(Of IBreakpoint)
    Get

Property Value

Type: IList IBreakpoint
The collection of IBreakpoint objects.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.Ebnf Property

IDebuggerStateEbnf Property

Gets the textual EBNF representation of the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Ebnf { get; }
ReadOnly Property Ebnf As String
    Get

Property Value

Type: String
The textual EBNF representation of the grammar.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.IsBreakForCanMatch Property

IDebuggerStateIsBreakForCanMatch Property

Gets whether the current pause is related to a can-match check for an EbnfTerm.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsBreakForCanMatch { get; }
ReadOnly Property IsBreakForCanMatch As Boolean
    Get

Property Value

Type: Boolean
true if the current pause is related to a can-match check; otherwise, false.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.Matches Property

IDebuggerStateMatches Property

Gets the list of IDebuggableAstNodeMatch objects that indicate the labeled AST node matches for the current scope.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IDebuggableAstNodeMatch> Matches { get; }
ReadOnly Property Matches As IList(Of IDebuggableAstNodeMatch)
    Get

Property Value

Type: IList IDebuggableAstNodeMatch
The list of IDebuggableAstNodeMatch objects that indicate the labeled AST node matches for the current scope.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.NonTerminals Property

IDebuggerStateNonTerminals Property

Gets the read-only list of IDebuggableNonTerminal objects defined in the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IDebuggableNonTerminal> NonTerminals { get; }
ReadOnly Property NonTerminals As IList(Of IDebuggableNonTerminal)
    Get

Property Value

Type: IList IDebuggableNonTerminal
The read-only list of IDebuggableNonTerminal objects defined in the grammar.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.NonTerminalStack Property

IDebuggerStateNonTerminalStack Property

Gets the stack of IDebuggableNonTerminal objects into which the parser has entered.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Stack<IDebuggableNonTerminal> NonTerminalStack { get; }
ReadOnly Property NonTerminalStack As Stack(Of IDebuggableNonTerminal)
    Get

Property Value

Type: Stack IDebuggableNonTerminal
The stack of IDebuggableNonTerminal objects into which the parser has entered.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.ParseErrors Property

IDebuggerStateParseErrors Property

Gets the collection of IParseError objects that will be returned in the IParseData parsing result.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<IParseError> ParseErrors { get; }
ReadOnly Property ParseErrors As IEnumerable(Of IParseError)
    Get

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that will be returned in the IParseData parsing result.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.RootNode Property

IDebuggerStateRootNode Property

Gets the root IDebuggableAstNode that has been constructed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDebuggableAstNode RootNode { get; }
ReadOnly Property RootNode As IDebuggableAstNode
    Get

Property Value

Type: IDebuggableAstNode
The root IDebuggableAstNode that has been constructed.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.Terminals Property

IDebuggerStateTerminals Property

Gets the read-only list of IDebuggableTerminal objects defined in the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IDebuggableTerminal> Terminals { get; }
ReadOnly Property Terminals As IList(Of IDebuggableTerminal)
    Get

Property Value

Type: IList IDebuggableTerminal
The read-only list of IDebuggableTerminal objects defined in the grammar.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.TermStack Property

IDebuggerStateTermStack Property

Gets the stack of IDebuggableEbnfTerm objects into which the parser has entered.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Stack<IDebuggableEbnfTerm> TermStack { get; }
ReadOnly Property TermStack As Stack(Of IDebuggableEbnfTerm)
    Get

Property Value

Type: Stack IDebuggableEbnfTerm
The stack of IDebuggableEbnfTerm objects into which the parser has entered.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.TokenReader Property

IDebuggerStateTokenReader Property

Gets the ITokenReader that is used to read tokens during the parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITokenReader TokenReader { get; }
ReadOnly Property TokenReader As ITokenReader
    Get

Property Value

Type: ITokenReader
The ITokenReader that is used to read tokens during the parsing operation.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState Methods

The IDebuggerState type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint | Adds an IBreakpoint for an IDebuggableSymbol.
Public method | RemoveBreakpoint | Removes an IBreakpoint for an IDebuggableSymbol.
Top
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.AddBreakpoint Method

IDebuggerStateAddBreakpoint Method

Adds an IBreakpoint for an IDebuggableSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void AddBreakpoint(
    IDebuggableSymbol symbol
)
Sub AddBreakpoint (
    symbol As IDebuggableSymbol
)

Parameters

symbol
Type: ActiproSoftware.Text.Parsing.LLParser.DebuggingIDebuggableSymbol
The IDebuggableSymbol for which a breakpoint should be created.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.RemoveBreakpoint Method

IDebuggerStateRemoveBreakpoint Method

Removes an IBreakpoint for an IDebuggableSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void RemoveBreakpoint(
    IDebuggableSymbol symbol
)
Sub RemoveBreakpoint (
    symbol As IDebuggableSymbol
)

Parameters

symbol
Type: ActiproSoftware.Text.Parsing.LLParser.DebuggingIDebuggableSymbol
The IDebuggableSymbol for which a breakpoint should be removed.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace

Contains implementation types related to the debugging of an LL parser.
Classes
 | Class | Description
Public class | Debugger | Represents a Grammar debugger that can control parser execution and obtain detailed information about parser state.
Public class | InfiniteLifetimeObjectBase | Provides the abstract base class for an object that can be proxied across an AppDomain and always remains active.


Debugger Class

Represents a Grammar debugger that can control parser execution and obtain detailed information about parser state.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.Debugging.ImplementationDebugger

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Debugger : IDebugger
Public Class Debugger
    Implements IDebugger

The Debugger type exposes the following members.

Constructors
 | Name | Description
Public method | Debugger | Initializes a new instance of the Debugger class
Top
Properties
 | Name | Description
Public property | IsAttached | Gets whether the debugger is currently attached to an ICodeDocument.
Public property | Mode | Gets the current DebuggerMode of the debugger.
Public property | State | Gets the IDebuggerState that contains information about the current state of the debugger.
Top
Methods
 | Name | Description
Public method | Attach | Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.
Public method | Detach | Detaches from the currently-attached document, if any.
Protected method | OnModeChanged | Raises the ModeChanged event.
Public method | Pause | Requests that the debugger pause execution if the it is currently running.
Public method | Start | Starts debugging on the attached document.
Public method | StepInto | Steps into the next debuggable location.
Public method | StepOut | Steps out of the current debuggable location.
Public method | StepOver | Steps over the current debuggable location.
Public method | Stop | Stops debugging on the attached document.
Top
Events
 | Name | Description
Public event | ModeChanged | Occurs when the Mode property changes.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger Constructor

Initializes a new instance of the Debugger class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Debugger()
Public Sub New
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger Properties

The Debugger type exposes the following members.

Properties
 | Name | Description
Public property | IsAttached | Gets whether the debugger is currently attached to an ICodeDocument.
Public property | Mode | Gets the current DebuggerMode of the debugger.
Public property | State | Gets the IDebuggerState that contains information about the current state of the debugger.
Top
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.IsAttached Property

DebuggerIsAttached Property

Gets whether the debugger is currently attached to an ICodeDocument.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAttached { get; }
Public ReadOnly Property IsAttached As Boolean
    Get

Property Value

Type: Boolean
true if the debugger is currently attached to an ICodeDocument; otherwise, false.

Implements

IDebuggerIsAttached
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Mode Property

DebuggerMode Property

Gets the current DebuggerMode of the debugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DebuggerMode Mode { get; }
Public ReadOnly Property Mode As DebuggerMode
    Get

Property Value

Type: DebuggerMode
The current DebuggerMode of the debugger.

Implements

IDebuggerMode
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.State Property

DebuggerState Property

Gets the IDebuggerState that contains information about the current state of the debugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDebuggerState State { get; }
Public ReadOnly Property State As IDebuggerState
    Get

Property Value

Type: IDebuggerState
The IDebuggerState that contains information about the current state of the debugger.

Implements

IDebuggerState
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger Methods

The Debugger type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.
Public method | Detach | Detaches from the currently-attached document, if any.
Protected method | OnModeChanged | Raises the ModeChanged event.
Public method | Pause | Requests that the debugger pause execution if the it is currently running.
Public method | Start | Starts debugging on the attached document.
Public method | StepInto | Steps into the next debuggable location.
Public method | StepOut | Steps out of the current debuggable location.
Public method | StepOver | Steps over the current debuggable location.
Public method | Stop | Stops debugging on the attached document.
Top
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Attach Method

DebuggerAttach Method

Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Attach(
    ICodeDocument document
)
Public Function Attach (
    document As ICodeDocument
) As Boolean

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument to debug.

Return Value

Type: Boolean
true if the debugger was attached; otherwise, false.

Implements

IDebuggerAttach(ICodeDocument)
Remarks
This method will return false if the debugger is already attached to a document, if the document doesn't have an ISyntaxLanguage, or if the syntax language's IParser isn't an ILLParser.
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Detach Method

DebuggerDetach Method

Detaches from the currently-attached document, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Detach()
Public Sub Detach

Implements

IDebuggerDetach
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.OnModeChanged Method

DebuggerOnModeChanged Method

Raises the ModeChanged event.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnModeChanged(
    EventArgs e
)
Protected Overridable Sub OnModeChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Pause Method

DebuggerPause Method

Requests that the debugger pause execution if the it is currently running.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Pause()
Public Sub Pause

Implements

IDebuggerPause
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Start Method

DebuggerStart Method

Starts debugging on the attached document.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Start()
Public Function Start As Boolean

Return Value

Type: Boolean
true if debugging started; otherwise, false.

Implements

IDebuggerStart
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.StepInto Method

DebuggerStepInto Method

Steps into the next debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void StepInto()
Public Sub StepInto

Implements

IDebuggerStepInto
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.StepOut Method

DebuggerStepOut Method

Steps out of the current debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void StepOut()
Public Sub StepOut

Implements

IDebuggerStepOut
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.StepOver Method

DebuggerStepOver Method

Steps over the current debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void StepOver()
Public Sub StepOver

Implements

IDebuggerStepOver
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Stop Method

DebuggerStop Method

Stops debugging on the attached document.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Stop()
Public Sub Stop

Implements

IDebuggerStop
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger Events

The Debugger type exposes the following members.

Events
 | Name | Description
Public event | ModeChanged | Occurs when the Mode property changes.
Top
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.ModeChanged Event

DebuggerModeChanged Event

Occurs when the Mode property changes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ModeChanged
Public Event ModeChanged As EventHandler

Value

Type: SystemEventHandler

Implements

IDebuggerModeChanged
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


InfiniteLifetimeObjectBase Class

Provides the abstract base class for an object that can be proxied across an AppDomain and always remains active.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
ActiproSoftware.Text.Parsing.LLParser.Debugging.ImplementationInfiniteLifetimeObjectBase

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class InfiniteLifetimeObjectBase : MarshalByRefObject
Public MustInherit Class InfiniteLifetimeObjectBase
    Inherits MarshalByRefObject

The InfiniteLifetimeObjectBase type exposes the following members.

Constructors
 | Name | Description
Protected method | InfiniteLifetimeObjectBase | Initializes a new instance of the InfiniteLifetimeObjectBase class
Top
Methods
 | Name | Description
Public method | InitializeLifetimeService | Initializes lifetime service. (Overrides MarshalByRefObjectInitializeLifetimeService.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


InfiniteLifetimeObjectBase Constructor

Initializes a new instance of the InfiniteLifetimeObjectBase class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected InfiniteLifetimeObjectBase()
Protected Sub New
See Also

Reference

InfiniteLifetimeObjectBase Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


InfiniteLifetimeObjectBase Methods

The InfiniteLifetimeObjectBase type exposes the following members.

Methods
 | Name | Description
Public method | InitializeLifetimeService | Initializes lifetime service. (Overrides MarshalByRefObjectInitializeLifetimeService.)
Top
See Also

Reference

InfiniteLifetimeObjectBase Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


InfiniteLifetimeObjectBase.InitializeLifetimeService Method

InfiniteLifetimeObjectBaseInitializeLifetimeService Method

Initializes lifetime service.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object InitializeLifetimeService()
Public Overrides Function InitializeLifetimeService As Object

Return Value

Type: Object
A value indicating infinite lifetime.
See Also

Reference

InfiniteLifetimeObjectBase Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace

Contains implementation types related to the creation of an LL parser.
Classes
 | Class | Description
Public class | AstNodeMatch | Represents an IAstNode match made within the current IAstNodeBuilder scope.
Public class | EbnfAlternation | Represents an alternation expression within an EBNF production.
Public class | EbnfConcatenation | Represents a concatenation expression within an EBNF production.
Public class | EbnfNonTerminal | Represents a non-terminal symbol within an EBNF production.
Public class | EbnfProduction | Represents an EBNF production, which consists of an EbnfTerm-based pattern expression and a ITreeConstructionNode-based tree constructor.
Public class | EbnfQuantifiableTerm | Represents the abstract base class for a term within an EBNF production that can be sequentially matched a specified minimum and maximum times.
Public class | EbnfQuantifier | Represents a term within an EBNF production whose child term can be sequentially matched a specified minimum and maximum times.
Public class | EbnfSymbol | Represents the abstract base class for a symbol within an EBNF production.
Public class | EbnfTerm | Represents the abstract base class for a term within an EBNF production.
Public class | EbnfTerminal | Represents a terminal symbol within an EBNF production.
Public class | Grammar | Represents a grammar that can be used with a recursive descent parser.
Public class | LLParseData | Stores the results of a ILLParser parsing operation.
Public class | LLParserBase | Represents the base class for an IParser that executes based on a Grammar definition.
Public class | MergableTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for a IMergableLexer.
Public class | NonTerminal | Represents a non-terminal symbol within a grammar.
Public class | ParentTreeConstructionNodeBase | Represents an abstract ITreeConstructionNode base class that can contain child tree construction nodes.
Public class | ParserState | Represents an object that tracks the current state of a ILLParser.
Public class | Symbol | Represents an abstract base class for a symbol within a grammar.
Public class | Terminal | Represents a terminal symbol within a grammar.
Public class | TokenReaderBase | Represents the abstract base class of an object that can provide tokens to a ILLParser in a forward-only direction.
Public class | TreeConstructionNodeBase | Represents an abstract base class a tree construction node, used to output an IAstNode for an EbnfProduction.


AstNodeMatch Class

Represents an IAstNode match made within the current IAstNodeBuilder scope.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationAstNodeMatch

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AstNodeMatch : IAstNodeMatch
Public Class AstNodeMatch
    Implements IAstNodeMatch

The AstNodeMatch type exposes the following members.

Constructors
 | Name | Description
Public method | AstNodeMatch | Initializes a new instance of the AstNodeMatch class
Top
Properties
 | Name | Description
Public property | Label | Gets or sets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets or sets the IAstNode that was matched.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch Constructor

Initializes a new instance of the AstNodeMatch class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AstNodeMatch()
Public Sub New
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch Properties

The AstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets or sets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets or sets the IAstNode that was matched.
Top
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch.Label Property

AstNodeMatchLabel Property

Gets or sets the optional label applied to the match that can be used for identification during tree construction.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set

Property Value

Type: String
The optional label applied to the match that can be used for identification during tree construction.

Implements

IAstNodeMatchLabel
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch.Node Property

AstNodeMatchNode Property

Gets or sets the IAstNode that was matched.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNode Node { get; set; }
Public Property Node As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The IAstNode that was matched.

Implements

IAstNodeMatchNode
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch Methods

The AstNodeMatch type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch.ToString Method

AstNodeMatchToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation Class

Represents an alternation expression within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfAlternation

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class EbnfAlternation : EbnfQuantifiableTerm
Public NotInheritable Class EbnfAlternation
    Inherits EbnfQuantifiableTerm

The EbnfAlternation type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfAlternation | Initializes a new instance of the EbnfAlternation class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | Productions | Gets the list of EbnfProduction objects within the alternation.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation Constructor

Initializes a new instance of the EbnfAlternation class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfAlternation(
    params EbnfProduction[] productions
)
Public Sub New (
    ParamArray productions As EbnfProduction()
)

Parameters

productions
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction
The EbnfProduction objects within the expression.
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation Properties

The EbnfAlternation type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | Productions | Gets the list of EbnfProduction objects within the alternation.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation.Productions Property

EbnfAlternationProductions Property

Gets the list of EbnfProduction objects within the alternation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<EbnfProduction> Productions { get; }
Public ReadOnly Property Productions As IList(Of EbnfProduction)
    Get

Property Value

Type: IList EbnfProduction
The list of EbnfProduction objects within the alternation.
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation Methods

The EbnfAlternation type exposes the following members.

Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation.ToString Method

EbnfAlternationToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation Class

Represents a concatenation expression within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfConcatenation

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class EbnfConcatenation : EbnfQuantifiableTerm
Public NotInheritable Class EbnfConcatenation
    Inherits EbnfQuantifiableTerm

The EbnfConcatenation type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfConcatenation | Initializes a new instance of the EbnfConcatenation class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Overrides EbnfTermLabel.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | Terms | Gets the list of EbnfTerm objects within the expression.
Top
Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation Constructor

Initializes a new instance of the EbnfConcatenation class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfConcatenation(
    params EbnfTerm[] terms
)
Public Sub New (
    ParamArray terms As EbnfTerm()
)

Parameters

terms
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
The EbnfTerm objects within the expression.
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation Properties

The EbnfConcatenation type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Overrides EbnfTermLabel.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | Terms | Gets the list of EbnfTerm objects within the expression.
Top
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation.Label Property

EbnfConcatenationLabel Property

Gets or sets the label to apply to this term that may be used when rewriting.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string Label { get; set; }
Public Overrides Property Label As String
    Get
    Set

Property Value

Type: String
The label to apply to this term that may be used when rewriting.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation.Terms Property

EbnfConcatenationTerms Property

Gets the list of EbnfTerm objects within the expression.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<EbnfTerm> Terms { get; }
Public ReadOnly Property Terms As IList(Of EbnfTerm)
    Get

Property Value

Type: IList EbnfTerm
The list of EbnfTerm objects within the expression.
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation Methods

The EbnfConcatenation type exposes the following members.

Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation.ToString Method

EbnfConcatenationToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal Class

Represents a non-terminal symbol within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfNonTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class EbnfNonTerminal : EbnfSymbol
Public NotInheritable Class EbnfNonTerminal
    Inherits EbnfSymbol

The EbnfNonTerminal type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfNonTerminal | Initializes a new instance of the EbnfNonTerminal class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | NonTerminal | Gets or sets the NonTerminal that is referenced by this term.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal Constructor

Initializes a new instance of the EbnfNonTerminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfNonTerminal(
    NonTerminal nonTerminal
)
Public Sub New (
    nonTerminal As NonTerminal
)

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that is referenced by this term.
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal Properties

The EbnfNonTerminal type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | NonTerminal | Gets or sets the NonTerminal that is referenced by this term.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal.NonTerminal Property

EbnfNonTerminalNonTerminal Property

Gets or sets the NonTerminal that is referenced by this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NonTerminal NonTerminal { get; set; }
Public Property NonTerminal As NonTerminal
    Get
    Set

Property Value

Type: NonTerminal
The NonTerminal that is referenced by this term.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal Methods

The EbnfNonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal.ToString Method

EbnfNonTerminalToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Class

Represents an EBNF production, which consists of an EbnfTerm-based pattern expression and a ITreeConstructionNode-based tree constructor.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class EbnfProduction : EbnfQuantifiableTerm
Public NotInheritable Class EbnfProduction
    Inherits EbnfQuantifiableTerm

The EbnfProduction type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfProduction(EbnfTerm) | Initializes a new instance of the EbnfProduction class.
Public method | EbnfProduction(EbnfTerm, ITreeConstructionNode) | Initializes a new instance of the EbnfProduction class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | PatternExpression | Gets or sets the EbnfTerm that is the pattern expression.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | TreeConstructor | Gets or sets the ITreeConstructionNode that specifies how to construct the syntax tree results.
Top
Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Overrides EbnfTermToProduction.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
Operators
Name | Description
BitwiseOr |
(EbnfAlternation to EbnfProduction) |
(EbnfConcatenation to EbnfProduction) |
(EbnfNonTerminal to EbnfProduction) |
(EbnfQuantifier to EbnfProduction) |
(EbnfTerminal to EbnfProduction) |
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Constructor

Overload List
 | Name | Description
Public method | EbnfProduction(EbnfTerm) | Initializes a new instance of the EbnfProduction class.
Public method | EbnfProduction(EbnfTerm, ITreeConstructionNode) | Initializes a new instance of the EbnfProduction class.
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Constructor (EbnfTerm)

Initializes a new instance of the EbnfProduction class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction(
    EbnfTerm patternExpression
)
Public Sub New (
    patternExpression As EbnfTerm
)

Parameters

patternExpression
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
The EbnfTerm that is the pattern expression.
See Also

Reference

EbnfProduction Class
EbnfProduction Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Constructor (EbnfTerm, ITreeConstructionNode)

Initializes a new instance of the EbnfProduction class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction(
    EbnfTerm patternExpression,
    ITreeConstructionNode treeConstructor
)
Public Sub New (
    patternExpression As EbnfTerm,
    treeConstructor As ITreeConstructionNode
)

Parameters

patternExpression
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
The EbnfTerm that is the pattern expression.
treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The ITreeConstructionNode that specifies how to rewrite the parse results.
See Also

Reference

EbnfProduction Class
EbnfProduction Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Properties

The EbnfProduction type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | PatternExpression | Gets or sets the EbnfTerm that is the pattern expression.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | TreeConstructor | Gets or sets the ITreeConstructionNode that specifies how to construct the syntax tree results.
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.PatternExpression Property

EbnfProductionPatternExpression Property

Gets or sets the EbnfTerm that is the pattern expression.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfTerm PatternExpression { get; set; }
Public Property PatternExpression As EbnfTerm
    Get
    Set

Property Value

Type: EbnfTerm
The EbnfTerm that is the pattern expression.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.TreeConstructor Property

EbnfProductionTreeConstructor Property

Gets or sets the ITreeConstructionNode that specifies how to construct the syntax tree results.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITreeConstructionNode TreeConstructor { get; set; }
Public Property TreeConstructor As ITreeConstructionNode
    Get
    Set

Property Value

Type: ITreeConstructionNode
The ITreeConstructionNode that specifies how to construct the syntax tree results.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Methods

The EbnfProduction type exposes the following members.

Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Overrides EbnfTermToProduction.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnComplete Method

EbnfProductionOnComplete Method

Sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction OnComplete(
    ParserCallback callback
)
Public Function OnComplete (
    callback As ParserCallback
) As EbnfProduction

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called after the term is parsed.

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnError Method

EbnfProductionOnError Method

Sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction OnError(
    ParserErrorCallback callback
)
Public Function OnError (
    callback As ParserErrorCallback
) As EbnfProduction

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnErrorContinue Method

EbnfProductionOnErrorContinue Method

Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction OnErrorContinue()
Public Function OnErrorContinue As EbnfProduction

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnErrorIgnore Method

EbnfProductionOnErrorIgnore Method

Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction OnErrorIgnore()
Public Function OnErrorIgnore As EbnfProduction

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnErrorNoReport Method

EbnfProductionOnErrorNoReport Method

Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction OnErrorNoReport()
Public Function OnErrorNoReport As EbnfProduction

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnInitialize Method

EbnfProductionOnInitialize Method

Sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction OnInitialize(
    ParserCallback callback
)
Public Function OnInitialize (
    callback As ParserCallback
) As EbnfProduction

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called before the term is parsed.

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnSuccess Method

EbnfProductionOnSuccess Method

Sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction OnSuccess(
    ParserCallback callback
)
Public Function OnSuccess (
    callback As ParserCallback
) As EbnfProduction

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called when the term is successfully parsed.

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.ToProduction Method

EbnfProductionToProduction Method

Returns an EbnfProduction for this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override EbnfProduction ToProduction()
Public Overrides Function ToProduction As EbnfProduction

Return Value

Type: EbnfProduction
An EbnfProduction for this term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.ToString Method

EbnfProductionToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Operators and Type Conversions

The EbnfProduction type exposes the following members.

Operators
Name | Description
BitwiseOr |
(EbnfAlternation to EbnfProduction) |
(EbnfConcatenation to EbnfProduction) |
(EbnfNonTerminal to EbnfProduction) |
(EbnfQuantifier to EbnfProduction) |
(EbnfTerminal to EbnfProduction) |
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.BitwiseOr Operator

EbnfProductionBitwiseOr Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    EbnfProduction left,
    EbnfProduction right
)
Public Shared Operator Or (
    left As EbnfProduction,
    right As EbnfProduction
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction)"]

See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion Operators

EbnfProduction Conversion Operators

Overload List
Name | Description
(EbnfAlternation to EbnfProduction) |
(EbnfConcatenation to EbnfProduction) |
(EbnfNonTerminal to EbnfProduction) |
(EbnfQuantifier to EbnfProduction) |
(EbnfTerminal to EbnfProduction) |
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfAlternation to EbnfProduction)

EbnfProduction Conversion (EbnfAlternation to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfAlternation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfAlternation term
)
Public Shared Widening Operator CType (
    term As EbnfAlternation
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfAlternation

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfAlternation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfAlternation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfConcatenation to EbnfProduction)

EbnfProduction Conversion (EbnfConcatenation to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfConcatenation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfConcatenation term
)
Public Shared Widening Operator CType (
    term As EbnfConcatenation
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfConcatenation

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfConcatenation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfConcatenation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfNonTerminal to EbnfProduction)

EbnfProduction Conversion (EbnfNonTerminal to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfNonTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfNonTerminal term
)
Public Shared Widening Operator CType (
    term As EbnfNonTerminal
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfNonTerminal

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfNonTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfNonTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfQuantifier to EbnfProduction)

EbnfProduction Conversion (EbnfQuantifier to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfQuantifier)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfQuantifier term
)
Public Shared Widening Operator CType (
    term As EbnfQuantifier
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifier

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfQuantifier)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfQuantifier)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfTerminal to EbnfProduction)

EbnfProduction Conversion (EbnfTerminal to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfTerminal term
)
Public Shared Widening Operator CType (
    term As EbnfTerminal
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerminal

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm Class

Represents the abstract base class for a term within an EBNF production that can be sequentially matched a specified minimum and maximum times.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfAlternation
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfConcatenation
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfSymbol

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class EbnfQuantifiableTerm : EbnfTerm
Public MustInherit Class EbnfQuantifiableTerm
    Inherits EbnfTerm

The EbnfQuantifiableTerm type exposes the following members.

Constructors
 | Name | Description
Protected method | EbnfQuantifiableTerm | Initializes a new instance of the EbnfQuantifiableTerm class
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Marks the term such that one to many instances are permitted.
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Marks the term such that zero or one instances are permitted.
Public method | Range | Marks the term such that a range of instances are permitted.
Public method | SetLabel | Sets the Label for the term.
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm Constructor

Initializes a new instance of the EbnfQuantifiableTerm class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected EbnfQuantifiableTerm()
Protected Sub New
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm Properties

The EbnfQuantifiableTerm type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm Methods

The EbnfQuantifiableTerm type exposes the following members.

Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Marks the term such that one to many instances are permitted.
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Marks the term such that zero or one instances are permitted.
Public method | Range | Marks the term such that a range of instances are permitted.
Public method | SetLabel | Sets the Label for the term.
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted.
Top
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnComplete Method

EbnfQuantifiableTermOnComplete Method

Sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnComplete(
    ParserCallback callback
)
Public Function OnComplete (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called after the term is parsed.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OneOrMore Method

EbnfQuantifiableTermOneOrMore Method

Marks the term such that one to many instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifier OneOrMore()
Public Function OneOrMore As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnError Method

EbnfQuantifiableTermOnError Method

Sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnError(
    ParserErrorCallback callback
)
Public Function OnError (
    callback As ParserErrorCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnErrorContinue Method

EbnfQuantifiableTermOnErrorContinue Method

Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorContinue()
Public Function OnErrorContinue As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnErrorIgnore Method

EbnfQuantifiableTermOnErrorIgnore Method

Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorIgnore()
Public Function OnErrorIgnore As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnErrorNoReport Method

EbnfQuantifiableTermOnErrorNoReport Method

Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorNoReport()
Public Function OnErrorNoReport As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnInitialize Method

EbnfQuantifiableTermOnInitialize Method

Sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnInitialize(
    ParserCallback callback
)
Public Function OnInitialize (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called before the term is parsed.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnSuccess Method

EbnfQuantifiableTermOnSuccess Method

Sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnSuccess(
    ParserCallback callback
)
Public Function OnSuccess (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called when the term is successfully parsed.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.Optional Method

EbnfQuantifiableTermOptional Method

Marks the term such that zero or one instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifier Optional()
Public Function Optional As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.Range Method

EbnfQuantifiableTermRange Method

Marks the term such that a range of instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifier Range(
    int min,
    Nullable<int> max
)
Public Function Range (
    min As Integer,
    max As Nullable(Of Integer)
) As EbnfQuantifier

Parameters

min
Type: SystemInt32
The minimum number of instances.
max
Type: SystemNullable Int32
The maximum number of instances.

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.SetLabel Method

EbnfQuantifiableTermSetLabel Method

Sets the Label for the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm SetLabel(
    string label
)
Public Function SetLabel (
    label As String
) As EbnfQuantifiableTerm

Parameters

label
Type: SystemString
The Label for the term.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.ZeroOrMore Method

EbnfQuantifiableTermZeroOrMore Method

Marks the term such that zero to many instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifier ZeroOrMore()
Public Function ZeroOrMore As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier Class

Represents a term within an EBNF production whose child term can be sequentially matched a specified minimum and maximum times.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifier

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class EbnfQuantifier : EbnfTerm
Public NotInheritable Class EbnfQuantifier
    Inherits EbnfTerm

The EbnfQuantifier type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfQuantifier | Initializes a new instance of the EbnfQuantifier class.
Top
Properties
 | Name | Description
Public property | Child | Gets or sets the EbnfQuantifiableTerm that is quantified by this term.
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | Maximum | Gets or sets the maximum number of instances that the term may occur.
Public property | Minimum | Gets or sets the minimum number of instances that the term may occur.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public method | SetLabel | Sets the Label for the term. (Overrides EbnfTermSetLabel(String).)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier Constructor

Initializes a new instance of the EbnfQuantifier class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifier(
    EbnfQuantifiableTerm child,
    int minimum,
    Nullable<int> maximum
)
Public Sub New (
    child As EbnfQuantifiableTerm,
    minimum As Integer,
    maximum As Nullable(Of Integer)
)

Parameters

child
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
The EbnfQuantifiableTerm to quantify.
minimum
Type: SystemInt32
The minimum number of instances that the term may occur.
maximum
Type: SystemNullable Int32
The maximum number of instances that the term may occur.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier Properties

The EbnfQuantifier type exposes the following members.

Properties
 | Name | Description
Public property | Child | Gets or sets the EbnfQuantifiableTerm that is quantified by this term.
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | Maximum | Gets or sets the maximum number of instances that the term may occur.
Public property | Minimum | Gets or sets the minimum number of instances that the term may occur.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.Child Property

EbnfQuantifierChild Property

Gets or sets the EbnfQuantifiableTerm that is quantified by this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm Child { get; set; }
Public Property Child As EbnfQuantifiableTerm
    Get
    Set

Property Value

Type: EbnfQuantifiableTerm
The EbnfQuantifiableTerm that is quantified by this term.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.Maximum Property

EbnfQuantifierMaximum Property

Gets or sets the maximum number of instances that the term may occur.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> Maximum { get; set; }
Public Property Maximum As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The maximum number of instances that the term may occur.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.Minimum Property

EbnfQuantifierMinimum Property

Gets or sets the minimum number of instances that the term may occur.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set

Property Value

Type: Int32
The minimum number of instances that the term may occur.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier Methods

The EbnfQuantifier type exposes the following members.

Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public method | SetLabel | Sets the Label for the term. (Overrides EbnfTermSetLabel(String).)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.SetLabel Method

EbnfQuantifierSetLabel Method

Sets the Label for the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override EbnfTerm SetLabel(
    string newLabel
)
Public Overrides Function SetLabel (
    newLabel As String
) As EbnfTerm

Parameters

newLabel
Type: SystemString
The Label for the term.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.ToString Method

EbnfQuantifierToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfSymbol Class

Represents the abstract base class for a symbol within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfNonTerminal
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class EbnfSymbol : EbnfQuantifiableTerm
Public MustInherit Class EbnfSymbol
    Inherits EbnfQuantifiableTerm

The EbnfSymbol type exposes the following members.

Constructors
 | Name | Description
Protected method | EbnfSymbol | Initializes a new instance of the EbnfSymbol class
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfSymbol Constructor

Initializes a new instance of the EbnfSymbol class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected EbnfSymbol()
Protected Sub New
See Also

Reference

EbnfSymbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfSymbol Properties

The EbnfSymbol type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfSymbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfSymbol Methods

The EbnfSymbol type exposes the following members.

Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfSymbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Class

Represents the abstract base class for a term within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifier

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class EbnfTerm
Public MustInherit Class EbnfTerm

The EbnfTerm type exposes the following members.

Constructors
 | Name | Description
Protected method | EbnfTerm | Initializes a new instance of the EbnfTerm class
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term.
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting.
Public property | MatchCondition | Gets the IMatchCondition to use for this term.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed.
Top
Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | SetLabel | Sets the Label for the term.
Public method | ToEbnfString | Outputs the contents of the term in EBNF form.
Public method | ToProduction | Returns an EbnfProduction for this term.
Top
Operators
Name | Description
Addition |
BitwiseOr |
GreaterThan |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Constructor

Initializes a new instance of the EbnfTerm class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected EbnfTerm()
Protected Sub New
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Properties

The EbnfTerm type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term.
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting.
Public property | MatchCondition | Gets the IMatchCondition to use for this term.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed.
Top
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.CompleteCallback Property

EbnfTermCompleteCallback Property

Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParserCallback CompleteCallback { get; set; }
Public Property CompleteCallback As ParserCallback
    Get
    Set

Property Value

Type: ParserCallback
The delegate that will be called after the term is parsed.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.ErrorCallback Property

EbnfTermErrorCallback Property

Gets or sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParserErrorCallback ErrorCallback { get; set; }
Public Property ErrorCallback As ParserErrorCallback
    Get
    Set

Property Value

Type: ParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.InitializeCallback Property

EbnfTermInitializeCallback Property

Gets or sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParserCallback InitializeCallback { get; set; }
Public Property InitializeCallback As ParserCallback
    Get
    Set

Property Value

Type: ParserCallback
The delegate that will be called before the term is parsed.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.IsCompiled Property

EbnfTermIsCompiled Property

Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCompiled { get; }
Public ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.Label Property

EbnfTermLabel Property

Gets or sets the label to apply to this term that may be used when rewriting.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string Label { get; set; }
Public Overridable Property Label As String
    Get
    Set

Property Value

Type: String
The label to apply to this term that may be used when rewriting.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.MatchCondition Property

EbnfTermMatchCondition Property

Gets the IMatchCondition to use for this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IMatchCondition MatchCondition { get; }
Public ReadOnly Property MatchCondition As IMatchCondition
    Get

Property Value

Type: IMatchCondition
The IMatchCondition to use for this term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.SuccessCallback Property

EbnfTermSuccessCallback Property

Gets or sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParserCallback SuccessCallback { get; set; }
Public Property SuccessCallback As ParserCallback
    Get
    Set

Property Value

Type: ParserCallback
The delegate that will be called when the term is successfully parsed.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Methods

The EbnfTerm type exposes the following members.

Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | SetLabel | Sets the Label for the term.
Public method | ToEbnfString | Outputs the contents of the term in EBNF form.
Public method | ToProduction | Returns an EbnfProduction for this term.
Top
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnComplete Method

EbnfTermOnComplete Method

Sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfTerm OnComplete(
    ParserCallback callback
)
Public Function OnComplete (
    callback As ParserCallback
) As EbnfTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called after the term is parsed.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnError Method

EbnfTermOnError Method

Sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfTerm OnError(
    ParserErrorCallback callback
)
Public Function OnError (
    callback As ParserErrorCallback
) As EbnfTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnErrorContinue Method

EbnfTermOnErrorContinue Method

Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfTerm OnErrorContinue()
Public Function OnErrorContinue As EbnfTerm

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnErrorIgnore Method

EbnfTermOnErrorIgnore Method

Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfTerm OnErrorIgnore()
Public Function OnErrorIgnore As EbnfTerm

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnErrorNoReport Method

EbnfTermOnErrorNoReport Method

Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfTerm OnErrorNoReport()
Public Function OnErrorNoReport As EbnfTerm

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnInitialize Method

EbnfTermOnInitialize Method

Sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfTerm OnInitialize(
    ParserCallback callback
)
Public Function OnInitialize (
    callback As ParserCallback
) As EbnfTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called before the term is parsed.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnSuccess Method

EbnfTermOnSuccess Method

Sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfTerm OnSuccess(
    ParserCallback callback
)
Public Function OnSuccess (
    callback As ParserCallback
) As EbnfTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called when the term is successfully parsed.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.SetLabel Method

EbnfTermSetLabel Method

Sets the Label for the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual EbnfTerm SetLabel(
    string newLabel
)
Public Overridable Function SetLabel (
    newLabel As String
) As EbnfTerm

Parameters

newLabel
Type: SystemString
The Label for the term.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.ToEbnfString Method

EbnfTermToEbnfString Method

Outputs the contents of the term in EBNF form.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ToEbnfString()
Public Function ToEbnfString As String

Return Value

Type: String
A string containing the EBNF form of the term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.ToProduction Method

EbnfTermToProduction Method

Returns an EbnfProduction for this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual EbnfProduction ToProduction()
Public Overridable Function ToProduction As EbnfProduction

Return Value

Type: EbnfProduction
An EbnfProduction for this term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Operators

The EbnfTerm type exposes the following members.

Operators
Name | Description
Addition |
BitwiseOr |
GreaterThan |
LessThan |
Top
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.Addition Operator

EbnfTermAddition Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfConcatenation operator +(
    EbnfTerm left,
    EbnfTerm right
)
Public Shared Operator + (
    left As EbnfTerm,
    right As EbnfTerm
) As EbnfConcatenation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Return Value

Type: EbnfConcatenation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.BitwiseOr Operator

EbnfTermBitwiseOr Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    EbnfTerm left,
    EbnfTerm right
)
Public Shared Operator Or (
    left As EbnfTerm,
    right As EbnfTerm
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.GreaterThan Operator

EbnfTermGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfProduction operator >(
    EbnfTerm term,
    ITreeConstructionNode treeConstructor
)
Public Shared Operator > (
    term As EbnfTerm,
    treeConstructor As ITreeConstructionNode
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode

[Missing <param name="treeConstructor"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.LessThan Operator

EbnfTermLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfProduction operator <(
    EbnfTerm term,
    ITreeConstructionNode treeConstructor
)
Public Shared Operator < (
    term As EbnfTerm,
    treeConstructor As ITreeConstructionNode
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode

[Missing <param name="treeConstructor"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal Class

Represents a terminal symbol within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class EbnfTerminal : EbnfSymbol
Public NotInheritable Class EbnfTerminal
    Inherits EbnfSymbol

The EbnfTerminal type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfTerminal | Initializes a new instance of the EbnfTerminal class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | Terminal | Gets or sets the Terminal that is referenced by this term.
Top
Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal Constructor

Initializes a new instance of the EbnfTerminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfTerminal(
    Terminal terminal
)
Public Sub New (
    terminal As Terminal
)

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that is referenced by this term.
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal Properties

The EbnfTerminal type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | Terminal | Gets or sets the Terminal that is referenced by this term.
Top
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal.Terminal Property

EbnfTerminalTerminal Property

Gets or sets the Terminal that is referenced by this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Terminal Terminal { get; set; }
Public Property Terminal As Terminal
    Get
    Set

Property Value

Type: Terminal
The Terminal that is referenced by this term.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal Methods

The EbnfTerminal type exposes the following members.

Methods
 | Name | Description
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal.ToString Method

EbnfTerminalToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar Class

Represents a grammar that can be used with a recursive descent parser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptGrammar
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonGrammar
ActiproSoftware.Text.Languages.Python.ImplementationPythonGrammar
ActiproSoftware.Text.Languages.Xml.ImplementationXmlGrammar

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Grammar : IKeyedObject
Public Class Grammar
    Implements IKeyedObject

The Grammar type exposes the following members.

Constructors
 | Name | Description
Public method | Grammar | Initializes a new instance of the Grammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Key | Gets the string that identifies the grammar, generally the related language name.
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key.
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins.
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key.
Top
Methods
 | Name | Description
 | Ast(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes.
 | AstTAstNode | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type.
 | AstChildFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the first child of an IAstNodeMatch that has the specified label.
 | AstChildFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the specified child of an IAstNodeMatch that has the specified label.
 | AstChildrenFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the children of an IAstNodeMatch that has the specified label.
 | AstChildrenFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the descendants at the specified nesting level of an IAstNodeMatch that has the specified label, useful for gathering desired nodes two or more levels deep.
 | AstConditional(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
 | AstConditionalTAstNode(ITreeConstructionNode) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type, but only if there is more than one child available. If one child is available, it is directly returned.
 | AstConditionalFrom | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and child nodes from the children of an IAstNodeMatch that has the specified label, but only if there is at least one child available.
 | AstCount | Creates an ITreeConstructionNode that generates an IAstNode whose value is the count of IAstNode objects generated by contained nodes.
 | AstFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from an IAstNodeMatch that has the specified label.
 | AstFromTAstNode(String) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type from an IAstNodeMatch that has the specified label.
 | AstLeftAssociativityTAstNode, TDerivedAstNode | Creates an ITypedTreeConstructionNodeTAstNode that attempts to make a child node left associative instead of right associative, useful for scenarios such as binary operators.
 | AstValueOf | Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes.
 | AstValueOfConditional | Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
 | CanAlwaysMatch | Implements a ParserCanMatchCallback that always returns true, and is useful for assigning to non-terminals that are called from the Root non-terminal for a Grammar.
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage.
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form.
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar Constructor

Initializes a new instance of the Grammar class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Grammar(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the grammar, generally the related language name.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar Properties

The Grammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Key | Gets the string that identifies the grammar, generally the related language name.
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key.
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins.
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.IsCompiled Property

GrammarIsCompiled Property

Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCompiled { get; }
Public ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Key Property

GrammarKey Property

Gets the string that identifies the grammar, generally the related language name.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The string that identifies the grammar, generally the related language name.

Implements

IKeyedObjectKey
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.NonTerminals Property

GrammarNonTerminals Property

Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDictionary<string, NonTerminal> NonTerminals { get; }
Public ReadOnly Property NonTerminals As IDictionary(Of String, NonTerminal)
    Get

Property Value

Type: IDictionary String, NonTerminal
A dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key.
Remarks
This property returns until the grammar has been compiled.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Root Property

GrammarRoot Property

Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NonTerminal Root { get; set; }
Public Property Root As NonTerminal
    Get
    Set

Property Value

Type: NonTerminal
The root NonTerminal of the grammar.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Terminals Property

GrammarTerminals Property

Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDictionary<string, Terminal> Terminals { get; }
Public ReadOnly Property Terminals As IDictionary(Of String, Terminal)
    Get

Property Value

Type: IDictionary String, Terminal
A dictionary of all terminals defined in the grammar, with the key being the terminal string key.
Remarks
This property returns until the grammar has been compiled.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar Methods

The Grammar type exposes the following members.

Methods
 | Name | Description
 | Ast(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes.
 | AstTAstNode | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type.
 | AstChildFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the first child of an IAstNodeMatch that has the specified label.
 | AstChildFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the specified child of an IAstNodeMatch that has the specified label.
 | AstChildrenFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the children of an IAstNodeMatch that has the specified label.
 | AstChildrenFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the descendants at the specified nesting level of an IAstNodeMatch that has the specified label, useful for gathering desired nodes two or more levels deep.
 | AstConditional(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
 | AstConditionalTAstNode(ITreeConstructionNode) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type, but only if there is more than one child available. If one child is available, it is directly returned.
 | AstConditionalFrom | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and child nodes from the children of an IAstNodeMatch that has the specified label, but only if there is at least one child available.
 | AstCount | Creates an ITreeConstructionNode that generates an IAstNode whose value is the count of IAstNode objects generated by contained nodes.
 | AstFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from an IAstNodeMatch that has the specified label.
 | AstFromTAstNode(String) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type from an IAstNodeMatch that has the specified label.
 | AstLeftAssociativityTAstNode, TDerivedAstNode | Creates an ITypedTreeConstructionNodeTAstNode that attempts to make a child node left associative instead of right associative, useful for scenarios such as binary operators.
 | AstValueOf | Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes.
 | AstValueOfConditional | Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
 | CanAlwaysMatch | Implements a ParserCanMatchCallback that always returns true, and is useful for assigning to non-terminals that are called from the Root non-terminal for a Grammar.
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage.
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form.
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Ast Method

GrammarAst Method

Overload List
Name | Description
AstTAstNode | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type.
Ast(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Ast(TAstNode) Method

GrammarAstTAstNode Method

Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITypedTreeConstructionNode<TAstNode> Ast<TAstNode>()
where TAstNode : class, new(), IAstNode

Public Shared Function Ast(Of TAstNode As {Class, New, IAstNode}) As ITypedTreeConstructionNode(Of TAstNode)

Type Parameters

TAstNode
The type of IAstNode-based class to create.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode that was created.
See Also

Reference

Grammar Class
Ast Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Ast Method (String, ITreeConstructionNode[])

GrammarAst Method (String, ITreeConstructionNode)

Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode Ast(
    string value,
    params ITreeConstructionNode[] childNodes
)
Public Shared Function Ast (
    value As String,
    ParamArray childNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

value
Type: SystemString
The value to assign to the generated IAstNode.
childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
Ast Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildFrom Method

GrammarAstChildFrom Method

Overload List
Name | Description
AstChildFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the first child of an IAstNodeMatch that has the specified label.
AstChildFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the specified child of an IAstNodeMatch that has the specified label.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildFrom Method (String)

GrammarAstChildFrom Method (String)

Creates an ITreeConstructionNode that generates an IAstNode from the first child of an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstChildFrom(
    string label
)
Public Shared Function AstChildFrom (
    label As String
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstChildFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildFrom Method (String, Int32)

GrammarAstChildFrom Method (String, Int32)

Creates an ITreeConstructionNode that generates an IAstNode from the specified child of an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstChildFrom(
    string label,
    int childIndex
)
Public Shared Function AstChildFrom (
    label As String,
    childIndex As Integer
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.
childIndex
Type: SystemInt32
The index of the child.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstChildFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildrenFrom Method

GrammarAstChildrenFrom Method

Overload List
Name | Description
AstChildrenFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the children of an IAstNodeMatch that has the specified label.
AstChildrenFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the descendants at the specified nesting level of an IAstNodeMatch that has the specified label, useful for gathering desired nodes two or more levels deep.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildrenFrom Method (String)

GrammarAstChildrenFrom Method (String)

Creates an ITreeConstructionNode that generates an IAstNode from the children of an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstChildrenFrom(
    string label
)
Public Shared Function AstChildrenFrom (
    label As String
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstChildrenFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildrenFrom Method (String, Int32)

GrammarAstChildrenFrom Method (String, Int32)

Creates an ITreeConstructionNode that generates an IAstNode from the descendants at the specified nesting level of an IAstNodeMatch that has the specified label, useful for gathering desired nodes two or more levels deep.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstChildrenFrom(
    string label,
    int nestingLevel
)
Public Shared Function AstChildrenFrom (
    label As String,
    nestingLevel As Integer
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.
nestingLevel
Type: SystemInt32
The zero-based target nesting level, where 0 means direct children.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstChildrenFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstConditional Method

GrammarAstConditional Method

Overload List
Name | Description
AstConditionalTAstNode(ITreeConstructionNode) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type, but only if there is more than one child available. If one child is available, it is directly returned.
AstConditional(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstConditional(TAstNode) Method (ITreeConstructionNode[])

GrammarAstConditionalTAstNode Method (ITreeConstructionNode)

Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type, but only if there is more than one child available. If one child is available, it is directly returned.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITypedTreeConstructionNode<TAstNode> AstConditional<TAstNode>(
    params ITreeConstructionNode[] childNodes
)
where TAstNode : class, new(), IAstNode

Public Shared Function AstConditional(Of TAstNode As {Class, New, IAstNode}) (
    ParamArray childNodes As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TAstNode

[Missing <typeparam name="TAstNode"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Grammar.AstConditional``1(ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode[])"]

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode that was created.
See Also

Reference

Grammar Class
AstConditional Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstConditional Method (String, ITreeConstructionNode[])

GrammarAstConditional Method (String, ITreeConstructionNode)

Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstConditional(
    string value,
    params ITreeConstructionNode[] childNodes
)
Public Shared Function AstConditional (
    value As String,
    ParamArray childNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

value
Type: SystemString
The value to assign to the generated IAstNode.
childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstConditional Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstConditionalFrom Method

GrammarAstConditionalFrom Method

Creates an ITreeConstructionNode that generates an IAstNode with the specified value and child nodes from the children of an IAstNodeMatch that has the specified label, but only if there is at least one child available.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstConditionalFrom(
    string value,
    string label
)
Public Shared Function AstConditionalFrom (
    value As String,
    label As String
) As ITreeConstructionNode

Parameters

value
Type: SystemString
The value to assign to the generated IAstNode.
label
Type: SystemString
The IAstNodeMatch for which to search.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstCount Method

GrammarAstCount Method

Creates an ITreeConstructionNode that generates an IAstNode whose value is the count of IAstNode objects generated by contained nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstCount(
    params ITreeConstructionNode[] countNodes
)
Public Shared Function AstCount (
    ParamArray countNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

countNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstFrom Method

GrammarAstFrom Method

Overload List
Name | Description
AstFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from an IAstNodeMatch that has the specified label.
AstFromTAstNode(String) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type from an IAstNodeMatch that has the specified label.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstFrom Method (String)

GrammarAstFrom Method (String)

Creates an ITreeConstructionNode that generates an IAstNode from an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstFrom(
    string label
)
Public Shared Function AstFrom (
    label As String
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstFrom(TAstNode) Method (String)

GrammarAstFromTAstNode Method (String)

Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type from an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITypedTreeConstructionNode<TAstNode> AstFrom<TAstNode>(
    string label
)
where TAstNode : class, IAstNode

Public Shared Function AstFrom(Of TAstNode As {Class, IAstNode}) (
    label As String
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.

Type Parameters

TAstNode
The type of IAstNode-based class to create.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode that was created.
See Also

Reference

Grammar Class
AstFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstLeftAssociativity(TAstNode, TDerivedAstNode) Method

GrammarAstLeftAssociativityTAstNode, TDerivedAstNode Method

Creates an ITypedTreeConstructionNodeTAstNode that attempts to make a child node left associative instead of right associative, useful for scenarios such as binary operators.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITypedTreeConstructionNode<TAstNode> AstLeftAssociativity<TAstNode, TDerivedAstNode>(
    ITreeConstructionNode childNode,
    Expression<Func<TDerivedAstNode, TAstNode>> leftPropExpression,
    Expression<Func<TDerivedAstNode, TAstNode>> rightPropExpression,
    Func<TDerivedAstNode, TDerivedAstNode, bool> condition
)
where TAstNode : class, IAstNode
where TDerivedAstNode : class, TAstNode

Public Shared Function AstLeftAssociativity(Of TAstNode As {Class, IAstNode}, TDerivedAstNode As {Class, TAstNode}) (
    childNode As ITreeConstructionNode,
    leftPropExpression As Expression(Of Func(Of TDerivedAstNode, TAstNode)),
    rightPropExpression As Expression(Of Func(Of TDerivedAstNode, TAstNode)),
    condition As Func(Of TDerivedAstNode, TDerivedAstNode, Boolean)
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

childNode
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The child ITreeConstructionNode object.
leftPropExpression
Type: System.Linq.ExpressionsExpression Func TDerivedAstNode, TAstNode
The lambda expression indicating the property for the left side branch.
rightPropExpression
Type: System.Linq.ExpressionsExpression Func TDerivedAstNode, TAstNode
The lambda expression indicating the property for the right side branch.
condition
Type: SystemFunc TDerivedAstNode, TDerivedAstNode, Boolean
The optional lambda expression that is passed both the root and child nodes and returns true if the associativity change is permitted.

Type Parameters

TAstNode
The type of IAstNode-based class to return.
TDerivedAstNode
The type of IAstNode (that must inherit TAstNode) that supports associativity.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstValueOf Method

GrammarAstValueOf Method

Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstValueOf(
    ITreeConstructionNode valueOfNode,
    params ITreeConstructionNode[] childNodes
)
Public Shared Function AstValueOf (
    valueOfNode As ITreeConstructionNode,
    ParamArray childNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

valueOfNode
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The ITreeConstructionNode whose constructed IAstNode value will be used.
childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstValueOfConditional Method

GrammarAstValueOfConditional Method

Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstValueOfConditional(
    ITreeConstructionNode valueOfNode,
    params ITreeConstructionNode[] childNodes
)
Public Shared Function AstValueOfConditional (
    valueOfNode As ITreeConstructionNode,
    ParamArray childNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

valueOfNode
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The ITreeConstructionNode whose constructed IAstNode value will be used.
childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.CanAlwaysMatch Method

GrammarCanAlwaysMatch Method

Implements a ParserCanMatchCallback that always returns true, and is useful for assigning to non-terminals that are called from the Root non-terminal for a Grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool CanAlwaysMatch(
    IParserState state
)
Public Shared Function CanAlwaysMatch (
    state As IParserState
) As Boolean

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
A IParserState that provides information about the parser's current state.

Return Value

Type: Boolean
Always true.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Compile Method

GrammarCompile Method

Compiles the grammar, which prepares the grammar and its elements for parsing usage.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Compile()
Public Sub Compile
Remarks
Compiling the grammar also means that all elements of the language will be locked and no longer able to be modified.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.ToEbnfString Method

GrammarToEbnfString Method

Outputs the contents of the grammar in EBNF form.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ToEbnfString()
Public Function ToEbnfString As String

Return Value

Type: String
A string containing the EBNF form of the grammar.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Validate Method

GrammarValidate Method

Validates that the grammar and its elements are configured correctly and ready to be compiled.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Validate()
Public Sub Validate
Remarks
An exception will be thrown if validation fails.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData Class

Stores the results of a ILLParser parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParseData
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParseData
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParseData
ActiproSoftware.Text.Languages.Python.ImplementationPythonParseData
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParseData

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LLParseData : IParseData,
    ILLParseData, IParseErrorProvider
Public Class LLParseData
    Implements IParseData, ILLParseData, IParseErrorProvider

The LLParseData type exposes the following members.

Constructors
 | Name | Description
Public method | LLParseData | Initializes a new instance of the LLParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result.
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData Constructor

Initializes a new instance of the LLParseData class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LLParseData()
Public Sub New
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData Properties

The LLParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result.
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created.
Top
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData.Ast Property

LLParseDataAst Property

Gets or sets the object that contains the abstract syntax tree result.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNode Ast { get; set; }
Public Property Ast As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The object that contains the abstract syntax tree result.

Implements

ILLParseDataAst
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData.Errors Property

LLParseDataErrors Property

Gets or sets the collection of IParseError objects that specify parse errors.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<IParseError> Errors { get; set; }
Public Property Errors As IEnumerable(Of IParseError)
    Get
    Set

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that specify parse errors.

Implements

IParseErrorProviderErrors
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData.Snapshot Property

LLParseDataSnapshot Property

Gets the ITextSnapshot, if known, from which the parse errors were created.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; set; }
Public Property Snapshot As ITextSnapshot
    Get
    Set

Property Value

Type: ITextSnapshot
The ITextSnapshot, if known, from which the parse errors were created.

Implements

IParseErrorProviderSnapshot
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase Class

Represents the base class for an IParser that executes based on a Grammar definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParserBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParser
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParser
ActiproSoftware.Text.Languages.Python.ImplementationPythonParser
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParserBase

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LLParserBase : ParserBase,
    ILLParser, IParser, IKeyedObject
Public MustInherit Class LLParserBase
    Inherits ParserBase
    Implements ILLParser, IParser, IKeyedObject

The LLParserBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LLParserBase | Initializes a new instance of the LLParserBase class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser.
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState, after the parse operation has completed.
Protected method | CreateParserState | Creates an IParserState for a parse operation.
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens.
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState.
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Overrides ParserBaseParse(IParseRequest).)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase Constructor

Initializes a new instance of the LLParserBase class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LLParserBase(
    Grammar grammar
)
Protected Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar to use.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase Properties

The LLParserBase type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser.
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.Grammar Property

LLParserBaseGrammar Property

Gets the Grammar that is used by this parser.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Grammar Grammar { get; }
Public ReadOnly Property Grammar As Grammar
    Get

Property Value

Type: Grammar
The Grammar that is used by this parser.

Implements

ILLParserGrammar
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase Methods

The LLParserBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState, after the parse operation has completed.
Protected method | CreateParserState | Creates an IParserState for a parse operation.
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens.
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState.
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Overrides ParserBaseParse(IParseRequest).)
Top
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.CreateParseData Method

LLParserBaseCreateParseData Method

Creates an IParseData for the specified IParserState, after the parse operation has completed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overridable Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.CreateParserState Method

LLParserBaseCreateParserState Method

Creates an IParserState for a parse operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IParserState CreateParserState(
    ITokenReader tokenReader,
    IAstNodeBuilder astNodeBuilder,
    ITextSnapshot snapshot
)
Protected Overridable Function CreateParserState (
    tokenReader As ITokenReader,
    astNodeBuilder As IAstNodeBuilder,
    snapshot As ITextSnapshot
) As IParserState

Parameters

tokenReader
Type: ActiproSoftware.Text.Parsing.LLParserITokenReader
The ITokenReader that is used to read tokens during the parsing operation.
astNodeBuilder
Type: ActiproSoftware.Text.Parsing.LLParserIAstNodeBuilder
The IAstNodeBuilder to use for constructing AST node results
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot used to initiate the parsing operation, if known.

Return Value

Type: IParserState
The IParserState that was created.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.CreateTokenReader Method

LLParserBaseCreateTokenReader Method

Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public MustOverride Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.InitializeParseData Method

LLParserBaseInitializeParseData Method

Initializes a LLParseData using the specified IParserState.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void InitializeParseData(
    LLParseData parseData,
    IParserState state
)
Protected Overridable Sub InitializeParseData (
    parseData As LLParseData,
    state As IParserState
)

Parameters

parseData
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
The LLParseData to initialize.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.
Remarks
This method is called by default from the CreateParseData(IParseRequest, IParserState) method.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.InitializeParserState Method

LLParserBaseInitializeParserState Method

Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overridable Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.Parse Method

LLParserBaseParse Method

Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IParseData Parse(
    IParseRequest request
)
Public Overrides Function Parse (
    request As IParseRequest
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.

Return Value

Type: IParseData
An IParseData that is the result of the parsing operation.

Implements

IParserParse(IParseRequest)
IParserParse(IParseRequest)
Remarks
A IParseRequestDispatcher typically calls this method when a queued parse request is ready to be processed.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader Class

Represents an object that can provide tokens to a ILLParser in a forward-only direction for a IMergableLexer.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenReader
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenReader
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenReader
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenReader
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenReader

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MergableTokenReader : TokenReaderBase
Public Class MergableTokenReader
    Inherits TokenReaderBase

The MergableTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | MergableTokenReader | Initializes a new instance of the MergableTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides TokenReaderBaseGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Overrides TokenReaderBasePop.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Overrides TokenReaderBasePush.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader Constructor

Initializes a new instance of the MergableTokenReader class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MergableTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader Properties

The MergableTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader Methods

The MergableTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides TokenReaderBaseGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Overrides TokenReaderBasePop.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Overrides TokenReaderBasePush.)
Top
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader.GetNextToken Method

MergableTokenReaderGetNextToken Method

Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader.Pop Method

MergableTokenReaderPop Method

Pops the top token reader state from the stack and restores the token reader to that state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Pop()
Public Overrides Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITokenReaderPop
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader.Push Method

MergableTokenReaderPush Method

Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Push()
Public Overrides Sub Push

Implements

ITokenReaderPush
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal Class

Represents a non-terminal symbol within a grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NonTerminal : Symbol
Public Class NonTerminal
    Inherits Symbol

The NonTerminal type exposes the following members.

Constructors
 | Name | Description
Public method | NonTerminal | Initializes a new instance of the NonTerminal class.
Top
Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse. (Inherited from Symbol.)
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors. (Inherited from Symbol.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Symbol.)
Public property | Key | Gets or sets the string that identifies the symbol. (Inherited from Symbol.)
Public property | Production | Gets or sets the EbnfProduction for this non-terminal.
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol. (Inherited from Symbol.)
Top
Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token. (Inherited from Symbol.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from Symbol.)
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted. (Inherited from Symbol.)
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term. (Inherited from Symbol.)
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from Symbol.)
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed. (Inherited from Symbol.)
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed. (Inherited from Symbol.)
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted. (Inherited from Symbol.)
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted. (Inherited from Symbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Symbol.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted. (Inherited from Symbol.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal Constructor

Initializes a new instance of the NonTerminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NonTerminal(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the symbol.
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal Properties

The NonTerminal type exposes the following members.

Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse. (Inherited from Symbol.)
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors. (Inherited from Symbol.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Symbol.)
Public property | Key | Gets or sets the string that identifies the symbol. (Inherited from Symbol.)
Public property | Production | Gets or sets the EbnfProduction for this non-terminal.
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol. (Inherited from Symbol.)
Top
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal.Production Property

NonTerminalProduction Property

Gets or sets the EbnfProduction for this non-terminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfProduction Production { get; set; }
Public Property Production As EbnfProduction
    Get
    Set

Property Value

Type: EbnfProduction
The EbnfProduction for this non-terminal.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal Methods

The NonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token. (Inherited from Symbol.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from Symbol.)
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted. (Inherited from Symbol.)
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term. (Inherited from Symbol.)
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from Symbol.)
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed. (Inherited from Symbol.)
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed. (Inherited from Symbol.)
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted. (Inherited from Symbol.)
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted. (Inherited from Symbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Symbol.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted. (Inherited from Symbol.)
Top
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal.ToTerm Method

NonTerminalToTerm Method

Overload List
 | Name | Description
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Top
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal.ToTerm Method (String)

NonTerminalToTerm Method (String)

Wraps this symbol with a labeled EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override EbnfSymbol ToTerm(
    string label
)
Public Overrides Function ToTerm (
    label As String
) As EbnfSymbol

Parameters

label
Type: SystemString
The string label to use.

Return Value

Type: EbnfSymbol
The EbnfSymbol that was created.
See Also

Reference

NonTerminal Class
ToTerm Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase Class

Represents an abstract ITreeConstructionNode base class that can contain child tree construction nodes.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTreeConstructionNodeBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationParentTreeConstructionNodeBase

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class ParentTreeConstructionNodeBase : TreeConstructionNodeBase
Public MustInherit Class ParentTreeConstructionNodeBase
    Inherits TreeConstructionNodeBase

The ParentTreeConstructionNodeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ParentTreeConstructionNodeBase | Initializes a new instance of the ParentTreeConstructionNodeBase class.
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of child ITreeConstructionNode objects. (Overrides TreeConstructionNodeBaseChildren.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from TreeConstructionNodeBase.)
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results. (Inherited from TreeConstructionNodeBase.)
Top
Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node. (Inherited from TreeConstructionNodeBase.)
Public method | ToEbnfString | Outputs the contents of the rewrite node in EBNF form. (Inherited from TreeConstructionNodeBase.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase Constructor

Initializes a new instance of the ParentTreeConstructionNodeBase class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ParentTreeConstructionNodeBase(
    params ITreeConstructionNode[] children
)
Protected Sub New (
    ParamArray children As ITreeConstructionNode()
)

Parameters

children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The collection of child nodes.
See Also

Reference

ParentTreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase Properties

The ParentTreeConstructionNodeBase type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of child ITreeConstructionNode objects. (Overrides TreeConstructionNodeBaseChildren.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from TreeConstructionNodeBase.)
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results. (Inherited from TreeConstructionNodeBase.)
Top
See Also

Reference

ParentTreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase.Children Property

ParentTreeConstructionNodeBaseChildren Property

Gets the collection of child ITreeConstructionNode objects.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<ITreeConstructionNode> Children { get; }
Public Overrides ReadOnly Property Children As IEnumerable(Of ITreeConstructionNode)
    Get

Property Value

Type: IEnumerable ITreeConstructionNode
The collection of child ITreeConstructionNode objects.
See Also

Reference

ParentTreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase Methods

The ParentTreeConstructionNodeBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node. (Inherited from TreeConstructionNodeBase.)
Public method | ToEbnfString | Outputs the contents of the rewrite node in EBNF form. (Inherited from TreeConstructionNodeBase.)
Top
See Also

Reference

ParentTreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState Class

Represents an object that tracks the current state of a ILLParser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationParserState

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParserState : IParserState
Public Class ParserState
    Implements IParserState

The ParserState type exposes the following members.

Constructors
 | Name | Description
Public method | ParserState | Initializes a new instance of the ParserState class.
Top
Properties
 | Name | Description
Public property | AstNodeBuilder | Gets the IAstNodeBuilder to use for constructing AST node results.
Public property | CustomData | Gets or sets custom data that can be altered during a parsing operation.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | Parser | Gets the ILLParser for which this state is tracking data.
Public property | Snapshot | Gets the ITextSnapshot used to initiate the parsing operation, if known.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Public property | UntargetableParseErrorTokenIds | Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Top
Methods
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState Constructor

Initializes a new instance of the ParserState class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParserState(
    ILLParser parser,
    ITokenReader tokenReader,
    IAstNodeBuilder astNodeBuilder,
    ITextSnapshot snapshot
)
Public Sub New (
    parser As ILLParser,
    tokenReader As ITokenReader,
    astNodeBuilder As IAstNodeBuilder,
    snapshot As ITextSnapshot
)

Parameters

parser
Type: ActiproSoftware.Text.Parsing.LLParserILLParser
The ILLParser for which this state is tracking data.
tokenReader
Type: ActiproSoftware.Text.Parsing.LLParserITokenReader
The ITokenReader that is used to read tokens during the parsing operation.
astNodeBuilder
Type: ActiproSoftware.Text.Parsing.LLParserIAstNodeBuilder
The IAstNodeBuilder to use for constructing AST node results
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot used to initiate the parsing operation, if known.
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState Properties

The ParserState type exposes the following members.

Properties
 | Name | Description
Public property | AstNodeBuilder | Gets the IAstNodeBuilder to use for constructing AST node results.
Public property | CustomData | Gets or sets custom data that can be altered during a parsing operation.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | Parser | Gets the ILLParser for which this state is tracking data.
Public property | Snapshot | Gets the ITextSnapshot used to initiate the parsing operation, if known.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Public property | UntargetableParseErrorTokenIds | Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.AstNodeBuilder Property

ParserStateAstNodeBuilder Property

Gets the IAstNodeBuilder to use for constructing AST node results.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IAstNodeBuilder AstNodeBuilder { get; }
Public ReadOnly Property AstNodeBuilder As IAstNodeBuilder
    Get

Property Value

Type: IAstNodeBuilder
The IAstNodeBuilder to use for constructing AST node results.

Implements

IParserStateAstNodeBuilder
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.CustomData Property

ParserStateCustomData Property

Gets or sets custom data that can be altered during a parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object CustomData { get; set; }
Public Property CustomData As Object
    Get
    Set

Property Value

Type: Object
Custom data that can be altered during a parsing operation.

Implements

IParserStateCustomData
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ParseErrors Property

ParserStateParseErrors Property

Gets the collection of IParseError objects that will be returned in the IParseData parsing result.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<IParseError> ParseErrors { get; }
Public ReadOnly Property ParseErrors As IEnumerable(Of IParseError)
    Get

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that will be returned in the IParseData parsing result.

Implements

IParserStateParseErrors
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.Parser Property

ParserStateParser Property

Gets the ILLParser for which this state is tracking data.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILLParser Parser { get; }
Public ReadOnly Property Parser As ILLParser
    Get

Property Value

Type: ILLParser
The ILLParser for which this state is tracking data

Implements

IParserStateParser
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.Snapshot Property

ParserStateSnapshot Property

Gets the ITextSnapshot used to initiate the parsing operation, if known.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; }
Public ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot used to initiate the parsing operation, if known.

Implements

IParserStateSnapshot
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.TokenReader Property

ParserStateTokenReader Property

Gets the ITokenReader that is used to read tokens during the parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITokenReader TokenReader { get; }
Public ReadOnly Property TokenReader As ITokenReader
    Get

Property Value

Type: ITokenReader
The ITokenReader that is used to read tokens during the parsing operation.

Implements

IParserStateTokenReader
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.UntargetableParseErrorTokenIds Property

ParserStateUntargetableParseErrorTokenIds Property

Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<int> UntargetableParseErrorTokenIds { get; set; }
Public Property UntargetableParseErrorTokenIds As IEnumerable(Of Integer)
    Get
    Set

Property Value

Type: IEnumerable Int32
The collection of token IDs that should be avoided when determining where untargeted parse errors will appear.

Implements

IParserStateUntargetableParseErrorTokenIds
Remarks
If a parse error is reported without a target token, the parser will normally place the parse error at the next token. If that token is one of the IDs found in this collection, the parse error will appear after the previous token instead. This property should be set to a collection of any IDs for visually-insignificant tokens that can be passed to the parser such as a line feed, line continuation, document end, etc.
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState Methods

Methods
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportError Method

ParserStateReportError Method

Overload List
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportError Method (IParseError)

ParserStateReportError Method (IParseError)

Reports an IParseError.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void ReportError(
    IParseError parseError
)
Public Overridable Sub ReportError (
    parseError As IParseError
)

Parameters

parseError
Type: ActiproSoftware.Text.ParsingIParseError
The IParseError object that contains details about the error.

Implements

IParserStateReportError(IParseError)
See Also

Reference

ParserState Class
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportError Method (ParseErrorLevel, String)

ParserStateReportError Method (ParseErrorLevel, String)

Reports an IParseError, using the look-ahead token for its range.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseError ReportError(
    ParseErrorLevel level,
    string description
)
Public Function ReportError (
    level As ParseErrorLevel,
    description As String
) As IParseError

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportError(ParseErrorLevel, String)
See Also

Reference

ParserState Class
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportError Method (ParseErrorLevel, String, IToken)

ParserStateReportError Method (ParseErrorLevel, String, IToken)

Reports an IParseError, using the specified token for its range.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseError ReportError(
    ParseErrorLevel level,
    string description,
    IToken token
)
Public Function ReportError (
    level As ParseErrorLevel,
    description As String,
    token As IToken
) As IParseError

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine for the error range. If not passed, the look-ahead token is used.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportError(ParseErrorLevel, String, IToken)
See Also

Reference

ParserState Class
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportNonTerminalExpectedError Method

ParserStateReportNonTerminalExpectedError Method

Overload List
 | Name | Description
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportNonTerminalExpectedError Method (NonTerminal)

ParserStateReportNonTerminalExpectedError Method (NonTerminal)

Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal
)
Public Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportNonTerminalExpectedError(NonTerminal)
See Also

Reference

ParserState Class
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportNonTerminalExpectedError Method (NonTerminal, IToken)

ParserStateReportNonTerminalExpectedError Method (NonTerminal, IToken)

Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal,
    IToken token
)
Public Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal,
    token As IToken
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken at which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportNonTerminalExpectedError(NonTerminal, IToken)
See Also

Reference

ParserState Class
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportNonTerminalExpectedError Method (NonTerminal, TextPositionRange)

ParserStateReportNonTerminalExpectedError Method (NonTerminal, TextPositionRange)

Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal,
    TextPositionRange positionRange
)
Public Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal,
    positionRange As TextPositionRange
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange over which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportNonTerminalExpectedError(NonTerminal, TextPositionRange)
See Also

Reference

ParserState Class
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportTerminalExpectedError Method

ParserStateReportTerminalExpectedError Method

Overload List
 | Name | Description
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportTerminalExpectedError Method (Terminal)

ParserStateReportTerminalExpectedError Method (Terminal)

Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseError ReportTerminalExpectedError(
    Terminal terminal
)
Public Function ReportTerminalExpectedError (
    terminal As Terminal
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportTerminalExpectedError(Terminal)
See Also

Reference

ParserState Class
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportTerminalExpectedError Method (Terminal, IToken)

ParserStateReportTerminalExpectedError Method (Terminal, IToken)

Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseError ReportTerminalExpectedError(
    Terminal terminal,
    IToken token
)
Public Function ReportTerminalExpectedError (
    terminal As Terminal,
    token As IToken
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken at which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportTerminalExpectedError(Terminal, IToken)
See Also

Reference

ParserState Class
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportTerminalExpectedError Method (Terminal, TextPositionRange)

ParserStateReportTerminalExpectedError Method (Terminal, TextPositionRange)

Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IParseError ReportTerminalExpectedError(
    Terminal terminal,
    TextPositionRange positionRange
)
Public Function ReportTerminalExpectedError (
    terminal As Terminal,
    positionRange As TextPositionRange
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange over which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportTerminalExpectedError(Terminal, TextPositionRange)
See Also

Reference

ParserState Class
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Class

Represents an abstract base class for a symbol within a grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class Symbol : IKeyedObject
Public MustInherit Class Symbol
    Implements IKeyedObject

The Symbol type exposes the following members.

Constructors
 | Name | Description
Protected method | Symbol | Initializes a new instance of the Symbol class.
Top
Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse.
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Key | Gets or sets the string that identifies the symbol.
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol.
Top
Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token.
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted.
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted.
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol.
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol.
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted.
Top
Operators
Name | Description
Addition(EbnfTerm, Symbol) |
Addition(Symbol, EbnfTerm) |
Addition(Symbol, Symbol) |
BitwiseOr(EbnfTerm, Symbol) |
BitwiseOr(Symbol, EbnfTerm) |
BitwiseOr(Symbol, Symbol) |
GreaterThan |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Constructor

Initializes a new instance of the Symbol class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Symbol(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Properties

The Symbol type exposes the following members.

Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse.
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Key | Gets or sets the string that identifies the symbol.
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol.
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.CanMatchCallback Property

SymbolCanMatchCallback Property

Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParserCanMatchCallback CanMatchCallback { get; set; }
Public Property CanMatchCallback As ParserCanMatchCallback
    Get
    Set

Property Value

Type: ParserCanMatchCallback
The delegate that will be called when the non-terminal needs to determine at run-time whether it can parse.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ErrorAlias Property

SymbolErrorAlias Property

Gets or sets the alias to use for this symbol when reporting errors.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ErrorAlias { get; set; }
Public Property ErrorAlias As String
    Get
    Set

Property Value

Type: String
The alias to use for this symbol when reporting errors.
Remarks

Terminals always report errors and use their Key if no error alias is specified. Non-terminals will only report errors if an error alias is specified.

Once the grammar has been compiled, the setter of this property will throw an exception if called.

See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.IsCompiled Property

SymbolIsCompiled Property

Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCompiled { get; }
Public ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Key Property

SymbolKey Property

Gets or sets the string that identifies the symbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set

Property Value

Type: String
The string that identifies the symbol.

Implements

IKeyedObjectKey
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.SetLabel Property

SymbolSetLabel Property

Wraps this symbol with a labeled EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfSymbol this[
    string label
] { get; }
Public ReadOnly Default Property SetLabel (
    label As String
) As EbnfSymbol
    Get

Parameters

label
Type: SystemString
The string label to use.

Property Value

Type: EbnfSymbol
The EbnfSymbol that was created.
Remarks
This indexer is defined as shorthand syntax for calling the ToTerm(String) method.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Methods

The Symbol type exposes the following members.

Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token.
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted.
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted.
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol.
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol.
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted.
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.CanMatch Method

SymbolCanMatch Method

Returns whether the symbol can start to match using callbacks or the current look-ahead token.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMatch(
    IParserState state
)
Public Function CanMatch (
    state As IParserState
) As Boolean

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
An IParserState that provides information about the current parser state.

Return Value

Type: Boolean
true if the symbol can start to match; otherwise, false.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnComplete Method

SymbolOnComplete Method

Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnComplete(
    ParserCallback callback
)
Public Function OnComplete (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called after the term is parsed.

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OneOrMore Method

SymbolOneOrMore Method

Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifier OneOrMore()
Public Function OneOrMore As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnError Method

SymbolOnError Method

Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnError(
    ParserErrorCallback callback
)
Public Function OnError (
    callback As ParserErrorCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnErrorContinue Method

SymbolOnErrorContinue Method

Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorContinue()
Public Function OnErrorContinue As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnErrorIgnore Method

SymbolOnErrorIgnore Method

Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorIgnore()
Public Function OnErrorIgnore As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnErrorNoReport Method

SymbolOnErrorNoReport Method

Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorNoReport()
Public Function OnErrorNoReport As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnInitialize Method

SymbolOnInitialize Method

Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnInitialize(
    ParserCallback callback
)
Public Function OnInitialize (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called before the term is parsed.

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnSuccess Method

SymbolOnSuccess Method

Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnSuccess(
    ParserCallback callback
)
Public Function OnSuccess (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called when the term is successfully parsed.

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Optional Method

SymbolOptional Method

Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifier Optional()
Public Function Optional As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Range Method

SymbolRange Method

Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifier Range(
    int min,
    Nullable<int> max
)
Public Function Range (
    min As Integer,
    max As Nullable(Of Integer)
) As EbnfQuantifier

Parameters

min
Type: SystemInt32
The minimum number of instances.
max
Type: SystemNullable Int32
The maximum number of instances.

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ToString Method

SymbolToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ToTerm Method

SymbolToTerm Method

Overload List
 | Name | Description
Public method | ToTerm | Wraps this symbol with an EbnfSymbol.
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol.
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ToTerm Method

SymbolToTerm Method

Wraps this symbol with an EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfSymbol ToTerm()
Public Function ToTerm As EbnfSymbol

Return Value

Type: EbnfSymbol
The EbnfSymbol that was created.
See Also

Reference

Symbol Class
ToTerm Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ToTerm Method (String)

SymbolToTerm Method (String)

Wraps this symbol with a labeled EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract EbnfSymbol ToTerm(
    string label
)
Public MustOverride Function ToTerm (
    label As String
) As EbnfSymbol

Parameters

label
Type: SystemString
The string label to use.

Return Value

Type: EbnfSymbol
The EbnfSymbol that was created.
See Also

Reference

Symbol Class
ToTerm Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ZeroOrMore Method

SymbolZeroOrMore Method

Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EbnfQuantifier ZeroOrMore()
Public Function ZeroOrMore As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Operators

The Symbol type exposes the following members.

Operators
Name | Description
Addition(EbnfTerm, Symbol) |
Addition(Symbol, EbnfTerm) |
Addition(Symbol, Symbol) |
BitwiseOr(EbnfTerm, Symbol) |
BitwiseOr(Symbol, EbnfTerm) |
BitwiseOr(Symbol, Symbol) |
GreaterThan |
LessThan |
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Addition Operator

SymbolAddition Operator

Overload List
Name | Description
Addition(EbnfTerm, Symbol) |
Addition(Symbol, EbnfTerm) |
Addition(Symbol, Symbol) |
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Addition Operator (EbnfTerm, Symbol)

SymbolAddition Operator (EbnfTerm, Symbol)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfConcatenation operator +(
    EbnfTerm left,
    Symbol right
)
Public Shared Operator + (
    left As EbnfTerm,
    right As Symbol
) As EbnfConcatenation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Return Value

Type: EbnfConcatenation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

See Also

Reference

Symbol Class
Addition Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Addition Operator (Symbol, EbnfTerm)

SymbolAddition Operator (Symbol, EbnfTerm)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfConcatenation operator +(
    Symbol left,
    EbnfTerm right
)
Public Shared Operator + (
    left As Symbol,
    right As EbnfTerm
) As EbnfConcatenation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Return Value

Type: EbnfConcatenation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

See Also

Reference

Symbol Class
Addition Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Addition Operator (Symbol, Symbol)

SymbolAddition Operator (Symbol, Symbol)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfConcatenation operator +(
    Symbol left,
    Symbol right
)
Public Shared Operator + (
    left As Symbol,
    right As Symbol
) As EbnfConcatenation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Return Value

Type: EbnfConcatenation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

See Also

Reference

Symbol Class
Addition Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.BitwiseOr Operator

SymbolBitwiseOr Operator

Overload List
Name | Description
BitwiseOr(EbnfTerm, Symbol) |
BitwiseOr(Symbol, EbnfTerm) |
BitwiseOr(Symbol, Symbol) |
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.BitwiseOr Operator (EbnfTerm, Symbol)

SymbolBitwiseOr Operator (EbnfTerm, Symbol)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    EbnfTerm left,
    Symbol right
)
Public Shared Operator Or (
    left As EbnfTerm,
    right As Symbol
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

See Also

Reference

Symbol Class
BitwiseOr Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.BitwiseOr Operator (Symbol, EbnfTerm)

SymbolBitwiseOr Operator (Symbol, EbnfTerm)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    Symbol left,
    EbnfTerm right
)
Public Shared Operator Or (
    left As Symbol,
    right As EbnfTerm
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

See Also

Reference

Symbol Class
BitwiseOr Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.BitwiseOr Operator (Symbol, Symbol)

SymbolBitwiseOr Operator (Symbol, Symbol)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    Symbol left,
    Symbol right
)
Public Shared Operator Or (
    left As Symbol,
    right As Symbol
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

See Also

Reference

Symbol Class
BitwiseOr Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.GreaterThan Operator

SymbolGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfProduction operator >(
    Symbol symbol,
    ITreeConstructionNode treeConstructor
)
Public Shared Operator > (
    symbol As Symbol,
    treeConstructor As ITreeConstructionNode
) As EbnfProduction

Parameters

symbol
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="symbol"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode

[Missing <param name="treeConstructor"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.LessThan Operator

SymbolLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EbnfProduction operator <(
    Symbol symbol,
    ITreeConstructionNode treeConstructor
)
Public Shared Operator < (
    symbol As Symbol,
    treeConstructor As ITreeConstructionNode
) As EbnfProduction

Parameters

symbol
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="symbol"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode

[Missing <param name="treeConstructor"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Class

Represents a terminal symbol within a grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Terminal : Symbol
Public Class Terminal
    Inherits Symbol

The Terminal type exposes the following members.

Constructors
 | Name | Description
Public method | Terminal(Int32) | Initializes a new instance of the Terminal class.
Public method | Terminal(NullableInt32, ITokenIdProvider) | Initializes a new instance of the Terminal class.
Public method | Terminal(NullableInt32, String) | Initializes a new instance of the Terminal class.
Top
Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse. (Inherited from Symbol.)
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors. (Inherited from Symbol.)
Public property | Id | Gets or sets the ID that identifies the terminal.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Symbol.)
Public property | Key | Gets or sets the string that identifies the symbol. (Inherited from Symbol.)
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol. (Inherited from Symbol.)
Top
Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token. (Inherited from Symbol.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from Symbol.)
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted. (Inherited from Symbol.)
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term. (Inherited from Symbol.)
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from Symbol.)
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed. (Inherited from Symbol.)
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed. (Inherited from Symbol.)
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted. (Inherited from Symbol.)
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted. (Inherited from Symbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Symbol.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted. (Inherited from Symbol.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Constructor

Overload List
 | Name | Description
Public method | Terminal(Int32) | Initializes a new instance of the Terminal class.
Public method | Terminal(NullableInt32, ITokenIdProvider) | Initializes a new instance of the Terminal class.
Public method | Terminal(NullableInt32, String) | Initializes a new instance of the Terminal class.
Top
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Constructor (Int32)

Initializes a new instance of the Terminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Terminal(
    int id
)
Public Sub New (
    id As Integer
)

Parameters

id
Type: SystemInt32
The ID that identifies the terminal.
See Also

Reference

Terminal Class
Terminal Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Constructor (Nullable(Int32), ITokenIdProvider)

Terminal Constructor (NullableInt32, ITokenIdProvider)

Initializes a new instance of the Terminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Terminal(
    Nullable<int> id,
    ITokenIdProvider tokenIdProvider
)
Public Sub New (
    id As Nullable(Of Integer),
    tokenIdProvider As ITokenIdProvider
)

Parameters

id
Type: SystemNullable Int32
The ID that identifies the terminal.
tokenIdProvider
Type: ActiproSoftware.Text.LexingITokenIdProvider
An ITokenIdProvider that can provide a key for the specified token ID.
See Also

Reference

Terminal Class
Terminal Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Constructor (Nullable(Int32), String)

Terminal Constructor (NullableInt32, String)

Initializes a new instance of the Terminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Terminal(
    Nullable<int> id,
    string key
)
Public Sub New (
    id As Nullable(Of Integer),
    key As String
)

Parameters

id
Type: SystemNullable Int32
The ID that identifies the terminal.
key
Type: SystemString
A string that identifies the symbol.
See Also

Reference

Terminal Class
Terminal Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Properties

The Terminal type exposes the following members.

Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse. (Inherited from Symbol.)
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors. (Inherited from Symbol.)
Public property | Id | Gets or sets the ID that identifies the terminal.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Symbol.)
Public property | Key | Gets or sets the string that identifies the symbol. (Inherited from Symbol.)
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol. (Inherited from Symbol.)
Top
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal.Id Property

TerminalId Property

Gets or sets the ID that identifies the terminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> Id { get; set; }
Public Property Id As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The ID that identifies the terminal.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Methods

The Terminal type exposes the following members.

Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token. (Inherited from Symbol.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from Symbol.)
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted. (Inherited from Symbol.)
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term. (Inherited from Symbol.)
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from Symbol.)
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed. (Inherited from Symbol.)
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed. (Inherited from Symbol.)
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted. (Inherited from Symbol.)
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted. (Inherited from Symbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Symbol.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted. (Inherited from Symbol.)
Top
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal.ToTerm Method

TerminalToTerm Method

Overload List
 | Name | Description
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Top
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal.ToTerm Method (String)

TerminalToTerm Method (String)

Wraps this symbol with a labeled EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override EbnfSymbol ToTerm(
    string label
)
Public Overrides Function ToTerm (
    label As String
) As EbnfSymbol

Parameters

label
Type: SystemString
The string label to use.

Return Value

Type: EbnfSymbol
The EbnfSymbol that was created.
See Also

Reference

Terminal Class
ToTerm Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase Class

Represents the abstract base class of an object that can provide tokens to a ILLParser in a forward-only direction.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TokenReaderBase : ITokenReader
Public MustInherit Class TokenReaderBase
    Implements ITokenReader

The TokenReaderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TokenReaderBase | Initializes a new instance of the TokenReaderBase class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer.
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state.
Public property | LookAheadToken | Returns the IToken that is immediately after the current token.
Public property | Offset | Gets the current offset, which is offset after the last Token that was read.
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls.
Public property | Token | Gets the current IToken.
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken.
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs.
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token.
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader.
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends.
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state.
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase Constructor

Initializes a new instance of the TokenReaderBase class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TokenReaderBase(
    ITextBufferReader reader
)
Protected Sub New (
    reader As ITextBufferReader
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase Properties

The TokenReaderBase type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer.
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state.
Public property | LookAheadToken | Returns the IToken that is immediately after the current token.
Public property | Offset | Gets the current offset, which is offset after the last Token that was read.
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls.
Public property | Token | Gets the current IToken.
Top
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.IsAtEnd Property

TokenReaderBaseIsAtEnd Property

Gets whether the current IToken is at the end of the text buffer.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAtEnd { get; }
Public ReadOnly Property IsAtEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current IToken is at the end of the text buffer; otherwise, false.

Implements

ITokenReaderIsAtEnd
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.IsParserInErrorState Property

TokenReaderBaseIsParserInErrorState Property

Gets or sets whether the parser is currently recovering from an error state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsParserInErrorState { get; set; }
Public Property IsParserInErrorState As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the parser is currently recovering from an error state; otherwise, false.

Implements

ITokenReaderIsParserInErrorState
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.LookAheadToken Property

TokenReaderBaseLookAheadToken Property

Returns the IToken that is immediately after the current token.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IToken LookAheadToken { get; }
Public ReadOnly Property LookAheadToken As IToken
    Get

Property Value

Type: IToken
The IToken that is immediately after the current token.

Implements

ITokenReaderLookAheadToken
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Offset Property

TokenReaderBaseOffset Property

Gets the current offset, which is offset after the last Token that was read.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Offset { get; }
Public ReadOnly Property Offset As Integer
    Get

Property Value

Type: Int32
The current offset, which is offset after the last Token that was read.

Implements

ITokenReaderOffset
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.StackLevel Property

TokenReaderBaseStackLevel Property

Gets the current stack level from Push calls without corresponding Pop calls.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int StackLevel { get; }
Public ReadOnly Property StackLevel As Integer
    Get

Property Value

Type: Int32
The current stack level.

Implements

ITokenReaderStackLevel
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Token Property

TokenReaderBaseToken Property

Gets the current IToken.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IToken Token { get; }
Public ReadOnly Property Token As IToken
    Get

Property Value

Type: IToken
The current IToken.

Implements

ITokenReaderToken
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase Methods

The TokenReaderBase type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken.
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs.
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token.
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader.
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends.
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state.
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Top
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Advance Method

TokenReaderBaseAdvance Method

Advances to the next IToken.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Advance()
Public Sub Advance

Implements

ITokenReaderAdvance
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.AdvanceTo Method

TokenReaderBaseAdvanceTo Method

Overload List
 | Name | Description
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Top
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.AdvanceTo Method (Int32)

TokenReaderBaseAdvanceTo Method (Int32)

Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AdvanceTo(
    int tokenId
)
Public Function AdvanceTo (
    tokenId As Integer
) As Boolean

Parameters

tokenId
Type: SystemInt32
The ID of IToken for which to search.

Return Value

Type: Boolean
true if an IToken was found before the end of document; otherwise, false.

Implements

ITokenReaderAdvanceTo(Int32)
Remarks
If this method is successful, the LookAheadToken will be the IToken that was located.
See Also

Reference

TokenReaderBase Class
AdvanceTo Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.AdvanceTo Method (Int32[])

TokenReaderBaseAdvanceTo Method (Int32)

Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AdvanceTo(
    params int[] tokenIds
)
Public Function AdvanceTo (
    ParamArray tokenIds As Integer()
) As Boolean

Parameters

tokenIds
Type: SystemInt32
The array of IToken IDs for which to search.

Return Value

Type: Boolean
true if an IToken was found before the end of document; otherwise, false.

Implements

ITokenReaderAdvanceTo(Int32)
Remarks
If this method is successful, the LookAheadToken will be the IToken that was located.
See Also

Reference

TokenReaderBase Class
AdvanceTo Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.AreNext Method

TokenReaderBaseAreNext Method

Returns whether the next look-ahead tokens match the specified sequence of token IDs.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreNext(
    params int[] tokenIds
)
Public Function AreNext (
    ParamArray tokenIds As Integer()
) As Boolean

Parameters

tokenIds
Type: SystemInt32
The sequence of token IDs for which to search.

Return Value

Type: Boolean
true if the next look-ahead tokens match the specified sequence of token IDs; otherwise, false.

Implements

ITokenReaderAreNext(Int32)
Remarks
This method is very useful within can-match callbacks that require two or more token look-aheads.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.GetLookAheadToken Method

TokenReaderBaseGetLookAheadToken Method

Returns the IToken that is the specified number of positions past the current token.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IToken GetLookAheadToken(
    int count
)
Public Function GetLookAheadToken (
    count As Integer
) As IToken

Parameters

count
Type: SystemInt32
The number of positions past the current token to examine.

Return Value

Type: IToken
The IToken that is the specified number of positions past the current token.

Implements

ITokenReaderGetLookAheadToken(Int32)
Remarks
A parameter value of 1 will return the value of the LookAheadToken method without actually seeking past the next token.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.GetNextToken Method

TokenReaderBaseGetNextToken Method

Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract IToken GetNextToken()
Protected MustOverride Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.GetTokenText Method

TokenReaderBaseGetTokenText Method

Returns an IToken's encapsulated text from the text buffer using Newline for line ends.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string GetTokenText(
    IToken targetToken
)
Public Function GetTokenText (
    targetToken As IToken
) As String

Parameters

targetToken
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: String
The IToken's encapsulated text from the text buffer using Newline for line ends.

Implements

ITokenReaderGetTokenText(IToken)
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Initialize Method

TokenReaderBaseInitialize Method

Initializes the token reader, which will be called by a ILLParser before the token reader is used.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Initialize()
Public Sub Initialize

Implements

ITokenReaderInitialize
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.OffsetToPosition Method

TokenReaderBaseOffsetToPosition Method

Returns the TextPosition that represents the specified offset within the text lines.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextPosition OffsetToPosition(
    int offset
)
Public Function OffsetToPosition (
    offset As Integer
) As TextPosition

Parameters

offset
Type: SystemInt32
The offset of a character within the snapshot.

Return Value

Type: TextPosition
The TextPosition that represents the specified offset within the text lines.

Implements

ITokenReaderOffsetToPosition(Int32)
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Pop Method

TokenReaderBasePop Method

Pops the top token reader state from the stack and restores the token reader to that state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool Pop()
Public Overridable Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITokenReaderPop
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Push Method

TokenReaderBasePush Method

Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Push()
Public Overridable Sub Push

Implements

ITokenReaderPush
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase Class

Represents an abstract base class a tree construction node, used to output an IAstNode for an EbnfProduction.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTreeConstructionNodeBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationParentTreeConstructionNodeBase

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TreeConstructionNodeBase : ITreeConstructionNode
Public MustInherit Class TreeConstructionNodeBase
    Implements ITreeConstructionNode

The TreeConstructionNodeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TreeConstructionNodeBase | Initializes a new instance of the TreeConstructionNodeBase class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of child ITreeConstructionNode objects.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.
Top
Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node.
Public method | ToEbnfString | Outputs the contents of the rewrite node in EBNF form.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase Constructor

Initializes a new instance of the TreeConstructionNodeBase class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TreeConstructionNodeBase()
Protected Sub New
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase Properties

The TreeConstructionNodeBase type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of child ITreeConstructionNode objects.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.
Top
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.Children Property

TreeConstructionNodeBaseChildren Property

Gets the collection of child ITreeConstructionNode objects.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IEnumerable<ITreeConstructionNode> Children { get; }
Public Overridable ReadOnly Property Children As IEnumerable(Of ITreeConstructionNode)
    Get

Property Value

Type: IEnumerable ITreeConstructionNode
The collection of child ITreeConstructionNode objects.
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.IsCompiled Property

TreeConstructionNodeBaseIsCompiled Property

Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCompiled { get; }
Public ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.

Implements

ITreeConstructionNodeIsCompiled
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.IsList Property

TreeConstructionNodeBaseIsList Property

Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsList { get; }
Public Overridable ReadOnly Property IsList As Boolean
    Get

Property Value

Type: Boolean
true if this node creates a list of IAstNode results.

Implements

ITreeConstructionNodeIsList
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase Methods

The TreeConstructionNodeBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node.
Public method | ToEbnfString | Outputs the contents of the rewrite node in EBNF form.
Top
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.CreateNode Method

TreeConstructionNodeBaseCreateNode Method

Returns the IAstNode that is created for this tree construction node.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract IAstNode CreateNode(
    IAstNodeMatchCollection matches
)
Public MustOverride Function CreateNode (
    matches As IAstNodeMatchCollection
) As IAstNode

Parameters

matches
Type: ActiproSoftware.Text.Parsing.LLParserIAstNodeMatchCollection
The collection of matched IAstNode objects within the current IAstNodeBuilder scope.

Return Value

Type: IAstNode
The IAstNode that is created for this tree construction node.

Implements

ITreeConstructionNodeCreateNode(IAstNodeMatchCollection)
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.ToEbnfString Method

TreeConstructionNodeBaseToEbnfString Method

Outputs the contents of the rewrite node in EBNF form.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: ActiproSoftware.Text.LLParser.Wpf (in ActiproSoftware.Text.LLParser.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string ToEbnfString()
Public Overridable Function ToEbnfString As String

Return Value

Type: String
A string containing the EBNF form of the rewrite node.

Implements

ITreeConstructionNodeToEbnfString
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ActiproSoftware.Text.RegularExpressions Namespace

Contains types related to working with regular expressions.
Classes
 | Class | Description
Public class | CharClass | Stores information about a character class.
Public class | InvalidRegexPatternException | An exception that is thrown when parsing invalid regular expression patterns.
Public class | RegexHelper | Provides helper methods for working with regular expression patterns.
Structures
 | Structure | Description
Public structure | CharInterval | Stores an interval of characters.
Enumerations
 | Enumeration | Description
Public enumeration | MatchType | Represents the type of regular expression match that was made.


CharClass Class

Stores information about a character class.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.RegularExpressionsCharClass

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CharClass : IEnumerable, ICollection<CharInterval>,
    IEnumerable<CharInterval>
Public Class CharClass
    Implements IEnumerable, ICollection(Of CharInterval),
    IEnumerable(Of CharInterval)

The CharClass type exposes the following members.

Constructors
 | Name | Description
Public method | CharClass | Initializes a new instance of the CharClass class.
Public method | CharClass(Char) | Initializes a new instance of the CharClass class with a character.
Public method | CharClass(String) | Initializes a new instance of the CharClass class with a string of characters.
Public method | CharClass(CharClass) | Initializes a new instance of the CharClass class with another CharClass.
Public method | CharClass(CharInterval) | Initializes a new instance of the CharClass class with an array of CharInterval objects.
Public method | CharClass(Char, Boolean) | Initializes a new instance of the CharClass class with a character and an optional complement.
Public method | CharClass(Char, Char) | Initializes a new instance of the CharClass class with an interval of characters.
Public method | CharClass(Char, Char, Boolean) | Initializes a new instance of the CharClass class with an interval of characters and an optional complement.
Top
Properties
 | Name | Description
 | All | Gets a CharClass that contains all Unicode characters.
 | Alpha | Gets a CharClass that contains all alphabetic characters.
Public property | CharacterCount | Gets the number of characters contained in the CharClass intervals, excluding any Unicode general categories specified.
Public property | Count | Gets the number of elements contained in the CharClass instance.
 | Digit | Gets a CharClass that contains all Unicode decimal digits.
Public property | HasCategorySpecification | Gets whether there is at least one Unicode generate category specification in the character class.
 | HexDigit | Gets a CharClass that contains all Unicode hexidecimal digits.
Public property | IsNegated | Gets whether the character class is negated.
Public property | IsReadOnly | Gets whether the collection is read-only.
Public property | IsSingleCharacter | Gets whether the character class only contains an interval for a single character.
Public property | Item | Gets the interval at the specified index. [C#] In C#, this property is the indexer for the CharClass class.
 | LineTerminator | Gets a CharClass that contains all Unicode line terminators.
 | LineTerminatorWhitespace | Gets a CharClass that contains all Unicode line terminators and whitespace characters.
 | NonAlpha | Gets a CharClass that contains no alphabetic digits.
 | NonDigit | Gets a CharClass that contains no Unicode decimal digits.
 | None | Gets a CharClass that contains no characters.
 | NonHexDigit | Gets a CharClass that contains no Unicode hexidecimal digits.
 | NonLineTerminator | Gets a CharClass that contains no Unicode line terminators.
 | NonLineTerminatorWhitespace | Gets a CharClass that contains no Unicode line terminators or whitespace characters.
 | NonWhitespace | Gets a CharClass that contains no Unicode whitespace characters.
 | NonWord | Gets a CharClass that contains no word characters.
 | Whitespace | Gets a CharClass that contains all Unicode whitespace characters.
 | Word | Gets a CharClass that contains all word characters.
Top
Methods
 | Name | Description
Public method | Add(Char) | Adds a single character to the character class.
Public method | Add(CharInterval) | Adds an interval of characters to the character class.
Public method | Add(Char, Char) | Adds an interval of characters to the character class.
Public method | AddCategory(UnicodeCategory, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddCategory(String, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddRange(CharClass) | Adds the contents of a CharClass to the collection.
Public method | AddRange(CharInterval) | Adds the contents of a CharInterval array to the collection.
Public method | Clear | Clears the characters in this CharClass instance, but does not reset the IsNegated flag.
Public method | Contains(Char) | Returns whether the specified character is in the character class.
Public method | Contains(CharClass) | Returns whether the specified character class is in the character class.
Public method | Contains(CharInterval) | Returns whether the specified interval is in the character class.
Public method | Contains(Char, Char) | Returns whether the specified interval of characters is in the character class.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetCategorySpecification | Returns whether a certain Unicode general category is specified in this character class, and if so, whether it is positive or negative matching.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | Remove(Char) | Removes the specified character from the character class.
Public method | Remove(CharInterval) | Removes the specified character interval from the character class.
Public method | RemoveCategory(UnicodeCategory) | Removes the specified Unicode general category from the character class.
Public method | RemoveCategory(String) | Removes the specified Unicode general category from the character class.
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor

Overload List
 | Name | Description
Public method | CharClass | Initializes a new instance of the CharClass class.
Public method | CharClass(Char) | Initializes a new instance of the CharClass class with a character.
Public method | CharClass(String) | Initializes a new instance of the CharClass class with a string of characters.
Public method | CharClass(CharClass) | Initializes a new instance of the CharClass class with another CharClass.
Public method | CharClass(CharInterval) | Initializes a new instance of the CharClass class with an array of CharInterval objects.
Public method | CharClass(Char, Boolean) | Initializes a new instance of the CharClass class with a character and an optional complement.
Public method | CharClass(Char, Char) | Initializes a new instance of the CharClass class with an interval of characters.
Public method | CharClass(Char, Char, Boolean) | Initializes a new instance of the CharClass class with an interval of characters and an optional complement.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor

Initializes a new instance of the CharClass class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass()
Public Sub New
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (Char)

Initializes a new instance of the CharClass class with a character.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass(
    char ch
)
Public Sub New (
    ch As Char
)

Parameters

ch
Type: SystemChar
A character to add to the character class.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (String)

Initializes a new instance of the CharClass class with a string of characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass(
    string characters
)
Public Sub New (
    characters As String
)

Parameters

characters
Type: SystemString
The string of characters to add to the character class.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (CharClass)

Initializes a new instance of the CharClass class with another CharClass.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass(
    CharClass charClass
)
Public Sub New (
    charClass As CharClass
)

Parameters

charClass
Type: ActiproSoftware.Text.RegularExpressionsCharClass
The CharClass whose items should be added.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (CharInterval[])

CharClass Constructor (CharInterval)

Initializes a new instance of the CharClass class with an array of CharInterval objects.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass(
    CharInterval[] intervals
)
Public Sub New (
    intervals As CharInterval()
)

Parameters

intervals
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The array of CharInterval objects that should be added.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (Char, Boolean)

Initializes a new instance of the CharClass class with a character and an optional complement.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass(
    char ch,
    bool isNegated
)
Public Sub New (
    ch As Char,
    isNegated As Boolean
)

Parameters

ch
Type: SystemChar
A character to add to the character class.
isNegated
Type: SystemBoolean
Whether to negate the character class after adding the initial character.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (Char, Char)

Initializes a new instance of the CharClass class with an interval of characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass(
    char start,
    char end
)
Public Sub New (
    start As Char,
    end As Char
)

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (Char, Char, Boolean)

Initializes a new instance of the CharClass class with an interval of characters and an optional complement.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharClass(
    char start,
    char end,
    bool isNegated
)
Public Sub New (
    start As Char,
    end As Char,
    isNegated As Boolean
)

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.
isNegated
Type: SystemBoolean
Whether to negate the character class after adding the initial character range.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Properties

The CharClass type exposes the following members.

Properties
 | Name | Description
 | All | Gets a CharClass that contains all Unicode characters.
 | Alpha | Gets a CharClass that contains all alphabetic characters.
Public property | CharacterCount | Gets the number of characters contained in the CharClass intervals, excluding any Unicode general categories specified.
Public property | Count | Gets the number of elements contained in the CharClass instance.
 | Digit | Gets a CharClass that contains all Unicode decimal digits.
Public property | HasCategorySpecification | Gets whether there is at least one Unicode generate category specification in the character class.
 | HexDigit | Gets a CharClass that contains all Unicode hexidecimal digits.
Public property | IsNegated | Gets whether the character class is negated.
Public property | IsReadOnly | Gets whether the collection is read-only.
Public property | IsSingleCharacter | Gets whether the character class only contains an interval for a single character.
Public property | Item | Gets the interval at the specified index. [C#] In C#, this property is the indexer for the CharClass class.
 | LineTerminator | Gets a CharClass that contains all Unicode line terminators.
 | LineTerminatorWhitespace | Gets a CharClass that contains all Unicode line terminators and whitespace characters.
 | NonAlpha | Gets a CharClass that contains no alphabetic digits.
 | NonDigit | Gets a CharClass that contains no Unicode decimal digits.
 | None | Gets a CharClass that contains no characters.
 | NonHexDigit | Gets a CharClass that contains no Unicode hexidecimal digits.
 | NonLineTerminator | Gets a CharClass that contains no Unicode line terminators.
 | NonLineTerminatorWhitespace | Gets a CharClass that contains no Unicode line terminators or whitespace characters.
 | NonWhitespace | Gets a CharClass that contains no Unicode whitespace characters.
 | NonWord | Gets a CharClass that contains no word characters.
 | Whitespace | Gets a CharClass that contains all Unicode whitespace characters.
 | Word | Gets a CharClass that contains all word characters.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.All Property

CharClassAll Property

Gets a CharClass that contains all Unicode characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass All { get; }
Public Shared ReadOnly Property All As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode characters.
Remarks
This character class is the equivalent of [\u0000-\uFFFF].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Alpha Property

CharClassAlpha Property

Gets a CharClass that contains all alphabetic characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass Alpha { get; }
Public Shared ReadOnly Property Alpha As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all alphabetic characters.
Remarks
This character class is the equivalent of \p{L} (all letters).
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.CharacterCount Property

CharClassCharacterCount Property

Gets the number of characters contained in the CharClass intervals, excluding any Unicode general categories specified.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CharacterCount { get; }
Public ReadOnly Property CharacterCount As Integer
    Get

Property Value

Type: Int32
The number of characters contained in the CharClass intervals, excluding any Unicode general categories specified.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Count Property

CharClassCount Property

Gets the number of elements contained in the CharClass instance.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the CharClass instance.

Implements

ICollectionTCount
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Digit Property

CharClassDigit Property

Gets a CharClass that contains all Unicode decimal digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass Digit { get; }
Public Shared ReadOnly Property Digit As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode decimal digits.
Remarks
This character class is the equivalent of \d and \p{Nd}.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.HasCategorySpecification Property

CharClassHasCategorySpecification Property

Gets whether there is at least one Unicode generate category specification in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasCategorySpecification { get; }
Public ReadOnly Property HasCategorySpecification As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one Unicode generate category specification in the character class; otherwise, false.
Remarks
Use the GetCategorySpecification(UnicodeCategory) method to test whether a specific UnicodeCategory is specified, and whether it is positive or negative.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.HexDigit Property

CharClassHexDigit Property

Gets a CharClass that contains all Unicode hexidecimal digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass HexDigit { get; }
Public Shared ReadOnly Property HexDigit As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode hexidecimal digits.
Remarks
This character class is the equivalent of [0-9a-fA-F].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.IsNegated Property

CharClassIsNegated Property

Gets whether the character class is negated.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegated { get; set; }
Public Property IsNegated As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the character class is negated; otherwise, false.
Remarks
The negation is the opposite of the character class, specified by a ^ character after the open square brace. When negated, the return value of Contains(Char) is toggled.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.IsReadOnly Property

CharClassIsReadOnly Property

Gets whether the collection is read-only.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the colletion is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.IsSingleCharacter Property

CharClassIsSingleCharacter Property

Gets whether the character class only contains an interval for a single character.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSingleCharacter { get; }
Public ReadOnly Property IsSingleCharacter As Boolean
    Get

Property Value

Type: Boolean
true if the character class only contains an interval for a single character; otherwise, false.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Item Property

CharClassItem Property

Gets the interval at the specified index.

[C#] In C#, this property is the indexer for the CharClass class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharInterval this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As CharInterval
    Get

Parameters

index
Type: SystemInt32
The index of the interval to return.

Property Value

Type: CharInterval
The CharInterval at the specified index.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.LineTerminator Property

CharClassLineTerminator Property

Gets a CharClass that contains all Unicode line terminators.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass LineTerminator { get; }
Public Shared ReadOnly Property LineTerminator As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode line terminators.
Remarks
This character class is the equivalent of [\n\r\p{Zl}\p{Zp}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.LineTerminatorWhitespace Property

CharClassLineTerminatorWhitespace Property

Gets a CharClass that contains all Unicode line terminators and whitespace characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass LineTerminatorWhitespace { get; }
Public Shared ReadOnly Property LineTerminatorWhitespace As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode line terminators and whitespace characters.
Remarks
This character class is the equivalent of \s or [\f\n\r\t\v\x85\p{Z}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonAlpha Property

CharClassNonAlpha Property

Gets a CharClass that contains no alphabetic digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass NonAlpha { get; }
Public Shared ReadOnly Property NonAlpha As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no alphabetic digits.
Remarks
This character class is the equivalent of \P{L} (no letters).
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonDigit Property

CharClassNonDigit Property

Gets a CharClass that contains no Unicode decimal digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass NonDigit { get; }
Public Shared ReadOnly Property NonDigit As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode decimal digits.
Remarks
This character class is the equivalent of \D.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.None Property

CharClassNone Property

Gets a CharClass that contains no characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass None { get; }
Public Shared ReadOnly Property None As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no characters.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonHexDigit Property

CharClassNonHexDigit Property

Gets a CharClass that contains no Unicode hexidecimal digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass NonHexDigit { get; }
Public Shared ReadOnly Property NonHexDigit As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode hexidecimal digits.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonLineTerminator Property

CharClassNonLineTerminator Property

Gets a CharClass that contains no Unicode line terminators.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass NonLineTerminator { get; }
Public Shared ReadOnly Property NonLineTerminator As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode line terminators.
Remarks
This character class is the equivalent of [^\n\r\p{Zl}\p{Zp}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonLineTerminatorWhitespace Property

CharClassNonLineTerminatorWhitespace Property

Gets a CharClass that contains no Unicode line terminators or whitespace characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass NonLineTerminatorWhitespace { get; }
Public Shared ReadOnly Property NonLineTerminatorWhitespace As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode line terminators or whitespace characters.
Remarks
This character class is the equivalent of \S or [^\f\n\r\t\v\x85\p{Z}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonWhitespace Property

CharClassNonWhitespace Property

Gets a CharClass that contains no Unicode whitespace characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass NonWhitespace { get; }
Public Shared ReadOnly Property NonWhitespace As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode whitespace characters.
Remarks
This character class is the equivalent of [^\f\t\v\x85\p{Zs}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonWord Property

CharClassNonWord Property

Gets a CharClass that contains no word characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass NonWord { get; }
Public Shared ReadOnly Property NonWord As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no word characters.
Remarks
This character class is the equivalent of \W and [^\p{L}\p{Nd}\p{Pc}] (no letters, decimal digits, and connectors like underscore).
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Whitespace Property

CharClassWhitespace Property

Gets a CharClass that contains all Unicode whitespace characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass Whitespace { get; }
Public Shared ReadOnly Property Whitespace As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode whitespace characters.
Remarks
This character class is the equivalent of [\f\t\v\x85\p{Zs}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Word Property

CharClassWord Property

Gets a CharClass that contains all word characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CharClass Word { get; }
Public Shared ReadOnly Property Word As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all word characters.
Remarks
Remarks
This character class is the equivalent of \w and [\p{L}\p{Nd}\p{Pc}] (all letters, decimal digits, and connectors like underscore).
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Methods

The CharClass type exposes the following members.

Methods
 | Name | Description
Public method | Add(Char) | Adds a single character to the character class.
Public method | Add(CharInterval) | Adds an interval of characters to the character class.
Public method | Add(Char, Char) | Adds an interval of characters to the character class.
Public method | AddCategory(UnicodeCategory, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddCategory(String, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddRange(CharClass) | Adds the contents of a CharClass to the collection.
Public method | AddRange(CharInterval) | Adds the contents of a CharInterval array to the collection.
Public method | Clear | Clears the characters in this CharClass instance, but does not reset the IsNegated flag.
Public method | Contains(Char) | Returns whether the specified character is in the character class.
Public method | Contains(CharClass) | Returns whether the specified character class is in the character class.
Public method | Contains(CharInterval) | Returns whether the specified interval is in the character class.
Public method | Contains(Char, Char) | Returns whether the specified interval of characters is in the character class.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetCategorySpecification | Returns whether a certain Unicode general category is specified in this character class, and if so, whether it is positive or negative matching.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | Remove(Char) | Removes the specified character from the character class.
Public method | Remove(CharInterval) | Removes the specified character interval from the character class.
Public method | RemoveCategory(UnicodeCategory) | Removes the specified Unicode general category from the character class.
Public method | RemoveCategory(String) | Removes the specified Unicode general category from the character class.
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Add Method

CharClassAdd Method

Overload List
 | Name | Description
Public method | Add(Char) | Adds a single character to the character class.
Public method | Add(CharInterval) | Adds an interval of characters to the character class.
Public method | Add(Char, Char) | Adds an interval of characters to the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Add Method (Char)

CharClassAdd Method (Char)

Adds a single character to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Add(
    char ch
)
Public Sub Add (
    ch As Char
)

Parameters

ch
Type: SystemChar
The character to add.
See Also

Reference

CharClass Class
Add Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Add Method (CharInterval)

CharClassAdd Method (CharInterval)

Adds an interval of characters to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Add(
    CharInterval interval
)
Public Sub Add (
    interval As CharInterval
)

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The interval of characters to add.

Implements

ICollectionTAdd(T)
See Also

Reference

CharClass Class
Add Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Add Method (Char, Char)

CharClassAdd Method (Char, Char)

Adds an interval of characters to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Add(
    char start,
    char end
)
Public Sub Add (
    start As Char,
    end As Char
)

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.
See Also

Reference

CharClass Class
Add Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddCategory Method

CharClassAddCategory Method

Overload List
 | Name | Description
Public method | AddCategory(UnicodeCategory, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddCategory(String, Boolean) | Adds the specified Unicode general category to the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddCategory Method (UnicodeCategory, Boolean)

CharClassAddCategory Method (UnicodeCategory, Boolean)

Adds the specified Unicode general category to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddCategory(
    UnicodeCategory category,
    bool negate
)
Public Sub AddCategory (
    category As UnicodeCategory,
    negate As Boolean
)

Parameters

category
Type: System.GlobalizationUnicodeCategory
A UnicodeCategory indicating the category.
negate
Type: SystemBoolean
Whether to negate the category.
See Also

Reference

CharClass Class
AddCategory Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddCategory Method (String, Boolean)

CharClassAddCategory Method (String, Boolean)

Adds the specified Unicode general category to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddCategory(
    string categoryName,
    bool negate
)
Public Sub AddCategory (
    categoryName As String,
    negate As Boolean
)

Parameters

categoryName
Type: SystemString
The name of the category. For example, Lu is used for uppercase letters.
negate
Type: SystemBoolean
Whether to negate the category.
See Also

Reference

CharClass Class
AddCategory Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddRange Method

CharClassAddRange Method

Overload List
 | Name | Description
Public method | AddRange(CharClass) | Adds the contents of a CharClass to the collection.
Public method | AddRange(CharInterval) | Adds the contents of a CharInterval array to the collection.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddRange Method (CharClass)

CharClassAddRange Method (CharClass)

Adds the contents of a CharClass to the collection.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddRange(
    CharClass charClass
)
Public Sub AddRange (
    charClass As CharClass
)

Parameters

charClass
Type: ActiproSoftware.Text.RegularExpressionsCharClass
The CharClass whose values are to be added.
See Also

Reference

CharClass Class
AddRange Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddRange Method (CharInterval[])

CharClassAddRange Method (CharInterval)

Adds the contents of a CharInterval array to the collection.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddRange(
    CharInterval[] intervals
)
Public Sub AddRange (
    intervals As CharInterval()
)

Parameters

intervals
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The CharInterval array whose values are to be added.
See Also

Reference

CharClass Class
AddRange Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Clear Method

CharClassClear Method

Clears the characters in this CharClass instance, but does not reset the IsNegated flag.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method

CharClassContains Method

Overload List
 | Name | Description
Public method | Contains(Char) | Returns whether the specified character is in the character class.
Public method | Contains(CharClass) | Returns whether the specified character class is in the character class.
Public method | Contains(CharInterval) | Returns whether the specified interval is in the character class.
Public method | Contains(Char, Char) | Returns whether the specified interval of characters is in the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method (Char)

CharClassContains Method (Char)

Returns whether the specified character is in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    char ch
)
Public Function Contains (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to look for in the collection.

Return Value

Type: Boolean
true if the character is in the collection; otherwise, false.
See Also

Reference

CharClass Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method (CharClass)

CharClassContains Method (CharClass)

Returns whether the specified character class is in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    CharClass charClass
)
Public Function Contains (
    charClass As CharClass
) As Boolean

Parameters

charClass
Type: ActiproSoftware.Text.RegularExpressionsCharClass
The CharClass to look for in the collection.

Return Value

Type: Boolean
true if the character class is in the collection; otherwise, false.
See Also

Reference

CharClass Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method (CharInterval)

CharClassContains Method (CharInterval)

Returns whether the specified interval is in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    CharInterval interval
)
Public Function Contains (
    interval As CharInterval
) As Boolean

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The CharInterval to look for in the collection.

Return Value

Type: Boolean
true if the interval is in the collection; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

CharClass Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method (Char, Char)

CharClassContains Method (Char, Char)

Returns whether the specified interval of characters is in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    char start,
    char end
)
Public Function Contains (
    start As Char,
    end As Char
) As Boolean

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.

Return Value

Type: Boolean
true if the interval of characters is in the collection; otherwise, false.
See Also

Reference

CharClass Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.CopyTo Method

CharClassCopyTo Method

Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyTo(
    CharInterval[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As CharInterval(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The one-dimensional CharInterval array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Equals Method

CharClassEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.GetCategorySpecification Method

CharClassGetCategorySpecification Method

Returns whether a certain Unicode general category is specified in this character class, and if so, whether it is positive or negative matching.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> GetCategorySpecification(
    UnicodeCategory category
)
Public Function GetCategorySpecification (
    category As UnicodeCategory
) As Nullable(Of Boolean)

Parameters

category
Type: System.GlobalizationUnicodeCategory
A UnicodeCategory indicating the category.

Return Value

Type: Nullable Boolean
true if the category is specified as a positive match. false if the category is specified as a negative match. if the category is not specified.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.GetEnumerator Method

CharClassGetEnumerator Method

Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<CharInterval> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of CharInterval)

Return Value

Type: IEnumerator CharInterval
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.GetHashCode Method

CharClassGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Remove Method

CharClassRemove Method

Overload List
 | Name | Description
Public method | Remove(Char) | Removes the specified character from the character class.
Public method | Remove(CharInterval) | Removes the specified character interval from the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Remove Method (Char)

CharClassRemove Method (Char)

Removes the specified character from the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Remove(
    char ch
)
Public Function Remove (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to remove.

Return Value

Type: Boolean
true if the character was removed; otherwise, false.
See Also

Reference

CharClass Class
Remove Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Remove Method (CharInterval)

CharClassRemove Method (CharInterval)

Removes the specified character interval from the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Remove(
    CharInterval interval
)
Public Function Remove (
    interval As CharInterval
) As Boolean

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The character interval to remove.

Return Value

Type: Boolean
true if the character interval was removed; otherwise, false.

Implements

ICollectionTRemove(T)
See Also

Reference

CharClass Class
Remove Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.RemoveCategory Method

CharClassRemoveCategory Method

Overload List
 | Name | Description
Public method | RemoveCategory(UnicodeCategory) | Removes the specified Unicode general category from the character class.
Public method | RemoveCategory(String) | Removes the specified Unicode general category from the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.RemoveCategory Method (UnicodeCategory)

CharClassRemoveCategory Method (UnicodeCategory)

Removes the specified Unicode general category from the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveCategory(
    UnicodeCategory category
)
Public Sub RemoveCategory (
    category As UnicodeCategory
)

Parameters

category
Type: System.GlobalizationUnicodeCategory
A UnicodeCategory indicating the category.
See Also

Reference

CharClass Class
RemoveCategory Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.RemoveCategory Method (String)

CharClassRemoveCategory Method (String)

Removes the specified Unicode general category from the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveCategory(
    string categoryName
)
Public Sub RemoveCategory (
    categoryName As String
)

Parameters

categoryName
Type: SystemString
The name of the category. For example, Lu is used for uppercase letters.
See Also

Reference

CharClass Class
RemoveCategory Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.ToString Method

CharClassToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Structure

Stores an interval of characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public struct CharInterval
Public Structure CharInterval

The CharInterval type exposes the following members.

Constructors
 | Name | Description
Public method | CharInterval(Char) | Initializes a new instance of the CharInterval class.
Public method | CharInterval(Char, Char) | Initializes a new instance of the CharInterval class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of characters contained in interval.
Public property | End | Gets or sets the end character in the interval of this CharInterval.
Public property | Start | Gets or sets the start character in the interval of this CharInterval.
Top
Methods
 | Name | Description
Public method | Contains(Char) | Returns whether the specified character is contained by the interval.
Public method | Contains(CharInterval) | Returns whether the specified character interval is contained by the interval.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetIntersection | Creates the intersection of the interval with another CharInterval.
Public method | IntersectsWith | Returns whether the specified character interval intersects with the interval.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Constructor

Overload List
 | Name | Description
Public method | CharInterval(Char) | Initializes a new instance of the CharInterval class.
Public method | CharInterval(Char, Char) | Initializes a new instance of the CharInterval class.
Top
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Constructor (Char)

Initializes a new instance of the CharInterval class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharInterval(
    char ch
)
Public Sub New (
    ch As Char
)

Parameters

ch
Type: SystemChar
The character in the interval.
See Also

Reference

CharInterval Structure
CharInterval Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Constructor (Char, Char)

Initializes a new instance of the CharInterval class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharInterval(
    char start,
    char end
)
Public Sub New (
    start As Char,
    end As Char
)

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.
See Also

Reference

CharInterval Structure
CharInterval Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Properties

The CharInterval type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of characters contained in interval.
Public property | End | Gets or sets the end character in the interval of this CharInterval.
Public property | Start | Gets or sets the start character in the interval of this CharInterval.
Top
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Count Property

CharIntervalCount Property

Gets the number of characters contained in interval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of characters contained in interval.
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.End Property

CharIntervalEnd Property

Gets or sets the end character in the interval of this CharInterval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char End { get; set; }
Public Property End As Char
    Get
    Set

Property Value

Type: Char
The end character in the interval of this CharInterval.
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Start Property

CharIntervalStart Property

Gets or sets the start character in the interval of this CharInterval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char Start { get; set; }
Public Property Start As Char
    Get
    Set

Property Value

Type: Char
The start character in the interval of this CharInterval.
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Methods

The CharInterval type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Char) | Returns whether the specified character is contained by the interval.
Public method | Contains(CharInterval) | Returns whether the specified character interval is contained by the interval.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetIntersection | Creates the intersection of the interval with another CharInterval.
Public method | IntersectsWith | Returns whether the specified character interval intersects with the interval.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Contains Method

CharIntervalContains Method

Overload List
 | Name | Description
Public method | Contains(Char) | Returns whether the specified character is contained by the interval.
Public method | Contains(CharInterval) | Returns whether the specified character interval is contained by the interval.
Top
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Contains Method (Char)

CharIntervalContains Method (Char)

Returns whether the specified character is contained by the interval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    char ch
)
Public Function Contains (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to test.

Return Value

Type: Boolean
true if the specified character is contained by the interval; otherwise, false.
See Also

Reference

CharInterval Structure
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Contains Method (CharInterval)

CharIntervalContains Method (CharInterval)

Returns whether the specified character interval is contained by the interval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    CharInterval interval
)
Public Function Contains (
    interval As CharInterval
) As Boolean

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The character interval to test.

Return Value

Type: Boolean
true if the specified character interval is contained by the interval; otherwise, false.
See Also

Reference

CharInterval Structure
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Equals Method

CharIntervalEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.GetHashCode Method

CharIntervalGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.GetIntersection Method

CharIntervalGetIntersection Method

Creates the intersection of the interval with another CharInterval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharInterval GetIntersection(
    CharInterval interval
)
Public Function GetIntersection (
    interval As CharInterval
) As CharInterval

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The CharInterval used to find the intersection.

Return Value

Type: CharInterval
The intersection of the interval with another CharInterval.
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.IntersectsWith Method

CharIntervalIntersectsWith Method

Returns whether the specified character interval intersects with the interval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    CharInterval interval
)
Public Function IntersectsWith (
    interval As CharInterval
) As Boolean

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The character interval to test.

Return Value

Type: Boolean
true if the specified character interval intersects with the interval; otherwise, false.
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.ToString Method

CharIntervalToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Operators

The CharInterval type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Equality Operator

CharIntervalEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Equality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator ==(
    CharInterval left,
    CharInterval right
)
Public Shared Operator = (
    left As CharInterval,
    right As CharInterval
) As Boolean

Parameters

left
Type: ActiproSoftware.Text.RegularExpressionsCharInterval

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Equality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

right
Type: ActiproSoftware.Text.RegularExpressionsCharInterval

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Equality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Equality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Inequality Operator

CharIntervalInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Inequality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator !=(
    CharInterval left,
    CharInterval right
)
Public Shared Operator <> (
    left As CharInterval,
    right As CharInterval
) As Boolean

Parameters

left
Type: ActiproSoftware.Text.RegularExpressionsCharInterval

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Inequality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

right
Type: ActiproSoftware.Text.RegularExpressionsCharInterval

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Inequality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Inequality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

See Also

Reference

CharInterval Structure
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Class

An exception that is thrown when parsing invalid regular expression patterns.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.Text.RegularExpressionsInvalidRegexPatternException

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InvalidRegexPatternException : Exception
<SerializableAttribute>
Public Class InvalidRegexPatternException
    Inherits Exception
Constructors
 | Name | Description
Public method | InvalidRegexPatternException | Initializes a new instance of the InvalidRegexPatternException class.
Public method | InvalidRegexPatternException(String) | Initializes a new instance of the InvalidRegexPatternException class with a specified error message.
Protected method | InvalidRegexPatternException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidRegexPatternException class with serialized data.
Public method | InvalidRegexPatternException(String, Exception) | Initializes a new instance of the InvalidRegexPatternException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Constructor

Overload List
 | Name | Description
Public method | InvalidRegexPatternException | Initializes a new instance of the InvalidRegexPatternException class.
Public method | InvalidRegexPatternException(String) | Initializes a new instance of the InvalidRegexPatternException class with a specified error message.
Protected method | InvalidRegexPatternException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidRegexPatternException class with serialized data.
Public method | InvalidRegexPatternException(String, Exception) | Initializes a new instance of the InvalidRegexPatternException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidRegexPatternException Class
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Constructor

Initializes a new instance of the InvalidRegexPatternException class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidRegexPatternException()
Public Sub New
See Also

Reference

InvalidRegexPatternException Class
InvalidRegexPatternException Overload
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Constructor (String)

Initializes a new instance of the InvalidRegexPatternException class with a specified error message.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidRegexPatternException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
See Also

Reference

InvalidRegexPatternException Class
InvalidRegexPatternException Overload
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InvalidRegexPatternException class with serialized data.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected InvalidRegexPatternException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

InvalidRegexPatternException Class
InvalidRegexPatternException Overload
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Constructor (String, Exception)

Initializes a new instance of the InvalidRegexPatternException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidRegexPatternException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception.
See Also

Reference

InvalidRegexPatternException Class
InvalidRegexPatternException Overload
ActiproSoftware.Text.RegularExpressions Namespace


MatchType Enumeration

Represents the type of regular expression match that was made.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MatchType
Public Enumeration MatchType
Members
Member name | Value | Description
NoMatch | 0 | No match was made.
ExactMatch | 1 | An exact match was made.
LooseMatch | 2 | A loose match was made. This occurs when using a case insensitivity of AutoCorrect and a non-exact match was found.
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper Class

Provides helper methods for working with regular expression patterns.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.RegularExpressionsRegexHelper

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class RegexHelper
Public NotInheritable Class RegexHelper

The RegexHelper type exposes the following members.

Methods
Name | Description
Escape(String) | Escapes all special characters in the specified regex search pattern.
Escape(String, Boolean) | Escapes all special characters in the specified regex search or replace pattern.
IsPatternSpecialChar | Returns whether the specified character is a search pattern special character.
Validate(String, Boolean) | Validates the specified regular expression pattern.
Validate(String, Boolean, HashSetString) | Validates the specified regular expression pattern and referenced lexical macros.
Top
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper Methods

The RegexHelper type exposes the following members.

Methods
Name | Description
Escape(String) | Escapes all special characters in the specified regex search pattern.
Escape(String, Boolean) | Escapes all special characters in the specified regex search or replace pattern.
IsPatternSpecialChar | Returns whether the specified character is a search pattern special character.
Validate(String, Boolean) | Validates the specified regular expression pattern.
Validate(String, Boolean, HashSetString) | Validates the specified regular expression pattern and referenced lexical macros.
Top
See Also

Reference

RegexHelper Class
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Escape Method

RegexHelperEscape Method

Overload List
Name | Description
Escape(String) | Escapes all special characters in the specified regex search pattern.
Escape(String, Boolean) | Escapes all special characters in the specified regex search or replace pattern.
Top
See Also

Reference

RegexHelper Class
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Escape Method (String)

RegexHelperEscape Method (String)

Escapes all special characters in the specified regex search pattern.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string Escape(
    string pattern
)
Public Shared Function Escape (
    pattern As String
) As String

Parameters

pattern
Type: SystemString
The search pattern to escape.

Return Value

Type: String
The escaped pattern.
See Also

Reference

RegexHelper Class
Escape Overload
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Escape Method (String, Boolean)

RegexHelperEscape Method (String, Boolean)

Escapes all special characters in the specified regex search or replace pattern.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string Escape(
    string pattern,
    bool isReplacePattern
)
Public Shared Function Escape (
    pattern As String,
    isReplacePattern As Boolean
) As String

Parameters

pattern
Type: SystemString
The pattern to escape.
isReplacePattern
Type: SystemBoolean
Whether the pattern is a replace pattern.

Return Value

Type: String
The escaped pattern.
See Also

Reference

RegexHelper Class
Escape Overload
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.IsPatternSpecialChar Method

RegexHelperIsPatternSpecialChar Method

Returns whether the specified character is a search pattern special character.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsPatternSpecialChar(
    char ch
)
Public Shared Function IsPatternSpecialChar (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is a find pattern special character; otherwise, false.
See Also

Reference

RegexHelper Class
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Validate Method

RegexHelperValidate Method

Overload List
Name | Description
Validate(String, Boolean) | Validates the specified regular expression pattern.
Validate(String, Boolean, HashSetString) | Validates the specified regular expression pattern and referenced lexical macros.
Top
See Also

Reference

RegexHelper Class
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Validate Method (String, Boolean)

RegexHelperValidate Method (String, Boolean)

Validates the specified regular expression pattern.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void Validate(
    string pattern,
    bool allowCapturing
)
Public Shared Sub Validate (
    pattern As String,
    allowCapturing As Boolean
)

Parameters

pattern
Type: SystemString
The pattern to examine.
allowCapturing
Type: SystemBoolean
Whether to allow capturing.
Remarks
An exception will be thrown if the pattern is invalid.
See Also

Reference

RegexHelper Class
Validate Overload
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Validate Method (String, Boolean, HashSet(String))

RegexHelperValidate Method (String, Boolean, HashSetString)

Validates the specified regular expression pattern and referenced lexical macros.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void Validate(
    string pattern,
    bool allowCapturing,
    HashSet<string> macroKeys
)
Public Shared Sub Validate (
    pattern As String,
    allowCapturing As Boolean,
    macroKeys As HashSet(Of String)
)

Parameters

pattern
Type: SystemString
The pattern to examine.
allowCapturing
Type: SystemBoolean
Whether to allow capturing.
macroKeys
Type: System.Collections.GenericHashSet String
The set of available lexical macro keys.
Remarks
An exception will be thrown if the pattern is invalid.
See Also

Reference

RegexHelper Class
Validate Overload
ActiproSoftware.Text.RegularExpressions Namespace


ActiproSoftware.Text.Searching Namespace

Contains types related to searching within text documents.
Classes
 | Class | Description
Public class | SearchPatternProviders | Provides access to the built-in ISearchPatternProvider instances, that can provide regular expression find/replace patterns based on a supplied pattern.
Interfaces
 | Interface | Description
Public interface | ISearchCapture | Provides the base requirements for a single capture by a regular expression match within an ISearchResult.
Public interface | ISearchCaptureCollection | Provides the base requirements for a collection of ISearchCapture objects.
Public interface | ISearchOptions | Provides the base requirements for a class that stores options for a find/replace operation.
Public interface | ISearchPatternProvider | Provides the base requirements for an object that can provide regular expression find/replace patterns based on a supplied pattern.
Public interface | ISearchPatternProviderCollection | Provides the base requirements for a collection of ISearchPatternProvider objects.
Public interface | ISearchPatternProviderFactory | Provides the base requirements for a factory capable of creating ISearchPatternProvider objects.
Public interface | ISearchResult | Provides the base requirements for a class that stores a single result of a search operation.
Public interface | ISearchResultCollection | Provides the base requirements for a collection of ISearchResult objects.
Public interface | ISearchResultSet | Provides the base requirements for a class that stores the results of a search operation.
Enumerations
 | Enumeration | Description
Public enumeration | SearchOperationType | Specifies the type of search operation.


ISearchCapture Interface

Provides the base requirements for a single capture by a regular expression match within an ISearchResult.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISearchCapture : IKeyedObject,
    ITextRangeProvider
Public Interface ISearchCapture
    Inherits IKeyedObject, ITextRangeProvider

The ISearchCapture type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Text | Gets the text that was captured.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchCapture Properties

The ISearchCapture type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Text | Gets the text that was captured.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ISearchCapture Interface
ActiproSoftware.Text.Searching Namespace


ISearchCapture.Text Property

ISearchCaptureText Property

Gets the text that was captured.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The text that was captured.
See Also

Reference

ISearchCapture Interface
ActiproSoftware.Text.Searching Namespace


ISearchCaptureCollection Interface

Provides the base requirements for a collection of ISearchCapture objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISearchCaptureCollection : IEnumerable,
    IKeyedObservableCollection<ISearchCapture>, IObservableCollection<ISearchCapture>, IList<ISearchCapture>,
    ICollection<ISearchCapture>, IEnumerable<ISearchCapture>
Public Interface ISearchCaptureCollection
    Inherits IEnumerable, IKeyedObservableCollection(Of ISearchCapture), IObservableCollection(Of ISearchCapture),
    IList(Of ISearchCapture), ICollection(Of ISearchCapture), IEnumerable(Of ISearchCapture)

The ISearchCaptureCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ISearchCapture .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ISearchCapture .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ISearchCapture .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ISearchCapture .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ISearchCapture .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISearchCapture .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISearchCapture .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList ISearchCapture .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ISearchCapture .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISearchCapture .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ISearchCapture .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISearchCapture | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISearchCapture | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISearchCapture | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchCaptureCollection Properties

The ISearchCaptureCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ISearchCapture .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ISearchCapture .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList ISearchCapture .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

ISearchCaptureCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchCaptureCollection Methods

The ISearchCaptureCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ISearchCapture .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ISearchCapture .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISearchCapture .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISearchCapture .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList ISearchCapture .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ISearchCapture .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISearchCapture .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ISearchCapture .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISearchCapture | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISearchCapture | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISearchCapture | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ISearchCaptureCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchCaptureCollection Events

The ISearchCaptureCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ISearchCaptureCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions Interface

Provides the base requirements for a class that stores options for a find/replace operation.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISearchOptions
Public Interface ISearchOptions

The ISearchOptions type exposes the following members.

Properties
 | Name | Description
Public property | FindText | Gets or sets the text to find.
Public property | MatchCase | Gets or sets whether searches should be case sensitive.
Public property | MatchWholeWord | Gets or sets whether searches should only match whole words.
Public property | MaximumResultCount | Gets or sets the maximum number of results that can be found.
Public property | PatternProvider | Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.).
Public property | ReplaceText | Gets or sets the text with which to replace (replace operations only).
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchOptions Properties

The ISearchOptions type exposes the following members.

Properties
 | Name | Description
Public property | FindText | Gets or sets the text to find.
Public property | MatchCase | Gets or sets whether searches should be case sensitive.
Public property | MatchWholeWord | Gets or sets whether searches should only match whole words.
Public property | MaximumResultCount | Gets or sets the maximum number of results that can be found.
Public property | PatternProvider | Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.).
Public property | ReplaceText | Gets or sets the text with which to replace (replace operations only).
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.FindText Property

ISearchOptionsFindText Property

Gets or sets the text to find.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string FindText { get; set; }
Property FindText As String
    Get
    Set

Property Value

Type: String
The text to find.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.MatchCase Property

ISearchOptionsMatchCase Property

Gets or sets whether searches should be case sensitive.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool MatchCase { get; set; }
Property MatchCase As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be case sensitive; otherwise, false.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.MatchWholeWord Property

ISearchOptionsMatchWholeWord Property

Gets or sets whether searches should only match whole words.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool MatchWholeWord { get; set; }
Property MatchWholeWord As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should only match whole words; otherwise, false.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.MaximumResultCount Property

ISearchOptionsMaximumResultCount Property

Gets or sets the maximum number of results that can be found.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int MaximumResultCount { get; set; }
Property MaximumResultCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of results that can be found.
Remarks
The count must be larger than zero.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.PatternProvider Property

ISearchOptionsPatternProvider Property

Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.).

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchPatternProvider PatternProvider { get; set; }
Property PatternProvider As ISearchPatternProvider
    Get
    Set

Property Value

Type: ISearchPatternProvider
A ISearchPatternProvider specifying the search pattern provider.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.ReplaceText Property

ISearchOptionsReplaceText Property

Gets or sets the text with which to replace (replace operations only).

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ReplaceText { get; set; }
Property ReplaceText As String
    Get
    Set

Property Value

Type: String
The text with which to replace.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.SearchUp Property

ISearchOptionsSearchUp Property

Gets or sets whether to search backwards.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool SearchUp { get; set; }
Property SearchUp As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be performed backwards; otherwise, false.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider Interface

Provides the base requirements for an object that can provide regular expression find/replace patterns based on a supplied pattern.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISearchPatternProvider : IKeyedObject
Public Interface ISearchPatternProvider
    Inherits IKeyedObject

The ISearchPatternProvider type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the search pattern provider.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | RequiresCaseSensitivity | Gets whether this pattern requires case sensitivity.
Top
Methods
 | Name | Description
Public method | GetFindPattern | Returns the regular expression match pattern to use for find operations, based on the supplied pattern that uses this provider.
Public method | GetReplacePattern | Returns the regular expression match pattern to use for replace operations, based on the supplied pattern that uses this provider.
Top
Remarks
All find/replace operations are performed using the built-in regular expression engine. This interface allows for the creation of custom pattern formats and enables them to be converted to the core regular expression pattern syntax.
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider Properties

The ISearchPatternProvider type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the search pattern provider.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | RequiresCaseSensitivity | Gets whether this pattern requires case sensitivity.
Top
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider.Description Property

ISearchPatternProviderDescription Property

Gets the description of the search pattern provider.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the search pattern provider.
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider.RequiresCaseSensitivity Property

ISearchPatternProviderRequiresCaseSensitivity Property

Gets whether this pattern requires case sensitivity.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool RequiresCaseSensitivity { get; }
ReadOnly Property RequiresCaseSensitivity As Boolean
    Get

Property Value

Type: Boolean
true if this pattern requires case sensitivity; otherwise, false.
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider Methods

The ISearchPatternProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetFindPattern | Returns the regular expression match pattern to use for find operations, based on the supplied pattern that uses this provider.
Public method | GetReplacePattern | Returns the regular expression match pattern to use for replace operations, based on the supplied pattern that uses this provider.
Top
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider.GetFindPattern Method

ISearchPatternProviderGetFindPattern Method

Returns the regular expression match pattern to use for find operations, based on the supplied pattern that uses this provider.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetFindPattern(
    string pattern
)
Function GetFindPattern (
    pattern As String
) As String

Parameters

pattern
Type: SystemString
The pattern to convert using this provider.

Return Value

Type: String
The regular expression match pattern to use for find operations.
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider.GetReplacePattern Method

ISearchPatternProviderGetReplacePattern Method

Returns the regular expression match pattern to use for replace operations, based on the supplied pattern that uses this provider.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string GetReplacePattern(
    string pattern
)
Function GetReplacePattern (
    pattern As String
) As String

Parameters

pattern
Type: SystemString
The pattern to convert using this provider.

Return Value

Type: String
The regular expression match pattern to use for replace operations.
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProviderCollection Interface

Provides the base requirements for a collection of ISearchPatternProvider objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISearchPatternProviderCollection : IEnumerable,
    ICollection, IList, IList<ISearchPatternProvider>, ICollection<ISearchPatternProvider>,
    IEnumerable<ISearchPatternProvider>
Public Interface ISearchPatternProviderCollection
    Inherits IEnumerable, ICollection, IList, IList(Of ISearchPatternProvider),
    ICollection(Of ISearchPatternProvider), IEnumerable(Of ISearchPatternProvider)

The ISearchPatternProviderCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection. (Inherited from ICollection.)
Public property | IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from IList.)
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from IList.)
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ICollection.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ICollection.)
Top
Methods
 | Name | Description
Public method | Add(Object) | Adds an item to the IList. (Inherited from IList.)
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection ISearchPatternProvider .)
Public method | Clear | Removes all items from the IList. (Inherited from IList.)
Public method | Contains(Object) | Determines whether the IList contains a specific value. (Inherited from IList.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISearchPatternProvider .)
Public method | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ICollection.)
Public method | CopyTo(T, Int32) | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISearchPatternProvider .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(Object) | Determines the index of a specific item in the IList. (Inherited from IList.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList ISearchPatternProvider .)
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index. (Inherited from IList.)
Public method | Insert(Int32, T) | Inserts an item to the IListT at the specified index. (Inherited from IList ISearchPatternProvider .)
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList. (Inherited from IList.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISearchPatternProvider .)
Public method | RemoveAt | Removes the IList item at the specified index. (Inherited from IList.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISearchPatternProvider | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISearchPatternProvider | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISearchPatternProvider | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace
ActiproSoftware.Text.SearchingISearchPatternProvider
ActiproSoftware.Text.Searching.ImplementationSearchPatternProviderCollection


ISearchPatternProviderCollection Properties

The ISearchPatternProviderCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection. (Inherited from ICollection.)
Public property | IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from IList.)
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from IList.)
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ICollection.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ICollection.)
Top
See Also

Reference

ISearchPatternProviderCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProviderCollection Methods

The ISearchPatternProviderCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(Object) | Adds an item to the IList. (Inherited from IList.)
Public method | Add(T) | Adds an item to the ICollectionT. (Inherited from ICollection ISearchPatternProvider .)
Public method | Clear | Removes all items from the IList. (Inherited from IList.)
Public method | Contains(Object) | Determines whether the IList contains a specific value. (Inherited from IList.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISearchPatternProvider .)
Public method | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ICollection.)
Public method | CopyTo(T, Int32) | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISearchPatternProvider .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(Object) | Determines the index of a specific item in the IList. (Inherited from IList.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList ISearchPatternProvider .)
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index. (Inherited from IList.)
Public method | Insert(Int32, T) | Inserts an item to the IListT at the specified index. (Inherited from IList ISearchPatternProvider .)
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList. (Inherited from IList.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISearchPatternProvider .)
Public method | RemoveAt | Removes the IList item at the specified index. (Inherited from IList.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISearchPatternProvider | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISearchPatternProvider | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISearchPatternProvider | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ISearchPatternProviderCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProviderFactory Interface

Provides the base requirements for a factory capable of creating ISearchPatternProvider objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISearchPatternProviderFactory
Public Interface ISearchPatternProviderFactory

The ISearchPatternProviderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateProviders | Creates the collection of ISearchPatternProvider objects to use.
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace
ActiproSoftware.Text.Searching.ImplementationDefaultSearchPatternProviderFactory


ISearchPatternProviderFactory Methods

The ISearchPatternProviderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateProviders | Creates the collection of ISearchPatternProvider objects to use.
Top
See Also

Reference

ISearchPatternProviderFactory Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProviderFactory.CreateProviders Method

ISearchPatternProviderFactoryCreateProviders Method

Creates the collection of ISearchPatternProvider objects to use.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchPatternProviderCollection CreateProviders()
Function CreateProviders As ISearchPatternProviderCollection

Return Value

Type: ISearchPatternProviderCollection
A ISearchPatternProviderCollection containing the ISearchPatternProvider objects that were created.
See Also

Reference

ISearchPatternProviderFactory Interface
ActiproSoftware.Text.Searching Namespace


ISearchResult Interface

Provides the base requirements for a class that stores a single result of a search operation.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISearchResult : ITextRangeProvider
Public Interface ISearchResult
    Inherits ITextRangeProvider

The ISearchResult type exposes the following members.

Properties
 | Name | Description
Public property | Captures | Gets the read-only collection of captures.
Public property | FindSnapshotRange | Gets a TextSnapshotRange that contains the text that was found.
Public property | ReplaceSnapshotRange | Gets a TextSnapshotRange that contains the text that was replaced.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchResult Properties

The ISearchResult type exposes the following members.

Properties
 | Name | Description
Public property | Captures | Gets the read-only collection of captures.
Public property | FindSnapshotRange | Gets a TextSnapshotRange that contains the text that was found.
Public property | ReplaceSnapshotRange | Gets a TextSnapshotRange that contains the text that was replaced.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ISearchResult Interface
ActiproSoftware.Text.Searching Namespace


ISearchResult.Captures Property

ISearchResultCaptures Property

Gets the read-only collection of captures.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchCaptureCollection Captures { get; }
ReadOnly Property Captures As ISearchCaptureCollection
    Get

Property Value

Type: ISearchCaptureCollection
The read-only collection of captures.
See Also

Reference

ISearchResult Interface
ActiproSoftware.Text.Searching Namespace


ISearchResult.FindSnapshotRange Property

ISearchResultFindSnapshotRange Property

Gets a TextSnapshotRange that contains the text that was found.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotRange FindSnapshotRange { get; }
ReadOnly Property FindSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the text that was found.
See Also

Reference

ISearchResult Interface
ActiproSoftware.Text.Searching Namespace


ISearchResult.ReplaceSnapshotRange Property

ISearchResultReplaceSnapshotRange Property

Gets a TextSnapshotRange that contains the text that was replaced.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TextSnapshotRange ReplaceSnapshotRange { get; }
ReadOnly Property ReplaceSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the text that was replaced.
Remarks
The TextSnapshotRange is marked as deleted if no replace was performed.
See Also

Reference

ISearchResult Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultCollection Interface

Provides the base requirements for a collection of ISearchResult objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISearchResultCollection : IEnumerable,
    IList<ISearchResult>, ICollection<ISearchResult>, IEnumerable<ISearchResult>
Public Interface ISearchResultCollection
    Inherits IEnumerable, IList(Of ISearchResult), ICollection(Of ISearchResult),
    IEnumerable(Of ISearchResult)

The ISearchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ISearchResult .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ISearchResult .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList ISearchResult .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ISearchResult .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ISearchResult .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISearchResult .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISearchResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ISearchResult .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ISearchResult .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISearchResult .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ISearchResult .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISearchResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISearchResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISearchResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchResultCollection Properties

The ISearchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection ISearchResult .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection ISearchResult .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList ISearchResult .)
Top
See Also

Reference

ISearchResultCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultCollection Methods

The ISearchResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection ISearchResult .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection ISearchResult .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection ISearchResult .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection ISearchResult .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList ISearchResult .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList ISearchResult .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection ISearchResult .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList ISearchResult .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISearchResult | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISearchResult | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISearchResult | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ISearchResultCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet Interface

Provides the base requirements for a class that stores the results of a search operation.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISearchResultSet
Public Interface ISearchResultSet

The ISearchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | OperationType | Gets or sets a SearchOperationType that indicates the search operation type that was performed.
Public property | Options | Gets or sets a copy of the ISearchOptions that were used to generate this result set.
Public property | Results | Gets the collection of ISearchResult objects.
Public property | Wrapped | Gets or sets whether the find operation wrapped when it reached the end of the search text range.
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchResultSet Properties

The ISearchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | OperationType | Gets or sets a SearchOperationType that indicates the search operation type that was performed.
Public property | Options | Gets or sets a copy of the ISearchOptions that were used to generate this result set.
Public property | Results | Gets the collection of ISearchResult objects.
Public property | Wrapped | Gets or sets whether the find operation wrapped when it reached the end of the search text range.
Top
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet.OperationType Property

ISearchResultSetOperationType Property

Gets or sets a SearchOperationType that indicates the search operation type that was performed.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
SearchOperationType OperationType { get; set; }
Property OperationType As SearchOperationType
    Get
    Set

Property Value

Type: SearchOperationType
A SearchOperationType that indicates the search operation type that was performed.
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet.Options Property

ISearchResultSetOptions Property

Gets or sets a copy of the ISearchOptions that were used to generate this result set.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchOptions Options { get; set; }
Property Options As ISearchOptions
    Get
    Set

Property Value

Type: ISearchOptions
A copy of the ISearchOptions that were used to generate this result set.
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet.Results Property

ISearchResultSetResults Property

Gets the collection of ISearchResult objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ISearchResultCollection Results { get; }
ReadOnly Property Results As ISearchResultCollection
    Get

Property Value

Type: ISearchResultCollection
The collection of ISearchResult objects.
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet.Wrapped Property

ISearchResultSetWrapped Property

Gets or sets whether the find operation wrapped when it reached the end of the search text range.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Wrapped { get; set; }
Property Wrapped As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the find operation wrapped; otherwise, false.
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


SearchOperationType Enumeration

Specifies the type of search operation.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SearchOperationType
Public Enumeration SearchOperationType
Members
Member name | Value | Description
FindNext | 0 | Finds the next occurrence of the find text.
ReplaceNext | 1 | Replaces the next occurrence of the find text with the replace text.
FindAll | 2 | Finds all occurrences of the find text.
ReplaceAll | 3 | Replaces all occurrences of the find text with the replace text.
FindNextIncremental | 4 | Finds the next occurrence of the find text via incremental search mode.
See Also

Reference

ActiproSoftware.Text.Searching Namespace


SearchPatternProviders Class

Provides access to the built-in ISearchPatternProvider instances, that can provide regular expression find/replace patterns based on a supplied pattern.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.SearchingSearchPatternProviders

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class SearchPatternProviders
Public NotInheritable Class SearchPatternProviders

The SearchPatternProviders type exposes the following members.

Properties
Name | Description
Acronym | Gets the ISearchPatternProvider for an acronym search.
Normal | Gets the ISearchPatternProvider for a normal search.
RegularExpression | Gets the ISearchPatternProvider for a regular expression search.
Shorthand | Gets the ISearchPatternProvider for a shorthand search.
Wildcard | Gets the ISearchPatternProvider for a wildcard search.
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


SearchPatternProviders Properties

The SearchPatternProviders type exposes the following members.

Properties
Name | Description
Acronym | Gets the ISearchPatternProvider for an acronym search.
Normal | Gets the ISearchPatternProvider for a normal search.
RegularExpression | Gets the ISearchPatternProvider for a regular expression search.
Shorthand | Gets the ISearchPatternProvider for a shorthand search.
Wildcard | Gets the ISearchPatternProvider for a wildcard search.
Top
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.Acronym Property

SearchPatternProvidersAcronym Property

Gets the ISearchPatternProvider for an acronym search.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider Acronym { get; }
Public Shared ReadOnly Property Acronym As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for an acronym search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.Normal Property

SearchPatternProvidersNormal Property

Gets the ISearchPatternProvider for a normal search.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider Normal { get; }
Public Shared ReadOnly Property Normal As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for a normal search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.RegularExpression Property

SearchPatternProvidersRegularExpression Property

Gets the ISearchPatternProvider for a regular expression search.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider RegularExpression { get; }
Public Shared ReadOnly Property RegularExpression As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for a regular expression search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.Shorthand Property

SearchPatternProvidersShorthand Property

Gets the ISearchPatternProvider for a shorthand search.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider Shorthand { get; }
Public Shared ReadOnly Property Shorthand As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for a shorthand search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.Wildcard Property

SearchPatternProvidersWildcard Property

Gets the ISearchPatternProvider for a wildcard search.

Namespace: ActiproSoftware.Text.Searching
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider Wildcard { get; }
Public Shared ReadOnly Property Wildcard As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for a wildcard search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


ActiproSoftware.Text.Searching.Implementation Namespace

Contains implementation types related to searching within text documents.
Classes
 | Class | Description
Public class | DefaultSearchPatternProviderFactory | The default factory implementation that creates ISearchPatternProvider objects.
Public class | SearchPatternProviderCollection | Encapsulates a collection of ISearchPatternProvider objects.
Public class | SearchResultSet | Stores the results of a find operation.
Public class | TextSearcher | Provides core functionality for searching within an ITextSnapshot that is typically wrapped by external helper methods.


DefaultSearchPatternProviderFactory Class

The default factory implementation that creates ISearchPatternProvider objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Searching.ImplementationDefaultSearchPatternProviderFactory

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DefaultSearchPatternProviderFactory : ISearchPatternProviderFactory
Public Class DefaultSearchPatternProviderFactory
    Implements ISearchPatternProviderFactory

The DefaultSearchPatternProviderFactory type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultSearchPatternProviderFactory | Initializes a new instance of the DefaultSearchPatternProviderFactory class
Top
Methods
 | Name | Description
Public method | CreateProviders | Creates the collection of ISearchPatternProvider objects to use.
Top
See Also

Reference

ActiproSoftware.Text.Searching.Implementation Namespace


DefaultSearchPatternProviderFactory Constructor

Initializes a new instance of the DefaultSearchPatternProviderFactory class

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DefaultSearchPatternProviderFactory()
Public Sub New
See Also

Reference

DefaultSearchPatternProviderFactory Class
ActiproSoftware.Text.Searching.Implementation Namespace


DefaultSearchPatternProviderFactory Methods

The DefaultSearchPatternProviderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateProviders | Creates the collection of ISearchPatternProvider objects to use.
Top
See Also

Reference

DefaultSearchPatternProviderFactory Class
ActiproSoftware.Text.Searching.Implementation Namespace


DefaultSearchPatternProviderFactory.CreateProviders Method

DefaultSearchPatternProviderFactoryCreateProviders Method

Creates the collection of ISearchPatternProvider objects to use.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual ISearchPatternProviderCollection CreateProviders()
Public Overridable Function CreateProviders As ISearchPatternProviderCollection

Return Value

Type: ISearchPatternProviderCollection
A ISearchPatternProviderCollection containing the ISearchPatternProvider objects that were created.

Implements

ISearchPatternProviderFactoryCreateProviders
See Also

Reference

DefaultSearchPatternProviderFactory Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchPatternProviderCollection Class

Encapsulates a collection of ISearchPatternProvider objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection ISearchPatternProvider
ActiproSoftware.Text.UtilitySimpleObservableCollection ISearchPatternProvider
ActiproSoftware.Text.Searching.ImplementationSearchPatternProviderCollection

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SearchPatternProviderCollection : SimpleObservableCollection<ISearchPatternProvider>,
    IEnumerable, ICollection, IList, IList<ISearchPatternProvider>,
    ICollection<ISearchPatternProvider>, IEnumerable<ISearchPatternProvider>, ISearchPatternProviderCollection
Public Class SearchPatternProviderCollection
    Inherits SimpleObservableCollection(Of ISearchPatternProvider)
    Implements IEnumerable, ICollection, IList, IList(Of ISearchPatternProvider),
    ICollection(Of ISearchPatternProvider), IEnumerable(Of ISearchPatternProvider), ISearchPatternProviderCollection

The SearchPatternProviderCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SearchPatternProviderCollection | Initializes a new instance of the SearchPatternProviderCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection ISearchPatternProvider .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection ISearchPatternProvider .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection ISearchPatternProvider .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISearchPatternProvider | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISearchPatternProvider | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISearchPatternProvider | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Searching.Implementation Namespace
ActiproSoftware.Text.SearchingISearchPatternProvider


SearchPatternProviderCollection Constructor

Initializes a new instance of the SearchPatternProviderCollection class

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SearchPatternProviderCollection()
Public Sub New
See Also

Reference

SearchPatternProviderCollection Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchPatternProviderCollection Properties

The SearchPatternProviderCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection ISearchPatternProvider .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Top
See Also

Reference

SearchPatternProviderCollection Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchPatternProviderCollection Methods

The SearchPatternProviderCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection ISearchPatternProvider .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection ISearchPatternProvider .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection ISearchPatternProvider .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeISearchPatternProvider | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeISearchPatternProvider | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllISearchPatternProvider | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

SearchPatternProviderCollection Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchPatternProviderCollection Events

The SearchPatternProviderCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

SearchPatternProviderCollection Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet Class

Stores the results of a find operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Searching.ImplementationSearchResultSet

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SearchResultSet : ISearchResultSet
Public Class SearchResultSet
    Implements ISearchResultSet

The SearchResultSet type exposes the following members.

Constructors
 | Name | Description
Public method | SearchResultSet | Initializes a new instance of the SearchResultSet class.
Top
Properties
 | Name | Description
Public property | OperationType | Gets or sets a SearchOperationType that indicates the search operation type that was performed.
Public property | Options | Gets or sets a copy of the ISearchOptions that were used to generate this result set.
Public property | Results | Gets the collection of ISearchResult objects.
Public property | Wrapped | Gets or sets whether the find operation wrapped when it reached the end of the search text range.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet Constructor

Initializes a new instance of the SearchResultSet class.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SearchResultSet(
    SearchOperationType operationType,
    ISearchOptions options,
    bool wrapped
)
Public Sub New (
    operationType As SearchOperationType,
    options As ISearchOptions,
    wrapped As Boolean
)

Parameters

operationType
Type: ActiproSoftware.Text.SearchingSearchOperationType
A SearchOperationType that indicates the search operation type that was performed.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
A copy of the ISearchOptions that were used to generate this result set.
wrapped
Type: SystemBoolean
Whether the find operation wrapped when it reached the end of the search text range.
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet Properties

The SearchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | OperationType | Gets or sets a SearchOperationType that indicates the search operation type that was performed.
Public property | Options | Gets or sets a copy of the ISearchOptions that were used to generate this result set.
Public property | Results | Gets the collection of ISearchResult objects.
Public property | Wrapped | Gets or sets whether the find operation wrapped when it reached the end of the search text range.
Top
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.OperationType Property

SearchResultSetOperationType Property

Gets or sets a SearchOperationType that indicates the search operation type that was performed.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SearchOperationType OperationType { get; set; }
Public Property OperationType As SearchOperationType
    Get
    Set

Property Value

Type: SearchOperationType
A SearchOperationType that indicates the search operation type that was performed.

Implements

ISearchResultSetOperationType
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.Options Property

SearchResultSetOptions Property

Gets or sets a copy of the ISearchOptions that were used to generate this result set.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISearchOptions Options { get; set; }
Public Property Options As ISearchOptions
    Get
    Set

Property Value

Type: ISearchOptions
A copy of the ISearchOptions that were used to generate this result set.

Implements

ISearchResultSetOptions
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.Results Property

SearchResultSetResults Property

Gets the collection of ISearchResult objects.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISearchResultCollection Results { get; }
Public ReadOnly Property Results As ISearchResultCollection
    Get

Property Value

Type: ISearchResultCollection
The collection of ISearchResult objects.

Implements

ISearchResultSetResults
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.Wrapped Property

SearchResultSetWrapped Property

Gets or sets whether the find operation wrapped when it reached the end of the search text range.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Wrapped { get; set; }
Public Property Wrapped As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the find operation wrapped; otherwise, false.

Implements

ISearchResultSetWrapped
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet Methods

The SearchResultSet type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.ToString Method

SearchResultSetToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher Class

Provides core functionality for searching within an ITextSnapshot that is typically wrapped by external helper methods.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Searching.ImplementationTextSearcher

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class TextSearcher
Public NotInheritable Class TextSearcher

The TextSearcher type exposes the following members.

Methods
Name | Description
FindAll | Performs a find all operation over a specific range of the snapshot.
FindNext | Performs a find next operation over a specific range of the snapshot.
ReplaceAll | Performs a replace all operation over a specific range of the snapshot.
ReplaceNext | Performs a replace next operation over a specific range of the snapshot.
Top
See Also

Reference

ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher Methods

The TextSearcher type exposes the following members.

Methods
Name | Description
FindAll | Performs a find all operation over a specific range of the snapshot.
FindNext | Performs a find next operation over a specific range of the snapshot.
ReplaceAll | Performs a replace all operation over a specific range of the snapshot.
ReplaceNext | Performs a replace next operation over a specific range of the snapshot.
Top
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher.FindAll Method

TextSearcherFindAll Method

Performs a find all operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ISearchResultSet FindAll(
    ITextSnapshot snapshot,
    ISearchOptions options,
    TextRange searchTextRange
)
Public Shared Function FindAll (
    snapshot As ITextSnapshot,
    options As ISearchOptions,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot in which to search.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher.FindNext Method

TextSearcherFindNext Method

Performs a find next operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ISearchResultSet FindNext(
    ITextSnapshot snapshot,
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Public Shared Function FindNext (
    snapshot As ITextSnapshot,
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot in which to search.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher.ReplaceAll Method

TextSearcherReplaceAll Method

Performs a replace all operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ISearchResultSet ReplaceAll(
    ITextDocument document,
    Object source,
    ISearchOptions options,
    params TextRange[] searchTextRanges
)
Public Shared Function ReplaceAll (
    document As ITextDocument,
    source As Object,
    options As ISearchOptions,
    ParamArray searchTextRanges As TextRange()
) As ISearchResultSet

Parameters

document
Type: ActiproSoftware.TextITextDocument
The ITextDocument in which to search.
source
Type: SystemObject
The optional source of the text change, which is most often an editor view if specified.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRanges
Type: ActiproSoftware.TextTextRange
The TextRange array of offsets to search. If everything should be searched, specify the range 0 to the length of the document's current ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher.ReplaceNext Method

TextSearcherReplaceNext Method

Performs a replace next operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ISearchResultSet ReplaceNext(
    ITextDocument document,
    Object source,
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Public Shared Function ReplaceNext (
    document As ITextDocument,
    source As Object,
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

document
Type: ActiproSoftware.TextITextDocument
The ITextDocument in which to search.
source
Type: SystemObject
The optional source of the text change, which is most often an editor view if specified.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the document's current ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


ActiproSoftware.Text.Tagging Namespace

Contains types related to tagging text ranges with custom data.
Classes
 | Class | Description
Public class | TagAggregatorBaseT | An abstract base class for an object that aggregates ITag objects from multiple ITaggerT instances.
Public class | TaggerKeys | Specifies the names of the built-in ITaggerT objects that are included with this product.
Public class | TagsChangedEventArgs | Event arguments for when an ITaggerT alters tags on text.
Public class | TagSnapshotRangeT | Implements an object that represents an ITag and its associated TextSnapshotRange.
Public class | TagVersionRangeT | Implements an object that represents an ITag and its associated ITextVersionRange.
Interfaces
 | Interface | Description
Public interface | IClassificationTag | Provides the base requirements for an IClassificationType that can be associated with some text range.
Public interface | ICodeDocumentTaggerProvider | Provides the base requirements for a object that can create ITaggerT objects for an ICodeDocument.
Public interface | ICollapsedRegionTag | Provides the base requirements for a collapsed region of text.
Public interface | ICollectionTaggerT | Provides the base requirements for an ITaggerT that maintains a simple collection of tagged ranges.
Public interface | IDelimiterHighlightTag | Provides the base requirements for an ITag that spans a delimiter highlight.
Public interface | IIndicatorTag | Provides the base requirements for an indicator, which covers range of text and render a glyph in an editor's indicator margin for that range.
Public interface | IIntraLineSpacerTag | Provides the base requirements for an object that requests space to be inserted above and/or below a view line, generally used for rendering adornments within.
Public interface | IIntraTextSpacerTag | Provides the base requirements for a spacer that can be inserted between two text characters.
Public interface | IReadOnlyRegionTag | Provides the base requirements for an IReadOnlyRegionTag that can be associated with some text range to mark it as read-only.
Public interface | ISquiggleTag | Provides the base requirements for a squiggle line, generally used for error display, that can be associated with some text range.
Public interface | ITag | Provides the base requirements for a data object that can be associated with some text range.
Public interface | ITagAggregatorT | Provides the base requirements for a object that aggregates ITag objects from multiple ITaggerT instances.
Public interface | ITaggerT | Provides the base requirements for a object that can provide ITag objects that intersect with specified text ranges within an ICodeDocument.
Public interface | ITagSearchOptionsT | Provides the base requirements for a class that stores tag search operation options.
Public interface | ITextViewTaggerProvider | Provides the base requirements for a object that can create ITaggerT objects for an ITextView.
Public interface | ITokenTag | Provides the base requirements for an IToken from an ILexer that can be associated with some text range.


IClassificationTag Interface

Provides the base requirements for an IClassificationType that can be associated with some text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IClassificationTag : ITag
Public Interface IClassificationTag
    Inherits ITag

The IClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with this tag.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace
ActiproSoftware.Text.Tagging.ImplementationClassificationTag


IClassificationTag Properties

The IClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with this tag.
Top
See Also

Reference

IClassificationTag Interface
ActiproSoftware.Text.Tagging Namespace


IClassificationTag.ClassificationType Property

IClassificationTagClassificationType Property

Gets the IClassificationType associated with this tag.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; }
ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType associated with this tag.
See Also

Reference

IClassificationTag Interface
ActiproSoftware.Text.Tagging Namespace


ICodeDocumentTaggerProvider Interface

Provides the base requirements for a object that can create ITaggerT objects for an ICodeDocument.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICodeDocumentTaggerProvider
Public Interface ICodeDocumentTaggerProvider

The ICodeDocumentTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace
ActiproSoftware.Text.Tagging.ImplementationCodeDocumentTaggerProviderTTagger


ICodeDocumentTaggerProvider Properties

The ICodeDocumentTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
See Also

Reference

ICodeDocumentTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ICodeDocumentTaggerProvider.TagTypes Property

ICodeDocumentTaggerProviderTagTypes Property

Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<Type> TagTypes { get; }
ReadOnly Property TagTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The ITag Type objects that are supported by the ITaggerT objects created by this provider.
See Also

Reference

ICodeDocumentTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ICodeDocumentTaggerProvider Methods

The ICodeDocumentTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument.
Top
See Also

Reference

ICodeDocumentTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ICodeDocumentTaggerProvider.GetTagger(T) Method

ICodeDocumentTaggerProviderGetTaggerT Method

Returns an ITaggerT for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires an ITaggerT.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
An ITaggerT for the specified ICodeDocument.
See Also

Reference

ICodeDocumentTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ICollapsedRegionTag Interface

Provides the base requirements for a collapsed region of text.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICollapsedRegionTag : ITag
Public Interface ICollapsedRegionTag
    Inherits ITag
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T) Interface

ICollectionTaggerT Interface

Provides the base requirements for an ITaggerT that maintains a simple collection of tagged ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICollectionTagger<T> : IKeyedObject,
    ITagger<T>, IOrderable
where T : ITag

Public Interface ICollectionTagger(Of T As ITag)
    Inherits IKeyedObject, ITagger(Of T), IOrderable

Type Parameters

T
The tag type.

The ICollectionTaggerT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the ICollectionTagger interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Public method | Clear | Removes all items from the collection.
Public method | Close | Closes the tagger and detaches it. (Inherited from ITaggerT.)
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo |
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from ITaggerT.)
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate.
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from ITaggerT.)
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed. (Inherited from ITaggerT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T) Properties

ICollectionTaggerT Properties

The ICollectionTaggerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the ICollectionTagger interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Count Property

ICollectionTaggerTCount Property

Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Item Property

ICollectionTaggerTItem Property

Gets the tag range that points to the specified tag.

[C#] In C#, this property is the indexer for the ICollectionTagger interface.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TagVersionRange<T> this[
    T tag
] { get; }
ReadOnly Default Property Item (
    tag As T
) As TagVersionRange(Of T)
    Get

Parameters

tag
Type: T
The tag for which to search.

Property Value

Type: TagVersionRange T
The tag range that points to the specified tag.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T) Methods

ICollectionTaggerT Methods

The ICollectionTaggerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Public method | Clear | Removes all items from the collection.
Public method | Close | Closes the tagger and detaches it. (Inherited from ITaggerT.)
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo |
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from ITaggerT.)
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate.
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Add Method

ICollectionTaggerTAdd Method

Overload List
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Add Method (TagVersionRange(T))

ICollectionTaggerTAdd Method (TagVersionRangeT)

Adds a tag range to the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Add(
    TagVersionRange<T> tagRange
)
Sub Add (
    tagRange As TagVersionRange(Of T)
)

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The tag range to add to the collection.
Remarks
This is the lowest-level method used for adding a tag range, and gives the most control over snapshot translation options.
See Also

Reference

ICollectionTaggerT Interface
Add Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Add Method (ITextSnapshotLine, T)

ICollectionTaggerTAdd Method (ITextSnapshotLine, T)

Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TagVersionRange<T> Add(
    ITextSnapshotLine snapshotLine,
    T tag
)
Function Add (
    snapshotLine As ITextSnapshotLine,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: T
The ITag to add.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created.
Remarks
The generated ITextVersionRange is created with the DeleteWhenZeroLength and LineBased flags.
See Also

Reference

ICollectionTaggerT Interface
Add Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Add Method (TextSnapshotRange, T)

ICollectionTaggerTAdd Method (TextSnapshotRange, T)

Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TagVersionRange<T> Add(
    TextSnapshotRange snapshotRange,
    T tag
)
Function Add (
    snapshotRange As TextSnapshotRange,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: T
The ITag to add.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created.
Remarks
The generated ITextVersionRange is created with the DeleteWhenZeroLength flag.
See Also

Reference

ICollectionTaggerT Interface
Add Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Clear Method

ICollectionTaggerTClear Method

Removes all items from the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Clear()
Sub Clear
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Contains Method

ICollectionTaggerTContains Method

Determines whether the collection contains a specific value.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Contains(
    TagVersionRange<T> tagRange
)
Function Contains (
    tagRange As TagVersionRange(Of T)
) As Boolean

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The object to locate in the collection.

Return Value

Type: Boolean
true if the item is found in the collection; otherwise, false.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).CopyTo Method

ICollectionTaggerTCopyTo Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Tagging.ICollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void CopyTo(
    TagVersionRange<T>[] array,
    int arrayIndex
)
Sub CopyTo (
    array As TagVersionRange(Of T)(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.TaggingTagVersionRange T

[Missing <param name="array"/> documentation for "M:ActiproSoftware.Text.Tagging.ICollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

arrayIndex
Type: SystemInt32

[Missing <param name="arrayIndex"/> documentation for "M:ActiproSoftware.Text.Tagging.ICollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).CreateBatch Method

ICollectionTaggerTCreateBatch Method

Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDisposable CreateBatch()
Function CreateBatch As IDisposable

Return Value

Type: IDisposable
An IDisposable object. Once disposed, the batch is ended.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).FindNext Method

ICollectionTaggerTFindNext Method

Overload List
 | Name | Description
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).FindNext Method (ITextSnapshotLine, ITagSearchOptions(T))

ICollectionTaggerTFindNext Method (ITextSnapshotLine, ITagSearchOptionsT)

Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TagVersionRange<T> FindNext(
    ITextSnapshotLine snapshotLine,
    ITagSearchOptions<T> options
)
Function FindNext (
    snapshotLine As ITextSnapshotLine,
    options As ITagSearchOptions(Of T)
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The ITextSnapshotLine from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions T
The optional ITagSearchOptionsT that specifies search options.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was found, if any.
See Also

Reference

ICollectionTaggerT Interface
FindNext Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).FindNext Method (TextSnapshotOffset, ITagSearchOptions(T))

ICollectionTaggerTFindNext Method (TextSnapshotOffset, ITagSearchOptionsT)

Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TagVersionRange<T> FindNext(
    TextSnapshotOffset snapshotOffset,
    ITagSearchOptions<T> options
)
Function FindNext (
    snapshotOffset As TextSnapshotOffset,
    options As ITagSearchOptions(Of T)
) As TagVersionRange(Of T)

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions T
The optional ITagSearchOptionsT that specifies search options.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was found, if any.
See Also

Reference

ICollectionTaggerT Interface
FindNext Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).GetEnumerator Method

ICollectionTaggerTGetEnumerator Method

Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerator<TagVersionRange<T>> GetEnumerator()
Function GetEnumerator As IEnumerator(Of TagVersionRange(Of T))

Return Value

Type: IEnumerator TagVersionRange T
An IEnumerator object for the entire collection
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Remove Method

ICollectionTaggerTRemove Method

Overload List
 | Name | Description
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Remove Method (T)

ICollectionTaggerTRemove Method (T)

Removes a specific tag instance from the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Remove(
    T tag
)
Function Remove (
    tag As T
) As Boolean

Parameters

tag
Type: T
The ITag to remove from the collection.

Return Value

Type: Boolean
true if the tag was successfully removed from the collection; otherwise, false
See Also

Reference

ICollectionTaggerT Interface
Remove Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Remove Method (TagVersionRange(T))

ICollectionTaggerTRemove Method (TagVersionRangeT)

Removes the first occurrence of a specific tag range from the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Remove(
    TagVersionRange<T> tagRange
)
Function Remove (
    tagRange As TagVersionRange(Of T)
) As Boolean

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The tag range to remove from the collection.

Return Value

Type: Boolean
true if the tag range was successfully removed from the collection; otherwise, false
See Also

Reference

ICollectionTaggerT Interface
Remove Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).RemoveAll Method

ICollectionTaggerTRemoveAll Method

Removes all objects that match the conditions defined by the specified predicate.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int RemoveAll(
    Predicate<TagVersionRange<T>> match
)
Function RemoveAll (
    match As Predicate(Of TagVersionRange(Of T))
) As Integer

Parameters

match
Type: SystemPredicate TagVersionRange T
The predicate that defines the conditions for removal.

Return Value

Type: Int32
The number of objects that were removed.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Toggle Method

ICollectionTaggerTToggle Method

Overload List
 | Name | Description
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Toggle Method (ITextSnapshotLine, T)

ICollectionTaggerTToggle Method (ITextSnapshotLine, T)

Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TagVersionRange<T> Toggle(
    ITextSnapshotLine snapshotLine,
    T tag
)
Function Toggle (
    snapshotLine As ITextSnapshotLine,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: T
The ITag to add, if no tag is already on the line.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created, if a tag was added.
See Also

Reference

ICollectionTaggerT Interface
Toggle Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Toggle Method (TextSnapshotRange, T)

ICollectionTaggerTToggle Method (TextSnapshotRange, T)

Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TagVersionRange<T> Toggle(
    TextSnapshotRange snapshotRange,
    T tag
)
Function Toggle (
    snapshotRange As TextSnapshotRange,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: T
The ITag to add, if no tag is already in the text range.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created, if a tag was added.
See Also

Reference

ICollectionTaggerT Interface
Toggle Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T) Events

ICollectionTaggerT Events

The ICollectionTaggerT generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from ITaggerT.)
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed. (Inherited from ITaggerT.)
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


IDelimiterHighlightTag Interface

Provides the base requirements for an ITag that spans a delimiter highlight.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDelimiterHighlightTag : ITag
Public Interface IDelimiterHighlightTag
    Inherits ITag

The IDelimiterHighlightTag type exposes the following members.

Properties
 | Name | Description
Public property | MatchEdges | Gets which edges of the delimiter's range are considered part of the highlight.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


IDelimiterHighlightTag Properties

The IDelimiterHighlightTag type exposes the following members.

Properties
 | Name | Description
Public property | MatchEdges | Gets which edges of the delimiter's range are considered part of the highlight.
Top
See Also

Reference

IDelimiterHighlightTag Interface
ActiproSoftware.Text.Tagging Namespace


IDelimiterHighlightTag.MatchEdges Property

IDelimiterHighlightTagMatchEdges Property

Gets which edges of the delimiter's range are considered part of the highlight.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
StructureMatchEdges MatchEdges { get; }
ReadOnly Property MatchEdges As StructureMatchEdges
    Get

Property Value

Type: StructureMatchEdges
A StructureMatchEdges that specifies the valid edges.
See Also

Reference

IDelimiterHighlightTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag Interface

Provides the base requirements for an indicator, which covers range of text and render a glyph in an editor's indicator margin for that range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IIndicatorTag : ITag
Public Interface IIndicatorTag
    Inherits ITag

The IIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


IIndicatorTag Properties

The IIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag.ContentProvider Property

IIndicatorTagContentProvider Property

Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IContentProvider ContentProvider { get; set; }
Property ContentProvider As IContentProvider
    Get
    Set

Property Value

Type: IContentProvider
The optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag.Tag Property

IIndicatorTagTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag Methods

The IIndicatorTag type exposes the following members.

Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin.
Top
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag.DrawGlyph Method

IIndicatorTagDrawGlyph Method

Draws the indicator's glyph in an editor view margin.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void DrawGlyph(
    TextViewDrawContext context,
    ITextViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Sub DrawGlyph (
    context As TextViewDrawContext,
    viewLine As ITextViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
)

Parameters

context
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationTextViewDrawContext
The TextViewDrawContext to use for rendering.
viewLine
Type: ActiproSoftware.Windows.Controls.SyntaxEditorITextViewLine
The ITextViewLine for which the glyph is rendered.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: System.WindowsRect
The bounds in which the indicator will be rendered.
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraLineSpacerTag Interface

Provides the base requirements for an object that requests space to be inserted above and/or below a view line, generally used for rendering adornments within.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IIntraLineSpacerTag : ITag
Public Interface IIntraLineSpacerTag
    Inherits ITag

The IIntraLineSpacerTag type exposes the following members.

Properties
 | Name | Description
Public property | BottomMargin | Gets the bottom margin of the spacer, which the amount of additional vertical space needed below the view line.
Public property | Key | Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
Public property | TopMargin | Gets the top margin of the spacer, which the amount of additional vertical space needed above the view line.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


IIntraLineSpacerTag Properties

The IIntraLineSpacerTag type exposes the following members.

Properties
 | Name | Description
Public property | BottomMargin | Gets the bottom margin of the spacer, which the amount of additional vertical space needed below the view line.
Public property | Key | Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
Public property | TopMargin | Gets the top margin of the spacer, which the amount of additional vertical space needed above the view line.
Top
See Also

Reference

IIntraLineSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraLineSpacerTag.BottomMargin Property

IIntraLineSpacerTagBottomMargin Property

Gets the bottom margin of the spacer, which the amount of additional vertical space needed below the view line.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double BottomMargin { get; }
ReadOnly Property BottomMargin As Double
    Get

Property Value

Type: Double
The bottom margin of the spacer, which the amount of additional vertical space needed below the view line.
See Also

Reference

IIntraLineSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraLineSpacerTag.Key Property

IIntraLineSpacerTagKey Property

Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Key { get; }
ReadOnly Property Key As Object
    Get

Property Value

Type: Object
An object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
See Also

Reference

IIntraLineSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraLineSpacerTag.TopMargin Property

IIntraLineSpacerTagTopMargin Property

Gets the top margin of the spacer, which the amount of additional vertical space needed above the view line.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double TopMargin { get; }
ReadOnly Property TopMargin As Double
    Get

Property Value

Type: Double
The top margin of the spacer, which the amount of additional vertical space needed above the view line.
See Also

Reference

IIntraLineSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag Interface

Provides the base requirements for a spacer that can be inserted between two text characters.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IIntraTextSpacerTag : ITag
Public Interface IIntraTextSpacerTag
    Inherits ITag

The IIntraTextSpacerTag type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the baseline of the spacer, which is the distance from the top of the spacer to the text baseline.
Public property | Key | Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
Public property | Size | Gets the size of the spacer.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag Properties

The IIntraTextSpacerTag type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the baseline of the spacer, which is the distance from the top of the spacer to the text baseline.
Public property | Key | Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
Public property | Size | Gets the size of the spacer.
Top
See Also

Reference

IIntraTextSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag.Baseline Property

IIntraTextSpacerTagBaseline Property

Gets the baseline of the spacer, which is the distance from the top of the spacer to the text baseline.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double Baseline { get; }
ReadOnly Property Baseline As Double
    Get

Property Value

Type: Double
The baseline of the spacer, which is the distance from the top of the spacer to the text baseline.
Remarks
This property can return the height of the spacer to sit the spacer on top of the text baseline.
See Also

Reference

IIntraTextSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag.Key Property

IIntraTextSpacerTagKey Property

Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Key { get; }
ReadOnly Property Key As Object
    Get

Property Value

Type: Object
An object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
See Also

Reference

IIntraTextSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag.Size Property

IIntraTextSpacerTagSize Property

Gets the size of the spacer.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Size Size { get; }
ReadOnly Property Size As Size
    Get

Property Value

Type: Size
The size of the spacer.
Remarks
This must be a fixed size.
See Also

Reference

IIntraTextSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IReadOnlyRegionTag Interface

Provides the base requirements for an IReadOnlyRegionTag that can be associated with some text range to mark it as read-only.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IReadOnlyRegionTag : ITag
Public Interface IReadOnlyRegionTag
    Inherits ITag

The IReadOnlyRegionTag type exposes the following members.

Properties
 | Name | Description
Public property | IncludeFirstEdge | Gets or sets whether to consider any text ranges that align to this tag's leading (first) edge as being in the read-only region.
Public property | IncludeLastEdge | Gets or sets whether to consider any text ranges that align to this tag's trailing (last) edge as being in the read-only region.
Public property | IsReadOnly | Gets whether the tagged text range is currently read-only.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace
ActiproSoftware.Text.Tagging.ImplementationReadOnlyRegionTag


IReadOnlyRegionTag Properties

The IReadOnlyRegionTag type exposes the following members.

Properties
 | Name | Description
Public property | IncludeFirstEdge | Gets or sets whether to consider any text ranges that align to this tag's leading (first) edge as being in the read-only region.
Public property | IncludeLastEdge | Gets or sets whether to consider any text ranges that align to this tag's trailing (last) edge as being in the read-only region.
Public property | IsReadOnly | Gets whether the tagged text range is currently read-only.
Top
See Also

Reference

IReadOnlyRegionTag Interface
ActiproSoftware.Text.Tagging Namespace


IReadOnlyRegionTag.IncludeFirstEdge Property

IReadOnlyRegionTagIncludeFirstEdge Property

Gets or sets whether to consider any text ranges that align to this tag's leading (first) edge as being in the read-only region.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IncludeFirstEdge { get; set; }
Property IncludeFirstEdge As Boolean
    Get
    Set

Property Value

Type: Boolean
true if any text ranges that align to this tag's leading (first) edge are considered as in the read-only region; otherwise, false.
See Also

Reference

IReadOnlyRegionTag Interface
ActiproSoftware.Text.Tagging Namespace


IReadOnlyRegionTag.IncludeLastEdge Property

IReadOnlyRegionTagIncludeLastEdge Property

Gets or sets whether to consider any text ranges that align to this tag's trailing (last) edge as being in the read-only region.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IncludeLastEdge { get; set; }
Property IncludeLastEdge As Boolean
    Get
    Set

Property Value

Type: Boolean
true if any text ranges that align to this tag's trailing (last) edge are considered as in the read-only region; otherwise, false.
See Also

Reference

IReadOnlyRegionTag Interface
ActiproSoftware.Text.Tagging Namespace


IReadOnlyRegionTag.IsReadOnly Property

IReadOnlyRegionTagIsReadOnly Property

Gets whether the tagged text range is currently read-only.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the tagged text range is currently read-only; otherwise, false.
See Also

Reference

IReadOnlyRegionTag Interface
ActiproSoftware.Text.Tagging Namespace


ISquiggleTag Interface

Provides the base requirements for a squiggle line, generally used for error display, that can be associated with some text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISquiggleTag : ITag
Public Interface ISquiggleTag
    Inherits ITag

The ISquiggleTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the optional IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ISquiggleTag Properties

The ISquiggleTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the optional IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Top
See Also

Reference

ISquiggleTag Interface
ActiproSoftware.Text.Tagging Namespace


ISquiggleTag.ClassificationType Property

ISquiggleTagClassificationType Property

Gets or sets the optional IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; set; }
Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The optional IClassificationType associated with the tag.
See Also

Reference

ISquiggleTag Interface
ActiproSoftware.Text.Tagging Namespace


ISquiggleTag.ContentProvider Property

ISquiggleTagContentProvider Property

Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IContentProvider ContentProvider { get; set; }
Property ContentProvider As IContentProvider
    Get
    Set

Property Value

Type: IContentProvider
The optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
See Also

Reference

ISquiggleTag Interface
ActiproSoftware.Text.Tagging Namespace


ITag Interface

Provides the base requirements for a data object that can be associated with some text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITag
Public Interface ITag
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T) Interface

ITagAggregatorT Interface

Provides the base requirements for a object that aggregates ITag objects from multiple ITaggerT instances.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITagAggregator<T>
where T : ITag

Public Interface ITagAggregator(Of T As ITag)

Type Parameters

T
The type of ITag associated with this aggregator.

The ITagAggregatorT type exposes the following members.

Methods
 | Name | Description
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
Events
 | Name | Description
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T) Methods

ITagAggregatorT Methods

Methods
 | Name | Description
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
See Also

Reference

ITagAggregatorT Interface
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T).GetTags Method

ITagAggregatorTGetTags Method

Overload List
 | Name | Description
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
See Also

Reference

ITagAggregatorT Interface
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T).GetTags Method (TextSnapshotRange[])

ITagAggregatorTGetTags Method (TextSnapshotRange)

Returns the tag ranges that intersect with the specified snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<TagSnapshotRange<T>> GetTags(
    params TextSnapshotRange[] snapshotRanges
)
Function GetTags (
    ParamArray snapshotRanges As TextSnapshotRange()
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextTextSnapshotRange
The array of snapshot ranges.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified snapshot ranges.
See Also

Reference

ITagAggregatorT Interface
GetTags Overload
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T).GetTags Method (NormalizedTextSnapshotRangeCollection, Object)

ITagAggregatorTGetTags Method (NormalizedTextSnapshotRangeCollection, Object)

Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.
See Also

Reference

ITagAggregatorT Interface
GetTags Overload
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T) Events

ITagAggregatorT Events

The ITagAggregatorT generic type exposes the following members.

Events
 | Name | Description
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ITagAggregatorT Interface
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T).TagsChanged Event

ITagAggregatorTTagsChanged Event

Occurs after available tags for a specified TextSnapshotRange have changed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<TagsChangedEventArgs> TagsChanged
Event TagsChanged As EventHandler(Of TagsChangedEventArgs)

Value

Type: SystemEventHandler TagsChangedEventArgs
See Also

Reference

ITagAggregatorT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T) Interface

ITaggerT Interface

Provides the base requirements for a object that can provide ITag objects that intersect with specified text ranges within an ICodeDocument.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITagger<T> : IKeyedObject,
    IOrderable
where T : ITag

Public Interface ITagger(Of T As ITag)
    Inherits IKeyedObject, IOrderable

Type Parameters

T
The type of tag associated with this tagger.

The ITaggerT type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
Methods
 | Name | Description
Public method | Close | Closes the tagger and detaches it.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed.
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace
ActiproSoftware.Text.Tagging.ImplementationTokenTagger


ITagger(T) Properties

ITaggerT Properties

The ITaggerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T) Methods

ITaggerT Methods

The ITaggerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the tagger and detaches it.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T).Close Method

ITaggerTClose Method

Closes the tagger and detaches it.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Close()
Sub Close
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T).GetTags Method

ITaggerTGetTags Method

Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T) Events

ITaggerT Events

The ITaggerT generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed.
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T).Closed Event

ITaggerTClosed Event

Occurs after the tagger is closed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler Closed
Event Closed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T).TagsChanged Event

ITaggerTTagsChanged Event

Occurs after available tags for a specified TextSnapshotRange have changed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<TagsChangedEventArgs> TagsChanged
Event TagsChanged As EventHandler(Of TagsChangedEventArgs)

Value

Type: SystemEventHandler TagsChangedEventArgs
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T) Interface

ITagSearchOptionsT Interface

Provides the base requirements for a class that stores tag search operation options.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITagSearchOptions<T>
where T : ITag

Public Interface ITagSearchOptions(Of T As ITag)

Type Parameters

T
The tag type.

The ITagSearchOptionsT type exposes the following members.

Properties
 | Name | Description
Public property | CanWrap | Gets or sets whether the search can wrap at the end of the search text range.
Public property | Filter | Gets or sets the optional callback used to determine if a potential search result is valid.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T) Properties

ITagSearchOptionsT Properties

The ITagSearchOptionsT generic type exposes the following members.

Properties
 | Name | Description
Public property | CanWrap | Gets or sets whether the search can wrap at the end of the search text range.
Public property | Filter | Gets or sets the optional callback used to determine if a potential search result is valid.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

ITagSearchOptionsT Interface
ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T).CanWrap Property

ITagSearchOptionsTCanWrap Property

Gets or sets whether the search can wrap at the end of the search text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanWrap { get; set; }
Property CanWrap As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the search can wrap at the end of the search text range; otherwise, false.
See Also

Reference

ITagSearchOptionsT Interface
ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T).Filter Property

ITagSearchOptionsTFilter Property

Gets or sets the optional callback used to determine if a potential search result is valid.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Predicate<TagVersionRange<T>> Filter { get; set; }
Property Filter As Predicate(Of TagVersionRange(Of T))
    Get
    Set

Property Value

Type: Predicate TagVersionRange T
The optional callback used to determine if a potential search result is valid.
See Also

Reference

ITagSearchOptionsT Interface
ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T).SearchUp Property

ITagSearchOptionsTSearchUp Property

Gets or sets whether to search backwards.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool SearchUp { get; set; }
Property SearchUp As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be performed backwards; otherwise, false.
See Also

Reference

ITagSearchOptionsT Interface
ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider Interface

Provides the base requirements for a object that can create ITaggerT objects for an ITextView.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITextViewTaggerProvider
Public Interface ITextViewTaggerProvider

The ITextViewTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ITextView.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider Properties

The ITextViewTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
See Also

Reference

ITextViewTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider.TagTypes Property

ITextViewTaggerProviderTagTypes Property

Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<Type> TagTypes { get; }
ReadOnly Property TagTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The ITag Type objects that are supported by the ITaggerT objects created by this provider.
See Also

Reference

ITextViewTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider Methods

The ITextViewTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ITextView.
Top
See Also

Reference

ITextViewTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider.GetTagger(T) Method

ITextViewTaggerProviderGetTaggerT Method

Returns an ITaggerT for the specified ITextView.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITagger<T> GetTagger<T>(
    ITextView view
)
where T : ITag

Function GetTagger(Of T As ITag) (
    view As ITextView
) As ITagger(Of T)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorITextView
The ITextView that requires an ITaggerT.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
An ITaggerT for the specified ITextView.
See Also

Reference

ITextViewTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ITokenTag Interface

Provides the base requirements for an IToken from an ILexer that can be associated with some text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITokenTag : ITag
Public Interface ITokenTag
    Inherits ITag

The ITokenTag type exposes the following members.

Properties
 | Name | Description
Public property | Token | Gets the lexer IToken associated with this tag.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITokenTag Properties

The ITokenTag type exposes the following members.

Properties
 | Name | Description
Public property | Token | Gets the lexer IToken associated with this tag.
Top
See Also

Reference

ITokenTag Interface
ActiproSoftware.Text.Tagging Namespace


ITokenTag.Token Property

ITokenTagToken Property

Gets the lexer IToken associated with this tag.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IToken Token { get; }
ReadOnly Property Token As IToken
    Get

Property Value

Type: IToken
The lexer IToken associated with this tag.
See Also

Reference

ITokenTag Interface
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Class

TagAggregatorBaseT Class

An abstract base class for an object that aggregates ITag objects from multiple ITaggerT instances.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityDisposableObject
ActiproSoftware.Text.TaggingTagAggregatorBaseT

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TagAggregatorBase<T> : DisposableObject,
    ITagAggregator<T>
where T : ITag

Public MustInherit Class TagAggregatorBase(Of T As ITag)
    Inherits DisposableObject
    Implements ITagAggregator(Of T)

Type Parameters

T
The type of ITag associated with this aggregator.

The TagAggregatorBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | TagAggregatorBaseT | Initializes a new instance of the TagAggregatorBase class.
Protected method | TagAggregatorBaseT(Boolean) | Initializes a new instance of the TagAggregatorBase class.
Top
Properties
 | Name | Description
Protected property | CanAttachToEvents | Gets whether the tag aggregator can attach to events.
Protected property | IsDisposed | Gets whether this object has been disposed.
Top
Methods
 | Name | Description
Protected method | AttachDocument | Attaches to a new document.
Protected method | DetachDocument | Detaches the document.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Protected method | GetTaggers | Returns the list of available taggers.
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Protected method | IsRefreshRequired | Returns whether a Refresh is required when the specified service is added to or removed from the document's language.
Protected method | OnTagsChanged | Raises the TagsChanged event.
Protected method | Refresh | Refreshes the tag aggregator by reloading the taggers being watched.
Top
Events
 | Name | Description
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Constructor

TagAggregatorBaseT Constructor

Overload List
 | Name | Description
Protected method | TagAggregatorBaseT | Initializes a new instance of the TagAggregatorBase class.
Protected method | TagAggregatorBaseT(Boolean) | Initializes a new instance of the TagAggregatorBase class.
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Constructor

TagAggregatorBaseT Constructor

Initializes a new instance of the TagAggregatorBase class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TagAggregatorBase()
Protected Sub New
See Also

Reference

TagAggregatorBaseT Class
TagAggregatorBaseT Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Constructor (Boolean)

TagAggregatorBaseT Constructor (Boolean)

Initializes a new instance of the TagAggregatorBase class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TagAggregatorBase(
    bool canAttachToEvents
)
Protected Sub New (
    canAttachToEvents As Boolean
)

Parameters

canAttachToEvents
Type: SystemBoolean
Whether to attach to events such as document language changes.
See Also

Reference

TagAggregatorBaseT Class
TagAggregatorBaseT Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Properties

TagAggregatorBaseT Properties

The TagAggregatorBaseT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CanAttachToEvents | Gets whether the tag aggregator can attach to events.
Protected property | IsDisposed | Gets whether this object has been disposed.
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).CanAttachToEvents Property

TagAggregatorBaseTCanAttachToEvents Property

Gets whether the tag aggregator can attach to events.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool CanAttachToEvents { get; }
Protected ReadOnly Property CanAttachToEvents As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).IsDisposed Property

TagAggregatorBaseTIsDisposed Property

Gets whether this object has been disposed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool IsDisposed { get; }
Protected ReadOnly Property IsDisposed As Boolean
    Get

Property Value

Type: Boolean
true if this object has been disposed; otherwise, false.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Methods

TagAggregatorBaseT Methods

The TagAggregatorBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | AttachDocument | Attaches to a new document.
Protected method | DetachDocument | Detaches the document.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Protected method | GetTaggers | Returns the list of available taggers.
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Protected method | IsRefreshRequired | Returns whether a Refresh is required when the specified service is added to or removed from the document's language.
Protected method | OnTagsChanged | Raises the TagsChanged event.
Protected method | Refresh | Refreshes the tag aggregator by reloading the taggers being watched.
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).AttachDocument Method

TagAggregatorBaseTAttachDocument Method

Attaches to a new document.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void AttachDocument(
    ICodeDocument newDocument
)
Protected Sub AttachDocument (
    newDocument As ICodeDocument
)

Parameters

newDocument
Type: ActiproSoftware.TextICodeDocument
The new ICodeDocument.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).DetachDocument Method

TagAggregatorBaseTDetachDocument Method

Detaches the document.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void DetachDocument()
Protected Sub DetachDocument
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).Dispose Method

TagAggregatorBaseTDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).Dispose Method (Boolean)

TagAggregatorBaseTDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

TagAggregatorBaseT Class
Dispose Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).GetTaggers Method

TagAggregatorBaseTGetTaggers Method

Returns the list of available taggers.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IList<ITagger<T>> GetTaggers()
Protected Overridable Function GetTaggers As IList(Of ITagger(Of T))

Return Value

Type: IList ITagger T
The list of available taggers.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).GetTags Method

TagAggregatorBaseTGetTags Method

Overload List
 | Name | Description
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).GetTags Method (TextSnapshotRange[])

TagAggregatorBaseTGetTags Method (TextSnapshotRange)

Returns the tag ranges that intersect with the specified snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<TagSnapshotRange<T>> GetTags(
    params TextSnapshotRange[] snapshotRanges
)
Public Function GetTags (
    ParamArray snapshotRanges As TextSnapshotRange()
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextTextSnapshotRange
The array of snapshot ranges.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified snapshot ranges.

Implements

ITagAggregatorTGetTags(TextSnapshotRange)
See Also

Reference

TagAggregatorBaseT Class
GetTags Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).GetTags Method (NormalizedTextSnapshotRangeCollection, Object)

TagAggregatorBaseTGetTags Method (NormalizedTextSnapshotRangeCollection, Object)

Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Public Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.

Implements

ITagAggregatorTGetTags(NormalizedTextSnapshotRangeCollection, Object)
See Also

Reference

TagAggregatorBaseT Class
GetTags Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).IsRefreshRequired Method

TagAggregatorBaseTIsRefreshRequired Method

Returns whether a Refresh is required when the specified service is added to or removed from the document's language.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsRefreshRequired(
    Object service
)
Protected Overridable Function IsRefreshRequired (
    service As Object
) As Boolean

Parameters

service
Type: SystemObject
The service to examine.

Return Value

Type: Boolean
true if a refresh is required; otherwise, false.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).OnTagsChanged Method

TagAggregatorBaseTOnTagsChanged Method

Raises the TagsChanged event.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnTagsChanged(
    TagsChangedEventArgs e
)
Protected Overridable Sub OnTagsChanged (
    e As TagsChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.TaggingTagsChangedEventArgs
A TagsChangedEventArgs that contains the event data.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).Refresh Method

TagAggregatorBaseTRefresh Method

Refreshes the tag aggregator by reloading the taggers being watched.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void Refresh()
Protected Sub Refresh
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Events

TagAggregatorBaseT Events

The TagAggregatorBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).TagsChanged Event

TagAggregatorBaseTTagsChanged Event

Occurs after available tags for a specified TextSnapshotRange have changed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TagsChangedEventArgs> TagsChanged
Public Event TagsChanged As EventHandler(Of TagsChangedEventArgs)

Value

Type: SystemEventHandler TagsChangedEventArgs

Implements

ITagAggregatorTTagsChanged
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys Class

Specifies the names of the built-in ITaggerT objects that are included with this product.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.TaggingTaggerKeys

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class TaggerKeys
Public NotInheritable Class TaggerKeys

The TaggerKeys type exposes the following members.

Fields
Name | Description
BookmarkIndicator | The bookmark indicator tagger.
BreakpointIndicator | The breakpoint indicator tagger.
CurrentStatementIndicator | The current statement indicator tagger.
FindMatchHighlight | The find match highlight tagger.
Token | The token tagger, that also generally provides the core classification types for text.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TaggerKeys Fields

The TaggerKeys type exposes the following members.

Fields
Name | Description
BookmarkIndicator | The bookmark indicator tagger.
BreakpointIndicator | The breakpoint indicator tagger.
CurrentStatementIndicator | The current statement indicator tagger.
FindMatchHighlight | The find match highlight tagger.
Token | The token tagger, that also generally provides the core classification types for text.
Top
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.BookmarkIndicator Field

TaggerKeysBookmarkIndicator Field

The bookmark indicator tagger.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const string BookmarkIndicator = "BookmarkIndicator"
Public Const BookmarkIndicator As String = "BookmarkIndicator"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.BreakpointIndicator Field

TaggerKeysBreakpointIndicator Field

The breakpoint indicator tagger.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const string BreakpointIndicator = "BreakpointIndicator"
Public Const BreakpointIndicator As String = "BreakpointIndicator"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.CurrentStatementIndicator Field

TaggerKeysCurrentStatementIndicator Field

The current statement indicator tagger.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const string CurrentStatementIndicator = "CurrentStatementIndicator"
Public Const CurrentStatementIndicator As String = "CurrentStatementIndicator"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.FindMatchHighlight Field

TaggerKeysFindMatchHighlight Field

The find match highlight tagger.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const string FindMatchHighlight = "FindMatchHighlight"
Public Const FindMatchHighlight As String = "FindMatchHighlight"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.Token Field

TaggerKeysToken Field

The token tagger, that also generally provides the core classification types for text.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const string Token = "Token"
Public Const Token As String = "Token"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TagsChangedEventArgs Class

Event arguments for when an ITaggerT alters tags on text.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.TextTextSnapshotRangeEventArgs
ActiproSoftware.Text.TaggingTagsChangedEventArgs

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TagsChangedEventArgs : TextSnapshotRangeEventArgs
Public Class TagsChangedEventArgs
    Inherits TextSnapshotRangeEventArgs

The TagsChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TagsChangedEventArgs | Initializes a new instance of the TagsChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange of the change. (Inherited from TextSnapshotRangeEventArgs.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TagsChangedEventArgs Constructor

Initializes a new instance of the TagsChangedEventArgs class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagsChangedEventArgs(
    TextSnapshotRange snapshotRange
)
Public Sub New (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange of the change.
See Also

Reference

TagsChangedEventArgs Class
ActiproSoftware.Text.Tagging Namespace


TagsChangedEventArgs Properties

The TagsChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange of the change. (Inherited from TextSnapshotRangeEventArgs.)
Top
See Also

Reference

TagsChangedEventArgs Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T) Class

TagSnapshotRangeT Class

Implements an object that represents an ITag and its associated TextSnapshotRange.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.TaggingTagSnapshotRangeT

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TagSnapshotRange<T>
where T : ITag

Public Class TagSnapshotRange(Of T As ITag)

Type Parameters

T
The type of tag associated with this range.

The TagSnapshotRangeT type exposes the following members.

Constructors
 | Name | Description
Public method | TagSnapshotRangeT | Initializes a new instance of the TagSnapshotRange class.
Top
Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange over which the Tag applies.
Public property | Tag | Gets the ITag data object associated with this range.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T) Constructor

TagSnapshotRangeT Constructor

Initializes a new instance of the TagSnapshotRange class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagSnapshotRange(
    TextSnapshotRange snapshotRange,
    T tag
)
Public Sub New (
    snapshotRange As TextSnapshotRange,
    tag As T
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which the Tag applies.
tag
Type: T
The ITag data object associated with this range.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T) Properties

TagSnapshotRangeT Properties

The TagSnapshotRangeT generic type exposes the following members.

Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange over which the Tag applies.
Public property | Tag | Gets the ITag data object associated with this range.
Top
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).SnapshotRange Property

TagSnapshotRangeTSnapshotRange Property

Gets the TextSnapshotRange over which the Tag applies.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextSnapshotRange SnapshotRange { get; }
Public ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange over which the Tag applies.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).Tag Property

TagSnapshotRangeTTag Property

Gets the ITag data object associated with this range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Tag { get; }
Public ReadOnly Property Tag As T
    Get

Property Value

Type: T
The ITag data object associated with this range.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T) Methods

TagSnapshotRangeT Methods

The TagSnapshotRangeT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).Equals Method

TagSnapshotRangeTEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).GetHashCode Method

TagSnapshotRangeTGetHashCode Method

Serves as a hash function for a particular type.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).ToString Method

TagSnapshotRangeTToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Class

TagVersionRangeT Class

Implements an object that represents an ITag and its associated ITextVersionRange.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.TaggingTagVersionRangeT

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TagVersionRange<T>
where T : ITag

Public Class TagVersionRange(Of T As ITag)

Type Parameters

T
The type of tag associated with this range.

The TagVersionRangeT type exposes the following members.

Constructors
 | Name | Description
Public method | TagVersionRangeT(ITextVersionRange, T) | Initializes a new instance of the TagVersionRange class.
Public method | TagVersionRangeT(TextSnapshotRange, TextRangeTrackingModes, T) | Initializes a new instance of the TagVersionRange class.
Top
Properties
 | Name | Description
Public property | Tag | Gets the ITag data object associated with this range.
Public property | VersionRange | Gets the ITextVersionRange over which the Tag applies.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Constructor

TagVersionRangeT Constructor

Overload List
 | Name | Description
Public method | TagVersionRangeT(ITextVersionRange, T) | Initializes a new instance of the TagVersionRange class.
Public method | TagVersionRangeT(TextSnapshotRange, TextRangeTrackingModes, T) | Initializes a new instance of the TagVersionRange class.
Top
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Constructor (ITextVersionRange, T)

TagVersionRangeT Constructor (ITextVersionRange, T)

Initializes a new instance of the TagVersionRange class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagVersionRange(
    ITextVersionRange versionRange,
    T tag
)
Public Sub New (
    versionRange As ITextVersionRange,
    tag As T
)

Parameters

versionRange
Type: ActiproSoftware.TextITextVersionRange
The ITextVersionRange over which the Tag applies.
tag
Type: T
The ITag data object associated with this range.
See Also

Reference

TagVersionRangeT Class
TagVersionRangeT Overload
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Constructor (TextSnapshotRange, TextRangeTrackingModes, T)

TagVersionRangeT Constructor (TextSnapshotRange, TextRangeTrackingModes, T)

Initializes a new instance of the TagVersionRange class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagVersionRange(
    TextSnapshotRange snapshotRange,
    TextRangeTrackingModes trackingModes,
    T tag
)
Public Sub New (
    snapshotRange As TextSnapshotRange,
    trackingModes As TextRangeTrackingModes,
    tag As T
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which the Tag applies.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.
tag
Type: T
The ITag data object associated with this range.
See Also

Reference

TagVersionRangeT Class
TagVersionRangeT Overload
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Properties

TagVersionRangeT Properties

The TagVersionRangeT generic type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets the ITag data object associated with this range.
Public property | VersionRange | Gets the ITextVersionRange over which the Tag applies.
Top
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T).Tag Property

TagVersionRangeTTag Property

Gets the ITag data object associated with this range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Tag { get; }
Public ReadOnly Property Tag As T
    Get

Property Value

Type: T
The ITag data object associated with this range.
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T).VersionRange Property

TagVersionRangeTVersionRange Property

Gets the ITextVersionRange over which the Tag applies.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextVersionRange VersionRange { get; }
Public ReadOnly Property VersionRange As ITextVersionRange
    Get

Property Value

Type: ITextVersionRange
The ITextVersionRange over which the Tag applies.
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Methods

TagVersionRangeT Methods

The TagVersionRangeT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T).Equals Method

TagVersionRangeTEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T).GetHashCode Method

TagVersionRangeTGetHashCode Method

Serves as a hash function for a particular type.

Namespace: ActiproSoftware.Text.Tagging
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


ActiproSoftware.Text.Tagging.Implementation Namespace

Contains implementation types related to tagging text ranges with custom data.
Classes
 | Class | Description
Public class | BookmarkIndicatorTag | Represents an IIndicatorTag that renders a bookmark indicator.
Public class | BookmarkIndicatorTagger | Provides BookmarkIndicatorTag objects over text ranges.
Public class | BreakpointIndicatorTag | Represents an IIndicatorTag that renders a breakpoint over a text range.
Public class | BreakpointIndicatorTagger | Provides BreakpointIndicatorTag objects over text ranges.
Public class | ClassificationTag | Represents an ITag that can be used to associate an IClassificationType with some text range by implementing IClassificationTag.
Public class | CodeDocumentTaggerProviderTTagger | Provides an ICodeDocumentTaggerProvider capable of creating ITaggerT objects which have a constructor that accepts a single ICodeDocument instance parameter.
Public class | CollectionTaggerT | Provides a thread-safe ITaggerT implementation that maintains a simple collection of tagged ranges.
Public class | CurrentStatementIndicatorTag | Represents an IIndicatorTag that renders a current statement marker over a text range.
Public class | CurrentStatementIndicatorTagger | Provides CurrentStatementIndicatorTag objects over text ranges.
Public class | DelimiterHighlightTagger | Provides a view-based classification tagger that tags delimiter pairs or sets.
Public class | IndicatorClassificationTagBase | Provides the abstract base class for an ITag that can be used to mark an indicator and classification over a text range.
Public class | IndicatorClassificationTaggerBaseTTag | Represents the abstract base class for providing IIndicatorTag and IClassificationTag objects over text ranges.
Public class | IndicatorTagBase | Provides the abstract base class for an ITag that can be used to mark an indicator over a text range.
Public class | IndicatorTaggerBaseTTag | Represents the abstract base class for providing IIndicatorTag objects over text ranges.
Public class | ParseErrorTagger | Provides an ITaggerT implementation that tags IParseError objects found in a document's parse data.
Public class | ReadOnlyRegionTag | Represents an ITag that can be used to mark a text range as read-only, and can optionally associate an IClassificationType.
Public class | SearchResultHighlightTagger | Provides a view-based classification tagger that tags search results.
Public class | SquiggleTag | Provides a basic ISquiggleTag implementation, generally used for error display, that can be associated with some text range.
Public class | StyleRegistryClassificationTag | Provides a ClassificationTag implementation that uses an alternate IHighlightingStyleRegistry, and can be associated with some text range.
Public class | TaggerBaseT | Provides an abstract base class for an ITaggerT implementation.
Public class | TaggerProviderBaseTTagger | Provides an abstract tagger provider base class that automatically returns the TagTypes supported based on reflection of the TTagger type.
Public class | TagSearchOptionsT | Stores tag search operation options.
Public class | TextViewTaggerProviderTTagger | Provides an ITextViewTaggerProvider capable of creating ITaggerT objects which have a constructor that accepts a single ITextView instance parameter.
Public class | TokenClassificationTag | Represents an ITag that can be used to associate an IClassificationType and an IToken with some text range by implementing IClassificationTag and ITokenTag.
Public class | TokenTagger | An ITaggerT implementation that provides ITokenTag and IClassificationTag objects based on a language's ILexer.
Public class | TokenTaggerProviderTTagger | Provides an ICodeDocumentTaggerProvider capable of creating TokenTagger objects which have a constructor that accepts a single ICodeDocument instance parameter.


BookmarkIndicatorTag Class

Represents an IIndicatorTag that renders a bookmark indicator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationBookmarkIndicatorTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BookmarkIndicatorTag : IndicatorTagBase,
    INotifyPropertyChanged
Public Class BookmarkIndicatorTag
    Inherits IndicatorTagBase
    Implements INotifyPropertyChanged

The BookmarkIndicatorTag type exposes the following members.

Constructors
 | Name | Description
Public method | BookmarkIndicatorTag | Initializes a new instance of the BookmarkIndicatorTag class
Top
Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Public property | IsEnabled | Gets or sets whether the bookmark is enabled.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin. (Overrides IndicatorTagBaseDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments. (Inherited from IndicatorTagBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag Constructor

Initializes a new instance of the BookmarkIndicatorTag class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BookmarkIndicatorTag()
Public Sub New
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag Properties

The BookmarkIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Public property | IsEnabled | Gets or sets whether the bookmark is enabled.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.IsEnabled Property

BookmarkIndicatorTagIsEnabled Property

Gets or sets whether the bookmark is enabled.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the bookmark is enabled; otherwise, false.
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag Methods

The BookmarkIndicatorTag type exposes the following members.

Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin. (Overrides IndicatorTagBaseDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments. (Inherited from IndicatorTagBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Top
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.DrawGlyph Method

BookmarkIndicatorTagDrawGlyph Method

Draws the indicator's glyph in an editor view margin.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void DrawGlyph(
    TextViewDrawContext context,
    ITextViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Public Overrides Sub DrawGlyph (
    context As TextViewDrawContext,
    viewLine As ITextViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
)

Parameters

context
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationTextViewDrawContext
The TextViewDrawContext to use for rendering.
viewLine
Type: ActiproSoftware.Windows.Controls.SyntaxEditorITextViewLine
The ITextViewLine for which the glyph is rendered.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: System.WindowsRect
The bounds in which the indicator will be rendered.

Implements

IIndicatorTagDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect)
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.NotifyPropertyChanged Method

BookmarkIndicatorTagNotifyPropertyChanged Method

Notifies that a property has changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.OnPropertyChanged Method

BookmarkIndicatorTagOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag Events

The BookmarkIndicatorTag type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.PropertyChanged Event

BookmarkIndicatorTagPropertyChanged Event

Occurs when a property has been changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Class

Provides BookmarkIndicatorTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase BookmarkIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger BookmarkIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBase BookmarkIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationBookmarkIndicatorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BookmarkIndicatorTagger : IndicatorTaggerBase<BookmarkIndicatorTag>
Public Class BookmarkIndicatorTagger
    Inherits IndicatorTaggerBase(Of BookmarkIndicatorTag)

The BookmarkIndicatorTagger type exposes the following members.

Constructors
 | Name | Description
Public method | BookmarkIndicatorTagger | Initializes a new instance of the BookmarkIndicatorTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Constructor

Initializes a new instance of the BookmarkIndicatorTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BookmarkIndicatorTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

BookmarkIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Properties

The BookmarkIndicatorTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

BookmarkIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Methods

The BookmarkIndicatorTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
See Also

Reference

BookmarkIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Events

The BookmarkIndicatorTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

BookmarkIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Class

Represents an IIndicatorTag that renders a breakpoint over a text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTagBase
ActiproSoftware.Text.Tagging.ImplementationBreakpointIndicatorTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BreakpointIndicatorTag : IndicatorClassificationTagBase,
    INotifyPropertyChanged
Public Class BreakpointIndicatorTag
    Inherits IndicatorClassificationTagBase
    Implements INotifyPropertyChanged

The BreakpointIndicatorTag type exposes the following members.

Constructors
 | Name | Description
Public method | BreakpointIndicatorTag | Initializes a new instance of the BreakpointIndicatorTag class
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag. (Overrides IndicatorClassificationTagBaseClassificationType.)
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Public property | IsEnabled | Gets or sets whether the breakpoint is enabled.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin. (Overrides IndicatorTagBaseDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments. (Inherited from IndicatorTagBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Constructor

Initializes a new instance of the BreakpointIndicatorTag class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BreakpointIndicatorTag()
Public Sub New
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Properties

The BreakpointIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag. (Overrides IndicatorClassificationTagBaseClassificationType.)
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Public property | IsEnabled | Gets or sets whether the breakpoint is enabled.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.ClassificationType Property

BreakpointIndicatorTagClassificationType Property

Gets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IClassificationType ClassificationType { get; }
Public Overrides ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.IsEnabled Property

BreakpointIndicatorTagIsEnabled Property

Gets or sets whether the breakpoint is enabled.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the breakpoint is enabled; otherwise, false.
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Methods

The BreakpointIndicatorTag type exposes the following members.

Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin. (Overrides IndicatorTagBaseDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments. (Inherited from IndicatorTagBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Top
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.DrawGlyph Method

BreakpointIndicatorTagDrawGlyph Method

Draws the indicator's glyph in an editor view margin.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void DrawGlyph(
    TextViewDrawContext context,
    ITextViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Public Overrides Sub DrawGlyph (
    context As TextViewDrawContext,
    viewLine As ITextViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
)

Parameters

context
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationTextViewDrawContext
The TextViewDrawContext to use for rendering.
viewLine
Type: ActiproSoftware.Windows.Controls.SyntaxEditorITextViewLine
The ITextViewLine for which the glyph is rendered.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: System.WindowsRect
The bounds in which the indicator will be rendered.

Implements

IIndicatorTagDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect)
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.NotifyPropertyChanged Method

BreakpointIndicatorTagNotifyPropertyChanged Method

Notifies that a property has changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.OnPropertyChanged Method

BreakpointIndicatorTagOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Events

The BreakpointIndicatorTag type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.PropertyChanged Event

BreakpointIndicatorTagPropertyChanged Event

Occurs when a property has been changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Class

Provides BreakpointIndicatorTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase BreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger BreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBase BreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTaggerBase BreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationBreakpointIndicatorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BreakpointIndicatorTagger : IndicatorClassificationTaggerBase<BreakpointIndicatorTag>
Public Class BreakpointIndicatorTagger
    Inherits IndicatorClassificationTaggerBase(Of BreakpointIndicatorTag)

The BreakpointIndicatorTagger type exposes the following members.

Constructors
 | Name | Description
Public method | BreakpointIndicatorTagger | Initializes a new instance of the BreakpointIndicatorTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Constructor

Initializes a new instance of the BreakpointIndicatorTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BreakpointIndicatorTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

BreakpointIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Properties

The BreakpointIndicatorTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

BreakpointIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Methods

The BreakpointIndicatorTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
See Also

Reference

BreakpointIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Events

The BreakpointIndicatorTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

BreakpointIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Class

Represents an ITag that can be used to associate an IClassificationType with some text range by implementing IClassificationTag.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationClassificationTag
ActiproSoftware.Text.Tagging.ImplementationReadOnlyRegionTag
ActiproSoftware.Text.Tagging.ImplementationStyleRegistryClassificationTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ClassificationTag : IClassificationTag,
    ITag
Public Class ClassificationTag
    Implements IClassificationTag, ITag

The ClassificationTag type exposes the following members.

Constructors
 | Name | Description
Public method | ClassificationTag | Initializes a new instance of the ClassificationTag class.
Public method | ClassificationTag(IClassificationType) | Initializes a new instance of the ClassificationTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Top
Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Constructor

Overload List
 | Name | Description
Public method | ClassificationTag | Initializes a new instance of the ClassificationTag class.
Public method | ClassificationTag(IClassificationType) | Initializes a new instance of the ClassificationTag class.
Top
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Constructor

Initializes a new instance of the ClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ClassificationTag()
Public Sub New
See Also

Reference

ClassificationTag Class
ClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Constructor (IClassificationType)

Initializes a new instance of the ClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ClassificationTag(
    IClassificationType classificationType
)
Public Sub New (
    classificationType As IClassificationType
)

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
See Also

Reference

ClassificationTag Class
ClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Properties

The ClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Top
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag.ClassificationType Property

ClassificationTagClassificationType Property

Gets or sets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Methods

The ClassificationTag type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag.ToString Method

ClassificationTagToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Class

CodeDocumentTaggerProviderTTagger Class

Provides an ICodeDocumentTaggerProvider capable of creating ITaggerT objects which have a constructor that accepts a single ICodeDocument instance parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase TTagger
ActiproSoftware.Text.Tagging.ImplementationCodeDocumentTaggerProviderTTagger
ActiproSoftware.Text.Tagging.ImplementationTokenTaggerProviderTTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CodeDocumentTaggerProvider<TTagger> : TaggerProviderBase<TTagger>,
    ICodeDocumentTaggerProvider
where TTagger : class

Public Class CodeDocumentTaggerProvider(Of TTagger As Class)
    Inherits TaggerProviderBase(Of TTagger)
    Implements ICodeDocumentTaggerProvider

Type Parameters

TTagger
The Type of ITaggerT that this provider creates. The tagger type must have a constructor that accepts a single ICodeDocument instance parameter.

The CodeDocumentTaggerProviderTTagger type exposes the following members.

Constructors
 | Name | Description
Public method | CodeDocumentTaggerProviderTTagger | Initializes a new instance of the CodeDocumentTaggerProvider class.
Public method | CodeDocumentTaggerProviderTTagger(Object) | Initializes a new instance of the CodeDocumentTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Constructor

CodeDocumentTaggerProviderTTagger Constructor

Overload List
 | Name | Description
Public method | CodeDocumentTaggerProviderTTagger | Initializes a new instance of the CodeDocumentTaggerProvider class.
Public method | CodeDocumentTaggerProviderTTagger(Object) | Initializes a new instance of the CodeDocumentTaggerProvider class.
Top
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Constructor

CodeDocumentTaggerProviderTTagger Constructor

Initializes a new instance of the CodeDocumentTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CodeDocumentTaggerProvider()
Public Sub New
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
CodeDocumentTaggerProviderTTagger Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Constructor (Object)

CodeDocumentTaggerProviderTTagger Constructor (Object)

Initializes a new instance of the CodeDocumentTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CodeDocumentTaggerProvider(
    Object singletonKey
)
Public Sub New (
    singletonKey As Object
)

Parameters

singletonKey
Type: SystemObject
When a non-null value is passed, the tagger will be stored as a singleton under the specified key in the document's properties.
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
CodeDocumentTaggerProviderTTagger Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Properties

CodeDocumentTaggerProviderTTagger Properties

The CodeDocumentTaggerProviderTTagger generic type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Methods

CodeDocumentTaggerProviderTTagger Methods

The CodeDocumentTaggerProviderTTagger generic type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument.
Top
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger).GetTagger(T) Method

CodeDocumentTaggerProviderTTaggerGetTaggerT Method

Returns an ITaggerT for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires an ITaggerT.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
An ITaggerT for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Class

CollectionTaggerT Class

Provides a thread-safe ITaggerT implementation that maintains a simple collection of tagged ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase T
ActiproSoftware.Text.Tagging.ImplementationCollectionTaggerT
ActiproSoftware.Text.Tagging.ImplementationDelimiterHighlightTagger
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBaseTTag
ActiproSoftware.Text.Tagging.ImplementationParseErrorTagger
ActiproSoftware.Text.Tagging.ImplementationSearchResultHighlightTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class CollectionTagger<T> : TaggerBase<T>,
    IEnumerable, IKeyedObject, INotifyCollectionChanged, ITagger<T>, ICollection<TagVersionRange<T>>,
    IEnumerable<TagVersionRange<T>>, ICollectionTagger<T>, IOrderable
where T : class, ITag

Public MustInherit Class CollectionTagger(Of T As {Class, ITag})
    Inherits TaggerBase(Of T)
    Implements IEnumerable, IKeyedObject, INotifyCollectionChanged, ITagger(Of T),
    ICollection(Of TagVersionRange(Of T)), IEnumerable(Of TagVersionRange(Of T)),
    ICollectionTagger(Of T), IOrderable

Type Parameters

T
The type of tag associated with this tagger.

The CollectionTaggerT type exposes the following members.

Constructors
 | Name | Description
Protected method | CollectionTaggerT | Initializes a new instance of the CollectionTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection.
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo |
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Overrides TaggerBaseTGetTags(NormalizedTextSnapshotRangeCollection, Object).)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate.
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed.
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Constructor

CollectionTaggerT Constructor

Initializes a new instance of the CollectionTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected CollectionTagger(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document,
    bool isForLanguage
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument,
    isForLanguage As Boolean
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
isForLanguage
Type: SystemBoolean
Indicates whether this tagger is for a language. If true, the tagger is closed when the document's language changes.
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Properties

CollectionTaggerT Properties

The CollectionTaggerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Count Property

CollectionTaggerTCount Property

Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.

Implements

ICollectionTCount
ICollectionTaggerTCount
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Item Property

CollectionTaggerTItem Property

Gets the tag range that points to the specified tag.

[C#] In C#, this property is the indexer for the CollectionTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagVersionRange<T> this[
    T tag
] { get; }
Public ReadOnly Default Property Item (
    tag As T
) As TagVersionRange(Of T)
    Get

Parameters

tag
Type: T
The tag for which to search.

Property Value

Type: TagVersionRange T
The tag range that points to the specified tag.

Implements

ICollectionTaggerTItemT
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Methods

CollectionTaggerT Methods

The CollectionTaggerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection.
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo |
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Overrides TaggerBaseTGetTags(NormalizedTextSnapshotRangeCollection, Object).)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate.
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Add Method

CollectionTaggerTAdd Method

Overload List
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Add Method (TagVersionRange(T))

CollectionTaggerTAdd Method (TagVersionRangeT)

Adds a tag range to the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Add(
    TagVersionRange<T> tagRange
)
Public Sub Add (
    tagRange As TagVersionRange(Of T)
)

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The tag range to add to the collection.

Implements

ICollectionTAdd(T)
ICollectionTaggerTAdd(TagVersionRangeT)
Remarks
This is the lowest-level method used for adding a tag range, and gives the most control over snapshot translation options.
See Also

Reference

CollectionTaggerT Class
Add Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Add Method (ITextSnapshotLine, T)

CollectionTaggerTAdd Method (ITextSnapshotLine, T)

Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagVersionRange<T> Add(
    ITextSnapshotLine snapshotLine,
    T tag
)
Public Function Add (
    snapshotLine As ITextSnapshotLine,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: T
The ITag to add.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created.

Implements

ICollectionTaggerTAdd(ITextSnapshotLine, T)
Remarks
The generated ITextVersionRange is created with the DeleteWhenZeroLength and LineBased flags.
See Also

Reference

CollectionTaggerT Class
Add Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Add Method (TextSnapshotRange, T)

CollectionTaggerTAdd Method (TextSnapshotRange, T)

Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagVersionRange<T> Add(
    TextSnapshotRange snapshotRange,
    T tag
)
Public Function Add (
    snapshotRange As TextSnapshotRange,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: T
The ITag to add.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created.

Implements

ICollectionTaggerTAdd(TextSnapshotRange, T)
Remarks
The generated ITextVersionRange is created with the DeleteWhenZeroLength flag.
See Also

Reference

CollectionTaggerT Class
Add Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Clear Method

CollectionTaggerTClear Method

Removes all items from the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
ICollectionTaggerTClear
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Contains Method

CollectionTaggerTContains Method

Determines whether the collection contains a specific value.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    TagVersionRange<T> tagRange
)
Public Function Contains (
    tagRange As TagVersionRange(Of T)
) As Boolean

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The object to locate in the collection.

Return Value

Type: Boolean
true if the item is found in the collection; otherwise, false.

Implements

ICollectionTContains(T)
ICollectionTaggerTContains(TagVersionRangeT)
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).CopyTo Method

CollectionTaggerTCopyTo Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Tagging.Implementation.CollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyTo(
    TagVersionRange<T>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As TagVersionRange(Of T)(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.TaggingTagVersionRange T

[Missing <param name="array"/> documentation for "M:ActiproSoftware.Text.Tagging.Implementation.CollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

arrayIndex
Type: SystemInt32

[Missing <param name="arrayIndex"/> documentation for "M:ActiproSoftware.Text.Tagging.Implementation.CollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

Implements

ICollectionTCopyTo(T, Int32)
ICollectionTaggerTCopyTo(TagVersionRangeT, Int32)
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).CreateBatch Method

CollectionTaggerTCreateBatch Method

Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDisposable CreateBatch()
Public Function CreateBatch As IDisposable

Return Value

Type: IDisposable
An IDisposable object. Once disposed, the batch is ended.

Implements

ICollectionTaggerTCreateBatch
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).FindNext Method

CollectionTaggerTFindNext Method

Overload List
 | Name | Description
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).FindNext Method (ITextSnapshotLine, ITagSearchOptions(T))

CollectionTaggerTFindNext Method (ITextSnapshotLine, ITagSearchOptionsT)

Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagVersionRange<T> FindNext(
    ITextSnapshotLine snapshotLine,
    ITagSearchOptions<T> options
)
Public Function FindNext (
    snapshotLine As ITextSnapshotLine,
    options As ITagSearchOptions(Of T)
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The ITextSnapshotLine from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions T
The optional ITagSearchOptionsT that specifies search options.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was found, if any.

Implements

ICollectionTaggerTFindNext(ITextSnapshotLine, ITagSearchOptionsT)
See Also

Reference

CollectionTaggerT Class
FindNext Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).FindNext Method (TextSnapshotOffset, ITagSearchOptions(T))

CollectionTaggerTFindNext Method (TextSnapshotOffset, ITagSearchOptionsT)

Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagVersionRange<T> FindNext(
    TextSnapshotOffset snapshotOffset,
    ITagSearchOptions<T> options
)
Public Function FindNext (
    snapshotOffset As TextSnapshotOffset,
    options As ITagSearchOptions(Of T)
) As TagVersionRange(Of T)

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions T
The optional ITagSearchOptionsT that specifies search options.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was found, if any.

Implements

ICollectionTaggerTFindNext(TextSnapshotOffset, ITagSearchOptionsT)
See Also

Reference

CollectionTaggerT Class
FindNext Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).GetEnumerator Method

CollectionTaggerTGetEnumerator Method

Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<TagVersionRange<T>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TagVersionRange(Of T))

Return Value

Type: IEnumerator TagVersionRange T
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
ICollectionTaggerTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).GetTags Method

CollectionTaggerTGetTags Method

Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Public Overrides Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.

Implements

ITaggerTGetTags(NormalizedTextSnapshotRangeCollection, Object)
ITaggerTGetTags(NormalizedTextSnapshotRangeCollection, Object)
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Remove Method

CollectionTaggerTRemove Method

Overload List
 | Name | Description
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Remove Method (T)

CollectionTaggerTRemove Method (T)

Removes a specific tag instance from the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Remove(
    T tag
)
Public Function Remove (
    tag As T
) As Boolean

Parameters

tag
Type: T
The ITag to remove from the collection.

Return Value

Type: Boolean
true if the tag was successfully removed from the collection; otherwise, false

Implements

ICollectionTaggerTRemove(TagVersionRangeT)
See Also

Reference

CollectionTaggerT Class
Remove Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Remove Method (TagVersionRange(T))

CollectionTaggerTRemove Method (TagVersionRangeT)

Removes the first occurrence of a specific tag range from the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Remove(
    TagVersionRange<T> tagRange
)
Public Function Remove (
    tagRange As TagVersionRange(Of T)
) As Boolean

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The tag range to remove from the collection.

Return Value

Type: Boolean
true if the tag range was successfully removed from the collection; otherwise, false

Implements

ICollectionTRemove(T)
ICollectionTaggerTRemove(TagVersionRangeT)
See Also

Reference

CollectionTaggerT Class
Remove Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).RemoveAll Method

CollectionTaggerTRemoveAll Method

Removes all objects that match the conditions defined by the specified predicate.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int RemoveAll(
    Predicate<TagVersionRange<T>> match
)
Public Function RemoveAll (
    match As Predicate(Of TagVersionRange(Of T))
) As Integer

Parameters

match
Type: SystemPredicate TagVersionRange T
The predicate that defines the conditions for removal.

Return Value

Type: Int32
The number of objects that were removed.

Implements

ICollectionTaggerTRemoveAll(PredicateTagVersionRangeT)
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Toggle Method

CollectionTaggerTToggle Method

Overload List
 | Name | Description
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Toggle Method (ITextSnapshotLine, T)

CollectionTaggerTToggle Method (ITextSnapshotLine, T)

Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagVersionRange<T> Toggle(
    ITextSnapshotLine snapshotLine,
    T tag
)
Public Function Toggle (
    snapshotLine As ITextSnapshotLine,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: T
The ITag to add, if no tag is already on the line.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created, if a tag was added.

Implements

ICollectionTaggerTToggle(ITextSnapshotLine, T)
See Also

Reference

CollectionTaggerT Class
Toggle Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Toggle Method (TextSnapshotRange, T)

CollectionTaggerTToggle Method (TextSnapshotRange, T)

Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagVersionRange<T> Toggle(
    TextSnapshotRange snapshotRange,
    T tag
)
Public Function Toggle (
    snapshotRange As TextSnapshotRange,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: T
The ITag to add, if no tag is already in the text range.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created, if a tag was added.

Implements

ICollectionTaggerTToggle(TextSnapshotRange, T)
See Also

Reference

CollectionTaggerT Class
Toggle Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Events

CollectionTaggerT Events

The CollectionTaggerT generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed.
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).CollectionChanged Event

CollectionTaggerTCollectionChanged Event

Occurs when the collection is changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag Class

Represents an IIndicatorTag that renders a current statement marker over a text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTagBase
ActiproSoftware.Text.Tagging.ImplementationCurrentStatementIndicatorTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CurrentStatementIndicatorTag : IndicatorClassificationTagBase
Public Class CurrentStatementIndicatorTag
    Inherits IndicatorClassificationTagBase

The CurrentStatementIndicatorTag type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentStatementIndicatorTag | Initializes a new instance of the CurrentStatementIndicatorTag class
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag. (Overrides IndicatorClassificationTagBaseClassificationType.)
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin. (Overrides IndicatorTagBaseDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag Constructor

Initializes a new instance of the CurrentStatementIndicatorTag class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CurrentStatementIndicatorTag()
Public Sub New
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag Properties

The CurrentStatementIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag. (Overrides IndicatorClassificationTagBaseClassificationType.)
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag.ClassificationType Property

CurrentStatementIndicatorTagClassificationType Property

Gets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IClassificationType ClassificationType { get; }
Public Overrides ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag Methods

The CurrentStatementIndicatorTag type exposes the following members.

Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin. (Overrides IndicatorTagBaseDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag.DrawGlyph Method

CurrentStatementIndicatorTagDrawGlyph Method

Draws the indicator's glyph in an editor view margin.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void DrawGlyph(
    TextViewDrawContext context,
    ITextViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Public Overrides Sub DrawGlyph (
    context As TextViewDrawContext,
    viewLine As ITextViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
)

Parameters

context
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationTextViewDrawContext
The TextViewDrawContext to use for rendering.
viewLine
Type: ActiproSoftware.Windows.Controls.SyntaxEditorITextViewLine
The ITextViewLine for which the glyph is rendered.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: System.WindowsRect
The bounds in which the indicator will be rendered.

Implements

IIndicatorTagDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect)
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Class

Provides CurrentStatementIndicatorTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase CurrentStatementIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger CurrentStatementIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBase CurrentStatementIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTaggerBase CurrentStatementIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCurrentStatementIndicatorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CurrentStatementIndicatorTagger : IndicatorClassificationTaggerBase<CurrentStatementIndicatorTag>
Public Class CurrentStatementIndicatorTagger
    Inherits IndicatorClassificationTaggerBase(Of CurrentStatementIndicatorTag)

The CurrentStatementIndicatorTagger type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentStatementIndicatorTagger | Initializes a new instance of the CurrentStatementIndicatorTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Constructor

Initializes a new instance of the CurrentStatementIndicatorTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CurrentStatementIndicatorTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

CurrentStatementIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Properties

The CurrentStatementIndicatorTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CurrentStatementIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Methods

The CurrentStatementIndicatorTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
See Also

Reference

CurrentStatementIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Events

The CurrentStatementIndicatorTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CurrentStatementIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Class

Provides a view-based classification tagger that tags delimiter pairs or sets.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase IDelimiterHighlightTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger IDelimiterHighlightTag
ActiproSoftware.Text.Tagging.ImplementationDelimiterHighlightTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DelimiterHighlightTagger : CollectionTagger<IDelimiterHighlightTag>,
    IParseTarget, IKeyedObject, IParser
Public Class DelimiterHighlightTagger
    Inherits CollectionTagger(Of IDelimiterHighlightTag)
    Implements IParseTarget, IKeyedObject, IParser

The DelimiterHighlightTagger type exposes the following members.

Constructors
 | Name | Description
Public method | DelimiterHighlightTagger | Initializes a new instance of the DelimiterHighlightTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Constructor

Initializes a new instance of the DelimiterHighlightTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DelimiterHighlightTagger(
    IEditorView view
)
Public Sub New (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The view to which this manager is attached.
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Properties

The DelimiterHighlightTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Methods

The DelimiterHighlightTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger.OnClosed Method

DelimiterHighlightTaggerOnClosed Method

Occurs when the tagger is closed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Events

The DelimiterHighlightTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase Class

Provides the abstract base class for an ITag that can be used to mark an indicator and classification over a text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTagBase
ActiproSoftware.Text.Tagging.ImplementationBreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCurrentStatementIndicatorTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class IndicatorClassificationTagBase : IndicatorTagBase,
    ITag, IClassificationTag
Public MustInherit Class IndicatorClassificationTagBase
    Inherits IndicatorTagBase
    Implements ITag, IClassificationTag

The IndicatorClassificationTagBase type exposes the following members.

Constructors
 | Name | Description
Protected method | IndicatorClassificationTagBase | Initializes a new instance of the IndicatorClassificationTagBase class
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase Constructor

Initializes a new instance of the IndicatorClassificationTagBase class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IndicatorClassificationTagBase()
Protected Sub New
See Also

Reference

IndicatorClassificationTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase Properties

The IndicatorClassificationTagBase type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

IndicatorClassificationTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase.ClassificationType Property

IndicatorClassificationTagBaseClassificationType Property

Gets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract IClassificationType ClassificationType { get; }
Public MustOverride ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

IndicatorClassificationTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase Methods

The IndicatorClassificationTagBase type exposes the following members.

Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds. (Inherited from IndicatorTagBase.)
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

IndicatorClassificationTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Class

IndicatorClassificationTaggerBaseTTag Class

Represents the abstract base class for providing IIndicatorTag and IClassificationTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase TTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger TTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBase TTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTaggerBaseTTag
ActiproSoftware.Text.Tagging.ImplementationBreakpointIndicatorTagger
ActiproSoftware.Text.Tagging.ImplementationCurrentStatementIndicatorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class IndicatorClassificationTaggerBase<TTag> : IndicatorTaggerBase<TTag>,
    IKeyedObject, IOrderable, ITagger<IClassificationTag>
where TTag : class, IIndicatorTag, IClassificationTag

Public MustInherit Class IndicatorClassificationTaggerBase(Of TTag As {Class, IIndicatorTag, IClassificationTag})
    Inherits IndicatorTaggerBase(Of TTag)
    Implements IKeyedObject, IOrderable, ITagger(Of IClassificationTag)

Type Parameters

TTag

[Missing <typeparam name="TTag"/> documentation for "T:ActiproSoftware.Text.Tagging.Implementation.IndicatorClassificationTaggerBase`1"]

The IndicatorClassificationTaggerBaseTTag type exposes the following members.

Constructors
 | Name | Description
Protected method | IndicatorClassificationTaggerBaseTTag | Initializes a new instance of the IndicatorClassificationTaggerBase class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Constructor

IndicatorClassificationTaggerBaseTTag Constructor

Initializes a new instance of the IndicatorClassificationTaggerBase class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IndicatorClassificationTaggerBase(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document,
    bool isForLanguage
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument,
    isForLanguage As Boolean
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
isForLanguage
Type: SystemBoolean
Indicates whether this tagger is for a language. If true, the tagger is closed when the document's language changes.
See Also

Reference

IndicatorClassificationTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Properties

IndicatorClassificationTaggerBaseTTag Properties

The IndicatorClassificationTaggerBaseTTag generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

IndicatorClassificationTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Methods

IndicatorClassificationTaggerBaseTTag Methods

The IndicatorClassificationTaggerBaseTTag generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
See Also

Reference

IndicatorClassificationTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Events

IndicatorClassificationTaggerBaseTTag Events

The IndicatorClassificationTaggerBaseTTag generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

IndicatorClassificationTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase Class

Provides the abstract base class for an ITag that can be used to mark an indicator over a text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationBookmarkIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTagBase

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class IndicatorTagBase : ITag,
    IIndicatorTag
Public MustInherit Class IndicatorTagBase
    Implements ITag, IIndicatorTag

The IndicatorTagBase type exposes the following members.

Constructors
 | Name | Description
Protected method | IndicatorTagBase | Initializes a new instance of the IndicatorTagBase class
Top
Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin.
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds.
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase Constructor

Initializes a new instance of the IndicatorTagBase class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IndicatorTagBase()
Protected Sub New
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase Properties

The IndicatorTagBase type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Public property | GlyphSize | Gets the size of the indicator's glyph in an editor view margin.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.ContentProvider Property

IndicatorTagBaseContentProvider Property

Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IContentProvider ContentProvider { get; set; }
Public Property ContentProvider As IContentProvider
    Get
    Set

Property Value

Type: IContentProvider
The optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Implements

IIndicatorTagContentProvider
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.GlyphSize Property

IndicatorTagBaseGlyphSize Property

Gets the size of the indicator's glyph in an editor view margin.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Size GlyphSize { get; }
Public Overridable ReadOnly Property GlyphSize As Size
    Get

Property Value

Type: Size
The size of the indicator's glyph in an editor view margin.
Remarks
The default return value is 16, 16.
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.Tag Property

IndicatorTagBaseTag Property

Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .

Implements

IIndicatorTagTag
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase Methods

The IndicatorTagBase type exposes the following members.

Methods
 | Name | Description
Public method | DrawGlyph | Draws the indicator's glyph in an editor view margin.
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds.
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments.
Top
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.DrawGlyph Method

IndicatorTagBaseDrawGlyph Method

Draws the indicator's glyph in an editor view margin.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void DrawGlyph(
    TextViewDrawContext context,
    ITextViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Public MustOverride Sub DrawGlyph (
    context As TextViewDrawContext,
    viewLine As ITextViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
)

Parameters

context
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.ImplementationTextViewDrawContext
The TextViewDrawContext to use for rendering.
viewLine
Type: ActiproSoftware.Windows.Controls.SyntaxEditorITextViewLine
The ITextViewLine for which the glyph is rendered.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: System.WindowsRect
The bounds in which the indicator will be rendered.

Implements

IIndicatorTagDrawGlyph(TextViewDrawContext, ITextViewLine, TagSnapshotRangeIIndicatorTag, Rect)
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.GetLocation Method

IndicatorTagBaseGetLocation Method

Overload List
 | Name | Description
Protected method | GetLocation(Rect) | Returns the location of the glyph, centered within the specified editor view margin bounds.
Protected method | GetLocation(Rect, HorizontalAlignment, VerticalAlignment) | Returns the location of the glyph within the specified editor view margin bounds based on alignments.
Top
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.GetLocation Method (Rect)

IndicatorTagBaseGetLocation Method (Rect)

Returns the location of the glyph, centered within the specified editor view margin bounds.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Point GetLocation(
    Rect bounds
)
Protected Function GetLocation (
    bounds As Rect
) As Point

Parameters

bounds
Type: System.WindowsRect
The view margin bounds in which to render.

Return Value

Type: Point
The location at which to render the glyph.
See Also

Reference

IndicatorTagBase Class
GetLocation Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.GetLocation Method (Rect, HorizontalAlignment, VerticalAlignment)

IndicatorTagBaseGetLocation Method (Rect, HorizontalAlignment, VerticalAlignment)

Returns the location of the glyph within the specified editor view margin bounds based on alignments.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Point GetLocation(
    Rect bounds,
    HorizontalAlignment horizontalAlignment,
    VerticalAlignment verticalAlignment
)
Protected Function GetLocation (
    bounds As Rect,
    horizontalAlignment As HorizontalAlignment,
    verticalAlignment As VerticalAlignment
) As Point

Parameters

bounds
Type: System.WindowsRect
The view margin bounds in which to render.
horizontalAlignment
Type: System.WindowsHorizontalAlignment
The horizontal alignment within the bounds.
verticalAlignment
Type: System.WindowsVerticalAlignment
The vertical alignment within the bounds.

Return Value

Type: Point
The location at which to render the glyph.
See Also

Reference

IndicatorTagBase Class
GetLocation Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Class

IndicatorTaggerBaseTTag Class

Represents the abstract base class for providing IIndicatorTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase TTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger TTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBaseTTag
ActiproSoftware.Text.Tagging.ImplementationBookmarkIndicatorTagger
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTaggerBaseTTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class IndicatorTaggerBase<TTag> : CollectionTagger<TTag>,
    IKeyedObject, IOrderable, ITagger<IIndicatorTag>
where TTag : class, IIndicatorTag

Public MustInherit Class IndicatorTaggerBase(Of TTag As {Class, IIndicatorTag})
    Inherits CollectionTagger(Of TTag)
    Implements IKeyedObject, IOrderable, ITagger(Of IIndicatorTag)

Type Parameters

TTag

[Missing <typeparam name="TTag"/> documentation for "T:ActiproSoftware.Text.Tagging.Implementation.IndicatorTaggerBase`1"]

The IndicatorTaggerBaseTTag type exposes the following members.

Constructors
 | Name | Description
Protected method | IndicatorTaggerBaseTTag | Initializes a new instance of the IndicatorTaggerBase class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Constructor

IndicatorTaggerBaseTTag Constructor

Initializes a new instance of the IndicatorTaggerBase class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IndicatorTaggerBase(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document,
    bool isForLanguage
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument,
    isForLanguage As Boolean
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
isForLanguage
Type: SystemBoolean
Indicates whether this tagger is for a language. If true, the tagger is closed when the document's language changes.
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Properties

IndicatorTaggerBaseTTag Properties

The IndicatorTaggerBaseTTag generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Methods

IndicatorTaggerBaseTTag Methods

The IndicatorTaggerBaseTTag generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag).RaiseTagsChanged Method

IndicatorTaggerBaseTTagRaiseTagsChanged Method

Raises the TagsChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RaiseTagsChanged(
    TagsChangedEventArgs e
)
Public Sub RaiseTagsChanged (
    e As TagsChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.TaggingTagsChangedEventArgs
A TagsChangedEventArgs that contains the event data.
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Events

IndicatorTaggerBaseTTag Events

The IndicatorTaggerBaseTTag generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Class

Provides an ITaggerT implementation that tags IParseError objects found in a document's parse data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ISquiggleTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger ISquiggleTag
ActiproSoftware.Text.Tagging.ImplementationParseErrorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ParseErrorTagger : CollectionTagger<ISquiggleTag>
Public Class ParseErrorTagger
    Inherits CollectionTagger(Of ISquiggleTag)

The ParseErrorTagger type exposes the following members.

Constructors
 | Name | Description
Public method | ParseErrorTagger | Initializes a new instance of the ParseErrorTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | MaximumParseErrorCount | Gets or sets the maximum number of parse errors that can be pulled from the parse data.
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Constructor

Initializes a new instance of the ParseErrorTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ParseErrorTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Properties

The ParseErrorTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | MaximumParseErrorCount | Gets or sets the maximum number of parse errors that can be pulled from the parse data.
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger.MaximumParseErrorCount Property

ParseErrorTaggerMaximumParseErrorCount Property

Gets or sets the maximum number of parse errors that can be pulled from the parse data.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int MaximumParseErrorCount { get; set; }
Public Property MaximumParseErrorCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of parse errors that can be pulled from the parse data. The default value is 5000.
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Methods

The ParseErrorTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger.OnClosed Method

ParseErrorTaggerOnClosed Method

Occurs when the tagger is closed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Events

The ParseErrorTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag Class

Represents an ITag that can be used to mark a text range as read-only, and can optionally associate an IClassificationType.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationClassificationTag
ActiproSoftware.Text.Tagging.ImplementationReadOnlyRegionTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReadOnlyRegionTag : ClassificationTag,
    ITag, IReadOnlyRegionTag
Public Class ReadOnlyRegionTag
    Inherits ClassificationTag
    Implements ITag, IReadOnlyRegionTag

The ReadOnlyRegionTag type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOnlyRegionTag | Initializes a new instance of the ReadOnlyRegionTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag. (Inherited from ClassificationTag.)
Public property | IncludeFirstEdge | Gets or sets whether to consider any text ranges that align to this tag's leading (first) edge as being in the read-only region.
Public property | IncludeLastEdge | Gets or sets whether to consider any text ranges that align to this tag's trailing (last) edge as being in the read-only region.
Public property | IsReadOnly | Gets or sets whether the tagged text range is currently read-only.
Top
Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Inherited from ClassificationTag.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag Constructor

Initializes a new instance of the ReadOnlyRegionTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyRegionTag()
Public Sub New
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag Properties

The ReadOnlyRegionTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag. (Inherited from ClassificationTag.)
Public property | IncludeFirstEdge | Gets or sets whether to consider any text ranges that align to this tag's leading (first) edge as being in the read-only region.
Public property | IncludeLastEdge | Gets or sets whether to consider any text ranges that align to this tag's trailing (last) edge as being in the read-only region.
Public property | IsReadOnly | Gets or sets whether the tagged text range is currently read-only.
Top
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag.IncludeFirstEdge Property

ReadOnlyRegionTagIncludeFirstEdge Property

Gets or sets whether to consider any text ranges that align to this tag's leading (first) edge as being in the read-only region.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IncludeFirstEdge { get; set; }
Public Property IncludeFirstEdge As Boolean
    Get
    Set

Property Value

Type: Boolean
true if any text ranges that align to this tag's leading (first) edge are considered as in the read-only region; otherwise, false.

Implements

IReadOnlyRegionTagIncludeFirstEdge
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag.IncludeLastEdge Property

ReadOnlyRegionTagIncludeLastEdge Property

Gets or sets whether to consider any text ranges that align to this tag's trailing (last) edge as being in the read-only region.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IncludeLastEdge { get; set; }
Public Property IncludeLastEdge As Boolean
    Get
    Set

Property Value

Type: Boolean
true if any text ranges that align to this tag's trailing (last) edge are considered as in the read-only region; otherwise, false.

Implements

IReadOnlyRegionTagIncludeLastEdge
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag.IsReadOnly Property

ReadOnlyRegionTagIsReadOnly Property

Gets or sets whether the tagged text range is currently read-only.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tagged text range is currently read-only; otherwise, false.

Implements

IReadOnlyRegionTagIsReadOnly
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag Methods

The ReadOnlyRegionTag type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Inherited from ClassificationTag.)
Top
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Class

Provides a view-based classification tagger that tags search results.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase IClassificationTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger IClassificationTag
ActiproSoftware.Text.Tagging.ImplementationSearchResultHighlightTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SearchResultHighlightTagger : CollectionTagger<IClassificationTag>
Public Class SearchResultHighlightTagger
    Inherits CollectionTagger(Of IClassificationTag)

The SearchResultHighlightTagger type exposes the following members.

Constructors
 | Name | Description
Public method | SearchResultHighlightTagger | Initializes a new instance of the SearchResultHighlightTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Constructor

Initializes a new instance of the SearchResultHighlightTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SearchResultHighlightTagger(
    IEditorView view
)
Public Sub New (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorIEditorView
The view to which this manager is attached.
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Properties

The SearchResultHighlightTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Methods

The SearchResultHighlightTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Protected method | OnClosed | Occurs when the tagger is closed. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Top
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger.OnClosed Method

SearchResultHighlightTaggerOnClosed Method

Occurs when the tagger is closed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Events

The SearchResultHighlightTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Class

Provides a basic ISquiggleTag implementation, generally used for error display, that can be associated with some text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationSquiggleTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SquiggleTag : ITag,
    ISquiggleTag
Public Class SquiggleTag
    Implements ITag, ISquiggleTag

The SquiggleTag type exposes the following members.

Constructors
 | Name | Description
Public method | SquiggleTag | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IClassificationType) | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IContentProvider) | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IClassificationType, IContentProvider) | Initializes a new instance of the SquiggleTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor

Overload List
 | Name | Description
Public method | SquiggleTag | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IClassificationType) | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IContentProvider) | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IClassificationType, IContentProvider) | Initializes a new instance of the SquiggleTag class.
Top
See Also

Reference

SquiggleTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor

Initializes a new instance of the SquiggleTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SquiggleTag()
Public Sub New
See Also

Reference

SquiggleTag Class
SquiggleTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor (IClassificationType)

Initializes a new instance of the SquiggleTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SquiggleTag(
    IClassificationType classificationType
)
Public Sub New (
    classificationType As IClassificationType
)

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
See Also

Reference

SquiggleTag Class
SquiggleTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor (IContentProvider)

Initializes a new instance of the SquiggleTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SquiggleTag(
    IContentProvider contentProvider
)
Public Sub New (
    contentProvider As IContentProvider
)

Parameters

contentProvider
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIContentProvider
The IContentProvider associated with the tag.
See Also

Reference

SquiggleTag Class
SquiggleTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor (IClassificationType, IContentProvider)

Initializes a new instance of the SquiggleTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SquiggleTag(
    IClassificationType classificationType,
    IContentProvider contentProvider
)
Public Sub New (
    classificationType As IClassificationType,
    contentProvider As IContentProvider
)

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
contentProvider
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.IntelliPromptIContentProvider
The IContentProvider associated with the tag.
See Also

Reference

SquiggleTag Class
SquiggleTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Properties

The SquiggleTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Top
See Also

Reference

SquiggleTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag.ClassificationType Property

SquiggleTagClassificationType Property

Gets or sets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

ISquiggleTagClassificationType
See Also

Reference

SquiggleTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag.ContentProvider Property

SquiggleTagContentProvider Property

Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IContentProvider ContentProvider { get; set; }
Public Property ContentProvider As IContentProvider
    Get
    Set

Property Value

Type: IContentProvider
The optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Implements

ISquiggleTagContentProvider
See Also

Reference

SquiggleTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Class

Provides a ClassificationTag implementation that uses an alternate IHighlightingStyleRegistry, and can be associated with some text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationClassificationTag
ActiproSoftware.Text.Tagging.ImplementationStyleRegistryClassificationTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StyleRegistryClassificationTag : ClassificationTag,
    IHighlightingStyleRegistryProvider
Public Class StyleRegistryClassificationTag
    Inherits ClassificationTag
    Implements IHighlightingStyleRegistryProvider

The StyleRegistryClassificationTag type exposes the following members.

Constructors
 | Name | Description
Public method | StyleRegistryClassificationTag | Initializes a new instance of the StyleRegistryClassificationTag class.
Public method | StyleRegistryClassificationTag(IClassificationType, IHighlightingStyleRegistry) | Initializes a new instance of the StyleRegistryClassificationTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag. (Inherited from ClassificationTag.)
Public property | HighlightingStyleRegistry | Gets or sets the custom IHighlightingStyleRegistry associated with this object.
Top
Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Inherited from ClassificationTag.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Constructor

Overload List
 | Name | Description
Public method | StyleRegistryClassificationTag | Initializes a new instance of the StyleRegistryClassificationTag class.
Public method | StyleRegistryClassificationTag(IClassificationType, IHighlightingStyleRegistry) | Initializes a new instance of the StyleRegistryClassificationTag class.
Top
See Also

Reference

StyleRegistryClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Constructor

Initializes a new instance of the StyleRegistryClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StyleRegistryClassificationTag()
Public Sub New
See Also

Reference

StyleRegistryClassificationTag Class
StyleRegistryClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Constructor (IClassificationType, IHighlightingStyleRegistry)

Initializes a new instance of the StyleRegistryClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StyleRegistryClassificationTag(
    IClassificationType classificationType,
    IHighlightingStyleRegistry highlightingStyleRegistry
)
Public Sub New (
    classificationType As IClassificationType,
    highlightingStyleRegistry As IHighlightingStyleRegistry
)

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
highlightingStyleRegistry
Type: ActiproSoftware.Windows.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The custom IHighlightingStyleRegistry associated with this object.
See Also

Reference

StyleRegistryClassificationTag Class
StyleRegistryClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Properties

The StyleRegistryClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag. (Inherited from ClassificationTag.)
Public property | HighlightingStyleRegistry | Gets or sets the custom IHighlightingStyleRegistry associated with this object.
Top
See Also

Reference

StyleRegistryClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag.HighlightingStyleRegistry Property

StyleRegistryClassificationTagHighlightingStyleRegistry Property

Gets or sets the custom IHighlightingStyleRegistry associated with this object.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry HighlightingStyleRegistry { get; set; }
Public Property HighlightingStyleRegistry As IHighlightingStyleRegistry
    Get
    Set

Property Value

Type: IHighlightingStyleRegistry
The custom IHighlightingStyleRegistry associated with this object.

Implements

IHighlightingStyleRegistryProviderHighlightingStyleRegistry
See Also

Reference

StyleRegistryClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Methods

The StyleRegistryClassificationTag type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Inherited from ClassificationTag.)
Top
See Also

Reference

StyleRegistryClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Class

TaggerBaseT Class

Provides an abstract base class for an ITaggerT implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBaseT
ActiproSoftware.Text.Tagging.ImplementationCollectionTaggerT
ActiproSoftware.Text.Tagging.ImplementationTokenTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TaggerBase<T> : IKeyedObject,
    ITagger<T>, IOrderable
where T : ITag

Public MustInherit Class TaggerBase(Of T As ITag)
    Implements IKeyedObject, ITagger(Of T), IOrderable

Type Parameters

T
The type of tag associated with this tagger.

The TaggerBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | TaggerBaseT(String, IEnumerableOrdering, ICodeDocument) | Initializes a new instance of the TaggerBase class.
Protected method | TaggerBaseT(String, IEnumerableOrdering, ICodeDocument, Boolean) | Initializes a new instance of the TaggerBase class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached.
Public property | Key | Gets the string-based key that identifies the object.
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger.
Public method | Close | Closes the tagger and detaches it from the document.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Protected method | OnClosed | Occurs when the tagger is closed.
Protected method | OnTagsChanged | Raises the TagsChanged event.
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed.
Public event | TagsChanged | Occurs after a range of tags have changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Constructor

TaggerBaseT Constructor

Overload List
 | Name | Description
Protected method | TaggerBaseT(String, IEnumerableOrdering, ICodeDocument) | Initializes a new instance of the TaggerBase class.
Protected method | TaggerBaseT(String, IEnumerableOrdering, ICodeDocument, Boolean) | Initializes a new instance of the TaggerBase class.
Top
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Constructor (String, IEnumerable(Ordering), ICodeDocument)

TaggerBaseT Constructor (String, IEnumerableOrdering, ICodeDocument)

Initializes a new instance of the TaggerBase class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TaggerBase(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

TaggerBaseT Class
TaggerBaseT Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Constructor (String, IEnumerable(Ordering), ICodeDocument, Boolean)

TaggerBaseT Constructor (String, IEnumerableOrdering, ICodeDocument, Boolean)

Initializes a new instance of the TaggerBase class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TaggerBase(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document,
    bool isForLanguage
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument,
    isForLanguage As Boolean
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
isForLanguage
Type: SystemBoolean
Indicates whether this tagger is for a language. If true, the tagger is closed when the document's language changes.
See Also

Reference

TaggerBaseT Class
TaggerBaseT Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Properties

TaggerBaseT Properties

The TaggerBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached.
Public property | Key | Gets the string-based key that identifies the object.
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Document Property

TaggerBaseTDocument Property

Gets the document to which this tagger is attached.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICodeDocument Document { get; }
Public ReadOnly Property Document As ICodeDocument
    Get

Property Value

Type: ICodeDocument
The document to which this tagger is attached.
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Key Property

TaggerBaseTKey Property

Gets the string-based key that identifies the object.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The string-based key that identifies the object.

Implements

IKeyedObjectKey
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Orderings Property

TaggerBaseTOrderings Property

Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<Ordering> Orderings { get; }
Public ReadOnly Property Orderings As IEnumerable(Of Ordering)
    Get

Property Value

Type: IEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.

Implements

IOrderableOrderings
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Methods

TaggerBaseT Methods

The TaggerBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger.
Public method | Close | Closes the tagger and detaches it from the document.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Protected method | OnClosed | Occurs when the tagger is closed.
Protected method | OnTagsChanged | Raises the TagsChanged event.
Top
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).ChangeDocument Method

TaggerBaseTChangeDocument Method

Changes the document associated with the tagger.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void ChangeDocument(
    ICodeDocument newDocument
)
Protected Sub ChangeDocument (
    newDocument As ICodeDocument
)

Parameters

newDocument
Type: ActiproSoftware.TextICodeDocument
The new ICodeDocument.
Remarks
This method is used when a view-based tagger needs to update the associated document.
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Close Method

TaggerBaseTClose Method

Closes the tagger and detaches it from the document.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

ITaggerTClose
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).GetTags Method

TaggerBaseTGetTags Method

Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Public MustOverride Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.

Implements

ITaggerTGetTags(NormalizedTextSnapshotRangeCollection, Object)
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).OnClosed Method

TaggerBaseTOnClosed Method

Occurs when the tagger is closed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnClosed()
Protected Overridable Sub OnClosed
Remarks
The default implementation of this method does nothing. Overrides should release any event handlers set up in the tagger's constructor.
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).OnTagsChanged Method

TaggerBaseTOnTagsChanged Method

Raises the TagsChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnTagsChanged(
    TagsChangedEventArgs e
)
Protected Overridable Sub OnTagsChanged (
    e As TagsChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.TaggingTagsChangedEventArgs
A TagsChangedEventArgs that contains the event data.
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Events

TaggerBaseT Events

The TaggerBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed.
Public event | TagsChanged | Occurs after a range of tags have changed.
Top
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Closed Event

TaggerBaseTClosed Event

Occurs when the tagger is closed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler Closed
Public Event Closed As EventHandler

Value

Type: SystemEventHandler

Implements

ITaggerTClosed
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).TagsChanged Event

TaggerBaseTTagsChanged Event

Occurs after a range of tags have changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TagsChangedEventArgs> TagsChanged
Public Event TagsChanged As EventHandler(Of TagsChangedEventArgs)

Value

Type: SystemEventHandler TagsChangedEventArgs

Implements

ITaggerTTagsChanged
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerProviderBase(TTagger) Class

TaggerProviderBaseTTagger Class

Provides an abstract tagger provider base class that automatically returns the TagTypes supported based on reflection of the TTagger type.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBaseTTagger
More...

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TaggerProviderBase<TTagger>
where TTagger : class

Public MustInherit Class TaggerProviderBase(Of TTagger As Class)

Type Parameters

TTagger
The Type of ITaggerT that this factory creates.

The TaggerProviderBaseTTagger type exposes the following members.

Constructors
 | Name | Description
Protected method | TaggerProviderBaseTTagger | Initializes a new instance of the TaggerProviderBaseTTagger class
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBaseTTagger
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTaggerProvider
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTaggerProvider
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTaggerProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenTaggerProvider
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTaggerProvider
ActiproSoftware.Text.Tagging.ImplementationCodeDocumentTaggerProviderTTagger
ActiproSoftware.Text.Tagging.ImplementationTextViewTaggerProviderTTagger


TaggerProviderBase(TTagger) Constructor

TaggerProviderBaseTTagger Constructor

Initializes a new instance of the TaggerProviderBaseTTagger class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TaggerProviderBase()
Protected Sub New
See Also

Reference

TaggerProviderBaseTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerProviderBase(TTagger) Properties

TaggerProviderBaseTTagger Properties

The TaggerProviderBaseTTagger generic type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
See Also

Reference

TaggerProviderBaseTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerProviderBase(TTagger).TagTypes Property

TaggerProviderBaseTTaggerTagTypes Property

Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<Type> TagTypes { get; }
Public ReadOnly Property TagTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The ITag Type objects that are supported by the ITaggerT objects created by this provider.
See Also

Reference

TaggerProviderBaseTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T) Class

TagSearchOptionsT Class

Stores tag search operation options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTagSearchOptionsT

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TagSearchOptions<T> : ITagSearchOptions<T>
where T : ITag

Public Class TagSearchOptions(Of T As ITag)
    Implements ITagSearchOptions(Of T)

Type Parameters

T
The tag type.

The TagSearchOptionsT type exposes the following members.

Constructors
 | Name | Description
Public method | TagSearchOptionsT | Initializes a new instance of the TagSearchOptionsT class
Top
Properties
 | Name | Description
Public property | CanWrap | Gets or sets whether the search can wrap at the end of the search text range.
Public property | Filter | Gets or sets the optional callback used to determine if a potential search result is valid.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T) Constructor

TagSearchOptionsT Constructor

Initializes a new instance of the TagSearchOptionsT class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TagSearchOptions()
Public Sub New
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T) Properties

TagSearchOptionsT Properties

The TagSearchOptionsT generic type exposes the following members.

Properties
 | Name | Description
Public property | CanWrap | Gets or sets whether the search can wrap at the end of the search text range.
Public property | Filter | Gets or sets the optional callback used to determine if a potential search result is valid.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T).CanWrap Property

TagSearchOptionsTCanWrap Property

Gets or sets whether the search can wrap at the end of the search text range.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanWrap { get; set; }
Public Property CanWrap As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the search can wrap at the end of the search text range; otherwise, false.

Implements

ITagSearchOptionsTCanWrap
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T).Filter Property

TagSearchOptionsTFilter Property

Gets or sets the optional callback used to determine if a potential search result is valid.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Predicate<TagVersionRange<T>> Filter { get; set; }
Public Property Filter As Predicate(Of TagVersionRange(Of T))
    Get
    Set

Property Value

Type: Predicate TagVersionRange T
The optional callback used to determine if a potential search result is valid.

Implements

ITagSearchOptionsTFilter
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T).SearchUp Property

TagSearchOptionsTSearchUp Property

Gets or sets whether to search backwards.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool SearchUp { get; set; }
Public Property SearchUp As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be performed backwards; otherwise, false.

Implements

ITagSearchOptionsTSearchUp
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Class

TextViewTaggerProviderTTagger Class

Provides an ITextViewTaggerProvider capable of creating ITaggerT objects which have a constructor that accepts a single ITextView instance parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase TTagger
ActiproSoftware.Text.Tagging.ImplementationTextViewTaggerProviderTTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TextViewTaggerProvider<TTagger> : TaggerProviderBase<TTagger>,
    ITextViewTaggerProvider
where TTagger : class

Public Class TextViewTaggerProvider(Of TTagger As Class)
    Inherits TaggerProviderBase(Of TTagger)
    Implements ITextViewTaggerProvider

Type Parameters

TTagger
The Type of ITaggerT that this provider creates. The tagger type must have a constructor that accepts a single ITextView instance parameter.

The TextViewTaggerProviderTTagger type exposes the following members.

Constructors
 | Name | Description
Public method | TextViewTaggerProviderTTagger | Initializes a new instance of the TextViewTaggerProvider class.
Public method | TextViewTaggerProviderTTagger(Object) | Initializes a new instance of the TextViewTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ITextView.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Constructor

TextViewTaggerProviderTTagger Constructor

Overload List
 | Name | Description
Public method | TextViewTaggerProviderTTagger | Initializes a new instance of the TextViewTaggerProvider class.
Public method | TextViewTaggerProviderTTagger(Object) | Initializes a new instance of the TextViewTaggerProvider class.
Top
See Also

Reference

TextViewTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Constructor

TextViewTaggerProviderTTagger Constructor

Initializes a new instance of the TextViewTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextViewTaggerProvider()
Public Sub New
See Also

Reference

TextViewTaggerProviderTTagger Class
TextViewTaggerProviderTTagger Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Constructor (Object)

TextViewTaggerProviderTTagger Constructor (Object)

Initializes a new instance of the TextViewTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextViewTaggerProvider(
    Object singletonKey
)
Public Sub New (
    singletonKey As Object
)

Parameters

singletonKey
Type: SystemObject
When a non-null value is passed, the tagger will be stored as a singleton under the specified key in the views's properties.
See Also

Reference

TextViewTaggerProviderTTagger Class
TextViewTaggerProviderTTagger Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Properties

TextViewTaggerProviderTTagger Properties

The TextViewTaggerProviderTTagger generic type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

TextViewTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Methods

TextViewTaggerProviderTTagger Methods

The TextViewTaggerProviderTTagger generic type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ITextView.
Top
See Also

Reference

TextViewTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger).GetTagger(T) Method

TextViewTaggerProviderTTaggerGetTaggerT Method

Returns an ITaggerT for the specified ITextView.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ITextView view
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    view As ITextView
) As ITagger(Of T)

Parameters

view
Type: ActiproSoftware.Windows.Controls.SyntaxEditorITextView
The ITextView that requires an ITaggerT.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
An ITaggerT for the specified ITextView.

Implements

ITextViewTaggerProviderGetTaggerT(ITextView)
See Also

Reference

TextViewTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Class

Represents an ITag that can be used to associate an IClassificationType and an IToken with some text range by implementing IClassificationTag and ITokenTag.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTokenClassificationTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TokenClassificationTag : IClassificationTag,
    ITag, ITokenTag
Public Class TokenClassificationTag
    Implements IClassificationTag, ITag, ITokenTag

The TokenClassificationTag type exposes the following members.

Constructors
 | Name | Description
Public method | TokenClassificationTag | Initializes a new instance of the TokenClassificationTag class.
Public method | TokenClassificationTag(IToken, IClassificationType) | Initializes a new instance of the TokenClassificationTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Public property | Token | Gets or sets the lexer IToken associated with this tag.
Top
Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Constructor

Overload List
 | Name | Description
Public method | TokenClassificationTag | Initializes a new instance of the TokenClassificationTag class.
Public method | TokenClassificationTag(IToken, IClassificationType) | Initializes a new instance of the TokenClassificationTag class.
Top
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Constructor

Initializes a new instance of the TokenClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TokenClassificationTag()
Public Sub New
See Also

Reference

TokenClassificationTag Class
TokenClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Constructor (IToken, IClassificationType)

Initializes a new instance of the TokenClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TokenClassificationTag(
    IToken token,
    IClassificationType classificationType
)
Public Sub New (
    token As IToken,
    classificationType As IClassificationType
)

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The lexer IToken associated with this tag.
classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
See Also

Reference

TokenClassificationTag Class
TokenClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Properties

The TokenClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Public property | Token | Gets or sets the lexer IToken associated with this tag.
Top
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag.ClassificationType Property

TokenClassificationTagClassificationType Property

Gets or sets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag.Token Property

TokenClassificationTagToken Property

Gets or sets the lexer IToken associated with this tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IToken Token { get; set; }
Public Property Token As IToken
    Get
    Set

Property Value

Type: IToken
The lexer IToken associated with this tag.

Implements

ITokenTagToken
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Methods

The TokenClassificationTag type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag.ToString Method

TokenClassificationTagToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Class

An ITaggerT implementation that provides ITokenTag and IClassificationTag objects based on a language's ILexer.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTagger
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTagger
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTagger
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenTagger
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TokenTagger : TaggerBase<ITokenTag>,
    IKeyedObject, ITagger<IClassificationTag>, IOrderable
Public Class TokenTagger
    Inherits TaggerBase(Of ITokenTag)
    Implements IKeyedObject, ITagger(Of IClassificationTag),
    IOrderable

The TokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | TokenTagger | Initializes a new instance of the TokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate.
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Overrides TaggerBaseTGetTags(NormalizedTextSnapshotRangeCollection, Object).)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange.
Protected method | OnClosed | Occurs when the tagger is closed. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event.
Top
Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Constructor

Initializes a new instance of the TokenTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TokenTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Properties

The TokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this tagger is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Methods

The TokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate.
Public method | Close | Closes the tagger and detaches it from the document. (Inherited from TaggerBaseT.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Overrides TaggerBaseTGetTags(NormalizedTextSnapshotRangeCollection, Object).)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange.
Protected method | OnClosed | Occurs when the tagger is closed. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event.
Top
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.ClassifyToken Method

TokenTaggerClassifyToken Method

Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IClassificationType ClassifyToken(
    IToken token
)
Public Overridable Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.GetTags Method

TokenTaggerGetTags Method

Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<TagSnapshotRange<ITokenTag>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Public Overrides Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of ITokenTag))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange ITokenTag
The tag ranges that intersect with the specified normalized snapshot ranges.

Implements

ITaggerTGetTags(NormalizedTextSnapshotRangeCollection, Object)
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.GetTokens Method

TokenTaggerGetTokens Method

Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ITokenSet GetTokens(
    ILexer lexer,
    TextSnapshotRange desiredSnapshotRange,
    Object parseContext,
    bool canUpdateLineContexts,
    out int invalidateThroughOffset
)
Protected Function GetTokens (
    lexer As ILexer,
    desiredSnapshotRange As TextSnapshotRange,
    parseContext As Object,
    canUpdateLineContexts As Boolean,
    <OutAttribute> ByRef invalidateThroughOffset As Integer
) As ITokenSet

Parameters

lexer
Type: ActiproSoftware.Text.LexingILexer
The ILexer to use for token generation.
desiredSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange that should be examined.
parseContext
Type: SystemObject
An optional object that may be used to help provide context information when resuming incremental parsing.
canUpdateLineContexts
Type: SystemBoolean
Whether line contexts can be updated.
invalidateThroughOffset
Type: SystemInt32
Returns the offset through which tokens were invalidated.

Return Value

Type: ITokenSet
The ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange.
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.OnClosed Method

TokenTaggerOnClosed Method

Occurs when the tagger is closed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.RaiseTagsChanged Method

TokenTaggerRaiseTagsChanged Method

Raises the TagsChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RaiseTagsChanged(
    TagsChangedEventArgs e
)
Public Sub RaiseTagsChanged (
    e As TagsChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.TaggingTagsChangedEventArgs
A TagsChangedEventArgs that contains the event data.
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Events

The TokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTaggerProvider(TTagger) Class

TokenTaggerProviderTTagger Class

Provides an ICodeDocumentTaggerProvider capable of creating TokenTagger objects which have a constructor that accepts a single ICodeDocument instance parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase TTagger
ActiproSoftware.Text.Tagging.ImplementationCodeDocumentTaggerProvider TTagger
ActiproSoftware.Text.Tagging.ImplementationTokenTaggerProviderTTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TokenTaggerProvider<TTagger> : CodeDocumentTaggerProvider<TTagger>
where TTagger : class, Object, ITagger<ITokenTag>

Public Class TokenTaggerProvider(Of TTagger As {Class, Object, ITagger(Of ITokenTag)})
    Inherits CodeDocumentTaggerProvider(Of TTagger)

Type Parameters

TTagger
The Type of ITaggerT that this factory creates. The tagger type must have a constructor that accepts a single ICodeDocument instance parameter.

The TokenTaggerProviderTTagger type exposes the following members.

Constructors
 | Name | Description
Public method | TokenTaggerProviderTTagger | Initializes a new instance of the TokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument. (Inherited from CodeDocumentTaggerProviderTTagger.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTaggerProvider(TTagger) Constructor

TokenTaggerProviderTTagger Constructor

Initializes a new instance of the TokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TokenTaggerProvider()
Public Sub New
See Also

Reference

TokenTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTaggerProvider(TTagger) Properties

TokenTaggerProviderTTagger Properties

The TokenTaggerProviderTTagger generic type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

TokenTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTaggerProvider(TTagger) Methods

TokenTaggerProviderTTagger Methods

The TokenTaggerProviderTTagger generic type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument. (Inherited from CodeDocumentTaggerProviderTTagger.)
Top
See Also

Reference

TokenTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ActiproSoftware.Text.Undo Namespace

Contains types related to managing the undo/redo stacks of text documents.
Classes
 | Class | Description
Public class | ObservableUndoableTextChangeStack | Provides wrapper for an IUndoableTextChangeStack that implements INotifyCollectionChanged, allowing it to be used as an items source in UI controls.
Public class | UndoRedoRequestEventArgs | Event arguments for when an undo or redo operation is requesting to be applied to an ITextDocument.
Interfaces
 | Interface | Description
Public interface | IUndoableTextChange | Provides the base requirements for a single undoable text change unit.
Public interface | IUndoableTextChangeStack | Provides the base requirements for a simple last-in-first-out collection of IUndoableTextChange objects.
Public interface | IUndoHistory | Provides the base requirements for an object that tracks undo and redo history for a document and allows re-application of those text changes.
Enumerations
 | Enumeration | Description
Public enumeration | SavePointChangeType | Specifies the type of changes that have been made to a character range since the last save point.


IUndoableTextChange Interface

Provides the base requirements for a single undoable text change unit.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IUndoableTextChange
Public Interface IUndoableTextChange

The IUndoableTextChange type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | Gets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | Description | Gets the description of the contents of the text change, usually displayed in the user interface.
Public property | IsMerged | Gets whether this text change is the result of a merge of two or more text changes.
Public property | Operations | Gets the read-only list of ITextChangeOperation objects that make up this text change.
Public property | PostSelectionPositionRanges | Gets or sets the collection of sorted non-overlapping TextPositionRange objects that should be selected in the source view after the text change is applied.
Public property | PreSelectionPositionRanges | Gets or sets the collection of sorted non-overlapping TextPositionRange objects that were selected in the source view before the text change is applied.
Public property | RetainSelection | Gets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Type | Gets an ITextChangeType indicating the type of change that was made.
Top
Remarks
This interface only stores the necessary information to reconstruct an ITextChange for undo/redo purposes.
See Also

Reference

ActiproSoftware.Text.Undo Namespace


IUndoableTextChange Properties

The IUndoableTextChange type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | Gets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | Description | Gets the description of the contents of the text change, usually displayed in the user interface.
Public property | IsMerged | Gets whether this text change is the result of a merge of two or more text changes.
Public property | Operations | Gets the read-only list of ITextChangeOperation objects that make up this text change.
Public property | PostSelectionPositionRanges | Gets or sets the collection of sorted non-overlapping TextPositionRange objects that should be selected in the source view after the text change is applied.
Public property | PreSelectionPositionRanges | Gets or sets the collection of sorted non-overlapping TextPositionRange objects that were selected in the source view before the text change is applied.
Public property | RetainSelection | Gets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Type | Gets an ITextChangeType indicating the type of change that was made.
Top
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.CustomData Property

IUndoableTextChangeCustomData Property

Gets custom data that can be persisted with the text change and restored when undo operations occur later on.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object CustomData { get; }
ReadOnly Property CustomData As Object
    Get

Property Value

Type: Object
The custom data.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.Description Property

IUndoableTextChangeDescription Property

Gets the description of the contents of the text change, usually displayed in the user interface.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the contents of the text change, usually displayed in the user interface.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.IsMerged Property

IUndoableTextChangeIsMerged Property

Gets whether this text change is the result of a merge of two or more text changes.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsMerged { get; }
ReadOnly Property IsMerged As Boolean
    Get

Property Value

Type: Boolean
true if this text change is the result of a merge of two or more text changes; otherwise, false.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.Operations Property

IUndoableTextChangeOperations Property

Gets the read-only list of ITextChangeOperation objects that make up this text change.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<ITextChangeOperation> Operations { get; }
ReadOnly Property Operations As IList(Of ITextChangeOperation)
    Get

Property Value

Type: IList ITextChangeOperation
The read-only list of ITextChangeOperation objects that make up this text change.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.PostSelectionPositionRanges Property

IUndoableTextChangePostSelectionPositionRanges Property

Gets or sets the collection of sorted non-overlapping TextPositionRange objects that should be selected in the source view after the text change is applied.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextPositionRangeCollection PostSelectionPositionRanges { get; set; }
Property PostSelectionPositionRanges As ITextPositionRangeCollection
    Get
    Set

Property Value

Type: ITextPositionRangeCollection
The collection of sorted non-overlapping TextPositionRange objects that should be selected in the source view after the text change is applied.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.PreSelectionPositionRanges Property

IUndoableTextChangePreSelectionPositionRanges Property

Gets or sets the collection of sorted non-overlapping TextPositionRange objects that were selected in the source view before the text change is applied.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextPositionRangeCollection PreSelectionPositionRanges { get; set; }
Property PreSelectionPositionRanges As ITextPositionRangeCollection
    Get
    Set

Property Value

Type: ITextPositionRangeCollection
The collection of sorted non-overlapping TextPositionRange objects that were selected in the source view before the text change is applied.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.RetainSelection Property

IUndoableTextChangeRetainSelection Property

Gets whether to prevent the caret from moving to the end of the text change in the active view.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool RetainSelection { get; }
ReadOnly Property RetainSelection As Boolean
    Get

Property Value

Type: Boolean
true if the caret move should be prevented; otherwise, false.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.Type Property

IUndoableTextChangeType Property

Gets an ITextChangeType indicating the type of change that was made.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ITextChangeType Type { get; }
ReadOnly Property Type As ITextChangeType
    Get

Property Value

Type: ITextChangeType
An ITextChangeType indicating the type of change that was made.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack Interface

Provides the base requirements for a simple last-in-first-out collection of IUndoableTextChange objects.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IUndoableTextChangeStack : IEnumerable,
    IEnumerable<IUndoableTextChange>
Public Interface IUndoableTextChangeStack
    Inherits IEnumerable, IEnumerable(Of IUndoableTextChange)

The IUndoableTextChangeStack type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the stack.
Public property | Count | Gets the count of text changes on the stack.
Public property | IsAtSavePoint | Gets whether the last text change on the stack is a save point.
Top
Methods
 | Name | Description
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetTextChange | Gets the IUndoableTextChange that the specified location in the stack.
Public method | IndexOf | Returns the index of the IUndoableTextChange in the list.
Top
Events
 | Name | Description
Public event | CapacityChanged | Occurs when the capacity of the stack is changed.
Public event | StackChanged | Occurs when the contents of the stack are changed.
Top
See Also

Reference

ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack Properties

The IUndoableTextChangeStack type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the stack.
Public property | Count | Gets the count of text changes on the stack.
Public property | IsAtSavePoint | Gets whether the last text change on the stack is a save point.
Top
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.Capacity Property

IUndoableTextChangeStackCapacity Property

Gets or sets the capacity of the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Capacity { get; set; }
Property Capacity As Integer
    Get
    Set

Property Value

Type: Int32
The capacity of the stack.
Remarks
If a new text change added to the stack causes the stack to exceed its capacity, the text changes at the bottom of the stack are removed until the stack no longer exceeds its capacity.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.Count Property

IUndoableTextChangeStackCount Property

Gets the count of text changes on the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of text changes on the stack.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.IsAtSavePoint Property

IUndoableTextChangeStackIsAtSavePoint Property

Gets whether the last text change on the stack is a save point.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsAtSavePoint { get; }
ReadOnly Property IsAtSavePoint As Boolean
    Get

Property Value

Type: Boolean
true if the last text change on the stack is a save point; otherwise, false.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack Methods

The IUndoableTextChangeStack type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetTextChange | Gets the IUndoableTextChange that the specified location in the stack.
Public method | IndexOf | Returns the index of the IUndoableTextChange in the list.
Top
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.CopyTo Method

IUndoableTextChangeStackCopyTo Method

Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void CopyTo(
    IUndoableTextChange[] array,
    int arrayIndex
)
Sub CopyTo (
    array As IUndoableTextChange(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The one-dimensional IUndoableTextChange array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.GetTextChange Method

IUndoableTextChangeStackGetTextChange Method

Gets the IUndoableTextChange that the specified location in the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IUndoableTextChange GetTextChange(
    int index
)
Function GetTextChange (
    index As Integer
) As IUndoableTextChange

Parameters

index
Type: SystemInt32
The index of the text change to check.

Return Value

Type: IUndoableTextChange
The IUndoableTextChange that the specified location in the stack.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.IndexOf Method

IUndoableTextChangeStackIndexOf Method

Returns the index of the IUndoableTextChange in the list.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int IndexOf(
    IUndoableTextChange textChange
)
Function IndexOf (
    textChange As IUndoableTextChange
) As Integer

Parameters

textChange
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The IUndoableTextChange to look for in the list.

Return Value

Type: Int32
The index of the IUndoableTextChange in the list, or -1 if not found.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack Events

The IUndoableTextChangeStack type exposes the following members.

Events
 | Name | Description
Public event | CapacityChanged | Occurs when the capacity of the stack is changed.
Public event | StackChanged | Occurs when the contents of the stack are changed.
Top
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.CapacityChanged Event

IUndoableTextChangeStackCapacityChanged Event

Occurs when the capacity of the stack is changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler CapacityChanged
Event CapacityChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.StackChanged Event

IUndoableTextChangeStackStackChanged Event

Occurs when the contents of the stack are changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler StackChanged
Event StackChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory Interface

Provides the base requirements for an object that tracks undo and redo history for a document and allows re-application of those text changes.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IUndoHistory
Public Interface IUndoHistory

The IUndoHistory type exposes the following members.

Properties
 | Name | Description
Public property | CanRedo | Gets whether at least one redo text change is available to execute.
Public property | CanUndo | Gets whether at least one undo text change is available to execute.
Public property | RedoStack | Gets the IUndoableTextChangeStack containing the redo stack.
Public property | UndoStack | Gets the IUndoableTextChangeStack containing the undo stack.
Top
Methods
 | Name | Description
Public method | Clear | Clears the undo and redo stacks, without resetting change tracking.
Public method | Clear(Boolean) | Clears the undo and redo stacks.
Public method | GetChangeTypeForLineRange | Gets the SavePointChangeType for the specified line range.
Public method | Redo | Performs the top redo text change.
Public method | Redo(Int32) | Performs the specified number of redo text changes.
Public method | Undo | Performs the top undo text change.
Public method | Undo(Int32) | Performs the specified number of undo text changes.
Top
Events
 | Name | Description
Public event | Cleared | Occurs when the undo history is programmatically cleared.
Public event | UndoRedoRequested | Occurs when an undo or redo operation is requested.
Top
See Also

Reference

ActiproSoftware.Text.Undo Namespace


IUndoHistory Properties

The IUndoHistory type exposes the following members.

Properties
 | Name | Description
Public property | CanRedo | Gets whether at least one redo text change is available to execute.
Public property | CanUndo | Gets whether at least one undo text change is available to execute.
Public property | RedoStack | Gets the IUndoableTextChangeStack containing the redo stack.
Public property | UndoStack | Gets the IUndoableTextChangeStack containing the undo stack.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.CanRedo Property

IUndoHistoryCanRedo Property

Gets whether at least one redo text change is available to execute.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanRedo { get; }
ReadOnly Property CanRedo As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one redo text change is available to execute; otherwise, false.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.CanUndo Property

IUndoHistoryCanUndo Property

Gets whether at least one undo text change is available to execute.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanUndo { get; }
ReadOnly Property CanUndo As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one undo text change is available to execute; otherwise, false.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.RedoStack Property

IUndoHistoryRedoStack Property

Gets the IUndoableTextChangeStack containing the redo stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IUndoableTextChangeStack RedoStack { get; }
ReadOnly Property RedoStack As IUndoableTextChangeStack
    Get

Property Value

Type: IUndoableTextChangeStack
The IUndoableTextChangeStack containing the redo stack.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.UndoStack Property

IUndoHistoryUndoStack Property

Gets the IUndoableTextChangeStack containing the undo stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IUndoableTextChangeStack UndoStack { get; }
ReadOnly Property UndoStack As IUndoableTextChangeStack
    Get

Property Value

Type: IUndoableTextChangeStack
The IUndoableTextChangeStack containing the undo stack.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory Methods

The IUndoHistory type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the undo and redo stacks, without resetting change tracking.
Public method | Clear(Boolean) | Clears the undo and redo stacks.
Public method | GetChangeTypeForLineRange | Gets the SavePointChangeType for the specified line range.
Public method | Redo | Performs the top redo text change.
Public method | Redo(Int32) | Performs the specified number of redo text changes.
Public method | Undo | Performs the top undo text change.
Public method | Undo(Int32) | Performs the specified number of undo text changes.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Clear Method

IUndoHistoryClear Method

Overload List
 | Name | Description
Public method | Clear | Clears the undo and redo stacks, without resetting change tracking.
Public method | Clear(Boolean) | Clears the undo and redo stacks.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Clear Method

IUndoHistoryClear Method

Clears the undo and redo stacks, without resetting change tracking.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Clear()
Sub Clear
See Also

Reference

IUndoHistory Interface
Clear Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Clear Method (Boolean)

IUndoHistoryClear Method (Boolean)

Clears the undo and redo stacks.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Clear(
    bool resetChangeTracking
)
Sub Clear (
    resetChangeTracking As Boolean
)

Parameters

resetChangeTracking
Type: SystemBoolean
Whether to also reset all change tracking.
See Also

Reference

IUndoHistory Interface
Clear Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.GetChangeTypeForLineRange Method

IUndoHistoryGetChangeTypeForLineRange Method

Gets the SavePointChangeType for the specified line range.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
SavePointChangeType GetChangeTypeForLineRange(
    int startLineIndex,
    int endLineIndex
)
Function GetChangeTypeForLineRange (
    startLineIndex As Integer,
    endLineIndex As Integer
) As SavePointChangeType

Parameters

startLineIndex
Type: SystemInt32
The start index of the line range to examine.
endLineIndex
Type: SystemInt32
The end index of the line range to examine.

Return Value

Type: SavePointChangeType
The SavePointChangeType for the specified line range.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Redo Method

IUndoHistoryRedo Method

Overload List
 | Name | Description
Public method | Redo | Performs the top redo text change.
Public method | Redo(Int32) | Performs the specified number of redo text changes.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Redo Method

IUndoHistoryRedo Method

Performs the top redo text change.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Redo()
Function Redo As Boolean

Return Value

Type: Boolean
true if redo text change occurred successfully; otherwise, false.
See Also

Reference

IUndoHistory Interface
Redo Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Redo Method (Int32)

IUndoHistoryRedo Method (Int32)

Performs the specified number of redo text changes.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Redo(
    int count
)
Function Redo (
    count As Integer
) As Integer

Parameters

count
Type: SystemInt32
The number of redo text changes to perform.

Return Value

Type: Int32
The number of redo text changes that were performed.
See Also

Reference

IUndoHistory Interface
Redo Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Undo Method

IUndoHistoryUndo Method

Overload List
 | Name | Description
Public method | Undo | Performs the top undo text change.
Public method | Undo(Int32) | Performs the specified number of undo text changes.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Undo Method

IUndoHistoryUndo Method

Performs the top undo text change.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Undo()
Function Undo As Boolean

Return Value

Type: Boolean
true if undo text change occurred successfully; otherwise, false.
See Also

Reference

IUndoHistory Interface
Undo Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Undo Method (Int32)

IUndoHistoryUndo Method (Int32)

Performs the specified number of undo text changes.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Undo(
    int count
)
Function Undo (
    count As Integer
) As Integer

Parameters

count
Type: SystemInt32
The number of undo text changes to perform.

Return Value

Type: Int32
The number of undo text changes that were performed.
See Also

Reference

IUndoHistory Interface
Undo Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory Events

The IUndoHistory type exposes the following members.

Events
 | Name | Description
Public event | Cleared | Occurs when the undo history is programmatically cleared.
Public event | UndoRedoRequested | Occurs when an undo or redo operation is requested.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Cleared Event

IUndoHistoryCleared Event

Occurs when the undo history is programmatically cleared.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler Cleared
Event Cleared As EventHandler

Value

Type: SystemEventHandler
Remarks
This event is raised when the Clear method is called.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.UndoRedoRequested Event

IUndoHistoryUndoRedoRequested Event

Occurs when an undo or redo operation is requested.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<UndoRedoRequestEventArgs> UndoRedoRequested
Event UndoRedoRequested As EventHandler(Of UndoRedoRequestEventArgs)

Value

Type: SystemEventHandler UndoRedoRequestEventArgs
Remarks
This event is raised when the Undo or Redo method is called.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Class

Provides wrapper for an IUndoableTextChangeStack that implements INotifyCollectionChanged, allowing it to be used as an items source in UI controls.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityDisposableObject
ActiproSoftware.Text.UndoObservableUndoableTextChangeStack

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ObservableUndoableTextChangeStack : DisposableObject,
    IEnumerable, INotifyCollectionChanged, IUndoableTextChangeStack, IEnumerable<IUndoableTextChange>
Public Class ObservableUndoableTextChangeStack
    Inherits DisposableObject
    Implements IEnumerable, INotifyCollectionChanged, IUndoableTextChangeStack, IEnumerable(Of IUndoableTextChange)

The ObservableUndoableTextChangeStack type exposes the following members.

Constructors
 | Name | Description
Public method | ObservableUndoableTextChangeStack | Initializes a new instance of the ObservableUndoableTextChangeStack class.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the stack.
Public property | Count | Gets the count of text changes on the stack.
Public property | IsAtSavePoint | Gets whether the last text change on the stack is a save point.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the collection contains the specified IUndoableTextChange.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetTextChange | Gets the IUndoableTextChange that the specified location in the stack.
Public method | IndexOf | Returns the index of the IUndoableTextChange in the list.
Top
Events
 | Name | Description
Public event | CapacityChanged | Occurs when the capacity of the stack is changed.
Public event | CollectionChanged | Occurs when the collection is changed.
Public event | StackChanged | Occurs when the contents of the stack are changed.
Top
Remarks
Since the IUndoableTextChangeStack interface is defined in a .NET 2.0-based assembly and INotifyCollectionChanged was not added to .NET until 3.0, this class can be used as a wrapper for the core IUndoableTextChangeStack.
See Also

Reference

ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Constructor

Initializes a new instance of the ObservableUndoableTextChangeStack class.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableUndoableTextChangeStack(
    IUndoableTextChangeStack stack
)
Public Sub New (
    stack As IUndoableTextChangeStack
)

Parameters

stack
Type: ActiproSoftware.Text.UndoIUndoableTextChangeStack
The IUndoableTextChangeStack to wrap.
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Properties

The ObservableUndoableTextChangeStack type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the stack.
Public property | Count | Gets the count of text changes on the stack.
Public property | IsAtSavePoint | Gets whether the last text change on the stack is a save point.
Top
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Capacity Property

ObservableUndoableTextChangeStackCapacity Property

Gets or sets the capacity of the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Capacity { get; set; }
Public Property Capacity As Integer
    Get
    Set

Property Value

Type: Int32
The capacity of the stack.

Implements

IUndoableTextChangeStackCapacity
Remarks
If a new text change added to the stack causes the stack to exceed its capacity, the text changes at the bottom of the stack are removed until the stack no longer exceeds its capacity.
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Count Property

ObservableUndoableTextChangeStackCount Property

Gets the count of text changes on the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of text changes on the stack.

Implements

IUndoableTextChangeStackCount
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.IsAtSavePoint Property

ObservableUndoableTextChangeStackIsAtSavePoint Property

Gets whether the last text change on the stack is a save point.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAtSavePoint { get; }
Public ReadOnly Property IsAtSavePoint As Boolean
    Get

Property Value

Type: Boolean
true if the last text change on the stack is a save point; otherwise, false.

Implements

IUndoableTextChangeStackIsAtSavePoint
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Methods

The ObservableUndoableTextChangeStack type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the collection contains the specified IUndoableTextChange.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetTextChange | Gets the IUndoableTextChange that the specified location in the stack.
Public method | IndexOf | Returns the index of the IUndoableTextChange in the list.
Top
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Contains Method

ObservableUndoableTextChangeStackContains Method

Returns whether the collection contains the specified IUndoableTextChange.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    IUndoableTextChange textChange
)
Public Function Contains (
    textChange As IUndoableTextChange
) As Boolean

Parameters

textChange
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The IUndoableTextChange to look for in the list.

Return Value

Type: Boolean
true if the collection contains the specified IUndoableTextChange; otherwise, false.
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.CopyTo Method

ObservableUndoableTextChangeStackCopyTo Method

Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyTo(
    IUndoableTextChange[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As IUndoableTextChange(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The one-dimensional IUndoableTextChange array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

IUndoableTextChangeStackCopyTo(IUndoableTextChange, Int32)
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Dispose Method

ObservableUndoableTextChangeStackDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Top
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Dispose Method (Boolean)

ObservableUndoableTextChangeStackDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

ObservableUndoableTextChangeStack Class
Dispose Overload
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.GetEnumerator Method

ObservableUndoableTextChangeStackGetEnumerator Method

Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<IUndoableTextChange> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IUndoableTextChange)

Return Value

Type: IEnumerator IUndoableTextChange
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.GetTextChange Method

ObservableUndoableTextChangeStackGetTextChange Method

Gets the IUndoableTextChange that the specified location in the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IUndoableTextChange GetTextChange(
    int index
)
Public Function GetTextChange (
    index As Integer
) As IUndoableTextChange

Parameters

index
Type: SystemInt32
The index of the text change to check.

Return Value

Type: IUndoableTextChange
The IUndoableTextChange that the specified location in the stack.

Implements

IUndoableTextChangeStackGetTextChange(Int32)
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.IndexOf Method

ObservableUndoableTextChangeStackIndexOf Method

Returns the index of the IUndoableTextChange in the list.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    IUndoableTextChange textChange
)
Public Function IndexOf (
    textChange As IUndoableTextChange
) As Integer

Parameters

textChange
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The IUndoableTextChange to look for in the list.

Return Value

Type: Int32
The index of the IUndoableTextChange in the list, or -1 if not found.

Implements

IUndoableTextChangeStackIndexOf(IUndoableTextChange)
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Events

The ObservableUndoableTextChangeStack type exposes the following members.

Events
 | Name | Description
Public event | CapacityChanged | Occurs when the capacity of the stack is changed.
Public event | CollectionChanged | Occurs when the collection is changed.
Public event | StackChanged | Occurs when the contents of the stack are changed.
Top
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.CapacityChanged Event

ObservableUndoableTextChangeStackCapacityChanged Event

Occurs when the capacity of the stack is changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler CapacityChanged
Public Event CapacityChanged As EventHandler

Value

Type: SystemEventHandler

Implements

IUndoableTextChangeStackCapacityChanged
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.CollectionChanged Event

ObservableUndoableTextChangeStackCollectionChanged Event

Occurs when the collection is changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.StackChanged Event

ObservableUndoableTextChangeStackStackChanged Event

Occurs when the contents of the stack are changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.SyntaxEditor.Wpf (in ActiproSoftware.SyntaxEditor.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler StackChanged
Public Event StackChanged As EventHandler

Value

Type: SystemEventHandler

Implements

IUndoableTextChangeStackStackChanged
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


SavePointChangeType Enumeration

Specifies the type of changes that have been made to a character range since the last save point.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SavePointChangeType
Public Enumeration SavePointChangeType
Members
Member name | Value | Description
None | 0 | There are no changes from the original text.
SavedChanges | 1 | There are saved changed made since the last save point.
UnsavedChanges | 2 | There are unsaved changes made since the last save point.
RevertedChanges | 3 | These are reverted changes where undo was performed after the last save point.
See Also

Reference

ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs Class

Event arguments for when an undo or redo operation is requesting to be applied to an ITextDocument.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UndoUndoRedoRequestEventArgs

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UndoRedoRequestEventArgs : EventArgs
Public Class UndoRedoRequestEventArgs
    Inherits EventArgs

The UndoRedoRequestEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UndoRedoRequestEventArgs | Initializes a new instance of the UndoRedoRequestEventArgs class.
Top
Properties
 | Name | Description
Public property | Document | Gets the ITextDocument that is affected by this event, if known.
Public property | IsUndo | Gets whether this event is for an undo operation.
Public property | TextChange | Gets the IUndoableTextChange that is made to the document.
Top
See Also

Reference

ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs Constructor

Initializes a new instance of the UndoRedoRequestEventArgs class.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UndoRedoRequestEventArgs(
    ITextDocument document,
    IUndoableTextChange textChange,
    bool isUndo
)
Public Sub New (
    document As ITextDocument,
    textChange As IUndoableTextChange,
    isUndo As Boolean
)

Parameters

document
Type: ActiproSoftware.TextITextDocument
The ITextDocument that is affected by this event, if known.
textChange
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The IUndoableTextChange that is made.
isUndo
Type: SystemBoolean
true the event is for an undo operation; otherwise, false, meaning redo.
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs Properties

The UndoRedoRequestEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument that is affected by this event, if known.
Public property | IsUndo | Gets whether this event is for an undo operation.
Public property | TextChange | Gets the IUndoableTextChange that is made to the document.
Top
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs.Document Property

UndoRedoRequestEventArgsDocument Property

Gets the ITextDocument that is affected by this event, if known.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITextDocument Document { get; }
Public ReadOnly Property Document As ITextDocument
    Get

Property Value

Type: ITextDocument
The ITextDocument that is affected by this event, if known.
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs.IsUndo Property

UndoRedoRequestEventArgsIsUndo Property

Gets whether this event is for an undo operation.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsUndo { get; }
Public ReadOnly Property IsUndo As Boolean
    Get

Property Value

Type: Boolean
true the event is for an undo operation; otherwise, false, meaning redo.
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs.TextChange Property

UndoRedoRequestEventArgsTextChange Property

Gets the IUndoableTextChange that is made to the document.

Namespace: ActiproSoftware.Text.Undo
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IUndoableTextChange TextChange { get; }
Public ReadOnly Property TextChange As IUndoableTextChange
    Get

Property Value

Type: IUndoableTextChange
The IUndoableTextChange that is made to the document.
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


ActiproSoftware.Text.Utility Namespace

Contains utility classes.
Classes
 | Class | Description
Public class | CollectionChangeEventArgsT | Event arguments for various SimpleObservableCollectionT change events.
Public class | DisposableObject | Provides a base class that implements the IDisposable interface. This class functions in accordance with the Disposable design pattern.
Public class | IntegerList | Represents a list of integers.
Public class | KeyedObservableCollectionT | Provides a generic keyed collection that provides notifications when items are added or removed.
Public class | KeyedSynchronizedCollectionT | Provides a thread-safe generic keyed collection that provides notifications when items are added or removed.
Public class | LipsumGenerator | A utility class that can generate 'lorem ipsum' placeholder text.
Public class | OrderableHelper | Provides numerous utility methods for working with IOrderable objects.
Public class | Ordering | Provides data used to order one object relative to another.
Public class | PropertyChangedEventArgsT | Provides event arguments for a property change event, indicating the old and new values.
Public class | PropertyDictionary | Provides a thread-safe dictionary of properties.
Public class | RangeCollection | Provides an implementation of a collection of Range objects.
Public class | SimpleObservableCollectionT | Provides a generic collection that provides notifications when items are added or removed.
Public class | SimpleSynchronizedCollectionT | Provides a thread-safe generic collection that provides notifications when items are added or removed.
Public class | StringHelper | Provides numerous utility methods for working with strings.
Public class | StringPropertyChangedEventArgs | Provides event arguments for a property change event, indicating the old and new values.
Public class | WeakEventListenerTInstance, TEventArgs | Provides a listener that allows for "weak" listening to events.
Structures
 | Structure | Description
Public structure | Range | Represents an ordered pair of min and max values.
Interfaces
 | Interface | Description
Public interface | IKeyedObject | Provides the base requirements for an object that has a string-based key.
Public interface | IKeyedObservableCollectionT | Provides the base requirements for a collection that has string-based unique keys.
Public interface | IObservableCollectionT | Provides the base requirements for a collection that raises events when changed.
Public interface | IOrderable | Provides the base requirements for an object that can be ordered by name against other named objects.
Public interface | IServiceLocator | Provides the base requirements for an object that can store and provide services.
Delegates
 | Delegate | Description
Public delegate | PropertyDictionaryCreatorTValue | Creates a property value.
Public delegate | WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 | Provides the delegate for an event action.
Enumerations
 | Enumeration | Description
Public enumeration | EventHandlerPriority | Specifies the priority that applied to an event handler.
Public enumeration | OrderPlacement | Specifies the placement order for an Ordering.


CollectionChangeEventArgs(T) Class

CollectionChangeEventArgsT Class

Event arguments for various SimpleObservableCollectionT change events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UtilityCollectionChangeEventArgsT

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CollectionChangeEventArgs<T> : EventArgs

Public Class CollectionChangeEventArgs(Of T)
    Inherits EventArgs

Type Parameters

T
The Type of item.

The CollectionChangeEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionChangeEventArgsT | Initializes a new instance of the CollectionChangeEventArgs class.
Top
Properties
 | Name | Description
Public property | Index | Gets the index at which the item is/was located.
Public property | Item | Gets the T that is affected by this event.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


CollectionChangeEventArgs(T) Constructor

CollectionChangeEventArgsT Constructor

Initializes a new instance of the CollectionChangeEventArgs class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CollectionChangeEventArgs(
    int index,
    T item
)
Public Sub New (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index at which the item is/was located.
item
Type: T
The T that is affected by this event.
See Also

Reference

CollectionChangeEventArgsT Class
ActiproSoftware.Text.Utility Namespace


CollectionChangeEventArgs(T) Properties

CollectionChangeEventArgsT Properties

The CollectionChangeEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets the index at which the item is/was located.
Public property | Item | Gets the T that is affected by this event.
Top
See Also

Reference

CollectionChangeEventArgsT Class
ActiproSoftware.Text.Utility Namespace


CollectionChangeEventArgs(T).Index Property

CollectionChangeEventArgsTIndex Property

Gets the index at which the item is/was located.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index at which the item is/was located.
See Also

Reference

CollectionChangeEventArgsT Class
ActiproSoftware.Text.Utility Namespace


CollectionChangeEventArgs(T).Item Property

CollectionChangeEventArgsTItem Property

Gets the T that is affected by this event.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Item { get; }
Public ReadOnly Property Item As T
    Get

Property Value

Type: T
The T that is affected by this event.
See Also

Reference

CollectionChangeEventArgsT Class
ActiproSoftware.Text.Utility Namespace


DisposableObject Class

Provides a base class that implements the IDisposable interface. This class functions in accordance with the Disposable design pattern.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityDisposableObject
ActiproSoftware.Text.Parsing.ImplementationThreadedParseRequestDispatcher
ActiproSoftware.Text.TaggingTagAggregatorBaseT
ActiproSoftware.Text.UndoObservableUndoableTextChangeStack

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DisposableObject
Public MustInherit Class DisposableObject

The DisposableObject type exposes the following members.

Constructors
 | Name | Description
Protected method | DisposableObject | Initializes a new instance of the DisposableObject class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


DisposableObject Constructor

Initializes a new instance of the DisposableObject class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DisposableObject()
Protected Sub New
Remarks
The default constructor initializes all fields to their default values.
See Also

Reference

DisposableObject Class
ActiproSoftware.Text.Utility Namespace


DisposableObject Methods

The DisposableObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Top
See Also

Reference

DisposableObject Class
ActiproSoftware.Text.Utility Namespace


DisposableObject.Dispose Method

DisposableObjectDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Top
See Also

Reference

DisposableObject Class
ActiproSoftware.Text.Utility Namespace


DisposableObject.Dispose Method

DisposableObjectDispose Method

Releases all resources used by the object.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose
See Also

Reference

DisposableObject Class
Dispose Overload
ActiproSoftware.Text.Utility Namespace


DisposableObject.Dispose Method (Boolean)

DisposableObjectDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

DisposableObject Class
Dispose Overload
ActiproSoftware.Text.Utility Namespace


DisposableObject.Finalize Method

DisposableObjectFinalize Method

Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
See Also

Reference

DisposableObject Class
ActiproSoftware.Text.Utility Namespace


EventHandlerPriority Enumeration

Specifies the priority that applied to an event handler.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum EventHandlerPriority
Public Enumeration EventHandlerPriority
Members
Member name | Value | Description
Low | 0 | Low priority.
Medium | 1 | Medium priority.
High | 2 | High priority.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IKeyedObject Interface

Provides the base requirements for an object that has a string-based key.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IKeyedObject
Public Interface IKeyedObject

The IKeyedObject type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IKeyedObject Properties

The IKeyedObject type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object.
Top
See Also

Reference

IKeyedObject Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObject.Key Property

IKeyedObjectKey Property

Gets the string-based key that identifies the object.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Key { get; }
ReadOnly Property Key As String
    Get

Property Value

Type: String
The string-based key that identifies the object.
See Also

Reference

IKeyedObject Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T) Interface

IKeyedObservableCollectionT Interface

Provides the base requirements for a collection that has string-based unique keys.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IKeyedObservableCollection<T> : IEnumerable,
    IObservableCollection<T>, IList<T>, ICollection<T>, IEnumerable<T>
where T : class, IKeyedObject

Public Interface IKeyedObservableCollection(Of T As {Class, IKeyedObject})
    Inherits IEnumerable, IObservableCollection(Of T), IList(Of T),
    ICollection(Of T), IEnumerable(Of T)

Type Parameters

T
The Type of item in the collection.

The IKeyedObservableCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList T.)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList T.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T.)
Public method | Remove(String) | Removes the T with the specified key.
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeT | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllT | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T) Properties

IKeyedObservableCollectionT Properties

The IKeyedObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Item Property

IKeyedObservableCollectionTItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Item Property (String)

IKeyedObservableCollectionTItem Property (String)

Gets the T with the specified key.

[C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
T this[
    string key
] { get; }
ReadOnly Default Property Item (
    key As String
) As T
    Get

Parameters

key
Type: SystemString
The key of the T to return.

Property Value

Type: T
The T with the specified key.
See Also

Reference

IKeyedObservableCollectionT Interface
Item Overload
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T) Methods

IKeyedObservableCollectionT Methods

The IKeyedObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T .)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T .)
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T .)
Public method | Remove(String) | Removes the T with the specified key.
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeT | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllT | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Contains Method

IKeyedObservableCollectionTContains Method

Overload List
 | Name | Description
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Contains Method (String)

IKeyedObservableCollectionTContains Method (String)

Determines whether a T with the specified key is in the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Contains(
    string key
)
Function Contains (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T with the specified key is found in the collection; otherwise, false.
See Also

Reference

IKeyedObservableCollectionT Interface
Contains Overload
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).IndexOf Method

IKeyedObservableCollectionTIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).IndexOf Method (String)

IKeyedObservableCollectionTIndexOf Method (String)

Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int IndexOf(
    string key
)
Function IndexOf (
    key As String
) As Integer

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of a T with the specified key within the entire collection, if found; otherwise, -1.
See Also

Reference

IKeyedObservableCollectionT Interface
IndexOf Overload
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Remove Method

IKeyedObservableCollectionTRemove Method

Overload List
 | Name | Description
Public method | Remove(T) | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T .)
Public method | Remove(String) | Removes the T with the specified key.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Remove Method (String)

IKeyedObservableCollectionTRemove Method (String)

Removes the T with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Remove(
    string key
)
Function Remove (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T was removed; otherwise, false.
See Also

Reference

IKeyedObservableCollectionT Interface
Remove Overload
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T) Events

IKeyedObservableCollectionT Events

The IKeyedObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IntegerList Class

Represents a list of integers.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityIntegerList

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class IntegerList
Public Class IntegerList

The IntegerList type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerList | Initializes a new instance of the IntegerList class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of integers in the list.
Public property | Item | Gets or sets the integer at the specified index. [C#] In C#, this property is the indexer for the IntegerList class.
Top
Methods
 | Name | Description
Public method | Add | Adds an integer to the end of the list.
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | Increment | Increments all integers in the list after the specified index by the delta value.
Public method | Insert | Inserts an integer into the list.
Public method | RemoveAt | Removes the integer at the specified index from the list.
Public method | RemoveRange | Removes a range of integers from the list.
Public method | ToArray | Copies the integer of the collection to a new integer array.
Top
Remarks
The implementation uses a short array to track the values until the values become too large, at which point an integer array is used. This saves on memory for smaller-valued lists.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IntegerList Constructor

Initializes a new instance of the IntegerList class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IntegerList(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The initial capacity of the list.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList Properties

The IntegerList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of integers in the list.
Public property | Item | Gets or sets the integer at the specified index. [C#] In C#, this property is the indexer for the IntegerList class.
Top
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Count Property

IntegerListCount Property

Gets the number of integers in the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of integers in the list.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Item Property

IntegerListItem Property

Gets or sets the integer at the specified index.

[C#] In C#, this property is the indexer for the IntegerList class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As Integer
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the integer to return.

Property Value

Type: Int32
The integer at the specified index.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList Methods

The IntegerList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an integer to the end of the list.
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | Increment | Increments all integers in the list after the specified index by the delta value.
Public method | Insert | Inserts an integer into the list.
Public method | RemoveAt | Removes the integer at the specified index from the list.
Public method | RemoveRange | Removes a range of integers from the list.
Public method | ToArray | Copies the integer of the collection to a new integer array.
Top
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Add Method

IntegerListAdd Method

Adds an integer to the end of the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Add(
    int value
)
Public Function Add (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
The value to add.

Return Value

Type: Int32
The index at which the integer was added.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.BinarySearch Method

IntegerListBinarySearch Method

Performs a binary search for the specified value.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int BinarySearch(
    int value
)
Public Function BinarySearch (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
The value for which to search.

Return Value

Type: Int32
The index of the specified value in the specified array, if value is found. If value is not found and value is less than one or more elements in array, a negative number which is the bitwise complement of the index of the first element that is larger than value. If value is not found and value is greater than any of the elements in array, a negative number which is the bitwise complement of (the index of the last element plus 1).
Remarks
This method should only be used if the integers in the list are guaranteed to be sorted.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Increment Method

IntegerListIncrement Method

Increments all integers in the list after the specified index by the delta value.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Increment(
    int index,
    int delta
)
Public Sub Increment (
    index As Integer,
    delta As Integer
)

Parameters

index
Type: SystemInt32
The index at which to start incrementing value.
delta
Type: SystemInt32
The amount by which to increment.
Remarks
This method should only be used if the integers in the list are guaranteed to be sorted.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Insert Method

IntegerListInsert Method

Inserts an integer into the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Insert(
    int index,
    int value
)
Public Sub Insert (
    index As Integer,
    value As Integer
)

Parameters

index
Type: SystemInt32
The index at which to insert.
value
Type: SystemInt32
The value to insert.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.RemoveAt Method

IntegerListRemoveAt Method

Removes the integer at the specified index from the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the integer to remove.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.RemoveRange Method

IntegerListRemoveRange Method

Removes a range of integers from the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveRange(
    int index,
    int count
)
Public Sub RemoveRange (
    index As Integer,
    count As Integer
)

Parameters

index
Type: SystemInt32
The zero-based starting index of the range of integers to remove.
count
Type: SystemInt32
The number of integers to remove.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.ToArray Method

IntegerListToArray Method

Copies the integer of the collection to a new integer array.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int[] ToArray()
Public Function ToArray As Integer()

Return Value

Type: Int32
An array of integers.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T) Interface

IObservableCollectionT Interface

Provides the base requirements for a collection that raises events when changed.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IObservableCollection<T> : IEnumerable,
    IList<T>, ICollection<T>, IEnumerable<T>
where T : class

Public Interface IObservableCollection(Of T As Class)
    Inherits IEnumerable, IList(Of T), ICollection(Of T),
    IEnumerable(Of T)

Type Parameters

T
The Type of item in the collection.

The IObservableCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList T.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection.
Public event | ItemAdding | Occurs before an item is added to the collection.
Public event | ItemRemoved | Occurs after an item is removed from the collection.
Public event | ItemRemoving | Occurs before an item is removed from the collection.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeT | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllT | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IObservableCollection(T) Properties

IObservableCollectionT Properties

The IObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList T .)
Top
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T) Methods

IObservableCollectionT Methods

The IObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList T .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeT | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllT | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T) Events

IObservableCollectionT Events

The IObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection.
Public event | ItemAdding | Occurs before an item is added to the collection.
Public event | ItemRemoved | Occurs after an item is removed from the collection.
Public event | ItemRemoving | Occurs before an item is removed from the collection.
Top
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T).ItemAdded Event

IObservableCollectionTItemAdded Event

Occurs after an item is added to the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<T>> ItemAdded
Event ItemAdded As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T).ItemAdding Event

IObservableCollectionTItemAdding Event

Occurs before an item is added to the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<T>> ItemAdding
Event ItemAdding As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T).ItemRemoved Event

IObservableCollectionTItemRemoved Event

Occurs after an item is removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<T>> ItemRemoved
Event ItemRemoved As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T).ItemRemoving Event

IObservableCollectionTItemRemoving Event

Occurs before an item is removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<T>> ItemRemoving
Event ItemRemoving As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IOrderable Interface

Provides the base requirements for an object that can be ordered by name against other named objects.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IOrderable : IKeyedObject
Public Interface IOrderable
    Inherits IKeyedObject

The IOrderable type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IOrderable Properties

The IOrderable type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
See Also

Reference

IOrderable Interface
ActiproSoftware.Text.Utility Namespace


IOrderable.Orderings Property

IOrderableOrderings Property

Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<Ordering> Orderings { get; }
ReadOnly Property Orderings As IEnumerable(Of Ordering)
    Get

Property Value

Type: IEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
See Also

Reference

IOrderable Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator Interface

Provides the base requirements for an object that can store and provide services.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IServiceLocator
Public Interface IServiceLocator

The IServiceLocator type exposes the following members.

Properties
 | Name | Description
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services.
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object.
Public event | ServiceRemoved | Occurs after a service is removed from the object.
Top
Remarks
When calling the non-generic methods on this interface, the object key used to register the service should generally be a Type instance.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IServiceLocator Properties

The IServiceLocator type exposes the following members.

Properties
 | Name | Description
Public property | SyncRoot | Gets an object that can be used to synchronize access to the services.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.SyncRoot Property

IServiceLocatorSyncRoot Property

Gets an object that can be used to synchronize access to the services.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object SyncRoot { get; }
ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object
An object that can be used to synchronize access to the services.
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator Methods

The IServiceLocator type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.GetAllServiceTypes Method

IServiceLocatorGetAllServiceTypes Method

Returns a collection of all the service types that have been registered.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<Object> GetAllServiceTypes()
Function GetAllServiceTypes As IEnumerable(Of Object)

Return Value

Type: IEnumerable Object
A collection of all the service types that have been registered.
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.GetService Method

IServiceLocatorGetService Method

Overload List
 | Name | Description
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.GetService(T) Method

IServiceLocatorGetServiceT Method

Returns the service that has been registered with the specified type.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
T GetService<T>()

Function GetService(Of T) As T

Type Parameters

T
The type of service to return.

Return Value

Type: T
The service that has been registered with the specified type.
See Also

Reference

IServiceLocator Interface
GetService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.GetService Method (Object)

IServiceLocatorGetService Method (Object)

Returns the service that has been registered with the specified type.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object GetService(
    Object serviceType
)
Function GetService (
    serviceType As Object
) As Object

Parameters

serviceType
Type: SystemObject
The type of service to return.

Return Value

Type: Object
The service that has been registered with the specified type.
See Also

Reference

IServiceLocator Interface
GetService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.RegisterService Method

IServiceLocatorRegisterService Method

Overload List
 | Name | Description
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.RegisterService(T) Method (T)

IServiceLocatorRegisterServiceT Method (T)

Registers a service instance for the specified service type.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void RegisterService<T>(
    T service
)

Sub RegisterService(Of T) (
    service As T
)

Parameters

service
Type: T
The service object instance.

Type Parameters

T
The type of service.
See Also

Reference

IServiceLocator Interface
RegisterService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.RegisterService Method (Object, Object)

IServiceLocatorRegisterService Method (Object, Object)

Registers a service instance for the specified service type.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void RegisterService(
    Object serviceType,
    Object service
)
Sub RegisterService (
    serviceType As Object,
    service As Object
)

Parameters

serviceType
Type: SystemObject
The type of service.
service
Type: SystemObject
The service object instance.
See Also

Reference

IServiceLocator Interface
RegisterService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.UnregisterService Method

IServiceLocatorUnregisterService Method

Overload List
 | Name | Description
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.UnregisterService(T) Method

IServiceLocatorUnregisterServiceT Method

Unregisters a service of the specified service type.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void UnregisterService<T>()

Sub UnregisterService(Of T)

Type Parameters

T
The type of service.
See Also

Reference

IServiceLocator Interface
UnregisterService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.UnregisterService Method (Object)

IServiceLocatorUnregisterService Method (Object)

Unregisters a service of the specified service type.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void UnregisterService(
    Object serviceType
)
Sub UnregisterService (
    serviceType As Object
)

Parameters

serviceType
Type: SystemObject
The type of service.
See Also

Reference

IServiceLocator Interface
UnregisterService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator Events

The IServiceLocator type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object.
Public event | ServiceRemoved | Occurs after a service is removed from the object.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.ServiceAdded Event

IServiceLocatorServiceAdded Event

Occurs after a service is added to the object.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<Object>> ServiceAdded
Event ServiceAdded As EventHandler(Of CollectionChangeEventArgs(Of Object))

Value

Type: SystemEventHandler CollectionChangeEventArgs Object
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.ServiceRemoved Event

IServiceLocatorServiceRemoved Event

Occurs after a service is removed from the object.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<Object>> ServiceRemoved
Event ServiceRemoved As EventHandler(Of CollectionChangeEventArgs(Of Object))

Value

Type: SystemEventHandler CollectionChangeEventArgs Object
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Class

KeyedObservableCollectionT Class

Provides a generic keyed collection that provides notifications when items are added or removed.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
ActiproSoftware.Text.UtilitySimpleObservableCollection T
ActiproSoftware.Text.UtilityKeyedObservableCollectionT
ActiproSoftware.Text.Lexing.ImplementationLexicalStateCollection
ActiproSoftware.Text.UtilityKeyedSynchronizedCollectionT
ActiproSoftware.Windows.Controls.SyntaxEditor.Margins.ImplementationEditorViewMarginCollection
ActiproSoftware.Windows.Controls.SyntaxEditor.Margins.ImplementationPrinterViewMarginCollection

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class KeyedObservableCollection<T> : SimpleObservableCollection<T>,
    IEnumerable, IObservableCollection<T>, IList<T>, ICollection<T>, IEnumerable<T>,
    IKeyedObservableCollection<T>
where T : class, IKeyedObject

Public Class KeyedObservableCollection(Of T As {Class, IKeyedObject})
    Inherits SimpleObservableCollection(Of T)
    Implements IEnumerable, IObservableCollection(Of T), IList(Of T),
    ICollection(Of T), IEnumerable(Of T), IKeyedObservableCollection(Of T)

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.Text.Utility.KeyedObservableCollection`1"]

The KeyedObservableCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | KeyedObservableCollectionT | Initializes a new instance of the KeyedObservableCollectionT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection T.)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | Remove(String) | Removes the T with the specified key.
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeT | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllT | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Constructor

KeyedObservableCollectionT Constructor

Initializes a new instance of the KeyedObservableCollectionT class

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public KeyedObservableCollection()
Public Sub New
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Properties

KeyedObservableCollectionT Properties

The KeyedObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Item Property

KeyedObservableCollectionTItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Item Property (String)

KeyedObservableCollectionTItem Property (String)

Gets the T with the specified key.

[C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual T this[
    string key
] { get; }
Public Overridable ReadOnly Default Property Item (
    key As String
) As T
    Get

Parameters

key
Type: SystemString
The key of the T to return.

Property Value

Type: T
The T with the specified key.

Implements

IKeyedObservableCollectionTItemString
See Also

Reference

KeyedObservableCollectionT Class
Item Overload
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Methods

KeyedObservableCollectionT Methods

The KeyedObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | Remove(String) | Removes the T with the specified key.
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeT | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllT | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Contains Method

KeyedObservableCollectionTContains Method

Overload List
 | Name | Description
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Contains Method (String)

KeyedObservableCollectionTContains Method (String)

Determines whether a T with the specified key is in the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    string key
)
Public Function Contains (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T with the specified key is found in the collection; otherwise, false.

Implements

IKeyedObservableCollectionTContains(String)
See Also

Reference

KeyedObservableCollectionT Class
Contains Overload
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).IndexOf Method

KeyedObservableCollectionTIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).IndexOf Method (String)

KeyedObservableCollectionTIndexOf Method (String)

Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual int IndexOf(
    string key
)
Public Overridable Function IndexOf (
    key As String
) As Integer

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of a T with the specified key within the entire collection, if found; otherwise, -1.

Implements

IKeyedObservableCollectionTIndexOf(String)
See Also

Reference

KeyedObservableCollectionT Class
IndexOf Overload
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Remove Method

KeyedObservableCollectionTRemove Method

Overload List
 | Name | Description
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | Remove(String) | Removes the T with the specified key.
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Remove Method (String)

KeyedObservableCollectionTRemove Method (String)

Removes the T with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool Remove(
    string key
)
Public Overridable Function Remove (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T was removed; otherwise, false.

Implements

IKeyedObservableCollectionTRemove(String)
See Also

Reference

KeyedObservableCollectionT Class
Remove Overload
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Events

KeyedObservableCollectionT Events

The KeyedObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Class

KeyedSynchronizedCollectionT Class

Provides a thread-safe generic keyed collection that provides notifications when items are added or removed.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
ActiproSoftware.Text.UtilitySimpleObservableCollection T
ActiproSoftware.Text.UtilityKeyedObservableCollection T
ActiproSoftware.Text.UtilityKeyedSynchronizedCollectionT

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class KeyedSynchronizedCollection<T> : KeyedObservableCollection<T>
where T : class, IKeyedObject

Public Class KeyedSynchronizedCollection(Of T As {Class, IKeyedObject})
    Inherits KeyedObservableCollection(Of T)

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.Text.Utility.KeyedSynchronizedCollection`1"]

The KeyedSynchronizedCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | KeyedSynchronizedCollectionT | Initializes a new instance of the KeyedSynchronizedCollectionT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection T.)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Overrides KeyedObservableCollectionTItemString.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Overrides SimpleObservableCollectionTClearItems.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from KeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Overrides KeyedObservableCollectionTIndexOf(String).)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides SimpleObservableCollectionTInsertItem(Int32, T).)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | Remove(String) | Removes the T with the specified key. (Overrides KeyedObservableCollectionTRemove(String).)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides SimpleObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides SimpleObservableCollectionTSetItem(Int32, T).)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Constructor

KeyedSynchronizedCollectionT Constructor

Initializes a new instance of the KeyedSynchronizedCollectionT class

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public KeyedSynchronizedCollection()
Public Sub New
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Properties

KeyedSynchronizedCollectionT Properties

The KeyedSynchronizedCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Overrides KeyedObservableCollectionTItemString.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).Item Property

KeyedSynchronizedCollectionTItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Overrides KeyedObservableCollectionTItemString.)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).Item Property (String)

KeyedSynchronizedCollectionTItem Property (String)

Gets the T with the specified key.

[C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override T this[
    string key
] { get; }
Public Overrides ReadOnly Default Property Item (
    key As String
) As T
    Get

Parameters

key
Type: SystemString
The key of the T to return.

Property Value

Type: T
The T with the specified key.

Implements

IKeyedObservableCollectionTItemString
See Also

Reference

KeyedSynchronizedCollectionT Class
Item Overload
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Methods

KeyedSynchronizedCollectionT Methods

The KeyedSynchronizedCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Overrides SimpleObservableCollectionTClearItems.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from KeyedObservableCollectionT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Overrides KeyedObservableCollectionTIndexOf(String).)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides SimpleObservableCollectionTInsertItem(Int32, T).)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | Remove(String) | Removes the T with the specified key. (Overrides KeyedObservableCollectionTRemove(String).)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides SimpleObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides SimpleObservableCollectionTSetItem(Int32, T).)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).ClearItems Method

KeyedSynchronizedCollectionTClearItems Method

Removes all items from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).IndexOf Method

KeyedSynchronizedCollectionTIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Overrides KeyedObservableCollectionTIndexOf(String).)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).IndexOf Method (String)

KeyedSynchronizedCollectionTIndexOf Method (String)

Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int IndexOf(
    string key
)
Public Overrides Function IndexOf (
    key As String
) As Integer

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of a T with the specified key within the entire collection, if found; otherwise, -1.

Implements

IKeyedObservableCollectionTIndexOf(String)
See Also

Reference

KeyedSynchronizedCollectionT Class
IndexOf Overload
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).InsertItem Method

KeyedSynchronizedCollectionTInsertItem Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index at which to insert the item.
item
Type: T
The item to insert.
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).Remove Method

KeyedSynchronizedCollectionTRemove Method

Overload List
 | Name | Description
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | Remove(String) | Removes the T with the specified key. (Overrides KeyedObservableCollectionTRemove(String).)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).Remove Method (String)

KeyedSynchronizedCollectionTRemove Method (String)

Removes the T with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Remove(
    string key
)
Public Overrides Function Remove (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T was removed; otherwise, false.

Implements

IKeyedObservableCollectionTRemove(String)
See Also

Reference

KeyedSynchronizedCollectionT Class
Remove Overload
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).RemoveItem Method

KeyedSynchronizedCollectionTRemoveItem Method

Removes the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the item to remove.
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).SetItem Method

KeyedSynchronizedCollectionTSetItem Method

Replaces the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index of the item to replace.
item
Type: T
The item with which to replace.
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Events

KeyedSynchronizedCollectionT Events

The KeyedSynchronizedCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


LipsumGenerator Class

A utility class that can generate 'lorem ipsum' placeholder text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityLipsumGenerator

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LipsumGenerator
Public Class LipsumGenerator

The LipsumGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | LipsumGenerator | Initializes a new instance of the LipsumGenerator class.
Public method | LipsumGenerator(String, String) | Initializes a new instance of the LipsumGenerator class.
Top
Methods
 | Name | Description
Public method | GenerateParagraph | Generates a single paragraph of text.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


LipsumGenerator Constructor

Overload List
 | Name | Description
Public method | LipsumGenerator | Initializes a new instance of the LipsumGenerator class.
Public method | LipsumGenerator(String, String) | Initializes a new instance of the LipsumGenerator class.
Top
See Also

Reference

LipsumGenerator Class
ActiproSoftware.Text.Utility Namespace


LipsumGenerator Constructor

Initializes a new instance of the LipsumGenerator class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LipsumGenerator()
Public Sub New
See Also

Reference

LipsumGenerator Class
LipsumGenerator Overload
ActiproSoftware.Text.Utility Namespace


LipsumGenerator Constructor (String, String)

Initializes a new instance of the LipsumGenerator class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LipsumGenerator(
    string startingWords,
    string words
)
Public Sub New (
    startingWords As String,
    words As String
)

Parameters

startingWords
Type: SystemString
The words that can start the first paragraph.
words
Type: SystemString
The words.
See Also

Reference

LipsumGenerator Class
LipsumGenerator Overload
ActiproSoftware.Text.Utility Namespace


LipsumGenerator Methods

The LipsumGenerator type exposes the following members.

Methods
 | Name | Description
Public method | GenerateParagraph | Generates a single paragraph of text.
Top
See Also

Reference

LipsumGenerator Class
ActiproSoftware.Text.Utility Namespace


LipsumGenerator.GenerateParagraph Method

LipsumGeneratorGenerateParagraph Method

Generates a single paragraph of text.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string GenerateParagraph(
    bool useStartingWords,
    int wordCount
)
Public Function GenerateParagraph (
    useStartingWords As Boolean,
    wordCount As Integer
) As String

Parameters

useStartingWords
Type: SystemBoolean
Whether to use the starting words to begin the paragraph (e.g. Lorem ipsum dolor sit amet...).
wordCount
Type: SystemInt32
The number of words in the paragraph.

Return Value

Type: String
The generated text.
See Also

Reference

LipsumGenerator Class
ActiproSoftware.Text.Utility Namespace


OrderableHelper Class

Provides numerous utility methods for working with IOrderable objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityOrderableHelper

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class OrderableHelper
Public NotInheritable Class OrderableHelper
Methods
Name | Description
SortT(IEnumerableT) | Returns a sorted array of IOrderable items.
SortT(IEnumerableT, ComparisonT, ComparisonT) | Sorts a list of items, giving precedence to IOrderable items.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


OrderableHelper Methods

Methods
Name | Description
SortT(IEnumerableT) | Returns a sorted array of IOrderable items.
SortT(IEnumerableT, ComparisonT, ComparisonT) | Sorts a list of items, giving precedence to IOrderable items.
Top
See Also

Reference

OrderableHelper Class
ActiproSoftware.Text.Utility Namespace


OrderableHelper.Sort Method

OrderableHelperSort Method

Overload List
Name | Description
SortT(IEnumerableT) | Returns a sorted array of IOrderable items.
SortT(IEnumerableT, ComparisonT, ComparisonT) | Sorts a list of items, giving precedence to IOrderable items.
Top
See Also

Reference

OrderableHelper Class
ActiproSoftware.Text.Utility Namespace


OrderableHelper.Sort(T) Method (IEnumerable(T))

OrderableHelperSortT Method (IEnumerableT)

Returns a sorted array of IOrderable items.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static T[] Sort<T>(
    IEnumerable<T> unsortedItems
)
where T : IOrderable

Public Shared Function Sort(Of T As IOrderable) (
    unsortedItems As IEnumerable(Of T)
) As T()

Parameters

unsortedItems
Type: System.Collections.GenericIEnumerable T
The collection of unsorted IOrderable items.

Type Parameters

T
The item type.

Return Value

Type: T
A sorted array of IOrderable items.
See Also

Reference

OrderableHelper Class
Sort Overload
ActiproSoftware.Text.Utility Namespace


OrderableHelper.Sort(T) Method (IEnumerable(T), Comparison(T), Comparison(T))

OrderableHelperSortT Method (IEnumerableT, ComparisonT, ComparisonT)

Sorts a list of items, giving precedence to IOrderable items.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static T[] Sort<T>(
    IEnumerable<T> unsortedItems,
    Comparison<T> preComparison,
    Comparison<T> fallbackComparison
)

Public Shared Function Sort(Of T) (
    unsortedItems As IEnumerable(Of T),
    preComparison As Comparison(Of T),
    fallbackComparison As Comparison(Of T)
) As T()

Parameters

unsortedItems
Type: System.Collections.GenericIEnumerable T
The collection of unsorted items.
preComparison
Type: SystemComparison T
An optional comparison that executes before the default logic.
fallbackComparison
Type: SystemComparison T
An optional fallback comparison delegate.

Type Parameters

T
The item type.

Return Value

Type: T
A sorted array of items.
See Also

Reference

OrderableHelper Class
Sort Overload
ActiproSoftware.Text.Utility Namespace


Ordering Class

Provides data used to order one object relative to another.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityOrdering

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Ordering
Public Class Ordering

The Ordering type exposes the following members.

Constructors
 | Name | Description
Public method | Ordering | Initializes a new instance of the Ordering class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key of the object relative to which the ordering's owner should be positioned.
Public property | Placement | Gets the OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.
Top
Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


Ordering Constructor

Initializes a new instance of the Ordering class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Ordering(
    string key,
    OrderPlacement placement
)
Public Sub New (
    key As String,
    placement As OrderPlacement
)

Parameters

key
Type: SystemString
The string-based key of the object relative to which the ordering's owner should be positioned.
placement
Type: ActiproSoftware.Text.UtilityOrderPlacement
The OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering Properties

The Ordering type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key of the object relative to which the ordering's owner should be positioned.
Public property | Placement | Gets the OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.
Top
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering.Key Property

OrderingKey Property

Gets the string-based key of the object relative to which the ordering's owner should be positioned.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The string-based key of the object relative to which the ordering's owner should be positioned.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering.Placement Property

OrderingPlacement Property

Gets the OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OrderPlacement Placement { get; }
Public ReadOnly Property Placement As OrderPlacement
    Get

Property Value

Type: OrderPlacement
The OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering Methods

The Ordering type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering.ToString Method

OrderingToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


OrderPlacement Enumeration

Specifies the placement order for an Ordering.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum OrderPlacement
Public Enumeration OrderPlacement
Members
Member name | Value | Description
After | 0 | The object that contains the Ordering is after the object specified in the Ordering.
Before | 1 | The object that contains the Ordering is before the object specified in the Ordering.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T) Class

PropertyChangedEventArgsT Class

Provides event arguments for a property change event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UtilityPropertyChangedEventArgsT
ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyChangedEventArgs<T> : EventArgs

Public Class PropertyChangedEventArgs(Of T)
    Inherits EventArgs

Type Parameters

T
The return type of the property.

The PropertyChangedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyChangedEventArgsT | Initializes a new instance of the PropertyChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T) Constructor

PropertyChangedEventArgsT Constructor

Initializes a new instance of the PropertyChangedEventArgs class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyChangedEventArgs(
    T oldValue,
    T newValue
)
Public Sub New (
    oldValue As T,
    newValue As T
)

Parameters

oldValue
Type: T
The previous value of the property being tracked as reported by an event.
newValue
Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T) Properties

PropertyChangedEventArgsT Properties

The PropertyChangedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T).NewValue Property

PropertyChangedEventArgsTNewValue Property

Gets the new value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T NewValue { get; }
Public ReadOnly Property NewValue As T
    Get

Property Value

Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T).OldValue Property

PropertyChangedEventArgsTOldValue Property

Gets the previous value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T OldValue { get; }
Public ReadOnly Property OldValue As T
    Get

Property Value

Type: T
The previous value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary Class

Provides a thread-safe dictionary of properties.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityPropertyDictionary

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyDictionary
Public Class PropertyDictionary

The PropertyDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDictionary | Initializes a new instance of the PropertyDictionary class
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the value of the property with the specified key. [C#] In C#, this property is the indexer for the PropertyDictionary class.
Public property | Keys | Gets the collection of property keys that have been registered in this dictionary.
Top
Methods
 | Name | Description
Public method | Add | Adds a property to the dictionary.
Public method | ContainsKey | Returns whether the dictionary contains a property with the specified key.
Public method | GetOrCreateSingletonTValue(PropertyDictionaryCreatorTValue) |
Public method | GetOrCreateSingletonTValue(Object, PropertyDictionaryCreatorTValue) |
Public method | Remove | Removes the property with the specified key from the dictionary.
Public method | TryGetValueTValue | Attempts to return the value of the property with the specified key.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


PropertyDictionary Constructor

Initializes a new instance of the PropertyDictionary class

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyDictionary()
Public Sub New
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary Properties

The PropertyDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the value of the property with the specified key. [C#] In C#, this property is the indexer for the PropertyDictionary class.
Public property | Keys | Gets the collection of property keys that have been registered in this dictionary.
Top
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Item Property

PropertyDictionaryItem Property

Gets or sets the value of the property with the specified key.

[C#] In C#, this property is the indexer for the PropertyDictionary class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object this[
    Object key
] { get; set; }
Public Default Property Item (
    key As Object
) As Object
    Get
    Set

Parameters

key
Type: SystemObject
The property key for which to search.

Property Value

Type: Object
The value of the property with the specified key.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Keys Property

PropertyDictionaryKeys Property

Gets the collection of property keys that have been registered in this dictionary.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyCollection<Object> Keys { get; }
Public ReadOnly Property Keys As ReadOnlyCollection(Of Object)
    Get

Property Value

Type: ReadOnlyCollection Object
The collection of property keys that have been registered in this dictionary.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary Methods

The PropertyDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a property to the dictionary.
Public method | ContainsKey | Returns whether the dictionary contains a property with the specified key.
Public method | GetOrCreateSingletonTValue(PropertyDictionaryCreatorTValue) |
Public method | GetOrCreateSingletonTValue(Object, PropertyDictionaryCreatorTValue) |
Public method | Remove | Removes the property with the specified key from the dictionary.
Public method | TryGetValueTValue | Attempts to return the value of the property with the specified key.
Top
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Add Method

PropertyDictionaryAdd Method

Adds a property to the dictionary.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Add(
    Object key,
    Object value
)
Public Sub Add (
    key As Object,
    value As Object
)

Parameters

key
Type: SystemObject
A key that identifies the property.
value
Type: SystemObject
The property value.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.ContainsKey Method

PropertyDictionaryContainsKey Method

Returns whether the dictionary contains a property with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ContainsKey(
    Object key
)
Public Function ContainsKey (
    key As Object
) As Boolean

Parameters

key
Type: SystemObject
The property key for which to search.

Return Value

Type: Boolean
true if the dictionary contains a property with the specified key; otherwise, false.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.GetOrCreateSingleton Method

PropertyDictionaryGetOrCreateSingleton Method

Overload List
 | Name | Description
Public method | GetOrCreateSingletonTValue(PropertyDictionaryCreatorTValue) |
Public method | GetOrCreateSingletonTValue(Object, PropertyDictionaryCreatorTValue) |
Top
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.GetOrCreateSingleton(TValue) Method (PropertyDictionary.Creator(TValue))

PropertyDictionaryGetOrCreateSingletonTValue Method (PropertyDictionaryCreatorTValue)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TValue GetOrCreateSingleton<TValue>(
    PropertyDictionaryCreator<TValue> creator
)

Public Function GetOrCreateSingleton(Of TValue) (
    creator As PropertyDictionaryCreator(Of TValue)
) As TValue

Parameters

creator
Type: ActiproSoftware.Text.UtilityPropertyDictionaryCreator TValue

[Missing <param name="creator"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Type Parameters

TValue

[Missing <typeparam name="TValue"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Return Value

Type: TValue

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

See Also

Reference

PropertyDictionary Class
GetOrCreateSingleton Overload
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.GetOrCreateSingleton(TValue) Method (Object, PropertyDictionary.Creator(TValue))

PropertyDictionaryGetOrCreateSingletonTValue Method (Object, PropertyDictionaryCreatorTValue)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TValue GetOrCreateSingleton<TValue>(
    Object key,
    PropertyDictionaryCreator<TValue> creator
)

Public Function GetOrCreateSingleton(Of TValue) (
    key As Object,
    creator As PropertyDictionaryCreator(Of TValue)
) As TValue

Parameters

key
Type: SystemObject

[Missing <param name="key"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

creator
Type: ActiproSoftware.Text.UtilityPropertyDictionaryCreator TValue

[Missing <param name="creator"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Type Parameters

TValue

[Missing <typeparam name="TValue"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Return Value

Type: TValue

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

See Also

Reference

PropertyDictionary Class
GetOrCreateSingleton Overload
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Remove Method

PropertyDictionaryRemove Method

Removes the property with the specified key from the dictionary.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Remove(
    Object key
)
Public Function Remove (
    key As Object
) As Boolean

Parameters

key
Type: SystemObject
The key of the property to remove.

Return Value

Type: Boolean
true if a property was removed; otherwise, false.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.TryGetValue(TValue) Method

PropertyDictionaryTryGetValueTValue Method

Attempts to return the value of the property with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool TryGetValue<TValue>(
    Object key,
    out TValue value
)

Public Function TryGetValue(Of TValue) (
    key As Object,
    <OutAttribute> ByRef value As TValue
) As Boolean

Parameters

key
Type: SystemObject
The property key for which to search.
value
Type: TValue
Returns the property value.

Type Parameters

TValue
The type of property value.

Return Value

Type: Boolean
true if a value was returned; otherwise, false.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Creator(TValue) Delegate

PropertyDictionaryCreatorTValue Delegate

Creates a property value.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public delegate TValue Creator<TValue>()

Public Delegate Function Creator(Of TValue) As TValue

Type Parameters

TValue
The type of object to create.

Return Value

Type: TValue
The property value that was created.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


Range Structure

Represents an ordered pair of min and max values.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public struct Range
Public Structure Range

The Range type exposes the following members.

Constructors
 | Name | Description
Public method | Range(Int32) | Initializes a new instance of the Range class with the specified min and max value.
Public method | Range(Int32, Int32) | Initializes a new instance of the Range class with the specified min and max values.
Top
Properties
 | Name | Description
 | Empty | Returns an empty Range.
Public property | IsEmpty | Returns whether the Range is empty.
Public property | IsNormalized | Gets whether the range is normalized (the maximum value is greater than or equal to the minimum).
Public property | Length | Gets the length of this Range.
Public property | Max | Gets or sets the maximum value of this Range.
Public property | Min | Gets or sets the minimum value of this Range.
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the range inclusively contains the specified value.
Public method | Contains(Range) | Returns whether the range inclusively contains the specified Range.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | IntersectsWith | Returns whether the range intersects with the specified Range.
Public method | Normalize | Normalizes the range values (ensures that the maximum value is greater than or equal to the minimum).
Public method | OverlapsWith | Returns whether the Range overlaps with, or crosses, the specified Range.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | Union | Changes this Range to be the union of this Range with another Range.
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


Range Constructor

Overload List
 | Name | Description
Public method | Range(Int32) | Initializes a new instance of the Range class with the specified min and max value.
Public method | Range(Int32, Int32) | Initializes a new instance of the Range class with the specified min and max values.
Top
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range Constructor (Int32)

Initializes a new instance of the Range class with the specified min and max value.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Range(
    int value
)
Public Sub New (
    value As Integer
)

Parameters

value
Type: SystemInt32
The value to use for both the min and max.
See Also

Reference

Range Structure
Range Overload
ActiproSoftware.Text.Utility Namespace


Range Constructor (Int32, Int32)

Initializes a new instance of the Range class with the specified min and max values.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Range(
    int min,
    int max
)
Public Sub New (
    min As Integer,
    max As Integer
)

Parameters

min
Type: SystemInt32
The minimum value of the range.
max
Type: SystemInt32
The maximum value of the range.
See Also

Reference

Range Structure
Range Overload
ActiproSoftware.Text.Utility Namespace


Range Properties

The Range type exposes the following members.

Properties
 | Name | Description
 | Empty | Returns an empty Range.
Public property | IsEmpty | Returns whether the Range is empty.
Public property | IsNormalized | Gets whether the range is normalized (the maximum value is greater than or equal to the minimum).
Public property | Length | Gets the length of this Range.
Public property | Max | Gets or sets the maximum value of this Range.
Public property | Min | Gets or sets the minimum value of this Range.
Top
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Empty Property

RangeEmpty Property

Returns an empty Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Range Empty { get; }
Public Shared ReadOnly Property Empty As Range
    Get

Property Value

Type: Range
A Range that is empty.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.IsEmpty Property

RangeIsEmpty Property

Returns whether the Range is empty.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the Range is empty; otherwise, false.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.IsNormalized Property

RangeIsNormalized Property

Gets whether the range is normalized (the maximum value is greater than or equal to the minimum).

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNormalized { get; }
Public ReadOnly Property IsNormalized As Boolean
    Get

Property Value

Type: Boolean
true if the range is normalized; otherwise, false.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Length Property

RangeLength Property

Gets the length of this Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The length of this Range.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Max Property

RangeMax Property

Gets or sets the maximum value of this Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Max { get; set; }
Public Property Max As Integer
    Get
    Set

Property Value

Type: Int32
The maximum value of this Range.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Min Property

RangeMin Property

Gets or sets the minimum value of this Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Min { get; set; }
Public Property Min As Integer
    Get
    Set

Property Value

Type: Int32
The minimum value of this Range.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range Methods

The Range type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the range inclusively contains the specified value.
Public method | Contains(Range) | Returns whether the range inclusively contains the specified Range.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | IntersectsWith | Returns whether the range intersects with the specified Range.
Public method | Normalize | Normalizes the range values (ensures that the maximum value is greater than or equal to the minimum).
Public method | OverlapsWith | Returns whether the Range overlaps with, or crosses, the specified Range.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | Union | Changes this Range to be the union of this Range with another Range.
Top
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Contains Method

RangeContains Method

Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the range inclusively contains the specified value.
Public method | Contains(Range) | Returns whether the range inclusively contains the specified Range.
Top
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Contains Method (Int32)

RangeContains Method (Int32)

Returns whether the range inclusively contains the specified value.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    int value
)
Public Function Contains (
    value As Integer
) As Boolean

Parameters

value
Type: SystemInt32
The value to check.

Return Value

Type: Boolean
true if the range inclusively contains the specified value; otherwise, false.
See Also

Reference

Range Structure
Contains Overload
ActiproSoftware.Text.Utility Namespace


Range.Contains Method (Range)

RangeContains Method (Range)

Returns whether the range inclusively contains the specified Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    Range range
)
Public Function Contains (
    range As Range
) As Boolean

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to check.

Return Value

Type: Boolean
true if the range inclusively contains the specified Range; otherwise, false.
See Also

Reference

Range Structure
Contains Overload
ActiproSoftware.Text.Utility Namespace


Range.Equals Method

RangeEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.GetHashCode Method

RangeGetHashCode Method

Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.IntersectsWith Method

RangeIntersectsWith Method

Returns whether the range intersects with the specified Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    Range range
)
Public Function IntersectsWith (
    range As Range
) As Boolean

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to check.

Return Value

Type: Boolean
true if the range intersects with the specified Range; otherwise, false.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Normalize Method

RangeNormalize Method

Normalizes the range values (ensures that the maximum value is greater than or equal to the minimum).

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Normalize()
Public Sub Normalize
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.OverlapsWith Method

RangeOverlapsWith Method

Returns whether the Range overlaps with, or crosses, the specified Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    Range range
)
Public Function OverlapsWith (
    range As Range
) As Boolean

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to examine.

Return Value

Type: Boolean
true if the Range overlaps with, or crosses, the specified Range; otherwise, false.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.ToString Method

RangeToString Method

Converts the object to a String.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Union Method

RangeUnion Method

Changes this Range to be the union of this Range with another Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Union(
    Range range
)
Public Sub Union (
    range As Range
)

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range with which to merge.
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range Operators

The Range type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Equality Operator

RangeEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Equality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator ==(
    Range left,
    Range right
)
Public Shared Operator = (
    left As Range,
    right As Range
) As Boolean

Parameters

left
Type: ActiproSoftware.Text.UtilityRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Equality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

right
Type: ActiproSoftware.Text.UtilityRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Equality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Equality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


Range.Inequality Operator

RangeInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Inequality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator !=(
    Range left,
    Range right
)
Public Shared Operator <> (
    left As Range,
    right As Range
) As Boolean

Parameters

left
Type: ActiproSoftware.Text.UtilityRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Inequality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

right
Type: ActiproSoftware.Text.UtilityRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Inequality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Inequality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

See Also

Reference

Range Structure
ActiproSoftware.Text.Utility Namespace


RangeCollection Class

Provides an implementation of a collection of Range objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityRangeCollection

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RangeCollection : IEnumerable,
    IEnumerable<Range>
Public Class RangeCollection
    Implements IEnumerable, IEnumerable(Of Range)

The RangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | RangeCollection | Initializes a new instance of the RangeCollection class.
Public method | RangeCollection(String) | Initializes a new instance of the RangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the interval at the specified index. [C#] In C#, this property is the indexer for the RangeCollection class.
Public property | Key | Gets a unique string key that identifies the collection instance.
Top
Methods
 | Name | Description
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | Clear | Removes all elements in this collection.
Public method | Contains | Returns whether the specified value is in the contained ranges.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | IndexOf | Returns the index of the range that contains the specified value.
Public method | Merge | Merges the specified Range into the collection.
Public method | OverlapsWith | Returns whether the specified Range overlaps with a Range in the list.
Public method | Unmerge | Removes any range portions that cross the specified Range.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


RangeCollection Constructor

Overload List
 | Name | Description
Public method | RangeCollection | Initializes a new instance of the RangeCollection class.
Public method | RangeCollection(String) | Initializes a new instance of the RangeCollection class.
Top
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection Constructor

Initializes a new instance of the RangeCollection class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeCollection()
Public Sub New
See Also

Reference

RangeCollection Class
RangeCollection Overload
ActiproSoftware.Text.Utility Namespace


RangeCollection Constructor (String)

Initializes a new instance of the RangeCollection class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RangeCollection(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
A unique string key that identifies the collection instance.
See Also

Reference

RangeCollection Class
RangeCollection Overload
ActiproSoftware.Text.Utility Namespace


RangeCollection Properties

The RangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the interval at the specified index. [C#] In C#, this property is the indexer for the RangeCollection class.
Public property | Key | Gets a unique string key that identifies the collection instance.
Top
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Count Property

RangeCollectionCount Property

Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Item Property

RangeCollectionItem Property

Gets the interval at the specified index.

[C#] In C#, this property is the indexer for the RangeCollection class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Range this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Range
    Get

Parameters

index
Type: SystemInt32
The index of the interval to return.

Property Value

Type: Range
The Range at the specified index.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Key Property

RangeCollectionKey Property

Gets a unique string key that identifies the collection instance.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
A unique string key that identifies the collection instance.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection Methods

The RangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | Clear | Removes all elements in this collection.
Public method | Contains | Returns whether the specified value is in the contained ranges.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | IndexOf | Returns the index of the range that contains the specified value.
Public method | Merge | Merges the specified Range into the collection.
Public method | OverlapsWith | Returns whether the specified Range overlaps with a Range in the list.
Public method | Unmerge | Removes any range portions that cross the specified Range.
Top
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.BinarySearch Method

RangeCollectionBinarySearch Method

Performs a binary search for the specified value.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int BinarySearch(
    int value
)
Public Function BinarySearch (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
The value for which to search.

Return Value

Type: Int32
The index of the specified value in the specified array, if value is found. If value is not found and value is less than one or more elements in array, a negative number which is the bitwise complement of the index of the first element that is larger than value. If value is not found and value is greater than any of the elements in array, a negative number which is the bitwise complement of (the index of the last element plus 1).
Remarks
This method should only be used if the integers in the list are guaranteed to be sorted.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Clear Method

RangeCollectionClear Method

Removes all elements in this collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Contains Method

RangeCollectionContains Method

Returns whether the specified value is in the contained ranges.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    int value
)
Public Function Contains (
    value As Integer
) As Boolean

Parameters

value
Type: SystemInt32
The values for which to search.

Return Value

Type: Boolean
true if the specified value is in the contained ranges; otherwise, false.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.CopyTo Method

RangeCollectionCopyTo Method

Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyTo(
    Range[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Range(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.UtilityRange
The one-dimensional Range array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.GetEnumerator Method

RangeCollectionGetEnumerator Method

Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<Range> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Range)

Return Value

Type: IEnumerator Range
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.IndexOf Method

RangeCollectionIndexOf Method

Returns the index of the range that contains the specified value.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    int value
)
Public Function IndexOf (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
The values for which to search.

Return Value

Type: Int32
The index of the range that contains the specified value, or -1 if not found.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Merge Method

RangeCollectionMerge Method

Merges the specified Range into the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Range[] Merge(
    Range range
)
Public Function Merge (
    range As Range
) As Range()

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to merge.

Return Value

Type: Range
The array of Range objects in which a merge was made.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.OverlapsWith Method

RangeCollectionOverlapsWith Method

Returns whether the specified Range overlaps with a Range in the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    Range range
)
Public Function OverlapsWith (
    range As Range
) As Boolean

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to examine.

Return Value

Type: Boolean
true if the specified Range overlaps with a Range in the list; otherwise, false.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Unmerge Method

RangeCollectionUnmerge Method

Removes any range portions that cross the specified Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Range[] Unmerge(
    Range range
)
Public Function Unmerge (
    range As Range
) As Range()

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to remove.

Return Value

Type: Range
The array of Range objects in which a merge was made.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Class

SimpleObservableCollectionT Class

Provides a generic collection that provides notifications when items are added or removed.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
ActiproSoftware.Text.UtilitySimpleObservableCollectionT
ActiproSoftware.Text.Analysis.ImplementationStructureMatchResultCollection
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeCollection
ActiproSoftware.Text.Searching.ImplementationSearchPatternProviderCollection
ActiproSoftware.Text.UtilityKeyedObservableCollectionT
ActiproSoftware.Text.UtilitySimpleSynchronizedCollectionT

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SimpleObservableCollection<T> : Collection<T>
where T : class

Public Class SimpleObservableCollection(Of T As Class)
    Inherits Collection(Of T)

Type Parameters

T
The type of collection item.

The SimpleObservableCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleObservableCollectionT | Initializes a new instance of the SimpleObservableCollectionT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection.
Protected method | CheckReadOnly | Throws an exception if the collection is read-only.
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection.
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Overrides CollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | OnItemAdded | Called after an item as been added into the collection.
Protected method | OnItemAdding | Called before an item as been added into the collection.
Protected method | OnItemRemoved | Called after an item has been removed from the collection.
Protected method | OnItemRemoving | Called before an item has been removed from the collection.
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection.
Public event | ItemAdding | Occurs before an item is added to the collection.
Public event | ItemRemoved | Occurs after an item is removed from the collection.
Public event | ItemRemoving | Occurs before an item is removed from the collection.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Constructor

SimpleObservableCollectionT Constructor

Initializes a new instance of the SimpleObservableCollectionT class

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleObservableCollection()
Public Sub New
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Properties

SimpleObservableCollectionT Properties

The SimpleObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Top
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).IsReadOnly Property

SimpleObservableCollectionTIsReadOnly Property

Gets whether the collection is allowed to be modified.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the collection is allowed to be modified; otherwise, false.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Methods

SimpleObservableCollectionT Methods

The SimpleObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection.
Protected method | CheckReadOnly | Throws an exception if the collection is read-only.
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection.
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Overrides CollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | OnItemAdded | Called after an item as been added into the collection.
Protected method | OnItemAdding | Called before an item as been added into the collection.
Protected method | OnItemRemoved | Called after an item has been removed from the collection.
Protected method | OnItemRemoving | Called before an item has been removed from the collection.
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Top
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).BlockReentrancy Method

SimpleObservableCollectionTBlockReentrancy Method

Disallows reentrant attempts to change this collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IDisposable BlockReentrancy()
Protected Function BlockReentrancy As IDisposable

Return Value

Type: IDisposable
An IDisposable object that can be used to dispose of the object.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).CheckReadOnly Method

SimpleObservableCollectionTCheckReadOnly Method

Throws an exception if the collection is read-only.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void CheckReadOnly()
Protected Overridable Sub CheckReadOnly
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).CheckReentrancy Method

SimpleObservableCollectionTCheckReentrancy Method

Checks for reentrant attempts to change this collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void CheckReentrancy()
Protected Sub CheckReentrancy
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ClearItems Method

SimpleObservableCollectionTClearItems Method

Removes all items from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).InsertItem Method

SimpleObservableCollectionTInsertItem Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index at which to insert the item.
item
Type: T
The item to insert.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).OnItemAdded Method

SimpleObservableCollectionTOnItemAdded Method

Called after an item as been added into the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemAdded(
    int index,
    T value
)
Protected Overridable Sub OnItemAdded (
    index As Integer,
    value As T
)

Parameters

index
Type: SystemInt32
The index at which the item is added.
value
Type: T
The item that is added.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).OnItemAdding Method

SimpleObservableCollectionTOnItemAdding Method

Called before an item as been added into the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemAdding(
    int index,
    T value
)
Protected Overridable Sub OnItemAdding (
    index As Integer,
    value As T
)

Parameters

index
Type: SystemInt32
The index at which the item is added.
value
Type: T
The item that is added.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).OnItemRemoved Method

SimpleObservableCollectionTOnItemRemoved Method

Called after an item has been removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemRemoved(
    int index,
    T value
)
Protected Overridable Sub OnItemRemoved (
    index As Integer,
    value As T
)

Parameters

index
Type: SystemInt32
The index at which the item is removed.
value
Type: T
The item that is removed.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).OnItemRemoving Method

SimpleObservableCollectionTOnItemRemoving Method

Called before an item has been removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemRemoving(
    int index,
    T value
)
Protected Overridable Sub OnItemRemoving (
    index As Integer,
    value As T
)

Parameters

index
Type: SystemInt32
The index at which the item is removed.
value
Type: T
The item that is removed.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).RemoveItem Method

SimpleObservableCollectionTRemoveItem Method

Removes the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the item to remove.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).SetItem Method

SimpleObservableCollectionTSetItem Method

Replaces the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index of the item to replace.
item
Type: T
The item with which to replace.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Events

SimpleObservableCollectionT Events

The SimpleObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection.
Public event | ItemAdding | Occurs before an item is added to the collection.
Public event | ItemRemoved | Occurs after an item is removed from the collection.
Public event | ItemRemoving | Occurs before an item is removed from the collection.
Top
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ItemAdded Event

SimpleObservableCollectionTItemAdded Event

Occurs after an item is added to the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<T>> ItemAdded
Public Event ItemAdded As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ItemAdding Event

SimpleObservableCollectionTItemAdding Event

Occurs before an item is added to the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<T>> ItemAdding
Public Event ItemAdding As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ItemRemoved Event

SimpleObservableCollectionTItemRemoved Event

Occurs after an item is removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<T>> ItemRemoved
Public Event ItemRemoved As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ItemRemoving Event

SimpleObservableCollectionTItemRemoving Event

Occurs before an item is removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<T>> ItemRemoving
Public Event ItemRemoving As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Class

SimpleSynchronizedCollectionT Class

Provides a thread-safe generic collection that provides notifications when items are added or removed.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
ActiproSoftware.Text.UtilitySimpleObservableCollection T
ActiproSoftware.Text.UtilitySimpleSynchronizedCollectionT

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SimpleSynchronizedCollection<T> : SimpleObservableCollection<T>
where T : class

Public Class SimpleSynchronizedCollection(Of T As Class)
    Inherits SimpleObservableCollection(Of T)

Type Parameters

T
The type of collection item.

The SimpleSynchronizedCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleSynchronizedCollectionT | Initializes a new instance of the SimpleSynchronizedCollectionT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Overrides SimpleObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides SimpleObservableCollectionTInsertItem(Int32, T).)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides SimpleObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides SimpleObservableCollectionTSetItem(Int32, T).)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Constructor

SimpleSynchronizedCollectionT Constructor

Initializes a new instance of the SimpleSynchronizedCollectionT class

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleSynchronizedCollection()
Public Sub New
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Properties

SimpleSynchronizedCollectionT Properties

The SimpleSynchronizedCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Top
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Methods

SimpleSynchronizedCollectionT Methods

The SimpleSynchronizedCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Overrides SimpleObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides SimpleObservableCollectionTInsertItem(Int32, T).)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides SimpleObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides SimpleObservableCollectionTSetItem(Int32, T).)
Top
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T).ClearItems Method

SimpleSynchronizedCollectionTClearItems Method

Removes all items from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T).InsertItem Method

SimpleSynchronizedCollectionTInsertItem Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index at which to insert the item.
item
Type: T
The item to insert.
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T).RemoveItem Method

SimpleSynchronizedCollectionTRemoveItem Method

Removes the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the item to remove.
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T).SetItem Method

SimpleSynchronizedCollectionTSetItem Method

Replaces the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index of the item to replace.
item
Type: T
The item with which to replace.
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Events

SimpleSynchronizedCollectionT Events

The SimpleSynchronizedCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


StringHelper Class

Provides numerous utility methods for working with strings.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityStringHelper

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class StringHelper
Public NotInheritable Class StringHelper

The StringHelper type exposes the following members.

Methods
Name | Description
ContainsRtlCharacters | Returns whether the specified text string contains any right-to-left characters.
ConvertTextToLines | Converts the text to an array of lines.
CreateDescription | Returns a description from a key.
GetIndentAmount | Returns the indent amount of the specified text.
GetIndentText | Returns the string to use for indenting by the specified amount.
GetLineTerminatorText | Returns the text representation of the specified LineTerminator.
GetTextPositionDelta | Returns the TextPosition delta of the specified inserted text.
IsRtlCharacter | Returns whether the specified character is a right-to-left character.
TrimTrailingWhitespace | Trims the trailing whitespace off of the specified text.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


StringHelper Methods

The StringHelper type exposes the following members.

Methods
Name | Description
ContainsRtlCharacters | Returns whether the specified text string contains any right-to-left characters.
ConvertTextToLines | Converts the text to an array of lines.
CreateDescription | Returns a description from a key.
GetIndentAmount | Returns the indent amount of the specified text.
GetIndentText | Returns the string to use for indenting by the specified amount.
GetLineTerminatorText | Returns the text representation of the specified LineTerminator.
GetTextPositionDelta | Returns the TextPosition delta of the specified inserted text.
IsRtlCharacter | Returns whether the specified character is a right-to-left character.
TrimTrailingWhitespace | Trims the trailing whitespace off of the specified text.
Top
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.ContainsRtlCharacters Method

StringHelperContainsRtlCharacters Method

Returns whether the specified text string contains any right-to-left characters.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool ContainsRtlCharacters(
    string text
)
Public Shared Function ContainsRtlCharacters (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The string to examine.

Return Value

Type: Boolean
true if the string contains any right-to-left characters; otherwise, false.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.ConvertTextToLines Method

StringHelperConvertTextToLines Method

Converts the text to an array of lines.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IList<string> ConvertTextToLines(
    string text
)
Public Shared Function ConvertTextToLines (
    text As String
) As IList(Of String)

Parameters

text
Type: SystemString
The text to examine.

Return Value

Type: IList String
The array of lines.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.CreateDescription Method

StringHelperCreateDescription Method

Returns a description from a key.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string CreateDescription(
    string key
)
Public Shared Function CreateDescription (
    key As String
) As String

Parameters

key
Type: SystemString
The key to examine.

Return Value

Type: String
The description that was created.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.GetIndentAmount Method

StringHelperGetIndentAmount Method

Returns the indent amount of the specified text.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static int GetIndentAmount(
    string text,
    int tabSize
)
Public Shared Function GetIndentAmount (
    text As String,
    tabSize As Integer
) As Integer

Parameters

text
Type: SystemString
The text to examine.
tabSize
Type: SystemInt32
The tab size.

Return Value

Type: Int32
The indent amount of the specified text.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.GetIndentText Method

StringHelperGetIndentText Method

Returns the string to use for indenting by the specified amount.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string GetIndentText(
    bool convertTabsToSpaces,
    int tabSize,
    int indentAmount
)
Public Shared Function GetIndentText (
    convertTabsToSpaces As Boolean,
    tabSize As Integer,
    indentAmount As Integer
) As String

Parameters

convertTabsToSpaces
Type: SystemBoolean
Whether to convert tabs to spaces.
tabSize
Type: SystemInt32
The number of columns in a tab.
indentAmount
Type: SystemInt32
The number of columns to indent.

Return Value

Type: String
The string to use for indenting by the specified amount.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.GetLineTerminatorText Method

StringHelperGetLineTerminatorText Method

Returns the text representation of the specified LineTerminator.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string GetLineTerminatorText(
    LineTerminator lineTerminator
)
Public Shared Function GetLineTerminatorText (
    lineTerminator As LineTerminator
) As String

Parameters

lineTerminator
Type: ActiproSoftware.TextLineTerminator
The LineTerminator to examine.

Return Value

Type: String
The text representation of the specified LineTerminator.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.GetTextPositionDelta Method

StringHelperGetTextPositionDelta Method

Returns the TextPosition delta of the specified inserted text.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static TextPosition GetTextPositionDelta(
    string text
)
Public Shared Function GetTextPositionDelta (
    text As String
) As TextPosition

Parameters

text
Type: SystemString
The text to examine.

Return Value

Type: TextPosition
The TextPosition delta of the specified inserted text.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.IsRtlCharacter Method

StringHelperIsRtlCharacter Method

Returns whether the specified character is a right-to-left character.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsRtlCharacter(
    char ch
)
Public Shared Function IsRtlCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is a right-to-left character; otherwise, false.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.TrimTrailingWhitespace Method

StringHelperTrimTrailingWhitespace Method

Trims the trailing whitespace off of the specified text.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool TrimTrailingWhitespace(
    ref string text
)
Public Shared Function TrimTrailingWhitespace (
    ByRef text As String
) As Boolean

Parameters

text
Type: SystemString
The text to modify.

Return Value

Type: Boolean
true if a change was made; otherwise, false.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringPropertyChangedEventArgs Class

Provides event arguments for a property change event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UtilityPropertyChangedEventArgs String
ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StringPropertyChangedEventArgs : PropertyChangedEventArgs<string>
Public Class StringPropertyChangedEventArgs
    Inherits PropertyChangedEventArgs(Of String)

The StringPropertyChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StringPropertyChangedEventArgs | Initializes a new instance of the StringPropertyChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


StringPropertyChangedEventArgs Constructor

Initializes a new instance of the StringPropertyChangedEventArgs class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StringPropertyChangedEventArgs(
    string oldValue,
    string newValue
)
Public Sub New (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemString
The new value of the property being tracked as reported by an event.
See Also

Reference

StringPropertyChangedEventArgs Class
ActiproSoftware.Text.Utility Namespace


StringPropertyChangedEventArgs Properties

The StringPropertyChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
See Also

Reference

StringPropertyChangedEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Class

WeakEventListenerTInstance, TEventArgs Class

Provides a listener that allows for "weak" listening to events.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityWeakEventListenerTInstance, TEventArgs

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WeakEventListener<TInstance, TEventArgs>
where TInstance : class
where TEventArgs : EventArgs

Public Class WeakEventListener(Of TInstance As Class, TEventArgs As EventArgs)

Type Parameters

TInstance
The instance type that owns the listener.
TEventArgs
The event arguments type.

The WeakEventListenerTInstance, TEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WeakEventListenerTInstance, TEventArgs(TInstance) | Initializes a new instance of the WeakEventListener class.
Public method | WeakEventListenerTInstance, TEventArgs(TInstance, WeakEventListenerTInstance, TEventArgsEventActionTInstance, Object, TEventArgs, ActionWeakEventListenerTInstance, TEventArgs) | Initializes a new instance of the WeakEventListenerTInstance, TEventArgs class
Top
Properties
 | Name | Description
Public property | OnDetachAction | Gets or sets the delegate to execute when the event is detached.
Public property | OnEventAction | Gets or sets the delegate to execute when the event is raised.
Top
Methods
 | Name | Description
Public method | Detach | Detaches the event listener from the event.
Public method | OnEvent | The method that handles the event.
Top
Remarks
Make sure that only variables (i.e. not fields) for the event source are used when adding/removing event ties; otherwise this will not result in a "weak" listener. The instance type should also be disposable and should detach the event listener in the finalizer or a memory leak of WeakEventListener objects may occur.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Constructor

WeakEventListenerTInstance, TEventArgs Constructor

Overload List
 | Name | Description
Public method | WeakEventListenerTInstance, TEventArgs(TInstance) | Initializes a new instance of the WeakEventListener class.
Public method | WeakEventListenerTInstance, TEventArgs(TInstance, WeakEventListenerTInstance, TEventArgsEventActionTInstance, Object, TEventArgs, ActionWeakEventListenerTInstance, TEventArgs) | Initializes a new instance of the WeakEventListenerTInstance, TEventArgs class
Top
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Constructor (TInstance)

WeakEventListenerTInstance, TEventArgs Constructor (TInstance)

Initializes a new instance of the WeakEventListener class.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WeakEventListener(
    TInstance instance
)
Public Sub New (
    instance As TInstance
)

Parameters

instance
Type: TInstance
The instance that owns the listener.
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
WeakEventListenerTInstance, TEventArgs Overload
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Constructor (TInstance, WeakEventListener(TInstance, TEventArgs).EventAction(TInstance, Object, TEventArgs), Action(WeakEventListener(TInstance, TEventArgs)))

WeakEventListenerTInstance, TEventArgs Constructor (TInstance, WeakEventListenerTInstance, TEventArgsEventActionTInstance, Object, TEventArgs, ActionWeakEventListenerTInstance, TEventArgs)

Initializes a new instance of the WeakEventListenerTInstance, TEventArgs class

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WeakEventListener(
    TInstance instance,
    WeakEventListenerTInstance, TEventArgsEventAction<TInstance, Object, TEventArgs> onEventAction,
    Action<WeakEventListener<TInstance, TEventArgs>> onDetachAction
)
Public Sub New (
    instance As TInstance,
    onEventAction As WeakEventListenerTInstance, TEventArgsEventAction(Of TInstance, Object, TEventArgs),
    onDetachAction As Action(Of WeakEventListener(Of TInstance, TEventArgs))
)

Parameters

instance
Type: TInstance

[Missing <param name="instance"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.#ctor(`0,ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}.EventAction{`0,System.Object,`1},System.Action{ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}})"]

onEventAction
Type: ActiproSoftware.Text.UtilityWeakEventListenerTInstance, TEventArgsEventAction TInstance, Object, TEventArgs

[Missing <param name="onEventAction"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.#ctor(`0,ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}.EventAction{`0,System.Object,`1},System.Action{ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}})"]

onDetachAction
Type: SystemAction WeakEventListener TInstance, TEventArgs

[Missing <param name="onDetachAction"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.#ctor(`0,ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}.EventAction{`0,System.Object,`1},System.Action{ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}})"]

See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
WeakEventListenerTInstance, TEventArgs Overload
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Properties

WeakEventListenerTInstance, TEventArgs Properties

The WeakEventListenerTInstance, TEventArgs generic type exposes the following members.

Properties
 | Name | Description
Public property | OnDetachAction | Gets or sets the delegate to execute when the event is detached.
Public property | OnEventAction | Gets or sets the delegate to execute when the event is raised.
Top
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).OnDetachAction Property

WeakEventListenerTInstance, TEventArgsOnDetachAction Property

Gets or sets the delegate to execute when the event is detached.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Action<WeakEventListener<TInstance, TEventArgs>> OnDetachAction { get; set; }
Public Property OnDetachAction As Action(Of WeakEventListener(Of TInstance, TEventArgs))
    Get
    Set

Property Value

Type: Action WeakEventListener TInstance, TEventArgs
The delegate to execute when the event is detached.
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).OnEventAction Property

WeakEventListenerTInstance, TEventArgsOnEventAction Property

Gets or sets the delegate to execute when the event is raised.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WeakEventListenerTInstance, TEventArgsEventAction<TInstance, Object, TEventArgs> OnEventAction { get; set; }
Public Property OnEventAction As WeakEventListenerTInstance, TEventArgsEventAction(Of TInstance, Object, TEventArgs)
    Get
    Set

Property Value

Type: WeakEventListenerTInstance, TEventArgsEventAction TInstance, Object, TEventArgs
The delegate to execute when the event is raised.
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Methods

WeakEventListenerTInstance, TEventArgs Methods

The WeakEventListenerTInstance, TEventArgs generic type exposes the following members.

Methods
 | Name | Description
Public method | Detach | Detaches the event listener from the event.
Public method | OnEvent | The method that handles the event.
Top
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).Detach Method

WeakEventListenerTInstance, TEventArgsDetach Method

Detaches the event listener from the event.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Detach()
Public Sub Detach
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).OnEvent Method

WeakEventListenerTInstance, TEventArgsOnEvent Method

The method that handles the event.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void OnEvent(
    Object source,
    TEventArgs eventArgs
)
Public Sub OnEvent (
    source As Object,
    eventArgs As TEventArgs
)

Parameters

source
Type: SystemObject
The source of the event.
eventArgs
Type: TEventArgs
The event arguments.
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).EventAction(T1, T2, T3) Delegate

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 Delegate

Provides the delegate for an event action.

Namespace: ActiproSoftware.Text.Utility
Assembly: ActiproSoftware.Text.Wpf (in ActiproSoftware.Text.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public delegate void EventAction<T1, T2, T3>(
    T1 arg1,
    T2 arg2,
    T3 arg3
)

Public Delegate Sub EventAction(Of T1, T2, T3) (
    arg1 As T1,
    arg2 As T2,
    arg3 As T3
)

Parameters

arg1
Type: T1
The first argument.
arg2
Type: T2
The second argument.
arg3
Type: T3
The third argument.

Type Parameters

T1
The first parameter type.
T2
The second parameter type.
T3
The third parameter type.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


ActiproSoftware.Windows Namespace

Contains some core classes used throughout various products.
Classes
 | Class | Description
Public class | BooleanPropertyChangedRoutedEventArgs | Provides event arguments for a Boolean property change routed event, indicating the old and new values.
Public class | CancelRoutedEventArgs | Provides event arguments for a cancelable routed event.
Public class | DateRangeCollection | Represents a collection of DateRange objects.
Public class | DateTimePropertyChangedRoutedEventArgs | Provides event arguments for a DateTime property change routed event, indicating the old and new values.
Public class | DeferrableObservableCollectionT | Provides an ObservableCollectionT that is capable of suspending its property change notifications until a bulk update is complete.
Public class | DependencyObjectItemRoutedEventArgs | Provides event arguments for a DependencyObject-related routed event.
Public class | DisposableObjectBase | Provides a base class that implements the IDisposable interface. This class functions in accordance with the Disposable design pattern.
Public class | DoublePropertyChangedRoutedEventArgs | Provides event arguments for a Double property change routed event, indicating the old and new values.
Public class | DoublePropertyChangingRoutedEventArgs | Provides event arguments for a cancelable Double property change routed event, indicating the old and new values.
Public class | EnumerableViewT | Represents a read-only view on top of an IEnumerableT with support for filtering, sorting, and change notifications.
Public class | IEnumerablePropertyChangedRoutedEventArgs | Provides event arguments for an IEnumerable property change routed event, indicating the old and new values.
Public class | ItemRoutedEventArgsT | Provides event arguments for an item-related routed event.
Public class | LogicalChildrenCollectionT | Provides a DeferrableObservableCollectionT that is capable of adding/removing the logical parent, and optionally the visual parent, of the items in the collection.
Public class | LogicalTreeHelperExtended | Contains static methods that are useful for performing common tasks with nodes in a logical tree.
Public class | NullableDateTimePropertyChangedRoutedEventArgs | Provides event arguments for a nullable DateTime property change routed event, indicating the old and new values.
Public class | ObjectItemRoutedEventArgs | Provides event arguments for a Object-related routed event.
Public class | ObjectPropertyChangedRoutedEventArgs | Provides event arguments for an Object property change routed event, indicating the old and new values.
Public class | ObservableObjectBase | A simple object that implements INotifyPropertyChanged.
Public class | PropertyChangedRoutedEventArgsT | Provides event arguments for a property change routed event, indicating the old and new values.
Public class | PropertyChangingRoutedEventArgsT | Provides event arguments for a cancelable property change routed event, indicating the old and new values.
Public class | ResourceHelper | Represents a collection of helper methods when working with resources.
Public class | SecureStringPropertyChangedRoutedEventArgs | Provides event arguments for a SecureString property change routed event, indicating the old and new values.
Public class | SecureStringPropertyChangingRoutedEventArgs | Provides event arguments for a cancelable SecureString property change routed event, indicating the old and new values.
Public class | SecurityHelper | Contains security helper methods.
Public class | StringPropertyChangedRoutedEventArgs | Provides event arguments for a String property change routed event, indicating the old and new values.
Public class | StringPropertyChangingRoutedEventArgs | Provides event arguments for a cancelable String property change routed event, indicating the old and new values.
Public class | UnitConverter | Converts from a Unit object to an object of another data type and from another type to a Unit object.
Structures
 | Structure | Description
Public structure | DateRange | Represents a date range, which is an inclusive pair of DateTime objects representing dates.
Public structure | Unit | Represents a length measurement.
Interfaces
 | Interface | Description
Public interface | ILogicalParent | Provides the base requirements for an element that can add and remove logical child elements.
Enumerations
 | Enumeration | Description
Public enumeration | DateTimeFormatPattern | Specifies various format patterns for a DateTime value.
Public enumeration | DayOfWeekFormatPattern | Specifies various format patterns for a DayOfWeek value.
Public enumeration | UnitType | Specifies the unit of measurement.


BooleanPropertyChangedRoutedEventArgs Class

Provides event arguments for a Boolean property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs Boolean
ActiproSoftware.WindowsBooleanPropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BooleanPropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<bool>
Public Class BooleanPropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of Boolean)

The BooleanPropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanPropertyChangedRoutedEventArgs(Boolean, Boolean) | Initializes a new instance of the BooleanPropertyChangedRoutedEventArgs class.
Public method | BooleanPropertyChangedRoutedEventArgs(RoutedEvent, Boolean, Boolean) | Initializes a new instance of the BooleanPropertyChangedRoutedEventArgs class.
Public method | BooleanPropertyChangedRoutedEventArgs(RoutedEvent, Boolean, Boolean, Object) | Initializes a new instance of the BooleanPropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


BooleanPropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | BooleanPropertyChangedRoutedEventArgs(Boolean, Boolean) | Initializes a new instance of the BooleanPropertyChangedRoutedEventArgs class.
Public method | BooleanPropertyChangedRoutedEventArgs(RoutedEvent, Boolean, Boolean) | Initializes a new instance of the BooleanPropertyChangedRoutedEventArgs class.
Public method | BooleanPropertyChangedRoutedEventArgs(RoutedEvent, Boolean, Boolean, Object) | Initializes a new instance of the BooleanPropertyChangedRoutedEventArgs class.
Top
See Also

Reference

BooleanPropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


BooleanPropertyChangedRoutedEventArgs Constructor (Boolean, Boolean)

Initializes a new instance of the BooleanPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BooleanPropertyChangedRoutedEventArgs(
    bool oldValue,
    bool newValue
)
Public Sub New (
    oldValue As Boolean,
    newValue As Boolean
)

Parameters

oldValue
Type: SystemBoolean
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemBoolean
The new value of the property being tracked as reported by an event.
See Also

Reference

BooleanPropertyChangedRoutedEventArgs Class
BooleanPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


BooleanPropertyChangedRoutedEventArgs Constructor (RoutedEvent, Boolean, Boolean)

Initializes a new instance of the BooleanPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BooleanPropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    bool oldValue,
    bool newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As Boolean,
    newValue As Boolean
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemBoolean
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemBoolean
The new value of the property being tracked as reported by an event.
See Also

Reference

BooleanPropertyChangedRoutedEventArgs Class
BooleanPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


BooleanPropertyChangedRoutedEventArgs Constructor (RoutedEvent, Boolean, Boolean, Object)

Initializes a new instance of the BooleanPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BooleanPropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    bool oldValue,
    bool newValue,
    Object source
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As Boolean,
    newValue As Boolean,
    source As Object
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemBoolean
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemBoolean
The new value of the property being tracked as reported by an event.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

BooleanPropertyChangedRoutedEventArgs Class
BooleanPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


BooleanPropertyChangedRoutedEventArgs Properties

The BooleanPropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

BooleanPropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


CancelRoutedEventArgs Class

Provides event arguments for a cancelable routed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
More...

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CancelRoutedEventArgs : RoutedEventArgs
Public Class CancelRoutedEventArgs
    Inherits RoutedEventArgs

The CancelRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CancelRoutedEventArgs | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to false.
Public method | CancelRoutedEventArgs(Boolean) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to the given value.
Public method | CancelRoutedEventArgs(RoutedEvent) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to false.
Public method | CancelRoutedEventArgs(Boolean, RoutedEvent) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to the given value.
Public method | CancelRoutedEventArgs(RoutedEvent, Object) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to false.
Public method | CancelRoutedEventArgs(Boolean, RoutedEvent, Object) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to the given value.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled.
Top
See Also

Reference

ActiproSoftware.Windows Namespace
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.DockingAdvancedTabItemEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
ActiproSoftware.Windows.Controls.GridsPropertyModelValueChangeEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListViewColumnEventArgs
ActiproSoftware.Windows.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
ActiproSoftware.Windows.Controls.ViewsTaskCardEventArgs
ActiproSoftware.Windows.Controls.ViewsTaskColumnEventArgs
ActiproSoftware.Windows.Controls.WizardWizardSelectedPageChangeEventArgs


CancelRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | CancelRoutedEventArgs | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to false.
Public method | CancelRoutedEventArgs(Boolean) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to the given value.
Public method | CancelRoutedEventArgs(RoutedEvent) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to false.
Public method | CancelRoutedEventArgs(Boolean, RoutedEvent) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to the given value.
Public method | CancelRoutedEventArgs(RoutedEvent, Object) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to false.
Public method | CancelRoutedEventArgs(Boolean, RoutedEvent, Object) | Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to the given value.
Top
See Also

Reference

CancelRoutedEventArgs Class
ActiproSoftware.Windows Namespace


CancelRoutedEventArgs Constructor

Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CancelRoutedEventArgs()
Public Sub New
See Also

Reference

CancelRoutedEventArgs Class
CancelRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


CancelRoutedEventArgs Constructor (Boolean)

Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to the given value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CancelRoutedEventArgs(
    bool cancel
)
Public Sub New (
    cancel As Boolean
)

Parameters

cancel
Type: SystemBoolean
true to cancel the event; otherwise, false.
See Also

Reference

CancelRoutedEventArgs Class
CancelRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


CancelRoutedEventArgs Constructor (RoutedEvent)

Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CancelRoutedEventArgs(
    RoutedEvent routedEvent
)
Public Sub New (
    routedEvent As RoutedEvent
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
See Also

Reference

CancelRoutedEventArgs Class
CancelRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


CancelRoutedEventArgs Constructor (Boolean, RoutedEvent)

Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to the given value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CancelRoutedEventArgs(
    bool cancel,
    RoutedEvent routedEvent
)
Public Sub New (
    cancel As Boolean,
    routedEvent As RoutedEvent
)

Parameters

cancel
Type: SystemBoolean
true to cancel the event; otherwise, false.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
See Also

Reference

CancelRoutedEventArgs Class
CancelRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


CancelRoutedEventArgs Constructor (RoutedEvent, Object)

Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CancelRoutedEventArgs(
    RoutedEvent routedEvent,
    Object source
)
Public Sub New (
    routedEvent As RoutedEvent,
    source As Object
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

CancelRoutedEventArgs Class
CancelRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


CancelRoutedEventArgs Constructor (Boolean, RoutedEvent, Object)

Initializes a new instance of the CancelRoutedEventArgs class with the Cancel property set to the given value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CancelRoutedEventArgs(
    bool cancel,
    RoutedEvent routedEvent,
    Object source
)
Public Sub New (
    cancel As Boolean,
    routedEvent As RoutedEvent,
    source As Object
)

Parameters

cancel
Type: SystemBoolean
true to cancel the event; otherwise, false.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

CancelRoutedEventArgs Class
CancelRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


CancelRoutedEventArgs Properties

The CancelRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled.
Top
See Also

Reference

CancelRoutedEventArgs Class
ActiproSoftware.Windows Namespace


CancelRoutedEventArgs.Cancel Property

CancelRoutedEventArgsCancel Property

Gets or sets a value indicating whether the event should be canceled.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
true to cancel the event; otherwise, false.
See Also

Reference

CancelRoutedEventArgs Class
ActiproSoftware.Windows Namespace


DateRange Structure

Represents a date range, which is an inclusive pair of DateTime objects representing dates.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public struct DateRange : IEnumerable<DateTime>,
    IEnumerable
Public Structure DateRange
    Implements IEnumerable(Of DateTime), IEnumerable

The DateRange type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of dates contained in the range.
Public property | EndDate | Gets the end date of this range.
Public property | StartDate | Gets the start date of this range.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Contains(DateTime) | Determines whether the specified date is contained in this range.
Public method | Contains(DateRange) | Determines whether the specified date range is contained in this range.
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(DateRange) | Indicates whether the current object is equal to another object of the same type.
 | FromDate | Gets a date range for specified single date.
 | FromDecade | Gets a date range for the decade that contains the specified date.
 | FromMonth | Gets a date range for the month that contains the specified date.
 | FromRange | Gets a date range for specified range.
 | FromYear | Gets a date range for the year that contains the specified date.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | OverlapsWith | Determines whether the specified date range overlaps with, or crosses, this range.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality |
GreaterThan |
Inequality |
LessThan |
Top
See Also

Reference

ActiproSoftware.Windows Namespace


DateRange Properties

The DateRange type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of dates contained in the range.
Public property | EndDate | Gets the end date of this range.
Public property | StartDate | Gets the start date of this range.
Top
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.Count Property

DateRangeCount Property

Gets the number of dates contained in the range.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of dates contained in the range.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.EndDate Property

DateRangeEndDate Property

Gets the end date of this range.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime EndDate { get; }
Public ReadOnly Property EndDate As DateTime
    Get

Property Value

Type: DateTime
The end date of this range.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.StartDate Property

DateRangeStartDate Property

Gets the start date of this range.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime StartDate { get; }
Public ReadOnly Property StartDate As DateTime
    Get

Property Value

Type: DateTime
The start date of this range.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange Methods

The DateRange type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Contains(DateTime) | Determines whether the specified date is contained in this range.
Public method | Contains(DateRange) | Determines whether the specified date range is contained in this range.
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(DateRange) | Indicates whether the current object is equal to another object of the same type.
 | FromDate | Gets a date range for specified single date.
 | FromDecade | Gets a date range for the decade that contains the specified date.
 | FromMonth | Gets a date range for the month that contains the specified date.
 | FromRange | Gets a date range for specified range.
 | FromYear | Gets a date range for the year that contains the specified date.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | OverlapsWith | Determines whether the specified date range overlaps with, or crosses, this range.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.CompareTo Method

DateRangeCompareTo Method

Compares the current object with another object of the same type.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CompareTo(
    DateRange other
)
Public Function CompareTo (
    other As DateRange
) As Integer

Parameters

other
Type: ActiproSoftware.WindowsDateRange
An object to compare with this object.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Less than zero means this object is less than the other parameter. Zero means this object is equal to other. Greater than zero means this object is greater than other.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.Contains Method

DateRangeContains Method

Overload List
 | Name | Description
Public method | Contains(DateTime) | Determines whether the specified date is contained in this range.
Public method | Contains(DateRange) | Determines whether the specified date range is contained in this range.
Top
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.Contains Method (DateTime)

DateRangeContains Method (DateTime)

Determines whether the specified date is contained in this range.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    DateTime date
)
Public Function Contains (
    date As DateTime
) As Boolean

Parameters

date
Type: SystemDateTime
The date to examine.

Return Value

Type: Boolean
true if the specified date is contained in this range; otherwise, false.
See Also

Reference

DateRange Structure
Contains Overload
ActiproSoftware.Windows Namespace


DateRange.Contains Method (DateRange)

DateRangeContains Method (DateRange)

Determines whether the specified date range is contained in this range.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    DateRange dateRange
)
Public Function Contains (
    dateRange As DateRange
) As Boolean

Parameters

dateRange
Type: ActiproSoftware.WindowsDateRange
The date range.

Return Value

Type: Boolean
true if the specified date range is contained in this range; otherwise, false.
See Also

Reference

DateRange Structure
Contains Overload
ActiproSoftware.Windows Namespace


DateRange.Equals Method

DateRangeEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(DateRange) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.Equals Method (Object)

DateRangeEquals Method (Object)

Indicates whether this instance and a specified object are equal.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Another object to compare to.

Return Value

Type: Boolean
true if obj and this instance are the same type and represent the same value; otherwise, false.
See Also

Reference

DateRange Structure
Equals Overload
ActiproSoftware.Windows Namespace


DateRange.Equals Method (DateRange)

DateRangeEquals Method (DateRange)

Indicates whether the current object is equal to another object of the same type.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Equals(
    DateRange other
)
Public Function Equals (
    other As DateRange
) As Boolean

Parameters

other
Type: ActiproSoftware.WindowsDateRange
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.
See Also

Reference

DateRange Structure
Equals Overload
ActiproSoftware.Windows Namespace


DateRange.FromDate Method

DateRangeFromDate Method

Gets a date range for specified single date.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DateRange FromDate(
    DateTime date
)
Public Shared Function FromDate (
    date As DateTime
) As DateRange

Parameters

date
Type: SystemDateTime
The start date.

Return Value

Type: DateRange
A date range for the specified single date.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.FromDecade Method

DateRangeFromDecade Method

Gets a date range for the decade that contains the specified date.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DateRange FromDecade(
    DateTime date
)
Public Shared Function FromDecade (
    date As DateTime
) As DateRange

Parameters

date
Type: SystemDateTime
The date.

Return Value

Type: DateRange
A date range for the decade that contains the specified date.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.FromMonth Method

DateRangeFromMonth Method

Gets a date range for the month that contains the specified date.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DateRange FromMonth(
    DateTime date
)
Public Shared Function FromMonth (
    date As DateTime
) As DateRange

Parameters

date
Type: SystemDateTime
The date.

Return Value

Type: DateRange
A date range for the month that contains the specified date.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.FromRange Method

DateRangeFromRange Method

Gets a date range for specified range.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DateRange FromRange(
    DateTime startDate,
    DateTime endDate
)
Public Shared Function FromRange (
    startDate As DateTime,
    endDate As DateTime
) As DateRange

Parameters

startDate
Type: SystemDateTime
The start date.
endDate
Type: SystemDateTime
The end date.

Return Value

Type: DateRange
A date range for the specified range.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.FromYear Method

DateRangeFromYear Method

Gets a date range for the year that contains the specified date.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DateRange FromYear(
    DateTime date
)
Public Shared Function FromYear (
    date As DateTime
) As DateRange

Parameters

date
Type: SystemDateTime
The date.

Return Value

Type: DateRange
A date range for the year that contains the specified date.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.GetEnumerator Method

DateRangeGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<DateTime> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DateTime)

Return Value

Type: IEnumerator DateTime
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.GetHashCode Method

DateRangeGetHashCode Method

Returns the hash code for this instance.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.OverlapsWith Method

DateRangeOverlapsWith Method

Determines whether the specified date range overlaps with, or crosses, this range.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    DateRange otherRange
)
Public Function OverlapsWith (
    otherRange As DateRange
) As Boolean

Parameters

otherRange
Type: ActiproSoftware.WindowsDateRange
The date range to examine.

Return Value

Type: Boolean
true if the specified date range overlaps with, or crosses, this range; otherwise false.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.ToString Method

DateRangeToString Method

Returns the fully qualified type name of this instance.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String containing a fully qualified type name.
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange Operators

The DateRange type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
Inequality |
LessThan |
Top
See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.Equality Operator

DateRangeEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Windows.DateRange.op_Equality(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator ==(
    DateRange left,
    DateRange right
)
Public Shared Operator = (
    left As DateRange,
    right As DateRange
) As Boolean

Parameters

left
Type: ActiproSoftware.WindowsDateRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Windows.DateRange.op_Equality(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

right
Type: ActiproSoftware.WindowsDateRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Windows.DateRange.op_Equality(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.DateRange.op_Equality(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.GreaterThan Operator

DateRangeGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Windows.DateRange.op_GreaterThan(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator >(
    DateRange left,
    DateRange right
)
Public Shared Operator > (
    left As DateRange,
    right As DateRange
) As Boolean

Parameters

left
Type: ActiproSoftware.WindowsDateRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Windows.DateRange.op_GreaterThan(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

right
Type: ActiproSoftware.WindowsDateRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Windows.DateRange.op_GreaterThan(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.DateRange.op_GreaterThan(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.Inequality Operator

DateRangeInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Windows.DateRange.op_Inequality(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator !=(
    DateRange left,
    DateRange right
)
Public Shared Operator <> (
    left As DateRange,
    right As DateRange
) As Boolean

Parameters

left
Type: ActiproSoftware.WindowsDateRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Windows.DateRange.op_Inequality(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

right
Type: ActiproSoftware.WindowsDateRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Windows.DateRange.op_Inequality(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.DateRange.op_Inequality(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRange.LessThan Operator

DateRangeLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Windows.DateRange.op_LessThan(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator <(
    DateRange left,
    DateRange right
)
Public Shared Operator < (
    left As DateRange,
    right As DateRange
) As Boolean

Parameters

left
Type: ActiproSoftware.WindowsDateRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Windows.DateRange.op_LessThan(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

right
Type: ActiproSoftware.WindowsDateRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Windows.DateRange.op_LessThan(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.DateRange.op_LessThan(ActiproSoftware.Windows.DateRange,ActiproSoftware.Windows.DateRange)"]

See Also

Reference

DateRange Structure
ActiproSoftware.Windows Namespace


DateRangeCollection Class

Represents a collection of DateRange objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsDateRangeCollection

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DateRangeCollection : ICollection<DateRange>,
    IEnumerable<DateRange>, IEnumerable, INotifyCollectionChanged
Public Class DateRangeCollection
    Implements ICollection(Of DateRange), IEnumerable(Of DateRange),
    IEnumerable, INotifyCollectionChanged

The DateRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DateRangeCollection | Initializes a new instance of the DateRangeCollection struct.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of DateRange items in the collection.
Public property | DayCount | Gets the number of days contained in the collection.
Public property | IsReadOnly | Gets whether the collection is read-only.
Public property | Item | Gets the DateRange at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds a new DateRange item to the collection.
Public method | Clear | Clears the collection.
Public method | Contains(DateTime) | Returns whether the collection contains the specified DateTime.
Public method | Contains(DateRange) | Returns whether the collection contains the specified DateRange item.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | IndexOf(DateTime) | Searches for the specified DateTime and returns the zero-based index of the DateRange that contains it, if any.
Public method | IndexOf(DateRange) | Searches for the specified DateRange and returns the zero-based index of the DateRange that contains it, if any.
Public method | OverlapsWith | Determines whether the specified date range overlaps with, or crosses, any range in this collection.
Public method | Remove | Removes the specified DateRange item from the collection.
Public method | SetToMultipleDateRanges | Clears the collection, setting it to multiple DateRange items.
Public method | SetToSingleDateRange | Clears the collection, setting it to a single DateRange.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed.
Top
See Also

Reference

ActiproSoftware.Windows Namespace


DateRangeCollection Constructor

Initializes a new instance of the DateRangeCollection struct.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateRangeCollection()
Public Sub New
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection Properties

The DateRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of DateRange items in the collection.
Public property | DayCount | Gets the number of days contained in the collection.
Public property | IsReadOnly | Gets whether the collection is read-only.
Public property | Item | Gets the DateRange at the specified index.
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.Count Property

DateRangeCollectionCount Property

Gets the number of DateRange items in the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of DateRange items in the collection.

Implements

ICollectionTCount
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.DayCount Property

DateRangeCollectionDayCount Property

Gets the number of days contained in the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int DayCount { get; }
Public ReadOnly Property DayCount As Integer
    Get

Property Value

Type: Int32
The number of days contained in the collection.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.IsReadOnly Property

DateRangeCollectionIsReadOnly Property

Gets whether the collection is read-only.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the collection is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.Item Property

DateRangeCollectionItem Property

Gets the DateRange at the specified index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateRange this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As DateRange
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: DateRange
The DateRange at the specified index
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection Methods

The DateRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new DateRange item to the collection.
Public method | Clear | Clears the collection.
Public method | Contains(DateTime) | Returns whether the collection contains the specified DateTime.
Public method | Contains(DateRange) | Returns whether the collection contains the specified DateRange item.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | IndexOf(DateTime) | Searches for the specified DateTime and returns the zero-based index of the DateRange that contains it, if any.
Public method | IndexOf(DateRange) | Searches for the specified DateRange and returns the zero-based index of the DateRange that contains it, if any.
Public method | OverlapsWith | Determines whether the specified date range overlaps with, or crosses, any range in this collection.
Public method | Remove | Removes the specified DateRange item from the collection.
Public method | SetToMultipleDateRanges | Clears the collection, setting it to multiple DateRange items.
Public method | SetToSingleDateRange | Clears the collection, setting it to a single DateRange.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.Add Method

DateRangeCollectionAdd Method

Adds a new DateRange item to the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Add(
    DateRange item
)
Public Sub Add (
    item As DateRange
)

Parameters

item
Type: ActiproSoftware.WindowsDateRange
The DateRange to add.

Implements

ICollectionTAdd(T)
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.Clear Method

DateRangeCollectionClear Method

Clears the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.Contains Method

DateRangeCollectionContains Method

Overload List
 | Name | Description
Public method | Contains(DateTime) | Returns whether the collection contains the specified DateTime.
Public method | Contains(DateRange) | Returns whether the collection contains the specified DateRange item.
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.Contains Method (DateTime)

DateRangeCollectionContains Method (DateTime)

Returns whether the collection contains the specified DateTime.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    DateTime date
)
Public Function Contains (
    date As DateTime
) As Boolean

Parameters

date
Type: SystemDateTime
The DateTime for which to search.

Return Value

Type: Boolean
true if the collection contains the specified DateTime; otherwise, false.
See Also

Reference

DateRangeCollection Class
Contains Overload
ActiproSoftware.Windows Namespace


DateRangeCollection.Contains Method (DateRange)

DateRangeCollectionContains Method (DateRange)

Returns whether the collection contains the specified DateRange item.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    DateRange item
)
Public Function Contains (
    item As DateRange
) As Boolean

Parameters

item
Type: ActiproSoftware.WindowsDateRange
The DateRange item for which to search.

Return Value

Type: Boolean
true if the collection contains the specified DateRange item; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

DateRangeCollection Class
Contains Overload
ActiproSoftware.Windows Namespace


DateRangeCollection.CopyTo Method

DateRangeCollectionCopyTo Method

Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyTo(
    DateRange[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As DateRange(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.WindowsDateRange
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.GetEnumerator Method

DateRangeCollectionGetEnumerator Method

Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<DateRange> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DateRange)

Return Value

Type: IEnumerator DateRange
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.IndexOf Method

DateRangeCollectionIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(DateTime) | Searches for the specified DateTime and returns the zero-based index of the DateRange that contains it, if any.
Public method | IndexOf(DateRange) | Searches for the specified DateRange and returns the zero-based index of the DateRange that contains it, if any.
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.IndexOf Method (DateTime)

DateRangeCollectionIndexOf Method (DateTime)

Searches for the specified DateTime and returns the zero-based index of the DateRange that contains it, if any.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    DateTime date
)
Public Function IndexOf (
    date As DateTime
) As Integer

Parameters

date
Type: SystemDateTime
The DateTime for which to search.

Return Value

Type: Int32
The zero-based index of the DateRange that contains the specified DateTime, if found; otherwise -1.
See Also

Reference

DateRangeCollection Class
IndexOf Overload
ActiproSoftware.Windows Namespace


DateRangeCollection.IndexOf Method (DateRange)

DateRangeCollectionIndexOf Method (DateRange)

Searches for the specified DateRange and returns the zero-based index of the DateRange that contains it, if any.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    DateRange item
)
Public Function IndexOf (
    item As DateRange
) As Integer

Parameters

item
Type: ActiproSoftware.WindowsDateRange
The DateRange for which to search.

Return Value

Type: Int32
The zero-based index of the DateRange that contains the specified DateRange, if found; otherwise -1.
See Also

Reference

DateRangeCollection Class
IndexOf Overload
ActiproSoftware.Windows Namespace


DateRangeCollection.OverlapsWith Method

DateRangeCollectionOverlapsWith Method

Determines whether the specified date range overlaps with, or crosses, any range in this collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    DateRange range
)
Public Function OverlapsWith (
    range As DateRange
) As Boolean

Parameters

range
Type: ActiproSoftware.WindowsDateRange
The date range to examine.

Return Value

Type: Boolean
true if the specified date range overlaps with, or crosses, any range in this collection; otherwise false.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.Remove Method

DateRangeCollectionRemove Method

Removes the specified DateRange item from the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Remove(
    DateRange item
)
Public Function Remove (
    item As DateRange
) As Boolean

Parameters

item
Type: ActiproSoftware.WindowsDateRange
The DateRange to remove.

Return Value

Type: Boolean
true if anything was removed; otherwise, false.

Implements

ICollectionTRemove(T)
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.SetToMultipleDateRanges Method

DateRangeCollectionSetToMultipleDateRanges Method

Clears the collection, setting it to multiple DateRange items.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SetToMultipleDateRanges(
    IEnumerable<DateRange> items
)
Public Sub SetToMultipleDateRanges (
    items As IEnumerable(Of DateRange)
)

Parameters

items
Type: System.Collections.GenericIEnumerable DateRange
The collection of DateRange items to add.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.SetToSingleDateRange Method

DateRangeCollectionSetToSingleDateRange Method

Clears the collection, setting it to a single DateRange.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SetToSingleDateRange(
    DateRange item
)
Public Sub SetToSingleDateRange (
    item As DateRange
)

Parameters

item
Type: ActiproSoftware.WindowsDateRange
The DateRange containing the date range.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.ToString Method

DateRangeCollectionToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection Events

The DateRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed.
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateRangeCollection.CollectionChanged Event

DateRangeCollectionCollectionChanged Event

Occurs when the collection has changed.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

DateRangeCollection Class
ActiproSoftware.Windows Namespace


DateTimeFormatPattern Enumeration

Specifies various format patterns for a DateTime value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DateTimeFormatPattern
Public Enumeration DateTimeFormatPattern
Members
Member name | Value | Description
ShortDateTime | 0 | Short date and time.
FullDateTime | 1 | Long date and time.
LongDate | 2 | Long date.
LongTime | 3 | Long time.
MonthDay | 4 | Month and day.
Rfc1123 | 5 | Time based on the RFC1123 specification.
ShortDate | 6 | Short date.
ShortTime | 7 | Short time.
SortableDateTime | 8 | Sortable date and time.
UniversalSortableDateTime | 9 | Universal sortable date and time.
YearMonth | 10 | Year and month.
YearMonthNoDelimiter | 11 | Year and month, with no delimiter such as a comma.
See Also

Reference

ActiproSoftware.Windows Namespace


DateTimePropertyChangedRoutedEventArgs Class

Provides event arguments for a DateTime property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs DateTime
ActiproSoftware.WindowsDateTimePropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DateTimePropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<DateTime>
Public Class DateTimePropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of DateTime)

The DateTimePropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimePropertyChangedRoutedEventArgs(DateTime, DateTime) | Initializes a new instance of the DateTimePropertyChangedRoutedEventArgs class.
Public method | DateTimePropertyChangedRoutedEventArgs(RoutedEvent, DateTime, DateTime) | Initializes a new instance of the DateTimePropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


DateTimePropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | DateTimePropertyChangedRoutedEventArgs(DateTime, DateTime) | Initializes a new instance of the DateTimePropertyChangedRoutedEventArgs class.
Public method | DateTimePropertyChangedRoutedEventArgs(RoutedEvent, DateTime, DateTime) | Initializes a new instance of the DateTimePropertyChangedRoutedEventArgs class.
Top
See Also

Reference

DateTimePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


DateTimePropertyChangedRoutedEventArgs Constructor (DateTime, DateTime)

Initializes a new instance of the DateTimePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTimePropertyChangedRoutedEventArgs(
    DateTime oldValue,
    DateTime newValue
)
Public Sub New (
    oldValue As DateTime,
    newValue As DateTime
)

Parameters

oldValue
Type: SystemDateTime
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemDateTime
The new value of the property being tracked as reported by an event.
See Also

Reference

DateTimePropertyChangedRoutedEventArgs Class
DateTimePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


DateTimePropertyChangedRoutedEventArgs Constructor (RoutedEvent, DateTime, DateTime)

Initializes a new instance of the DateTimePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTimePropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    DateTime oldValue,
    DateTime newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As DateTime,
    newValue As DateTime
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemDateTime
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemDateTime
The new value of the property being tracked as reported by an event.
See Also

Reference

DateTimePropertyChangedRoutedEventArgs Class
DateTimePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


DateTimePropertyChangedRoutedEventArgs Properties

The DateTimePropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

DateTimePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


DayOfWeekFormatPattern Enumeration

Specifies various format patterns for a DayOfWeek value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DayOfWeekFormatPattern
Public Enumeration DayOfWeekFormatPattern
Members
Member name | Value | Description
SingleLetter | 0 | Indicates a format that uses a single letter for the day of the week.
Shortest | 1 | Indicates a format that uses the shortest text possible, while still being unique, for the day of the week.
ShortestUppercase | 2 | Indicates an all-uppercase format that uses the shortest text possible, while still being unique, for the day of the week.
Abbreviated | 3 | Indicates a format that uses an abbreviated text for the day of the week.
AbbreviatedUppercase | 4 | Indicates a format that uses an all-uppercase abbreviated text for the day of the week.
Full | 5 | Indicates a format that uses the full text of the day of the week.
See Also

Reference

ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T) Class

DeferrableObservableCollectionT Class

Provides an ObservableCollectionT that is capable of suspending its property change notifications until a bulk update is complete.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.WindowsDeferrableObservableCollectionT
More...

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DeferrableObservableCollection<T> : ObservableCollection<T>

Public Class DeferrableObservableCollection(Of T)
    Inherits ObservableCollection(Of T)

Type Parameters

T
The type of items.

The DeferrableObservableCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | DeferrableObservableCollectionT | Initializes a new instance of the DeferrableObservableCollectionT class.
Public method | DeferrableObservableCollectionT(IComparerT) | Initializes a new instance of the DeferrableObservableCollectionT class.
Public method | DeferrableObservableCollectionT(IComparerT, Boolean) | Initializes a new instance of the DeferrableObservableCollectionT class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | IsDirty | Gets whether there are any suspended property changes.
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Public method | AddRange | Adds multiple items to the collection.
Public method | BeginUpdate | Flags that a bulk update is about to begin.
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection T.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | EndUpdate | Flags that a bulk update has ended.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides ObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Overrides ObservableCollectionTOnPropertyChanged(PropertyChangedEventArgs).)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection T.)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection.
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.WindowsDeferrableObservableCollectionT
ActiproSoftware.Windows.Controls.ChartsDeferrableObservableItemCollectionT
ActiproSoftware.Windows.Controls.DockingDockingWindowCollectionBaseT
ActiproSoftware.Windows.Controls.Docking.SerializationXmlAutoHideTabStripCollection
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObjectCollection
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDocumentWindowCollection
ActiproSoftware.Windows.Controls.Docking.SerializationXmlRaftingHostCollection
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindowCollection
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindowContainerCollection
ActiproSoftware.Windows.Controls.DockingToolWindowContainerCollection
ActiproSoftware.Windows.Controls.MicroChartsMicroQualitativeRangeCollection
ActiproSoftware.Windows.Controls.MicroChartsMicroXYRangeCollection
ActiproSoftware.Windows.Controls.MicroChartsMicroXYSeriesCollection
ActiproSoftware.Windows.Controls.Navigation.SerializationXmlNavigationPaneCollection
ActiproSoftware.Windows.Controls.Ribbon.CollectionsGroupVariantCollection
ActiproSoftware.Windows.Controls.Ribbon.CollectionsRibbonControlCollectionT
ActiproSoftware.Windows.DocumentManagementDocumentReferenceCollection
ActiproSoftware.WindowsLogicalChildrenCollectionT
ActiproSoftware.Windows.ThemesTintGroupCollection


DeferrableObservableCollection(T) Constructor

DeferrableObservableCollectionT Constructor

Overload List
 | Name | Description
Public method | DeferrableObservableCollectionT | Initializes a new instance of the DeferrableObservableCollectionT class.
Public method | DeferrableObservableCollectionT(IComparerT) | Initializes a new instance of the DeferrableObservableCollectionT class.
Public method | DeferrableObservableCollectionT(IComparerT, Boolean) | Initializes a new instance of the DeferrableObservableCollectionT class.
Top
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T) Constructor

DeferrableObservableCollectionT Constructor

Initializes a new instance of the DeferrableObservableCollectionT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DeferrableObservableCollection()
Public Sub New
See Also

Reference

DeferrableObservableCollectionT Class
DeferrableObservableCollectionT Overload
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T) Constructor (IComparer(T))

DeferrableObservableCollectionT Constructor (IComparerT)

Initializes a new instance of the DeferrableObservableCollectionT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DeferrableObservableCollection(
    IComparer<T> sortComparer
)
Public Sub New (
    sortComparer As IComparer(Of T)
)

Parameters

sortComparer
Type: System.Collections.GenericIComparer T
A comparer used to sort items; otherwise .
See Also

Reference

DeferrableObservableCollectionT Class
DeferrableObservableCollectionT Overload
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T) Constructor (IComparer(T), Boolean)

DeferrableObservableCollectionT Constructor (IComparerT, Boolean)

Initializes a new instance of the DeferrableObservableCollectionT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DeferrableObservableCollection(
    IComparer<T> sortComparer,
    bool useStableSort
)
Public Sub New (
    sortComparer As IComparer(Of T),
    useStableSort As Boolean
)

Parameters

sortComparer
Type: System.Collections.GenericIComparer T
A comparer used to sort items; otherwise .
useStableSort
Type: SystemBoolean
if set to true then equivalent items will be maintained in the order they are added.
See Also

Reference

DeferrableObservableCollectionT Class
DeferrableObservableCollectionT Overload
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T) Properties

DeferrableObservableCollectionT Properties

The DeferrableObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | IsDirty | Gets whether there are any suspended property changes.
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Top
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).IsDirty Property

DeferrableObservableCollectionTIsDirty Property

Gets whether there are any suspended property changes.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDirty { get; }
Public ReadOnly Property IsDirty As Boolean
    Get

Property Value

Type: Boolean
true if there are any suspended property changes; otherwise, false.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).IsPropertyChangeSuspended Property

DeferrableObservableCollectionTIsPropertyChangeSuspended Property

Gets whether property change notifications are currently suspended.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPropertyChangeSuspended { get; }
Public ReadOnly Property IsPropertyChangeSuspended As Boolean
    Get

Property Value

Type: Boolean
true if property change notifications are currently suspended; otherwise, false.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T) Methods

DeferrableObservableCollectionT Methods

The DeferrableObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Public method | AddRange | Adds multiple items to the collection.
Public method | BeginUpdate | Flags that a bulk update is about to begin.
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection T .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | EndUpdate | Flags that a bulk update has ended.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides ObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Overrides ObservableCollectionTOnPropertyChanged(PropertyChangedEventArgs).)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection T .)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection.
Top
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).AddRange Method

DeferrableObservableCollectionTAddRange Method

Adds multiple items to the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddRange(
    IEnumerable<T> items
)
Public Sub AddRange (
    items As IEnumerable(Of T)
)

Parameters

items
Type: System.Collections.GenericIEnumerable T
The collection of items to add.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).BeginUpdate Method

DeferrableObservableCollectionTBeginUpdate Method

Flags that a bulk update is about to begin.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void BeginUpdate()
Public Sub BeginUpdate
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).EndUpdate Method

DeferrableObservableCollectionTEndUpdate Method

Flags that a bulk update has ended.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void EndUpdate()
Public Sub EndUpdate
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).InsertItem Method

DeferrableObservableCollectionTInsertItem Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).OnCollectionChanged Method

DeferrableObservableCollectionTOnCollectionChanged Method

Raises the CollectionChanged event with the provided arguments.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overrides Sub OnCollectionChanged (
    e As NotifyCollectionChangedEventArgs
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
A NotifyCollectionChangedEventArgs that contains the event data.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).OnPropertyChanged Method

DeferrableObservableCollectionTOnPropertyChanged Method

Raises the PropertyChanged event with the provided arguments.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
A PropertyChangedEventArgs that contains the event data.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).SetItem Method

DeferrableObservableCollectionTSetItem Method

Replaces the element at the specified index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: T
The new value for the element at the specified index.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T).ToArray Method

DeferrableObservableCollectionTToArray Method

Returns a strongly-typed array containing the items in this collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T[] ToArray()
Public Function ToArray As T()

Return Value

Type: T
A strongly-typed array containing the items in this collection.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DeferrableObservableCollection(T) Events

DeferrableObservableCollectionT Events

The DeferrableObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T .)
Top
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.Windows Namespace


DependencyObjectItemRoutedEventArgs Class

Provides event arguments for a DependencyObject-related routed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsItemRoutedEventArgs DependencyObject
ActiproSoftware.WindowsDependencyObjectItemRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DependencyObjectItemRoutedEventArgs : ItemRoutedEventArgs<DependencyObject>
Public Class DependencyObjectItemRoutedEventArgs
    Inherits ItemRoutedEventArgs(Of DependencyObject)

The DependencyObjectItemRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DependencyObjectItemRoutedEventArgs(DependencyObject) | Initializes a new instance of the DependencyObjectItemRoutedEventArgs class.
Public method | DependencyObjectItemRoutedEventArgs(DependencyObject, RoutedEvent) | Initializes a new instance of the DependencyObjectItemRoutedEventArgs class.
Public method | DependencyObjectItemRoutedEventArgs(DependencyObject, RoutedEvent, Object) | Initializes a new instance of the DependencyObjectItemRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the item that is the focus of this event. (Inherited from ItemRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


DependencyObjectItemRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | DependencyObjectItemRoutedEventArgs(DependencyObject) | Initializes a new instance of the DependencyObjectItemRoutedEventArgs class.
Public method | DependencyObjectItemRoutedEventArgs(DependencyObject, RoutedEvent) | Initializes a new instance of the DependencyObjectItemRoutedEventArgs class.
Public method | DependencyObjectItemRoutedEventArgs(DependencyObject, RoutedEvent, Object) | Initializes a new instance of the DependencyObjectItemRoutedEventArgs class.
Top
See Also

Reference

DependencyObjectItemRoutedEventArgs Class
ActiproSoftware.Windows Namespace


DependencyObjectItemRoutedEventArgs Constructor (DependencyObject)

Initializes a new instance of the DependencyObjectItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DependencyObjectItemRoutedEventArgs(
    DependencyObject item
)
Public Sub New (
    item As DependencyObject
)

Parameters

item
Type: System.WindowsDependencyObject
The item that is the focus of this event.
See Also

Reference

DependencyObjectItemRoutedEventArgs Class
DependencyObjectItemRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


DependencyObjectItemRoutedEventArgs Constructor (DependencyObject, RoutedEvent)

Initializes a new instance of the DependencyObjectItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DependencyObjectItemRoutedEventArgs(
    DependencyObject item,
    RoutedEvent routedEvent
)
Public Sub New (
    item As DependencyObject,
    routedEvent As RoutedEvent
)

Parameters

item
Type: System.WindowsDependencyObject
The item that is the focus of this event.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
See Also

Reference

DependencyObjectItemRoutedEventArgs Class
DependencyObjectItemRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


DependencyObjectItemRoutedEventArgs Constructor (DependencyObject, RoutedEvent, Object)

Initializes a new instance of the DependencyObjectItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DependencyObjectItemRoutedEventArgs(
    DependencyObject item,
    RoutedEvent routedEvent,
    Object source
)
Public Sub New (
    item As DependencyObject,
    routedEvent As RoutedEvent,
    source As Object
)

Parameters

item
Type: System.WindowsDependencyObject
The item that is the focus of this event.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

DependencyObjectItemRoutedEventArgs Class
DependencyObjectItemRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


DependencyObjectItemRoutedEventArgs Properties

The DependencyObjectItemRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the item that is the focus of this event. (Inherited from ItemRoutedEventArgsT.)
Top
See Also

Reference

DependencyObjectItemRoutedEventArgs Class
ActiproSoftware.Windows Namespace


DisposableObjectBase Class

Provides a base class that implements the IDisposable interface. This class functions in accordance with the Disposable design pattern.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsDisposableObjectBase
ActiproSoftware.ShellShellObjectBase
ActiproSoftware.ShellWindowsShellService
ActiproSoftware.Windows.Controls.RenderingCanvasDrawContext

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DisposableObjectBase
Public MustInherit Class DisposableObjectBase

The DisposableObjectBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DisposableObjectBase | Initializes a new instance of the DisposableObjectBase class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


DisposableObjectBase Constructor

Initializes a new instance of the DisposableObjectBase class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DisposableObjectBase()
Protected Sub New
Remarks
The default constructor initializes all fields to their default values.
See Also

Reference

DisposableObjectBase Class
ActiproSoftware.Windows Namespace


DisposableObjectBase Methods

The DisposableObjectBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Top
See Also

Reference

DisposableObjectBase Class
ActiproSoftware.Windows Namespace


DisposableObjectBase.Dispose Method

DisposableObjectBaseDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Top
See Also

Reference

DisposableObjectBase Class
ActiproSoftware.Windows Namespace


DisposableObjectBase.Dispose Method

DisposableObjectBaseDispose Method

Releases all resources used by the object.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose
See Also

Reference

DisposableObjectBase Class
Dispose Overload
ActiproSoftware.Windows Namespace


DisposableObjectBase.Dispose Method (Boolean)

DisposableObjectBaseDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

DisposableObjectBase Class
Dispose Overload
ActiproSoftware.Windows Namespace


DisposableObjectBase.Finalize Method

DisposableObjectBaseFinalize Method

Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
See Also

Reference

DisposableObjectBase Class
ActiproSoftware.Windows Namespace


DoublePropertyChangedRoutedEventArgs Class

Provides event arguments for a Double property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs Double
ActiproSoftware.WindowsDoublePropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoublePropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<double>
Public Class DoublePropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of Double)

The DoublePropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DoublePropertyChangedRoutedEventArgs(Double, Double) | Initializes a new instance of the DoublePropertyChangedRoutedEventArgs class.
Public method | DoublePropertyChangedRoutedEventArgs(RoutedEvent, Double, Double) | Initializes a new instance of the DoublePropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


DoublePropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | DoublePropertyChangedRoutedEventArgs(Double, Double) | Initializes a new instance of the DoublePropertyChangedRoutedEventArgs class.
Public method | DoublePropertyChangedRoutedEventArgs(RoutedEvent, Double, Double) | Initializes a new instance of the DoublePropertyChangedRoutedEventArgs class.
Top
See Also

Reference

DoublePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


DoublePropertyChangedRoutedEventArgs Constructor (Double, Double)

Initializes a new instance of the DoublePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoublePropertyChangedRoutedEventArgs(
    double oldValue,
    double newValue
)
Public Sub New (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemDouble
The new value of the property being tracked as reported by an event.
See Also

Reference

DoublePropertyChangedRoutedEventArgs Class
DoublePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


DoublePropertyChangedRoutedEventArgs Constructor (RoutedEvent, Double, Double)

Initializes a new instance of the DoublePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoublePropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    double oldValue,
    double newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As Double,
    newValue As Double
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemDouble
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemDouble
The new value of the property being tracked as reported by an event.
See Also

Reference

DoublePropertyChangedRoutedEventArgs Class
DoublePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


DoublePropertyChangedRoutedEventArgs Properties

The DoublePropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

DoublePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


DoublePropertyChangingRoutedEventArgs Class

Provides event arguments for a cancelable Double property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangingRoutedEventArgs Double
ActiproSoftware.WindowsDoublePropertyChangingRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoublePropertyChangingRoutedEventArgs : PropertyChangingRoutedEventArgs<double>
Public Class DoublePropertyChangingRoutedEventArgs
    Inherits PropertyChangingRoutedEventArgs(Of Double)

The DoublePropertyChangingRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DoublePropertyChangingRoutedEventArgs(Double, Double) | Initializes a new instance of the DoublePropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | DoublePropertyChangingRoutedEventArgs(RoutedEvent, Double, Double) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | NewValue | Gets or sets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


DoublePropertyChangingRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | DoublePropertyChangingRoutedEventArgs(Double, Double) | Initializes a new instance of the DoublePropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | DoublePropertyChangingRoutedEventArgs(RoutedEvent, Double, Double) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Top
See Also

Reference

DoublePropertyChangingRoutedEventArgs Class
ActiproSoftware.Windows Namespace


DoublePropertyChangingRoutedEventArgs Constructor (Double, Double)

Initializes a new instance of the DoublePropertyChangingRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoublePropertyChangingRoutedEventArgs(
    double oldValue,
    double newValue
)
Public Sub New (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The current value of the property.
newValue
Type: SystemDouble
The new value of the property that will be set if the property change is not cancelled.
See Also

Reference

DoublePropertyChangingRoutedEventArgs Class
DoublePropertyChangingRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


DoublePropertyChangingRoutedEventArgs Constructor (RoutedEvent, Double, Double)

Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoublePropertyChangingRoutedEventArgs(
    RoutedEvent routedEvent,
    double oldValue,
    double newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As Double,
    newValue As Double
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemDouble
The current value of the property.
newValue
Type: SystemDouble
The new value of the property that will be set if the property change is not cancelled.
See Also

Reference

DoublePropertyChangingRoutedEventArgs Class
DoublePropertyChangingRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


DoublePropertyChangingRoutedEventArgs Properties

The DoublePropertyChangingRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | NewValue | Gets or sets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Top
See Also

Reference

DoublePropertyChangingRoutedEventArgs Class
ActiproSoftware.Windows Namespace


EnumerableView(T) Class

EnumerableViewT Class

Represents a read-only view on top of an IEnumerableT with support for filtering, sorting, and change notifications.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsEnumerableViewT

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumerableView<T> : IEnumerable,
    INotifyCollectionChanged, ICollection<T>, IEnumerable<T>, IList<T>, ICollection,
    IList

Public Class EnumerableView(Of T)
    Implements IEnumerable, INotifyCollectionChanged, ICollection(Of T),
    IEnumerable(Of T), IList(Of T), ICollection, IList

Type Parameters

T
The type of items.

The EnumerableViewT type exposes the following members.

Constructors
 | Name | Description
Public method | EnumerableViewT(IEnumerableT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, IComparerT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, ComparisonT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, PredicateT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, PredicateT, IComparerT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, PredicateT, ComparisonT) | Initializes a new instance of the EnumerableViewT class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | FilterPredicate | Gets or sets a filter predicate delegate, which can be used to filter the associated collection.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | IsSorting | Gets a value indicating whether this instance is sorting its items.
Public property | Item | Gets or sets the element at the specified index.
Public property | SortComparer | Gets or sets a sort comparer, which can be used to sort the associated collection.
Public property | SortComparison | Gets or sets a sort comparison delegate, which can be used to sort the associated collection.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the collection.
Public method | Clear | Removes all items from the collection.
Public method | Contains(Object) | Determines whether the list contains a specific value.
Public method | Contains(T) | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | IndexOf(Object) | Determines the index of a specific item in the list.
Public method | IndexOf(T) | Determines the index of a specific item in the list.
Public method | Insert(Int32, Object) | Inserts an item to the list at the specified index.
Public method | Insert(Int32, T) | Inserts an item to the list at the specified index.
Public method | Reevaluate | Reevaluates the filtering and sorting logic applied to the specified item from the associated collection.
Public method | ReevaluateAt | Reevaluates the filtering and sorting logic applied to the item at the specified index relative to the associated collection.
Public method | Remove | Removes the first occurrence of a specific object from the collection.
Public method | RemoveAt | Removes the list item at the specified index.
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeT | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllT | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


EnumerableView(T) Constructor

EnumerableViewT Constructor

Overload List
 | Name | Description
Public method | EnumerableViewT(IEnumerableT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, IComparerT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, ComparisonT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, PredicateT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, PredicateT, IComparerT) | Initializes a new instance of the EnumerableViewT class.
Public method | EnumerableViewT(IEnumerableT, PredicateT, ComparisonT) | Initializes a new instance of the EnumerableViewT class.
Top
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T) Constructor (IEnumerable(T))

EnumerableViewT Constructor (IEnumerableT)

Initializes a new instance of the EnumerableViewT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerableView(
    IEnumerable<T> collection
)
Public Sub New (
    collection As IEnumerable(Of T)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection to wrap/filter.
See Also

Reference

EnumerableViewT Class
EnumerableViewT Overload
ActiproSoftware.Windows Namespace


EnumerableView(T) Constructor (IEnumerable(T), IComparer(T))

EnumerableViewT Constructor (IEnumerableT, IComparerT)

Initializes a new instance of the EnumerableViewT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerableView(
    IEnumerable<T> collection,
    IComparer<T> sort
)
Public Sub New (
    collection As IEnumerable(Of T),
    sort As IComparer(Of T)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection to wrap/filter.
sort
Type: System.Collections.GenericIComparer T
The sort logic.
See Also

Reference

EnumerableViewT Class
EnumerableViewT Overload
ActiproSoftware.Windows Namespace


EnumerableView(T) Constructor (IEnumerable(T), Comparison(T))

EnumerableViewT Constructor (IEnumerableT, ComparisonT)

Initializes a new instance of the EnumerableViewT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerableView(
    IEnumerable<T> collection,
    Comparison<T> sort
)
Public Sub New (
    collection As IEnumerable(Of T),
    sort As Comparison(Of T)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection to wrap/filter.
sort
Type: SystemComparison T
The sort logic.
See Also

Reference

EnumerableViewT Class
EnumerableViewT Overload
ActiproSoftware.Windows Namespace


EnumerableView(T) Constructor (IEnumerable(T), Predicate(T))

EnumerableViewT Constructor (IEnumerableT, PredicateT)

Initializes a new instance of the EnumerableViewT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerableView(
    IEnumerable<T> collection,
    Predicate<T> filter
)
Public Sub New (
    collection As IEnumerable(Of T),
    filter As Predicate(Of T)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection to wrap/filter.
filter
Type: SystemPredicate T
The filter logic.
See Also

Reference

EnumerableViewT Class
EnumerableViewT Overload
ActiproSoftware.Windows Namespace


EnumerableView(T) Constructor (IEnumerable(T), Predicate(T), IComparer(T))

EnumerableViewT Constructor (IEnumerableT, PredicateT, IComparerT)

Initializes a new instance of the EnumerableViewT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerableView(
    IEnumerable<T> collection,
    Predicate<T> filter,
    IComparer<T> sort
)
Public Sub New (
    collection As IEnumerable(Of T),
    filter As Predicate(Of T),
    sort As IComparer(Of T)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection to wrap/filter.
filter
Type: SystemPredicate T
The filter logic.
sort
Type: System.Collections.GenericIComparer T
The sort logic.
See Also

Reference

EnumerableViewT Class
EnumerableViewT Overload
ActiproSoftware.Windows Namespace


EnumerableView(T) Constructor (IEnumerable(T), Predicate(T), Comparison(T))

EnumerableViewT Constructor (IEnumerableT, PredicateT, ComparisonT)

Initializes a new instance of the EnumerableViewT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumerableView(
    IEnumerable<T> collection,
    Predicate<T> filter,
    Comparison<T> sort
)
Public Sub New (
    collection As IEnumerable(Of T),
    filter As Predicate(Of T),
    sort As Comparison(Of T)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection to wrap/filter.
filter
Type: SystemPredicate T
The filter logic.
sort
Type: SystemComparison T
The sort logic.
See Also

Reference

EnumerableViewT Class
EnumerableViewT Overload
ActiproSoftware.Windows Namespace


EnumerableView(T) Properties

EnumerableViewT Properties

The EnumerableViewT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | FilterPredicate | Gets or sets a filter predicate delegate, which can be used to filter the associated collection.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | IsSorting | Gets a value indicating whether this instance is sorting its items.
Public property | Item | Gets or sets the element at the specified index.
Public property | SortComparer | Gets or sets a sort comparer, which can be used to sort the associated collection.
Public property | SortComparison | Gets or sets a sort comparison delegate, which can be used to sort the associated collection.
Top
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).Count Property

EnumerableViewTCount Property

Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.

Implements

ICollectionTCount
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).FilterPredicate Property

EnumerableViewTFilterPredicate Property

Gets or sets a filter predicate delegate, which can be used to filter the associated collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Predicate<T> FilterPredicate { get; set; }
Public Property FilterPredicate As Predicate(Of T)
    Get
    Set

Property Value

Type: Predicate T
The filter logic, which returns true to filter an item.
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).IsReadOnly Property

EnumerableViewTIsReadOnly Property

Gets a value indicating whether the collection is read-only.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the collection is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
IListIsReadOnly
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).IsSorting Property

EnumerableViewTIsSorting Property

Gets a value indicating whether this instance is sorting its items.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSorting { get; }
Public ReadOnly Property IsSorting As Boolean
    Get

Property Value

Type: Boolean
true if this instance is sorting its items; otherwise, false.
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).Item Property

EnumerableViewTItem Property

Gets or sets the element at the specified index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set

Parameters

index
Type: SystemInt32
The zero-based index of the element to get or set.

Property Value

Type: T
The element at the specified index.

Implements

IListTItemInt32
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).SortComparer Property

EnumerableViewTSortComparer Property

Gets or sets a sort comparer, which can be used to sort the associated collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IComparer<T> SortComparer { get; set; }
Public Property SortComparer As IComparer(Of T)
    Get
    Set

Property Value

Type: IComparer T
The sort comparer, used to compare items for sorting.
Remarks
This property takes precedence over the SortComparison property.
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).SortComparison Property

EnumerableViewTSortComparison Property

Gets or sets a sort comparison delegate, which can be used to sort the associated collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Comparison<T> SortComparison { get; set; }
Public Property SortComparison As Comparison(Of T)
    Get
    Set

Property Value

Type: Comparison T
The sort logic.
Remarks
The SortComparer property takes precedence over this property.
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T) Methods

EnumerableViewT Methods

The EnumerableViewT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the collection.
Public method | Clear | Removes all items from the collection.
Public method | Contains(Object) | Determines whether the list contains a specific value.
Public method | Contains(T) | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | IndexOf(Object) | Determines the index of a specific item in the list.
Public method | IndexOf(T) | Determines the index of a specific item in the list.
Public method | Insert(Int32, Object) | Inserts an item to the list at the specified index.
Public method | Insert(Int32, T) | Inserts an item to the list at the specified index.
Public method | Reevaluate | Reevaluates the filtering and sorting logic applied to the specified item from the associated collection.
Public method | ReevaluateAt | Reevaluates the filtering and sorting logic applied to the item at the specified index relative to the associated collection.
Public method | Remove | Removes the first occurrence of a specific object from the collection.
Public method | RemoveAt | Removes the list item at the specified index.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeT | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllT | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).Add Method

EnumerableViewTAdd Method

Adds an item to the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Add(
    T item
)
Public Sub Add (
    item As T
)

Parameters

item
Type: T
The object to add to the collection.

Implements

ICollectionTAdd(T)
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).Clear Method

EnumerableViewTClear Method

Removes all items from the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
IListClear
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).Contains Method

EnumerableViewTContains Method

Overload List
 | Name | Description
Public method | Contains(Object) | Determines whether the list contains a specific value.
Public method | Contains(T) | Determines whether the collection contains a specific value.
Top
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).Contains Method (Object)

EnumerableViewTContains Method (Object)

Determines whether the list contains a specific value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    Object value
)
Public Function Contains (
    value As Object
) As Boolean

Parameters

value
Type: SystemObject
The Object to locate in the list.

Return Value

Type: Boolean
true if the Object is found in the list; otherwise, false.

Implements

IListContains(Object)
See Also

Reference

EnumerableViewT Class
Contains Overload
ActiproSoftware.Windows Namespace


EnumerableView(T).Contains Method (T)

EnumerableViewTContains Method (T)

Determines whether the collection contains a specific value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean

Parameters

item
Type: T
The object to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

EnumerableViewT Class
Contains Overload
ActiproSoftware.Windows Namespace


EnumerableView(T).CopyTo Method

EnumerableViewTCopyTo Method

Copies the elements of the collection to an Array, starting at a particular Array index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from collection. The Array must have zero-based indexing..
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).GetEnumerator Method

EnumerableViewTGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)

Return Value

Type: IEnumerator T
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).IndexOf Method

EnumerableViewTIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(Object) | Determines the index of a specific item in the list.
Public method | IndexOf(T) | Determines the index of a specific item in the list.
Top
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).IndexOf Method (Object)

EnumerableViewTIndexOf Method (Object)

Determines the index of a specific item in the list.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    Object value
)
Public Function IndexOf (
    value As Object
) As Integer

Parameters

value
Type: SystemObject
The Object to locate in the list.

Return Value

Type: Int32
The index of value if found in the list; otherwise, -1.

Implements

IListIndexOf(Object)
See Also

Reference

EnumerableViewT Class
IndexOf Overload
ActiproSoftware.Windows Namespace


EnumerableView(T).IndexOf Method (T)

EnumerableViewTIndexOf Method (T)

Determines the index of a specific item in the list.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer

Parameters

item
Type: T
The object to locate in the list.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

EnumerableViewT Class
IndexOf Overload
ActiproSoftware.Windows Namespace


EnumerableView(T).Insert Method

EnumerableViewTInsert Method

Overload List
 | Name | Description
Public method | Insert(Int32, Object) | Inserts an item to the list at the specified index.
Public method | Insert(Int32, T) | Inserts an item to the list at the specified index.
Top
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).Insert Method (Int32, Object)

EnumerableViewTInsert Method (Int32, Object)

Inserts an item to the list at the specified index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Insert(
    int index,
    Object value
)
Public Sub Insert (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which value should be inserted.
value
Type: SystemObject
The Object to insert into the list.

Implements

IListInsert(Int32, Object)
See Also

Reference

EnumerableViewT Class
Insert Overload
ActiproSoftware.Windows Namespace


EnumerableView(T).Insert Method (Int32, T)

EnumerableViewTInsert Method (Int32, T)

Inserts an item to the list at the specified index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Insert(
    int index,
    T item
)
Public Sub Insert (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert into the list.

Implements

IListTInsert(Int32, T)
See Also

Reference

EnumerableViewT Class
Insert Overload
ActiproSoftware.Windows Namespace


EnumerableView(T).Reevaluate Method

EnumerableViewTReevaluate Method

Reevaluates the filtering and sorting logic applied to the specified item from the associated collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Reevaluate(
    T item
)
Public Sub Reevaluate (
    item As T
)

Parameters

item
Type: T
The item to reevaluate.
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).ReevaluateAt Method

EnumerableViewTReevaluateAt Method

Reevaluates the filtering and sorting logic applied to the item at the specified index relative to the associated collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ReevaluateAt(
    int index
)
Public Sub ReevaluateAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the item to reevaluate.
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).Remove Method

EnumerableViewTRemove Method

Removes the first occurrence of a specific object from the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Remove(
    T item
)
Public Function Remove (
    item As T
) As Boolean

Parameters

item
Type: T
The object to remove from the collection.

Return Value

Type: Boolean
true if item was successfully removed from the collection; otherwise, false. This method also returns false if item is not found in the original collection.

Implements

ICollectionTRemove(T)
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).RemoveAt Method

EnumerableViewTRemoveAt Method

Removes the list item at the specified index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
IListRemoveAt(Int32)
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T) Events

EnumerableViewT Events

The EnumerableViewT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes.
Top
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


EnumerableView(T).CollectionChanged Event

EnumerableViewTCollectionChanged Event

Occurs when the collection changes.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

EnumerableViewT Class
ActiproSoftware.Windows Namespace


IEnumerablePropertyChangedRoutedEventArgs Class

Provides event arguments for an IEnumerable property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs IEnumerable
ActiproSoftware.WindowsIEnumerablePropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class IEnumerablePropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<IEnumerable>
Public Class IEnumerablePropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of IEnumerable)

The IEnumerablePropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | IEnumerablePropertyChangedRoutedEventArgs(IEnumerable, IEnumerable) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Public method | IEnumerablePropertyChangedRoutedEventArgs(RoutedEvent, IEnumerable, IEnumerable) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


IEnumerablePropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | IEnumerablePropertyChangedRoutedEventArgs(IEnumerable, IEnumerable) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Public method | IEnumerablePropertyChangedRoutedEventArgs(RoutedEvent, IEnumerable, IEnumerable) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Top
See Also

Reference

IEnumerablePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


IEnumerablePropertyChangedRoutedEventArgs Constructor (IEnumerable, IEnumerable)

Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerablePropertyChangedRoutedEventArgs(
    IEnumerable oldValue,
    IEnumerable newValue
)
Public Sub New (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
The previous value of the property being tracked as reported by an event.
newValue
Type: System.CollectionsIEnumerable
The new value of the property being tracked as reported by an event.
See Also

Reference

IEnumerablePropertyChangedRoutedEventArgs Class
IEnumerablePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


IEnumerablePropertyChangedRoutedEventArgs Constructor (RoutedEvent, IEnumerable, IEnumerable)

Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerablePropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    IEnumerable oldValue,
    IEnumerable newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: System.CollectionsIEnumerable
The previous value of the property being tracked as reported by an event.
newValue
Type: System.CollectionsIEnumerable
The new value of the property being tracked as reported by an event.
See Also

Reference

IEnumerablePropertyChangedRoutedEventArgs Class
IEnumerablePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


IEnumerablePropertyChangedRoutedEventArgs Properties

The IEnumerablePropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

IEnumerablePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


ILogicalParent Interface

Provides the base requirements for an element that can add and remove logical child elements.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILogicalParent
Public Interface ILogicalParent

The ILogicalParent type exposes the following members.

Methods
 | Name | Description
Public method | AddLogicalChild | Adds the provided object to the logical tree of this element.
Public method | RemoveLogicalChild | Removes the provided object from the logical tree of this element.
Top
See Also

Reference

ActiproSoftware.Windows Namespace


ILogicalParent Methods

The ILogicalParent type exposes the following members.

Methods
 | Name | Description
Public method | AddLogicalChild | Adds the provided object to the logical tree of this element.
Public method | RemoveLogicalChild | Removes the provided object from the logical tree of this element.
Top
See Also

Reference

ILogicalParent Interface
ActiproSoftware.Windows Namespace


ILogicalParent.AddLogicalChild Method

ILogicalParentAddLogicalChild Method

Adds the provided object to the logical tree of this element.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void AddLogicalChild(
    Object child
)
Sub AddLogicalChild (
    child As Object
)

Parameters

child
Type: SystemObject
Child element to add.
See Also

Reference

ILogicalParent Interface
ActiproSoftware.Windows Namespace


ILogicalParent.RemoveLogicalChild Method

ILogicalParentRemoveLogicalChild Method

Removes the provided object from the logical tree of this element.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void RemoveLogicalChild(
    Object child
)
Sub RemoveLogicalChild (
    child As Object
)

Parameters

child
Type: SystemObject
Child element to remove.
See Also

Reference

ILogicalParent Interface
ActiproSoftware.Windows Namespace


ItemRoutedEventArgs(T) Class

ItemRoutedEventArgsT Class

Provides event arguments for an item-related routed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsItemRoutedEventArgsT
ActiproSoftware.Windows.ControlsContextMenuItemRoutedEventArgs
ActiproSoftware.WindowsDependencyObjectItemRoutedEventArgs
ActiproSoftware.WindowsObjectItemRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ItemRoutedEventArgs<T> : RoutedEventArgs

Public Class ItemRoutedEventArgs(Of T)
    Inherits RoutedEventArgs

Type Parameters

T
The type of the item.

The ItemRoutedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | ItemRoutedEventArgsT(T) | Initializes a new instance of the ItemRoutedEventArgs class.
Public method | ItemRoutedEventArgsT(T, RoutedEvent) | Initializes a new instance of the ItemRoutedEventArgs class.
Public method | ItemRoutedEventArgsT(T, RoutedEvent, Object) | Initializes a new instance of the ItemRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the item that is the focus of this event.
Top
See Also

Reference

ActiproSoftware.Windows Namespace


ItemRoutedEventArgs(T) Constructor

ItemRoutedEventArgsT Constructor

Overload List
 | Name | Description
Public method | ItemRoutedEventArgsT(T) | Initializes a new instance of the ItemRoutedEventArgs class.
Public method | ItemRoutedEventArgsT(T, RoutedEvent) | Initializes a new instance of the ItemRoutedEventArgs class.
Public method | ItemRoutedEventArgsT(T, RoutedEvent, Object) | Initializes a new instance of the ItemRoutedEventArgs class.
Top
See Also

Reference

ItemRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


ItemRoutedEventArgs(T) Constructor (T)

ItemRoutedEventArgsT Constructor (T)

Initializes a new instance of the ItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemRoutedEventArgs(
    T item
)
Public Sub New (
    item As T
)

Parameters

item
Type: T
The item that is the focus of this event.
See Also

Reference

ItemRoutedEventArgsT Class
ItemRoutedEventArgsT Overload
ActiproSoftware.Windows Namespace


ItemRoutedEventArgs(T) Constructor (T, RoutedEvent)

ItemRoutedEventArgsT Constructor (T, RoutedEvent)

Initializes a new instance of the ItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemRoutedEventArgs(
    T item,
    RoutedEvent routedEvent
)
Public Sub New (
    item As T,
    routedEvent As RoutedEvent
)

Parameters

item
Type: T
The item that is the focus of this event.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
See Also

Reference

ItemRoutedEventArgsT Class
ItemRoutedEventArgsT Overload
ActiproSoftware.Windows Namespace


ItemRoutedEventArgs(T) Constructor (T, RoutedEvent, Object)

ItemRoutedEventArgsT Constructor (T, RoutedEvent, Object)

Initializes a new instance of the ItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemRoutedEventArgs(
    T item,
    RoutedEvent routedEvent,
    Object source
)
Public Sub New (
    item As T,
    routedEvent As RoutedEvent,
    source As Object
)

Parameters

item
Type: T
The item that is the focus of this event.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

ItemRoutedEventArgsT Class
ItemRoutedEventArgsT Overload
ActiproSoftware.Windows Namespace


ItemRoutedEventArgs(T) Properties

ItemRoutedEventArgsT Properties

The ItemRoutedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the item that is the focus of this event.
Top
See Also

Reference

ItemRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


ItemRoutedEventArgs(T).Item Property

ItemRoutedEventArgsTItem Property

Gets or sets the item that is the focus of this event.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Item { get; set; }
Public Property Item As T
    Get
    Set

Property Value

Type: T
The item that is the focus of this event.
See Also

Reference

ItemRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T) Class

LogicalChildrenCollectionT Class

Provides a DeferrableObservableCollectionT that is capable of adding/removing the logical parent, and optionally the visual parent, of the items in the collection.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.WindowsDeferrableObservableCollection T
ActiproSoftware.WindowsLogicalChildrenCollectionT
More...

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LogicalChildrenCollection<T> : DeferrableObservableCollection<T>

Public Class LogicalChildrenCollection(Of T)
    Inherits DeferrableObservableCollection(Of T)

Type Parameters

T
The type of items.

The LogicalChildrenCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalChildrenCollectionT(ILogicalParent) | Initializes a new instance of the LogicalChildrenCollectionT class.
Public method | LogicalChildrenCollectionT(ILogicalParent, Boolean) | Initializes a new instance of the LogicalChildrenCollectionT class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Public property | Parent | Gets the logical parent of the items in this collection.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.WindowsDeferrableObservableCollection T
ActiproSoftware.WindowsLogicalChildrenCollectionT
ActiproSoftware.Windows.Controls.GaugeCircularPointerCollection
ActiproSoftware.Windows.Controls.GaugeCircularRangeCollection
ActiproSoftware.Windows.Controls.GaugeCircularScaleCollection
ActiproSoftware.Windows.Controls.GaugeCircularTickCollection
ActiproSoftware.Windows.Controls.GaugeCircularTickSetCollection
ActiproSoftware.Windows.Controls.GaugeLinearPointerCollection
ActiproSoftware.Windows.Controls.GaugeLinearRangeCollection
ActiproSoftware.Windows.Controls.GaugeLinearScaleCollection
ActiproSoftware.Windows.Controls.GaugeLinearTickCollection
ActiproSoftware.Windows.Controls.GaugeLinearTickSetCollection


LogicalChildrenCollection(T) Constructor

LogicalChildrenCollectionT Constructor

Overload List
 | Name | Description
Public method | LogicalChildrenCollectionT(ILogicalParent) | Initializes a new instance of the LogicalChildrenCollectionT class.
Public method | LogicalChildrenCollectionT(ILogicalParent, Boolean) | Initializes a new instance of the LogicalChildrenCollectionT class.
Top
See Also

Reference

LogicalChildrenCollectionT Class
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T) Constructor (ILogicalParent)

LogicalChildrenCollectionT Constructor (ILogicalParent)

Initializes a new instance of the LogicalChildrenCollectionT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LogicalChildrenCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

LogicalChildrenCollectionT Class
LogicalChildrenCollectionT Overload
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T) Constructor (ILogicalParent, Boolean)

LogicalChildrenCollectionT Constructor (ILogicalParent, Boolean)

Initializes a new instance of the LogicalChildrenCollectionT class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LogicalChildrenCollection(
    ILogicalParent parent,
    bool areVisualChildren
)
Public Sub New (
    parent As ILogicalParent,
    areVisualChildren As Boolean
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
areVisualChildren
Type: SystemBoolean
if set to true then the items in this collection are also visual children; otherwise false.
Remarks
If areVisualChildren is set to true and parent implements IVisualParent, then this collection will also call the IVisualParent methods when items are added and removed from this collection.
See Also

Reference

LogicalChildrenCollectionT Class
LogicalChildrenCollectionT Overload
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T) Properties

LogicalChildrenCollectionT Properties

The LogicalChildrenCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Public property | Parent | Gets the logical parent of the items in this collection.
Top
See Also

Reference

LogicalChildrenCollectionT Class
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T).Parent Property

LogicalChildrenCollectionTParent Property

Gets the logical parent of the items in this collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ILogicalParent Parent { get; }
Public ReadOnly Property Parent As ILogicalParent
    Get

Property Value

Type: ILogicalParent
The logical parent.
See Also

Reference

LogicalChildrenCollectionT Class
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T) Methods

LogicalChildrenCollectionT Methods

The LogicalChildrenCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

LogicalChildrenCollectionT Class
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T).ClearItems Method

LogicalChildrenCollectionTClearItems Method

Removes all items from the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

LogicalChildrenCollectionT Class
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T).InsertItem Method

LogicalChildrenCollectionTInsertItem Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert.
See Also

Reference

LogicalChildrenCollectionT Class
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T).RemoveItem Method

LogicalChildrenCollectionTRemoveItem Method

Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
See Also

Reference

LogicalChildrenCollectionT Class
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T).SetItem Method

LogicalChildrenCollectionTSetItem Method

Replaces the element at the specified index.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: T
The new value for the element at the specified index.
See Also

Reference

LogicalChildrenCollectionT Class
ActiproSoftware.Windows Namespace


LogicalChildrenCollection(T) Events

LogicalChildrenCollectionT Events

The LogicalChildrenCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T .)
Top
See Also

Reference

LogicalChildrenCollectionT Class
ActiproSoftware.Windows Namespace


LogicalTreeHelperExtended Class

Contains static methods that are useful for performing common tasks with nodes in a logical tree.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsLogicalTreeHelperExtended

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class LogicalTreeHelperExtended
Public NotInheritable Class LogicalTreeHelperExtended

The LogicalTreeHelperExtended type exposes the following members.

Methods
Name | Description
GetRoot | Returns the root DependencyObject in the logical tree.
Merge | Merges the specified logical children into a single list, which can be collections or individual objects.
Top
See Also

Reference

ActiproSoftware.Windows Namespace


LogicalTreeHelperExtended Methods

The LogicalTreeHelperExtended type exposes the following members.

Methods
Name | Description
GetRoot | Returns the root DependencyObject in the logical tree.
Merge | Merges the specified logical children into a single list, which can be collections or individual objects.
Top
See Also

Reference

LogicalTreeHelperExtended Class
ActiproSoftware.Windows Namespace


LogicalTreeHelperExtended.GetRoot Method

LogicalTreeHelperExtendedGetRoot Method

Returns the root DependencyObject in the logical tree.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DependencyObject GetRoot(
    DependencyObject source
)
Public Shared Function GetRoot (
    source As DependencyObject
) As DependencyObject

Parameters

source
Type: System.WindowsDependencyObject
The visual whose root is returned.

Return Value

Type: DependencyObject
The root DependencyObject in the visual tree.
See Also

Reference

LogicalTreeHelperExtended Class
ActiproSoftware.Windows Namespace


LogicalTreeHelperExtended.Merge Method

LogicalTreeHelperExtendedMerge Method

Merges the specified logical children into a single list, which can be collections or individual objects.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IEnumerator Merge(
    params Object[] items
)
Public Shared Function Merge (
    ParamArray items As Object()
) As IEnumerator

Parameters

items
Type: SystemObject
The items to merge.

Return Value

Type: IEnumerator
An IEnumerator which references a list of all the given items.
See Also

Reference

LogicalTreeHelperExtended Class
ActiproSoftware.Windows Namespace


NullableDateTimePropertyChangedRoutedEventArgs Class

Provides event arguments for a nullable DateTime property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs Nullable DateTime
ActiproSoftware.WindowsNullableDateTimePropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableDateTimePropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<Nullable<DateTime>>
Public Class NullableDateTimePropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of Nullable(Of DateTime))

The NullableDateTimePropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NullableDateTimePropertyChangedRoutedEventArgs(NullableDateTime, NullableDateTime) | Initializes a new instance of the NullableDateTimePropertyChangedRoutedEventArgs class.
Public method | NullableDateTimePropertyChangedRoutedEventArgs(RoutedEvent, NullableDateTime, NullableDateTime) | Initializes a new instance of the NullableDateTimePropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


NullableDateTimePropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | NullableDateTimePropertyChangedRoutedEventArgs(NullableDateTime, NullableDateTime) | Initializes a new instance of the NullableDateTimePropertyChangedRoutedEventArgs class.
Public method | NullableDateTimePropertyChangedRoutedEventArgs(RoutedEvent, NullableDateTime, NullableDateTime) | Initializes a new instance of the NullableDateTimePropertyChangedRoutedEventArgs class.
Top
See Also

Reference

NullableDateTimePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


NullableDateTimePropertyChangedRoutedEventArgs Constructor (Nullable(DateTime), Nullable(DateTime))

NullableDateTimePropertyChangedRoutedEventArgs Constructor (NullableDateTime, NullableDateTime)

Initializes a new instance of the NullableDateTimePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableDateTimePropertyChangedRoutedEventArgs(
    Nullable<DateTime> oldValue,
    Nullable<DateTime> newValue
)
Public Sub New (
    oldValue As Nullable(Of DateTime),
    newValue As Nullable(Of DateTime)
)

Parameters

oldValue
Type: SystemNullable DateTime
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemNullable DateTime
The new value of the property being tracked as reported by an event.
See Also

Reference

NullableDateTimePropertyChangedRoutedEventArgs Class
NullableDateTimePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


NullableDateTimePropertyChangedRoutedEventArgs Constructor (RoutedEvent, Nullable(DateTime), Nullable(DateTime))

NullableDateTimePropertyChangedRoutedEventArgs Constructor (RoutedEvent, NullableDateTime, NullableDateTime)

Initializes a new instance of the NullableDateTimePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableDateTimePropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    Nullable<DateTime> oldValue,
    Nullable<DateTime> newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As Nullable(Of DateTime),
    newValue As Nullable(Of DateTime)
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemNullable DateTime
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemNullable DateTime
The new value of the property being tracked as reported by an event.
See Also

Reference

NullableDateTimePropertyChangedRoutedEventArgs Class
NullableDateTimePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


NullableDateTimePropertyChangedRoutedEventArgs Properties

The NullableDateTimePropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

NullableDateTimePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


ObjectItemRoutedEventArgs Class

Provides event arguments for a Object-related routed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsItemRoutedEventArgs Object
ActiproSoftware.WindowsObjectItemRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ObjectItemRoutedEventArgs : ItemRoutedEventArgs<Object>
Public Class ObjectItemRoutedEventArgs
    Inherits ItemRoutedEventArgs(Of Object)

The ObjectItemRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectItemRoutedEventArgs(Object) | Initializes a new instance of the ObjectItemRoutedEventArgs class.
Public method | ObjectItemRoutedEventArgs(Object, RoutedEvent) | Initializes a new instance of the ObjectItemRoutedEventArgs class.
Public method | ObjectItemRoutedEventArgs(Object, RoutedEvent, Object) | Initializes a new instance of the ObjectItemRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the item that is the focus of this event. (Inherited from ItemRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


ObjectItemRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | ObjectItemRoutedEventArgs(Object) | Initializes a new instance of the ObjectItemRoutedEventArgs class.
Public method | ObjectItemRoutedEventArgs(Object, RoutedEvent) | Initializes a new instance of the ObjectItemRoutedEventArgs class.
Public method | ObjectItemRoutedEventArgs(Object, RoutedEvent, Object) | Initializes a new instance of the ObjectItemRoutedEventArgs class.
Top
See Also

Reference

ObjectItemRoutedEventArgs Class
ActiproSoftware.Windows Namespace


ObjectItemRoutedEventArgs Constructor (Object)

Initializes a new instance of the ObjectItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObjectItemRoutedEventArgs(
    Object item
)
Public Sub New (
    item As Object
)

Parameters

item
Type: SystemObject
The item that is the focus of this event.
See Also

Reference

ObjectItemRoutedEventArgs Class
ObjectItemRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


ObjectItemRoutedEventArgs Constructor (Object, RoutedEvent)

Initializes a new instance of the ObjectItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObjectItemRoutedEventArgs(
    Object item,
    RoutedEvent routedEvent
)
Public Sub New (
    item As Object,
    routedEvent As RoutedEvent
)

Parameters

item
Type: SystemObject
The item that is the focus of this event.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
See Also

Reference

ObjectItemRoutedEventArgs Class
ObjectItemRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


ObjectItemRoutedEventArgs Constructor (Object, RoutedEvent, Object)

Initializes a new instance of the ObjectItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObjectItemRoutedEventArgs(
    Object item,
    RoutedEvent routedEvent,
    Object source
)
Public Sub New (
    item As Object,
    routedEvent As RoutedEvent,
    source As Object
)

Parameters

item
Type: SystemObject
The item that is the focus of this event.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

ObjectItemRoutedEventArgs Class
ObjectItemRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


ObjectItemRoutedEventArgs Properties

The ObjectItemRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the item that is the focus of this event. (Inherited from ItemRoutedEventArgsT.)
Top
See Also

Reference

ObjectItemRoutedEventArgs Class
ActiproSoftware.Windows Namespace


ObjectPropertyChangedRoutedEventArgs Class

Provides event arguments for an Object property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs Object
ActiproSoftware.WindowsObjectPropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ObjectPropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<Object>
Public Class ObjectPropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of Object)

The ObjectPropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectPropertyChangedRoutedEventArgs(Object, Object) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Public method | ObjectPropertyChangedRoutedEventArgs(RoutedEvent, Object, Object) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Public method | ObjectPropertyChangedRoutedEventArgs(RoutedEvent, Object, Object, Object) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


ObjectPropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | ObjectPropertyChangedRoutedEventArgs(Object, Object) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Public method | ObjectPropertyChangedRoutedEventArgs(RoutedEvent, Object, Object) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Public method | ObjectPropertyChangedRoutedEventArgs(RoutedEvent, Object, Object, Object) | Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.
Top
See Also

Reference

ObjectPropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


ObjectPropertyChangedRoutedEventArgs Constructor (Object, Object)

Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObjectPropertyChangedRoutedEventArgs(
    Object oldValue,
    Object newValue
)
Public Sub New (
    oldValue As Object,
    newValue As Object
)

Parameters

oldValue
Type: SystemObject
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemObject
The new value of the property being tracked as reported by an event.
See Also

Reference

ObjectPropertyChangedRoutedEventArgs Class
ObjectPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


ObjectPropertyChangedRoutedEventArgs Constructor (RoutedEvent, Object, Object)

Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObjectPropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    Object oldValue,
    Object newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As Object,
    newValue As Object
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemObject
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemObject
The new value of the property being tracked as reported by an event.
See Also

Reference

ObjectPropertyChangedRoutedEventArgs Class
ObjectPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


ObjectPropertyChangedRoutedEventArgs Constructor (RoutedEvent, Object, Object, Object)

Initializes a new instance of the ObjectPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObjectPropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    Object oldValue,
    Object newValue,
    Object source
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As Object,
    newValue As Object,
    source As Object
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemObject
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemObject
The new value of the property being tracked as reported by an event.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

ObjectPropertyChangedRoutedEventArgs Class
ObjectPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


ObjectPropertyChangedRoutedEventArgs Properties

The ObjectPropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ObjectPropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


ObservableObjectBase Class

A simple object that implements INotifyPropertyChanged.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
More...

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class ObservableObjectBase : INotifyPropertyChanged
Public MustInherit Class ObservableObjectBase
    Implements INotifyPropertyChanged

The ObservableObjectBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ObservableObjectBase | Initializes a new instance of the ObservableObjectBase class
Top
Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ActiproSoftware.Windows Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.ChartsLegendKey
ActiproSoftware.Windows.Controls.Charts.PrimitivesDataPointBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsCategoryEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsCategoryEditorProperty
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroDataPointBase
ActiproSoftware.Windows.Controls.Navigation.PrimitivesNavigationBarOptionsWindowItem
ActiproSoftware.Windows.Controls.ShellShellObjectViewModel
ActiproSoftware.Windows.Controls.SyntaxEditor.Highlighting.ImplementationHighlightingStyle


ObservableObjectBase Constructor

Initializes a new instance of the ObservableObjectBase class

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ObservableObjectBase()
Protected Sub New
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.Windows Namespace


ObservableObjectBase Methods

The ObservableObjectBase type exposes the following members.

Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Top
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.Windows Namespace


ObservableObjectBase.NotifyPropertyChanged Method

ObservableObjectBaseNotifyPropertyChanged Method

Notifies that a property has changed.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.Windows Namespace


ObservableObjectBase.OnPropertyChanged Method

ObservableObjectBaseOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.Windows Namespace


ObservableObjectBase Events

The ObservableObjectBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.Windows Namespace


ObservableObjectBase.PropertyChanged Event

ObservableObjectBasePropertyChanged Event

Occurs when a property has been changed.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.Windows Namespace


PropertyChangedRoutedEventArgs(T) Class

PropertyChangedRoutedEventArgsT Class

Provides event arguments for a property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgsT
More...

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyChangedRoutedEventArgs<T> : RoutedEventArgs

Public Class PropertyChangedRoutedEventArgs(Of T)
    Inherits RoutedEventArgs

Type Parameters

T
The return type of the property.

The PropertyChangedRoutedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyChangedRoutedEventArgsT(T, T) | Initializes a new instance of the PropertyChangedRoutedEventArgs class.
Public method | PropertyChangedRoutedEventArgsT(RoutedEvent, T, T) | Initializes a new instance of the PropertyChangedRoutedEventArgs class.
Public method | PropertyChangedRoutedEventArgsT(RoutedEvent, T, T, Object) | Initializes a new instance of the PropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
See Also

Reference

ActiproSoftware.Windows Namespace
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgsT
ActiproSoftware.WindowsBooleanPropertyChangedRoutedEventArgs
ActiproSoftware.Windows.Controls.GaugeLedStatePropertyChangedRoutedEventArgs
ActiproSoftware.Windows.Controls.NavigationBreadcrumbItemPropertyChangedRoutedEventArgs
ActiproSoftware.Windows.ControlsOperationStatePropertyChangedRoutedEventArgs
ActiproSoftware.Windows.Controls.Ribbon.ControlsTabPropertyChangedRoutedEventArgs
ActiproSoftware.Windows.Controls.SyntaxEditorEditorDocumentChangedEventArgs
ActiproSoftware.Windows.Controls.SyntaxEditorEditorDocumentLanguageChangedEventArgs
ActiproSoftware.Windows.Controls.SyntaxEditorEditorViewChangedEventArgs
ActiproSoftware.WindowsDateTimePropertyChangedRoutedEventArgs
ActiproSoftware.WindowsDoublePropertyChangedRoutedEventArgs
ActiproSoftware.WindowsIEnumerablePropertyChangedRoutedEventArgs
ActiproSoftware.WindowsNullableDateTimePropertyChangedRoutedEventArgs
ActiproSoftware.WindowsObjectPropertyChangedRoutedEventArgs
ActiproSoftware.WindowsSecureStringPropertyChangedRoutedEventArgs
ActiproSoftware.WindowsStringPropertyChangedRoutedEventArgs


PropertyChangedRoutedEventArgs(T) Constructor

PropertyChangedRoutedEventArgsT Constructor

Overload List
 | Name | Description
Public method | PropertyChangedRoutedEventArgsT(T, T) | Initializes a new instance of the PropertyChangedRoutedEventArgs class.
Public method | PropertyChangedRoutedEventArgsT(RoutedEvent, T, T) | Initializes a new instance of the PropertyChangedRoutedEventArgs class.
Public method | PropertyChangedRoutedEventArgsT(RoutedEvent, T, T, Object) | Initializes a new instance of the PropertyChangedRoutedEventArgs class.
Top
See Also

Reference

PropertyChangedRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


PropertyChangedRoutedEventArgs(T) Constructor (T, T)

PropertyChangedRoutedEventArgsT Constructor (T, T)

Initializes a new instance of the PropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyChangedRoutedEventArgs(
    T oldValue,
    T newValue
)
Public Sub New (
    oldValue As T,
    newValue As T
)

Parameters

oldValue
Type: T
The previous value of the property being tracked as reported by an event.
newValue
Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedRoutedEventArgsT Class
PropertyChangedRoutedEventArgsT Overload
ActiproSoftware.Windows Namespace


PropertyChangedRoutedEventArgs(T) Constructor (RoutedEvent, T, T)

PropertyChangedRoutedEventArgsT Constructor (RoutedEvent, T, T)

Initializes a new instance of the PropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    T oldValue,
    T newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As T,
    newValue As T
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: T
The previous value of the property being tracked as reported by an event.
newValue
Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedRoutedEventArgsT Class
PropertyChangedRoutedEventArgsT Overload
ActiproSoftware.Windows Namespace


PropertyChangedRoutedEventArgs(T) Constructor (RoutedEvent, T, T, Object)

PropertyChangedRoutedEventArgsT Constructor (RoutedEvent, T, T, Object)

Initializes a new instance of the PropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    T oldValue,
    T newValue,
    Object source
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As T,
    newValue As T,
    source As Object
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: T
The previous value of the property being tracked as reported by an event.
newValue
Type: T
The new value of the property being tracked as reported by an event.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

PropertyChangedRoutedEventArgsT Class
PropertyChangedRoutedEventArgsT Overload
ActiproSoftware.Windows Namespace


PropertyChangedRoutedEventArgs(T) Properties

PropertyChangedRoutedEventArgsT Properties

The PropertyChangedRoutedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
See Also

Reference

PropertyChangedRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


PropertyChangedRoutedEventArgs(T).NewValue Property

PropertyChangedRoutedEventArgsTNewValue Property

Gets the new value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T NewValue { get; }
Public ReadOnly Property NewValue As T
    Get

Property Value

Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


PropertyChangedRoutedEventArgs(T).OldValue Property

PropertyChangedRoutedEventArgsTOldValue Property

Gets the previous value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T OldValue { get; }
Public ReadOnly Property OldValue As T
    Get

Property Value

Type: T
The previous value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


PropertyChangingRoutedEventArgs(T) Class

PropertyChangingRoutedEventArgsT Class

Provides event arguments for a cancelable property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangingRoutedEventArgsT
ActiproSoftware.Windows.Controls.Ribbon.ControlsTabPropertyChangingRoutedEventArgs
ActiproSoftware.WindowsDoublePropertyChangingRoutedEventArgs
ActiproSoftware.WindowsSecureStringPropertyChangingRoutedEventArgs
ActiproSoftware.WindowsStringPropertyChangingRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyChangingRoutedEventArgs<T> : RoutedEventArgs

Public Class PropertyChangingRoutedEventArgs(Of T)
    Inherits RoutedEventArgs

Type Parameters

T
The return type of the property.

The PropertyChangingRoutedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyChangingRoutedEventArgsT(T, T) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | PropertyChangingRoutedEventArgsT(RoutedEvent, T, T) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | PropertyChangingRoutedEventArgsT(RoutedEvent, T, T, Object) | Initializes a new instance of the PropertyChangingRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled.
Public property | NewValue | Gets or sets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
See Also

Reference

ActiproSoftware.Windows Namespace


PropertyChangingRoutedEventArgs(T) Constructor

PropertyChangingRoutedEventArgsT Constructor

Overload List
 | Name | Description
Public method | PropertyChangingRoutedEventArgsT(T, T) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | PropertyChangingRoutedEventArgsT(RoutedEvent, T, T) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | PropertyChangingRoutedEventArgsT(RoutedEvent, T, T, Object) | Initializes a new instance of the PropertyChangingRoutedEventArgs class.
Top
See Also

Reference

PropertyChangingRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


PropertyChangingRoutedEventArgs(T) Constructor (T, T)

PropertyChangingRoutedEventArgsT Constructor (T, T)

Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyChangingRoutedEventArgs(
    T oldValue,
    T newValue
)
Public Sub New (
    oldValue As T,
    newValue As T
)

Parameters

oldValue
Type: T
The previous value of the property being tracked as reported by an event.
newValue
Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangingRoutedEventArgsT Class
PropertyChangingRoutedEventArgsT Overload
ActiproSoftware.Windows Namespace


PropertyChangingRoutedEventArgs(T) Constructor (RoutedEvent, T, T)

PropertyChangingRoutedEventArgsT Constructor (RoutedEvent, T, T)

Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyChangingRoutedEventArgs(
    RoutedEvent routedEvent,
    T oldValue,
    T newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As T,
    newValue As T
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: T
The previous value of the property being tracked as reported by an event.
newValue
Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangingRoutedEventArgsT Class
PropertyChangingRoutedEventArgsT Overload
ActiproSoftware.Windows Namespace


PropertyChangingRoutedEventArgs(T) Constructor (RoutedEvent, T, T, Object)

PropertyChangingRoutedEventArgsT Constructor (RoutedEvent, T, T, Object)

Initializes a new instance of the PropertyChangingRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyChangingRoutedEventArgs(
    RoutedEvent routedEvent,
    T oldValue,
    T newValue,
    Object source
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As T,
    newValue As T,
    source As Object
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: T
The previous value of the property being tracked as reported by an event.
newValue
Type: T
The new value of the property being tracked as reported by an event.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

PropertyChangingRoutedEventArgsT Class
PropertyChangingRoutedEventArgsT Overload
ActiproSoftware.Windows Namespace


PropertyChangingRoutedEventArgs(T) Properties

PropertyChangingRoutedEventArgsT Properties

The PropertyChangingRoutedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled.
Public property | NewValue | Gets or sets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
See Also

Reference

PropertyChangingRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


PropertyChangingRoutedEventArgs(T).Cancel Property

PropertyChangingRoutedEventArgsTCancel Property

Gets or sets a value indicating whether the event should be canceled.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
true to cancel the event; otherwise, false.
See Also

Reference

PropertyChangingRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


PropertyChangingRoutedEventArgs(T).NewValue Property

PropertyChangingRoutedEventArgsTNewValue Property

Gets or sets the new value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T NewValue { get; set; }
Public Property NewValue As T
    Get
    Set

Property Value

Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangingRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


PropertyChangingRoutedEventArgs(T).OldValue Property

PropertyChangingRoutedEventArgsTOldValue Property

Gets the previous value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T OldValue { get; }
Public ReadOnly Property OldValue As T
    Get

Property Value

Type: T
The previous value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangingRoutedEventArgsT Class
ActiproSoftware.Windows Namespace


ResourceHelper Class

Represents a collection of helper methods when working with resources.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsResourceHelper

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class ResourceHelper
Public NotInheritable Class ResourceHelper

The ResourceHelper type exposes the following members.

Methods
Name | Description
GetLocationUri(Assembly, String) | Returns a pack Uri based on the specified parameters, that can be used to construct a Uri.
GetLocationUri(Assembly, String, Boolean, Boolean) | Returns a pack Uri based on the specified parameters, that can be used to construct a Uri.
GetLocationUriString(Assembly, String) | Returns a string-representation of a pack URI based on the specified parameters, that can be used to construct a Uri.
GetLocationUriString(Assembly, String, Boolean, Boolean) | Returns a string-representation of a pack URI based on the specified parameters, that can be used to construct a Uri.
GetLocationUriStringBase | Returns a string-representation of a base pack URI based on the specified parameters, that can be used to construct a Uri.
Top
See Also

Reference

ActiproSoftware.Windows Namespace


ResourceHelper Methods

The ResourceHelper type exposes the following members.

Methods
Name | Description
GetLocationUri(Assembly, String) | Returns a pack Uri based on the specified parameters, that can be used to construct a Uri.
GetLocationUri(Assembly, String, Boolean, Boolean) | Returns a pack Uri based on the specified parameters, that can be used to construct a Uri.
GetLocationUriString(Assembly, String) | Returns a string-representation of a pack URI based on the specified parameters, that can be used to construct a Uri.
GetLocationUriString(Assembly, String, Boolean, Boolean) | Returns a string-representation of a pack URI based on the specified parameters, that can be used to construct a Uri.
GetLocationUriStringBase | Returns a string-representation of a base pack URI based on the specified parameters, that can be used to construct a Uri.
Top
See Also

Reference

ResourceHelper Class
ActiproSoftware.Windows Namespace


ResourceHelper.GetLocationUri Method

ResourceHelperGetLocationUri Method

Overload List
Name | Description
GetLocationUri(Assembly, String) | Returns a pack Uri based on the specified parameters, that can be used to construct a Uri.
GetLocationUri(Assembly, String, Boolean, Boolean) | Returns a pack Uri based on the specified parameters, that can be used to construct a Uri.
Top
See Also

Reference

ResourceHelper Class
ActiproSoftware.Windows Namespace


ResourceHelper.GetLocationUri Method (Assembly, String)

ResourceHelperGetLocationUri Method (Assembly, String)

Returns a pack Uri based on the specified parameters, that can be used to construct a Uri.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Uri GetLocationUri(
    Assembly assembly,
    string relativeLocation
)
Public Shared Function GetLocationUri (
    assembly As Assembly,
    relativeLocation As String
) As Uri

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly that contains the resource.
relativeLocation
Type: SystemString
The relative location of the resource file within the assembly. The location must start NOT with a /, and should be the location from the root of the assembly like:
Copy
Themes/AnimatedProgressBar/AeroNormalColor.xaml
.

Return Value

Type: Uri
A pack Uri.
See Also

Reference

ResourceHelper Class
GetLocationUri Overload
ActiproSoftware.Windows Namespace


ResourceHelper.GetLocationUri Method (Assembly, String, Boolean, Boolean)

ResourceHelperGetLocationUri Method (Assembly, String, Boolean, Boolean)

Returns a pack Uri based on the specified parameters, that can be used to construct a Uri.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Uri GetLocationUri(
    Assembly assembly,
    string relativeLocation,
    bool includePackPrefix,
    bool includeAssemblyVersion
)
Public Shared Function GetLocationUri (
    assembly As Assembly,
    relativeLocation As String,
    includePackPrefix As Boolean,
    includeAssemblyVersion As Boolean
) As Uri

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly that contains the resource.
relativeLocation
Type: SystemString
The relative location of the resource file within the assembly. The location must start NOT with a /, and should be the location from the root of the assembly like:
Copy
Themes/AnimatedProgressBar/AeroNormalColor.xaml
.
includePackPrefix
Type: SystemBoolean
if set to true then the pack URI prefix will be included.
includeAssemblyVersion
Type: SystemBoolean
if set to true then the assembly's version will be included.

Return Value

Type: Uri
A pack Uri.
See Also

Reference

ResourceHelper Class
GetLocationUri Overload
ActiproSoftware.Windows Namespace


ResourceHelper.GetLocationUriString Method

ResourceHelperGetLocationUriString Method

Overload List
Name | Description
GetLocationUriString(Assembly, String) | Returns a string-representation of a pack URI based on the specified parameters, that can be used to construct a Uri.
GetLocationUriString(Assembly, String, Boolean, Boolean) | Returns a string-representation of a pack URI based on the specified parameters, that can be used to construct a Uri.
Top
See Also

Reference

ResourceHelper Class
ActiproSoftware.Windows Namespace


ResourceHelper.GetLocationUriString Method (Assembly, String)

ResourceHelperGetLocationUriString Method (Assembly, String)

Returns a string-representation of a pack URI based on the specified parameters, that can be used to construct a Uri.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string GetLocationUriString(
    Assembly assembly,
    string relativeLocation
)
Public Shared Function GetLocationUriString (
    assembly As Assembly,
    relativeLocation As String
) As String

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly that contains the resource.
relativeLocation
Type: SystemString
The relative location of the resource file within the assembly. The location must start NOT with a /, and should be the location from the root of the assembly like:
Copy
Themes/AnimatedProgressBar/AeroNormalColor.xaml
.

Return Value

Type: String
A string-representation of a pack URI.
See Also

Reference

ResourceHelper Class
GetLocationUriString Overload
ActiproSoftware.Windows Namespace


ResourceHelper.GetLocationUriString Method (Assembly, String, Boolean, Boolean)

ResourceHelperGetLocationUriString Method (Assembly, String, Boolean, Boolean)

Returns a string-representation of a pack URI based on the specified parameters, that can be used to construct a Uri.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string GetLocationUriString(
    Assembly assembly,
    string relativeLocation,
    bool includePackPrefix,
    bool includeAssemblyVersion
)
Public Shared Function GetLocationUriString (
    assembly As Assembly,
    relativeLocation As String,
    includePackPrefix As Boolean,
    includeAssemblyVersion As Boolean
) As String

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly that contains the resource.
relativeLocation
Type: SystemString
The relative location of the resource file within the assembly. The location must start NOT with a /, and should be the location from the root of the assembly like:
Copy
Themes/AnimatedProgressBar/AeroNormalColor.xaml
.
includePackPrefix
Type: SystemBoolean
if set to true then the pack URI prefix will be included.
includeAssemblyVersion
Type: SystemBoolean
if set to true then the assembly's version will be included.

Return Value

Type: String
A string-representation of a pack URI.
See Also

Reference

ResourceHelper Class
GetLocationUriString Overload
ActiproSoftware.Windows Namespace


ResourceHelper.GetLocationUriStringBase Method

ResourceHelperGetLocationUriStringBase Method

Returns a string-representation of a base pack URI based on the specified parameters, that can be used to construct a Uri.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static string GetLocationUriStringBase(
    Assembly assembly
)
Public Shared Function GetLocationUriStringBase (
    assembly As Assembly
) As String

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly that contains the resource.

Return Value

Type: String
A string-representation of a base pack URI.
See Also

Reference

ResourceHelper Class
ActiproSoftware.Windows Namespace


SecureStringPropertyChangedRoutedEventArgs Class

Provides event arguments for a SecureString property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs SecureString
ActiproSoftware.WindowsSecureStringPropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SecureStringPropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<SecureString>
Public Class SecureStringPropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of SecureString)

The SecureStringPropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SecureStringPropertyChangedRoutedEventArgs(SecureString, SecureString) | Initializes a new instance of the SecureStringPropertyChangedRoutedEventArgs class.
Public method | SecureStringPropertyChangedRoutedEventArgs(RoutedEvent, SecureString, SecureString) | Initializes a new instance of the SecureStringPropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


SecureStringPropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | SecureStringPropertyChangedRoutedEventArgs(SecureString, SecureString) | Initializes a new instance of the SecureStringPropertyChangedRoutedEventArgs class.
Public method | SecureStringPropertyChangedRoutedEventArgs(RoutedEvent, SecureString, SecureString) | Initializes a new instance of the SecureStringPropertyChangedRoutedEventArgs class.
Top
See Also

Reference

SecureStringPropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


SecureStringPropertyChangedRoutedEventArgs Constructor (SecureString, SecureString)

Initializes a new instance of the SecureStringPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SecureStringPropertyChangedRoutedEventArgs(
    SecureString oldValue,
    SecureString newValue
)
Public Sub New (
    oldValue As SecureString,
    newValue As SecureString
)

Parameters

oldValue
Type: System.SecuritySecureString
The previous value of the property being tracked as reported by an event.
newValue
Type: System.SecuritySecureString
The new value of the property being tracked as reported by an event.
See Also

Reference

SecureStringPropertyChangedRoutedEventArgs Class
SecureStringPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


SecureStringPropertyChangedRoutedEventArgs Constructor (RoutedEvent, SecureString, SecureString)

Initializes a new instance of the SecureStringPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SecureStringPropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    SecureString oldValue,
    SecureString newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As SecureString,
    newValue As SecureString
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: System.SecuritySecureString
The previous value of the property being tracked as reported by an event.
newValue
Type: System.SecuritySecureString
The new value of the property being tracked as reported by an event.
See Also

Reference

SecureStringPropertyChangedRoutedEventArgs Class
SecureStringPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


SecureStringPropertyChangedRoutedEventArgs Properties

The SecureStringPropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

SecureStringPropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


SecureStringPropertyChangingRoutedEventArgs Class

Provides event arguments for a cancelable SecureString property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangingRoutedEventArgs SecureString
ActiproSoftware.WindowsSecureStringPropertyChangingRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SecureStringPropertyChangingRoutedEventArgs : PropertyChangingRoutedEventArgs<SecureString>
Public Class SecureStringPropertyChangingRoutedEventArgs
    Inherits PropertyChangingRoutedEventArgs(Of SecureString)

The SecureStringPropertyChangingRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SecureStringPropertyChangingRoutedEventArgs(SecureString, SecureString) | Initializes a new instance of the SecureStringPropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | SecureStringPropertyChangingRoutedEventArgs(RoutedEvent, SecureString, SecureString) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | NewValue | Gets or sets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


SecureStringPropertyChangingRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | SecureStringPropertyChangingRoutedEventArgs(SecureString, SecureString) | Initializes a new instance of the SecureStringPropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | SecureStringPropertyChangingRoutedEventArgs(RoutedEvent, SecureString, SecureString) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Top
See Also

Reference

SecureStringPropertyChangingRoutedEventArgs Class
ActiproSoftware.Windows Namespace


SecureStringPropertyChangingRoutedEventArgs Constructor (SecureString, SecureString)

Initializes a new instance of the SecureStringPropertyChangingRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SecureStringPropertyChangingRoutedEventArgs(
    SecureString oldValue,
    SecureString newValue
)
Public Sub New (
    oldValue As SecureString,
    newValue As SecureString
)

Parameters

oldValue
Type: System.SecuritySecureString
The current value of the property.
newValue
Type: System.SecuritySecureString
The new value of the property that will be set if the property change is not cancelled.
See Also

Reference

SecureStringPropertyChangingRoutedEventArgs Class
SecureStringPropertyChangingRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


SecureStringPropertyChangingRoutedEventArgs Constructor (RoutedEvent, SecureString, SecureString)

Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SecureStringPropertyChangingRoutedEventArgs(
    RoutedEvent routedEvent,
    SecureString oldValue,
    SecureString newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As SecureString,
    newValue As SecureString
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: System.SecuritySecureString
The current value of the property.
newValue
Type: System.SecuritySecureString
The new value of the property that will be set if the property change is not cancelled.
See Also

Reference

SecureStringPropertyChangingRoutedEventArgs Class
SecureStringPropertyChangingRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


SecureStringPropertyChangingRoutedEventArgs Properties

The SecureStringPropertyChangingRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | NewValue | Gets or sets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Top
See Also

Reference

SecureStringPropertyChangingRoutedEventArgs Class
ActiproSoftware.Windows Namespace


SecurityHelper Class

Contains security helper methods.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsSecurityHelper

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class SecurityHelper
Public NotInheritable Class SecurityHelper

The SecurityHelper type exposes the following members.

Properties
Name | Description
IsFullTrust | Gets whether the application is in full trust.
Top
See Also

Reference

ActiproSoftware.Windows Namespace


SecurityHelper Properties

The SecurityHelper type exposes the following members.

Properties
Name | Description
IsFullTrust | Gets whether the application is in full trust.
Top
See Also

Reference

SecurityHelper Class
ActiproSoftware.Windows Namespace


SecurityHelper.IsFullTrust Property

SecurityHelperIsFullTrust Property

Gets whether the application is in full trust.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool IsFullTrust { get; }
Public Shared ReadOnly Property IsFullTrust As Boolean
    Get

Property Value

Type: Boolean
true if the application is in full trust; otherwise, false.
See Also

Reference

SecurityHelper Class
ActiproSoftware.Windows Namespace


StringPropertyChangedRoutedEventArgs Class

Provides event arguments for a String property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs String
ActiproSoftware.WindowsStringPropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StringPropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<string>
Public Class StringPropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of String)

The StringPropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StringPropertyChangedRoutedEventArgs(String, String) | Initializes a new instance of the StringPropertyChangedRoutedEventArgs class.
Public method | StringPropertyChangedRoutedEventArgs(RoutedEvent, String, String) | Initializes a new instance of the StringPropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


StringPropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | StringPropertyChangedRoutedEventArgs(String, String) | Initializes a new instance of the StringPropertyChangedRoutedEventArgs class.
Public method | StringPropertyChangedRoutedEventArgs(RoutedEvent, String, String) | Initializes a new instance of the StringPropertyChangedRoutedEventArgs class.
Top
See Also

Reference

StringPropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


StringPropertyChangedRoutedEventArgs Constructor (String, String)

Initializes a new instance of the StringPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StringPropertyChangedRoutedEventArgs(
    string oldValue,
    string newValue
)
Public Sub New (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemString
The new value of the property being tracked as reported by an event.
See Also

Reference

StringPropertyChangedRoutedEventArgs Class
StringPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


StringPropertyChangedRoutedEventArgs Constructor (RoutedEvent, String, String)

Initializes a new instance of the StringPropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StringPropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    string oldValue,
    string newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As String,
    newValue As String
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemString
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemString
The new value of the property being tracked as reported by an event.
See Also

Reference

StringPropertyChangedRoutedEventArgs Class
StringPropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


StringPropertyChangedRoutedEventArgs Properties

The StringPropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

StringPropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows Namespace


StringPropertyChangingRoutedEventArgs Class

Provides event arguments for a cancelable String property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangingRoutedEventArgs String
ActiproSoftware.WindowsStringPropertyChangingRoutedEventArgs

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StringPropertyChangingRoutedEventArgs : PropertyChangingRoutedEventArgs<string>
Public Class StringPropertyChangingRoutedEventArgs
    Inherits PropertyChangingRoutedEventArgs(Of String)

The StringPropertyChangingRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StringPropertyChangingRoutedEventArgs(String, String) | Initializes a new instance of the StringPropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | StringPropertyChangingRoutedEventArgs(RoutedEvent, String, String) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | NewValue | Gets or sets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


StringPropertyChangingRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | StringPropertyChangingRoutedEventArgs(String, String) | Initializes a new instance of the StringPropertyChangingRoutedEventArgs class with the Cancel property set to false.
Public method | StringPropertyChangingRoutedEventArgs(RoutedEvent, String, String) | Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.
Top
See Also

Reference

StringPropertyChangingRoutedEventArgs Class
ActiproSoftware.Windows Namespace


StringPropertyChangingRoutedEventArgs Constructor (String, String)

Initializes a new instance of the StringPropertyChangingRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StringPropertyChangingRoutedEventArgs(
    string oldValue,
    string newValue
)
Public Sub New (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The current value of the property.
newValue
Type: SystemString
The new value of the property that will be set if the property change is not cancelled.
See Also

Reference

StringPropertyChangingRoutedEventArgs Class
StringPropertyChangingRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


StringPropertyChangingRoutedEventArgs Constructor (RoutedEvent, String, String)

Initializes a new instance of the PropertyChangingRoutedEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StringPropertyChangingRoutedEventArgs(
    RoutedEvent routedEvent,
    string oldValue,
    string newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As String,
    newValue As String
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: SystemString
The current value of the property.
newValue
Type: SystemString
The new value of the property that will be set if the property change is not cancelled.
See Also

Reference

StringPropertyChangingRoutedEventArgs Class
StringPropertyChangingRoutedEventArgs Overload
ActiproSoftware.Windows Namespace


StringPropertyChangingRoutedEventArgs Properties

The StringPropertyChangingRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | NewValue | Gets or sets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangingRoutedEventArgsT.)
Top
See Also

Reference

StringPropertyChangingRoutedEventArgs Class
ActiproSoftware.Windows Namespace


Unit Structure

Represents a length measurement.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct Unit
<SerializableAttribute>
Public Structure Unit

The Unit type exposes the following members.

Constructors
 | Name | Description
Public method | Unit(Double) | Initializes a new instance of the Unit struct.
Public method | Unit(String) | Initializes a new instance of the Unit struct.
Public method | Unit(Double, UnitType) | Initializes a new instance of the Unit struct.
Public method | Unit(String, CultureInfo) | Initializes a new instance of the Unit struct.
Top
Properties
 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Type | Gets the type of units used by Value.
Public property | Value | Gets the value.
Top
Methods
 | Name | Description
 | Centimeter | Creates a new Unit instance with the specified centimeters.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetPixels | Gets the number of pixels represented by this Unit using the specified width when the Type is set to Percentage.
 | Inch | Creates a new Unit instance with the specified inches.
 | Parse(String) | Parses the specified string.
 | Parse(String, CultureInfo) | Parses the specified string using the specified CultureInfo.
 | Percentage | Creates a new Unit instance with the specified percentage.
 | Pixel | Creates a new Unit instance with the specified pixels.
 | Point | Creates a new Unit instance with the specified points.
Public method | ToString | Returns a String representation of this instance. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Returns a String representation of this instance using the specified IFormatProvider to convert the Value.
 | ValidateIsGreaterThan | Validates that the object is a Unit greater than the specified number.
 | ValidateIsGreaterThanOrEqual | Validates that the object is a Unit greater than or equal to the specified number.
 | ValidateIsPositive | Validates that the object is a Unit greater than or equal to 0.
Top
Operators
Name | Description
Equality |
(Double to Unit) |
Inequality |
Top
Fields
Name | Description
Empty | Represents an empty Unit. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows Namespace


Unit Constructor

Overload List
 | Name | Description
Public method | Unit(Double) | Initializes a new instance of the Unit struct.
Public method | Unit(String) | Initializes a new instance of the Unit struct.
Public method | Unit(Double, UnitType) | Initializes a new instance of the Unit struct.
Public method | Unit(String, CultureInfo) | Initializes a new instance of the Unit struct.
Top
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit Constructor (Double)

Initializes a new instance of the Unit struct.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit(
    double value
)
Public Sub New (
    value As Double
)

Parameters

value
Type: SystemDouble
The value.
See Also

Reference

Unit Structure
Unit Overload
ActiproSoftware.Windows Namespace


Unit Constructor (String)

Initializes a new instance of the Unit struct.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit(
    string value
)
Public Sub New (
    value As String
)

Parameters

value
Type: SystemString
The value.
See Also

Reference

Unit Structure
Unit Overload
ActiproSoftware.Windows Namespace


Unit Constructor (Double, UnitType)

Initializes a new instance of the Unit struct.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit(
    double value,
    UnitType type
)
Public Sub New (
    value As Double,
    type As UnitType
)

Parameters

value
Type: SystemDouble
The value.
type
Type: ActiproSoftware.WindowsUnitType
The type.
See Also

Reference

Unit Structure
Unit Overload
ActiproSoftware.Windows Namespace


Unit Constructor (String, CultureInfo)

Initializes a new instance of the Unit struct.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit(
    string value,
    CultureInfo culture
)
Public Sub New (
    value As String,
    culture As CultureInfo
)

Parameters

value
Type: SystemString
The value.
culture
Type: System.GlobalizationCultureInfo
The culture.
See Also

Reference

Unit Structure
Unit Overload
ActiproSoftware.Windows Namespace


Unit Properties

The Unit type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Type | Gets the type of units used by Value.
Public property | Value | Gets the value.
Top
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.IsEmpty Property

UnitIsEmpty Property

Gets a value indicating whether this instance is empty.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if this instance is empty; otherwise, false.
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Type Property

UnitType Property

Gets the type of units used by Value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UnitType Type { get; }
Public ReadOnly Property Type As UnitType
    Get

Property Value

Type: UnitType
The type of units.
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Value Property

UnitValue Property

Gets the value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; }
Public ReadOnly Property Value As Double
    Get

Property Value

Type: Double
The value.
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit Methods

The Unit type exposes the following members.

Methods
 | Name | Description
 | Centimeter | Creates a new Unit instance with the specified centimeters.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetPixels | Gets the number of pixels represented by this Unit using the specified width when the Type is set to Percentage.
 | Inch | Creates a new Unit instance with the specified inches.
 | Parse(String) | Parses the specified string.
 | Parse(String, CultureInfo) | Parses the specified string using the specified CultureInfo.
 | Percentage | Creates a new Unit instance with the specified percentage.
 | Pixel | Creates a new Unit instance with the specified pixels.
 | Point | Creates a new Unit instance with the specified points.
Public method | ToString | Returns a String representation of this instance. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Returns a String representation of this instance using the specified IFormatProvider to convert the Value.
 | ValidateIsGreaterThan | Validates that the object is a Unit greater than the specified number.
 | ValidateIsGreaterThanOrEqual | Validates that the object is a Unit greater than or equal to the specified number.
 | ValidateIsPositive | Validates that the object is a Unit greater than or equal to 0.
Top
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Centimeter Method

UnitCentimeter Method

Creates a new Unit instance with the specified centimeters.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit Centimeter(
    double value
)
Public Shared Function Centimeter (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The centimeter value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.Centimeter(System.Double)"]

See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Equals Method

UnitEquals Method

Indicates whether this instance and a specified object are equal.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Another object to compare to.

Return Value

Type: Boolean
true if obj and this instance are the same type and represent the same value; otherwise, false.
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.GetHashCode Method

UnitGetHashCode Method

Returns the hash code for this instance.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.GetPixels Method

UnitGetPixels Method

Gets the number of pixels represented by this Unit using the specified width when the Type is set to Percentage.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double GetPixels(
    double width
)
Public Function GetPixels (
    width As Double
) As Double

Parameters

width
Type: SystemDouble
The width.

Return Value

Type: Double

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.GetPixels(System.Double)"]

See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Inch Method

UnitInch Method

Creates a new Unit instance with the specified inches.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit Inch(
    double value
)
Public Shared Function Inch (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The inch value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.Inch(System.Double)"]

See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Parse Method

UnitParse Method

Overload List
Name | Description
Parse(String) | Parses the specified string.
Parse(String, CultureInfo) | Parses the specified string using the specified CultureInfo.
Top
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Parse Method (String)

UnitParse Method (String)

Parses the specified string.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit Parse(
    string value
)
Public Shared Function Parse (
    value As String
) As Unit

Parameters

value
Type: SystemString
The string to parse.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.Parse(System.String)"]

See Also

Reference

Unit Structure
Parse Overload
ActiproSoftware.Windows Namespace


Unit.Parse Method (String, CultureInfo)

UnitParse Method (String, CultureInfo)

Parses the specified string using the specified CultureInfo.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit Parse(
    string value,
    CultureInfo culture
)
Public Shared Function Parse (
    value As String,
    culture As CultureInfo
) As Unit

Parameters

value
Type: SystemString
The string to parse.
culture
Type: System.GlobalizationCultureInfo
The culture.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.Parse(System.String,System.Globalization.CultureInfo)"]

See Also

Reference

Unit Structure
Parse Overload
ActiproSoftware.Windows Namespace


Unit.Percentage Method

UnitPercentage Method

Creates a new Unit instance with the specified percentage.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit Percentage(
    double value
)
Public Shared Function Percentage (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The percentage value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.Percentage(System.Double)"]

See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Pixel Method

UnitPixel Method

Creates a new Unit instance with the specified pixels.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit Pixel(
    double value
)
Public Shared Function Pixel (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The pixel value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.Pixel(System.Double)"]

See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Point Method

UnitPoint Method

Creates a new Unit instance with the specified points.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit Point(
    double value
)
Public Shared Function Point (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The point value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.Point(System.Double)"]

See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.ToString Method

UnitToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a String representation of this instance. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Returns a String representation of this instance using the specified IFormatProvider to convert the Value.
Top
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.ToString Method

UnitToString Method

Returns a String representation of this instance.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String representation of this instance.
See Also

Reference

Unit Structure
ToString Overload
ActiproSoftware.Windows Namespace


Unit.ToString Method (IFormatProvider)

UnitToString Method (IFormatProvider)

Returns a String representation of this instance using the specified IFormatProvider to convert the Value.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ToString(
    IFormatProvider formatProvider
)
Public Function ToString (
    formatProvider As IFormatProvider
) As String

Parameters

formatProvider
Type: SystemIFormatProvider
The format provider.

Return Value

Type: String

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.ToString(System.IFormatProvider)"]

See Also

Reference

Unit Structure
ToString Overload
ActiproSoftware.Windows Namespace


Unit.ValidateIsGreaterThan Method

UnitValidateIsGreaterThan Method

Validates that the object is a Unit greater than the specified number.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool ValidateIsGreaterThan(
    Object value,
    double min
)
Public Shared Function ValidateIsGreaterThan (
    value As Object,
    min As Double
) As Boolean

Parameters

value
Type: SystemObject
The object to validate.
min
Type: SystemDouble
The number that the value must be greater than.

Return Value

Type: Boolean
true if the validation is successful; otherwise, false.
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.ValidateIsGreaterThanOrEqual Method

UnitValidateIsGreaterThanOrEqual Method

Validates that the object is a Unit greater than or equal to the specified number.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool ValidateIsGreaterThanOrEqual(
    Object value,
    double min
)
Public Shared Function ValidateIsGreaterThanOrEqual (
    value As Object,
    min As Double
) As Boolean

Parameters

value
Type: SystemObject
The object to validate.
min
Type: SystemDouble
The number that the value must be greater than or equal to.

Return Value

Type: Boolean
true if the validation is successful; otherwise, false.
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.ValidateIsPositive Method

UnitValidateIsPositive Method

Validates that the object is a Unit greater than or equal to 0.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool ValidateIsPositive(
    Object value
)
Public Shared Function ValidateIsPositive (
    value As Object
) As Boolean

Parameters

value
Type: SystemObject
The object to validate.

Return Value

Type: Boolean
true if the validation is successful; otherwise, false.
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit Operators and Type Conversions

The Unit type exposes the following members.

Operators
Name | Description
Equality |
(Double to Unit) |
Inequality |
Top
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Equality Operator

UnitEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Unit.op_Equality(ActiproSoftware.Windows.Unit,ActiproSoftware.Windows.Unit)"]

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator ==(
    Unit left,
    Unit right
)
Public Shared Operator = (
    left As Unit,
    right As Unit
) As Boolean

Parameters

left
Type: ActiproSoftware.WindowsUnit

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Windows.Unit.op_Equality(ActiproSoftware.Windows.Unit,ActiproSoftware.Windows.Unit)"]

right
Type: ActiproSoftware.WindowsUnit

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Windows.Unit.op_Equality(ActiproSoftware.Windows.Unit,ActiproSoftware.Windows.Unit)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.op_Equality(ActiproSoftware.Windows.Unit,ActiproSoftware.Windows.Unit)"]

See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit Implicit Conversion (Double to Unit)

Unit Conversion (Double to Unit)

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Unit.op_Implicit(System.Double)~ActiproSoftware.Windows.Unit"]

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static implicit operator Unit (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble

[Missing <param name="value"/> documentation for "M:ActiproSoftware.Windows.Unit.op_Implicit(System.Double)~ActiproSoftware.Windows.Unit"]

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.op_Implicit(System.Double)~ActiproSoftware.Windows.Unit"]

See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Inequality Operator

UnitInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Unit.op_Inequality(ActiproSoftware.Windows.Unit,ActiproSoftware.Windows.Unit)"]

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool operator !=(
    Unit left,
    Unit right
)
Public Shared Operator <> (
    left As Unit,
    right As Unit
) As Boolean

Parameters

left
Type: ActiproSoftware.WindowsUnit

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Windows.Unit.op_Inequality(ActiproSoftware.Windows.Unit,ActiproSoftware.Windows.Unit)"]

right
Type: ActiproSoftware.WindowsUnit

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Windows.Unit.op_Inequality(ActiproSoftware.Windows.Unit,ActiproSoftware.Windows.Unit)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Unit.op_Inequality(ActiproSoftware.Windows.Unit,ActiproSoftware.Windows.Unit)"]

See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit Fields

The Unit type exposes the following members.

Fields
Name | Description
Empty | Represents an empty Unit. This field is read-only.
Top
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


Unit.Empty Field

UnitEmpty Field

Represents an empty Unit. This field is read-only.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly Unit Empty
Public Shared ReadOnly Empty As Unit

Field Value

Type: Unit
See Also

Reference

Unit Structure
ActiproSoftware.Windows Namespace


UnitConverter Class

Converts from a Unit object to an object of another data type and from another type to a Unit object.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.WindowsUnitConverter

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UnitConverter : TypeConverter
Public Class UnitConverter
    Inherits TypeConverter

The UnitConverter type exposes the following members.

Constructors
 | Name | Description
Public method | UnitConverter | Initializes a new instance of the UnitConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows Namespace


UnitConverter Constructor

Initializes a new instance of the UnitConverter class

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UnitConverter()
Public Sub New
See Also

Reference

UnitConverter Class
ActiproSoftware.Windows Namespace


UnitConverter Methods

The UnitConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

UnitConverter Class
ActiproSoftware.Windows Namespace


UnitConverter.CanConvertFrom Method

UnitConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

UnitConverter Class
ActiproSoftware.Windows Namespace


UnitConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

UnitConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

UnitConverter Class
CanConvertFrom Overload
ActiproSoftware.Windows Namespace


UnitConverter.CanConvertTo Method

UnitConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

UnitConverter Class
ActiproSoftware.Windows Namespace


UnitConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

UnitConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: SystemType
A Type that represents the type you want to convert to.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

UnitConverter Class
CanConvertTo Overload
ActiproSoftware.Windows Namespace


UnitConverter.ConvertFrom Method

UnitConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

UnitConverter Class
ActiproSoftware.Windows Namespace


UnitConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

UnitConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
Exceptions
Exception | Condition
NotSupportedException | The conversion cannot be performed.
See Also

Reference

UnitConverter Class
ConvertFrom Overload
ActiproSoftware.Windows Namespace


UnitConverter.ConvertTo Method

UnitConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

UnitConverter Class
ActiproSoftware.Windows Namespace


UnitConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

UnitConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
Exceptions
Exception | Condition
ArgumentNullException | The destinationType parameter is null.
NotSupportedException | The conversion cannot be performed.
See Also

Reference

UnitConverter Class
ConvertTo Overload
ActiproSoftware.Windows Namespace


UnitType Enumeration

Specifies the unit of measurement.

Namespace: ActiproSoftware.Windows
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum UnitType
Public Enumeration UnitType
Members
Member name | Value | Description
Pixel | 1 | Indicates the measurement is in pixels.
Percentage | 2 | Indicates the measurement is a percentage.
Inch | 3 | Indicates the measurement is in inches.
Centimeter | 4 | Indicates the measurement is in centimeters.
Point | 5 | Indicates the measurement is in points.
See Also

Reference

ActiproSoftware.Windows Namespace


ActiproSoftware.Windows.Controls Namespace

Contains some core controls and related classes.
Classes
 | Class | Description
Public class | ActiproLogo | Represents the Actipro company logo.
Public class | AdvancedTextBlock | Represents an advanced text block control that renders a single line of text but has additional highlighting and overflow options.
Public class | AnimatedExpander | Represents an expander with an optional animated expansion.
Public class | AnimatedExpanderDecorator | Represents a Decorator that can be used in an Expander template to provide animated content display.
Public class | AnimatedProgressBar | Represents an animated progress bar control.
Public class | ContextMenuItemRoutedEventArgs | Provides event arguments for a ContextMenu-related routed event.
Public class | CustomDrawElement | Represents a UIElement that is capable of being custom drawn via the handling of its CustomDraw event.
Public class | CustomDrawElementCustomDrawEventArgs | Provides event arguments for performing custom draw of a CustomDrawElement.
Public class | CustomDrawEventArgsT | Provides event arguments for performing custom draw of an element.
Public class | DropShadowChrome | Renders a drop shadow effect.
Public class | DynamicImage | Represents a dynamic Image control implementation that supports auto-grayscaling the image when the control is disabled.
Public class | EditableContentControl | Represents a control that displays content by default but can toggle to an editable mode for editing the content.
Public class | GlassWindow | Provides an implementation of a Window that allows you to extend Aero glass effects into the client area when used in Vista with Aero enabled.
Public class | HintProperties | Provides attached properties that provide hint content for controls
Public class | HorizontalListBox | Represents a horizontal ListBox.
Public class | ImageConverter | Represents a value converter that returns a new Image instance created using a specified URI or BitmapSource.
Public class | ImageTextInfo | Represents an object that has properties for setting large and small image sources, along with a text label.
Public class | OperationStatePropertyChangedRoutedEventArgs | Provides event arguments for a OperationState property change routed event, indicating the old and new values.
Public class | PixelSnapper | Represents a Decorator that measures its contents at integer intervals to help with pixel snapping.
Public class | PopupButton | Represents a popup, or split, button control.
Public class | RadialSlider | Represents a radial slider.
Public class | RadioButtonList | Represents a ListBox that renders its items as a list of radio buttons.
Public class | ReflectionContentControl | Represents a ContentControl that displays its content and a reflection of the content below it.
Public class | ResizableContentControl | Represents a ContentControl that contains a gripper, allowing it to be resized.
Public class | RingSlice | Represents a Path that renders a ring slice.
Public class | RingSpinner | Provides a spinnable ring-shaped busy indicator.
Public class | ZeroSizeContentControl | Represents a ContentControl that can return a zero width or height during its measuring pass.
Interfaces
 | Interface | Description
Public interface | IOrientedElement | Provides the base requirements for an element that has an Orientation property.
Enumerations
 | Enumeration | Description
Public enumeration | ControlResizeMode | Specifies the resize mode for a control.
Public enumeration | ControlUsageContext | Specifies the usage context for a control.
Public enumeration | Corner | Specifies a corners of a rectangle.
Public enumeration | Corners | Specifies zero or more corners of a rectangle as a combination of flags.
Public enumeration | OperationState | Specifies the state of an AnimatedProgressBar control.
Public enumeration | PopupButtonDisplayMode | Specifies the display mode of a PopupButton control.
Public enumeration | ResizeOperation | Specifies a resize operation.
Public enumeration | RoundMode | Specifies the mode of rounding a value.
Public enumeration | Side | Specifies a single side of a rectangle.
Public enumeration | Sides | Specifies zero or more sides of a rectangle as a combination of flags.


ActiproLogo Class

Represents the Actipro company logo.
ActiproLogo
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
ActiproSoftware.Windows.ControlsActiproLogo

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ActiproLogo : UserControl,
    IComponentConnector
Public Class ActiproLogo
    Inherits UserControl
    Implements IComponentConnector

The ActiproLogo type exposes the following members.

Constructors
 | Name | Description
Public method | ActiproLogo | Initializes a new instance of the ActiproLogo class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | InitializeComponent | InitializeComponent
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


ActiproLogo Constructor

Initializes a new instance of the ActiproLogo class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ActiproLogo()
Public Sub New
See Also

Reference

ActiproLogo Class
ActiproSoftware.Windows.Controls Namespace


ActiproLogo Properties

The ActiproLogo type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ActiproLogo Class
ActiproSoftware.Windows.Controls Namespace


ActiproLogo Methods

The ActiproLogo type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | InitializeComponent | InitializeComponent
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproLogo Class
ActiproSoftware.Windows.Controls Namespace


ActiproLogo.InitializeComponent Method

ActiproLogoInitializeComponent Method

InitializeComponent

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void InitializeComponent()
Public Sub InitializeComponent

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ActiproLogo Class
ActiproSoftware.Windows.Controls Namespace


ActiproLogo Events

The ActiproLogo type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

ActiproLogo Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock Class

Represents an advanced text block control that renders a single line of text but has additional highlighting and overflow options.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.ControlsAdvancedTextBlock

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTextBlock : Control
Public Class AdvancedTextBlock
    Inherits Control

The AdvancedTextBlock type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTextBlock | Initializes an instance of the AdvancedTextBlock class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Captures | Gets or sets the collection of text captures to highlight.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasToolTipOnOverflow | Gets or sets whether the control's tool tip is automatically set to the Text value when overflowed.
Public property | HighlightBackground | Gets or sets the background Brush to use for highlighted capture ranges.
Public property | HighlightFontWeight | Gets or sets the FontWeight to use for highlighted capture ranges.
Public property | HighlightForeground | Gets or sets the foreground Brush to use for highlighted capture ranges.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOverflowed | Gets whether the text is overflowed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text string to render.
Public property | TextTrimming | Gets or sets the TextTrimming mode to use.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CapturesProperty | Identifies the Captures dependency property. This field is read-only.
HasToolTipOnOverflowProperty | Identifies the HasToolTipOnOverflow dependency property. This field is read-only.
HighlightBackgroundProperty | Identifies the HighlightBackground dependency property. This field is read-only.
HighlightFontWeightProperty | Identifies the HighlightFontWeight dependency property. This field is read-only.
HighlightForegroundProperty | Identifies the HighlightForeground dependency property. This field is read-only.
IsOverflowedProperty | Identifies the IsOverflowed dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
TextTrimmingProperty | Identifies the TextTrimming dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock Constructor

Initializes an instance of the AdvancedTextBlock class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTextBlock()
Public Sub New
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock Properties

The AdvancedTextBlock type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Captures | Gets or sets the collection of text captures to highlight.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasToolTipOnOverflow | Gets or sets whether the control's tool tip is automatically set to the Text value when overflowed.
Public property | HighlightBackground | Gets or sets the background Brush to use for highlighted capture ranges.
Public property | HighlightFontWeight | Gets or sets the FontWeight to use for highlighted capture ranges.
Public property | HighlightForeground | Gets or sets the foreground Brush to use for highlighted capture ranges.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOverflowed | Gets whether the text is overflowed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text string to render.
Public property | TextTrimming | Gets or sets the TextTrimming mode to use.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.Captures Property

AdvancedTextBlockCaptures Property

Gets or sets the collection of text captures to highlight.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<StringFilterCapture> Captures { get; set; }
Public Property Captures As IEnumerable(Of StringFilterCapture)
    Get
    Set

Property Value

Type: IEnumerable StringFilterCapture
The collection of text captures to highlight.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.HasToolTipOnOverflow Property

AdvancedTextBlockHasToolTipOnOverflow Property

Gets or sets whether the control's tool tip is automatically set to the Text value when overflowed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasToolTipOnOverflow { get; set; }
Public Property HasToolTipOnOverflow As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control's tool tip is automatically set to the Text value when overflowed; otherwise, false. The default value is true.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.HighlightBackground Property

AdvancedTextBlockHighlightBackground Property

Gets or sets the background Brush to use for highlighted capture ranges.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush HighlightBackground { get; set; }
Public Property HighlightBackground As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush to use for highlighted capture ranges.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.HighlightFontWeight Property

AdvancedTextBlockHighlightFontWeight Property

Gets or sets the FontWeight to use for highlighted capture ranges.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontWeight HighlightFontWeight { get; set; }
Public Property HighlightFontWeight As FontWeight
    Get
    Set

Property Value

Type: FontWeight
The FontWeight to use for highlighted capture ranges. The default value is Bold.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.HighlightForeground Property

AdvancedTextBlockHighlightForeground Property

Gets or sets the foreground Brush to use for highlighted capture ranges.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush HighlightForeground { get; set; }
Public Property HighlightForeground As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush to use for highlighted capture ranges.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.IsOverflowed Property

AdvancedTextBlockIsOverflowed Property

Gets whether the text is overflowed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOverflowed { get; }
Public ReadOnly Property IsOverflowed As Boolean
    Get

Property Value

Type: Boolean
true if the text is overflowed; otherwise, false.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.Text Property

AdvancedTextBlockText Property

Gets or sets the text string to render.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text string to render.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.TextTrimming Property

AdvancedTextBlockTextTrimming Property

Gets or sets the TextTrimming mode to use.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextTrimming TextTrimming { get; set; }
Public Property TextTrimming As TextTrimming
    Get
    Set

Property Value

Type: TextTrimming
The TextTrimming mode to use. The default value is CharacterEllipsis.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock Methods

The AdvancedTextBlock type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.ArrangeOverride Method

AdvancedTextBlockArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.OnApplyTemplate Method

AdvancedTextBlockOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.OnCreateAutomationPeer Method

AdvancedTextBlockOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock Events

The AdvancedTextBlock type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock Fields

The AdvancedTextBlock type exposes the following members.

Fields
Name | Description
CapturesProperty | Identifies the Captures dependency property. This field is read-only.
HasToolTipOnOverflowProperty | Identifies the HasToolTipOnOverflow dependency property. This field is read-only.
HighlightBackgroundProperty | Identifies the HighlightBackground dependency property. This field is read-only.
HighlightFontWeightProperty | Identifies the HighlightFontWeight dependency property. This field is read-only.
HighlightForegroundProperty | Identifies the HighlightForeground dependency property. This field is read-only.
IsOverflowedProperty | Identifies the IsOverflowed dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
TextTrimmingProperty | Identifies the TextTrimming dependency property. This field is read-only.
Top
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.CapturesProperty Field

AdvancedTextBlockCapturesProperty Field

Identifies the Captures dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CapturesProperty
Public Shared ReadOnly CapturesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Captures dependency property.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.HasToolTipOnOverflowProperty Field

AdvancedTextBlockHasToolTipOnOverflowProperty Field

Identifies the HasToolTipOnOverflow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasToolTipOnOverflowProperty
Public Shared ReadOnly HasToolTipOnOverflowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasToolTipOnOverflow dependency property.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.HighlightBackgroundProperty Field

AdvancedTextBlockHighlightBackgroundProperty Field

Identifies the HighlightBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightBackgroundProperty
Public Shared ReadOnly HighlightBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightBackground dependency property.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.HighlightFontWeightProperty Field

AdvancedTextBlockHighlightFontWeightProperty Field

Identifies the HighlightFontWeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightFontWeightProperty
Public Shared ReadOnly HighlightFontWeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightFontWeight dependency property.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.HighlightForegroundProperty Field

AdvancedTextBlockHighlightForegroundProperty Field

Identifies the HighlightForeground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightForegroundProperty
Public Shared ReadOnly HighlightForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightForeground dependency property.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.IsOverflowedProperty Field

AdvancedTextBlockIsOverflowedProperty Field

Identifies the IsOverflowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOverflowedProperty
Public Shared ReadOnly IsOverflowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOverflowed dependency property.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.TextProperty Field

AdvancedTextBlockTextProperty Field

Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AdvancedTextBlock.TextTrimmingProperty Field

AdvancedTextBlockTextTrimmingProperty Field

Identifies the TextTrimming dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextTrimmingProperty
Public Shared ReadOnly TextTrimmingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextTrimming dependency property.
See Also

Reference

AdvancedTextBlock Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander Class

Represents an expander with an optional animated expansion.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsHeaderedContentControl
System.Windows.ControlsExpander
ActiproSoftware.Windows.ControlsAnimatedExpander

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AnimatedExpander : Expander
Public Class AnimatedExpander
    Inherits Expander

The AnimatedExpander type exposes the following members.

Constructors
 | Name | Description
Public method | AnimatedExpander | Initializes a new instance of the AnimatedExpander class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanMeasureCollapsedContent | Gets or sets whether the expander will use the width measurement of collapsed content when calculating its own width. This is a dependency property.
Public property | CollapseDuration | Gets or sets the Duration of the collapse animation. This is a dependency property.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExpandDirection | Gets or sets the direction in which the Expander content window opens. (Inherited from Expander.)
Public property | ExpandDuration | Gets or sets the Duration of the expand animation. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasHeader | Gets a value that indicates whether the header is null. (Inherited from HeaderedContentControl.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderContextMenu | Gets or sets the ContextMenu used for the header. This is a dependency property.
Public property | HeaderCornerRadius | Gets or sets the corner radius used by the header. This is a dependency property.
Public property | HeaderPadding | Gets or sets the Thickness of the padding around header content. This is a dependency property.
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAutoCollapseOnBlurEnabled | Gets or sets whether the expander will auto-collapse when focus leaves it. This is a dependency property.
Public property | IsAutoExpandOnFocusEnabled | Gets or sets whether the expander will auto-expand when focus enters it. This is a dependency property.
Public property | IsAutoFocusOnExpandEnabled | Gets or sets whether focus will attempt to be set in the content of the expander following the completion of the expansion animation. This is a dependency property.
Public property | IsExpanded | Gets or sets whether the Expander content window is visible. (Inherited from Expander.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCollapsed | Raises the Collapsed event when the IsExpanded property changes from true to false. (Inherited from Expander.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates the implementation of AutomationPeer for the Expander control. (Inherited from Expander.)
Protected method | OnExpanded | Raises the Expanded event when the IsExpanded property changes from false to true. (Inherited from Expander.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Collapsed | Occurs when the content window of an Expander control closes and only the Header is visible. (Inherited from Expander.)
Public event | Expanded | Occurs when the content window of an Expander control opens to display both its header and content. (Inherited from Expander.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CanMeasureCollapsedContentProperty | Identifies the CanMeasureCollapsedContent dependency property. This field is read-only.
CollapseDurationProperty | Identifies the CollapseDuration dependency property. This field is read-only.
ExpandDurationProperty | Identifies the ExpandDuration dependency property. This field is read-only.
HeaderContextMenuProperty | Identifies the HeaderContextMenu dependency property. This field is read-only.
HeaderCornerRadiusProperty | Identifies the HeaderCornerRadius dependency property. This field is read-only.
HeaderPaddingProperty | Identifies the HeaderPadding dependency property. This field is read-only.
IsAutoCollapseOnBlurEnabledProperty | Identifies the IsAutoCollapseOnBlurEnabled dependency property. This field is read-only.
IsAutoExpandOnFocusEnabledProperty | Identifies the IsAutoExpandOnFocusEnabled dependency property. This field is read-only.
IsAutoFocusOnExpandEnabledProperty | Identifies the IsAutoFocusOnExpandEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the AnimatedExpander documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


AnimatedExpander Constructor

Initializes a new instance of the AnimatedExpander class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AnimatedExpander()
Public Sub New
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander Properties

The AnimatedExpander type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanMeasureCollapsedContent | Gets or sets whether the expander will use the width measurement of collapsed content when calculating its own width. This is a dependency property.
Public property | CollapseDuration | Gets or sets the Duration of the collapse animation. This is a dependency property.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExpandDirection | Gets or sets the direction in which the Expander content window opens. (Inherited from Expander.)
Public property | ExpandDuration | Gets or sets the Duration of the expand animation. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasHeader | Gets a value that indicates whether the header is null. (Inherited from HeaderedContentControl.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderContextMenu | Gets or sets the ContextMenu used for the header. This is a dependency property.
Public property | HeaderCornerRadius | Gets or sets the corner radius used by the header. This is a dependency property.
Public property | HeaderPadding | Gets or sets the Thickness of the padding around header content. This is a dependency property.
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAutoCollapseOnBlurEnabled | Gets or sets whether the expander will auto-collapse when focus leaves it. This is a dependency property.
Public property | IsAutoExpandOnFocusEnabled | Gets or sets whether the expander will auto-expand when focus enters it. This is a dependency property.
Public property | IsAutoFocusOnExpandEnabled | Gets or sets whether focus will attempt to be set in the content of the expander following the completion of the expansion animation. This is a dependency property.
Public property | IsExpanded | Gets or sets whether the Expander content window is visible. (Inherited from Expander.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.CanMeasureCollapsedContent Property

AnimatedExpanderCanMeasureCollapsedContent Property

Gets or sets whether the expander will use the width measurement of collapsed content when calculating its own width. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMeasureCollapsedContent { get; set; }
Public Property CanMeasureCollapsedContent As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the expander will use the width measurement of collapsed content when calculating its own width; otherwise, false. The default value is true.
Remarks
When true, a consistent width will be maintained when collapsed. When false, the expander will load faster (if collapsed) since less measuring is taking place.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.CollapseDuration Property

AnimatedExpanderCollapseDuration Property

Gets or sets the Duration of the collapse animation. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration CollapseDuration { get; set; }
Public Property CollapseDuration As Duration
    Get
    Set

Property Value

Type: Duration
The Duration of the collapse animation. The default value is 250 milliseconds.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.ExpandDuration Property

AnimatedExpanderExpandDuration Property

Gets or sets the Duration of the expand animation. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration ExpandDuration { get; set; }
Public Property ExpandDuration As Duration
    Get
    Set

Property Value

Type: Duration
The Duration of the expand animation. The default value is 250 milliseconds.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.HeaderContextMenu Property

AnimatedExpanderHeaderContextMenu Property

Gets or sets the ContextMenu used for the header. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextMenu HeaderContextMenu { get; set; }
Public Property HeaderContextMenu As ContextMenu
    Get
    Set

Property Value

Type: ContextMenu
The ContextMenu used for the header. The default value is .
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.HeaderCornerRadius Property

AnimatedExpanderHeaderCornerRadius Property

Gets or sets the corner radius used by the header. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius HeaderCornerRadius { get; set; }
Public Property HeaderCornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius used by the header. The default value is 0,0,0,0.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.HeaderPadding Property

AnimatedExpanderHeaderPadding Property

Gets or sets the Thickness of the padding around header content. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness HeaderPadding { get; set; }
Public Property HeaderPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the padding around header content. The default value is 0,0,0,0
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.IsAutoCollapseOnBlurEnabled Property

AnimatedExpanderIsAutoCollapseOnBlurEnabled Property

Gets or sets whether the expander will auto-collapse when focus leaves it. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAutoCollapseOnBlurEnabled { get; set; }
Public Property IsAutoCollapseOnBlurEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the expander will auto-collapse when focus leaves it; otherwise, false. The default value is false.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.IsAutoExpandOnFocusEnabled Property

AnimatedExpanderIsAutoExpandOnFocusEnabled Property

Gets or sets whether the expander will auto-expand when focus enters it. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAutoExpandOnFocusEnabled { get; set; }
Public Property IsAutoExpandOnFocusEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the expander will auto-expand when focus enters it; otherwise, false. The default value is false.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.IsAutoFocusOnExpandEnabled Property

AnimatedExpanderIsAutoFocusOnExpandEnabled Property

Gets or sets whether focus will attempt to be set in the content of the expander following the completion of the expansion animation. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAutoFocusOnExpandEnabled { get; set; }
Public Property IsAutoFocusOnExpandEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if focus will be set; otherwise, false. The default value is false.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander Methods

The AnimatedExpander type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCollapsed | Raises the Collapsed event when the IsExpanded property changes from true to false. (Inherited from Expander.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates the implementation of AutomationPeer for the Expander control. (Inherited from Expander.)
Protected method | OnExpanded | Raises the Expanded event when the IsExpanded property changes from false to true. (Inherited from Expander.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.OnIsKeyboardFocusWithinChanged Method

AnimatedExpanderOnIsKeyboardFocusWithinChanged Method

Reports that the IsKeyboardFocusWithin property changed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
A DependencyPropertyChangedEventArgs that contains the event data.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander Events

The AnimatedExpander type exposes the following members.

Events
 | Name | Description
Public event | Collapsed | Occurs when the content window of an Expander control closes and only the Header is visible. (Inherited from Expander.)
Public event | Expanded | Occurs when the content window of an Expander control opens to display both its header and content. (Inherited from Expander.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander Fields

The AnimatedExpander type exposes the following members.

Fields
Name | Description
CanMeasureCollapsedContentProperty | Identifies the CanMeasureCollapsedContent dependency property. This field is read-only.
CollapseDurationProperty | Identifies the CollapseDuration dependency property. This field is read-only.
ExpandDurationProperty | Identifies the ExpandDuration dependency property. This field is read-only.
HeaderContextMenuProperty | Identifies the HeaderContextMenu dependency property. This field is read-only.
HeaderCornerRadiusProperty | Identifies the HeaderCornerRadius dependency property. This field is read-only.
HeaderPaddingProperty | Identifies the HeaderPadding dependency property. This field is read-only.
IsAutoCollapseOnBlurEnabledProperty | Identifies the IsAutoCollapseOnBlurEnabled dependency property. This field is read-only.
IsAutoExpandOnFocusEnabledProperty | Identifies the IsAutoExpandOnFocusEnabled dependency property. This field is read-only.
IsAutoFocusOnExpandEnabledProperty | Identifies the IsAutoFocusOnExpandEnabled dependency property. This field is read-only.
Top
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.CanMeasureCollapsedContentProperty Field

AnimatedExpanderCanMeasureCollapsedContentProperty Field

Identifies the CanMeasureCollapsedContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanMeasureCollapsedContentProperty
Public Shared ReadOnly CanMeasureCollapsedContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanMeasureCollapsedContent dependency property.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.CollapseDurationProperty Field

AnimatedExpanderCollapseDurationProperty Field

Identifies the CollapseDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CollapseDurationProperty
Public Shared ReadOnly CollapseDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CollapseDuration dependency property.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.ExpandDurationProperty Field

AnimatedExpanderExpandDurationProperty Field

Identifies the ExpandDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ExpandDurationProperty
Public Shared ReadOnly ExpandDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ExpandDuration dependency property.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.HeaderContextMenuProperty Field

AnimatedExpanderHeaderContextMenuProperty Field

Identifies the HeaderContextMenu dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderContextMenuProperty
Public Shared ReadOnly HeaderContextMenuProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderContextMenu dependency property.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.HeaderCornerRadiusProperty Field

AnimatedExpanderHeaderCornerRadiusProperty Field

Identifies the HeaderCornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderCornerRadiusProperty
Public Shared ReadOnly HeaderCornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderCornerRadius dependency property.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.HeaderPaddingProperty Field

AnimatedExpanderHeaderPaddingProperty Field

Identifies the HeaderPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderPaddingProperty
Public Shared ReadOnly HeaderPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderPadding dependency property.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.IsAutoCollapseOnBlurEnabledProperty Field

AnimatedExpanderIsAutoCollapseOnBlurEnabledProperty Field

Identifies the IsAutoCollapseOnBlurEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoCollapseOnBlurEnabledProperty
Public Shared ReadOnly IsAutoCollapseOnBlurEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoCollapseOnBlurEnabled dependency property.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.IsAutoExpandOnFocusEnabledProperty Field

AnimatedExpanderIsAutoExpandOnFocusEnabledProperty Field

Identifies the IsAutoExpandOnFocusEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoExpandOnFocusEnabledProperty
Public Shared ReadOnly IsAutoExpandOnFocusEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoExpandOnFocusEnabled dependency property.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpander.IsAutoFocusOnExpandEnabledProperty Field

AnimatedExpanderIsAutoFocusOnExpandEnabledProperty Field

Identifies the IsAutoFocusOnExpandEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoFocusOnExpandEnabledProperty
Public Shared ReadOnly IsAutoFocusOnExpandEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoFocusOnExpandEnabled dependency property.
See Also

Reference

AnimatedExpander Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator Class

Represents a Decorator that can be used in an Expander template to provide animated content display.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsDecorator
ActiproSoftware.Windows.ControlsAnimatedExpanderDecorator

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AnimatedExpanderDecorator : Decorator
Public Class AnimatedExpanderDecorator
    Inherits Decorator

The AnimatedExpanderDecorator type exposes the following members.

Constructors
 | Name | Description
Public method | AnimatedExpanderDecorator | Initializes a new instance of the AnimatedExpanderDecorator class
Top
Properties
 | Name | Description
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | CollapseDuration | Gets or sets the Duration of the collapse animation. This is a dependency property.
Public property | CollapsedVisibility | Gets or sets the Visibility of the decorator when IsExpanded is false. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExpandDirection | Gets or sets the ExpandDirection of the expansion. This is a dependency property.
Public property | ExpandDuration | Gets or sets the Duration of the expand animation. This is a dependency property.
Public property | IsExpanded | Gets or sets whether the contents of the decorator are expanded. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides DecoratorArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetCollapseDuration | Gets the value of the CollapseDuration attached property for the specified object.
 | GetExpandDuration | Gets the value of the ExpandDuration attached property for the specified object.
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides DecoratorMeasureOverride(Size).)
Protected method | OnCollapseAnimationCompleted | Raises the CollapseAnimationCompleted event.
Protected method | OnExpansionAnimationCompleted | Raises the ExpansionAnimationCompleted event.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetCollapseDuration | Sets the value of the CollapseDuration attached property to the specified object.
 | SetExpandDuration | Sets the value of the ExpandDuration attached property to the specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CollapseAnimationCompleted | Occurs when the expansion animation has completed.
Public event | ExpansionAnimationCompleted | Occurs when the expansion animation has completed.
Top
Fields
Name | Description
CollapseAnimationCompletedEvent | Identifies the CollapseAnimationCompleted routed event. This field is read-only.
CollapseDurationProperty | Identifies the CollapseDuration dependency property. This field is read-only.
CollapsedVisibilityProperty | Identifies the CollapsedVisibility dependency property. This field is read-only.
ExpandDirectionProperty | Identifies the ExpandDirection dependency property. This field is read-only.
ExpandDurationProperty | Identifies the ExpandDuration dependency property. This field is read-only.
ExpansionAnimationCompletedEvent | Identifies the ExpansionAnimationCompleted routed event. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator Constructor

Initializes a new instance of the AnimatedExpanderDecorator class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AnimatedExpanderDecorator()
Public Sub New
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator Properties

The AnimatedExpanderDecorator type exposes the following members.

Properties
 | Name | Description
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | CollapseDuration | Gets or sets the Duration of the collapse animation. This is a dependency property.
Public property | CollapsedVisibility | Gets or sets the Visibility of the decorator when IsExpanded is false. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExpandDirection | Gets or sets the ExpandDirection of the expansion. This is a dependency property.
Public property | ExpandDuration | Gets or sets the Duration of the expand animation. This is a dependency property.
Public property | IsExpanded | Gets or sets whether the contents of the decorator are expanded. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.CollapseDuration Property

AnimatedExpanderDecoratorCollapseDuration Property

Gets or sets the Duration of the collapse animation. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration CollapseDuration { get; set; }
Public Property CollapseDuration As Duration
    Get
    Set

Property Value

Type: Duration
The Duration of the collapse animation. The default value is 250 milliseconds.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.CollapsedVisibility Property

AnimatedExpanderDecoratorCollapsedVisibility Property

Gets or sets the Visibility of the decorator when IsExpanded is false. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Visibility CollapsedVisibility { get; set; }
Public Property CollapsedVisibility As Visibility
    Get
    Set

Property Value

Type: Visibility
The Visibility of the decorator when IsExpanded is false. The default value is Hidden.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.ExpandDirection Property

AnimatedExpanderDecoratorExpandDirection Property

Gets or sets the ExpandDirection of the expansion. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpandDirection ExpandDirection { get; set; }
Public Property ExpandDirection As ExpandDirection
    Get
    Set

Property Value

Type: ExpandDirection
The ExpandDirection of the expansion. The default value is ExpandDirection.Down.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.ExpandDuration Property

AnimatedExpanderDecoratorExpandDuration Property

Gets or sets the Duration of the expand animation. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration ExpandDuration { get; set; }
Public Property ExpandDuration As Duration
    Get
    Set

Property Value

Type: Duration
The Duration of the expand animation. The default value is 250 milliseconds.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.IsExpanded Property

AnimatedExpanderDecoratorIsExpanded Property

Gets or sets whether the contents of the decorator are expanded. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsExpanded { get; set; }
Public Property IsExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the contents of the decorator are expanded; otherwise, false.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator Methods

The AnimatedExpanderDecorator type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides DecoratorArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetCollapseDuration | Gets the value of the CollapseDuration attached property for the specified object.
 | GetExpandDuration | Gets the value of the ExpandDuration attached property for the specified object.
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides DecoratorMeasureOverride(Size).)
Protected method | OnCollapseAnimationCompleted | Raises the CollapseAnimationCompleted event.
Protected method | OnExpansionAnimationCompleted | Raises the ExpansionAnimationCompleted event.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetCollapseDuration | Sets the value of the CollapseDuration attached property to the specified object.
 | SetExpandDuration | Sets the value of the ExpandDuration attached property to the specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.ArrangeOverride Method

AnimatedExpanderDecoratorArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size arrangeSize
)
Protected Overrides Function ArrangeOverride (
    arrangeSize As Size
) As Size

Parameters

arrangeSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.GetCollapseDuration Method

AnimatedExpanderDecoratorGetCollapseDuration Method

Gets the value of the CollapseDuration attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Duration GetCollapseDuration(
    DependencyObject obj
)
Public Shared Function GetCollapseDuration (
    obj As DependencyObject
) As Duration

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Duration
The object's value.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.GetExpandDuration Method

AnimatedExpanderDecoratorGetExpandDuration Method

Gets the value of the ExpandDuration attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Duration GetExpandDuration(
    DependencyObject obj
)
Public Shared Function GetExpandDuration (
    obj As DependencyObject
) As Duration

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Duration
The object's value.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.MeasureOverride Method

AnimatedExpanderDecoratorMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.OnCollapseAnimationCompleted Method

AnimatedExpanderDecoratorOnCollapseAnimationCompleted Method

Raises the CollapseAnimationCompleted event.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnCollapseAnimationCompleted()
Protected Overridable Sub OnCollapseAnimationCompleted
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.OnExpansionAnimationCompleted Method

AnimatedExpanderDecoratorOnExpansionAnimationCompleted Method

Raises the ExpansionAnimationCompleted event.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnExpansionAnimationCompleted()
Protected Overridable Sub OnExpansionAnimationCompleted
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.SetCollapseDuration Method

AnimatedExpanderDecoratorSetCollapseDuration Method

Sets the value of the CollapseDuration attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetCollapseDuration(
    DependencyObject obj,
    Duration value
)
Public Shared Sub SetCollapseDuration (
    obj As DependencyObject,
    value As Duration
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: System.WindowsDuration
The value to set.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.SetExpandDuration Method

AnimatedExpanderDecoratorSetExpandDuration Method

Sets the value of the ExpandDuration attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetExpandDuration(
    DependencyObject obj,
    Duration value
)
Public Shared Sub SetExpandDuration (
    obj As DependencyObject,
    value As Duration
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: System.WindowsDuration
The value to set.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator Events

The AnimatedExpanderDecorator type exposes the following members.

Events
 | Name | Description
Public event | CollapseAnimationCompleted | Occurs when the expansion animation has completed.
Public event | ExpansionAnimationCompleted | Occurs when the expansion animation has completed.
Top
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.CollapseAnimationCompleted Event

AnimatedExpanderDecoratorCollapseAnimationCompleted Event

Occurs when the expansion animation has completed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler CollapseAnimationCompleted
Public Event CollapseAnimationCompleted As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.ExpansionAnimationCompleted Event

AnimatedExpanderDecoratorExpansionAnimationCompleted Event

Occurs when the expansion animation has completed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler ExpansionAnimationCompleted
Public Event ExpansionAnimationCompleted As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator Fields

The AnimatedExpanderDecorator type exposes the following members.

Fields
Name | Description
CollapseAnimationCompletedEvent | Identifies the CollapseAnimationCompleted routed event. This field is read-only.
CollapseDurationProperty | Identifies the CollapseDuration dependency property. This field is read-only.
CollapsedVisibilityProperty | Identifies the CollapsedVisibility dependency property. This field is read-only.
ExpandDirectionProperty | Identifies the ExpandDirection dependency property. This field is read-only.
ExpandDurationProperty | Identifies the ExpandDuration dependency property. This field is read-only.
ExpansionAnimationCompletedEvent | Identifies the ExpansionAnimationCompleted routed event. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
Top
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.CollapseAnimationCompletedEvent Field

AnimatedExpanderDecoratorCollapseAnimationCompletedEvent Field

Identifies the CollapseAnimationCompleted routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent CollapseAnimationCompletedEvent
Public Shared ReadOnly CollapseAnimationCompletedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the CollapseAnimationCompleted routed event.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.CollapseDurationProperty Field

AnimatedExpanderDecoratorCollapseDurationProperty Field

Identifies the CollapseDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CollapseDurationProperty
Public Shared ReadOnly CollapseDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CollapseDuration dependency property.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.CollapsedVisibilityProperty Field

AnimatedExpanderDecoratorCollapsedVisibilityProperty Field

Identifies the CollapsedVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CollapsedVisibilityProperty
Public Shared ReadOnly CollapsedVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CollapsedVisibility dependency property.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.ExpandDirectionProperty Field

AnimatedExpanderDecoratorExpandDirectionProperty Field

Identifies the ExpandDirection dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ExpandDirectionProperty
Public Shared ReadOnly ExpandDirectionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ExpandDirection dependency property.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.ExpandDurationProperty Field

AnimatedExpanderDecoratorExpandDurationProperty Field

Identifies the ExpandDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ExpandDurationProperty
Public Shared ReadOnly ExpandDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ExpandDuration dependency property.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.ExpansionAnimationCompletedEvent Field

AnimatedExpanderDecoratorExpansionAnimationCompletedEvent Field

Identifies the ExpansionAnimationCompleted routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ExpansionAnimationCompletedEvent
Public Shared ReadOnly ExpansionAnimationCompletedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ExpansionAnimationCompleted routed event.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedExpanderDecorator.IsExpandedProperty Field

AnimatedExpanderDecoratorIsExpandedProperty Field

Identifies the IsExpanded dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsExpandedProperty
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsExpanded dependency property.
See Also

Reference

AnimatedExpanderDecorator Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar Class

Represents an animated progress bar control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesRangeBase
ActiproSoftware.Windows.ControlsAnimatedProgressBar

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AnimatedProgressBar : RangeBase
Public Class AnimatedProgressBar
    Inherits RangeBase

The AnimatedProgressBar type exposes the following members.

Constructors
 | Name | Description
Public method | AnimatedProgressBar | Initializes a new instance of the AnimatedProgressBar class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DecreaseDuration | Gets or sets the Duration of the decrease animation. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncreaseDuration | Gets or sets the Duration of the increase animation. This is a dependency property.
Public property | IsAnimationEnabled | Gets or sets value indicating whether the progress bar should animate Value changes. This is a dependency property.
Public property | IsCompleted | Gets a value indicating whether Value is equal to Maximum. This is a dependency property.
Public property | IsContinuous | Gets or sets value indicating whether the progress bar should render a continuous or segmented indicator. This is a dependency property.
Public property | IsIndeterminate | Gets or sets a value indicating whether the AnimatedProgressBar shows actual values or generic, continuous progress feedback. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Orientation | Gets or sets the orientation of a AnimatedProgressBar: horizontal or vertical. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | State | Gets or sets the state of the AnimatedProgressBar. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Attempts to locate and initialize the PART_Track and PART_Indicator parts from the applied template. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Creates an appropriate AnimatedProgressBarAutomationPeer for this control as part of the WPF infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMaximumChanged | Called when the Maximum property changes. (Inherited from RangeBase.)
Protected method | OnMinimumChanged | Called when the Minimum property changes. (Inherited from RangeBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnStateChanged | Invoked when the State property is changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged routed event. (Overrides RangeBaseOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateProgressBarIndicatorLength | Updates the length of the PART_Indicator element.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | StateChanged | Occurs when the StateChanged is changed.
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
Fields
Name | Description
DecreaseDurationProperty | Identifies the DecreaseDuration dependency property. This field is read-only.
IncreaseDurationProperty | Identifies the IncreaseDuration dependency property. This field is read-only.
IsAnimationEnabledProperty | Identifies the IsAnimationEnabled dependency property. This field is read-only.
IsCompletedProperty | Identifies the read-only IsCompleted dependency property. This field is read-only.
IsContinuousProperty | Identifies the IsContinuous dependency property. This field is read-only.
IsIndeterminateProperty | Identifies the IsIndeterminate dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
StateChangedEvent | Identifies the StateChanged routed event. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the AnimatedProgressBar documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar Constructor

Initializes a new instance of the AnimatedProgressBar class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AnimatedProgressBar()
Public Sub New
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar Properties

The AnimatedProgressBar type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DecreaseDuration | Gets or sets the Duration of the decrease animation. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncreaseDuration | Gets or sets the Duration of the increase animation. This is a dependency property.
Public property | IsAnimationEnabled | Gets or sets value indicating whether the progress bar should animate Value changes. This is a dependency property.
Public property | IsCompleted | Gets a value indicating whether Value is equal to Maximum. This is a dependency property.
Public property | IsContinuous | Gets or sets value indicating whether the progress bar should render a continuous or segmented indicator. This is a dependency property.
Public property | IsIndeterminate | Gets or sets a value indicating whether the AnimatedProgressBar shows actual values or generic, continuous progress feedback. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Orientation | Gets or sets the orientation of a AnimatedProgressBar: horizontal or vertical. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | State | Gets or sets the state of the AnimatedProgressBar. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.DecreaseDuration Property

AnimatedProgressBarDecreaseDuration Property

Gets or sets the Duration of the decrease animation. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration DecreaseDuration { get; set; }
Public Property DecreaseDuration As Duration
    Get
    Set

Property Value

Type: Duration
The Duration of the decrease animation. The default value is 500 milliseconds.
Remarks
This property is not used when IsAnimationEnabled is set to false.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IncreaseDuration Property

AnimatedProgressBarIncreaseDuration Property

Gets or sets the Duration of the increase animation. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration IncreaseDuration { get; set; }
Public Property IncreaseDuration As Duration
    Get
    Set

Property Value

Type: Duration
The Duration of the increase animation. The default value is 500 milliseconds.
Remarks
This property is not used when IsAnimationEnabled is set to false.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IsAnimationEnabled Property

AnimatedProgressBarIsAnimationEnabled Property

Gets or sets value indicating whether the progress bar should animate Value changes. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAnimationEnabled { get; set; }
Public Property IsAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the progress bar should animate Value changes; otherwise, false. The default value is true.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IsCompleted Property

AnimatedProgressBarIsCompleted Property

Gets a value indicating whether Value is equal to Maximum. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCompleted { get; }
Public ReadOnly Property IsCompleted As Boolean
    Get

Property Value

Type: Boolean
true if Value is equal to Maximum; otherwise, false.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IsContinuous Property

AnimatedProgressBarIsContinuous Property

Gets or sets value indicating whether the progress bar should render a continuous or segmented indicator. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsContinuous { get; set; }
Public Property IsContinuous As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the progress bar should render a continuous indicator; otherwise, false. The default value is false.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IsIndeterminate Property

AnimatedProgressBarIsIndeterminate Property

Gets or sets a value indicating whether the AnimatedProgressBar shows actual values or generic, continuous progress feedback. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsIndeterminate { get; set; }
Public Property IsIndeterminate As Boolean
    Get
    Set

Property Value

Type: Boolean
false if the AnimatedProgressBar shows actual values; true if the AnimatedProgressBar shows generic progress. The default value is false.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.Orientation Property

AnimatedProgressBarOrientation Property

Gets or sets the orientation of a AnimatedProgressBar: horizontal or vertical. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
One of the Orientation values. The default value is Orientation.Horizontal.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.State Property

AnimatedProgressBarState Property

Gets or sets the state of the AnimatedProgressBar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperationState State { get; set; }
Public Property State As OperationState
    Get
    Set

Property Value

Type: OperationState
The state. The default value is Normal.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar Methods

The AnimatedProgressBar type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Attempts to locate and initialize the PART_Track and PART_Indicator parts from the applied template. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Creates an appropriate AnimatedProgressBarAutomationPeer for this control as part of the WPF infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMaximumChanged | Called when the Maximum property changes. (Inherited from RangeBase.)
Protected method | OnMinimumChanged | Called when the Minimum property changes. (Inherited from RangeBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnStateChanged | Invoked when the State property is changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged routed event. (Overrides RangeBaseOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateProgressBarIndicatorLength | Updates the length of the PART_Indicator element.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.OnApplyTemplate Method

AnimatedProgressBarOnApplyTemplate Method

Attempts to locate and initialize the PART_Track and PART_Indicator parts from the applied template.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.OnCreateAutomationPeer Method

AnimatedProgressBarOnCreateAutomationPeer Method

Creates an appropriate AnimatedProgressBarAutomationPeer for this control as part of the WPF infrastructure.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.AnimatedProgressBar.OnCreateAutomationPeer"]

See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.OnStateChanged Method

AnimatedProgressBarOnStateChanged Method

Invoked when the State property is changed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnStateChanged(
    OperationState oldValue,
    OperationState newValue
)
Protected Overridable Sub OnStateChanged (
    oldValue As OperationState,
    newValue As OperationState
)

Parameters

oldValue
Type: ActiproSoftware.Windows.ControlsOperationState
The old property value.
newValue
Type: ActiproSoftware.Windows.ControlsOperationState
The new property value.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.OnValueChanged Method

AnimatedProgressBarOnValueChanged Method

Raises the ValueChanged routed event.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    double oldValue,
    double newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
Old value of the Value property
newValue
Type: SystemDouble
New value of the Value property
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.UpdateProgressBarIndicatorLength Method

AnimatedProgressBarUpdateProgressBarIndicatorLength Method

Updates the length of the PART_Indicator element.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateProgressBarIndicatorLength(
    bool allowAnimation
)
Protected Overridable Sub UpdateProgressBarIndicatorLength (
    allowAnimation As Boolean
)

Parameters

allowAnimation
Type: SystemBoolean
if set to true the change can be animated.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar Events

The AnimatedProgressBar type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | StateChanged | Occurs when the StateChanged is changed.
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.StateChanged Event

AnimatedProgressBarStateChanged Event

Occurs when the StateChanged is changed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<OperationStatePropertyChangedRoutedEventArgs> StateChanged
Public Event StateChanged As EventHandler(Of OperationStatePropertyChangedRoutedEventArgs)

Value

Type: SystemEventHandler OperationStatePropertyChangedRoutedEventArgs
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar Fields

The AnimatedProgressBar type exposes the following members.

Fields
Name | Description
DecreaseDurationProperty | Identifies the DecreaseDuration dependency property. This field is read-only.
IncreaseDurationProperty | Identifies the IncreaseDuration dependency property. This field is read-only.
IsAnimationEnabledProperty | Identifies the IsAnimationEnabled dependency property. This field is read-only.
IsCompletedProperty | Identifies the read-only IsCompleted dependency property. This field is read-only.
IsContinuousProperty | Identifies the IsContinuous dependency property. This field is read-only.
IsIndeterminateProperty | Identifies the IsIndeterminate dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
StateChangedEvent | Identifies the StateChanged routed event. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
Top
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.DecreaseDurationProperty Field

AnimatedProgressBarDecreaseDurationProperty Field

Identifies the DecreaseDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DecreaseDurationProperty
Public Shared ReadOnly DecreaseDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DecreaseDuration dependency property.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IncreaseDurationProperty Field

AnimatedProgressBarIncreaseDurationProperty Field

Identifies the IncreaseDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IncreaseDurationProperty
Public Shared ReadOnly IncreaseDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IncreaseDuration dependency property.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IsAnimationEnabledProperty Field

AnimatedProgressBarIsAnimationEnabledProperty Field

Identifies the IsAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAnimationEnabledProperty
Public Shared ReadOnly IsAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAnimationEnabled dependency property.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IsCompletedProperty Field

AnimatedProgressBarIsCompletedProperty Field

Identifies the read-only IsCompleted dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCompletedProperty
Public Shared ReadOnly IsCompletedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCompleted dependency property.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IsContinuousProperty Field

AnimatedProgressBarIsContinuousProperty Field

Identifies the IsContinuous dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsContinuousProperty
Public Shared ReadOnly IsContinuousProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsContinuous dependency property.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.IsIndeterminateProperty Field

AnimatedProgressBarIsIndeterminateProperty Field

Identifies the IsIndeterminate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsIndeterminateProperty
Public Shared ReadOnly IsIndeterminateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsIndeterminate dependency property.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.OrientationProperty Field

AnimatedProgressBarOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.StateChangedEvent Field

AnimatedProgressBarStateChangedEvent Field

Identifies the StateChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent StateChangedEvent
Public Shared ReadOnly StateChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the StateChanged routed event.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


AnimatedProgressBar.StateProperty Field

AnimatedProgressBarStateProperty Field

Identifies the State dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StateProperty
Public Shared ReadOnly StateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the State dependency property.
See Also

Reference

AnimatedProgressBar Class
ActiproSoftware.Windows.Controls Namespace


ContextMenuItemRoutedEventArgs Class

Provides event arguments for a ContextMenu-related routed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsItemRoutedEventArgs ContextMenu
ActiproSoftware.Windows.ControlsContextMenuItemRoutedEventArgs

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ContextMenuItemRoutedEventArgs : ItemRoutedEventArgs<ContextMenu>
Public Class ContextMenuItemRoutedEventArgs
    Inherits ItemRoutedEventArgs(Of ContextMenu)

The ContextMenuItemRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ContextMenuItemRoutedEventArgs(ContextMenu) | Initializes a new instance of the ContextMenuItemRoutedEventArgs class.
Public method | ContextMenuItemRoutedEventArgs(ContextMenu, RoutedEvent) | Initializes a new instance of the ContextMenuItemRoutedEventArgs class.
Public method | ContextMenuItemRoutedEventArgs(ContextMenu, RoutedEvent, Object) | Initializes a new instance of the ContextMenuItemRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the item that is the focus of this event. (Inherited from ItemRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


ContextMenuItemRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | ContextMenuItemRoutedEventArgs(ContextMenu) | Initializes a new instance of the ContextMenuItemRoutedEventArgs class.
Public method | ContextMenuItemRoutedEventArgs(ContextMenu, RoutedEvent) | Initializes a new instance of the ContextMenuItemRoutedEventArgs class.
Public method | ContextMenuItemRoutedEventArgs(ContextMenu, RoutedEvent, Object) | Initializes a new instance of the ContextMenuItemRoutedEventArgs class.
Top
See Also

Reference

ContextMenuItemRoutedEventArgs Class
ActiproSoftware.Windows.Controls Namespace


ContextMenuItemRoutedEventArgs Constructor (ContextMenu)

Initializes a new instance of the ContextMenuItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextMenuItemRoutedEventArgs(
    ContextMenu item
)
Public Sub New (
    item As ContextMenu
)

Parameters

item
Type: System.Windows.ControlsContextMenu
The item that is the focus of this event.
See Also

Reference

ContextMenuItemRoutedEventArgs Class
ContextMenuItemRoutedEventArgs Overload
ActiproSoftware.Windows.Controls Namespace


ContextMenuItemRoutedEventArgs Constructor (ContextMenu, RoutedEvent)

Initializes a new instance of the ContextMenuItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextMenuItemRoutedEventArgs(
    ContextMenu item,
    RoutedEvent routedEvent
)
Public Sub New (
    item As ContextMenu,
    routedEvent As RoutedEvent
)

Parameters

item
Type: System.Windows.ControlsContextMenu
The item that is the focus of this event.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
See Also

Reference

ContextMenuItemRoutedEventArgs Class
ContextMenuItemRoutedEventArgs Overload
ActiproSoftware.Windows.Controls Namespace


ContextMenuItemRoutedEventArgs Constructor (ContextMenu, RoutedEvent, Object)

Initializes a new instance of the ContextMenuItemRoutedEventArgs class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextMenuItemRoutedEventArgs(
    ContextMenu item,
    RoutedEvent routedEvent,
    Object source
)
Public Sub New (
    item As ContextMenu,
    routedEvent As RoutedEvent,
    source As Object
)

Parameters

item
Type: System.Windows.ControlsContextMenu
The item that is the focus of this event.
routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
source
Type: SystemObject
An alternate source that will be reported when the event is handled.
See Also

Reference

ContextMenuItemRoutedEventArgs Class
ContextMenuItemRoutedEventArgs Overload
ActiproSoftware.Windows.Controls Namespace


ContextMenuItemRoutedEventArgs Properties

The ContextMenuItemRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the item that is the focus of this event. (Inherited from ItemRoutedEventArgsT.)
Top
See Also

Reference

ContextMenuItemRoutedEventArgs Class
ActiproSoftware.Windows.Controls Namespace


ControlResizeMode Enumeration

Specifies the resize mode for a control.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ControlResizeMode
Public Enumeration ControlResizeMode
Members
Member name | Value | Description
None | 0 | No resizing is allowed.
Horizontal | 1 | Only horizontal resizing is allowed.
Vertical | 2 | Only vertical resizing is allowed.
Both | 3 | Both horizontal and vertical resizing is allowed.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


ControlUsageContext Enumeration

Specifies the usage context for a control.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ControlUsageContext
Public Enumeration ControlUsageContext
Members
Member name | Value | Description
Default | 0 | Used in normal scenarios.
ToolBar | 1 | Used within a toolbar.
Menu | 2 | Used within a menu.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


Corner Enumeration

Specifies a corners of a rectangle.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum Corner
Public Enumeration Corner
Members
Member name | Value | Description
TopLeft | 1 | Indicates the top-left corner.
TopRight | 2 | Indicates the top-right corner.
BottomRight | 4 | Indicates the bottom-left corner.
BottomLeft | 8 | Indicates the bottom-right corner.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


Corners Enumeration

Specifies zero or more corners of a rectangle as a combination of flags.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum Corners
Public Enumeration Corners
Members
Member name | Value | Description
None | 0 | Indicates no corners.
TopLeft | 1 | Indicates the top-left corner.
TopRight | 2 | Indicates the top-right corner.
BottomRight | 4 | Indicates the bottom-left corner.
BottomLeft | 8 | Indicates the bottom-right corner.
Left | 9 | Indicates the left corners, top-left and bottom-left.
Top | 3 | Indicates the top corners, top-left and top-right.
Right | 6 | Indicates the right corners, top-right and bottom-right.
Bottom | 12 | Indicates the bottom corners, bottom-left and bottom-right.
All | 15 | Indicates all four corners, top-left, top-right, bottom-left and bottom-right.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


CustomDrawElement Class

Represents a UIElement that is capable of being custom drawn via the handling of its CustomDraw event.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.ControlsCustomDrawElement

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CustomDrawElement : FrameworkElement
Public Class CustomDrawElement
    Inherits FrameworkElement

The CustomDrawElement type exposes the following members.

Constructors
 | Name | Description
Public method | CustomDrawElement | Initializes a new instance of the CustomDrawElement class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. (Overrides FrameworkElementGetLayoutClip(Size).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCustomDraw | Raises the CustomDraw event.
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CustomDraw | Occurs when the element requests to be custom drawn.
Top
Fields
Name | Description
CustomDrawEvent | Identifies the CustomDraw routed event. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the CustomDrawElement documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


CustomDrawElement Constructor

Initializes a new instance of the CustomDrawElement class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CustomDrawElement()
Public Sub New
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElement Properties

The CustomDrawElement type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElement Methods

The CustomDrawElement type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. (Overrides FrameworkElementGetLayoutClip(Size).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCustomDraw | Raises the CustomDraw event.
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElement.GetLayoutClip Method

CustomDrawElementGetLayoutClip Method

Returns a geometry for a clipping mask.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Geometry GetLayoutClip(
    Size layoutSlotSize
)
Protected Overrides Function GetLayoutClip (
    layoutSlotSize As Size
) As Geometry

Parameters

layoutSlotSize
Type: System.WindowsSize
The layout slot size.

Return Value

Type: Geometry
The clipping mask geometry.
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElement.OnCustomDraw Method

CustomDrawElementOnCustomDraw Method

Raises the CustomDraw event.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnCustomDraw(
    DrawingContext drawingContext
)
Protected Overridable Sub OnCustomDraw (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The DrawingContext to use.
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElement.OnRender Method

CustomDrawElementOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElement Events

The CustomDrawElement type exposes the following members.

Events
 | Name | Description
Public event | CustomDraw | Occurs when the element requests to be custom drawn.
Top
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElement.CustomDraw Event

CustomDrawElementCustomDraw Event

Occurs when the element requests to be custom drawn.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CustomDrawElementCustomDrawEventArgs> CustomDraw
Public Event CustomDraw As EventHandler(Of CustomDrawElementCustomDrawEventArgs)

Value

Type: SystemEventHandler CustomDrawElementCustomDrawEventArgs
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElement Fields

The CustomDrawElement type exposes the following members.

Fields
Name | Description
CustomDrawEvent | Identifies the CustomDraw routed event. This field is read-only.
Top
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElement.CustomDrawEvent Field

CustomDrawElementCustomDrawEvent Field

Identifies the CustomDraw routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent CustomDrawEvent
Public Shared ReadOnly CustomDrawEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the CustomDraw routed event.
See Also

Reference

CustomDrawElement Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElementCustomDrawEventArgs Class

Provides event arguments for performing custom draw of a CustomDrawElement.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.Windows.ControlsCustomDrawEventArgs CustomDrawElement
ActiproSoftware.Windows.ControlsCustomDrawElementCustomDrawEventArgs

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CustomDrawElementCustomDrawEventArgs : CustomDrawEventArgs<CustomDrawElement>
Public Class CustomDrawElementCustomDrawEventArgs
    Inherits CustomDrawEventArgs(Of CustomDrawElement)

The CustomDrawElementCustomDrawEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CustomDrawElementCustomDrawEventArgs | Initializes a new instance of the CustomDrawElementCustomDrawEventArgs class.
Top
Properties
 | Name | Description
Public property | DrawingContext | Gets the DrawingContext to use. (Inherited from CustomDrawEventArgsT.)
Public property | Element | Gets the element being drawn. (Inherited from CustomDrawEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


CustomDrawElementCustomDrawEventArgs Constructor

Initializes a new instance of the CustomDrawElementCustomDrawEventArgs class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CustomDrawElementCustomDrawEventArgs(
    RoutedEvent routedEvent,
    CustomDrawElement element,
    DrawingContext drawingContext
)
Public Sub New (
    routedEvent As RoutedEvent,
    element As CustomDrawElement,
    drawingContext As DrawingContext
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
element
Type: ActiproSoftware.Windows.ControlsCustomDrawElement
The element being drawn.
drawingContext
Type: System.Windows.MediaDrawingContext
The DrawingContext to use.
See Also

Reference

CustomDrawElementCustomDrawEventArgs Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawElementCustomDrawEventArgs Properties

The CustomDrawElementCustomDrawEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DrawingContext | Gets the DrawingContext to use. (Inherited from CustomDrawEventArgsT.)
Public property | Element | Gets the element being drawn. (Inherited from CustomDrawEventArgsT.)
Top
See Also

Reference

CustomDrawElementCustomDrawEventArgs Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawEventArgs(T) Class

CustomDrawEventArgsT Class

Provides event arguments for performing custom draw of an element.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.Windows.ControlsCustomDrawEventArgsT
ActiproSoftware.Windows.ControlsCustomDrawElementCustomDrawEventArgs

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CustomDrawEventArgs<T> : RoutedEventArgs

Public Class CustomDrawEventArgs(Of T)
    Inherits RoutedEventArgs

Type Parameters

T
The type of element being drawn.

The CustomDrawEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | CustomDrawEventArgsT | Initializes a new instance of the CustomDrawEventArgs class.
Top
Properties
 | Name | Description
Public property | DrawingContext | Gets the DrawingContext to use.
Public property | Element | Gets the element being drawn.
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


CustomDrawEventArgs(T) Constructor

CustomDrawEventArgsT Constructor

Initializes a new instance of the CustomDrawEventArgs class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CustomDrawEventArgs(
    RoutedEvent routedEvent,
    T element,
    DrawingContext drawingContext
)
Public Sub New (
    routedEvent As RoutedEvent,
    element As T,
    drawingContext As DrawingContext
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
element
Type: T
The element being drawn.
drawingContext
Type: System.Windows.MediaDrawingContext
The DrawingContext to use.
See Also

Reference

CustomDrawEventArgsT Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawEventArgs(T) Properties

CustomDrawEventArgsT Properties

The CustomDrawEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | DrawingContext | Gets the DrawingContext to use.
Public property | Element | Gets the element being drawn.
Top
See Also

Reference

CustomDrawEventArgsT Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawEventArgs(T).DrawingContext Property

CustomDrawEventArgsTDrawingContext Property

Gets the DrawingContext to use.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DrawingContext DrawingContext { get; }
Public ReadOnly Property DrawingContext As DrawingContext
    Get

Property Value

Type: DrawingContext
The DrawingContext to use.
See Also

Reference

CustomDrawEventArgsT Class
ActiproSoftware.Windows.Controls Namespace


CustomDrawEventArgs(T).Element Property

CustomDrawEventArgsTElement Property

Gets the element being drawn.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Element { get; }
Public ReadOnly Property Element As T
    Get

Property Value

Type: T
The element being drawn.
See Also

Reference

CustomDrawEventArgsT Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome Class

Renders a drop shadow effect.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsDecorator
ActiproSoftware.Windows.ControlsDropShadowChrome

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DropShadowChrome : Decorator
Public Class DropShadowChrome
    Inherits Decorator

The DropShadowChrome type exposes the following members.

Constructors
 | Name | Description
Public method | DropShadowChrome | Initializes a new instance of the DropShadowChrome class
Top
Properties
 | Name | Description
Public property | BorderThickness | Gets or sets the Thickness of the drop shadow borders.
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Color | Gets or sets the color of the drop shadow.
Public property | CornerRadius | Gets or sets the CornerRadius of the drop shadow borders.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XOffset | Gets or sets the horizontal offset of the drop shadow behind its content.
Public property | YOffset | Gets or sets the vertical offset of the drop shadow behind its content.
Public property | ZOffset | Gets or sets the z-offset of the drop shadow behind its content.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a Decorator element. (Inherited from Decorator.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures the child element of a Decorator to prepare for arranging it during the ArrangeOverride(Size) pass. (Inherited from Decorator.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BorderThicknessProperty | Identifies the BorderThickness dependency property. This field is read-only.
ColorProperty | Identifies the Color dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
XOffsetProperty | Identifies the XOffset dependency property. This field is read-only.
YOffsetProperty | Identifies the YOffset dependency property. This field is read-only.
ZOffsetProperty | Identifies the ZOffset dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the DropShadowChrome documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


DropShadowChrome Constructor

Initializes a new instance of the DropShadowChrome class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DropShadowChrome()
Public Sub New
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome Properties

The DropShadowChrome type exposes the following members.

Properties
 | Name | Description
Public property | BorderThickness | Gets or sets the Thickness of the drop shadow borders.
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Color | Gets or sets the color of the drop shadow.
Public property | CornerRadius | Gets or sets the CornerRadius of the drop shadow borders.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XOffset | Gets or sets the horizontal offset of the drop shadow behind its content.
Public property | YOffset | Gets or sets the vertical offset of the drop shadow behind its content.
Public property | ZOffset | Gets or sets the z-offset of the drop shadow behind its content.
Top
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.BorderThickness Property

DropShadowChromeBorderThickness Property

Gets or sets the Thickness of the drop shadow borders.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness BorderThickness { get; set; }
Public Property BorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the drop shadow borders. The default value is 5.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.Color Property

DropShadowChromeColor Property

Gets or sets the color of the drop shadow.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
The color of the drop shadow. The default value is #71000000.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.CornerRadius Property

DropShadowChromeCornerRadius Property

Gets or sets the CornerRadius of the drop shadow borders.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The CornerRadius of the drop shadow borders. The default value is 0.
Remarks
When setting a non-zero corner radius, please use a uniform value and also use a uniform BorderThickness value as well.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.XOffset Property

DropShadowChromeXOffset Property

Gets or sets the horizontal offset of the drop shadow behind its content.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double XOffset { get; set; }
Public Property XOffset As Double
    Get
    Set

Property Value

Type: Double
The horizontal offset of the drop shadow behind its content. The default value is 5.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.YOffset Property

DropShadowChromeYOffset Property

Gets or sets the vertical offset of the drop shadow behind its content.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double YOffset { get; set; }
Public Property YOffset As Double
    Get
    Set

Property Value

Type: Double
The vertical offset of the drop shadow behind its content. The default value is 5.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.ZOffset Property

DropShadowChromeZOffset Property

Gets or sets the z-offset of the drop shadow behind its content.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ZOffset { get; set; }
Public Property ZOffset As Double
    Get
    Set

Property Value

Type: Double
The z-offset of the drop shadow behind its content. The default value is 0.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome Methods

The DropShadowChrome type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a Decorator element. (Inherited from Decorator.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures the child element of a Decorator to prepare for arranging it during the ArrangeOverride(Size) pass. (Inherited from Decorator.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.OnRender Method

DropShadowChromeOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome Fields

The DropShadowChrome type exposes the following members.

Fields
Name | Description
BorderThicknessProperty | Identifies the BorderThickness dependency property. This field is read-only.
ColorProperty | Identifies the Color dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
XOffsetProperty | Identifies the XOffset dependency property. This field is read-only.
YOffsetProperty | Identifies the YOffset dependency property. This field is read-only.
ZOffsetProperty | Identifies the ZOffset dependency property. This field is read-only.
Top
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.BorderThicknessProperty Field

DropShadowChromeBorderThicknessProperty Field

Identifies the BorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderThicknessProperty
Public Shared ReadOnly BorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderThickness dependency property.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.ColorProperty Field

DropShadowChromeColorProperty Field

Identifies the Color dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColorProperty
Public Shared ReadOnly ColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Color dependency property.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.CornerRadiusProperty Field

DropShadowChromeCornerRadiusProperty Field

Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.XOffsetProperty Field

DropShadowChromeXOffsetProperty Field

Identifies the XOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XOffsetProperty
Public Shared ReadOnly XOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XOffset dependency property.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.YOffsetProperty Field

DropShadowChromeYOffsetProperty Field

Identifies the YOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YOffsetProperty
Public Shared ReadOnly YOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YOffset dependency property.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DropShadowChrome.ZOffsetProperty Field

DropShadowChromeZOffsetProperty Field

Identifies the ZOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZOffsetProperty
Public Shared ReadOnly ZOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZOffset dependency property.
See Also

Reference

DropShadowChrome Class
ActiproSoftware.Windows.Controls Namespace


DynamicImage Class

Represents a dynamic Image control implementation that supports auto-grayscaling the image when the control is disabled.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsImage
ActiproSoftware.Windows.ControlsDynamicImage

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DynamicImage : Image
Public Class DynamicImage
    Inherits Image

The DynamicImage type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicImage | Initializes a new instance of the DynamicImage class
Top
Properties
 | Name | Description
Protected property | BaseUri | Gets or sets the base uniform resource identifier (URI) for the Image. (Inherited from Image.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Source | Gets or sets the ImageSource for the image. (Inherited from Image.)
Public property | Stretch | Gets or sets a value that describes how an Image should be stretched to fill the destination rectangle. (Inherited from Image.)
Public property | StretchDirection | Gets or sets a value that indicates how the image is scaled. (Inherited from Image.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges and sizes an image control. (Inherited from Image.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Updates the DesiredSize of the image. This method is called by the parent UIElement and is the first pass of layout. (Inherited from Image.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this Image. (Inherited from Image.)
Protected method | OnRender | Renders the contents of an Image. (Inherited from Image.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ImageFailed | Occurs when there is a failure in the image. (Inherited from Image.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


DynamicImage Constructor

Initializes a new instance of the DynamicImage class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DynamicImage()
Public Sub New
See Also

Reference

DynamicImage Class
ActiproSoftware.Windows.Controls Namespace


DynamicImage Properties

The DynamicImage type exposes the following members.

Properties
 | Name | Description
Protected property | BaseUri | Gets or sets the base uniform resource identifier (URI) for the Image. (Inherited from Image.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Source | Gets or sets the ImageSource for the image. (Inherited from Image.)
Public property | Stretch | Gets or sets a value that describes how an Image should be stretched to fill the destination rectangle. (Inherited from Image.)
Public property | StretchDirection | Gets or sets a value that indicates how the image is scaled. (Inherited from Image.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DynamicImage Class
ActiproSoftware.Windows.Controls Namespace


DynamicImage Methods

The DynamicImage type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges and sizes an image control. (Inherited from Image.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Updates the DesiredSize of the image. This method is called by the parent UIElement and is the first pass of layout. (Inherited from Image.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this Image. (Inherited from Image.)
Protected method | OnRender | Renders the contents of an Image. (Inherited from Image.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DynamicImage Class
ActiproSoftware.Windows.Controls Namespace


DynamicImage Events

The DynamicImage type exposes the following members.

Events
 | Name | Description
Public event | ImageFailed | Occurs when there is a failure in the image. (Inherited from Image.)
Top
See Also

Reference

DynamicImage Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl Class

Represents a control that displays content by default but can toggle to an editable mode for editing the content.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.ControlsEditableContentControl
ActiproSoftware.Windows.Controls.Shell.PrimitivesShellEditableContentControl

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EditableContentControl : ContentControl
Public Class EditableContentControl
    Inherits ContentControl

The EditableContentControl type exposes the following members.

Constructors
 | Name | Description
Public method | EditableContentControl | Initializes an instance of the EditableContentControl class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EditableContent | Gets or sets the content being edited.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsEditing | Gets or sets whether the content is currently being edited.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SelectText | Selects the text in the specified TextBox when editing starts.
Protected method | SetContentAfterEditing | Sets the Content property with the specified edited content following a committed edit.
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
EditableContentProperty | Identifies the EditableContent dependency property. This field is read-only.
IsEditingProperty | Identifies the IsEditing dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


EditableContentControl Constructor

Initializes an instance of the EditableContentControl class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EditableContentControl()
Public Sub New
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl Properties

The EditableContentControl type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EditableContent | Gets or sets the content being edited.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsEditing | Gets or sets whether the content is currently being edited.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl.EditableContent Property

EditableContentControlEditableContent Property

Gets or sets the content being edited.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object EditableContent { get; set; }
Public Property EditableContent As Object
    Get
    Set

Property Value

Type: Object
The content being edited.
Remarks
This property is for internal use only.
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl.IsEditing Property

EditableContentControlIsEditing Property

Gets or sets whether the content is currently being edited.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEditing { get; set; }
Public Property IsEditing As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the content is currently being edited; otherwise, false.
Remarks
This property toggles the UI of the control between display and edit modes.
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl Methods

The EditableContentControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SelectText | Selects the text in the specified TextBox when editing starts.
Protected method | SetContentAfterEditing | Sets the Content property with the specified edited content following a committed edit.
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl.OnIsKeyboardFocusWithinChanged Method

EditableContentControlOnIsKeyboardFocusWithinChanged Method

Occurs when the property value has changed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs containing data related to this event.
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl.OnKeyDown Method

EditableContentControlOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl.SelectText Method

EditableContentControlSelectText Method

Selects the text in the specified TextBox when editing starts.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void SelectText(
    TextBox textBox
)
Protected Overridable Sub SelectText (
    textBox As TextBox
)

Parameters

textBox
Type: System.Windows.ControlsTextBox
The TextBox to update.
Remarks
The default implementation of this method selects all text. Override it to select a range of text instead, such as a filename's actual name range before the extension.
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl.SetContentAfterEditing Method

EditableContentControlSetContentAfterEditing Method

Sets the Content property with the specified edited content following a committed edit.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void SetContentAfterEditing(
    Object editedContent
)
Protected Overridable Sub SetContentAfterEditing (
    editedContent As Object
)

Parameters

editedContent
Type: SystemObject
The EditableContent value prior to editing ending.
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl Events

The EditableContentControl type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl Fields

The EditableContentControl type exposes the following members.

Fields
Name | Description
EditableContentProperty | Identifies the EditableContent dependency property. This field is read-only.
IsEditingProperty | Identifies the IsEditing dependency property. This field is read-only.
Top
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl.EditableContentProperty Field

EditableContentControlEditableContentProperty Field

Identifies the EditableContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EditableContentProperty
Public Shared ReadOnly EditableContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EditableContent dependency property.
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


EditableContentControl.IsEditingProperty Field

EditableContentControlIsEditingProperty Field

Identifies the IsEditing dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEditingProperty
Public Shared ReadOnly IsEditingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEditing dependency property.
See Also

Reference

EditableContentControl Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow Class

Provides an implementation of a Window that allows you to extend Aero glass effects into the client area when used in Vista with Aero enabled.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
ActiproSoftware.Windows.ControlsGlassWindow
ActiproSoftware.Windows.Controls.WizardAeroWizardWindow

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GlassWindow : Window
Public Class GlassWindow
    Inherits Window

The GlassWindow type exposes the following members.

Constructors
 | Name | Description
Public method | GlassWindow | Initializes a new instance of the GlassWindow class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets whether the window can close.
Public property | CanToggleMaximizedState | Gets whether the window can toggle its maximization state.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GlassThickness | Gets or sets the Thickness of the glass frame into the client area.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsFullScreenAllowed | Gets or sets whether the window can cover the taskbar when maximized.
Public property | IsGlassActive | Gets whether Windows Vista glass transparency effects are currently active.
Public property | IsGlassEnabled | Gets or sets whether Windows Vista glass transparency effects are currently enabled.
Public property | IsIconVisible | Gets whether the title bar icon is visible.
Public property | IsMaximizeButtonVisible | Gets or sets whether the maximize button is visible.
Public property | IsMinimizeButtonVisible | Gets or sets whether the minimize button is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTitleVisible | Gets whether the title bar caption is visible.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSourceInitialized | Occurs after the source handle has been initialized. (Overrides WindowOnSourceInitialized(EventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShowSystemMenu(FrameworkElement) | Displays the window's system menu under the specified child control.
Public method | ShowSystemMenu(Point) | Displays the window's system menu at the specified location relative to the window.
Public method | StartResize | Starts a window resize operation.
Public method | ToggleMaximizedState | Toggles the window's maximized state.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
GlassThicknessProperty | Identifies the GlassThickness dependency property. This field is read-only.
IsFullScreenAllowedProperty | Identifies the IsFullScreenAllowed dependency property. This field is read-only.
IsGlassActiveProperty | Identifies the IsGlassActive dependency property. This field is read-only.
IsGlassEnabledProperty | Identifies the IsGlassEnabled dependency property. This field is read-only.
IsIconVisibleProperty | Identifies the IsIconVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsTitleVisibleProperty | Identifies the IsTitleVisible dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the GlassWindow documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


GlassWindow Constructor

Initializes a new instance of the GlassWindow class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GlassWindow()
Public Sub New
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow Properties

The GlassWindow type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets whether the window can close.
Public property | CanToggleMaximizedState | Gets whether the window can toggle its maximization state.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GlassThickness | Gets or sets the Thickness of the glass frame into the client area.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsFullScreenAllowed | Gets or sets whether the window can cover the taskbar when maximized.
Public property | IsGlassActive | Gets whether Windows Vista glass transparency effects are currently active.
Public property | IsGlassEnabled | Gets or sets whether Windows Vista glass transparency effects are currently enabled.
Public property | IsIconVisible | Gets whether the title bar icon is visible.
Public property | IsMaximizeButtonVisible | Gets or sets whether the maximize button is visible.
Public property | IsMinimizeButtonVisible | Gets or sets whether the minimize button is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTitleVisible | Gets whether the title bar caption is visible.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.CanClose Property

GlassWindowCanClose Property

Gets whether the window can close.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanClose { get; }
Public Overridable ReadOnly Property CanClose As Boolean
    Get

Property Value

Type: Boolean
true if the window can close; otherwise, false.
Remarks
The return value of this property is always true unless overridden.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.CanToggleMaximizedState Property

GlassWindowCanToggleMaximizedState Property

Gets whether the window can toggle its maximization state.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanToggleMaximizedState { get; }
Public Overridable ReadOnly Property CanToggleMaximizedState As Boolean
    Get

Property Value

Type: Boolean
true if the window can toggle its maximization state; otherwise, false.
Remarks
The return value of this property is based on the ResizeMode property value.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.GlassThickness Property

GlassWindowGlassThickness Property

Gets or sets the Thickness of the glass frame into the client area.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness GlassThickness { get; set; }
Public Property GlassThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the glass frame into the client area. The default value is 0,0,0,0.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsFullScreenAllowed Property

GlassWindowIsFullScreenAllowed Property

Gets or sets whether the window can cover the taskbar when maximized.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsFullScreenAllowed { get; set; }
Public Property IsFullScreenAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window can cover the taskbar when maximized; otherwise, false. The default value is true.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsGlassActive Property

GlassWindowIsGlassActive Property

Gets whether Windows Vista glass transparency effects are currently active.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGlassActive { get; }
Public ReadOnly Property IsGlassActive As Boolean
    Get

Property Value

Type: Boolean
true if Windows Vista glass transparency effects are currently active; otherwise, false.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsGlassEnabled Property

GlassWindowIsGlassEnabled Property

Gets or sets whether Windows Vista glass transparency effects are currently enabled.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGlassEnabled { get; set; }
Public Property IsGlassEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if Windows Vista glass transparency effects are currently enabled; otherwise, false. The default value is true.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsIconVisible Property

GlassWindowIsIconVisible Property

Gets whether the title bar icon is visible.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsIconVisible { get; protected set; }
Public Property IsIconVisible As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the title bar icon is visible; otherwise, false.
Remarks
This property must be set before the window's source has been created.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsMaximizeButtonVisible Property

GlassWindowIsMaximizeButtonVisible Property

Gets or sets whether the maximize button is visible.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMaximizeButtonVisible { get; set; }
Public Property IsMaximizeButtonVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the maximize button is visible; otherwise, false. The default value is true.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsMinimizeButtonVisible Property

GlassWindowIsMinimizeButtonVisible Property

Gets or sets whether the minimize button is visible.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMinimizeButtonVisible { get; set; }
Public Property IsMinimizeButtonVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the minimize button is visible; otherwise, false. The default value is true.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsTitleVisible Property

GlassWindowIsTitleVisible Property

Gets whether the title bar caption is visible.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTitleVisible { get; protected set; }
Public Property IsTitleVisible As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the title bar caption is visible; otherwise, false.
Remarks
This property must be set before the window's source has been created.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow Methods

The GlassWindow type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSourceInitialized | Occurs after the source handle has been initialized. (Overrides WindowOnSourceInitialized(EventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShowSystemMenu(FrameworkElement) | Displays the window's system menu under the specified child control.
Public method | ShowSystemMenu(Point) | Displays the window's system menu at the specified location relative to the window.
Public method | StartResize | Starts a window resize operation.
Public method | ToggleMaximizedState | Toggles the window's maximized state.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.OnSourceInitialized Method

GlassWindowOnSourceInitialized Method

Occurs after the source handle has been initialized.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnSourceInitialized(
    EventArgs e
)
Protected Overrides Sub OnSourceInitialized (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.ShowSystemMenu Method

GlassWindowShowSystemMenu Method

Overload List
 | Name | Description
Public method | ShowSystemMenu(FrameworkElement) | Displays the window's system menu under the specified child control.
Public method | ShowSystemMenu(Point) | Displays the window's system menu at the specified location relative to the window.
Top
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.ShowSystemMenu Method (FrameworkElement)

GlassWindowShowSystemMenu Method (FrameworkElement)

Displays the window's system menu under the specified child control.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ShowSystemMenu(
    FrameworkElement element
)
Public Sub ShowSystemMenu (
    element As FrameworkElement
)

Parameters

element
Type: System.WindowsFrameworkElement
The FrameworkElement under which to display the system menu.
Remarks
If this overload is used, pass the Image that displays the icon for the window.
See Also

Reference

GlassWindow Class
ShowSystemMenu Overload
ActiproSoftware.Windows.Controls Namespace


GlassWindow.ShowSystemMenu Method (Point)

GlassWindowShowSystemMenu Method (Point)

Displays the window's system menu at the specified location relative to the window.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ShowSystemMenu(
    Point point
)
Public Sub ShowSystemMenu (
    point As Point
)

Parameters

point
Type: System.WindowsPoint
The Point at which to display the menu, in client coordinates.
See Also

Reference

GlassWindow Class
ShowSystemMenu Overload
ActiproSoftware.Windows.Controls Namespace


GlassWindow.StartResize Method

GlassWindowStartResize Method

Starts a window resize operation.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void StartResize(
    ResizeOperation operation
)
Public Sub StartResize (
    operation As ResizeOperation
)

Parameters

operation
Type: ActiproSoftware.Windows.ControlsResizeOperation
A ResizeOperation that specifies the type of resize.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.ToggleMaximizedState Method

GlassWindowToggleMaximizedState Method

Toggles the window's maximized state.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ToggleMaximizedState()
Public Sub ToggleMaximizedState
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow Events

The GlassWindow type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow Fields

The GlassWindow type exposes the following members.

Fields
Name | Description
GlassThicknessProperty | Identifies the GlassThickness dependency property. This field is read-only.
IsFullScreenAllowedProperty | Identifies the IsFullScreenAllowed dependency property. This field is read-only.
IsGlassActiveProperty | Identifies the IsGlassActive dependency property. This field is read-only.
IsGlassEnabledProperty | Identifies the IsGlassEnabled dependency property. This field is read-only.
IsIconVisibleProperty | Identifies the IsIconVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsTitleVisibleProperty | Identifies the IsTitleVisible dependency property. This field is read-only.
Top
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.GlassThicknessProperty Field

GlassWindowGlassThicknessProperty Field

Identifies the GlassThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GlassThicknessProperty
Public Shared ReadOnly GlassThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GlassThickness dependency property.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsFullScreenAllowedProperty Field

GlassWindowIsFullScreenAllowedProperty Field

Identifies the IsFullScreenAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFullScreenAllowedProperty
Public Shared ReadOnly IsFullScreenAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFullScreenAllowed dependency property.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsGlassActiveProperty Field

GlassWindowIsGlassActiveProperty Field

Identifies the IsGlassActive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGlassActiveProperty
Public Shared ReadOnly IsGlassActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGlassActive dependency property.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsGlassEnabledProperty Field

GlassWindowIsGlassEnabledProperty Field

Identifies the IsGlassEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGlassEnabledProperty
Public Shared ReadOnly IsGlassEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGlassEnabled dependency property.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsIconVisibleProperty Field

GlassWindowIsIconVisibleProperty Field

Identifies the IsIconVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsIconVisibleProperty
Public Shared ReadOnly IsIconVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsIconVisible dependency property.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsMaximizeButtonVisibleProperty Field

GlassWindowIsMaximizeButtonVisibleProperty Field

Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMaximizeButtonVisibleProperty
Public Shared ReadOnly IsMaximizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMaximizeButtonVisible dependency property.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsMinimizeButtonVisibleProperty Field

GlassWindowIsMinimizeButtonVisibleProperty Field

Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMinimizeButtonVisibleProperty
Public Shared ReadOnly IsMinimizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMinimizeButtonVisible dependency property.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


GlassWindow.IsTitleVisibleProperty Field

GlassWindowIsTitleVisibleProperty Field

Identifies the IsTitleVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTitleVisibleProperty
Public Shared ReadOnly IsTitleVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTitleVisible dependency property.
See Also

Reference

GlassWindow Class
ActiproSoftware.Windows.Controls Namespace


HintProperties Class

Provides attached properties that provide hint content for controls
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.ControlsHintProperties

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class HintProperties
Public NotInheritable Class HintProperties

The HintProperties type exposes the following members.

Methods
Name | Description
GetHasContent | Gets the value of the HasContent attached property for the specified object.
GetHasHint | Gets the value of the HasHint attached property for the specified object.
GetHint | Gets the value of the Hint attached property for the specified object.
GetHintTemplate | Gets the value of the HintTemplate attached property for the specified object.
GetHintTemplateSelector | Gets the value of the HintTemplateSelector attached property for the specified object.
SetHint | Sets the value of the Hint attached property to the specified object.
SetHintTemplate | Sets the value of the HintTemplate attached property to the specified object.
SetHintTemplateSelector | Sets the value of the HintTemplateSelector attached property to the specified object.
Top
Fields
Name | Description
HasContentProperty | Identifies the read-only HasContent dependency property. This field is read-only.
HasHintProperty | Identifies the read-only HasHint dependency property. This field is read-only.
HintProperty | Identifies the Hint dependency property. This field is read-only.
HintTemplateProperty | Identifies the HintTemplate dependency property. This field is read-only.
HintTemplateSelectorProperty | Identifies the HintTemplateSelector dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | HasContent |
Public attached property | HasHint |
Public attached property | Hint |
Public attached property | HintTemplate |
Public attached property | HintTemplateSelector |
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


HintProperties Methods

The HintProperties type exposes the following members.

Methods
Name | Description
GetHasContent | Gets the value of the HasContent attached property for the specified object.
GetHasHint | Gets the value of the HasHint attached property for the specified object.
GetHint | Gets the value of the Hint attached property for the specified object.
GetHintTemplate | Gets the value of the HintTemplate attached property for the specified object.
GetHintTemplateSelector | Gets the value of the HintTemplateSelector attached property for the specified object.
SetHint | Sets the value of the Hint attached property to the specified object.
SetHintTemplate | Sets the value of the HintTemplate attached property to the specified object.
SetHintTemplateSelector | Sets the value of the HintTemplateSelector attached property to the specified object.
Top
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.GetHasContent Method

HintPropertiesGetHasContent Method

Gets the value of the HasContent attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetHasContent(
    DependencyObject obj
)
Public Shared Function GetHasContent (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.GetHasHint Method

HintPropertiesGetHasHint Method

Gets the value of the HasHint attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetHasHint(
    DependencyObject obj
)
Public Shared Function GetHasHint (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.GetHint Method

HintPropertiesGetHint Method

Gets the value of the Hint attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Object GetHint(
    DependencyObject obj
)
Public Shared Function GetHint (
    obj As DependencyObject
) As Object

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Object
The object's value.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.GetHintTemplate Method

HintPropertiesGetHintTemplate Method

Gets the value of the HintTemplate attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DataTemplate GetHintTemplate(
    DependencyObject obj
)
Public Shared Function GetHintTemplate (
    obj As DependencyObject
) As DataTemplate

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: DataTemplate
The object's value.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.GetHintTemplateSelector Method

HintPropertiesGetHintTemplateSelector Method

Gets the value of the HintTemplateSelector attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DataTemplateSelector GetHintTemplateSelector(
    DependencyObject obj
)
Public Shared Function GetHintTemplateSelector (
    obj As DependencyObject
) As DataTemplateSelector

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: DataTemplateSelector
The object's value.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.SetHint Method

HintPropertiesSetHint Method

Sets the value of the Hint attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetHint(
    DependencyObject obj,
    Object value
)
Public Shared Sub SetHint (
    obj As DependencyObject,
    value As Object
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemObject
The value to set.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.SetHintTemplate Method

HintPropertiesSetHintTemplate Method

Sets the value of the HintTemplate attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetHintTemplate(
    DependencyObject obj,
    DataTemplate value
)
Public Shared Sub SetHintTemplate (
    obj As DependencyObject,
    value As DataTemplate
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: System.WindowsDataTemplate
The value to set.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.SetHintTemplateSelector Method

HintPropertiesSetHintTemplateSelector Method

Sets the value of the HintTemplateSelector attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetHintTemplateSelector(
    DependencyObject obj,
    DataTemplateSelector value
)
Public Shared Sub SetHintTemplateSelector (
    obj As DependencyObject,
    value As DataTemplateSelector
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: System.Windows.ControlsDataTemplateSelector
The value to set.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties Fields

The HintProperties type exposes the following members.

Fields
Name | Description
HasContentProperty | Identifies the read-only HasContent dependency property. This field is read-only.
HasHintProperty | Identifies the read-only HasHint dependency property. This field is read-only.
HintProperty | Identifies the Hint dependency property. This field is read-only.
HintTemplateProperty | Identifies the HintTemplate dependency property. This field is read-only.
HintTemplateSelectorProperty | Identifies the HintTemplateSelector dependency property. This field is read-only.
Top
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.HasContentProperty Field

HintPropertiesHasContentProperty Field

Identifies the read-only HasContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasContentProperty
Public Shared ReadOnly HasContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasContent dependency property.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.HasHintProperty Field

HintPropertiesHasHintProperty Field

Identifies the read-only HasHint dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasHintProperty
Public Shared ReadOnly HasHintProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasHint dependency property.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.HintProperty Field

HintPropertiesHintProperty Field

Identifies the Hint dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HintProperty
Public Shared ReadOnly HintProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hint dependency property.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.HintTemplateProperty Field

HintPropertiesHintTemplateProperty Field

Identifies the HintTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HintTemplateProperty
Public Shared ReadOnly HintTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HintTemplate dependency property.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.HintTemplateSelectorProperty Field

HintPropertiesHintTemplateSelectorProperty Field

Identifies the HintTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HintTemplateSelectorProperty
Public Shared ReadOnly HintTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HintTemplateSelector dependency property.
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties Attached Properties

The HintProperties type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | HasContent |
Public attached property | HasHint |
Public attached property | Hint |
Public attached property | HintTemplate |
Public attached property | HintTemplateSelector |
Top
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.HasContent Attached Property

HintPropertiesHasContent Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.HintProperties.HasContent"]

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetHasContent
See GetHasContent

Property Value

Type: Boolean
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.HasHint Attached Property

HintPropertiesHasHint Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.HintProperties.HasHint"]

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetHasHint
See GetHasHint

Property Value

Type: Boolean
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.Hint Attached Property

HintPropertiesHint Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.HintProperties.Hint"]

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetHint, SetHint
See GetHint, SetHint

Property Value

Type: Object
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.HintTemplate Attached Property

HintPropertiesHintTemplate Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.HintProperties.HintTemplate"]

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetHintTemplate, SetHintTemplate
See GetHintTemplate, SetHintTemplate

Property Value

Type: DataTemplate
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HintProperties.HintTemplateSelector Attached Property

HintPropertiesHintTemplateSelector Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.HintProperties.HintTemplateSelector"]

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetHintTemplateSelector, SetHintTemplateSelector
See GetHintTemplateSelector, SetHintTemplateSelector

Property Value

Type: DataTemplateSelector
See Also

Reference

HintProperties Class
ActiproSoftware.Windows.Controls Namespace


HorizontalListBox Class

Represents a horizontal ListBox.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsListBox
ActiproSoftware.Windows.ControlsHorizontalListBox

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class HorizontalListBox : ListBox
Public Class HorizontalListBox
    Inherits ListBox

The HorizontalListBox type exposes the following members.

Constructors
 | Name | Description
Public method | HorizontalListBox | Initializes an instance of the HorizontalListBox class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Inherited from ListBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


HorizontalListBox Constructor

Initializes an instance of the HorizontalListBox class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public HorizontalListBox()
Public Sub New
See Also

Reference

HorizontalListBox Class
ActiproSoftware.Windows.Controls Namespace


HorizontalListBox Properties

The HorizontalListBox type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

HorizontalListBox Class
ActiproSoftware.Windows.Controls Namespace


HorizontalListBox Methods

The HorizontalListBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Inherited from ListBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

HorizontalListBox Class
ActiproSoftware.Windows.Controls Namespace


HorizontalListBox Events

The HorizontalListBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
See Also

Reference

HorizontalListBox Class
ActiproSoftware.Windows.Controls Namespace


ImageConverter Class

Represents a value converter that returns a new Image instance created using a specified URI or BitmapSource.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.ControlsImageConverter

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ImageConverter : DependencyObject,
    IValueConverter
Public Class ImageConverter
    Inherits DependencyObject
    Implements IValueConverter

The ImageConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ImageConverter | Initializes a new instance of the ImageConverter class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | UriPrefix | Gets or sets the URI prefix that should be prepended to all values converted by this object. This is a dependency property.
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Convert | Converts the specified URI, in the form of a String or Uri, or the specified BitmapSource to an Image.
Public method | ConvertBack | This method always returns and should not be used.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
UriPrefixProperty | Identifies the UriPrefix dependency property. This field is read-only.
Top
Remarks
This converter expects the source value to be a Uri, a URI String, or a BitmapSource that can be used to create a new Image instance. A prefix can be defined in UriPrefix which will be prepended to all source values of type String before the Image is created.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


ImageConverter Constructor

Initializes a new instance of the ImageConverter class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageConverter()
Public Sub New
See Also

Reference

ImageConverter Class
ActiproSoftware.Windows.Controls Namespace


ImageConverter Properties

The ImageConverter type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | UriPrefix | Gets or sets the URI prefix that should be prepended to all values converted by this object. This is a dependency property.
Top
See Also

Reference

ImageConverter Class
ActiproSoftware.Windows.Controls Namespace


ImageConverter.UriPrefix Property

ImageConverterUriPrefix Property

Gets or sets the URI prefix that should be prepended to all values converted by this object. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string UriPrefix { get; set; }
Public Property UriPrefix As String
    Get
    Set

Property Value

Type: String
The URI prefix.
See Also

Reference

ImageConverter Class
ActiproSoftware.Windows.Controls Namespace


ImageConverter Methods

The ImageConverter type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Convert | Converts the specified URI, in the form of a String or Uri, or the specified BitmapSource to an Image.
Public method | ConvertBack | This method always returns and should not be used.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ImageConverter Class
ActiproSoftware.Windows.Controls Namespace


ImageConverter.Convert Method

ImageConverterConvert Method

Converts the specified URI, in the form of a String or Uri, or the specified BitmapSource to an Image.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
An Image associated with the specified URI.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
Remarks
See ImageConverter for more information on the expected source values.
See Also

Reference

ImageConverter Class
ActiproSoftware.Windows.Controls Namespace


ImageConverter.ConvertBack Method

ImageConverterConvertBack Method

This method always returns and should not be used.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
Not used.
targetType
Type: SystemType
Not used.
parameter
Type: SystemObject
Not used.
culture
Type: System.GlobalizationCultureInfo
Not used.

Return Value

Type: Object
.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ImageConverter Class
ActiproSoftware.Windows.Controls Namespace


ImageConverter Fields

The ImageConverter type exposes the following members.

Fields
Name | Description
UriPrefixProperty | Identifies the UriPrefix dependency property. This field is read-only.
Top
See Also

Reference

ImageConverter Class
ActiproSoftware.Windows.Controls Namespace


ImageConverter.UriPrefixProperty Field

ImageConverterUriPrefixProperty Field

Identifies the UriPrefix dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UriPrefixProperty
Public Shared ReadOnly UriPrefixProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UriPrefix dependency property.
See Also

Reference

ImageConverter Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo Class

Represents an object that has properties for setting large and small image sources, along with a text label.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.ControlsImageTextInfo

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ImageTextInfo : DependencyObject
Public Class ImageTextInfo
    Inherits DependencyObject

The ImageTextInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ImageTextInfo | Initializes a new instance of the ImageTextInfo class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ImageSourceLarge | Gets or sets a large ImageSource.
Public property | ImageSourceSmall | Gets or sets a small ImageSource.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object.
Public property | Text | Gets or sets a text label.
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
ImageSourceLargeProperty | Identifies the ImageSourceLarge dependency property. This field is read-only.
ImageSourceSmallProperty | Identifies the ImageSourceSmall dependency property. This field is read-only.
TagProperty | Identifies the Tag dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
Top
Remarks
This class is ideal for using to databind images, text or other information to the Header of a HeaderedContentControl.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


ImageTextInfo Constructor

Initializes a new instance of the ImageTextInfo class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageTextInfo()
Public Sub New
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo Properties

The ImageTextInfo type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ImageSourceLarge | Gets or sets a large ImageSource.
Public property | ImageSourceSmall | Gets or sets a small ImageSource.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object.
Public property | Text | Gets or sets a text label.
Top
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo.ImageSourceLarge Property

ImageTextInfoImageSourceLarge Property

Gets or sets a large ImageSource.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSourceLarge { get; set; }
Public Property ImageSourceLarge As ImageSource
    Get
    Set

Property Value

Type: ImageSource
A large ImageSource.
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo.ImageSourceSmall Property

ImageTextInfoImageSourceSmall Property

Gets or sets a small ImageSource.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSourceSmall { get; set; }
Public Property ImageSourceSmall As ImageSource
    Get
    Set

Property Value

Type: ImageSource
A small ImageSource.
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo.Tag Property

ImageTextInfoTag Property

Gets or sets an arbitrary object value that can be used to store custom information about this object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
The intended value. This property has no default value.
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo.Text Property

ImageTextInfoText Property

Gets or sets a text label.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
A text label.
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo Methods

The ImageTextInfo type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo.ToString Method

ImageTextInfoToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo Fields

The ImageTextInfo type exposes the following members.

Fields
Name | Description
ImageSourceLargeProperty | Identifies the ImageSourceLarge dependency property. This field is read-only.
ImageSourceSmallProperty | Identifies the ImageSourceSmall dependency property. This field is read-only.
TagProperty | Identifies the Tag dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
Top
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo.ImageSourceLargeProperty Field

ImageTextInfoImageSourceLargeProperty Field

Identifies the ImageSourceLarge dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceLargeProperty
Public Shared ReadOnly ImageSourceLargeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSourceLarge dependency property.
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo.ImageSourceSmallProperty Field

ImageTextInfoImageSourceSmallProperty Field

Identifies the ImageSourceSmall dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceSmallProperty
Public Shared ReadOnly ImageSourceSmallProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSourceSmall dependency property.
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo.TagProperty Field

ImageTextInfoTagProperty Field

Identifies the Tag dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TagProperty
Public Shared ReadOnly TagProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Tag dependency property.
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


ImageTextInfo.TextProperty Field

ImageTextInfoTextProperty Field

Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

ImageTextInfo Class
ActiproSoftware.Windows.Controls Namespace


IOrientedElement Interface

Provides the base requirements for an element that has an Orientation property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IOrientedElement
Public Interface IOrientedElement

The IOrientedElement type exposes the following members.

Properties
 | Name | Description
Public property | Orientation | Gets the orientation of the element.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


IOrientedElement Properties

The IOrientedElement type exposes the following members.

Properties
 | Name | Description
Public property | Orientation | Gets the orientation of the element.
Top
See Also

Reference

IOrientedElement Interface
ActiproSoftware.Windows.Controls Namespace


IOrientedElement.Orientation Property

IOrientedElementOrientation Property

Gets the orientation of the element.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Orientation Orientation { get; }
ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The orientation of the element.
See Also

Reference

IOrientedElement Interface
ActiproSoftware.Windows.Controls Namespace


IOrientedElement Methods

The IOrientedElement type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

IOrientedElement Interface
ActiproSoftware.Windows.Controls Namespace


OperationState Enumeration

Specifies the state of an AnimatedProgressBar control.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum OperationState
Public Enumeration OperationState
Members
Member name | Value | Description
Normal | 0 | The AnimatedProgressBar control is in a normal state.
Paused | 1 | The AnimatedProgressBar control is in a paused state.
Error | 2 | The AnimatedProgressBar control is in an error state.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


OperationStatePropertyChangedRoutedEventArgs Class

Provides event arguments for a OperationState property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs OperationState
ActiproSoftware.Windows.ControlsOperationStatePropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class OperationStatePropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<OperationState>
Public Class OperationStatePropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of OperationState)

The OperationStatePropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OperationStatePropertyChangedRoutedEventArgs(OperationState, OperationState) | Initializes a new instance of the OperationStatePropertyChangedRoutedEventArgs class.
Public method | OperationStatePropertyChangedRoutedEventArgs(RoutedEvent, OperationState, OperationState) | Initializes a new instance of the OperationStatePropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


OperationStatePropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | OperationStatePropertyChangedRoutedEventArgs(OperationState, OperationState) | Initializes a new instance of the OperationStatePropertyChangedRoutedEventArgs class.
Public method | OperationStatePropertyChangedRoutedEventArgs(RoutedEvent, OperationState, OperationState) | Initializes a new instance of the OperationStatePropertyChangedRoutedEventArgs class.
Top
See Also

Reference

OperationStatePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows.Controls Namespace


OperationStatePropertyChangedRoutedEventArgs Constructor (OperationState, OperationState)

Initializes a new instance of the OperationStatePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperationStatePropertyChangedRoutedEventArgs(
    OperationState oldValue,
    OperationState newValue
)
Public Sub New (
    oldValue As OperationState,
    newValue As OperationState
)

Parameters

oldValue
Type: ActiproSoftware.Windows.ControlsOperationState
The previous value of the property being tracked as reported by an event.
newValue
Type: ActiproSoftware.Windows.ControlsOperationState
The new value of the property being tracked as reported by an event.
See Also

Reference

OperationStatePropertyChangedRoutedEventArgs Class
OperationStatePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows.Controls Namespace


OperationStatePropertyChangedRoutedEventArgs Constructor (RoutedEvent, OperationState, OperationState)

Initializes a new instance of the OperationStatePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public OperationStatePropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    OperationState oldValue,
    OperationState newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As OperationState,
    newValue As OperationState
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: ActiproSoftware.Windows.ControlsOperationState
The previous value of the property being tracked as reported by an event.
newValue
Type: ActiproSoftware.Windows.ControlsOperationState
The new value of the property being tracked as reported by an event.
See Also

Reference

OperationStatePropertyChangedRoutedEventArgs Class
OperationStatePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows.Controls Namespace


OperationStatePropertyChangedRoutedEventArgs Properties

The OperationStatePropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

OperationStatePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows.Controls Namespace


PixelSnapper Class

Represents a Decorator that measures its contents at integer intervals to help with pixel snapping.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsDecorator
ActiproSoftware.Windows.ControlsPixelSnapper

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PixelSnapper : Decorator
Public Class PixelSnapper
    Inherits Decorator

The PixelSnapper type exposes the following members.

Constructors
 | Name | Description
Public method | PixelSnapper | Initializes a new instance of the PixelSnapper class
Top
Properties
 | Name | Description
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HorizontalRoundMode | Gets or sets a RoundMode indicating how to round the horizontal measurement of the child content. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | VerticalRoundMode | Gets or sets a RoundMode indicating how to round the vertical measurement of the child content. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a Decorator element. (Inherited from Decorator.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides DecoratorMeasureOverride(Size).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
HorizontalRoundModeProperty | Identifies the HorizontalRoundMode dependency property. This field is read-only.
VerticalRoundModeProperty | Identifies the VerticalRoundMode dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


PixelSnapper Constructor

Initializes a new instance of the PixelSnapper class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PixelSnapper()
Public Sub New
See Also

Reference

PixelSnapper Class
ActiproSoftware.Windows.Controls Namespace


PixelSnapper Properties

The PixelSnapper type exposes the following members.

Properties
 | Name | Description
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HorizontalRoundMode | Gets or sets a RoundMode indicating how to round the horizontal measurement of the child content. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | VerticalRoundMode | Gets or sets a RoundMode indicating how to round the vertical measurement of the child content. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PixelSnapper Class
ActiproSoftware.Windows.Controls Namespace


PixelSnapper.HorizontalRoundMode Property

PixelSnapperHorizontalRoundMode Property

Gets or sets a RoundMode indicating how to round the horizontal measurement of the child content. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RoundMode HorizontalRoundMode { get; set; }
Public Property HorizontalRoundMode As RoundMode
    Get
    Set

Property Value

Type: RoundMode
A RoundMode indicating how to round the horizontal measurement of the child content. The default value is RoundMode.Ceiling.
See Also

Reference

PixelSnapper Class
ActiproSoftware.Windows.Controls Namespace


PixelSnapper.VerticalRoundMode Property

PixelSnapperVerticalRoundMode Property

Gets or sets a RoundMode indicating how to round the vertical measurement of the child content. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RoundMode VerticalRoundMode { get; set; }
Public Property VerticalRoundMode As RoundMode
    Get
    Set

Property Value

Type: RoundMode
A RoundMode indicating how to round the vertical measurement of the child content. The default value is RoundMode.Ceiling.
See Also

Reference

PixelSnapper Class
ActiproSoftware.Windows.Controls Namespace


PixelSnapper Methods

The PixelSnapper type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a Decorator element. (Inherited from Decorator.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides DecoratorMeasureOverride(Size).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PixelSnapper Class
ActiproSoftware.Windows.Controls Namespace


PixelSnapper.MeasureOverride Method

PixelSnapperMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size constraint
)
Protected Overrides Function MeasureOverride (
    constraint As Size
) As Size

Parameters

constraint
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

PixelSnapper Class
ActiproSoftware.Windows.Controls Namespace


PixelSnapper Fields

The PixelSnapper type exposes the following members.

Fields
Name | Description
HorizontalRoundModeProperty | Identifies the HorizontalRoundMode dependency property. This field is read-only.
VerticalRoundModeProperty | Identifies the VerticalRoundMode dependency property. This field is read-only.
Top
See Also

Reference

PixelSnapper Class
ActiproSoftware.Windows.Controls Namespace


PixelSnapper.HorizontalRoundModeProperty Field

PixelSnapperHorizontalRoundModeProperty Field

Identifies the HorizontalRoundMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HorizontalRoundModeProperty
Public Shared ReadOnly HorizontalRoundModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HorizontalRoundMode dependency property.
See Also

Reference

PixelSnapper Class
ActiproSoftware.Windows.Controls Namespace


PixelSnapper.VerticalRoundModeProperty Field

PixelSnapperVerticalRoundModeProperty Field

Identifies the VerticalRoundMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty VerticalRoundModeProperty
Public Shared ReadOnly VerticalRoundModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the VerticalRoundMode dependency property.
See Also

Reference

PixelSnapper Class
ActiproSoftware.Windows.Controls Namespace


PopupButton Class

Represents a popup, or split, button control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.Controls.PrimitivesButtonBase
System.Windows.ControlsButton
ActiproSoftware.Windows.ControlsPopupButton
ActiproSoftware.Windows.Controls.Navigation.PrimitivesBreadcrumbButtonBase

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PopupButton : Button
Public Class PopupButton
    Inherits Button

The PopupButton type exposes the following members.

Constructors
 | Name | Description
Public method | PopupButton | Initializes a new instance of the PopupButton class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
 | ClosePopup | Gets the RoutedCommand used to close a Popup.
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMode | Gets or sets the display mode of the PopupButton. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasDropShadow | Gets or sets whether the popup will display a drop-shadow effect. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAutoFocusOnOpenEnabled | Gets or sets a value indicating whether the popup content will be automatically focused when the popup is opened. This is a dependency property.
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPopupOpen | Gets or sets whether the popup is currently displayed. This is a dependency property.
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsPreviewMouseDownHandled | Gets or sets a value indicating whether the click should be executed when a PreviewMouseDown event is raised. This is a dependency property.
Public property | IsRounded | Gets or sets a value indicating whether the button should be drawn with round corners, if the current theme supports rounded corners. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTransparencyModeEnabled | Gets or sets a value indicating whether transparency mode is enabled. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides ContentControlLogicalChildren.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PopupAllowsTransparency | Gets or sets a value for the popup's AllowTransparency property. This is a dependency property.
Public property | PopupAnimation | Gets or sets an animation for the opening and closing of the associated popup. This is a dependency property.
Public property | PopupContent | Gets or sets the content that is displayed on the popup for the button. This is a dependency property.
Public property | PopupContentTemplate | Gets or sets the DataTemplate to use for the PopupContent. This is a dependency property.
Public property | PopupContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the PopupContent. This is a dependency property.
Public property | PopupHorizontalOffset | Gets or sets the horizontal distance between the target origin and the popup alignment point. This is a dependency property.
Public property | PopupIndicator | Gets or sets the object used in the indicator portion of the PopupButton. This is a dependency property.
Public property | PopupIndicatorTemplate | Gets or sets the DataTemplate used to present the indicator portion of the PopupButton. This is a dependency property.
Public property | PopupIndicatorToolTip | Gets or sets the tool-tip object that is displayed for the popup indicator element. This is a dependency property.
Public property | PopupMenu | Gets or sets the ContextMenu shown by the PopupButton. This is a dependency property.
Public property | PopupMenuDataContext | Gets or sets the the data context for the ContextMenu shown by the PopupButton when it participates in data binding. This is a dependency property.
Public property | PopupVerticalOffset | Gets or sets the vertical distance between the target origin and the popup alignment point. This is a dependency property.
Public property | StaysOpen | Gets or sets a value that indicates whether the Popup closes when the control is no longer in focus. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Overrides FrameworkElementVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Overrides FrameworkElementGetVisualChild(Int32).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClick | Called when a PopupButton is clicked. (Overrides ButtonOnClick.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PopupButtonAutomationPeer for this control as part of the automation infrastructure. (Overrides ButtonOnCreateAutomationPeer.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown event. (Overrides ButtonBaseOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPopupClosed | Raises the PopupClosed event.
Protected method | OnPopupOpened | Raises the PopupOpened event.
Protected method | OnPopupOpening | Raises the PopupOpening event.
Protected method | OnPreviewKeyDown | Provides class handling for the PreviewKeyDownEvent routed event that occurs when the user presses a key while this control has focus. (Overrides UIElementOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. (Overrides UIElementOnPreviewMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PopupClosed | Occurs when the IsPopupOpen property changes to false.
Public event | PopupOpened | Occurs when the IsPopupOpen property changes to true.
Public event | PopupOpening | Occurs before the IsPopupOpen property changes to true.
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
DisplayModeProperty | Identifies the DisplayMode dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
IsAutoFocusOnOpenEnabledProperty | Identifies the IsAutoFocusOnOpenEnabled dependency property. This field is read-only.
IsPopupOpenProperty | Identifies the IsPopupOpen dependency property. This field is read-only.
IsPreviewMouseDownHandledProperty | Identifies the IsPreviewMouseDownHandled dependency property. This field is read-only.
IsRoundedProperty | Identifies the IsRounded dependency property. This field is read-only.
IsTransparencyModeEnabledProperty | Identifies the IsTransparencyModeEnabled dependency property. This field is read-only.
PopupAllowsTransparencyProperty | Identifies the PopupAllowsTransparency dependency property. This field is read-only.
PopupAnimationProperty | Identifies the PopupAnimation dependency property. This field is read-only.
PopupClosedEvent | Identifies the PopupClosed routed event. This field is read-only.
PopupContentProperty | Identifies the PopupContent dependency property. This field is read-only.
PopupContentTemplateProperty | Identifies the PopupContentTemplate dependency property. This field is read-only.
PopupContentTemplateSelectorProperty | Identifies the PopupContentTemplateSelector dependency property. This field is read-only.
PopupHorizontalOffsetProperty | Identifies the PopupHorizontalOffset dependency property. This field is read-only.
PopupIndicatorProperty | Identifies the PopupIndicator dependency property. This field is read-only.
PopupIndicatorTemplateProperty | Identifies the PopupIndicatorTemplate dependency property. This field is read-only.
PopupIndicatorToolTipProperty | Identifies the PopupIndicatorToolTip dependency property. This field is read-only.
PopupMenuDataContextProperty | Identifies the PopupMenuDataContext dependency property. This field is read-only.
PopupMenuProperty | Identifies the PopupMenu dependency property. This field is read-only.
PopupOpenedEvent | Identifies the PopupOpened routed event. This field is read-only.
PopupOpeningEvent | Identifies the PopupOpening routed event. This field is read-only.
PopupVerticalOffsetProperty | Identifies the PopupVerticalOffset dependency property. This field is read-only.
StaysOpenProperty | Identifies the StaysOpen dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the PopupButton documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


PopupButton Constructor

Initializes a new instance of the PopupButton class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PopupButton()
Public Sub New
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton Properties

The PopupButton type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
 | ClosePopup | Gets the RoutedCommand used to close a Popup.
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMode | Gets or sets the display mode of the PopupButton. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasDropShadow | Gets or sets whether the popup will display a drop-shadow effect. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAutoFocusOnOpenEnabled | Gets or sets a value indicating whether the popup content will be automatically focused when the popup is opened. This is a dependency property.
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPopupOpen | Gets or sets whether the popup is currently displayed. This is a dependency property.
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsPreviewMouseDownHandled | Gets or sets a value indicating whether the click should be executed when a PreviewMouseDown event is raised. This is a dependency property.
Public property | IsRounded | Gets or sets a value indicating whether the button should be drawn with round corners, if the current theme supports rounded corners. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTransparencyModeEnabled | Gets or sets a value indicating whether transparency mode is enabled. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides ContentControlLogicalChildren.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PopupAllowsTransparency | Gets or sets a value for the popup's AllowTransparency property. This is a dependency property.
Public property | PopupAnimation | Gets or sets an animation for the opening and closing of the associated popup. This is a dependency property.
Public property | PopupContent | Gets or sets the content that is displayed on the popup for the button. This is a dependency property.
Public property | PopupContentTemplate | Gets or sets the DataTemplate to use for the PopupContent. This is a dependency property.
Public property | PopupContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the PopupContent. This is a dependency property.
Public property | PopupHorizontalOffset | Gets or sets the horizontal distance between the target origin and the popup alignment point. This is a dependency property.
Public property | PopupIndicator | Gets or sets the object used in the indicator portion of the PopupButton. This is a dependency property.
Public property | PopupIndicatorTemplate | Gets or sets the DataTemplate used to present the indicator portion of the PopupButton. This is a dependency property.
Public property | PopupIndicatorToolTip | Gets or sets the tool-tip object that is displayed for the popup indicator element. This is a dependency property.
Public property | PopupMenu | Gets or sets the ContextMenu shown by the PopupButton. This is a dependency property.
Public property | PopupMenuDataContext | Gets or sets the the data context for the ContextMenu shown by the PopupButton when it participates in data binding. This is a dependency property.
Public property | PopupVerticalOffset | Gets or sets the vertical distance between the target origin and the popup alignment point. This is a dependency property.
Public property | StaysOpen | Gets or sets a value that indicates whether the Popup closes when the control is no longer in focus. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Overrides FrameworkElementVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.ClosePopup Property

PopupButtonClosePopup Property

Gets the RoutedCommand used to close a Popup.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static RoutedCommand ClosePopup { get; }
Public Shared ReadOnly Property ClosePopup As RoutedCommand
    Get

Property Value

Type: RoutedCommand
The RoutedCommand.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.DisplayMode Property

PopupButtonDisplayMode Property

Gets or sets the display mode of the PopupButton. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PopupButtonDisplayMode DisplayMode { get; set; }
Public Property DisplayMode As PopupButtonDisplayMode
    Get
    Set

Property Value

Type: PopupButtonDisplayMode
The display mode.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.HasDropShadow Property

PopupButtonHasDropShadow Property

Gets or sets whether the popup will display a drop-shadow effect. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDropShadow { get; set; }
Public Property HasDropShadow As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the popup will display a drop-shadow effect; otherwise, false. The default value is true.
Remarks
Setting this property to true has no effect if the SystemParameters.DropShadow property is false.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsAutoFocusOnOpenEnabled Property

PopupButtonIsAutoFocusOnOpenEnabled Property

Gets or sets a value indicating whether the popup content will be automatically focused when the popup is opened. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAutoFocusOnOpenEnabled { get; set; }
Public Property IsAutoFocusOnOpenEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the popup content will be automatically focused when the popup is opened; otherwise, false. The default value is false.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsPopupOpen Property

PopupButtonIsPopupOpen Property

Gets or sets whether the popup is currently displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPopupOpen { get; set; }
Public Property IsPopupOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the popup is currently displayed; otherwise, false.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsPreviewMouseDownHandled Property

PopupButtonIsPreviewMouseDownHandled Property

Gets or sets a value indicating whether the click should be executed when a PreviewMouseDown event is raised. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPreviewMouseDownHandled { get; set; }
Public Property IsPreviewMouseDownHandled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the click should be executed when a PreviewMouseDown event is raised; otherwise, false. The default value is false.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsRounded Property

PopupButtonIsRounded Property

Gets or sets a value indicating whether the button should be drawn with round corners, if the current theme supports rounded corners. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsRounded { get; set; }
Public Property IsRounded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the buttons corners should be rounded; otherwise, false. The default value is true.
Remarks
This property is not supported in the following themes:
  • Classic -
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsTransparencyModeEnabled Property

PopupButtonIsTransparencyModeEnabled Property

Gets or sets a value indicating whether transparency mode is enabled. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTransparencyModeEnabled { get; set; }
Public Property IsTransparencyModeEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if transparency mode is enabled; otherwise, false. The default value is false.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.LogicalChildren Property

PopupButtonLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupAllowsTransparency Property

PopupButtonPopupAllowsTransparency Property

Gets or sets a value for the popup's AllowTransparency property. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool PopupAllowsTransparency { get; set; }
Public Property PopupAllowsTransparency As Boolean
    Get
    Set

Property Value

Type: Boolean
true if transparency is allowed; otherwise, false. The default value is true.
Remarks
When this property is set to false, interop content will be able to render on the popup.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupAnimation Property

PopupButtonPopupAnimation Property

Gets or sets an animation for the opening and closing of the associated popup. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PopupAnimation PopupAnimation { get; set; }
Public Property PopupAnimation As PopupAnimation
    Get
    Set

Property Value

Type: PopupAnimation
An animation for the opening and closing of the associated popup.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupContent Property

PopupButtonPopupContent Property

Gets or sets the content that is displayed on the popup for the button. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object PopupContent { get; set; }
Public Property PopupContent As Object
    Get
    Set

Property Value

Type: Object
The content that is displayed on the popup for the button.
Remarks
This can be any object, including panels of multiple controls. The PopupContentTemplate and/or DataTemplateSelector can be used to customize the display of data objects (or non-UI elements). This property takes precedence over the PopupMenu property. Therefore, if this property is set then the PopupMenu property is ignored.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupContentTemplate Property

PopupButtonPopupContentTemplate Property

Gets or sets the DataTemplate to use for the PopupContent. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate PopupContentTemplate { get; set; }
Public Property PopupContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the PopupContent.
Remarks
This property is only really useful if your popup content is a data object and not a UI element.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupContentTemplateSelector Property

PopupButtonPopupContentTemplateSelector Property

Gets or sets the DataTemplateSelector to use for the PopupContent. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector PopupContentTemplateSelector { get; set; }
Public Property PopupContentTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for the PopupContent.
Remarks
This property is only really useful if your popup content is a data object and not a UI element.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupHorizontalOffset Property

PopupButtonPopupHorizontalOffset Property

Gets or sets the horizontal distance between the target origin and the popup alignment point. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double PopupHorizontalOffset { get; set; }
Public Property PopupHorizontalOffset As Double
    Get
    Set

Property Value

Type: Double
The horizontal distance between the target origin and the popup alignment point. The default is 0.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupIndicator Property

PopupButtonPopupIndicator Property

Gets or sets the object used in the indicator portion of the PopupButton. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UIElement PopupIndicator { get; set; }
Public Property PopupIndicator As UIElement
    Get
    Set

Property Value

Type: UIElement
The object used in the indicator portion.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupIndicatorTemplate Property

PopupButtonPopupIndicatorTemplate Property

Gets or sets the DataTemplate used to present the indicator portion of the PopupButton. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate PopupIndicatorTemplate { get; set; }
Public Property PopupIndicatorTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate used to present the indicator portion.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupIndicatorToolTip Property

PopupButtonPopupIndicatorToolTip Property

Gets or sets the tool-tip object that is displayed for the popup indicator element. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object PopupIndicatorToolTip { get; set; }
Public Property PopupIndicatorToolTip As Object
    Get
    Set

Property Value

Type: Object
The tool-tip object that is displayed for the popup indicator element.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupMenu Property

PopupButtonPopupMenu Property

Gets or sets the ContextMenu shown by the PopupButton. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextMenu PopupMenu { get; set; }
Public Property PopupMenu As ContextMenu
    Get
    Set

Property Value

Type: ContextMenu
The ContextMenu shown.
Remarks
The PopupContent property takes precedence over this property. Therefore, if PopupContent is set then this property is ignored.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupMenuDataContext Property

PopupButtonPopupMenuDataContext Property

Gets or sets the the data context for the ContextMenu shown by the PopupButton when it participates in data binding. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object PopupMenuDataContext { get; set; }
Public Property PopupMenuDataContext As Object
    Get
    Set

Property Value

Type: Object
The object to use as data context. The default style binds this property to the DataContext of the PopupButton.
Remarks
The DataContext property of the PopupMenu is bound to this property, if and only if the DataContext property was not already set on the ContextMenu. Additionally, this property
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupVerticalOffset Property

PopupButtonPopupVerticalOffset Property

Gets or sets the vertical distance between the target origin and the popup alignment point. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double PopupVerticalOffset { get; set; }
Public Property PopupVerticalOffset As Double
    Get
    Set

Property Value

Type: Double
The vertical distance between the target origin and the popup alignment point. The default is 0.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.StaysOpen Property

PopupButtonStaysOpen Property

Gets or sets a value that indicates whether the Popup closes when the control is no longer in focus. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool StaysOpen { get; set; }
Public Property StaysOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Popup closes when the control is no longer in focus; otherwise, false. The default is false.
Remarks
This property has no effect when using PopupMenu.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.VisualChildrenCount Property

PopupButtonVisualChildrenCount Property

Gets the number of visual child elements within this element.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override int VisualChildrenCount { get; }
Protected Overrides ReadOnly Property VisualChildrenCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
The number of visual child elements for this element.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton Methods

The PopupButton type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Overrides FrameworkElementGetVisualChild(Int32).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClick | Called when a PopupButton is clicked. (Overrides ButtonOnClick.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PopupButtonAutomationPeer for this control as part of the automation infrastructure. (Overrides ButtonOnCreateAutomationPeer.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown event. (Overrides ButtonBaseOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPopupClosed | Raises the PopupClosed event.
Protected method | OnPopupOpened | Raises the PopupOpened event.
Protected method | OnPopupOpening | Raises the PopupOpening event.
Protected method | OnPreviewKeyDown | Provides class handling for the PreviewKeyDownEvent routed event that occurs when the user presses a key while this control has focus. (Overrides UIElementOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. (Overrides UIElementOnPreviewMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.GetVisualChild Method

PopupButtonGetVisualChild Method

Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Visual GetVisualChild(
    int index
)
Protected Overrides Function GetVisualChild (
    index As Integer
) As Visual

Parameters

index
Type: SystemInt32
The zero-based index of the requested child element in the collection.

Return Value

Type: Visual
The requested child element. This should not return null; if the provided index is out of range, an exception is thrown.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.OnApplyTemplate Method

PopupButtonOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.OnClick Method

PopupButtonOnClick Method

Called when a PopupButton is clicked.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnClick()
Protected Overrides Sub OnClick
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.OnCreateAutomationPeer Method

PopupButtonOnCreateAutomationPeer Method

Creates an appropriate PopupButtonAutomationPeer for this control as part of the automation infrastructure.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.PopupButton.OnCreateAutomationPeer"]

See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.OnMouseLeftButtonDown Method

PopupButtonOnMouseLeftButtonDown Method

Provides class handling for the MouseLeftButtonDown event.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The event data.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.OnPopupClosed Method

PopupButtonOnPopupClosed Method

Raises the PopupClosed event.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPopupClosed(
    RoutedEventArgs e
)
Protected Overridable Sub OnPopupClosed (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.OnPopupOpened Method

PopupButtonOnPopupOpened Method

Raises the PopupOpened event.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPopupOpened(
    RoutedEventArgs e
)
Protected Overridable Sub OnPopupOpened (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.OnPopupOpening Method

PopupButtonOnPopupOpening Method

Raises the PopupOpening event.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPopupOpening(
    CancelRoutedEventArgs e
)
Protected Overridable Sub OnPopupOpening (
    e As CancelRoutedEventArgs
)

Parameters

e
Type: ActiproSoftware.WindowsCancelRoutedEventArgs
A CancelRoutedEventArgs that contains the event data.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.OnPreviewKeyDown Method

PopupButtonOnPreviewKeyDown Method

Provides class handling for the PreviewKeyDownEvent routed event that occurs when the user presses a key while this control has focus.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPreviewKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnPreviewKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The event data.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.OnPreviewMouseLeftButtonDown Method

PopupButtonOnPreviewMouseLeftButtonDown Method

Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPreviewMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnPreviewMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. The event data reports that the left mouse button was pressed.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton Events

The PopupButton type exposes the following members.

Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PopupClosed | Occurs when the IsPopupOpen property changes to false.
Public event | PopupOpened | Occurs when the IsPopupOpen property changes to true.
Public event | PopupOpening | Occurs before the IsPopupOpen property changes to true.
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupClosed Event

PopupButtonPopupClosed Event

Occurs when the IsPopupOpen property changes to false.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler PopupClosed
Public Event PopupClosed As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupOpened Event

PopupButtonPopupOpened Event

Occurs when the IsPopupOpen property changes to true.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler PopupOpened
Public Event PopupOpened As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupOpening Event

PopupButtonPopupOpening Event

Occurs before the IsPopupOpen property changes to true.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CancelRoutedEventArgs> PopupOpening
Public Event PopupOpening As EventHandler(Of CancelRoutedEventArgs)

Value

Type: SystemEventHandler CancelRoutedEventArgs
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton Fields

The PopupButton type exposes the following members.

Fields
Name | Description
DisplayModeProperty | Identifies the DisplayMode dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
IsAutoFocusOnOpenEnabledProperty | Identifies the IsAutoFocusOnOpenEnabled dependency property. This field is read-only.
IsPopupOpenProperty | Identifies the IsPopupOpen dependency property. This field is read-only.
IsPreviewMouseDownHandledProperty | Identifies the IsPreviewMouseDownHandled dependency property. This field is read-only.
IsRoundedProperty | Identifies the IsRounded dependency property. This field is read-only.
IsTransparencyModeEnabledProperty | Identifies the IsTransparencyModeEnabled dependency property. This field is read-only.
PopupAllowsTransparencyProperty | Identifies the PopupAllowsTransparency dependency property. This field is read-only.
PopupAnimationProperty | Identifies the PopupAnimation dependency property. This field is read-only.
PopupClosedEvent | Identifies the PopupClosed routed event. This field is read-only.
PopupContentProperty | Identifies the PopupContent dependency property. This field is read-only.
PopupContentTemplateProperty | Identifies the PopupContentTemplate dependency property. This field is read-only.
PopupContentTemplateSelectorProperty | Identifies the PopupContentTemplateSelector dependency property. This field is read-only.
PopupHorizontalOffsetProperty | Identifies the PopupHorizontalOffset dependency property. This field is read-only.
PopupIndicatorProperty | Identifies the PopupIndicator dependency property. This field is read-only.
PopupIndicatorTemplateProperty | Identifies the PopupIndicatorTemplate dependency property. This field is read-only.
PopupIndicatorToolTipProperty | Identifies the PopupIndicatorToolTip dependency property. This field is read-only.
PopupMenuDataContextProperty | Identifies the PopupMenuDataContext dependency property. This field is read-only.
PopupMenuProperty | Identifies the PopupMenu dependency property. This field is read-only.
PopupOpenedEvent | Identifies the PopupOpened routed event. This field is read-only.
PopupOpeningEvent | Identifies the PopupOpening routed event. This field is read-only.
PopupVerticalOffsetProperty | Identifies the PopupVerticalOffset dependency property. This field is read-only.
StaysOpenProperty | Identifies the StaysOpen dependency property. This field is read-only.
Top
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.DisplayModeProperty Field

PopupButtonDisplayModeProperty Field

Identifies the DisplayMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayModeProperty
Public Shared ReadOnly DisplayModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayMode dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.HasDropShadowProperty Field

PopupButtonHasDropShadowProperty Field

Identifies the HasDropShadow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasDropShadowProperty
Public Shared ReadOnly HasDropShadowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasDropShadow dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsAutoFocusOnOpenEnabledProperty Field

PopupButtonIsAutoFocusOnOpenEnabledProperty Field

Identifies the IsAutoFocusOnOpenEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoFocusOnOpenEnabledProperty
Public Shared ReadOnly IsAutoFocusOnOpenEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoFocusOnOpenEnabled dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsPopupOpenProperty Field

PopupButtonIsPopupOpenProperty Field

Identifies the IsPopupOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPopupOpenProperty
Public Shared ReadOnly IsPopupOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPopupOpen dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsPreviewMouseDownHandledProperty Field

PopupButtonIsPreviewMouseDownHandledProperty Field

Identifies the IsPreviewMouseDownHandled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPreviewMouseDownHandledProperty
Public Shared ReadOnly IsPreviewMouseDownHandledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPreviewMouseDownHandled dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsRoundedProperty Field

PopupButtonIsRoundedProperty Field

Identifies the IsRounded dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRoundedProperty
Public Shared ReadOnly IsRoundedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRounded dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.IsTransparencyModeEnabledProperty Field

PopupButtonIsTransparencyModeEnabledProperty Field

Identifies the IsTransparencyModeEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTransparencyModeEnabledProperty
Public Shared ReadOnly IsTransparencyModeEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTransparencyModeEnabled dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupAllowsTransparencyProperty Field

PopupButtonPopupAllowsTransparencyProperty Field

Identifies the PopupAllowsTransparency dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupAllowsTransparencyProperty
Public Shared ReadOnly PopupAllowsTransparencyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupAllowsTransparency dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupAnimationProperty Field

PopupButtonPopupAnimationProperty Field

Identifies the PopupAnimation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupAnimationProperty
Public Shared ReadOnly PopupAnimationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupAnimation dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupClosedEvent Field

PopupButtonPopupClosedEvent Field

Identifies the PopupClosed routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent PopupClosedEvent
Public Shared ReadOnly PopupClosedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the PopupClosed routed event.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupContentProperty Field

PopupButtonPopupContentProperty Field

Identifies the PopupContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupContentProperty
Public Shared ReadOnly PopupContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupContent dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupContentTemplateProperty Field

PopupButtonPopupContentTemplateProperty Field

Identifies the PopupContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupContentTemplateProperty
Public Shared ReadOnly PopupContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupContentTemplate dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupContentTemplateSelectorProperty Field

PopupButtonPopupContentTemplateSelectorProperty Field

Identifies the PopupContentTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupContentTemplateSelectorProperty
Public Shared ReadOnly PopupContentTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupContentTemplateSelector dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupHorizontalOffsetProperty Field

PopupButtonPopupHorizontalOffsetProperty Field

Identifies the PopupHorizontalOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupHorizontalOffsetProperty
Public Shared ReadOnly PopupHorizontalOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupHorizontalOffset dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupIndicatorProperty Field

PopupButtonPopupIndicatorProperty Field

Identifies the PopupIndicator dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupIndicatorProperty
Public Shared ReadOnly PopupIndicatorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupIndicator dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupIndicatorTemplateProperty Field

PopupButtonPopupIndicatorTemplateProperty Field

Identifies the PopupIndicatorTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupIndicatorTemplateProperty
Public Shared ReadOnly PopupIndicatorTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupIndicatorTemplate dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupIndicatorToolTipProperty Field

PopupButtonPopupIndicatorToolTipProperty Field

Identifies the PopupIndicatorToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupIndicatorToolTipProperty
Public Shared ReadOnly PopupIndicatorToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupIndicatorToolTip dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupMenuDataContextProperty Field

PopupButtonPopupMenuDataContextProperty Field

Identifies the PopupMenuDataContext dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupMenuDataContextProperty
Public Shared ReadOnly PopupMenuDataContextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupMenuDataContext dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupMenuProperty Field

PopupButtonPopupMenuProperty Field

Identifies the PopupMenu dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupMenuProperty
Public Shared ReadOnly PopupMenuProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupMenu dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupOpenedEvent Field

PopupButtonPopupOpenedEvent Field

Identifies the PopupOpened routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent PopupOpenedEvent
Public Shared ReadOnly PopupOpenedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the PopupOpened routed event.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupOpeningEvent Field

PopupButtonPopupOpeningEvent Field

Identifies the PopupOpening routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent PopupOpeningEvent
Public Shared ReadOnly PopupOpeningEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the PopupOpening routed event.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.PopupVerticalOffsetProperty Field

PopupButtonPopupVerticalOffsetProperty Field

Identifies the PopupVerticalOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupVerticalOffsetProperty
Public Shared ReadOnly PopupVerticalOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupVerticalOffset dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButton.StaysOpenProperty Field

PopupButtonStaysOpenProperty Field

Identifies the StaysOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StaysOpenProperty
Public Shared ReadOnly StaysOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StaysOpen dependency property.
See Also

Reference

PopupButton Class
ActiproSoftware.Windows.Controls Namespace


PopupButtonDisplayMode Enumeration

Specifies the display mode of a PopupButton control.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PopupButtonDisplayMode
Public Enumeration PopupButtonDisplayMode
Members
Member name | Value | Description
Split | 0 | The PopupButton control will show the content in a normal button area and the popup indicator. This display mode is also known as a split button.
Merged | 1 | The PopupButton control will show the content inside the popup indicator. This display mode is also know as a drop-down button.
ButtonOnly | 2 | The PopupButton control will show the content as a normal button, but no popup indicator. This display mode is identical to a normal Button.
PopupOnly | 3 | The PopupButton control will show the popup indicator, but not the content.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


RadialSlider Class

Represents a radial slider.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesRangeBase
ActiproSoftware.Windows.ControlsRadialSlider
ActiproSoftware.Windows.Controls.Editors.PrimitivesEmbeddedRadialSlider

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RadialSlider : RangeBase
Public Class RadialSlider
    Inherits RangeBase

The RadialSlider type exposes the following members.

Constructors
 | Name | Description
Public method | RadialSlider | Initializes an instance of the RadialSlider class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IntermediateValue | Gets or sets the value of the slider while the user is interacting with it, before the value is snapped.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Radius | Gets or sets the slider's radius.
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ThumbArrowAngle | Gets or sets the thumb's arrow angle.
Public property | ThumbBackground | Gets or sets the background Brush to render when the thumb is in a normal state.
Public property | ThumbPressedBackground | Gets or sets the background Brush to render when the thumb is pressed.
Public property | ThumbStyle | Gets or sets the Style to use for the thumb.
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMaximumChanged | Called when the Maximum property changes. (Inherited from RangeBase.)
Protected method | OnMinimumChanged | Called when the Minimum property changes. (Inherited from RangeBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed. (Overrides RangeBaseOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SetValueCore | Sets the Value property and applies snapping.
Public method | StartDrag | Starts a thumb drag.
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
Fields
Name | Description
IntermediateValueProperty | Identifies the IntermediateValue dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
ThumbArrowAngleProperty | Identifies the ThumbArrowAngle dependency property. This field is read-only.
ThumbBackgroundProperty | Identifies the ThumbBackground dependency property. This field is read-only.
ThumbPressedBackgroundProperty | Identifies the ThumbPressedBackground dependency property. This field is read-only.
ThumbStyleProperty | Identifies the ThumbStyle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


RadialSlider Constructor

Initializes an instance of the RadialSlider class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RadialSlider()
Public Sub New
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider Properties

The RadialSlider type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IntermediateValue | Gets or sets the value of the slider while the user is interacting with it, before the value is snapped.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Radius | Gets or sets the slider's radius.
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ThumbArrowAngle | Gets or sets the thumb's arrow angle.
Public property | ThumbBackground | Gets or sets the background Brush to render when the thumb is in a normal state.
Public property | ThumbPressedBackground | Gets or sets the background Brush to render when the thumb is pressed.
Public property | ThumbStyle | Gets or sets the Style to use for the thumb.
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.IntermediateValue Property

RadialSliderIntermediateValue Property

Gets or sets the value of the slider while the user is interacting with it, before the value is snapped.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double IntermediateValue { get; set; }
Public Property IntermediateValue As Double
    Get
    Set

Property Value

Type: Double
A temporary value.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.Radius Property

RadialSliderRadius Property

Gets or sets the slider's radius.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The slider's radius. The default value is 100.0.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.ThumbArrowAngle Property

RadialSliderThumbArrowAngle Property

Gets or sets the thumb's arrow angle.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ThumbArrowAngle { get; set; }
Public Property ThumbArrowAngle As Double
    Get
    Set

Property Value

Type: Double
The thumb's arrow angle. The default value is 180.0, meaning it will face down when up at 0 degrees in the slider.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.ThumbBackground Property

RadialSliderThumbBackground Property

Gets or sets the background Brush to render when the thumb is in a normal state.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ThumbBackground { get; set; }
Public Property ThumbBackground As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush to render when the thumb is in a normal state.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.ThumbPressedBackground Property

RadialSliderThumbPressedBackground Property

Gets or sets the background Brush to render when the thumb is pressed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ThumbPressedBackground { get; set; }
Public Property ThumbPressedBackground As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush to render when the thumb is pressed.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.ThumbStyle Property

RadialSliderThumbStyle Property

Gets or sets the Style to use for the thumb.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ThumbStyle { get; set; }
Public Property ThumbStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the thumb.
Remarks
Use this property if a custom thumb Style is desired.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider Methods

The RadialSlider type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMaximumChanged | Called when the Maximum property changes. (Inherited from RangeBase.)
Protected method | OnMinimumChanged | Called when the Minimum property changes. (Inherited from RangeBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed. (Overrides RangeBaseOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SetValueCore | Sets the Value property and applies snapping.
Public method | StartDrag | Starts a thumb drag.
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.OnApplyTemplate Method

RadialSliderOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.OnCreateAutomationPeer Method

RadialSliderOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.OnValueChanged Method

RadialSliderOnValueChanged Method

Occurs when the Value property has changed.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    double oldValue,
    double newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The old value.
newValue
Type: SystemDouble
The new value.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.SetValueCore Method

RadialSliderSetValueCore Method

Sets the Value property and applies snapping.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void SetValueCore(
    double value
)
Protected Sub SetValueCore (
    value As Double
)

Parameters

value
Type: SystemDouble
The value to set.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.StartDrag Method

RadialSliderStartDrag Method

Starts a thumb drag.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void StartDrag(
    InputPointerButtonEventArgs sourceEventArgs
)
Public Sub StartDrag (
    sourceEventArgs As InputPointerButtonEventArgs
)

Parameters

sourceEventArgs
Type: ActiproSoftware.Windows.InputInputPointerButtonEventArgs
The source InputPointerButtonEventArgs, which can be used to capture the pointer.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider Events

The RadialSlider type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider Fields

The RadialSlider type exposes the following members.

Fields
Name | Description
IntermediateValueProperty | Identifies the IntermediateValue dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
ThumbArrowAngleProperty | Identifies the ThumbArrowAngle dependency property. This field is read-only.
ThumbBackgroundProperty | Identifies the ThumbBackground dependency property. This field is read-only.
ThumbPressedBackgroundProperty | Identifies the ThumbPressedBackground dependency property. This field is read-only.
ThumbStyleProperty | Identifies the ThumbStyle dependency property. This field is read-only.
Top
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.IntermediateValueProperty Field

RadialSliderIntermediateValueProperty Field

Identifies the IntermediateValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IntermediateValueProperty
Public Shared ReadOnly IntermediateValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IntermediateValue dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.RadiusProperty Field

RadialSliderRadiusProperty Field

Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.ThumbArrowAngleProperty Field

RadialSliderThumbArrowAngleProperty Field

Identifies the ThumbArrowAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThumbArrowAngleProperty
Public Shared ReadOnly ThumbArrowAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThumbArrowAngle dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.ThumbBackgroundProperty Field

RadialSliderThumbBackgroundProperty Field

Identifies the ThumbBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThumbBackgroundProperty
Public Shared ReadOnly ThumbBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThumbBackground dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.ThumbPressedBackgroundProperty Field

RadialSliderThumbPressedBackgroundProperty Field

Identifies the ThumbPressedBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThumbPressedBackgroundProperty
Public Shared ReadOnly ThumbPressedBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThumbPressedBackground dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadialSlider.ThumbStyleProperty Field

RadialSliderThumbStyleProperty Field

Identifies the ThumbStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThumbStyleProperty
Public Shared ReadOnly ThumbStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThumbStyle dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList Class

Represents a ListBox that renders its items as a list of radio buttons.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsListBox
ActiproSoftware.Windows.ControlsRadioButtonList

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RadioButtonList : ListBox
Public Class RadioButtonList
    Inherits ListBox

The RadioButtonList type exposes the following members.

Constructors
 | Name | Description
Public method | RadioButtonList | Initializes a new instance of the RadioButtonList class
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AutoDisableNonSelectedItemContent | Gets or sets whether item content will be automatically disabled when the item is not selected. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BulletMargin | Gets or sets the Thickness of the margin around the bullet. This is a dependency property.
Public property | BulletVerticalAlignment | Gets or sets a VerticalAlignment that indicates the vertical alignment of the bullet. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Orientation | Gets or sets the Orientation that indicates the orientation of the list items. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetBulletMargin | Gets the value of the BulletMargin attached property for the specified object.
 | GetBulletVerticalAlignment | Gets the value of the BulletVerticalAlignment attached property for the specified object.
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Inherited from ListBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
 | SetBulletMargin | Sets the value of the BulletMargin attached property to the specified object.
 | SetBulletVerticalAlignment | Sets the value of the BulletVerticalAlignment attached property to the specified object.
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
Fields
Name | Description
AutoDisableNonSelectedItemContentProperty | Identifies the AutoDisableNonSelectedItemContent dependency property. This field is read-only.
BulletMarginProperty | Identifies the BulletMargin dependency property. This field is read-only.
BulletVerticalAlignmentProperty | Identifies the BulletVerticalAlignment dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the RadioButtonList documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


RadioButtonList Constructor

Initializes a new instance of the RadioButtonList class

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RadioButtonList()
Public Sub New
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList Properties

The RadioButtonList type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AutoDisableNonSelectedItemContent | Gets or sets whether item content will be automatically disabled when the item is not selected. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BulletMargin | Gets or sets the Thickness of the margin around the bullet. This is a dependency property.
Public property | BulletVerticalAlignment | Gets or sets a VerticalAlignment that indicates the vertical alignment of the bullet. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Orientation | Gets or sets the Orientation that indicates the orientation of the list items. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.AutoDisableNonSelectedItemContent Property

RadioButtonListAutoDisableNonSelectedItemContent Property

Gets or sets whether item content will be automatically disabled when the item is not selected. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AutoDisableNonSelectedItemContent { get; set; }
Public Property AutoDisableNonSelectedItemContent As Boolean
    Get
    Set

Property Value

Type: Boolean
true if item content will be automatically disabled when the item is not selected; otherwise, false. The default value is false.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.BulletMargin Property

RadioButtonListBulletMargin Property

Gets or sets the Thickness of the margin around the bullet. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness BulletMargin { get; set; }
Public Property BulletMargin As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the margin around the bullet. The default value is 0, 0, 4, 0.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.BulletVerticalAlignment Property

RadioButtonListBulletVerticalAlignment Property

Gets or sets a VerticalAlignment that indicates the vertical alignment of the bullet. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VerticalAlignment BulletVerticalAlignment { get; set; }
Public Property BulletVerticalAlignment As VerticalAlignment
    Get
    Set

Property Value

Type: VerticalAlignment
A VerticalAlignment that indicates the vertical alignment of the bullet. The default value is VerticalAlignment.Center.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.Orientation Property

RadioButtonListOrientation Property

Gets or sets the Orientation that indicates the orientation of the list items. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation that indicates the orientation of the list items. The default value is Orientation.Vertical.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList Methods

The RadioButtonList type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetBulletMargin | Gets the value of the BulletMargin attached property for the specified object.
 | GetBulletVerticalAlignment | Gets the value of the BulletVerticalAlignment attached property for the specified object.
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Inherited from ListBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
 | SetBulletMargin | Sets the value of the BulletMargin attached property to the specified object.
 | SetBulletVerticalAlignment | Sets the value of the BulletVerticalAlignment attached property to the specified object.
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.GetBulletMargin Method

RadioButtonListGetBulletMargin Method

Gets the value of the BulletMargin attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Thickness GetBulletMargin(
    DependencyObject obj
)
Public Shared Function GetBulletMargin (
    obj As DependencyObject
) As Thickness

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Thickness
The object's value.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.GetBulletVerticalAlignment Method

RadioButtonListGetBulletVerticalAlignment Method

Gets the value of the BulletVerticalAlignment attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static VerticalAlignment GetBulletVerticalAlignment(
    DependencyObject obj
)
Public Shared Function GetBulletVerticalAlignment (
    obj As DependencyObject
) As VerticalAlignment

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: VerticalAlignment
The object's value.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.SetBulletMargin Method

RadioButtonListSetBulletMargin Method

Sets the value of the BulletMargin attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetBulletMargin(
    DependencyObject obj,
    Thickness value
)
Public Shared Sub SetBulletMargin (
    obj As DependencyObject,
    value As Thickness
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: System.WindowsThickness
The value to set.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.SetBulletVerticalAlignment Method

RadioButtonListSetBulletVerticalAlignment Method

Sets the value of the BulletVerticalAlignment attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetBulletVerticalAlignment(
    DependencyObject obj,
    VerticalAlignment value
)
Public Shared Sub SetBulletVerticalAlignment (
    obj As DependencyObject,
    value As VerticalAlignment
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: System.WindowsVerticalAlignment
The value to set.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList Events

The RadioButtonList type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList Fields

The RadioButtonList type exposes the following members.

Fields
Name | Description
AutoDisableNonSelectedItemContentProperty | Identifies the AutoDisableNonSelectedItemContent dependency property. This field is read-only.
BulletMarginProperty | Identifies the BulletMargin dependency property. This field is read-only.
BulletVerticalAlignmentProperty | Identifies the BulletVerticalAlignment dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.AutoDisableNonSelectedItemContentProperty Field

RadioButtonListAutoDisableNonSelectedItemContentProperty Field

Identifies the AutoDisableNonSelectedItemContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoDisableNonSelectedItemContentProperty
Public Shared ReadOnly AutoDisableNonSelectedItemContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoDisableNonSelectedItemContent dependency property.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.BulletMarginProperty Field

RadioButtonListBulletMarginProperty Field

Identifies the BulletMargin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BulletMarginProperty
Public Shared ReadOnly BulletMarginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BulletMargin dependency property.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.BulletVerticalAlignmentProperty Field

RadioButtonListBulletVerticalAlignmentProperty Field

Identifies the BulletVerticalAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BulletVerticalAlignmentProperty
Public Shared ReadOnly BulletVerticalAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BulletVerticalAlignment dependency property.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


RadioButtonList.OrientationProperty Field

RadioButtonListOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

RadioButtonList Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl Class

Represents a ContentControl that displays its content and a reflection of the content below it.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.ControlsReflectionContentControl

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReflectionContentControl : ContentControl
Public Class ReflectionContentControl
    Inherits ContentControl

The ReflectionContentControl type exposes the following members.

Constructors
 | Name | Description
Public method | ReflectionContentControl | Initializes an instance of the ReflectionContentControl class.
Public method | ReflectionContentControl(Object) | Initializes an instance of the ReflectionContentControl class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ReflectionEndOffset | Gets or sets the offset at which the end opacity (least opaque) is located in the reflection.
Public property | ReflectionEndOpacity | Gets or sets the opacity of the reflection at its ending (least opaque) point.
Public property | ReflectionHeight | Gets or sets the height of the reflection.
Public property | ReflectionMargin | Gets or sets the margin distance between the content and the reflection.
Public property | ReflectionSkewAngleX | Gets or sets the skew angle of the reflection in the x-plane.
Public property | ReflectionStartOpacity | Gets or sets the opacity of the reflection at its starting (most opaque) point.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ReflectionEndOffsetProperty | Identifies the ReflectionEndOffset dependency property. This field is read-only.
ReflectionEndOpacityProperty | Identifies the ReflectionEndOpacity dependency property. This field is read-only.
ReflectionHeightProperty | Identifies the ReflectionHeight dependency property. This field is read-only.
ReflectionMarginProperty | Identifies the ReflectionMargin dependency property. This field is read-only.
ReflectionSkewAngleXProperty | Identifies the ReflectionSkewAngleX dependency property. This field is read-only.
ReflectionStartOpacityProperty | Identifies the ReflectionStartOpacity dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the ReflectionContentControl documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl Constructor

Overload List
 | Name | Description
Public method | ReflectionContentControl | Initializes an instance of the ReflectionContentControl class.
Public method | ReflectionContentControl(Object) | Initializes an instance of the ReflectionContentControl class.
Top
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl Constructor

Initializes an instance of the ReflectionContentControl class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReflectionContentControl()
Public Sub New
See Also

Reference

ReflectionContentControl Class
ReflectionContentControl Overload
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl Constructor (Object)

Initializes an instance of the ReflectionContentControl class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReflectionContentControl(
    Object content
)
Public Sub New (
    content As Object
)

Parameters

content
Type: SystemObject
The object to use as the content.
See Also

Reference

ReflectionContentControl Class
ReflectionContentControl Overload
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl Properties

The ReflectionContentControl type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ReflectionEndOffset | Gets or sets the offset at which the end opacity (least opaque) is located in the reflection.
Public property | ReflectionEndOpacity | Gets or sets the opacity of the reflection at its ending (least opaque) point.
Public property | ReflectionHeight | Gets or sets the height of the reflection.
Public property | ReflectionMargin | Gets or sets the margin distance between the content and the reflection.
Public property | ReflectionSkewAngleX | Gets or sets the skew angle of the reflection in the x-plane.
Public property | ReflectionStartOpacity | Gets or sets the opacity of the reflection at its starting (most opaque) point.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionEndOffset Property

ReflectionContentControlReflectionEndOffset Property

Gets or sets the offset at which the end opacity (least opaque) is located in the reflection.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ReflectionEndOffset { get; set; }
Public Property ReflectionEndOffset As Double
    Get
    Set

Property Value

Type: Double
The offset at which the end opacity (least opaque) is located in the reflection. The default value is 0.9.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionEndOpacity Property

ReflectionContentControlReflectionEndOpacity Property

Gets or sets the opacity of the reflection at its ending (least opaque) point.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ReflectionEndOpacity { get; set; }
Public Property ReflectionEndOpacity As Double
    Get
    Set

Property Value

Type: Double
The opacity of the reflection at its starting (least opaque) point. The default value is 0.0, meaning transparent.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionHeight Property

ReflectionContentControlReflectionHeight Property

Gets or sets the height of the reflection.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ReflectionHeight { get; set; }
Public Property ReflectionHeight As Double
    Get
    Set

Property Value

Type: Double
The height of the reflection. The default value is NaN, meaning that the height will be the same height as the content.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionMargin Property

ReflectionContentControlReflectionMargin Property

Gets or sets the margin distance between the content and the reflection.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ReflectionMargin { get; set; }
Public Property ReflectionMargin As Double
    Get
    Set

Property Value

Type: Double
The margin distance between the content and the reflection. The default value is 0.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionSkewAngleX Property

ReflectionContentControlReflectionSkewAngleX Property

Gets or sets the skew angle of the reflection in the x-plane.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ReflectionSkewAngleX { get; set; }
Public Property ReflectionSkewAngleX As Double
    Get
    Set

Property Value

Type: Double
The skew angle of the reflection in the x-plane. The default value is 0, meaning no skew is applied.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionStartOpacity Property

ReflectionContentControlReflectionStartOpacity Property

Gets or sets the opacity of the reflection at its starting (most opaque) point.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ReflectionStartOpacity { get; set; }
Public Property ReflectionStartOpacity As Double
    Get
    Set

Property Value

Type: Double
The opacity of the reflection at its starting (most opaque) point. The default value is 0.4, meaning 40% opaque.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl Methods

The ReflectionContentControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.OnRender Method

ReflectionContentControlOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl Events

The ReflectionContentControl type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl Fields

The ReflectionContentControl type exposes the following members.

Fields
Name | Description
ReflectionEndOffsetProperty | Identifies the ReflectionEndOffset dependency property. This field is read-only.
ReflectionEndOpacityProperty | Identifies the ReflectionEndOpacity dependency property. This field is read-only.
ReflectionHeightProperty | Identifies the ReflectionHeight dependency property. This field is read-only.
ReflectionMarginProperty | Identifies the ReflectionMargin dependency property. This field is read-only.
ReflectionSkewAngleXProperty | Identifies the ReflectionSkewAngleX dependency property. This field is read-only.
ReflectionStartOpacityProperty | Identifies the ReflectionStartOpacity dependency property. This field is read-only.
Top
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionEndOffsetProperty Field

ReflectionContentControlReflectionEndOffsetProperty Field

Identifies the ReflectionEndOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReflectionEndOffsetProperty
Public Shared ReadOnly ReflectionEndOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReflectionEndOffset dependency property.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionEndOpacityProperty Field

ReflectionContentControlReflectionEndOpacityProperty Field

Identifies the ReflectionEndOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReflectionEndOpacityProperty
Public Shared ReadOnly ReflectionEndOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReflectionEndOpacity dependency property.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionHeightProperty Field

ReflectionContentControlReflectionHeightProperty Field

Identifies the ReflectionHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReflectionHeightProperty
Public Shared ReadOnly ReflectionHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReflectionHeight dependency property.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionMarginProperty Field

ReflectionContentControlReflectionMarginProperty Field

Identifies the ReflectionMargin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReflectionMarginProperty
Public Shared ReadOnly ReflectionMarginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReflectionMargin dependency property.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionSkewAngleXProperty Field

ReflectionContentControlReflectionSkewAngleXProperty Field

Identifies the ReflectionSkewAngleX dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReflectionSkewAngleXProperty
Public Shared ReadOnly ReflectionSkewAngleXProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReflectionSkewAngleX dependency property.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ReflectionContentControl.ReflectionStartOpacityProperty Field

ReflectionContentControlReflectionStartOpacityProperty Field

Identifies the ReflectionStartOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReflectionStartOpacityProperty
Public Shared ReadOnly ReflectionStartOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReflectionStartOpacity dependency property.
See Also

Reference

ReflectionContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl Class

Represents a ContentControl that contains a gripper, allowing it to be resized.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.ControlsResizableContentControl

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ResizableContentControl : ContentControl
Public Class ResizableContentControl
    Inherits ContentControl

The ResizableContentControl type exposes the following members.

Constructors
 | Name | Description
Public method | ResizableContentControl | Initializes an instance of the ResizableContentControl class.
Public method | ResizableContentControl(Object) | Initializes an instance of the ResizableContentControl class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAutoSize | Gets or sets whether the gripper auto-sizes to its content when it is double-clicked.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GripperBackground | Gets or sets the Brush to use for the gripper background.
Public property | GripperForeground | Gets or sets the Brush to use for the gripper foreground.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ResizeMode | Gets or sets a ControlResizeMode indicating the resizing capabilities of the gripper.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | AutoSize | Auto-sizes the content control to the desired size of its content.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetUseAlternateScrollViewerStyle | Gets the value of the UseAlternateScrollViewerStyleProperty attached property for a specified object.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetUseAlternateScrollViewerStyle | Sets the value of the UseAlternateScrollViewerStyleProperty attached property to a specified object.
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CanAutoSizeProperty | Identifies the CanAutoSize dependency property. This field is read-only.
GripperBackgroundProperty | Identifies the GripperBackground dependency property. This field is read-only.
GripperForegroundProperty | Identifies the GripperForeground dependency property. This field is read-only.
ResizeModeProperty | Identifies the ResizeMode dependency property. This field is read-only.
UseAlternateScrollViewerStyleProperty | Identifies the UseAlternateScrollViewerStyle dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | UseAlternateScrollViewerStyle |
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the ResizableContentControl documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


ResizableContentControl Constructor

Overload List
 | Name | Description
Public method | ResizableContentControl | Initializes an instance of the ResizableContentControl class.
Public method | ResizableContentControl(Object) | Initializes an instance of the ResizableContentControl class.
Top
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl Constructor

Initializes an instance of the ResizableContentControl class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ResizableContentControl()
Public Sub New
See Also

Reference

ResizableContentControl Class
ResizableContentControl Overload
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl Constructor (Object)

Initializes an instance of the ResizableContentControl class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ResizableContentControl(
    Object content
)
Public Sub New (
    content As Object
)

Parameters

content
Type: SystemObject
The object to use as the content.
See Also

Reference

ResizableContentControl Class
ResizableContentControl Overload
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl Properties

The ResizableContentControl type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAutoSize | Gets or sets whether the gripper auto-sizes to its content when it is double-clicked.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GripperBackground | Gets or sets the Brush to use for the gripper background.
Public property | GripperForeground | Gets or sets the Brush to use for the gripper foreground.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ResizeMode | Gets or sets a ControlResizeMode indicating the resizing capabilities of the gripper.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.CanAutoSize Property

ResizableContentControlCanAutoSize Property

Gets or sets whether the gripper auto-sizes to its content when it is double-clicked.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanAutoSize { get; set; }
Public Property CanAutoSize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the gripper auto-sizes to its content when it is double-clicked; otherwise, false. The default value is true.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.GripperBackground Property

ResizableContentControlGripperBackground Property

Gets or sets the Brush to use for the gripper background.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush GripperBackground { get; set; }
Public Property GripperBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for the gripper background.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.GripperForeground Property

ResizableContentControlGripperForeground Property

Gets or sets the Brush to use for the gripper foreground.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush GripperForeground { get; set; }
Public Property GripperForeground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for the gripper foreground.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.ResizeMode Property

ResizableContentControlResizeMode Property

Gets or sets a ControlResizeMode indicating the resizing capabilities of the gripper.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ControlResizeMode ResizeMode { get; set; }
Public Property ResizeMode As ControlResizeMode
    Get
    Set

Property Value

Type: ControlResizeMode
A ControlResizeMode indicating the resizing capabilities of the gripper. The default value is ControlResizeMode.Both.
Remarks
Use the ControlResizeMode.None value to hide the gripper.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl Methods

The ResizableContentControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | AutoSize | Auto-sizes the content control to the desired size of its content.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetUseAlternateScrollViewerStyle | Gets the value of the UseAlternateScrollViewerStyleProperty attached property for a specified object.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetUseAlternateScrollViewerStyle | Sets the value of the UseAlternateScrollViewerStyleProperty attached property to a specified object.
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.AutoSize Method

ResizableContentControlAutoSize Method

Auto-sizes the content control to the desired size of its content.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AutoSize()
Public Sub AutoSize
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.GetUseAlternateScrollViewerStyle Method

ResizableContentControlGetUseAlternateScrollViewerStyle Method

Gets the value of the UseAlternateScrollViewerStyleProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetUseAlternateScrollViewerStyle(
    DependencyObject obj
)
Public Shared Function GetUseAlternateScrollViewerStyle (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Boolean
true if the alternate Style should be used for ScrollViewer elements; otherwise, false.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.OnApplyTemplate Method

ResizableContentControlOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.SetUseAlternateScrollViewerStyle Method

ResizableContentControlSetUseAlternateScrollViewerStyle Method

Sets the value of the UseAlternateScrollViewerStyleProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetUseAlternateScrollViewerStyle(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetUseAlternateScrollViewerStyle (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
true if the alternate Style should be used for ScrollViewer elements; otherwise, false.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl Events

The ResizableContentControl type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl Fields

The ResizableContentControl type exposes the following members.

Fields
Name | Description
CanAutoSizeProperty | Identifies the CanAutoSize dependency property. This field is read-only.
GripperBackgroundProperty | Identifies the GripperBackground dependency property. This field is read-only.
GripperForegroundProperty | Identifies the GripperForeground dependency property. This field is read-only.
ResizeModeProperty | Identifies the ResizeMode dependency property. This field is read-only.
UseAlternateScrollViewerStyleProperty | Identifies the UseAlternateScrollViewerStyle dependency property. This field is read-only.
Top
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.CanAutoSizeProperty Field

ResizableContentControlCanAutoSizeProperty Field

Identifies the CanAutoSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAutoSizeProperty
Public Shared ReadOnly CanAutoSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAutoSize dependency property.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.GripperBackgroundProperty Field

ResizableContentControlGripperBackgroundProperty Field

Identifies the GripperBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GripperBackgroundProperty
Public Shared ReadOnly GripperBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GripperBackground dependency property.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.GripperForegroundProperty Field

ResizableContentControlGripperForegroundProperty Field

Identifies the GripperForeground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GripperForegroundProperty
Public Shared ReadOnly GripperForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GripperForeground dependency property.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.ResizeModeProperty Field

ResizableContentControlResizeModeProperty Field

Identifies the ResizeMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResizeModeProperty
Public Shared ReadOnly ResizeModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResizeMode dependency property.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.UseAlternateScrollViewerStyleProperty Field

ResizableContentControlUseAlternateScrollViewerStyleProperty Field

Identifies the UseAlternateScrollViewerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseAlternateScrollViewerStyleProperty
Public Shared ReadOnly UseAlternateScrollViewerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseAlternateScrollViewerStyle dependency property.
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl Attached Properties

The ResizableContentControl type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | UseAlternateScrollViewerStyle |
Top
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizableContentControl.UseAlternateScrollViewerStyle Attached Property

ResizableContentControlUseAlternateScrollViewerStyle Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.ResizableContentControl.UseAlternateScrollViewerStyle"]

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetUseAlternateScrollViewerStyle, SetUseAlternateScrollViewerStyle
See GetUseAlternateScrollViewerStyle, SetUseAlternateScrollViewerStyle

Property Value

Type: Boolean
See Also

Reference

ResizableContentControl Class
ActiproSoftware.Windows.Controls Namespace


ResizeOperation Enumeration

Specifies a resize operation.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ResizeOperation
Public Enumeration ResizeOperation
Members
Member name | Value | Description
None | 61440 | No resize operation.
West | 61441 | West.
East | 61442 | East.
North | 61443 | North.
NorthWest | 61444 | North-west.
NorthEast | 61445 | North-east.
South | 61446 | South.
SouthWest | 61447 | South-west.
SouthEast | 61448 | South-east.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


RingSlice Class

Represents a Path that renders a ring slice.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ShapesShape
ActiproSoftware.Windows.ControlsRingSlice

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RingSlice : Shape
Public Class RingSlice
    Inherits Shape

The RingSlice type exposes the following members.

Constructors
 | Name | Description
Public method | RingSlice | Initializes an instance of the RingSlice class.
Top
Properties
 | Name | Description
Protected property | DefiningGeometry | Gets a value that represents the Geometry of the Shape. (Overrides ShapeDefiningGeometry.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndAngle | Gets or sets the end angle.
Public property | Fill | Gets or sets the Brush that specifies how the shape's interior is painted. (Inherited from Shape.)
Public property | GeometryTransform | Gets a value that represents a Transform that is applied to the geometry of a Shape prior to when it is drawn. (Inherited from Shape.)
Public property | IsRenderedWhenFullCircle | Gets or sets whether the ring slice renders a full circle when the StartAngle and EndAngle are different values, but are normalized to the same value.
Public property | Radius | Gets or sets the ring's outer radius.
Public property | RenderedGeometry | Gets a value that represents the final rendered Geometry of a Shape. (Inherited from Shape.)
Public property | StartAngle | Gets or sets the start angle.
Public property | Stretch | Gets or sets a Stretch enumeration value that describes how the shape fills its allocated space. (Inherited from Shape.)
Public property | Stroke | Gets or sets the Brush that specifies how the Shape outline is painted. (Inherited from Shape.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline shapes. (Inherited from Shape.)
Public property | StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from Shape.)
Public property | StrokeDashOffset | Gets or sets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from Shape.)
Public property | StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from Shape.)
Public property | StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from Shape.)
Public property | StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from Shape.)
Public property | StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a Stroke. (Inherited from Shape.)
Public property | StrokeThickness | Gets or sets the width of the Shape outline. (Inherited from Shape.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ShapeArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides ShapeMeasureOverride(Size).)
Protected method | OnRender | Provides a means to change the default appearance of a Shape element. (Inherited from Shape.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
DataProperty | Identifies the Data dependency property. This field is read-only.
EndAngleProperty | Identifies the EndAngle dependency property. This field is read-only.
IsRenderedWhenFullCircleProperty | Identifies the IsRenderedWhenFullCircle dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


RingSlice Constructor

Initializes an instance of the RingSlice class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RingSlice()
Public Sub New
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice Properties

The RingSlice type exposes the following members.

Properties
 | Name | Description
Protected property | DefiningGeometry | Gets a value that represents the Geometry of the Shape. (Overrides ShapeDefiningGeometry.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndAngle | Gets or sets the end angle.
Public property | Fill | Gets or sets the Brush that specifies how the shape's interior is painted. (Inherited from Shape.)
Public property | GeometryTransform | Gets a value that represents a Transform that is applied to the geometry of a Shape prior to when it is drawn. (Inherited from Shape.)
Public property | IsRenderedWhenFullCircle | Gets or sets whether the ring slice renders a full circle when the StartAngle and EndAngle are different values, but are normalized to the same value.
Public property | Radius | Gets or sets the ring's outer radius.
Public property | RenderedGeometry | Gets a value that represents the final rendered Geometry of a Shape. (Inherited from Shape.)
Public property | StartAngle | Gets or sets the start angle.
Public property | Stretch | Gets or sets a Stretch enumeration value that describes how the shape fills its allocated space. (Inherited from Shape.)
Public property | Stroke | Gets or sets the Brush that specifies how the Shape outline is painted. (Inherited from Shape.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline shapes. (Inherited from Shape.)
Public property | StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from Shape.)
Public property | StrokeDashOffset | Gets or sets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from Shape.)
Public property | StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from Shape.)
Public property | StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from Shape.)
Public property | StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from Shape.)
Public property | StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a Stroke. (Inherited from Shape.)
Public property | StrokeThickness | Gets or sets the width of the Shape outline. (Inherited from Shape.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.DefiningGeometry Property

RingSliceDefiningGeometry Property

Gets a value that represents the Geometry of the Shape.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Geometry DefiningGeometry { get; }
Protected Overrides ReadOnly Property DefiningGeometry As Geometry
    Get

Property Value

Type: Geometry
The Geometry of the Shape.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.EndAngle Property

RingSliceEndAngle Property

Gets or sets the end angle.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndAngle { get; set; }
Public Property EndAngle As Double
    Get
    Set

Property Value

Type: Double
The end angle. The default value is 360.0.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.IsRenderedWhenFullCircle Property

RingSliceIsRenderedWhenFullCircle Property

Gets or sets whether the ring slice renders a full circle when the StartAngle and EndAngle are different values, but are normalized to the same value.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsRenderedWhenFullCircle { get; set; }
Public Property IsRenderedWhenFullCircle As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the ring slice renders a full circle when the StartAngle and EndAngle are different values, but are normalized to the same value; otherwise, false. The default value is true.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.Radius Property

RingSliceRadius Property

Gets or sets the ring's outer radius.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The ring's outer radius. The default value is 40.0.
Remarks
This ring is rendered inward from this radius.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.StartAngle Property

RingSliceStartAngle Property

Gets or sets the start angle.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set

Property Value

Type: Double
The start angle. The default value is 0.0.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice Methods

The RingSlice type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ShapeArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides ShapeMeasureOverride(Size).)
Protected method | OnRender | Provides a means to change the default appearance of a Shape element. (Inherited from Shape.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.ArrangeOverride Method

RingSliceArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.MeasureOverride Method

RingSliceMeasureOverride Method

Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice Fields

The RingSlice type exposes the following members.

Fields
Name | Description
DataProperty | Identifies the Data dependency property. This field is read-only.
EndAngleProperty | Identifies the EndAngle dependency property. This field is read-only.
IsRenderedWhenFullCircleProperty | Identifies the IsRenderedWhenFullCircle dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
Top
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.DataProperty Field

RingSliceDataProperty Field

Identifies the Data dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataProperty
Public Shared ReadOnly DataProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Data dependency property.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.EndAngleProperty Field

RingSliceEndAngleProperty Field

Identifies the EndAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndAngleProperty
Public Shared ReadOnly EndAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndAngle dependency property.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.IsRenderedWhenFullCircleProperty Field

RingSliceIsRenderedWhenFullCircleProperty Field

Identifies the IsRenderedWhenFullCircle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRenderedWhenFullCircleProperty
Public Shared ReadOnly IsRenderedWhenFullCircleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRenderedWhenFullCircle dependency property.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.RadiusProperty Field

RingSliceRadiusProperty Field

Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSlice.StartAngleProperty Field

RingSliceStartAngleProperty Field

Identifies the StartAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartAngleProperty
Public Shared ReadOnly StartAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartAngle dependency property.
See Also

Reference

RingSlice Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner Class

Provides a spinnable ring-shaped busy indicator.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.ControlsRingSpinner

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RingSpinner : Control
Public Class RingSpinner
    Inherits Control

The RingSpinner type exposes the following members.

Constructors
 | Name | Description
Public method | RingSpinner | Initializes an instance of the RingSpinner class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSpinning | Gets or sets whether the control is spinning.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LineCap | Gets or sets the ring line cap.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Radius | Gets the ring's outer radius.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
IsSpinningProperty | Identifies the IsSpinning dependency property. This field is read-only.
LineCapProperty | Identifies the LineCap dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


RingSpinner Constructor

Initializes an instance of the RingSpinner class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RingSpinner()
Public Sub New
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner Properties

The RingSpinner type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSpinning | Gets or sets whether the control is spinning.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LineCap | Gets or sets the ring line cap.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Radius | Gets the ring's outer radius.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner.IsSpinning Property

RingSpinnerIsSpinning Property

Gets or sets whether the control is spinning.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSpinning { get; set; }
Public Property IsSpinning As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control is spinning; otherwise, false. The default value is false.
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner.LineCap Property

RingSpinnerLineCap Property

Gets or sets the ring line cap.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PenLineCap LineCap { get; set; }
Public Property LineCap As PenLineCap
    Get
    Set

Property Value

Type: PenLineCap
The ring line cap. The default value is Round.
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner.Radius Property

RingSpinnerRadius Property

Gets the ring's outer radius.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Radius { get; }
Public ReadOnly Property Radius As Double
    Get

Property Value

Type: Double
The ring's outer radius. The default value is 8.0.
Remarks
This ring is rendered inward from this radius.
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner Methods

The RingSpinner type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner.ArrangeOverride Method

RingSpinnerArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner.MeasureOverride Method

RingSpinnerMeasureOverride Method

Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner.OnApplyTemplate Method

RingSpinnerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner Events

The RingSpinner type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner Fields

The RingSpinner type exposes the following members.

Fields
Name | Description
IsSpinningProperty | Identifies the IsSpinning dependency property. This field is read-only.
LineCapProperty | Identifies the LineCap dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner.IsSpinningProperty Field

RingSpinnerIsSpinningProperty Field

Identifies the IsSpinning dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSpinningProperty
Public Shared ReadOnly IsSpinningProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSpinning dependency property.
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner.LineCapProperty Field

RingSpinnerLineCapProperty Field

Identifies the LineCap dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineCapProperty
Public Shared ReadOnly LineCapProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineCap dependency property.
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RingSpinner.RadiusProperty Field

RingSpinnerRadiusProperty Field

Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

RingSpinner Class
ActiproSoftware.Windows.Controls Namespace


RoundMode Enumeration

Specifies the mode of rounding a value.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum RoundMode
Public Enumeration RoundMode
Members
Member name | Value | Description
None | 0 | No rounding is applied.
Floor | 1 | The largest integer less than or equal to the value is returned.
FloorToEven | 2 | The largest even integer less than or equal to the value is returned.
FloorToOdd | 3 | The largest odd integer less than or equal to the value is returned.
Ceiling | 4 | The smallest integer greater than or equal to the value is returned.
CeilingToEven | 5 | The smallest even integer greater than or equal to the value is returned.
CeilingToOdd | 6 | The smallest odd integer greater than or equal to the value is returned.
Round | 7 | The closest integer to the value is returned.
RoundToEven | 8 | The closest even integer to the value is returned.
RoundToOdd | 9 | The closest odd integer to the value is returned.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


Side Enumeration

Specifies a single side of a rectangle.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum Side
Public Enumeration Side
Members
Member name | Value | Description
Left | 0 | Indicates the left side.
Top | 1 | Indicates the top side.
Right | 2 | Indicates the right side.
Bottom | 3 | Indicates the bottom side.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


Sides Enumeration

Specifies zero or more sides of a rectangle as a combination of flags.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum Sides
Public Enumeration Sides
Members
Member name | Value | Description
None | 0 | Indicates no sides.
Left | 1 | Indicates the left side.
Top | 2 | Indicates the top side.
Right | 4 | Indicates the right side.
Bottom | 8 | Indicates the bottom side.
All | 15 | Indicates all four sides, left, top, right, and bottom.
See Also

Reference

ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl Class

Represents a ContentControl that can return a zero width or height during its measuring pass.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.ControlsZeroSizeContentControl

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ZeroSizeContentControl : ContentControl
Public Class ZeroSizeContentControl
    Inherits ContentControl

The ZeroSizeContentControl type exposes the following members.

Constructors
 | Name | Description
Public method | ZeroSizeContentControl | Initializes an instance of the ZeroSizeContentControl class.
Public method | ZeroSizeContentControl(Object) | Initializes an instance of the ZeroSizeContentControl class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasHeight | Gets or sets whether the content's height should be used in the measuring pass.
Public property | HasWidth | Gets or sets whether the content's width should be used in the measuring pass.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IdealSize | Gets the ideal Size of the control, since the DesiredSize will not represent the true desired size.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
HasHeightProperty | Identifies the HasHeight dependency property. This field is read-only.
HasWidthProperty | Identifies the HasWidth dependency property. This field is read-only.
IdealSizeProperty | Identifies the IdealSize dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
Use the HorizontalContentAlignment and VerticalContentAlignment properties to align the content with no width or height respectively.

For detailed documentation on this control's features and how to use them, please see the ZeroSizeContentControl documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl Constructor

Overload List
 | Name | Description
Public method | ZeroSizeContentControl | Initializes an instance of the ZeroSizeContentControl class.
Public method | ZeroSizeContentControl(Object) | Initializes an instance of the ZeroSizeContentControl class.
Top
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl Constructor

Initializes an instance of the ZeroSizeContentControl class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ZeroSizeContentControl()
Public Sub New
See Also

Reference

ZeroSizeContentControl Class
ZeroSizeContentControl Overload
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl Constructor (Object)

Initializes an instance of the ZeroSizeContentControl class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ZeroSizeContentControl(
    Object content
)
Public Sub New (
    content As Object
)

Parameters

content
Type: SystemObject
The object to use as the content.
See Also

Reference

ZeroSizeContentControl Class
ZeroSizeContentControl Overload
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl Properties

The ZeroSizeContentControl type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasHeight | Gets or sets whether the content's height should be used in the measuring pass.
Public property | HasWidth | Gets or sets whether the content's width should be used in the measuring pass.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IdealSize | Gets the ideal Size of the control, since the DesiredSize will not represent the true desired size.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl.HasHeight Property

ZeroSizeContentControlHasHeight Property

Gets or sets whether the content's height should be used in the measuring pass.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasHeight { get; set; }
Public Property HasHeight As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the content's height should be used in the measuring pass; otherwise, false. The default value is true.
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl.HasWidth Property

ZeroSizeContentControlHasWidth Property

Gets or sets whether the content's width should be used in the measuring pass.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasWidth { get; set; }
Public Property HasWidth As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the content's width should be used in the measuring pass; otherwise, false. The default value is true.
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl.IdealSize Property

ZeroSizeContentControlIdealSize Property

Gets the ideal Size of the control, since the DesiredSize will not represent the true desired size.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size IdealSize { get; }
Public ReadOnly Property IdealSize As Size
    Get

Property Value

Type: Size
The ideal Size of the control.
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl Methods

The ZeroSizeContentControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl.ArrangeOverride Method

ZeroSizeContentControlArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size arrangeBounds
)
Protected Overrides Function ArrangeOverride (
    arrangeBounds As Size
) As Size

Parameters

arrangeBounds
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl.MeasureOverride Method

ZeroSizeContentControlMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl Events

The ZeroSizeContentControl type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl Fields

The ZeroSizeContentControl type exposes the following members.

Fields
Name | Description
HasHeightProperty | Identifies the HasHeight dependency property. This field is read-only.
HasWidthProperty | Identifies the HasWidth dependency property. This field is read-only.
IdealSizeProperty | Identifies the IdealSize dependency property. This field is read-only.
Top
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl.HasHeightProperty Field

ZeroSizeContentControlHasHeightProperty Field

Identifies the HasHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasHeightProperty
Public Shared ReadOnly HasHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasHeight dependency property.
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl.HasWidthProperty Field

ZeroSizeContentControlHasWidthProperty Field

Identifies the HasWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasWidthProperty
Public Shared ReadOnly HasWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasWidth dependency property.
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ZeroSizeContentControl.IdealSizeProperty Field

ZeroSizeContentControlIdealSizeProperty Field

Identifies the IdealSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IdealSizeProperty
Public Shared ReadOnly IdealSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IdealSize dependency property.
See Also

Reference

ZeroSizeContentControl Class
ActiproSoftware.Windows.Controls Namespace


ActiproSoftware.Windows.Controls.Automation.Peers Namespace

Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | AdvancedTextBlockAutomationPeer | Exposes AdvancedTextBlock types to UI Automation.
Public class | AnimatedProgressBarAutomationPeer | Exposes AnimatedProgressBar types to UI Automation.
Public class | AutomationContentControlAutomationPeer | Exposes AutomationContentControl types to UI Automation.
Public class | PopupButtonAutomationPeer | Exposes PopupButton types to UI Automation.
Public class | RadialSliderAutomationPeer | Exposes RadialSlider types to UI Automation.


AdvancedTextBlockAutomationPeer Class

Exposes AdvancedTextBlock types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Automation.PeersAdvancedTextBlockAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTextBlockAutomationPeer : FrameworkElementAutomationPeer
Public Class AdvancedTextBlockAutomationPeer
    Inherits FrameworkElementAutomationPeer

The AdvancedTextBlockAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTextBlockAutomationPeer | Initializes a new instance of the AdvancedTextBlockAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AdvancedTextBlockAutomationPeer Constructor

Initializes a new instance of the AdvancedTextBlockAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTextBlockAutomationPeer(
    AdvancedTextBlock owner
)
Public Sub New (
    owner As AdvancedTextBlock
)

Parameters

owner
Type: ActiproSoftware.Windows.ControlsAdvancedTextBlock
The owner element.
See Also

Reference

AdvancedTextBlockAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AdvancedTextBlockAutomationPeer Properties

The AdvancedTextBlockAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

AdvancedTextBlockAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AdvancedTextBlockAutomationPeer Methods

The AdvancedTextBlockAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AdvancedTextBlockAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AdvancedTextBlockAutomationPeer.GetAutomationControlTypeCore Method

AdvancedTextBlockAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

AdvancedTextBlockAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AdvancedTextBlockAutomationPeer.GetClassNameCore Method

AdvancedTextBlockAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

AdvancedTextBlockAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AdvancedTextBlockAutomationPeer.GetLocalizedControlTypeCore Method

AdvancedTextBlockAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

AdvancedTextBlockAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AdvancedTextBlockAutomationPeer.GetNameCore Method

AdvancedTextBlockAutomationPeerGetNameCore Method

Gets text that describes the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The name.
See Also

Reference

AdvancedTextBlockAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AnimatedProgressBarAutomationPeer Class

Exposes AnimatedProgressBar types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
System.Windows.Automation.PeersRangeBaseAutomationPeer
ActiproSoftware.Windows.Controls.Automation.PeersAnimatedProgressBarAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AnimatedProgressBarAutomationPeer : RangeBaseAutomationPeer,
    IRangeValueProvider, IValueProvider
Public Class AnimatedProgressBarAutomationPeer
    Inherits RangeBaseAutomationPeer
    Implements IRangeValueProvider, IValueProvider

The AnimatedProgressBarAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AnimatedProgressBarAutomationPeer | Initializes a new instance of the AnimatedProgressBarAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this AnimatedProgressBarAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this AnimatedProgressBarAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides RangeBaseAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AnimatedProgressBarAutomationPeer Constructor

Initializes a new instance of the AnimatedProgressBarAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AnimatedProgressBarAutomationPeer(
    AnimatedProgressBar owner
)
Public Sub New (
    owner As AnimatedProgressBar
)

Parameters

owner
Type: ActiproSoftware.Windows.ControlsAnimatedProgressBar
The owner.
See Also

Reference

AnimatedProgressBarAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AnimatedProgressBarAutomationPeer Properties

The AnimatedProgressBarAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

AnimatedProgressBarAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AnimatedProgressBarAutomationPeer Methods

The AnimatedProgressBarAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this AnimatedProgressBarAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this AnimatedProgressBarAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides RangeBaseAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AnimatedProgressBarAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AnimatedProgressBarAutomationPeer.GetAutomationControlTypeCore Method

AnimatedProgressBarAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the UIElement that is associated with this AnimatedProgressBarAutomationPeer. This method is called by GetAutomationControlType.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The ProgressBar enumeration value.
See Also

Reference

AnimatedProgressBarAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AnimatedProgressBarAutomationPeer.GetClassNameCore Method

AnimatedProgressBarAutomationPeerGetClassNameCore Method

Gets the name of the UIElement that is associated with this AnimatedProgressBarAutomationPeer. This method is called by GetClassName.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The Type.Name of the Owner.
See Also

Reference

AnimatedProgressBarAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AnimatedProgressBarAutomationPeer.GetPattern Method

AnimatedProgressBarAutomationPeerGetPattern Method

Gets the object that supports the specified control pattern of the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value in the enumeration.

Return Value

Type: Object
This method will return a this pointer in the follow cases:
  • If patternInterface is Value. -
  • If patternInterface is RangeValue and the owning AnimatedProgressBar has IsIndeterminate set to false. -
See Also

Reference

AnimatedProgressBarAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AutomationContentControlAutomationPeer Class

Exposes AutomationContentControl types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Automation.PeersAutomationContentControlAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutomationContentControlAutomationPeer : FrameworkElementAutomationPeer
Public Class AutomationContentControlAutomationPeer
    Inherits FrameworkElementAutomationPeer

The AutomationContentControlAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AutomationContentControlAutomationPeer | Initializes a new instance of the AutomationContentControlAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this AutomationContentControlAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this AutomationContentControlAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AutomationContentControlAutomationPeer Constructor

Initializes a new instance of the AutomationContentControlAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutomationContentControlAutomationPeer(
    AutomationContentControl owner
)
Public Sub New (
    owner As AutomationContentControl
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.PrimitivesAutomationContentControl
The owner.
See Also

Reference

AutomationContentControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AutomationContentControlAutomationPeer Properties

The AutomationContentControlAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

AutomationContentControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AutomationContentControlAutomationPeer Methods

The AutomationContentControlAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this AutomationContentControlAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this AutomationContentControlAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AutomationContentControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AutomationContentControlAutomationPeer.GetAutomationControlTypeCore Method

AutomationContentControlAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the UIElement that is associated with this AutomationContentControlAutomationPeer. This method is called by GetAutomationControlType.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The AutomationControlType specified in the owning AutomationContentControl.
See Also

Reference

AutomationContentControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


AutomationContentControlAutomationPeer.GetClassNameCore Method

AutomationContentControlAutomationPeerGetClassNameCore Method

Gets the name of the UIElement that is associated with this AutomationContentControlAutomationPeer. This method is called by GetClassName.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The Type.Name of the Owner.
See Also

Reference

AutomationContentControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


PopupButtonAutomationPeer Class

Exposes PopupButton types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
System.Windows.Automation.PeersButtonBaseAutomationPeer
System.Windows.Automation.PeersButtonAutomationPeer
ActiproSoftware.Windows.Controls.Automation.PeersPopupButtonAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PopupButtonAutomationPeer : ButtonAutomationPeer,
    IExpandCollapseProvider
Public Class PopupButtonAutomationPeer
    Inherits ButtonAutomationPeer
    Implements IExpandCollapseProvider

The PopupButtonAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | PopupButtonAutomationPeer | Initializes a new instance of the PopupButtonAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the element associated with this ButtonBaseAutomationPeer. Called by GetAcceleratorKey. (Inherited from ButtonBaseAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type of the element that is associated with the UI Automation peer. (Overrides ButtonAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the AutomationId for the element associated with this ButtonBaseAutomationPeer. Called by GetAutomationId. (Inherited from ButtonBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this PopupButtonAutomationPeer. This method is called by GetClassName. (Overrides ButtonAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the name of the class of the element associated with this ButtonBaseAutomationPeer. Called by GetName. (Inherited from ButtonBaseAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides ButtonAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Automation.Peers Namespace


PopupButtonAutomationPeer Constructor

Initializes a new instance of the PopupButtonAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PopupButtonAutomationPeer(
    PopupButton owner
)
Public Sub New (
    owner As PopupButton
)

Parameters

owner
Type: ActiproSoftware.Windows.ControlsPopupButton
The owner.
See Also

Reference

PopupButtonAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


PopupButtonAutomationPeer Properties

The PopupButtonAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

PopupButtonAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


PopupButtonAutomationPeer Methods

The PopupButtonAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the element associated with this ButtonBaseAutomationPeer. Called by GetAcceleratorKey. (Inherited from ButtonBaseAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type of the element that is associated with the UI Automation peer. (Overrides ButtonAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the AutomationId for the element associated with this ButtonBaseAutomationPeer. Called by GetAutomationId. (Inherited from ButtonBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this PopupButtonAutomationPeer. This method is called by GetClassName. (Overrides ButtonAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the name of the class of the element associated with this ButtonBaseAutomationPeer. Called by GetName. (Inherited from ButtonBaseAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides ButtonAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PopupButtonAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


PopupButtonAutomationPeer.GetAutomationControlTypeCore Method

PopupButtonAutomationPeerGetAutomationControlTypeCore Method

Gets the control type of the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
SplitButton if the owning PopupButton has DisplayMode set to Split; otherwise Button.
See Also

Reference

PopupButtonAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


PopupButtonAutomationPeer.GetClassNameCore Method

PopupButtonAutomationPeerGetClassNameCore Method

Gets the name of the UIElement that is associated with this PopupButtonAutomationPeer. This method is called by GetClassName.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The Type.Name of the Owner.
See Also

Reference

PopupButtonAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


PopupButtonAutomationPeer.GetPattern Method

PopupButtonAutomationPeerGetPattern Method

Gets the object that supports the specified control pattern of the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value in the enumeration.

Return Value

Type: Object
This method will return a this pointer in the follow cases:
  • If patternInterface is Invoke and the owning PopupButton does not have DisplayMode set to PopupOnly -
  • If patternInterface is ExpandCollapse and the owning PopupButton does not have DisplayMode set to ButtonOnly -
See Also

Reference

PopupButtonAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer Class

Exposes RadialSlider types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
System.Windows.Automation.PeersRangeBaseAutomationPeer
ActiproSoftware.Windows.Controls.Automation.PeersRadialSliderAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RadialSliderAutomationPeer : RangeBaseAutomationPeer
Public Class RadialSliderAutomationPeer
    Inherits RangeBaseAutomationPeer

The RadialSliderAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | RadialSliderAutomationPeer | Initializes a new instance of the RadialSliderAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the RangeBase that is associated with this RangeBaseAutomationPeer. (Inherited from RangeBaseAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer Constructor

Initializes a new instance of the RadialSliderAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RadialSliderAutomationPeer(
    RadialSlider owner
)
Public Sub New (
    owner As RadialSlider
)

Parameters

owner
Type: ActiproSoftware.Windows.ControlsRadialSlider
The owner element.
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer Properties

The RadialSliderAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer Methods

The RadialSliderAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the RangeBase that is associated with this RangeBaseAutomationPeer. (Inherited from RangeBaseAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer.GetAutomationControlTypeCore Method

RadialSliderAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer.GetClassNameCore Method

RadialSliderAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer.GetLocalizedControlTypeCore Method

RadialSliderAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Automation.Peers
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Automation.Peers Namespace


ActiproSoftware.Windows.Controls.BarCode Namespace

Contains the implementation of the BarCode control and its available symbologies.
Classes
 | Class | Description
Public class | BarCode | Represents a control that can display a bar code.
Public class | BarCodeSymbology | Provides the base class for a bar code symbology.
Public class | CodabarSymbology | Represents a bar code symbology implementation for Codabar. This symbology is also known as Ames Code, ANSI/AIM Codabar, Code 2 of 7, Monarch, NW-7, Rationalized Codabar, and USD-4.
Public class | Code128Symbology | Represents a bar code symbology implementation for Code 128.
Public class | Code39ExtendedSymbology | Represents a bar code symbology implementation for Code 39 Extended. This symbology is also known as Code 39 Full ASCII.
Public class | Code39Symbology | Represents a bar code symbology implementation for Code 39. This symbology is also known as Alpha39, Code 39 mod 43, Code 3 of 9, Code 3/9, USD-3, and USS Code 39.
Public class | Code93ExtendedSymbology | Represents a bar code symbology implementation for Code 93 Extended. This symbology is also known as Code 93 Full ASCII.
Public class | Code93Symbology | Represents a bar code symbology implementation for Code 93.
Public class | Ean13Symbology | Represents a bar code symbology implementation for EAN-13. This symbology is also known as European Article Number 13, and Japanese Article Number (JAN) in Japan.
Public class | Ean8Symbology | Represents a bar code symbology implementation for EAN-8.
Public class | Grid2DBarCodeSymbology | Provides the base class for a two dimensional grid bar code symbology.
Public class | Interleaved2of5Symbology | Represents a bar code symbology implementation for Interleaved 2 of 5.
Public class | LinearBarCodeSymbology | Provides the base class for a one-dimensional bar code symbology.
Public class | PostnetSymbology | Represents a bar code symbology implementation for Postnet.
Public class | QrCodeSymbology | Represents a bar code symbology implementation for QrCode.
Public class | UpcASymbology | Represents a bar code symbology implementation for UPC-A. This symbology is also known as Universal Product Code version A.
Public class | UpcESymbology | Represents a bar code symbology implementation for UPC-E.
Enumerations
 | Enumeration | Description
Public enumeration | LinearBarCodeSymbologyInstruction | Specifies an instruction for a LinearBarCodeSymbology.
Public enumeration | LinearBarCodeValueDisplayStyle | Specifies the display style for the value of a LinearBarCodeSymbology.
Public enumeration | QrEncodingMode | Specifies the various encoding modes supported by QrCodeSymbology.
Public enumeration | QrErrorCorrectionLevel | Specifies the various error correction levels supported by QrCodeSymbology.
Public enumeration | QrVersion | Specifies the various versions supported by QrCodeSymbology. The size of the symbol for Micro QR Code symbols is always 9 + (2 * microVersion). For the 40 versions of regular QR Code symbols, the size is 17 + (4 * version). All versions are square.


BarCode Class

Represents a control that can display a bar code.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.BarCodeBarCode

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BarCode : Control
Public Class BarCode
    Inherits Control

The BarCode type exposes the following members.

Constructors
 | Name | Description
Public method | BarCode | Initializes a new instance of the BarCode class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Caption | Gets or sets the caption to display above the bar code.
Public property | CornerRadius | Gets or sets the corner radius of the border.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCaption | Gets a value indicating whether Caption has a non-null/empty value. This is a dependency property.
Public property | HasSymbology | Gets a value indicating whether Symbology has a non-null value. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Symbology | Gets or sets the BarCodeSymbology used to render the core bar code.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this type. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CaptionProperty | Identifies the Caption dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
HasCaptionProperty | Identifies the read-only HasCaption dependency property. This field is read-only.
HasSymbologyProperty | Identifies the read-only HasSymbology dependency property. This field is read-only.
SymbologyProperty | Identifies the Symbology dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Bar Code-related series of documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode Constructor

Initializes a new instance of the BarCode class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BarCode()
Public Sub New
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode Properties

The BarCode type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Caption | Gets or sets the caption to display above the bar code.
Public property | CornerRadius | Gets or sets the corner radius of the border.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCaption | Gets a value indicating whether Caption has a non-null/empty value. This is a dependency property.
Public property | HasSymbology | Gets a value indicating whether Symbology has a non-null value. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Symbology | Gets or sets the BarCodeSymbology used to render the core bar code.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.Caption Property

BarCodeCaption Property

Gets or sets the caption to display above the bar code.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Caption { get; set; }
Public Property Caption As Object
    Get
    Set

Property Value

Type: Object
The caption to display above the bar code.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.CornerRadius Property

BarCodeCornerRadius Property

Gets or sets the corner radius of the border.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the border.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.HasCaption Property

BarCodeHasCaption Property

Gets a value indicating whether Caption has a non-null/empty value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasCaption { get; }
Public ReadOnly Property HasCaption As Boolean
    Get

Property Value

Type: Boolean
true if Caption has a non-null/empty value; otherwise, false. The default value is false.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.HasSymbology Property

BarCodeHasSymbology Property

Gets a value indicating whether Symbology has a non-null value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSymbology { get; }
Public ReadOnly Property HasSymbology As Boolean
    Get

Property Value

Type: Boolean
true if Symbology has a non-null value; otherwise, false. The default value is false.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.LogicalChildren Property

BarCodeLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.Symbology Property

BarCodeSymbology Property

Gets or sets the BarCodeSymbology used to render the core bar code.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BarCodeSymbology Symbology { get; set; }
Public Property Symbology As BarCodeSymbology
    Get
    Set

Property Value

Type: BarCodeSymbology
The BarCodeSymbology used to render the core bar code.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode Methods

The BarCode type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this type. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.OnCreateAutomationPeer Method

BarCodeOnCreateAutomationPeer Method

Creates and returns an AutomationPeer object for this type.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The AutomationPeer that was created.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode Events

The BarCode type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode Fields

The BarCode type exposes the following members.

Fields
Name | Description
CaptionProperty | Identifies the Caption dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
HasCaptionProperty | Identifies the read-only HasCaption dependency property. This field is read-only.
HasSymbologyProperty | Identifies the read-only HasSymbology dependency property. This field is read-only.
SymbologyProperty | Identifies the Symbology dependency property. This field is read-only.
Top
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.CaptionProperty Field

BarCodeCaptionProperty Field

Identifies the Caption dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CaptionProperty
Public Shared ReadOnly CaptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Caption dependency property.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.CornerRadiusProperty Field

BarCodeCornerRadiusProperty Field

Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.HasCaptionProperty Field

BarCodeHasCaptionProperty Field

Identifies the read-only HasCaption dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasCaptionProperty
Public Shared ReadOnly HasCaptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasCaption dependency property.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.HasSymbologyProperty Field

BarCodeHasSymbologyProperty Field

Identifies the read-only HasSymbology dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasSymbologyProperty
Public Shared ReadOnly HasSymbologyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasSymbology dependency property.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCode.SymbologyProperty Field

BarCodeSymbologyProperty Field

Identifies the Symbology dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SymbologyProperty
Public Shared ReadOnly SymbologyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Symbology dependency property.
See Also

Reference

BarCode Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology Class

Provides the base class for a bar code symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeGrid2DBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class BarCodeSymbology : FrameworkElement
Public MustInherit Class BarCodeSymbology
    Inherits FrameworkElement

The BarCodeSymbology type exposes the following members.

Constructors
 | Name | Description
Protected method | BarCodeSymbology | Initializes a new instance of the BarCodeSymbology class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology.
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground.
Public property | Value | Gets or sets the value to encode in the bar code.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size.
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this symbology's features and how to use them, please see the Bar Code Symbology-related series of documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology Constructor

Initializes a new instance of the BarCodeSymbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected BarCodeSymbology()
Protected Sub New
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology Properties

The BarCodeSymbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology.
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground.
Public property | Value | Gets or sets the value to encode in the bar code.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.Background Property

BarCodeSymbologyBackground Property

Gets or sets the Brush to use for rendering the background.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Background { get; set; }
Public Property Background As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for rendering the background. The default background is White.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.DisplayName Property

BarCodeSymbologyDisplayName Property

Gets the display name of the symbology.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.Foreground Property

BarCodeSymbologyForeground Property

Gets or sets the Brush to use for rendering the foreground.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Foreground { get; set; }
Public Property Foreground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for rendering the foreground. The default foreground is Black.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.Value Property

BarCodeSymbologyValue Property

Gets or sets the value to encode in the bar code.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The value to encode in the bar code.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology Methods

The BarCodeSymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size.
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.MeasureDesiredSize Method

BarCodeSymbologyMeasureDesiredSize Method

Measures the desired size of the symbology, based on the specified available size.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size MeasureDesiredSize(
    Size availableSize
)
Public Function MeasureDesiredSize (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.MeasureOverride Method

BarCodeSymbologyMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.OnRender Method

BarCodeSymbologyOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.OnValueChanged Method

BarCodeSymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overridable Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.Render Method

BarCodeSymbologyRender Method

Renders the symbology to the specified DrawingContext.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void Render(
    DrawingContext drawingContext,
    Point location,
    Size size
)
Public MustOverride Sub Render (
    drawingContext As DrawingContext,
    location As Point,
    size As Size
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The DrawingContext upon which to render the symbology.
location
Type: System.WindowsPoint
The location at which to draw the bar code.
size
Type: System.WindowsSize
The size of the bar code to draw.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.ToBitmap Method

BarCodeSymbologyToBitmap Method

Creates a BitmapSource based on the contents of the symbology.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BitmapSource ToBitmap(
    double dpiX,
    double dpiY
)
Public Function ToBitmap (
    dpiX As Double,
    dpiY As Double
) As BitmapSource

Parameters

dpiX
Type: SystemDouble
The x DPI.
dpiY
Type: SystemDouble
The y DPI.

Return Value

Type: BitmapSource
The BitmapSource that was created.
Remarks
It is recommended that this symbology not have a visual parent when calling this method.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.ValidateValue Method

BarCodeSymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract ValidationResult ValidateValue(
    string value
)
Public MustOverride Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology Fields

The BarCodeSymbology type exposes the following members.

Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.BackgroundProperty Field

BarCodeSymbologyBackgroundProperty Field

Identifies the Background dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundProperty
Public Shared ReadOnly BackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Background dependency property.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.ForegroundProperty Field

BarCodeSymbologyForegroundProperty Field

Identifies the Foreground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundProperty
Public Shared ReadOnly ForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Foreground dependency property.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


BarCodeSymbology.ValueProperty Field

BarCodeSymbologyValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


CodabarSymbology Class

Represents a bar code symbology implementation for Codabar.

This symbology is also known as Ames Code, ANSI/AIM Codabar, Code 2 of 7, Monarch, NW-7, Rationalized Codabar, and USD-4.

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeCodabarSymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CodabarSymbology : LinearBarCodeSymbology
Public Class CodabarSymbology
    Inherits LinearBarCodeSymbology

The CodabarSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | CodabarSymbology | Initializes an instance of the CodabarSymbology class.
Top
Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters are visible in the displayed value.
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
Codabar is a linear symbology, developed in 1972 by Pitney Bowes, Inc. It is most commonly used by libraries, blood banks, and on FedEx airbills.

This symbology can encode 16 characters (0 through 9, and -$:/.+), along with 4 start/stop characters.

Each encoded value must start and stop with A, B, C, or D. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology is self-checking, so no checksum or check digit is required.

For detailed documentation on this symbology's features and how to use them, please see the Codabar documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


CodabarSymbology Constructor

Initializes an instance of the CodabarSymbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CodabarSymbology()
Public Sub New
See Also

Reference

CodabarSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


CodabarSymbology Properties

The CodabarSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters are visible in the displayed value.
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

CodabarSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


CodabarSymbology.AreStartStopCharactersVisible Property

CodabarSymbologyAreStartStopCharactersVisible Property

Gets or sets whether the start/stop characters are visible in the displayed value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreStartStopCharactersVisible { get; set; }
Public Property AreStartStopCharactersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the start/stop characters are visible in the displayed value; otherwise, false. The default value is false.
See Also

Reference

CodabarSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


CodabarSymbology Methods

The CodabarSymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CodabarSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


CodabarSymbology.OnValueChanged Method

CodabarSymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

CodabarSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


CodabarSymbology.ValidateValue Method

CodabarSymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

CodabarSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


CodabarSymbology Fields

The CodabarSymbology type exposes the following members.

Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
Top
See Also

Reference

CodabarSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


CodabarSymbology.AreStartStopCharactersVisibleProperty Field

CodabarSymbologyAreStartStopCharactersVisibleProperty Field

Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreStartStopCharactersVisibleProperty
Public Shared ReadOnly AreStartStopCharactersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreStartStopCharactersVisible dependency property.
See Also

Reference

CodabarSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology Class

Represents a bar code symbology implementation for Code 128.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeCode128Symbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code128Symbology : LinearBarCodeSymbology
Public Class Code128Symbology
    Inherits LinearBarCodeSymbology

The Code128Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code128Symbology | Initializes an instance of the Code128Symbology class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
Fnc1Char | The character that can be used to encode FNC1.
Fnc2Char | The character that can be used to encode FNC2.
Fnc3Char | The character that can be used to encode FNC3.
Fnc4Char | The character that can be used to encode FNC4.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
Code 128 is a high-density barcode symbology, used extensively worldwide in shipping and packaging industries.

This symbology can encode all of the lower 128 ASCII characters. It is especially efficient when encoding sequential numbers since they are merged into a single output character width.

This symbology implementation auto-calculates and inserts a check character.

For detailed documentation on this symbology's features and how to use them, please see the Code 128 documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology Constructor

Initializes an instance of the Code128Symbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code128Symbology()
Public Sub New
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology Properties

The Code128Symbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology Methods

The Code128Symbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology.OnValueChanged Method

Code128SymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology.ValidateValue Method

Code128SymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology Fields

The Code128Symbology type exposes the following members.

Fields
Name | Description
Fnc1Char | The character that can be used to encode FNC1.
Fnc2Char | The character that can be used to encode FNC2.
Fnc3Char | The character that can be used to encode FNC3.
Fnc4Char | The character that can be used to encode FNC4.
Top
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology.Fnc1Char Field

Code128SymbologyFnc1Char Field

The character that can be used to encode FNC1.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const char Fnc1Char = ''
Public Const Fnc1Char As Char = ""C

Field Value

Type: Char
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology.Fnc2Char Field

Code128SymbologyFnc2Char Field

The character that can be used to encode FNC2.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const char Fnc2Char = ''
Public Const Fnc2Char As Char = ""C

Field Value

Type: Char
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology.Fnc3Char Field

Code128SymbologyFnc3Char Field

The character that can be used to encode FNC3.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const char Fnc3Char = ''
Public Const Fnc3Char As Char = ""C

Field Value

Type: Char
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code128Symbology.Fnc4Char Field

Code128SymbologyFnc4Char Field

The character that can be used to encode FNC4.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const char Fnc4Char = ''
Public Const Fnc4Char As Char = ""C

Field Value

Type: Char
See Also

Reference

Code128Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39ExtendedSymbology Class

Represents a bar code symbology implementation for Code 39 Extended.

This symbology is also known as Code 39 Full ASCII.

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeCode39Symbology
ActiproSoftware.Windows.Controls.BarCodeCode39ExtendedSymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code39ExtendedSymbology : Code39Symbology
Public Class Code39ExtendedSymbology
    Inherits Code39Symbology

The Code39ExtendedSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code39ExtendedSymbology | Initializes a new instance of the Code39ExtendedSymbology class
Top
Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value. (Inherited from Code39Symbology.)
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added. (Inherited from Code39Symbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from Code39Symbology.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary. (Overrides Code39SymbologyPreprocessCharacter(Char).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides Code39SymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
Code 39 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 39.

This symbology can encode all of the lower 128 ASCII characters.

Each encoded value must start and stop with *, which is automatically inserted. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology is self-checking, so no checksum or check digit is required. However if the IsChecksumEnabled property is true, the symbology's implementation auto-calculates and inserts a check digit. This is referred to as Code 39 mod 43.

The standard implementation of Code 39 is available in Code39Symbology. That implementation allows for encoding a subset of the characters able to be encoded by this symbology.

For detailed documentation on this symbology's features and how to use them, please see the Code 39 Extended documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


Code39ExtendedSymbology Constructor

Initializes a new instance of the Code39ExtendedSymbology class

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code39ExtendedSymbology()
Public Sub New
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39ExtendedSymbology Properties

The Code39ExtendedSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value. (Inherited from Code39Symbology.)
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added. (Inherited from Code39Symbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39ExtendedSymbology Methods

The Code39ExtendedSymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from Code39Symbology.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary. (Overrides Code39SymbologyPreprocessCharacter(Char).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides Code39SymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39ExtendedSymbology.PreprocessCharacter Method

Code39ExtendedSymbologyPreprocessCharacter Method

Pre-processes the specified character and expands it if necessary.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string PreprocessCharacter(
    char ch
)
Protected Overrides Function PreprocessCharacter (
    ch As Char
) As String

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: String
The pre-processing result.
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39ExtendedSymbology.ValidateValue Method

Code39ExtendedSymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology Class

Represents a bar code symbology implementation for Code 39.

This symbology is also known as Alpha39, Code 39 mod 43, Code 3 of 9, Code 3/9, USD-3, and USS Code 39.

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeCode39Symbology
ActiproSoftware.Windows.Controls.BarCodeCode39ExtendedSymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code39Symbology : LinearBarCodeSymbology
Public Class Code39Symbology
    Inherits LinearBarCodeSymbology

The Code39Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code39Symbology | Initializes an instance of the Code39Symbology class.
Top
Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added.
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
IsChecksumEnabledProperty | Identifies the IsChecksumEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
Code 39 is a linear symbology, and is one of the first alphanumeric bar codes. Each character encoded is made up of 5 bars and 4 spaces for a total of 9 elements. 3 out of the 9 element are always wide. Although it is not as dense of a symbology such as Code 128, it is one of the most widely supported symbologies by devices.

This symbology can encode numbers, uppercase letters, and -$% ./+ characters.

Each encoded value must start and stop with *, which is automatically inserted. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology is self-checking, so no checksum or check digit is required. However if the IsChecksumEnabled property is true, the symbology's implementation auto-calculates and inserts a check digit. This is referred to as Code 39 mod 43.

An extended implementation of Code 39 is available in Code39ExtendedSymbology. That implementation allows for all lower 128 ASCII characters to be encoded based on the core Code 39 concepts.

For detailed documentation on this symbology's features and how to use them, please see the Code 39 documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology Constructor

Initializes an instance of the Code39Symbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code39Symbology()
Public Sub New
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology Properties

The Code39Symbology type exposes the following members.

Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added.
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology.AreStartStopCharactersVisible Property

Code39SymbologyAreStartStopCharactersVisible Property

Gets or sets whether the start/stop characters (*) are visible in the displayed value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreStartStopCharactersVisible { get; set; }
Public Property AreStartStopCharactersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the start/stop characters (*) are visible in the displayed value; otherwise, false. The default value is false.
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology.IsChecksumEnabled Property

Code39SymbologyIsChecksumEnabled Property

Gets or sets whether the optional checksum should be added.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsChecksumEnabled { get; set; }
Public Property IsChecksumEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the optional checksum should be added; otherwise, false. The default value is false.
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology Methods

The Code39Symbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology.OnValueChanged Method

Code39SymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology.PreprocessCharacter Method

Code39SymbologyPreprocessCharacter Method

Pre-processes the specified character and expands it if necessary.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string PreprocessCharacter(
    char ch
)
Protected Overridable Function PreprocessCharacter (
    ch As Char
) As String

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: String
The pre-processing result.
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology.ValidateValue Method

Code39SymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology Fields

The Code39Symbology type exposes the following members.

Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
IsChecksumEnabledProperty | Identifies the IsChecksumEnabled dependency property. This field is read-only.
Top
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology.AreStartStopCharactersVisibleProperty Field

Code39SymbologyAreStartStopCharactersVisibleProperty Field

Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreStartStopCharactersVisibleProperty
Public Shared ReadOnly AreStartStopCharactersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreStartStopCharactersVisible dependency property.
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code39Symbology.IsChecksumEnabledProperty Field

Code39SymbologyIsChecksumEnabledProperty Field

Identifies the IsChecksumEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsChecksumEnabledProperty
Public Shared ReadOnly IsChecksumEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsChecksumEnabled dependency property.
See Also

Reference

Code39Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93ExtendedSymbology Class

Represents a bar code symbology implementation for Code 93 Extended.

This symbology is also known as Code 93 Full ASCII.

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeCode93Symbology
ActiproSoftware.Windows.Controls.BarCodeCode93ExtendedSymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code93ExtendedSymbology : Code93Symbology
Public Class Code93ExtendedSymbology
    Inherits Code93Symbology

The Code93ExtendedSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code93ExtendedSymbology | Initializes a new instance of the Code93ExtendedSymbology class
Top
Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value. (Inherited from Code93Symbology.)
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from Code93Symbology.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary. (Overrides Code93SymbologyPreprocessCharacter(Char).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides Code93SymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
Code 93 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 93.

This symbology can encode all of the lower 128 ASCII characters.

Each encoded value must start and stop with *, which is automatically inserted. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology implementation auto-calculates and inserts two check characters.

The standard implementation of Code 93 is available in Code93Symbology. That implementation allows for encoding a subset of the characters able to be encoded by this symbology.

For detailed documentation on this symbology's features and how to use them, please see the Code 93 Extended documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


Code93ExtendedSymbology Constructor

Initializes a new instance of the Code93ExtendedSymbology class

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code93ExtendedSymbology()
Public Sub New
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93ExtendedSymbology Properties

The Code93ExtendedSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value. (Inherited from Code93Symbology.)
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93ExtendedSymbology Methods

The Code93ExtendedSymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from Code93Symbology.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary. (Overrides Code93SymbologyPreprocessCharacter(Char).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides Code93SymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93ExtendedSymbology.PreprocessCharacter Method

Code93ExtendedSymbologyPreprocessCharacter Method

Pre-processes the specified character and expands it if necessary.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string PreprocessCharacter(
    char ch
)
Protected Overrides Function PreprocessCharacter (
    ch As Char
) As String

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: String
The pre-processing result.
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93ExtendedSymbology.ValidateValue Method

Code93ExtendedSymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology Class

Represents a bar code symbology implementation for Code 93.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeCode93Symbology
ActiproSoftware.Windows.Controls.BarCodeCode93ExtendedSymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code93Symbology : LinearBarCodeSymbology
Public Class Code93Symbology
    Inherits LinearBarCodeSymbology

The Code93Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code93Symbology | Initializes an instance of the Code93Symbology class.
Top
Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
Code 93 is a linear symbology, designed in 1982 by Intermec to provide a higher density and data security enhancement to Code 39. Each Code 93 character is divided into nine modules and always has three bars and three spaces. This symbology is primarily used by the Canadian postal office.

This symbology can encode numbers, uppercase letters, and -. $/+% characters.

Each encoded value must start and stop with *, which is automatically inserted. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology implementation auto-calculates and inserts two check characters.

An extended implementation of Code 93 is available in Code93ExtendedSymbology. That implementation allows for all lower 128 ASCII characters to be encoded based on the core Code 93 concepts.

For detailed documentation on this symbology's features and how to use them, please see the Code 93 documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology Constructor

Initializes an instance of the Code93Symbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code93Symbology()
Public Sub New
See Also

Reference

Code93Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology Properties

The Code93Symbology type exposes the following members.

Properties
 | Name | Description
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Code93Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology.AreStartStopCharactersVisible Property

Code93SymbologyAreStartStopCharactersVisible Property

Gets or sets whether the start/stop characters (*) are visible in the displayed value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreStartStopCharactersVisible { get; set; }
Public Property AreStartStopCharactersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the start/stop characters (*) are visible in the displayed value; otherwise, false. The default value is false.
See Also

Reference

Code93Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology Methods

The Code93Symbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Code93Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology.OnValueChanged Method

Code93SymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Code93Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology.PreprocessCharacter Method

Code93SymbologyPreprocessCharacter Method

Pre-processes the specified character and expands it if necessary.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string PreprocessCharacter(
    char ch
)
Protected Overridable Function PreprocessCharacter (
    ch As Char
) As String

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: String
The pre-processing result.
See Also

Reference

Code93Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology.ValidateValue Method

Code93SymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code93Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology Fields

The Code93Symbology type exposes the following members.

Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
Top
See Also

Reference

Code93Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Code93Symbology.AreStartStopCharactersVisibleProperty Field

Code93SymbologyAreStartStopCharactersVisibleProperty Field

Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreStartStopCharactersVisibleProperty
Public Shared ReadOnly AreStartStopCharactersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreStartStopCharactersVisible dependency property.
See Also

Reference

Code93Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean13Symbology Class

Represents a bar code symbology implementation for EAN-13.

This symbology is also known as European Article Number 13, and Japanese Article Number (JAN) in Japan.

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeEan13Symbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Ean13Symbology : LinearBarCodeSymbology
Public Class Ean13Symbology
    Inherits LinearBarCodeSymbology

The Ean13Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Ean13Symbology | Initializes an instance of the Ean13Symbology class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
EAN-13 is a linear symbology, based on the original 12-digit Universal Product Code (UPC) system developed in North America. EAN-13 bar codes are used worldwide for marking retail goods.

This symbology can encode 13 numeric characters, divided into four parts: system code, manufacturer code, product code, and check digit.

This symbology implementation auto-calculates and inserts a check digit.

For detailed documentation on this symbology's features and how to use them, please see the EAN-13 documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


Ean13Symbology Constructor

Initializes an instance of the Ean13Symbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Ean13Symbology()
Public Sub New
See Also

Reference

Ean13Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean13Symbology Properties

The Ean13Symbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Ean13Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean13Symbology Methods

The Ean13Symbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Ean13Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean13Symbology.OnValueChanged Method

Ean13SymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Ean13Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean13Symbology.ValidateValue Method

Ean13SymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Ean13Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean8Symbology Class

Represents a bar code symbology implementation for EAN-8.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeEan8Symbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Ean8Symbology : LinearBarCodeSymbology
Public Class Ean8Symbology
    Inherits LinearBarCodeSymbology

The Ean8Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Ean8Symbology | Initializes an instance of the Ean8Symbology class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
EAN-8 is a linear symbology, used on smaller retail packages where EAN-13 bar codes don't fit.

This symbology can encode 8 numeric characters, divided into three parts: system code, product code, and check digit.

This symbology implementation auto-calculates and inserts a check digit.

For detailed documentation on this symbology's features and how to use them, please see the EAN-8 documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


Ean8Symbology Constructor

Initializes an instance of the Ean8Symbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Ean8Symbology()
Public Sub New
See Also

Reference

Ean8Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean8Symbology Properties

The Ean8Symbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Ean8Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean8Symbology Methods

The Ean8Symbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Ean8Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean8Symbology.OnValueChanged Method

Ean8SymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Ean8Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Ean8Symbology.ValidateValue Method

Ean8SymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Ean8Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology Class

Provides the base class for a two dimensional grid bar code symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeGrid2DBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeQrCodeSymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class Grid2DBarCodeSymbology : BarCodeSymbology
Public MustInherit Class Grid2DBarCodeSymbology
    Inherits BarCodeSymbology

The Grid2DBarCodeSymbology type exposes the following members.

Constructors
 | Name | Description
Protected method | Grid2DBarCodeSymbology | Initializes a new instance of the Grid2DBarCodeSymbology class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Public property | CellSize | Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | GridData | Gets or sets an two dimensional array of boolean values that specifies how the symbol is to be rendered.
Public property | QuietZoneThickness | Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property.
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides BarCodeSymbologyMeasureOverride(Size).)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from BarCodeSymbology.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Overrides BarCodeSymbologyRender(DrawingContext, Point, Size).)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Inherited from BarCodeSymbology.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
CellSizeProperty | Identifies the CellSize dependency property. This field is read-only.
GridDataProperty | Identifies the GridData dependency property. This field is read-only.
QuietZoneThicknessProperty | Identifies the QuietZoneThickness dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this symbology's features and how to use them, please see the Bar Code Symbology-related series of documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology Constructor

Initializes a new instance of the Grid2DBarCodeSymbology class

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Grid2DBarCodeSymbology()
Protected Sub New
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology Properties

The Grid2DBarCodeSymbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Public property | CellSize | Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | GridData | Gets or sets an two dimensional array of boolean values that specifies how the symbol is to be rendered.
Public property | QuietZoneThickness | Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property.
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology.CellSize Property

Grid2DBarCodeSymbologyCellSize Property

Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CellSize { get; set; }
Public Property CellSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the cell.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology.GridData Property

Grid2DBarCodeSymbologyGridData Property

Gets or sets an two dimensional array of boolean values that specifies how the symbol is to be rendered.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool[,] GridData { get; set; }
Protected Property GridData As Boolean(,)
    Get
    Set

Property Value

Type: Boolean
The grid data.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology.QuietZoneThickness Property

Grid2DBarCodeSymbologyQuietZoneThickness Property

Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness QuietZoneThickness { get; set; }
Public Property QuietZoneThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The quiet zone.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology Methods

The Grid2DBarCodeSymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides BarCodeSymbologyMeasureOverride(Size).)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from BarCodeSymbology.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Overrides BarCodeSymbologyRender(DrawingContext, Point, Size).)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Inherited from BarCodeSymbology.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology.MeasureOverride Method

Grid2DBarCodeSymbologyMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology.Render Method

Grid2DBarCodeSymbologyRender Method

Renders the symbology to the specified DrawingContext.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Render(
    DrawingContext drawingContext,
    Point location,
    Size size
)
Public Overrides Sub Render (
    drawingContext As DrawingContext,
    location As Point,
    size As Size
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The DrawingContext upon which to render the symbology.
location
Type: System.WindowsPoint
The location at which to draw the bar code.
size
Type: System.WindowsSize
The size of the bar code to draw.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology Fields

The Grid2DBarCodeSymbology type exposes the following members.

Fields
Name | Description
CellSizeProperty | Identifies the CellSize dependency property. This field is read-only.
GridDataProperty | Identifies the GridData dependency property. This field is read-only.
QuietZoneThicknessProperty | Identifies the QuietZoneThickness dependency property. This field is read-only.
Top
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology.CellSizeProperty Field

Grid2DBarCodeSymbologyCellSizeProperty Field

Identifies the CellSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellSizeProperty
Public Shared ReadOnly CellSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellSize dependency property.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology.GridDataProperty Field

Grid2DBarCodeSymbologyGridDataProperty Field

Identifies the GridData dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static readonly DependencyProperty GridDataProperty
Protected Shared ReadOnly GridDataProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridData dependency property.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Grid2DBarCodeSymbology.QuietZoneThicknessProperty Field

Grid2DBarCodeSymbologyQuietZoneThicknessProperty Field

Identifies the QuietZoneThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty QuietZoneThicknessProperty
Public Shared ReadOnly QuietZoneThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the QuietZoneThickness dependency property.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Interleaved2of5Symbology Class

Represents a bar code symbology implementation for Interleaved 2 of 5.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeInterleaved2of5Symbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Interleaved2of5Symbology : LinearBarCodeSymbology
Public Class Interleaved2of5Symbology
    Inherits LinearBarCodeSymbology

The Interleaved2of5Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Interleaved2of5Symbology | Initializes an instance of the Interleaved2of5Symbology class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added.
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
IsChecksumEnabledProperty | Identifies the IsChecksumEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
Interleaved 2 of 5 is a linear symbology, that provides higher density than the Industrial 2 of 5 symbology that it is based on. It is most commonly used by the distribution and warehouse industry.

This symbology can encode numeric digits, and requires that an even number of digits (including the optional check digit) are encoded. This symbology implementation will automatically add a 0 at the start of the encoded value to ensure that an even number of digits are encoded.

The symbology's implementation auto-calculates and inserts an optional check digit if the IsChecksumEnabled property is true.

For detailed documentation on this symbology's features and how to use them, please see the Interleaved 2 of 5 documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


Interleaved2of5Symbology Constructor

Initializes an instance of the Interleaved2of5Symbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Interleaved2of5Symbology()
Public Sub New
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Interleaved2of5Symbology Properties

The Interleaved2of5Symbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added.
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Interleaved2of5Symbology.IsChecksumEnabled Property

Interleaved2of5SymbologyIsChecksumEnabled Property

Gets or sets whether the optional checksum should be added.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsChecksumEnabled { get; set; }
Public Property IsChecksumEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the optional checksum should be added; otherwise, false. The default value is false.
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Interleaved2of5Symbology Methods

The Interleaved2of5Symbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Interleaved2of5Symbology.OnValueChanged Method

Interleaved2of5SymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Interleaved2of5Symbology.ValidateValue Method

Interleaved2of5SymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Interleaved2of5Symbology Fields

The Interleaved2of5Symbology type exposes the following members.

Fields
Name | Description
IsChecksumEnabledProperty | Identifies the IsChecksumEnabled dependency property. This field is read-only.
Top
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


Interleaved2of5Symbology.IsChecksumEnabledProperty Field

Interleaved2of5SymbologyIsChecksumEnabledProperty Field

Identifies the IsChecksumEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsChecksumEnabledProperty
Public Shared ReadOnly IsChecksumEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsChecksumEnabled dependency property.
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology Class

Provides the base class for a one-dimensional bar code symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
More...

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LinearBarCodeSymbology : BarCodeSymbology
Public MustInherit Class LinearBarCodeSymbology
    Inherits BarCodeSymbology

The LinearBarCodeSymbology type exposes the following members.

Constructors
 | Name | Description
Protected method | LinearBarCodeSymbology | Initializes a new instance of the LinearBarCodeSymbology class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code.
Public property | BarHeight | Gets or sets the desired height of the bars.
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions.
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone.
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides BarCodeSymbologyMeasureOverride(Size).)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from BarCodeSymbology.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Overrides BarCodeSymbologyRender(DrawingContext, Point, Size).)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Inherited from BarCodeSymbology.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BarDataProperty | Identifies the BarData dependency property. This field is read-only.
BarHeightProperty | Identifies the BarHeight dependency property. This field is read-only.
BarWidthRatioProperty | Identifies the BarWidthRatio dependency property. This field is read-only.
DisplayValueProperty | Identifies the DisplayValue dependency property. This field is read-only.
InstructionsProperty | Identifies the Instructions dependency property. This field is read-only.
MinBarHeightWidthRatioProperty | Identifies the MinBarHeightWidthRatio dependency property. This field is read-only.
QuietZoneThicknessProperty | Identifies the QuietZoneThickness dependency property. This field is read-only.
ValueDisplayStyleProperty | Identifies the ValueDisplayStyle dependency property. This field is read-only.
ValueIntrusionOffsetProperty | Identifies the ValueIntrusionOffset dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this symbology's features and how to use them, please see the Bar Code Symbology-related series of documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeCodabarSymbology
ActiproSoftware.Windows.Controls.BarCodeCode128Symbology
ActiproSoftware.Windows.Controls.BarCodeCode39Symbology
ActiproSoftware.Windows.Controls.BarCodeCode93Symbology
ActiproSoftware.Windows.Controls.BarCodeEan13Symbology
ActiproSoftware.Windows.Controls.BarCodeEan8Symbology
ActiproSoftware.Windows.Controls.BarCodeInterleaved2of5Symbology
ActiproSoftware.Windows.Controls.BarCodePostnetSymbology
ActiproSoftware.Windows.Controls.BarCodeUpcASymbology
ActiproSoftware.Windows.Controls.BarCodeUpcESymbology


LinearBarCodeSymbology Constructor

Initializes a new instance of the LinearBarCodeSymbology class

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LinearBarCodeSymbology()
Protected Sub New
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology Properties

The LinearBarCodeSymbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code.
Public property | BarHeight | Gets or sets the desired height of the bars.
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions.
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone.
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.BarData Property

LinearBarCodeSymbologyBarData Property

Gets or sets the string that specifies the data used to draw the bar code.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected string BarData { get; set; }
Protected Property BarData As String
    Get
    Set

Property Value

Type: String
The string that specifies the data used to draw the bar code.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.BarHeight Property

LinearBarCodeSymbologyBarHeight Property

Gets or sets the desired height of the bars.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double BarHeight { get; set; }
Public Property BarHeight As Double
    Get
    Set

Property Value

Type: Double
The desired height of the bars. The default value is 35.
Remarks
When calculating the desired height of the bar code, the BarHeight property will be used unless its height is less than the percentage of the desired width specified by MinBarHeightWidthRatio. In that case the MinBarHeightWidthRatio percentage of the desired width is used for height. This ensures that the bar code is always sized to be read properly.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.BarWidthRatio Property

LinearBarCodeSymbologyBarWidthRatio Property

Gets or sets the width ratio of wide lines to narrow lines.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double BarWidthRatio { get; set; }
Public Property BarWidthRatio As Double
    Get
    Set

Property Value

Type: Double
The width ratio of wide lines to narrow lines. The default value is 2, meaning that wide lines are twice as thick as narrow lines.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.DisplayValue Property

LinearBarCodeSymbologyDisplayValue Property

Gets or sets the value that is displayed if ValueDisplayStyle is not None.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DisplayValue { get; protected set; }
Public Property DisplayValue As String
    Get
    Protected Set

Property Value

Type: String
The value that is displayed if ValueDisplayStyle is not None.
Remarks
This property must be set by each symbology implementation.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.Instructions Property

LinearBarCodeSymbologyInstructions Property

Gets or sets the dictionary of BarData characters and their related instructions.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Dictionary<char, LinearBarCodeSymbologyInstruction> Instructions { get; set; }
Protected Property Instructions As Dictionary(Of Char, LinearBarCodeSymbologyInstruction)
    Get
    Set

Property Value

Type: Dictionary Char, LinearBarCodeSymbologyInstruction
The dictionary of BarData characters and their related instructions.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.MinBarHeightWidthRatio Property

LinearBarCodeSymbologyMinBarHeightWidthRatio Property

Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MinBarHeightWidthRatio { get; set; }
Public Property MinBarHeightWidthRatio As Double
    Get
    Set

Property Value

Type: Double
The minimum ratio that the height of the bar code must be in relation to its width. The default value is 0.15 (15%).
Remarks
Many symbologies indicate that the bar code's height must be at least x% of its width. For instance, Code 39 specifies that the height must be at least 15% of the width.

When calculating the desired height of the bar code, the BarHeight property will be used unless its height is less than the percentage of the desired width specified by MinBarHeightWidthRatio. In that case the MinBarHeightWidthRatio percentage of the desired width is used for height. This ensures that the bar code is always sized to be read properly.

See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.QuietZoneThickness Property

LinearBarCodeSymbologyQuietZoneThickness Property

Gets or sets the Thickness of the quiet zone.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness QuietZoneThickness { get; set; }
Public Property QuietZoneThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the quiet zone. The default value is 10,0,10,0.
Remarks
The quiet zone is the margin whitespace area that appears around the bar code.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.ValueDisplayStyle Property

LinearBarCodeSymbologyValueDisplayStyle Property

Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearBarCodeValueDisplayStyle ValueDisplayStyle { get; set; }
Public Property ValueDisplayStyle As LinearBarCodeValueDisplayStyle
    Get
    Set

Property Value

Type: LinearBarCodeValueDisplayStyle
A LinearBarCodeValueDisplayStyle that indicates how the value should rendered. The default value is Centered.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.ValueIntrusionOffset Property

LinearBarCodeSymbologyValueIntrusionOffset Property

Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ValueIntrusionOffset { get; set; }
Public Property ValueIntrusionOffset As Double
    Get
    Set

Property Value

Type: Double
The distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. The default value is 0.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology Methods

The LinearBarCodeSymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides BarCodeSymbologyMeasureOverride(Size).)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from BarCodeSymbology.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Overrides BarCodeSymbologyRender(DrawingContext, Point, Size).)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Inherited from BarCodeSymbology.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.MeasureOverride Method

LinearBarCodeSymbologyMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.Render Method

LinearBarCodeSymbologyRender Method

Renders the symbology to the specified DrawingContext.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Render(
    DrawingContext drawingContext,
    Point location,
    Size size
)
Public Overrides Sub Render (
    drawingContext As DrawingContext,
    location As Point,
    size As Size
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The DrawingContext upon which to render the symbology.
location
Type: System.WindowsPoint
The location at which to draw the bar code.
size
Type: System.WindowsSize
The size of the bar code to draw.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology Fields

The LinearBarCodeSymbology type exposes the following members.

Fields
Name | Description
BarDataProperty | Identifies the BarData dependency property. This field is read-only.
BarHeightProperty | Identifies the BarHeight dependency property. This field is read-only.
BarWidthRatioProperty | Identifies the BarWidthRatio dependency property. This field is read-only.
DisplayValueProperty | Identifies the DisplayValue dependency property. This field is read-only.
InstructionsProperty | Identifies the Instructions dependency property. This field is read-only.
MinBarHeightWidthRatioProperty | Identifies the MinBarHeightWidthRatio dependency property. This field is read-only.
QuietZoneThicknessProperty | Identifies the QuietZoneThickness dependency property. This field is read-only.
ValueDisplayStyleProperty | Identifies the ValueDisplayStyle dependency property. This field is read-only.
ValueIntrusionOffsetProperty | Identifies the ValueIntrusionOffset dependency property. This field is read-only.
Top
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.BarDataProperty Field

LinearBarCodeSymbologyBarDataProperty Field

Identifies the BarData dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarDataProperty
Public Shared ReadOnly BarDataProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarData dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.BarHeightProperty Field

LinearBarCodeSymbologyBarHeightProperty Field

Identifies the BarHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarHeightProperty
Public Shared ReadOnly BarHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarHeight dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.BarWidthRatioProperty Field

LinearBarCodeSymbologyBarWidthRatioProperty Field

Identifies the BarWidthRatio dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarWidthRatioProperty
Public Shared ReadOnly BarWidthRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarWidthRatio dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.DisplayValueProperty Field

LinearBarCodeSymbologyDisplayValueProperty Field

Identifies the DisplayValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayValueProperty
Public Shared ReadOnly DisplayValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayValue dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.InstructionsProperty Field

LinearBarCodeSymbologyInstructionsProperty Field

Identifies the Instructions dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InstructionsProperty
Public Shared ReadOnly InstructionsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Instructions dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.MinBarHeightWidthRatioProperty Field

LinearBarCodeSymbologyMinBarHeightWidthRatioProperty Field

Identifies the MinBarHeightWidthRatio dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinBarHeightWidthRatioProperty
Public Shared ReadOnly MinBarHeightWidthRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinBarHeightWidthRatio dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.QuietZoneThicknessProperty Field

LinearBarCodeSymbologyQuietZoneThicknessProperty Field

Identifies the QuietZoneThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty QuietZoneThicknessProperty
Public Shared ReadOnly QuietZoneThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the QuietZoneThickness dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.ValueDisplayStyleProperty Field

LinearBarCodeSymbologyValueDisplayStyleProperty Field

Identifies the ValueDisplayStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueDisplayStyleProperty
Public Shared ReadOnly ValueDisplayStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueDisplayStyle dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbology.ValueIntrusionOffsetProperty Field

LinearBarCodeSymbologyValueIntrusionOffsetProperty Field

Identifies the ValueIntrusionOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueIntrusionOffsetProperty
Public Shared ReadOnly ValueIntrusionOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueIntrusionOffset dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeSymbologyInstruction Enumeration

Specifies an instruction for a LinearBarCodeSymbology.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LinearBarCodeSymbologyInstruction
Public Enumeration LinearBarCodeSymbologyInstruction
Members
Member name | Value | Description
Black1 | 0 | A narrow black line.
Black2 | 1 | A wide black line (2x narrow).
Black3 | 2 | A wide black line (3x narrow).
Black4 | 3 | A wide black line (4x narrow).
BlackAscender2 | 4 | A wide black line (2x narrow) that only covers the top two-thirds of a normal size line.
BlackDescender2 | 5 | A wide black line (2x narrow) that only covers the bottom two-thirds of a normal size line.
BlackHalfDescender2 | 6 | A wide black line (2x narrow) that only covers the bottom third of a normal size line.
BlackHalfTracker2 | 7 | A wide black line (2x narrow) that only covers the middle third of a normal size line.
White1 | 8 | A narrow white line.
White2 | 9 | A wide white line (2x narrow).
White3 | 10 | A wide white line (3x narrow).
White4 | 11 | A wide white line (4x narrow).
ControlCharacterStart | 12 | The start of a control character.
EncodedCharacterStart | 13 | The start of an encoded character.
CharacterEnd | 14 | The end of a character.
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


LinearBarCodeValueDisplayStyle Enumeration

Specifies the display style for the value of a LinearBarCodeSymbology.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LinearBarCodeValueDisplayStyle
Public Enumeration LinearBarCodeValueDisplayStyle
Members
Member name | Value | Description
None | 0 | The value is not displayed.
Centered | 1 | The value is centered horizontally.
LeftAligned | 2 | The value is left-aligned.
RightAligned | 3 | The value is right-aligned.
CharactersAlignedWithBars | 4 | The characters in the value are centered under the bars that represent each character.
QuietZoneExtension | 5 | The first and last characters are drawn in the lead/tail quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as UPC-A.
QuietZoneExtensionLeft | 6 | The first character is drawn in the lead quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as EIN-13.
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


PostnetSymbology Class

Represents a bar code symbology implementation for Postnet.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodePostnetSymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PostnetSymbology : LinearBarCodeSymbology
Public Class PostnetSymbology
    Inherits LinearBarCodeSymbology

The PostnetSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | PostnetSymbology | Initializes an instance of the PostnetSymbology class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
Postnet is used by the United States Postal Service to assist in directing mail.

This symbology can encode 5, 9, or 11 numbers (all plus a check digit) where the required 5 characters are the 5-digit zip code, the optional next 4 characters are the zip+4 code, and the optional last two digits represent the last two numbers of the numeric address number.

This symbology implementation auto-calculates and inserts a check character.

For detailed documentation on this symbology's features and how to use them, please see the Postnet documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


PostnetSymbology Constructor

Initializes an instance of the PostnetSymbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PostnetSymbology()
Public Sub New
See Also

Reference

PostnetSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


PostnetSymbology Properties

The PostnetSymbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PostnetSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


PostnetSymbology Methods

The PostnetSymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PostnetSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


PostnetSymbology.OnValueChanged Method

PostnetSymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

PostnetSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


PostnetSymbology.ValidateValue Method

PostnetSymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

PostnetSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology Class

Represents a bar code symbology implementation for QrCode.
Data tables that are used in the creation of a symbol.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeGrid2DBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeQrCodeSymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class QrCodeSymbology : Grid2DBarCodeSymbology
Public Class QrCodeSymbology
    Inherits Grid2DBarCodeSymbology

The QrCodeSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | QrCodeSymbology | Initializes a new instance of the QrCodeSymbology class.
Top
Properties
 | Name | Description
Public property | AllowLowercase | Gets or sets a value indicating whether lowercase characters are allowed. This is a dependency property.
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Public property | CellSize | Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property. (Inherited from Grid2DBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | EncodingMode | Gets or sets the mode used to encode the specified value. This is a dependency property.
Public property | ErrorCorrectionLevel | Gets or sets the percentage of data loss that can occur on a symbol before it becomes unreadable. As the error correction level increases, the amount of data that can be encoded decreases. This is a dependency property.
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | GridData | Gets or sets an two dimensional array of boolean values that specifies how the symbol is to be rendered. (Inherited from Grid2DBarCodeSymbology.)
Public property | MaskIndex | Gets or sets the QR mask applied to the code. This is a dependency property.
Public property | QuietZoneThickness | Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property. (Inherited from Grid2DBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | Version | Gets or sets the version of the QR symbol. This value determines the number of modules that compose the symbol, thus contributing to the maximum amount of data that can be encoded. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from Grid2DBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from Grid2DBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
AllowLowercaseProperty | Identifies the AllowLowercase dependency property. This field is read-only.
EncodingModeProperty | Identifies the EncodingMode dependency property. This field is read-only.
ErrorCorrectionLevelProperty | Identifies the ErrorCorrectionLevel dependency property. This field is read-only.
MaskIndexProperty | Identifies the MaskIndex dependency property. This field is read-only.
VersionProperty | Identifies the Version dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
QR Code is a two dimensional grid symbology, developed in 1994 by Denso. It was initially intended for use in production control of automotive parts, but it has become widespread in other fields.

This symbology can encode a maximum of 7089 numerical characters, 4296 alphanumeric characters, 2953 binary characters, or 1817 Kanji characters.

For detailed documentation on this symbology's features and how to use them, please see the QrCode documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology Constructor

Initializes a new instance of the QrCodeSymbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QrCodeSymbology()
Public Sub New
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology Properties

The QrCodeSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AllowLowercase | Gets or sets a value indicating whether lowercase characters are allowed. This is a dependency property.
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Public property | CellSize | Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property. (Inherited from Grid2DBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | EncodingMode | Gets or sets the mode used to encode the specified value. This is a dependency property.
Public property | ErrorCorrectionLevel | Gets or sets the percentage of data loss that can occur on a symbol before it becomes unreadable. As the error correction level increases, the amount of data that can be encoded decreases. This is a dependency property.
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | GridData | Gets or sets an two dimensional array of boolean values that specifies how the symbol is to be rendered. (Inherited from Grid2DBarCodeSymbology.)
Public property | MaskIndex | Gets or sets the QR mask applied to the code. This is a dependency property.
Public property | QuietZoneThickness | Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property. (Inherited from Grid2DBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | Version | Gets or sets the version of the QR symbol. This value determines the number of modules that compose the symbol, thus contributing to the maximum amount of data that can be encoded. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.AllowLowercase Property

QrCodeSymbologyAllowLowercase Property

Gets or sets a value indicating whether lowercase characters are allowed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AllowLowercase { get; set; }
Public Property AllowLowercase As Boolean
    Get
    Set

Property Value

Type: Boolean
true if lowercase characters are allowed; otherwise, false will force all lowercase characters to be uppercase. The default value is false.
Remarks
The QR code specification does not allow lowercase characters when using the alphanumeric encoding mode. Therefore, when allowing lowercase characters the binary encoding mode must be used.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.EncodingMode Property

QrCodeSymbologyEncodingMode Property

Gets or sets the mode used to encode the specified value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<QrEncodingMode> EncodingMode { get; set; }
Public Property EncodingMode As Nullable(Of QrEncodingMode)
    Get
    Set

Property Value

Type: Nullable QrEncodingMode
The QR encoding mode. The default value is , which indicates the encoding mode will be auto-selected based on the specified value.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.ErrorCorrectionLevel Property

QrCodeSymbologyErrorCorrectionLevel Property

Gets or sets the percentage of data loss that can occur on a symbol before it becomes unreadable. As the error correction level increases, the amount of data that can be encoded decreases. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public QrErrorCorrectionLevel ErrorCorrectionLevel { get; set; }
Public Property ErrorCorrectionLevel As QrErrorCorrectionLevel
    Get
    Set

Property Value

Type: QrErrorCorrectionLevel
The error correction level.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.MaskIndex Property

QrCodeSymbologyMaskIndex Property

Gets or sets the QR mask applied to the code. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> MaskIndex { get; set; }
Public Property MaskIndex As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The QR mask applied to the code. The default value is , which indicates the mask will be auto-selected based on the specified value.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.Version Property

QrCodeSymbologyVersion Property

Gets or sets the version of the QR symbol. This value determines the number of modules that compose the symbol, thus contributing to the maximum amount of data that can be encoded. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<QrVersion> Version { get; set; }
Public Property Version As Nullable(Of QrVersion)
    Get
    Set

Property Value

Type: Nullable QrVersion
The version of the QR symbol. The default value is , which indicates the version will be auto-selected based on the specified value.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology Methods

The QrCodeSymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from Grid2DBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from Grid2DBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.OnValueChanged Method

QrCodeSymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.ValidateValue Method

QrCodeSymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology Fields

The QrCodeSymbology type exposes the following members.

Fields
Name | Description
AllowLowercaseProperty | Identifies the AllowLowercase dependency property. This field is read-only.
EncodingModeProperty | Identifies the EncodingMode dependency property. This field is read-only.
ErrorCorrectionLevelProperty | Identifies the ErrorCorrectionLevel dependency property. This field is read-only.
MaskIndexProperty | Identifies the MaskIndex dependency property. This field is read-only.
VersionProperty | Identifies the Version dependency property. This field is read-only.
Top
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.AllowLowercaseProperty Field

QrCodeSymbologyAllowLowercaseProperty Field

Identifies the AllowLowercase dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AllowLowercaseProperty
Public Shared ReadOnly AllowLowercaseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AllowLowercase dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.EncodingModeProperty Field

QrCodeSymbologyEncodingModeProperty Field

Identifies the EncodingMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EncodingModeProperty
Public Shared ReadOnly EncodingModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EncodingMode dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.ErrorCorrectionLevelProperty Field

QrCodeSymbologyErrorCorrectionLevelProperty Field

Identifies the ErrorCorrectionLevel dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ErrorCorrectionLevelProperty
Public Shared ReadOnly ErrorCorrectionLevelProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ErrorCorrectionLevel dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.MaskIndexProperty Field

QrCodeSymbologyMaskIndexProperty Field

Identifies the MaskIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaskIndexProperty
Public Shared ReadOnly MaskIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaskIndex dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrCodeSymbology.VersionProperty Field

QrCodeSymbologyVersionProperty Field

Identifies the Version dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty VersionProperty
Public Shared ReadOnly VersionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Version dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


QrEncodingMode Enumeration

Specifies the various encoding modes supported by QrCodeSymbology.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum QrEncodingMode
Public Enumeration QrEncodingMode
Members
Member name | Value | Description
Alphanumeric | 1 | Indicates that the data to be encoded will contain letters, numbers, and a limited set of symbols.
Binary | 2 | Indicates that the data to be encoded will be 8-bit bytes.
Kanji | 3 | Indicates that the data to be encoded will contain 8-bit bytes which represent Kanji characters.
Numeric | 0 | Indicates that the data to be encoded will contain only decimal numbers (0 through 9).
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


QrErrorCorrectionLevel Enumeration

Specifies the various error correction levels supported by QrCodeSymbology.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum QrErrorCorrectionLevel
Public Enumeration QrErrorCorrectionLevel
Members
Member name | Value | Description
L | 0 | Indicates that the error correction level should be 7%.
M | 1 | Indicates that the error correction level should be 15%.
Q | 2 | Indicates that the error correction level should be 25%.
H | 3 | Indicates that the error correction level should be 30%.
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


QrVersion Enumeration

Specifies the various versions supported by QrCodeSymbology. The size of the symbol for Micro QR Code symbols is always 9 + (2 * microVersion). For the 40 versions of regular QR Code symbols, the size is 17 + (4 * version). All versions are square.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum QrVersion
Public Enumeration QrVersion
Members
Member name | Value | Description
Version1 | 0 | Indicates that the version should be 1. The symbol size is 21.
Version2 | 1 | Indicates that the version should be 2. The symbol size is 25.
Version3 | 2 | Indicates that the version should be 3. The symbol size is 29.
Version4 | 3 | Indicates that the version should be 4. The symbol size is 33.
Version5 | 4 | Indicates that the version should be 5. The symbol size is 37.
Version6 | 5 | Indicates that the version should be 6. The symbol size is 41.
Version7 | 6 | Indicates that the version should be 7. The symbol size is 45.
Version8 | 7 | Indicates that the version should be 8. The symbol size is 49.
Version9 | 8 | Indicates that the version should be 9. The symbol size is 53.
Version10 | 9 | Indicates that the version should be 10. The symbol size is 57.
Version11 | 10 | Indicates that the version should be 11. The symbol size is 61.
Version12 | 11 | Indicates that the version should be 12. The symbol size is 65.
Version13 | 12 | Indicates that the version should be 13. The symbol size is 69.
Version14 | 13 | Indicates that the version should be 14. The symbol size is 73.
Version15 | 14 | Indicates that the version should be 15. The symbol size is 77.
Version16 | 15 | Indicates that the version should be 16. The symbol size is 81.
Version17 | 16 | Indicates that the version should be 17. The symbol size is 85.
Version18 | 17 | Indicates that the version should be 18. The symbol size is 89.
Version19 | 18 | Indicates that the version should be 19. The symbol size is 93.
Version20 | 19 | Indicates that the version should be 20. The symbol size is 97.
Version21 | 20 | Indicates that the version should be 21. The symbol size is 101.
Version22 | 21 | Indicates that the version should be 22. The symbol size is 105.
Version23 | 22 | Indicates that the version should be 23. The symbol size is 109.
Version24 | 23 | Indicates that the version should be 24. The symbol size is 113.
Version25 | 24 | Indicates that the version should be 25. The symbol size is 117.
Version26 | 25 | Indicates that the version should be 26. The symbol size is 121.
Version27 | 26 | Indicates that the version should be 27. The symbol size is 125.
Version28 | 27 | Indicates that the version should be 28. The symbol size is 129.
Version29 | 28 | Indicates that the version should be 29. The symbol size is 133.
Version30 | 29 | Indicates that the version should be 30. The symbol size is 137.
Version31 | 30 | Indicates that the version should be 31. The symbol size is 141.
Version32 | 31 | Indicates that the version should be 32. The symbol size is 145.
Version33 | 32 | Indicates that the version should be 33. The symbol size is 149.
Version34 | 33 | Indicates that the version should be 34. The symbol size is 153.
Version35 | 34 | Indicates that the version should be 35. The symbol size is 157.
Version36 | 35 | Indicates that the version should be 36. The symbol size is 161.
Version37 | 36 | Indicates that the version should be 37. The symbol size is 165.
Version38 | 37 | Indicates that the version should be 38. The symbol size is 169.
Version39 | 38 | Indicates that the version should be 39. The symbol size is 173.
Version40 | 39 | Indicates that the version should be 40. The symbol size is 177.
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


UpcASymbology Class

Represents a bar code symbology implementation for UPC-A.

This symbology is also known as Universal Product Code version A.

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeUpcASymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UpcASymbology : LinearBarCodeSymbology
Public Class UpcASymbology
    Inherits LinearBarCodeSymbology

The UpcASymbology type exposes the following members.

Constructors
 | Name | Description
Public method | UpcASymbology | Initializes an instance of the UpcASymbology class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
UPC-A is a linear symbology, widely used in the United States and Canada for tracking trade items in stores.

This symbology can encode 12 numeric characters, divided into four parts: system code, manufacturer code, product code, and check digit.

This symbology implementation auto-calculates and inserts a check digit.

For detailed documentation on this symbology's features and how to use them, please see the UPC-A documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


UpcASymbology Constructor

Initializes an instance of the UpcASymbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UpcASymbology()
Public Sub New
See Also

Reference

UpcASymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


UpcASymbology Properties

The UpcASymbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

UpcASymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


UpcASymbology Methods

The UpcASymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

UpcASymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


UpcASymbology.OnValueChanged Method

UpcASymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

UpcASymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


UpcASymbology.ValidateValue Method

UpcASymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

UpcASymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


UpcESymbology Class

Represents a bar code symbology implementation for UPC-E.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.BarCodeBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeLinearBarCodeSymbology
ActiproSoftware.Windows.Controls.BarCodeUpcESymbology

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UpcESymbology : LinearBarCodeSymbology
Public Class UpcESymbology
    Inherits LinearBarCodeSymbology

The UpcESymbology type exposes the following members.

Constructors
 | Name | Description
Public method | UpcESymbology | Initializes an instance of the UpcESymbology class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
UPC-E is a linear symbology, used on smaller retail packages where UPC-A bar codes don't fit.

This symbology can encode 8 numeric characters, divided into three parts: system code, product code, and check digit.

This symbology uses a check digit, but it is not currently calculated automatically.

For detailed documentation on this symbology's features and how to use them, please see the UPC-E documentation topic.

See Also

Reference

ActiproSoftware.Windows.Controls.BarCode Namespace


UpcESymbology Constructor

Initializes an instance of the UpcESymbology class.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UpcESymbology()
Public Sub New
See Also

Reference

UpcESymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


UpcESymbology Properties

The UpcESymbology type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush to use for rendering the background. (Inherited from BarCodeSymbology.)
Protected property | BarData | Gets or sets the string that specifies the data used to draw the bar code. (Inherited from LinearBarCodeSymbology.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | Foreground | Gets or sets the Brush to use for rendering the foreground. (Inherited from BarCodeSymbology.)
Protected property | Instructions | Gets or sets the dictionary of BarData characters and their related instructions. (Inherited from LinearBarCodeSymbology.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

UpcESymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


UpcESymbology Methods

The UpcESymbology type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MeasureDesiredSize | Measures the desired size of the symbology, based on the specified available size. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from LinearBarCodeSymbology.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from BarCodeSymbology.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Render | Renders the symbology to the specified DrawingContext. (Inherited from LinearBarCodeSymbology.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the symbology. (Inherited from BarCodeSymbology.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

UpcESymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


UpcESymbology.OnValueChanged Method

UpcESymbologyOnValueChanged Method

Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

UpcESymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


UpcESymbology.ValidateValue Method

UpcESymbologyValidateValue Method

Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.Windows.Controls.BarCode
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

UpcESymbology Class
ActiproSoftware.Windows.Controls.BarCode Namespace


ActiproSoftware.Windows.Controls.BarCode.Automation.Peers Namespace

Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | BarCodeAutomationPeer | Exposes the BarCode control to UI Automation.


BarCodeAutomationPeer Class

Exposes the BarCode control to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.BarCode.Automation.PeersBarCodeAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.BarCode.Automation.Peers
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BarCodeAutomationPeer : FrameworkElementAutomationPeer
Public Class BarCodeAutomationPeer
    Inherits FrameworkElementAutomationPeer

The BarCodeAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | BarCodeAutomationPeer | Initializes an instance of the BarCodeAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the AutomationControlType for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text string describing the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.Automation.Peers Namespace


BarCodeAutomationPeer Constructor

Initializes an instance of the BarCodeAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.BarCode.Automation.Peers
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BarCodeAutomationPeer(
    FrameworkElement owner
)
Public Sub New (
    owner As FrameworkElement
)

Parameters

owner
Type: System.WindowsFrameworkElement
The owner of the automation peer.
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.Windows.Controls.BarCode.Automation.Peers Namespace


BarCodeAutomationPeer Properties

The BarCodeAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.Windows.Controls.BarCode.Automation.Peers Namespace


BarCodeAutomationPeer Methods

The BarCodeAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the AutomationControlType for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text string describing the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.Windows.Controls.BarCode.Automation.Peers Namespace


BarCodeAutomationPeer.GetAutomationControlTypeCore Method

BarCodeAutomationPeerGetAutomationControlTypeCore Method

Gets the AutomationControlType for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.BarCode.Automation.Peers
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
A AutomationControlType indicating the control type.
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.Windows.Controls.BarCode.Automation.Peers Namespace


BarCodeAutomationPeer.GetClassNameCore Method

BarCodeAutomationPeerGetClassNameCore Method

Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.BarCode.Automation.Peers
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The string that contains the name.
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.Windows.Controls.BarCode.Automation.Peers Namespace


BarCodeAutomationPeer.GetNameCore Method

BarCodeAutomationPeerGetNameCore Method

Gets the text string describing the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.BarCode.Automation.Peers
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The string that contains the name.
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.Windows.Controls.BarCode.Automation.Peers Namespace


ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace

Contains ValidationRule classes that can be used in bindings to validate input values for a bar code symbology.
Classes
 | Class | Description
Public class | CodabarValidationRule | A validation rule that determines whether a value is valid for the Codabar symbology.
Public class | Code128ValidationRule | A validation rule that determines whether a value is valid for the Code 128 symbology.
Public class | Code39ExtendedValidationRule | A validation rule that determines whether a value is valid for the Code 39 Extended symbology.
Public class | Code39ValidationRule | A validation rule that determines whether a value is valid for the Code 39 symbology.
Public class | Code93ExtendedValidationRule | A validation rule that determines whether a value is valid for the Code 39 Extended symbology.
Public class | Code93ValidationRule | A validation rule that determines whether a value is valid for the Code 93 symbology.
Public class | Ean13ValidationRule | A validation rule that determines whether a value is valid for the EAN-13 symbology.
Public class | Ean8ValidationRule | A validation rule that determines whether a value is valid for the EAN-8 symbology.
Public class | Interleaved2of5ValidationRule | A validation rule that determines whether a value is valid for the Interleaved 2 of 5 symbology.
Public class | PostnetValidationRule | A validation rule that determines whether a value is valid for the Postnet symbology.
Public class | UpcAValidationRule | A validation rule that determines whether a value is valid for the UPC-A symbology.
Public class | UpcEValidationRule | A validation rule that determines whether a value is valid for the UPC-E symbology.


CodabarValidationRule Class

A validation rule that determines whether a value is valid for the Codabar symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesCodabarValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CodabarValidationRule : ValidationRule
Public Class CodabarValidationRule
    Inherits ValidationRule

The CodabarValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | CodabarValidationRule | Initializes a new instance of the CodabarValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


CodabarValidationRule Constructor

Initializes a new instance of the CodabarValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CodabarValidationRule()
Public Sub New
See Also

Reference

CodabarValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


CodabarValidationRule Properties

The CodabarValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

CodabarValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


CodabarValidationRule Methods

The CodabarValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

CodabarValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


CodabarValidationRule.Validate Method

CodabarValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

CodabarValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code128ValidationRule Class

A validation rule that determines whether a value is valid for the Code 128 symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesCode128ValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code128ValidationRule : ValidationRule
Public Class Code128ValidationRule
    Inherits ValidationRule

The Code128ValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | Code128ValidationRule | Initializes a new instance of the Code128ValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code128ValidationRule Constructor

Initializes a new instance of the Code128ValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code128ValidationRule()
Public Sub New
See Also

Reference

Code128ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code128ValidationRule Properties

The Code128ValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

Code128ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code128ValidationRule Methods

The Code128ValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

Code128ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code128ValidationRule.Validate Method

Code128ValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

Code128ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ExtendedValidationRule Class

A validation rule that determines whether a value is valid for the Code 39 Extended symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesCode39ExtendedValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code39ExtendedValidationRule : ValidationRule
Public Class Code39ExtendedValidationRule
    Inherits ValidationRule

The Code39ExtendedValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | Code39ExtendedValidationRule | Initializes a new instance of the Code39ExtendedValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ExtendedValidationRule Constructor

Initializes a new instance of the Code39ExtendedValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code39ExtendedValidationRule()
Public Sub New
See Also

Reference

Code39ExtendedValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ExtendedValidationRule Properties

The Code39ExtendedValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

Code39ExtendedValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ExtendedValidationRule Methods

The Code39ExtendedValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

Code39ExtendedValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ExtendedValidationRule.Validate Method

Code39ExtendedValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

Code39ExtendedValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ValidationRule Class

A validation rule that determines whether a value is valid for the Code 39 symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesCode39ValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code39ValidationRule : ValidationRule
Public Class Code39ValidationRule
    Inherits ValidationRule

The Code39ValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | Code39ValidationRule | Initializes a new instance of the Code39ValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ValidationRule Constructor

Initializes a new instance of the Code39ValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code39ValidationRule()
Public Sub New
See Also

Reference

Code39ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ValidationRule Properties

The Code39ValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

Code39ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ValidationRule Methods

The Code39ValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

Code39ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code39ValidationRule.Validate Method

Code39ValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

Code39ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ExtendedValidationRule Class

A validation rule that determines whether a value is valid for the Code 39 Extended symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesCode93ExtendedValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code93ExtendedValidationRule : ValidationRule
Public Class Code93ExtendedValidationRule
    Inherits ValidationRule

The Code93ExtendedValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | Code93ExtendedValidationRule | Initializes a new instance of the Code93ExtendedValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ExtendedValidationRule Constructor

Initializes a new instance of the Code93ExtendedValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code93ExtendedValidationRule()
Public Sub New
See Also

Reference

Code93ExtendedValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ExtendedValidationRule Properties

The Code93ExtendedValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

Code93ExtendedValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ExtendedValidationRule Methods

The Code93ExtendedValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

Code93ExtendedValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ExtendedValidationRule.Validate Method

Code93ExtendedValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

Code93ExtendedValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ValidationRule Class

A validation rule that determines whether a value is valid for the Code 93 symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesCode93ValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Code93ValidationRule : ValidationRule
Public Class Code93ValidationRule
    Inherits ValidationRule

The Code93ValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | Code93ValidationRule | Initializes a new instance of the Code93ValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ValidationRule Constructor

Initializes a new instance of the Code93ValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Code93ValidationRule()
Public Sub New
See Also

Reference

Code93ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ValidationRule Properties

The Code93ValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

Code93ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ValidationRule Methods

The Code93ValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

Code93ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Code93ValidationRule.Validate Method

Code93ValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

Code93ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean13ValidationRule Class

A validation rule that determines whether a value is valid for the EAN-13 symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesEan13ValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Ean13ValidationRule : ValidationRule
Public Class Ean13ValidationRule
    Inherits ValidationRule

The Ean13ValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | Ean13ValidationRule | Initializes a new instance of the Ean13ValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean13ValidationRule Constructor

Initializes a new instance of the Ean13ValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Ean13ValidationRule()
Public Sub New
See Also

Reference

Ean13ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean13ValidationRule Properties

The Ean13ValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

Ean13ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean13ValidationRule Methods

The Ean13ValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

Ean13ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean13ValidationRule.Validate Method

Ean13ValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

Ean13ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean8ValidationRule Class

A validation rule that determines whether a value is valid for the EAN-8 symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesEan8ValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Ean8ValidationRule : ValidationRule
Public Class Ean8ValidationRule
    Inherits ValidationRule

The Ean8ValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | Ean8ValidationRule | Initializes a new instance of the Ean8ValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean8ValidationRule Constructor

Initializes a new instance of the Ean8ValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Ean8ValidationRule()
Public Sub New
See Also

Reference

Ean8ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean8ValidationRule Properties

The Ean8ValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

Ean8ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean8ValidationRule Methods

The Ean8ValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

Ean8ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Ean8ValidationRule.Validate Method

Ean8ValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

Ean8ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Interleaved2of5ValidationRule Class

A validation rule that determines whether a value is valid for the Interleaved 2 of 5 symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesInterleaved2of5ValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Interleaved2of5ValidationRule : ValidationRule
Public Class Interleaved2of5ValidationRule
    Inherits ValidationRule

The Interleaved2of5ValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | Interleaved2of5ValidationRule | Initializes a new instance of the Interleaved2of5ValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Interleaved2of5ValidationRule Constructor

Initializes a new instance of the Interleaved2of5ValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Interleaved2of5ValidationRule()
Public Sub New
See Also

Reference

Interleaved2of5ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Interleaved2of5ValidationRule Properties

The Interleaved2of5ValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

Interleaved2of5ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Interleaved2of5ValidationRule Methods

The Interleaved2of5ValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

Interleaved2of5ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


Interleaved2of5ValidationRule.Validate Method

Interleaved2of5ValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

Interleaved2of5ValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


PostnetValidationRule Class

A validation rule that determines whether a value is valid for the Postnet symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesPostnetValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PostnetValidationRule : ValidationRule
Public Class PostnetValidationRule
    Inherits ValidationRule

The PostnetValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | PostnetValidationRule | Initializes a new instance of the PostnetValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


PostnetValidationRule Constructor

Initializes a new instance of the PostnetValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PostnetValidationRule()
Public Sub New
See Also

Reference

PostnetValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


PostnetValidationRule Properties

The PostnetValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

PostnetValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


PostnetValidationRule Methods

The PostnetValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

PostnetValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


PostnetValidationRule.Validate Method

PostnetValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

PostnetValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcAValidationRule Class

A validation rule that determines whether a value is valid for the UPC-A symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesUpcAValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UpcAValidationRule : ValidationRule
Public Class UpcAValidationRule
    Inherits ValidationRule

The UpcAValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | UpcAValidationRule | Initializes a new instance of the UpcAValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcAValidationRule Constructor

Initializes a new instance of the UpcAValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UpcAValidationRule()
Public Sub New
See Also

Reference

UpcAValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcAValidationRule Properties

The UpcAValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

UpcAValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcAValidationRule Methods

The UpcAValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

UpcAValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcAValidationRule.Validate Method

UpcAValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

UpcAValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcEValidationRule Class

A validation rule that determines whether a value is valid for the UPC-E symbology.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
ActiproSoftware.Windows.Controls.BarCode.ValidationRulesUpcEValidationRule

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class UpcEValidationRule : ValidationRule
Public Class UpcEValidationRule
    Inherits ValidationRule

The UpcEValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | UpcEValidationRule | Initializes a new instance of the UpcEValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcEValidationRule Constructor

Initializes a new instance of the UpcEValidationRule class

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UpcEValidationRule()
Public Sub New
See Also

Reference

UpcEValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcEValidationRule Properties

The UpcEValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

UpcEValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcEValidationRule Methods

The UpcEValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Performs validation checks on a value. (Overrides ValidationRuleValidate(Object, CultureInfo).)
Top
See Also

Reference

UpcEValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


UpcEValidationRule.Validate Method

UpcEValidationRuleValidate Method

Performs validation checks on a value.

Namespace: ActiproSoftware.Windows.Controls.BarCode.ValidationRules
Assembly: ActiproSoftware.BarCode.Wpf (in ActiproSoftware.BarCode.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
Public Overrides Function Validate (
    value As Object,
    cultureInfo As CultureInfo
) As ValidationResult

Parameters

value
Type: SystemObject
The value from the binding target to check.
cultureInfo
Type: System.GlobalizationCultureInfo
The culture to use in this rule.

Return Value

Type: ValidationResult
A ValidationResult that specifies the result.
See Also

Reference

UpcEValidationRule Class
ActiproSoftware.Windows.Controls.BarCode.ValidationRules Namespace


ActiproSoftware.Windows.Controls.Charts Namespace

Contains classes that support implementing chart controls for WPF.
Classes
 | Class | Description
Public class | AreaSeries | Represents an area series for use in a XYChart.
Public class | BarSeries | Represents a bar series for use in a XYChart.
Public class | ChartMarker | Represents a control capable of rendering predefined shapes.
Public class | DataPointLabel | A label on a data point.
Public class | DeferrableObservableItemCollectionT | Represents a collection of objects that can be observed for items being removed and added by any means, including Clear and Replace.
Public class | DonutChart | Represents a donut chart control, which is a pie chart with the center cut out.
Public class | InvalidAxisException | An exception thrown when an axis is bound to an incorrect data type.
Public class | LegendKey | Describes a key shown in a legend.
Public class | LineSeries | Represents a line series for use in a XYChart.
Public class | NonNumericValueException | An exception for when a non-numeric value is provided.
Public class | PieChart | A control that displays a pie chart based on given data.
Public class | PieSeries | Represents a pie series for use in a PieChart or DonutChart.
Public class | PieSliceStyleSelector | A base class that selects a style for a given PieSlice.
Public class | PieSliceStyleSelectorConverter | Represents a type converter for the SeriesStyleSelector type.
Public class | ScatterSeries | Represents a scatter series for use in a XYChart.
Public class | SeriesStyleSelector | Provides a way to apply series styles based on custom logic.
Public class | SeriesStyleSelectorConverter | Represents a type converter for the SeriesStyleSelector type.
Public class | TimeSpanConverter | Converts TimeSpan to and from a String.
Public class | XYAxisCollection | Represents a collection of XYAxisBase objects.
Public class | XYChart | Represents a chart control that uses an X/Y coordinate system.
Public class | XYDataPoint | Represents a data point presented by a a XYSeriesBase series.
Public class | XYDateTimeAxis | Represents an axis for data in DateTime format.
Public class | XYDecimalAxis | Represents an axis for data in Decimal format.
Public class | XYDecimalAxisBaseT | Represents an axis for data in Decimal format.
Public class | XYDoubleAxis | Represents an axis for data in Double format.
Public class | XYGroupedAxis | XYGroupedAxis is an axis type used for displaying non-value data, such as strings and complex types. It can group, label, and sort data based on custom criteria.
Public class | XYPercentageAxis | Represents an axis for data displayed as stacked in percentage mode.
Public class | XYRange | Represents a range for use in a XYChart.
Public class | XYRangeCollection | Represents a collection of XYRange objects.
Public class | XYSeriesCollection | Represents a collection of XYRange objects.
Interfaces
 | Interface | Description
Public interface | ILabelPositioner | Positions data point labels.
Public interface | IPieSliceStyleSelector | Provides the base requirements for a class that determines how a pie slice will be styled.
Public interface | ISeriesStyleSelector | Provides the base requirements for a class that determines how a series will be styled.
Enumerations
 | Enumeration | Description
Public enumeration | AggregationKind | Specifies the various kinds of built-in aggregation functions.
Public enumeration | AxisPosition | Specifies the position of the axis in relation to the chart.
Public enumeration | ChartMarkerShapeKind | Specifies the various predefined shapes supported by ChartMarker.
Public enumeration | ChartMarkerVisibility | Specifies the visibility of the various kinds of ChartMarker.
Public enumeration | GridLineVisibility | Specifies which axes that grid lines will be visible for.
Public enumeration | GridStripeVisibility | Specifies which axes that grid stripes will be visible for.
Public enumeration | LabelCollisionMode | Specifies how data point labels resolve collisions.
Public enumeration | LabelPositioningMode | Specifies how data point labels are positioned.
Public enumeration | LabelVisibility | Specifies the visibility of data point labels on the chart.
Public enumeration | LegendHorizontalPosition | Specifies the horizontal position of the legend in relation to its parent chart.
Public enumeration | LegendVerticalPosition | Specifies the vertical position of the legend in relation to its parent chart.
Public enumeration | LineSeriesVisibility | Specifies the visibility of the various kinds of a line.
Public enumeration | PieSeriesChildPosition | The position of the child pie series.
Public enumeration | PieSliceLabelInsideFitMode | Determines what happens if a label does not fit inside the pie slice.
Public enumeration | PieSliceLabelPosition | Determines where the pie slice labels are positioned.
Public enumeration | TimeUnit | Specifies a unit of time.
Public enumeration | XYSeriesLineKind | Specifies the line kinds supported by a LineSeries and AreaSeries series.
Public enumeration | XYSeriesStackKind | Specifies the stacking methods supported by a XYSeriesBase series.


AggregationKind Enumeration

Specifies the various kinds of built-in aggregation functions.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum AggregationKind
Public Enumeration AggregationKind
Members
Member name | Value | Description
Average | 0 | Indicates that the values will be averaged together.
Maximum | 1 | Indicates that the maximum value will be used.
Minimum | 2 | Indicates that the minimum value will be used.
First | 3 | Indicates that the first value will be used.
Last | 4 | Indicates that the last value will be used.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries Class

Represents an area series for use in a XYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesLineSeriesBase
ActiproSoftware.Windows.Controls.ChartsAreaSeries

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AreaSeries : LineSeriesBase
Public Class AreaSeries
    Inherits LineSeriesBase

The AreaSeries type exposes the following members.

Constructors
 | Name | Description
Public method | AreaSeries | Initializes a new instance of the AreaSeries class.
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AreaStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Overrides LineSeriesBaseLabelPositioningMode.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineVisibility | Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from LineSeriesBase.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from LineSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
Fields
Name | Description
AreaStyleProperty | Identifies the AreaStyle dependency property. This field is read-only.
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
LineVisibilityProperty | Identifies the LineVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries Constructor

Initializes a new instance of the AreaSeries class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AreaSeries()
Public Sub New
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries Properties

The AreaSeries type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AreaStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Overrides LineSeriesBaseLabelPositioningMode.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineVisibility | Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from LineSeriesBase.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from LineSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries.AreaStyle Property

AreaSeriesAreaStyle Property

Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style AreaStyle { get; set; }
Public Property AreaStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries.LabelPositioningMode Property

AreaSeriesLabelPositioningMode Property

Gets or sets the LabelPositioningMode used to determine how labels are laid out.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override LabelPositioningMode LabelPositioningMode { get; set; }
Public Overrides Property LabelPositioningMode As LabelPositioningMode
    Get
    Set

Property Value

Type: LabelPositioningMode
The label positioning mode. The default value is FromBaseline.
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries.LineVisibility Property

AreaSeriesLineVisibility Property

Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LineSeriesVisibility LineVisibility { get; set; }
Public Property LineVisibility As LineSeriesVisibility
    Get
    Set

Property Value

Type: LineSeriesVisibility
A LineSeriesVisibility indicating which lines are rendered along the series. The default value is LineSeriesVisibility.None.
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries Methods

The AreaSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries Events

The AreaSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries Fields

The AreaSeries type exposes the following members.

Fields
Name | Description
AreaStyleProperty | Identifies the AreaStyle dependency property. This field is read-only.
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
LineVisibilityProperty | Identifies the LineVisibility dependency property. This field is read-only.
Top
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries.AreaStyleProperty Field

AreaSeriesAreaStyleProperty Field

Identifies the AreaStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreaStyleProperty
Public Shared ReadOnly AreaStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreaStyle dependency property.
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries.LabelPositioningModeProperty Field

AreaSeriesLabelPositioningModeProperty Field

Identifies the LabelPositioningMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositioningModeProperty
Public Shared ReadOnly LabelPositioningModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelPositioningMode dependency property.
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AreaSeries.LineVisibilityProperty Field

AreaSeriesLineVisibilityProperty Field

Identifies the LineVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineVisibilityProperty
Public Shared ReadOnly LineVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineVisibility dependency property.
See Also

Reference

AreaSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


AxisPosition Enumeration

Specifies the position of the axis in relation to the chart.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum AxisPosition
Public Enumeration AxisPosition
Members
Member name | Value | Description
NearEdge | 0 | Indicates that the axis will be placed on the near (bottom / left) edge of the chart.
FarEdge | 1 | Indicates that the axis will be placed on the far (top / right) edge of the chart.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


BarSeries Class

Represents a bar series for use in a XYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesBarSeriesBase
ActiproSoftware.Windows.Controls.ChartsBarSeries

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BarSeries : BarSeriesBase
Public Class BarSeries
    Inherits BarSeriesBase

The BarSeries type exposes the following members.

Constructors
 | Name | Description
Public method | BarSeries | Initializes a new instance of the BarSeries class.
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | BarTemplate | Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Inherited from BarSeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from BarSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from BarSeriesBase.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from BarSeriesBase.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from BarSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


BarSeries Constructor

Initializes a new instance of the BarSeries class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BarSeries()
Public Sub New
See Also

Reference

BarSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


BarSeries Properties

The BarSeries type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | BarTemplate | Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Inherited from BarSeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from BarSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from BarSeriesBase.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from BarSeriesBase.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from BarSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

BarSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


BarSeries Methods

The BarSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

BarSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


BarSeries Events

The BarSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
See Also

Reference

BarSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker Class

Represents a control capable of rendering predefined shapes.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ChartsChartMarker

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ChartMarker : Control
Public Class ChartMarker
    Inherits Control

The ChartMarker type exposes the following members.

Constructors
 | Name | Description
Public method | ChartMarker | Initializes a new instance of the ChartMarker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Protected property | Path | Gets the Path associated with the marker.
Public property | ShapeKind | Gets or sets a ChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdatePath | Updates the Geometry of the Path element.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ShapeKindProperty | Identifies the ShapeKind dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker Constructor

Initializes a new instance of the ChartMarker class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ChartMarker()
Public Sub New
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker Properties

The ChartMarker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Protected property | Path | Gets the Path associated with the marker.
Public property | ShapeKind | Gets or sets a ChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker.Path Property

ChartMarkerPath Property

Gets the Path associated with the marker.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Path Path { get; }
Protected ReadOnly Property Path As Path
    Get

Property Value

Type: Path
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker.ShapeKind Property

ChartMarkerShapeKind Property

Gets or sets a ChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ChartMarkerShapeKind ShapeKind { get; set; }
Public Property ShapeKind As ChartMarkerShapeKind
    Get
    Set

Property Value

Type: ChartMarkerShapeKind
A ChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. The default value is ChartMarkerShapeKind.Ellipse.
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker Methods

The ChartMarker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdatePath | Updates the Geometry of the Path element.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker.OnApplyTemplate Method

ChartMarkerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker.UpdatePath Method

ChartMarkerUpdatePath Method

Updates the Geometry of the Path element.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdatePath()
Protected Overridable Sub UpdatePath
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker Events

The ChartMarker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker Fields

The ChartMarker type exposes the following members.

Fields
Name | Description
ShapeKindProperty | Identifies the ShapeKind dependency property. This field is read-only.
Top
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarker.ShapeKindProperty Field

ChartMarkerShapeKindProperty Field

Identifies the ShapeKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ShapeKindProperty
Public Shared ReadOnly ShapeKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ShapeKind dependency property.
See Also

Reference

ChartMarker Class
ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarkerShapeKind Enumeration

Specifies the various predefined shapes supported by ChartMarker.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ChartMarkerShapeKind
Public Enumeration ChartMarkerShapeKind
Members
Member name | Value | Description
Diamond | 0 | Indicates a diamond shape will be rendered.
Ellipse | 1 | Indicates an ellipse shape will be rendered.
Hexagon | 2 | Indicates a hexagon shape will be rendered.
Pentagon | 3 | Indicates a pentagon shape will be rendered.
Octagon | 4 | Indicates an octagon shape will be rendered.
Rectangle | 5 | Indicates a rectangle shape will be rendered.
RoundedRectangle | 6 | Indicates a rounded rectangle shape will be rendered.
Star4Points | 7 | Indicates an 4-pointed star shape will be rendered.
Star5Points | 8 | Indicates an 5-pointed star shape will be rendered.
Star6Points | 9 | Indicates an 6-pointed star shape will be rendered.
Star8Points | 10 | Indicates an 8-pointed star shape will be rendered.
Triangle | 11 | Indicates a triangle shape will be rendered.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


ChartMarkerVisibility Enumeration

Specifies the visibility of the various kinds of ChartMarker.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ChartMarkerVisibility
Public Enumeration ChartMarkerVisibility
Members
Member name | Value | Description
None | 0 | Indicates that no markers will be visible.
Positive | 1 | Indicates that positive markers will be visible.
Negative | 2 | Indicates that negative markers will be visible.
High | 4 | Indicates that high markers will be visible.
Low | 8 | Indicates that low markers will be visible.
First | 16 | Indicates that the first marker will be visible.
Last | 32 | Indicates that the last marker will be visible.
All | 63 | Indicates that all markers will be visible.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel Class

A label on a data point.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ChartsDataPointLabel

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataPointLabel : Control
Public Class DataPointLabel
    Inherits Control

The DataPointLabel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DesiredPosition | Gets or sets the desired position.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SeriesDefaultBrush | Gets or sets the series default brush.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the label text.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WasMouseInsideBounds | Gets or sets a value indicating whether the data point was mouse inside bounds.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | Hide | Begins the animation to hide the data point label.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Show | Begins the animation to show the data point label.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
SeriesDefaultBrushProperty | Identifies the SeriesDefaultBrush dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
WasMouseInsideBoundsProperty | Identifies the WasMouseInsideBounds dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel Properties

The DataPointLabel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DesiredPosition | Gets or sets the desired position.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SeriesDefaultBrush | Gets or sets the series default brush.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the label text.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WasMouseInsideBounds | Gets or sets a value indicating whether the data point was mouse inside bounds.
Top
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.DesiredPosition Property

DataPointLabelDesiredPosition Property

Gets or sets the desired position.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point DesiredPosition { get; set; }
Public Property DesiredPosition As Point
    Get
    Set

Property Value

Type: Point
The desired position.
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.SeriesDefaultBrush Property

DataPointLabelSeriesDefaultBrush Property

Gets or sets the series default brush.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush SeriesDefaultBrush { get; set; }
Public Property SeriesDefaultBrush As Brush
    Get
    Set

Property Value

Type: Brush
The series default brush.
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.Text Property

DataPointLabelText Property

Gets or sets the label text.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The label text.
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.WasMouseInsideBounds Property

DataPointLabelWasMouseInsideBounds Property

Gets or sets a value indicating whether the data point was mouse inside bounds.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool WasMouseInsideBounds { get; set; }
Public Property WasMouseInsideBounds As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data point was mouse inside bounds; otherwise, false.
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel Methods

The DataPointLabel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | Hide | Begins the animation to hide the data point label.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Show | Begins the animation to show the data point label.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.Hide Method

DataPointLabelHide Method

Begins the animation to hide the data point label.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Hide()
Public Sub Hide
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.OnApplyTemplate Method

DataPointLabelOnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.Show Method

DataPointLabelShow Method

Begins the animation to show the data point label.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Show()
Public Sub Show
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel Events

The DataPointLabel type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel Fields

The DataPointLabel type exposes the following members.

Fields
Name | Description
SeriesDefaultBrushProperty | Identifies the SeriesDefaultBrush dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
WasMouseInsideBoundsProperty | Identifies the WasMouseInsideBounds dependency property. This field is read-only.
Top
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.SeriesDefaultBrushProperty Field

DataPointLabelSeriesDefaultBrushProperty Field

Identifies the SeriesDefaultBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SeriesDefaultBrushProperty
Public Shared ReadOnly SeriesDefaultBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SeriesDefaultBrush dependency property.
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.TextProperty Field

DataPointLabelTextProperty Field

Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DataPointLabel.WasMouseInsideBoundsProperty Field

DataPointLabelWasMouseInsideBoundsProperty Field

Identifies the WasMouseInsideBounds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WasMouseInsideBoundsProperty
Public Shared ReadOnly WasMouseInsideBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WasMouseInsideBounds dependency property.
See Also

Reference

DataPointLabel Class
ActiproSoftware.Windows.Controls.Charts Namespace


DeferrableObservableItemCollection(T) Class

DeferrableObservableItemCollectionT Class

Represents a collection of objects that can be observed for items being removed and added by any means, including Clear and Replace.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.WindowsDeferrableObservableCollection T
ActiproSoftware.Windows.Controls.ChartsDeferrableObservableItemCollectionT
ActiproSoftware.Windows.Controls.ChartsXYAxisCollection
ActiproSoftware.Windows.Controls.ChartsXYRangeCollection
ActiproSoftware.Windows.Controls.ChartsXYSeriesCollection

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DeferrableObservableItemCollection<T> : DeferrableObservableCollection<T>
where T : class

Public Class DeferrableObservableItemCollection(Of T As Class)
    Inherits DeferrableObservableCollection(Of T)

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.Windows.Controls.Charts.DeferrableObservableItemCollection`1"]

The DeferrableObservableItemCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


DeferrableObservableItemCollection(T) Properties

DeferrableObservableItemCollectionT Properties

The DeferrableObservableItemCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Top
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.Windows.Controls.Charts Namespace


DeferrableObservableItemCollection(T) Methods

DeferrableObservableItemCollectionT Methods

The DeferrableObservableItemCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.Windows.Controls.Charts Namespace


DeferrableObservableItemCollection(T).ClearItems Method

DeferrableObservableItemCollectionTClearItems Method

Removes all items from the collection.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.Windows.Controls.Charts Namespace


DeferrableObservableItemCollection(T).InsertItem Method

DeferrableObservableItemCollectionTInsertItem Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert.
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.Windows.Controls.Charts Namespace


DeferrableObservableItemCollection(T).RemoveItem Method

DeferrableObservableItemCollectionTRemoveItem Method

Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.Windows.Controls.Charts Namespace


DeferrableObservableItemCollection(T).SetItem Method

DeferrableObservableItemCollectionTSetItem Method

Replaces the element at the specified index.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to replace.
item
Type: T
The new value for the element at the specified index.
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.Windows.Controls.Charts Namespace


DeferrableObservableItemCollection(T) Events

DeferrableObservableItemCollectionT Events

The DeferrableObservableItemCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T .)
Top
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.Windows.Controls.Charts Namespace


DonutChart Class

Represents a donut chart control, which is a pie chart with the center cut out.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ChartsPieChart
ActiproSoftware.Windows.Controls.ChartsDonutChart

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DonutChart : PieChart
Public Class DonutChart
    Inherits PieChart

The DonutChart type exposes the following members.

Constructors
 | Name | Description
Public method | DonutChart | Initializes a new instance of the DonutChart class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | DrawingSurfaceSize | Gets or sets the size of the drawing surface. (Inherited from PieChart.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HoleRadiusPercentage | Gets the hole radius percentage.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible. (Inherited from PieChart.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position. (Inherited from PieChart.)
Public property | LegendMargin | Gets or sets the legend margin. (Inherited from PieChart.)
Public property | LegendStyle | Gets or sets the legend style. Must have a TargetType of Legend. (Inherited from PieChart.)
Public property | LegendVerticalPosition | Gets or sets the legend vertical position. (Inherited from PieChart.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Series | Gets the series. (Inherited from PieChart.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TetherBrush | Gets or sets the brush used to draw label tethers. Remarks If TetherBrush is not set, then Foreground will be used instead. (Inherited from PieChart.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Inherited from PieChart.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PieChart.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Refreshes this instance. (Inherited from PieChart.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
HoleRadiusPercentageProperty | Identifies the HoleRadiusPercentage dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


DonutChart Constructor

Initializes a new instance of the DonutChart class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DonutChart()
Public Sub New
See Also

Reference

DonutChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


DonutChart Properties

The DonutChart type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | DrawingSurfaceSize | Gets or sets the size of the drawing surface. (Inherited from PieChart.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HoleRadiusPercentage | Gets the hole radius percentage.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible. (Inherited from PieChart.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position. (Inherited from PieChart.)
Public property | LegendMargin | Gets or sets the legend margin. (Inherited from PieChart.)
Public property | LegendStyle | Gets or sets the legend style. Must have a TargetType of Legend. (Inherited from PieChart.)
Public property | LegendVerticalPosition | Gets or sets the legend vertical position. (Inherited from PieChart.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Series | Gets the series. (Inherited from PieChart.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TetherBrush | Gets or sets the brush used to draw label tethers. Remarks If TetherBrush is not set, then Foreground will be used instead. (Inherited from PieChart.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DonutChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


DonutChart.HoleRadiusPercentage Property

DonutChartHoleRadiusPercentage Property

Gets the hole radius percentage.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double HoleRadiusPercentage { get; set; }
Public Property HoleRadiusPercentage As Double
    Get
    Set

Property Value

Type: Double
The hole radius percentage.
See Also

Reference

DonutChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


DonutChart Methods

The DonutChart type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Inherited from PieChart.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PieChart.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Refreshes this instance. (Inherited from PieChart.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DonutChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


DonutChart Events

The DonutChart type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DonutChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


DonutChart Fields

The DonutChart type exposes the following members.

Fields
Name | Description
HoleRadiusPercentageProperty | Identifies the HoleRadiusPercentage dependency property. This field is read-only.
Top
See Also

Reference

DonutChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


DonutChart.HoleRadiusPercentageProperty Field

DonutChartHoleRadiusPercentageProperty Field

Identifies the HoleRadiusPercentage dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HoleRadiusPercentageProperty
Public Shared ReadOnly HoleRadiusPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HoleRadiusPercentage dependency property.
See Also

Reference

DonutChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


GridLineVisibility Enumeration

Specifies which axes that grid lines will be visible for.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum GridLineVisibility
Public Enumeration GridLineVisibility
Members
Member name | Value | Description
None | 0 | Indicates that grid lines will not be visible.
X | 1 | Indicates that grid lines will be visible for the X axis.
Y | 2 | Indicates that grid lines will be visible for the Y axis.
All | 3 | Indicates that grid lines will be visible for both the X and Y axis.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


GridStripeVisibility Enumeration

Specifies which axes that grid stripes will be visible for.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum GridStripeVisibility
Public Enumeration GridStripeVisibility
Members
Member name | Value | Description
None | 0 | Indicates that grid stripes will not be visible.
X | 1 | Indicates that grid stripes will be visible for the X axis.
Y | 2 | Indicates that grid stripes will be visible for the Y axis.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


ILabelPositioner Interface

Positions data point labels.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ILabelPositioner
Public Interface ILabelPositioner

The ILabelPositioner type exposes the following members.

Methods
 | Name | Description
Public method | GetRotationPointForLabel | Gets the rotation point for a given DataPointLabel.
Public method | SetLabelPosition | Sets the label position.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


ILabelPositioner Methods

The ILabelPositioner type exposes the following members.

Methods
 | Name | Description
Public method | GetRotationPointForLabel | Gets the rotation point for a given DataPointLabel.
Public method | SetLabelPosition | Sets the label position.
Top
See Also

Reference

ILabelPositioner Interface
ActiproSoftware.Windows.Controls.Charts Namespace


ILabelPositioner.GetRotationPointForLabel Method

ILabelPositionerGetRotationPointForLabel Method

Gets the rotation point for a given DataPointLabel.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Point GetRotationPointForLabel(
    DataPointLabel label,
    IEnumerable<DataPointLabel> allLabels
)
Function GetRotationPointForLabel (
    label As DataPointLabel,
    allLabels As IEnumerable(Of DataPointLabel)
) As Point

Parameters

label
Type: ActiproSoftware.Windows.Controls.ChartsDataPointLabel
The label.
allLabels
Type: System.Collections.GenericIEnumerable DataPointLabel
All labels.

Return Value

Type: Point
The rotation point for a given DataPointLabel.
See Also

Reference

ILabelPositioner Interface
ActiproSoftware.Windows.Controls.Charts Namespace


ILabelPositioner.SetLabelPosition Method

ILabelPositionerSetLabelPosition Method

Sets the label position.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void SetLabelPosition(
    DataPointLabel label,
    IEnumerable<DataPointLabel> allLabels
)
Sub SetLabelPosition (
    label As DataPointLabel,
    allLabels As IEnumerable(Of DataPointLabel)
)

Parameters

label
Type: ActiproSoftware.Windows.Controls.ChartsDataPointLabel
The label.
allLabels
Type: System.Collections.GenericIEnumerable DataPointLabel
All labels.
See Also

Reference

ILabelPositioner Interface
ActiproSoftware.Windows.Controls.Charts Namespace


InvalidAxisException Class

An exception thrown when an axis is bound to an incorrect data type.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.Windows.Controls.ChartsInvalidAxisException

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InvalidAxisException : Exception
<SerializableAttribute>
Public Class InvalidAxisException
    Inherits Exception
Constructors
 | Name | Description
Public method | InvalidAxisException | Initializes a new instance of the InvalidAxisException class.
Public method | InvalidAxisException(String) | Initializes a new instance of the Exception class with a specified error message.
Protected method | InvalidAxisException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidAxisException class with serialized data.
Public method | InvalidAxisException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


InvalidAxisException Constructor

Overload List
 | Name | Description
Public method | InvalidAxisException | Initializes a new instance of the InvalidAxisException class.
Public method | InvalidAxisException(String) | Initializes a new instance of the Exception class with a specified error message.
Protected method | InvalidAxisException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidAxisException class with serialized data.
Public method | InvalidAxisException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidAxisException Class
ActiproSoftware.Windows.Controls.Charts Namespace


InvalidAxisException Constructor

Initializes a new instance of the InvalidAxisException class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidAxisException()
Public Sub New
See Also

Reference

InvalidAxisException Class
InvalidAxisException Overload
ActiproSoftware.Windows.Controls.Charts Namespace


InvalidAxisException Constructor (String)

Initializes a new instance of the Exception class with a specified error message.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidAxisException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InvalidAxisException Class
InvalidAxisException Overload
ActiproSoftware.Windows.Controls.Charts Namespace


InvalidAxisException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InvalidAxisException class with serialized data.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected InvalidAxisException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

InvalidAxisException Class
InvalidAxisException Overload
ActiproSoftware.Windows.Controls.Charts Namespace


InvalidAxisException Constructor (String, Exception)

Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidAxisException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
See Also

Reference

InvalidAxisException Class
InvalidAxisException Overload
ActiproSoftware.Windows.Controls.Charts Namespace


IPieSliceStyleSelector Interface

Provides the base requirements for a class that determines how a pie slice will be styled.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPieSliceStyleSelector
Public Interface IPieSliceStyleSelector

The IPieSliceStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. The Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. The Style must have TargetType of PieSlice.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


IPieSliceStyleSelector Methods

The IPieSliceStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. The Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. The Style must have TargetType of PieSlice.
Top
See Also

Reference

IPieSliceStyleSelector Interface
ActiproSoftware.Windows.Controls.Charts Namespace


IPieSliceStyleSelector.SelectChildPieSliceStyle Method

IPieSliceStyleSelectorSelectChildPieSliceStyle Method

Selects the child pie slice style. The Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Style SelectChildPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Color parentFill,
    Style defaultStyle
)
Function SelectChildPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    parentFill As Color,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
parentFill
Type: System.Windows.MediaColor
The parent fill color.
defaultStyle
Type: System.WindowsStyle
The default style.

Return Value

Type: Style
A Style for PieSlice.
See Also

Reference

IPieSliceStyleSelector Interface
ActiproSoftware.Windows.Controls.Charts Namespace


IPieSliceStyleSelector.SelectPieSliceStyle Method

IPieSliceStyleSelectorSelectPieSliceStyle Method

Selects the pie slice style. The Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Style SelectPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Style defaultStyle
)
Function SelectPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
defaultStyle
Type: System.WindowsStyle
The default style.

Return Value

Type: Style
A Style for PieSlice.
See Also

Reference

IPieSliceStyleSelector Interface
ActiproSoftware.Windows.Controls.Charts Namespace


ISeriesStyleSelector Interface

Provides the base requirements for a class that determines how a series will be styled.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISeriesStyleSelector
Public Interface ISeriesStyleSelector

The ISeriesStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the bar Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


ISeriesStyleSelector Methods

The ISeriesStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the bar Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.Windows.Controls.Charts Namespace


ISeriesStyleSelector.SelectAreaStyle Method

ISeriesStyleSelectorSelectAreaStyle Method

Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Style SelectAreaStyle(
    SeriesBase series,
    Style defaultStyle
)
Function SelectAreaStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.Windows.Controls.Charts Namespace


ISeriesStyleSelector.SelectBarStyle Method

ISeriesStyleSelectorSelectBarStyle Method

Returns the bar Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Style SelectBarStyle(
    SeriesBase series,
    int barIndex,
    int barCount,
    Style defaultStyle
)
Function SelectBarStyle (
    series As SeriesBase,
    barIndex As Integer,
    barCount As Integer,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
barIndex
Type: SystemInt32
The zero-based index of the bar.
barCount
Type: SystemInt32
The number of bars.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.Windows.Controls.Charts Namespace


ISeriesStyleSelector.SelectLegendMarkerStyle Method

ISeriesStyleSelectorSelectLegendMarkerStyle Method

Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Style SelectLegendMarkerStyle(
    XYSeriesBase series,
    Style defaultStyle
)
Function SelectLegendMarkerStyle (
    series As XYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.Windows.Controls.Charts Namespace


ISeriesStyleSelector.SelectLineStyle Method

ISeriesStyleSelectorSelectLineStyle Method

Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Style SelectLineStyle(
    SeriesBase series,
    Style defaultStyle
)
Function SelectLineStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.Windows.Controls.Charts Namespace


ISeriesStyleSelector.SelectMarkerStyle Method

ISeriesStyleSelectorSelectMarkerStyle Method

Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Style SelectMarkerStyle(
    SeriesBase series,
    Style defaultStyle
)
Function SelectMarkerStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.Windows.Controls.Charts Namespace


LabelCollisionMode Enumeration

Specifies how data point labels resolve collisions.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LabelCollisionMode
Public Enumeration LabelCollisionMode
Members
Member name | Value | Description
None | 0 | Indicates that data point labels will not attempt to resolve collision and can overlap.
Stacked | 1 | Indicates that overlapping data point labels will stack above or below each other, away from the baseline.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


LabelPositioningMode Enumeration

Specifies how data point labels are positioned.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LabelPositioningMode
Public Enumeration LabelPositioningMode
Members
Member name | Value | Description
FromBaseline | 0 | Indicates that data point labels will be positioned away from the baseline.
FromAverage | 1 | Indicates that data point labels will be positioned away from the average primary value of data points on the secondary axis.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


LabelVisibility Enumeration

Specifies the visibility of data point labels on the chart.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LabelVisibility
Public Enumeration LabelVisibility
Members
Member name | Value | Description
Hidden | 0 | Indicates that data point labels are not shown.
Visible | 1 | Indicates that data point labels are always visible.
PointerProximity | 2 | Indicates that data point labels near the mouse pointer are visible.
PointerAxis | 3 | Indicates that data point labels on the secondary axis value closest to the mouse pointer are visible.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


LegendHorizontalPosition Enumeration

Specifies the horizontal position of the legend in relation to its parent chart.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LegendHorizontalPosition
Public Enumeration LegendHorizontalPosition
Members
Member name | Value | Description
CenterOutside | 0 | Indicates that the legend will be centered horizontally in the chart control.
CenterInside | 1 | Indicates that the legend will be centered horizontally inside the drawing surface of the chart control.
LeftInside | 2 | Indicates that the legend will be placed to the left of the chart control.
LeftOutside | 3 | Indicates that the legend will be placed to the left of the drawing surface of the chart control.
RightInside | 4 | Indicates that the legend will be placed to the right of the chart control.
RightOutside | 5 | Indicates that the legend will be placed to the right of the drawing surface of the chart control.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


LegendKey Class

Describes a key shown in a legend.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.ChartsLegendKey

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LegendKey : ObservableObjectBase
Public Class LegendKey
    Inherits ObservableObjectBase

The LegendKey type exposes the following members.

Constructors
 | Name | Description
Public method | LegendKey | Initializes a new instance of the LegendKey class
Top
Properties
 | Name | Description
Public property | Label | Gets or sets the label.
Public property | LegendMarkerStyle | Gets or sets the legend marker style.
Top
Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


LegendKey Constructor

Initializes a new instance of the LegendKey class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LegendKey()
Public Sub New
See Also

Reference

LegendKey Class
ActiproSoftware.Windows.Controls.Charts Namespace


LegendKey Properties

The LegendKey type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets or sets the label.
Public property | LegendMarkerStyle | Gets or sets the legend marker style.
Top
See Also

Reference

LegendKey Class
ActiproSoftware.Windows.Controls.Charts Namespace


LegendKey.Label Property

LegendKeyLabel Property

Gets or sets the label.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set

Property Value

Type: String
The label.
See Also

Reference

LegendKey Class
ActiproSoftware.Windows.Controls.Charts Namespace


LegendKey.LegendMarkerStyle Property

LegendKeyLegendMarkerStyle Property

Gets or sets the legend marker style.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LegendMarkerStyle { get; set; }
Public Property LegendMarkerStyle As Style
    Get
    Set

Property Value

Type: Style
The legend marker style.
See Also

Reference

LegendKey Class
ActiproSoftware.Windows.Controls.Charts Namespace


LegendKey Methods

The LegendKey type exposes the following members.

Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

LegendKey Class
ActiproSoftware.Windows.Controls.Charts Namespace


LegendKey Events

The LegendKey type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

LegendKey Class
ActiproSoftware.Windows.Controls.Charts Namespace


LegendVerticalPosition Enumeration

Specifies the vertical position of the legend in relation to its parent chart.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LegendVerticalPosition
Public Enumeration LegendVerticalPosition
Members
Member name | Value | Description
CenterOutside | 0 | Indicates that the legend will be centered vertically in the chart control.
CenterInside | 1 | Indicates that the legend will be centered vertically inside the drawing surface of the chart control.
TopOutside | 2 | Indicates that the legend will be placed to the top of the chart control.
TopInside | 3 | Indicates that the legend will be placed to the top of the drawing surface of the chart control.
BottomOutside | 4 | Indicates that the legend will be placed to the bottom of the chart control.
BottomInside | 5 | Indicates that the legend will be placed to the bottom of the drawing surface of the chart control.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


LineSeries Class

Represents a line series for use in a XYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesLineSeriesBase
ActiproSoftware.Windows.Controls.ChartsLineSeries

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LineSeries : LineSeriesBase
Public Class LineSeries
    Inherits LineSeriesBase

The LineSeries type exposes the following members.

Constructors
 | Name | Description
Public method | LineSeries | Initializes a new instance of the LineSeries class.
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Inherited from LineSeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from LineSeriesBase.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from LineSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


LineSeries Constructor

Initializes a new instance of the LineSeries class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LineSeries()
Public Sub New
See Also

Reference

LineSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


LineSeries Properties

The LineSeries type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Inherited from LineSeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from LineSeriesBase.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from LineSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

LineSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


LineSeries Methods

The LineSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LineSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


LineSeries Events

The LineSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
See Also

Reference

LineSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


LineSeriesVisibility Enumeration

Specifies the visibility of the various kinds of a line.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LineSeriesVisibility
Public Enumeration LineSeriesVisibility
Members
Member name | Value | Description
None | 0 | Indicates that no lines will be visible.
Positive | 1 | Indicates that positive lines will be visible.
Negative | 2 | Indicates that negative lines will be visible.
All | 3 | Indicates that all markers will be visible.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


NonNumericValueException Class

An exception for when a non-numeric value is provided.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.Windows.Controls.ChartsNonNumericValueException

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
[SerializableAttribute]
public class NonNumericValueException : Exception
<SerializableAttribute>
Public Class NonNumericValueException
    Inherits Exception
Constructors
 | Name | Description
Public method | NonNumericValueException | Initializes a new instance of the NonNumericValueException class.
Public method | NonNumericValueException(String) | Initializes a new instance of the Exception class with a specified error message.
Protected method | NonNumericValueException(SerializationInfo, StreamingContext) | Initializes a new instance of the NonNumericValueException class with serialized data.
Public method | NonNumericValueException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


NonNumericValueException Constructor

Overload List
 | Name | Description
Public method | NonNumericValueException | Initializes a new instance of the NonNumericValueException class.
Public method | NonNumericValueException(String) | Initializes a new instance of the Exception class with a specified error message.
Protected method | NonNumericValueException(SerializationInfo, StreamingContext) | Initializes a new instance of the NonNumericValueException class with serialized data.
Public method | NonNumericValueException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

NonNumericValueException Class
ActiproSoftware.Windows.Controls.Charts Namespace


NonNumericValueException Constructor

Initializes a new instance of the NonNumericValueException class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NonNumericValueException()
Public Sub New
See Also

Reference

NonNumericValueException Class
NonNumericValueException Overload
ActiproSoftware.Windows.Controls.Charts Namespace


NonNumericValueException Constructor (String)

Initializes a new instance of the Exception class with a specified error message.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NonNumericValueException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

NonNumericValueException Class
NonNumericValueException Overload
ActiproSoftware.Windows.Controls.Charts Namespace


NonNumericValueException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the NonNumericValueException class with serialized data.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected NonNumericValueException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

NonNumericValueException Class
NonNumericValueException Overload
ActiproSoftware.Windows.Controls.Charts Namespace


NonNumericValueException Constructor (String, Exception)

Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NonNumericValueException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
See Also

Reference

NonNumericValueException Class
NonNumericValueException Overload
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart Class

A control that displays a pie chart based on given data.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ChartsPieChart
ActiproSoftware.Windows.Controls.ChartsDonutChart

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PieChart : Control
Public Class PieChart
    Inherits Control

The PieChart type exposes the following members.

Constructors
 | Name | Description
Public method | PieChart | Initializes a new instance of the PieChart class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | DrawingSurfaceSize | Gets or sets the size of the drawing surface.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position.
Public property | LegendMargin | Gets or sets the legend margin.
Public property | LegendStyle | Gets or sets the legend style. Must have a TargetType of Legend.
Public property | LegendVerticalPosition | Gets or sets the legend vertical position.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Series | Gets the series.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TetherBrush | Gets or sets the brush used to draw label tethers. Remarks If TetherBrush is not set, then Foreground will be used instead.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Refreshes this instance.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendMarginProperty | Identifies the LegendMargin dependency property. This field is read-only.
LegendStyleProperty | Identifies the LegendStyle dependency property. This field is read-only.
LegendVerticalPositionProperty | Identifies the LegendVerticalPosition dependency property. This field is read-only.
TetherBrushProperty | Identifies the TetherBrush dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


PieChart Constructor

Initializes a new instance of the PieChart class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieChart()
Public Sub New
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart Properties

The PieChart type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | DrawingSurfaceSize | Gets or sets the size of the drawing surface.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position.
Public property | LegendMargin | Gets or sets the legend margin.
Public property | LegendStyle | Gets or sets the legend style. Must have a TargetType of Legend.
Public property | LegendVerticalPosition | Gets or sets the legend vertical position.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Series | Gets the series.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TetherBrush | Gets or sets the brush used to draw label tethers. Remarks If TetherBrush is not set, then Foreground will be used instead.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.DrawingSurfaceSize Property

PieChartDrawingSurfaceSize Property

Gets or sets the size of the drawing surface.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Size DrawingSurfaceSize { get; }
Protected ReadOnly Property DrawingSurfaceSize As Size
    Get

Return Value

Type: Size
Size.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.IsLegendVisible Property

PieChartIsLegendVisible Property

Gets or sets a value indicating whether this instance is legend visible.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsLegendVisible { get; set; }
Public Property IsLegendVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is legend visible; otherwise, false.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.LegendHorizontalPosition Property

PieChartLegendHorizontalPosition Property

Gets or sets the legend horizontal position.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LegendHorizontalPosition LegendHorizontalPosition { get; set; }
Public Property LegendHorizontalPosition As LegendHorizontalPosition
    Get
    Set

Property Value

Type: LegendHorizontalPosition
The legend horizontal position.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.LegendMargin Property

PieChartLegendMargin Property

Gets or sets the legend margin.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness LegendMargin { get; set; }
Public Property LegendMargin As Thickness
    Get
    Set

Property Value

Type: Thickness
The legend margin.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.LegendStyle Property

PieChartLegendStyle Property

Gets or sets the legend style. Must have a TargetType of Legend.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LegendStyle { get; set; }
Public Property LegendStyle As Style
    Get
    Set

Property Value

Type: Style
The legend style.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.LegendVerticalPosition Property

PieChartLegendVerticalPosition Property

Gets or sets the legend vertical position.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LegendVerticalPosition LegendVerticalPosition { get; set; }
Public Property LegendVerticalPosition As LegendVerticalPosition
    Get
    Set

Property Value

Type: LegendVerticalPosition
The legend vertical position.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.Series Property

PieChartSeries Property

Gets the series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<PieSeries> Series { get; }
Public ReadOnly Property Series As ObservableCollection(Of PieSeries)
    Get

Property Value

Type: ObservableCollection PieSeries
The series.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.TetherBrush Property

PieChartTetherBrush Property

Gets or sets the brush used to draw label tethers.
Remarks
If TetherBrush is not set, then Foreground will be used instead.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TetherBrush { get; set; }
Public Property TetherBrush As Brush
    Get
    Set

Property Value

Type: Brush
The tether brush.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart Methods

The PieChart type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Refreshes this instance.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.MeasureOverride Method

PieChartMeasureOverride Method

Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this object can give to child objects. Infinity (PositiveInfinity) can be specified as a value to indicate that the object will size to whatever content is available.

Return Value

Type: Size
The size that this object determines it needs during layout, based on its calculations of the allocated sizes for child objects; or based on other considerations, such as a fixed container size.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.OnApplyTemplate Method

PieChartOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.Refresh Method

PieChartRefresh Method

Refreshes this instance.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart Events

The PieChart type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart Fields

The PieChart type exposes the following members.

Fields
Name | Description
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendMarginProperty | Identifies the LegendMargin dependency property. This field is read-only.
LegendStyleProperty | Identifies the LegendStyle dependency property. This field is read-only.
LegendVerticalPositionProperty | Identifies the LegendVerticalPosition dependency property. This field is read-only.
TetherBrushProperty | Identifies the TetherBrush dependency property. This field is read-only.
Top
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.IsLegendVisibleProperty Field

PieChartIsLegendVisibleProperty Field

Identifies the IsLegendVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLegendVisibleProperty
Public Shared ReadOnly IsLegendVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLegendVisible dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.LegendHorizontalPositionProperty Field

PieChartLegendHorizontalPositionProperty Field

Identifies the LegendHorizontalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendHorizontalPositionProperty
Public Shared ReadOnly LegendHorizontalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendHorizontalPosition dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.LegendMarginProperty Field

PieChartLegendMarginProperty Field

Identifies the LegendMargin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendMarginProperty
Public Shared ReadOnly LegendMarginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendMargin dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.LegendStyleProperty Field

PieChartLegendStyleProperty Field

Identifies the LegendStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStyleProperty
Public Shared ReadOnly LegendStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStyle dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.LegendVerticalPositionProperty Field

PieChartLegendVerticalPositionProperty Field

Identifies the LegendVerticalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendVerticalPositionProperty
Public Shared ReadOnly LegendVerticalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendVerticalPosition dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieChart.TetherBrushProperty Field

PieChartTetherBrushProperty Field

Identifies the TetherBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TetherBrushProperty
Public Shared ReadOnly TetherBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TetherBrush dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries Class

Represents a pie series for use in a PieChart or DonutChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ChartsPieSeries

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PieSeries : Control
Public Class PieSeries
    Inherits Control

The PieSeries type exposes the following members.

Constructors
 | Name | Description
Public method | PieSeries | Initializes a new instance of the PieSeries class
Top
Properties
 | Name | Description
Public property | AreChildLabelsVisible | Gets or sets a value indicating whether child labels are visible or not.
Public property | AreChildrenVisibleInLegend | Gets or sets a value indicating whether children are visible in the legend or not.
Public property | AreLabelsVisible | Gets or sets a value indicating whether labels are visible or not.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ChildLabelBrush | Gets or sets the brush used for child pie slice labels.
Public property | ChildLabelPosition | Gets or sets the child label position.
Public property | ChildLabelStyle | Gets or sets the style applied to child pie slice labels. Style should have TargetType of TextBlock.
Public property | ChildrenLength | Gets or sets the length of the children.
Public property | ChildrenPath | Gets or sets the children path.
Public property | ChildrenPosition | Gets or sets the children position.
Public property | ChildSliceLabelFormat | Gets or sets the child slice label format.
Public property | ChildSliceLabelFunc | Gets or sets the child slice label func.
Public property | ChildSliceTitlePath | Gets or sets the child slice title path.
Public property | ChildSliceToolTipFormat | Gets or sets the child slice tooltip format.
Public property | ChildSliceToolTipFunc | Gets or sets the child slice tooltip func.
Public property | ChildSliceValuePath | Gets or sets the child slice value path.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOtherThresholdPercent | Gets or sets a value indicating whether this instance is other threshold percent.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisibleInLegend | Gets or sets a value indicating whether this instance is visible in legend.
Public property | ItemsSource | Gets or sets the items source.
Public property | LabelBrush | Gets or sets the brush used for labels.
Public property | LabelInsideFitMode | Gets or sets the label inside fit mode.
Public property | LabelPosition | Gets or sets the label position.
Public property | LabelStyle | Gets or sets the style applied to pie slice labels. Style should have TargetType of TextBlock.
Public property | Length | Gets or sets the size of pie series in relation to the other pie series.
Public property | OtherThreshold | Gets or sets the threshold for the "Other" slice.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SliceLabelFormat | Gets or sets the slice label format.
Public property | SliceLabelFunc | Gets or sets the slice label func.
Public property | SliceStyleSelector | Gets or sets the slice style selector, which determines the style used for each pie slice.
Public property | SliceTitlePath | Gets or sets the slice title path.
Public property | SliceToolTipFormat | Gets or sets the slice tooltip format.
Public property | SliceToolTipFunc | Gets or sets the slice tooltip func.
Public property | SliceValuePath | Gets or sets the slice value path.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | FireRefresh | Fires the Refresh event.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refresh | Occurs when a property on pie series is changed that requires the pie chart to be refreshed.
Top
Fields
Name | Description
AreChildLabelsVisibleProperty | Identifies the AreChildLabelsVisible dependency property. This field is read-only.
AreChildrenVisibleInLegendProperty | Identifies the AreChildrenVisibleInLegend dependency property. This field is read-only.
AreLabelsVisibleProperty | Identifies the AreLabelsVisible dependency property. This field is read-only.
ChildLabelBrushProperty | Identifies the ChildLabelBrush dependency property. This field is read-only.
ChildLabelPositionProperty | Identifies the ChildLabelPosition dependency property. This field is read-only.
ChildLabelStyleProperty | Identifies the ChildLabelStyle dependency property. This field is read-only.
ChildLengthProperty | Identifies the ChildrenLength dependency property. This field is read-only.
ChildPositionProperty | Identifies the ChildrenPosition dependency property. This field is read-only.
ChildrenPathProperty | Identifies the ChildrenPath dependency property. This field is read-only.
ChildSliceLabelFormatProperty | Identifies the ChildSliceLabelFormat dependency property. This field is read-only.
ChildSliceLabelFuncProperty | Identifies the ChildSliceLabelFunc dependency property. This field is read-only.
ChildSliceTitlePathProperty | Identifies the ChildSliceTitlePath dependency property. This field is read-only.
ChildSliceToolTipFormatProperty | Identifies the ChildSliceToolTipFormat dependency property. This field is read-only.
ChildSliceToolTipFuncProperty | Identifies the ChildSliceToolTipFunc dependency property. This field is read-only.
ChildValuePathProperty | Identifies the ChildSliceValuePath dependency property. This field is read-only.
IsOtherThresholdPercentProperty | Identifies the IsOtherThresholdPercent dependency property. This field is read-only.
IsVisibleInLegendProperty | Identifies the IsVisibleInLegend dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
LabelBrushProperty | Identifies the LabelBrush dependency property. This field is read-only.
LabelInsideFitModeProperty | Identifies the LabelInsideFitMode dependency property. This field is read-only.
LabelPositionProperty | Identifies the LabelPosition dependency property. This field is read-only.
LabelStyleProperty | Identifies the LabelStyle dependency property. This field is read-only.
LengthProperty | Identifies the Length dependency property. This field is read-only.
OtherThresholdProperty | Identifies the OtherThreshold dependency property. This field is read-only.
SliceLabelFormatProperty | Identifies the SliceLabelFormat dependency property. This field is read-only.
SliceLabelFuncProperty | Identifies the SliceLabelFunc dependency property. This field is read-only.
SliceStyleSelectorProperty | Identifies the SliceStyleSelector dependency property. This field is read-only.
SliceTitlePathProperty | Identifies the SliceTitlePath dependency property. This field is read-only.
SliceToolTipFormatProperty | Identifies the SliceToolTipFormat dependency property. This field is read-only.
SliceToolTipFuncProperty | Identifies the SliceToolTipFunc dependency property. This field is read-only.
SliceValuePathProperty | Identifies the SliceValuePath dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries Constructor

Initializes a new instance of the PieSeries class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSeries()
Public Sub New
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries Properties

The PieSeries type exposes the following members.

Properties
 | Name | Description
Public property | AreChildLabelsVisible | Gets or sets a value indicating whether child labels are visible or not.
Public property | AreChildrenVisibleInLegend | Gets or sets a value indicating whether children are visible in the legend or not.
Public property | AreLabelsVisible | Gets or sets a value indicating whether labels are visible or not.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ChildLabelBrush | Gets or sets the brush used for child pie slice labels.
Public property | ChildLabelPosition | Gets or sets the child label position.
Public property | ChildLabelStyle | Gets or sets the style applied to child pie slice labels. Style should have TargetType of TextBlock.
Public property | ChildrenLength | Gets or sets the length of the children.
Public property | ChildrenPath | Gets or sets the children path.
Public property | ChildrenPosition | Gets or sets the children position.
Public property | ChildSliceLabelFormat | Gets or sets the child slice label format.
Public property | ChildSliceLabelFunc | Gets or sets the child slice label func.
Public property | ChildSliceTitlePath | Gets or sets the child slice title path.
Public property | ChildSliceToolTipFormat | Gets or sets the child slice tooltip format.
Public property | ChildSliceToolTipFunc | Gets or sets the child slice tooltip func.
Public property | ChildSliceValuePath | Gets or sets the child slice value path.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOtherThresholdPercent | Gets or sets a value indicating whether this instance is other threshold percent.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisibleInLegend | Gets or sets a value indicating whether this instance is visible in legend.
Public property | ItemsSource | Gets or sets the items source.
Public property | LabelBrush | Gets or sets the brush used for labels.
Public property | LabelInsideFitMode | Gets or sets the label inside fit mode.
Public property | LabelPosition | Gets or sets the label position.
Public property | LabelStyle | Gets or sets the style applied to pie slice labels. Style should have TargetType of TextBlock.
Public property | Length | Gets or sets the size of pie series in relation to the other pie series.
Public property | OtherThreshold | Gets or sets the threshold for the "Other" slice.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SliceLabelFormat | Gets or sets the slice label format.
Public property | SliceLabelFunc | Gets or sets the slice label func.
Public property | SliceStyleSelector | Gets or sets the slice style selector, which determines the style used for each pie slice.
Public property | SliceTitlePath | Gets or sets the slice title path.
Public property | SliceToolTipFormat | Gets or sets the slice tooltip format.
Public property | SliceToolTipFunc | Gets or sets the slice tooltip func.
Public property | SliceValuePath | Gets or sets the slice value path.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.AreChildLabelsVisible Property

PieSeriesAreChildLabelsVisible Property

Gets or sets a value indicating whether child labels are visible or not.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreChildLabelsVisible { get; set; }
Public Property AreChildLabelsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if child labels are visible; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.AreChildrenVisibleInLegend Property

PieSeriesAreChildrenVisibleInLegend Property

Gets or sets a value indicating whether children are visible in the legend or not.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreChildrenVisibleInLegend { get; set; }
Public Property AreChildrenVisibleInLegend As Boolean
    Get
    Set

Property Value

Type: Boolean
true if children are visible in the legend; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.AreLabelsVisible Property

PieSeriesAreLabelsVisible Property

Gets or sets a value indicating whether labels are visible or not.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreLabelsVisible { get; set; }
Public Property AreLabelsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if labels are visible; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildLabelBrush Property

PieSeriesChildLabelBrush Property

Gets or sets the brush used for child pie slice labels.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ChildLabelBrush { get; set; }
Public Property ChildLabelBrush As Brush
    Get
    Set

Property Value

Type: Brush
The child label brush.
Remarks
If ChildLabelBrush is not set, then LabelBrush will be used, or Foreground if neither are set.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildLabelPosition Property

PieSeriesChildLabelPosition Property

Gets or sets the child label position.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSliceLabelPosition ChildLabelPosition { get; set; }
Public Property ChildLabelPosition As PieSliceLabelPosition
    Get
    Set

Property Value

Type: PieSliceLabelPosition
The child label position.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildLabelStyle Property

PieSeriesChildLabelStyle Property

Gets or sets the style applied to child pie slice labels. Style should have TargetType of TextBlock.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ChildLabelStyle { get; set; }
Public Property ChildLabelStyle As Style
    Get
    Set

Property Value

Type: Style
The label style.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildrenLength Property

PieSeriesChildrenLength Property

Gets or sets the length of the children.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ChildrenLength { get; set; }
Public Property ChildrenLength As Double
    Get
    Set

Property Value

Type: Double
The length of the children.
Remarks
Length is the size of children in relation to the other pie series.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildrenPath Property

PieSeriesChildrenPath Property

Gets or sets the children path.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ChildrenPath { get; set; }
Public Property ChildrenPath As String
    Get
    Set

Property Value

Type: String
The children path.
Remarks
This is a path to a property on a value in ItemsSource that is an IEnumerable containing child data.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildrenPosition Property

PieSeriesChildrenPosition Property

Gets or sets the children position.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSeriesChildPosition ChildrenPosition { get; set; }
Public Property ChildrenPosition As PieSeriesChildPosition
    Get
    Set

Property Value

Type: PieSeriesChildPosition
The children position.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceLabelFormat Property

PieSeriesChildSliceLabelFormat Property

Gets or sets the child slice label format.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ChildSliceLabelFormat { get; set; }
Public Property ChildSliceLabelFormat As String
    Get
    Set

Property Value

Type: String
The child slice label format.
Remarks
This property is ignored if ChildSliceLabelFunc is specified. The label format has three parameters: {0} is the percentage of the child pie slice. {1} is the original value of the child pie slice. {2} is the title of the child pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceLabelFunc Property

PieSeriesChildSliceLabelFunc Property

Gets or sets the child slice label func.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<double, Object, string, string> ChildSliceLabelFunc { get; set; }
Public Property ChildSliceLabelFunc As Func(Of Double, Object, String, String)
    Get
    Set

Property Value

Type: Func Double, Object, String, String
The child slice label func.
Remarks
This is a custom function that takes the pie slice percentage, original value, and title as parameters and returns the label of your choice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceTitlePath Property

PieSeriesChildSliceTitlePath Property

Gets or sets the child slice title path.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ChildSliceTitlePath { get; set; }
Public Property ChildSliceTitlePath As String
    Get
    Set

Property Value

Type: String
The child slice title path.
Remarks
This is a path to a property on a value of child items that represents the title of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceToolTipFormat Property

PieSeriesChildSliceToolTipFormat Property

Gets or sets the child slice tooltip format.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ChildSliceToolTipFormat { get; set; }
Public Property ChildSliceToolTipFormat As String
    Get
    Set

Property Value

Type: String
The child slice tooltip format.
Remarks
This property is ignored if ChildSliceToolTipFunc is specified. The tooltip format has three parameters: {0} is the percentage of the child pie slice. {1} is the original value of the child pie slice. {2} is the title of the child pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceToolTipFunc Property

PieSeriesChildSliceToolTipFunc Property

Gets or sets the child slice tooltip func.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<double, Object, string, string> ChildSliceToolTipFunc { get; set; }
Public Property ChildSliceToolTipFunc As Func(Of Double, Object, String, String)
    Get
    Set

Property Value

Type: Func Double, Object, String, String
The child slice tooltip func.
Remarks
This is a custom function that takes the pie slice percentage, original value, and title as parameters and returns the tooltip of your choice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceValuePath Property

PieSeriesChildSliceValuePath Property

Gets or sets the child slice value path.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ChildSliceValuePath { get; set; }
Public Property ChildSliceValuePath As String
    Get
    Set

Property Value

Type: String
The child slice value path.
Remarks
This is a path to a property on a value of child items that represents the value of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.IsOtherThresholdPercent Property

PieSeriesIsOtherThresholdPercent Property

Gets or sets a value indicating whether this instance is other threshold percent.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOtherThresholdPercent { get; set; }
Public Property IsOtherThresholdPercent As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is other threshold percent; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.IsVisibleInLegend Property

PieSeriesIsVisibleInLegend Property

Gets or sets a value indicating whether this instance is visible in legend.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsVisibleInLegend { get; set; }
Public Property IsVisibleInLegend As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is visible in legend; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ItemsSource Property

PieSeriesItemsSource Property

Gets or sets the items source.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable ItemsSource { get; set; }
Public Property ItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
The items source.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.LabelBrush Property

PieSeriesLabelBrush Property

Gets or sets the brush used for labels.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LabelBrush { get; set; }
Public Property LabelBrush As Brush
    Get
    Set

Property Value

Type: Brush
The label brush.
Remarks
If LabelBrush is not set, then Foreground will be used instead.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.LabelInsideFitMode Property

PieSeriesLabelInsideFitMode Property

Gets or sets the label inside fit mode.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSliceLabelInsideFitMode LabelInsideFitMode { get; set; }
Public Property LabelInsideFitMode As PieSliceLabelInsideFitMode
    Get
    Set

Property Value

Type: PieSliceLabelInsideFitMode
The label inside fit mode.
Remarks
This determines how the label reacts when it doesn't fit inside the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.LabelPosition Property

PieSeriesLabelPosition Property

Gets or sets the label position.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSliceLabelPosition LabelPosition { get; set; }
Public Property LabelPosition As PieSliceLabelPosition
    Get
    Set

Property Value

Type: PieSliceLabelPosition
The label position.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.LabelStyle Property

PieSeriesLabelStyle Property

Gets or sets the style applied to pie slice labels. Style should have TargetType of TextBlock.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LabelStyle { get; set; }
Public Property LabelStyle As Style
    Get
    Set

Property Value

Type: Style
The label style.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.Length Property

PieSeriesLength Property

Gets or sets the size of pie series in relation to the other pie series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Length { get; set; }
Public Property Length As Double
    Get
    Set

Property Value

Type: Double
The length.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.OtherThreshold Property

PieSeriesOtherThreshold Property

Gets or sets the threshold for the "Other" slice.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double OtherThreshold { get; set; }
Public Property OtherThreshold As Double
    Get
    Set

Property Value

Type: Double
The other threshold.
Remarks
If IsOtherThresholdPercent is true, then this value represents a percentage between 0.0 and 1.0. Otherwise, it represents a numerical value. All values beneath the other threshold will be aggregated into an "Other" pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceLabelFormat Property

PieSeriesSliceLabelFormat Property

Gets or sets the slice label format.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string SliceLabelFormat { get; set; }
Public Property SliceLabelFormat As String
    Get
    Set

Property Value

Type: String
The slice label format.
Remarks
This property is ignored if SliceLabelFunc is specified. The label format has three parameters: {0} is the percentage of the pie slice. {1} is the original value of the pie slice. {2} is the title of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceLabelFunc Property

PieSeriesSliceLabelFunc Property

Gets or sets the slice label func.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<double, Object, string, string> SliceLabelFunc { get; set; }
Public Property SliceLabelFunc As Func(Of Double, Object, String, String)
    Get
    Set

Property Value

Type: Func Double, Object, String, String
The slice label func.
Remarks
This is a custom function that takes the pie slice percentage, original value, and title as parameters and returns the label of your choice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceStyleSelector Property

PieSeriesSliceStyleSelector Property

Gets or sets the slice style selector, which determines the style used for each pie slice.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IPieSliceStyleSelector SliceStyleSelector { get; set; }
Public Property SliceStyleSelector As IPieSliceStyleSelector
    Get
    Set

Property Value

Type: IPieSliceStyleSelector
The slice style selector.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceTitlePath Property

PieSeriesSliceTitlePath Property

Gets or sets the slice title path.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string SliceTitlePath { get; set; }
Public Property SliceTitlePath As String
    Get
    Set

Property Value

Type: String
The slice title path.
Remarks
This is a path to a property on a value in ItemsSource that represents the value of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceToolTipFormat Property

PieSeriesSliceToolTipFormat Property

Gets or sets the slice tooltip format.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string SliceToolTipFormat { get; set; }
Public Property SliceToolTipFormat As String
    Get
    Set

Property Value

Type: String
The slice tooltip format.
Remarks
This property is ignored if SliceToolTipFunc is specified. The tooltip format has three parameters: {0} is the percentage of the pie slice. {1} is the original value of the pie slice. {2} is the title of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceToolTipFunc Property

PieSeriesSliceToolTipFunc Property

Gets or sets the slice tooltip func.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<double, Object, string, string> SliceToolTipFunc { get; set; }
Public Property SliceToolTipFunc As Func(Of Double, Object, String, String)
    Get
    Set

Property Value

Type: Func Double, Object, String, String
The slice tooltip func.
Remarks
This is a custom function that takes the pie slice percentage, original value, and title as parameters and returns the tooltip of your choice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceValuePath Property

PieSeriesSliceValuePath Property

Gets or sets the slice value path.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string SliceValuePath { get; set; }
Public Property SliceValuePath As String
    Get
    Set

Property Value

Type: String
The slice value path.
Remarks
This is a path to a property on a value in ItemsSource that represents the value of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries Methods

The PieSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | FireRefresh | Fires the Refresh event.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.FireRefresh Method

PieSeriesFireRefresh Method

Fires the Refresh event.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void FireRefresh()
Protected Sub FireRefresh
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries Events

The PieSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refresh | Occurs when a property on pie series is changed that requires the pie chart to be refreshed.
Top
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.Refresh Event

PieSeriesRefresh Event

Occurs when a property on pie series is changed that requires the pie chart to be refreshed.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler Refresh
Public Event Refresh As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries Fields

The PieSeries type exposes the following members.

Fields
Name | Description
AreChildLabelsVisibleProperty | Identifies the AreChildLabelsVisible dependency property. This field is read-only.
AreChildrenVisibleInLegendProperty | Identifies the AreChildrenVisibleInLegend dependency property. This field is read-only.
AreLabelsVisibleProperty | Identifies the AreLabelsVisible dependency property. This field is read-only.
ChildLabelBrushProperty | Identifies the ChildLabelBrush dependency property. This field is read-only.
ChildLabelPositionProperty | Identifies the ChildLabelPosition dependency property. This field is read-only.
ChildLabelStyleProperty | Identifies the ChildLabelStyle dependency property. This field is read-only.
ChildLengthProperty | Identifies the ChildrenLength dependency property. This field is read-only.
ChildPositionProperty | Identifies the ChildrenPosition dependency property. This field is read-only.
ChildrenPathProperty | Identifies the ChildrenPath dependency property. This field is read-only.
ChildSliceLabelFormatProperty | Identifies the ChildSliceLabelFormat dependency property. This field is read-only.
ChildSliceLabelFuncProperty | Identifies the ChildSliceLabelFunc dependency property. This field is read-only.
ChildSliceTitlePathProperty | Identifies the ChildSliceTitlePath dependency property. This field is read-only.
ChildSliceToolTipFormatProperty | Identifies the ChildSliceToolTipFormat dependency property. This field is read-only.
ChildSliceToolTipFuncProperty | Identifies the ChildSliceToolTipFunc dependency property. This field is read-only.
ChildValuePathProperty | Identifies the ChildSliceValuePath dependency property. This field is read-only.
IsOtherThresholdPercentProperty | Identifies the IsOtherThresholdPercent dependency property. This field is read-only.
IsVisibleInLegendProperty | Identifies the IsVisibleInLegend dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
LabelBrushProperty | Identifies the LabelBrush dependency property. This field is read-only.
LabelInsideFitModeProperty | Identifies the LabelInsideFitMode dependency property. This field is read-only.
LabelPositionProperty | Identifies the LabelPosition dependency property. This field is read-only.
LabelStyleProperty | Identifies the LabelStyle dependency property. This field is read-only.
LengthProperty | Identifies the Length dependency property. This field is read-only.
OtherThresholdProperty | Identifies the OtherThreshold dependency property. This field is read-only.
SliceLabelFormatProperty | Identifies the SliceLabelFormat dependency property. This field is read-only.
SliceLabelFuncProperty | Identifies the SliceLabelFunc dependency property. This field is read-only.
SliceStyleSelectorProperty | Identifies the SliceStyleSelector dependency property. This field is read-only.
SliceTitlePathProperty | Identifies the SliceTitlePath dependency property. This field is read-only.
SliceToolTipFormatProperty | Identifies the SliceToolTipFormat dependency property. This field is read-only.
SliceToolTipFuncProperty | Identifies the SliceToolTipFunc dependency property. This field is read-only.
SliceValuePathProperty | Identifies the SliceValuePath dependency property. This field is read-only.
Top
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.AreChildLabelsVisibleProperty Field

PieSeriesAreChildLabelsVisibleProperty Field

Identifies the AreChildLabelsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreChildLabelsVisibleProperty
Public Shared ReadOnly AreChildLabelsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreChildLabelsVisible dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.AreChildrenVisibleInLegendProperty Field

PieSeriesAreChildrenVisibleInLegendProperty Field

Identifies the AreChildrenVisibleInLegend dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreChildrenVisibleInLegendProperty
Public Shared ReadOnly AreChildrenVisibleInLegendProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreChildrenVisibleInLegend dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.AreLabelsVisibleProperty Field

PieSeriesAreLabelsVisibleProperty Field

Identifies the AreLabelsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreLabelsVisibleProperty
Public Shared ReadOnly AreLabelsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreLabelsVisible dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildLabelBrushProperty Field

PieSeriesChildLabelBrushProperty Field

Identifies the ChildLabelBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildLabelBrushProperty
Public Shared ReadOnly ChildLabelBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildLabelBrush dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildLabelPositionProperty Field

PieSeriesChildLabelPositionProperty Field

Identifies the ChildLabelPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildLabelPositionProperty
Public Shared ReadOnly ChildLabelPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildLabelPosition dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildLabelStyleProperty Field

PieSeriesChildLabelStyleProperty Field

Identifies the ChildLabelStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildLabelStyleProperty
Public Shared ReadOnly ChildLabelStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildLabelStyle dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildLengthProperty Field

PieSeriesChildLengthProperty Field

Identifies the ChildrenLength dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildLengthProperty
Public Shared ReadOnly ChildLengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildrenLength dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildPositionProperty Field

PieSeriesChildPositionProperty Field

Identifies the ChildrenPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildPositionProperty
Public Shared ReadOnly ChildPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildrenPosition dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildrenPathProperty Field

PieSeriesChildrenPathProperty Field

Identifies the ChildrenPath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildrenPathProperty
Public Shared ReadOnly ChildrenPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildrenPath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceLabelFormatProperty Field

PieSeriesChildSliceLabelFormatProperty Field

Identifies the ChildSliceLabelFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildSliceLabelFormatProperty
Public Shared ReadOnly ChildSliceLabelFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceLabelFormat dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceLabelFuncProperty Field

PieSeriesChildSliceLabelFuncProperty Field

Identifies the ChildSliceLabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildSliceLabelFuncProperty
Public Shared ReadOnly ChildSliceLabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceLabelFunc dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceTitlePathProperty Field

PieSeriesChildSliceTitlePathProperty Field

Identifies the ChildSliceTitlePath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildSliceTitlePathProperty
Public Shared ReadOnly ChildSliceTitlePathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceTitlePath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceToolTipFormatProperty Field

PieSeriesChildSliceToolTipFormatProperty Field

Identifies the ChildSliceToolTipFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildSliceToolTipFormatProperty
Public Shared ReadOnly ChildSliceToolTipFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceToolTipFormat dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildSliceToolTipFuncProperty Field

PieSeriesChildSliceToolTipFuncProperty Field

Identifies the ChildSliceToolTipFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildSliceToolTipFuncProperty
Public Shared ReadOnly ChildSliceToolTipFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceToolTipFunc dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ChildValuePathProperty Field

PieSeriesChildValuePathProperty Field

Identifies the ChildSliceValuePath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildValuePathProperty
Public Shared ReadOnly ChildValuePathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceValuePath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.IsOtherThresholdPercentProperty Field

PieSeriesIsOtherThresholdPercentProperty Field

Identifies the IsOtherThresholdPercent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOtherThresholdPercentProperty
Public Shared ReadOnly IsOtherThresholdPercentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOtherThresholdPercent dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.IsVisibleInLegendProperty Field

PieSeriesIsVisibleInLegendProperty Field

Identifies the IsVisibleInLegend dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsVisibleInLegendProperty
Public Shared ReadOnly IsVisibleInLegendProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsVisibleInLegend dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.ItemsSourceProperty Field

PieSeriesItemsSourceProperty Field

Identifies the ItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemsSourceProperty
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemsSource dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.LabelBrushProperty Field

PieSeriesLabelBrushProperty Field

Identifies the LabelBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelBrushProperty
Public Shared ReadOnly LabelBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelBrush dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.LabelInsideFitModeProperty Field

PieSeriesLabelInsideFitModeProperty Field

Identifies the LabelInsideFitMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelInsideFitModeProperty
Public Shared ReadOnly LabelInsideFitModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelInsideFitMode dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.LabelPositionProperty Field

PieSeriesLabelPositionProperty Field

Identifies the LabelPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositionProperty
Public Shared ReadOnly LabelPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelPosition dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.LabelStyleProperty Field

PieSeriesLabelStyleProperty Field

Identifies the LabelStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelStyleProperty
Public Shared ReadOnly LabelStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelStyle dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.LengthProperty Field

PieSeriesLengthProperty Field

Identifies the Length dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LengthProperty
Public Shared ReadOnly LengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Length dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.OtherThresholdProperty Field

PieSeriesOtherThresholdProperty Field

Identifies the OtherThreshold dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OtherThresholdProperty
Public Shared ReadOnly OtherThresholdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OtherThreshold dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceLabelFormatProperty Field

PieSeriesSliceLabelFormatProperty Field

Identifies the SliceLabelFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceLabelFormatProperty
Public Shared ReadOnly SliceLabelFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceLabelFormat dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceLabelFuncProperty Field

PieSeriesSliceLabelFuncProperty Field

Identifies the SliceLabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceLabelFuncProperty
Public Shared ReadOnly SliceLabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceLabelFunc dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceStyleSelectorProperty Field

PieSeriesSliceStyleSelectorProperty Field

Identifies the SliceStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceStyleSelectorProperty
Public Shared ReadOnly SliceStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceStyleSelector dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceTitlePathProperty Field

PieSeriesSliceTitlePathProperty Field

Identifies the SliceTitlePath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceTitlePathProperty
Public Shared ReadOnly SliceTitlePathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceTitlePath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceToolTipFormatProperty Field

PieSeriesSliceToolTipFormatProperty Field

Identifies the SliceToolTipFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceToolTipFormatProperty
Public Shared ReadOnly SliceToolTipFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceToolTipFormat dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceToolTipFuncProperty Field

PieSeriesSliceToolTipFuncProperty Field

Identifies the SliceToolTipFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceToolTipFuncProperty
Public Shared ReadOnly SliceToolTipFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceToolTipFunc dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeries.SliceValuePathProperty Field

PieSeriesSliceValuePathProperty Field

Identifies the SliceValuePath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceValuePathProperty
Public Shared ReadOnly SliceValuePathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceValuePath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSeriesChildPosition Enumeration

The position of the child pie series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PieSeriesChildPosition
Public Enumeration PieSeriesChildPosition
Members
Member name | Value | Description
Inside | 0 | The child pie series will be positioned on the inside of the parent pie series.
Outside | 1 | The child pie series will be positioned on the outside of the parent pie series.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceLabelInsideFitMode Enumeration

Determines what happens if a label does not fit inside the pie slice.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PieSliceLabelInsideFitMode
Public Enumeration PieSliceLabelInsideFitMode
Members
Member name | Value | Description
None | 0 | The label will overlap the bounds of the pie slice.
Hide | 1 | The label will be automatically hidden.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceLabelPosition Enumeration

Determines where the pie slice labels are positioned.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PieSliceLabelPosition
Public Enumeration PieSliceLabelPosition
Members
Member name | Value | Description
Inside | 0 | Labels will be placed inside each pie slice.
Sides | 1 | Labels will be placed in a column on either side of the pie chart.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelector Class

A base class that selects a style for a given PieSlice.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.ChartsPieSliceStyleSelector

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PieSliceStyleSelector : IPieSliceStyleSelector
Public Class PieSliceStyleSelector
    Implements IPieSliceStyleSelector

The PieSliceStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PieSliceStyleSelector | Initializes a new instance of the PieSliceStyleSelector class
Top
Methods
 | Name | Description
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. Style must have TargetType of PieSlice.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelector Constructor

Initializes a new instance of the PieSliceStyleSelector class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSliceStyleSelector()
Public Sub New
See Also

Reference

PieSliceStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelector Methods

The PieSliceStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. Style must have TargetType of PieSlice.
Top
See Also

Reference

PieSliceStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelector.SelectChildPieSliceStyle Method

PieSliceStyleSelectorSelectChildPieSliceStyle Method

Selects the child pie slice style. Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectChildPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Color parentFill,
    Style defaultStyle
)
Public Overridable Function SelectChildPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    parentFill As Color,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
parentFill
Type: System.Windows.MediaColor
The parent fill color.
defaultStyle
Type: System.WindowsStyle
The default style.

Return Value

Type: Style
A Style for a PieSlice.

Implements

IPieSliceStyleSelectorSelectChildPieSliceStyle(Int32, Int32, Color, Style)
See Also

Reference

PieSliceStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelector.SelectPieSliceStyle Method

PieSliceStyleSelectorSelectPieSliceStyle Method

Selects the pie slice style. Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Style defaultStyle
)
Public Overridable Function SelectPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
defaultStyle
Type: System.WindowsStyle
The default style.

Return Value

Type: Style
A Style for a PieSlice.

Implements

IPieSliceStyleSelectorSelectPieSliceStyle(Int32, Int32, Style)
See Also

Reference

PieSliceStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelectorConverter Class

Represents a type converter for the SeriesStyleSelector type.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.Windows.Controls.ChartsPieSliceStyleSelectorConverter

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class PieSliceStyleSelectorConverter : TypeConverter
Public NotInheritable Class PieSliceStyleSelectorConverter
    Inherits TypeConverter

The PieSliceStyleSelectorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PieSliceStyleSelectorConverter | Initializes a new instance of the PieSliceStyleSelectorConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelectorConverter Constructor

Initializes a new instance of the PieSliceStyleSelectorConverter class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSliceStyleSelectorConverter()
Public Sub New
See Also

Reference

PieSliceStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelectorConverter Methods

The PieSliceStyleSelectorConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

PieSliceStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelectorConverter.CanConvertFrom Method

PieSliceStyleSelectorConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

PieSliceStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelectorConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

PieSliceStyleSelectorConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether the type converter can convert an object from the specified type to the type of this converter.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
sourceType
Type: SystemType
The type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

PieSliceStyleSelectorConverter Class
CanConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelectorConverter.ConvertFrom Method

PieSliceStyleSelectorConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

PieSliceStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


PieSliceStyleSelectorConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

PieSliceStyleSelectorConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts from the specified value to the intended conversion type of the converter.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The value to convert to the type of this converter.

Return Value

Type: Object
The converted value.
See Also

Reference

PieSliceStyleSelectorConverter Class
ConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts Namespace


ScatterSeries Class

Represents a scatter series for use in a XYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.Windows.Controls.ChartsScatterSeries

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ScatterSeries : XYSeriesBase
Public Class ScatterSeries
    Inherits XYSeriesBase

The ScatterSeries type exposes the following members.

Constructors
 | Name | Description
Public method | ScatterSeries | Initializes a new instance of the ScatterSeries class.
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


ScatterSeries Constructor

Initializes a new instance of the ScatterSeries class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ScatterSeries()
Public Sub New
See Also

Reference

ScatterSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


ScatterSeries Properties

The ScatterSeries type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

ScatterSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


ScatterSeries.MinimumMargin Property

ScatterSeriesMinimumMargin Property

Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> MinimumMargin { get; }
Protected Overrides ReadOnly Property MinimumMargin As Nullable(Of Thickness)
    Get

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

ScatterSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


ScatterSeries Methods

The ScatterSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ScatterSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


ScatterSeries Events

The ScatterSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
See Also

Reference

ScatterSeries Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelector Class

Provides a way to apply series styles based on custom logic.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.ChartsSeriesStyleSelector

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SeriesStyleSelector : ISeriesStyleSelector
Public Class SeriesStyleSelector
    Implements ISeriesStyleSelector

The SeriesStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesStyleSelector | Initializes a new instance of the SeriesStyleSelector class
Top
Methods
 | Name | Description
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the bar Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelector Constructor

Initializes a new instance of the SeriesStyleSelector class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesStyleSelector()
Public Sub New
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelector Methods

The SeriesStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the bar Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelector.SelectAreaStyle Method

SeriesStyleSelectorSelectAreaStyle Method

Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectAreaStyle(SeriesBase, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelector.SelectBarStyle Method

SeriesStyleSelectorSelectBarStyle Method

Returns the bar Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectBarStyle(
    SeriesBase series,
    int barIndex,
    int barCount,
    Style defaultStyle
)
Public Overridable Function SelectBarStyle (
    series As SeriesBase,
    barIndex As Integer,
    barCount As Integer,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
barIndex
Type: SystemInt32
The zero-based index of the bar.
barCount
Type: SystemInt32
The number of bars.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectBarStyle(SeriesBase, Int32, Int32, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelector.SelectLegendMarkerStyle Method

SeriesStyleSelectorSelectLegendMarkerStyle Method

Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectLegendMarkerStyle(
    XYSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLegendMarkerStyle (
    series As XYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectLegendMarkerStyle(XYSeriesBase, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelector.SelectLineStyle Method

SeriesStyleSelectorSelectLineStyle Method

Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectLineStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLineStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectLineStyle(SeriesBase, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelector.SelectMarkerStyle Method

SeriesStyleSelectorSelectMarkerStyle Method

Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectMarkerStyle(SeriesBase, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelectorConverter Class

Represents a type converter for the SeriesStyleSelector type.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.Windows.Controls.ChartsSeriesStyleSelectorConverter

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class SeriesStyleSelectorConverter : TypeConverter
Public NotInheritable Class SeriesStyleSelectorConverter
    Inherits TypeConverter

The SeriesStyleSelectorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesStyleSelectorConverter | Initializes a new instance of the SeriesStyleSelectorConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelectorConverter Constructor

Initializes a new instance of the SeriesStyleSelectorConverter class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesStyleSelectorConverter()
Public Sub New
See Also

Reference

SeriesStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelectorConverter Methods

The SeriesStyleSelectorConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

SeriesStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelectorConverter.CanConvertFrom Method

SeriesStyleSelectorConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

SeriesStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelectorConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

SeriesStyleSelectorConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether the type converter can convert an object from the specified type to the type of this converter.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
sourceType
Type: SystemType
The type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

SeriesStyleSelectorConverter Class
CanConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelectorConverter.ConvertFrom Method

SeriesStyleSelectorConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

SeriesStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


SeriesStyleSelectorConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

SeriesStyleSelectorConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts from the specified value to the intended conversion type of the converter.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The value to convert to the type of this converter.

Return Value

Type: Object
The converted value.
See Also

Reference

SeriesStyleSelectorConverter Class
ConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter Class

Converts TimeSpan to and from a String.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.Windows.Controls.ChartsTimeSpanConverter

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TimeSpanConverter : TypeConverter
Public Class TimeSpanConverter
    Inherits TypeConverter

The TimeSpanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSpanConverter | Initializes a new instance of the TimeSpanConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object to the specified type. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the specified value object to the specified type. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter Constructor

Initializes a new instance of the TimeSpanConverter class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpanConverter()
Public Sub New
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter Methods

The TimeSpanConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object to the specified type. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the specified value object to the specified type. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter.CanConvertFrom Method

TimeSpanConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

TimeSpanConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether the type converter can convert an object from the specified type to the type of this converter.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
sourceType
Type: SystemType
The type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

TimeSpanConverter Class
CanConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter.CanConvertTo Method

TimeSpanConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object to the specified type. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

TimeSpanConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Returns whether the type converter can convert an object to the specified type.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
destinationType
Type: SystemType
The type you want to convert to.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

TimeSpanConverter Class
CanConvertTo Overload
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter.ConvertFrom Method

TimeSpanConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

TimeSpanConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts from the specified value to the intended conversion type of the converter.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The value to convert to the type of this converter.

Return Value

Type: Object
The converted value.
See Also

Reference

TimeSpanConverter Class
ConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter.ConvertTo Method

TimeSpanConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the specified value object to the specified type. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.Windows.Controls.Charts Namespace


TimeSpanConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

TimeSpanConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the specified value object to the specified type.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The object to convert.
destinationType
Type: SystemType
The type to convert the object to.

Return Value

Type: Object
The converted object.
See Also

Reference

TimeSpanConverter Class
ConvertTo Overload
ActiproSoftware.Windows.Controls.Charts Namespace


TimeUnit Enumeration

Specifies a unit of time.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TimeUnit
Public Enumeration TimeUnit
Members
Member name | Value | Description
Millisecond | 0 | Indicates a millisecond time unit.
Second | 1 | Indicates a second time unit.
Minute | 2 | Indicates a minute time unit.
Hour | 3 | Indicates a hour time unit.
Day | 4 | Indicates a day time unit.
Month | 5 | Indicates a month time unit.
Week | 6 | Indicates a week time unit.
Year | 7 | Indicates a year time unit.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYAxisCollection Class

Represents a collection of XYAxisBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XYAxisBase
System.Collections.ObjectModelObservableCollection XYAxisBase
ActiproSoftware.WindowsDeferrableObservableCollection XYAxisBase
ActiproSoftware.Windows.Controls.ChartsDeferrableObservableItemCollection XYAxisBase
ActiproSoftware.Windows.Controls.ChartsXYAxisCollection

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYAxisCollection : DeferrableObservableItemCollection<XYAxisBase>
Public Class XYAxisCollection
    Inherits DeferrableObservableItemCollection(Of XYAxisBase)

The XYAxisCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XYAxisCollection | Initializes a new instance of the XYAxisCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XYAxisBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XYAxisBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XYAxisBase .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XYAxisBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XYAxisBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XYAxisBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XYAxisBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XYAxisBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XYAxisBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XYAxisBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XYAxisBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XYAxisBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYAxisBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYAxisBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XYAxisBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XYAxisBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XYAxisBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XYAxisBase .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYAxisCollection Constructor

Initializes a new instance of the XYAxisCollection class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYAxisCollection()
Public Sub New
See Also

Reference

XYAxisCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYAxisCollection Properties

The XYAxisCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XYAxisBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XYAxisBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XYAxisBase .)
Top
See Also

Reference

XYAxisCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYAxisCollection Methods

The XYAxisCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XYAxisBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XYAxisBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XYAxisBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XYAxisBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XYAxisBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XYAxisBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XYAxisBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XYAxisBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XYAxisBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYAxisBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYAxisBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XYAxisBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XYAxisBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

XYAxisCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYAxisCollection Events

The XYAxisCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XYAxisBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XYAxisBase .)
Top
See Also

Reference

XYAxisCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart Class

Represents a chart control that uses an X/Y coordinate system.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ChartsXYChart

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYChart : Control
Public Class XYChart
    Inherits Control

The XYChart type exposes the following members.

Constructors
 | Name | Description
Public method | XYChart | Initializes a new instance of the XYChart class.
Top
Properties
 | Name | Description
Public property | AxisBaselineStyle | Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GridLineMajorBrush | Gets or sets the grid line major brush.
Public property | GridLineMajorVisibility | Gets or sets the grid line major visibility.
Public property | GridLineMinorBrush | Gets or sets the grid line minor brush.
Public property | GridLineMinorVisibility | Gets or sets the grid line minor visibility.
Public property | GridStripeAlternatingBrush | Gets or sets the grid stripe alternating brush.
Public property | GridStripeBrush | Gets or sets the grid stripe brush.
Public property | GridStripeVisibility | Gets or sets the grid stripe visibility.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAxisBaselineVisible | Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.
Public property | IsLegendVisible | Gets or sets a value indicating whether the legend is visible. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelCollisionMode | Gets or sets the label collision mode.
Public property | LegendHorizontalPosition | Gets or sets the horizontal position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.
Public property | LegendKeys | Gets the collection of legend keys displayed in the legend.
Public property | LegendStyle | Gets or sets the Style applied to the legend. The Style must have a TargetType of ItemsControl.
Public property | LegendVerticalPosition | Gets or sets the vertical position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PaddingPercentage | The percentage of the chart size used for padding. Valid values are 0.0d (0%) to 1.0d (100%).
Public property | Series | Gets the collection of series displayed by this chart.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxes | Gets the collection of X axes displayed by this chart.
Public property | YAxes | Gets the collection of Y axes displayed by this chart.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of Silverlight layout. Classes can override this method to define their own Arrange pass behavior. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the UI Automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeave | Called before the mouse pointer exits the control. (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseMove | Called before the mouse pointer is moved. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
AxisBaselineStyleProperty | Identifies the AxisBaselineStyle dependency property. This field is read-only.
GridLineMajorBrushProperty | Identifies the GridLineMinorBrush dependency property. This field is read-only.
GridLineMajorVisibilityProperty | Identifies the GridLineMajorVisibility dependency property. This field is read-only.
GridLineMinorBrushProperty | Identifies the GridLineMinorBrush dependency property. This field is read-only.
GridLineMinorVisibilityProperty | Identifies the GridLineMinorVisibility dependency property. This field is read-only.
GridStripeAlternatingBrushProperty | Identifies the GridStripeAlternatingBrush dependency property. This field is read-only.
GridStripeBrushProperty | Identifies the GridStripeBrush dependency property. This field is read-only.
GridStripeVisibilityProperty | Identifies the GridStripeVisibility dependency property. This field is read-only.
IsAxisBaselineVisibleProperty | Identifies the IsAxisBaselineVisible dependency property. This field is read-only.
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LabelCollisionModeProperty | Identifies the LabelCollisionMode dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendStyleProperty | Identifies the LegendStyle dependency property. This field is read-only.
LegendVerticalPositionProperty | Identifies the LegendVerticalPosition dependency property. This field is read-only.
PaddingPercentageProperty | Identifies the PaddingPercentage dependency property. This field is read-only.
SeriesStyleSelectorProperty | Identifies the SeriesStyleSelector dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYChart Constructor

Initializes a new instance of the XYChart class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYChart()
Public Sub New
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart Properties

The XYChart type exposes the following members.

Properties
 | Name | Description
Public property | AxisBaselineStyle | Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GridLineMajorBrush | Gets or sets the grid line major brush.
Public property | GridLineMajorVisibility | Gets or sets the grid line major visibility.
Public property | GridLineMinorBrush | Gets or sets the grid line minor brush.
Public property | GridLineMinorVisibility | Gets or sets the grid line minor visibility.
Public property | GridStripeAlternatingBrush | Gets or sets the grid stripe alternating brush.
Public property | GridStripeBrush | Gets or sets the grid stripe brush.
Public property | GridStripeVisibility | Gets or sets the grid stripe visibility.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAxisBaselineVisible | Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.
Public property | IsLegendVisible | Gets or sets a value indicating whether the legend is visible. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelCollisionMode | Gets or sets the label collision mode.
Public property | LegendHorizontalPosition | Gets or sets the horizontal position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.
Public property | LegendKeys | Gets the collection of legend keys displayed in the legend.
Public property | LegendStyle | Gets or sets the Style applied to the legend. The Style must have a TargetType of ItemsControl.
Public property | LegendVerticalPosition | Gets or sets the vertical position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PaddingPercentage | The percentage of the chart size used for padding. Valid values are 0.0d (0%) to 1.0d (100%).
Public property | Series | Gets the collection of series displayed by this chart.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxes | Gets the collection of X axes displayed by this chart.
Public property | YAxes | Gets the collection of Y axes displayed by this chart.
Top
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.AxisBaselineStyle Property

XYChartAxisBaselineStyle Property

Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style AxisBaselineStyle { get; set; }
Public Property AxisBaselineStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape element used to render the baseline along the chart. The default value is .
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridLineMajorBrush Property

XYChartGridLineMajorBrush Property

Gets or sets the grid line major brush.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush GridLineMajorBrush { get; set; }
Public Property GridLineMajorBrush As Brush
    Get
    Set

Property Value

Type: Brush
The grid line major brush.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridLineMajorVisibility Property

XYChartGridLineMajorVisibility Property

Gets or sets the grid line major visibility.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GridLineVisibility GridLineMajorVisibility { get; set; }
Public Property GridLineMajorVisibility As GridLineVisibility
    Get
    Set

Property Value

Type: GridLineVisibility
The grid line major visibility.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridLineMinorBrush Property

XYChartGridLineMinorBrush Property

Gets or sets the grid line minor brush.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush GridLineMinorBrush { get; set; }
Public Property GridLineMinorBrush As Brush
    Get
    Set

Property Value

Type: Brush
The grid line minor brush.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridLineMinorVisibility Property

XYChartGridLineMinorVisibility Property

Gets or sets the grid line minor visibility.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GridLineVisibility GridLineMinorVisibility { get; set; }
Public Property GridLineMinorVisibility As GridLineVisibility
    Get
    Set

Property Value

Type: GridLineVisibility
The grid line minor visibility.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridStripeAlternatingBrush Property

XYChartGridStripeAlternatingBrush Property

Gets or sets the grid stripe alternating brush.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush GridStripeAlternatingBrush { get; set; }
Public Property GridStripeAlternatingBrush As Brush
    Get
    Set

Property Value

Type: Brush
The grid stripe alternating brush.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridStripeBrush Property

XYChartGridStripeBrush Property

Gets or sets the grid stripe brush.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush GridStripeBrush { get; set; }
Public Property GridStripeBrush As Brush
    Get
    Set

Property Value

Type: Brush
The grid stripe brush.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridStripeVisibility Property

XYChartGridStripeVisibility Property

Gets or sets the grid stripe visibility.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GridStripeVisibility GridStripeVisibility { get; set; }
Public Property GridStripeVisibility As GridStripeVisibility
    Get
    Set

Property Value

Type: GridStripeVisibility
The grid stripe visibility.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.IsAxisBaselineVisible Property

XYChartIsAxisBaselineVisible Property

Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAxisBaselineVisible { get; set; }
Public Property IsAxisBaselineVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a line is rendered at the baseline value; otherwise, false. The default value is false.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.IsLegendVisible Property

XYChartIsLegendVisible Property

Gets or sets a value indicating whether the legend is visible. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsLegendVisible { get; set; }
Public Property IsLegendVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the legend is visible; otherwise, false. The default value is false.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.LabelCollisionMode Property

XYChartLabelCollisionMode Property

Gets or sets the label collision mode.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LabelCollisionMode LabelCollisionMode { get; set; }
Public Property LabelCollisionMode As LabelCollisionMode
    Get
    Set

Property Value

Type: LabelCollisionMode
The label collision mode.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.LegendHorizontalPosition Property

XYChartLegendHorizontalPosition Property

Gets or sets the horizontal position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LegendHorizontalPosition LegendHorizontalPosition { get; set; }
Public Property LegendHorizontalPosition As LegendHorizontalPosition
    Get
    Set

Property Value

Type: LegendHorizontalPosition
The horizontal position of the legend.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.LegendKeys Property

XYChartLegendKeys Property

Gets the collection of legend keys displayed in the legend.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<LegendKey> LegendKeys { get; }
Public ReadOnly Property LegendKeys As ObservableCollection(Of LegendKey)
    Get

Property Value

Type: ObservableCollection LegendKey
The collection of legend keys.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.LegendStyle Property

XYChartLegendStyle Property

Gets or sets the Style applied to the legend. The Style must have a TargetType of ItemsControl.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LegendStyle { get; set; }
Public Property LegendStyle As Style
    Get
    Set

Property Value

Type: Style
The style to apply to the legend.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.LegendVerticalPosition Property

XYChartLegendVerticalPosition Property

Gets or sets the vertical position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LegendVerticalPosition LegendVerticalPosition { get; set; }
Public Property LegendVerticalPosition As LegendVerticalPosition
    Get
    Set

Property Value

Type: LegendVerticalPosition
The vertical position of the legend.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.PaddingPercentage Property

XYChartPaddingPercentage Property

The percentage of the chart size used for padding. Valid values are 0.0d (0%) to 1.0d (100%).

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness PaddingPercentage { get; set; }
Public Property PaddingPercentage As Thickness
    Get
    Set

Property Value

Type: Thickness
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.Series Property

XYChartSeries Property

Gets the collection of series displayed by this chart.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYSeriesCollection Series { get; }
Public ReadOnly Property Series As XYSeriesCollection
    Get

Property Value

Type: XYSeriesCollection
The collection of series displayed by this chart.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.SeriesStyleSelector Property

XYChartSeriesStyleSelector Property

Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISeriesStyleSelector SeriesStyleSelector { get; set; }
Public Property SeriesStyleSelector As ISeriesStyleSelector
    Get
    Set

Property Value

Type: ISeriesStyleSelector
A SeriesStyleSelector object that contains logic that chooses the style to use for each element in the associated series. The default value is .
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.XAxes Property

XYChartXAxes Property

Gets the collection of X axes displayed by this chart.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYAxisCollection XAxes { get; }
Public ReadOnly Property XAxes As XYAxisCollection
    Get

Property Value

Type: XYAxisCollection
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.YAxes Property

XYChartYAxes Property

Gets the collection of Y axes displayed by this chart.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYAxisCollection YAxes { get; }
Public ReadOnly Property YAxes As XYAxisCollection
    Get

Property Value

Type: XYAxisCollection
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart Methods

The XYChart type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of Silverlight layout. Classes can override this method to define their own Arrange pass behavior. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the UI Automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeave | Called before the mouse pointer exits the control. (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseMove | Called before the mouse pointer is moved. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.ArrangeOverride Method

XYChartArrangeOverride Method

Provides the behavior for the Arrange pass of Silverlight layout. Classes can override this method to define their own Arrange pass behavior.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this object should use to arrange itself and its children.

Return Value

Type: Size
The actual size that is used after the element is arranged in layout.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.MeasureOverride Method

XYChartMeasureOverride Method

Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this object can give to child objects. Infinity (PositiveInfinity) can be specified as a value to indicate that the object will size to whatever content is available.

Return Value

Type: Size
The size that this object determines it needs during layout, based on its calculations of the allocated sizes for child objects; or based on other considerations, such as a fixed container size.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.OnApplyTemplate Method

XYChartOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.OnCreateAutomationPeer Method

XYChartOnCreateAutomationPeer Method

When implemented in a derived class, returns class-specific AutomationPeer implementations for the UI Automation infrastructure.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.OnMouseLeave Method

XYChartOnMouseLeave Method

Called before the mouse pointer exits the control.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeave(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseLeave (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
Event data for the event.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.OnMouseMove Method

XYChartOnMouseMove Method

Called before the mouse pointer is moved.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
Event data for the event.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.Refresh Method

XYChartRefresh Method

Updates the chart based on the current state.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart Events

The XYChart type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart Fields

The XYChart type exposes the following members.

Fields
Name | Description
AxisBaselineStyleProperty | Identifies the AxisBaselineStyle dependency property. This field is read-only.
GridLineMajorBrushProperty | Identifies the GridLineMinorBrush dependency property. This field is read-only.
GridLineMajorVisibilityProperty | Identifies the GridLineMajorVisibility dependency property. This field is read-only.
GridLineMinorBrushProperty | Identifies the GridLineMinorBrush dependency property. This field is read-only.
GridLineMinorVisibilityProperty | Identifies the GridLineMinorVisibility dependency property. This field is read-only.
GridStripeAlternatingBrushProperty | Identifies the GridStripeAlternatingBrush dependency property. This field is read-only.
GridStripeBrushProperty | Identifies the GridStripeBrush dependency property. This field is read-only.
GridStripeVisibilityProperty | Identifies the GridStripeVisibility dependency property. This field is read-only.
IsAxisBaselineVisibleProperty | Identifies the IsAxisBaselineVisible dependency property. This field is read-only.
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LabelCollisionModeProperty | Identifies the LabelCollisionMode dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendStyleProperty | Identifies the LegendStyle dependency property. This field is read-only.
LegendVerticalPositionProperty | Identifies the LegendVerticalPosition dependency property. This field is read-only.
PaddingPercentageProperty | Identifies the PaddingPercentage dependency property. This field is read-only.
SeriesStyleSelectorProperty | Identifies the SeriesStyleSelector dependency property. This field is read-only.
Top
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.AxisBaselineStyleProperty Field

XYChartAxisBaselineStyleProperty Field

Identifies the AxisBaselineStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AxisBaselineStyleProperty
Public Shared ReadOnly AxisBaselineStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AxisBaselineStyle dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridLineMajorBrushProperty Field

XYChartGridLineMajorBrushProperty Field

Identifies the GridLineMinorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineMajorBrushProperty
Public Shared ReadOnly GridLineMajorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineMinorBrush dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridLineMajorVisibilityProperty Field

XYChartGridLineMajorVisibilityProperty Field

Identifies the GridLineMajorVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineMajorVisibilityProperty
Public Shared ReadOnly GridLineMajorVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineMajorVisibility dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridLineMinorBrushProperty Field

XYChartGridLineMinorBrushProperty Field

Identifies the GridLineMinorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineMinorBrushProperty
Public Shared ReadOnly GridLineMinorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineMinorBrush dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridLineMinorVisibilityProperty Field

XYChartGridLineMinorVisibilityProperty Field

Identifies the GridLineMinorVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineMinorVisibilityProperty
Public Shared ReadOnly GridLineMinorVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineMinorVisibility dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridStripeAlternatingBrushProperty Field

XYChartGridStripeAlternatingBrushProperty Field

Identifies the GridStripeAlternatingBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridStripeAlternatingBrushProperty
Public Shared ReadOnly GridStripeAlternatingBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridStripeAlternatingBrush dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridStripeBrushProperty Field

XYChartGridStripeBrushProperty Field

Identifies the GridStripeBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridStripeBrushProperty
Public Shared ReadOnly GridStripeBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridStripeBrush dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.GridStripeVisibilityProperty Field

XYChartGridStripeVisibilityProperty Field

Identifies the GridStripeVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridStripeVisibilityProperty
Public Shared ReadOnly GridStripeVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridStripeVisibility dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.IsAxisBaselineVisibleProperty Field

XYChartIsAxisBaselineVisibleProperty Field

Identifies the IsAxisBaselineVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAxisBaselineVisibleProperty
Public Shared ReadOnly IsAxisBaselineVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAxisBaselineVisible dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.IsLegendVisibleProperty Field

XYChartIsLegendVisibleProperty Field

Identifies the IsLegendVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLegendVisibleProperty
Public Shared ReadOnly IsLegendVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLegendVisible dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.LabelCollisionModeProperty Field

XYChartLabelCollisionModeProperty Field

Identifies the LabelCollisionMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelCollisionModeProperty
Public Shared ReadOnly LabelCollisionModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelCollisionMode dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.LegendHorizontalPositionProperty Field

XYChartLegendHorizontalPositionProperty Field

Identifies the LegendHorizontalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendHorizontalPositionProperty
Public Shared ReadOnly LegendHorizontalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendHorizontalPosition dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.LegendStyleProperty Field

XYChartLegendStyleProperty Field

Identifies the LegendStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStyleProperty
Public Shared ReadOnly LegendStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStyle dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.LegendVerticalPositionProperty Field

XYChartLegendVerticalPositionProperty Field

Identifies the LegendVerticalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendVerticalPositionProperty
Public Shared ReadOnly LegendVerticalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendVerticalPosition dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.PaddingPercentageProperty Field

XYChartPaddingPercentageProperty Field

Identifies the PaddingPercentage dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PaddingPercentageProperty
Public Shared ReadOnly PaddingPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PaddingPercentage dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYChart.SeriesStyleSelectorProperty Field

XYChartSeriesStyleSelectorProperty Field

Identifies the SeriesStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SeriesStyleSelectorProperty
Public Shared ReadOnly SeriesStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SeriesStyleSelector dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint Class

Represents a data point presented by a a XYSeriesBase series.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesDataPointBase
ActiproSoftware.Windows.Controls.ChartsXYDataPoint

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYDataPoint : DataPointBase
Public Class XYDataPoint
    Inherits DataPointBase

The XYDataPoint type exposes the following members.

Constructors
 | Name | Description
Public method | XYDataPoint | Initializes a new instance of the XYDataPoint class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point. (Inherited from DataPointBase.)
Public property | OriginalValue | Gets the original value.
Public property | StackedDataPoint | Gets the XYDataPoint that this data point is stacked on top of.
Public property | XValue | Gets the X-value of the data point.
Public property | XValueResolved | Gets the resolved X-value of the data point.
Public property | YValue | Gets the Y-value of the data point.
Public property | YValueResolved | Gets the resolved Y-value of the data point.
Top
Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint Constructor

Initializes a new instance of the XYDataPoint class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYDataPoint()
Public Sub New
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint Properties

The XYDataPoint type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point. (Inherited from DataPointBase.)
Public property | OriginalValue | Gets the original value.
Public property | StackedDataPoint | Gets the XYDataPoint that this data point is stacked on top of.
Public property | XValue | Gets the X-value of the data point.
Public property | XValueResolved | Gets the resolved X-value of the data point.
Public property | YValue | Gets the Y-value of the data point.
Public property | YValueResolved | Gets the resolved Y-value of the data point.
Top
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint.OriginalValue Property

XYDataPointOriginalValue Property

Gets the original value.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object OriginalValue { get; }
Public ReadOnly Property OriginalValue As Object
    Get

Property Value

Type: Object
The original value.
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint.StackedDataPoint Property

XYDataPointStackedDataPoint Property

Gets the XYDataPoint that this data point is stacked on top of.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYDataPoint StackedDataPoint { get; }
Public ReadOnly Property StackedDataPoint As XYDataPoint
    Get

Property Value

Type: XYDataPoint
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint.XValue Property

XYDataPointXValue Property

Gets the X-value of the data point.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object XValue { get; }
Public ReadOnly Property XValue As Object
    Get

Property Value

Type: Object
The X-value of the data point.
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint.XValueResolved Property

XYDataPointXValueResolved Property

Gets the resolved X-value of the data point.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object XValueResolved { get; }
Public ReadOnly Property XValueResolved As Object
    Get

Property Value

Type: Object
The resolved X-value of the data point.
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint.YValue Property

XYDataPointYValue Property

Gets the Y-value of the data point.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object YValue { get; }
Public ReadOnly Property YValue As Object
    Get

Property Value

Type: Object
The Y-value of the data point.
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint.YValueResolved Property

XYDataPointYValueResolved Property

Gets the resolved Y-value of the data point.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object YValueResolved { get; }
Public ReadOnly Property YValueResolved As Object
    Get

Property Value

Type: Object
The resolved Y-value of the data point.
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint Methods

The XYDataPoint type exposes the following members.

Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDataPoint Events

The XYDataPoint type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

XYDataPoint Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis Class

Represents an axis for data in DateTime format.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.Windows.Controls.ChartsXYDateTimeAxis

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYDateTimeAxis : XYAxisBase
Public Class XYDateTimeAxis
    Inherits XYAxisBase

The XYDateTimeAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYDateTimeAxis | Creates a new XYDateTimeAxis.
Top
Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Maximum | The maximum value of the axis.
Public property | Minimum | The minimum value of the axis.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | SlotIntervalUnit | The time unit that the SlotInterval represents for data points of the axis when using slotted layout.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorIntervalUnit | The unit of time that TickMajorInterval represents.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorIntervalUnit | The unit of time that TickMinorInterval represents.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
SlotIntervalUnitProperty | Identifies the SlotIntervalUnit dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMajorIntervalUnitProperty | Identifies the TickMajorIntervalUnit dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
TickMinorIntervalUnitProperty | Identifies the TickMinorIntervalUnit dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis Constructor

Creates a new XYDateTimeAxis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYDateTimeAxis()
Public Sub New
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis Properties

The XYDateTimeAxis type exposes the following members.

Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Maximum | The maximum value of the axis.
Public property | Minimum | The minimum value of the axis.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | SlotIntervalUnit | The time unit that the SlotInterval represents for data points of the axis when using slotted layout.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorIntervalUnit | The unit of time that TickMajorInterval represents.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorIntervalUnit | The unit of time that TickMinorInterval represents.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.Baseline Property

XYDateTimeAxisBaseline Property

The baseline value for the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Baseline { get; set; }
Public Property Baseline As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.LabelFunc Property

XYDateTimeAxisLabelFunc Property

Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<DateTime, DateTime, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of DateTime, DateTime, String)
    Get
    Set

Property Value

Type: Func DateTime, DateTime, String
The function used to determine axis labels.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.Maximum Property

XYDateTimeAxisMaximum Property

The maximum value of the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.Minimum Property

XYDateTimeAxisMinimum Property

The minimum value of the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.SlotInterval Property

XYDateTimeAxisSlotInterval Property

The slot interval for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SlotInterval { get; set; }
Public Property SlotInterval As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace
XYDateTimeAxisSlotIntervalUnit


XYDateTimeAxis.SlotIntervalUnit Property

XYDateTimeAxisSlotIntervalUnit Property

The time unit that the SlotInterval represents for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeUnit SlotIntervalUnit { get; set; }
Public Property SlotIntervalUnit As TimeUnit
    Get
    Set

Property Value

Type: TimeUnit
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace
XYDateTimeAxisSlotInterval


XYDateTimeAxis.TickMajorInterval Property

XYDateTimeAxisTickMajorInterval Property

The interval at which to display major ticks.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int TickMajorInterval { get; set; }
Public Property TickMajorInterval As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace
XYDateTimeAxisTickMajorIntervalUnit


XYDateTimeAxis.TickMajorIntervalUnit Property

XYDateTimeAxisTickMajorIntervalUnit Property

The unit of time that TickMajorInterval represents.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeUnit TickMajorIntervalUnit { get; set; }
Public Property TickMajorIntervalUnit As TimeUnit
    Get
    Set

Property Value

Type: TimeUnit
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace
XYDateTimeAxisTickMajorInterval


XYDateTimeAxis.TickMinorInterval Property

XYDateTimeAxisTickMinorInterval Property

The interval at which to display minor ticks.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int TickMinorInterval { get; set; }
Public Property TickMinorInterval As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace
XYDateTimeAxisTickMinorIntervalUnit


XYDateTimeAxis.TickMinorIntervalUnit Property

XYDateTimeAxisTickMinorIntervalUnit Property

The unit of time that TickMinorInterval represents.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeUnit TickMinorIntervalUnit { get; set; }
Public Property TickMinorIntervalUnit As TimeUnit
    Get
    Set

Property Value

Type: TimeUnit
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace
XYDateTimeAxisTickMinorInterval


XYDateTimeAxis Methods

The XYDateTimeAxis type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis Events

The XYDateTimeAxis type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis Fields

The XYDateTimeAxis type exposes the following members.

Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
SlotIntervalUnitProperty | Identifies the SlotIntervalUnit dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMajorIntervalUnitProperty | Identifies the TickMajorIntervalUnit dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
TickMinorIntervalUnitProperty | Identifies the TickMinorIntervalUnit dependency property. This field is read-only.
Top
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.BaselineProperty Field

XYDateTimeAxisBaselineProperty Field

Identifies the Baseline dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaselineProperty
Public Shared ReadOnly BaselineProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Baseline dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.LabelFuncProperty Field

XYDateTimeAxisLabelFuncProperty Field

Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.MaximumProperty Field

XYDateTimeAxisMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.MinimumProperty Field

XYDateTimeAxisMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.SlotIntervalProperty Field

XYDateTimeAxisSlotIntervalProperty Field

Identifies the SlotInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotIntervalProperty
Public Shared ReadOnly SlotIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotInterval dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.SlotIntervalUnitProperty Field

XYDateTimeAxisSlotIntervalUnitProperty Field

Identifies the SlotIntervalUnit dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotIntervalUnitProperty
Public Shared ReadOnly SlotIntervalUnitProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotIntervalUnit dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.TickMajorIntervalProperty Field

XYDateTimeAxisTickMajorIntervalProperty Field

Identifies the TickMajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalProperty
Public Shared ReadOnly TickMajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorInterval dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.TickMajorIntervalUnitProperty Field

XYDateTimeAxisTickMajorIntervalUnitProperty Field

Identifies the TickMajorIntervalUnit dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalUnitProperty
Public Shared ReadOnly TickMajorIntervalUnitProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorIntervalUnit dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.TickMinorIntervalProperty Field

XYDateTimeAxisTickMinorIntervalProperty Field

Identifies the TickMinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalProperty
Public Shared ReadOnly TickMinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorInterval dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDateTimeAxis.TickMinorIntervalUnitProperty Field

XYDateTimeAxisTickMinorIntervalUnitProperty Field

Identifies the TickMinorIntervalUnit dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalUnitProperty
Public Shared ReadOnly TickMinorIntervalUnitProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorIntervalUnit dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxis Class

Represents an axis for data in Decimal format.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.Windows.Controls.ChartsXYDecimalAxisBase Decimal
ActiproSoftware.Windows.Controls.ChartsXYDecimalAxis

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYDecimalAxis : XYDecimalAxisBase<decimal>
Public Class XYDecimalAxis
    Inherits XYDecimalAxisBase(Of Decimal)

The XYDecimalAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYDecimalAxis | Initializes a new instance of the XYDecimalAxis class
Top
Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Maximum | The maximum value of the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | Minimum | The minimum value of the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout. (Inherited from XYDecimalAxisBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks. (Inherited from XYDecimalAxisBaseT.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks. (Inherited from XYDecimalAxisBaseT.)
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxis Constructor

Initializes a new instance of the XYDecimalAxis class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYDecimalAxis()
Public Sub New
See Also

Reference

XYDecimalAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxis Properties

The XYDecimalAxis type exposes the following members.

Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Maximum | The maximum value of the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | Minimum | The minimum value of the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout. (Inherited from XYDecimalAxisBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks. (Inherited from XYDecimalAxisBaseT.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks. (Inherited from XYDecimalAxisBaseT.)
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XYDecimalAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxis Methods

The XYDecimalAxis type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYDecimalAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxis Events

The XYDecimalAxis type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
See Also

Reference

XYDecimalAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T) Class

XYDecimalAxisBaseT Class

Represents an axis for data in Decimal format.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.Windows.Controls.ChartsXYDecimalAxisBaseT
ActiproSoftware.Windows.Controls.ChartsXYDecimalAxis

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYDecimalAxisBase<T> : XYAxisBase

Public Class XYDecimalAxisBase(Of T)
    Inherits XYAxisBase

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.Windows.Controls.Charts.XYDecimalAxisBase`1"]

The XYDecimalAxisBaseT type exposes the following members.

Constructors
 | Name | Description
Public method | XYDecimalAxisBaseT | Creates a new XYDecimalAxis.
Top
Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Maximum | The maximum value of the axis.
Public property | Minimum | The minimum value of the axis.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T) Constructor

XYDecimalAxisBaseT Constructor

Creates a new XYDecimalAxis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYDecimalAxisBase()
Public Sub New
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T) Properties

XYDecimalAxisBaseT Properties

The XYDecimalAxisBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Maximum | The maximum value of the axis.
Public property | Minimum | The minimum value of the axis.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).Baseline Property

XYDecimalAxisBaseTBaseline Property

The baseline value for the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Baseline { get; set; }
Public Property Baseline As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).LabelFunc Property

XYDecimalAxisBaseTLabelFunc Property

Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<decimal, decimal, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Decimal, Decimal, String)
    Get
    Set

Property Value

Type: Func Decimal, Decimal, String
The function used to determine axis labels.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).Maximum Property

XYDecimalAxisBaseTMaximum Property

The maximum value of the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Maximum { get; set; }
Public Property Maximum As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).Minimum Property

XYDecimalAxisBaseTMinimum Property

The minimum value of the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Minimum { get; set; }
Public Property Minimum As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).SlotInterval Property

XYDecimalAxisBaseTSlotInterval Property

The slot interval for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T SlotInterval { get; set; }
Public Property SlotInterval As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).TickMajorInterval Property

XYDecimalAxisBaseTTickMajorInterval Property

The interval at which to display major ticks.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T TickMajorInterval { get; set; }
Public Property TickMajorInterval As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).TickMinorInterval Property

XYDecimalAxisBaseTTickMinorInterval Property

The interval at which to display minor ticks.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T TickMinorInterval { get; set; }
Public Property TickMinorInterval As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T) Methods

XYDecimalAxisBaseT Methods

The XYDecimalAxisBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T) Events

XYDecimalAxisBaseT Events

The XYDecimalAxisBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T) Fields

XYDecimalAxisBaseT Fields

The XYDecimalAxisBaseT generic type exposes the following members.

Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).BaselineProperty Field

XYDecimalAxisBaseTBaselineProperty Field

Identifies the Baseline dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaselineProperty
Public Shared ReadOnly BaselineProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Baseline dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).LabelFuncProperty Field

XYDecimalAxisBaseTLabelFuncProperty Field

Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).MaximumProperty Field

XYDecimalAxisBaseTMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).MinimumProperty Field

XYDecimalAxisBaseTMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).SlotIntervalProperty Field

XYDecimalAxisBaseTSlotIntervalProperty Field

Identifies the SlotInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotIntervalProperty
Public Shared ReadOnly SlotIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotInterval dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).TickMajorIntervalProperty Field

XYDecimalAxisBaseTTickMajorIntervalProperty Field

Identifies the TickMajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalProperty
Public Shared ReadOnly TickMajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorInterval dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDecimalAxisBase(T).TickMinorIntervalProperty Field

XYDecimalAxisBaseTTickMinorIntervalProperty Field

Identifies the TickMinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalProperty
Public Shared ReadOnly TickMinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorInterval dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis Class

Represents an axis for data in Double format.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.Windows.Controls.ChartsXYDoubleAxis

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYDoubleAxis : XYAxisBase
Public Class XYDoubleAxis
    Inherits XYAxisBase

The XYDoubleAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYDoubleAxis | Creates a new XYDoubleAxis.
Top
Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Maximum | The maximum value of the axis.
Public property | Minimum | The minimum value of the axis.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis Constructor

Creates a new XYDoubleAxis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYDoubleAxis()
Public Sub New
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis Properties

The XYDoubleAxis type exposes the following members.

Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Maximum | The maximum value of the axis.
Public property | Minimum | The minimum value of the axis.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.Baseline Property

XYDoubleAxisBaseline Property

The baseline value for the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Baseline { get; set; }
Public Property Baseline As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.LabelFunc Property

XYDoubleAxisLabelFunc Property

Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<double, double, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Double, Double, String)
    Get
    Set

Property Value

Type: Func Double, Double, String
The function used to determine axis labels.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.Maximum Property

XYDoubleAxisMaximum Property

The maximum value of the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.Minimum Property

XYDoubleAxisMinimum Property

The minimum value of the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.SlotInterval Property

XYDoubleAxisSlotInterval Property

The slot interval for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SlotInterval { get; set; }
Public Property SlotInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.TickMajorInterval Property

XYDoubleAxisTickMajorInterval Property

The interval at which to display major ticks.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TickMajorInterval { get; set; }
Public Property TickMajorInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.TickMinorInterval Property

XYDoubleAxisTickMinorInterval Property

The interval at which to display minor ticks.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TickMinorInterval { get; set; }
Public Property TickMinorInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis Methods

The XYDoubleAxis type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis Events

The XYDoubleAxis type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis Fields

The XYDoubleAxis type exposes the following members.

Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.BaselineProperty Field

XYDoubleAxisBaselineProperty Field

Identifies the Baseline dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaselineProperty
Public Shared ReadOnly BaselineProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Baseline dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.LabelFuncProperty Field

XYDoubleAxisLabelFuncProperty Field

Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.MaximumProperty Field

XYDoubleAxisMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.MinimumProperty Field

XYDoubleAxisMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.SlotIntervalProperty Field

XYDoubleAxisSlotIntervalProperty Field

Identifies the SlotInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotIntervalProperty
Public Shared ReadOnly SlotIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotInterval dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.TickMajorIntervalProperty Field

XYDoubleAxisTickMajorIntervalProperty Field

Identifies the TickMajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalProperty
Public Shared ReadOnly TickMajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorInterval dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYDoubleAxis.TickMinorIntervalProperty Field

XYDoubleAxisTickMinorIntervalProperty Field

Identifies the TickMinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalProperty
Public Shared ReadOnly TickMinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorInterval dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis Class

XYGroupedAxis is an axis type used for displaying non-value data, such as strings and complex types. It can group, label, and sort data based on custom criteria.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.Windows.Controls.ChartsXYGroupedAxis

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYGroupedAxis : XYAxisBase
Public Class XYGroupedAxis
    Inherits XYAxisBase

The XYGroupedAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYGroupedAxis | Creates a new XYDoubleAxis.
Top
Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupingFunc | The function used to group items for a XYGroupedAxis. The function takes two data items and returns a Boolean indicating whether or not the items are grouped.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | The function used to label groups of items. The function takes a single data item from a group and returns a String used to label the group.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SortingFunc | The function used to sort groups of items. The function takes two data items from seperate groups and returns an Int32 comparing the two values. XYGroupedAxis should have SortFunc -- takes two groups and returns an int, like a comparable ("group" is first item in group) If the function returns a negative value, then the first instance is sorted before the second. If the function returns zero, then the instances are considered equal and sorted next to each other. If the function returns a positive value, then the first instance is sorted after the second.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
Fields
Name | Description
GroupingFuncProperty | Identifies the GroupingFunc dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
SortingFuncProperty | Identifies the SortingFunc dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis Constructor

Creates a new XYDoubleAxis.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYGroupedAxis()
Public Sub New
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis Properties

The XYGroupedAxis type exposes the following members.

Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupingFunc | The function used to group items for a XYGroupedAxis. The function takes two data items and returns a Boolean indicating whether or not the items are grouped.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | The function used to label groups of items. The function takes a single data item from a group and returns a String used to label the group.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | SortingFunc | The function used to sort groups of items. The function takes two data items from seperate groups and returns an Int32 comparing the two values. XYGroupedAxis should have SortFunc -- takes two groups and returns an int, like a comparable ("group" is first item in group) If the function returns a negative value, then the first instance is sorted before the second. If the function returns zero, then the instances are considered equal and sorted next to each other. If the function returns a positive value, then the first instance is sorted after the second.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis.GroupingFunc Property

XYGroupedAxisGroupingFunc Property

The function used to group items for a XYGroupedAxis. The function takes two data items and returns a Boolean indicating whether or not the items are grouped.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<Object, Object, bool> GroupingFunc { get; set; }
Public Property GroupingFunc As Func(Of Object, Object, Boolean)
    Get
    Set

Property Value

Type: Func Object, Object, Boolean
The grouping function.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis.LabelFunc Property

XYGroupedAxisLabelFunc Property

The function used to label groups of items. The function takes a single data item from a group and returns a String used to label the group.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<Object, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Object, String)
    Get
    Set

Property Value

Type: Func Object, String
The label function.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis.SortingFunc Property

XYGroupedAxisSortingFunc Property

The function used to sort groups of items. The function takes two data items from seperate groups and returns an Int32 comparing the two values. XYGroupedAxis should have SortFunc -- takes two groups and returns an int, like a comparable ("group" is first item in group) If the function returns a negative value, then the first instance is sorted before the second. If the function returns zero, then the instances are considered equal and sorted next to each other. If the function returns a positive value, then the first instance is sorted after the second.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<Object, Object, int> SortingFunc { get; set; }
Public Property SortingFunc As Func(Of Object, Object, Integer)
    Get
    Set

Property Value

Type: Func Object, Object, Int32
The sorting function.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis Methods

The XYGroupedAxis type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis Events

The XYGroupedAxis type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis Fields

The XYGroupedAxis type exposes the following members.

Fields
Name | Description
GroupingFuncProperty | Identifies the GroupingFunc dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
SortingFuncProperty | Identifies the SortingFunc dependency property. This field is read-only.
Top
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis.GroupingFuncProperty Field

XYGroupedAxisGroupingFuncProperty Field

Identifies the GroupingFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GroupingFuncProperty
Public Shared ReadOnly GroupingFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GroupingFunc dependency property.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis.LabelFuncProperty Field

XYGroupedAxisLabelFuncProperty Field

Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYGroupedAxis.SortingFuncProperty Field

XYGroupedAxisSortingFuncProperty Field

Identifies the SortingFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortingFuncProperty
Public Shared ReadOnly SortingFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortingFunc dependency property.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis Class

Represents an axis for data displayed as stacked in percentage mode.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.Windows.Controls.ChartsXYPercentageAxis

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYPercentageAxis : XYAxisBase
Public Class XYPercentageAxis
    Inherits XYAxisBase

The XYPercentageAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYPercentageAxis | Initializes a new instance of the XYPercentageAxis class.
Top
Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. The first parameter of the function will be the value of the axis point represented by the label. In the case of XYPercentageAxis, it will be a percentage value between 0.0 and 1.0.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | Gets or sets the interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | Gets or sets the interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
Fields
Name | Description
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis Constructor

Initializes a new instance of the XYPercentageAxis class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYPercentageAxis()
Public Sub New
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis Properties

The XYPercentageAxis type exposes the following members.

Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. The first parameter of the function will be the value of the axis point represented by the label. In the case of XYPercentageAxis, it will be a percentage value between 0.0 and 1.0.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorInterval | Gets or sets the interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | Gets or sets the interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels. (Inherited from XYAxisBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis.LabelFunc Property

XYPercentageAxisLabelFunc Property

Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. The first parameter of the function will be the value of the axis point represented by the label. In the case of XYPercentageAxis, it will be a percentage value between 0.0 and 1.0.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<double, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Double, String)
    Get
    Set

Property Value

Type: Func Double, String
The function used to determine axis labels.
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis.TickMajorInterval Property

XYPercentageAxisTickMajorInterval Property

Gets or sets the interval at which to display major ticks.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TickMajorInterval { get; set; }
Public Property TickMajorInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis.TickMinorInterval Property

XYPercentageAxisTickMinorInterval Property

Gets or sets the interval at which to display minor ticks.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TickMinorInterval { get; set; }
Public Property TickMinorInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis Methods

The XYPercentageAxis type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis Events

The XYPercentageAxis type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Top
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis Fields

The XYPercentageAxis type exposes the following members.

Fields
Name | Description
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis.LabelFuncProperty Field

XYPercentageAxisLabelFuncProperty Field

Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis.TickMajorIntervalProperty Field

XYPercentageAxisTickMajorIntervalProperty Field

Identifies the TickMajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalProperty
Public Shared ReadOnly TickMajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorInterval dependency property.
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYPercentageAxis.TickMinorIntervalProperty Field

XYPercentageAxisTickMinorIntervalProperty Field

Identifies the TickMinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalProperty
Public Shared ReadOnly TickMinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorInterval dependency property.
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange Class

Represents a range for use in a XYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ChartsXYRange

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYRange : Control
Public Class XYRange
    Inherits Control

The XYRange type exposes the following members.

Constructors
 | Name | Description
Public method | XYRange | Initializes a new instance of the XYRange class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value of the range. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value of the range. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the range. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the range based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYRange Constructor

Initializes a new instance of the XYRange class.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYRange()
Public Sub New
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange Properties

The XYRange type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value of the range. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value of the range. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the range. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange.Maximum Property

XYRangeMaximum Property

Gets or sets the maximum value of the range. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Maximum { get; set; }
Public Property Maximum As Object
    Get
    Set

Property Value

Type: Object
The maximum value of the range. The default value is .
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange.Minimum Property

XYRangeMinimum Property

Gets or sets the minimum value of the range. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Minimum { get; set; }
Public Property Minimum As Object
    Get
    Set

Property Value

Type: Object
The minimum value of the range. The default value is .
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange.Orientation Property

XYRangeOrientation Property

Gets or sets the orientation of the range. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the range. The default value is Orientation.Horizontal.
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange Methods

The XYRange type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the range based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange.Refresh Method

XYRangeRefresh Method

Updates the range based on the current state.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange Events

The XYRange type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange Fields

The XYRange type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange.MaximumProperty Field

XYRangeMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange.MinimumProperty Field

XYRangeMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRange.OrientationProperty Field

XYRangeOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

XYRange Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRangeCollection Class

Represents a collection of XYRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XYRange
System.Collections.ObjectModelObservableCollection XYRange
ActiproSoftware.WindowsDeferrableObservableCollection XYRange
ActiproSoftware.Windows.Controls.ChartsDeferrableObservableItemCollection XYRange
ActiproSoftware.Windows.Controls.ChartsXYRangeCollection

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYRangeCollection : DeferrableObservableItemCollection<XYRange>
Public Class XYRangeCollection
    Inherits DeferrableObservableItemCollection(Of XYRange)

The XYRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XYRangeCollection | Initializes a new instance of the XYRangeCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XYRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XYRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XYRange .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XYRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XYRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XYRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XYRange .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XYRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XYRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XYRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XYRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XYRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XYRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XYRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XYRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XYRange .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYRangeCollection Constructor

Initializes a new instance of the XYRangeCollection class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYRangeCollection()
Public Sub New
See Also

Reference

XYRangeCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRangeCollection Properties

The XYRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XYRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XYRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XYRange .)
Top
See Also

Reference

XYRangeCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRangeCollection Methods

The XYRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XYRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XYRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XYRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XYRange .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XYRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XYRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XYRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XYRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XYRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XYRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XYRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

XYRangeCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYRangeCollection Events

The XYRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XYRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XYRange .)
Top
See Also

Reference

XYRangeCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYSeriesCollection Class

Represents a collection of XYRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XYSeriesBase
System.Collections.ObjectModelObservableCollection XYSeriesBase
ActiproSoftware.WindowsDeferrableObservableCollection XYSeriesBase
ActiproSoftware.Windows.Controls.ChartsDeferrableObservableItemCollection XYSeriesBase
ActiproSoftware.Windows.Controls.ChartsXYSeriesCollection

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYSeriesCollection : DeferrableObservableItemCollection<XYSeriesBase>
Public Class XYSeriesCollection
    Inherits DeferrableObservableItemCollection(Of XYSeriesBase)

The XYSeriesCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XYSeriesCollection | Initializes a new instance of the XYSeriesCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XYSeriesBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XYSeriesBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XYSeriesBase .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XYSeriesBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XYSeriesBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XYSeriesBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XYSeriesBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XYSeriesBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYSeriesBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYSeriesBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XYSeriesBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XYSeriesBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XYSeriesBase .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYSeriesCollection Constructor

Initializes a new instance of the XYSeriesCollection class

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYSeriesCollection()
Public Sub New
See Also

Reference

XYSeriesCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYSeriesCollection Properties

The XYSeriesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XYSeriesBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XYSeriesBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XYSeriesBase .)
Top
See Also

Reference

XYSeriesCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYSeriesCollection Methods

The XYSeriesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XYSeriesBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XYSeriesBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XYSeriesBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XYSeriesBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XYSeriesBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYSeriesBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XYSeriesBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XYSeriesBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XYSeriesBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

XYSeriesCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYSeriesCollection Events

The XYSeriesCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XYSeriesBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XYSeriesBase .)
Top
See Also

Reference

XYSeriesCollection Class
ActiproSoftware.Windows.Controls.Charts Namespace


XYSeriesLineKind Enumeration

Specifies the line kinds supported by a LineSeries and AreaSeries series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum XYSeriesLineKind
Public Enumeration XYSeriesLineKind
Members
Member name | Value | Description
Normal | 0 | Indicates a normal line will be used to connect the data points.
Spline | 1 | Indicates a spline will be used to connect the data points.
Step | 2 | Indicates stepped lines will be used to connect the data points.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


XYSeriesStackKind Enumeration

Specifies the stacking methods supported by a XYSeriesBase series.

Namespace: ActiproSoftware.Windows.Controls.Charts
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum XYSeriesStackKind
Public Enumeration XYSeriesStackKind
Members
Member name | Value | Description
None | 0 | Indicates the series will not be stacked.
Normal | 1 | Indicates the series will be stacked by adding its values to the values of other stacked series.
Percentage | 2 | Indicates the series will be stacked by calculating percentages of its values based on the total values of all stacked series.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts Namespace


ActiproSoftware.Windows.Controls.Charts.Automation.Peers Namespace

Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | XYChartAutomationPeer | Exposes the XYChart control to UI Automation.


XYChartAutomationPeer Class

Exposes the XYChart control to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Charts.Automation.PeersXYChartAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Charts.Automation.Peers
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XYChartAutomationPeer : FrameworkElementAutomationPeer
Public Class XYChartAutomationPeer
    Inherits FrameworkElementAutomationPeer

The XYChartAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | XYChartAutomationPeer | Initializes a new instance of the XYChartAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer Constructor

Initializes a new instance of the XYChartAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Automation.Peers
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYChartAutomationPeer(
    XYChart owner
)
Public Sub New (
    owner As XYChart
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.ChartsXYChart
The owner.
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.Windows.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer Properties

The XYChartAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.Windows.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer Methods

The XYChartAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.Windows.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer.GetChildrenCore Method

XYChartAutomationPeerGetChildrenCore Method

Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren.

Namespace: ActiproSoftware.Windows.Controls.Charts.Automation.Peers
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override List<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As List(Of AutomationPeer)

Return Value

Type: List AutomationPeer
A list of child AutomationPeer elements.
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.Windows.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer.GetClassNameCore Method

XYChartAutomationPeerGetClassNameCore Method

Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Charts.Automation.Peers
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The string that contains the name.
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.Windows.Controls.Charts.Automation.Peers Namespace


ActiproSoftware.Windows.Controls.Charts.Palettes Namespace

Contains types related to chart palettes.
Classes
 | Class | Description
Public class | Palette | Provides a palette of colors for use in charts.
Public class | PaletteConverter | Represents a type converter for the Palette type.
Public class | PaletteData | Stores palette data.
Public class | PaletteStyleSelectorBaseT | The base class for style selectors that use palettes.
Public class | PieSlicePaletteStyleSelector | Selects a style for a given PieSlice using a palette of colors.
Public class | SeriesPaletteData | Stores series-related palette data.
Public class | SeriesPaletteStyleSelector | Provides a way to apply series styles based on a palette of colors.
Enumerations
 | Enumeration | Description
Public enumeration | ColorSelectionHint | Specifies a hint for how a SeriesPaletteStyleSelector should select colors for a series.
Public enumeration | PaletteKind | Specifies the built-in palette options for a SeriesPaletteStyleSelector.
Public enumeration | SeriesBrushKind | Specifies the kind of brush to use for a series element.


ColorSelectionHint Enumeration

Specifies a hint for how a SeriesPaletteStyleSelector should select colors for a series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ColorSelectionHint
Public Enumeration ColorSelectionHint
Members
Member name | Value | Description
Sequential | 0 | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
UniformDistribution | 1 | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette Class

Provides a palette of colors for use in charts.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PalettesPalette

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Palette
Public Class Palette

The Palette type exposes the following members.

Constructors
 | Name | Description
Public method | Palette | Initializes a new instance of the Palette class.
Public method | Palette(Color) | Initializes a new instance of the Palette class.
Public method | Palette(PaletteKind) | Initializes a new instance of the Palette class.
Top
Properties
 | Name | Description
Public property | BaseColors | Gets the collection of palette base Color objects used to generate the palette.
Public property | Colors | Gets the read-only collection of Color objects in this palette.
Public property | ColorSelectionHint | Gets or sets a ColorSelectionHint that provides a hint on how to perform color selection for this palette.
Public property | IsShadeGenerationEnabled | Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.
Public property | Kind | Gets or sets a PaletteKind that indicates the built-in palette to use.
Top
Methods
 | Name | Description
Protected method | OnChanged | Raises the Changed event.
Top
Events
 | Name | Description
Public event | Changed | Occurs after the palette has been changed.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette Constructor

Overload List
 | Name | Description
Public method | Palette | Initializes a new instance of the Palette class.
Public method | Palette(Color) | Initializes a new instance of the Palette class.
Public method | Palette(PaletteKind) | Initializes a new instance of the Palette class.
Top
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette Constructor

Initializes a new instance of the Palette class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Palette()
Public Sub New
See Also

Reference

Palette Class
Palette Overload
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette Constructor (Color[])

Palette Constructor (Color)

Initializes a new instance of the Palette class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Palette(
    params Color[] paletteBaseColors
)
Public Sub New (
    ParamArray paletteBaseColors As Color()
)

Parameters

paletteBaseColors
Type: System.Windows.MediaColor
The palette Color values.
See Also

Reference

Palette Class
Palette Overload
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette Constructor (PaletteKind)

Initializes a new instance of the Palette class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Palette(
    PaletteKind kind
)
Public Sub New (
    kind As PaletteKind
)

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Charts.PalettesPaletteKind
A PaletteKind that indicates the built-in palette to use.
See Also

Reference

Palette Class
Palette Overload
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette Properties

The Palette type exposes the following members.

Properties
 | Name | Description
Public property | BaseColors | Gets the collection of palette base Color objects used to generate the palette.
Public property | Colors | Gets the read-only collection of Color objects in this palette.
Public property | ColorSelectionHint | Gets or sets a ColorSelectionHint that provides a hint on how to perform color selection for this palette.
Public property | IsShadeGenerationEnabled | Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.
Public property | Kind | Gets or sets a PaletteKind that indicates the built-in palette to use.
Top
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette.BaseColors Property

PaletteBaseColors Property

Gets the collection of palette base Color objects used to generate the palette.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<Color> BaseColors { get; }
Public ReadOnly Property BaseColors As ObservableCollection(Of Color)
    Get

Property Value

Type: ObservableCollection Color
The collection of palette base Color objects used to generate the palette.
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette.Colors Property

PaletteColors Property

Gets the read-only collection of Color objects in this palette.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyObservableCollection<Color> Colors { get; }
Public ReadOnly Property Colors As ReadOnlyObservableCollection(Of Color)
    Get

Property Value

Type: ReadOnlyObservableCollection Color
The read-only collection of Color objects in this palette.
Remarks
This collection includes the BaseColors values, along with other shade variants if the IsShadeGenerationEnabled property is set to true.
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
PaletteIsShadeGenerationEnabled


Palette.ColorSelectionHint Property

PaletteColorSelectionHint Property

Gets or sets a ColorSelectionHint that provides a hint on how to perform color selection for this palette.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorSelectionHint ColorSelectionHint { get; set; }
Public Property ColorSelectionHint As ColorSelectionHint
    Get
    Set

Property Value

Type: ColorSelectionHint
A ColorSelectionHint that provides a hint on how to perform color selection for this palette. The default hint is UniformDistribution.
Remarks
See the documentation on the ColorSelectionHint for more information on usage.
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette.IsShadeGenerationEnabled Property

PaletteIsShadeGenerationEnabled Property

Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsShadeGenerationEnabled { get; set; }
Public Property IsShadeGenerationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if shade generation is enabled; otherwise, false.
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette.Kind Property

PaletteKind Property

Gets or sets a PaletteKind that indicates the built-in palette to use.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PaletteKind Kind { get; set; }
Public Property Kind As PaletteKind
    Get
    Set

Property Value

Type: PaletteKind
A PaletteKind that indicates the built-in palette to use.
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette Methods

The Palette type exposes the following members.

Methods
 | Name | Description
Protected method | OnChanged | Raises the Changed event.
Top
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette.OnChanged Method

PaletteOnChanged Method

Raises the Changed event.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnChanged(
    EventArgs e
)
Protected Overridable Sub OnChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette Events

The Palette type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the palette has been changed.
Top
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


Palette.Changed Event

PaletteChanged Event

Occurs after the palette has been changed.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler Changed
Public Event Changed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Palette Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteConverter Class

Represents a type converter for the Palette type.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.Windows.Controls.Charts.PalettesPaletteConverter

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class PaletteConverter : TypeConverter
Public NotInheritable Class PaletteConverter
    Inherits TypeConverter

The PaletteConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PaletteConverter | Initializes a new instance of the PaletteConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteConverter Constructor

Initializes a new instance of the PaletteConverter class

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PaletteConverter()
Public Sub New
See Also

Reference

PaletteConverter Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteConverter Methods

The PaletteConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

PaletteConverter Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteConverter.CanConvertFrom Method

PaletteConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

PaletteConverter Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

PaletteConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether the type converter can convert an object from the specified type to the type of this converter.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
sourceType
Type: SystemType
The type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

PaletteConverter Class
CanConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteConverter.ConvertFrom Method

PaletteConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

PaletteConverter Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

PaletteConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts from the specified value to the intended conversion type of the converter.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The value to convert to the type of this converter.

Return Value

Type: Object
The converted value.
See Also

Reference

PaletteConverter Class
ConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteData Class

Stores palette data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PalettesPaletteData
ActiproSoftware.Windows.Controls.Charts.PalettesSeriesPaletteData

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PaletteData
Public Class PaletteData

The PaletteData type exposes the following members.

Constructors
 | Name | Description
Public method | PaletteData | Initializes a new instance of the PaletteData class
Top
Properties
 | Name | Description
Public property | Color | Gets or sets the palette color.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteData Constructor

Initializes a new instance of the PaletteData class

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PaletteData()
Public Sub New
See Also

Reference

PaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteData Properties

The PaletteData type exposes the following members.

Properties
 | Name | Description
Public property | Color | Gets or sets the palette color.
Top
See Also

Reference

PaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteData.Color Property

PaletteDataColor Property

Gets or sets the palette color.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public UIColor Color { get; set; }
Public Property Color As UIColor
    Get
    Set

Property Value

Type: UIColor
The palette color.
See Also

Reference

PaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteKind Enumeration

Specifies the built-in palette options for a SeriesPaletteStyleSelector.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PaletteKind
Public Enumeration PaletteKind
Members
Member name | Value | Description
Default | 0 | The default colors.
Autumn | 1 | Red to green colors.
Beach | 2 | Blue, yellow, and green colors.
Earth | 3 | Yellow and brown colors.
Fishbowl | 4 | Blue, tan, and orange colors.
Forest | 5 | Green, blue, and brown colors.
IceCream | 6 | Muted blue, beige, and pink colors.
Melon | 7 | Muted pastel colors.
Mesa | 8 | Blue/green, tan, and red colors.
Plum | 9 | Purple colors.
Rainbow | 10 | Rainbow colors.
Retro | 11 | Purple, orange, and green colors.
Roman | 12 | Red, tan, and blue colors.
Rose | 13 | Rose reddish colors.
Sand | 14 | Muted blue and tan colors.
Sea | 15 | Blue and green colors.
Tulip | 16 | Red, green, yellow, and purple colors.
Vibrant | 17 | Magenta, blue, and green colors.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T) Class

PaletteStyleSelectorBaseT Class

The base class for style selectors that use palettes.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PalettesPaletteStyleSelectorBaseT
ActiproSoftware.Windows.Controls.Charts.PalettesPieSlicePaletteStyleSelector
ActiproSoftware.Windows.Controls.Charts.PalettesSeriesPaletteStyleSelector

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PaletteStyleSelectorBase<T>
where T : new(), PaletteData

Public Class PaletteStyleSelectorBase(Of T As {New, PaletteData})

Type Parameters

T
The type of PaletteData.

The PaletteStyleSelectorBaseT type exposes the following members.

Properties
 | Name | Description
Public property | Palette | Gets or sets the Palette of colors to use.
Top
Methods
 | Name | Description
Protected method | GetPaletteData | Returns the proper palette data for a given item.
Protected method | GetSettersFromStyle | Gets the setters from style.
Protected method | InvalidatePaletteData | Invalidates the palette data.
Top
Fields
Name | Description
UnsetColor | Gets the 'unset' color value.
UnsetStrokeThickness | Gets the 'unset' stroke thickness value.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T) Properties

PaletteStyleSelectorBaseT Properties

The PaletteStyleSelectorBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Palette | Gets or sets the Palette of colors to use.
Top
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).Palette Property

PaletteStyleSelectorBaseTPalette Property

Gets or sets the Palette of colors to use.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Palette Palette { get; set; }
Public Property Palette As Palette
    Get
    Set

Property Value

Type: Palette
The Palette of colors to use.
Exceptions
Exception | Condition
ArgumentNullException | value
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T) Methods

PaletteStyleSelectorBaseT Methods

The PaletteStyleSelectorBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | GetPaletteData | Returns the proper palette data for a given item.
Protected method | GetSettersFromStyle | Gets the setters from style.
Protected method | InvalidatePaletteData | Invalidates the palette data.
Top
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).GetPaletteData Method

PaletteStyleSelectorBaseTGetPaletteData Method

Returns the proper palette data for a given item.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected T GetPaletteData(
    int index,
    int count
)
Protected Function GetPaletteData (
    index As Integer,
    count As Integer
) As T

Parameters

index
Type: SystemInt32
The item index.
count
Type: SystemInt32
The item count.

Return Value

Type: T
The proper palette data for a given item.
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).GetSettersFromStyle Method

PaletteStyleSelectorBaseTGetSettersFromStyle Method

Gets the setters from style.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IEnumerable<Setter> GetSettersFromStyle(
    Style defaultStyle
)
Protected Function GetSettersFromStyle (
    defaultStyle As Style
) As IEnumerable(Of Setter)

Parameters

defaultStyle
Type: System.WindowsStyle
The default style.

Return Value

Type: IEnumerable Setter
An IEnumerableT of setters from a given style.
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).InvalidatePaletteData Method

PaletteStyleSelectorBaseTInvalidatePaletteData Method

Invalidates the palette data.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void InvalidatePaletteData()
Protected Sub InvalidatePaletteData
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T) Fields

PaletteStyleSelectorBaseT Fields

The PaletteStyleSelectorBaseT generic type exposes the following members.

Fields
Name | Description
UnsetColor | Gets the 'unset' color value.
UnsetStrokeThickness | Gets the 'unset' stroke thickness value.
Top
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).UnsetColor Field

PaletteStyleSelectorBaseTUnsetColor Field

Gets the 'unset' color value.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static readonly Color UnsetColor
Protected Shared ReadOnly UnsetColor As Color

Field Value

Type: Color
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).UnsetStrokeThickness Field

PaletteStyleSelectorBaseTUnsetStrokeThickness Field

Gets the 'unset' stroke thickness value.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected const double UnsetStrokeThickness = -1.79769313486232E+308
Protected Const UnsetStrokeThickness As Double = -1.79769313486232E+308

Field Value

Type: Double
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Class

Selects a style for a given PieSlice using a palette of colors.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PalettesPaletteStyleSelectorBase PaletteData
ActiproSoftware.Windows.Controls.Charts.PalettesPieSlicePaletteStyleSelector

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PieSlicePaletteStyleSelector : PaletteStyleSelectorBase<PaletteData>,
    IPieSliceStyleSelector
Public Class PieSlicePaletteStyleSelector
    Inherits PaletteStyleSelectorBase(Of PaletteData)
    Implements IPieSliceStyleSelector

The PieSlicePaletteStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PieSlicePaletteStyleSelector | Initializes a new instance of the PieSlicePaletteStyleSelector class.
Public method | PieSlicePaletteStyleSelector(Palette) | Initializes a new instance of the PieSlicePaletteStyleSelector class.
Top
Properties
 | Name | Description
Public property | Palette | Gets or sets the Palette of colors to use. (Inherited from PaletteStyleSelectorBaseT.)
Top
Methods
 | Name | Description
Protected method | GetPaletteData | Returns the proper palette data for a given item. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | GetSettersFromStyle | Gets the setters from style. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | InvalidatePaletteData | Invalidates the palette data. (Inherited from PaletteStyleSelectorBaseT.)
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. Style must have TargetType of PieSlice.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Constructor

Overload List
 | Name | Description
Public method | PieSlicePaletteStyleSelector | Initializes a new instance of the PieSlicePaletteStyleSelector class.
Public method | PieSlicePaletteStyleSelector(Palette) | Initializes a new instance of the PieSlicePaletteStyleSelector class.
Top
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Constructor

Initializes a new instance of the PieSlicePaletteStyleSelector class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSlicePaletteStyleSelector()
Public Sub New
See Also

Reference

PieSlicePaletteStyleSelector Class
PieSlicePaletteStyleSelector Overload
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Constructor (Palette)

Initializes a new instance of the PieSlicePaletteStyleSelector class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSlicePaletteStyleSelector(
    Palette palette
)
Public Sub New (
    palette As Palette
)

Parameters

palette
Type: ActiproSoftware.Windows.Controls.Charts.PalettesPalette
The Palette of colors to use.
See Also

Reference

PieSlicePaletteStyleSelector Class
PieSlicePaletteStyleSelector Overload
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Properties

The PieSlicePaletteStyleSelector type exposes the following members.

Properties
 | Name | Description
Public property | Palette | Gets or sets the Palette of colors to use. (Inherited from PaletteStyleSelectorBaseT.)
Top
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Methods

The PieSlicePaletteStyleSelector type exposes the following members.

Methods
 | Name | Description
Protected method | GetPaletteData | Returns the proper palette data for a given item. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | GetSettersFromStyle | Gets the setters from style. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | InvalidatePaletteData | Invalidates the palette data. (Inherited from PaletteStyleSelectorBaseT.)
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. Style must have TargetType of PieSlice.
Top
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector.SelectChildPieSliceStyle Method

PieSlicePaletteStyleSelectorSelectChildPieSliceStyle Method

Selects the child pie slice style. Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style SelectChildPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Color parentFill,
    Style defaultStyle
)
Public Function SelectChildPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    parentFill As Color,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
parentFill
Type: System.Windows.MediaColor
The parent fill color.
defaultStyle
Type: System.WindowsStyle
The default style.

Return Value

Type: Style
A Style for PieSlice.

Implements

IPieSliceStyleSelectorSelectChildPieSliceStyle(Int32, Int32, Color, Style)
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector.SelectPieSliceStyle Method

PieSlicePaletteStyleSelectorSelectPieSliceStyle Method

Selects the pie slice style. Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style SelectPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Style defaultStyle
)
Public Function SelectPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
defaultStyle
Type: System.WindowsStyle
The default style.

Return Value

Type: Style
A Style for PieSlice.

Implements

IPieSliceStyleSelectorSelectPieSliceStyle(Int32, Int32, Style)
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesBrushKind Enumeration

Specifies the kind of brush to use for a series element.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SeriesBrushKind
Public Enumeration SeriesBrushKind
Members
Member name | Value | Description
Default | 0 | Use the exact palette color.
Light | 1 | Use a slightly lighter version of the palette color.
Dark | 2 | Use a slightly darker version of the palette color.
SemiTransparent | 3 | Use a semi-transparent version of the palette color.
SemiTransparentGradient | 4 | Use a gradient, from a semi-transparent version of the palette color to an almost completely transparent version of the palette color.
DarkToLightGradient | 5 | Use a gradient, from the Dark to Light color.
LightToDarkGradient | 6 | Use a gradient, from the Light to Dark color.
CylinderGradient | 7 | Use a gradient, creating a cylindrical appearance.
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData Class

Stores series-related palette data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PalettesPaletteData
ActiproSoftware.Windows.Controls.Charts.PalettesSeriesPaletteData

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SeriesPaletteData : PaletteData
Public Class SeriesPaletteData
    Inherits PaletteData

The SeriesPaletteData type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesPaletteData | Initializes a new instance of the SeriesPaletteData class
Top
Properties
 | Name | Description
Public property | AreaHorizontalBrush | Gets or sets a cached Brush used for horizontal area series.
Public property | AreaVerticalBrush | Gets or sets a cached Brush used for vertical area series.
Public property | BarHorizontalBrush | Gets or sets a cached Brush used for horizontal bar series.
Public property | BarStrokeBrush | Gets or sets a cached Brush used for the stroke around bar series.
Public property | BarVerticalBrush | Gets or sets a cached Brush used for vertical bar series.
Public property | Color | Gets or sets the palette color. (Inherited from PaletteData.)
Public property | LegendBrush | Gets or sets a cached Brush.
Public property | LineBrush | Gets or sets a cached Brush.
Public property | MarkerBrush | Gets or sets a cached Brush.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData Constructor

Initializes a new instance of the SeriesPaletteData class

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesPaletteData()
Public Sub New
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData Properties

The SeriesPaletteData type exposes the following members.

Properties
 | Name | Description
Public property | AreaHorizontalBrush | Gets or sets a cached Brush used for horizontal area series.
Public property | AreaVerticalBrush | Gets or sets a cached Brush used for vertical area series.
Public property | BarHorizontalBrush | Gets or sets a cached Brush used for horizontal bar series.
Public property | BarStrokeBrush | Gets or sets a cached Brush used for the stroke around bar series.
Public property | BarVerticalBrush | Gets or sets a cached Brush used for vertical bar series.
Public property | Color | Gets or sets the palette color. (Inherited from PaletteData.)
Public property | LegendBrush | Gets or sets a cached Brush.
Public property | LineBrush | Gets or sets a cached Brush.
Public property | MarkerBrush | Gets or sets a cached Brush.
Top
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData.AreaHorizontalBrush Property

SeriesPaletteDataAreaHorizontalBrush Property

Gets or sets a cached Brush used for horizontal area series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush AreaHorizontalBrush { get; set; }
Public Property AreaHorizontalBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for horizontal area series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData.AreaVerticalBrush Property

SeriesPaletteDataAreaVerticalBrush Property

Gets or sets a cached Brush used for vertical area series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush AreaVerticalBrush { get; set; }
Public Property AreaVerticalBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for vertical area series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData.BarHorizontalBrush Property

SeriesPaletteDataBarHorizontalBrush Property

Gets or sets a cached Brush used for horizontal bar series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BarHorizontalBrush { get; set; }
Public Property BarHorizontalBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for horizontal bar series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData.BarStrokeBrush Property

SeriesPaletteDataBarStrokeBrush Property

Gets or sets a cached Brush used for the stroke around bar series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BarStrokeBrush { get; set; }
Public Property BarStrokeBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for the stroke around bar series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData.BarVerticalBrush Property

SeriesPaletteDataBarVerticalBrush Property

Gets or sets a cached Brush used for vertical bar series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BarVerticalBrush { get; set; }
Public Property BarVerticalBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for vertical bar series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData.LegendBrush Property

SeriesPaletteDataLegendBrush Property

Gets or sets a cached Brush.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LegendBrush { get; set; }
Public Property LegendBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData.LineBrush Property

SeriesPaletteDataLineBrush Property

Gets or sets a cached Brush.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LineBrush { get; set; }
Public Property LineBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteData.MarkerBrush Property

SeriesPaletteDataMarkerBrush Property

Gets or sets a cached Brush.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush MarkerBrush { get; set; }
Public Property MarkerBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Class

Provides a way to apply series styles based on a palette of colors.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PalettesPaletteStyleSelectorBase SeriesPaletteData
ActiproSoftware.Windows.Controls.Charts.PalettesSeriesPaletteStyleSelector

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SeriesPaletteStyleSelector : PaletteStyleSelectorBase<SeriesPaletteData>,
    ISeriesStyleSelector
Public Class SeriesPaletteStyleSelector
    Inherits PaletteStyleSelectorBase(Of SeriesPaletteData)
    Implements ISeriesStyleSelector

The SeriesPaletteStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesPaletteStyleSelector | Initializes a new instance of the SeriesPaletteStyleSelector class.
Public method | SeriesPaletteStyleSelector(Palette) | Initializes a new instance of the SeriesPaletteStyleSelector class.
Top
Properties
 | Name | Description
Public property | AreaBrushCustom | Gets or sets the custom Brush to use for areas.
Public property | AreaBrushKind | Gets or sets the kind of brush to use for areas.
Public property | AreaTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.
Public property | BarBrushCustom | Gets or sets the custom Brush to use for the fill inside bars.
Public property | BarBrushKind | Gets or sets the kind of brush to use for the fill inside bars.
Public property | BarStrokeBrushCustom | Gets or sets the custom Brush to use for the stroke around bars.
Public property | BarStrokeBrushKind | Gets or sets the kind of brush to use for the stroke around bars.
Public property | BarStrokeThickness | Gets or sets the thickness of the stroke around bars.
Public property | BarStrokeTintColor | Gets or sets the tint color to apply to the resulting brush from the BarStrokeBrushKind setting.
Public property | BarTintColor | Gets or sets the tint color to apply to the resulting brush from the BarBrushKind setting.
Public property | LineBrushCustom | Gets or sets the custom Brush to use for lines.
Public property | LineBrushKind | Gets or sets the kind of brush to use for lines.
Public property | LineTintColor | Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.
Public property | MarkerBrushCustom | Gets or sets the custom Brush to use for markers.
Public property | MarkerBrushKind | Gets or sets the kind of brush to use for markers.
Public property | MarkerTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.
Public property | Palette | Gets or sets the Palette of colors to use. (Inherited from PaletteStyleSelectorBaseT.)
Top
Methods
 | Name | Description
Protected method | GetPaletteData | Returns the proper palette data for a given item. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | GetSettersFromStyle | Gets the setters from style. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | InvalidatePaletteData | Invalidates the palette data. (Inherited from PaletteStyleSelectorBaseT.)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the area Style to use for the specified bar series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Constructor

Overload List
 | Name | Description
Public method | SeriesPaletteStyleSelector | Initializes a new instance of the SeriesPaletteStyleSelector class.
Public method | SeriesPaletteStyleSelector(Palette) | Initializes a new instance of the SeriesPaletteStyleSelector class.
Top
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Constructor

Initializes a new instance of the SeriesPaletteStyleSelector class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesPaletteStyleSelector()
Public Sub New
See Also

Reference

SeriesPaletteStyleSelector Class
SeriesPaletteStyleSelector Overload
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Constructor (Palette)

Initializes a new instance of the SeriesPaletteStyleSelector class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesPaletteStyleSelector(
    Palette palette
)
Public Sub New (
    palette As Palette
)

Parameters

palette
Type: ActiproSoftware.Windows.Controls.Charts.PalettesPalette
The Palette of colors to use.
See Also

Reference

SeriesPaletteStyleSelector Class
SeriesPaletteStyleSelector Overload
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Properties

The SeriesPaletteStyleSelector type exposes the following members.

Properties
 | Name | Description
Public property | AreaBrushCustom | Gets or sets the custom Brush to use for areas.
Public property | AreaBrushKind | Gets or sets the kind of brush to use for areas.
Public property | AreaTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.
Public property | BarBrushCustom | Gets or sets the custom Brush to use for the fill inside bars.
Public property | BarBrushKind | Gets or sets the kind of brush to use for the fill inside bars.
Public property | BarStrokeBrushCustom | Gets or sets the custom Brush to use for the stroke around bars.
Public property | BarStrokeBrushKind | Gets or sets the kind of brush to use for the stroke around bars.
Public property | BarStrokeThickness | Gets or sets the thickness of the stroke around bars.
Public property | BarStrokeTintColor | Gets or sets the tint color to apply to the resulting brush from the BarStrokeBrushKind setting.
Public property | BarTintColor | Gets or sets the tint color to apply to the resulting brush from the BarBrushKind setting.
Public property | LineBrushCustom | Gets or sets the custom Brush to use for lines.
Public property | LineBrushKind | Gets or sets the kind of brush to use for lines.
Public property | LineTintColor | Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.
Public property | MarkerBrushCustom | Gets or sets the custom Brush to use for markers.
Public property | MarkerBrushKind | Gets or sets the kind of brush to use for markers.
Public property | MarkerTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.
Public property | Palette | Gets or sets the Palette of colors to use. (Inherited from PaletteStyleSelectorBaseT.)
Top
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.AreaBrushCustom Property

SeriesPaletteStyleSelectorAreaBrushCustom Property

Gets or sets the custom Brush to use for areas.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush AreaBrushCustom { get; set; }
Public Property AreaBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for areas.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorAreaBrushKind


SeriesPaletteStyleSelector.AreaBrushKind Property

SeriesPaletteStyleSelectorAreaBrushKind Property

Gets or sets the kind of brush to use for areas.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesBrushKind AreaBrushKind { get; set; }
Public Property AreaBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for areas.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorAreaBrushCustom
SeriesPaletteStyleSelectorAreaTintColor


SeriesPaletteStyleSelector.AreaTintColor Property

SeriesPaletteStyleSelectorAreaTintColor Property

Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color AreaTintColor { get; set; }
Public Property AreaTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorAreaBrushKind


SeriesPaletteStyleSelector.BarBrushCustom Property

SeriesPaletteStyleSelectorBarBrushCustom Property

Gets or sets the custom Brush to use for the fill inside bars.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BarBrushCustom { get; set; }
Public Property BarBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the fill inside bars.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the BarBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarBrushKind


SeriesPaletteStyleSelector.BarBrushKind Property

SeriesPaletteStyleSelectorBarBrushKind Property

Gets or sets the kind of brush to use for the fill inside bars.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesBrushKind BarBrushKind { get; set; }
Public Property BarBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for the fill inside bars.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarTintColor


SeriesPaletteStyleSelector.BarStrokeBrushCustom Property

SeriesPaletteStyleSelectorBarStrokeBrushCustom Property

Gets or sets the custom Brush to use for the stroke around bars.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BarStrokeBrushCustom { get; set; }
Public Property BarStrokeBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the stroke around bars.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the BarStrokeBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarStrokeBrushKind


SeriesPaletteStyleSelector.BarStrokeBrushKind Property

SeriesPaletteStyleSelectorBarStrokeBrushKind Property

Gets or sets the kind of brush to use for the stroke around bars.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesBrushKind BarStrokeBrushKind { get; set; }
Public Property BarStrokeBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for the stroke around bars.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarStrokeBrushCustom
SeriesPaletteStyleSelectorBarStrokeTintColor


SeriesPaletteStyleSelector.BarStrokeThickness Property

SeriesPaletteStyleSelectorBarStrokeThickness Property

Gets or sets the thickness of the stroke around bars.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double BarStrokeThickness { get; set; }
Public Property BarStrokeThickness As Double
    Get
    Set

Property Value

Type: Double
A NullableT indicating the thickness of the stroke around bars.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.BarStrokeTintColor Property

SeriesPaletteStyleSelectorBarStrokeTintColor Property

Gets or sets the tint color to apply to the resulting brush from the BarStrokeBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color BarStrokeTintColor { get; set; }
Public Property BarStrokeTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarStrokeBrushKind


SeriesPaletteStyleSelector.BarTintColor Property

SeriesPaletteStyleSelectorBarTintColor Property

Gets or sets the tint color to apply to the resulting brush from the BarBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color BarTintColor { get; set; }
Public Property BarTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarBrushKind


SeriesPaletteStyleSelector.LineBrushCustom Property

SeriesPaletteStyleSelectorLineBrushCustom Property

Gets or sets the custom Brush to use for lines.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LineBrushCustom { get; set; }
Public Property LineBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for lines.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the LineBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorLineBrushKind


SeriesPaletteStyleSelector.LineBrushKind Property

SeriesPaletteStyleSelectorLineBrushKind Property

Gets or sets the kind of brush to use for lines.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesBrushKind LineBrushKind { get; set; }
Public Property LineBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for lines.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorLineBrushCustom
SeriesPaletteStyleSelectorLineTintColor


SeriesPaletteStyleSelector.LineTintColor Property

SeriesPaletteStyleSelectorLineTintColor Property

Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color LineTintColor { get; set; }
Public Property LineTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorLineBrushKind


SeriesPaletteStyleSelector.MarkerBrushCustom Property

SeriesPaletteStyleSelectorMarkerBrushCustom Property

Gets or sets the custom Brush to use for markers.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush MarkerBrushCustom { get; set; }
Public Property MarkerBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for markers.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorMarkerBrushKind


SeriesPaletteStyleSelector.MarkerBrushKind Property

SeriesPaletteStyleSelectorMarkerBrushKind Property

Gets or sets the kind of brush to use for markers.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesBrushKind MarkerBrushKind { get; set; }
Public Property MarkerBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for markers.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorMarkerBrushCustom
SeriesPaletteStyleSelectorMarkerTintColor


SeriesPaletteStyleSelector.MarkerTintColor Property

SeriesPaletteStyleSelectorMarkerTintColor Property

Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color MarkerTintColor { get; set; }
Public Property MarkerTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorMarkerBrushKind


SeriesPaletteStyleSelector Methods

The SeriesPaletteStyleSelector type exposes the following members.

Methods
 | Name | Description
Protected method | GetPaletteData | Returns the proper palette data for a given item. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | GetSettersFromStyle | Gets the setters from style. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | InvalidatePaletteData | Invalidates the palette data. (Inherited from PaletteStyleSelectorBaseT.)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the area Style to use for the specified bar series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectAreaStyle Method

SeriesPaletteStyleSelectorSelectAreaStyle Method

Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectAreaStyle(SeriesBase, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectBarStyle Method

SeriesPaletteStyleSelectorSelectBarStyle Method

Returns the area Style to use for the specified bar series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectBarStyle(
    SeriesBase series,
    int barIndex,
    int barCount,
    Style defaultStyle
)
Public Overridable Function SelectBarStyle (
    series As SeriesBase,
    barIndex As Integer,
    barCount As Integer,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
barIndex
Type: SystemInt32
The zero-based index of the bar.
barCount
Type: SystemInt32
The number of bars.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified bar series.

Implements

ISeriesStyleSelectorSelectBarStyle(SeriesBase, Int32, Int32, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectLegendMarkerStyle Method

SeriesPaletteStyleSelectorSelectLegendMarkerStyle Method

Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectLegendMarkerStyle(
    XYSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLegendMarkerStyle (
    series As XYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectLegendMarkerStyle(XYSeriesBase, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectLineStyle Method

SeriesPaletteStyleSelectorSelectLineStyle Method

Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectLineStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLineStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectLineStyle(SeriesBase, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectMarkerStyle Method

SeriesPaletteStyleSelectorSelectMarkerStyle Method

Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Palettes
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectMarkerStyle(SeriesBase, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.Charts.Palettes Namespace


ActiproSoftware.Windows.Controls.Charts.Primitives Namespace

Contains the primitive classes used for charts.
Classes
 | Class | Description
Public class | AxisTick | Represents a tick on an axis.
Public class | AxisVisual | Visualizes a given axis.
Public class | BarSeriesBase | Represents a base class for bar series used in a XYChart.
Public class | ChartCanvas | Represents a panel were child elements are positioned using explicit/relative coordinates.
Public class | ChartPanel | ChartPanel is responsible for orchestrating the layout / arrangement of different chart elements, and the order in which they refresh, measure, and arrange.
Public class | ConvertibleTypeConverterT | Implements a TypeConverter that allows any IConvertible type to be converted to a T.
Public class | DataPointBase | Represents a base class for a data point presented by a chart series.
Public class | DataPointLabeler | Responsible for displaying labels for data points.
Public class | DateTimeInterval | Represents an interval of time.
Public class | DesignTimeData | Used to display sample chart data at design-time.
Public class | GridVisual | Draws a grid behind the chart at major and minor points on the X and Y axis.
Public class | InvalidPropertyPathException | InvalidPropertyPathException is an exception for use when a PropertyPath is invalid.
Public class | LabelInfo | Information that describes a data point label.
Public class | Legend | The legend control used to display a collection of LegendKey in a chart.
Public class | LegendItem | Represents an item used in a chart legend.
Public class | LineSeriesBase | Represents a base class for line and area series for use in a XYChart.
Public class | PieSlice | A single pie slice in a pie series.
Public class | SeriesBase | Provides the base class for a series.
Public class | SeriesItemsSourceConverter | Represents a type converter for the ItemsSource type.
Public class | XAxisVisual | Draws an axis given axis data.
Public class | XYAxisBase | Represents the base functionality of a chart axis.
Public class | XYSeriesBase | Provides the base class for a series that uses an X/Y axis.
Public class | YAxisVisual | Draws an axis given axis data.


AxisTick Class

Represents a tick on an axis.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PrimitivesAxisTick

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AxisTick
Public Class AxisTick

The AxisTick type exposes the following members.

Constructors
 | Name | Description
Public method | AxisTick(Double) | Initializes a new instance of the AxisTick class.
Public method | AxisTick(String, Double) | Initializes a new instance of the AxisTick class.
Top
Properties
 | Name | Description
Public property | Label | The String representation of the data at the tick point.
Public property | Position | The position on the axis that the tick resides.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified AxisTick is equal to the current AxisTick. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick Constructor

Overload List
 | Name | Description
Public method | AxisTick(Double) | Initializes a new instance of the AxisTick class.
Public method | AxisTick(String, Double) | Initializes a new instance of the AxisTick class.
Top
See Also

Reference

AxisTick Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick Constructor (Double)

Initializes a new instance of the AxisTick class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AxisTick(
    double position
)
Public Sub New (
    position As Double
)

Parameters

position
Type: SystemDouble
The position.
See Also

Reference

AxisTick Class
AxisTick Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick Constructor (String, Double)

Initializes a new instance of the AxisTick class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AxisTick(
    string label,
    double position
)
Public Sub New (
    label As String,
    position As Double
)

Parameters

label
Type: SystemString
The label.
position
Type: SystemDouble
The position.
See Also

Reference

AxisTick Class
AxisTick Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick Properties

The AxisTick type exposes the following members.

Properties
 | Name | Description
Public property | Label | The String representation of the data at the tick point.
Public property | Position | The position on the axis that the tick resides.
Top
See Also

Reference

AxisTick Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick.Label Property

AxisTickLabel Property

The String representation of the data at the tick point.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Label { get; }
Public ReadOnly Property Label As String
    Get

Property Value

Type: String
See Also

Reference

AxisTick Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick.Position Property

AxisTickPosition Property

The position on the axis that the tick resides.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Position { get; }
Public ReadOnly Property Position As Double
    Get

Property Value

Type: Double
See Also

Reference

AxisTick Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick Methods

The AxisTick type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified AxisTick is equal to the current AxisTick. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

AxisTick Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick.Equals Method

AxisTickEquals Method

Determines whether the specified AxisTick is equal to the current AxisTick.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The AxisTick to compare with the current AxisTick.

Return Value

Type: Boolean
true if the specified AxisTick is equal to the current AxisTick; otherwise, false.
See Also

Reference

AxisTick Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick.GetHashCode Method

AxisTickGetHashCode Method

Serves as a hash function for a particular type.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

AxisTick Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisTick.ToString Method

AxisTickToString Method

Returns a String that represents this instance.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

AxisTick Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual Class

Visualizes a given axis.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesAxisVisual
ActiproSoftware.Windows.Controls.Charts.PrimitivesXAxisVisual
ActiproSoftware.Windows.Controls.Charts.PrimitivesYAxisVisual

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class AxisVisual : Control
Public MustInherit Class AxisVisual
    Inherits Control

The AxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary.
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible.
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
 | DrawLineOnGeometry | Draws a line on a given geometry.
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis.
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis.
Protected method | DrawSpine | Draws an axis spine.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetRealNumberOrDefault | Provides the given argumentValue if it is not infinity, otherwise provides the given default argumentValue.
 | GetTextBlockMeasuredSize | Gets the measured size of the text block.
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsSpineVisible | Determines whether or not the spine is visible.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Redraws the axis.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateTitlePosition | Updates the title position.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
Infinity | Size with width and height of infinity.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual Properties

The AxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary.
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.TickMajorMidPixel Property

AxisVisualTickMajorMidPixel Property

Gets the major tick position snapped to mid-pixel, if necessary.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double TickMajorMidPixel { get; }
Protected ReadOnly Property TickMajorMidPixel As Double
    Get

Return Value

Type: Double
The major tick position snapped to mid-pixel, if necessary.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.TickMinorMidPixel Property

AxisVisualTickMinorMidPixel Property

Gets the minor tick position snapped to mid-pixel, if necessary.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double TickMinorMidPixel { get; }
Protected ReadOnly Property TickMinorMidPixel As Double
    Get

Return Value

Type: Double
The minor tick position snapped to mid-pixel, if necessary.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual Methods

The AxisVisual type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible.
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
 | DrawLineOnGeometry | Draws a line on a given geometry.
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis.
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis.
Protected method | DrawSpine | Draws an axis spine.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetRealNumberOrDefault | Provides the given argumentValue if it is not infinity, otherwise provides the given default argumentValue.
 | GetTextBlockMeasuredSize | Gets the measured size of the text block.
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsSpineVisible | Determines whether or not the spine is visible.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Redraws the axis.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateTitlePosition | Updates the title position.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.AreAnyTicksVisible Method

AxisVisualAreAnyTicksVisible Method

Determines if any ticks are visible.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool AreAnyTicksVisible(
    Size plotSize
)
Protected Function AreAnyTicksVisible (
    plotSize As Size
) As Boolean

Parameters

plotSize
Type: System.WindowsSize
The plot size.

Return Value

Type: Boolean
True if any ticks are visible, otherwise false.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.DrawLineOnGeometry Method

AxisVisualDrawLineOnGeometry Method

Draws a line on a given geometry.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static void DrawLineOnGeometry(
    PathGeometry geometry,
    double x1,
    double y1,
    double x2,
    double y2
)
Protected Shared Sub DrawLineOnGeometry (
    geometry As PathGeometry,
    x1 As Double,
    y1 As Double,
    x2 As Double,
    y2 As Double
)

Parameters

geometry
Type: System.Windows.MediaPathGeometry
The PathGeometry to draw the line on.
x1
Type: SystemDouble
The starting X point of the line.
y1
Type: SystemDouble
The starting Y point of the line.
x2
Type: SystemDouble
The ending X point of the line.
y2
Type: SystemDouble
The ending Y point of the line.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.DrawMajorTickAtPosition Method

AxisVisualDrawMajorTickAtPosition Method

Draws a major tick at a given position on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void DrawMajorTickAtPosition(
    double position,
    Size plotSize
)
Protected MustOverride Sub DrawMajorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: System.WindowsSize
Size of the plot.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.DrawMinorTickAtPosition Method

AxisVisualDrawMinorTickAtPosition Method

Draws a minor tick at a given position on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void DrawMinorTickAtPosition(
    double position,
    Size plotSize
)
Protected MustOverride Sub DrawMinorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: System.WindowsSize
Size of the plot.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.DrawSpine Method

AxisVisualDrawSpine Method

Draws an axis spine.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void DrawSpine(
    Size plotSize
)
Protected MustOverride Sub DrawSpine (
    plotSize As Size
)

Parameters

plotSize
Type: System.WindowsSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.AxisVisual.DrawSpine(System.Windows.Size)"]

See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.GetRealNumberOrDefault Method

AxisVisualGetRealNumberOrDefault Method

Provides the given argumentValue if it is not infinity, otherwise provides the given default argumentValue.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static double GetRealNumberOrDefault(
    double value,
    double defaultValue
)
Protected Shared Function GetRealNumberOrDefault (
    value As Double,
    defaultValue As Double
) As Double

Parameters

value
Type: SystemDouble
The argumentValue to be returned if real.
defaultValue
Type: SystemDouble
The default argumentValue to be returned if the primary argumentValue is infinity.

Return Value

Type: Double
The argumentValue if it is not infinity, otherwise the default argumentValue.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.GetTextBlockMeasuredSize Method

AxisVisualGetTextBlockMeasuredSize Method

Gets the measured size of the text block.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static Size GetTextBlockMeasuredSize(
    TextBlock textBlock
)
Protected Shared Function GetTextBlockMeasuredSize (
    textBlock As TextBlock
) As Size

Parameters

textBlock
Type: System.Windows.ControlsTextBlock
The text block.

Return Value

Type: Size
The measured size of the text block.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.GetTitleTemplateFromResources Method

AxisVisualGetTitleTemplateFromResources Method

Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract DataTemplate GetTitleTemplateFromResources(
    ResourceDictionary resources
)
Protected MustOverride Function GetTitleTemplateFromResources (
    resources As ResourceDictionary
) As DataTemplate

Parameters

resources
Type: System.WindowsResourceDictionary
The ResourceDictionary to retrieve the title template from.

Return Value

Type: DataTemplate
The template for the axis title.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.IsSpineVisible Method

AxisVisualIsSpineVisible Method

Determines whether or not the spine is visible.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSpineVisible()
Public Function IsSpineVisible As Boolean

Return Value

Type: Boolean
true if the spine is visible; otherwise, false.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.OnApplyTemplate Method

AxisVisualOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.PlaceLabelAtPosition Method

AxisVisualPlaceLabelAtPosition Method

Place the axis label at the given position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void PlaceLabelAtPosition(
    TextBlock label,
    double position,
    double angle,
    Size plotSize
)
Protected MustOverride Sub PlaceLabelAtPosition (
    label As TextBlock,
    position As Double,
    angle As Double,
    plotSize As Size
)

Parameters

label
Type: System.Windows.ControlsTextBlock
The axis label to lay out.
position
Type: SystemDouble
The position to draw the axis label at.
angle
Type: SystemDouble
The angle to draw the axis label at.
plotSize
Type: System.WindowsSize
Size of the plot.
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.Refresh Method

AxisVisualRefresh Method

Redraws the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Refresh(
    Size plotSize
)
Public Overridable Sub Refresh (
    plotSize As Size
)

Parameters

plotSize
Type: System.WindowsSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.AxisVisual.Refresh(System.Windows.Size)"]

See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.UpdateTitlePosition Method

AxisVisualUpdateTitlePosition Method

Updates the title position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void UpdateTitlePosition(
    Size plotSize
)
Protected MustOverride Sub UpdateTitlePosition (
    plotSize As Size
)

Parameters

plotSize
Type: System.WindowsSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.AxisVisual.UpdateTitlePosition(System.Windows.Size)"]

See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual Events

The AxisVisual type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual Fields

The AxisVisual type exposes the following members.

Fields
Name | Description
Infinity | Size with width and height of infinity.
Top
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


AxisVisual.Infinity Field

AxisVisualInfinity Field

Size with width and height of infinity.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static readonly Size Infinity
Protected Shared ReadOnly Infinity As Size

Field Value

Type: Size
See Also

Reference

AxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase Class

Represents a base class for bar series used in a XYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesBarSeriesBase
ActiproSoftware.Windows.Controls.ChartsBarSeries

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class BarSeriesBase : XYSeriesBase
Public MustInherit Class BarSeriesBase
    Inherits XYSeriesBase

The BarSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | BarSeriesBase | Initializes a new instance of the BarSeriesBase class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarTemplate | Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out.
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Overrides SeriesBaseLogicalOrientation.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Overrides XYSeriesBaseRequiresSlottedLayout.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
Fields
Name | Description
BarStyleProperty | Identifies the BarStyle dependency property. This field is read-only.
BarTemplateProperty | Identifies the BarTemplate dependency property. This field is read-only.
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase Constructor

Initializes a new instance of the BarSeriesBase class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected BarSeriesBase()
Protected Sub New
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase Properties

The BarSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarTemplate | Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out.
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Overrides SeriesBaseLogicalOrientation.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Overrides XYSeriesBaseRequiresSlottedLayout.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.BarStyle Property

BarSeriesBaseBarStyle Property

Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style BarStyle { get; set; }
Public Property BarStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.BarTemplate Property

BarSeriesBaseBarTemplate Property

Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate BarTemplate { get; set; }
Public Property BarTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The bar template. The default value is .
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.LabelPositioningMode Property

BarSeriesBaseLabelPositioningMode Property

Gets or sets the LabelPositioningMode used to determine how labels are laid out.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LabelPositioningMode LabelPositioningMode { get; set; }
Public Property LabelPositioningMode As LabelPositioningMode
    Get
    Set

Property Value

Type: LabelPositioningMode
The label positioning mode. The default value is FromBaseline.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.LogicalOrientation Property

BarSeriesBaseLogicalOrientation Property

Gets the logical orientation of the series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Orientation LogicalOrientation { get; }
Public Overrides ReadOnly Property LogicalOrientation As Orientation
    Get

Property Value

Type: Orientation
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.MarkerVisibility Property

BarSeriesBaseMarkerVisibility Property

Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ChartMarkerVisibility MarkerVisibility { get; set; }
Public Property MarkerVisibility As ChartMarkerVisibility
    Get
    Set

Property Value

Type: ChartMarkerVisibility
A ChartMarkerVisibility indicating which markers are rendered along the series. The default value is ChartMarkerVisibility.None.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.MinimumMargin Property

BarSeriesBaseMinimumMargin Property

Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> MinimumMargin { get; }
Protected Overrides ReadOnly Property MinimumMargin As Nullable(Of Thickness)
    Get

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.Orientation Property

BarSeriesBaseOrientation Property

Gets or sets the orientation of the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the series. The default value is Orientation.Horizontal.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.RequiresSlottedLayout Property

BarSeriesBaseRequiresSlottedLayout Property

Gets a value indicating whether the series requires slotted layout.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool RequiresSlottedLayout { get; }
Public Overrides ReadOnly Property RequiresSlottedLayout As Boolean
    Get

Property Value

Type: Boolean
true if the series requires slotted layout; otherwise, false.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase Methods

The BarSeriesBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase Events

The BarSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase Fields

The BarSeriesBase type exposes the following members.

Fields
Name | Description
BarStyleProperty | Identifies the BarStyle dependency property. This field is read-only.
BarTemplateProperty | Identifies the BarTemplate dependency property. This field is read-only.
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.BarStyleProperty Field

BarSeriesBaseBarStyleProperty Field

Identifies the BarStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarStyleProperty
Public Shared ReadOnly BarStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarStyle dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.BarTemplateProperty Field

BarSeriesBaseBarTemplateProperty Field

Identifies the BarTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarTemplateProperty
Public Shared ReadOnly BarTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarTemplate dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.LabelPositioningModeProperty Field

BarSeriesBaseLabelPositioningModeProperty Field

Identifies the LabelPositioningMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositioningModeProperty
Public Shared ReadOnly LabelPositioningModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.MarkerVisibilityProperty Field

BarSeriesBaseMarkerVisibilityProperty Field

Identifies the MarkerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerVisibilityProperty
Public Shared ReadOnly MarkerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


BarSeriesBase.OrientationProperty Field

BarSeriesBaseOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas Class

Represents a panel were child elements are positioned using explicit/relative coordinates.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Charts.PrimitivesChartCanvas

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ChartCanvas : Panel
Public Class ChartCanvas
    Inherits Panel

The ChartCanvas type exposes the following members.

Constructors
 | Name | Description
Public method | ChartCanvas | Initializes a new instance of the ChartCanvas class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
 | GetX | Gets the value of the XProperty attached property for a specified element.
 | GetY | Gets the value of the YProperty attached property for a specified element.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetX | Sets the value of the XProperty attached property to a specified element.
 | SetY | Sets the value of the YProperty attached property to a specified element.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | X |
Public attached property | Y |
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas Constructor

Initializes a new instance of the ChartCanvas class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ChartCanvas()
Public Sub New
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas Properties

The ChartCanvas type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas Methods

The ChartCanvas type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
 | GetX | Gets the value of the XProperty attached property for a specified element.
 | GetY | Gets the value of the YProperty attached property for a specified element.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetX | Sets the value of the XProperty attached property to a specified element.
 | SetY | Sets the value of the YProperty attached property to a specified element.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.ArrangeOverride Method

ChartCanvasArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.GetX Method

ChartCanvasGetX Method

Gets the value of the XProperty attached property for a specified element.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetX(
    DependencyObject element
)
Public Shared Function GetX (
    element As DependencyObject
) As Double

Parameters

element
Type: System.WindowsDependencyObject
The element to which the attached property is retrieved.

Return Value

Type: Double
The X-coordinate value.
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.GetY Method

ChartCanvasGetY Method

Gets the value of the YProperty attached property for a specified element.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetY(
    DependencyObject element
)
Public Shared Function GetY (
    element As DependencyObject
) As Double

Parameters

element
Type: System.WindowsDependencyObject
The element to which the attached property is retrieved.

Return Value

Type: Double
The Y-coordinate value.
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.MeasureOverride Method

ChartCanvasMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.SetX Method

ChartCanvasSetX Method

Sets the value of the XProperty attached property to a specified element.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetX(
    DependencyObject element,
    double value
)
Public Shared Sub SetX (
    element As DependencyObject,
    value As Double
)

Parameters

element
Type: System.WindowsDependencyObject
The element to which the attached property is written.
value
Type: SystemDouble
The X-coordinate value.
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.SetY Method

ChartCanvasSetY Method

Sets the value of the YProperty attached property to a specified element.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetY(
    DependencyObject element,
    double value
)
Public Shared Sub SetY (
    element As DependencyObject,
    value As Double
)

Parameters

element
Type: System.WindowsDependencyObject
The element to which the attached property is written.
value
Type: SystemDouble
The Y-coordinate value.
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas Fields

The ChartCanvas type exposes the following members.

Fields
Name | Description
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.XProperty Field

ChartCanvasXProperty Field

Identifies the X dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XProperty
Public Shared ReadOnly XProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the X dependency property.
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.YProperty Field

ChartCanvasYProperty Field

Identifies the Y dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YProperty
Public Shared ReadOnly YProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Y dependency property.
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas Attached Properties

The ChartCanvas type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | X |
Public attached property | Y |
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.X Attached Property

ChartCanvasX Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Charts.Primitives.ChartCanvas.X"]

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetX, SetX
See GetX, SetX

Property Value

Type: Double
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartCanvas.Y Attached Property

ChartCanvasY Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Charts.Primitives.ChartCanvas.Y"]

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetY, SetY
See GetY, SetY

Property Value

Type: Double
See Also

Reference

ChartCanvas Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel Class

ChartPanel is responsible for orchestrating the layout / arrangement of different chart elements, and the order in which they refresh, measure, and arrange.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Charts.PrimitivesChartPanel

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ChartPanel : Panel
Public Class ChartPanel
    Inherits Panel

The ChartPanel type exposes the following members.

Constructors
 | Name | Description
Public method | ChartPanel | Initializes a new instance of the ChartPanel class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible.
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position.
Public property | LegendVerticalPosition | Gets or sets the legend vertical position.
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | PaddingPercentage | Gets or sets the padding percentage.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | Teardown | Tears down the control.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendVerticalPositionProperty | The legend vertical position property
PaddingPercentageProperty | The padding percentage property
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel Constructor

Initializes a new instance of the ChartPanel class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ChartPanel()
Public Sub New
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel Properties

The ChartPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible.
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position.
Public property | LegendVerticalPosition | Gets or sets the legend vertical position.
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | PaddingPercentage | Gets or sets the padding percentage.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.IsLegendVisible Property

ChartPanelIsLegendVisible Property

Gets or sets a value indicating whether this instance is legend visible.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsLegendVisible { get; set; }
Public Property IsLegendVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is legend visible; otherwise, false.
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.LegendHorizontalPosition Property

ChartPanelLegendHorizontalPosition Property

Gets or sets the legend horizontal position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LegendHorizontalPosition LegendHorizontalPosition { get; set; }
Public Property LegendHorizontalPosition As LegendHorizontalPosition
    Get
    Set

Property Value

Type: LegendHorizontalPosition
The legend horizontal position.
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.LegendVerticalPosition Property

ChartPanelLegendVerticalPosition Property

Gets or sets the legend vertical position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LegendVerticalPosition LegendVerticalPosition { get; set; }
Public Property LegendVerticalPosition As LegendVerticalPosition
    Get
    Set

Property Value

Type: LegendVerticalPosition
The legend vertical position.
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.PaddingPercentage Property

ChartPanelPaddingPercentage Property

Gets or sets the padding percentage.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness PaddingPercentage { get; set; }
Public Property PaddingPercentage As Thickness
    Get
    Set

Property Value

Type: Thickness
The padding percentage.
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel Methods

The ChartPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | Teardown | Tears down the control.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.ArrangeOverride Method

ChartPanelArrangeOverride Method

Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this object should use to arrange itself and its children.

Return Value

Type: Size
The actual size that is used after the element is arranged in layout.
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.MeasureOverride Method

ChartPanelMeasureOverride Method

Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this object can give to child objects. Infinity (PositiveInfinity) can be specified as a value to indicate that the object will size to whatever content is available.

Return Value

Type: Size
The size that this object determines it needs during layout, based on its calculations of the allocated sizes for child objects; or based on other considerations, such as a fixed container size.
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.Teardown Method

ChartPanelTeardown Method

Tears down the control.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Teardown()
Public Sub Teardown
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel Fields

The ChartPanel type exposes the following members.

Fields
Name | Description
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendVerticalPositionProperty | The legend vertical position property
PaddingPercentageProperty | The padding percentage property
Top
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.IsLegendVisibleProperty Field

ChartPanelIsLegendVisibleProperty Field

Identifies the IsLegendVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLegendVisibleProperty
Public Shared ReadOnly IsLegendVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLegendVisible dependency property.
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.LegendHorizontalPositionProperty Field

ChartPanelLegendHorizontalPositionProperty Field

Identifies the LegendHorizontalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendHorizontalPositionProperty
Public Shared ReadOnly LegendHorizontalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLegendVisible dependency property.
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.LegendVerticalPositionProperty Field

ChartPanelLegendVerticalPositionProperty Field

The legend vertical position property

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendVerticalPositionProperty
Public Shared ReadOnly LegendVerticalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ChartPanel.PaddingPercentageProperty Field

ChartPanelPaddingPercentageProperty Field

The padding percentage property

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PaddingPercentageProperty
Public Shared ReadOnly PaddingPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ChartPanel Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T) Class

ConvertibleTypeConverterT Class

Implements a TypeConverter that allows any IConvertible type to be converted to a T.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.Windows.Controls.Charts.PrimitivesConvertibleTypeConverterT

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ConvertibleTypeConverter<T> : TypeConverter

Public Class ConvertibleTypeConverter(Of T)
    Inherits TypeConverter

Type Parameters

T
The target type, which must be an IConvertible.

The ConvertibleTypeConverterT type exposes the following members.

Constructors
 | Name | Description
Public method | ConvertibleTypeConverterT | Initializes a new instance of the ConvertibleTypeConverterT class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T) Constructor

ConvertibleTypeConverterT Constructor

Initializes a new instance of the ConvertibleTypeConverterT class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ConvertibleTypeConverter()
Public Sub New
See Also

Reference

ConvertibleTypeConverterT Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T) Methods

ConvertibleTypeConverterT Methods

The ConvertibleTypeConverterT generic type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ConvertibleTypeConverterT Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T).CanConvertFrom Method

ConvertibleTypeConverterTCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

ConvertibleTypeConverterT Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T).CanConvertFrom Method (ITypeDescriptorContext, Type)

ConvertibleTypeConverterTCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

ConvertibleTypeConverterT Class
CanConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T).CanConvertTo Method

ConvertibleTypeConverterTCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

ConvertibleTypeConverterT Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T).CanConvertTo Method (ITypeDescriptorContext, Type)

ConvertibleTypeConverterTCanConvertTo Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: SystemType
A Type that represents the type you want to convert to.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

ConvertibleTypeConverterT Class
CanConvertTo Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T).ConvertFrom Method

ConvertibleTypeConverterTConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

ConvertibleTypeConverterT Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T).ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

ConvertibleTypeConverterTConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
Exceptions
Exception | Condition
NotSupportedException | The conversion cannot be performed.
See Also

Reference

ConvertibleTypeConverterT Class
ConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T).ConvertTo Method

ConvertibleTypeConverterTConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

ConvertibleTypeConverterT Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ConvertibleTypeConverter(T).ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

ConvertibleTypeConverterTConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
Exceptions
Exception | Condition
ArgumentNullException | The destinationType parameter is null.
NotSupportedException | The conversion cannot be performed.
See Also

Reference

ConvertibleTypeConverterT Class
ConvertTo Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointBase Class

Represents a base class for a data point presented by a chart series.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesDataPointBase
ActiproSoftware.Windows.Controls.ChartsXYDataPoint

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DataPointBase : ObservableObjectBase
Public MustInherit Class DataPointBase
    Inherits ObservableObjectBase

The DataPointBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DataPointBase | Initializes a new instance of the DataPointBase class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point.
Top
Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointBase Constructor

Initializes a new instance of the DataPointBase class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DataPointBase()
Protected Sub New
See Also

Reference

DataPointBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointBase Properties

The DataPointBase type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point.
Top
See Also

Reference

DataPointBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointBase.Index Property

DataPointBaseIndex Property

Gets or sets the index of the data point.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the data point; The default value is 0.
See Also

Reference

DataPointBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointBase Methods

The DataPointBase type exposes the following members.

Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DataPointBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointBase Events

The DataPointBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DataPointBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler Class

Responsible for displaying labels for data points.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesDataPointLabeler

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataPointLabeler : Control
Public Class DataPointLabeler
    Inherits Control

The DataPointLabeler type exposes the following members.

Constructors
 | Name | Description
Public method | DataPointLabeler | Initializes a new instance of the DataPointLabeler class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelCollisionMode | Gets or sets the label collision mode.
Public property | LabelExcess | Gets the excess space outside of bounds taken up by the labels.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PlotMargin | Gets or sets the plot margin.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddLabel | Adds a label based on a given LabelInfo.
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearLabels | Clears all labels.
Public method | FinalizeLabels | Finalizes the labels. Called after all labels have been added for this draw operation.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | NotifyMouseExited | Notifies that the mouse exited.
Public method | NotifyMouseMoved | Notifies that the mouse was moved.
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
LabelCollisionModeProperty | Identifies the LabelCollisionMode dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler Constructor

Initializes a new instance of the DataPointLabeler class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataPointLabeler()
Public Sub New
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler Properties

The DataPointLabeler type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelCollisionMode | Gets or sets the label collision mode.
Public property | LabelExcess | Gets the excess space outside of bounds taken up by the labels.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PlotMargin | Gets or sets the plot margin.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.LabelCollisionMode Property

DataPointLabelerLabelCollisionMode Property

Gets or sets the label collision mode.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LabelCollisionMode LabelCollisionMode { get; set; }
Public Property LabelCollisionMode As LabelCollisionMode
    Get
    Set

Property Value

Type: LabelCollisionMode
The label collision mode.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.LabelExcess Property

DataPointLabelerLabelExcess Property

Gets the excess space outside of bounds taken up by the labels.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Thickness LabelExcess { get; }
Public Overridable ReadOnly Property LabelExcess As Thickness
    Get

Property Value

Type: Thickness
The excess space outside of bounds taken up by the labels.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.PlotMargin Property

DataPointLabelerPlotMargin Property

Gets or sets the plot margin.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness PlotMargin { get; set; }
Public Property PlotMargin As Thickness
    Get
    Set

Property Value

Type: Thickness
The plot margin.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler Methods

The DataPointLabeler type exposes the following members.

Methods
 | Name | Description
Public method | AddLabel | Adds a label based on a given LabelInfo.
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearLabels | Clears all labels.
Public method | FinalizeLabels | Finalizes the labels. Called after all labels have been added for this draw operation.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | NotifyMouseExited | Notifies that the mouse exited.
Public method | NotifyMouseMoved | Notifies that the mouse was moved.
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.AddLabel Method

DataPointLabelerAddLabel Method

Adds a label based on a given LabelInfo.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void AddLabel(
    LabelInfo labelInfo
)
Public Overridable Sub AddLabel (
    labelInfo As LabelInfo
)

Parameters

labelInfo
Type: ActiproSoftware.Windows.Controls.Charts.PrimitivesLabelInfo
The label info to build the label from.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.ClearLabels Method

DataPointLabelerClearLabels Method

Clears all labels.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void ClearLabels()
Public Overridable Sub ClearLabels
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.FinalizeLabels Method

DataPointLabelerFinalizeLabels Method

Finalizes the labels. Called after all labels have been added for this draw operation.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void FinalizeLabels(
    Size plotSize
)
Public Sub FinalizeLabels (
    plotSize As Size
)

Parameters

plotSize
Type: System.WindowsSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.DataPointLabeler.FinalizeLabels(System.Windows.Size)"]

See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.NotifyMouseExited Method

DataPointLabelerNotifyMouseExited Method

Notifies that the mouse exited.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void NotifyMouseExited()
Public Sub NotifyMouseExited
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.NotifyMouseMoved Method

DataPointLabelerNotifyMouseMoved Method

Notifies that the mouse was moved.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void NotifyMouseMoved(
    Point mousePosition
)
Public Sub NotifyMouseMoved (
    mousePosition As Point
)

Parameters

mousePosition
Type: System.WindowsPoint
The mouse position.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.OnApplyTemplate Method

DataPointLabelerOnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler Events

The DataPointLabeler type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler Fields

The DataPointLabeler type exposes the following members.

Fields
Name | Description
LabelCollisionModeProperty | Identifies the LabelCollisionMode dependency property. This field is read-only.
Top
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DataPointLabeler.LabelCollisionModeProperty Field

DataPointLabelerLabelCollisionModeProperty Field

Identifies the LabelCollisionMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelCollisionModeProperty
Public Shared ReadOnly LabelCollisionModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelCollisionMode dependency property.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DateTimeInterval Class

Represents an interval of time.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PrimitivesDateTimeInterval

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DateTimeInterval
Public Class DateTimeInterval

The DateTimeInterval type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeInterval | Initializes a new instance of the DateTimeInterval class
Top
Properties
 | Name | Description
Public property | Unit | Gets or sets the unit of time represented by Value.
Public property | Value | Gets or sets the value of the interval.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Public method | ToTimeSpan | Converts the current DateTimeInterval to a TimeSpan.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DateTimeInterval Constructor

Initializes a new instance of the DateTimeInterval class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTimeInterval()
Public Sub New
See Also

Reference

DateTimeInterval Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DateTimeInterval Properties

The DateTimeInterval type exposes the following members.

Properties
 | Name | Description
Public property | Unit | Gets or sets the unit of time represented by Value.
Public property | Value | Gets or sets the value of the interval.
Top
See Also

Reference

DateTimeInterval Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DateTimeInterval.Unit Property

DateTimeIntervalUnit Property

Gets or sets the unit of time represented by Value.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<TimeUnit> Unit { get; set; }
Public Property Unit As Nullable(Of TimeUnit)
    Get
    Set

Property Value

Type: Nullable TimeUnit
The unit of time represented by Value.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace
DateTimeIntervalValue


DateTimeInterval.Value Property

DateTimeIntervalValue Property

Gets or sets the value of the interval.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<long> Value { get; set; }
Public Property Value As Nullable(Of Long)
    Get
    Set

Property Value

Type: Nullable Int64
The value of the interval.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace
DateTimeIntervalUnit


DateTimeInterval Methods

The DateTimeInterval type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Public method | ToTimeSpan | Converts the current DateTimeInterval to a TimeSpan.
Top
See Also

Reference

DateTimeInterval Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DateTimeInterval.Equals Method

DateTimeIntervalEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DateTimeInterval.GetHashCode Method

DateTimeIntervalGetHashCode Method

Returns a hash code for this instance.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DateTimeInterval.ToString Method

DateTimeIntervalToString Method

Returns a String that represents this instance.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DateTimeInterval.ToTimeSpan Method

DateTimeIntervalToTimeSpan Method

Converts the current DateTimeInterval to a TimeSpan.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan ToTimeSpan(
    DateTime dateTime
)
Public Function ToTimeSpan (
    dateTime As DateTime
) As TimeSpan

Parameters

dateTime
Type: SystemDateTime

[Missing <param name="dateTime"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.DateTimeInterval.ToTimeSpan(System.DateTime)"]

Return Value

Type: TimeSpan
A TimeSpan from the current DateTimeInterval.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DesignTimeData Class

Used to display sample chart data at design-time.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PrimitivesDesignTimeData

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DesignTimeData
Public Class DesignTimeData

The DesignTimeData type exposes the following members.

Constructors
 | Name | Description
Public method | DesignTimeData | Initializes a new instance of the DesignTimeData class
Top
Properties
 | Name | Description
Public property | Title | Gets or sets the title.
Public property | Value | Gets or sets the value.
Top
Methods
Name | Description
BuildDesignTimeData | Builds design-time data.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DesignTimeData Constructor

Initializes a new instance of the DesignTimeData class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DesignTimeData()
Public Sub New
See Also

Reference

DesignTimeData Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DesignTimeData Properties

The DesignTimeData type exposes the following members.

Properties
 | Name | Description
Public property | Title | Gets or sets the title.
Public property | Value | Gets or sets the value.
Top
See Also

Reference

DesignTimeData Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DesignTimeData.Title Property

DesignTimeDataTitle Property

Gets or sets the title.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title.
See Also

Reference

DesignTimeData Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DesignTimeData.Value Property

DesignTimeDataValue Property

Gets or sets the value.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value.
See Also

Reference

DesignTimeData Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DesignTimeData Methods

The DesignTimeData type exposes the following members.

Methods
Name | Description
BuildDesignTimeData | Builds design-time data.
Top
See Also

Reference

DesignTimeData Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


DesignTimeData.BuildDesignTimeData Method

DesignTimeDataBuildDesignTimeData Method

Builds design-time data.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IEnumerable<DesignTimeData> BuildDesignTimeData()
Public Shared Function BuildDesignTimeData As IEnumerable(Of DesignTimeData)

Return Value

Type: IEnumerable DesignTimeData
An IEnumerableT of sample data.
See Also

Reference

DesignTimeData Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual Class

Draws a grid behind the chart at major and minor points on the X and Y axis.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesGridVisual

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GridVisual : Control
Public Class GridVisual
    Inherits Control

The GridVisual type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LineMajorBrush | Gets or sets the line major brush.
Public property | LineMajorVisibility | Gets or sets the major line visibility.
Public property | LineMinorBrush | Gets or sets the line minor brush.
Public property | LineMinorVisibility | Gets or sets the minor line visibility.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | StripeAlternatingBrush | Gets or sets the brush used to fill alternate stripes.
Public property | StripeBrush | Gets or sets the brush used to fill stripes.
Public property | StripeVisibility | Gets or sets the stripe visibility.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Clears and redraws the grid.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
LineMajorBrushProperty | Identifies the LineMajorBrush dependency property. This field is read-only.
LineMajorVisibilityProperty | Identifies the LineMajorVisibility dependency property. This field is read-only.
LineMinorBrushProperty | Identifies the LineMinorBrush dependency property. This field is read-only.
LineMinorVisibilityProperty | Identifies the LineMinorVisibility dependency property. This field is read-only.
StripeAlternatingBrushProperty | Identifies the StripeAlternatingBrush dependency property. This field is read-only.
StripeBrushProperty | Identifies the StripeBrush dependency property. This field is read-only.
StripeVisibilityProperty | Identifies the StripeVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual Properties

The GridVisual type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LineMajorBrush | Gets or sets the line major brush.
Public property | LineMajorVisibility | Gets or sets the major line visibility.
Public property | LineMinorBrush | Gets or sets the line minor brush.
Public property | LineMinorVisibility | Gets or sets the minor line visibility.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | StripeAlternatingBrush | Gets or sets the brush used to fill alternate stripes.
Public property | StripeBrush | Gets or sets the brush used to fill stripes.
Public property | StripeVisibility | Gets or sets the stripe visibility.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.LineMajorBrush Property

GridVisualLineMajorBrush Property

Gets or sets the line major brush.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LineMajorBrush { get; set; }
Public Property LineMajorBrush As Brush
    Get
    Set

Property Value

Type: Brush
The line major brush.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.LineMajorVisibility Property

GridVisualLineMajorVisibility Property

Gets or sets the major line visibility.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GridLineVisibility LineMajorVisibility { get; set; }
Public Property LineMajorVisibility As GridLineVisibility
    Get
    Set

Property Value

Type: GridLineVisibility
The major line visibility.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.LineMinorBrush Property

GridVisualLineMinorBrush Property

Gets or sets the line minor brush.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LineMinorBrush { get; set; }
Public Property LineMinorBrush As Brush
    Get
    Set

Property Value

Type: Brush
The line minor brush.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.LineMinorVisibility Property

GridVisualLineMinorVisibility Property

Gets or sets the minor line visibility.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GridLineVisibility LineMinorVisibility { get; set; }
Public Property LineMinorVisibility As GridLineVisibility
    Get
    Set

Property Value

Type: GridLineVisibility
The minor line visibility.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.StripeAlternatingBrush Property

GridVisualStripeAlternatingBrush Property

Gets or sets the brush used to fill alternate stripes.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush StripeAlternatingBrush { get; set; }
Public Property StripeAlternatingBrush As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to fill alternate stripes.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.StripeBrush Property

GridVisualStripeBrush Property

Gets or sets the brush used to fill stripes.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush StripeBrush { get; set; }
Public Property StripeBrush As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to fill stripes.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.StripeVisibility Property

GridVisualStripeVisibility Property

Gets or sets the stripe visibility.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GridStripeVisibility StripeVisibility { get; set; }
Public Property StripeVisibility As GridStripeVisibility
    Get
    Set

Property Value

Type: GridStripeVisibility
The stripe visibility.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual Methods

The GridVisual type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Clears and redraws the grid.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.OnApplyTemplate Method

GridVisualOnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.Refresh Method

GridVisualRefresh Method

Clears and redraws the grid.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Refresh(
    Size plotSize
)
Public Overridable Sub Refresh (
    plotSize As Size
)

Parameters

plotSize
Type: System.WindowsSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.GridVisual.Refresh(System.Windows.Size)"]

See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual Events

The GridVisual type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual Fields

The GridVisual type exposes the following members.

Fields
Name | Description
LineMajorBrushProperty | Identifies the LineMajorBrush dependency property. This field is read-only.
LineMajorVisibilityProperty | Identifies the LineMajorVisibility dependency property. This field is read-only.
LineMinorBrushProperty | Identifies the LineMinorBrush dependency property. This field is read-only.
LineMinorVisibilityProperty | Identifies the LineMinorVisibility dependency property. This field is read-only.
StripeAlternatingBrushProperty | Identifies the StripeAlternatingBrush dependency property. This field is read-only.
StripeBrushProperty | Identifies the StripeBrush dependency property. This field is read-only.
StripeVisibilityProperty | Identifies the StripeVisibility dependency property. This field is read-only.
Top
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.LineMajorBrushProperty Field

GridVisualLineMajorBrushProperty Field

Identifies the LineMajorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineMajorBrushProperty
Public Shared ReadOnly LineMajorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineMajorBrush dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.LineMajorVisibilityProperty Field

GridVisualLineMajorVisibilityProperty Field

Identifies the LineMajorVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineMajorVisibilityProperty
Public Shared ReadOnly LineMajorVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineMajorVisibility dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.LineMinorBrushProperty Field

GridVisualLineMinorBrushProperty Field

Identifies the LineMinorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineMinorBrushProperty
Public Shared ReadOnly LineMinorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineMinorBrush dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.LineMinorVisibilityProperty Field

GridVisualLineMinorVisibilityProperty Field

Identifies the LineMinorVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineMinorVisibilityProperty
Public Shared ReadOnly LineMinorVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineMinorVisibility dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.StripeAlternatingBrushProperty Field

GridVisualStripeAlternatingBrushProperty Field

Identifies the StripeAlternatingBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StripeAlternatingBrushProperty
Public Shared ReadOnly StripeAlternatingBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StripeAlternatingBrush dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.StripeBrushProperty Field

GridVisualStripeBrushProperty Field

Identifies the StripeBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StripeBrushProperty
Public Shared ReadOnly StripeBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StripeBrush dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


GridVisual.StripeVisibilityProperty Field

GridVisualStripeVisibilityProperty Field

Identifies the StripeVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StripeVisibilityProperty
Public Shared ReadOnly StripeVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StripeVisibility dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Class

InvalidPropertyPathException is an exception for use when a PropertyPath is invalid.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.Windows.Controls.Charts.PrimitivesInvalidPropertyPathException

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InvalidPropertyPathException : Exception
Public Class InvalidPropertyPathException
    Inherits Exception
Constructors
 | Name | Description
Public method | InvalidPropertyPathException | Initializes a new instance of the InvalidPropertyPathException class.
Public method | InvalidPropertyPathException(String) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message.
Public method | InvalidPropertyPathException(String, Exception) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Constructor

Overload List
 | Name | Description
Public method | InvalidPropertyPathException | Initializes a new instance of the InvalidPropertyPathException class.
Public method | InvalidPropertyPathException(String) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message.
Public method | InvalidPropertyPathException(String, Exception) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidPropertyPathException Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Constructor

Initializes a new instance of the InvalidPropertyPathException class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException()
Public Sub New
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Constructor (String)

Initializes a new instance of the InvalidPropertyPathException class with a specified error message.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Constructor (String, Exception)

Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo Class

Information that describes a data point label.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PrimitivesLabelInfo

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LabelInfo
Public Class LabelInfo

The LabelInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LabelInfo | Initializes a new instance of the LabelInfo class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle.
Public property | Color | Gets or sets the color.
Public property | DataPointPosition | Gets or sets the data point position.
Public property | IsAboveBaseline | Gets or sets a value indicating whether this instance is above baseline.
Public property | IsHorizontal | Gets or sets a value indicating whether this instance is horizontal.
Public property | LabelOrigin | Gets the label origin.
Public property | LabelOriginX | Gets or sets the label origin X.
Public property | LabelOriginY | Gets or sets the label origin Y.
Public property | PositioningMode | Gets or sets the positioning mode.
Public property | SeriesIndex | Gets or sets the series index.
Public property | Style | Gets or sets the label style.
Public property | Text | Gets or sets the text.
Public property | Visibility | Gets or sets the visibility.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo Constructor

Initializes a new instance of the LabelInfo class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LabelInfo()
Public Sub New
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo Properties

The LabelInfo type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle.
Public property | Color | Gets or sets the color.
Public property | DataPointPosition | Gets or sets the data point position.
Public property | IsAboveBaseline | Gets or sets a value indicating whether this instance is above baseline.
Public property | IsHorizontal | Gets or sets a value indicating whether this instance is horizontal.
Public property | LabelOrigin | Gets the label origin.
Public property | LabelOriginX | Gets or sets the label origin X.
Public property | LabelOriginY | Gets or sets the label origin Y.
Public property | PositioningMode | Gets or sets the positioning mode.
Public property | SeriesIndex | Gets or sets the series index.
Public property | Style | Gets or sets the label style.
Public property | Text | Gets or sets the text.
Public property | Visibility | Gets or sets the visibility.
Top
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.Angle Property

LabelInfoAngle Property

Gets or sets the angle.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
The angle.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.Color Property

LabelInfoColor Property

Gets or sets the color.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
The color.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.DataPointPosition Property

LabelInfoDataPointPosition Property

Gets or sets the data point position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point DataPointPosition { get; set; }
Public Property DataPointPosition As Point
    Get
    Set

Property Value

Type: Point
The data point position.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.IsAboveBaseline Property

LabelInfoIsAboveBaseline Property

Gets or sets a value indicating whether this instance is above baseline.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAboveBaseline { get; set; }
Public Property IsAboveBaseline As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is above baseline; otherwise, false.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.IsHorizontal Property

LabelInfoIsHorizontal Property

Gets or sets a value indicating whether this instance is horizontal.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsHorizontal { get; set; }
Public Property IsHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is horizontal; otherwise, false.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.LabelOrigin Property

LabelInfoLabelOrigin Property

Gets the label origin.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point LabelOrigin { get; }
Public ReadOnly Property LabelOrigin As Point
    Get

Property Value

Type: Point
The label origin.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.LabelOriginX Property

LabelInfoLabelOriginX Property

Gets or sets the label origin X.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LabelOriginX { get; set; }
Public Property LabelOriginX As Double
    Get
    Set

Property Value

Type: Double
The label origin X.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.LabelOriginY Property

LabelInfoLabelOriginY Property

Gets or sets the label origin Y.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LabelOriginY { get; set; }
Public Property LabelOriginY As Double
    Get
    Set

Property Value

Type: Double
The label origin Y.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.PositioningMode Property

LabelInfoPositioningMode Property

Gets or sets the positioning mode.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LabelPositioningMode PositioningMode { get; set; }
Public Property PositioningMode As LabelPositioningMode
    Get
    Set

Property Value

Type: LabelPositioningMode
The positioning mode.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.SeriesIndex Property

LabelInfoSeriesIndex Property

Gets or sets the series index.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SeriesIndex { get; set; }
Public Property SeriesIndex As Integer
    Get
    Set

Property Value

Type: Int32
The series index.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.Style Property

LabelInfoStyle Property

Gets or sets the label style.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style Style { get; set; }
Public Property Style As Style
    Get
    Set

Property Value

Type: Style
The label style.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.Text Property

LabelInfoText Property

Gets or sets the text.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LabelInfo.Visibility Property

LabelInfoVisibility Property

Gets or sets the visibility.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LabelVisibility Visibility { get; set; }
Public Property Visibility As LabelVisibility
    Get
    Set

Property Value

Type: LabelVisibility
The visibility.
See Also

Reference

LabelInfo Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


Legend Class

The legend control used to display a collection of LegendKey in a chart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesLegend

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Legend : ItemsControl
Public Class Legend
    Inherits ItemsControl

The Legend type exposes the following members.

Constructors
 | Name | Description
Public method | Legend | Creates an instance of Legend.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


Legend Constructor

Creates an instance of Legend.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Legend()
Public Sub New
See Also

Reference

Legend Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


Legend Properties

The Legend type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Legend Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


Legend Methods

The Legend type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Legend Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


Legend Events

The Legend type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

Legend Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LegendItem Class

Represents an item used in a chart legend.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Charts.PrimitivesLegendItem

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LegendItem
Public Class LegendItem

The LegendItem type exposes the following members.

Constructors
 | Name | Description
Public method | LegendItem | Initializes a new instance of the LegendItem class
Top
Properties
 | Name | Description
Public property | MarkerStyle | Gets the Style applied to the ChartMarker used to present the legend item.
Public property | Text | Gets a description of the legend item.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LegendItem Constructor

Initializes a new instance of the LegendItem class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LegendItem()
Public Sub New
See Also

Reference

LegendItem Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LegendItem Properties

The LegendItem type exposes the following members.

Properties
 | Name | Description
Public property | MarkerStyle | Gets the Style applied to the ChartMarker used to present the legend item.
Public property | Text | Gets a description of the legend item.
Top
See Also

Reference

LegendItem Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LegendItem.MarkerStyle Property

LegendItemMarkerStyle Property

Gets the Style applied to the ChartMarker used to present the legend item.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; }
Public ReadOnly Property MarkerStyle As Style
    Get

Property Value

Type: Style
See Also

Reference

LegendItem Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LegendItem.Text Property

LegendItemText Property

Gets a description of the legend item.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
See Also

Reference

LegendItem Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase Class

Represents a base class for line and area series for use in a XYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesLineSeriesBase
ActiproSoftware.Windows.Controls.ChartsAreaSeries
ActiproSoftware.Windows.Controls.ChartsLineSeries

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LineSeriesBase : XYSeriesBase
Public MustInherit Class LineSeriesBase
    Inherits XYSeriesBase

The LineSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LineSeriesBase | Initializes a new instance of the LineSeriesBase class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out.
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
Fields
Name | Description
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
LineKindProperty | Identifies the LineKind dependency property. This field is read-only.
LineStyleProperty | Identifies the LineStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase Constructor

Initializes a new instance of the LineSeriesBase class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LineSeriesBase()
Protected Sub New
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase Properties

The LineSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out.
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase.LabelPositioningMode Property

LineSeriesBaseLabelPositioningMode Property

Gets or sets the LabelPositioningMode used to determine how labels are laid out.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual LabelPositioningMode LabelPositioningMode { get; set; }
Public Overridable Property LabelPositioningMode As LabelPositioningMode
    Get
    Set

Property Value

Type: LabelPositioningMode
The label positioning mode. The default value is FromAverage.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase.LineKind Property

LineSeriesBaseLineKind Property

Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYSeriesLineKind LineKind { get; set; }
Public Property LineKind As XYSeriesLineKind
    Get
    Set

Property Value

Type: XYSeriesLineKind
A XYSeriesLineKind, which indicates what kind of line should be rendered by the series. The default value is XYSeriesLineKind.Normal.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase.LineStyle Property

LineSeriesBaseLineStyle Property

Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LineStyle { get; set; }
Public Property LineStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase.MarkerVisibility Property

LineSeriesBaseMarkerVisibility Property

Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ChartMarkerVisibility MarkerVisibility { get; set; }
Public Property MarkerVisibility As ChartMarkerVisibility
    Get
    Set

Property Value

Type: ChartMarkerVisibility
A ChartMarkerVisibility indicating which markers are rendered along the series. The default value is ChartMarkerVisibility.None.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase.MinimumMargin Property

LineSeriesBaseMinimumMargin Property

Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> MinimumMargin { get; }
Protected Overrides ReadOnly Property MinimumMargin As Nullable(Of Thickness)
    Get

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase Methods

The LineSeriesBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase Events

The LineSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Top
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase Fields

The LineSeriesBase type exposes the following members.

Fields
Name | Description
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
LineKindProperty | Identifies the LineKind dependency property. This field is read-only.
LineStyleProperty | Identifies the LineStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
Top
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase.LabelPositioningModeProperty Field

LineSeriesBaseLabelPositioningModeProperty Field

Identifies the LabelPositioningMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositioningModeProperty
Public Shared ReadOnly LabelPositioningModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelPositioningMode dependency property.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase.LineKindProperty Field

LineSeriesBaseLineKindProperty Field

Identifies the LineKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineKindProperty
Public Shared ReadOnly LineKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineKind dependency property.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase.LineStyleProperty Field

LineSeriesBaseLineStyleProperty Field

Identifies the LineStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineStyleProperty
Public Shared ReadOnly LineStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineStyle dependency property.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


LineSeriesBase.MarkerVisibilityProperty Field

LineSeriesBaseMarkerVisibilityProperty Field

Identifies the MarkerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerVisibilityProperty
Public Shared ReadOnly MarkerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice Class

A single pie slice in a pie series.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesPieSlice

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PieSlice : Control
Public Class PieSlice
    Inherits Control

The PieSlice type exposes the following members.

Constructors
 | Name | Description
Public method | PieSlice | Initializes a new instance of the PieSlice class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CollisionPolygon | Gets the collision polygon.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DrawingBounds | Gets or sets the drawing bounds.
Public property | EndAngle | Gets the end angle.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HoleRadius | Gets or sets the hole radius.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelPosition | Gets or sets the label position.
Public property | OriginalItems | Gets the original items.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PathData | Gets or sets the path data.
Public property | Percentage | Gets or sets the percentage.
Public property | Radius | Gets or sets the radius.
Public property | StartAngle | Gets or sets the start angle.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title.
Public property | Values | Gets the values.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetTetherEndPoint | Gets the tether end point.
Public method | GetTetherStartPoint | Gets the tether start point.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
DrawingBoundsProperty | Identifies the DrawingBounds dependency property. This field is read-only.
HoleRadiusProperty | Identifies the HoleRadius dependency property. This field is read-only.
LabelPositionProperty | Identifies the LabelPosition dependency property. This field is read-only.
PathDataProperty | Identifies the PathData dependency property. This field is read-only.
PercentageProperty | Identifies the Percentage dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice Constructor

Initializes a new instance of the PieSlice class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSlice()
Public Sub New
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice Properties

The PieSlice type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CollisionPolygon | Gets the collision polygon.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DrawingBounds | Gets or sets the drawing bounds.
Public property | EndAngle | Gets the end angle.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HoleRadius | Gets or sets the hole radius.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelPosition | Gets or sets the label position.
Public property | OriginalItems | Gets the original items.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PathData | Gets or sets the path data.
Public property | Percentage | Gets or sets the percentage.
Public property | Radius | Gets or sets the radius.
Public property | StartAngle | Gets or sets the start angle.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title.
Public property | Values | Gets the values.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.CollisionPolygon Property

PieSliceCollisionPolygon Property

Gets the collision polygon.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<Point> CollisionPolygon { get; }
Public ReadOnly Property CollisionPolygon As IEnumerable(Of Point)
    Get

Property Value

Type: IEnumerable Point
The collision polygon.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.DrawingBounds Property

PieSliceDrawingBounds Property

Gets or sets the drawing bounds.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect DrawingBounds { get; set; }
Public Property DrawingBounds As Rect
    Get
    Set

Property Value

Type: Rect
The drawing bounds.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.EndAngle Property

PieSliceEndAngle Property

Gets the end angle.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndAngle { get; }
Public ReadOnly Property EndAngle As Double
    Get

Property Value

Type: Double
The end angle.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.HoleRadius Property

PieSliceHoleRadius Property

Gets or sets the hole radius.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double HoleRadius { get; set; }
Public Property HoleRadius As Double
    Get
    Set

Property Value

Type: Double
The hole radius.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.LabelPosition Property

PieSliceLabelPosition Property

Gets or sets the label position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PieSliceLabelPosition LabelPosition { get; set; }
Public Property LabelPosition As PieSliceLabelPosition
    Get
    Set

Property Value

Type: PieSliceLabelPosition
The label position.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.OriginalItems Property

PieSliceOriginalItems Property

Gets the original items.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Object> OriginalItems { get; }
Public ReadOnly Property OriginalItems As IList(Of Object)
    Get

Property Value

Type: IList Object
The original items.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.PathData Property

PieSlicePathData Property

Gets or sets the path data.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry PathData { get; set; }
Public Property PathData As Geometry
    Get
    Set

Property Value

Type: Geometry
The path data.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.Percentage Property

PieSlicePercentage Property

Gets or sets the percentage.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Percentage { get; set; }
Public Property Percentage As Double
    Get
    Set

Property Value

Type: Double
The percentage.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.Radius Property

PieSliceRadius Property

Gets or sets the radius.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The radius.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.StartAngle Property

PieSliceStartAngle Property

Gets or sets the start angle.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set

Property Value

Type: Double
The start angle.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.Title Property

PieSliceTitle Property

Gets or sets the title.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.Values Property

PieSliceValues Property

Gets the values.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<Object> Values { get; }
Public ReadOnly Property Values As IList(Of Object)
    Get

Property Value

Type: IList Object
The values.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice Methods

The PieSlice type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetTetherEndPoint | Gets the tether end point.
Public method | GetTetherStartPoint | Gets the tether start point.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.GetTetherEndPoint Method

PieSliceGetTetherEndPoint Method

Gets the tether end point.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point GetTetherEndPoint(
    Rect drawingBounds
)
Public Function GetTetherEndPoint (
    drawingBounds As Rect
) As Point

Parameters

drawingBounds
Type: System.WindowsRect
The drawing bounds.

Return Value

Type: Point
A Point where the tether ends.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.GetTetherStartPoint Method

PieSliceGetTetherStartPoint Method

Gets the tether start point.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point GetTetherStartPoint(
    Rect drawingBounds
)
Public Function GetTetherStartPoint (
    drawingBounds As Rect
) As Point

Parameters

drawingBounds
Type: System.WindowsRect
The drawing bounds.

Return Value

Type: Point
A Point where the tether starts.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.MeasureOverride Method

PieSliceMeasureOverride Method

Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this object can give to child objects. Infinity (PositiveInfinity) can be specified as a value to indicate that the object will size to whatever content is available.

Return Value

Type: Size
The size that this object determines it needs during layout, based on its calculations of the allocated sizes for child objects; or based on other considerations, such as a fixed container size.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.OnApplyTemplate Method

PieSliceOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice Events

The PieSlice type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice Fields

The PieSlice type exposes the following members.

Fields
Name | Description
DrawingBoundsProperty | Identifies the DrawingBounds dependency property. This field is read-only.
HoleRadiusProperty | Identifies the HoleRadius dependency property. This field is read-only.
LabelPositionProperty | Identifies the LabelPosition dependency property. This field is read-only.
PathDataProperty | Identifies the PathData dependency property. This field is read-only.
PercentageProperty | Identifies the Percentage dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
Top
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.DrawingBoundsProperty Field

PieSliceDrawingBoundsProperty Field

Identifies the DrawingBounds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DrawingBoundsProperty
Public Shared ReadOnly DrawingBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DrawingBounds dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.HoleRadiusProperty Field

PieSliceHoleRadiusProperty Field

Identifies the HoleRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HoleRadiusProperty
Public Shared ReadOnly HoleRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HoleRadius dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.LabelPositionProperty Field

PieSliceLabelPositionProperty Field

Identifies the LabelPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositionProperty
Public Shared ReadOnly LabelPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelPosition dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.PathDataProperty Field

PieSlicePathDataProperty Field

Identifies the PathData dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PathDataProperty
Public Shared ReadOnly PathDataProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PathData dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.PercentageProperty Field

PieSlicePercentageProperty Field

Identifies the Percentage dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PercentageProperty
Public Shared ReadOnly PercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Percentage dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.RadiusProperty Field

PieSliceRadiusProperty Field

Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.StartAngleProperty Field

PieSliceStartAngleProperty Field

Identifies the StartAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartAngleProperty
Public Shared ReadOnly StartAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartAngle dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


PieSlice.TitleProperty Field

PieSliceTitleProperty Field

Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase Class

Provides the base class for a series.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class SeriesBase : Control
Public MustInherit Class SeriesBase
    Inherits Control

The SeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SeriesBase | Initializes a new instance of the SeriesBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property.
Public property | LabelAngle | Gets or sets the label angle.
Public property | LabelFormat | Gets or sets the label format.
Public property | LabelFunc | Gets or sets the label function.
Public property | LabelStyle | Gets or sets the label style.
Public property | LabelVisibility | Gets or sets the label visibility.
Public property | LogicalOrientation | Gets the logical orientation of the series.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed.
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
IndexProperty | Identifies the read-only Index dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase Constructor

Initializes a new instance of the SeriesBase class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected SeriesBase()
Protected Sub New
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase Properties

The SeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property.
Public property | LabelAngle | Gets or sets the label angle.
Public property | LabelFormat | Gets or sets the label format.
Public property | LabelFunc | Gets or sets the label function.
Public property | LabelStyle | Gets or sets the label style.
Public property | LabelVisibility | Gets or sets the label visibility.
Public property | LogicalOrientation | Gets the logical orientation of the series.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.Index Property

SeriesBaseIndex Property

Gets the index of this series in the associated chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of this series in the associated chart. The default value is -1.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.ItemsSource Property

SeriesBaseItemsSource Property

Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable ItemsSource { get; set; }
Public Property ItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
A collection used to generate the data points of the SeriesBase. The default value is .
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.LabelAngle Property

SeriesBaseLabelAngle Property

Gets or sets the label angle.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LabelAngle { get; set; }
Public Property LabelAngle As Double
    Get
    Set

Property Value

Type: Double
The label angle.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.LabelFormat Property

SeriesBaseLabelFormat Property

Gets or sets the label format.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LabelFormat { get; set; }
Public Property LabelFormat As String
    Get
    Set

Property Value

Type: String
The label format.
Remarks
The format string will be passed the following parameters:
  • {0} is the value on the primary axis.
  • {1} is the value on the secondary axis.
  • {2} is the value on the X axis.
  • {3} is the value on the Y axis.
The format is ignored if LabelFunc is specified.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.LabelFunc Property

SeriesBaseLabelFunc Property

Gets or sets the label function.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<Object, Object, Object, Object, Object, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Object, Object, Object, Object, Object, String)
    Get
    Set

Property Value

Type: Func Object, Object, Object, Object, Object, String
The label function.
Remarks
This is a Func that determines what the label text will be. The parameters are primary axis value, secondary axis value, X axis value, Y axis value, and original value.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.LabelStyle Property

SeriesBaseLabelStyle Property

Gets or sets the label style.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LabelStyle { get; set; }
Public Property LabelStyle As Style
    Get
    Set

Property Value

Type: Style
The label style.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.LabelVisibility Property

SeriesBaseLabelVisibility Property

Gets or sets the label visibility.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LabelVisibility LabelVisibility { get; set; }
Public Property LabelVisibility As LabelVisibility
    Get
    Set

Property Value

Type: LabelVisibility
The label visibility.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.LogicalOrientation Property

SeriesBaseLogicalOrientation Property

Gets the logical orientation of the series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Orientation LogicalOrientation { get; }
Public Overridable ReadOnly Property LogicalOrientation As Orientation
    Get

Property Value

Type: Orientation
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase Methods

The SeriesBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed.
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.GetLabelText Method

SeriesBaseGetLabelText Method

Gets the label text.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string GetLabelText(
    Object primaryValue,
    Object secondaryValue,
    Object xValue,
    Object yValue,
    Object originalValue
)
Protected Overridable Function GetLabelText (
    primaryValue As Object,
    secondaryValue As Object,
    xValue As Object,
    yValue As Object,
    originalValue As Object
) As String

Parameters

primaryValue
Type: SystemObject
The primary value.
secondaryValue
Type: SystemObject
The secondary value.
xValue
Type: SystemObject
The x value.
yValue
Type: SystemObject
The y value.
originalValue
Type: SystemObject
The original value.

Return Value

Type: String
The text to apply to the label.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.OnItemsSourceChanged Method

SeriesBaseOnItemsSourceChanged Method

Occurs when the ItemsSource value is changed.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Protected Overridable Sub OnItemsSourceChanged (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
Old value of the ItemsSource property.
newValue
Type: System.CollectionsIEnumerable
New value of the ItemsSource property.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.OnItemsSourceCollectionChanged Method

SeriesBaseOnItemsSourceCollectionChanged Method

Handles the CollectionChanged event of the ItemsSource collection.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemsSourceCollectionChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Protected Overridable Sub OnItemsSourceCollectionChanged (
    sender As Object,
    e As NotifyCollectionChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
The NotifyCollectionChangedEventArgs instance containing the event data.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.Refresh Method

SeriesBaseRefresh Method

Updates the series based on the current state.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void Refresh()
Public MustOverride Sub Refresh
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase Events

The SeriesBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase Fields

The SeriesBase type exposes the following members.

Fields
Name | Description
IndexProperty | Identifies the read-only Index dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
Top
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.IndexProperty Field

SeriesBaseIndexProperty Field

Identifies the read-only Index dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndexProperty
Public Shared ReadOnly IndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Index dependency property.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesBase.ItemsSourceProperty Field

SeriesBaseItemsSourceProperty Field

Identifies the ItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemsSourceProperty
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemsSource dependency property.
See Also

Reference

SeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter Class

Represents a type converter for the ItemsSource type.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesItemsSourceConverter

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class SeriesItemsSourceConverter : TypeConverter
Public NotInheritable Class SeriesItemsSourceConverter
    Inherits TypeConverter

The SeriesItemsSourceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesItemsSourceConverter | Initializes a new instance of the SeriesItemsSourceConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter Constructor

Initializes a new instance of the SeriesItemsSourceConverter class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SeriesItemsSourceConverter()
Public Sub New
See Also

Reference

SeriesItemsSourceConverter Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter Methods

The SeriesItemsSourceConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

SeriesItemsSourceConverter Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter.CanConvertFrom Method

SeriesItemsSourceConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

SeriesItemsSourceConverter Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

SeriesItemsSourceConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether the type converter can convert an object from the specified type to the type of this converter.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
sourceType
Type: SystemType
The type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

SeriesItemsSourceConverter Class
CanConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter.ConvertFrom Method

SeriesItemsSourceConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

SeriesItemsSourceConverter Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

SeriesItemsSourceConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts from the specified value to the intended conversion type of the converter.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The value to convert to the type of this converter.

Return Value

Type: Object
The converted value.
See Also

Reference

SeriesItemsSourceConverter Class
ConvertFrom Overload
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual Class

Draws an axis given axis data.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesAxisVisual
ActiproSoftware.Windows.Controls.Charts.PrimitivesXAxisVisual

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XAxisVisual : AxisVisual
Public Class XAxisVisual
    Inherits AxisVisual

The XAxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible. (Inherited from AxisVisual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis. (Overrides AxisVisualDrawMajorTickAtPosition(Double, Size).)
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis. (Overrides AxisVisualDrawMinorTickAtPosition(Double, Size).)
Protected method | DrawSpine | Draws an axis spine. (Overrides AxisVisualDrawSpine(Size).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary. (Overrides AxisVisualGetTitleTemplateFromResources(ResourceDictionary).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsSpineVisible | Determines whether or not the spine is visible. (Inherited from AxisVisual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AxisVisual.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position. (Overrides AxisVisualPlaceLabelAtPosition(TextBlock, Double, Double, Size).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Redraws the axis. (Inherited from AxisVisual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateTitlePosition | Updates the title position. (Overrides AxisVisualUpdateTitlePosition(Size).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual Properties

The XAxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual Methods

The XAxisVisual type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible. (Inherited from AxisVisual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis. (Overrides AxisVisualDrawMajorTickAtPosition(Double, Size).)
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis. (Overrides AxisVisualDrawMinorTickAtPosition(Double, Size).)
Protected method | DrawSpine | Draws an axis spine. (Overrides AxisVisualDrawSpine(Size).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary. (Overrides AxisVisualGetTitleTemplateFromResources(ResourceDictionary).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsSpineVisible | Determines whether or not the spine is visible. (Inherited from AxisVisual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AxisVisual.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position. (Overrides AxisVisualPlaceLabelAtPosition(TextBlock, Double, Double, Size).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Redraws the axis. (Inherited from AxisVisual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateTitlePosition | Updates the title position. (Overrides AxisVisualUpdateTitlePosition(Size).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual.ArrangeOverride Method

XAxisVisualArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual.DrawMajorTickAtPosition Method

XAxisVisualDrawMajorTickAtPosition Method

Draws a major tick at a given position on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void DrawMajorTickAtPosition(
    double position,
    Size plotSize
)
Protected Overrides Sub DrawMajorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: System.WindowsSize
Size of the plot.
See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual.DrawMinorTickAtPosition Method

XAxisVisualDrawMinorTickAtPosition Method

Draws a minor tick at a given position on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void DrawMinorTickAtPosition(
    double position,
    Size plotSize
)
Protected Overrides Sub DrawMinorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: System.WindowsSize
Size of the plot.
See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual.DrawSpine Method

XAxisVisualDrawSpine Method

Draws an axis spine.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void DrawSpine(
    Size plotSize
)
Protected Overrides Sub DrawSpine (
    plotSize As Size
)

Parameters

plotSize
Type: System.WindowsSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.XAxisVisual.DrawSpine(System.Windows.Size)"]

See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual.GetTitleTemplateFromResources Method

XAxisVisualGetTitleTemplateFromResources Method

Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DataTemplate GetTitleTemplateFromResources(
    ResourceDictionary resources
)
Protected Overrides Function GetTitleTemplateFromResources (
    resources As ResourceDictionary
) As DataTemplate

Parameters

resources
Type: System.WindowsResourceDictionary
The ResourceDictionary to retrieve the title template from.

Return Value

Type: DataTemplate
The template for the axis title.
See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual.MeasureOverride Method

XAxisVisualMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a argumentValue to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual.PlaceLabelAtPosition Method

XAxisVisualPlaceLabelAtPosition Method

Place the axis label at the given position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PlaceLabelAtPosition(
    TextBlock label,
    double position,
    double angle,
    Size plotSize
)
Protected Overrides Sub PlaceLabelAtPosition (
    label As TextBlock,
    position As Double,
    angle As Double,
    plotSize As Size
)

Parameters

label
Type: System.Windows.ControlsTextBlock
The axis label to lay out.
position
Type: SystemDouble
The position to draw the axis label at.
angle
Type: SystemDouble
The angle to draw the axis label at.
plotSize
Type: System.WindowsSize
Size of the plot.
Exceptions
Exception | Condition
ArgumentNullException | label
See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual.UpdateTitlePosition Method

XAxisVisualUpdateTitlePosition Method

Updates the title position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateTitlePosition(
    Size plotSize
)
Protected Overrides Sub UpdateTitlePosition (
    plotSize As Size
)

Parameters

plotSize
Type: System.WindowsSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.XAxisVisual.UpdateTitlePosition(System.Windows.Size)"]

See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XAxisVisual Events

The XAxisVisual type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

XAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase Class

Represents the base functionality of a chart axis.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.Windows.Controls.ChartsXYDateTimeAxis
ActiproSoftware.Windows.Controls.ChartsXYDecimalAxisBaseT
ActiproSoftware.Windows.Controls.ChartsXYDoubleAxis
ActiproSoftware.Windows.Controls.ChartsXYGroupedAxis
ActiproSoftware.Windows.Controls.ChartsXYPercentageAxis

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class XYAxisBase : Control
Public MustInherit Class XYAxisBase
    Inherits Control

The XYAxisBase type exposes the following members.

Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible.
Public property | AreMajorTicksVisible | Whether or not major ticks are visible.
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible.
Public property | AxisType | The type of data on the axis.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing.
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels.
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position.
Public property | Ranges | Gets the collection of ranges displayed by this chart.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path.
Public property | Title | Gets or sets the axis title.
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter.
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
 | OnPropertyChanged | Called when property changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed.
Top
Fields
Name | Description
AreLabelsVisibleProperty | Identifies the AreLabelsVisible dependency property. This field is read-only.
AreMajorTicksVisibleProperty | Identifies the AreMajorTicksVisible dependency property. This field is read-only.
AreMinorTicksVisibleProperty | Identifies the AreMinorTicksVisible dependency property. This field is read-only.
BarGroupSpacingProperty | Identifies the BarGroupSpacing dependency property. This field is read-only.
BarSpacingProperty | Identifies the BarSpacing dependency property. This field is read-only.
LabelAngleProperty | Identifies the LabelAngle dependency property. This field is read-only.
LabelFormatProperty | Identifies the LabelFormat dependency property. This field is read-only.
LabelStyleProperty | Identifies the LabelStyle dependency property. This field is read-only.
PositionProperty | Identifies the Position dependency property. This field is read-only.
TickMajorStyleProperty | Identifies the TickMajorStyle dependency property. This field is read-only.
TickMinorStyleProperty | Identifies the TickMinorStyle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TitleStyleProperty | Identifies the TitleStyle dependency property. This field is read-only.
UseDisplayOptimizationsProperty | Identifies the UseDisplayOptimizations dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase Properties

The XYAxisBase type exposes the following members.

Properties
 | Name | Description
Public property | AreLabelsVisible | Whether or not axis labels are visible.
Public property | AreMajorTicksVisible | Whether or not major ticks are visible.
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible.
Public property | AxisType | The type of data on the axis.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing.
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels.
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Position | Gets or sets the axis position.
Public property | Ranges | Gets the collection of ranges displayed by this chart.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path.
Public property | Title | Gets or sets the axis title.
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter.
Public property | UseDisplayOptimizations | Whether data point values are rounded to better appear on display pixels.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.AreLabelsVisible Property

XYAxisBaseAreLabelsVisible Property

Whether or not axis labels are visible.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreLabelsVisible { get; set; }
Public Property AreLabelsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.AreMajorTicksVisible Property

XYAxisBaseAreMajorTicksVisible Property

Whether or not major ticks are visible.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreMajorTicksVisible { get; set; }
Public Property AreMajorTicksVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.AreMinorTicksVisible Property

XYAxisBaseAreMinorTicksVisible Property

Whether or not minor ticks are visible.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreMinorTicksVisible { get; set; }
Public Property AreMinorTicksVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.AxisType Property

XYAxisBaseAxisType Property

The type of data on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type AxisType { get; }
Public ReadOnly Property AxisType As Type
    Get

Property Value

Type: Type
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.BarGroupSpacing Property

XYAxisBaseBarGroupSpacing Property

Gets or sets the bar group spacing.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit BarGroupSpacing { get; set; }
Public Property BarGroupSpacing As Unit
    Get
    Set

Property Value

Type: Unit
The bar group spacing.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.BarSpacing Property

XYAxisBaseBarSpacing Property

Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit BarSpacing { get; set; }
Public Property BarSpacing As Unit
    Get
    Set

Property Value

Type: Unit
The amount of spacing applied to either side of the individual bar shapes. The default value is 1px.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.LabelAngle Property

XYAxisBaseLabelAngle Property

The angle at which to draw the axis labels.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LabelAngle { get; set; }
Public Property LabelAngle As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.LabelFormat Property

XYAxisBaseLabelFormat Property

Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LabelFormat { get; set; }
Public Property LabelFormat As String
    Get
    Set

Property Value

Type: String
The string format used when presenting a label on an axis tick.
Remarks
The format string will be passed the following parameters:
  • {0} - The value of the axis tick, or null when the axis is slotted, such as on a bar chart. -
  • {1} - The starting value of the current slot when the axis is slotted, such as on a bar chart. Otherwise, null. -
  • {2} - The ending value of the current slot when the axis is slotted, such as on a bar chart. Otherwise, null. -
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.LabelStyle Property

XYAxisBaseLabelStyle Property

The style to apply to axis labels. TargetType of the Style must be a TextBlock.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LabelStyle { get; set; }
Public Property LabelStyle As Style
    Get
    Set

Property Value

Type: Style
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.Position Property

XYAxisBasePosition Property

Gets or sets the axis position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AxisPosition Position { get; set; }
Public Property Position As AxisPosition
    Get
    Set

Property Value

Type: AxisPosition
The axis position.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.Ranges Property

XYAxisBaseRanges Property

Gets the collection of ranges displayed by this chart.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYRangeCollection Ranges { get; }
Public ReadOnly Property Ranges As XYRangeCollection
    Get

Property Value

Type: XYRangeCollection
The collection of ranges displayed by this chart.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.TickMajorStyle Property

XYAxisBaseTickMajorStyle Property

The style to apply to major ticks. TargetType of the Style must be a Path.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TickMajorStyle { get; set; }
Public Property TickMajorStyle As Style
    Get
    Set

Property Value

Type: Style
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.TickMinorStyle Property

XYAxisBaseTickMinorStyle Property

The style to apply to minor ticks. TargetType of the Style must be a Path.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TickMinorStyle { get; set; }
Public Property TickMinorStyle As Style
    Get
    Set

Property Value

Type: Style
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.Title Property

XYAxisBaseTitle Property

Gets or sets the axis title.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Title { get; set; }
Public Property Title As Object
    Get
    Set

Property Value

Type: Object
The title displayed on the axis.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.TitleStyle Property

XYAxisBaseTitleStyle Property

Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TitleStyle { get; set; }
Public Property TitleStyle As Style
    Get
    Set

Property Value

Type: Style
The style to apply to the axis title.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.UseDisplayOptimizations Property

XYAxisBaseUseDisplayOptimizations Property

Whether data point values are rounded to better appear on display pixels.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseDisplayOptimizations { get; set; }
Public Property UseDisplayOptimizations As Boolean
    Get
    Set

Property Value

Type: Boolean
true if data point values are rounded to better appear on display pixels; otherwise, false. The default value is true.
Remarks
This property is usually good to leave as its default value of true because it will ensure that lines render with minimal anti-aliasing. It accomplishes this by slightly rounding data point values as needed. However if precise data point locations are required, such as when rendering a smooth curved line graph, set this to false to remove line jaggedness.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase Methods

The XYAxisBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
 | OnPropertyChanged | Called when property changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.OnApplyTemplate Method

XYAxisBaseOnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.OnPropertyChanged Method

XYAxisBaseOnPropertyChanged Method

Called when property changed.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static void OnPropertyChanged(
    DependencyObject sender,
    DependencyPropertyChangedEventArgs args
)
Protected Shared Sub OnPropertyChanged (
    sender As DependencyObject,
    args As DependencyPropertyChangedEventArgs
)

Parameters

sender
Type: System.WindowsDependencyObject
The sender.
args
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase Events

The XYAxisBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when XYAxisBase is refershed.
Top
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.Refreshed Event

XYAxisBaseRefreshed Event

Occurs when XYAxisBase is refershed.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler Refreshed
Public Event Refreshed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase Fields

The XYAxisBase type exposes the following members.

Fields
Name | Description
AreLabelsVisibleProperty | Identifies the AreLabelsVisible dependency property. This field is read-only.
AreMajorTicksVisibleProperty | Identifies the AreMajorTicksVisible dependency property. This field is read-only.
AreMinorTicksVisibleProperty | Identifies the AreMinorTicksVisible dependency property. This field is read-only.
BarGroupSpacingProperty | Identifies the BarGroupSpacing dependency property. This field is read-only.
BarSpacingProperty | Identifies the BarSpacing dependency property. This field is read-only.
LabelAngleProperty | Identifies the LabelAngle dependency property. This field is read-only.
LabelFormatProperty | Identifies the LabelFormat dependency property. This field is read-only.
LabelStyleProperty | Identifies the LabelStyle dependency property. This field is read-only.
PositionProperty | Identifies the Position dependency property. This field is read-only.
TickMajorStyleProperty | Identifies the TickMajorStyle dependency property. This field is read-only.
TickMinorStyleProperty | Identifies the TickMinorStyle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TitleStyleProperty | Identifies the TitleStyle dependency property. This field is read-only.
UseDisplayOptimizationsProperty | Identifies the UseDisplayOptimizations dependency property. This field is read-only.
Top
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.AreLabelsVisibleProperty Field

XYAxisBaseAreLabelsVisibleProperty Field

Identifies the AreLabelsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreLabelsVisibleProperty
Public Shared ReadOnly AreLabelsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreLabelsVisible dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.AreMajorTicksVisibleProperty Field

XYAxisBaseAreMajorTicksVisibleProperty Field

Identifies the AreMajorTicksVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreMajorTicksVisibleProperty
Public Shared ReadOnly AreMajorTicksVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreMajorTicksVisible dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.AreMinorTicksVisibleProperty Field

XYAxisBaseAreMinorTicksVisibleProperty Field

Identifies the AreMinorTicksVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreMinorTicksVisibleProperty
Public Shared ReadOnly AreMinorTicksVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreMinorTicksVisible dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.BarGroupSpacingProperty Field

XYAxisBaseBarGroupSpacingProperty Field

Identifies the BarGroupSpacing dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarGroupSpacingProperty
Public Shared ReadOnly BarGroupSpacingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarGroupSpacing dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.BarSpacingProperty Field

XYAxisBaseBarSpacingProperty Field

Identifies the BarSpacing dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarSpacingProperty
Public Shared ReadOnly BarSpacingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarSpacing dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.LabelAngleProperty Field

XYAxisBaseLabelAngleProperty Field

Identifies the LabelAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelAngleProperty
Public Shared ReadOnly LabelAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFormat dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.LabelFormatProperty Field

XYAxisBaseLabelFormatProperty Field

Identifies the LabelFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFormatProperty
Public Shared ReadOnly LabelFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFormat dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.LabelStyleProperty Field

XYAxisBaseLabelStyleProperty Field

Identifies the LabelStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelStyleProperty
Public Shared ReadOnly LabelStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelStyle dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.PositionProperty Field

XYAxisBasePositionProperty Field

Identifies the Position dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PositionProperty
Public Shared ReadOnly PositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Position dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.TickMajorStyleProperty Field

XYAxisBaseTickMajorStyleProperty Field

Identifies the TickMajorStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorStyleProperty
Public Shared ReadOnly TickMajorStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorStyle dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.TickMinorStyleProperty Field

XYAxisBaseTickMinorStyleProperty Field

Identifies the TickMinorStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorStyleProperty
Public Shared ReadOnly TickMinorStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorStyle dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.TitleProperty Field

XYAxisBaseTitleProperty Field

Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.TitleStyleProperty Field

XYAxisBaseTitleStyleProperty Field

Identifies the TitleStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleStyleProperty
Public Shared ReadOnly TitleStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleStyle dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYAxisBase.UseDisplayOptimizationsProperty Field

XYAxisBaseUseDisplayOptimizationsProperty Field

Identifies the UseDisplayOptimizations dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDisplayOptimizationsProperty
Public Shared ReadOnly UseDisplayOptimizationsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDisplayOptimizations dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase Class

Provides the base class for a series that uses an X/Y axis.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesBarSeriesBase
ActiproSoftware.Windows.Controls.Charts.PrimitivesLineSeriesBase
ActiproSoftware.Windows.Controls.ChartsScatterSeries

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class XYSeriesBase : SeriesBase
Public MustInherit Class XYSeriesBase
    Inherits SeriesBase

The XYSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | XYSeriesBase | Initializes a new instance of the XYSeriesBase class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series.
Public property | Description | Gets or sets a description of the series. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property.
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property.
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout.
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property.
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property.
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property.
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Overrides SeriesBaseRefresh.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed.
Top
Fields
Name | Description
AggregationFactorProperty | Identifies the AggregationFactor dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
IsAggregationEnabledProperty | Identifies the IsAggregationEnabled dependency property. This field is read-only.
LegendMarkerStyleProperty | Identifies the LegendMarkerStyle dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
PrimaryAggregationKindProperty | Identifies the PrimaryAggregationKind dependency property. This field is read-only.
SecondaryAggregationKindProperty | Identifies the SecondaryAggregationKind dependency property. This field is read-only.
StackKindProperty | Identifies the StackKind dependency property. This field is read-only.
XAxisProperty | Identifies the XAxis dependency property. This field is read-only.
XPathProperty | Identifies the XPath dependency property. This field is read-only.
YAxisProperty | Identifies the YAxis dependency property. This field is read-only.
YPathProperty | Identifies the YPath dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase Constructor

Initializes a new instance of the XYSeriesBase class

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected XYSeriesBase()
Protected Sub New
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase Properties

The XYSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series.
Public property | Description | Gets or sets a description of the series. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property.
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property.
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout.
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property.
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property.
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property.
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.
Top
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.AggregationFactor Property

XYSeriesBaseAggregationFactor Property

Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AggregationFactor { get; set; }
Public Property AggregationFactor As Double
    Get
    Set

Property Value

Type: Double
A factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. The default value is 0.2.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.Chart Property

XYSeriesBaseChart Property

Gets the XYChart that owns this series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYChart Chart { get; }
Public ReadOnly Property Chart As XYChart
    Get

Property Value

Type: XYChart
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.Description Property

XYSeriesBaseDescription Property

Gets or sets a description of the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
A description of the series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.IsAggregationEnabled Property

XYSeriesBaseIsAggregationEnabled Property

Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAggregationEnabled { get; set; }
Public Property IsAggregationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data points will be an aggregation of the source data; otherwise, false. The default value is true.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.LegendMarkerStyle Property

XYSeriesBaseLegendMarkerStyle Property

Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LegendMarkerStyle { get; set; }
Public Property LegendMarkerStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the ChartMarker used when presenting a legend item for the series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.LegendStringFormat Property

XYSeriesBaseLegendStringFormat Property

Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format used when presenting legend item for the series. The default value is "{0}".
Remarks
The format string will be passed the following parameters:
  • {0} - The value of the primary axis. -
  • {1} - The value of the secondary axis. -
  • {2} - The X value. -
  • {3} - The Y value. -
  • {4} - Reserved. -
  • {5} - Description. -
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.MarkerStyle Property

XYSeriesBaseMarkerStyle Property

Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; set; }
Public Property MarkerStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the ChartMarker used to render the markers along the series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.MinimumMargin Property

XYSeriesBaseMinimumMargin Property

Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Nullable<Thickness> MinimumMargin { get; }
Protected Overridable ReadOnly Property MinimumMargin As Nullable(Of Thickness)
    Get

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.PrimaryAggregationKind Property

XYSeriesBasePrimaryAggregationKind Property

Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AggregationKind PrimaryAggregationKind { get; set; }
Public Property PrimaryAggregationKind As AggregationKind
    Get
    Set

Property Value

Type: AggregationKind
A AggregationKind indicating which kind of aggregation to perform along the primary axis. The default value is AggregationKind.Average.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.RequiresSlottedLayout Property

XYSeriesBaseRequiresSlottedLayout Property

Gets a value indicating whether the series requires slotted layout.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool RequiresSlottedLayout { get; }
Public Overridable ReadOnly Property RequiresSlottedLayout As Boolean
    Get

Property Value

Type: Boolean
true if the series requires slotted layout; otherwise, false.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.SecondaryAggregationKind Property

XYSeriesBaseSecondaryAggregationKind Property

Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AggregationKind SecondaryAggregationKind { get; set; }
Public Property SecondaryAggregationKind As AggregationKind
    Get
    Set

Property Value

Type: AggregationKind
A AggregationKind indicating which kind of aggregation to perform along the secondary axis. The default value is AggregationKind.First.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.StackKind Property

XYSeriesBaseStackKind Property

Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYSeriesStackKind StackKind { get; set; }
Public Property StackKind As XYSeriesStackKind
    Get
    Set

Property Value

Type: XYSeriesStackKind
The kind of stacking applied to the series. The default value is XYSeriesStackKind.None.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.XAxis Property

XYSeriesBaseXAxis Property

Gets or sets the X axis to be used for this series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYAxisBase XAxis { get; set; }
Public Property XAxis As XYAxisBase
    Get
    Set

Property Value

Type: XYAxisBase
The X axis to be used for this series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.XPath Property

XYSeriesBaseXPath Property

Gets or sets the path to the item property represented along the X-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string XPath { get; set; }
Public Property XPath As String
    Get
    Set

Property Value

Type: String
The path to the item property represented along the X-axis. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.YAxis Property

XYSeriesBaseYAxis Property

Gets or sets the Y axis to be used for this series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XYAxisBase YAxis { get; set; }
Public Property YAxis As XYAxisBase
    Get
    Set

Property Value

Type: XYAxisBase
The Y axis to be used for this series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.YPath Property

XYSeriesBaseYPath Property

Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string YPath { get; set; }
Public Property YPath As String
    Get
    Set

Property Value

Type: String
The path to the item property represented along the Y-axis. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase Methods

The XYSeriesBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state. (Overrides SeriesBaseRefresh.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.NormalizeValue Method

XYSeriesBaseNormalizeValue Method

Normalizes the value using the specified baseline

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Object NormalizeValue(
    Object value,
    Object baselineValue
)
Protected Overridable Function NormalizeValue (
    value As Object,
    baselineValue As Object
) As Object

Parameters

value
Type: SystemObject
The value to normalize.
baselineValue
Type: SystemObject
The baseline value.

Return Value

Type: Object
A normalized value.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.Refresh Method

XYSeriesBaseRefresh Method

Updates the series based on the current state.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase Events

The XYSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Refreshed | Occurs when the series is refreshed.
Top
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.Refreshed Event

XYSeriesBaseRefreshed Event

Occurs when the series is refreshed.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler Refreshed
Public Event Refreshed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase Fields

The XYSeriesBase type exposes the following members.

Fields
Name | Description
AggregationFactorProperty | Identifies the AggregationFactor dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
IsAggregationEnabledProperty | Identifies the IsAggregationEnabled dependency property. This field is read-only.
LegendMarkerStyleProperty | Identifies the LegendMarkerStyle dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
PrimaryAggregationKindProperty | Identifies the PrimaryAggregationKind dependency property. This field is read-only.
SecondaryAggregationKindProperty | Identifies the SecondaryAggregationKind dependency property. This field is read-only.
StackKindProperty | Identifies the StackKind dependency property. This field is read-only.
XAxisProperty | Identifies the XAxis dependency property. This field is read-only.
XPathProperty | Identifies the XPath dependency property. This field is read-only.
YAxisProperty | Identifies the YAxis dependency property. This field is read-only.
YPathProperty | Identifies the YPath dependency property. This field is read-only.
Top
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.AggregationFactorProperty Field

XYSeriesBaseAggregationFactorProperty Field

Identifies the AggregationFactor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AggregationFactorProperty
Public Shared ReadOnly AggregationFactorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AggregationFactor dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.DescriptionProperty Field

XYSeriesBaseDescriptionProperty Field

Identifies the Description dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DescriptionProperty
Public Shared ReadOnly DescriptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Description dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.IsAggregationEnabledProperty Field

XYSeriesBaseIsAggregationEnabledProperty Field

Identifies the IsAggregationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAggregationEnabledProperty
Public Shared ReadOnly IsAggregationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAggregationEnabled dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.LegendMarkerStyleProperty Field

XYSeriesBaseLegendMarkerStyleProperty Field

Identifies the LegendMarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendMarkerStyleProperty
Public Shared ReadOnly LegendMarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendMarkerStyle dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.LegendStringFormatProperty Field

XYSeriesBaseLegendStringFormatProperty Field

Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.MarkerStyleProperty Field

XYSeriesBaseMarkerStyleProperty Field

Identifies the MarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerStyleProperty
Public Shared ReadOnly MarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerStyle dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.PrimaryAggregationKindProperty Field

XYSeriesBasePrimaryAggregationKindProperty Field

Identifies the PrimaryAggregationKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PrimaryAggregationKindProperty
Public Shared ReadOnly PrimaryAggregationKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PrimaryAggregationKind dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.SecondaryAggregationKindProperty Field

XYSeriesBaseSecondaryAggregationKindProperty Field

Identifies the SecondaryAggregationKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SecondaryAggregationKindProperty
Public Shared ReadOnly SecondaryAggregationKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SecondaryAggregationKind dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.StackKindProperty Field

XYSeriesBaseStackKindProperty Field

Identifies the StackKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StackKindProperty
Public Shared ReadOnly StackKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StackKind dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.XAxisProperty Field

XYSeriesBaseXAxisProperty Field

Identifies the XAxis dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XAxisProperty
Public Shared ReadOnly XAxisProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XAxis dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.XPathProperty Field

XYSeriesBaseXPathProperty Field

Identifies the XPath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XPathProperty
Public Shared ReadOnly XPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XPath dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.YAxisProperty Field

XYSeriesBaseYAxisProperty Field

Identifies the YAxis dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YAxisProperty
Public Shared ReadOnly YAxisProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YAxis dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


XYSeriesBase.YPathProperty Field

XYSeriesBaseYPathProperty Field

Identifies the YPath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YPathProperty
Public Shared ReadOnly YPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YPath dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual Class

Draws an axis given axis data.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Charts.PrimitivesAxisVisual
ActiproSoftware.Windows.Controls.Charts.PrimitivesYAxisVisual

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class YAxisVisual : AxisVisual
Public Class YAxisVisual
    Inherits AxisVisual

The YAxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible. (Inherited from AxisVisual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis. (Overrides AxisVisualDrawMajorTickAtPosition(Double, Size).)
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis. (Overrides AxisVisualDrawMinorTickAtPosition(Double, Size).)
Protected method | DrawSpine | Draws an axis spine. (Overrides AxisVisualDrawSpine(Size).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary. (Overrides AxisVisualGetTitleTemplateFromResources(ResourceDictionary).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsSpineVisible | Determines whether or not the spine is visible. (Inherited from AxisVisual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AxisVisual.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position. (Overrides AxisVisualPlaceLabelAtPosition(TextBlock, Double, Double, Size).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Redraws the axis. (Inherited from AxisVisual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateTitlePosition | Updates the title position. (Overrides AxisVisualUpdateTitlePosition(Size).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual Properties

The YAxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual Methods

The YAxisVisual type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible. (Inherited from AxisVisual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis. (Overrides AxisVisualDrawMajorTickAtPosition(Double, Size).)
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis. (Overrides AxisVisualDrawMinorTickAtPosition(Double, Size).)
Protected method | DrawSpine | Draws an axis spine. (Overrides AxisVisualDrawSpine(Size).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary. (Overrides AxisVisualGetTitleTemplateFromResources(ResourceDictionary).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsSpineVisible | Determines whether or not the spine is visible. (Inherited from AxisVisual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AxisVisual.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position. (Overrides AxisVisualPlaceLabelAtPosition(TextBlock, Double, Double, Size).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Redraws the axis. (Inherited from AxisVisual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateTitlePosition | Updates the title position. (Overrides AxisVisualUpdateTitlePosition(Size).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual.ArrangeOverride Method

YAxisVisualArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual.DrawMajorTickAtPosition Method

YAxisVisualDrawMajorTickAtPosition Method

Draws a major tick at a given position on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void DrawMajorTickAtPosition(
    double position,
    Size plotSize
)
Protected Overrides Sub DrawMajorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: System.WindowsSize
Size of the plot.
See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual.DrawMinorTickAtPosition Method

YAxisVisualDrawMinorTickAtPosition Method

Draws a minor tick at a given position on the axis.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void DrawMinorTickAtPosition(
    double position,
    Size plotSize
)
Protected Overrides Sub DrawMinorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: System.WindowsSize
Size of the plot.
See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual.DrawSpine Method

YAxisVisualDrawSpine Method

Draws an axis spine.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void DrawSpine(
    Size plotSize
)
Protected Overrides Sub DrawSpine (
    plotSize As Size
)

Parameters

plotSize
Type: System.WindowsSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.YAxisVisual.DrawSpine(System.Windows.Size)"]

See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual.GetTitleTemplateFromResources Method

YAxisVisualGetTitleTemplateFromResources Method

Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DataTemplate GetTitleTemplateFromResources(
    ResourceDictionary resources
)
Protected Overrides Function GetTitleTemplateFromResources (
    resources As ResourceDictionary
) As DataTemplate

Parameters

resources
Type: System.WindowsResourceDictionary
The ResourceDictionary to retrieve the title template from.

Return Value

Type: DataTemplate
The template for the axis title.
See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual.MeasureOverride Method

YAxisVisualMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a argumentValue to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual.PlaceLabelAtPosition Method

YAxisVisualPlaceLabelAtPosition Method

Place the axis label at the given position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PlaceLabelAtPosition(
    TextBlock label,
    double position,
    double angle,
    Size plotSize
)
Protected Overrides Sub PlaceLabelAtPosition (
    label As TextBlock,
    position As Double,
    angle As Double,
    plotSize As Size
)

Parameters

label
Type: System.Windows.ControlsTextBlock
The axis label to lay out.
position
Type: SystemDouble
The position to draw the axis label at.
angle
Type: SystemDouble
The angle to draw the axis label at.
plotSize
Type: System.WindowsSize
Size of the plot.
Exceptions
Exception | Condition
ArgumentNullException | label
See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual.UpdateTitlePosition Method

YAxisVisualUpdateTitlePosition Method

Updates the title position.

Namespace: ActiproSoftware.Windows.Controls.Charts.Primitives
Assembly: ActiproSoftware.Charts.Wpf (in ActiproSoftware.Charts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateTitlePosition(
    Size plotSize
)
Protected Overrides Sub UpdateTitlePosition (
    plotSize As Size
)

Parameters

plotSize
Type: System.WindowsSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.Windows.Controls.Charts.Primitives.YAxisVisual.UpdateTitlePosition(System.Windows.Size)"]

See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


YAxisVisual Events

The YAxisVisual type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

YAxisVisual Class
ActiproSoftware.Windows.Controls.Charts.Primitives Namespace


ActiproSoftware.Windows.Controls.ColorSelection Namespace

Contains several controls for performing color selection similar to that found in Adobe Photoshop or Microsoft Expression Blend.
Classes
 | Class | Description
Public class | ColorComponentSlider | Represents a color component slider control.
Public class | ColorToStringConverter | Represents a value converter that converts between a Color and a web color (#FF00FF, etc.).
Public class | GradientBrushSlider | Represents a slider capable of altering the stops of a GradientBrush.
Public class | SpectrumColorPicker | Represents a hue spectrum color picker control.
Public class | SpectrumSlice | Represents a hue spectrum slice control.
Public class | SpectrumSlider | Represents a hue spectrum slider control.
Enumerations
 | Enumeration | Description
Public enumeration | ColorComponent | Specifies the various ARGB color components.


ColorComponent Enumeration

Specifies the various ARGB color components.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ColorComponent
Public Enumeration ColorComponent
Members
Member name | Value | Description
Alpha | 0 | Indicates the alpha color component.
Red | 1 | Indicates the red color component.
Green | 2 | Indicates the green color component.
Blue | 3 | Indicates the blue color component.
See Also

Reference

ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider Class

Represents a color component slider control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesRangeBase
System.Windows.ControlsSlider
ActiproSoftware.Windows.Controls.ColorSelectionColorComponentSlider

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ColorComponentSlider : Slider
Public Class ColorComponentSlider
    Inherits Slider

The ColorComponentSlider type exposes the following members.

Constructors
 | Name | Description
Public method | ColorComponentSlider | Initializes an instance of the ColorComponentSlider class.
Top
Properties
 | Name | Description
Public property | ActiveGradientBrush | Gets the active gradient brush to be presented by the slider. This is a dependency property.
Public property | AutoToolTipPlacement | Gets or sets whether a tooltip that contains the current value of the Slider displays when the Thumb is pressed. If a tooltip is displayed, this property also specifies the placement of the tooltip. (Inherited from Slider.)
Public property | AutoToolTipPrecision | Gets or sets the number of digits that are displayed to the right side of the decimal point for the Value of the Slider in a tooltip. (Inherited from Slider.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Component | Gets or sets the color component that is modified by the slider. This is a dependency property.
Public property | Delay | Gets or sets the amount of time in milliseconds that a RepeatButton waits, while it is pressed, before a command to move the Thumb executes, such as a DecreaseLarge command. (Inherited from Slider.)
Public property | DisabledOpacity | Gets or sets the opacity used when the control is disabled. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Interval | Gets or sets the amount of time in milliseconds between increase or decrease commands when a user clicks the RepeatButton of a Slider. (Inherited from Slider.)
Public property | IsDirectionReversed | Gets or sets the direction of increasing value. (Inherited from Slider.)
Public property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. (Inherited from Slider.)
Public property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider displays a selection range along the Slider. (Inherited from Slider.)
Public property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. (Inherited from Slider.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Orientation | Gets or sets the orientation of a Slider. (Inherited from Slider.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedColor | Gets or sets the Color that is selected in the slider. This is a dependency property.
Public property | SelectionEnd | Gets or sets the largest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SelectionStart | Gets or sets the smallest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickFrequency | Gets or sets the interval between tick marks. (Inherited from Slider.)
Public property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. (Inherited from Slider.)
Public property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. (Inherited from Slider.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a Slider and determines its Size. (Inherited from Slider.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Builds the visual tree for the Slider control. (Inherited from Slider.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Slider. (Inherited from Slider.)
Protected method | OnDecreaseLarge | Responds to the DecreaseLarge command. (Inherited from Slider.)
Protected method | OnDecreaseSmall | Responds to a DecreaseSmall command. (Inherited from Slider.)
Protected method | OnIncreaseLarge | Responds to an IncreaseLarge command. (Inherited from Slider.)
Protected method | OnIncreaseSmall | Responds to an IncreaseSmall command. (Inherited from Slider.)
Protected method | OnMaximizeValue | Responds to the MaximizeValue command. (Inherited from Slider.)
Protected method | OnMaximumChanged | Responds to a change in the value of the Maximum property. (Inherited from Slider.)
Protected method | OnMinimizeValue | Responds to a MinimizeValue command. (Inherited from Slider.)
Protected method | OnMinimumChanged | Responds to a change in the value of the Minimum property. (Inherited from Slider.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseLeftButtonDown | Provides class handling for the PreviewMouseLeftButtonDown routed event. (Inherited from Slider.)
Protected method | OnSelectedColorChanged | Raises the SelectedColorChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnThumbDragCompleted | Provides class handling for the DragCompleted event that occurs when the user stops dragging the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragDelta | Provides class handling for the DragDelta event that occurs when the user drags the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragStarted | Provides class handling for the DragStarted event that occurs when the user starts to drag the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnValueChanged | Occurs when the value of the slider changes. (Overrides SliderOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when the value of the SelectedColor property is changed.
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
Fields
Name | Description
ActiveGradientBrushProperty | Identifies the read-only ActiveGradientBrush dependency property. This field is read-only.
ComponentProperty | Identifies the Component dependency property. This field is read-only.
DisabledOpacityProperty | Identifies the DisabledOpacity dependency property. This field is read-only.
SelectedColorChangedEvent | Identifies the SelectedColorChanged routed event. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Shared Color Selection documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider Constructor

Initializes an instance of the ColorComponentSlider class.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorComponentSlider()
Public Sub New
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider Properties

The ColorComponentSlider type exposes the following members.

Properties
 | Name | Description
Public property | ActiveGradientBrush | Gets the active gradient brush to be presented by the slider. This is a dependency property.
Public property | AutoToolTipPlacement | Gets or sets whether a tooltip that contains the current value of the Slider displays when the Thumb is pressed. If a tooltip is displayed, this property also specifies the placement of the tooltip. (Inherited from Slider.)
Public property | AutoToolTipPrecision | Gets or sets the number of digits that are displayed to the right side of the decimal point for the Value of the Slider in a tooltip. (Inherited from Slider.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Component | Gets or sets the color component that is modified by the slider. This is a dependency property.
Public property | Delay | Gets or sets the amount of time in milliseconds that a RepeatButton waits, while it is pressed, before a command to move the Thumb executes, such as a DecreaseLarge command. (Inherited from Slider.)
Public property | DisabledOpacity | Gets or sets the opacity used when the control is disabled. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Interval | Gets or sets the amount of time in milliseconds between increase or decrease commands when a user clicks the RepeatButton of a Slider. (Inherited from Slider.)
Public property | IsDirectionReversed | Gets or sets the direction of increasing value. (Inherited from Slider.)
Public property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. (Inherited from Slider.)
Public property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider displays a selection range along the Slider. (Inherited from Slider.)
Public property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. (Inherited from Slider.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Orientation | Gets or sets the orientation of a Slider. (Inherited from Slider.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedColor | Gets or sets the Color that is selected in the slider. This is a dependency property.
Public property | SelectionEnd | Gets or sets the largest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SelectionStart | Gets or sets the smallest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickFrequency | Gets or sets the interval between tick marks. (Inherited from Slider.)
Public property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. (Inherited from Slider.)
Public property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. (Inherited from Slider.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.ActiveGradientBrush Property

ColorComponentSliderActiveGradientBrush Property

Gets the active gradient brush to be presented by the slider. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ActiveGradientBrush { get; }
Public ReadOnly Property ActiveGradientBrush As Brush
    Get

Property Value

Type: Brush
The active gradient brush to be presented by the slider. The default value is null.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.Component Property

ColorComponentSliderComponent Property

Gets or sets the color component that is modified by the slider. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorComponent Component { get; set; }
Public Property Component As ColorComponent
    Get
    Set

Property Value

Type: ColorComponent
The color component that is modified by the slider. The default value is ColorComponent.Alpha
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.DisabledOpacity Property

ColorComponentSliderDisabledOpacity Property

Gets or sets the opacity used when the control is disabled. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DisabledOpacity { get; set; }
Public Property DisabledOpacity As Double
    Get
    Set

Property Value

Type: Double
The opacity used when the control is disabled. The default value is 1.0.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.SelectedColor Property

ColorComponentSliderSelectedColor Property

Gets or sets the Color that is selected in the slider. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set

Property Value

Type: Color
The Color that is selected in the slider. The default value is Colors.Red.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider Methods

The ColorComponentSlider type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a Slider and determines its Size. (Inherited from Slider.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Builds the visual tree for the Slider control. (Inherited from Slider.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Slider. (Inherited from Slider.)
Protected method | OnDecreaseLarge | Responds to the DecreaseLarge command. (Inherited from Slider.)
Protected method | OnDecreaseSmall | Responds to a DecreaseSmall command. (Inherited from Slider.)
Protected method | OnIncreaseLarge | Responds to an IncreaseLarge command. (Inherited from Slider.)
Protected method | OnIncreaseSmall | Responds to an IncreaseSmall command. (Inherited from Slider.)
Protected method | OnMaximizeValue | Responds to the MaximizeValue command. (Inherited from Slider.)
Protected method | OnMaximumChanged | Responds to a change in the value of the Maximum property. (Inherited from Slider.)
Protected method | OnMinimizeValue | Responds to a MinimizeValue command. (Inherited from Slider.)
Protected method | OnMinimumChanged | Responds to a change in the value of the Minimum property. (Inherited from Slider.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseLeftButtonDown | Provides class handling for the PreviewMouseLeftButtonDown routed event. (Inherited from Slider.)
Protected method | OnSelectedColorChanged | Raises the SelectedColorChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnThumbDragCompleted | Provides class handling for the DragCompleted event that occurs when the user stops dragging the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragDelta | Provides class handling for the DragDelta event that occurs when the user drags the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragStarted | Provides class handling for the DragStarted event that occurs when the user starts to drag the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnValueChanged | Occurs when the value of the slider changes. (Overrides SliderOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.OnSelectedColorChanged Method

ColorComponentSliderOnSelectedColorChanged Method

Raises the SelectedColorChanged event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSelectedColorChanged(
    Color oldValue,
    Color newValue
)
Protected Overridable Sub OnSelectedColorChanged (
    oldValue As Color,
    newValue As Color
)

Parameters

oldValue
Type: System.Windows.MediaColor
The old value.
newValue
Type: System.Windows.MediaColor
The new value.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.OnValueChanged Method

ColorComponentSliderOnValueChanged Method

Occurs when the value of the slider changes.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    double oldValue,
    double newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The old value.
newValue
Type: SystemDouble
The new value.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider Events

The ColorComponentSlider type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when the value of the SelectedColor property is changed.
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.SelectedColorChanged Event

ColorComponentSliderSelectedColorChanged Event

Occurs when the value of the SelectedColor property is changed.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedPropertyChangedEventHandler<Color> SelectedColorChanged
Public Event SelectedColorChanged As RoutedPropertyChangedEventHandler(Of Color)

Value

Type: System.WindowsRoutedPropertyChangedEventHandler Color
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider Fields

The ColorComponentSlider type exposes the following members.

Fields
Name | Description
ActiveGradientBrushProperty | Identifies the read-only ActiveGradientBrush dependency property. This field is read-only.
ComponentProperty | Identifies the Component dependency property. This field is read-only.
DisabledOpacityProperty | Identifies the DisabledOpacity dependency property. This field is read-only.
SelectedColorChangedEvent | Identifies the SelectedColorChanged routed event. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
Top
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.ActiveGradientBrushProperty Field

ColorComponentSliderActiveGradientBrushProperty Field

Identifies the read-only ActiveGradientBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveGradientBrushProperty
Public Shared ReadOnly ActiveGradientBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveGradientBrush dependency property.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.ComponentProperty Field

ColorComponentSliderComponentProperty Field

Identifies the Component dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComponentProperty
Public Shared ReadOnly ComponentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Component dependency property.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.DisabledOpacityProperty Field

ColorComponentSliderDisabledOpacityProperty Field

Identifies the DisabledOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisabledOpacityProperty
Public Shared ReadOnly DisabledOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisabledOpacity dependency property.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.SelectedColorChangedEvent Field

ColorComponentSliderSelectedColorChangedEvent Field

Identifies the SelectedColorChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent SelectedColorChangedEvent
Public Shared ReadOnly SelectedColorChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the SelectedColorChanged routed event.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorComponentSlider.SelectedColorProperty Field

ColorComponentSliderSelectedColorProperty Field

Identifies the SelectedColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedColorProperty
Public Shared ReadOnly SelectedColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedColor dependency property.
See Also

Reference

ColorComponentSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorToStringConverter Class

Represents a value converter that converts between a Color and a web color (#FF00FF, etc.).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.ColorSelectionColorToStringConverter

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ColorToStringConverter : IValueConverter
Public Class ColorToStringConverter
    Implements IValueConverter

The ColorToStringConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ColorToStringConverter | Initializes a new instance of the ColorToStringConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
Remarks
The parameter can be a boolean true or false to indicate whether the alpha component of the color should be included.
See Also

Reference

ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorToStringConverter Constructor

Initializes a new instance of the ColorToStringConverter class

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorToStringConverter()
Public Sub New
See Also

Reference

ColorToStringConverter Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorToStringConverter Methods

The ColorToStringConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

ColorToStringConverter Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorToStringConverter.Convert Method

ColorToStringConverterConvert Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ColorToStringConverter Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ColorToStringConverter.ConvertBack Method

ColorToStringConverterConvertBack Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ColorToStringConverter Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider Class

Represents a slider capable of altering the stops of a GradientBrush.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ColorSelectionGradientBrushSlider

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GradientBrushSlider : Control
Public Class GradientBrushSlider
    Inherits Control

The GradientBrushSlider type exposes the following members.

Constructors
 | Name | Description
Public method | GradientBrushSlider | Initializes an instance of the GradientBrushSlider class.
Top
Properties
 | Name | Description
Public property | ActiveGradientBrush | Gets the active gradient brush to be presented by the slider. This is a dependency property.
 | AddStopCommand | Gets the RoutedCommand used to add a gradient stop.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAddStops | Gets or sets the whether stops can be added. This is a dependency property.
Public property | CanRemoveStops | Gets or sets the whether stops can be removed. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the slider. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
 | RemoveStopCommand | Gets the RoutedCommand used to remove a gradient stop.
 | ReverseStopsCommand | Gets the RoutedCommand used to reverse the gradient stops.
Public property | SelectedBrush | Gets or sets the GradientBrush that is selected in the slider. This is a dependency property.
Public property | SelectedStop | Gets the selected gradient stop in the slider. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddStop | Adds a gradient stop, where appropriate.
Public method | AddStop(Double) | Adds a gradient stop at the specified offset.
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | InvalidateThumbArrange | Invalidates the thumb panel's arrangement.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedBrushChanged | Raises the SelectedBrushChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | RemoveSelectedStop | Removes the selected gradient stop from the selected brush.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ReverseStops | Reverses the stops of the selected brush.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedBrushChanged | Occurs when the value of the SelectedBrush property is changed.
Top
Fields
Name | Description
ActiveGradientBrushProperty | Identifies the read-only ActiveGradientBrush dependency property. This field is read-only.
CanAddStopsProperty | Identifies the CanAddStops dependency property. This field is read-only.
CanRemoveStopsProperty | Identifies the CanRemoveStops dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SelectedBrushChangedEvent | Identifies the SelectedBrushChanged routed event. This field is read-only.
SelectedBrushProperty | Identifies the SelectedBrush dependency property. This field is read-only.
SelectedStopProperty | Identifies the read-only SelectedStop dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Shared Color Selection documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider Constructor

Initializes an instance of the GradientBrushSlider class.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientBrushSlider()
Public Sub New
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider Properties

The GradientBrushSlider type exposes the following members.

Properties
 | Name | Description
Public property | ActiveGradientBrush | Gets the active gradient brush to be presented by the slider. This is a dependency property.
 | AddStopCommand | Gets the RoutedCommand used to add a gradient stop.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAddStops | Gets or sets the whether stops can be added. This is a dependency property.
Public property | CanRemoveStops | Gets or sets the whether stops can be removed. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the slider. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
 | RemoveStopCommand | Gets the RoutedCommand used to remove a gradient stop.
 | ReverseStopsCommand | Gets the RoutedCommand used to reverse the gradient stops.
Public property | SelectedBrush | Gets or sets the GradientBrush that is selected in the slider. This is a dependency property.
Public property | SelectedStop | Gets the selected gradient stop in the slider. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.ActiveGradientBrush Property

GradientBrushSliderActiveGradientBrush Property

Gets the active gradient brush to be presented by the slider. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ActiveGradientBrush { get; }
Public ReadOnly Property ActiveGradientBrush As Brush
    Get

Property Value

Type: Brush
The active gradient brush to be presented by the slider. The default value is .
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.AddStopCommand Property

GradientBrushSliderAddStopCommand Property

Gets the RoutedCommand used to add a gradient stop.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static RoutedCommand AddStopCommand { get; }
Public Shared ReadOnly Property AddStopCommand As RoutedCommand
    Get

Property Value

Type: RoutedCommand
The RoutedCommand.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.CanAddStops Property

GradientBrushSliderCanAddStops Property

Gets or sets the whether stops can be added. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanAddStops { get; set; }
Public Property CanAddStops As Boolean
    Get
    Set

Property Value

Type: Boolean
true if stops can be added; otherwise, false. The default value is true.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.CanRemoveStops Property

GradientBrushSliderCanRemoveStops Property

Gets or sets the whether stops can be removed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanRemoveStops { get; set; }
Public Property CanRemoveStops As Boolean
    Get
    Set

Property Value

Type: Boolean
true if stops can be removed; otherwise, false. The default value is true.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.Orientation Property

GradientBrushSliderOrientation Property

Gets or sets the Orientation of the slider. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the slider. The default value is Orientation.Horizontal.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.RemoveStopCommand Property

GradientBrushSliderRemoveStopCommand Property

Gets the RoutedCommand used to remove a gradient stop.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static RoutedCommand RemoveStopCommand { get; }
Public Shared ReadOnly Property RemoveStopCommand As RoutedCommand
    Get

Property Value

Type: RoutedCommand
The RoutedCommand.
Remarks
This command will remove the gradient stop specified by the index in the command parameter. If no command parameter is provided, then the selected gradient stop will be removed, if any.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.ReverseStopsCommand Property

GradientBrushSliderReverseStopsCommand Property

Gets the RoutedCommand used to reverse the gradient stops.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static RoutedCommand ReverseStopsCommand { get; }
Public Shared ReadOnly Property ReverseStopsCommand As RoutedCommand
    Get

Property Value

Type: RoutedCommand
The RoutedCommand.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.SelectedBrush Property

GradientBrushSliderSelectedBrush Property

Gets or sets the GradientBrush that is selected in the slider. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush SelectedBrush { get; set; }
Public Property SelectedBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Color that is selected in the slider. The default value is .
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.SelectedStop Property

GradientBrushSliderSelectedStop Property

Gets the selected gradient stop in the slider. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientStop SelectedStop { get; }
Public ReadOnly Property SelectedStop As GradientStop
    Get

Property Value

Type: GradientStop
The selected gradient stop in the slider. The default value is .
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider Methods

The GradientBrushSlider type exposes the following members.

Methods
 | Name | Description
Public method | AddStop | Adds a gradient stop, where appropriate.
Public method | AddStop(Double) | Adds a gradient stop at the specified offset.
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | InvalidateThumbArrange | Invalidates the thumb panel's arrangement.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedBrushChanged | Raises the SelectedBrushChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | RemoveSelectedStop | Removes the selected gradient stop from the selected brush.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ReverseStops | Reverses the stops of the selected brush.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.AddStop Method

GradientBrushSliderAddStop Method

Overload List
 | Name | Description
Public method | AddStop | Adds a gradient stop, where appropriate.
Public method | AddStop(Double) | Adds a gradient stop at the specified offset.
Top
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.AddStop Method

GradientBrushSliderAddStop Method

Adds a gradient stop, where appropriate.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddStop()
Public Sub AddStop
See Also

Reference

GradientBrushSlider Class
AddStop Overload
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.AddStop Method (Double)

GradientBrushSliderAddStop Method (Double)

Adds a gradient stop at the specified offset.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddStop(
    double offset
)
Public Sub AddStop (
    offset As Double
)

Parameters

offset
Type: SystemDouble
The offset at which the gradient stop should be added.
See Also

Reference

GradientBrushSlider Class
AddStop Overload
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.InvalidateThumbArrange Method

GradientBrushSliderInvalidateThumbArrange Method

Invalidates the thumb panel's arrangement.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void InvalidateThumbArrange()
Public Sub InvalidateThumbArrange
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.OnApplyTemplate Method

GradientBrushSliderOnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.OnSelectedBrushChanged Method

GradientBrushSliderOnSelectedBrushChanged Method

Raises the SelectedBrushChanged event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSelectedBrushChanged(
    Brush oldValue,
    Brush newValue
)
Protected Overridable Sub OnSelectedBrushChanged (
    oldValue As Brush,
    newValue As Brush
)

Parameters

oldValue
Type: System.Windows.MediaBrush
The old value.
newValue
Type: System.Windows.MediaBrush
The new value.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.RemoveSelectedStop Method

GradientBrushSliderRemoveSelectedStop Method

Removes the selected gradient stop from the selected brush.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool RemoveSelectedStop()
Public Function RemoveSelectedStop As Boolean

Return Value

Type: Boolean
true if the selected gradient stop was removed; otherwise, false.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.ReverseStops Method

GradientBrushSliderReverseStops Method

Reverses the stops of the selected brush.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ReverseStops()
Public Sub ReverseStops
Remarks
Gradient stops at offset 1.0 will be moved to offset 0.0 gradient stops at offset 0.0 will be moved to offset 1.0. Gradient stops at offset 0.5 will not be changed.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider Events

The GradientBrushSlider type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedBrushChanged | Occurs when the value of the SelectedBrush property is changed.
Top
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.SelectedBrushChanged Event

GradientBrushSliderSelectedBrushChanged Event

Occurs when the value of the SelectedBrush property is changed.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedPropertyChangedEventHandler<Brush> SelectedBrushChanged
Public Event SelectedBrushChanged As RoutedPropertyChangedEventHandler(Of Brush)

Value

Type: System.WindowsRoutedPropertyChangedEventHandler Brush
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider Fields

The GradientBrushSlider type exposes the following members.

Fields
Name | Description
ActiveGradientBrushProperty | Identifies the read-only ActiveGradientBrush dependency property. This field is read-only.
CanAddStopsProperty | Identifies the CanAddStops dependency property. This field is read-only.
CanRemoveStopsProperty | Identifies the CanRemoveStops dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SelectedBrushChangedEvent | Identifies the SelectedBrushChanged routed event. This field is read-only.
SelectedBrushProperty | Identifies the SelectedBrush dependency property. This field is read-only.
SelectedStopProperty | Identifies the read-only SelectedStop dependency property. This field is read-only.
Top
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.ActiveGradientBrushProperty Field

GradientBrushSliderActiveGradientBrushProperty Field

Identifies the read-only ActiveGradientBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveGradientBrushProperty
Public Shared ReadOnly ActiveGradientBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveGradientBrush dependency property.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.CanAddStopsProperty Field

GradientBrushSliderCanAddStopsProperty Field

Identifies the CanAddStops dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAddStopsProperty
Public Shared ReadOnly CanAddStopsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAddStops dependency property.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.CanRemoveStopsProperty Field

GradientBrushSliderCanRemoveStopsProperty Field

Identifies the CanRemoveStops dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRemoveStopsProperty
Public Shared ReadOnly CanRemoveStopsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRemoveStops dependency property.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.OrientationProperty Field

GradientBrushSliderOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.SelectedBrushChangedEvent Field

GradientBrushSliderSelectedBrushChangedEvent Field

Identifies the SelectedBrushChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent SelectedBrushChangedEvent
Public Shared ReadOnly SelectedBrushChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the SelectedBrushChanged routed event.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.SelectedBrushProperty Field

GradientBrushSliderSelectedBrushProperty Field

Identifies the SelectedBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedBrushProperty
Public Shared ReadOnly SelectedBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedBrush dependency property.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


GradientBrushSlider.SelectedStopProperty Field

GradientBrushSliderSelectedStopProperty Field

Identifies the read-only SelectedStop dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedStopProperty
Public Shared ReadOnly SelectedStopProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedStop dependency property.
See Also

Reference

GradientBrushSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker Class

Represents a hue spectrum color picker control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ColorSelectionSpectrumColorPicker

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SpectrumColorPicker : Control
Public Class SpectrumColorPicker
    Inherits Control

The SpectrumColorPicker type exposes the following members.

Constructors
 | Name | Description
Public method | SpectrumColorPicker | Initializes an instance of the SpectrumColorPicker class.
Top
Properties
 | Name | Description
Public property | A | Gets or sets the ARGB alpha component of the SelectedColor.
Public property | B | Gets or sets the RGB blue component of the SelectedColor.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DisabledOpacity | Gets or sets the opacity used when the control is disabled.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | G | Gets or sets the RGB green component of the SelectedColor.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InitialColor | Gets or sets the Color that was initially selected in the picker.
Public property | InitialColorBrush | Gets a Brush that uses the InitialColor. This is a dependency property.
Public property | IsColorSwatchRowVisible | Gets or sets whether the color swatch row is visible in the color picker.
Public property | IsInitialColorVisible | Gets or sets whether the initial color swatch is visible in the color picker.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | R | Gets or sets the RGB red component of the SelectedColor.
Public property | SelectedColor | Gets or sets the Color that is selected in the picker.
Public property | SelectedColorBrush | Gets a Brush that uses the SelectedColor. This is a dependency property.
 | SetColor | Gets the ICommand for setting a color.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedColorChanged | Raises the SelectedColorChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when the value of the SelectedColor property is changed.
Top
Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BProperty | Identifies the B dependency property. This field is read-only.
DisabledOpacityProperty | Identifies the DisabledOpacity dependency property. This field is read-only.
GProperty | Identifies the G dependency property. This field is read-only.
InitialColorBrushProperty | Identifies the read-only InitialColorBrush dependency property. This field is read-only.
InitialColorProperty | Identifies the InitialColor dependency property. This field is read-only.
IsColorSwatchRowVisibleProperty | Identifies the IsColorSwatchRowVisible dependency property. This field is read-only.
IsInitialColorVisibleProperty | Identifies the IsInitialColorVisible dependency property. This field is read-only.
RProperty | Identifies the R dependency property. This field is read-only.
SelectedColorBrushProperty | Identifies the read-only SelectedColorBrush dependency property. This field is read-only.
SelectedColorChangedEvent | Identifies the SelectedColorChanged routed event. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Shared Color Selection documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker Constructor

Initializes an instance of the SpectrumColorPicker class.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpectrumColorPicker()
Public Sub New
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker Properties

The SpectrumColorPicker type exposes the following members.

Properties
 | Name | Description
Public property | A | Gets or sets the ARGB alpha component of the SelectedColor.
Public property | B | Gets or sets the RGB blue component of the SelectedColor.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DisabledOpacity | Gets or sets the opacity used when the control is disabled.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | G | Gets or sets the RGB green component of the SelectedColor.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InitialColor | Gets or sets the Color that was initially selected in the picker.
Public property | InitialColorBrush | Gets a Brush that uses the InitialColor. This is a dependency property.
Public property | IsColorSwatchRowVisible | Gets or sets whether the color swatch row is visible in the color picker.
Public property | IsInitialColorVisible | Gets or sets whether the initial color swatch is visible in the color picker.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | R | Gets or sets the RGB red component of the SelectedColor.
Public property | SelectedColor | Gets or sets the Color that is selected in the picker.
Public property | SelectedColorBrush | Gets a Brush that uses the SelectedColor. This is a dependency property.
 | SetColor | Gets the ICommand for setting a color.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.A Property

SpectrumColorPickerA Property

Gets or sets the ARGB alpha component of the SelectedColor.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte A { get; set; }
Public Property A As Byte
    Get
    Set

Property Value

Type: Byte
The ARGB alpha component of the SelectedColor.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.B Property

SpectrumColorPickerB Property

Gets or sets the RGB blue component of the SelectedColor.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte B { get; set; }
Public Property B As Byte
    Get
    Set

Property Value

Type: Byte
The RGB blue component of the SelectedColor.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.DisabledOpacity Property

SpectrumColorPickerDisabledOpacity Property

Gets or sets the opacity used when the control is disabled.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DisabledOpacity { get; set; }
Public Property DisabledOpacity As Double
    Get
    Set

Property Value

Type: Double
The opacity used when the control is disabled.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.G Property

SpectrumColorPickerG Property

Gets or sets the RGB green component of the SelectedColor.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte G { get; set; }
Public Property G As Byte
    Get
    Set

Property Value

Type: Byte
The RGB green component of the SelectedColor.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.InitialColor Property

SpectrumColorPickerInitialColor Property

Gets or sets the Color that was initially selected in the picker.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color InitialColor { get; set; }
Public Property InitialColor As Color
    Get
    Set

Property Value

Type: Color
The Color that was initially selected in the picker.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.InitialColorBrush Property

SpectrumColorPickerInitialColorBrush Property

Gets a Brush that uses the InitialColor. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush InitialColorBrush { get; }
Public ReadOnly Property InitialColorBrush As Brush
    Get

Property Value

Type: Brush
A Brush.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.IsColorSwatchRowVisible Property

SpectrumColorPickerIsColorSwatchRowVisible Property

Gets or sets whether the color swatch row is visible in the color picker.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsColorSwatchRowVisible { get; set; }
Public Property IsColorSwatchRowVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the color swatch row is visible in the color picker; otherwise, false. The default value is true.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.IsInitialColorVisible Property

SpectrumColorPickerIsInitialColorVisible Property

Gets or sets whether the initial color swatch is visible in the color picker.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsInitialColorVisible { get; set; }
Public Property IsInitialColorVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the initial color swatch is visible in the color picker; otherwise, false. The default value is true.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.R Property

SpectrumColorPickerR Property

Gets or sets the RGB red component of the SelectedColor.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte R { get; set; }
Public Property R As Byte
    Get
    Set

Property Value

Type: Byte
The RGB red component of the SelectedColor.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.SelectedColor Property

SpectrumColorPickerSelectedColor Property

Gets or sets the Color that is selected in the picker.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set

Property Value

Type: Color
The Color that is selected in the picker.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.SelectedColorBrush Property

SpectrumColorPickerSelectedColorBrush Property

Gets a Brush that uses the SelectedColor. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush SelectedColorBrush { get; }
Public ReadOnly Property SelectedColorBrush As Brush
    Get

Property Value

Type: Brush
A Brush.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.SetColor Property

SpectrumColorPickerSetColor Property

Gets the ICommand for setting a color.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ICommand SetColor { get; }
Public Shared ReadOnly Property SetColor As ICommand
    Get

Property Value

Type: ICommand
The ICommand for setting a color.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker Methods

The SpectrumColorPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedColorChanged | Raises the SelectedColorChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.OnApplyTemplate Method

SpectrumColorPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.OnSelectedColorChanged Method

SpectrumColorPickerOnSelectedColorChanged Method

Raises the SelectedColorChanged event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSelectedColorChanged(
    Color oldValue,
    Color newValue
)
Protected Overridable Sub OnSelectedColorChanged (
    oldValue As Color,
    newValue As Color
)

Parameters

oldValue
Type: System.Windows.MediaColor
The old value.
newValue
Type: System.Windows.MediaColor
The new value.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker Events

The SpectrumColorPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when the value of the SelectedColor property is changed.
Top
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.SelectedColorChanged Event

SpectrumColorPickerSelectedColorChanged Event

Occurs when the value of the SelectedColor property is changed.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedPropertyChangedEventHandler<Color> SelectedColorChanged
Public Event SelectedColorChanged As RoutedPropertyChangedEventHandler(Of Color)

Value

Type: System.WindowsRoutedPropertyChangedEventHandler Color
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker Fields

The SpectrumColorPicker type exposes the following members.

Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BProperty | Identifies the B dependency property. This field is read-only.
DisabledOpacityProperty | Identifies the DisabledOpacity dependency property. This field is read-only.
GProperty | Identifies the G dependency property. This field is read-only.
InitialColorBrushProperty | Identifies the read-only InitialColorBrush dependency property. This field is read-only.
InitialColorProperty | Identifies the InitialColor dependency property. This field is read-only.
IsColorSwatchRowVisibleProperty | Identifies the IsColorSwatchRowVisible dependency property. This field is read-only.
IsInitialColorVisibleProperty | Identifies the IsInitialColorVisible dependency property. This field is read-only.
RProperty | Identifies the R dependency property. This field is read-only.
SelectedColorBrushProperty | Identifies the read-only SelectedColorBrush dependency property. This field is read-only.
SelectedColorChangedEvent | Identifies the SelectedColorChanged routed event. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
Top
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.AProperty Field

SpectrumColorPickerAProperty Field

Identifies the A dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AProperty
Public Shared ReadOnly AProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the A dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.BProperty Field

SpectrumColorPickerBProperty Field

Identifies the B dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BProperty
Public Shared ReadOnly BProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the B dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.DisabledOpacityProperty Field

SpectrumColorPickerDisabledOpacityProperty Field

Identifies the DisabledOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisabledOpacityProperty
Public Shared ReadOnly DisabledOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisabledOpacity dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.GProperty Field

SpectrumColorPickerGProperty Field

Identifies the G dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GProperty
Public Shared ReadOnly GProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the G dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.InitialColorBrushProperty Field

SpectrumColorPickerInitialColorBrushProperty Field

Identifies the read-only InitialColorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InitialColorBrushProperty
Public Shared ReadOnly InitialColorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InitialColorBrush dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.InitialColorProperty Field

SpectrumColorPickerInitialColorProperty Field

Identifies the InitialColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InitialColorProperty
Public Shared ReadOnly InitialColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InitialColor dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.IsColorSwatchRowVisibleProperty Field

SpectrumColorPickerIsColorSwatchRowVisibleProperty Field

Identifies the IsColorSwatchRowVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsColorSwatchRowVisibleProperty
Public Shared ReadOnly IsColorSwatchRowVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsColorSwatchRowVisible dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.IsInitialColorVisibleProperty Field

SpectrumColorPickerIsInitialColorVisibleProperty Field

Identifies the IsInitialColorVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsInitialColorVisibleProperty
Public Shared ReadOnly IsInitialColorVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsInitialColorVisible dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.RProperty Field

SpectrumColorPickerRProperty Field

Identifies the R dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RProperty
Public Shared ReadOnly RProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the R dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.SelectedColorBrushProperty Field

SpectrumColorPickerSelectedColorBrushProperty Field

Identifies the read-only SelectedColorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedColorBrushProperty
Public Shared ReadOnly SelectedColorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedColorBrush dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.SelectedColorChangedEvent Field

SpectrumColorPickerSelectedColorChangedEvent Field

Identifies the SelectedColorChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent SelectedColorChangedEvent
Public Shared ReadOnly SelectedColorChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the SelectedColorChanged routed event.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumColorPicker.SelectedColorProperty Field

SpectrumColorPickerSelectedColorProperty Field

Identifies the SelectedColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedColorProperty
Public Shared ReadOnly SelectedColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedColor dependency property.
See Also

Reference

SpectrumColorPicker Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice Class

Represents a hue spectrum slice control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.ColorSelectionSpectrumSlice

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SpectrumSlice : Control
Public Class SpectrumSlice
    Inherits Control

The SpectrumSlice type exposes the following members.

Constructors
 | Name | Description
Public method | SpectrumSlice | Initializes an instance of the SpectrumSlice class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BaseColor | Gets or sets the Color that is used to construct the slice.
Public property | BaseColorBrush | Gets a Brush that uses the BaseColor. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | MarkedColor | Gets the Color that the marker is over in the slice. This is a dependency property.
Public property | MarkedColorBrush | Gets a Brush that uses the MarkedColor. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedColor | Gets or sets the Color that is selected in the slice. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked when an unhandled UIElement.MouseMove attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnSelectedColorChanged | Raises the SelectedColorChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when the value of the SelectedColor property is changed.
Top
Fields
Name | Description
BaseColorBrushProperty | Identifies the read-only BaseColorBrush dependency property. This field is read-only.
BaseColorProperty | Identifies the BaseColor dependency property. This field is read-only.
MarkedColorBrushProperty | Identifies the MarkedColorBrush dependency property. This field is read-only.
MarkedColorProperty | Identifies the MarkedColor dependency property. This field is read-only.
SelectedColorChangedEvent | Identifies the SelectedColorChanged routed event. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Shared Color Selection documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice Constructor

Initializes an instance of the SpectrumSlice class.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpectrumSlice()
Public Sub New
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice Properties

The SpectrumSlice type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BaseColor | Gets or sets the Color that is used to construct the slice.
Public property | BaseColorBrush | Gets a Brush that uses the BaseColor. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | MarkedColor | Gets the Color that the marker is over in the slice. This is a dependency property.
Public property | MarkedColorBrush | Gets a Brush that uses the MarkedColor. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedColor | Gets or sets the Color that is selected in the slice. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.BaseColor Property

SpectrumSliceBaseColor Property

Gets or sets the Color that is used to construct the slice.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color BaseColor { get; set; }
Public Property BaseColor As Color
    Get
    Set

Property Value

Type: Color
The Color that is used to construct the slice.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.BaseColorBrush Property

SpectrumSliceBaseColorBrush Property

Gets a Brush that uses the BaseColor. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BaseColorBrush { get; }
Public ReadOnly Property BaseColorBrush As Brush
    Get

Property Value

Type: Brush
A Brush.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.MarkedColor Property

SpectrumSliceMarkedColor Property

Gets the Color that the marker is over in the slice. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color MarkedColor { get; }
Public ReadOnly Property MarkedColor As Color
    Get

Property Value

Type: Color
The Color that the marker is over in the slice.
Remarks
When the mouse is used to drag the marker, this color is set to the SelectedColor property upon the release of the mouse button.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.MarkedColorBrush Property

SpectrumSliceMarkedColorBrush Property

Gets a Brush that uses the MarkedColor. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush MarkedColorBrush { get; }
Public ReadOnly Property MarkedColorBrush As Brush
    Get

Property Value

Type: Brush
A Brush.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.SelectedColor Property

SpectrumSliceSelectedColor Property

Gets or sets the Color that is selected in the slice. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set

Property Value

Type: Color
The Color that is selected in the slice.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice Methods

The SpectrumSlice type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked when an unhandled UIElement.MouseMove attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnSelectedColorChanged | Raises the SelectedColorChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.OnMouseLeftButtonDown Method

SpectrumSliceOnMouseLeftButtonDown Method

Invoked when an unhandled UIElement.MouseLeftButtonDown attached event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs that contains the event data.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.OnMouseLeftButtonUp Method

SpectrumSliceOnMouseLeftButtonUp Method

Invoked when an unhandled UIElement.MouseLeftButtonUp attached event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs that contains the event data.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.OnMouseMove Method

SpectrumSliceOnMouseMove Method

Invoked when an unhandled UIElement.MouseMove attached event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs that contains the event data.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.OnRenderSizeChanged Method

SpectrumSliceOnRenderSizeChanged Method

Called when the rendered size of a control changes.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRenderSizeChanged(
    SizeChangedInfo sizeInfo
)
Protected Overrides Sub OnRenderSizeChanged (
    sizeInfo As SizeChangedInfo
)

Parameters

sizeInfo
Type: System.WindowsSizeChangedInfo
Specifies the size changes.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.OnSelectedColorChanged Method

SpectrumSliceOnSelectedColorChanged Method

Raises the SelectedColorChanged event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSelectedColorChanged(
    Color oldValue,
    Color newValue
)
Protected Overridable Sub OnSelectedColorChanged (
    oldValue As Color,
    newValue As Color
)

Parameters

oldValue
Type: System.Windows.MediaColor
The old value.
newValue
Type: System.Windows.MediaColor
The new value.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice Events

The SpectrumSlice type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when the value of the SelectedColor property is changed.
Top
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.SelectedColorChanged Event

SpectrumSliceSelectedColorChanged Event

Occurs when the value of the SelectedColor property is changed.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedPropertyChangedEventHandler<Color> SelectedColorChanged
Public Event SelectedColorChanged As RoutedPropertyChangedEventHandler(Of Color)

Value

Type: System.WindowsRoutedPropertyChangedEventHandler Color
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice Fields

The SpectrumSlice type exposes the following members.

Fields
Name | Description
BaseColorBrushProperty | Identifies the read-only BaseColorBrush dependency property. This field is read-only.
BaseColorProperty | Identifies the BaseColor dependency property. This field is read-only.
MarkedColorBrushProperty | Identifies the MarkedColorBrush dependency property. This field is read-only.
MarkedColorProperty | Identifies the MarkedColor dependency property. This field is read-only.
SelectedColorChangedEvent | Identifies the SelectedColorChanged routed event. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
Top
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.BaseColorBrushProperty Field

SpectrumSliceBaseColorBrushProperty Field

Identifies the read-only BaseColorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaseColorBrushProperty
Public Shared ReadOnly BaseColorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BaseColorBrush dependency property.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.BaseColorProperty Field

SpectrumSliceBaseColorProperty Field

Identifies the BaseColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaseColorProperty
Public Shared ReadOnly BaseColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BaseColor dependency property.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.MarkedColorBrushProperty Field

SpectrumSliceMarkedColorBrushProperty Field

Identifies the MarkedColorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkedColorBrushProperty
Public Shared ReadOnly MarkedColorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkedColorBrush dependency property.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.MarkedColorProperty Field

SpectrumSliceMarkedColorProperty Field

Identifies the MarkedColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkedColorProperty
Public Shared ReadOnly MarkedColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkedColor dependency property.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.SelectedColorChangedEvent Field

SpectrumSliceSelectedColorChangedEvent Field

Identifies the SelectedColorChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent SelectedColorChangedEvent
Public Shared ReadOnly SelectedColorChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the SelectedColorChanged routed event.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlice.SelectedColorProperty Field

SpectrumSliceSelectedColorProperty Field

Identifies the SelectedColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedColorProperty
Public Shared ReadOnly SelectedColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedColor dependency property.
See Also

Reference

SpectrumSlice Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider Class

Represents a hue spectrum slider control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesRangeBase
System.Windows.ControlsSlider
ActiproSoftware.Windows.Controls.ColorSelectionSpectrumSlider

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SpectrumSlider : Slider
Public Class SpectrumSlider
    Inherits Slider

The SpectrumSlider type exposes the following members.

Constructors
 | Name | Description
Public method | SpectrumSlider | Initializes an instance of the SpectrumSlider class.
Top
Properties
 | Name | Description
Public property | AutoToolTipPlacement | Gets or sets whether a tooltip that contains the current value of the Slider displays when the Thumb is pressed. If a tooltip is displayed, this property also specifies the placement of the tooltip. (Inherited from Slider.)
Public property | AutoToolTipPrecision | Gets or sets the number of digits that are displayed to the right side of the decimal point for the Value of the Slider in a tooltip. (Inherited from Slider.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Delay | Gets or sets the amount of time in milliseconds that a RepeatButton waits, while it is pressed, before a command to move the Thumb executes, such as a DecreaseLarge command. (Inherited from Slider.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Interval | Gets or sets the amount of time in milliseconds between increase or decrease commands when a user clicks the RepeatButton of a Slider. (Inherited from Slider.)
Public property | IsDirectionReversed | Gets or sets the direction of increasing value. (Inherited from Slider.)
Public property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. (Inherited from Slider.)
Public property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider displays a selection range along the Slider. (Inherited from Slider.)
Public property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. (Inherited from Slider.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Orientation | Gets or sets the orientation of a Slider. (Inherited from Slider.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedColor | Gets or sets the Color that is selected in the slider.
Public property | SelectionEnd | Gets or sets the largest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SelectionStart | Gets or sets the smallest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickFrequency | Gets or sets the interval between tick marks. (Inherited from Slider.)
Public property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. (Inherited from Slider.)
Public property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. (Inherited from Slider.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a Slider and determines its Size. (Inherited from Slider.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Builds the visual tree for the Slider control. (Inherited from Slider.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Slider. (Inherited from Slider.)
Protected method | OnDecreaseLarge | Responds to the DecreaseLarge command. (Inherited from Slider.)
Protected method | OnDecreaseSmall | Responds to a DecreaseSmall command. (Inherited from Slider.)
Protected method | OnIncreaseLarge | Responds to an IncreaseLarge command. (Inherited from Slider.)
Protected method | OnIncreaseSmall | Responds to an IncreaseSmall command. (Inherited from Slider.)
Protected method | OnMaximizeValue | Responds to the MaximizeValue command. (Inherited from Slider.)
Protected method | OnMaximumChanged | Responds to a change in the value of the Maximum property. (Inherited from Slider.)
Protected method | OnMinimizeValue | Responds to a MinimizeValue command. (Inherited from Slider.)
Protected method | OnMinimumChanged | Responds to a change in the value of the Minimum property. (Inherited from Slider.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked when an unhandled UIElement.MouseMove attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseWheel | Invoked when an unhandled UIElement.MouseWheel attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseWheel(MouseWheelEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled UIElement.PreviewMouseLeftButtonDown attached event is raised on this element. Implement this method to add class handling for this event. (Overrides SliderOnPreviewMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnSelectedColorChanged | Raises the SelectedColorChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnThumbDragCompleted | Provides class handling for the DragCompleted event that occurs when the user stops dragging the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragDelta | Provides class handling for the DragDelta event that occurs when the user drags the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragStarted | Provides class handling for the DragStarted event that occurs when the user starts to drag the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnValueChanged | Occurs when the value of the slider changes. (Overrides SliderOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when the value of the SelectedColor property is changed.
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
Fields
Name | Description
SelectedColorChangedEvent | Identifies the SelectedColorChanged routed event. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Shared Color Selection documentation topic.
See Also

Reference

ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider Constructor

Initializes an instance of the SpectrumSlider class.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpectrumSlider()
Public Sub New
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider Properties

The SpectrumSlider type exposes the following members.

Properties
 | Name | Description
Public property | AutoToolTipPlacement | Gets or sets whether a tooltip that contains the current value of the Slider displays when the Thumb is pressed. If a tooltip is displayed, this property also specifies the placement of the tooltip. (Inherited from Slider.)
Public property | AutoToolTipPrecision | Gets or sets the number of digits that are displayed to the right side of the decimal point for the Value of the Slider in a tooltip. (Inherited from Slider.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Delay | Gets or sets the amount of time in milliseconds that a RepeatButton waits, while it is pressed, before a command to move the Thumb executes, such as a DecreaseLarge command. (Inherited from Slider.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Interval | Gets or sets the amount of time in milliseconds between increase or decrease commands when a user clicks the RepeatButton of a Slider. (Inherited from Slider.)
Public property | IsDirectionReversed | Gets or sets the direction of increasing value. (Inherited from Slider.)
Public property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. (Inherited from Slider.)
Public property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider displays a selection range along the Slider. (Inherited from Slider.)
Public property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. (Inherited from Slider.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Orientation | Gets or sets the orientation of a Slider. (Inherited from Slider.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedColor | Gets or sets the Color that is selected in the slider.
Public property | SelectionEnd | Gets or sets the largest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SelectionStart | Gets or sets the smallest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TickFrequency | Gets or sets the interval between tick marks. (Inherited from Slider.)
Public property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. (Inherited from Slider.)
Public property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. (Inherited from Slider.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.SelectedColor Property

SpectrumSliderSelectedColor Property

Gets or sets the Color that is selected in the slider.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set

Property Value

Type: Color
The Color that is selected in the slider.
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider Methods

The SpectrumSlider type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a Slider and determines its Size. (Inherited from Slider.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Builds the visual tree for the Slider control. (Inherited from Slider.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Slider. (Inherited from Slider.)
Protected method | OnDecreaseLarge | Responds to the DecreaseLarge command. (Inherited from Slider.)
Protected method | OnDecreaseSmall | Responds to a DecreaseSmall command. (Inherited from Slider.)
Protected method | OnIncreaseLarge | Responds to an IncreaseLarge command. (Inherited from Slider.)
Protected method | OnIncreaseSmall | Responds to an IncreaseSmall command. (Inherited from Slider.)
Protected method | OnMaximizeValue | Responds to the MaximizeValue command. (Inherited from Slider.)
Protected method | OnMaximumChanged | Responds to a change in the value of the Maximum property. (Inherited from Slider.)
Protected method | OnMinimizeValue | Responds to a MinimizeValue command. (Inherited from Slider.)
Protected method | OnMinimumChanged | Responds to a change in the value of the Minimum property. (Inherited from Slider.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked when an unhandled UIElement.MouseMove attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseWheel | Invoked when an unhandled UIElement.MouseWheel attached event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseWheel(MouseWheelEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled UIElement.PreviewMouseLeftButtonDown attached event is raised on this element. Implement this method to add class handling for this event. (Overrides SliderOnPreviewMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnSelectedColorChanged | Raises the SelectedColorChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnThumbDragCompleted | Provides class handling for the DragCompleted event that occurs when the user stops dragging the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragDelta | Provides class handling for the DragDelta event that occurs when the user drags the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragStarted | Provides class handling for the DragStarted event that occurs when the user starts to drag the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnValueChanged | Occurs when the value of the slider changes. (Overrides SliderOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.OnMouseLeftButtonUp Method

SpectrumSliderOnMouseLeftButtonUp Method

Invoked when an unhandled UIElement.MouseLeftButtonUp attached event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs that contains the event data.
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.OnMouseMove Method

SpectrumSliderOnMouseMove Method

Invoked when an unhandled UIElement.MouseMove attached event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs that contains the event data.
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.OnMouseWheel Method

SpectrumSliderOnMouseWheel Method

Invoked when an unhandled UIElement.MouseWheel attached event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseWheel(
    MouseWheelEventArgs e
)
Protected Overrides Sub OnMouseWheel (
    e As MouseWheelEventArgs
)

Parameters

e
Type: System.Windows.InputMouseWheelEventArgs
A MouseWheelEventArgs that contains the event data.
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.OnPreviewMouseLeftButtonDown Method

SpectrumSliderOnPreviewMouseLeftButtonDown Method

Invoked when an unhandled UIElement.PreviewMouseLeftButtonDown attached event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPreviewMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnPreviewMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs that contains the event data.
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.OnSelectedColorChanged Method

SpectrumSliderOnSelectedColorChanged Method

Raises the SelectedColorChanged event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSelectedColorChanged(
    Color oldValue,
    Color newValue
)
Protected Overridable Sub OnSelectedColorChanged (
    oldValue As Color,
    newValue As Color
)

Parameters

oldValue
Type: System.Windows.MediaColor
The old value.
newValue
Type: System.Windows.MediaColor
The new value.
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.OnValueChanged Method

SpectrumSliderOnValueChanged Method

Occurs when the value of the slider changes.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    double oldValue,
    double newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The old value.
newValue
Type: SystemDouble
The new value.
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider Events

The SpectrumSlider type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when the value of the SelectedColor property is changed.
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.SelectedColorChanged Event

SpectrumSliderSelectedColorChanged Event

Occurs when the value of the SelectedColor property is changed.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedPropertyChangedEventHandler<Color> SelectedColorChanged
Public Event SelectedColorChanged As RoutedPropertyChangedEventHandler(Of Color)

Value

Type: System.WindowsRoutedPropertyChangedEventHandler Color
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider Fields

The SpectrumSlider type exposes the following members.

Fields
Name | Description
SelectedColorChangedEvent | Identifies the SelectedColorChanged routed event. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
Top
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.SelectedColorChangedEvent Field

SpectrumSliderSelectedColorChangedEvent Field

Identifies the SelectedColorChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent SelectedColorChangedEvent
Public Shared ReadOnly SelectedColorChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the SelectedColorChanged routed event.
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


SpectrumSlider.SelectedColorProperty Field

SpectrumSliderSelectedColorProperty Field

Identifies the SelectedColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedColorProperty
Public Shared ReadOnly SelectedColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedColor dependency property.
See Also

Reference

SpectrumSlider Class
ActiproSoftware.Windows.Controls.ColorSelection Namespace


ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace

Contains the primitive types related to color selection.
Classes
 | Class | Description
Public class | GradientBrushThumb | Represents a thumb for use in GradientBrushSlider.
Public class | GradientBrushThumbPanel | Represents a panel for use in a GradientBrushSlider.


GradientBrushThumb Class

Represents a thumb for use in GradientBrushSlider.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesThumb
ActiproSoftware.Windows.Controls.ColorSelection.PrimitivesGradientBrushThumb

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GradientBrushThumb : Thumb
Public Class GradientBrushThumb
    Inherits Thumb

The GradientBrushThumb type exposes the following members.

Constructors
 | Name | Description
Public method | GradientBrushThumb | Initializes a new instance of the GradientBrushThumb class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDragging | Gets whether the Thumb control has logical focus and mouse capture and the left mouse button is pressed. (Inherited from Thumb.)
Public property | IsSelected | Gets or sets a value indicating whether the item is selected. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the panel. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Stop | Gets or sets the gradient stop represented by this thumb. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CancelDrag | Cancels a drag operation for the Thumb. (Inherited from Thumb.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Thumb control. (Inherited from Thumb.)
Protected method | OnDraggingChanged | Responds to a change in the value of the IsDragging property. (Inherited from Thumb.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown event. (Overrides ThumbOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp event. (Inherited from Thumb.)
Protected method | OnMouseMove | Provides class handling for the MouseMove event. (Inherited from Thumb.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | DragCompleted | Occurs when the Thumb control loses mouse capture. (Inherited from Thumb.)
Public event | DragDelta | Occurs one or more times as the mouse changes position when a Thumb control has logical focus and mouse capture. (Inherited from Thumb.)
Public event | DragStarted | Occurs when a Thumb control receives logical focus and mouse capture. (Inherited from Thumb.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Selected | Occurs when the thumb is selected.
Public event | Unselected | Occurs when the thumb is unselected.
Top
Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SelectedEvent | Identifies the Selected routed event. This field is read-only.
StopProperty | Identifies the Stop dependency property. This field is read-only.
UnselectedEvent | Identifies the Unselected routed event. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb Constructor

Initializes a new instance of the GradientBrushThumb class.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientBrushThumb()
Public Sub New
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb Properties

The GradientBrushThumb type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDragging | Gets whether the Thumb control has logical focus and mouse capture and the left mouse button is pressed. (Inherited from Thumb.)
Public property | IsSelected | Gets or sets a value indicating whether the item is selected. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the panel. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Stop | Gets or sets the gradient stop represented by this thumb. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.IsSelected Property

GradientBrushThumbIsSelected Property

Gets or sets a value indicating whether the item is selected. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is selected; otherwise, false. The default value is false.
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.Orientation Property

GradientBrushThumbOrientation Property

Gets or sets the Orientation of the panel. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the panel. The default value is Orientation.Horizontal
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.Stop Property

GradientBrushThumbStop Property

Gets or sets the gradient stop represented by this thumb. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientStop Stop { get; set; }
Public Property Stop As GradientStop
    Get
    Set

Property Value

Type: GradientStop
The gradient stop represented by this thumb. The default value is .
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb Methods

The GradientBrushThumb type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CancelDrag | Cancels a drag operation for the Thumb. (Inherited from Thumb.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Thumb control. (Inherited from Thumb.)
Protected method | OnDraggingChanged | Responds to a change in the value of the IsDragging property. (Inherited from Thumb.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown event. (Overrides ThumbOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp event. (Inherited from Thumb.)
Protected method | OnMouseMove | Provides class handling for the MouseMove event. (Inherited from Thumb.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.OnIsKeyboardFocusWithinChanged Method

GradientBrushThumbOnIsKeyboardFocusWithinChanged Method

Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
A DependencyPropertyChangedEventArgs that contains the event data.
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.OnMouseLeftButtonDown Method

GradientBrushThumbOnMouseLeftButtonDown Method

Provides class handling for the MouseLeftButtonDown event.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The event data.
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb Events

The GradientBrushThumb type exposes the following members.

Events
 | Name | Description
Public event | DragCompleted | Occurs when the Thumb control loses mouse capture. (Inherited from Thumb.)
Public event | DragDelta | Occurs one or more times as the mouse changes position when a Thumb control has logical focus and mouse capture. (Inherited from Thumb.)
Public event | DragStarted | Occurs when a Thumb control receives logical focus and mouse capture. (Inherited from Thumb.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Selected | Occurs when the thumb is selected.
Public event | Unselected | Occurs when the thumb is unselected.
Top
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.Selected Event

GradientBrushThumbSelected Event

Occurs when the thumb is selected.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Selected
Public Event Selected As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.Unselected Event

GradientBrushThumbUnselected Event

Occurs when the thumb is unselected.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Unselected
Public Event Unselected As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb Fields

The GradientBrushThumb type exposes the following members.

Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SelectedEvent | Identifies the Selected routed event. This field is read-only.
StopProperty | Identifies the Stop dependency property. This field is read-only.
UnselectedEvent | Identifies the Unselected routed event. This field is read-only.
Top
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.IsSelectedProperty Field

GradientBrushThumbIsSelectedProperty Field

Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.OrientationProperty Field

GradientBrushThumbOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.SelectedEvent Field

GradientBrushThumbSelectedEvent Field

Identifies the Selected routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent SelectedEvent
Public Shared ReadOnly SelectedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Selected routed event.
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.StopProperty Field

GradientBrushThumbStopProperty Field

Identifies the Stop dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StopProperty
Public Shared ReadOnly StopProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Stop dependency property.
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumb.UnselectedEvent Field

GradientBrushThumbUnselectedEvent Field

Identifies the Unselected routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent UnselectedEvent
Public Shared ReadOnly UnselectedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Unselected routed event.
See Also

Reference

GradientBrushThumb Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel Class

Represents a panel for use in a GradientBrushSlider.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.ColorSelection.PrimitivesGradientBrushThumbPanel

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GradientBrushThumbPanel : Panel
Public Class GradientBrushThumbPanel
    Inherits Panel

The GradientBrushThumbPanel type exposes the following members.

Constructors
 | Name | Description
Public method | GradientBrushThumbPanel | Initializes a new instance of the GradientBrushThumbPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets or sets the Orientation of the panel. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetOffset | Gets the value of the OffsetProperty attached property for the specified object.
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetOffset | Sets the value of the OffsetProperty attached property to the specified object.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
OffsetProperty | Identifies the Offset dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | Offset |
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel Constructor

Initializes a new instance of the GradientBrushThumbPanel class

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientBrushThumbPanel()
Public Sub New
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel Properties

The GradientBrushThumbPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets or sets the Orientation of the panel. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel.Orientation Property

GradientBrushThumbPanelOrientation Property

Gets or sets the Orientation of the panel. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the panel. The default value is Orientation.Horizontal
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel Methods

The GradientBrushThumbPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetOffset | Gets the value of the OffsetProperty attached property for the specified object.
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetOffset | Sets the value of the OffsetProperty attached property to the specified object.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel.ArrangeOverride Method

GradientBrushThumbPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel.GetOffset Method

GradientBrushThumbPanelGetOffset Method

Gets the value of the OffsetProperty attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetOffset(
    UIElement element
)
Public Shared Function GetOffset (
    element As UIElement
) As Double

Parameters

element
Type: System.WindowsUIElement
The element from which the property value is read.

Return Value

Type: Double
The object's value.
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel.MeasureOverride Method

GradientBrushThumbPanelMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel.SetOffset Method

GradientBrushThumbPanelSetOffset Method

Sets the value of the OffsetProperty attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetOffset(
    UIElement element,
    double value
)
Public Shared Sub SetOffset (
    element As UIElement,
    value As Double
)

Parameters

element
Type: System.WindowsUIElement
The element to which the attached property is written.
value
Type: SystemDouble
The value to set.
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel Fields

The GradientBrushThumbPanel type exposes the following members.

Fields
Name | Description
OffsetProperty | Identifies the Offset dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel.OffsetProperty Field

GradientBrushThumbPanelOffsetProperty Field

Identifies the Offset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OffsetProperty
Public Shared ReadOnly OffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Offset dependency property.
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel.OrientationProperty Field

GradientBrushThumbPanelOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel Attached Properties

The GradientBrushThumbPanel type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | Offset |
Top
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


GradientBrushThumbPanel.Offset Attached Property

GradientBrushThumbPanelOffset Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.ColorSelection.Primitives.GradientBrushThumbPanel.Offset"]

Namespace: ActiproSoftware.Windows.Controls.ColorSelection.Primitives
Assembly: ActiproSoftware.Shared.Wpf (in ActiproSoftware.Shared.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetOffset, SetOffset
See GetOffset, SetOffset

Property Value

Type: Double
See Also

Reference

GradientBrushThumbPanel Class
ActiproSoftware.Windows.Controls.ColorSelection.Primitives Namespace


ActiproSoftware.Windows.Controls.DataGrid Namespace

Contains classes that provide enhancements for the Microsoft DataGrid.
Classes
 | Class | Description
Public class | DataGridCommands | Contains the commands used for the ActiproSoftware.Windows.Controls.DataGrid control.
Public class | DataGridExtensions | Represents a set of helper extension methods for the DataGrid.
Public class | FocusBehavior | Provides attached behavior for DataGrid controls to track the focus.
Public class | NewRowTemplateBehavior | Provides attached behavior for DataGrid controls to customize the new row template.
Public class | SelectionBehavior | Provides attached behavior for DataGrid controls to track the selection.
Public class | ThemedDataGrid | Represents a DataGrid that uses custom themes and integrates into the Actipro theme manager.
Enumerations
 | Enumeration | Description
Public enumeration | FocusTrackingModes | Specifies the various tracking modes available by the FocusBehavior.
Public enumeration | SelectionTrackingModes | Specifies the various tracking modes available by the SelectionBehavior.


DataGridCommands Class

Contains the commands used for the ActiproSoftware.Windows.Controls.DataGrid control.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.DataGridDataGridCommands

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class DataGridCommands
Public NotInheritable Class DataGridCommands

The DataGridCommands type exposes the following members.

Properties
Name | Description
ToggleFrozenColumn | Gets the RoutedCommand that is used to toggle the frozen state of a DataGridColumn.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.DataGrid Namespace


DataGridCommands Properties

The DataGridCommands type exposes the following members.

Properties
Name | Description
ToggleFrozenColumn | Gets the RoutedCommand that is used to toggle the frozen state of a DataGridColumn.
Top
See Also

Reference

DataGridCommands Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


DataGridCommands.ToggleFrozenColumn Property

DataGridCommandsToggleFrozenColumn Property

Gets the RoutedCommand that is used to toggle the frozen state of a DataGridColumn.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static RoutedCommand ToggleFrozenColumn { get; }
Public Shared ReadOnly Property ToggleFrozenColumn As RoutedCommand
    Get

Property Value

Type: RoutedCommand
The RoutedCommand that is used to toggle the frozen state of a DataGridColumn.
Remarks
The related DataGridColumnHeader must be located in the command parameter.
See Also

Reference

DataGridCommands Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


DataGridExtensions Class

Represents a set of helper extension methods for the DataGrid.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.DataGridDataGridExtensions

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class DataGridExtensions
<ExtensionAttribute>
Public NotInheritable Class DataGridExtensions
Methods
Name | Description
GetRow(DataGrid, Int32) | Gets the DataGridRow at the specified index.
GetRow(DataGrid, Object) | Gets the DataGridRow for the specified item.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.DataGrid Namespace


DataGridExtensions Methods

Methods
Name | Description
GetRow(DataGrid, Int32) | Gets the DataGridRow at the specified index.
GetRow(DataGrid, Object) | Gets the DataGridRow for the specified item.
Top
See Also

Reference

DataGridExtensions Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


DataGridExtensions.GetRow Method

DataGridExtensionsGetRow Method

Overload List
Name | Description
GetRow(DataGrid, Int32) | Gets the DataGridRow at the specified index.
GetRow(DataGrid, Object) | Gets the DataGridRow for the specified item.
Top
See Also

Reference

DataGridExtensions Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


DataGridExtensions.GetRow Method (DataGrid, Int32)

DataGridExtensionsGetRow Method (DataGrid, Int32)

Gets the DataGridRow at the specified index.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DataGridRow GetRow(
    this DataGrid dataGrid,
    int index
)
<ExtensionAttribute>
Public Shared Function GetRow (
    dataGrid As DataGrid,
    index As Integer
) As DataGridRow

Parameters

dataGrid
Type: System.Windows.ControlsDataGrid
The DataGrid.
index
Type: SystemInt32
The index of the DataGridRow.

Return Value

Type: DataGridRow
The DataGridRow at the specified index.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataGrid. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataGridExtensions Class
GetRow Overload
ActiproSoftware.Windows.Controls.DataGrid Namespace


DataGridExtensions.GetRow Method (DataGrid, Object)

DataGridExtensionsGetRow Method (DataGrid, Object)

Gets the DataGridRow for the specified item.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DataGridRow GetRow(
    this DataGrid dataGrid,
    Object item
)
<ExtensionAttribute>
Public Shared Function GetRow (
    dataGrid As DataGrid,
    item As Object
) As DataGridRow

Parameters

dataGrid
Type: System.Windows.ControlsDataGrid
The DataGrid.
item
Type: SystemObject
The item.

Return Value

Type: DataGridRow
The DataGridRow for the specified item.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataGrid. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataGridExtensions Class
GetRow Overload
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior Class

Provides attached behavior for DataGrid controls to track the focus.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.DataGridFocusBehavior

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class FocusBehavior
Public NotInheritable Class FocusBehavior

The FocusBehavior type exposes the following members.

Methods
Name | Description
GetIsFocusedHeader | Gets a value indicating whether a DataGridColumnHeader corresponds to the column of the a currently focused DataGridCell.
GetTrackingModes | Gets the value of the TrackingModesProperty attached property for a specified DataGrid.
SetTrackingModes | Sets the value of the TrackingModesProperty attached property to a specified DataGrid.
Top
Fields
Name | Description
IsFocusedHeaderProperty | Identifies the IsFocusedHeader attached dependency property. This field is read-only.
TrackingModesProperty | Identifies the TrackingModes attached dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | IsFocusedHeader |
Public attached property | TrackingModes |
Top
See Also

Reference

ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior Methods

The FocusBehavior type exposes the following members.

Methods
Name | Description
GetIsFocusedHeader | Gets a value indicating whether a DataGridColumnHeader corresponds to the column of the a currently focused DataGridCell.
GetTrackingModes | Gets the value of the TrackingModesProperty attached property for a specified DataGrid.
SetTrackingModes | Sets the value of the TrackingModesProperty attached property to a specified DataGrid.
Top
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior.GetIsFocusedHeader Method

FocusBehaviorGetIsFocusedHeader Method

Gets a value indicating whether a DataGridColumnHeader corresponds to the column of the a currently focused DataGridCell.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsFocusedHeader(
    DataGridColumnHeader obj
)
Public Shared Function GetIsFocusedHeader (
    obj As DataGridColumnHeader
) As Boolean

Parameters

obj
Type: System.Windows.Controls.PrimitivesDataGridColumnHeader
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior.GetTrackingModes Method

FocusBehaviorGetTrackingModes Method

Gets the value of the TrackingModesProperty attached property for a specified DataGrid.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static FocusTrackingModes GetTrackingModes(
    DataGrid obj
)
Public Shared Function GetTrackingModes (
    obj As DataGrid
) As FocusTrackingModes

Parameters

obj
Type: System.Windows.ControlsDataGrid
The object to which the attached property is retrieved.

Return Value

Type: FocusTrackingModes
The focus that should be tracked in a DataGrid.
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior.SetTrackingModes Method

FocusBehaviorSetTrackingModes Method

Sets the value of the TrackingModesProperty attached property to a specified DataGrid.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetTrackingModes(
    DataGrid obj,
    FocusTrackingModes value
)
Public Shared Sub SetTrackingModes (
    obj As DataGrid,
    value As FocusTrackingModes
)

Parameters

obj
Type: System.Windows.ControlsDataGrid
The object to which the attached property is written.
value
Type: ActiproSoftware.Windows.Controls.DataGridFocusTrackingModes
A value indicating the focus that should be tracked in a DataGrid.
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior Fields

The FocusBehavior type exposes the following members.

Fields
Name | Description
IsFocusedHeaderProperty | Identifies the IsFocusedHeader attached dependency property. This field is read-only.
TrackingModesProperty | Identifies the TrackingModes attached dependency property. This field is read-only.
Top
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior.IsFocusedHeaderProperty Field

FocusBehaviorIsFocusedHeaderProperty Field

Identifies the IsFocusedHeader attached dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFocusedHeaderProperty
Public Shared ReadOnly IsFocusedHeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFocusedHeader attached dependency property.
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior.TrackingModesProperty Field

FocusBehaviorTrackingModesProperty Field

Identifies the TrackingModes attached dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TrackingModesProperty
Public Shared ReadOnly TrackingModesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TrackingModes attached dependency property.
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior Attached Properties

The FocusBehavior type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsFocusedHeader |
Public attached property | TrackingModes |
Top
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior.IsFocusedHeader Attached Property

FocusBehaviorIsFocusedHeader Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.DataGrid.FocusBehavior.IsFocusedHeader"]

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsFocusedHeader
See GetIsFocusedHeader

Property Value

Type: Boolean
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusBehavior.TrackingModes Attached Property

FocusBehaviorTrackingModes Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.DataGrid.FocusBehavior.TrackingModes"]

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetTrackingModes, SetTrackingModes
See GetTrackingModes, SetTrackingModes

Property Value

Type: FocusTrackingModes
See Also

Reference

FocusBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


FocusTrackingModes Enumeration

Specifies the various tracking modes available by the FocusBehavior.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum FocusTrackingModes
Public Enumeration FocusTrackingModes
Members
Member name | Value | Description
None | 0 | Indicates that the focus will not be tracked.
Headers | 1 | Indicates DataGridColumnHeader focus will be tracked.
All | 1 | Indicates that all available types will be tracked.
See Also

Reference

ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior Class

Provides attached behavior for DataGrid controls to customize the new row template.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.DataGridNewRowTemplateBehavior

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class NewRowTemplateBehavior
Public NotInheritable Class NewRowTemplateBehavior

The NewRowTemplateBehavior type exposes the following members.

Methods
Name | Description
GetDefaultTemplate | Gets the value of the DefaultTemplateProperty attached property for a specified DataGrid.
GetTemplate | Gets the value of the TemplateProperty attached property for a specified DataGrid.
SetTemplate | Sets the value of the TemplateProperty attached property to a specified DataGrid.
Top
Fields
Name | Description
DefaultTemplateProperty | Identifies the read-only DefaultTemplate dependency property. This field is read-only.
TemplateProperty | Identifies the Template attached dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | DefaultTemplate |
Public attached property | Template |
Top
See Also

Reference

ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior Methods

The NewRowTemplateBehavior type exposes the following members.

Methods
Name | Description
GetDefaultTemplate | Gets the value of the DefaultTemplateProperty attached property for a specified DataGrid.
GetTemplate | Gets the value of the TemplateProperty attached property for a specified DataGrid.
SetTemplate | Sets the value of the TemplateProperty attached property to a specified DataGrid.
Top
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior.GetDefaultTemplate Method

NewRowTemplateBehaviorGetDefaultTemplate Method

Gets the value of the DefaultTemplateProperty attached property for a specified DataGrid.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ControlTemplate GetDefaultTemplate(
    DataGrid obj
)
Public Shared Function GetDefaultTemplate (
    obj As DataGrid
) As ControlTemplate

Parameters

obj
Type: System.Windows.ControlsDataGrid
The object to which the attached property is retrieved.

Return Value

Type: ControlTemplate
The default ControlTemplate to use for rows in a DataGrid.
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior.GetTemplate Method

NewRowTemplateBehaviorGetTemplate Method

Gets the value of the TemplateProperty attached property for a specified DataGrid.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static ControlTemplate GetTemplate(
    DataGrid obj
)
Public Shared Function GetTemplate (
    obj As DataGrid
) As ControlTemplate

Parameters

obj
Type: System.Windows.ControlsDataGrid
The object to which the attached property is retrieved.

Return Value

Type: ControlTemplate
The ControlTemplate to use for the "new" row in a DataGrid.
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior.SetTemplate Method

NewRowTemplateBehaviorSetTemplate Method

Sets the value of the TemplateProperty attached property to a specified DataGrid.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetTemplate(
    DataGrid obj,
    ControlTemplate value
)
Public Shared Sub SetTemplate (
    obj As DataGrid,
    value As ControlTemplate
)

Parameters

obj
Type: System.Windows.ControlsDataGrid
The object to which the attached property is written.
value
Type: System.Windows.ControlsControlTemplate
A value indicating the ControlTemplate to use for the "new" row in a DataGrid.
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior Fields

The NewRowTemplateBehavior type exposes the following members.

Fields
Name | Description
DefaultTemplateProperty | Identifies the read-only DefaultTemplate dependency property. This field is read-only.
TemplateProperty | Identifies the Template attached dependency property. This field is read-only.
Top
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior.DefaultTemplateProperty Field

NewRowTemplateBehaviorDefaultTemplateProperty Field

Identifies the read-only DefaultTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultTemplateProperty
Public Shared ReadOnly DefaultTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultTemplate dependency property.
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior.TemplateProperty Field

NewRowTemplateBehaviorTemplateProperty Field

Identifies the Template attached dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TemplateProperty
Public Shared ReadOnly TemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Template attached dependency property.
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior Attached Properties

The NewRowTemplateBehavior type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | DefaultTemplate |
Public attached property | Template |
Top
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior.DefaultTemplate Attached Property

NewRowTemplateBehaviorDefaultTemplate Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.DataGrid.NewRowTemplateBehavior.DefaultTemplate"]

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetDefaultTemplate
See GetDefaultTemplate

Property Value

Type: ControlTemplate
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


NewRowTemplateBehavior.Template Attached Property

NewRowTemplateBehaviorTemplate Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.DataGrid.NewRowTemplateBehavior.Template"]

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetTemplate, SetTemplate
See GetTemplate, SetTemplate

Property Value

Type: ControlTemplate
See Also

Reference

NewRowTemplateBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior Class

Provides attached behavior for DataGrid controls to track the selection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.DataGridSelectionBehavior

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class SelectionBehavior
Public NotInheritable Class SelectionBehavior

The SelectionBehavior type exposes the following members.

Methods
Name | Description
GetIsSelectedHeader | Gets a value indicating whether a DataGridColumnHeader corresponds to the column of the a currently selected DataGridCell.
GetTrackingModes | Gets the value of the TrackingModesProperty attached property for a specified DataGrid.
SetTrackingModes | Sets the value of the TrackingModesProperty attached property to a specified DataGrid.
Top
Fields
Name | Description
IsSelectedHeaderProperty | Identifies the IsSelectedHeader attached dependency property. This field is read-only.
TrackingModesProperty | Identifies the TrackingModes attached dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | IsSelectedHeader |
Public attached property | TrackingModes |
Top
See Also

Reference

ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior Methods

The SelectionBehavior type exposes the following members.

Methods
Name | Description
GetIsSelectedHeader | Gets a value indicating whether a DataGridColumnHeader corresponds to the column of the a currently selected DataGridCell.
GetTrackingModes | Gets the value of the TrackingModesProperty attached property for a specified DataGrid.
SetTrackingModes | Sets the value of the TrackingModesProperty attached property to a specified DataGrid.
Top
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior.GetIsSelectedHeader Method

SelectionBehaviorGetIsSelectedHeader Method

Gets a value indicating whether a DataGridColumnHeader corresponds to the column of the a currently selected DataGridCell.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsSelectedHeader(
    DataGridColumnHeader obj
)
Public Shared Function GetIsSelectedHeader (
    obj As DataGridColumnHeader
) As Boolean

Parameters

obj
Type: System.Windows.Controls.PrimitivesDataGridColumnHeader
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior.GetTrackingModes Method

SelectionBehaviorGetTrackingModes Method

Gets the value of the TrackingModesProperty attached property for a specified DataGrid.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static SelectionTrackingModes GetTrackingModes(
    DataGrid obj
)
Public Shared Function GetTrackingModes (
    obj As DataGrid
) As SelectionTrackingModes

Parameters

obj
Type: System.Windows.ControlsDataGrid
The object to which the attached property is retrieved.

Return Value

Type: SelectionTrackingModes
The selections that should be tracked in a DataGrid.
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior.SetTrackingModes Method

SelectionBehaviorSetTrackingModes Method

Sets the value of the TrackingModesProperty attached property to a specified DataGrid.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetTrackingModes(
    DataGrid obj,
    SelectionTrackingModes value
)
Public Shared Sub SetTrackingModes (
    obj As DataGrid,
    value As SelectionTrackingModes
)

Parameters

obj
Type: System.Windows.ControlsDataGrid
The object to which the attached property is written.
value
Type: ActiproSoftware.Windows.Controls.DataGridSelectionTrackingModes
A value indicating the selections that should be tracked in a DataGrid.
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior Fields

The SelectionBehavior type exposes the following members.

Fields
Name | Description
IsSelectedHeaderProperty | Identifies the IsSelectedHeader attached dependency property. This field is read-only.
TrackingModesProperty | Identifies the TrackingModes attached dependency property. This field is read-only.
Top
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior.IsSelectedHeaderProperty Field

SelectionBehaviorIsSelectedHeaderProperty Field

Identifies the IsSelectedHeader attached dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedHeaderProperty
Public Shared ReadOnly IsSelectedHeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelectedHeader attached dependency property.
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior.TrackingModesProperty Field

SelectionBehaviorTrackingModesProperty Field

Identifies the TrackingModes attached dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TrackingModesProperty
Public Shared ReadOnly TrackingModesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TrackingModes attached dependency property.
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior Attached Properties

The SelectionBehavior type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsSelectedHeader |
Public attached property | TrackingModes |
Top
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior.IsSelectedHeader Attached Property

SelectionBehaviorIsSelectedHeader Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.DataGrid.SelectionBehavior.IsSelectedHeader"]

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsSelectedHeader
See GetIsSelectedHeader

Property Value

Type: Boolean
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionBehavior.TrackingModes Attached Property

SelectionBehaviorTrackingModes Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.DataGrid.SelectionBehavior.TrackingModes"]

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetTrackingModes, SetTrackingModes
See GetTrackingModes, SetTrackingModes

Property Value

Type: SelectionTrackingModes
See Also

Reference

SelectionBehavior Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


SelectionTrackingModes Enumeration

Specifies the various tracking modes available by the SelectionBehavior.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SelectionTrackingModes
Public Enumeration SelectionTrackingModes
Members
Member name | Value | Description
None | 0 | Indicates that the selection will not be tracked.
Headers | 1 | Indicates DataGridColumnHeader selection will be tracked.
All | 1 | Indicates that all available types will be tracked.
See Also

Reference

ActiproSoftware.Windows.Controls.DataGrid Namespace


ThemedDataGrid Class

Represents a DataGrid that uses custom themes and integrates into the Actipro theme manager.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.Controls.PrimitivesMultiSelector
System.Windows.ControlsDataGrid
ActiproSoftware.Windows.Controls.DataGridThemedDataGrid

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ThemedDataGrid : DataGrid
Public Class ThemedDataGrid
    Inherits DataGrid

The ThemedDataGrid type exposes the following members.

Constructors
 | Name | Description
Public method | ThemedDataGrid | Initializes a new instance of the ThemedDataGrid class
Top
Properties
 | Name | Description
Public property | AlternatingRowBackground | Gets or sets the background brush for use on alternating rows. (Inherited from DataGrid.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreRowDetailsFrozen | Gets or sets a value that indicates whether the row details can scroll horizontally. (Inherited from DataGrid.)
Public property | AutoGenerateColumns | Gets or sets a value that indicates whether the columns are created automatically. (Inherited from DataGrid.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Protected property | CanSelectMultipleItems | Gets or sets a value that indicates whether the multiple items in the MultiSelector can be selected at a time. (Inherited from MultiSelector.)
Public property | CanUserAddRows | Gets or sets a value that indicates whether the user can add new rows to the DataGrid. (Inherited from DataGrid.)
Public property | CanUserDeleteRows | Gets or sets a value that indicates whether the user can delete rows from the DataGrid. (Inherited from DataGrid.)
Public property | CanUserReorderColumns | Gets or sets a value that indicates whether the user can change the column display order by dragging column headers with the mouse. (Inherited from DataGrid.)
Public property | CanUserResizeColumns | Gets or sets a value that indicates whether the user can adjust the width of columns by using the mouse. (Inherited from DataGrid.)
Public property | CanUserResizeRows | Gets or sets a value that indicates whether the user can adjust the height of rows by using the mouse. (Inherited from DataGrid.)
Public property | CanUserSortColumns | Gets or sets a value that indicates whether the user can sort columns by clicking the column header. (Inherited from DataGrid.)
Public property | CellsPanelHorizontalOffset | Gets the horizontal offset for the DataGridCellsPanel. (Inherited from DataGrid.)
Public property | CellStyle | Gets or sets the style applied to all cells in the DataGrid. (Inherited from DataGrid.)
Public property | ClipboardCopyMode | Gets or sets a value that indicates how content is copied to the clipboard. (Inherited from DataGrid.)
Public property | ColumnHeaderHeight | Gets or sets the height of the column headers row. (Inherited from DataGrid.)
Public property | ColumnHeaderStyle | Gets or sets the style applied to all column headers in the DataGrid. (Inherited from DataGrid.)
Public property | Columns | Gets a collection that contains all the columns in the DataGrid. (Inherited from DataGrid.)
Public property | ColumnWidth | Gets or sets the standard width and sizing mode of columns and headers in the DataGrid. (Inherited from DataGrid.)
Public property | CurrentCell | Gets or sets the cell that has focus. (Inherited from DataGrid.)
Public property | CurrentColumn | Gets or sets the column that contains the current cell. (Inherited from DataGrid.)
Public property | CurrentItem | Gets the data item bound to the row that contains the current cell. (Inherited from DataGrid.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | DragIndicatorStyle | Gets or sets the style that is used when rendering the drag indicator that is displayed while dragging a column header. (Inherited from DataGrid.)
Public property | DropLocationIndicatorStyle | Gets or sets the style that is applied to indicate the drop location when dragging a column header. (Inherited from DataGrid.)
Public property | EnableColumnVirtualization | Gets or sets a value that indicates whether column virtualization is enabled. (Inherited from DataGrid.)
Public property | EnableRowVirtualization | Gets or sets a value that indicates whether row virtualization is enabled. (Inherited from DataGrid.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns. (Inherited from DataGrid.)
Public property | GridLinesVisibility | Gets or sets a value that indicates which grid lines are shown. (Inherited from DataGrid.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the DataGrid supports custom keyboard scrolling. (Inherited from DataGrid.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HeadersVisibility | Gets or sets the value that specifies the visibility of the row and column headers. (Inherited from DataGrid.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalGridLinesBrush | Gets or sets the brush that is used to draw the horizontal grid lines. (Inherited from DataGrid.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates how horizontal scroll bars are displayed in the DataGrid. (Inherited from DataGrid.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the user can edit values in the DataGrid. (Inherited from DataGrid.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Protected property | IsUpdatingSelectedItems | Gets a value that indicates whether the MultiSelector is currently performing a bulk update to the SelectedItems collection. (Inherited from MultiSelector.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxColumnWidth | Gets or sets the maximum width constraint of the columns and headers in the DataGrid. (Inherited from DataGrid.)
Public property | MinColumnWidth | Gets or sets the minimum width constraint of the columns and headers in the DataGrid. (Inherited from DataGrid.)
Public property | MinRowHeight | Gets or sets the minimum height constraint of the rows and headers in the DataGrid. (Inherited from DataGrid.)
Public property | NonFrozenColumnsViewportHorizontalOffset | Gets the horizontal offset of the scrollable columns in the view port. (Inherited from DataGrid.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RowBackground | Gets or sets the default brush for the row background. (Inherited from DataGrid.)
Public property | RowDetailsTemplate | Gets or sets the template that is used to display the row details. (Inherited from DataGrid.)
Public property | RowDetailsTemplateSelector | Gets or sets the template selector that is used for the row details. (Inherited from DataGrid.)
Public property | RowDetailsVisibilityMode | Gets or sets a value that indicates when the details section of a row is displayed. (Inherited from DataGrid.)
Public property | RowHeaderActualWidth | Gets the rendered width of the row headers column. (Inherited from DataGrid.)
Public property | RowHeaderStyle | Gets or sets the style applied to all row headers. (Inherited from DataGrid.)
Public property | RowHeaderTemplate | Gets or set the template for the row headers. (Inherited from DataGrid.)
Public property | RowHeaderTemplateSelector | Gets or sets the template selector for row headers. (Inherited from DataGrid.)
Public property | RowHeaderWidth | Gets or sets the width of the row header column. (Inherited from DataGrid.)
Public property | RowHeight | Gets or sets the suggested height for all rows. (Inherited from DataGrid.)
Public property | RowStyle | Gets or sets the style applied to all rows. (Inherited from DataGrid.)
Public property | RowStyleSelector | Gets or sets the style selector for the rows. (Inherited from DataGrid.)
Public property | RowValidationErrorTemplate | Gets or sets the template that is used to visually indicate an error in row validation. (Inherited from DataGrid.)
Public property | RowValidationRules | Gets the rules that are used to validate the data in each row. (Inherited from DataGrid.)
Public property | SelectedCells | Gets the list of cells that are currently selected. (Inherited from DataGrid.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the items in the MultiSelector that are selected. (Inherited from MultiSelector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets a value that indicates how rows and cells are selected in the DataGrid. (Inherited from DataGrid.)
Public property | SelectionUnit | Gets or sets a value that indicates whether rows, cells, or both can be selected in the DataGrid. (Inherited from DataGrid.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalGridLinesBrush | Gets or sets the brush that is used to draw the vertical grid lines. (Inherited from DataGrid.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates how vertical scroll bars are displayed in the DataGrid. (Inherited from DataGrid.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ApplyThemedStyle(DataGridCheckBoxColumn) | Applies a themed style to the element in the specified column, if the current style is defaulted.
Protected method | ApplyThemedStyle(DataGridComboBoxColumn) | Applies a themed style to the element in the specified column, if the current style is defaulted.
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginEdit | Invokes the BeginEdit command, which will place the current cell or row into edit mode. (Inherited from DataGrid.)
Public method | BeginEdit(RoutedEventArgs) | Invokes the BeginEdit command, which will place the current cell or row into edit mode. (Inherited from DataGrid.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Protected method | BeginUpdateSelectedItems | Starts a new selection transaction. (Inherited from MultiSelector.)
Public method | CancelEdit | Invokes the CancelEditCommand command for the cell or row currently in edit mode. (Inherited from DataGrid.)
Public method | CancelEdit(DataGridEditingUnit) | Invokes the CancelEditCommand command for the specified cell or row in edit mode. (Inherited from DataGrid.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Unloads the row for the specified item. (Inherited from DataGrid.)
Public method | ClearDetailsVisibilityForItem | Clears the DetailsVisibility property for the DataGridRow that represents the specified data item. (Inherited from DataGrid.)
Public method | ColumnFromDisplayIndex | Gets the DataGridColumn at the specified index. (Inherited from DataGrid.)
Public method | CommitEdit | Invokes the CommitEditCommand command for the cell or row currently in edit mode. (Inherited from DataGrid.)
Public method | CommitEdit(DataGridEditingUnit, Boolean) | Invokes the CommitEditCommand command for the specified cell or row currently in edit mode. (Inherited from DataGrid.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Protected method | EndUpdateSelectedItems | Commits the selected items to the MultiSelector. (Inherited from MultiSelector.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Instantiates a new DataGridRow. (Inherited from DataGrid.)
Public method | GetDetailsVisibilityForItem | Gets the DetailsVisibility property for the DataGridRow that represents the specified data item. (Inherited from DataGrid.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if an item is a DataGridRow. (Inherited from DataGrid.)
Protected method | MeasureOverride | Determines the desired size of the DataGrid. (Inherited from DataGrid.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Inherited from DataGrid.)
Protected method | OnAutoGeneratedColumns | Raises the AutoGeneratedColumns event. (Inherited from DataGrid.)
Protected method | OnAutoGeneratingColumn | Occurs when auto-generating a column. (Overrides DataGridOnAutoGeneratingColumn(DataGridAutoGeneratingColumnEventArgs).)
Protected method | OnBeginningEdit | Raises the BeginningEdit event. (Inherited from DataGrid.)
Protected method | OnCanExecuteBeginEdit | Provides handling for the CanExecute event associated with the BeginEditCommand command. (Inherited from DataGrid.)
Protected method | OnCanExecuteCancelEdit | Provides handling for the CanExecute event associated with the CancelEditCommand command. (Inherited from DataGrid.)
Protected method | OnCanExecuteCommitEdit | Provides handling for the CanExecute event associated with the CommitEditCommand command. (Inherited from DataGrid.)
Protected method | OnCanExecuteCopy | Provides handling for the CanExecute event associated with the Copy command. (Inherited from DataGrid.)
Protected method | OnCanExecuteDelete | Provides handling for the CanExecute event associated with the DeleteCommand command. (Inherited from DataGrid.)
Protected method | OnCellEditEnding | Raises the CellEditEnding event. (Inherited from DataGrid.)
Protected method | OnColumnDisplayIndexChanged | Raises the ColumnDisplayIndexChanged event. (Inherited from DataGrid.)
Protected method | OnColumnHeaderDragCompleted | Raises the ColumnHeaderDragCompleted event. (Inherited from DataGrid.)
Protected method | OnColumnHeaderDragDelta | Raises the ColumnHeaderDragDelta event. (Inherited from DataGrid.)
Protected method | OnColumnHeaderDragStarted | Raises the ColumnHeaderDragStarted event. (Inherited from DataGrid.)
Protected method | OnColumnReordered | Raises the ColumnReordered event. (Inherited from DataGrid.)
Protected method | OnColumnReordering | Raises the ColumnReordering event. (Inherited from DataGrid.)
Protected method | OnContextMenuOpening | Selects a cell if its context menu is opened. (Inherited from DataGrid.)
Protected method | OnCopyingRowClipboardContent | Raises the CopyingRowClipboardContent event. (Inherited from DataGrid.)
Protected method | OnCreateAutomationPeer | Returns the automation peer for this DataGrid. (Inherited from DataGrid.)
Protected method | OnCurrentCellChanged | Raises the CurrentCellChanged event. (Inherited from DataGrid.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnExecutedBeginEdit | Provides handling for the Executed event associated with the BeginEditCommand command. (Inherited from DataGrid.)
Protected method | OnExecutedCancelEdit | Provides handling for the Executed event associated with the CancelEditCommand command. (Inherited from DataGrid.)
Protected method | OnExecutedCommitEdit | Provides handling for the Executed event associated with the CommitEditCommand command. (Inherited from DataGrid.)
Protected method | OnExecutedCopy | Provides handling for the Executed event associated with the Copy command. (Inherited from DataGrid.)
Protected method | OnExecutedDelete | Provides handling for the Executed event associated with the DeleteCommand command. (Inherited from DataGrid.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnInitializingNewItem | Raises the InitializingNewItem event. (Inherited from DataGrid.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes on this element. (Inherited from DataGrid.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Performs column auto generation and updates validation flags when items change. (Inherited from DataGrid.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Invoked when the ItemsSource property changes. (Inherited from DataGrid.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Inherited from DataGrid.)
Protected method | OnLoadingRow | Raises the LoadingRow event. (Inherited from DataGrid.)
Protected method | OnLoadingRowDetails | Raises the LoadingRowDetails event. (Inherited from DataGrid.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Updates the collection of items that are selected due to the user dragging the mouse in the DataGrid. (Inherited from DataGrid.)
Protected method | OnPreparingCellForEdit | Raises the PreparingCellForEdit event. (Inherited from DataGrid.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRowDetailsVisibilityChanged | Raises the RowDetailsVisibilityChanged event. (Inherited from DataGrid.)
Protected method | OnRowEditEnding | Raises the RowEditEnding event. (Inherited from DataGrid.)
Protected method | OnSelectedCellsChanged | Raises the SelectedCellsChanged event. (Inherited from DataGrid.)
Protected method | OnSelectionChanged | Invoked when the selection changes. (Inherited from DataGrid.)
Protected method | OnSorting | Raises the Sorting event. (Inherited from DataGrid.)
Protected method | OnTemplateChanged | Called whenever the template of the DataGrid changes. (Inherited from DataGrid.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnUnloadingRow | Raises the UnloadingRow event. (Inherited from DataGrid.)
Protected method | OnUnloadingRowDetails | Raises the UnloadingRowDetails event. (Inherited from DataGrid.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares a new row for the specified item. (Inherited from DataGrid.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView(Object) | Scrolls the DataGrid vertically to display the row for the specified data item. (Inherited from DataGrid.)
Public method | ScrollIntoView(Object, DataGridColumn) | Scrolls the DataGrid vertically and horizontally to display a cell for the specified data item and column. (Inherited from DataGrid.)
Public method | SelectAll | Selects all of the items in the MultiSelector. (Inherited from MultiSelector.)
Public method | SelectAllCells | Selects all the cells in the DataGrid. (Inherited from DataGrid.)
Public method | SetDetailsVisibilityForItem | Sets the value of the DetailsVisibility property for the DataGridRow that contains the specified object. (Inherited from DataGrid.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Unselects all of the items in the MultiSelector. (Inherited from MultiSelector.)
Public method | UnselectAllCells | Unselects all the cells in the DataGrid. (Inherited from DataGrid.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | AutoGeneratedColumns | Occurs when auto generation of all columns is completed. (Inherited from DataGrid.)
Public event | AutoGeneratingColumn | Occurs when an individual column is auto-generated. (Inherited from DataGrid.)
Public event | BeginningEdit | Occurs before a row or cell enters edit mode. (Inherited from DataGrid.)
Public event | CellEditEnding | Occurs before a cell edit is committed or canceled. (Inherited from DataGrid.)
Public event | ColumnDisplayIndexChanged | Occurs when the DisplayIndex property on one of the columns changes. (Inherited from DataGrid.)
Public event | ColumnHeaderDragCompleted | Occurs when the user releases a column header after dragging it by using the mouse. (Inherited from DataGrid.)
Public event | ColumnHeaderDragDelta | Occurs every time the mouse position changes while the user drags a column header. (Inherited from DataGrid.)
Public event | ColumnHeaderDragStarted | Occurs when the user begins dragging a column header by using the mouse. (Inherited from DataGrid.)
Public event | ColumnReordered | Occurs when a column moves to a new position in the display order. (Inherited from DataGrid.)
Public event | ColumnReordering | Occurs before a column moves to a new position in the display order. (Inherited from DataGrid.)
Public event | CopyingRowClipboardContent | Occurs after the default row content is prepared. (Inherited from DataGrid.)
Public event | CurrentCellChanged | Occurs when the value of the CurrentCell property has changed. (Inherited from DataGrid.)
Public event | InitializingNewItem | Occurs when a new item is created. (Inherited from DataGrid.)
Public event | LoadingRow | Occurs after a DataGridRow is instantiated, so that you can customize it before it is used. (Inherited from DataGrid.)
Public event | LoadingRowDetails | Occurs when a new row details template is applied to a row. (Inherited from DataGrid.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreparingCellForEdit | Occurs when a cell enters edit mode. (Inherited from DataGrid.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | RowDetailsVisibilityChanged | Occurs when the visibility of a row details element changes. (Inherited from DataGrid.)
Public event | RowEditEnding | Occurs before a row edit is committed or canceled. (Inherited from DataGrid.)
Public event | SelectedCellsChanged | Occurs when the SelectedCells collection changes. (Inherited from DataGrid.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | Sorting | Occurs when a column is being sorted. (Inherited from DataGrid.)
Public event | UnloadingRow | Occurs when a DataGridRow object becomes available for reuse. (Inherited from DataGrid.)
Public event | UnloadingRowDetails | Occurs when a row details element becomes available for reuse. (Inherited from DataGrid.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetRow(Int32) | Overloaded. Gets the DataGridRow at the specified index. (Defined by DataGridExtensions.)
Public Extension Method | GetRow(Object) | Overloaded. Gets the DataGridRow for the specified item. (Defined by DataGridExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.DataGrid Namespace


ThemedDataGrid Constructor

Initializes a new instance of the ThemedDataGrid class

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ThemedDataGrid()
Public Sub New
See Also

Reference

ThemedDataGrid Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


ThemedDataGrid Properties

The ThemedDataGrid type exposes the following members.

Properties
 | Name | Description
Public property | AlternatingRowBackground | Gets or sets the background brush for use on alternating rows. (Inherited from DataGrid.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreRowDetailsFrozen | Gets or sets a value that indicates whether the row details can scroll horizontally. (Inherited from DataGrid.)
Public property | AutoGenerateColumns | Gets or sets a value that indicates whether the columns are created automatically. (Inherited from DataGrid.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Protected property | CanSelectMultipleItems | Gets or sets a value that indicates whether the multiple items in the MultiSelector can be selected at a time. (Inherited from MultiSelector.)
Public property | CanUserAddRows | Gets or sets a value that indicates whether the user can add new rows to the DataGrid. (Inherited from DataGrid.)
Public property | CanUserDeleteRows | Gets or sets a value that indicates whether the user can delete rows from the DataGrid. (Inherited from DataGrid.)
Public property | CanUserReorderColumns | Gets or sets a value that indicates whether the user can change the column display order by dragging column headers with the mouse. (Inherited from DataGrid.)
Public property | CanUserResizeColumns | Gets or sets a value that indicates whether the user can adjust the width of columns by using the mouse. (Inherited from DataGrid.)
Public property | CanUserResizeRows | Gets or sets a value that indicates whether the user can adjust the height of rows by using the mouse. (Inherited from DataGrid.)
Public property | CanUserSortColumns | Gets or sets a value that indicates whether the user can sort columns by clicking the column header. (Inherited from DataGrid.)
Public property | CellsPanelHorizontalOffset | Gets the horizontal offset for the DataGridCellsPanel. (Inherited from DataGrid.)
Public property | CellStyle | Gets or sets the style applied to all cells in the DataGrid. (Inherited from DataGrid.)
Public property | ClipboardCopyMode | Gets or sets a value that indicates how content is copied to the clipboard. (Inherited from DataGrid.)
Public property | ColumnHeaderHeight | Gets or sets the height of the column headers row. (Inherited from DataGrid.)
Public property | ColumnHeaderStyle | Gets or sets the style applied to all column headers in the DataGrid. (Inherited from DataGrid.)
Public property | Columns | Gets a collection that contains all the columns in the DataGrid. (Inherited from DataGrid.)
Public property | ColumnWidth | Gets or sets the standard width and sizing mode of columns and headers in the DataGrid. (Inherited from DataGrid.)
Public property | CurrentCell | Gets or sets the cell that has focus. (Inherited from DataGrid.)
Public property | CurrentColumn | Gets or sets the column that contains the current cell. (Inherited from DataGrid.)
Public property | CurrentItem | Gets the data item bound to the row that contains the current cell. (Inherited from DataGrid.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | DragIndicatorStyle | Gets or sets the style that is used when rendering the drag indicator that is displayed while dragging a column header. (Inherited from DataGrid.)
Public property | DropLocationIndicatorStyle | Gets or sets the style that is applied to indicate the drop location when dragging a column header. (Inherited from DataGrid.)
Public property | EnableColumnVirtualization | Gets or sets a value that indicates whether column virtualization is enabled. (Inherited from DataGrid.)
Public property | EnableRowVirtualization | Gets or sets a value that indicates whether row virtualization is enabled. (Inherited from DataGrid.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns. (Inherited from DataGrid.)
Public property | GridLinesVisibility | Gets or sets a value that indicates which grid lines are shown. (Inherited from DataGrid.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the DataGrid supports custom keyboard scrolling. (Inherited from DataGrid.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HeadersVisibility | Gets or sets the value that specifies the visibility of the row and column headers. (Inherited from DataGrid.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalGridLinesBrush | Gets or sets the brush that is used to draw the horizontal grid lines. (Inherited from DataGrid.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates how horizontal scroll bars are displayed in the DataGrid. (Inherited from DataGrid.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the user can edit values in the DataGrid. (Inherited from DataGrid.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Protected property | IsUpdatingSelectedItems | Gets a value that indicates whether the MultiSelector is currently performing a bulk update to the SelectedItems collection. (Inherited from MultiSelector.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxColumnWidth | Gets or sets the maximum width constraint of the columns and headers in the DataGrid. (Inherited from DataGrid.)
Public property | MinColumnWidth | Gets or sets the minimum width constraint of the columns and headers in the DataGrid. (Inherited from DataGrid.)
Public property | MinRowHeight | Gets or sets the minimum height constraint of the rows and headers in the DataGrid. (Inherited from DataGrid.)
Public property | NonFrozenColumnsViewportHorizontalOffset | Gets the horizontal offset of the scrollable columns in the view port. (Inherited from DataGrid.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RowBackground | Gets or sets the default brush for the row background. (Inherited from DataGrid.)
Public property | RowDetailsTemplate | Gets or sets the template that is used to display the row details. (Inherited from DataGrid.)
Public property | RowDetailsTemplateSelector | Gets or sets the template selector that is used for the row details. (Inherited from DataGrid.)
Public property | RowDetailsVisibilityMode | Gets or sets a value that indicates when the details section of a row is displayed. (Inherited from DataGrid.)
Public property | RowHeaderActualWidth | Gets the rendered width of the row headers column. (Inherited from DataGrid.)
Public property | RowHeaderStyle | Gets or sets the style applied to all row headers. (Inherited from DataGrid.)
Public property | RowHeaderTemplate | Gets or set the template for the row headers. (Inherited from DataGrid.)
Public property | RowHeaderTemplateSelector | Gets or sets the template selector for row headers. (Inherited from DataGrid.)
Public property | RowHeaderWidth | Gets or sets the width of the row header column. (Inherited from DataGrid.)
Public property | RowHeight | Gets or sets the suggested height for all rows. (Inherited from DataGrid.)
Public property | RowStyle | Gets or sets the style applied to all rows. (Inherited from DataGrid.)
Public property | RowStyleSelector | Gets or sets the style selector for the rows. (Inherited from DataGrid.)
Public property | RowValidationErrorTemplate | Gets or sets the template that is used to visually indicate an error in row validation. (Inherited from DataGrid.)
Public property | RowValidationRules | Gets the rules that are used to validate the data in each row. (Inherited from DataGrid.)
Public property | SelectedCells | Gets the list of cells that are currently selected. (Inherited from DataGrid.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the items in the MultiSelector that are selected. (Inherited from MultiSelector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets a value that indicates how rows and cells are selected in the DataGrid. (Inherited from DataGrid.)
Public property | SelectionUnit | Gets or sets a value that indicates whether rows, cells, or both can be selected in the DataGrid. (Inherited from DataGrid.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalGridLinesBrush | Gets or sets the brush that is used to draw the vertical grid lines. (Inherited from DataGrid.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates how vertical scroll bars are displayed in the DataGrid. (Inherited from DataGrid.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ThemedDataGrid Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


ThemedDataGrid Methods

The ThemedDataGrid type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ApplyThemedStyle(DataGridCheckBoxColumn) | Applies a themed style to the element in the specified column, if the current style is defaulted.
Protected method | ApplyThemedStyle(DataGridComboBoxColumn) | Applies a themed style to the element in the specified column, if the current style is defaulted.
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginEdit | Invokes the BeginEdit command, which will place the current cell or row into edit mode. (Inherited from DataGrid.)
Public method | BeginEdit(RoutedEventArgs) | Invokes the BeginEdit command, which will place the current cell or row into edit mode. (Inherited from DataGrid.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Protected method | BeginUpdateSelectedItems | Starts a new selection transaction. (Inherited from MultiSelector.)
Public method | CancelEdit | Invokes the CancelEditCommand command for the cell or row currently in edit mode. (Inherited from DataGrid.)
Public method | CancelEdit(DataGridEditingUnit) | Invokes the CancelEditCommand command for the specified cell or row in edit mode. (Inherited from DataGrid.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Unloads the row for the specified item. (Inherited from DataGrid.)
Public method | ClearDetailsVisibilityForItem | Clears the DetailsVisibility property for the DataGridRow that represents the specified data item. (Inherited from DataGrid.)
Public method | ColumnFromDisplayIndex | Gets the DataGridColumn at the specified index. (Inherited from DataGrid.)
Public method | CommitEdit | Invokes the CommitEditCommand command for the cell or row currently in edit mode. (Inherited from DataGrid.)
Public method | CommitEdit(DataGridEditingUnit, Boolean) | Invokes the CommitEditCommand command for the specified cell or row currently in edit mode. (Inherited from DataGrid.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Protected method | EndUpdateSelectedItems | Commits the selected items to the MultiSelector. (Inherited from MultiSelector.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Instantiates a new DataGridRow. (Inherited from DataGrid.)
Public method | GetDetailsVisibilityForItem | Gets the DetailsVisibility property for the DataGridRow that represents the specified data item. (Inherited from DataGrid.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if an item is a DataGridRow. (Inherited from DataGrid.)
Protected method | MeasureOverride | Determines the desired size of the DataGrid. (Inherited from DataGrid.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Inherited from DataGrid.)
Protected method | OnAutoGeneratedColumns | Raises the AutoGeneratedColumns event. (Inherited from DataGrid.)
Protected method | OnAutoGeneratingColumn | Occurs when auto-generating a column. (Overrides DataGridOnAutoGeneratingColumn(DataGridAutoGeneratingColumnEventArgs).)
Protected method | OnBeginningEdit | Raises the BeginningEdit event. (Inherited from DataGrid.)
Protected method | OnCanExecuteBeginEdit | Provides handling for the CanExecute event associated with the BeginEditCommand command. (Inherited from DataGrid.)
Protected method | OnCanExecuteCancelEdit | Provides handling for the CanExecute event associated with the CancelEditCommand command. (Inherited from DataGrid.)
Protected method | OnCanExecuteCommitEdit | Provides handling for the CanExecute event associated with the CommitEditCommand command. (Inherited from DataGrid.)
Protected method | OnCanExecuteCopy | Provides handling for the CanExecute event associated with the Copy command. (Inherited from DataGrid.)
Protected method | OnCanExecuteDelete | Provides handling for the CanExecute event associated with the DeleteCommand command. (Inherited from DataGrid.)
Protected method | OnCellEditEnding | Raises the CellEditEnding event. (Inherited from DataGrid.)
Protected method | OnColumnDisplayIndexChanged | Raises the ColumnDisplayIndexChanged event. (Inherited from DataGrid.)
Protected method | OnColumnHeaderDragCompleted | Raises the ColumnHeaderDragCompleted event. (Inherited from DataGrid.)
Protected method | OnColumnHeaderDragDelta | Raises the ColumnHeaderDragDelta event. (Inherited from DataGrid.)
Protected method | OnColumnHeaderDragStarted | Raises the ColumnHeaderDragStarted event. (Inherited from DataGrid.)
Protected method | OnColumnReordered | Raises the ColumnReordered event. (Inherited from DataGrid.)
Protected method | OnColumnReordering | Raises the ColumnReordering event. (Inherited from DataGrid.)
Protected method | OnContextMenuOpening | Selects a cell if its context menu is opened. (Inherited from DataGrid.)
Protected method | OnCopyingRowClipboardContent | Raises the CopyingRowClipboardContent event. (Inherited from DataGrid.)
Protected method | OnCreateAutomationPeer | Returns the automation peer for this DataGrid. (Inherited from DataGrid.)
Protected method | OnCurrentCellChanged | Raises the CurrentCellChanged event. (Inherited from DataGrid.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnExecutedBeginEdit | Provides handling for the Executed event associated with the BeginEditCommand command. (Inherited from DataGrid.)
Protected method | OnExecutedCancelEdit | Provides handling for the Executed event associated with the CancelEditCommand command. (Inherited from DataGrid.)
Protected method | OnExecutedCommitEdit | Provides handling for the Executed event associated with the CommitEditCommand command. (Inherited from DataGrid.)
Protected method | OnExecutedCopy | Provides handling for the Executed event associated with the Copy command. (Inherited from DataGrid.)
Protected method | OnExecutedDelete | Provides handling for the Executed event associated with the DeleteCommand command. (Inherited from DataGrid.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnInitializingNewItem | Raises the InitializingNewItem event. (Inherited from DataGrid.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes on this element. (Inherited from DataGrid.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Performs column auto generation and updates validation flags when items change. (Inherited from DataGrid.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Invoked when the ItemsSource property changes. (Inherited from DataGrid.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Inherited from DataGrid.)
Protected method | OnLoadingRow | Raises the LoadingRow event. (Inherited from DataGrid.)
Protected method | OnLoadingRowDetails | Raises the LoadingRowDetails event. (Inherited from DataGrid.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Updates the collection of items that are selected due to the user dragging the mouse in the DataGrid. (Inherited from DataGrid.)
Protected method | OnPreparingCellForEdit | Raises the PreparingCellForEdit event. (Inherited from DataGrid.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRowDetailsVisibilityChanged | Raises the RowDetailsVisibilityChanged event. (Inherited from DataGrid.)
Protected method | OnRowEditEnding | Raises the RowEditEnding event. (Inherited from DataGrid.)
Protected method | OnSelectedCellsChanged | Raises the SelectedCellsChanged event. (Inherited from DataGrid.)
Protected method | OnSelectionChanged | Invoked when the selection changes. (Inherited from DataGrid.)
Protected method | OnSorting | Raises the Sorting event. (Inherited from DataGrid.)
Protected method | OnTemplateChanged | Called whenever the template of the DataGrid changes. (Inherited from DataGrid.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnUnloadingRow | Raises the UnloadingRow event. (Inherited from DataGrid.)
Protected method | OnUnloadingRowDetails | Raises the UnloadingRowDetails event. (Inherited from DataGrid.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares a new row for the specified item. (Inherited from DataGrid.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView(Object) | Scrolls the DataGrid vertically to display the row for the specified data item. (Inherited from DataGrid.)
Public method | ScrollIntoView(Object, DataGridColumn) | Scrolls the DataGrid vertically and horizontally to display a cell for the specified data item and column. (Inherited from DataGrid.)
Public method | SelectAll | Selects all of the items in the MultiSelector. (Inherited from MultiSelector.)
Public method | SelectAllCells | Selects all the cells in the DataGrid. (Inherited from DataGrid.)
Public method | SetDetailsVisibilityForItem | Sets the value of the DetailsVisibility property for the DataGridRow that contains the specified object. (Inherited from DataGrid.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Unselects all of the items in the MultiSelector. (Inherited from MultiSelector.)
Public method | UnselectAllCells | Unselects all the cells in the DataGrid. (Inherited from DataGrid.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetRow(Int32) | Overloaded. Gets the DataGridRow at the specified index. (Defined by DataGridExtensions.)
Public Extension Method | GetRow(Object) | Overloaded. Gets the DataGridRow for the specified item. (Defined by DataGridExtensions.)
Top
See Also

Reference

ThemedDataGrid Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


ThemedDataGrid.ApplyThemedStyle Method

ThemedDataGridApplyThemedStyle Method

Overload List
 | Name | Description
Protected method | ApplyThemedStyle(DataGridCheckBoxColumn) | Applies a themed style to the element in the specified column, if the current style is defaulted.
Protected method | ApplyThemedStyle(DataGridComboBoxColumn) | Applies a themed style to the element in the specified column, if the current style is defaulted.
Top
See Also

Reference

ThemedDataGrid Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


ThemedDataGrid.ApplyThemedStyle Method (DataGridCheckBoxColumn)

ThemedDataGridApplyThemedStyle Method (DataGridCheckBoxColumn)

Applies a themed style to the element in the specified column, if the current style is defaulted.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void ApplyThemedStyle(
    DataGridCheckBoxColumn column
)
Protected Overridable Sub ApplyThemedStyle (
    column As DataGridCheckBoxColumn
)

Parameters

column
Type: System.Windows.ControlsDataGridCheckBoxColumn
The column to examine.
See Also

Reference

ThemedDataGrid Class
ApplyThemedStyle Overload
ActiproSoftware.Windows.Controls.DataGrid Namespace


ThemedDataGrid.ApplyThemedStyle Method (DataGridComboBoxColumn)

ThemedDataGridApplyThemedStyle Method (DataGridComboBoxColumn)

Applies a themed style to the element in the specified column, if the current style is defaulted.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void ApplyThemedStyle(
    DataGridComboBoxColumn column
)
Protected Overridable Sub ApplyThemedStyle (
    column As DataGridComboBoxColumn
)

Parameters

column
Type: System.Windows.ControlsDataGridComboBoxColumn
The column to examine.
See Also

Reference

ThemedDataGrid Class
ApplyThemedStyle Overload
ActiproSoftware.Windows.Controls.DataGrid Namespace


ThemedDataGrid.OnAutoGeneratingColumn Method

ThemedDataGridOnAutoGeneratingColumn Method

Occurs when auto-generating a column.

Namespace: ActiproSoftware.Windows.Controls.DataGrid
Assembly: ActiproSoftware.DataGrid.Contrib.Wpf (in ActiproSoftware.DataGrid.Contrib.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnAutoGeneratingColumn(
    DataGridAutoGeneratingColumnEventArgs e
)
Protected Overrides Sub OnAutoGeneratingColumn (
    e As DataGridAutoGeneratingColumnEventArgs
)

Parameters

e
Type: System.Windows.ControlsDataGridAutoGeneratingColumnEventArgs
The DataGridAutoGeneratingColumnEventArgs that contains data related to this event.
See Also

Reference

ThemedDataGrid Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


ThemedDataGrid Events

The ThemedDataGrid type exposes the following members.

Events
 | Name | Description
Public event | AutoGeneratedColumns | Occurs when auto generation of all columns is completed. (Inherited from DataGrid.)
Public event | AutoGeneratingColumn | Occurs when an individual column is auto-generated. (Inherited from DataGrid.)
Public event | BeginningEdit | Occurs before a row or cell enters edit mode. (Inherited from DataGrid.)
Public event | CellEditEnding | Occurs before a cell edit is committed or canceled. (Inherited from DataGrid.)
Public event | ColumnDisplayIndexChanged | Occurs when the DisplayIndex property on one of the columns changes. (Inherited from DataGrid.)
Public event | ColumnHeaderDragCompleted | Occurs when the user releases a column header after dragging it by using the mouse. (Inherited from DataGrid.)
Public event | ColumnHeaderDragDelta | Occurs every time the mouse position changes while the user drags a column header. (Inherited from DataGrid.)
Public event | ColumnHeaderDragStarted | Occurs when the user begins dragging a column header by using the mouse. (Inherited from DataGrid.)
Public event | ColumnReordered | Occurs when a column moves to a new position in the display order. (Inherited from DataGrid.)
Public event | ColumnReordering | Occurs before a column moves to a new position in the display order. (Inherited from DataGrid.)
Public event | CopyingRowClipboardContent | Occurs after the default row content is prepared. (Inherited from DataGrid.)
Public event | CurrentCellChanged | Occurs when the value of the CurrentCell property has changed. (Inherited from DataGrid.)
Public event | InitializingNewItem | Occurs when a new item is created. (Inherited from DataGrid.)
Public event | LoadingRow | Occurs after a DataGridRow is instantiated, so that you can customize it before it is used. (Inherited from DataGrid.)
Public event | LoadingRowDetails | Occurs when a new row details template is applied to a row. (Inherited from DataGrid.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreparingCellForEdit | Occurs when a cell enters edit mode. (Inherited from DataGrid.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | RowDetailsVisibilityChanged | Occurs when the visibility of a row details element changes. (Inherited from DataGrid.)
Public event | RowEditEnding | Occurs before a row edit is committed or canceled. (Inherited from DataGrid.)
Public event | SelectedCellsChanged | Occurs when the SelectedCells collection changes. (Inherited from DataGrid.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | Sorting | Occurs when a column is being sorted. (Inherited from DataGrid.)
Public event | UnloadingRow | Occurs when a DataGridRow object becomes available for reuse. (Inherited from DataGrid.)
Public event | UnloadingRowDetails | Occurs when a row details element becomes available for reuse. (Inherited from DataGrid.)
Top
See Also

Reference

ThemedDataGrid Class
ActiproSoftware.Windows.Controls.DataGrid Namespace


ActiproSoftware.Windows.Controls.Docking Namespace

Contains classes that support implementing docking windows & MDI for WPF.
Classes
 | Class | Description
Public class | AdvancedTabControl | Represents a tab control with advanced features.
Public class | AdvancedTabControlMenuEventArgs | Provides event arguments for customizing a menu that is opening within an AdvancedTabControl.
Public class | AdvancedTabItem | Represents a tab item for use in an AdvancedTabControl.
Public class | AdvancedTabItemEventArgs | Provides event arguments for AdvancedTabItem-related drag events.
Public class | DockHost | Represents a root host that can contain a docking window hierarchy.
Public class | DockingMenuEventArgs | Provides event arguments for customizing a docking-related context or drop-down menu.
Public class | DockingWindow | Represents the base class for a docking window implementation.
Public class | DockingWindowCollection | Represents an observable collection of DockingWindow objects.
Public class | DockingWindowCollectionBaseT | Represents the base class for an observable collection of DockingWindow objects.
Public class | DockingWindowDefaultLocationEventArgs | Provides event arguments for DockingWindow-related default location events.
Public class | DockingWindowEventArgs | Provides event arguments for DockingWindow-related events.
Public class | DockingWindowsAutoHidingEventArgs | Provides event arguments for DockingWindow auto-hiding events.
Public class | DockingWindowsDragOverEventArgs | Provides event arguments for when one or more docking windows are dragged over a new dock target, with support for hiding certain dock guides by altering the AllowedDockGuideKinds property.
Public class | DockingWindowsEventArgs | Provides event arguments for DockingWindow-related events that deal with potentially muliple windows.
Public class | DockSite | Represents a dock site, the root control for docking window host functionality.
Public class | DocumentWindow | Represents a document window.
Public class | DocumentWindowCollection | Represents an observable collection of DocumentWindow objects.
Public class | FloatingWindowOpeningEventArgs | Provides event arguments for floating window opening events.
Public class | InteropFocusTracking | Provides an attached behavior for ensuring that a HwndHost (such as a WindowsFormsHost or WebBrowser) properly registers activation in containing docking windows.
Public class | ReadOnlyDockingWindowBaseCollectionT | Represents the base class for a read-only observable collection of DockingWindow objects.
Public class | ReadOnlyDockingWindowCollection | Represents a read-only observable collection of DockingWindow objects.
Public class | ReadOnlyToolWindowCollection | Represents a read-only observable collection of ToolWindow objects.
Public class | SimpleSwitcher | Implements a SwitcherBase that has no user interface and simply processes keystrokes.
Public class | SplitContainer | Represents a container that has multiple split panes of content.
Public class | StandardMdiHost | Represents a container that hosts docking windows in a standard, or windowed, MDI (multiple-document interface) mode.
Public class | StandardSwitcher | Implements a SwitcherBase that is similar to the switcher found in Visual Studio.
Public class | TabbedMdiContainer | Represents a container of one or more documents in tabbed MDI.
Public class | TabbedMdiHost | Represents a container that hosts docking windows in a tabbed MDI (multiple-document interface) mode.
Public class | ToolWindow | Represents a tool window.
Public class | ToolWindowCollection | Represents an observable collection of ToolWindow objects.
Public class | ToolWindowContainer | Represents a container of one or more tool windows.
Public class | ToolWindowContainerCollection | Represents an observable collection of ToolWindowContainer objects.
Public class | WindowControl | Represents a ContentControl that renders like a normal native Window but can be used in other non-top-level contexts.
Public class | Workspace | Represents a control that can contain a MDI host, and around which tool windows are docked.
Interfaces
 | Interface | Description
Public interface | IDockTarget | Provides the base requirements for an object that is a possible target for a docking operation.
Enumerations
 | Enumeration | Description
Public enumeration | ContextContentAlignment | Indicates the alignment around the primary content (e.g. title) that the contextual content appears.
Public enumeration | DockGuideKinds | Specifies multiple dock guide kinds.
Public enumeration | DockingMenuKind | Specifies the kind of context or drop-down menu used by the docking elements.
Public enumeration | DockingWindowItemKind | Indicates the kind of container that is generated for a DockSite item.
Public enumeration | DockingWindowState | Indicates the state for a DockingWindow.
Public enumeration | FloatingWindowShowInTaskBarMode | Specifies the mode by which to show floating windows in the taskbar.
Public enumeration | MdiKind | Specifies the kind of MDI (multiple-document interface).
Public enumeration | SingleTabLayoutBehavior | Indicates the behavior of single tabs in their associated containers.
Public enumeration | SizeToContentModes | Specifies the modes when size-to-content should be applied.
Public enumeration | TabFlashMode | Specifies the flash mode to apply to a tab.
Public enumeration | TabHighlightKind | Specifies the kind of highlight to apply to a tab.
Public enumeration | TabLayoutKind | Specifies the kind of tab, which affects its layout.
Public enumeration | TabOverflowBehavior | Indicates the overflow behavior of tabs.


AdvancedTabControl Class

Represents a tab control with advanced features.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsTabControl
ActiproSoftware.Windows.Controls.DockingAdvancedTabControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesTabbedMdiContainerTabControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesToolWindowContainerTabControl

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTabControl : TabControl
Public Class AdvancedTabControl
    Inherits TabControl

The AdvancedTabControl type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabControl | Initializes an instance of the AdvancedTabControl class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible.
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported.
Public property | CanScrollForward | Gets whether scrolling forward is supported.
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them.
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled.
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones.
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button.
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button.
Public property | CanTabsSelectOnDragOver | Gets or sets whether tabs can be selected when performing a system (e.g. text, file) drag over them.
Public property | ContentStringFormat | Gets a composite string that specifies how to format the contents of the TabItem objects if they are displayed as strings. (Inherited from TabControl.)
Public property | ContentTemplate | Gets or sets the DataTemplate to apply to any TabItem that does not have a ContentTemplate or ContentTemplateSelector property defined. (Inherited from TabControl.)
Public property | ContentTemplateSelector | Gets or sets a DataTemplateSelector that provides custom logic for choosing the template that is used to display the content of the control. (Inherited from TabControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available.
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available.
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border.
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border.
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus.
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed.
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible.
Public property | IsOverflowed | Gets whether the tabs are overflowed.
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation.
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled.
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible.
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab.
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content.
Public property | MinTabExtent | Gets or sets the minimum extent of a tab.
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button.
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu.
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab.
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement.
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement.
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement.
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content.
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward.
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content.
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward.
Public property | ScrollOffset | Gets the scroll offset.
Public property | SelectedContent | Gets the content of the currently selected TabItem. (Inherited from TabControl.)
Public property | SelectedContentStringFormat | Gets a composite string that specifies how to format the content of the currently selected TabItem if it is displayed as a string. (Inherited from TabControl.)
Public property | SelectedContentTemplate | Gets the DataTemplate of the currently selected item. (Inherited from TabControl.)
Public property | SelectedContentTemplateSelector | Gets the DataTemplateSelector of the currently selected item. (Inherited from TabControl.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item.
Public property | TabBackground | Gets or sets the tabs' background Brush to use.
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active.
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive.
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it.
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab.
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use.
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active.
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive.
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it.
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab.
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab.
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs.
Public property | TabFarSlantExtent | Gets or sets the far side slant extent of the tabs.
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use.
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active.
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive.
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it.
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab.
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabNearSlantExtent | Gets or sets the near side slant extent of the tabs.
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.
Public property | TabPadding | Gets or sets the tab padding.
Public property | TabSpacing | Gets or sets the spacing between tabs.
Public property | TabStripPlacement | Gets or sets how tab headers align relative to the tab content. (Inherited from TabControl.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDefaultFocusHandling | Gets or sets whether to use default TabItem focus handling.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides SelectorClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TabControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TabControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TabControlOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TabControlOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Called when IsInitialized is set to true. (Inherited from TabControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called to update the current selection when items change. (Inherited from TabControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides TabControlOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Occurs when the control's size is changed. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnSelectionChanged | Occurs when the selection has changed. (Overrides TabControlOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides SelectorPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MenuOpening | Occurs before a context or drop-down menu is opening.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | NewTabRequested | Occurs when a new tab is requested.
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button.
Top
Fields
Name | Description
AreScrollButtonsVisibleProperty | Identifies the AreScrollButtonsVisible dependency property. This field is read-only.
AreTabEmbeddedButtonsAlwaysVisibleProperty | Identifies the AreTabEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.
CanScrollBackwardProperty | Identifies the CanScrollBackward dependency property. This field is read-only.
CanScrollForwardProperty | Identifies the CanScrollForward dependency property. This field is read-only.
CanTabsCloseOnMiddleClickProperty | Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.
CanTabsDragProperty | Identifies the CanTabsDrag dependency property. This field is read-only.
CanTabsHighlightOnPointerOverWhenInactiveProperty | Identifies the CanTabsHighlightOnPointerOverWhenInactive dependency property. This field is read-only.
CanTabsPinProperty | Identifies the CanTabsPin dependency property. This field is read-only.
CanTabsPromoteProperty | Identifies the CanTabsPromote dependency property. This field is read-only.
CanTabsSelectOnDragOverProperty | Identifies the CanTabsSelectOnDragOver dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
HasNewTabButtonProperty | Identifies the HasNewTabButton dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
HighlightBrushActiveProperty | Identifies the HighlightBrushActive dependency property. This field is read-only.
HighlightBrushInactiveProperty | Identifies the HighlightBrushInactive dependency property. This field is read-only.
HighlightThicknessProperty | Identifies the HighlightThickness dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsLayoutAnimationEnabledProperty | Identifies the IsLayoutAnimationEnabled dependency property. This field is read-only.
IsMenuButtonVisibleProperty | Identifies the IsMenuButtonVisible dependency property. This field is read-only.
IsOverflowedProperty | Identifies the IsOverflowed dependency property. This field is read-only.
IsTabContentHorizontalProperty | Identifies the IsTabContentHorizontal dependency property. This field is read-only.
IsTabKeyboardAccessEnabledProperty | Identifies the IsTabKeyboardAccessEnabled dependency property. This field is read-only.
IsTabKeyboardSwitchingEnabledProperty | Identifies the IsTabKeyboardSwitchingEnabled dependency property. This field is read-only.
IsTabStripVisibleProperty | Identifies the IsTabStripVisible dependency property. This field is read-only.
MaxTabExtentProperty | Identifies the MaxTabExtent dependency property. This field is read-only.
MenuButtonContentTemplateProperty | Identifies the MenuButtonContentTemplate dependency property. This field is read-only.
MinTabExtentProperty | Identifies the MinTabExtent dependency property. This field is read-only.
NewTabButtonStyleProperty | Identifies the NewTabButtonStyle dependency property. This field is read-only.
OverflowMenuButtonContentTemplateProperty | Identifies the OverflowMenuButtonContentTemplate dependency property. This field is read-only.
RotatedBorderThicknessProperty | Identifies the RotatedBorderThickness dependency property. This field is read-only.
RotatedHighlightThicknessProperty | Identifies the RotatedHighlightThickness dependency property. This field is read-only.
RotatedPaddingProperty | Identifies the RotatedPadding dependency property. This field is read-only.
ScrollBackwardButtonContentTemplateProperty | Identifies the ScrollBackwardButtonContentTemplate dependency property. This field is read-only.
ScrollForwardButtonContentTemplateProperty | Identifies the ScrollForwardButtonContentTemplate dependency property. This field is read-only.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property. This field is read-only.
TabBackgroundActiveSelectedProperty | Identifies the TabBackgroundActiveSelected dependency property. This field is read-only.
TabBackgroundInactiveSelectedProperty | Identifies the TabBackgroundInactiveSelected dependency property. This field is read-only.
TabBackgroundPointerOverProperty | Identifies the TabBackgroundPointerOver dependency property. This field is read-only.
TabBackgroundPreviewActiveSelectedProperty | Identifies the TabBackgroundPreviewActiveSelected dependency property. This field is read-only.
TabBackgroundPreviewPointerOverProperty | Identifies the TabBackgroundPreviewPointerOver dependency property. This field is read-only.
TabBackgroundPreviewProperty | Identifies the TabBackgroundPreview dependency property. This field is read-only.
TabBackgroundProperty | Identifies the TabBackground dependency property. This field is read-only.
TabBorderBrushActiveSelectedProperty | Identifies the TabBorderBrushActiveSelected dependency property. This field is read-only.
TabBorderBrushInactiveSelectedProperty | Identifies the TabBorderBrushInactiveSelected dependency property. This field is read-only.
TabBorderBrushPointerOverProperty | Identifies the TabBorderBrushPointerOver dependency property. This field is read-only.
TabBorderBrushPreviewActiveSelectedProperty | Identifies the TabBorderBrushPreviewActiveSelected dependency property. This field is read-only.
TabBorderBrushPreviewPointerOverProperty | Identifies the TabBorderBrushPreviewPointerOver dependency property. This field is read-only.
TabBorderBrushPreviewProperty | Identifies the TabBorderBrushPreview dependency property. This field is read-only.
TabBorderBrushProperty | Identifies the TabBorderBrush dependency property. This field is read-only.
TabCornerRadiusProperty | Identifies the TabCornerRadius dependency property. This field is read-only.
TabEmbeddedButtonStyleProperty | Identifies the TabEmbeddedButtonStyle dependency property. This field is read-only.
TabFarSlantExtentProperty | Identifies the TabFarSlantExtent dependency property. This field is read-only.
TabForegroundActiveSelectedProperty | Identifies the TabForegroundActiveSelected dependency property. This field is read-only.
TabForegroundInactiveSelectedProperty | Identifies the TabForegroundInactiveSelected dependency property. This field is read-only.
TabForegroundPointerOverProperty | Identifies the TabForegroundPointerOver dependency property. This field is read-only.
TabForegroundPreviewActiveSelectedProperty | Identifies the TabForegroundPreviewActiveSelected dependency property. This field is read-only.
TabForegroundPreviewPointerOverProperty | Identifies the TabForegroundPreviewPointerOver dependency property. This field is read-only.
TabForegroundPreviewProperty | Identifies the TabForegroundPreview dependency property. This field is read-only.
TabForegroundProperty | Identifies the TabForeground dependency property. This field is read-only.
TabNearSlantExtentProperty | Identifies the TabNearSlantExtent dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabPaddingProperty | Identifies the TabPadding dependency property. This field is read-only.
TabSpacingProperty | Identifies the TabSpacing dependency property. This field is read-only.
UseDefaultFocusHandlingProperty | Identifies the UseDefaultFocusHandling dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl Constructor

Initializes an instance of the AdvancedTabControl class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabControl()
Public Sub New
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl Properties

The AdvancedTabControl type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible.
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported.
Public property | CanScrollForward | Gets whether scrolling forward is supported.
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them.
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled.
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones.
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button.
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button.
Public property | CanTabsSelectOnDragOver | Gets or sets whether tabs can be selected when performing a system (e.g. text, file) drag over them.
Public property | ContentStringFormat | Gets a composite string that specifies how to format the contents of the TabItem objects if they are displayed as strings. (Inherited from TabControl.)
Public property | ContentTemplate | Gets or sets the DataTemplate to apply to any TabItem that does not have a ContentTemplate or ContentTemplateSelector property defined. (Inherited from TabControl.)
Public property | ContentTemplateSelector | Gets or sets a DataTemplateSelector that provides custom logic for choosing the template that is used to display the content of the control. (Inherited from TabControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available.
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available.
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border.
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border.
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus.
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed.
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible.
Public property | IsOverflowed | Gets whether the tabs are overflowed.
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation.
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled.
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible.
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab.
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content.
Public property | MinTabExtent | Gets or sets the minimum extent of a tab.
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button.
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu.
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab.
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement.
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement.
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement.
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content.
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward.
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content.
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward.
Public property | ScrollOffset | Gets the scroll offset.
Public property | SelectedContent | Gets the content of the currently selected TabItem. (Inherited from TabControl.)
Public property | SelectedContentStringFormat | Gets a composite string that specifies how to format the content of the currently selected TabItem if it is displayed as a string. (Inherited from TabControl.)
Public property | SelectedContentTemplate | Gets the DataTemplate of the currently selected item. (Inherited from TabControl.)
Public property | SelectedContentTemplateSelector | Gets the DataTemplateSelector of the currently selected item. (Inherited from TabControl.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item.
Public property | TabBackground | Gets or sets the tabs' background Brush to use.
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active.
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive.
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it.
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab.
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use.
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active.
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive.
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it.
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab.
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab.
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs.
Public property | TabFarSlantExtent | Gets or sets the far side slant extent of the tabs.
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use.
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active.
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive.
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it.
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab.
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabNearSlantExtent | Gets or sets the near side slant extent of the tabs.
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.
Public property | TabPadding | Gets or sets the tab padding.
Public property | TabSpacing | Gets or sets the spacing between tabs.
Public property | TabStripPlacement | Gets or sets how tab headers align relative to the tab content. (Inherited from TabControl.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDefaultFocusHandling | Gets or sets whether to use default TabItem focus handling.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.AreScrollButtonsVisible Property

AdvancedTabControlAreScrollButtonsVisible Property

Gets whether the scroll buttons are visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreScrollButtonsVisible { get; }
Public ReadOnly Property AreScrollButtonsVisible As Boolean
    Get

Property Value

Type: Boolean
true if the scroll buttons are visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.AreTabEmbeddedButtonsAlwaysVisible Property

AdvancedTabControlAreTabEmbeddedButtonsAlwaysVisible Property

Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreTabEmbeddedButtonsAlwaysVisible { get; set; }
Public Property AreTabEmbeddedButtonsAlwaysVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tab embedded buttons are always visible, even when the tab is unselected; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanScrollBackward Property

AdvancedTabControlCanScrollBackward Property

Gets whether scrolling backward is supported.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanScrollBackward { get; }
Public ReadOnly Property CanScrollBackward As Boolean
    Get

Property Value

Type: Boolean
true if scrolling backward is supported; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanScrollForward Property

AdvancedTabControlCanScrollForward Property

Gets whether scrolling forward is supported.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanScrollForward { get; }
Public ReadOnly Property CanScrollForward As Boolean
    Get

Property Value

Type: Boolean
true if scrolling forward is supported; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsCloseOnMiddleClick Property

AdvancedTabControlCanTabsCloseOnMiddleClick Property

Gets or sets whether tabs can close when a middle-click is performed over them.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanTabsCloseOnMiddleClick { get; set; }
Public Property CanTabsCloseOnMiddleClick As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs can close when a middle-click is performed over them; otherwise, false. The default value is true.
Remarks
The CanClose property must also be set to true for this behavior to work.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsDrag Property

AdvancedTabControlCanTabsDrag Property

Gets or sets whether the dragging of tabs to reorder is enabled.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanTabsDrag { get; set; }
Public Property CanTabsDrag As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dragging of tabs to reorder is enabled; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsHighlightOnPointerOverWhenInactive Property

AdvancedTabControlCanTabsHighlightOnPointerOverWhenInactive Property

Gets or sets whether tabs can highlight when the pointer is over inactive ones.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanTabsHighlightOnPointerOverWhenInactive { get; set; }
Public Property CanTabsHighlightOnPointerOverWhenInactive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs can highlight when the pointer is over inactive ones; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsPin Property

AdvancedTabControlCanTabsPin Property

Gets or sets whether tabs display an embedded pin button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanTabsPin { get; set; }
Public Property CanTabsPin As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs display an embedded pin button; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsPromote Property

AdvancedTabControlCanTabsPromote Property

Gets or sets whether tabs display an embedded promote from preview layout kind button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanTabsPromote { get; set; }
Public Property CanTabsPromote As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs display an embedded promote from preview layout kind button; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsSelectOnDragOver Property

AdvancedTabControlCanTabsSelectOnDragOver Property

Gets or sets whether tabs can be selected when performing a system (e.g. text, file) drag over them.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanTabsSelectOnDragOver { get; set; }
Public Property CanTabsSelectOnDragOver As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs can be selected when performing a system (e.g. text, file) drag over them; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.EmbeddedButtonStyle Property

AdvancedTabControlEmbeddedButtonStyle Property

Gets or sets the Style to use for embedded buttons.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style EmbeddedButtonStyle { get; set; }
Public Property EmbeddedButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for embedded buttons.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HasNewTabButton Property

AdvancedTabControlHasNewTabButton Property

Gets or sets whether a new tab button is available.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasNewTabButton { get; set; }
Public Property HasNewTabButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a new tab button is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HasTabCloseButtons Property

AdvancedTabControlHasTabCloseButtons Property

Gets or sets whether tabs have an embedded close button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabCloseButtons { get; set; }
Public Property HasTabCloseButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs have an embedded close button; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HasTabImages Property

AdvancedTabControlHasTabImages Property

Gets or sets whether tabs display an embedded image when one is available.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabImages { get; set; }
Public Property HasTabImages As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs display an embedded image when one is available; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HighlightBrushActive Property

AdvancedTabControlHighlightBrushActive Property

Gets or sets the Brush to use for rendering an active highlight effect around the content border.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush HighlightBrushActive { get; set; }
Public Property HighlightBrushActive As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for rendering an active highlight effect around the content border.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HighlightBrushInactive Property

AdvancedTabControlHighlightBrushInactive Property

Gets or sets the Brush to use for rendering an inactive highlight effect around the content border.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush HighlightBrushInactive { get; set; }
Public Property HighlightBrushInactive As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for rendering an inactive highlight effect around the content border. The default value is 0.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HighlightThickness Property

AdvancedTabControlHighlightThickness Property

Gets or sets the thickness of the highlight effect around the content border.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness HighlightThickness { get; set; }
Public Property HighlightThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The thickness of the highlight effect around the content border. The default value is 0.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsActive Property

AdvancedTabControlIsActive Property

Gets or sets whether the tab control is active, generally meaning it contains focus.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsActive { get; set; }
Public Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab control is active; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsLayoutAnimationEnabled Property

AdvancedTabControlIsLayoutAnimationEnabled Property

Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsLayoutAnimationEnabled { get; set; }
Public Property IsLayoutAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if animation effects are applied during layout, such as when tabs are added or removed; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsMenuButtonVisible Property

AdvancedTabControlIsMenuButtonVisible Property

Gets whether the drop-down menu button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMenuButtonVisible { get; }
Public ReadOnly Property IsMenuButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the drop-down menu button is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsOverflowed Property

AdvancedTabControlIsOverflowed Property

Gets whether the tabs are overflowed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOverflowed { get; }
Public ReadOnly Property IsOverflowed As Boolean
    Get

Property Value

Type: Boolean
true if the tabs are overflowed; otherwise, false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsTabContentHorizontal Property

AdvancedTabControlIsTabContentHorizontal Property

Gets or sets whether the tab content layout is in a horizontal orientation.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTabContentHorizontal { get; set; }
Public Property IsTabContentHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab content layout is in a horizontal orientation; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsTabKeyboardAccessEnabled Property

AdvancedTabControlIsTabKeyboardAccessEnabled Property

Gets or sets whether keyboard access to directly select a tab is enabled.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTabKeyboardAccessEnabled { get; set; }
Public Property IsTabKeyboardAccessEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if keyboard access to directly select a tab is enabled; otherwise, false. The default value is true.
Remarks
When enabled, Ctrl+1 will activate the first tab in a normal state, with Ctrl+2 activating the second normal tab, and so on. Ctrl+Alt+1 will activate the first tab in a pinned state, with Ctrl+Alt+2 activating the second pinned tab, and so on.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsTabKeyboardSwitchingEnabled Property

AdvancedTabControlIsTabKeyboardSwitchingEnabled Property

Gets or sets whether keyboard access to switch to the previous/next tab is enabled.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTabKeyboardSwitchingEnabled { get; set; }
Public Property IsTabKeyboardSwitchingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if keyboard access to switch to the previous/next tab is enabled; otherwise, false. The default value is true.
Remarks
When enabled, Ctrl+Tab will switch to the next tab and Ctrl+Shift+Tab will switch to the previous tab.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsTabStripVisible Property

AdvancedTabControlIsTabStripVisible Property

Gets or sets whether the tabstrip is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTabStripVisible { get; set; }
Public Property IsTabStripVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tabstrip is visible; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.MaxTabExtent Property

AdvancedTabControlMaxTabExtent Property

Gets or sets the maximum extent of a tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MaxTabExtent { get; set; }
Public Property MaxTabExtent As Double
    Get
    Set

Property Value

Type: Double
The maximum extent of a tab. The default value is 260.0.
Remarks
Set the MinTabExtent to the same as the MaxTabExtent to produce fixed-size tabs.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.MenuButtonContentTemplate Property

AdvancedTabControlMenuButtonContentTemplate Property

Gets or sets the DataTemplate to use for the drop-down menu button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate MenuButtonContentTemplate { get; set; }
Public Property MenuButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the drop-down menu button content.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.MinTabExtent Property

AdvancedTabControlMinTabExtent Property

Gets or sets the minimum extent of a tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MinTabExtent { get; set; }
Public Property MinTabExtent As Double
    Get
    Set

Property Value

Type: Double
The minimum extent of a tab. The default value is 30.0.
Remarks
Set the MinTabExtent to the same as the MaxTabExtent to produce fixed-size tabs. This property will be ignored when a TabOverflowBehavior that involves shrinking is active and the tabs enter an overflow scenario.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.NewTabButtonStyle Property

AdvancedTabControlNewTabButtonStyle Property

Gets or sets the Style to use for the new tab button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style NewTabButtonStyle { get; set; }
Public Property NewTabButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the new tab button.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.OpenMenuCommand Property

AdvancedTabControlOpenMenuCommand Property

Gets the ICommand that can be used to open the drop-down menu.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand OpenMenuCommand { get; }
Public ReadOnly Property OpenMenuCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to open the drop-down menu.
Remarks
Pass the source button element as the command parameter.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.OverflowMenuButtonContentTemplate Property

AdvancedTabControlOverflowMenuButtonContentTemplate Property

Gets or sets the DataTemplate to use for the overflow drop-down menu button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate OverflowMenuButtonContentTemplate { get; set; }
Public Property OverflowMenuButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the overflow drop-down menu button content.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.RequestNewTabCommand Property

AdvancedTabControlRequestNewTabCommand Property

Gets the ICommand that can be used to request a new tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand RequestNewTabCommand { get; }
Public ReadOnly Property RequestNewTabCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to request a new tab.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.RotatedBorderThickness Property

AdvancedTabControlRotatedBorderThickness Property

Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness RotatedBorderThickness { get; set; }
Public Property RotatedBorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The BorderThickness value, but automatically rotated based on the TabStripPlacement. The default value is 0.
Remarks
This property should not be set, as it will be set internally.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.RotatedHighlightThickness Property

AdvancedTabControlRotatedHighlightThickness Property

Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness RotatedHighlightThickness { get; set; }
Public Property RotatedHighlightThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The HighlightThickness value, but automatically rotated based on the TabStripPlacement. The default value is 0.
Remarks
This property should not be set, as it will be set internally.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.RotatedPadding Property

AdvancedTabControlRotatedPadding Property

Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness RotatedPadding { get; set; }
Public Property RotatedPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The Padding value, but automatically rotated based on the TabStripPlacement. The default value is 0.
Remarks
This property should not be set, as it will be set internally.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ScrollBackwardButtonContentTemplate Property

AdvancedTabControlScrollBackwardButtonContentTemplate Property

Gets or sets the DataTemplate to use for the scroll backward button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ScrollBackwardButtonContentTemplate { get; set; }
Public Property ScrollBackwardButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the scroll backward content.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ScrollBackwardCommand Property

AdvancedTabControlScrollBackwardCommand Property

Gets the ICommand that can be used to scroll backward.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ScrollBackwardCommand { get; }
Public ReadOnly Property ScrollBackwardCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to scroll backward.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ScrollForwardButtonContentTemplate Property

AdvancedTabControlScrollForwardButtonContentTemplate Property

Gets or sets the DataTemplate to use for the scroll forward button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ScrollForwardButtonContentTemplate { get; set; }
Public Property ScrollForwardButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the scroll forward content.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ScrollForwardCommand Property

AdvancedTabControlScrollForwardCommand Property

Gets the ICommand that can be used to scroll forward.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ScrollForwardCommand { get; }
Public ReadOnly Property ScrollForwardCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to scroll forward.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ScrollOffset Property

AdvancedTabControlScrollOffset Property

Gets the scroll offset.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ScrollOffset { get; }
Public ReadOnly Property ScrollOffset As Double
    Get

Property Value

Type: Double
The scroll offset.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.SelectItemCommand Property

AdvancedTabControlSelectItemCommand Property

Gets the ICommand that can be used to select an item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SelectItemCommand { get; }
Public ReadOnly Property SelectItemCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to select an item.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackground Property

AdvancedTabControlTabBackground Property

Gets or sets the tabs' background Brush to use.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBackground { get; set; }
Public Property TabBackground As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundActiveSelected Property

AdvancedTabControlTabBackgroundActiveSelected Property

Gets or sets the tabs' background Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBackgroundActiveSelected { get; set; }
Public Property TabBackgroundActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundInactiveSelected Property

AdvancedTabControlTabBackgroundInactiveSelected Property

Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBackgroundInactiveSelected { get; set; }
Public Property TabBackgroundInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPointerOver Property

AdvancedTabControlTabBackgroundPointerOver Property

Gets or sets the tabs' background Brush to use when the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBackgroundPointerOver { get; set; }
Public Property TabBackgroundPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreview Property

AdvancedTabControlTabBackgroundPreview Property

Gets or sets the tabs' background Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBackgroundPreview { get; set; }
Public Property TabBackgroundPreview As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewActiveSelected Property

AdvancedTabControlTabBackgroundPreviewActiveSelected Property

Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBackgroundPreviewActiveSelected { get; set; }
Public Property TabBackgroundPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewPointerOver Property

AdvancedTabControlTabBackgroundPreviewPointerOver Property

Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBackgroundPreviewPointerOver { get; set; }
Public Property TabBackgroundPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrush Property

AdvancedTabControlTabBorderBrush Property

Gets or sets the tabs' border Brush to use.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBorderBrush { get; set; }
Public Property TabBorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushActiveSelected Property

AdvancedTabControlTabBorderBrushActiveSelected Property

Gets or sets the tabs' border Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushActiveSelected { get; set; }
Public Property TabBorderBrushActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushInactiveSelected Property

AdvancedTabControlTabBorderBrushInactiveSelected Property

Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushInactiveSelected { get; set; }
Public Property TabBorderBrushInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPointerOver Property

AdvancedTabControlTabBorderBrushPointerOver Property

Gets or sets the tabs' border Brush to use when the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushPointerOver { get; set; }
Public Property TabBorderBrushPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreview Property

AdvancedTabControlTabBorderBrushPreview Property

Gets or sets the tabs' border Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushPreview { get; set; }
Public Property TabBorderBrushPreview As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewActiveSelected Property

AdvancedTabControlTabBorderBrushPreviewActiveSelected Property

Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushPreviewActiveSelected { get; set; }
Public Property TabBorderBrushPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewPointerOver Property

AdvancedTabControlTabBorderBrushPreviewPointerOver Property

Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushPreviewPointerOver { get; set; }
Public Property TabBorderBrushPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabCornerRadius Property

AdvancedTabControlTabCornerRadius Property

Gets or sets the corner radius of tab borders, relative to a top-facing tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius TabCornerRadius { get; set; }
Public Property TabCornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of tab borders, relative to a top-facing tab.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabEmbeddedButtonStyle Property

AdvancedTabControlTabEmbeddedButtonStyle Property

Gets or sets the Style to use for embedded buttons within tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TabEmbeddedButtonStyle { get; set; }
Public Property TabEmbeddedButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for embedded buttons within tabs.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabFarSlantExtent Property

AdvancedTabControlTabFarSlantExtent Property

Gets or sets the far side slant extent of the tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TabFarSlantExtent { get; set; }
Public Property TabFarSlantExtent As Double
    Get
    Set

Property Value

Type: Double
The far side slant extent of the tabs, or 0.0 for no slant. The default value is 0.0.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForeground Property

AdvancedTabControlTabForeground Property

Gets or sets the tabs' foreground Brush to use.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabForeground { get; set; }
Public Property TabForeground As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundActiveSelected Property

AdvancedTabControlTabForegroundActiveSelected Property

Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabForegroundActiveSelected { get; set; }
Public Property TabForegroundActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundInactiveSelected Property

AdvancedTabControlTabForegroundInactiveSelected Property

Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabForegroundInactiveSelected { get; set; }
Public Property TabForegroundInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPointerOver Property

AdvancedTabControlTabForegroundPointerOver Property

Gets or sets the tabs' foreground Brush to use when the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabForegroundPointerOver { get; set; }
Public Property TabForegroundPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreview Property

AdvancedTabControlTabForegroundPreview Property

Gets or sets the tabs' foreground Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabForegroundPreview { get; set; }
Public Property TabForegroundPreview As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewActiveSelected Property

AdvancedTabControlTabForegroundPreviewActiveSelected Property

Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabForegroundPreviewActiveSelected { get; set; }
Public Property TabForegroundPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewPointerOver Property

AdvancedTabControlTabForegroundPreviewPointerOver Property

Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TabForegroundPreviewPointerOver { get; set; }
Public Property TabForegroundPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabNearSlantExtent Property

AdvancedTabControlTabNearSlantExtent Property

Gets or sets the near side slant extent of the tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TabNearSlantExtent { get; set; }
Public Property TabNearSlantExtent As Double
    Get
    Set

Property Value

Type: Double
The near side slant extent of the tabs, or 0.0 for no slant. The default value is 0.0.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabOverflowBehavior Property

AdvancedTabControlTabOverflowBehavior Property

Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabOverflowBehavior TabOverflowBehavior { get; set; }
Public Property TabOverflowBehavior As TabOverflowBehavior
    Get
    Set

Property Value

Type: TabOverflowBehavior
The TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. The default value is Shrink.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabPadding Property

AdvancedTabControlTabPadding Property

Gets or sets the tab padding.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness TabPadding { get; set; }
Public Property TabPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The tab padding. The default value is 5,2.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabSpacing Property

AdvancedTabControlTabSpacing Property

Gets or sets the spacing between tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TabSpacing { get; set; }
Public Property TabSpacing As Double
    Get
    Set

Property Value

Type: Double
The spacing between tabs. The default value is 0.0.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.UseDefaultFocusHandling Property

AdvancedTabControlUseDefaultFocusHandling Property

Gets or sets whether to use default TabItem focus handling.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseDefaultFocusHandling { get; set; }
Public Property UseDefaultFocusHandling As Boolean
    Get
    Set

Property Value

Type: Boolean
true if default TabItem focus handling should be used; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl Methods

The AdvancedTabControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides SelectorClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TabControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TabControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TabControlOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TabControlOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Called when IsInitialized is set to true. (Inherited from TabControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called to update the current selection when items change. (Inherited from TabControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides TabControlOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Occurs when the control's size is changed. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnSelectionChanged | Occurs when the selection has changed. (Overrides TabControlOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides SelectorPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ArrangeOverride Method

AdvancedTabControlArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ClearContainerForItemOverride Method

AdvancedTabControlClearContainerForItemOverride Method

Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.GetContainerForItemOverride Method

AdvancedTabControlGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsItemItsOwnContainerOverride Method

AdvancedTabControlIsItemItsOwnContainerOverride Method

Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.OnApplyTemplate Method

AdvancedTabControlOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.OnCreateAutomationPeer Method

AdvancedTabControlOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.OnKeyDown Method

AdvancedTabControlOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.OnRenderSizeChanged Method

AdvancedTabControlOnRenderSizeChanged Method

Occurs when the control's size is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRenderSizeChanged(
    SizeChangedInfo sizeInfo
)
Protected Overrides Sub OnRenderSizeChanged (
    sizeInfo As SizeChangedInfo
)

Parameters

sizeInfo
Type: System.WindowsSizeChangedInfo
The size change info.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.OnSelectionChanged Method

AdvancedTabControlOnSelectionChanged Method

Occurs when the selection has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnSelectionChanged(
    SelectionChangedEventArgs e
)
Protected Overrides Sub OnSelectionChanged (
    e As SelectionChangedEventArgs
)

Parameters

e
Type: System.Windows.ControlsSelectionChangedEventArgs
The SelectionChangedEventArgs containing arguments related to this event.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.PrepareContainerForItemOverride Method

AdvancedTabControlPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.UpdateHighlightBrushes Method

AdvancedTabControlUpdateHighlightBrushes Method

Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateHighlightBrushes()
Protected Overridable Sub UpdateHighlightBrushes
Remarks
The default implementation of this method does nothing.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl Events

The AdvancedTabControl type exposes the following members.

Events
 | Name | Description
Public event | MenuOpening | Occurs before a context or drop-down menu is opening.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | NewTabRequested | Occurs when a new tab is requested.
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button.
Top
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.MenuOpening Event

AdvancedTabControlMenuOpening Event

Occurs before a context or drop-down menu is opening.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<AdvancedTabControlMenuEventArgs> MenuOpening
Public Event MenuOpening As EventHandler(Of AdvancedTabControlMenuEventArgs)

Value

Type: SystemEventHandler AdvancedTabControlMenuEventArgs
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.NewTabRequested Event

AdvancedTabControlNewTabRequested Event

Occurs when a new tab is requested.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler NewTabRequested
Public Event NewTabRequested As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabClosing Event

AdvancedTabControlTabClosing Event

Occurs before a tab is closed due to clicking on its close button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<AdvancedTabItemEventArgs> TabClosing
Public Event TabClosing As EventHandler(Of AdvancedTabItemEventArgs)

Value

Type: SystemEventHandler AdvancedTabItemEventArgs
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl Fields

The AdvancedTabControl type exposes the following members.

Fields
Name | Description
AreScrollButtonsVisibleProperty | Identifies the AreScrollButtonsVisible dependency property. This field is read-only.
AreTabEmbeddedButtonsAlwaysVisibleProperty | Identifies the AreTabEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.
CanScrollBackwardProperty | Identifies the CanScrollBackward dependency property. This field is read-only.
CanScrollForwardProperty | Identifies the CanScrollForward dependency property. This field is read-only.
CanTabsCloseOnMiddleClickProperty | Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.
CanTabsDragProperty | Identifies the CanTabsDrag dependency property. This field is read-only.
CanTabsHighlightOnPointerOverWhenInactiveProperty | Identifies the CanTabsHighlightOnPointerOverWhenInactive dependency property. This field is read-only.
CanTabsPinProperty | Identifies the CanTabsPin dependency property. This field is read-only.
CanTabsPromoteProperty | Identifies the CanTabsPromote dependency property. This field is read-only.
CanTabsSelectOnDragOverProperty | Identifies the CanTabsSelectOnDragOver dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
HasNewTabButtonProperty | Identifies the HasNewTabButton dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
HighlightBrushActiveProperty | Identifies the HighlightBrushActive dependency property. This field is read-only.
HighlightBrushInactiveProperty | Identifies the HighlightBrushInactive dependency property. This field is read-only.
HighlightThicknessProperty | Identifies the HighlightThickness dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsLayoutAnimationEnabledProperty | Identifies the IsLayoutAnimationEnabled dependency property. This field is read-only.
IsMenuButtonVisibleProperty | Identifies the IsMenuButtonVisible dependency property. This field is read-only.
IsOverflowedProperty | Identifies the IsOverflowed dependency property. This field is read-only.
IsTabContentHorizontalProperty | Identifies the IsTabContentHorizontal dependency property. This field is read-only.
IsTabKeyboardAccessEnabledProperty | Identifies the IsTabKeyboardAccessEnabled dependency property. This field is read-only.
IsTabKeyboardSwitchingEnabledProperty | Identifies the IsTabKeyboardSwitchingEnabled dependency property. This field is read-only.
IsTabStripVisibleProperty | Identifies the IsTabStripVisible dependency property. This field is read-only.
MaxTabExtentProperty | Identifies the MaxTabExtent dependency property. This field is read-only.
MenuButtonContentTemplateProperty | Identifies the MenuButtonContentTemplate dependency property. This field is read-only.
MinTabExtentProperty | Identifies the MinTabExtent dependency property. This field is read-only.
NewTabButtonStyleProperty | Identifies the NewTabButtonStyle dependency property. This field is read-only.
OverflowMenuButtonContentTemplateProperty | Identifies the OverflowMenuButtonContentTemplate dependency property. This field is read-only.
RotatedBorderThicknessProperty | Identifies the RotatedBorderThickness dependency property. This field is read-only.
RotatedHighlightThicknessProperty | Identifies the RotatedHighlightThickness dependency property. This field is read-only.
RotatedPaddingProperty | Identifies the RotatedPadding dependency property. This field is read-only.
ScrollBackwardButtonContentTemplateProperty | Identifies the ScrollBackwardButtonContentTemplate dependency property. This field is read-only.
ScrollForwardButtonContentTemplateProperty | Identifies the ScrollForwardButtonContentTemplate dependency property. This field is read-only.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property. This field is read-only.
TabBackgroundActiveSelectedProperty | Identifies the TabBackgroundActiveSelected dependency property. This field is read-only.
TabBackgroundInactiveSelectedProperty | Identifies the TabBackgroundInactiveSelected dependency property. This field is read-only.
TabBackgroundPointerOverProperty | Identifies the TabBackgroundPointerOver dependency property. This field is read-only.
TabBackgroundPreviewActiveSelectedProperty | Identifies the TabBackgroundPreviewActiveSelected dependency property. This field is read-only.
TabBackgroundPreviewPointerOverProperty | Identifies the TabBackgroundPreviewPointerOver dependency property. This field is read-only.
TabBackgroundPreviewProperty | Identifies the TabBackgroundPreview dependency property. This field is read-only.
TabBackgroundProperty | Identifies the TabBackground dependency property. This field is read-only.
TabBorderBrushActiveSelectedProperty | Identifies the TabBorderBrushActiveSelected dependency property. This field is read-only.
TabBorderBrushInactiveSelectedProperty | Identifies the TabBorderBrushInactiveSelected dependency property. This field is read-only.
TabBorderBrushPointerOverProperty | Identifies the TabBorderBrushPointerOver dependency property. This field is read-only.
TabBorderBrushPreviewActiveSelectedProperty | Identifies the TabBorderBrushPreviewActiveSelected dependency property. This field is read-only.
TabBorderBrushPreviewPointerOverProperty | Identifies the TabBorderBrushPreviewPointerOver dependency property. This field is read-only.
TabBorderBrushPreviewProperty | Identifies the TabBorderBrushPreview dependency property. This field is read-only.
TabBorderBrushProperty | Identifies the TabBorderBrush dependency property. This field is read-only.
TabCornerRadiusProperty | Identifies the TabCornerRadius dependency property. This field is read-only.
TabEmbeddedButtonStyleProperty | Identifies the TabEmbeddedButtonStyle dependency property. This field is read-only.
TabFarSlantExtentProperty | Identifies the TabFarSlantExtent dependency property. This field is read-only.
TabForegroundActiveSelectedProperty | Identifies the TabForegroundActiveSelected dependency property. This field is read-only.
TabForegroundInactiveSelectedProperty | Identifies the TabForegroundInactiveSelected dependency property. This field is read-only.
TabForegroundPointerOverProperty | Identifies the TabForegroundPointerOver dependency property. This field is read-only.
TabForegroundPreviewActiveSelectedProperty | Identifies the TabForegroundPreviewActiveSelected dependency property. This field is read-only.
TabForegroundPreviewPointerOverProperty | Identifies the TabForegroundPreviewPointerOver dependency property. This field is read-only.
TabForegroundPreviewProperty | Identifies the TabForegroundPreview dependency property. This field is read-only.
TabForegroundProperty | Identifies the TabForeground dependency property. This field is read-only.
TabNearSlantExtentProperty | Identifies the TabNearSlantExtent dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabPaddingProperty | Identifies the TabPadding dependency property. This field is read-only.
TabSpacingProperty | Identifies the TabSpacing dependency property. This field is read-only.
UseDefaultFocusHandlingProperty | Identifies the UseDefaultFocusHandling dependency property. This field is read-only.
Top
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.AreScrollButtonsVisibleProperty Field

AdvancedTabControlAreScrollButtonsVisibleProperty Field

Identifies the AreScrollButtonsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreScrollButtonsVisibleProperty
Public Shared ReadOnly AreScrollButtonsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreScrollButtonsVisible dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.AreTabEmbeddedButtonsAlwaysVisibleProperty Field

AdvancedTabControlAreTabEmbeddedButtonsAlwaysVisibleProperty Field

Identifies the AreTabEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreTabEmbeddedButtonsAlwaysVisibleProperty
Public Shared ReadOnly AreTabEmbeddedButtonsAlwaysVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreTabEmbeddedButtonsAlwaysVisible dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanScrollBackwardProperty Field

AdvancedTabControlCanScrollBackwardProperty Field

Identifies the CanScrollBackward dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanScrollBackwardProperty
Public Shared ReadOnly CanScrollBackwardProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanScrollBackward dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanScrollForwardProperty Field

AdvancedTabControlCanScrollForwardProperty Field

Identifies the CanScrollForward dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanScrollForwardProperty
Public Shared ReadOnly CanScrollForwardProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanScrollForward dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsCloseOnMiddleClickProperty Field

AdvancedTabControlCanTabsCloseOnMiddleClickProperty Field

Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsCloseOnMiddleClickProperty
Public Shared ReadOnly CanTabsCloseOnMiddleClickProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsCloseOnMiddleClick dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsDragProperty Field

AdvancedTabControlCanTabsDragProperty Field

Identifies the CanTabsDrag dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsDragProperty
Public Shared ReadOnly CanTabsDragProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsDrag dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsHighlightOnPointerOverWhenInactiveProperty Field

AdvancedTabControlCanTabsHighlightOnPointerOverWhenInactiveProperty Field

Identifies the CanTabsHighlightOnPointerOverWhenInactive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsHighlightOnPointerOverWhenInactiveProperty
Public Shared ReadOnly CanTabsHighlightOnPointerOverWhenInactiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsHighlightOnPointerOverWhenInactive dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsPinProperty Field

AdvancedTabControlCanTabsPinProperty Field

Identifies the CanTabsPin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsPinProperty
Public Shared ReadOnly CanTabsPinProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsPin dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsPromoteProperty Field

AdvancedTabControlCanTabsPromoteProperty Field

Identifies the CanTabsPromote dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsPromoteProperty
Public Shared ReadOnly CanTabsPromoteProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsPromote dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.CanTabsSelectOnDragOverProperty Field

AdvancedTabControlCanTabsSelectOnDragOverProperty Field

Identifies the CanTabsSelectOnDragOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsSelectOnDragOverProperty
Public Shared ReadOnly CanTabsSelectOnDragOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsSelectOnDragOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.EmbeddedButtonStyleProperty Field

AdvancedTabControlEmbeddedButtonStyleProperty Field

Identifies the EmbeddedButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmbeddedButtonStyleProperty
Public Shared ReadOnly EmbeddedButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmbeddedButtonStyle dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HasNewTabButtonProperty Field

AdvancedTabControlHasNewTabButtonProperty Field

Identifies the HasNewTabButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasNewTabButtonProperty
Public Shared ReadOnly HasNewTabButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasNewTabButton dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HasTabCloseButtonsProperty Field

AdvancedTabControlHasTabCloseButtonsProperty Field

Identifies the HasTabCloseButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabCloseButtonsProperty
Public Shared ReadOnly HasTabCloseButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabCloseButtons dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HasTabImagesProperty Field

AdvancedTabControlHasTabImagesProperty Field

Identifies the HasTabImages dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabImagesProperty
Public Shared ReadOnly HasTabImagesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabImages dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HighlightBrushActiveProperty Field

AdvancedTabControlHighlightBrushActiveProperty Field

Identifies the HighlightBrushActive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightBrushActiveProperty
Public Shared ReadOnly HighlightBrushActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightBrushActive dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HighlightBrushInactiveProperty Field

AdvancedTabControlHighlightBrushInactiveProperty Field

Identifies the HighlightBrushInactive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightBrushInactiveProperty
Public Shared ReadOnly HighlightBrushInactiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightBrushInactive dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.HighlightThicknessProperty Field

AdvancedTabControlHighlightThicknessProperty Field

Identifies the HighlightThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightThicknessProperty
Public Shared ReadOnly HighlightThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightThickness dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsActiveProperty Field

AdvancedTabControlIsActiveProperty Field

Identifies the IsActive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsActiveProperty
Public Shared ReadOnly IsActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsActive dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsLayoutAnimationEnabledProperty Field

AdvancedTabControlIsLayoutAnimationEnabledProperty Field

Identifies the IsLayoutAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLayoutAnimationEnabledProperty
Public Shared ReadOnly IsLayoutAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLayoutAnimationEnabled dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsMenuButtonVisibleProperty Field

AdvancedTabControlIsMenuButtonVisibleProperty Field

Identifies the IsMenuButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMenuButtonVisibleProperty
Public Shared ReadOnly IsMenuButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMenuButtonVisible dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsOverflowedProperty Field

AdvancedTabControlIsOverflowedProperty Field

Identifies the IsOverflowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOverflowedProperty
Public Shared ReadOnly IsOverflowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOverflowed dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsTabContentHorizontalProperty Field

AdvancedTabControlIsTabContentHorizontalProperty Field

Identifies the IsTabContentHorizontal dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabContentHorizontalProperty
Public Shared ReadOnly IsTabContentHorizontalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabContentHorizontal dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsTabKeyboardAccessEnabledProperty Field

AdvancedTabControlIsTabKeyboardAccessEnabledProperty Field

Identifies the IsTabKeyboardAccessEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabKeyboardAccessEnabledProperty
Public Shared ReadOnly IsTabKeyboardAccessEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabKeyboardAccessEnabled dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsTabKeyboardSwitchingEnabledProperty Field

AdvancedTabControlIsTabKeyboardSwitchingEnabledProperty Field

Identifies the IsTabKeyboardSwitchingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabKeyboardSwitchingEnabledProperty
Public Shared ReadOnly IsTabKeyboardSwitchingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabKeyboardSwitchingEnabled dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.IsTabStripVisibleProperty Field

AdvancedTabControlIsTabStripVisibleProperty Field

Identifies the IsTabStripVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabStripVisibleProperty
Public Shared ReadOnly IsTabStripVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabStripVisible dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.MaxTabExtentProperty Field

AdvancedTabControlMaxTabExtentProperty Field

Identifies the MaxTabExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxTabExtentProperty
Public Shared ReadOnly MaxTabExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxTabExtent dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.MenuButtonContentTemplateProperty Field

AdvancedTabControlMenuButtonContentTemplateProperty Field

Identifies the MenuButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MenuButtonContentTemplateProperty
Public Shared ReadOnly MenuButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MenuButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.MinTabExtentProperty Field

AdvancedTabControlMinTabExtentProperty Field

Identifies the MinTabExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinTabExtentProperty
Public Shared ReadOnly MinTabExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinTabExtent dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.NewTabButtonStyleProperty Field

AdvancedTabControlNewTabButtonStyleProperty Field

Identifies the NewTabButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NewTabButtonStyleProperty
Public Shared ReadOnly NewTabButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NewTabButtonStyle dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.OverflowMenuButtonContentTemplateProperty Field

AdvancedTabControlOverflowMenuButtonContentTemplateProperty Field

Identifies the OverflowMenuButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OverflowMenuButtonContentTemplateProperty
Public Shared ReadOnly OverflowMenuButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OverflowMenuButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.RotatedBorderThicknessProperty Field

AdvancedTabControlRotatedBorderThicknessProperty Field

Identifies the RotatedBorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RotatedBorderThicknessProperty
Public Shared ReadOnly RotatedBorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RotatedBorderThickness dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.RotatedHighlightThicknessProperty Field

AdvancedTabControlRotatedHighlightThicknessProperty Field

Identifies the RotatedHighlightThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RotatedHighlightThicknessProperty
Public Shared ReadOnly RotatedHighlightThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RotatedHighlightThickness dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.RotatedPaddingProperty Field

AdvancedTabControlRotatedPaddingProperty Field

Identifies the RotatedPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RotatedPaddingProperty
Public Shared ReadOnly RotatedPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RotatedPadding dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ScrollBackwardButtonContentTemplateProperty Field

AdvancedTabControlScrollBackwardButtonContentTemplateProperty Field

Identifies the ScrollBackwardButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollBackwardButtonContentTemplateProperty
Public Shared ReadOnly ScrollBackwardButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollBackwardButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ScrollForwardButtonContentTemplateProperty Field

AdvancedTabControlScrollForwardButtonContentTemplateProperty Field

Identifies the ScrollForwardButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollForwardButtonContentTemplateProperty
Public Shared ReadOnly ScrollForwardButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollForwardButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.ScrollOffsetProperty Field

AdvancedTabControlScrollOffsetProperty Field

Identifies the ScrollOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollOffsetProperty
Public Shared ReadOnly ScrollOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollOffset dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundActiveSelectedProperty Field

AdvancedTabControlTabBackgroundActiveSelectedProperty Field

Identifies the TabBackgroundActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundActiveSelectedProperty
Public Shared ReadOnly TabBackgroundActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundInactiveSelectedProperty Field

AdvancedTabControlTabBackgroundInactiveSelectedProperty Field

Identifies the TabBackgroundInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundInactiveSelectedProperty
Public Shared ReadOnly TabBackgroundInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundInactiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPointerOverProperty Field

AdvancedTabControlTabBackgroundPointerOverProperty Field

Identifies the TabBackgroundPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundPointerOverProperty
Public Shared ReadOnly TabBackgroundPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewActiveSelectedProperty Field

AdvancedTabControlTabBackgroundPreviewActiveSelectedProperty Field

Identifies the TabBackgroundPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundPreviewActiveSelectedProperty
Public Shared ReadOnly TabBackgroundPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewPointerOverProperty Field

AdvancedTabControlTabBackgroundPreviewPointerOverProperty Field

Identifies the TabBackgroundPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundPreviewPointerOverProperty
Public Shared ReadOnly TabBackgroundPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewProperty Field

AdvancedTabControlTabBackgroundPreviewProperty Field

Identifies the TabBackgroundPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundPreviewProperty
Public Shared ReadOnly TabBackgroundPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundPreview dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundProperty Field

AdvancedTabControlTabBackgroundProperty Field

Identifies the TabBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundProperty
Public Shared ReadOnly TabBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackground dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushActiveSelectedProperty Field

AdvancedTabControlTabBorderBrushActiveSelectedProperty Field

Identifies the TabBorderBrushActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushActiveSelectedProperty
Public Shared ReadOnly TabBorderBrushActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushInactiveSelectedProperty Field

AdvancedTabControlTabBorderBrushInactiveSelectedProperty Field

Identifies the TabBorderBrushInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushInactiveSelectedProperty
Public Shared ReadOnly TabBorderBrushInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushInactiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPointerOverProperty Field

AdvancedTabControlTabBorderBrushPointerOverProperty Field

Identifies the TabBorderBrushPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushPointerOverProperty
Public Shared ReadOnly TabBorderBrushPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewActiveSelectedProperty Field

AdvancedTabControlTabBorderBrushPreviewActiveSelectedProperty Field

Identifies the TabBorderBrushPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushPreviewActiveSelectedProperty
Public Shared ReadOnly TabBorderBrushPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewPointerOverProperty Field

AdvancedTabControlTabBorderBrushPreviewPointerOverProperty Field

Identifies the TabBorderBrushPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushPreviewPointerOverProperty
Public Shared ReadOnly TabBorderBrushPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewProperty Field

AdvancedTabControlTabBorderBrushPreviewProperty Field

Identifies the TabBorderBrushPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushPreviewProperty
Public Shared ReadOnly TabBorderBrushPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushPreview dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushProperty Field

AdvancedTabControlTabBorderBrushProperty Field

Identifies the TabBorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushProperty
Public Shared ReadOnly TabBorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrush dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabCornerRadiusProperty Field

AdvancedTabControlTabCornerRadiusProperty Field

Identifies the TabCornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabCornerRadiusProperty
Public Shared ReadOnly TabCornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabCornerRadius dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabEmbeddedButtonStyleProperty Field

AdvancedTabControlTabEmbeddedButtonStyleProperty Field

Identifies the TabEmbeddedButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabEmbeddedButtonStyleProperty
Public Shared ReadOnly TabEmbeddedButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabEmbeddedButtonStyle dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabFarSlantExtentProperty Field

AdvancedTabControlTabFarSlantExtentProperty Field

Identifies the TabFarSlantExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabFarSlantExtentProperty
Public Shared ReadOnly TabFarSlantExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabFarSlantExtent dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundActiveSelectedProperty Field

AdvancedTabControlTabForegroundActiveSelectedProperty Field

Identifies the TabForegroundActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundActiveSelectedProperty
Public Shared ReadOnly TabForegroundActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundInactiveSelectedProperty Field

AdvancedTabControlTabForegroundInactiveSelectedProperty Field

Identifies the TabForegroundInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundInactiveSelectedProperty
Public Shared ReadOnly TabForegroundInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundInactiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPointerOverProperty Field

AdvancedTabControlTabForegroundPointerOverProperty Field

Identifies the TabForegroundPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundPointerOverProperty
Public Shared ReadOnly TabForegroundPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewActiveSelectedProperty Field

AdvancedTabControlTabForegroundPreviewActiveSelectedProperty Field

Identifies the TabForegroundPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundPreviewActiveSelectedProperty
Public Shared ReadOnly TabForegroundPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewPointerOverProperty Field

AdvancedTabControlTabForegroundPreviewPointerOverProperty Field

Identifies the TabForegroundPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundPreviewPointerOverProperty
Public Shared ReadOnly TabForegroundPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewProperty Field

AdvancedTabControlTabForegroundPreviewProperty Field

Identifies the TabForegroundPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundPreviewProperty
Public Shared ReadOnly TabForegroundPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundPreview dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabForegroundProperty Field

AdvancedTabControlTabForegroundProperty Field

Identifies the TabForeground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundProperty
Public Shared ReadOnly TabForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForeground dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabNearSlantExtentProperty Field

AdvancedTabControlTabNearSlantExtentProperty Field

Identifies the TabNearSlantExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabNearSlantExtentProperty
Public Shared ReadOnly TabNearSlantExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabNearSlantExtent dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabOverflowBehaviorProperty Field

AdvancedTabControlTabOverflowBehaviorProperty Field

Identifies the TabOverflowBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabOverflowBehaviorProperty
Public Shared ReadOnly TabOverflowBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabOverflowBehavior dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabPaddingProperty Field

AdvancedTabControlTabPaddingProperty Field

Identifies the TabPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabPaddingProperty
Public Shared ReadOnly TabPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabPadding dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.TabSpacingProperty Field

AdvancedTabControlTabSpacingProperty Field

Identifies the TabSpacing dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabSpacingProperty
Public Shared ReadOnly TabSpacingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabSpacing dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControl.UseDefaultFocusHandlingProperty Field

AdvancedTabControlUseDefaultFocusHandlingProperty Field

Identifies the UseDefaultFocusHandling dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDefaultFocusHandlingProperty
Public Shared ReadOnly UseDefaultFocusHandlingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDefaultFocusHandling dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs Class

Provides event arguments for customizing a menu that is opening within an AdvancedTabControl.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Windows.Controls.DockingAdvancedTabControlMenuEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTabControlMenuEventArgs : EventArgs
Public Class AdvancedTabControlMenuEventArgs
    Inherits EventArgs

The AdvancedTabControlMenuEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabControlMenuEventArgs | Initializes a new instance of the AdvancedTabControlMenuEventArgs class
Top
Properties
 | Name | Description
Public property | Menu | Gets or sets the ContextMenu that is about to be displayed.
Public property | TabItem | Gets the related AdvancedTabItem, if any.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs Constructor

Initializes a new instance of the AdvancedTabControlMenuEventArgs class

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabControlMenuEventArgs()
Public Sub New
See Also

Reference

AdvancedTabControlMenuEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs Properties

The AdvancedTabControlMenuEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Menu | Gets or sets the ContextMenu that is about to be displayed.
Public property | TabItem | Gets the related AdvancedTabItem, if any.
Top
See Also

Reference

AdvancedTabControlMenuEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs.Menu Property

AdvancedTabControlMenuEventArgsMenu Property

Gets or sets the ContextMenu that is about to be displayed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextMenu Menu { get; set; }
Public Property Menu As ContextMenu
    Get
    Set

Property Value

Type: ContextMenu
The ContextMenu that is about to be displayed.
See Also

Reference

AdvancedTabControlMenuEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs.TabItem Property

AdvancedTabControlMenuEventArgsTabItem Property

Gets the related AdvancedTabItem, if any.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabItem TabItem { get; }
Public ReadOnly Property TabItem As AdvancedTabItem
    Get

Property Value

Type: AdvancedTabItem
The related AdvancedTabItem, if any.
See Also

Reference

AdvancedTabControlMenuEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem Class

Represents a tab item for use in an AdvancedTabControl.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsHeaderedContentControl
System.Windows.ControlsTabItem
ActiproSoftware.Windows.Controls.DockingAdvancedTabItem
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockingWindowContainerTabItem

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTabItem : TabItem
Public Class AdvancedTabItem
    Inherits TabItem

The AdvancedTabItem type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabItem | Initializes an instance of the AdvancedTabItem class.
Top
Properties
 | Name | Description
Public property | AreEmbeddedButtonsAlwaysVisible | Gets or sets whether embedded buttons are always visible, even when the tab is unselected.
Public property | ArrangeHeightAnimated | Gets or sets the arrange height of the tab. This property is for internal use only.
Public property | ArrangeWidthAnimated | Gets or sets the arrange width of the tab. This property is for internal use only.
Public property | ArrangeXAnimated | Gets or sets the arrange x-coordinate of the tab. This property is for internal use only.
Public property | ArrangeYAnimated | Gets or sets the arrange y-coordinate of the tab. This property is for internal use only.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BackgroundActiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is active.
Public property | BackgroundInactiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is inactive.
Public property | BackgroundPointerOver | Gets or sets the control's background Brush to use when the pointer is over it.
Public property | BackgroundPreview | Gets or sets the control's background Brush to use when the tab is a preview tab.
Public property | BackgroundPreviewActiveSelected | Gets or sets the control's background Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | BackgroundPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderBrushActiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is active.
Public property | BorderBrushInactiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is inactive.
Public property | BorderBrushPointerOver | Gets or sets the control's border Brush to use when the pointer is over it.
Public property | BorderBrushPreview | Gets or sets the control's border Brush to use when the tab is a preview tab.
Public property | BorderBrushPreviewActiveSelected | Gets or sets the control's border Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | BorderBrushPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the tab displays an embedded close button.
Public property | CanHighlightOnPointerOverWhenInactive | Gets or sets whether the tab can highlight when the pointer is over it and it is inactive.
Public property | CanPin | Gets or sets whether the tab displays an embedded pin button.
Public property | CanPromote | Gets or sets whether the tab displays an embedded promote from preview layout kind button.
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content.
Public property | CloseCommand | Gets the ICommand that can be used to close the tab.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets the contextual content to display.
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content.
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | FarSlantExtent | Gets or sets the far side slant extent of the tab.
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled.
Public property | FlashMode | Gets or sets the flash mode for the tab.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | ForegroundActiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is active.
Public property | ForegroundInactiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is inactive.
Public property | ForegroundPointerOver | Gets or sets the control's foreground Brush to use when the pointer is over it.
Public property | ForegroundPreview | Gets or sets the control's foreground Brush to use when the tab is a preview tab.
Public property | ForegroundPreviewActiveSelected | Gets or sets the control's foreground Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | ForegroundPreviewPointerOver | Gets or sets the control's foreground Brush to use when the tab is a preview tab and the pointer is over it.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets whether the tab has an embedded close button based on its current state.
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasHeader | Gets a value that indicates whether the header is null. (Inherited from HeaderedContentControl.)
Public property | HasToggleLayoutKindButton | Gets whether the tab has an embedded toggle layout kind button based on its current state.
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | HighlightKind | Gets a TabHighlightKind indicating the kind of highlight to apply to the tab.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets a ImageSource for an image that renders on the tab.
Public property | IsCloseButtonVisible | Gets whether the embedded close button is visible.
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation.
Public property | IsImageVisible | Gets whether the embedded image is visible.
Public property | IsLoadAnimationEnabled | Gets or sets whether animation effects may be applied when the tab is loaded.
Public property | IsReadOnly | Gets or sets whether the tab's contents are read-only.
Public property | IsSelected | Gets or sets a value that indicates whether the TabItem is selected. (Inherited from TabItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsToggleLayoutKindButtonVisible | Gets whether the embedded toggle layout kind button is visible.
Public property | LayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned.
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | NearSlantExtent | Gets or sets the near side slant extent of the tab.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content.
Public property | PromoteButtonContentTemplate | Gets or sets the DataTemplate to use for the promote button content.
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabStripPlacement | Gets the tab strip placement. (Inherited from TabItem.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes.
Public property | ToggleLayoutKindCommand | Gets the ICommand that can be used to toggle the tab's layout kind.
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the tab, removing it from the containing tab control.
Public method | DragMove | Starts a drag/move.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when an AccessKey for a TabControl is called. (Inherited from TabItem.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from TabItem.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from TabItem.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from TabItem.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Overrides FrameworkElementOnContextMenuOpening(ContextMenuEventArgs).)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TabItemOnCreateAutomationPeer.)
Protected method | OnDragEnter | Occurs when a drag operation enters the control. (Overrides UIElementOnDragEnter(DragEventArgs).)
Protected method | OnDragOver | Occurs when a drag operation moves over the control. (Overrides UIElementOnDragOver(DragEventArgs).)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when the left mouse button is pressed. (Overrides TabItemOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnPreviewGotKeyboardFocus | Occurs when the control gains keyboard focus. (Overrides TabItemOnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelected | Occurs when the control is selected. (Overrides TabItemOnSelected(RoutedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnUnselected | Occurs when the control is unselected. (Overrides TabItemOnUnselected(RoutedEventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToggleLayoutKind | Toggles the tab's LayoutKind.
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
AreEmbeddedButtonsAlwaysVisibleProperty | Identifies the AreEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.
ArrangeHeightAnimatedProperty | Identifies the ArrangeHeightAnimated dependency property. This field is read-only.
ArrangeWidthAnimatedProperty | Identifies the ArrangeWidthAnimated dependency property. This field is read-only.
ArrangeXAnimatedProperty | Identifies the ArrangeXAnimated dependency property. This field is read-only.
ArrangeYAnimatedProperty | Identifies the ArrangeYAnimated dependency property. This field is read-only.
BackgroundActiveSelectedProperty | Identifies the BackgroundActiveSelected dependency property. This field is read-only.
BackgroundInactiveSelectedProperty | Identifies the BackgroundInactiveSelected dependency property. This field is read-only.
BackgroundPointerOverProperty | Identifies the BackgroundPointerOver dependency property. This field is read-only.
BackgroundPreviewActiveSelectedProperty | Identifies the BackgroundPreviewActiveSelected dependency property. This field is read-only.
BackgroundPreviewPointerOverProperty | Identifies the BackgroundPreviewPointerOver dependency property. This field is read-only.
BackgroundPreviewProperty | Identifies the BackgroundPreview dependency property. This field is read-only.
BorderBrushActiveSelectedProperty | Identifies the BorderBrushActiveSelected dependency property. This field is read-only.
BorderBrushInactiveSelectedProperty | Identifies the BorderBrushInactiveSelected dependency property. This field is read-only.
BorderBrushPointerOverProperty | Identifies the BorderBrushPointerOver dependency property. This field is read-only.
BorderBrushPreviewActiveSelectedProperty | Identifies the BorderBrushPreviewActiveSelected dependency property. This field is read-only.
BorderBrushPreviewPointerOverProperty | Identifies the BorderBrushPreviewPointerOver dependency property. This field is read-only.
BorderBrushPreviewProperty | Identifies the BorderBrushPreview dependency property. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
CanHighlightOnPointerOverWhenInactiveProperty | Identifies the CanHighlightOnPointerOverWhenInactive dependency property. This field is read-only.
CanPinProperty | Identifies the CanPin dependency property. This field is read-only.
CanPromoteProperty | Identifies the CanPromote dependency property. This field is read-only.
CloseButtonContentTemplateProperty | Identifies the CloseButtonContentTemplate dependency property. This field is read-only.
ContextContentProperty | Identifies the ContextContent dependency property. This field is read-only.
ContextContentTemplateProperty | Identifies the ContextContentTemplate dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
FarSlantExtentProperty | Identifies the FarSlantExtent dependency property. This field is read-only.
FlashColorProperty | Identifies the FlashColor dependency property. This field is read-only.
FlashModeProperty | Identifies the FlashMode dependency property. This field is read-only.
ForegroundActiveSelectedProperty | Identifies the ForegroundActiveSelected dependency property. This field is read-only.
ForegroundInactiveSelectedProperty | Identifies the ForegroundInactiveSelected dependency property. This field is read-only.
ForegroundPointerOverProperty | Identifies the ForegroundPointerOver dependency property. This field is read-only.
ForegroundPreviewActiveSelectedProperty | Identifies the ForegroundPreviewActiveSelected dependency property. This field is read-only.
ForegroundPreviewPointerOverProperty | Identifies the ForegroundPreviewPointerOver dependency property. This field is read-only.
ForegroundPreviewProperty | Identifies the ForegroundPreview dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasToggleLayoutKindButtonProperty | Identifies the HasToggleLayoutKindButton dependency property. This field is read-only.
HighlightKindProperty | Identifies the HighlightKind dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsContentHorizontalProperty | Identifies the IsContentHorizontal dependency property. This field is read-only.
IsImageVisibleProperty | Identifies the IsImageVisible dependency property. This field is read-only.
IsLoadAnimationEnabledProperty | Identifies the IsLoadAnimationEnabled dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsToggleLayoutKindButtonVisibleProperty | Identifies the IsToggleLayoutKindButtonVisible dependency property. This field is read-only.
LayoutKindProperty | Identifies the LayoutKind dependency property. This field is read-only.
NearSlantExtentProperty | Identifies the NearSlantExtent dependency property. This field is read-only.
PinButtonContentTemplateProperty | Identifies the PinButtonContentTemplate dependency property. This field is read-only.
PromoteButtonContentTemplateProperty | Identifies the PromoteButtonContentTemplate dependency property. This field is read-only.
ReadOnlyContextContentTemplateProperty | Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.
TintColorProperty | Identifies the TintColor dependency property. This field is read-only.
UnpinButtonContentTemplateProperty | Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem Constructor

Initializes an instance of the AdvancedTabItem class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabItem()
Public Sub New
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem Properties

The AdvancedTabItem type exposes the following members.

Properties
 | Name | Description
Public property | AreEmbeddedButtonsAlwaysVisible | Gets or sets whether embedded buttons are always visible, even when the tab is unselected.
Public property | ArrangeHeightAnimated | Gets or sets the arrange height of the tab. This property is for internal use only.
Public property | ArrangeWidthAnimated | Gets or sets the arrange width of the tab. This property is for internal use only.
Public property | ArrangeXAnimated | Gets or sets the arrange x-coordinate of the tab. This property is for internal use only.
Public property | ArrangeYAnimated | Gets or sets the arrange y-coordinate of the tab. This property is for internal use only.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BackgroundActiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is active.
Public property | BackgroundInactiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is inactive.
Public property | BackgroundPointerOver | Gets or sets the control's background Brush to use when the pointer is over it.
Public property | BackgroundPreview | Gets or sets the control's background Brush to use when the tab is a preview tab.
Public property | BackgroundPreviewActiveSelected | Gets or sets the control's background Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | BackgroundPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderBrushActiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is active.
Public property | BorderBrushInactiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is inactive.
Public property | BorderBrushPointerOver | Gets or sets the control's border Brush to use when the pointer is over it.
Public property | BorderBrushPreview | Gets or sets the control's border Brush to use when the tab is a preview tab.
Public property | BorderBrushPreviewActiveSelected | Gets or sets the control's border Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | BorderBrushPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the tab displays an embedded close button.
Public property | CanHighlightOnPointerOverWhenInactive | Gets or sets whether the tab can highlight when the pointer is over it and it is inactive.
Public property | CanPin | Gets or sets whether the tab displays an embedded pin button.
Public property | CanPromote | Gets or sets whether the tab displays an embedded promote from preview layout kind button.
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content.
Public property | CloseCommand | Gets the ICommand that can be used to close the tab.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets the contextual content to display.
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content.
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | FarSlantExtent | Gets or sets the far side slant extent of the tab.
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled.
Public property | FlashMode | Gets or sets the flash mode for the tab.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | ForegroundActiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is active.
Public property | ForegroundInactiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is inactive.
Public property | ForegroundPointerOver | Gets or sets the control's foreground Brush to use when the pointer is over it.
Public property | ForegroundPreview | Gets or sets the control's foreground Brush to use when the tab is a preview tab.
Public property | ForegroundPreviewActiveSelected | Gets or sets the control's foreground Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | ForegroundPreviewPointerOver | Gets or sets the control's foreground Brush to use when the tab is a preview tab and the pointer is over it.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets whether the tab has an embedded close button based on its current state.
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasHeader | Gets a value that indicates whether the header is null. (Inherited from HeaderedContentControl.)
Public property | HasToggleLayoutKindButton | Gets whether the tab has an embedded toggle layout kind button based on its current state.
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | HighlightKind | Gets a TabHighlightKind indicating the kind of highlight to apply to the tab.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets a ImageSource for an image that renders on the tab.
Public property | IsCloseButtonVisible | Gets whether the embedded close button is visible.
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation.
Public property | IsImageVisible | Gets whether the embedded image is visible.
Public property | IsLoadAnimationEnabled | Gets or sets whether animation effects may be applied when the tab is loaded.
Public property | IsReadOnly | Gets or sets whether the tab's contents are read-only.
Public property | IsSelected | Gets or sets a value that indicates whether the TabItem is selected. (Inherited from TabItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsToggleLayoutKindButtonVisible | Gets whether the embedded toggle layout kind button is visible.
Public property | LayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned.
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | NearSlantExtent | Gets or sets the near side slant extent of the tab.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content.
Public property | PromoteButtonContentTemplate | Gets or sets the DataTemplate to use for the promote button content.
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabStripPlacement | Gets the tab strip placement. (Inherited from TabItem.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes.
Public property | ToggleLayoutKindCommand | Gets the ICommand that can be used to toggle the tab's layout kind.
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.AreEmbeddedButtonsAlwaysVisible Property

AdvancedTabItemAreEmbeddedButtonsAlwaysVisible Property

Gets or sets whether embedded buttons are always visible, even when the tab is unselected.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreEmbeddedButtonsAlwaysVisible { get; set; }
Public Property AreEmbeddedButtonsAlwaysVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if embedded buttons are always visible, even when the tab is unselected; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ArrangeHeightAnimated Property

AdvancedTabItemArrangeHeightAnimated Property

Gets or sets the arrange height of the tab. This property is for internal use only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ArrangeHeightAnimated { get; set; }
Public Property ArrangeHeightAnimated As Double
    Get
    Set

Property Value

Type: Double
The arrange height of the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ArrangeWidthAnimated Property

AdvancedTabItemArrangeWidthAnimated Property

Gets or sets the arrange width of the tab. This property is for internal use only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ArrangeWidthAnimated { get; set; }
Public Property ArrangeWidthAnimated As Double
    Get
    Set

Property Value

Type: Double
The arrange width of the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ArrangeXAnimated Property

AdvancedTabItemArrangeXAnimated Property

Gets or sets the arrange x-coordinate of the tab. This property is for internal use only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ArrangeXAnimated { get; set; }
Public Property ArrangeXAnimated As Double
    Get
    Set

Property Value

Type: Double
The arrange x-coordinate of the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ArrangeYAnimated Property

AdvancedTabItemArrangeYAnimated Property

Gets or sets the arrange y-coordinate of the tab. This property is for internal use only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ArrangeYAnimated { get; set; }
Public Property ArrangeYAnimated As Double
    Get
    Set

Property Value

Type: Double
The arrange y-coordinate of the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundActiveSelected Property

AdvancedTabItemBackgroundActiveSelected Property

Gets or sets the control's background Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BackgroundActiveSelected { get; set; }
Public Property BackgroundActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundInactiveSelected Property

AdvancedTabItemBackgroundInactiveSelected Property

Gets or sets the control's background Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BackgroundInactiveSelected { get; set; }
Public Property BackgroundInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundPointerOver Property

AdvancedTabItemBackgroundPointerOver Property

Gets or sets the control's background Brush to use when the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BackgroundPointerOver { get; set; }
Public Property BackgroundPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreview Property

AdvancedTabItemBackgroundPreview Property

Gets or sets the control's background Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BackgroundPreview { get; set; }
Public Property BackgroundPreview As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewActiveSelected Property

AdvancedTabItemBackgroundPreviewActiveSelected Property

Gets or sets the control's background Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BackgroundPreviewActiveSelected { get; set; }
Public Property BackgroundPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewPointerOver Property

AdvancedTabItemBackgroundPreviewPointerOver Property

Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BackgroundPreviewPointerOver { get; set; }
Public Property BackgroundPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushActiveSelected Property

AdvancedTabItemBorderBrushActiveSelected Property

Gets or sets the control's border Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrushActiveSelected { get; set; }
Public Property BorderBrushActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushInactiveSelected Property

AdvancedTabItemBorderBrushInactiveSelected Property

Gets or sets the control's border Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrushInactiveSelected { get; set; }
Public Property BorderBrushInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPointerOver Property

AdvancedTabItemBorderBrushPointerOver Property

Gets or sets the control's border Brush to use when the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrushPointerOver { get; set; }
Public Property BorderBrushPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreview Property

AdvancedTabItemBorderBrushPreview Property

Gets or sets the control's border Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrushPreview { get; set; }
Public Property BorderBrushPreview As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewActiveSelected Property

AdvancedTabItemBorderBrushPreviewActiveSelected Property

Gets or sets the control's border Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrushPreviewActiveSelected { get; set; }
Public Property BorderBrushPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewPointerOver Property

AdvancedTabItemBorderBrushPreviewPointerOver Property

Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrushPreviewPointerOver { get; set; }
Public Property BorderBrushPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CanClose Property

AdvancedTabItemCanClose Property

Gets or sets whether the tab displays an embedded close button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanClose { get; set; }
Public Property CanClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab displays an embedded close button; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CanHighlightOnPointerOverWhenInactive Property

AdvancedTabItemCanHighlightOnPointerOverWhenInactive Property

Gets or sets whether the tab can highlight when the pointer is over it and it is inactive.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanHighlightOnPointerOverWhenInactive { get; set; }
Public Property CanHighlightOnPointerOverWhenInactive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab can highlight when the pointer is over it and it is inactive; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CanPin Property

AdvancedTabItemCanPin Property

Gets or sets whether the tab displays an embedded pin button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanPin { get; set; }
Public Property CanPin As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab displays an embedded pin button; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CanPromote Property

AdvancedTabItemCanPromote Property

Gets or sets whether the tab displays an embedded promote from preview layout kind button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanPromote { get; set; }
Public Property CanPromote As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab displays an embedded promote from preview layout kind button; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CloseButtonContentTemplate Property

AdvancedTabItemCloseButtonContentTemplate Property

Gets or sets the DataTemplate to use for the close button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate CloseButtonContentTemplate { get; set; }
Public Property CloseButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the close content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CloseCommand Property

AdvancedTabItemCloseCommand Property

Gets the ICommand that can be used to close the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CloseCommand { get; }
Public ReadOnly Property CloseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to close the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ContextContent Property

AdvancedTabItemContextContent Property

Gets the contextual content to display.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ContextContent { get; }
Public ReadOnly Property ContextContent As Object
    Get

Property Value

Type: Object
The contextual content to display.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ContextContentTemplate Property

AdvancedTabItemContextContentTemplate Property

Gets or sets the DataTemplate to use for displaying contextual content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ContextContentTemplate { get; set; }
Public Property ContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for displaying contextual content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CornerRadius Property

AdvancedTabItemCornerRadius Property

Gets or sets the corner radius of the tab border, relative to a top-facing tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the tab border, relative to a top-facing tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.EmbeddedButtonStyle Property

AdvancedTabItemEmbeddedButtonStyle Property

Gets or sets the Style to use for embedded buttons.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style EmbeddedButtonStyle { get; set; }
Public Property EmbeddedButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for embedded buttons.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.FarSlantExtent Property

AdvancedTabItemFarSlantExtent Property

Gets or sets the far side slant extent of the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double FarSlantExtent { get; set; }
Public Property FarSlantExtent As Double
    Get
    Set

Property Value

Type: Double
The far side slant extent of the tab, or 0.0 for no slant. The default value is 0.0.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.FlashColor Property

AdvancedTabItemFlashColor Property

Gets or sets the flash color to use if flashing is enabled.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color FlashColor { get; set; }
Public Property FlashColor As Color
    Get
    Set

Property Value

Type: Color
The flash color to use if flashing is enabled. The default value is #80FFA000.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.FlashMode Property

AdvancedTabItemFlashMode Property

Gets or sets the flash mode for the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabFlashMode FlashMode { get; set; }
Public Property FlashMode As TabFlashMode
    Get
    Set

Property Value

Type: TabFlashMode
The flash mode for the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundActiveSelected Property

AdvancedTabItemForegroundActiveSelected Property

Gets or sets the control's foreground Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ForegroundActiveSelected { get; set; }
Public Property ForegroundActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundInactiveSelected Property

AdvancedTabItemForegroundInactiveSelected Property

Gets or sets the control's foreground Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ForegroundInactiveSelected { get; set; }
Public Property ForegroundInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundPointerOver Property

AdvancedTabItemForegroundPointerOver Property

Gets or sets the control's foreground Brush to use when the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ForegroundPointerOver { get; set; }
Public Property ForegroundPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreview Property

AdvancedTabItemForegroundPreview Property

Gets or sets the control's foreground Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ForegroundPreview { get; set; }
Public Property ForegroundPreview As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewActiveSelected Property

AdvancedTabItemForegroundPreviewActiveSelected Property

Gets or sets the control's foreground Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ForegroundPreviewActiveSelected { get; set; }
Public Property ForegroundPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewPointerOver Property

AdvancedTabItemForegroundPreviewPointerOver Property

Gets or sets the control's foreground Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ForegroundPreviewPointerOver { get; set; }
Public Property ForegroundPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.HasCloseButton Property

AdvancedTabItemHasCloseButton Property

Gets whether the tab has an embedded close button based on its current state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasCloseButton { get; }
Public ReadOnly Property HasCloseButton As Boolean
    Get

Property Value

Type: Boolean
true if the tab has an embedded close button based on its current state; otherwise, false. The default value is false.
Remarks
When this property is true, space is reserved in the tab for the close button. The actual visibility of the close button depends on the IsCloseButtonVisible property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.HasToggleLayoutKindButton Property

AdvancedTabItemHasToggleLayoutKindButton Property

Gets whether the tab has an embedded toggle layout kind button based on its current state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasToggleLayoutKindButton { get; }
Public ReadOnly Property HasToggleLayoutKindButton As Boolean
    Get

Property Value

Type: Boolean
true if the tab has an embedded toggle layout kind button based on its current state; otherwise, false. The default value is false.
Remarks
When this property is true, space is reserved in the tab for the toggle layout kind button. The actual visibility of the toggle layout kind button depends on the IsToggleLayoutKindButtonVisible property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.HighlightKind Property

AdvancedTabItemHighlightKind Property

Gets a TabHighlightKind indicating the kind of highlight to apply to the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabHighlightKind HighlightKind { get; }
Public ReadOnly Property HighlightKind As TabHighlightKind
    Get

Property Value

Type: TabHighlightKind
A TabHighlightKind indicating the kind of highlight to apply to the tab. The default value is None.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ImageSource Property

AdvancedTabItemImageSource Property

Gets or sets a ImageSource for an image that renders on the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
A ImageSource for an image that renders on the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsCloseButtonVisible Property

AdvancedTabItemIsCloseButtonVisible Property

Gets whether the embedded close button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCloseButtonVisible { get; }
Public ReadOnly Property IsCloseButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the embedded close button is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsContentHorizontal Property

AdvancedTabItemIsContentHorizontal Property

Gets or sets whether the content layout is in a horizontal orientation.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsContentHorizontal { get; set; }
Public Property IsContentHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the content layout is in a horizontal orientation; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsImageVisible Property

AdvancedTabItemIsImageVisible Property

Gets whether the embedded image is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsImageVisible { get; }
Public ReadOnly Property IsImageVisible As Boolean
    Get

Property Value

Type: Boolean
true if the embedded image is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsLoadAnimationEnabled Property

AdvancedTabItemIsLoadAnimationEnabled Property

Gets or sets whether animation effects may be applied when the tab is loaded.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsLoadAnimationEnabled { get; set; }
Public Property IsLoadAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if animation effects may be applied when the tab is loaded; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsReadOnly Property

AdvancedTabItemIsReadOnly Property

Gets or sets whether the tab's contents are read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab's contents are read-only; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsToggleLayoutKindButtonVisible Property

AdvancedTabItemIsToggleLayoutKindButtonVisible Property

Gets whether the embedded toggle layout kind button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsToggleLayoutKindButtonVisible { get; }
Public ReadOnly Property IsToggleLayoutKindButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the embedded toggle layout kind button is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.LayoutKind Property

AdvancedTabItemLayoutKind Property

Gets or sets the TabLayoutKind that indicates how the tab will be positioned.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabLayoutKind LayoutKind { get; set; }
Public Property LayoutKind As TabLayoutKind
    Get
    Set

Property Value

Type: TabLayoutKind
The TabLayoutKind that indicates how the tab will be positioned. The default value is Normal.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.NearSlantExtent Property

AdvancedTabItemNearSlantExtent Property

Gets or sets the near side slant extent of the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double NearSlantExtent { get; set; }
Public Property NearSlantExtent As Double
    Get
    Set

Property Value

Type: Double
The near side slant extent of the tab, or 0.0 for no slant. The default value is 0.0.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.PinButtonContentTemplate Property

AdvancedTabItemPinButtonContentTemplate Property

Gets or sets the DataTemplate to use for the pin button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate PinButtonContentTemplate { get; set; }
Public Property PinButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the pin content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.PromoteButtonContentTemplate Property

AdvancedTabItemPromoteButtonContentTemplate Property

Gets or sets the DataTemplate to use for the promote button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate PromoteButtonContentTemplate { get; set; }
Public Property PromoteButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the promote content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ReadOnlyContextContentTemplate Property

AdvancedTabItemReadOnlyContextContentTemplate Property

Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ReadOnlyContextContentTemplate { get; set; }
Public Property ReadOnlyContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.TintColor Property

AdvancedTabItemTintColor Property

Gets or sets the tint color applied to the Background and BorderBrush brushes.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color TintColor { get; set; }
Public Property TintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color applied to the Background and BorderBrush brushes. The default value is Transparent, which indicates no tinting should be applied.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ToggleLayoutKindCommand Property

AdvancedTabItemToggleLayoutKindCommand Property

Gets the ICommand that can be used to toggle the tab's layout kind.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ToggleLayoutKindCommand { get; }
Public ReadOnly Property ToggleLayoutKindCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to toggle the tab's layout kind.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.UnpinButtonContentTemplate Property

AdvancedTabItemUnpinButtonContentTemplate Property

Gets or sets the DataTemplate to use for the unpin button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate UnpinButtonContentTemplate { get; set; }
Public Property UnpinButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the unpin content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem Methods

The AdvancedTabItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the tab, removing it from the containing tab control.
Public method | DragMove | Starts a drag/move.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when an AccessKey for a TabControl is called. (Inherited from TabItem.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from TabItem.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from TabItem.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from TabItem.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Overrides FrameworkElementOnContextMenuOpening(ContextMenuEventArgs).)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TabItemOnCreateAutomationPeer.)
Protected method | OnDragEnter | Occurs when a drag operation enters the control. (Overrides UIElementOnDragEnter(DragEventArgs).)
Protected method | OnDragOver | Occurs when a drag operation moves over the control. (Overrides UIElementOnDragOver(DragEventArgs).)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when the left mouse button is pressed. (Overrides TabItemOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnPreviewGotKeyboardFocus | Occurs when the control gains keyboard focus. (Overrides TabItemOnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelected | Occurs when the control is selected. (Overrides TabItemOnSelected(RoutedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnUnselected | Occurs when the control is unselected. (Overrides TabItemOnUnselected(RoutedEventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToggleLayoutKind | Toggles the tab's LayoutKind.
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.Close Method

AdvancedTabItemClose Method

Closes the tab, removing it from the containing tab control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.DragMove Method

AdvancedTabItemDragMove Method

Starts a drag/move.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void DragMove(
    InputPointerButtonEventArgs sourceEventArgs
)
Public Sub DragMove (
    sourceEventArgs As InputPointerButtonEventArgs
)

Parameters

sourceEventArgs
Type: ActiproSoftware.Windows.InputInputPointerButtonEventArgs
The source InputPointerButtonEventArgs, which can be used to capture the pointer.
Remarks
The primary button of the pointer in the event arguments must be pressed down when calling this method. The pointer will be captured.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.OnApplyTemplate Method

AdvancedTabItemOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.OnContextMenuOpening Method

AdvancedTabItemOnContextMenuOpening Method

Occurs when a context menu is requested.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnContextMenuOpening(
    ContextMenuEventArgs e
)
Protected Overrides Sub OnContextMenuOpening (
    e As ContextMenuEventArgs
)

Parameters

e
Type: System.Windows.ControlsContextMenuEventArgs
The ContextMenuEventArgs that contains the event data.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.OnCreateAutomationPeer Method

AdvancedTabItemOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.OnDragEnter Method

AdvancedTabItemOnDragEnter Method

Occurs when a drag operation enters the control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragEnter(
    DragEventArgs e
)
Protected Overrides Sub OnDragEnter (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs that contains the event data.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.OnDragOver Method

AdvancedTabItemOnDragOver Method

Occurs when a drag operation moves over the control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragOver(
    DragEventArgs e
)
Protected Overrides Sub OnDragOver (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs that contains the event data.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.OnMouseLeftButtonDown Method

AdvancedTabItemOnMouseLeftButtonDown Method

Occurs when the left mouse button is pressed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.OnPreviewGotKeyboardFocus Method

AdvancedTabItemOnPreviewGotKeyboardFocus Method

Occurs when the control gains keyboard focus.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPreviewGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
Protected Overrides Sub OnPreviewGotKeyboardFocus (
    e As KeyboardFocusChangedEventArgs
)

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
The KeyboardFocusChangedEventArgs that contains the event data.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.OnSelected Method

AdvancedTabItemOnSelected Method

Occurs when the control is selected.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnSelected(
    RoutedEventArgs e
)
Protected Overrides Sub OnSelected (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.OnUnselected Method

AdvancedTabItemOnUnselected Method

Occurs when the control is unselected.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnUnselected(
    RoutedEventArgs e
)
Protected Overrides Sub OnUnselected (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ToggleLayoutKind Method

AdvancedTabItemToggleLayoutKind Method

Toggles the tab's LayoutKind.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ToggleLayoutKind()
Public Sub ToggleLayoutKind
Remarks
Normal tabs will switch to Pinned layout. All other layout kinds switch back to Normal.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem Events

The AdvancedTabItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem Fields

The AdvancedTabItem type exposes the following members.

Fields
Name | Description
AreEmbeddedButtonsAlwaysVisibleProperty | Identifies the AreEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.
ArrangeHeightAnimatedProperty | Identifies the ArrangeHeightAnimated dependency property. This field is read-only.
ArrangeWidthAnimatedProperty | Identifies the ArrangeWidthAnimated dependency property. This field is read-only.
ArrangeXAnimatedProperty | Identifies the ArrangeXAnimated dependency property. This field is read-only.
ArrangeYAnimatedProperty | Identifies the ArrangeYAnimated dependency property. This field is read-only.
BackgroundActiveSelectedProperty | Identifies the BackgroundActiveSelected dependency property. This field is read-only.
BackgroundInactiveSelectedProperty | Identifies the BackgroundInactiveSelected dependency property. This field is read-only.
BackgroundPointerOverProperty | Identifies the BackgroundPointerOver dependency property. This field is read-only.
BackgroundPreviewActiveSelectedProperty | Identifies the BackgroundPreviewActiveSelected dependency property. This field is read-only.
BackgroundPreviewPointerOverProperty | Identifies the BackgroundPreviewPointerOver dependency property. This field is read-only.
BackgroundPreviewProperty | Identifies the BackgroundPreview dependency property. This field is read-only.
BorderBrushActiveSelectedProperty | Identifies the BorderBrushActiveSelected dependency property. This field is read-only.
BorderBrushInactiveSelectedProperty | Identifies the BorderBrushInactiveSelected dependency property. This field is read-only.
BorderBrushPointerOverProperty | Identifies the BorderBrushPointerOver dependency property. This field is read-only.
BorderBrushPreviewActiveSelectedProperty | Identifies the BorderBrushPreviewActiveSelected dependency property. This field is read-only.
BorderBrushPreviewPointerOverProperty | Identifies the BorderBrushPreviewPointerOver dependency property. This field is read-only.
BorderBrushPreviewProperty | Identifies the BorderBrushPreview dependency property. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
CanHighlightOnPointerOverWhenInactiveProperty | Identifies the CanHighlightOnPointerOverWhenInactive dependency property. This field is read-only.
CanPinProperty | Identifies the CanPin dependency property. This field is read-only.
CanPromoteProperty | Identifies the CanPromote dependency property. This field is read-only.
CloseButtonContentTemplateProperty | Identifies the CloseButtonContentTemplate dependency property. This field is read-only.
ContextContentProperty | Identifies the ContextContent dependency property. This field is read-only.
ContextContentTemplateProperty | Identifies the ContextContentTemplate dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
FarSlantExtentProperty | Identifies the FarSlantExtent dependency property. This field is read-only.
FlashColorProperty | Identifies the FlashColor dependency property. This field is read-only.
FlashModeProperty | Identifies the FlashMode dependency property. This field is read-only.
ForegroundActiveSelectedProperty | Identifies the ForegroundActiveSelected dependency property. This field is read-only.
ForegroundInactiveSelectedProperty | Identifies the ForegroundInactiveSelected dependency property. This field is read-only.
ForegroundPointerOverProperty | Identifies the ForegroundPointerOver dependency property. This field is read-only.
ForegroundPreviewActiveSelectedProperty | Identifies the ForegroundPreviewActiveSelected dependency property. This field is read-only.
ForegroundPreviewPointerOverProperty | Identifies the ForegroundPreviewPointerOver dependency property. This field is read-only.
ForegroundPreviewProperty | Identifies the ForegroundPreview dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasToggleLayoutKindButtonProperty | Identifies the HasToggleLayoutKindButton dependency property. This field is read-only.
HighlightKindProperty | Identifies the HighlightKind dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsContentHorizontalProperty | Identifies the IsContentHorizontal dependency property. This field is read-only.
IsImageVisibleProperty | Identifies the IsImageVisible dependency property. This field is read-only.
IsLoadAnimationEnabledProperty | Identifies the IsLoadAnimationEnabled dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsToggleLayoutKindButtonVisibleProperty | Identifies the IsToggleLayoutKindButtonVisible dependency property. This field is read-only.
LayoutKindProperty | Identifies the LayoutKind dependency property. This field is read-only.
NearSlantExtentProperty | Identifies the NearSlantExtent dependency property. This field is read-only.
PinButtonContentTemplateProperty | Identifies the PinButtonContentTemplate dependency property. This field is read-only.
PromoteButtonContentTemplateProperty | Identifies the PromoteButtonContentTemplate dependency property. This field is read-only.
ReadOnlyContextContentTemplateProperty | Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.
TintColorProperty | Identifies the TintColor dependency property. This field is read-only.
UnpinButtonContentTemplateProperty | Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.
Top
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.AreEmbeddedButtonsAlwaysVisibleProperty Field

AdvancedTabItemAreEmbeddedButtonsAlwaysVisibleProperty Field

Identifies the AreEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreEmbeddedButtonsAlwaysVisibleProperty
Public Shared ReadOnly AreEmbeddedButtonsAlwaysVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreEmbeddedButtonsAlwaysVisible dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ArrangeHeightAnimatedProperty Field

AdvancedTabItemArrangeHeightAnimatedProperty Field

Identifies the ArrangeHeightAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArrangeHeightAnimatedProperty
Public Shared ReadOnly ArrangeHeightAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArrangeHeightAnimated dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ArrangeWidthAnimatedProperty Field

AdvancedTabItemArrangeWidthAnimatedProperty Field

Identifies the ArrangeWidthAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArrangeWidthAnimatedProperty
Public Shared ReadOnly ArrangeWidthAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArrangeWidthAnimated dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ArrangeXAnimatedProperty Field

AdvancedTabItemArrangeXAnimatedProperty Field

Identifies the ArrangeXAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArrangeXAnimatedProperty
Public Shared ReadOnly ArrangeXAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArrangeXAnimated dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ArrangeYAnimatedProperty Field

AdvancedTabItemArrangeYAnimatedProperty Field

Identifies the ArrangeYAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArrangeYAnimatedProperty
Public Shared ReadOnly ArrangeYAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArrangeYAnimated dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundActiveSelectedProperty Field

AdvancedTabItemBackgroundActiveSelectedProperty Field

Identifies the BackgroundActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundActiveSelectedProperty
Public Shared ReadOnly BackgroundActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundInactiveSelectedProperty Field

AdvancedTabItemBackgroundInactiveSelectedProperty Field

Identifies the BackgroundInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundInactiveSelectedProperty
Public Shared ReadOnly BackgroundInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundInactiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundPointerOverProperty Field

AdvancedTabItemBackgroundPointerOverProperty Field

Identifies the BackgroundPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundPointerOverProperty
Public Shared ReadOnly BackgroundPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewActiveSelectedProperty Field

AdvancedTabItemBackgroundPreviewActiveSelectedProperty Field

Identifies the BackgroundPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundPreviewActiveSelectedProperty
Public Shared ReadOnly BackgroundPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewPointerOverProperty Field

AdvancedTabItemBackgroundPreviewPointerOverProperty Field

Identifies the BackgroundPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundPreviewPointerOverProperty
Public Shared ReadOnly BackgroundPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewProperty Field

AdvancedTabItemBackgroundPreviewProperty Field

Identifies the BackgroundPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundPreviewProperty
Public Shared ReadOnly BackgroundPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundPreview dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushActiveSelectedProperty Field

AdvancedTabItemBorderBrushActiveSelectedProperty Field

Identifies the BorderBrushActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushActiveSelectedProperty
Public Shared ReadOnly BorderBrushActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushInactiveSelectedProperty Field

AdvancedTabItemBorderBrushInactiveSelectedProperty Field

Identifies the BorderBrushInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushInactiveSelectedProperty
Public Shared ReadOnly BorderBrushInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushInactiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPointerOverProperty Field

AdvancedTabItemBorderBrushPointerOverProperty Field

Identifies the BorderBrushPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushPointerOverProperty
Public Shared ReadOnly BorderBrushPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewActiveSelectedProperty Field

AdvancedTabItemBorderBrushPreviewActiveSelectedProperty Field

Identifies the BorderBrushPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushPreviewActiveSelectedProperty
Public Shared ReadOnly BorderBrushPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewPointerOverProperty Field

AdvancedTabItemBorderBrushPreviewPointerOverProperty Field

Identifies the BorderBrushPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushPreviewPointerOverProperty
Public Shared ReadOnly BorderBrushPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewProperty Field

AdvancedTabItemBorderBrushPreviewProperty Field

Identifies the BorderBrushPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushPreviewProperty
Public Shared ReadOnly BorderBrushPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushPreview dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CanCloseProperty Field

AdvancedTabItemCanCloseProperty Field

Identifies the CanClose dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCloseProperty
Public Shared ReadOnly CanCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanClose dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CanHighlightOnPointerOverWhenInactiveProperty Field

AdvancedTabItemCanHighlightOnPointerOverWhenInactiveProperty Field

Identifies the CanHighlightOnPointerOverWhenInactive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanHighlightOnPointerOverWhenInactiveProperty
Public Shared ReadOnly CanHighlightOnPointerOverWhenInactiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanHighlightOnPointerOverWhenInactive dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CanPinProperty Field

AdvancedTabItemCanPinProperty Field

Identifies the CanPin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanPinProperty
Public Shared ReadOnly CanPinProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanPin dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CanPromoteProperty Field

AdvancedTabItemCanPromoteProperty Field

Identifies the CanPromote dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanPromoteProperty
Public Shared ReadOnly CanPromoteProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanPromote dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CloseButtonContentTemplateProperty Field

AdvancedTabItemCloseButtonContentTemplateProperty Field

Identifies the CloseButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CloseButtonContentTemplateProperty
Public Shared ReadOnly CloseButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CloseButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ContextContentProperty Field

AdvancedTabItemContextContentProperty Field

Identifies the ContextContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentProperty
Public Shared ReadOnly ContextContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContent dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ContextContentTemplateProperty Field

AdvancedTabItemContextContentTemplateProperty Field

Identifies the ContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentTemplateProperty
Public Shared ReadOnly ContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.CornerRadiusProperty Field

AdvancedTabItemCornerRadiusProperty Field

Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.EmbeddedButtonStyleProperty Field

AdvancedTabItemEmbeddedButtonStyleProperty Field

Identifies the EmbeddedButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmbeddedButtonStyleProperty
Public Shared ReadOnly EmbeddedButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmbeddedButtonStyle dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.FarSlantExtentProperty Field

AdvancedTabItemFarSlantExtentProperty Field

Identifies the FarSlantExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FarSlantExtentProperty
Public Shared ReadOnly FarSlantExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FarSlantExtent dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.FlashColorProperty Field

AdvancedTabItemFlashColorProperty Field

Identifies the FlashColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FlashColorProperty
Public Shared ReadOnly FlashColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FlashColor dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.FlashModeProperty Field

AdvancedTabItemFlashModeProperty Field

Identifies the FlashMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FlashModeProperty
Public Shared ReadOnly FlashModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FlashMode dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundActiveSelectedProperty Field

AdvancedTabItemForegroundActiveSelectedProperty Field

Identifies the ForegroundActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundActiveSelectedProperty
Public Shared ReadOnly ForegroundActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundInactiveSelectedProperty Field

AdvancedTabItemForegroundInactiveSelectedProperty Field

Identifies the ForegroundInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundInactiveSelectedProperty
Public Shared ReadOnly ForegroundInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundInactiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundPointerOverProperty Field

AdvancedTabItemForegroundPointerOverProperty Field

Identifies the ForegroundPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundPointerOverProperty
Public Shared ReadOnly ForegroundPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewActiveSelectedProperty Field

AdvancedTabItemForegroundPreviewActiveSelectedProperty Field

Identifies the ForegroundPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundPreviewActiveSelectedProperty
Public Shared ReadOnly ForegroundPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewPointerOverProperty Field

AdvancedTabItemForegroundPreviewPointerOverProperty Field

Identifies the ForegroundPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundPreviewPointerOverProperty
Public Shared ReadOnly ForegroundPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewProperty Field

AdvancedTabItemForegroundPreviewProperty Field

Identifies the ForegroundPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundPreviewProperty
Public Shared ReadOnly ForegroundPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundPreview dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.HasCloseButtonProperty Field

AdvancedTabItemHasCloseButtonProperty Field

Identifies the HasCloseButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasCloseButtonProperty
Public Shared ReadOnly HasCloseButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasCloseButton dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.HasToggleLayoutKindButtonProperty Field

AdvancedTabItemHasToggleLayoutKindButtonProperty Field

Identifies the HasToggleLayoutKindButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasToggleLayoutKindButtonProperty
Public Shared ReadOnly HasToggleLayoutKindButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasToggleLayoutKindButton dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.HighlightKindProperty Field

AdvancedTabItemHighlightKindProperty Field

Identifies the HighlightKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightKindProperty
Public Shared ReadOnly HighlightKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightKind dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ImageSourceProperty Field

AdvancedTabItemImageSourceProperty Field

Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsCloseButtonVisibleProperty Field

AdvancedTabItemIsCloseButtonVisibleProperty Field

Identifies the IsCloseButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCloseButtonVisibleProperty
Public Shared ReadOnly IsCloseButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCloseButtonVisible dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsContentHorizontalProperty Field

AdvancedTabItemIsContentHorizontalProperty Field

Identifies the IsContentHorizontal dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsContentHorizontalProperty
Public Shared ReadOnly IsContentHorizontalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsContentHorizontal dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsImageVisibleProperty Field

AdvancedTabItemIsImageVisibleProperty Field

Identifies the IsImageVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsImageVisibleProperty
Public Shared ReadOnly IsImageVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsImageVisible dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsLoadAnimationEnabledProperty Field

AdvancedTabItemIsLoadAnimationEnabledProperty Field

Identifies the IsLoadAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLoadAnimationEnabledProperty
Public Shared ReadOnly IsLoadAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLoadAnimationEnabled dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsReadOnlyProperty Field

AdvancedTabItemIsReadOnlyProperty Field

Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.IsToggleLayoutKindButtonVisibleProperty Field

AdvancedTabItemIsToggleLayoutKindButtonVisibleProperty Field

Identifies the IsToggleLayoutKindButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsToggleLayoutKindButtonVisibleProperty
Public Shared ReadOnly IsToggleLayoutKindButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsToggleLayoutKindButtonVisible dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.LayoutKindProperty Field

AdvancedTabItemLayoutKindProperty Field

Identifies the LayoutKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LayoutKindProperty
Public Shared ReadOnly LayoutKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LayoutKind dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.NearSlantExtentProperty Field

AdvancedTabItemNearSlantExtentProperty Field

Identifies the NearSlantExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NearSlantExtentProperty
Public Shared ReadOnly NearSlantExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NearSlantExtent dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.PinButtonContentTemplateProperty Field

AdvancedTabItemPinButtonContentTemplateProperty Field

Identifies the PinButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PinButtonContentTemplateProperty
Public Shared ReadOnly PinButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PinButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.PromoteButtonContentTemplateProperty Field

AdvancedTabItemPromoteButtonContentTemplateProperty Field

Identifies the PromoteButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PromoteButtonContentTemplateProperty
Public Shared ReadOnly PromoteButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PromoteButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.ReadOnlyContextContentTemplateProperty Field

AdvancedTabItemReadOnlyContextContentTemplateProperty Field

Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReadOnlyContextContentTemplateProperty
Public Shared ReadOnly ReadOnlyContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReadOnlyContextContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.TintColorProperty Field

AdvancedTabItemTintColorProperty Field

Identifies the TintColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TintColorProperty
Public Shared ReadOnly TintColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TintColor dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItem.UnpinButtonContentTemplateProperty Field

AdvancedTabItemUnpinButtonContentTemplateProperty Field

Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UnpinButtonContentTemplateProperty
Public Shared ReadOnly UnpinButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UnpinButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItemEventArgs Class

Provides event arguments for AdvancedTabItem-related drag events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.DockingAdvancedTabItemEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTabItemEventArgs : CancelRoutedEventArgs
Public Class AdvancedTabItemEventArgs
    Inherits CancelRoutedEventArgs

The AdvancedTabItemEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabItemEventArgs | Initializes a new instance of the AdvancedTabItemEventArgs class
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | TabItem | Gets or sets the AdvancedTabItem that is the focus of this event.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItemEventArgs Constructor

Initializes a new instance of the AdvancedTabItemEventArgs class

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabItemEventArgs()
Public Sub New
See Also

Reference

AdvancedTabItemEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItemEventArgs Properties

The AdvancedTabItemEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | TabItem | Gets or sets the AdvancedTabItem that is the focus of this event.
Top
See Also

Reference

AdvancedTabItemEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


AdvancedTabItemEventArgs.TabItem Property

AdvancedTabItemEventArgsTabItem Property

Gets or sets the AdvancedTabItem that is the focus of this event.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabItem TabItem { get; set; }
Public Property TabItem As AdvancedTabItem
    Get
    Set

Property Value

Type: AdvancedTabItem
The AdvancedTabItem that is the focus of this event.
See Also

Reference

AdvancedTabItemEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


ContextContentAlignment Enumeration

Indicates the alignment around the primary content (e.g. title) that the contextual content appears.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ContextContentAlignment
Public Enumeration ContextContentAlignment
Members
Member name | Value | Description
Near | 0 | The context content will appear on the near side (left side of titles in title bars).
Far | 1 | The context content will appear on the far side (right side of titles in title bars, near other buttons).
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockGuideKinds Enumeration

Specifies multiple dock guide kinds.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DockGuideKinds
Public Enumeration DockGuideKinds
Members
Member name | Value | Description
None | 0 | No dock guides.
OuterLeft | 1 | The outer left dock guide.
OuterTop | 2 | The outer top dock guide.
OuterRight | 4 | The outer right dock guide.
OuterBottom | 8 | The outer bottom dock guide.
Outer | 15 | All outer dock guides.
InnerLeft | 16 | The inner left dock guide.
InnerTop | 32 | The inner top dock guide.
InnerRight | 64 | The inner right dock guide.
InnerBottom | 128 | The inner bottom dock guide.
Inner | 240 | All inner dock guides.
Center | 256 | The center dock guide.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockHost Class

Represents a root host that can contain a docking window hierarchy.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.DockingDockHost

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockHost : Control, IDockTarget
Public Class DockHost
    Inherits Control
    Implements IDockTarget

The DockHost type exposes the following members.

Constructors
 | Name | Description
Public method | DockHost | Initializes an instance of the DockHost class.
Top
Properties
 | Name | Description
Public property | AutoHideBottomContainers | Gets the collection of ToolWindowContainer items that appear in the bottom auto-hide tabstrip.
Public property | AutoHideLeftContainers | Gets the collection of ToolWindowContainer items that appear in the left auto-hide tabstrip.
Public property | AutoHidePopupToolWindow | Gets the ToolWindow that is currently open in the auto-hide popup, if any.
Public property | AutoHideRightContainers | Gets the collection of ToolWindowContainer items that appear in the right auto-hide tabstrip.
Public property | AutoHideTabItemTemplate | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
Public property | AutoHideTabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.
Public property | AutoHideTopContainers | Gets the collection of ToolWindowContainer items that appear in the top auto-hide tabstrip.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Child | Gets or sets the FrameworkElement that is the child content of this container.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite that is managing this container.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets the icon ImageSource for a window that contains this dock host.
Public property | IsAutoHidePopupOpen | Gets whether the auto-hide popup is currently open.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MdiHost | Gets the TabbedMdiHost or StandardMdiHost that is currently in use, if any.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SplitterSize | Gets or sets the size of splitters.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets the title text for a window that contains this dock host.
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Workspace | Gets the Workspace, if any, that is in the dock host.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | CloseAutoHidePopup | Closes the auto-hide popup.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Occurs when a key is pressed. (Overrides UIElementOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
AutoHidePopupToolWindowProperty | Identifies the AutoHidePopupToolWindow dependency property. This field is read-only.
AutoHideTabItemTemplateProperty | Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.
AutoHideTabItemTemplateSelectorProperty | Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
IconProperty | Identifies the Icon dependency property. This field is read-only.
SplitterSizeProperty | Identifies the SplitterSize dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
UniqueIdProperty | Identifies the UniqueId dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockHost Constructor

Initializes an instance of the DockHost class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost()
Public Sub New
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost Properties

The DockHost type exposes the following members.

Properties
 | Name | Description
Public property | AutoHideBottomContainers | Gets the collection of ToolWindowContainer items that appear in the bottom auto-hide tabstrip.
Public property | AutoHideLeftContainers | Gets the collection of ToolWindowContainer items that appear in the left auto-hide tabstrip.
Public property | AutoHidePopupToolWindow | Gets the ToolWindow that is currently open in the auto-hide popup, if any.
Public property | AutoHideRightContainers | Gets the collection of ToolWindowContainer items that appear in the right auto-hide tabstrip.
Public property | AutoHideTabItemTemplate | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
Public property | AutoHideTabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.
Public property | AutoHideTopContainers | Gets the collection of ToolWindowContainer items that appear in the top auto-hide tabstrip.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Child | Gets or sets the FrameworkElement that is the child content of this container.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite that is managing this container.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets the icon ImageSource for a window that contains this dock host.
Public property | IsAutoHidePopupOpen | Gets whether the auto-hide popup is currently open.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MdiHost | Gets the TabbedMdiHost or StandardMdiHost that is currently in use, if any.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SplitterSize | Gets or sets the size of splitters.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets the title text for a window that contains this dock host.
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Workspace | Gets the Workspace, if any, that is in the dock host.
Top
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHideBottomContainers Property

DockHostAutoHideBottomContainers Property

Gets the collection of ToolWindowContainer items that appear in the bottom auto-hide tabstrip.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideBottomContainers { get; }
Public ReadOnly Property AutoHideBottomContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the bottom auto-hide tabstrip.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHideLeftContainers Property

DockHostAutoHideLeftContainers Property

Gets the collection of ToolWindowContainer items that appear in the left auto-hide tabstrip.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideLeftContainers { get; }
Public ReadOnly Property AutoHideLeftContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the left auto-hide tabstrip.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHidePopupToolWindow Property

DockHostAutoHidePopupToolWindow Property

Gets the ToolWindow that is currently open in the auto-hide popup, if any.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindow AutoHidePopupToolWindow { get; }
Public ReadOnly Property AutoHidePopupToolWindow As ToolWindow
    Get

Property Value

Type: ToolWindow
The ToolWindow that is currently open in the auto-hide popup, if any.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHideRightContainers Property

DockHostAutoHideRightContainers Property

Gets the collection of ToolWindowContainer items that appear in the right auto-hide tabstrip.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideRightContainers { get; }
Public ReadOnly Property AutoHideRightContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the right auto-hide tabstrip.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHideTabItemTemplate Property

DockHostAutoHideTabItemTemplate Property

Gets or sets the DataTemplate to use for rendering the auto-hide tab items.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate AutoHideTabItemTemplate { get; set; }
Public Property AutoHideTabItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for rendering the auto-hide tab items.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHideTabItemTemplateSelector Property

DockHostAutoHideTabItemTemplateSelector Property

Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector AutoHideTabItemTemplateSelector { get; set; }
Public Property AutoHideTabItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for rendering the auto-hide tab items.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHideTopContainers Property

DockHostAutoHideTopContainers Property

Gets the collection of ToolWindowContainer items that appear in the top auto-hide tabstrip.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideTopContainers { get; }
Public ReadOnly Property AutoHideTopContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the top auto-hide tabstrip.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.Child Property

DockHostChild Property

Gets or sets the FrameworkElement that is the child content of this container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FrameworkElement Child { get; set; }
Public Property Child As FrameworkElement
    Get
    Set

Property Value

Type: FrameworkElement
The FrameworkElement that is the child content of this container.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.DockSite Property

DockHostDockSite Property

Gets the DockSite that is managing this container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this container.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.Icon Property

DockHostIcon Property

Gets the icon ImageSource for a window that contains this dock host.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource Icon { get; }
Public ReadOnly Property Icon As ImageSource
    Get

Property Value

Type: ImageSource
The icon ImageSource for a window that contains this dock host.
Remarks
This property value is based on the FloatingWindowIcon property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.IsAutoHidePopupOpen Property

DockHostIsAutoHidePopupOpen Property

Gets whether the auto-hide popup is currently open.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAutoHidePopupOpen { get; }
Public ReadOnly Property IsAutoHidePopupOpen As Boolean
    Get

Property Value

Type: Boolean
true if the auto-hide popup is currently open; otherwise, false.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.LogicalChildren Property

DockHostLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.MdiHost Property

DockHostMdiHost Property

Gets the TabbedMdiHost or StandardMdiHost that is currently in use, if any.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MdiHostBase MdiHost { get; }
Public ReadOnly Property MdiHost As MdiHostBase
    Get

Property Value

Type: MdiHostBase
The TabbedMdiHost or StandardMdiHost that is currently in use, if any.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.SplitterSize Property

DockHostSplitterSize Property

Gets or sets the size of splitters.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SplitterSize { get; set; }
Public Property SplitterSize As Double
    Get
    Set

Property Value

Type: Double
The size of splitters. The default value is 5.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.Title Property

DockHostTitle Property

Gets the title text for a window that contains this dock host.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get

Property Value

Type: String
The title text for a window that contains this dock host.
Remarks
This property value is based on the FloatingWindowTitle property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.UniqueId Property

DockHostUniqueId Property

Gets the Guid that uniquely identifies the control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; }
Public ReadOnly Property UniqueId As Guid
    Get

Property Value

Type: Guid
The Guid that uniquely identifies the control.
Remarks
A new Guid value is assigned to this property every time the application is run.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.Workspace Property

DockHostWorkspace Property

Gets the Workspace, if any, that is in the dock host.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Workspace Workspace { get; }
Public ReadOnly Property Workspace As Workspace
    Get

Property Value

Type: Workspace
The Workspace, if any, that is in the dock host.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost Methods

The DockHost type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | CloseAutoHidePopup | Closes the auto-hide popup.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Occurs when a key is pressed. (Overrides UIElementOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.ArrangeOverride Method

DockHostArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.CloseAutoHidePopup Method

DockHostCloseAutoHidePopup Method

Closes the auto-hide popup.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CloseAutoHidePopup(
    bool closeImmediately,
    bool blurFocus
)
Public Sub CloseAutoHidePopup (
    closeImmediately As Boolean,
    blurFocus As Boolean
)

Parameters

closeImmediately
Type: SystemBoolean
Whether to close the popup immediately.
blurFocus
Type: SystemBoolean
Whether to blur focus.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.OnApplyTemplate Method

DockHostOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.OnCreateAutomationPeer Method

DockHostOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.OnIsKeyboardFocusWithinChanged Method

DockHostOnIsKeyboardFocusWithinChanged Method

Reports that the IsKeyboardFocusWithin property changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
A DependencyPropertyChangedEventArgs that contains the event data.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.OnKeyDown Method

DockHostOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.OnPreviewKeyDown Method

DockHostOnPreviewKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPreviewKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnPreviewKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.ToString Method

DockHostToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost Events

The DockHost type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost Fields

The DockHost type exposes the following members.

Fields
Name | Description
AutoHidePopupToolWindowProperty | Identifies the AutoHidePopupToolWindow dependency property. This field is read-only.
AutoHideTabItemTemplateProperty | Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.
AutoHideTabItemTemplateSelectorProperty | Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
IconProperty | Identifies the Icon dependency property. This field is read-only.
SplitterSizeProperty | Identifies the SplitterSize dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
UniqueIdProperty | Identifies the UniqueId dependency property. This field is read-only.
Top
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHidePopupToolWindowProperty Field

DockHostAutoHidePopupToolWindowProperty Field

Identifies the AutoHidePopupToolWindow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupToolWindowProperty
Public Shared ReadOnly AutoHidePopupToolWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupToolWindow dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHideTabItemTemplateProperty Field

DockHostAutoHideTabItemTemplateProperty Field

Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabItemTemplateProperty
Public Shared ReadOnly AutoHideTabItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabItemTemplate dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.AutoHideTabItemTemplateSelectorProperty Field

DockHostAutoHideTabItemTemplateSelectorProperty Field

Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabItemTemplateSelectorProperty
Public Shared ReadOnly AutoHideTabItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabItemTemplateSelector dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.ChildProperty Field

DockHostChildProperty Field

Identifies the Child dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildProperty
Public Shared ReadOnly ChildProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Child dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.IconProperty Field

DockHostIconProperty Field

Identifies the Icon dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IconProperty
Public Shared ReadOnly IconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Icon dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.SplitterSizeProperty Field

DockHostSplitterSizeProperty Field

Identifies the SplitterSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SplitterSizeProperty
Public Shared ReadOnly SplitterSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SplitterSize dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.TitleProperty Field

DockHostTitleProperty Field

Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockHost.UniqueIdProperty Field

DockHostUniqueIdProperty Field

Identifies the UniqueId dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UniqueIdProperty
Public Shared ReadOnly UniqueIdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UniqueId dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingMenuEventArgs Class

Provides event arguments for customizing a docking-related context or drop-down menu.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
ActiproSoftware.Windows.Controls.DockingDockingMenuEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingMenuEventArgs : DockingWindowEventArgs
Public Class DockingMenuEventArgs
    Inherits DockingWindowEventArgs

The DockingMenuEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingMenuEventArgs | Initializes a new instance of the DockingMenuEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Kind | Gets a DockingMenuKind indicating the menu kind.
Public property | Menu | Gets or sets the ContextMenu that is about to be displayed.
Public property | Window | Gets or sets the DockingWindow that is the focus of this event. (Inherited from DockingWindowEventArgs.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingMenuEventArgs Constructor

Initializes a new instance of the DockingMenuEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingMenuEventArgs(
    DockingMenuKind kind
)
Public Sub New (
    kind As DockingMenuKind
)

Parameters

kind
Type: ActiproSoftware.Windows.Controls.DockingDockingMenuKind
A DockingMenuKind indicating the menu kind.
See Also

Reference

DockingMenuEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingMenuEventArgs Properties

The DockingMenuEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Kind | Gets a DockingMenuKind indicating the menu kind.
Public property | Menu | Gets or sets the ContextMenu that is about to be displayed.
Public property | Window | Gets or sets the DockingWindow that is the focus of this event. (Inherited from DockingWindowEventArgs.)
Top
See Also

Reference

DockingMenuEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingMenuEventArgs.Kind Property

DockingMenuEventArgsKind Property

Gets a DockingMenuKind indicating the menu kind.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingMenuKind Kind { get; }
Public ReadOnly Property Kind As DockingMenuKind
    Get

Property Value

Type: DockingMenuKind
A DockingMenuKind indicating the menu kind.
See Also

Reference

DockingMenuEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingMenuEventArgs.Menu Property

DockingMenuEventArgsMenu Property

Gets or sets the ContextMenu that is about to be displayed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextMenu Menu { get; set; }
Public Property Menu As ContextMenu
    Get
    Set

Property Value

Type: ContextMenu
The ContextMenu that is about to be displayed.
See Also

Reference

DockingMenuEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingMenuKind Enumeration

Specifies the kind of context or drop-down menu used by the docking elements.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DockingMenuKind
Public Enumeration DockingMenuKind
Members
Member name | Value | Description
Unknown | 0 | The menu kind is not known.
AutoHideContextMenu | 1 | Context menu for an auto-hide well. If the menu is displayed for a particular tab, the related docking window is passed in the event arguments.
StandardMdiWindowControlContextMenu | 2 | Context menu for a standard MDI window control. The related docking window is passed in the event arguments.
TabbedMdiContainerOverflowMenu | 3 | Overflow menu for a tabbed MDI container. The container's currently-selected docking window is passed in the event arguments.
TabbedMdiContainerTabContextMenu | 4 | Context menu for a tabbed MDI container tab. The related docking window is passed in the event arguments.
ToolWindowContainerOverflowMenu | 5 | Overflow menu for a tool window container. The container's currently-selected docking window is passed in the event arguments.
ToolWindowContainerTabContextMenu | 6 | Context menu for a tool window container tab. The related docking window is passed in the event arguments.
ToolWindowContainerTitleBarContextMenu | 7 | Context menu for a tool window container title bar. The container's currently-selected docking window is passed in the event arguments.
ToolWindowContainerTitleBarOptionsMenu | 8 | Options menu, displayed when clicking an options button in a tool window container title bar. The container's currently-selected docking window is passed in the event arguments.
WindowControlContextMenu | 9 | Context menu for a window control.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow Class

Represents the base class for a docking window implementation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.DockingDockingWindow
ActiproSoftware.Windows.Controls.DockingDocumentWindow
ActiproSoftware.Windows.Controls.DockingToolWindow

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DockingWindow : ContentControl,
    INotifyPropertyChanged, IDockTarget
Public MustInherit Class DockingWindow
    Inherits ContentControl
    Implements INotifyPropertyChanged, IDockTarget

The DockingWindow type exposes the following members.

Constructors
 | Name | Description
Protected method | DockingWindow | Initializes a new instance of the DockingWindow class.
Protected method | DockingWindow(Boolean) | Initializes a new instance of the DockingWindow class.
Top
Properties
 | Name | Description
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping.
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state.
Public property | CanClose | Gets or sets whether the window may be closed.
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed.
Public property | CanDock | Gets or sets whether the window may be docked.
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked.
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location.
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location.
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site.
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site.
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI.
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI.
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI.
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI.
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost.
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized.
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.
Public property | CloseAllInContainerCommand | Gets or sets the ICommand that can close all windows in the current container.
Public property | CloseCommand | Gets the ICommand that can Close the window.
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container.
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state.
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container.
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container.
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container.
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI.
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost in which the window is currently located.
Public property | DockSite | Gets the DockSite that is managing this docking window.
Public property | FloatCommand | Gets the ICommand that can Float the window.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs.
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus.
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties.
Public property | IsFloating | Gets or sets whether the docking window is floating, meaning it is currently open in a floating DockHost, or is closed and was last open in a floating DockHost.
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout.
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area.
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI.
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI.
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container.
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI.
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host.
Public property | OpenCommand | Gets the ICommand that can Open the window.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window.
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data.
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter.
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content.
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state.
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window.
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI.
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window.
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview).
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab.
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled.
Public property | TabFlashMode | Gets or sets the flash mode for the tab.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs.
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs.
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes.
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI.
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity.
Top
Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it.
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it.
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window, removing it from the layout.
Public method | CloseAllInContainer | Closes all windows in the same parent container, removing them from the layout.
Public method | CloseOthers | Closes all other windows in the same parent container, removing them from the layout.
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite.
Public method | DragMove | Programmatically starts a drag/move.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | Float | Floats the window to a default location with its current size.
Public method | Float(Point) | Floats the window to the specified location with its current size.
Public method | Float(Size) | Floats the window to a default location with the specified size.
Public method | Float(NullablePoint, NullableSize) | Floats the window to the specified optional location and size.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container.
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container.
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container.
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site.
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area.
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area.
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI.
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI.
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI.
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI.
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed.
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | OnStateChanged | Occurs when the value of the State property has changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | Open | Opens the window, inserting it into the layout.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value.
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value.
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value.
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value.
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value.
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value.
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value.
Protected method | UpdateCommands | Updates the enabled states of the commands.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed.
Top
Fields
Name | Description
CanAttachProperty | Identifies the CanAttach dependency property. This field is read-only.
CanAttachResolvedProperty | Identifies the CanAttachResolved dependency property. This field is read-only.
CanBecomeDocumentResolvedProperty | Identifies the CanBecomeDocumentResolved dependency property. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
CanCloseResolvedProperty | Identifies the CanCloseResolved dependency property. This field is read-only.
CanDockProperty | Identifies the CanDock dependency property. This field is read-only.
CanDockResolvedProperty | Identifies the CanDockResolved dependency property. This field is read-only.
CanDragTabProperty | Identifies the CanDragTab dependency property. This field is read-only.
CanDragTabResolvedProperty | Identifies the CanDragTabResolved dependency property. This field is read-only.
CanDragToLinkedDockSitesProperty | Identifies the CanDragToLinkedDockSites dependency property. This field is read-only.
CanDragToLinkedDockSitesResolvedProperty | Identifies the CanDragToLinkedDockSitesResolved dependency property. This field is read-only.
CanFloatProperty | Identifies the CanFloat dependency property. This field is read-only.
CanFloatResolvedProperty | Identifies the CanFloatResolved dependency property. This field is read-only.
CanSerializeProperty | Identifies the CanSerialize dependency property. This field is read-only.
CanStandardMdiMaximizeProperty | Identifies the CanStandardMdiMaximize dependency property. This field is read-only.
CanStandardMdiMaximizeResolvedProperty | Identifies the CanStandardMdiMaximizeResolved dependency property. This field is read-only.
CanStandardMdiMinimizeProperty | Identifies the CanStandardMdiMinimize dependency property. This field is read-only.
CanStandardMdiMinimizeResolvedProperty | Identifies the CanStandardMdiMinimizeResolved dependency property. This field is read-only.
ContainerDockedSizeProperty | Identifies the ContainerDockedSize dependency property. This field is read-only.
ContainerMaxSizeProperty | Identifies the ContainerMaxSize dependency property. This field is read-only.
ContainerMinSizeProperty | Identifies the ContainerMinSize dependency property. This field is read-only.
DefaultLocationRequestedEvent | Identifies the DefaultLocationRequested routed event. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsFloatingProperty | Identifies the IsFloating dependency property. This field is read-only.
IsOpenProperty | Identifies the IsOpen dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
LastActiveDateTimeProperty | Identifies the LastActiveDateTime dependency property. This field is read-only.
SerializationIdProperty | Identifies the SerializationId dependency property. This field is read-only.
SizeToContentModesProperty | Identifies the SizeToContentModes dependency property. This field is read-only.
StandardMdiBoundsProperty | Identifies the StandardMdiBounds dependency property. This field is read-only.
StandardMdiTitleBarContextContentTemplateProperty | Identifies the StandardMdiTitleBarContextContentTemplate dependency property. This field is read-only.
StandardMdiWindowStateProperty | Identifies the StandardMdiWindowState dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
TabbedMdiLayoutKindProperty | Identifies the TabbedMdiLayoutKind dependency property. This field is read-only.
TabbedMdiTabContextContentTemplateProperty | Identifies the TabbedMdiTabContextContentTemplate dependency property. This field is read-only.
TabFlashColorProperty | Identifies the TabFlashColor dependency property. This field is read-only.
TabFlashModeProperty | Identifies the TabFlashMode dependency property. This field is read-only.
TabTextProperty | Identifies the TabText dependency property. This field is read-only.
TabTextResolvedProperty | Identifies the TabTextResolved dependency property. This field is read-only.
TabTintColorProperty | Identifies the TabTintColor dependency property. This field is read-only.
TabToolTipProperty | Identifies the TabToolTip dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
UniqueIdProperty | Identifies the UniqueId dependency property. This field is read-only.
WindowGroupNameProperty | Identifies the WindowGroupName dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow Constructor

Overload List
 | Name | Description
Protected method | DockingWindow | Initializes a new instance of the DockingWindow class.
Protected method | DockingWindow(Boolean) | Initializes a new instance of the DockingWindow class.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow Constructor

Initializes a new instance of the DockingWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DockingWindow()
Protected Sub New
See Also

Reference

DockingWindow Class
DockingWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow Constructor (Boolean)

Initializes a new instance of the DockingWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DockingWindow(
    bool isContainerForItem
)
Protected Sub New (
    isContainerForItem As Boolean
)

Parameters

isContainerForItem
Type: SystemBoolean
Whether the window has been auto-created as a container for an item.
See Also

Reference

DockingWindow Class
DockingWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow Properties

The DockingWindow type exposes the following members.

Properties
 | Name | Description
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping.
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state.
Public property | CanClose | Gets or sets whether the window may be closed.
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed.
Public property | CanDock | Gets or sets whether the window may be docked.
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked.
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location.
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location.
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site.
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site.
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI.
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI.
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI.
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI.
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost.
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized.
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.
Public property | CloseAllInContainerCommand | Gets or sets the ICommand that can close all windows in the current container.
Public property | CloseCommand | Gets the ICommand that can Close the window.
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container.
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state.
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container.
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container.
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container.
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI.
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost in which the window is currently located.
Public property | DockSite | Gets the DockSite that is managing this docking window.
Public property | FloatCommand | Gets the ICommand that can Float the window.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs.
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus.
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties.
Public property | IsFloating | Gets or sets whether the docking window is floating, meaning it is currently open in a floating DockHost, or is closed and was last open in a floating DockHost.
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout.
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area.
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI.
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI.
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container.
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI.
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host.
Public property | OpenCommand | Gets the ICommand that can Open the window.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window.
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data.
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter.
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content.
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state.
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window.
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI.
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window.
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview).
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab.
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled.
Public property | TabFlashMode | Gets or sets the flash mode for the tab.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs.
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs.
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes.
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI.
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ActivateCommand Property

DockingWindowActivateCommand Property

Gets or sets the ICommand that can Activate the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ActivateCommand { get; }
Public ReadOnly Property ActivateCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Activate the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanAttach Property

DockingWindowCanAttach Property

Gets or sets whether the window may be attached to another window, creating a tabbed grouping.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanAttach { get; set; }
Public Property CanAttach As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be attached to another window, creating a tabbed grouping.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanAttachResolved Property

DockingWindowCanAttachResolved Property

Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanAttachResolved { get; protected set; }
Public Property CanAttachResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be attached to another window, creating a tabbed grouping; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanBecomeDocumentResolved Property

DockingWindowCanBecomeDocumentResolved Property

Gets a resolved value indicating whether the window may be placed in a document state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanBecomeDocumentResolved { get; protected set; }
Public Property CanBecomeDocumentResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be placed in a document state; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanClose Property

DockingWindowCanClose Property

Gets or sets whether the window may be closed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanClose { get; set; }
Public Property CanClose As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be closed.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanCloseResolved Property

DockingWindowCanCloseResolved Property

Gets a resolved value indicating whether the window may be closed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCloseResolved { get; protected set; }
Public Property CanCloseResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be closed; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDock Property

DockingWindowCanDock Property

Gets or sets whether the window may be docked.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanDock { get; set; }
Public Property CanDock As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be docked.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDockResolved Property

DockingWindowCanDockResolved Property

Gets a resolved value indicating whether the window may be docked.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDockResolved { get; protected set; }
Public Property CanDockResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be docked; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDragTab Property

DockingWindowCanDragTab Property

Gets or sets whether the window's tab may be dragged to another location.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanDragTab { get; set; }
Public Property CanDragTab As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window's tab may be dragged to another location.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDragTabResolved Property

DockingWindowCanDragTabResolved Property

Gets a resolved value indicating whether the window's tab may be dragged to another location.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDragTabResolved { get; protected set; }
Public Property CanDragTabResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window's tab may be dragged to another location; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDragToLinkedDockSites Property

DockingWindowCanDragToLinkedDockSites Property

Gets or sets whether the window may be dragged to a linked dock site.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanDragToLinkedDockSites { get; set; }
Public Property CanDragToLinkedDockSites As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be dragged to a linked dock site.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDragToLinkedDockSitesResolved Property

DockingWindowCanDragToLinkedDockSitesResolved Property

Gets a resolved value indicating whether the window may be dragged to a linked dock site.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDragToLinkedDockSitesResolved { get; protected set; }
Public Property CanDragToLinkedDockSitesResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be dragged to a linked dock site; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanFloat Property

DockingWindowCanFloat Property

Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanFloat { get; set; }
Public Property CanFloat As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanFloatResolved Property

DockingWindowCanFloatResolved Property

Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanFloatResolved { get; protected set; }
Public Property CanFloatResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanMoveToNewHorizontalContainer Property

DockingWindowCanMoveToNewHorizontalContainer Property

Gets whether the window can move to a new horizontal container within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMoveToNewHorizontalContainer { get; }
Public ReadOnly Property CanMoveToNewHorizontalContainer As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to a new horizontal container; otherwise, false.
Remarks
This property returns true when the window is currently within a tabbed MDI container that has more than one docking window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanMoveToNewVerticalContainer Property

DockingWindowCanMoveToNewVerticalContainer Property

Gets whether the window can move to a new vertical container within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMoveToNewVerticalContainer { get; }
Public ReadOnly Property CanMoveToNewVerticalContainer As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to a new vertical container; otherwise, false.
Remarks
This property returns true when the window is currently within a tabbed MDI container that has more than one docking window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanMoveToNextContainer Property

DockingWindowCanMoveToNextContainer Property

Gets whether the window can move to the next container within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMoveToNextContainer { get; }
Public ReadOnly Property CanMoveToNextContainer As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to the next container; otherwise, false.
Remarks
This property returns true when the window is currently within a tabbed MDI container and there is another tabbed MDI container after it in the layout.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanMoveToPreviousContainer Property

DockingWindowCanMoveToPreviousContainer Property

Gets whether the window can move to the previous container within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMoveToPreviousContainer { get; }
Public ReadOnly Property CanMoveToPreviousContainer As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to the previous container; otherwise, false.
Remarks
This property returns true when the window is currently within a tabbed MDI container and there is another tabbed MDI container before it in the layout.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanMoveToPrimaryMdiHost Property

DockingWindowCanMoveToPrimaryMdiHost Property

Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanMoveToPrimaryMdiHost { get; }
Public ReadOnly Property CanMoveToPrimaryMdiHost As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to the primary MDI host; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanSerialize Property

DockingWindowCanSerialize Property

Gets or sets whether the window's layout information may be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanSerialize { get; set; }
Public Property CanSerialize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window's layout information may be serialized; otherwise, false. The default value is true.
Remarks
When false, this property designates that the window should not be included in serialized layout information.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanStandardMdiMaximize Property

DockingWindowCanStandardMdiMaximize Property

Gets or sets whether the window may be maximized when hosted in a StandardMdiHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanStandardMdiMaximize { get; set; }
Public Property CanStandardMdiMaximize As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be maximized when hosted in a StandardMdiHost.
Remarks
If set to , the resolved value will use the global StandardMdiHost setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanStandardMdiMaximizeResolved Property

DockingWindowCanStandardMdiMaximizeResolved Property

Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanStandardMdiMaximizeResolved { get; }
Public ReadOnly Property CanStandardMdiMaximizeResolved As Boolean
    Get

Property Value

Type: Boolean
true if the window may be maximized when hosted in a StandardMdiHost; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanStandardMdiMinimize Property

DockingWindowCanStandardMdiMinimize Property

Gets or sets whether the window may be minimized when hosted in a StandardMdiHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanStandardMdiMinimize { get; set; }
Public Property CanStandardMdiMinimize As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be minimized when hosted in a StandardMdiHost.
Remarks
If set to , the resolved value will use the global StandardMdiHost setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanStandardMdiMinimizeResolved Property

DockingWindowCanStandardMdiMinimizeResolved Property

Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanStandardMdiMinimizeResolved { get; }
Public ReadOnly Property CanStandardMdiMinimizeResolved As Boolean
    Get

Property Value

Type: Boolean
true if the window may be attached to another window; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CloseAllInContainerCommand Property

DockingWindowCloseAllInContainerCommand Property

Gets or sets the ICommand that can close all windows in the current container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CloseAllInContainerCommand { get; }
Public ReadOnly Property CloseAllInContainerCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close all windows in the current container.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CloseCommand Property

DockingWindowCloseCommand Property

Gets the ICommand that can Close the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CloseCommand { get; }
Public ReadOnly Property CloseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Close the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CloseOthersCommand Property

DockingWindowCloseOthersCommand Property

Gets or sets the ICommand that can close all other windows in the current container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CloseOthersCommand { get; }
Public ReadOnly Property CloseOthersCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close all other windows in the current container.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ContainerDockedSize Property

DockingWindowContainerDockedSize Property

Gets or sets the Size of the docking window's container when it is in a docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size ContainerDockedSize { get; set; }
Public Property ContainerDockedSize As Size
    Get
    Set

Property Value

Type: Size
The Size of the docking window's container when it is in a docked state.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ContainerMaxSize Property

DockingWindowContainerMaxSize Property

Gets or sets the maximum Size of the docking window's container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size ContainerMaxSize { get; set; }
Public Property ContainerMaxSize As Size
    Get
    Set

Property Value

Type: Size
The maximum Size of the docking window's container.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ContainerMaxSizeResolved Property

DockingWindowContainerMaxSizeResolved Property

Gets the resolved maximum Size of the docking window's container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size ContainerMaxSizeResolved { get; }
Public ReadOnly Property ContainerMaxSizeResolved As Size
    Get

Property Value

Type: Size
The maximum Size of the docking window's container.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ContainerMinSize Property

DockingWindowContainerMinSize Property

Gets or sets the minimum Size of the docking window's container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size ContainerMinSize { get; set; }
Public Property ContainerMinSize As Size
    Get
    Set

Property Value

Type: Size
The minimum Size of the docking window's container.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ContainerMinSizeResolved Property

DockingWindowContainerMinSizeResolved Property

Gets the resolved minimum Size of the docking window's container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size ContainerMinSizeResolved { get; }
Public ReadOnly Property ContainerMinSizeResolved As Size
    Get

Property Value

Type: Size
The minimum Size of the docking window's container.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Description Property

DockingWindowDescription Property

Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description for the docking window, which may be used in Ctrl+Tab switching UI.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.DestroyCommand Property

DockingWindowDestroyCommand Property

Gets or sets the ICommand that can Destroy the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand DestroyCommand { get; }
Public ReadOnly Property DestroyCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Destroy the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.DockHost Property

DockingWindowDockHost Property

Gets the DockHost in which the window is currently located.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost in which the window is currently located.
Remarks
The primary dock host is the one directly within the DockSite hierarchy. Floating dock hosts are top-level containers that are external to the DockSite hierarchy's primary dock host.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.DockSite Property

DockingWindowDockSite Property

Gets the DockSite that is managing this docking window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this docking window.

Implements

IDockTargetDockSite
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.FloatCommand Property

DockingWindowFloatCommand Property

Gets the ICommand that can Float the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand FloatCommand { get; }
Public ReadOnly Property FloatCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Float the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ImageSource Property

DockingWindowImageSource Property

Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The ImageSource specifying the 16x16 image for the docking window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.IsActive Property

DockingWindowIsActive Property

Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsActive { get; set; }
Public Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the docking window is currently active; otherwise, false.
Remarks
This property is set to true when the ActiveWindow is this window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.IsContainerForItem Property

DockingWindowIsContainerForItem Property

Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsContainerForItem { get; }
Public ReadOnly Property IsContainerForItem As Boolean
    Get

Property Value

Type: Boolean
true if this window was auto-created as a container for an item; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.IsFloating Property

DockingWindowIsFloating Property

Gets or sets whether the docking window is floating, meaning it is currently open in a floating DockHost, or is closed and was last open in a floating DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsFloating { get; set; }
Public Property IsFloating As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the docking window is floating; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.IsOpen Property

DockingWindowIsOpen Property

Gets or sets whether the docking window is currently open in the layout.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOpen { get; set; }
Public Property IsOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the docking window is currently open in the layout; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.IsSelected Property

DockingWindowIsSelected Property

Gets or sets whether the docking window is currently selected in its parent container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the docking window is currently selected in its parent container; otherwise, false.
Remarks
The container is generally a TabbedMdiContainer, StandardMdiHost, or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.LastActiveDateTime Property

DockingWindowLastActiveDateTime Property

Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime LastActiveDateTime { get; }
Public ReadOnly Property LastActiveDateTime As DateTime
    Get

Property Value

Type: DateTime
The DateTime at which the window was last active, meaning the primary window that was focused.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToMdiCommand Property

DockingWindowMoveToMdiCommand Property

Gets or sets the ICommand that can change the window into a document within a MDI area.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MoveToMdiCommand { get; }
Public ReadOnly Property MoveToMdiCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can change the window into a document within a MDI area.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToNewHorizontalContainerCommand Property

DockingWindowMoveToNewHorizontalContainerCommand Property

Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MoveToNewHorizontalContainerCommand { get; }
Public ReadOnly Property MoveToNewHorizontalContainerCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to a new horizontal container.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToNewVerticalContainerCommand Property

DockingWindowMoveToNewVerticalContainerCommand Property

Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MoveToNewVerticalContainerCommand { get; }
Public ReadOnly Property MoveToNewVerticalContainerCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to a new vertical container.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToNextContainerCommand Property

DockingWindowMoveToNextContainerCommand Property

Gets or sets the ICommand that can move the window to the next container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MoveToNextContainerCommand { get; }
Public ReadOnly Property MoveToNextContainerCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to the next container.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToPreviousContainerCommand Property

DockingWindowMoveToPreviousContainerCommand Property

Gets or sets the ICommand that can move the window to the previous container within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MoveToPreviousContainerCommand { get; }
Public ReadOnly Property MoveToPreviousContainerCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to the previous container.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToPrimaryMdiHostCommand Property

DockingWindowMoveToPrimaryMdiHostCommand Property

Gets or sets the ICommand that can move the window to the primary MDI host.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MoveToPrimaryMdiHostCommand { get; }
Public ReadOnly Property MoveToPrimaryMdiHostCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to the primary MDI host.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.OpenCommand Property

DockingWindowOpenCommand Property

Gets the ICommand that can Open the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand OpenCommand { get; }
Public ReadOnly Property OpenCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Open the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ParentContainer Property

DockingWindowParentContainer Property

Gets the DockingWindowContainerBase that currently contains the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowContainerBase ParentContainer { get; }
Public ReadOnly Property ParentContainer As DockingWindowContainerBase
    Get

Property Value

Type: DockingWindowContainerBase
The DockingWindowContainerBase that currently contains the window.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.SerializationId Property

DockingWindowSerializationId Property

Gets or sets the unique ID to use when matching up windows with serialized layout data.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string SerializationId { get; set; }
Public Property SerializationId As String
    Get
    Set

Property Value

Type: String
The unique ID to use when matching up windows with serialized layout data.
Remarks
When deserializing a saved layout, the layout information has to be matched up with related windows, which is done via this property. Each window needs to have a unique serialization ID, specified by this property. When this property is , the window's Name property will be used instead. While the Name property must conform to standard .NET identifier syntax, this property can use any characters in its value.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.SetTabbedMdiLayoutKindCommand Property

DockingWindowSetTabbedMdiLayoutKindCommand Property

Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SetTabbedMdiLayoutKindCommand { get; }
Public ReadOnly Property SetTabbedMdiLayoutKindCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.SizeToContentModes Property

DockingWindowSizeToContentModes Property

Gets or sets a SizeToContentModes that indicates when to try to size-to-content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SizeToContentModes SizeToContentModes { get; set; }
Public Property SizeToContentModes As SizeToContentModes
    Get
    Set

Property Value

Type: SizeToContentModes
A SizeToContentModes that specifies the modes. The default value is None.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.StandardMdiBounds Property

DockingWindowStandardMdiBounds Property

Gets or sets the bounds of this docking window when in standard MDI 'restored' state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect StandardMdiBounds { get; set; }
Public Property StandardMdiBounds As Rect
    Get
    Set

Property Value

Type: Rect
The bounds of this docking window when in standard MDI 'restored' state.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.StandardMdiTitleBarContextContentTemplate Property

DockingWindowStandardMdiTitleBarContextContentTemplate Property

Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate StandardMdiTitleBarContextContentTemplate { get; set; }
Public Property StandardMdiTitleBarContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.StandardMdiWindowState Property

DockingWindowStandardMdiWindowState Property

Gets or sets the WindowState of this docking window when in standard MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WindowState StandardMdiWindowState { get; set; }
Public Property StandardMdiWindowState As WindowState
    Get
    Set

Property Value

Type: WindowState
The WindowState of this docking window when in standard MDI.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.State Property

DockingWindowState Property

Gets or sets the DockingWindowState that specifies the current state of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowState State { get; set; }
Public Property State As DockingWindowState
    Get
    Set

Property Value

Type: DockingWindowState
The DockingWindowState that specifies the current state of the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabbedMdiLayoutKind Property

DockingWindowTabbedMdiLayoutKind Property

Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview).

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabLayoutKind TabbedMdiLayoutKind { get; set; }
Public Property TabbedMdiLayoutKind As TabLayoutKind
    Get
    Set

Property Value

Type: TabLayoutKind
The TabLayoutKind that indicates how the tab will be positioned.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabbedMdiTabContextContentTemplate Property

DockingWindowTabbedMdiTabContextContentTemplate Property

Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate TabbedMdiTabContextContentTemplate { get; set; }
Public Property TabbedMdiTabContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for displaying contextual content in a tabbed MDI tab.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabFlashColor Property

DockingWindowTabFlashColor Property

Gets or sets the flash color to use if tab flashing is enabled.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color TabFlashColor { get; set; }
Public Property TabFlashColor As Color
    Get
    Set

Property Value

Type: Color
The flash color to use if tab flashing is enabled. The default value is #80FFA000.
Remarks
Tab flashing can be enabled via the TabFlashMode property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabFlashMode Property

DockingWindowTabFlashMode Property

Gets or sets the flash mode for the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabFlashMode TabFlashMode { get; set; }
Public Property TabFlashMode As TabFlashMode
    Get
    Set

Property Value

Type: TabFlashMode
The flash mode for the tab.
Remarks
The tab flash color can be set via the TabFlashColor property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabText Property

DockingWindowTabText Property

Gets or sets the optional text to only display on tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TabText { get; set; }
Public Property TabText As String
    Get
    Set

Property Value

Type: String
The optional text to only display on tabs.
Remarks
If this text is not specified, the Title will display on tabs.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabTextResolved Property

DockingWindowTabTextResolved Property

Gets the resolved optional text to only display on tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TabTextResolved { get; }
Public ReadOnly Property TabTextResolved As String
    Get

Property Value

Type: String
The resolved optional text to only display on tabs.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabTintColor Property

DockingWindowTabTintColor Property

Gets or sets the color used to tint the tab background and border brushes.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color TabTintColor { get; set; }
Public Property TabTintColor As Color
    Get
    Set

Property Value

Type: Color
The color used to tint the tab background and border brushes.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabToolTip Property

DockingWindowTabToolTip Property

Gets or sets the tooltip content to use for tabs that represent the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object TabToolTip { get; set; }
Public Property TabToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip content to use for tabs that represent the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Title Property

DockingWindowTitle Property

Gets or sets the title for the docking window, which appears in several places throughout the UI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title for the docking window.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UniqueId Property

DockingWindowUniqueId Property

Gets the Guid that uniquely identifies the control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; }
Public ReadOnly Property UniqueId As Guid
    Get

Property Value

Type: Guid
The Guid that uniquely identifies the control.
Remarks
A new Guid value is assigned to this property every time the application is run. Use the SerializationId property to designate an ID that uniquely identifies the window for layout deserialization purposes.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.WindowGroupName Property

DockingWindowWindowGroupName Property

Gets or sets an optional name that specifies a group of windows that have an affinity.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string WindowGroupName { get; set; }
Public Property WindowGroupName As String
    Get
    Set

Property Value

Type: String
The optional name that specifies a group of windows that have an affinity.
Remarks
Say that there are three windows that should generally be attached together. All of them should be assigned the same group name (e.g. Bottom). When a window is first opened and no previous location is found for it, it will search for other windows that are already open in the same state and have the same group name. If any are found, it will default to attaching to the most recently activated one.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow Methods

The DockingWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it.
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it.
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window, removing it from the layout.
Public method | CloseAllInContainer | Closes all windows in the same parent container, removing them from the layout.
Public method | CloseOthers | Closes all other windows in the same parent container, removing them from the layout.
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite.
Public method | DragMove | Programmatically starts a drag/move.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | Float | Floats the window to a default location with its current size.
Public method | Float(Point) | Floats the window to the specified location with its current size.
Public method | Float(Size) | Floats the window to a default location with the specified size.
Public method | Float(NullablePoint, NullableSize) | Floats the window to the specified optional location and size.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container.
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container.
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container.
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site.
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area.
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area.
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI.
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI.
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI.
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI.
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed.
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | OnStateChanged | Occurs when the value of the State property has changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | Open | Opens the window, inserting it into the layout.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value.
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value.
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value.
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value.
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value.
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value.
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value.
Protected method | UpdateCommands | Updates the enabled states of the commands.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Activate Method

DockingWindowActivate Method

Overload List
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it.
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Activate Method

DockingWindowActivate Method

Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Activate()
Public Sub Activate
See Also

Reference

DockingWindow Class
Activate Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Activate Method (Boolean)

DockingWindowActivate Method (Boolean)

Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Activate(
    bool focus
)
Public Sub Activate (
    focus As Boolean
)

Parameters

focus
Type: SystemBoolean
Whether to focus the window as well.
See Also

Reference

DockingWindow Class
Activate Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Close Method

DockingWindowClose Method

Closes the window, removing it from the layout.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Close()
Public Function Close As Boolean

Return Value

Type: Boolean
true if the docking window was closed successfully; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CloseAllInContainer Method

DockingWindowCloseAllInContainer Method

Closes all windows in the same parent container, removing them from the layout.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CloseAllInContainer(
    bool onlyCloseable = true
)
Public Function CloseAllInContainer (
    Optional onlyCloseable As Boolean = true
) As Boolean

Parameters

onlyCloseable (Optional)
Type: SystemBoolean
Only close windows whose CanCloseResolved property is true. The default value is true.

Return Value

Type: Boolean
true if the docking windows were closed successfully; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CloseOthers Method

DockingWindowCloseOthers Method

Closes all other windows in the same parent container, removing them from the layout.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CloseOthers(
    bool onlyCloseable = true
)
Public Function CloseOthers (
    Optional onlyCloseable As Boolean = true
) As Boolean

Parameters

onlyCloseable (Optional)
Type: SystemBoolean
Only close windows whose CanCloseResolved property is true. The default value is true.

Return Value

Type: Boolean
true if the other docking windows were closed successfully; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Destroy Method

DockingWindowDestroy Method

Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Destroy()
Public Sub Destroy
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.DragMove Method

DockingWindowDragMove Method

Programmatically starts a drag/move.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void DragMove(
    InputPointerButtonEventArgs sourceEventArgs
)
Public Sub DragMove (
    sourceEventArgs As InputPointerButtonEventArgs
)

Parameters

sourceEventArgs
Type: ActiproSoftware.Windows.InputInputPointerButtonEventArgs
The source InputPointerButtonEventArgs, which can be used to capture the pointer.
Remarks
The primary button of the pointer in the event arguments must be pressed down when calling this method. The pointer will be captured.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Float Method

DockingWindowFloat Method

Overload List
 | Name | Description
Public method | Float | Floats the window to a default location with its current size.
Public method | Float(Point) | Floats the window to the specified location with its current size.
Public method | Float(Size) | Floats the window to a default location with the specified size.
Public method | Float(NullablePoint, NullableSize) | Floats the window to the specified optional location and size.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Float Method

DockingWindowFloat Method

Floats the window to a default location with its current size.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Float()
Public Sub Float
See Also

Reference

DockingWindow Class
Float Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Float Method (Point)

DockingWindowFloat Method (Point)

Floats the window to the specified location with its current size.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Float(
    Point location
)
Public Sub Float (
    location As Point
)

Parameters

location
Type: System.WindowsPoint
A Point specifying the target location of the floating dock host.
See Also

Reference

DockingWindow Class
Float Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Float Method (Size)

DockingWindowFloat Method (Size)

Floats the window to a default location with the specified size.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Float(
    Size size
)
Public Sub Float (
    size As Size
)

Parameters

size
Type: System.WindowsSize
A Size specifying the target size of the floating dock host.
See Also

Reference

DockingWindow Class
Float Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Float Method (Nullable(Point), Nullable(Size))

DockingWindowFloat Method (NullablePoint, NullableSize)

Floats the window to the specified optional location and size.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void Float(
    Nullable<Point> location,
    Nullable<Size> size
)
Public MustOverride Sub Float (
    location As Nullable(Of Point),
    size As Nullable(Of Size)
)

Parameters

location
Type: SystemNullable Point
An optional Point specifying the target location of the floating dock host.
size
Type: SystemNullable Size
An optional Size specifying the target size of the floating dock host.
Remarks
When location is not specified, it will float to a default location. When size is not specified, it will float with its current size.
See Also

Reference

DockingWindow Class
Float Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToFirst Method

DockingWindowMoveToFirst Method

Moves the DockingWindow to be the first item in the current parent container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void MoveToFirst()
Public Sub MoveToFirst
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToIndex Method

DockingWindowMoveToIndex Method

Moves the DockingWindow to the specified location in the current parent container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void MoveToIndex(
    int index
)
Public Sub MoveToIndex (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index where the window should be moved.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToLast Method

DockingWindowMoveToLast Method

Moves the DockingWindow to be the last item in the current parent container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void MoveToLast()
Public Sub MoveToLast
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToLinkedDockSite Method

DockingWindowMoveToLinkedDockSite Method

Moves the DockingWindow to the specified linked dock site.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void MoveToLinkedDockSite(
    DockSite targetDockSite
)
Public Sub MoveToLinkedDockSite (
    targetDockSite As DockSite
)

Parameters

targetDockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The dock site where the window should be moved.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToMdi Method

DockingWindowMoveToMdi Method

Overload List
 | Name | Description
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area.
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToMdi Method

DockingWindowMoveToMdi Method

Changes the DockingWindow into a document within a MDI area.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void MoveToMdi()
Public Sub MoveToMdi
Remarks
Using this method places the DockingWindow in a Document State.
See Also

Reference

DockingWindow Class
MoveToMdi Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToMdi Method (DockHost)

DockingWindowMoveToMdi Method (DockHost)

Changes the DockingWindow into a document within a specific DockHost's MDI area.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void MoveToMdi(
    DockHost dockHost
)
Public Sub MoveToMdi (
    dockHost As DockHost
)

Parameters

dockHost
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The DockHost that contains a MDI area in which to move the window.
Remarks
Using this method places the DockingWindow in a Document State.
See Also

Reference

DockingWindow Class
MoveToMdi Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToNewHorizontalContainer Method

DockingWindowMoveToNewHorizontalContainer Method

Moves the window to a new horizontal container within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveToNewHorizontalContainer()
Public Function MoveToNewHorizontalContainer As Boolean

Return Value

Type: Boolean
true if the window was moved to a new horizontal container; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToNewVerticalContainer Method

DockingWindowMoveToNewVerticalContainer Method

Moves the window to a new vertical container within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveToNewVerticalContainer()
Public Function MoveToNewVerticalContainer As Boolean

Return Value

Type: Boolean
true if the window was moved to a new vertical container; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToNextContainer Method

DockingWindowMoveToNextContainer Method

Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveToNextContainer()
Public Function MoveToNextContainer As Boolean

Return Value

Type: Boolean
true if the window was moved to the next container; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.MoveToPreviousContainer Method

DockingWindowMoveToPreviousContainer Method

Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveToPreviousContainer()
Public Function MoveToPreviousContainer As Boolean

Return Value

Type: Boolean
true if the window was moved to the previous container; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.NotifyPropertyChanged Method

DockingWindowNotifyPropertyChanged Method

Notifies that a property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.OnDefaultLocationRequested Method

DockingWindowOnDefaultLocationRequested Method

Occurs when a DockingWindow's default location is requested.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDefaultLocationRequested(
    DockingWindowDefaultLocationEventArgs e
)
Protected Overridable Sub OnDefaultLocationRequested (
    e As DockingWindowDefaultLocationEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowDefaultLocationEventArgs
The DockingWindowDefaultLocationEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.OnDockSiteChanged Method

DockingWindowOnDockSiteChanged Method

Occurs when the value of the DockSite property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDockSiteChanged(
    DockSite oldValue,
    DockSite newValue
)
Protected Overridable Sub OnDockSiteChanged (
    oldValue As DockSite,
    newValue As DockSite
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The new value.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.OnGotKeyboardFocus Method

DockingWindowOnGotKeyboardFocus Method

Occurs when a control within this control's hierarchy gains keyboard focus.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
Protected Overrides Sub OnGotKeyboardFocus (
    e As KeyboardFocusChangedEventArgs
)

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
The KeyboardFocusChangedEventArgs that contains data related to this event.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.OnIsSelectedChanged Method

DockingWindowOnIsSelectedChanged Method

Occurs when the value of the IsSelected property changes.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnIsSelectedChanged()
Protected Overridable Sub OnIsSelectedChanged
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.OnPropertyChanged Method

DockingWindowOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.OnStateChanged Method

DockingWindowOnStateChanged Method

Occurs when the value of the State property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnStateChanged(
    DockingWindowState oldValue,
    DockingWindowState newValue
)
Protected Overridable Sub OnStateChanged (
    oldValue As DockingWindowState,
    newValue As DockingWindowState
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowState
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowState
The new value.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.Open Method

DockingWindowOpen Method

Opens the window, inserting it into the layout.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Open()
Public Sub Open
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ToString Method

DockingWindowToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UpdateCanAttachResolved Method

DockingWindowUpdateCanAttachResolved Method

Updates the CanAttachResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanAttachResolved()
Protected MustOverride Sub UpdateCanAttachResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UpdateCanBecomeDocumentResolved Method

DockingWindowUpdateCanBecomeDocumentResolved Method

Updates the CanBecomeDocumentResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateCanBecomeDocumentResolved()
Protected Overridable Sub UpdateCanBecomeDocumentResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UpdateCanCloseResolved Method

DockingWindowUpdateCanCloseResolved Method

Updates the CanCloseResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanCloseResolved()
Protected MustOverride Sub UpdateCanCloseResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UpdateCanDockResolved Method

DockingWindowUpdateCanDockResolved Method

Updates the CanDockResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanDockResolved()
Protected MustOverride Sub UpdateCanDockResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UpdateCanDragTabResolved Method

DockingWindowUpdateCanDragTabResolved Method

Updates the CanDragTabResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanDragTabResolved()
Protected MustOverride Sub UpdateCanDragTabResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UpdateCanDragToLinkedDockSitesResolved Method

DockingWindowUpdateCanDragToLinkedDockSitesResolved Method

Updates the CanDragToLinkedDockSitesResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanDragToLinkedDockSitesResolved()
Protected MustOverride Sub UpdateCanDragToLinkedDockSitesResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UpdateCanFloatResolved Method

DockingWindowUpdateCanFloatResolved Method

Updates the CanFloatResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanFloatResolved()
Protected MustOverride Sub UpdateCanFloatResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UpdateCommands Method

DockingWindowUpdateCommands Method

Updates the enabled states of the commands.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateCommands()
Protected Overridable Sub UpdateCommands
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow Events

The DockingWindow type exposes the following members.

Events
 | Name | Description
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.DefaultLocationRequested Event

DockingWindowDefaultLocationRequested Event

Occurs when a DockingWindow's default location is requested.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowDefaultLocationEventArgs> DefaultLocationRequested
Public Event DefaultLocationRequested As EventHandler(Of DockingWindowDefaultLocationEventArgs)

Value

Type: SystemEventHandler DockingWindowDefaultLocationEventArgs
Remarks
The handler should examine the event arguments and set the Target and/or Side properties as appropriate.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.PropertyChanged Event

DockingWindowPropertyChanged Event

Occurs when a property has been changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow Fields

The DockingWindow type exposes the following members.

Fields
Name | Description
CanAttachProperty | Identifies the CanAttach dependency property. This field is read-only.
CanAttachResolvedProperty | Identifies the CanAttachResolved dependency property. This field is read-only.
CanBecomeDocumentResolvedProperty | Identifies the CanBecomeDocumentResolved dependency property. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
CanCloseResolvedProperty | Identifies the CanCloseResolved dependency property. This field is read-only.
CanDockProperty | Identifies the CanDock dependency property. This field is read-only.
CanDockResolvedProperty | Identifies the CanDockResolved dependency property. This field is read-only.
CanDragTabProperty | Identifies the CanDragTab dependency property. This field is read-only.
CanDragTabResolvedProperty | Identifies the CanDragTabResolved dependency property. This field is read-only.
CanDragToLinkedDockSitesProperty | Identifies the CanDragToLinkedDockSites dependency property. This field is read-only.
CanDragToLinkedDockSitesResolvedProperty | Identifies the CanDragToLinkedDockSitesResolved dependency property. This field is read-only.
CanFloatProperty | Identifies the CanFloat dependency property. This field is read-only.
CanFloatResolvedProperty | Identifies the CanFloatResolved dependency property. This field is read-only.
CanSerializeProperty | Identifies the CanSerialize dependency property. This field is read-only.
CanStandardMdiMaximizeProperty | Identifies the CanStandardMdiMaximize dependency property. This field is read-only.
CanStandardMdiMaximizeResolvedProperty | Identifies the CanStandardMdiMaximizeResolved dependency property. This field is read-only.
CanStandardMdiMinimizeProperty | Identifies the CanStandardMdiMinimize dependency property. This field is read-only.
CanStandardMdiMinimizeResolvedProperty | Identifies the CanStandardMdiMinimizeResolved dependency property. This field is read-only.
ContainerDockedSizeProperty | Identifies the ContainerDockedSize dependency property. This field is read-only.
ContainerMaxSizeProperty | Identifies the ContainerMaxSize dependency property. This field is read-only.
ContainerMinSizeProperty | Identifies the ContainerMinSize dependency property. This field is read-only.
DefaultLocationRequestedEvent | Identifies the DefaultLocationRequested routed event. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsFloatingProperty | Identifies the IsFloating dependency property. This field is read-only.
IsOpenProperty | Identifies the IsOpen dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
LastActiveDateTimeProperty | Identifies the LastActiveDateTime dependency property. This field is read-only.
SerializationIdProperty | Identifies the SerializationId dependency property. This field is read-only.
SizeToContentModesProperty | Identifies the SizeToContentModes dependency property. This field is read-only.
StandardMdiBoundsProperty | Identifies the StandardMdiBounds dependency property. This field is read-only.
StandardMdiTitleBarContextContentTemplateProperty | Identifies the StandardMdiTitleBarContextContentTemplate dependency property. This field is read-only.
StandardMdiWindowStateProperty | Identifies the StandardMdiWindowState dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
TabbedMdiLayoutKindProperty | Identifies the TabbedMdiLayoutKind dependency property. This field is read-only.
TabbedMdiTabContextContentTemplateProperty | Identifies the TabbedMdiTabContextContentTemplate dependency property. This field is read-only.
TabFlashColorProperty | Identifies the TabFlashColor dependency property. This field is read-only.
TabFlashModeProperty | Identifies the TabFlashMode dependency property. This field is read-only.
TabTextProperty | Identifies the TabText dependency property. This field is read-only.
TabTextResolvedProperty | Identifies the TabTextResolved dependency property. This field is read-only.
TabTintColorProperty | Identifies the TabTintColor dependency property. This field is read-only.
TabToolTipProperty | Identifies the TabToolTip dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
UniqueIdProperty | Identifies the UniqueId dependency property. This field is read-only.
WindowGroupNameProperty | Identifies the WindowGroupName dependency property. This field is read-only.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanAttachProperty Field

DockingWindowCanAttachProperty Field

Identifies the CanAttach dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAttachProperty
Public Shared ReadOnly CanAttachProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAttach dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanAttachResolvedProperty Field

DockingWindowCanAttachResolvedProperty Field

Identifies the CanAttachResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAttachResolvedProperty
Public Shared ReadOnly CanAttachResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAttachResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanBecomeDocumentResolvedProperty Field

DockingWindowCanBecomeDocumentResolvedProperty Field

Identifies the CanBecomeDocumentResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanBecomeDocumentResolvedProperty
Public Shared ReadOnly CanBecomeDocumentResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanBecomeDocumentResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanCloseProperty Field

DockingWindowCanCloseProperty Field

Identifies the CanClose dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCloseProperty
Public Shared ReadOnly CanCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanClose dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanCloseResolvedProperty Field

DockingWindowCanCloseResolvedProperty Field

Identifies the CanCloseResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCloseResolvedProperty
Public Shared ReadOnly CanCloseResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanCloseResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDockProperty Field

DockingWindowCanDockProperty Field

Identifies the CanDock dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDockProperty
Public Shared ReadOnly CanDockProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDock dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDockResolvedProperty Field

DockingWindowCanDockResolvedProperty Field

Identifies the CanDockResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDockResolvedProperty
Public Shared ReadOnly CanDockResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDockResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDragTabProperty Field

DockingWindowCanDragTabProperty Field

Identifies the CanDragTab dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragTabProperty
Public Shared ReadOnly CanDragTabProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragTab dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDragTabResolvedProperty Field

DockingWindowCanDragTabResolvedProperty Field

Identifies the CanDragTabResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragTabResolvedProperty
Public Shared ReadOnly CanDragTabResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragTabResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDragToLinkedDockSitesProperty Field

DockingWindowCanDragToLinkedDockSitesProperty Field

Identifies the CanDragToLinkedDockSites dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragToLinkedDockSitesProperty
Public Shared ReadOnly CanDragToLinkedDockSitesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragToLinkedDockSites dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanDragToLinkedDockSitesResolvedProperty Field

DockingWindowCanDragToLinkedDockSitesResolvedProperty Field

Identifies the CanDragToLinkedDockSitesResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragToLinkedDockSitesResolvedProperty
Public Shared ReadOnly CanDragToLinkedDockSitesResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragToLinkedDockSitesResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanFloatProperty Field

DockingWindowCanFloatProperty Field

Identifies the CanFloat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanFloatProperty
Public Shared ReadOnly CanFloatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanFloat dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanFloatResolvedProperty Field

DockingWindowCanFloatResolvedProperty Field

Identifies the CanFloatResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanFloatResolvedProperty
Public Shared ReadOnly CanFloatResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanFloatResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanSerializeProperty Field

DockingWindowCanSerializeProperty Field

Identifies the CanSerialize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanSerializeProperty
Public Shared ReadOnly CanSerializeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanSerialize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanStandardMdiMaximizeProperty Field

DockingWindowCanStandardMdiMaximizeProperty Field

Identifies the CanStandardMdiMaximize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanStandardMdiMaximizeProperty
Public Shared ReadOnly CanStandardMdiMaximizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanStandardMdiMaximize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanStandardMdiMaximizeResolvedProperty Field

DockingWindowCanStandardMdiMaximizeResolvedProperty Field

Identifies the CanStandardMdiMaximizeResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanStandardMdiMaximizeResolvedProperty
Public Shared ReadOnly CanStandardMdiMaximizeResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanStandardMdiMaximizeResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanStandardMdiMinimizeProperty Field

DockingWindowCanStandardMdiMinimizeProperty Field

Identifies the CanStandardMdiMinimize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanStandardMdiMinimizeProperty
Public Shared ReadOnly CanStandardMdiMinimizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanStandardMdiMinimize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.CanStandardMdiMinimizeResolvedProperty Field

DockingWindowCanStandardMdiMinimizeResolvedProperty Field

Identifies the CanStandardMdiMinimizeResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanStandardMdiMinimizeResolvedProperty
Public Shared ReadOnly CanStandardMdiMinimizeResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanStandardMdiMinimizeResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ContainerDockedSizeProperty Field

DockingWindowContainerDockedSizeProperty Field

Identifies the ContainerDockedSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainerDockedSizeProperty
Public Shared ReadOnly ContainerDockedSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainerDockedSize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ContainerMaxSizeProperty Field

DockingWindowContainerMaxSizeProperty Field

Identifies the ContainerMaxSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainerMaxSizeProperty
Public Shared ReadOnly ContainerMaxSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainerMaxSize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ContainerMinSizeProperty Field

DockingWindowContainerMinSizeProperty Field

Identifies the ContainerMinSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainerMinSizeProperty
Public Shared ReadOnly ContainerMinSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainerMinSize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.DefaultLocationRequestedEvent Field

DockingWindowDefaultLocationRequestedEvent Field

Identifies the DefaultLocationRequested routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent DefaultLocationRequestedEvent
Public Shared ReadOnly DefaultLocationRequestedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the DefaultLocationRequested routed event.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.DescriptionProperty Field

DockingWindowDescriptionProperty Field

Identifies the Description dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DescriptionProperty
Public Shared ReadOnly DescriptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Description dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.ImageSourceProperty Field

DockingWindowImageSourceProperty Field

Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.IsActiveProperty Field

DockingWindowIsActiveProperty Field

Identifies the IsActive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsActiveProperty
Public Shared ReadOnly IsActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsActive dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.IsFloatingProperty Field

DockingWindowIsFloatingProperty Field

Identifies the IsFloating dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFloatingProperty
Public Shared ReadOnly IsFloatingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFloating dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.IsOpenProperty Field

DockingWindowIsOpenProperty Field

Identifies the IsOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOpenProperty
Public Shared ReadOnly IsOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOpen dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.IsSelectedProperty Field

DockingWindowIsSelectedProperty Field

Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.LastActiveDateTimeProperty Field

DockingWindowLastActiveDateTimeProperty Field

Identifies the LastActiveDateTime dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LastActiveDateTimeProperty
Public Shared ReadOnly LastActiveDateTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LastActiveDateTime dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.SerializationIdProperty Field

DockingWindowSerializationIdProperty Field

Identifies the SerializationId dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SerializationIdProperty
Public Shared ReadOnly SerializationIdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SerializationId dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.SizeToContentModesProperty Field

DockingWindowSizeToContentModesProperty Field

Identifies the SizeToContentModes dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeToContentModesProperty
Public Shared ReadOnly SizeToContentModesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SizeToContentModes dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.StandardMdiBoundsProperty Field

DockingWindowStandardMdiBoundsProperty Field

Identifies the StandardMdiBounds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardMdiBoundsProperty
Public Shared ReadOnly StandardMdiBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardMdiBounds dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.StandardMdiTitleBarContextContentTemplateProperty Field

DockingWindowStandardMdiTitleBarContextContentTemplateProperty Field

Identifies the StandardMdiTitleBarContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardMdiTitleBarContextContentTemplateProperty
Public Shared ReadOnly StandardMdiTitleBarContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardMdiTitleBarContextContentTemplate dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.StandardMdiWindowStateProperty Field

DockingWindowStandardMdiWindowStateProperty Field

Identifies the StandardMdiWindowState dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardMdiWindowStateProperty
Public Shared ReadOnly StandardMdiWindowStateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardMdiWindowState dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.StateProperty Field

DockingWindowStateProperty Field

Identifies the State dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StateProperty
Public Shared ReadOnly StateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the State dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabbedMdiLayoutKindProperty Field

DockingWindowTabbedMdiLayoutKindProperty Field

Identifies the TabbedMdiLayoutKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabbedMdiLayoutKindProperty
Public Shared ReadOnly TabbedMdiLayoutKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabbedMdiLayoutKind dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabbedMdiTabContextContentTemplateProperty Field

DockingWindowTabbedMdiTabContextContentTemplateProperty Field

Identifies the TabbedMdiTabContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabbedMdiTabContextContentTemplateProperty
Public Shared ReadOnly TabbedMdiTabContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabbedMdiTabContextContentTemplate dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabFlashColorProperty Field

DockingWindowTabFlashColorProperty Field

Identifies the TabFlashColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabFlashColorProperty
Public Shared ReadOnly TabFlashColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabFlashColor dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabFlashModeProperty Field

DockingWindowTabFlashModeProperty Field

Identifies the TabFlashMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabFlashModeProperty
Public Shared ReadOnly TabFlashModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabFlashMode dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabTextProperty Field

DockingWindowTabTextProperty Field

Identifies the TabText dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabTextProperty
Public Shared ReadOnly TabTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabText dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabTextResolvedProperty Field

DockingWindowTabTextResolvedProperty Field

Identifies the TabTextResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabTextResolvedProperty
Public Shared ReadOnly TabTextResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabTextResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabTintColorProperty Field

DockingWindowTabTintColorProperty Field

Identifies the TabTintColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabTintColorProperty
Public Shared ReadOnly TabTintColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabTintColor dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TabToolTipProperty Field

DockingWindowTabToolTipProperty Field

Identifies the TabToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabToolTipProperty
Public Shared ReadOnly TabToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabToolTip dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.TitleProperty Field

DockingWindowTitleProperty Field

Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.UniqueIdProperty Field

DockingWindowUniqueIdProperty Field

Identifies the UniqueId dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UniqueIdProperty
Public Shared ReadOnly UniqueIdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UniqueId dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindow.WindowGroupNameProperty Field

DockingWindowWindowGroupNameProperty Field

Identifies the WindowGroupName dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WindowGroupNameProperty
Public Shared ReadOnly WindowGroupNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WindowGroupName dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollection Class

Represents an observable collection of DockingWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection DockingWindow
System.Collections.ObjectModelObservableCollection DockingWindow
ActiproSoftware.WindowsDeferrableObservableCollection DockingWindow
ActiproSoftware.Windows.Controls.DockingDockingWindowCollectionBase DockingWindow
ActiproSoftware.Windows.Controls.DockingDockingWindowCollection

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowCollection : DockingWindowCollectionBase<DockingWindow>
Public Class DockingWindowCollection
    Inherits DockingWindowCollectionBase(Of DockingWindow)

The DockingWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowCollection | Initializes a new instance of the DockingWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection DockingWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection DockingWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection DockingWindow .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection DockingWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection DockingWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection DockingWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection DockingWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection DockingWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection DockingWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection DockingWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection DockingWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection DockingWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection DockingWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection DockingWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection DockingWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection DockingWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection DockingWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection DockingWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection DockingWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection DockingWindow .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollection Constructor

Initializes a new instance of the DockingWindowCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowCollection()
Public Sub New
See Also

Reference

DockingWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollection Properties

The DockingWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection DockingWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection DockingWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection DockingWindow .)
Top
See Also

Reference

DockingWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollection Methods

The DockingWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection DockingWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection DockingWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection DockingWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection DockingWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection DockingWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection DockingWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection DockingWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection DockingWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection DockingWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection DockingWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection DockingWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection DockingWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection DockingWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection DockingWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection DockingWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

DockingWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollection Events

The DockingWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection DockingWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection DockingWindow .)
Top
See Also

Reference

DockingWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T) Class

DockingWindowCollectionBaseT Class

Represents the base class for an observable collection of DockingWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.WindowsDeferrableObservableCollection T
ActiproSoftware.Windows.Controls.DockingDockingWindowCollectionBaseT
ActiproSoftware.Windows.Controls.DockingDockingWindowCollection
ActiproSoftware.Windows.Controls.DockingDocumentWindowCollection
ActiproSoftware.Windows.Controls.DockingToolWindowCollection

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowCollectionBase<T> : DeferrableObservableCollection<T>
where T : DockingWindow

Public Class DockingWindowCollectionBase(Of T As DockingWindow)
    Inherits DeferrableObservableCollection(Of T)

Type Parameters

T
The type of DockingWindow in this collection.

The DockingWindowCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowCollectionBaseT | Initializes a new instance of the DockingWindowCollectionBaseT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection T.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection T.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection T.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T) Constructor

DockingWindowCollectionBaseT Constructor

Initializes a new instance of the DockingWindowCollectionBaseT class

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowCollectionBase()
Public Sub New
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T) Properties

DockingWindowCollectionBaseT Properties

The DockingWindowCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection T .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T).Item Property

DockingWindowCollectionBaseTItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection T .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T).Item Property (Guid)

DockingWindowCollectionBaseTItem Property (Guid)

Gets the item with the specified UniqueId value.

[C#] In C#, this property is the indexer for the collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T this[
    Guid uniqueId
] { get; }
Public ReadOnly Default Property Item (
    uniqueId As Guid
) As T
    Get

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Property Value

Type: T
The item with the specified UniqueId value.
See Also

Reference

DockingWindowCollectionBaseT Class
Item Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T).Item Property (String)

DockingWindowCollectionBaseTItem Property (String)

Gets the item with the specified Name value.

[C#] In C#, this property is the indexer for the collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As T
    Get

Parameters

name
Type: SystemString
The name value to locate in the collection.

Property Value

Type: T
The item with the specified Name value.
See Also

Reference

DockingWindowCollectionBaseT Class
Item Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T) Methods

DockingWindowCollectionBaseT Methods

The DockingWindowCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection T .)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection T .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T).Contains Method

DockingWindowCollectionBaseTContains Method

Overload List
 | Name | Description
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T).Contains Method (Guid)

DockingWindowCollectionBaseTContains Method (Guid)

Determines whether an item with the specified UniqueId value is in the collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    Guid uniqueId
)
Public Function Contains (
    uniqueId As Guid
) As Boolean

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Return Value

Type: Boolean
true if an item with the specified UniqueId value is found in the collection; otherwise, false.
See Also

Reference

DockingWindowCollectionBaseT Class
Contains Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T).Contains Method (String)

DockingWindowCollectionBaseTContains Method (String)

Determines whether an item with the specified Name value is in the collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name value to locate in the collection.

Return Value

Type: Boolean
true if an item with the specified Name value is found in the collection; otherwise, false.
See Also

Reference

DockingWindowCollectionBaseT Class
Contains Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T).IndexOf Method

DockingWindowCollectionBaseTIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T).IndexOf Method (Guid)

DockingWindowCollectionBaseTIndexOf Method (Guid)

Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    Guid uniqueId
)
Public Function IndexOf (
    uniqueId As Guid
) As Integer

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of an item with the specified UniqueId value within the entire collection, if found; otherwise, -1.
See Also

Reference

DockingWindowCollectionBaseT Class
IndexOf Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T).IndexOf Method (String)

DockingWindowCollectionBaseTIndexOf Method (String)

Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    string name
)
Public Function IndexOf (
    name As String
) As Integer

Parameters

name
Type: SystemString
The name value to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of an item with the specified Name value within the entire collection, if found; otherwise, -1.
See Also

Reference

DockingWindowCollectionBaseT Class
IndexOf Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowCollectionBase(T) Events

DockingWindowCollectionBaseT Events

The DockingWindowCollectionBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T .)
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs Class

Provides event arguments for DockingWindow-related default location events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowDefaultLocationEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowDefaultLocationEventArgs : DockingWindowEventArgs
Public Class DockingWindowDefaultLocationEventArgs
    Inherits DockingWindowEventArgs

The DockingWindowDefaultLocationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowDefaultLocationEventArgs | Initializes a new instance of the DockingWindowDefaultLocationEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | FloatingLocation | Gets or sets the location to use if ShouldFloat is true.
Public property | ShouldFloat | Gets or sets whether the window should be floated instead of docking against the Target.
Public property | Side | Gets or sets the optional Side to dock against the Target control.
Public property | State | Gets the DockingWindowState in which the window is requesting a default location.
Public property | Target | Gets or sets the IDockTarget against which to dock.
Public property | Window | Gets or sets the DockingWindow that is the focus of this event. (Inherited from DockingWindowEventArgs.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs Constructor

Initializes a new instance of the DockingWindowDefaultLocationEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowDefaultLocationEventArgs(
    DockingWindow window,
    DockingWindowState state
)
Public Sub New (
    window As DockingWindow,
    state As DockingWindowState
)

Parameters

window
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The DockingWindow that is the focus of this event.
state
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowState
The DockingWindowState in which the window is requesting a default location.
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs Properties

The DockingWindowDefaultLocationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | FloatingLocation | Gets or sets the location to use if ShouldFloat is true.
Public property | ShouldFloat | Gets or sets whether the window should be floated instead of docking against the Target.
Public property | Side | Gets or sets the optional Side to dock against the Target control.
Public property | State | Gets the DockingWindowState in which the window is requesting a default location.
Public property | Target | Gets or sets the IDockTarget against which to dock.
Public property | Window | Gets or sets the DockingWindow that is the focus of this event. (Inherited from DockingWindowEventArgs.)
Top
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs.FloatingLocation Property

DockingWindowDefaultLocationEventArgsFloatingLocation Property

Gets or sets the location to use if ShouldFloat is true.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Point> FloatingLocation { get; set; }
Public Property FloatingLocation As Nullable(Of Point)
    Get
    Set

Property Value

Type: Nullable Point
The location to use if ShouldFloat is true.
Remarks
Specify a value to use a default location.
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs.ShouldFloat Property

DockingWindowDefaultLocationEventArgsShouldFloat Property

Gets or sets whether the window should be floated instead of docking against the Target.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ShouldFloat { get; set; }
Public Property ShouldFloat As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window should be floated instead of docking against the Target; otherwise, false.
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs.Side Property

DockingWindowDefaultLocationEventArgsSide Property

Gets or sets the optional Side to dock against the Target control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Side> Side { get; set; }
Public Property Side As Nullable(Of Side)
    Get
    Set

Property Value

Type: Nullable Side
The optional Side to dock against the Target control.
Remarks
Specify a value to designate an "attach".
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs.State Property

DockingWindowDefaultLocationEventArgsState Property

Gets the DockingWindowState in which the window is requesting a default location.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowState State { get; }
Public ReadOnly Property State As DockingWindowState
    Get

Property Value

Type: DockingWindowState
The DockingWindowState in which the window is requesting a default location.
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs.Target Property

DockingWindowDefaultLocationEventArgsTarget Property

Gets or sets the IDockTarget against which to dock.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDockTarget Target { get; set; }
Public Property Target As IDockTarget
    Get
    Set

Property Value

Type: IDockTarget
The IDockTarget against which to dock.
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowEventArgs Class

Provides event arguments for DockingWindow-related events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
ActiproSoftware.Windows.Controls.DockingDockingMenuEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowDefaultLocationEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowEventArgs : CancelRoutedEventArgs
Public Class DockingWindowEventArgs
    Inherits CancelRoutedEventArgs

The DockingWindowEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowEventArgs | Initializes a new instance of the DockingWindowEventArgs class
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Window | Gets or sets the DockingWindow that is the focus of this event.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowEventArgs Constructor

Initializes a new instance of the DockingWindowEventArgs class

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowEventArgs()
Public Sub New
See Also

Reference

DockingWindowEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowEventArgs Properties

The DockingWindowEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Window | Gets or sets the DockingWindow that is the focus of this event.
Top
See Also

Reference

DockingWindowEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowEventArgs.Window Property

DockingWindowEventArgsWindow Property

Gets or sets the DockingWindow that is the focus of this event.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindow Window { get; set; }
Public Property Window As DockingWindow
    Get
    Set

Property Value

Type: DockingWindow
The DockingWindow that is the focus of this event.
See Also

Reference

DockingWindowEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowItemKind Enumeration

Indicates the kind of container that is generated for a DockSite item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DockingWindowItemKind
Public Enumeration DockingWindowItemKind
Members
Member name | Value | Description
Document | 0 | The item is a document window.
Tool | 1 | The item is a tool window.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsAutoHidingEventArgs Class

Provides event arguments for DockingWindow auto-hiding events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowsAutoHidingEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowsAutoHidingEventArgs : DockingWindowsEventArgs
Public Class DockingWindowsAutoHidingEventArgs
    Inherits DockingWindowsEventArgs

The DockingWindowsAutoHidingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowsAutoHidingEventArgs | Initializes a new instance of the DockingWindowsAutoHidingEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Side | Gets or sets the Side upon which the docking windows will be auto-hidden.
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event. (Inherited from DockingWindowsEventArgs.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsAutoHidingEventArgs Constructor

Initializes a new instance of the DockingWindowsAutoHidingEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowsAutoHidingEventArgs(
    IEnumerable<DockingWindow> windows
)
Public Sub New (
    windows As IEnumerable(Of DockingWindow)
)

Parameters

windows
Type: System.Collections.GenericIEnumerable DockingWindow
The collection of DockingWindow controls that are the focus of this event.
See Also

Reference

DockingWindowsAutoHidingEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsAutoHidingEventArgs Properties

The DockingWindowsAutoHidingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Side | Gets or sets the Side upon which the docking windows will be auto-hidden.
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event. (Inherited from DockingWindowsEventArgs.)
Top
See Also

Reference

DockingWindowsAutoHidingEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsAutoHidingEventArgs.Side Property

DockingWindowsAutoHidingEventArgsSide Property

Gets or sets the Side upon which the docking windows will be auto-hidden.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Side Side { get; set; }
Public Property Side As Side
    Get
    Set

Property Value

Type: Side
The Side upon which the docking windows will be auto-hidden.
See Also

Reference

DockingWindowsAutoHidingEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsDragOverEventArgs Class

Provides event arguments for when one or more docking windows are dragged over a new dock target, with support for hiding certain dock guides by altering the AllowedDockGuideKinds property.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowsDragOverEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowsDragOverEventArgs : DockingWindowsEventArgs
Public Class DockingWindowsDragOverEventArgs
    Inherits DockingWindowsEventArgs

The DockingWindowsDragOverEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowsDragOverEventArgs | Initializes a new instance of the DockingWindowsDragOverEventArgs class.
Top
Properties
 | Name | Description
Public property | AllowedDockGuideKinds | Gets or sets the dock guide kinds that are allowed by this DraggedDockHost and dock Target combination.
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | DraggedDockHost | Gets the DockHost that is being dragged, and that contains the Windows.
Public property | SupportedDockGuideKinds | Gets the dock guide kinds that are supported by this DraggedDockHost and dock Target combination.
Public property | Target | Gets the IDockTarget that the drag is over.
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event. (Inherited from DockingWindowsEventArgs.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsDragOverEventArgs Constructor

Initializes a new instance of the DockingWindowsDragOverEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowsDragOverEventArgs(
    DockHost draggedDockHost,
    IDockTarget target,
    DockGuideKinds supportedDockGuideKinds
)
Public Sub New (
    draggedDockHost As DockHost,
    target As IDockTarget,
    supportedDockGuideKinds As DockGuideKinds
)

Parameters

draggedDockHost
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The DockHost that is being dragged, and that contains the Windows.
target
Type: ActiproSoftware.Windows.Controls.DockingIDockTarget
The IDockTarget that the drag is over.
supportedDockGuideKinds
Type: ActiproSoftware.Windows.Controls.DockingDockGuideKinds
The dock guide kinds that are supported by this DraggedDockHost and dock Target combination.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsDragOverEventArgs Properties

The DockingWindowsDragOverEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AllowedDockGuideKinds | Gets or sets the dock guide kinds that are allowed by this DraggedDockHost and dock Target combination.
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | DraggedDockHost | Gets the DockHost that is being dragged, and that contains the Windows.
Public property | SupportedDockGuideKinds | Gets the dock guide kinds that are supported by this DraggedDockHost and dock Target combination.
Public property | Target | Gets the IDockTarget that the drag is over.
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event. (Inherited from DockingWindowsEventArgs.)
Top
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsDragOverEventArgs.AllowedDockGuideKinds Property

DockingWindowsDragOverEventArgsAllowedDockGuideKinds Property

Gets or sets the dock guide kinds that are allowed by this DraggedDockHost and dock Target combination.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideKinds AllowedDockGuideKinds { get; set; }
Public Property AllowedDockGuideKinds As DockGuideKinds
    Get
    Set

Property Value

Type: DockGuideKinds
The dock guide kinds that are allowed by this DraggedDockHost and dock Target combination.
Remarks
Remove dock guide kind flags from this property to prevent the related dock guide from showing.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsDragOverEventArgs.DraggedDockHost Property

DockingWindowsDragOverEventArgsDraggedDockHost Property

Gets the DockHost that is being dragged, and that contains the Windows.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost DraggedDockHost { get; }
Public ReadOnly Property DraggedDockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that is being dragged, and that contains the Windows.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsDragOverEventArgs.SupportedDockGuideKinds Property

DockingWindowsDragOverEventArgsSupportedDockGuideKinds Property

Gets the dock guide kinds that are supported by this DraggedDockHost and dock Target combination.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideKinds SupportedDockGuideKinds { get; }
Public ReadOnly Property SupportedDockGuideKinds As DockGuideKinds
    Get

Property Value

Type: DockGuideKinds
The dock guide kinds that are supported by this DraggedDockHost and dock Target combination.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace
DockingWindowsDragOverEventArgsAllowedDockGuideKinds


DockingWindowsDragOverEventArgs.Target Property

DockingWindowsDragOverEventArgsTarget Property

Gets the IDockTarget that the drag is over.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDockTarget Target { get; }
Public ReadOnly Property Target As IDockTarget
    Get

Property Value

Type: IDockTarget
The IDockTarget that the drag is over.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsEventArgs Class

Provides event arguments for DockingWindow-related events that deal with potentially muliple windows.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowsAutoHidingEventArgs
ActiproSoftware.Windows.Controls.DockingDockingWindowsDragOverEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowsEventArgs : CancelRoutedEventArgs
Public Class DockingWindowsEventArgs
    Inherits CancelRoutedEventArgs

The DockingWindowsEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowsEventArgs(DockHost) | Initializes a new instance of the DockingWindowsEventArgs class.
Public method | DockingWindowsEventArgs(IEnumerableDockingWindow) | Initializes a new instance of the DockingWindowsEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsEventArgs Constructor

Overload List
 | Name | Description
Public method | DockingWindowsEventArgs(DockHost) | Initializes a new instance of the DockingWindowsEventArgs class.
Public method | DockingWindowsEventArgs(IEnumerableDockingWindow) | Initializes a new instance of the DockingWindowsEventArgs class.
Top
See Also

Reference

DockingWindowsEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsEventArgs Constructor (DockHost)

Initializes a new instance of the DockingWindowsEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowsEventArgs(
    DockHost dockHost
)
Public Sub New (
    dockHost As DockHost
)

Parameters

dockHost
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The DockHost containing the DockingWindow controls that are the focus of this event.
See Also

Reference

DockingWindowsEventArgs Class
DockingWindowsEventArgs Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsEventArgs Constructor (IEnumerable(DockingWindow))

DockingWindowsEventArgs Constructor (IEnumerableDockingWindow)

Initializes a new instance of the DockingWindowsEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowsEventArgs(
    IEnumerable<DockingWindow> windows
)
Public Sub New (
    windows As IEnumerable(Of DockingWindow)
)

Parameters

windows
Type: System.Collections.GenericIEnumerable DockingWindow
The collection of DockingWindow controls that are the focus of this event.
See Also

Reference

DockingWindowsEventArgs Class
DockingWindowsEventArgs Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsEventArgs Properties

The DockingWindowsEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event.
Top
See Also

Reference

DockingWindowsEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowsEventArgs.Windows Property

DockingWindowsEventArgsWindows Property

Gets the collection of DockingWindow controls that are the focus of this event.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<DockingWindow> Windows { get; }
Public ReadOnly Property Windows As IEnumerable(Of DockingWindow)
    Get

Property Value

Type: IEnumerable DockingWindow
The collection of DockingWindow controls that are the focus of this event.
See Also

Reference

DockingWindowsEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockingWindowState Enumeration

Indicates the state for a DockingWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DockingWindowState
Public Enumeration DockingWindowState
Members
Member name | Value | Description
Docked | 0 | The window is docked in a container outside of the MDI (multiple document interface) area.
Document | 1 | The window is a document within the MDI (multiple document interface) area.
AutoHide | 2 | The window is auto-hidden in a container along the side of a dock host.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockSite Class

Represents a dock site, the root control for docking window host functionality.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.DockingDockSite

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockSite : Control, IDockTarget
Public Class DockSite
    Inherits Control
    Implements IDockTarget

The DockSite type exposes the following members.

Constructors
 | Name | Description
Public method | DockSite | Initializes an instance of the DockSite class.
Top
Properties
 | Name | Description
Public property | ActivateNextDocumentCommand | Gets the ICommand that can activate the next document.
Public property | ActivatePreviousDocumentCommand | Gets the ICommand that can activate the previous document.
Public property | ActivatePrimaryDocumentCommand | Gets the ICommand that can activate the primary document.
Public property | ActiveWindow | Gets the DockingWindow that is currently active.
Public property | AreDocumentWindowsDestroyedOnClose | Gets or sets whether document windows are automatically destroyed (removed from the DockSite) when closed.
Public property | AreNewTabsInsertedBeforeExistingTabs | Gets or sets whether new tabs are inserted before existing tabs when they are added, such as when dragging and attaching a tool window to an existing tool window container.
Public property | AutoHideBottomContainers | Gets the collection of ToolWindowContainer items that appear in the primary bottom auto-hide tabstrip.
Public property | AutoHideLeftContainers | Gets the collection of ToolWindowContainer items that appear in the primary left auto-hide tabstrip.
Public property | AutoHidePerContainer | Gets or sets whether auto-hide state toggles affect all the windows in the parent ToolWindowContainer.
Public property | AutoHidePopupCloseAnimationDuration | Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup close.
Public property | AutoHidePopupCloseDelay | Gets or sets the duration in milliseconds of the delay between when the pointer leaves an auto-hide popup and when the popup closes if the pointer has not moved back over the popup.
Public property | AutoHidePopupClosesOnLostFocus | Gets or sets whether the auto-hide popup closes when keyboard focus is moved outside of the popup.
Public property | AutoHidePopupOpenAnimationDuration | Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup open.
Public property | AutoHidePopupOpenDelay | Gets or sets the duration in milliseconds of the delay between when the pointer moves over an auto-hide tab item and the auto-hide popup opens to display the tool window represented by the tab item.
Public property | AutoHidePopupOpensOnMouseHover | Gets or sets whether the auto-hide popup displays when the mouse hovers over an auto-hide tab item.
Public property | AutoHideRightContainers | Gets the collection of ToolWindowContainer items that appear in the primary right auto-hide tabstrip.
Public property | AutoHideTabItemTemplate | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
Public property | AutoHideTabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.
Public property | AutoHideTopContainers | Gets the collection of ToolWindowContainer items that appear in the primary top auto-hide tabstrip.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanDocumentWindowsClose | Gets or sets the global setting for whether document windows can be closed.
Public property | CanDocumentWindowsDragToLinkedDockSites | Gets or sets the global setting for whether document windows may be dragged to a linked DockSite.
Public property | CanDocumentWindowsFloat | Gets or sets the global setting for whether document windows may be contained in a floating window.
Public property | CanFloatingDockHostsHideOnDockSiteUnload | Gets or sets whether FloatingDockHosts should hide when the DockSite is unloaded, such as in nested DockSite scenarios when the parent tab is deselected.
Public property | CanToolWindowsAttach | Gets or sets the global setting for whether tool windows may be attached to another tool window, creating a tabbed grouping.
Public property | CanToolWindowsAutoHide | Gets or sets the global setting for whether tool windows may be placed in auto-hide mode.
Public property | CanToolWindowsBecomeDocuments | Gets or sets the global setting for whether tool windows may be placed in a document state.
Public property | CanToolWindowsClose | Gets or sets the global setting for whether tool windows can be closed.
Public property | CanToolWindowsCloseOnMiddleClick | Gets or sets a value indicating whether tool windows can be closed by clicking the tab with the middle mouse button.
Public property | CanToolWindowsDock | Gets or sets the global setting for whether tool windows can be docked.
Public property | CanToolWindowsDragToFloatingDockHostsWithWorkspaces | Gets or sets the whether tool windows may be dragged to floating dock hosts that contain a workspace.
Public property | CanToolWindowsDragToLinkedDockSites | Gets or sets the global setting for whether tool windows may be dragged to a linked DockSite.
Public property | CanToolWindowsFloat | Gets or sets the global setting for whether tool windows may be floated into separate top-level containers.
Public property | CanToolWindowTabsDrag | Gets or sets the global setting for whether tool window tabs may be dragged to another location.
Public property | CanUpdateItemsSourceOnUnregister | Gets or sets whether to try and remove an item from its items source when the related container DockingWindow is unregistered.
Public property | CascadeDocumentsCommand | Gets the ICommand that can cascade the open documents.
Public property | Child | Gets or sets the FrameworkElement that is the child content of this dock site.
Public property | CloseAllDocumentsCommand | Gets the ICommand that can close all open documents.
Public property | ClosePerContainer | Gets or sets whether close operations affect all the windows in the parent ToolWindowContainer.
Public property | ClosePrimaryDocumentCommand | Gets the ICommand that can close the primary document.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DocumentItemContainerStyle | Gets or sets the Style that is applied to the container DockingWindow generated for each document item.
Public property | DocumentItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.
Public property | DocumentItemsSource | Gets or sets a collection used to generate document windows for use in the DockSite.
Public property | DocumentItemTemplate | Gets or sets the DataTemplate used to display each document item.
Public property | DocumentItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each document item.
Public property | Documents | Gets the collection of DockingWindow controls that are currently open in the MDI area.
Public property | DocumentWindows | Gets the DocumentWindowCollection of document windows that are currently registered with the DockSite.
Public property | FloatingDockHosts | Gets the collection of floating dock hosts, which are those that are top-level and external to the DockSite hierarchy's primary dock host.
Public property | FloatingToolWindowContainersHaveMaximizeButtons | Gets or sets whether floating ToolWindowContainer controls can have title bar maximize buttons.
Public property | FloatingToolWindowContainersHaveMinimizeButtons | Gets or sets whether floating ToolWindowContainer controls can have title bar minimize buttons.
Public property | FloatingWindowIcon | Gets or sets the ImageSource for floating window icons, which should be set if document windows are allowed to float.
Public property | FloatingWindowShowInTaskBarMode | Gets or sets a mode that determines when to show floating windows in the taskbar.
Public property | FloatingWindowSnapToScreenThreshold | Gets or sets the minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen.
Public property | FloatingWindowTitle | Gets or sets the title text for floating windows, which should be set if document windows are allowed to float..
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasDocuments | Gets whether the DockSite currently has any open documents.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HostedFloatingWindowContainer | Gets or sets the FrameworkElement whose bounds should be used to restrict the movement of hosted floating windows. The FrameworkElement must be the DockSite or one of it's visual ancestors.
Public property | InactiveFloatingWindowFadeDelay | Gets or sets the duration in milliseconds of inactivity that must take place for a hosted floating window before it starts to fade out.
Public property | InactiveFloatingWindowFadeDuration | Gets or sets the duration in milliseconds over which an inactive hosted floating window will fade.
Public property | InactiveFloatingWindowFadeOpacity | Gets or sets the target opacity to which inactive hosted floating windows to fade.
Public property | IsDockGuideAnimationEnabled | Gets or sets whether dock guide animation is enabled.
Public property | IsFloatingWindowSnapToScreenEnabled | Gets or sets whether floating windows are snapped onto the closest screen when displayed via a method other than being dragged.
Public property | IsInactiveFloatingWindowFadeEnabled | Gets or sets whether hosted floating windows will fade out following inactivity.
Public property | IsLiveSplittingEnabled | Gets or sets whether live splitting of docking windows is enabled.
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects are applied during tab layout, such as when tabs are added or removed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LinkedDockSites | Gets the linked DockSites, to which registered docking windows can be docked into.
Public property | MagnetismGapDistance | Gets or sets the distance between windows that are snapped together via magnetism.
Public property | MagnetismSnapDistance | Gets or sets the distance at which magnetism begins to snap windows being dragged.
Public property | MdiKind | Gets or sets the kind of MDI currently in use.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryDockHost | Gets the primary dock host, which is the one that is implicitly created within the DockSite's template.
Public property | PrimaryDocument | Gets the DockingWindow that currently is the primary document in the dock site.
Public property | SetMdiKindCommand | Gets the ICommand that can set the MDI kind to the MdiKind enumeration value specified in the command parameter.
Public property | SplitterSize | Gets or sets the size of splitters.
Public property | Switcher | Gets or sets the SwitcherBase that will be used to provide Ctrl+Tab window switching capabilities.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TileDocumentsHorizontallyCommand | Gets the ICommand that can tile the open documents horizontally.
Public property | TileDocumentsVerticallyCommand | Gets the ICommand that can tile the open documents vertically.
Public property | ToolItemContainerStyle | Gets or sets the Style that is applied to the container DockingWindow generated for each tool item.
Public property | ToolItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.
Public property | ToolItemsSource | Gets or sets a collection used to generate tool windows for use in the DockSite.
Public property | ToolItemTemplate | Gets or sets the DataTemplate used to display each tool item.
Public property | ToolItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each tool item.
Public property | ToolWindows | Gets the ToolWindowCollection of tool windows that are currently registered with the DockSite.
Public property | ToolWindowsHaveCloseButtons | Gets or sets whether ToolWindowContainer controls can have title bar close buttons.
Public property | ToolWindowsHaveOptionsButtons | Gets or sets whether ToolWindowContainer controls can have title bar options buttons.
Public property | ToolWindowsHaveTabImages | Gets or sets the global setting for whether tool windows have images on tabs.
Public property | ToolWindowsHaveTitleBarIcons | Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window.
Public property | ToolWindowsHaveTitleBars | Gets or sets the global setting for whether tool windows display a title bar when not in MDI.
Public property | ToolWindowsHaveToggleAutoHideButtons | Gets or sets whether ToolWindowContainer controls can have title bar toggle auto-hide buttons.
Public property | ToolWindowsSingleTabLayoutBehavior | Gets or sets the global setting for the behavior used when a single tool window is in a container.
Public property | ToolWindowsTabOverflowBehavior | Gets or sets the global setting for the overflow behavior of the tool window tabs.
Public property | ToolWindowsTabStripPlacement | Gets or sets a Side indicating the side upon which the tool window tabs are located.
Public property | ToolWindowsTitleBarContextContentAlignment | Gets or sets the alignment of tool window container title bar context content.
Public property | ToolWindowTabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers in a ToolWindowContainer.
Public property | UseDragFloatPreviews | Gets or sets whether to use float previews when dragging windows instead of instantly creating floating windows.
Public property | UseHostedFloatingWindows | Gets or sets whether floating windows should be hosted within the bounds of the dock site.
Public property | UseHostedPopups | Gets or sets whether popups should be hosted within the bounds of the dock site.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | ActivateNextDocument | Activates the next document by selecting it and focusing its content.
Public method | ActivatePreviousDocument | Activates the previous document by selecting it and focusing its content.
Public method | ActivatePrimaryDocument | Activates the primary document by focusing its content.
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
 | ApplyContainerStyle | Applies the style of the specified container window.
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CascadeDocuments | Cascades all open documents, if using tabbed or standard MDI.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DockingWindow, Object, DockingWindowItemKind) method.
Public method | CloseAllDocuments | Closes all open documents.
Public method | ClosePrimaryDocument | Closes the primary document.
Public method | ContainerFromDocumentItem | Returns the DocumentWindow corresponding to the given item contained in DocumentItemsSource.
Public method | ContainerFromItem | Returns the DockingWindow corresponding to the given item contained in DocumentItemsSource or ToolItemsSource.
Public method | ContainerFromToolItem | Returns the ToolWindow corresponding to the given item contained in ToolItemsSource.
Public method | DockSiteRegistryConstructor | Initializes a new instance of the DockSite class.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the DockingWindow that is used to display the given item.
Protected method | InitializeAutoHidePopupWindow | Initializes a Window that contains an auto-hide popup.
Protected method | InitializeDockingAdornmentWindow | Initializes a Window that can host dock guide and dock preview adornments during a docking operation.
Protected method | InitializeFloatingWindow | Initializes a Window that contains a floating DockHost.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container.
Public method | LinkDockSite | Links this DockSite to the specified DockSite and vice versa, allowing docking windows to be seamlessly moved between the dock sites.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDocumentItemsSourceChanged | Called when the DocumentItemsSource property changes.
Protected method | OnFloatingWindowOpening | Occurs when a floating window is opening, allowing for customization before it is displayed.
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnInitialized | Occurs when the control is initialized. (Overrides FrameworkElementOnInitialized(EventArgs).)
Protected method | OnMdiKindChanged | Occurs when the MdiKind property is changed.
Protected method | OnMenuOpening | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnNewWindowRequested | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPrimaryDocumentChanged | Occurs when the PrimaryDocument property has changed.
Protected method | OnPropertyChanged | Occurs when a property is changed. (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnToolItemsSourceChanged | Called when the ToolItemsSource property changes.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnWindowActivated | Occurs after a DockingWindow has been activated.
Protected method | OnWindowAutoHidePopupClosed | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
Protected method | OnWindowAutoHidePopupOpened | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
Protected method | OnWindowDeactivated | Occurs after a DockingWindow has been deactivated.
Protected method | OnWindowDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Protected method | OnWindowRegistered | Occurs after a DockingWindow has been registered.
Protected method | OnWindowsAutoHiding | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
Protected method | OnWindowsClosed | Occurs after one or more DockingWindow controls have been closed.
Protected method | OnWindowsClosing | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
Protected method | OnWindowsDockHostChanged | Occurs after one or more DockingWindow controls' DockHost properties have changed.
Protected method | OnWindowsDragged | Occurs after one or more DockingWindow controls are dragged by the end user.
Protected method | OnWindowsDragging | Occurs before one or more DockingWindow controls are dragged by the end user.
Protected method | OnWindowsDragOver | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
Protected method | OnWindowsOpened | Occurs after one or more DockingWindow controls have been opened.
Protected method | OnWindowsOpening | Occurs before one or more DockingWindow controls is opened.
Protected method | OnWindowsStateChanged | Occurs after one or more DockingWindow controls' states have changed.
Protected method | OnWindowUnregistered | Occurs after a DockingWindow has been unregistered.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified DockingWindow to display the specified item.
Protected method | ProcessDockHostKeyDown | Processes a key down event from a dock host.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TileDocumentsHorizontally | Tiles all open documents horizontally, if using tabbed or standard MDI.
Public method | TileDocumentsVertically | Tiles all open documents vertically, if using tabbed or standard MDI.
Public method | ToHierarchyString | Creates a string that contains a textual representation of the dock site hierarchy, useful for debugging purposes.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnlinkDockSite | Unlinks this DockSite from the specified DockSite and vice versa.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | FloatingWindowOpening | Occurs when a floating window is opening, allowing for customization before it is displayed.
Public event | MdiKindChanged | Occurs when the MdiKind property is changed.
Public event | MenuOpening | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | NewWindowRequested | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PrimaryDocumentChanged | Occurs when the PrimaryDocument property has changed.
Public event | WindowActivated | Occurs after a DockingWindow has been activated.
Public event | WindowAutoHidePopupClosed | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
Public event | WindowAutoHidePopupOpened | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
Public event | WindowDeactivated | Occurs after a DockingWindow has been deactivated.
Public event | WindowDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Public event | WindowRegistered | Occurs after a DockingWindow has been registered.
Public event | WindowsAutoHiding | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
Public event | WindowsClosed | Occurs after one or more DockingWindow controls have been closed.
Public event | WindowsClosing | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
Public event | WindowsDockHostChanged | Occurs after one or more DockingWindow controls' DockHost properties have changed.
Public event | WindowsDragged | Occurs after one or more DockingWindow controls are dragged by the end user.
Public event | WindowsDragging | Occurs before one or more DockingWindow controls are dragged by the end user.
Public event | WindowsDragOver | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
Public event | WindowsOpened | Occurs after one or more DockingWindow controls have been opened.
Public event | WindowsOpening | Occurs before one or more DockingWindow controls is opened.
Public event | WindowsStateChanged | Occurs after one or more DockingWindow controls' states have changed.
Public event | WindowUnregistered | Occurs after a DockingWindow has been unregistered.
Top
Fields
Name | Description
ActiveWindowProperty | Identifies the ActiveWindow dependency property. This field is read-only.
AreDocumentWindowsDestroyedOnCloseProperty | Identifies the AreDocumentWindowsDestroyedOnClose dependency property. This field is read-only.
AreNewTabsInsertedBeforeExistingTabsProperty | Identifies the AreNewTabsInsertedBeforeExistingTabs dependency property. This field is read-only.
AutoHidePerContainerProperty | Identifies the AutoHidePerContainer dependency property. This field is read-only.
AutoHidePopupCloseAnimationDurationProperty | Identifies the AutoHidePopupCloseAnimationDuration dependency property. This field is read-only.
AutoHidePopupCloseDelayProperty | Identifies the AutoHidePopupCloseDelay dependency property. This field is read-only.
AutoHidePopupClosesOnLostFocusProperty | Identifies the AutoHidePopupClosesOnLostFocus dependency property. This field is read-only.
AutoHidePopupOpenAnimationDurationProperty | Identifies the AutoHidePopupOpenAnimationDuration dependency property. This field is read-only.
AutoHidePopupOpenDelayProperty | Identifies the AutoHidePopupOpenDelay dependency property. This field is read-only.
AutoHidePopupOpensOnMouseHoverProperty | Identifies the AutoHidePopupOpensOnMouseHover dependency property. This field is read-only.
AutoHideTabItemTemplateProperty | Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.
AutoHideTabItemTemplateSelectorProperty | Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.
CanDocumentWindowsCloseProperty | Identifies the CanDocumentWindowsClose dependency property. This field is read-only.
CanDocumentWindowsDragToLinkedDockSitesProperty | Identifies the CanDocumentWindowsDragToLinkedDockSites dependency property. This field is read-only.
CanDocumentWindowsFloatProperty | Identifies the CanDocumentWindowsFloat dependency property. This field is read-only.
CanFloatingDockHostsHideOnDockSiteUnloadProperty | Identifies the CanFloatingDockHostsHideOnDockSiteUnload dependency property. This field is read-only.
CanToolWindowsAttachProperty | Identifies the CanToolWindowsAttach dependency property. This field is read-only.
CanToolWindowsAutoHideProperty | Identifies the CanToolWindowsAutoHide dependency property. This field is read-only.
CanToolWindowsBecomeDocumentsProperty | Identifies the CanToolWindowsBecomeDocuments dependency property. This field is read-only.
CanToolWindowsCloseOnMiddleClickProperty | Identifies the CanToolWindowsCloseOnMiddleClick dependency property. This field is read-only.
CanToolWindowsCloseProperty | Identifies the CanToolWindowsClose dependency property. This field is read-only.
CanToolWindowsDockProperty | Identifies the CanToolWindowsDock dependency property. This field is read-only.
CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty | Identifies the CanToolWindowsDragToFloatingDockHostsWithWorkspaces dependency property. This field is read-only.
CanToolWindowsDragToLinkedDockSitesProperty | Identifies the CanToolWindowsDragToLinkedDockSites dependency property. This field is read-only.
CanToolWindowsFloatProperty | Identifies the CanToolWindowsFloat dependency property. This field is read-only.
CanToolWindowTabsDragProperty | Identifies the CanToolWindowTabsDrag dependency property. This field is read-only.
CanUpdateItemsSourceOnUnregisterProperty | Identifies the CanUpdateItemsSourceOnUnregister dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
ClosePerContainerProperty | Identifies the ClosePerContainer dependency property. This field is read-only.
DocumentItemContainerStyleProperty | Identifies the DocumentItemContainerStyle dependency property. This field is read-only.
DocumentItemContainerStyleSelectorProperty | Identifies the DocumentItemContainerStyleSelector dependency property. This field is read-only.
DocumentItemsSourceProperty | Identifies the DocumentItemsSource dependency property. This field is read-only.
DocumentItemTemplateProperty | Identifies the DocumentItemTemplate dependency property. This field is read-only.
DocumentItemTemplateSelectorProperty | Identifies the DocumentItemTemplateSelector dependency property. This field is read-only.
FloatingToolWindowContainersHaveMaximizeButtonsProperty | Identifies the FloatingToolWindowContainersHaveMaximizeButtons dependency property. This field is read-only.
FloatingToolWindowContainersHaveMinimizeButtonsProperty | Identifies the FloatingToolWindowContainersHaveMinimizeButtons dependency property. This field is read-only.
FloatingWindowIconProperty | Identifies the FloatingWindowIcon dependency property. This field is read-only.
FloatingWindowOpeningEvent | Identifies the FloatingWindowOpening routed event. This field is read-only.
FloatingWindowShowInTaskBarModeProperty | Identifies the FloatingWindowShowInTaskBarMode dependency property. This field is read-only.
FloatingWindowSnapToScreenThresholdProperty | Identifies the FloatingWindowSnapToScreenThreshold dependency property. This field is read-only.
FloatingWindowTitleProperty | Identifies the FloatingWindowTitle dependency property. This field is read-only.
HostedFloatingWindowContainerProperty | Identifies the HostedFloatingWindowContainer dependency property. This field is read-only.
InactiveFloatingWindowFadeDelayProperty | Identifies the InactiveFloatingWindowFadeDelay dependency property. This field is read-only.
InactiveFloatingWindowFadeDurationProperty | Identifies the InactiveFloatingWindowFadeDuration dependency property. This field is read-only.
InactiveFloatingWindowFadeOpacityProperty | Identifies the InactiveFloatingWindowFadeOpacity dependency property. This field is read-only.
IsDockGuideAnimationEnabledProperty | Identifies the IsDockGuideAnimationEnabled dependency property. This field is read-only.
IsFloatingWindowSnapToScreenEnabledProperty | Identifies the IsFloatingWindowSnapToScreenEnabled dependency property. This field is read-only.
IsInactiveFloatingWindowFadeEnabledProperty | Identifies the IsInactiveFloatingWindowFadeEnabled dependency property. This field is read-only.
IsLiveSplittingEnabledProperty | Identifies the IsLiveSplittingEnabled dependency property. This field is read-only.
IsTabLayoutAnimationEnabledProperty | Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.
MagnetismGapDistanceProperty | Identifies the MagnetismGapDistance dependency property. This field is read-only.
MagnetismSnapDistanceProperty | Identifies the MagnetismSnapDistance dependency property. This field is read-only.
MdiKindChangedEvent | Identifies the MdiKindChanged routed event. This field is read-only.
MdiKindProperty | Identifies the MdiKind dependency property. This field is read-only.
MenuOpeningEvent | Identifies the MenuOpening routed event. This field is read-only.
NewWindowRequestedEvent | Identifies the NewWindowRequested routed event. This field is read-only.
PrimaryDocumentChangedEvent | Identifies the PrimaryDocumentChanged routed event. This field is read-only.
PrimaryDocumentProperty | Identifies the PrimaryDocument dependency property. This field is read-only.
SplitterSizeProperty | Identifies the SplitterSize dependency property. This field is read-only.
SwitcherProperty | Identifies the Switcher dependency property. This field is read-only.
ToolItemContainerStyleProperty | Identifies the ToolItemContainerStyle dependency property. This field is read-only.
ToolItemContainerStyleSelectorProperty | Identifies the ToolItemContainerStyleSelector dependency property. This field is read-only.
ToolItemsSourceProperty | Identifies the ToolItemsSource dependency property. This field is read-only.
ToolItemTemplateProperty | Identifies the ToolItemTemplate dependency property. This field is read-only.
ToolItemTemplateSelectorProperty | Identifies the ToolItemTemplateSelector dependency property. This field is read-only.
ToolWindowsHaveCloseButtonsProperty | Identifies the ToolWindowsHaveCloseButtons dependency property. This field is read-only.
ToolWindowsHaveOptionsButtonsProperty | Identifies the ToolWindowsHaveOptionsButtons dependency property. This field is read-only.
ToolWindowsHaveTabImagesProperty | Identifies the ToolWindowsHaveTabImages dependency property. This field is read-only.
ToolWindowsHaveTitleBarIconsProperty | Identifies the ToolWindowsHaveTitleBarIcons dependency property. This field is read-only.
ToolWindowsHaveTitleBarsProperty | Identifies the ToolWindowsHaveTitleBars dependency property. This field is read-only.
ToolWindowsHaveToggleAutoHideButtonsProperty | Identifies the ToolWindowsHaveToggleAutoHideButtons dependency property. This field is read-only.
ToolWindowsSingleTabLayoutBehaviorProperty | Identifies the ToolWindowsSingleTabLayoutBehavior dependency property. This field is read-only.
ToolWindowsTabOverflowBehaviorProperty | Identifies the ToolWindowsTabOverflowBehavior dependency property. This field is read-only.
ToolWindowsTabStripPlacementProperty | Identifies the ToolWindowsTabStripPlacement dependency property. This field is read-only.
ToolWindowsTitleBarContextContentAlignmentProperty | Identifies the ToolWindowsTitleBarContextContentAlignment dependency property. This field is read-only.
ToolWindowTabItemContainerStyleProperty | Identifies the ToolWindowTabItemContainerStyle dependency property. This field is read-only.
UseDragFloatPreviewsProperty | Identifies the UseDragFloatPreviews dependency property. This field is read-only.
UseHostedFloatingWindowsProperty | Identifies the UseHostedFloatingWindows dependency property. This field is read-only.
UseHostedPopupsProperty | Identifies the UseHostedPopups dependency property. This field is read-only.
WindowActivatedEvent | Identifies the WindowActivated routed event. This field is read-only.
WindowAutoHidePopupClosedEvent | Identifies the WindowAutoHidePopupClosed routed event. This field is read-only.
WindowAutoHidePopupOpenedEvent | Identifies the WindowAutoHidePopupOpened routed event. This field is read-only.
WindowDeactivatedEvent | Identifies the WindowDeactivated routed event. This field is read-only.
WindowDefaultLocationRequestedEvent | Identifies the WindowDefaultLocationRequested routed event. This field is read-only.
WindowRegisteredEvent | Identifies the WindowRegistered routed event. This field is read-only.
WindowsAutoHidingEvent | Identifies the WindowsAutoHiding routed event. This field is read-only.
WindowsClosedEvent | Identifies the WindowsClosed routed event. This field is read-only.
WindowsClosingEvent | Identifies the WindowsClosing routed event. This field is read-only.
WindowsDockHostChangedEvent | Identifies the WindowsDockHostChanged routed event. This field is read-only.
WindowsDraggedEvent | Identifies the WindowsDragged routed event. This field is read-only.
WindowsDraggingEvent | Identifies the WindowsDragging routed event. This field is read-only.
WindowsDragOverEvent | Identifies the WindowsDragOver routed event. This field is read-only.
WindowsOpenedEvent | Identifies the WindowsOpened routed event. This field is read-only.
WindowsOpeningEvent | Identifies the WindowsOpening routed event. This field is read-only.
WindowsStateChangedEvent | Identifies the WindowsStateChanged routed event. This field is read-only.
WindowUnregisteredEvent | Identifies the WindowUnregistered routed event. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DockSite Constructor

Initializes an instance of the DockSite class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite()
Public Sub New
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite Properties

The DockSite type exposes the following members.

Properties
 | Name | Description
Public property | ActivateNextDocumentCommand | Gets the ICommand that can activate the next document.
Public property | ActivatePreviousDocumentCommand | Gets the ICommand that can activate the previous document.
Public property | ActivatePrimaryDocumentCommand | Gets the ICommand that can activate the primary document.
Public property | ActiveWindow | Gets the DockingWindow that is currently active.
Public property | AreDocumentWindowsDestroyedOnClose | Gets or sets whether document windows are automatically destroyed (removed from the DockSite) when closed.
Public property | AreNewTabsInsertedBeforeExistingTabs | Gets or sets whether new tabs are inserted before existing tabs when they are added, such as when dragging and attaching a tool window to an existing tool window container.
Public property | AutoHideBottomContainers | Gets the collection of ToolWindowContainer items that appear in the primary bottom auto-hide tabstrip.
Public property | AutoHideLeftContainers | Gets the collection of ToolWindowContainer items that appear in the primary left auto-hide tabstrip.
Public property | AutoHidePerContainer | Gets or sets whether auto-hide state toggles affect all the windows in the parent ToolWindowContainer.
Public property | AutoHidePopupCloseAnimationDuration | Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup close.
Public property | AutoHidePopupCloseDelay | Gets or sets the duration in milliseconds of the delay between when the pointer leaves an auto-hide popup and when the popup closes if the pointer has not moved back over the popup.
Public property | AutoHidePopupClosesOnLostFocus | Gets or sets whether the auto-hide popup closes when keyboard focus is moved outside of the popup.
Public property | AutoHidePopupOpenAnimationDuration | Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup open.
Public property | AutoHidePopupOpenDelay | Gets or sets the duration in milliseconds of the delay between when the pointer moves over an auto-hide tab item and the auto-hide popup opens to display the tool window represented by the tab item.
Public property | AutoHidePopupOpensOnMouseHover | Gets or sets whether the auto-hide popup displays when the mouse hovers over an auto-hide tab item.
Public property | AutoHideRightContainers | Gets the collection of ToolWindowContainer items that appear in the primary right auto-hide tabstrip.
Public property | AutoHideTabItemTemplate | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
Public property | AutoHideTabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.
Public property | AutoHideTopContainers | Gets the collection of ToolWindowContainer items that appear in the primary top auto-hide tabstrip.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanDocumentWindowsClose | Gets or sets the global setting for whether document windows can be closed.
Public property | CanDocumentWindowsDragToLinkedDockSites | Gets or sets the global setting for whether document windows may be dragged to a linked DockSite.
Public property | CanDocumentWindowsFloat | Gets or sets the global setting for whether document windows may be contained in a floating window.
Public property | CanFloatingDockHostsHideOnDockSiteUnload | Gets or sets whether FloatingDockHosts should hide when the DockSite is unloaded, such as in nested DockSite scenarios when the parent tab is deselected.
Public property | CanToolWindowsAttach | Gets or sets the global setting for whether tool windows may be attached to another tool window, creating a tabbed grouping.
Public property | CanToolWindowsAutoHide | Gets or sets the global setting for whether tool windows may be placed in auto-hide mode.
Public property | CanToolWindowsBecomeDocuments | Gets or sets the global setting for whether tool windows may be placed in a document state.
Public property | CanToolWindowsClose | Gets or sets the global setting for whether tool windows can be closed.
Public property | CanToolWindowsCloseOnMiddleClick | Gets or sets a value indicating whether tool windows can be closed by clicking the tab with the middle mouse button.
Public property | CanToolWindowsDock | Gets or sets the global setting for whether tool windows can be docked.
Public property | CanToolWindowsDragToFloatingDockHostsWithWorkspaces | Gets or sets the whether tool windows may be dragged to floating dock hosts that contain a workspace.
Public property | CanToolWindowsDragToLinkedDockSites | Gets or sets the global setting for whether tool windows may be dragged to a linked DockSite.
Public property | CanToolWindowsFloat | Gets or sets the global setting for whether tool windows may be floated into separate top-level containers.
Public property | CanToolWindowTabsDrag | Gets or sets the global setting for whether tool window tabs may be dragged to another location.
Public property | CanUpdateItemsSourceOnUnregister | Gets or sets whether to try and remove an item from its items source when the related container DockingWindow is unregistered.
Public property | CascadeDocumentsCommand | Gets the ICommand that can cascade the open documents.
Public property | Child | Gets or sets the FrameworkElement that is the child content of this dock site.
Public property | CloseAllDocumentsCommand | Gets the ICommand that can close all open documents.
Public property | ClosePerContainer | Gets or sets whether close operations affect all the windows in the parent ToolWindowContainer.
Public property | ClosePrimaryDocumentCommand | Gets the ICommand that can close the primary document.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DocumentItemContainerStyle | Gets or sets the Style that is applied to the container DockingWindow generated for each document item.
Public property | DocumentItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.
Public property | DocumentItemsSource | Gets or sets a collection used to generate document windows for use in the DockSite.
Public property | DocumentItemTemplate | Gets or sets the DataTemplate used to display each document item.
Public property | DocumentItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each document item.
Public property | Documents | Gets the collection of DockingWindow controls that are currently open in the MDI area.
Public property | DocumentWindows | Gets the DocumentWindowCollection of document windows that are currently registered with the DockSite.
Public property | FloatingDockHosts | Gets the collection of floating dock hosts, which are those that are top-level and external to the DockSite hierarchy's primary dock host.
Public property | FloatingToolWindowContainersHaveMaximizeButtons | Gets or sets whether floating ToolWindowContainer controls can have title bar maximize buttons.
Public property | FloatingToolWindowContainersHaveMinimizeButtons | Gets or sets whether floating ToolWindowContainer controls can have title bar minimize buttons.
Public property | FloatingWindowIcon | Gets or sets the ImageSource for floating window icons, which should be set if document windows are allowed to float.
Public property | FloatingWindowShowInTaskBarMode | Gets or sets a mode that determines when to show floating windows in the taskbar.
Public property | FloatingWindowSnapToScreenThreshold | Gets or sets the minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen.
Public property | FloatingWindowTitle | Gets or sets the title text for floating windows, which should be set if document windows are allowed to float..
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasDocuments | Gets whether the DockSite currently has any open documents.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HostedFloatingWindowContainer | Gets or sets the FrameworkElement whose bounds should be used to restrict the movement of hosted floating windows. The FrameworkElement must be the DockSite or one of it's visual ancestors.
Public property | InactiveFloatingWindowFadeDelay | Gets or sets the duration in milliseconds of inactivity that must take place for a hosted floating window before it starts to fade out.
Public property | InactiveFloatingWindowFadeDuration | Gets or sets the duration in milliseconds over which an inactive hosted floating window will fade.
Public property | InactiveFloatingWindowFadeOpacity | Gets or sets the target opacity to which inactive hosted floating windows to fade.
Public property | IsDockGuideAnimationEnabled | Gets or sets whether dock guide animation is enabled.
Public property | IsFloatingWindowSnapToScreenEnabled | Gets or sets whether floating windows are snapped onto the closest screen when displayed via a method other than being dragged.
Public property | IsInactiveFloatingWindowFadeEnabled | Gets or sets whether hosted floating windows will fade out following inactivity.
Public property | IsLiveSplittingEnabled | Gets or sets whether live splitting of docking windows is enabled.
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects are applied during tab layout, such as when tabs are added or removed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LinkedDockSites | Gets the linked DockSites, to which registered docking windows can be docked into.
Public property | MagnetismGapDistance | Gets or sets the distance between windows that are snapped together via magnetism.
Public property | MagnetismSnapDistance | Gets or sets the distance at which magnetism begins to snap windows being dragged.
Public property | MdiKind | Gets or sets the kind of MDI currently in use.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryDockHost | Gets the primary dock host, which is the one that is implicitly created within the DockSite's template.
Public property | PrimaryDocument | Gets the DockingWindow that currently is the primary document in the dock site.
Public property | SetMdiKindCommand | Gets the ICommand that can set the MDI kind to the MdiKind enumeration value specified in the command parameter.
Public property | SplitterSize | Gets or sets the size of splitters.
Public property | Switcher | Gets or sets the SwitcherBase that will be used to provide Ctrl+Tab window switching capabilities.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TileDocumentsHorizontallyCommand | Gets the ICommand that can tile the open documents horizontally.
Public property | TileDocumentsVerticallyCommand | Gets the ICommand that can tile the open documents vertically.
Public property | ToolItemContainerStyle | Gets or sets the Style that is applied to the container DockingWindow generated for each tool item.
Public property | ToolItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.
Public property | ToolItemsSource | Gets or sets a collection used to generate tool windows for use in the DockSite.
Public property | ToolItemTemplate | Gets or sets the DataTemplate used to display each tool item.
Public property | ToolItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each tool item.
Public property | ToolWindows | Gets the ToolWindowCollection of tool windows that are currently registered with the DockSite.
Public property | ToolWindowsHaveCloseButtons | Gets or sets whether ToolWindowContainer controls can have title bar close buttons.
Public property | ToolWindowsHaveOptionsButtons | Gets or sets whether ToolWindowContainer controls can have title bar options buttons.
Public property | ToolWindowsHaveTabImages | Gets or sets the global setting for whether tool windows have images on tabs.
Public property | ToolWindowsHaveTitleBarIcons | Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window.
Public property | ToolWindowsHaveTitleBars | Gets or sets the global setting for whether tool windows display a title bar when not in MDI.
Public property | ToolWindowsHaveToggleAutoHideButtons | Gets or sets whether ToolWindowContainer controls can have title bar toggle auto-hide buttons.
Public property | ToolWindowsSingleTabLayoutBehavior | Gets or sets the global setting for the behavior used when a single tool window is in a container.
Public property | ToolWindowsTabOverflowBehavior | Gets or sets the global setting for the overflow behavior of the tool window tabs.
Public property | ToolWindowsTabStripPlacement | Gets or sets a Side indicating the side upon which the tool window tabs are located.
Public property | ToolWindowsTitleBarContextContentAlignment | Gets or sets the alignment of tool window container title bar context content.
Public property | ToolWindowTabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers in a ToolWindowContainer.
Public property | UseDragFloatPreviews | Gets or sets whether to use float previews when dragging windows instead of instantly creating floating windows.
Public property | UseHostedFloatingWindows | Gets or sets whether floating windows should be hosted within the bounds of the dock site.
Public property | UseHostedPopups | Gets or sets whether popups should be hosted within the bounds of the dock site.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ActivateNextDocumentCommand Property

DockSiteActivateNextDocumentCommand Property

Gets the ICommand that can activate the next document.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ActivateNextDocumentCommand { get; }
Public ReadOnly Property ActivateNextDocumentCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can activate the next document.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ActivatePreviousDocumentCommand Property

DockSiteActivatePreviousDocumentCommand Property

Gets the ICommand that can activate the previous document.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ActivatePreviousDocumentCommand { get; }
Public ReadOnly Property ActivatePreviousDocumentCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can activate the previous document.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ActivatePrimaryDocumentCommand Property

DockSiteActivatePrimaryDocumentCommand Property

Gets the ICommand that can activate the primary document.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ActivatePrimaryDocumentCommand { get; }
Public ReadOnly Property ActivatePrimaryDocumentCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can activate the primary document.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ActiveWindow Property

DockSiteActiveWindow Property

Gets the DockingWindow that is currently active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindow ActiveWindow { get; }
Public ReadOnly Property ActiveWindow As DockingWindow
    Get

Property Value

Type: DockingWindow
The DockingWindow that is currently active.
Remarks
Only one docking window can be active at any given time.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AreDocumentWindowsDestroyedOnClose Property

DockSiteAreDocumentWindowsDestroyedOnClose Property

Gets or sets whether document windows are automatically destroyed (removed from the DockSite) when closed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreDocumentWindowsDestroyedOnClose { get; set; }
Public Property AreDocumentWindowsDestroyedOnClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document windows are automatically destroyed (removed from the DockSite) when closed; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AreNewTabsInsertedBeforeExistingTabs Property

DockSiteAreNewTabsInsertedBeforeExistingTabs Property

Gets or sets whether new tabs are inserted before existing tabs when they are added, such as when dragging and attaching a tool window to an existing tool window container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreNewTabsInsertedBeforeExistingTabs { get; set; }
Public Property AreNewTabsInsertedBeforeExistingTabs As Boolean
    Get
    Set

Property Value

Type: Boolean
true if new tabs are inserted before existing tabs when they are added; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHideBottomContainers Property

DockSiteAutoHideBottomContainers Property

Gets the collection of ToolWindowContainer items that appear in the primary bottom auto-hide tabstrip.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideBottomContainers { get; }
Public ReadOnly Property AutoHideBottomContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the primary bottom auto-hide tabstrip.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHideLeftContainers Property

DockSiteAutoHideLeftContainers Property

Gets the collection of ToolWindowContainer items that appear in the primary left auto-hide tabstrip.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideLeftContainers { get; }
Public ReadOnly Property AutoHideLeftContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the primary left auto-hide tabstrip.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePerContainer Property

DockSiteAutoHidePerContainer Property

Gets or sets whether auto-hide state toggles affect all the windows in the parent ToolWindowContainer.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AutoHidePerContainer { get; set; }
Public Property AutoHidePerContainer As Boolean
    Get
    Set

Property Value

Type: Boolean
true if auto-hide state toggles affect all the windows in the parent ToolWindowContainer; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupCloseAnimationDuration Property

DockSiteAutoHidePopupCloseAnimationDuration Property

Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup close.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AutoHidePopupCloseAnimationDuration { get; set; }
Public Property AutoHidePopupCloseAnimationDuration As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds of the animation that is applied to an auto-hide popup close. The default value is 150ms.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupCloseDelay Property

DockSiteAutoHidePopupCloseDelay Property

Gets or sets the duration in milliseconds of the delay between when the pointer leaves an auto-hide popup and when the popup closes if the pointer has not moved back over the popup.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AutoHidePopupCloseDelay { get; set; }
Public Property AutoHidePopupCloseDelay As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds of the delay between when the pointer leaves an auto-hide popup and when the popup closes if the pointer has not moved back over the popup. The default value is 500ms.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupClosesOnLostFocus Property

DockSiteAutoHidePopupClosesOnLostFocus Property

Gets or sets whether the auto-hide popup closes when keyboard focus is moved outside of the popup.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AutoHidePopupClosesOnLostFocus { get; set; }
Public Property AutoHidePopupClosesOnLostFocus As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the auto-hide popup closes when keyboard focus is moved outside of the popup; otherwise, false. The default value is true.
Remarks
This property can be temporarily set to false while a dialog window is displayed from a tool window that is currently within an auto-hide popup. This prevents the popup from closing while the dialog is displayed.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupOpenAnimationDuration Property

DockSiteAutoHidePopupOpenAnimationDuration Property

Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup open.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AutoHidePopupOpenAnimationDuration { get; set; }
Public Property AutoHidePopupOpenAnimationDuration As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds of the animation that is applied to an auto-hide popup open. The default value is 150ms.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupOpenDelay Property

DockSiteAutoHidePopupOpenDelay Property

Gets or sets the duration in milliseconds of the delay between when the pointer moves over an auto-hide tab item and the auto-hide popup opens to display the tool window represented by the tab item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AutoHidePopupOpenDelay { get; set; }
Public Property AutoHidePopupOpenDelay As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds of the delay between when the pointer moves over an auto-hide tab item and the auto-hide popup opens to display the tool window represented by the tab item. The default value is 200ms.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupOpensOnMouseHover Property

DockSiteAutoHidePopupOpensOnMouseHover Property

Gets or sets whether the auto-hide popup displays when the mouse hovers over an auto-hide tab item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AutoHidePopupOpensOnMouseHover { get; set; }
Public Property AutoHidePopupOpensOnMouseHover As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the auto-hide popup displays when the mouse hovers over an auto-hide tab item; otherwise, false. The default value is false for most themes, but may be true for some themes.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHideRightContainers Property

DockSiteAutoHideRightContainers Property

Gets the collection of ToolWindowContainer items that appear in the primary right auto-hide tabstrip.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideRightContainers { get; }
Public ReadOnly Property AutoHideRightContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the primary right auto-hide tabstrip.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHideTabItemTemplate Property

DockSiteAutoHideTabItemTemplate Property

Gets or sets the DataTemplate to use for rendering the auto-hide tab items.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate AutoHideTabItemTemplate { get; set; }
Public Property AutoHideTabItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for rendering the auto-hide tab items.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHideTabItemTemplateSelector Property

DockSiteAutoHideTabItemTemplateSelector Property

Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector AutoHideTabItemTemplateSelector { get; set; }
Public Property AutoHideTabItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for rendering the auto-hide tab items.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHideTopContainers Property

DockSiteAutoHideTopContainers Property

Gets the collection of ToolWindowContainer items that appear in the primary top auto-hide tabstrip.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideTopContainers { get; }
Public ReadOnly Property AutoHideTopContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the primary top auto-hide tabstrip.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanDocumentWindowsClose Property

DockSiteCanDocumentWindowsClose Property

Gets or sets the global setting for whether document windows can be closed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDocumentWindowsClose { get; set; }
Public Property CanDocumentWindowsClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document windows can be closed; otherwise, false. The default value is true.
Remarks
This setting only affects document windows whose CanClose property is set to . Any other setting on the document window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanDocumentWindowsDragToLinkedDockSites Property

DockSiteCanDocumentWindowsDragToLinkedDockSites Property

Gets or sets the global setting for whether document windows may be dragged to a linked DockSite.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDocumentWindowsDragToLinkedDockSites { get; set; }
Public Property CanDocumentWindowsDragToLinkedDockSites As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document windows may be dragged to a linked DockSite; otherwise, false. The default value is true.
Remarks
This setting only affects document windows whose CanDragToLinkedDockSites property is set to . Any other setting on the document window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanDocumentWindowsFloat Property

DockSiteCanDocumentWindowsFloat Property

Gets or sets the global setting for whether document windows may be contained in a floating window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDocumentWindowsFloat { get; set; }
Public Property CanDocumentWindowsFloat As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document windows may be contained in a floating window; otherwise, false. The default value is false.
Remarks
This setting only affects document windows whose CanFloat property is set to . Any other setting on the document window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanFloatingDockHostsHideOnDockSiteUnload Property

DockSiteCanFloatingDockHostsHideOnDockSiteUnload Property

Gets or sets whether FloatingDockHosts should hide when the DockSite is unloaded, such as in nested DockSite scenarios when the parent tab is deselected.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanFloatingDockHostsHideOnDockSiteUnload { get; set; }
Public Property CanFloatingDockHostsHideOnDockSiteUnload As Boolean
    Get
    Set

Property Value

Type: Boolean
true if FloatingDockHosts should hide when the DockSite is unloaded; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsAttach Property

DockSiteCanToolWindowsAttach Property

Gets or sets the global setting for whether tool windows may be attached to another tool window, creating a tabbed grouping.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowsAttach { get; set; }
Public Property CanToolWindowsAttach As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be attached to another tool window; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanAttach property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsAutoHide Property

DockSiteCanToolWindowsAutoHide Property

Gets or sets the global setting for whether tool windows may be placed in auto-hide mode.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowsAutoHide { get; set; }
Public Property CanToolWindowsAutoHide As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be placed in auto-hide mode; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanAutoHide property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsBecomeDocuments Property

DockSiteCanToolWindowsBecomeDocuments Property

Gets or sets the global setting for whether tool windows may be placed in a document state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowsBecomeDocuments { get; set; }
Public Property CanToolWindowsBecomeDocuments As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be placed in a document state; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanBecomeDocument property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsClose Property

DockSiteCanToolWindowsClose Property

Gets or sets the global setting for whether tool windows can be closed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowsClose { get; set; }
Public Property CanToolWindowsClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows can be closed; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanClose property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsCloseOnMiddleClick Property

DockSiteCanToolWindowsCloseOnMiddleClick Property

Gets or sets a value indicating whether tool windows can be closed by clicking the tab with the middle mouse button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowsCloseOnMiddleClick { get; set; }
Public Property CanToolWindowsCloseOnMiddleClick As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows can be closed by clicking the tab with the middle mouse button; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsDock Property

DockSiteCanToolWindowsDock Property

Gets or sets the global setting for whether tool windows can be docked.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowsDock { get; set; }
Public Property CanToolWindowsDock As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows can be docked; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanDock property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsDragToFloatingDockHostsWithWorkspaces Property

DockSiteCanToolWindowsDragToFloatingDockHostsWithWorkspaces Property

Gets or sets the whether tool windows may be dragged to floating dock hosts that contain a workspace.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowsDragToFloatingDockHostsWithWorkspaces { get; set; }
Public Property CanToolWindowsDragToFloatingDockHostsWithWorkspaces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be dragged to floating dock hosts that contain a workspace; otherwise, false. The default value is true.
Remarks
When false, tool windows can still be dragged and docked against floating dock hosts that only contain tool windows.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsDragToLinkedDockSites Property

DockSiteCanToolWindowsDragToLinkedDockSites Property

Gets or sets the global setting for whether tool windows may be dragged to a linked DockSite.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowsDragToLinkedDockSites { get; set; }
Public Property CanToolWindowsDragToLinkedDockSites As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be dragged to a linked DockSite; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanDragToLinkedDockSites property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsFloat Property

DockSiteCanToolWindowsFloat Property

Gets or sets the global setting for whether tool windows may be floated into separate top-level containers.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowsFloat { get; set; }
Public Property CanToolWindowsFloat As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be floated into separate top-level containers; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanFloat property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowTabsDrag Property

DockSiteCanToolWindowTabsDrag Property

Gets or sets the global setting for whether tool window tabs may be dragged to another location.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanToolWindowTabsDrag { get; set; }
Public Property CanToolWindowTabsDrag As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool window tabs may be dragged to another location; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanDragTab property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanUpdateItemsSourceOnUnregister Property

DockSiteCanUpdateItemsSourceOnUnregister Property

Gets or sets whether to try and remove an item from its items source when the related container DockingWindow is unregistered.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanUpdateItemsSourceOnUnregister { get; set; }
Public Property CanUpdateItemsSourceOnUnregister As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item should try to be removed; otherwise, false. The default value is true.
Remarks
This feature is only active when using the DocumentItemsSource or ToolItemsSource properties, and the functionality only works if the items source implements IList and is not read-only. Otherwise, the WindowUnregistered event should be monitored and the items source updated manually.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CascadeDocumentsCommand Property

DockSiteCascadeDocumentsCommand Property

Gets the ICommand that can cascade the open documents.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CascadeDocumentsCommand { get; }
Public ReadOnly Property CascadeDocumentsCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can cascade the open documents.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.Child Property

DockSiteChild Property

Gets or sets the FrameworkElement that is the child content of this dock site.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FrameworkElement Child { get; set; }
Public Property Child As FrameworkElement
    Get
    Set

Property Value

Type: FrameworkElement
The FrameworkElement that is the child content of this dock site.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CloseAllDocumentsCommand Property

DockSiteCloseAllDocumentsCommand Property

Gets the ICommand that can close all open documents.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CloseAllDocumentsCommand { get; }
Public ReadOnly Property CloseAllDocumentsCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close all open documents.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ClosePerContainer Property

DockSiteClosePerContainer Property

Gets or sets whether close operations affect all the windows in the parent ToolWindowContainer.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ClosePerContainer { get; set; }
Public Property ClosePerContainer As Boolean
    Get
    Set

Property Value

Type: Boolean
true if close operations affect all the windows in the parent ToolWindowContainer; otherwise, false. The default value is false.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ClosePrimaryDocumentCommand Property

DockSiteClosePrimaryDocumentCommand Property

Gets the ICommand that can close the primary document.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ClosePrimaryDocumentCommand { get; }
Public ReadOnly Property ClosePrimaryDocumentCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close the primary document.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemContainerStyle Property

DockSiteDocumentItemContainerStyle Property

Gets or sets the Style that is applied to the container DockingWindow generated for each document item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style DocumentItemContainerStyle { get; set; }
Public Property DocumentItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that is applied to the container DockingWindow generated for each document item. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemContainerStyleSelector Property

DockSiteDocumentItemContainerStyleSelector Property

Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StyleSelector DocumentItemContainerStyleSelector { get; set; }
Public Property DocumentItemContainerStyleSelector As StyleSelector
    Get
    Set

Property Value

Type: StyleSelector
A StyleSelector object that contains logic that chooses the style to use as the DocumentItemContainerStyle. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemsSource Property

DockSiteDocumentItemsSource Property

Gets or sets a collection used to generate document windows for use in the DockSite.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable DocumentItemsSource { get; set; }
Public Property DocumentItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
A collection that is used to generate generate document windows for use in the DockSite. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemTemplate Property

DockSiteDocumentItemTemplate Property

Gets or sets the DataTemplate used to display each document item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DocumentItemTemplate { get; set; }
Public Property DocumentItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that specifies the visualization of the data objects. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemTemplateSelector Property

DockSiteDocumentItemTemplateSelector Property

Gets or sets the custom logic for choosing a template used to display each document item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector DocumentItemTemplateSelector { get; set; }
Public Property DocumentItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
A custom DataTemplateSelector object that provides logic and returns a DataTemplate. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.Documents Property

DockSiteDocuments Property

Gets the collection of DockingWindow controls that are currently open in the MDI area.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyDockingWindowCollection Documents { get; }
Public ReadOnly Property Documents As ReadOnlyDockingWindowCollection
    Get

Property Value

Type: ReadOnlyDockingWindowCollection
The collection of DockingWindow controls that are currently open in the MDI area.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentWindows Property

DockSiteDocumentWindows Property

Gets the DocumentWindowCollection of document windows that are currently registered with the DockSite.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentWindowCollection DocumentWindows { get; }
Public ReadOnly Property DocumentWindows As DocumentWindowCollection
    Get

Property Value

Type: DocumentWindowCollection
The DocumentWindowCollection of document windows that are currently registered with the DockSite.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingDockHosts Property

DockSiteFloatingDockHosts Property

Gets the collection of floating dock hosts, which are those that are top-level and external to the DockSite hierarchy's primary dock host.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyObservableCollection<DockHost> FloatingDockHosts { get; }
Public ReadOnly Property FloatingDockHosts As ReadOnlyObservableCollection(Of DockHost)
    Get

Property Value

Type: ReadOnlyObservableCollection DockHost
The collection of floating dock hosts.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingToolWindowContainersHaveMaximizeButtons Property

DockSiteFloatingToolWindowContainersHaveMaximizeButtons Property

Gets or sets whether floating ToolWindowContainer controls can have title bar maximize buttons.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool FloatingToolWindowContainersHaveMaximizeButtons { get; set; }
Public Property FloatingToolWindowContainersHaveMaximizeButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if floating ToolWindowContainer controls can have title bar maximize buttons; otherwise, false. The default value is true.
Remarks
This property only affects non-hosted floating windows.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingToolWindowContainersHaveMinimizeButtons Property

DockSiteFloatingToolWindowContainersHaveMinimizeButtons Property

Gets or sets whether floating ToolWindowContainer controls can have title bar minimize buttons.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool FloatingToolWindowContainersHaveMinimizeButtons { get; set; }
Public Property FloatingToolWindowContainersHaveMinimizeButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if floating ToolWindowContainer controls can have title bar minimize buttons; otherwise, false. The default value is false.
Remarks
This property only affects non-hosted floating windows.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowIcon Property

DockSiteFloatingWindowIcon Property

Gets or sets the ImageSource for floating window icons, which should be set if document windows are allowed to float.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource FloatingWindowIcon { get; set; }
Public Property FloatingWindowIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The ImageSource for floating window icons.
Remarks
The value is generally the same as your application icon.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowShowInTaskBarMode Property

DockSiteFloatingWindowShowInTaskBarMode Property

Gets or sets a mode that determines when to show floating windows in the taskbar.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FloatingWindowShowInTaskBarMode FloatingWindowShowInTaskBarMode { get; set; }
Public Property FloatingWindowShowInTaskBarMode As FloatingWindowShowInTaskBarMode
    Get
    Set

Property Value

Type: FloatingWindowShowInTaskBarMode
A mode that determines when to show floating windows in the taskbar. The default value is FloatingWindowShowInTaskBarMode.Default.
Remarks
This feature only affects non-hosted floating windows.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowSnapToScreenThreshold Property

DockSiteFloatingWindowSnapToScreenThreshold Property

Gets or sets the minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double FloatingWindowSnapToScreenThreshold { get; set; }
Public Property FloatingWindowSnapToScreenThreshold As Double
    Get
    Set

Property Value

Type: Double
The minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen. The default value is 70.0.
Remarks
This feature is only used when the IsFloatingWindowSnapToScreenEnabled property is true. If a floating window is completely beyond the screen edge, it will be fully snapped back onto the screen. If a floating window is only partially beyond the screen edge, but the visible portion is less than this property's value, it will be snapped partially back onto the screen.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowTitle Property

DockSiteFloatingWindowTitle Property

Gets or sets the title text for floating windows, which should be set if document windows are allowed to float..

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string FloatingWindowTitle { get; set; }
Public Property FloatingWindowTitle As String
    Get
    Set

Property Value

Type: String
The title text for floating windows.
Remarks
The value is generally the same as your application name.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.HasDocuments Property

DockSiteHasDocuments Property

Gets whether the DockSite currently has any open documents.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDocuments { get; }
Public ReadOnly Property HasDocuments As Boolean
    Get

Return Value

Type: Boolean
true if the DockSite currently has any open documents; otherwise, false.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.HostedFloatingWindowContainer Property

DockSiteHostedFloatingWindowContainer Property

Gets or sets the FrameworkElement whose bounds should be used to restrict the movement of hosted floating windows. The FrameworkElement must be the DockSite or one of it's visual ancestors.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FrameworkElement HostedFloatingWindowContainer { get; set; }
Public Property HostedFloatingWindowContainer As FrameworkElement
    Get
    Set

Property Value

Type: FrameworkElement
The FrameworkElement whose bounds should be used to restrict the movement of hosted floating windows; otherwise which indicates to use the DockSite itself.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeDelay Property

DockSiteInactiveFloatingWindowFadeDelay Property

Gets or sets the duration in milliseconds of inactivity that must take place for a hosted floating window before it starts to fade out.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double InactiveFloatingWindowFadeDelay { get; set; }
Public Property InactiveFloatingWindowFadeDelay As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds of inactivity that must take place for a hosted floating window before it starts to fade out. The default value is 20 seconds.
Remarks
The IsInactiveFloatingWindowFadeEnabled property must be set to true for this property to be used.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeDuration Property

DockSiteInactiveFloatingWindowFadeDuration Property

Gets or sets the duration in milliseconds over which an inactive hosted floating window will fade.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double InactiveFloatingWindowFadeDuration { get; set; }
Public Property InactiveFloatingWindowFadeDuration As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds over which an inactive hosted floating window will fade. The default value is 20 seconds.
Remarks
The IsInactiveFloatingWindowFadeEnabled property must be set to true for this property to be used.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeOpacity Property

DockSiteInactiveFloatingWindowFadeOpacity Property

Gets or sets the target opacity to which inactive hosted floating windows to fade.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double InactiveFloatingWindowFadeOpacity { get; set; }
Public Property InactiveFloatingWindowFadeOpacity As Double
    Get
    Set

Property Value

Type: Double
The target opacity to which inactive hosted floating windows to fade. The default value is 0.25 (25% opacity).
Remarks
The IsInactiveFloatingWindowFadeEnabled property must be set to true for this property to be used.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsDockGuideAnimationEnabled Property

DockSiteIsDockGuideAnimationEnabled Property

Gets or sets whether dock guide animation is enabled.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDockGuideAnimationEnabled { get; set; }
Public Property IsDockGuideAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if dock guide animation is enabled; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsFloatingWindowSnapToScreenEnabled Property

DockSiteIsFloatingWindowSnapToScreenEnabled Property

Gets or sets whether floating windows are snapped onto the closest screen when displayed via a method other than being dragged.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsFloatingWindowSnapToScreenEnabled { get; set; }
Public Property IsFloatingWindowSnapToScreenEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if floating windows are snapped onto the closest screen when displayed via a method other than being dragged; otherwise, false. The default value is true.
Remarks
This feature ensures that floating windows are fully visible on-screen when being programmatically displayed, such as when a layout is loaded.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsInactiveFloatingWindowFadeEnabled Property

DockSiteIsInactiveFloatingWindowFadeEnabled Property

Gets or sets whether hosted floating windows will fade out following inactivity.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsInactiveFloatingWindowFadeEnabled { get; set; }
Public Property IsInactiveFloatingWindowFadeEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if hosted floating windows will fade out following inactivity; otherwise, false. The default value is true.
Remarks
This option only applied when hosted floating windows are in use.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsLiveSplittingEnabled Property

DockSiteIsLiveSplittingEnabled Property

Gets or sets whether live splitting of docking windows is enabled.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsLiveSplittingEnabled { get; set; }
Public Property IsLiveSplittingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if live splitting of docking windows is enabled; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsTabLayoutAnimationEnabled Property

DockSiteIsTabLayoutAnimationEnabled Property

Gets or sets whether animation effects are applied during tab layout, such as when tabs are added or removed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTabLayoutAnimationEnabled { get; set; }
Public Property IsTabLayoutAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if animation effects are applied during tab layout, such as when tabs are added or removed; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.LinkedDockSites Property

DockSiteLinkedDockSites Property

Gets the linked DockSites, to which registered docking windows can be docked into.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<DockSite> LinkedDockSites { get; }
Public ReadOnly Property LinkedDockSites As IEnumerable(Of DockSite)
    Get

Property Value

Type: IEnumerable DockSite
The linked DockSites, to which registered docking windows can be docked into.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MagnetismGapDistance Property

DockSiteMagnetismGapDistance Property

Gets or sets the distance between windows that are snapped together via magnetism.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MagnetismGapDistance { get; set; }
Public Property MagnetismGapDistance As Double
    Get
    Set

Property Value

Type: Double
The distance between windows that are snapped together via magnetism. The default value is 1.
Remarks
If this value is greater than 0, there will be a gap between windows that are snapped together when magnetism is enabled by the MagnetismSnapDistance property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MagnetismSnapDistance Property

DockSiteMagnetismSnapDistance Property

Gets or sets the distance at which magnetism begins to snap windows being dragged.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MagnetismSnapDistance { get; set; }
Public Property MagnetismSnapDistance As Double
    Get
    Set

Property Value

Type: Double
The distance at which magnetism begins to snap windows being dragged. The default value is 5.
Remarks
If this value is greater than 0, magnetism is enabled. Set it to 0 to disable magnetism. Magnetism tries to snap corners of a window being dragged to other window corners around it. Increase this property's value to increase the range over which the magnetism will work. Magnetism also takes effect when resizing via window borders.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MdiKind Property

DockSiteMdiKind Property

Gets or sets the kind of MDI currently in use.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MdiKind MdiKind { get; set; }
Public Property MdiKind As MdiKind
    Get
    Set

Property Value

Type: MdiKind
A MdiKind indicating the kind of MDI currently in use. The default value is None.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.PrimaryDockHost Property

DockSitePrimaryDockHost Property

Gets the primary dock host, which is the one that is implicitly created within the DockSite's template.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost PrimaryDockHost { get; }
Public ReadOnly Property PrimaryDockHost As DockHost
    Get

Property Value

Type: DockHost
The primary dock host.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.PrimaryDocument Property

DockSitePrimaryDocument Property

Gets the DockingWindow that currently is the primary document in the dock site.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindow PrimaryDocument { get; }
Public ReadOnly Property PrimaryDocument As DockingWindow
    Get

Property Value

Type: DockingWindow
The DockingWindow that currently is the primary document in the dock site.
Remarks
The primary document is the same as ActiveWindow if the active window is a document. When the ActiveWindow is not a document, then the primary document is the open document that was last activated.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.SetMdiKindCommand Property

DockSiteSetMdiKindCommand Property

Gets the ICommand that can set the MDI kind to the MdiKind enumeration value specified in the command parameter.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SetMdiKindCommand { get; }
Public ReadOnly Property SetMdiKindCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can set the MDI kind to the MdiKind enumeration value specified in the command parameter.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.SplitterSize Property

DockSiteSplitterSize Property

Gets or sets the size of splitters.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SplitterSize { get; set; }
Public Property SplitterSize As Double
    Get
    Set

Property Value

Type: Double
The size of splitters. The default value is 5.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.Switcher Property

DockSiteSwitcher Property

Gets or sets the SwitcherBase that will be used to provide Ctrl+Tab window switching capabilities.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SwitcherBase Switcher { get; set; }
Public Property Switcher As SwitcherBase
    Get
    Set

Property Value

Type: SwitcherBase
The SwitcherBase that will be used to provide Ctrl+Tab window switching capabilities.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.TileDocumentsHorizontallyCommand Property

DockSiteTileDocumentsHorizontallyCommand Property

Gets the ICommand that can tile the open documents horizontally.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand TileDocumentsHorizontallyCommand { get; }
Public ReadOnly Property TileDocumentsHorizontallyCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can tile the open documents horizontally.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.TileDocumentsVerticallyCommand Property

DockSiteTileDocumentsVerticallyCommand Property

Gets the ICommand that can tile the open documents vertically.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand TileDocumentsVerticallyCommand { get; }
Public ReadOnly Property TileDocumentsVerticallyCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can tile the open documents vertically.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemContainerStyle Property

DockSiteToolItemContainerStyle Property

Gets or sets the Style that is applied to the container DockingWindow generated for each tool item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ToolItemContainerStyle { get; set; }
Public Property ToolItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that is applied to the container DockingWindow generated for each tool item. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemContainerStyleSelector Property

DockSiteToolItemContainerStyleSelector Property

Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StyleSelector ToolItemContainerStyleSelector { get; set; }
Public Property ToolItemContainerStyleSelector As StyleSelector
    Get
    Set

Property Value

Type: StyleSelector
A StyleSelector object that contains logic that chooses the style to use as the ToolItemContainerStyle. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemsSource Property

DockSiteToolItemsSource Property

Gets or sets a collection used to generate tool windows for use in the DockSite.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable ToolItemsSource { get; set; }
Public Property ToolItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
A collection that is used to generate generate tool windows for use in the DockSite. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemTemplate Property

DockSiteToolItemTemplate Property

Gets or sets the DataTemplate used to display each tool item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ToolItemTemplate { get; set; }
Public Property ToolItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that specifies the visualization of the data objects. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemTemplateSelector Property

DockSiteToolItemTemplateSelector Property

Gets or sets the custom logic for choosing a template used to display each tool item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector ToolItemTemplateSelector { get; set; }
Public Property ToolItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
A custom DataTemplateSelector object that provides logic and returns a DataTemplate. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindows Property

DockSiteToolWindows Property

Gets the ToolWindowCollection of tool windows that are currently registered with the DockSite.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowCollection ToolWindows { get; }
Public ReadOnly Property ToolWindows As ToolWindowCollection
    Get

Property Value

Type: ToolWindowCollection
The ToolWindowCollection of tool windows that are currently registered with the DockSite.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveCloseButtons Property

DockSiteToolWindowsHaveCloseButtons Property

Gets or sets whether ToolWindowContainer controls can have title bar close buttons.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveCloseButtons { get; set; }
Public Property ToolWindowsHaveCloseButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ToolWindowContainer controls can have title bar close buttons; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveOptionsButtons Property

DockSiteToolWindowsHaveOptionsButtons Property

Gets or sets whether ToolWindowContainer controls can have title bar options buttons.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveOptionsButtons { get; set; }
Public Property ToolWindowsHaveOptionsButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ToolWindowContainer controls can have title bar options buttons; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveTabImages Property

DockSiteToolWindowsHaveTabImages Property

Gets or sets the global setting for whether tool windows have images on tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveTabImages { get; set; }
Public Property ToolWindowsHaveTabImages As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows have images on tabs; otherwise, false. The default value is false.
Remarks
This setting does not affect tabbed MDI, since TabbedMdiHost has its own HasTabImages property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveTitleBarIcons Property

DockSiteToolWindowsHaveTitleBarIcons Property

Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveTitleBarIcons { get; set; }
Public Property ToolWindowsHaveTitleBarIcons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool window title bars display the icon of the selected tool window; otherwise, false. The default value is false.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveTitleBars Property

DockSiteToolWindowsHaveTitleBars Property

Gets or sets the global setting for whether tool windows display a title bar when not in MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveTitleBars { get; set; }
Public Property ToolWindowsHaveTitleBars As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows display a title bar when not in MDI; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose HasTitleBar property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveToggleAutoHideButtons Property

DockSiteToolWindowsHaveToggleAutoHideButtons Property

Gets or sets whether ToolWindowContainer controls can have title bar toggle auto-hide buttons.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveToggleAutoHideButtons { get; set; }
Public Property ToolWindowsHaveToggleAutoHideButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ToolWindowContainer controls can have title bar toggle auto-hide buttons; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsSingleTabLayoutBehavior Property

DockSiteToolWindowsSingleTabLayoutBehavior Property

Gets or sets the global setting for the behavior used when a single tool window is in a container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SingleTabLayoutBehavior ToolWindowsSingleTabLayoutBehavior { get; set; }
Public Property ToolWindowsSingleTabLayoutBehavior As SingleTabLayoutBehavior
    Get
    Set

Property Value

Type: SingleTabLayoutBehavior
The behavior used when a single tool window is in a container. The default value is SingleTabLayoutBehavior.Hide.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsTabOverflowBehavior Property

DockSiteToolWindowsTabOverflowBehavior Property

Gets or sets the global setting for the overflow behavior of the tool window tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabOverflowBehavior ToolWindowsTabOverflowBehavior { get; set; }
Public Property ToolWindowsTabOverflowBehavior As TabOverflowBehavior
    Get
    Set

Property Value

Type: TabOverflowBehavior
The overflow behavior of the tool window tabs. The default value is TabOverflowBehavior.Shrink.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsTabStripPlacement Property

DockSiteToolWindowsTabStripPlacement Property

Gets or sets a Side indicating the side upon which the tool window tabs are located.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Side ToolWindowsTabStripPlacement { get; set; }
Public Property ToolWindowsTabStripPlacement As Side
    Get
    Set

Property Value

Type: Side
A Side indicating the side upon which the tool window tabs are located. The default value is Bottom.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsTitleBarContextContentAlignment Property

DockSiteToolWindowsTitleBarContextContentAlignment Property

Gets or sets the alignment of tool window container title bar context content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextContentAlignment ToolWindowsTitleBarContextContentAlignment { get; set; }
Public Property ToolWindowsTitleBarContextContentAlignment As ContextContentAlignment
    Get
    Set

Property Value

Type: ContextContentAlignment
The alignment of tool window container title bar context content. The default value is Far.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowTabItemContainerStyle Property

DockSiteToolWindowTabItemContainerStyle Property

Gets or sets the Style to use for rendering the tab item containers in a ToolWindowContainer.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ToolWindowTabItemContainerStyle { get; set; }
Public Property ToolWindowTabItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for rendering the tab item containers in a ToolWindowContainer.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.UseDragFloatPreviews Property

DockSiteUseDragFloatPreviews Property

Gets or sets whether to use float previews when dragging windows instead of instantly creating floating windows.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseDragFloatPreviews { get; set; }
Public Property UseDragFloatPreviews As Boolean
    Get
    Set

Property Value

Type: Boolean
true if float previews should be used when dragging windows instead of instantly creating floating windows; otherwise, false. The default value is false.
Remarks
This property should be set to true when docking window content contains a large number of elements that may not measure/arrange quickly. When this property is true, fewer layout cycles occur since a float preview is used to show where the floating window will be created instead of instantly moving the dragged windows into a floating window.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.UseHostedFloatingWindows Property

DockSiteUseHostedFloatingWindows Property

Gets or sets whether floating windows should be hosted within the bounds of the dock site.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseHostedFloatingWindows { get; set; }
Public Property UseHostedFloatingWindows As Boolean
    Get
    Set

Property Value

Type: Boolean
true if floating windows should be hosted within the bounds of the dock site; otherwise, false. The default value is false.
Remarks
Due to security restrictions with the Window class in XBAPs, when used in an XBAP, a value of true will be forced.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.UseHostedPopups Property

DockSiteUseHostedPopups Property

Gets or sets whether popups should be hosted within the bounds of the dock site.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseHostedPopups { get; set; }
Public Property UseHostedPopups As Boolean
    Get
    Set

Property Value

Type: Boolean
true if popups should be hosted within the bounds of the dock site; otherwise, false. The default value is true.
Remarks
This property should be false only in Windows applications where you expect to host interop (Windows Forms, DirectX, etc.) controls. If you do not plan on hosting interop controls, leave it true.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite Methods

The DockSite type exposes the following members.

Methods
 | Name | Description
Public method | ActivateNextDocument | Activates the next document by selecting it and focusing its content.
Public method | ActivatePreviousDocument | Activates the previous document by selecting it and focusing its content.
Public method | ActivatePrimaryDocument | Activates the primary document by focusing its content.
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
 | ApplyContainerStyle | Applies the style of the specified container window.
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CascadeDocuments | Cascades all open documents, if using tabbed or standard MDI.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DockingWindow, Object, DockingWindowItemKind) method.
Public method | CloseAllDocuments | Closes all open documents.
Public method | ClosePrimaryDocument | Closes the primary document.
Public method | ContainerFromDocumentItem | Returns the DocumentWindow corresponding to the given item contained in DocumentItemsSource.
Public method | ContainerFromItem | Returns the DockingWindow corresponding to the given item contained in DocumentItemsSource or ToolItemsSource.
Public method | ContainerFromToolItem | Returns the ToolWindow corresponding to the given item contained in ToolItemsSource.
Public method | DockSiteRegistryConstructor | Initializes a new instance of the DockSite class.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the DockingWindow that is used to display the given item.
Protected method | InitializeAutoHidePopupWindow | Initializes a Window that contains an auto-hide popup.
Protected method | InitializeDockingAdornmentWindow | Initializes a Window that can host dock guide and dock preview adornments during a docking operation.
Protected method | InitializeFloatingWindow | Initializes a Window that contains a floating DockHost.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container.
Public method | LinkDockSite | Links this DockSite to the specified DockSite and vice versa, allowing docking windows to be seamlessly moved between the dock sites.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDocumentItemsSourceChanged | Called when the DocumentItemsSource property changes.
Protected method | OnFloatingWindowOpening | Occurs when a floating window is opening, allowing for customization before it is displayed.
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnInitialized | Occurs when the control is initialized. (Overrides FrameworkElementOnInitialized(EventArgs).)
Protected method | OnMdiKindChanged | Occurs when the MdiKind property is changed.
Protected method | OnMenuOpening | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnNewWindowRequested | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPrimaryDocumentChanged | Occurs when the PrimaryDocument property has changed.
Protected method | OnPropertyChanged | Occurs when a property is changed. (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnToolItemsSourceChanged | Called when the ToolItemsSource property changes.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnWindowActivated | Occurs after a DockingWindow has been activated.
Protected method | OnWindowAutoHidePopupClosed | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
Protected method | OnWindowAutoHidePopupOpened | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
Protected method | OnWindowDeactivated | Occurs after a DockingWindow has been deactivated.
Protected method | OnWindowDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Protected method | OnWindowRegistered | Occurs after a DockingWindow has been registered.
Protected method | OnWindowsAutoHiding | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
Protected method | OnWindowsClosed | Occurs after one or more DockingWindow controls have been closed.
Protected method | OnWindowsClosing | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
Protected method | OnWindowsDockHostChanged | Occurs after one or more DockingWindow controls' DockHost properties have changed.
Protected method | OnWindowsDragged | Occurs after one or more DockingWindow controls are dragged by the end user.
Protected method | OnWindowsDragging | Occurs before one or more DockingWindow controls are dragged by the end user.
Protected method | OnWindowsDragOver | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
Protected method | OnWindowsOpened | Occurs after one or more DockingWindow controls have been opened.
Protected method | OnWindowsOpening | Occurs before one or more DockingWindow controls is opened.
Protected method | OnWindowsStateChanged | Occurs after one or more DockingWindow controls' states have changed.
Protected method | OnWindowUnregistered | Occurs after a DockingWindow has been unregistered.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified DockingWindow to display the specified item.
Protected method | ProcessDockHostKeyDown | Processes a key down event from a dock host.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TileDocumentsHorizontally | Tiles all open documents horizontally, if using tabbed or standard MDI.
Public method | TileDocumentsVertically | Tiles all open documents vertically, if using tabbed or standard MDI.
Public method | ToHierarchyString | Creates a string that contains a textual representation of the dock site hierarchy, useful for debugging purposes.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnlinkDockSite | Unlinks this DockSite from the specified DockSite and vice versa.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ActivateNextDocument Method

DockSiteActivateNextDocument Method

Activates the next document by selecting it and focusing its content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ActivateNextDocument()
Public Sub ActivateNextDocument
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ActivatePreviousDocument Method

DockSiteActivatePreviousDocument Method

Activates the previous document by selecting it and focusing its content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ActivatePreviousDocument()
Public Sub ActivatePreviousDocument
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ActivatePrimaryDocument Method

DockSiteActivatePrimaryDocument Method

Activates the primary document by focusing its content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ActivatePrimaryDocument()
Public Sub ActivatePrimaryDocument
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ApplyContainerStyle Method

DockSiteApplyContainerStyle Method

Applies the style of the specified container window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void ApplyContainerStyle(
    Object item,
    DockingWindow container,
    StyleSelector styleSelector,
    Style style
)
Public Shared Sub ApplyContainerStyle (
    item As Object,
    container As DockingWindow,
    styleSelector As StyleSelector,
    style As Style
)

Parameters

item
Type: SystemObject
The data item.
container
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The container window whose style should be set.
styleSelector
Type: System.Windows.ControlsStyleSelector
The option style selector.
style
Type: System.WindowsStyle
The desired specific style.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CascadeDocuments Method

DockSiteCascadeDocuments Method

Cascades all open documents, if using tabbed or standard MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CascadeDocuments()
Public Sub CascadeDocuments
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ClearContainerForItemOverride Method

DockSiteClearContainerForItemOverride Method

When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DockingWindow, Object, DockingWindowItemKind) method.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void ClearContainerForItemOverride(
    DockingWindow container,
    Object item,
    DockingWindowItemKind kind
)
Protected Overridable Sub ClearContainerForItemOverride (
    container As DockingWindow,
    item As Object,
    kind As DockingWindowItemKind
)

Parameters

container
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The container DockingWindow.
item
Type: SystemObject
The item.
kind
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowItemKind
The kind of the item.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CloseAllDocuments Method

DockSiteCloseAllDocuments Method

Closes all open documents.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CloseAllDocuments()
Public Function CloseAllDocuments As Boolean

Return Value

Type: Boolean
true if all open documents were closed; otherwise, false.
Remarks
Only documents that are closable are closed.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ClosePrimaryDocument Method

DockSiteClosePrimaryDocument Method

Closes the primary document.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ClosePrimaryDocument()
Public Function ClosePrimaryDocument As Boolean

Return Value

Type: Boolean
true if the primary document was closed; otherwise, false.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ContainerFromDocumentItem Method

DockSiteContainerFromDocumentItem Method

Returns the DocumentWindow corresponding to the given item contained in DocumentItemsSource.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentWindow ContainerFromDocumentItem(
    Object item
)
Public Function ContainerFromDocumentItem (
    item As Object
) As DocumentWindow

Parameters

item
Type: SystemObject
The Object item to find the DocumentWindow for.

Return Value

Type: DocumentWindow
A DocumentWindow that corresponds to the given item; otherwise, indicates the item does not belong to the item collection.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ContainerFromItem Method

DockSiteContainerFromItem Method

Returns the DockingWindow corresponding to the given item contained in DocumentItemsSource or ToolItemsSource.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindow ContainerFromItem(
    Object item
)
Public Function ContainerFromItem (
    item As Object
) As DockingWindow

Parameters

item
Type: SystemObject
The Object item to find the DockingWindow for.

Return Value

Type: DockingWindow
A DockingWindow that corresponds to the given item; otherwise, indicates the item does not belong to either item collection.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ContainerFromToolItem Method

DockSiteContainerFromToolItem Method

Returns the ToolWindow corresponding to the given item contained in ToolItemsSource.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindow ContainerFromToolItem(
    Object item
)
Public Function ContainerFromToolItem (
    item As Object
) As ToolWindow

Parameters

item
Type: SystemObject
The Object item to find the ToolWindow for.

Return Value

Type: ToolWindow
A ToolWindow that corresponds to the given item; otherwise, indicates the item does not belong to the item collection.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DockSiteRegistryConstructor Method

DockSiteDockSiteRegistryConstructor Method

Initializes a new instance of the DockSite class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void DockSiteRegistryConstructor()
Public Sub DockSiteRegistryConstructor
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.GetContainerForItemOverride Method

DockSiteGetContainerForItemOverride Method

Creates or identifies the DockingWindow that is used to display the given item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual DockingWindow GetContainerForItemOverride(
    DockingWindowItemKind kind
)
Protected Overridable Function GetContainerForItemOverride (
    kind As DockingWindowItemKind
) As DockingWindow

Parameters

kind
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowItemKind
The kind of the item.

Return Value

Type: DockingWindow
The DockingWindow that is used to display the given item.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.InitializeAutoHidePopupWindow Method

DockSiteInitializeAutoHidePopupWindow Method

Initializes a Window that contains an auto-hide popup.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void InitializeAutoHidePopupWindow(
    Window window
)
Protected Overridable Sub InitializeAutoHidePopupWindow (
    window As Window
)

Parameters

window
Type: System.WindowsWindow
The Window to initialize.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.InitializeDockingAdornmentWindow Method

DockSiteInitializeDockingAdornmentWindow Method

Initializes a Window that can host dock guide and dock preview adornments during a docking operation.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void InitializeDockingAdornmentWindow(
    Window window
)
Protected Overridable Sub InitializeDockingAdornmentWindow (
    window As Window
)

Parameters

window
Type: System.WindowsWindow
The Window to initialize.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.InitializeFloatingWindow Method

DockSiteInitializeFloatingWindow Method

Initializes a Window that contains a floating DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void InitializeFloatingWindow(
    Window window
)
Protected Overridable Sub InitializeFloatingWindow (
    window As Window
)

Parameters

window
Type: System.WindowsWindow
The Window to initialize.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsItemItsOwnContainerOverride Method

DockSiteIsItemItsOwnContainerOverride Method

Determines if the specified item is (or is eligible to be) its own container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsItemItsOwnContainerOverride(
    Object item,
    DockingWindowItemKind kind
)
Protected Overridable Function IsItemItsOwnContainerOverride (
    item As Object,
    kind As DockingWindowItemKind
) As Boolean

Parameters

item
Type: SystemObject
The item to check.
kind
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowItemKind
The kind of the item.

Return Value

Type: Boolean
true if the item is (or is eligible to be) its own container; otherwise, false.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.LinkDockSite Method

DockSiteLinkDockSite Method

Links this DockSite to the specified DockSite and vice versa, allowing docking windows to be seamlessly moved between the dock sites.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void LinkDockSite(
    DockSite dockSite
)
Public Sub LinkDockSite (
    dockSite As DockSite
)

Parameters

dockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The DockSite to link.
Remarks
This method will completely link this DockSite to the specified DockSite. There is no need to call LinkDockSite(DockSite) on both DockSites.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnApplyTemplate Method

DockSiteOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnCreateAutomationPeer Method

DockSiteOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnDocumentItemsSourceChanged Method

DockSiteOnDocumentItemsSourceChanged Method

Called when the DocumentItemsSource property changes.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Protected Overridable Sub OnDocumentItemsSourceChanged (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
Old value of the DocumentItemsSource property.
newValue
Type: System.CollectionsIEnumerable
New value of the DocumentItemsSource property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnFloatingWindowOpening Method

DockSiteOnFloatingWindowOpening Method

Occurs when a floating window is opening, allowing for customization before it is displayed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnFloatingWindowOpening(
    FloatingWindowOpeningEventArgs e
)
Protected Overridable Sub OnFloatingWindowOpening (
    e As FloatingWindowOpeningEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingFloatingWindowOpeningEventArgs
The FloatingWindowOpeningEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnGotKeyboardFocus Method

DockSiteOnGotKeyboardFocus Method

Occurs when a control within this control's hierarchy gains keyboard focus.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
Protected Overrides Sub OnGotKeyboardFocus (
    e As KeyboardFocusChangedEventArgs
)

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
The KeyboardFocusChangedEventArgs that contains data related to this event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnInitialized Method

DockSiteOnInitialized Method

Occurs when the control is initialized.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnInitialized(
    EventArgs e
)
Protected Overrides Sub OnInitialized (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:ActiproSoftware.Windows.Controls.Docking.DockSite.OnInitialized(System.EventArgs)"]

See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnMdiKindChanged Method

DockSiteOnMdiKindChanged Method

Occurs when the MdiKind property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnMdiKindChanged(
    RoutedEventArgs e
)
Protected Overridable Sub OnMdiKindChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnMenuOpening Method

DockSiteOnMenuOpening Method

Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnMenuOpening(
    DockingMenuEventArgs e
)
Protected Overridable Sub OnMenuOpening (
    e As DockingMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingMenuEventArgs
The DockingMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnNewWindowRequested Method

DockSiteOnNewWindowRequested Method

Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnNewWindowRequested(
    RoutedEventArgs e
)
Protected Overridable Sub OnNewWindowRequested (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnPrimaryDocumentChanged Method

DockSiteOnPrimaryDocumentChanged Method

Occurs when the PrimaryDocument property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPrimaryDocumentChanged(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnPrimaryDocumentChanged (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnPropertyChanged Method

DockSiteOnPropertyChanged Method

Occurs when a property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
A DependencyPropertyChangedEventArgs that contains the event data.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnToolItemsSourceChanged Method

DockSiteOnToolItemsSourceChanged Method

Called when the ToolItemsSource property changes.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnToolItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Protected Overridable Sub OnToolItemsSourceChanged (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
Old value of the ToolItemsSource property.
newValue
Type: System.CollectionsIEnumerable
New value of the ToolItemsSource property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowActivated Method

DockSiteOnWindowActivated Method

Occurs after a DockingWindow has been activated.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowActivated(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowActivated (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowAutoHidePopupClosed Method

DockSiteOnWindowAutoHidePopupClosed Method

Occurs after an auto-hide popup has been closed that displayed a ToolWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowAutoHidePopupClosed(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowAutoHidePopupClosed (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowAutoHidePopupOpened Method

DockSiteOnWindowAutoHidePopupOpened Method

Occurs after an auto-hide popup has been opened that displays a ToolWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowAutoHidePopupOpened(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowAutoHidePopupOpened (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowDeactivated Method

DockSiteOnWindowDeactivated Method

Occurs after a DockingWindow has been deactivated.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowDeactivated(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowDeactivated (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowDefaultLocationRequested Method

DockSiteOnWindowDefaultLocationRequested Method

Occurs when a DockingWindow's default location is requested.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowDefaultLocationRequested(
    DockingWindowDefaultLocationEventArgs e
)
Protected Overridable Sub OnWindowDefaultLocationRequested (
    e As DockingWindowDefaultLocationEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowDefaultLocationEventArgs
The DockingWindowDefaultLocationEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowRegistered Method

DockSiteOnWindowRegistered Method

Occurs after a DockingWindow has been registered.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowRegistered(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowRegistered (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsAutoHiding Method

DockSiteOnWindowsAutoHiding Method

Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsAutoHiding(
    DockingWindowsAutoHidingEventArgs e
)
Protected Overridable Sub OnWindowsAutoHiding (
    e As DockingWindowsAutoHidingEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsAutoHidingEventArgs
The DockingWindowsAutoHidingEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsClosed Method

DockSiteOnWindowsClosed Method

Occurs after one or more DockingWindow controls have been closed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsClosed(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsClosed (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsClosing Method

DockSiteOnWindowsClosing Method

Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsClosing(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsClosing (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsDockHostChanged Method

DockSiteOnWindowsDockHostChanged Method

Occurs after one or more DockingWindow controls' DockHost properties have changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsDockHostChanged(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsDockHostChanged (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsDragged Method

DockSiteOnWindowsDragged Method

Occurs after one or more DockingWindow controls are dragged by the end user.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsDragged(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsDragged (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsDragging Method

DockSiteOnWindowsDragging Method

Occurs before one or more DockingWindow controls are dragged by the end user.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsDragging(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsDragging (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsDragOver Method

DockSiteOnWindowsDragOver Method

Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsDragOver(
    DockingWindowsDragOverEventArgs e
)
Protected Overridable Sub OnWindowsDragOver (
    e As DockingWindowsDragOverEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsDragOverEventArgs
The DockingWindowsDragOverEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsOpened Method

DockSiteOnWindowsOpened Method

Occurs after one or more DockingWindow controls have been opened.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsOpened(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsOpened (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsOpening Method

DockSiteOnWindowsOpening Method

Occurs before one or more DockingWindow controls is opened.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsOpening(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsOpening (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowsStateChanged Method

DockSiteOnWindowsStateChanged Method

Occurs after one or more DockingWindow controls' states have changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsStateChanged(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsStateChanged (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.OnWindowUnregistered Method

DockSiteOnWindowUnregistered Method

Occurs after a DockingWindow has been unregistered.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowUnregistered(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowUnregistered (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.PrepareContainerForItemOverride Method

DockSitePrepareContainerForItemOverride Method

Prepares the specified DockingWindow to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void PrepareContainerForItemOverride(
    DockingWindow container,
    Object item,
    DockingWindowItemKind kind
)
Protected Overridable Sub PrepareContainerForItemOverride (
    container As DockingWindow,
    item As Object,
    kind As DockingWindowItemKind
)

Parameters

container
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The DockingWindow used to display the specified item.
item
Type: SystemObject
The item.
kind
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowItemKind
The kind of the item.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ProcessDockHostKeyDown Method

DockSiteProcessDockHostKeyDown Method

Processes a key down event from a dock host.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void ProcessDockHostKeyDown(
    DockHost dockHost,
    KeyEventArgs e
)
Protected Overridable Sub ProcessDockHostKeyDown (
    dockHost As DockHost,
    e As KeyEventArgs
)

Parameters

dockHost
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The DockHost requesting processing.
e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.TileDocumentsHorizontally Method

DockSiteTileDocumentsHorizontally Method

Tiles all open documents horizontally, if using tabbed or standard MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void TileDocumentsHorizontally()
Public Sub TileDocumentsHorizontally
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.TileDocumentsVertically Method

DockSiteTileDocumentsVertically Method

Tiles all open documents vertically, if using tabbed or standard MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void TileDocumentsVertically()
Public Sub TileDocumentsVertically
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToHierarchyString Method

DockSiteToHierarchyString Method

Creates a string that contains a textual representation of the dock site hierarchy, useful for debugging purposes.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ToHierarchyString()
Public Function ToHierarchyString As String

Return Value

Type: String
The string that was created.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.UnlinkDockSite Method

DockSiteUnlinkDockSite Method

Unlinks this DockSite from the specified DockSite and vice versa.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void UnlinkDockSite(
    DockSite dockSite
)
Public Sub UnlinkDockSite (
    dockSite As DockSite
)

Parameters

dockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The DockSite to unlink.
Remarks
This method will completely unlink this DockSite from the specified DockSite. There is no need to call UnlinkDockSite(DockSite) on both DockSites.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite Events

The DockSite type exposes the following members.

Events
 | Name | Description
Public event | FloatingWindowOpening | Occurs when a floating window is opening, allowing for customization before it is displayed.
Public event | MdiKindChanged | Occurs when the MdiKind property is changed.
Public event | MenuOpening | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | NewWindowRequested | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PrimaryDocumentChanged | Occurs when the PrimaryDocument property has changed.
Public event | WindowActivated | Occurs after a DockingWindow has been activated.
Public event | WindowAutoHidePopupClosed | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
Public event | WindowAutoHidePopupOpened | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
Public event | WindowDeactivated | Occurs after a DockingWindow has been deactivated.
Public event | WindowDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Public event | WindowRegistered | Occurs after a DockingWindow has been registered.
Public event | WindowsAutoHiding | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
Public event | WindowsClosed | Occurs after one or more DockingWindow controls have been closed.
Public event | WindowsClosing | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
Public event | WindowsDockHostChanged | Occurs after one or more DockingWindow controls' DockHost properties have changed.
Public event | WindowsDragged | Occurs after one or more DockingWindow controls are dragged by the end user.
Public event | WindowsDragging | Occurs before one or more DockingWindow controls are dragged by the end user.
Public event | WindowsDragOver | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
Public event | WindowsOpened | Occurs after one or more DockingWindow controls have been opened.
Public event | WindowsOpening | Occurs before one or more DockingWindow controls is opened.
Public event | WindowsStateChanged | Occurs after one or more DockingWindow controls' states have changed.
Public event | WindowUnregistered | Occurs after a DockingWindow has been unregistered.
Top
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowOpening Event

DockSiteFloatingWindowOpening Event

Occurs when a floating window is opening, allowing for customization before it is displayed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<FloatingWindowOpeningEventArgs> FloatingWindowOpening
Public Event FloatingWindowOpening As EventHandler(Of FloatingWindowOpeningEventArgs)

Value

Type: SystemEventHandler FloatingWindowOpeningEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MdiKindChanged Event

DockSiteMdiKindChanged Event

Occurs when the MdiKind property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler MdiKindChanged
Public Event MdiKindChanged As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MenuOpening Event

DockSiteMenuOpening Event

Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingMenuEventArgs> MenuOpening
Public Event MenuOpening As EventHandler(Of DockingMenuEventArgs)

Value

Type: SystemEventHandler DockingMenuEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.NewWindowRequested Event

DockSiteNewWindowRequested Event

Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler NewWindowRequested
Public Event NewWindowRequested As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.PrimaryDocumentChanged Event

DockSitePrimaryDocumentChanged Event

Occurs when the PrimaryDocument property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> PrimaryDocumentChanged
Public Event PrimaryDocumentChanged As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowActivated Event

DockSiteWindowActivated Event

Occurs after a DockingWindow has been activated.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowActivated
Public Event WindowActivated As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowAutoHidePopupClosed Event

DockSiteWindowAutoHidePopupClosed Event

Occurs after an auto-hide popup has been closed that displayed a ToolWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowAutoHidePopupClosed
Public Event WindowAutoHidePopupClosed As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowAutoHidePopupOpened Event

DockSiteWindowAutoHidePopupOpened Event

Occurs after an auto-hide popup has been opened that displays a ToolWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowAutoHidePopupOpened
Public Event WindowAutoHidePopupOpened As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowDeactivated Event

DockSiteWindowDeactivated Event

Occurs after a DockingWindow has been deactivated.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowDeactivated
Public Event WindowDeactivated As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowDefaultLocationRequested Event

DockSiteWindowDefaultLocationRequested Event

Occurs when a DockingWindow's default location is requested.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowDefaultLocationEventArgs> WindowDefaultLocationRequested
Public Event WindowDefaultLocationRequested As EventHandler(Of DockingWindowDefaultLocationEventArgs)

Value

Type: SystemEventHandler DockingWindowDefaultLocationEventArgs
Remarks
The handler should examine the event arguments and set the Target and/or Side properties as appropriate.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowRegistered Event

DockSiteWindowRegistered Event

Occurs after a DockingWindow has been registered.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowRegistered
Public Event WindowRegistered As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsAutoHiding Event

DockSiteWindowsAutoHiding Event

Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsAutoHidingEventArgs> WindowsAutoHiding
Public Event WindowsAutoHiding As EventHandler(Of DockingWindowsAutoHidingEventArgs)

Value

Type: SystemEventHandler DockingWindowsAutoHidingEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsClosed Event

DockSiteWindowsClosed Event

Occurs after one or more DockingWindow controls have been closed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsClosed
Public Event WindowsClosed As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsClosing Event

DockSiteWindowsClosing Event

Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsClosing
Public Event WindowsClosing As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsDockHostChanged Event

DockSiteWindowsDockHostChanged Event

Occurs after one or more DockingWindow controls' DockHost properties have changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsDockHostChanged
Public Event WindowsDockHostChanged As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsDragged Event

DockSiteWindowsDragged Event

Occurs after one or more DockingWindow controls are dragged by the end user.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsDragged
Public Event WindowsDragged As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsDragging Event

DockSiteWindowsDragging Event

Occurs before one or more DockingWindow controls are dragged by the end user.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsDragging
Public Event WindowsDragging As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsDragOver Event

DockSiteWindowsDragOver Event

Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsDragOverEventArgs> WindowsDragOver
Public Event WindowsDragOver As EventHandler(Of DockingWindowsDragOverEventArgs)

Value

Type: SystemEventHandler DockingWindowsDragOverEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsOpened Event

DockSiteWindowsOpened Event

Occurs after one or more DockingWindow controls have been opened.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsOpened
Public Event WindowsOpened As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsOpening Event

DockSiteWindowsOpening Event

Occurs before one or more DockingWindow controls is opened.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsOpening
Public Event WindowsOpening As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsStateChanged Event

DockSiteWindowsStateChanged Event

Occurs after one or more DockingWindow controls' states have changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsStateChanged
Public Event WindowsStateChanged As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowUnregistered Event

DockSiteWindowUnregistered Event

Occurs after a DockingWindow has been unregistered.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowUnregistered
Public Event WindowUnregistered As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite Fields

The DockSite type exposes the following members.

Fields
Name | Description
ActiveWindowProperty | Identifies the ActiveWindow dependency property. This field is read-only.
AreDocumentWindowsDestroyedOnCloseProperty | Identifies the AreDocumentWindowsDestroyedOnClose dependency property. This field is read-only.
AreNewTabsInsertedBeforeExistingTabsProperty | Identifies the AreNewTabsInsertedBeforeExistingTabs dependency property. This field is read-only.
AutoHidePerContainerProperty | Identifies the AutoHidePerContainer dependency property. This field is read-only.
AutoHidePopupCloseAnimationDurationProperty | Identifies the AutoHidePopupCloseAnimationDuration dependency property. This field is read-only.
AutoHidePopupCloseDelayProperty | Identifies the AutoHidePopupCloseDelay dependency property. This field is read-only.
AutoHidePopupClosesOnLostFocusProperty | Identifies the AutoHidePopupClosesOnLostFocus dependency property. This field is read-only.
AutoHidePopupOpenAnimationDurationProperty | Identifies the AutoHidePopupOpenAnimationDuration dependency property. This field is read-only.
AutoHidePopupOpenDelayProperty | Identifies the AutoHidePopupOpenDelay dependency property. This field is read-only.
AutoHidePopupOpensOnMouseHoverProperty | Identifies the AutoHidePopupOpensOnMouseHover dependency property. This field is read-only.
AutoHideTabItemTemplateProperty | Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.
AutoHideTabItemTemplateSelectorProperty | Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.
CanDocumentWindowsCloseProperty | Identifies the CanDocumentWindowsClose dependency property. This field is read-only.
CanDocumentWindowsDragToLinkedDockSitesProperty | Identifies the CanDocumentWindowsDragToLinkedDockSites dependency property. This field is read-only.
CanDocumentWindowsFloatProperty | Identifies the CanDocumentWindowsFloat dependency property. This field is read-only.
CanFloatingDockHostsHideOnDockSiteUnloadProperty | Identifies the CanFloatingDockHostsHideOnDockSiteUnload dependency property. This field is read-only.
CanToolWindowsAttachProperty | Identifies the CanToolWindowsAttach dependency property. This field is read-only.
CanToolWindowsAutoHideProperty | Identifies the CanToolWindowsAutoHide dependency property. This field is read-only.
CanToolWindowsBecomeDocumentsProperty | Identifies the CanToolWindowsBecomeDocuments dependency property. This field is read-only.
CanToolWindowsCloseOnMiddleClickProperty | Identifies the CanToolWindowsCloseOnMiddleClick dependency property. This field is read-only.
CanToolWindowsCloseProperty | Identifies the CanToolWindowsClose dependency property. This field is read-only.
CanToolWindowsDockProperty | Identifies the CanToolWindowsDock dependency property. This field is read-only.
CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty | Identifies the CanToolWindowsDragToFloatingDockHostsWithWorkspaces dependency property. This field is read-only.
CanToolWindowsDragToLinkedDockSitesProperty | Identifies the CanToolWindowsDragToLinkedDockSites dependency property. This field is read-only.
CanToolWindowsFloatProperty | Identifies the CanToolWindowsFloat dependency property. This field is read-only.
CanToolWindowTabsDragProperty | Identifies the CanToolWindowTabsDrag dependency property. This field is read-only.
CanUpdateItemsSourceOnUnregisterProperty | Identifies the CanUpdateItemsSourceOnUnregister dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
ClosePerContainerProperty | Identifies the ClosePerContainer dependency property. This field is read-only.
DocumentItemContainerStyleProperty | Identifies the DocumentItemContainerStyle dependency property. This field is read-only.
DocumentItemContainerStyleSelectorProperty | Identifies the DocumentItemContainerStyleSelector dependency property. This field is read-only.
DocumentItemsSourceProperty | Identifies the DocumentItemsSource dependency property. This field is read-only.
DocumentItemTemplateProperty | Identifies the DocumentItemTemplate dependency property. This field is read-only.
DocumentItemTemplateSelectorProperty | Identifies the DocumentItemTemplateSelector dependency property. This field is read-only.
FloatingToolWindowContainersHaveMaximizeButtonsProperty | Identifies the FloatingToolWindowContainersHaveMaximizeButtons dependency property. This field is read-only.
FloatingToolWindowContainersHaveMinimizeButtonsProperty | Identifies the FloatingToolWindowContainersHaveMinimizeButtons dependency property. This field is read-only.
FloatingWindowIconProperty | Identifies the FloatingWindowIcon dependency property. This field is read-only.
FloatingWindowOpeningEvent | Identifies the FloatingWindowOpening routed event. This field is read-only.
FloatingWindowShowInTaskBarModeProperty | Identifies the FloatingWindowShowInTaskBarMode dependency property. This field is read-only.
FloatingWindowSnapToScreenThresholdProperty | Identifies the FloatingWindowSnapToScreenThreshold dependency property. This field is read-only.
FloatingWindowTitleProperty | Identifies the FloatingWindowTitle dependency property. This field is read-only.
HostedFloatingWindowContainerProperty | Identifies the HostedFloatingWindowContainer dependency property. This field is read-only.
InactiveFloatingWindowFadeDelayProperty | Identifies the InactiveFloatingWindowFadeDelay dependency property. This field is read-only.
InactiveFloatingWindowFadeDurationProperty | Identifies the InactiveFloatingWindowFadeDuration dependency property. This field is read-only.
InactiveFloatingWindowFadeOpacityProperty | Identifies the InactiveFloatingWindowFadeOpacity dependency property. This field is read-only.
IsDockGuideAnimationEnabledProperty | Identifies the IsDockGuideAnimationEnabled dependency property. This field is read-only.
IsFloatingWindowSnapToScreenEnabledProperty | Identifies the IsFloatingWindowSnapToScreenEnabled dependency property. This field is read-only.
IsInactiveFloatingWindowFadeEnabledProperty | Identifies the IsInactiveFloatingWindowFadeEnabled dependency property. This field is read-only.
IsLiveSplittingEnabledProperty | Identifies the IsLiveSplittingEnabled dependency property. This field is read-only.
IsTabLayoutAnimationEnabledProperty | Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.
MagnetismGapDistanceProperty | Identifies the MagnetismGapDistance dependency property. This field is read-only.
MagnetismSnapDistanceProperty | Identifies the MagnetismSnapDistance dependency property. This field is read-only.
MdiKindChangedEvent | Identifies the MdiKindChanged routed event. This field is read-only.
MdiKindProperty | Identifies the MdiKind dependency property. This field is read-only.
MenuOpeningEvent | Identifies the MenuOpening routed event. This field is read-only.
NewWindowRequestedEvent | Identifies the NewWindowRequested routed event. This field is read-only.
PrimaryDocumentChangedEvent | Identifies the PrimaryDocumentChanged routed event. This field is read-only.
PrimaryDocumentProperty | Identifies the PrimaryDocument dependency property. This field is read-only.
SplitterSizeProperty | Identifies the SplitterSize dependency property. This field is read-only.
SwitcherProperty | Identifies the Switcher dependency property. This field is read-only.
ToolItemContainerStyleProperty | Identifies the ToolItemContainerStyle dependency property. This field is read-only.
ToolItemContainerStyleSelectorProperty | Identifies the ToolItemContainerStyleSelector dependency property. This field is read-only.
ToolItemsSourceProperty | Identifies the ToolItemsSource dependency property. This field is read-only.
ToolItemTemplateProperty | Identifies the ToolItemTemplate dependency property. This field is read-only.
ToolItemTemplateSelectorProperty | Identifies the ToolItemTemplateSelector dependency property. This field is read-only.
ToolWindowsHaveCloseButtonsProperty | Identifies the ToolWindowsHaveCloseButtons dependency property. This field is read-only.
ToolWindowsHaveOptionsButtonsProperty | Identifies the ToolWindowsHaveOptionsButtons dependency property. This field is read-only.
ToolWindowsHaveTabImagesProperty | Identifies the ToolWindowsHaveTabImages dependency property. This field is read-only.
ToolWindowsHaveTitleBarIconsProperty | Identifies the ToolWindowsHaveTitleBarIcons dependency property. This field is read-only.
ToolWindowsHaveTitleBarsProperty | Identifies the ToolWindowsHaveTitleBars dependency property. This field is read-only.
ToolWindowsHaveToggleAutoHideButtonsProperty | Identifies the ToolWindowsHaveToggleAutoHideButtons dependency property. This field is read-only.
ToolWindowsSingleTabLayoutBehaviorProperty | Identifies the ToolWindowsSingleTabLayoutBehavior dependency property. This field is read-only.
ToolWindowsTabOverflowBehaviorProperty | Identifies the ToolWindowsTabOverflowBehavior dependency property. This field is read-only.
ToolWindowsTabStripPlacementProperty | Identifies the ToolWindowsTabStripPlacement dependency property. This field is read-only.
ToolWindowsTitleBarContextContentAlignmentProperty | Identifies the ToolWindowsTitleBarContextContentAlignment dependency property. This field is read-only.
ToolWindowTabItemContainerStyleProperty | Identifies the ToolWindowTabItemContainerStyle dependency property. This field is read-only.
UseDragFloatPreviewsProperty | Identifies the UseDragFloatPreviews dependency property. This field is read-only.
UseHostedFloatingWindowsProperty | Identifies the UseHostedFloatingWindows dependency property. This field is read-only.
UseHostedPopupsProperty | Identifies the UseHostedPopups dependency property. This field is read-only.
WindowActivatedEvent | Identifies the WindowActivated routed event. This field is read-only.
WindowAutoHidePopupClosedEvent | Identifies the WindowAutoHidePopupClosed routed event. This field is read-only.
WindowAutoHidePopupOpenedEvent | Identifies the WindowAutoHidePopupOpened routed event. This field is read-only.
WindowDeactivatedEvent | Identifies the WindowDeactivated routed event. This field is read-only.
WindowDefaultLocationRequestedEvent | Identifies the WindowDefaultLocationRequested routed event. This field is read-only.
WindowRegisteredEvent | Identifies the WindowRegistered routed event. This field is read-only.
WindowsAutoHidingEvent | Identifies the WindowsAutoHiding routed event. This field is read-only.
WindowsClosedEvent | Identifies the WindowsClosed routed event. This field is read-only.
WindowsClosingEvent | Identifies the WindowsClosing routed event. This field is read-only.
WindowsDockHostChangedEvent | Identifies the WindowsDockHostChanged routed event. This field is read-only.
WindowsDraggedEvent | Identifies the WindowsDragged routed event. This field is read-only.
WindowsDraggingEvent | Identifies the WindowsDragging routed event. This field is read-only.
WindowsDragOverEvent | Identifies the WindowsDragOver routed event. This field is read-only.
WindowsOpenedEvent | Identifies the WindowsOpened routed event. This field is read-only.
WindowsOpeningEvent | Identifies the WindowsOpening routed event. This field is read-only.
WindowsStateChangedEvent | Identifies the WindowsStateChanged routed event. This field is read-only.
WindowUnregisteredEvent | Identifies the WindowUnregistered routed event. This field is read-only.
Top
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ActiveWindowProperty Field

DockSiteActiveWindowProperty Field

Identifies the ActiveWindow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveWindowProperty
Public Shared ReadOnly ActiveWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveWindow dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AreDocumentWindowsDestroyedOnCloseProperty Field

DockSiteAreDocumentWindowsDestroyedOnCloseProperty Field

Identifies the AreDocumentWindowsDestroyedOnClose dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreDocumentWindowsDestroyedOnCloseProperty
Public Shared ReadOnly AreDocumentWindowsDestroyedOnCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreDocumentWindowsDestroyedOnClose dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AreNewTabsInsertedBeforeExistingTabsProperty Field

DockSiteAreNewTabsInsertedBeforeExistingTabsProperty Field

Identifies the AreNewTabsInsertedBeforeExistingTabs dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreNewTabsInsertedBeforeExistingTabsProperty
Public Shared ReadOnly AreNewTabsInsertedBeforeExistingTabsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreNewTabsInsertedBeforeExistingTabs dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePerContainerProperty Field

DockSiteAutoHidePerContainerProperty Field

Identifies the AutoHidePerContainer dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePerContainerProperty
Public Shared ReadOnly AutoHidePerContainerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePerContainer dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupCloseAnimationDurationProperty Field

DockSiteAutoHidePopupCloseAnimationDurationProperty Field

Identifies the AutoHidePopupCloseAnimationDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupCloseAnimationDurationProperty
Public Shared ReadOnly AutoHidePopupCloseAnimationDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupCloseAnimationDuration dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupCloseDelayProperty Field

DockSiteAutoHidePopupCloseDelayProperty Field

Identifies the AutoHidePopupCloseDelay dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupCloseDelayProperty
Public Shared ReadOnly AutoHidePopupCloseDelayProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupCloseDelay dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupClosesOnLostFocusProperty Field

DockSiteAutoHidePopupClosesOnLostFocusProperty Field

Identifies the AutoHidePopupClosesOnLostFocus dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupClosesOnLostFocusProperty
Public Shared ReadOnly AutoHidePopupClosesOnLostFocusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupClosesOnLostFocus dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupOpenAnimationDurationProperty Field

DockSiteAutoHidePopupOpenAnimationDurationProperty Field

Identifies the AutoHidePopupOpenAnimationDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupOpenAnimationDurationProperty
Public Shared ReadOnly AutoHidePopupOpenAnimationDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupOpenAnimationDuration dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupOpenDelayProperty Field

DockSiteAutoHidePopupOpenDelayProperty Field

Identifies the AutoHidePopupOpenDelay dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupOpenDelayProperty
Public Shared ReadOnly AutoHidePopupOpenDelayProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupOpenDelay dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHidePopupOpensOnMouseHoverProperty Field

DockSiteAutoHidePopupOpensOnMouseHoverProperty Field

Identifies the AutoHidePopupOpensOnMouseHover dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupOpensOnMouseHoverProperty
Public Shared ReadOnly AutoHidePopupOpensOnMouseHoverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupOpensOnMouseHover dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHideTabItemTemplateProperty Field

DockSiteAutoHideTabItemTemplateProperty Field

Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabItemTemplateProperty
Public Shared ReadOnly AutoHideTabItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabItemTemplate dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.AutoHideTabItemTemplateSelectorProperty Field

DockSiteAutoHideTabItemTemplateSelectorProperty Field

Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabItemTemplateSelectorProperty
Public Shared ReadOnly AutoHideTabItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabItemTemplateSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanDocumentWindowsCloseProperty Field

DockSiteCanDocumentWindowsCloseProperty Field

Identifies the CanDocumentWindowsClose dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentWindowsCloseProperty
Public Shared ReadOnly CanDocumentWindowsCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentWindowsClose dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanDocumentWindowsDragToLinkedDockSitesProperty Field

DockSiteCanDocumentWindowsDragToLinkedDockSitesProperty Field

Identifies the CanDocumentWindowsDragToLinkedDockSites dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentWindowsDragToLinkedDockSitesProperty
Public Shared ReadOnly CanDocumentWindowsDragToLinkedDockSitesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentWindowsDragToLinkedDockSites dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanDocumentWindowsFloatProperty Field

DockSiteCanDocumentWindowsFloatProperty Field

Identifies the CanDocumentWindowsFloat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentWindowsFloatProperty
Public Shared ReadOnly CanDocumentWindowsFloatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentWindowsFloat dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanFloatingDockHostsHideOnDockSiteUnloadProperty Field

DockSiteCanFloatingDockHostsHideOnDockSiteUnloadProperty Field

Identifies the CanFloatingDockHostsHideOnDockSiteUnload dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanFloatingDockHostsHideOnDockSiteUnloadProperty
Public Shared ReadOnly CanFloatingDockHostsHideOnDockSiteUnloadProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanFloatingDockHostsHideOnDockSiteUnload dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsAttachProperty Field

DockSiteCanToolWindowsAttachProperty Field

Identifies the CanToolWindowsAttach dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsAttachProperty
Public Shared ReadOnly CanToolWindowsAttachProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsAttach dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsAutoHideProperty Field

DockSiteCanToolWindowsAutoHideProperty Field

Identifies the CanToolWindowsAutoHide dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsAutoHideProperty
Public Shared ReadOnly CanToolWindowsAutoHideProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsAutoHide dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsBecomeDocumentsProperty Field

DockSiteCanToolWindowsBecomeDocumentsProperty Field

Identifies the CanToolWindowsBecomeDocuments dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsBecomeDocumentsProperty
Public Shared ReadOnly CanToolWindowsBecomeDocumentsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsBecomeDocuments dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsCloseOnMiddleClickProperty Field

DockSiteCanToolWindowsCloseOnMiddleClickProperty Field

Identifies the CanToolWindowsCloseOnMiddleClick dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsCloseOnMiddleClickProperty
Public Shared ReadOnly CanToolWindowsCloseOnMiddleClickProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsCloseOnMiddleClick dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsCloseProperty Field

DockSiteCanToolWindowsCloseProperty Field

Identifies the CanToolWindowsClose dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsCloseProperty
Public Shared ReadOnly CanToolWindowsCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsClose dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsDockProperty Field

DockSiteCanToolWindowsDockProperty Field

Identifies the CanToolWindowsDock dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsDockProperty
Public Shared ReadOnly CanToolWindowsDockProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsDock dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty Field

DockSiteCanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty Field

Identifies the CanToolWindowsDragToFloatingDockHostsWithWorkspaces dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty
Public Shared ReadOnly CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsDragToFloatingDockHostsWithWorkspaces dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsDragToLinkedDockSitesProperty Field

DockSiteCanToolWindowsDragToLinkedDockSitesProperty Field

Identifies the CanToolWindowsDragToLinkedDockSites dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsDragToLinkedDockSitesProperty
Public Shared ReadOnly CanToolWindowsDragToLinkedDockSitesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsDragToLinkedDockSites dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowsFloatProperty Field

DockSiteCanToolWindowsFloatProperty Field

Identifies the CanToolWindowsFloat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsFloatProperty
Public Shared ReadOnly CanToolWindowsFloatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsFloat dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanToolWindowTabsDragProperty Field

DockSiteCanToolWindowTabsDragProperty Field

Identifies the CanToolWindowTabsDrag dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowTabsDragProperty
Public Shared ReadOnly CanToolWindowTabsDragProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowTabsDrag dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.CanUpdateItemsSourceOnUnregisterProperty Field

DockSiteCanUpdateItemsSourceOnUnregisterProperty Field

Identifies the CanUpdateItemsSourceOnUnregister dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanUpdateItemsSourceOnUnregisterProperty
Public Shared ReadOnly CanUpdateItemsSourceOnUnregisterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanUpdateItemsSourceOnUnregister dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ChildProperty Field

DockSiteChildProperty Field

Identifies the Child dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildProperty
Public Shared ReadOnly ChildProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Child dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ClosePerContainerProperty Field

DockSiteClosePerContainerProperty Field

Identifies the ClosePerContainer dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClosePerContainerProperty
Public Shared ReadOnly ClosePerContainerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ClosePerContainer dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemContainerStyleProperty Field

DockSiteDocumentItemContainerStyleProperty Field

Identifies the DocumentItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemContainerStyleProperty
Public Shared ReadOnly DocumentItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemContainerStyle dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemContainerStyleSelectorProperty Field

DockSiteDocumentItemContainerStyleSelectorProperty Field

Identifies the DocumentItemContainerStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemContainerStyleSelectorProperty
Public Shared ReadOnly DocumentItemContainerStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemContainerStyleSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemsSourceProperty Field

DockSiteDocumentItemsSourceProperty Field

Identifies the DocumentItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemsSourceProperty
Public Shared ReadOnly DocumentItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemsSource dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemTemplateProperty Field

DockSiteDocumentItemTemplateProperty Field

Identifies the DocumentItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemTemplateProperty
Public Shared ReadOnly DocumentItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemTemplate dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.DocumentItemTemplateSelectorProperty Field

DockSiteDocumentItemTemplateSelectorProperty Field

Identifies the DocumentItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemTemplateSelectorProperty
Public Shared ReadOnly DocumentItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemTemplateSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingToolWindowContainersHaveMaximizeButtonsProperty Field

DockSiteFloatingToolWindowContainersHaveMaximizeButtonsProperty Field

Identifies the FloatingToolWindowContainersHaveMaximizeButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FloatingToolWindowContainersHaveMaximizeButtonsProperty
Public Shared ReadOnly FloatingToolWindowContainersHaveMaximizeButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FloatingToolWindowContainersHaveMaximizeButtons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingToolWindowContainersHaveMinimizeButtonsProperty Field

DockSiteFloatingToolWindowContainersHaveMinimizeButtonsProperty Field

Identifies the FloatingToolWindowContainersHaveMinimizeButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FloatingToolWindowContainersHaveMinimizeButtonsProperty
Public Shared ReadOnly FloatingToolWindowContainersHaveMinimizeButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FloatingToolWindowContainersHaveMinimizeButtons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowIconProperty Field

DockSiteFloatingWindowIconProperty Field

Identifies the FloatingWindowIcon dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FloatingWindowIconProperty
Public Shared ReadOnly FloatingWindowIconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FloatingWindowIcon dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowOpeningEvent Field

DockSiteFloatingWindowOpeningEvent Field

Identifies the FloatingWindowOpening routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent FloatingWindowOpeningEvent
Public Shared ReadOnly FloatingWindowOpeningEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the FloatingWindowOpening routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowShowInTaskBarModeProperty Field

DockSiteFloatingWindowShowInTaskBarModeProperty Field

Identifies the FloatingWindowShowInTaskBarMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FloatingWindowShowInTaskBarModeProperty
Public Shared ReadOnly FloatingWindowShowInTaskBarModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FloatingWindowShowInTaskBarMode dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowSnapToScreenThresholdProperty Field

DockSiteFloatingWindowSnapToScreenThresholdProperty Field

Identifies the FloatingWindowSnapToScreenThreshold dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FloatingWindowSnapToScreenThresholdProperty
Public Shared ReadOnly FloatingWindowSnapToScreenThresholdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FloatingWindowSnapToScreenThreshold dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.FloatingWindowTitleProperty Field

DockSiteFloatingWindowTitleProperty Field

Identifies the FloatingWindowTitle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FloatingWindowTitleProperty
Public Shared ReadOnly FloatingWindowTitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FloatingWindowTitle dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.HostedFloatingWindowContainerProperty Field

DockSiteHostedFloatingWindowContainerProperty Field

Identifies the HostedFloatingWindowContainer dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HostedFloatingWindowContainerProperty
Public Shared ReadOnly HostedFloatingWindowContainerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HostedFloatingWindowContainer dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeDelayProperty Field

DockSiteInactiveFloatingWindowFadeDelayProperty Field

Identifies the InactiveFloatingWindowFadeDelay dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InactiveFloatingWindowFadeDelayProperty
Public Shared ReadOnly InactiveFloatingWindowFadeDelayProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InactiveFloatingWindowFadeDelay dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeDurationProperty Field

DockSiteInactiveFloatingWindowFadeDurationProperty Field

Identifies the InactiveFloatingWindowFadeDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InactiveFloatingWindowFadeDurationProperty
Public Shared ReadOnly InactiveFloatingWindowFadeDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InactiveFloatingWindowFadeDuration dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeOpacityProperty Field

DockSiteInactiveFloatingWindowFadeOpacityProperty Field

Identifies the InactiveFloatingWindowFadeOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InactiveFloatingWindowFadeOpacityProperty
Public Shared ReadOnly InactiveFloatingWindowFadeOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InactiveFloatingWindowFadeOpacity dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsDockGuideAnimationEnabledProperty Field

DockSiteIsDockGuideAnimationEnabledProperty Field

Identifies the IsDockGuideAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDockGuideAnimationEnabledProperty
Public Shared ReadOnly IsDockGuideAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDockGuideAnimationEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsFloatingWindowSnapToScreenEnabledProperty Field

DockSiteIsFloatingWindowSnapToScreenEnabledProperty Field

Identifies the IsFloatingWindowSnapToScreenEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFloatingWindowSnapToScreenEnabledProperty
Public Shared ReadOnly IsFloatingWindowSnapToScreenEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFloatingWindowSnapToScreenEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsInactiveFloatingWindowFadeEnabledProperty Field

DockSiteIsInactiveFloatingWindowFadeEnabledProperty Field

Identifies the IsInactiveFloatingWindowFadeEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsInactiveFloatingWindowFadeEnabledProperty
Public Shared ReadOnly IsInactiveFloatingWindowFadeEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsInactiveFloatingWindowFadeEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsLiveSplittingEnabledProperty Field

DockSiteIsLiveSplittingEnabledProperty Field

Identifies the IsLiveSplittingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLiveSplittingEnabledProperty
Public Shared ReadOnly IsLiveSplittingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLiveSplittingEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.IsTabLayoutAnimationEnabledProperty Field

DockSiteIsTabLayoutAnimationEnabledProperty Field

Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabLayoutAnimationEnabledProperty
Public Shared ReadOnly IsTabLayoutAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabLayoutAnimationEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MagnetismGapDistanceProperty Field

DockSiteMagnetismGapDistanceProperty Field

Identifies the MagnetismGapDistance dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MagnetismGapDistanceProperty
Public Shared ReadOnly MagnetismGapDistanceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MagnetismGapDistance dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MagnetismSnapDistanceProperty Field

DockSiteMagnetismSnapDistanceProperty Field

Identifies the MagnetismSnapDistance dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MagnetismSnapDistanceProperty
Public Shared ReadOnly MagnetismSnapDistanceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MagnetismSnapDistance dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MdiKindChangedEvent Field

DockSiteMdiKindChangedEvent Field

Identifies the MdiKindChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent MdiKindChangedEvent
Public Shared ReadOnly MdiKindChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the MdiKindChanged routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MdiKindProperty Field

DockSiteMdiKindProperty Field

Identifies the MdiKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MdiKindProperty
Public Shared ReadOnly MdiKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MdiKind dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.MenuOpeningEvent Field

DockSiteMenuOpeningEvent Field

Identifies the MenuOpening routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent MenuOpeningEvent
Public Shared ReadOnly MenuOpeningEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the MenuOpening routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.NewWindowRequestedEvent Field

DockSiteNewWindowRequestedEvent Field

Identifies the NewWindowRequested routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent NewWindowRequestedEvent
Public Shared ReadOnly NewWindowRequestedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the NewWindowRequested routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.PrimaryDocumentChangedEvent Field

DockSitePrimaryDocumentChangedEvent Field

Identifies the PrimaryDocumentChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent PrimaryDocumentChangedEvent
Public Shared ReadOnly PrimaryDocumentChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the PrimaryDocumentChanged routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.PrimaryDocumentProperty Field

DockSitePrimaryDocumentProperty Field

Identifies the PrimaryDocument dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PrimaryDocumentProperty
Public Shared ReadOnly PrimaryDocumentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PrimaryDocument dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.SplitterSizeProperty Field

DockSiteSplitterSizeProperty Field

Identifies the SplitterSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SplitterSizeProperty
Public Shared ReadOnly SplitterSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SplitterSize dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.SwitcherProperty Field

DockSiteSwitcherProperty Field

Identifies the Switcher dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwitcherProperty
Public Shared ReadOnly SwitcherProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Switcher dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemContainerStyleProperty Field

DockSiteToolItemContainerStyleProperty Field

Identifies the ToolItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemContainerStyleProperty
Public Shared ReadOnly ToolItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemContainerStyle dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemContainerStyleSelectorProperty Field

DockSiteToolItemContainerStyleSelectorProperty Field

Identifies the ToolItemContainerStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemContainerStyleSelectorProperty
Public Shared ReadOnly ToolItemContainerStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemContainerStyleSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemsSourceProperty Field

DockSiteToolItemsSourceProperty Field

Identifies the ToolItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemsSourceProperty
Public Shared ReadOnly ToolItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemsSource dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemTemplateProperty Field

DockSiteToolItemTemplateProperty Field

Identifies the ToolItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemTemplateProperty
Public Shared ReadOnly ToolItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemTemplate dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolItemTemplateSelectorProperty Field

DockSiteToolItemTemplateSelectorProperty Field

Identifies the ToolItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemTemplateSelectorProperty
Public Shared ReadOnly ToolItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemTemplateSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveCloseButtonsProperty Field

DockSiteToolWindowsHaveCloseButtonsProperty Field

Identifies the ToolWindowsHaveCloseButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveCloseButtonsProperty
Public Shared ReadOnly ToolWindowsHaveCloseButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveCloseButtons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveOptionsButtonsProperty Field

DockSiteToolWindowsHaveOptionsButtonsProperty Field

Identifies the ToolWindowsHaveOptionsButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveOptionsButtonsProperty
Public Shared ReadOnly ToolWindowsHaveOptionsButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveOptionsButtons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveTabImagesProperty Field

DockSiteToolWindowsHaveTabImagesProperty Field

Identifies the ToolWindowsHaveTabImages dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveTabImagesProperty
Public Shared ReadOnly ToolWindowsHaveTabImagesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveTabImages dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveTitleBarIconsProperty Field

DockSiteToolWindowsHaveTitleBarIconsProperty Field

Identifies the ToolWindowsHaveTitleBarIcons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveTitleBarIconsProperty
Public Shared ReadOnly ToolWindowsHaveTitleBarIconsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveTitleBarIcons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveTitleBarsProperty Field

DockSiteToolWindowsHaveTitleBarsProperty Field

Identifies the ToolWindowsHaveTitleBars dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveTitleBarsProperty
Public Shared ReadOnly ToolWindowsHaveTitleBarsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveTitleBars dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsHaveToggleAutoHideButtonsProperty Field

DockSiteToolWindowsHaveToggleAutoHideButtonsProperty Field

Identifies the ToolWindowsHaveToggleAutoHideButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveToggleAutoHideButtonsProperty
Public Shared ReadOnly ToolWindowsHaveToggleAutoHideButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveToggleAutoHideButtons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsSingleTabLayoutBehaviorProperty Field

DockSiteToolWindowsSingleTabLayoutBehaviorProperty Field

Identifies the ToolWindowsSingleTabLayoutBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsSingleTabLayoutBehaviorProperty
Public Shared ReadOnly ToolWindowsSingleTabLayoutBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsSingleTabLayoutBehavior dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsTabOverflowBehaviorProperty Field

DockSiteToolWindowsTabOverflowBehaviorProperty Field

Identifies the ToolWindowsTabOverflowBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsTabOverflowBehaviorProperty
Public Shared ReadOnly ToolWindowsTabOverflowBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsTabOverflowBehavior dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsTabStripPlacementProperty Field

DockSiteToolWindowsTabStripPlacementProperty Field

Identifies the ToolWindowsTabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsTabStripPlacementProperty
Public Shared ReadOnly ToolWindowsTabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsTabStripPlacement dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowsTitleBarContextContentAlignmentProperty Field

DockSiteToolWindowsTitleBarContextContentAlignmentProperty Field

Identifies the ToolWindowsTitleBarContextContentAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsTitleBarContextContentAlignmentProperty
Public Shared ReadOnly ToolWindowsTitleBarContextContentAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsTitleBarContextContentAlignment dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.ToolWindowTabItemContainerStyleProperty Field

DockSiteToolWindowTabItemContainerStyleProperty Field

Identifies the ToolWindowTabItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowTabItemContainerStyleProperty
Public Shared ReadOnly ToolWindowTabItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowTabItemContainerStyle dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.UseDragFloatPreviewsProperty Field

DockSiteUseDragFloatPreviewsProperty Field

Identifies the UseDragFloatPreviews dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDragFloatPreviewsProperty
Public Shared ReadOnly UseDragFloatPreviewsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDragFloatPreviews dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.UseHostedFloatingWindowsProperty Field

DockSiteUseHostedFloatingWindowsProperty Field

Identifies the UseHostedFloatingWindows dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseHostedFloatingWindowsProperty
Public Shared ReadOnly UseHostedFloatingWindowsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseHostedFloatingWindows dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.UseHostedPopupsProperty Field

DockSiteUseHostedPopupsProperty Field

Identifies the UseHostedPopups dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseHostedPopupsProperty
Public Shared ReadOnly UseHostedPopupsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseHostedPopups dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowActivatedEvent Field

DockSiteWindowActivatedEvent Field

Identifies the WindowActivated routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowActivatedEvent
Public Shared ReadOnly WindowActivatedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowActivated routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowAutoHidePopupClosedEvent Field

DockSiteWindowAutoHidePopupClosedEvent Field

Identifies the WindowAutoHidePopupClosed routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowAutoHidePopupClosedEvent
Public Shared ReadOnly WindowAutoHidePopupClosedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowAutoHidePopupClosed routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowAutoHidePopupOpenedEvent Field

DockSiteWindowAutoHidePopupOpenedEvent Field

Identifies the WindowAutoHidePopupOpened routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowAutoHidePopupOpenedEvent
Public Shared ReadOnly WindowAutoHidePopupOpenedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowAutoHidePopupOpened routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowDeactivatedEvent Field

DockSiteWindowDeactivatedEvent Field

Identifies the WindowDeactivated routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowDeactivatedEvent
Public Shared ReadOnly WindowDeactivatedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowDeactivated routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowDefaultLocationRequestedEvent Field

DockSiteWindowDefaultLocationRequestedEvent Field

Identifies the WindowDefaultLocationRequested routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowDefaultLocationRequestedEvent
Public Shared ReadOnly WindowDefaultLocationRequestedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowDefaultLocationRequested routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowRegisteredEvent Field

DockSiteWindowRegisteredEvent Field

Identifies the WindowRegistered routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowRegisteredEvent
Public Shared ReadOnly WindowRegisteredEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowRegistered routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsAutoHidingEvent Field

DockSiteWindowsAutoHidingEvent Field

Identifies the WindowsAutoHiding routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsAutoHidingEvent
Public Shared ReadOnly WindowsAutoHidingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsAutoHiding routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsClosedEvent Field

DockSiteWindowsClosedEvent Field

Identifies the WindowsClosed routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsClosedEvent
Public Shared ReadOnly WindowsClosedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsClosed routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsClosingEvent Field

DockSiteWindowsClosingEvent Field

Identifies the WindowsClosing routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsClosingEvent
Public Shared ReadOnly WindowsClosingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsClosing routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsDockHostChangedEvent Field

DockSiteWindowsDockHostChangedEvent Field

Identifies the WindowsDockHostChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsDockHostChangedEvent
Public Shared ReadOnly WindowsDockHostChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsDockHostChanged routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsDraggedEvent Field

DockSiteWindowsDraggedEvent Field

Identifies the WindowsDragged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsDraggedEvent
Public Shared ReadOnly WindowsDraggedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsDragged routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsDraggingEvent Field

DockSiteWindowsDraggingEvent Field

Identifies the WindowsDragging routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsDraggingEvent
Public Shared ReadOnly WindowsDraggingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsDragging routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsDragOverEvent Field

DockSiteWindowsDragOverEvent Field

Identifies the WindowsDragOver routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsDragOverEvent
Public Shared ReadOnly WindowsDragOverEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsDragOver routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsOpenedEvent Field

DockSiteWindowsOpenedEvent Field

Identifies the WindowsOpened routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsOpenedEvent
Public Shared ReadOnly WindowsOpenedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsOpened routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsOpeningEvent Field

DockSiteWindowsOpeningEvent Field

Identifies the WindowsOpening routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsOpeningEvent
Public Shared ReadOnly WindowsOpeningEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsOpening routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowsStateChangedEvent Field

DockSiteWindowsStateChangedEvent Field

Identifies the WindowsStateChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowsStateChangedEvent
Public Shared ReadOnly WindowsStateChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowsStateChanged routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DockSite.WindowUnregisteredEvent Field

DockSiteWindowUnregisteredEvent Field

Identifies the WindowUnregistered routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent WindowUnregisteredEvent
Public Shared ReadOnly WindowUnregisteredEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the WindowUnregistered routed event.
See Also

Reference

DockSite Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Class

Represents a document window.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.DockingDockingWindow
ActiproSoftware.Windows.Controls.DockingDocumentWindow

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DocumentWindow : DockingWindow
Public Class DocumentWindow
    Inherits DockingWindow

The DocumentWindow type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentWindow | Initializes a new instance of the DocumentWindow class. When creating instances of DocumentWindow programmatically, use a constructor that accepts a DockSite instead.
Public method | DocumentWindow(Boolean) | Initializes a new instance of the DocumentWindow class.
Public method | DocumentWindow(DockSite) | Initializes a new instance of the DocumentWindow class.
Public method | DocumentWindow(DockSite, String, String, ImageSource, Object) | Initializes a new instance of the DocumentWindow class.
Top
Properties
 | Name | Description
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window. (Inherited from DockingWindow.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state. (Inherited from DockingWindow.)
Public property | CanClose | Gets or sets whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanDock | Gets or sets whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost. (Inherited from DockingWindow.)
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CloseAllInContainerCommand | Gets or sets the ICommand that can close all windows in the current container. (Inherited from DockingWindow.)
Public property | CloseCommand | Gets the ICommand that can Close the window. (Inherited from DockingWindow.)
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container. (Inherited from DockingWindow.)
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state. (Inherited from DockingWindow.)
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI. (Inherited from DockingWindow.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window. (Inherited from DockingWindow.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost in which the window is currently located. (Inherited from DockingWindow.)
Public property | DockSite | Gets the DockSite that is managing this docking window. (Inherited from DockingWindow.)
Public property | FileName | Gets or sets the full path to the document.
Public property | FloatCommand | Gets the ICommand that can Float the window. (Inherited from DockingWindow.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs. (Inherited from DockingWindow.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus. (Inherited from DockingWindow.)
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties. (Inherited from DockingWindow.)
Public property | IsFloating | Gets or sets whether the docking window is floating, meaning it is currently open in a floating DockHost, or is closed and was last open in a floating DockHost. (Inherited from DockingWindow.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout. (Inherited from DockingWindow.)
Public property | IsReadOnly | Gets or sets whether the document window is currently in a read-only state.
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container. (Inherited from DockingWindow.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from DockingWindow.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area. (Inherited from DockingWindow.)
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container. (Inherited from DockingWindow.)
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host. (Inherited from DockingWindow.)
Public property | OpenCommand | Gets the ICommand that can Open the window. (Inherited from DockingWindow.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window. (Inherited from DockingWindow.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data. (Inherited from DockingWindow.)
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter. (Inherited from DockingWindow.)
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content. (Inherited from DockingWindow.)
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state. (Inherited from DockingWindow.)
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window. (Inherited from DockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI. (Inherited from DockingWindow.)
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window. (Inherited from DockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview). (Inherited from DockingWindow.)
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab. (Inherited from DockingWindow.)
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled. (Inherited from DockingWindow.)
Public property | TabFlashMode | Gets or sets the flash mode for the tab. (Inherited from DockingWindow.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes. (Inherited from DockingWindow.)
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window. (Inherited from DockingWindow.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI. (Inherited from DockingWindow.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from DockingWindow.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity. (Inherited from DockingWindow.)
Top
Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it. (Inherited from DockingWindow.)
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it. (Inherited from DockingWindow.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | Attach | Attaches the DocumentWindow to the specified target, generally making a tabbed group.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window, removing it from the layout. (Inherited from DockingWindow.)
Public method | CloseAllInContainer | Closes all windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers | Closes all other windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite. (Inherited from DockingWindow.)
Public method | Dock | Docks the DocumentWindow to the side of a specified target.
Public method | DragMove | Programmatically starts a drag/move. (Inherited from DockingWindow.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the DocumentWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site. (Inherited from DockingWindow.)
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area. (Inherited from DockingWindow.)
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area. (Inherited from DockingWindow.)
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from DockingWindow.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed. (Inherited from DockingWindow.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Inherited from DockingWindow.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes. (Inherited from DockingWindow.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from DockingWindow.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed. (Overrides DockingWindowOnStateChanged(DockingWindowState, DockingWindowState).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | Open | Opens the window, inserting it into the layout. (Inherited from DockingWindow.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindow.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value. (Overrides DockingWindowUpdateCanAttachResolved.)
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value. (Inherited from DockingWindow.)
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value. (Overrides DockingWindowUpdateCanCloseResolved.)
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value. (Overrides DockingWindowUpdateCanDockResolved.)
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value. (Overrides DockingWindowUpdateCanDragTabResolved.)
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value. (Overrides DockingWindowUpdateCanDragToLinkedDockSitesResolved.)
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value. (Overrides DockingWindowUpdateCanFloatResolved.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Inherited from DockingWindow.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from DockingWindow.)
Top
Fields
Name | Description
FileNameProperty | Identifies the FileName dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Constructor

Overload List
 | Name | Description
Public method | DocumentWindow | Initializes a new instance of the DocumentWindow class. When creating instances of DocumentWindow programmatically, use a constructor that accepts a DockSite instead.
Public method | DocumentWindow(Boolean) | Initializes a new instance of the DocumentWindow class.
Public method | DocumentWindow(DockSite) | Initializes a new instance of the DocumentWindow class.
Public method | DocumentWindow(DockSite, String, String, ImageSource, Object) | Initializes a new instance of the DocumentWindow class.
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Constructor

Initializes a new instance of the DocumentWindow class. When creating instances of DocumentWindow programmatically, use a constructor that accepts a DockSite instead.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentWindow()
Public Sub New
See Also

Reference

DocumentWindow Class
DocumentWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Constructor (Boolean)

Initializes a new instance of the DocumentWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentWindow(
    bool isContainerForItem
)
Public Sub New (
    isContainerForItem As Boolean
)

Parameters

isContainerForItem
Type: SystemBoolean
Whether the window is a container for an item.
See Also

Reference

DocumentWindow Class
DocumentWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Constructor (DockSite)

Initializes a new instance of the DocumentWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentWindow(
    DockSite dockSite
)
Public Sub New (
    dockSite As DockSite
)

Parameters

dockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The DockSite with which to register this window.
See Also

Reference

DocumentWindow Class
DocumentWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Constructor (DockSite, String, String, ImageSource, Object)

Initializes a new instance of the DocumentWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentWindow(
    DockSite dockSite,
    string serializationId,
    string title,
    ImageSource imageSource,
    Object content
)
Public Sub New (
    dockSite As DockSite,
    serializationId As String,
    title As String,
    imageSource As ImageSource,
    content As Object
)

Parameters

dockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The DockSite with which to register this window.
serializationId
Type: SystemString
The serialization ID of the window, used during layout serialization.
title
Type: SystemString
The title of the window.
imageSource
Type: System.Windows.MediaImageSource
The image source for the window's icon.
content
Type: SystemObject
The content of the window.
See Also

Reference

DocumentWindow Class
DocumentWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Properties

The DocumentWindow type exposes the following members.

Properties
 | Name | Description
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window. (Inherited from DockingWindow.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state. (Inherited from DockingWindow.)
Public property | CanClose | Gets or sets whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanDock | Gets or sets whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost. (Inherited from DockingWindow.)
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CloseAllInContainerCommand | Gets or sets the ICommand that can close all windows in the current container. (Inherited from DockingWindow.)
Public property | CloseCommand | Gets the ICommand that can Close the window. (Inherited from DockingWindow.)
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container. (Inherited from DockingWindow.)
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state. (Inherited from DockingWindow.)
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI. (Inherited from DockingWindow.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window. (Inherited from DockingWindow.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost in which the window is currently located. (Inherited from DockingWindow.)
Public property | DockSite | Gets the DockSite that is managing this docking window. (Inherited from DockingWindow.)
Public property | FileName | Gets or sets the full path to the document.
Public property | FloatCommand | Gets the ICommand that can Float the window. (Inherited from DockingWindow.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs. (Inherited from DockingWindow.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus. (Inherited from DockingWindow.)
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties. (Inherited from DockingWindow.)
Public property | IsFloating | Gets or sets whether the docking window is floating, meaning it is currently open in a floating DockHost, or is closed and was last open in a floating DockHost. (Inherited from DockingWindow.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout. (Inherited from DockingWindow.)
Public property | IsReadOnly | Gets or sets whether the document window is currently in a read-only state.
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container. (Inherited from DockingWindow.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from DockingWindow.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area. (Inherited from DockingWindow.)
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container. (Inherited from DockingWindow.)
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host. (Inherited from DockingWindow.)
Public property | OpenCommand | Gets the ICommand that can Open the window. (Inherited from DockingWindow.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window. (Inherited from DockingWindow.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data. (Inherited from DockingWindow.)
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter. (Inherited from DockingWindow.)
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content. (Inherited from DockingWindow.)
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state. (Inherited from DockingWindow.)
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window. (Inherited from DockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI. (Inherited from DockingWindow.)
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window. (Inherited from DockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview). (Inherited from DockingWindow.)
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab. (Inherited from DockingWindow.)
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled. (Inherited from DockingWindow.)
Public property | TabFlashMode | Gets or sets the flash mode for the tab. (Inherited from DockingWindow.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes. (Inherited from DockingWindow.)
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window. (Inherited from DockingWindow.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI. (Inherited from DockingWindow.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from DockingWindow.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity. (Inherited from DockingWindow.)
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.FileName Property

DocumentWindowFileName Property

Gets or sets the full path to the document.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The full path to the document.
Remarks
This property is displayed on switchers.
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.IsReadOnly Property

DocumentWindowIsReadOnly Property

Gets or sets whether the document window is currently in a read-only state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document window is currently in a read-only state; otherwise, false. The default value is false.
Remarks
This flag is purely a visual cue to the end user that the contents of the document window are read-only.
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Methods

The DocumentWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it. (Inherited from DockingWindow.)
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it. (Inherited from DockingWindow.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | Attach | Attaches the DocumentWindow to the specified target, generally making a tabbed group.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window, removing it from the layout. (Inherited from DockingWindow.)
Public method | CloseAllInContainer | Closes all windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers | Closes all other windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite. (Inherited from DockingWindow.)
Public method | Dock | Docks the DocumentWindow to the side of a specified target.
Public method | DragMove | Programmatically starts a drag/move. (Inherited from DockingWindow.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the DocumentWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site. (Inherited from DockingWindow.)
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area. (Inherited from DockingWindow.)
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area. (Inherited from DockingWindow.)
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from DockingWindow.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed. (Inherited from DockingWindow.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Inherited from DockingWindow.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes. (Inherited from DockingWindow.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from DockingWindow.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed. (Overrides DockingWindowOnStateChanged(DockingWindowState, DockingWindowState).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | Open | Opens the window, inserting it into the layout. (Inherited from DockingWindow.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindow.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value. (Overrides DockingWindowUpdateCanAttachResolved.)
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value. (Inherited from DockingWindow.)
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value. (Overrides DockingWindowUpdateCanCloseResolved.)
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value. (Overrides DockingWindowUpdateCanDockResolved.)
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value. (Overrides DockingWindowUpdateCanDragTabResolved.)
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value. (Overrides DockingWindowUpdateCanDragToLinkedDockSitesResolved.)
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value. (Overrides DockingWindowUpdateCanFloatResolved.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Inherited from DockingWindow.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.Attach Method

DocumentWindowAttach Method

Attaches the DocumentWindow to the specified target, generally making a tabbed group.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Attach(
    IDockTarget target
)
Public Sub Attach (
    target As IDockTarget
)

Parameters

target
Type: ActiproSoftware.Windows.Controls.DockingIDockTarget
The IDockTarget against which to attach.
Remarks
The target must be another DocumentWindow or TabbedMdiContainer.
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.Dock Method

DocumentWindowDock Method

Docks the DocumentWindow to the side of a specified target.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Dock(
    IDockTarget target,
    Side side
)
Public Sub Dock (
    target As IDockTarget,
    side As Side
)

Parameters

target
Type: ActiproSoftware.Windows.Controls.DockingIDockTarget
The IDockTarget that is the target of the dock.
side
Type: ActiproSoftware.Windows.ControlsSide
The target's Side against which to dock.
Remarks
The target must be another DocumentWindow or TabbedMdiContainer. Use the Attach(IDockTarget) method to dock into a particular target.
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.Float Method

DocumentWindowFloat Method

Overload List
 | Name | Description
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the DocumentWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.Float Method (Nullable(Point), Nullable(Size))

DocumentWindowFloat Method (NullablePoint, NullableSize)

Floats the DocumentWindow to the specified optional location and size.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Float(
    Nullable<Point> location,
    Nullable<Size> size
)
Public Overrides Sub Float (
    location As Nullable(Of Point),
    size As Nullable(Of Size)
)

Parameters

location
Type: SystemNullable Point
An optional Point specifying the target location of the floating dock host.
size
Type: SystemNullable Size
An optional Size specifying the target size of the floating dock host.
Remarks
When location is not specified, it will float to a default location. When size is not specified, it will float with its current size. Using this method places the DocumentWindow in a new MDI host within a floating dock host.
See Also

Reference

DocumentWindow Class
Float Overload
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.OnCreateAutomationPeer Method

DocumentWindowOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.OnStateChanged Method

DocumentWindowOnStateChanged Method

Occurs when the value of the State property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnStateChanged(
    DockingWindowState oldValue,
    DockingWindowState newValue
)
Protected Overrides Sub OnStateChanged (
    oldValue As DockingWindowState,
    newValue As DockingWindowState
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowState
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowState
The new value.
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.UpdateCanAttachResolved Method

DocumentWindowUpdateCanAttachResolved Method

Updates the CanAttachResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanAttachResolved()
Protected Overrides Sub UpdateCanAttachResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.UpdateCanCloseResolved Method

DocumentWindowUpdateCanCloseResolved Method

Updates the CanCloseResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanCloseResolved()
Protected Overrides Sub UpdateCanCloseResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.UpdateCanDockResolved Method

DocumentWindowUpdateCanDockResolved Method

Updates the CanDockResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanDockResolved()
Protected Overrides Sub UpdateCanDockResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.UpdateCanDragTabResolved Method

DocumentWindowUpdateCanDragTabResolved Method

Updates the CanDragTabResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanDragTabResolved()
Protected Overrides Sub UpdateCanDragTabResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.UpdateCanDragToLinkedDockSitesResolved Method

DocumentWindowUpdateCanDragToLinkedDockSitesResolved Method

Updates the CanDragToLinkedDockSitesResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanDragToLinkedDockSitesResolved()
Protected Overrides Sub UpdateCanDragToLinkedDockSitesResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.UpdateCanFloatResolved Method

DocumentWindowUpdateCanFloatResolved Method

Updates the CanFloatResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanFloatResolved()
Protected Overrides Sub UpdateCanFloatResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Events

The DocumentWindow type exposes the following members.

Events
 | Name | Description
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from DockingWindow.)
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow Fields

The DocumentWindow type exposes the following members.

Fields
Name | Description
FileNameProperty | Identifies the FileName dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.FileNameProperty Field

DocumentWindowFileNameProperty Field

Identifies the FileName dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FileNameProperty
Public Shared ReadOnly FileNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FileName dependency property.
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindow.IsReadOnlyProperty Field

DocumentWindowIsReadOnlyProperty Field

Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

DocumentWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindowCollection Class

Represents an observable collection of DocumentWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection DocumentWindow
System.Collections.ObjectModelObservableCollection DocumentWindow
ActiproSoftware.WindowsDeferrableObservableCollection DocumentWindow
ActiproSoftware.Windows.Controls.DockingDockingWindowCollectionBase DocumentWindow
ActiproSoftware.Windows.Controls.DockingDocumentWindowCollection

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DocumentWindowCollection : DockingWindowCollectionBase<DocumentWindow>
Public Class DocumentWindowCollection
    Inherits DockingWindowCollectionBase(Of DocumentWindow)

The DocumentWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentWindowCollection | Initializes a new instance of the DocumentWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection DocumentWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection DocumentWindow .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection DocumentWindow .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection DocumentWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection DocumentWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection DocumentWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection DocumentWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection DocumentWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection DocumentWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection DocumentWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection DocumentWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection DocumentWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection DocumentWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection DocumentWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection DocumentWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection DocumentWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection DocumentWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection DocumentWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection DocumentWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection DocumentWindow .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindowCollection Constructor

Initializes a new instance of the DocumentWindowCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentWindowCollection()
Public Sub New
See Also

Reference

DocumentWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindowCollection Properties

The DocumentWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection DocumentWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection DocumentWindow .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection DocumentWindow .)
Top
See Also

Reference

DocumentWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindowCollection Methods

The DocumentWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection DocumentWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection DocumentWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection DocumentWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection DocumentWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection DocumentWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection DocumentWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection DocumentWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection DocumentWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection DocumentWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection DocumentWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection DocumentWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection DocumentWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection DocumentWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection DocumentWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection DocumentWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

DocumentWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


DocumentWindowCollection Events

The DocumentWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection DocumentWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection DocumentWindow .)
Top
See Also

Reference

DocumentWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


FloatingWindowOpeningEventArgs Class

Provides event arguments for floating window opening events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.Windows.Controls.DockingFloatingWindowOpeningEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FloatingWindowOpeningEventArgs : RoutedEventArgs
Public Class FloatingWindowOpeningEventArgs
    Inherits RoutedEventArgs

The FloatingWindowOpeningEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FloatingWindowOpeningEventArgs | Initializes a new instance of the FloatingWindowOpeningEventArgs class.
Top
Properties
 | Name | Description
Public property | DockHost | Gets the DockHost that will be the child of the floating window.
Public property | DockHostChild | Gets the child FrameworkElement of the DockHost.
Public property | Size | Gets or sets the Size of the floating window.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


FloatingWindowOpeningEventArgs Constructor

Initializes a new instance of the FloatingWindowOpeningEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FloatingWindowOpeningEventArgs(
    DockHost dockHost
)
Public Sub New (
    dockHost As DockHost
)

Parameters

dockHost
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The DockHost that will be the child of the floating window.
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


FloatingWindowOpeningEventArgs Properties

The FloatingWindowOpeningEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DockHost | Gets the DockHost that will be the child of the floating window.
Public property | DockHostChild | Gets the child FrameworkElement of the DockHost.
Public property | Size | Gets or sets the Size of the floating window.
Top
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


FloatingWindowOpeningEventArgs.DockHost Property

FloatingWindowOpeningEventArgsDockHost Property

Gets the DockHost that will be the child of the floating window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that will be the child of the floating window.
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


FloatingWindowOpeningEventArgs.DockHostChild Property

FloatingWindowOpeningEventArgsDockHostChild Property

Gets the child FrameworkElement of the DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FrameworkElement DockHostChild { get; }
Public ReadOnly Property DockHostChild As FrameworkElement
    Get

Property Value

Type: FrameworkElement
The child FrameworkElement of the DockHost.
Remarks
The Child property isn't populated when drag previews are used. This property always provides access to the element that will become the DockHost child in those scenarios.
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


FloatingWindowOpeningEventArgs.Size Property

FloatingWindowOpeningEventArgsSize Property

Gets or sets the Size of the floating window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
The Size of the floating window.
Remarks
This property is initialized to the default size and can be adjusted as appropriate.
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.Windows.Controls.Docking Namespace


FloatingWindowShowInTaskBarMode Enumeration

Specifies the mode by which to show floating windows in the taskbar.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum FloatingWindowShowInTaskBarMode
Public Enumeration FloatingWindowShowInTaskBarMode
Members
Member name | Value | Description
Default | 0 | Only show floating windows with dock hosts that contain workspaces in the taskbar (e.g. floating tabbed MDI documents).
Never | 1 | Never show floating windows in the taskbar.
Always | 2 | Always show floating windows in the taskbar.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


IDockTarget Interface

Provides the base requirements for an object that is a possible target for a docking operation.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDockTarget
Public Interface IDockTarget

The IDockTarget type exposes the following members.

Properties
 | Name | Description
Public property | DockHost | Gets the owner DockHost.
Public property | DockSite | Gets the DockSite that is managing this object.
Top
Methods
 | Name | Description
Public method | GetState | Returns the DockingWindowState that specifies the state of the docking location around the target.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


IDockTarget Properties

The IDockTarget type exposes the following members.

Properties
 | Name | Description
Public property | DockHost | Gets the owner DockHost.
Public property | DockSite | Gets the DockSite that is managing this object.
Top
See Also

Reference

IDockTarget Interface
ActiproSoftware.Windows.Controls.Docking Namespace


IDockTarget.DockHost Property

IDockTargetDockHost Property

Gets the owner DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DockHost DockHost { get; }
ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The owner DockHost.
See Also

Reference

IDockTarget Interface
ActiproSoftware.Windows.Controls.Docking Namespace


IDockTarget.DockSite Property

IDockTargetDockSite Property

Gets the DockSite that is managing this object.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DockSite DockSite { get; }
ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this object.
See Also

Reference

IDockTarget Interface
ActiproSoftware.Windows.Controls.Docking Namespace


IDockTarget Methods

The IDockTarget type exposes the following members.

Methods
 | Name | Description
Public method | GetState | Returns the DockingWindowState that specifies the state of the docking location around the target.
Top
See Also

Reference

IDockTarget Interface
ActiproSoftware.Windows.Controls.Docking Namespace


IDockTarget.GetState Method

IDockTargetGetState Method

Returns the DockingWindowState that specifies the state of the docking location around the target.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DockingWindowState GetState(
    Nullable<Side> side
)
Function GetState (
    side As Nullable(Of Side)
) As DockingWindowState

Parameters

side
Type: SystemNullable Side

[Missing <param name="side"/> documentation for "M:ActiproSoftware.Windows.Controls.Docking.IDockTarget.GetState(System.Nullable{ActiproSoftware.Windows.Controls.Side})"]

Field Value

Type: DockingWindowState
The DockingWindowState that specifies the state of the docking location around the target.

Return Value

Type: DockingWindowState

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Docking.IDockTarget.GetState(System.Nullable{ActiproSoftware.Windows.Controls.Side})"]

See Also

Reference

IDockTarget Interface
ActiproSoftware.Windows.Controls.Docking Namespace


InteropFocusTracking Class

Provides an attached behavior for ensuring that a HwndHost (such as a WindowsFormsHost or WebBrowser) properly registers activation in containing docking windows.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.DockingInteropFocusTracking

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class InteropFocusTracking
Public NotInheritable Class InteropFocusTracking

The InteropFocusTracking type exposes the following members.

Methods
Name | Description
GetIsEnabled | Gets the value of the IsEnabled attached property for the specified object.
SetIsEnabled | Sets the value of the IsEnabled attached property to the specified object.
Top
Fields
Name | Description
IsEnabledProperty | Identifies the IsEnabled dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | IsEnabled |
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


InteropFocusTracking Methods

The InteropFocusTracking type exposes the following members.

Methods
Name | Description
GetIsEnabled | Gets the value of the IsEnabled attached property for the specified object.
SetIsEnabled | Sets the value of the IsEnabled attached property to the specified object.
Top
See Also

Reference

InteropFocusTracking Class
ActiproSoftware.Windows.Controls.Docking Namespace


InteropFocusTracking.GetIsEnabled Method

InteropFocusTrackingGetIsEnabled Method

Gets the value of the IsEnabled attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsEnabled(
    HwndHost obj
)
Public Shared Function GetIsEnabled (
    obj As HwndHost
) As Boolean

Parameters

obj
Type: System.Windows.InteropHwndHost
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

InteropFocusTracking Class
ActiproSoftware.Windows.Controls.Docking Namespace


InteropFocusTracking.SetIsEnabled Method

InteropFocusTrackingSetIsEnabled Method

Sets the value of the IsEnabled attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIsEnabled(
    HwndHost obj,
    bool value
)
Public Shared Sub SetIsEnabled (
    obj As HwndHost,
    value As Boolean
)

Parameters

obj
Type: System.Windows.InteropHwndHost
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

InteropFocusTracking Class
ActiproSoftware.Windows.Controls.Docking Namespace


InteropFocusTracking Fields

The InteropFocusTracking type exposes the following members.

Fields
Name | Description
IsEnabledProperty | Identifies the IsEnabled dependency property. This field is read-only.
Top
See Also

Reference

InteropFocusTracking Class
ActiproSoftware.Windows.Controls.Docking Namespace


InteropFocusTracking.IsEnabledProperty Field

InteropFocusTrackingIsEnabledProperty Field

Identifies the IsEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEnabledProperty
Public Shared ReadOnly IsEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEnabled dependency property.
See Also

Reference

InteropFocusTracking Class
ActiproSoftware.Windows.Controls.Docking Namespace


InteropFocusTracking Attached Properties

The InteropFocusTracking type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsEnabled |
Top
See Also

Reference

InteropFocusTracking Class
ActiproSoftware.Windows.Controls.Docking Namespace


InteropFocusTracking.IsEnabled Attached Property

InteropFocusTrackingIsEnabled Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Docking.InteropFocusTracking.IsEnabled"]

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsEnabled, SetIsEnabled
See GetIsEnabled, SetIsEnabled

Property Value

Type: Boolean
See Also

Reference

InteropFocusTracking Class
ActiproSoftware.Windows.Controls.Docking Namespace


MdiKind Enumeration

Specifies the kind of MDI (multiple-document interface).

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MdiKind
Public Enumeration MdiKind
Members
Member name | Value | Description
None | 0 | No MDI.
Tabbed | 1 | Tabbed MDI.
Standard | 2 | Standard (windowed) MDI.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Class

ReadOnlyDockingWindowBaseCollectionT Class

Represents the base class for a read-only observable collection of DockingWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelReadOnlyCollection T
System.Collections.ObjectModelReadOnlyObservableCollection T
ActiproSoftware.Windows.Controls.DockingReadOnlyDockingWindowBaseCollectionT
ActiproSoftware.Windows.Controls.DockingReadOnlyDockingWindowCollection
ActiproSoftware.Windows.Controls.DockingReadOnlyToolWindowCollection

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReadOnlyDockingWindowBaseCollection<T> : ReadOnlyObservableCollection<T>
where T : DockingWindow

Public Class ReadOnlyDockingWindowBaseCollection(Of T As DockingWindow)
    Inherits ReadOnlyObservableCollection(Of T)

Type Parameters

T
The type of DockingWindow in this collection.

The ReadOnlyDockingWindowBaseCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOnlyDockingWindowBaseCollectionT | Initializes a new instance of the ReadOnlyDockingWindowBaseCollectionT class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionT instance. (Inherited from ReadOnlyCollection T.)
Public property | ItemInt32 | Gets the element at the specified index. (Inherited from ReadOnlyCollection T.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Protected property | Items | Returns the IListT that the ReadOnlyCollectionT wraps. (Inherited from ReadOnlyCollection T.)
Top
Methods
 | Name | Description
Public method | Contains(T) | Determines whether an element is in the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection T.)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Public method | CopyTo | Copies the entire ReadOnlyCollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection T.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection T.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollectionT. (Inherited from ReadOnlyCollection T.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Protected method | OnCollectionChanged | Raises the CollectionChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection T.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection T.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection.
Top
Events
 | Name | Description
Protected event | CollectionChanged | Occurs when an item is added or removed. (Inherited from ReadOnlyObservableCollection T.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ReadOnlyObservableCollection T.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Constructor

ReadOnlyDockingWindowBaseCollectionT Constructor

Initializes a new instance of the ReadOnlyDockingWindowBaseCollectionT class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyDockingWindowBaseCollection(
    ObservableCollection<T> list
)
Public Sub New (
    list As ObservableCollection(Of T)
)

Parameters

list
Type: System.Collections.ObjectModelObservableCollection T
The collection with which to create this instance.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Properties

ReadOnlyDockingWindowBaseCollectionT Properties

The ReadOnlyDockingWindowBaseCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionT instance. (Inherited from ReadOnlyCollection T .)
Public property | ItemInt32 | Gets the element at the specified index. (Inherited from ReadOnlyCollection T .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Protected property | Items | Returns the IListT that the ReadOnlyCollectionT wraps. (Inherited from ReadOnlyCollection T .)
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Item Property

ReadOnlyDockingWindowBaseCollectionTItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets the element at the specified index. (Inherited from ReadOnlyCollection T .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Item Property (Guid)

ReadOnlyDockingWindowBaseCollectionTItem Property (Guid)

Gets the item with the specified UniqueId value.

[C#] In C#, this property is the indexer for the collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T this[
    Guid uniqueId
] { get; }
Public ReadOnly Default Property Item (
    uniqueId As Guid
) As T
    Get

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Property Value

Type: T
The item with the specified UniqueId value.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
Item Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Item Property (String)

ReadOnlyDockingWindowBaseCollectionTItem Property (String)

Gets the item with the specified Name value.

[C#] In C#, this property is the indexer for the collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As T
    Get

Parameters

name
Type: SystemString
The name value to locate in the collection.

Property Value

Type: T
The item with the specified Name value.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
Item Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Methods

ReadOnlyDockingWindowBaseCollectionT Methods

The ReadOnlyDockingWindowBaseCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Contains(T) | Determines whether an element is in the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection T .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Public method | CopyTo | Copies the entire ReadOnlyCollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection T .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection T .)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollectionT. (Inherited from ReadOnlyCollection T .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Protected method | OnCollectionChanged | Raises the CollectionChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection T .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection T .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection.
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Contains Method

ReadOnlyDockingWindowBaseCollectionTContains Method

Overload List
 | Name | Description
Public method | Contains(T) | Determines whether an element is in the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection T .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Contains Method (Guid)

ReadOnlyDockingWindowBaseCollectionTContains Method (Guid)

Determines whether an item with the specified UniqueId value is in the collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    Guid uniqueId
)
Public Function Contains (
    uniqueId As Guid
) As Boolean

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Return Value

Type: Boolean
true if an item with the specified UniqueId value is found in the collection; otherwise, false.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
Contains Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Contains Method (String)

ReadOnlyDockingWindowBaseCollectionTContains Method (String)

Determines whether an item with the specified Name value is in the collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name value to locate in the collection.

Return Value

Type: Boolean
true if an item with the specified Name value is found in the collection; otherwise, false.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
Contains Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).IndexOf Method

ReadOnlyDockingWindowBaseCollectionTIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollectionT. (Inherited from ReadOnlyCollection T .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).IndexOf Method (Guid)

ReadOnlyDockingWindowBaseCollectionTIndexOf Method (Guid)

Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    Guid uniqueId
)
Public Function IndexOf (
    uniqueId As Guid
) As Integer

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of an item with the specified UniqueId value within the entire collection, if found; otherwise, -1.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
IndexOf Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).IndexOf Method (String)

ReadOnlyDockingWindowBaseCollectionTIndexOf Method (String)

Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    string name
)
Public Function IndexOf (
    name As String
) As Integer

Parameters

name
Type: SystemString
The name value to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of an item with the specified Name value within the entire collection, if found; otherwise, -1.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
IndexOf Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).ToArray Method

ReadOnlyDockingWindowBaseCollectionTToArray Method

Returns a strongly-typed array containing the items in this collection.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T[] ToArray()
Public Function ToArray As T()

Return Value

Type: T
A strongly-typed array containing the items in this collection.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Events

ReadOnlyDockingWindowBaseCollectionT Events

The ReadOnlyDockingWindowBaseCollectionT generic type exposes the following members.

Events
 | Name | Description
Protected event | CollectionChanged | Occurs when an item is added or removed. (Inherited from ReadOnlyObservableCollection T .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ReadOnlyObservableCollection T .)
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Class

Represents a read-only observable collection of DockingWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelReadOnlyCollection DockingWindow
System.Collections.ObjectModelReadOnlyObservableCollection DockingWindow
ActiproSoftware.Windows.Controls.DockingReadOnlyDockingWindowBaseCollection DockingWindow
ActiproSoftware.Windows.Controls.DockingReadOnlyDockingWindowCollection

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReadOnlyDockingWindowCollection : ReadOnlyDockingWindowBaseCollection<DockingWindow>
Public Class ReadOnlyDockingWindowCollection
    Inherits ReadOnlyDockingWindowBaseCollection(Of DockingWindow)

The ReadOnlyDockingWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOnlyDockingWindowCollection | Initializes an instance of the ReadOnlyDockingWindowCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionT instance. (Inherited from ReadOnlyCollection DockingWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemInt32 | Gets the element at the specified index. (Inherited from ReadOnlyCollection DockingWindow .)
Protected property | Items | Returns the IListT that the ReadOnlyCollectionT wraps. (Inherited from ReadOnlyCollection DockingWindow .)
Top
Methods
 | Name | Description
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(T) | Determines whether an element is in the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection DockingWindow .)
Public method | CopyTo | Copies the entire ReadOnlyCollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection DockingWindow .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection DockingWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollectionT. (Inherited from ReadOnlyCollection DockingWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection DockingWindow .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection DockingWindow .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Top
Events
 | Name | Description
Protected event | CollectionChanged | Occurs when an item is added or removed. (Inherited from ReadOnlyObservableCollection DockingWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ReadOnlyObservableCollection DockingWindow .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Constructor

Initializes an instance of the ReadOnlyDockingWindowCollection class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyDockingWindowCollection(
    ObservableCollection<DockingWindow> list
)
Public Sub New (
    list As ObservableCollection(Of DockingWindow)
)

Parameters

list
Type: System.Collections.ObjectModelObservableCollection DockingWindow
The collection with which to create this instance.
See Also

Reference

ReadOnlyDockingWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Properties

The ReadOnlyDockingWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionT instance. (Inherited from ReadOnlyCollection DockingWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemInt32 | Gets the element at the specified index. (Inherited from ReadOnlyCollection DockingWindow .)
Protected property | Items | Returns the IListT that the ReadOnlyCollectionT wraps. (Inherited from ReadOnlyCollection DockingWindow .)
Top
See Also

Reference

ReadOnlyDockingWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Methods

The ReadOnlyDockingWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(T) | Determines whether an element is in the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection DockingWindow .)
Public method | CopyTo | Copies the entire ReadOnlyCollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection DockingWindow .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection DockingWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollectionT. (Inherited from ReadOnlyCollection DockingWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection DockingWindow .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection DockingWindow .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Top
See Also

Reference

ReadOnlyDockingWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Events

The ReadOnlyDockingWindowCollection type exposes the following members.

Events
 | Name | Description
Protected event | CollectionChanged | Occurs when an item is added or removed. (Inherited from ReadOnlyObservableCollection DockingWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ReadOnlyObservableCollection DockingWindow .)
Top
See Also

Reference

ReadOnlyDockingWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyToolWindowCollection Class

Represents a read-only observable collection of ToolWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelReadOnlyCollection ToolWindow
System.Collections.ObjectModelReadOnlyObservableCollection ToolWindow
ActiproSoftware.Windows.Controls.DockingReadOnlyDockingWindowBaseCollection ToolWindow
ActiproSoftware.Windows.Controls.DockingReadOnlyToolWindowCollection

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ReadOnlyToolWindowCollection : ReadOnlyDockingWindowBaseCollection<ToolWindow>
Public Class ReadOnlyToolWindowCollection
    Inherits ReadOnlyDockingWindowBaseCollection(Of ToolWindow)

The ReadOnlyToolWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOnlyToolWindowCollection | Initializes an instance of the ReadOnlyToolWindowCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionT instance. (Inherited from ReadOnlyCollection ToolWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemInt32 | Gets the element at the specified index. (Inherited from ReadOnlyCollection ToolWindow .)
Protected property | Items | Returns the IListT that the ReadOnlyCollectionT wraps. (Inherited from ReadOnlyCollection ToolWindow .)
Top
Methods
 | Name | Description
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(T) | Determines whether an element is in the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection ToolWindow .)
Public method | CopyTo | Copies the entire ReadOnlyCollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection ToolWindow .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection ToolWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollectionT. (Inherited from ReadOnlyCollection ToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection ToolWindow .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection ToolWindow .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Top
Events
 | Name | Description
Protected event | CollectionChanged | Occurs when an item is added or removed. (Inherited from ReadOnlyObservableCollection ToolWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ReadOnlyObservableCollection ToolWindow .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyToolWindowCollection Constructor

Initializes an instance of the ReadOnlyToolWindowCollection class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyToolWindowCollection(
    ObservableCollection<ToolWindow> list
)
Public Sub New (
    list As ObservableCollection(Of ToolWindow)
)

Parameters

list
Type: System.Collections.ObjectModelObservableCollection ToolWindow
The collection with which to create this instance.
See Also

Reference

ReadOnlyToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyToolWindowCollection Properties

The ReadOnlyToolWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionT instance. (Inherited from ReadOnlyCollection ToolWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemInt32 | Gets the element at the specified index. (Inherited from ReadOnlyCollection ToolWindow .)
Protected property | Items | Returns the IListT that the ReadOnlyCollectionT wraps. (Inherited from ReadOnlyCollection ToolWindow .)
Top
See Also

Reference

ReadOnlyToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyToolWindowCollection Methods

The ReadOnlyToolWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(T) | Determines whether an element is in the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection ToolWindow .)
Public method | CopyTo | Copies the entire ReadOnlyCollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection ToolWindow .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionT. (Inherited from ReadOnlyCollection ToolWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollectionT. (Inherited from ReadOnlyCollection ToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection ToolWindow .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event using the provided arguments. (Inherited from ReadOnlyObservableCollection ToolWindow .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Top
See Also

Reference

ReadOnlyToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ReadOnlyToolWindowCollection Events

The ReadOnlyToolWindowCollection type exposes the following members.

Events
 | Name | Description
Protected event | CollectionChanged | Occurs when an item is added or removed. (Inherited from ReadOnlyObservableCollection ToolWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ReadOnlyObservableCollection ToolWindow .)
Top
See Also

Reference

ReadOnlyToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


SimpleSwitcher Class

Implements a SwitcherBase that has no user interface and simply processes keystrokes.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesSwitcherBase
ActiproSoftware.Windows.Controls.DockingSimpleSwitcher

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SimpleSwitcher : SwitcherBase
Public Class SimpleSwitcher
    Inherits SwitcherBase

The SimpleSwitcher type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleSwitcher | Initializes a new instance of the SimpleSwitcher class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active. (Inherited from SwitcherBase.)
Public property | Documents | Gets the collection of open documents in the MDI area. (Inherited from SwitcherBase.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOpen | Gets whether the switcher is currently open and active. (Inherited from SwitcherBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected. (Inherited from SwitcherBase.)
Public property | SelectNextDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextDocument method by default. (Inherited from SwitcherBase.)
Public property | SelectNextToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextToolWindow method by default. (Inherited from SwitcherBase.)
Public property | SelectPreviousDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousDocument method by default. (Inherited from SwitcherBase.)
Public property | SelectPreviousToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousToolWindow method by default. (Inherited from SwitcherBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area. (Inherited from SwitcherBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the switcher. (Inherited from SwitcherBase.)
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher. (Inherited from SwitcherBase.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher. (Inherited from SwitcherBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnClosed | Invoked when the switcher is closed. (Inherited from SwitcherBase.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from SwitcherBase.)
Protected method | OnKeyUp | Occurs when a key is released. (Inherited from SwitcherBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from SwitcherBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened. (Inherited from SwitcherBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides SwitcherBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SelectNextDocument | Selects the next document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousDocument | Selects the previous document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher. (Inherited from SwitcherBase.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


SimpleSwitcher Constructor

Initializes a new instance of the SimpleSwitcher class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SimpleSwitcher()
Public Sub New
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


SimpleSwitcher Properties

The SimpleSwitcher type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active. (Inherited from SwitcherBase.)
Public property | Documents | Gets the collection of open documents in the MDI area. (Inherited from SwitcherBase.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOpen | Gets whether the switcher is currently open and active. (Inherited from SwitcherBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected. (Inherited from SwitcherBase.)
Public property | SelectNextDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextDocument method by default. (Inherited from SwitcherBase.)
Public property | SelectNextToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextToolWindow method by default. (Inherited from SwitcherBase.)
Public property | SelectPreviousDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousDocument method by default. (Inherited from SwitcherBase.)
Public property | SelectPreviousToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousToolWindow method by default. (Inherited from SwitcherBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area. (Inherited from SwitcherBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


SimpleSwitcher Methods

The SimpleSwitcher type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the switcher. (Inherited from SwitcherBase.)
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher. (Inherited from SwitcherBase.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher. (Inherited from SwitcherBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnClosed | Invoked when the switcher is closed. (Inherited from SwitcherBase.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from SwitcherBase.)
Protected method | OnKeyUp | Occurs when a key is released. (Inherited from SwitcherBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from SwitcherBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened. (Inherited from SwitcherBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides SwitcherBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SelectNextDocument | Selects the next document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousDocument | Selects the previous document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher. (Inherited from SwitcherBase.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


SimpleSwitcher.OnSelectedWindowChanged Method

SimpleSwitcherOnSelectedWindowChanged Method

Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnSelectedWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overrides Sub OnSelectedWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The new value.
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


SimpleSwitcher Events

The SimpleSwitcher type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


SingleTabLayoutBehavior Enumeration

Indicates the behavior of single tabs in their associated containers.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SingleTabLayoutBehavior
Public Enumeration SingleTabLayoutBehavior
Members
Member name | Value | Description
Hide | 0 | Indicates that the tab panel will be hidden when there is a single tab.
Show | 1 | Indicates that the single tab will be displayed normally.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


SizeToContentModes Enumeration

Specifies the modes when size-to-content should be applied.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SizeToContentModes
Public Enumeration SizeToContentModes
Members
Member name | Value | Description
None | 0 | No size-to-content modes.
StandardMdi | 1 | Size-to-content when entering standard MDI.
Floating | 2 | Size-to-content when entering a floating window.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer Class

Represents a container that has multiple split panes of content.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.DockingSplitContainer

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SplitContainer : Control,
    IOrientedElement
Public Class SplitContainer
    Inherits Control
    Implements IOrientedElement

The SplitContainer type exposes the following members.

Constructors
 | Name | Description
Public method | SplitContainer | Initializes an instance of the SplitContainer class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Children | Gets the collection of child FrameworkElement objects.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResizeSlots | Resizes the slots based on the specified ratios, if any.
Public method | ReverseSlots | Reverses the slots.
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer Constructor

Initializes an instance of the SplitContainer class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SplitContainer()
Public Sub New
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer Properties

The SplitContainer type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Children | Gets the collection of child FrameworkElement objects.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.Children Property

SplitContainerChildren Property

Gets the collection of child FrameworkElement objects.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<FrameworkElement> Children { get; }
Public ReadOnly Property Children As ObservableCollection(Of FrameworkElement)
    Get

Property Value

Type: ObservableCollection FrameworkElement
The collection of child FrameworkElement objects.
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.DockHost Property

SplitContainerDockHost Property

Gets the DockHost that contains this control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.DockSite Property

SplitContainerDockSite Property

Gets the DockSite that is managing this control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this control.
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.Orientation Property

SplitContainerOrientation Property

Gets or sets the Orientation of the child element layout.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Horizontal.

Implements

IOrientedElementOrientation
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer Methods

The SplitContainer type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResizeSlots | Resizes the slots based on the specified ratios, if any.
Public method | ReverseSlots | Reverses the slots.
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.OnApplyTemplate Method

SplitContainerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.OnCreateAutomationPeer Method

SplitContainerOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.ResizeSlots Method

SplitContainerResizeSlots Method

Resizes the slots based on the specified ratios, if any.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ResizeSlots(
    params double[] desiredRatios
)
Public Sub ResizeSlots (
    ParamArray desiredRatios As Double()
)

Parameters

desiredRatios
Type: SystemDouble
This list of zero or more desired ratios.
Remarks
If desiredRatios contains 0-1 items, then the slots will be resized equally. Otherwise, the specified ratio will be applied to the associated slot (i.e. the slot that shared the same index). If there are more slots than there are desired ratios, then the last ratio will be repeated for the remaining slots.
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.ReverseSlots Method

SplitContainerReverseSlots Method

Reverses the slots.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ReverseSlots()
Public Sub ReverseSlots
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.ToString Method

SplitContainerToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer Events

The SplitContainer type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer Fields

The SplitContainer type exposes the following members.

Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


SplitContainer.OrientationProperty Field

SplitContainerOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

SplitContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost Class

Represents a container that hosts docking windows in a standard, or windowed, MDI (multiple-document interface) mode.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesMdiHostBase
ActiproSoftware.Windows.Controls.DockingStandardMdiHost

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StandardMdiHost : MdiHostBase,
    IDockTarget
Public Class StandardMdiHost
    Inherits MdiHostBase
    Implements IDockTarget

The StandardMdiHost type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiHost | Initializes an instance of the StandardMdiHost class.
Top
Properties
 | Name | Description
Public property | AreMaximizedWindowFramesVisible | Gets or sets whether the frames should be displayed when the windows are maximized.
Public property | AreWindowsMaximized | Gets or sets whether windows in the host are currently maximized.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanWindowsMaximize | Gets or sets whether the windows in this host can be maximized.
Public property | CanWindowsMinimize | Gets or sets whether the windows in this host can be minimized.
Public property | ClosePrimaryWindowCommand | Gets the ICommand that can close the PrimaryWindow.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from MdiHostBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from MdiHostBase.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAutoCascadeEnabled | Gets or sets a value indicating whether the windows should be automatically cascaded on the initial load.
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents). (Inherited from MdiHostBase.)
Public property | IsExternalMaximizedUIRequired | Gets whether external maximized window UI (generally minimize, restore, and close buttons) should be visible.
Public property | IsScrollingEnabled | Gets or sets a value indicating whether scrolling is supported by the standard MDI host.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MaximizePrimaryWindowCommand | Gets the ICommand that can maximize the PrimaryWindow.
Public property | MinimizePrimaryWindowCommand | Gets the ICommand that can minimize the PrimaryWindow.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host. (Inherited from MdiHostBase.)
Public property | RestorePrimaryWindowCommand | Gets the ICommand that can restore the PrimaryWindow.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ArrangeMinimizedWindows | Re-arranges the minimized windows.
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | Cascade | Cascades the open documents.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClosePrimaryWindow | Closes the PrimaryWindow, if any.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetDocuments | Returns the list of docking windows within the MDI. (Overrides MdiHostBaseGetDocuments.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MaximizePrimaryWindow | Maximizes the PrimaryWindow, if any.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MinimizePrimaryWindow | Minimizes the PrimaryWindow, if any.
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides MdiHostBaseOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed. (Inherited from MdiHostBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed. (Overrides MdiHostBaseOnPrimaryWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RestorePrimaryWindow | Restores the PrimaryWindow, if any.
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileVertically | Tiles the open documents vertically.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed. (Inherited from MdiHostBase.)
Top
Fields
Name | Description
AreMaximizedWindowFramesVisibleProperty | Identifies the AreMaximizedWindowFramesVisible dependency property. This field is read-only.
AreWindowsMaximizedProperty | Identifies the AreWindowsMaximized dependency property. This field is read-only.
CanWindowsMaximizeProperty | Identifies the CanWindowsMaximize dependency property. This field is read-only.
CanWindowsMinimizeProperty | Identifies the CanWindowsMinimize dependency property. This field is read-only.
IsAutoCascadeEnabledProperty | Identifies the IsAutoCascadeEnabled dependency property. This field is read-only.
IsExternalMaximizedUIRequiredProperty | Identifies the IsExternalMaximizedUIRequired dependency property. This field is read-only.
IsScrollingEnabledProperty | Identifies the IsScrollingEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost Constructor

Initializes an instance of the StandardMdiHost class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StandardMdiHost()
Public Sub New
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost Properties

The StandardMdiHost type exposes the following members.

Properties
 | Name | Description
Public property | AreMaximizedWindowFramesVisible | Gets or sets whether the frames should be displayed when the windows are maximized.
Public property | AreWindowsMaximized | Gets or sets whether windows in the host are currently maximized.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanWindowsMaximize | Gets or sets whether the windows in this host can be maximized.
Public property | CanWindowsMinimize | Gets or sets whether the windows in this host can be minimized.
Public property | ClosePrimaryWindowCommand | Gets the ICommand that can close the PrimaryWindow.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from MdiHostBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from MdiHostBase.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAutoCascadeEnabled | Gets or sets a value indicating whether the windows should be automatically cascaded on the initial load.
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents). (Inherited from MdiHostBase.)
Public property | IsExternalMaximizedUIRequired | Gets whether external maximized window UI (generally minimize, restore, and close buttons) should be visible.
Public property | IsScrollingEnabled | Gets or sets a value indicating whether scrolling is supported by the standard MDI host.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MaximizePrimaryWindowCommand | Gets the ICommand that can maximize the PrimaryWindow.
Public property | MinimizePrimaryWindowCommand | Gets the ICommand that can minimize the PrimaryWindow.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host. (Inherited from MdiHostBase.)
Public property | RestorePrimaryWindowCommand | Gets the ICommand that can restore the PrimaryWindow.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Top
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.AreMaximizedWindowFramesVisible Property

StandardMdiHostAreMaximizedWindowFramesVisible Property

Gets or sets whether the frames should be displayed when the windows are maximized.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreMaximizedWindowFramesVisible { get; set; }
Public Property AreMaximizedWindowFramesVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the frames should be displayed when the windows are maximized; otherwise, false. The default value is true.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.AreWindowsMaximized Property

StandardMdiHostAreWindowsMaximized Property

Gets or sets whether windows in the host are currently maximized.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreWindowsMaximized { get; set; }
Public Property AreWindowsMaximized As Boolean
    Get
    Set

Property Value

Type: Boolean
true if windows in the host are currently maximized; otherwise, false. The default value is false.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.CanWindowsMaximize Property

StandardMdiHostCanWindowsMaximize Property

Gets or sets whether the windows in this host can be maximized.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanWindowsMaximize { get; set; }
Public Property CanWindowsMaximize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the windows in this host can be maximized; otherwise, false. The default value is true.
Remarks
This setting only affects docking windows whose CanStandardMdiMaximize property is set to . Any other setting on the docking window instance overrides this global setting.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.CanWindowsMinimize Property

StandardMdiHostCanWindowsMinimize Property

Gets or sets whether the windows in this host can be minimized.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanWindowsMinimize { get; set; }
Public Property CanWindowsMinimize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the windows in this host can be minimized; otherwise, false. The default value is true.
Remarks
This setting only affects docking windows whose CanStandardMdiMinimize property is set to . Any other setting on the docking window instance overrides this global setting.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.ClosePrimaryWindowCommand Property

StandardMdiHostClosePrimaryWindowCommand Property

Gets the ICommand that can close the PrimaryWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ClosePrimaryWindowCommand { get; }
Public ReadOnly Property ClosePrimaryWindowCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close the PrimaryWindow.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.IsAutoCascadeEnabled Property

StandardMdiHostIsAutoCascadeEnabled Property

Gets or sets a value indicating whether the windows should be automatically cascaded on the initial load.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAutoCascadeEnabled { get; set; }
Public Property IsAutoCascadeEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the windows should be automatically cascaded on the initial load; otherwise false. The default value is true.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.IsExternalMaximizedUIRequired Property

StandardMdiHostIsExternalMaximizedUIRequired Property

Gets whether external maximized window UI (generally minimize, restore, and close buttons) should be visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsExternalMaximizedUIRequired { get; }
Public ReadOnly Property IsExternalMaximizedUIRequired As Boolean
    Get

Property Value

Type: Boolean
true if external maximized window UI should be visible; otherwise false. The default value is false.
Remarks
This property can be bound to the visibility of an external UI panel. It is only true when a document is maximized and AreMaximizedWindowFramesVisible is false.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.IsScrollingEnabled Property

StandardMdiHostIsScrollingEnabled Property

Gets or sets a value indicating whether scrolling is supported by the standard MDI host.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsScrollingEnabled { get; set; }
Public Property IsScrollingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if scrolling is supported by the standard MDI host; otherwise false. The default value is false.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.LogicalChildren Property

StandardMdiHostLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.MaximizePrimaryWindowCommand Property

StandardMdiHostMaximizePrimaryWindowCommand Property

Gets the ICommand that can maximize the PrimaryWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MaximizePrimaryWindowCommand { get; }
Public ReadOnly Property MaximizePrimaryWindowCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can maximize the PrimaryWindow.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.MinimizePrimaryWindowCommand Property

StandardMdiHostMinimizePrimaryWindowCommand Property

Gets the ICommand that can minimize the PrimaryWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MinimizePrimaryWindowCommand { get; }
Public ReadOnly Property MinimizePrimaryWindowCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can minimize the PrimaryWindow.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.RestorePrimaryWindowCommand Property

StandardMdiHostRestorePrimaryWindowCommand Property

Gets the ICommand that can restore the PrimaryWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand RestorePrimaryWindowCommand { get; }
Public ReadOnly Property RestorePrimaryWindowCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can restore the PrimaryWindow.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.Windows Property

StandardMdiHostWindows Property

Gets the collection of child DockingWindow objects.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<DockingWindow> Windows { get; }
Public ReadOnly Property Windows As ObservableCollection(Of DockingWindow)
    Get

Property Value

Type: ObservableCollection DockingWindow
The collection of child DockingWindow objects.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost Methods

The StandardMdiHost type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ArrangeMinimizedWindows | Re-arranges the minimized windows.
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | Cascade | Cascades the open documents.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClosePrimaryWindow | Closes the PrimaryWindow, if any.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetDocuments | Returns the list of docking windows within the MDI. (Overrides MdiHostBaseGetDocuments.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MaximizePrimaryWindow | Maximizes the PrimaryWindow, if any.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MinimizePrimaryWindow | Minimizes the PrimaryWindow, if any.
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides MdiHostBaseOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed. (Inherited from MdiHostBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed. (Overrides MdiHostBaseOnPrimaryWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RestorePrimaryWindow | Restores the PrimaryWindow, if any.
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileVertically | Tiles the open documents vertically.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.ArrangeMinimizedWindows Method

StandardMdiHostArrangeMinimizedWindows Method

Re-arranges the minimized windows.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ArrangeMinimizedWindows()
Public Sub ArrangeMinimizedWindows
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.Cascade Method

StandardMdiHostCascade Method

Cascades the open documents.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Cascade()
Public Sub Cascade
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.ClosePrimaryWindow Method

StandardMdiHostClosePrimaryWindow Method

Closes the PrimaryWindow, if any.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ClosePrimaryWindow()
Public Sub ClosePrimaryWindow
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.GetDocuments Method

StandardMdiHostGetDocuments Method

Returns the list of docking windows within the MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed IList<DockingWindow> GetDocuments()
Public Overrides NotOverridable Function GetDocuments As IList(Of DockingWindow)

Return Value

Type: IList DockingWindow
The list of docking windows within the MDI.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.MaximizePrimaryWindow Method

StandardMdiHostMaximizePrimaryWindow Method

Maximizes the PrimaryWindow, if any.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void MaximizePrimaryWindow()
Public Sub MaximizePrimaryWindow
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.MinimizePrimaryWindow Method

StandardMdiHostMinimizePrimaryWindow Method

Minimizes the PrimaryWindow, if any.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void MinimizePrimaryWindow()
Public Sub MinimizePrimaryWindow
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.OnApplyTemplate Method

StandardMdiHostOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.OnCreateAutomationPeer Method

StandardMdiHostOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.OnPrimaryWindowChanged Method

StandardMdiHostOnPrimaryWindowChanged Method

Occurs when the value of the PrimaryWindow property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPrimaryWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overrides Sub OnPrimaryWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The new value.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.RestorePrimaryWindow Method

StandardMdiHostRestorePrimaryWindow Method

Restores the PrimaryWindow, if any.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RestorePrimaryWindow()
Public Sub RestorePrimaryWindow
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.TileHorizontally Method

StandardMdiHostTileHorizontally Method

Tiles the open documents horizontally.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void TileHorizontally()
Public Sub TileHorizontally
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.TileVertically Method

StandardMdiHostTileVertically Method

Tiles the open documents vertically.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void TileVertically()
Public Sub TileVertically
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost Events

The StandardMdiHost type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed. (Inherited from MdiHostBase.)
Top
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost Fields

The StandardMdiHost type exposes the following members.

Fields
Name | Description
AreMaximizedWindowFramesVisibleProperty | Identifies the AreMaximizedWindowFramesVisible dependency property. This field is read-only.
AreWindowsMaximizedProperty | Identifies the AreWindowsMaximized dependency property. This field is read-only.
CanWindowsMaximizeProperty | Identifies the CanWindowsMaximize dependency property. This field is read-only.
CanWindowsMinimizeProperty | Identifies the CanWindowsMinimize dependency property. This field is read-only.
IsAutoCascadeEnabledProperty | Identifies the IsAutoCascadeEnabled dependency property. This field is read-only.
IsExternalMaximizedUIRequiredProperty | Identifies the IsExternalMaximizedUIRequired dependency property. This field is read-only.
IsScrollingEnabledProperty | Identifies the IsScrollingEnabled dependency property. This field is read-only.
Top
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.AreMaximizedWindowFramesVisibleProperty Field

StandardMdiHostAreMaximizedWindowFramesVisibleProperty Field

Identifies the AreMaximizedWindowFramesVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreMaximizedWindowFramesVisibleProperty
Public Shared ReadOnly AreMaximizedWindowFramesVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreMaximizedWindowFramesVisible dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.AreWindowsMaximizedProperty Field

StandardMdiHostAreWindowsMaximizedProperty Field

Identifies the AreWindowsMaximized dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreWindowsMaximizedProperty
Public Shared ReadOnly AreWindowsMaximizedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreWindowsMaximized dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.CanWindowsMaximizeProperty Field

StandardMdiHostCanWindowsMaximizeProperty Field

Identifies the CanWindowsMaximize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanWindowsMaximizeProperty
Public Shared ReadOnly CanWindowsMaximizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanWindowsMaximize dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.CanWindowsMinimizeProperty Field

StandardMdiHostCanWindowsMinimizeProperty Field

Identifies the CanWindowsMinimize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanWindowsMinimizeProperty
Public Shared ReadOnly CanWindowsMinimizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanWindowsMinimize dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.IsAutoCascadeEnabledProperty Field

StandardMdiHostIsAutoCascadeEnabledProperty Field

Identifies the IsAutoCascadeEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoCascadeEnabledProperty
Public Shared ReadOnly IsAutoCascadeEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoCascadeEnabled dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.IsExternalMaximizedUIRequiredProperty Field

StandardMdiHostIsExternalMaximizedUIRequiredProperty Field

Identifies the IsExternalMaximizedUIRequired dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsExternalMaximizedUIRequiredProperty
Public Shared ReadOnly IsExternalMaximizedUIRequiredProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsExternalMaximizedUIRequired dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardMdiHost.IsScrollingEnabledProperty Field

StandardMdiHostIsScrollingEnabledProperty Field

Identifies the IsScrollingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsScrollingEnabledProperty
Public Shared ReadOnly IsScrollingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsScrollingEnabled dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher Class

Implements a SwitcherBase that is similar to the switcher found in Visual Studio.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesSwitcherBase
ActiproSoftware.Windows.Controls.DockingStandardSwitcher

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StandardSwitcher : SwitcherBase
Public Class StandardSwitcher
    Inherits SwitcherBase

The StandardSwitcher type exposes the following members.

Constructors
 | Name | Description
Public method | StandardSwitcher | Initializes an instance of the StandardSwitcher class.
Top
Properties
 | Name | Description
Public property | AreDocumentsVisible | Gets or sets a value indicating whether the documents are visible in the switcher.
Public property | AreToolWindowsVisible | Gets or sets a value indicating whether the tool windows are visible in the switcher.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active. (Inherited from SwitcherBase.)
Public property | Documents | Gets the collection of open documents in the MDI area. (Inherited from SwitcherBase.)
Public property | DropShadowZOffset | Gets or sets the z-offset of the drop shadow.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | FooterTemplate | Gets or sets the DataTemplate to use for the footer area of the switcher, whose content is the SelectedWindow.
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HeaderTemplate | Gets or sets the DataTemplate to use for the header area of the switcher, whose content is the SelectedWindow.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOpen | Gets whether the switcher is currently open and active. (Inherited from SwitcherBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style to use for rendering items.
Public property | ItemTemplate | Gets or sets the DataTemplate to use for rendering items.
Public property | MaxDocumentColumnCount | Gets or sets the maximum number of document columns to display.
Public property | MaxRowCount | Gets or sets the maximum number of item rows that can be displayed.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ScrollButtonStyle | Gets or sets the Style to use for a scroll button.
Public property | ScrollDownButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll down button content.
Public property | ScrollUpButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll up button content.
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected. (Inherited from SwitcherBase.)
Public property | SelectNextDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextDocument method by default. (Inherited from SwitcherBase.)
Public property | SelectNextToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextToolWindow method by default. (Inherited from SwitcherBase.)
Public property | SelectPreviousDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousDocument method by default. (Inherited from SwitcherBase.)
Public property | SelectPreviousToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousToolWindow method by default. (Inherited from SwitcherBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area. (Inherited from SwitcherBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the switcher. (Inherited from SwitcherBase.)
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher. (Inherited from SwitcherBase.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher. (Inherited from SwitcherBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClosed | Invoked when the switcher is closed. (Overrides SwitcherBaseOnClosed.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides SwitcherBaseOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Occurs when a key is released. (Inherited from SwitcherBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from SwitcherBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened. (Overrides SwitcherBaseOnOpened.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides SwitcherBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SelectNextDocument | Selects the next document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousDocument | Selects the previous document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher. (Inherited from SwitcherBase.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
AreDocumentsVisibleProperty | Identifies the AreDocumentsVisible dependency property. This field is read-only.
AreToolWindowsVisibleProperty | Identifies the AreToolWindowsVisible dependency property. This field is read-only.
DropShadowZOffsetProperty | Identifies the DropShadowZOffset dependency property. This field is read-only.
FooterTemplateProperty | Identifies the FooterTemplate dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemTemplateProperty | Identifies the ItemTemplate dependency property. This field is read-only.
MaxDocumentColumnCountProperty | Identifies the MaxDocumentColumnCount dependency property. This field is read-only.
MaxRowCountProperty | Identifies the MaxRowCount dependency property. This field is read-only.
ScrollButtonStyleProperty | Identifies the ScrollButtonStyle dependency property. This field is read-only.
ScrollDownButtonContentTemplateProperty | Identifies the ScrollDownButtonContentTemplate dependency property. This field is read-only.
ScrollUpButtonContentTemplateProperty | Identifies the ScrollUpButtonContentTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher Constructor

Initializes an instance of the StandardSwitcher class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StandardSwitcher()
Public Sub New
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher Properties

The StandardSwitcher type exposes the following members.

Properties
 | Name | Description
Public property | AreDocumentsVisible | Gets or sets a value indicating whether the documents are visible in the switcher.
Public property | AreToolWindowsVisible | Gets or sets a value indicating whether the tool windows are visible in the switcher.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active. (Inherited from SwitcherBase.)
Public property | Documents | Gets the collection of open documents in the MDI area. (Inherited from SwitcherBase.)
Public property | DropShadowZOffset | Gets or sets the z-offset of the drop shadow.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | FooterTemplate | Gets or sets the DataTemplate to use for the footer area of the switcher, whose content is the SelectedWindow.
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HeaderTemplate | Gets or sets the DataTemplate to use for the header area of the switcher, whose content is the SelectedWindow.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOpen | Gets whether the switcher is currently open and active. (Inherited from SwitcherBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style to use for rendering items.
Public property | ItemTemplate | Gets or sets the DataTemplate to use for rendering items.
Public property | MaxDocumentColumnCount | Gets or sets the maximum number of document columns to display.
Public property | MaxRowCount | Gets or sets the maximum number of item rows that can be displayed.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ScrollButtonStyle | Gets or sets the Style to use for a scroll button.
Public property | ScrollDownButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll down button content.
Public property | ScrollUpButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll up button content.
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected. (Inherited from SwitcherBase.)
Public property | SelectNextDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextDocument method by default. (Inherited from SwitcherBase.)
Public property | SelectNextToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextToolWindow method by default. (Inherited from SwitcherBase.)
Public property | SelectPreviousDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousDocument method by default. (Inherited from SwitcherBase.)
Public property | SelectPreviousToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousToolWindow method by default. (Inherited from SwitcherBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area. (Inherited from SwitcherBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.AreDocumentsVisible Property

StandardSwitcherAreDocumentsVisible Property

Gets or sets a value indicating whether the documents are visible in the switcher.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreDocumentsVisible { get; set; }
Public Property AreDocumentsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the documents are visible in the switcher; otherwise false. The default value is true.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.AreToolWindowsVisible Property

StandardSwitcherAreToolWindowsVisible Property

Gets or sets a value indicating whether the tool windows are visible in the switcher.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreToolWindowsVisible { get; set; }
Public Property AreToolWindowsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tool windows are visible in the switcher; otherwise false. The default value is true.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.DropShadowZOffset Property

StandardSwitcherDropShadowZOffset Property

Gets or sets the z-offset of the drop shadow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DropShadowZOffset { get; set; }
Public Property DropShadowZOffset As Double
    Get
    Set

Property Value

Type: Double
The z-offset of the drop shadow. The default value is 6.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.FooterTemplate Property

StandardSwitcherFooterTemplate Property

Gets or sets the DataTemplate to use for the footer area of the switcher, whose content is the SelectedWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate FooterTemplate { get; set; }
Public Property FooterTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the footer area of the switcher.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.HeaderTemplate Property

StandardSwitcherHeaderTemplate Property

Gets or sets the DataTemplate to use for the header area of the switcher, whose content is the SelectedWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate HeaderTemplate { get; set; }
Public Property HeaderTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the header area of the switcher.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ItemContainerStyle Property

StandardSwitcherItemContainerStyle Property

Gets or sets the Style to use for rendering items.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ItemContainerStyle { get; set; }
Public Property ItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for rendering items.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ItemTemplate Property

StandardSwitcherItemTemplate Property

Gets or sets the DataTemplate to use for rendering items.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ItemTemplate { get; set; }
Public Property ItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for rendering items.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.MaxDocumentColumnCount Property

StandardSwitcherMaxDocumentColumnCount Property

Gets or sets the maximum number of document columns to display.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int MaxDocumentColumnCount { get; set; }
Public Property MaxDocumentColumnCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of document columns to display. The default value is 3.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.MaxRowCount Property

StandardSwitcherMaxRowCount Property

Gets or sets the maximum number of item rows that can be displayed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int MaxRowCount { get; set; }
Public Property MaxRowCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of item rows that can be displayed. The default value is 15.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ScrollButtonStyle Property

StandardSwitcherScrollButtonStyle Property

Gets or sets the Style to use for a scroll button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ScrollButtonStyle { get; set; }
Public Property ScrollButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for a scroll button.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ScrollDownButtonContentTemplate Property

StandardSwitcherScrollDownButtonContentTemplate Property

Gets or sets the DataTemplate to use for the scroll down button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ScrollDownButtonContentTemplate { get; set; }
Public Property ScrollDownButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the scroll down button content.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ScrollUpButtonContentTemplate Property

StandardSwitcherScrollUpButtonContentTemplate Property

Gets or sets the DataTemplate to use for the scroll up button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ScrollUpButtonContentTemplate { get; set; }
Public Property ScrollUpButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the scroll up button content.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher Methods

The StandardSwitcher type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the switcher. (Inherited from SwitcherBase.)
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher. (Inherited from SwitcherBase.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher. (Inherited from SwitcherBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClosed | Invoked when the switcher is closed. (Overrides SwitcherBaseOnClosed.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides SwitcherBaseOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Occurs when a key is released. (Inherited from SwitcherBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from SwitcherBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened. (Overrides SwitcherBaseOnOpened.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides SwitcherBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SelectNextDocument | Selects the next document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousDocument | Selects the previous document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher. (Inherited from SwitcherBase.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.OnApplyTemplate Method

StandardSwitcherOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.OnClosed Method

StandardSwitcherOnClosed Method

Invoked when the switcher is closed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.OnCreateAutomationPeer Method

StandardSwitcherOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.OnKeyDown Method

StandardSwitcherOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.OnOpened Method

StandardSwitcherOnOpened Method

Invoked when the switcher is opened.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnOpened()
Protected Overrides Sub OnOpened
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.OnSelectedWindowChanged Method

StandardSwitcherOnSelectedWindowChanged Method

Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnSelectedWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overrides Sub OnSelectedWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The new value.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher Events

The StandardSwitcher type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher Fields

The StandardSwitcher type exposes the following members.

Fields
Name | Description
AreDocumentsVisibleProperty | Identifies the AreDocumentsVisible dependency property. This field is read-only.
AreToolWindowsVisibleProperty | Identifies the AreToolWindowsVisible dependency property. This field is read-only.
DropShadowZOffsetProperty | Identifies the DropShadowZOffset dependency property. This field is read-only.
FooterTemplateProperty | Identifies the FooterTemplate dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemTemplateProperty | Identifies the ItemTemplate dependency property. This field is read-only.
MaxDocumentColumnCountProperty | Identifies the MaxDocumentColumnCount dependency property. This field is read-only.
MaxRowCountProperty | Identifies the MaxRowCount dependency property. This field is read-only.
ScrollButtonStyleProperty | Identifies the ScrollButtonStyle dependency property. This field is read-only.
ScrollDownButtonContentTemplateProperty | Identifies the ScrollDownButtonContentTemplate dependency property. This field is read-only.
ScrollUpButtonContentTemplateProperty | Identifies the ScrollUpButtonContentTemplate dependency property. This field is read-only.
Top
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.AreDocumentsVisibleProperty Field

StandardSwitcherAreDocumentsVisibleProperty Field

Identifies the AreDocumentsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreDocumentsVisibleProperty
Public Shared ReadOnly AreDocumentsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreDocumentsVisible dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.AreToolWindowsVisibleProperty Field

StandardSwitcherAreToolWindowsVisibleProperty Field

Identifies the AreToolWindowsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreToolWindowsVisibleProperty
Public Shared ReadOnly AreToolWindowsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreToolWindowsVisible dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.DropShadowZOffsetProperty Field

StandardSwitcherDropShadowZOffsetProperty Field

Identifies the DropShadowZOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DropShadowZOffsetProperty
Public Shared ReadOnly DropShadowZOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DropShadowZOffset dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.FooterTemplateProperty Field

StandardSwitcherFooterTemplateProperty Field

Identifies the FooterTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FooterTemplateProperty
Public Shared ReadOnly FooterTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FooterTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.HeaderTemplateProperty Field

StandardSwitcherHeaderTemplateProperty Field

Identifies the HeaderTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderTemplateProperty
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ItemContainerStyleProperty Field

StandardSwitcherItemContainerStyleProperty Field

Identifies the ItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemContainerStyleProperty
Public Shared ReadOnly ItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemContainerStyle dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ItemTemplateProperty Field

StandardSwitcherItemTemplateProperty Field

Identifies the ItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemTemplateProperty
Public Shared ReadOnly ItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.MaxDocumentColumnCountProperty Field

StandardSwitcherMaxDocumentColumnCountProperty Field

Identifies the MaxDocumentColumnCount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxDocumentColumnCountProperty
Public Shared ReadOnly MaxDocumentColumnCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxDocumentColumnCount dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.MaxRowCountProperty Field

StandardSwitcherMaxRowCountProperty Field

Identifies the MaxRowCount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxRowCountProperty
Public Shared ReadOnly MaxRowCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxRowCount dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ScrollButtonStyleProperty Field

StandardSwitcherScrollButtonStyleProperty Field

Identifies the ScrollButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollButtonStyleProperty
Public Shared ReadOnly ScrollButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollButtonStyle dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ScrollDownButtonContentTemplateProperty Field

StandardSwitcherScrollDownButtonContentTemplateProperty Field

Identifies the ScrollDownButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollDownButtonContentTemplateProperty
Public Shared ReadOnly ScrollDownButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollDownButtonContentTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


StandardSwitcher.ScrollUpButtonContentTemplateProperty Field

StandardSwitcherScrollUpButtonContentTemplateProperty Field

Identifies the ScrollUpButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollUpButtonContentTemplateProperty
Public Shared ReadOnly ScrollUpButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollUpButtonContentTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer Class

Represents a container of one or more documents in tabbed MDI.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockingWindowContainerBase
ActiproSoftware.Windows.Controls.DockingTabbedMdiContainer

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TabbedMdiContainer : DockingWindowContainerBase,
    IOrientedElement, IDockTarget
Public Class TabbedMdiContainer
    Inherits DockingWindowContainerBase
    Implements IOrientedElement, IDockTarget

The TabbedMdiContainer type exposes the following members.

Constructors
 | Name | Description
Public method | TabbedMdiContainer | Initializes an instance of the TabbedMdiContainer class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from DockingWindowContainerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from DockingWindowContainerBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from DockingWindowContainerBase.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available.
Public property | HasTabCloseButtons | Gets or sets whether close buttons should appear on document tabs.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from DockingWindowContainerBase.)
Public property | HasTabPinButtons | Gets or sets whether pin buttons should appear on document tabs (normal layout kind).
Public property | HasTabPromoteButtons | Gets or sets whether promote buttons should appear on document tabs (preview layout kind).
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible. (Inherited from DockingWindowContainerBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from DockingWindowContainerBase.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container. (Inherited from DockingWindowContainerBase.)
Public property | State | Gets the DockingWindowState that specifies the current state of the container. (Inherited from DockingWindowContainerBase.)
Protected property | TabControl | Gets the tab control in the container's user interface. (Inherited from DockingWindowContainerBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl. (Inherited from DockingWindowContainerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers. (Inherited from DockingWindowContainerBase.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from DockingWindowContainerBase.)
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located. (Inherited from DockingWindowContainerBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Protected property | WindowsCore | Gets the collection of child DockingWindow objects. (Inherited from DockingWindowContainerBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from DockingWindowContainerBase.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed. (Overrides DockingWindowContainerBaseOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from DockingWindowContainerBase.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides DockingWindowContainerBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening. (Overrides DockingWindowContainerBaseOnTabControlMenuOpening(AdvancedTabControlMenuEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnWindowsChanged | Occurs when the Windows collection is changed. (Overrides DockingWindowContainerBaseOnWindowsChanged(NotifyCollectionChangedEventArgs).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindowContainerBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows. (Overrides DockingWindowContainerBaseUpdateDockingWindowStates.)
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateVisualState | Updates the visual state. (Inherited from DockingWindowContainerBase.)
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container. (Inherited from DockingWindowContainerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
HasNewTabButtonProperty | Identifies the HasNewTabButton dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabPinButtonsProperty | Identifies the HasTabPinButtons dependency property. This field is read-only.
HasTabPromoteButtonsProperty | Identifies the HasTabPromoteButtons dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer Constructor

Initializes an instance of the TabbedMdiContainer class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabbedMdiContainer()
Public Sub New
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer Properties

The TabbedMdiContainer type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from DockingWindowContainerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from DockingWindowContainerBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from DockingWindowContainerBase.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available.
Public property | HasTabCloseButtons | Gets or sets whether close buttons should appear on document tabs.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from DockingWindowContainerBase.)
Public property | HasTabPinButtons | Gets or sets whether pin buttons should appear on document tabs (normal layout kind).
Public property | HasTabPromoteButtons | Gets or sets whether promote buttons should appear on document tabs (preview layout kind).
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible. (Inherited from DockingWindowContainerBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from DockingWindowContainerBase.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container. (Inherited from DockingWindowContainerBase.)
Public property | State | Gets the DockingWindowState that specifies the current state of the container. (Inherited from DockingWindowContainerBase.)
Protected property | TabControl | Gets the tab control in the container's user interface. (Inherited from DockingWindowContainerBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl. (Inherited from DockingWindowContainerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers. (Inherited from DockingWindowContainerBase.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from DockingWindowContainerBase.)
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located. (Inherited from DockingWindowContainerBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Protected property | WindowsCore | Gets the collection of child DockingWindow objects. (Inherited from DockingWindowContainerBase.)
Top
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.HasNewTabButton Property

TabbedMdiContainerHasNewTabButton Property

Gets or sets whether a new tab button is available.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasNewTabButton { get; set; }
Public Property HasNewTabButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a new tab button is visible; otherwise, false. The default value is false.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.HasTabCloseButtons Property

TabbedMdiContainerHasTabCloseButtons Property

Gets or sets whether close buttons should appear on document tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabCloseButtons { get; set; }
Public Property HasTabCloseButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if close buttons should appear on document tabs; otherwise, false. The default value is true.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.HasTabPinButtons Property

TabbedMdiContainerHasTabPinButtons Property

Gets or sets whether pin buttons should appear on document tabs (normal layout kind).

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabPinButtons { get; set; }
Public Property HasTabPinButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if pin buttons should appear on document tabs (normal layout kind); otherwise, false. The default value is false.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.HasTabPromoteButtons Property

TabbedMdiContainerHasTabPromoteButtons Property

Gets or sets whether promote buttons should appear on document tabs (preview layout kind).

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabPromoteButtons { get; set; }
Public Property HasTabPromoteButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if promote buttons should appear on document tabs (preview layout kind); otherwise, false. The default value is true.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.Windows Property

TabbedMdiContainerWindows Property

Gets the collection of child DockingWindow objects.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<DockingWindow> Windows { get; }
Public ReadOnly Property Windows As ObservableCollection(Of DockingWindow)
    Get

Property Value

Type: ObservableCollection DockingWindow
The collection of child DockingWindow objects.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer Methods

The TabbedMdiContainer type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from DockingWindowContainerBase.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed. (Overrides DockingWindowContainerBaseOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from DockingWindowContainerBase.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides DockingWindowContainerBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening. (Overrides DockingWindowContainerBaseOnTabControlMenuOpening(AdvancedTabControlMenuEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnWindowsChanged | Occurs when the Windows collection is changed. (Overrides DockingWindowContainerBaseOnWindowsChanged(NotifyCollectionChangedEventArgs).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindowContainerBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows. (Overrides DockingWindowContainerBaseUpdateDockingWindowStates.)
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateVisualState | Updates the visual state. (Inherited from DockingWindowContainerBase.)
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container. (Inherited from DockingWindowContainerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.OnCreateAutomationPeer Method

TabbedMdiContainerOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.OnDockSiteChanged Method

TabbedMdiContainerOnDockSiteChanged Method

Occurs when the DockSite property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDockSiteChanged(
    DockSite oldDockSite,
    DockSite newDockSite
)
Protected Overrides Sub OnDockSiteChanged (
    oldDockSite As DockSite,
    newDockSite As DockSite
)

Parameters

oldDockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The old value.
newDockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The new value.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.OnKeyDown Method

TabbedMdiContainerOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.OnSelectedWindowChanged Method

TabbedMdiContainerOnSelectedWindowChanged Method

Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnSelectedWindowChanged(
    DockingWindow oldSelectedWindow,
    DockingWindow newSelectedWindow
)
Protected Overrides Sub OnSelectedWindowChanged (
    oldSelectedWindow As DockingWindow,
    newSelectedWindow As DockingWindow
)

Parameters

oldSelectedWindow
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The old selected window.
newSelectedWindow
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The new selected window.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.OnTabControlMenuOpening Method

TabbedMdiContainerOnTabControlMenuOpening Method

Occurs when a menu on the tab control is opening.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnTabControlMenuOpening(
    AdvancedTabControlMenuEventArgs e
)
Protected Overrides Sub OnTabControlMenuOpening (
    e As AdvancedTabControlMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingAdvancedTabControlMenuEventArgs
The AdvancedTabControlMenuEventArgs that contains the event data.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.OnWindowsChanged Method

TabbedMdiContainerOnWindowsChanged Method

Occurs when the Windows collection is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnWindowsChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overrides Sub OnWindowsChanged (
    e As NotifyCollectionChangedEventArgs
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
A NotifyCollectionChangedEventArgs that contains the event data.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.UpdateDockingWindowStates Method

TabbedMdiContainerUpdateDockingWindowStates Method

Updates the DockingWindowState associated with all child docking windows.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateDockingWindowStates()
Protected Overrides Sub UpdateDockingWindowStates
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer Events

The TabbedMdiContainer type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer Fields

The TabbedMdiContainer type exposes the following members.

Fields
Name | Description
HasNewTabButtonProperty | Identifies the HasNewTabButton dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabPinButtonsProperty | Identifies the HasTabPinButtons dependency property. This field is read-only.
HasTabPromoteButtonsProperty | Identifies the HasTabPromoteButtons dependency property. This field is read-only.
Top
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.HasNewTabButtonProperty Field

TabbedMdiContainerHasNewTabButtonProperty Field

Identifies the HasNewTabButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasNewTabButtonProperty
Public Shared ReadOnly HasNewTabButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasNewTabButton dependency property.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.HasTabCloseButtonsProperty Field

TabbedMdiContainerHasTabCloseButtonsProperty Field

Identifies the HasTabCloseButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabCloseButtonsProperty
Public Shared ReadOnly HasTabCloseButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabCloseButtons dependency property.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.HasTabPinButtonsProperty Field

TabbedMdiContainerHasTabPinButtonsProperty Field

Identifies the HasTabPinButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabPinButtonsProperty
Public Shared ReadOnly HasTabPinButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabPinButtons dependency property.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiContainer.HasTabPromoteButtonsProperty Field

TabbedMdiContainerHasTabPromoteButtonsProperty Field

Identifies the HasTabPromoteButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabPromoteButtonsProperty
Public Shared ReadOnly HasTabPromoteButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabPromoteButtons dependency property.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost Class

Represents a container that hosts docking windows in a tabbed MDI (multiple-document interface) mode.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesMdiHostBase
ActiproSoftware.Windows.Controls.DockingTabbedMdiHost

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TabbedMdiHost : MdiHostBase,
    IDockTarget
Public Class TabbedMdiHost
    Inherits MdiHostBase
    Implements IDockTarget

The TabbedMdiHost type exposes the following members.

Constructors
 | Name | Description
Public method | TabbedMdiHost | Initializes an instance of the TabbedMdiHost class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanDocumentsAttach | Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping.
Public property | CanDocumentsCloseOnMiddleClick | Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button.
Public property | CanDocumentsDock | Gets or sets the global setting for whether documents can be docked to a new container.
Public property | CanDocumentTabsDrag | Gets or sets the global setting for whether document tabs may be dragged to another location.
Public property | Child | Gets the FrameworkElement child of the host, which can be a SplitContainer or TabbedMdiContainer.
Public property | ContainersHaveNewTabButtons | Gets or sets whether containers have new tab buttons.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from MdiHostBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from MdiHostBase.)
Public property | EmptyContent | Gets or sets the content to display when there are no documents visible in the host.
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no documents visible in the host.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasTabCloseButtons | Gets or sets whether close buttons should appear on document tabs.
Public property | HasTabImages | Gets or sets whether document tabs display an embedded image when one is available.
Public property | HasTabPinButtons | Gets or sets whether pin buttons should appear on document tabs (normal layout kind).
Public property | HasTabPromoteButtons | Gets or sets whether promote buttons should appear on document tabs (preview layout kind).
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents). (Inherited from MdiHostBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host. (Inherited from MdiHostBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained tab controls in a TabbedMdiContainer.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers in a TabbedMdiContainer.
Public property | TabOverflowBehavior | Gets or sets the overflow behavior of the document tabs.
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | Cascade | Cascades the open documents.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetDocuments | Returns the list of docking windows within the MDI. (Overrides MdiHostBaseGetDocuments.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from MdiHostBase.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed. (Overrides MdiHostBaseOnDockHostChanged(DockHost, DockHost).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed. (Inherited from MdiHostBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileHorizontally(Int32) | Tiles the open documents horizontally.
Public method | TileVertically | Tiles the open documents vertically.
Public method | TileVertically(Int32) | Tiles the open documents horizontally.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed. (Inherited from MdiHostBase.)
Top
Fields
Name | Description
CanDocumentsAttachProperty | Identifies the CanDocumentsAttach dependency property. This field is read-only.
CanDocumentsCloseOnMiddleClickProperty | Identifies the CanDocumentsCloseOnMiddleClick dependency property. This field is read-only.
CanDocumentsDockProperty | Identifies the CanDocumentsDock dependency property. This field is read-only.
CanDocumentTabsDragProperty | Identifies the CanDocumentTabsDrag dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
ContainersHaveNewTabButtonsProperty | Identifies the ContainersHaveNewTabButtons dependency property. This field is read-only.
EmptyContentProperty | Identifies the EmptyContent dependency property. This field is read-only.
EmptyContentTemplateProperty | Identifies the EmptyContentTemplate dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
HasTabPinButtonsProperty | Identifies the HasTabPinButtons dependency property. This field is read-only.
HasTabPromoteButtonsProperty | Identifies the HasTabPromoteButtons dependency property. This field is read-only.
TabControlStyleProperty | Identifies the TabControlStyle dependency property. This field is read-only.
TabItemContainerStyleProperty | Identifies the TabItemContainerStyle dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost Constructor

Initializes an instance of the TabbedMdiHost class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabbedMdiHost()
Public Sub New
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost Properties

The TabbedMdiHost type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanDocumentsAttach | Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping.
Public property | CanDocumentsCloseOnMiddleClick | Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button.
Public property | CanDocumentsDock | Gets or sets the global setting for whether documents can be docked to a new container.
Public property | CanDocumentTabsDrag | Gets or sets the global setting for whether document tabs may be dragged to another location.
Public property | Child | Gets the FrameworkElement child of the host, which can be a SplitContainer or TabbedMdiContainer.
Public property | ContainersHaveNewTabButtons | Gets or sets whether containers have new tab buttons.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from MdiHostBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from MdiHostBase.)
Public property | EmptyContent | Gets or sets the content to display when there are no documents visible in the host.
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no documents visible in the host.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasTabCloseButtons | Gets or sets whether close buttons should appear on document tabs.
Public property | HasTabImages | Gets or sets whether document tabs display an embedded image when one is available.
Public property | HasTabPinButtons | Gets or sets whether pin buttons should appear on document tabs (normal layout kind).
Public property | HasTabPromoteButtons | Gets or sets whether promote buttons should appear on document tabs (preview layout kind).
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents). (Inherited from MdiHostBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host. (Inherited from MdiHostBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained tab controls in a TabbedMdiContainer.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers in a TabbedMdiContainer.
Public property | TabOverflowBehavior | Gets or sets the overflow behavior of the document tabs.
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsAttach Property

TabbedMdiHostCanDocumentsAttach Property

Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDocumentsAttach { get; set; }
Public Property CanDocumentsAttach As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documents may be attached to another document; otherwise, false. The default value is true.
Remarks
This setting only affects documents whose CanAttach property is set to . Any other setting on the document instance overrides this global setting.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsCloseOnMiddleClick Property

TabbedMdiHostCanDocumentsCloseOnMiddleClick Property

Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDocumentsCloseOnMiddleClick { get; set; }
Public Property CanDocumentsCloseOnMiddleClick As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documents can be closed by clicking the tab with the middle mouse button; otherwise, false. The default value is true.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsDock Property

TabbedMdiHostCanDocumentsDock Property

Gets or sets the global setting for whether documents can be docked to a new container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDocumentsDock { get; set; }
Public Property CanDocumentsDock As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documents can be docked to a new container; otherwise, false. The default value is true.
Remarks
This setting only affects documents whose CanDock property is set to . Any other setting on the document instance overrides this global setting.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.CanDocumentTabsDrag Property

TabbedMdiHostCanDocumentTabsDrag Property

Gets or sets the global setting for whether document tabs may be dragged to another location.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDocumentTabsDrag { get; set; }
Public Property CanDocumentTabsDrag As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document tabs may be dragged to another location; otherwise, false. The default value is true.
Remarks
This setting only affects documents whose CanDragTab property is set to . Any other setting on the document instance overrides this global setting.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.Child Property

TabbedMdiHostChild Property

Gets the FrameworkElement child of the host, which can be a SplitContainer or TabbedMdiContainer.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FrameworkElement Child { get; set; }
Public Property Child As FrameworkElement
    Get
    Set

Property Value

Type: FrameworkElement
The FrameworkElement child of the host. The default value is .
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.ContainersHaveNewTabButtons Property

TabbedMdiHostContainersHaveNewTabButtons Property

Gets or sets whether containers have new tab buttons.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ContainersHaveNewTabButtons { get; set; }
Public Property ContainersHaveNewTabButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if containers have new tab buttons; otherwise, false. The default value is false.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.EmptyContent Property

TabbedMdiHostEmptyContent Property

Gets or sets the content to display when there are no documents visible in the host.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object EmptyContent { get; set; }
Public Property EmptyContent As Object
    Get
    Set

Property Value

Type: Object
The content to display when there are no documents visible in the host.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.EmptyContentTemplate Property

TabbedMdiHostEmptyContentTemplate Property

Gets or sets the DataTemplate to display when there are no documents visible in the host.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate EmptyContentTemplate { get; set; }
Public Property EmptyContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to display when there are no documents visible in the host.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.HasTabCloseButtons Property

TabbedMdiHostHasTabCloseButtons Property

Gets or sets whether close buttons should appear on document tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabCloseButtons { get; set; }
Public Property HasTabCloseButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if close buttons should appear on document tabs; otherwise, false. The default value is true.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.HasTabImages Property

TabbedMdiHostHasTabImages Property

Gets or sets whether document tabs display an embedded image when one is available.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabImages { get; set; }
Public Property HasTabImages As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document tabs display an embedded image when one is available; otherwise, false. The default value is false.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.HasTabPinButtons Property

TabbedMdiHostHasTabPinButtons Property

Gets or sets whether pin buttons should appear on document tabs (normal layout kind).

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabPinButtons { get; set; }
Public Property HasTabPinButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if pin buttons should appear on document tabs (normal layout kind); otherwise, false. The default value is false.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.HasTabPromoteButtons Property

TabbedMdiHostHasTabPromoteButtons Property

Gets or sets whether promote buttons should appear on document tabs (preview layout kind).

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabPromoteButtons { get; set; }
Public Property HasTabPromoteButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if promote buttons should appear on document tabs (preview layout kind); otherwise, false. The default value is true.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TabControlStyle Property

TabbedMdiHostTabControlStyle Property

Gets or sets the Style to use for the contained tab controls in a TabbedMdiContainer.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TabControlStyle { get; set; }
Public Property TabControlStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the contained tab controls in a TabbedMdiContainer.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TabItemContainerStyle Property

TabbedMdiHostTabItemContainerStyle Property

Gets or sets the Style to use for rendering the tab item containers in a TabbedMdiContainer.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TabItemContainerStyle { get; set; }
Public Property TabItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for rendering the tab item containers in a TabbedMdiContainer.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TabOverflowBehavior Property

TabbedMdiHostTabOverflowBehavior Property

Gets or sets the overflow behavior of the document tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabOverflowBehavior TabOverflowBehavior { get; set; }
Public Property TabOverflowBehavior As TabOverflowBehavior
    Get
    Set

Property Value

Type: TabOverflowBehavior
The overflow behavior of the document tabs. The default value is Menu.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TabStripPlacement Property

TabbedMdiHostTabStripPlacement Property

Gets or sets a Side indicating the side upon which the tabs are located.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Side TabStripPlacement { get; set; }
Public Property TabStripPlacement As Side
    Get
    Set

Property Value

Type: Side
A Side indicating the side upon which the tabs are located. The default value is Top.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost Methods

The TabbedMdiHost type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | Cascade | Cascades the open documents.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetDocuments | Returns the list of docking windows within the MDI. (Overrides MdiHostBaseGetDocuments.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from MdiHostBase.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed. (Overrides MdiHostBaseOnDockHostChanged(DockHost, DockHost).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed. (Inherited from MdiHostBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileHorizontally(Int32) | Tiles the open documents horizontally.
Public method | TileVertically | Tiles the open documents vertically.
Public method | TileVertically(Int32) | Tiles the open documents horizontally.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.Cascade Method

TabbedMdiHostCascade Method

Cascades the open documents.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Cascade()
Public Sub Cascade
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.GetDocuments Method

TabbedMdiHostGetDocuments Method

Returns the list of docking windows within the MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override sealed IList<DockingWindow> GetDocuments()
Public Overrides NotOverridable Function GetDocuments As IList(Of DockingWindow)

Return Value

Type: IList DockingWindow
The list of docking windows within the MDI.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.OnDockHostChanged Method

TabbedMdiHostOnDockHostChanged Method

Occurs when the value of the DockHost property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDockHostChanged(
    DockHost oldValue,
    DockHost newValue
)
Protected Overrides Sub OnDockHostChanged (
    oldValue As DockHost,
    newValue As DockHost
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The new value.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TileHorizontally Method

TabbedMdiHostTileHorizontally Method

Overload List
 | Name | Description
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileHorizontally(Int32) | Tiles the open documents horizontally.
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TileHorizontally Method

TabbedMdiHostTileHorizontally Method

Tiles the open documents horizontally.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void TileHorizontally()
Public Sub TileHorizontally
See Also

Reference

TabbedMdiHost Class
TileHorizontally Overload
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TileHorizontally Method (Int32)

TabbedMdiHostTileHorizontally Method (Int32)

Tiles the open documents horizontally.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void TileHorizontally(
    int maxColumnCount
)
Public Sub TileHorizontally (
    maxColumnCount As Integer
)

Parameters

maxColumnCount
Type: SystemInt32
The maximum column count
See Also

Reference

TabbedMdiHost Class
TileHorizontally Overload
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TileVertically Method

TabbedMdiHostTileVertically Method

Overload List
 | Name | Description
Public method | TileVertically | Tiles the open documents vertically.
Public method | TileVertically(Int32) | Tiles the open documents horizontally.
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TileVertically Method

TabbedMdiHostTileVertically Method

Tiles the open documents vertically.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void TileVertically()
Public Sub TileVertically
See Also

Reference

TabbedMdiHost Class
TileVertically Overload
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TileVertically Method (Int32)

TabbedMdiHostTileVertically Method (Int32)

Tiles the open documents horizontally.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void TileVertically(
    int maxRowCount
)
Public Sub TileVertically (
    maxRowCount As Integer
)

Parameters

maxRowCount
Type: SystemInt32
The maximum row count
See Also

Reference

TabbedMdiHost Class
TileVertically Overload
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost Events

The TabbedMdiHost type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed. (Inherited from MdiHostBase.)
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost Fields

The TabbedMdiHost type exposes the following members.

Fields
Name | Description
CanDocumentsAttachProperty | Identifies the CanDocumentsAttach dependency property. This field is read-only.
CanDocumentsCloseOnMiddleClickProperty | Identifies the CanDocumentsCloseOnMiddleClick dependency property. This field is read-only.
CanDocumentsDockProperty | Identifies the CanDocumentsDock dependency property. This field is read-only.
CanDocumentTabsDragProperty | Identifies the CanDocumentTabsDrag dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
ContainersHaveNewTabButtonsProperty | Identifies the ContainersHaveNewTabButtons dependency property. This field is read-only.
EmptyContentProperty | Identifies the EmptyContent dependency property. This field is read-only.
EmptyContentTemplateProperty | Identifies the EmptyContentTemplate dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
HasTabPinButtonsProperty | Identifies the HasTabPinButtons dependency property. This field is read-only.
HasTabPromoteButtonsProperty | Identifies the HasTabPromoteButtons dependency property. This field is read-only.
TabControlStyleProperty | Identifies the TabControlStyle dependency property. This field is read-only.
TabItemContainerStyleProperty | Identifies the TabItemContainerStyle dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsAttachProperty Field

TabbedMdiHostCanDocumentsAttachProperty Field

Identifies the CanDocumentsAttach dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentsAttachProperty
Public Shared ReadOnly CanDocumentsAttachProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentsAttach dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsCloseOnMiddleClickProperty Field

TabbedMdiHostCanDocumentsCloseOnMiddleClickProperty Field

Identifies the CanDocumentsCloseOnMiddleClick dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentsCloseOnMiddleClickProperty
Public Shared ReadOnly CanDocumentsCloseOnMiddleClickProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentsCloseOnMiddleClick dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsDockProperty Field

TabbedMdiHostCanDocumentsDockProperty Field

Identifies the CanDocumentsDock dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentsDockProperty
Public Shared ReadOnly CanDocumentsDockProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentsDock dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.CanDocumentTabsDragProperty Field

TabbedMdiHostCanDocumentTabsDragProperty Field

Identifies the CanDocumentTabsDrag dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentTabsDragProperty
Public Shared ReadOnly CanDocumentTabsDragProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentTabsDrag dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.ChildProperty Field

TabbedMdiHostChildProperty Field

Identifies the Child dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildProperty
Public Shared ReadOnly ChildProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Child dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.ContainersHaveNewTabButtonsProperty Field

TabbedMdiHostContainersHaveNewTabButtonsProperty Field

Identifies the ContainersHaveNewTabButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainersHaveNewTabButtonsProperty
Public Shared ReadOnly ContainersHaveNewTabButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainersHaveNewTabButtons dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.EmptyContentProperty Field

TabbedMdiHostEmptyContentProperty Field

Identifies the EmptyContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmptyContentProperty
Public Shared ReadOnly EmptyContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmptyContent dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.EmptyContentTemplateProperty Field

TabbedMdiHostEmptyContentTemplateProperty Field

Identifies the EmptyContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmptyContentTemplateProperty
Public Shared ReadOnly EmptyContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmptyContentTemplate dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.HasTabCloseButtonsProperty Field

TabbedMdiHostHasTabCloseButtonsProperty Field

Identifies the HasTabCloseButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabCloseButtonsProperty
Public Shared ReadOnly HasTabCloseButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabCloseButtons dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.HasTabImagesProperty Field

TabbedMdiHostHasTabImagesProperty Field

Identifies the HasTabImages dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabImagesProperty
Public Shared ReadOnly HasTabImagesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabImages dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.HasTabPinButtonsProperty Field

TabbedMdiHostHasTabPinButtonsProperty Field

Identifies the HasTabPinButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabPinButtonsProperty
Public Shared ReadOnly HasTabPinButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabPinButtons dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.HasTabPromoteButtonsProperty Field

TabbedMdiHostHasTabPromoteButtonsProperty Field

Identifies the HasTabPromoteButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabPromoteButtonsProperty
Public Shared ReadOnly HasTabPromoteButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabPromoteButtons dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TabControlStyleProperty Field

TabbedMdiHostTabControlStyleProperty Field

Identifies the TabControlStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabControlStyleProperty
Public Shared ReadOnly TabControlStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabControlStyle dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TabItemContainerStyleProperty Field

TabbedMdiHostTabItemContainerStyleProperty Field

Identifies the TabItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabItemContainerStyleProperty
Public Shared ReadOnly TabItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabItemContainerStyle dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TabOverflowBehaviorProperty Field

TabbedMdiHostTabOverflowBehaviorProperty Field

Identifies the TabOverflowBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabOverflowBehaviorProperty
Public Shared ReadOnly TabOverflowBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabOverflowBehavior dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabbedMdiHost.TabStripPlacementProperty Field

TabbedMdiHostTabStripPlacementProperty Field

Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking Namespace


TabFlashMode Enumeration

Specifies the flash mode to apply to a tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TabFlashMode
Public Enumeration TabFlashMode
Members
Member name | Value | Description
None | 0 | No flashing.
Blink | 1 | An all-on or all-off flash mode.
Smooth | 2 | A smooth transition flash mode.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


TabHighlightKind Enumeration

Specifies the kind of highlight to apply to a tab.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TabHighlightKind
Public Enumeration TabHighlightKind
Members
Member name | Value | Description
None | 0 | No highlight, for a normal or pinned tab.
Preview | 1 | No highlight, for a preview tab.
PointerOver | 2 | Pointer over, for a normal or pinned tab.
PreviewPointerOver | 3 | Pointer over, for a preview tab.
ActiveSelected | 4 | Active selected, for a normal or pinned tab.
PreviewActiveSelected | 5 | Active selected, for a preview tab.
InactiveSelected | 6 | Inactive selected.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


TabLayoutKind Enumeration

Specifies the kind of tab, which affects its layout.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TabLayoutKind
Public Enumeration TabLayoutKind
Members
Member name | Value | Description
Normal | 0 | Indicates a normal tab.
Pinned | 1 | Indicates a tab that is pinned to the front of the tab strip.
Preview | 2 | Indicates a tab that is intended to be temporary and appears at the very end of the tab strip.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


TabOverflowBehavior Enumeration

Indicates the overflow behavior of tabs.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TabOverflowBehavior
Public Enumeration TabOverflowBehavior
Members
Member name | Value | Description
None | 0 | Indicates no overflow behavior will be used.
Menu | 1 | Indicates an overflow menu will be displayed.
Shrink | 2 | Indicates the tabs will be stretched down to fit in the available space.
ShrinkWithMenu | 3 | Indicates the tabs will be stretched down to fit in the available space and an overflow menu will be displayed.
Scroll | 4 | Indicates the tabs will support scrolling.
ScrollWithMenu | 5 | Indicates the tabs will support scrolling and an overflow menu will be displayed.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Class

Represents a tool window.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.DockingDockingWindow
ActiproSoftware.Windows.Controls.DockingToolWindow

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ToolWindow : DockingWindow
Public Class ToolWindow
    Inherits DockingWindow

The ToolWindow type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindow | Initializes a new instance of the ToolWindow class. When creating instances of ToolWindow programmatically, use a constructor that accepts a DockSite instead.
Public method | ToolWindow(Boolean) | Initializes a new instance of the ToolWindow class.
Public method | ToolWindow(DockSite) | Initializes a new instance of the ToolWindow class.
Public method | ToolWindow(DockSite, String, String, ImageSource, Object) | Initializes a new instance of the ToolWindow class.
Top
Properties
 | Name | Description
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window. (Inherited from DockingWindow.)
Public property | AutoHideCommand | Gets the ICommand that can move the window into an auto-hide state.
Public property | AutoHideTabContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAutoHide | Gets or sets whether the tool window may be placed in auto-hide mode.
Public property | CanAutoHideResolved | Gets a resolved value indicating whether the tool window may be placed in auto-hide mode.
Public property | CanBecomeDocument | Gets or sets whether the tool window may be placed in a document state.
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state. (Inherited from DockingWindow.)
Public property | CanClose | Gets or sets whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanDock | Gets or sets whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost. (Inherited from DockingWindow.)
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CloseAllInContainerCommand | Gets or sets the ICommand that can close all windows in the current container. (Inherited from DockingWindow.)
Public property | CloseCommand | Gets the ICommand that can Close the window. (Inherited from DockingWindow.)
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container. (Inherited from DockingWindow.)
Public property | ContainerAutoHideSize | Gets or sets the Size of the tool window's container when it is in an auto-hide state.
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state. (Inherited from DockingWindow.)
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | DefaultDockSide | Gets or sets the default Side that the tool window will dock towards when no prior location is known.
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI. (Inherited from DockingWindow.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window. (Inherited from DockingWindow.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockCommand | Gets the ICommand that can move the window into a docked state.
Public property | DockHost | Gets the DockHost in which the window is currently located. (Inherited from DockingWindow.)
Public property | DockSite | Gets the DockSite that is managing this docking window. (Inherited from DockingWindow.)
Public property | FloatCommand | Gets the ICommand that can Float the window. (Inherited from DockingWindow.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasOptionsButton | Gets or sets whether the tool window displays an options button in its ToolWindowContainer title bar.
Public property | HasOptionsButtonResolved | Gets a resolved value indicating whether the tool window displays an options button in its ToolWindowContainer title bar.
Public property | HasTitleBar | Gets or sets whether the tool window displays a title bar in its parent ToolWindowContainer.
Public property | HasTitleBarResolved | Gets a resolved value indicating whether the tool window displays a title bar in its parent ToolWindowContainer.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs. (Inherited from DockingWindow.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus. (Inherited from DockingWindow.)
Public property | IsAutoHidePopupOpen | Gets whether the tool window is currently visible within an auto-hide popup.
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties. (Inherited from DockingWindow.)
Public property | IsFloating | Gets or sets whether the docking window is floating, meaning it is currently open in a floating DockHost, or is closed and was last open in a floating DockHost. (Inherited from DockingWindow.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout. (Inherited from DockingWindow.)
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container. (Inherited from DockingWindow.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from DockingWindow.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area. (Inherited from DockingWindow.)
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container. (Inherited from DockingWindow.)
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host. (Inherited from DockingWindow.)
Public property | OpenCommand | Gets the ICommand that can Open the window. (Inherited from DockingWindow.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window. (Inherited from DockingWindow.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data. (Inherited from DockingWindow.)
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter. (Inherited from DockingWindow.)
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content. (Inherited from DockingWindow.)
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state. (Inherited from DockingWindow.)
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window. (Inherited from DockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI. (Inherited from DockingWindow.)
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window. (Inherited from DockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview). (Inherited from DockingWindow.)
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab. (Inherited from DockingWindow.)
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled. (Inherited from DockingWindow.)
Public property | TabFlashMode | Gets or sets the flash mode for the tab. (Inherited from DockingWindow.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes. (Inherited from DockingWindow.)
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window. (Inherited from DockingWindow.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI. (Inherited from DockingWindow.)
Public property | ToolWindowContainerTabContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's tab for this tool window.
Public property | ToolWindowContainerTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's title bar when this tool window is active.
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from DockingWindow.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity. (Inherited from DockingWindow.)
Top
Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it. (Inherited from DockingWindow.)
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it. (Inherited from DockingWindow.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | Attach | Attaches the ToolWindow to the specified target, generally making a tabbed group.
Public method | AutoHide | Auto-hides the ToolWindow to the closest outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the ToolWindow to the specified outer-edge of the ancestor DockHost.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window, removing it from the layout. (Inherited from DockingWindow.)
Public method | CloseAllInContainer | Closes all windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers | Closes all other windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite. (Inherited from DockingWindow.)
Public method | Dock | Docks the ToolWindow back to its default docked location.
Public method | Dock(IDockTarget, Side) | Docks the ToolWindow to the side of a specified target.
Public method | DragMove | Programmatically starts a drag/move. (Inherited from DockingWindow.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the ToolWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Public method | GetCurrentSide | Returns a Side indicating where the tool window is located, if it is currently open.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site. (Inherited from DockingWindow.)
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area. (Inherited from DockingWindow.)
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area. (Inherited from DockingWindow.)
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from DockingWindow.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed. (Overrides DockingWindowOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Inherited from DockingWindow.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes. (Inherited from DockingWindow.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from DockingWindow.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed. (Overrides DockingWindowOnStateChanged(DockingWindowState, DockingWindowState).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | Open | Opens the window, inserting it into the layout. (Inherited from DockingWindow.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Overrides DockingWindowToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value. (Overrides DockingWindowUpdateCanAttachResolved.)
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value. (Overrides DockingWindowUpdateCanBecomeDocumentResolved.)
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value. (Overrides DockingWindowUpdateCanCloseResolved.)
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value. (Overrides DockingWindowUpdateCanDockResolved.)
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value. (Overrides DockingWindowUpdateCanDragTabResolved.)
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value. (Overrides DockingWindowUpdateCanDragToLinkedDockSitesResolved.)
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value. (Overrides DockingWindowUpdateCanFloatResolved.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Overrides DockingWindowUpdateCommands.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from DockingWindow.)
Top
Fields
Name | Description
AutoHideTabContextContentTemplateProperty | Identifies the AutoHideTabContextContentTemplate dependency property. This field is read-only.
CanAutoHideProperty | Identifies the CanAutoHide dependency property. This field is read-only.
CanAutoHideResolvedProperty | Identifies the CanAutoHideResolved dependency property. This field is read-only.
CanBecomeDocumentProperty | Identifies the CanBecomeDocument dependency property. This field is read-only.
ContainerAutoHideSizeProperty | Identifies the ContainerAutoHideSize dependency property. This field is read-only.
DefaultDockSideProperty | Identifies the DefaultDockSide dependency property. This field is read-only.
HasOptionsButtonProperty | Identifies the HasOptionsButton dependency property. This field is read-only.
HasOptionsButtonResolvedProperty | Identifies the HasOptionsButtonResolved dependency property. This field is read-only.
HasTitleBarProperty | Identifies the HasTitleBar dependency property. This field is read-only.
HasTitleBarResolvedProperty | Identifies the HasTitleBarResolved dependency property. This field is read-only.
IsAutoHidePopupOpenProperty | Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.
ToolWindowContainerTabContextContentTemplateProperty | Identifies the ToolWindowContainerTabContextContentTemplate dependency property. This field is read-only.
ToolWindowContainerTitleBarContextContentTemplateProperty | Identifies the ToolWindowContainerTitleBarContextContentTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Constructor

Overload List
 | Name | Description
Public method | ToolWindow | Initializes a new instance of the ToolWindow class. When creating instances of ToolWindow programmatically, use a constructor that accepts a DockSite instead.
Public method | ToolWindow(Boolean) | Initializes a new instance of the ToolWindow class.
Public method | ToolWindow(DockSite) | Initializes a new instance of the ToolWindow class.
Public method | ToolWindow(DockSite, String, String, ImageSource, Object) | Initializes a new instance of the ToolWindow class.
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Constructor

Initializes a new instance of the ToolWindow class. When creating instances of ToolWindow programmatically, use a constructor that accepts a DockSite instead.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindow()
Public Sub New
See Also

Reference

ToolWindow Class
ToolWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Constructor (Boolean)

Initializes a new instance of the ToolWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindow(
    bool isContainerForItem
)
Public Sub New (
    isContainerForItem As Boolean
)

Parameters

isContainerForItem
Type: SystemBoolean
Whether the window is a container for an item.
See Also

Reference

ToolWindow Class
ToolWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Constructor (DockSite)

Initializes a new instance of the ToolWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindow(
    DockSite dockSite
)
Public Sub New (
    dockSite As DockSite
)

Parameters

dockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The DockSite with which to register this window.
See Also

Reference

ToolWindow Class
ToolWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Constructor (DockSite, String, String, ImageSource, Object)

Initializes a new instance of the ToolWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindow(
    DockSite dockSite,
    string serializationId,
    string title,
    ImageSource imageSource,
    Object content
)
Public Sub New (
    dockSite As DockSite,
    serializationId As String,
    title As String,
    imageSource As ImageSource,
    content As Object
)

Parameters

dockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The DockSite with which to register this window.
serializationId
Type: SystemString
The serialization ID of the window, used during layout serialization.
title
Type: SystemString
The title of the window.
imageSource
Type: System.Windows.MediaImageSource
The image source for the window's icon.
content
Type: SystemObject
The content of the window.
See Also

Reference

ToolWindow Class
ToolWindow Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Properties

The ToolWindow type exposes the following members.

Properties
 | Name | Description
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window. (Inherited from DockingWindow.)
Public property | AutoHideCommand | Gets the ICommand that can move the window into an auto-hide state.
Public property | AutoHideTabContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAutoHide | Gets or sets whether the tool window may be placed in auto-hide mode.
Public property | CanAutoHideResolved | Gets a resolved value indicating whether the tool window may be placed in auto-hide mode.
Public property | CanBecomeDocument | Gets or sets whether the tool window may be placed in a document state.
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state. (Inherited from DockingWindow.)
Public property | CanClose | Gets or sets whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanDock | Gets or sets whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost. (Inherited from DockingWindow.)
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CloseAllInContainerCommand | Gets or sets the ICommand that can close all windows in the current container. (Inherited from DockingWindow.)
Public property | CloseCommand | Gets the ICommand that can Close the window. (Inherited from DockingWindow.)
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container. (Inherited from DockingWindow.)
Public property | ContainerAutoHideSize | Gets or sets the Size of the tool window's container when it is in an auto-hide state.
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state. (Inherited from DockingWindow.)
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | DefaultDockSide | Gets or sets the default Side that the tool window will dock towards when no prior location is known.
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI. (Inherited from DockingWindow.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window. (Inherited from DockingWindow.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockCommand | Gets the ICommand that can move the window into a docked state.
Public property | DockHost | Gets the DockHost in which the window is currently located. (Inherited from DockingWindow.)
Public property | DockSite | Gets the DockSite that is managing this docking window. (Inherited from DockingWindow.)
Public property | FloatCommand | Gets the ICommand that can Float the window. (Inherited from DockingWindow.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasOptionsButton | Gets or sets whether the tool window displays an options button in its ToolWindowContainer title bar.
Public property | HasOptionsButtonResolved | Gets a resolved value indicating whether the tool window displays an options button in its ToolWindowContainer title bar.
Public property | HasTitleBar | Gets or sets whether the tool window displays a title bar in its parent ToolWindowContainer.
Public property | HasTitleBarResolved | Gets a resolved value indicating whether the tool window displays a title bar in its parent ToolWindowContainer.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs. (Inherited from DockingWindow.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus. (Inherited from DockingWindow.)
Public property | IsAutoHidePopupOpen | Gets whether the tool window is currently visible within an auto-hide popup.
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties. (Inherited from DockingWindow.)
Public property | IsFloating | Gets or sets whether the docking window is floating, meaning it is currently open in a floating DockHost, or is closed and was last open in a floating DockHost. (Inherited from DockingWindow.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout. (Inherited from DockingWindow.)
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container. (Inherited from DockingWindow.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from DockingWindow.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area. (Inherited from DockingWindow.)
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container. (Inherited from DockingWindow.)
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host. (Inherited from DockingWindow.)
Public property | OpenCommand | Gets the ICommand that can Open the window. (Inherited from DockingWindow.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window. (Inherited from DockingWindow.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data. (Inherited from DockingWindow.)
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter. (Inherited from DockingWindow.)
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content. (Inherited from DockingWindow.)
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state. (Inherited from DockingWindow.)
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window. (Inherited from DockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI. (Inherited from DockingWindow.)
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window. (Inherited from DockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview). (Inherited from DockingWindow.)
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab. (Inherited from DockingWindow.)
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled. (Inherited from DockingWindow.)
Public property | TabFlashMode | Gets or sets the flash mode for the tab. (Inherited from DockingWindow.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes. (Inherited from DockingWindow.)
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window. (Inherited from DockingWindow.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI. (Inherited from DockingWindow.)
Public property | ToolWindowContainerTabContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's tab for this tool window.
Public property | ToolWindowContainerTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's title bar when this tool window is active.
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from DockingWindow.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity. (Inherited from DockingWindow.)
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.AutoHideCommand Property

ToolWindowAutoHideCommand Property

Gets the ICommand that can move the window into an auto-hide state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand AutoHideCommand { get; }
Public ReadOnly Property AutoHideCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window into an auto-hide state.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.AutoHideTabContextContentTemplate Property

ToolWindowAutoHideTabContextContentTemplate Property

Gets or sets the DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate AutoHideTabContextContentTemplate { get; set; }
Public Property AutoHideTabContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.CanAutoHide Property

ToolWindowCanAutoHide Property

Gets or sets whether the tool window may be placed in auto-hide mode.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanAutoHide { get; set; }
Public Property CanAutoHide As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the tool window may be placed in auto-hide mode.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.CanAutoHideResolved Property

ToolWindowCanAutoHideResolved Property

Gets a resolved value indicating whether the tool window may be placed in auto-hide mode.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanAutoHideResolved { get; }
Public ReadOnly Property CanAutoHideResolved As Boolean
    Get

Property Value

Type: Boolean
true if the tool window may be placed in auto-hide mode; otherwise, false.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.CanBecomeDocument Property

ToolWindowCanBecomeDocument Property

Gets or sets whether the tool window may be placed in a document state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanBecomeDocument { get; set; }
Public Property CanBecomeDocument As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the tool window may be placed in a document state.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.ContainerAutoHideSize Property

ToolWindowContainerAutoHideSize Property

Gets or sets the Size of the tool window's container when it is in an auto-hide state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size ContainerAutoHideSize { get; set; }
Public Property ContainerAutoHideSize As Size
    Get
    Set

Property Value

Type: Size
The Size of the tool window's container when it is in an auto-hide state.
Remarks
The container is a ToolWindowContainer.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.DefaultDockSide Property

ToolWindowDefaultDockSide Property

Gets or sets the default Side that the tool window will dock towards when no prior location is known.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Side DefaultDockSide { get; set; }
Public Property DefaultDockSide As Side
    Get
    Set

Property Value

Type: Side
The default Side that the tool window will dock towards when no prior location is known. The default value is Right.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.DockCommand Property

ToolWindowDockCommand Property

Gets the ICommand that can move the window into a docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand DockCommand { get; }
Public ReadOnly Property DockCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window into a docked state.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.HasOptionsButton Property

ToolWindowHasOptionsButton Property

Gets or sets whether the tool window displays an options button in its ToolWindowContainer title bar.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> HasOptionsButton { get; set; }
Public Property HasOptionsButton As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the tool window displays an options button in its ToolWindowContainer title bar.
Remarks
If set to , the resolved value will use the global DockSite setting. If this value resolves to true then the window will display a drop-down menu button.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.HasOptionsButtonResolved Property

ToolWindowHasOptionsButtonResolved Property

Gets a resolved value indicating whether the tool window displays an options button in its ToolWindowContainer title bar.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasOptionsButtonResolved { get; }
Public ReadOnly Property HasOptionsButtonResolved As Boolean
    Get

Property Value

Type: Boolean
true if the tool window displays an options button in its ToolWindowContainer title bar; otherwise, false.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.HasTitleBar Property

ToolWindowHasTitleBar Property

Gets or sets whether the tool window displays a title bar in its parent ToolWindowContainer.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> HasTitleBar { get; set; }
Public Property HasTitleBar As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the tool window displays a title bar in its parent ToolWindowContainer.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.HasTitleBarResolved Property

ToolWindowHasTitleBarResolved Property

Gets a resolved value indicating whether the tool window displays a title bar in its parent ToolWindowContainer.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTitleBarResolved { get; }
Public ReadOnly Property HasTitleBarResolved As Boolean
    Get

Property Value

Type: Boolean
true if the tool window displays a title bar in its parent ToolWindowContainer; otherwise, false.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.IsAutoHidePopupOpen Property

ToolWindowIsAutoHidePopupOpen Property

Gets whether the tool window is currently visible within an auto-hide popup.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAutoHidePopupOpen { get; }
Public ReadOnly Property IsAutoHidePopupOpen As Boolean
    Get

Property Value

Type: Boolean
true if the tool window is currently visible within an auto-hide popup; otherwise, false. The default value is false.
Remarks
This property is only true when the tool window is an auto-hide State and it is the AutoHidePopupToolWindow in the containing dock host.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.ToolWindowContainerTabContextContentTemplate Property

ToolWindowToolWindowContainerTabContextContentTemplate Property

Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's tab for this tool window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ToolWindowContainerTabContextContentTemplate { get; set; }
Public Property ToolWindowContainerTabContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing contextual content that should be rendered in a tool window container's tab for this tool window.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.ToolWindowContainerTitleBarContextContentTemplate Property

ToolWindowToolWindowContainerTitleBarContextContentTemplate Property

Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's title bar when this tool window is active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ToolWindowContainerTitleBarContextContentTemplate { get; set; }
Public Property ToolWindowContainerTitleBarContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing contextual content that should be rendered in a tool window container's title bar when this tool window is active.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Methods

The ToolWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it. (Inherited from DockingWindow.)
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it. (Inherited from DockingWindow.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | Attach | Attaches the ToolWindow to the specified target, generally making a tabbed group.
Public method | AutoHide | Auto-hides the ToolWindow to the closest outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the ToolWindow to the specified outer-edge of the ancestor DockHost.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window, removing it from the layout. (Inherited from DockingWindow.)
Public method | CloseAllInContainer | Closes all windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers | Closes all other windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite. (Inherited from DockingWindow.)
Public method | Dock | Docks the ToolWindow back to its default docked location.
Public method | Dock(IDockTarget, Side) | Docks the ToolWindow to the side of a specified target.
Public method | DragMove | Programmatically starts a drag/move. (Inherited from DockingWindow.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the ToolWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Public method | GetCurrentSide | Returns a Side indicating where the tool window is located, if it is currently open.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site. (Inherited from DockingWindow.)
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area. (Inherited from DockingWindow.)
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area. (Inherited from DockingWindow.)
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from DockingWindow.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed. (Overrides DockingWindowOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Inherited from DockingWindow.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes. (Inherited from DockingWindow.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from DockingWindow.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed. (Overrides DockingWindowOnStateChanged(DockingWindowState, DockingWindowState).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | Open | Opens the window, inserting it into the layout. (Inherited from DockingWindow.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Overrides DockingWindowToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value. (Overrides DockingWindowUpdateCanAttachResolved.)
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value. (Overrides DockingWindowUpdateCanBecomeDocumentResolved.)
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value. (Overrides DockingWindowUpdateCanCloseResolved.)
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value. (Overrides DockingWindowUpdateCanDockResolved.)
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value. (Overrides DockingWindowUpdateCanDragTabResolved.)
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value. (Overrides DockingWindowUpdateCanDragToLinkedDockSitesResolved.)
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value. (Overrides DockingWindowUpdateCanFloatResolved.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Overrides DockingWindowUpdateCommands.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.Attach Method

ToolWindowAttach Method

Attaches the ToolWindow to the specified target, generally making a tabbed group.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Attach(
    IDockTarget target
)
Public Sub Attach (
    target As IDockTarget
)

Parameters

target
Type: ActiproSoftware.Windows.Controls.DockingIDockTarget
The IDockTarget against which to attach.
Remarks
The target can be another docking window, TabbedMdiContainer, or ToolWindowContainer. Use the Dock(IDockTarget, Side) method to dock to the side of the target instead.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.AutoHide Method

ToolWindowAutoHide Method

Overload List
 | Name | Description
Public method | AutoHide | Auto-hides the ToolWindow to the closest outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the ToolWindow to the specified outer-edge of the ancestor DockHost.
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.AutoHide Method

ToolWindowAutoHide Method

Auto-hides the ToolWindow to the closest outer-edge of the ancestor DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AutoHide()
Public Sub AutoHide
Remarks
Using this method places the ToolWindow in an AutoHide State. Use the AutoHide(Side) method overload to auto-hide to a specific side.
See Also

Reference

ToolWindow Class
AutoHide Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.AutoHide Method (Side)

ToolWindowAutoHide Method (Side)

Auto-hides the ToolWindow to the specified outer-edge of the ancestor DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AutoHide(
    Side side
)
Public Sub AutoHide (
    side As Side
)

Parameters

side
Type: ActiproSoftware.Windows.ControlsSide
A Side indicating the side upon which to auto-hide.
Remarks
Using this method places the ToolWindow in an AutoHide State. Use the AutoHide method overload to auto-hide to the control's default side.
See Also

Reference

ToolWindow Class
AutoHide Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.Dock Method

ToolWindowDock Method

Overload List
 | Name | Description
Public method | Dock | Docks the ToolWindow back to its default docked location.
Public method | Dock(IDockTarget, Side) | Docks the ToolWindow to the side of a specified target.
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.Dock Method

ToolWindowDock Method

Docks the ToolWindow back to its default docked location.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Dock()
Public Sub Dock
Remarks
Using this method places the ToolWindow in a Docked State. If the tool window isn't currently open or isn't in a Docked state, it will attempt to restore to the previous docked location. If one isn't available, a default docked location will be selected based on WindowGroupName, DefaultLocationRequested, and DefaultDockSide.
See Also

Reference

ToolWindow Class
Dock Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.Dock Method (IDockTarget, Side)

ToolWindowDock Method (IDockTarget, Side)

Docks the ToolWindow to the side of a specified target.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Dock(
    IDockTarget target,
    Side side
)
Public Sub Dock (
    target As IDockTarget,
    side As Side
)

Parameters

target
Type: ActiproSoftware.Windows.Controls.DockingIDockTarget
The IDockTarget that is the target of the dock.
side
Type: ActiproSoftware.Windows.ControlsSide
The target's Side against which to dock.
Remarks
Use the Dock method overload to dock back to its previous docked location. Use the Attach(IDockTarget) method to dock into a particular target.
See Also

Reference

ToolWindow Class
Dock Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.Float Method

ToolWindowFloat Method

Overload List
 | Name | Description
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the ToolWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.Float Method (Nullable(Point), Nullable(Size))

ToolWindowFloat Method (NullablePoint, NullableSize)

Floats the ToolWindow to the specified optional location and size.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Float(
    Nullable<Point> location,
    Nullable<Size> size
)
Public Overrides Sub Float (
    location As Nullable(Of Point),
    size As Nullable(Of Size)
)

Parameters

location
Type: SystemNullable Point
An optional Point specifying the target location of the floating dock host.
size
Type: SystemNullable Size
An optional Size specifying the target size of the floating dock host.
Remarks
When location is not specified, it will float to a default location. When size is not specified, it will float with its current size. Using this method places the ToolWindow in a Docked State within a floating dock host.
See Also

Reference

ToolWindow Class
Float Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.GetCurrentSide Method

ToolWindowGetCurrentSide Method

Returns a Side indicating where the tool window is located, if it is currently open.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Side> GetCurrentSide()
Public Function GetCurrentSide As Nullable(Of Side)

Return Value

Type: Nullable Side
A Side indicating where the tool window is located, if it is currently open.
Remarks
If the tool window is open in a Document state, is returned. If the tool window is open in an AutoHide state, the auto-hide dock Side is returned. If the tool window is open in a Docked state and the containing dock host has a workspace (no tool window inner-fill), a Side indicating the location of the tool window relative to the workspace is returned. If the tool window is open in a Docked state and the containing dock host does not has a workspace (tool window inner-fill is active), a Side indicating the location of the tool window's midpoint relative to the dock host's bounds is returned. Otherwise, if the tool window is closed, is returned.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.OnCreateAutomationPeer Method

ToolWindowOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.OnDockSiteChanged Method

ToolWindowOnDockSiteChanged Method

Occurs when the value of the DockSite property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDockSiteChanged(
    DockSite oldValue,
    DockSite newValue
)
Protected Overrides Sub OnDockSiteChanged (
    oldValue As DockSite,
    newValue As DockSite
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The new value.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.OnStateChanged Method

ToolWindowOnStateChanged Method

Occurs when the value of the State property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnStateChanged(
    DockingWindowState oldValue,
    DockingWindowState newValue
)
Protected Overrides Sub OnStateChanged (
    oldValue As DockingWindowState,
    newValue As DockingWindowState
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowState
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindowState
The new value.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.ToString Method

ToolWindowToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.UpdateCanAttachResolved Method

ToolWindowUpdateCanAttachResolved Method

Updates the CanAttachResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanAttachResolved()
Protected Overrides Sub UpdateCanAttachResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.UpdateCanBecomeDocumentResolved Method

ToolWindowUpdateCanBecomeDocumentResolved Method

Updates the CanBecomeDocumentResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanBecomeDocumentResolved()
Protected Overrides Sub UpdateCanBecomeDocumentResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.UpdateCanCloseResolved Method

ToolWindowUpdateCanCloseResolved Method

Updates the CanCloseResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanCloseResolved()
Protected Overrides Sub UpdateCanCloseResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.UpdateCanDockResolved Method

ToolWindowUpdateCanDockResolved Method

Updates the CanDockResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanDockResolved()
Protected Overrides Sub UpdateCanDockResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.UpdateCanDragTabResolved Method

ToolWindowUpdateCanDragTabResolved Method

Updates the CanDragTabResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanDragTabResolved()
Protected Overrides Sub UpdateCanDragTabResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.UpdateCanDragToLinkedDockSitesResolved Method

ToolWindowUpdateCanDragToLinkedDockSitesResolved Method

Updates the CanDragToLinkedDockSitesResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanDragToLinkedDockSitesResolved()
Protected Overrides Sub UpdateCanDragToLinkedDockSitesResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.UpdateCanFloatResolved Method

ToolWindowUpdateCanFloatResolved Method

Updates the CanFloatResolved value.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCanFloatResolved()
Protected Overrides Sub UpdateCanFloatResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.UpdateCommands Method

ToolWindowUpdateCommands Method

Updates the enabled states of the commands.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCommands()
Protected Overrides Sub UpdateCommands
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Events

The ToolWindow type exposes the following members.

Events
 | Name | Description
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from DockingWindow.)
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow Fields

The ToolWindow type exposes the following members.

Fields
Name | Description
AutoHideTabContextContentTemplateProperty | Identifies the AutoHideTabContextContentTemplate dependency property. This field is read-only.
CanAutoHideProperty | Identifies the CanAutoHide dependency property. This field is read-only.
CanAutoHideResolvedProperty | Identifies the CanAutoHideResolved dependency property. This field is read-only.
CanBecomeDocumentProperty | Identifies the CanBecomeDocument dependency property. This field is read-only.
ContainerAutoHideSizeProperty | Identifies the ContainerAutoHideSize dependency property. This field is read-only.
DefaultDockSideProperty | Identifies the DefaultDockSide dependency property. This field is read-only.
HasOptionsButtonProperty | Identifies the HasOptionsButton dependency property. This field is read-only.
HasOptionsButtonResolvedProperty | Identifies the HasOptionsButtonResolved dependency property. This field is read-only.
HasTitleBarProperty | Identifies the HasTitleBar dependency property. This field is read-only.
HasTitleBarResolvedProperty | Identifies the HasTitleBarResolved dependency property. This field is read-only.
IsAutoHidePopupOpenProperty | Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.
ToolWindowContainerTabContextContentTemplateProperty | Identifies the ToolWindowContainerTabContextContentTemplate dependency property. This field is read-only.
ToolWindowContainerTitleBarContextContentTemplateProperty | Identifies the ToolWindowContainerTitleBarContextContentTemplate dependency property. This field is read-only.
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.AutoHideTabContextContentTemplateProperty Field

ToolWindowAutoHideTabContextContentTemplateProperty Field

Identifies the AutoHideTabContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabContextContentTemplateProperty
Public Shared ReadOnly AutoHideTabContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabContextContentTemplate dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.CanAutoHideProperty Field

ToolWindowCanAutoHideProperty Field

Identifies the CanAutoHide dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAutoHideProperty
Public Shared ReadOnly CanAutoHideProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAutoHide dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.CanAutoHideResolvedProperty Field

ToolWindowCanAutoHideResolvedProperty Field

Identifies the CanAutoHideResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAutoHideResolvedProperty
Public Shared ReadOnly CanAutoHideResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAutoHideResolved dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.CanBecomeDocumentProperty Field

ToolWindowCanBecomeDocumentProperty Field

Identifies the CanBecomeDocument dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanBecomeDocumentProperty
Public Shared ReadOnly CanBecomeDocumentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanBecomeDocument dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.ContainerAutoHideSizeProperty Field

ToolWindowContainerAutoHideSizeProperty Field

Identifies the ContainerAutoHideSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainerAutoHideSizeProperty
Public Shared ReadOnly ContainerAutoHideSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainerAutoHideSize dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.DefaultDockSideProperty Field

ToolWindowDefaultDockSideProperty Field

Identifies the DefaultDockSide dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultDockSideProperty
Public Shared ReadOnly DefaultDockSideProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultDockSide dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.HasOptionsButtonProperty Field

ToolWindowHasOptionsButtonProperty Field

Identifies the HasOptionsButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasOptionsButtonProperty
Public Shared ReadOnly HasOptionsButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasOptionsButton dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.HasOptionsButtonResolvedProperty Field

ToolWindowHasOptionsButtonResolvedProperty Field

Identifies the HasOptionsButtonResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasOptionsButtonResolvedProperty
Public Shared ReadOnly HasOptionsButtonResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasOptionsButtonResolved dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.HasTitleBarProperty Field

ToolWindowHasTitleBarProperty Field

Identifies the HasTitleBar dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTitleBarProperty
Public Shared ReadOnly HasTitleBarProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTitleBar dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.HasTitleBarResolvedProperty Field

ToolWindowHasTitleBarResolvedProperty Field

Identifies the HasTitleBarResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTitleBarResolvedProperty
Public Shared ReadOnly HasTitleBarResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTitleBarResolved dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.IsAutoHidePopupOpenProperty Field

ToolWindowIsAutoHidePopupOpenProperty Field

Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoHidePopupOpenProperty
Public Shared ReadOnly IsAutoHidePopupOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoHidePopupOpen dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.ToolWindowContainerTabContextContentTemplateProperty Field

ToolWindowToolWindowContainerTabContextContentTemplateProperty Field

Identifies the ToolWindowContainerTabContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowContainerTabContextContentTemplateProperty
Public Shared ReadOnly ToolWindowContainerTabContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowContainerTabContextContentTemplate dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindow.ToolWindowContainerTitleBarContextContentTemplateProperty Field

ToolWindowToolWindowContainerTitleBarContextContentTemplateProperty Field

Identifies the ToolWindowContainerTitleBarContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowContainerTitleBarContextContentTemplateProperty
Public Shared ReadOnly ToolWindowContainerTitleBarContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowContainerTitleBarContextContentTemplate dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowCollection Class

Represents an observable collection of ToolWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection ToolWindow
System.Collections.ObjectModelObservableCollection ToolWindow
ActiproSoftware.WindowsDeferrableObservableCollection ToolWindow
ActiproSoftware.Windows.Controls.DockingDockingWindowCollectionBase ToolWindow
ActiproSoftware.Windows.Controls.DockingToolWindowCollection

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ToolWindowCollection : DockingWindowCollectionBase<ToolWindow>
Public Class ToolWindowCollection
    Inherits DockingWindowCollectionBase(Of ToolWindow)

The ToolWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowCollection | Initializes a new instance of the ToolWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection ToolWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection ToolWindow .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection ToolWindow .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection ToolWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection ToolWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection ToolWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection ToolWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection ToolWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection ToolWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection ToolWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection ToolWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection ToolWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection ToolWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ToolWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection ToolWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection ToolWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection ToolWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection ToolWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection ToolWindow .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowCollection Constructor

Initializes a new instance of the ToolWindowCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowCollection()
Public Sub New
See Also

Reference

ToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowCollection Properties

The ToolWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection ToolWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection ToolWindow .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection ToolWindow .)
Top
See Also

Reference

ToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowCollection Methods

The ToolWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection ToolWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection ToolWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection ToolWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection ToolWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection ToolWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection ToolWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection ToolWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection ToolWindow .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection ToolWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection ToolWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ToolWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection ToolWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection ToolWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection ToolWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

ToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowCollection Events

The ToolWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection ToolWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection ToolWindow .)
Top
See Also

Reference

ToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer Class

Represents a container of one or more tool windows.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockingWindowContainerBase
ActiproSoftware.Windows.Controls.DockingToolWindowContainer

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ToolWindowContainer : DockingWindowContainerBase,
    IOrientedElement, IDockTarget
Public Class ToolWindowContainer
    Inherits DockingWindowContainerBase
    Implements IOrientedElement, IDockTarget

The ToolWindowContainer type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowContainer | Initializes an instance of the ToolWindowContainer class.
Top
Properties
 | Name | Description
Public property | AutoHideCommand | Gets the ICommand that can auto-hide the windows in the container.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from DockingWindowContainerBase.)
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content.
Public property | CloseCommand | Gets the ICommand that can close the windows in the container.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockCommand | Gets the ICommand that can dock the windows in the container.
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from DockingWindowContainerBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from DockingWindowContainerBase.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the container has a title bar close button if the SelectedWindow is closable.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from DockingWindowContainerBase.)
Public property | HasTitleBarGripper | Gets or sets whether the titlebar has a gripper.
Public property | HasTitleBarIcon | Gets or sets whether the container is capable of displaying the selected window's icon in the title bar.
Public property | HasToggleAutoHideButton | Gets or sets whether the container has a title bar toggle auto-hide button if the SelectedWindow can auto-hide.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it. (Inherited from DockingWindowContainerBase.)
Public property | IsCloseButtonVisible | Gets whether the container's close button is visible.
Public property | IsMaximizeButtonVisible | Gets whether the container's maximize button is visible.
Public property | IsMinimizeButtonVisible | Gets whether the container's minimize button is visible.
Public property | IsOptionsButtonVisible | Gets whether the container's options button is visible.
Public property | IsRestoreButtonVisible | Gets whether the container's restore button is visible.
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible. (Inherited from DockingWindowContainerBase.)
Public property | IsToggleAutoHideButtonVisible | Gets whether the container's toggle auto-hide button is visible.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from DockingWindowContainerBase.)
Public property | MaximizeButtonContentTemplate | Gets or sets the DataTemplate to use for the maximize button content.
Public property | MaximizeCommand | Gets the ICommand that can maximize the window that hosts the container.
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content.
Public property | MinimizeButtonContentTemplate | Gets or sets the DataTemplate to use for the minimize button content.
Public property | MinimizeCommand | Gets the ICommand that can minimize the window that hosts the container.
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | OpenOptionsMenuCommand | Gets the ICommand that can open the options menu.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content.
Public property | RestoreButtonContentTemplate | Gets or sets the DataTemplate to use for the restore button content.
Public property | RestoreCommand | Gets the ICommand that can restore the window that hosts the container.
Public property | SelectedToolWindow | Gets the ToolWindow that is currently selected in the container.
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container. (Inherited from DockingWindowContainerBase.)
Public property | SingleTabLayoutBehavior | Gets or sets the behavior used when a single ToolWindow is in the container.
Public property | State | Gets the DockingWindowState that specifies the current state of the container. (Inherited from DockingWindowContainerBase.)
Protected property | TabControl | Gets the tab control in the container's user interface. (Inherited from DockingWindowContainerBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl. (Inherited from DockingWindowContainerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers. (Inherited from DockingWindowContainerBase.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from DockingWindowContainerBase.)
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located. (Inherited from DockingWindowContainerBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TitleBarContextContentAlignment | Gets or sets the alignment of title bar context content.
Public property | TitleFontFamily | Gets or sets the title's font family.
Public property | TitleFontSize | Gets or sets the title's font size.
Public property | TitleFontWeight | Gets or sets the title's font weight.
Public property | ToggleAutoHideCommand | Gets the ICommand that can toggle the container between an auto-hide and docked state.
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Protected property | WindowsCore | Gets the collection of child DockingWindow objects. (Inherited from DockingWindowContainerBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | AutoHide | Auto-hides the contained ToolWindow controls to the outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the contained ToolWindow controls to the specified outer-edge of the ancestor DockHost.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the tool windows in the container, removing them from the layout.
Public method | Dock | Docks the contained ToolWindow controls back to their default docked location.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides DockingWindowContainerBaseOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed. (Overrides DockingWindowContainerBaseOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from DockingWindowContainerBase.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Inherited from DockingWindowContainerBase.)
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening. (Overrides DockingWindowContainerBaseOnTabControlMenuOpening(AdvancedTabControlMenuEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnWindowsChanged | Occurs when the ActiproSoftware.Windows collection is changed. (Inherited from DockingWindowContainerBase.)
Public method | OpenOptionsMenu | Options the options menu for the SelectedWindow.
Public method | OpenOptionsMenu(FrameworkElement) | Options the options menu for the SelectedWindow under the specified placement target element.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindowContainerBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Overrides DockingWindowContainerBaseUpdateCommands.)
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows. (Overrides DockingWindowContainerBaseUpdateDockingWindowStates.)
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property. (Overrides DockingWindowContainerBaseUpdateIsTabStripVisible.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility. (Overrides DockingWindowContainerBaseUpdateTitleBarButtonVisibility.)
Protected method | UpdateVisualState | Updates the visual state. (Overrides DockingWindowContainerBaseUpdateVisualState(Boolean).)
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container. (Overrides DockingWindowContainerBaseValidateChildType(DockingWindow).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CloseButtonContentTemplateProperty | Identifies the CloseButtonContentTemplate dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasTitleBarGripperProperty | Identifies the HasTitleBarGripper dependency property. This field is read-only.
HasTitleBarIconProperty | Identifies the HasTitleBarIcon dependency property. This field is read-only.
HasToggleAutoHideButtonProperty | Identifies the HasToggleAutoHideButton dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsOptionsButtonVisibleProperty | Identifies the IsOptionsButtonVisible dependency property. This field is read-only.
IsRestoreButtonVisibleProperty | Identifies the IsRestoreButtonVisible dependency property. This field is read-only.
IsToggleAutoHideButtonVisibleProperty | Identifies the IsToggleAutoHideButtonVisible dependency property. This field is read-only.
MaximizeButtonContentTemplateProperty | Identifies the MaximizeButtonContentTemplate dependency property. This field is read-only.
MenuButtonContentTemplateProperty | Identifies the MenuButtonContentTemplate dependency property. This field is read-only.
MinimizeButtonContentTemplateProperty | Identifies the MinimizeButtonContentTemplate dependency property. This field is read-only.
PinButtonContentTemplateProperty | Identifies the PinButtonContentTemplate dependency property. This field is read-only.
RestoreButtonContentTemplateProperty | Identifies the RestoreButtonContentTemplate dependency property. This field is read-only.
SingleTabLayoutBehaviorProperty | Identifies the SingleTabLayoutBehavior dependency property. This field is read-only.
TitleBarContextContentAlignmentProperty | Identifies the TitleBarContextContentAlignment dependency property. This field is read-only.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. This field is read-only.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. This field is read-only.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. This field is read-only.
UnpinButtonContentTemplateProperty | Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer Constructor

Initializes an instance of the ToolWindowContainer class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainer()
Public Sub New
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer Properties

The ToolWindowContainer type exposes the following members.

Properties
 | Name | Description
Public property | AutoHideCommand | Gets the ICommand that can auto-hide the windows in the container.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from DockingWindowContainerBase.)
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content.
Public property | CloseCommand | Gets the ICommand that can close the windows in the container.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockCommand | Gets the ICommand that can dock the windows in the container.
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from DockingWindowContainerBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from DockingWindowContainerBase.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the container has a title bar close button if the SelectedWindow is closable.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from DockingWindowContainerBase.)
Public property | HasTitleBarGripper | Gets or sets whether the titlebar has a gripper.
Public property | HasTitleBarIcon | Gets or sets whether the container is capable of displaying the selected window's icon in the title bar.
Public property | HasToggleAutoHideButton | Gets or sets whether the container has a title bar toggle auto-hide button if the SelectedWindow can auto-hide.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it. (Inherited from DockingWindowContainerBase.)
Public property | IsCloseButtonVisible | Gets whether the container's close button is visible.
Public property | IsMaximizeButtonVisible | Gets whether the container's maximize button is visible.
Public property | IsMinimizeButtonVisible | Gets whether the container's minimize button is visible.
Public property | IsOptionsButtonVisible | Gets whether the container's options button is visible.
Public property | IsRestoreButtonVisible | Gets whether the container's restore button is visible.
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible. (Inherited from DockingWindowContainerBase.)
Public property | IsToggleAutoHideButtonVisible | Gets whether the container's toggle auto-hide button is visible.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from DockingWindowContainerBase.)
Public property | MaximizeButtonContentTemplate | Gets or sets the DataTemplate to use for the maximize button content.
Public property | MaximizeCommand | Gets the ICommand that can maximize the window that hosts the container.
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content.
Public property | MinimizeButtonContentTemplate | Gets or sets the DataTemplate to use for the minimize button content.
Public property | MinimizeCommand | Gets the ICommand that can minimize the window that hosts the container.
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | OpenOptionsMenuCommand | Gets the ICommand that can open the options menu.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content.
Public property | RestoreButtonContentTemplate | Gets or sets the DataTemplate to use for the restore button content.
Public property | RestoreCommand | Gets the ICommand that can restore the window that hosts the container.
Public property | SelectedToolWindow | Gets the ToolWindow that is currently selected in the container.
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container. (Inherited from DockingWindowContainerBase.)
Public property | SingleTabLayoutBehavior | Gets or sets the behavior used when a single ToolWindow is in the container.
Public property | State | Gets the DockingWindowState that specifies the current state of the container. (Inherited from DockingWindowContainerBase.)
Protected property | TabControl | Gets the tab control in the container's user interface. (Inherited from DockingWindowContainerBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl. (Inherited from DockingWindowContainerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers. (Inherited from DockingWindowContainerBase.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from DockingWindowContainerBase.)
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located. (Inherited from DockingWindowContainerBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TitleBarContextContentAlignment | Gets or sets the alignment of title bar context content.
Public property | TitleFontFamily | Gets or sets the title's font family.
Public property | TitleFontSize | Gets or sets the title's font size.
Public property | TitleFontWeight | Gets or sets the title's font weight.
Public property | ToggleAutoHideCommand | Gets the ICommand that can toggle the container between an auto-hide and docked state.
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Protected property | WindowsCore | Gets the collection of child DockingWindow objects. (Inherited from DockingWindowContainerBase.)
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.AutoHideCommand Property

ToolWindowContainerAutoHideCommand Property

Gets the ICommand that can auto-hide the windows in the container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand AutoHideCommand { get; }
Public ReadOnly Property AutoHideCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can auto-hide the windows in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.CloseButtonContentTemplate Property

ToolWindowContainerCloseButtonContentTemplate Property

Gets or sets the DataTemplate to use for the close button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate CloseButtonContentTemplate { get; set; }
Public Property CloseButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the close button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.CloseCommand Property

ToolWindowContainerCloseCommand Property

Gets the ICommand that can close the windows in the container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CloseCommand { get; }
Public ReadOnly Property CloseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close the windows in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.DockCommand Property

ToolWindowContainerDockCommand Property

Gets the ICommand that can dock the windows in the container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand DockCommand { get; }
Public ReadOnly Property DockCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can dock the windows in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.EmbeddedButtonStyle Property

ToolWindowContainerEmbeddedButtonStyle Property

Gets or sets the Style to use for embedded buttons.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style EmbeddedButtonStyle { get; set; }
Public Property EmbeddedButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for embedded buttons.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.HasCloseButton Property

ToolWindowContainerHasCloseButton Property

Gets or sets whether the container has a title bar close button if the SelectedWindow is closable.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasCloseButton { get; set; }
Public Property HasCloseButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the container has a title bar close button if the SelectedWindow is closable; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.HasTitleBarGripper Property

ToolWindowContainerHasTitleBarGripper Property

Gets or sets whether the titlebar has a gripper.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTitleBarGripper { get; set; }
Public Property HasTitleBarGripper As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the titlebar has a gripper; otherwise, false. The default value is false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.HasTitleBarIcon Property

ToolWindowContainerHasTitleBarIcon Property

Gets or sets whether the container is capable of displaying the selected window's icon in the title bar.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTitleBarIcon { get; set; }
Public Property HasTitleBarIcon As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying the selected window's icon in the title bar; otherwise, false. The default value is false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.HasToggleAutoHideButton Property

ToolWindowContainerHasToggleAutoHideButton Property

Gets or sets whether the container has a title bar toggle auto-hide button if the SelectedWindow can auto-hide.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasToggleAutoHideButton { get; set; }
Public Property HasToggleAutoHideButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the container has a title bar toggle auto-hide button if the SelectedWindow can auto-hide; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsCloseButtonVisible Property

ToolWindowContainerIsCloseButtonVisible Property

Gets whether the container's close button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCloseButtonVisible { get; }
Public ReadOnly Property IsCloseButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's close button is visible; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsMaximizeButtonVisible Property

ToolWindowContainerIsMaximizeButtonVisible Property

Gets whether the container's maximize button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMaximizeButtonVisible { get; }
Public ReadOnly Property IsMaximizeButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's maximize button is visible; otherwise, false. The default value is false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsMinimizeButtonVisible Property

ToolWindowContainerIsMinimizeButtonVisible Property

Gets whether the container's minimize button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMinimizeButtonVisible { get; }
Public ReadOnly Property IsMinimizeButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's minimize button is visible; otherwise, false. The default value is false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsOptionsButtonVisible Property

ToolWindowContainerIsOptionsButtonVisible Property

Gets whether the container's options button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOptionsButtonVisible { get; }
Public ReadOnly Property IsOptionsButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's options button is visible; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsRestoreButtonVisible Property

ToolWindowContainerIsRestoreButtonVisible Property

Gets whether the container's restore button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsRestoreButtonVisible { get; }
Public ReadOnly Property IsRestoreButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's restore button is visible; otherwise, false. The default value is false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsToggleAutoHideButtonVisible Property

ToolWindowContainerIsToggleAutoHideButtonVisible Property

Gets whether the container's toggle auto-hide button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsToggleAutoHideButtonVisible { get; }
Public ReadOnly Property IsToggleAutoHideButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's toggle auto-hide button is visible; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.MaximizeButtonContentTemplate Property

ToolWindowContainerMaximizeButtonContentTemplate Property

Gets or sets the DataTemplate to use for the maximize button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate MaximizeButtonContentTemplate { get; set; }
Public Property MaximizeButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the maximize button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.MaximizeCommand Property

ToolWindowContainerMaximizeCommand Property

Gets the ICommand that can maximize the window that hosts the container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MaximizeCommand { get; }
Public ReadOnly Property MaximizeCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can maximize the window that hosts the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.MenuButtonContentTemplate Property

ToolWindowContainerMenuButtonContentTemplate Property

Gets or sets the DataTemplate to use for the drop-down menu button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate MenuButtonContentTemplate { get; set; }
Public Property MenuButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the drop-down menu button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.MinimizeButtonContentTemplate Property

ToolWindowContainerMinimizeButtonContentTemplate Property

Gets or sets the DataTemplate to use for the minimize button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate MinimizeButtonContentTemplate { get; set; }
Public Property MinimizeButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the minimize button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.MinimizeCommand Property

ToolWindowContainerMinimizeCommand Property

Gets the ICommand that can minimize the window that hosts the container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MinimizeCommand { get; }
Public ReadOnly Property MinimizeCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can minimize the window that hosts the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.OpenOptionsMenuCommand Property

ToolWindowContainerOpenOptionsMenuCommand Property

Gets the ICommand that can open the options menu.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand OpenOptionsMenuCommand { get; }
Public ReadOnly Property OpenOptionsMenuCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can open the options menu.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.PinButtonContentTemplate Property

ToolWindowContainerPinButtonContentTemplate Property

Gets or sets the DataTemplate to use for the pin button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate PinButtonContentTemplate { get; set; }
Public Property PinButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the pin button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.RestoreButtonContentTemplate Property

ToolWindowContainerRestoreButtonContentTemplate Property

Gets or sets the DataTemplate to use for the restore button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate RestoreButtonContentTemplate { get; set; }
Public Property RestoreButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the restore button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.RestoreCommand Property

ToolWindowContainerRestoreCommand Property

Gets the ICommand that can restore the window that hosts the container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand RestoreCommand { get; }
Public ReadOnly Property RestoreCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can restore the window that hosts the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.SelectedToolWindow Property

ToolWindowContainerSelectedToolWindow Property

Gets the ToolWindow that is currently selected in the container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindow SelectedToolWindow { get; }
Public ReadOnly Property SelectedToolWindow As ToolWindow
    Get

Property Value

Type: ToolWindow
The ToolWindow that is currently selected in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.SingleTabLayoutBehavior Property

ToolWindowContainerSingleTabLayoutBehavior Property

Gets or sets the behavior used when a single ToolWindow is in the container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SingleTabLayoutBehavior SingleTabLayoutBehavior { get; set; }
Public Property SingleTabLayoutBehavior As SingleTabLayoutBehavior
    Get
    Set

Property Value

Type: SingleTabLayoutBehavior
The behavior used when a single ToolWindow is in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.TitleBarContextContentAlignment Property

ToolWindowContainerTitleBarContextContentAlignment Property

Gets or sets the alignment of title bar context content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextContentAlignment TitleBarContextContentAlignment { get; set; }
Public Property TitleBarContextContentAlignment As ContextContentAlignment
    Get
    Set

Property Value

Type: ContextContentAlignment
The alignment of title bar context content. The default value is Far.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.TitleFontFamily Property

ToolWindowContainerTitleFontFamily Property

Gets or sets the title's font family.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontFamily TitleFontFamily { get; set; }
Public Property TitleFontFamily As FontFamily
    Get
    Set

Property Value

Type: FontFamily
The title's font family.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.TitleFontSize Property

ToolWindowContainerTitleFontSize Property

Gets or sets the title's font size.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TitleFontSize { get; set; }
Public Property TitleFontSize As Double
    Get
    Set

Property Value

Type: Double
The title's font size.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.TitleFontWeight Property

ToolWindowContainerTitleFontWeight Property

Gets or sets the title's font weight.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontWeight TitleFontWeight { get; set; }
Public Property TitleFontWeight As FontWeight
    Get
    Set

Property Value

Type: FontWeight
The title's font weight. The default value is Normal.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.ToggleAutoHideCommand Property

ToolWindowContainerToggleAutoHideCommand Property

Gets the ICommand that can toggle the container between an auto-hide and docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ToggleAutoHideCommand { get; }
Public ReadOnly Property ToggleAutoHideCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can toggle the container between an auto-hide and docked state.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.UnpinButtonContentTemplate Property

ToolWindowContainerUnpinButtonContentTemplate Property

Gets or sets the DataTemplate to use for the unpin button content.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate UnpinButtonContentTemplate { get; set; }
Public Property UnpinButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the unpin button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.Windows Property

ToolWindowContainerWindows Property

Gets the collection of child DockingWindow objects.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<DockingWindow> Windows { get; }
Public ReadOnly Property Windows As ObservableCollection(Of DockingWindow)
    Get

Property Value

Type: ObservableCollection DockingWindow
The collection of child DockingWindow objects.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer Methods

The ToolWindowContainer type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | AutoHide | Auto-hides the contained ToolWindow controls to the outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the contained ToolWindow controls to the specified outer-edge of the ancestor DockHost.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the tool windows in the container, removing them from the layout.
Public method | Dock | Docks the contained ToolWindow controls back to their default docked location.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides DockingWindowContainerBaseOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed. (Overrides DockingWindowContainerBaseOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from DockingWindowContainerBase.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Inherited from DockingWindowContainerBase.)
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening. (Overrides DockingWindowContainerBaseOnTabControlMenuOpening(AdvancedTabControlMenuEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnWindowsChanged | Occurs when the ActiproSoftware.Windows collection is changed. (Inherited from DockingWindowContainerBase.)
Public method | OpenOptionsMenu | Options the options menu for the SelectedWindow.
Public method | OpenOptionsMenu(FrameworkElement) | Options the options menu for the SelectedWindow under the specified placement target element.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindowContainerBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Overrides DockingWindowContainerBaseUpdateCommands.)
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows. (Overrides DockingWindowContainerBaseUpdateDockingWindowStates.)
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property. (Overrides DockingWindowContainerBaseUpdateIsTabStripVisible.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility. (Overrides DockingWindowContainerBaseUpdateTitleBarButtonVisibility.)
Protected method | UpdateVisualState | Updates the visual state. (Overrides DockingWindowContainerBaseUpdateVisualState(Boolean).)
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container. (Overrides DockingWindowContainerBaseValidateChildType(DockingWindow).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.AutoHide Method

ToolWindowContainerAutoHide Method

Overload List
 | Name | Description
Public method | AutoHide | Auto-hides the contained ToolWindow controls to the outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the contained ToolWindow controls to the specified outer-edge of the ancestor DockHost.
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.AutoHide Method

ToolWindowContainerAutoHide Method

Auto-hides the contained ToolWindow controls to the outer-edge of the ancestor DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AutoHide()
Public Sub AutoHide
Remarks
Using this method places the contained ToolWindow controls in an AutoHide State. Use the AutoHide(Side) method overload to auto-hide to a specific side.
See Also

Reference

ToolWindowContainer Class
AutoHide Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.AutoHide Method (Side)

ToolWindowContainerAutoHide Method (Side)

Auto-hides the contained ToolWindow controls to the specified outer-edge of the ancestor DockHost.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AutoHide(
    Side side
)
Public Sub AutoHide (
    side As Side
)

Parameters

side
Type: ActiproSoftware.Windows.ControlsSide
A Side indicating the side upon which to auto-hide.
Remarks
Using this method places the contained ToolWindow controls in an AutoHide State. Use the AutoHide method overload to auto-hide to the control's default side.
See Also

Reference

ToolWindowContainer Class
AutoHide Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.Close Method

ToolWindowContainerClose Method

Closes the tool windows in the container, removing them from the layout.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Close()
Public Function Close As Boolean

Return Value

Type: Boolean
true if all tool windows were closed successfully; otherwise, false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.Dock Method

ToolWindowContainerDock Method

Docks the contained ToolWindow controls back to their default docked location.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Dock()
Public Sub Dock
Remarks
Using this method places the contained ToolWindow controls in a Docked State.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.OnApplyTemplate Method

ToolWindowContainerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.OnCreateAutomationPeer Method

ToolWindowContainerOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.OnDockSiteChanged Method

ToolWindowContainerOnDockSiteChanged Method

Occurs when the DockSite property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDockSiteChanged(
    DockSite oldDockSite,
    DockSite newDockSite
)
Protected Overrides Sub OnDockSiteChanged (
    oldDockSite As DockSite,
    newDockSite As DockSite
)

Parameters

oldDockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The old value.
newDockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The new value.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.OnKeyDown Method

ToolWindowContainerOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.OnTabControlMenuOpening Method

ToolWindowContainerOnTabControlMenuOpening Method

Occurs when a menu on the tab control is opening.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnTabControlMenuOpening(
    AdvancedTabControlMenuEventArgs e
)
Protected Overrides Sub OnTabControlMenuOpening (
    e As AdvancedTabControlMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingAdvancedTabControlMenuEventArgs
The AdvancedTabControlMenuEventArgs that contains the event data.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.OpenOptionsMenu Method

ToolWindowContainerOpenOptionsMenu Method

Overload List
 | Name | Description
Public method | OpenOptionsMenu | Options the options menu for the SelectedWindow.
Public method | OpenOptionsMenu(FrameworkElement) | Options the options menu for the SelectedWindow under the specified placement target element.
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.OpenOptionsMenu Method

ToolWindowContainerOpenOptionsMenu Method

Options the options menu for the SelectedWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void OpenOptionsMenu()
Public Sub OpenOptionsMenu
See Also

Reference

ToolWindowContainer Class
OpenOptionsMenu Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.OpenOptionsMenu Method (FrameworkElement)

ToolWindowContainerOpenOptionsMenu Method (FrameworkElement)

Options the options menu for the SelectedWindow under the specified placement target element.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void OpenOptionsMenu(
    FrameworkElement placementTarget
)
Public Sub OpenOptionsMenu (
    placementTarget As FrameworkElement
)

Parameters

placementTarget
Type: System.WindowsFrameworkElement
The optional FrameworkElement under which to open the menu.
See Also

Reference

ToolWindowContainer Class
OpenOptionsMenu Overload
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.UpdateCommands Method

ToolWindowContainerUpdateCommands Method

Updates the enabled states of the commands.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateCommands()
Protected Overrides Sub UpdateCommands
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.UpdateDockingWindowStates Method

ToolWindowContainerUpdateDockingWindowStates Method

Updates the DockingWindowState associated with all child docking windows.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateDockingWindowStates()
Protected Overrides Sub UpdateDockingWindowStates
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.UpdateIsTabStripVisible Method

ToolWindowContainerUpdateIsTabStripVisible Method

Updates the IsTabStripVisible property.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateIsTabStripVisible()
Protected Overrides Sub UpdateIsTabStripVisible
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.UpdateTitleBarButtonVisibility Method

ToolWindowContainerUpdateTitleBarButtonVisibility Method

Updates the title bar button visibility.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateTitleBarButtonVisibility()
Protected Overrides Sub UpdateTitleBarButtonVisibility
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.UpdateVisualState Method

ToolWindowContainerUpdateVisualState Method

Updates the visual state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateVisualState(
    bool useTransitions
)
Protected Overrides Sub UpdateVisualState (
    useTransitions As Boolean
)

Parameters

useTransitions
Type: SystemBoolean
Whether to use transitions.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.ValidateChildType Method

ToolWindowContainerValidateChildType Method

Validates that the specified child DockingWindow type is valid for this container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ValidateChildType(
    DockingWindow window
)
Protected Overrides Sub ValidateChildType (
    window As DockingWindow
)

Parameters

window
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The DockingWindow to examine.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer Events

The ToolWindowContainer type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer Fields

The ToolWindowContainer type exposes the following members.

Fields
Name | Description
CloseButtonContentTemplateProperty | Identifies the CloseButtonContentTemplate dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasTitleBarGripperProperty | Identifies the HasTitleBarGripper dependency property. This field is read-only.
HasTitleBarIconProperty | Identifies the HasTitleBarIcon dependency property. This field is read-only.
HasToggleAutoHideButtonProperty | Identifies the HasToggleAutoHideButton dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsOptionsButtonVisibleProperty | Identifies the IsOptionsButtonVisible dependency property. This field is read-only.
IsRestoreButtonVisibleProperty | Identifies the IsRestoreButtonVisible dependency property. This field is read-only.
IsToggleAutoHideButtonVisibleProperty | Identifies the IsToggleAutoHideButtonVisible dependency property. This field is read-only.
MaximizeButtonContentTemplateProperty | Identifies the MaximizeButtonContentTemplate dependency property. This field is read-only.
MenuButtonContentTemplateProperty | Identifies the MenuButtonContentTemplate dependency property. This field is read-only.
MinimizeButtonContentTemplateProperty | Identifies the MinimizeButtonContentTemplate dependency property. This field is read-only.
PinButtonContentTemplateProperty | Identifies the PinButtonContentTemplate dependency property. This field is read-only.
RestoreButtonContentTemplateProperty | Identifies the RestoreButtonContentTemplate dependency property. This field is read-only.
SingleTabLayoutBehaviorProperty | Identifies the SingleTabLayoutBehavior dependency property. This field is read-only.
TitleBarContextContentAlignmentProperty | Identifies the TitleBarContextContentAlignment dependency property. This field is read-only.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. This field is read-only.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. This field is read-only.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. This field is read-only.
UnpinButtonContentTemplateProperty | Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.CloseButtonContentTemplateProperty Field

ToolWindowContainerCloseButtonContentTemplateProperty Field

Identifies the CloseButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CloseButtonContentTemplateProperty
Public Shared ReadOnly CloseButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CloseButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.EmbeddedButtonStyleProperty Field

ToolWindowContainerEmbeddedButtonStyleProperty Field

Identifies the EmbeddedButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmbeddedButtonStyleProperty
Public Shared ReadOnly EmbeddedButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmbeddedButtonStyle dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.HasCloseButtonProperty Field

ToolWindowContainerHasCloseButtonProperty Field

Identifies the HasCloseButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasCloseButtonProperty
Public Shared ReadOnly HasCloseButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasCloseButton dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.HasTitleBarGripperProperty Field

ToolWindowContainerHasTitleBarGripperProperty Field

Identifies the HasTitleBarGripper dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTitleBarGripperProperty
Public Shared ReadOnly HasTitleBarGripperProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTitleBarGripper dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.HasTitleBarIconProperty Field

ToolWindowContainerHasTitleBarIconProperty Field

Identifies the HasTitleBarIcon dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTitleBarIconProperty
Public Shared ReadOnly HasTitleBarIconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTitleBarIcon dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.HasToggleAutoHideButtonProperty Field

ToolWindowContainerHasToggleAutoHideButtonProperty Field

Identifies the HasToggleAutoHideButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasToggleAutoHideButtonProperty
Public Shared ReadOnly HasToggleAutoHideButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasToggleAutoHideButton dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsCloseButtonVisibleProperty Field

ToolWindowContainerIsCloseButtonVisibleProperty Field

Identifies the IsCloseButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCloseButtonVisibleProperty
Public Shared ReadOnly IsCloseButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCloseButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsMaximizeButtonVisibleProperty Field

ToolWindowContainerIsMaximizeButtonVisibleProperty Field

Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMaximizeButtonVisibleProperty
Public Shared ReadOnly IsMaximizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMaximizeButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsMinimizeButtonVisibleProperty Field

ToolWindowContainerIsMinimizeButtonVisibleProperty Field

Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMinimizeButtonVisibleProperty
Public Shared ReadOnly IsMinimizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMinimizeButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsOptionsButtonVisibleProperty Field

ToolWindowContainerIsOptionsButtonVisibleProperty Field

Identifies the IsOptionsButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOptionsButtonVisibleProperty
Public Shared ReadOnly IsOptionsButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOptionsButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsRestoreButtonVisibleProperty Field

ToolWindowContainerIsRestoreButtonVisibleProperty Field

Identifies the IsRestoreButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRestoreButtonVisibleProperty
Public Shared ReadOnly IsRestoreButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRestoreButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.IsToggleAutoHideButtonVisibleProperty Field

ToolWindowContainerIsToggleAutoHideButtonVisibleProperty Field

Identifies the IsToggleAutoHideButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsToggleAutoHideButtonVisibleProperty
Public Shared ReadOnly IsToggleAutoHideButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsToggleAutoHideButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.MaximizeButtonContentTemplateProperty Field

ToolWindowContainerMaximizeButtonContentTemplateProperty Field

Identifies the MaximizeButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximizeButtonContentTemplateProperty
Public Shared ReadOnly MaximizeButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaximizeButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.MenuButtonContentTemplateProperty Field

ToolWindowContainerMenuButtonContentTemplateProperty Field

Identifies the MenuButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MenuButtonContentTemplateProperty
Public Shared ReadOnly MenuButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MenuButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.MinimizeButtonContentTemplateProperty Field

ToolWindowContainerMinimizeButtonContentTemplateProperty Field

Identifies the MinimizeButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimizeButtonContentTemplateProperty
Public Shared ReadOnly MinimizeButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinimizeButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.PinButtonContentTemplateProperty Field

ToolWindowContainerPinButtonContentTemplateProperty Field

Identifies the PinButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PinButtonContentTemplateProperty
Public Shared ReadOnly PinButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PinButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.RestoreButtonContentTemplateProperty Field

ToolWindowContainerRestoreButtonContentTemplateProperty Field

Identifies the RestoreButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RestoreButtonContentTemplateProperty
Public Shared ReadOnly RestoreButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RestoreButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.SingleTabLayoutBehaviorProperty Field

ToolWindowContainerSingleTabLayoutBehaviorProperty Field

Identifies the SingleTabLayoutBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SingleTabLayoutBehaviorProperty
Public Shared ReadOnly SingleTabLayoutBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SingleTabLayoutBehavior dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.TitleBarContextContentAlignmentProperty Field

ToolWindowContainerTitleBarContextContentAlignmentProperty Field

Identifies the TitleBarContextContentAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleBarContextContentAlignmentProperty
Public Shared ReadOnly TitleBarContextContentAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleBarContextContentAlignment dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.TitleFontFamilyProperty Field

ToolWindowContainerTitleFontFamilyProperty Field

Identifies the TitleFontFamily dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleFontFamilyProperty
Public Shared ReadOnly TitleFontFamilyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleFontFamily dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.TitleFontSizeProperty Field

ToolWindowContainerTitleFontSizeProperty Field

Identifies the TitleFontSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleFontSizeProperty
Public Shared ReadOnly TitleFontSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleFontSize dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.TitleFontWeightProperty Field

ToolWindowContainerTitleFontWeightProperty Field

Identifies the TitleFontWeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleFontWeightProperty
Public Shared ReadOnly TitleFontWeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleFontWeight dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainer.UnpinButtonContentTemplateProperty Field

ToolWindowContainerUnpinButtonContentTemplateProperty Field

Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UnpinButtonContentTemplateProperty
Public Shared ReadOnly UnpinButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UnpinButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainerCollection Class

Represents an observable collection of ToolWindowContainer objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection ToolWindowContainer
System.Collections.ObjectModelObservableCollection ToolWindowContainer
ActiproSoftware.WindowsDeferrableObservableCollection ToolWindowContainer
ActiproSoftware.Windows.Controls.DockingToolWindowContainerCollection

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ToolWindowContainerCollection : DeferrableObservableCollection<ToolWindowContainer>
Public Class ToolWindowContainerCollection
    Inherits DeferrableObservableCollection(Of ToolWindowContainer)

The ToolWindowContainerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowContainerCollection | Initializes a new instance of the ToolWindowContainerCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection ToolWindowContainer .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection ToolWindowContainer .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection ToolWindowContainer .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection ToolWindowContainer .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection ToolWindowContainer .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection ToolWindowContainer .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection ToolWindowContainer .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection ToolWindowContainer .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection ToolWindowContainer .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection ToolWindowContainer .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainerCollection Constructor

Initializes a new instance of the ToolWindowContainerCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection()
Public Sub New
See Also

Reference

ToolWindowContainerCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainerCollection Properties

The ToolWindowContainerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection ToolWindowContainer .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection ToolWindowContainer .)
Top
See Also

Reference

ToolWindowContainerCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainerCollection Methods

The ToolWindowContainerCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection ToolWindowContainer .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection ToolWindowContainer .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection ToolWindowContainer .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection ToolWindowContainer .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection ToolWindowContainer .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection ToolWindowContainer .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection ToolWindowContainer .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

ToolWindowContainerCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


ToolWindowContainerCollection Events

The ToolWindowContainerCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection ToolWindowContainer .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection ToolWindowContainer .)
Top
See Also

Reference

ToolWindowContainerCollection Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl Class

Represents a ContentControl that renders like a normal native Window but can be used in other non-top-level contexts.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.DockingWindowControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesFloatingWindowControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesStandardMdiWindowControl

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WindowControl : ContentControl
Public Class WindowControl
    Inherits ContentControl

The WindowControl type exposes the following members.

Constructors
 | Name | Description
Public method | WindowControl | Initializes an instance of the WindowControl class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the window can close.
Public property | CloseCommand | Gets the ICommand that can close the window.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title.
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent.
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent.
Public property | CornerRadius | Gets or sets the CornerRadius of the window.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropShadowColor | Gets or sets the base Color to use for drawing the drop-shadow.
Public property | DropShadowZOffset | Gets or sets the z-offset of the drop shadow.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button.
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasDropShadow | Gets or sets whether the window has a drop shadow.
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon.
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button.
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button.
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button.
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon.
Public property | IsActive | Gets whether the window is currently active.
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible.
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible.
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized.
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible.
Public property | IsMoving | Gets whether the window is currently being dragged to move its location.
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only.
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size.
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTitleBarTextShadowEnabled | Gets or sets whether the title bar text should draw using a shadow.
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container.
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window.
Public property | MinimizeCommand | Gets the ICommand that can minimize the window.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize.
Public property | RestoreCommand | Gets the ICommand that can restore the window.
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window.
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title.
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window.
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it.
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window.
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnActivated | Called when the window gains focus within.
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClosed | Called when the window is about to close.
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure.
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDeactivated | Called when the window loses focus within.
Protected method | OnDragMoved | Called after the window has been moved from a drag.
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag.
Protected method | OnDragResized | Called after the window has been resized from a drag.
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize.
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnLocationChanged | Called when the window is moved.
Protected method | OnLostKeyboardFocus | Occurs when a control within this control's hierarchy loses keyboard focus. (Overrides UIElementOnLostKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened.
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action.
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | Show | Shows the window.
Public method | ToggleWindowState | Toggles the window's state based on its current state.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the window gains focus within.
Public event | Closed | Occurs when the window is about to close.
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure.
Public event | Deactivated | Occurs when the window loses focus within.
Public event | DragMoved | Occurs after the window has been moved from a drag.
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag.
Public event | DragResized | Occurs after the window has been resized from a drag.
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize.
Public event | LocationChanged | Occurs when the window is moved.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | Opened | Occurs when the window is opened.
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | StateChanged | Occurs after the window's WindowState property has changed.
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action.
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu.
Top
Fields
Name | Description
ActivatedEvent | Identifies the Activated routed event. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
ClosedEvent | Identifies the Closed routed event. This field is read-only.
ClosingEvent | Identifies the Closing routed event. This field is read-only.
ContextContentProperty | Identifies the ContextContent dependency property. This field is read-only.
ContextContentTemplateProperty | Identifies the ContextContentTemplate dependency property. This field is read-only.
ContextContentTemplateSelectorProperty | Identifies the ContextContentTemplateSelector dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
DeactivatedEvent | Identifies the Deactivated routed event. This field is read-only.
DragMovedEvent | Identifies the DragMoved routed event. This field is read-only.
DragMovingEvent | Identifies the DragMoving routed event. This field is read-only.
DragResizedEvent | Identifies the DragResized routed event. This field is read-only.
DragResizingEvent | Identifies the DragResizing routed event. This field is read-only.
DropShadowColorProperty | Identifies the DropShadowColor dependency property. This field is read-only.
DropShadowZOffsetProperty | Identifies the DropShadowZOffset dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
HasIconProperty | Identifies the HasIcon dependency property. This field is read-only.
HasMaximizeButtonProperty | Identifies the HasMaximizeButton dependency property. This field is read-only.
HasMinimizeButtonProperty | Identifies the HasMinimizeButton dependency property. This field is read-only.
HasRestoreButtonProperty | Identifies the HasRestoreButton dependency property. This field is read-only.
HasTitleBarProperty | Identifies the HasTitleBar dependency property. This field is read-only.
IconProperty | Identifies the Icon dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMaximizedFrameVisibleProperty | Identifies the IsMaximizedFrameVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsMovingProperty | Identifies the IsMoving dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsResizingProperty | Identifies the IsResizing dependency property. This field is read-only.
IsRestoreButtonVisibleProperty | Identifies the IsRestoreButtonVisible dependency property. This field is read-only.
IsTitleBarTextShadowEnabledProperty | Identifies the IsTitleBarTextShadowEnabled dependency property. This field is read-only.
LeftProperty | Identifies the Left dependency property. This field is read-only.
LocationChangedEvent | Identifies the LocationChanged routed event. This field is read-only.
OpenedEvent | Identifies the Opened routed event. This field is read-only.
ReadOnlyContextContentTemplateProperty | Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.
ResizeModeProperty | Identifies the ResizeMode dependency property. This field is read-only.
RestoredBoundsProperty | Identifies the RestoredBounds dependency property. This field is read-only.
StateChangedEvent | Identifies the StateChanged routed event. This field is read-only.
TitleBarDoubleTappedEvent | Identifies the TitleBarDoubleTapped routed event. This field is read-only.
TitleBarFontWeightProperty | Identifies the TitleBarFontWeight dependency property. This field is read-only.
TitleBarMenuOpeningEvent | Identifies the TitleBarMenuOpening routed event. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TopProperty | Identifies the Top dependency property. This field is read-only.
WindowStateProperty | Identifies the WindowState dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl Constructor

Initializes an instance of the WindowControl class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WindowControl()
Public Sub New
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl Properties

The WindowControl type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the window can close.
Public property | CloseCommand | Gets the ICommand that can close the window.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title.
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent.
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent.
Public property | CornerRadius | Gets or sets the CornerRadius of the window.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropShadowColor | Gets or sets the base Color to use for drawing the drop-shadow.
Public property | DropShadowZOffset | Gets or sets the z-offset of the drop shadow.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button.
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasDropShadow | Gets or sets whether the window has a drop shadow.
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon.
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button.
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button.
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button.
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon.
Public property | IsActive | Gets whether the window is currently active.
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible.
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible.
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized.
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible.
Public property | IsMoving | Gets whether the window is currently being dragged to move its location.
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only.
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size.
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTitleBarTextShadowEnabled | Gets or sets whether the title bar text should draw using a shadow.
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container.
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window.
Public property | MinimizeCommand | Gets the ICommand that can minimize the window.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize.
Public property | RestoreCommand | Gets the ICommand that can restore the window.
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window.
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title.
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window.
Top
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.CanClose Property

WindowControlCanClose Property

Gets or sets whether the window can close.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanClose { get; set; }
Public Property CanClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window can close; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.CloseCommand Property

WindowControlCloseCommand Property

Gets the ICommand that can close the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CloseCommand { get; }
Public ReadOnly Property CloseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close the window.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ContextContent Property

WindowControlContextContent Property

Gets or sets the context content that is displayed on the title bar next to the title.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ContextContent { get; set; }
Public Property ContextContent As Object
    Get
    Set

Property Value

Type: Object
The context content that is displayed on the title bar next to the title. The default value is .
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ContextContentTemplate Property

WindowControlContextContentTemplate Property

Gets or sets the DataTemplate to use for the ContextContent.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ContextContentTemplate { get; set; }
Public Property ContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the ContextContent. The default value is .
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ContextContentTemplateSelector Property

WindowControlContextContentTemplateSelector Property

Gets or sets the DataTemplateSelector to use for the ContextContent.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector ContextContentTemplateSelector { get; set; }
Public Property ContextContentTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for the ContextContent. The default value is .
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.CornerRadius Property

WindowControlCornerRadius Property

Gets or sets the CornerRadius of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The CornerRadius of the window. The default value is 0.0.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DropShadowColor Property

WindowControlDropShadowColor Property

Gets or sets the base Color to use for drawing the drop-shadow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color DropShadowColor { get; set; }
Public Property DropShadowColor As Color
    Get
    Set

Property Value

Type: Color
The base Color to use for drawing the drop-shadow. The default value is #10000000.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DropShadowZOffset Property

WindowControlDropShadowZOffset Property

Gets or sets the z-offset of the drop shadow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DropShadowZOffset { get; set; }
Public Property DropShadowZOffset As Double
    Get
    Set

Property Value

Type: Double
The z-offset of the drop shadow. The default value is 16.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasCloseButton Property

WindowControlHasCloseButton Property

Gets or sets whether the window is capable of displaying a close button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasCloseButton { get; set; }
Public Property HasCloseButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a close button; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasDropShadow Property

WindowControlHasDropShadow Property

Gets or sets whether the window has a drop shadow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDropShadow { get; set; }
Public Property HasDropShadow As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window has a drop shadow; otherwise, false. The default value is false.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasIcon Property

WindowControlHasIcon Property

Gets or sets whether the window is capable of displaying an icon.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasIcon { get; set; }
Public Property HasIcon As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying an icon; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasMaximizeButton Property

WindowControlHasMaximizeButton Property

Gets or sets whether the window is capable of displaying a maximize button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMaximizeButton { get; set; }
Public Property HasMaximizeButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a maximize button; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasMinimizeButton Property

WindowControlHasMinimizeButton Property

Gets or sets whether the window is capable of displaying a minimize button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMinimizeButton { get; set; }
Public Property HasMinimizeButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a minimize button; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasRestoreButton Property

WindowControlHasRestoreButton Property

Gets or sets whether the window is capable of displaying a restore button.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasRestoreButton { get; set; }
Public Property HasRestoreButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a restore button; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasTitleBar Property

WindowControlHasTitleBar Property

Gets or sets whether the window is capable of displaying a title bar.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTitleBar { get; set; }
Public Property HasTitleBar As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a title bar; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Icon Property

WindowControlIcon Property

Gets or sets the ImageSource displayed as the window icon.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource Icon { get; set; }
Public Property Icon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The ImageSource displayed as the window icon. The default value is .
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsActive Property

WindowControlIsActive Property

Gets whether the window is currently active.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsActive { get; protected set; }
Public Property IsActive As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window is currently active; otherwise, false.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsCloseButtonVisible Property

WindowControlIsCloseButtonVisible Property

Gets whether the window's close button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCloseButtonVisible { get; }
Public ReadOnly Property IsCloseButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the window's close button is visible; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsMaximizeButtonVisible Property

WindowControlIsMaximizeButtonVisible Property

Gets whether the window's maximize button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMaximizeButtonVisible { get; }
Public ReadOnly Property IsMaximizeButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the window's maximize button is visible; otherwise, false. The default value is false.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsMaximizedFrameVisible Property

WindowControlIsMaximizedFrameVisible Property

Gets or sets whether the frame should be displayed when the window is maximized.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMaximizedFrameVisible { get; set; }
Public Property IsMaximizedFrameVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the frame should be displayed when the window is maximized; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsMinimizeButtonVisible Property

WindowControlIsMinimizeButtonVisible Property

Gets whether the window's minimize button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMinimizeButtonVisible { get; }
Public ReadOnly Property IsMinimizeButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the window's minimize button is visible; otherwise, false. The default value is false.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsMoving Property

WindowControlIsMoving Property

Gets whether the window is currently being dragged to move its location.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMoving { get; }
Public ReadOnly Property IsMoving As Boolean
    Get

Property Value

Type: Boolean
true if the window is currently being dragged to move its location; otherwise, false.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsReadOnly Property

WindowControlIsReadOnly Property

Gets or sets whether the windows's contents are read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the windows's contents are read-only; otherwise, false. The default value is false.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsResizing Property

WindowControlIsResizing Property

Gets whether the window is currently being dragged to alter its size.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsResizing { get; }
Public ReadOnly Property IsResizing As Boolean
    Get

Property Value

Type: Boolean
true if the window is currently being dragged to alter its size; otherwise, false.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsRestoreButtonVisible Property

WindowControlIsRestoreButtonVisible Property

Gets whether the window's restore button is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsRestoreButtonVisible { get; }
Public ReadOnly Property IsRestoreButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the window's restore button is visible; otherwise, false. The default value is false.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsTitleBarTextShadowEnabled Property

WindowControlIsTitleBarTextShadowEnabled Property

Gets or sets whether the title bar text should draw using a shadow.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTitleBarTextShadowEnabled { get; set; }
Public Property IsTitleBarTextShadowEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the title bar text should draw using a shadow; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Left Property

WindowControlLeft Property

Gets or sets the position of the window's left edge, in relation to its container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Left { get; set; }
Public Property Left As Double
    Get
    Set

Property Value

Type: Double
The position of the window's left edge, in relation to its container.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.MaximizeCommand Property

WindowControlMaximizeCommand Property

Gets the ICommand that can maximize the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MaximizeCommand { get; }
Public ReadOnly Property MaximizeCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can maximize the window.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.MinimizeCommand Property

WindowControlMinimizeCommand Property

Gets the ICommand that can minimize the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand MinimizeCommand { get; }
Public ReadOnly Property MinimizeCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can minimize the window.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ReadOnlyContextContentTemplate Property

WindowControlReadOnlyContextContentTemplate Property

Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ReadOnlyContextContentTemplate { get; set; }
Public Property ReadOnlyContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ResizeMode Property

WindowControlResizeMode Property

Gets or sets a ResizeMode indicating how the window is able to resize.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ResizeMode ResizeMode { get; set; }
Public Property ResizeMode As ResizeMode
    Get
    Set

Property Value

Type: ResizeMode
A ResizeMode indicating how the window is able to resize. The default value is CanResize.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.RestoreCommand Property

WindowControlRestoreCommand Property

Gets the ICommand that can restore the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand RestoreCommand { get; }
Public ReadOnly Property RestoreCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can restore the window.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.RestoredBounds Property

WindowControlRestoredBounds Property

Gets or sets the bounds of this window when in a 'restored' state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect RestoredBounds { get; set; }
Public Property RestoredBounds As Rect
    Get
    Set

Property Value

Type: Rect
The bounds of this window when in a 'restored' state.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Title Property

WindowControlTitle Property

Gets or sets the title of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title of the window.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.TitleBarFontWeight Property

WindowControlTitleBarFontWeight Property

Gets or sets the FontWeight of the title.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontWeight TitleBarFontWeight { get; set; }
Public Property TitleBarFontWeight As FontWeight
    Get
    Set

Property Value

Type: FontWeight
The FontWeight of the title. The default value is Normal.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Top Property

WindowControlTop Property

Gets or sets the position of the window's top edge, in relation to its container.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Top { get; set; }
Public Property Top As Double
    Get
    Set

Property Value

Type: Double
The position of the window's top edge, in relation to its container.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.WindowState Property

WindowControlWindowState Property

Gets or sets a WindowState indicating the current state of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WindowState WindowState { get; set; }
Public Property WindowState As WindowState
    Get
    Set

Property Value

Type: WindowState
A WindowState indicating the current state of the window. The default value is Normal.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl Methods

The WindowControl type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it.
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window.
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnActivated | Called when the window gains focus within.
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClosed | Called when the window is about to close.
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure.
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDeactivated | Called when the window loses focus within.
Protected method | OnDragMoved | Called after the window has been moved from a drag.
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag.
Protected method | OnDragResized | Called after the window has been resized from a drag.
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize.
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnLocationChanged | Called when the window is moved.
Protected method | OnLostKeyboardFocus | Occurs when a control within this control's hierarchy loses keyboard focus. (Overrides UIElementOnLostKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened.
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action.
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | Show | Shows the window.
Public method | ToggleWindowState | Toggles the window's state based on its current state.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Activate Method

WindowControlActivate Method

Attempts to bring the window to the foreground and activates it.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool Activate()
Public Overridable Function Activate As Boolean

Return Value

Type: Boolean
true if the window was successfully activated; otherwise, false.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Close Method

WindowControlClose Method

Closes the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DragMove Method

WindowControlDragMove Method

Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void DragMove(
    InputPointerButtonEventArgs e
)
Public Sub DragMove (
    e As InputPointerButtonEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.InputInputPointerButtonEventArgs
The InputPointerButtonEventArgs that can wrap a platform-specific input event args instance.
Remarks
The primary button of the pointer in the event arguments must be pressed down when calling this method. The pointer will be captured.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.GetAdjustedBounds Method

WindowControlGetAdjustedBounds Method

Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Rect GetAdjustedBounds(
    Rect bounds,
    ResizeOperation resizeOperation
)
Public Overridable Function GetAdjustedBounds (
    bounds As Rect,
    resizeOperation As ResizeOperation
) As Rect

Parameters

bounds
Type: System.WindowsRect
The bounds to examine.
resizeOperation
Type: ActiproSoftware.Windows.ControlsResizeOperation
The active resize operation.

Return Value

Type: Rect
The adjusted bounds.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HitTestResizeOperation Method

WindowControlHitTestResizeOperation Method

Hit tests the specified Point to see if it might cause a resize operation.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ResizeOperation HitTestResizeOperation(
    Point point
)
Public Function HitTestResizeOperation (
    point As Point
) As ResizeOperation

Parameters

point
Type: System.WindowsPoint
The Point, in control coordinates, to hit test.

Return Value

Type: ResizeOperation
The resize operation that can be caused by dragging at the Point.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnActivated Method

WindowControlOnActivated Method

Called when the window gains focus within.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnActivated(
    RoutedEventArgs e
)
Protected Overridable Sub OnActivated (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnApplyTemplate Method

WindowControlOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnClosed Method

WindowControlOnClosed Method

Called when the window is about to close.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnClosed(
    RoutedEventArgs e
)
Protected Overridable Sub OnClosed (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnClosing Method

WindowControlOnClosing Method

Called directly after Close is called, and can be handled to cancel window closure.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnClosing(
    CancelRoutedEventArgs e
)
Protected Overridable Sub OnClosing (
    e As CancelRoutedEventArgs
)

Parameters

e
Type: ActiproSoftware.WindowsCancelRoutedEventArgs
A CancelRoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnCreateAutomationPeer Method

WindowControlOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnDeactivated Method

WindowControlOnDeactivated Method

Called when the window loses focus within.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDeactivated(
    RoutedEventArgs e
)
Protected Overridable Sub OnDeactivated (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnDragMoved Method

WindowControlOnDragMoved Method

Called after the window has been moved from a drag.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDragMoved(
    RoutedEventArgs e
)
Protected Overridable Sub OnDragMoved (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnDragMoving Method

WindowControlOnDragMoving Method

Called before the window is moved from a drag, and can be handled to cancel the drag.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDragMoving(
    CancelRoutedEventArgs e
)
Protected Overridable Sub OnDragMoving (
    e As CancelRoutedEventArgs
)

Parameters

e
Type: ActiproSoftware.WindowsCancelRoutedEventArgs
A CancelRoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnDragResized Method

WindowControlOnDragResized Method

Called after the window has been resized from a drag.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDragResized(
    RoutedEventArgs e
)
Protected Overridable Sub OnDragResized (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnDragResizing Method

WindowControlOnDragResizing Method

Called before the window is resized from a drag, and can be handled to cancel the resize.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDragResizing(
    CancelRoutedEventArgs e
)
Protected Overridable Sub OnDragResizing (
    e As CancelRoutedEventArgs
)

Parameters

e
Type: ActiproSoftware.WindowsCancelRoutedEventArgs
A CancelRoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnGotKeyboardFocus Method

WindowControlOnGotKeyboardFocus Method

Occurs when a control within this control's hierarchy gains keyboard focus.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
Protected Overrides Sub OnGotKeyboardFocus (
    e As KeyboardFocusChangedEventArgs
)

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
The KeyboardFocusChangedEventArgs that contains data related to this event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnLocationChanged Method

WindowControlOnLocationChanged Method

Called when the window is moved.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnLocationChanged(
    RoutedEventArgs e
)
Protected Overridable Sub OnLocationChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnLostKeyboardFocus Method

WindowControlOnLostKeyboardFocus Method

Occurs when a control within this control's hierarchy loses keyboard focus.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
Protected Overrides Sub OnLostKeyboardFocus (
    e As KeyboardFocusChangedEventArgs
)

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
The KeyboardFocusChangedEventArgs that contains data related to this event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnOpened Method

WindowControlOnOpened Method

Called when the window is opened.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnOpened(
    RoutedEventArgs e
)
Protected Overridable Sub OnOpened (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnStateChanged Method

WindowControlOnStateChanged Method

Called after the window's WindowState property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnStateChanged(
    RoutedEventArgs e
)
Protected Overridable Sub OnStateChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnTitleBarDoubleTapped Method

WindowControlOnTitleBarDoubleTapped Method

Called when the title-bar is double-tapped, and can be handled to cancel the default action.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnTitleBarDoubleTapped(
    CancelRoutedEventArgs e
)
Protected Overridable Sub OnTitleBarDoubleTapped (
    e As CancelRoutedEventArgs
)

Parameters

e
Type: ActiproSoftware.WindowsCancelRoutedEventArgs
A CancelRoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OnTitleBarMenuOpening Method

WindowControlOnTitleBarMenuOpening Method

Called when the title-bar should display a context menu.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnTitleBarMenuOpening(
    DockingMenuEventArgs e
)
Protected Overridable Sub OnTitleBarMenuOpening (
    e As DockingMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingMenuEventArgs
A DockingMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Show Method

WindowControlShow Method

Shows the window.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Show()
Public Sub Show
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ToggleWindowState Method

WindowControlToggleWindowState Method

Toggles the window's state based on its current state.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ToggleWindowState()
Public Sub ToggleWindowState
Remarks
This method is generally called when the title bar is double-tapped.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl Events

The WindowControl type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the window gains focus within.
Public event | Closed | Occurs when the window is about to close.
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure.
Public event | Deactivated | Occurs when the window loses focus within.
Public event | DragMoved | Occurs after the window has been moved from a drag.
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag.
Public event | DragResized | Occurs after the window has been resized from a drag.
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize.
Public event | LocationChanged | Occurs when the window is moved.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | Opened | Occurs when the window is opened.
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | StateChanged | Occurs after the window's WindowState property has changed.
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action.
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu.
Top
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Activated Event

WindowControlActivated Event

Occurs when the window gains focus within.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Activated
Public Event Activated As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Closed Event

WindowControlClosed Event

Occurs when the window is about to close.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Closed
Public Event Closed As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Closing Event

WindowControlClosing Event

Occurs directly after Close is called, and can be handled to cancel window closure.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CancelRoutedEventArgs> Closing
Public Event Closing As EventHandler(Of CancelRoutedEventArgs)

Value

Type: SystemEventHandler CancelRoutedEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Deactivated Event

WindowControlDeactivated Event

Occurs when the window loses focus within.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Deactivated
Public Event Deactivated As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DragMoved Event

WindowControlDragMoved Event

Occurs after the window has been moved from a drag.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler DragMoved
Public Event DragMoved As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DragMoving Event

WindowControlDragMoving Event

Occurs before the window is moved from a drag, and can be handled to cancel the drag.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CancelRoutedEventArgs> DragMoving
Public Event DragMoving As EventHandler(Of CancelRoutedEventArgs)

Value

Type: SystemEventHandler CancelRoutedEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DragResized Event

WindowControlDragResized Event

Occurs after the window has been resized from a drag.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler DragResized
Public Event DragResized As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DragResizing Event

WindowControlDragResizing Event

Occurs before the window is resized from a drag, and can be handled to cancel the resize.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CancelRoutedEventArgs> DragResizing
Public Event DragResizing As EventHandler(Of CancelRoutedEventArgs)

Value

Type: SystemEventHandler CancelRoutedEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.LocationChanged Event

WindowControlLocationChanged Event

Occurs when the window is moved.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler LocationChanged
Public Event LocationChanged As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.Opened Event

WindowControlOpened Event

Occurs when the window is opened.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Opened
Public Event Opened As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.StateChanged Event

WindowControlStateChanged Event

Occurs after the window's WindowState property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler StateChanged
Public Event StateChanged As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.TitleBarDoubleTapped Event

WindowControlTitleBarDoubleTapped Event

Occurs when the title-bar is double-tapped, and can be handled to cancel the default action.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<CancelRoutedEventArgs> TitleBarDoubleTapped
Public Event TitleBarDoubleTapped As EventHandler(Of CancelRoutedEventArgs)

Value

Type: SystemEventHandler CancelRoutedEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.TitleBarMenuOpening Event

WindowControlTitleBarMenuOpening Event

Occurs when the title-bar should display a context menu.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingMenuEventArgs> TitleBarMenuOpening
Public Event TitleBarMenuOpening As EventHandler(Of DockingMenuEventArgs)

Value

Type: SystemEventHandler DockingMenuEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl Fields

The WindowControl type exposes the following members.

Fields
Name | Description
ActivatedEvent | Identifies the Activated routed event. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
ClosedEvent | Identifies the Closed routed event. This field is read-only.
ClosingEvent | Identifies the Closing routed event. This field is read-only.
ContextContentProperty | Identifies the ContextContent dependency property. This field is read-only.
ContextContentTemplateProperty | Identifies the ContextContentTemplate dependency property. This field is read-only.
ContextContentTemplateSelectorProperty | Identifies the ContextContentTemplateSelector dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
DeactivatedEvent | Identifies the Deactivated routed event. This field is read-only.
DragMovedEvent | Identifies the DragMoved routed event. This field is read-only.
DragMovingEvent | Identifies the DragMoving routed event. This field is read-only.
DragResizedEvent | Identifies the DragResized routed event. This field is read-only.
DragResizingEvent | Identifies the DragResizing routed event. This field is read-only.
DropShadowColorProperty | Identifies the DropShadowColor dependency property. This field is read-only.
DropShadowZOffsetProperty | Identifies the DropShadowZOffset dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
HasIconProperty | Identifies the HasIcon dependency property. This field is read-only.
HasMaximizeButtonProperty | Identifies the HasMaximizeButton dependency property. This field is read-only.
HasMinimizeButtonProperty | Identifies the HasMinimizeButton dependency property. This field is read-only.
HasRestoreButtonProperty | Identifies the HasRestoreButton dependency property. This field is read-only.
HasTitleBarProperty | Identifies the HasTitleBar dependency property. This field is read-only.
IconProperty | Identifies the Icon dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMaximizedFrameVisibleProperty | Identifies the IsMaximizedFrameVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsMovingProperty | Identifies the IsMoving dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsResizingProperty | Identifies the IsResizing dependency property. This field is read-only.
IsRestoreButtonVisibleProperty | Identifies the IsRestoreButtonVisible dependency property. This field is read-only.
IsTitleBarTextShadowEnabledProperty | Identifies the IsTitleBarTextShadowEnabled dependency property. This field is read-only.
LeftProperty | Identifies the Left dependency property. This field is read-only.
LocationChangedEvent | Identifies the LocationChanged routed event. This field is read-only.
OpenedEvent | Identifies the Opened routed event. This field is read-only.
ReadOnlyContextContentTemplateProperty | Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.
ResizeModeProperty | Identifies the ResizeMode dependency property. This field is read-only.
RestoredBoundsProperty | Identifies the RestoredBounds dependency property. This field is read-only.
StateChangedEvent | Identifies the StateChanged routed event. This field is read-only.
TitleBarDoubleTappedEvent | Identifies the TitleBarDoubleTapped routed event. This field is read-only.
TitleBarFontWeightProperty | Identifies the TitleBarFontWeight dependency property. This field is read-only.
TitleBarMenuOpeningEvent | Identifies the TitleBarMenuOpening routed event. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TopProperty | Identifies the Top dependency property. This field is read-only.
WindowStateProperty | Identifies the WindowState dependency property. This field is read-only.
Top
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ActivatedEvent Field

WindowControlActivatedEvent Field

Identifies the Activated routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ActivatedEvent
Public Shared ReadOnly ActivatedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Activated routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.CanCloseProperty Field

WindowControlCanCloseProperty Field

Identifies the CanClose dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCloseProperty
Public Shared ReadOnly CanCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanClose dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ClosedEvent Field

WindowControlClosedEvent Field

Identifies the Closed routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ClosedEvent
Public Shared ReadOnly ClosedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Closed routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ClosingEvent Field

WindowControlClosingEvent Field

Identifies the Closing routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ClosingEvent
Public Shared ReadOnly ClosingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Closing routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ContextContentProperty Field

WindowControlContextContentProperty Field

Identifies the ContextContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentProperty
Public Shared ReadOnly ContextContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContent dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ContextContentTemplateProperty Field

WindowControlContextContentTemplateProperty Field

Identifies the ContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentTemplateProperty
Public Shared ReadOnly ContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContentTemplate dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ContextContentTemplateSelectorProperty Field

WindowControlContextContentTemplateSelectorProperty Field

Identifies the ContextContentTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentTemplateSelectorProperty
Public Shared ReadOnly ContextContentTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContentTemplateSelector dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.CornerRadiusProperty Field

WindowControlCornerRadiusProperty Field

Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DeactivatedEvent Field

WindowControlDeactivatedEvent Field

Identifies the Deactivated routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent DeactivatedEvent
Public Shared ReadOnly DeactivatedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Deactivated routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DragMovedEvent Field

WindowControlDragMovedEvent Field

Identifies the DragMoved routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent DragMovedEvent
Public Shared ReadOnly DragMovedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the DragMoved routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DragMovingEvent Field

WindowControlDragMovingEvent Field

Identifies the DragMoving routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent DragMovingEvent
Public Shared ReadOnly DragMovingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the DragMoving routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DragResizedEvent Field

WindowControlDragResizedEvent Field

Identifies the DragResized routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent DragResizedEvent
Public Shared ReadOnly DragResizedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the DragResized routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DragResizingEvent Field

WindowControlDragResizingEvent Field

Identifies the DragResizing routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent DragResizingEvent
Public Shared ReadOnly DragResizingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the DragResizing routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DropShadowColorProperty Field

WindowControlDropShadowColorProperty Field

Identifies the DropShadowColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DropShadowColorProperty
Public Shared ReadOnly DropShadowColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DropShadowColor dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.DropShadowZOffsetProperty Field

WindowControlDropShadowZOffsetProperty Field

Identifies the DropShadowZOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DropShadowZOffsetProperty
Public Shared ReadOnly DropShadowZOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DropShadowZOffset dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasCloseButtonProperty Field

WindowControlHasCloseButtonProperty Field

Identifies the HasCloseButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasCloseButtonProperty
Public Shared ReadOnly HasCloseButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasCloseButton dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasDropShadowProperty Field

WindowControlHasDropShadowProperty Field

Identifies the HasDropShadow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasDropShadowProperty
Public Shared ReadOnly HasDropShadowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasDropShadow dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasIconProperty Field

WindowControlHasIconProperty Field

Identifies the HasIcon dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasIconProperty
Public Shared ReadOnly HasIconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasIcon dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasMaximizeButtonProperty Field

WindowControlHasMaximizeButtonProperty Field

Identifies the HasMaximizeButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasMaximizeButtonProperty
Public Shared ReadOnly HasMaximizeButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasMaximizeButton dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasMinimizeButtonProperty Field

WindowControlHasMinimizeButtonProperty Field

Identifies the HasMinimizeButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasMinimizeButtonProperty
Public Shared ReadOnly HasMinimizeButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasMinimizeButton dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasRestoreButtonProperty Field

WindowControlHasRestoreButtonProperty Field

Identifies the HasRestoreButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasRestoreButtonProperty
Public Shared ReadOnly HasRestoreButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasRestoreButton dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.HasTitleBarProperty Field

WindowControlHasTitleBarProperty Field

Identifies the HasTitleBar dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTitleBarProperty
Public Shared ReadOnly HasTitleBarProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTitleBar dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IconProperty Field

WindowControlIconProperty Field

Identifies the Icon dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IconProperty
Public Shared ReadOnly IconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Icon dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsActiveProperty Field

WindowControlIsActiveProperty Field

Identifies the IsActive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsActiveProperty
Public Shared ReadOnly IsActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsActive dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsCloseButtonVisibleProperty Field

WindowControlIsCloseButtonVisibleProperty Field

Identifies the IsCloseButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCloseButtonVisibleProperty
Public Shared ReadOnly IsCloseButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCloseButtonVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsMaximizeButtonVisibleProperty Field

WindowControlIsMaximizeButtonVisibleProperty Field

Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMaximizeButtonVisibleProperty
Public Shared ReadOnly IsMaximizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMaximizeButtonVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsMaximizedFrameVisibleProperty Field

WindowControlIsMaximizedFrameVisibleProperty Field

Identifies the IsMaximizedFrameVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMaximizedFrameVisibleProperty
Public Shared ReadOnly IsMaximizedFrameVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMaximizedFrameVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsMinimizeButtonVisibleProperty Field

WindowControlIsMinimizeButtonVisibleProperty Field

Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMinimizeButtonVisibleProperty
Public Shared ReadOnly IsMinimizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMinimizeButtonVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsMovingProperty Field

WindowControlIsMovingProperty Field

Identifies the IsMoving dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMovingProperty
Public Shared ReadOnly IsMovingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMoving dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsReadOnlyProperty Field

WindowControlIsReadOnlyProperty Field

Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsResizingProperty Field

WindowControlIsResizingProperty Field

Identifies the IsResizing dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizingProperty
Public Shared ReadOnly IsResizingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizing dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsRestoreButtonVisibleProperty Field

WindowControlIsRestoreButtonVisibleProperty Field

Identifies the IsRestoreButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRestoreButtonVisibleProperty
Public Shared ReadOnly IsRestoreButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRestoreButtonVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.IsTitleBarTextShadowEnabledProperty Field

WindowControlIsTitleBarTextShadowEnabledProperty Field

Identifies the IsTitleBarTextShadowEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTitleBarTextShadowEnabledProperty
Public Shared ReadOnly IsTitleBarTextShadowEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTitleBarTextShadowEnabled dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.LeftProperty Field

WindowControlLeftProperty Field

Identifies the Left dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LeftProperty
Public Shared ReadOnly LeftProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Left dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.LocationChangedEvent Field

WindowControlLocationChangedEvent Field

Identifies the LocationChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent LocationChangedEvent
Public Shared ReadOnly LocationChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the LocationChanged routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.OpenedEvent Field

WindowControlOpenedEvent Field

Identifies the Opened routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent OpenedEvent
Public Shared ReadOnly OpenedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Opened routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ReadOnlyContextContentTemplateProperty Field

WindowControlReadOnlyContextContentTemplateProperty Field

Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReadOnlyContextContentTemplateProperty
Public Shared ReadOnly ReadOnlyContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReadOnlyContextContentTemplate dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.ResizeModeProperty Field

WindowControlResizeModeProperty Field

Identifies the ResizeMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResizeModeProperty
Public Shared ReadOnly ResizeModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResizeMode dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.RestoredBoundsProperty Field

WindowControlRestoredBoundsProperty Field

Identifies the RestoredBounds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RestoredBoundsProperty
Public Shared ReadOnly RestoredBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RestoredBounds dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.StateChangedEvent Field

WindowControlStateChangedEvent Field

Identifies the StateChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent StateChangedEvent
Public Shared ReadOnly StateChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the StateChanged routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.TitleBarDoubleTappedEvent Field

WindowControlTitleBarDoubleTappedEvent Field

Identifies the TitleBarDoubleTapped routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent TitleBarDoubleTappedEvent
Public Shared ReadOnly TitleBarDoubleTappedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the TitleBarDoubleTapped routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.TitleBarFontWeightProperty Field

WindowControlTitleBarFontWeightProperty Field

Identifies the TitleBarFontWeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleBarFontWeightProperty
Public Shared ReadOnly TitleBarFontWeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleBarFontWeight dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.TitleBarMenuOpeningEvent Field

WindowControlTitleBarMenuOpeningEvent Field

Identifies the TitleBarMenuOpening routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent TitleBarMenuOpeningEvent
Public Shared ReadOnly TitleBarMenuOpeningEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the TitleBarMenuOpening routed event.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.TitleProperty Field

WindowControlTitleProperty Field

Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.TopProperty Field

WindowControlTopProperty Field

Identifies the Top dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TopProperty
Public Shared ReadOnly TopProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Top dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


WindowControl.WindowStateProperty Field

WindowControlWindowStateProperty Field

Identifies the WindowState dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WindowStateProperty
Public Shared ReadOnly WindowStateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WindowState dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.Windows.Controls.Docking Namespace


Workspace Class

Represents a control that can contain a MDI host, and around which tool windows are docked.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.DockingWorkspace

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Workspace : ContentControl, IDockTarget
Public Class Workspace
    Inherits ContentControl
    Implements IDockTarget

The Workspace type exposes the following members.

Constructors
 | Name | Description
Public method | Workspace | Initializes an instance of the Workspace class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Occurs when the content changes. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking Namespace


Workspace Constructor

Initializes an instance of the Workspace class.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Workspace()
Public Sub New
See Also

Reference

Workspace Class
ActiproSoftware.Windows.Controls.Docking Namespace


Workspace Properties

The Workspace type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Workspace Class
ActiproSoftware.Windows.Controls.Docking Namespace


Workspace.DockHost Property

WorkspaceDockHost Property

Gets the DockHost that contains this control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.

Implements

IDockTargetDockHost
See Also

Reference

Workspace Class
ActiproSoftware.Windows.Controls.Docking Namespace


Workspace.DockSite Property

WorkspaceDockSite Property

Gets the DockSite that is managing this control.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this control.

Implements

IDockTargetDockSite
See Also

Reference

Workspace Class
ActiproSoftware.Windows.Controls.Docking Namespace


Workspace Methods

The Workspace type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Occurs when the content changes. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Workspace Class
ActiproSoftware.Windows.Controls.Docking Namespace


Workspace.OnContentChanged Method

WorkspaceOnContentChanged Method

Occurs when the content changes.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Protected Overrides Sub OnContentChanged (
    oldContent As Object,
    newContent As Object
)

Parameters

oldContent
Type: SystemObject
The old content.
newContent
Type: SystemObject
The new content.
See Also

Reference

Workspace Class
ActiproSoftware.Windows.Controls.Docking Namespace


Workspace.OnCreateAutomationPeer Method

WorkspaceOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

Workspace Class
ActiproSoftware.Windows.Controls.Docking Namespace


Workspace Events

The Workspace type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

Workspace Class
ActiproSoftware.Windows.Controls.Docking Namespace


ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace

Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | AdvancedTabControlAutomationPeer | Exposes AdvancedTabControl types to UI Automation.
Public class | AdvancedTabItemAutomationPeer | Exposes AdvancedTabItem types to UI Automation.
Public class | AdvancedTabItemWrapperAutomationPeer | Exposes AdvancedTabItem types to UI Automation.
Public class | DockHostAutomationPeer | Exposes DockHost types to UI Automation.
Public class | DockingWindowAutomationPeerBase | Exposes DockingWindow types to UI Automation.
Public class | DockingWindowContainerBaseAutomationPeer | Exposes DockingWindowContainerBase types to UI Automation.
Public class | DockingWindowContainerTabItemAutomationPeer | Exposes DockingWindowContainerTabItem types to UI Automation.
Public class | DockSiteAutomationPeer | Exposes DockSite types to UI Automation.
Public class | DocumentWindowAutomationPeer | Exposes DocumentWindow types to UI Automation.
Public class | SplitContainerAutomationPeer | Exposes SplitContainer types to UI Automation.
Public class | StandardMdiHostAutomationPeer | Exposes StandardMdiHost types to UI Automation.
Public class | StandardSwitcherAutomationPeer | Exposes StandardSwitcher types to UI Automation.
Public class | StandardSwitcherItemAutomationPeer | Exposes StandardSwitcherItem types to UI Automation.
Public class | TabbedMdiContainerAutomationPeer | Exposes TabbedMdiContainer types to UI Automation.
Public class | ToolWindowAutomationPeer | Exposes ToolWindow types to UI Automation.
Public class | ToolWindowContainerAutomationPeer | Exposes ToolWindowContainer types to UI Automation.
Public class | WindowControlAutomationPeer | Exposes WindowControl types to UI Automation.
Public class | WorkspaceAutomationPeer | Exposes Workspace types to UI Automation.


AdvancedTabControlAutomationPeer Class

Exposes AdvancedTabControl types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
System.Windows.Automation.PeersItemsControlAutomationPeer
System.Windows.Automation.PeersSelectorAutomationPeer
System.Windows.Automation.PeersTabControlAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersAdvancedTabControlAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTabControlAutomationPeer : TabControlAutomationPeer
Public Class AdvancedTabControlAutomationPeer
    Inherits TabControlAutomationPeer

The AdvancedTabControlAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabControlAutomationPeer | Initializes a new instance of the AdvancedTabControlAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateItemAutomationPeer | Creates an ItemAutomationPeer for a data item. (Overrides TabControlAutomationPeerCreateItemAutomationPeer(Object).)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the collection of child elements for the TabItem that is associated with the new TabItemAutomationPeer. This method is called by GetChildren. (Inherited from TabControlAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides FrameworkElementAutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the ItemsControl that is associated with this ItemsControlAutomationPeer. This method is called by GetChildren. (Inherited from ItemsControlAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the TabItem that is associated with the new TabItemAutomationPeer. This method is called by GetClassName. (Inherited from TabControlAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | This method is called by GetClickablePoint. (Inherited from TabControlAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the Selector that is associated with this SelectorAutomationPeer. (Inherited from SelectorAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabControlAutomationPeer Constructor

Initializes a new instance of the AdvancedTabControlAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabControlAutomationPeer(
    AdvancedTabControl owner
)
Public Sub New (
    owner As AdvancedTabControl
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingAdvancedTabControl
The owner element.
See Also

Reference

AdvancedTabControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabControlAutomationPeer Properties

The AdvancedTabControlAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

AdvancedTabControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabControlAutomationPeer Methods

The AdvancedTabControlAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateItemAutomationPeer | Creates an ItemAutomationPeer for a data item. (Overrides TabControlAutomationPeerCreateItemAutomationPeer(Object).)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the collection of child elements for the TabItem that is associated with the new TabItemAutomationPeer. This method is called by GetChildren. (Inherited from TabControlAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides FrameworkElementAutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the ItemsControl that is associated with this ItemsControlAutomationPeer. This method is called by GetChildren. (Inherited from ItemsControlAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the TabItem that is associated with the new TabItemAutomationPeer. This method is called by GetClassName. (Inherited from TabControlAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | This method is called by GetClickablePoint. (Inherited from TabControlAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the Selector that is associated with this SelectorAutomationPeer. (Inherited from SelectorAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AdvancedTabControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabControlAutomationPeer.CreateItemAutomationPeer Method

AdvancedTabControlAutomationPeerCreateItemAutomationPeer Method

Creates an ItemAutomationPeer for a data item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override ItemAutomationPeer CreateItemAutomationPeer(
    Object item
)
Protected Overrides Function CreateItemAutomationPeer (
    item As Object
) As ItemAutomationPeer

Parameters

item
Type: SystemObject
The data item.

Return Value

Type: ItemAutomationPeer
The ItemAutomationPeer that was created.
See Also

Reference

AdvancedTabControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabControlAutomationPeer.GetAutomationIdCore Method

AdvancedTabControlAutomationPeerGetAutomationIdCore Method

Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetAutomationIdCore()
Protected Overrides Function GetAutomationIdCore As String

Return Value

Type: String
The string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.
See Also

Reference

AdvancedTabControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemAutomationPeer Class

Exposes AdvancedTabItem types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersItemAutomationPeer
System.Windows.Automation.PeersSelectorItemAutomationPeer
System.Windows.Automation.PeersTabItemAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersAdvancedTabItemAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTabItemAutomationPeer : TabItemAutomationPeer
Public Class AdvancedTabItemAutomationPeer
    Inherits TabItemAutomationPeer

The AdvancedTabItemAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabItemAutomationPeer | Initializes a new instance of the AdvancedTabItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the TabItem that is associated with this TabItemAutomationPeer. Called by GetAutomationControlType. (Inherited from TabItemAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the TabItem that is associated with this TabItemAutomationPeer. Called by GetChildren. (Inherited from TabItemAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the TabItem that is associated with this TabItemAutomationPeer. Called by GetClassName. (Inherited from TabItemAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that conveys the visual status of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified UIElement represents. (Inherited from ItemAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the Label that is targeted to the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the TabItem that is associated with this TabItemAutomationPeer. Called by GetName. (Inherited from TabItemAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the specified UIElement is laid out in a particular direction. (Inherited from ItemAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from SelectorItemAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the specified UIElement currently has keyboard input focus. (Inherited from ItemAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the specified UIElement contains data that is presented to the user. (Inherited from ItemAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets a value that indicates whether the UIElement that is associated with this ItemAutomationPeer is understood by the end user as interactive. (Inherited from ItemAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the specified UIElement can receive and send events. (Inherited from ItemAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the specified UIElement can accept keyboard focus. (Inherited from ItemAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the specified UIElement is off the screen. (Inherited from ItemAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the specified UIElement contains protected content. (Inherited from ItemAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the specified UIElement is required to be completed on a form. (Inherited from ItemAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the specified UIElement. The UIElement corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemAutomationPeer Constructor

Initializes a new instance of the AdvancedTabItemAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabItemAutomationPeer(
    Object owner,
    AdvancedTabControlAutomationPeer tabControlAutomationPeer
)
Public Sub New (
    owner As Object,
    tabControlAutomationPeer As AdvancedTabControlAutomationPeer
)

Parameters

owner
Type: SystemObject
The owner element.
tabControlAutomationPeer
Type: ActiproSoftware.Windows.Controls.Docking.Automation.PeersAdvancedTabControlAutomationPeer
The items control.
See Also

Reference

AdvancedTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemAutomationPeer Properties

The AdvancedTabItemAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
See Also

Reference

AdvancedTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemAutomationPeer Methods

The AdvancedTabItemAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the TabItem that is associated with this TabItemAutomationPeer. Called by GetAutomationControlType. (Inherited from TabItemAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the TabItem that is associated with this TabItemAutomationPeer. Called by GetChildren. (Inherited from TabItemAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the TabItem that is associated with this TabItemAutomationPeer. Called by GetClassName. (Inherited from TabItemAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that conveys the visual status of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified UIElement represents. (Inherited from ItemAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the Label that is targeted to the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the TabItem that is associated with this TabItemAutomationPeer. Called by GetName. (Inherited from TabItemAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the specified UIElement is laid out in a particular direction. (Inherited from ItemAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from SelectorItemAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the specified UIElement currently has keyboard input focus. (Inherited from ItemAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the specified UIElement contains data that is presented to the user. (Inherited from ItemAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets a value that indicates whether the UIElement that is associated with this ItemAutomationPeer is understood by the end user as interactive. (Inherited from ItemAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the specified UIElement can receive and send events. (Inherited from ItemAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the specified UIElement can accept keyboard focus. (Inherited from ItemAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the specified UIElement is off the screen. (Inherited from ItemAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the specified UIElement contains protected content. (Inherited from ItemAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the specified UIElement is required to be completed on a form. (Inherited from ItemAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the specified UIElement. The UIElement corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AdvancedTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemWrapperAutomationPeer Class

Exposes AdvancedTabItem types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
System.Windows.Automation.PeersTabItemWrapperAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersAdvancedTabItemWrapperAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTabItemWrapperAutomationPeer : TabItemWrapperAutomationPeer
Public Class AdvancedTabItemWrapperAutomationPeer
    Inherits TabItemWrapperAutomationPeer

The AdvancedTabItemWrapperAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabItemWrapperAutomationPeer | Initializes a new instance of the AdvancedTabItemWrapperAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClassName. (Inherited from UIElementAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the TabItem control that is associated with this TabItemWrapperAutomationPeer object is off the screen. This method is called by IsOffscreen. (Inherited from TabItemWrapperAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemWrapperAutomationPeer Constructor

Initializes a new instance of the AdvancedTabItemWrapperAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabItemWrapperAutomationPeer(
    AdvancedTabItem owner
)
Public Sub New (
    owner As AdvancedTabItem
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingAdvancedTabItem
The owner element.
See Also

Reference

AdvancedTabItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemWrapperAutomationPeer Properties

The AdvancedTabItemWrapperAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

AdvancedTabItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemWrapperAutomationPeer Methods

The AdvancedTabItemWrapperAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClassName. (Inherited from UIElementAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the TabItem control that is associated with this TabItemWrapperAutomationPeer object is off the screen. This method is called by IsOffscreen. (Inherited from TabItemWrapperAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AdvancedTabItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer Class

Exposes DockHost types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDockHostAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockHostAutomationPeer : FrameworkElementAutomationPeer
Public Class DockHostAutomationPeer
    Inherits FrameworkElementAutomationPeer

The DockHostAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | DockHostAutomationPeer | Initializes a new instance of the DockHostAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides FrameworkElementAutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer Constructor

Initializes a new instance of the DockHostAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHostAutomationPeer(
    DockHost owner
)
Public Sub New (
    owner As DockHost
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The owner element.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer Properties

The DockHostAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer Methods

The DockHostAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides FrameworkElementAutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetAutomationControlTypeCore Method

DockHostAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetAutomationIdCore Method

DockHostAutomationPeerGetAutomationIdCore Method

Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetAutomationIdCore()
Protected Overrides Function GetAutomationIdCore As String

Return Value

Type: String
The string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetChildrenCore Method

DockHostAutomationPeerGetChildrenCore Method

Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override List<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As List(Of AutomationPeer)

Return Value

Type: List AutomationPeer
The collection of AutomationPeer objects for child elements.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetClassNameCore Method

DockHostAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetClickablePointCore Method

DockHostAutomationPeerGetClickablePointCore Method

Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetLocalizedControlTypeCore Method

DockHostAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase Class

Exposes DockingWindow types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDockingWindowAutomationPeerBase
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDocumentWindowAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersToolWindowAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DockingWindowAutomationPeerBase : FrameworkElementAutomationPeer,
    IInvokeProvider
Public MustInherit Class DockingWindowAutomationPeerBase
    Inherits FrameworkElementAutomationPeer
    Implements IInvokeProvider

The DockingWindowAutomationPeerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DockingWindowAutomationPeerBase | Initializes a new instance of the DockingWindowAutomationPeerBase class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | Invoke |
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase Constructor

Initializes a new instance of the DockingWindowAutomationPeerBase class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DockingWindowAutomationPeerBase(
    DockingWindow owner
)
Protected Sub New (
    owner As DockingWindow
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The owner element.
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase Properties

The DockingWindowAutomationPeerBase type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase Methods

The DockingWindowAutomationPeerBase type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | Invoke |
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase.GetAutomationControlTypeCore Method

DockingWindowAutomationPeerBaseGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase.GetClassNameCore Method

DockingWindowAutomationPeerBaseGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase.GetNameCore Method

DockingWindowAutomationPeerBaseGetNameCore Method

Gets text that describes the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The name.
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase.GetPattern Method

DockingWindowAutomationPeerBaseGetPattern Method

Gets the control pattern that is associated with the specified PatternInterface.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value from the PatternInterface enumeration.

Return Value

Type: Object
The object that implements the pattern interface; if the peer does not support this interface.
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase.Invoke Method

DockingWindowAutomationPeerBaseInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Docking.Automation.Peers.DockingWindowAutomationPeerBase.Invoke"]

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Invoke()
Public Sub Invoke

Implements

IInvokeProviderInvoke
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer Class

Exposes DockingWindowContainerBase types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDockingWindowContainerBaseAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersTabbedMdiContainerAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersToolWindowContainerAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DockingWindowContainerBaseAutomationPeer : FrameworkElementAutomationPeer
Public MustInherit Class DockingWindowContainerBaseAutomationPeer
    Inherits FrameworkElementAutomationPeer

The DockingWindowContainerBaseAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Protected method | DockingWindowContainerBaseAutomationPeer | Initializes a new instance of the DockingWindowContainerBaseAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides FrameworkElementAutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer Constructor

Initializes a new instance of the DockingWindowContainerBaseAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DockingWindowContainerBaseAutomationPeer(
    DockingWindowContainerBase owner
)
Protected Sub New (
    owner As DockingWindowContainerBase
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.Docking.PrimitivesDockingWindowContainerBase
The owner element.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer Properties

The DockingWindowContainerBaseAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer Methods

The DockingWindowContainerBaseAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides FrameworkElementAutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer.GetAutomationControlTypeCore Method

DockingWindowContainerBaseAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer.GetAutomationIdCore Method

DockingWindowContainerBaseAutomationPeerGetAutomationIdCore Method

Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetAutomationIdCore()
Protected Overrides Function GetAutomationIdCore As String

Return Value

Type: String
The string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer.GetChildrenCore Method

DockingWindowContainerBaseAutomationPeerGetChildrenCore Method

Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override List<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As List(Of AutomationPeer)

Return Value

Type: List AutomationPeer
The collection of AutomationPeer objects for child elements.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer.GetClassNameCore Method

DockingWindowContainerBaseAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer Class

Exposes DockingWindowContainerTabItem types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDockingWindowContainerTabItemAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowContainerTabItemAutomationPeer : FrameworkElementAutomationPeer
Public Class DockingWindowContainerTabItemAutomationPeer
    Inherits FrameworkElementAutomationPeer

The DockingWindowContainerTabItemAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowContainerTabItemAutomationPeer | Initializes a new instance of the DockingWindowContainerTabItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides FrameworkElementAutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer Constructor

Initializes a new instance of the DockingWindowContainerTabItemAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowContainerTabItemAutomationPeer(
    AdvancedTabItem owner
)
Public Sub New (
    owner As AdvancedTabItem
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingAdvancedTabItem
The owner element.
See Also

Reference

DockingWindowContainerTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer Properties

The DockingWindowContainerTabItemAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

DockingWindowContainerTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer Methods

The DockingWindowContainerTabItemAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides FrameworkElementAutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DockingWindowContainerTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer.GetAutomationControlTypeCore Method

DockingWindowContainerTabItemAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

DockingWindowContainerTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer.GetAutomationIdCore Method

DockingWindowContainerTabItemAutomationPeerGetAutomationIdCore Method

Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetAutomationIdCore()
Protected Overrides Function GetAutomationIdCore As String

Return Value

Type: String
The string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.
See Also

Reference

DockingWindowContainerTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer.GetChildrenCore Method

DockingWindowContainerTabItemAutomationPeerGetChildrenCore Method

Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override List<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As List(Of AutomationPeer)

Return Value

Type: List AutomationPeer
The collection of AutomationPeer objects for child elements.
See Also

Reference

DockingWindowContainerTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer.GetClassNameCore Method

DockingWindowContainerTabItemAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

DockingWindowContainerTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer.GetLocalizedControlTypeCore Method

DockingWindowContainerTabItemAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

DockingWindowContainerTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerTabItemAutomationPeer.GetNameCore Method

DockingWindowContainerTabItemAutomationPeerGetNameCore Method

Gets text that describes the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The name.
See Also

Reference

DockingWindowContainerTabItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer Class

Exposes DockSite types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDockSiteAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockSiteAutomationPeer : FrameworkElementAutomationPeer
Public Class DockSiteAutomationPeer
    Inherits FrameworkElementAutomationPeer

The DockSiteAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | DockSiteAutomationPeer | Initializes a new instance of the DockSiteAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer Constructor

Initializes a new instance of the DockSiteAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSiteAutomationPeer(
    DockSite owner
)
Public Sub New (
    owner As DockSite
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The owner element.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer Properties

The DockSiteAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer Methods

The DockSiteAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer.GetAutomationControlTypeCore Method

DockSiteAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer.GetClassNameCore Method

DockSiteAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer.GetClickablePointCore Method

DockSiteAutomationPeerGetClickablePointCore Method

Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer.GetLocalizedControlTypeCore Method

DockSiteAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer Class

Exposes DocumentWindow types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDockingWindowAutomationPeerBase
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDocumentWindowAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DocumentWindowAutomationPeer : DockingWindowAutomationPeerBase
Public Class DocumentWindowAutomationPeer
    Inherits DockingWindowAutomationPeerBase

The DocumentWindowAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentWindowAutomationPeer | Initializes a new instance of the DocumentWindowAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from DockingWindowAutomationPeerBase.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | Invoke | (Inherited from DockingWindowAutomationPeerBase.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer Constructor

Initializes a new instance of the DocumentWindowAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DocumentWindowAutomationPeer(
    DocumentWindow owner
)
Public Sub New (
    owner As DocumentWindow
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingDocumentWindow
The owner element.
See Also

Reference

DocumentWindowAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer Properties

The DocumentWindowAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

DocumentWindowAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer Methods

The DocumentWindowAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from DockingWindowAutomationPeerBase.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | Invoke | (Inherited from DockingWindowAutomationPeerBase.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DocumentWindowAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer.GetLocalizedControlTypeCore Method

DocumentWindowAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

DocumentWindowAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer Class

Exposes SplitContainer types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersSplitContainerAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SplitContainerAutomationPeer : FrameworkElementAutomationPeer
Public Class SplitContainerAutomationPeer
    Inherits FrameworkElementAutomationPeer

The SplitContainerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | SplitContainerAutomationPeer | Initializes a new instance of the SplitContainerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates the explicit control orientation, if any. (Overrides UIElementAutomationPeerGetOrientationCore.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer Constructor

Initializes a new instance of the SplitContainerAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SplitContainerAutomationPeer(
    SplitContainer owner
)
Public Sub New (
    owner As SplitContainer
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingSplitContainer
The owner element.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer Properties

The SplitContainerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer Methods

The SplitContainerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates the explicit control orientation, if any. (Overrides UIElementAutomationPeerGetOrientationCore.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetAutomationControlTypeCore Method

SplitContainerAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetClassNameCore Method

SplitContainerAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetClickablePointCore Method

SplitContainerAutomationPeerGetClickablePointCore Method

Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetLocalizedControlTypeCore Method

SplitContainerAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetOrientationCore Method

SplitContainerAutomationPeerGetOrientationCore Method

Gets a value that indicates the explicit control orientation, if any.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationOrientation GetOrientationCore()
Protected Overrides Function GetOrientationCore As AutomationOrientation

Return Value

Type: AutomationOrientation
The orientation.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer Class

Exposes StandardMdiHost types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersStandardMdiHostAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StandardMdiHostAutomationPeer : FrameworkElementAutomationPeer
Public Class StandardMdiHostAutomationPeer
    Inherits FrameworkElementAutomationPeer

The StandardMdiHostAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiHostAutomationPeer | Initializes a new instance of the StandardMdiHostAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer Constructor

Initializes a new instance of the StandardMdiHostAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StandardMdiHostAutomationPeer(
    StandardMdiHost owner
)
Public Sub New (
    owner As StandardMdiHost
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingStandardMdiHost
The owner element.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer Properties

The StandardMdiHostAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer Methods

The StandardMdiHostAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetAutomationControlTypeCore Method

StandardMdiHostAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetChildrenCore Method

StandardMdiHostAutomationPeerGetChildrenCore Method

Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override List<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As List(Of AutomationPeer)

Return Value

Type: List AutomationPeer
The collection of AutomationPeer objects for child elements.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetClassNameCore Method

StandardMdiHostAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetClickablePointCore Method

StandardMdiHostAutomationPeerGetClickablePointCore Method

Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetLocalizedControlTypeCore Method

StandardMdiHostAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer Class

Exposes StandardSwitcher types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersStandardSwitcherAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StandardSwitcherAutomationPeer : FrameworkElementAutomationPeer,
    ISelectionProvider
Public Class StandardSwitcherAutomationPeer
    Inherits FrameworkElementAutomationPeer
    Implements ISelectionProvider

The StandardSwitcherAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | StandardSwitcherAutomationPeer | Initializes a new instance of the StandardSwitcherAutomationPeer class.
Top
Properties
 | Name | Description
Public property | CanSelectMultiple | Gets a value that specifies whether the UI Automation provider allows more than one child element to be selected concurrently.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | IsSelectionRequired | Gets a value that specifies whether the UI Automation provider requires at least one child element to be selected.
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | GetSelection | Retrieves a UI Automation provider for each child element that is selected.
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer Constructor

Initializes a new instance of the StandardSwitcherAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StandardSwitcherAutomationPeer(
    StandardSwitcher owner
)
Public Sub New (
    owner As StandardSwitcher
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingStandardSwitcher
The owner element.
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer Properties

The StandardSwitcherAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | CanSelectMultiple | Gets a value that specifies whether the UI Automation provider allows more than one child element to be selected concurrently.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | IsSelectionRequired | Gets a value that specifies whether the UI Automation provider requires at least one child element to be selected.
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.CanSelectMultiple Property

StandardSwitcherAutomationPeerCanSelectMultiple Property

Gets a value that specifies whether the UI Automation provider allows more than one child element to be selected concurrently.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanSelectMultiple { get; }
Public ReadOnly Property CanSelectMultiple As Boolean
    Get

Property Value

Type: Boolean
true if multiple selection is allowed; otherwise false.

Implements

ISelectionProviderCanSelectMultiple
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.IsSelectionRequired Property

StandardSwitcherAutomationPeerIsSelectionRequired Property

Gets a value that specifies whether the UI Automation provider requires at least one child element to be selected.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelectionRequired { get; }
Public ReadOnly Property IsSelectionRequired As Boolean
    Get

Property Value

Type: Boolean
true if selection is required; otherwise false.

Implements

ISelectionProviderIsSelectionRequired
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer Methods

The StandardSwitcherAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | GetSelection | Retrieves a UI Automation provider for each child element that is selected.
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.GetAutomationControlTypeCore Method

StandardSwitcherAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.GetChildrenCore Method

StandardSwitcherAutomationPeerGetChildrenCore Method

Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override List<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As List(Of AutomationPeer)

Return Value

Type: List AutomationPeer
The collection of AutomationPeer objects for child elements.
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.GetClassNameCore Method

StandardSwitcherAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.GetClickablePointCore Method

StandardSwitcherAutomationPeerGetClickablePointCore Method

Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.GetLocalizedControlTypeCore Method

StandardSwitcherAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.GetNameCore Method

StandardSwitcherAutomationPeerGetNameCore Method

Gets text that describes the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The name.
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.GetPattern Method

StandardSwitcherAutomationPeerGetPattern Method

Gets the control pattern that is associated with the specified PatternInterface.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value from the PatternInterface enumeration.

Return Value

Type: Object
The object that implements the pattern interface; if the peer does not support this interface.
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherAutomationPeer.GetSelection Method

StandardSwitcherAutomationPeerGetSelection Method

Retrieves a UI Automation provider for each child element that is selected.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IRawElementProviderSimple[] GetSelection()
Public Function GetSelection As IRawElementProviderSimple()

Return Value

Type: IRawElementProviderSimple
A collection of UI Automation providers.

Implements

ISelectionProviderGetSelection
See Also

Reference

StandardSwitcherAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer Class

Exposes StandardSwitcherItem types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersStandardSwitcherItemAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StandardSwitcherItemAutomationPeer : FrameworkElementAutomationPeer,
    IInvokeProvider, ISelectionItemProvider
Public Class StandardSwitcherItemAutomationPeer
    Inherits FrameworkElementAutomationPeer
    Implements IInvokeProvider, ISelectionItemProvider

The StandardSwitcherItemAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | StandardSwitcherItemAutomationPeer | Initializes a new instance of the StandardSwitcherItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | IsSelected | Gets a value that indicates whether an item is selected.
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public property | SelectionContainer | Gets the UI Automation provider that implements ISelectionProvider and acts as the container for the calling object.
Top
Methods
 | Name | Description
Public method | AddToSelection | Adds the current element to the collection of selected items.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | Invoke |
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RemoveFromSelection | Removes the current element from the collection of selected items.
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | Select | Deselects any selected items and then selects the current element.
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer Constructor

Initializes a new instance of the StandardSwitcherItemAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StandardSwitcherItemAutomationPeer(
    StandardSwitcherItem owner
)
Public Sub New (
    owner As StandardSwitcherItem
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.Docking.PrimitivesStandardSwitcherItem
The owner element.
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer Properties

The StandardSwitcherItemAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | IsSelected | Gets a value that indicates whether an item is selected.
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public property | SelectionContainer | Gets the UI Automation provider that implements ISelectionProvider and acts as the container for the calling object.
Top
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.IsSelected Property

StandardSwitcherItemAutomationPeerIsSelected Property

Gets a value that indicates whether an item is selected.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; }
Public ReadOnly Property IsSelected As Boolean
    Get

Property Value

Type: Boolean
true if the element is selected; otherwise false.

Implements

ISelectionItemProviderIsSelected
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.SelectionContainer Property

StandardSwitcherItemAutomationPeerSelectionContainer Property

Gets the UI Automation provider that implements ISelectionProvider and acts as the container for the calling object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IRawElementProviderSimple SelectionContainer { get; }
Public ReadOnly Property SelectionContainer As IRawElementProviderSimple
    Get

Property Value

Type: IRawElementProviderSimple
The provider that supports ISelectionProvider.

Implements

ISelectionItemProviderSelectionContainer
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer Methods

The StandardSwitcherItemAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | AddToSelection | Adds the current element to the collection of selected items.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | Invoke |
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RemoveFromSelection | Removes the current element from the collection of selected items.
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | Select | Deselects any selected items and then selects the current element.
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.AddToSelection Method

StandardSwitcherItemAutomationPeerAddToSelection Method

Adds the current element to the collection of selected items.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddToSelection()
Public Sub AddToSelection

Implements

ISelectionItemProviderAddToSelection
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.GetAutomationControlTypeCore Method

StandardSwitcherItemAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.GetChildrenCore Method

StandardSwitcherItemAutomationPeerGetChildrenCore Method

Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override List<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As List(Of AutomationPeer)

Return Value

Type: List AutomationPeer
The collection of AutomationPeer objects for child elements.
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.GetClassNameCore Method

StandardSwitcherItemAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.GetLocalizedControlTypeCore Method

StandardSwitcherItemAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.GetNameCore Method

StandardSwitcherItemAutomationPeerGetNameCore Method

Gets text that describes the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The name.
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.GetPattern Method

StandardSwitcherItemAutomationPeerGetPattern Method

Gets the control pattern that is associated with the specified PatternInterface.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value from the PatternInterface enumeration.

Return Value

Type: Object
The object that implements the pattern interface; if the peer does not support this interface.
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.Invoke Method

StandardSwitcherItemAutomationPeerInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Docking.Automation.Peers.StandardSwitcherItemAutomationPeer.Invoke"]

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Invoke()
Public Sub Invoke

Implements

IInvokeProviderInvoke
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.RemoveFromSelection Method

StandardSwitcherItemAutomationPeerRemoveFromSelection Method

Removes the current element from the collection of selected items.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveFromSelection()
Public Sub RemoveFromSelection

Implements

ISelectionItemProviderRemoveFromSelection
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


StandardSwitcherItemAutomationPeer.Select Method

StandardSwitcherItemAutomationPeerSelect Method

Deselects any selected items and then selects the current element.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Select()
Public Sub Select

Implements

ISelectionItemProviderSelect
See Also

Reference

StandardSwitcherItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer Class

Exposes TabbedMdiContainer types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDockingWindowContainerBaseAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersTabbedMdiContainerAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TabbedMdiContainerAutomationPeer : DockingWindowContainerBaseAutomationPeer
Public Class TabbedMdiContainerAutomationPeer
    Inherits DockingWindowContainerBaseAutomationPeer

The TabbedMdiContainerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | TabbedMdiContainerAutomationPeer | Initializes a new instance of the TabbedMdiContainerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer Constructor

Initializes a new instance of the TabbedMdiContainerAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabbedMdiContainerAutomationPeer(
    TabbedMdiContainer owner
)
Public Sub New (
    owner As TabbedMdiContainer
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingTabbedMdiContainer
The owner element.
See Also

Reference

TabbedMdiContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer Properties

The TabbedMdiContainerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

TabbedMdiContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer Methods

The TabbedMdiContainerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

TabbedMdiContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer.GetLocalizedControlTypeCore Method

TabbedMdiContainerAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

TabbedMdiContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer Class

Exposes ToolWindow types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDockingWindowAutomationPeerBase
ActiproSoftware.Windows.Controls.Docking.Automation.PeersToolWindowAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ToolWindowAutomationPeer : DockingWindowAutomationPeerBase
Public Class ToolWindowAutomationPeer
    Inherits DockingWindowAutomationPeerBase

The ToolWindowAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowAutomationPeer | Initializes a new instance of the ToolWindowAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from DockingWindowAutomationPeerBase.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | Invoke | (Inherited from DockingWindowAutomationPeerBase.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer Constructor

Initializes a new instance of the ToolWindowAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowAutomationPeer(
    ToolWindow owner
)
Public Sub New (
    owner As ToolWindow
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingToolWindow
The owner element.
See Also

Reference

ToolWindowAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer Properties

The ToolWindowAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

ToolWindowAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer Methods

The ToolWindowAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from DockingWindowAutomationPeerBase.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | Invoke | (Inherited from DockingWindowAutomationPeerBase.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ToolWindowAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer.GetLocalizedControlTypeCore Method

ToolWindowAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

ToolWindowAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer Class

Exposes ToolWindowContainer types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersDockingWindowContainerBaseAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersToolWindowContainerAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ToolWindowContainerAutomationPeer : DockingWindowContainerBaseAutomationPeer
Public Class ToolWindowContainerAutomationPeer
    Inherits DockingWindowContainerBaseAutomationPeer

The ToolWindowContainerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowContainerAutomationPeer | Initializes a new instance of the ToolWindowContainerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer Constructor

Initializes a new instance of the ToolWindowContainerAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerAutomationPeer(
    ToolWindowContainer owner
)
Public Sub New (
    owner As ToolWindowContainer
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingToolWindowContainer
The owner element.
See Also

Reference

ToolWindowContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer Properties

The ToolWindowContainerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

ToolWindowContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer Methods

The ToolWindowContainerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ToolWindowContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer.GetLocalizedControlTypeCore Method

ToolWindowContainerAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

ToolWindowContainerAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer Class

Exposes WindowControl types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersWindowControlAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WindowControlAutomationPeer : FrameworkElementAutomationPeer,
    ITransformProvider, IWindowProvider
Public Class WindowControlAutomationPeer
    Inherits FrameworkElementAutomationPeer
    Implements ITransformProvider, IWindowProvider

The WindowControlAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | WindowControlAutomationPeer | Initializes a new instance of the WindowControlAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer Constructor

Initializes a new instance of the WindowControlAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WindowControlAutomationPeer(
    WindowControl owner
)
Public Sub New (
    owner As WindowControl
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingWindowControl
The owner element.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer Properties

The WindowControlAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer Methods

The WindowControlAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetAutomationControlTypeCore Method

WindowControlAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetClassNameCore Method

WindowControlAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetLocalizedControlTypeCore Method

WindowControlAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetNameCore Method

WindowControlAutomationPeerGetNameCore Method

Gets text that describes the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The name.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetPattern Method

WindowControlAutomationPeerGetPattern Method

Gets the object that supports the specified control pattern of the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value in the enumeration.

Return Value

Type: Object
This method will return a 'this' pointer in the follow cases:
  • If patternInterface is Transform. -
  • If patternInterface is Window. -
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer Class

Exposes Workspace types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Docking.Automation.PeersWorkspaceAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class WorkspaceAutomationPeer : FrameworkElementAutomationPeer
Public Class WorkspaceAutomationPeer
    Inherits FrameworkElementAutomationPeer

The WorkspaceAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | WorkspaceAutomationPeer | Initializes a new instance of the WorkspaceAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer Constructor

Initializes a new instance of the WorkspaceAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WorkspaceAutomationPeer(
    Workspace owner
)
Public Sub New (
    owner As Workspace
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.DockingWorkspace
The owner element.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer Properties

The WorkspaceAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer Methods

The WorkspaceAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides UIElementAutomationPeerGetClickablePointCore.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer.GetAutomationControlTypeCore Method

WorkspaceAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer.GetClassNameCore Method

WorkspaceAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer.GetClickablePointCore Method

WorkspaceAutomationPeerGetClickablePointCore Method

Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer.GetLocalizedControlTypeCore Method

WorkspaceAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Docking.Automation.Peers
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.Windows.Controls.Docking.Automation.Peers Namespace


ActiproSoftware.Windows.Controls.Docking.Primitives Namespace

Contains primitive classes used for Docking & MDI controls.
Classes
 | Class | Description
Public class | AdvancedTabPanel | Represents a Panel that is used by an AdvancedTabControl.
Public class | AutoHideContainerSplitter | Represents a splitter for an auto-hide container.
Public class | AutoHideTabGroup | Represents a tab group that can contain dockable windows in auto-hide mode.
Public class | AutoHideTabItem | Represents a tab item the provides access to a dockable window in auto-hide mode.
Public class | AutoHideTabStrip | Represents an auto-hide tab strip.
Public class | DockGuideBase | Represents a dock guide for the outer bottom side of a dock host.
Public class | DockGuideCenter | Represents a center dock guide.
Public class | DockGuideCross | Represents a cross-shaped container for other dock guides.
Public class | DockGuideInnerBottom | Represents an inner bottom dock guide.
Public class | DockGuideInnerLeft | Represents an inner left dock guide.
Public class | DockGuideInnerRight | Represents an inner right dock guide.
Public class | DockGuideInnerTop | Represents an inner top dock guide.
Public class | DockGuideOuterBottom | Represents an outer bottom dock guide.
Public class | DockGuideOuterLeft | Represents an outer left dock guide.
Public class | DockGuideOuterRight | Represents an outer right dock guide.
Public class | DockGuideOuterTop | Represents an outer top dock guide.
Public class | DockingWindowContainerBase | Represents the base class for a control that can contain multiple docking windows, with one selected.
Public class | DockingWindowContainerTabItem | Represents an AdvancedTabItem for use within a DockingWindowContainerBase.
Public class | DockPreview | Represents a dock preview that shows when dragging over a dock guide.
Public class | FloatingWindowControl | Represents a WindowControl that is used as the root control of a hosted floating window.
Public class | FloatPreview | Represents a float preview that can show when not dragging over a dock guide.
Public class | MdiHostBase | Represents the base class for a container that hosts docking windows in a MDI (multiple-document interface).
Public class | NewTabButton | Represents a new tab button.
Public class | NonUIElementConverter | Represents a value converter that only passes through a value if it isn't a UIElement.
Public class | SideToDockConverter | Represents a value converter that converts between a side and a Dock.
Public class | SplitContainerPanel | Represents a Panel that is used by a SplitContainer.
Public class | SplitContainerSplitter | Represents a splitter within a SplitContainer.
Public class | SplitterBase | Represents an abstract base class for a splitter.
Public class | StandardMdiItemsControl | Represents an ItemsControl that displays standard MDI windows.
Public class | StandardMdiPanel | Represents a Panel that is used by a StandardMdiItemsControl.
Public class | StandardMdiWindowControl | Represents a WindowControl that is used as the root control of a hosted floating window.
Public class | StandardSwitcherItem | Represents an item in a StandardSwitcher.
Public class | SwitcherBase | Provides the base class for a component that provides Ctrl+Tab-like switching of docking windows.
Public class | TabbedMdiContainerTabControl | Represents an AdvancedTabControl for use within a TabbedMdiContainer.
Public class | TabItemBorder | Renders a border for a tab item.
Public class | TitleBarPanel | Represents a Panel within a title bar.
Public class | TitleConverter | Represents a value converter that can shorten long text by only allowing a certain prefix number of characters at the start, then injecting the patch string, and allowing a certain suffix number of characters at the end.
Public class | ToolWindowContainerTabControl | Represents an AdvancedTabControl for use within a ToolWindowContainer.


AdvancedTabPanel Class

Represents a Panel that is used by an AdvancedTabControl.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
System.Windows.Controls.PrimitivesTabPanel
ActiproSoftware.Windows.Controls.Docking.PrimitivesAdvancedTabPanel

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AdvancedTabPanel : TabPanel,
    IOrientedElement
Public Class AdvancedTabPanel
    Inherits TabPanel
    Implements IOrientedElement

The AdvancedTabPanel type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabPanel | Initializes a new instance of the AdvancedTabPanel class.
Protected method | AdvancedTabPanel(Boolean) | Initializes a new instance of the AdvancedTabPanel class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TabPanelArrangeOverride(Size).)
Protected method | ArrangeTab | Arranges a single tab When performing custom ArrangeOverride logic.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. (Overrides TabPanelGetLayoutClip(Size).)
Protected method | GetTabItemElements | Returns the collection of tab item elements.
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides TabPanelMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Occurs when the IsItemsHost property changes. (Overrides PanelOnIsItemsHostChanged(Boolean, Boolean).)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel Constructor

Overload List
 | Name | Description
Public method | AdvancedTabPanel | Initializes a new instance of the AdvancedTabPanel class.
Protected method | AdvancedTabPanel(Boolean) | Initializes a new instance of the AdvancedTabPanel class.
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel Constructor

Initializes a new instance of the AdvancedTabPanel class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AdvancedTabPanel()
Public Sub New
See Also

Reference

AdvancedTabPanel Class
AdvancedTabPanel Overload
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel Constructor (Boolean)

Initializes a new instance of the AdvancedTabPanel class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected AdvancedTabPanel(
    bool useCustomLayoutLogic
)
Protected Sub New (
    useCustomLayoutLogic As Boolean
)

Parameters

useCustomLayoutLogic
Type: SystemBoolean
Specify true when using completely custom layout logic (i.e. overriding ArrangeOverride).
See Also

Reference

AdvancedTabPanel Class
AdvancedTabPanel Overload
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel Properties

The AdvancedTabPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel.Orientation Property

AdvancedTabPanelOrientation Property

Gets or sets the Orientation of the child element layout.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Horizontal.

Implements

IOrientedElementOrientation
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel Methods

The AdvancedTabPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TabPanelArrangeOverride(Size).)
Protected method | ArrangeTab | Arranges a single tab When performing custom ArrangeOverride logic.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. (Overrides TabPanelGetLayoutClip(Size).)
Protected method | GetTabItemElements | Returns the collection of tab item elements.
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides TabPanelMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Occurs when the IsItemsHost property changes. (Overrides PanelOnIsItemsHostChanged(Boolean, Boolean).)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel.ArrangeOverride Method

AdvancedTabPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel.ArrangeTab Method

AdvancedTabPanelArrangeTab Method

Arranges a single tab When performing custom ArrangeOverride logic.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void ArrangeTab(
    AdvancedTabItem tabItem,
    Rect bounds,
    int sortOrder
)
Protected Sub ArrangeTab (
    tabItem As AdvancedTabItem,
    bounds As Rect,
    sortOrder As Integer
)

Parameters

tabItem
Type: ActiproSoftware.Windows.Controls.DockingAdvancedTabItem
The AdvancedTabItem to arrange.
bounds
Type: System.WindowsRect
The target bounds for the tab item.
sortOrder
Type: SystemInt32
The zero-based sort order of the tab.
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel.GetLayoutClip Method

AdvancedTabPanelGetLayoutClip Method

Returns a geometry for a clipping mask.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Geometry GetLayoutClip(
    Size layoutSlotSize
)
Protected Overrides Function GetLayoutClip (
    layoutSlotSize As Size
) As Geometry

Parameters

layoutSlotSize
Type: System.WindowsSize
The layout slot size.

Return Value

Type: Geometry
The clipping mask geometry.
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel.GetTabItemElements Method

AdvancedTabPanelGetTabItemElements Method

Returns the collection of tab item elements.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IEnumerable<AdvancedTabItem> GetTabItemElements(
    Nullable<TabLayoutKind> layoutKind = null
)
Protected Function GetTabItemElements (
    Optional layoutKind As Nullable(Of TabLayoutKind) = Nothing
) As IEnumerable(Of AdvancedTabItem)

Parameters

layoutKind (Optional)
Type: SystemNullable TabLayoutKind
The desired tab layout kind.

Return Value

Type: IEnumerable AdvancedTabItem
The collection of tab item elements.
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel.MeasureOverride Method

AdvancedTabPanelMeasureOverride Method

Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel.OnIsItemsHostChanged Method

AdvancedTabPanelOnIsItemsHostChanged Method

Occurs when the IsItemsHost property changes.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsItemsHostChanged(
    bool oldIsItemsHost,
    bool newIsItemsHost
)
Protected Overrides Sub OnIsItemsHostChanged (
    oldIsItemsHost As Boolean,
    newIsItemsHost As Boolean
)

Parameters

oldIsItemsHost
Type: SystemBoolean
The old value.
newIsItemsHost
Type: SystemBoolean
The new value.
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel Fields

The AdvancedTabPanel type exposes the following members.

Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AdvancedTabPanel.OrientationProperty Field

AdvancedTabPanelOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Class

Represents a splitter for an auto-hide container.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesSplitterBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesAutoHideContainerSplitter

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutoHideContainerSplitter : SplitterBase,
    IOrientedElement
Public Class AutoHideContainerSplitter
    Inherits SplitterBase
    Implements IOrientedElement

The AutoHideContainerSplitter type exposes the following members.

Constructors
 | Name | Description
Public method | AutoHideContainerSplitter | Initializes an instance of the AutoHideContainerSplitter class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted. (Inherited from SplitterBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the splitter. (Inherited from SplitterBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from SplitterBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Constructor

Initializes an instance of the AutoHideContainerSplitter class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoHideContainerSplitter()
Public Sub New
See Also

Reference

AutoHideContainerSplitter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Properties

The AutoHideContainerSplitter type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted. (Inherited from SplitterBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the splitter. (Inherited from SplitterBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AutoHideContainerSplitter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Methods

The AutoHideContainerSplitter type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from SplitterBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

AutoHideContainerSplitter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Events

The AutoHideContainerSplitter type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

AutoHideContainerSplitter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup Class

Represents a tab group that can contain dockable windows in auto-hide mode.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesAutoHideTabGroup

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutoHideTabGroup : ItemsControl
Public Class AutoHideTabGroup
    Inherits ItemsControl

The AutoHideTabGroup type exposes the following members.

Constructors
 | Name | Description
Public method | AutoHideTabGroup | Initializes an instance of the AutoHideTabGroup class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup Constructor

Initializes an instance of the AutoHideTabGroup class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoHideTabGroup()
Public Sub New
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup Properties

The AutoHideTabGroup type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup.Placement Property

AutoHideTabGroupPlacement Property

Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Side Placement { get; set; }
Public Property Placement As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip is placed.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup Methods

The AutoHideTabGroup type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup.ClearContainerForItemOverride Method

AutoHideTabGroupClearContainerForItemOverride Method

Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup.GetContainerForItemOverride Method

AutoHideTabGroupGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup.IsItemItsOwnContainerOverride Method

AutoHideTabGroupIsItemItsOwnContainerOverride Method

Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup.PrepareContainerForItemOverride Method

AutoHideTabGroupPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup Events

The AutoHideTabGroup type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup Fields

The AutoHideTabGroup type exposes the following members.

Fields
Name | Description
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
Top
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabGroup.PlacementProperty Field

AutoHideTabGroupPlacementProperty Field

Identifies the Placement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlacementProperty
Public Shared ReadOnly PlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Placement dependency property.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem Class

Represents a tab item the provides access to a dockable window in auto-hide mode.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesAutoHideTabItem

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutoHideTabItem : ContentControl
Public Class AutoHideTabItem
    Inherits ContentControl

The AutoHideTabItem type exposes the following members.

Constructors
 | Name | Description
Public method | AutoHideTabItem | Initializes an instance of the AutoHideTabItem class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAutoHidePopupOpen | Gets or sets whether the related auto-hide popup is currently visible.
Public property | IsImageVisible | Gets whether the embedded image is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnDragEnter | Occurs when a drag operation moves over the control. (Overrides UIElementOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when a drag operation leaves the control. (Overrides UIElementOnDragLeave(DragEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
IsAutoHidePopupOpenProperty | Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.
IsImageVisibleProperty | Identifies the IsImageVisible dependency property. This field is read-only.
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem Constructor

Initializes an instance of the AutoHideTabItem class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoHideTabItem()
Public Sub New
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem Properties

The AutoHideTabItem type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAutoHidePopupOpen | Gets or sets whether the related auto-hide popup is currently visible.
Public property | IsImageVisible | Gets whether the embedded image is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.CornerRadius Property

AutoHideTabItemCornerRadius Property

Gets or sets the corner radius of the tab border, relative to a top-facing tab.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the tab border, relative to a top-facing tab.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.IsAutoHidePopupOpen Property

AutoHideTabItemIsAutoHidePopupOpen Property

Gets or sets whether the related auto-hide popup is currently visible.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAutoHidePopupOpen { get; set; }
Public Property IsAutoHidePopupOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the related auto-hide popup is currently visible; otherwise, false. The default value is false.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.IsImageVisible Property

AutoHideTabItemIsImageVisible Property

Gets whether the embedded image is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsImageVisible { get; }
Public ReadOnly Property IsImageVisible As Boolean
    Get

Property Value

Type: Boolean
true if the embedded image is visible; otherwise, false. The default value is false.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.Placement Property

AutoHideTabItemPlacement Property

Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Side Placement { get; set; }
Public Property Placement As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip is placed.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem Methods

The AutoHideTabItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnDragEnter | Occurs when a drag operation moves over the control. (Overrides UIElementOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when a drag operation leaves the control. (Overrides UIElementOnDragLeave(DragEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.OnApplyTemplate Method

AutoHideTabItemOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.OnDragEnter Method

AutoHideTabItemOnDragEnter Method

Occurs when a drag operation moves over the control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragEnter(
    DragEventArgs e
)
Protected Overrides Sub OnDragEnter (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs that contains the event data.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.OnDragLeave Method

AutoHideTabItemOnDragLeave Method

Occurs when a drag operation leaves the control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragLeave(
    DragEventArgs e
)
Protected Overrides Sub OnDragLeave (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs that contains the event data.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem Events

The AutoHideTabItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem Fields

The AutoHideTabItem type exposes the following members.

Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
IsAutoHidePopupOpenProperty | Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.
IsImageVisibleProperty | Identifies the IsImageVisible dependency property. This field is read-only.
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
Top
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.CornerRadiusProperty Field

AutoHideTabItemCornerRadiusProperty Field

Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.IsAutoHidePopupOpenProperty Field

AutoHideTabItemIsAutoHidePopupOpenProperty Field

Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoHidePopupOpenProperty
Public Shared ReadOnly IsAutoHidePopupOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoHidePopupOpen dependency property.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.IsImageVisibleProperty Field

AutoHideTabItemIsImageVisibleProperty Field

Identifies the IsImageVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsImageVisibleProperty
Public Shared ReadOnly IsImageVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsImageVisible dependency property.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabItem.PlacementProperty Field

AutoHideTabItemPlacementProperty Field

Identifies the Placement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlacementProperty
Public Shared ReadOnly PlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Placement dependency property.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip Class

Represents an auto-hide tab strip.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesAutoHideTabStrip

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutoHideTabStrip : ItemsControl
Public Class AutoHideTabStrip
    Inherits ItemsControl

The AutoHideTabStrip type exposes the following members.

Constructors
 | Name | Description
Public method | AutoHideTabStrip | Initializes an instance of the AutoHideTabStrip class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHorizontal | Gets whether the tabstrip is positioned horizontally.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemTemplate | Gets or sets the DataTemplate to use for rendering the tab items.
Public property | TabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the tab items.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
IsHorizontalProperty | Identifies the IsHorizontal dependency property. This field is read-only.
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
TabItemTemplateProperty | Identifies the TabItemTemplate dependency property. This field is read-only.
TabItemTemplateSelectorProperty | Identifies the TabItemTemplateSelector dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip Constructor

Initializes an instance of the AutoHideTabStrip class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoHideTabStrip()
Public Sub New
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip Properties

The AutoHideTabStrip type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHorizontal | Gets whether the tabstrip is positioned horizontally.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemTemplate | Gets or sets the DataTemplate to use for rendering the tab items.
Public property | TabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the tab items.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.IsHorizontal Property

AutoHideTabStripIsHorizontal Property

Gets whether the tabstrip is positioned horizontally.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsHorizontal { get; }
Public ReadOnly Property IsHorizontal As Boolean
    Get

Property Value

Type: Boolean
true if the tabstrip is positioned horizontally; otherwise, false.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.Placement Property

AutoHideTabStripPlacement Property

Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Side Placement { get; set; }
Public Property Placement As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip is placed.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.TabItemTemplate Property

AutoHideTabStripTabItemTemplate Property

Gets or sets the DataTemplate to use for rendering the tab items.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate TabItemTemplate { get; set; }
Public Property TabItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for rendering the tab items.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.TabItemTemplateSelector Property

AutoHideTabStripTabItemTemplateSelector Property

Gets or sets the DataTemplateSelector to use for rendering the tab items.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector TabItemTemplateSelector { get; set; }
Public Property TabItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for rendering the tab items.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip Methods

The AutoHideTabStrip type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.ClearContainerForItemOverride Method

AutoHideTabStripClearContainerForItemOverride Method

Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.GetContainerForItemOverride Method

AutoHideTabStripGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.IsItemItsOwnContainerOverride Method

AutoHideTabStripIsItemItsOwnContainerOverride Method

Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.PrepareContainerForItemOverride Method

AutoHideTabStripPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip Events

The AutoHideTabStrip type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip Fields

The AutoHideTabStrip type exposes the following members.

Fields
Name | Description
IsHorizontalProperty | Identifies the IsHorizontal dependency property. This field is read-only.
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
TabItemTemplateProperty | Identifies the TabItemTemplate dependency property. This field is read-only.
TabItemTemplateSelectorProperty | Identifies the TabItemTemplateSelector dependency property. This field is read-only.
Top
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.IsHorizontalProperty Field

AutoHideTabStripIsHorizontalProperty Field

Identifies the IsHorizontal dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHorizontalProperty
Public Shared ReadOnly IsHorizontalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHorizontal dependency property.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.PlacementProperty Field

AutoHideTabStripPlacementProperty Field

Identifies the Placement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlacementProperty
Public Shared ReadOnly PlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Placement dependency property.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.TabItemTemplateProperty Field

AutoHideTabStripTabItemTemplateProperty Field

Identifies the TabItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabItemTemplateProperty
Public Shared ReadOnly TabItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabItemTemplate dependency property.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


AutoHideTabStrip.TabItemTemplateSelectorProperty Field

AutoHideTabStripTabItemTemplateSelectorProperty Field

Identifies the TabItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabItemTemplateSelectorProperty
Public Shared ReadOnly TabItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabItemTemplateSelector dependency property.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideBase Class

Represents a dock guide for the outer bottom side of a dock host.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
More...

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DockGuideBase : ContentControl
Public MustInherit Class DockGuideBase
    Inherits ContentControl

The DockGuideBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DockGuideBase | Initializes a new instance of the DockGuideBase class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideCenter
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideInnerBottom
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideInnerLeft
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideInnerRight
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideInnerTop
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideOuterBottom
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideOuterLeft
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideOuterRight
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideOuterTop


DockGuideBase Constructor

Initializes a new instance of the DockGuideBase class

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DockGuideBase()
Protected Sub New
See Also

Reference

DockGuideBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideBase Properties

The DockGuideBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideBase.IsSelected Property

DockGuideBaseIsSelected Property

Gets or sets whether the dock guide is selected.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dock guide is selected; otherwise, false.
See Also

Reference

DockGuideBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideBase.Side Property

DockGuideBaseSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract Nullable<Side> Side { get; }
Public MustOverride ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideBase.Target Property

DockGuideBaseTarget Property

Gets the target control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDockTarget Target { get; }
Public ReadOnly Property Target As IDockTarget
    Get

Property Value

Type: IDockTarget
The target control.
See Also

Reference

DockGuideBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideBase Methods

The DockGuideBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideBase Events

The DockGuideBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideBase Fields

The DockGuideBase type exposes the following members.

Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
See Also

Reference

DockGuideBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideBase.IsSelectedProperty Field

DockGuideBaseIsSelectedProperty Field

Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

DockGuideBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCenter Class

Represents a center dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideCenter

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideCenter : DockGuideBase
Public Class DockGuideCenter
    Inherits DockGuideBase

The DockGuideCenter type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideCenter | Initializes an instance of the DockGuideCenter class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCenter Constructor

Initializes an instance of the DockGuideCenter class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideCenter()
Public Sub New
See Also

Reference

DockGuideCenter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCenter Properties

The DockGuideCenter type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideCenter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCenter.Side Property

DockGuideCenterSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideCenter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCenter Methods

The DockGuideCenter type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideCenter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCenter Events

The DockGuideCenter type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideCenter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCross Class

Represents a cross-shaped container for other dock guides.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideCross

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideCross : Control
Public Class DockGuideCross
    Inherits Control

The DockGuideCross type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideCross | Initializes an instance of the DockGuideCross class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCross Constructor

Initializes an instance of the DockGuideCross class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideCross()
Public Sub New
See Also

Reference

DockGuideCross Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCross Properties

The DockGuideCross type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideCross Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCross Methods

The DockGuideCross type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideCross Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCross.OnApplyTemplate Method

DockGuideCrossOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DockGuideCross Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideCross Events

The DockGuideCross type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideCross Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Class

Represents an inner bottom dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideInnerBottom

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideInnerBottom : DockGuideBase
Public Class DockGuideInnerBottom
    Inherits DockGuideBase

The DockGuideInnerBottom type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideInnerBottom | Initializes an instance of the DockGuideInnerBottom class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Constructor

Initializes an instance of the DockGuideInnerBottom class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideInnerBottom()
Public Sub New
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Properties

The DockGuideInnerBottom type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerBottom.Side Property

DockGuideInnerBottomSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Methods

The DockGuideInnerBottom type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Events

The DockGuideInnerBottom type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Class

Represents an inner left dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideInnerLeft

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideInnerLeft : DockGuideBase
Public Class DockGuideInnerLeft
    Inherits DockGuideBase

The DockGuideInnerLeft type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideInnerLeft | Initializes an instance of the DockGuideInnerLeft class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Constructor

Initializes an instance of the DockGuideInnerLeft class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideInnerLeft()
Public Sub New
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Properties

The DockGuideInnerLeft type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerLeft.Side Property

DockGuideInnerLeftSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Methods

The DockGuideInnerLeft type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Events

The DockGuideInnerLeft type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerRight Class

Represents an inner right dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideInnerRight

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideInnerRight : DockGuideBase
Public Class DockGuideInnerRight
    Inherits DockGuideBase

The DockGuideInnerRight type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideInnerRight | Initializes an instance of the DockGuideInnerRight class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerRight Constructor

Initializes an instance of the DockGuideInnerRight class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideInnerRight()
Public Sub New
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerRight Properties

The DockGuideInnerRight type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerRight.Side Property

DockGuideInnerRightSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerRight Methods

The DockGuideInnerRight type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerRight Events

The DockGuideInnerRight type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerTop Class

Represents an inner top dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideInnerTop

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideInnerTop : DockGuideBase
Public Class DockGuideInnerTop
    Inherits DockGuideBase

The DockGuideInnerTop type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideInnerTop | Initializes an instance of the DockGuideInnerTop class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerTop Constructor

Initializes an instance of the DockGuideInnerTop class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideInnerTop()
Public Sub New
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerTop Properties

The DockGuideInnerTop type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerTop.Side Property

DockGuideInnerTopSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerTop Methods

The DockGuideInnerTop type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideInnerTop Events

The DockGuideInnerTop type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Class

Represents an outer bottom dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideOuterBottom

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideOuterBottom : DockGuideBase
Public Class DockGuideOuterBottom
    Inherits DockGuideBase

The DockGuideOuterBottom type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideOuterBottom | Initializes an instance of the DockGuideOuterBottom class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Constructor

Initializes an instance of the DockGuideOuterBottom class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideOuterBottom()
Public Sub New
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Properties

The DockGuideOuterBottom type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterBottom.Side Property

DockGuideOuterBottomSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Methods

The DockGuideOuterBottom type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Events

The DockGuideOuterBottom type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Class

Represents an outer left dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideOuterLeft

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideOuterLeft : DockGuideBase
Public Class DockGuideOuterLeft
    Inherits DockGuideBase

The DockGuideOuterLeft type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideOuterLeft | Initializes an instance of the DockGuideOuterLeft class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Constructor

Initializes an instance of the DockGuideOuterLeft class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideOuterLeft()
Public Sub New
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Properties

The DockGuideOuterLeft type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterLeft.Side Property

DockGuideOuterLeftSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Methods

The DockGuideOuterLeft type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Events

The DockGuideOuterLeft type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterRight Class

Represents an outer right dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideOuterRight

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideOuterRight : DockGuideBase
Public Class DockGuideOuterRight
    Inherits DockGuideBase

The DockGuideOuterRight type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideOuterRight | Initializes an instance of the DockGuideOuterRight class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterRight Constructor

Initializes an instance of the DockGuideOuterRight class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideOuterRight()
Public Sub New
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterRight Properties

The DockGuideOuterRight type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterRight.Side Property

DockGuideOuterRightSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterRight Methods

The DockGuideOuterRight type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterRight Events

The DockGuideOuterRight type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterTop Class

Represents an outer top dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockGuideOuterTop

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockGuideOuterTop : DockGuideBase
Public Class DockGuideOuterTop
    Inherits DockGuideBase

The DockGuideOuterTop type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideOuterTop | Initializes an instance of the DockGuideOuterTop class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterTop Constructor

Initializes an instance of the DockGuideOuterTop class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockGuideOuterTop()
Public Sub New
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterTop Properties

The DockGuideOuterTop type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterTop.Side Property

DockGuideOuterTopSide Property

Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterTop Methods

The DockGuideOuterTop type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockGuideOuterTop Events

The DockGuideOuterTop type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Class

Represents the base class for a control that can contain multiple docking windows, with one selected.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockingWindowContainerBase
ActiproSoftware.Windows.Controls.DockingTabbedMdiContainer
ActiproSoftware.Windows.Controls.DockingToolWindowContainer

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DockingWindowContainerBase : Control,
    IOrientedElement
Public MustInherit Class DockingWindowContainerBase
    Inherits Control
    Implements IOrientedElement

The DockingWindowContainerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DockingWindowContainerBase | Initializes an instance of the DockingWindowContainerBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it.
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed.
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab.
Public property | MinTabExtent | Gets or sets the minimum extent of a tab.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container.
Public property | State | Gets the DockingWindowState that specifies the current state of the container.
Protected property | TabControl | Gets the tab control in the container's user interface.
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers.
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Protected property | WindowsCore | Gets the collection of child DockingWindow objects.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed.
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed.
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnWindowsChanged | Occurs when the ActiproSoftware.Windows collection is changed.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCommands | Updates the enabled states of the commands.
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows.
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property.
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility.
Protected method | UpdateVisualState | Updates the visual state.
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CanTabsCloseOnMiddleClickProperty | Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsTabLayoutAnimationEnabledProperty | Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.
IsTabLayoutAnimationEnabledResolvedProperty | Identifies the IsTabLayoutAnimationEnabledResolved dependency property. This field is read-only.
IsTabStripVisibleProperty | Identifies the IsTabStripVisible dependency property. This field is read-only.
MaxTabExtentProperty | Identifies the MaxTabExtent dependency property. This field is read-only.
MinTabExtentProperty | Identifies the MinTabExtent dependency property. This field is read-only.
SelectedWindowProperty | Identifies the SelectedWindow dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
TabControlStyleProperty | Identifies the TabControlStyle dependency property. This field is read-only.
TabItemContainerStyleProperty | Identifies the TabItemContainerStyle dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Constructor

Initializes an instance of the DockingWindowContainerBase class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DockingWindowContainerBase()
Protected Sub New
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Properties

The DockingWindowContainerBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it.
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed.
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab.
Public property | MinTabExtent | Gets or sets the minimum extent of a tab.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container.
Public property | State | Gets the DockingWindowState that specifies the current state of the container.
Protected property | TabControl | Gets the tab control in the container's user interface.
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers.
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Protected property | WindowsCore | Gets the collection of child DockingWindow objects.
Top
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.CanTabsCloseOnMiddleClick Property

DockingWindowContainerBaseCanTabsCloseOnMiddleClick Property

Gets or sets whether tabs can close when a middle-click is performed over them.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanTabsCloseOnMiddleClick { get; set; }
Public Property CanTabsCloseOnMiddleClick As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs can close when a middle-click is performed over them; otherwise, false. The default value is true.
Remarks
The CanClose property must also be set to true for this behavior to work.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.DockHost Property

DockingWindowContainerBaseDockHost Property

Gets the DockHost that contains this control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.DockSite Property

DockingWindowContainerBaseDockSite Property

Gets the DockSite that is managing this control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this control.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.HasTabImages Property

DockingWindowContainerBaseHasTabImages Property

Gets or sets whether tabs display an embedded image when one is available.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasTabImages { get; set; }
Public Property HasTabImages As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs display an embedded image when one is available; otherwise, false. The default value is false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsActive Property

DockingWindowContainerBaseIsActive Property

Gets whether the container is currently active, due to focus being within it.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
    Get

Property Value

Type: Boolean
true if the container is currently active, due to focus being within it; otherwise, false. The default value is false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabLayoutAnimationEnabled Property

DockingWindowContainerBaseIsTabLayoutAnimationEnabled Property

Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTabLayoutAnimationEnabled { get; set; }
Public Property IsTabLayoutAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if animation effects should be applied during tab layout, such as when tabs are added or removed; otherwise, false. The default value is false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabLayoutAnimationEnabledResolved Property

DockingWindowContainerBaseIsTabLayoutAnimationEnabledResolved Property

Gets whether animation effects are applied during tab layout, such as when tabs are added or removed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTabLayoutAnimationEnabledResolved { get; }
Public ReadOnly Property IsTabLayoutAnimationEnabledResolved As Boolean
    Get

Property Value

Type: Boolean
true if animation effects are applied during tab layout, such as when tabs are added or removed; otherwise, false. The default value is false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabStripVisible Property

DockingWindowContainerBaseIsTabStripVisible Property

Gets whether the tabstrip is visible.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTabStripVisible { get; protected set; }
Public Property IsTabStripVisible As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the tabstrip is visible; otherwise, false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.LogicalChildren Property

DockingWindowContainerBaseLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.MaxTabExtent Property

DockingWindowContainerBaseMaxTabExtent Property

Gets or sets the maximum extent of a tab.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MaxTabExtent { get; set; }
Public Property MaxTabExtent As Double
    Get
    Set

Property Value

Type: Double
The maximum extent of a tab. The default value is 260.0.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.MinTabExtent Property

DockingWindowContainerBaseMinTabExtent Property

Gets or sets the minimum extent of a tab.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MinTabExtent { get; set; }
Public Property MinTabExtent As Double
    Get
    Set

Property Value

Type: Double
The minimum extent of a tab. The default value is 30.0.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.SelectedWindow Property

DockingWindowContainerBaseSelectedWindow Property

Gets or sets the DockingWindow that is currently selected in the container.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindow SelectedWindow { get; set; }
Public Property SelectedWindow As DockingWindow
    Get
    Set

Property Value

Type: DockingWindow
The DockingWindow that is currently selected in the container.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.State Property

DockingWindowContainerBaseState Property

Gets the DockingWindowState that specifies the current state of the container.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowState State { get; }
Public ReadOnly Property State As DockingWindowState
    Get

Property Value

Type: DockingWindowState
The DockingWindowState that specifies the current state of the container.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabControl Property

DockingWindowContainerBaseTabControl Property

Gets the tab control in the container's user interface.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected AdvancedTabControl TabControl { get; }
Protected ReadOnly Property TabControl As AdvancedTabControl
    Get

Property Value

Type: AdvancedTabControl
The tab control in the container's user interface.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabControlStyle Property

DockingWindowContainerBaseTabControlStyle Property

Gets or sets the Style to use for the contained TabControl.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TabControlStyle { get; set; }
Public Property TabControlStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the contained TabControl.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabItemContainerStyle Property

DockingWindowContainerBaseTabItemContainerStyle Property

Gets or sets the Style to use for rendering the tab item containers.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TabItemContainerStyle { get; set; }
Public Property TabItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for rendering the tab item containers.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabOverflowBehavior Property

DockingWindowContainerBaseTabOverflowBehavior Property

Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabOverflowBehavior TabOverflowBehavior { get; set; }
Public Property TabOverflowBehavior As TabOverflowBehavior
    Get
    Set

Property Value

Type: TabOverflowBehavior
The TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. The default value is Shrink.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabStripPlacement Property

DockingWindowContainerBaseTabStripPlacement Property

Gets or sets a Side indicating the side upon which the tabs are located.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Side TabStripPlacement { get; set; }
Public Property TabStripPlacement As Side
    Get
    Set

Property Value

Type: Side
A Side indicating the side upon which the tabs are located. The default value is Bottom.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.WindowsCore Property

DockingWindowContainerBaseWindowsCore Property

Gets the collection of child DockingWindow objects.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ObservableCollection<DockingWindow> WindowsCore { get; }
Protected ReadOnly Property WindowsCore As ObservableCollection(Of DockingWindow)
    Get

Property Value

Type: ObservableCollection DockingWindow
The collection of child DockingWindow objects.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Methods

The DockingWindowContainerBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed.
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed.
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnWindowsChanged | Occurs when the ActiproSoftware.Windows collection is changed.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateCommands | Updates the enabled states of the commands.
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows.
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property.
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility.
Protected method | UpdateVisualState | Updates the visual state.
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnApplyTemplate Method

DockingWindowContainerBaseOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnDockSiteChanged Method

DockingWindowContainerBaseOnDockSiteChanged Method

Occurs when the DockSite property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDockSiteChanged(
    DockSite oldDockSite,
    DockSite newDockSite
)
Protected Overridable Sub OnDockSiteChanged (
    oldDockSite As DockSite,
    newDockSite As DockSite
)

Parameters

oldDockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The old value.
newDockSite
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The new value.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnIsKeyboardFocusWithinChanged Method

DockingWindowContainerBaseOnIsKeyboardFocusWithinChanged Method

Reports that the IsKeyboardFocusWithin property changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
A DependencyPropertyChangedEventArgs that contains the event data.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnSelectedWindowChanged Method

DockingWindowContainerBaseOnSelectedWindowChanged Method

Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSelectedWindowChanged(
    DockingWindow oldSelectedWindow,
    DockingWindow newSelectedWindow
)
Protected Overridable Sub OnSelectedWindowChanged (
    oldSelectedWindow As DockingWindow,
    newSelectedWindow As DockingWindow
)

Parameters

oldSelectedWindow
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The old selected window.
newSelectedWindow
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The new selected window.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnTabControlMenuOpening Method

DockingWindowContainerBaseOnTabControlMenuOpening Method

Occurs when a menu on the tab control is opening.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnTabControlMenuOpening(
    AdvancedTabControlMenuEventArgs e
)
Protected Overridable Sub OnTabControlMenuOpening (
    e As AdvancedTabControlMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingAdvancedTabControlMenuEventArgs
The AdvancedTabControlMenuEventArgs that contains the event data.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnWindowsChanged Method

DockingWindowContainerBaseOnWindowsChanged Method

Occurs when the ActiproSoftware.Windows collection is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overridable Sub OnWindowsChanged (
    e As NotifyCollectionChangedEventArgs
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
A NotifyCollectionChangedEventArgs that contains the event data.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.ToString Method

DockingWindowContainerBaseToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateCommands Method

DockingWindowContainerBaseUpdateCommands Method

Updates the enabled states of the commands.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateCommands()
Protected Overridable Sub UpdateCommands
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateDockingWindowStates Method

DockingWindowContainerBaseUpdateDockingWindowStates Method

Updates the DockingWindowState associated with all child docking windows.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void UpdateDockingWindowStates()
Protected MustOverride Sub UpdateDockingWindowStates
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateIsTabStripVisible Method

DockingWindowContainerBaseUpdateIsTabStripVisible Method

Updates the IsTabStripVisible property.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateIsTabStripVisible()
Protected Overridable Sub UpdateIsTabStripVisible
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateTitleBarButtonVisibility Method

DockingWindowContainerBaseUpdateTitleBarButtonVisibility Method

Updates the title bar button visibility.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateTitleBarButtonVisibility()
Protected Overridable Sub UpdateTitleBarButtonVisibility
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateVisualState Method

DockingWindowContainerBaseUpdateVisualState Method

Updates the visual state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateVisualState(
    bool useTransitions
)
Protected Overridable Sub UpdateVisualState (
    useTransitions As Boolean
)

Parameters

useTransitions
Type: SystemBoolean
Whether to use transitions.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.ValidateChildType Method

DockingWindowContainerBaseValidateChildType Method

Validates that the specified child DockingWindow type is valid for this container.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void ValidateChildType(
    DockingWindow window
)
Protected Overridable Sub ValidateChildType (
    window As DockingWindow
)

Parameters

window
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The DockingWindow to examine.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Events

The DockingWindowContainerBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Fields

The DockingWindowContainerBase type exposes the following members.

Fields
Name | Description
CanTabsCloseOnMiddleClickProperty | Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsTabLayoutAnimationEnabledProperty | Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.
IsTabLayoutAnimationEnabledResolvedProperty | Identifies the IsTabLayoutAnimationEnabledResolved dependency property. This field is read-only.
IsTabStripVisibleProperty | Identifies the IsTabStripVisible dependency property. This field is read-only.
MaxTabExtentProperty | Identifies the MaxTabExtent dependency property. This field is read-only.
MinTabExtentProperty | Identifies the MinTabExtent dependency property. This field is read-only.
SelectedWindowProperty | Identifies the SelectedWindow dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
TabControlStyleProperty | Identifies the TabControlStyle dependency property. This field is read-only.
TabItemContainerStyleProperty | Identifies the TabItemContainerStyle dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.CanTabsCloseOnMiddleClickProperty Field

DockingWindowContainerBaseCanTabsCloseOnMiddleClickProperty Field

Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsCloseOnMiddleClickProperty
Public Shared ReadOnly CanTabsCloseOnMiddleClickProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsCloseOnMiddleClick dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.HasTabImagesProperty Field

DockingWindowContainerBaseHasTabImagesProperty Field

Identifies the HasTabImages dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabImagesProperty
Public Shared ReadOnly HasTabImagesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabImages dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsActiveProperty Field

DockingWindowContainerBaseIsActiveProperty Field

Identifies the IsActive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsActiveProperty
Public Shared ReadOnly IsActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsActive dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabLayoutAnimationEnabledProperty Field

DockingWindowContainerBaseIsTabLayoutAnimationEnabledProperty Field

Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabLayoutAnimationEnabledProperty
Public Shared ReadOnly IsTabLayoutAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabLayoutAnimationEnabled dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabLayoutAnimationEnabledResolvedProperty Field

DockingWindowContainerBaseIsTabLayoutAnimationEnabledResolvedProperty Field

Identifies the IsTabLayoutAnimationEnabledResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabLayoutAnimationEnabledResolvedProperty
Public Shared ReadOnly IsTabLayoutAnimationEnabledResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabLayoutAnimationEnabledResolved dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabStripVisibleProperty Field

DockingWindowContainerBaseIsTabStripVisibleProperty Field

Identifies the IsTabStripVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabStripVisibleProperty
Public Shared ReadOnly IsTabStripVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabStripVisible dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.MaxTabExtentProperty Field

DockingWindowContainerBaseMaxTabExtentProperty Field

Identifies the MaxTabExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxTabExtentProperty
Public Shared ReadOnly MaxTabExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxTabExtent dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.MinTabExtentProperty Field

DockingWindowContainerBaseMinTabExtentProperty Field

Identifies the MinTabExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinTabExtentProperty
Public Shared ReadOnly MinTabExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinTabExtent dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.SelectedWindowProperty Field

DockingWindowContainerBaseSelectedWindowProperty Field

Identifies the SelectedWindow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedWindowProperty
Public Shared ReadOnly SelectedWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedWindow dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.StateProperty Field

DockingWindowContainerBaseStateProperty Field

Identifies the State dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StateProperty
Public Shared ReadOnly StateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the State dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabControlStyleProperty Field

DockingWindowContainerBaseTabControlStyleProperty Field

Identifies the TabControlStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabControlStyleProperty
Public Shared ReadOnly TabControlStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabControlStyle dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabItemContainerStyleProperty Field

DockingWindowContainerBaseTabItemContainerStyleProperty Field

Identifies the TabItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabItemContainerStyleProperty
Public Shared ReadOnly TabItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabItemContainerStyle dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabOverflowBehaviorProperty Field

DockingWindowContainerBaseTabOverflowBehaviorProperty Field

Identifies the TabOverflowBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabOverflowBehaviorProperty
Public Shared ReadOnly TabOverflowBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabOverflowBehavior dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabStripPlacementProperty Field

DockingWindowContainerBaseTabStripPlacementProperty Field

Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerTabItem Class

Represents an AdvancedTabItem for use within a DockingWindowContainerBase.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsHeaderedContentControl
System.Windows.ControlsTabItem
ActiproSoftware.Windows.Controls.DockingAdvancedTabItem
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockingWindowContainerTabItem

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowContainerTabItem : AdvancedTabItem
Public Class DockingWindowContainerTabItem
    Inherits AdvancedTabItem

The DockingWindowContainerTabItem type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowContainerTabItem | Initializes an instance of the DockingWindowContainerTabItem class.
Top
Properties
 | Name | Description
Public property | AreEmbeddedButtonsAlwaysVisible | Gets or sets whether embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabItem.)
Public property | ArrangeHeightAnimated | Gets or sets the arrange height of the tab. This property is for internal use only. (Inherited from AdvancedTabItem.)
Public property | ArrangeWidthAnimated | Gets or sets the arrange width of the tab. This property is for internal use only. (Inherited from AdvancedTabItem.)
Public property | ArrangeXAnimated | Gets or sets the arrange x-coordinate of the tab. This property is for internal use only. (Inherited from AdvancedTabItem.)
Public property | ArrangeYAnimated | Gets or sets the arrange y-coordinate of the tab. This property is for internal use only. (Inherited from AdvancedTabItem.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BackgroundActiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabItem.)
Public property | BackgroundInactiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabItem.)
Public property | BackgroundPointerOver | Gets or sets the control's background Brush to use when the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | BackgroundPreview | Gets or sets the control's background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabItem.)
Public property | BackgroundPreviewActiveSelected | Gets or sets the control's background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabItem.)
Public property | BackgroundPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderBrushActiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabItem.)
Public property | BorderBrushInactiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabItem.)
Public property | BorderBrushPointerOver | Gets or sets the control's border Brush to use when the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | BorderBrushPreview | Gets or sets the control's border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabItem.)
Public property | BorderBrushPreviewActiveSelected | Gets or sets the control's border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabItem.)
Public property | BorderBrushPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the tab displays an embedded close button. (Inherited from AdvancedTabItem.)
Public property | CanHighlightOnPointerOverWhenInactive | Gets or sets whether the tab can highlight when the pointer is over it and it is inactive. (Inherited from AdvancedTabItem.)
Public property | CanPin | Gets or sets whether the tab displays an embedded pin button. (Inherited from AdvancedTabItem.)
Public property | CanPromote | Gets or sets whether the tab displays an embedded promote from preview layout kind button. (Inherited from AdvancedTabItem.)
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content. (Inherited from AdvancedTabItem.)
Public property | CloseCommand | Gets the ICommand that can be used to close the tab. (Inherited from AdvancedTabItem.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets the contextual content to display. (Inherited from AdvancedTabItem.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content. (Inherited from AdvancedTabItem.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab. (Inherited from AdvancedTabItem.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabItem.)
Public property | FarSlantExtent | Gets or sets the far side slant extent of the tab. (Inherited from AdvancedTabItem.)
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled. (Inherited from AdvancedTabItem.)
Public property | FlashMode | Gets or sets the flash mode for the tab. (Inherited from AdvancedTabItem.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | ForegroundActiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabItem.)
Public property | ForegroundInactiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabItem.)
Public property | ForegroundPointerOver | Gets or sets the control's foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | ForegroundPreview | Gets or sets the control's foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabItem.)
Public property | ForegroundPreviewActiveSelected | Gets or sets the control's foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabItem.)
Public property | ForegroundPreviewPointerOver | Gets or sets the control's foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabItem.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets whether the tab has an embedded close button based on its current state. (Inherited from AdvancedTabItem.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasHeader | Gets a value that indicates whether the header is null. (Inherited from HeaderedContentControl.)
Public property | HasToggleLayoutKindButton | Gets whether the tab has an embedded toggle layout kind button based on its current state. (Inherited from AdvancedTabItem.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | HighlightKind | Gets a TabHighlightKind indicating the kind of highlight to apply to the tab. (Inherited from AdvancedTabItem.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets a ImageSource for an image that renders on the tab. (Inherited from AdvancedTabItem.)
Public property | IsCloseButtonVisible | Gets whether the embedded close button is visible. (Inherited from AdvancedTabItem.)
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation. (Inherited from AdvancedTabItem.)
Public property | IsImageVisible | Gets whether the embedded image is visible. (Inherited from AdvancedTabItem.)
Public property | IsLoadAnimationEnabled | Gets or sets whether animation effects may be applied when the tab is loaded. (Inherited from AdvancedTabItem.)
Public property | IsReadOnly | Gets or sets whether the tab's contents are read-only. (Inherited from AdvancedTabItem.)
Public property | IsSelected | Gets or sets a value that indicates whether the TabItem is selected. (Inherited from TabItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsToggleLayoutKindButtonVisible | Gets whether the embedded toggle layout kind button is visible. (Inherited from AdvancedTabItem.)
Public property | LayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned. (Inherited from AdvancedTabItem.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | NearSlantExtent | Gets or sets the near side slant extent of the tab. (Inherited from AdvancedTabItem.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content. (Inherited from AdvancedTabItem.)
Public property | PromoteButtonContentTemplate | Gets or sets the DataTemplate to use for the promote button content. (Inherited from AdvancedTabItem.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from AdvancedTabItem.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabStripPlacement | Gets the tab strip placement. (Inherited from TabItem.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes. (Inherited from AdvancedTabItem.)
Public property | ToggleLayoutKindCommand | Gets the ICommand that can be used to toggle the tab's layout kind. (Inherited from AdvancedTabItem.)
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content. (Inherited from AdvancedTabItem.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the tab, removing it from the containing tab control. (Inherited from AdvancedTabItem.)
Public method | DragMove | Starts a drag/move. (Inherited from AdvancedTabItem.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when an AccessKey for a TabControl is called. (Inherited from TabItem.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabItem.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from TabItem.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from TabItem.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from TabItem.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Inherited from AdvancedTabItem.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides AdvancedTabItemOnCreateAutomationPeer.)
Protected method | OnDragEnter | Occurs when a drag operation enters the control. (Inherited from AdvancedTabItem.)
Protected method | OnDragOver | Occurs when a drag operation moves over the control. (Inherited from AdvancedTabItem.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when the left mouse button is pressed. (Inherited from AdvancedTabItem.)
Protected method | OnPreviewGotKeyboardFocus | Occurs when the control gains keyboard focus. (Inherited from AdvancedTabItem.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelected | Occurs when the control is selected. (Inherited from AdvancedTabItem.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnUnselected | Occurs when the control is unselected. (Inherited from AdvancedTabItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToggleLayoutKind | Toggles the tab's LayoutKind. (Inherited from AdvancedTabItem.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerTabItem Constructor

Initializes an instance of the DockingWindowContainerTabItem class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowContainerTabItem()
Public Sub New
See Also

Reference

DockingWindowContainerTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerTabItem Properties

The DockingWindowContainerTabItem type exposes the following members.

Properties
 | Name | Description
Public property | AreEmbeddedButtonsAlwaysVisible | Gets or sets whether embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabItem.)
Public property | ArrangeHeightAnimated | Gets or sets the arrange height of the tab. This property is for internal use only. (Inherited from AdvancedTabItem.)
Public property | ArrangeWidthAnimated | Gets or sets the arrange width of the tab. This property is for internal use only. (Inherited from AdvancedTabItem.)
Public property | ArrangeXAnimated | Gets or sets the arrange x-coordinate of the tab. This property is for internal use only. (Inherited from AdvancedTabItem.)
Public property | ArrangeYAnimated | Gets or sets the arrange y-coordinate of the tab. This property is for internal use only. (Inherited from AdvancedTabItem.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BackgroundActiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabItem.)
Public property | BackgroundInactiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabItem.)
Public property | BackgroundPointerOver | Gets or sets the control's background Brush to use when the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | BackgroundPreview | Gets or sets the control's background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabItem.)
Public property | BackgroundPreviewActiveSelected | Gets or sets the control's background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabItem.)
Public property | BackgroundPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderBrushActiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabItem.)
Public property | BorderBrushInactiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabItem.)
Public property | BorderBrushPointerOver | Gets or sets the control's border Brush to use when the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | BorderBrushPreview | Gets or sets the control's border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabItem.)
Public property | BorderBrushPreviewActiveSelected | Gets or sets the control's border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabItem.)
Public property | BorderBrushPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the tab displays an embedded close button. (Inherited from AdvancedTabItem.)
Public property | CanHighlightOnPointerOverWhenInactive | Gets or sets whether the tab can highlight when the pointer is over it and it is inactive. (Inherited from AdvancedTabItem.)
Public property | CanPin | Gets or sets whether the tab displays an embedded pin button. (Inherited from AdvancedTabItem.)
Public property | CanPromote | Gets or sets whether the tab displays an embedded promote from preview layout kind button. (Inherited from AdvancedTabItem.)
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content. (Inherited from AdvancedTabItem.)
Public property | CloseCommand | Gets the ICommand that can be used to close the tab. (Inherited from AdvancedTabItem.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets the contextual content to display. (Inherited from AdvancedTabItem.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content. (Inherited from AdvancedTabItem.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab. (Inherited from AdvancedTabItem.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabItem.)
Public property | FarSlantExtent | Gets or sets the far side slant extent of the tab. (Inherited from AdvancedTabItem.)
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled. (Inherited from AdvancedTabItem.)
Public property | FlashMode | Gets or sets the flash mode for the tab. (Inherited from AdvancedTabItem.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | ForegroundActiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabItem.)
Public property | ForegroundInactiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabItem.)
Public property | ForegroundPointerOver | Gets or sets the control's foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabItem.)
Public property | ForegroundPreview | Gets or sets the control's foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabItem.)
Public property | ForegroundPreviewActiveSelected | Gets or sets the control's foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabItem.)
Public property | ForegroundPreviewPointerOver | Gets or sets the control's foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabItem.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets whether the tab has an embedded close button based on its current state. (Inherited from AdvancedTabItem.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasHeader | Gets a value that indicates whether the header is null. (Inherited from HeaderedContentControl.)
Public property | HasToggleLayoutKindButton | Gets whether the tab has an embedded toggle layout kind button based on its current state. (Inherited from AdvancedTabItem.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | HighlightKind | Gets a TabHighlightKind indicating the kind of highlight to apply to the tab. (Inherited from AdvancedTabItem.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets a ImageSource for an image that renders on the tab. (Inherited from AdvancedTabItem.)
Public property | IsCloseButtonVisible | Gets whether the embedded close button is visible. (Inherited from AdvancedTabItem.)
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation. (Inherited from AdvancedTabItem.)
Public property | IsImageVisible | Gets whether the embedded image is visible. (Inherited from AdvancedTabItem.)
Public property | IsLoadAnimationEnabled | Gets or sets whether animation effects may be applied when the tab is loaded. (Inherited from AdvancedTabItem.)
Public property | IsReadOnly | Gets or sets whether the tab's contents are read-only. (Inherited from AdvancedTabItem.)
Public property | IsSelected | Gets or sets a value that indicates whether the TabItem is selected. (Inherited from TabItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsToggleLayoutKindButtonVisible | Gets whether the embedded toggle layout kind button is visible. (Inherited from AdvancedTabItem.)
Public property | LayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned. (Inherited from AdvancedTabItem.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | NearSlantExtent | Gets or sets the near side slant extent of the tab. (Inherited from AdvancedTabItem.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content. (Inherited from AdvancedTabItem.)
Public property | PromoteButtonContentTemplate | Gets or sets the DataTemplate to use for the promote button content. (Inherited from AdvancedTabItem.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from AdvancedTabItem.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabStripPlacement | Gets the tab strip placement. (Inherited from TabItem.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes. (Inherited from AdvancedTabItem.)
Public property | ToggleLayoutKindCommand | Gets the ICommand that can be used to toggle the tab's layout kind. (Inherited from AdvancedTabItem.)
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content. (Inherited from AdvancedTabItem.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockingWindowContainerTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerTabItem Methods

The DockingWindowContainerTabItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the tab, removing it from the containing tab control. (Inherited from AdvancedTabItem.)
Public method | DragMove | Starts a drag/move. (Inherited from AdvancedTabItem.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when an AccessKey for a TabControl is called. (Inherited from TabItem.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabItem.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from TabItem.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from TabItem.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from TabItem.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Inherited from AdvancedTabItem.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides AdvancedTabItemOnCreateAutomationPeer.)
Protected method | OnDragEnter | Occurs when a drag operation enters the control. (Inherited from AdvancedTabItem.)
Protected method | OnDragOver | Occurs when a drag operation moves over the control. (Inherited from AdvancedTabItem.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when the left mouse button is pressed. (Inherited from AdvancedTabItem.)
Protected method | OnPreviewGotKeyboardFocus | Occurs when the control gains keyboard focus. (Inherited from AdvancedTabItem.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelected | Occurs when the control is selected. (Inherited from AdvancedTabItem.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnUnselected | Occurs when the control is unselected. (Inherited from AdvancedTabItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToggleLayoutKind | Toggles the tab's LayoutKind. (Inherited from AdvancedTabItem.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockingWindowContainerTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerTabItem.OnCreateAutomationPeer Method

DockingWindowContainerTabItemOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

DockingWindowContainerTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockingWindowContainerTabItem Events

The DockingWindowContainerTabItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockingWindowContainerTabItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockPreview Class

Represents a dock preview that shows when dragging over a dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesDockPreview

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockPreview : Control
Public Class DockPreview
    Inherits Control

The DockPreview type exposes the following members.

Constructors
 | Name | Description
Public method | DockPreview | Initializes an instance of the DockPreview class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Geometry | Gets or sets the preview geometry.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockPreview Constructor

Initializes an instance of the DockPreview class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockPreview()
Public Sub New
See Also

Reference

DockPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockPreview Properties

The DockPreview type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Geometry | Gets or sets the preview geometry.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DockPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockPreview.Geometry Property

DockPreviewGeometry Property

Gets or sets the preview geometry.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry Geometry { get; set; }
Public Property Geometry As Geometry
    Get
    Set

Property Value

Type: Geometry
The preview geometry.
See Also

Reference

DockPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockPreview Methods

The DockPreview type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DockPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockPreview Events

The DockPreview type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

DockPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockPreview Fields

The DockPreview type exposes the following members.

Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
Top
See Also

Reference

DockPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


DockPreview.GeometryProperty Field

DockPreviewGeometryProperty Field

Identifies the Geometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GeometryProperty
Public Shared ReadOnly GeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Geometry dependency property.
See Also

Reference

DockPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl Class

Represents a WindowControl that is used as the root control of a hosted floating window.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.DockingWindowControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesFloatingWindowControl

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FloatingWindowControl : WindowControl
Public Class FloatingWindowControl
    Inherits WindowControl

The FloatingWindowControl type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the window can close. (Inherited from WindowControl.)
Public property | CloseCommand | Gets the ICommand that can close the window. (Inherited from WindowControl.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title. (Inherited from WindowControl.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent. (Inherited from WindowControl.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window. (Inherited from WindowControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite that is managing the window.
Public property | DropShadowColor | Gets or sets the base Color to use for drawing the drop-shadow. (Inherited from WindowControl.)
Public property | DropShadowZOffset | Gets or sets the z-offset of the drop shadow. (Inherited from WindowControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button. (Inherited from WindowControl.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasDropShadow | Gets or sets whether the window has a drop shadow. (Inherited from WindowControl.)
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon. (Inherited from WindowControl.)
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button. (Inherited from WindowControl.)
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button. (Inherited from WindowControl.)
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button. (Inherited from WindowControl.)
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar. (Inherited from WindowControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon. (Inherited from WindowControl.)
Public property | IsActive | Gets whether the window is currently active. (Inherited from WindowControl.)
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible. (Inherited from WindowControl.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible. (Inherited from WindowControl.)
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized. (Inherited from WindowControl.)
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible. (Inherited from WindowControl.)
Public property | IsMoving | Gets whether the window is currently being dragged to move its location. (Inherited from WindowControl.)
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only. (Inherited from WindowControl.)
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size. (Inherited from WindowControl.)
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible. (Inherited from WindowControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTitleBarTextShadowEnabled | Gets or sets whether the title bar text should draw using a shadow. (Inherited from WindowControl.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container. (Inherited from WindowControl.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window. (Inherited from WindowControl.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window. (Inherited from WindowControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from WindowControl.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize. (Inherited from WindowControl.)
Public property | RestoreCommand | Gets the ICommand that can restore the window. (Inherited from WindowControl.)
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state. (Inherited from WindowControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window. (Inherited from WindowControl.)
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title. (Inherited from WindowControl.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container. (Inherited from WindowControl.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window. (Inherited from WindowControl.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Overrides WindowControlActivate.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window. (Inherited from WindowControl.)
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle. (Inherited from WindowControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism. (Overrides WindowControlGetAdjustedBounds(Rect, ResizeOperation).)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation. (Inherited from WindowControl.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnActivated | Called when the window gains focus within. (Overrides WindowControlOnActivated(RoutedEventArgs).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from WindowControl.)
Protected method | OnClosed | Called when the window is about to close. (Inherited from WindowControl.)
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure. (Overrides WindowControlOnClosing(CancelRoutedEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from WindowControl.)
Protected method | OnDeactivated | Called when the window loses focus within. (Overrides WindowControlOnDeactivated(RoutedEventArgs).)
Protected method | OnDragMoved | Called after the window has been moved from a drag. (Inherited from WindowControl.)
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Protected method | OnDragResized | Called after the window has been resized from a drag. (Inherited from WindowControl.)
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Inherited from WindowControl.)
Protected method | OnLocationChanged | Called when the window is moved. (Inherited from WindowControl.)
Protected method | OnLostKeyboardFocus | Occurs when a control within this control's hierarchy loses keyboard focus. (Inherited from WindowControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened. (Inherited from WindowControl.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed. (Inherited from WindowControl.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu. (Inherited from WindowControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | Show | Shows the window. (Inherited from WindowControl.)
Public method | ToggleWindowState | Toggles the window's state based on its current state. (Inherited from WindowControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the window gains focus within. (Inherited from WindowControl.)
Public event | Closed | Occurs when the window is about to close. (Inherited from WindowControl.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Public event | Deactivated | Occurs when the window loses focus within. (Inherited from WindowControl.)
Public event | DragMoved | Occurs after the window has been moved from a drag. (Inherited from WindowControl.)
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Public event | DragResized | Occurs after the window has been resized from a drag. (Inherited from WindowControl.)
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Public event | LocationChanged | Occurs when the window is moved. (Inherited from WindowControl.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | Opened | Occurs when the window is opened. (Inherited from WindowControl.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | StateChanged | Occurs after the window's WindowState property has changed. (Inherited from WindowControl.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu. (Inherited from WindowControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl Properties

The FloatingWindowControl type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the window can close. (Inherited from WindowControl.)
Public property | CloseCommand | Gets the ICommand that can close the window. (Inherited from WindowControl.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title. (Inherited from WindowControl.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent. (Inherited from WindowControl.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window. (Inherited from WindowControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite that is managing the window.
Public property | DropShadowColor | Gets or sets the base Color to use for drawing the drop-shadow. (Inherited from WindowControl.)
Public property | DropShadowZOffset | Gets or sets the z-offset of the drop shadow. (Inherited from WindowControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button. (Inherited from WindowControl.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasDropShadow | Gets or sets whether the window has a drop shadow. (Inherited from WindowControl.)
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon. (Inherited from WindowControl.)
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button. (Inherited from WindowControl.)
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button. (Inherited from WindowControl.)
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button. (Inherited from WindowControl.)
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar. (Inherited from WindowControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon. (Inherited from WindowControl.)
Public property | IsActive | Gets whether the window is currently active. (Inherited from WindowControl.)
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible. (Inherited from WindowControl.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible. (Inherited from WindowControl.)
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized. (Inherited from WindowControl.)
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible. (Inherited from WindowControl.)
Public property | IsMoving | Gets whether the window is currently being dragged to move its location. (Inherited from WindowControl.)
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only. (Inherited from WindowControl.)
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size. (Inherited from WindowControl.)
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible. (Inherited from WindowControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTitleBarTextShadowEnabled | Gets or sets whether the title bar text should draw using a shadow. (Inherited from WindowControl.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container. (Inherited from WindowControl.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window. (Inherited from WindowControl.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window. (Inherited from WindowControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from WindowControl.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize. (Inherited from WindowControl.)
Public property | RestoreCommand | Gets the ICommand that can restore the window. (Inherited from WindowControl.)
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state. (Inherited from WindowControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window. (Inherited from WindowControl.)
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title. (Inherited from WindowControl.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container. (Inherited from WindowControl.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window. (Inherited from WindowControl.)
Top
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl.DockSite Property

FloatingWindowControlDockSite Property

Gets the DockSite that is managing the window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing the window.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl Methods

The FloatingWindowControl type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Overrides WindowControlActivate.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window. (Inherited from WindowControl.)
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle. (Inherited from WindowControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism. (Overrides WindowControlGetAdjustedBounds(Rect, ResizeOperation).)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation. (Inherited from WindowControl.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnActivated | Called when the window gains focus within. (Overrides WindowControlOnActivated(RoutedEventArgs).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from WindowControl.)
Protected method | OnClosed | Called when the window is about to close. (Inherited from WindowControl.)
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure. (Overrides WindowControlOnClosing(CancelRoutedEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from WindowControl.)
Protected method | OnDeactivated | Called when the window loses focus within. (Overrides WindowControlOnDeactivated(RoutedEventArgs).)
Protected method | OnDragMoved | Called after the window has been moved from a drag. (Inherited from WindowControl.)
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Protected method | OnDragResized | Called after the window has been resized from a drag. (Inherited from WindowControl.)
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Inherited from WindowControl.)
Protected method | OnLocationChanged | Called when the window is moved. (Inherited from WindowControl.)
Protected method | OnLostKeyboardFocus | Occurs when a control within this control's hierarchy loses keyboard focus. (Inherited from WindowControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened. (Inherited from WindowControl.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed. (Inherited from WindowControl.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu. (Inherited from WindowControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | Show | Shows the window. (Inherited from WindowControl.)
Public method | ToggleWindowState | Toggles the window's state based on its current state. (Inherited from WindowControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl.Activate Method

FloatingWindowControlActivate Method

Attempts to bring the window to the foreground and activates it.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool Activate()
Public Overrides Function Activate As Boolean

Return Value

Type: Boolean
true if the window was successfully activated; otherwise, false.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl.GetAdjustedBounds Method

FloatingWindowControlGetAdjustedBounds Method

Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Rect GetAdjustedBounds(
    Rect bounds,
    ResizeOperation resizeOperation
)
Public Overrides Function GetAdjustedBounds (
    bounds As Rect,
    resizeOperation As ResizeOperation
) As Rect

Parameters

bounds
Type: System.WindowsRect
The bounds to examine.
resizeOperation
Type: ActiproSoftware.Windows.ControlsResizeOperation
The active resize operation.

Return Value

Type: Rect
The adjusted bounds.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl.OnActivated Method

FloatingWindowControlOnActivated Method

Called when the window gains focus within.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnActivated(
    RoutedEventArgs e
)
Protected Overrides Sub OnActivated (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl.OnClosing Method

FloatingWindowControlOnClosing Method

Called directly after Close is called, and can be handled to cancel window closure.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnClosing(
    CancelRoutedEventArgs e
)
Protected Overrides Sub OnClosing (
    e As CancelRoutedEventArgs
)

Parameters

e
Type: ActiproSoftware.WindowsCancelRoutedEventArgs
A CancelRoutedEventArgs that contains the event data.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl.OnDeactivated Method

FloatingWindowControlOnDeactivated Method

Called when the window loses focus within.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDeactivated(
    RoutedEventArgs e
)
Protected Overrides Sub OnDeactivated (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatingWindowControl Events

The FloatingWindowControl type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the window gains focus within. (Inherited from WindowControl.)
Public event | Closed | Occurs when the window is about to close. (Inherited from WindowControl.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Public event | Deactivated | Occurs when the window loses focus within. (Inherited from WindowControl.)
Public event | DragMoved | Occurs after the window has been moved from a drag. (Inherited from WindowControl.)
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Public event | DragResized | Occurs after the window has been resized from a drag. (Inherited from WindowControl.)
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Public event | LocationChanged | Occurs when the window is moved. (Inherited from WindowControl.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | Opened | Occurs when the window is opened. (Inherited from WindowControl.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | StateChanged | Occurs after the window's WindowState property has changed. (Inherited from WindowControl.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu. (Inherited from WindowControl.)
Top
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatPreview Class

Represents a float preview that can show when not dragging over a dock guide.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesFloatPreview

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FloatPreview : Control
Public Class FloatPreview
    Inherits Control

The FloatPreview type exposes the following members.

Constructors
 | Name | Description
Public method | FloatPreview | Initializes an instance of the FloatPreview class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatPreview Constructor

Initializes an instance of the FloatPreview class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FloatPreview()
Public Sub New
See Also

Reference

FloatPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatPreview Properties

The FloatPreview type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

FloatPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatPreview Methods

The FloatPreview type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

FloatPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


FloatPreview Events

The FloatPreview type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

FloatPreview Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase Class

Represents the base class for a container that hosts docking windows in a MDI (multiple-document interface).
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesMdiHostBase
ActiproSoftware.Windows.Controls.DockingStandardMdiHost
ActiproSoftware.Windows.Controls.DockingTabbedMdiHost

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class MdiHostBase : Control
Public MustInherit Class MdiHostBase
    Inherits Control

The MdiHostBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MdiHostBase | Initializes a new instance of the MdiHostBase class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents).
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetDocuments | Returns the list of docking windows within the MDI.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed.
Top
Fields
Name | Description
IsEmptyProperty | Identifies the IsEmpty dependency property. This field is read-only.
PrimaryWindowChangedEvent | Identifies the PrimaryWindowChanged routed event. This field is read-only.
PrimaryWindowProperty | Identifies the PrimaryWindow dependency property key. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase Constructor

Initializes a new instance of the MdiHostBase class

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MdiHostBase()
Protected Sub New
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase Properties

The MdiHostBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents).
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.DockHost Property

MdiHostBaseDockHost Property

Gets the DockHost that contains this control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.DockSite Property

MdiHostBaseDockSite Property

Gets the DockSite that is managing this control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this control.
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.IsEmpty Property

MdiHostBaseIsEmpty Property

Gets whether the host is currently empty (doesn't contain any visible documents).

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; protected set; }
Public Property IsEmpty As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the host is currently empty (doesn't contain any visible documents); otherwise, false. The default value is true.
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.PrimaryWindow Property

MdiHostBasePrimaryWindow Property

Gets the primary DockingWindow within the host.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindow PrimaryWindow { get; }
Public ReadOnly Property PrimaryWindow As DockingWindow
    Get

Property Value

Type: DockingWindow
The primary DockingWindow within the host. The default value is .
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase Methods

The MdiHostBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetDocuments | Returns the list of docking windows within the MDI.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.GetDocuments Method

MdiHostBaseGetDocuments Method

Returns the list of docking windows within the MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract IList<DockingWindow> GetDocuments()
Public MustOverride Function GetDocuments As IList(Of DockingWindow)

Return Value

Type: IList DockingWindow
The list of docking windows within the MDI.
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.OnApplyTemplate Method

MdiHostBaseOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.OnDockHostChanged Method

MdiHostBaseOnDockHostChanged Method

Occurs when the value of the DockHost property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDockHostChanged(
    DockHost oldValue,
    DockHost newValue
)
Protected Overridable Sub OnDockHostChanged (
    oldValue As DockHost,
    newValue As DockHost
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockHost
The new value.
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.OnPrimaryWindowChanged Method

MdiHostBaseOnPrimaryWindowChanged Method

Occurs when the value of the PrimaryWindow property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPrimaryWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overridable Sub OnPrimaryWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The new value.
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase Events

The MdiHostBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed.
Top
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.PrimaryWindowChanged Event

MdiHostBasePrimaryWindowChanged Event

Occurs when PrimaryWindow is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> PrimaryWindowChanged
Public Event PrimaryWindowChanged As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase Fields

The MdiHostBase type exposes the following members.

Fields
Name | Description
IsEmptyProperty | Identifies the IsEmpty dependency property. This field is read-only.
PrimaryWindowChangedEvent | Identifies the PrimaryWindowChanged routed event. This field is read-only.
PrimaryWindowProperty | Identifies the PrimaryWindow dependency property key. This field is read-only.
Top
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.IsEmptyProperty Field

MdiHostBaseIsEmptyProperty Field

Identifies the IsEmpty dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEmptyProperty
Public Shared ReadOnly IsEmptyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEmpty dependency property.
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.PrimaryWindowChangedEvent Field

MdiHostBasePrimaryWindowChangedEvent Field

Identifies the PrimaryWindowChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent PrimaryWindowChangedEvent
Public Shared ReadOnly PrimaryWindowChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the PrimaryWindowChanged routed event.
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


MdiHostBase.PrimaryWindowProperty Field

MdiHostBasePrimaryWindowProperty Field

Identifies the PrimaryWindow dependency property key. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PrimaryWindowProperty
Public Shared ReadOnly PrimaryWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PrimaryWindow dependency property key.
See Also

Reference

MdiHostBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton Class

Represents a new tab button.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.Controls.PrimitivesButtonBase
System.Windows.ControlsButton
ActiproSoftware.Windows.Controls.Docking.PrimitivesNewTabButton

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NewTabButton : Button
Public Class NewTabButton
    Inherits Button

The NewTabButton type exposes the following members.

Constructors
 | Name | Description
Public method | NewTabButton | Initializes an instance of the NewTabButton class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | CornerRadius | Gets or sets the corner radius of the button border, relative to a top-facing tab.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation.
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
IsContentHorizontalProperty | Identifies the IsContentHorizontal dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton Constructor

Initializes an instance of the NewTabButton class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NewTabButton()
Public Sub New
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton Properties

The NewTabButton type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | CornerRadius | Gets or sets the corner radius of the button border, relative to a top-facing tab.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation.
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton.CornerRadius Property

NewTabButtonCornerRadius Property

Gets or sets the corner radius of the button border, relative to a top-facing tab.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the button border, relative to a top-facing tab.
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton.IsContentHorizontal Property

NewTabButtonIsContentHorizontal Property

Gets or sets whether the content layout is in a horizontal orientation.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsContentHorizontal { get; set; }
Public Property IsContentHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the content layout is in a horizontal orientation; otherwise, false. The default value is true.
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton.TabStripPlacement Property

NewTabButtonTabStripPlacement Property

Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Dock TabStripPlacement { get; set; }
Public Property TabStripPlacement As Dock
    Get
    Set

Property Value

Type: Dock
The side upon which the tabstrip is placed.
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton Methods

The NewTabButton type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton Events

The NewTabButton type exposes the following members.

Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton Fields

The NewTabButton type exposes the following members.

Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
IsContentHorizontalProperty | Identifies the IsContentHorizontal dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton.CornerRadiusProperty Field

NewTabButtonCornerRadiusProperty Field

Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton.IsContentHorizontalProperty Field

NewTabButtonIsContentHorizontalProperty Field

Identifies the IsContentHorizontal dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsContentHorizontalProperty
Public Shared ReadOnly IsContentHorizontalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsContentHorizontal dependency property.
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NewTabButton.TabStripPlacementProperty Field

NewTabButtonTabStripPlacementProperty Field

Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

NewTabButton Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NonUIElementConverter Class

Represents a value converter that only passes through a value if it isn't a UIElement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Docking.PrimitivesNonUIElementConverter

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class NonUIElementConverter : IValueConverter
Public NotInheritable Class NonUIElementConverter
    Implements IValueConverter

The NonUIElementConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NonUIElementConverter | Initializes a new instance of the NonUIElementConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NonUIElementConverter Constructor

Initializes a new instance of the NonUIElementConverter class

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NonUIElementConverter()
Public Sub New
See Also

Reference

NonUIElementConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NonUIElementConverter Methods

The NonUIElementConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

NonUIElementConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NonUIElementConverter.Convert Method

NonUIElementConverterConvert Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

NonUIElementConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


NonUIElementConverter.ConvertBack Method

NonUIElementConverterConvertBack Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

NonUIElementConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SideToDockConverter Class

Represents a value converter that converts between a side and a Dock.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Docking.PrimitivesSideToDockConverter

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class SideToDockConverter : IValueConverter
Public NotInheritable Class SideToDockConverter
    Implements IValueConverter

The SideToDockConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SideToDockConverter | Initializes a new instance of the SideToDockConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SideToDockConverter Constructor

Initializes a new instance of the SideToDockConverter class

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SideToDockConverter()
Public Sub New
See Also

Reference

SideToDockConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SideToDockConverter Methods

The SideToDockConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

SideToDockConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SideToDockConverter.Convert Method

SideToDockConverterConvert Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

SideToDockConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SideToDockConverter.ConvertBack Method

SideToDockConverterConvertBack Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

SideToDockConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel Class

Represents a Panel that is used by a SplitContainer.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Docking.PrimitivesSplitContainerPanel

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SplitContainerPanel : Panel,
    IOrientedElement
Public Class SplitContainerPanel
    Inherits Panel
    Implements IOrientedElement

The SplitContainerPanel type exposes the following members.

Constructors
 | Name | Description
Public method | SplitContainerPanel | Initializes an instance of the SplitContainerPanel class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | SlotElements | Gets the collection of slot elements.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetSlotLength | Gets the value of the SlotLength attached property for the specified object.
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetSlotLength | Sets the value of the SlotLength attached property to the specified object.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SlotLengthProperty | Identifies the SlotLength dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | SlotLength |
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel Constructor

Initializes an instance of the SplitContainerPanel class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SplitContainerPanel()
Public Sub New
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel Properties

The SplitContainerPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | SlotElements | Gets the collection of slot elements.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel.Orientation Property

SplitContainerPanelOrientation Property

Gets or sets the Orientation of the child element layout.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Horizontal.

Implements

IOrientedElementOrientation
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel.SlotElements Property

SplitContainerPanelSlotElements Property

Gets the collection of slot elements.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DeferrableObservableCollection<UIElement> SlotElements { get; }
Public ReadOnly Property SlotElements As DeferrableObservableCollection(Of UIElement)
    Get

Property Value

Type: DeferrableObservableCollection UIElement
The collection of slot elements.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel Methods

The SplitContainerPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetSlotLength | Gets the value of the SlotLength attached property for the specified object.
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetSlotLength | Sets the value of the SlotLength attached property to the specified object.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel.ArrangeOverride Method

SplitContainerPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel.GetSlotLength Method

SplitContainerPanelGetSlotLength Method

Gets the value of the SlotLength attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetSlotLength(
    DependencyObject obj
)
Public Shared Function GetSlotLength (
    obj As DependencyObject
) As Double

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Double
The object's value.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel.MeasureOverride Method

SplitContainerPanelMeasureOverride Method

Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel.SetSlotLength Method

SplitContainerPanelSetSlotLength Method

Sets the value of the SlotLength attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetSlotLength(
    DependencyObject obj,
    double value
)
Public Shared Sub SetSlotLength (
    obj As DependencyObject,
    value As Double
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemDouble
The value to set.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel Fields

The SplitContainerPanel type exposes the following members.

Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SlotLengthProperty | Identifies the SlotLength dependency property. This field is read-only.
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel.OrientationProperty Field

SplitContainerPanelOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel.SlotLengthProperty Field

SplitContainerPanelSlotLengthProperty Field

Identifies the SlotLength dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotLengthProperty
Public Shared ReadOnly SlotLengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotLength dependency property.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel Attached Properties

The SplitContainerPanel type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | SlotLength |
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerPanel.SlotLength Attached Property

SplitContainerPanelSlotLength Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Docking.Primitives.SplitContainerPanel.SlotLength"]

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetSlotLength, SetSlotLength
See GetSlotLength, SetSlotLength

Property Value

Type: Double
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerSplitter Class

Represents a splitter within a SplitContainer.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesSplitterBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesSplitContainerSplitter

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SplitContainerSplitter : SplitterBase,
    IOrientedElement
Public Class SplitContainerSplitter
    Inherits SplitterBase
    Implements IOrientedElement

The SplitContainerSplitter type exposes the following members.

Constructors
 | Name | Description
Public method | SplitContainerSplitter | Initializes an instance of the SplitContainerSplitter class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted. (Inherited from SplitterBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the splitter. (Inherited from SplitterBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from SplitterBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerSplitter Constructor

Initializes an instance of the SplitContainerSplitter class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SplitContainerSplitter()
Public Sub New
See Also

Reference

SplitContainerSplitter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerSplitter Properties

The SplitContainerSplitter type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted. (Inherited from SplitterBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the splitter. (Inherited from SplitterBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SplitContainerSplitter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerSplitter Methods

The SplitContainerSplitter type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from SplitterBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

SplitContainerSplitter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitContainerSplitter Events

The SplitContainerSplitter type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

SplitContainerSplitter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase Class

Represents an abstract base class for a splitter.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesSplitterBase
ActiproSoftware.Windows.Controls.Docking.PrimitivesAutoHideContainerSplitter
ActiproSoftware.Windows.Controls.Docking.PrimitivesSplitContainerSplitter

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class SplitterBase : Control
Public MustInherit Class SplitterBase
    Inherits Control

The SplitterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SplitterBase | Initializes an instance of the SplitterBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the splitter.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
IsHighlightedProperty | Identifies the IsHighlighted dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase Constructor

Initializes an instance of the SplitterBase class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected SplitterBase()
Protected Sub New
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase Properties

The SplitterBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the splitter.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase.IsHighlighted Property

SplitterBaseIsHighlighted Property

Gets or sets whether the splitter is currently highlighted.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsHighlighted { get; set; }
Public Property IsHighlighted As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the splitter is currently highlighted; otherwise, false. The default value is false.
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase.Orientation Property

SplitterBaseOrientation Property

Gets or sets the Orientation of the splitter.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the splitter. The default value is Horizontal.
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase Methods

The SplitterBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase.OnApplyTemplate Method

SplitterBaseOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase Events

The SplitterBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase Fields

The SplitterBase type exposes the following members.

Fields
Name | Description
IsHighlightedProperty | Identifies the IsHighlighted dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase.IsHighlightedProperty Field

SplitterBaseIsHighlightedProperty Field

Identifies the IsHighlighted dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHighlightedProperty
Public Shared ReadOnly IsHighlightedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHighlighted dependency property.
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SplitterBase.OrientationProperty Field

SplitterBaseOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

SplitterBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Class

Represents an ItemsControl that displays standard MDI windows.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesStandardMdiItemsControl

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StandardMdiItemsControl : ItemsControl
Public Class StandardMdiItemsControl
    Inherits ItemsControl

The StandardMdiItemsControl type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiItemsControl | Initializes an instance of the StandardMdiItemsControl class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Constructor

Initializes an instance of the StandardMdiItemsControl class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StandardMdiItemsControl()
Public Sub New
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Properties

The StandardMdiItemsControl type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Methods

The StandardMdiItemsControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiItemsControl.ClearContainerForItemOverride Method

StandardMdiItemsControlClearContainerForItemOverride Method

Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiItemsControl.GetContainerForItemOverride Method

StandardMdiItemsControlGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiItemsControl.IsItemItsOwnContainerOverride Method

StandardMdiItemsControlIsItemItsOwnContainerOverride Method

Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiItemsControl.PrepareContainerForItemOverride Method

StandardMdiItemsControlPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Events

The StandardMdiItemsControl type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiPanel Class

Represents a Panel that is used by a StandardMdiItemsControl.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Docking.PrimitivesStandardMdiPanel

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StandardMdiPanel : Panel
Public Class StandardMdiPanel
    Inherits Panel

The StandardMdiPanel type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiPanel | Initializes a new instance of the StandardMdiPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiPanel Constructor

Initializes a new instance of the StandardMdiPanel class

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StandardMdiPanel()
Public Sub New
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiPanel Properties

The StandardMdiPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiPanel Methods

The StandardMdiPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiPanel.ArrangeOverride Method

StandardMdiPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiPanel.MeasureOverride Method

StandardMdiPanelMeasureOverride Method

Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Class

Represents a WindowControl that is used as the root control of a hosted floating window.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.DockingWindowControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesStandardMdiWindowControl

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StandardMdiWindowControl : WindowControl
Public Class StandardMdiWindowControl
    Inherits WindowControl

The StandardMdiWindowControl type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiWindowControl | Initializes an instance of the StandardMdiWindowControl class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the window can close. (Inherited from WindowControl.)
Public property | CloseCommand | Gets the ICommand that can close the window. (Inherited from WindowControl.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title. (Inherited from WindowControl.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent. (Inherited from WindowControl.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window. (Inherited from WindowControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockingWindow | Gets the DockingWindow that is wrapped by this control.
Public property | DockSite | Gets the DockSite that is managing this docking window.
Public property | DropShadowColor | Gets or sets the base Color to use for drawing the drop-shadow. (Inherited from WindowControl.)
Public property | DropShadowZOffset | Gets or sets the z-offset of the drop shadow. (Inherited from WindowControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button. (Inherited from WindowControl.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasDropShadow | Gets or sets whether the window has a drop shadow. (Inherited from WindowControl.)
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon. (Inherited from WindowControl.)
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button. (Inherited from WindowControl.)
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button. (Inherited from WindowControl.)
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button. (Inherited from WindowControl.)
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar. (Inherited from WindowControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon. (Inherited from WindowControl.)
Public property | IsActive | Gets whether the window is currently active. (Inherited from WindowControl.)
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible. (Inherited from WindowControl.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible. (Inherited from WindowControl.)
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized. (Inherited from WindowControl.)
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible. (Inherited from WindowControl.)
Public property | IsMoving | Gets whether the window is currently being dragged to move its location. (Inherited from WindowControl.)
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only. (Inherited from WindowControl.)
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size. (Inherited from WindowControl.)
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible. (Inherited from WindowControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTitleBarTextShadowEnabled | Gets or sets whether the title bar text should draw using a shadow. (Inherited from WindowControl.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container. (Inherited from WindowControl.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window. (Inherited from WindowControl.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window. (Inherited from WindowControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from WindowControl.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize. (Inherited from WindowControl.)
Public property | RestoreCommand | Gets the ICommand that can restore the window. (Inherited from WindowControl.)
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state. (Inherited from WindowControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window. (Inherited from WindowControl.)
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title. (Inherited from WindowControl.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container. (Inherited from WindowControl.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window. (Inherited from WindowControl.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from WindowControl.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window. (Inherited from WindowControl.)
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle. (Inherited from WindowControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism. (Overrides WindowControlGetAdjustedBounds(Rect, ResizeOperation).)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation. (Inherited from WindowControl.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnActivated | Called when the window gains focus within. (Overrides WindowControlOnActivated(RoutedEventArgs).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from WindowControl.)
Protected method | OnClosed | Called when the window is about to close. (Overrides WindowControlOnClosed(RoutedEventArgs).)
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Protected method | OnContentChanged | Occurs when the content changes. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from WindowControl.)
Protected method | OnDeactivated | Called when the window loses focus within. (Inherited from WindowControl.)
Protected method | OnDragMoved | Called after the window has been moved from a drag. (Inherited from WindowControl.)
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Protected method | OnDragResized | Called after the window has been resized from a drag. (Inherited from WindowControl.)
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Inherited from WindowControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnLocationChanged | Called when the window is moved. (Overrides WindowControlOnLocationChanged(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Occurs when a control within this control's hierarchy loses keyboard focus. (Inherited from WindowControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened. (Inherited from WindowControl.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed. (Overrides WindowControlOnStateChanged(RoutedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu. (Overrides WindowControlOnTitleBarMenuOpening(DockingMenuEventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | Show | Shows the window. (Inherited from WindowControl.)
Public method | ToggleWindowState | Toggles the window's state based on its current state. (Inherited from WindowControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the window gains focus within. (Inherited from WindowControl.)
Public event | Closed | Occurs when the window is about to close. (Inherited from WindowControl.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Public event | Deactivated | Occurs when the window loses focus within. (Inherited from WindowControl.)
Public event | DragMoved | Occurs after the window has been moved from a drag. (Inherited from WindowControl.)
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Public event | DragResized | Occurs after the window has been resized from a drag. (Inherited from WindowControl.)
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Public event | LocationChanged | Occurs when the window is moved. (Inherited from WindowControl.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | Opened | Occurs when the window is opened. (Inherited from WindowControl.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | StateChanged | Occurs after the window's WindowState property has changed. (Inherited from WindowControl.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu. (Inherited from WindowControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Constructor

Initializes an instance of the StandardMdiWindowControl class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StandardMdiWindowControl()
Public Sub New
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Properties

The StandardMdiWindowControl type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanClose | Gets or sets whether the window can close. (Inherited from WindowControl.)
Public property | CloseCommand | Gets the ICommand that can close the window. (Inherited from WindowControl.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title. (Inherited from WindowControl.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent. (Inherited from WindowControl.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window. (Inherited from WindowControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockingWindow | Gets the DockingWindow that is wrapped by this control.
Public property | DockSite | Gets the DockSite that is managing this docking window.
Public property | DropShadowColor | Gets or sets the base Color to use for drawing the drop-shadow. (Inherited from WindowControl.)
Public property | DropShadowZOffset | Gets or sets the z-offset of the drop shadow. (Inherited from WindowControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button. (Inherited from WindowControl.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HasDropShadow | Gets or sets whether the window has a drop shadow. (Inherited from WindowControl.)
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon. (Inherited from WindowControl.)
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button. (Inherited from WindowControl.)
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button. (Inherited from WindowControl.)
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button. (Inherited from WindowControl.)
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar. (Inherited from WindowControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon. (Inherited from WindowControl.)
Public property | IsActive | Gets whether the window is currently active. (Inherited from WindowControl.)
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible. (Inherited from WindowControl.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible. (Inherited from WindowControl.)
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized. (Inherited from WindowControl.)
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible. (Inherited from WindowControl.)
Public property | IsMoving | Gets whether the window is currently being dragged to move its location. (Inherited from WindowControl.)
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only. (Inherited from WindowControl.)
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size. (Inherited from WindowControl.)
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible. (Inherited from WindowControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTitleBarTextShadowEnabled | Gets or sets whether the title bar text should draw using a shadow. (Inherited from WindowControl.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container. (Inherited from WindowControl.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window. (Inherited from WindowControl.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window. (Inherited from WindowControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from WindowControl.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize. (Inherited from WindowControl.)
Public property | RestoreCommand | Gets the ICommand that can restore the window. (Inherited from WindowControl.)
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state. (Inherited from WindowControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window. (Inherited from WindowControl.)
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title. (Inherited from WindowControl.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container. (Inherited from WindowControl.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window. (Inherited from WindowControl.)
Top
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.DockHost Property

StandardMdiWindowControlDockHost Property

Gets the DockHost that contains this control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.DockingWindow Property

StandardMdiWindowControlDockingWindow Property

Gets the DockingWindow that is wrapped by this control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindow DockingWindow { get; }
Public ReadOnly Property DockingWindow As DockingWindow
    Get

Property Value

Type: DockingWindow
The DockingWindow that is wrapped by this control.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.DockSite Property

StandardMdiWindowControlDockSite Property

Gets the DockSite that is managing this docking window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this docking window.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Methods

The StandardMdiWindowControl type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from WindowControl.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the window. (Inherited from WindowControl.)
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle. (Inherited from WindowControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism. (Overrides WindowControlGetAdjustedBounds(Rect, ResizeOperation).)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation. (Inherited from WindowControl.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnActivated | Called when the window gains focus within. (Overrides WindowControlOnActivated(RoutedEventArgs).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from WindowControl.)
Protected method | OnClosed | Called when the window is about to close. (Overrides WindowControlOnClosed(RoutedEventArgs).)
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Protected method | OnContentChanged | Occurs when the content changes. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from WindowControl.)
Protected method | OnDeactivated | Called when the window loses focus within. (Inherited from WindowControl.)
Protected method | OnDragMoved | Called after the window has been moved from a drag. (Inherited from WindowControl.)
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Protected method | OnDragResized | Called after the window has been resized from a drag. (Inherited from WindowControl.)
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Inherited from WindowControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnLocationChanged | Called when the window is moved. (Overrides WindowControlOnLocationChanged(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Occurs when a control within this control's hierarchy loses keyboard focus. (Inherited from WindowControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened. (Inherited from WindowControl.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed. (Overrides WindowControlOnStateChanged(RoutedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu. (Overrides WindowControlOnTitleBarMenuOpening(DockingMenuEventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | Show | Shows the window. (Inherited from WindowControl.)
Public method | ToggleWindowState | Toggles the window's state based on its current state. (Inherited from WindowControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.GetAdjustedBounds Method

StandardMdiWindowControlGetAdjustedBounds Method

Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Rect GetAdjustedBounds(
    Rect bounds,
    ResizeOperation resizeOperation
)
Public Overrides Function GetAdjustedBounds (
    bounds As Rect,
    resizeOperation As ResizeOperation
) As Rect

Parameters

bounds
Type: System.WindowsRect
The bounds to examine.
resizeOperation
Type: ActiproSoftware.Windows.ControlsResizeOperation
The active resize operation.

Return Value

Type: Rect
The adjusted bounds.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnActivated Method

StandardMdiWindowControlOnActivated Method

Called when the window gains focus within.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnActivated(
    RoutedEventArgs e
)
Protected Overrides Sub OnActivated (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnClosed Method

StandardMdiWindowControlOnClosed Method

Called when the window is about to close.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnClosed(
    RoutedEventArgs e
)
Protected Overrides Sub OnClosed (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnContentChanged Method

StandardMdiWindowControlOnContentChanged Method

Occurs when the content changes.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Protected Overrides Sub OnContentChanged (
    oldContent As Object,
    newContent As Object
)

Parameters

oldContent
Type: SystemObject
The old content.
newContent
Type: SystemObject
The new content.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnIsKeyboardFocusWithinChanged Method

StandardMdiWindowControlOnIsKeyboardFocusWithinChanged Method

Reports that the IsKeyboardFocusWithin property changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
A DependencyPropertyChangedEventArgs that contains the event data.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnLocationChanged Method

StandardMdiWindowControlOnLocationChanged Method

Called when the window is moved.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLocationChanged(
    RoutedEventArgs e
)
Protected Overrides Sub OnLocationChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnStateChanged Method

StandardMdiWindowControlOnStateChanged Method

Called after the window's WindowState property has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnStateChanged(
    RoutedEventArgs e
)
Protected Overrides Sub OnStateChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs that contains the event data.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnTitleBarMenuOpening Method

StandardMdiWindowControlOnTitleBarMenuOpening Method

Called when the title-bar should display a context menu.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnTitleBarMenuOpening(
    DockingMenuEventArgs e
)
Protected Overrides Sub OnTitleBarMenuOpening (
    e As DockingMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.DockingDockingMenuEventArgs
A DockingMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Events

The StandardMdiWindowControl type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the window gains focus within. (Inherited from WindowControl.)
Public event | Closed | Occurs when the window is about to close. (Inherited from WindowControl.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Public event | Deactivated | Occurs when the window loses focus within. (Inherited from WindowControl.)
Public event | DragMoved | Occurs after the window has been moved from a drag. (Inherited from WindowControl.)
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Public event | DragResized | Occurs after the window has been resized from a drag. (Inherited from WindowControl.)
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Public event | LocationChanged | Occurs when the window is moved. (Inherited from WindowControl.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | Opened | Occurs when the window is opened. (Inherited from WindowControl.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | StateChanged | Occurs after the window's WindowState property has changed. (Inherited from WindowControl.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu. (Inherited from WindowControl.)
Top
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem Class

Represents an item in a StandardSwitcher.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesStandardSwitcherItem

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StandardSwitcherItem : ContentControl
Public Class StandardSwitcherItem
    Inherits ContentControl

The StandardSwitcherItem type exposes the following members.

Constructors
 | Name | Description
Public method | StandardSwitcherItem | Initializes a new instance of the StandardSwitcherItem class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the item is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Occurs when the content is changed. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem Constructor

Initializes a new instance of the StandardSwitcherItem class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StandardSwitcherItem()
Public Sub New
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem Properties

The StandardSwitcherItem type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets whether the item is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem.IsSelected Property

StandardSwitcherItemIsSelected Property

Gets or sets whether the item is selected.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is selected; otherwise, false.
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem Methods

The StandardSwitcherItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Occurs when the content is changed. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem.OnApplyTemplate Method

StandardSwitcherItemOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem.OnContentChanged Method

StandardSwitcherItemOnContentChanged Method

Occurs when the content is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Protected Overrides Sub OnContentChanged (
    oldContent As Object,
    newContent As Object
)

Parameters

oldContent
Type: SystemObject
The old content.
newContent
Type: SystemObject
The new content.
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem.OnCreateAutomationPeer Method

StandardSwitcherItemOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem Events

The StandardSwitcherItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem Fields

The StandardSwitcherItem type exposes the following members.

Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


StandardSwitcherItem.IsSelectedProperty Field

StandardSwitcherItemIsSelectedProperty Field

Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase Class

Provides the base class for a component that provides Ctrl+Tab-like switching of docking windows.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesSwitcherBase
ActiproSoftware.Windows.Controls.DockingSimpleSwitcher
ActiproSoftware.Windows.Controls.DockingStandardSwitcher

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class SwitcherBase : Control
Public MustInherit Class SwitcherBase
    Inherits Control

The SwitcherBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SwitcherBase | Initializes a new instance of the SwitcherBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active.
Public property | Documents | Gets the collection of open documents in the MDI area.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOpen | Gets whether the switcher is currently open and active.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected.
Public property | SelectNextDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextDocument method by default.
Public property | SelectNextToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextToolWindow method by default.
Public property | SelectPreviousDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousDocument method by default.
Public property | SelectPreviousToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousToolWindow method by default.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the switcher.
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnClosed | Invoked when the switcher is closed.
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Occurs when a key is released. (Overrides UIElementOnKeyUp(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened.
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SelectNextDocument | Selects the next document in the switcher.
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher.
Protected method | SelectPreviousDocument | Selects the previous document in the switcher.
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
DockSiteProperty | Identifies the DockSite dependency property. This field is read-only.
IsOpenProperty | Identifies the IsOpen dependency property. This field is read-only.
SelectedWindowProperty | Identifies the SelectedWindow dependency property. This field is read-only.
SelectNextDocumentKeyGestureProperty | Identifies the SelectNextDocumentKeyGesture dependency property. This field is read-only.
SelectNextToolWindowKeyGestureProperty | Identifies the SelectNextToolWindowKeyGesture dependency property. This field is read-only.
SelectPreviousDocumentKeyGestureProperty | Identifies the SelectPreviousDocumentKeyGesture dependency property. This field is read-only.
SelectPreviousToolWindowKeyGestureProperty | Identifies the SelectPreviousToolWindowKeyGesture dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase Constructor

Initializes a new instance of the SwitcherBase class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected SwitcherBase(
    bool canSortByLastFocusedDateTime
)
Protected Sub New (
    canSortByLastFocusedDateTime As Boolean
)

Parameters

canSortByLastFocusedDateTime
Type: SystemBoolean
Whether to sort docking windows by last focused date/time.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase Properties

The SwitcherBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active.
Public property | Documents | Gets the collection of open documents in the MDI area.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOpen | Gets whether the switcher is currently open and active.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected.
Public property | SelectNextDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextDocument method by default.
Public property | SelectNextToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectNextToolWindow method by default.
Public property | SelectPreviousDocumentKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousDocument method by default.
Public property | SelectPreviousToolWindowKeyGesture | Gets or sets the KeyGesture that is used to invoke the SelectPreviousToolWindow method by default.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.DockSite Property

SwitcherBaseDockSite Property

Gets the DockSite for which the switcher is currently active.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite for which the switcher is currently active.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.Documents Property

SwitcherBaseDocuments Property

Gets the collection of open documents in the MDI area.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyDockingWindowCollection Documents { get; }
Public ReadOnly Property Documents As ReadOnlyDockingWindowCollection
    Get

Property Value

Type: ReadOnlyDockingWindowCollection
The collection of open documents in the MDI area.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.IsOpen Property

SwitcherBaseIsOpen Property

Gets whether the switcher is currently open and active.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOpen { get; }
Public ReadOnly Property IsOpen As Boolean
    Get

Property Value

Type: Boolean
true if the switcher is currently open and active; otherwise, false.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectedWindow Property

SwitcherBaseSelectedWindow Property

Gets or sets the DockingWindow that is currently selected.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindow SelectedWindow { get; set; }
Public Property SelectedWindow As DockingWindow
    Get
    Set

Property Value

Type: DockingWindow
The DockingWindow that is currently selected.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectNextDocumentKeyGesture Property

SwitcherBaseSelectNextDocumentKeyGesture Property

Gets or sets the KeyGesture that is used to invoke the SelectNextDocument method by default.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public KeyGesture SelectNextDocumentKeyGesture { get; set; }
Public Property SelectNextDocumentKeyGesture As KeyGesture
    Get
    Set

Property Value

Type: KeyGesture
The KeyGesture that is used to invoke the SelectNextDocument method by default. The default value is Ctrl+Tab.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectNextToolWindowKeyGesture Property

SwitcherBaseSelectNextToolWindowKeyGesture Property

Gets or sets the KeyGesture that is used to invoke the SelectNextToolWindow method by default.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public KeyGesture SelectNextToolWindowKeyGesture { get; set; }
Public Property SelectNextToolWindowKeyGesture As KeyGesture
    Get
    Set

Property Value

Type: KeyGesture
The KeyGesture that is used to invoke the SelectNextToolWindow method by default. The default value is Alt+F7.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectPreviousDocumentKeyGesture Property

SwitcherBaseSelectPreviousDocumentKeyGesture Property

Gets or sets the KeyGesture that is used to invoke the SelectPreviousDocument method by default.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public KeyGesture SelectPreviousDocumentKeyGesture { get; set; }
Public Property SelectPreviousDocumentKeyGesture As KeyGesture
    Get
    Set

Property Value

Type: KeyGesture
The KeyGesture that is used to invoke the SelectPreviousDocument method by default. The default value is Ctrl+Shift+Tab.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectPreviousToolWindowKeyGesture Property

SwitcherBaseSelectPreviousToolWindowKeyGesture Property

Gets or sets the KeyGesture that is used to invoke the SelectPreviousToolWindow method by default.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public KeyGesture SelectPreviousToolWindowKeyGesture { get; set; }
Public Property SelectPreviousToolWindowKeyGesture As KeyGesture
    Get
    Set

Property Value

Type: KeyGesture
The KeyGesture that is used to invoke the SelectPreviousToolWindow method by default. The default value is Shift+Alt+F7.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.ToolWindows Property

SwitcherBaseToolWindows Property

Gets the collection of open tool windows that are not in the MDI area.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyToolWindowCollection ToolWindows { get; }
Public ReadOnly Property ToolWindows As ReadOnlyToolWindowCollection
    Get

Property Value

Type: ReadOnlyToolWindowCollection
The collection of open tool windows that are not in the MDI area.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase Methods

The SwitcherBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Close | Closes the switcher.
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnClosed | Invoked when the switcher is closed.
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Occurs when a key is released. (Overrides UIElementOnKeyUp(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened.
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SelectNextDocument | Selects the next document in the switcher.
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher.
Protected method | SelectPreviousDocument | Selects the previous document in the switcher.
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.Close Method

SwitcherBaseClose Method

Closes the switcher.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.CreatePopup Method

SwitcherBaseCreatePopup Method

Creates a Popup that can be used to host this switcher.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Popup CreatePopup()
Protected Overridable Function CreatePopup As Popup

Return Value

Type: Popup
The Popup that was created.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.IsActivationKey Method

SwitcherBaseIsActivationKey Method

Returns whether the specified key is a key combination that can activate the switcher.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsActivationKey(
    KeyEventArgs e
)
Protected Overridable Function IsActivationKey (
    e As KeyEventArgs
) As Boolean

Parameters

e
Type: System.Windows.InputKeyEventArgs
A KeyEventArgs that contains the event data.

Return Value

Type: Boolean
true if the key combination can activate the switcher; otherwise, false.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.OnClosed Method

SwitcherBaseOnClosed Method

Invoked when the switcher is closed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnClosed()
Protected Overridable Sub OnClosed
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.OnKeyDown Method

SwitcherBaseOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.OnKeyUp Method

SwitcherBaseOnKeyUp Method

Occurs when a key is released.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyUp(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyUp (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
A KeyEventArgs that contains the event data.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.OnLostFocus Method

SwitcherBaseOnLostFocus Method

Occurs when the control loses focus.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.OnOpened Method

SwitcherBaseOnOpened Method

Invoked when the switcher is opened.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnOpened()
Protected Overridable Sub OnOpened
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.OnSelectedWindowChanged Method

SwitcherBaseOnSelectedWindowChanged Method

Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSelectedWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overridable Sub OnSelectedWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The new value.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectNextDocument Method

SwitcherBaseSelectNextDocument Method

Selects the next document in the switcher.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void SelectNextDocument()
Protected Overridable Sub SelectNextDocument
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectNextToolWindow Method

SwitcherBaseSelectNextToolWindow Method

Selects the next tool window in the switcher.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void SelectNextToolWindow()
Protected Overridable Sub SelectNextToolWindow
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectPreviousDocument Method

SwitcherBaseSelectPreviousDocument Method

Selects the previous document in the switcher.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void SelectPreviousDocument()
Protected Overridable Sub SelectPreviousDocument
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectPreviousToolWindow Method

SwitcherBaseSelectPreviousToolWindow Method

Selects the previous tool window in the switcher.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void SelectPreviousToolWindow()
Protected Overridable Sub SelectPreviousToolWindow
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase Events

The SwitcherBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase Fields

The SwitcherBase type exposes the following members.

Fields
Name | Description
DockSiteProperty | Identifies the DockSite dependency property. This field is read-only.
IsOpenProperty | Identifies the IsOpen dependency property. This field is read-only.
SelectedWindowProperty | Identifies the SelectedWindow dependency property. This field is read-only.
SelectNextDocumentKeyGestureProperty | Identifies the SelectNextDocumentKeyGesture dependency property. This field is read-only.
SelectNextToolWindowKeyGestureProperty | Identifies the SelectNextToolWindowKeyGesture dependency property. This field is read-only.
SelectPreviousDocumentKeyGestureProperty | Identifies the SelectPreviousDocumentKeyGesture dependency property. This field is read-only.
SelectPreviousToolWindowKeyGestureProperty | Identifies the SelectPreviousToolWindowKeyGesture dependency property. This field is read-only.
Top
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.DockSiteProperty Field

SwitcherBaseDockSiteProperty Field

Identifies the DockSite dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DockSiteProperty
Public Shared ReadOnly DockSiteProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DockSite dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.IsOpenProperty Field

SwitcherBaseIsOpenProperty Field

Identifies the IsOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOpenProperty
Public Shared ReadOnly IsOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOpen dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectedWindowProperty Field

SwitcherBaseSelectedWindowProperty Field

Identifies the SelectedWindow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedWindowProperty
Public Shared ReadOnly SelectedWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedWindow dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectNextDocumentKeyGestureProperty Field

SwitcherBaseSelectNextDocumentKeyGestureProperty Field

Identifies the SelectNextDocumentKeyGesture dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectNextDocumentKeyGestureProperty
Public Shared ReadOnly SelectNextDocumentKeyGestureProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectNextDocumentKeyGesture dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectNextToolWindowKeyGestureProperty Field

SwitcherBaseSelectNextToolWindowKeyGestureProperty Field

Identifies the SelectNextToolWindowKeyGesture dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectNextToolWindowKeyGestureProperty
Public Shared ReadOnly SelectNextToolWindowKeyGestureProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectNextToolWindowKeyGesture dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectPreviousDocumentKeyGestureProperty Field

SwitcherBaseSelectPreviousDocumentKeyGestureProperty Field

Identifies the SelectPreviousDocumentKeyGesture dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectPreviousDocumentKeyGestureProperty
Public Shared ReadOnly SelectPreviousDocumentKeyGestureProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectPreviousDocumentKeyGesture dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


SwitcherBase.SelectPreviousToolWindowKeyGestureProperty Field

SwitcherBaseSelectPreviousToolWindowKeyGestureProperty Field

Identifies the SelectPreviousToolWindowKeyGesture dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectPreviousToolWindowKeyGestureProperty
Public Shared ReadOnly SelectPreviousToolWindowKeyGestureProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectPreviousToolWindowKeyGesture dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Class

Represents an AdvancedTabControl for use within a TabbedMdiContainer.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsTabControl
ActiproSoftware.Windows.Controls.DockingAdvancedTabControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesTabbedMdiContainerTabControl

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TabbedMdiContainerTabControl : AdvancedTabControl
Public Class TabbedMdiContainerTabControl
    Inherits AdvancedTabControl

The TabbedMdiContainerTabControl type exposes the following members.

Constructors
 | Name | Description
Public method | TabbedMdiContainerTabControl | Initializes an instance of the TabbedMdiContainerTabControl class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible. (Inherited from AdvancedTabControl.)
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported. (Inherited from AdvancedTabControl.)
Public property | CanScrollForward | Gets whether scrolling forward is supported. (Inherited from AdvancedTabControl.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from AdvancedTabControl.)
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled. (Inherited from AdvancedTabControl.)
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones. (Inherited from AdvancedTabControl.)
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button. (Inherited from AdvancedTabControl.)
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button. (Inherited from AdvancedTabControl.)
Public property | CanTabsSelectOnDragOver | Gets or sets whether tabs can be selected when performing a system (e.g. text, file) drag over them. (Inherited from AdvancedTabControl.)
Public property | ContentStringFormat | Gets a composite string that specifies how to format the contents of the TabItem objects if they are displayed as strings. (Inherited from TabControl.)
Public property | ContentTemplate | Gets or sets the DataTemplate to apply to any TabItem that does not have a ContentTemplate or ContentTemplateSelector property defined. (Inherited from TabControl.)
Public property | ContentTemplateSelector | Gets or sets a DataTemplateSelector that provides custom logic for choosing the template that is used to display the content of the control. (Inherited from TabControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available. (Inherited from AdvancedTabControl.)
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button. (Inherited from AdvancedTabControl.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus. (Inherited from AdvancedTabControl.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed. (Inherited from AdvancedTabControl.)
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible. (Inherited from AdvancedTabControl.)
Public property | IsOverflowed | Gets whether the tabs are overflowed. (Inherited from AdvancedTabControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible. (Inherited from AdvancedTabControl.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button. (Inherited from AdvancedTabControl.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu. (Inherited from AdvancedTabControl.)
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab. (Inherited from AdvancedTabControl.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward. (Inherited from AdvancedTabControl.)
Public property | ScrollOffset | Gets the scroll offset. (Inherited from AdvancedTabControl.)
Public property | SelectedContent | Gets the content of the currently selected TabItem. (Inherited from TabControl.)
Public property | SelectedContentStringFormat | Gets a composite string that specifies how to format the content of the currently selected TabItem if it is displayed as a string. (Inherited from TabControl.)
Public property | SelectedContentTemplate | Gets the DataTemplate of the currently selected item. (Inherited from TabControl.)
Public property | SelectedContentTemplateSelector | Gets the DataTemplateSelector of the currently selected item. (Inherited from TabControl.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item. (Inherited from AdvancedTabControl.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab. (Inherited from AdvancedTabControl.)
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs. (Inherited from AdvancedTabControl.)
Public property | TabFarSlantExtent | Gets or sets the far side slant extent of the tabs. (Inherited from AdvancedTabControl.)
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabNearSlantExtent | Gets or sets the near side slant extent of the tabs. (Inherited from AdvancedTabControl.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from AdvancedTabControl.)
Public property | TabPadding | Gets or sets the tab padding. (Inherited from AdvancedTabControl.)
Public property | TabSpacing | Gets or sets the spacing between tabs. (Inherited from AdvancedTabControl.)
Public property | TabStripPlacement | Gets or sets how tab headers align relative to the tab content. (Inherited from TabControl.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDefaultFocusHandling | Gets or sets whether to use default TabItem focus handling. (Inherited from AdvancedTabControl.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from AdvancedTabControl.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides AdvancedTabControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides AdvancedTabControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Inherited from AdvancedTabControl.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from AdvancedTabControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Called when IsInitialized is set to true. (Inherited from TabControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called to update the current selection when items change. (Inherited from TabControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from AdvancedTabControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Occurs when the control's size is changed. (Inherited from AdvancedTabControl.)
Protected method | OnSelectionChanged | Occurs when the selection has changed. (Overrides AdvancedTabControlOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides AdvancedTabControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab. (Overrides AdvancedTabControlUpdateHighlightBrushes.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MenuOpening | Occurs before a context or drop-down menu is opening. (Inherited from AdvancedTabControl.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | NewTabRequested | Occurs when a new tab is requested. (Inherited from AdvancedTabControl.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button. (Inherited from AdvancedTabControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Constructor

Initializes an instance of the TabbedMdiContainerTabControl class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabbedMdiContainerTabControl()
Public Sub New
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Properties

The TabbedMdiContainerTabControl type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible. (Inherited from AdvancedTabControl.)
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported. (Inherited from AdvancedTabControl.)
Public property | CanScrollForward | Gets whether scrolling forward is supported. (Inherited from AdvancedTabControl.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from AdvancedTabControl.)
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled. (Inherited from AdvancedTabControl.)
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones. (Inherited from AdvancedTabControl.)
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button. (Inherited from AdvancedTabControl.)
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button. (Inherited from AdvancedTabControl.)
Public property | CanTabsSelectOnDragOver | Gets or sets whether tabs can be selected when performing a system (e.g. text, file) drag over them. (Inherited from AdvancedTabControl.)
Public property | ContentStringFormat | Gets a composite string that specifies how to format the contents of the TabItem objects if they are displayed as strings. (Inherited from TabControl.)
Public property | ContentTemplate | Gets or sets the DataTemplate to apply to any TabItem that does not have a ContentTemplate or ContentTemplateSelector property defined. (Inherited from TabControl.)
Public property | ContentTemplateSelector | Gets or sets a DataTemplateSelector that provides custom logic for choosing the template that is used to display the content of the control. (Inherited from TabControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available. (Inherited from AdvancedTabControl.)
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button. (Inherited from AdvancedTabControl.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus. (Inherited from AdvancedTabControl.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed. (Inherited from AdvancedTabControl.)
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible. (Inherited from AdvancedTabControl.)
Public property | IsOverflowed | Gets whether the tabs are overflowed. (Inherited from AdvancedTabControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible. (Inherited from AdvancedTabControl.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button. (Inherited from AdvancedTabControl.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu. (Inherited from AdvancedTabControl.)
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab. (Inherited from AdvancedTabControl.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward. (Inherited from AdvancedTabControl.)
Public property | ScrollOffset | Gets the scroll offset. (Inherited from AdvancedTabControl.)
Public property | SelectedContent | Gets the content of the currently selected TabItem. (Inherited from TabControl.)
Public property | SelectedContentStringFormat | Gets a composite string that specifies how to format the content of the currently selected TabItem if it is displayed as a string. (Inherited from TabControl.)
Public property | SelectedContentTemplate | Gets the DataTemplate of the currently selected item. (Inherited from TabControl.)
Public property | SelectedContentTemplateSelector | Gets the DataTemplateSelector of the currently selected item. (Inherited from TabControl.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item. (Inherited from AdvancedTabControl.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab. (Inherited from AdvancedTabControl.)
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs. (Inherited from AdvancedTabControl.)
Public property | TabFarSlantExtent | Gets or sets the far side slant extent of the tabs. (Inherited from AdvancedTabControl.)
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabNearSlantExtent | Gets or sets the near side slant extent of the tabs. (Inherited from AdvancedTabControl.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from AdvancedTabControl.)
Public property | TabPadding | Gets or sets the tab padding. (Inherited from AdvancedTabControl.)
Public property | TabSpacing | Gets or sets the spacing between tabs. (Inherited from AdvancedTabControl.)
Public property | TabStripPlacement | Gets or sets how tab headers align relative to the tab content. (Inherited from TabControl.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDefaultFocusHandling | Gets or sets whether to use default TabItem focus handling. (Inherited from AdvancedTabControl.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Methods

The TabbedMdiContainerTabControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from AdvancedTabControl.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides AdvancedTabControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides AdvancedTabControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Inherited from AdvancedTabControl.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from AdvancedTabControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Called when IsInitialized is set to true. (Inherited from TabControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called to update the current selection when items change. (Inherited from TabControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from AdvancedTabControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Occurs when the control's size is changed. (Inherited from AdvancedTabControl.)
Protected method | OnSelectionChanged | Occurs when the selection has changed. (Overrides AdvancedTabControlOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides AdvancedTabControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab. (Overrides AdvancedTabControlUpdateHighlightBrushes.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl.ClearContainerForItemOverride Method

TabbedMdiContainerTabControlClearContainerForItemOverride Method

Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl.GetContainerForItemOverride Method

TabbedMdiContainerTabControlGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl.OnSelectionChanged Method

TabbedMdiContainerTabControlOnSelectionChanged Method

Occurs when the selection has changed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnSelectionChanged(
    SelectionChangedEventArgs e
)
Protected Overrides Sub OnSelectionChanged (
    e As SelectionChangedEventArgs
)

Parameters

e
Type: System.Windows.ControlsSelectionChangedEventArgs
The SelectionChangedEventArgs containing arguments related to this event.
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl.PrepareContainerForItemOverride Method

TabbedMdiContainerTabControlPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl.UpdateHighlightBrushes Method

TabbedMdiContainerTabControlUpdateHighlightBrushes Method

Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateHighlightBrushes()
Protected Overrides Sub UpdateHighlightBrushes
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Events

The TabbedMdiContainerTabControl type exposes the following members.

Events
 | Name | Description
Public event | MenuOpening | Occurs before a context or drop-down menu is opening. (Inherited from AdvancedTabControl.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | NewTabRequested | Occurs when a new tab is requested. (Inherited from AdvancedTabControl.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button. (Inherited from AdvancedTabControl.)
Top
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder Class

Renders a border for a tab item.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsDecorator
ActiproSoftware.Windows.Controls.Docking.PrimitivesTabItemBorder

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TabItemBorder : Decorator
Public Class TabItemBorder
    Inherits Decorator

The TabItemBorder type exposes the following members.

Constructors
 | Name | Description
Public method | TabItemBorder | Initializes a new instance of the TabItemBorder class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the Brush that specifies how the tab's interior is painted.
Public property | BorderBrush | Gets or sets the Brush that specifies how the tab's outline is painted.
Public property | BorderThickness | Gets or sets the width of the tab's outline.
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FarSlantExtent | Gets or sets the far side slant extent of the tab.
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled.
Public property | FlashMode | Gets or sets the flash mode for the tab.
Public property | IsSelected | Gets or sets whether the tab is selected.
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | NearSlantExtent | Gets or sets the near side slant extent of the tab.
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes.
Public property | UntintedBackground | Gets or sets the untinted Brush that specifies how the tab's interior is painted.
Public property | UntintedBorderBrush | Gets or sets the untinted Brush that specifies how the tab's outline is painted.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides DecoratorArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides DecoratorMeasureOverride(Size).)
Protected method | OnRender | Occurs when the element is rendered. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderThicknessProperty | Identifies the BorderThickness dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
FarSlantExtentProperty | Identifies the FarSlantExtent dependency property. This field is read-only.
FlashColorProperty | Identifies the FlashColor dependency property. This field is read-only.
FlashModeProperty | Identifies the FlashMode dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
NearSlantExtentProperty | Identifies the NearSlantExtent dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
TintColorProperty | Identifies the TintColor dependency property. This field is read-only.
UntintedBackgroundProperty | Identifies the UntintedBackground dependency property. This field is read-only.
UntintedBorderBrushProperty | Identifies the UntintedBorderBrush dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder Constructor

Initializes a new instance of the TabItemBorder class

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabItemBorder()
Public Sub New
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder Properties

The TabItemBorder type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the Brush that specifies how the tab's interior is painted.
Public property | BorderBrush | Gets or sets the Brush that specifies how the tab's outline is painted.
Public property | BorderThickness | Gets or sets the width of the tab's outline.
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FarSlantExtent | Gets or sets the far side slant extent of the tab.
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled.
Public property | FlashMode | Gets or sets the flash mode for the tab.
Public property | IsSelected | Gets or sets whether the tab is selected.
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | NearSlantExtent | Gets or sets the near side slant extent of the tab.
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes.
Public property | UntintedBackground | Gets or sets the untinted Brush that specifies how the tab's interior is painted.
Public property | UntintedBorderBrush | Gets or sets the untinted Brush that specifies how the tab's outline is painted.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.Background Property

TabItemBorderBackground Property

Gets or sets the Brush that specifies how the tab's interior is painted.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Background { get; set; }
Public Property Background As Brush
    Get
    Set

Property Value

Type: Brush
The Brush that specifies how the tab's interior is painted.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.BorderBrush Property

TabItemBorderBorderBrush Property

Gets or sets the Brush that specifies how the tab's outline is painted.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrush { get; set; }
Public Property BorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush that specifies how the tab's outline is painted.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.BorderThickness Property

TabItemBorderBorderThickness Property

Gets or sets the width of the tab's outline.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness BorderThickness { get; set; }
Public Property BorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The width of the tab's outline.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.CornerRadius Property

TabItemBorderCornerRadius Property

Gets or sets the corner radius of the tab border, relative to a top-facing tab.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the tab border, relative to a top-facing tab.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.FarSlantExtent Property

TabItemBorderFarSlantExtent Property

Gets or sets the far side slant extent of the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double FarSlantExtent { get; set; }
Public Property FarSlantExtent As Double
    Get
    Set

Property Value

Type: Double
The far side slant extent of the tab, or 0.0 for no slant. The default value is 0.0.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.FlashColor Property

TabItemBorderFlashColor Property

Gets or sets the flash color to use if flashing is enabled.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color FlashColor { get; set; }
Public Property FlashColor As Color
    Get
    Set

Property Value

Type: Color
The flash color to use if flashing is enabled. The default value is #80FFA000.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.FlashMode Property

TabItemBorderFlashMode Property

Gets or sets the flash mode for the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabFlashMode FlashMode { get; set; }
Public Property FlashMode As TabFlashMode
    Get
    Set

Property Value

Type: TabFlashMode
The flash mode for the tab.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.IsSelected Property

TabItemBorderIsSelected Property

Gets or sets whether the tab is selected.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab is selected; otherwise, false.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.NearSlantExtent Property

TabItemBorderNearSlantExtent Property

Gets or sets the near side slant extent of the tab.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double NearSlantExtent { get; set; }
Public Property NearSlantExtent As Double
    Get
    Set

Property Value

Type: Double
The near side slant extent of the tab, or 0.0 for no slant. The default value is 0.0.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.TabStripPlacement Property

TabItemBorderTabStripPlacement Property

Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Dock TabStripPlacement { get; set; }
Public Property TabStripPlacement As Dock
    Get
    Set

Property Value

Type: Dock
The side upon which the tabstrip is placed.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.TintColor Property

TabItemBorderTintColor Property

Gets or sets the tint color applied to the Background and BorderBrush brushes.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color TintColor { get; set; }
Public Property TintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color applied to the Background and BorderBrush brushes. The default value is Transparent, which indicates no tinting should be applied.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.UntintedBackground Property

TabItemBorderUntintedBackground Property

Gets or sets the untinted Brush that specifies how the tab's interior is painted.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush UntintedBackground { get; set; }
Public Property UntintedBackground As Brush
    Get
    Set

Property Value

Type: Brush
The untinted Brush that specifies how the tab's interior is painted.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.UntintedBorderBrush Property

TabItemBorderUntintedBorderBrush Property

Gets or sets the untinted Brush that specifies how the tab's outline is painted.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush UntintedBorderBrush { get; set; }
Public Property UntintedBorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The untinted Brush that specifies how the tab's outline is painted.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder Methods

The TabItemBorder type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides DecoratorArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides DecoratorMeasureOverride(Size).)
Protected method | OnRender | Occurs when the element is rendered. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.ArrangeOverride Method

TabItemBorderArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.MeasureOverride Method

TabItemBorderMeasureOverride Method

Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.OnRender Method

TabItemBorderOnRender Method

Occurs when the element is rendered.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The DrawingContext to use.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder Fields

The TabItemBorder type exposes the following members.

Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderThicknessProperty | Identifies the BorderThickness dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
FarSlantExtentProperty | Identifies the FarSlantExtent dependency property. This field is read-only.
FlashColorProperty | Identifies the FlashColor dependency property. This field is read-only.
FlashModeProperty | Identifies the FlashMode dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
NearSlantExtentProperty | Identifies the NearSlantExtent dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
TintColorProperty | Identifies the TintColor dependency property. This field is read-only.
UntintedBackgroundProperty | Identifies the UntintedBackground dependency property. This field is read-only.
UntintedBorderBrushProperty | Identifies the UntintedBorderBrush dependency property. This field is read-only.
Top
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.BackgroundProperty Field

TabItemBorderBackgroundProperty Field

Identifies the Background dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundProperty
Public Shared ReadOnly BackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Background dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.BorderBrushProperty Field

TabItemBorderBorderBrushProperty Field

Identifies the BorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushProperty
Public Shared ReadOnly BorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrush dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.BorderThicknessProperty Field

TabItemBorderBorderThicknessProperty Field

Identifies the BorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderThicknessProperty
Public Shared ReadOnly BorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderThickness dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.CornerRadiusProperty Field

TabItemBorderCornerRadiusProperty Field

Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.FarSlantExtentProperty Field

TabItemBorderFarSlantExtentProperty Field

Identifies the FarSlantExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FarSlantExtentProperty
Public Shared ReadOnly FarSlantExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FarSlantExtent dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.FlashColorProperty Field

TabItemBorderFlashColorProperty Field

Identifies the FlashColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FlashColorProperty
Public Shared ReadOnly FlashColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FlashColor dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.FlashModeProperty Field

TabItemBorderFlashModeProperty Field

Identifies the FlashMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FlashModeProperty
Public Shared ReadOnly FlashModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FlashMode dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.IsSelectedProperty Field

TabItemBorderIsSelectedProperty Field

Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.NearSlantExtentProperty Field

TabItemBorderNearSlantExtentProperty Field

Identifies the NearSlantExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NearSlantExtentProperty
Public Shared ReadOnly NearSlantExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NearSlantExtent dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.TabStripPlacementProperty Field

TabItemBorderTabStripPlacementProperty Field

Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.TintColorProperty Field

TabItemBorderTintColorProperty Field

Identifies the TintColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TintColorProperty
Public Shared ReadOnly TintColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TintColor dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.UntintedBackgroundProperty Field

TabItemBorderUntintedBackgroundProperty Field

Identifies the UntintedBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UntintedBackgroundProperty
Public Shared ReadOnly UntintedBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UntintedBackground dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TabItemBorder.UntintedBorderBrushProperty Field

TabItemBorderUntintedBorderBrushProperty Field

Identifies the UntintedBorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UntintedBorderBrushProperty
Public Shared ReadOnly UntintedBorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UntintedBorderBrush dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel Class

Represents a Panel within a title bar.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Docking.PrimitivesTitleBarPanel

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TitleBarPanel : Panel
Public Class TitleBarPanel
    Inherits Panel

The TitleBarPanel type exposes the following members.

Constructors
 | Name | Description
Public method | TitleBarPanel | Initializes a new instance of the TitleBarPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | ContextContentAlignment | Gets or sets the alignment of context content.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetIsContextContent | Gets the value of the IsContextContent attached property for the specified object.
 | GetIsFiller | Gets the value of the IsFiller attached property for the specified object.
 | GetIsHeader | Gets the value of the IsHeader attached property for the specified object.
 | GetIsIcon | Gets the value of the IsIcon attached property for the specified object.
 | GetIsReadOnlyContextContent | Gets the value of the IsReadOnlyContextContent attached property for the specified object.
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetIsContextContent | Sets the value of the IsContextContent attached property to the specified object.
 | SetIsFiller | Sets the value of the IsFiller attached property to the specified object.
 | SetIsHeader | Sets the value of the IsHeader attached property to the specified object.
 | SetIsIcon | Sets the value of the IsIcon attached property to the specified object.
 | SetIsReadOnlyContextContent | Sets the value of the IsReadOnlyContextContent attached property to the specified object.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
ContextContentAlignmentProperty | Identifies the ContextContentAlignment dependency property. This field is read-only.
IsContextContentProperty | Identifies the IsContextContent dependency property. This field is read-only.
IsFillerProperty | Identifies the IsFiller dependency property. This field is read-only.
IsHeaderProperty | Identifies the IsHeader dependency property. This field is read-only.
IsIconProperty | Identifies the IsIcon dependency property. This field is read-only.
IsReadOnlyContextContentProperty | Identifies the IsReadOnlyContextContent dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | IsContextContent |
Public attached property | IsFiller |
Public attached property | IsHeader |
Public attached property | IsIcon |
Public attached property | IsReadOnlyContextContent |
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel Constructor

Initializes a new instance of the TitleBarPanel class

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TitleBarPanel()
Public Sub New
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel Properties

The TitleBarPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | ContextContentAlignment | Gets or sets the alignment of context content.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.ContextContentAlignment Property

TitleBarPanelContextContentAlignment Property

Gets or sets the alignment of context content.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextContentAlignment ContextContentAlignment { get; set; }
Public Property ContextContentAlignment As ContextContentAlignment
    Get
    Set

Property Value

Type: ContextContentAlignment
The alignment of context content. The default value is Far.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel Methods

The TitleBarPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetIsContextContent | Gets the value of the IsContextContent attached property for the specified object.
 | GetIsFiller | Gets the value of the IsFiller attached property for the specified object.
 | GetIsHeader | Gets the value of the IsHeader attached property for the specified object.
 | GetIsIcon | Gets the value of the IsIcon attached property for the specified object.
 | GetIsReadOnlyContextContent | Gets the value of the IsReadOnlyContextContent attached property for the specified object.
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetIsContextContent | Sets the value of the IsContextContent attached property to the specified object.
 | SetIsFiller | Sets the value of the IsFiller attached property to the specified object.
 | SetIsHeader | Sets the value of the IsHeader attached property to the specified object.
 | SetIsIcon | Sets the value of the IsIcon attached property to the specified object.
 | SetIsReadOnlyContextContent | Sets the value of the IsReadOnlyContextContent attached property to the specified object.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.ArrangeOverride Method

TitleBarPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.GetIsContextContent Method

TitleBarPanelGetIsContextContent Method

Gets the value of the IsContextContent attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsContextContent(
    DependencyObject obj
)
Public Shared Function GetIsContextContent (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.GetIsFiller Method

TitleBarPanelGetIsFiller Method

Gets the value of the IsFiller attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsFiller(
    DependencyObject obj
)
Public Shared Function GetIsFiller (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.GetIsHeader Method

TitleBarPanelGetIsHeader Method

Gets the value of the IsHeader attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsHeader(
    DependencyObject obj
)
Public Shared Function GetIsHeader (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.GetIsIcon Method

TitleBarPanelGetIsIcon Method

Gets the value of the IsIcon attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsIcon(
    DependencyObject obj
)
Public Shared Function GetIsIcon (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.GetIsReadOnlyContextContent Method

TitleBarPanelGetIsReadOnlyContextContent Method

Gets the value of the IsReadOnlyContextContent attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsReadOnlyContextContent(
    DependencyObject obj
)
Public Shared Function GetIsReadOnlyContextContent (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.MeasureOverride Method

TitleBarPanelMeasureOverride Method

Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.SetIsContextContent Method

TitleBarPanelSetIsContextContent Method

Sets the value of the IsContextContent attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIsContextContent(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsContextContent (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.SetIsFiller Method

TitleBarPanelSetIsFiller Method

Sets the value of the IsFiller attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIsFiller(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsFiller (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.SetIsHeader Method

TitleBarPanelSetIsHeader Method

Sets the value of the IsHeader attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIsHeader(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsHeader (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.SetIsIcon Method

TitleBarPanelSetIsIcon Method

Sets the value of the IsIcon attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIsIcon(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsIcon (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.SetIsReadOnlyContextContent Method

TitleBarPanelSetIsReadOnlyContextContent Method

Sets the value of the IsReadOnlyContextContent attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIsReadOnlyContextContent(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsReadOnlyContextContent (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel Fields

The TitleBarPanel type exposes the following members.

Fields
Name | Description
ContextContentAlignmentProperty | Identifies the ContextContentAlignment dependency property. This field is read-only.
IsContextContentProperty | Identifies the IsContextContent dependency property. This field is read-only.
IsFillerProperty | Identifies the IsFiller dependency property. This field is read-only.
IsHeaderProperty | Identifies the IsHeader dependency property. This field is read-only.
IsIconProperty | Identifies the IsIcon dependency property. This field is read-only.
IsReadOnlyContextContentProperty | Identifies the IsReadOnlyContextContent dependency property. This field is read-only.
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.ContextContentAlignmentProperty Field

TitleBarPanelContextContentAlignmentProperty Field

Identifies the ContextContentAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentAlignmentProperty
Public Shared ReadOnly ContextContentAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContentAlignment dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsContextContentProperty Field

TitleBarPanelIsContextContentProperty Field

Identifies the IsContextContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsContextContentProperty
Public Shared ReadOnly IsContextContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsContextContent dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsFillerProperty Field

TitleBarPanelIsFillerProperty Field

Identifies the IsFiller dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFillerProperty
Public Shared ReadOnly IsFillerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFiller dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsHeaderProperty Field

TitleBarPanelIsHeaderProperty Field

Identifies the IsHeader dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHeaderProperty
Public Shared ReadOnly IsHeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHeader dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsIconProperty Field

TitleBarPanelIsIconProperty Field

Identifies the IsIcon dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsIconProperty
Public Shared ReadOnly IsIconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsIcon dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsReadOnlyContextContentProperty Field

TitleBarPanelIsReadOnlyContextContentProperty Field

Identifies the IsReadOnlyContextContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyContextContentProperty
Public Shared ReadOnly IsReadOnlyContextContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnlyContextContent dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel Attached Properties

The TitleBarPanel type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsContextContent |
Public attached property | IsFiller |
Public attached property | IsHeader |
Public attached property | IsIcon |
Public attached property | IsReadOnlyContextContent |
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsContextContent Attached Property

TitleBarPanelIsContextContent Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Docking.Primitives.TitleBarPanel.IsContextContent"]

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsContextContent, SetIsContextContent
See GetIsContextContent, SetIsContextContent

Property Value

Type: Boolean
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsFiller Attached Property

TitleBarPanelIsFiller Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Docking.Primitives.TitleBarPanel.IsFiller"]

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsFiller, SetIsFiller
See GetIsFiller, SetIsFiller

Property Value

Type: Boolean
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsHeader Attached Property

TitleBarPanelIsHeader Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Docking.Primitives.TitleBarPanel.IsHeader"]

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsHeader, SetIsHeader
See GetIsHeader, SetIsHeader

Property Value

Type: Boolean
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsIcon Attached Property

TitleBarPanelIsIcon Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Docking.Primitives.TitleBarPanel.IsIcon"]

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsIcon, SetIsIcon
See GetIsIcon, SetIsIcon

Property Value

Type: Boolean
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleBarPanel.IsReadOnlyContextContent Attached Property

TitleBarPanelIsReadOnlyContextContent Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Docking.Primitives.TitleBarPanel.IsReadOnlyContextContent"]

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsReadOnlyContextContent, SetIsReadOnlyContextContent
See GetIsReadOnlyContextContent, SetIsReadOnlyContextContent

Property Value

Type: Boolean
See Also

Reference

TitleBarPanel Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleConverter Class

Represents a value converter that can shorten long text by only allowing a certain prefix number of characters at the start, then injecting the patch string, and allowing a certain suffix number of characters at the end.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Docking.PrimitivesTitleConverter

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TitleConverter : IValueConverter
Public Class TitleConverter
    Implements IValueConverter

The TitleConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TitleConverter | Initializes a new instance of the TitleConverter class
Top
Properties
 | Name | Description
Public property | Patch | Gets or sets the string to use in the middle of the string when the title exceeds a maximum length.
Public property | Prefix | Gets or sets the maximum allowed length of the title's prefix.
Public property | Suffix | Gets or sets the maximum allowed length of the title's suffix.
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleConverter Constructor

Initializes a new instance of the TitleConverter class

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TitleConverter()
Public Sub New
See Also

Reference

TitleConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleConverter Properties

The TitleConverter type exposes the following members.

Properties
 | Name | Description
Public property | Patch | Gets or sets the string to use in the middle of the string when the title exceeds a maximum length.
Public property | Prefix | Gets or sets the maximum allowed length of the title's prefix.
Public property | Suffix | Gets or sets the maximum allowed length of the title's suffix.
Top
See Also

Reference

TitleConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleConverter.Patch Property

TitleConverterPatch Property

Gets or sets the string to use in the middle of the string when the title exceeds a maximum length.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Patch { get; set; }
Public Property Patch As String
    Get
    Set

Property Value

Type: String
The string to use in the middle of the string when the title exceeds a maximum length. The default value is ....
See Also

Reference

TitleConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleConverter.Prefix Property

TitleConverterPrefix Property

Gets or sets the maximum allowed length of the title's prefix.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Prefix { get; set; }
Public Property Prefix As Integer
    Get
    Set

Property Value

Type: Int32
The maximum allowed length of the title's prefix. The default value is 20.
See Also

Reference

TitleConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleConverter.Suffix Property

TitleConverterSuffix Property

Gets or sets the maximum allowed length of the title's suffix.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Suffix { get; set; }
Public Property Suffix As Integer
    Get
    Set

Property Value

Type: Int32
The maximum allowed length of the title's suffix. The default value is 15.
See Also

Reference

TitleConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleConverter Methods

The TitleConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

TitleConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleConverter.Convert Method

TitleConverterConvert Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

TitleConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


TitleConverter.ConvertBack Method

TitleConverterConvertBack Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

TitleConverter Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Class

Represents an AdvancedTabControl for use within a ToolWindowContainer.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsTabControl
ActiproSoftware.Windows.Controls.DockingAdvancedTabControl
ActiproSoftware.Windows.Controls.Docking.PrimitivesToolWindowContainerTabControl

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ToolWindowContainerTabControl : AdvancedTabControl
Public Class ToolWindowContainerTabControl
    Inherits AdvancedTabControl

The ToolWindowContainerTabControl type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowContainerTabControl | Initializes an instance of the ToolWindowContainerTabControl class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible. (Inherited from AdvancedTabControl.)
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported. (Inherited from AdvancedTabControl.)
Public property | CanScrollForward | Gets whether scrolling forward is supported. (Inherited from AdvancedTabControl.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from AdvancedTabControl.)
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled. (Inherited from AdvancedTabControl.)
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones. (Inherited from AdvancedTabControl.)
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button. (Inherited from AdvancedTabControl.)
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button. (Inherited from AdvancedTabControl.)
Public property | CanTabsSelectOnDragOver | Gets or sets whether tabs can be selected when performing a system (e.g. text, file) drag over them. (Inherited from AdvancedTabControl.)
Public property | ContentStringFormat | Gets a composite string that specifies how to format the contents of the TabItem objects if they are displayed as strings. (Inherited from TabControl.)
Public property | ContentTemplate | Gets or sets the DataTemplate to apply to any TabItem that does not have a ContentTemplate or ContentTemplateSelector property defined. (Inherited from TabControl.)
Public property | ContentTemplateSelector | Gets or sets a DataTemplateSelector that provides custom logic for choosing the template that is used to display the content of the control. (Inherited from TabControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available. (Inherited from AdvancedTabControl.)
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button. (Inherited from AdvancedTabControl.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus. (Inherited from AdvancedTabControl.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed. (Inherited from AdvancedTabControl.)
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible. (Inherited from AdvancedTabControl.)
Public property | IsOverflowed | Gets whether the tabs are overflowed. (Inherited from AdvancedTabControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible. (Inherited from AdvancedTabControl.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button. (Inherited from AdvancedTabControl.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu. (Inherited from AdvancedTabControl.)
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab. (Inherited from AdvancedTabControl.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward. (Inherited from AdvancedTabControl.)
Public property | ScrollOffset | Gets the scroll offset. (Inherited from AdvancedTabControl.)
Public property | SelectedContent | Gets the content of the currently selected TabItem. (Inherited from TabControl.)
Public property | SelectedContentStringFormat | Gets a composite string that specifies how to format the content of the currently selected TabItem if it is displayed as a string. (Inherited from TabControl.)
Public property | SelectedContentTemplate | Gets the DataTemplate of the currently selected item. (Inherited from TabControl.)
Public property | SelectedContentTemplateSelector | Gets the DataTemplateSelector of the currently selected item. (Inherited from TabControl.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item. (Inherited from AdvancedTabControl.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab. (Inherited from AdvancedTabControl.)
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs. (Inherited from AdvancedTabControl.)
Public property | TabFarSlantExtent | Gets or sets the far side slant extent of the tabs. (Inherited from AdvancedTabControl.)
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabNearSlantExtent | Gets or sets the near side slant extent of the tabs. (Inherited from AdvancedTabControl.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from AdvancedTabControl.)
Public property | TabPadding | Gets or sets the tab padding. (Inherited from AdvancedTabControl.)
Public property | TabSpacing | Gets or sets the spacing between tabs. (Inherited from AdvancedTabControl.)
Public property | TabStripPlacement | Gets or sets how tab headers align relative to the tab content. (Inherited from TabControl.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDefaultFocusHandling | Gets or sets whether to use default TabItem focus handling. (Inherited from AdvancedTabControl.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from AdvancedTabControl.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides AdvancedTabControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides AdvancedTabControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Inherited from AdvancedTabControl.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from AdvancedTabControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Called when IsInitialized is set to true. (Inherited from TabControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called to update the current selection when items change. (Inherited from TabControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from AdvancedTabControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Occurs when the control's size is changed. (Inherited from AdvancedTabControl.)
Protected method | OnSelectionChanged | Occurs when the selection has changed. (Inherited from AdvancedTabControl.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides AdvancedTabControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab. (Inherited from AdvancedTabControl.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MenuOpening | Occurs before a context or drop-down menu is opening. (Inherited from AdvancedTabControl.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | NewTabRequested | Occurs when a new tab is requested. (Inherited from AdvancedTabControl.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button. (Inherited from AdvancedTabControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Constructor

Initializes an instance of the ToolWindowContainerTabControl class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToolWindowContainerTabControl()
Public Sub New
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Properties

The ToolWindowContainerTabControl type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible. (Inherited from AdvancedTabControl.)
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported. (Inherited from AdvancedTabControl.)
Public property | CanScrollForward | Gets whether scrolling forward is supported. (Inherited from AdvancedTabControl.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from AdvancedTabControl.)
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled. (Inherited from AdvancedTabControl.)
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones. (Inherited from AdvancedTabControl.)
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button. (Inherited from AdvancedTabControl.)
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button. (Inherited from AdvancedTabControl.)
Public property | CanTabsSelectOnDragOver | Gets or sets whether tabs can be selected when performing a system (e.g. text, file) drag over them. (Inherited from AdvancedTabControl.)
Public property | ContentStringFormat | Gets a composite string that specifies how to format the contents of the TabItem objects if they are displayed as strings. (Inherited from TabControl.)
Public property | ContentTemplate | Gets or sets the DataTemplate to apply to any TabItem that does not have a ContentTemplate or ContentTemplateSelector property defined. (Inherited from TabControl.)
Public property | ContentTemplateSelector | Gets or sets a DataTemplateSelector that provides custom logic for choosing the template that is used to display the content of the control. (Inherited from TabControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available. (Inherited from AdvancedTabControl.)
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button. (Inherited from AdvancedTabControl.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus. (Inherited from AdvancedTabControl.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed. (Inherited from AdvancedTabControl.)
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible. (Inherited from AdvancedTabControl.)
Public property | IsOverflowed | Gets whether the tabs are overflowed. (Inherited from AdvancedTabControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible. (Inherited from AdvancedTabControl.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button. (Inherited from AdvancedTabControl.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu. (Inherited from AdvancedTabControl.)
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab. (Inherited from AdvancedTabControl.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward. (Inherited from AdvancedTabControl.)
Public property | ScrollOffset | Gets the scroll offset. (Inherited from AdvancedTabControl.)
Public property | SelectedContent | Gets the content of the currently selected TabItem. (Inherited from TabControl.)
Public property | SelectedContentStringFormat | Gets a composite string that specifies how to format the content of the currently selected TabItem if it is displayed as a string. (Inherited from TabControl.)
Public property | SelectedContentTemplate | Gets the DataTemplate of the currently selected item. (Inherited from TabControl.)
Public property | SelectedContentTemplateSelector | Gets the DataTemplateSelector of the currently selected item. (Inherited from TabControl.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item. (Inherited from AdvancedTabControl.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab. (Inherited from AdvancedTabControl.)
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs. (Inherited from AdvancedTabControl.)
Public property | TabFarSlantExtent | Gets or sets the far side slant extent of the tabs. (Inherited from AdvancedTabControl.)
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TabNearSlantExtent | Gets or sets the near side slant extent of the tabs. (Inherited from AdvancedTabControl.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from AdvancedTabControl.)
Public property | TabPadding | Gets or sets the tab padding. (Inherited from AdvancedTabControl.)
Public property | TabSpacing | Gets or sets the spacing between tabs. (Inherited from AdvancedTabControl.)
Public property | TabStripPlacement | Gets or sets how tab headers align relative to the tab content. (Inherited from TabControl.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDefaultFocusHandling | Gets or sets whether to use default TabItem focus handling. (Inherited from AdvancedTabControl.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Methods

The ToolWindowContainerTabControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from AdvancedTabControl.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides AdvancedTabControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides AdvancedTabControlGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Inherited from AdvancedTabControl.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from AdvancedTabControl.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Called when IsInitialized is set to true. (Inherited from TabControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called to update the current selection when items change. (Inherited from TabControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from AdvancedTabControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Occurs when the control's size is changed. (Inherited from AdvancedTabControl.)
Protected method | OnSelectionChanged | Occurs when the selection has changed. (Inherited from AdvancedTabControl.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides AdvancedTabControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab. (Inherited from AdvancedTabControl.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl.ClearContainerForItemOverride Method

ToolWindowContainerTabControlClearContainerForItemOverride Method

Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl.GetContainerForItemOverride Method

ToolWindowContainerTabControlGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl.PrepareContainerForItemOverride Method

ToolWindowContainerTabControlPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Docking.Primitives
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Events

The ToolWindowContainerTabControl type exposes the following members.

Events
 | Name | Description
Public event | MenuOpening | Occurs before a context or drop-down menu is opening. (Inherited from AdvancedTabControl.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | NewTabRequested | Occurs when a new tab is requested. (Inherited from AdvancedTabControl.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button. (Inherited from AdvancedTabControl.)
Top
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.Windows.Controls.Docking.Primitives Namespace


ActiproSoftware.Windows.Controls.Docking.Serialization Namespace

Contains classes that are used to serialize layout data for the DockSite control.
Classes
 | Class | Description
Public class | DockingWindowDeserializingEventArgs | Provides event arguments that are used for DockingWindow deserializing event.
Public class | DockSiteLayoutSerializer | Provides DockSite layout serialization and deserialization functionality.
Public class | XmlAutoHideHost | Represents a serializable version of the auto-hide portion of a DockHost, used for saving to XML layout.
Public class | XmlAutoHideTabStrip | Represents a serializable version of the auto-hide tab strip on each side of a DockHost, used for saving to XML layout.
Public class | XmlAutoHideTabStripCollection | Represents a list of XmlAutoHideTabStrip objects.
Public class | XmlDockingObject | Represents the base class for a docking object, used for saving to XML layout.
Public class | XmlDockingObjectCollection | Represents a list of XmlObjectBase objects.
Public class | XmlDockingWindow | Represents a serializable version of the DockingWindow class, used for saving to XML layout.
Public class | XmlDockingWindowContainer | Represents a serializable version of the DockingWindowContainerBase class reference, used for saving to XML layout.
Public class | XmlDockingWindowRef | Represents a serializable version of the DockingWindow class reference, used for saving to XML layout.
Public class | XmlDockSiteLayout | Represents the serializable root node for a DockSite layout.
Public class | XmlDocumentWindow | Represents a serializable version of the DocumentWindow class, used for saving to XML layout.
Public class | XmlDocumentWindowCollection | Represents a list of XmlDocumentWindow objects.
Public class | XmlDocumentWindowRef | Represents a serializable version of the DocumentWindow class reference, used for saving to XML layout.
Public class | XmlRaftedDocumentWindowContainer | Represents a serializable version of the deprecated RaftedDocumentWindowContainer class reference, used for saving to XML layout.
Public class | XmlRaftingHost | Represents a serializable version of a floating DockHost, used for saving to XML layout.
Public class | XmlRaftingHostCollection | Represents a list of XmlRaftingHost objects.
Public class | XmlSplitContainer | Represents a serializable version of the SplitContainer class reference, used for saving to XML layout.
Public class | XmlStandardMdiHost | Represents a serializable version of the StandardMdiHost class reference, used for saving to XML layout.
Public class | XmlTabbedMdiContainer | Represents a serializable version of the XmlTabbedMdiContainer class reference, used for saving to XML layout.
Public class | XmlTabbedMdiHost | Represents a serializable version of the TabbedMdiHost class, used for saving to XML layout.
Public class | XmlToolWindow | Represents a serializable version of the ToolWindow class, used for saving to XML layout.
Public class | XmlToolWindowCollection | Represents a list of XmlToolWindow objects.
Public class | XmlToolWindowContainer | Represents a serializable version of the ToolWindowContainer class reference, used for saving to XML layout.
Public class | XmlToolWindowContainerCollection | Represents a list of XmlToolWindowContainer objects.
Public class | XmlToolWindowRef | Represents a serializable version of the ToolWindow class reference, used for saving to XML layout.
Public class | XmlTrack | Represents a serializable version of the Track class reference, used for saving to XML layout.
Public class | XmlWorkspace | Represents a serializable version of the Workspace class, used for saving to XML layout.
Enumerations
 | Enumeration | Description
Public enumeration | DockingWindowDeserializationBehavior | Specifies the various behaviors available when deserializing a DockingWindow.
Public enumeration | DockSiteSerializationBehavior | Specifies the various behaviors available when deserializing a DockSite.
Public enumeration | XmlDockingWindowState | Indicates the state for a XmlDockingWindow.


DockingWindowDeserializationBehavior Enumeration

Specifies the various behaviors available when deserializing a DockingWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DockingWindowDeserializationBehavior
Public Enumeration DockingWindowDeserializationBehavior
Members
Member name | Value | Description
Discard | 0 | Indicates that the layout data will be discarded if the associated DockingWindow does not exist.
AutoCreate | 1 | Indicates that the DockingWindow will be auto-created, if possible, before restoring the layout data.
LazyLoad | 2 | Indicates that the layout data will be stored by the DockSite and will be restored when the associated DockingWindow is registered.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs Class

Provides event arguments that are used for DockingWindow deserializing event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Windows.Controls.Docking.SerializationDockingWindowDeserializingEventArgs

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockingWindowDeserializingEventArgs : EventArgs
Public Class DockingWindowDeserializingEventArgs
    Inherits EventArgs

The DockingWindowDeserializingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowDeserializingEventArgs | Initializes a new instance of the ItemSerializationEventArgs class.
Top
Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates whether the default processing should be cancelled.
Public property | Node | Gets the serializable XmlDockingWindow that is used to represent the Window.
Public property | Window | Gets or sets the DockingWindow that is represented by the serializable Node.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs Constructor

Initializes a new instance of the ItemSerializationEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowDeserializingEventArgs(
    DockingWindow window,
    XmlDockingWindow node
)
Public Sub New (
    window As DockingWindow,
    node As XmlDockingWindow
)

Parameters

window
Type: ActiproSoftware.Windows.Controls.DockingDockingWindow
The DockingWindow that is represented by the serializable Node.
node
Type: ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindow
The serializable XmlDockingWindow that is used to represent the Window.
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs Properties

The DockingWindowDeserializingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates whether the default processing should be cancelled.
Public property | Node | Gets the serializable XmlDockingWindow that is used to represent the Window.
Public property | Window | Gets or sets the DockingWindow that is represented by the serializable Node.
Top
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs.Handled Property

DockingWindowDeserializingEventArgsHandled Property

Gets or sets a value that indicates whether the default processing should be cancelled.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the event has been handled; otherwise, false.
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs.Node Property

DockingWindowDeserializingEventArgsNode Property

Gets the serializable XmlDockingWindow that is used to represent the Window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDockingWindow Node { get; }
Public ReadOnly Property Node As XmlDockingWindow
    Get

Property Value

Type: XmlDockingWindow
The serializable XmlDockingWindow that is used to represent the Window.
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs.Window Property

DockingWindowDeserializingEventArgsWindow Property

Gets or sets the DockingWindow that is represented by the serializable Node.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindow Window { get; set; }
Public Property Window As DockingWindow
    Get
    Set

Property Value

Type: DockingWindow
The DockingWindow that is represented by the serializable Node.
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Class

Provides DockSite layout serialization and deserialization functionality.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlSerializerBase DockSite, XmlDockSiteLayout
ActiproSoftware.Windows.Controls.Docking.SerializationDockSiteLayoutSerializer

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DockSiteLayoutSerializer : XmlSerializerBase<DockSite, XmlDockSiteLayout>
Public Class DockSiteLayoutSerializer
    Inherits XmlSerializerBase(Of DockSite, XmlDockSiteLayout)

The DockSiteLayoutSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | DockSiteLayoutSerializer | Initializes an instance of the DockSiteLayoutSerializer class.
Public method | DockSiteLayoutSerializer(XmlDockSiteLayout) | Initializes an instance of the DockSiteLayoutSerializer class.
Top
Properties
 | Name | Description
Public property | CanKeepExistingDocumentWindowsOpen | Gets or sets whether existing open document windows are kept open during a layout serialization that affects the MDI area, even when they aren't listed in the loaded layout data.
Public property | CanSerializeUnusedLazyLoadData | Gets or sets whether unused lazy load data can be serialized.
Public property | CustomTypes | Gets the collection of custom Types that can be serialized and deserialized using this serializer. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public property | DocumentWindowDeserializationBehavior | Gets or sets the DocumentWindow deserialization behavior.
Public property | RootNode | Gets or sets the root TXmlObj node that is serialized and deserialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public property | SerializationBehavior | Gets or sets the DockSite serialization behavior.
Public property | ToolWindowDeserializationBehavior | Gets or sets the ToolWindow deserialization behavior.
Top
Methods
 | Name | Description
Public method | ApplyTo | Applies the information contained within this serializer to the specified object. (Overrides XmlSerializerBaseTObj, TXmlObjApplyTo(TObj).)
Public method | CreateRootNodeFor | Creates a root node for the specified object. (Overrides XmlSerializerBaseTObj, TXmlObjCreateRootNodeFor(TObj).)
Protected method | GetXmlSerializer | Returns the XmlSerializer to use for serialization and deserialization. (Overrides XmlSerializerBaseTObj, TXmlObjGetXmlSerializer.)
Public method | LoadFromFile(String) | Deserializes the RootNode from the specified file. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromFile(String, TObj) | Deserializes the RootNode from the specified file. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromStream(Stream) | Deserializes the RootNode from the specified Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromStream(Stream, TObj) | Deserializes the RootNode from the specified Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromString(String) | Deserializes the RootNode from the specified XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromString(String, TObj) | Deserializes the RootNode from the specified XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromXmlReader(XmlReader) | Deserializes the RootNode from the specified XmlReader. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromXmlReader(XmlReader, TObj) | Deserializes the RootNode from the specified XmlReader. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | RaiseDockingWindowDeserializing | Raises the DockingWindowDeserializing event with the specified arguments.
Protected method | RaiseObjectDeserialized | Raises the ObjectDeserialized event with the specified arguments. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | RaiseObjectSerialized | Raises the ObjectSerialized event with the specified arguments. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToFile(String) | Serializes the RootNode to XML within a file. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToFile(String, TObj) | Serializes the RootNode to XML within a file. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToStream(Stream) | Serializes the RootNode to XML within a Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToStream(Stream, TObj) | Serializes the RootNode to XML within a Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToString | Serializes the RootNode to an XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToString(TObj) | Serializes the RootNode to an XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToXmlWriter(XmlWriter) | Serializes the RootNode to XML by using an XmlWriter. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToXmlWriter(XmlWriter, TObj) | Serializes the RootNode to XML by using an XmlWriter. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | WriteHeader | Allows for dynamic injection of an XML comment or other data before the main serialization routine occurs. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Top
Events
 | Name | Description
Public event | DockingWindowDeserializing | Occurs when an object is deserialized.
Public event | ObjectDeserialized | Occurs when an object is deserialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public event | ObjectSerialized | Occurs when an object is serialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Constructor

Overload List
 | Name | Description
Public method | DockSiteLayoutSerializer | Initializes an instance of the DockSiteLayoutSerializer class.
Public method | DockSiteLayoutSerializer(XmlDockSiteLayout) | Initializes an instance of the DockSiteLayoutSerializer class.
Top
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Constructor

Initializes an instance of the DockSiteLayoutSerializer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSiteLayoutSerializer()
Public Sub New
See Also

Reference

DockSiteLayoutSerializer Class
DockSiteLayoutSerializer Overload
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Constructor (XmlDockSiteLayout)

Initializes an instance of the DockSiteLayoutSerializer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSiteLayoutSerializer(
    XmlDockSiteLayout layout
)
Public Sub New (
    layout As XmlDockSiteLayout
)

Parameters

layout
Type: ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockSiteLayout
The root XmlDockSiteLayout node.
See Also

Reference

DockSiteLayoutSerializer Class
DockSiteLayoutSerializer Overload
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Properties

The DockSiteLayoutSerializer type exposes the following members.

Properties
 | Name | Description
Public property | CanKeepExistingDocumentWindowsOpen | Gets or sets whether existing open document windows are kept open during a layout serialization that affects the MDI area, even when they aren't listed in the loaded layout data.
Public property | CanSerializeUnusedLazyLoadData | Gets or sets whether unused lazy load data can be serialized.
Public property | CustomTypes | Gets the collection of custom Types that can be serialized and deserialized using this serializer. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public property | DocumentWindowDeserializationBehavior | Gets or sets the DocumentWindow deserialization behavior.
Public property | RootNode | Gets or sets the root TXmlObj node that is serialized and deserialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public property | SerializationBehavior | Gets or sets the DockSite serialization behavior.
Public property | ToolWindowDeserializationBehavior | Gets or sets the ToolWindow deserialization behavior.
Top
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.CanKeepExistingDocumentWindowsOpen Property

DockSiteLayoutSerializerCanKeepExistingDocumentWindowsOpen Property

Gets or sets whether existing open document windows are kept open during a layout serialization that affects the MDI area, even when they aren't listed in the loaded layout data.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanKeepExistingDocumentWindowsOpen { get; set; }
Public Property CanKeepExistingDocumentWindowsOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if existing open document windows are kept open during a layout serialization that affects the MDI area, even when they aren't listed in the loaded layout data; otherwise, false. The default value is false.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.CanSerializeUnusedLazyLoadData Property

DockSiteLayoutSerializerCanSerializeUnusedLazyLoadData Property

Gets or sets whether unused lazy load data can be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanSerializeUnusedLazyLoadData { get; set; }
Public Property CanSerializeUnusedLazyLoadData As Boolean
    Get
    Set

Property Value

Type: Boolean
true if unused lazy load data can be serialized; otherwise, false. The default value is false.
Remarks
When a layout is deserialized and ToolWindowDeserializationBehavior or DocumentWindowDeserializationBehavior are LazyLoad, lazy load data is stored for the windows if windows in the layout are not yet registered with the DockSite. If they later become registered, their lazy load data allows them to be restored to their previous location in the layout. If a layout is serialized without one of these windows being registered, normally it will discard the lazy load data so that it does not accumulate over time. Change this property to true to allow that lazy load data to be retained during serialization.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.DocumentWindowDeserializationBehavior Property

DockSiteLayoutSerializerDocumentWindowDeserializationBehavior Property

Gets or sets the DocumentWindow deserialization behavior.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowDeserializationBehavior DocumentWindowDeserializationBehavior { get; set; }
Public Property DocumentWindowDeserializationBehavior As DockingWindowDeserializationBehavior
    Get
    Set

Property Value

Type: DockingWindowDeserializationBehavior
The DocumentWindow deserialization behavior.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.SerializationBehavior Property

DockSiteLayoutSerializerSerializationBehavior Property

Gets or sets the DockSite serialization behavior.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSiteSerializationBehavior SerializationBehavior { get; set; }
Public Property SerializationBehavior As DockSiteSerializationBehavior
    Get
    Set

Property Value

Type: DockSiteSerializationBehavior
The DockSite serialization behavior.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.ToolWindowDeserializationBehavior Property

DockSiteLayoutSerializerToolWindowDeserializationBehavior Property

Gets or sets the ToolWindow deserialization behavior.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockingWindowDeserializationBehavior ToolWindowDeserializationBehavior { get; set; }
Public Property ToolWindowDeserializationBehavior As DockingWindowDeserializationBehavior
    Get
    Set

Property Value

Type: DockingWindowDeserializationBehavior
The ToolWindow deserialization behavior.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Methods

The DockSiteLayoutSerializer type exposes the following members.

Methods
 | Name | Description
Public method | ApplyTo | Applies the information contained within this serializer to the specified object. (Overrides XmlSerializerBaseTObj, TXmlObjApplyTo(TObj).)
Public method | CreateRootNodeFor | Creates a root node for the specified object. (Overrides XmlSerializerBaseTObj, TXmlObjCreateRootNodeFor(TObj).)
Protected method | GetXmlSerializer | Returns the XmlSerializer to use for serialization and deserialization. (Overrides XmlSerializerBaseTObj, TXmlObjGetXmlSerializer.)
Public method | LoadFromFile(String) | Deserializes the RootNode from the specified file. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromFile(String, TObj) | Deserializes the RootNode from the specified file. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromStream(Stream) | Deserializes the RootNode from the specified Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromStream(Stream, TObj) | Deserializes the RootNode from the specified Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromString(String) | Deserializes the RootNode from the specified XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromString(String, TObj) | Deserializes the RootNode from the specified XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromXmlReader(XmlReader) | Deserializes the RootNode from the specified XmlReader. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromXmlReader(XmlReader, TObj) | Deserializes the RootNode from the specified XmlReader. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | RaiseDockingWindowDeserializing | Raises the DockingWindowDeserializing event with the specified arguments.
Protected method | RaiseObjectDeserialized | Raises the ObjectDeserialized event with the specified arguments. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | RaiseObjectSerialized | Raises the ObjectSerialized event with the specified arguments. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToFile(String) | Serializes the RootNode to XML within a file. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToFile(String, TObj) | Serializes the RootNode to XML within a file. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToStream(Stream) | Serializes the RootNode to XML within a Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToStream(Stream, TObj) | Serializes the RootNode to XML within a Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToString | Serializes the RootNode to an XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToString(TObj) | Serializes the RootNode to an XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToXmlWriter(XmlWriter) | Serializes the RootNode to XML by using an XmlWriter. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToXmlWriter(XmlWriter, TObj) | Serializes the RootNode to XML by using an XmlWriter. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | WriteHeader | Allows for dynamic injection of an XML comment or other data before the main serialization routine occurs. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Top
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.ApplyTo Method

DockSiteLayoutSerializerApplyTo Method

Applies the information contained within this serializer to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void ApplyTo(
    DockSite obj
)
Public Overrides Sub ApplyTo (
    obj As DockSite
)

Parameters

obj
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The object to update with deserialized information.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.CreateRootNodeFor Method

DockSiteLayoutSerializerCreateRootNodeFor Method

Creates a root node for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override XmlDockSiteLayout CreateRootNodeFor(
    DockSite obj
)
Public Overrides Function CreateRootNodeFor (
    obj As DockSite
) As XmlDockSiteLayout

Parameters

obj
Type: ActiproSoftware.Windows.Controls.DockingDockSite
The object for which to create a root node.

Return Value

Type: XmlDockSiteLayout
The root node that was created.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.GetXmlSerializer Method

DockSiteLayoutSerializerGetXmlSerializer Method

Returns the XmlSerializer to use for serialization and deserialization.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override XmlSerializer GetXmlSerializer()
Protected Overrides Function GetXmlSerializer As XmlSerializer

Return Value

Type: XmlSerializer
The XmlSerializer that was created.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.RaiseDockingWindowDeserializing Method

DockSiteLayoutSerializerRaiseDockingWindowDeserializing Method

Raises the DockingWindowDeserializing event with the specified arguments.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void RaiseDockingWindowDeserializing(
    DockingWindowDeserializingEventArgs eventArgs
)
Protected Overridable Sub RaiseDockingWindowDeserializing (
    eventArgs As DockingWindowDeserializingEventArgs
)

Parameters

eventArgs
Type: ActiproSoftware.Windows.Controls.Docking.SerializationDockingWindowDeserializingEventArgs
The DockingWindowDeserializingEventArgs instance containing the event data.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Events

The DockSiteLayoutSerializer type exposes the following members.

Events
 | Name | Description
Public event | DockingWindowDeserializing | Occurs when an object is deserialized.
Public event | ObjectDeserialized | Occurs when an object is deserialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public event | ObjectSerialized | Occurs when an object is serialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Top
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.DockingWindowDeserializing Event

DockSiteLayoutSerializerDockingWindowDeserializing Event

Occurs when an object is deserialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowDeserializingEventArgs> DockingWindowDeserializing
Public Event DockingWindowDeserializing As EventHandler(Of DockingWindowDeserializingEventArgs)

Value

Type: SystemEventHandler DockingWindowDeserializingEventArgs
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


DockSiteSerializationBehavior Enumeration

Specifies the various behaviors available when deserializing a DockSite.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DockSiteSerializationBehavior
Public Enumeration DockSiteSerializationBehavior
Members
Member name | Value | Description
ToolWindowsOnly | 0 | Indicates that only the layout of the tool windows will be serialized.
All | 1 | Indicates that the entire layout will be serialized.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideHost Class

Represents a serializable version of the auto-hide portion of a DockHost, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlAutoHideHost

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlAutoHideHost : XmlObjectBase
Public Class XmlAutoHideHost
    Inherits XmlObjectBase

The XmlAutoHideHost type exposes the following members.

Constructors
 | Name | Description
Public method | XmlAutoHideHost | Initializes a new instance of the XmlAutoHideHost class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideHost Constructor

Initializes a new instance of the XmlAutoHideHost class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlAutoHideHost()
Public Sub New
See Also

Reference

XmlAutoHideHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideHost Properties

The XmlAutoHideHost type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlAutoHideHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideHost.Children Property

XmlAutoHideHostChildren Property

Gets the collection of children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlAutoHideTabStripCollection Children { get; }
Public ReadOnly Property Children As XmlAutoHideTabStripCollection
    Get

Property Value

Type: XmlAutoHideTabStripCollection
The collection of children.
See Also

Reference

XmlAutoHideHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip Class

Represents a serializable version of the auto-hide tab strip on each side of a DockHost, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlAutoHideTabStrip

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlAutoHideTabStrip : XmlObjectBase
Public Class XmlAutoHideTabStrip
    Inherits XmlObjectBase

The XmlAutoHideTabStrip type exposes the following members.

Constructors
 | Name | Description
Public method | XmlAutoHideTabStrip | Initializes a new instance of the XmlAutoHideTabStrip class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | Side | Gets or sets the side upon which the tabstrip appears.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip Constructor

Initializes a new instance of the XmlAutoHideTabStrip class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlAutoHideTabStrip()
Public Sub New
See Also

Reference

XmlAutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip Properties

The XmlAutoHideTabStrip type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | Side | Gets or sets the side upon which the tabstrip appears.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlAutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip.Children Property

XmlAutoHideTabStripChildren Property

Gets the collection of children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlToolWindowContainerCollection Children { get; }
Public ReadOnly Property Children As XmlToolWindowContainerCollection
    Get

Property Value

Type: XmlToolWindowContainerCollection
The collection of children.
See Also

Reference

XmlAutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip.Side Property

XmlAutoHideTabStripSide Property

Gets or sets the side upon which the tabstrip appears.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Side Side { get; set; }
Public Property Side As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip appears.
See Also

Reference

XmlAutoHideTabStrip Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Class

Represents a list of XmlAutoHideTabStrip objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlAutoHideTabStrip
System.Collections.ObjectModelObservableCollection XmlAutoHideTabStrip
ActiproSoftware.WindowsDeferrableObservableCollection XmlAutoHideTabStrip
ActiproSoftware.Windows.Controls.Docking.SerializationXmlAutoHideTabStripCollection

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlAutoHideTabStripCollection : DeferrableObservableCollection<XmlAutoHideTabStrip>
Public Class XmlAutoHideTabStripCollection
    Inherits DeferrableObservableCollection(Of XmlAutoHideTabStrip)

The XmlAutoHideTabStripCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlAutoHideTabStripCollection | Initializes a new instance of the XmlAutoHideTabStripCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlAutoHideTabStrip .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Constructor

Initializes a new instance of the XmlAutoHideTabStripCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlAutoHideTabStripCollection()
Public Sub New
See Also

Reference

XmlAutoHideTabStripCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Properties

The XmlAutoHideTabStripCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlAutoHideTabStrip .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Top
See Also

Reference

XmlAutoHideTabStripCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Methods

The XmlAutoHideTabStripCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

XmlAutoHideTabStripCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Events

The XmlAutoHideTabStripCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Top
See Also

Reference

XmlAutoHideTabStripCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingObject Class

Represents the base class for a docking object, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
More...

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class XmlDockingObject : XmlObjectBase
Public MustInherit Class XmlDockingObject
    Inherits XmlObjectBase

The XmlDockingObject type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlDockingObject | Initializes a new instance of the XmlDockingObject class
Top
Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindow
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindowRef
ActiproSoftware.Windows.Controls.Docking.SerializationXmlRaftingHost
ActiproSoftware.Windows.Controls.Docking.SerializationXmlSplitContainer
ActiproSoftware.Windows.Controls.Docking.SerializationXmlTrack
ActiproSoftware.Windows.Controls.Docking.SerializationXmlWorkspace


XmlDockingObject Constructor

Initializes a new instance of the XmlDockingObject class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected XmlDockingObject()
Protected Sub New
See Also

Reference

XmlDockingObject Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingObject Properties

The XmlDockingObject type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlDockingObject Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Class

Represents a list of XmlObjectBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlObjectBase
System.Collections.ObjectModelObservableCollection XmlObjectBase
ActiproSoftware.WindowsDeferrableObservableCollection XmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObjectCollection

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlDockingObjectCollection : DeferrableObservableCollection<XmlObjectBase>
Public Class XmlDockingObjectCollection
    Inherits DeferrableObservableCollection(Of XmlObjectBase)

The XmlDockingObjectCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDockingObjectCollection | Initializes a new instance of the XmlDockingObjectCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlObjectBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlObjectBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlObjectBase .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlObjectBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlObjectBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlObjectBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlObjectBase .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlObjectBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlObjectBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlObjectBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlObjectBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlObjectBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlObjectBase .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlObjectBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlObjectBase .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Constructor

Initializes a new instance of the XmlDockingObjectCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDockingObjectCollection()
Public Sub New
See Also

Reference

XmlDockingObjectCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Properties

The XmlDockingObjectCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlObjectBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlObjectBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlObjectBase .)
Top
See Also

Reference

XmlDockingObjectCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Methods

The XmlDockingObjectCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlObjectBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlObjectBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlObjectBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlObjectBase .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlObjectBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlObjectBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlObjectBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlObjectBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlObjectBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlObjectBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlObjectBase .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

XmlDockingObjectCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Events

The XmlDockingObjectCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlObjectBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlObjectBase .)
Top
See Also

Reference

XmlDockingObjectCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow Class

Represents a serializable version of the DockingWindow class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindow
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDocumentWindow
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindow

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class XmlDockingWindow : XmlDockingObject
Public MustInherit Class XmlDockingWindow
    Inherits XmlDockingObject

The XmlDockingWindow type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlDockingWindow | Initializes an instance of the XmlDockingWindow class.
Top
Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | IsOpen | Gets or sets whether the window is open.
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.
Public property | Name | Gets or sets the name of the window.
Public property | SerializationId | Gets or sets the serialization ID of the window.
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI.
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI.
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI.
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI.
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window.
Public property | State | Gets or sets the current state of the window.
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control.
Public property | TypeSerializable | Gets or sets the type of the associated control.
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
Methods
 | Name | Description
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized.
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized.
Public method | ShouldSerializeName | Determines if the Name property should be serialized.
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized.
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized.
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized.
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized.
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized.
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow Constructor

Initializes an instance of the XmlDockingWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected XmlDockingWindow()
Protected Sub New
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow Properties

The XmlDockingWindow type exposes the following members.

Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | IsOpen | Gets or sets whether the window is open.
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.
Public property | Name | Gets or sets the name of the window.
Public property | SerializationId | Gets or sets the serialization ID of the window.
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI.
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI.
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI.
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI.
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window.
Public property | State | Gets or sets the current state of the window.
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control.
Public property | TypeSerializable | Gets or sets the type of the associated control.
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ContainerDockedSize Property

XmlDockingWindowContainerDockedSize Property

Gets or sets the size of the docking window's container when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size ContainerDockedSize { get; set; }
Public Property ContainerDockedSize As Size
    Get
    Set

Property Value

Type: Size
The size of the docking window's container when in a Docked state.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ContainerDockedSizeSerializable Property

XmlDockingWindowContainerDockedSizeSerializable Property

Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ContainerDockedSizeSerializable { get; set; }
Public Property ContainerDockedSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.IsOpen Property

XmlDockingWindowIsOpen Property

Gets or sets whether the window is open.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOpen { get; set; }
Public Property IsOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is open; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.LastActiveDateTime Property

XmlDockingWindowLastActiveDateTime Property

Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime LastActiveDateTime { get; set; }
Public Property LastActiveDateTime As DateTime
    Get
    Set

Property Value

Type: DateTime
The DateTime at which the window was last active, meaning the primary window that was focused.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.Name Property

XmlDockingWindowName Property

Gets or sets the name of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.SerializationId Property

XmlDockingWindowSerializationId Property

Gets or sets the serialization ID of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string SerializationId { get; set; }
Public Property SerializationId As String
    Get
    Set

Property Value

Type: String
The serialization ID of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiBounds Property

XmlDockingWindowStandardMdiBounds Property

Gets or sets the current bounds of the window in standard MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Rect> StandardMdiBounds { get; set; }
Public Property StandardMdiBounds As Nullable(Of Rect)
    Get
    Set

Property Value

Type: Nullable Rect
The current bounds of the window in standard MDI.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiBoundsSerializable Property

XmlDockingWindowStandardMdiBoundsSerializable Property

Gets or sets the current bounds of the window in standard MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string StandardMdiBoundsSerializable { get; set; }
Public Property StandardMdiBoundsSerializable As String
    Get
    Set

Property Value

Type: String
The current bounds of the window in standard MDI.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiRestoreBounds Property

XmlDockingWindowStandardMdiRestoreBounds Property

Gets or sets the restore bounds of the window in standard MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Rect> StandardMdiRestoreBounds { get; set; }
Public Property StandardMdiRestoreBounds As Nullable(Of Rect)
    Get
    Set

Property Value

Type: Nullable Rect
The restore bounds of the window in standard MDI.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiRestoreBoundsSerializable Property

XmlDockingWindowStandardMdiRestoreBoundsSerializable Property

Gets or sets the restore bounds of the window in standard MDI.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string StandardMdiRestoreBoundsSerializable { get; set; }
Public Property StandardMdiRestoreBoundsSerializable As String
    Get
    Set

Property Value

Type: String
The restore bounds of the window in standard MDI.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiWindowState Property

XmlDockingWindowStandardMdiWindowState Property

Gets or sets the standard MDI state of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WindowState StandardMdiWindowState { get; set; }
Public Property StandardMdiWindowState As WindowState
    Get
    Set

Property Value

Type: WindowState
The standard MDI state of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.State Property

XmlDockingWindowState Property

Gets or sets the current state of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDockingWindowState State { get; set; }
Public Property State As XmlDockingWindowState
    Get
    Set

Property Value

Type: XmlDockingWindowState
The current state of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.TabbedMdiLayoutKind Property

XmlDockingWindowTabbedMdiLayoutKind Property

Gets or sets the tab layout kind.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TabLayoutKind TabbedMdiLayoutKind { get; set; }
Public Property TabbedMdiLayoutKind As TabLayoutKind
    Get
    Set

Property Value

Type: TabLayoutKind
The tab layout kind.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.Type Property

XmlDockingWindowType Property

Gets or sets the type of the associated control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type Type { get; set; }
Public Property Type As Type
    Get
    Set

Property Value

Type: Type
The type of the associated control.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.TypeSerializable Property

XmlDockingWindowTypeSerializable Property

Gets or sets the type of the associated control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TypeSerializable { get; set; }
Public Property TypeSerializable As String
    Get
    Set

Property Value

Type: String
The type of the associated control.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.UniqueId Property

XmlDockingWindowUniqueId Property

Gets or sets the unique ID of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow Methods

The XmlDockingWindow type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized.
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized.
Public method | ShouldSerializeName | Determines if the Name property should be serialized.
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized.
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized.
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized.
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized.
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized.
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Top
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeContainerDockedSizeSerializable Method

XmlDockingWindowShouldSerializeContainerDockedSizeSerializable Method

Determines if the ContainerDockedSizeSerializable property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeContainerDockedSizeSerializable()
Public Overridable Function ShouldSerializeContainerDockedSizeSerializable As Boolean

Return Value

Type: Boolean
true if the ContainerDockedSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeLastActiveDateTime Method

XmlDockingWindowShouldSerializeLastActiveDateTime Method

Determines if the LastActiveDateTime property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeLastActiveDateTime()
Public Overridable Function ShouldSerializeLastActiveDateTime As Boolean

Return Value

Type: Boolean
true if the LastActiveDateTime property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeName Method

XmlDockingWindowShouldSerializeName Method

Determines if the Name property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeName()
Public Overridable Function ShouldSerializeName As Boolean

Return Value

Type: Boolean
true if the Name property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeSerializationId Method

XmlDockingWindowShouldSerializeSerializationId Method

Determines if the SerializationId property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeSerializationId()
Public Overridable Function ShouldSerializeSerializationId As Boolean

Return Value

Type: Boolean
true if the SerializationId property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeStandardMdiBoundsSerializable Method

XmlDockingWindowShouldSerializeStandardMdiBoundsSerializable Method

Determines if the StandardMdiBoundsSerializable property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeStandardMdiBoundsSerializable()
Public Overridable Function ShouldSerializeStandardMdiBoundsSerializable As Boolean

Return Value

Type: Boolean
true if the StandardMdiBoundsSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeStandardMdiWindowState Method

XmlDockingWindowShouldSerializeStandardMdiWindowState Method

Determines if the StandardMdiWindowState property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeStandardMdiWindowState()
Public Overridable Function ShouldSerializeStandardMdiWindowState As Boolean

Return Value

Type: Boolean
true if the StandardMdiWindowState property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeTabbedMdiLayoutKind Method

XmlDockingWindowShouldSerializeTabbedMdiLayoutKind Method

Determines if the TabbedMdiLayoutKind property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeTabbedMdiLayoutKind()
Public Overridable Function ShouldSerializeTabbedMdiLayoutKind As Boolean

Return Value

Type: Boolean
true if the TabbedMdiLayoutKind property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeTypeSerializable Method

XmlDockingWindowShouldSerializeTypeSerializable Method

Determines if the TypeSerializable property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeTypeSerializable()
Public Overridable Function ShouldSerializeTypeSerializable As Boolean

Return Value

Type: Boolean
true if the TypeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeUniqueId Method

XmlDockingWindowShouldSerializeUniqueId Method

Determines if the UniqueId property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeUniqueId()
Public Overridable Function ShouldSerializeUniqueId As Boolean

Return Value

Type: Boolean
true if the UniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer Class

Represents a serializable version of the DockingWindowContainerBase class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.Windows.Controls.Docking.SerializationXmlRaftedDocumentWindowContainer
ActiproSoftware.Windows.Controls.Docking.SerializationXmlTabbedMdiContainer
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindowContainer

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class XmlDockingWindowContainer : XmlDockingObject
Public MustInherit Class XmlDockingWindowContainer
    Inherits XmlDockingObject

The XmlDockingWindowContainer type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlDockingWindowContainer | Initializes an instance of the XmlDockingWindowContainer class.
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | DockedSize | Gets or sets the size of the control when in a Docked state.
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized.
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer Constructor

Initializes an instance of the XmlDockingWindowContainer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected XmlDockingWindowContainer()
Protected Sub New
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer Properties

The XmlDockingWindowContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | DockedSize | Gets or sets the size of the control when in a Docked state.
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.Children Property

XmlDockingWindowContainerChildren Property

Gets the collection of children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDockingObjectCollection Children { get; }
Public ReadOnly Property Children As XmlDockingObjectCollection
    Get

Property Value

Type: XmlDockingObjectCollection
The collection of children.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.DockedSize Property

XmlDockingWindowContainerDockedSize Property

Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size DockedSize { get; set; }
Public Property DockedSize As Size
    Get
    Set

Property Value

Type: Size
The size of the control when in a Docked state.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.DockedSizeSerializable Property

XmlDockingWindowContainerDockedSizeSerializable Property

Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DockedSizeSerializable { get; set; }
Public Property DockedSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.SelectedWindowUniqueId Property

XmlDockingWindowContainerSelectedWindowUniqueId Property

Gets or sets the unique ID of the selected window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Guid SelectedWindowUniqueId { get; set; }
Public Property SelectedWindowUniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the selected window.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer Methods

The XmlDockingWindowContainer type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized.
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized.
Top
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.ShouldSerializeDockedSizeSerializable Method

XmlDockingWindowContainerShouldSerializeDockedSizeSerializable Method

Determines if the DockedSizeSerializable property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeDockedSizeSerializable()
Public Overridable Function ShouldSerializeDockedSizeSerializable As Boolean

Return Value

Type: Boolean
true if the DockedSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.ShouldSerializeSelectedWindowUniqueId Method

XmlDockingWindowContainerShouldSerializeSelectedWindowUniqueId Method

Determines if the SelectedWindowUniqueId property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeSelectedWindowUniqueId()
Public Overridable Function ShouldSerializeSelectedWindowUniqueId As Boolean

Return Value

Type: Boolean
true if the SelectedWindowUniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowRef Class

Represents a serializable version of the DockingWindow class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindowRef
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDocumentWindowRef
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindowRef

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class XmlDockingWindowRef : XmlDockingObject
Public MustInherit Class XmlDockingWindowRef
    Inherits XmlDockingObject

The XmlDockingWindowRef type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlDockingWindowRef | Initializes a new instance of the XmlDockingWindowRef class
Top
Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
Methods
 | Name | Description
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowRef Constructor

Initializes a new instance of the XmlDockingWindowRef class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected XmlDockingWindowRef()
Protected Sub New
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowRef Properties

The XmlDockingWindowRef type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowRef.UniqueId Property

XmlDockingWindowRefUniqueId Property

Gets or sets the unique ID of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the window.
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowRef Methods

The XmlDockingWindowRef type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Top
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowRef.ShouldSerializeUniqueId Method

XmlDockingWindowRefShouldSerializeUniqueId Method

Determines if the UniqueId property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeUniqueId()
Public Overridable Function ShouldSerializeUniqueId As Boolean

Return Value

Type: Boolean
true if the UniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockingWindowState Enumeration

Indicates the state for a XmlDockingWindow.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum XmlDockingWindowState
Public Enumeration XmlDockingWindowState
Members
Member name | Value | Description
Docked | 0 | The window is docked in a container outside of the MDI (multiple document interface) area.
Document | 1 | The window is a document within the MDI (multiple document interface) area.
AutoHide | 2 | The window is auto-hidden in a container along the side of a dock host.
Floating | 3 | Deprecated, for compatibility with old versions only.
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout Class

Represents the serializable root node for a DockSite layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockSiteLayout

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlDockSiteLayout : XmlObjectBase
Public Class XmlDockSiteLayout
    Inherits XmlObjectBase

The XmlDockSiteLayout type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDockSiteLayout | Initializes an instance of the XmlDockSiteLayout class.
Top
Properties
 | Name | Description
Public property | AutoHideHost | Gets or sets the auto-hide host of the dock site.
Public property | Content | Gets or sets the content of the dock site.
Public property | DocumentWindows | Gets the collection of document windows.
Public property | RaftingHosts | Gets the collection of rafting hosts.
Public property | SerializationFormat | Gets or sets the serialization format used when saving the layout.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | ToolWindows | Gets the collection of tool windows.
Public property | Version | Gets or sets the layout version.
Top
Methods
 | Name | Description
Public method | ShouldSerializeDocumentWindows | Determines if the DocumentWindows property should be serialized.
Public method | ShouldSerializeRaftingHosts | Determines if the RaftingHosts property should be serialized.
Public method | ShouldSerializeToolWindows | Determines if the ToolWindows property should be serialized.
Public method | ShouldSerializeVersion | Determines if the Version property should be serialized.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout Constructor

Initializes an instance of the XmlDockSiteLayout class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDockSiteLayout()
Public Sub New
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout Properties

The XmlDockSiteLayout type exposes the following members.

Properties
 | Name | Description
Public property | AutoHideHost | Gets or sets the auto-hide host of the dock site.
Public property | Content | Gets or sets the content of the dock site.
Public property | DocumentWindows | Gets the collection of document windows.
Public property | RaftingHosts | Gets the collection of rafting hosts.
Public property | SerializationFormat | Gets or sets the serialization format used when saving the layout.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | ToolWindows | Gets the collection of tool windows.
Public property | Version | Gets or sets the layout version.
Top
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.AutoHideHost Property

XmlDockSiteLayoutAutoHideHost Property

Gets or sets the auto-hide host of the dock site.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlAutoHideHost AutoHideHost { get; set; }
Public Property AutoHideHost As XmlAutoHideHost
    Get
    Set

Property Value

Type: XmlAutoHideHost
The auto-hide host of the dock site.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.Content Property

XmlDockSiteLayoutContent Property

Gets or sets the content of the dock site.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlObjectBase Content { get; set; }
Public Property Content As XmlObjectBase
    Get
    Set

Property Value

Type: XmlObjectBase
The content of the dock site.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.DocumentWindows Property

XmlDockSiteLayoutDocumentWindows Property

Gets the collection of document windows.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDocumentWindowCollection DocumentWindows { get; }
Public ReadOnly Property DocumentWindows As XmlDocumentWindowCollection
    Get

Property Value

Type: XmlDocumentWindowCollection
The collection of document windows.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.RaftingHosts Property

XmlDockSiteLayoutRaftingHosts Property

Gets the collection of rafting hosts.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlRaftingHostCollection RaftingHosts { get; }
Public ReadOnly Property RaftingHosts As XmlRaftingHostCollection
    Get

Property Value

Type: XmlRaftingHostCollection
The collection of rafting hosts.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.SerializationFormat Property

XmlDockSiteLayoutSerializationFormat Property

Gets or sets the serialization format used when saving the layout.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DockSiteSerializationBehavior SerializationFormat { get; set; }
Public Property SerializationFormat As DockSiteSerializationBehavior
    Get
    Set

Property Value

Type: DockSiteSerializationBehavior
The serialization format used when saving the layout.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ToolWindows Property

XmlDockSiteLayoutToolWindows Property

Gets the collection of tool windows.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlToolWindowCollection ToolWindows { get; }
Public ReadOnly Property ToolWindows As XmlToolWindowCollection
    Get

Property Value

Type: XmlToolWindowCollection
The collection of tool windows.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.Version Property

XmlDockSiteLayoutVersion Property

Gets or sets the layout version.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Version { get; set; }
Public Property Version As Integer
    Get
    Set

Property Value

Type: Int32
The layout version.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout Methods

The XmlDockSiteLayout type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeDocumentWindows | Determines if the DocumentWindows property should be serialized.
Public method | ShouldSerializeRaftingHosts | Determines if the RaftingHosts property should be serialized.
Public method | ShouldSerializeToolWindows | Determines if the ToolWindows property should be serialized.
Public method | ShouldSerializeVersion | Determines if the Version property should be serialized.
Top
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ShouldSerializeDocumentWindows Method

XmlDockSiteLayoutShouldSerializeDocumentWindows Method

Determines if the DocumentWindows property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeDocumentWindows()
Public Overridable Function ShouldSerializeDocumentWindows As Boolean

Return Value

Type: Boolean
true if the DocumentWindows property should be serialized; otherwise, false.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ShouldSerializeRaftingHosts Method

XmlDockSiteLayoutShouldSerializeRaftingHosts Method

Determines if the RaftingHosts property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeRaftingHosts()
Public Overridable Function ShouldSerializeRaftingHosts As Boolean

Return Value

Type: Boolean
true if the RaftingHosts property should be serialized; otherwise, false.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ShouldSerializeToolWindows Method

XmlDockSiteLayoutShouldSerializeToolWindows Method

Determines if the ToolWindows property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeToolWindows()
Public Overridable Function ShouldSerializeToolWindows As Boolean

Return Value

Type: Boolean
true if the ToolWindows property should be serialized; otherwise, false.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ShouldSerializeVersion Method

XmlDockSiteLayoutShouldSerializeVersion Method

Determines if the Version property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeVersion()
Public Overridable Function ShouldSerializeVersion As Boolean

Return Value

Type: Boolean
true if the Version property should be serialized; otherwise, false.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindow Class

Represents a serializable version of the DocumentWindow class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindow
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDocumentWindow

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlDocumentWindow : XmlDockingWindow
Public Class XmlDocumentWindow
    Inherits XmlDockingWindow

The XmlDocumentWindow type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDocumentWindow | Initializes a new instance of the XmlDocumentWindow class
Top
Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | FileName | Gets or sets the filename of the window.
Public property | IsOpen | Gets or sets whether the window is open. (Inherited from XmlDockingWindow.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from XmlDockingWindow.)
Public property | Name | Gets or sets the name of the window. (Inherited from XmlDockingWindow.)
Public property | SerializationId | Gets or sets the serialization ID of the window. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window. (Inherited from XmlDockingWindow.)
Public property | State | Gets or sets the current state of the window. (Inherited from XmlDockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind. (Inherited from XmlDockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | TypeSerializable | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindow.)
Top
Methods
 | Name | Description
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeFileName | Determines if the FileName property should be serialized.
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeName | Determines if the Name property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindow.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindow Constructor

Initializes a new instance of the XmlDocumentWindow class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDocumentWindow()
Public Sub New
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindow Properties

The XmlDocumentWindow type exposes the following members.

Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | FileName | Gets or sets the filename of the window.
Public property | IsOpen | Gets or sets whether the window is open. (Inherited from XmlDockingWindow.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from XmlDockingWindow.)
Public property | Name | Gets or sets the name of the window. (Inherited from XmlDockingWindow.)
Public property | SerializationId | Gets or sets the serialization ID of the window. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window. (Inherited from XmlDockingWindow.)
Public property | State | Gets or sets the current state of the window. (Inherited from XmlDockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind. (Inherited from XmlDockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | TypeSerializable | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindow.)
Top
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindow.FileName Property

XmlDocumentWindowFileName Property

Gets or sets the filename of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The filename of the window.
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindow Methods

The XmlDocumentWindow type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeFileName | Determines if the FileName property should be serialized.
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeName | Determines if the Name property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindow.)
Top
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindow.ShouldSerializeFileName Method

XmlDocumentWindowShouldSerializeFileName Method

Determines if the FileName property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeFileName()
Public Overridable Function ShouldSerializeFileName As Boolean

Return Value

Type: Boolean
true if the FileName property should be serialized; otherwise, false.
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Class

Represents a list of XmlDocumentWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlDocumentWindow
System.Collections.ObjectModelObservableCollection XmlDocumentWindow
ActiproSoftware.WindowsDeferrableObservableCollection XmlDocumentWindow
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDocumentWindowCollection

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlDocumentWindowCollection : DeferrableObservableCollection<XmlDocumentWindow>
Public Class XmlDocumentWindowCollection
    Inherits DeferrableObservableCollection(Of XmlDocumentWindow)

The XmlDocumentWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDocumentWindowCollection | Initializes a new instance of the XmlDocumentWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlDocumentWindow .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlDocumentWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlDocumentWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlDocumentWindow .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Constructor

Initializes a new instance of the XmlDocumentWindowCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDocumentWindowCollection()
Public Sub New
See Also

Reference

XmlDocumentWindowCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Properties

The XmlDocumentWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlDocumentWindow .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Top
See Also

Reference

XmlDocumentWindowCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Methods

The XmlDocumentWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlDocumentWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlDocumentWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlDocumentWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

XmlDocumentWindowCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Events

The XmlDocumentWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlDocumentWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlDocumentWindow .)
Top
See Also

Reference

XmlDocumentWindowCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindowRef Class

Represents a serializable version of the DocumentWindow class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindowRef
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDocumentWindowRef

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlDocumentWindowRef : XmlDockingWindowRef
Public Class XmlDocumentWindowRef
    Inherits XmlDockingWindowRef

The XmlDocumentWindowRef type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDocumentWindowRef | Initializes a new instance of the XmlDocumentWindowRef class
Top
Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindowRef.)
Top
Methods
 | Name | Description
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindowRef.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindowRef Constructor

Initializes a new instance of the XmlDocumentWindowRef class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDocumentWindowRef()
Public Sub New
See Also

Reference

XmlDocumentWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindowRef Properties

The XmlDocumentWindowRef type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindowRef.)
Top
See Also

Reference

XmlDocumentWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlDocumentWindowRef Methods

The XmlDocumentWindowRef type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindowRef.)
Top
See Also

Reference

XmlDocumentWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftedDocumentWindowContainer Class

Represents a serializable version of the deprecated RaftedDocumentWindowContainer class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.Windows.Controls.Docking.SerializationXmlRaftedDocumentWindowContainer

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlRaftedDocumentWindowContainer : XmlDockingWindowContainer
Public Class XmlRaftedDocumentWindowContainer
    Inherits XmlDockingWindowContainer

The XmlRaftedDocumentWindowContainer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRaftedDocumentWindowContainer | Initializes a new instance of the XmlRaftedDocumentWindowContainer class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftedDocumentWindowContainer Constructor

Initializes a new instance of the XmlRaftedDocumentWindowContainer class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlRaftedDocumentWindowContainer()
Public Sub New
See Also

Reference

XmlRaftedDocumentWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftedDocumentWindowContainer Properties

The XmlRaftedDocumentWindowContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlRaftedDocumentWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftedDocumentWindowContainer Methods

The XmlRaftedDocumentWindowContainer type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Top
See Also

Reference

XmlRaftedDocumentWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost Class

Represents a serializable version of a floating DockHost, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlRaftingHost

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlRaftingHost : XmlDockingObject
Public Class XmlRaftingHost
    Inherits XmlDockingObject

The XmlRaftingHost type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRaftingHost | Initializes a new instance of the XmlRaftingHost class
Top
Properties
 | Name | Description
Public property | AutoHideHost | Gets or sets the auto-hide host of the host.
Public property | Content | Gets or sets the content of the host.
Public property | Location | Gets or sets the location of the host.
Public property | LocationSerializable | Gets or sets the location of the host.
Public property | Size | Gets or sets the size of the host.
Public property | SizeSerializable | Gets or sets the size of the host.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the control.
Public property | WindowState | Gets or sets a value indicating the associated window's state.
Top
Methods
 | Name | Description
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost Constructor

Initializes a new instance of the XmlRaftingHost class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlRaftingHost()
Public Sub New
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost Properties

The XmlRaftingHost type exposes the following members.

Properties
 | Name | Description
Public property | AutoHideHost | Gets or sets the auto-hide host of the host.
Public property | Content | Gets or sets the content of the host.
Public property | Location | Gets or sets the location of the host.
Public property | LocationSerializable | Gets or sets the location of the host.
Public property | Size | Gets or sets the size of the host.
Public property | SizeSerializable | Gets or sets the size of the host.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the control.
Public property | WindowState | Gets or sets a value indicating the associated window's state.
Top
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost.AutoHideHost Property

XmlRaftingHostAutoHideHost Property

Gets or sets the auto-hide host of the host.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlAutoHideHost AutoHideHost { get; set; }
Public Property AutoHideHost As XmlAutoHideHost
    Get
    Set

Property Value

Type: XmlAutoHideHost
The auto-hide host of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost.Content Property

XmlRaftingHostContent Property

Gets or sets the content of the host.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlObjectBase Content { get; set; }
Public Property Content As XmlObjectBase
    Get
    Set

Property Value

Type: XmlObjectBase
The content of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost.Location Property

XmlRaftingHostLocation Property

Gets or sets the location of the host.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Point> Location { get; set; }
Public Property Location As Nullable(Of Point)
    Get
    Set

Property Value

Type: Nullable Point
The location of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost.LocationSerializable Property

XmlRaftingHostLocationSerializable Property

Gets or sets the location of the host.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LocationSerializable { get; set; }
Public Property LocationSerializable As String
    Get
    Set

Property Value

Type: String
The location of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost.Size Property

XmlRaftingHostSize Property

Gets or sets the size of the host.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
The size of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost.SizeSerializable Property

XmlRaftingHostSizeSerializable Property

Gets or sets the size of the host.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string SizeSerializable { get; set; }
Public Property SizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost.UniqueId Property

XmlRaftingHostUniqueId Property

Gets or sets the unique ID of the control.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the control.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost.WindowState Property

XmlRaftingHostWindowState Property

Gets or sets a value indicating the associated window's state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public WindowState WindowState { get; set; }
Public Property WindowState As WindowState
    Get
    Set

Property Value

Type: WindowState
A WindowState indicating the associated window's state.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost Methods

The XmlRaftingHost type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Top
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHost.ShouldSerializeUniqueId Method

XmlRaftingHostShouldSerializeUniqueId Method

Determines if the UniqueId property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeUniqueId()
Public Overridable Function ShouldSerializeUniqueId As Boolean

Return Value

Type: Boolean
true if the UniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Class

Represents a list of XmlRaftingHost objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlRaftingHost
System.Collections.ObjectModelObservableCollection XmlRaftingHost
ActiproSoftware.WindowsDeferrableObservableCollection XmlRaftingHost
ActiproSoftware.Windows.Controls.Docking.SerializationXmlRaftingHostCollection

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlRaftingHostCollection : DeferrableObservableCollection<XmlRaftingHost>
Public Class XmlRaftingHostCollection
    Inherits DeferrableObservableCollection(Of XmlRaftingHost)

The XmlRaftingHostCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRaftingHostCollection | Initializes a new instance of the XmlRaftingHostCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlRaftingHost .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlRaftingHost .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlRaftingHost .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlRaftingHost .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlRaftingHost .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlRaftingHost .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlRaftingHost .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlRaftingHost .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlRaftingHost .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlRaftingHost .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Constructor

Initializes a new instance of the XmlRaftingHostCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlRaftingHostCollection()
Public Sub New
See Also

Reference

XmlRaftingHostCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Properties

The XmlRaftingHostCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlRaftingHost .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlRaftingHost .)
Top
See Also

Reference

XmlRaftingHostCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Methods

The XmlRaftingHostCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlRaftingHost .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlRaftingHost .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlRaftingHost .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlRaftingHost .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlRaftingHost .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlRaftingHost .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlRaftingHost .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

XmlRaftingHostCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Events

The XmlRaftingHostCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlRaftingHost .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlRaftingHost .)
Top
See Also

Reference

XmlRaftingHostCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlSplitContainer Class

Represents a serializable version of the SplitContainer class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlSplitContainer

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlSplitContainer : XmlDockingObject
Public Class XmlSplitContainer
    Inherits XmlDockingObject

The XmlSplitContainer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSplitContainer | Initializes an instance of the XmlSplitContainer class.
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | DockedSize | Gets or sets the size of the control when in a Docked state.
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | Orientation | Gets or sets the orientation of the container.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlSplitContainer Constructor

Initializes an instance of the XmlSplitContainer class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlSplitContainer()
Public Sub New
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlSplitContainer Properties

The XmlSplitContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | DockedSize | Gets or sets the size of the control when in a Docked state.
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | Orientation | Gets or sets the orientation of the container.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlSplitContainer.Children Property

XmlSplitContainerChildren Property

Gets the collection of children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDockingObjectCollection Children { get; }
Public ReadOnly Property Children As XmlDockingObjectCollection
    Get

Property Value

Type: XmlDockingObjectCollection
The collection of children.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlSplitContainer.DockedSize Property

XmlSplitContainerDockedSize Property

Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size DockedSize { get; set; }
Public Property DockedSize As Size
    Get
    Set

Property Value

Type: Size
The size of the control when in a Docked state.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlSplitContainer.DockedSizeSerializable Property

XmlSplitContainerDockedSizeSerializable Property

Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DockedSizeSerializable { get; set; }
Public Property DockedSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlSplitContainer.Orientation Property

XmlSplitContainerOrientation Property

Gets or sets the orientation of the container.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the container.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlSplitContainer Methods

The XmlSplitContainer type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized.
Top
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlSplitContainer.ShouldSerializeDockedSizeSerializable Method

XmlSplitContainerShouldSerializeDockedSizeSerializable Method

Determines if the DockedSizeSerializable property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeDockedSizeSerializable()
Public Overridable Function ShouldSerializeDockedSizeSerializable As Boolean

Return Value

Type: Boolean
true if the DockedSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlStandardMdiHost Class

Represents a serializable version of the StandardMdiHost class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlStandardMdiHost

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlStandardMdiHost : XmlObjectBase
Public Class XmlStandardMdiHost
    Inherits XmlObjectBase

The XmlStandardMdiHost type exposes the following members.

Constructors
 | Name | Description
Public method | XmlStandardMdiHost | Initializes a new instance of the XmlStandardMdiHost class
Top
Properties
 | Name | Description
Public property | AreWindowsMaximized | Gets or sets whether windows in the host are currently maximized.
Public property | Children | Gets the collection of children.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlStandardMdiHost Constructor

Initializes a new instance of the XmlStandardMdiHost class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlStandardMdiHost()
Public Sub New
See Also

Reference

XmlStandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlStandardMdiHost Properties

The XmlStandardMdiHost type exposes the following members.

Properties
 | Name | Description
Public property | AreWindowsMaximized | Gets or sets whether windows in the host are currently maximized.
Public property | Children | Gets the collection of children.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlStandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlStandardMdiHost.AreWindowsMaximized Property

XmlStandardMdiHostAreWindowsMaximized Property

Gets or sets whether windows in the host are currently maximized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreWindowsMaximized { get; set; }
Public Property AreWindowsMaximized As Boolean
    Get
    Set

Property Value

Type: Boolean
true if windows in the host are currently maximized; otherwise, false.
See Also

Reference

XmlStandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlStandardMdiHost.Children Property

XmlStandardMdiHostChildren Property

Gets the collection of children.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlDockingObjectCollection Children { get; }
Public ReadOnly Property Children As XmlDockingObjectCollection
    Get

Property Value

Type: XmlDockingObjectCollection
The collection of children.
See Also

Reference

XmlStandardMdiHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTabbedMdiContainer Class

Represents a serializable version of the XmlTabbedMdiContainer class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.Windows.Controls.Docking.SerializationXmlTabbedMdiContainer

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlTabbedMdiContainer : XmlDockingWindowContainer
Public Class XmlTabbedMdiContainer
    Inherits XmlDockingWindowContainer

The XmlTabbedMdiContainer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTabbedMdiContainer | Initializes a new instance of the XmlTabbedMdiContainer class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTabbedMdiContainer Constructor

Initializes a new instance of the XmlTabbedMdiContainer class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlTabbedMdiContainer()
Public Sub New
See Also

Reference

XmlTabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTabbedMdiContainer Properties

The XmlTabbedMdiContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlTabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTabbedMdiContainer Methods

The XmlTabbedMdiContainer type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Top
See Also

Reference

XmlTabbedMdiContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTabbedMdiHost Class

Represents a serializable version of the TabbedMdiHost class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlTabbedMdiHost

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlTabbedMdiHost : XmlObjectBase
Public Class XmlTabbedMdiHost
    Inherits XmlObjectBase

The XmlTabbedMdiHost type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTabbedMdiHost | Initializes a new instance of the XmlTabbedMdiHost class
Top
Properties
 | Name | Description
Public property | Content | Gets or sets the content of the host.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTabbedMdiHost Constructor

Initializes a new instance of the XmlTabbedMdiHost class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlTabbedMdiHost()
Public Sub New
See Also

Reference

XmlTabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTabbedMdiHost Properties

The XmlTabbedMdiHost type exposes the following members.

Properties
 | Name | Description
Public property | Content | Gets or sets the content of the host.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlTabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTabbedMdiHost.Content Property

XmlTabbedMdiHostContent Property

Gets or sets the content of the host.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlObjectBase Content { get; set; }
Public Property Content As XmlObjectBase
    Get
    Set

Property Value

Type: XmlObjectBase
The content of the host.
See Also

Reference

XmlTabbedMdiHost Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindow Class

Represents a serializable version of the ToolWindow class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindow
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindow

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlToolWindow : XmlDockingWindow
Public Class XmlToolWindow
    Inherits XmlDockingWindow

The XmlToolWindow type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindow | Initializes an instance of the XmlToolWindow class.
Top
Properties
 | Name | Description
Public property | ContainerAutoHideSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerAutoHideSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | IsOpen | Gets or sets whether the window is open. (Inherited from XmlDockingWindow.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from XmlDockingWindow.)
Public property | Name | Gets or sets the name of the window. (Inherited from XmlDockingWindow.)
Public property | SerializationId | Gets or sets the serialization ID of the window. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window. (Inherited from XmlDockingWindow.)
Public property | State | Gets or sets the current state of the window. (Inherited from XmlDockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind. (Inherited from XmlDockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | TypeSerializable | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindow.)
Top
Methods
 | Name | Description
Public method | ShouldSerializeContainerAutoHideSizeSerializable | Determines if the ContainerAutoHideSizeSerializable property should be serialized.
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeName | Determines if the Name property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindow.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindow Constructor

Initializes an instance of the XmlToolWindow class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlToolWindow()
Public Sub New
See Also

Reference

XmlToolWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindow Properties

The XmlToolWindow type exposes the following members.

Properties
 | Name | Description
Public property | ContainerAutoHideSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerAutoHideSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | IsOpen | Gets or sets whether the window is open. (Inherited from XmlDockingWindow.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from XmlDockingWindow.)
Public property | Name | Gets or sets the name of the window. (Inherited from XmlDockingWindow.)
Public property | SerializationId | Gets or sets the serialization ID of the window. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window. (Inherited from XmlDockingWindow.)
Public property | State | Gets or sets the current state of the window. (Inherited from XmlDockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind. (Inherited from XmlDockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | TypeSerializable | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindow.)
Top
See Also

Reference

XmlToolWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindow.ContainerAutoHideSize Property

XmlToolWindowContainerAutoHideSize Property

Gets or sets the size of the docking window's container when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size ContainerAutoHideSize { get; set; }
Public Property ContainerAutoHideSize As Size
    Get
    Set

Property Value

Type: Size
The size of the docking window's container when in a Docked state.
See Also

Reference

XmlToolWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindow.ContainerAutoHideSizeSerializable Property

XmlToolWindowContainerAutoHideSizeSerializable Property

Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ContainerAutoHideSizeSerializable { get; set; }
Public Property ContainerAutoHideSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlToolWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindow Methods

The XmlToolWindow type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeContainerAutoHideSizeSerializable | Determines if the ContainerAutoHideSizeSerializable property should be serialized.
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeName | Determines if the Name property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindow.)
Top
See Also

Reference

XmlToolWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindow.ShouldSerializeContainerAutoHideSizeSerializable Method

XmlToolWindowShouldSerializeContainerAutoHideSizeSerializable Method

Determines if the ContainerAutoHideSizeSerializable property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeContainerAutoHideSizeSerializable()
Public Overridable Function ShouldSerializeContainerAutoHideSizeSerializable As Boolean

Return Value

Type: Boolean
true if the ContainerAutoHideSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlToolWindow Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Class

Represents a list of XmlToolWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlToolWindow
System.Collections.ObjectModelObservableCollection XmlToolWindow
ActiproSoftware.WindowsDeferrableObservableCollection XmlToolWindow
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindowCollection

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlToolWindowCollection : DeferrableObservableCollection<XmlToolWindow>
Public Class XmlToolWindowCollection
    Inherits DeferrableObservableCollection(Of XmlToolWindow)

The XmlToolWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindowCollection | Initializes a new instance of the XmlToolWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlToolWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlToolWindow .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlToolWindow .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlToolWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlToolWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlToolWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlToolWindow .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlToolWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlToolWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlToolWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlToolWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlToolWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlToolWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlToolWindow .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Constructor

Initializes a new instance of the XmlToolWindowCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlToolWindowCollection()
Public Sub New
See Also

Reference

XmlToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Properties

The XmlToolWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlToolWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlToolWindow .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlToolWindow .)
Top
See Also

Reference

XmlToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Methods

The XmlToolWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlToolWindow .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlToolWindow .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlToolWindow .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlToolWindow .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlToolWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlToolWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlToolWindow .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlToolWindow .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlToolWindow .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlToolWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

XmlToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Events

The XmlToolWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlToolWindow .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlToolWindow .)
Top
See Also

Reference

XmlToolWindowCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowContainer Class

Represents a serializable version of the ToolWindowContainer class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindowContainer

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlToolWindowContainer : XmlDockingWindowContainer
Public Class XmlToolWindowContainer
    Inherits XmlDockingWindowContainer

The XmlToolWindowContainer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindowContainer | Initializes a new instance of the XmlToolWindowContainer class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowContainer Constructor

Initializes a new instance of the XmlToolWindowContainer class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlToolWindowContainer()
Public Sub New
See Also

Reference

XmlToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowContainer Properties

The XmlToolWindowContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowContainer Methods

The XmlToolWindowContainer type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Top
See Also

Reference

XmlToolWindowContainer Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Class

Represents a list of XmlToolWindowContainer objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlToolWindowContainer
System.Collections.ObjectModelObservableCollection XmlToolWindowContainer
ActiproSoftware.WindowsDeferrableObservableCollection XmlToolWindowContainer
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindowContainerCollection

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlToolWindowContainerCollection : DeferrableObservableCollection<XmlToolWindowContainer>
Public Class XmlToolWindowContainerCollection
    Inherits DeferrableObservableCollection(Of XmlToolWindowContainer)

The XmlToolWindowContainerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindowContainerCollection | Initializes a new instance of the XmlToolWindowContainerCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlToolWindowContainer .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlToolWindowContainer .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlToolWindowContainer .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlToolWindowContainer .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Constructor

Initializes a new instance of the XmlToolWindowContainerCollection class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlToolWindowContainerCollection()
Public Sub New
See Also

Reference

XmlToolWindowContainerCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Properties

The XmlToolWindowContainerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection XmlToolWindowContainer .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Top
See Also

Reference

XmlToolWindowContainerCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Methods

The XmlToolWindowContainerCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection XmlToolWindowContainer .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection XmlToolWindowContainer .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection XmlToolWindowContainer .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

XmlToolWindowContainerCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Events

The XmlToolWindowContainerCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection XmlToolWindowContainer .)
Top
See Also

Reference

XmlToolWindowContainerCollection Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowRef Class

Represents a serializable version of the ToolWindow class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingWindowRef
ActiproSoftware.Windows.Controls.Docking.SerializationXmlToolWindowRef

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlToolWindowRef : XmlDockingWindowRef
Public Class XmlToolWindowRef
    Inherits XmlDockingWindowRef

The XmlToolWindowRef type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindowRef | Initializes a new instance of the XmlToolWindowRef class
Top
Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindowRef.)
Top
Methods
 | Name | Description
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindowRef.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowRef Constructor

Initializes a new instance of the XmlToolWindowRef class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlToolWindowRef()
Public Sub New
See Also

Reference

XmlToolWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowRef Properties

The XmlToolWindowRef type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindowRef.)
Top
See Also

Reference

XmlToolWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlToolWindowRef Methods

The XmlToolWindowRef type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindowRef.)
Top
See Also

Reference

XmlToolWindowRef Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack Class

Represents a serializable version of the Track class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlTrack

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlTrack : XmlDockingObject
Public Class XmlTrack
    Inherits XmlDockingObject

The XmlTrack type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTrack | Initializes an instance of the XmlTrack class.
Top
Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | CreationDateTime | Gets or sets the date/time at which the breadcrumb was created.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
Methods
 | Name | Description
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized.
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack Constructor

Initializes an instance of the XmlTrack class.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlTrack()
Public Sub New
See Also

Reference

XmlTrack Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack Properties

The XmlTrack type exposes the following members.

Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | CreationDateTime | Gets or sets the date/time at which the breadcrumb was created.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
See Also

Reference

XmlTrack Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack.ContainerDockedSize Property

XmlTrackContainerDockedSize Property

Gets or sets the size of the docking window's container when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size ContainerDockedSize { get; set; }
Public Property ContainerDockedSize As Size
    Get
    Set

Property Value

Type: Size
The size of the docking window's container when in a Docked state.
See Also

Reference

XmlTrack Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack.ContainerDockedSizeSerializable Property

XmlTrackContainerDockedSizeSerializable Property

Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ContainerDockedSizeSerializable { get; set; }
Public Property ContainerDockedSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlTrack Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack.CreationDateTime Property

XmlTrackCreationDateTime Property

Gets or sets the date/time at which the breadcrumb was created.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime CreationDateTime { get; set; }
Public Property CreationDateTime As DateTime
    Get
    Set

Property Value

Type: DateTime
The date/time at which the breadcrumb was created.
See Also

Reference

XmlTrack Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack.UniqueId Property

XmlTrackUniqueId Property

Gets or sets the unique ID of the window.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the window.
See Also

Reference

XmlTrack Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack Methods

The XmlTrack type exposes the following members.

Methods
 | Name | Description
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized.
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Top
See Also

Reference

XmlTrack Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack.ShouldSerializeContainerDockedSizeSerializable Method

XmlTrackShouldSerializeContainerDockedSizeSerializable Method

Determines if the ContainerDockedSizeSerializable property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeContainerDockedSizeSerializable()
Public Overridable Function ShouldSerializeContainerDockedSizeSerializable As Boolean

Return Value

Type: Boolean
true if the ContainerDockedSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlTrack Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlTrack.ShouldSerializeUniqueId Method

XmlTrackShouldSerializeUniqueId Method

Determines if the UniqueId property should be serialized.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeUniqueId()
Public Overridable Function ShouldSerializeUniqueId As Boolean

Return Value

Type: Boolean
true if the UniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlTrack Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlWorkspace Class

Represents a serializable version of the Workspace class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.SerializationXmlObjectBase
ActiproSoftware.Windows.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.Windows.Controls.Docking.SerializationXmlWorkspace

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class XmlWorkspace : XmlDockingObject
Public Class XmlWorkspace
    Inherits XmlDockingObject

The XmlWorkspace type exposes the following members.

Constructors
 | Name | Description
Public method | XmlWorkspace | Initializes a new instance of the XmlWorkspace class
Top
Properties
 | Name | Description
Public property | Content | Gets or sets the content of the workspace.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlWorkspace Constructor

Initializes a new instance of the XmlWorkspace class

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlWorkspace()
Public Sub New
See Also

Reference

XmlWorkspace Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlWorkspace Properties

The XmlWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | Content | Gets or sets the content of the workspace.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlWorkspace Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


XmlWorkspace.Content Property

XmlWorkspaceContent Property

Gets or sets the content of the workspace.

Namespace: ActiproSoftware.Windows.Controls.Docking.Serialization
Assembly: ActiproSoftware.Docking.Wpf (in ActiproSoftware.Docking.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public XmlObjectBase Content { get; set; }
Public Property Content As XmlObjectBase
    Get
    Set

Property Value

Type: XmlObjectBase
The content of the workspace.
See Also

Reference

XmlWorkspace Class
ActiproSoftware.Windows.Controls.Docking.Serialization Namespace


ActiproSoftware.Windows.Controls.Editors Namespace

Contains classes that support implementing embeddable and standalone masked/part-based editor controls for WPF.
Classes
 | Class | Description
Public class | AutoCompleteBox | Represents a text control that provides suggestions to end users as they type.
Public class | AutoCompleteBoxEventArgs | Provides event arguments for AutoCompleteBox events.
Public class | AutoCompleteBoxStringFilter | Represents a IDataFilter implementation based on the AutoCompleteBox text being entered.
Public class | BrushEditBox | Represents a Brush edit box.
Public class | BrushPicker | Represents a Brush picker.
Public class | ByteEditBox | Represents an Byte edit box.
Public class | BytePicker | Represents an Byte picker.
Public class | Calculator | Represents a calculator control.
Public class | ColorEditBox | Represents a Color edit box.
Public class | ColorPicker | Represents a color picker control.
Public class | CornerRadiusEditBox | Represents a CornerRadius edit box.
Public class | CornerRadiusPicker | Represents a CornerRadius picker.
Public class | Country | Specifies the various countries and associated data.
Public class | CountryComboBox | A drop-down list for country selection, populated with Country objects.
Public class | CountryCurrencyMapping | A mapping between a Country and a Currency.
Public class | Currency | Specifies a country's currency.
Public class | CurrencyComboBox | A drop-down list for currency selection, populated with Currency objects.
Public class | DateEditBox | Represents a date-only edit box.
Public class | DatePicker | Represents a date picker.
Public class | DateTimeEditBox | Represents a date/time edit box.
Public class | DateTimePicker | Represents a date/time picker.
Public class | DoubleEditBox | Represents a Double edit box.
Public class | DoublePicker | Represents a Double picker.
Public class | EnumEditBox | Represents an Enum edit box.
Public class | EnumListBox | Represents a list box that automatically presents the values of an enumeration.
Public class | EnumListBoxItem | Represents a selectable item in a EnumListBox.
Public class | EnumPicker | Represents an Enum picker.
Public class | GradientStopSlider | A slider for manipulating gradient stops.
Public class | GuidEditBox | Represents an Guid edit box.
Public class | HsbColorPicker | Represents a color picker control that allows for visual selection of hue, saturation, and brightness.
Public class | Int16EditBox | Represents an Int16 edit box.
Public class | Int16Picker | Represents an Int16 picker.
Public class | Int32EditBox | Represents an Int32 edit box.
Public class | Int32Picker | Represents an Int32 picker.
Public class | Int32RectEditBox | Represents a Int32Rect edit box.
Public class | Int32RectPicker | Represents an Int32Rect picker.
Public class | Int64EditBox | Represents an Int64 edit box.
Public class | Int64Picker | Represents an Int64 picker.
Public class | MaskedTextBox | Represents a TextBox that restricts input based on a specified mask.
Public class | MonthCalendar | Represents a month calendar control.
Public class | MonthCalendarItem | Represents a month calendar item.
Public class | PartEditBoxInline | Represents an inline UI element within a PartEditBoxBase-derived control.
Public class | PartEditBoxInlineCollection | Represents a collection of PartEditBoxInline objects.
Public class | PointEditBox | Represents a Point edit box.
Public class | PointPicker | Represents a Point picker.
Public class | RadialHuePicker | Represents a radial color hue picker control.
Public class | Rating | Represents a rating control that allows the user to set or view a rating of an entity.
Public class | RatingItem | Represents a single item in a Rating control.
Public class | RectEditBox | Represents a Rect edit box.
Public class | RectPicker | Represents a Rect picker.
Public class | SaturationBrightnessPicker | Represents a saturation/brightness picker control.
Public class | SingleEditBox | Represents a Single edit box.
Public class | SinglePicker | Represents a Single picker.
Public class | SizeEditBox | Represents a Size edit box.
Public class | SizePicker | Represents a Size picker.
Public class | ThicknessEditBox | Represents a Thickness edit box.
Public class | ThicknessPicker | Represents a Thickness picker.
Public class | TimeEditBox | Represents a time-only edit box.
Public class | TimePicker | Represents a time picker.
Public class | TimeSpanEditBox | Represents a timespan edit box.
Public class | TimeSpanPicker | Represents a TimeSpan picker.
Public class | VectorEditBox | Represents a Vector edit box.
Public class | VectorPicker | Represents a Vector picker.
Enumerations
 | Enumeration | Description
Public enumeration | AutoCompleteBoxChangeReason | Specifies the reason why an AutoCompleteBox change occurred.
Public enumeration | BrushKind | Specifies the kind of brush.
Public enumeration | ByteEditBoxPickerKind | Specifies the kind of Style to apply to the BytePicker used within a ByteEditBox's popup.
Public enumeration | CalculatorOperationKind | Specifies an operation used with a calculator.
Public enumeration | ColorPickerTextInputMode | Specifies the mode to use for text input within a ColorPicker.
Public enumeration | DaysOfWeek | Specifies the various days of the week as enumeration flags.
Public enumeration | DoubleEditBoxPickerKind | Specifies the kind of Style to apply to the DoublePicker used within a DoubleEditBox's popup.
Public enumeration | Int16EditBoxPickerKind | Specifies the kind of Style to apply to the Int16Picker used within a Int16EditBox's popup.
Public enumeration | Int32EditBoxPickerKind | Specifies the kind of Style to apply to the Int32Picker used within a Int32EditBox's popup.
Public enumeration | Int64EditBoxPickerKind | Specifies the kind of Style to apply to the Int64Picker used within a Int64EditBox's popup.
Public enumeration | MaskKind | Specifies the mask kinds supported by a MaskedTextBox.
Public enumeration | MaskPromptVisibility | Specifies the visibility of mask prompts within a MaskedTextBox.
Public enumeration | MonthCalendarSelectionMode | Specifies the various selection modes of a MonthCalendar.
Public enumeration | MonthCalendarViewMode | Specifies the various views of a MonthCalendar.
Public enumeration | MonthCalendarViewResetMode | Specifies the view reset mode of a MonthCalendar when it loses focus.
Public enumeration | PartEditBoxCommitTriggers | Specifies the triggers that force a PartEditBoxBase-derived control to immediately commit any changes.
Public enumeration | RatingItemState | Specifies the various states supported by RatingItem.
Public enumeration | SingleEditBoxPickerKind | Specifies the kind of Style to apply to the SinglePicker used within a SingleEditBox's popup.
Public enumeration | SpinnerVisibility | Specifies the desired visibility of a spinner within a parent control.
Public enumeration | SpinWrapping | Specifies the various wrapping behaviors supported when spinning a value in a part edit box.
Public enumeration | TimeSpanEditableParts | Specifies the various editable parts of a TimeSpanPicker.


AutoCompleteBox Class

Represents a text control that provides suggestions to end users as they type.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.EditorsAutoCompleteBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutoCompleteBox : Control
Public Class AutoCompleteBox
    Inherits Control

The AutoCompleteBox type exposes the following members.

Constructors
 | Name | Description
Public method | AutoCompleteBox | Initializes an instance of the AutoCompleteBox class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanSelectAllOnUpdate | Gets or sets whether the entire text should be selected following a text update, like a suggestion being chosen.
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box.
Public property | ClearCommand | Gets the ICommand that clears the text value.
Public property | DataFilter | Gets or sets the IDataFilter to use for matching suggested items.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets the name of the property that provides each item's text within the suggestion list.
Public property | FilteredItemsSource | Gets the filtered collection of suggested items to display in the suggestion list.
Protected property | FilterText | Gets the text against which suggested items should be filtered.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets whether there is at least one suggested item in the suggestion list.
Public property | HasPopupButton | Gets or sets a value indicating whether the control has a popup button.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible.
Public property | IsPopupOpen | Gets or sets whether the popup is open.
Public property | IsPopupOpenedOnFocus | Gets or sets whether the popup automatically opens when the control gains focus.
Public property | IsReadOnly | Gets or sets a value indicating whether the control is read-only.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container generated for each item.
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container.
Public property | ItemsSource | Gets or sets the collection of suggestion items that is filtered based on the user-entered text.
Public property | ItemTemplate | Gets or sets the DataTemplate used to render items in the suggestion list.
Public property | ItemTemplateSelector | Gets or sets the DataTemplateSelector used to render items in the suggestion list.
Public property | MaxPopupHeight | Gets or sets the maximum height of the popup.
Public property | MinCharacterCountToOpenPopup | Gets or sets the minimum number of characters that need to be typed to open the popup.
Public property | NoItemsContent | Gets or sets the content to display when the popup is open but there are no suggested items.
Public property | NoItemsContentTemplate | Gets or sets the DataTemplate to display when the popup is open but there are no suggested items.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PlaceholderText | Gets or sets the placeholder text to be displayed in the control.
Public property | SelectedItem | Gets or sets the selected suggested item.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text being edited in the control.
Public property | TextMemberPath | Gets or sets the name of the property that provides each item's text.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ConvertToString | Converts the specified suggested item to a string representation.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Overrides UIElementOnLostMouseCapture(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Occurs before a mouse button is pressed over the control. (Overrides UIElementOnPreviewMouseDown(MouseButtonEventArgs).)
Protected method | OnSubmitted | Occurs when the end user submits a text entry, generally by pressing Enter.
Protected method | OnSuggestionChosen | Occurs when a suggested item is chosen and needs to be converted to text.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextChanged | Occurs when the Text is changed.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectAll | Selects all the contents of the text-editing control.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Submitted | Occurs when the end user submits a text entry, generally by pressing Enter.
Public event | SuggestionChosen | Occurs when a suggested item is chosen and needs to be converted to text.
Public event | TextChanged | Occurs when the Text is changed.
Top
Fields
Name | Description
CanSelectAllOnUpdateProperty | Identifies the CanSelectAllOnUpdate dependency property. This field is read-only.
CharacterCasingProperty | Identifies the CharacterCasing dependency property. This field is read-only.
DataFilterProperty | Identifies the DataFilter dependency property. This field is read-only.
DisplayMemberPathProperty | Identifies the DisplayMemberPath dependency property. This field is read-only.
HasItemsProperty | Identifies the HasItems dependency property. This field is read-only.
HasPopupButtonProperty | Identifies the HasPopupButton dependency property. This field is read-only.
IsPopupButtonVisibleProperty | Identifies the IsPopupButtonVisible dependency property. This field is read-only.
IsPopupOpenedOnFocusProperty | Identifies the IsPopupOpenedOnFocus dependency property. This field is read-only.
IsPopupOpenProperty | Identifies the IsPopupOpen dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
ItemTemplateProperty | Identifies the ItemTemplate dependency property. This field is read-only.
ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector dependency property. This field is read-only.
MaxPopupHeightProperty | Identifies the MaxPopupHeight dependency property. This field is read-only.
MinCharacterCountToOpenPopupProperty | Identifies the MinCharacterCountToOpenPopup dependency property. This field is read-only.
NoItemsContentProperty | Identifies the NoItemsContent dependency property. This field is read-only.
NoItemsContentTemplateProperty | Identifies the NoItemsContentTemplate dependency property. This field is read-only.
PlaceholderTextProperty | Identifies the PlaceholderText dependency property. This field is read-only.
SelectedItemProperty | Identifies the SelectedItem dependency property. This field is read-only.
SubmittedEvent | Identifies the Submitted routed event. This field is read-only.
SuggestionChosenEvent | Identifies the SuggestionChosen routed event. This field is read-only.
TextChangedEvent | Identifies the TextChanged routed event. This field is read-only.
TextMemberPathProperty | Identifies the TextMemberPath dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox Constructor

Initializes an instance of the AutoCompleteBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoCompleteBox()
Public Sub New
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox Properties

The AutoCompleteBox type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanSelectAllOnUpdate | Gets or sets whether the entire text should be selected following a text update, like a suggestion being chosen.
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box.
Public property | ClearCommand | Gets the ICommand that clears the text value.
Public property | DataFilter | Gets or sets the IDataFilter to use for matching suggested items.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets the name of the property that provides each item's text within the suggestion list.
Public property | FilteredItemsSource | Gets the filtered collection of suggested items to display in the suggestion list.
Protected property | FilterText | Gets the text against which suggested items should be filtered.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets whether there is at least one suggested item in the suggestion list.
Public property | HasPopupButton | Gets or sets a value indicating whether the control has a popup button.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible.
Public property | IsPopupOpen | Gets or sets whether the popup is open.
Public property | IsPopupOpenedOnFocus | Gets or sets whether the popup automatically opens when the control gains focus.
Public property | IsReadOnly | Gets or sets a value indicating whether the control is read-only.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container generated for each item.
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container.
Public property | ItemsSource | Gets or sets the collection of suggestion items that is filtered based on the user-entered text.
Public property | ItemTemplate | Gets or sets the DataTemplate used to render items in the suggestion list.
Public property | ItemTemplateSelector | Gets or sets the DataTemplateSelector used to render items in the suggestion list.
Public property | MaxPopupHeight | Gets or sets the maximum height of the popup.
Public property | MinCharacterCountToOpenPopup | Gets or sets the minimum number of characters that need to be typed to open the popup.
Public property | NoItemsContent | Gets or sets the content to display when the popup is open but there are no suggested items.
Public property | NoItemsContentTemplate | Gets or sets the DataTemplate to display when the popup is open but there are no suggested items.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PlaceholderText | Gets or sets the placeholder text to be displayed in the control.
Public property | SelectedItem | Gets or sets the selected suggested item.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text being edited in the control.
Public property | TextMemberPath | Gets or sets the name of the property that provides each item's text.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.CanSelectAllOnUpdate Property

AutoCompleteBoxCanSelectAllOnUpdate Property

Gets or sets whether the entire text should be selected following a text update, like a suggestion being chosen.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanSelectAllOnUpdate { get; set; }
Public Property CanSelectAllOnUpdate As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the entire text should be selected following a text update, like a suggestion being chosen; otherwise false. The default value is true.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.CharacterCasing Property

AutoCompleteBoxCharacterCasing Property

Gets or sets how characters are cased when they are manually entered into the text box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharacterCasing CharacterCasing { get; set; }
Public Property CharacterCasing As CharacterCasing
    Get
    Set

Property Value

Type: CharacterCasing
One of the CharacterCasing values that specifies how manually entered characters are cased. The default value is Normal.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ClearCommand Property

AutoCompleteBoxClearCommand Property

Gets the ICommand that clears the text value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ClearCommand { get; }
Public ReadOnly Property ClearCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that clears the text value.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.DataFilter Property

AutoCompleteBoxDataFilter Property

Gets or sets the IDataFilter to use for matching suggested items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDataFilter DataFilter { get; set; }
Public Property DataFilter As IDataFilter
    Get
    Set

Property Value

Type: IDataFilter
The IDataFilter to use for matching suggested items.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.DisplayMemberPath Property

AutoCompleteBoxDisplayMemberPath Property

Gets or sets the name of the property that provides each item's text within the suggestion list.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DisplayMemberPath { get; set; }
Public Property DisplayMemberPath As String
    Get
    Set

Property Value

Type: String
The name of the property that provides each item's text within the suggestion list.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.FilteredItemsSource Property

AutoCompleteBoxFilteredItemsSource Property

Gets the filtered collection of suggested items to display in the suggestion list.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable FilteredItemsSource { get; }
Public ReadOnly Property FilteredItemsSource As IEnumerable
    Get

Property Value

Type: IEnumerable
The filtered collection of suggested items to display in the suggestion list.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.FilterText Property

AutoCompleteBoxFilterText Property

Gets the text against which suggested items should be filtered.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string FilterText { get; }
Protected Overridable ReadOnly Property FilterText As String
    Get

Property Value

Type: String
The text against which suggested items should be filtered.
Remarks
The default implementation of this property returns the Text property value.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.HasItems Property

AutoCompleteBoxHasItems Property

Gets whether there is at least one suggested item in the suggestion list.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one suggested item in the suggestion list; otherwise, false. The default value is false.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.HasPopupButton Property

AutoCompleteBoxHasPopupButton Property

Gets or sets a value indicating whether the control has a popup button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasPopupButton { get; set; }
Public Property HasPopupButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control has a popup button; otherwise false. The default value is true.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.IsPopupButtonVisible Property

AutoCompleteBoxIsPopupButtonVisible Property

Gets whether the toggle popup button is visible.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPopupButtonVisible { get; }
Public ReadOnly Property IsPopupButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the toggle popup button is visible; otherwise false. The default value is false.
Remarks
The HasPopupButton property determines whether the toggle popup button is visible.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.IsPopupOpen Property

AutoCompleteBoxIsPopupOpen Property

Gets or sets whether the popup is open.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPopupOpen { get; set; }
Public Property IsPopupOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the popup is open; otherwise, false. The default value is false.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.IsPopupOpenedOnFocus Property

AutoCompleteBoxIsPopupOpenedOnFocus Property

Gets or sets whether the popup automatically opens when the control gains focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPopupOpenedOnFocus { get; set; }
Public Property IsPopupOpenedOnFocus As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the popup automatically opens when the control gains focus; otherwise, false. The default value is false.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.IsReadOnly Property

AutoCompleteBoxIsReadOnly Property

Gets or sets a value indicating whether the control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control is read-only; otherwise false. The default value is false.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemContainerStyle Property

AutoCompleteBoxItemContainerStyle Property

Gets or sets the Style that is applied to the container generated for each item.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ItemContainerStyle { get; set; }
Public Property ItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that is applied to the container generated for each item. The default value is .
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemContainerStyleSelector Property

AutoCompleteBoxItemContainerStyleSelector Property

Gets or sets custom style-selection logic for a style that can be applied to each generated container.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StyleSelector ItemContainerStyleSelector { get; set; }
Public Property ItemContainerStyleSelector As StyleSelector
    Get
    Set

Property Value

Type: StyleSelector
A StyleSelector object that contains logic that chooses the style to use as the ItemContainerStyle. The default value is .
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemsSource Property

AutoCompleteBoxItemsSource Property

Gets or sets the collection of suggestion items that is filtered based on the user-entered text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable ItemsSource { get; set; }
Public Property ItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
The collection of suggested items that is filtered based on the user-entered text.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemTemplate Property

AutoCompleteBoxItemTemplate Property

Gets or sets the DataTemplate used to render items in the suggestion list.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ItemTemplate { get; set; }
Public Property ItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate used to render items in the suggestion list.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemTemplateSelector Property

AutoCompleteBoxItemTemplateSelector Property

Gets or sets the DataTemplateSelector used to render items in the suggestion list.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector ItemTemplateSelector { get; set; }
Public Property ItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector used to render items in the suggestion list.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.MaxPopupHeight Property

AutoCompleteBoxMaxPopupHeight Property

Gets or sets the maximum height of the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MaxPopupHeight { get; set; }
Public Property MaxPopupHeight As Double
    Get
    Set

Property Value

Type: Double
The maximum height of the popup. The default value is 500.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.MinCharacterCountToOpenPopup Property

AutoCompleteBoxMinCharacterCountToOpenPopup Property

Gets or sets the minimum number of characters that need to be typed to open the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int MinCharacterCountToOpenPopup { get; set; }
Public Property MinCharacterCountToOpenPopup As Integer
    Get
    Set

Property Value

Type: Int32
The minimum number of characters that need to be typed to open the popup. The default value is 1.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.NoItemsContent Property

AutoCompleteBoxNoItemsContent Property

Gets or sets the content to display when the popup is open but there are no suggested items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object NoItemsContent { get; set; }
Public Property NoItemsContent As Object
    Get
    Set

Property Value

Type: Object
The content to display when the popup is open but there are no suggested items.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.NoItemsContentTemplate Property

AutoCompleteBoxNoItemsContentTemplate Property

Gets or sets the DataTemplate to display when the popup is open but there are no suggested items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate NoItemsContentTemplate { get; set; }
Public Property NoItemsContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to display when the popup is open but there are no suggested items.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.PlaceholderText Property

AutoCompleteBoxPlaceholderText Property

Gets or sets the placeholder text to be displayed in the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string PlaceholderText { get; set; }
Public Property PlaceholderText As String
    Get
    Set

Property Value

Type: String
The placeholder text to be displayed in the control.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.SelectedItem Property

AutoCompleteBoxSelectedItem Property

Gets or sets the selected suggested item.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object SelectedItem { get; set; }
Public Property SelectedItem As Object
    Get
    Set

Property Value

Type: Object
The selected suggested item.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.Text Property

AutoCompleteBoxText Property

Gets or sets the text being edited in the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text being edited in the control.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.TextMemberPath Property

AutoCompleteBoxTextMemberPath Property

Gets or sets the name of the property that provides each item's text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TextMemberPath { get; set; }
Public Property TextMemberPath As String
    Get
    Set

Property Value

Type: String
The name of the property that provides each item's text.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox Methods

The AutoCompleteBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ConvertToString | Converts the specified suggested item to a string representation.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Overrides UIElementOnLostMouseCapture(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Occurs before a mouse button is pressed over the control. (Overrides UIElementOnPreviewMouseDown(MouseButtonEventArgs).)
Protected method | OnSubmitted | Occurs when the end user submits a text entry, generally by pressing Enter.
Protected method | OnSuggestionChosen | Occurs when a suggested item is chosen and needs to be converted to text.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextChanged | Occurs when the Text is changed.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectAll | Selects all the contents of the text-editing control.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ConvertToString Method

AutoCompleteBoxConvertToString Method

Converts the specified suggested item to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string ConvertToString(
    Object itemToConvert
)
Protected Overridable Function ConvertToString (
    itemToConvert As Object
) As String

Parameters

itemToConvert
Type: SystemObject
The suggested item to convert.

Return Value

Type: String
The string representation of the specified suggested item.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.OnApplyTemplate Method

AutoCompleteBoxOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.OnCreateAutomationPeer Method

AutoCompleteBoxOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.OnGotFocus Method

AutoCompleteBoxOnGotFocus Method

Occurs when the control gains focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.OnIsKeyboardFocusWithinChanged Method

AutoCompleteBoxOnIsKeyboardFocusWithinChanged Method

Reports that the IsKeyboardFocusWithin property changed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
A DependencyPropertyChangedEventArgs that contains the event data.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.OnLostMouseCapture Method

AutoCompleteBoxOnLostMouseCapture Method

Occurs when mouse capture is lost.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostMouseCapture(
    MouseEventArgs e
)
Protected Overrides Sub OnLostMouseCapture (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs that contains the event data.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.OnPreviewMouseDown Method

AutoCompleteBoxOnPreviewMouseDown Method

Occurs before a mouse button is pressed over the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPreviewMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnPreviewMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.OnSubmitted Method

AutoCompleteBoxOnSubmitted Method

Occurs when the end user submits a text entry, generally by pressing Enter.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSubmitted(
    AutoCompleteBoxEventArgs e
)
Protected Overridable Sub OnSubmitted (
    e As AutoCompleteBoxEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.EditorsAutoCompleteBoxEventArgs
The AutoCompleteBoxEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.OnSuggestionChosen Method

AutoCompleteBoxOnSuggestionChosen Method

Occurs when a suggested item is chosen and needs to be converted to text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSuggestionChosen(
    AutoCompleteBoxEventArgs e
)
Protected Overridable Sub OnSuggestionChosen (
    e As AutoCompleteBoxEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.EditorsAutoCompleteBoxEventArgs
The AutoCompleteBoxEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.OnTextChanged Method

AutoCompleteBoxOnTextChanged Method

Occurs when the Text is changed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnTextChanged(
    AutoCompleteBoxEventArgs e
)
Protected Overridable Sub OnTextChanged (
    e As AutoCompleteBoxEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.EditorsAutoCompleteBoxEventArgs
The AutoCompleteBoxEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.SelectAll Method

AutoCompleteBoxSelectAll Method

Selects all the contents of the text-editing control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SelectAll()
Public Sub SelectAll
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox Events

The AutoCompleteBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Submitted | Occurs when the end user submits a text entry, generally by pressing Enter.
Public event | SuggestionChosen | Occurs when a suggested item is chosen and needs to be converted to text.
Public event | TextChanged | Occurs when the Text is changed.
Top
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.Submitted Event

AutoCompleteBoxSubmitted Event

Occurs when the end user submits a text entry, generally by pressing Enter.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<AutoCompleteBoxEventArgs> Submitted
Public Event Submitted As EventHandler(Of AutoCompleteBoxEventArgs)

Value

Type: SystemEventHandler AutoCompleteBoxEventArgs
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.SuggestionChosen Event

AutoCompleteBoxSuggestionChosen Event

Occurs when a suggested item is chosen and needs to be converted to text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<AutoCompleteBoxEventArgs> SuggestionChosen
Public Event SuggestionChosen As EventHandler(Of AutoCompleteBoxEventArgs)

Value

Type: SystemEventHandler AutoCompleteBoxEventArgs
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.TextChanged Event

AutoCompleteBoxTextChanged Event

Occurs when the Text is changed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<AutoCompleteBoxEventArgs> TextChanged
Public Event TextChanged As EventHandler(Of AutoCompleteBoxEventArgs)

Value

Type: SystemEventHandler AutoCompleteBoxEventArgs
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox Fields

The AutoCompleteBox type exposes the following members.

Fields
Name | Description
CanSelectAllOnUpdateProperty | Identifies the CanSelectAllOnUpdate dependency property. This field is read-only.
CharacterCasingProperty | Identifies the CharacterCasing dependency property. This field is read-only.
DataFilterProperty | Identifies the DataFilter dependency property. This field is read-only.
DisplayMemberPathProperty | Identifies the DisplayMemberPath dependency property. This field is read-only.
HasItemsProperty | Identifies the HasItems dependency property. This field is read-only.
HasPopupButtonProperty | Identifies the HasPopupButton dependency property. This field is read-only.
IsPopupButtonVisibleProperty | Identifies the IsPopupButtonVisible dependency property. This field is read-only.
IsPopupOpenedOnFocusProperty | Identifies the IsPopupOpenedOnFocus dependency property. This field is read-only.
IsPopupOpenProperty | Identifies the IsPopupOpen dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
ItemTemplateProperty | Identifies the ItemTemplate dependency property. This field is read-only.
ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector dependency property. This field is read-only.
MaxPopupHeightProperty | Identifies the MaxPopupHeight dependency property. This field is read-only.
MinCharacterCountToOpenPopupProperty | Identifies the MinCharacterCountToOpenPopup dependency property. This field is read-only.
NoItemsContentProperty | Identifies the NoItemsContent dependency property. This field is read-only.
NoItemsContentTemplateProperty | Identifies the NoItemsContentTemplate dependency property. This field is read-only.
PlaceholderTextProperty | Identifies the PlaceholderText dependency property. This field is read-only.
SelectedItemProperty | Identifies the SelectedItem dependency property. This field is read-only.
SubmittedEvent | Identifies the Submitted routed event. This field is read-only.
SuggestionChosenEvent | Identifies the SuggestionChosen routed event. This field is read-only.
TextChangedEvent | Identifies the TextChanged routed event. This field is read-only.
TextMemberPathProperty | Identifies the TextMemberPath dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
Top
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.CanSelectAllOnUpdateProperty Field

AutoCompleteBoxCanSelectAllOnUpdateProperty Field

Identifies the CanSelectAllOnUpdate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanSelectAllOnUpdateProperty
Public Shared ReadOnly CanSelectAllOnUpdateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanSelectAllOnUpdate dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.CharacterCasingProperty Field

AutoCompleteBoxCharacterCasingProperty Field

Identifies the CharacterCasing dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterCasingProperty
Public Shared ReadOnly CharacterCasingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterCasing dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.DataFilterProperty Field

AutoCompleteBoxDataFilterProperty Field

Identifies the DataFilter dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataFilterProperty
Public Shared ReadOnly DataFilterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DataFilter dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.DisplayMemberPathProperty Field

AutoCompleteBoxDisplayMemberPathProperty Field

Identifies the DisplayMemberPath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayMemberPathProperty
Public Shared ReadOnly DisplayMemberPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayMemberPath dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.HasItemsProperty Field

AutoCompleteBoxHasItemsProperty Field

Identifies the HasItems dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasItemsProperty
Public Shared ReadOnly HasItemsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasItems dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.HasPopupButtonProperty Field

AutoCompleteBoxHasPopupButtonProperty Field

Identifies the HasPopupButton dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasPopupButtonProperty
Public Shared ReadOnly HasPopupButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasPopupButton dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.IsPopupButtonVisibleProperty Field

AutoCompleteBoxIsPopupButtonVisibleProperty Field

Identifies the IsPopupButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPopupButtonVisibleProperty
Public Shared ReadOnly IsPopupButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPopupButtonVisible dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.IsPopupOpenedOnFocusProperty Field

AutoCompleteBoxIsPopupOpenedOnFocusProperty Field

Identifies the IsPopupOpenedOnFocus dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPopupOpenedOnFocusProperty
Public Shared ReadOnly IsPopupOpenedOnFocusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPopupOpenedOnFocus dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.IsPopupOpenProperty Field

AutoCompleteBoxIsPopupOpenProperty Field

Identifies the IsPopupOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPopupOpenProperty
Public Shared ReadOnly IsPopupOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPopupOpen dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.IsReadOnlyProperty Field

AutoCompleteBoxIsReadOnlyProperty Field

Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemContainerStyleProperty Field

AutoCompleteBoxItemContainerStyleProperty Field

Identifies the ItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemContainerStyleProperty
Public Shared ReadOnly ItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemContainerStyle dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemContainerStyleSelectorProperty Field

AutoCompleteBoxItemContainerStyleSelectorProperty Field

Identifies the ItemContainerStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemContainerStyleSelectorProperty
Public Shared ReadOnly ItemContainerStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemContainerStyleSelector dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemsSourceProperty Field

AutoCompleteBoxItemsSourceProperty Field

Identifies the ItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemsSourceProperty
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemsSource dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemTemplateProperty Field

AutoCompleteBoxItemTemplateProperty Field

Identifies the ItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemTemplateProperty
Public Shared ReadOnly ItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemTemplate dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.ItemTemplateSelectorProperty Field

AutoCompleteBoxItemTemplateSelectorProperty Field

Identifies the ItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemTemplateSelectorProperty
Public Shared ReadOnly ItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemTemplateSelector dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.MaxPopupHeightProperty Field

AutoCompleteBoxMaxPopupHeightProperty Field

Identifies the MaxPopupHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxPopupHeightProperty
Public Shared ReadOnly MaxPopupHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxPopupHeight dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.MinCharacterCountToOpenPopupProperty Field

AutoCompleteBoxMinCharacterCountToOpenPopupProperty Field

Identifies the MinCharacterCountToOpenPopup dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinCharacterCountToOpenPopupProperty
Public Shared ReadOnly MinCharacterCountToOpenPopupProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinCharacterCountToOpenPopup dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.NoItemsContentProperty Field

AutoCompleteBoxNoItemsContentProperty Field

Identifies the NoItemsContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NoItemsContentProperty
Public Shared ReadOnly NoItemsContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NoItemsContent dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.NoItemsContentTemplateProperty Field

AutoCompleteBoxNoItemsContentTemplateProperty Field

Identifies the NoItemsContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NoItemsContentTemplateProperty
Public Shared ReadOnly NoItemsContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NoItemsContentTemplate dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.PlaceholderTextProperty Field

AutoCompleteBoxPlaceholderTextProperty Field

Identifies the PlaceholderText dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlaceholderTextProperty
Public Shared ReadOnly PlaceholderTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PlaceholderText dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.SelectedItemProperty Field

AutoCompleteBoxSelectedItemProperty Field

Identifies the SelectedItem dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedItemProperty
Public Shared ReadOnly SelectedItemProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedItem dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.SubmittedEvent Field

AutoCompleteBoxSubmittedEvent Field

Identifies the Submitted routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent SubmittedEvent
Public Shared ReadOnly SubmittedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Submitted routed event.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.SuggestionChosenEvent Field

AutoCompleteBoxSuggestionChosenEvent Field

Identifies the SuggestionChosen routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent SuggestionChosenEvent
Public Shared ReadOnly SuggestionChosenEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the SuggestionChosen routed event.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.TextChangedEvent Field

AutoCompleteBoxTextChangedEvent Field

Identifies the TextChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent TextChangedEvent
Public Shared ReadOnly TextChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the TextChanged routed event.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.TextMemberPathProperty Field

AutoCompleteBoxTextMemberPathProperty Field

Identifies the TextMemberPath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextMemberPathProperty
Public Shared ReadOnly TextMemberPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextMemberPath dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBox.TextProperty Field

AutoCompleteBoxTextProperty Field

Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

AutoCompleteBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxChangeReason Enumeration

Specifies the reason why an AutoCompleteBox change occurred.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum AutoCompleteBoxChangeReason
Public Enumeration AutoCompleteBoxChangeReason
Members
Member name | Value | Description
UserInput | 0 | The end user changed the text.
ProgrammaticChange | 1 | The text was programatically changed.
SuggestionChosen | 2 | The end user chose a suggestion.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxEventArgs Class

Provides event arguments for AutoCompleteBox events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.Windows.Controls.EditorsAutoCompleteBoxEventArgs

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutoCompleteBoxEventArgs : RoutedEventArgs
Public Class AutoCompleteBoxEventArgs
    Inherits RoutedEventArgs

The AutoCompleteBoxEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AutoCompleteBoxEventArgs | Initializes a new instance of the AutoCompleteBoxEventArgs class.
Top
Properties
 | Name | Description
Public property | IsPopupAllowed | Gets or sets whether the AutoCompleteBox is allowed to show its popup in response to the related text change when appropriate.
Public property | Item | Gets the suggested item related to this event, if applicable.
Public property | Reason | Gets the reason for the event.
Public property | Text | Gets or sets the text value related to this event.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxEventArgs Constructor

Initializes a new instance of the AutoCompleteBoxEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoCompleteBoxEventArgs(
    AutoCompleteBoxChangeReason reason,
    Object item
)
Public Sub New (
    reason As AutoCompleteBoxChangeReason,
    item As Object
)

Parameters

reason
Type: ActiproSoftware.Windows.Controls.EditorsAutoCompleteBoxChangeReason
The reason for the event.
item
Type: SystemObject
The suggestion item related to this event, if applicable.
See Also

Reference

AutoCompleteBoxEventArgs Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxEventArgs Properties

The AutoCompleteBoxEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsPopupAllowed | Gets or sets whether the AutoCompleteBox is allowed to show its popup in response to the related text change when appropriate.
Public property | Item | Gets the suggested item related to this event, if applicable.
Public property | Reason | Gets the reason for the event.
Public property | Text | Gets or sets the text value related to this event.
Top
See Also

Reference

AutoCompleteBoxEventArgs Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxEventArgs.IsPopupAllowed Property

AutoCompleteBoxEventArgsIsPopupAllowed Property

Gets or sets whether the AutoCompleteBox is allowed to show its popup in response to the related text change when appropriate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPopupAllowed { get; set; }
Public Property IsPopupAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the AutoCompleteBox is allowed to show its popup in response to the related text change when appropriate; otherwise, false.
Remarks
This property is only used after the TextChanged event is raised.
See Also

Reference

AutoCompleteBoxEventArgs Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxEventArgs.Item Property

AutoCompleteBoxEventArgsItem Property

Gets the suggested item related to this event, if applicable.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Item { get; }
Public ReadOnly Property Item As Object
    Get

Property Value

Type: Object
The suggested item related to this event, if applicable.
See Also

Reference

AutoCompleteBoxEventArgs Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxEventArgs.Reason Property

AutoCompleteBoxEventArgsReason Property

Gets the reason for the event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoCompleteBoxChangeReason Reason { get; }
Public ReadOnly Property Reason As AutoCompleteBoxChangeReason
    Get

Property Value

Type: AutoCompleteBoxChangeReason
The reason for the event.
See Also

Reference

AutoCompleteBoxEventArgs Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxEventArgs.Text Property

AutoCompleteBoxEventArgsText Property

Gets or sets the text value related to this event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text value related to this event.
See Also

Reference

AutoCompleteBoxEventArgs Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxStringFilter Class

Represents a IDataFilter implementation based on the AutoCompleteBox text being entered.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.Data.FilteringDataFilterBase
ActiproSoftware.Windows.Data.FilteringStringFilterBase
ActiproSoftware.Windows.Controls.EditorsAutoCompleteBoxStringFilter

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutoCompleteBoxStringFilter : StringFilterBase
Public Class AutoCompleteBoxStringFilter
    Inherits StringFilterBase

The AutoCompleteBoxStringFilter type exposes the following members.

Constructors
 | Name | Description
Public method | AutoCompleteBoxStringFilter | Initializes a new instance of the AutoCompleteBoxStringFilter class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IncludedFilterResult | Gets or sets the DataFilterResult to return when an item meets filter conditions. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the string operation performed by this filter. (Inherited from StringFilterBase.)
Public property | RegexOptions | Gets or sets the options used for regex matches performed by this filter. (Inherited from StringFilterBase.)
Public property | StringComparison | Gets or sets the string comparison performed by this filter. (Inherited from StringFilterBase.)
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from StringFilterBase.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object, Object).)
Protected method | FilterByString | Examines the specified source string to see if it meets filter conditions. (Inherited from StringFilterBase.)
Public method | GetCaptures | Returns the collection of filter match captures. (Inherited from StringFilterBase.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxStringFilter Constructor

Initializes a new instance of the AutoCompleteBoxStringFilter class

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoCompleteBoxStringFilter()
Public Sub New
See Also

Reference

AutoCompleteBoxStringFilter Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxStringFilter Properties

The AutoCompleteBoxStringFilter type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IncludedFilterResult | Gets or sets the DataFilterResult to return when an item meets filter conditions. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the string operation performed by this filter. (Inherited from StringFilterBase.)
Public property | RegexOptions | Gets or sets the options used for regex matches performed by this filter. (Inherited from StringFilterBase.)
Public property | StringComparison | Gets or sets the string comparison performed by this filter. (Inherited from StringFilterBase.)
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from StringFilterBase.)
Top
See Also

Reference

AutoCompleteBoxStringFilter Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxStringFilter Methods

The AutoCompleteBoxStringFilter type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object, Object).)
Protected method | FilterByString | Examines the specified source string to see if it meets filter conditions. (Inherited from StringFilterBase.)
Public method | GetCaptures | Returns the collection of filter match captures. (Inherited from StringFilterBase.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AutoCompleteBoxStringFilter Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxStringFilter.Filter Method

AutoCompleteBoxStringFilterFilter Method

Examines the specified item to see if meets filter conditions.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override DataFilterResult Filter(
    Object item,
    Object context
)
Public Overrides Function Filter (
    item As Object,
    context As Object
) As DataFilterResult

Parameters

item
Type: SystemObject
The item to examine.
context
Type: SystemObject
An optional object that provides contextual information for the filter request.

Return Value

Type: DataFilterResult
A DataFilterResult that indicates the filter result.

Implements

IDataFilterFilter(Object, Object)
See Also

Reference

AutoCompleteBoxStringFilter Class
ActiproSoftware.Windows.Controls.Editors Namespace


AutoCompleteBoxStringFilter Events

The AutoCompleteBoxStringFilter type exposes the following members.

Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
See Also

Reference

AutoCompleteBoxStringFilter Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox Class

Represents a Brush edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Brush
ActiproSoftware.Windows.Controls.EditorsBrushEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BrushEditBox : PartEditBoxBase<Brush>
Public Class BrushEditBox
    Inherits PartEditBoxBase(Of Brush)

The BrushEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | BrushEditBox | Initializes an instance of the BrushEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanReuseBrush | Gets or sets whether the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | SwatchBrush | Gets the Brush that renders a sample swatch.
Public property | SwatchMargin | Gets or sets the Thickness of the margin around the sample swatch.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from PartEditBoxBaseT.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Overrides PartEditBoxBaseTOnIntermediateValueChanged(T, T).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CanReuseBrushProperty | Identifies the CanReuseBrush dependency property. This field is read-only.
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
SwatchBrushProperty | Identifies the SwatchBrush dependency property. This field is read-only.
SwatchMarginProperty | Identifies the SwatchMargin dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox Constructor

Initializes an instance of the BrushEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BrushEditBox()
Public Sub New
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox Properties

The BrushEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanReuseBrush | Gets or sets whether the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | SwatchBrush | Gets the Brush that renders a sample swatch.
Public property | SwatchMargin | Gets or sets the Thickness of the margin around the sample swatch.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.CanReuseBrush Property

BrushEditBoxCanReuseBrush Property

Gets or sets whether the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanReuseBrush { get; set; }
Public Property CanReuseBrush As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update; otherwise, false. The default value is true.
Remarks
Set this to false in scenarios where ValueChanged events need to fire on any update, or when binding to Value using value converters.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.HasPopupButtonWhenReadOnly Property

BrushEditBoxHasPopupButtonWhenReadOnly Property

Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.HasSwatch Property

BrushEditBoxHasSwatch Property

Gets or sets whether the edit box should display a swatch that previews the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box should display a swatch that previews the Value; otherwise, false. The default value is true.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.IsAlphaEnabled Property

BrushEditBoxIsAlphaEnabled Property

Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the brush value colors is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.IsGradientAllowed Property

BrushEditBoxIsGradientAllowed Property

Gets or sets whether gradient brush values can be entered.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGradientAllowed { get; set; }
Public Property IsGradientAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if gradient brush values can be entered; otherwise, false. The default value is true.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.SwatchBrush Property

BrushEditBoxSwatchBrush Property

Gets the Brush that renders a sample swatch.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush SwatchBrush { get; }
Public ReadOnly Property SwatchBrush As Brush
    Get

Property Value

Type: Brush
The Brush that renders a sample swatch.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.SwatchMargin Property

BrushEditBoxSwatchMargin Property

Gets or sets the Thickness of the margin around the sample swatch.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness SwatchMargin { get; set; }
Public Property SwatchMargin As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the margin around the sample swatch.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox Methods

The BrushEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from PartEditBoxBaseT.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Overrides PartEditBoxBaseTOnIntermediateValueChanged(T, T).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.ConvertToString Method

BrushEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Brush valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Brush
) As String

Parameters

valueToConvert
Type: System.Windows.MediaBrush
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.CreateIncrementalChangeRequest Method

BrushEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Brush> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Brush)

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Brush
The incremental change (spin) request that was created.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.GenerateParts Method

BrushEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.IsValidValue Method

BrushEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Brush value
)
Protected Overrides Function IsValidValue (
    value As Brush
) As Boolean

Parameters

value
Type: System.Windows.MediaBrush
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.OnApplyTemplate Method

BrushEditBoxOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.OnIntermediateValueChanged Method

BrushEditBoxOnIntermediateValueChanged Method

Invoked when the value of the IntermediateValue property changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIntermediateValueChanged(
    Brush oldValue,
    Brush newValue
)
Protected Overrides Sub OnIntermediateValueChanged (
    oldValue As Brush,
    newValue As Brush
)

Parameters

oldValue
Type: System.Windows.MediaBrush
The old value of the property.
newValue
Type: System.Windows.MediaBrush
The new value of the property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.RaiseValueChangedEvent Method

BrushEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.ResetValue Method

BrushEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.TryConvertFromString Method

BrushEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Brush value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Brush
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: System.Windows.MediaBrush
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox Events

The BrushEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.ValueChanged Event

BrushEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox Fields

The BrushEditBox type exposes the following members.

Fields
Name | Description
CanReuseBrushProperty | Identifies the CanReuseBrush dependency property. This field is read-only.
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
SwatchBrushProperty | Identifies the SwatchBrush dependency property. This field is read-only.
SwatchMarginProperty | Identifies the SwatchMargin dependency property. This field is read-only.
Top
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.CanReuseBrushProperty Field

BrushEditBoxCanReuseBrushProperty Field

Identifies the CanReuseBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanReuseBrushProperty
Public Shared ReadOnly CanReuseBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanReuseBrush dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.HasSwatchProperty Field

BrushEditBoxHasSwatchProperty Field

Identifies the HasSwatch dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasSwatchProperty
Public Shared ReadOnly HasSwatchProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasSwatch dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.IsAlphaEnabledProperty Field

BrushEditBoxIsAlphaEnabledProperty Field

Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.IsGradientAllowedProperty Field

BrushEditBoxIsGradientAllowedProperty Field

Identifies the IsGradientAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGradientAllowedProperty
Public Shared ReadOnly IsGradientAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGradientAllowed dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.SwatchBrushProperty Field

BrushEditBoxSwatchBrushProperty Field

Identifies the SwatchBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwatchBrushProperty
Public Shared ReadOnly SwatchBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwatchBrush dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushEditBox.SwatchMarginProperty Field

BrushEditBoxSwatchMarginProperty Field

Identifies the SwatchMargin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwatchMarginProperty
Public Shared ReadOnly SwatchMarginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwatchMargin dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushKind Enumeration

Specifies the kind of brush.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum BrushKind
Public Enumeration BrushKind
Members
Member name | Value | Description
None | 0 | Indicates that there is no brush.
SolidColor | 1 | Indicates that the brush is a solid color.
HorizontalLinearGradient | 2 | Indicates that the brush is a horizontal linear gradient.
VerticalLinearGradient | 3 | Indicates that the brush is a vertical linear gradient.
DiagonalDownwardLinearGradient | 4 | Indicates that the brush is a diagonal downward linear gradient.
DiagonalUpwardLinearGradient | 5 | Indicates that the brush is a diagonal upward linear gradient.
RadialGradient | 6 | Indicates that the brush is a radial gradient.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker Class

Represents a Brush picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsBrushPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BrushPicker : PickerBase
Public Class BrushPicker
    Inherits PickerBase

The BrushPicker type exposes the following members.

Constructors
 | Name | Description
Public method | BrushPicker | Initializes an instance of the BrushPicker class.
Top
Properties
 | Name | Description
Public property | AddGradientStopButtonToolTip | Gets or sets the tooltip for the add gradient stop button.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrushKind | Gets a BrushKind indicating the kind of brush that is being edited.
Public property | CanReuseBrush | Gets or sets whether the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsGradient | Gets whether the brush being edited is a GradientBrush.
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsNull | Gets whether the brush being edited is a null value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RemoveGradientStopButtonToolTip | Gets or sets the tooltip for the remove gradient stop button.
Public property | ReverseGradientStopsButtonToolTip | Gets or sets the tooltip for the reverse gradient stops button.
Public property | SelectedColor | Gets or sets the currently selected Color.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
AddGradientStopButtonToolTipProperty | Identifies the AddGradientStopButtonToolTip dependency property. This field is read-only.
BrushKindProperty | Identifies the BrushKind dependency property. This field is read-only.
CanReuseBrushProperty | Identifies the CanReuseBrush dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
IsGradientProperty | Identifies the IsGradient dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsNullProperty | Identifies the IsNull dependency property. This field is read-only.
RemoveGradientStopButtonToolTipProperty | Identifies the RemoveGradientStopButtonToolTip dependency property. This field is read-only.
ReverseGradientStopsButtonToolTipProperty | Identifies the ReverseGradientStopsButtonToolTip dependency property. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker Constructor

Initializes an instance of the BrushPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BrushPicker()
Public Sub New
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker Properties

The BrushPicker type exposes the following members.

Properties
 | Name | Description
Public property | AddGradientStopButtonToolTip | Gets or sets the tooltip for the add gradient stop button.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrushKind | Gets a BrushKind indicating the kind of brush that is being edited.
Public property | CanReuseBrush | Gets or sets whether the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsGradient | Gets whether the brush being edited is a GradientBrush.
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsNull | Gets whether the brush being edited is a null value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RemoveGradientStopButtonToolTip | Gets or sets the tooltip for the remove gradient stop button.
Public property | ReverseGradientStopsButtonToolTip | Gets or sets the tooltip for the reverse gradient stops button.
Public property | SelectedColor | Gets or sets the currently selected Color.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.AddGradientStopButtonToolTip Property

BrushPickerAddGradientStopButtonToolTip Property

Gets or sets the tooltip for the add gradient stop button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object AddGradientStopButtonToolTip { get; set; }
Public Property AddGradientStopButtonToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip for the add gradient stop button.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.BrushKind Property

BrushPickerBrushKind Property

Gets a BrushKind indicating the kind of brush that is being edited.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BrushKind BrushKind { get; }
Public ReadOnly Property BrushKind As BrushKind
    Get

Property Value

Type: BrushKind
A BrushKind indicating the kind of brush that is being edited.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.CanReuseBrush Property

BrushPickerCanReuseBrush Property

Gets or sets whether the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanReuseBrush { get; set; }
Public Property CanReuseBrush As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update; otherwise, false. The default value is true.
Remarks
Set this to false in scenarios where ValueChanged events need to fire on any update, or when binding to Value using value converters.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsAlphaEnabled Property

BrushPickerIsAlphaEnabled Property

Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the brush value colors is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsGradient Property

BrushPickerIsGradient Property

Gets whether the brush being edited is a GradientBrush.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGradient { get; }
Public ReadOnly Property IsGradient As Boolean
    Get

Property Value

Type: Boolean
true if the brush being edited is a GradientBrush; otherwise, false.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsGradientAllowed Property

BrushPickerIsGradientAllowed Property

Gets or sets whether gradient brush values can be entered.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGradientAllowed { get; set; }
Public Property IsGradientAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if gradient brush values can be entered; otherwise, false. The default value is true.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsNull Property

BrushPickerIsNull Property

Gets whether the brush being edited is a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get

Property Value

Type: Boolean
true if the brush being edited is a null value; otherwise, false.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsNullAllowed Property

BrushPickerIsNullAllowed Property

Gets or sets a value indicating whether null values are allowed to be entered by the user.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNullAllowed { get; set; }
Public Property IsNullAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if null values are allowed to be entered by the user; otherwise false. The default value is true.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.RemoveGradientStopButtonToolTip Property

BrushPickerRemoveGradientStopButtonToolTip Property

Gets or sets the tooltip for the remove gradient stop button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object RemoveGradientStopButtonToolTip { get; set; }
Public Property RemoveGradientStopButtonToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip for the remove gradient stop button.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.ReverseGradientStopsButtonToolTip Property

BrushPickerReverseGradientStopsButtonToolTip Property

Gets or sets the tooltip for the reverse gradient stops button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ReverseGradientStopsButtonToolTip { get; set; }
Public Property ReverseGradientStopsButtonToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip for the reverse gradient stops button.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.SelectedColor Property

BrushPickerSelectedColor Property

Gets or sets the currently selected Color.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set

Property Value

Type: Color
The currently selected Color.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.Value Property

BrushPickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Value { get; set; }
Public Property Value As Brush
    Get
    Set

Property Value

Type: Brush
The value of the control.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker Methods

The BrushPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.OnApplyTemplate Method

BrushPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker Events

The BrushPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.ValueChanged Event

BrushPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker Fields

The BrushPicker type exposes the following members.

Fields
Name | Description
AddGradientStopButtonToolTipProperty | Identifies the AddGradientStopButtonToolTip dependency property. This field is read-only.
BrushKindProperty | Identifies the BrushKind dependency property. This field is read-only.
CanReuseBrushProperty | Identifies the CanReuseBrush dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
IsGradientProperty | Identifies the IsGradient dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsNullProperty | Identifies the IsNull dependency property. This field is read-only.
RemoveGradientStopButtonToolTipProperty | Identifies the RemoveGradientStopButtonToolTip dependency property. This field is read-only.
ReverseGradientStopsButtonToolTipProperty | Identifies the ReverseGradientStopsButtonToolTip dependency property. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.AddGradientStopButtonToolTipProperty Field

BrushPickerAddGradientStopButtonToolTipProperty Field

Identifies the AddGradientStopButtonToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AddGradientStopButtonToolTipProperty
Public Shared ReadOnly AddGradientStopButtonToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AddGradientStopButtonToolTip dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.BrushKindProperty Field

BrushPickerBrushKindProperty Field

Identifies the BrushKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrushKindProperty
Public Shared ReadOnly BrushKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BrushKind dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.CanReuseBrushProperty Field

BrushPickerCanReuseBrushProperty Field

Identifies the CanReuseBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanReuseBrushProperty
Public Shared ReadOnly CanReuseBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanReuseBrush dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsAlphaEnabledProperty Field

BrushPickerIsAlphaEnabledProperty Field

Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsGradientAllowedProperty Field

BrushPickerIsGradientAllowedProperty Field

Identifies the IsGradientAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGradientAllowedProperty
Public Shared ReadOnly IsGradientAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGradientAllowed dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsGradientProperty Field

BrushPickerIsGradientProperty Field

Identifies the IsGradient dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGradientProperty
Public Shared ReadOnly IsGradientProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGradient dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsNullAllowedProperty Field

BrushPickerIsNullAllowedProperty Field

Identifies the IsNullAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNullAllowedProperty
Public Shared ReadOnly IsNullAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNullAllowed dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.IsNullProperty Field

BrushPickerIsNullProperty Field

Identifies the IsNull dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNullProperty
Public Shared ReadOnly IsNullProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNull dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.RemoveGradientStopButtonToolTipProperty Field

BrushPickerRemoveGradientStopButtonToolTipProperty Field

Identifies the RemoveGradientStopButtonToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RemoveGradientStopButtonToolTipProperty
Public Shared ReadOnly RemoveGradientStopButtonToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RemoveGradientStopButtonToolTip dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.ReverseGradientStopsButtonToolTipProperty Field

BrushPickerReverseGradientStopsButtonToolTipProperty Field

Identifies the ReverseGradientStopsButtonToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReverseGradientStopsButtonToolTipProperty
Public Shared ReadOnly ReverseGradientStopsButtonToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReverseGradientStopsButtonToolTip dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.SelectedColorProperty Field

BrushPickerSelectedColorProperty Field

Identifies the SelectedColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedColorProperty
Public Shared ReadOnly SelectedColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedColor dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BrushPicker.ValueProperty Field

BrushPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox Class

Represents an Byte edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Byte
ActiproSoftware.Windows.Controls.EditorsByteEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ByteEditBox : PartEditBoxBase<Nullable<byte>>
Public Class ByteEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Byte))

The ByteEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | ByteEditBox | Initializes an instance of the ByteEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox Constructor

Initializes an instance of the ByteEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ByteEditBox()
Public Sub New
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox Properties

The ByteEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.CalculatorPopupPickerStyle Property

ByteEditBoxCalculatorPopupPickerStyle Property

Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.DefaultValue Property

ByteEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte DefaultValue { get; set; }
Public Property DefaultValue As Byte
    Get
    Set

Property Value

Type: Byte
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.Format Property

ByteEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.LargeChange Property

ByteEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte LargeChange { get; set; }
Public Property LargeChange As Byte
    Get
    Set

Property Value

Type: Byte
The large change value. The default value is 5.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.Maximum Property

ByteEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte Maximum { get; set; }
Public Property Maximum As Byte
    Get
    Set

Property Value

Type: Byte
The highest possible value.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.Minimum Property

ByteEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte Minimum { get; set; }
Public Property Minimum As Byte
    Get
    Set

Property Value

Type: Byte
The lowest possible value.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.PickerKind Property

ByteEditBoxPickerKind Property

Gets or sets an ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ByteEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As ByteEditBoxPickerKind
    Get
    Set

Property Value

Type: ByteEditBoxPickerKind
An ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.ResolvedFormat Property

ByteEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.SmallChange Property

ByteEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte SmallChange { get; set; }
Public Property SmallChange As Byte
    Get
    Set

Property Value

Type: Byte
The small change value. The default value is 1.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox Methods

The ByteEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.CoerceValidValue Method

ByteEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<byte> CoerceValidValue(
    Nullable<byte> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Byte)
) As Nullable(Of Byte)

Parameters

value
Type: SystemNullable Byte
The value to coerce.

Return Value

Type: Nullable Byte
The coerced value.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.ConvertToString Method

ByteEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<byte> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Byte)
) As String

Parameters

valueToConvert
Type: SystemNullable Byte
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.CreateIncrementalChangeRequest Method

ByteEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<byte>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Byte))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Byte
The incremental change (spin) request that was created.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.GenerateParts Method

ByteEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.IsValidValue Method

ByteEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<byte> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Byte)
) As Boolean

Parameters

value
Type: SystemNullable Byte
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.RaiseValueChangedEvent Method

ByteEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.ResetValue Method

ByteEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.TryConvertFromString Method

ByteEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<byte> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Byte)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Byte
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox Events

The ByteEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.ValueChanged Event

ByteEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox Fields

The ByteEditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.CalculatorPopupPickerStyleProperty Field

ByteEditBoxCalculatorPopupPickerStyleProperty Field

Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.DefaultValueProperty Field

ByteEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.FormatProperty Field

ByteEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.LargeChangeProperty Field

ByteEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.MaximumProperty Field

ByteEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.MinimumProperty Field

ByteEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.PickerKindProperty Field

ByteEditBoxPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.ResolvedFormatProperty Field

ByteEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBox.SmallChangeProperty Field

ByteEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

ByteEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ByteEditBoxPickerKind Enumeration

Specifies the kind of Style to apply to the BytePicker used within a ByteEditBox's popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ByteEditBoxPickerKind
Public Enumeration ByteEditBoxPickerKind
Members
Member name | Value | Description
Default | 0 | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default BytePicker style, which is templated to contain a radial slider control.
Calculator | 1 | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker Class

Represents an Byte picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.Windows.Controls.EditorsBytePicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BytePicker : RadialSliderPickerBase
Public Class BytePicker
    Inherits RadialSliderPickerBase

The BytePicker type exposes the following members.

Constructors
 | Name | Description
Public method | BytePicker | Initializes an instance of the BytePicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker Constructor

Initializes an instance of the BytePicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BytePicker()
Public Sub New
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker Properties

The BytePicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.Maximum Property

BytePickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte Maximum { get; set; }
Public Property Maximum As Byte
    Get
    Set

Property Value

Type: Byte
The highest possible value.
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.Minimum Property

BytePickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte Minimum { get; set; }
Public Property Minimum As Byte
    Get
    Set

Property Value

Type: Byte
The lowest possible value.
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.SmallChange Property

BytePickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte SmallChange { get; set; }
Public Property SmallChange As Byte
    Get
    Set

Property Value

Type: Byte
The small change value. The default value is 1.
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.Value Property

BytePickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte Value { get; set; }
Public Property Value As Byte
    Get
    Set

Property Value

Type: Byte
The value of the control.
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker Methods

The BytePicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.OnApplyTemplate Method

BytePickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker Events

The BytePicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.ValueChanged Event

BytePickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker Fields

The BytePicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.MaximumProperty Field

BytePickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.MinimumProperty Field

BytePickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.SmallChangeProperty Field

BytePickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


BytePicker.ValueProperty Field

BytePickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

BytePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator Class

Represents a calculator control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.EditorsCalculator

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Calculator : Control
Public Class Calculator
    Inherits Control

The Calculator type exposes the following members.

Constructors
 | Name | Description
Public method | Calculator | Initializes an instance of the Calculator class.
Top
Properties
 | Name | Description
Public property | AcceptsEscape | Gets or sets whether to accept the Escape key for clearing the calculator's current entry and value.
Public property | AddToMemoryCommand | Gets the ICommand that can add to memory.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BackspaceCommand | Gets the ICommand that can backspace a digit.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculateCommand | Gets the ICommand that can calculate the result.
Public property | ClearCommand | Gets the ICommand that can clear the current entry and value.
Public property | ClearEntryCommand | Gets the ICommand that can clear the current entry.
Public property | ClearMemoryCommand | Gets the ICommand that can clear memory.
Public property | DigitButtonStyle | Gets or sets the Style to use for digit buttons.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayFontSize | Gets or sets the display font size.
Public property | DisplayText | Gets the text that represents the calculator output.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasDisplay | Gets or sets whether the calculator output is displayed.
Public property | HasMemoryButtons | Gets or sets whether the memory buttons are displayed.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InsertDecimalSeparatorCommand | Gets the ICommand that can insert a decimal separator.
Public property | InsertDigitCommand | Gets the ICommand that can insert a digit.
Public property | IsOutOfRange | Gets whether the calculated value is outside the Minimum and Maximum range.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MemoryButtonStyle | Gets or sets the Style to use for memory buttons.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | OperationButtonStyle | Gets or sets the Style to use for operation buttons.
Public property | OperationCommand | Gets the ICommand that can execute an operation.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RecallMemoryCommand | Gets the ICommand that can recall memory.
Public property | SetMemoryCommand | Gets the ICommand that can set memory.
Public property | SubtractFromMemoryCommand | Gets the ICommand that can subtract from memory.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the current calculated value.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
AcceptsEscapeProperty | Identifies the AcceptsEscape dependency property. This field is read-only.
DigitButtonStyleProperty | Identifies the DigitButtonStyle dependency property. This field is read-only.
DisplayFontSizeProperty | Identifies the DisplayFontSize dependency property. This field is read-only.
DisplayTextProperty | Identifies the DisplayText dependency property. This field is read-only.
HasDisplayProperty | Identifies the HasDisplay dependency property. This field is read-only.
HasMemoryButtonsProperty | Identifies the HasMemoryButtons dependency property. This field is read-only.
IsOutOfRangeProperty | Identifies the IsOutOfRange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MemoryButtonStyleProperty | Identifies the MemoryButtonStyle dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OperationButtonStyleProperty | Identifies the OperationButtonStyle dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Calculator Constructor

Initializes an instance of the Calculator class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Calculator()
Public Sub New
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator Properties

The Calculator type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsEscape | Gets or sets whether to accept the Escape key for clearing the calculator's current entry and value.
Public property | AddToMemoryCommand | Gets the ICommand that can add to memory.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BackspaceCommand | Gets the ICommand that can backspace a digit.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculateCommand | Gets the ICommand that can calculate the result.
Public property | ClearCommand | Gets the ICommand that can clear the current entry and value.
Public property | ClearEntryCommand | Gets the ICommand that can clear the current entry.
Public property | ClearMemoryCommand | Gets the ICommand that can clear memory.
Public property | DigitButtonStyle | Gets or sets the Style to use for digit buttons.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayFontSize | Gets or sets the display font size.
Public property | DisplayText | Gets the text that represents the calculator output.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasDisplay | Gets or sets whether the calculator output is displayed.
Public property | HasMemoryButtons | Gets or sets whether the memory buttons are displayed.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InsertDecimalSeparatorCommand | Gets the ICommand that can insert a decimal separator.
Public property | InsertDigitCommand | Gets the ICommand that can insert a digit.
Public property | IsOutOfRange | Gets whether the calculated value is outside the Minimum and Maximum range.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MemoryButtonStyle | Gets or sets the Style to use for memory buttons.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | OperationButtonStyle | Gets or sets the Style to use for operation buttons.
Public property | OperationCommand | Gets the ICommand that can execute an operation.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RecallMemoryCommand | Gets the ICommand that can recall memory.
Public property | SetMemoryCommand | Gets the ICommand that can set memory.
Public property | SubtractFromMemoryCommand | Gets the ICommand that can subtract from memory.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the current calculated value.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.AcceptsEscape Property

CalculatorAcceptsEscape Property

Gets or sets whether to accept the Escape key for clearing the calculator's current entry and value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AcceptsEscape { get; set; }
Public Property AcceptsEscape As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Escape key should be accepted; otherwise, false. The default value is true.
Remarks
The Shift+Del key can also be used to clear the calculator's current entry and value.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.AddToMemoryCommand Property

CalculatorAddToMemoryCommand Property

Gets the ICommand that can add to memory.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand AddToMemoryCommand { get; }
Public ReadOnly Property AddToMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can add to memory.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.BackspaceCommand Property

CalculatorBackspaceCommand Property

Gets the ICommand that can backspace a digit.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand BackspaceCommand { get; }
Public ReadOnly Property BackspaceCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can backspace a digit.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.CalculateCommand Property

CalculatorCalculateCommand Property

Gets the ICommand that can calculate the result.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CalculateCommand { get; }
Public ReadOnly Property CalculateCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can calculate the result.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.ClearCommand Property

CalculatorClearCommand Property

Gets the ICommand that can clear the current entry and value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ClearCommand { get; }
Public ReadOnly Property ClearCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can clear the current entry and value.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.ClearEntryCommand Property

CalculatorClearEntryCommand Property

Gets the ICommand that can clear the current entry.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ClearEntryCommand { get; }
Public ReadOnly Property ClearEntryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can clear the current entry.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.ClearMemoryCommand Property

CalculatorClearMemoryCommand Property

Gets the ICommand that can clear memory.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ClearMemoryCommand { get; }
Public ReadOnly Property ClearMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can clear memory.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.DigitButtonStyle Property

CalculatorDigitButtonStyle Property

Gets or sets the Style to use for digit buttons.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style DigitButtonStyle { get; set; }
Public Property DigitButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for digit buttons.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.DisplayFontSize Property

CalculatorDisplayFontSize Property

Gets or sets the display font size.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DisplayFontSize { get; set; }
Public Property DisplayFontSize As Double
    Get
    Set

Property Value

Type: Double
The display font size.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.DisplayText Property

CalculatorDisplayText Property

Gets the text that represents the calculator output.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DisplayText { get; }
Public ReadOnly Property DisplayText As String
    Get

Property Value

Type: String
The text that represents the calculator output. The default value is "0".
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.HasDisplay Property

CalculatorHasDisplay Property

Gets or sets whether the calculator output is displayed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDisplay { get; set; }
Public Property HasDisplay As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the calculator output is displayed; otherwise, false. The default value is true.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.HasMemoryButtons Property

CalculatorHasMemoryButtons Property

Gets or sets whether the memory buttons are displayed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasMemoryButtons { get; set; }
Public Property HasMemoryButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the memory buttons are displayed; otherwise, false. The default value is true.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.InsertDecimalSeparatorCommand Property

CalculatorInsertDecimalSeparatorCommand Property

Gets the ICommand that can insert a decimal separator.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand InsertDecimalSeparatorCommand { get; }
Public ReadOnly Property InsertDecimalSeparatorCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can insert a decimal separator.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.InsertDigitCommand Property

CalculatorInsertDigitCommand Property

Gets the ICommand that can insert a digit.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand InsertDigitCommand { get; }
Public ReadOnly Property InsertDigitCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can insert a digit.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.IsOutOfRange Property

CalculatorIsOutOfRange Property

Gets whether the calculated value is outside the Minimum and Maximum range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOutOfRange { get; }
Public ReadOnly Property IsOutOfRange As Boolean
    Get

Property Value

Type: Boolean
true if the calculated value is outside the Minimum and Maximum range; otherwise, false.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace
CalculatorMinimum
CalculatorMaximum


Calculator.Maximum Property

CalculatorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible value.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace
CalculatorIsOutOfRange


Calculator.MemoryButtonStyle Property

CalculatorMemoryButtonStyle Property

Gets or sets the Style to use for memory buttons.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MemoryButtonStyle { get; set; }
Public Property MemoryButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for memory buttons.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.Minimum Property

CalculatorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible value.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace
CalculatorIsOutOfRange


Calculator.OperationButtonStyle Property

CalculatorOperationButtonStyle Property

Gets or sets the Style to use for operation buttons.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style OperationButtonStyle { get; set; }
Public Property OperationButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for operation buttons.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.OperationCommand Property

CalculatorOperationCommand Property

Gets the ICommand that can execute an operation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand OperationCommand { get; }
Public ReadOnly Property OperationCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can execute an operation.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.RecallMemoryCommand Property

CalculatorRecallMemoryCommand Property

Gets the ICommand that can recall memory.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand RecallMemoryCommand { get; }
Public ReadOnly Property RecallMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can recall memory.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.SetMemoryCommand Property

CalculatorSetMemoryCommand Property

Gets the ICommand that can set memory.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SetMemoryCommand { get; }
Public ReadOnly Property SetMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can set memory.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.SubtractFromMemoryCommand Property

CalculatorSubtractFromMemoryCommand Property

Gets the ICommand that can subtract from memory.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SubtractFromMemoryCommand { get; }
Public ReadOnly Property SubtractFromMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can subtract from memory.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.Value Property

CalculatorValue Property

Gets or sets the current calculated value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The current calculated value. The default value is 0.0.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator Methods

The Calculator type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.OnApplyTemplate Method

CalculatorOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.OnCreateAutomationPeer Method

CalculatorOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.OnGotFocus Method

CalculatorOnGotFocus Method

Occurs when the control gains focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.OnKeyDown Method

CalculatorOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.OnLostFocus Method

CalculatorOnLostFocus Method

Occurs when the control loses focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator Events

The Calculator type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.ValueChanged Event

CalculatorValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator Fields

The Calculator type exposes the following members.

Fields
Name | Description
AcceptsEscapeProperty | Identifies the AcceptsEscape dependency property. This field is read-only.
DigitButtonStyleProperty | Identifies the DigitButtonStyle dependency property. This field is read-only.
DisplayFontSizeProperty | Identifies the DisplayFontSize dependency property. This field is read-only.
DisplayTextProperty | Identifies the DisplayText dependency property. This field is read-only.
HasDisplayProperty | Identifies the HasDisplay dependency property. This field is read-only.
HasMemoryButtonsProperty | Identifies the HasMemoryButtons dependency property. This field is read-only.
IsOutOfRangeProperty | Identifies the IsOutOfRange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MemoryButtonStyleProperty | Identifies the MemoryButtonStyle dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OperationButtonStyleProperty | Identifies the OperationButtonStyle dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.AcceptsEscapeProperty Field

CalculatorAcceptsEscapeProperty Field

Identifies the AcceptsEscape dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AcceptsEscapeProperty
Public Shared ReadOnly AcceptsEscapeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AcceptsEscape dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.DigitButtonStyleProperty Field

CalculatorDigitButtonStyleProperty Field

Identifies the DigitButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DigitButtonStyleProperty
Public Shared ReadOnly DigitButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DigitButtonStyle dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.DisplayFontSizeProperty Field

CalculatorDisplayFontSizeProperty Field

Identifies the DisplayFontSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayFontSizeProperty
Public Shared ReadOnly DisplayFontSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayFontSize dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.DisplayTextProperty Field

CalculatorDisplayTextProperty Field

Identifies the DisplayText dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayTextProperty
Public Shared ReadOnly DisplayTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayText dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.HasDisplayProperty Field

CalculatorHasDisplayProperty Field

Identifies the HasDisplay dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasDisplayProperty
Public Shared ReadOnly HasDisplayProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasDisplay dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.HasMemoryButtonsProperty Field

CalculatorHasMemoryButtonsProperty Field

Identifies the HasMemoryButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasMemoryButtonsProperty
Public Shared ReadOnly HasMemoryButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasMemoryButtons dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.IsOutOfRangeProperty Field

CalculatorIsOutOfRangeProperty Field

Identifies the IsOutOfRange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOutOfRangeProperty
Public Shared ReadOnly IsOutOfRangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOutOfRange dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.MaximumProperty Field

CalculatorMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.MemoryButtonStyleProperty Field

CalculatorMemoryButtonStyleProperty Field

Identifies the MemoryButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MemoryButtonStyleProperty
Public Shared ReadOnly MemoryButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MemoryButtonStyle dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.MinimumProperty Field

CalculatorMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.OperationButtonStyleProperty Field

CalculatorOperationButtonStyleProperty Field

Identifies the OperationButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OperationButtonStyleProperty
Public Shared ReadOnly OperationButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OperationButtonStyle dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


Calculator.ValueProperty Field

CalculatorValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.Windows.Controls.Editors Namespace


CalculatorOperationKind Enumeration

Specifies an operation used with a calculator.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CalculatorOperationKind
Public Enumeration CalculatorOperationKind
Members
Member name | Value | Description
Add | 0 | Add.
Subtract | 1 | Subtract.
Multiply | 2 | Multiply.
Divide | 3 | Divide.
Percent | 4 | Convert the entry to a percentage of the previous operand.
Reciprocal | 5 | Reciprocal (1/x).
SquareRoot | 6 | Square root.
ToggleSign | 7 | Toggle whether the number is positve or negative.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox Class

Represents a Color edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Color
ActiproSoftware.Windows.Controls.EditorsColorEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ColorEditBox : PartEditBoxBase<Nullable<Color>>
Public Class ColorEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Color))

The ColorEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | ColorEditBox | Initializes an instance of the ColorEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsInitialValueComparedOnPopup | Gets or sets a value indicating whether the initial color value is compared to the current value in the popup color picker.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | SwatchBrush | Gets the Brush that renders a sample swatch.
Public property | SwatchMargin | Gets or sets the Thickness of the margin around the sample swatch.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from PartEditBoxBaseT.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Overrides PartEditBoxBaseTOnIntermediateValueChanged(T, T).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Overrides PartEditBoxBaseTOnPopupOpened.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsInitialValueComparedOnPopupProperty | Identifies the IsInitialValueComparedOnPopup dependency property. This field is read-only.
SwatchBrushProperty | Identifies the SwatchBrush dependency property. This field is read-only.
SwatchMarginProperty | Identifies the SwatchMargin dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox Constructor

Initializes an instance of the ColorEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorEditBox()
Public Sub New
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox Properties

The ColorEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsInitialValueComparedOnPopup | Gets or sets a value indicating whether the initial color value is compared to the current value in the popup color picker.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | SwatchBrush | Gets the Brush that renders a sample swatch.
Public property | SwatchMargin | Gets or sets the Thickness of the margin around the sample swatch.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.DefaultValue Property

ColorEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color DefaultValue { get; set; }
Public Property DefaultValue As Color
    Get
    Set

Property Value

Type: Color
The value to set when incrementing/decrementing from a null value. The default value is Red.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.HasPopupButtonWhenReadOnly Property

ColorEditBoxHasPopupButtonWhenReadOnly Property

Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.HasSwatch Property

ColorEditBoxHasSwatch Property

Gets or sets whether the edit box should display a swatch that previews the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box should display a swatch that previews the Value; otherwise, false. The default value is true.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.IsAlphaEnabled Property

ColorEditBoxIsAlphaEnabled Property

Gets or sets whether the alpha channel (transparency) of the color value is enabled.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the color value is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.IsInitialValueComparedOnPopup Property

ColorEditBoxIsInitialValueComparedOnPopup Property

Gets or sets a value indicating whether the initial color value is compared to the current value in the popup color picker.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsInitialValueComparedOnPopup { get; set; }
Public Property IsInitialValueComparedOnPopup As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the initial color value is compared to the current value in the popup color picker; otherwise false. The default value is true.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.SwatchBrush Property

ColorEditBoxSwatchBrush Property

Gets the Brush that renders a sample swatch.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush SwatchBrush { get; }
Public ReadOnly Property SwatchBrush As Brush
    Get

Property Value

Type: Brush
The Brush that renders a sample swatch.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.SwatchMargin Property

ColorEditBoxSwatchMargin Property

Gets or sets the Thickness of the margin around the sample swatch.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness SwatchMargin { get; set; }
Public Property SwatchMargin As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the margin around the sample swatch.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox Methods

The ColorEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from PartEditBoxBaseT.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Overrides PartEditBoxBaseTOnIntermediateValueChanged(T, T).)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Overrides PartEditBoxBaseTOnPopupOpened.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.ConvertToString Method

ColorEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Color> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Color)
) As String

Parameters

valueToConvert
Type: SystemNullable Color
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.CreateIncrementalChangeRequest Method

ColorEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Color>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Color))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Color
The incremental change (spin) request that was created.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.GenerateParts Method

ColorEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.IsValidValue Method

ColorEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Color> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Color)
) As Boolean

Parameters

value
Type: SystemNullable Color
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.OnApplyTemplate Method

ColorEditBoxOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.OnIntermediateValueChanged Method

ColorEditBoxOnIntermediateValueChanged Method

Invoked when the value of the IntermediateValue property changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIntermediateValueChanged(
    Nullable<Color> oldValue,
    Nullable<Color> newValue
)
Protected Overrides Sub OnIntermediateValueChanged (
    oldValue As Nullable(Of Color),
    newValue As Nullable(Of Color)
)

Parameters

oldValue
Type: SystemNullable Color
The old value of the property.
newValue
Type: SystemNullable Color
The new value of the property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.OnPopupOpened Method

ColorEditBoxOnPopupOpened Method

Occurs when the popup is opened.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPopupOpened()
Protected Overrides Sub OnPopupOpened
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.RaiseValueChangedEvent Method

ColorEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.ResetValue Method

ColorEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.TryConvertFromString Method

ColorEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Color> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Color)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Color
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox Events

The ColorEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.ValueChanged Event

ColorEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox Fields

The ColorEditBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsInitialValueComparedOnPopupProperty | Identifies the IsInitialValueComparedOnPopup dependency property. This field is read-only.
SwatchBrushProperty | Identifies the SwatchBrush dependency property. This field is read-only.
SwatchMarginProperty | Identifies the SwatchMargin dependency property. This field is read-only.
Top
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.DefaultValueProperty Field

ColorEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.HasSwatchProperty Field

ColorEditBoxHasSwatchProperty Field

Identifies the HasSwatch dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasSwatchProperty
Public Shared ReadOnly HasSwatchProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasSwatch dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.IsAlphaEnabledProperty Field

ColorEditBoxIsAlphaEnabledProperty Field

Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.IsInitialValueComparedOnPopupProperty Field

ColorEditBoxIsInitialValueComparedOnPopupProperty Field

Identifies the IsInitialValueComparedOnPopup dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsInitialValueComparedOnPopupProperty
Public Shared ReadOnly IsInitialValueComparedOnPopupProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsInitialValueComparedOnPopup dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.SwatchBrushProperty Field

ColorEditBoxSwatchBrushProperty Field

Identifies the SwatchBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwatchBrushProperty
Public Shared ReadOnly SwatchBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwatchBrush dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorEditBox.SwatchMarginProperty Field

ColorEditBoxSwatchMarginProperty Field

Identifies the SwatchMargin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwatchMarginProperty
Public Shared ReadOnly SwatchMarginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwatchMargin dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker Class

Represents a color picker control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsColorPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ColorPicker : PickerBase
Public Class ColorPicker
    Inherits PickerBase

The ColorPicker type exposes the following members.

Constructors
 | Name | Description
Public method | ColorPicker | Initializes an instance of the ColorPicker class.
Top
Properties
 | Name | Description
Public property | A | Gets or sets the alpha transparency component (0 - 255) of the Value.
Public property | B | Gets or sets the RGB blue component (0 - 255) of the Value.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the HSB brightness component (0 - 1.0) of the Value.
Public property | ComparisonValue | Gets or sets the comparison color.
Public property | Component1SwatchBrush | Gets the Brush to render in the component 1 swatch.
Public property | Component2SwatchBrush | Gets the Brush to render in the component 2 swatch.
Public property | Component3SwatchBrush | Gets the Brush to render in the component 3 swatch.
Public property | DegreeInlineTemplate | Gets or sets the DataTemplate with inline content for a degree glyph.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | G | Gets or sets the RGB green component (0 - 255) of the Value.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasColorEditBox | Gets or sets whether an embedded ColorEditBox should appear in the picker for hex-based color entry.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the HSB hue component (0 - 359.00) of the Value.
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsComparisonValueVisible | Gets or sets a value indicating whether the comparison value is visible.
Public property | IsEditable | Gets or sets a value indicating whether the edit box text areas within the control are editable.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PercentInlineTemplate | Gets or sets the DataTemplate with inline content for a percent glyph.
Public property | R | Gets or sets the RGB red component (0 - 255) of the Value.
Public property | Saturation | Gets or sets the HSB saturation component (0 - 1.0) of the Value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextInputMode | Gets or sets the text input mode of the picker.
Public property | Value | Gets or sets the selected color.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BProperty | Identifies the B dependency property. This field is read-only.
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
ComparisonValueProperty | Identifies the ComparisonValue dependency property. This field is read-only.
Component1SwatchBrushProperty | Identifies the Component1SwatchBrush dependency property. This field is read-only.
Component2SwatchBrushProperty | Identifies the Component2SwatchBrush dependency property. This field is read-only.
Component3SwatchBrushProperty | Identifies the Component3SwatchBrush dependency property. This field is read-only.
DegreeInlineTemplateProperty | Identifies the DegreeInlineTemplate dependency property. This field is read-only.
GProperty | Identifies the G dependency property. This field is read-only.
HasColorEditBoxProperty | Identifies the HasColorEditBox dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsComparisonValueVisibleProperty | Identifies the IsComparisonValueVisible dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
PercentInlineTemplateProperty | Identifies the PercentInlineTemplate dependency property. This field is read-only.
RProperty | Identifies the R dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
TextInputModeProperty | Identifies the TextInputMode dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker Constructor

Initializes an instance of the ColorPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorPicker()
Public Sub New
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker Properties

The ColorPicker type exposes the following members.

Properties
 | Name | Description
Public property | A | Gets or sets the alpha transparency component (0 - 255) of the Value.
Public property | B | Gets or sets the RGB blue component (0 - 255) of the Value.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the HSB brightness component (0 - 1.0) of the Value.
Public property | ComparisonValue | Gets or sets the comparison color.
Public property | Component1SwatchBrush | Gets the Brush to render in the component 1 swatch.
Public property | Component2SwatchBrush | Gets the Brush to render in the component 2 swatch.
Public property | Component3SwatchBrush | Gets the Brush to render in the component 3 swatch.
Public property | DegreeInlineTemplate | Gets or sets the DataTemplate with inline content for a degree glyph.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | G | Gets or sets the RGB green component (0 - 255) of the Value.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasColorEditBox | Gets or sets whether an embedded ColorEditBox should appear in the picker for hex-based color entry.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the HSB hue component (0 - 359.00) of the Value.
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsComparisonValueVisible | Gets or sets a value indicating whether the comparison value is visible.
Public property | IsEditable | Gets or sets a value indicating whether the edit box text areas within the control are editable.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PercentInlineTemplate | Gets or sets the DataTemplate with inline content for a percent glyph.
Public property | R | Gets or sets the RGB red component (0 - 255) of the Value.
Public property | Saturation | Gets or sets the HSB saturation component (0 - 1.0) of the Value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextInputMode | Gets or sets the text input mode of the picker.
Public property | Value | Gets or sets the selected color.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.A Property

ColorPickerA Property

Gets or sets the alpha transparency component (0 - 255) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int A { get; set; }
Public Property A As Integer
    Get
    Set

Property Value

Type: Int32
The alpha transparency component of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.B Property

ColorPickerB Property

Gets or sets the RGB blue component (0 - 255) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int B { get; set; }
Public Property B As Integer
    Get
    Set

Property Value

Type: Int32
The RGB blue component of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Brightness Property

ColorPickerBrightness Property

Gets or sets the HSB brightness component (0 - 1.0) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set

Property Value

Type: Double
The HSB brightness component (0 - 1.0) of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.ComparisonValue Property

ColorPickerComparisonValue Property

Gets or sets the comparison color.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color ComparisonValue { get; set; }
Public Property ComparisonValue As Color
    Get
    Set

Property Value

Type: Color
The comparison color.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Component1SwatchBrush Property

ColorPickerComponent1SwatchBrush Property

Gets the Brush to render in the component 1 swatch.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Component1SwatchBrush { get; }
Public ReadOnly Property Component1SwatchBrush As Brush
    Get

Property Value

Type: Brush
The Brush to render in the component 1 swatch.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Component2SwatchBrush Property

ColorPickerComponent2SwatchBrush Property

Gets the Brush to render in the component 2 swatch.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Component2SwatchBrush { get; }
Public ReadOnly Property Component2SwatchBrush As Brush
    Get

Property Value

Type: Brush
The Brush to render in the component 2 swatch.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Component3SwatchBrush Property

ColorPickerComponent3SwatchBrush Property

Gets the Brush to render in the component 3 swatch.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Component3SwatchBrush { get; }
Public ReadOnly Property Component3SwatchBrush As Brush
    Get

Property Value

Type: Brush
The Brush to render in the component 3 swatch.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.DegreeInlineTemplate Property

ColorPickerDegreeInlineTemplate Property

Gets or sets the DataTemplate with inline content for a degree glyph.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DegreeInlineTemplate { get; set; }
Public Property DegreeInlineTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate with inline content for a degree glyph.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.G Property

ColorPickerG Property

Gets or sets the RGB green component (0 - 255) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int G { get; set; }
Public Property G As Integer
    Get
    Set

Property Value

Type: Int32
The RGB green component of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.HasColorEditBox Property

ColorPickerHasColorEditBox Property

Gets or sets whether an embedded ColorEditBox should appear in the picker for hex-based color entry.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasColorEditBox { get; set; }
Public Property HasColorEditBox As Boolean
    Get
    Set

Property Value

Type: Boolean
true if an embedded ColorEditBox should appear in the picker for hex-based color entry; otherwise, false. The default value is true.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Hue Property

ColorPickerHue Property

Gets or sets the HSB hue component (0 - 359.00) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The HSB hue component (0 - 359.00) of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.IsAlphaEnabled Property

ColorPickerIsAlphaEnabled Property

Gets or sets whether the alpha channel (transparency) of the color value is enabled.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the color value is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.IsComparisonValueVisible Property

ColorPickerIsComparisonValueVisible Property

Gets or sets a value indicating whether the comparison value is visible.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsComparisonValueVisible { get; set; }
Public Property IsComparisonValueVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the comparison value is visible; otherwise false. The default value is false.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.IsEditable Property

ColorPickerIsEditable Property

Gets or sets a value indicating whether the edit box text areas within the control are editable.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box text areas within the control are editable; otherwise false. The default value is true.
Remarks
When false, the edit boxes behave more like a ComboBox.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.PercentInlineTemplate Property

ColorPickerPercentInlineTemplate Property

Gets or sets the DataTemplate with inline content for a percent glyph.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate PercentInlineTemplate { get; set; }
Public Property PercentInlineTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate with inline content for a percent glyph.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.R Property

ColorPickerR Property

Gets or sets the RGB red component (0 - 255) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int R { get; set; }
Public Property R As Integer
    Get
    Set

Property Value

Type: Int32
The RGB red component of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Saturation Property

ColorPickerSaturation Property

Gets or sets the HSB saturation component (0 - 1.0) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Saturation { get; set; }
Public Property Saturation As Double
    Get
    Set

Property Value

Type: Double
The HSB saturation component (0 - 1.0) of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.TextInputMode Property

ColorPickerTextInputMode Property

Gets or sets the text input mode of the picker.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorPickerTextInputMode TextInputMode { get; set; }
Public Property TextInputMode As ColorPickerTextInputMode
    Get
    Set

Property Value

Type: ColorPickerTextInputMode
The text input mode of the picker.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Value Property

ColorPickerValue Property

Gets or sets the selected color.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color Value { get; set; }
Public Property Value As Color
    Get
    Set

Property Value

Type: Color
The selected color.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker Methods

The ColorPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.OnApplyTemplate Method

ColorPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker Events

The ColorPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.ValueChanged Event

ColorPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker Fields

The ColorPicker type exposes the following members.

Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BProperty | Identifies the B dependency property. This field is read-only.
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
ComparisonValueProperty | Identifies the ComparisonValue dependency property. This field is read-only.
Component1SwatchBrushProperty | Identifies the Component1SwatchBrush dependency property. This field is read-only.
Component2SwatchBrushProperty | Identifies the Component2SwatchBrush dependency property. This field is read-only.
Component3SwatchBrushProperty | Identifies the Component3SwatchBrush dependency property. This field is read-only.
DegreeInlineTemplateProperty | Identifies the DegreeInlineTemplate dependency property. This field is read-only.
GProperty | Identifies the G dependency property. This field is read-only.
HasColorEditBoxProperty | Identifies the HasColorEditBox dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsComparisonValueVisibleProperty | Identifies the IsComparisonValueVisible dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
PercentInlineTemplateProperty | Identifies the PercentInlineTemplate dependency property. This field is read-only.
RProperty | Identifies the R dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
TextInputModeProperty | Identifies the TextInputMode dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.AProperty Field

ColorPickerAProperty Field

Identifies the A dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AProperty
Public Shared ReadOnly AProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the A dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.BProperty Field

ColorPickerBProperty Field

Identifies the B dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BProperty
Public Shared ReadOnly BProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the B dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.BrightnessProperty Field

ColorPickerBrightnessProperty Field

Identifies the Brightness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrightnessProperty
Public Shared ReadOnly BrightnessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Brightness dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.ComparisonValueProperty Field

ColorPickerComparisonValueProperty Field

Identifies the ComparisonValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparisonValueProperty
Public Shared ReadOnly ComparisonValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparisonValue dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Component1SwatchBrushProperty Field

ColorPickerComponent1SwatchBrushProperty Field

Identifies the Component1SwatchBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty Component1SwatchBrushProperty
Public Shared ReadOnly Component1SwatchBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Component1SwatchBrush dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Component2SwatchBrushProperty Field

ColorPickerComponent2SwatchBrushProperty Field

Identifies the Component2SwatchBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty Component2SwatchBrushProperty
Public Shared ReadOnly Component2SwatchBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Component2SwatchBrush dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.Component3SwatchBrushProperty Field

ColorPickerComponent3SwatchBrushProperty Field

Identifies the Component3SwatchBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty Component3SwatchBrushProperty
Public Shared ReadOnly Component3SwatchBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Component3SwatchBrush dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.DegreeInlineTemplateProperty Field

ColorPickerDegreeInlineTemplateProperty Field

Identifies the DegreeInlineTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeInlineTemplateProperty
Public Shared ReadOnly DegreeInlineTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeInlineTemplate dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.GProperty Field

ColorPickerGProperty Field

Identifies the G dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GProperty
Public Shared ReadOnly GProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the G dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.HasColorEditBoxProperty Field

ColorPickerHasColorEditBoxProperty Field

Identifies the HasColorEditBox dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasColorEditBoxProperty
Public Shared ReadOnly HasColorEditBoxProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasColorEditBox dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.HueProperty Field

ColorPickerHueProperty Field

Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.IsAlphaEnabledProperty Field

ColorPickerIsAlphaEnabledProperty Field

Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.IsComparisonValueVisibleProperty Field

ColorPickerIsComparisonValueVisibleProperty Field

Identifies the IsComparisonValueVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsComparisonValueVisibleProperty
Public Shared ReadOnly IsComparisonValueVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsComparisonValueVisible dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.IsEditableProperty Field

ColorPickerIsEditableProperty Field

Identifies the IsEditable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEditableProperty
Public Shared ReadOnly IsEditableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEditable dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.PercentInlineTemplateProperty Field

ColorPickerPercentInlineTemplateProperty Field

Identifies the PercentInlineTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PercentInlineTemplateProperty
Public Shared ReadOnly PercentInlineTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PercentInlineTemplate dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.RProperty Field

ColorPickerRProperty Field

Identifies the R dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RProperty
Public Shared ReadOnly RProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the R dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.SaturationProperty Field

ColorPickerSaturationProperty Field

Identifies the Saturation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SaturationProperty
Public Shared ReadOnly SaturationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Saturation dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.TextInputModeProperty Field

ColorPickerTextInputModeProperty Field

Identifies the TextInputMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextInputModeProperty
Public Shared ReadOnly TextInputModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextInputMode dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPicker.ValueProperty Field

ColorPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ColorPickerTextInputMode Enumeration

Specifies the mode to use for text input within a ColorPicker.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ColorPickerTextInputMode
Public Enumeration ColorPickerTextInputMode
Members
Member name | Value | Description
Rgb | 0 | Red, green, and blue.
Hsb | 1 | Hue, saturation, and brightness.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox Class

Represents a CornerRadius edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable CornerRadius
ActiproSoftware.Windows.Controls.EditorsCornerRadiusEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CornerRadiusEditBox : PartEditBoxBase<Nullable<CornerRadius>>
Public Class CornerRadiusEditBox
    Inherits PartEditBoxBase(Of Nullable(Of CornerRadius))

The CornerRadiusEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | CornerRadiusEditBox | Initializes an instance of the CornerRadiusEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox Constructor

Initializes an instance of the CornerRadiusEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadiusEditBox()
Public Sub New
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox Properties

The CornerRadiusEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.DefaultValue Property

CornerRadiusEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius DefaultValue { get; set; }
Public Property DefaultValue As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.Format Property

CornerRadiusEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.IsNaNAllowed Property

CornerRadiusEditBoxIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.IsNegativeInfinityAllowed Property

CornerRadiusEditBoxIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.IsPositiveInfinityAllowed Property

CornerRadiusEditBoxIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.LargeChange Property

CornerRadiusEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius LargeChange { get; set; }
Public Property LargeChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The large change value. The default value is 5.0.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.Maximum Property

CornerRadiusEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius Maximum { get; set; }
Public Property Maximum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The highest possible value.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.Minimum Property

CornerRadiusEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius Minimum { get; set; }
Public Property Minimum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The lowest possible value.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.ResolvedFormat Property

CornerRadiusEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.RoundingDecimalPlace Property

CornerRadiusEditBoxRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.SmallChange Property

CornerRadiusEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius SmallChange { get; set; }
Public Property SmallChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The small change value. The default value is 1.0.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox Methods

The CornerRadiusEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.CoerceValidValue Method

CornerRadiusEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<CornerRadius> CoerceValidValue(
    Nullable<CornerRadius> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of CornerRadius)
) As Nullable(Of CornerRadius)

Parameters

value
Type: SystemNullable CornerRadius
The value to coerce.

Return Value

Type: Nullable CornerRadius
The coerced value.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.ConvertToString Method

CornerRadiusEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<CornerRadius> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of CornerRadius)
) As String

Parameters

valueToConvert
Type: SystemNullable CornerRadius
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.CreateIncrementalChangeRequest Method

CornerRadiusEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<CornerRadius>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of CornerRadius))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable CornerRadius
The incremental change (spin) request that was created.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.GenerateParts Method

CornerRadiusEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.IsValidValue Method

CornerRadiusEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<CornerRadius> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of CornerRadius)
) As Boolean

Parameters

value
Type: SystemNullable CornerRadius
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.ProcessTextInput Method

CornerRadiusEditBoxProcessTextInput Method

Processes typed text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.RaiseValueChangedEvent Method

CornerRadiusEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.ResetValue Method

CornerRadiusEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.TryConvertFromString Method

CornerRadiusEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<CornerRadius> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of CornerRadius)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable CornerRadius
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox Events

The CornerRadiusEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.ValueChanged Event

CornerRadiusEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox Fields

The CornerRadiusEditBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.DefaultValueProperty Field

CornerRadiusEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.FormatProperty Field

CornerRadiusEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.IsNaNAllowedProperty Field

CornerRadiusEditBoxIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.IsNegativeInfinityAllowedProperty Field

CornerRadiusEditBoxIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.IsPositiveInfinityAllowedProperty Field

CornerRadiusEditBoxIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.LargeChangeProperty Field

CornerRadiusEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.MaximumProperty Field

CornerRadiusEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.MinimumProperty Field

CornerRadiusEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.ResolvedFormatProperty Field

CornerRadiusEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.RoundingDecimalPlaceProperty Field

CornerRadiusEditBoxRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusEditBox.SmallChangeProperty Field

CornerRadiusEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker Class

Represents a CornerRadius picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsCornerRadiusPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CornerRadiusPicker : PickerBase
Public Class CornerRadiusPicker
    Inherits PickerBase

The CornerRadiusPicker type exposes the following members.

Constructors
 | Name | Description
Public method | CornerRadiusPicker | Initializes an instance of the CornerRadiusPicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker Constructor

Initializes an instance of the CornerRadiusPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadiusPicker()
Public Sub New
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker Properties

The CornerRadiusPicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.Maximum Property

CornerRadiusPickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius Maximum { get; set; }
Public Property Maximum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The highest possible value.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.Minimum Property

CornerRadiusPickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius Minimum { get; set; }
Public Property Minimum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The lowest possible value.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.RoundingDecimalPlace Property

CornerRadiusPickerRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.SmallChange Property

CornerRadiusPickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius SmallChange { get; set; }
Public Property SmallChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The small change value. The default value is 1.0.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.Value Property

CornerRadiusPickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius Value { get; set; }
Public Property Value As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The value of the control.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker Methods

The CornerRadiusPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.OnApplyTemplate Method

CornerRadiusPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker Events

The CornerRadiusPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.ValueChanged Event

CornerRadiusPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker Fields

The CornerRadiusPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.MaximumProperty Field

CornerRadiusPickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.MinimumProperty Field

CornerRadiusPickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.RoundingDecimalPlaceProperty Field

CornerRadiusPickerRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.SmallChangeProperty Field

CornerRadiusPickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


CornerRadiusPicker.ValueProperty Field

CornerRadiusPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Country Class

Specifies the various countries and associated data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.EditorsCountry

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Country
Public Class Country

The Country type exposes the following members.

Constructors
 | Name | Description
Public method | Country(String, String) | Initializes an instance of the Country class.
Public method | Country(String, String, String) | Initializes an instance of the Country class.
Top
Properties
 | Name | Description
Public property | Alpha2Code | Gets the two-letter Country code.
Public property | Alpha3Code | Gets the three-letter Country code.
Public property | Code | Gets the two-letter Country code.
 | Countries | Gets the global collection of Country objects used by CountryComboBox.
Public property | Name | Gets or sets the name of the Country.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Country Constructor

Overload List
 | Name | Description
Public method | Country(String, String) | Initializes an instance of the Country class.
Public method | Country(String, String, String) | Initializes an instance of the Country class.
Top
See Also

Reference

Country Class
ActiproSoftware.Windows.Controls.Editors Namespace


Country Constructor (String, String)

Initializes an instance of the Country class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Country(
    string name,
    string alpha2Code
)
Public Sub New (
    name As String,
    alpha2Code As String
)

Parameters

name
Type: SystemString
The name of the Country.
alpha2Code
Type: SystemString
The two letter Country code.
See Also

Reference

Country Class
Country Overload
ActiproSoftware.Windows.Controls.Editors Namespace


Country Constructor (String, String, String)

Initializes an instance of the Country class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Country(
    string name,
    string alpha2Code,
    string alpha3Code
)
Public Sub New (
    name As String,
    alpha2Code As String,
    alpha3Code As String
)

Parameters

name
Type: SystemString
The name of the Country.
alpha2Code
Type: SystemString
The two-letter Country code.
alpha3Code
Type: SystemString
The three-letter Country code.
See Also

Reference

Country Class
Country Overload
ActiproSoftware.Windows.Controls.Editors Namespace


Country Properties

The Country type exposes the following members.

Properties
 | Name | Description
Public property | Alpha2Code | Gets the two-letter Country code.
Public property | Alpha3Code | Gets the three-letter Country code.
Public property | Code | Gets the two-letter Country code.
 | Countries | Gets the global collection of Country objects used by CountryComboBox.
Public property | Name | Gets or sets the name of the Country.
Top
See Also

Reference

Country Class
ActiproSoftware.Windows.Controls.Editors Namespace


Country.Alpha2Code Property

CountryAlpha2Code Property

Gets the two-letter Country code.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Alpha2Code { get; }
Public ReadOnly Property Alpha2Code As String
    Get

Property Value

Type: String
The two-letter Country code.
See Also

Reference

Country Class
ActiproSoftware.Windows.Controls.Editors Namespace


Country.Alpha3Code Property

CountryAlpha3Code Property

Gets the three-letter Country code.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Alpha3Code { get; }
Public ReadOnly Property Alpha3Code As String
    Get

Property Value

Type: String
The three-letter Country code.
See Also

Reference

Country Class
ActiproSoftware.Windows.Controls.Editors Namespace


Country.Code Property

CountryCode Property

Gets the two-letter Country code.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Code { get; }
Public ReadOnly Property Code As String
    Get

Property Value

Type: String
The two-letter Country code.
See Also

Reference

Country Class
ActiproSoftware.Windows.Controls.Editors Namespace


Country.Countries Property

CountryCountries Property

Gets the global collection of Country objects used by CountryComboBox.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DeferrableObservableCollection<Country> Countries { get; }
Public Shared ReadOnly Property Countries As DeferrableObservableCollection(Of Country)
    Get

Property Value

Type: DeferrableObservableCollection Country
A collection of Country objects.
See Also

Reference

Country Class
ActiproSoftware.Windows.Controls.Editors Namespace


Country.Name Property

CountryName Property

Gets or sets the name of the Country.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the Country.
See Also

Reference

Country Class
ActiproSoftware.Windows.Controls.Editors Namespace


CountryComboBox Class

A drop-down list for country selection, populated with Country objects.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsComboBox
ActiproSoftware.Windows.Controls.EditorsCountryComboBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CountryComboBox : ComboBox
Public Class CountryComboBox
    Inherits ComboBox

The CountryComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | CountryComboBox | Initializes an instance of the CountryComboBox class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate is called. (Inherited from ComboBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


CountryComboBox Constructor

Initializes an instance of the CountryComboBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CountryComboBox()
Public Sub New
See Also

Reference

CountryComboBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CountryComboBox Properties

The CountryComboBox type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

CountryComboBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CountryComboBox Methods

The CountryComboBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate is called. (Inherited from ComboBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CountryComboBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CountryComboBox Events

The CountryComboBox type exposes the following members.

Events
 | Name | Description
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
See Also

Reference

CountryComboBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CountryCurrencyMapping Class

A mapping between a Country and a Currency.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.EditorsCountryCurrencyMapping

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CountryCurrencyMapping
Public Class CountryCurrencyMapping

The CountryCurrencyMapping type exposes the following members.

Constructors
 | Name | Description
Public method | CountryCurrencyMapping | Initializes an instance of the CountryCurrencyMapping class.
Top
Properties
 | Name | Description
Public property | CountryCode | Gets the 2 letter country code for this mapping.
Public property | CurrencyCode | Gets the 3 letter currency code for this mapping.
 | Mappings | Gets the global collection of CountryCurrencyMapping objects.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


CountryCurrencyMapping Constructor

Initializes an instance of the CountryCurrencyMapping class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CountryCurrencyMapping(
    string countryCode,
    string currencyCode
)
Public Sub New (
    countryCode As String,
    currencyCode As String
)

Parameters

countryCode
Type: SystemString
The 2 letter Country code.
currencyCode
Type: SystemString
The 3 letter Currency code.
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.Windows.Controls.Editors Namespace


CountryCurrencyMapping Properties

The CountryCurrencyMapping type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the 2 letter country code for this mapping.
Public property | CurrencyCode | Gets the 3 letter currency code for this mapping.
 | Mappings | Gets the global collection of CountryCurrencyMapping objects.
Top
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.Windows.Controls.Editors Namespace


CountryCurrencyMapping.CountryCode Property

CountryCurrencyMappingCountryCode Property

Gets the 2 letter country code for this mapping.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string CountryCode { get; }
Public ReadOnly Property CountryCode As String
    Get

Property Value

Type: String
The 2 letter country code for this mapping.
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.Windows.Controls.Editors Namespace


CountryCurrencyMapping.CurrencyCode Property

CountryCurrencyMappingCurrencyCode Property

Gets the 3 letter currency code for this mapping.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string CurrencyCode { get; }
Public ReadOnly Property CurrencyCode As String
    Get

Property Value

Type: String
The 3 letter currency code for this mapping.
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.Windows.Controls.Editors Namespace


CountryCurrencyMapping.Mappings Property

CountryCurrencyMappingMappings Property

Gets the global collection of CountryCurrencyMapping objects.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DeferrableObservableCollection<CountryCurrencyMapping> Mappings { get; }
Public Shared ReadOnly Property Mappings As DeferrableObservableCollection(Of CountryCurrencyMapping)
    Get

Property Value

Type: DeferrableObservableCollection CountryCurrencyMapping
A collection of CountryCurrencyMapping objects.
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.Windows.Controls.Editors Namespace


Currency Class

Specifies a country's currency.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.EditorsCurrency

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Currency
Public Class Currency

The Currency type exposes the following members.

Constructors
 | Name | Description
Public method | Currency | Initializes an instance of the Currency class.
Top
Properties
 | Name | Description
Public property | Code | Gets the 3 letter Currency code.
 | Currencies | Gets the global collection of Currency objects used by CurrencyComboBox.
Public property | Description | Gets the description of the currency, which is a concatenation of the other properties.
Public property | Name | Gets or sets the name of the Currency (i.e. Dollar).
Public property | Symbol | Gets or sets the Currency symbol.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Currency Constructor

Initializes an instance of the Currency class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Currency(
    string code,
    string name,
    string symbol
)
Public Sub New (
    code As String,
    name As String,
    symbol As String
)

Parameters

code
Type: SystemString
The 3 letter Currency code.
name
Type: SystemString
The plural name of the Currency (i.e. Dollars).
symbol
Type: SystemString
The Currency symbol.
See Also

Reference

Currency Class
ActiproSoftware.Windows.Controls.Editors Namespace


Currency Properties

The Currency type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets the 3 letter Currency code.
 | Currencies | Gets the global collection of Currency objects used by CurrencyComboBox.
Public property | Description | Gets the description of the currency, which is a concatenation of the other properties.
Public property | Name | Gets or sets the name of the Currency (i.e. Dollar).
Public property | Symbol | Gets or sets the Currency symbol.
Top
See Also

Reference

Currency Class
ActiproSoftware.Windows.Controls.Editors Namespace


Currency.Code Property

CurrencyCode Property

Gets the 3 letter Currency code.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Code { get; }
Public ReadOnly Property Code As String
    Get

Property Value

Type: String
The 3 letter Currency code.
See Also

Reference

Currency Class
ActiproSoftware.Windows.Controls.Editors Namespace


Currency.Currencies Property

CurrencyCurrencies Property

Gets the global collection of Currency objects used by CurrencyComboBox.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static DeferrableObservableCollection<Currency> Currencies { get; }
Public Shared ReadOnly Property Currencies As DeferrableObservableCollection(Of Currency)
    Get

Property Value

Type: DeferrableObservableCollection Currency
A collection of Currency objects.
See Also

Reference

Currency Class
ActiproSoftware.Windows.Controls.Editors Namespace


Currency.Description Property

CurrencyDescription Property

Gets the description of the currency, which is a concatenation of the other properties.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the currency, which is a concatenation of the other properties.
See Also

Reference

Currency Class
ActiproSoftware.Windows.Controls.Editors Namespace


Currency.Name Property

CurrencyName Property

Gets or sets the name of the Currency (i.e. Dollar).

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the Currency (i.e. Dollar).
See Also

Reference

Currency Class
ActiproSoftware.Windows.Controls.Editors Namespace


Currency.Symbol Property

CurrencySymbol Property

Gets or sets the Currency symbol.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Symbol { get; set; }
Public Property Symbol As String
    Get
    Set

Property Value

Type: String
The Currency symbol.
See Also

Reference

Currency Class
ActiproSoftware.Windows.Controls.Editors Namespace


CurrencyComboBox Class

A drop-down list for currency selection, populated with Currency objects.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsComboBox
ActiproSoftware.Windows.Controls.EditorsCurrencyComboBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CurrencyComboBox : ComboBox
Public Class CurrencyComboBox
    Inherits ComboBox

The CurrencyComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | CurrencyComboBox | Initializes an instance of the CurrencyComboBox class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate is called. (Inherited from ComboBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


CurrencyComboBox Constructor

Initializes an instance of the CurrencyComboBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CurrencyComboBox()
Public Sub New
See Also

Reference

CurrencyComboBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CurrencyComboBox Properties

The CurrencyComboBox type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

CurrencyComboBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CurrencyComboBox Methods

The CurrencyComboBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate is called. (Inherited from ComboBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CurrencyComboBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


CurrencyComboBox Events

The CurrencyComboBox type exposes the following members.

Events
 | Name | Description
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
See Also

Reference

CurrencyComboBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox Class

Represents a date-only edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable DateTime
ActiproSoftware.Windows.Controls.EditorsDateTimeEditBox
ActiproSoftware.Windows.Controls.EditorsDateEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DateEditBox : DateTimeEditBox
Public Class DateEditBox
    Inherits DateTimeEditBox

The DateEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | DateEditBox | Initializes an instance of the DateEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimeEditBox.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from DateTimeEditBox.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimeEditBox.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimeEditBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string. (Inherited from DateTimeEditBox.)
Public property | SetValueToNowCommand | Gets the ICommand that sets the value to the current date/time. (Inherited from DateTimeEditBox.)
Public property | SetValueToTodayCommand | Gets the ICommand that sets the value to the current date. (Inherited from DateTimeEditBox.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceParsedValue | Coerces the parsed value from text, which is used for time-only edit boxes to ensure their date doesn't change. (Inherited from DateTimeEditBox.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from DateTimeEditBox.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Inherited from DateTimeEditBox.)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Inherited from DateTimeEditBox.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Inherited from DateTimeEditBox.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Inherited from DateTimeEditBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Inherited from DateTimeEditBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides DateTimeEditBoxResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides DateTimeEditBoxTryConvertFromString(String, Boolean, NullableDateTime).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from DateTimeEditBox.)
Top
Fields
Name | Description
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox Constructor

Initializes an instance of the DateEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateEditBox()
Public Sub New
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox Properties

The DateEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimeEditBox.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from DateTimeEditBox.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimeEditBox.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimeEditBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string. (Inherited from DateTimeEditBox.)
Public property | SetValueToNowCommand | Gets the ICommand that sets the value to the current date/time. (Inherited from DateTimeEditBox.)
Public property | SetValueToTodayCommand | Gets the ICommand that sets the value to the current date. (Inherited from DateTimeEditBox.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox.CanRetainTime Property

DateEditBoxCanRetainTime Property

Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanRetainTime { get; set; }
Public Property CanRetainTime As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the various DateTime values can retain the time-portion; otherwise, false. The default value is false.
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox Methods

The DateEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceParsedValue | Coerces the parsed value from text, which is used for time-only edit boxes to ensure their date doesn't change. (Inherited from DateTimeEditBox.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from DateTimeEditBox.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Inherited from DateTimeEditBox.)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Inherited from DateTimeEditBox.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Inherited from DateTimeEditBox.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Inherited from DateTimeEditBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Inherited from DateTimeEditBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides DateTimeEditBoxResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides DateTimeEditBoxTryConvertFromString(String, Boolean, NullableDateTime).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox.OnApplyTemplate Method

DateEditBoxOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox.ResetValue Method

DateEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox.TryConvertFromString Method

DateEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<DateTime> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of DateTime)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable DateTime
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox Events

The DateEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from DateTimeEditBox.)
Top
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox Fields

The DateEditBox type exposes the following members.

Fields
Name | Description
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
Top
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateEditBox.CanRetainTimeProperty Field

DateEditBoxCanRetainTimeProperty Field

Identifies the CanRetainTime dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRetainTimeProperty
Public Shared ReadOnly CanRetainTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRetainTime dependency property.
See Also

Reference

DateEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker Class

Represents a date picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsDatePicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DatePicker : PickerBase
Public Class DatePicker
    Inherits PickerBase

The DatePicker type exposes the following members.

Constructors
 | Name | Description
Public method | DatePicker | Initializes an instance of the DatePicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Public event | ValueCommitted | Occurs after the Value is committed, either by pressing Enter or clicking on a date value.
Top
Fields
Name | Description
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker Constructor

Initializes an instance of the DatePicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DatePicker()
Public Sub New
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker Properties

The DatePicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.CanRetainTime Property

DatePickerCanRetainTime Property

Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanRetainTime { get; set; }
Public Property CanRetainTime As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the various DateTime values can retain the time-portion; otherwise, false. The default value is false.
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.Maximum Property

DatePickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.Minimum Property

DatePickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.Value Property

DatePickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Value { get; set; }
Public Property Value As DateTime
    Get
    Set

Property Value

Type: DateTime
The value of the control.
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker Methods

The DatePicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.OnApplyTemplate Method

DatePickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker Events

The DatePicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Public event | ValueCommitted | Occurs after the Value is committed, either by pressing Enter or clicking on a date value.
Top
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.ValueChanged Event

DatePickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.ValueCommitted Event

DatePickerValueCommitted Event

Occurs after the Value is committed, either by pressing Enter or clicking on a date value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueCommitted
Public Event ValueCommitted As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker Fields

The DatePicker type exposes the following members.

Fields
Name | Description
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.CanRetainTimeProperty Field

DatePickerCanRetainTimeProperty Field

Identifies the CanRetainTime dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRetainTimeProperty
Public Shared ReadOnly CanRetainTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRetainTime dependency property.
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.MaximumProperty Field

DatePickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.MinimumProperty Field

DatePickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DatePicker.ValueProperty Field

DatePickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

DatePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox Class

Represents a date/time edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable DateTime
ActiproSoftware.Windows.Controls.EditorsDateTimeEditBox
ActiproSoftware.Windows.Controls.EditorsDateEditBox
ActiproSoftware.Windows.Controls.EditorsTimeEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DateTimeEditBox : PartEditBoxBase<Nullable<DateTime>>
Public Class DateTimeEditBox
    Inherits PartEditBoxBase(Of Nullable(Of DateTime))

The DateTimeEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeEditBox | Initializes an instance of the DateTimeEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string.
Public property | SetValueToNowCommand | Gets the ICommand that sets the value to the current date/time.
Public property | SetValueToTodayCommand | Gets the ICommand that sets the value to the current date.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceParsedValue | Coerces the parsed value from text, which is used for time-only edit boxes to ensure their date doesn't change.
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox Constructor

Initializes an instance of the DateTimeEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTimeEditBox()
Public Sub New
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox Properties

The DateTimeEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string.
Public property | SetValueToNowCommand | Gets the ICommand that sets the value to the current date/time.
Public property | SetValueToTodayCommand | Gets the ICommand that sets the value to the current date.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.Format Property

DateTimeEditBoxFormat Property

Gets or sets the date/time format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The date/time format string. The default value is "g".
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.HasPopupButtonWhenReadOnly Property

DateTimeEditBoxHasPopupButtonWhenReadOnly Property

Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.Maximum Property

DateTimeEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.Minimum Property

DateTimeEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.ResolvedFormat Property

DateTimeEditBoxResolvedFormat Property

Gets the resolved date/time format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved date/time format string.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.SetValueToNowCommand Property

DateTimeEditBoxSetValueToNowCommand Property

Gets the ICommand that sets the value to the current date/time.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SetValueToNowCommand { get; }
Public ReadOnly Property SetValueToNowCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that sets the value to the current date/time.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.SetValueToTodayCommand Property

DateTimeEditBoxSetValueToTodayCommand Property

Gets the ICommand that sets the value to the current date.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SetValueToTodayCommand { get; }
Public ReadOnly Property SetValueToTodayCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that sets the value to the current date.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox Methods

The DateTimeEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceParsedValue | Coerces the parsed value from text, which is used for time-only edit boxes to ensure their date doesn't change.
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.CoerceParsedValue Method

DateTimeEditBoxCoerceParsedValue Method

Coerces the parsed value from text, which is used for time-only edit boxes to ensure their date doesn't change.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Nullable<DateTime> CoerceParsedValue(
    Nullable<DateTime> value
)
Protected Overridable Function CoerceParsedValue (
    value As Nullable(Of DateTime)
) As Nullable(Of DateTime)

Parameters

value
Type: SystemNullable DateTime
The value to coerce.

Return Value

Type: Nullable DateTime
The coerced value.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.CoerceValidValue Method

DateTimeEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<DateTime> CoerceValidValue(
    Nullable<DateTime> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of DateTime)
) As Nullable(Of DateTime)

Parameters

value
Type: SystemNullable DateTime
The value to coerce.

Return Value

Type: Nullable DateTime
The coerced value.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.ConvertToString Method

DateTimeEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<DateTime> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of DateTime)
) As String

Parameters

valueToConvert
Type: SystemNullable DateTime
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.CreateIncrementalChangeRequest Method

DateTimeEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<DateTime>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of DateTime))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable DateTime
The incremental change (spin) request that was created.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.GenerateParts Method

DateTimeEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.IsValidValue Method

DateTimeEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<DateTime> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of DateTime)
) As Boolean

Parameters

value
Type: SystemNullable DateTime
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.RaiseValueChangedEvent Method

DateTimeEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.ResetValue Method

DateTimeEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.TryConvertFromString Method

DateTimeEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<DateTime> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of DateTime)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable DateTime
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox Events

The DateTimeEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.ValueChanged Event

DateTimeEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox Fields

The DateTimeEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
Top
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.FormatProperty Field

DateTimeEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.MaximumProperty Field

DateTimeEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.MinimumProperty Field

DateTimeEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimeEditBox.ResolvedFormatProperty Field

DateTimeEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker Class

Represents a date/time picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsDateTimePicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DateTimePicker : PickerBase
Public Class DateTimePicker
    Inherits PickerBase

The DateTimePicker type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimePicker | Initializes an instance of the DateTimePicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker Constructor

Initializes an instance of the DateTimePicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTimePicker()
Public Sub New
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker Properties

The DateTimePicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker.Maximum Property

DateTimePickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker.Minimum Property

DateTimePickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker.Value Property

DateTimePickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Value { get; set; }
Public Property Value As DateTime
    Get
    Set

Property Value

Type: DateTime
The value of the control.
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker Methods

The DateTimePicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker.OnApplyTemplate Method

DateTimePickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker Events

The DateTimePicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker.ValueChanged Event

DateTimePickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker Fields

The DateTimePicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker.MaximumProperty Field

DateTimePickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker.MinimumProperty Field

DateTimePickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DateTimePicker.ValueProperty Field

DateTimePickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

DateTimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DaysOfWeek Enumeration

Specifies the various days of the week as enumeration flags.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DaysOfWeek
Public Enumeration DaysOfWeek
Members
Member name | Value | Description
None | 0 | Indicates none of the days of the week.
Sunday | 1 | Indicates Sunday.
Monday | 2 | Indicates Monday.
Tuesday | 4 | Indicates Tuesday.
Wednesday | 8 | Indicates Wednesday.
Thursday | 16 | Indicates Thursday.
Friday | 32 | Indicates Friday.
Saturday | 64 | Indicates Saturday.
Weekdays | 62 | Indicates the weekdays, Monday through Friday.
Weekend | 65 | Indicates the weekend days, Sunday and Saturday.
All | 127 | Indicates all of the days of the week.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox Class

Represents a Double edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Double
ActiproSoftware.Windows.Controls.EditorsDoubleEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoubleEditBox : PartEditBoxBase<Nullable<double>>
Public Class DoubleEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Double))

The DoubleEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleEditBox | Initializes an instance of the DoubleEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox Constructor

Initializes an instance of the DoubleEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleEditBox()
Public Sub New
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox Properties

The DoubleEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.CalculatorPopupPickerStyle Property

DoubleEditBoxCalculatorPopupPickerStyle Property

Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.DefaultValue Property

DoubleEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DefaultValue { get; set; }
Public Property DefaultValue As Double
    Get
    Set

Property Value

Type: Double
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.Format Property

DoubleEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.IsNaNAllowed Property

DoubleEditBoxIsNaNAllowed Property

Gets or sets whether NaN is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.IsNegativeInfinityAllowed Property

DoubleEditBoxIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.IsPositiveInfinityAllowed Property

DoubleEditBoxIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.LargeChange Property

DoubleEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LargeChange { get; set; }
Public Property LargeChange As Double
    Get
    Set

Property Value

Type: Double
The large change value. The default value is 5.0.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.Maximum Property

DoubleEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible value.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.Minimum Property

DoubleEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible value.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.PickerKind Property

DoubleEditBoxPickerKind Property

Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As DoubleEditBoxPickerKind
    Get
    Set

Property Value

Type: DoubleEditBoxPickerKind
A DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.ResolvedFormat Property

DoubleEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.RoundingDecimalPlace Property

DoubleEditBoxRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.SmallChange Property

DoubleEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SmallChange { get; set; }
Public Property SmallChange As Double
    Get
    Set

Property Value

Type: Double
The small change value. The default value is 1.0.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox Methods

The DoubleEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.CoerceValidValue Method

DoubleEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<double> CoerceValidValue(
    Nullable<double> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Double)
) As Nullable(Of Double)

Parameters

value
Type: SystemNullable Double
The value to coerce.

Return Value

Type: Nullable Double
The coerced value.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.ConvertToString Method

DoubleEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<double> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Double)
) As String

Parameters

valueToConvert
Type: SystemNullable Double
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.CreateIncrementalChangeRequest Method

DoubleEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<double>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Double))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Double
The incremental change (spin) request that was created.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.GenerateParts Method

DoubleEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.IsValidValue Method

DoubleEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<double> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Double)
) As Boolean

Parameters

value
Type: SystemNullable Double
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.ProcessTextInput Method

DoubleEditBoxProcessTextInput Method

Processes typed text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.RaiseValueChangedEvent Method

DoubleEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.ResetValue Method

DoubleEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.TryConvertFromString Method

DoubleEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<double> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Double)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Double
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox Events

The DoubleEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.ValueChanged Event

DoubleEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox Fields

The DoubleEditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.CalculatorPopupPickerStyleProperty Field

DoubleEditBoxCalculatorPopupPickerStyleProperty Field

Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.DefaultValueProperty Field

DoubleEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.FormatProperty Field

DoubleEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.IsNaNAllowedProperty Field

DoubleEditBoxIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.IsNegativeInfinityAllowedProperty Field

DoubleEditBoxIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.IsPositiveInfinityAllowedProperty Field

DoubleEditBoxIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.LargeChangeProperty Field

DoubleEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.MaximumProperty Field

DoubleEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.MinimumProperty Field

DoubleEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.PickerKindProperty Field

DoubleEditBoxPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.ResolvedFormatProperty Field

DoubleEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.RoundingDecimalPlaceProperty Field

DoubleEditBoxRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBox.SmallChangeProperty Field

DoubleEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoubleEditBoxPickerKind Enumeration

Specifies the kind of Style to apply to the DoublePicker used within a DoubleEditBox's popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DoubleEditBoxPickerKind
Public Enumeration DoubleEditBoxPickerKind
Members
Member name | Value | Description
Default | 0 | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default DoublePicker style, which is templated to contain a radial slider control.
Calculator | 1 | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker Class

Represents a Double picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.Windows.Controls.EditorsDoublePicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoublePicker : RadialSliderPickerBase
Public Class DoublePicker
    Inherits RadialSliderPickerBase

The DoublePicker type exposes the following members.

Constructors
 | Name | Description
Public method | DoublePicker | Initializes an instance of the DoublePicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker Constructor

Initializes an instance of the DoublePicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoublePicker()
Public Sub New
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker Properties

The DoublePicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.Maximum Property

DoublePickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible value.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.Minimum Property

DoublePickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible value.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.RoundingDecimalPlace Property

DoublePickerRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.SmallChange Property

DoublePickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SmallChange { get; set; }
Public Property SmallChange As Double
    Get
    Set

Property Value

Type: Double
The small change value. The default value is 1.0.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.Value Property

DoublePickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value of the control.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker Methods

The DoublePicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.OnApplyTemplate Method

DoublePickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker Events

The DoublePicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.ValueChanged Event

DoublePickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker Fields

The DoublePicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.MaximumProperty Field

DoublePickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.MinimumProperty Field

DoublePickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.RoundingDecimalPlaceProperty Field

DoublePickerRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.SmallChangeProperty Field

DoublePickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


DoublePicker.ValueProperty Field

DoublePickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

DoublePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox Class

Represents an Enum edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Object
ActiproSoftware.Windows.Controls.EditorsEnumEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumEditBox : PartEditBoxBase<Object>
Public Class EnumEditBox
    Inherits PartEditBoxBase(Of Object)

The EnumEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | EnumEditBox | Initializes an instance of the EnumEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from PartEditBoxBaseT.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox Constructor

Initializes an instance of the EnumEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumEditBox()
Public Sub New
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox Properties

The EnumEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.EnumSortComparer Property

EnumEditBoxEnumSortComparer Property

Gets or sets the IComparerT used to sort the enumeration values.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IComparer<Enum> EnumSortComparer { get; set; }
Public Property EnumSortComparer As IComparer(Of Enum)
    Get
    Set

Property Value

Type: IComparer Enum
The IComparerT used to sort the enumeration values; otherwise to indicate no sorting, which will use the order the enumeration values are defined.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.EnumType Property

EnumEditBoxEnumType Property

Gets or sets the enumeration type.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type EnumType { get; set; }
Public Property EnumType As Type
    Get
    Set

Property Value

Type: Type
The enumeration type.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.HasPopupButtonWhenReadOnly Property

EnumEditBoxHasPopupButtonWhenReadOnly Property

Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.UseDisplayAttributes Property

EnumEditBoxUseDisplayAttributes Property

Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseDisplayAttributes { get; set; }
Public Property UseDisplayAttributes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if enumeration values should be displayed using an associated DisplayAttribute, if any; otherwise false. The default value is false.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox Methods

The EnumEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from PartEditBoxBaseT.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.ConvertToString Method

EnumEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Object valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Object
) As String

Parameters

valueToConvert
Type: SystemObject
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.CreateIncrementalChangeRequest Method

EnumEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Object> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Object)

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Object
The incremental change (spin) request that was created.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.GenerateParts Method

EnumEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.IsValidValue Method

EnumEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Object value
)
Protected Overrides Function IsValidValue (
    value As Object
) As Boolean

Parameters

value
Type: SystemObject
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.RaiseValueChangedEvent Method

EnumEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.ResetValue Method

EnumEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.TryConvertFromString Method

EnumEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Object value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Object
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemObject
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox Events

The EnumEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.ValueChanged Event

EnumEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox Fields

The EnumEditBox type exposes the following members.

Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.EnumSortComparerProperty Field

EnumEditBoxEnumSortComparerProperty Field

Identifies the EnumSortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumSortComparerProperty
Public Shared ReadOnly EnumSortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumSortComparer dependency property.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.EnumTypeProperty Field

EnumEditBoxEnumTypeProperty Field

Identifies the EnumType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumTypeProperty
Public Shared ReadOnly EnumTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumType dependency property.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumEditBox.UseDisplayAttributesProperty Field

EnumEditBoxUseDisplayAttributesProperty Field

Identifies the UseDisplayAttributes dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDisplayAttributesProperty
Public Shared ReadOnly UseDisplayAttributesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDisplayAttributes dependency property.
See Also

Reference

EnumEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox Class

Represents a list box that automatically presents the values of an enumeration.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsListBox
ActiproSoftware.Windows.Controls.EditorsEnumListBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumListBox : ListBox
Public Class EnumListBox
    Inherits ListBox

The EnumListBox type exposes the following members.

Constructors
 | Name | Description
Public method | EnumListBox | Initializes a new instance of the EnumListBox class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | EnumValue | Gets or sets the current enumeration value.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsFlagsEnum | Gets a value indicating whether the EnumType has the FlagsAttribute.
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsOnPopup | Gets or sets whether the control is being used on a popup, which affects how value changes are handled.
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBoxGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ListBoxIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ListBoxOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ListBoxPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
EnumValueProperty | Identifies the EnumValue dependency property. This field is read-only.
IsFlagsEnumProperty | Identifies the IsFlagsEnum dependency property. This field is read-only.
IsOnPopupProperty | Identifies the IsOnPopup dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox Constructor

Initializes a new instance of the EnumListBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumListBox()
Public Sub New
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox Properties

The EnumListBox type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | EnumValue | Gets or sets the current enumeration value.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsFlagsEnum | Gets a value indicating whether the EnumType has the FlagsAttribute.
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsOnPopup | Gets or sets whether the control is being used on a popup, which affects how value changes are handled.
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.EnumSortComparer Property

EnumListBoxEnumSortComparer Property

Gets or sets the IComparerT used to sort the enumeration values.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IComparer<Enum> EnumSortComparer { get; set; }
Public Property EnumSortComparer As IComparer(Of Enum)
    Get
    Set

Property Value

Type: IComparer Enum
The IComparerT used to sort the enumeration values; otherwise to indicate no sorting, which will use the order the enumeration values are defined.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.EnumType Property

EnumListBoxEnumType Property

Gets or sets the enumeration type.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type EnumType { get; set; }
Public Property EnumType As Type
    Get
    Set

Property Value

Type: Type
The enumeration type.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.EnumValue Property

EnumListBoxEnumValue Property

Gets or sets the current enumeration value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object EnumValue { get; set; }
Public Property EnumValue As Object
    Get
    Set

Property Value

Type: Object
The current enumeration value.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.IsFlagsEnum Property

EnumListBoxIsFlagsEnum Property

Gets a value indicating whether the EnumType has the FlagsAttribute.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsFlagsEnum { get; }
Public ReadOnly Property IsFlagsEnum As Boolean
    Get

Property Value

Type: Boolean
true if the EnumType has the FlagsAttribute; otherwise false.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.IsOnPopup Property

EnumListBoxIsOnPopup Property

Gets or sets whether the control is being used on a popup, which affects how value changes are handled.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOnPopup { get; set; }
Public Property IsOnPopup As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control is being used on a popup; otherwise, false.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.UseDisplayAttributes Property

EnumListBoxUseDisplayAttributes Property

Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseDisplayAttributes { get; set; }
Public Property UseDisplayAttributes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if enumeration values should be displayed using an associated DisplayAttribute, if any; otherwise false. The default value is false.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox Methods

The EnumListBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBoxGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ListBoxIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ListBoxOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ListBoxPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.GetContainerForItemOverride Method

EnumListBoxGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.IsItemItsOwnContainerOverride Method

EnumListBoxIsItemItsOwnContainerOverride Method

Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.OnGotKeyboardFocus Method

EnumListBoxOnGotKeyboardFocus Method

Occurs when a control within this control's hierarchy gains keyboard focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
Protected Overrides Sub OnGotKeyboardFocus (
    e As KeyboardFocusChangedEventArgs
)

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
The KeyboardFocusChangedEventArgs that contains data related to this event.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.OnKeyDown Method

EnumListBoxOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.PrepareContainerForItemOverride Method

EnumListBoxPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox Events

The EnumListBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox Fields

The EnumListBox type exposes the following members.

Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
EnumValueProperty | Identifies the EnumValue dependency property. This field is read-only.
IsFlagsEnumProperty | Identifies the IsFlagsEnum dependency property. This field is read-only.
IsOnPopupProperty | Identifies the IsOnPopup dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.EnumSortComparerProperty Field

EnumListBoxEnumSortComparerProperty Field

Identifies the EnumSortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumSortComparerProperty
Public Shared ReadOnly EnumSortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumSortComparer dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.EnumTypeProperty Field

EnumListBoxEnumTypeProperty Field

Identifies the EnumType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumTypeProperty
Public Shared ReadOnly EnumTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumType dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.EnumValueProperty Field

EnumListBoxEnumValueProperty Field

Identifies the EnumValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumValueProperty
Public Shared ReadOnly EnumValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumValue dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.IsFlagsEnumProperty Field

EnumListBoxIsFlagsEnumProperty Field

Identifies the IsFlagsEnum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFlagsEnumProperty
Public Shared ReadOnly IsFlagsEnumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFlagsEnum dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.IsOnPopupProperty Field

EnumListBoxIsOnPopupProperty Field

Identifies the IsOnPopup dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOnPopupProperty
Public Shared ReadOnly IsOnPopupProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOnPopup dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBox.UseDisplayAttributesProperty Field

EnumListBoxUseDisplayAttributesProperty Field

Identifies the UseDisplayAttributes dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDisplayAttributesProperty
Public Shared ReadOnly UseDisplayAttributesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDisplayAttributes dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem Class

Represents a selectable item in a EnumListBox.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsListBoxItem
ActiproSoftware.Windows.Controls.EditorsEnumListBoxItem

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumListBoxItem : ListBoxItem
Public Class EnumListBoxItem
    Inherits ListBoxItem

The EnumListBoxItem type exposes the following members.

Constructors
 | Name | Description
Public method | EnumListBoxItem | Initializes a new instance of the EnumListBoxItem class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsFlagsEnum | Gets a value indicating whether the enumeration is a flags enumeration.
Public property | IsGroupStart | Gets a value indicating whether the enumeration value starts a group.
Public property | IsPartiallySelected | Gets a value indicating whether the enumeration value represented by this item is partially selected.
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown event. (Overrides ListBoxItemOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseRightButtonDown | Called when the user presses the right mouse button over a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelected | Called when the ListBoxItem is selected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnUnselected | Called when the ListBoxItem is unselected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the visual parent of a list box item changes. (Inherited from ListBoxItem.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Selected | Occurs when a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public event | Unselected | Occurs when a ListBoxItem is unselected. (Inherited from ListBoxItem.)
Top
Fields
Name | Description
IsFlagsEnumProperty | Identifies the IsFlagsEnum dependency property. This field is read-only.
IsGroupStartProperty | Identifies the IsGroupStart dependency property. This field is read-only.
IsPartiallySelectedProperty | Identifies the IsPartiallySelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem Constructor

Initializes a new instance of the EnumListBoxItem class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumListBoxItem()
Public Sub New
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem Properties

The EnumListBoxItem type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsFlagsEnum | Gets a value indicating whether the enumeration is a flags enumeration.
Public property | IsGroupStart | Gets a value indicating whether the enumeration value starts a group.
Public property | IsPartiallySelected | Gets a value indicating whether the enumeration value represented by this item is partially selected.
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem.IsFlagsEnum Property

EnumListBoxItemIsFlagsEnum Property

Gets a value indicating whether the enumeration is a flags enumeration.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsFlagsEnum { get; }
Public ReadOnly Property IsFlagsEnum As Boolean
    Get

Property Value

Type: Boolean
true if the enumeration is a flags enumeration; otherwise false.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem.IsGroupStart Property

EnumListBoxItemIsGroupStart Property

Gets a value indicating whether the enumeration value starts a group.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGroupStart { get; }
Public ReadOnly Property IsGroupStart As Boolean
    Get

Property Value

Type: Boolean
true if the enumeration value starts a group; otherwise false.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem.IsPartiallySelected Property

EnumListBoxItemIsPartiallySelected Property

Gets a value indicating whether the enumeration value represented by this item is partially selected.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPartiallySelected { get; }
Public ReadOnly Property IsPartiallySelected As Boolean
    Get

Property Value

Type: Boolean
true if the enumeration value represented by this item is partially selected; otherwise false.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem Methods

The EnumListBoxItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown event. (Overrides ListBoxItemOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseRightButtonDown | Called when the user presses the right mouse button over a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelected | Called when the ListBoxItem is selected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnUnselected | Called when the ListBoxItem is unselected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the visual parent of a list box item changes. (Inherited from ListBoxItem.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem.OnApplyTemplate Method

EnumListBoxItemOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem.OnMouseLeftButtonDown Method

EnumListBoxItemOnMouseLeftButtonDown Method

Provides class handling for the MouseLeftButtonDown event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The event data.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem Events

The EnumListBoxItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Selected | Occurs when a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public event | Unselected | Occurs when a ListBoxItem is unselected. (Inherited from ListBoxItem.)
Top
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem Fields

The EnumListBoxItem type exposes the following members.

Fields
Name | Description
IsFlagsEnumProperty | Identifies the IsFlagsEnum dependency property. This field is read-only.
IsGroupStartProperty | Identifies the IsGroupStart dependency property. This field is read-only.
IsPartiallySelectedProperty | Identifies the IsPartiallySelected dependency property. This field is read-only.
Top
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem.IsFlagsEnumProperty Field

EnumListBoxItemIsFlagsEnumProperty Field

Identifies the IsFlagsEnum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFlagsEnumProperty
Public Shared ReadOnly IsFlagsEnumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFlagsEnum dependency property.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem.IsGroupStartProperty Field

EnumListBoxItemIsGroupStartProperty Field

Identifies the IsGroupStart dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGroupStartProperty
Public Shared ReadOnly IsGroupStartProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGroupStart dependency property.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumListBoxItem.IsPartiallySelectedProperty Field

EnumListBoxItemIsPartiallySelectedProperty Field

Identifies the IsPartiallySelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPartiallySelectedProperty
Public Shared ReadOnly IsPartiallySelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPartiallySelected dependency property.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker Class

Represents an Enum picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsEnumPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumPicker : PickerBase
Public Class EnumPicker
    Inherits PickerBase

The EnumPicker type exposes the following members.

Constructors
 | Name | Description
Public method | EnumPicker | Initializes an instance of the EnumPicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOnPopup | Gets or sets whether the control is being used on a popup, which affects how value changes are handled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
IsOnPopupProperty | Identifies the IsOnPopup dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker Constructor

Initializes an instance of the EnumPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumPicker()
Public Sub New
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker Properties

The EnumPicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsOnPopup | Gets or sets whether the control is being used on a popup, which affects how value changes are handled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.EnumSortComparer Property

EnumPickerEnumSortComparer Property

Gets or sets the IComparerT used to sort the enumeration values.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IComparer<Enum> EnumSortComparer { get; set; }
Public Property EnumSortComparer As IComparer(Of Enum)
    Get
    Set

Property Value

Type: IComparer Enum
The IComparerT used to sort the enumeration values; otherwise to indicate no sorting, which will use the order the enumeration values are defined.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.EnumType Property

EnumPickerEnumType Property

Gets or sets the enumeration type.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type EnumType { get; set; }
Public Property EnumType As Type
    Get
    Set

Property Value

Type: Type
The enumeration type.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.IsOnPopup Property

EnumPickerIsOnPopup Property

Gets or sets whether the control is being used on a popup, which affects how value changes are handled.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOnPopup { get; set; }
Public Property IsOnPopup As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control is being used on a popup; otherwise, false.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.UseDisplayAttributes Property

EnumPickerUseDisplayAttributes Property

Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseDisplayAttributes { get; set; }
Public Property UseDisplayAttributes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if enumeration values should be displayed using an associated DisplayAttribute, if any; otherwise false. The default value is false.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.Value Property

EnumPickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

Property Value

Type: Object
The value of the control.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker Methods

The EnumPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker Events

The EnumPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.ValueChanged Event

EnumPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker Fields

The EnumPicker type exposes the following members.

Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
IsOnPopupProperty | Identifies the IsOnPopup dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.EnumSortComparerProperty Field

EnumPickerEnumSortComparerProperty Field

Identifies the EnumSortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumSortComparerProperty
Public Shared ReadOnly EnumSortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumSortComparer dependency property.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.EnumTypeProperty Field

EnumPickerEnumTypeProperty Field

Identifies the EnumType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumTypeProperty
Public Shared ReadOnly EnumTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumType dependency property.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.IsOnPopupProperty Field

EnumPickerIsOnPopupProperty Field

Identifies the IsOnPopup dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOnPopupProperty
Public Shared ReadOnly IsOnPopupProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOnPopup dependency property.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.UseDisplayAttributesProperty Field

EnumPickerUseDisplayAttributesProperty Field

Identifies the UseDisplayAttributes dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDisplayAttributesProperty
Public Shared ReadOnly UseDisplayAttributesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDisplayAttributes dependency property.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


EnumPicker.ValueProperty Field

EnumPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

EnumPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider Class

A slider for manipulating gradient stops.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.EditorsGradientStopSlider

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GradientStopSlider : Control
Public Class GradientStopSlider
    Inherits Control

The GradientStopSlider type exposes the following members.

Constructors
 | Name | Description
Public method | GradientStopSlider | Initializes an instance of the GradientStopSlider class.
Top
Properties
 | Name | Description
Public property | ActiveBrush | Gets or sets the Brush to render and adjust with the slider.
Public property | AddStopCommand | Gets the ICommand that calls the AddStop method.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAddStops | Gets or sets whether stops can be added.
Public property | CanRemoveStops | Gets or sets whether stops can be removed.
Public property | CanReuseBrush | Gets or sets whether the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RemoveSelectedStopCommand | Gets the ICommand that calls the RemoveSelectedStop method.
Public property | ReverseStopsCommand | Gets the ICommand that calls the ReverseStops method.
Public property | SelectedColor | Gets or sets the currently selected Color.
Public property | SelectedStopIndex | Gets or sets the index of the selected stop.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TrackGradientBrush | Gets the resolved GradientBrush to render in the track and adjust with the slider.
Public property | TrackHeight | Gets or sets the height of the slider track.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddStop | Adds a new gradient stop.
Public method | AddStop(NullableDouble) | Adds a new gradient stop.
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Refreshes the control, such as when an external change is made to ActiveBrush that is unable to be detected.
Public method | RemoveSelectedStop | Removes the selected gradient stop.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ReverseStops | Reverses the gradient stops in the ActiveBrush.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ActiveBrushProperty | Identifies the ActiveBrush dependency property. This field is read-only.
CanAddStopsProperty | Identifies the CanAddStops dependency property. This field is read-only.
CanRemoveStopsProperty | Identifies the CanRemoveStops dependency property. This field is read-only.
CanReuseBrushProperty | Identifies the CanReuseBrush dependency property. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
SelectedStopIndexProperty | Identifies the SelectedStopIndex dependency property. This field is read-only.
TrackGradientBrushProperty | Identifies the TrackGradientBrush dependency property. This field is read-only.
TrackHeightProperty | Identifies the TrackHeight dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider Constructor

Initializes an instance of the GradientStopSlider class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientStopSlider()
Public Sub New
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider Properties

The GradientStopSlider type exposes the following members.

Properties
 | Name | Description
Public property | ActiveBrush | Gets or sets the Brush to render and adjust with the slider.
Public property | AddStopCommand | Gets the ICommand that calls the AddStop method.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAddStops | Gets or sets whether stops can be added.
Public property | CanRemoveStops | Gets or sets whether stops can be removed.
Public property | CanReuseBrush | Gets or sets whether the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RemoveSelectedStopCommand | Gets the ICommand that calls the RemoveSelectedStop method.
Public property | ReverseStopsCommand | Gets the ICommand that calls the ReverseStops method.
Public property | SelectedColor | Gets or sets the currently selected Color.
Public property | SelectedStopIndex | Gets or sets the index of the selected stop.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TrackGradientBrush | Gets the resolved GradientBrush to render in the track and adjust with the slider.
Public property | TrackHeight | Gets or sets the height of the slider track.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.ActiveBrush Property

GradientStopSliderActiveBrush Property

Gets or sets the Brush to render and adjust with the slider.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ActiveBrush { get; set; }
Public Property ActiveBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to render and adjust with the slider.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.AddStopCommand Property

GradientStopSliderAddStopCommand Property

Gets the ICommand that calls the AddStop method.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand AddStopCommand { get; }
Public ReadOnly Property AddStopCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that calls the AddStop method.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.CanAddStops Property

GradientStopSliderCanAddStops Property

Gets or sets whether stops can be added.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanAddStops { get; set; }
Public Property CanAddStops As Boolean
    Get
    Set

Property Value

Type: Boolean
true if stops can be added; otherwise, false. The default value is true.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.CanRemoveStops Property

GradientStopSliderCanRemoveStops Property

Gets or sets whether stops can be removed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanRemoveStops { get; set; }
Public Property CanRemoveStops As Boolean
    Get
    Set

Property Value

Type: Boolean
true if stops can be removed; otherwise, false. The default value is true.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.CanReuseBrush Property

GradientStopSliderCanReuseBrush Property

Gets or sets whether the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanReuseBrush { get; set; }
Public Property CanReuseBrush As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Brush value can simply have components like gradient stops updated instead of requiring a new brush to be created on any update; otherwise, false. The default value is true.
Remarks
Set this to false in scenarios when binding to ActiveBrush using value converters.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.RemoveSelectedStopCommand Property

GradientStopSliderRemoveSelectedStopCommand Property

Gets the ICommand that calls the RemoveSelectedStop method.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand RemoveSelectedStopCommand { get; }
Public ReadOnly Property RemoveSelectedStopCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that calls the RemoveSelectedStop method.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.ReverseStopsCommand Property

GradientStopSliderReverseStopsCommand Property

Gets the ICommand that calls the ReverseStops method.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ReverseStopsCommand { get; }
Public ReadOnly Property ReverseStopsCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that calls the ReverseStops method.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.SelectedColor Property

GradientStopSliderSelectedColor Property

Gets or sets the currently selected Color.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set

Property Value

Type: Color
The currently selected Color.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.SelectedStopIndex Property

GradientStopSliderSelectedStopIndex Property

Gets or sets the index of the selected stop.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SelectedStopIndex { get; set; }
Public Property SelectedStopIndex As Integer
    Get
    Set

Property Value

Type: Int32
The index of the selected stop.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.TrackGradientBrush Property

GradientStopSliderTrackGradientBrush Property

Gets the resolved GradientBrush to render in the track and adjust with the slider.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientBrush TrackGradientBrush { get; }
Public ReadOnly Property TrackGradientBrush As GradientBrush
    Get

Property Value

Type: GradientBrush
The GradientBrush to render in the track and adjust with the slider.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.TrackHeight Property

GradientStopSliderTrackHeight Property

Gets or sets the height of the slider track.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TrackHeight { get; set; }
Public Property TrackHeight As Double
    Get
    Set

Property Value

Type: Double
The height of the slider track. The default value is 12.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider Methods

The GradientStopSlider type exposes the following members.

Methods
 | Name | Description
Public method | AddStop | Adds a new gradient stop.
Public method | AddStop(NullableDouble) | Adds a new gradient stop.
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Refreshes the control, such as when an external change is made to ActiveBrush that is unable to be detected.
Public method | RemoveSelectedStop | Removes the selected gradient stop.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ReverseStops | Reverses the gradient stops in the ActiveBrush.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.AddStop Method

GradientStopSliderAddStop Method

Overload List
 | Name | Description
Public method | AddStop | Adds a new gradient stop.
Public method | AddStop(NullableDouble) | Adds a new gradient stop.
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.AddStop Method

GradientStopSliderAddStop Method

Adds a new gradient stop.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddStop()
Public Sub AddStop
See Also

Reference

GradientStopSlider Class
AddStop Overload
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.AddStop Method (Nullable(Double))

GradientStopSliderAddStop Method (NullableDouble)

Adds a new gradient stop.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddStop(
    Nullable<double> stopOffset
)
Public Sub AddStop (
    stopOffset As Nullable(Of Double)
)

Parameters

stopOffset
Type: SystemNullable Double
The optional specific offset for the new gradient stop.
See Also

Reference

GradientStopSlider Class
AddStop Overload
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.MeasureOverride Method

GradientStopSliderMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size constraint
)
Protected Overrides Function MeasureOverride (
    constraint As Size
) As Size

Parameters

constraint
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.OnApplyTemplate Method

GradientStopSliderOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.OnCreateAutomationPeer Method

GradientStopSliderOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.Refresh Method

GradientStopSliderRefresh Method

Refreshes the control, such as when an external change is made to ActiveBrush that is unable to be detected.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.RemoveSelectedStop Method

GradientStopSliderRemoveSelectedStop Method

Removes the selected gradient stop.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveSelectedStop()
Public Sub RemoveSelectedStop
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.ReverseStops Method

GradientStopSliderReverseStops Method

Reverses the gradient stops in the ActiveBrush.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ReverseStops()
Public Sub ReverseStops
Remarks
Gradient stops at offset 1.0 will be moved to offset 0.0 gradient stops at offset 0.0 will be moved to offset 1.0. Gradient stops at offset 0.5 will not be changed.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider Events

The GradientStopSlider type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider Fields

The GradientStopSlider type exposes the following members.

Fields
Name | Description
ActiveBrushProperty | Identifies the ActiveBrush dependency property. This field is read-only.
CanAddStopsProperty | Identifies the CanAddStops dependency property. This field is read-only.
CanRemoveStopsProperty | Identifies the CanRemoveStops dependency property. This field is read-only.
CanReuseBrushProperty | Identifies the CanReuseBrush dependency property. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
SelectedStopIndexProperty | Identifies the SelectedStopIndex dependency property. This field is read-only.
TrackGradientBrushProperty | Identifies the TrackGradientBrush dependency property. This field is read-only.
TrackHeightProperty | Identifies the TrackHeight dependency property. This field is read-only.
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.ActiveBrushProperty Field

GradientStopSliderActiveBrushProperty Field

Identifies the ActiveBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveBrushProperty
Public Shared ReadOnly ActiveBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveBrush dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.CanAddStopsProperty Field

GradientStopSliderCanAddStopsProperty Field

Identifies the CanAddStops dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAddStopsProperty
Public Shared ReadOnly CanAddStopsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAddStops dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.CanRemoveStopsProperty Field

GradientStopSliderCanRemoveStopsProperty Field

Identifies the CanRemoveStops dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRemoveStopsProperty
Public Shared ReadOnly CanRemoveStopsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRemoveStops dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.CanReuseBrushProperty Field

GradientStopSliderCanReuseBrushProperty Field

Identifies the CanReuseBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanReuseBrushProperty
Public Shared ReadOnly CanReuseBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanReuseBrush dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.SelectedColorProperty Field

GradientStopSliderSelectedColorProperty Field

Identifies the SelectedColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedColorProperty
Public Shared ReadOnly SelectedColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedColor dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.SelectedStopIndexProperty Field

GradientStopSliderSelectedStopIndexProperty Field

Identifies the SelectedStopIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedStopIndexProperty
Public Shared ReadOnly SelectedStopIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedStopIndex dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.TrackGradientBrushProperty Field

GradientStopSliderTrackGradientBrushProperty Field

Identifies the TrackGradientBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TrackGradientBrushProperty
Public Shared ReadOnly TrackGradientBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TrackGradientBrush dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GradientStopSlider.TrackHeightProperty Field

GradientStopSliderTrackHeightProperty Field

Identifies the TrackHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TrackHeightProperty
Public Shared ReadOnly TrackHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TrackHeight dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox Class

Represents an Guid edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Guid
ActiproSoftware.Windows.Controls.EditorsGuidEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GuidEditBox : PartEditBoxBase<Nullable<Guid>>
Public Class GuidEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Guid))

The GuidEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | GuidEditBox | Initializes an instance of the GuidEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the GUID format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | NewGuidButtonToolTip | Gets or sets the tooltip for the new GUID button.
Public property | NewGuidCommand | Gets the ICommand that can be used to generate a new GUID.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved GUID format string.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from PartEditBoxBaseT.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides PartEditBoxBaseTOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
NewGuidButtonToolTipProperty | Identifies the NewGuidButtonToolTip dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox Constructor

Initializes an instance of the GuidEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GuidEditBox()
Public Sub New
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox Properties

The GuidEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the GUID format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | NewGuidButtonToolTip | Gets or sets the tooltip for the new GUID button.
Public property | NewGuidCommand | Gets the ICommand that can be used to generate a new GUID.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved GUID format string.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.Format Property

GuidEditBoxFormat Property

Gets or sets the GUID format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The GUID format string. The default value is "D".
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.NewGuidButtonToolTip Property

GuidEditBoxNewGuidButtonToolTip Property

Gets or sets the tooltip for the new GUID button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object NewGuidButtonToolTip { get; set; }
Public Property NewGuidButtonToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip for the new GUID button.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.NewGuidCommand Property

GuidEditBoxNewGuidCommand Property

Gets the ICommand that can be used to generate a new GUID.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand NewGuidCommand { get; }
Public ReadOnly Property NewGuidCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to generate a new GUID.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.ResolvedFormat Property

GuidEditBoxResolvedFormat Property

Gets the resolved GUID format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved GUID format string.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox Methods

The GuidEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from PartEditBoxBaseT.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides PartEditBoxBaseTOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.ConvertToString Method

GuidEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Guid> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Guid)
) As String

Parameters

valueToConvert
Type: SystemNullable Guid
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.CreateIncrementalChangeRequest Method

GuidEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Guid>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Guid))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Guid
The incremental change (spin) request that was created.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.GenerateParts Method

GuidEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.IsValidValue Method

GuidEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Guid> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Guid)
) As Boolean

Parameters

value
Type: SystemNullable Guid
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.OnKeyDown Method

GuidEditBoxOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.RaiseValueChangedEvent Method

GuidEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.ResetValue Method

GuidEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.TryConvertFromString Method

GuidEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Guid> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Guid)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Guid
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox Events

The GuidEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.ValueChanged Event

GuidEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox Fields

The GuidEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
NewGuidButtonToolTipProperty | Identifies the NewGuidButtonToolTip dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
Top
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.FormatProperty Field

GuidEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.NewGuidButtonToolTipProperty Field

GuidEditBoxNewGuidButtonToolTipProperty Field

Identifies the NewGuidButtonToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NewGuidButtonToolTipProperty
Public Shared ReadOnly NewGuidButtonToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NewGuidButtonToolTip dependency property.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


GuidEditBox.ResolvedFormatProperty Field

GuidEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

GuidEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker Class

Represents a color picker control that allows for visual selection of hue, saturation, and brightness.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsHsbColorPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class HsbColorPicker : PickerBase
Public Class HsbColorPicker
    Inherits PickerBase

The HsbColorPicker type exposes the following members.

Constructors
 | Name | Description
Public method | HsbColorPicker | Initializes an instance of the HsbColorPicker class.
Top
Properties
 | Name | Description
Public property | A | Gets or sets the alpha transparency component (0 - 255) of the color.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the HSB brightness component (0 - 1.0) of the color.
Public property | ComparisonValue | Gets or sets the comparison color.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the HSB hue component (0 - 359.00) of the color.
Public property | IsComparisonValueVisible | Gets or sets a value indicating whether the comparison value is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Saturation | Gets or sets the HSB saturation component (0 - 1.0) of the color.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | BrightnessChanged | Occurs after the Brightness property value changes.
Public event | HueChanged | Occurs after the Hue property value changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SaturationChanged | Occurs after the Saturation property value changes.
Top
Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
ComparisonValueProperty | Identifies the ComparisonValue dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
IsComparisonValueVisibleProperty | Identifies the IsComparisonValueVisible dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker Constructor

Initializes an instance of the HsbColorPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public HsbColorPicker()
Public Sub New
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker Properties

The HsbColorPicker type exposes the following members.

Properties
 | Name | Description
Public property | A | Gets or sets the alpha transparency component (0 - 255) of the color.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the HSB brightness component (0 - 1.0) of the color.
Public property | ComparisonValue | Gets or sets the comparison color.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the HSB hue component (0 - 359.00) of the color.
Public property | IsComparisonValueVisible | Gets or sets a value indicating whether the comparison value is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Saturation | Gets or sets the HSB saturation component (0 - 1.0) of the color.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.A Property

HsbColorPickerA Property

Gets or sets the alpha transparency component (0 - 255) of the color.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int A { get; set; }
Public Property A As Integer
    Get
    Set

Property Value

Type: Int32
The alpha transparency component of the color.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.Brightness Property

HsbColorPickerBrightness Property

Gets or sets the HSB brightness component (0 - 1.0) of the color.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set

Property Value

Type: Double
The HSB brightness component (0 - 1.0) of the color.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.ComparisonValue Property

HsbColorPickerComparisonValue Property

Gets or sets the comparison color.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color ComparisonValue { get; set; }
Public Property ComparisonValue As Color
    Get
    Set

Property Value

Type: Color
The comparison color.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.Hue Property

HsbColorPickerHue Property

Gets or sets the HSB hue component (0 - 359.00) of the color.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The HSB hue component (0 - 359.00) of the color.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.IsComparisonValueVisible Property

HsbColorPickerIsComparisonValueVisible Property

Gets or sets a value indicating whether the comparison value is visible.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsComparisonValueVisible { get; set; }
Public Property IsComparisonValueVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the comparison value is visible; otherwise false. The default value is false.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.Saturation Property

HsbColorPickerSaturation Property

Gets or sets the HSB saturation component (0 - 1.0) of the color.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Saturation { get; set; }
Public Property Saturation As Double
    Get
    Set

Property Value

Type: Double
The HSB saturation component (0 - 1.0) of the color.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker Methods

The HsbColorPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.OnApplyTemplate Method

HsbColorPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker Events

The HsbColorPicker type exposes the following members.

Events
 | Name | Description
Public event | BrightnessChanged | Occurs after the Brightness property value changes.
Public event | HueChanged | Occurs after the Hue property value changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SaturationChanged | Occurs after the Saturation property value changes.
Top
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.BrightnessChanged Event

HsbColorPickerBrightnessChanged Event

Occurs after the Brightness property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler BrightnessChanged
Public Event BrightnessChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.HueChanged Event

HsbColorPickerHueChanged Event

Occurs after the Hue property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler HueChanged
Public Event HueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.SaturationChanged Event

HsbColorPickerSaturationChanged Event

Occurs after the Saturation property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler SaturationChanged
Public Event SaturationChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker Fields

The HsbColorPicker type exposes the following members.

Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
ComparisonValueProperty | Identifies the ComparisonValue dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
IsComparisonValueVisibleProperty | Identifies the IsComparisonValueVisible dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
Top
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.AProperty Field

HsbColorPickerAProperty Field

Identifies the A dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AProperty
Public Shared ReadOnly AProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the A dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.BrightnessProperty Field

HsbColorPickerBrightnessProperty Field

Identifies the Brightness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrightnessProperty
Public Shared ReadOnly BrightnessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Brightness dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.ComparisonValueProperty Field

HsbColorPickerComparisonValueProperty Field

Identifies the ComparisonValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparisonValueProperty
Public Shared ReadOnly ComparisonValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparisonValue dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.HueProperty Field

HsbColorPickerHueProperty Field

Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.IsComparisonValueVisibleProperty Field

HsbColorPickerIsComparisonValueVisibleProperty Field

Identifies the IsComparisonValueVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsComparisonValueVisibleProperty
Public Shared ReadOnly IsComparisonValueVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsComparisonValueVisible dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


HsbColorPicker.SaturationProperty Field

HsbColorPickerSaturationProperty Field

Identifies the Saturation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SaturationProperty
Public Shared ReadOnly SaturationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Saturation dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox Class

Represents an Int16 edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Int16
ActiproSoftware.Windows.Controls.EditorsInt16EditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int16EditBox : PartEditBoxBase<Nullable<short>>
Public Class Int16EditBox
    Inherits PartEditBoxBase(Of Nullable(Of Short))

The Int16EditBox type exposes the following members.

Constructors
 | Name | Description
Public method | Int16EditBox | Initializes an instance of the Int16EditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox Constructor

Initializes an instance of the Int16EditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int16EditBox()
Public Sub New
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox Properties

The Int16EditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.CalculatorPopupPickerStyle Property

Int16EditBoxCalculatorPopupPickerStyle Property

Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.DefaultValue Property

Int16EditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short DefaultValue { get; set; }
Public Property DefaultValue As Short
    Get
    Set

Property Value

Type: Int16
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.Format Property

Int16EditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.LargeChange Property

Int16EditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short LargeChange { get; set; }
Public Property LargeChange As Short
    Get
    Set

Property Value

Type: Int16
The large change value. The default value is 5.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.Maximum Property

Int16EditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short Maximum { get; set; }
Public Property Maximum As Short
    Get
    Set

Property Value

Type: Int16
The highest possible value.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.Minimum Property

Int16EditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short Minimum { get; set; }
Public Property Minimum As Short
    Get
    Set

Property Value

Type: Int16
The lowest possible value.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.PickerKind Property

Int16EditBoxPickerKind Property

Gets or sets an Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int16EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int16EditBoxPickerKind
    Get
    Set

Property Value

Type: Int16EditBoxPickerKind
An Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.ResolvedFormat Property

Int16EditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.SmallChange Property

Int16EditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short SmallChange { get; set; }
Public Property SmallChange As Short
    Get
    Set

Property Value

Type: Int16
The small change value. The default value is 1.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox Methods

The Int16EditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.CoerceValidValue Method

Int16EditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<short> CoerceValidValue(
    Nullable<short> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Short)
) As Nullable(Of Short)

Parameters

value
Type: SystemNullable Int16
The value to coerce.

Return Value

Type: Nullable Int16
The coerced value.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.ConvertToString Method

Int16EditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<short> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Short)
) As String

Parameters

valueToConvert
Type: SystemNullable Int16
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.CreateIncrementalChangeRequest Method

Int16EditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<short>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Short))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Int16
The incremental change (spin) request that was created.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.GenerateParts Method

Int16EditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.IsValidValue Method

Int16EditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<short> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Short)
) As Boolean

Parameters

value
Type: SystemNullable Int16
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.RaiseValueChangedEvent Method

Int16EditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.ResetValue Method

Int16EditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.TryConvertFromString Method

Int16EditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<short> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Short)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Int16
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox Events

The Int16EditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.ValueChanged Event

Int16EditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox Fields

The Int16EditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.CalculatorPopupPickerStyleProperty Field

Int16EditBoxCalculatorPopupPickerStyleProperty Field

Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.DefaultValueProperty Field

Int16EditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.FormatProperty Field

Int16EditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.LargeChangeProperty Field

Int16EditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.MaximumProperty Field

Int16EditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.MinimumProperty Field

Int16EditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.PickerKindProperty Field

Int16EditBoxPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.ResolvedFormatProperty Field

Int16EditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBox.SmallChangeProperty Field

Int16EditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16EditBoxPickerKind Enumeration

Specifies the kind of Style to apply to the Int16Picker used within a Int16EditBox's popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum Int16EditBoxPickerKind
Public Enumeration Int16EditBoxPickerKind
Members
Member name | Value | Description
Default | 0 | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int16Picker style, which is templated to contain a radial slider control.
Calculator | 1 | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker Class

Represents an Int16 picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.Windows.Controls.EditorsInt16Picker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int16Picker : RadialSliderPickerBase
Public Class Int16Picker
    Inherits RadialSliderPickerBase

The Int16Picker type exposes the following members.

Constructors
 | Name | Description
Public method | Int16Picker | Initializes an instance of the Int16Picker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker Constructor

Initializes an instance of the Int16Picker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int16Picker()
Public Sub New
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker Properties

The Int16Picker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.Maximum Property

Int16PickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short Maximum { get; set; }
Public Property Maximum As Short
    Get
    Set

Property Value

Type: Int16
The highest possible value.
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.Minimum Property

Int16PickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short Minimum { get; set; }
Public Property Minimum As Short
    Get
    Set

Property Value

Type: Int16
The lowest possible value.
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.SmallChange Property

Int16PickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short SmallChange { get; set; }
Public Property SmallChange As Short
    Get
    Set

Property Value

Type: Int16
The small change value. The default value is 1.
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.Value Property

Int16PickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short Value { get; set; }
Public Property Value As Short
    Get
    Set

Property Value

Type: Int16
The value of the control.
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker Methods

The Int16Picker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.OnApplyTemplate Method

Int16PickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker Events

The Int16Picker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.ValueChanged Event

Int16PickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker Fields

The Int16Picker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.MaximumProperty Field

Int16PickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.MinimumProperty Field

Int16PickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.SmallChangeProperty Field

Int16PickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int16Picker.ValueProperty Field

Int16PickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Int16Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox Class

Represents an Int32 edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Int32
ActiproSoftware.Windows.Controls.EditorsInt32EditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int32EditBox : PartEditBoxBase<Nullable<int>>
Public Class Int32EditBox
    Inherits PartEditBoxBase(Of Nullable(Of Integer))

The Int32EditBox type exposes the following members.

Constructors
 | Name | Description
Public method | Int32EditBox | Initializes an instance of the Int32EditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox Constructor

Initializes an instance of the Int32EditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32EditBox()
Public Sub New
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox Properties

The Int32EditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.CalculatorPopupPickerStyle Property

Int32EditBoxCalculatorPopupPickerStyle Property

Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.DefaultValue Property

Int32EditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int DefaultValue { get; set; }
Public Property DefaultValue As Integer
    Get
    Set

Property Value

Type: Int32
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.Format Property

Int32EditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.LargeChange Property

Int32EditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int LargeChange { get; set; }
Public Property LargeChange As Integer
    Get
    Set

Property Value

Type: Int32
The large change value. The default value is 5.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.Maximum Property

Int32EditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Maximum { get; set; }
Public Property Maximum As Integer
    Get
    Set

Property Value

Type: Int32
The highest possible value.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.Minimum Property

Int32EditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set

Property Value

Type: Int32
The lowest possible value.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.PickerKind Property

Int32EditBoxPickerKind Property

Gets or sets an Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int32EditBoxPickerKind
    Get
    Set

Property Value

Type: Int32EditBoxPickerKind
An Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.ResolvedFormat Property

Int32EditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.SmallChange Property

Int32EditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SmallChange { get; set; }
Public Property SmallChange As Integer
    Get
    Set

Property Value

Type: Int32
The small change value. The default value is 1.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox Methods

The Int32EditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.CoerceValidValue Method

Int32EditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<int> CoerceValidValue(
    Nullable<int> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Integer)
) As Nullable(Of Integer)

Parameters

value
Type: SystemNullable Int32
The value to coerce.

Return Value

Type: Nullable Int32
The coerced value.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.ConvertToString Method

Int32EditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<int> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Integer)
) As String

Parameters

valueToConvert
Type: SystemNullable Int32
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.CreateIncrementalChangeRequest Method

Int32EditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<int>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Integer))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Int32
The incremental change (spin) request that was created.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.GenerateParts Method

Int32EditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.IsValidValue Method

Int32EditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<int> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Integer)
) As Boolean

Parameters

value
Type: SystemNullable Int32
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.RaiseValueChangedEvent Method

Int32EditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.ResetValue Method

Int32EditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.TryConvertFromString Method

Int32EditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<int> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Integer)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Int32
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox Events

The Int32EditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.ValueChanged Event

Int32EditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox Fields

The Int32EditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.CalculatorPopupPickerStyleProperty Field

Int32EditBoxCalculatorPopupPickerStyleProperty Field

Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.DefaultValueProperty Field

Int32EditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.FormatProperty Field

Int32EditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.LargeChangeProperty Field

Int32EditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.MaximumProperty Field

Int32EditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.MinimumProperty Field

Int32EditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.PickerKindProperty Field

Int32EditBoxPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.ResolvedFormatProperty Field

Int32EditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBox.SmallChangeProperty Field

Int32EditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32EditBoxPickerKind Enumeration

Specifies the kind of Style to apply to the Int32Picker used within a Int32EditBox's popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum Int32EditBoxPickerKind
Public Enumeration Int32EditBoxPickerKind
Members
Member name | Value | Description
Default | 0 | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int32Picker style, which is templated to contain a radial slider control.
Calculator | 1 | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker Class

Represents an Int32 picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.Windows.Controls.EditorsInt32Picker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int32Picker : RadialSliderPickerBase
Public Class Int32Picker
    Inherits RadialSliderPickerBase

The Int32Picker type exposes the following members.

Constructors
 | Name | Description
Public method | Int32Picker | Initializes an instance of the Int32Picker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker Constructor

Initializes an instance of the Int32Picker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Picker()
Public Sub New
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker Properties

The Int32Picker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.Maximum Property

Int32PickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Maximum { get; set; }
Public Property Maximum As Integer
    Get
    Set

Property Value

Type: Int32
The highest possible value.
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.Minimum Property

Int32PickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set

Property Value

Type: Int32
The lowest possible value.
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.SmallChange Property

Int32PickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SmallChange { get; set; }
Public Property SmallChange As Integer
    Get
    Set

Property Value

Type: Int32
The small change value. The default value is 1.
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.Value Property

Int32PickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set

Property Value

Type: Int32
The value of the control.
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker Methods

The Int32Picker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.OnApplyTemplate Method

Int32PickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker Events

The Int32Picker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.ValueChanged Event

Int32PickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker Fields

The Int32Picker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.MaximumProperty Field

Int32PickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.MinimumProperty Field

Int32PickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.SmallChangeProperty Field

Int32PickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32Picker.ValueProperty Field

Int32PickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Int32Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox Class

Represents a Int32Rect edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Int32Rect
ActiproSoftware.Windows.Controls.EditorsInt32RectEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int32RectEditBox : PartEditBoxBase<Nullable<Int32Rect>>
Public Class Int32RectEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Int32Rect))

The Int32RectEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | Int32RectEditBox | Initializes an instance of the Int32RectEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox Constructor

Initializes an instance of the Int32RectEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32RectEditBox()
Public Sub New
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox Properties

The Int32RectEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.DefaultValue Property

Int32RectEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect DefaultValue { get; set; }
Public Property DefaultValue As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.Format Property

Int32RectEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.LargeChange Property

Int32RectEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect LargeChange { get; set; }
Public Property LargeChange As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The large change value. The default value is 5.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.Maximum Property

Int32RectEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect Maximum { get; set; }
Public Property Maximum As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The highest possible value.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.Minimum Property

Int32RectEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect Minimum { get; set; }
Public Property Minimum As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The lowest possible value.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.ResolvedFormat Property

Int32RectEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.SmallChange Property

Int32RectEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect SmallChange { get; set; }
Public Property SmallChange As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The small change value. The default value is 1.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox Methods

The Int32RectEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.CoerceValidValue Method

Int32RectEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Int32Rect> CoerceValidValue(
    Nullable<Int32Rect> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Int32Rect)
) As Nullable(Of Int32Rect)

Parameters

value
Type: SystemNullable Int32Rect
The value to coerce.

Return Value

Type: Nullable Int32Rect
The coerced value.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.ConvertToString Method

Int32RectEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Int32Rect> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Int32Rect)
) As String

Parameters

valueToConvert
Type: SystemNullable Int32Rect
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.CreateIncrementalChangeRequest Method

Int32RectEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Int32Rect>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Int32Rect))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Int32Rect
The incremental change (spin) request that was created.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.GenerateParts Method

Int32RectEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.IsValidValue Method

Int32RectEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Int32Rect> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Int32Rect)
) As Boolean

Parameters

value
Type: SystemNullable Int32Rect
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.RaiseValueChangedEvent Method

Int32RectEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.ResetValue Method

Int32RectEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.TryConvertFromString Method

Int32RectEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Int32Rect> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Int32Rect)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Int32Rect
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox Events

The Int32RectEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.ValueChanged Event

Int32RectEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox Fields

The Int32RectEditBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.DefaultValueProperty Field

Int32RectEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.FormatProperty Field

Int32RectEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.LargeChangeProperty Field

Int32RectEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.MaximumProperty Field

Int32RectEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.MinimumProperty Field

Int32RectEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.ResolvedFormatProperty Field

Int32RectEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectEditBox.SmallChangeProperty Field

Int32RectEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int32RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker Class

Represents an Int32Rect picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsInt32RectPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int32RectPicker : PickerBase
Public Class Int32RectPicker
    Inherits PickerBase

The Int32RectPicker type exposes the following members.

Constructors
 | Name | Description
Public method | Int32RectPicker | Initializes an instance of the Int32RectPicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker Constructor

Initializes an instance of the Int32RectPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32RectPicker()
Public Sub New
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker Properties

The Int32RectPicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.Maximum Property

Int32RectPickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect Maximum { get; set; }
Public Property Maximum As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The highest possible value.
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.Minimum Property

Int32RectPickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect Minimum { get; set; }
Public Property Minimum As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The lowest possible value.
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.SmallChange Property

Int32RectPickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect SmallChange { get; set; }
Public Property SmallChange As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The small change value. The default value is 1.
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.Value Property

Int32RectPickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect Value { get; set; }
Public Property Value As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The value of the control.
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker Methods

The Int32RectPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.OnApplyTemplate Method

Int32RectPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker Events

The Int32RectPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.ValueChanged Event

Int32RectPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker Fields

The Int32RectPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.MaximumProperty Field

Int32RectPickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.MinimumProperty Field

Int32RectPickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.SmallChangeProperty Field

Int32RectPickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int32RectPicker.ValueProperty Field

Int32RectPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Int32RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox Class

Represents an Int64 edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Int64
ActiproSoftware.Windows.Controls.EditorsInt64EditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int64EditBox : PartEditBoxBase<Nullable<long>>
Public Class Int64EditBox
    Inherits PartEditBoxBase(Of Nullable(Of Long))

The Int64EditBox type exposes the following members.

Constructors
 | Name | Description
Public method | Int64EditBox | Initializes an instance of the Int64EditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox Constructor

Initializes an instance of the Int64EditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int64EditBox()
Public Sub New
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox Properties

The Int64EditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.CalculatorPopupPickerStyle Property

Int64EditBoxCalculatorPopupPickerStyle Property

Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.DefaultValue Property

Int64EditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long DefaultValue { get; set; }
Public Property DefaultValue As Long
    Get
    Set

Property Value

Type: Int64
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.Format Property

Int64EditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.LargeChange Property

Int64EditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long LargeChange { get; set; }
Public Property LargeChange As Long
    Get
    Set

Property Value

Type: Int64
The large change value. The default value is 5.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.Maximum Property

Int64EditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long Maximum { get; set; }
Public Property Maximum As Long
    Get
    Set

Property Value

Type: Int64
The highest possible value.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.Minimum Property

Int64EditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long Minimum { get; set; }
Public Property Minimum As Long
    Get
    Set

Property Value

Type: Int64
The lowest possible value.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.PickerKind Property

Int64EditBoxPickerKind Property

Gets or sets an Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int64EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int64EditBoxPickerKind
    Get
    Set

Property Value

Type: Int64EditBoxPickerKind
An Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.ResolvedFormat Property

Int64EditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.SmallChange Property

Int64EditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long SmallChange { get; set; }
Public Property SmallChange As Long
    Get
    Set

Property Value

Type: Int64
The small change value. The default value is 1.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox Methods

The Int64EditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.CoerceValidValue Method

Int64EditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<long> CoerceValidValue(
    Nullable<long> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Long)
) As Nullable(Of Long)

Parameters

value
Type: SystemNullable Int64
The value to coerce.

Return Value

Type: Nullable Int64
The coerced value.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.ConvertToString Method

Int64EditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<long> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Long)
) As String

Parameters

valueToConvert
Type: SystemNullable Int64
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.CreateIncrementalChangeRequest Method

Int64EditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<long>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Long))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Int64
The incremental change (spin) request that was created.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.GenerateParts Method

Int64EditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.IsValidValue Method

Int64EditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<long> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Long)
) As Boolean

Parameters

value
Type: SystemNullable Int64
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.RaiseValueChangedEvent Method

Int64EditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.ResetValue Method

Int64EditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.TryConvertFromString Method

Int64EditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<long> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Long)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Int64
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox Events

The Int64EditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.ValueChanged Event

Int64EditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox Fields

The Int64EditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.CalculatorPopupPickerStyleProperty Field

Int64EditBoxCalculatorPopupPickerStyleProperty Field

Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.DefaultValueProperty Field

Int64EditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.FormatProperty Field

Int64EditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.LargeChangeProperty Field

Int64EditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.MaximumProperty Field

Int64EditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.MinimumProperty Field

Int64EditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.PickerKindProperty Field

Int64EditBoxPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.ResolvedFormatProperty Field

Int64EditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBox.SmallChangeProperty Field

Int64EditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64EditBoxPickerKind Enumeration

Specifies the kind of Style to apply to the Int64Picker used within a Int64EditBox's popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum Int64EditBoxPickerKind
Public Enumeration Int64EditBoxPickerKind
Members
Member name | Value | Description
Default | 0 | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int64Picker style, which is templated to contain a radial slider control.
Calculator | 1 | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker Class

Represents an Int64 picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.Windows.Controls.EditorsInt64Picker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int64Picker : RadialSliderPickerBase
Public Class Int64Picker
    Inherits RadialSliderPickerBase

The Int64Picker type exposes the following members.

Constructors
 | Name | Description
Public method | Int64Picker | Initializes an instance of the Int64Picker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker Constructor

Initializes an instance of the Int64Picker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int64Picker()
Public Sub New
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker Properties

The Int64Picker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.Maximum Property

Int64PickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long Maximum { get; set; }
Public Property Maximum As Long
    Get
    Set

Property Value

Type: Int64
The highest possible value.
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.Minimum Property

Int64PickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long Minimum { get; set; }
Public Property Minimum As Long
    Get
    Set

Property Value

Type: Int64
The lowest possible value.
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.SmallChange Property

Int64PickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long SmallChange { get; set; }
Public Property SmallChange As Long
    Get
    Set

Property Value

Type: Int64
The small change value. The default value is 1.
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.Value Property

Int64PickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set

Property Value

Type: Int64
The value of the control.
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker Methods

The Int64Picker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.OnApplyTemplate Method

Int64PickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker Events

The Int64Picker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.ValueChanged Event

Int64PickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker Fields

The Int64Picker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.MaximumProperty Field

Int64PickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.MinimumProperty Field

Int64PickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.SmallChangeProperty Field

Int64PickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Int64Picker.ValueProperty Field

Int64PickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Int64Picker Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox Class

Represents a TextBox that restricts input based on a specified mask.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsTextBox
ActiproSoftware.Windows.Controls.EditorsMaskedTextBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MaskedTextBox : TextBox
Public Class MaskedTextBox
    Inherits TextBox

The MaskedTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | MaskedTextBox | Initializes an instance of the MaskedTextBox class.
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Public property | IsCaseAutoCorrected | Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.
Public property | IsCaseSensitive | Gets or sets whether the mask is case sensitive.
Public property | IsMatched | Gets whether the input text successfully matches the pattern.
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Mask | Gets or sets the text that designates the input mask.
Public property | MaskKind | Gets or sets the kind of input mask.
Public property | MatchedText | Gets or sets the matched text, which is generally the same as the Text property but without any prompt characters included.
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PromptChar | Gets or sets the character used to indicate required input.
Public property | PromptVisibility | Gets or sets the visibility of mask prompts.
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides TextBoxBaseOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Occurs when a pointer button is down. (Overrides TextBoxBaseOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | IsMatchedChanged | Occurs after the IsMatched property value changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Top
Fields
Name | Description
IsCaseAutoCorrectedProperty | Identifies the IsCaseAutoCorrected dependency property. This field is read-only.
IsCaseSensitiveProperty | Identifies the IsCaseSensitive dependency property. This field is read-only.
IsMatchedProperty | Identifies the IsMatched dependency property. This field is read-only.
MaskKindProperty | Identifies the MaskKind dependency property. This field is read-only.
MaskProperty | Identifies the Mask dependency property. This field is read-only.
MatchedTextProperty | Identifies the MatchedText dependency property. This field is read-only.
PromptCharProperty | Identifies the PromptChar dependency property. This field is read-only.
PromptVisibilityProperty | Identifies the PromptVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox Constructor

Initializes an instance of the MaskedTextBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MaskedTextBox()
Public Sub New
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox Properties

The MaskedTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Public property | IsCaseAutoCorrected | Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.
Public property | IsCaseSensitive | Gets or sets whether the mask is case sensitive.
Public property | IsMatched | Gets whether the input text successfully matches the pattern.
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Mask | Gets or sets the text that designates the input mask.
Public property | MaskKind | Gets or sets the kind of input mask.
Public property | MatchedText | Gets or sets the matched text, which is generally the same as the Text property but without any prompt characters included.
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PromptChar | Gets or sets the character used to indicate required input.
Public property | PromptVisibility | Gets or sets the visibility of mask prompts.
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.IsCaseAutoCorrected Property

MaskedTextBoxIsCaseAutoCorrected Property

Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCaseAutoCorrected { get; set; }
Public Property IsCaseAutoCorrected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if characters entered will have their case auto-corrected to match the defined mask; otherwise, false. The default value is false.
Remarks
When this property is set to true, then the IsCaseSensitive property is ignored.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.IsCaseSensitive Property

MaskedTextBoxIsCaseSensitive Property

Gets or sets whether the mask is case sensitive.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCaseSensitive { get; set; }
Public Property IsCaseSensitive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the mask is case sensitive; otherwise, false. The default value is false.
Remarks
When the IsCaseAutoCorrected property is set to true, this property is ignored.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.IsMatched Property

MaskedTextBoxIsMatched Property

Gets whether the input text successfully matches the pattern.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMatched { get; }
Public ReadOnly Property IsMatched As Boolean
    Get

Property Value

Type: Boolean
true if the input text successfully matches the pattern; otherwise, false.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.Mask Property

MaskedTextBoxMask Property

Gets or sets the text that designates the input mask.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set

Property Value

Type: String
The text that designates the input mask. The default value is .
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.MaskKind Property

MaskedTextBoxMaskKind Property

Gets or sets the kind of input mask.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MaskKind MaskKind { get; set; }
Public Property MaskKind As MaskKind
    Get
    Set

Property Value

Type: MaskKind
The kind of input mask. The default value is Regex.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.MatchedText Property

MaskedTextBoxMatchedText Property

Gets or sets the matched text, which is generally the same as the Text property but without any prompt characters included.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string MatchedText { get; set; }
Public Property MatchedText As String
    Get
    Set

Property Value

Type: String
The matched text.
Remarks
Any bindings to MaskedTextBox should bind to this property instead of Text, so that prompt characters aren't included in the result.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.PromptChar Property

MaskedTextBoxPromptChar Property

Gets or sets the character used to indicate required input.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char PromptChar { get; set; }
Public Property PromptChar As Char
    Get
    Set

Property Value

Type: Char
The character used to indicate required input. The default value is \u2022.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.PromptVisibility Property

MaskedTextBoxPromptVisibility Property

Gets or sets the visibility of mask prompts.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MaskPromptVisibility PromptVisibility { get; set; }
Public Property PromptVisibility As MaskPromptVisibility
    Get
    Set

Property Value

Type: MaskPromptVisibility
A MaskPromptVisibility that indicates the visibility of mask prompts. The default value is FocusedOnly.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox Methods

The MaskedTextBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides TextBoxBaseOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Occurs when a pointer button is down. (Overrides TextBoxBaseOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.OnGotFocus Method

MaskedTextBoxOnGotFocus Method

Occurs when the control gains focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.OnLostFocus Method

MaskedTextBoxOnLostFocus Method

Occurs when the control loses focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.OnMouseDown Method

MaskedTextBoxOnMouseDown Method

Occurs when a pointer button is down.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox Events

The MaskedTextBox type exposes the following members.

Events
 | Name | Description
Public event | IsMatchedChanged | Occurs after the IsMatched property value changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Top
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.IsMatchedChanged Event

MaskedTextBoxIsMatchedChanged Event

Occurs after the IsMatched property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler IsMatchedChanged
Public Event IsMatchedChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox Fields

The MaskedTextBox type exposes the following members.

Fields
Name | Description
IsCaseAutoCorrectedProperty | Identifies the IsCaseAutoCorrected dependency property. This field is read-only.
IsCaseSensitiveProperty | Identifies the IsCaseSensitive dependency property. This field is read-only.
IsMatchedProperty | Identifies the IsMatched dependency property. This field is read-only.
MaskKindProperty | Identifies the MaskKind dependency property. This field is read-only.
MaskProperty | Identifies the Mask dependency property. This field is read-only.
MatchedTextProperty | Identifies the MatchedText dependency property. This field is read-only.
PromptCharProperty | Identifies the PromptChar dependency property. This field is read-only.
PromptVisibilityProperty | Identifies the PromptVisibility dependency property. This field is read-only.
Top
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.IsCaseAutoCorrectedProperty Field

MaskedTextBoxIsCaseAutoCorrectedProperty Field

Identifies the IsCaseAutoCorrected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCaseAutoCorrectedProperty
Public Shared ReadOnly IsCaseAutoCorrectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCaseAutoCorrected dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.IsCaseSensitiveProperty Field

MaskedTextBoxIsCaseSensitiveProperty Field

Identifies the IsCaseSensitive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCaseSensitiveProperty
Public Shared ReadOnly IsCaseSensitiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCaseSensitive dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.IsMatchedProperty Field

MaskedTextBoxIsMatchedProperty Field

Identifies the IsMatched dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMatchedProperty
Public Shared ReadOnly IsMatchedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMatched dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.MaskKindProperty Field

MaskedTextBoxMaskKindProperty Field

Identifies the MaskKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaskKindProperty
Public Shared ReadOnly MaskKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaskKind dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.MaskProperty Field

MaskedTextBoxMaskProperty Field

Identifies the Mask dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaskProperty
Public Shared ReadOnly MaskProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Mask dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.MatchedTextProperty Field

MaskedTextBoxMatchedTextProperty Field

Identifies the MatchedText dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MatchedTextProperty
Public Shared ReadOnly MatchedTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MatchedText dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.PromptCharProperty Field

MaskedTextBoxPromptCharProperty Field

Identifies the PromptChar dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PromptCharProperty
Public Shared ReadOnly PromptCharProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PromptChar dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskedTextBox.PromptVisibilityProperty Field

MaskedTextBoxPromptVisibilityProperty Field

Identifies the PromptVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PromptVisibilityProperty
Public Shared ReadOnly PromptVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PromptVisibility dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


MaskKind Enumeration

Specifies the mask kinds supported by a MaskedTextBox.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MaskKind
Public Enumeration MaskKind
Members
Member name | Value | Description
Regex | 0 | The mask is defined as a regular expression.
Wildcard | 1 | The mask is defined using wild card characters.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


MaskPromptVisibility Enumeration

Specifies the visibility of mask prompts within a MaskedTextBox.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MaskPromptVisibility
Public Enumeration MaskPromptVisibility
Members
Member name | Value | Description
FocusedOnly | 0 | Prompts will only be visible when the control contains the focus.
Always | 1 | Prompts will always be visible.
Never | 2 | Prompts will never be visible.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar Class

Represents a month calendar control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.EditorsMonthCalendar

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MonthCalendar : Control
Public Class MonthCalendar
    Inherits Control

The MonthCalendar type exposes the following members.

Constructors
 | Name | Description
Public method | MonthCalendar | Initializes a new instance of the MonthCalendar class.
Top
Properties
 | Name | Description
Public property | ActiveDate | Gets or sets the active date in the calendar.
Public property | ActiveViewMode | Gets or sets the active view mode of the calendar.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalendarWeekRule | Gets or sets the calendar week rule, which determines how weeks are numbered.
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | ClearButtonStyle | Gets or sets the Style to apply to the Clear button.
Public property | ClearButtonText | Gets or sets the text to display in the Clear button.
Public property | ClearSelectionCommand | Gets the ICommand that is used to clear the selection.
Public property | DayItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging day items.
Public property | DayItemTemplate | Gets or sets the DataTemplate to use for day items.
Public property | DayItemTemplateSelector | Gets or sets the DataTemplateSelector to use for day items.
Public property | DayNameItemContainerStyle | Gets or sets the Style to apply to day name items.
Public property | DayNameItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging day name items.
Public property | DayNameItemTemplate | Gets or sets the DataTemplate to use for day name items.
Public property | DayOfWeekFormatPattern | Gets or sets the format pattern used for DayOfWeek values.
Public property | DecadeItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging decade items.
Public property | DecadeItemTemplate | Gets or sets the DataTemplate to use for decade items.
Public property | DisabledDaysOfWeek | Gets or sets the disabled days of the week.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FirstDayOfWeek | Gets or sets the first day of the week.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GoToNextViewCommand | Gets the ICommand that is used to go to the next view.
Public property | GoToPreviousViewCommand | Gets the ICommand that is used to go to the next view.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsClearButtonVisible | Gets or sets whether the clear button is visible.
Public property | IsDateDisabledFunc | Gets or sets a function that is called when a day cell is rendered to determine if it should be disabled.
Public property | IsDayOfWeekSelectionEnabled | Gets or sets whether the day of week headers can be used to select dates.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTodayButtonVisible | Gets or sets whether the Today button is visible.
Public property | IsTodayHighlighted | Gets or sets whether DateTime.Today is highlighted.
Public property | IsWeekNumberColumnVisible | Gets or sets whether the week number column is visible.
Public property | IsWeekNumberSelectionEnabled | Gets or sets whether the week numbers can be used to select dates.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxSelectionCount | Gets or sets the maximum number of dates that can be selected.
Public property | MaxViewMode | Gets or sets the maximum view mode allowed.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MonthItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging month items.
Public property | MonthItemTemplate | Gets or sets the DataTemplate to use for month items.
Public property | NavigationButtonStyle | Gets or sets the Style to apply to the navigation buttons.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectDateCommand | Gets the ICommand that is used to select a date.
Public property | SelectDayOfWeekCommand | Gets the ICommand that is used to select an entire day of week.
Public property | SelectedDate | Gets or sets the selected date, if any, in the calendar.
Public property | SelectedDates | Gets the currently-selected dates in the calendar.
Public property | SelectionMode | Gets or sets the selection mode of the calendar.
Public property | SelectTodayCommand | Gets the ICommand that is used to select today's date.
Public property | SelectWeekCommand | Gets the ICommand that is used to select an entire week.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets the title that is displayed for the active view.
Public property | TitleButtonStyle | Gets or sets the Style to apply to the title button.
Public property | TodayButtonStyle | Gets or sets the Style to apply to the Today button.
Public property | TodayButtonText | Gets the text to display in the Today button.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | ViewResetMode | Gets or sets the view reset mode, which can be used to reset the view when the calendar loses focus.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WeekNumberItemContainerStyle | Gets or sets the Style to apply to week number items.
Public property | WeekNumberItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging week number items.
Public property | WeekNumberItemTemplate | Gets or sets the DataTemplate to use for week number items.
Public property | YearItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging year items.
Public property | YearItemTemplate | Gets or sets the DataTemplate to use for year items.
Public property | ZoomInCommand | Gets the ICommand that is used to zoom in.
Public property | ZoomOutCommand | Gets the ICommand that is used to zoom out.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Refreshes the control.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectToday | Selects today's date.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDayItem | Updates a MonthCalendarItem for the specified day.
Protected method | UpdateDayNameItem | Updates a MonthCalendarItem for the specified day of week.
Protected method | UpdateDecadeItem | Updates a MonthCalendarItem for the specified decade.
Protected method | UpdateMonthItem | Updates a MonthCalendarItem for the specified month.
Protected method | UpdateWeekNumberItem | Updates a MonthCalendarItem for the specified week number.
Protected method | UpdateYearItem | Updates a MonthCalendarItem for the specified year.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs after the SelectedDate property value and/or SelectedDates collection changes.
Public event | SelectionCommitted | Occurs when the selection is committed, either by pressing Enter or clicking on a date value in single selection mode.
Top
Fields
Name | Description
ActiveDateProperty | Identifies the ActiveDate dependency property. This field is read-only.
ActiveViewModeProperty | Identifies the ActiveViewMode dependency property. This field is read-only.
CalendarWeekRuleProperty | Identifies the CalendarWeekRule dependency property. This field is read-only.
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
ClearButtonStyleProperty | Identifies the ClearButtonStyle dependency property. This field is read-only.
ClearButtonTextProperty | Identifies the ClearButtonText dependency property. This field is read-only.
DayItemsPanelTemplateProperty | Identifies the DayItemsPanelTemplate dependency property. This field is read-only.
DayItemTemplateProperty | Identifies the DayItemTemplate dependency property. This field is read-only.
DayItemTemplateSelectorProperty | Identifies the DayItemTemplateSelector dependency property. This field is read-only.
DayNameItemContainerStyleProperty | Identifies the DayNameItemContainerStyle dependency property. This field is read-only.
DayNameItemsPanelTemplateProperty | Identifies the DayNameItemsPanelTemplate dependency property. This field is read-only.
DayNameItemTemplateProperty | Identifies the DayNameItemTemplate dependency property. This field is read-only.
DayOfWeekFormatPatternProperty | Identifies the DayOfWeekFormatPattern dependency property. This field is read-only.
DecadeItemsPanelTemplateProperty | Identifies the DecadeItemsPanelTemplate dependency property. This field is read-only.
DecadeItemTemplateProperty | Identifies the DecadeItemTemplate dependency property. This field is read-only.
DisabledDaysOfWeekProperty | Identifies the DisabledDaysOfWeek dependency property. This field is read-only.
FirstDayOfWeekProperty | Identifies the FirstDayOfWeek dependency property. This field is read-only.
IsClearButtonVisibleProperty | Identifies the IsClearButtonVisible dependency property. This field is read-only.
IsDateDisabledFuncProperty | Identifies the IsDateDisabledFunc dependency property. This field is read-only.
IsDayOfWeekSelectionEnabledProperty | Identifies the IsDayOfWeekSelectionEnabled dependency property. This field is read-only.
IsTodayButtonVisibleProperty | Identifies the IsTodayButtonVisible dependency property. This field is read-only.
IsTodayHighlightedProperty | Identifies the IsTodayHighlighted dependency property. This field is read-only.
IsWeekNumberColumnVisibleProperty | Identifies the IsWeekNumberColumnVisible dependency property. This field is read-only.
IsWeekNumberSelectionEnabledProperty | Identifies the IsWeekNumberSelectionEnabled dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MaxSelectionCountProperty | Identifies the MaxSelectionCount dependency property. This field is read-only.
MaxViewModeProperty | Identifies the MaxViewMode dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MonthItemsPanelTemplateProperty | Identifies the MonthItemsPanelTemplate dependency property. This field is read-only.
MonthItemTemplateProperty | Identifies the MonthItemTemplate dependency property. This field is read-only.
NavigationButtonStyleProperty | Identifies the NavigationButtonStyle dependency property. This field is read-only.
SelectedDateProperty | Identifies the SelectedDate dependency property. This field is read-only.
SelectionModeProperty | Identifies the SelectionMode dependency property. This field is read-only.
TitleButtonStyleProperty | Identifies the TitleButtonStyle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TodayButtonStyleProperty | Identifies the TodayButtonStyle dependency property. This field is read-only.
TodayButtonTextProperty | Identifies the TodayButtonText dependency property. This field is read-only.
ViewResetModeProperty | Identifies the ViewResetMode dependency property. This field is read-only.
WeekNumberItemContainerStyleProperty | Identifies the WeekNumberItemContainerStyle dependency property. This field is read-only.
WeekNumberItemsPanelTemplateProperty | Identifies the WeekNumberItemsPanelTemplate dependency property. This field is read-only.
WeekNumberItemTemplateProperty | Identifies the WeekNumberItemTemplate dependency property. This field is read-only.
YearItemsPanelTemplateProperty | Identifies the YearItemsPanelTemplate dependency property. This field is read-only.
YearItemTemplateProperty | Identifies the YearItemTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar Constructor

Initializes a new instance of the MonthCalendar class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MonthCalendar()
Public Sub New
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar Properties

The MonthCalendar type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDate | Gets or sets the active date in the calendar.
Public property | ActiveViewMode | Gets or sets the active view mode of the calendar.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalendarWeekRule | Gets or sets the calendar week rule, which determines how weeks are numbered.
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | ClearButtonStyle | Gets or sets the Style to apply to the Clear button.
Public property | ClearButtonText | Gets or sets the text to display in the Clear button.
Public property | ClearSelectionCommand | Gets the ICommand that is used to clear the selection.
Public property | DayItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging day items.
Public property | DayItemTemplate | Gets or sets the DataTemplate to use for day items.
Public property | DayItemTemplateSelector | Gets or sets the DataTemplateSelector to use for day items.
Public property | DayNameItemContainerStyle | Gets or sets the Style to apply to day name items.
Public property | DayNameItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging day name items.
Public property | DayNameItemTemplate | Gets or sets the DataTemplate to use for day name items.
Public property | DayOfWeekFormatPattern | Gets or sets the format pattern used for DayOfWeek values.
Public property | DecadeItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging decade items.
Public property | DecadeItemTemplate | Gets or sets the DataTemplate to use for decade items.
Public property | DisabledDaysOfWeek | Gets or sets the disabled days of the week.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FirstDayOfWeek | Gets or sets the first day of the week.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GoToNextViewCommand | Gets the ICommand that is used to go to the next view.
Public property | GoToPreviousViewCommand | Gets the ICommand that is used to go to the next view.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsClearButtonVisible | Gets or sets whether the clear button is visible.
Public property | IsDateDisabledFunc | Gets or sets a function that is called when a day cell is rendered to determine if it should be disabled.
Public property | IsDayOfWeekSelectionEnabled | Gets or sets whether the day of week headers can be used to select dates.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTodayButtonVisible | Gets or sets whether the Today button is visible.
Public property | IsTodayHighlighted | Gets or sets whether DateTime.Today is highlighted.
Public property | IsWeekNumberColumnVisible | Gets or sets whether the week number column is visible.
Public property | IsWeekNumberSelectionEnabled | Gets or sets whether the week numbers can be used to select dates.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxSelectionCount | Gets or sets the maximum number of dates that can be selected.
Public property | MaxViewMode | Gets or sets the maximum view mode allowed.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MonthItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging month items.
Public property | MonthItemTemplate | Gets or sets the DataTemplate to use for month items.
Public property | NavigationButtonStyle | Gets or sets the Style to apply to the navigation buttons.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectDateCommand | Gets the ICommand that is used to select a date.
Public property | SelectDayOfWeekCommand | Gets the ICommand that is used to select an entire day of week.
Public property | SelectedDate | Gets or sets the selected date, if any, in the calendar.
Public property | SelectedDates | Gets the currently-selected dates in the calendar.
Public property | SelectionMode | Gets or sets the selection mode of the calendar.
Public property | SelectTodayCommand | Gets the ICommand that is used to select today's date.
Public property | SelectWeekCommand | Gets the ICommand that is used to select an entire week.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Title | Gets the title that is displayed for the active view.
Public property | TitleButtonStyle | Gets or sets the Style to apply to the title button.
Public property | TodayButtonStyle | Gets or sets the Style to apply to the Today button.
Public property | TodayButtonText | Gets the text to display in the Today button.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | ViewResetMode | Gets or sets the view reset mode, which can be used to reset the view when the calendar loses focus.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WeekNumberItemContainerStyle | Gets or sets the Style to apply to week number items.
Public property | WeekNumberItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging week number items.
Public property | WeekNumberItemTemplate | Gets or sets the DataTemplate to use for week number items.
Public property | YearItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging year items.
Public property | YearItemTemplate | Gets or sets the DataTemplate to use for year items.
Public property | ZoomInCommand | Gets the ICommand that is used to zoom in.
Public property | ZoomOutCommand | Gets the ICommand that is used to zoom out.
Top
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ActiveDate Property

MonthCalendarActiveDate Property

Gets or sets the active date in the calendar.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime ActiveDate { get; set; }
Public Property ActiveDate As DateTime
    Get
    Set

Property Value

Type: DateTime
The active date in the calendar.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ActiveViewMode Property

MonthCalendarActiveViewMode Property

Gets or sets the active view mode of the calendar.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MonthCalendarViewMode ActiveViewMode { get; set; }
Public Property ActiveViewMode As MonthCalendarViewMode
    Get
    Set

Property Value

Type: MonthCalendarViewMode
The active view mode of the calendar. The default value is MonthCalendarViewMode.Month.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.CalendarWeekRule Property

MonthCalendarCalendarWeekRule Property

Gets or sets the calendar week rule, which determines how weeks are numbered.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<CalendarWeekRule> CalendarWeekRule { get; set; }
Public Property CalendarWeekRule As Nullable(Of CalendarWeekRule)
    Get
    Set

Property Value

Type: Nullable CalendarWeekRule
The calendar week rule. When set to , the calendar week rule is pulled from the current culture. The default value is .
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.CanRetainTime Property

MonthCalendarCanRetainTime Property

Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanRetainTime { get; set; }
Public Property CanRetainTime As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the various DateTime values can retain the time-portion; otherwise, false. The default value is false.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ClearButtonStyle Property

MonthCalendarClearButtonStyle Property

Gets or sets the Style to apply to the Clear button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ClearButtonStyle { get; set; }
Public Property ClearButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to the Clear button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ClearButtonText Property

MonthCalendarClearButtonText Property

Gets or sets the text to display in the Clear button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ClearButtonText { get; set; }
Public Property ClearButtonText As String
    Get
    Set

Property Value

Type: String
The text to display in the Clear button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ClearSelectionCommand Property

MonthCalendarClearSelectionCommand Property

Gets the ICommand that is used to clear the selection.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ClearSelectionCommand { get; }
Public ReadOnly Property ClearSelectionCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to clear the selection.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayItemsPanelTemplate Property

MonthCalendarDayItemsPanelTemplate Property

Gets or sets the ItemsPanelTemplate to use for arranging day items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate DayItemsPanelTemplate { get; set; }
Public Property DayItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging day items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayItemTemplate Property

MonthCalendarDayItemTemplate Property

Gets or sets the DataTemplate to use for day items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DayItemTemplate { get; set; }
Public Property DayItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for day items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayItemTemplateSelector Property

MonthCalendarDayItemTemplateSelector Property

Gets or sets the DataTemplateSelector to use for day items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector DayItemTemplateSelector { get; set; }
Public Property DayItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for day items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayNameItemContainerStyle Property

MonthCalendarDayNameItemContainerStyle Property

Gets or sets the Style to apply to day name items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style DayNameItemContainerStyle { get; set; }
Public Property DayNameItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to day name items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayNameItemsPanelTemplate Property

MonthCalendarDayNameItemsPanelTemplate Property

Gets or sets the ItemsPanelTemplate to use for arranging day name items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate DayNameItemsPanelTemplate { get; set; }
Public Property DayNameItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging day name items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayNameItemTemplate Property

MonthCalendarDayNameItemTemplate Property

Gets or sets the DataTemplate to use for day name items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DayNameItemTemplate { get; set; }
Public Property DayNameItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for day name items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayOfWeekFormatPattern Property

MonthCalendarDayOfWeekFormatPattern Property

Gets or sets the format pattern used for DayOfWeek values.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DayOfWeekFormatPattern DayOfWeekFormatPattern { get; set; }
Public Property DayOfWeekFormatPattern As DayOfWeekFormatPattern
    Get
    Set

Property Value

Type: DayOfWeekFormatPattern
The format pattern used for DayOfWeek values. The default value is DayOfWeekFormatPattern.AbbreviatedUppercase.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DecadeItemsPanelTemplate Property

MonthCalendarDecadeItemsPanelTemplate Property

Gets or sets the ItemsPanelTemplate to use for arranging decade items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate DecadeItemsPanelTemplate { get; set; }
Public Property DecadeItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging decade items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DecadeItemTemplate Property

MonthCalendarDecadeItemTemplate Property

Gets or sets the DataTemplate to use for decade items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DecadeItemTemplate { get; set; }
Public Property DecadeItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for decade items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DisabledDaysOfWeek Property

MonthCalendarDisabledDaysOfWeek Property

Gets or sets the disabled days of the week.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DaysOfWeek DisabledDaysOfWeek { get; set; }
Public Property DisabledDaysOfWeek As DaysOfWeek
    Get
    Set

Property Value

Type: DaysOfWeek
The disabled days of the week. The default value is DaysOfWeek.None.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.FirstDayOfWeek Property

MonthCalendarFirstDayOfWeek Property

Gets or sets the first day of the week.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<DayOfWeek> FirstDayOfWeek { get; set; }
Public Property FirstDayOfWeek As Nullable(Of DayOfWeek)
    Get
    Set

Property Value

Type: Nullable DayOfWeek
The first day of the week. When set to , the first day of the week is pulled from the current culture. The default value is .
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.GoToNextViewCommand Property

MonthCalendarGoToNextViewCommand Property

Gets the ICommand that is used to go to the next view.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand GoToNextViewCommand { get; }
Public ReadOnly Property GoToNextViewCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to go to the next view.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.GoToPreviousViewCommand Property

MonthCalendarGoToPreviousViewCommand Property

Gets the ICommand that is used to go to the next view.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand GoToPreviousViewCommand { get; }
Public ReadOnly Property GoToPreviousViewCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to go to the next view.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsClearButtonVisible Property

MonthCalendarIsClearButtonVisible Property

Gets or sets whether the clear button is visible.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsClearButtonVisible { get; set; }
Public Property IsClearButtonVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the clear button is visible; otherwise false. The default value is false.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsDateDisabledFunc Property

MonthCalendarIsDateDisabledFunc Property

Gets or sets a function that is called when a day cell is rendered to determine if it should be disabled.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Func<DateTime, bool> IsDateDisabledFunc { get; set; }
Public Property IsDateDisabledFunc As Func(Of DateTime, Boolean)
    Get
    Set

Property Value

Type: Func DateTime, Boolean
A function that is called when a day cell is rendered to determine if it should be disabled.
Remarks
This function is not called for dates that are outside of the Minimum and Maximum range, nor for dates that are disabled by the DisabledDaysOfWeek property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsDayOfWeekSelectionEnabled Property

MonthCalendarIsDayOfWeekSelectionEnabled Property

Gets or sets whether the day of week headers can be used to select dates.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDayOfWeekSelectionEnabled { get; set; }
Public Property IsDayOfWeekSelectionEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the day of week headers can be used to select dates; otherwise false. The default value is true.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsTodayButtonVisible Property

MonthCalendarIsTodayButtonVisible Property

Gets or sets whether the Today button is visible.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTodayButtonVisible { get; set; }
Public Property IsTodayButtonVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Today button is visible; otherwise false. The default value is true.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsTodayHighlighted Property

MonthCalendarIsTodayHighlighted Property

Gets or sets whether DateTime.Today is highlighted.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsTodayHighlighted { get; set; }
Public Property IsTodayHighlighted As Boolean
    Get
    Set

Property Value

Type: Boolean
true if DateTime.Today is highlighted; otherwise false. The default value is true.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsWeekNumberColumnVisible Property

MonthCalendarIsWeekNumberColumnVisible Property

Gets or sets whether the week number column is visible.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsWeekNumberColumnVisible { get; set; }
Public Property IsWeekNumberColumnVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the week number column is visible; otherwise false. The default value is false.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsWeekNumberSelectionEnabled Property

MonthCalendarIsWeekNumberSelectionEnabled Property

Gets or sets whether the week numbers can be used to select dates.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsWeekNumberSelectionEnabled { get; set; }
Public Property IsWeekNumberSelectionEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the week numbers can be used to select dates; otherwise false. The default value is true.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.Maximum Property

MonthCalendarMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MaxSelectionCount Property

MonthCalendarMaxSelectionCount Property

Gets or sets the maximum number of dates that can be selected.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int MaxSelectionCount { get; set; }
Public Property MaxSelectionCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of dates that can be selected. The default value is -1, which indicates no upper limit.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MaxViewMode Property

MonthCalendarMaxViewMode Property

Gets or sets the maximum view mode allowed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MonthCalendarViewMode MaxViewMode { get; set; }
Public Property MaxViewMode As MonthCalendarViewMode
    Get
    Set

Property Value

Type: MonthCalendarViewMode
The maximum view mode allowed. The default value is MonthCalendarViewMode.Century.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace
MonthCalendarActiveViewMode


MonthCalendar.Minimum Property

MonthCalendarMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MonthItemsPanelTemplate Property

MonthCalendarMonthItemsPanelTemplate Property

Gets or sets the ItemsPanelTemplate to use for arranging month items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate MonthItemsPanelTemplate { get; set; }
Public Property MonthItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging month items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MonthItemTemplate Property

MonthCalendarMonthItemTemplate Property

Gets or sets the DataTemplate to use for month items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate MonthItemTemplate { get; set; }
Public Property MonthItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for month items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.NavigationButtonStyle Property

MonthCalendarNavigationButtonStyle Property

Gets or sets the Style to apply to the navigation buttons.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style NavigationButtonStyle { get; set; }
Public Property NavigationButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to the navigation buttons.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectDateCommand Property

MonthCalendarSelectDateCommand Property

Gets the ICommand that is used to select a date.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SelectDateCommand { get; }
Public ReadOnly Property SelectDateCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to select a date.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectDayOfWeekCommand Property

MonthCalendarSelectDayOfWeekCommand Property

Gets the ICommand that is used to select an entire day of week.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SelectDayOfWeekCommand { get; }
Public ReadOnly Property SelectDayOfWeekCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to select an entire day of week.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectedDate Property

MonthCalendarSelectedDate Property

Gets or sets the selected date, if any, in the calendar.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<DateTime> SelectedDate { get; set; }
Public Property SelectedDate As Nullable(Of DateTime)
    Get
    Set

Property Value

Type: Nullable DateTime
The selected date, if any, in the calendar.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectedDates Property

MonthCalendarSelectedDates Property

Gets the currently-selected dates in the calendar.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateRangeCollection SelectedDates { get; }
Public ReadOnly Property SelectedDates As DateRangeCollection
    Get

Property Value

Type: DateRangeCollection
The currently-selected dates in the calendar.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectionMode Property

MonthCalendarSelectionMode Property

Gets or sets the selection mode of the calendar.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MonthCalendarSelectionMode SelectionMode { get; set; }
Public Property SelectionMode As MonthCalendarSelectionMode
    Get
    Set

Property Value

Type: MonthCalendarSelectionMode
The selection mode of the calendar. The default value is MonthCalendarSelectionMode.Single.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectTodayCommand Property

MonthCalendarSelectTodayCommand Property

Gets the ICommand that is used to select today's date.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SelectTodayCommand { get; }
Public ReadOnly Property SelectTodayCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to select today's date.
Remarks
This command calls the SelectToday method.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectWeekCommand Property

MonthCalendarSelectWeekCommand Property

Gets the ICommand that is used to select an entire week.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SelectWeekCommand { get; }
Public ReadOnly Property SelectWeekCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to select an entire week.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.Title Property

MonthCalendarTitle Property

Gets the title that is displayed for the active view.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get

Property Value

Type: String
The title that is displayed for the active view.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.TitleButtonStyle Property

MonthCalendarTitleButtonStyle Property

Gets or sets the Style to apply to the title button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TitleButtonStyle { get; set; }
Public Property TitleButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to the title button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.TodayButtonStyle Property

MonthCalendarTodayButtonStyle Property

Gets or sets the Style to apply to the Today button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style TodayButtonStyle { get; set; }
Public Property TodayButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to the Today button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.TodayButtonText Property

MonthCalendarTodayButtonText Property

Gets the text to display in the Today button.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TodayButtonText { get; }
Public ReadOnly Property TodayButtonText As String
    Get

Property Value

Type: String
The text to display in the Today button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ViewResetMode Property

MonthCalendarViewResetMode Property

Gets or sets the view reset mode, which can be used to reset the view when the calendar loses focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MonthCalendarViewResetMode ViewResetMode { get; set; }
Public Property ViewResetMode As MonthCalendarViewResetMode
    Get
    Set

Property Value

Type: MonthCalendarViewResetMode
The view reset mode, which can be used to reset the view when the calendar loses focus. The default value is MonthCalendarViewResetMode.None.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.WeekNumberItemContainerStyle Property

MonthCalendarWeekNumberItemContainerStyle Property

Gets or sets the Style to apply to week number items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style WeekNumberItemContainerStyle { get; set; }
Public Property WeekNumberItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to week number items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.WeekNumberItemsPanelTemplate Property

MonthCalendarWeekNumberItemsPanelTemplate Property

Gets or sets the ItemsPanelTemplate to use for arranging week number items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate WeekNumberItemsPanelTemplate { get; set; }
Public Property WeekNumberItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging week number items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.WeekNumberItemTemplate Property

MonthCalendarWeekNumberItemTemplate Property

Gets or sets the DataTemplate to use for week number items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate WeekNumberItemTemplate { get; set; }
Public Property WeekNumberItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for week number items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.YearItemsPanelTemplate Property

MonthCalendarYearItemsPanelTemplate Property

Gets or sets the ItemsPanelTemplate to use for arranging year items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate YearItemsPanelTemplate { get; set; }
Public Property YearItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging year items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.YearItemTemplate Property

MonthCalendarYearItemTemplate Property

Gets or sets the DataTemplate to use for year items.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate YearItemTemplate { get; set; }
Public Property YearItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for year items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ZoomInCommand Property

MonthCalendarZoomInCommand Property

Gets the ICommand that is used to zoom in.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ZoomInCommand { get; }
Public ReadOnly Property ZoomInCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to zoom in.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ZoomOutCommand Property

MonthCalendarZoomOutCommand Property

Gets the ICommand that is used to zoom out.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ZoomOutCommand { get; }
Public ReadOnly Property ZoomOutCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to zoom out.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar Methods

The MonthCalendar type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Refreshes the control.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectToday | Selects today's date.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDayItem | Updates a MonthCalendarItem for the specified day.
Protected method | UpdateDayNameItem | Updates a MonthCalendarItem for the specified day of week.
Protected method | UpdateDecadeItem | Updates a MonthCalendarItem for the specified decade.
Protected method | UpdateMonthItem | Updates a MonthCalendarItem for the specified month.
Protected method | UpdateWeekNumberItem | Updates a MonthCalendarItem for the specified week number.
Protected method | UpdateYearItem | Updates a MonthCalendarItem for the specified year.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.OnApplyTemplate Method

MonthCalendarOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.OnCreateAutomationPeer Method

MonthCalendarOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.OnIsKeyboardFocusWithinChanged Method

MonthCalendarOnIsKeyboardFocusWithinChanged Method

Occurs when the property value has changed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs containing data related to this event.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.OnKeyDown Method

MonthCalendarOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.Refresh Method

MonthCalendarRefresh Method

Refreshes the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Refresh(
    bool requiresNewView
)
Public Sub Refresh (
    requiresNewView As Boolean
)

Parameters

requiresNewView
Type: SystemBoolean
Whether a new view is required (if UI elements are changing instead of only simple data).
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectToday Method

MonthCalendarSelectToday Method

Selects today's date.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SelectToday()
Public Sub SelectToday
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.UpdateDayItem Method

MonthCalendarUpdateDayItem Method

Updates a MonthCalendarItem for the specified day.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateDayItem(
    MonthCalendarItem item,
    DateTime date
)
Protected Overridable Sub UpdateDayItem (
    item As MonthCalendarItem,
    date As DateTime
)

Parameters

item
Type: ActiproSoftware.Windows.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
date
Type: SystemDateTime
The date for which to update the model.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.UpdateDayNameItem Method

MonthCalendarUpdateDayNameItem Method

Updates a MonthCalendarItem for the specified day of week.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateDayNameItem(
    MonthCalendarItem item,
    DayOfWeek dayOfWeek
)
Protected Overridable Sub UpdateDayNameItem (
    item As MonthCalendarItem,
    dayOfWeek As DayOfWeek
)

Parameters

item
Type: ActiproSoftware.Windows.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
dayOfWeek
Type: SystemDayOfWeek
The upated day of week.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.UpdateDecadeItem Method

MonthCalendarUpdateDecadeItem Method

Updates a MonthCalendarItem for the specified decade.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateDecadeItem(
    MonthCalendarItem item,
    DateTime date
)
Protected Overridable Sub UpdateDecadeItem (
    item As MonthCalendarItem,
    date As DateTime
)

Parameters

item
Type: ActiproSoftware.Windows.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
date
Type: SystemDateTime
The date for which to update the model.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.UpdateMonthItem Method

MonthCalendarUpdateMonthItem Method

Updates a MonthCalendarItem for the specified month.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateMonthItem(
    MonthCalendarItem item,
    DateTime date
)
Protected Overridable Sub UpdateMonthItem (
    item As MonthCalendarItem,
    date As DateTime
)

Parameters

item
Type: ActiproSoftware.Windows.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
date
Type: SystemDateTime
The date for which to update the model.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.UpdateWeekNumberItem Method

MonthCalendarUpdateWeekNumberItem Method

Updates a MonthCalendarItem for the specified week number.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateWeekNumberItem(
    MonthCalendarItem item,
    int weekNumber
)
Protected Overridable Sub UpdateWeekNumberItem (
    item As MonthCalendarItem,
    weekNumber As Integer
)

Parameters

item
Type: ActiproSoftware.Windows.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
weekNumber
Type: SystemInt32
The updated week number.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.UpdateYearItem Method

MonthCalendarUpdateYearItem Method

Updates a MonthCalendarItem for the specified year.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateYearItem(
    MonthCalendarItem item,
    DateTime date
)
Protected Overridable Sub UpdateYearItem (
    item As MonthCalendarItem,
    date As DateTime
)

Parameters

item
Type: ActiproSoftware.Windows.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
date
Type: SystemDateTime
The date for which to update the model.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar Events

The MonthCalendar type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs after the SelectedDate property value and/or SelectedDates collection changes.
Public event | SelectionCommitted | Occurs when the selection is committed, either by pressing Enter or clicking on a date value in single selection mode.
Top
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectionChanged Event

MonthCalendarSelectionChanged Event

Occurs after the SelectedDate property value and/or SelectedDates collection changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectionCommitted Event

MonthCalendarSelectionCommitted Event

Occurs when the selection is committed, either by pressing Enter or clicking on a date value in single selection mode.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler SelectionCommitted
Public Event SelectionCommitted As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar Fields

The MonthCalendar type exposes the following members.

Fields
Name | Description
ActiveDateProperty | Identifies the ActiveDate dependency property. This field is read-only.
ActiveViewModeProperty | Identifies the ActiveViewMode dependency property. This field is read-only.
CalendarWeekRuleProperty | Identifies the CalendarWeekRule dependency property. This field is read-only.
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
ClearButtonStyleProperty | Identifies the ClearButtonStyle dependency property. This field is read-only.
ClearButtonTextProperty | Identifies the ClearButtonText dependency property. This field is read-only.
DayItemsPanelTemplateProperty | Identifies the DayItemsPanelTemplate dependency property. This field is read-only.
DayItemTemplateProperty | Identifies the DayItemTemplate dependency property. This field is read-only.
DayItemTemplateSelectorProperty | Identifies the DayItemTemplateSelector dependency property. This field is read-only.
DayNameItemContainerStyleProperty | Identifies the DayNameItemContainerStyle dependency property. This field is read-only.
DayNameItemsPanelTemplateProperty | Identifies the DayNameItemsPanelTemplate dependency property. This field is read-only.
DayNameItemTemplateProperty | Identifies the DayNameItemTemplate dependency property. This field is read-only.
DayOfWeekFormatPatternProperty | Identifies the DayOfWeekFormatPattern dependency property. This field is read-only.
DecadeItemsPanelTemplateProperty | Identifies the DecadeItemsPanelTemplate dependency property. This field is read-only.
DecadeItemTemplateProperty | Identifies the DecadeItemTemplate dependency property. This field is read-only.
DisabledDaysOfWeekProperty | Identifies the DisabledDaysOfWeek dependency property. This field is read-only.
FirstDayOfWeekProperty | Identifies the FirstDayOfWeek dependency property. This field is read-only.
IsClearButtonVisibleProperty | Identifies the IsClearButtonVisible dependency property. This field is read-only.
IsDateDisabledFuncProperty | Identifies the IsDateDisabledFunc dependency property. This field is read-only.
IsDayOfWeekSelectionEnabledProperty | Identifies the IsDayOfWeekSelectionEnabled dependency property. This field is read-only.
IsTodayButtonVisibleProperty | Identifies the IsTodayButtonVisible dependency property. This field is read-only.
IsTodayHighlightedProperty | Identifies the IsTodayHighlighted dependency property. This field is read-only.
IsWeekNumberColumnVisibleProperty | Identifies the IsWeekNumberColumnVisible dependency property. This field is read-only.
IsWeekNumberSelectionEnabledProperty | Identifies the IsWeekNumberSelectionEnabled dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MaxSelectionCountProperty | Identifies the MaxSelectionCount dependency property. This field is read-only.
MaxViewModeProperty | Identifies the MaxViewMode dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MonthItemsPanelTemplateProperty | Identifies the MonthItemsPanelTemplate dependency property. This field is read-only.
MonthItemTemplateProperty | Identifies the MonthItemTemplate dependency property. This field is read-only.
NavigationButtonStyleProperty | Identifies the NavigationButtonStyle dependency property. This field is read-only.
SelectedDateProperty | Identifies the SelectedDate dependency property. This field is read-only.
SelectionModeProperty | Identifies the SelectionMode dependency property. This field is read-only.
TitleButtonStyleProperty | Identifies the TitleButtonStyle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TodayButtonStyleProperty | Identifies the TodayButtonStyle dependency property. This field is read-only.
TodayButtonTextProperty | Identifies the TodayButtonText dependency property. This field is read-only.
ViewResetModeProperty | Identifies the ViewResetMode dependency property. This field is read-only.
WeekNumberItemContainerStyleProperty | Identifies the WeekNumberItemContainerStyle dependency property. This field is read-only.
WeekNumberItemsPanelTemplateProperty | Identifies the WeekNumberItemsPanelTemplate dependency property. This field is read-only.
WeekNumberItemTemplateProperty | Identifies the WeekNumberItemTemplate dependency property. This field is read-only.
YearItemsPanelTemplateProperty | Identifies the YearItemsPanelTemplate dependency property. This field is read-only.
YearItemTemplateProperty | Identifies the YearItemTemplate dependency property. This field is read-only.
Top
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ActiveDateProperty Field

MonthCalendarActiveDateProperty Field

Identifies the ActiveDate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveDateProperty
Public Shared ReadOnly ActiveDateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveDate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ActiveViewModeProperty Field

MonthCalendarActiveViewModeProperty Field

Identifies the ActiveViewMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveViewModeProperty
Public Shared ReadOnly ActiveViewModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveViewMode dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.CalendarWeekRuleProperty Field

MonthCalendarCalendarWeekRuleProperty Field

Identifies the CalendarWeekRule dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalendarWeekRuleProperty
Public Shared ReadOnly CalendarWeekRuleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalendarWeekRule dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.CanRetainTimeProperty Field

MonthCalendarCanRetainTimeProperty Field

Identifies the CanRetainTime dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRetainTimeProperty
Public Shared ReadOnly CanRetainTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRetainTime dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ClearButtonStyleProperty Field

MonthCalendarClearButtonStyleProperty Field

Identifies the ClearButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClearButtonStyleProperty
Public Shared ReadOnly ClearButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ClearButtonStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ClearButtonTextProperty Field

MonthCalendarClearButtonTextProperty Field

Identifies the ClearButtonText dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClearButtonTextProperty
Public Shared ReadOnly ClearButtonTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ClearButtonText dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayItemsPanelTemplateProperty Field

MonthCalendarDayItemsPanelTemplateProperty Field

Identifies the DayItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayItemsPanelTemplateProperty
Public Shared ReadOnly DayItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayItemTemplateProperty Field

MonthCalendarDayItemTemplateProperty Field

Identifies the DayItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayItemTemplateProperty
Public Shared ReadOnly DayItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayItemTemplateSelectorProperty Field

MonthCalendarDayItemTemplateSelectorProperty Field

Identifies the DayItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayItemTemplateSelectorProperty
Public Shared ReadOnly DayItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayItemTemplateSelector dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayNameItemContainerStyleProperty Field

MonthCalendarDayNameItemContainerStyleProperty Field

Identifies the DayNameItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayNameItemContainerStyleProperty
Public Shared ReadOnly DayNameItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayNameItemContainerStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayNameItemsPanelTemplateProperty Field

MonthCalendarDayNameItemsPanelTemplateProperty Field

Identifies the DayNameItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayNameItemsPanelTemplateProperty
Public Shared ReadOnly DayNameItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayNameItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayNameItemTemplateProperty Field

MonthCalendarDayNameItemTemplateProperty Field

Identifies the DayNameItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayNameItemTemplateProperty
Public Shared ReadOnly DayNameItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayNameItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DayOfWeekFormatPatternProperty Field

MonthCalendarDayOfWeekFormatPatternProperty Field

Identifies the DayOfWeekFormatPattern dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayOfWeekFormatPatternProperty
Public Shared ReadOnly DayOfWeekFormatPatternProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayOfWeekFormatPattern dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DecadeItemsPanelTemplateProperty Field

MonthCalendarDecadeItemsPanelTemplateProperty Field

Identifies the DecadeItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DecadeItemsPanelTemplateProperty
Public Shared ReadOnly DecadeItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DecadeItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DecadeItemTemplateProperty Field

MonthCalendarDecadeItemTemplateProperty Field

Identifies the DecadeItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DecadeItemTemplateProperty
Public Shared ReadOnly DecadeItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DecadeItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.DisabledDaysOfWeekProperty Field

MonthCalendarDisabledDaysOfWeekProperty Field

Identifies the DisabledDaysOfWeek dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisabledDaysOfWeekProperty
Public Shared ReadOnly DisabledDaysOfWeekProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisabledDaysOfWeek dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.FirstDayOfWeekProperty Field

MonthCalendarFirstDayOfWeekProperty Field

Identifies the FirstDayOfWeek dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FirstDayOfWeekProperty
Public Shared ReadOnly FirstDayOfWeekProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FirstDayOfWeek dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsClearButtonVisibleProperty Field

MonthCalendarIsClearButtonVisibleProperty Field

Identifies the IsClearButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsClearButtonVisibleProperty
Public Shared ReadOnly IsClearButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsClearButtonVisible dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsDateDisabledFuncProperty Field

MonthCalendarIsDateDisabledFuncProperty Field

Identifies the IsDateDisabledFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDateDisabledFuncProperty
Public Shared ReadOnly IsDateDisabledFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDateDisabledFunc dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsDayOfWeekSelectionEnabledProperty Field

MonthCalendarIsDayOfWeekSelectionEnabledProperty Field

Identifies the IsDayOfWeekSelectionEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDayOfWeekSelectionEnabledProperty
Public Shared ReadOnly IsDayOfWeekSelectionEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDayOfWeekSelectionEnabled dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsTodayButtonVisibleProperty Field

MonthCalendarIsTodayButtonVisibleProperty Field

Identifies the IsTodayButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTodayButtonVisibleProperty
Public Shared ReadOnly IsTodayButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTodayButtonVisible dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsTodayHighlightedProperty Field

MonthCalendarIsTodayHighlightedProperty Field

Identifies the IsTodayHighlighted dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTodayHighlightedProperty
Public Shared ReadOnly IsTodayHighlightedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTodayHighlighted dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsWeekNumberColumnVisibleProperty Field

MonthCalendarIsWeekNumberColumnVisibleProperty Field

Identifies the IsWeekNumberColumnVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsWeekNumberColumnVisibleProperty
Public Shared ReadOnly IsWeekNumberColumnVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsWeekNumberColumnVisible dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.IsWeekNumberSelectionEnabledProperty Field

MonthCalendarIsWeekNumberSelectionEnabledProperty Field

Identifies the IsWeekNumberSelectionEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsWeekNumberSelectionEnabledProperty
Public Shared ReadOnly IsWeekNumberSelectionEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsWeekNumberSelectionEnabled dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MaximumProperty Field

MonthCalendarMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MaxSelectionCountProperty Field

MonthCalendarMaxSelectionCountProperty Field

Identifies the MaxSelectionCount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxSelectionCountProperty
Public Shared ReadOnly MaxSelectionCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxSelectionCount dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MaxViewModeProperty Field

MonthCalendarMaxViewModeProperty Field

Identifies the MaxViewMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxViewModeProperty
Public Shared ReadOnly MaxViewModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxViewMode dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MinimumProperty Field

MonthCalendarMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MonthItemsPanelTemplateProperty Field

MonthCalendarMonthItemsPanelTemplateProperty Field

Identifies the MonthItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MonthItemsPanelTemplateProperty
Public Shared ReadOnly MonthItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MonthItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.MonthItemTemplateProperty Field

MonthCalendarMonthItemTemplateProperty Field

Identifies the MonthItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MonthItemTemplateProperty
Public Shared ReadOnly MonthItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MonthItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.NavigationButtonStyleProperty Field

MonthCalendarNavigationButtonStyleProperty Field

Identifies the NavigationButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NavigationButtonStyleProperty
Public Shared ReadOnly NavigationButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NavigationButtonStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectedDateProperty Field

MonthCalendarSelectedDateProperty Field

Identifies the SelectedDate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedDateProperty
Public Shared ReadOnly SelectedDateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedDate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.SelectionModeProperty Field

MonthCalendarSelectionModeProperty Field

Identifies the SelectionMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionModeProperty
Public Shared ReadOnly SelectionModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionMode dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.TitleButtonStyleProperty Field

MonthCalendarTitleButtonStyleProperty Field

Identifies the TitleButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleButtonStyleProperty
Public Shared ReadOnly TitleButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleButtonStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.TitleProperty Field

MonthCalendarTitleProperty Field

Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.TodayButtonStyleProperty Field

MonthCalendarTodayButtonStyleProperty Field

Identifies the TodayButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TodayButtonStyleProperty
Public Shared ReadOnly TodayButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TodayButtonStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.TodayButtonTextProperty Field

MonthCalendarTodayButtonTextProperty Field

Identifies the TodayButtonText dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TodayButtonTextProperty
Public Shared ReadOnly TodayButtonTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TodayButtonText dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.ViewResetModeProperty Field

MonthCalendarViewResetModeProperty Field

Identifies the ViewResetMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ViewResetModeProperty
Public Shared ReadOnly ViewResetModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ViewResetMode dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.WeekNumberItemContainerStyleProperty Field

MonthCalendarWeekNumberItemContainerStyleProperty Field

Identifies the WeekNumberItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WeekNumberItemContainerStyleProperty
Public Shared ReadOnly WeekNumberItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WeekNumberItemContainerStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.WeekNumberItemsPanelTemplateProperty Field

MonthCalendarWeekNumberItemsPanelTemplateProperty Field

Identifies the WeekNumberItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WeekNumberItemsPanelTemplateProperty
Public Shared ReadOnly WeekNumberItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WeekNumberItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.WeekNumberItemTemplateProperty Field

MonthCalendarWeekNumberItemTemplateProperty Field

Identifies the WeekNumberItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WeekNumberItemTemplateProperty
Public Shared ReadOnly WeekNumberItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WeekNumberItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.YearItemsPanelTemplateProperty Field

MonthCalendarYearItemsPanelTemplateProperty Field

Identifies the YearItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YearItemsPanelTemplateProperty
Public Shared ReadOnly YearItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YearItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendar.YearItemTemplateProperty Field

MonthCalendarYearItemTemplateProperty Field

Identifies the YearItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YearItemTemplateProperty
Public Shared ReadOnly YearItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YearItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem Class

Represents a month calendar item.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.EditorsMonthCalendarItem

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MonthCalendarItem : ContentControl
Public Class MonthCalendarItem
    Inherits ContentControl

The MonthCalendarItem type exposes the following members.

Constructors
 | Name | Description
Public method | MonthCalendarItem | Initializes a new instance of the MonthCalendarItem class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Command | Gets or sets the ICommand to execute when the item is tapped.
Public property | CommandParameter | Gets or sets the ICommand parameter to pass when the item is tapped.
Public property | ContainsToday | Gets or sets a value indicating whether the item contains DateTime.Today.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Date | Gets the date associated with this item.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHeader | Gets or sets whether the item is a header and shouldn't show visual state highlights.
Public property | IsInactive | Gets or sets whether the item is outside of the active view.
Public property | IsPressed | Gets whether the item is pressed.
Public property | IsSelected | Gets or sets whether the item is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CommandParameterProperty | Identifies the CommandParameter dependency property. This field is read-only.
CommandProperty | Identifies the Command dependency property. This field is read-only.
ContainsTodayProperty | Identifies the ContainsToday dependency property. This field is read-only.
IsHeaderProperty | Identifies the IsHeader dependency property. This field is read-only.
IsInactiveProperty | Identifies the IsInactive dependency property. This field is read-only.
IsPressedProperty | Identifies the IsPressed dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem Constructor

Initializes a new instance of the MonthCalendarItem class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MonthCalendarItem()
Public Sub New
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem Properties

The MonthCalendarItem type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Command | Gets or sets the ICommand to execute when the item is tapped.
Public property | CommandParameter | Gets or sets the ICommand parameter to pass when the item is tapped.
Public property | ContainsToday | Gets or sets a value indicating whether the item contains DateTime.Today.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Date | Gets the date associated with this item.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHeader | Gets or sets whether the item is a header and shouldn't show visual state highlights.
Public property | IsInactive | Gets or sets whether the item is outside of the active view.
Public property | IsPressed | Gets whether the item is pressed.
Public property | IsSelected | Gets or sets whether the item is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.Command Property

MonthCalendarItemCommand Property

Gets or sets the ICommand to execute when the item is tapped.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand Command { get; set; }
Public Property Command As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand to execute when the item is tapped.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.CommandParameter Property

MonthCalendarItemCommandParameter Property

Gets or sets the ICommand parameter to pass when the item is tapped.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object CommandParameter { get; set; }
Public Property CommandParameter As Object
    Get
    Set

Property Value

Type: Object
The ICommand parameter to pass when the item is tapped.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.ContainsToday Property

MonthCalendarItemContainsToday Property

Gets or sets a value indicating whether the item contains DateTime.Today.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ContainsToday { get; set; }
Public Property ContainsToday As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item contains DateTime.Today; otherwise false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.Date Property

MonthCalendarItemDate Property

Gets the date associated with this item.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<DateTime> Date { get; }
Public ReadOnly Property Date As Nullable(Of DateTime)
    Get

Property Value

Type: Nullable DateTime
The date associated with this item.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.IsHeader Property

MonthCalendarItemIsHeader Property

Gets or sets whether the item is a header and shouldn't show visual state highlights.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsHeader { get; set; }
Public Property IsHeader As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is a header and shouldn't show visual state highlights; otherwise, false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.IsInactive Property

MonthCalendarItemIsInactive Property

Gets or sets whether the item is outside of the active view.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsInactive { get; set; }
Public Property IsInactive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is outside of the active view; otherwise, false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.IsPressed Property

MonthCalendarItemIsPressed Property

Gets whether the item is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPressed { get; }
Public ReadOnly Property IsPressed As Boolean
    Get

Property Value

Type: Boolean
true if the item is pressed; otherwise, false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.IsSelected Property

MonthCalendarItemIsSelected Property

Gets or sets whether the item is selected.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is selected; otherwise, false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem Methods

The MonthCalendarItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.OnApplyTemplate Method

MonthCalendarItemOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.OnGotFocus Method

MonthCalendarItemOnGotFocus Method

Occurs when the control gains focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.OnKeyDown Method

MonthCalendarItemOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.OnLostFocus Method

MonthCalendarItemOnLostFocus Method

Occurs when the control loses focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem Events

The MonthCalendarItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem Fields

The MonthCalendarItem type exposes the following members.

Fields
Name | Description
CommandParameterProperty | Identifies the CommandParameter dependency property. This field is read-only.
CommandProperty | Identifies the Command dependency property. This field is read-only.
ContainsTodayProperty | Identifies the ContainsToday dependency property. This field is read-only.
IsHeaderProperty | Identifies the IsHeader dependency property. This field is read-only.
IsInactiveProperty | Identifies the IsInactive dependency property. This field is read-only.
IsPressedProperty | Identifies the IsPressed dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.CommandParameterProperty Field

MonthCalendarItemCommandParameterProperty Field

Identifies the CommandParameter dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CommandParameterProperty
Public Shared ReadOnly CommandParameterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CommandParameter dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.CommandProperty Field

MonthCalendarItemCommandProperty Field

Identifies the Command dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CommandProperty
Public Shared ReadOnly CommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Command dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.ContainsTodayProperty Field

MonthCalendarItemContainsTodayProperty Field

Identifies the ContainsToday dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainsTodayProperty
Public Shared ReadOnly ContainsTodayProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainsToday dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.IsHeaderProperty Field

MonthCalendarItemIsHeaderProperty Field

Identifies the IsHeader dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHeaderProperty
Public Shared ReadOnly IsHeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHeader dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.IsInactiveProperty Field

MonthCalendarItemIsInactiveProperty Field

Identifies the IsInactive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsInactiveProperty
Public Shared ReadOnly IsInactiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsInactive dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.IsPressedProperty Field

MonthCalendarItemIsPressedProperty Field

Identifies the IsPressed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPressedProperty
Public Shared ReadOnly IsPressedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPressed dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarItem.IsSelectedProperty Field

MonthCalendarItemIsSelectedProperty Field

Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarSelectionMode Enumeration

Specifies the various selection modes of a MonthCalendar.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MonthCalendarSelectionMode
Public Enumeration MonthCalendarSelectionMode
Members
Member name | Value | Description
Single | 0 | Indicates that only one item can be selected.
Multiple | 1 | Indicates that multiple items can be selected, without holding down a modifier key.
Extended | 2 | Indicates that multiple items can be selected by holding down a modifier key (e.g. Control and/or Shift).
Range | 3 | Indicates that multiple items can be selected by holding down a modifier key (e.g. Control and/or Shift), but must be in a contiguous range.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarViewMode Enumeration

Specifies the various views of a MonthCalendar.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MonthCalendarViewMode
Public Enumeration MonthCalendarViewMode
Members
Member name | Value | Description
Month | 0 | Indicates that the calendar will present a month view.
Year | 1 | Indicates that the calendar will present a year view.
Decade | 2 | Indicates that the calendar will present a decade view.
Century | 3 | Indicates that the calendar will present a century view.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


MonthCalendarViewResetMode Enumeration

Specifies the view reset mode of a MonthCalendar when it loses focus.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MonthCalendarViewResetMode
Public Enumeration MonthCalendarViewResetMode
Members
Member name | Value | Description
None | 0 | Indicates that the calendar view will not be reset.
Today | 1 | Indicates that the calendar view will be zoomed into the month view that contains DateTime.Today.
Active | 2 | Indicates that the calendar view will be zoomed into the month view that contains the active date.
FirstSelected | 3 | Indicates that the calendar view will be zoomed into the month view that contains the first selected date.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxCommitTriggers Enumeration

Specifies the triggers that force a PartEditBoxBase-derived control to immediately commit any changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PartEditBoxCommitTriggers
Public Enumeration PartEditBoxCommitTriggers
Members
Member name | Value | Description
None | 0 | Indicates that changes will only be committed when the control loses focus.
EnterKeyDown | 1 | Indicates that changes made will be committed when the Enter key is pressed. Other changes will only be committed when the control loses focus.
SpinnerChange | 2 | Indicates that changes made using an associated Spinner will be committed immediately. Other changes will only be committed when the control loses focus.
ActivePartChange | 4 | Indicates that changes will be committed when the active part changes. Other changes will only be committed when the control loses focus.
StringValueChange | 8 | Indicates that changes will be committed immediately when typing and other text edits occur. Other changes will only be committed when the control loses focus.
All | 15 | Indicates that changes will be always be committed immediately.
Default | 3 | Indicates that changes made using an associated Spinner will be committed immediately. Other changes will only be committed when the control loses focus or when the Enter key is pressed. This is the same as EnterKeyDown | SpinnerChange.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxInline Class

Represents an inline UI element within a PartEditBoxBase-derived control.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.EditorsPartEditBoxInline

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PartEditBoxInline
Public Class PartEditBoxInline

The PartEditBoxInline type exposes the following members.

Constructors
 | Name | Description
Public method | PartEditBoxInline | Initializes a new instance of the PartEditBoxInline class
Top
Properties
 | Name | Description
Public property | ContentTemplate | Gets or sets the DataTemplate to use for rendering the UI of the inline.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxInline Constructor

Initializes a new instance of the PartEditBoxInline class

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PartEditBoxInline()
Public Sub New
See Also

Reference

PartEditBoxInline Class
ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxInline Properties

The PartEditBoxInline type exposes the following members.

Properties
 | Name | Description
Public property | ContentTemplate | Gets or sets the DataTemplate to use for rendering the UI of the inline.
Top
See Also

Reference

PartEditBoxInline Class
ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxInline.ContentTemplate Property

PartEditBoxInlineContentTemplate Property

Gets or sets the DataTemplate to use for rendering the UI of the inline.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ContentTemplate { get; set; }
Public Property ContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for rendering the UI of the inline.
See Also

Reference

PartEditBoxInline Class
ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxInlineCollection Class

Represents a collection of PartEditBoxInline objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection PartEditBoxInline
System.Collections.ObjectModelObservableCollection PartEditBoxInline
ActiproSoftware.Windows.Controls.EditorsPartEditBoxInlineCollection

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PartEditBoxInlineCollection : ObservableCollection<PartEditBoxInline>
Public Class PartEditBoxInlineCollection
    Inherits ObservableCollection(Of PartEditBoxInline)

The PartEditBoxInlineCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PartEditBoxInlineCollection | Initializes a new instance of the PartEditBoxInlineCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection PartEditBoxInline .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection PartEditBoxInline .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection PartEditBoxInline .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection PartEditBoxInline .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection PartEditBoxInline .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection PartEditBoxInline .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection PartEditBoxInline .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection PartEditBoxInline .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection PartEditBoxInline .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection PartEditBoxInline .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection PartEditBoxInline .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection PartEditBoxInline .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection PartEditBoxInline .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection PartEditBoxInline .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection PartEditBoxInline .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection PartEditBoxInline .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection PartEditBoxInline .)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection PartEditBoxInline .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection PartEditBoxInline .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxInlineCollection Constructor

Initializes a new instance of the PartEditBoxInlineCollection class

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PartEditBoxInlineCollection()
Public Sub New
See Also

Reference

PartEditBoxInlineCollection Class
ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxInlineCollection Properties

The PartEditBoxInlineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection PartEditBoxInline .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection PartEditBoxInline .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection PartEditBoxInline .)
Top
See Also

Reference

PartEditBoxInlineCollection Class
ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxInlineCollection Methods

The PartEditBoxInlineCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection PartEditBoxInline .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection PartEditBoxInline .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection PartEditBoxInline .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection PartEditBoxInline .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection PartEditBoxInline .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection PartEditBoxInline .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection PartEditBoxInline .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection PartEditBoxInline .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection PartEditBoxInline .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection PartEditBoxInline .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection PartEditBoxInline .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection PartEditBoxInline .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection PartEditBoxInline .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection PartEditBoxInline .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection PartEditBoxInline .)
Top
See Also

Reference

PartEditBoxInlineCollection Class
ActiproSoftware.Windows.Controls.Editors Namespace


PartEditBoxInlineCollection Events

The PartEditBoxInlineCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection PartEditBoxInline .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection PartEditBoxInline .)
Top
See Also

Reference

PartEditBoxInlineCollection Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox Class

Represents a Point edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Point
ActiproSoftware.Windows.Controls.EditorsPointEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PointEditBox : PartEditBoxBase<Nullable<Point>>
Public Class PointEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Point))

The PointEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | PointEditBox | Initializes an instance of the PointEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox Constructor

Initializes an instance of the PointEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointEditBox()
Public Sub New
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox Properties

The PointEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.DefaultValue Property

PointEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point DefaultValue { get; set; }
Public Property DefaultValue As Point
    Get
    Set

Property Value

Type: Point
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.Format Property

PointEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.IsNaNAllowed Property

PointEditBoxIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.IsNegativeInfinityAllowed Property

PointEditBoxIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.IsPositiveInfinityAllowed Property

PointEditBoxIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.LargeChange Property

PointEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point LargeChange { get; set; }
Public Property LargeChange As Point
    Get
    Set

Property Value

Type: Point
The large change value. The default value is 5.0.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.Maximum Property

PointEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point Maximum { get; set; }
Public Property Maximum As Point
    Get
    Set

Property Value

Type: Point
The highest possible value.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.Minimum Property

PointEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point Minimum { get; set; }
Public Property Minimum As Point
    Get
    Set

Property Value

Type: Point
The lowest possible value.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.ResolvedFormat Property

PointEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.RoundingDecimalPlace Property

PointEditBoxRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.SmallChange Property

PointEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point SmallChange { get; set; }
Public Property SmallChange As Point
    Get
    Set

Property Value

Type: Point
The small change value. The default value is 1.0.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox Methods

The PointEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.CoerceValidValue Method

PointEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Point> CoerceValidValue(
    Nullable<Point> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Point)
) As Nullable(Of Point)

Parameters

value
Type: SystemNullable Point
The value to coerce.

Return Value

Type: Nullable Point
The coerced value.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.ConvertToString Method

PointEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Point> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Point)
) As String

Parameters

valueToConvert
Type: SystemNullable Point
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.CreateIncrementalChangeRequest Method

PointEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Point>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Point))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Point
The incremental change (spin) request that was created.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.GenerateParts Method

PointEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.IsValidValue Method

PointEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Point> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Point)
) As Boolean

Parameters

value
Type: SystemNullable Point
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.ProcessTextInput Method

PointEditBoxProcessTextInput Method

Processes typed text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.RaiseValueChangedEvent Method

PointEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.ResetValue Method

PointEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.TryConvertFromString Method

PointEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Point> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Point)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Point
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox Events

The PointEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.ValueChanged Event

PointEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox Fields

The PointEditBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.DefaultValueProperty Field

PointEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.FormatProperty Field

PointEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.IsNaNAllowedProperty Field

PointEditBoxIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.IsNegativeInfinityAllowedProperty Field

PointEditBoxIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.IsPositiveInfinityAllowedProperty Field

PointEditBoxIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.LargeChangeProperty Field

PointEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.MaximumProperty Field

PointEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.MinimumProperty Field

PointEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.ResolvedFormatProperty Field

PointEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.RoundingDecimalPlaceProperty Field

PointEditBoxRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointEditBox.SmallChangeProperty Field

PointEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker Class

Represents a Point picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsPointPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PointPicker : PickerBase
Public Class PointPicker
    Inherits PickerBase

The PointPicker type exposes the following members.

Constructors
 | Name | Description
Public method | PointPicker | Initializes an instance of the PointPicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker Constructor

Initializes an instance of the PointPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointPicker()
Public Sub New
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker Properties

The PointPicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.Maximum Property

PointPickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point Maximum { get; set; }
Public Property Maximum As Point
    Get
    Set

Property Value

Type: Point
The highest possible value.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.Minimum Property

PointPickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point Minimum { get; set; }
Public Property Minimum As Point
    Get
    Set

Property Value

Type: Point
The lowest possible value.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.RoundingDecimalPlace Property

PointPickerRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.SmallChange Property

PointPickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point SmallChange { get; set; }
Public Property SmallChange As Point
    Get
    Set

Property Value

Type: Point
The small change value. The default value is 1.0.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.Value Property

PointPickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point Value { get; set; }
Public Property Value As Point
    Get
    Set

Property Value

Type: Point
The value of the control.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker Methods

The PointPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.OnApplyTemplate Method

PointPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker Events

The PointPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.ValueChanged Event

PointPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker Fields

The PointPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.MaximumProperty Field

PointPickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.MinimumProperty Field

PointPickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.RoundingDecimalPlaceProperty Field

PointPickerRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.SmallChangeProperty Field

PointPickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


PointPicker.ValueProperty Field

PointPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

PointPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker Class

Represents a radial color hue picker control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.EditorsRadialHuePicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RadialHuePicker : ContentControl
Public Class RadialHuePicker
    Inherits ContentControl

The RadialHuePicker type exposes the following members.

Constructors
 | Name | Description
Public method | RadialHuePicker | Initializes an instance of the RadialHuePicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the color hue.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Radius | Gets or sets the ring's outer radius.
Public property | SliderRadius | Gets the slider's radius.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | HueChanged | Occurs after the Hue property value changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
HueProperty | Identifies the Hue dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
SliderRadiusProperty | Identifies the SliderRadius dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker Constructor

Initializes an instance of the RadialHuePicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RadialHuePicker()
Public Sub New
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker Properties

The RadialHuePicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the color hue.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Radius | Gets or sets the ring's outer radius.
Public property | SliderRadius | Gets the slider's radius.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker.Hue Property

RadialHuePickerHue Property

Gets or sets the color hue.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The color hue. The default value is 0.0.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker.Radius Property

RadialHuePickerRadius Property

Gets or sets the ring's outer radius.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The ring's outer radius. The default value is 130.0.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker.SliderRadius Property

RadialHuePickerSliderRadius Property

Gets the slider's radius.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SliderRadius { get; }
Public ReadOnly Property SliderRadius As Double
    Get

Property Value

Type: Double
The slider's radius.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker Methods

The RadialHuePicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker.OnApplyTemplate Method

RadialHuePickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker.OnCreateAutomationPeer Method

RadialHuePickerOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker Events

The RadialHuePicker type exposes the following members.

Events
 | Name | Description
Public event | HueChanged | Occurs after the Hue property value changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker.HueChanged Event

RadialHuePickerHueChanged Event

Occurs after the Hue property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler HueChanged
Public Event HueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker Fields

The RadialHuePicker type exposes the following members.

Fields
Name | Description
HueProperty | Identifies the Hue dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
SliderRadiusProperty | Identifies the SliderRadius dependency property. This field is read-only.
Top
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker.HueProperty Field

RadialHuePickerHueProperty Field

Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker.RadiusProperty Field

RadialHuePickerRadiusProperty Field

Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RadialHuePicker.SliderRadiusProperty Field

RadialHuePickerSliderRadiusProperty Field

Identifies the SliderRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliderRadiusProperty
Public Shared ReadOnly SliderRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliderRadius dependency property.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating Class

Represents a rating control that allows the user to set or view a rating of an entity.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
ActiproSoftware.Windows.Controls.EditorsRating

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Rating : ItemsControl, IOrientedElement
Public Class Rating
    Inherits ItemsControl
    Implements IOrientedElement

The Rating type exposes the following members.

Constructors
 | Name | Description
Public method | Rating | Initializes an instance of the Rating class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AverageValue | Gets or sets the average rating value currently presented by the control.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClearValueCommand | Gets the ICommand that can clear the value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | ItemCount | Gets or sets the number of items to display in the rating.
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the rating value currently presented by the control, if any.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection has changed. (Overrides ItemsControlOnItemsChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ItemsControlOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
AverageValueProperty | Identifies the AverageValue dependency property. This field is read-only.
ItemCountProperty | Identifies the read-only ItemCount dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


Rating Constructor

Initializes an instance of the Rating class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rating()
Public Sub New
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating Properties

The Rating type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AverageValue | Gets or sets the average rating value currently presented by the control.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClearValueCommand | Gets the ICommand that can clear the value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | ItemCount | Gets or sets the number of items to display in the rating.
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the rating value currently presented by the control, if any.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.AverageValue Property

RatingAverageValue Property

Gets or sets the average rating value currently presented by the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AverageValue { get; set; }
Public Property AverageValue As Double
    Get
    Set

Property Value

Type: Double
The average rating value currently presented by the control. The default value is 0.0.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.ClearValueCommand Property

RatingClearValueCommand Property

Gets the ICommand that can clear the value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ClearValueCommand { get; }
Public ReadOnly Property ClearValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can clear the value.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.ItemCount Property

RatingItemCount Property

Gets or sets the number of items to display in the rating.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int ItemCount { get; set; }
Public Property ItemCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of items to display in the rating. The default value is 0.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.Orientation Property

RatingOrientation Property

Gets or sets the Orientation of the child element layout.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Horizontal.

Implements

IOrientedElementOrientation
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.Value Property

RatingValue Property

Gets or sets the rating value currently presented by the control, if any.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<double> Value { get; set; }
Public Property Value As Nullable(Of Double)
    Get
    Set

Property Value

Type: Nullable Double
The rating value currently presented by the control, if any. The default value is .
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating Methods

The Rating type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection has changed. (Overrides ItemsControlOnItemsChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ItemsControlOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.OnCreateAutomationPeer Method

RatingOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.OnItemsChanged Method

RatingOnItemsChanged Method

Occurs when the Items collection has changed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overrides Sub OnItemsChanged (
    e As NotifyCollectionChangedEventArgs
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
The NotifyCollectionChangedEventArgs that contains the event data.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.OnKeyDown Method

RatingOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating Events

The Rating type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.ValueChanged Event

RatingValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating Fields

The Rating type exposes the following members.

Fields
Name | Description
AverageValueProperty | Identifies the AverageValue dependency property. This field is read-only.
ItemCountProperty | Identifies the read-only ItemCount dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.AverageValueProperty Field

RatingAverageValueProperty Field

Identifies the AverageValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AverageValueProperty
Public Shared ReadOnly AverageValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AverageValue dependency property.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.ItemCountProperty Field

RatingItemCountProperty Field

Identifies the read-only ItemCount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemCountProperty
Public Shared ReadOnly ItemCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemCount dependency property.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.OrientationProperty Field

RatingOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


Rating.ValueProperty Field

RatingValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Rating Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem Class

Represents a single item in a Rating control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.EditorsRatingItem

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RatingItem : ContentControl, IOrientedElement
Public Class RatingItem
    Inherits ContentControl
    Implements IOrientedElement

The RatingItem type exposes the following members.

Constructors
 | Name | Description
Public method | RatingItem | Initializes an instance of the RatingItem class.
Top
Properties
 | Name | Description
Public property | ActiveGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the end user's pointer actively over this item or one after it.
Public property | AverageGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the item is involved in rendering an average value for the overall rating.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClipPercentage | Gets the clip percentage to apply on the foreground glyph.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | NormalGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph in the normal (unselected) state.
Public property | Orientation | Gets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the item is involved in the end user's value selection.
Public property | State | Gets the current item state.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ActiveGlyphTemplateProperty | Identifies the ActiveGlyphTemplate dependency property. This field is read-only.
AverageGlyphTemplateProperty | Identifies the AverageGlyphTemplate dependency property. This field is read-only.
ClipPercentageProperty | Identifies the ClipPercentage dependency property. This field is read-only.
NormalGlyphTemplateProperty | Identifies the NormalGlyphTemplate dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SelectedGlyphTemplateProperty | Identifies the SelectedGlyphTemplate dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem Constructor

Initializes an instance of the RatingItem class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RatingItem()
Public Sub New
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem Properties

The RatingItem type exposes the following members.

Properties
 | Name | Description
Public property | ActiveGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the end user's pointer actively over this item or one after it.
Public property | AverageGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the item is involved in rendering an average value for the overall rating.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClipPercentage | Gets the clip percentage to apply on the foreground glyph.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | NormalGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph in the normal (unselected) state.
Public property | Orientation | Gets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the item is involved in the end user's value selection.
Public property | State | Gets the current item state.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.ActiveGlyphTemplate Property

RatingItemActiveGlyphTemplate Property

Gets or sets the DataTemplate to use for the item glyph when the end user's pointer actively over this item or one after it.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ActiveGlyphTemplate { get; set; }
Public Property ActiveGlyphTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the item glyph when the end user's pointer actively over this item or one after it.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.AverageGlyphTemplate Property

RatingItemAverageGlyphTemplate Property

Gets or sets the DataTemplate to use for the item glyph when the item is involved in rendering an average value for the overall rating.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate AverageGlyphTemplate { get; set; }
Public Property AverageGlyphTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the item glyph when the item is involved in rendering an average value for the overall rating.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.ClipPercentage Property

RatingItemClipPercentage Property

Gets the clip percentage to apply on the foreground glyph.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ClipPercentage { get; }
Public ReadOnly Property ClipPercentage As Double
    Get

Property Value

Type: Double
The clip percentage to apply on the foreground glyph.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.NormalGlyphTemplate Property

RatingItemNormalGlyphTemplate Property

Gets or sets the DataTemplate to use for the item glyph in the normal (unselected) state.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate NormalGlyphTemplate { get; set; }
Public Property NormalGlyphTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the item glyph in the normal (unselected) state.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.Orientation Property

RatingItemOrientation Property

Gets the Orientation of the child element layout.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; }
Public ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Vertical.

Implements

IOrientedElementOrientation
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.SelectedGlyphTemplate Property

RatingItemSelectedGlyphTemplate Property

Gets or sets the DataTemplate to use for the item glyph when the item is involved in the end user's value selection.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate SelectedGlyphTemplate { get; set; }
Public Property SelectedGlyphTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the item glyph when the item is involved in the end user's value selection.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.State Property

RatingItemState Property

Gets the current item state.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RatingItemState State { get; }
Public ReadOnly Property State As RatingItemState
    Get

Property Value

Type: RatingItemState
A RatingItemState that indicates the current item state.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem Methods

The RatingItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.OnApplyTemplate Method

RatingItemOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem Events

The RatingItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem Fields

The RatingItem type exposes the following members.

Fields
Name | Description
ActiveGlyphTemplateProperty | Identifies the ActiveGlyphTemplate dependency property. This field is read-only.
AverageGlyphTemplateProperty | Identifies the AverageGlyphTemplate dependency property. This field is read-only.
ClipPercentageProperty | Identifies the ClipPercentage dependency property. This field is read-only.
NormalGlyphTemplateProperty | Identifies the NormalGlyphTemplate dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SelectedGlyphTemplateProperty | Identifies the SelectedGlyphTemplate dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
Top
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.ActiveGlyphTemplateProperty Field

RatingItemActiveGlyphTemplateProperty Field

Identifies the ActiveGlyphTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveGlyphTemplateProperty
Public Shared ReadOnly ActiveGlyphTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveGlyphTemplate dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.AverageGlyphTemplateProperty Field

RatingItemAverageGlyphTemplateProperty Field

Identifies the AverageGlyphTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AverageGlyphTemplateProperty
Public Shared ReadOnly AverageGlyphTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AverageGlyphTemplate dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.ClipPercentageProperty Field

RatingItemClipPercentageProperty Field

Identifies the ClipPercentage dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClipPercentageProperty
Public Shared ReadOnly ClipPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ClipPercentage dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.NormalGlyphTemplateProperty Field

RatingItemNormalGlyphTemplateProperty Field

Identifies the NormalGlyphTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NormalGlyphTemplateProperty
Public Shared ReadOnly NormalGlyphTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NormalGlyphTemplate dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.OrientationProperty Field

RatingItemOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.SelectedGlyphTemplateProperty Field

RatingItemSelectedGlyphTemplateProperty Field

Identifies the SelectedGlyphTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedGlyphTemplateProperty
Public Shared ReadOnly SelectedGlyphTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedGlyphTemplate dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItem.StateProperty Field

RatingItemStateProperty Field

Identifies the State dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StateProperty
Public Shared ReadOnly StateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the State dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.Windows.Controls.Editors Namespace


RatingItemState Enumeration

Specifies the various states supported by RatingItem.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum RatingItemState
Public Enumeration RatingItemState
Members
Member name | Value | Description
Normal | 0 | The rating item is in a normal (unselected) state.
Active | 1 | The rating item or one of the items after it has the end user's pointer actively over it.
Average | 2 | The rating item is involved in rendering an average value for the overall rating.
Selected | 3 | The rating item is involved in the end user's value selection.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox Class

Represents a Rect edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Rect
ActiproSoftware.Windows.Controls.EditorsRectEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RectEditBox : PartEditBoxBase<Nullable<Rect>>
Public Class RectEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Rect))

The RectEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | RectEditBox | Initializes an instance of the RectEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox Constructor

Initializes an instance of the RectEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RectEditBox()
Public Sub New
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox Properties

The RectEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.DefaultValue Property

RectEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect DefaultValue { get; set; }
Public Property DefaultValue As Rect
    Get
    Set

Property Value

Type: Rect
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.Format Property

RectEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.IsNaNAllowed Property

RectEditBoxIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.IsNegativeInfinityAllowed Property

RectEditBoxIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.IsPositiveInfinityAllowed Property

RectEditBoxIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.LargeChange Property

RectEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect LargeChange { get; set; }
Public Property LargeChange As Rect
    Get
    Set

Property Value

Type: Rect
The large change value. The default value is 5.0.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.Maximum Property

RectEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect Maximum { get; set; }
Public Property Maximum As Rect
    Get
    Set

Property Value

Type: Rect
The highest possible value.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.Minimum Property

RectEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect Minimum { get; set; }
Public Property Minimum As Rect
    Get
    Set

Property Value

Type: Rect
The lowest possible value.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.ResolvedFormat Property

RectEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.RoundingDecimalPlace Property

RectEditBoxRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.SmallChange Property

RectEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect SmallChange { get; set; }
Public Property SmallChange As Rect
    Get
    Set

Property Value

Type: Rect
The small change value. The default value is 1.0.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox Methods

The RectEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.CoerceValidValue Method

RectEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Rect> CoerceValidValue(
    Nullable<Rect> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Rect)
) As Nullable(Of Rect)

Parameters

value
Type: SystemNullable Rect
The value to coerce.

Return Value

Type: Nullable Rect
The coerced value.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.ConvertToString Method

RectEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Rect> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Rect)
) As String

Parameters

valueToConvert
Type: SystemNullable Rect
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.CreateIncrementalChangeRequest Method

RectEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Rect>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Rect))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Rect
The incremental change (spin) request that was created.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.GenerateParts Method

RectEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.IsValidValue Method

RectEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Rect> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Rect)
) As Boolean

Parameters

value
Type: SystemNullable Rect
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.ProcessTextInput Method

RectEditBoxProcessTextInput Method

Processes typed text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.RaiseValueChangedEvent Method

RectEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.ResetValue Method

RectEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.TryConvertFromString Method

RectEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Rect> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Rect)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Rect
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox Events

The RectEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.ValueChanged Event

RectEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox Fields

The RectEditBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.DefaultValueProperty Field

RectEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.FormatProperty Field

RectEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.IsNaNAllowedProperty Field

RectEditBoxIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.IsNegativeInfinityAllowedProperty Field

RectEditBoxIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.IsPositiveInfinityAllowedProperty Field

RectEditBoxIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.LargeChangeProperty Field

RectEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.MaximumProperty Field

RectEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.MinimumProperty Field

RectEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.ResolvedFormatProperty Field

RectEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.RoundingDecimalPlaceProperty Field

RectEditBoxRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectEditBox.SmallChangeProperty Field

RectEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker Class

Represents a Rect picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsRectPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RectPicker : PickerBase
Public Class RectPicker
    Inherits PickerBase

The RectPicker type exposes the following members.

Constructors
 | Name | Description
Public method | RectPicker | Initializes an instance of the RectPicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker Constructor

Initializes an instance of the RectPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RectPicker()
Public Sub New
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker Properties

The RectPicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.Maximum Property

RectPickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect Maximum { get; set; }
Public Property Maximum As Rect
    Get
    Set

Property Value

Type: Rect
The highest possible value.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.Minimum Property

RectPickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect Minimum { get; set; }
Public Property Minimum As Rect
    Get
    Set

Property Value

Type: Rect
The lowest possible value.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.RoundingDecimalPlace Property

RectPickerRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.SmallChange Property

RectPickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect SmallChange { get; set; }
Public Property SmallChange As Rect
    Get
    Set

Property Value

Type: Rect
The small change value. The default value is 1.0.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.Value Property

RectPickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect Value { get; set; }
Public Property Value As Rect
    Get
    Set

Property Value

Type: Rect
The value of the control.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker Methods

The RectPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.OnApplyTemplate Method

RectPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker Events

The RectPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.ValueChanged Event

RectPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker Fields

The RectPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.MaximumProperty Field

RectPickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.MinimumProperty Field

RectPickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.RoundingDecimalPlaceProperty Field

RectPickerRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.SmallChangeProperty Field

RectPickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


RectPicker.ValueProperty Field

RectPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

RectPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker Class

Represents a saturation/brightness picker control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.EditorsSaturationBrightnessPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SaturationBrightnessPicker : Control
Public Class SaturationBrightnessPicker
    Inherits Control

The SaturationBrightnessPicker type exposes the following members.

Constructors
 | Name | Description
Public method | SaturationBrightnessPicker | Initializes an instance of the SaturationBrightnessPicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the color brightness.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the color hue.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Saturation | Gets or sets the color saturation.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | BrightnessChanged | Occurs after the Brightness property value changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SaturationChanged | Occurs after the Saturation property value changes.
Top
Fields
Name | Description
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker Constructor

Initializes an instance of the SaturationBrightnessPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SaturationBrightnessPicker()
Public Sub New
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker Properties

The SaturationBrightnessPicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the color brightness.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the color hue.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Saturation | Gets or sets the color saturation.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.Brightness Property

SaturationBrightnessPickerBrightness Property

Gets or sets the color brightness.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set

Property Value

Type: Double
The color brightness.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.Hue Property

SaturationBrightnessPickerHue Property

Gets or sets the color hue.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The color hue.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.Saturation Property

SaturationBrightnessPickerSaturation Property

Gets or sets the color saturation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Saturation { get; set; }
Public Property Saturation As Double
    Get
    Set

Property Value

Type: Double
The color saturation.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker Methods

The SaturationBrightnessPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.OnApplyTemplate Method

SaturationBrightnessPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.OnCreateAutomationPeer Method

SaturationBrightnessPickerOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker Events

The SaturationBrightnessPicker type exposes the following members.

Events
 | Name | Description
Public event | BrightnessChanged | Occurs after the Brightness property value changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SaturationChanged | Occurs after the Saturation property value changes.
Top
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.BrightnessChanged Event

SaturationBrightnessPickerBrightnessChanged Event

Occurs after the Brightness property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler BrightnessChanged
Public Event BrightnessChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.SaturationChanged Event

SaturationBrightnessPickerSaturationChanged Event

Occurs after the Saturation property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler SaturationChanged
Public Event SaturationChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker Fields

The SaturationBrightnessPicker type exposes the following members.

Fields
Name | Description
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
Top
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.BrightnessProperty Field

SaturationBrightnessPickerBrightnessProperty Field

Identifies the Brightness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrightnessProperty
Public Shared ReadOnly BrightnessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Brightness dependency property.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.HueProperty Field

SaturationBrightnessPickerHueProperty Field

Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SaturationBrightnessPicker.SaturationProperty Field

SaturationBrightnessPickerSaturationProperty Field

Identifies the Saturation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SaturationProperty
Public Shared ReadOnly SaturationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Saturation dependency property.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox Class

Represents a Single edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Single
ActiproSoftware.Windows.Controls.EditorsSingleEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SingleEditBox : PartEditBoxBase<Nullable<float>>
Public Class SingleEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Single))

The SingleEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | SingleEditBox | Initializes an instance of the SingleEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox Constructor

Initializes an instance of the SingleEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SingleEditBox()
Public Sub New
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox Properties

The SingleEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.CalculatorPopupPickerStyle Property

SingleEditBoxCalculatorPopupPickerStyle Property

Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.DefaultValue Property

SingleEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float DefaultValue { get; set; }
Public Property DefaultValue As Single
    Get
    Set

Property Value

Type: Single
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.Format Property

SingleEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.IsNaNAllowed Property

SingleEditBoxIsNaNAllowed Property

Gets or sets whether NaN is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.IsNegativeInfinityAllowed Property

SingleEditBoxIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.IsPositiveInfinityAllowed Property

SingleEditBoxIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.LargeChange Property

SingleEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float LargeChange { get; set; }
Public Property LargeChange As Single
    Get
    Set

Property Value

Type: Single
The large change value. The default value is 5.0.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.Maximum Property

SingleEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float Maximum { get; set; }
Public Property Maximum As Single
    Get
    Set

Property Value

Type: Single
The highest possible value.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.Minimum Property

SingleEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float Minimum { get; set; }
Public Property Minimum As Single
    Get
    Set

Property Value

Type: Single
The lowest possible value.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.PickerKind Property

SingleEditBoxPickerKind Property

Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SingleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As SingleEditBoxPickerKind
    Get
    Set

Property Value

Type: SingleEditBoxPickerKind
A SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.ResolvedFormat Property

SingleEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.RoundingDecimalPlace Property

SingleEditBoxRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 7. Pass a null value to disable rounding. The default value is 7.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.SmallChange Property

SingleEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float SmallChange { get; set; }
Public Property SmallChange As Single
    Get
    Set

Property Value

Type: Single
The small change value. The default value is 1.0.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox Methods

The SingleEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.CoerceValidValue Method

SingleEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<float> CoerceValidValue(
    Nullable<float> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Single)
) As Nullable(Of Single)

Parameters

value
Type: SystemNullable Single
The value to coerce.

Return Value

Type: Nullable Single
The coerced value.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.ConvertToString Method

SingleEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<float> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Single)
) As String

Parameters

valueToConvert
Type: SystemNullable Single
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.CreateIncrementalChangeRequest Method

SingleEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<float>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Single))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Single
The incremental change (spin) request that was created.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.GenerateParts Method

SingleEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.IsValidValue Method

SingleEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<float> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Single)
) As Boolean

Parameters

value
Type: SystemNullable Single
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.ProcessTextInput Method

SingleEditBoxProcessTextInput Method

Processes typed text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.RaiseValueChangedEvent Method

SingleEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.ResetValue Method

SingleEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.TryConvertFromString Method

SingleEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<float> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Single)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Single
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox Events

The SingleEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.ValueChanged Event

SingleEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox Fields

The SingleEditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.CalculatorPopupPickerStyleProperty Field

SingleEditBoxCalculatorPopupPickerStyleProperty Field

Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.DefaultValueProperty Field

SingleEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.FormatProperty Field

SingleEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.IsNaNAllowedProperty Field

SingleEditBoxIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.IsNegativeInfinityAllowedProperty Field

SingleEditBoxIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.IsPositiveInfinityAllowedProperty Field

SingleEditBoxIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.LargeChangeProperty Field

SingleEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.MaximumProperty Field

SingleEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.MinimumProperty Field

SingleEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.PickerKindProperty Field

SingleEditBoxPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.ResolvedFormatProperty Field

SingleEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.RoundingDecimalPlaceProperty Field

SingleEditBoxRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBox.SmallChangeProperty Field

SingleEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SingleEditBoxPickerKind Enumeration

Specifies the kind of Style to apply to the SinglePicker used within a SingleEditBox's popup.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SingleEditBoxPickerKind
Public Enumeration SingleEditBoxPickerKind
Members
Member name | Value | Description
Default | 0 | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default SinglePicker style, which is templated to contain a radial slider control.
Calculator | 1 | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker Class

Represents a Single picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.Windows.Controls.EditorsSinglePicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SinglePicker : RadialSliderPickerBase
Public Class SinglePicker
    Inherits RadialSliderPickerBase

The SinglePicker type exposes the following members.

Constructors
 | Name | Description
Public method | SinglePicker | Initializes an instance of the SinglePicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker Constructor

Initializes an instance of the SinglePicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SinglePicker()
Public Sub New
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker Properties

The SinglePicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.Maximum Property

SinglePickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float Maximum { get; set; }
Public Property Maximum As Single
    Get
    Set

Property Value

Type: Single
The highest possible value.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.Minimum Property

SinglePickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float Minimum { get; set; }
Public Property Minimum As Single
    Get
    Set

Property Value

Type: Single
The lowest possible value.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.RoundingDecimalPlace Property

SinglePickerRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 7. Pass a null value to disable rounding. The default value is 7.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.SmallChange Property

SinglePickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float SmallChange { get; set; }
Public Property SmallChange As Single
    Get
    Set

Property Value

Type: Single
The small change value. The default value is 1.0.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.Value Property

SinglePickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float Value { get; set; }
Public Property Value As Single
    Get
    Set

Property Value

Type: Single
The value of the control.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker Methods

The SinglePicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.OnApplyTemplate Method

SinglePickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker Events

The SinglePicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.ValueChanged Event

SinglePickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker Fields

The SinglePicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.MaximumProperty Field

SinglePickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.MinimumProperty Field

SinglePickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.RoundingDecimalPlaceProperty Field

SinglePickerRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.SmallChangeProperty Field

SinglePickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SinglePicker.ValueProperty Field

SinglePickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

SinglePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox Class

Represents a Size edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Size
ActiproSoftware.Windows.Controls.EditorsSizeEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SizeEditBox : PartEditBoxBase<Nullable<Size>>
Public Class SizeEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Size))

The SizeEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | SizeEditBox | Initializes an instance of the SizeEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox Constructor

Initializes an instance of the SizeEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SizeEditBox()
Public Sub New
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox Properties

The SizeEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.DefaultValue Property

SizeEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size DefaultValue { get; set; }
Public Property DefaultValue As Size
    Get
    Set

Property Value

Type: Size
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.Format Property

SizeEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.IsNaNAllowed Property

SizeEditBoxIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.IsNegativeInfinityAllowed Property

SizeEditBoxIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.IsPositiveInfinityAllowed Property

SizeEditBoxIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.LargeChange Property

SizeEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size LargeChange { get; set; }
Public Property LargeChange As Size
    Get
    Set

Property Value

Type: Size
The large change value. The default value is 5.0.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.Maximum Property

SizeEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Maximum { get; set; }
Public Property Maximum As Size
    Get
    Set

Property Value

Type: Size
The highest possible value.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.Minimum Property

SizeEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Minimum { get; set; }
Public Property Minimum As Size
    Get
    Set

Property Value

Type: Size
The lowest possible value.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.ResolvedFormat Property

SizeEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.RoundingDecimalPlace Property

SizeEditBoxRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.SmallChange Property

SizeEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size SmallChange { get; set; }
Public Property SmallChange As Size
    Get
    Set

Property Value

Type: Size
The small change value. The default value is 1.0.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox Methods

The SizeEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.CoerceValidValue Method

SizeEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Size> CoerceValidValue(
    Nullable<Size> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Size)
) As Nullable(Of Size)

Parameters

value
Type: SystemNullable Size
The value to coerce.

Return Value

Type: Nullable Size
The coerced value.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.ConvertToString Method

SizeEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Size> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Size)
) As String

Parameters

valueToConvert
Type: SystemNullable Size
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.CreateIncrementalChangeRequest Method

SizeEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Size>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Size))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Size
The incremental change (spin) request that was created.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.GenerateParts Method

SizeEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.IsValidValue Method

SizeEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Size> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Size)
) As Boolean

Parameters

value
Type: SystemNullable Size
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.ProcessTextInput Method

SizeEditBoxProcessTextInput Method

Processes typed text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.RaiseValueChangedEvent Method

SizeEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.ResetValue Method

SizeEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.TryConvertFromString Method

SizeEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Size> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Size)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Size
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox Events

The SizeEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.ValueChanged Event

SizeEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox Fields

The SizeEditBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.DefaultValueProperty Field

SizeEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.FormatProperty Field

SizeEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.IsNaNAllowedProperty Field

SizeEditBoxIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.IsNegativeInfinityAllowedProperty Field

SizeEditBoxIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.IsPositiveInfinityAllowedProperty Field

SizeEditBoxIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.LargeChangeProperty Field

SizeEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.MaximumProperty Field

SizeEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.MinimumProperty Field

SizeEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.ResolvedFormatProperty Field

SizeEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.RoundingDecimalPlaceProperty Field

SizeEditBoxRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizeEditBox.SmallChangeProperty Field

SizeEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker Class

Represents a Size picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsSizePicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SizePicker : PickerBase
Public Class SizePicker
    Inherits PickerBase

The SizePicker type exposes the following members.

Constructors
 | Name | Description
Public method | SizePicker | Initializes an instance of the SizePicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker Constructor

Initializes an instance of the SizePicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SizePicker()
Public Sub New
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker Properties

The SizePicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.Maximum Property

SizePickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Maximum { get; set; }
Public Property Maximum As Size
    Get
    Set

Property Value

Type: Size
The highest possible value.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.Minimum Property

SizePickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Minimum { get; set; }
Public Property Minimum As Size
    Get
    Set

Property Value

Type: Size
The lowest possible value.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.RoundingDecimalPlace Property

SizePickerRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.SmallChange Property

SizePickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size SmallChange { get; set; }
Public Property SmallChange As Size
    Get
    Set

Property Value

Type: Size
The small change value. The default value is 1.0.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.Value Property

SizePickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Value { get; set; }
Public Property Value As Size
    Get
    Set

Property Value

Type: Size
The value of the control.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker Methods

The SizePicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.OnApplyTemplate Method

SizePickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker Events

The SizePicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.ValueChanged Event

SizePickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker Fields

The SizePicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.MaximumProperty Field

SizePickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.MinimumProperty Field

SizePickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.RoundingDecimalPlaceProperty Field

SizePickerRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.SmallChangeProperty Field

SizePickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SizePicker.ValueProperty Field

SizePickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

SizePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


SpinnerVisibility Enumeration

Specifies the desired visibility of a spinner within a parent control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SpinnerVisibility
Public Enumeration SpinnerVisibility
Members
Member name | Value | Description
Collapsed | 0 | The spinner should always be hidden.
Visible | 1 | The spinner should always be visible.
VisibleWhenActive | 2 | The spinner should be visible when the parent control has focus or a pointer over it.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


SpinWrapping Enumeration

Specifies the various wrapping behaviors supported when spinning a value in a part edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum SpinWrapping
Public Enumeration SpinWrapping
Members
Member name | Value | Description
NoWrap | 0 | Indicates that the values will not wrap when the minimum or maximum are reached.
SimpleWrap | 1 | Indicates that the values will wrap when the minimum or maximum are reached (e.g. incrementing the maximum value will result in the minimum value).
Wrap | 2 | Indicates that the values will wrap when the minimum or maximum are reached (e.g. incrementing the maximum value will result in the minimum value), but may or may not include special handling (see remarks for more information).
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox Class

Represents a Thickness edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Thickness
ActiproSoftware.Windows.Controls.EditorsThicknessEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ThicknessEditBox : PartEditBoxBase<Nullable<Thickness>>
Public Class ThicknessEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Thickness))

The ThicknessEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | ThicknessEditBox | Initializes an instance of the ThicknessEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox Constructor

Initializes an instance of the ThicknessEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ThicknessEditBox()
Public Sub New
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox Properties

The ThicknessEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.DefaultValue Property

ThicknessEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness DefaultValue { get; set; }
Public Property DefaultValue As Thickness
    Get
    Set

Property Value

Type: Thickness
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.Format Property

ThicknessEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.IsNaNAllowed Property

ThicknessEditBoxIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.IsNegativeInfinityAllowed Property

ThicknessEditBoxIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.IsPositiveInfinityAllowed Property

ThicknessEditBoxIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.LargeChange Property

ThicknessEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness LargeChange { get; set; }
Public Property LargeChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The large change value. The default value is 5.0.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.Maximum Property

ThicknessEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Maximum { get; set; }
Public Property Maximum As Thickness
    Get
    Set

Property Value

Type: Thickness
The highest possible value.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.Minimum Property

ThicknessEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Minimum { get; set; }
Public Property Minimum As Thickness
    Get
    Set

Property Value

Type: Thickness
The lowest possible value.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.ResolvedFormat Property

ThicknessEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.RoundingDecimalPlace Property

ThicknessEditBoxRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.SmallChange Property

ThicknessEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness SmallChange { get; set; }
Public Property SmallChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The small change value. The default value is 1.0.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox Methods

The ThicknessEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.CoerceValidValue Method

ThicknessEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> CoerceValidValue(
    Nullable<Thickness> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Thickness)
) As Nullable(Of Thickness)

Parameters

value
Type: SystemNullable Thickness
The value to coerce.

Return Value

Type: Nullable Thickness
The coerced value.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.ConvertToString Method

ThicknessEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Thickness> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Thickness)
) As String

Parameters

valueToConvert
Type: SystemNullable Thickness
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.CreateIncrementalChangeRequest Method

ThicknessEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Thickness>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Thickness))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Thickness
The incremental change (spin) request that was created.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.GenerateParts Method

ThicknessEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.IsValidValue Method

ThicknessEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Thickness> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Thickness)
) As Boolean

Parameters

value
Type: SystemNullable Thickness
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.ProcessTextInput Method

ThicknessEditBoxProcessTextInput Method

Processes typed text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.RaiseValueChangedEvent Method

ThicknessEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.ResetValue Method

ThicknessEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.TryConvertFromString Method

ThicknessEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Thickness> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Thickness)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Thickness
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox Events

The ThicknessEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.ValueChanged Event

ThicknessEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox Fields

The ThicknessEditBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.DefaultValueProperty Field

ThicknessEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.FormatProperty Field

ThicknessEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.IsNaNAllowedProperty Field

ThicknessEditBoxIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.IsNegativeInfinityAllowedProperty Field

ThicknessEditBoxIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.IsPositiveInfinityAllowedProperty Field

ThicknessEditBoxIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.LargeChangeProperty Field

ThicknessEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.MaximumProperty Field

ThicknessEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.MinimumProperty Field

ThicknessEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.ResolvedFormatProperty Field

ThicknessEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.RoundingDecimalPlaceProperty Field

ThicknessEditBoxRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessEditBox.SmallChangeProperty Field

ThicknessEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker Class

Represents a Thickness picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsThicknessPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ThicknessPicker : PickerBase
Public Class ThicknessPicker
    Inherits PickerBase

The ThicknessPicker type exposes the following members.

Constructors
 | Name | Description
Public method | ThicknessPicker | Initializes an instance of the ThicknessPicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker Constructor

Initializes an instance of the ThicknessPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ThicknessPicker()
Public Sub New
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker Properties

The ThicknessPicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.Maximum Property

ThicknessPickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Maximum { get; set; }
Public Property Maximum As Thickness
    Get
    Set

Property Value

Type: Thickness
The highest possible value.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.Minimum Property

ThicknessPickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Minimum { get; set; }
Public Property Minimum As Thickness
    Get
    Set

Property Value

Type: Thickness
The lowest possible value.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.RoundingDecimalPlace Property

ThicknessPickerRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.SmallChange Property

ThicknessPickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness SmallChange { get; set; }
Public Property SmallChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The small change value. The default value is 1.0.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.Value Property

ThicknessPickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Value { get; set; }
Public Property Value As Thickness
    Get
    Set

Property Value

Type: Thickness
The value of the control.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker Methods

The ThicknessPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.OnApplyTemplate Method

ThicknessPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker Events

The ThicknessPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.ValueChanged Event

ThicknessPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker Fields

The ThicknessPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.MaximumProperty Field

ThicknessPickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.MinimumProperty Field

ThicknessPickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.RoundingDecimalPlaceProperty Field

ThicknessPickerRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.SmallChangeProperty Field

ThicknessPickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ThicknessPicker.ValueProperty Field

ThicknessPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeEditBox Class

Represents a time-only edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable DateTime
ActiproSoftware.Windows.Controls.EditorsDateTimeEditBox
ActiproSoftware.Windows.Controls.EditorsTimeEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TimeEditBox : DateTimeEditBox
Public Class TimeEditBox
    Inherits DateTimeEditBox

The TimeEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | TimeEditBox | Initializes an instance of the TimeEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimeEditBox.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides DateTimeEditBoxHasPopupButtonWhenReadOnly.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimeEditBox.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimeEditBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string. (Inherited from DateTimeEditBox.)
Public property | SetValueToNowCommand | Gets the ICommand that sets the value to the current date/time. (Inherited from DateTimeEditBox.)
Public property | SetValueToTodayCommand | Gets the ICommand that sets the value to the current date. (Inherited from DateTimeEditBox.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceParsedValue | Coerces the parsed value from text, which is used for time-only edit boxes to ensure their date doesn't change. (Overrides DateTimeEditBoxCoerceParsedValue(NullableDateTime).)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from DateTimeEditBox.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Inherited from DateTimeEditBox.)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Inherited from DateTimeEditBox.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Inherited from DateTimeEditBox.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Inherited from DateTimeEditBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Inherited from DateTimeEditBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides DateTimeEditBoxResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides DateTimeEditBoxTryConvertFromString(String, Boolean, NullableDateTime).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from DateTimeEditBox.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


TimeEditBox Constructor

Initializes an instance of the TimeEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeEditBox()
Public Sub New
See Also

Reference

TimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeEditBox Properties

The TimeEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimeEditBox.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides DateTimeEditBoxHasPopupButtonWhenReadOnly.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimeEditBox.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimeEditBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string. (Inherited from DateTimeEditBox.)
Public property | SetValueToNowCommand | Gets the ICommand that sets the value to the current date/time. (Inherited from DateTimeEditBox.)
Public property | SetValueToTodayCommand | Gets the ICommand that sets the value to the current date. (Inherited from DateTimeEditBox.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeEditBox.HasPopupButtonWhenReadOnly Property

TimeEditBoxHasPopupButtonWhenReadOnly Property

Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

TimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeEditBox Methods

The TimeEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceParsedValue | Coerces the parsed value from text, which is used for time-only edit boxes to ensure their date doesn't change. (Overrides DateTimeEditBoxCoerceParsedValue(NullableDateTime).)
Protected method | CoerceValidValue | Coerces the value to be within range. (Inherited from DateTimeEditBox.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Inherited from DateTimeEditBox.)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Inherited from DateTimeEditBox.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Inherited from DateTimeEditBox.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Inherited from DateTimeEditBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Inherited from DateTimeEditBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides DateTimeEditBoxResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides DateTimeEditBoxTryConvertFromString(String, Boolean, NullableDateTime).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeEditBox.CoerceParsedValue Method

TimeEditBoxCoerceParsedValue Method

Coerces the parsed value from text, which is used for time-only edit boxes to ensure their date doesn't change.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<DateTime> CoerceParsedValue(
    Nullable<DateTime> value
)
Protected Overrides Function CoerceParsedValue (
    value As Nullable(Of DateTime)
) As Nullable(Of DateTime)

Parameters

value
Type: SystemNullable DateTime
The value to coerce.

Return Value

Type: Nullable DateTime
The coerced value.
See Also

Reference

TimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeEditBox.ResetValue Method

TimeEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

TimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeEditBox.TryConvertFromString Method

TimeEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<DateTime> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of DateTime)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable DateTime
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

TimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeEditBox Events

The TimeEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from DateTimeEditBox.)
Top
See Also

Reference

TimeEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker Class

Represents a time picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsTimePicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TimePicker : PickerBase
Public Class TimePicker
    Inherits PickerBase

The TimePicker type exposes the following members.

Constructors
 | Name | Description
Public method | TimePicker | Initializes an instance of the TimePicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hour | Gets or sets the hour value.
Public property | HourDegreeMaximum | Gets the highest possible hour degree value, which can be bound to a radial slider.
Public property | HourDegreeMinimum | Gets the lowest possible hour degree value, which can be bound to a radial slider.
Public property | HourDegreeValue | Gets or sets the hour value in degrees.
Public property | IsPM | Gets whether the time is PM.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Minute | Gets or sets the minute value.
Public property | MinuteDegreeMaximum | Gets the highest possible minute degree value, which can be bound to a radial slider.
Public property | MinuteDegreeMinimum | Gets the lowest possible minute degree value, which can be bound to a radial slider.
Public property | MinuteDegreeValue | Gets or sets the minute value in degrees.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
HourDegreeMaximumProperty | Identifies the HourDegreeMaximum dependency property. This field is read-only.
HourDegreeMinimumProperty | Identifies the HourDegreeMinimum dependency property. This field is read-only.
HourDegreeValueProperty | Identifies the HourDegreeValue dependency property. This field is read-only.
HourProperty | Identifies the Hour dependency property. This field is read-only.
IsPMProperty | Identifies the IsPM dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinuteDegreeMaximumProperty | Identifies the MinuteDegreeMaximum dependency property. This field is read-only.
MinuteDegreeMinimumProperty | Identifies the MinuteDegreeMinimum dependency property. This field is read-only.
MinuteDegreeValueProperty | Identifies the MinuteDegreeValue dependency property. This field is read-only.
MinuteProperty | Identifies the Minute dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker Constructor

Initializes an instance of the TimePicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimePicker()
Public Sub New
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker Properties

The TimePicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hour | Gets or sets the hour value.
Public property | HourDegreeMaximum | Gets the highest possible hour degree value, which can be bound to a radial slider.
Public property | HourDegreeMinimum | Gets the lowest possible hour degree value, which can be bound to a radial slider.
Public property | HourDegreeValue | Gets or sets the hour value in degrees.
Public property | IsPM | Gets whether the time is PM.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Minute | Gets or sets the minute value.
Public property | MinuteDegreeMaximum | Gets the highest possible minute degree value, which can be bound to a radial slider.
Public property | MinuteDegreeMinimum | Gets the lowest possible minute degree value, which can be bound to a radial slider.
Public property | MinuteDegreeValue | Gets or sets the minute value in degrees.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.Hour Property

TimePickerHour Property

Gets or sets the hour value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Hour { get; set; }
Public Property Hour As Integer
    Get
    Set

Property Value

Type: Int32
The hour value.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.HourDegreeMaximum Property

TimePickerHourDegreeMaximum Property

Gets the highest possible hour degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double HourDegreeMaximum { get; }
Public ReadOnly Property HourDegreeMaximum As Double
    Get

Property Value

Type: Double
The highest possible hour degree value.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.HourDegreeMinimum Property

TimePickerHourDegreeMinimum Property

Gets the lowest possible hour degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double HourDegreeMinimum { get; }
Public ReadOnly Property HourDegreeMinimum As Double
    Get

Property Value

Type: Double
The lowest possible hour degree value.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.HourDegreeValue Property

TimePickerHourDegreeValue Property

Gets or sets the hour value in degrees.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int HourDegreeValue { get; set; }
Public Property HourDegreeValue As Integer
    Get
    Set

Property Value

Type: Int32
The hour value in degrees.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.IsPM Property

TimePickerIsPM Property

Gets whether the time is PM.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPM { get; }
Public ReadOnly Property IsPM As Boolean
    Get

Property Value

Type: Boolean
true if the time is PM; otherwise, false.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.Maximum Property

TimePickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.Minimum Property

TimePickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.Minute Property

TimePickerMinute Property

Gets or sets the minute value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Minute { get; set; }
Public Property Minute As Integer
    Get
    Set

Property Value

Type: Int32
The minute value.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.MinuteDegreeMaximum Property

TimePickerMinuteDegreeMaximum Property

Gets the highest possible minute degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MinuteDegreeMaximum { get; }
Public ReadOnly Property MinuteDegreeMaximum As Double
    Get

Property Value

Type: Double
The highest possible minute degree value.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.MinuteDegreeMinimum Property

TimePickerMinuteDegreeMinimum Property

Gets the lowest possible minute degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MinuteDegreeMinimum { get; }
Public ReadOnly Property MinuteDegreeMinimum As Double
    Get

Property Value

Type: Double
The lowest possible minute degree value.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.MinuteDegreeValue Property

TimePickerMinuteDegreeValue Property

Gets or sets the minute value in degrees.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int MinuteDegreeValue { get; set; }
Public Property MinuteDegreeValue As Integer
    Get
    Set

Property Value

Type: Int32
The degree minute value in degrees.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.Value Property

TimePickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Value { get; set; }
Public Property Value As DateTime
    Get
    Set

Property Value

Type: DateTime
The value of the control.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker Methods

The TimePicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.OnApplyTemplate Method

TimePickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker Events

The TimePicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.ValueChanged Event

TimePickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker Fields

The TimePicker type exposes the following members.

Fields
Name | Description
HourDegreeMaximumProperty | Identifies the HourDegreeMaximum dependency property. This field is read-only.
HourDegreeMinimumProperty | Identifies the HourDegreeMinimum dependency property. This field is read-only.
HourDegreeValueProperty | Identifies the HourDegreeValue dependency property. This field is read-only.
HourProperty | Identifies the Hour dependency property. This field is read-only.
IsPMProperty | Identifies the IsPM dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinuteDegreeMaximumProperty | Identifies the MinuteDegreeMaximum dependency property. This field is read-only.
MinuteDegreeMinimumProperty | Identifies the MinuteDegreeMinimum dependency property. This field is read-only.
MinuteDegreeValueProperty | Identifies the MinuteDegreeValue dependency property. This field is read-only.
MinuteProperty | Identifies the Minute dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.HourDegreeMaximumProperty Field

TimePickerHourDegreeMaximumProperty Field

Identifies the HourDegreeMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HourDegreeMaximumProperty
Public Shared ReadOnly HourDegreeMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HourDegreeMaximum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.HourDegreeMinimumProperty Field

TimePickerHourDegreeMinimumProperty Field

Identifies the HourDegreeMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HourDegreeMinimumProperty
Public Shared ReadOnly HourDegreeMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HourDegreeMinimum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.HourDegreeValueProperty Field

TimePickerHourDegreeValueProperty Field

Identifies the HourDegreeValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HourDegreeValueProperty
Public Shared ReadOnly HourDegreeValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HourDegreeValue dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.HourProperty Field

TimePickerHourProperty Field

Identifies the Hour dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HourProperty
Public Shared ReadOnly HourProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hour dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.IsPMProperty Field

TimePickerIsPMProperty Field

Identifies the IsPM dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPMProperty
Public Shared ReadOnly IsPMProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPM dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.MaximumProperty Field

TimePickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.MinimumProperty Field

TimePickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.MinuteDegreeMaximumProperty Field

TimePickerMinuteDegreeMaximumProperty Field

Identifies the MinuteDegreeMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinuteDegreeMaximumProperty
Public Shared ReadOnly MinuteDegreeMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinuteDegreeMaximum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.MinuteDegreeMinimumProperty Field

TimePickerMinuteDegreeMinimumProperty Field

Identifies the MinuteDegreeMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinuteDegreeMinimumProperty
Public Shared ReadOnly MinuteDegreeMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinuteDegreeMinimum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.MinuteDegreeValueProperty Field

TimePickerMinuteDegreeValueProperty Field

Identifies the MinuteDegreeValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinuteDegreeValueProperty
Public Shared ReadOnly MinuteDegreeValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinuteDegreeValue dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.MinuteProperty Field

TimePickerMinuteProperty Field

Identifies the Minute dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinuteProperty
Public Shared ReadOnly MinuteProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minute dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimePicker.ValueProperty Field

TimePickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditableParts Enumeration

Specifies the various editable parts of a TimeSpanPicker.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TimeSpanEditableParts
Public Enumeration TimeSpanEditableParts
Members
Member name | Value | Description
None | 0 | Indicates that no parts will be editable.
Days | 1 | Indicates that the days part will be editable.
Hours | 2 | Indicates that the hours part will be editable.
Minutes | 4 | Indicates that the minutes part will be editable.
Seconds | 8 | Indicates that the seconds part will be editable.
Milliseconds | 16 | Indicates that the milliseconds part will be editable.
All | 31 | Indicates that all the parts will be editable.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox Class

Represents a timespan edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable TimeSpan
ActiproSoftware.Windows.Controls.EditorsTimeSpanEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TimeSpanEditBox : PartEditBoxBase<Nullable<TimeSpan>>
Public Class TimeSpanEditBox
    Inherits PartEditBoxBase(Of Nullable(Of TimeSpan))

The TimeSpanEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSpanEditBox | Initializes an instance of the TimeSpanEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the timespan format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerEditableParts | Gets the picker's editable parts.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved timespan format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerEditablePartsProperty | Identifies the PickerEditableParts dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox Constructor

Initializes an instance of the TimeSpanEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpanEditBox()
Public Sub New
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox Properties

The TimeSpanEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the timespan format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerEditableParts | Gets the picker's editable parts.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved timespan format string.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.DefaultValue Property

TimeSpanEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan DefaultValue { get; set; }
Public Property DefaultValue As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.Format Property

TimeSpanEditBoxFormat Property

Gets or sets the timespan format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The timespan format string. The default value is "g".
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.HasPopupButtonWhenReadOnly Property

TimeSpanEditBoxHasPopupButtonWhenReadOnly Property

Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.LargeChange Property

TimeSpanEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan LargeChange { get; set; }
Public Property LargeChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The large change value. The default value is 7.3:5:5:050.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.Maximum Property

TimeSpanEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan Maximum { get; set; }
Public Property Maximum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The highest possible value.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.Minimum Property

TimeSpanEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan Minimum { get; set; }
Public Property Minimum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The lowest possible value.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.PickerEditableParts Property

TimeSpanEditBoxPickerEditableParts Property

Gets the picker's editable parts.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpanEditableParts PickerEditableParts { get; }
Public ReadOnly Property PickerEditableParts As TimeSpanEditableParts
    Get

Property Value

Type: TimeSpanEditableParts
The picker's editable parts.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.ResolvedFormat Property

TimeSpanEditBoxResolvedFormat Property

Gets the resolved timespan format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved timespan format string.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.SmallChange Property

TimeSpanEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan SmallChange { get; set; }
Public Property SmallChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The small change value. The default value is 1.1:1:1:1.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox Methods

The TimeSpanEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.CoerceValidValue Method

TimeSpanEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<TimeSpan> CoerceValidValue(
    Nullable<TimeSpan> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of TimeSpan)
) As Nullable(Of TimeSpan)

Parameters

value
Type: SystemNullable TimeSpan
The value to coerce.

Return Value

Type: Nullable TimeSpan
The coerced value.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.ConvertToString Method

TimeSpanEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<TimeSpan> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of TimeSpan)
) As String

Parameters

valueToConvert
Type: SystemNullable TimeSpan
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.CreateIncrementalChangeRequest Method

TimeSpanEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<TimeSpan>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of TimeSpan))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable TimeSpan
The incremental change (spin) request that was created.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.GenerateParts Method

TimeSpanEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.IsValidValue Method

TimeSpanEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<TimeSpan> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of TimeSpan)
) As Boolean

Parameters

value
Type: SystemNullable TimeSpan
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.RaiseValueChangedEvent Method

TimeSpanEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.ResetValue Method

TimeSpanEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.TryConvertFromString Method

TimeSpanEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<TimeSpan> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of TimeSpan)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable TimeSpan
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox Events

The TimeSpanEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.ValueChanged Event

TimeSpanEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox Fields

The TimeSpanEditBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerEditablePartsProperty | Identifies the PickerEditableParts dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.DefaultValueProperty Field

TimeSpanEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.FormatProperty Field

TimeSpanEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.LargeChangeProperty Field

TimeSpanEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.MaximumProperty Field

TimeSpanEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.MinimumProperty Field

TimeSpanEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.PickerEditablePartsProperty Field

TimeSpanEditBoxPickerEditablePartsProperty Field

Identifies the PickerEditableParts dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerEditablePartsProperty
Public Shared ReadOnly PickerEditablePartsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerEditableParts dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.ResolvedFormatProperty Field

TimeSpanEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanEditBox.SmallChangeProperty Field

TimeSpanEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker Class

Represents a TimeSpan picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsTimeSpanPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TimeSpanPicker : PickerBase
Public Class TimeSpanPicker
    Inherits PickerBase

The TimeSpanPicker type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSpanPicker | Initializes an instance of the TimeSpanPicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Days | Gets the days component (0 - 255) of the Value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EditableParts | Gets or sets the editable parts.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hours | Gets the hours component (0 - 23) of the Value.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Milliseconds | Gets the milliseconds component (0 - 999) of the Value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Minutes | Gets the minutes component (0 - 59) of the Value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Seconds | Gets the seconds component (0 - 59) of the Value.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DaysProperty | Identifies the Days dependency property. This field is read-only.
EditablePartsProperty | Identifies the EditableParts dependency property. This field is read-only.
HoursProperty | Identifies the Hours dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MillisecondsProperty | Identifies the Milliseconds dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinutesProperty | Identifies the Minutes dependency property. This field is read-only.
SecondsProperty | Identifies the Seconds dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker Constructor

Initializes an instance of the TimeSpanPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpanPicker()
Public Sub New
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker Properties

The TimeSpanPicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Days | Gets the days component (0 - 255) of the Value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EditableParts | Gets or sets the editable parts.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hours | Gets the hours component (0 - 23) of the Value.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Milliseconds | Gets the milliseconds component (0 - 999) of the Value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Minutes | Gets the minutes component (0 - 59) of the Value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Seconds | Gets the seconds component (0 - 59) of the Value.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.Days Property

TimeSpanPickerDays Property

Gets the days component (0 - 255) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Days { get; }
Public ReadOnly Property Days As Integer
    Get

Property Value

Type: Int32
The days component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.EditableParts Property

TimeSpanPickerEditableParts Property

Gets or sets the editable parts.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpanEditableParts EditableParts { get; set; }
Public Property EditableParts As TimeSpanEditableParts
    Get
    Set

Property Value

Type: TimeSpanEditableParts
The editable parts.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.Hours Property

TimeSpanPickerHours Property

Gets the hours component (0 - 23) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Hours { get; }
Public ReadOnly Property Hours As Integer
    Get

Property Value

Type: Int32
The hours component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.Maximum Property

TimeSpanPickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan Maximum { get; set; }
Public Property Maximum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The highest possible value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.Milliseconds Property

TimeSpanPickerMilliseconds Property

Gets the milliseconds component (0 - 999) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Milliseconds { get; }
Public ReadOnly Property Milliseconds As Integer
    Get

Property Value

Type: Int32
The milliseconds component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.Minimum Property

TimeSpanPickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan Minimum { get; set; }
Public Property Minimum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The lowest possible value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.Minutes Property

TimeSpanPickerMinutes Property

Gets the minutes component (0 - 59) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Minutes { get; }
Public ReadOnly Property Minutes As Integer
    Get

Property Value

Type: Int32
The minutes component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.Seconds Property

TimeSpanPickerSeconds Property

Gets the seconds component (0 - 59) of the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Seconds { get; }
Public ReadOnly Property Seconds As Integer
    Get

Property Value

Type: Int32
The seconds component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.SmallChange Property

TimeSpanPickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan SmallChange { get; set; }
Public Property SmallChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The small change value. The default value is 1.0.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.Value Property

TimeSpanPickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan Value { get; set; }
Public Property Value As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The value of the control.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker Methods

The TimeSpanPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.OnApplyTemplate Method

TimeSpanPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker Events

The TimeSpanPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.ValueChanged Event

TimeSpanPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker Fields

The TimeSpanPicker type exposes the following members.

Fields
Name | Description
DaysProperty | Identifies the Days dependency property. This field is read-only.
EditablePartsProperty | Identifies the EditableParts dependency property. This field is read-only.
HoursProperty | Identifies the Hours dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MillisecondsProperty | Identifies the Milliseconds dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinutesProperty | Identifies the Minutes dependency property. This field is read-only.
SecondsProperty | Identifies the Seconds dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.DaysProperty Field

TimeSpanPickerDaysProperty Field

Identifies the Days dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DaysProperty
Public Shared ReadOnly DaysProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Days dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.EditablePartsProperty Field

TimeSpanPickerEditablePartsProperty Field

Identifies the EditableParts dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EditablePartsProperty
Public Shared ReadOnly EditablePartsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EditableParts dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.HoursProperty Field

TimeSpanPickerHoursProperty Field

Identifies the Hours dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HoursProperty
Public Shared ReadOnly HoursProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hours dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.MaximumProperty Field

TimeSpanPickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.MillisecondsProperty Field

TimeSpanPickerMillisecondsProperty Field

Identifies the Milliseconds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MillisecondsProperty
Public Shared ReadOnly MillisecondsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Milliseconds dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.MinimumProperty Field

TimeSpanPickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.MinutesProperty Field

TimeSpanPickerMinutesProperty Field

Identifies the Minutes dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinutesProperty
Public Shared ReadOnly MinutesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minutes dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.SecondsProperty Field

TimeSpanPickerSecondsProperty Field

Identifies the Seconds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SecondsProperty
Public Shared ReadOnly SecondsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Seconds dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.SmallChangeProperty Field

TimeSpanPickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


TimeSpanPicker.ValueProperty Field

TimeSpanPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox Class

Represents a Vector edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase Nullable Vector
ActiproSoftware.Windows.Controls.EditorsVectorEditBox

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VectorEditBox : PartEditBoxBase<Nullable<Vector>>
Public Class VectorEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Vector))

The VectorEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | VectorEditBox | Initializes an instance of the VectorEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox Constructor

Initializes an instance of the VectorEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VectorEditBox()
Public Sub New
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox Properties

The VectorEditBox type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets or sets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control. (Inherited from PartEditBoxBaseT.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect. (Inherited from PartEditBoxBaseT.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxBaseT.)
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance. (Inherited from PartEditBoxBaseT.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.DefaultValue Property

VectorEditBoxDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector DefaultValue { get; set; }
Public Property DefaultValue As Vector
    Get
    Set

Property Value

Type: Vector
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.Format Property

VectorEditBoxFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.IsNaNAllowed Property

VectorEditBoxIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.IsNegativeInfinityAllowed Property

VectorEditBoxIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.IsPositiveInfinityAllowed Property

VectorEditBoxIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.LargeChange Property

VectorEditBoxLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector LargeChange { get; set; }
Public Property LargeChange As Vector
    Get
    Set

Property Value

Type: Vector
The large change value. The default value is 5.0.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.Maximum Property

VectorEditBoxMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector Maximum { get; set; }
Public Property Maximum As Vector
    Get
    Set

Property Value

Type: Vector
The highest possible value.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.Minimum Property

VectorEditBoxMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector Minimum { get; set; }
Public Property Minimum As Vector
    Get
    Set

Property Value

Type: Vector
The lowest possible value.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.ResolvedFormat Property

VectorEditBoxResolvedFormat Property

Gets the resolved number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.RoundingDecimalPlace Property

VectorEditBoxRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.SmallChange Property

VectorEditBoxSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector SmallChange { get; set; }
Public Property SmallChange As Vector
    Get
    Set

Property Value

Type: Vector
The small change value. The default value is 1.0.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox Methods

The VectorEditBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range. (Overrides PartEditBoxBaseTCoerceValidValue(T).)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Inherited from PartEditBoxBaseT.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnPopupOpened | Occurs when the popup is opened. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Inherited from PartEditBoxBaseT.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Inherited from PartEditBoxBaseT.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.CoerceValidValue Method

VectorEditBoxCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Vector> CoerceValidValue(
    Nullable<Vector> value
)
Protected Overrides Function CoerceValidValue (
    value As Nullable(Of Vector)
) As Nullable(Of Vector)

Parameters

value
Type: SystemNullable Vector
The value to coerce.

Return Value

Type: Nullable Vector
The coerced value.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.ConvertToString Method

VectorEditBoxConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Vector> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Vector)
) As String

Parameters

valueToConvert
Type: SystemNullable Vector
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.CreateIncrementalChangeRequest Method

VectorEditBoxCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Vector>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Vector))

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Vector
The incremental change (spin) request that was created.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.GenerateParts Method

VectorEditBoxGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.IsValidValue Method

VectorEditBoxIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Vector> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Vector)
) As Boolean

Parameters

value
Type: SystemNullable Vector
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.ProcessTextInput Method

VectorEditBoxProcessTextInput Method

Processes typed text.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.RaiseValueChangedEvent Method

VectorEditBoxRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.ResetValue Method

VectorEditBoxResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.TryConvertFromString Method

VectorEditBoxTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Vector> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Vector)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Vector
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox Events

The VectorEditBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.ValueChanged Event

VectorEditBoxValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox Fields

The VectorEditBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.DefaultValueProperty Field

VectorEditBoxDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.FormatProperty Field

VectorEditBoxFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.IsNaNAllowedProperty Field

VectorEditBoxIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.IsNegativeInfinityAllowedProperty Field

VectorEditBoxIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.IsPositiveInfinityAllowedProperty Field

VectorEditBoxIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.LargeChangeProperty Field

VectorEditBoxLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.MaximumProperty Field

VectorEditBoxMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.MinimumProperty Field

VectorEditBoxMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.ResolvedFormatProperty Field

VectorEditBoxResolvedFormatProperty Field

Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.RoundingDecimalPlaceProperty Field

VectorEditBoxRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorEditBox.SmallChangeProperty Field

VectorEditBoxSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

VectorEditBox Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker Class

Represents a Vector picker.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsVectorPicker

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VectorPicker : PickerBase
Public Class VectorPicker
    Inherits PickerBase

The VectorPicker type exposes the following members.

Constructors
 | Name | Description
Public method | VectorPicker | Initializes an instance of the VectorPicker class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker Constructor

Initializes an instance of the VectorPicker class.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VectorPicker()
Public Sub New
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker Properties

The VectorPicker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.Maximum Property

VectorPickerMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector Maximum { get; set; }
Public Property Maximum As Vector
    Get
    Set

Property Value

Type: Vector
The highest possible value.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.Minimum Property

VectorPickerMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector Minimum { get; set; }
Public Property Minimum As Vector
    Get
    Set

Property Value

Type: Vector
The lowest possible value.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.RoundingDecimalPlace Property

VectorPickerRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.SmallChange Property

VectorPickerSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector SmallChange { get; set; }
Public Property SmallChange As Vector
    Get
    Set

Property Value

Type: Vector
The small change value. The default value is 1.0.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.Value Property

VectorPickerValue Property

Gets or sets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector Value { get; set; }
Public Property Value As Vector
    Get
    Set

Property Value

Type: Vector
The value of the control.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker Methods

The VectorPicker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.OnApplyTemplate Method

VectorPickerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker Events

The VectorPicker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.ValueChanged Event

VectorPickerValueChanged Event

Occurs after the Value property value changes.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker Fields

The VectorPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.MaximumProperty Field

VectorPickerMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.MinimumProperty Field

VectorPickerMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.RoundingDecimalPlaceProperty Field

VectorPickerRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.SmallChangeProperty Field

VectorPickerSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


VectorPicker.ValueProperty Field

VectorPickerValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

VectorPicker Class
ActiproSoftware.Windows.Controls.Editors Namespace


ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace

Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | AutoCompleteBoxAutomationPeer | Exposes AutoCompleteBox types to UI Automation.
Public class | CalculatorAutomationPeer | Exposes Calculator types to UI Automation.
Public class | GradientStopSliderAutomationPeer | Exposes GradientStopSlider types to UI Automation.
Public class | HueRingAutomationPeer | Exposes HueRing types to UI Automation.
Public class | MonthCalendarAutomationPeer | Exposes MonthCalendar types to UI Automation.
Public class | PartEditBoxBaseAutomationPeerT | Exposes PartEditBoxBaseT types to UI Automation.
Public class | PickerBaseAutomationPeer | Exposes PickerBase types to UI Automation.
Public class | RadialHuePickerAutomationPeer | Exposes RadialHuePicker types to UI Automation.
Public class | RatingAutomationPeer | Exposes Rating types to UI Automation.
Public class | SaturationBrightnessPickerAutomationPeer | Exposes SaturationBrightnessPicker types to UI Automation.


AutoCompleteBoxAutomationPeer Class

Exposes AutoCompleteBox types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersAutoCompleteBoxAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutoCompleteBoxAutomationPeer : FrameworkElementAutomationPeer,
    IExpandCollapseProvider, IValueProvider
Public Class AutoCompleteBoxAutomationPeer
    Inherits FrameworkElementAutomationPeer
    Implements IExpandCollapseProvider, IValueProvider

The AutoCompleteBoxAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AutoCompleteBoxAutomationPeer | Initializes a new instance of the AutoCompleteBoxAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | IsReadOnly | Gets a value that indicates whether the value of a control is read-only.
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public property | Value | Gets the value of the control.
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Expand | Displays all child nodes, controls, or content of the control.
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | SetValue | Sets the value of a control.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer Constructor

Initializes a new instance of the AutoCompleteBoxAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutoCompleteBoxAutomationPeer(
    AutoCompleteBox owner
)
Public Sub New (
    owner As AutoCompleteBox
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.EditorsAutoCompleteBox
The owner element.
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer Properties

The AutoCompleteBoxAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | IsReadOnly | Gets a value that indicates whether the value of a control is read-only.
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public property | Value | Gets the value of the control.
Top
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.ExpandCollapseState Property

AutoCompleteBoxAutomationPeerExpandCollapseState Property

Gets the state, expanded or collapsed, of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpandCollapseState ExpandCollapseState { get; }
Public ReadOnly Property ExpandCollapseState As ExpandCollapseState
    Get

Property Value

Type: ExpandCollapseState

Return Value

Type: ExpandCollapseState
The state, expanded or collapsed, of the control.

Implements

IExpandCollapseProviderExpandCollapseState
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.IsReadOnly Property

AutoCompleteBoxAutomationPeerIsReadOnly Property

Gets a value that indicates whether the value of a control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the value is read-only; false if it can be modified.

Implements

IValueProviderIsReadOnly
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.Value Property

AutoCompleteBoxAutomationPeerValue Property

Gets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Value { get; }
Public ReadOnly Property Value As String
    Get

Property Value

Type: String
The value of the control.

Implements

IValueProviderValue
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer Methods

The AutoCompleteBoxAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Expand | Displays all child nodes, controls, or content of the control.
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | SetValue | Sets the value of a control.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.Collapse Method

AutoCompleteBoxAutomationPeerCollapse Method

Hides all nodes, controls, or content that are descendants of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Collapse()
Public Sub Collapse

Implements

IExpandCollapseProviderCollapse
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.Expand Method

AutoCompleteBoxAutomationPeerExpand Method

Displays all child nodes, controls, or content of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Expand()
Public Sub Expand

Implements

IExpandCollapseProviderExpand
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.GetAutomationControlTypeCore Method

AutoCompleteBoxAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.GetClassNameCore Method

AutoCompleteBoxAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.GetLocalizedControlTypeCore Method

AutoCompleteBoxAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.GetPattern Method

AutoCompleteBoxAutomationPeerGetPattern Method

Gets the control pattern that is associated with the specified PatternInterface.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value from the PatternInterface enumeration.

Return Value

Type: Object
The object that implements the pattern interface; if the peer does not support this interface.
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


AutoCompleteBoxAutomationPeer.SetValue Method

AutoCompleteBoxAutomationPeerSetValue Method

Sets the value of a control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SetValue(
    string value
)
Public Sub SetValue (
    value As String
)

Parameters

value
Type: SystemString
The value to set. The provider is responsible for converting the value to the appropriate data type.

Implements

IValueProviderSetValue(String)
See Also

Reference

AutoCompleteBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer Class

Exposes Calculator types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersCalculatorAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CalculatorAutomationPeer : FrameworkElementAutomationPeer
Public Class CalculatorAutomationPeer
    Inherits FrameworkElementAutomationPeer

The CalculatorAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | CalculatorAutomationPeer | Initializes a new instance of the CalculatorAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer Constructor

Initializes a new instance of the CalculatorAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CalculatorAutomationPeer(
    Calculator owner
)
Public Sub New (
    owner As Calculator
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.EditorsCalculator
The owner element.
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer Properties

The CalculatorAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer Methods

The CalculatorAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer.GetAutomationControlTypeCore Method

CalculatorAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer.GetClassNameCore Method

CalculatorAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer.GetLocalizedControlTypeCore Method

CalculatorAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer Class

Exposes GradientStopSlider types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersGradientStopSliderAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GradientStopSliderAutomationPeer : FrameworkElementAutomationPeer
Public Class GradientStopSliderAutomationPeer
    Inherits FrameworkElementAutomationPeer

The GradientStopSliderAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | GradientStopSliderAutomationPeer | Initializes a new instance of the GradientStopSliderAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer Constructor

Initializes a new instance of the GradientStopSliderAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientStopSliderAutomationPeer(
    GradientStopSlider owner
)
Public Sub New (
    owner As GradientStopSlider
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.EditorsGradientStopSlider
The owner element.
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer Properties

The GradientStopSliderAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer Methods

The GradientStopSliderAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer.GetAutomationControlTypeCore Method

GradientStopSliderAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer.GetClassNameCore Method

GradientStopSliderAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer.GetLocalizedControlTypeCore Method

GradientStopSliderAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer Class

Exposes HueRing types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersHueRingAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class HueRingAutomationPeer : FrameworkElementAutomationPeer
Public Class HueRingAutomationPeer
    Inherits FrameworkElementAutomationPeer

The HueRingAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | HueRingAutomationPeer | Initializes a new instance of the HueRingAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer Constructor

Initializes a new instance of the HueRingAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public HueRingAutomationPeer(
    HueRing owner
)
Public Sub New (
    owner As HueRing
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesHueRing
The owner element.
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer Properties

The HueRingAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer Methods

The HueRingAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer.GetAutomationControlTypeCore Method

HueRingAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer.GetClassNameCore Method

HueRingAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer.GetLocalizedControlTypeCore Method

HueRingAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer Class

Exposes MonthCalendar types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersMonthCalendarAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MonthCalendarAutomationPeer : FrameworkElementAutomationPeer
Public Class MonthCalendarAutomationPeer
    Inherits FrameworkElementAutomationPeer

The MonthCalendarAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | MonthCalendarAutomationPeer | Initializes a new instance of the MonthCalendarAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer Constructor

Initializes a new instance of the MonthCalendarAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MonthCalendarAutomationPeer(
    MonthCalendar owner
)
Public Sub New (
    owner As MonthCalendar
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.EditorsMonthCalendar
The owner element.
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer Properties

The MonthCalendarAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer Methods

The MonthCalendarAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer.GetAutomationControlTypeCore Method

MonthCalendarAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer.GetClassNameCore Method

MonthCalendarAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer.GetLocalizedControlTypeCore Method

MonthCalendarAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T) Class

PartEditBoxBaseAutomationPeerT Class

Exposes PartEditBoxBaseT types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersPartEditBoxBaseAutomationPeerT

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PartEditBoxBaseAutomationPeer<T> : FrameworkElementAutomationPeer,
    IExpandCollapseProvider, IValueProvider, IToggleProvider

Public Class PartEditBoxBaseAutomationPeer(Of T)
    Inherits FrameworkElementAutomationPeer
    Implements IExpandCollapseProvider, IValueProvider, IToggleProvider

Type Parameters

T
The type of value being edited.

The PartEditBoxBaseAutomationPeerT type exposes the following members.

Constructors
 | Name | Description
Public method | PartEditBoxBaseAutomationPeerT | Initializes a new instance of the PartEditBoxBaseAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | IsReadOnly | Gets a value that indicates whether the value of a control is read-only.
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public property | ToggleState | Gets whether the control is toggled.
Public property | Value | Gets the value of the control.
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Expand | Displays all child nodes, controls, or content of the control.
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | SetValue | Sets the value of a control.
Public method | Toggle | Toggles the control's state.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T) Constructor

PartEditBoxBaseAutomationPeerT Constructor

Initializes a new instance of the PartEditBoxBaseAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PartEditBoxBaseAutomationPeer(
    PartEditBoxBase<T> owner
)
Public Sub New (
    owner As PartEditBoxBase(Of T)
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBase T
The owner element.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T) Properties

PartEditBoxBaseAutomationPeerT Properties

The PartEditBoxBaseAutomationPeerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | IsReadOnly | Gets a value that indicates whether the value of a control is read-only.
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public property | ToggleState | Gets whether the control is toggled.
Public property | Value | Gets the value of the control.
Top
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).ExpandCollapseState Property

PartEditBoxBaseAutomationPeerTExpandCollapseState Property

Gets the state, expanded or collapsed, of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpandCollapseState ExpandCollapseState { get; }
Public ReadOnly Property ExpandCollapseState As ExpandCollapseState
    Get

Property Value

Type: ExpandCollapseState

Return Value

Type: ExpandCollapseState
The state, expanded or collapsed, of the control.

Implements

IExpandCollapseProviderExpandCollapseState
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).IsReadOnly Property

PartEditBoxBaseAutomationPeerTIsReadOnly Property

Gets a value that indicates whether the value of a control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the value is read-only; false if it can be modified.

Implements

IValueProviderIsReadOnly
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).ToggleState Property

PartEditBoxBaseAutomationPeerTToggleState Property

Gets whether the control is toggled.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToggleState ToggleState { get; }
Public ReadOnly Property ToggleState As ToggleState
    Get

Property Value

Type: ToggleState
true if the control is toggled; otherwise, false.

Implements

IToggleProviderToggleState
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).Value Property

PartEditBoxBaseAutomationPeerTValue Property

Gets the value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Value { get; }
Public ReadOnly Property Value As String
    Get

Property Value

Type: String
The value of the control.

Implements

IValueProviderValue
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T) Methods

PartEditBoxBaseAutomationPeerT Methods

The PartEditBoxBaseAutomationPeerT generic type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Expand | Displays all child nodes, controls, or content of the control.
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | SetValue | Sets the value of a control.
Public method | Toggle | Toggles the control's state.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).Collapse Method

PartEditBoxBaseAutomationPeerTCollapse Method

Hides all nodes, controls, or content that are descendants of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Collapse()
Public Sub Collapse

Implements

IExpandCollapseProviderCollapse
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).Expand Method

PartEditBoxBaseAutomationPeerTExpand Method

Displays all child nodes, controls, or content of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Expand()
Public Sub Expand

Implements

IExpandCollapseProviderExpand
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).GetAutomationControlTypeCore Method

PartEditBoxBaseAutomationPeerTGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).GetClassNameCore Method

PartEditBoxBaseAutomationPeerTGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).GetLocalizedControlTypeCore Method

PartEditBoxBaseAutomationPeerTGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).GetPattern Method

PartEditBoxBaseAutomationPeerTGetPattern Method

Gets the control pattern that is associated with the specified PatternInterface.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value from the PatternInterface enumeration.

Return Value

Type: Object
The object that implements the pattern interface; if the peer does not support this interface.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).SetValue Method

PartEditBoxBaseAutomationPeerTSetValue Method

Sets the value of a control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SetValue(
    string value
)
Public Sub SetValue (
    value As String
)

Parameters

value
Type: SystemString
The value to set. The provider is responsible for converting the value to the appropriate data type.

Implements

IValueProviderSetValue(String)
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).Toggle Method

PartEditBoxBaseAutomationPeerTToggle Method

Toggles the control's state.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Toggle()
Public Sub Toggle

Implements

IToggleProviderToggle
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer Class

Exposes PickerBase types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersPickerBaseAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PickerBaseAutomationPeer : FrameworkElementAutomationPeer
Public Class PickerBaseAutomationPeer
    Inherits FrameworkElementAutomationPeer

The PickerBaseAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | PickerBaseAutomationPeer | Initializes a new instance of the PickerBaseAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer Constructor

Initializes a new instance of the PickerBaseAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PickerBaseAutomationPeer(
    PickerBase owner
)
Public Sub New (
    owner As PickerBase
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
The owner element.
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer Properties

The PickerBaseAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer Methods

The PickerBaseAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer.GetAutomationControlTypeCore Method

PickerBaseAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer.GetClassNameCore Method

PickerBaseAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer.GetLocalizedControlTypeCore Method

PickerBaseAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer Class

Exposes RadialHuePicker types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersRadialHuePickerAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RadialHuePickerAutomationPeer : FrameworkElementAutomationPeer
Public Class RadialHuePickerAutomationPeer
    Inherits FrameworkElementAutomationPeer

The RadialHuePickerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | RadialHuePickerAutomationPeer | Initializes a new instance of the RadialHuePickerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer Constructor

Initializes a new instance of the RadialHuePickerAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RadialHuePickerAutomationPeer(
    RadialHuePicker owner
)
Public Sub New (
    owner As RadialHuePicker
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.EditorsRadialHuePicker
The owner element.
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer Properties

The RadialHuePickerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer Methods

The RadialHuePickerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer.GetAutomationControlTypeCore Method

RadialHuePickerAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer.GetClassNameCore Method

RadialHuePickerAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer.GetLocalizedControlTypeCore Method

RadialHuePickerAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer Class

Exposes Rating types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersRatingAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RatingAutomationPeer : FrameworkElementAutomationPeer
Public Class RatingAutomationPeer
    Inherits FrameworkElementAutomationPeer

The RatingAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | RatingAutomationPeer | Initializes a new instance of the RatingAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer Constructor

Initializes a new instance of the RatingAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RatingAutomationPeer(
    Rating owner
)
Public Sub New (
    owner As Rating
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.EditorsRating
The owner element.
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer Properties

The RatingAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer Methods

The RatingAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer.GetAutomationControlTypeCore Method

RatingAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer.GetClassNameCore Method

RatingAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer.GetLocalizedControlTypeCore Method

RatingAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer Class

Exposes SaturationBrightnessPicker types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Editors.Automation.PeersSaturationBrightnessPickerAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SaturationBrightnessPickerAutomationPeer : FrameworkElementAutomationPeer
Public Class SaturationBrightnessPickerAutomationPeer
    Inherits FrameworkElementAutomationPeer

The SaturationBrightnessPickerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | SaturationBrightnessPickerAutomationPeer | Initializes a new instance of the SaturationBrightnessPickerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer Constructor

Initializes a new instance of the SaturationBrightnessPickerAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SaturationBrightnessPickerAutomationPeer(
    SaturationBrightnessPicker owner
)
Public Sub New (
    owner As SaturationBrightnessPicker
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.EditorsSaturationBrightnessPicker
The owner element.
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer Properties

The SaturationBrightnessPickerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer Methods

The SaturationBrightnessPickerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer.GetAutomationControlTypeCore Method

SaturationBrightnessPickerAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer.GetClassNameCore Method

SaturationBrightnessPickerAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer.GetLocalizedControlTypeCore Method

SaturationBrightnessPickerAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Automation.Peers
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.Windows.Controls.Editors.Automation.Peers Namespace


ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace

Contains classes that support integration of Editors with DataGrid.
Classes
 | Class | Description
Public class | DataGridBrushColumn | Represents a data-bound column for use in a DataGrid that utilizes the BrushEditBox control.
Public class | DataGridByteColumn | Represents a data-bound column for use in a DataGrid that utilizes the ByteEditBox control.
Public class | DataGridColorColumn | Represents a data-bound column for use in a DataGrid that utilizes the ColorEditBox control.
Public class | DataGridCornerRadiusColumn | Represents a data-bound column for use in a DataGrid that utilizes the CornerRadiusEditBox control.
Public class | DataGridDateColumn | Represents a data-bound column for use in a DataGrid that utilizes the DateEditBox control.
Public class | DataGridDateTimeColumn | Represents a data-bound column for use in a DataGrid that utilizes the DateTimeEditBox control.
Public class | DataGridDoubleColumn | Represents a data-bound column for use in a DataGrid that utilizes the DoubleEditBox control.
Public class | DataGridEnumColumn | Represents a data-bound column for use in a DataGrid that utilizes the EnumEditBox control.
Public class | DataGridGuidColumn | Represents a data-bound column for use in a DataGrid that utilizes the GuidEditBox control.
Public class | DataGridInt16Column | Represents a data-bound column for use in a DataGrid that utilizes the Int16EditBox control.
Public class | DataGridInt32Column | Represents a data-bound column for use in a DataGrid that utilizes the Int32EditBox control.
Public class | DataGridInt32RectColumn | Represents a data-bound column for use in a DataGrid that utilizes the Int32RectEditBox control.
Public class | DataGridInt64Column | Represents a data-bound column for use in a DataGrid that utilizes the Int64EditBox control.
Public class | DataGridMaskedStringColumn | Represents a base class for data-bound columns for use in a DataGrid that utilize MaskedTextBox controls.
Public class | DataGridPointColumn | Represents a data-bound column for use in a DataGrid that utilizes the PointEditBox control.
Public class | DataGridRectColumn | Represents a data-bound column for use in a DataGrid that utilizes the RectEditBox control.
Public class | DataGridSingleColumn | Represents a data-bound column for use in a DataGrid that utilizes the SingleEditBox control.
Public class | DataGridSizeColumn | Represents a data-bound column for use in a DataGrid that utilizes the SizeEditBox control.
Public class | DataGridThicknessColumn | Represents a data-bound column for use in a DataGrid that utilizes the ThicknessEditBox control.
Public class | DataGridTimeColumn | Represents a data-bound column for use in a DataGrid that utilizes the TimeEditBox control.
Public class | DataGridTimeSpanColumn | Represents a data-bound column for use in a DataGrid that utilizes the TimeSpanEditBox control.
Public class | DataGridVectorColumn | Represents a data-bound column for use in a DataGrid that utilizes the VectorEditBox control.


DataGridBrushColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the BrushEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Brush
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridBrushColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridBrushColumn : DataGridPartEditBoxColumnBase<Brush>
Public Class DataGridBrushColumn
    Inherits DataGridPartEditBoxColumnBase(Of Brush)

The DataGridBrushColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridBrushColumn | Initializes an instance of the DataGridBrushColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn Constructor

Initializes an instance of the DataGridBrushColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridBrushColumn()
Public Sub New
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn Properties

The DataGridBrushColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn.HasSwatch Property

DataGridBrushColumnHasSwatch Property

Gets or sets whether the edit box should display a swatch that previews the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box should display a swatch that previews the Value; otherwise, false. The default value is true.
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn.IsAlphaEnabled Property

DataGridBrushColumnIsAlphaEnabled Property

Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the brush value colors is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn.IsGradientAllowed Property

DataGridBrushColumnIsGradientAllowed Property

Gets or sets whether gradient brush values can be entered.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGradientAllowed { get; set; }
Public Property IsGradientAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if gradient brush values can be entered; otherwise, false. The default value is true.
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn Methods

The DataGridBrushColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn.ApplyStandardValues Method

DataGridBrushColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn.GetEditBoxType Method

DataGridBrushColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn Events

The DataGridBrushColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn Fields

The DataGridBrushColumn type exposes the following members.

Fields
Name | Description
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
Top
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn.HasSwatchProperty Field

DataGridBrushColumnHasSwatchProperty Field

Identifies the HasSwatch dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasSwatchProperty
Public Shared ReadOnly HasSwatchProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasSwatch dependency property.
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn.IsAlphaEnabledProperty Field

DataGridBrushColumnIsAlphaEnabledProperty Field

Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridBrushColumn.IsGradientAllowedProperty Field

DataGridBrushColumnIsGradientAllowedProperty Field

Identifies the IsGradientAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGradientAllowedProperty
Public Shared ReadOnly IsGradientAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGradientAllowed dependency property.
See Also

Reference

DataGridBrushColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the ByteEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Byte
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridByteColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridByteColumn : DataGridPartEditBoxColumnBase<Nullable<byte>>
Public Class DataGridByteColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Byte))

The DataGridByteColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridByteColumn | Initializes an instance of the DataGridByteColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn Constructor

Initializes an instance of the DataGridByteColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridByteColumn()
Public Sub New
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn Properties

The DataGridByteColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.DefaultValue Property

DataGridByteColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte DefaultValue { get; set; }
Public Property DefaultValue As Byte
    Get
    Set

Property Value

Type: Byte
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.Format Property

DataGridByteColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.LargeChange Property

DataGridByteColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte LargeChange { get; set; }
Public Property LargeChange As Byte
    Get
    Set

Property Value

Type: Byte
The large change value. The default value is 5.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.Maximum Property

DataGridByteColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte Maximum { get; set; }
Public Property Maximum As Byte
    Get
    Set

Property Value

Type: Byte
The highest possible value.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.Minimum Property

DataGridByteColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte Minimum { get; set; }
Public Property Minimum As Byte
    Get
    Set

Property Value

Type: Byte
The lowest possible value.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.PickerKind Property

DataGridByteColumnPickerKind Property

Gets or sets an ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ByteEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As ByteEditBoxPickerKind
    Get
    Set

Property Value

Type: ByteEditBoxPickerKind
An ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.SmallChange Property

DataGridByteColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte SmallChange { get; set; }
Public Property SmallChange As Byte
    Get
    Set

Property Value

Type: Byte
The small change value. The default value is 1.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn Methods

The DataGridByteColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.ApplyStandardValues Method

DataGridByteColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.GetEditBoxType Method

DataGridByteColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn Events

The DataGridByteColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn Fields

The DataGridByteColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.DefaultValueProperty Field

DataGridByteColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.FormatProperty Field

DataGridByteColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.LargeChangeProperty Field

DataGridByteColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.MaximumProperty Field

DataGridByteColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.MinimumProperty Field

DataGridByteColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.PickerKindProperty Field

DataGridByteColumnPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridByteColumn.SmallChangeProperty Field

DataGridByteColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridByteColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the ColorEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Color
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridColorColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridColorColumn : DataGridPartEditBoxColumnBase<Nullable<Color>>
Public Class DataGridColorColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Color))

The DataGridColorColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridColorColumn | Initializes an instance of the DataGridColorColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn Constructor

Initializes an instance of the DataGridColorColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridColorColumn()
Public Sub New
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn Properties

The DataGridColorColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn.DefaultValue Property

DataGridColorColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color DefaultValue { get; set; }
Public Property DefaultValue As Color
    Get
    Set

Property Value

Type: Color
The value to set when incrementing/decrementing from a null value. The default value is Red.
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn.HasSwatch Property

DataGridColorColumnHasSwatch Property

Gets or sets whether the edit box should display a swatch that previews the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box should display a swatch that previews the Value; otherwise, false. The default value is true.
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn.IsAlphaEnabled Property

DataGridColorColumnIsAlphaEnabled Property

Gets or sets whether the alpha channel (transparency) of the color value is enabled.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the color value is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn Methods

The DataGridColorColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn.ApplyStandardValues Method

DataGridColorColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn.GetEditBoxType Method

DataGridColorColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn Events

The DataGridColorColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn Fields

The DataGridColorColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
Top
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn.DefaultValueProperty Field

DataGridColorColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn.HasSwatchProperty Field

DataGridColorColumnHasSwatchProperty Field

Identifies the HasSwatch dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasSwatchProperty
Public Shared ReadOnly HasSwatchProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasSwatch dependency property.
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridColorColumn.IsAlphaEnabledProperty Field

DataGridColorColumnIsAlphaEnabledProperty Field

Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

DataGridColorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the CornerRadiusEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable CornerRadius
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridCornerRadiusColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridCornerRadiusColumn : DataGridPartEditBoxColumnBase<Nullable<CornerRadius>>
Public Class DataGridCornerRadiusColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of CornerRadius))

The DataGridCornerRadiusColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridCornerRadiusColumn | Initializes an instance of the DataGridCornerRadiusColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn Constructor

Initializes an instance of the DataGridCornerRadiusColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridCornerRadiusColumn()
Public Sub New
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn Properties

The DataGridCornerRadiusColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.DefaultValue Property

DataGridCornerRadiusColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius DefaultValue { get; set; }
Public Property DefaultValue As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.Format Property

DataGridCornerRadiusColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.IsNaNAllowed Property

DataGridCornerRadiusColumnIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.IsNegativeInfinityAllowed Property

DataGridCornerRadiusColumnIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.IsPositiveInfinityAllowed Property

DataGridCornerRadiusColumnIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.LargeChange Property

DataGridCornerRadiusColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius LargeChange { get; set; }
Public Property LargeChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The large change value. The default value is 5.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.Maximum Property

DataGridCornerRadiusColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius Maximum { get; set; }
Public Property Maximum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The highest possible value.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.Minimum Property

DataGridCornerRadiusColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius Minimum { get; set; }
Public Property Minimum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The lowest possible value.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.RoundingDecimalPlace Property

DataGridCornerRadiusColumnRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.SmallChange Property

DataGridCornerRadiusColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius SmallChange { get; set; }
Public Property SmallChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The small change value. The default value is 1.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn Methods

The DataGridCornerRadiusColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.ApplyStandardValues Method

DataGridCornerRadiusColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.GetEditBoxType Method

DataGridCornerRadiusColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn Events

The DataGridCornerRadiusColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn Fields

The DataGridCornerRadiusColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.DefaultValueProperty Field

DataGridCornerRadiusColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.FormatProperty Field

DataGridCornerRadiusColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.IsNaNAllowedProperty Field

DataGridCornerRadiusColumnIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.IsNegativeInfinityAllowedProperty Field

DataGridCornerRadiusColumnIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.IsPositiveInfinityAllowedProperty Field

DataGridCornerRadiusColumnIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.LargeChangeProperty Field

DataGridCornerRadiusColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.MaximumProperty Field

DataGridCornerRadiusColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.MinimumProperty Field

DataGridCornerRadiusColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.RoundingDecimalPlaceProperty Field

DataGridCornerRadiusColumnRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridCornerRadiusColumn.SmallChangeProperty Field

DataGridCornerRadiusColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridCornerRadiusColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the DateEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable DateTime
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridDateTimeColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridDateColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridDateColumn : DataGridDateTimeColumn
Public Class DataGridDateColumn
    Inherits DataGridDateTimeColumn

The DataGridDateColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridDateColumn | Initializes an instance of the DataGridDateColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DataGridDateTimeColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DataGridDateTimeColumn.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DataGridDateTimeColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Inherited from DataGridDateTimeColumn.)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridDateTimeColumnGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateColumn Constructor

Initializes an instance of the DataGridDateColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridDateColumn()
Public Sub New
See Also

Reference

DataGridDateColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateColumn Properties

The DataGridDateColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DataGridDateTimeColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DataGridDateTimeColumn.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DataGridDateTimeColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridDateColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateColumn Methods

The DataGridDateColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Inherited from DataGridDateTimeColumn.)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridDateTimeColumnGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridDateColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateColumn.GetEditBoxType Method

DataGridDateColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridDateColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateColumn Events

The DataGridDateColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridDateColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the DateTimeEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable DateTime
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridDateTimeColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridDateColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridTimeColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridDateTimeColumn : DataGridPartEditBoxColumnBase<Nullable<DateTime>>
Public Class DataGridDateTimeColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of DateTime))

The DataGridDateTimeColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridDateTimeColumn | Initializes an instance of the DataGridDateTimeColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the date/time format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn Constructor

Initializes an instance of the DataGridDateTimeColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridDateTimeColumn()
Public Sub New
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn Properties

The DataGridDateTimeColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the date/time format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn.Format Property

DataGridDateTimeColumnFormat Property

Gets or sets the date/time format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The date/time format string. The default value is "g".
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn.Maximum Property

DataGridDateTimeColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn.Minimum Property

DataGridDateTimeColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn Methods

The DataGridDateTimeColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn.ApplyStandardValues Method

DataGridDateTimeColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn.GetEditBoxType Method

DataGridDateTimeColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn Events

The DataGridDateTimeColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn Fields

The DataGridDateTimeColumn type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
Top
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn.FormatProperty Field

DataGridDateTimeColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn.MaximumProperty Field

DataGridDateTimeColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDateTimeColumn.MinimumProperty Field

DataGridDateTimeColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridDateTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the DoubleEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Double
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridDoubleColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridDoubleColumn : DataGridPartEditBoxColumnBase<Nullable<double>>
Public Class DataGridDoubleColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Double))

The DataGridDoubleColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridDoubleColumn | Initializes an instance of the DataGridDoubleColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn Constructor

Initializes an instance of the DataGridDoubleColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridDoubleColumn()
Public Sub New
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn Properties

The DataGridDoubleColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.DefaultValue Property

DataGridDoubleColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DefaultValue { get; set; }
Public Property DefaultValue As Double
    Get
    Set

Property Value

Type: Double
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.Format Property

DataGridDoubleColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.IsNaNAllowed Property

DataGridDoubleColumnIsNaNAllowed Property

Gets or sets whether NaN is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.IsNegativeInfinityAllowed Property

DataGridDoubleColumnIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.IsPositiveInfinityAllowed Property

DataGridDoubleColumnIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.LargeChange Property

DataGridDoubleColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LargeChange { get; set; }
Public Property LargeChange As Double
    Get
    Set

Property Value

Type: Double
The large change value. The default value is 5.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.Maximum Property

DataGridDoubleColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible value.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.Minimum Property

DataGridDoubleColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible value.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.PickerKind Property

DataGridDoubleColumnPickerKind Property

Gets or sets an DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As DoubleEditBoxPickerKind
    Get
    Set

Property Value

Type: DoubleEditBoxPickerKind
An DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.RoundingDecimalPlace Property

DataGridDoubleColumnRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.SmallChange Property

DataGridDoubleColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SmallChange { get; set; }
Public Property SmallChange As Double
    Get
    Set

Property Value

Type: Double
The small change value. The default value is 1.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn Methods

The DataGridDoubleColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.ApplyStandardValues Method

DataGridDoubleColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.GetEditBoxType Method

DataGridDoubleColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn Events

The DataGridDoubleColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn Fields

The DataGridDoubleColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.DefaultValueProperty Field

DataGridDoubleColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.FormatProperty Field

DataGridDoubleColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.IsNaNAllowedProperty Field

DataGridDoubleColumnIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.IsNegativeInfinityAllowedProperty Field

DataGridDoubleColumnIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.IsPositiveInfinityAllowedProperty Field

DataGridDoubleColumnIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.LargeChangeProperty Field

DataGridDoubleColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.MaximumProperty Field

DataGridDoubleColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.MinimumProperty Field

DataGridDoubleColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.PickerKindProperty Field

DataGridDoubleColumnPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.RoundingDecimalPlaceProperty Field

DataGridDoubleColumnRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridDoubleColumn.SmallChangeProperty Field

DataGridDoubleColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridDoubleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the EnumEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Object
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridEnumColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridEnumColumn : DataGridPartEditBoxColumnBase<Object>
Public Class DataGridEnumColumn
    Inherits DataGridPartEditBoxColumnBase(Of Object)

The DataGridEnumColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridEnumColumn | Initializes an instance of the DataGridEnumColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn Constructor

Initializes an instance of the DataGridEnumColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridEnumColumn()
Public Sub New
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn Properties

The DataGridEnumColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn.EnumSortComparer Property

DataGridEnumColumnEnumSortComparer Property

Gets or sets the IComparerT used to sort the enumeration values.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IComparer<Enum> EnumSortComparer { get; set; }
Public Property EnumSortComparer As IComparer(Of Enum)
    Get
    Set

Property Value

Type: IComparer Enum
The IComparerT used to sort the enumeration values; otherwise to indicate no sorting, which will use the order the enumeration values are defined.
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn.EnumType Property

DataGridEnumColumnEnumType Property

Gets or sets the enumeration type.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type EnumType { get; set; }
Public Property EnumType As Type
    Get
    Set

Property Value

Type: Type
The enumeration type.
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn.UseDisplayAttributes Property

DataGridEnumColumnUseDisplayAttributes Property

Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseDisplayAttributes { get; set; }
Public Property UseDisplayAttributes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if enumeration values should be displayed using an associated DisplayAttribute, if any; otherwise false. The default value is false.
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn Methods

The DataGridEnumColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn.ApplyStandardValues Method

DataGridEnumColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn.GetEditBoxType Method

DataGridEnumColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn Events

The DataGridEnumColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn Fields

The DataGridEnumColumn type exposes the following members.

Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn.EnumSortComparerProperty Field

DataGridEnumColumnEnumSortComparerProperty Field

Identifies the EnumSortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumSortComparerProperty
Public Shared ReadOnly EnumSortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumSortComparer dependency property.
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn.EnumTypeProperty Field

DataGridEnumColumnEnumTypeProperty Field

Identifies the EnumType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumTypeProperty
Public Shared ReadOnly EnumTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumType dependency property.
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridEnumColumn.UseDisplayAttributesProperty Field

DataGridEnumColumnUseDisplayAttributesProperty Field

Identifies the UseDisplayAttributes dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDisplayAttributesProperty
Public Shared ReadOnly UseDisplayAttributesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDisplayAttributes dependency property.
See Also

Reference

DataGridEnumColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the GuidEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Guid
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridGuidColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridGuidColumn : DataGridPartEditBoxColumnBase<Nullable<Guid>>
Public Class DataGridGuidColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Guid))

The DataGridGuidColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridGuidColumn | Initializes an instance of the DataGridGuidColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn Constructor

Initializes an instance of the DataGridGuidColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridGuidColumn()
Public Sub New
See Also

Reference

DataGridGuidColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn Properties

The DataGridGuidColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridGuidColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn.Format Property

DataGridGuidColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

DataGridGuidColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn Methods

The DataGridGuidColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridGuidColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn.ApplyStandardValues Method

DataGridGuidColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridGuidColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn.GetEditBoxType Method

DataGridGuidColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridGuidColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn Events

The DataGridGuidColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridGuidColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn Fields

The DataGridGuidColumn type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
Top
See Also

Reference

DataGridGuidColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridGuidColumn.FormatProperty Field

DataGridGuidColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridGuidColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column Class

Represents a data-bound column for use in a DataGrid that utilizes the Int16EditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Int16
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridInt16Column

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridInt16Column : DataGridPartEditBoxColumnBase<Nullable<short>>
Public Class DataGridInt16Column
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Short))

The DataGridInt16Column type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridInt16Column | Initializes an instance of the DataGridInt16Column class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column Constructor

Initializes an instance of the DataGridInt16Column class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridInt16Column()
Public Sub New
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column Properties

The DataGridInt16Column type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.DefaultValue Property

DataGridInt16ColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short DefaultValue { get; set; }
Public Property DefaultValue As Short
    Get
    Set

Property Value

Type: Int16
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.Format Property

DataGridInt16ColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.LargeChange Property

DataGridInt16ColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short LargeChange { get; set; }
Public Property LargeChange As Short
    Get
    Set

Property Value

Type: Int16
The large change value. The default value is 5.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.Maximum Property

DataGridInt16ColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short Maximum { get; set; }
Public Property Maximum As Short
    Get
    Set

Property Value

Type: Int16
The highest possible value.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.Minimum Property

DataGridInt16ColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short Minimum { get; set; }
Public Property Minimum As Short
    Get
    Set

Property Value

Type: Int16
The lowest possible value.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.PickerKind Property

DataGridInt16ColumnPickerKind Property

Gets or sets an Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int16EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int16EditBoxPickerKind
    Get
    Set

Property Value

Type: Int16EditBoxPickerKind
An Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.SmallChange Property

DataGridInt16ColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short SmallChange { get; set; }
Public Property SmallChange As Short
    Get
    Set

Property Value

Type: Int16
The small change value. The default value is 1.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column Methods

The DataGridInt16Column type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.ApplyStandardValues Method

DataGridInt16ColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.GetEditBoxType Method

DataGridInt16ColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column Events

The DataGridInt16Column type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column Fields

The DataGridInt16Column type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.DefaultValueProperty Field

DataGridInt16ColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.FormatProperty Field

DataGridInt16ColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.LargeChangeProperty Field

DataGridInt16ColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.MaximumProperty Field

DataGridInt16ColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.MinimumProperty Field

DataGridInt16ColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.PickerKindProperty Field

DataGridInt16ColumnPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt16Column.SmallChangeProperty Field

DataGridInt16ColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridInt16Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column Class

Represents a data-bound column for use in a DataGrid that utilizes the Int32EditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Int32
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridInt32Column

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridInt32Column : DataGridPartEditBoxColumnBase<Nullable<int>>
Public Class DataGridInt32Column
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Integer))

The DataGridInt32Column type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridInt32Column | Initializes an instance of the DataGridInt32Column class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column Constructor

Initializes an instance of the DataGridInt32Column class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridInt32Column()
Public Sub New
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column Properties

The DataGridInt32Column type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.DefaultValue Property

DataGridInt32ColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int DefaultValue { get; set; }
Public Property DefaultValue As Integer
    Get
    Set

Property Value

Type: Int32
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.Format Property

DataGridInt32ColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.LargeChange Property

DataGridInt32ColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int LargeChange { get; set; }
Public Property LargeChange As Integer
    Get
    Set

Property Value

Type: Int32
The large change value. The default value is 5.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.Maximum Property

DataGridInt32ColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Maximum { get; set; }
Public Property Maximum As Integer
    Get
    Set

Property Value

Type: Int32
The highest possible value.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.Minimum Property

DataGridInt32ColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set

Property Value

Type: Int32
The lowest possible value.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.PickerKind Property

DataGridInt32ColumnPickerKind Property

Gets or sets an Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int32EditBoxPickerKind
    Get
    Set

Property Value

Type: Int32EditBoxPickerKind
An Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.SmallChange Property

DataGridInt32ColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SmallChange { get; set; }
Public Property SmallChange As Integer
    Get
    Set

Property Value

Type: Int32
The small change value. The default value is 1.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column Methods

The DataGridInt32Column type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.ApplyStandardValues Method

DataGridInt32ColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.GetEditBoxType Method

DataGridInt32ColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column Events

The DataGridInt32Column type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column Fields

The DataGridInt32Column type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.DefaultValueProperty Field

DataGridInt32ColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.FormatProperty Field

DataGridInt32ColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.LargeChangeProperty Field

DataGridInt32ColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.MaximumProperty Field

DataGridInt32ColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.MinimumProperty Field

DataGridInt32ColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.PickerKindProperty Field

DataGridInt32ColumnPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32Column.SmallChangeProperty Field

DataGridInt32ColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridInt32Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the Int32RectEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Int32Rect
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridInt32RectColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridInt32RectColumn : DataGridPartEditBoxColumnBase<Nullable<Int32Rect>>
Public Class DataGridInt32RectColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Int32Rect))

The DataGridInt32RectColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridInt32RectColumn | Initializes an instance of the DataGridInt32RectColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn Constructor

Initializes an instance of the DataGridInt32RectColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridInt32RectColumn()
Public Sub New
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn Properties

The DataGridInt32RectColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.DefaultValue Property

DataGridInt32RectColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect DefaultValue { get; set; }
Public Property DefaultValue As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.Format Property

DataGridInt32RectColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.LargeChange Property

DataGridInt32RectColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect LargeChange { get; set; }
Public Property LargeChange As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The large change value. The default value is 5.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.Maximum Property

DataGridInt32RectColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect Maximum { get; set; }
Public Property Maximum As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The highest possible value.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.Minimum Property

DataGridInt32RectColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect Minimum { get; set; }
Public Property Minimum As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The lowest possible value.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.SmallChange Property

DataGridInt32RectColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect SmallChange { get; set; }
Public Property SmallChange As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The small change value. The default value is 1.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn Methods

The DataGridInt32RectColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.ApplyStandardValues Method

DataGridInt32RectColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.GetEditBoxType Method

DataGridInt32RectColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn Events

The DataGridInt32RectColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn Fields

The DataGridInt32RectColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.DefaultValueProperty Field

DataGridInt32RectColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.FormatProperty Field

DataGridInt32RectColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.LargeChangeProperty Field

DataGridInt32RectColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.MaximumProperty Field

DataGridInt32RectColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.MinimumProperty Field

DataGridInt32RectColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt32RectColumn.SmallChangeProperty Field

DataGridInt32RectColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridInt32RectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column Class

Represents a data-bound column for use in a DataGrid that utilizes the Int64EditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Int64
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridInt64Column

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridInt64Column : DataGridPartEditBoxColumnBase<Nullable<long>>
Public Class DataGridInt64Column
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Long))

The DataGridInt64Column type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridInt64Column | Initializes an instance of the DataGridInt64Column class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column Constructor

Initializes an instance of the DataGridInt64Column class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridInt64Column()
Public Sub New
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column Properties

The DataGridInt64Column type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.DefaultValue Property

DataGridInt64ColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long DefaultValue { get; set; }
Public Property DefaultValue As Long
    Get
    Set

Property Value

Type: Int64
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.Format Property

DataGridInt64ColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.LargeChange Property

DataGridInt64ColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long LargeChange { get; set; }
Public Property LargeChange As Long
    Get
    Set

Property Value

Type: Int64
The large change value. The default value is 5.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.Maximum Property

DataGridInt64ColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long Maximum { get; set; }
Public Property Maximum As Long
    Get
    Set

Property Value

Type: Int64
The highest possible value.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.Minimum Property

DataGridInt64ColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long Minimum { get; set; }
Public Property Minimum As Long
    Get
    Set

Property Value

Type: Int64
The lowest possible value.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.PickerKind Property

DataGridInt64ColumnPickerKind Property

Gets or sets an Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int64EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int64EditBoxPickerKind
    Get
    Set

Property Value

Type: Int64EditBoxPickerKind
An Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.SmallChange Property

DataGridInt64ColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long SmallChange { get; set; }
Public Property SmallChange As Long
    Get
    Set

Property Value

Type: Int64
The small change value. The default value is 1.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column Methods

The DataGridInt64Column type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.ApplyStandardValues Method

DataGridInt64ColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.GetEditBoxType Method

DataGridInt64ColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column Events

The DataGridInt64Column type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column Fields

The DataGridInt64Column type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.DefaultValueProperty Field

DataGridInt64ColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.FormatProperty Field

DataGridInt64ColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.LargeChangeProperty Field

DataGridInt64ColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.MaximumProperty Field

DataGridInt64ColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.MinimumProperty Field

DataGridInt64ColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.PickerKindProperty Field

DataGridInt64ColumnPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridInt64Column.SmallChangeProperty Field

DataGridInt64ColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridInt64Column Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn Class

Represents a base class for data-bound columns for use in a DataGrid that utilize MaskedTextBox controls.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridMaskedStringColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridMaskedStringColumn : DataGridBoundColumnBase
Public Class DataGridMaskedStringColumn
    Inherits DataGridBoundColumnBase

The DataGridMaskedStringColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridMaskedStringColumn | Initializes a new instance of the DataGridMaskedStringColumn class
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
 | DefaultEditingElementStyle | Gets the default value for the EditingElementStyleProperty dependency property.
 | DefaultElementStyle | Gets the default value for the EditingElementStyleProperty dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsCaseAutoCorrected | Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.
Public property | IsCaseSensitive | Gets or sets whether the mask is case sensitive.
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | Mask | Gets or sets the text that designates the input mask.
Public property | MaskKind | Gets or sets the kind of input mask.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PromptChar | Gets or sets the character used to indicate required input.
Public property | PromptVisibility | Gets or sets the visibility of mask prompts.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element.
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Commits the cell edit. (Overrides DataGridColumnCommitCellEdit(FrameworkElement).)
Protected method | GenerateEditingElement | Generates the editing element. (Overrides DataGridColumnGenerateEditingElement(DataGridCell, Object).)
Protected method | GenerateElement | Generates the display element. (Overrides DataGridColumnGenerateElement(DataGridCell, Object).)
Protected method | GenerateMaskedTextBox | Generates an instance of a MaskedTextBox object.
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Overrides DataGridColumnPrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
IsCaseAutoCorrectedProperty | Identifies the IsCaseAutoCorrected dependency property. This field is read-only.
IsCaseSensitiveProperty | Identifies the IsCaseSensitive dependency property. This field is read-only.
MaskKindProperty | Identifies the MaskKind dependency property. This field is read-only.
MaskProperty | Identifies the Mask dependency property. This field is read-only.
PromptCharProperty | Identifies the PromptChar dependency property. This field is read-only.
PromptVisibilityProperty | Identifies the PromptVisibility dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn Constructor

Initializes a new instance of the DataGridMaskedStringColumn class

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridMaskedStringColumn()
Public Sub New
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn Properties

The DataGridMaskedStringColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
 | DefaultEditingElementStyle | Gets the default value for the EditingElementStyleProperty dependency property.
 | DefaultElementStyle | Gets the default value for the EditingElementStyleProperty dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsCaseAutoCorrected | Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.
Public property | IsCaseSensitive | Gets or sets whether the mask is case sensitive.
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | Mask | Gets or sets the text that designates the input mask.
Public property | MaskKind | Gets or sets the kind of input mask.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PromptChar | Gets or sets the character used to indicate required input.
Public property | PromptVisibility | Gets or sets the visibility of mask prompts.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.DefaultEditingElementStyle Property

DataGridMaskedStringColumnDefaultEditingElementStyle Property

Gets the default value for the EditingElementStyleProperty dependency property.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Style DefaultEditingElementStyle { get; }
Public Shared ReadOnly Property DefaultEditingElementStyle As Style
    Get

Property Value

Type: Style
The default value for the EditingElementStyleProperty dependency property.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.DefaultElementStyle Property

DataGridMaskedStringColumnDefaultElementStyle Property

Gets the default value for the EditingElementStyleProperty dependency property.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Style DefaultElementStyle { get; }
Public Shared ReadOnly Property DefaultElementStyle As Style
    Get

Property Value

Type: Style
The default value for the EditingElementStyleProperty dependency property.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.IsCaseAutoCorrected Property

DataGridMaskedStringColumnIsCaseAutoCorrected Property

Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCaseAutoCorrected { get; set; }
Public Property IsCaseAutoCorrected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if characters entered will have their case auto-corrected to match the defined mask; otherwise, false. The default value is false.
Remarks
When this property is set to true, then the IsCaseSensitive property is ignored.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.IsCaseSensitive Property

DataGridMaskedStringColumnIsCaseSensitive Property

Gets or sets whether the mask is case sensitive.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCaseSensitive { get; set; }
Public Property IsCaseSensitive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the mask is case sensitive; otherwise, false. The default value is false.
Remarks
When the IsCaseAutoCorrected property is set to true, this property is ignored.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.Mask Property

DataGridMaskedStringColumnMask Property

Gets or sets the text that designates the input mask.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set

Property Value

Type: String
The text that designates the input mask. The default value is .
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.MaskKind Property

DataGridMaskedStringColumnMaskKind Property

Gets or sets the kind of input mask.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MaskKind MaskKind { get; set; }
Public Property MaskKind As MaskKind
    Get
    Set

Property Value

Type: MaskKind
The kind of input mask. The default value is Regex.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.PromptChar Property

DataGridMaskedStringColumnPromptChar Property

Gets or sets the character used to indicate required input.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char PromptChar { get; set; }
Public Property PromptChar As Char
    Get
    Set

Property Value

Type: Char
The character used to indicate required input. The default value is \u2022.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.PromptVisibility Property

DataGridMaskedStringColumnPromptVisibility Property

Gets or sets the visibility of mask prompts.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MaskPromptVisibility PromptVisibility { get; set; }
Public Property PromptVisibility As MaskPromptVisibility
    Get
    Set

Property Value

Type: MaskPromptVisibility
A MaskPromptVisibility that indicates the visibility of mask prompts. The default value is FocusedOnly.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn Methods

The DataGridMaskedStringColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element.
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Commits the cell edit. (Overrides DataGridColumnCommitCellEdit(FrameworkElement).)
Protected method | GenerateEditingElement | Generates the editing element. (Overrides DataGridColumnGenerateEditingElement(DataGridCell, Object).)
Protected method | GenerateElement | Generates the display element. (Overrides DataGridColumnGenerateElement(DataGridCell, Object).)
Protected method | GenerateMaskedTextBox | Generates an instance of a MaskedTextBox object.
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Overrides DataGridColumnPrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.ApplyStandardValues Method

DataGridMaskedStringColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overridable Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.CommitCellEdit Method

DataGridMaskedStringColumnCommitCellEdit Method

Commits the cell edit.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool CommitCellEdit(
    FrameworkElement editingElement
)
Protected Overrides Function CommitCellEdit (
    editingElement As FrameworkElement
) As Boolean

Parameters

editingElement
Type: System.WindowsFrameworkElement
The editing element.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.DataGridMaskedStringColumn.CommitCellEdit(System.Windows.FrameworkElement)"]

See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.GenerateEditingElement Method

DataGridMaskedStringColumnGenerateEditingElement Method

Generates the editing element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override FrameworkElement GenerateEditingElement(
    DataGridCell cell,
    Object dataItem
)
Protected Overrides Function GenerateEditingElement (
    cell As DataGridCell,
    dataItem As Object
) As FrameworkElement

Parameters

cell
Type: System.Windows.ControlsDataGridCell
The cell.
dataItem
Type: SystemObject
The data item.

Return Value

Type: FrameworkElement
The FrameworkElement to use for editing.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.GenerateElement Method

DataGridMaskedStringColumnGenerateElement Method

Generates the display element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override FrameworkElement GenerateElement(
    DataGridCell cell,
    Object dataItem
)
Protected Overrides Function GenerateElement (
    cell As DataGridCell,
    dataItem As Object
) As FrameworkElement

Parameters

cell
Type: System.Windows.ControlsDataGridCell
The cell.
dataItem
Type: SystemObject
The data item.

Return Value

Type: FrameworkElement
The FrameworkElement to use for display.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.GenerateMaskedTextBox Method

DataGridMaskedStringColumnGenerateMaskedTextBox Method

Generates an instance of a MaskedTextBox object.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual MaskedTextBox GenerateMaskedTextBox(
    bool isEditing,
    DataGridCell cell
)
Protected Overridable Function GenerateMaskedTextBox (
    isEditing As Boolean,
    cell As DataGridCell
) As MaskedTextBox

Parameters

isEditing
Type: SystemBoolean
Whether the text box will be used for editing.
cell
Type: System.Windows.ControlsDataGridCell
The cell.

Return Value

Type: MaskedTextBox
An instance of a MaskedTextBox object.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.PrepareCellForEdit Method

DataGridMaskedStringColumnPrepareCellForEdit Method

Prepares the cell for edit.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Protected Overrides Function PrepareCellForEdit (
    editingElement As FrameworkElement,
    editingEventArgs As RoutedEventArgs
) As Object

Parameters

editingElement
Type: System.WindowsFrameworkElement
The editing element.
editingEventArgs
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs instance containing the event data.

Return Value

Type: Object

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.DataGridMaskedStringColumn.PrepareCellForEdit(System.Windows.FrameworkElement,System.Windows.RoutedEventArgs)"]

See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn Events

The DataGridMaskedStringColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn Fields

The DataGridMaskedStringColumn type exposes the following members.

Fields
Name | Description
IsCaseAutoCorrectedProperty | Identifies the IsCaseAutoCorrected dependency property. This field is read-only.
IsCaseSensitiveProperty | Identifies the IsCaseSensitive dependency property. This field is read-only.
MaskKindProperty | Identifies the MaskKind dependency property. This field is read-only.
MaskProperty | Identifies the Mask dependency property. This field is read-only.
PromptCharProperty | Identifies the PromptChar dependency property. This field is read-only.
PromptVisibilityProperty | Identifies the PromptVisibility dependency property. This field is read-only.
Top
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.IsCaseAutoCorrectedProperty Field

DataGridMaskedStringColumnIsCaseAutoCorrectedProperty Field

Identifies the IsCaseAutoCorrected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCaseAutoCorrectedProperty
Public Shared ReadOnly IsCaseAutoCorrectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCaseAutoCorrected dependency property.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.IsCaseSensitiveProperty Field

DataGridMaskedStringColumnIsCaseSensitiveProperty Field

Identifies the IsCaseSensitive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCaseSensitiveProperty
Public Shared ReadOnly IsCaseSensitiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCaseSensitive dependency property.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.MaskKindProperty Field

DataGridMaskedStringColumnMaskKindProperty Field

Identifies the MaskKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaskKindProperty
Public Shared ReadOnly MaskKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaskKind dependency property.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.MaskProperty Field

DataGridMaskedStringColumnMaskProperty Field

Identifies the Mask dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaskProperty
Public Shared ReadOnly MaskProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Mask dependency property.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.PromptCharProperty Field

DataGridMaskedStringColumnPromptCharProperty Field

Identifies the PromptChar dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PromptCharProperty
Public Shared ReadOnly PromptCharProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PromptChar dependency property.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridMaskedStringColumn.PromptVisibilityProperty Field

DataGridMaskedStringColumnPromptVisibilityProperty Field

Identifies the PromptVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PromptVisibilityProperty
Public Shared ReadOnly PromptVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PromptVisibility dependency property.
See Also

Reference

DataGridMaskedStringColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the PointEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Point
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridPointColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridPointColumn : DataGridPartEditBoxColumnBase<Nullable<Point>>
Public Class DataGridPointColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Point))

The DataGridPointColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridPointColumn | Initializes an instance of the DataGridPointColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn Constructor

Initializes an instance of the DataGridPointColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridPointColumn()
Public Sub New
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn Properties

The DataGridPointColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.DefaultValue Property

DataGridPointColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point DefaultValue { get; set; }
Public Property DefaultValue As Point
    Get
    Set

Property Value

Type: Point
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.Format Property

DataGridPointColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.IsNaNAllowed Property

DataGridPointColumnIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.IsNegativeInfinityAllowed Property

DataGridPointColumnIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.IsPositiveInfinityAllowed Property

DataGridPointColumnIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.LargeChange Property

DataGridPointColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point LargeChange { get; set; }
Public Property LargeChange As Point
    Get
    Set

Property Value

Type: Point
The large change value. The default value is 5.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.Maximum Property

DataGridPointColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point Maximum { get; set; }
Public Property Maximum As Point
    Get
    Set

Property Value

Type: Point
The highest possible value.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.Minimum Property

DataGridPointColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point Minimum { get; set; }
Public Property Minimum As Point
    Get
    Set

Property Value

Type: Point
The lowest possible value.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.RoundingDecimalPlace Property

DataGridPointColumnRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.SmallChange Property

DataGridPointColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point SmallChange { get; set; }
Public Property SmallChange As Point
    Get
    Set

Property Value

Type: Point
The small change value. The default value is 1.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn Methods

The DataGridPointColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.ApplyStandardValues Method

DataGridPointColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.GetEditBoxType Method

DataGridPointColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn Events

The DataGridPointColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn Fields

The DataGridPointColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.DefaultValueProperty Field

DataGridPointColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.FormatProperty Field

DataGridPointColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.IsNaNAllowedProperty Field

DataGridPointColumnIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.IsNegativeInfinityAllowedProperty Field

DataGridPointColumnIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.IsPositiveInfinityAllowedProperty Field

DataGridPointColumnIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.LargeChangeProperty Field

DataGridPointColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.MaximumProperty Field

DataGridPointColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.MinimumProperty Field

DataGridPointColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.RoundingDecimalPlaceProperty Field

DataGridPointColumnRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridPointColumn.SmallChangeProperty Field

DataGridPointColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridPointColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the RectEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Rect
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridRectColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridRectColumn : DataGridPartEditBoxColumnBase<Nullable<Rect>>
Public Class DataGridRectColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Rect))

The DataGridRectColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridRectColumn | Initializes an instance of the DataGridRectColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn Constructor

Initializes an instance of the DataGridRectColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridRectColumn()
Public Sub New
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn Properties

The DataGridRectColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.DefaultValue Property

DataGridRectColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect DefaultValue { get; set; }
Public Property DefaultValue As Rect
    Get
    Set

Property Value

Type: Rect
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.Format Property

DataGridRectColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.IsNaNAllowed Property

DataGridRectColumnIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.IsNegativeInfinityAllowed Property

DataGridRectColumnIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.IsPositiveInfinityAllowed Property

DataGridRectColumnIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.LargeChange Property

DataGridRectColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect LargeChange { get; set; }
Public Property LargeChange As Rect
    Get
    Set

Property Value

Type: Rect
The large change value. The default value is 5.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.Maximum Property

DataGridRectColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect Maximum { get; set; }
Public Property Maximum As Rect
    Get
    Set

Property Value

Type: Rect
The highest possible value.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.Minimum Property

DataGridRectColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect Minimum { get; set; }
Public Property Minimum As Rect
    Get
    Set

Property Value

Type: Rect
The lowest possible value.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.RoundingDecimalPlace Property

DataGridRectColumnRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.SmallChange Property

DataGridRectColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect SmallChange { get; set; }
Public Property SmallChange As Rect
    Get
    Set

Property Value

Type: Rect
The small change value. The default value is 1.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn Methods

The DataGridRectColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.ApplyStandardValues Method

DataGridRectColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.GetEditBoxType Method

DataGridRectColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn Events

The DataGridRectColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn Fields

The DataGridRectColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.DefaultValueProperty Field

DataGridRectColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.FormatProperty Field

DataGridRectColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.IsNaNAllowedProperty Field

DataGridRectColumnIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.IsNegativeInfinityAllowedProperty Field

DataGridRectColumnIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.IsPositiveInfinityAllowedProperty Field

DataGridRectColumnIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.LargeChangeProperty Field

DataGridRectColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.MaximumProperty Field

DataGridRectColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.MinimumProperty Field

DataGridRectColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.RoundingDecimalPlaceProperty Field

DataGridRectColumnRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridRectColumn.SmallChangeProperty Field

DataGridRectColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridRectColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the SingleEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Single
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridSingleColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridSingleColumn : DataGridPartEditBoxColumnBase<Nullable<float>>
Public Class DataGridSingleColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Single))

The DataGridSingleColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridSingleColumn | Initializes an instance of the DataGridSingleColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn Constructor

Initializes an instance of the DataGridSingleColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridSingleColumn()
Public Sub New
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn Properties

The DataGridSingleColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PickerKind | Gets or sets an SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.DefaultValue Property

DataGridSingleColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float DefaultValue { get; set; }
Public Property DefaultValue As Single
    Get
    Set

Property Value

Type: Single
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.Format Property

DataGridSingleColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.IsNaNAllowed Property

DataGridSingleColumnIsNaNAllowed Property

Gets or sets whether NaN is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.IsNegativeInfinityAllowed Property

DataGridSingleColumnIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.IsPositiveInfinityAllowed Property

DataGridSingleColumnIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.LargeChange Property

DataGridSingleColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float LargeChange { get; set; }
Public Property LargeChange As Single
    Get
    Set

Property Value

Type: Single
The large change value. The default value is 5.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.Maximum Property

DataGridSingleColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float Maximum { get; set; }
Public Property Maximum As Single
    Get
    Set

Property Value

Type: Single
The highest possible value.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.Minimum Property

DataGridSingleColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float Minimum { get; set; }
Public Property Minimum As Single
    Get
    Set

Property Value

Type: Single
The lowest possible value.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.PickerKind Property

DataGridSingleColumnPickerKind Property

Gets or sets an SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SingleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As SingleEditBoxPickerKind
    Get
    Set

Property Value

Type: SingleEditBoxPickerKind
An SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.RoundingDecimalPlace Property

DataGridSingleColumnRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 7. Pass a null value to disable rounding. The default value is 7.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.SmallChange Property

DataGridSingleColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float SmallChange { get; set; }
Public Property SmallChange As Single
    Get
    Set

Property Value

Type: Single
The small change value. The default value is 1.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn Methods

The DataGridSingleColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.ApplyStandardValues Method

DataGridSingleColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.GetEditBoxType Method

DataGridSingleColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn Events

The DataGridSingleColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn Fields

The DataGridSingleColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.DefaultValueProperty Field

DataGridSingleColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.FormatProperty Field

DataGridSingleColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.IsNaNAllowedProperty Field

DataGridSingleColumnIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.IsNegativeInfinityAllowedProperty Field

DataGridSingleColumnIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.IsPositiveInfinityAllowedProperty Field

DataGridSingleColumnIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.LargeChangeProperty Field

DataGridSingleColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.MaximumProperty Field

DataGridSingleColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.MinimumProperty Field

DataGridSingleColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.PickerKindProperty Field

DataGridSingleColumnPickerKindProperty Field

Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.RoundingDecimalPlaceProperty Field

DataGridSingleColumnRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSingleColumn.SmallChangeProperty Field

DataGridSingleColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridSingleColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the SizeEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Size
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridSizeColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridSizeColumn : DataGridPartEditBoxColumnBase<Nullable<Size>>
Public Class DataGridSizeColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Size))

The DataGridSizeColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridSizeColumn | Initializes an instance of the DataGridSizeColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn Constructor

Initializes an instance of the DataGridSizeColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridSizeColumn()
Public Sub New
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn Properties

The DataGridSizeColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.DefaultValue Property

DataGridSizeColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size DefaultValue { get; set; }
Public Property DefaultValue As Size
    Get
    Set

Property Value

Type: Size
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.Format Property

DataGridSizeColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.IsNaNAllowed Property

DataGridSizeColumnIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.IsNegativeInfinityAllowed Property

DataGridSizeColumnIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.IsPositiveInfinityAllowed Property

DataGridSizeColumnIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.LargeChange Property

DataGridSizeColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size LargeChange { get; set; }
Public Property LargeChange As Size
    Get
    Set

Property Value

Type: Size
The large change value. The default value is 5.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.Maximum Property

DataGridSizeColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Maximum { get; set; }
Public Property Maximum As Size
    Get
    Set

Property Value

Type: Size
The highest possible value.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.Minimum Property

DataGridSizeColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Minimum { get; set; }
Public Property Minimum As Size
    Get
    Set

Property Value

Type: Size
The lowest possible value.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.RoundingDecimalPlace Property

DataGridSizeColumnRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.SmallChange Property

DataGridSizeColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size SmallChange { get; set; }
Public Property SmallChange As Size
    Get
    Set

Property Value

Type: Size
The small change value. The default value is 1.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn Methods

The DataGridSizeColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.ApplyStandardValues Method

DataGridSizeColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.GetEditBoxType Method

DataGridSizeColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn Events

The DataGridSizeColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn Fields

The DataGridSizeColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.DefaultValueProperty Field

DataGridSizeColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.FormatProperty Field

DataGridSizeColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.IsNaNAllowedProperty Field

DataGridSizeColumnIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.IsNegativeInfinityAllowedProperty Field

DataGridSizeColumnIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.IsPositiveInfinityAllowedProperty Field

DataGridSizeColumnIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.LargeChangeProperty Field

DataGridSizeColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.MaximumProperty Field

DataGridSizeColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.MinimumProperty Field

DataGridSizeColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.RoundingDecimalPlaceProperty Field

DataGridSizeColumnRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridSizeColumn.SmallChangeProperty Field

DataGridSizeColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridSizeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the ThicknessEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Thickness
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridThicknessColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridThicknessColumn : DataGridPartEditBoxColumnBase<Nullable<Thickness>>
Public Class DataGridThicknessColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Thickness))

The DataGridThicknessColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridThicknessColumn | Initializes an instance of the DataGridThicknessColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn Constructor

Initializes an instance of the DataGridThicknessColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridThicknessColumn()
Public Sub New
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn Properties

The DataGridThicknessColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.DefaultValue Property

DataGridThicknessColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness DefaultValue { get; set; }
Public Property DefaultValue As Thickness
    Get
    Set

Property Value

Type: Thickness
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.Format Property

DataGridThicknessColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.IsNaNAllowed Property

DataGridThicknessColumnIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.IsNegativeInfinityAllowed Property

DataGridThicknessColumnIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.IsPositiveInfinityAllowed Property

DataGridThicknessColumnIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.LargeChange Property

DataGridThicknessColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness LargeChange { get; set; }
Public Property LargeChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The large change value. The default value is 5.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.Maximum Property

DataGridThicknessColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Maximum { get; set; }
Public Property Maximum As Thickness
    Get
    Set

Property Value

Type: Thickness
The highest possible value.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.Minimum Property

DataGridThicknessColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Minimum { get; set; }
Public Property Minimum As Thickness
    Get
    Set

Property Value

Type: Thickness
The lowest possible value.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.RoundingDecimalPlace Property

DataGridThicknessColumnRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.SmallChange Property

DataGridThicknessColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness SmallChange { get; set; }
Public Property SmallChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The small change value. The default value is 1.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn Methods

The DataGridThicknessColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.ApplyStandardValues Method

DataGridThicknessColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.GetEditBoxType Method

DataGridThicknessColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn Events

The DataGridThicknessColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn Fields

The DataGridThicknessColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.DefaultValueProperty Field

DataGridThicknessColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.FormatProperty Field

DataGridThicknessColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.IsNaNAllowedProperty Field

DataGridThicknessColumnIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.IsNegativeInfinityAllowedProperty Field

DataGridThicknessColumnIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.IsPositiveInfinityAllowedProperty Field

DataGridThicknessColumnIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.LargeChangeProperty Field

DataGridThicknessColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.MaximumProperty Field

DataGridThicknessColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.MinimumProperty Field

DataGridThicknessColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.RoundingDecimalPlaceProperty Field

DataGridThicknessColumnRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridThicknessColumn.SmallChangeProperty Field

DataGridThicknessColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridThicknessColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the TimeEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable DateTime
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridDateTimeColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridTimeColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridTimeColumn : DataGridDateTimeColumn
Public Class DataGridTimeColumn
    Inherits DataGridDateTimeColumn

The DataGridTimeColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridTimeColumn | Initializes an instance of the DataGridTimeColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DataGridDateTimeColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DataGridDateTimeColumn.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DataGridDateTimeColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Inherited from DataGridDateTimeColumn.)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridDateTimeColumnGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeColumn Constructor

Initializes an instance of the DataGridTimeColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridTimeColumn()
Public Sub New
See Also

Reference

DataGridTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeColumn Properties

The DataGridTimeColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DataGridDateTimeColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DataGridDateTimeColumn.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DataGridDateTimeColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeColumn Methods

The DataGridTimeColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Inherited from DataGridDateTimeColumn.)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridDateTimeColumnGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeColumn.GetEditBoxType Method

DataGridTimeColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeColumn Events

The DataGridTimeColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridTimeColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the TimeSpanEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable TimeSpan
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridTimeSpanColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridTimeSpanColumn : DataGridPartEditBoxColumnBase<Nullable<TimeSpan>>
Public Class DataGridTimeSpanColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of TimeSpan))

The DataGridTimeSpanColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridTimeSpanColumn | Initializes an instance of the DataGridTimeSpanColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the timespan format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn Constructor

Initializes an instance of the DataGridTimeSpanColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridTimeSpanColumn()
Public Sub New
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn Properties

The DataGridTimeSpanColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the timespan format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.DefaultValue Property

DataGridTimeSpanColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan DefaultValue { get; set; }
Public Property DefaultValue As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.Format Property

DataGridTimeSpanColumnFormat Property

Gets or sets the timespan format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The timespan format string. The default value is "g".
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.LargeChange Property

DataGridTimeSpanColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan LargeChange { get; set; }
Public Property LargeChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The large change value. The default value is 5.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.Maximum Property

DataGridTimeSpanColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan Maximum { get; set; }
Public Property Maximum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The highest possible value.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.Minimum Property

DataGridTimeSpanColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan Minimum { get; set; }
Public Property Minimum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The lowest possible value.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.SmallChange Property

DataGridTimeSpanColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan SmallChange { get; set; }
Public Property SmallChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The small change value. The default value is 1.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn Methods

The DataGridTimeSpanColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.ApplyStandardValues Method

DataGridTimeSpanColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.GetEditBoxType Method

DataGridTimeSpanColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn Events

The DataGridTimeSpanColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn Fields

The DataGridTimeSpanColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.DefaultValueProperty Field

DataGridTimeSpanColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.FormatProperty Field

DataGridTimeSpanColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.LargeChangeProperty Field

DataGridTimeSpanColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.MaximumProperty Field

DataGridTimeSpanColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.MinimumProperty Field

DataGridTimeSpanColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridTimeSpanColumn.SmallChangeProperty Field

DataGridTimeSpanColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridTimeSpanColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn Class

Represents a data-bound column for use in a DataGrid that utilizes the VectorEditBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBase Nullable Vector
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridVectorColumn

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataGridVectorColumn : DataGridPartEditBoxColumnBase<Nullable<Vector>>
Public Class DataGridVectorColumn
    Inherits DataGridPartEditBoxColumnBase(Of Nullable(Of Vector))

The DataGridVectorColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridVectorColumn | Initializes an instance of the DataGridVectorColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn Constructor

Initializes an instance of the DataGridVectorColumn class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataGridVectorColumn()
Public Sub New
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn Properties

The DataGridVectorColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.DefaultValue Property

DataGridVectorColumnDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector DefaultValue { get; set; }
Public Property DefaultValue As Vector
    Get
    Set

Property Value

Type: Vector
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.Format Property

DataGridVectorColumnFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.IsNaNAllowed Property

DataGridVectorColumnIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.IsNegativeInfinityAllowed Property

DataGridVectorColumnIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.IsPositiveInfinityAllowed Property

DataGridVectorColumnIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.LargeChange Property

DataGridVectorColumnLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector LargeChange { get; set; }
Public Property LargeChange As Vector
    Get
    Set

Property Value

Type: Vector
The large change value. The default value is 5.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.Maximum Property

DataGridVectorColumnMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector Maximum { get; set; }
Public Property Maximum As Vector
    Get
    Set

Property Value

Type: Vector
The highest possible value.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.Minimum Property

DataGridVectorColumnMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector Minimum { get; set; }
Public Property Minimum As Vector
    Get
    Set

Property Value

Type: Vector
The lowest possible value.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.RoundingDecimalPlace Property

DataGridVectorColumnRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.SmallChange Property

DataGridVectorColumnSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector SmallChange { get; set; }
Public Property SmallChange As Vector
    Get
    Set

Property Value

Type: Vector
The small change value. The default value is 1.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn Methods

The DataGridVectorColumn type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element. (Overrides DataGridPartEditBoxColumnBaseTApplyStandardValues(FrameworkElement).)
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateEditingElement | Generates the editing element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | GenerateElement | Generates the display element. (Inherited from DataGridPartEditBoxColumnBaseT.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control. (Overrides DataGridPartEditBoxColumnBaseTGetEditBoxType.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Inherited from DataGridPartEditBoxColumnBaseT.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.ApplyStandardValues Method

DataGridVectorColumnApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overrides Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.GetEditBoxType Method

DataGridVectorColumnGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type GetEditBoxType()
Protected Overrides Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn Events

The DataGridVectorColumn type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn Fields

The DataGridVectorColumn type exposes the following members.

Fields
Name | Description
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
RoundingDecimalPlaceProperty | Identifies the RoundingDecimalPlace dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.DefaultValueProperty Field

DataGridVectorColumnDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.FormatProperty Field

DataGridVectorColumnFormatProperty Field

Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.IsNaNAllowedProperty Field

DataGridVectorColumnIsNaNAllowedProperty Field

Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.IsNegativeInfinityAllowedProperty Field

DataGridVectorColumnIsNegativeInfinityAllowedProperty Field

Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.IsPositiveInfinityAllowedProperty Field

DataGridVectorColumnIsPositiveInfinityAllowedProperty Field

Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.LargeChangeProperty Field

DataGridVectorColumnLargeChangeProperty Field

Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.MaximumProperty Field

DataGridVectorColumnMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.MinimumProperty Field

DataGridVectorColumnMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.RoundingDecimalPlaceProperty Field

DataGridVectorColumnRoundingDecimalPlaceProperty Field

Identifies the RoundingDecimalPlace dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundingDecimalPlaceProperty
Public Shared ReadOnly RoundingDecimalPlaceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundingDecimalPlace dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


DataGridVectorColumn.SmallChangeProperty Field

DataGridVectorColumnSmallChangeProperty Field

Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DataGridVectorColumn Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid Namespace


ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace

Contains primitive classes that support integration of Editors with DataGrid.
Classes
 | Class | Description
Public class | DataGridBoundColumnBase | Represents a base class for data-bound columns for use in a DataGrid.
Public class | DataGridPartEditBoxColumnBaseT | Represents a base class for data-bound columns for use in a DataGrid that utilize PartEditBoxBase-derived controls.


DataGridBoundColumnBase Class

Represents a base class for data-bound columns for use in a DataGrid.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridMaskedStringColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBaseT

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DataGridBoundColumnBase : DataGridBoundColumn
Public MustInherit Class DataGridBoundColumnBase
    Inherits DataGridBoundColumn

The DataGridBoundColumnBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DataGridBoundColumnBase | Initializes a new instance of the DataGridBoundColumnBase class
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property.
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property.
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditingElement | When overridden in a derived class, gets an editing element that is bound to the Binding property value of the column. (Inherited from DataGridColumn.)
Protected method | GenerateElement | When overridden in a derived class, gets a read-only element that is bound to the Binding property value of the column. (Inherited from DataGridColumn.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | When overridden in a derived class, sets cell content as needed for editing. (Inherited from DataGridColumn.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Overrides DataGridBoundColumnRefreshCellContent(FrameworkElement, String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridBoundColumnBase Constructor

Initializes a new instance of the DataGridBoundColumnBase class

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DataGridBoundColumnBase()
Protected Sub New
See Also

Reference

DataGridBoundColumnBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridBoundColumnBase Properties

The DataGridBoundColumnBase type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridBoundColumnBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridBoundColumnBase Methods

The DataGridBoundColumnBase type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property.
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property.
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditingElement | When overridden in a derived class, gets an editing element that is bound to the Binding property value of the column. (Inherited from DataGridColumn.)
Protected method | GenerateElement | When overridden in a derived class, gets a read-only element that is bound to the Binding property value of the column. (Inherited from DataGridColumn.)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | When overridden in a derived class, sets cell content as needed for editing. (Inherited from DataGridColumn.)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Overrides DataGridBoundColumnRefreshCellContent(FrameworkElement, String).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridBoundColumnBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridBoundColumnBase.ApplyBinding Method

DataGridBoundColumnBaseApplyBinding Method

Associates the binding expression, defined by the Binding property, with the specified target property.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void ApplyBinding(
    FrameworkElement targetElement,
    DependencyProperty targetProperty
)
Protected Sub ApplyBinding (
    targetElement As FrameworkElement,
    targetProperty As DependencyProperty
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
targetProperty
Type: System.WindowsDependencyProperty
The target property.
See Also

Reference

DataGridBoundColumnBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridBoundColumnBase.ApplyValue Method

DataGridBoundColumnBaseApplyValue Method

Sets the value of the specified target object and property, based on the specified source property.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void ApplyValue(
    DependencyProperty sourceProperty,
    FrameworkElement targetElement,
    DependencyProperty targetProperty
)
Protected Overridable Sub ApplyValue (
    sourceProperty As DependencyProperty,
    targetElement As FrameworkElement,
    targetProperty As DependencyProperty
)

Parameters

sourceProperty
Type: System.WindowsDependencyProperty
The source property.
targetElement
Type: System.WindowsFrameworkElement
The target element.
targetProperty
Type: System.WindowsDependencyProperty
The target property.
See Also

Reference

DataGridBoundColumnBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridBoundColumnBase.RefreshCellContent Method

DataGridBoundColumnBaseRefreshCellContent Method

Refreshes the contents of a cell in the column in response to a column property value change.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RefreshCellContent(
    FrameworkElement element,
    string propertyName
)
Protected Overrides Sub RefreshCellContent (
    element As FrameworkElement,
    propertyName As String
)

Parameters

element
Type: System.WindowsFrameworkElement
The element returned by the Content property of the cell to refresh.
propertyName
Type: SystemString
The name of the column property that has changed.
See Also

Reference

DataGridBoundColumnBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridBoundColumnBase Events

The DataGridBoundColumnBase type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridBoundColumnBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T) Class

DataGridPartEditBoxColumnBaseT Class

Represents a base class for data-bound columns for use in a DataGrid that utilize PartEditBoxBase-derived controls.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBaseT
More...

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DataGridPartEditBoxColumnBase<T> : DataGridBoundColumnBase

Public MustInherit Class DataGridPartEditBoxColumnBase(Of T)
    Inherits DataGridBoundColumnBase

Type Parameters

T
The type of value being edited.

The DataGridPartEditBoxColumnBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | DataGridPartEditBoxColumnBaseT | Initializes a new instance of the DataGridPartEditBoxColumnBaseT class
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes.
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
 | DefaultEditingElementStyle | Gets the default value for the EditingElementStyleProperty dependency property.
 | DefaultElementStyle | Gets the default value for the EditingElementStyleProperty dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available.
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable.
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.
Public property | TextAlignment | Gets or sets the text alignment of the text editing area.
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element.
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object.
Protected method | GenerateEditingElement | Generates the editing element. (Overrides DataGridColumnGenerateEditingElement(DataGridCell, Object).)
Protected method | GenerateElement | Generates the display element. (Overrides DataGridColumnGenerateElement(DataGridCell, Object).)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control.
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Overrides DataGridColumnPrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
Fields
Name | Description
CommitTriggersProperty | Identifies the CommitTriggers dependency property. This field is read-only.
HasPopupProperty | Identifies the HasPopup dependency property. This field is read-only.
IsArrowKeyPartNavigationEnabledProperty | Identifies the IsArrowKeyPartNavigationEnabled dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsUndoEnabledProperty | Identifies the IsUndoEnabled dependency property. This field is read-only.
PlaceholderTextProperty | Identifies the PlaceholderText dependency property. This field is read-only.
SpinnerVisibilityProperty | Identifies the SpinnerVisibility dependency property. This field is read-only.
SpinWrappingProperty | Identifies the SpinWrapping dependency property. This field is read-only.
TextAlignmentProperty | Identifies the TextAlignment dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.ControlsDataGridColumn
System.Windows.ControlsDataGridBoundColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridBoundColumnBase
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.PrimitivesDataGridPartEditBoxColumnBaseT
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridBrushColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridByteColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridColorColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridCornerRadiusColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridDateTimeColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridDoubleColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridEnumColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridGuidColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridInt16Column
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridInt32Column
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridInt32RectColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridInt64Column
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridPointColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridRectColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridSingleColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridSizeColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridThicknessColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridTimeSpanColumn
ActiproSoftware.Windows.Controls.Editors.Interop.DataGridDataGridVectorColumn


DataGridPartEditBoxColumnBase(T) Constructor

DataGridPartEditBoxColumnBaseT Constructor

Initializes a new instance of the DataGridPartEditBoxColumnBaseT class

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DataGridPartEditBoxColumnBase()
Protected Sub New
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T) Properties

DataGridPartEditBoxColumnBaseT Properties

The DataGridPartEditBoxColumnBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the current width of the column, in device-independent units (1/96th inch per unit). (Inherited from DataGridColumn.)
Public property | Binding | Gets or sets the binding that associates the column with a property in the data source. (Inherited from DataGridBoundColumn.)
Public property | CanUserReorder | Gets or sets a value that indicates whether the user can change the column display position by dragging the column header. (Inherited from DataGridColumn.)
Public property | CanUserResize | Gets or sets a value that indicates whether the user can adjust the column width by using the mouse. (Inherited from DataGridColumn.)
Public property | CanUserSort | Gets or sets a value that indicates whether the user can sort the column by clicking the column header. (Inherited from DataGridColumn.)
Public property | CellStyle | Gets or sets the style that is used to render cells in the column. (Inherited from DataGridColumn.)
Public property | ClipboardContentBinding | Gets or sets the binding object to use when getting or setting cell content for the clipboard. (Inherited from DataGridBoundColumn.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes.
Protected property | DataGridOwner | Gets the DataGrid control that contains this column. (Inherited from DataGridColumn.)
 | DefaultEditingElementStyle | Gets the default value for the EditingElementStyleProperty dependency property.
 | DefaultElementStyle | Gets the default value for the EditingElementStyleProperty dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayIndex | Gets or sets the display position of the column relative to the other columns in the DataGrid. (Inherited from DataGridColumn.)
Public property | DragIndicatorStyle | Gets or sets the style object to apply to the column header during a drag operation. (Inherited from DataGridColumn.)
Public property | EditingElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell in editing mode. (Inherited from DataGridBoundColumn.)
Public property | ElementStyle | Gets or sets the style that is used when rendering the element that the column displays for a cell that is not in editing mode. (Inherited from DataGridBoundColumn.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available.
Public property | Header | Gets or sets the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStringFormat | Gets or sets the format pattern to apply to the content of the column header. (Inherited from DataGridColumn.)
Public property | HeaderStyle | Gets or sets the style that is used when rendering the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplate | Gets or sets the template that defines the visual representation of the column header. (Inherited from DataGridColumn.)
Public property | HeaderTemplateSelector | Gets or sets the object that selects which template to use for the column header. (Inherited from DataGridColumn.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.
Public property | IsAutoGenerated | Gets a value that indicates whether the column is auto-generated. (Inherited from DataGridColumn.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable.
Public property | IsFrozen | Gets a value that indicates whether the column is prevented from scrolling horizontally. (Inherited from DataGridColumn.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsReadOnly | Gets or sets a value that indicates whether cells in the column can be edited. (Inherited from DataGridColumn.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control.
Public property | MaxWidth | Gets or sets the maximum width constraint of the column. (Inherited from DataGridColumn.)
Public property | MinWidth | Gets or sets the minimum width constraint of the column. (Inherited from DataGridColumn.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.
Public property | SortDirection | Gets or sets the sort direction (ascending or descending) of the column. (Inherited from DataGridColumn.)
Public property | SortMemberPath | Gets or sets a property name, or a period-delimited hierarchy of property names, that indicates the member to sort by. (Inherited from DataGridColumn.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.
Public property | TextAlignment | Gets or sets the text alignment of the text editing area.
Public property | Visibility | Gets or sets the visibility of the column. (Inherited from DataGridColumn.)
Public property | Width | Gets or sets the column width or automatic sizing mode. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).CommitTriggers Property

DataGridPartEditBoxColumnBaseTCommitTriggers Property

Gets or sets the triggers that will force this control to commit any changes.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PartEditBoxCommitTriggers CommitTriggers { get; set; }
Public Property CommitTriggers As PartEditBoxCommitTriggers
    Get
    Set

Property Value

Type: PartEditBoxCommitTriggers
A PartEditBoxCommitTriggers indicating the triggers that will force this control to commit any changes. The default value is PartEditBoxCommitTriggers.Default.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).DefaultEditingElementStyle Property

DataGridPartEditBoxColumnBaseTDefaultEditingElementStyle Property

Gets the default value for the EditingElementStyleProperty dependency property.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Style DefaultEditingElementStyle { get; }
Public Shared ReadOnly Property DefaultEditingElementStyle As Style
    Get

Property Value

Type: Style
The default value for the EditingElementStyleProperty dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).DefaultElementStyle Property

DataGridPartEditBoxColumnBaseTDefaultElementStyle Property

Gets the default value for the EditingElementStyleProperty dependency property.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Style DefaultElementStyle { get; }
Public Shared ReadOnly Property DefaultElementStyle As Style
    Get

Property Value

Type: Style
The default value for the EditingElementStyleProperty dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).HasPopup Property

DataGridPartEditBoxColumnBaseTHasPopup Property

Gets or sets a value indicating whether the control has a popup available.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasPopup { get; set; }
Public Property HasPopup As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control has a popup available; otherwise false. The default value is true.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).IsArrowKeyPartNavigationEnabled Property

DataGridPartEditBoxColumnBaseTIsArrowKeyPartNavigationEnabled Property

Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsArrowKeyPartNavigationEnabled { get; set; }
Public Property IsArrowKeyPartNavigationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the left/right arrow keys can be used to move between and select editable parts; otherwise false. The default value is true.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).IsEditable Property

DataGridPartEditBoxColumnBaseTIsEditable Property

Gets or sets a value indicating whether the edit box's text area is editable.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box's text area is editable; otherwise false. The default value is true.
Remarks
When false, the edit box behaves more like a ComboBox.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).IsNullAllowed Property

DataGridPartEditBoxColumnBaseTIsNullAllowed Property

Gets or sets a value indicating whether null values are allowed to be entered by the user.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNullAllowed { get; set; }
Public Property IsNullAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if null values are allowed to be entered by the user; otherwise false. The default value is false.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).IsUndoEnabled Property

DataGridPartEditBoxColumnBaseTIsUndoEnabled Property

Gets or sets whether undo/redo support is enabled for the text-editing portion of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsUndoEnabled { get; set; }
Public Property IsUndoEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if undo/redo support is enabled for the text-editing portion of the control. The default value is true.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).PlaceholderText Property

DataGridPartEditBoxColumnBaseTPlaceholderText Property

Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string PlaceholderText { get; set; }
Public Property PlaceholderText As String
    Get
    Set

Property Value

Type: String
The text that is displayed in the control until the value is changed by a user action or some other operation.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).SpinnerVisibility Property

DataGridPartEditBoxColumnBaseTSpinnerVisibility Property

Gets or sets a value indicating if and when the control has a spinner available.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpinnerVisibility SpinnerVisibility { get; set; }
Public Property SpinnerVisibility As SpinnerVisibility
    Get
    Set

Property Value

Type: SpinnerVisibility
A value indicating if and when the control has a spinner available. The default value is SpinnerVisibility.Collapsed.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).SpinWrapping Property

DataGridPartEditBoxColumnBaseTSpinWrapping Property

Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpinWrapping SpinWrapping { get; set; }
Public Property SpinWrapping As SpinWrapping
    Get
    Set

Property Value

Type: SpinWrapping
The wrapping behavior used when spinning past a minimum or maximum value in the active part. The default value is SpinWrapping.NoWrap.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).TextAlignment Property

DataGridPartEditBoxColumnBaseTTextAlignment Property

Gets or sets the text alignment of the text editing area.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextAlignment TextAlignment { get; set; }
Public Property TextAlignment As TextAlignment
    Get
    Set

Property Value

Type: TextAlignment
The text alignment of the text editing area. The default value is TextAlignment.Left.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T) Methods

DataGridPartEditBoxColumnBaseT Methods

The DataGridPartEditBoxColumnBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBinding | Associates the binding expression, defined by the Binding property, with the specified target property. (Inherited from DataGridBoundColumnBase.)
Protected method | ApplyStandardValues | Applies standard values to the specified target element.
Protected method | ApplyValue | Sets the value of the specified target object and property, based on the specified source property. (Inherited from DataGridBoundColumnBase.)
Protected method | CancelCellEdit | Causes the cell being edited to revert to the original, unedited value. (Inherited from DataGridColumn.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CommitCellEdit | Performs any required validation before exiting cell editing mode. (Inherited from DataGridColumn.)
Protected method | GenerateEditBox | Generates an instance of a PartEditBoxBase-derived object.
Protected method | GenerateEditingElement | Generates the editing element. (Overrides DataGridColumnGenerateEditingElement(DataGridCell, Object).)
Protected method | GenerateElement | Generates the display element. (Overrides DataGridColumnGenerateElement(DataGridCell, Object).)
Public method | GetCellContent(Object) | Gets the Content property value for the cell at the intersection of this column and the row that represents the specified data item. (Inherited from DataGridColumn.)
Public method | GetCellContent(DataGridRow) | Retrieves the Content property value for the cell at the intersection of this column and the specified row. (Inherited from DataGridColumn.)
Protected method | GetEditBoxType | Gets the type of the associated PartEditBoxBase-derived control.
Protected method | NotifyPropertyChanged | Notifies the DataGrid that contains this column that a column property has changed. (Inherited from DataGridColumn.)
Protected method | OnBindingChanged | Notifies the DataGrid when the value of the Binding property changes. (Inherited from DataGridBoundColumn.)
Protected method | OnCoerceIsReadOnly | Determines the value of the IsReadOnly property based on property rules from the data grid that contains this column. (Inherited from DataGridBoundColumn.)
Public method | OnCopyingCellClipboardContent | Raises the CopyingCellClipboardContent event. (Inherited from DataGridColumn.)
Public method | OnPastingCellClipboardContent | Raises the PastingCellClipboardContent event. (Inherited from DataGridColumn.)
Protected method | PrepareCellForEdit | Prepares the cell for edit. (Overrides DataGridColumnPrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
Protected method | RefreshCellContent | Refreshes the contents of a cell in the column in response to a column property value change. (Inherited from DataGridBoundColumnBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).ApplyStandardValues Method

DataGridPartEditBoxColumnBaseTApplyStandardValues Method

Applies standard values to the specified target element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void ApplyStandardValues(
    FrameworkElement targetElement
)
Protected Overridable Sub ApplyStandardValues (
    targetElement As FrameworkElement
)

Parameters

targetElement
Type: System.WindowsFrameworkElement
The target element.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).GenerateEditBox Method

DataGridPartEditBoxColumnBaseTGenerateEditBox Method

Generates an instance of a PartEditBoxBase-derived object.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual PartEditBoxBase<T> GenerateEditBox(
    bool isEditing,
    DataGridCell cell
)
Protected Overridable Function GenerateEditBox (
    isEditing As Boolean,
    cell As DataGridCell
) As PartEditBoxBase(Of T)

Parameters

isEditing
Type: SystemBoolean
Whether the edit box will be used for editing.
cell
Type: System.Windows.ControlsDataGridCell
The cell.

Return Value

Type: PartEditBoxBase T
An instance of a PartEditBoxBase-derived object.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).GenerateEditingElement Method

DataGridPartEditBoxColumnBaseTGenerateEditingElement Method

Generates the editing element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override FrameworkElement GenerateEditingElement(
    DataGridCell cell,
    Object dataItem
)
Protected Overrides Function GenerateEditingElement (
    cell As DataGridCell,
    dataItem As Object
) As FrameworkElement

Parameters

cell
Type: System.Windows.ControlsDataGridCell
The cell.
dataItem
Type: SystemObject
The data item.

Return Value

Type: FrameworkElement
The FrameworkElement to use for editing.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).GenerateElement Method

DataGridPartEditBoxColumnBaseTGenerateElement Method

Generates the display element.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override FrameworkElement GenerateElement(
    DataGridCell cell,
    Object dataItem
)
Protected Overrides Function GenerateElement (
    cell As DataGridCell,
    dataItem As Object
) As FrameworkElement

Parameters

cell
Type: System.Windows.ControlsDataGridCell
The cell.
dataItem
Type: SystemObject
The data item.

Return Value

Type: FrameworkElement
The FrameworkElement to use for display.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).GetEditBoxType Method

DataGridPartEditBoxColumnBaseTGetEditBoxType Method

Gets the type of the associated PartEditBoxBase-derived control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Type GetEditBoxType()
Protected MustOverride Function GetEditBoxType As Type

Return Value

Type: Type
The type of the associated PartEditBoxBase-derived control.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).PrepareCellForEdit Method

DataGridPartEditBoxColumnBaseTPrepareCellForEdit Method

Prepares the cell for edit.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Protected Overrides Function PrepareCellForEdit (
    editingElement As FrameworkElement,
    editingEventArgs As RoutedEventArgs
) As Object

Parameters

editingElement
Type: System.WindowsFrameworkElement
The editing element.
editingEventArgs
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs instance containing the event data.

Return Value

Type: Object

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives.DataGridPartEditBoxColumnBase`1.PrepareCellForEdit(System.Windows.FrameworkElement,System.Windows.RoutedEventArgs)"]

See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T) Events

DataGridPartEditBoxColumnBaseT Events

The DataGridPartEditBoxColumnBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | CopyingCellClipboardContent | Occurs after the cell clipboard content is prepared. (Inherited from DataGridColumn.)
Public event | PastingCellClipboardContent | Occurs before the clipboard content is moved to the cell. (Inherited from DataGridColumn.)
Top
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T) Fields

DataGridPartEditBoxColumnBaseT Fields

The DataGridPartEditBoxColumnBaseT generic type exposes the following members.

Fields
Name | Description
CommitTriggersProperty | Identifies the CommitTriggers dependency property. This field is read-only.
HasPopupProperty | Identifies the HasPopup dependency property. This field is read-only.
IsArrowKeyPartNavigationEnabledProperty | Identifies the IsArrowKeyPartNavigationEnabled dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsUndoEnabledProperty | Identifies the IsUndoEnabled dependency property. This field is read-only.
PlaceholderTextProperty | Identifies the PlaceholderText dependency property. This field is read-only.
SpinnerVisibilityProperty | Identifies the SpinnerVisibility dependency property. This field is read-only.
SpinWrappingProperty | Identifies the SpinWrapping dependency property. This field is read-only.
TextAlignmentProperty | Identifies the TextAlignment dependency property. This field is read-only.
Top
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).CommitTriggersProperty Field

DataGridPartEditBoxColumnBaseTCommitTriggersProperty Field

Identifies the CommitTriggers dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CommitTriggersProperty
Public Shared ReadOnly CommitTriggersProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CommitTriggers dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).HasPopupProperty Field

DataGridPartEditBoxColumnBaseTHasPopupProperty Field

Identifies the HasPopup dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasPopupProperty
Public Shared ReadOnly HasPopupProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasPopup dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).IsArrowKeyPartNavigationEnabledProperty Field

DataGridPartEditBoxColumnBaseTIsArrowKeyPartNavigationEnabledProperty Field

Identifies the IsArrowKeyPartNavigationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsArrowKeyPartNavigationEnabledProperty
Public Shared ReadOnly IsArrowKeyPartNavigationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsArrowKeyPartNavigationEnabled dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).IsEditableProperty Field

DataGridPartEditBoxColumnBaseTIsEditableProperty Field

Identifies the IsEditable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEditableProperty
Public Shared ReadOnly IsEditableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEditable dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).IsNullAllowedProperty Field

DataGridPartEditBoxColumnBaseTIsNullAllowedProperty Field

Identifies the IsNullAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNullAllowedProperty
Public Shared ReadOnly IsNullAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNullAllowed dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).IsUndoEnabledProperty Field

DataGridPartEditBoxColumnBaseTIsUndoEnabledProperty Field

Identifies the IsUndoEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsUndoEnabledProperty
Public Shared ReadOnly IsUndoEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsUndoEnabled dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).PlaceholderTextProperty Field

DataGridPartEditBoxColumnBaseTPlaceholderTextProperty Field

Identifies the PlaceholderText dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlaceholderTextProperty
Public Shared ReadOnly PlaceholderTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PlaceholderText dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).SpinnerVisibilityProperty Field

DataGridPartEditBoxColumnBaseTSpinnerVisibilityProperty Field

Identifies the SpinnerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SpinnerVisibilityProperty
Public Shared ReadOnly SpinnerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SpinnerVisibility dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).SpinWrappingProperty Field

DataGridPartEditBoxColumnBaseTSpinWrappingProperty Field

Identifies the SpinWrapping dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SpinWrappingProperty
Public Shared ReadOnly SpinWrappingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SpinWrapping dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


DataGridPartEditBoxColumnBase(T).TextAlignmentProperty Field

DataGridPartEditBoxColumnBaseTTextAlignmentProperty Field

Identifies the TextAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives
Assembly: ActiproSoftware.Editors.Interop.DataGrid.Wpf (in ActiproSoftware.Editors.Interop.DataGrid.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextAlignmentProperty
Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextAlignment dependency property.
See Also

Reference

DataGridPartEditBoxColumnBaseT Class
ActiproSoftware.Windows.Controls.Editors.Interop.DataGrid.Primitives Namespace


ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace

Contains property editor classes that support integration of Editors with PropertyGrid.
Classes
 | Class | Description
Public class | BrushPropertyEditor | Represents a PropertyEditor for editing a Brush value with a BrushEditBox.
Public class | BuiltinPropertyEditors | Provides access to the built-in editor property value templates.
Public class | BytePropertyEditor | Represents a PropertyEditor for editing a Byte value with a ByteEditBox.
Public class | ColorPropertyEditor | Represents a PropertyEditor for editing a Color value with a ColorEditBox.
Public class | CornerRadiusPropertyEditor | Represents a PropertyEditor for editing a CornerRadius value with a CornerRadiusEditBox.
Public class | DatePropertyEditor | Represents a PropertyEditor for editing a DateTime value with a DateEditBox.
Public class | DateTimePropertyEditor | Represents a PropertyEditor for editing a DateTime value with a DateTimeEditBox.
Public class | DoublePropertyEditor | Represents a PropertyEditor for editing a Double value with a DoubleEditBox.
Public class | EnumPropertyEditor | Represents a PropertyEditor for editing a Enum value with a EnumEditBox.
Public class | GuidPropertyEditor | Represents a PropertyEditor for editing a Guid value with a GuidEditBox.
Public class | Int16PropertyEditor | Represents a PropertyEditor for editing a Int16 value with a Int16EditBox.
Public class | Int32PropertyEditor | Represents a PropertyEditor for editing a Int32 value with a Int32EditBox.
Public class | Int32RectPropertyEditor | Represents a PropertyEditor for editing a Int32Rect value with a Int32RectEditBox.
Public class | Int64PropertyEditor | Represents a PropertyEditor for editing a Int64 value with a Int64EditBox.
Public class | MaskedStringPropertyEditor | Represents a PropertyEditor for editing a masked String value with a MaskedTextBox.
Public class | NullableBytePropertyEditor | Represents a PropertyEditor for editing a nullable Byte value with a ByteEditBox.
Public class | NullableColorPropertyEditor | Represents a PropertyEditor for editing a nullable Color value with a ColorEditBox.
Public class | NullableCornerRadiusPropertyEditor | Represents a PropertyEditor for editing a nullable CornerRadius value with a CornerRadiusEditBox.
Public class | NullableDatePropertyEditor | Represents a PropertyEditor for editing a nullable DateTime value with a DateEditBox.
Public class | NullableDateTimePropertyEditor | Represents a PropertyEditor for editing a nullable DateTime value with a DateTimeEditBox.
Public class | NullableDoublePropertyEditor | Represents a PropertyEditor for editing a nullable Double value with a DoubleEditBox.
Public class | NullableGuidPropertyEditor | Represents a PropertyEditor for editing a nullable Guid value with a GuidEditBox.
Public class | NullableInt16PropertyEditor | Represents a PropertyEditor for editing a nullable Int16 value with a Int16EditBox.
Public class | NullableInt32PropertyEditor | Represents a PropertyEditor for editing a nullable Int32 value with a Int32EditBox.
Public class | NullableInt32RectPropertyEditor | Represents a PropertyEditor for editing a nullable Int32Rect value with a Int32RectEditBox.
Public class | NullableInt64PropertyEditor | Represents a PropertyEditor for editing a nullable Int64 value with a Int64EditBox.
Public class | NullablePointPropertyEditor | Represents a PropertyEditor for editing a nullable Point value with a PointEditBox.
Public class | NullableRectPropertyEditor | Represents a PropertyEditor for editing a nullable Rect value with a RectEditBox.
Public class | NullableSinglePropertyEditor | Represents a PropertyEditor for editing a nullable Single value with a SingleEditBox.
Public class | NullableSizePropertyEditor | Represents a PropertyEditor for editing a nullable Size value with a SizeEditBox.
Public class | NullableThicknessPropertyEditor | Represents a PropertyEditor for editing a nullable Thickness value with a ThicknessEditBox.
Public class | NullableTimePropertyEditor | Represents a PropertyEditor for editing a nullable DateTime value with a TimeEditBox.
Public class | NullableTimeSpanPropertyEditor | Represents a PropertyEditor for editing a nullable TimeSpan value with a TimeSpanEditBox.
Public class | NullableVectorPropertyEditor | Represents a PropertyEditor for editing a nullable Vector value with a VectorEditBox.
Public class | PointPropertyEditor | Represents a PropertyEditor for editing a Point value with a PointEditBox.
Public class | PropertyEditorsResourceDictionary | Represents a ResourceDictionary related to the property editors defined in this assembly.
Public class | RectPropertyEditor | Represents a PropertyEditor for editing a Rect value with a RectEditBox.
Public class | SinglePropertyEditor | Represents a PropertyEditor for editing a Single value with a SingleEditBox.
Public class | SizePropertyEditor | Represents a PropertyEditor for editing a Size value with a SizeEditBox.
Public class | ThicknessPropertyEditor | Represents a PropertyEditor for editing a Thickness value with a ThicknessEditBox.
Public class | TimePropertyEditor | Represents a PropertyEditor for editing a DateTime value with a TimeEditBox.
Public class | TimeSpanPropertyEditor | Represents a PropertyEditor for editing a TimeSpan value with a TimeSpanEditBox.
Public class | VectorPropertyEditor | Represents a PropertyEditor for editing a Vector value with a VectorEditBox.


BrushPropertyEditor Class

Represents a PropertyEditor for editing a Brush value with a BrushEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsBrushPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BrushPropertyEditor : PartEditBoxPropertyEditorBase
Public Class BrushPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The BrushPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | BrushPropertyEditor | Initializes an instance of the BrushPropertyEditor class.
Protected method | BrushPropertyEditor(Type) | Initializes an instance of the BrushPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Constructor

Overload List
 | Name | Description
Public method | BrushPropertyEditor | Initializes an instance of the BrushPropertyEditor class.
Protected method | BrushPropertyEditor(Type) | Initializes an instance of the BrushPropertyEditor class.
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Constructor

Initializes an instance of the BrushPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BrushPropertyEditor()
Public Sub New
See Also

Reference

BrushPropertyEditor Class
BrushPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Constructor (Type)

Initializes an instance of the BrushPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected BrushPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

BrushPropertyEditor Class
BrushPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Properties

The BrushPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor.HasSwatch Property

BrushPropertyEditorHasSwatch Property

Gets or sets whether the edit box should display a swatch that previews the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box should display a swatch that previews the Value; otherwise, false. The default value is true.
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor.IsAlphaEnabled Property

BrushPropertyEditorIsAlphaEnabled Property

Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the brush value colors are enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor.IsGradientAllowed Property

BrushPropertyEditorIsGradientAllowed Property

Gets or sets whether gradient brush values can be entered.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsGradientAllowed { get; set; }
Public Property IsGradientAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if gradient brush values can be entered; otherwise, false. The default value is true.
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor.PredefinedValueTemplateKey Property

BrushPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Methods

The BrushPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Events

The BrushPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors Class

Provides access to the built-in editor property value templates.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsBuiltinPropertyEditors

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static class BuiltinPropertyEditors
Public NotInheritable Class BuiltinPropertyEditors

The BuiltinPropertyEditors type exposes the following members.

Methods
Name | Description
GetIsEnabled | Gets the value of the IsEnabled attached property for the specified object.
SetIsEnabled | Sets the value of the IsEnabled attached property to the specified object.
Top
Fields
Name | Description
IsEnabledProperty | Identifies the IsEnabled dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | IsEnabled |
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors Methods

The BuiltinPropertyEditors type exposes the following members.

Methods
Name | Description
GetIsEnabled | Gets the value of the IsEnabled attached property for the specified object.
SetIsEnabled | Sets the value of the IsEnabled attached property to the specified object.
Top
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors.GetIsEnabled Method

BuiltinPropertyEditorsGetIsEnabled Method

Gets the value of the IsEnabled attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsEnabled(
    IPropertyEditorsProvider obj
)
Public Shared Function GetIsEnabled (
    obj As IPropertyEditorsProvider
) As Boolean

Parameters

obj
Type: ActiproSoftware.Windows.Controls.Grids.PropertyEditorsIPropertyEditorsProvider
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors.SetIsEnabled Method

BuiltinPropertyEditorsSetIsEnabled Method

Sets the value of the IsEnabled attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIsEnabled(
    IPropertyEditorsProvider obj,
    bool value
)
Public Shared Sub SetIsEnabled (
    obj As IPropertyEditorsProvider,
    value As Boolean
)

Parameters

obj
Type: ActiproSoftware.Windows.Controls.Grids.PropertyEditorsIPropertyEditorsProvider
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors Fields

The BuiltinPropertyEditors type exposes the following members.

Fields
Name | Description
IsEnabledProperty | Identifies the IsEnabled dependency property. This field is read-only.
Top
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors.IsEnabledProperty Field

BuiltinPropertyEditorsIsEnabledProperty Field

Identifies the IsEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEnabledProperty
Public Shared ReadOnly IsEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEnabled dependency property.
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors Attached Properties

The BuiltinPropertyEditors type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsEnabled |
Top
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors.IsEnabled Attached Property

BuiltinPropertyEditorsIsEnabled Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.BuiltinPropertyEditors.IsEnabled"]

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsEnabled, SetIsEnabled
See GetIsEnabled, SetIsEnabled

Property Value

Type: Boolean
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor Class

Represents a PropertyEditor for editing a Byte value with a ByteEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsBytePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableBytePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BytePropertyEditor : PartEditBoxPropertyEditorBase
Public Class BytePropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The BytePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | BytePropertyEditor | Initializes an instance of the BytePropertyEditor class.
Protected method | BytePropertyEditor(Type) | Initializes an instance of the BytePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor Constructor

Overload List
 | Name | Description
Public method | BytePropertyEditor | Initializes an instance of the BytePropertyEditor class.
Protected method | BytePropertyEditor(Type) | Initializes an instance of the BytePropertyEditor class.
Top
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor Constructor

Initializes an instance of the BytePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BytePropertyEditor()
Public Sub New
See Also

Reference

BytePropertyEditor Class
BytePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor Constructor (Type)

Initializes an instance of the BytePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected BytePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

BytePropertyEditor Class
BytePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor Properties

The BytePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor.DefaultValue Property

BytePropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte DefaultValue { get; set; }
Public Property DefaultValue As Byte
    Get
    Set

Property Value

Type: Byte
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor.Format Property

BytePropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor.LargeChange Property

BytePropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte LargeChange { get; set; }
Public Property LargeChange As Byte
    Get
    Set

Property Value

Type: Byte
The large change value. The default value is 5.
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor.Maximum Property

BytePropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte Maximum { get; set; }
Public Property Maximum As Byte
    Get
    Set

Property Value

Type: Byte
The highest possible value.
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor.Minimum Property

BytePropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte Minimum { get; set; }
Public Property Minimum As Byte
    Get
    Set

Property Value

Type: Byte
The lowest possible value.
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor.PickerKind Property

BytePropertyEditorPickerKind Property

Gets or sets a ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ByteEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As ByteEditBoxPickerKind
    Get
    Set

Property Value

Type: ByteEditBoxPickerKind
A ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor.PredefinedValueTemplateKey Property

BytePropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor.SmallChange Property

BytePropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public byte SmallChange { get; set; }
Public Property SmallChange As Byte
    Get
    Set

Property Value

Type: Byte
The small change value. The default value is 1.
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor Methods

The BytePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BytePropertyEditor Events

The BytePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Class

Represents a PropertyEditor for editing a Color value with a ColorEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsColorPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableColorPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ColorPropertyEditor : PartEditBoxPropertyEditorBase
Public Class ColorPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The ColorPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ColorPropertyEditor | Initializes an instance of the ColorPropertyEditor class.
Protected method | ColorPropertyEditor(Type) | Initializes an instance of the ColorPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Constructor

Overload List
 | Name | Description
Public method | ColorPropertyEditor | Initializes an instance of the ColorPropertyEditor class.
Protected method | ColorPropertyEditor(Type) | Initializes an instance of the ColorPropertyEditor class.
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Constructor

Initializes an instance of the ColorPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorPropertyEditor()
Public Sub New
See Also

Reference

ColorPropertyEditor Class
ColorPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Constructor (Type)

Initializes an instance of the ColorPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ColorPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

ColorPropertyEditor Class
ColorPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Properties

The ColorPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor.DefaultValue Property

ColorPropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color DefaultValue { get; set; }
Public Property DefaultValue As Color
    Get
    Set

Property Value

Type: Color
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor.HasSwatch Property

ColorPropertyEditorHasSwatch Property

Gets or sets whether the edit box should display a swatch that previews the Value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box should display a swatch that previews the Value; otherwise, false. The default value is true.
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor.IsAlphaEnabled Property

ColorPropertyEditorIsAlphaEnabled Property

Gets or sets whether the alpha channel (transparency) of the color value is enabled.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the color value is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor.PredefinedValueTemplateKey Property

ColorPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Methods

The ColorPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Events

The ColorPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Class

Represents a PropertyEditor for editing a CornerRadius value with a CornerRadiusEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsCornerRadiusPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableCornerRadiusPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CornerRadiusPropertyEditor : PartEditBoxPropertyEditorBase
Public Class CornerRadiusPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The CornerRadiusPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | CornerRadiusPropertyEditor | Initializes an instance of the CornerRadiusPropertyEditor class.
Protected method | CornerRadiusPropertyEditor(Type) | Initializes an instance of the CornerRadiusPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Constructor

Overload List
 | Name | Description
Public method | CornerRadiusPropertyEditor | Initializes an instance of the CornerRadiusPropertyEditor class.
Protected method | CornerRadiusPropertyEditor(Type) | Initializes an instance of the CornerRadiusPropertyEditor class.
Top
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Constructor

Initializes an instance of the CornerRadiusPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadiusPropertyEditor()
Public Sub New
See Also

Reference

CornerRadiusPropertyEditor Class
CornerRadiusPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Constructor (Type)

Initializes an instance of the CornerRadiusPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected CornerRadiusPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

CornerRadiusPropertyEditor Class
CornerRadiusPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Properties

The CornerRadiusPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.DefaultValue Property

CornerRadiusPropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius DefaultValue { get; set; }
Public Property DefaultValue As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.Format Property

CornerRadiusPropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.IsNaNAllowed Property

CornerRadiusPropertyEditorIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.IsNegativeInfinityAllowed Property

CornerRadiusPropertyEditorIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.IsPositiveInfinityAllowed Property

CornerRadiusPropertyEditorIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.LargeChange Property

CornerRadiusPropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius LargeChange { get; set; }
Public Property LargeChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The large change value. The default value is 5.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.Maximum Property

CornerRadiusPropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius Maximum { get; set; }
Public Property Maximum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The highest possible value.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.Minimum Property

CornerRadiusPropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius Minimum { get; set; }
Public Property Minimum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The lowest possible value.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.PredefinedValueTemplateKey Property

CornerRadiusPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.RoundingDecimalPlace Property

CornerRadiusPropertyEditorRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.SmallChange Property

CornerRadiusPropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CornerRadius SmallChange { get; set; }
Public Property SmallChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The small change value. The default value is 1.
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Methods

The CornerRadiusPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Events

The CornerRadiusPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Class

Represents a PropertyEditor for editing a DateTime value with a DateEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDatePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableDatePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DatePropertyEditor : DateTimePropertyEditor
Public Class DatePropertyEditor
    Inherits DateTimePropertyEditor

The DatePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | DatePropertyEditor | Initializes an instance of the DatePropertyEditor class.
Protected method | DatePropertyEditor(Type) | Initializes an instance of the DatePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides DateTimePropertyEditorPredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Constructor

Overload List
 | Name | Description
Public method | DatePropertyEditor | Initializes an instance of the DatePropertyEditor class.
Protected method | DatePropertyEditor(Type) | Initializes an instance of the DatePropertyEditor class.
Top
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Constructor

Initializes an instance of the DatePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DatePropertyEditor()
Public Sub New
See Also

Reference

DatePropertyEditor Class
DatePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Constructor (Type)

Initializes an instance of the DatePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DatePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

DatePropertyEditor Class
DatePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Properties

The DatePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides DateTimePropertyEditorPredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor.PredefinedValueTemplateKey Property

DatePropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Methods

The DatePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Events

The DatePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Class

Represents a PropertyEditor for editing a DateTime value with a DateTimeEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDatePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableDateTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsTimePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DateTimePropertyEditor : PartEditBoxPropertyEditorBase
Public Class DateTimePropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The DateTimePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimePropertyEditor | Initializes an instance of the DateTimePropertyEditor class.
Protected method | DateTimePropertyEditor(Type) | Initializes an instance of the DateTimePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Constructor

Overload List
 | Name | Description
Public method | DateTimePropertyEditor | Initializes an instance of the DateTimePropertyEditor class.
Protected method | DateTimePropertyEditor(Type) | Initializes an instance of the DateTimePropertyEditor class.
Top
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Constructor

Initializes an instance of the DateTimePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTimePropertyEditor()
Public Sub New
See Also

Reference

DateTimePropertyEditor Class
DateTimePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Constructor (Type)

Initializes an instance of the DateTimePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DateTimePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

DateTimePropertyEditor Class
DateTimePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Properties

The DateTimePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor.Format Property

DateTimePropertyEditorFormat Property

Gets or sets the date/time format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number date/time string. The default value is "g".
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor.Maximum Property

DateTimePropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor.Minimum Property

DateTimePropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor.PredefinedValueTemplateKey Property

DateTimePropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Methods

The DateTimePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Events

The DateTimePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Class

Represents a PropertyEditor for editing a Double value with a DoubleEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDoublePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableDoublePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoublePropertyEditor : PartEditBoxPropertyEditorBase
Public Class DoublePropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The DoublePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | DoublePropertyEditor | Initializes an instance of the DoublePropertyEditor class.
Protected method | DoublePropertyEditor(Type) | Initializes an instance of the DoublePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Constructor

Overload List
 | Name | Description
Public method | DoublePropertyEditor | Initializes an instance of the DoublePropertyEditor class.
Protected method | DoublePropertyEditor(Type) | Initializes an instance of the DoublePropertyEditor class.
Top
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Constructor

Initializes an instance of the DoublePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoublePropertyEditor()
Public Sub New
See Also

Reference

DoublePropertyEditor Class
DoublePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Constructor (Type)

Initializes an instance of the DoublePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DoublePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

DoublePropertyEditor Class
DoublePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Properties

The DoublePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.DefaultValue Property

DoublePropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DefaultValue { get; set; }
Public Property DefaultValue As Double
    Get
    Set

Property Value

Type: Double
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.Format Property

DoublePropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.IsNaNAllowed Property

DoublePropertyEditorIsNaNAllowed Property

Gets or sets whether NaN is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.IsNegativeInfinityAllowed Property

DoublePropertyEditorIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.IsPositiveInfinityAllowed Property

DoublePropertyEditorIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.LargeChange Property

DoublePropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LargeChange { get; set; }
Public Property LargeChange As Double
    Get
    Set

Property Value

Type: Double
The large change value. The default value is 5.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.Maximum Property

DoublePropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible value.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.Minimum Property

DoublePropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible value.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.PickerKind Property

DoublePropertyEditorPickerKind Property

Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As DoubleEditBoxPickerKind
    Get
    Set

Property Value

Type: DoubleEditBoxPickerKind
A DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.PredefinedValueTemplateKey Property

DoublePropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.RoundingDecimalPlace Property

DoublePropertyEditorRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.SmallChange Property

DoublePropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SmallChange { get; set; }
Public Property SmallChange As Double
    Get
    Set

Property Value

Type: Double
The small change value. The default value is 1.
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Methods

The DoublePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Events

The DoublePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Class

Represents a PropertyEditor for editing a Enum value with a EnumEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsEnumPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumPropertyEditor : PartEditBoxPropertyEditorBase
Public Class EnumPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The EnumPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | EnumPropertyEditor | Initializes an instance of the EnumPropertyEditor class.
Protected method | EnumPropertyEditor(Type) | Initializes an instance of the EnumPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Constructor

Overload List
 | Name | Description
Public method | EnumPropertyEditor | Initializes an instance of the EnumPropertyEditor class.
Protected method | EnumPropertyEditor(Type) | Initializes an instance of the EnumPropertyEditor class.
Top
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Constructor

Initializes an instance of the EnumPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumPropertyEditor()
Public Sub New
See Also

Reference

EnumPropertyEditor Class
EnumPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Constructor (Type)

Initializes an instance of the EnumPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected EnumPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

EnumPropertyEditor Class
EnumPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Properties

The EnumPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor.EnumSortComparer Property

EnumPropertyEditorEnumSortComparer Property

Gets or sets the IComparerT used to sort the enumeration values.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IComparer<Enum> EnumSortComparer { get; set; }
Public Property EnumSortComparer As IComparer(Of Enum)
    Get
    Set

Property Value

Type: IComparer Enum
The IComparerT used to sort the enumeration values; otherwise to indicate no sorting, which will use the order the enumeration values are defined.
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor.PredefinedValueTemplateKey Property

EnumPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor.UseDisplayAttributes Property

EnumPropertyEditorUseDisplayAttributes Property

Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool UseDisplayAttributes { get; set; }
Public Property UseDisplayAttributes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if enumeration values should be displayed using an associated DisplayAttribute, if any; otherwise false. The default value is false.
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Methods

The EnumPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Events

The EnumPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Class

Represents a PropertyEditor for editing a Guid value with a GuidEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsGuidPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableGuidPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GuidPropertyEditor : PartEditBoxPropertyEditorBase
Public Class GuidPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The GuidPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | GuidPropertyEditor | Initializes an instance of the GuidPropertyEditor class.
Protected method | GuidPropertyEditor(Type) | Initializes an instance of the GuidPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the GUID format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Constructor

Overload List
 | Name | Description
Public method | GuidPropertyEditor | Initializes an instance of the GuidPropertyEditor class.
Protected method | GuidPropertyEditor(Type) | Initializes an instance of the GuidPropertyEditor class.
Top
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Constructor

Initializes an instance of the GuidPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GuidPropertyEditor()
Public Sub New
See Also

Reference

GuidPropertyEditor Class
GuidPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Constructor (Type)

Initializes an instance of the GuidPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected GuidPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

GuidPropertyEditor Class
GuidPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Properties

The GuidPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the GUID format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor.Format Property

GuidPropertyEditorFormat Property

Gets or sets the GUID format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The GUID format string. The default value is "D".
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor.PredefinedValueTemplateKey Property

GuidPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Methods

The GuidPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Events

The GuidPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Class

Represents a PropertyEditor for editing a Int16 value with a Int16EditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt16PropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt16PropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int16PropertyEditor : PartEditBoxPropertyEditorBase
Public Class Int16PropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The Int16PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | Int16PropertyEditor | Initializes an instance of the Int16PropertyEditor class.
Protected method | Int16PropertyEditor(Type) | Initializes an instance of the Int16PropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Constructor

Overload List
 | Name | Description
Public method | Int16PropertyEditor | Initializes an instance of the Int16PropertyEditor class.
Protected method | Int16PropertyEditor(Type) | Initializes an instance of the Int16PropertyEditor class.
Top
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Constructor

Initializes an instance of the Int16PropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int16PropertyEditor()
Public Sub New
See Also

Reference

Int16PropertyEditor Class
Int16PropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Constructor (Type)

Initializes an instance of the Int16PropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Int16PropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

Int16PropertyEditor Class
Int16PropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Properties

The Int16PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.DefaultValue Property

Int16PropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short DefaultValue { get; set; }
Public Property DefaultValue As Short
    Get
    Set

Property Value

Type: Int16
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.Format Property

Int16PropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.LargeChange Property

Int16PropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short LargeChange { get; set; }
Public Property LargeChange As Short
    Get
    Set

Property Value

Type: Int16
The large change value. The default value is 5.
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.Maximum Property

Int16PropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short Maximum { get; set; }
Public Property Maximum As Short
    Get
    Set

Property Value

Type: Int16
The highest possible value.
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.Minimum Property

Int16PropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short Minimum { get; set; }
Public Property Minimum As Short
    Get
    Set

Property Value

Type: Int16
The lowest possible value.
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.PickerKind Property

Int16PropertyEditorPickerKind Property

Gets or sets a Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int16EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int16EditBoxPickerKind
    Get
    Set

Property Value

Type: Int16EditBoxPickerKind
A Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.PredefinedValueTemplateKey Property

Int16PropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.SmallChange Property

Int16PropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public short SmallChange { get; set; }
Public Property SmallChange As Short
    Get
    Set

Property Value

Type: Int16
The small change value. The default value is 1.
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Methods

The Int16PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Events

The Int16PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Class

Represents a PropertyEditor for editing a Int32 value with a Int32EditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt32PropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt32PropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int32PropertyEditor : PartEditBoxPropertyEditorBase
Public Class Int32PropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The Int32PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | Int32PropertyEditor | Initializes an instance of the Int32PropertyEditor class.
Protected method | Int32PropertyEditor(Type) | Initializes an instance of the Int32PropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Constructor

Overload List
 | Name | Description
Public method | Int32PropertyEditor | Initializes an instance of the Int32PropertyEditor class.
Protected method | Int32PropertyEditor(Type) | Initializes an instance of the Int32PropertyEditor class.
Top
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Constructor

Initializes an instance of the Int32PropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32PropertyEditor()
Public Sub New
See Also

Reference

Int32PropertyEditor Class
Int32PropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Constructor (Type)

Initializes an instance of the Int32PropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Int32PropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

Int32PropertyEditor Class
Int32PropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Properties

The Int32PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.DefaultValue Property

Int32PropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int DefaultValue { get; set; }
Public Property DefaultValue As Integer
    Get
    Set

Property Value

Type: Int32
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.Format Property

Int32PropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.LargeChange Property

Int32PropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int LargeChange { get; set; }
Public Property LargeChange As Integer
    Get
    Set

Property Value

Type: Int32
The large change value. The default value is 5.
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.Maximum Property

Int32PropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Maximum { get; set; }
Public Property Maximum As Integer
    Get
    Set

Property Value

Type: Int32
The highest possible value.
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.Minimum Property

Int32PropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set

Property Value

Type: Int32
The lowest possible value.
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.PickerKind Property

Int32PropertyEditorPickerKind Property

Gets or sets a Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int32EditBoxPickerKind
    Get
    Set

Property Value

Type: Int32EditBoxPickerKind
A Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.PredefinedValueTemplateKey Property

Int32PropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.SmallChange Property

Int32PropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SmallChange { get; set; }
Public Property SmallChange As Integer
    Get
    Set

Property Value

Type: Int32
The small change value. The default value is 1.
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Methods

The Int32PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Events

The Int32PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor Class

Represents a PropertyEditor for editing a Int32Rect value with a Int32RectEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt32RectPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt32RectPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int32RectPropertyEditor : PartEditBoxPropertyEditorBase
Public Class Int32RectPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The Int32RectPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | Int32RectPropertyEditor | Initializes an instance of the Int32RectPropertyEditor class.
Protected method | Int32RectPropertyEditor(Type) | Initializes an instance of the Int32RectPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor Constructor

Overload List
 | Name | Description
Public method | Int32RectPropertyEditor | Initializes an instance of the Int32RectPropertyEditor class.
Protected method | Int32RectPropertyEditor(Type) | Initializes an instance of the Int32RectPropertyEditor class.
Top
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor Constructor

Initializes an instance of the Int32RectPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32RectPropertyEditor()
Public Sub New
See Also

Reference

Int32RectPropertyEditor Class
Int32RectPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor Constructor (Type)

Initializes an instance of the Int32RectPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Int32RectPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

Int32RectPropertyEditor Class
Int32RectPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor Properties

The Int32RectPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor.DefaultValue Property

Int32RectPropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect DefaultValue { get; set; }
Public Property DefaultValue As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor.Format Property

Int32RectPropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor.LargeChange Property

Int32RectPropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect LargeChange { get; set; }
Public Property LargeChange As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The large change value. The default value is 5.
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor.Maximum Property

Int32RectPropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect Maximum { get; set; }
Public Property Maximum As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The highest possible value.
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor.Minimum Property

Int32RectPropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect Minimum { get; set; }
Public Property Minimum As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The lowest possible value.
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor.PredefinedValueTemplateKey Property

Int32RectPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor.SmallChange Property

Int32RectPropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int32Rect SmallChange { get; set; }
Public Property SmallChange As Int32Rect
    Get
    Set

Property Value

Type: Int32Rect
The small change value. The default value is 1.
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor Methods

The Int32RectPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32RectPropertyEditor Events

The Int32RectPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Class

Represents a PropertyEditor for editing a Int64 value with a Int64EditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt64PropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt64PropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Int64PropertyEditor : PartEditBoxPropertyEditorBase
Public Class Int64PropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The Int64PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | Int64PropertyEditor | Initializes an instance of the Int64PropertyEditor class.
Protected method | Int64PropertyEditor(Type) | Initializes an instance of the Int64PropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Constructor

Overload List
 | Name | Description
Public method | Int64PropertyEditor | Initializes an instance of the Int64PropertyEditor class.
Protected method | Int64PropertyEditor(Type) | Initializes an instance of the Int64PropertyEditor class.
Top
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Constructor

Initializes an instance of the Int64PropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int64PropertyEditor()
Public Sub New
See Also

Reference

Int64PropertyEditor Class
Int64PropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Constructor (Type)

Initializes an instance of the Int64PropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Int64PropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

Int64PropertyEditor Class
Int64PropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Properties

The Int64PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.DefaultValue Property

Int64PropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long DefaultValue { get; set; }
Public Property DefaultValue As Long
    Get
    Set

Property Value

Type: Int64
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.Format Property

Int64PropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.LargeChange Property

Int64PropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long LargeChange { get; set; }
Public Property LargeChange As Long
    Get
    Set

Property Value

Type: Int64
The large change value. The default value is 5.
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.Maximum Property

Int64PropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long Maximum { get; set; }
Public Property Maximum As Long
    Get
    Set

Property Value

Type: Int64
The highest possible value.
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.Minimum Property

Int64PropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long Minimum { get; set; }
Public Property Minimum As Long
    Get
    Set

Property Value

Type: Int64
The lowest possible value.
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.PickerKind Property

Int64PropertyEditorPickerKind Property

Gets or sets a Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Int64EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int64EditBoxPickerKind
    Get
    Set

Property Value

Type: Int64EditBoxPickerKind
A Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.PredefinedValueTemplateKey Property

Int64PropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.SmallChange Property

Int64PropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public long SmallChange { get; set; }
Public Property SmallChange As Long
    Get
    Set

Property Value

Type: Int64
The small change value. The default value is 1.
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Methods

The Int64PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Events

The Int64PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Class

Represents a PropertyEditor for editing a masked String value with a MaskedTextBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsMaskedStringPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MaskedStringPropertyEditor : PropertyEditorBase
Public Class MaskedStringPropertyEditor
    Inherits PropertyEditorBase

The MaskedStringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | MaskedStringPropertyEditor | Initializes an instance of the MaskedStringPropertyEditor class.
Top
Properties
 | Name | Description
Public property | IsCaseAutoCorrected | Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.
Public property | IsCaseSensitive | Gets or sets whether the mask is case sensitive.
Public property | Mask | Gets or sets the text that designates the input mask.
Public property | MaskKind | Gets or sets the kind of input mask.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PromptChar | Gets or sets the character used to indicate required input.
Public property | PromptVisibility | Gets or sets the visibility of mask prompts.
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
Remarks
This property editor is not automatically installed by the BuiltinPropertyEditors since it requires a specific Mask to be set to the scenario in which it is used. Set a Mask and also the PropertyName (or also ObjectType and PropertyType properties as needed) of the property to target with this property editor.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Constructor

Initializes an instance of the MaskedStringPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MaskedStringPropertyEditor()
Public Sub New
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Properties

The MaskedStringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsCaseAutoCorrected | Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.
Public property | IsCaseSensitive | Gets or sets whether the mask is case sensitive.
Public property | Mask | Gets or sets the text that designates the input mask.
Public property | MaskKind | Gets or sets the kind of input mask.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PromptChar | Gets or sets the character used to indicate required input.
Public property | PromptVisibility | Gets or sets the visibility of mask prompts.
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.IsCaseAutoCorrected Property

MaskedStringPropertyEditorIsCaseAutoCorrected Property

Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCaseAutoCorrected { get; set; }
Public Property IsCaseAutoCorrected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if characters entered will have their case auto-corrected to match the defined mask; otherwise, false. The default value is false.
Remarks
When this property is set to true, then the IsCaseSensitive property is ignored.
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.IsCaseSensitive Property

MaskedStringPropertyEditorIsCaseSensitive Property

Gets or sets whether the mask is case sensitive.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCaseSensitive { get; set; }
Public Property IsCaseSensitive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the mask is case sensitive; otherwise, false. The default value is false.
Remarks
When the IsCaseAutoCorrected property is set to true, this property is ignored.
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.Mask Property

MaskedStringPropertyEditorMask Property

Gets or sets the text that designates the input mask.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set

Property Value

Type: String
The text that designates the input mask. The default value is .
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.MaskKind Property

MaskedStringPropertyEditorMaskKind Property

Gets or sets the kind of input mask.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MaskKind MaskKind { get; set; }
Public Property MaskKind As MaskKind
    Get
    Set

Property Value

Type: MaskKind
The kind of input mask. The default value is Regex.
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.PredefinedValueTemplateKey Property

MaskedStringPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.PromptChar Property

MaskedStringPropertyEditorPromptChar Property

Gets or sets the character used to indicate required input.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public char PromptChar { get; set; }
Public Property PromptChar As Char
    Get
    Set

Property Value

Type: Char
The character used to indicate required input. The default value is \u2022.
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.PromptVisibility Property

MaskedStringPropertyEditorPromptVisibility Property

Gets or sets the visibility of mask prompts.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MaskPromptVisibility PromptVisibility { get; set; }
Public Property PromptVisibility As MaskPromptVisibility
    Get
    Set

Property Value

Type: MaskPromptVisibility
A MaskPromptVisibility that indicates the visibility of mask prompts. The default value is FocusedOnly.
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Methods

The MaskedStringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Events

The MaskedStringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableBytePropertyEditor Class

Represents a PropertyEditor for editing a nullable Byte value with a ByteEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsBytePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableBytePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableBytePropertyEditor : BytePropertyEditor
Public Class NullableBytePropertyEditor
    Inherits BytePropertyEditor

The NullableBytePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableBytePropertyEditor | Initializes an instance of the NullableBytePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from BytePropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from BytePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from BytePropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from BytePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from BytePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from BytePropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from BytePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from BytePropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableBytePropertyEditor Constructor

Initializes an instance of the NullableBytePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableBytePropertyEditor()
Public Sub New
See Also

Reference

NullableBytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableBytePropertyEditor Properties

The NullableBytePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from BytePropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from BytePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from BytePropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from BytePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from BytePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a ByteEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from BytePropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from BytePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from BytePropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableBytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableBytePropertyEditor Methods

The NullableBytePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableBytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableBytePropertyEditor Events

The NullableBytePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableBytePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Class

Represents a PropertyEditor for editing a nullable Color value with a ColorEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsColorPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableColorPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableColorPropertyEditor : ColorPropertyEditor
Public Class NullableColorPropertyEditor
    Inherits ColorPropertyEditor

The NullableColorPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableColorPropertyEditor | Initializes an instance of the NullableColorPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from ColorPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value. (Inherited from ColorPropertyEditor.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled. (Inherited from ColorPropertyEditor.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from ColorPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Constructor

Initializes an instance of the NullableColorPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableColorPropertyEditor()
Public Sub New
See Also

Reference

NullableColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Properties

The NullableColorPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from ColorPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value. (Inherited from ColorPropertyEditor.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled. (Inherited from ColorPropertyEditor.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from ColorPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Methods

The NullableColorPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Events

The NullableColorPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Class

Represents a PropertyEditor for editing a nullable CornerRadius value with a CornerRadiusEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsCornerRadiusPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableCornerRadiusPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableCornerRadiusPropertyEditor : CornerRadiusPropertyEditor
Public Class NullableCornerRadiusPropertyEditor
    Inherits CornerRadiusPropertyEditor

The NullableCornerRadiusPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableCornerRadiusPropertyEditor | Initializes an instance of the NullableCornerRadiusPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from CornerRadiusPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from CornerRadiusPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from CornerRadiusPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from CornerRadiusPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from CornerRadiusPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from CornerRadiusPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from CornerRadiusPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from CornerRadiusPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from CornerRadiusPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from CornerRadiusPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from CornerRadiusPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Constructor

Initializes an instance of the NullableCornerRadiusPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableCornerRadiusPropertyEditor()
Public Sub New
See Also

Reference

NullableCornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Properties

The NullableCornerRadiusPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from CornerRadiusPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from CornerRadiusPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from CornerRadiusPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from CornerRadiusPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from CornerRadiusPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from CornerRadiusPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from CornerRadiusPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from CornerRadiusPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from CornerRadiusPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from CornerRadiusPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from CornerRadiusPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableCornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Methods

The NullableCornerRadiusPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableCornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Events

The NullableCornerRadiusPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableCornerRadiusPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Class

Represents a PropertyEditor for editing a nullable DateTime value with a DateEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDatePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableDatePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableDatePropertyEditor : DatePropertyEditor
Public Class NullableDatePropertyEditor
    Inherits DatePropertyEditor

The NullableDatePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableDatePropertyEditor | Initializes an instance of the NullableDatePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from DatePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Constructor

Initializes an instance of the NullableDatePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableDatePropertyEditor()
Public Sub New
See Also

Reference

NullableDatePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Properties

The NullableDatePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from DatePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableDatePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Methods

The NullableDatePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableDatePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Events

The NullableDatePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableDatePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Class

Represents a PropertyEditor for editing a nullable DateTime value with a DateTimeEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableDateTimePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableDateTimePropertyEditor : DateTimePropertyEditor
Public Class NullableDateTimePropertyEditor
    Inherits DateTimePropertyEditor

The NullableDateTimePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableDateTimePropertyEditor | Initializes an instance of the NullableDateTimePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from DateTimePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Constructor

Initializes an instance of the NullableDateTimePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableDateTimePropertyEditor()
Public Sub New
See Also

Reference

NullableDateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Properties

The NullableDateTimePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from DateTimePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableDateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Methods

The NullableDateTimePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableDateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Events

The NullableDateTimePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableDateTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Class

Represents a PropertyEditor for editing a nullable Double value with a DoubleEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDoublePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableDoublePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableDoublePropertyEditor : DoublePropertyEditor
Public Class NullableDoublePropertyEditor
    Inherits DoublePropertyEditor

The NullableDoublePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableDoublePropertyEditor | Initializes an instance of the NullableDoublePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from DoublePropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from DoublePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value. (Inherited from DoublePropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value. (Inherited from DoublePropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value. (Inherited from DoublePropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from DoublePropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DoublePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DoublePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from DoublePropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from DoublePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from DoublePropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from DoublePropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Constructor

Initializes an instance of the NullableDoublePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableDoublePropertyEditor()
Public Sub New
See Also

Reference

NullableDoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Properties

The NullableDoublePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from DoublePropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from DoublePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value. (Inherited from DoublePropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value. (Inherited from DoublePropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value. (Inherited from DoublePropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from DoublePropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DoublePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DoublePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from DoublePropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from DoublePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from DoublePropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from DoublePropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableDoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Methods

The NullableDoublePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableDoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Events

The NullableDoublePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableDoublePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Class

Represents a PropertyEditor for editing a nullable Guid value with a GuidEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsGuidPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableGuidPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableGuidPropertyEditor : GuidPropertyEditor
Public Class NullableGuidPropertyEditor
    Inherits GuidPropertyEditor

The NullableGuidPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableGuidPropertyEditor | Initializes an instance of the NullableGuidPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the GUID format string. (Inherited from GuidPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from GuidPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Constructor

Initializes an instance of the NullableGuidPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableGuidPropertyEditor()
Public Sub New
See Also

Reference

NullableGuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Properties

The NullableGuidPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the GUID format string. (Inherited from GuidPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from GuidPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableGuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Methods

The NullableGuidPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableGuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Events

The NullableGuidPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableGuidPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Class

Represents a PropertyEditor for editing a nullable Int16 value with a Int16EditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt16PropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt16PropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableInt16PropertyEditor : Int16PropertyEditor
Public Class NullableInt16PropertyEditor
    Inherits Int16PropertyEditor

The NullableInt16PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableInt16PropertyEditor | Initializes an instance of the NullableInt16PropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from Int16PropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from Int16PropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from Int16PropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from Int16PropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from Int16PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from Int16PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from Int16PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from Int16PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Constructor

Initializes an instance of the NullableInt16PropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableInt16PropertyEditor()
Public Sub New
See Also

Reference

NullableInt16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Properties

The NullableInt16PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from Int16PropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from Int16PropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from Int16PropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from Int16PropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from Int16PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from Int16PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from Int16PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from Int16PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableInt16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Methods

The NullableInt16PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Events

The NullableInt16PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt16PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Class

Represents a PropertyEditor for editing a nullable Int32 value with a Int32EditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt32PropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt32PropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableInt32PropertyEditor : Int32PropertyEditor
Public Class NullableInt32PropertyEditor
    Inherits Int32PropertyEditor

The NullableInt32PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableInt32PropertyEditor | Initializes an instance of the NullableInt32PropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from Int32PropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from Int32PropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from Int32PropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from Int32PropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from Int32PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from Int32PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from Int32PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from Int32PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Constructor

Initializes an instance of the NullableInt32PropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableInt32PropertyEditor()
Public Sub New
See Also

Reference

NullableInt32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Properties

The NullableInt32PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from Int32PropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from Int32PropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from Int32PropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from Int32PropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from Int32PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from Int32PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from Int32PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from Int32PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableInt32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Methods

The NullableInt32PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Events

The NullableInt32PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt32PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32RectPropertyEditor Class

Represents a PropertyEditor for editing a nullable Int32Rect value with a Int32RectEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt32RectPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt32RectPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableInt32RectPropertyEditor : Int32RectPropertyEditor
Public Class NullableInt32RectPropertyEditor
    Inherits Int32RectPropertyEditor

The NullableInt32RectPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableInt32RectPropertyEditor | Initializes an instance of the NullableInt32RectPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from Int32RectPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from Int32RectPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from Int32RectPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from Int32RectPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from Int32RectPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from Int32RectPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from Int32RectPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32RectPropertyEditor Constructor

Initializes an instance of the NullableInt32RectPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableInt32RectPropertyEditor()
Public Sub New
See Also

Reference

NullableInt32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32RectPropertyEditor Properties

The NullableInt32RectPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from Int32RectPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from Int32RectPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from Int32RectPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from Int32RectPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from Int32RectPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from Int32RectPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from Int32RectPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableInt32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32RectPropertyEditor Methods

The NullableInt32RectPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32RectPropertyEditor Events

The NullableInt32RectPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt32RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Class

Represents a PropertyEditor for editing a nullable Int64 value with a Int64EditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt64PropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt64PropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableInt64PropertyEditor : Int64PropertyEditor
Public Class NullableInt64PropertyEditor
    Inherits Int64PropertyEditor

The NullableInt64PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableInt64PropertyEditor | Initializes an instance of the NullableInt64PropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from Int64PropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from Int64PropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from Int64PropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from Int64PropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from Int64PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from Int64PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from Int64PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from Int64PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Constructor

Initializes an instance of the NullableInt64PropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableInt64PropertyEditor()
Public Sub New
See Also

Reference

NullableInt64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Properties

The NullableInt64PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from Int64PropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from Int64PropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from Int64PropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from Int64PropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from Int64PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from Int64PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from Int64PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from Int64PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableInt64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Methods

The NullableInt64PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Events

The NullableInt64PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt64PropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Class

Represents a PropertyEditor for editing a nullable Point value with a PointEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsPointPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullablePointPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullablePointPropertyEditor : PointPropertyEditor
Public Class NullablePointPropertyEditor
    Inherits PointPropertyEditor

The NullablePointPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullablePointPropertyEditor | Initializes an instance of the NullablePointPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from PointPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from PointPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from PointPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from PointPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from PointPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from PointPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from PointPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from PointPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from PointPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from PointPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from PointPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Constructor

Initializes an instance of the NullablePointPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullablePointPropertyEditor()
Public Sub New
See Also

Reference

NullablePointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Properties

The NullablePointPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from PointPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from PointPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from PointPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from PointPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from PointPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from PointPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from PointPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from PointPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from PointPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from PointPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from PointPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullablePointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Methods

The NullablePointPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullablePointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Events

The NullablePointPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullablePointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Class

Represents a PropertyEditor for editing a nullable Rect value with a RectEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsRectPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableRectPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableRectPropertyEditor : RectPropertyEditor
Public Class NullableRectPropertyEditor
    Inherits RectPropertyEditor

The NullableRectPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableRectPropertyEditor | Initializes an instance of the NullableRectPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from RectPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from RectPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from RectPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from RectPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from RectPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from RectPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from RectPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from RectPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from RectPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from RectPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from RectPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Constructor

Initializes an instance of the NullableRectPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableRectPropertyEditor()
Public Sub New
See Also

Reference

NullableRectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Properties

The NullableRectPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from RectPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from RectPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from RectPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from RectPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from RectPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from RectPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from RectPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from RectPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from RectPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from RectPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from RectPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableRectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Methods

The NullableRectPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableRectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Events

The NullableRectPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableRectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Class

Represents a PropertyEditor for editing a nullable Single value with a SingleEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsSinglePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableSinglePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableSinglePropertyEditor : SinglePropertyEditor
Public Class NullableSinglePropertyEditor
    Inherits SinglePropertyEditor

The NullableSinglePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableSinglePropertyEditor | Initializes an instance of the NullableSinglePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from SinglePropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from SinglePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value. (Inherited from SinglePropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value. (Inherited from SinglePropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value. (Inherited from SinglePropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from SinglePropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from SinglePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from SinglePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from SinglePropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from SinglePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from SinglePropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from SinglePropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Constructor

Initializes an instance of the NullableSinglePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableSinglePropertyEditor()
Public Sub New
See Also

Reference

NullableSinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Properties

The NullableSinglePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from SinglePropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from SinglePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value. (Inherited from SinglePropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value. (Inherited from SinglePropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value. (Inherited from SinglePropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from SinglePropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from SinglePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from SinglePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. (Inherited from SinglePropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from SinglePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from SinglePropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from SinglePropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableSinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Methods

The NullableSinglePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableSinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Events

The NullableSinglePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableSinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Class

Represents a PropertyEditor for editing a nullable Size value with a SizeEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsSizePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableSizePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableSizePropertyEditor : SizePropertyEditor
Public Class NullableSizePropertyEditor
    Inherits SizePropertyEditor

The NullableSizePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableSizePropertyEditor | Initializes an instance of the NullableSizePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from SizePropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from SizePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from SizePropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from SizePropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from SizePropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from SizePropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from SizePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from SizePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from SizePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from SizePropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from SizePropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Constructor

Initializes an instance of the NullableSizePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableSizePropertyEditor()
Public Sub New
See Also

Reference

NullableSizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Properties

The NullableSizePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from SizePropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from SizePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from SizePropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from SizePropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from SizePropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from SizePropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from SizePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from SizePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from SizePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from SizePropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from SizePropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableSizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Methods

The NullableSizePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableSizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Events

The NullableSizePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableSizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Class

Represents a PropertyEditor for editing a nullable Thickness value with a ThicknessEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsThicknessPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableThicknessPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableThicknessPropertyEditor : ThicknessPropertyEditor
Public Class NullableThicknessPropertyEditor
    Inherits ThicknessPropertyEditor

The NullableThicknessPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableThicknessPropertyEditor | Initializes an instance of the NullableThicknessPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from ThicknessPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from ThicknessPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from ThicknessPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from ThicknessPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from ThicknessPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from ThicknessPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from ThicknessPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from ThicknessPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from ThicknessPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from ThicknessPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from ThicknessPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Constructor

Initializes an instance of the NullableThicknessPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableThicknessPropertyEditor()
Public Sub New
See Also

Reference

NullableThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Properties

The NullableThicknessPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from ThicknessPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from ThicknessPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from ThicknessPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from ThicknessPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from ThicknessPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from ThicknessPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from ThicknessPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from ThicknessPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from ThicknessPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from ThicknessPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from ThicknessPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Methods

The NullableThicknessPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Events

The NullableThicknessPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Class

Represents a PropertyEditor for editing a nullable DateTime value with a TimeEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableTimePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableTimePropertyEditor : TimePropertyEditor
Public Class NullableTimePropertyEditor
    Inherits TimePropertyEditor

The NullableTimePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableTimePropertyEditor | Initializes an instance of the NullableTimePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from TimePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Constructor

Initializes an instance of the NullableTimePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableTimePropertyEditor()
Public Sub New
See Also

Reference

NullableTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Properties

The NullableTimePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from TimePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Methods

The NullableTimePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Events

The NullableTimePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableTimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Class

Represents a PropertyEditor for editing a nullable TimeSpan value with a TimeSpanEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsTimeSpanPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableTimeSpanPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableTimeSpanPropertyEditor : TimeSpanPropertyEditor
Public Class NullableTimeSpanPropertyEditor
    Inherits TimeSpanPropertyEditor

The NullableTimeSpanPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableTimeSpanPropertyEditor | Initializes an instance of the NullableTimeSpanPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from TimeSpanPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from TimeSpanPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from TimeSpanPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from TimeSpanPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from TimeSpanPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from TimeSpanPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from TimeSpanPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Constructor

Initializes an instance of the NullableTimeSpanPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableTimeSpanPropertyEditor()
Public Sub New
See Also

Reference

NullableTimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Properties

The NullableTimeSpanPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from TimeSpanPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from TimeSpanPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from TimeSpanPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from TimeSpanPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from TimeSpanPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from TimeSpanPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from TimeSpanPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableTimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Methods

The NullableTimeSpanPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableTimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Events

The NullableTimeSpanPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableTimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableVectorPropertyEditor Class

Represents a PropertyEditor for editing a nullable Vector value with a VectorEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsVectorPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableVectorPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableVectorPropertyEditor : VectorPropertyEditor
Public Class NullableVectorPropertyEditor
    Inherits VectorPropertyEditor

The NullableVectorPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableVectorPropertyEditor | Initializes an instance of the NullableVectorPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from VectorPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from VectorPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from VectorPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from VectorPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from VectorPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from VectorPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from VectorPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from VectorPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from VectorPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from VectorPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from VectorPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableVectorPropertyEditor Constructor

Initializes an instance of the NullableVectorPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableVectorPropertyEditor()
Public Sub New
See Also

Reference

NullableVectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableVectorPropertyEditor Properties

The NullableVectorPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value. (Inherited from VectorPropertyEditor.)
Public property | Format | Gets or sets the number format string. (Inherited from VectorPropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value. (Inherited from VectorPropertyEditor.)
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value. (Inherited from VectorPropertyEditor.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value. (Inherited from VectorPropertyEditor.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value. (Inherited from VectorPropertyEditor.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from VectorPropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from VectorPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from VectorPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place. (Inherited from VectorPropertyEditor.)
Public property | SmallChange | Gets or sets the small change value. (Inherited from VectorPropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableVectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableVectorPropertyEditor Methods

The NullableVectorPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableVectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableVectorPropertyEditor Events

The NullableVectorPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableVectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Class

Represents a PropertyEditor for editing a Point value with a PointEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsPointPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullablePointPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PointPropertyEditor : PartEditBoxPropertyEditorBase
Public Class PointPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The PointPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | PointPropertyEditor | Initializes an instance of the PointPropertyEditor class.
Protected method | PointPropertyEditor(Type) | Initializes an instance of the PointPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Constructor

Overload List
 | Name | Description
Public method | PointPropertyEditor | Initializes an instance of the PointPropertyEditor class.
Protected method | PointPropertyEditor(Type) | Initializes an instance of the PointPropertyEditor class.
Top
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Constructor

Initializes an instance of the PointPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointPropertyEditor()
Public Sub New
See Also

Reference

PointPropertyEditor Class
PointPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Constructor (Type)

Initializes an instance of the PointPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected PointPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

PointPropertyEditor Class
PointPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Properties

The PointPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.DefaultValue Property

PointPropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point DefaultValue { get; set; }
Public Property DefaultValue As Point
    Get
    Set

Property Value

Type: Point
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.Format Property

PointPropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.IsNaNAllowed Property

PointPropertyEditorIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.IsNegativeInfinityAllowed Property

PointPropertyEditorIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.IsPositiveInfinityAllowed Property

PointPropertyEditorIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.LargeChange Property

PointPropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point LargeChange { get; set; }
Public Property LargeChange As Point
    Get
    Set

Property Value

Type: Point
The large change value. The default value is 5.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.Maximum Property

PointPropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point Maximum { get; set; }
Public Property Maximum As Point
    Get
    Set

Property Value

Type: Point
The highest possible value.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.Minimum Property

PointPropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point Minimum { get; set; }
Public Property Minimum As Point
    Get
    Set

Property Value

Type: Point
The lowest possible value.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.PredefinedValueTemplateKey Property

PointPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.RoundingDecimalPlace Property

PointPropertyEditorRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.SmallChange Property

PointPropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Point SmallChange { get; set; }
Public Property SmallChange As Point
    Get
    Set

Property Value

Type: Point
The small change value. The default value is 1.
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Methods

The PointPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Events

The PointPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary Class

Represents a ResourceDictionary related to the property editors defined in this assembly.
PropertyEditorsResourceDictionary
Inheritance Hierarchy
SystemObject
System.WindowsResourceDictionary
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsPropertyEditorsResourceDictionary

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class PropertyEditorsResourceDictionary : ResourceDictionary,
    IComponentConnector
Public NotInheritable Class PropertyEditorsResourceDictionary
    Inherits ResourceDictionary
    Implements IComponentConnector

The PropertyEditorsResourceDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyEditorsResourceDictionary | Initializes a new instance of the PropertyEditorsResourceDictionary class.
Top
Properties
Name | Description
Instance | Gets the instance of the ResourceDictionary.
Top
Methods
 | Name | Description
Public method | InitializeComponent | InitializeComponent
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary Constructor

Initializes a new instance of the PropertyEditorsResourceDictionary class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditorsResourceDictionary()
Public Sub New
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary Properties

The PropertyEditorsResourceDictionary type exposes the following members.

Properties
Name | Description
Instance | Gets the instance of the ResourceDictionary.
Top
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary.Instance Property

PropertyEditorsResourceDictionaryInstance Property

Gets the instance of the ResourceDictionary.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static PropertyEditorsResourceDictionary Instance { get; }
Public Shared ReadOnly Property Instance As PropertyEditorsResourceDictionary
    Get

Property Value

Type: PropertyEditorsResourceDictionary
The instance of the ResourceDictionary.
Remarks
Use this property to ensure that no excess instances of this type are created.
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary Methods

The PropertyEditorsResourceDictionary type exposes the following members.

Methods
 | Name | Description
Public method | InitializeComponent | InitializeComponent
Top
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary.InitializeComponent Method

PropertyEditorsResourceDictionaryInitializeComponent Method

InitializeComponent

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void InitializeComponent()
Public Sub InitializeComponent

Implements

IComponentConnectorInitializeComponent
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Class

Represents a PropertyEditor for editing a Rect value with a RectEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsRectPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableRectPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RectPropertyEditor : PartEditBoxPropertyEditorBase
Public Class RectPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The RectPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | RectPropertyEditor | Initializes an instance of the RectPropertyEditor class.
Protected method | RectPropertyEditor(Type) | Initializes an instance of the RectPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Constructor

Overload List
 | Name | Description
Public method | RectPropertyEditor | Initializes an instance of the RectPropertyEditor class.
Protected method | RectPropertyEditor(Type) | Initializes an instance of the RectPropertyEditor class.
Top
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Constructor

Initializes an instance of the RectPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RectPropertyEditor()
Public Sub New
See Also

Reference

RectPropertyEditor Class
RectPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Constructor (Type)

Initializes an instance of the RectPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected RectPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

RectPropertyEditor Class
RectPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Properties

The RectPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.DefaultValue Property

RectPropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect DefaultValue { get; set; }
Public Property DefaultValue As Rect
    Get
    Set

Property Value

Type: Rect
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.Format Property

RectPropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.IsNaNAllowed Property

RectPropertyEditorIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.IsNegativeInfinityAllowed Property

RectPropertyEditorIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.IsPositiveInfinityAllowed Property

RectPropertyEditorIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.LargeChange Property

RectPropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect LargeChange { get; set; }
Public Property LargeChange As Rect
    Get
    Set

Property Value

Type: Rect
The large change value. The default value is 5.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.Maximum Property

RectPropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect Maximum { get; set; }
Public Property Maximum As Rect
    Get
    Set

Property Value

Type: Rect
The highest possible value.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.Minimum Property

RectPropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect Minimum { get; set; }
Public Property Minimum As Rect
    Get
    Set

Property Value

Type: Rect
The lowest possible value.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.PredefinedValueTemplateKey Property

RectPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.RoundingDecimalPlace Property

RectPropertyEditorRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.SmallChange Property

RectPropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Rect SmallChange { get; set; }
Public Property SmallChange As Rect
    Get
    Set

Property Value

Type: Rect
The small change value. The default value is 1.
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Methods

The RectPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Events

The RectPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Class

Represents a PropertyEditor for editing a Single value with a SingleEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsSinglePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableSinglePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SinglePropertyEditor : PartEditBoxPropertyEditorBase
Public Class SinglePropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The SinglePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SinglePropertyEditor | Initializes an instance of the SinglePropertyEditor class.
Protected method | SinglePropertyEditor(Type) | Initializes an instance of the SinglePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Constructor

Overload List
 | Name | Description
Public method | SinglePropertyEditor | Initializes an instance of the SinglePropertyEditor class.
Protected method | SinglePropertyEditor(Type) | Initializes an instance of the SinglePropertyEditor class.
Top
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Constructor

Initializes an instance of the SinglePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SinglePropertyEditor()
Public Sub New
See Also

Reference

SinglePropertyEditor Class
SinglePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Constructor (Type)

Initializes an instance of the SinglePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected SinglePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

SinglePropertyEditor Class
SinglePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Properties

The SinglePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.DefaultValue Property

SinglePropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float DefaultValue { get; set; }
Public Property DefaultValue As Single
    Get
    Set

Property Value

Type: Single
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.Format Property

SinglePropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.IsNaNAllowed Property

SinglePropertyEditorIsNaNAllowed Property

Gets or sets whether NaN is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.IsNegativeInfinityAllowed Property

SinglePropertyEditorIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.IsPositiveInfinityAllowed Property

SinglePropertyEditorIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.LargeChange Property

SinglePropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float LargeChange { get; set; }
Public Property LargeChange As Single
    Get
    Set

Property Value

Type: Single
The large change value. The default value is 5.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.Maximum Property

SinglePropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float Maximum { get; set; }
Public Property Maximum As Single
    Get
    Set

Property Value

Type: Single
The highest possible value.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.Minimum Property

SinglePropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float Minimum { get; set; }
Public Property Minimum As Single
    Get
    Set

Property Value

Type: Single
The lowest possible value.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.PickerKind Property

SinglePropertyEditorPickerKind Property

Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SingleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As SingleEditBoxPickerKind
    Get
    Set

Property Value

Type: SingleEditBoxPickerKind
A SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.PredefinedValueTemplateKey Property

SinglePropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.RoundingDecimalPlace Property

SinglePropertyEditorRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 7. Pass a null value to disable rounding. The default value is 7.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.SmallChange Property

SinglePropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public float SmallChange { get; set; }
Public Property SmallChange As Single
    Get
    Set

Property Value

Type: Single
The small change value. The default value is 1.
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Methods

The SinglePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Events

The SinglePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Class

Represents a PropertyEditor for editing a Size value with a SizeEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsSizePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableSizePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SizePropertyEditor : PartEditBoxPropertyEditorBase
Public Class SizePropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The SizePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SizePropertyEditor | Initializes an instance of the SizePropertyEditor class.
Protected method | SizePropertyEditor(Type) | Initializes an instance of the SizePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Constructor

Overload List
 | Name | Description
Public method | SizePropertyEditor | Initializes an instance of the SizePropertyEditor class.
Protected method | SizePropertyEditor(Type) | Initializes an instance of the SizePropertyEditor class.
Top
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Constructor

Initializes an instance of the SizePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SizePropertyEditor()
Public Sub New
See Also

Reference

SizePropertyEditor Class
SizePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Constructor (Type)

Initializes an instance of the SizePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected SizePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

SizePropertyEditor Class
SizePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Properties

The SizePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.DefaultValue Property

SizePropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size DefaultValue { get; set; }
Public Property DefaultValue As Size
    Get
    Set

Property Value

Type: Size
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.Format Property

SizePropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.IsNaNAllowed Property

SizePropertyEditorIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.IsNegativeInfinityAllowed Property

SizePropertyEditorIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.IsPositiveInfinityAllowed Property

SizePropertyEditorIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.LargeChange Property

SizePropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size LargeChange { get; set; }
Public Property LargeChange As Size
    Get
    Set

Property Value

Type: Size
The large change value. The default value is 5.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.Maximum Property

SizePropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Maximum { get; set; }
Public Property Maximum As Size
    Get
    Set

Property Value

Type: Size
The highest possible value.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.Minimum Property

SizePropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size Minimum { get; set; }
Public Property Minimum As Size
    Get
    Set

Property Value

Type: Size
The lowest possible value.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.PredefinedValueTemplateKey Property

SizePropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.RoundingDecimalPlace Property

SizePropertyEditorRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.SmallChange Property

SizePropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Size SmallChange { get; set; }
Public Property SmallChange As Size
    Get
    Set

Property Value

Type: Size
The small change value. The default value is 1.
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Methods

The SizePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Events

The SizePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Class

Represents a PropertyEditor for editing a Thickness value with a ThicknessEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsThicknessPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableThicknessPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ThicknessPropertyEditor : PartEditBoxPropertyEditorBase
Public Class ThicknessPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The ThicknessPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ThicknessPropertyEditor | Initializes an instance of the ThicknessPropertyEditor class.
Protected method | ThicknessPropertyEditor(Type) | Initializes an instance of the ThicknessPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Constructor

Overload List
 | Name | Description
Public method | ThicknessPropertyEditor | Initializes an instance of the ThicknessPropertyEditor class.
Protected method | ThicknessPropertyEditor(Type) | Initializes an instance of the ThicknessPropertyEditor class.
Top
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Constructor

Initializes an instance of the ThicknessPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ThicknessPropertyEditor()
Public Sub New
See Also

Reference

ThicknessPropertyEditor Class
ThicknessPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Constructor (Type)

Initializes an instance of the ThicknessPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ThicknessPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

ThicknessPropertyEditor Class
ThicknessPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Properties

The ThicknessPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.DefaultValue Property

ThicknessPropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness DefaultValue { get; set; }
Public Property DefaultValue As Thickness
    Get
    Set

Property Value

Type: Thickness
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.Format Property

ThicknessPropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.IsNaNAllowed Property

ThicknessPropertyEditorIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.IsNegativeInfinityAllowed Property

ThicknessPropertyEditorIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.IsPositiveInfinityAllowed Property

ThicknessPropertyEditorIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.LargeChange Property

ThicknessPropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness LargeChange { get; set; }
Public Property LargeChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The large change value. The default value is 5.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.Maximum Property

ThicknessPropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Maximum { get; set; }
Public Property Maximum As Thickness
    Get
    Set

Property Value

Type: Thickness
The highest possible value.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.Minimum Property

ThicknessPropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Minimum { get; set; }
Public Property Minimum As Thickness
    Get
    Set

Property Value

Type: Thickness
The lowest possible value.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.PredefinedValueTemplateKey Property

ThicknessPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.RoundingDecimalPlace Property

ThicknessPropertyEditorRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.SmallChange Property

ThicknessPropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness SmallChange { get; set; }
Public Property SmallChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The small change value. The default value is 1.
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Methods

The ThicknessPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Events

The ThicknessPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Class

Represents a PropertyEditor for editing a DateTime value with a TimeEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableTimePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TimePropertyEditor : DateTimePropertyEditor
Public Class TimePropertyEditor
    Inherits DateTimePropertyEditor

The TimePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | TimePropertyEditor | Initializes an instance of the TimePropertyEditor class.
Protected method | TimePropertyEditor(Type) | Initializes an instance of the TimePropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides DateTimePropertyEditorPredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Constructor

Overload List
 | Name | Description
Public method | TimePropertyEditor | Initializes an instance of the TimePropertyEditor class.
Protected method | TimePropertyEditor(Type) | Initializes an instance of the TimePropertyEditor class.
Top
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Constructor

Initializes an instance of the TimePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimePropertyEditor()
Public Sub New
See Also

Reference

TimePropertyEditor Class
TimePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Constructor (Type)

Initializes an instance of the TimePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TimePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

TimePropertyEditor Class
TimePropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Properties

The TimePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimePropertyEditor.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimePropertyEditor.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides DateTimePropertyEditorPredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor.PredefinedValueTemplateKey Property

TimePropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Methods

The TimePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Events

The TimePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Class

Represents a PropertyEditor for editing a TimeSpan value with a TimeSpanEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsTimeSpanPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableTimeSpanPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TimeSpanPropertyEditor : PartEditBoxPropertyEditorBase
Public Class TimeSpanPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The TimeSpanPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSpanPropertyEditor | Initializes an instance of the TimeSpanPropertyEditor class.
Protected method | TimeSpanPropertyEditor(Type) | Initializes an instance of the TimeSpanPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Constructor

Overload List
 | Name | Description
Public method | TimeSpanPropertyEditor | Initializes an instance of the TimeSpanPropertyEditor class.
Protected method | TimeSpanPropertyEditor(Type) | Initializes an instance of the TimeSpanPropertyEditor class.
Top
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Constructor

Initializes an instance of the TimeSpanPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpanPropertyEditor()
Public Sub New
See Also

Reference

TimeSpanPropertyEditor Class
TimeSpanPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Constructor (Type)

Initializes an instance of the TimeSpanPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TimeSpanPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

TimeSpanPropertyEditor Class
TimeSpanPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Properties

The TimeSpanPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.DefaultValue Property

TimeSpanPropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan DefaultValue { get; set; }
Public Property DefaultValue As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.Format Property

TimeSpanPropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "c".
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.LargeChange Property

TimeSpanPropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan LargeChange { get; set; }
Public Property LargeChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The large change value. The default value is 7.3:5:5:050.
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.Maximum Property

TimeSpanPropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan Maximum { get; set; }
Public Property Maximum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The highest possible value.
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.Minimum Property

TimeSpanPropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan Minimum { get; set; }
Public Property Minimum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The lowest possible value.
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.PredefinedValueTemplateKey Property

TimeSpanPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.SmallChange Property

TimeSpanPropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TimeSpan SmallChange { get; set; }
Public Property SmallChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The small change value. The default value is 1.1:1:1:1.
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Methods

The TimeSpanPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Events

The TimeSpanPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor Class

Represents a PropertyEditor for editing a Vector value with a VectorEditBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsVectorPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsNullableVectorPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class VectorPropertyEditor : PartEditBoxPropertyEditorBase
Public Class VectorPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The VectorPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | VectorPropertyEditor | Initializes an instance of the VectorPropertyEditor class.
Protected method | VectorPropertyEditor(Type) | Initializes an instance of the VectorPropertyEditor class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor Constructor

Overload List
 | Name | Description
Public method | VectorPropertyEditor | Initializes an instance of the VectorPropertyEditor class.
Protected method | VectorPropertyEditor(Type) | Initializes an instance of the VectorPropertyEditor class.
Top
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor Constructor

Initializes an instance of the VectorPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VectorPropertyEditor()
Public Sub New
See Also

Reference

VectorPropertyEditor Class
VectorPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor Constructor (Type)

Initializes an instance of the VectorPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected VectorPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

VectorPropertyEditor Class
VectorPropertyEditor Overload
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor Properties

The VectorPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | DefaultValue | Gets or sets the value to set when incrementing/decrementing from a null value.
Public property | Format | Gets or sets the number format string.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a component value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a component value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a component value.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area. (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.DefaultValue Property

VectorPropertyEditorDefaultValue Property

Gets or sets the value to set when incrementing/decrementing from a null value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector DefaultValue { get; set; }
Public Property DefaultValue As Vector
    Get
    Set

Property Value

Type: Vector
The value to set when incrementing/decrementing from a null value. The default value is 0.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.Format Property

VectorPropertyEditorFormat Property

Gets or sets the number format string.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.IsNaNAllowed Property

VectorPropertyEditorIsNaNAllowed Property

Gets or sets whether NaN is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.IsNegativeInfinityAllowed Property

VectorPropertyEditorIsNegativeInfinityAllowed Property

Gets or sets whether NegativeInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.IsPositiveInfinityAllowed Property

VectorPropertyEditorIsPositiveInfinityAllowed Property

Gets or sets whether PositiveInfinity is accepted as a component value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a component value; otherwise, false. The default value is false.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.LargeChange Property

VectorPropertyEditorLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector LargeChange { get; set; }
Public Property LargeChange As Vector
    Get
    Set

Property Value

Type: Vector
The large change value. The default value is 5.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.Maximum Property

VectorPropertyEditorMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector Maximum { get; set; }
Public Property Maximum As Vector
    Get
    Set

Property Value

Type: Vector
The highest possible value.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.Minimum Property

VectorPropertyEditorMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector Minimum { get; set; }
Public Property Minimum As Vector
    Get
    Set

Property Value

Type: Vector
The lowest possible value.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.PredefinedValueTemplateKey Property

VectorPropertyEditorPredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.RoundingDecimalPlace Property

VectorPropertyEditorRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding. The default value is 8.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor.SmallChange Property

VectorPropertyEditorSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Vector SmallChange { get; set; }
Public Property SmallChange As Vector
    Get
    Set

Property Value

Type: Vector
The small change value. The default value is 1.
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor Methods

The VectorPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


VectorPropertyEditor Events

The VectorPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

VectorPropertyEditor Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace

Contains property editor primitive classes that support integration of Editors with PropertyGrid.
Classes
 | Class | Description
Public class | PartEditBoxPropertyEditorBase | Represents the abstract base class for a PropertyEditor that uses a part edit box.
Public class | PropertyEditorBase | Represents the abstract base class for a PropertyEditor that uses Actipro Editors.


PartEditBoxPropertyEditorBase Class

Represents the abstract base class for a PropertyEditor that uses a part edit box.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
More...

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class PartEditBoxPropertyEditorBase : PropertyEditorBase
Public MustInherit Class PartEditBoxPropertyEditorBase
    Inherits PropertyEditorBase

The PartEditBoxPropertyEditorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PartEditBoxPropertyEditorBase | Initializes an instance of the PartEditBoxPropertyEditorBase class.
Top
Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.
Public property | TextAlignment | Gets or sets the text alignment of the text editing area.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsBrushPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsBytePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsColorPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsCornerRadiusPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsDoublePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsEnumPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsGuidPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt16PropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt32PropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt32RectPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsInt64PropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsPointPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsRectPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsSinglePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsSizePropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsThicknessPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsTimeSpanPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsVectorPropertyEditor


PartEditBoxPropertyEditorBase Constructor

Initializes an instance of the PartEditBoxPropertyEditorBase class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected PartEditBoxPropertyEditorBase(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase Properties

The PartEditBoxPropertyEditorBase type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.
Public property | TextAlignment | Gets or sets the text alignment of the text editing area.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.CommitTriggers Property

PartEditBoxPropertyEditorBaseCommitTriggers Property

Gets or sets the triggers that will force this control to commit any changes.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PartEditBoxCommitTriggers CommitTriggers { get; set; }
Public Property CommitTriggers As PartEditBoxCommitTriggers
    Get
    Set

Property Value

Type: PartEditBoxCommitTriggers
A PartEditBoxCommitTriggers indicating the triggers that will force this control to commit any changes. The default value is PartEditBoxCommitTriggers.Default.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.HasPopup Property

PartEditBoxPropertyEditorBaseHasPopup Property

Gets or sets a value indicating whether the control has a popup available.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasPopup { get; set; }
Public Property HasPopup As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control has a popup available; otherwise false. The default value is true.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.IsArrowKeyPartNavigationEnabled Property

PartEditBoxPropertyEditorBaseIsArrowKeyPartNavigationEnabled Property

Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsArrowKeyPartNavigationEnabled { get; set; }
Public Property IsArrowKeyPartNavigationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the left/right arrow keys can be used to move between and select editable parts; otherwise false. The default value is true.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.IsEditable Property

PartEditBoxPropertyEditorBaseIsEditable Property

Gets or sets a value indicating whether the edit box's text area is editable.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box's text area is editable; otherwise false. The default value is true.
Remarks
When false, the edit box behaves more like a ComboBox.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.IsNullAllowed Property

PartEditBoxPropertyEditorBaseIsNullAllowed Property

Gets or sets a value indicating whether null values are allowed to be entered by the user.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNullAllowed { get; set; }
Public Property IsNullAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if null values are allowed to be entered by the user; otherwise false. The default value is false.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.IsUndoEnabled Property

PartEditBoxPropertyEditorBaseIsUndoEnabled Property

Gets or sets whether undo/redo support is enabled for the text-editing portion of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsUndoEnabled { get; set; }
Public Property IsUndoEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if undo/redo support is enabled for the text-editing portion of the control. The default value is true.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.PlaceholderText Property

PartEditBoxPropertyEditorBasePlaceholderText Property

Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string PlaceholderText { get; set; }
Public Property PlaceholderText As String
    Get
    Set

Property Value

Type: String
The text that is displayed in the control until the value is changed by a user action or some other operation.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.SpinnerVisibility Property

PartEditBoxPropertyEditorBaseSpinnerVisibility Property

Gets or sets a value indicating if and when the control has a spinner available.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpinnerVisibility SpinnerVisibility { get; set; }
Public Property SpinnerVisibility As SpinnerVisibility
    Get
    Set

Property Value

Type: SpinnerVisibility
A value indicating if and when the control has a spinner available. The default value is SpinnerVisibility.Collapsed.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.SpinWrapping Property

PartEditBoxPropertyEditorBaseSpinWrapping Property

Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpinWrapping SpinWrapping { get; set; }
Public Property SpinWrapping As SpinWrapping
    Get
    Set

Property Value

Type: SpinWrapping
The wrapping behavior used when spinning past a minimum or maximum value in the active part. The default value is SpinWrapping.NoWrap.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.TextAlignment Property

PartEditBoxPropertyEditorBaseTextAlignment Property

Gets or sets the text alignment of the text editing area.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextAlignment TextAlignment { get; set; }
Public Property TextAlignment As TextAlignment
    Get
    Set

Property Value

Type: TextAlignment
The text alignment of the text editing area. The default value is TextAlignment.Left.
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase Methods

The PartEditBoxPropertyEditorBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value. (Inherited from PropertyEditorBase.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase Events

The PartEditBoxPropertyEditorBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Class

Represents the abstract base class for a PropertyEditor that uses Actipro Editors.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditorsMaskedStringPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class PropertyEditorBase : PropertyEditor
Public MustInherit Class PropertyEditorBase
    Inherits PropertyEditor

The PropertyEditorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PropertyEditorBase | Initializes an instance of the PropertyEditorBase class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Overrides PropertyEditorValueTemplate.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value.
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Constructor

Initializes an instance of the PropertyEditorBase class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected PropertyEditorBase(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType
The type of the property.
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Properties

The PropertyEditorBase type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Protected property | PredefinedValueTemplateKey | Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Overrides PropertyEditorValueTemplate.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase.PredefinedValueTemplateKey Property

PropertyEditorBasePredefinedValueTemplateKey Property

Gets the resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Object PredefinedValueTemplateKey { get; }
Protected MustOverride ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a pre-defined DataTemplate within internal resources to use for editing the property value.
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase.ValueTemplate Property

PropertyEditorBaseValueTemplate Property

Gets or sets the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override DataTemplate ValueTemplate { get; set; }
Public Overrides Property ValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for editing the property value.
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Methods

The PropertyEditorBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | Creates the DataTemplate to use for editing the property value.
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase.CreateValueTemplate Method

PropertyEditorBaseCreateValueTemplate Method

Creates the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: ActiproSoftware.Editors.Interop.Grids.Wpf (in ActiproSoftware.Editors.Interop.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual DataTemplate CreateValueTemplate()
Protected Overridable Function CreateValueTemplate As DataTemplate

Return Value

Type: DataTemplate
The DataTemplate to use for editing the property value.
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Events

The PropertyEditorBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


ActiproSoftware.Windows.Controls.Editors.Primitives Namespace

Contains primitive classes used for Editors controls.
Classes
 | Class | Description
Public class | ColorComponentToPercentConverter | Represents the converter that converts a color component to a percentage.
Public class | DateToDecadeStringConverter | Represents the converter that converts DateTime to decade string values.
Public class | DefaultValueConverter | Represents the converter that converts null values to a default value, but otherwise allows the non-null value to pass directly through.
Public class | DropDownButton | Represents a drop-down styled toggle button.
Public class | EmbeddedListBox | Represents a ListBox that can be embedded into other controls.
Public class | EmbeddedListBoxItem | Represents an EmbeddedListBox item.
Public class | EmbeddedRadialSlider | Represents a RadialSlider that is intended to be embedded within a popup.
Public class | EnumValueNameSortComparer | Sorts enumeration values by name, in ascending order.
Public class | GradientStopSliderPanel | Represents a Panel for arranging thumbs in a GradientStopSlider.
Public class | GradientStopThumb | Represents a thumb for dragging a gradient stop in a GradientStopSlider.
Public class | HueRing | Represents a ring that renders color hues.
Public class | IncrementalChangeRequestT | Represents a request for an incremental (spin) change to a value.
Public class | InputScopeConverter | Represents the converter that converts InputScopeNameValue to InputScope values.
Public class | MonthCalendarButton | Represents a button used within a MonthCalendar.
Public class | MonthCalendarRepeatButton | Represents a repeat button used within a MonthCalendar.
Public class | PartEditBoxBaseT | Represents the abstract base class for a part-based edit box.
Public class | PartEditBoxInlinePanel | Represents a Panel for arranging inlines in a part edit box.
Public class | PickerBase | Provides an abstract base class that can be used for pickers.
Public class | RadialSliderPickerBase | Provides an abstract base class that can be used for pickers that use radial sliders.
Public class | RatingPanel | Represents a Panel for arranging items in a Rating.
Public class | SaturationBrightnessSquare | Represents a square that renders the saturation and brightness variants of a color.
Public class | Spinner | Represents a spinner control, which offers up/down or left/right buttons.
Public class | SpinnerButtonPanel | Provides a panel for arranging buttons within a Spinner.
Interfaces
 | Interface | Description
Public interface | IPart | Provides the base requirements for a part within a part-based edit box.
Public interface | ISpinnablePartT | Provides the base requirements for a spinnable part.
Enumerations
 | Enumeration | Description
Public enumeration | IncrementalChangeRequestKind | Specifies the kind of incremental change request.


ColorComponentToPercentConverter Class

Represents the converter that converts a color component to a percentage.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Editors.PrimitivesColorComponentToPercentConverter

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ColorComponentToPercentConverter : IValueConverter
Public Class ColorComponentToPercentConverter
    Implements IValueConverter

The ColorComponentToPercentConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ColorComponentToPercentConverter | Initializes a new instance of the ColorComponentToPercentConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


ColorComponentToPercentConverter Constructor

Initializes a new instance of the ColorComponentToPercentConverter class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorComponentToPercentConverter()
Public Sub New
See Also

Reference

ColorComponentToPercentConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


ColorComponentToPercentConverter Methods

The ColorComponentToPercentConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

ColorComponentToPercentConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


ColorComponentToPercentConverter.Convert Method

ColorComponentToPercentConverterConvert Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ColorComponentToPercentConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


ColorComponentToPercentConverter.ConvertBack Method

ColorComponentToPercentConverterConvertBack Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ColorComponentToPercentConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DateToDecadeStringConverter Class

Represents the converter that converts DateTime to decade string values.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Editors.PrimitivesDateToDecadeStringConverter

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DateToDecadeStringConverter : IValueConverter
Public Class DateToDecadeStringConverter
    Implements IValueConverter

The DateToDecadeStringConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DateToDecadeStringConverter | Initializes a new instance of the DateToDecadeStringConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DateToDecadeStringConverter Constructor

Initializes a new instance of the DateToDecadeStringConverter class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DateToDecadeStringConverter()
Public Sub New
See Also

Reference

DateToDecadeStringConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DateToDecadeStringConverter Methods

The DateToDecadeStringConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

DateToDecadeStringConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DateToDecadeStringConverter.Convert Method

DateToDecadeStringConverterConvert Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DateToDecadeStringConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DateToDecadeStringConverter.ConvertBack Method

DateToDecadeStringConverterConvertBack Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DateToDecadeStringConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DefaultValueConverter Class

Represents the converter that converts null values to a default value, but otherwise allows the non-null value to pass directly through.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Editors.PrimitivesDefaultValueConverter

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DefaultValueConverter : IValueConverter
Public Class DefaultValueConverter
    Implements IValueConverter

The DefaultValueConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultValueConverter | Initializes a new instance of the DefaultValueConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DefaultValueConverter Constructor

Initializes a new instance of the DefaultValueConverter class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DefaultValueConverter()
Public Sub New
See Also

Reference

DefaultValueConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DefaultValueConverter Methods

The DefaultValueConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

DefaultValueConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DefaultValueConverter.Convert Method

DefaultValueConverterConvert Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DefaultValueConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DefaultValueConverter.ConvertBack Method

DefaultValueConverterConvertBack Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DefaultValueConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DropDownButton Class

Represents a drop-down styled toggle button.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.Controls.PrimitivesButtonBase
System.Windows.Controls.PrimitivesToggleButton
ActiproSoftware.Windows.Controls.Editors.PrimitivesDropDownButton

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DropDownButton : ToggleButton
Public Class DropDownButton
    Inherits ToggleButton

The DropDownButton type exposes the following members.

Constructors
 | Name | Description
Public method | DropDownButton | Initializes an instance of the DropDownButton class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPointerOverParent | Gets or sets whether the button should be forced to reflect a pointer over state, such as when the mouse is over the templated parent.
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnChecked | Called when a ToggleButton raises a Checked event. (Inherited from ToggleButton.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ToggleButtonAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ToggleButton.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnToggle | Called by the OnClick method to implement toggle behavior. (Inherited from ToggleButton.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Top
Fields
Name | Description
IsPointerOverParentProperty | Identifies the IsPointerOverParent dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DropDownButton Constructor

Initializes an instance of the DropDownButton class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DropDownButton()
Public Sub New
See Also

Reference

DropDownButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DropDownButton Properties

The DropDownButton type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPointerOverParent | Gets or sets whether the button should be forced to reflect a pointer over state, such as when the mouse is over the templated parent.
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DropDownButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DropDownButton.IsPointerOverParent Property

DropDownButtonIsPointerOverParent Property

Gets or sets whether the button should be forced to reflect a pointer over state, such as when the mouse is over the templated parent.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPointerOverParent { get; set; }
Public Property IsPointerOverParent As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the button should be forced to reflect a pointer over state; otherwise, false.
See Also

Reference

DropDownButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DropDownButton Methods

The DropDownButton type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnChecked | Called when a ToggleButton raises a Checked event. (Inherited from ToggleButton.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ToggleButtonAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ToggleButton.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnToggle | Called by the OnClick method to implement toggle behavior. (Inherited from ToggleButton.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DropDownButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DropDownButton Events

The DropDownButton type exposes the following members.

Events
 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Top
See Also

Reference

DropDownButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DropDownButton Fields

The DropDownButton type exposes the following members.

Fields
Name | Description
IsPointerOverParentProperty | Identifies the IsPointerOverParent dependency property. This field is read-only.
Top
See Also

Reference

DropDownButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


DropDownButton.IsPointerOverParentProperty Field

DropDownButtonIsPointerOverParentProperty Field

Identifies the IsPointerOverParent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPointerOverParentProperty
Public Shared ReadOnly IsPointerOverParentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPointerOverParent dependency property.
See Also

Reference

DropDownButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBox Class

Represents a ListBox that can be embedded into other controls.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsListBox
ActiproSoftware.Windows.Controls.Editors.PrimitivesEmbeddedListBox

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EmbeddedListBox : ListBox
Public Class EmbeddedListBox
    Inherits ListBox

The EmbeddedListBox type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedListBox | Initializes an instance of the EmbeddedListBox class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBoxGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ListBoxPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBox Constructor

Initializes an instance of the EmbeddedListBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EmbeddedListBox()
Public Sub New
See Also

Reference

EmbeddedListBox Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBox Properties

The EmbeddedListBox type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EmbeddedListBox Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBox Methods

The EmbeddedListBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBoxGetContainerForItemOverride.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ListBoxPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

EmbeddedListBox Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBox.GetContainerForItemOverride Method

EmbeddedListBoxGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

EmbeddedListBox Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBox.PrepareContainerForItemOverride Method

EmbeddedListBoxPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

EmbeddedListBox Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBox Events

The EmbeddedListBox type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
See Also

Reference

EmbeddedListBox Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBoxItem Class

Represents an EmbeddedListBox item.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsListBoxItem
ActiproSoftware.Windows.Controls.Editors.PrimitivesEmbeddedListBoxItem

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EmbeddedListBoxItem : ListBoxItem
Public Class EmbeddedListBoxItem
    Inherits ListBoxItem

The EmbeddedListBoxItem type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedListBoxItem | Initializes an instance of the EmbeddedListBoxItem class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown event. (Overrides ListBoxItemOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseRightButtonDown | Called when the user presses the right mouse button over a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelected | Called when the ListBoxItem is selected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnUnselected | Called when the ListBoxItem is unselected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the visual parent of a list box item changes. (Inherited from ListBoxItem.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Selected | Occurs when a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public event | Unselected | Occurs when a ListBoxItem is unselected. (Inherited from ListBoxItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBoxItem Constructor

Initializes an instance of the EmbeddedListBoxItem class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EmbeddedListBoxItem()
Public Sub New
See Also

Reference

EmbeddedListBoxItem Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBoxItem Properties

The EmbeddedListBoxItem type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EmbeddedListBoxItem Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBoxItem Methods

The EmbeddedListBoxItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown event. (Overrides ListBoxItemOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseRightButtonDown | Called when the user presses the right mouse button over a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelected | Called when the ListBoxItem is selected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnUnselected | Called when the ListBoxItem is unselected in a ListBox. (Inherited from ListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the visual parent of a list box item changes. (Inherited from ListBoxItem.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

EmbeddedListBoxItem Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBoxItem.OnMouseLeftButtonDown Method

EmbeddedListBoxItemOnMouseLeftButtonDown Method

Provides class handling for the MouseLeftButtonDown event.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The event data.
See Also

Reference

EmbeddedListBoxItem Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedListBoxItem Events

The EmbeddedListBoxItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Selected | Occurs when a ListBoxItem is selected. (Inherited from ListBoxItem.)
Public event | Unselected | Occurs when a ListBoxItem is unselected. (Inherited from ListBoxItem.)
Top
See Also

Reference

EmbeddedListBoxItem Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Class

Represents a RadialSlider that is intended to be embedded within a popup.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesRangeBase
ActiproSoftware.Windows.ControlsRadialSlider
ActiproSoftware.Windows.Controls.Editors.PrimitivesEmbeddedRadialSlider

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EmbeddedRadialSlider : RadialSlider
Public Class EmbeddedRadialSlider
    Inherits RadialSlider

The EmbeddedRadialSlider type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedRadialSlider | Initializes an instance of the EmbeddedRadialSlider class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IntermediateValue | Gets or sets the value of the slider while the user is interacting with it, before the value is snapped. (Inherited from RadialSlider.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Radius | Gets or sets the slider's radius. (Inherited from RadialSlider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ThumbArrowAngle | Gets or sets the thumb's arrow angle. (Inherited from RadialSlider.)
Public property | ThumbBackground | Gets or sets the background Brush to render when the thumb is in a normal state. (Inherited from RadialSlider.)
Public property | ThumbPressedBackground | Gets or sets the background Brush to render when the thumb is pressed. (Inherited from RadialSlider.)
Public property | ThumbStyle | Gets or sets the Style to use for the thumb. (Inherited from RadialSlider.)
Public property | TotalEndAngle | Gets or sets the total end angle.
Public property | TotalStartAngle | Gets or sets the total start angle.
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides RadialSliderOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from RadialSlider.)
Protected method | OnMaximumChanged | Occurs when the Maximum property has changed. (Overrides RangeBaseOnMaximumChanged(Double, Double).)
Protected method | OnMinimumChanged | Occurs when the Minimum property has changed. (Overrides RangeBaseOnMinimumChanged(Double, Double).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed. (Overrides RadialSliderOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SetValueCore | Sets the Value property and applies snapping. (Inherited from RadialSlider.)
Public method | StartDrag | Starts a thumb drag. (Inherited from RadialSlider.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
Fields
Name | Description
TotalEndAngleProperty | Identifies the TotalEndAngle dependency property. This field is read-only.
TotalStartAngleProperty | Identifies the TotalStartAngle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Constructor

Initializes an instance of the EmbeddedRadialSlider class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EmbeddedRadialSlider()
Public Sub New
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Properties

The EmbeddedRadialSlider type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IntermediateValue | Gets or sets the value of the slider while the user is interacting with it, before the value is snapped. (Inherited from RadialSlider.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Radius | Gets or sets the slider's radius. (Inherited from RadialSlider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ThumbArrowAngle | Gets or sets the thumb's arrow angle. (Inherited from RadialSlider.)
Public property | ThumbBackground | Gets or sets the background Brush to render when the thumb is in a normal state. (Inherited from RadialSlider.)
Public property | ThumbPressedBackground | Gets or sets the background Brush to render when the thumb is pressed. (Inherited from RadialSlider.)
Public property | ThumbStyle | Gets or sets the Style to use for the thumb. (Inherited from RadialSlider.)
Public property | TotalEndAngle | Gets or sets the total end angle.
Public property | TotalStartAngle | Gets or sets the total start angle.
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.TotalEndAngle Property

EmbeddedRadialSliderTotalEndAngle Property

Gets or sets the total end angle.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TotalEndAngle { get; set; }
Public Property TotalEndAngle As Double
    Get
    Set

Property Value

Type: Double
The total end angle.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.TotalStartAngle Property

EmbeddedRadialSliderTotalStartAngle Property

Gets or sets the total start angle.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TotalStartAngle { get; set; }
Public Property TotalStartAngle As Double
    Get
    Set

Property Value

Type: Double
The total start angle.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Methods

The EmbeddedRadialSlider type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides RadialSliderOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from RadialSlider.)
Protected method | OnMaximumChanged | Occurs when the Maximum property has changed. (Overrides RangeBaseOnMaximumChanged(Double, Double).)
Protected method | OnMinimumChanged | Occurs when the Minimum property has changed. (Overrides RangeBaseOnMinimumChanged(Double, Double).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed. (Overrides RadialSliderOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | SetValueCore | Sets the Value property and applies snapping. (Inherited from RadialSlider.)
Public method | StartDrag | Starts a thumb drag. (Inherited from RadialSlider.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.OnApplyTemplate Method

EmbeddedRadialSliderOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.OnMaximumChanged Method

EmbeddedRadialSliderOnMaximumChanged Method

Occurs when the Maximum property has changed.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMaximumChanged(
    double oldMaximum,
    double newMaximum
)
Protected Overrides Sub OnMaximumChanged (
    oldMaximum As Double,
    newMaximum As Double
)

Parameters

oldMaximum
Type: SystemDouble
The old value.
newMaximum
Type: SystemDouble
The new value.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.OnMinimumChanged Method

EmbeddedRadialSliderOnMinimumChanged Method

Occurs when the Minimum property has changed.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMinimumChanged(
    double oldMinimum,
    double newMinimum
)
Protected Overrides Sub OnMinimumChanged (
    oldMinimum As Double,
    newMinimum As Double
)

Parameters

oldMinimum
Type: SystemDouble
The old value.
newMinimum
Type: SystemDouble
The new value.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.OnValueChanged Method

EmbeddedRadialSliderOnValueChanged Method

Occurs when the Value property has changed.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    double oldValue,
    double newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The old value.
newValue
Type: SystemDouble
The new value.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Events

The EmbeddedRadialSlider type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Fields

The EmbeddedRadialSlider type exposes the following members.

Fields
Name | Description
TotalEndAngleProperty | Identifies the TotalEndAngle dependency property. This field is read-only.
TotalStartAngleProperty | Identifies the TotalStartAngle dependency property. This field is read-only.
Top
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.TotalEndAngleProperty Field

EmbeddedRadialSliderTotalEndAngleProperty Field

Identifies the TotalEndAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TotalEndAngleProperty
Public Shared ReadOnly TotalEndAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TotalEndAngle dependency property.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.TotalStartAngleProperty Field

EmbeddedRadialSliderTotalStartAngleProperty Field

Identifies the TotalStartAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TotalStartAngleProperty
Public Shared ReadOnly TotalStartAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TotalStartAngle dependency property.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer Class

Sorts enumeration values by name, in ascending order.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Editors.PrimitivesEnumValueNameSortComparer

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class EnumValueNameSortComparer : IComparer<Enum>
Public Class EnumValueNameSortComparer
    Implements IComparer(Of Enum)

The EnumValueNameSortComparer type exposes the following members.

Constructors
 | Name | Description
Public method | EnumValueNameSortComparer | Initializes a new instance of the EnumValueNameSortComparer class
Top
Properties
Name | Description
Instance | Gets a global instance of this comparer.
Top
Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer Constructor

Initializes a new instance of the EnumValueNameSortComparer class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public EnumValueNameSortComparer()
Public Sub New
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer Properties

The EnumValueNameSortComparer type exposes the following members.

Properties
Name | Description
Instance | Gets a global instance of this comparer.
Top
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer.Instance Property

EnumValueNameSortComparerInstance Property

Gets a global instance of this comparer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static EnumValueNameSortComparer Instance { get; }
Public Shared ReadOnly Property Instance As EnumValueNameSortComparer
    Get

Property Value

Type: EnumValueNameSortComparer
A global instance of this comparer.
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer Methods

The EnumValueNameSortComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Top
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer.Compare Method

EnumValueNameSortComparerCompare Method

Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Compare(
    Enum x,
    Enum y
)
Public Function Compare (
    x As Enum,
    y As Enum
) As Integer

Parameters

x
Type: SystemEnum
The first object to compare.
y
Type: SystemEnum
The second object to compare.

Return Value

Type: Int32
Value Condition Less than zero - x is less than y. Zero - x equals y. Greater than zero - x is greater than y.

Implements

IComparerTCompare(T, T)
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopSliderPanel Class

Represents a Panel for arranging thumbs in a GradientStopSlider.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Editors.PrimitivesGradientStopSliderPanel

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GradientStopSliderPanel : Panel
Public Class GradientStopSliderPanel
    Inherits Panel

The GradientStopSliderPanel type exposes the following members.

Constructors
 | Name | Description
Public method | GradientStopSliderPanel | Initializes a new instance of the GradientStopSliderPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges and performs layout on children given a size to layout within. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns its desired size based on the size of its children. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopSliderPanel Constructor

Initializes a new instance of the GradientStopSliderPanel class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientStopSliderPanel()
Public Sub New
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopSliderPanel Properties

The GradientStopSliderPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopSliderPanel Methods

The GradientStopSliderPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges and performs layout on children given a size to layout within. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Measures all children given an available size and returns its desired size based on the size of its children. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopSliderPanel.ArrangeOverride Method

GradientStopSliderPanelArrangeOverride Method

Arranges and performs layout on children given a size to layout within.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The size Panel is suggested to occupy for layout.

Return Value

Type: Size
The size Panel occupies after layout.
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopSliderPanel.MeasureOverride Method

GradientStopSliderPanelMeasureOverride Method

Measures all children given an available size and returns its desired size based on the size of its children.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The size the Panel is suggested to fit inside.

Return Value

Type: Size
The desired size of the Panel.
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb Class

Represents a thumb for dragging a gradient stop in a GradientStopSlider.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesGradientStopThumb

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GradientStopThumb : Control
Public Class GradientStopThumb
    Inherits Control

The GradientStopThumb type exposes the following members.

Constructors
 | Name | Description
Public method | GradientStopThumb | Initializes an instance of the GradientStopThumb class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDragging | Gets whether the thumb is being dragged by a pointer.
Public property | IsDraggingToRemove | Gets whether the thumb is being dragged by a pointer into a location where it will be removed.
Public property | IsSelected | Gets or sets whether the thumb is currently selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | RemoveIfAllowed | Removes the gradient stop, if the slider allows it.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
IsDraggingToRemoveProperty | Identifies the IsDraggingToRemove dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb Constructor

Initializes an instance of the GradientStopThumb class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientStopThumb()
Public Sub New
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb Properties

The GradientStopThumb type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDragging | Gets whether the thumb is being dragged by a pointer.
Public property | IsDraggingToRemove | Gets whether the thumb is being dragged by a pointer into a location where it will be removed.
Public property | IsSelected | Gets or sets whether the thumb is currently selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb.IsDragging Property

GradientStopThumbIsDragging Property

Gets whether the thumb is being dragged by a pointer.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get

Property Value

Type: Boolean
true if the thumb is being dragged by a pointer; otherwise, false.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb.IsDraggingToRemove Property

GradientStopThumbIsDraggingToRemove Property

Gets whether the thumb is being dragged by a pointer into a location where it will be removed.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDraggingToRemove { get; }
Public ReadOnly Property IsDraggingToRemove As Boolean
    Get

Property Value

Type: Boolean
true if the thumb is being dragged by a pointer into a location where it will be removed; otherwise, false.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb.IsSelected Property

GradientStopThumbIsSelected Property

Gets or sets whether the thumb is currently selected.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the thumb is currently selected; otherwise, false.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb Methods

The GradientStopThumb type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | RemoveIfAllowed | Removes the gradient stop, if the slider allows it.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb.OnKeyDown Method

GradientStopThumbOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb.RemoveIfAllowed Method

GradientStopThumbRemoveIfAllowed Method

Removes the gradient stop, if the slider allows it.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveIfAllowed()
Public Sub RemoveIfAllowed
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb Events

The GradientStopThumb type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb Fields

The GradientStopThumb type exposes the following members.

Fields
Name | Description
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
IsDraggingToRemoveProperty | Identifies the IsDraggingToRemove dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb.IsDraggingProperty Field

GradientStopThumbIsDraggingProperty Field

Identifies the IsDragging dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDraggingProperty
Public Shared ReadOnly IsDraggingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDragging dependency property.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb.IsDraggingToRemoveProperty Field

GradientStopThumbIsDraggingToRemoveProperty Field

Identifies the IsDraggingToRemove dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDraggingToRemoveProperty
Public Shared ReadOnly IsDraggingToRemoveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDraggingToRemove dependency property.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


GradientStopThumb.IsSelectedProperty Field

GradientStopThumbIsSelectedProperty Field

Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing Class

Represents a ring that renders color hues.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesHueRing

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class HueRing : Control
Public Class HueRing
    Inherits Control

The HueRing type exposes the following members.

Constructors
 | Name | Description
Public method | HueRing | Initializes an instance of the HueRing class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Length | Gets or sets the length of the ring.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
LengthProperty | Identifies the Length dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing Constructor

Initializes an instance of the HueRing class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public HueRing()
Public Sub New
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing Properties

The HueRing type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Length | Gets or sets the length of the ring.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing.Length Property

HueRingLength Property

Gets or sets the length of the ring.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Length { get; set; }
Public Property Length As Double
    Get
    Set

Property Value

Type: Double
The length of the ring. The default value is 40.0.
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing Methods

The HueRing type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing.ArrangeOverride Method

HueRingArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing.OnApplyTemplate Method

HueRingOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing.OnCreateAutomationPeer Method

HueRingOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing Events

The HueRing type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing Fields

The HueRing type exposes the following members.

Fields
Name | Description
LengthProperty | Identifies the Length dependency property. This field is read-only.
Top
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


HueRing.LengthProperty Field

HueRingLengthProperty Field

Identifies the Length dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LengthProperty
Public Shared ReadOnly LengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Length dependency property.
See Also

Reference

HueRing Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T) Class

IncrementalChangeRequestT Class

Represents a request for an incremental (spin) change to a value.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestT

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class IncrementalChangeRequest<T>

Public Class IncrementalChangeRequest(Of T)

Type Parameters

T
The part value type.

The IncrementalChangeRequestT type exposes the following members.

Constructors
 | Name | Description
Public method | IncrementalChangeRequestT | Initializes an instance of the IncrementalChangeRequest class.
Top
Properties
 | Name | Description
Public property | Kind | Gets or sets the kind of request.
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value.
Public property | Value | Gets or sets the base value upon which to apply the incremental change.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T) Constructor

IncrementalChangeRequestT Constructor

Initializes an instance of the IncrementalChangeRequest class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IncrementalChangeRequest()
Public Sub New
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T) Properties

IncrementalChangeRequestT Properties

The IncrementalChangeRequestT generic type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets or sets the kind of request.
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | RoundingDecimalPlace | Gets or sets the rounding decimal place.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value.
Public property | Value | Gets or sets the base value upon which to apply the incremental change.
Top
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).Kind Property

IncrementalChangeRequestTKind Property

Gets or sets the kind of request.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IncrementalChangeRequestKind Kind { get; set; }
Public Property Kind As IncrementalChangeRequestKind
    Get
    Set

Property Value

Type: IncrementalChangeRequestKind
An IncrementalChangeRequestKind that specifies the kind of request.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).LargeChange Property

IncrementalChangeRequestTLargeChange Property

Gets or sets the large change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T LargeChange { get; set; }
Public Property LargeChange As T
    Get
    Set

Property Value

Type: T
The large change value.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).Maximum Property

IncrementalChangeRequestTMaximum Property

Gets or sets the highest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Maximum { get; set; }
Public Property Maximum As T
    Get
    Set

Property Value

Type: T
The highest possible value.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).Minimum Property

IncrementalChangeRequestTMinimum Property

Gets or sets the lowest possible value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Minimum { get; set; }
Public Property Minimum As T
    Get
    Set

Property Value

Type: T
The lowest possible value.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).RoundingDecimalPlace Property

IncrementalChangeRequestTRoundingDecimalPlace Property

Gets or sets the rounding decimal place.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<int> RoundingDecimalPlace { get; set; }
Public Property RoundingDecimalPlace As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The rounding decimal place, which is a value between 0 and 15. Pass a null value to disable rounding.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).SmallChange Property

IncrementalChangeRequestTSmallChange Property

Gets or sets the small change value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T SmallChange { get; set; }
Public Property SmallChange As T
    Get
    Set

Property Value

Type: T
The small change value.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).SpinWrapping Property

IncrementalChangeRequestTSpinWrapping Property

Gets or sets the wrapping behavior used when spinning past a minimum or maximum value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpinWrapping SpinWrapping { get; set; }
Public Property SpinWrapping As SpinWrapping
    Get
    Set

Property Value

Type: SpinWrapping
The wrapping behavior used when spinning past a minimum or maximum value. The default value is SpinBehavior.NoWrap.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).Value Property

IncrementalChangeRequestTValue Property

Gets or sets the base value upon which to apply the incremental change.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Value { get; set; }
Public Property Value As T
    Get
    Set

Property Value

Type: T
The base value upon which to apply the incremental change.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind Enumeration

Specifies the kind of incremental change request.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum IncrementalChangeRequestKind
Public Enumeration IncrementalChangeRequestKind
Members
Member name | Value | Description
None | 0 | No change.
Increase | 1 | Single increment.
MultipleIncrease | 2 | Multiple increments.
Decrease | 3 | Single decrement.
MultipleDecrease | 4 | Multiple decrements.
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


InputScopeConverter Class

Represents the converter that converts InputScopeNameValue to InputScope values.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Editors.PrimitivesInputScopeConverter

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class InputScopeConverter : IValueConverter
Public Class InputScopeConverter
    Implements IValueConverter

The InputScopeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | InputScopeConverter | Initializes a new instance of the InputScopeConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


InputScopeConverter Constructor

Initializes a new instance of the InputScopeConverter class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InputScopeConverter()
Public Sub New
See Also

Reference

InputScopeConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


InputScopeConverter Methods

The InputScopeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Top
See Also

Reference

InputScopeConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


InputScopeConverter.Convert Method

InputScopeConverterConvert Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

InputScopeConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


InputScopeConverter.ConvertBack Method

InputScopeConverterConvertBack Method

Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

InputScopeConverter Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart Interface

Provides the base requirements for a part within a part-based edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPart
Public Interface IPart

The IPart type exposes the following members.

Properties
 | Name | Description
Public property | IsEditable | Gets whether the part is editable.
Public property | IsLiteral | Gets whether the part is a literal.
Public property | IsOptional | Gets whether this part is optional.
Public property | Length | Gets the character length of the part within the text.
Public property | StartOffset | Gets the start offset of the part within the text.
Public property | StringValue | Gets or sets the current string value of the part, if known.
Top
Methods
 | Name | Description
Public method | TryParseText | Tries to parse the text starting offset and returns the offset through which parsing was completed.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart Properties

The IPart type exposes the following members.

Properties
 | Name | Description
Public property | IsEditable | Gets whether the part is editable.
Public property | IsLiteral | Gets whether the part is a literal.
Public property | IsOptional | Gets whether this part is optional.
Public property | Length | Gets the character length of the part within the text.
Public property | StartOffset | Gets the start offset of the part within the text.
Public property | StringValue | Gets or sets the current string value of the part, if known.
Top
See Also

Reference

IPart Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart.IsEditable Property

IPartIsEditable Property

Gets whether the part is editable.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsEditable { get; }
ReadOnly Property IsEditable As Boolean
    Get

Property Value

Type: Boolean
true if the part is editable; otherwise, false.
See Also

Reference

IPart Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart.IsLiteral Property

IPartIsLiteral Property

Gets whether the part is a literal.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsLiteral { get; }
ReadOnly Property IsLiteral As Boolean
    Get

Property Value

Type: Boolean
true if the part is a literal; otherwise, false.
See Also

Reference

IPart Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart.IsOptional Property

IPartIsOptional Property

Gets whether this part is optional.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsOptional { get; }
ReadOnly Property IsOptional As Boolean
    Get

Property Value

Type: Boolean
true if this part is optional; otherwise, false.
See Also

Reference

IPart Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart.Length Property

IPartLength Property

Gets the character length of the part within the text.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Length { get; set; }
Property Length As Integer
    Get
    Set

Property Value

Type: Int32
The character length of the part within the text.
See Also

Reference

IPart Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart.StartOffset Property

IPartStartOffset Property

Gets the start offset of the part within the text.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int StartOffset { get; set; }
Property StartOffset As Integer
    Get
    Set

Property Value

Type: Int32
The start offset of the part within the text.
See Also

Reference

IPart Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart.StringValue Property

IPartStringValue Property

Gets or sets the current string value of the part, if known.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string StringValue { get; set; }
Property StringValue As String
    Get
    Set

Property Value

Type: String
The current string value of the part, if known.
See Also

Reference

IPart Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart Methods

The IPart type exposes the following members.

Methods
 | Name | Description
Public method | TryParseText | Tries to parse the text starting offset and returns the offset through which parsing was completed.
Top
See Also

Reference

IPart Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


IPart.TryParseText Method

IPartTryParseText Method

Tries to parse the text starting offset and returns the offset through which parsing was completed.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool TryParseText(
    IList<IPart> parts,
    string text,
    int startOffset,
    CultureInfo culture,
    out int offset
)
Function TryParseText (
    parts As IList(Of IPart),
    text As String,
    startOffset As Integer,
    culture As CultureInfo,
    <OutAttribute> ByRef offset As Integer
) As Boolean

Parameters

parts
Type: System.Collections.GenericIList IPart
The part collection in which this part is a member.
text
Type: SystemString
The text to examine.
startOffset
Type: SystemInt32
The start offset.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use.
offset
Type: SystemInt32
Returns the offset through which parsing was completed.

Return Value

Type: Boolean
true if parsing was successful; otherwise, false.
See Also

Reference

IPart Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


ISpinnablePart(T) Interface

ISpinnablePartT Interface

Provides the base requirements for a spinnable part.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISpinnablePart<T> : IPart

Public Interface ISpinnablePart(Of T)
    Inherits IPart

Type Parameters

T
The composite value type.

The ISpinnablePartT type exposes the following members.

Properties
 | Name | Description
Public property | IsEditable | Gets whether the part is editable. (Inherited from IPart.)
Public property | IsLiteral | Gets whether the part is a literal. (Inherited from IPart.)
Public property | IsOptional | Gets whether this part is optional. (Inherited from IPart.)
Public property | Length | Gets the character length of the part within the text. (Inherited from IPart.)
Public property | StartOffset | Gets the start offset of the part within the text. (Inherited from IPart.)
Public property | StringValue | Gets or sets the current string value of the part, if known. (Inherited from IPart.)
Top
Methods
 | Name | Description
Public method | ApplyIncrementalChange | Applies an incremental change to the part's value.
Public method | TryParseText | Tries to parse the text starting offset and returns the offset through which parsing was completed. (Inherited from IPart.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


ISpinnablePart(T) Properties

ISpinnablePartT Properties

The ISpinnablePartT generic type exposes the following members.

Properties
 | Name | Description
Public property | IsEditable | Gets whether the part is editable. (Inherited from IPart.)
Public property | IsLiteral | Gets whether the part is a literal. (Inherited from IPart.)
Public property | IsOptional | Gets whether this part is optional. (Inherited from IPart.)
Public property | Length | Gets the character length of the part within the text. (Inherited from IPart.)
Public property | StartOffset | Gets the start offset of the part within the text. (Inherited from IPart.)
Public property | StringValue | Gets or sets the current string value of the part, if known. (Inherited from IPart.)
Top
See Also

Reference

ISpinnablePartT Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


ISpinnablePart(T) Methods

ISpinnablePartT Methods

The ISpinnablePartT generic type exposes the following members.

Methods
 | Name | Description
Public method | ApplyIncrementalChange | Applies an incremental change to the part's value.
Public method | TryParseText | Tries to parse the text starting offset and returns the offset through which parsing was completed. (Inherited from IPart.)
Top
See Also

Reference

ISpinnablePartT Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


ISpinnablePart(T).ApplyIncrementalChange Method

ISpinnablePartTApplyIncrementalChange Method

Applies an incremental change to the part's value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ApplyIncrementalChange(
    IncrementalChangeRequest<T> request
)
Function ApplyIncrementalChange (
    request As IncrementalChangeRequest(Of T)
) As Boolean

Parameters

request
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequest T
The incremental change request.

Return Value

Type: Boolean
true if an incremental change was made; otherwise, false.
See Also

Reference

ISpinnablePartT Interface
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarButton Class

Represents a button used within a MonthCalendar.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.Controls.PrimitivesButtonBase
System.Windows.ControlsButton
ActiproSoftware.Windows.Controls.Editors.PrimitivesMonthCalendarButton

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MonthCalendarButton : Button
Public Class MonthCalendarButton
    Inherits Button

The MonthCalendarButton type exposes the following members.

Constructors
 | Name | Description
Public method | MonthCalendarButton | Initializes a new instance of the MonthCalendarButton class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Overrides ButtonBaseOnLostMouseCapture(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarButton Constructor

Initializes a new instance of the MonthCalendarButton class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MonthCalendarButton()
Public Sub New
See Also

Reference

MonthCalendarButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarButton Properties

The MonthCalendarButton type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MonthCalendarButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarButton Methods

The MonthCalendarButton type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Overrides ButtonBaseOnLostMouseCapture(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MonthCalendarButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarButton.OnLostMouseCapture Method

MonthCalendarButtonOnLostMouseCapture Method

Occurs when mouse capture is lost.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostMouseCapture(
    MouseEventArgs e
)
Protected Overrides Sub OnLostMouseCapture (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs that contains the event data.
See Also

Reference

MonthCalendarButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarButton Events

The MonthCalendarButton type exposes the following members.

Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MonthCalendarButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarRepeatButton Class

Represents a repeat button used within a MonthCalendar.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.Controls.PrimitivesButtonBase
System.Windows.Controls.PrimitivesRepeatButton
ActiproSoftware.Windows.Controls.Editors.PrimitivesMonthCalendarRepeatButton

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MonthCalendarRepeatButton : RepeatButton
Public Class MonthCalendarRepeatButton
    Inherits RepeatButton

The MonthCalendarRepeatButton type exposes the following members.

Constructors
 | Name | Description
Public method | MonthCalendarRepeatButton | Initializes a new instance of the MonthCalendarRepeatButton class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Delay | Gets or sets the amount of time, in milliseconds, the RepeatButton waits while it is pressed before it starts repeating. The value must be non-negative. (Inherited from RepeatButton.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Interval | Gets or sets the amount of time, in milliseconds, between repeats once repeating starts. The value must be non-negative. (Inherited from RepeatButton.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnClick | Raises an automation event and calls the base method to raise the Click event. (Inherited from RepeatButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate RepeatButtonAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from RepeatButton.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from RepeatButton.)
Protected method | OnKeyUp | Responds to the KeyUp event. (Inherited from RepeatButton.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Overrides RepeatButtonOnLostMouseCapture(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Reports when the mouse enters an element. (Inherited from RepeatButton.)
Protected method | OnMouseLeave | Reports when the mouse leaves an element. (Inherited from RepeatButton.)
Protected method | OnMouseLeftButtonDown | Responds to the MouseLeftButtonDown event. (Inherited from RepeatButton.)
Protected method | OnMouseLeftButtonUp | Responds to the MouseLeftButtonUp event. (Inherited from RepeatButton.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarRepeatButton Constructor

Initializes a new instance of the MonthCalendarRepeatButton class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MonthCalendarRepeatButton()
Public Sub New
See Also

Reference

MonthCalendarRepeatButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarRepeatButton Properties

The MonthCalendarRepeatButton type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Delay | Gets or sets the amount of time, in milliseconds, the RepeatButton waits while it is pressed before it starts repeating. The value must be non-negative. (Inherited from RepeatButton.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Interval | Gets or sets the amount of time, in milliseconds, between repeats once repeating starts. The value must be non-negative. (Inherited from RepeatButton.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MonthCalendarRepeatButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarRepeatButton Methods

The MonthCalendarRepeatButton type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnClick | Raises an automation event and calls the base method to raise the Click event. (Inherited from RepeatButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate RepeatButtonAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from RepeatButton.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from RepeatButton.)
Protected method | OnKeyUp | Responds to the KeyUp event. (Inherited from RepeatButton.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Overrides RepeatButtonOnLostMouseCapture(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Reports when the mouse enters an element. (Inherited from RepeatButton.)
Protected method | OnMouseLeave | Reports when the mouse leaves an element. (Inherited from RepeatButton.)
Protected method | OnMouseLeftButtonDown | Responds to the MouseLeftButtonDown event. (Inherited from RepeatButton.)
Protected method | OnMouseLeftButtonUp | Responds to the MouseLeftButtonUp event. (Inherited from RepeatButton.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MonthCalendarRepeatButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarRepeatButton.OnLostMouseCapture Method

MonthCalendarRepeatButtonOnLostMouseCapture Method

Occurs when mouse capture is lost.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostMouseCapture(
    MouseEventArgs e
)
Protected Overrides Sub OnLostMouseCapture (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs that contains the event data.
See Also

Reference

MonthCalendarRepeatButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


MonthCalendarRepeatButton Events

The MonthCalendarRepeatButton type exposes the following members.

Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MonthCalendarRepeatButton Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Class

PartEditBoxBaseT Class

Represents the abstract base class for a part-based edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBaseT
More...

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class PartEditBoxBase<T> : Control

Public MustInherit Class PartEditBoxBase(Of T)
    Inherits Control

Type Parameters

T
The type of value being edited.

The PartEditBoxBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | PartEditBoxBaseT | Initializes an instance of the DateTimeEditBox class.
Top
Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes.
Protected property | CurrentSelectionLength | Gets the current text selection length.
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset.
Protected property | CurrentText | Gets or sets the current text value in the TextBox.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available.
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control.
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text.
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible.
Public property | IsPopupOpen | Gets or sets whether the popup is open.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only.
Public property | IsSpinnerVisible | Gets whether the spinner is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.
Public property | PopupBackground | Gets or sets the Brush to use for the popup background.
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border.
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup.
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount.
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area.
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance.
Public property | Value | Gets or sets the committed value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range.
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated.
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated.
Protected method | ConvertToString | Converts the specified value to a string representation.
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box.
Protected method | InvalidateParts | Invalidates the parts.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes.
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes.
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Overrides UIElementOnLostMouseCapture(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnPopupOpened | Occurs when the popup is opened.
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Overrides UIElementOnPreviewMouseUp(MouseButtonEventArgs).)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Overrides UIElementOnPreviewTextInput(TextCompositionEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text.
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value.
Public method | SelectAll | Selects all text in the edit box.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ActivePartIndexProperty | Identifies the ActivePartIndex dependency property. This field is read-only.
CommitTriggersProperty | Identifies the CommitTriggers dependency property. This field is read-only.
HasPopupProperty | Identifies the HasPopup dependency property. This field is read-only.
InlinesProperty | Identifies the Inlines dependency property. This field is read-only.
InputScopeNameValueProperty | Identifies the InputScopeNameValue dependency property. This field is read-only.
IntermediateValueProperty | Identifies the IntermediateValue dependency property. This field is read-only.
IsArrowKeyPartNavigationEnabledProperty | Identifies the IsArrowKeyPartNavigationEnabled dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
IsNonDefaultUsageContextProperty | Identifies the IsNonDefaultUsageContext dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsPopupButtonVisibleProperty | Identifies the IsPopupButtonVisible dependency property. This field is read-only.
IsPopupOpenProperty | Identifies the IsPopupOpen dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSpinnerVisibleProperty | Identifies the IsSpinnerVisible dependency property. This field is read-only.
IsUndoEnabledProperty | Identifies the IsUndoEnabled dependency property. This field is read-only.
PlaceholderTextProperty | Identifies the PlaceholderText dependency property. This field is read-only.
PopupBackgroundProperty | Identifies the PopupBackground dependency property. This field is read-only.
PopupBorderBrushProperty | Identifies the PopupBorderBrush dependency property. This field is read-only.
PopupPickerStyleProperty | Identifies the PopupPickerStyle dependency property. This field is read-only.
SpinnerVisibilityProperty | Identifies the SpinnerVisibility dependency property. This field is read-only.
SpinWrappingProperty | Identifies the SpinWrapping dependency property. This field is read-only.
TextAlignmentProperty | Identifies the TextAlignment dependency property. This field is read-only.
UsageContextProperty | Identifies the UsageContext dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxBaseT
ActiproSoftware.Windows.Controls.EditorsBrushEditBox
ActiproSoftware.Windows.Controls.EditorsByteEditBox
ActiproSoftware.Windows.Controls.EditorsColorEditBox
ActiproSoftware.Windows.Controls.EditorsCornerRadiusEditBox
ActiproSoftware.Windows.Controls.EditorsDateTimeEditBox
ActiproSoftware.Windows.Controls.EditorsDoubleEditBox
ActiproSoftware.Windows.Controls.EditorsEnumEditBox
ActiproSoftware.Windows.Controls.EditorsGuidEditBox
ActiproSoftware.Windows.Controls.EditorsInt16EditBox
ActiproSoftware.Windows.Controls.EditorsInt32EditBox
ActiproSoftware.Windows.Controls.EditorsInt32RectEditBox
ActiproSoftware.Windows.Controls.EditorsInt64EditBox
ActiproSoftware.Windows.Controls.EditorsPointEditBox
ActiproSoftware.Windows.Controls.EditorsRectEditBox
ActiproSoftware.Windows.Controls.EditorsSingleEditBox
ActiproSoftware.Windows.Controls.EditorsSizeEditBox
ActiproSoftware.Windows.Controls.EditorsThicknessEditBox
ActiproSoftware.Windows.Controls.EditorsTimeSpanEditBox
ActiproSoftware.Windows.Controls.EditorsVectorEditBox


PartEditBoxBase(T) Constructor

PartEditBoxBaseT Constructor

Initializes an instance of the DateTimeEditBox class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected PartEditBoxBase()
Protected Sub New
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Properties

PartEditBoxBaseT Properties

The PartEditBoxBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes.
Protected property | CurrentSelectionLength | Gets the current text selection length.
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset.
Protected property | CurrentText | Gets or sets the current text value in the TextBox.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available.
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Inlines | Gets or sets the collection of inline UI element placed within the control.
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text.
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable.
Public property | IsNonDefaultUsageContext | Gets whether a non-default UsageContext is currently in effect.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible.
Public property | IsPopupOpen | Gets or sets whether the popup is open.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only.
Public property | IsSpinnerVisible | Gets whether the spinner is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets whether undo/redo support is enabled for the text-editing portion of the control.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parts | Gets the collection of parts.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.
Public property | PopupBackground | Gets or sets the Brush to use for the popup background.
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border.
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup.
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount.
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount.
Public property | SpinnerVisibility | Gets or sets a value indicating if and when the control has a spinner available.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment of the text editing area.
Public property | UsageContext | Gets or sets the usage context of the control, which may alter its appearance.
Public property | Value | Gets or sets the committed value of the control.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ActivePartIndex Property

PartEditBoxBaseTActivePartIndex Property

Gets the index of the part that the caret is currently in.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int ActivePartIndex { get; }
Public ReadOnly Property ActivePartIndex As Integer
    Get

Property Value

Type: Int32
The index of the part that the caret is currently in.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CommitTriggers Property

PartEditBoxBaseTCommitTriggers Property

Gets or sets the triggers that will force this control to commit any changes.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PartEditBoxCommitTriggers CommitTriggers { get; set; }
Public Property CommitTriggers As PartEditBoxCommitTriggers
    Get
    Set

Property Value

Type: PartEditBoxCommitTriggers
A PartEditBoxCommitTriggers indicating the triggers that will force this control to commit any changes. The default value is PartEditBoxCommitTriggers.Default.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CurrentSelectionLength Property

PartEditBoxBaseTCurrentSelectionLength Property

Gets the current text selection length.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected int CurrentSelectionLength { get; }
Protected ReadOnly Property CurrentSelectionLength As Integer
    Get

Property Value

Type: Int32
The current text selection length.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CurrentSelectionStartOffset Property

PartEditBoxBaseTCurrentSelectionStartOffset Property

Gets the current text selection start offset.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected int CurrentSelectionStartOffset { get; }
Protected ReadOnly Property CurrentSelectionStartOffset As Integer
    Get

Property Value

Type: Int32
The current text selection start offset.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CurrentText Property

PartEditBoxBaseTCurrentText Property

Gets or sets the current text value in the TextBox.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected string CurrentText { get; set; }
Protected Property CurrentText As String
    Get
    Set

Property Value

Type: String
The current text value in the TextBox.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HasPopup Property

PartEditBoxBaseTHasPopup Property

Gets or sets a value indicating whether the control has a popup available.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasPopup { get; set; }
Public Property HasPopup As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control has a popup available; otherwise false. The default value is true.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HasPopupButtonWhenReadOnly Property

PartEditBoxBaseTHasPopupButtonWhenReadOnly Property

Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool HasPopupButtonWhenReadOnly { get; }
Protected Overridable ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Inlines Property

PartEditBoxBaseTInlines Property

Gets or sets the collection of inline UI element placed within the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PartEditBoxInlineCollection Inlines { get; set; }
Public Property Inlines As PartEditBoxInlineCollection
    Get
    Set

Property Value

Type: PartEditBoxInlineCollection
The collection of inline UI element placed within the control.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).InputScopeNameValue Property

PartEditBoxBaseTInputScopeNameValue Property

Gets or sets the InputScopeNameValue to use for the editable text.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InputScopeNameValue InputScopeNameValue { get; set; }
Public Property InputScopeNameValue As InputScopeNameValue
    Get
    Set

Property Value

Type: InputScopeNameValue
The InputScopeNameValue to use for the editable text.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IntermediateValue Property

PartEditBoxBaseTIntermediateValue Property

Gets the current value of the control, that stays in relative sync with the editable text representation.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T IntermediateValue { get; }
Public ReadOnly Property IntermediateValue As T
    Get

Property Value

Type: T
The current value of the control.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsArrowKeyPartNavigationEnabled Property

PartEditBoxBaseTIsArrowKeyPartNavigationEnabled Property

Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsArrowKeyPartNavigationEnabled { get; set; }
Public Property IsArrowKeyPartNavigationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the left/right arrow keys can be used to move between and select editable parts; otherwise false. The default value is true.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsEditable Property

PartEditBoxBaseTIsEditable Property

Gets or sets a value indicating whether the edit box's text area is editable.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box's text area is editable; otherwise false. The default value is true.
Remarks
When false, the edit box behaves more like a ComboBox.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsNonDefaultUsageContext Property

PartEditBoxBaseTIsNonDefaultUsageContext Property

Gets whether a non-default UsageContext is currently in effect.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNonDefaultUsageContext { get; }
Public ReadOnly Property IsNonDefaultUsageContext As Boolean
    Get

Property Value

Type: Boolean
true if a non-default UsageContext is currently in effect; otherwise, false. The default value is false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsNullAllowed Property

PartEditBoxBaseTIsNullAllowed Property

Gets or sets a value indicating whether null values are allowed to be entered by the user.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsNullAllowed { get; set; }
Public Property IsNullAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if null values are allowed to be entered by the user; otherwise false. The default value is false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsPopupButtonVisible Property

PartEditBoxBaseTIsPopupButtonVisible Property

Gets whether the toggle popup button is visible.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPopupButtonVisible { get; }
Public ReadOnly Property IsPopupButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the toggle popup button is visible; otherwise false. The default value is false.
Remarks
The HasPopup and HasPopupButtonWhenReadOnly properties, and other state-related info determines whether the toggle popup button is visible.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsPopupOpen Property

PartEditBoxBaseTIsPopupOpen Property

Gets or sets whether the popup is open.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPopupOpen { get; set; }
Public Property IsPopupOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the popup is open; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsReadOnly Property

PartEditBoxBaseTIsReadOnly Property

Gets or sets a value indicating whether the edit box is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box is read-only; otherwise false. The default value is false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsSpinnerVisible Property

PartEditBoxBaseTIsSpinnerVisible Property

Gets whether the spinner is visible.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSpinnerVisible { get; }
Public ReadOnly Property IsSpinnerVisible As Boolean
    Get

Property Value

Type: Boolean
true if the spinner is visible; otherwise false. The default value is false.
Remarks
The SpinnerVisibility property and other state-related info determines whether the spinner is visible.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsUndoEnabled Property

PartEditBoxBaseTIsUndoEnabled Property

Gets or sets whether undo/redo support is enabled for the text-editing portion of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsUndoEnabled { get; set; }
Public Property IsUndoEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if undo/redo support is enabled for the text-editing portion of the control. The default value is true.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Parts Property

PartEditBoxBaseTParts Property

Gets the collection of parts.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList<IPart> Parts { get; }
Public ReadOnly Property Parts As IList(Of IPart)
    Get

Property Value

Type: IList IPart
The collection of parts.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PlaceholderText Property

PartEditBoxBaseTPlaceholderText Property

Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string PlaceholderText { get; set; }
Public Property PlaceholderText As String
    Get
    Set

Property Value

Type: String
The text that is displayed in the control until the value is changed by a user action or some other operation.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupBackground Property

PartEditBoxBaseTPopupBackground Property

Gets or sets the Brush to use for the popup background.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush PopupBackground { get; set; }
Public Property PopupBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for the popup background.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupBorderBrush Property

PartEditBoxBaseTPopupBorderBrush Property

Gets or sets the Brush to use for the popup border.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush PopupBorderBrush { get; set; }
Public Property PopupBorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for the popup border.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupPickerStyle Property

PartEditBoxBaseTPopupPickerStyle Property

Gets or sets the optional custom Style that can be applied to the picker within the popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style PopupPickerStyle { get; set; }
Public Property PopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The optional custom Style that can be applied to the picker within the popup.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ResetValueCommand Property

PartEditBoxBaseTResetValueCommand Property

Gets the ICommand that resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ResetValueCommand { get; }
Public ReadOnly Property ResetValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that resets the value to a default value.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SmallDecrementValueCommand Property

PartEditBoxBaseTSmallDecrementValueCommand Property

Gets the ICommand that can be used to decrement the value by a small amount.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SmallDecrementValueCommand { get; }
Public ReadOnly Property SmallDecrementValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to decrement the value by a small amount.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SmallIncrementValueCommand Property

PartEditBoxBaseTSmallIncrementValueCommand Property

Gets the ICommand that can be used to increment the value by a small amount.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SmallIncrementValueCommand { get; }
Public ReadOnly Property SmallIncrementValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to increment the value by a small amount.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SpinnerVisibility Property

PartEditBoxBaseTSpinnerVisibility Property

Gets or sets a value indicating if and when the control has a spinner available.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpinnerVisibility SpinnerVisibility { get; set; }
Public Property SpinnerVisibility As SpinnerVisibility
    Get
    Set

Property Value

Type: SpinnerVisibility
A value indicating if and when the control has a spinner available. The default value is SpinnerVisibility.Collapsed.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SpinWrapping Property

PartEditBoxBaseTSpinWrapping Property

Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpinWrapping SpinWrapping { get; set; }
Public Property SpinWrapping As SpinWrapping
    Get
    Set

Property Value

Type: SpinWrapping
The wrapping behavior used when spinning past a minimum or maximum value in the active part. The default value is SpinWrapping.NoWrap.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).TextAlignment Property

PartEditBoxBaseTTextAlignment Property

Gets or sets the text alignment of the text editing area.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextAlignment TextAlignment { get; set; }
Public Property TextAlignment As TextAlignment
    Get
    Set

Property Value

Type: TextAlignment
The text alignment of the text editing area. The default value is TextAlignment.Left.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).UsageContext Property

PartEditBoxBaseTUsageContext Property

Gets or sets the usage context of the control, which may alter its appearance.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ControlUsageContext UsageContext { get; set; }
Public Property UsageContext As ControlUsageContext
    Get
    Set

Property Value

Type: ControlUsageContext
The usage context of the control, which may alter its appearance. The default value is ControlUsageContext.Default.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Value Property

PartEditBoxBaseTValue Property

Gets or sets the committed value of the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public T Value { get; set; }
Public Property Value As T
    Get
    Set

Property Value

Type: T
The committed value of the control.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Methods

PartEditBoxBaseT Methods

The PartEditBoxBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CoerceValidValue | Coerces the value to be within range.
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated.
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated.
Protected method | ConvertToString | Converts the specified value to a string representation.
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GenerateParts | Generates the parts for the edit box.
Protected method | InvalidateParts | Invalidates the parts.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsValidValue | Returns whether the specified value is valid.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes.
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes.
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnLostMouseCapture | Occurs when mouse capture is lost. (Overrides UIElementOnLostMouseCapture(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Occurs when a mouse button is pressed. (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnPopupOpened | Occurs when the popup is opened.
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseUp | Occurs when a mouse button is released. (Overrides UIElementOnPreviewMouseUp(MouseButtonEventArgs).)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Overrides UIElementOnPreviewTextInput(TextCompositionEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | ProcessTextInput | Processes typed text.
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetValue | Resets the value to a default value.
Public method | SelectAll | Selects all text in the edit box.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CoerceValidValue Method

PartEditBoxBaseTCoerceValidValue Method

Coerces the value to be within range.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual T CoerceValidValue(
    T value
)
Protected Overridable Function CoerceValidValue (
    value As T
) As T

Parameters

value
Type: T
The value to coerce.

Return Value

Type: T
The coerced value.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Commit Method

PartEditBoxBaseTCommit Method

Overload List
 | Name | Description
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated.
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated.
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Commit Method

PartEditBoxBaseTCommit Method

Commits any pending text updates and returns whether the Value has been updated.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Commit()
Public Function Commit As Boolean

Return Value

Type: Boolean
true if the value has been updated; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
Commit Overload
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Commit Method (Boolean)

PartEditBoxBaseTCommit Method (Boolean)

Commits any pending text updates and returns whether the Value has been updated.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Commit(
    bool allowTextUpdate
)
Public Function Commit (
    allowTextUpdate As Boolean
) As Boolean

Parameters

allowTextUpdate
Type: SystemBoolean
Whether to allow the text to be updated if a valid value is parsed.

Return Value

Type: Boolean
true if the value has been updated; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
Commit Overload
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ConvertToString Method

PartEditBoxBaseTConvertToString Method

Converts the specified value to a string representation.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract string ConvertToString(
    T valueToConvert
)
Protected MustOverride Function ConvertToString (
    valueToConvert As T
) As String

Parameters

valueToConvert
Type: T
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CreateIncrementalChangeRequest Method

PartEditBoxBaseTCreateIncrementalChangeRequest Method

Creates an incremental change (spin) request.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract IncrementalChangeRequest<T> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected MustOverride Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of T)

Parameters

kind
Type: ActiproSoftware.Windows.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest T
The incremental change (spin) request that was created.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).GenerateParts Method

PartEditBoxBaseTGenerateParts Method

Generates the parts for the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract IList<IPart> GenerateParts()
Protected MustOverride Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).InvalidateParts Method

PartEditBoxBaseTInvalidateParts Method

Invalidates the parts.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void InvalidateParts()
Protected Sub InvalidateParts
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsValidValue Method

PartEditBoxBaseTIsValidValue Method

Returns whether the specified value is valid.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool IsValidValue(
    T value
)
Protected MustOverride Function IsValidValue (
    value As T
) As Boolean

Parameters

value
Type: T
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnApplyTemplate Method

PartEditBoxBaseTOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnCreateAutomationPeer Method

PartEditBoxBaseTOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnGotFocus Method

PartEditBoxBaseTOnGotFocus Method

Occurs when the control gains focus.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnIntermediateValueChanged Method

PartEditBoxBaseTOnIntermediateValueChanged Method

Invoked when the value of the IntermediateValue property changes.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnIntermediateValueChanged(
    T oldValue,
    T newValue
)
Protected Overridable Sub OnIntermediateValueChanged (
    oldValue As T,
    newValue As T
)

Parameters

oldValue
Type: T
The old value of the property.
newValue
Type: T
The new value of the property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnIsKeyboardFocusWithinChanged Method

PartEditBoxBaseTOnIsKeyboardFocusWithinChanged Method

Reports that the IsKeyboardFocusWithin property changed.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
A DependencyPropertyChangedEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnIsNullAllowedChanged Method

PartEditBoxBaseTOnIsNullAllowedChanged Method

Invoked when the value of the IsNullAllowed property changes.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnIsNullAllowedChanged(
    bool oldValue,
    bool newValue
)
Protected Overridable Sub OnIsNullAllowedChanged (
    oldValue As Boolean,
    newValue As Boolean
)

Parameters

oldValue
Type: SystemBoolean
The old value of the property.
newValue
Type: SystemBoolean
The new value of the property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnKeyDown Method

PartEditBoxBaseTOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnLostFocus Method

PartEditBoxBaseTOnLostFocus Method

Occurs when the control loses focus.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnLostMouseCapture Method

PartEditBoxBaseTOnLostMouseCapture Method

Occurs when mouse capture is lost.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostMouseCapture(
    MouseEventArgs e
)
Protected Overrides Sub OnLostMouseCapture (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnMouseLeftButtonDown Method

PartEditBoxBaseTOnMouseLeftButtonDown Method

Occurs when a mouse button is pressed.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnPopupOpened Method

PartEditBoxBaseTOnPopupOpened Method

Occurs when the popup is opened.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPopupOpened()
Protected Overridable Sub OnPopupOpened
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnPreviewMouseUp Method

PartEditBoxBaseTOnPreviewMouseUp Method

Occurs when a mouse button is released.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPreviewMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnPreviewMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnPreviewTextInput Method

PartEditBoxBaseTOnPreviewTextInput Method

Occurs before text input is sent to the control.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPreviewTextInput(
    TextCompositionEventArgs e
)
Protected Overrides Sub OnPreviewTextInput (
    e As TextCompositionEventArgs
)

Parameters

e
Type: System.Windows.InputTextCompositionEventArgs
The TextCompositionEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnValueChanged Method

PartEditBoxBaseTOnValueChanged Method

Invoked when the value of the Value property changes.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnValueChanged(
    T oldValue,
    T newValue
)
Protected Overridable Sub OnValueChanged (
    oldValue As T,
    newValue As T
)

Parameters

oldValue
Type: T
The old value of the property.
newValue
Type: T
The new value of the property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ProcessTextInput Method

PartEditBoxBaseTProcessTextInput Method

Processes typed text.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool ProcessTextInput(
    string text
)
Protected Overridable Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).RaiseValueChangedEvent Method

PartEditBoxBaseTRaiseValueChangedEvent Method

Raises the ValueChanged event.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void RaiseValueChangedEvent()
Protected MustOverride Sub RaiseValueChangedEvent
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ResetValue Method

PartEditBoxBaseTResetValue Method

Resets the value to a default value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void ResetValue()
Protected MustOverride Sub ResetValue
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SelectAll Method

PartEditBoxBaseTSelectAll Method

Selects all text in the edit box.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SelectAll()
Public Sub SelectAll
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).TryConvertFromString Method

PartEditBoxBaseTTryConvertFromString Method

Tries to convert the specified text to a value.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out T value
)
Protected MustOverride Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As T
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: T
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Events

PartEditBoxBaseT Events

The PartEditBoxBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Fields

PartEditBoxBaseT Fields

The PartEditBoxBaseT generic type exposes the following members.

Fields
Name | Description
ActivePartIndexProperty | Identifies the ActivePartIndex dependency property. This field is read-only.
CommitTriggersProperty | Identifies the CommitTriggers dependency property. This field is read-only.
HasPopupProperty | Identifies the HasPopup dependency property. This field is read-only.
InlinesProperty | Identifies the Inlines dependency property. This field is read-only.
InputScopeNameValueProperty | Identifies the InputScopeNameValue dependency property. This field is read-only.
IntermediateValueProperty | Identifies the IntermediateValue dependency property. This field is read-only.
IsArrowKeyPartNavigationEnabledProperty | Identifies the IsArrowKeyPartNavigationEnabled dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
IsNonDefaultUsageContextProperty | Identifies the IsNonDefaultUsageContext dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsPopupButtonVisibleProperty | Identifies the IsPopupButtonVisible dependency property. This field is read-only.
IsPopupOpenProperty | Identifies the IsPopupOpen dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSpinnerVisibleProperty | Identifies the IsSpinnerVisible dependency property. This field is read-only.
IsUndoEnabledProperty | Identifies the IsUndoEnabled dependency property. This field is read-only.
PlaceholderTextProperty | Identifies the PlaceholderText dependency property. This field is read-only.
PopupBackgroundProperty | Identifies the PopupBackground dependency property. This field is read-only.
PopupBorderBrushProperty | Identifies the PopupBorderBrush dependency property. This field is read-only.
PopupPickerStyleProperty | Identifies the PopupPickerStyle dependency property. This field is read-only.
SpinnerVisibilityProperty | Identifies the SpinnerVisibility dependency property. This field is read-only.
SpinWrappingProperty | Identifies the SpinWrapping dependency property. This field is read-only.
TextAlignmentProperty | Identifies the TextAlignment dependency property. This field is read-only.
UsageContextProperty | Identifies the UsageContext dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ActivePartIndexProperty Field

PartEditBoxBaseTActivePartIndexProperty Field

Identifies the ActivePartIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActivePartIndexProperty
Public Shared ReadOnly ActivePartIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActivePartIndex dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CommitTriggersProperty Field

PartEditBoxBaseTCommitTriggersProperty Field

Identifies the CommitTriggers dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CommitTriggersProperty
Public Shared ReadOnly CommitTriggersProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CommitTriggers dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HasPopupProperty Field

PartEditBoxBaseTHasPopupProperty Field

Identifies the HasPopup dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasPopupProperty
Public Shared ReadOnly HasPopupProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasPopup dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).InlinesProperty Field

PartEditBoxBaseTInlinesProperty Field

Identifies the Inlines dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InlinesProperty
Public Shared ReadOnly InlinesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Inlines dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).InputScopeNameValueProperty Field

PartEditBoxBaseTInputScopeNameValueProperty Field

Identifies the InputScopeNameValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InputScopeNameValueProperty
Public Shared ReadOnly InputScopeNameValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InputScopeNameValue dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IntermediateValueProperty Field

PartEditBoxBaseTIntermediateValueProperty Field

Identifies the IntermediateValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IntermediateValueProperty
Public Shared ReadOnly IntermediateValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IntermediateValue dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsArrowKeyPartNavigationEnabledProperty Field

PartEditBoxBaseTIsArrowKeyPartNavigationEnabledProperty Field

Identifies the IsArrowKeyPartNavigationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsArrowKeyPartNavigationEnabledProperty
Public Shared ReadOnly IsArrowKeyPartNavigationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsArrowKeyPartNavigationEnabled dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsEditableProperty Field

PartEditBoxBaseTIsEditableProperty Field

Identifies the IsEditable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEditableProperty
Public Shared ReadOnly IsEditableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEditable dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsNonDefaultUsageContextProperty Field

PartEditBoxBaseTIsNonDefaultUsageContextProperty Field

Identifies the IsNonDefaultUsageContext dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNonDefaultUsageContextProperty
Public Shared ReadOnly IsNonDefaultUsageContextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNonDefaultUsageContext dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsNullAllowedProperty Field

PartEditBoxBaseTIsNullAllowedProperty Field

Identifies the IsNullAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNullAllowedProperty
Public Shared ReadOnly IsNullAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNullAllowed dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsPopupButtonVisibleProperty Field

PartEditBoxBaseTIsPopupButtonVisibleProperty Field

Identifies the IsPopupButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPopupButtonVisibleProperty
Public Shared ReadOnly IsPopupButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPopupButtonVisible dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsPopupOpenProperty Field

PartEditBoxBaseTIsPopupOpenProperty Field

Identifies the IsPopupOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPopupOpenProperty
Public Shared ReadOnly IsPopupOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPopupOpen dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsReadOnlyProperty Field

PartEditBoxBaseTIsReadOnlyProperty Field

Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsSpinnerVisibleProperty Field

PartEditBoxBaseTIsSpinnerVisibleProperty Field

Identifies the IsSpinnerVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSpinnerVisibleProperty
Public Shared ReadOnly IsSpinnerVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSpinnerVisible dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsUndoEnabledProperty Field

PartEditBoxBaseTIsUndoEnabledProperty Field

Identifies the IsUndoEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsUndoEnabledProperty
Public Shared ReadOnly IsUndoEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsUndoEnabled dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PlaceholderTextProperty Field

PartEditBoxBaseTPlaceholderTextProperty Field

Identifies the PlaceholderText dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlaceholderTextProperty
Public Shared ReadOnly PlaceholderTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PlaceholderText dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupBackgroundProperty Field

PartEditBoxBaseTPopupBackgroundProperty Field

Identifies the PopupBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupBackgroundProperty
Public Shared ReadOnly PopupBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupBackground dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupBorderBrushProperty Field

PartEditBoxBaseTPopupBorderBrushProperty Field

Identifies the PopupBorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupBorderBrushProperty
Public Shared ReadOnly PopupBorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupBorderBrush dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupPickerStyleProperty Field

PartEditBoxBaseTPopupPickerStyleProperty Field

Identifies the PopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupPickerStyleProperty
Public Shared ReadOnly PopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupPickerStyle dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SpinnerVisibilityProperty Field

PartEditBoxBaseTSpinnerVisibilityProperty Field

Identifies the SpinnerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SpinnerVisibilityProperty
Public Shared ReadOnly SpinnerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SpinnerVisibility dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SpinWrappingProperty Field

PartEditBoxBaseTSpinWrappingProperty Field

Identifies the SpinWrapping dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SpinWrappingProperty
Public Shared ReadOnly SpinWrappingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SpinWrapping dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).TextAlignmentProperty Field

PartEditBoxBaseTTextAlignmentProperty Field

Identifies the TextAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextAlignmentProperty
Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextAlignment dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).UsageContextProperty Field

PartEditBoxBaseTUsageContextProperty Field

Identifies the UsageContext dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UsageContextProperty
Public Shared ReadOnly UsageContextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UsageContext dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ValueProperty Field

PartEditBoxBaseTValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxInlinePanel Class

Represents a Panel for arranging inlines in a part edit box.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
System.Windows.ControlsStackPanel
ActiproSoftware.Windows.Controls.Editors.PrimitivesPartEditBoxInlinePanel

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PartEditBoxInlinePanel : StackPanel
Public Class PartEditBoxInlinePanel
    Inherits StackPanel

The PartEditBoxInlinePanel type exposes the following members.

Constructors
 | Name | Description
Public method | PartEditBoxInlinePanel | Initializes an instance of the PartEditBoxInlinePanel class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | CanHorizontallyScroll | Gets or sets a value that indicates whether a StackPanel can scroll in the horizontal dimension. (Inherited from StackPanel.)
Public property | CanVerticallyScroll | Gets or sets a value that indicates whether content can scroll in the vertical dimension. (Inherited from StackPanel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtentHeight | Gets a value that contains the vertical size of the extent. (Inherited from StackPanel.)
Public property | ExtentWidth | Gets a value that contains the horizontal size of the extent. (Inherited from StackPanel.)
Protected property | HasLogicalOrientation | Gets a value that indicates if this StackPanel has vertical or horizontal orientation. (Inherited from StackPanel.)
Public property | HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled content. (Inherited from StackPanel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | Gets a value that represents the Orientation of the StackPanel. (Inherited from StackPanel.)
Public property | Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked. (Inherited from StackPanel.)
Public property | ScrollOwner | Gets or sets a value that identifies the container that controls scrolling behavior in this StackPanel. (Inherited from StackPanel.)
Public property | VerticalOffset | Gets a value that contains the vertical offset of the scrolled content. (Inherited from StackPanel.)
Public property | ViewportHeight | Gets a value that contains the vertical size of the content's viewport. (Inherited from StackPanel.)
Public property | ViewportWidth | Gets a value that contains the horizontal size of the content's viewport. (Inherited from StackPanel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a StackPanel element. (Inherited from StackPanel.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls content downward by one logical unit. (Inherited from StackPanel.)
Public method | LineLeft | Scrolls content by one logical unit to the left. (Inherited from StackPanel.)
Public method | LineRight | Scrolls content by one logical unit to the right. (Inherited from StackPanel.)
Public method | LineUp | Scrolls content by one logical unit upward. (Inherited from StackPanel.)
Public method | MakeVisible | Scrolls to the specified coordinates and makes that part of a Visual visible. (Inherited from StackPanel.)
Protected method | MeasureOverride | Measures the child elements of a StackPanel in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from StackPanel.)
Public method | MouseWheelDown | Scrolls content logically downward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelLeft | Scrolls content logically to the left in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelRight | Scrolls content logically to the right in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelUp | Scrolls content logically upward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PageDown | Scrolls content logically downward by one page. (Inherited from StackPanel.)
Public method | PageLeft | Scrolls content logically to the left by one page. (Inherited from StackPanel.)
Public method | PageRight | Scrolls content logically to the right by one page. (Inherited from StackPanel.)
Public method | PageUp | Scrolls content logically upward by one page. (Inherited from StackPanel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetHorizontalOffset | Sets the value of the HorizontalOffset property. (Inherited from StackPanel.)
Public method | SetVerticalOffset | Sets the value of the VerticalOffset property. (Inherited from StackPanel.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxInlinePanel Constructor

Initializes an instance of the PartEditBoxInlinePanel class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PartEditBoxInlinePanel()
Public Sub New
See Also

Reference

PartEditBoxInlinePanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxInlinePanel Properties

The PartEditBoxInlinePanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | CanHorizontallyScroll | Gets or sets a value that indicates whether a StackPanel can scroll in the horizontal dimension. (Inherited from StackPanel.)
Public property | CanVerticallyScroll | Gets or sets a value that indicates whether content can scroll in the vertical dimension. (Inherited from StackPanel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtentHeight | Gets a value that contains the vertical size of the extent. (Inherited from StackPanel.)
Public property | ExtentWidth | Gets a value that contains the horizontal size of the extent. (Inherited from StackPanel.)
Protected property | HasLogicalOrientation | Gets a value that indicates if this StackPanel has vertical or horizontal orientation. (Inherited from StackPanel.)
Public property | HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled content. (Inherited from StackPanel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | Gets a value that represents the Orientation of the StackPanel. (Inherited from StackPanel.)
Public property | Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked. (Inherited from StackPanel.)
Public property | ScrollOwner | Gets or sets a value that identifies the container that controls scrolling behavior in this StackPanel. (Inherited from StackPanel.)
Public property | VerticalOffset | Gets a value that contains the vertical offset of the scrolled content. (Inherited from StackPanel.)
Public property | ViewportHeight | Gets a value that contains the vertical size of the content's viewport. (Inherited from StackPanel.)
Public property | ViewportWidth | Gets a value that contains the horizontal size of the content's viewport. (Inherited from StackPanel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PartEditBoxInlinePanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PartEditBoxInlinePanel Methods

The PartEditBoxInlinePanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges the content of a StackPanel element. (Inherited from StackPanel.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls content downward by one logical unit. (Inherited from StackPanel.)
Public method | LineLeft | Scrolls content by one logical unit to the left. (Inherited from StackPanel.)
Public method | LineRight | Scrolls content by one logical unit to the right. (Inherited from StackPanel.)
Public method | LineUp | Scrolls content by one logical unit upward. (Inherited from StackPanel.)
Public method | MakeVisible | Scrolls to the specified coordinates and makes that part of a Visual visible. (Inherited from StackPanel.)
Protected method | MeasureOverride | Measures the child elements of a StackPanel in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from StackPanel.)
Public method | MouseWheelDown | Scrolls content logically downward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelLeft | Scrolls content logically to the left in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelRight | Scrolls content logically to the right in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelUp | Scrolls content logically upward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PageDown | Scrolls content logically downward by one page. (Inherited from StackPanel.)
Public method | PageLeft | Scrolls content logically to the left by one page. (Inherited from StackPanel.)
Public method | PageRight | Scrolls content logically to the right by one page. (Inherited from StackPanel.)
Public method | PageUp | Scrolls content logically upward by one page. (Inherited from StackPanel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetHorizontalOffset | Sets the value of the HorizontalOffset property. (Inherited from StackPanel.)
Public method | SetVerticalOffset | Sets the value of the VerticalOffset property. (Inherited from StackPanel.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PartEditBoxInlinePanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PickerBase Class

Provides an abstract base class that can be used for pickers.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
More...

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class PickerBase : Control
Public MustInherit Class PickerBase
    Inherits Control

The PickerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PickerBase | Initializes an instance of the PickerBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.EditorsBrushPicker
ActiproSoftware.Windows.Controls.EditorsColorPicker
ActiproSoftware.Windows.Controls.EditorsCornerRadiusPicker
ActiproSoftware.Windows.Controls.EditorsDatePicker
ActiproSoftware.Windows.Controls.EditorsDateTimePicker
ActiproSoftware.Windows.Controls.EditorsEnumPicker
ActiproSoftware.Windows.Controls.EditorsHsbColorPicker
ActiproSoftware.Windows.Controls.EditorsInt32RectPicker
ActiproSoftware.Windows.Controls.EditorsPointPicker
ActiproSoftware.Windows.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.Windows.Controls.EditorsRectPicker
ActiproSoftware.Windows.Controls.EditorsSizePicker
ActiproSoftware.Windows.Controls.EditorsThicknessPicker
ActiproSoftware.Windows.Controls.EditorsTimePicker
ActiproSoftware.Windows.Controls.EditorsTimeSpanPicker
ActiproSoftware.Windows.Controls.EditorsVectorPicker


PickerBase Constructor

Initializes an instance of the PickerBase class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected PickerBase()
Protected Sub New
See Also

Reference

PickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PickerBase Properties

The PickerBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PickerBase Methods

The PickerBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PickerBase.OnCreateAutomationPeer Method

PickerBaseOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

PickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


PickerBase Events

The PickerBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

PickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Class

Provides an abstract base class that can be used for pickers that use radial sliders.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.Editors.PrimitivesRadialSliderPickerBase
More...

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class RadialSliderPickerBase : PickerBase
Public MustInherit Class RadialSliderPickerBase
    Inherits PickerBase

The RadialSliderPickerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | RadialSliderPickerBase | Initializes a new instance of the RadialSliderPickerBase class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider.
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider.
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider.
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider.
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount.
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
DegreeLargeChangeProperty | Identifies the DegreeLargeChange dependency property. This field is read-only.
DegreeMaximumProperty | Identifies the DegreeMaximum dependency property. This field is read-only.
DegreeMinimumProperty | Identifies the DegreeMinimum dependency property. This field is read-only.
DegreeSmallChangeProperty | Identifies the DegreeSmallChange dependency property. This field is read-only.
DegreeValueProperty | Identifies the DegreeValue dependency property. This field is read-only.
SetValueAndClosePopupCommandProperty | Identifies the SetValueAndClosePopupCommand dependency property. This field is read-only.
SmallDecrementValueCommandProperty | Identifies the SmallDecrementValueCommand dependency property. This field is read-only.
SmallIncrementValueCommandProperty | Identifies the SmallIncrementValueCommand dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.Windows.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.Windows.Controls.EditorsBytePicker
ActiproSoftware.Windows.Controls.EditorsDoublePicker
ActiproSoftware.Windows.Controls.EditorsInt16Picker
ActiproSoftware.Windows.Controls.EditorsInt32Picker
ActiproSoftware.Windows.Controls.EditorsInt64Picker
ActiproSoftware.Windows.Controls.EditorsSinglePicker


RadialSliderPickerBase Constructor

Initializes a new instance of the RadialSliderPickerBase class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected RadialSliderPickerBase()
Protected Sub New
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Properties

The RadialSliderPickerBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider.
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider.
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider.
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider.
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount.
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeLargeChange Property

RadialSliderPickerBaseDegreeLargeChange Property

Gets or sets the large change degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DegreeLargeChange { get; set; }
Public Property DegreeLargeChange As Double
    Get
    Set

Property Value

Type: Double
The large change degree value.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeMaximum Property

RadialSliderPickerBaseDegreeMaximum Property

Gets or sets the highest possible degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DegreeMaximum { get; set; }
Public Property DegreeMaximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible degree value.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeMinimum Property

RadialSliderPickerBaseDegreeMinimum Property

Gets or sets the lowest possible degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DegreeMinimum { get; set; }
Public Property DegreeMinimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible degree value.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeSmallChange Property

RadialSliderPickerBaseDegreeSmallChange Property

Gets or sets the small change degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DegreeSmallChange { get; set; }
Public Property DegreeSmallChange As Double
    Get
    Set

Property Value

Type: Double
The small change degree value.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeValue Property

RadialSliderPickerBaseDegreeValue Property

Gets or sets the degree value of the control, which can be bound to a radial slider.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DegreeValue { get; set; }
Public Property DegreeValue As Double
    Get
    Set

Property Value

Type: Double
The degree value of the control.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SetValueAndClosePopupCommand Property

RadialSliderPickerBaseSetValueAndClosePopupCommand Property

Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SetValueAndClosePopupCommand { get; set; }
Public Property SetValueAndClosePopupCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SmallDecrementValueCommand Property

RadialSliderPickerBaseSmallDecrementValueCommand Property

Gets or sets the ICommand that can be used to decrement the value by a small amount.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SmallDecrementValueCommand { get; set; }
Public Property SmallDecrementValueCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand that can be used to decrement the value by a small amount.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SmallIncrementValueCommand Property

RadialSliderPickerBaseSmallIncrementValueCommand Property

Gets or sets the ICommand that can be used to increment the value by a small amount.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SmallIncrementValueCommand { get; set; }
Public Property SmallIncrementValueCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand that can be used to increment the value by a small amount.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Methods

The RadialSliderPickerBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Events

The RadialSliderPickerBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Fields

The RadialSliderPickerBase type exposes the following members.

Fields
Name | Description
DegreeLargeChangeProperty | Identifies the DegreeLargeChange dependency property. This field is read-only.
DegreeMaximumProperty | Identifies the DegreeMaximum dependency property. This field is read-only.
DegreeMinimumProperty | Identifies the DegreeMinimum dependency property. This field is read-only.
DegreeSmallChangeProperty | Identifies the DegreeSmallChange dependency property. This field is read-only.
DegreeValueProperty | Identifies the DegreeValue dependency property. This field is read-only.
SetValueAndClosePopupCommandProperty | Identifies the SetValueAndClosePopupCommand dependency property. This field is read-only.
SmallDecrementValueCommandProperty | Identifies the SmallDecrementValueCommand dependency property. This field is read-only.
SmallIncrementValueCommandProperty | Identifies the SmallIncrementValueCommand dependency property. This field is read-only.
Top
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeLargeChangeProperty Field

RadialSliderPickerBaseDegreeLargeChangeProperty Field

Identifies the DegreeLargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeLargeChangeProperty
Public Shared ReadOnly DegreeLargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeLargeChange dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeMaximumProperty Field

RadialSliderPickerBaseDegreeMaximumProperty Field

Identifies the DegreeMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeMaximumProperty
Public Shared ReadOnly DegreeMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeMaximum dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeMinimumProperty Field

RadialSliderPickerBaseDegreeMinimumProperty Field

Identifies the DegreeMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeMinimumProperty
Public Shared ReadOnly DegreeMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeMinimum dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeSmallChangeProperty Field

RadialSliderPickerBaseDegreeSmallChangeProperty Field

Identifies the DegreeSmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeSmallChangeProperty
Public Shared ReadOnly DegreeSmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeSmallChange dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeValueProperty Field

RadialSliderPickerBaseDegreeValueProperty Field

Identifies the DegreeValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeValueProperty
Public Shared ReadOnly DegreeValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeValue dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SetValueAndClosePopupCommandProperty Field

RadialSliderPickerBaseSetValueAndClosePopupCommandProperty Field

Identifies the SetValueAndClosePopupCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SetValueAndClosePopupCommandProperty
Public Shared ReadOnly SetValueAndClosePopupCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SetValueAndClosePopupCommand dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SmallDecrementValueCommandProperty Field

RadialSliderPickerBaseSmallDecrementValueCommandProperty Field

Identifies the SmallDecrementValueCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallDecrementValueCommandProperty
Public Shared ReadOnly SmallDecrementValueCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallDecrementValueCommand dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SmallIncrementValueCommandProperty Field

RadialSliderPickerBaseSmallIncrementValueCommandProperty Field

Identifies the SmallIncrementValueCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallIncrementValueCommandProperty
Public Shared ReadOnly SmallIncrementValueCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallIncrementValueCommand dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RatingPanel Class

Represents a Panel for arranging items in a Rating.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
System.Windows.ControlsStackPanel
ActiproSoftware.Windows.Controls.Editors.PrimitivesRatingPanel

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class RatingPanel : StackPanel
Public Class RatingPanel
    Inherits StackPanel

The RatingPanel type exposes the following members.

Constructors
 | Name | Description
Public method | RatingPanel | Initializes a new instance of the RatingPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | CanHorizontallyScroll | Gets or sets a value that indicates whether a StackPanel can scroll in the horizontal dimension. (Inherited from StackPanel.)
Public property | CanVerticallyScroll | Gets or sets a value that indicates whether content can scroll in the vertical dimension. (Inherited from StackPanel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtentHeight | Gets a value that contains the vertical size of the extent. (Inherited from StackPanel.)
Public property | ExtentWidth | Gets a value that contains the horizontal size of the extent. (Inherited from StackPanel.)
Protected property | HasLogicalOrientation | Gets a value that indicates if this StackPanel has vertical or horizontal orientation. (Inherited from StackPanel.)
Public property | HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled content. (Inherited from StackPanel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | Gets a value that represents the Orientation of the StackPanel. (Inherited from StackPanel.)
Public property | Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked. (Inherited from StackPanel.)
Public property | ScrollOwner | Gets or sets a value that identifies the container that controls scrolling behavior in this StackPanel. (Inherited from StackPanel.)
Public property | VerticalOffset | Gets a value that contains the vertical offset of the scrolled content. (Inherited from StackPanel.)
Public property | ViewportHeight | Gets a value that contains the vertical size of the content's viewport. (Inherited from StackPanel.)
Public property | ViewportWidth | Gets a value that contains the horizontal size of the content's viewport. (Inherited from StackPanel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges and performs layout on children given a size to layout within. (Overrides StackPanelArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls content downward by one logical unit. (Inherited from StackPanel.)
Public method | LineLeft | Scrolls content by one logical unit to the left. (Inherited from StackPanel.)
Public method | LineRight | Scrolls content by one logical unit to the right. (Inherited from StackPanel.)
Public method | LineUp | Scrolls content by one logical unit upward. (Inherited from StackPanel.)
Public method | MakeVisible | Scrolls to the specified coordinates and makes that part of a Visual visible. (Inherited from StackPanel.)
Protected method | MeasureOverride | Measures all children given an available size and returns its desired size based on the size of its children. (Overrides StackPanelMeasureOverride(Size).)
Public method | MouseWheelDown | Scrolls content logically downward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelLeft | Scrolls content logically to the left in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelRight | Scrolls content logically to the right in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelUp | Scrolls content logically upward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Protected method | OnIsItemsHostChanged | Occurs when the IsItemsHost property changes. (Overrides PanelOnIsItemsHostChanged(Boolean, Boolean).)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PageDown | Scrolls content logically downward by one page. (Inherited from StackPanel.)
Public method | PageLeft | Scrolls content logically to the left by one page. (Inherited from StackPanel.)
Public method | PageRight | Scrolls content logically to the right by one page. (Inherited from StackPanel.)
Public method | PageUp | Scrolls content logically upward by one page. (Inherited from StackPanel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetHorizontalOffset | Sets the value of the HorizontalOffset property. (Inherited from StackPanel.)
Public method | SetVerticalOffset | Sets the value of the VerticalOffset property. (Inherited from StackPanel.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RatingPanel Constructor

Initializes a new instance of the RatingPanel class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RatingPanel()
Public Sub New
See Also

Reference

RatingPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RatingPanel Properties

The RatingPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | CanHorizontallyScroll | Gets or sets a value that indicates whether a StackPanel can scroll in the horizontal dimension. (Inherited from StackPanel.)
Public property | CanVerticallyScroll | Gets or sets a value that indicates whether content can scroll in the vertical dimension. (Inherited from StackPanel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtentHeight | Gets a value that contains the vertical size of the extent. (Inherited from StackPanel.)
Public property | ExtentWidth | Gets a value that contains the horizontal size of the extent. (Inherited from StackPanel.)
Protected property | HasLogicalOrientation | Gets a value that indicates if this StackPanel has vertical or horizontal orientation. (Inherited from StackPanel.)
Public property | HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled content. (Inherited from StackPanel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | Gets a value that represents the Orientation of the StackPanel. (Inherited from StackPanel.)
Public property | Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked. (Inherited from StackPanel.)
Public property | ScrollOwner | Gets or sets a value that identifies the container that controls scrolling behavior in this StackPanel. (Inherited from StackPanel.)
Public property | VerticalOffset | Gets a value that contains the vertical offset of the scrolled content. (Inherited from StackPanel.)
Public property | ViewportHeight | Gets a value that contains the vertical size of the content's viewport. (Inherited from StackPanel.)
Public property | ViewportWidth | Gets a value that contains the horizontal size of the content's viewport. (Inherited from StackPanel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RatingPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RatingPanel Methods

The RatingPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Arranges and performs layout on children given a size to layout within. (Overrides StackPanelArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls content downward by one logical unit. (Inherited from StackPanel.)
Public method | LineLeft | Scrolls content by one logical unit to the left. (Inherited from StackPanel.)
Public method | LineRight | Scrolls content by one logical unit to the right. (Inherited from StackPanel.)
Public method | LineUp | Scrolls content by one logical unit upward. (Inherited from StackPanel.)
Public method | MakeVisible | Scrolls to the specified coordinates and makes that part of a Visual visible. (Inherited from StackPanel.)
Protected method | MeasureOverride | Measures all children given an available size and returns its desired size based on the size of its children. (Overrides StackPanelMeasureOverride(Size).)
Public method | MouseWheelDown | Scrolls content logically downward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelLeft | Scrolls content logically to the left in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelRight | Scrolls content logically to the right in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelUp | Scrolls content logically upward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Protected method | OnIsItemsHostChanged | Occurs when the IsItemsHost property changes. (Overrides PanelOnIsItemsHostChanged(Boolean, Boolean).)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PageDown | Scrolls content logically downward by one page. (Inherited from StackPanel.)
Public method | PageLeft | Scrolls content logically to the left by one page. (Inherited from StackPanel.)
Public method | PageRight | Scrolls content logically to the right by one page. (Inherited from StackPanel.)
Public method | PageUp | Scrolls content logically upward by one page. (Inherited from StackPanel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetHorizontalOffset | Sets the value of the HorizontalOffset property. (Inherited from StackPanel.)
Public method | SetVerticalOffset | Sets the value of the VerticalOffset property. (Inherited from StackPanel.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RatingPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RatingPanel.ArrangeOverride Method

RatingPanelArrangeOverride Method

Arranges and performs layout on children given a size to layout within.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The size Panel is suggested to occupy for layout.

Return Value

Type: Size
The size Panel occupies after layout.
See Also

Reference

RatingPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RatingPanel.MeasureOverride Method

RatingPanelMeasureOverride Method

Measures all children given an available size and returns its desired size based on the size of its children.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The size the Panel is suggested to fit inside.

Return Value

Type: Size
The desired size of the Panel.
See Also

Reference

RatingPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


RatingPanel.OnIsItemsHostChanged Method

RatingPanelOnIsItemsHostChanged Method

Occurs when the IsItemsHost property changes.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsItemsHostChanged(
    bool oldIsItemsHost,
    bool newIsItemsHost
)
Protected Overrides Sub OnIsItemsHostChanged (
    oldIsItemsHost As Boolean,
    newIsItemsHost As Boolean
)

Parameters

oldIsItemsHost
Type: SystemBoolean
The old value.
newIsItemsHost
Type: SystemBoolean
The new value.
See Also

Reference

RatingPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Class

Represents a square that renders the saturation and brightness variants of a color.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesSaturationBrightnessSquare

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SaturationBrightnessSquare : Control
Public Class SaturationBrightnessSquare
    Inherits Control

The SaturationBrightnessSquare type exposes the following members.

Constructors
 | Name | Description
Public method | SaturationBrightnessSquare | Initializes an instance of the SaturationBrightnessSquare class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrightnessBrush | Gets the Brush used to render brightness.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the base color hue.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SaturationBrush | Gets the Brush used to render saturation.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
BrightnessBrushProperty | Identifies the BrightnessBrush dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationBrushProperty | Identifies the SaturationBrush dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Constructor

Initializes an instance of the SaturationBrightnessSquare class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SaturationBrightnessSquare()
Public Sub New
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Properties

The SaturationBrightnessSquare type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrightnessBrush | Gets the Brush used to render brightness.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the base color hue.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SaturationBrush | Gets the Brush used to render saturation.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.BrightnessBrush Property

SaturationBrightnessSquareBrightnessBrush Property

Gets the Brush used to render brightness.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BrightnessBrush { get; }
Public ReadOnly Property BrightnessBrush As Brush
    Get

Property Value

Type: Brush
The Brush used to render brightness.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.Hue Property

SaturationBrightnessSquareHue Property

Gets or sets the base color hue.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The base color hue.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.SaturationBrush Property

SaturationBrightnessSquareSaturationBrush Property

Gets the Brush used to render saturation.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush SaturationBrush { get; }
Public ReadOnly Property SaturationBrush As Brush
    Get

Property Value

Type: Brush
The Brush used to render saturation.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Methods

The SaturationBrightnessSquare type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Events

The SaturationBrightnessSquare type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Fields

The SaturationBrightnessSquare type exposes the following members.

Fields
Name | Description
BrightnessBrushProperty | Identifies the BrightnessBrush dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationBrushProperty | Identifies the SaturationBrush dependency property. This field is read-only.
Top
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.BrightnessBrushProperty Field

SaturationBrightnessSquareBrightnessBrushProperty Field

Identifies the BrightnessBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrightnessBrushProperty
Public Shared ReadOnly BrightnessBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BrightnessBrush dependency property.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.HueProperty Field

SaturationBrightnessSquareHueProperty Field

Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.SaturationBrushProperty Field

SaturationBrightnessSquareSaturationBrushProperty Field

Identifies the SaturationBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SaturationBrushProperty
Public Shared ReadOnly SaturationBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SaturationBrush dependency property.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner Class

Represents a spinner control, which offers up/down or left/right buttons.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Editors.PrimitivesSpinner

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Spinner : Control
Public Class Spinner
    Inherits Control

The Spinner type exposes the following members.

Constructors
 | Name | Description
Public method | Spinner | Initializes an instance of the Spinner class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommandParameter | Gets or sets the command parameters to use with the buttons.
Public property | DecrementCommand | Gets or sets the ICommand executed when the decrement button is tapped.
Public property | DecrementToolTip | Gets or sets the tooltip content for the decrement button.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncrementCommand | Gets or sets the ICommand executed when the increment button is tapped.
Public property | IncrementToolTip | Gets or sets the tooltip content for the increment button.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the spinner.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CommandParameterProperty | Identifies the CommandParameter dependency property. This field is read-only.
DecrementCommandProperty | Identifies the DecrementCommand dependency property. This field is read-only.
DecrementToolTipProperty | Identifies the DecrementToolTip dependency property. This field is read-only.
IncrementCommandProperty | Identifies the IncrementCommand dependency property. This field is read-only.
IncrementToolTipProperty | Identifies the IncrementToolTip dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner Constructor

Initializes an instance of the Spinner class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Spinner()
Public Sub New
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner Properties

The Spinner type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CommandParameter | Gets or sets the command parameters to use with the buttons.
Public property | DecrementCommand | Gets or sets the ICommand executed when the decrement button is tapped.
Public property | DecrementToolTip | Gets or sets the tooltip content for the decrement button.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncrementCommand | Gets or sets the ICommand executed when the increment button is tapped.
Public property | IncrementToolTip | Gets or sets the tooltip content for the increment button.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Orientation | Gets or sets the Orientation of the spinner.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.CommandParameter Property

SpinnerCommandParameter Property

Gets or sets the command parameters to use with the buttons.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object CommandParameter { get; set; }
Public Property CommandParameter As Object
    Get
    Set

Property Value

Type: Object
The command parameters to use with the buttons.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.DecrementCommand Property

SpinnerDecrementCommand Property

Gets or sets the ICommand executed when the decrement button is tapped.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand DecrementCommand { get; set; }
Public Property DecrementCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand executed when the decrement button is tapped.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.DecrementToolTip Property

SpinnerDecrementToolTip Property

Gets or sets the tooltip content for the decrement button.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object DecrementToolTip { get; set; }
Public Property DecrementToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip content for the decrement button.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.IncrementCommand Property

SpinnerIncrementCommand Property

Gets or sets the ICommand executed when the increment button is tapped.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand IncrementCommand { get; set; }
Public Property IncrementCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand executed when the increment button is tapped.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.IncrementToolTip Property

SpinnerIncrementToolTip Property

Gets or sets the tooltip content for the increment button.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object IncrementToolTip { get; set; }
Public Property IncrementToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip content for the increment button.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.Orientation Property

SpinnerOrientation Property

Gets or sets the Orientation of the spinner.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the spinner. The default value is Vertical.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner Methods

The Spinner type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.OnApplyTemplate Method

SpinnerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner Events

The Spinner type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner Fields

The Spinner type exposes the following members.

Fields
Name | Description
CommandParameterProperty | Identifies the CommandParameter dependency property. This field is read-only.
DecrementCommandProperty | Identifies the DecrementCommand dependency property. This field is read-only.
DecrementToolTipProperty | Identifies the DecrementToolTip dependency property. This field is read-only.
IncrementCommandProperty | Identifies the IncrementCommand dependency property. This field is read-only.
IncrementToolTipProperty | Identifies the IncrementToolTip dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.CommandParameterProperty Field

SpinnerCommandParameterProperty Field

Identifies the CommandParameter dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CommandParameterProperty
Public Shared ReadOnly CommandParameterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CommandParameter dependency property.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.DecrementCommandProperty Field

SpinnerDecrementCommandProperty Field

Identifies the DecrementCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DecrementCommandProperty
Public Shared ReadOnly DecrementCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DecrementCommand dependency property.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.DecrementToolTipProperty Field

SpinnerDecrementToolTipProperty Field

Identifies the DecrementToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DecrementToolTipProperty
Public Shared ReadOnly DecrementToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DecrementToolTip dependency property.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.IncrementCommandProperty Field

SpinnerIncrementCommandProperty Field

Identifies the IncrementCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IncrementCommandProperty
Public Shared ReadOnly IncrementCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IncrementCommand dependency property.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.IncrementToolTipProperty Field

SpinnerIncrementToolTipProperty Field

Identifies the IncrementToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IncrementToolTipProperty
Public Shared ReadOnly IncrementToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IncrementToolTip dependency property.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


Spinner.OrientationProperty Field

SpinnerOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

Spinner Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SpinnerButtonPanel Class

Provides a panel for arranging buttons within a Spinner.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Editors.PrimitivesSpinnerButtonPanel

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SpinnerButtonPanel : Panel
Public Class SpinnerButtonPanel
    Inherits Panel

The SpinnerButtonPanel type exposes the following members.

Constructors
 | Name | Description
Public method | SpinnerButtonPanel | Initializes a new instance of the SpinnerButtonPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets or sets the Orientation of the spinner.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SpinnerButtonPanel Constructor

Initializes a new instance of the SpinnerButtonPanel class

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SpinnerButtonPanel()
Public Sub New
See Also

Reference

SpinnerButtonPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SpinnerButtonPanel Properties

The SpinnerButtonPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets or sets the Orientation of the spinner.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SpinnerButtonPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SpinnerButtonPanel.Orientation Property

SpinnerButtonPanelOrientation Property

Gets or sets the Orientation of the spinner.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the spinner. The default value is Vertical.
See Also

Reference

SpinnerButtonPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SpinnerButtonPanel Methods

The SpinnerButtonPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

SpinnerButtonPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SpinnerButtonPanel.ArrangeOverride Method

SpinnerButtonPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

SpinnerButtonPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SpinnerButtonPanel.MeasureOverride Method

SpinnerButtonPanelMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

SpinnerButtonPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SpinnerButtonPanel Fields

The SpinnerButtonPanel type exposes the following members.

Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

SpinnerButtonPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


SpinnerButtonPanel.OrientationProperty Field

SpinnerButtonPanelOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Editors.Primitives
Assembly: ActiproSoftware.Editors.Wpf (in ActiproSoftware.Editors.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

SpinnerButtonPanel Class
ActiproSoftware.Windows.Controls.Editors.Primitives Namespace


ActiproSoftware.Windows.Controls.Gauge Namespace

Contains classes that support implementing gauge controls for WPF.
Classes
 | Class | Description
Public class | BooleanToLedStateConverter | Represents a value converter can can convert between a Boolean to an LedState.
Public class | CircularGauge | Represents a circular gauge control.
Public class | CircularPointerBar | Represents a bar pointer for use in a CircularGauge.
Public class | CircularPointerCap | Represents a cap pointer for use in a CircularGauge.
Public class | CircularPointerCollection | Represents a collection of CircularPointerBase objects.
Public class | CircularPointerLabel | Represents a text pointer for use in a CircularGauge.
Public class | CircularPointerMarker | Represents a marker pointer for use in a CircularGauge.
Public class | CircularPointerNeedle | Represents a needle pointer for use in a CircularGauge.
Public class | CircularRange | Represents an element that renders a range in a CircularGauge.
Public class | CircularRangeCollection | Represents a collection of CircularRange objects.
Public class | CircularScale | Represents a scale for use in a CircularGauge.
Public class | CircularScaleCollection | Represents a collection of CircularScale objects.
Public class | CircularTickCollection | Represents a collection of CircularTickBase objects.
Public class | CircularTickLabelCustom | Represents an element that renders a custom tick label in a CircularGauge.
Public class | CircularTickLabelMajor | Represents an element that renders major tick labels in a CircularGauge.
Public class | CircularTickLabelMinor | Represents an element that renders minor tick labels in a CircularGauge.
Public class | CircularTickMarkCustom | Represents an element that renders a custom tick mark in a CircularGauge.
Public class | CircularTickMarkMajor | Represents an element that renders major tick marks in a CircularGauge.
Public class | CircularTickMarkMinor | Represents an element that renders minor tick marks in a CircularGauge.
Public class | CircularTickSet | Represents a tick-set used in a CircularGauge.
Public class | CircularTickSetCollection | Represents a collection of CircularTickSet objects.
Public class | DigitalGauge | Represents a digital gauge control.
Public class | DoubleAverageConverter | Represents a value converter that returns an average of the values that are passed to the converter.
Public class | DoubleMaximumConverter | Represents a value converter that returns the maximum of the values that are passed to the converter.
Public class | DoubleMinimumConverter | Represents a value converter that returns the minimum of the values that are passed to the converter.
Public class | Led | Represents a led control.
Public class | LedStatePropertyChangedRoutedEventArgs | Provides event arguments for a LedState property change routed event, indicating the old and new values.
Public class | LinearGauge | Represents a linear gauge control.
Public class | LinearPointerBar | Represents a bar pointer for use in a LinearGauge.
Public class | LinearPointerCollection | Represents a collection of LinearPointerBase objects.
Public class | LinearPointerLabel | Represents a text pointer for use in a LinearGauge.
Public class | LinearPointerMarker | Represents a marker pointer for use in a LinearGauge.
Public class | LinearRange | Represents an element that renders a range in a LinearGauge.
Public class | LinearRangeCollection | Represents a collection of LinearRange objects.
Public class | LinearScale | Represents a scale for use in a LinearGauge.
Public class | LinearScaleCollection | Represents a collection of LinearScale objects.
Public class | LinearTickCollection | Represents a collection of LinearTickBase objects.
Public class | LinearTickLabelCustom | Represents an element that renders a custom tick label in a LinearGauge.
Public class | LinearTickLabelMajor | Represents an element that renders major tick labels in a LinearGauge.
Public class | LinearTickLabelMinor | Represents an element that renders minor tick labels in a LinearGauge.
Public class | LinearTickMarkCustom | Represents an element that renders a custom tick mark in a LinearGauge.
Public class | LinearTickMarkMajor | Represents an element that renders major tick marks in a LinearGauge.
Public class | LinearTickMarkMinor | Represents an element that renders minor tick marks in a LinearGauge.
Public class | LinearTickSet | Represents a tick set used in a LinearGauge.
Public class | LinearTickSetCollection | Represents a collection of LinearTickSet objects.
Public class | ToggleSwitch | Represents a toggle switch control.
Enumerations
 | Enumeration | Description
Public enumeration | CircularBackgroundType | Specifies the types of backgrounds supported by CircularGaugeBase.
Public enumeration | CircularFrameType | Specifies the types of frames supported by CircularGauge.
Public enumeration | CircularGlassType | Specifies the types of glass effects supported by CircularGlassEffect.
Public enumeration | CircularPointerDirection | Specifies the directions supported by circular pointers.
Public enumeration | CircularRimType | Specifies the types of rims supported by CircularGaugeBase.
Public enumeration | CoordinateOrigin | Specifies the origin point for use with x/y coordinates.
Public enumeration | DigitalCharacterOverflowAlignment | Specifies the various types digital character alignment when characters are overflowed.
Public enumeration | DigitalCharacterScrollState | Specifies the various directions that the digital characters can be scrolled.
Public enumeration | DigitalCharacterType | Specifies the various types of digital characters.
Public enumeration | DigitalTextAlignment | Specifies the digital text alignment.
Public enumeration | IntervalOrigin | Specifies the various interval origins.
Public enumeration | IntervalType | Specifies the various interval types.
Public enumeration | LedState | Specifies the states supported by Led.
Public enumeration | LedType | Specifies the types of led shapes supported by Led.
Public enumeration | PointerBarOrigin | Specifies the origins supported by the CircularPointerBar element.
Public enumeration | PointerBarType | Specifies the types of markers supported by the LinearPointerBar element.
Public enumeration | PointerCapType | Specifies the types of caps supported by the CircularPointerCap element.
Public enumeration | PointerMarkerType | Specifies the types of markers supported by the CircularPointerMarker and LinearPointerMarker elements.
Public enumeration | PointerNeedleType | Specifies the types of needles supported by a CircularPointerNeedle element.
Public enumeration | RectangularBackgroundType | Specifies the types of backgrounds supported by RectangularGaugeBase.
Public enumeration | RectangularFrameType | Specifies the types of frames supported by LinearGauge and DigitalGauge.
Public enumeration | RectangularGlassType | Specifies the types of glass effects supported by RectangularGlassEffect.
Public enumeration | RectangularRimType | Specifies the types of rim supported by RectangularGaugeBase.
Public enumeration | ScalePlacement | Specifies the various placements support by elements hosted in a gauge scale.
Public enumeration | TextOrientation | Specifies the orientation of text when rendered in a gauge control.
Public enumeration | TickMarkType | Specifies the types of tick marks supported by TickBase-derived elements.
Public enumeration | TickVisibility | Specifies the various visible states of tick marks and tick labels.
Public enumeration | ToggleSwitchType | Specifies the types of switches supported by ToggleSwitch.


BooleanToLedStateConverter Class

Represents a value converter can can convert between a Boolean to an LedState.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.GaugeBooleanToLedStateConverter

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BooleanToLedStateConverter : IValueConverter
Public Class BooleanToLedStateConverter
    Implements IValueConverter

The BooleanToLedStateConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanToLedStateConverter | Initializes a new instance of the BooleanToLedStateConverter class
Top
Properties
 | Name | Description
Public property | FalseState | Gets or sets the LedState that is considered equivalent to false.
Public property | TrueState | Gets or sets the LedState that is considered equivalent to true.
Top
Methods
 | Name | Description
Public method | Convert | Converts a value.
Public method | ConvertBack | Converts a value.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


BooleanToLedStateConverter Constructor

Initializes a new instance of the BooleanToLedStateConverter class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BooleanToLedStateConverter()
Public Sub New
See Also

Reference

BooleanToLedStateConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


BooleanToLedStateConverter Properties

The BooleanToLedStateConverter type exposes the following members.

Properties
 | Name | Description
Public property | FalseState | Gets or sets the LedState that is considered equivalent to false.
Public property | TrueState | Gets or sets the LedState that is considered equivalent to true.
Top
See Also

Reference

BooleanToLedStateConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


BooleanToLedStateConverter.FalseState Property

BooleanToLedStateConverterFalseState Property

Gets or sets the LedState that is considered equivalent to false.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LedState FalseState { get; set; }
Public Property FalseState As LedState
    Get
    Set

Property Value

Type: LedState
The LedState that is considered equivalent to false.
See Also

Reference

BooleanToLedStateConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


BooleanToLedStateConverter.TrueState Property

BooleanToLedStateConverterTrueState Property

Gets or sets the LedState that is considered equivalent to true.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LedState TrueState { get; set; }
Public Property TrueState As LedState
    Get
    Set

Property Value

Type: LedState
The LedState that is considered equivalent to true.
See Also

Reference

BooleanToLedStateConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


BooleanToLedStateConverter Methods

The BooleanToLedStateConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value.
Public method | ConvertBack | Converts a value.
Top
See Also

Reference

BooleanToLedStateConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


BooleanToLedStateConverter.Convert Method

BooleanToLedStateConverterConvert Method

Converts a value.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value. If the method returns null, the valid null value is used.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BooleanToLedStateConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


BooleanToLedStateConverter.ConvertBack Method

BooleanToLedStateConverterConvertBack Method

Converts a value.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value that is produced by the binding target.
targetType
Type: SystemType
The type to convert to.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
A converted value. If the method returns null, the valid null value is used.

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BooleanToLedStateConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularBackgroundType Enumeration

Specifies the types of backgrounds supported by CircularGaugeBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CircularBackgroundType
Public Enumeration CircularBackgroundType
Members
Member name | Value | Description
CircularDarkEdge | 0 | Indicates a circular background frame with a dark edge effect.
CircularEclipseShade | 1 | Indicates a circular background frame with eclipse shade effect.
CircularOrb | 2 | Indicates a circular background frame with an orb effect.
CircularSideGradient | 3 | Indicates a circular background frame with side gradient effect.
CircularTopGradient | 4 | Indicates a circular background frame with top gradient effect.
CustomBackgroundGeometry | 5 | Indicates the circular background frame will be based on a custom geometry.
CustomBackgroundImage | 6 | Indicates the circular background frame will be based on a custom image.
FanSideGradient | 7 | Indicates a fan shaped background frame with side gradient effect.
FanTopGradient | 8 | Indicates a fan shaped background frame with top gradient effect.
None | 9 | Indicates that no frame will be rendered.
SemicircularOrb | 10 | Indicates a semi-circular background frame with orb effect.
SemicircularSideGradient | 11 | Indicates a semi-circular background frame with a side gradient effect.
SemicircularTopGradient | 12 | Indicates semi-circular background frame with a top gradient effect.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularFrameType Enumeration

Specifies the types of frames supported by CircularGauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CircularFrameType
Public Enumeration CircularFrameType
Members
Member name | Value | Description
CircularOrb | 0 | Indicates a circular frame with thick rim and an orb effect.
RoundedRectangle | 1 | Indicates a rounded rectangle frame.
ClippedRectangle | 2 | Indicates a clipped rectangle frame.
CircularThickRim | 3 | Indicates a circular frame with thick rim.
CircularTopGradient | 4 | Indicates a circular frame with top gradient effect.
CircularEclipseShade | 5 | Indicates a circular frame with eclipse shade effect.
CircularThickRimEclipse | 6 | Indicates a circular frame with thick rim and eclipse shade effect.
CircularDarkEdge | 7 | Indicates a circulr frame with a dark rim.
CircularGear | 8 | Indicates a circular frame with gear shaped rim.
FanRoundedRectangle | 9 | Indicates a fan shaped frame with a rectangular rim.
FanClippedRectangle | 10 | Indicates a fan shaped frame with a clipped rectangular rim.
SemicircularThickRim | 11 | Indicates a semi-circular frame with a thick rim.
SemicircularThinRim | 12 | Indicates a semi-circular frame with a thin rim.
SemicircularRoundedRectangle | 13 | Indicates a semi-circular frame with a rounded rectangular rim.
SemicircularClippedRectangle | 14 | Indicates semi-circular frame with a clipped rectangular rim
None | 15 | Indicates that no frame will be rendered.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularGauge Class

Represents a circular gauge control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularGaugeBase
ActiproSoftware.Windows.Controls.GaugeCircularGauge

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularGauge : CircularGaugeBase
Public Class CircularGauge
    Inherits CircularGaugeBase

The CircularGauge type exposes the following members.

Constructors
 | Name | Description
Public method | CircularGauge | Initializes a new instance of the CircularGauge class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundRadiusRatio | Gets or sets the radius of the frame background as a ratio of the Radius property. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FrameType | Gets or sets the type of frame rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides CircularGaugeBaseLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Radius | Gets or sets the radius of the gauge. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | Scales | Gets the scale elements within the gauge.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides CircularGaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides CircularGaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularGaugeBase.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from CircularGaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularGauge Constructor

Initializes a new instance of the CircularGauge class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularGauge()
Public Sub New
See Also

Reference

CircularGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularGauge Properties

The CircularGauge type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundRadiusRatio | Gets or sets the radius of the frame background as a ratio of the Radius property. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FrameType | Gets or sets the type of frame rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides CircularGaugeBaseLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Radius | Gets or sets the radius of the gauge. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | Scales | Gets the scale elements within the gauge.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularGauge.LogicalChildren Property

CircularGaugeLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

CircularGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularGauge.Scales Property

CircularGaugeScales Property

Gets the scale elements within the gauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularScaleCollection Scales { get; }
Public ReadOnly Property Scales As CircularScaleCollection
    Get

Property Value

Type: CircularScaleCollection
The scales.
See Also

Reference

CircularGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularGauge Methods

The CircularGauge type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides CircularGaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides CircularGaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularGaugeBase.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from CircularGaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularGauge.ArrangeOverride Method

CircularGaugeArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

CircularGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularGauge.MeasureOverride Method

CircularGaugeMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

CircularGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularGlassType Enumeration

Specifies the types of glass effects supported by CircularGlassEffect.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CircularGlassType
Public Enumeration CircularGlassType
Members
Member name | Value | Description
Circular | 0 | Indicates a circular glass effect.
CircularGear | 1 | Indicates a circular gear glass effect.
Fan | 2 | Indicates a fan glass effect.
None | 3 | Indicates that no glass effect will be rendered.
Semicircular | 4 | Indicates a semicircular glass effect.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerBar Class

Represents a bar pointer for use in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularPointerBase
ActiproSoftware.Windows.Controls.GaugeCircularPointerBar

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularPointerBar : CircularPointerBase
Public Class CircularPointerBar
    Inherits CircularPointerBase

The CircularPointerBar type exposes the following members.

Constructors
 | Name | Description
Public method | CircularPointerBar | Initializes a new instance of the CircularPointerBar class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BarOrigin | Gets or sets the origin of the bar. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
BarOriginProperty | Identifies the BarOrigin dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerBar Constructor

Initializes a new instance of the CircularPointerBar class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularPointerBar()
Public Sub New
See Also

Reference

CircularPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerBar Properties

The CircularPointerBar type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BarOrigin | Gets or sets the origin of the bar. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerBar.BarOrigin Property

CircularPointerBarBarOrigin Property

Gets or sets the origin of the bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointerBarOrigin BarOrigin { get; set; }
Public Property BarOrigin As PointerBarOrigin
    Get
    Set

Property Value

Type: PointerBarOrigin
The origin of the bar. The default value is Minimum.
See Also

Reference

CircularPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerBar Methods

The CircularPointerBar type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerBar.OnRender Method

CircularPointerBarOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerBar Events

The CircularPointerBar type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

CircularPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerBar Fields

The CircularPointerBar type exposes the following members.

Fields
Name | Description
BarOriginProperty | Identifies the BarOrigin dependency property. This field is read-only.
Top
See Also

Reference

CircularPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerBar.BarOriginProperty Field

CircularPointerBarBarOriginProperty Field

Identifies the BarOrigin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarOriginProperty
Public Shared ReadOnly BarOriginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarOrigin dependency property.
See Also

Reference

CircularPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap Class

Represents a cap pointer for use in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularPointerBase
ActiproSoftware.Windows.Controls.GaugeCircularPointerCap

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularPointerCap : CircularPointerBase
Public Class CircularPointerCap
    Inherits CircularPointerBase

The CircularPointerCap type exposes the following members.

Constructors
 | Name | Description
Public method | CircularPointerCap | Initializes a new instance of the CircularPointerCap class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | CanRotate | Gets and sets a value indicating whether the circular pointer cap should be rotated to point to the associated value. This is a dependency property.
Public property | CapType | Gets or sets the type of cap rendered. This is a dependency property.
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the cap. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate AutomationPeer for this control as part of the WPF infrastructure. (Overrides PointerBaseOnCreateAutomationPeer.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
CanRotateProperty | Identifies the CanRotate dependency property. This field is read-only.
CapTypeProperty | Identifies the CapType dependency property. This field is read-only.
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsBackgroundEffectEnabledProperty | Identifies the IsBackgroundEffectEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap Constructor

Initializes a new instance of the CircularPointerCap class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularPointerCap()
Public Sub New
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap Properties

The CircularPointerCap type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | CanRotate | Gets and sets a value indicating whether the circular pointer cap should be rotated to point to the associated value. This is a dependency property.
Public property | CapType | Gets or sets the type of cap rendered. This is a dependency property.
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the cap. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.CanRotate Property

CircularPointerCapCanRotate Property

Gets and sets a value indicating whether the circular pointer cap should be rotated to point to the associated value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanRotate { get; set; }
Public Property CanRotate As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the pointer cap should rotate; otherwise, false. The default value is false.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.CapType Property

CircularPointerCapCapType Property

Gets or sets the type of cap rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointerCapType CapType { get; set; }
Public Property CapType As PointerCapType
    Get
    Set

Property Value

Type: PointerCapType
The type of cap rendered. The default value is PointerCapType.CircleConcave.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.Geometry Property

CircularPointerCapGeometry Property

Gets or sets the custom geometry. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry Geometry { get; set; }
Public Property Geometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry. The default value is .
Remarks
This property is only used when CapType is set to PointerCapType.CustomGeometry.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.ImageSource Property

CircularPointerCapImageSource Property

Gets or sets the source of a custom image. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source. The default value is .
Remarks
This property is only used when CapType is set to PointerCapType.CustomImage.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.IsBackgroundEffectEnabled Property

CircularPointerCapIsBackgroundEffectEnabled Property

Gets and sets a value indicating whether a special effect should be rendered for the background of the cap. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsBackgroundEffectEnabled { get; set; }
Public Property IsBackgroundEffectEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the background effect is enabled; otherwise, false. The default value is true.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap Methods

The CircularPointerCap type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate AutomationPeer for this control as part of the WPF infrastructure. (Overrides PointerBaseOnCreateAutomationPeer.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.OnCreateAutomationPeer Method

CircularPointerCapOnCreateAutomationPeer Method

Creates an appropriate AutomationPeer for this control as part of the WPF infrastructure.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.OnRender Method

CircularPointerCapOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap Events

The CircularPointerCap type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap Fields

The CircularPointerCap type exposes the following members.

Fields
Name | Description
CanRotateProperty | Identifies the CanRotate dependency property. This field is read-only.
CapTypeProperty | Identifies the CapType dependency property. This field is read-only.
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsBackgroundEffectEnabledProperty | Identifies the IsBackgroundEffectEnabled dependency property. This field is read-only.
Top
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.CanRotateProperty Field

CircularPointerCapCanRotateProperty Field

Identifies the CanRotate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRotateProperty
Public Shared ReadOnly CanRotateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRotate dependency property.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.CapTypeProperty Field

CircularPointerCapCapTypeProperty Field

Identifies the CapType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CapTypeProperty
Public Shared ReadOnly CapTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CapType dependency property.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.GeometryProperty Field

CircularPointerCapGeometryProperty Field

Identifies the Geometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GeometryProperty
Public Shared ReadOnly GeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Geometry dependency property.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.ImageSourceProperty Field

CircularPointerCapImageSourceProperty Field

Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCap.IsBackgroundEffectEnabledProperty Field

CircularPointerCapIsBackgroundEffectEnabledProperty Field

Identifies the IsBackgroundEffectEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsBackgroundEffectEnabledProperty
Public Shared ReadOnly IsBackgroundEffectEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsBackgroundEffectEnabled dependency property.
See Also

Reference

CircularPointerCap Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCollection Class

Represents a collection of CircularPointerBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection CircularPointerBase
System.Collections.ObjectModelObservableCollection CircularPointerBase
ActiproSoftware.WindowsDeferrableObservableCollection CircularPointerBase
ActiproSoftware.WindowsLogicalChildrenCollection CircularPointerBase
ActiproSoftware.Windows.Controls.GaugeCircularPointerCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularPointerCollection : LogicalChildrenCollection<CircularPointerBase>
Public Class CircularPointerCollection
    Inherits LogicalChildrenCollection(Of CircularPointerBase)

The CircularPointerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CircularPointerCollection | Initializes a new instance of the CircularPointerCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularPointerBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularPointerBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularPointerBase .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularPointerBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularPointerBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularPointerBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularPointerBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularPointerBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularPointerBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularPointerBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularPointerBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularPointerBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularPointerBase .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCollection Constructor

Initializes a new instance of the CircularPointerCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularPointerCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

CircularPointerCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCollection Properties

The CircularPointerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularPointerBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularPointerBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularPointerBase .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

CircularPointerCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCollection Methods

The CircularPointerCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularPointerBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularPointerBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularPointerBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularPointerBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularPointerBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularPointerBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularPointerBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularPointerBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularPointerBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

CircularPointerCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerCollection Events

The CircularPointerCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularPointerBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularPointerBase .)
Top
See Also

Reference

CircularPointerCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerDirection Enumeration

Specifies the directions supported by circular pointers.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CircularPointerDirection
Public Enumeration CircularPointerDirection
Members
Member name | Value | Description
CounterClockwise | 0 | Indicates the pointer can only move in the counter-clockwise direction.
Clockwise | 1 | Indicates the pointer can only move in the clockwise direction.
Normal | 2 | Indicates the pointer can move either clockwise or counter-clockwise, but will not cross over the minimum or maximum value.
ShortestDistance | 3 | Indicates the pointer can move either clockwise or counter-clockwise, but will pick the shortest distance.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel Class

Represents a text pointer for use in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularPointerBase
ActiproSoftware.Windows.Controls.GaugeCircularPointerLabel

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularPointerLabel : CircularPointerBase
Public Class CircularPointerLabel
    Inherits CircularPointerBase

The CircularPointerLabel type exposes the following members.

Constructors
 | Name | Description
Public method | CircularPointerLabel | Initializes a new instance of the CircularPointerLabel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property.
Public property | FontSize | Gets or sets the size of the font. This is a dependency property.
Public property | FontStyle | Gets or sets the font style. This is a dependency property.
Public property | FontWeight | Gets or sets the font weight. This is a dependency property.
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | Text | Gets or sets the text that should be rendered at the specified value. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property.
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property.
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. This field is read-only.
FontSizeProperty | Identifies the FontSize dependency property. This field is read-only.
FontStyleProperty | Identifies the FontStyle dependency property. This field is read-only.
FontWeightProperty | Identifies the FontWeight dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
RoundModeProperty | Identifies the RoundMode dependency property. This field is read-only.
TextFormatProperty | Identifies the TextFormat dependency property. This field is read-only.
TextOrientationProperty | Identifies the TextOrientation dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel Constructor

Initializes a new instance of the CircularPointerLabel class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularPointerLabel()
Public Sub New
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel Properties

The CircularPointerLabel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property.
Public property | FontSize | Gets or sets the size of the font. This is a dependency property.
Public property | FontStyle | Gets or sets the font style. This is a dependency property.
Public property | FontWeight | Gets or sets the font weight. This is a dependency property.
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | Text | Gets or sets the text that should be rendered at the specified value. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property.
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property.
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.FontFamily Property

CircularPointerLabelFontFamily Property

Gets or sets the font family. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontFamily FontFamily { get; set; }
Public Property FontFamily As FontFamily
    Get
    Set

Property Value

Type: FontFamily
The font family. The default value is SystemFonts.MessageFontFamily.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.FontSize Property

CircularPointerLabelFontSize Property

Gets or sets the size of the font. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit FontSize { get; set; }
Public Property FontSize As Unit
    Get
    Set

Property Value

Type: Unit
The size of the font. The default value is SystemFonts.MesssageFontSize.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.FontStyle Property

CircularPointerLabelFontStyle Property

Gets or sets the font style. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontStyle FontStyle { get; set; }
Public Property FontStyle As FontStyle
    Get
    Set

Property Value

Type: FontStyle
The font style. The default value is SystemFonts.MessageFontStyle.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.FontWeight Property

CircularPointerLabelFontWeight Property

Gets or sets the font weight. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontWeight FontWeight { get; set; }
Public Property FontWeight As FontWeight
    Get
    Set

Property Value

Type: FontWeight
The font weight. The default value is SystemFonts.MessageFontWeight.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.Foreground Property

CircularPointerLabelForeground Property

Gets or sets the foreground brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Foreground { get; set; }
Public Property Foreground As Brush
    Get
    Set

Property Value

Type: Brush
The foreground brush. The default value is WhiteSmoke.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.RoundMode Property

CircularPointerLabelRoundMode Property

Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RoundMode RoundMode { get; set; }
Public Property RoundMode As RoundMode
    Get
    Set

Property Value

Type: RoundMode
A RoundMode indicating how to round the values displayed. The default value is RoundMode.Round.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.Text Property

CircularPointerLabelText Property

Gets or sets the text that should be rendered at the specified value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text that should be rendered. The default value is .
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.TextFormat Property

CircularPointerLabelTextFormat Property

Gets or sets the format used to convert Value to a string. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TextFormat { get; set; }
Public Property TextFormat As String
    Get
    Set

Property Value

Type: String
The format used to convert Value to a string. The default value is "{0:G}".
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.TextOrientation Property

CircularPointerLabelTextOrientation Property

Gets or sets the text orientation. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextOrientation TextOrientation { get; set; }
Public Property TextOrientation As TextOrientation
    Get
    Set

Property Value

Type: TextOrientation
The text orientation. The default value is TextOrienation.Normal.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel Methods

The CircularPointerLabel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.GetValueText Method

CircularPointerLabelGetValueText Method

Gets the string representation of the specified value, using TextFormat and RoundMode.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string GetValueText(
    double value
)
Protected Overridable Function GetValueText (
    value As Double
) As String

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.OnRender Method

CircularPointerLabelOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel Events

The CircularPointerLabel type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel Fields

The CircularPointerLabel type exposes the following members.

Fields
Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. This field is read-only.
FontSizeProperty | Identifies the FontSize dependency property. This field is read-only.
FontStyleProperty | Identifies the FontStyle dependency property. This field is read-only.
FontWeightProperty | Identifies the FontWeight dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
RoundModeProperty | Identifies the RoundMode dependency property. This field is read-only.
TextFormatProperty | Identifies the TextFormat dependency property. This field is read-only.
TextOrientationProperty | Identifies the TextOrientation dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
Top
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.FontFamilyProperty Field

CircularPointerLabelFontFamilyProperty Field

Identifies the FontFamily dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontFamilyProperty
Public Shared ReadOnly FontFamilyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontFamily dependency property.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.FontSizeProperty Field

CircularPointerLabelFontSizeProperty Field

Identifies the FontSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontSizeProperty
Public Shared ReadOnly FontSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontSize dependency property.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.FontStyleProperty Field

CircularPointerLabelFontStyleProperty Field

Identifies the FontStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontStyleProperty
Public Shared ReadOnly FontStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontStyle dependency property.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.FontWeightProperty Field

CircularPointerLabelFontWeightProperty Field

Identifies the FontWeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontWeightProperty
Public Shared ReadOnly FontWeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontWeight dependency property.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.ForegroundProperty Field

CircularPointerLabelForegroundProperty Field

Identifies the Foreground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundProperty
Public Shared ReadOnly ForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Foreground dependency property.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.RoundModeProperty Field

CircularPointerLabelRoundModeProperty Field

Identifies the RoundMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundModeProperty
Public Shared ReadOnly RoundModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundMode dependency property.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.TextFormatProperty Field

CircularPointerLabelTextFormatProperty Field

Identifies the TextFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextFormatProperty
Public Shared ReadOnly TextFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextFormat dependency property.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.TextOrientationProperty Field

CircularPointerLabelTextOrientationProperty Field

Identifies the TextOrientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextOrientationProperty
Public Shared ReadOnly TextOrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextOrientation dependency property.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerLabel.TextProperty Field

CircularPointerLabelTextProperty Field

Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

CircularPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker Class

Represents a marker pointer for use in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularPointerBase
ActiproSoftware.Windows.Controls.GaugeCircularPointerMarker

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularPointerMarker : CircularPointerBase
Public Class CircularPointerMarker
    Inherits CircularPointerBase

The CircularPointerMarker type exposes the following members.

Constructors
 | Name | Description
Public method | CircularPointerMarker | Initializes a new instance of the CircularPointerMarker class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Public property | MarkerType | Gets or sets the type of marker rendered. This is a dependency property.
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
MarkerTypeProperty | Identifies the MarkerType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker Constructor

Initializes a new instance of the CircularPointerMarker class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularPointerMarker()
Public Sub New
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker Properties

The CircularPointerMarker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Public property | MarkerType | Gets or sets the type of marker rendered. This is a dependency property.
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker.Geometry Property

CircularPointerMarkerGeometry Property

Gets or sets the custom geometry. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry Geometry { get; set; }
Public Property Geometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry. The default value is .
Remarks
This property is only used when MarkerType is set to PointerMarkerType.CustomGeometry.
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker.ImageSource Property

CircularPointerMarkerImageSource Property

Gets or sets the source of a custom image. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source. The default value is .
Remarks
This property is only used when MarkerType is set to PointerMarkerType.CustomImage.
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker.MarkerType Property

CircularPointerMarkerMarkerType Property

Gets or sets the type of marker rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointerMarkerType MarkerType { get; set; }
Public Property MarkerType As PointerMarkerType
    Get
    Set

Property Value

Type: PointerMarkerType
The type of marker rendered. The default value is PointerMarkerType.Diamond.
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker Methods

The CircularPointerMarker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker.OnRender Method

CircularPointerMarkerOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker Events

The CircularPointerMarker type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker Fields

The CircularPointerMarker type exposes the following members.

Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
MarkerTypeProperty | Identifies the MarkerType dependency property. This field is read-only.
Top
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker.GeometryProperty Field

CircularPointerMarkerGeometryProperty Field

Identifies the Geometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GeometryProperty
Public Shared ReadOnly GeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Geometry dependency property.
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker.ImageSourceProperty Field

CircularPointerMarkerImageSourceProperty Field

Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerMarker.MarkerTypeProperty Field

CircularPointerMarkerMarkerTypeProperty Field

Identifies the MarkerType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerTypeProperty
Public Shared ReadOnly MarkerTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerType dependency property.
See Also

Reference

CircularPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle Class

Represents a needle pointer for use in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularPointerBase
ActiproSoftware.Windows.Controls.GaugeCircularPointerNeedle

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularPointerNeedle : CircularPointerBase
Public Class CircularPointerNeedle
    Inherits CircularPointerBase

The CircularPointerNeedle type exposes the following members.

Constructors
 | Name | Description
Public method | CircularPointerNeedle | Initializes a new instance of the CircularPointerNeedle class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | NeedleType | Gets or sets the type of needle rendered. This is a dependency property.
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
NeedleTypeProperty | Identifies the NeedleType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle Constructor

Initializes a new instance of the CircularPointerNeedle class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularPointerNeedle()
Public Sub New
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle Properties

The CircularPointerNeedle type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | NeedleType | Gets or sets the type of needle rendered. This is a dependency property.
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property. (Inherited from CircularPointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularPointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property. (Inherited from CircularPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle.Geometry Property

CircularPointerNeedleGeometry Property

Gets or sets the custom geometry. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry Geometry { get; set; }
Public Property Geometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry. The default value is .
Remarks
This property is only used when NeedleType is set to PointerNeedleType.CustomGeometry.
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle.ImageSource Property

CircularPointerNeedleImageSource Property

Gets or sets the source of a custom image. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source. The default value is .
Remarks
This property is only used when NeedleType is set to PointerNeedleType.CustomImage.
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle.NeedleType Property

CircularPointerNeedleNeedleType Property

Gets or sets the type of needle rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointerNeedleType NeedleType { get; set; }
Public Property NeedleType As PointerNeedleType
    Get
    Set

Property Value

Type: PointerNeedleType
The type of the needle. The default value is PointerNeedleType.Rectangle
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle Methods

The CircularPointerNeedle type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle. (Inherited from CircularPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from CircularPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from CircularPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property. (Inherited from CircularPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle.OnRender Method

CircularPointerNeedleOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle Events

The CircularPointerNeedle type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle Fields

The CircularPointerNeedle type exposes the following members.

Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
NeedleTypeProperty | Identifies the NeedleType dependency property. This field is read-only.
Top
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle.GeometryProperty Field

CircularPointerNeedleGeometryProperty Field

Identifies the Geometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GeometryProperty
Public Shared ReadOnly GeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Geometry dependency property.
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle.ImageSourceProperty Field

CircularPointerNeedleImageSourceProperty Field

Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularPointerNeedle.NeedleTypeProperty Field

CircularPointerNeedleNeedleTypeProperty Field

Identifies the NeedleType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NeedleTypeProperty
Public Shared ReadOnly NeedleTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NeedleType dependency property.
See Also

Reference

CircularPointerNeedle Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange Class

Represents an element that renders a range in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesRangeBase
ActiproSoftware.Windows.Controls.GaugeCircularRange

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularRange : RangeBase
Public Class CircularRange
    Inherits RangeBase

The CircularRange type exposes the following members.

Constructors
 | Name | Description
Public method | CircularRange | Initializes a new instance of the CircularRange class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from RangeBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndExtent | Gets or sets the extent of the range at the EndValue. This is a dependency property.
Public property | EndValue | Gets or sets the end value of the range. This is a dependency property. (Inherited from RangeBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from RangeBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from RangeBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from RangeBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from RangeBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from RangeBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from RangeBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale.
Protected property | ScaleBarExtent | Gets the extent of the scale bar, which is inherited/set via an attached property on ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from RangeBase.)
Public property | ScalePlacement | Gets or sets the placement of the range relative to the scale. This is a dependency property. (Inherited from RangeBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale.
Public property | StartExtent | Gets or sets the extent of the range at the StartValue. This is a dependency property.
Public property | StartValue | Gets or sets the start value of the range. This is a dependency property. (Inherited from RangeBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndExtentProperty | Identifies the EndExtent dependency property. This field is read-only.
StartExtentProperty | Identifies the StartExtent dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange Constructor

Initializes a new instance of the CircularRange class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularRange()
Public Sub New
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange Properties

The CircularRange type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from RangeBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndExtent | Gets or sets the extent of the range at the EndValue. This is a dependency property.
Public property | EndValue | Gets or sets the end value of the range. This is a dependency property. (Inherited from RangeBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from RangeBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from RangeBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from RangeBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from RangeBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from RangeBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from RangeBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale.
Protected property | ScaleBarExtent | Gets the extent of the scale bar, which is inherited/set via an attached property on ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from RangeBase.)
Public property | ScalePlacement | Gets or sets the placement of the range relative to the scale. This is a dependency property. (Inherited from RangeBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale.
Public property | StartExtent | Gets or sets the extent of the range at the StartValue. This is a dependency property.
Public property | StartValue | Gets or sets the start value of the range. This is a dependency property. (Inherited from RangeBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.EndExtent Property

CircularRangeEndExtent Property

Gets or sets the extent of the range at the EndValue. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit EndExtent { get; set; }
Public Property EndExtent As Unit
    Get
    Set

Property Value

Type: Unit
The extent of the range at the EndValue. The default value is 5 pixels.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.Radius Property

CircularRangeRadius Property

Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double Radius { get; }
Protected ReadOnly Property Radius As Double
    Get

Property Value

Type: Double
The radius.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.ScaleBarExtent Property

CircularRangeScaleBarExtent Property

Gets the extent of the scale bar, which is inherited/set via an attached property on ScaleBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ScaleBarExtent { get; }
Protected ReadOnly Property ScaleBarExtent As Double
    Get

Property Value

Type: Double
The extent of the bar.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.StartAngle Property

CircularRangeStartAngle Property

Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double StartAngle { get; }
Protected ReadOnly Property StartAngle As Double
    Get

Property Value

Type: Double
The start angle.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.StartExtent Property

CircularRangeStartExtent Property

Gets or sets the extent of the range at the StartValue. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit StartExtent { get; set; }
Public Property StartExtent As Unit
    Get
    Set

Property Value

Type: Unit
The extent of the range at the StartValue. The default value is 5 pixels.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.SweepAngle Property

CircularRangeSweepAngle Property

Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double SweepAngle { get; }
Protected ReadOnly Property SweepAngle As Double
    Get

Property Value

Type: Double
The sweep angle.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange Methods

The CircularRange type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.CalculateAngle Method

CircularRangeCalculateAngle Method

Calculates an angle (not including the start angle) for the specified value.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double CalculateAngle(
    double value
)
Protected Function CalculateAngle (
    value As Double
) As Double

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: Double
The angle of the specified value, not including the start angle.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.OnRender Method

CircularRangeOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange Fields

The CircularRange type exposes the following members.

Fields
Name | Description
EndExtentProperty | Identifies the EndExtent dependency property. This field is read-only.
StartExtentProperty | Identifies the StartExtent dependency property. This field is read-only.
Top
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.EndExtentProperty Field

CircularRangeEndExtentProperty Field

Identifies the EndExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndExtentProperty
Public Shared ReadOnly EndExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndExtent dependency property.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRange.StartExtentProperty Field

CircularRangeStartExtentProperty Field

Identifies the StartExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartExtentProperty
Public Shared ReadOnly StartExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartExtent dependency property.
See Also

Reference

CircularRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRangeCollection Class

Represents a collection of CircularRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection CircularRange
System.Collections.ObjectModelObservableCollection CircularRange
ActiproSoftware.WindowsDeferrableObservableCollection CircularRange
ActiproSoftware.WindowsLogicalChildrenCollection CircularRange
ActiproSoftware.Windows.Controls.GaugeCircularRangeCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularRangeCollection : LogicalChildrenCollection<CircularRange>
Public Class CircularRangeCollection
    Inherits LogicalChildrenCollection(Of CircularRange)

The CircularRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CircularRangeCollection | Initializes a new instance of the CircularRangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularRange .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularRange .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularRange .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRangeCollection Constructor

Initializes a new instance of the CircularRangeCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularRangeCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

CircularRangeCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRangeCollection Properties

The CircularRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularRange .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

CircularRangeCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRangeCollection Methods

The CircularRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularRange .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

CircularRangeCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRangeCollection Events

The CircularRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularRange .)
Top
See Also

Reference

CircularRangeCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularRimType Enumeration

Specifies the types of rims supported by CircularGaugeBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CircularRimType
Public Enumeration CircularRimType
Members
Member name | Value | Description
CircularGearRim | 0 | Indicates a circular rim with gear shaped rim.
CircularMediumRim | 1 | Indicates a circular rim with medium rim.
CircularNoRimMediumGradient | 2 | Indicates a circular rim with no rim and medium gradient effect.
CircularNoRimSideGradient | 3 | Indicates a circulr rim with no rim and side gradient effect.
CircularThickRim | 4 | Indicates a circular rim with thick rim.
CircularThinRim | 5 | Indicates a circular rim with thin rim.
ClippedRectangle | 6 | Indicates a clipped rectangle rim.
CustomRimGeometry | 7 | Indicates the circular rim will be based on a custom geometry.
CustomRimImage | 8 | Indicates the circular rim will be based on a custom image.
FanClippedRectangle | 9 | Indicates a fan shaped rim with a clipped rectangular rim.
FanRoundedRectangle | 10 | Indicates a fan shaped rim with a rectangular rim.
None | 11 | Indicates that no rim will be rendered.
RoundedRectangle | 12 | Indicates a rounded rectangle rim.
SemicircularClippedRectangle | 13 | Indicates semi-circular rim with a clipped rectangular rim.
SemicircularRoundedRectangle | 14 | Indicates a semi-circular rim with a rounded rectangular rim.
SemicircularThickRim | 15 | Indicates a semi-circular rim with a thick rim.
SemicircularThinRim | 16 | Indicates a semi-circular rim with a thin rim.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale Class

Represents a scale for use in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesScaleBase
ActiproSoftware.Windows.Controls.GaugeCircularScale

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularScale : ScaleBase
Public Class CircularScale
    Inherits ScaleBase

The CircularScale type exposes the following members.

Constructors
 | Name | Description
Public method | CircularScale | Initializes a new instance of the CircularScale class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from ScaleBase.)
Public property | BarExtent | Gets or sets the extent of the bar. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from ScaleBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsBarVisible | Gets or sets a value indicating whether the scale renders an associated bar. This is a dependency property. (Inherited from ScaleBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | Radius | Gets or sets the radius of the scale. This is a dependency property.
Public property | StartAngle | Gets or sets the start angle of the scale. This is a dependency property.
Public property | SweepAngle | Gets or sets the sweep angle of the scale. This is a dependency property.
Public property | TickSets | Gets the tick-set elements within the scale.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetRadius | Gets the value of the RadiusProperty attached property for a specified object.
 | GetStartAngle | Gets the value of the StartAngleProperty attached property for a specified object.
 | GetSweepAngle | Gets the value of the SweepAngleProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate ScaleBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from ScaleBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetRadius | Sets the value of the RadiusProperty attached property to a specified object.
 | SetStartAngle | Sets the value of the StartAngleProperty attached property to a specified object.
 | SetSweepAngle | Sets the value of the SweepAngleProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
SweepAngleProperty | Identifies the SweepAngle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale Constructor

Initializes a new instance of the CircularScale class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularScale()
Public Sub New
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale Properties

The CircularScale type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from ScaleBase.)
Public property | BarExtent | Gets or sets the extent of the bar. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from ScaleBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsBarVisible | Gets or sets a value indicating whether the scale renders an associated bar. This is a dependency property. (Inherited from ScaleBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | Radius | Gets or sets the radius of the scale. This is a dependency property.
Public property | StartAngle | Gets or sets the start angle of the scale. This is a dependency property.
Public property | SweepAngle | Gets or sets the sweep angle of the scale. This is a dependency property.
Public property | TickSets | Gets the tick-set elements within the scale.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.LogicalChildren Property

CircularScaleLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.Radius Property

CircularScaleRadius Property

Gets or sets the radius of the scale. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit Radius { get; set; }
Public Property Radius As Unit
    Get
    Set

Property Value

Type: Unit
The radius, which should be greater than 0. The default value is 30.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.StartAngle Property

CircularScaleStartAngle Property

Gets or sets the start angle of the scale. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set

Property Value

Type: Double
The start angle, which should be between 0 and 360. The default value is 0.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.SweepAngle Property

CircularScaleSweepAngle Property

Gets or sets the sweep angle of the scale. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SweepAngle { get; set; }
Public Property SweepAngle As Double
    Get
    Set

Property Value

Type: Double
The sweep angle, which should be between 0 and 360. The default value is 360
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.TickSets Property

CircularScaleTickSets Property

Gets the tick-set elements within the scale.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickSetCollection TickSets { get; }
Public ReadOnly Property TickSets As CircularTickSetCollection
    Get

Property Value

Type: CircularTickSetCollection
The tick-sets.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale Methods

The CircularScale type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetRadius | Gets the value of the RadiusProperty attached property for a specified object.
 | GetStartAngle | Gets the value of the StartAngleProperty attached property for a specified object.
 | GetSweepAngle | Gets the value of the SweepAngleProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate ScaleBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from ScaleBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetRadius | Sets the value of the RadiusProperty attached property to a specified object.
 | SetStartAngle | Sets the value of the StartAngleProperty attached property to a specified object.
 | SetSweepAngle | Sets the value of the SweepAngleProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.ArrangeOverride Method

CircularScaleArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.GetRadius Method

CircularScaleGetRadius Method

Gets the value of the RadiusProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit GetRadius(
    DependencyObject obj
)
Public Shared Function GetRadius (
    obj As DependencyObject
) As Unit

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Unit
The radius.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.GetStartAngle Method

CircularScaleGetStartAngle Method

Gets the value of the StartAngleProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetStartAngle(
    DependencyObject obj
)
Public Shared Function GetStartAngle (
    obj As DependencyObject
) As Double

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Double
The start angle.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.GetSweepAngle Method

CircularScaleGetSweepAngle Method

Gets the value of the SweepAngleProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetSweepAngle(
    DependencyObject obj
)
Public Shared Function GetSweepAngle (
    obj As DependencyObject
) As Double

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Double
The sweep angle.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.MeasureOverride Method

CircularScaleMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.OnRender Method

CircularScaleOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.SetRadius Method

CircularScaleSetRadius Method

Sets the value of the RadiusProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetRadius(
    DependencyObject obj,
    Unit value
)
Public Shared Sub SetRadius (
    obj As DependencyObject,
    value As Unit
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.WindowsUnit
The radius.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.SetStartAngle Method

CircularScaleSetStartAngle Method

Sets the value of the StartAngleProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetStartAngle(
    DependencyObject obj,
    double value
)
Public Shared Sub SetStartAngle (
    obj As DependencyObject,
    value As Double
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemDouble
The start angle.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.SetSweepAngle Method

CircularScaleSetSweepAngle Method

Sets the value of the SweepAngleProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetSweepAngle(
    DependencyObject obj,
    double value
)
Public Shared Sub SetSweepAngle (
    obj As DependencyObject,
    value As Double
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemDouble
The sweep angle.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale Fields

The CircularScale type exposes the following members.

Fields
Name | Description
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
SweepAngleProperty | Identifies the SweepAngle dependency property. This field is read-only.
Top
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.RadiusProperty Field

CircularScaleRadiusProperty Field

Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.StartAngleProperty Field

CircularScaleStartAngleProperty Field

Identifies the StartAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartAngleProperty
Public Shared ReadOnly StartAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartAngle dependency property.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScale.SweepAngleProperty Field

CircularScaleSweepAngleProperty Field

Identifies the SweepAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SweepAngleProperty
Public Shared ReadOnly SweepAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SweepAngle dependency property.
See Also

Reference

CircularScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScaleCollection Class

Represents a collection of CircularScale objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection CircularScale
System.Collections.ObjectModelObservableCollection CircularScale
ActiproSoftware.WindowsDeferrableObservableCollection CircularScale
ActiproSoftware.WindowsLogicalChildrenCollection CircularScale
ActiproSoftware.Windows.Controls.GaugeCircularScaleCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularScaleCollection : LogicalChildrenCollection<CircularScale>
Public Class CircularScaleCollection
    Inherits LogicalChildrenCollection(Of CircularScale)

The CircularScaleCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CircularScaleCollection | Initializes a new instance of the CircularScaleCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularScale .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularScale .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularScale .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularScale .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularScale .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularScale .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularScale .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularScale .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularScale .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularScale .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularScale .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularScale .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularScale .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularScale .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularScale .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularScale .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularScale .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularScale .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScaleCollection Constructor

Initializes a new instance of the CircularScaleCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularScaleCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

CircularScaleCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScaleCollection Properties

The CircularScaleCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularScale .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularScale .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularScale .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

CircularScaleCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScaleCollection Methods

The CircularScaleCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularScale .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularScale .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularScale .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularScale .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularScale .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularScale .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularScale .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularScale .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularScale .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularScale .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularScale .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularScale .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularScale .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

CircularScaleCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularScaleCollection Events

The CircularScaleCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularScale .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularScale .)
Top
See Also

Reference

CircularScaleCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickCollection Class

Represents a collection of CircularTickBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection CircularTickBase
System.Collections.ObjectModelObservableCollection CircularTickBase
ActiproSoftware.WindowsDeferrableObservableCollection CircularTickBase
ActiproSoftware.WindowsLogicalChildrenCollection CircularTickBase
ActiproSoftware.Windows.Controls.GaugeCircularTickCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularTickCollection : LogicalChildrenCollection<CircularTickBase>
Public Class CircularTickCollection
    Inherits LogicalChildrenCollection(Of CircularTickBase)

The CircularTickCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CircularTickCollection | Initializes a new instance of the CircularTickCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularTickBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularTickBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularTickBase .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularTickBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularTickBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularTickBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularTickBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularTickBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularTickBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularTickBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularTickBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularTickBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularTickBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularTickBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularTickBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularTickBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularTickBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularTickBase .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickCollection Constructor

Initializes a new instance of the CircularTickCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

CircularTickCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickCollection Properties

The CircularTickCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularTickBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularTickBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularTickBase .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

CircularTickCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickCollection Methods

The CircularTickCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularTickBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularTickBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularTickBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularTickBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularTickBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularTickBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularTickBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularTickBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularTickBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularTickBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularTickBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularTickBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularTickBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

CircularTickCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickCollection Events

The CircularTickCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularTickBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularTickBase .)
Top
See Also

Reference

CircularTickCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom Class

Represents an element that renders a custom tick label in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickLabelBase
ActiproSoftware.Windows.Controls.GaugeCircularTickLabelCustom

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularTickLabelCustom : CircularTickLabelBase
Public Class CircularTickLabelCustom
    Inherits CircularTickLabelBase

The CircularTickLabelCustom type exposes the following members.

Constructors
 | Name | Description
Public method | CircularTickLabelCustom | Initializes a new instance of the CircularTickLabelCustom class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | Text | Gets or sets the text that should be rendered at the specified Value. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | Value | Gets or sets the value where the custom tick label should be placed. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides CircularTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value. (Overrides CircularTickLabelBaseGetValueText(Double).)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
TextProperty | Identifies the Text dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom Constructor

Initializes a new instance of the CircularTickLabelCustom class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickLabelCustom()
Public Sub New
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom Properties

The CircularTickLabelCustom type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | Text | Gets or sets the text that should be rendered at the specified Value. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | Value | Gets or sets the value where the custom tick label should be placed. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom.Text Property

CircularTickLabelCustomText Property

Gets or sets the text that should be rendered at the specified Value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text that should be rendered. The default value is .
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom.Value Property

CircularTickLabelCustomValue Property

Gets or sets the value where the custom tick label should be placed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value where the custom tick label should be placed. The default value is 0.
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom Methods

The CircularTickLabelCustom type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides CircularTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value. (Overrides CircularTickLabelBaseGetValueText(Double).)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom.GetValues Method

CircularTickLabelCustomGetValues Method

Gets the values to be rendered by this tick label element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick label element.
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom.GetValueText Method

CircularTickLabelCustomGetValueText Method

Gets the string representation of the specified value.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetValueText(
    double value
)
Protected Overrides Function GetValueText (
    value As Double
) As String

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom Fields

The CircularTickLabelCustom type exposes the following members.

Fields
Name | Description
TextProperty | Identifies the Text dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom.TextProperty Field

CircularTickLabelCustomTextProperty Field

Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelCustom.ValueProperty Field

CircularTickLabelCustomValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

CircularTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor Class

Represents an element that renders major tick labels in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickLabelBase
ActiproSoftware.Windows.Controls.GaugeCircularTickLabelMajor

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularTickLabelMajor : CircularTickLabelBase
Public Class CircularTickLabelMajor
    Inherits CircularTickLabelBase

The CircularTickLabelMajor type exposes the following members.

Constructors
 | Name | Description
Public method | CircularTickLabelMajor | Initializes a new instance of the CircularTickLabelMajor class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Public property | MaximumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinimumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides CircularTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode. (Inherited from CircularTickLabelBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
MaximumTickVisibilityProperty | Identifies the MaximumTickVisibility dependency property. This field is read-only.
MinimumTickVisibilityProperty | Identifies the MinimumTickVisibility dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor Constructor

Initializes a new instance of the CircularTickLabelMajor class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickLabelMajor()
Public Sub New
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor Properties

The CircularTickLabelMajor type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Public property | MaximumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinimumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.EndValue Property

CircularTickLabelMajorEndValue Property

Gets or sets the last value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndValue { get; set; }
Public Property EndValue As Double
    Get
    Set

Property Value

Type: Double
The last value that should be rendered. The default value is Double.NaN.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.MaximumTickVisibility Property

CircularTickLabelMajorMaximumTickVisibility Property

Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickVisibility MaximumTickVisibility { get; set; }
Public Property MaximumTickVisibility As TickVisibility
    Get
    Set

Property Value

Type: TickVisibility
The visibility of the maximum tick. The default value is Always.
Remarks
The SkipValues property takes precedence over this property.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.MinimumTickVisibility Property

CircularTickLabelMajorMinimumTickVisibility Property

Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickVisibility MinimumTickVisibility { get; set; }
Public Property MinimumTickVisibility As TickVisibility
    Get
    Set

Property Value

Type: TickVisibility
The visibility of the minimum tick. The default value is Always.
Remarks
The SkipValues property takes precedence over this property.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.SkipValues Property

CircularTickLabelMajorSkipValues Property

Gets or sets the values that should not be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleCollection SkipValues { get; set; }
Public Property SkipValues As DoubleCollection
    Get
    Set

Property Value

Type: DoubleCollection
The values that should not be rendered. The default value is .
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.StartValue Property

CircularTickLabelMajorStartValue Property

Gets or sets the first value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartValue { get; set; }
Public Property StartValue As Double
    Get
    Set

Property Value

Type: Double
The first value that should be rendered. The default value is Double.NaN.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor Methods

The CircularTickLabelMajor type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides CircularTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode. (Inherited from CircularTickLabelBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.GetValues Method

CircularTickLabelMajorGetValues Method

Gets the values to be rendered by this tick label element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick label element.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor Fields

The CircularTickLabelMajor type exposes the following members.

Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
MaximumTickVisibilityProperty | Identifies the MaximumTickVisibility dependency property. This field is read-only.
MinimumTickVisibilityProperty | Identifies the MinimumTickVisibility dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.EndValueProperty Field

CircularTickLabelMajorEndValueProperty Field

Identifies the EndValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndValueProperty
Public Shared ReadOnly EndValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndValue dependency property.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.MaximumTickVisibilityProperty Field

CircularTickLabelMajorMaximumTickVisibilityProperty Field

Identifies the MaximumTickVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumTickVisibilityProperty
Public Shared ReadOnly MaximumTickVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaximumTickVisibility dependency property.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.MinimumTickVisibilityProperty Field

CircularTickLabelMajorMinimumTickVisibilityProperty Field

Identifies the MinimumTickVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumTickVisibilityProperty
Public Shared ReadOnly MinimumTickVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinimumTickVisibility dependency property.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.SkipValuesProperty Field

CircularTickLabelMajorSkipValuesProperty Field

Identifies the SkipValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkipValuesProperty
Public Shared ReadOnly SkipValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkipValues dependency property.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMajor.StartValueProperty Field

CircularTickLabelMajorStartValueProperty Field

Identifies the StartValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartValueProperty
Public Shared ReadOnly StartValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartValue dependency property.
See Also

Reference

CircularTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor Class

Represents an element that renders minor tick labels in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickLabelBase
ActiproSoftware.Windows.Controls.GaugeCircularTickLabelMinor

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularTickLabelMinor : CircularTickLabelBase
Public Class CircularTickLabelMinor
    Inherits CircularTickLabelBase

The CircularTickLabelMinor type exposes the following members.

Constructors
 | Name | Description
Public method | CircularTickLabelMinor | Initializes a new instance of the CircularTickLabelMinor class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides CircularTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode. (Inherited from CircularTickLabelBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor Constructor

Initializes a new instance of the CircularTickLabelMinor class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickLabelMinor()
Public Sub New
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor Properties

The CircularTickLabelMinor type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from CircularTickLabelBase.)
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property. (Inherited from CircularTickLabelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor.EndValue Property

CircularTickLabelMinorEndValue Property

Gets or sets the last value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndValue { get; set; }
Public Property EndValue As Double
    Get
    Set

Property Value

Type: Double
The last value that should be rendered. The default value is Double.NaN.
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor.SkipValues Property

CircularTickLabelMinorSkipValues Property

Gets or sets the values that should not be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleCollection SkipValues { get; set; }
Public Property SkipValues As DoubleCollection
    Get
    Set

Property Value

Type: DoubleCollection
The values that should not be rendered. The default value is .
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor.StartValue Property

CircularTickLabelMinorStartValue Property

Gets or sets the first value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartValue { get; set; }
Public Property StartValue As Double
    Get
    Set

Property Value

Type: Double
The first value that should be rendered. The default value is Double.NaN.
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor Methods

The CircularTickLabelMinor type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides CircularTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode. (Inherited from CircularTickLabelBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor.GetValues Method

CircularTickLabelMinorGetValues Method

Gets the values to be rendered by this tick label element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick label element.
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor Fields

The CircularTickLabelMinor type exposes the following members.

Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor.EndValueProperty Field

CircularTickLabelMinorEndValueProperty Field

Identifies the EndValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndValueProperty
Public Shared ReadOnly EndValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndValue dependency property.
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor.SkipValuesProperty Field

CircularTickLabelMinorSkipValuesProperty Field

Identifies the SkipValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkipValuesProperty
Public Shared ReadOnly SkipValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkipValues dependency property.
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickLabelMinor.StartValueProperty Field

CircularTickLabelMinorStartValueProperty Field

Identifies the StartValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartValueProperty
Public Shared ReadOnly StartValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartValue dependency property.
See Also

Reference

CircularTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkCustom Class

Represents an element that renders a custom tick mark in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickMarkBase
ActiproSoftware.Windows.Controls.GaugeCircularTickMarkCustom

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularTickMarkCustom : CircularTickMarkBase
Public Class CircularTickMarkCustom
    Inherits CircularTickMarkBase

The CircularTickMarkCustom type exposes the following members.

Constructors
 | Name | Description
Public method | CircularTickMarkCustom | Initializes a new instance of the CircularTickMarkCustom class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | Value | Gets or sets the value where the custom tick mark should be placed. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides CircularTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkCustom Constructor

Initializes a new instance of the CircularTickMarkCustom class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickMarkCustom()
Public Sub New
See Also

Reference

CircularTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkCustom Properties

The CircularTickMarkCustom type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | Value | Gets or sets the value where the custom tick mark should be placed. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkCustom.Value Property

CircularTickMarkCustomValue Property

Gets or sets the value where the custom tick mark should be placed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value where the custom tick mark should be placed. The default value is 0.
See Also

Reference

CircularTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkCustom Methods

The CircularTickMarkCustom type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides CircularTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkCustom.GetValues Method

CircularTickMarkCustomGetValues Method

Gets the values to be rendered by this tick mark element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick mark element.
See Also

Reference

CircularTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkCustom Fields

The CircularTickMarkCustom type exposes the following members.

Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

CircularTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkCustom.ValueProperty Field

CircularTickMarkCustomValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

CircularTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor Class

Represents an element that renders major tick marks in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickMarkBase
ActiproSoftware.Windows.Controls.GaugeCircularTickMarkMajor

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularTickMarkMajor : CircularTickMarkBase
Public Class CircularTickMarkMajor
    Inherits CircularTickMarkBase

The CircularTickMarkMajor type exposes the following members.

Constructors
 | Name | Description
Public method | CircularTickMarkMajor | Initializes a new instance of the CircularTickMarkMajor class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Public property | MaximumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinimumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides CircularTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
MaximumTickVisibilityProperty | Identifies the MaximumTickVisibility dependency property. This field is read-only.
MinimumTickVisibilityProperty | Identifies the MinimumTickVisibility dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor Constructor

Initializes a new instance of the CircularTickMarkMajor class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickMarkMajor()
Public Sub New
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor Properties

The CircularTickMarkMajor type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Public property | MaximumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinimumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.EndValue Property

CircularTickMarkMajorEndValue Property

Gets or sets the last value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndValue { get; set; }
Public Property EndValue As Double
    Get
    Set

Property Value

Type: Double
The last value that should be rendered. The default value is Double.NaN.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.MaximumTickVisibility Property

CircularTickMarkMajorMaximumTickVisibility Property

Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickVisibility MaximumTickVisibility { get; set; }
Public Property MaximumTickVisibility As TickVisibility
    Get
    Set

Property Value

Type: TickVisibility
The visibility of the maximum tick. The default value is Always.
Remarks
The SkipValues property takes precedence over this property.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.MinimumTickVisibility Property

CircularTickMarkMajorMinimumTickVisibility Property

Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickVisibility MinimumTickVisibility { get; set; }
Public Property MinimumTickVisibility As TickVisibility
    Get
    Set

Property Value

Type: TickVisibility
The visibility of the minimum tick. The default value is Always.
Remarks
The SkipValues property takes precedence over this property.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.SkipValues Property

CircularTickMarkMajorSkipValues Property

Gets or sets the values that should not be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleCollection SkipValues { get; set; }
Public Property SkipValues As DoubleCollection
    Get
    Set

Property Value

Type: DoubleCollection
The values that should not be rendered. The default value is .
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.StartValue Property

CircularTickMarkMajorStartValue Property

Gets or sets the first value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartValue { get; set; }
Public Property StartValue As Double
    Get
    Set

Property Value

Type: Double
The first value that should be rendered. The default value is Double.NaN.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor Methods

The CircularTickMarkMajor type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides CircularTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.GetValues Method

CircularTickMarkMajorGetValues Method

Gets the values to be rendered by this tick mark element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick mark element.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor Fields

The CircularTickMarkMajor type exposes the following members.

Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
MaximumTickVisibilityProperty | Identifies the MaximumTickVisibility dependency property. This field is read-only.
MinimumTickVisibilityProperty | Identifies the MinimumTickVisibility dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.EndValueProperty Field

CircularTickMarkMajorEndValueProperty Field

Identifies the EndValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndValueProperty
Public Shared ReadOnly EndValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndValue dependency property.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.MaximumTickVisibilityProperty Field

CircularTickMarkMajorMaximumTickVisibilityProperty Field

Identifies the MaximumTickVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumTickVisibilityProperty
Public Shared ReadOnly MaximumTickVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaximumTickVisibility dependency property.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.MinimumTickVisibilityProperty Field

CircularTickMarkMajorMinimumTickVisibilityProperty Field

Identifies the MinimumTickVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumTickVisibilityProperty
Public Shared ReadOnly MinimumTickVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinimumTickVisibility dependency property.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.SkipValuesProperty Field

CircularTickMarkMajorSkipValuesProperty Field

Identifies the SkipValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkipValuesProperty
Public Shared ReadOnly SkipValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkipValues dependency property.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMajor.StartValueProperty Field

CircularTickMarkMajorStartValueProperty Field

Identifies the StartValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartValueProperty
Public Shared ReadOnly StartValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartValue dependency property.
See Also

Reference

CircularTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor Class

Represents an element that renders minor tick marks in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickMarkBase
ActiproSoftware.Windows.Controls.GaugeCircularTickMarkMinor

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularTickMarkMinor : CircularTickMarkBase
Public Class CircularTickMarkMinor
    Inherits CircularTickMarkBase

The CircularTickMarkMinor type exposes the following members.

Constructors
 | Name | Description
Public method | CircularTickMarkMinor | Initializes a new instance of the CircularTickMarkMinor class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides CircularTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor Constructor

Initializes a new instance of the CircularTickMarkMinor class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickMarkMinor()
Public Sub New
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor Properties

The CircularTickMarkMinor type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from CircularTickMarkBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor.EndValue Property

CircularTickMarkMinorEndValue Property

Gets or sets the last value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndValue { get; set; }
Public Property EndValue As Double
    Get
    Set

Property Value

Type: Double
The last value that should be rendered. The default value is Double.NaN.
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor.SkipValues Property

CircularTickMarkMinorSkipValues Property

Gets or sets the values that should not be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleCollection SkipValues { get; set; }
Public Property SkipValues As DoubleCollection
    Get
    Set

Property Value

Type: DoubleCollection
The values that should not be rendered. The default value is .
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor.StartValue Property

CircularTickMarkMinorStartValue Property

Gets or sets the first value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartValue { get; set; }
Public Property StartValue As Double
    Get
    Set

Property Value

Type: Double
The first value that should be rendered. The default value is Double.NaN.
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor Methods

The CircularTickMarkMinor type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides CircularTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from CircularTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor.GetValues Method

CircularTickMarkMinorGetValues Method

Gets the values to be rendered by this tick mark element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick mark element.
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor Fields

The CircularTickMarkMinor type exposes the following members.

Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor.EndValueProperty Field

CircularTickMarkMinorEndValueProperty Field

Identifies the EndValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndValueProperty
Public Shared ReadOnly EndValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndValue dependency property.
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor.SkipValuesProperty Field

CircularTickMarkMinorSkipValuesProperty Field

Identifies the SkipValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkipValuesProperty
Public Shared ReadOnly SkipValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkipValues dependency property.
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickMarkMinor.StartValueProperty Field

CircularTickMarkMinorStartValueProperty Field

Identifies the StartValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartValueProperty
Public Shared ReadOnly StartValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartValue dependency property.
See Also

Reference

CircularTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet Class

Represents a tick-set used in a CircularGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickSetBase
ActiproSoftware.Windows.Controls.GaugeCircularTickSet

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularTickSet : TickSetBase
Public Class CircularTickSet
    Inherits TickSetBase

The CircularTickSet type exposes the following members.

Constructors
 | Name | Description
Public method | CircularTickSet | Initializes a new instance of the CircularTickSet class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickSetBase.)
Public property | IsLogarithmic | Gets or sets a value indicating whether this instance uses a logarithmic scale. This is a dependency property. (Inherited from TickSetBase.)
Public property | IsReversed | Gets or sets a value indicating whether this instance is reversed. This is a dependency property. (Inherited from TickSetBase.)
Public property | LogarithmicBase | Gets or sets the base of the logarithm used when IsLogarithmic is set to true. This is a dependency property. (Inherited from TickSetBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickSetBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickSetBase.)
Public property | Maximum | Gets or sets the maximum value. This is a dependency property. (Inherited from TickSetBase.)
Public property | Minimum | Gets or sets the minimum value. This is a dependency property. (Inherited from TickSetBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickSetBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickSetBase.)
Public property | Pointers | Gets the pointer elements within the tick-set.
Public property | Ranges | Gets the range elements within the tick-set.
Public property | Ticks | Gets the tick mark and label elements within the tick-set.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet Constructor

Initializes a new instance of the CircularTickSet class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickSet()
Public Sub New
See Also

Reference

CircularTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet Properties

The CircularTickSet type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickSetBase.)
Public property | IsLogarithmic | Gets or sets a value indicating whether this instance uses a logarithmic scale. This is a dependency property. (Inherited from TickSetBase.)
Public property | IsReversed | Gets or sets a value indicating whether this instance is reversed. This is a dependency property. (Inherited from TickSetBase.)
Public property | LogarithmicBase | Gets or sets the base of the logarithm used when IsLogarithmic is set to true. This is a dependency property. (Inherited from TickSetBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickSetBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickSetBase.)
Public property | Maximum | Gets or sets the maximum value. This is a dependency property. (Inherited from TickSetBase.)
Public property | Minimum | Gets or sets the minimum value. This is a dependency property. (Inherited from TickSetBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickSetBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickSetBase.)
Public property | Pointers | Gets the pointer elements within the tick-set.
Public property | Ranges | Gets the range elements within the tick-set.
Public property | Ticks | Gets the tick mark and label elements within the tick-set.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet.LogicalChildren Property

CircularTickSetLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

CircularTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet.Pointers Property

CircularTickSetPointers Property

Gets the pointer elements within the tick-set.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularPointerCollection Pointers { get; }
Public ReadOnly Property Pointers As CircularPointerCollection
    Get

Property Value

Type: CircularPointerCollection
The pointers.
See Also

Reference

CircularTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet.Ranges Property

CircularTickSetRanges Property

Gets the range elements within the tick-set.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularRangeCollection Ranges { get; }
Public ReadOnly Property Ranges As CircularRangeCollection
    Get

Property Value

Type: CircularRangeCollection
The ranges.
See Also

Reference

CircularTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet.Ticks Property

CircularTickSetTicks Property

Gets the tick mark and label elements within the tick-set.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickCollection Ticks { get; }
Public ReadOnly Property Ticks As CircularTickCollection
    Get

Property Value

Type: CircularTickCollection
The tick marks and labels.
See Also

Reference

CircularTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet Methods

The CircularTickSet type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet.ArrangeOverride Method

CircularTickSetArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

CircularTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSet.MeasureOverride Method

CircularTickSetMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

CircularTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSetCollection Class

Represents a collection of CircularTickSet objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection CircularTickSet
System.Collections.ObjectModelObservableCollection CircularTickSet
ActiproSoftware.WindowsDeferrableObservableCollection CircularTickSet
ActiproSoftware.WindowsLogicalChildrenCollection CircularTickSet
ActiproSoftware.Windows.Controls.GaugeCircularTickSetCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CircularTickSetCollection : LogicalChildrenCollection<CircularTickSet>
Public Class CircularTickSetCollection
    Inherits LogicalChildrenCollection(Of CircularTickSet)

The CircularTickSetCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CircularTickSetCollection | Initializes a new instance of the CircularTickSetCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularTickSet .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularTickSet .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularTickSet .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularTickSet .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularTickSet .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularTickSet .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularTickSet .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularTickSet .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularTickSet .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularTickSet .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularTickSet .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularTickSet .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularTickSet .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularTickSet .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularTickSet .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularTickSet .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularTickSet .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularTickSet .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSetCollection Constructor

Initializes a new instance of the CircularTickSetCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularTickSetCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

CircularTickSetCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSetCollection Properties

The CircularTickSetCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CircularTickSet .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CircularTickSet .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CircularTickSet .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

CircularTickSetCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSetCollection Methods

The CircularTickSetCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CircularTickSet .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CircularTickSet .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CircularTickSet .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CircularTickSet .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CircularTickSet .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CircularTickSet .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CircularTickSet .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CircularTickSet .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CircularTickSet .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularTickSet .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CircularTickSet .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CircularTickSet .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CircularTickSet .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

CircularTickSetCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CircularTickSetCollection Events

The CircularTickSetCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CircularTickSet .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CircularTickSet .)
Top
See Also

Reference

CircularTickSetCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


CoordinateOrigin Enumeration

Specifies the origin point for use with x/y coordinates.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CoordinateOrigin
Public Enumeration CoordinateOrigin
Members
Member name | Value | Description
Center | 0 | Indicates that the center point will be used at the origin.
TopLeft | 1 | Indicates that the top-left point will be used at the origin.
TopRight | 2 | Indicates that the top-right point will be used at the origin.
BottomLeft | 3 | Indicates that the bottom-left point will be used at the origin.
BottomRight | 4 | Indicates that the bottom-right point will be used at the origin.
CenterTop | 5 | Indicates that the center-top point will be used at the origin.
CenterBottom | 6 | Indicates that the center-bottom point will be used at the origin.
MiddleLeft | 7 | Indicates that the middle-left point will be used at the origin.
MiddleRight | 8 | Indicates that the middle-right point will be used at the origin.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalCharacterOverflowAlignment Enumeration

Specifies the various types digital character alignment when characters are overflowed.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DigitalCharacterOverflowAlignment
Public Enumeration DigitalCharacterOverflowAlignment
Members
Member name | Value | Description
Left | 0 | Indicates the characters on the left side of the string will be displayed.
Right | 1 | Indicates the characters on the right side of the string will be displayed.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalCharacterScrollState Enumeration

Specifies the various directions that the digital characters can be scrolled.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DigitalCharacterScrollState
Public Enumeration DigitalCharacterScrollState
Members
Member name | Value | Description
Left | 0 | Indicates the characters will scroll to the left.
None | 1 | Indicates the characters will not scroll.
Right | 2 | Indicates the characters will scroll to the right.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalCharacterType Enumeration

Specifies the various types of digital characters.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DigitalCharacterType
Public Enumeration DigitalCharacterType
Members
Member name | Value | Description
Segment14Normal | 0 | Indicates a 14-segment digital digital character with line segments.
Segment7Normal | 1 | Indicates a 7-segment digital character with line segments.
Segment7Trapezoid | 2 | Indicates a 7-segment digital character with trapezoid segments.
DotMatrix5By7Ellipse | 3 | Indicates a 5 by 7 ellipse dot matrix characters.
DotMatrix5By7Rectangle | 4 | Indicates a 5 by 7 rectangle dot matrix characters.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge Class

Represents a digital gauge control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesRectangularGaugeBase
ActiproSoftware.Windows.Controls.GaugeDigitalGauge

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DigitalGauge : RectangularGaugeBase
Public Class DigitalGauge
    Inherits RectangularGaugeBase

The DigitalGauge type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalGauge | Initializes a new instance of the DigitalGauge class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundSizeRatio | Gets or sets the size of the frame background as a ratio of the ActualWidth and ActualHeight properties. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BlinkInterval | Gets or sets the interval used when LedState is set to Blinking. This is a dependency property.
Public property | CharacterCasing | Gets or sets the character casing. This is a dependency property.
Public property | CharacterCount | Gets or sets the number of characters displayed. This is a dependency property.
Public property | CharacterHeight | Gets or sets the height of the characters. This is a dependency property.
Public property | CharacterOverflowAlignment | Gets or sets the alignment of the characters when the text is longer than what can be displayed. This is a dependency property.
Public property | CharacterPadding | Gets or sets the padding of the characters displayed. This is a dependency property.
Public property | CharacterSegmentThickness | Gets or sets the thickness of the character segments (not used by all character types). This is a dependency property.
Public property | CharacterSpacing | Gets or sets the spacing between characters. This is a dependency property.
Public property | CharacterType | Gets or sets the type of the characters displayed. This is a dependency property.
Public property | CharacterWidthRatio | Gets or sets the width of the characters as a ratio of the CharacterHeight. This is a dependency property.
Public property | DimmedBrush | Gets or sets the dimmed brush, which is used to render the unlit character segments. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Foreground | Gets or sets the foreground brush, which is used to render the character segments. This is a dependency property.
Protected property | FrameAngle | Gets the angle of the frame, which is used when rendering the background frame. (Inherited from RectangularGaugeBase.)
Public property | FrameType | Gets or sets the type of rectangular frame rendered in the background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Public property | LedOffOpacity | Gets or sets the opacity of the led lights when off. This is a dependency property.
Public property | LedOnOpacity | Gets or sets the opacity of the led lights when on. This is a dependency property.
Public property | LedState | Gets or sets the current state of the led lights. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides RectangularGaugeBaseLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | RefreshRate | Gets or sets the refresh rate, which indicates the minimum interval between updates to the value currently being displayed. This is a dependency property.
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | ScrollInterval | Gets or sets the interval used when scrolling characters. This is a dependency property.
Public property | ScrollState | Gets or sets the scroll state, which determines how and when the characters should be scrolled. This is a dependency property.
Public property | SkewAngleX | Gets or sets the skew angle along the X-axis. This is a dependency property.
Public property | SkewAngleY | Gets or sets the skew angle along the Y-axis. This is a dependency property.
Public property | TextAlignment | Gets or sets the alignment of the label text. This is a read-only dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | Value | Gets or sets the value displayed by the gauge. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides RectangularGaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides RectangularGaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from RectangularGaugeBase.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType property. (Inherited from RectangularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType property. (Inherited from RectangularGaugeBase.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from GaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BlinkIntervalProperty | Identifies the BlinkInterval dependency property. This field is read-only.
CharacterCasingProperty | Identifies the CharacterCasing dependency property. This field is read-only.
CharacterCountProperty | Identifies the CharacterCount dependency property. This field is read-only.
CharacterHeightProperty | Identifies the CharacterHeight dependency property. This field is read-only.
CharacterOverflowAlignmentProperty | Identifies the CharacterOverflowAlignment dependency property. This field is read-only.
CharacterPaddingProperty | Identifies the CharacterPadding dependency property. This field is read-only.
CharacterSegmentThicknessProperty | Identifies the CharacterSegmentThickness dependency property. This field is read-only.
CharacterSpacingProperty | Identifies the CharacterSpacing dependency property. This field is read-only.
CharacterTypeProperty | Identifies the CharacterType dependency property. This field is read-only.
CharacterWidthRatioProperty | Identifies the CharacterWidthRatio dependency property. This field is read-only.
DimmedBrushProperty | Identifies the DimmedBrush dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
LedOffOpacityProperty | Identifies the LedOffOpacity dependency property. This field is read-only.
LedOnOpacityProperty | Identifies the LedOnOpacity dependency property. This field is read-only.
LedStateProperty | Identifies the LedState dependency property. This field is read-only.
RefreshRateProperty | Identifies the RefreshRate dependency property. This field is read-only.
ScrollIntervalProperty | Identifies the ScrollInterval dependency property. This field is read-only.
ScrollStateProperty | Identifies the ScrollState dependency property. This field is read-only.
SkewAngleXProperty | Identifies the SkewAngleX dependency property. This field is read-only.
SkewAngleYProperty | Identifies the SkewAngleY dependency property. This field is read-only.
TextAlignmentProperty | Identifies the TextAlignment dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge Constructor

Initializes a new instance of the DigitalGauge class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DigitalGauge()
Public Sub New
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge Properties

The DigitalGauge type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundSizeRatio | Gets or sets the size of the frame background as a ratio of the ActualWidth and ActualHeight properties. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BlinkInterval | Gets or sets the interval used when LedState is set to Blinking. This is a dependency property.
Public property | CharacterCasing | Gets or sets the character casing. This is a dependency property.
Public property | CharacterCount | Gets or sets the number of characters displayed. This is a dependency property.
Public property | CharacterHeight | Gets or sets the height of the characters. This is a dependency property.
Public property | CharacterOverflowAlignment | Gets or sets the alignment of the characters when the text is longer than what can be displayed. This is a dependency property.
Public property | CharacterPadding | Gets or sets the padding of the characters displayed. This is a dependency property.
Public property | CharacterSegmentThickness | Gets or sets the thickness of the character segments (not used by all character types). This is a dependency property.
Public property | CharacterSpacing | Gets or sets the spacing between characters. This is a dependency property.
Public property | CharacterType | Gets or sets the type of the characters displayed. This is a dependency property.
Public property | CharacterWidthRatio | Gets or sets the width of the characters as a ratio of the CharacterHeight. This is a dependency property.
Public property | DimmedBrush | Gets or sets the dimmed brush, which is used to render the unlit character segments. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Foreground | Gets or sets the foreground brush, which is used to render the character segments. This is a dependency property.
Protected property | FrameAngle | Gets the angle of the frame, which is used when rendering the background frame. (Inherited from RectangularGaugeBase.)
Public property | FrameType | Gets or sets the type of rectangular frame rendered in the background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Public property | LedOffOpacity | Gets or sets the opacity of the led lights when off. This is a dependency property.
Public property | LedOnOpacity | Gets or sets the opacity of the led lights when on. This is a dependency property.
Public property | LedState | Gets or sets the current state of the led lights. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides RectangularGaugeBaseLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | RefreshRate | Gets or sets the refresh rate, which indicates the minimum interval between updates to the value currently being displayed. This is a dependency property.
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | ScrollInterval | Gets or sets the interval used when scrolling characters. This is a dependency property.
Public property | ScrollState | Gets or sets the scroll state, which determines how and when the characters should be scrolled. This is a dependency property.
Public property | SkewAngleX | Gets or sets the skew angle along the X-axis. This is a dependency property.
Public property | SkewAngleY | Gets or sets the skew angle along the Y-axis. This is a dependency property.
Public property | TextAlignment | Gets or sets the alignment of the label text. This is a read-only dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | Value | Gets or sets the value displayed by the gauge. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.BlinkInterval Property

DigitalGaugeBlinkInterval Property

Gets or sets the interval used when LedState is set to Blinking. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration BlinkInterval { get; set; }
Public Property BlinkInterval As Duration
    Get
    Set

Property Value

Type: Duration
The interval used when LedState is set to Blinking. The default value is 500 milliseconds.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterCasing Property

DigitalGaugeCharacterCasing Property

Gets or sets the character casing. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CharacterCasing CharacterCasing { get; set; }
Public Property CharacterCasing As CharacterCasing
    Get
    Set

Property Value

Type: CharacterCasing
The character casing. The default value is Upper.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterCount Property

DigitalGaugeCharacterCount Property

Gets or sets the number of characters displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CharacterCount { get; set; }
Public Property CharacterCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of characters displayed. The default value is 10.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterHeight Property

DigitalGaugeCharacterHeight Property

Gets or sets the height of the characters. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double CharacterHeight { get; set; }
Public Property CharacterHeight As Double
    Get
    Set

Property Value

Type: Double
The height of the characters. The default value is Double.NaN.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterOverflowAlignment Property

DigitalGaugeCharacterOverflowAlignment Property

Gets or sets the alignment of the characters when the text is longer than what can be displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DigitalCharacterOverflowAlignment CharacterOverflowAlignment { get; set; }
Public Property CharacterOverflowAlignment As DigitalCharacterOverflowAlignment
    Get
    Set

Property Value

Type: DigitalCharacterOverflowAlignment
The alignment of the characters when the text is longer than what can be displayed. The default value is DigitalCharacterOverflowAlignment.Left.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterPadding Property

DigitalGaugeCharacterPadding Property

Gets or sets the padding of the characters displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness CharacterPadding { get; set; }
Public Property CharacterPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The padding of the characters displayed. The default value is 0.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterSegmentThickness Property

DigitalGaugeCharacterSegmentThickness Property

Gets or sets the thickness of the character segments (not used by all character types). This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double CharacterSegmentThickness { get; set; }
Public Property CharacterSegmentThickness As Double
    Get
    Set

Property Value

Type: Double
The thickness of the character segments, or Double.NaN for an automatic thickness. The default value is Double.NaN.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterSpacing Property

DigitalGaugeCharacterSpacing Property

Gets or sets the spacing between characters. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double CharacterSpacing { get; set; }
Public Property CharacterSpacing As Double
    Get
    Set

Property Value

Type: Double
The spacing between characters. The default value is 5 pixels.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterType Property

DigitalGaugeCharacterType Property

Gets or sets the type of the characters displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DigitalCharacterType CharacterType { get; set; }
Public Property CharacterType As DigitalCharacterType
    Get
    Set

Property Value

Type: DigitalCharacterType
The type of the characters displayed. The default value is Segment14Normal
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterWidthRatio Property

DigitalGaugeCharacterWidthRatio Property

Gets or sets the width of the characters as a ratio of the CharacterHeight. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double CharacterWidthRatio { get; set; }
Public Property CharacterWidthRatio As Double
    Get
    Set

Property Value

Type: Double
The character width ratio. The default value is 0.4 (40%).
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.DimmedBrush Property

DigitalGaugeDimmedBrush Property

Gets or sets the dimmed brush, which is used to render the unlit character segments. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush DimmedBrush { get; set; }
Public Property DimmedBrush As Brush
    Get
    Set

Property Value

Type: Brush
The dimmed brush. The default value is #1E000000.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.Foreground Property

DigitalGaugeForeground Property

Gets or sets the foreground brush, which is used to render the character segments. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Foreground { get; set; }
Public Property Foreground As Brush
    Get
    Set

Property Value

Type: Brush
The foreground brush. The default value is WhiteSmoke.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.LedOffOpacity Property

DigitalGaugeLedOffOpacity Property

Gets or sets the opacity of the led lights when off. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LedOffOpacity { get; set; }
Public Property LedOffOpacity As Double
    Get
    Set

Property Value

Type: Double
The opacity of the led lights when off. The default value is 0.0.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.LedOnOpacity Property

DigitalGaugeLedOnOpacity Property

Gets or sets the opacity of the led lights when on. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LedOnOpacity { get; set; }
Public Property LedOnOpacity As Double
    Get
    Set

Property Value

Type: Double
The opacity of the led lights when on. The default value is 1.0.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.LedState Property

DigitalGaugeLedState Property

Gets or sets the current state of the led lights. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LedState LedState { get; set; }
Public Property LedState As LedState
    Get
    Set

Property Value

Type: LedState
The current state of the led lights. The default value is LedState.On.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.LogicalChildren Property

DigitalGaugeLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.RefreshRate Property

DigitalGaugeRefreshRate Property

Gets or sets the refresh rate, which indicates the minimum interval between updates to the value currently being displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration RefreshRate { get; set; }
Public Property RefreshRate As Duration
    Get
    Set

Property Value

Type: Duration
The refresh rate. The default value is 0 milliseconds.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.ScrollInterval Property

DigitalGaugeScrollInterval Property

Gets or sets the interval used when scrolling characters. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration ScrollInterval { get; set; }
Public Property ScrollInterval As Duration
    Get
    Set

Property Value

Type: Duration
The interval used when scrolling characters. The default value is 500 milliseconds.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.ScrollState Property

DigitalGaugeScrollState Property

Gets or sets the scroll state, which determines how and when the characters should be scrolled. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DigitalCharacterScrollState ScrollState { get; set; }
Public Property ScrollState As DigitalCharacterScrollState
    Get
    Set

Property Value

Type: DigitalCharacterScrollState
The scroll state. The default value is DigitalCharacterScrollState.None.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.SkewAngleX Property

DigitalGaugeSkewAngleX Property

Gets or sets the skew angle along the X-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SkewAngleX { get; set; }
Public Property SkewAngleX As Double
    Get
    Set

Property Value

Type: Double
The skew angle along the X-axis. The default value is 0.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.SkewAngleY Property

DigitalGaugeSkewAngleY Property

Gets or sets the skew angle along the Y-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SkewAngleY { get; set; }
Public Property SkewAngleY As Double
    Get
    Set

Property Value

Type: Double
The skew angle along the Y-axis. The default value is 0.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.TextAlignment Property

DigitalGaugeTextAlignment Property

Gets or sets the alignment of the label text. This is a read-only dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DigitalTextAlignment TextAlignment { get; set; }
Public Property TextAlignment As DigitalTextAlignment
    Get
    Set

Property Value

Type: DigitalTextAlignment
The alignment of the label text. The default value is Right.
Remarks
Valid values are Left or Right.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.Value Property

DigitalGaugeValue Property

Gets or sets the value displayed by the gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

Property Value

Type: Object
The value displayed by the gauge. The default value is .
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge Methods

The DigitalGauge type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides RectangularGaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides RectangularGaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from RectangularGaugeBase.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType property. (Inherited from RectangularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType property. (Inherited from RectangularGaugeBase.)
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from GaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.ArrangeOverride Method

DigitalGaugeArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.MeasureOverride Method

DigitalGaugeMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge Fields

The DigitalGauge type exposes the following members.

Fields
Name | Description
BlinkIntervalProperty | Identifies the BlinkInterval dependency property. This field is read-only.
CharacterCasingProperty | Identifies the CharacterCasing dependency property. This field is read-only.
CharacterCountProperty | Identifies the CharacterCount dependency property. This field is read-only.
CharacterHeightProperty | Identifies the CharacterHeight dependency property. This field is read-only.
CharacterOverflowAlignmentProperty | Identifies the CharacterOverflowAlignment dependency property. This field is read-only.
CharacterPaddingProperty | Identifies the CharacterPadding dependency property. This field is read-only.
CharacterSegmentThicknessProperty | Identifies the CharacterSegmentThickness dependency property. This field is read-only.
CharacterSpacingProperty | Identifies the CharacterSpacing dependency property. This field is read-only.
CharacterTypeProperty | Identifies the CharacterType dependency property. This field is read-only.
CharacterWidthRatioProperty | Identifies the CharacterWidthRatio dependency property. This field is read-only.
DimmedBrushProperty | Identifies the DimmedBrush dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
LedOffOpacityProperty | Identifies the LedOffOpacity dependency property. This field is read-only.
LedOnOpacityProperty | Identifies the LedOnOpacity dependency property. This field is read-only.
LedStateProperty | Identifies the LedState dependency property. This field is read-only.
RefreshRateProperty | Identifies the RefreshRate dependency property. This field is read-only.
ScrollIntervalProperty | Identifies the ScrollInterval dependency property. This field is read-only.
ScrollStateProperty | Identifies the ScrollState dependency property. This field is read-only.
SkewAngleXProperty | Identifies the SkewAngleX dependency property. This field is read-only.
SkewAngleYProperty | Identifies the SkewAngleY dependency property. This field is read-only.
TextAlignmentProperty | Identifies the TextAlignment dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.BlinkIntervalProperty Field

DigitalGaugeBlinkIntervalProperty Field

Identifies the BlinkInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BlinkIntervalProperty
Public Shared ReadOnly BlinkIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BlinkInterval dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterCasingProperty Field

DigitalGaugeCharacterCasingProperty Field

Identifies the CharacterCasing dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterCasingProperty
Public Shared ReadOnly CharacterCasingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterCasing dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterCountProperty Field

DigitalGaugeCharacterCountProperty Field

Identifies the CharacterCount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterCountProperty
Public Shared ReadOnly CharacterCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterCount dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterHeightProperty Field

DigitalGaugeCharacterHeightProperty Field

Identifies the CharacterHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterHeightProperty
Public Shared ReadOnly CharacterHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterHeight dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterOverflowAlignmentProperty Field

DigitalGaugeCharacterOverflowAlignmentProperty Field

Identifies the CharacterOverflowAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterOverflowAlignmentProperty
Public Shared ReadOnly CharacterOverflowAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterOverflowAlignment dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterPaddingProperty Field

DigitalGaugeCharacterPaddingProperty Field

Identifies the CharacterPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterPaddingProperty
Public Shared ReadOnly CharacterPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterPadding dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterSegmentThicknessProperty Field

DigitalGaugeCharacterSegmentThicknessProperty Field

Identifies the CharacterSegmentThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterSegmentThicknessProperty
Public Shared ReadOnly CharacterSegmentThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterSegmentThickness dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterSpacingProperty Field

DigitalGaugeCharacterSpacingProperty Field

Identifies the CharacterSpacing dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterSpacingProperty
Public Shared ReadOnly CharacterSpacingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterSpacing dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterTypeProperty Field

DigitalGaugeCharacterTypeProperty Field

Identifies the CharacterType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterTypeProperty
Public Shared ReadOnly CharacterTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterType dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.CharacterWidthRatioProperty Field

DigitalGaugeCharacterWidthRatioProperty Field

Identifies the CharacterWidthRatio dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CharacterWidthRatioProperty
Public Shared ReadOnly CharacterWidthRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CharacterWidthRatio dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.DimmedBrushProperty Field

DigitalGaugeDimmedBrushProperty Field

Identifies the DimmedBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DimmedBrushProperty
Public Shared ReadOnly DimmedBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DimmedBrush dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.ForegroundProperty Field

DigitalGaugeForegroundProperty Field

Identifies the Foreground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundProperty
Public Shared ReadOnly ForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Foreground dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.LedOffOpacityProperty Field

DigitalGaugeLedOffOpacityProperty Field

Identifies the LedOffOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedOffOpacityProperty
Public Shared ReadOnly LedOffOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedOffOpacity dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.LedOnOpacityProperty Field

DigitalGaugeLedOnOpacityProperty Field

Identifies the LedOnOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedOnOpacityProperty
Public Shared ReadOnly LedOnOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedOnOpacity dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.LedStateProperty Field

DigitalGaugeLedStateProperty Field

Identifies the LedState dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedStateProperty
Public Shared ReadOnly LedStateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedState dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.RefreshRateProperty Field

DigitalGaugeRefreshRateProperty Field

Identifies the RefreshRate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RefreshRateProperty
Public Shared ReadOnly RefreshRateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RefreshRate dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.ScrollIntervalProperty Field

DigitalGaugeScrollIntervalProperty Field

Identifies the ScrollInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollIntervalProperty
Public Shared ReadOnly ScrollIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollInterval dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.ScrollStateProperty Field

DigitalGaugeScrollStateProperty Field

Identifies the ScrollState dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollStateProperty
Public Shared ReadOnly ScrollStateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollState dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.SkewAngleXProperty Field

DigitalGaugeSkewAngleXProperty Field

Identifies the SkewAngleX dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkewAngleXProperty
Public Shared ReadOnly SkewAngleXProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkewAngleX dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.SkewAngleYProperty Field

DigitalGaugeSkewAngleYProperty Field

Identifies the SkewAngleY dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkewAngleYProperty
Public Shared ReadOnly SkewAngleYProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkewAngleY dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.TextAlignmentProperty Field

DigitalGaugeTextAlignmentProperty Field

Identifies the TextAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextAlignmentProperty
Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextAlignment dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalGauge.ValueProperty Field

DigitalGaugeValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

DigitalGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DigitalTextAlignment Enumeration

Specifies the digital text alignment.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DigitalTextAlignment
Public Enumeration DigitalTextAlignment
Members
Member name | Value | Description
Left | 0 | Align text to the left side of the control.
Right | 1 | Align text to the right side of the control.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleAverageConverter Class

Represents a value converter that returns an average of the values that are passed to the converter.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.Controls.GaugeDoubleAverageConverter

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoubleAverageConverter : DependencyObject,
    IValueConverter
Public Class DoubleAverageConverter
    Inherits DependencyObject
    Implements IValueConverter

The DoubleAverageConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleAverageConverter | Initializes a new instance of the DoubleAverageConverter class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ValueCount | Gets or sets the number of values used to calculate the average. This is a dependency property.
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Convert | Converts the specified value to an average based on the previous values converted.
Public method | ConvertBack | This method always throws a NotImplementedException exception and should not be used.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
ValueCountProperty | Identifies the ValueCount dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleAverageConverter Constructor

Initializes a new instance of the DoubleAverageConverter class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleAverageConverter()
Public Sub New
See Also

Reference

DoubleAverageConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleAverageConverter Properties

The DoubleAverageConverter type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ValueCount | Gets or sets the number of values used to calculate the average. This is a dependency property.
Top
See Also

Reference

DoubleAverageConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleAverageConverter.ValueCount Property

DoubleAverageConverterValueCount Property

Gets or sets the number of values used to calculate the average. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int ValueCount { get; set; }
Public Property ValueCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of values to use to calculate the average, or -1 for a running average.
See Also

Reference

DoubleAverageConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleAverageConverter Methods

The DoubleAverageConverter type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Convert | Converts the specified value to an average based on the previous values converted.
Public method | ConvertBack | This method always throws a NotImplementedException exception and should not be used.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DoubleAverageConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleAverageConverter.Convert Method

DoubleAverageConverterConvert Method

Converts the specified value to an average based on the previous values converted.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
An average of the specified value and previous values.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleAverageConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleAverageConverter.ConvertBack Method

DoubleAverageConverterConvertBack Method

This method always throws a NotImplementedException exception and should not be used.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
Not used.
targetType
Type: SystemType
Not used.
parameter
Type: SystemObject
Not used.
culture
Type: System.GlobalizationCultureInfo
Not used.

Return Value

Type: Object

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Gauge.DoubleAverageConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleAverageConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleAverageConverter Fields

The DoubleAverageConverter type exposes the following members.

Fields
Name | Description
ValueCountProperty | Identifies the ValueCount dependency property. This field is read-only.
Top
See Also

Reference

DoubleAverageConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleAverageConverter.ValueCountProperty Field

DoubleAverageConverterValueCountProperty Field

Identifies the ValueCount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueCountProperty
Public Shared ReadOnly ValueCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueCount dependency property.
See Also

Reference

DoubleAverageConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMaximumConverter Class

Represents a value converter that returns the maximum of the values that are passed to the converter.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.Controls.GaugeDoubleMaximumConverter

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoubleMaximumConverter : DependencyObject,
    IValueConverter
Public Class DoubleMaximumConverter
    Inherits DependencyObject
    Implements IValueConverter

The DoubleMaximumConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleMaximumConverter | Initializes a new instance of the DoubleMaximumConverter class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ValueCount | Gets or sets the number of values used to calculate the maximum. This is a dependency property.
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Convert | Converts the specified value to the maximum value based on the previous values converted.
Public method | ConvertBack | This method always throws a NotImplementedException exception and should not be used.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
ValueCountProperty | Identifies the ValueCount dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMaximumConverter Constructor

Initializes a new instance of the DoubleMaximumConverter class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleMaximumConverter()
Public Sub New
See Also

Reference

DoubleMaximumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMaximumConverter Properties

The DoubleMaximumConverter type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ValueCount | Gets or sets the number of values used to calculate the maximum. This is a dependency property.
Top
See Also

Reference

DoubleMaximumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMaximumConverter.ValueCount Property

DoubleMaximumConverterValueCount Property

Gets or sets the number of values used to calculate the maximum. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int ValueCount { get; set; }
Public Property ValueCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of values to use to calculate the maximum, or -1 for no limit.
See Also

Reference

DoubleMaximumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMaximumConverter Methods

The DoubleMaximumConverter type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Convert | Converts the specified value to the maximum value based on the previous values converted.
Public method | ConvertBack | This method always throws a NotImplementedException exception and should not be used.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DoubleMaximumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMaximumConverter.Convert Method

DoubleMaximumConverterConvert Method

Converts the specified value to the maximum value based on the previous values converted.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
The maximum value of the specified value and previous values.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleMaximumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMaximumConverter.ConvertBack Method

DoubleMaximumConverterConvertBack Method

This method always throws a NotImplementedException exception and should not be used.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
Not used.
targetType
Type: SystemType
Not used.
parameter
Type: SystemObject
Not used.
culture
Type: System.GlobalizationCultureInfo
Not used.

Return Value

Type: Object

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Gauge.DoubleMaximumConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleMaximumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMaximumConverter Fields

The DoubleMaximumConverter type exposes the following members.

Fields
Name | Description
ValueCountProperty | Identifies the ValueCount dependency property. This field is read-only.
Top
See Also

Reference

DoubleMaximumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMaximumConverter.ValueCountProperty Field

DoubleMaximumConverterValueCountProperty Field

Identifies the ValueCount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueCountProperty
Public Shared ReadOnly ValueCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueCount dependency property.
See Also

Reference

DoubleMaximumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMinimumConverter Class

Represents a value converter that returns the minimum of the values that are passed to the converter.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.Controls.GaugeDoubleMinimumConverter

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DoubleMinimumConverter : DependencyObject,
    IValueConverter
Public Class DoubleMinimumConverter
    Inherits DependencyObject
    Implements IValueConverter

The DoubleMinimumConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleMinimumConverter | Initializes a new instance of the DoubleMinimumConverter class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ValueCount | Gets or sets the number of values used to calculate the minimum. This is a dependency property.
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Convert | Converts the specified value to the minimum value based on the previous values converted.
Public method | ConvertBack | This method always throws a NotImplementedException exception and should not be used.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
ValueCountProperty | Identifies the ValueCount dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMinimumConverter Constructor

Initializes a new instance of the DoubleMinimumConverter class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleMinimumConverter()
Public Sub New
See Also

Reference

DoubleMinimumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMinimumConverter Properties

The DoubleMinimumConverter type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ValueCount | Gets or sets the number of values used to calculate the minimum. This is a dependency property.
Top
See Also

Reference

DoubleMinimumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMinimumConverter.ValueCount Property

DoubleMinimumConverterValueCount Property

Gets or sets the number of values used to calculate the minimum. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int ValueCount { get; set; }
Public Property ValueCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of values to use to calculate the minimum, or -1 for no limit.
See Also

Reference

DoubleMinimumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMinimumConverter Methods

The DoubleMinimumConverter type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Convert | Converts the specified value to the minimum value based on the previous values converted.
Public method | ConvertBack | This method always throws a NotImplementedException exception and should not be used.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DoubleMinimumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMinimumConverter.Convert Method

DoubleMinimumConverterConvert Method

Converts the specified value to the minimum value based on the previous values converted.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
culture
Type: System.GlobalizationCultureInfo
The culture to use in the converter.

Return Value

Type: Object
The minimum value of the specified value and previous values.

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleMinimumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMinimumConverter.ConvertBack Method

DoubleMinimumConverterConvertBack Method

This method always throws a NotImplementedException exception and should not be used.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    culture As CultureInfo
) As Object

Parameters

value
Type: SystemObject
Not used.
targetType
Type: SystemType
Not used.
parameter
Type: SystemObject
Not used.
culture
Type: System.GlobalizationCultureInfo
Not used.

Return Value

Type: Object

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Gauge.DoubleMinimumConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleMinimumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMinimumConverter Fields

The DoubleMinimumConverter type exposes the following members.

Fields
Name | Description
ValueCountProperty | Identifies the ValueCount dependency property. This field is read-only.
Top
See Also

Reference

DoubleMinimumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


DoubleMinimumConverter.ValueCountProperty Field

DoubleMinimumConverterValueCountProperty Field

Identifies the ValueCount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueCountProperty
Public Shared ReadOnly ValueCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueCount dependency property.
See Also

Reference

DoubleMinimumConverter Class
ActiproSoftware.Windows.Controls.Gauge Namespace


IntervalOrigin Enumeration

Specifies the various interval origins.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum IntervalOrigin
Public Enumeration IntervalOrigin
Members
Member name | Value | Description
Minimum | 0 | Indicates that the intervals should start counting at the minimum value.
Zero | 1 | Indicates that the intervals should start counting at zero.
Maximum | 2 | Indicates that the intervals should start counting at the maximum value.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


IntervalType Enumeration

Specifies the various interval types.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum IntervalType
Public Enumeration IntervalType
Members
Member name | Value | Description
Auto | 0 | Indicates that the interval should be automatically determined.
Linear | 1 | Indicates that the interval should be linear.
Logarithmic | 2 | Indicates that the interval should be logarithmic.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


Led Class

Represents a led control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularGaugeBase
ActiproSoftware.Windows.Controls.GaugeLed

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Led : CircularGaugeBase
Public Class Led
    Inherits CircularGaugeBase

The Led type exposes the following members.

Constructors
 | Name | Description
Public method | Led | Initializes a new instance of the Led class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundRadiusRatio | Gets or sets the radius of the frame background as a ratio of the Radius property. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BlinkInterval | Gets or sets the interval used when LedState is set to Blinking. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FrameType | Gets or sets the type of frame rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsLedEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the led. This is a dependency property.
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Public property | LedBackground | Gets or sets the background brush, which is used to render the led light. This is a dependency property.
Public property | LedBorderBrush | Gets or sets the border brush, which is used to render the led light. This is a dependency property.
Public property | LedBorderThickness | Gets or sets the border thickness, which is used to render the led light. This is a dependency property.
Public property | LedForeground | Gets or sets the foreground brush, which is used to render the led light. This is a dependency property.
Public property | LedGeometry | Gets or sets a custom geometry used for the led light. This is a dependency property.
Public property | LedOffOpacity | Gets or sets the opacity of the led light when off. This is a dependency property.
Public property | LedOnOpacity | Gets or sets the opacity of the led light when on. This is a dependency property.
Protected property | LedOpacity | Gets or sets the opacity used to render the led light. This is a dependency property.
Public property | LedRadiusRatio | Gets or sets the radius of the led light as a ratio of the Radius property. This is a dependency property.
Public property | LedState | Gets or sets the current state of the led light. This is a dependency property.
Public property | LedType | Gets or sets the type of led light rendered. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from CircularGaugeBase.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Radius | Gets or sets the radius of the gauge. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from CircularGaugeBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from CircularGaugeBase.)
Protected method | OnCreateAutomationPeer | Creates an appropriate LedAutomationPeer for this control as part of the WPF infrastructure. (Overrides GaugeBaseOnCreateAutomationPeer.)
Protected method | OnLedStateChanged | Invoked when the LedState property is changed.
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides CircularGaugeBaseOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderLed | Renders the led light based on various properties.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateLedOpacity | Updates the LedOpacity, usually with an animation.
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from CircularGaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | LedStateChanged | Occurs when the LedState is changed.
Top
Fields
Name | Description
BlinkIntervalProperty | Identifies the BlinkInterval dependency property. This field is read-only.
IsLedEffectEnabledProperty | Identifies the IsLedEffectEnabled dependency property. This field is read-only.
LedBackgroundProperty | Identifies the LedBackground dependency property. This field is read-only.
LedBorderBrushProperty | Identifies the LedBorderBrush dependency property. This field is read-only.
LedBorderThicknessProperty | Identifies the LedBorderThickness dependency property. This field is read-only.
LedForegroundProperty | Identifies the LedForeground dependency property. This field is read-only.
LedGeometryProperty | Identifies the LedGeometry dependency property. This field is read-only.
LedOffOpacityProperty | Identifies the LedOffOpacity dependency property. This field is read-only.
LedOnOpacityProperty | Identifies the LedOnOpacity dependency property. This field is read-only.
LedOpacityProperty | Identifies the LedOpacity dependency property. This field is read-only.
LedRadiusRatioProperty | Identifies the LedRadiusRatio dependency property. This field is read-only.
LedStateChangedEvent | Identifies the LedStateChanged routed event. This field is read-only.
LedStateProperty | Identifies the LedState dependency property. This field is read-only.
LedTypeProperty | Identifies the LedType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


Led Constructor

Initializes a new instance of the Led class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Led()
Public Sub New
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led Properties

The Led type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundRadiusRatio | Gets or sets the radius of the frame background as a ratio of the Radius property. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BlinkInterval | Gets or sets the interval used when LedState is set to Blinking. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FrameType | Gets or sets the type of frame rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsLedEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the led. This is a dependency property.
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Public property | LedBackground | Gets or sets the background brush, which is used to render the led light. This is a dependency property.
Public property | LedBorderBrush | Gets or sets the border brush, which is used to render the led light. This is a dependency property.
Public property | LedBorderThickness | Gets or sets the border thickness, which is used to render the led light. This is a dependency property.
Public property | LedForeground | Gets or sets the foreground brush, which is used to render the led light. This is a dependency property.
Public property | LedGeometry | Gets or sets a custom geometry used for the led light. This is a dependency property.
Public property | LedOffOpacity | Gets or sets the opacity of the led light when off. This is a dependency property.
Public property | LedOnOpacity | Gets or sets the opacity of the led light when on. This is a dependency property.
Protected property | LedOpacity | Gets or sets the opacity used to render the led light. This is a dependency property.
Public property | LedRadiusRatio | Gets or sets the radius of the led light as a ratio of the Radius property. This is a dependency property.
Public property | LedState | Gets or sets the current state of the led light. This is a dependency property.
Public property | LedType | Gets or sets the type of led light rendered. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from CircularGaugeBase.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Radius | Gets or sets the radius of the gauge. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.BlinkInterval Property

LedBlinkInterval Property

Gets or sets the interval used when LedState is set to Blinking. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration BlinkInterval { get; set; }
Public Property BlinkInterval As Duration
    Get
    Set

Property Value

Type: Duration
The interval used when LedState is set to Blinking. The default value is 500 milliseconds.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.IsLedEffectEnabled Property

LedIsLedEffectEnabled Property

Gets and sets a value indicating whether a special effect should be rendered for the led. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsLedEffectEnabled { get; set; }
Public Property IsLedEffectEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the led effect is enabled; otherwise, false. The default value is true.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedBackground Property

LedLedBackground Property

Gets or sets the background brush, which is used to render the led light. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LedBackground { get; set; }
Public Property LedBackground As Brush
    Get
    Set

Property Value

Type: Brush
The background brush. The default value is DarkGray.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedBorderBrush Property

LedLedBorderBrush Property

Gets or sets the border brush, which is used to render the led light. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LedBorderBrush { get; set; }
Public Property LedBorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The border brush. The default value is Black.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedBorderThickness Property

LedLedBorderThickness Property

Gets or sets the border thickness, which is used to render the led light. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LedBorderThickness { get; set; }
Public Property LedBorderThickness As Double
    Get
    Set

Property Value

Type: Double
The border thickness. The default value is 1.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedForeground Property

LedLedForeground Property

Gets or sets the foreground brush, which is used to render the led light. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LedForeground { get; set; }
Public Property LedForeground As Brush
    Get
    Set

Property Value

Type: Brush
The foreground brush. The default value is Red.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedGeometry Property

LedLedGeometry Property

Gets or sets a custom geometry used for the led light. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry LedGeometry { get; set; }
Public Property LedGeometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry used for the led light. The default value is .
Remarks
This property is only used when LedType is set to LedType.CustomGeometry.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedOffOpacity Property

LedLedOffOpacity Property

Gets or sets the opacity of the led light when off. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LedOffOpacity { get; set; }
Public Property LedOffOpacity As Double
    Get
    Set

Property Value

Type: Double
The opacity of the led light when off. The default value is 0.4.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedOnOpacity Property

LedLedOnOpacity Property

Gets or sets the opacity of the led light when on. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LedOnOpacity { get; set; }
Public Property LedOnOpacity As Double
    Get
    Set

Property Value

Type: Double
The opacity of the led light when on. The default value is 1.0.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedOpacity Property

LedLedOpacity Property

Gets or sets the opacity used to render the led light. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double LedOpacity { get; set; }
Protected Property LedOpacity As Double
    Get
    Set

Property Value

Type: Double
The opacity used to render the led light. The default value is 0.0.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedRadiusRatio Property

LedLedRadiusRatio Property

Gets or sets the radius of the led light as a ratio of the Radius property. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LedRadiusRatio { get; set; }
Public Property LedRadiusRatio As Double
    Get
    Set

Property Value

Type: Double
The radius of the led light as a ratio of the Radius property. The default value is 0.5.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedState Property

LedLedState Property

Gets or sets the current state of the led light. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LedState LedState { get; set; }
Public Property LedState As LedState
    Get
    Set

Property Value

Type: LedState
The current state of the led light. The default value is LedState.On.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedType Property

LedLedType Property

Gets or sets the type of led light rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LedType LedType { get; set; }
Public Property LedType As LedType
    Get
    Set

Property Value

Type: LedType
The type of led light rendered. The default value is LedType.Circle.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led Methods

The Led type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from CircularGaugeBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from CircularGaugeBase.)
Protected method | OnCreateAutomationPeer | Creates an appropriate LedAutomationPeer for this control as part of the WPF infrastructure. (Overrides GaugeBaseOnCreateAutomationPeer.)
Protected method | OnLedStateChanged | Invoked when the LedState property is changed.
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides CircularGaugeBaseOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderLed | Renders the led light based on various properties.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateLedOpacity | Updates the LedOpacity, usually with an animation.
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from CircularGaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.OnCreateAutomationPeer Method

LedOnCreateAutomationPeer Method

Creates an appropriate LedAutomationPeer for this control as part of the WPF infrastructure.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An instance of LedAutomationPeer.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.OnLedStateChanged Method

LedOnLedStateChanged Method

Invoked when the LedState property is changed.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnLedStateChanged(
    LedState oldValue,
    LedState newValue
)
Protected Overridable Sub OnLedStateChanged (
    oldValue As LedState,
    newValue As LedState
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.GaugeLedState
The old property value.
newValue
Type: ActiproSoftware.Windows.Controls.GaugeLedState
The new property value.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.OnRender Method

LedOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.RenderLed Method

LedRenderLed Method

Renders the led light based on various properties.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void RenderLed(
    DrawingContext drawingContext
)
Protected Overridable Sub RenderLed (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing context.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.UpdateLedOpacity Method

LedUpdateLedOpacity Method

Updates the LedOpacity, usually with an animation.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateLedOpacity()
Protected Overridable Sub UpdateLedOpacity
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led Events

The Led type exposes the following members.

Events
 | Name | Description
Public event | LedStateChanged | Occurs when the LedState is changed.
Top
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedStateChanged Event

LedLedStateChanged Event

Occurs when the LedState is changed.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<LedStatePropertyChangedRoutedEventArgs> LedStateChanged
Public Event LedStateChanged As EventHandler(Of LedStatePropertyChangedRoutedEventArgs)

Value

Type: SystemEventHandler LedStatePropertyChangedRoutedEventArgs
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led Fields

The Led type exposes the following members.

Fields
Name | Description
BlinkIntervalProperty | Identifies the BlinkInterval dependency property. This field is read-only.
IsLedEffectEnabledProperty | Identifies the IsLedEffectEnabled dependency property. This field is read-only.
LedBackgroundProperty | Identifies the LedBackground dependency property. This field is read-only.
LedBorderBrushProperty | Identifies the LedBorderBrush dependency property. This field is read-only.
LedBorderThicknessProperty | Identifies the LedBorderThickness dependency property. This field is read-only.
LedForegroundProperty | Identifies the LedForeground dependency property. This field is read-only.
LedGeometryProperty | Identifies the LedGeometry dependency property. This field is read-only.
LedOffOpacityProperty | Identifies the LedOffOpacity dependency property. This field is read-only.
LedOnOpacityProperty | Identifies the LedOnOpacity dependency property. This field is read-only.
LedOpacityProperty | Identifies the LedOpacity dependency property. This field is read-only.
LedRadiusRatioProperty | Identifies the LedRadiusRatio dependency property. This field is read-only.
LedStateChangedEvent | Identifies the LedStateChanged routed event. This field is read-only.
LedStateProperty | Identifies the LedState dependency property. This field is read-only.
LedTypeProperty | Identifies the LedType dependency property. This field is read-only.
Top
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.BlinkIntervalProperty Field

LedBlinkIntervalProperty Field

Identifies the BlinkInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BlinkIntervalProperty
Public Shared ReadOnly BlinkIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BlinkInterval dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.IsLedEffectEnabledProperty Field

LedIsLedEffectEnabledProperty Field

Identifies the IsLedEffectEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLedEffectEnabledProperty
Public Shared ReadOnly IsLedEffectEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLedEffectEnabled dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedBackgroundProperty Field

LedLedBackgroundProperty Field

Identifies the LedBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedBackgroundProperty
Public Shared ReadOnly LedBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedBackground dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedBorderBrushProperty Field

LedLedBorderBrushProperty Field

Identifies the LedBorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedBorderBrushProperty
Public Shared ReadOnly LedBorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedBorderBrush dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedBorderThicknessProperty Field

LedLedBorderThicknessProperty Field

Identifies the LedBorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedBorderThicknessProperty
Public Shared ReadOnly LedBorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedBorderThickness dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedForegroundProperty Field

LedLedForegroundProperty Field

Identifies the LedForeground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedForegroundProperty
Public Shared ReadOnly LedForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedForeground dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedGeometryProperty Field

LedLedGeometryProperty Field

Identifies the LedGeometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedGeometryProperty
Public Shared ReadOnly LedGeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedGeometry dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedOffOpacityProperty Field

LedLedOffOpacityProperty Field

Identifies the LedOffOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedOffOpacityProperty
Public Shared ReadOnly LedOffOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedOffOpacity dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedOnOpacityProperty Field

LedLedOnOpacityProperty Field

Identifies the LedOnOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedOnOpacityProperty
Public Shared ReadOnly LedOnOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedOnOpacity dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedOpacityProperty Field

LedLedOpacityProperty Field

Identifies the LedOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static readonly DependencyProperty LedOpacityProperty
Protected Shared ReadOnly LedOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedOpacity dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedRadiusRatioProperty Field

LedLedRadiusRatioProperty Field

Identifies the LedRadiusRatio dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedRadiusRatioProperty
Public Shared ReadOnly LedRadiusRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedRadiusRatio dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedStateChangedEvent Field

LedLedStateChangedEvent Field

Identifies the LedStateChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent LedStateChangedEvent
Public Shared ReadOnly LedStateChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the LedStateChanged routed event.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedStateProperty Field

LedLedStateProperty Field

Identifies the LedState dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedStateProperty
Public Shared ReadOnly LedStateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedState dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


Led.LedTypeProperty Field

LedLedTypeProperty Field

Identifies the LedType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LedTypeProperty
Public Shared ReadOnly LedTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LedType dependency property.
See Also

Reference

Led Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LedState Enumeration

Specifies the states supported by Led.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LedState
Public Enumeration LedState
Members
Member name | Value | Description
Blinking | 0 | Indicates that the led will blink on and off.
Off | 1 | Indicates that the led will be off.
On | 2 | Indicates that the led will be on.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LedStatePropertyChangedRoutedEventArgs Class

Provides event arguments for a LedState property change routed event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsPropertyChangedRoutedEventArgs LedState
ActiproSoftware.Windows.Controls.GaugeLedStatePropertyChangedRoutedEventArgs

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LedStatePropertyChangedRoutedEventArgs : PropertyChangedRoutedEventArgs<LedState>
Public Class LedStatePropertyChangedRoutedEventArgs
    Inherits PropertyChangedRoutedEventArgs(Of LedState)

The LedStatePropertyChangedRoutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LedStatePropertyChangedRoutedEventArgs(LedState, LedState) | Initializes a new instance of the LedStatePropertyChangedRoutedEventArgs class.
Public method | LedStatePropertyChangedRoutedEventArgs(RoutedEvent, LedState, LedState) | Initializes a new instance of the LedStatePropertyChangedRoutedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LedStatePropertyChangedRoutedEventArgs Constructor

Overload List
 | Name | Description
Public method | LedStatePropertyChangedRoutedEventArgs(LedState, LedState) | Initializes a new instance of the LedStatePropertyChangedRoutedEventArgs class.
Public method | LedStatePropertyChangedRoutedEventArgs(RoutedEvent, LedState, LedState) | Initializes a new instance of the LedStatePropertyChangedRoutedEventArgs class.
Top
See Also

Reference

LedStatePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LedStatePropertyChangedRoutedEventArgs Constructor (LedState, LedState)

Initializes a new instance of the LedStatePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LedStatePropertyChangedRoutedEventArgs(
    LedState oldValue,
    LedState newValue
)
Public Sub New (
    oldValue As LedState,
    newValue As LedState
)

Parameters

oldValue
Type: ActiproSoftware.Windows.Controls.GaugeLedState
The previous value of the property being tracked as reported by an event.
newValue
Type: ActiproSoftware.Windows.Controls.GaugeLedState
The new value of the property being tracked as reported by an event.
See Also

Reference

LedStatePropertyChangedRoutedEventArgs Class
LedStatePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows.Controls.Gauge Namespace


LedStatePropertyChangedRoutedEventArgs Constructor (RoutedEvent, LedState, LedState)

Initializes a new instance of the LedStatePropertyChangedRoutedEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LedStatePropertyChangedRoutedEventArgs(
    RoutedEvent routedEvent,
    LedState oldValue,
    LedState newValue
)
Public Sub New (
    routedEvent As RoutedEvent,
    oldValue As LedState,
    newValue As LedState
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event identifier for this event arguments instance.
oldValue
Type: ActiproSoftware.Windows.Controls.GaugeLedState
The previous value of the property being tracked as reported by an event.
newValue
Type: ActiproSoftware.Windows.Controls.GaugeLedState
The new value of the property being tracked as reported by an event.
See Also

Reference

LedStatePropertyChangedRoutedEventArgs Class
LedStatePropertyChangedRoutedEventArgs Overload
ActiproSoftware.Windows.Controls.Gauge Namespace


LedStatePropertyChangedRoutedEventArgs Properties

The LedStatePropertyChangedRoutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedRoutedEventArgsT.)
Top
See Also

Reference

LedStatePropertyChangedRoutedEventArgs Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LedType Enumeration

Specifies the types of led shapes supported by Led.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum LedType
Public Enumeration LedType
Members
Member name | Value | Description
ArrowDown | 0 | Indicates an arrow led shape that points down.
ArrowLeft | 1 | Indicates an arrow led shape that points left.
ArrowRight | 2 | Indicates an arrow led shape that points right.
ArrowUp | 3 | Indicates an arrow led shape that points up.
Circle | 4 | Indicates a circle led shape.
ClippedRectangle | 5 | Indicates a clipped rectangle led shape.
CustomGeometry | 6 | Indicates the led will be based on a custom geometry.
Diamond | 7 | Indicates a diamond led shape.
Fan | 8 | Indicates a fan led shape.
Rectangle | 9 | Indicates a rectangle led shape.
RoundedRectangle | 10 | Indicates a rounded rectangle led shape.
Semicircular | 11 | Indicates a semi-circular led shape.
SwordBluntDown | 12 | Indicates a sword led shape that points down with a blunt tip.
SwordBluntLeft | 13 | Indicates a sword led shape that points left with a blunt tip.
SwordBluntRight | 14 | Indicates a sword led shape that points right with a blunt tip.
SwordBluntUp | 15 | Indicates a sword led shape that points up with a blunt tip.
SwordSharpDown | 16 | Indicates a sword led shape that points down with a sharp tip.
SwordSharpLeft | 17 | Indicates a sword led shape that points left with a sharp tip.
SwordSharpRight | 18 | Indicates a sword led shape that points right with a sharp tip.
SwordSharpUp | 19 | Indicates a sword led shape that points up with a sharp tip.
TeardropDown | 20 | Indicates a tear drop led shape that points down.
TeardropLeft | 21 | Indicates a tear drop led shape that points left.
TeardropRight | 22 | Indicates a tear drop led shape that points right.
TeardropUp | 23 | Indicates a tear drop led shape that points up.
TriangleBluntDown | 24 | Indicates a triangle led shape that points down with a blunt tip.
TriangleBluntLeft | 25 | Indicates a triangle led shape that points left with a blunt tip.
TriangleBluntRight | 26 | Indicates a triangle led shape that points right with a blunt tip.
TriangleBluntUp | 27 | Indicates a triangle led shape that points up with a blunt tip.
TriangleSharpDown | 28 | Indicates a triangle led shape that points down with a sharp tip.
TriangleSharpLeft | 29 | Indicates a triangle led shape that points left with a sharp tip.
TriangleSharpRight | 30 | Indicates a triangle led shape that points right with a sharp tip.
TriangleSharpUp | 31 | Indicates a triangle led shape that points up with a sharp tip.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge Class

Represents a linear gauge control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesRectangularGaugeBase
ActiproSoftware.Windows.Controls.GaugeLinearGauge

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearGauge : RectangularGaugeBase
Public Class LinearGauge
    Inherits RectangularGaugeBase

The LinearGauge type exposes the following members.

Constructors
 | Name | Description
Public method | LinearGauge | Initializes a new instance of the LinearGauge class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundSizeRatio | Gets or sets the size of the frame background as a ratio of the ActualWidth and ActualHeight properties. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FrameAngle | Gets the angle of the frame, which is used when rendering the background frame. (Overrides RectangularGaugeBaseFrameAngle.)
Public property | FrameType | Gets or sets the type of rectangular frame rendered in the background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides RectangularGaugeBaseLogicalChildren.)
Public property | Orientation | Gets or sets the orientation of the gauge. This is a dependency property.
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | Scales | Gets the scale elements within the gauge.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides RectangularGaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
 | GetOrientation | Gets the value of the OrientationProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides RectangularGaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from RectangularGaugeBase.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType property. (Inherited from RectangularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType property. (Inherited from RectangularGaugeBase.)
 | SetOrientation | Sets the value of the OrientationProperty attached property to a specified object.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from GaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge Constructor

Initializes a new instance of the LinearGauge class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearGauge()
Public Sub New
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge Properties

The LinearGauge type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundSizeRatio | Gets or sets the size of the frame background as a ratio of the ActualWidth and ActualHeight properties. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FrameAngle | Gets the angle of the frame, which is used when rendering the background frame. (Overrides RectangularGaugeBaseFrameAngle.)
Public property | FrameType | Gets or sets the type of rectangular frame rendered in the background. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides RectangularGaugeBaseLogicalChildren.)
Public property | Orientation | Gets or sets the orientation of the gauge. This is a dependency property.
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from RectangularGaugeBase.)
Public property | Scales | Gets the scale elements within the gauge.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge.FrameAngle Property

LinearGaugeFrameAngle Property

Gets the angle of the frame, which is used when rendering the background frame.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override double FrameAngle { get; }
Protected Overrides ReadOnly Property FrameAngle As Double
    Get

Property Value

Type: Double
The frame angle.
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge.LogicalChildren Property

LinearGaugeLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge.Orientation Property

LinearGaugeOrientation Property

Gets or sets the orientation of the gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation. The default value is Orientation.Horizontal.
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge.Scales Property

LinearGaugeScales Property

Gets the scale elements within the gauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearScaleCollection Scales { get; }
Public ReadOnly Property Scales As LinearScaleCollection
    Get

Property Value

Type: LinearScaleCollection
The scales.
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge Methods

The LinearGauge type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides RectangularGaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
 | GetOrientation | Gets the value of the OrientationProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides RectangularGaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from RectangularGaugeBase.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType property. (Inherited from RectangularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType property. (Inherited from RectangularGaugeBase.)
 | SetOrientation | Sets the value of the OrientationProperty attached property to a specified object.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from GaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge.ArrangeOverride Method

LinearGaugeArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge.GetOrientation Method

LinearGaugeGetOrientation Method

Gets the value of the OrientationProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Orientation GetOrientation(
    DependencyObject obj
)
Public Shared Function GetOrientation (
    obj As DependencyObject
) As Orientation

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Orientation
The orientation.
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge.MeasureOverride Method

LinearGaugeMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge.SetOrientation Method

LinearGaugeSetOrientation Method

Sets the value of the OrientationProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetOrientation(
    DependencyObject obj,
    Orientation value
)
Public Shared Sub SetOrientation (
    obj As DependencyObject,
    value As Orientation
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: System.Windows.ControlsOrientation
The orientation.
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge Fields

The LinearGauge type exposes the following members.

Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearGauge.OrientationProperty Field

LinearGaugeOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

LinearGauge Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar Class

Represents a bar pointer for use in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearPointerBase
ActiproSoftware.Windows.Controls.GaugeLinearPointerBar

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearPointerBar : LinearPointerBase
Public Class LinearPointerBar
    Inherits LinearPointerBase

The LinearPointerBar type exposes the following members.

Constructors
 | Name | Description
Public method | LinearPointerBar | Initializes a new instance of the LinearPointerBar class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BarOrigin | Gets or sets the origin of the bar. This is a dependency property.
Public property | BarType | Gets or sets the type of bar rendered. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearPointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueExtent | Gets or sets the extent used to display the Value on the linear gauge. This is a dependency property. (Inherited from LinearPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified extent. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from LinearPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from LinearPointerBase.)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from LinearPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueExtent | Updates the ValueExtent property. (Inherited from LinearPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
BarOriginProperty | Identifies the BarOrigin dependency property. This field is read-only.
BarTypeProperty | Identifies the BarType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar Constructor

Initializes a new instance of the LinearPointerBar class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearPointerBar()
Public Sub New
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar Properties

The LinearPointerBar type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BarOrigin | Gets or sets the origin of the bar. This is a dependency property.
Public property | BarType | Gets or sets the type of bar rendered. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearPointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueExtent | Gets or sets the extent used to display the Value on the linear gauge. This is a dependency property. (Inherited from LinearPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar.BarOrigin Property

LinearPointerBarBarOrigin Property

Gets or sets the origin of the bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointerBarOrigin BarOrigin { get; set; }
Public Property BarOrigin As PointerBarOrigin
    Get
    Set

Property Value

Type: PointerBarOrigin
The origin of the bar. The default value is Minimum.
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar.BarType Property

LinearPointerBarBarType Property

Gets or sets the type of bar rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointerBarType BarType { get; set; }
Public Property BarType As PointerBarType
    Get
    Set

Property Value

Type: PointerBarType
The type of bar rendered. The default value is Rectangle.
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar Methods

The LinearPointerBar type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified extent. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from LinearPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from LinearPointerBase.)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from LinearPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueExtent | Updates the ValueExtent property. (Inherited from LinearPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar.OnRender Method

LinearPointerBarOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar Events

The LinearPointerBar type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar Fields

The LinearPointerBar type exposes the following members.

Fields
Name | Description
BarOriginProperty | Identifies the BarOrigin dependency property. This field is read-only.
BarTypeProperty | Identifies the BarType dependency property. This field is read-only.
Top
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar.BarOriginProperty Field

LinearPointerBarBarOriginProperty Field

Identifies the BarOrigin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarOriginProperty
Public Shared ReadOnly BarOriginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarOrigin dependency property.
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerBar.BarTypeProperty Field

LinearPointerBarBarTypeProperty Field

Identifies the BarType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarTypeProperty
Public Shared ReadOnly BarTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarType dependency property.
See Also

Reference

LinearPointerBar Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerCollection Class

Represents a collection of LinearPointerBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection LinearPointerBase
System.Collections.ObjectModelObservableCollection LinearPointerBase
ActiproSoftware.WindowsDeferrableObservableCollection LinearPointerBase
ActiproSoftware.WindowsLogicalChildrenCollection LinearPointerBase
ActiproSoftware.Windows.Controls.GaugeLinearPointerCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearPointerCollection : LogicalChildrenCollection<LinearPointerBase>
Public Class LinearPointerCollection
    Inherits LogicalChildrenCollection(Of LinearPointerBase)

The LinearPointerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LinearPointerCollection | Initializes a new instance of the LinearPointerCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearPointerBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearPointerBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearPointerBase .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearPointerBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearPointerBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearPointerBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearPointerBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearPointerBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearPointerBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearPointerBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearPointerBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearPointerBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearPointerBase .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerCollection Constructor

Initializes a new instance of the LinearPointerCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearPointerCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

LinearPointerCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerCollection Properties

The LinearPointerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearPointerBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearPointerBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearPointerBase .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

LinearPointerCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerCollection Methods

The LinearPointerCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearPointerBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearPointerBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearPointerBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearPointerBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearPointerBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearPointerBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearPointerBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearPointerBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearPointerBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

LinearPointerCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerCollection Events

The LinearPointerCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearPointerBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearPointerBase .)
Top
See Also

Reference

LinearPointerCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel Class

Represents a text pointer for use in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearPointerBase
ActiproSoftware.Windows.Controls.GaugeLinearPointerLabel

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearPointerLabel : LinearPointerBase
Public Class LinearPointerLabel
    Inherits LinearPointerBase

The LinearPointerLabel type exposes the following members.

Constructors
 | Name | Description
Public method | LinearPointerLabel | Initializes a new instance of the LinearPointerLabel class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property.
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property.
Public property | FontSize | Gets or sets the size of the font. This is a dependency property.
Public property | FontStyle | Gets or sets the font style. This is a dependency property.
Public property | FontWeight | Gets or sets the font weight. This is a dependency property.
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearPointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Public property | Text | Gets or sets the text that should be rendered at the specified value. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property.
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueExtent | Gets or sets the extent used to display the Value on the linear gauge. This is a dependency property. (Inherited from LinearPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified extent. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from LinearPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from LinearPointerBase.)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from LinearPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueExtent | Updates the ValueExtent property. (Inherited from LinearPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
AngleProperty | Identifies the Angle dependency property. This field is read-only.
FontFamilyProperty | Identifies the FontFamily dependency property. This field is read-only.
FontSizeProperty | Identifies the FontSize dependency property. This field is read-only.
FontStyleProperty | Identifies the FontStyle dependency property. This field is read-only.
FontWeightProperty | Identifies the FontWeight dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
RoundModeProperty | Identifies the RoundMode dependency property. This field is read-only.
TextFormatProperty | Identifies the TextFormat dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel Constructor

Initializes a new instance of the LinearPointerLabel class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearPointerLabel()
Public Sub New
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel Properties

The LinearPointerLabel type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property.
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property.
Public property | FontSize | Gets or sets the size of the font. This is a dependency property.
Public property | FontStyle | Gets or sets the font style. This is a dependency property.
Public property | FontWeight | Gets or sets the font weight. This is a dependency property.
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearPointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Public property | Text | Gets or sets the text that should be rendered at the specified value. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property.
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueExtent | Gets or sets the extent used to display the Value on the linear gauge. This is a dependency property. (Inherited from LinearPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.Angle Property

LinearPointerLabelAngle Property

Gets or sets the angle used to render the tick. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
The angle. The default value is 0.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.FontFamily Property

LinearPointerLabelFontFamily Property

Gets or sets the font family. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontFamily FontFamily { get; set; }
Public Property FontFamily As FontFamily
    Get
    Set

Property Value

Type: FontFamily
The font family. The default value is SystemFonts.MessageFontFamily.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.FontSize Property

LinearPointerLabelFontSize Property

Gets or sets the size of the font. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit FontSize { get; set; }
Public Property FontSize As Unit
    Get
    Set

Property Value

Type: Unit
The size of the font. The default value is SystemFonts.MesssageFontSize.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.FontStyle Property

LinearPointerLabelFontStyle Property

Gets or sets the font style. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontStyle FontStyle { get; set; }
Public Property FontStyle As FontStyle
    Get
    Set

Property Value

Type: FontStyle
The font style. The default value is SystemFonts.MessageFontStyle.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.FontWeight Property

LinearPointerLabelFontWeight Property

Gets or sets the font weight. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontWeight FontWeight { get; set; }
Public Property FontWeight As FontWeight
    Get
    Set

Property Value

Type: FontWeight
The font weight. The default value is SystemFonts.MessageFontWeight.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.Foreground Property

LinearPointerLabelForeground Property

Gets or sets the foreground brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Foreground { get; set; }
Public Property Foreground As Brush
    Get
    Set

Property Value

Type: Brush
The foreground brush. The default value is WhiteSmoke.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.RoundMode Property

LinearPointerLabelRoundMode Property

Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RoundMode RoundMode { get; set; }
Public Property RoundMode As RoundMode
    Get
    Set

Property Value

Type: RoundMode
A RoundMode indicating how to round the values displayed. The default value is RoundMode.Round.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.Text Property

LinearPointerLabelText Property

Gets or sets the text that should be rendered at the specified value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text that should be rendered. The default value is .
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.TextFormat Property

LinearPointerLabelTextFormat Property

Gets or sets the format used to convert Value to a string. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TextFormat { get; set; }
Public Property TextFormat As String
    Get
    Set

Property Value

Type: String
The format used to convert Value to a string. The default value is "{0:G}".
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel Methods

The LinearPointerLabel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified extent. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from LinearPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from LinearPointerBase.)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from LinearPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueExtent | Updates the ValueExtent property. (Inherited from LinearPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.GetValueText Method

LinearPointerLabelGetValueText Method

Gets the string representation of the specified value, using TextFormat and RoundMode.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string GetValueText(
    double value
)
Protected Overridable Function GetValueText (
    value As Double
) As String

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.OnRender Method

LinearPointerLabelOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel Events

The LinearPointerLabel type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel Fields

The LinearPointerLabel type exposes the following members.

Fields
Name | Description
AngleProperty | Identifies the Angle dependency property. This field is read-only.
FontFamilyProperty | Identifies the FontFamily dependency property. This field is read-only.
FontSizeProperty | Identifies the FontSize dependency property. This field is read-only.
FontStyleProperty | Identifies the FontStyle dependency property. This field is read-only.
FontWeightProperty | Identifies the FontWeight dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
RoundModeProperty | Identifies the RoundMode dependency property. This field is read-only.
TextFormatProperty | Identifies the TextFormat dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
Top
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.AngleProperty Field

LinearPointerLabelAngleProperty Field

Identifies the Angle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AngleProperty
Public Shared ReadOnly AngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Angle dependency property.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.FontFamilyProperty Field

LinearPointerLabelFontFamilyProperty Field

Identifies the FontFamily dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontFamilyProperty
Public Shared ReadOnly FontFamilyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontFamily dependency property.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.FontSizeProperty Field

LinearPointerLabelFontSizeProperty Field

Identifies the FontSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontSizeProperty
Public Shared ReadOnly FontSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontSize dependency property.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.FontStyleProperty Field

LinearPointerLabelFontStyleProperty Field

Identifies the FontStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontStyleProperty
Public Shared ReadOnly FontStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontStyle dependency property.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.FontWeightProperty Field

LinearPointerLabelFontWeightProperty Field

Identifies the FontWeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontWeightProperty
Public Shared ReadOnly FontWeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontWeight dependency property.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.ForegroundProperty Field

LinearPointerLabelForegroundProperty Field

Identifies the Foreground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundProperty
Public Shared ReadOnly ForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Foreground dependency property.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.RoundModeProperty Field

LinearPointerLabelRoundModeProperty Field

Identifies the RoundMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundModeProperty
Public Shared ReadOnly RoundModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundMode dependency property.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.TextFormatProperty Field

LinearPointerLabelTextFormatProperty Field

Identifies the TextFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextFormatProperty
Public Shared ReadOnly TextFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextFormat dependency property.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerLabel.TextProperty Field

LinearPointerLabelTextProperty Field

Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

LinearPointerLabel Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker Class

Represents a marker pointer for use in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearPointerBase
ActiproSoftware.Windows.Controls.GaugeLinearPointerMarker

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearPointerMarker : LinearPointerBase
Public Class LinearPointerMarker
    Inherits LinearPointerBase

The LinearPointerMarker type exposes the following members.

Constructors
 | Name | Description
Public method | LinearPointerMarker | Initializes a new instance of the LinearPointerMarker class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Public property | MarkerType | Gets or sets the type of marker rendered. This is a dependency property.
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearPointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueExtent | Gets or sets the extent used to display the Value on the linear gauge. This is a dependency property. (Inherited from LinearPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified extent. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from LinearPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from LinearPointerBase.)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from LinearPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueExtent | Updates the ValueExtent property. (Inherited from LinearPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
MarkerTypeProperty | Identifies the MarkerType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker Constructor

Initializes a new instance of the LinearPointerMarker class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearPointerMarker()
Public Sub New
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker Properties

The LinearPointerMarker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Public property | MarkerType | Gets or sets the type of marker rendered. This is a dependency property.
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearPointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearPointerBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueExtent | Gets or sets the extent used to display the Value on the linear gauge. This is a dependency property. (Inherited from LinearPointerBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker.Geometry Property

LinearPointerMarkerGeometry Property

Gets or sets the custom geometry. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry Geometry { get; set; }
Public Property Geometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry. The default value is .
Remarks
This property is only used when MarkerType is set to PointerMarkerType.CustomGeometry.
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker.ImageSource Property

LinearPointerMarkerImageSource Property

Gets or sets the source of a custom image. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source. The default value is .
Remarks
This property is only used when MarkerType is set to PointerMarkerType.CustomImage.
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker.MarkerType Property

LinearPointerMarkerMarkerType Property

Gets or sets the type of marker rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointerMarkerType MarkerType { get; set; }
Public Property MarkerType As PointerMarkerType
    Get
    Set

Property Value

Type: PointerMarkerType
The type of marker rendered. The default value is PointerMarkerType.Diamond.
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker Methods

The LinearPointerMarker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Double) | Calculates the value based on a specified extent. (Inherited from LinearPointerBase.)
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Inherited from LinearPointerBase.)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from LinearPointerBase.)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property. (Inherited from LinearPointerBase.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueExtent | Updates the ValueExtent property. (Inherited from LinearPointerBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker.OnRender Method

LinearPointerMarkerOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker Events

The LinearPointerMarker type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker Fields

The LinearPointerMarker type exposes the following members.

Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
MarkerTypeProperty | Identifies the MarkerType dependency property. This field is read-only.
Top
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker.GeometryProperty Field

LinearPointerMarkerGeometryProperty Field

Identifies the Geometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GeometryProperty
Public Shared ReadOnly GeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Geometry dependency property.
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker.ImageSourceProperty Field

LinearPointerMarkerImageSourceProperty Field

Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearPointerMarker.MarkerTypeProperty Field

LinearPointerMarkerMarkerTypeProperty Field

Identifies the MarkerType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerTypeProperty
Public Shared ReadOnly MarkerTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerType dependency property.
See Also

Reference

LinearPointerMarker Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange Class

Represents an element that renders a range in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesRangeBase
ActiproSoftware.Windows.Controls.GaugeLinearRange

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearRange : RangeBase
Public Class LinearRange
    Inherits RangeBase

The LinearRange type exposes the following members.

Constructors
 | Name | Description
Public method | LinearRange | Initializes a new instance of the LinearRange class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from RangeBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndAscent | Gets or sets the ascent of the range at the EndValue. This is a dependency property.
Public property | EndValue | Gets or sets the end value of the range. This is a dependency property. (Inherited from RangeBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from RangeBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from RangeBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from RangeBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from RangeBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from RangeBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from RangeBase.)
Protected property | Orientation | Gets the orientation of this element, which is inherited/set via an attached property on LinearGauge.
Protected property | ScaleBarAscent | Gets the ascent of the scale bar, which is inherited/set via an attached property on LinearScale.
Protected property | ScaleBarExtent | Gets the extent of the scale bar, which is inherited/set via an attached property on ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from RangeBase.)
Public property | ScalePlacement | Gets or sets the placement of the range relative to the scale. This is a dependency property. (Inherited from RangeBase.)
Public property | StartAscent | Gets or sets the ascent of the range at the StartValue. This is a dependency property.
Public property | StartValue | Gets or sets the start value of the range. This is a dependency property. (Inherited from RangeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndAscentProperty | Identifies the EndAscent dependency property. This field is read-only.
StartAscentProperty | Identifies the StartAscent dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange Constructor

Initializes a new instance of the LinearRange class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearRange()
Public Sub New
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange Properties

The LinearRange type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from RangeBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from RangeBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndAscent | Gets or sets the ascent of the range at the EndValue. This is a dependency property.
Public property | EndValue | Gets or sets the end value of the range. This is a dependency property. (Inherited from RangeBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from RangeBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from RangeBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from RangeBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from RangeBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from RangeBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from RangeBase.)
Protected property | Orientation | Gets the orientation of this element, which is inherited/set via an attached property on LinearGauge.
Protected property | ScaleBarAscent | Gets the ascent of the scale bar, which is inherited/set via an attached property on LinearScale.
Protected property | ScaleBarExtent | Gets the extent of the scale bar, which is inherited/set via an attached property on ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from RangeBase.)
Public property | ScalePlacement | Gets or sets the placement of the range relative to the scale. This is a dependency property. (Inherited from RangeBase.)
Public property | StartAscent | Gets or sets the ascent of the range at the StartValue. This is a dependency property.
Public property | StartValue | Gets or sets the start value of the range. This is a dependency property. (Inherited from RangeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange.EndAscent Property

LinearRangeEndAscent Property

Gets or sets the ascent of the range at the EndValue. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit EndAscent { get; set; }
Public Property EndAscent As Unit
    Get
    Set

Property Value

Type: Unit
The ascent of the range at the EndValue. The default value is 5 pixels.
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange.Orientation Property

LinearRangeOrientation Property

Gets the orientation of this element, which is inherited/set via an attached property on LinearGauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Orientation Orientation { get; }
Protected ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The orientation.
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange.ScaleBarAscent Property

LinearRangeScaleBarAscent Property

Gets the ascent of the scale bar, which is inherited/set via an attached property on LinearScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ScaleBarAscent { get; }
Protected ReadOnly Property ScaleBarAscent As Double
    Get

Property Value

Type: Double
The ascent of the bar.
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange.ScaleBarExtent Property

LinearRangeScaleBarExtent Property

Gets the extent of the scale bar, which is inherited/set via an attached property on ScaleBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ScaleBarExtent { get; }
Protected ReadOnly Property ScaleBarExtent As Double
    Get

Property Value

Type: Double
The extent of the bar.
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange.StartAscent Property

LinearRangeStartAscent Property

Gets or sets the ascent of the range at the StartValue. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit StartAscent { get; set; }
Public Property StartAscent As Unit
    Get
    Set

Property Value

Type: Unit
The ascent of the range at the StartValue. The default value is 5 pixels.
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange Methods

The LinearRange type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange.OnRender Method

LinearRangeOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange Fields

The LinearRange type exposes the following members.

Fields
Name | Description
EndAscentProperty | Identifies the EndAscent dependency property. This field is read-only.
StartAscentProperty | Identifies the StartAscent dependency property. This field is read-only.
Top
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange.EndAscentProperty Field

LinearRangeEndAscentProperty Field

Identifies the EndAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndAscentProperty
Public Shared ReadOnly EndAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndAscent dependency property.
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRange.StartAscentProperty Field

LinearRangeStartAscentProperty Field

Identifies the StartAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartAscentProperty
Public Shared ReadOnly StartAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartAscent dependency property.
See Also

Reference

LinearRange Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRangeCollection Class

Represents a collection of LinearRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection LinearRange
System.Collections.ObjectModelObservableCollection LinearRange
ActiproSoftware.WindowsDeferrableObservableCollection LinearRange
ActiproSoftware.WindowsLogicalChildrenCollection LinearRange
ActiproSoftware.Windows.Controls.GaugeLinearRangeCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearRangeCollection : LogicalChildrenCollection<LinearRange>
Public Class LinearRangeCollection
    Inherits LogicalChildrenCollection(Of LinearRange)

The LinearRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LinearRangeCollection | Initializes a new instance of the LinearRangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearRange .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearRange .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearRange .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRangeCollection Constructor

Initializes a new instance of the LinearRangeCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearRangeCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

LinearRangeCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRangeCollection Properties

The LinearRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearRange .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

LinearRangeCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRangeCollection Methods

The LinearRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearRange .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

LinearRangeCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearRangeCollection Events

The LinearRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearRange .)
Top
See Also

Reference

LinearRangeCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale Class

Represents a scale for use in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesScaleBase
ActiproSoftware.Windows.Controls.GaugeLinearScale

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearScale : ScaleBase
Public Class LinearScale
    Inherits ScaleBase

The LinearScale type exposes the following members.

Constructors
 | Name | Description
Public method | LinearScale | Initializes a new instance of the LinearScale class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from ScaleBase.)
Public property | BarAscent | Gets or sets the ascent of the bar. This is a dependency property.
Public property | BarExtent | Gets or sets the extent of the bar. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from ScaleBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsBarVisible | Gets or sets a value indicating whether the scale renders an associated bar. This is a dependency property. (Inherited from ScaleBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Protected property | Orientation | Gets the orientation of this element, which is inherited/set via an attached property on LinearGauge.
Public property | TickSets | Gets the tick-set elements within the scale.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetBarAscent | Gets the value of the BarAscentProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate ScaleBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from ScaleBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetBarAscent | Sets the value of the BarAscentProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BarAscentProperty | Identifies the BarAscent dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale Constructor

Initializes a new instance of the LinearScale class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearScale()
Public Sub New
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale Properties

The LinearScale type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from ScaleBase.)
Public property | BarAscent | Gets or sets the ascent of the bar. This is a dependency property.
Public property | BarExtent | Gets or sets the extent of the bar. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from ScaleBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from ScaleBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsBarVisible | Gets or sets a value indicating whether the scale renders an associated bar. This is a dependency property. (Inherited from ScaleBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Protected property | Orientation | Gets the orientation of this element, which is inherited/set via an attached property on LinearGauge.
Public property | TickSets | Gets the tick-set elements within the scale.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.BarAscent Property

LinearScaleBarAscent Property

Gets or sets the ascent of the bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit BarAscent { get; set; }
Public Property BarAscent As Unit
    Get
    Set

Property Value

Type: Unit
The ascent of the bar. The default value is 5 pixels.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.LogicalChildren Property

LinearScaleLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.Orientation Property

LinearScaleOrientation Property

Gets the orientation of this element, which is inherited/set via an attached property on LinearGauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Orientation Orientation { get; }
Protected ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The orientation.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.TickSets Property

LinearScaleTickSets Property

Gets the tick-set elements within the scale.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickSetCollection TickSets { get; }
Public ReadOnly Property TickSets As LinearTickSetCollection
    Get

Property Value

Type: LinearTickSetCollection
The tick-sets.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale Methods

The LinearScale type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetBarAscent | Gets the value of the BarAscentProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate ScaleBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from ScaleBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetBarAscent | Sets the value of the BarAscentProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.ArrangeOverride Method

LinearScaleArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.GetBarAscent Method

LinearScaleGetBarAscent Method

Gets the value of the BarAscentProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit GetBarAscent(
    DependencyObject obj
)
Public Shared Function GetBarAscent (
    obj As DependencyObject
) As Unit

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Unit
The bar ascent.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.MeasureOverride Method

LinearScaleMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.OnRender Method

LinearScaleOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.SetBarAscent Method

LinearScaleSetBarAscent Method

Sets the value of the BarAscentProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetBarAscent(
    DependencyObject obj,
    Unit value
)
Public Shared Sub SetBarAscent (
    obj As DependencyObject,
    value As Unit
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.WindowsUnit
The bar ascent.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale Fields

The LinearScale type exposes the following members.

Fields
Name | Description
BarAscentProperty | Identifies the BarAscent dependency property. This field is read-only.
Top
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScale.BarAscentProperty Field

LinearScaleBarAscentProperty Field

Identifies the BarAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarAscentProperty
Public Shared ReadOnly BarAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarAscent dependency property.
See Also

Reference

LinearScale Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScaleCollection Class

Represents a collection of LinearScale objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection LinearScale
System.Collections.ObjectModelObservableCollection LinearScale
ActiproSoftware.WindowsDeferrableObservableCollection LinearScale
ActiproSoftware.WindowsLogicalChildrenCollection LinearScale
ActiproSoftware.Windows.Controls.GaugeLinearScaleCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearScaleCollection : LogicalChildrenCollection<LinearScale>
Public Class LinearScaleCollection
    Inherits LogicalChildrenCollection(Of LinearScale)

The LinearScaleCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LinearScaleCollection | Initializes a new instance of the LinearScaleCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearScale .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearScale .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearScale .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearScale .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearScale .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearScale .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearScale .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearScale .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearScale .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearScale .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearScale .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearScale .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearScale .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearScale .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearScale .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearScale .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearScale .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearScale .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScaleCollection Constructor

Initializes a new instance of the LinearScaleCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearScaleCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

LinearScaleCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScaleCollection Properties

The LinearScaleCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearScale .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearScale .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearScale .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

LinearScaleCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScaleCollection Methods

The LinearScaleCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearScale .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearScale .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearScale .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearScale .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearScale .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearScale .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearScale .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearScale .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearScale .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearScale .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearScale .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearScale .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearScale .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

LinearScaleCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearScaleCollection Events

The LinearScaleCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearScale .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearScale .)
Top
See Also

Reference

LinearScaleCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickCollection Class

Represents a collection of LinearTickBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection LinearTickBase
System.Collections.ObjectModelObservableCollection LinearTickBase
ActiproSoftware.WindowsDeferrableObservableCollection LinearTickBase
ActiproSoftware.WindowsLogicalChildrenCollection LinearTickBase
ActiproSoftware.Windows.Controls.GaugeLinearTickCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearTickCollection : LogicalChildrenCollection<LinearTickBase>
Public Class LinearTickCollection
    Inherits LogicalChildrenCollection(Of LinearTickBase)

The LinearTickCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LinearTickCollection | Initializes a new instance of the LinearTickCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearTickBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearTickBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearTickBase .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearTickBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearTickBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearTickBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearTickBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearTickBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearTickBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearTickBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearTickBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearTickBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearTickBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearTickBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearTickBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearTickBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearTickBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearTickBase .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickCollection Constructor

Initializes a new instance of the LinearTickCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

LinearTickCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickCollection Properties

The LinearTickCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearTickBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearTickBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearTickBase .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

LinearTickCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickCollection Methods

The LinearTickCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearTickBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearTickBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearTickBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearTickBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearTickBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearTickBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearTickBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearTickBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearTickBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearTickBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearTickBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearTickBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearTickBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

LinearTickCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickCollection Events

The LinearTickCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearTickBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearTickBase .)
Top
See Also

Reference

LinearTickCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom Class

Represents an element that renders a custom tick label in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickLabelBase
ActiproSoftware.Windows.Controls.GaugeLinearTickLabelCustom

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearTickLabelCustom : LinearTickLabelBase
Public Class LinearTickLabelCustom
    Inherits LinearTickLabelBase

The LinearTickLabelCustom type exposes the following members.

Constructors
 | Name | Description
Public method | LinearTickLabelCustom | Initializes a new instance of the LinearTickLabelCustom class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | Text | Gets or sets the text that should be rendered at the specified Value. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | Value | Gets or sets the value where the custom tick label should be placed. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides LinearTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value. (Overrides LinearTickLabelBaseGetValueText(Double).)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
TextProperty | Identifies the Text dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom Constructor

Initializes a new instance of the LinearTickLabelCustom class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickLabelCustom()
Public Sub New
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom Properties

The LinearTickLabelCustom type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | Text | Gets or sets the text that should be rendered at the specified Value. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | Value | Gets or sets the value where the custom tick label should be placed. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom.Text Property

LinearTickLabelCustomText Property

Gets or sets the text that should be rendered at the specified Value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text that should be rendered. The default value is .
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom.Value Property

LinearTickLabelCustomValue Property

Gets or sets the value where the custom tick label should be placed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value where the custom tick label should be placed. The default value is 0.
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom Methods

The LinearTickLabelCustom type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides LinearTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value. (Overrides LinearTickLabelBaseGetValueText(Double).)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom.GetValues Method

LinearTickLabelCustomGetValues Method

Gets the values to be rendered by this tick label element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick label element.
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom.GetValueText Method

LinearTickLabelCustomGetValueText Method

Gets the string representation of the specified value.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetValueText(
    double value
)
Protected Overrides Function GetValueText (
    value As Double
) As String

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom Fields

The LinearTickLabelCustom type exposes the following members.

Fields
Name | Description
TextProperty | Identifies the Text dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom.TextProperty Field

LinearTickLabelCustomTextProperty Field

Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelCustom.ValueProperty Field

LinearTickLabelCustomValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

LinearTickLabelCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor Class

Represents an element that renders major tick labels in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickLabelBase
ActiproSoftware.Windows.Controls.GaugeLinearTickLabelMajor

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearTickLabelMajor : LinearTickLabelBase
Public Class LinearTickLabelMajor
    Inherits LinearTickLabelBase

The LinearTickLabelMajor type exposes the following members.

Constructors
 | Name | Description
Public method | LinearTickLabelMajor | Initializes a new instance of the LinearTickLabelMajor class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Public property | MaximumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinimumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides LinearTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode. (Inherited from LinearTickLabelBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
MaximumTickVisibilityProperty | Identifies the MaximumTickVisibility dependency property. This field is read-only.
MinimumTickVisibilityProperty | Identifies the MinimumTickVisibility dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor Constructor

Initializes a new instance of the LinearTickLabelMajor class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickLabelMajor()
Public Sub New
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor Properties

The LinearTickLabelMajor type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Public property | MaximumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinimumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.EndValue Property

LinearTickLabelMajorEndValue Property

Gets or sets the last value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndValue { get; set; }
Public Property EndValue As Double
    Get
    Set

Property Value

Type: Double
The last value that should be rendered. The default value is Double.NaN.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.MaximumTickVisibility Property

LinearTickLabelMajorMaximumTickVisibility Property

Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickVisibility MaximumTickVisibility { get; set; }
Public Property MaximumTickVisibility As TickVisibility
    Get
    Set

Property Value

Type: TickVisibility
The visibility of the maximum tick. The default value is Always.
Remarks
The SkipValues property takes precedence over this property.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.MinimumTickVisibility Property

LinearTickLabelMajorMinimumTickVisibility Property

Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickVisibility MinimumTickVisibility { get; set; }
Public Property MinimumTickVisibility As TickVisibility
    Get
    Set

Property Value

Type: TickVisibility
The visibility of the minimum tick. The default value is Always.
Remarks
The SkipValues property takes precedence over this property.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.SkipValues Property

LinearTickLabelMajorSkipValues Property

Gets or sets the values that should not be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleCollection SkipValues { get; set; }
Public Property SkipValues As DoubleCollection
    Get
    Set

Property Value

Type: DoubleCollection
The values that should not be rendered. The default value is .
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.StartValue Property

LinearTickLabelMajorStartValue Property

Gets or sets the first value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartValue { get; set; }
Public Property StartValue As Double
    Get
    Set

Property Value

Type: Double
The first value that should be rendered. The default value is Double.NaN.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor Methods

The LinearTickLabelMajor type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides LinearTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode. (Inherited from LinearTickLabelBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.GetValues Method

LinearTickLabelMajorGetValues Method

Gets the values to be rendered by this tick label element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick label element.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor Fields

The LinearTickLabelMajor type exposes the following members.

Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
MaximumTickVisibilityProperty | Identifies the MaximumTickVisibility dependency property. This field is read-only.
MinimumTickVisibilityProperty | Identifies the MinimumTickVisibility dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.EndValueProperty Field

LinearTickLabelMajorEndValueProperty Field

Identifies the EndValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndValueProperty
Public Shared ReadOnly EndValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndValue dependency property.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.MaximumTickVisibilityProperty Field

LinearTickLabelMajorMaximumTickVisibilityProperty Field

Identifies the MaximumTickVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumTickVisibilityProperty
Public Shared ReadOnly MaximumTickVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaximumTickVisibility dependency property.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.MinimumTickVisibilityProperty Field

LinearTickLabelMajorMinimumTickVisibilityProperty Field

Identifies the MinimumTickVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumTickVisibilityProperty
Public Shared ReadOnly MinimumTickVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinimumTickVisibility dependency property.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.SkipValuesProperty Field

LinearTickLabelMajorSkipValuesProperty Field

Identifies the SkipValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkipValuesProperty
Public Shared ReadOnly SkipValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkipValues dependency property.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMajor.StartValueProperty Field

LinearTickLabelMajorStartValueProperty Field

Identifies the StartValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartValueProperty
Public Shared ReadOnly StartValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartValue dependency property.
See Also

Reference

LinearTickLabelMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor Class

Represents an element that renders minor tick labels in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickLabelBase
ActiproSoftware.Windows.Controls.GaugeLinearTickLabelMinor

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearTickLabelMinor : LinearTickLabelBase
Public Class LinearTickLabelMinor
    Inherits LinearTickLabelBase

The LinearTickLabelMinor type exposes the following members.

Constructors
 | Name | Description
Public method | LinearTickLabelMinor | Initializes a new instance of the LinearTickLabelMinor class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides LinearTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode. (Inherited from LinearTickLabelBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor Constructor

Initializes a new instance of the LinearTickLabelMinor class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickLabelMinor()
Public Sub New
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor Properties

The LinearTickLabelMinor type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | FontFamily | Gets or sets the font family. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontSize | Gets or sets the size of the font. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | FontWeight | Gets or sets the font weight. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property. (Inherited from LinearTickLabelBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property. (Inherited from LinearTickLabelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor.EndValue Property

LinearTickLabelMinorEndValue Property

Gets or sets the last value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndValue { get; set; }
Public Property EndValue As Double
    Get
    Set

Property Value

Type: Double
The last value that should be rendered. The default value is Double.NaN.
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor.SkipValues Property

LinearTickLabelMinorSkipValues Property

Gets or sets the values that should not be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleCollection SkipValues { get; set; }
Public Property SkipValues As DoubleCollection
    Get
    Set

Property Value

Type: DoubleCollection
The values that should not be rendered. The default value is .
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor.StartValue Property

LinearTickLabelMinorStartValue Property

Gets or sets the first value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartValue { get; set; }
Public Property StartValue As Double
    Get
    Set

Property Value

Type: Double
The first value that should be rendered. The default value is Double.NaN.
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor Methods

The LinearTickLabelMinor type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element. (Overrides LinearTickLabelBaseGetValues.)
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode. (Inherited from LinearTickLabelBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickLabelBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor.GetValues Method

LinearTickLabelMinorGetValues Method

Gets the values to be rendered by this tick label element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick label element.
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor Fields

The LinearTickLabelMinor type exposes the following members.

Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor.EndValueProperty Field

LinearTickLabelMinorEndValueProperty Field

Identifies the EndValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndValueProperty
Public Shared ReadOnly EndValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndValue dependency property.
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor.SkipValuesProperty Field

LinearTickLabelMinorSkipValuesProperty Field

Identifies the SkipValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkipValuesProperty
Public Shared ReadOnly SkipValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkipValues dependency property.
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickLabelMinor.StartValueProperty Field

LinearTickLabelMinorStartValueProperty Field

Identifies the StartValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartValueProperty
Public Shared ReadOnly StartValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartValue dependency property.
See Also

Reference

LinearTickLabelMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkCustom Class

Represents an element that renders a custom tick mark in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickMarkBase
ActiproSoftware.Windows.Controls.GaugeLinearTickMarkCustom

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearTickMarkCustom : LinearTickMarkBase
Public Class LinearTickMarkCustom
    Inherits LinearTickMarkBase

The LinearTickMarkCustom type exposes the following members.

Constructors
 | Name | Description
Public method | LinearTickMarkCustom | Initializes a new instance of the LinearTickMarkCustom class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | Value | Gets or sets the value where the custom tick mark should be placed. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides LinearTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkCustom Constructor

Initializes a new instance of the LinearTickMarkCustom class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickMarkCustom()
Public Sub New
See Also

Reference

LinearTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkCustom Properties

The LinearTickMarkCustom type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | Value | Gets or sets the value where the custom tick mark should be placed. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkCustom.Value Property

LinearTickMarkCustomValue Property

Gets or sets the value where the custom tick mark should be placed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value where the custom tick mark should be placed. The default value is 0.
See Also

Reference

LinearTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkCustom Methods

The LinearTickMarkCustom type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides LinearTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkCustom.GetValues Method

LinearTickMarkCustomGetValues Method

Gets the values to be rendered by this tick mark element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick mark element.
See Also

Reference

LinearTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkCustom Fields

The LinearTickMarkCustom type exposes the following members.

Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

LinearTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkCustom.ValueProperty Field

LinearTickMarkCustomValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

LinearTickMarkCustom Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor Class

Represents an element that renders major tick marks in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickMarkBase
ActiproSoftware.Windows.Controls.GaugeLinearTickMarkMajor

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearTickMarkMajor : LinearTickMarkBase
Public Class LinearTickMarkMajor
    Inherits LinearTickMarkBase

The LinearTickMarkMajor type exposes the following members.

Constructors
 | Name | Description
Public method | LinearTickMarkMajor | Initializes a new instance of the LinearTickMarkMajor class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Public property | MaximumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinimumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides LinearTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
MaximumTickVisibilityProperty | Identifies the MaximumTickVisibility dependency property. This field is read-only.
MinimumTickVisibilityProperty | Identifies the MinimumTickVisibility dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor Constructor

Initializes a new instance of the LinearTickMarkMajor class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickMarkMajor()
Public Sub New
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor Properties

The LinearTickMarkMajor type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Public property | MaximumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinimumTickVisibility | Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.EndValue Property

LinearTickMarkMajorEndValue Property

Gets or sets the last value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndValue { get; set; }
Public Property EndValue As Double
    Get
    Set

Property Value

Type: Double
The last value that should be rendered. The default value is Double.NaN.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.MaximumTickVisibility Property

LinearTickMarkMajorMaximumTickVisibility Property

Gets or sets a value indicating whether a tick should be rendered at the maximum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickVisibility MaximumTickVisibility { get; set; }
Public Property MaximumTickVisibility As TickVisibility
    Get
    Set

Property Value

Type: TickVisibility
The visibility of the maximum tick. The default value is Always.
Remarks
The SkipValues property takes precedence over this property.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.MinimumTickVisibility Property

LinearTickMarkMajorMinimumTickVisibility Property

Gets or sets a value indicating whether a tick should be rendered at the minimum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickVisibility MinimumTickVisibility { get; set; }
Public Property MinimumTickVisibility As TickVisibility
    Get
    Set

Property Value

Type: TickVisibility
The visibility of the minimum tick. The default value is Always.
Remarks
The SkipValues property takes precedence over this property.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.SkipValues Property

LinearTickMarkMajorSkipValues Property

Gets or sets the values that should not be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleCollection SkipValues { get; set; }
Public Property SkipValues As DoubleCollection
    Get
    Set

Property Value

Type: DoubleCollection
The values that should not be rendered. The default value is .
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.StartValue Property

LinearTickMarkMajorStartValue Property

Gets or sets the first value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartValue { get; set; }
Public Property StartValue As Double
    Get
    Set

Property Value

Type: Double
The first value that should be rendered. The default value is Double.NaN.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor Methods

The LinearTickMarkMajor type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides LinearTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.GetValues Method

LinearTickMarkMajorGetValues Method

Gets the values to be rendered by this tick mark element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick mark element.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor Fields

The LinearTickMarkMajor type exposes the following members.

Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
MaximumTickVisibilityProperty | Identifies the MaximumTickVisibility dependency property. This field is read-only.
MinimumTickVisibilityProperty | Identifies the MinimumTickVisibility dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.EndValueProperty Field

LinearTickMarkMajorEndValueProperty Field

Identifies the EndValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndValueProperty
Public Shared ReadOnly EndValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndValue dependency property.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.MaximumTickVisibilityProperty Field

LinearTickMarkMajorMaximumTickVisibilityProperty Field

Identifies the MaximumTickVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumTickVisibilityProperty
Public Shared ReadOnly MaximumTickVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaximumTickVisibility dependency property.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.MinimumTickVisibilityProperty Field

LinearTickMarkMajorMinimumTickVisibilityProperty Field

Identifies the MinimumTickVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumTickVisibilityProperty
Public Shared ReadOnly MinimumTickVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinimumTickVisibility dependency property.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.SkipValuesProperty Field

LinearTickMarkMajorSkipValuesProperty Field

Identifies the SkipValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkipValuesProperty
Public Shared ReadOnly SkipValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkipValues dependency property.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMajor.StartValueProperty Field

LinearTickMarkMajorStartValueProperty Field

Identifies the StartValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartValueProperty
Public Shared ReadOnly StartValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartValue dependency property.
See Also

Reference

LinearTickMarkMajor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor Class

Represents an element that renders minor tick marks in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickMarkBase
ActiproSoftware.Windows.Controls.GaugeLinearTickMarkMinor

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearTickMarkMinor : LinearTickMarkBase
Public Class LinearTickMarkMinor
    Inherits LinearTickMarkBase

The LinearTickMarkMinor type exposes the following members.

Constructors
 | Name | Description
Public method | LinearTickMarkMinor | Initializes a new instance of the LinearTickMarkMinor class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides LinearTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor Constructor

Initializes a new instance of the LinearTickMarkMinor class

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickMarkMinor()
Public Sub New
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor Properties

The LinearTickMarkMinor type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the last value that should be rendered. This is a dependency property.
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | SkipValues | Gets or sets the values that should not be rendered. This is a dependency property.
Public property | StartValue | Gets or sets the first value that should be rendered. This is a dependency property.
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property. (Inherited from LinearTickMarkBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor.EndValue Property

LinearTickMarkMinorEndValue Property

Gets or sets the last value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndValue { get; set; }
Public Property EndValue As Double
    Get
    Set

Property Value

Type: Double
The last value that should be rendered. The default value is Double.NaN.
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor.SkipValues Property

LinearTickMarkMinorSkipValues Property

Gets or sets the values that should not be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DoubleCollection SkipValues { get; set; }
Public Property SkipValues As DoubleCollection
    Get
    Set

Property Value

Type: DoubleCollection
The values that should not be rendered. The default value is .
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor.StartValue Property

LinearTickMarkMinorStartValue Property

Gets or sets the first value that should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartValue { get; set; }
Public Property StartValue As Double
    Get
    Set

Property Value

Type: Double
The first value that should be rendered. The default value is Double.NaN.
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor Methods

The LinearTickMarkMinor type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element. (Overrides LinearTickMarkBaseGetValues.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from LinearTickMarkBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor.GetValues Method

LinearTickMarkMinorGetValues Method

Gets the values to be rendered by this tick mark element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DoubleCollection GetValues()
Protected Overrides Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick mark element.
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor Fields

The LinearTickMarkMinor type exposes the following members.

Fields
Name | Description
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
SkipValuesProperty | Identifies the SkipValues dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor.EndValueProperty Field

LinearTickMarkMinorEndValueProperty Field

Identifies the EndValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndValueProperty
Public Shared ReadOnly EndValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndValue dependency property.
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor.SkipValuesProperty Field

LinearTickMarkMinorSkipValuesProperty Field

Identifies the SkipValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SkipValuesProperty
Public Shared ReadOnly SkipValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SkipValues dependency property.
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickMarkMinor.StartValueProperty Field

LinearTickMarkMinorStartValueProperty Field

Identifies the StartValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartValueProperty
Public Shared ReadOnly StartValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartValue dependency property.
See Also

Reference

LinearTickMarkMinor Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet Class

Represents a tick set used in a LinearGauge.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickSetBase
ActiproSoftware.Windows.Controls.GaugeLinearTickSet

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearTickSet : TickSetBase
Public Class LinearTickSet
    Inherits TickSetBase

The LinearTickSet type exposes the following members.

Constructors
 | Name | Description
Public method | LinearTickSet | Initializes a new instance of the LinearTickSet class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickSetBase.)
Public property | IsLogarithmic | Gets or sets a value indicating whether this instance uses a logarithmic scale. This is a dependency property. (Inherited from TickSetBase.)
Public property | IsReversed | Gets or sets a value indicating whether this instance is reversed. This is a dependency property. (Inherited from TickSetBase.)
Public property | LogarithmicBase | Gets or sets the base of the logarithm used when IsLogarithmic is set to true. This is a dependency property. (Inherited from TickSetBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickSetBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickSetBase.)
Public property | Maximum | Gets or sets the maximum value. This is a dependency property. (Inherited from TickSetBase.)
Public property | Minimum | Gets or sets the minimum value. This is a dependency property. (Inherited from TickSetBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickSetBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickSetBase.)
Public property | Pointers | Gets the pointer elements within the tick-set.
Public property | Ranges | Gets the range elements within the tick-set.
Public property | Ticks | Gets the tick mark and label elements within the tick-set.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet Constructor

Initializes a new instance of the LinearTickSet class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickSet()
Public Sub New
See Also

Reference

LinearTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet Properties

The LinearTickSet type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickSetBase.)
Public property | IsLogarithmic | Gets or sets a value indicating whether this instance uses a logarithmic scale. This is a dependency property. (Inherited from TickSetBase.)
Public property | IsReversed | Gets or sets a value indicating whether this instance is reversed. This is a dependency property. (Inherited from TickSetBase.)
Public property | LogarithmicBase | Gets or sets the base of the logarithm used when IsLogarithmic is set to true. This is a dependency property. (Inherited from TickSetBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickSetBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickSetBase.)
Public property | Maximum | Gets or sets the maximum value. This is a dependency property. (Inherited from TickSetBase.)
Public property | Minimum | Gets or sets the minimum value. This is a dependency property. (Inherited from TickSetBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickSetBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickSetBase.)
Public property | Pointers | Gets the pointer elements within the tick-set.
Public property | Ranges | Gets the range elements within the tick-set.
Public property | Ticks | Gets the tick mark and label elements within the tick-set.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet.LogicalChildren Property

LinearTickSetLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

LinearTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet.Pointers Property

LinearTickSetPointers Property

Gets the pointer elements within the tick-set.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearPointerCollection Pointers { get; }
Public ReadOnly Property Pointers As LinearPointerCollection
    Get

Property Value

Type: LinearPointerCollection
The pointers.
See Also

Reference

LinearTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet.Ranges Property

LinearTickSetRanges Property

Gets the range elements within the tick-set.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearRangeCollection Ranges { get; }
Public ReadOnly Property Ranges As LinearRangeCollection
    Get

Property Value

Type: LinearRangeCollection
The ranges.
See Also

Reference

LinearTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet.Ticks Property

LinearTickSetTicks Property

Gets the tick mark and label elements within the tick-set.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickCollection Ticks { get; }
Public ReadOnly Property Ticks As LinearTickCollection
    Get

Property Value

Type: LinearTickCollection
The tick marks and labels.
See Also

Reference

LinearTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet Methods

The LinearTickSet type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet.ArrangeOverride Method

LinearTickSetArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

LinearTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSet.MeasureOverride Method

LinearTickSetMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

LinearTickSet Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSetCollection Class

Represents a collection of LinearTickSet objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection LinearTickSet
System.Collections.ObjectModelObservableCollection LinearTickSet
ActiproSoftware.WindowsDeferrableObservableCollection LinearTickSet
ActiproSoftware.WindowsLogicalChildrenCollection LinearTickSet
ActiproSoftware.Windows.Controls.GaugeLinearTickSetCollection

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LinearTickSetCollection : LogicalChildrenCollection<LinearTickSet>
Public Class LinearTickSetCollection
    Inherits LogicalChildrenCollection(Of LinearTickSet)

The LinearTickSetCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LinearTickSetCollection | Initializes a new instance of the LinearTickSetCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearTickSet .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearTickSet .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearTickSet .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearTickSet .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearTickSet .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearTickSet .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearTickSet .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearTickSet .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearTickSet .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearTickSet .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearTickSet .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearTickSet .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearTickSet .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearTickSet .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearTickSet .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearTickSet .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearTickSet .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearTickSet .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSetCollection Constructor

Initializes a new instance of the LinearTickSetCollection class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LinearTickSetCollection(
    ILogicalParent parent
)
Public Sub New (
    parent As ILogicalParent
)

Parameters

parent
Type: ActiproSoftware.WindowsILogicalParent
The parent.
See Also

Reference

LinearTickSetCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSetCollection Properties

The LinearTickSetCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection LinearTickSet .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection LinearTickSet .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection LinearTickSet .)
Public property | Parent | Gets the logical parent of the items in this collection. (Inherited from LogicalChildrenCollectionT.)
Top
See Also

Reference

LinearTickSetCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSetCollection Methods

The LinearTickSetCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection LinearTickSet .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection LinearTickSet .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection LinearTickSet .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection LinearTickSet .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from LogicalChildrenCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection LinearTickSet .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection LinearTickSet .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection LinearTickSet .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection LinearTickSet .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection LinearTickSet .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearTickSet .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection LinearTickSet .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection LinearTickSet .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection LinearTickSet .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from LogicalChildrenCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from LogicalChildrenCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

LinearTickSetCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


LinearTickSetCollection Events

The LinearTickSetCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection LinearTickSet .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection LinearTickSet .)
Top
See Also

Reference

LinearTickSetCollection Class
ActiproSoftware.Windows.Controls.Gauge Namespace


PointerBarOrigin Enumeration

Specifies the origins supported by the CircularPointerBar element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PointerBarOrigin
Public Enumeration PointerBarOrigin
Members
Member name | Value | Description
Minimum | 0 | Indicates that the bar should start at the minimum value.
Maximum | 1 | Indicates that the bar should start at the maximum value.
Zero | 2 | Indicates that the bar should start at zero.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


PointerBarType Enumeration

Specifies the types of markers supported by the LinearPointerBar element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PointerBarType
Public Enumeration PointerBarType
Members
Member name | Value | Description
Rectangle | 0 | Indicates a rectangle shaped bar.
RoundedRectangle | 1 | Indicates a rounded rectangle shaped bar.
CircleBulbRectangle | 2 | Indicates a rectangle shaped bar with a bulb.
CircleBulbRoundedRectangle | 3 | Indicates a rounded rectangle shaped bar with a bulb.
SegmentedRectangle | 4 | Indicates a rectangle shaped bar with segments.
SegmentedRoundedRectangle | 5 | Indicates a rounded rectangle shaped bar with segments.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


PointerCapType Enumeration

Specifies the types of caps supported by the CircularPointerCap element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PointerCapType
Public Enumeration PointerCapType
Members
Member name | Value | Description
CircleConcave | 0 | Indicates a circle-shaped cap with a concave surface.
CircleConvex | 1 | Indicates a circle-shaped cap with a convex surface.
CircleFlat | 2 | Indicates a circle-shaped cap with a flat surface.
CircleShiny | 3 | Indicates a circle-shaped cap with a shiny surface.
GearConcave | 4 | Indicates a gear-shaped cap with a concave surface.
GearConvex | 5 | Indicates a gear-shaped cap with a convex surface.
GearFlat | 6 | Indicates a gear-shaped cap with a flat surface.
GearShiny | 7 | Indicates a gear-shaped cap with a shiny surface.
CustomImage | 8 | Indicates the cap will be based on a custom image.
CustomGeometry | 9 | Indicates the cap will be based on a custom geometry.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


PointerMarkerType Enumeration

Specifies the types of markers supported by the CircularPointerMarker and LinearPointerMarker elements.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PointerMarkerType
Public Enumeration PointerMarkerType
Members
Member name | Value | Description
Circle | 0 | Indicates a circle shaped marker.
Diamond | 1 | A diamond shaped marker.
Ellipse | 2 | Indicates an ellipse shaped marker.
Rectangle | 3 | Indicates a rectangle shaped marker.
RoundedRectangle | 4 | Indicates a rounded rectangle shaped marker.
SwordBlunt | 5 | Indicates a sword shaped marker with a blunt tip.
SwordSharp | 6 | Indicates a sword shaped marker with a sharp tip.
TriangleBlunt | 7 | Indicates a triangle shaped marker with a blunt tip.
TriangleSharp | 8 | Indicates a triangle shaped marker with a sharp tip.
CustomImage | 9 | Indicates the marker will be based on a custom image.
CustomGeometry | 10 | Indicates the marker will be based on a custom geometry.
DoubleCircleBar | 11 | A double-circle bar shaped marker.
DoubleRectangleBar | 12 | A double-rectangle bar shaped marker.
DoubleTriangleBar | 13 | A double-triangle bar shaped marker.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


PointerNeedleType Enumeration

Specifies the types of needles supported by a CircularPointerNeedle element.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PointerNeedleType
Public Enumeration PointerNeedleType
Members
Member name | Value | Description
Rectangle | 0 | Indicates a rectangle shaped needle.
RoundedRectangle | 1 | Indicates a rounded rectangle shaped needle.
SwordBlunt | 2 | Indicates a sword shaped needle with a blunt tip.
SwordSharp | 3 | Indicates a sword shaped needle with a sharp tip.
Teardrop | 4 | Indicates a tear-drop shaped needle.
TriangleBlunt | 5 | Indicates a triangle shaped needle with a blunt tip.
TriangleSharp | 6 | Indicates a triangle shaped needle with a sharp tip.
PivotRectangle | 7 | Indicates a rectangle shaped needle with a centered circle.
PivotRoundedRectangle | 8 | Indicates a rounded rectangle shaped needle with a centered circle.
PivotSwordBlunt | 9 | Indicates a sword shaped needle with a blunt tip and a centered circle.
PivotSwordSharp | 10 | Indicates a sword shaped needle with a sharp tip and a centered circle.
PivotTeardrop | 11 | Indicates a tear-drop shaped needle with a centered circle.
PivotTriangleBlunt | 12 | Indicates a triangle shaped needle with a blunt tip and a centered circle.
PivotTriangleSharp | 13 | Indicates a triangle shaped needle with a sharp tip and a centered circle.
Knob | 14 | Indicates a gear shaped needle.
CustomImage | 15 | Indicates the needle will be based on a custom image.
CustomGeometry | 16 | Indicates the needle will be based on a custom geometry.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


RectangularBackgroundType Enumeration

Specifies the types of backgrounds supported by RectangularGaugeBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum RectangularBackgroundType
Public Enumeration RectangularBackgroundType
Members
Member name | Value | Description
ClippedRectangle | 0 | Indicates a clipped rectangle frame.
CustomBackgroundGeometry | 1 | Indicates the rectangular background frame will be based on a custom geometry.
CustomBackgroundImage | 2 | Indicates the rectangular background frame will be based on a custom image.
None | 3 | Indicates that no frame will be rendered.
RoundedRectangleDarkGradient | 4 | Indicates a rounded rectangle frame with a thin rim.
RoundedRectangleLightGradient | 5 | Indicates a rounded rectangle frame with a darker gradient on the outer rim.
RoundedSide | 6 | Indicates a frame with rounded sides.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


RectangularFrameType Enumeration

Specifies the types of frames supported by LinearGauge and DigitalGauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum RectangularFrameType
Public Enumeration RectangularFrameType
Members
Member name | Value | Description
RoundedRectangleDarkerGradient | 0 | Indicates a rounded rectangle frame with a darker gradient on the outer rim.
RoundedRectangleLightGradient | 1 | Indicates a rounded rectangle frame with a ligher gradient on the outer rim.
RoundedRectangleThinRim | 2 | Indicates a rounded rectangle frame with a thin rim.
ClippedRectangle | 3 | Indicates a clipped rectangle frame.
RectangleGradient | 4 | Indicates a rectangle frame.
RoundedSideThinRim | 5 | Indicates a frame with rounded sides and a thin rim.
RoundedSideThickRim | 6 | Indicates a frame with rounded sides and a thick rim.
None | 7 | Indicates that no frame will be rendered.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


RectangularGlassType Enumeration

Specifies the types of glass effects supported by RectangularGlassEffect.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum RectangularGlassType
Public Enumeration RectangularGlassType
Members
Member name | Value | Description
ClippedRectangle | 0 | Indicates a clipped rectangle glass effect.
None | 1 | Indicates that no glass effect will be rendered.
Rectangle | 2 | Indicates a rectangle glass effect.
RoundedRectangle | 3 | Indicates a rounded rectangle glass effect.
RoundedSideRectangle | 4 | Indicates a glass effect with rounded sides.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


RectangularRimType Enumeration

Specifies the types of rim supported by RectangularGaugeBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum RectangularRimType
Public Enumeration RectangularRimType
Members
Member name | Value | Description
ClippedRectangle | 0 | Indicates a clipped rectangle frame.
CustomRimGeometry | 1 | Indicates the rectangular rim will be based on a custom geometry.
CustomRimImage | 2 | Indicates the rectangular rim will be based on a custom image.
None | 3 | Indicates that no frame will be rendered.
RectangleGradient | 4 | Indicates a rectangle frame.
RoundedRectangleDarkerGradient | 5 | Indicates a rounded rectangle frame with a darker gradient on the outer rim.
RoundedRectangleLightGradient | 6 | Indicates a rounded rectangle frame with a ligher gradient on the outer rim.
RoundedRectangleThinRim | 7 | Indicates a rounded rectangle frame with a thin rim.
RoundedSideThinRim | 8 | Indicates a frame with rounded sides and a thin rim.
RoundedSideThickRim | 9 | Indicates a frame with rounded sides and a thick rim.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


ScalePlacement Enumeration

Specifies the various placements support by elements hosted in a gauge scale.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ScalePlacement
Public Enumeration ScalePlacement
Members
Member name | Value | Description
Inside | 0 | Indicates the element should be placed on the inside of the scale bar.
Outside | 1 | Indicates the element should be placed on the outside of the scale bar.
Overlay | 2 | Indicates the element should be centered over the scale bar.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


TextOrientation Enumeration

Specifies the orientation of text when rendered in a gauge control.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TextOrientation
Public Enumeration TextOrientation
Members
Member name | Value | Description
Normal | 0 | Indicates the text shall be rendered horizontally regardless of where it is located in the gauge.
Rotated | 1 | Indicates the text may be rotated when it is rendered.
RotatedAdjusted | 2 | Indicates the text may be rotated when it is rendered, but that the top the text will never point downwards.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


TickMarkType Enumeration

Specifies the types of tick marks supported by TickBase-derived elements.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TickMarkType
Public Enumeration TickMarkType
Members
Member name | Value | Description
Diamond | 0 | Indicates a diamond shaped tick mark.
Ellipse | 1 | Indicates an ellipse shaped tick mark.
Rectangle | 2 | Indicates a rectangle shaped tick mark.
RoundedRectangle | 3 | Indicates a rounded rectangle shaped tick mark.
SwordBlunt | 4 | Indicates a sword shaped tick mark with a blunt tip.
SwordSharp | 5 | Indicates a sword shaped tick mark with a sharp tip.
TriangleBlunt | 6 | Indicates a triangle shaped tick mark with a blunt tip.
TriangleSharp | 7 | Indicates a triangle shaped tick mark with a sharp tip.
CustomImage | 8 | Indicates the tick mark will be based on a custom image.
CustomGeometry | 9 | Indicates the tick mark will be based on a custom geometry.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


TickVisibility Enumeration

Specifies the various visible states of tick marks and tick labels.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TickVisibility
Public Enumeration TickVisibility
Members
Member name | Value | Description
Always | 0 | Indicates the tick will always be visible.
Never | 1 | Indicates the tick will never be visible.
OnInterval | 2 | Indicates the tick will only be visible if it is part of the associated interval.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch Class

Represents a toggle switch control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularGaugeBase
ActiproSoftware.Windows.Controls.GaugeToggleSwitch

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ToggleSwitch : CircularGaugeBase
Public Class ToggleSwitch
    Inherits CircularGaugeBase

The ToggleSwitch type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleSwitch | Initializes a new instance of the ToggleSwitch class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundRadiusRatio | Gets or sets the radius of the frame background as a ratio of the Radius property. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BallBrush | Gets or sets the brush used to render the ball of the switch. This is a dependency property.
Public property | BaseAccentBrush | Gets or sets the brush used to render the accent shape on the base. This is a dependency property.
Public property | BaseBackground | Gets or sets the brush used to render the base background. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FocusBrush | Gets or sets brush used to render the focus indicator. This is a dependency property.
Public property | FocusExtent | Gets or sets the extent of the focus indicator. This is a dependency property.
Public property | FrameType | Gets or sets the type of frame rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsChecked | Gets or sets whether the ToggleSwitch is checked. This is a dependency property.
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsSwitchEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the switch. This is a dependency property.
Public property | IsThreeState | Gets or sets whether the control supports two or three states. This is a dependency property.
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from CircularGaugeBase.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Radius | Gets or sets the radius of the gauge. This is a dependency property. (Inherited from CircularGaugeBase.)
Protected property | RenderedFocused | Gets and sets a value indicating whether the switch should be rendered with a focus indicator. This is a dependency property.
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | ShaftBrush | Gets or sets the brush used to render the shaft of the switch. This is a dependency property.
Public property | SwitchInterval | Gets or sets the interval that it takes the switch to travel to a new location. This is a dependency property.
Protected property | SwitchOffset | Gets or sets the offset of the switch, which is used to move it up and down. This is a dependency property.
Public property | SwitchRadiusRatio | Gets or sets the radius of the switch as a ratio of the Radius property. This is a dependency property.
Public property | SwitchType | Gets or sets the type of switch rendered. This is a dependency property.
Public property | TipBrush | Gets or sets the brush used to render the tip of the switch. This is a dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from CircularGaugeBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from CircularGaugeBase.)
Protected method | OnChecked | Raises the Checked event.
Protected method | OnCreateAutomationPeer | Creates an appropriate ToggleSwitchAutomationPeer for this control as part of the WPF infrastructure. (Overrides GaugeBaseOnCreateAutomationPeer.)
Protected method | OnIndeterminate | Raises the Indeterminate event.
Protected method | OnMouseDown | Invoked when an unhandled Mouse.MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides CircularGaugeBaseOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnToggle | Called by the OnClick method to implement toggle behavior.
Protected method | OnUnchecked | Raises the Unchecked event.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderToggleSwitch | Renders the switch based on various properties.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateSwitchOffset | Updates the SwitchOffset, usually with an animation.
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from CircularGaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Checked | Occurs when the IsChecked property is changed to true.
Public event | Indeterminate | Occurs when the IsChecked property is changed to .
Public event | Unchecked | Occurs when the IsChecked property is changed to false.
Top
Fields
Name | Description
BallBrushProperty | Identifies the BallBrush dependency property. This field is read-only.
BaseAccentBrushProperty | Identifies the BaseAccentBrush dependency property. This field is read-only.
BaseBackgroundProperty | Identifies the BaseBackground dependency property. This field is read-only.
CheckedEvent | Identifies the Checked routed event. This field is read-only.
FocusBrushProperty | Identifies the FocusBrush dependency property. This field is read-only.
FocusExtentProperty | Identifies the FocusExtent dependency property. This field is read-only.
IndeterminateEvent | Identifies the Checked routed event. This field is read-only.
IsCheckedProperty | Identifies the IsChecked dependency property. This field is read-only.
IsSwitchEffectEnabledProperty | Identifies the IsSwitchEffectEnabled dependency property. This field is read-only.
IsThreeStateProperty | Identifies the IsThreeState dependency property. This field is read-only.
RenderedFocusedProperty | Identifies the RenderedFocused dependency property. This field is read-only.
ShaftBrushProperty | Identifies the ShaftBrush dependency property. This field is read-only.
SwitchIntervalProperty | Identifies the SwitchInterval dependency property. This field is read-only.
SwitchOffsetProperty | Identifies the SwitchOffset dependency property. This field is read-only.
SwitchRadiusRatioProperty | Identifies the SwitchRadiusRatio dependency property. This field is read-only.
SwitchTypeProperty | Identifies the SwitchType dependency property. This field is read-only.
TipBrushProperty | Identifies the TipBrush dependency property. This field is read-only.
UncheckedEvent | Identifies the Checked routed event. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch Constructor

Initializes a new instance of the ToggleSwitch class.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToggleSwitch()
Public Sub New
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch Properties

The ToggleSwitch type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundRadiusRatio | Gets or sets the radius of the frame background as a ratio of the Radius property. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | BallBrush | Gets or sets the brush used to render the ball of the switch. This is a dependency property.
Public property | BaseAccentBrush | Gets or sets the brush used to render the accent shape on the base. This is a dependency property.
Public property | BaseBackground | Gets or sets the brush used to render the base background. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FocusBrush | Gets or sets brush used to render the focus indicator. This is a dependency property.
Public property | FocusExtent | Gets or sets the extent of the focus indicator. This is a dependency property.
Public property | FrameType | Gets or sets the type of frame rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsChecked | Gets or sets whether the ToggleSwitch is checked. This is a dependency property.
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsSwitchEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the switch. This is a dependency property.
Public property | IsThreeState | Gets or sets whether the control supports two or three states. This is a dependency property.
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from CircularGaugeBase.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Radius | Gets or sets the radius of the gauge. This is a dependency property. (Inherited from CircularGaugeBase.)
Protected property | RenderedFocused | Gets and sets a value indicating whether the switch should be rendered with a focus indicator. This is a dependency property.
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property. (Inherited from CircularGaugeBase.)
Public property | ShaftBrush | Gets or sets the brush used to render the shaft of the switch. This is a dependency property.
Public property | SwitchInterval | Gets or sets the interval that it takes the switch to travel to a new location. This is a dependency property.
Protected property | SwitchOffset | Gets or sets the offset of the switch, which is used to move it up and down. This is a dependency property.
Public property | SwitchRadiusRatio | Gets or sets the radius of the switch as a ratio of the Radius property. This is a dependency property.
Public property | SwitchType | Gets or sets the type of switch rendered. This is a dependency property.
Public property | TipBrush | Gets or sets the brush used to render the tip of the switch. This is a dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.BallBrush Property

ToggleSwitchBallBrush Property

Gets or sets the brush used to render the ball of the switch. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BallBrush { get; set; }
Public Property BallBrush As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to render the ball of the switch. The default value is DarkGray.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.BaseAccentBrush Property

ToggleSwitchBaseAccentBrush Property

Gets or sets the brush used to render the accent shape on the base. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BaseAccentBrush { get; set; }
Public Property BaseAccentBrush As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to render the accent shape on the base. The default value is Black.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.BaseBackground Property

ToggleSwitchBaseBackground Property

Gets or sets the brush used to render the base background. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BaseBackground { get; set; }
Public Property BaseBackground As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to render the base background. The default value is DarkGray.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.FocusBrush Property

ToggleSwitchFocusBrush Property

Gets or sets brush used to render the focus indicator. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush FocusBrush { get; set; }
Public Property FocusBrush As Brush
    Get
    Set

Property Value

Type: Brush
The ToggleSwitch focus brush. The default value is DarkGoldenrod.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.FocusExtent Property

ToggleSwitchFocusExtent Property

Gets or sets the extent of the focus indicator. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit FocusExtent { get; set; }
Public Property FocusExtent As Unit
    Get
    Set

Property Value

Type: Unit
The extent of the focus indicator. The default value is 3%.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.IsChecked Property

ToggleSwitchIsChecked Property

Gets or sets whether the ToggleSwitch is checked. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> IsChecked { get; set; }
Public Property IsChecked As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
true if the ToggleSwitch is checked; false if the ToggleSwitch is unchecked; otherwise . The default value is false.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.IsSwitchEffectEnabled Property

ToggleSwitchIsSwitchEffectEnabled Property

Gets and sets a value indicating whether a special effect should be rendered for the switch. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSwitchEffectEnabled { get; set; }
Public Property IsSwitchEffectEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the switch effect is enabled; otherwise, false. The default value is true.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.IsThreeState Property

ToggleSwitchIsThreeState Property

Gets or sets whether the control supports two or three states. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsThreeState { get; set; }
Public Property IsThreeState As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control supports three states; otherwise, false. The default value is false.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.RenderedFocused Property

ToggleSwitchRenderedFocused Property

Gets and sets a value indicating whether the switch should be rendered with a focus indicator. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool RenderedFocused { get; set; }
Protected Property RenderedFocused As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the switch should be rendered with a focus indicator; otherwise, false. The default value is false.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.ShaftBrush Property

ToggleSwitchShaftBrush Property

Gets or sets the brush used to render the shaft of the switch. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ShaftBrush { get; set; }
Public Property ShaftBrush As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to render the shaft of the switch. The default value is Gray.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.SwitchInterval Property

ToggleSwitchSwitchInterval Property

Gets or sets the interval that it takes the switch to travel to a new location. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration SwitchInterval { get; set; }
Public Property SwitchInterval As Duration
    Get
    Set

Property Value

Type: Duration
The interval that it takes the switch to travel to a new location. The default value is 250 milliseconds.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.SwitchOffset Property

ToggleSwitchSwitchOffset Property

Gets or sets the offset of the switch, which is used to move it up and down. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double SwitchOffset { get; set; }
Protected Property SwitchOffset As Double
    Get
    Set

Property Value

Type: Double
The offset of the switch. The default value is 0.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.SwitchRadiusRatio Property

ToggleSwitchSwitchRadiusRatio Property

Gets or sets the radius of the switch as a ratio of the Radius property. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SwitchRadiusRatio { get; set; }
Public Property SwitchRadiusRatio As Double
    Get
    Set

Property Value

Type: Double
The radius of the switch as a ratio of the Radius property. The default value is 0.75.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.SwitchType Property

ToggleSwitchSwitchType Property

Gets or sets the type of switch rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToggleSwitchType SwitchType { get; set; }
Public Property SwitchType As ToggleSwitchType
    Get
    Set

Property Value

Type: ToggleSwitchType
The type of switch rendered. The default value is ToggleSwitchType.Circular.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.TipBrush Property

ToggleSwitchTipBrush Property

Gets or sets the brush used to render the tip of the switch. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush TipBrush { get; set; }
Public Property TipBrush As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to render the tip of the switch. The default value is Gray.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch Methods

The ToggleSwitch type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from CircularGaugeBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from CircularGaugeBase.)
Protected method | OnChecked | Raises the Checked event.
Protected method | OnCreateAutomationPeer | Creates an appropriate ToggleSwitchAutomationPeer for this control as part of the WPF infrastructure. (Overrides GaugeBaseOnCreateAutomationPeer.)
Protected method | OnIndeterminate | Raises the Indeterminate event.
Protected method | OnMouseDown | Invoked when an unhandled Mouse.MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides CircularGaugeBaseOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnToggle | Called by the OnClick method to implement toggle behavior.
Protected method | OnUnchecked | Raises the Unchecked event.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType and Radius properties. (Inherited from CircularGaugeBase.)
Protected method | RenderToggleSwitch | Renders the switch based on various properties.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateSwitchOffset | Updates the SwitchOffset, usually with an animation.
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from CircularGaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.OnChecked Method

ToggleSwitchOnChecked Method

Raises the Checked event.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnChecked(
    RoutedEventArgs e
)
Protected Overridable Sub OnChecked (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs instance containing the event data.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.OnCreateAutomationPeer Method

ToggleSwitchOnCreateAutomationPeer Method

Creates an appropriate ToggleSwitchAutomationPeer for this control as part of the WPF infrastructure.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An instance of ToggleSwitchAutomationPeer.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.OnIndeterminate Method

ToggleSwitchOnIndeterminate Method

Raises the Indeterminate event.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnIndeterminate(
    RoutedEventArgs e
)
Protected Overridable Sub OnIndeterminate (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs instance containing the event data.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.OnMouseDown Method

ToggleSwitchOnMouseDown Method

Invoked when an unhandled Mouse.MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.OnRender Method

ToggleSwitchOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.OnToggle Method

ToggleSwitchOnToggle Method

Called by the OnClick method to implement toggle behavior.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnToggle()
Protected Overridable Sub OnToggle
Remarks
This method toggles the IsChecked property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.OnUnchecked Method

ToggleSwitchOnUnchecked Method

Raises the Unchecked event.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnUnchecked(
    RoutedEventArgs e
)
Protected Overridable Sub OnUnchecked (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs instance containing the event data.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.RenderToggleSwitch Method

ToggleSwitchRenderToggleSwitch Method

Renders the switch based on various properties.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void RenderToggleSwitch(
    DrawingContext drawingContext
)
Protected Overridable Sub RenderToggleSwitch (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing context.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.UpdateSwitchOffset Method

ToggleSwitchUpdateSwitchOffset Method

Updates the SwitchOffset, usually with an animation.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateSwitchOffset()
Protected Overridable Sub UpdateSwitchOffset
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch Events

The ToggleSwitch type exposes the following members.

Events
 | Name | Description
Public event | Checked | Occurs when the IsChecked property is changed to true.
Public event | Indeterminate | Occurs when the IsChecked property is changed to .
Public event | Unchecked | Occurs when the IsChecked property is changed to false.
Top
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.Checked Event

ToggleSwitchChecked Event

Occurs when the IsChecked property is changed to true.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Checked
Public Event Checked As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.Indeterminate Event

ToggleSwitchIndeterminate Event

Occurs when the IsChecked property is changed to .

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Indeterminate
Public Event Indeterminate As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.Unchecked Event

ToggleSwitchUnchecked Event

Occurs when the IsChecked property is changed to false.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Unchecked
Public Event Unchecked As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch Fields

The ToggleSwitch type exposes the following members.

Fields
Name | Description
BallBrushProperty | Identifies the BallBrush dependency property. This field is read-only.
BaseAccentBrushProperty | Identifies the BaseAccentBrush dependency property. This field is read-only.
BaseBackgroundProperty | Identifies the BaseBackground dependency property. This field is read-only.
CheckedEvent | Identifies the Checked routed event. This field is read-only.
FocusBrushProperty | Identifies the FocusBrush dependency property. This field is read-only.
FocusExtentProperty | Identifies the FocusExtent dependency property. This field is read-only.
IndeterminateEvent | Identifies the Checked routed event. This field is read-only.
IsCheckedProperty | Identifies the IsChecked dependency property. This field is read-only.
IsSwitchEffectEnabledProperty | Identifies the IsSwitchEffectEnabled dependency property. This field is read-only.
IsThreeStateProperty | Identifies the IsThreeState dependency property. This field is read-only.
RenderedFocusedProperty | Identifies the RenderedFocused dependency property. This field is read-only.
ShaftBrushProperty | Identifies the ShaftBrush dependency property. This field is read-only.
SwitchIntervalProperty | Identifies the SwitchInterval dependency property. This field is read-only.
SwitchOffsetProperty | Identifies the SwitchOffset dependency property. This field is read-only.
SwitchRadiusRatioProperty | Identifies the SwitchRadiusRatio dependency property. This field is read-only.
SwitchTypeProperty | Identifies the SwitchType dependency property. This field is read-only.
TipBrushProperty | Identifies the TipBrush dependency property. This field is read-only.
UncheckedEvent | Identifies the Checked routed event. This field is read-only.
Top
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.BallBrushProperty Field

ToggleSwitchBallBrushProperty Field

Identifies the BallBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BallBrushProperty
Public Shared ReadOnly BallBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BallBrush dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.BaseAccentBrushProperty Field

ToggleSwitchBaseAccentBrushProperty Field

Identifies the BaseAccentBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaseAccentBrushProperty
Public Shared ReadOnly BaseAccentBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BaseAccentBrush dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.BaseBackgroundProperty Field

ToggleSwitchBaseBackgroundProperty Field

Identifies the BaseBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaseBackgroundProperty
Public Shared ReadOnly BaseBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BaseBackground dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.CheckedEvent Field

ToggleSwitchCheckedEvent Field

Identifies the Checked routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent CheckedEvent
Public Shared ReadOnly CheckedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Checked routed event.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.FocusBrushProperty Field

ToggleSwitchFocusBrushProperty Field

Identifies the FocusBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FocusBrushProperty
Public Shared ReadOnly FocusBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FocusBrush dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.FocusExtentProperty Field

ToggleSwitchFocusExtentProperty Field

Identifies the FocusExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FocusExtentProperty
Public Shared ReadOnly FocusExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FocusExtent dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.IndeterminateEvent Field

ToggleSwitchIndeterminateEvent Field

Identifies the Checked routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent IndeterminateEvent
Public Shared ReadOnly IndeterminateEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Checked routed event.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.IsCheckedProperty Field

ToggleSwitchIsCheckedProperty Field

Identifies the IsChecked dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCheckedProperty
Public Shared ReadOnly IsCheckedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsChecked dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.IsSwitchEffectEnabledProperty Field

ToggleSwitchIsSwitchEffectEnabledProperty Field

Identifies the IsSwitchEffectEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSwitchEffectEnabledProperty
Public Shared ReadOnly IsSwitchEffectEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSwitchEffectEnabled dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.IsThreeStateProperty Field

ToggleSwitchIsThreeStateProperty Field

Identifies the IsThreeState dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsThreeStateProperty
Public Shared ReadOnly IsThreeStateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsThreeState dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.RenderedFocusedProperty Field

ToggleSwitchRenderedFocusedProperty Field

Identifies the RenderedFocused dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static readonly DependencyProperty RenderedFocusedProperty
Protected Shared ReadOnly RenderedFocusedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RenderedFocused dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.ShaftBrushProperty Field

ToggleSwitchShaftBrushProperty Field

Identifies the ShaftBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ShaftBrushProperty
Public Shared ReadOnly ShaftBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ShaftBrush dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.SwitchIntervalProperty Field

ToggleSwitchSwitchIntervalProperty Field

Identifies the SwitchInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwitchIntervalProperty
Public Shared ReadOnly SwitchIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwitchInterval dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.SwitchOffsetProperty Field

ToggleSwitchSwitchOffsetProperty Field

Identifies the SwitchOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static readonly DependencyProperty SwitchOffsetProperty
Protected Shared ReadOnly SwitchOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwitchOffset dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.SwitchRadiusRatioProperty Field

ToggleSwitchSwitchRadiusRatioProperty Field

Identifies the SwitchRadiusRatio dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwitchRadiusRatioProperty
Public Shared ReadOnly SwitchRadiusRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwitchRadiusRatio dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.SwitchTypeProperty Field

ToggleSwitchSwitchTypeProperty Field

Identifies the SwitchType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwitchTypeProperty
Public Shared ReadOnly SwitchTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwitchType dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.TipBrushProperty Field

ToggleSwitchTipBrushProperty Field

Identifies the TipBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TipBrushProperty
Public Shared ReadOnly TipBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TipBrush dependency property.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitch.UncheckedEvent Field

ToggleSwitchUncheckedEvent Field

Identifies the Checked routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent UncheckedEvent
Public Shared ReadOnly UncheckedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the Checked routed event.
See Also

Reference

ToggleSwitch Class
ActiproSoftware.Windows.Controls.Gauge Namespace


ToggleSwitchType Enumeration

Specifies the types of switches supported by ToggleSwitch.

Namespace: ActiproSoftware.Windows.Controls.Gauge
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ToggleSwitchType
Public Enumeration ToggleSwitchType
Members
Member name | Value | Description
Circular | 0 | Indicates a circular switch will be used.
Flat | 1 | Indicates a flat switch will be used.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge Namespace


ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace

Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | GaugeBaseAutomationPeer | Exposes GaugeBase types to UI Automation.
Public class | LedAutomationPeer | Exposes Led types to UI Automation.
Public class | PointerBaseAutomationPeer | Exposes PointerBase types to UI Automation.
Public class | ScaleBaseAutomationPeer | Exposes ScaleBase types to UI Automation.
Public class | ToggleSwitchAutomationPeer | Exposes ToggleSwitch types to UI Automation.


GaugeBaseAutomationPeer Class

Exposes GaugeBase types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Gauge.Automation.PeersGaugeBaseAutomationPeer
ActiproSoftware.Windows.Controls.Gauge.Automation.PeersLedAutomationPeer
ActiproSoftware.Windows.Controls.Gauge.Automation.PeersToggleSwitchAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class GaugeBaseAutomationPeer : FrameworkElementAutomationPeer
Public Class GaugeBaseAutomationPeer
    Inherits FrameworkElementAutomationPeer

The GaugeBaseAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | GaugeBaseAutomationPeer | Initializes a new instance of the GaugeBaseAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this GaugeBaseAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


GaugeBaseAutomationPeer Constructor

Initializes a new instance of the GaugeBaseAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GaugeBaseAutomationPeer(
    GaugeBase owner
)
Public Sub New (
    owner As GaugeBase
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
The owner.
See Also

Reference

GaugeBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


GaugeBaseAutomationPeer Properties

The GaugeBaseAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

GaugeBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


GaugeBaseAutomationPeer Methods

The GaugeBaseAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this GaugeBaseAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

GaugeBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


GaugeBaseAutomationPeer.GetAutomationControlTypeCore Method

GaugeBaseAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The Custom enumeration value.
See Also

Reference

GaugeBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


GaugeBaseAutomationPeer.GetClassNameCore Method

GaugeBaseAutomationPeerGetClassNameCore Method

Gets the name of the UIElement that is associated with this GaugeBaseAutomationPeer. This method is called by GetClassName.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The Type.Name of the Owner.
See Also

Reference

GaugeBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


LedAutomationPeer Class

Exposes Led types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Gauge.Automation.PeersGaugeBaseAutomationPeer
ActiproSoftware.Windows.Controls.Gauge.Automation.PeersLedAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LedAutomationPeer : GaugeBaseAutomationPeer,
    IValueProvider
Public Class LedAutomationPeer
    Inherits GaugeBaseAutomationPeer
    Implements IValueProvider

The LedAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | LedAutomationPeer | Initializes a new instance of the LedAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from GaugeBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this GaugeBaseAutomationPeer. This method is called by GetClassName. (Inherited from GaugeBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


LedAutomationPeer Constructor

Initializes a new instance of the LedAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LedAutomationPeer(
    Led owner
)
Public Sub New (
    owner As Led
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.GaugeLed
The owner.
See Also

Reference

LedAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


LedAutomationPeer Properties

The LedAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

LedAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


LedAutomationPeer Methods

The LedAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from GaugeBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this GaugeBaseAutomationPeer. This method is called by GetClassName. (Inherited from GaugeBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

LedAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


LedAutomationPeer.GetPattern Method

LedAutomationPeerGetPattern Method

Gets the object that supports the specified control pattern of the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value in the enumeration.

Return Value

Type: Object
This method will return a 'this' pointer in the follow cases:
  • If patternInterface is PatternInterface.Value. -
See Also

Reference

LedAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


PointerBaseAutomationPeer Class

Exposes PointerBase types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Gauge.Automation.PeersPointerBaseAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PointerBaseAutomationPeer : FrameworkElementAutomationPeer,
    IRangeValueProvider
Public Class PointerBaseAutomationPeer
    Inherits FrameworkElementAutomationPeer
    Implements IRangeValueProvider

The PointerBaseAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | PointerBaseAutomationPeer | Initializes a new instance of the PointerBaseAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this PointerBaseAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


PointerBaseAutomationPeer Constructor

Initializes a new instance of the PointerBaseAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PointerBaseAutomationPeer(
    PointerBase owner
)
Public Sub New (
    owner As PointerBase
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
The owner.
See Also

Reference

PointerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


PointerBaseAutomationPeer Properties

The PointerBaseAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

PointerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


PointerBaseAutomationPeer Methods

The PointerBaseAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this PointerBaseAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PointerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


PointerBaseAutomationPeer.GetAutomationControlTypeCore Method

PointerBaseAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The Custom enumeration value.
See Also

Reference

PointerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


PointerBaseAutomationPeer.GetClassNameCore Method

PointerBaseAutomationPeerGetClassNameCore Method

Gets the name of the UIElement that is associated with this PointerBaseAutomationPeer. This method is called by GetClassName.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The Type.Name of the Owner.
See Also

Reference

PointerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


PointerBaseAutomationPeer.GetPattern Method

PointerBaseAutomationPeerGetPattern Method

Gets the object that supports the specified control pattern of the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value in the enumeration.

Return Value

Type: Object
This method will return a 'this' pointer in the follow cases:
  • If patternInterface is PatternInterface.RangeValue. -
See Also

Reference

PointerBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ScaleBaseAutomationPeer Class

Exposes ScaleBase types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Gauge.Automation.PeersScaleBaseAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ScaleBaseAutomationPeer : FrameworkElementAutomationPeer
Public Class ScaleBaseAutomationPeer
    Inherits FrameworkElementAutomationPeer

The ScaleBaseAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | ScaleBaseAutomationPeer | Initializes a new instance of the ScaleBaseAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this ScaleBaseAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ScaleBaseAutomationPeer Constructor

Initializes a new instance of the ScaleBaseAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ScaleBaseAutomationPeer(
    ScaleBase owner
)
Public Sub New (
    owner As ScaleBase
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.Gauge.PrimitivesScaleBase
The owner.
See Also

Reference

ScaleBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ScaleBaseAutomationPeer Properties

The ScaleBaseAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

ScaleBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ScaleBaseAutomationPeer Methods

The ScaleBaseAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this ScaleBaseAutomationPeer. This method is called by GetClassName. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ScaleBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ScaleBaseAutomationPeer.GetAutomationControlTypeCore Method

ScaleBaseAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The Custom enumeration value.
See Also

Reference

ScaleBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ScaleBaseAutomationPeer.GetClassNameCore Method

ScaleBaseAutomationPeerGetClassNameCore Method

Gets the name of the UIElement that is associated with this ScaleBaseAutomationPeer. This method is called by GetClassName.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The Type.Name of the Owner.
See Also

Reference

ScaleBaseAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ToggleSwitchAutomationPeer Class

Exposes ToggleSwitch types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Gauge.Automation.PeersGaugeBaseAutomationPeer
ActiproSoftware.Windows.Controls.Gauge.Automation.PeersToggleSwitchAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ToggleSwitchAutomationPeer : GaugeBaseAutomationPeer,
    IToggleProvider
Public Class ToggleSwitchAutomationPeer
    Inherits GaugeBaseAutomationPeer
    Implements IToggleProvider

The ToggleSwitchAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleSwitchAutomationPeer | Initializes a new instance of the ToggleSwitchAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from GaugeBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this GaugeBaseAutomationPeer. This method is called by GetClassName. (Inherited from GaugeBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ToggleSwitchAutomationPeer Constructor

Initializes a new instance of the ToggleSwitchAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ToggleSwitchAutomationPeer(
    ToggleSwitch owner
)
Public Sub New (
    owner As ToggleSwitch
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.GaugeToggleSwitch
The owner.
See Also

Reference

ToggleSwitchAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ToggleSwitchAutomationPeer Properties

The ToggleSwitchAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

ToggleSwitchAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ToggleSwitchAutomationPeer Methods

The ToggleSwitchAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from GaugeBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets the name of the UIElement that is associated with this GaugeBaseAutomationPeer. This method is called by GetClassName. (Inherited from GaugeBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ToggleSwitchAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ToggleSwitchAutomationPeer.GetPattern Method

ToggleSwitchAutomationPeerGetPattern Method

Gets the object that supports the specified control pattern of the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Automation.Peers
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value in the enumeration.

Return Value

Type: Object
This method will return a 'this' pointer in the follow cases:
  • If patternInterface is PatternInterface.Toggle. -
See Also

Reference

ToggleSwitchAutomationPeer Class
ActiproSoftware.Windows.Controls.Gauge.Automation.Peers Namespace


ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace

Contains the primitive classes used for Gauge product controls.
Classes
 | Class | Description
Public class | CircularGaugeBase | Represents a circular gauge control.
Public class | CircularPointerBase | Represents a base class for linear pointers.
Public class | CircularTickBase | Represents the base class for circular tick marks and labels.
Public class | CircularTickLabelBase | Represents the base class for circular tick labels.
Public class | CircularTickMarkBase | Represents the base class for circular tick marks.
Public class | GaugeBase | Represents the base class for all Gauge controls.
Public class | GaugeElement | Represents the base class of all gauge elements.
Public class | LinearPointerBase | Represents a base class for linear pointers.
Public class | LinearTickBase | Represents the base class for linear tick marks and labels.
Public class | LinearTickLabelBase | Represents the base class for linear tick labels.
Public class | LinearTickMarkBase | Represents the base class for linear tick marks.
Public class | PointerBase | Represents a base class for pointers.
Public class | RangeBase | Represents the base class for ranges.
Public class | RectangularGaugeBase | Represents a base class for rectangular gauge controls.
Public class | ScaleBase | Represents the base class for scales.
Public class | TickBase | Represents the base class for tick marks and tick labels.
Public class | TickSetBase | Represents the base class for tick-sets.


CircularGaugeBase Class

Represents a circular gauge control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularGaugeBase
ActiproSoftware.Windows.Controls.GaugeCircularGauge
ActiproSoftware.Windows.Controls.GaugeLed
ActiproSoftware.Windows.Controls.GaugeToggleSwitch

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class CircularGaugeBase : GaugeBase
Public MustInherit Class CircularGaugeBase
    Inherits GaugeBase

The CircularGaugeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CircularGaugeBase | Initializes a new instance of the CircularGaugeBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property.
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property.
Public property | BackgroundRadiusRatio | Gets or sets the radius of the frame background as a ratio of the Radius property. This is a dependency property.
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FrameType | Gets or sets the type of frame rendered. This is a dependency property.
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property.
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides GaugeBaseLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Radius | Gets or sets the radius of the gauge. This is a dependency property.
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property.
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property.
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides GaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
 | GetRadius | Gets the value of the RadiusProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides GaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType and Radius properties.
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType and Radius properties.
 | SetRadius | Sets the value of the RadiusProperty attached property to a specified object.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Overrides GaugeBaseUpdateUnitBases.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BackgroundGeometryProperty | Identifies the BackgroundGeometry dependency property. This field is read-only.
BackgroundImageSourceProperty | Identifies the BackgroundImageSource dependency property. This field is read-only.
BackgroundRadiusRatioProperty | Identifies the BackgroundRadiusRatio dependency property. This field is read-only.
BackgroundTypeProperty | Identifies the BackgroundType dependency property. This field is read-only.
FrameTypeProperty | Identifies the FrameType dependency property. This field is read-only.
GlassTypeProperty | Identifies the GlassType dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
RimGeometryProperty | Identifies the RimGeometry dependency property. This field is read-only.
RimImageSourceProperty | Identifies the RimImageSource dependency property. This field is read-only.
RimTypeProperty | Identifies the RimType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase Constructor

Initializes a new instance of the CircularGaugeBase class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected CircularGaugeBase()
Protected Sub New
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase Properties

The CircularGaugeBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property.
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property.
Public property | BackgroundRadiusRatio | Gets or sets the radius of the frame background as a ratio of the Radius property. This is a dependency property.
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FrameType | Gets or sets the type of frame rendered. This is a dependency property.
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property.
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides GaugeBaseLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Radius | Gets or sets the radius of the gauge. This is a dependency property.
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property.
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property.
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.BackgroundGeometry Property

CircularGaugeBaseBackgroundGeometry Property

Gets or sets the custom geometry used for the frame background. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry BackgroundGeometry { get; set; }
Public Property BackgroundGeometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry for the frame background. The default value is .
Remarks
This property is only used when BackgroundType is set to CircularBackgroundType.CustomBackgroundGeometry.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.BackgroundImageSource Property

CircularGaugeBaseBackgroundImageSource Property

Gets or sets the source of a custom image used for the frame background. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource BackgroundImageSource { get; set; }
Public Property BackgroundImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source for the frame background. The default value is .
Remarks
This property is only used when BackgroundType is set to CircularBackgroundType.CustomBackgroundImage.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.BackgroundRadiusRatio Property

CircularGaugeBaseBackgroundRadiusRatio Property

Gets or sets the radius of the frame background as a ratio of the Radius property. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double BackgroundRadiusRatio { get; set; }
Public Property BackgroundRadiusRatio As Double
    Get
    Set

Property Value

Type: Double
The radius of the frame background as a ratio of the Radius property. The default value is 0.7846.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.BackgroundType Property

CircularGaugeBaseBackgroundType Property

Gets or sets the type of frame background to be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularBackgroundType BackgroundType { get; set; }
Public Property BackgroundType As CircularBackgroundType
    Get
    Set

Property Value

Type: CircularBackgroundType
The type of frame background to be rendered. The default value is CircularBackgroundType.CircularOrb.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.FrameType Property

CircularGaugeBaseFrameType Property

Gets or sets the type of frame rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularFrameType FrameType { get; set; }
Public Property FrameType As CircularFrameType
    Get
    Set

Property Value

Type: CircularFrameType
The type of frame rendered. The default value is CircularOrb.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.GlassType Property

CircularGaugeBaseGlassType Property

Gets or sets the type of glass effect rendered, if any. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularGlassType GlassType { get; set; }
Public Property GlassType As CircularGlassType
    Get
    Set

Property Value

Type: CircularGlassType
The type of glass rendered, if any. The default value is CircularGlassType.None.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.LogicalChildren Property

CircularGaugeBaseLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.Radius Property

CircularGaugeBaseRadius Property

Gets or sets the radius of the gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit Radius { get; set; }
Public Property Radius As Unit
    Get
    Set

Property Value

Type: Unit
The radius. The default value is 100 pixels.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.RimGeometry Property

CircularGaugeBaseRimGeometry Property

Gets or sets the custom geometry used for the frame rim. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry RimGeometry { get; set; }
Public Property RimGeometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry for the frame rim. The default value is .
Remarks
This property is only used when RimType is set to CircularRimType.CustomRimGeometry.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.RimImageSource Property

CircularGaugeBaseRimImageSource Property

Gets or sets the source of a custom image used for the frame rim. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource RimImageSource { get; set; }
Public Property RimImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source for the frame rim. The default value is .
Remarks
This property is only used when RimType is set to CircularRimType.CustomRimImage.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.RimType Property

CircularGaugeBaseRimType Property

Gets or sets the type of frame rim to be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularRimType RimType { get; set; }
Public Property RimType As CircularRimType
    Get
    Set

Property Value

Type: CircularRimType
The type of frame rim to be rendered. The default value is CircularRimType.CircularThinRim.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase Methods

The CircularGaugeBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides GaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
 | GetRadius | Gets the value of the RadiusProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides GaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType and Radius properties.
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType and Radius properties.
 | SetRadius | Sets the value of the RadiusProperty attached property to a specified object.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Overrides GaugeBaseUpdateUnitBases.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.ArrangeOverride Method

CircularGaugeBaseArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.GetRadius Method

CircularGaugeBaseGetRadius Method

Gets the value of the RadiusProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit GetRadius(
    DependencyObject obj
)
Public Shared Function GetRadius (
    obj As DependencyObject
) As Unit

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Unit
The radius.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.MeasureOverride Method

CircularGaugeBaseMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.OnRender Method

CircularGaugeBaseOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.RenderFrameBackground Method

CircularGaugeBaseRenderFrameBackground Method

Renders the background of the frame based on the actual width and height, and the FrameType and Radius properties.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void RenderFrameBackground(
    DrawingContext drawingContext
)
Protected Overridable Sub RenderFrameBackground (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing context.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.RenderFrameRim Method

CircularGaugeBaseRenderFrameRim Method

Renders the rim of the frame based on the actual width and height, and the FrameType and Radius properties.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void RenderFrameRim(
    DrawingContext drawingContext
)
Protected Overridable Sub RenderFrameRim (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing context.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.SetRadius Method

CircularGaugeBaseSetRadius Method

Sets the value of the RadiusProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetRadius(
    DependencyObject obj,
    Unit value
)
Public Shared Sub SetRadius (
    obj As DependencyObject,
    value As Unit
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.WindowsUnit
The radius.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.UpdateUnitBases Method

CircularGaugeBaseUpdateUnitBases Method

Updates UnitBaseX and UnitBaseY.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateUnitBases()
Protected Overrides Sub UpdateUnitBases
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase Fields

The CircularGaugeBase type exposes the following members.

Fields
Name | Description
BackgroundGeometryProperty | Identifies the BackgroundGeometry dependency property. This field is read-only.
BackgroundImageSourceProperty | Identifies the BackgroundImageSource dependency property. This field is read-only.
BackgroundRadiusRatioProperty | Identifies the BackgroundRadiusRatio dependency property. This field is read-only.
BackgroundTypeProperty | Identifies the BackgroundType dependency property. This field is read-only.
FrameTypeProperty | Identifies the FrameType dependency property. This field is read-only.
GlassTypeProperty | Identifies the GlassType dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
RimGeometryProperty | Identifies the RimGeometry dependency property. This field is read-only.
RimImageSourceProperty | Identifies the RimImageSource dependency property. This field is read-only.
RimTypeProperty | Identifies the RimType dependency property. This field is read-only.
Top
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.BackgroundGeometryProperty Field

CircularGaugeBaseBackgroundGeometryProperty Field

Identifies the BackgroundGeometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundGeometryProperty
Public Shared ReadOnly BackgroundGeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundGeometry dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.BackgroundImageSourceProperty Field

CircularGaugeBaseBackgroundImageSourceProperty Field

Identifies the BackgroundImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundImageSourceProperty
Public Shared ReadOnly BackgroundImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundImageSource dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.BackgroundRadiusRatioProperty Field

CircularGaugeBaseBackgroundRadiusRatioProperty Field

Identifies the BackgroundRadiusRatio dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundRadiusRatioProperty
Public Shared ReadOnly BackgroundRadiusRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundRadiusRatio dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.BackgroundTypeProperty Field

CircularGaugeBaseBackgroundTypeProperty Field

Identifies the BackgroundType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundTypeProperty
Public Shared ReadOnly BackgroundTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundType dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.FrameTypeProperty Field

CircularGaugeBaseFrameTypeProperty Field

Identifies the FrameType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FrameTypeProperty
Public Shared ReadOnly FrameTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FrameType dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.GlassTypeProperty Field

CircularGaugeBaseGlassTypeProperty Field

Identifies the GlassType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GlassTypeProperty
Public Shared ReadOnly GlassTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GlassType dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.RadiusProperty Field

CircularGaugeBaseRadiusProperty Field

Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.RimGeometryProperty Field

CircularGaugeBaseRimGeometryProperty Field

Identifies the RimGeometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RimGeometryProperty
Public Shared ReadOnly RimGeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RimGeometry dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.RimImageSourceProperty Field

CircularGaugeBaseRimImageSourceProperty Field

Identifies the RimImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RimImageSourceProperty
Public Shared ReadOnly RimImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RimImageSource dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularGaugeBase.RimTypeProperty Field

CircularGaugeBaseRimTypeProperty Field

Identifies the RimType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RimTypeProperty
Public Shared ReadOnly RimTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RimType dependency property.
See Also

Reference

CircularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase Class

Represents a base class for linear pointers.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularPointerBase
ActiproSoftware.Windows.Controls.GaugeCircularPointerBar
ActiproSoftware.Windows.Controls.GaugeCircularPointerCap
ActiproSoftware.Windows.Controls.GaugeCircularPointerLabel
ActiproSoftware.Windows.Controls.GaugeCircularPointerMarker
ActiproSoftware.Windows.Controls.GaugeCircularPointerNeedle

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class CircularPointerBase : PointerBase
Public MustInherit Class CircularPointerBase
    Inherits PointerBase

The CircularPointerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CircularPointerBase | Initializes a new instance of the CircularPointerBase class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property.
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale.
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale.
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value.
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle.
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Overrides PointerBaseCalculateValue(Point).)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property.
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
PointerDirectionProperty | Identifies the PointerDirection dependency property. This field is read-only.
ValueAngleProperty | Identifies the ValueAngle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase Constructor

Initializes a new instance of the CircularPointerBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected CircularPointerBase()
Protected Sub New
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase Properties

The CircularPointerBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerDirection | Gets or sets the direction the pointer will rotate on value changes. This is a dependency property.
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale.
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale.
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueAngle | Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.PointerDirection Property

CircularPointerBasePointerDirection Property

Gets or sets the direction the pointer will rotate on value changes. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CircularPointerDirection PointerDirection { get; set; }
Public Property PointerDirection As CircularPointerDirection
    Get
    Set

Property Value

Type: CircularPointerDirection
The direction the pointer will rotate on value changes. The default value is CircularPointerDirection.Normal.
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.Radius Property

CircularPointerBaseRadius Property

Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double Radius { get; }
Protected ReadOnly Property Radius As Double
    Get

Property Value

Type: Double
The radius.
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.ScaleBarExtent Property

CircularPointerBaseScaleBarExtent Property

Gets the extent of the bar in the associated ScaleBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ScaleBarExtent { get; }
Protected ReadOnly Property ScaleBarExtent As Double
    Get

Property Value

Type: Double
The extent of the bar.
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.StartAngle Property

CircularPointerBaseStartAngle Property

Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double StartAngle { get; }
Protected ReadOnly Property StartAngle As Double
    Get

Property Value

Type: Double
The start angle.
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.SweepAngle Property

CircularPointerBaseSweepAngle Property

Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double SweepAngle { get; }
Protected ReadOnly Property SweepAngle As Double
    Get

Property Value

Type: Double
The sweep angle.
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.ValueAngle Property

CircularPointerBaseValueAngle Property

Gets or sets the angle used to display the Value on the circular gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ValueAngle { get; set; }
Protected Property ValueAngle As Double
    Get
    Set

Property Value

Type: Double
The value angle. The default value is 0.
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase Methods

The CircularPointerBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value.
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle.
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Overrides PointerBaseCalculateValue(Point).)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property.
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueAngle | Updates the ValueAngle property.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.CalculateAngle Method

CircularPointerBaseCalculateAngle Method

Calculates an angle (not including the start angle) for the specified value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double CalculateAngle(
    double value
)
Protected Function CalculateAngle (
    value As Double
) As Double

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: Double
The angle of the specified value, not including the start angle.
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.CalculateValue Method

CircularPointerBaseCalculateValue Method

Overload List
 | Name | Description
Protected method | CalculateValue(Double) | Calculates the value based on a specified angle.
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Overrides PointerBaseCalculateValue(Point).)
Top
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.CalculateValue Method (Double)

CircularPointerBaseCalculateValue Method (Double)

Calculates the value based on a specified angle.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double CalculateValue(
    double angle
)
Protected Function CalculateValue (
    angle As Double
) As Double

Parameters

angle
Type: SystemDouble
The angle.

Return Value

Type: Double
The value of specified angle.
See Also

Reference

CircularPointerBase Class
CalculateValue Overload
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.CalculateValue Method (Point)

CircularPointerBaseCalculateValue Method (Point)

Calculates the value based on a specified point.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override double CalculateValue(
    Point point
)
Protected Overrides Function CalculateValue (
    point As Point
) As Double

Parameters

point
Type: System.WindowsPoint
The point.

Return Value

Type: Double
The value of specified point.
See Also

Reference

CircularPointerBase Class
CalculateValue Overload
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.UpdateDisplayValue Method

CircularPointerBaseUpdateDisplayValue Method

Updates the DisplayValue property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateDisplayValue()
Protected Overridable Sub UpdateDisplayValue
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.UpdateValueAngle Method

CircularPointerBaseUpdateValueAngle Method

Updates the ValueAngle property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateValueAngle()
Protected Overridable Sub UpdateValueAngle
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase Events

The CircularPointerBase type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase Fields

The CircularPointerBase type exposes the following members.

Fields
Name | Description
PointerDirectionProperty | Identifies the PointerDirection dependency property. This field is read-only.
ValueAngleProperty | Identifies the ValueAngle dependency property. This field is read-only.
Top
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.PointerDirectionProperty Field

CircularPointerBasePointerDirectionProperty Field

Identifies the PointerDirection dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PointerDirectionProperty
Public Shared ReadOnly PointerDirectionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PointerDirection dependency property.
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularPointerBase.ValueAngleProperty Field

CircularPointerBaseValueAngleProperty Field

Identifies the ValueAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static readonly DependencyProperty ValueAngleProperty
Protected Shared ReadOnly ValueAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueAngle dependency property.
See Also

Reference

CircularPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickBase Class

Represents the base class for circular tick marks and labels.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickLabelBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickMarkBase

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class CircularTickBase : TickBase
Public MustInherit Class CircularTickBase
    Inherits TickBase

The CircularTickBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CircularTickBase | Initializes a new instance of the CircularTickBase class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickBase Constructor

Initializes a new instance of the CircularTickBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected CircularTickBase()
Protected Sub New
See Also

Reference

CircularTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickBase Properties

The CircularTickBase type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale.
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickBase.Radius Property

CircularTickBaseRadius Property

Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double Radius { get; }
Protected ReadOnly Property Radius As Double
    Get

Property Value

Type: Double
The radius.
See Also

Reference

CircularTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickBase.ScaleBarExtent Property

CircularTickBaseScaleBarExtent Property

Gets the extent of the bar in the associated ScaleBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ScaleBarExtent { get; }
Protected ReadOnly Property ScaleBarExtent As Double
    Get

Property Value

Type: Double
The extent of the bar.
See Also

Reference

CircularTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickBase.StartAngle Property

CircularTickBaseStartAngle Property

Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double StartAngle { get; }
Protected ReadOnly Property StartAngle As Double
    Get

Property Value

Type: Double
The start angle.
See Also

Reference

CircularTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickBase.SweepAngle Property

CircularTickBaseSweepAngle Property

Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double SweepAngle { get; }
Protected ReadOnly Property SweepAngle As Double
    Get

Property Value

Type: Double
The sweep angle.
See Also

Reference

CircularTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickBase Methods

The CircularTickBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickBase.CalculateAngle Method

CircularTickBaseCalculateAngle Method

Calculates an angle (not including the start angle) for the specified value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double CalculateAngle(
    double value
)
Protected Function CalculateAngle (
    value As Double
) As Double

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: Double
The angle of the specified value, not including the start angle.
See Also

Reference

CircularTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase Class

Represents the base class for circular tick labels.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickLabelBase
ActiproSoftware.Windows.Controls.GaugeCircularTickLabelCustom
ActiproSoftware.Windows.Controls.GaugeCircularTickLabelMajor
ActiproSoftware.Windows.Controls.GaugeCircularTickLabelMinor

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class CircularTickLabelBase : CircularTickBase
Public MustInherit Class CircularTickLabelBase
    Inherits CircularTickBase

The CircularTickLabelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CircularTickLabelBase | Initializes a new instance of the CircularTickLabelBase class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property.
Public property | FontSize | Gets or sets the size of the font. This is a dependency property.
Public property | FontStyle | Gets or sets the font style. This is a dependency property.
Public property | FontWeight | Gets or sets the font weight. This is a dependency property.
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property.
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element.
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. This field is read-only.
FontSizeProperty | Identifies the FontSize dependency property. This field is read-only.
FontStyleProperty | Identifies the FontStyle dependency property. This field is read-only.
FontWeightProperty | Identifies the FontWeight dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
RoundModeProperty | Identifies the RoundMode dependency property. This field is read-only.
TextFormatProperty | Identifies the TextFormat dependency property. This field is read-only.
TextOrientationProperty | Identifies the TextOrientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase Constructor

Initializes a new instance of the CircularTickLabelBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected CircularTickLabelBase()
Protected Sub New
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase Properties

The CircularTickLabelBase type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property.
Public property | FontSize | Gets or sets the size of the font. This is a dependency property.
Public property | FontStyle | Gets or sets the font style. This is a dependency property.
Public property | FontWeight | Gets or sets the font weight. This is a dependency property.
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property.
Public property | TextOrientation | Gets or sets the text orientation. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.FontFamily Property

CircularTickLabelBaseFontFamily Property

Gets or sets the font family. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontFamily FontFamily { get; set; }
Public Property FontFamily As FontFamily
    Get
    Set

Property Value

Type: FontFamily
The font family. The default value is SystemFonts.MessageFontFamily.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.FontSize Property

CircularTickLabelBaseFontSize Property

Gets or sets the size of the font. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit FontSize { get; set; }
Public Property FontSize As Unit
    Get
    Set

Property Value

Type: Unit
The size of the font. The default value is SystemFonts.MesssageFontSize.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.FontStyle Property

CircularTickLabelBaseFontStyle Property

Gets or sets the font style. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontStyle FontStyle { get; set; }
Public Property FontStyle As FontStyle
    Get
    Set

Property Value

Type: FontStyle
The font style. The default value is SystemFonts.MessageFontStyle.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.FontWeight Property

CircularTickLabelBaseFontWeight Property

Gets or sets the font weight. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontWeight FontWeight { get; set; }
Public Property FontWeight As FontWeight
    Get
    Set

Property Value

Type: FontWeight
The font weight. The default value is SystemFonts.MessageFontWeight.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.Foreground Property

CircularTickLabelBaseForeground Property

Gets or sets the foreground brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Foreground { get; set; }
Public Property Foreground As Brush
    Get
    Set

Property Value

Type: Brush
The foreground brush. The default value is WhiteSmoke.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.RoundMode Property

CircularTickLabelBaseRoundMode Property

Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RoundMode RoundMode { get; set; }
Public Property RoundMode As RoundMode
    Get
    Set

Property Value

Type: RoundMode
A RoundMode indicating how to round the values displayed. The default value is RoundMode.Round.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.TextFormat Property

CircularTickLabelBaseTextFormat Property

Gets or sets the format used to convert Value to a string. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TextFormat { get; set; }
Public Property TextFormat As String
    Get
    Set

Property Value

Type: String
The format used to convert Value to a string. The default value is "{0:G}".
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.TextOrientation Property

CircularTickLabelBaseTextOrientation Property

Gets or sets the text orientation. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TextOrientation TextOrientation { get; set; }
Public Property TextOrientation As TextOrientation
    Get
    Set

Property Value

Type: TextOrientation
The text orientation. The default value is TextOrienation.Normal.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase Methods

The CircularTickLabelBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element.
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.GetValues Method

CircularTickLabelBaseGetValues Method

Gets the values to be rendered by this tick label element.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract DoubleCollection GetValues()
Protected MustOverride Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick label element.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.GetValueText Method

CircularTickLabelBaseGetValueText Method

Gets the string representation of the specified value, using TextFormat and RoundMode.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string GetValueText(
    double value
)
Protected Overridable Function GetValueText (
    value As Double
) As String

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.OnRender Method

CircularTickLabelBaseOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase Fields

The CircularTickLabelBase type exposes the following members.

Fields
Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. This field is read-only.
FontSizeProperty | Identifies the FontSize dependency property. This field is read-only.
FontStyleProperty | Identifies the FontStyle dependency property. This field is read-only.
FontWeightProperty | Identifies the FontWeight dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
RoundModeProperty | Identifies the RoundMode dependency property. This field is read-only.
TextFormatProperty | Identifies the TextFormat dependency property. This field is read-only.
TextOrientationProperty | Identifies the TextOrientation dependency property. This field is read-only.
Top
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.FontFamilyProperty Field

CircularTickLabelBaseFontFamilyProperty Field

Identifies the FontFamily dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontFamilyProperty
Public Shared ReadOnly FontFamilyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontFamily dependency property.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.FontSizeProperty Field

CircularTickLabelBaseFontSizeProperty Field

Identifies the FontSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontSizeProperty
Public Shared ReadOnly FontSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontSize dependency property.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.FontStyleProperty Field

CircularTickLabelBaseFontStyleProperty Field

Identifies the FontStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontStyleProperty
Public Shared ReadOnly FontStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontStyle dependency property.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.FontWeightProperty Field

CircularTickLabelBaseFontWeightProperty Field

Identifies the FontWeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontWeightProperty
Public Shared ReadOnly FontWeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontWeight dependency property.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.ForegroundProperty Field

CircularTickLabelBaseForegroundProperty Field

Identifies the Foreground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundProperty
Public Shared ReadOnly ForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Foreground dependency property.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.RoundModeProperty Field

CircularTickLabelBaseRoundModeProperty Field

Identifies the RoundMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundModeProperty
Public Shared ReadOnly RoundModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundMode dependency property.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.TextFormatProperty Field

CircularTickLabelBaseTextFormatProperty Field

Identifies the TextFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextFormatProperty
Public Shared ReadOnly TextFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextFormat dependency property.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickLabelBase.TextOrientationProperty Field

CircularTickLabelBaseTextOrientationProperty Field

Identifies the TextOrientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextOrientationProperty
Public Shared ReadOnly TextOrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextOrientation dependency property.
See Also

Reference

CircularTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase Class

Represents the base class for circular tick marks.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickMarkBase
ActiproSoftware.Windows.Controls.GaugeCircularTickMarkCustom
ActiproSoftware.Windows.Controls.GaugeCircularTickMarkMajor
ActiproSoftware.Windows.Controls.GaugeCircularTickMarkMinor

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class CircularTickMarkBase : CircularTickBase
Public MustInherit Class CircularTickMarkBase
    Inherits CircularTickBase

The CircularTickMarkBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CircularTickMarkBase | Initializes a new instance of the CircularTickMarkBase class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property.
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property.
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
TickMarkAscentProperty | Identifies the TickMarkAscent dependency property. This field is read-only.
TickMarkExtentProperty | Identifies the TickMarkExtent dependency property. This field is read-only.
TickMarkTypeProperty | Identifies the TickMarkType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase Constructor

Initializes a new instance of the CircularTickMarkBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected CircularTickMarkBase()
Protected Sub New
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase Properties

The CircularTickMarkBase type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Radius | Gets the associated radius of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from CircularTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | StartAngle | Gets the associated start angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Protected property | SweepAngle | Gets the associated sweep angle of this element, which is inherited/set via an attached property on CircularScale. (Inherited from CircularTickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property.
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property.
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.Background Property

CircularTickMarkBaseBackground Property

Gets or sets the background brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Background { get; set; }
Public Property Background As Brush
    Get
    Set

Property Value

Type: Brush
The background brush. The default value is WhiteSmoke.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.Geometry Property

CircularTickMarkBaseGeometry Property

Gets or sets the custom geometry. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry Geometry { get; set; }
Public Property Geometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry. The default value is .
Remarks
This property is only used when TickMarkType is set to TickMarkType.CustomGeometry.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.ImageSource Property

CircularTickMarkBaseImageSource Property

Gets or sets the source of a custom image. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source. The default value is .
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.TickMarkAscent Property

CircularTickMarkBaseTickMarkAscent Property

Gets or sets the ascent of the tick mark. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit TickMarkAscent { get; set; }
Public Property TickMarkAscent As Unit
    Get
    Set

Property Value

Type: Unit
The ascent of the tick mark. The default value is 1 pixel.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.TickMarkExtent Property

CircularTickMarkBaseTickMarkExtent Property

Gets or sets the extent of the tick mark. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit TickMarkExtent { get; set; }
Public Property TickMarkExtent As Unit
    Get
    Set

Property Value

Type: Unit
The extent of the tick mark. The default value is 6 pixels.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.TickMarkType Property

CircularTickMarkBaseTickMarkType Property

Gets or sets the type of tick mark. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickMarkType TickMarkType { get; set; }
Public Property TickMarkType As TickMarkType
    Get
    Set

Property Value

Type: TickMarkType
The type of tick mark. The default value is TickMarkType.Rectangle.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase Methods

The CircularTickMarkBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateAngle | Calculates an angle (not including the start angle) for the specified value. (Inherited from CircularTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.GetValues Method

CircularTickMarkBaseGetValues Method

Gets the values to be rendered by this tick mark element.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract DoubleCollection GetValues()
Protected MustOverride Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick mark element.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.OnRender Method

CircularTickMarkBaseOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase Fields

The CircularTickMarkBase type exposes the following members.

Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
TickMarkAscentProperty | Identifies the TickMarkAscent dependency property. This field is read-only.
TickMarkExtentProperty | Identifies the TickMarkExtent dependency property. This field is read-only.
TickMarkTypeProperty | Identifies the TickMarkType dependency property. This field is read-only.
Top
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.BackgroundProperty Field

CircularTickMarkBaseBackgroundProperty Field

Identifies the Background dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundProperty
Public Shared ReadOnly BackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Background dependency property.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.GeometryProperty Field

CircularTickMarkBaseGeometryProperty Field

Identifies the Geometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GeometryProperty
Public Shared ReadOnly GeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Geometry dependency property.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.ImageSourceProperty Field

CircularTickMarkBaseImageSourceProperty Field

Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.TickMarkAscentProperty Field

CircularTickMarkBaseTickMarkAscentProperty Field

Identifies the TickMarkAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMarkAscentProperty
Public Shared ReadOnly TickMarkAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMarkAscent dependency property.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.TickMarkExtentProperty Field

CircularTickMarkBaseTickMarkExtentProperty Field

Identifies the TickMarkExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMarkExtentProperty
Public Shared ReadOnly TickMarkExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMarkExtent dependency property.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


CircularTickMarkBase.TickMarkTypeProperty Field

CircularTickMarkBaseTickMarkTypeProperty Field

Identifies the TickMarkType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMarkTypeProperty
Public Shared ReadOnly TickMarkTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMarkType dependency property.
See Also

Reference

CircularTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase Class

Represents the base class for all Gauge controls.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesRectangularGaugeBase

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class GaugeBase : GaugeElement
Public MustInherit Class GaugeBase
    Inherits GaugeElement

The GaugeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | GaugeBase | Initializes a new instance of the GaugeBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property.
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property.
Public property | Items | Gets the UIElement objects within the gauge.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property.
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property.
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property.
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property.
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size.
 | GetOrigin | Gets the value of the OriginProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
 | GetX | Gets the value of the XProperty attached property for a specified object.
 | GetY | Gets the value of the YProperty attached property for a specified object.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetOrigin | Sets the value of the OriginProperty attached property to a specified object.
 | SetX | Sets the value of the XProperty attached property to a specified object.
 | SetY | Sets the value of the YProperty attached property to a specified object.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
IsBackgroundEffectEnabledProperty | Identifies the IsBackgroundEffectEnabled dependency property. This field is read-only.
IsRimEffectEnabledProperty | Identifies the IsRimEffectEnabled dependency property. This field is read-only.
OriginProperty | Identifies the Origin dependency property. This field is read-only.
RimBrushProperty | Identifies the RimBrush dependency property. This field is read-only.
UnitBaseXProperty | Identifies the read-only UnitBaseX dependency property. This field is read-only.
UnitBaseYProperty | Identifies the read-only UnitBaseY dependency property. This field is read-only.
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase Constructor

Initializes a new instance of the GaugeBase class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected GaugeBase()
Protected Sub New
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase Properties

The GaugeBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property.
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property.
Public property | Items | Gets the UIElement objects within the gauge.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property.
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property.
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property.
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property.
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.Background Property

GaugeBaseBackground Property

Gets or sets the background brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Background { get; set; }
Public Property Background As Brush
    Get
    Set

Property Value

Type: Brush
The background brush.. The default value is Gray.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.IsBackgroundEffectEnabled Property

GaugeBaseIsBackgroundEffectEnabled Property

Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsBackgroundEffectEnabled { get; set; }
Public Property IsBackgroundEffectEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the background effect is enabled; otherwise, false. The default value is true.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.IsRimEffectEnabled Property

GaugeBaseIsRimEffectEnabled Property

Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsRimEffectEnabled { get; set; }
Public Property IsRimEffectEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the rim effect is enabled; otherwise, false. The default value is true.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.Items Property

GaugeBaseItems Property

Gets the UIElement objects within the gauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LogicalChildrenCollection<UIElement> Items { get; }
Public ReadOnly Property Items As LogicalChildrenCollection(Of UIElement)
    Get

Property Value

Type: LogicalChildrenCollection UIElement
The items.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.LogicalChildren Property

GaugeBaseLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.Origin Property

GaugeBaseOrigin Property

Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CoordinateOrigin Origin { get; set; }
Public Property Origin As CoordinateOrigin
    Get
    Set

Property Value

Type: CoordinateOrigin
The coordinate origin. The default value is Center.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.RimBrush Property

GaugeBaseRimBrush Property

Gets or sets the rim brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush RimBrush { get; set; }
Public Property RimBrush As Brush
    Get
    Set

Property Value

Type: Brush
The rim brush. The default value is DarkGray.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.UnitBaseX Property

GaugeBaseUnitBaseX Property

Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double UnitBaseX { get; protected set; }
Public Property UnitBaseX As Double
    Get
    Protected Set

Property Value

Type: Double
The base value used to convert Unit types to a double along the x-axis.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.UnitBaseY Property

GaugeBaseUnitBaseY Property

Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double UnitBaseY { get; protected set; }
Public Property UnitBaseY As Double
    Get
    Protected Set

Property Value

Type: Double
The base value used to convert Unit types to a double along the y-axis.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.X Property

GaugeBaseX Property

Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit X { get; set; }
Public Property X As Unit
    Get
    Set

Property Value

Type: Unit
The X-coordinate. The default value is 0px.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.Y Property

GaugeBaseY Property

Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit Y { get; set; }
Public Property Y As Unit
    Get
    Set

Property Value

Type: Unit
The Y-coordinate. The default value is 0px.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase Methods

The GaugeBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size.
 | GetOrigin | Gets the value of the OriginProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
 | GetX | Gets the value of the XProperty attached property for a specified object.
 | GetY | Gets the value of the YProperty attached property for a specified object.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetOrigin | Sets the value of the OriginProperty attached property to a specified object.
 | SetX | Sets the value of the XProperty attached property to a specified object.
 | SetY | Sets the value of the YProperty attached property to a specified object.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.ArrangeOverride Method

GaugeBaseArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.GetLocation Method

GaugeBaseGetLocation Method

Gets the location of the given element assuming the specified size.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Point GetLocation(
    UIElement element,
    Size size
)
Protected Overridable Function GetLocation (
    element As UIElement,
    size As Size
) As Point

Parameters

element
Type: System.WindowsUIElement
The element.
size
Type: System.WindowsSize
The size.

Return Value

Type: Point

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Gauge.Primitives.GaugeBase.GetLocation(System.Windows.UIElement,System.Windows.Size)"]

See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.GetOrigin Method

GaugeBaseGetOrigin Method

Gets the value of the OriginProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static CoordinateOrigin GetOrigin(
    DependencyObject obj
)
Public Shared Function GetOrigin (
    obj As DependencyObject
) As CoordinateOrigin

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: CoordinateOrigin
The coordinate origin.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.GetX Method

GaugeBaseGetX Method

Gets the value of the XProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit GetX(
    DependencyObject obj
)
Public Shared Function GetX (
    obj As DependencyObject
) As Unit

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Unit
The X-coordinate value.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.GetY Method

GaugeBaseGetY Method

Gets the value of the YProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit GetY(
    DependencyObject obj
)
Public Shared Function GetY (
    obj As DependencyObject
) As Unit

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Unit
The Y-coordinate value.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.MeasureOverride Method

GaugeBaseMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.OnCreateAutomationPeer Method

GaugeBaseOnCreateAutomationPeer Method

Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Gauge.Primitives.GaugeBase.OnCreateAutomationPeer"]

See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.OnRenderSizeChanged Method

GaugeBaseOnRenderSizeChanged Method

Raises the SizeChanged event, using the specified information as part of the eventual event data.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRenderSizeChanged(
    SizeChangedInfo sizeInfo
)
Protected Overrides Sub OnRenderSizeChanged (
    sizeInfo As SizeChangedInfo
)

Parameters

sizeInfo
Type: System.WindowsSizeChangedInfo
Details of the old and new size involved in the change.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.SetOrigin Method

GaugeBaseSetOrigin Method

Sets the value of the OriginProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetOrigin(
    DependencyObject obj,
    CoordinateOrigin value
)
Public Shared Sub SetOrigin (
    obj As DependencyObject,
    value As CoordinateOrigin
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.Windows.Controls.GaugeCoordinateOrigin
The coordinate origin.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.SetX Method

GaugeBaseSetX Method

Sets the value of the XProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetX(
    DependencyObject obj,
    Unit value
)
Public Shared Sub SetX (
    obj As DependencyObject,
    value As Unit
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.WindowsUnit
The X-coordinate value.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.SetY Method

GaugeBaseSetY Method

Sets the value of the YProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetY(
    DependencyObject obj,
    Unit value
)
Public Shared Sub SetY (
    obj As DependencyObject,
    value As Unit
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.WindowsUnit
The Y-coordinate value.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.ToBitmap Method

GaugeBaseToBitmap Method

Creates a BitmapSource based on the contents of the gauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BitmapSource ToBitmap(
    double dpiX,
    double dpiY
)
Public Function ToBitmap (
    dpiX As Double,
    dpiY As Double
) As BitmapSource

Parameters

dpiX
Type: SystemDouble
The x DPI.
dpiY
Type: SystemDouble
The y DPI.

Return Value

Type: BitmapSource
The BitmapSource that was created.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.UpdateUnitBases Method

GaugeBaseUpdateUnitBases Method

Updates UnitBaseX and UnitBaseY.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateUnitBases()
Protected Overridable Sub UpdateUnitBases
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase Fields

The GaugeBase type exposes the following members.

Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
IsBackgroundEffectEnabledProperty | Identifies the IsBackgroundEffectEnabled dependency property. This field is read-only.
IsRimEffectEnabledProperty | Identifies the IsRimEffectEnabled dependency property. This field is read-only.
OriginProperty | Identifies the Origin dependency property. This field is read-only.
RimBrushProperty | Identifies the RimBrush dependency property. This field is read-only.
UnitBaseXProperty | Identifies the read-only UnitBaseX dependency property. This field is read-only.
UnitBaseYProperty | Identifies the read-only UnitBaseY dependency property. This field is read-only.
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
Top
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.BackgroundProperty Field

GaugeBaseBackgroundProperty Field

Identifies the Background dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundProperty
Public Shared ReadOnly BackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Background dependency property.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.IsBackgroundEffectEnabledProperty Field

GaugeBaseIsBackgroundEffectEnabledProperty Field

Identifies the IsBackgroundEffectEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsBackgroundEffectEnabledProperty
Public Shared ReadOnly IsBackgroundEffectEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsBackgroundEffectEnabled dependency property.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.IsRimEffectEnabledProperty Field

GaugeBaseIsRimEffectEnabledProperty Field

Identifies the IsRimEffectEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRimEffectEnabledProperty
Public Shared ReadOnly IsRimEffectEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRimEffectEnabled dependency property.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.OriginProperty Field

GaugeBaseOriginProperty Field

Identifies the Origin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OriginProperty
Public Shared ReadOnly OriginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Origin dependency property.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.RimBrushProperty Field

GaugeBaseRimBrushProperty Field

Identifies the RimBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RimBrushProperty
Public Shared ReadOnly RimBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RimBrush dependency property.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.UnitBaseXProperty Field

GaugeBaseUnitBaseXProperty Field

Identifies the read-only UnitBaseX dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UnitBaseXProperty
Public Shared ReadOnly UnitBaseXProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UnitBaseX dependency property.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.UnitBaseYProperty Field

GaugeBaseUnitBaseYProperty Field

Identifies the read-only UnitBaseY dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UnitBaseYProperty
Public Shared ReadOnly UnitBaseYProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UnitBaseY dependency property.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.XProperty Field

GaugeBaseXProperty Field

Identifies the X dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XProperty
Public Shared ReadOnly XProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the X dependency property.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeBase.YProperty Field

GaugeBaseYProperty Field

Identifies the Y dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YProperty
Public Shared ReadOnly YProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Y dependency property.
See Also

Reference

GaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement Class

Represents the base class of all gauge elements.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
More...

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class GaugeElement : FrameworkElement,
    ILogicalParent, IVisualParent
Public MustInherit Class GaugeElement
    Inherits FrameworkElement
    Implements ILogicalParent, IVisualParent

The GaugeElement type exposes the following members.

Constructors
 | Name | Description
Protected method | GaugeElement | Initializes a new instance of the GaugeElement class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element.
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Overrides FrameworkElementVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Overrides FrameworkElementGetVisualChild(Int32).)
 | GetZIndex | Gets the value of the ZIndexProperty attached property for a specified object.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetZIndex | Sets the value of the ZIndexProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
ZIndexProperty | Identifies the ZIndex dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesRangeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesScaleBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickSetBase


GaugeElement Constructor

Initializes a new instance of the GaugeElement class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected GaugeElement()
Protected Sub New
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement Properties

The GaugeElement type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element.
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Overrides FrameworkElementVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property.
Top
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement.VisualChildren Property

GaugeElementVisualChildren Property

Gets the visual child elements within this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual VisualCollection VisualChildren { get; }
Protected Overridable ReadOnly Property VisualChildren As VisualCollection
    Get

Property Value

Type: VisualCollection
The visual children.
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement.VisualChildrenCount Property

GaugeElementVisualChildrenCount Property

Gets the number of visual child elements within this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override int VisualChildrenCount { get; }
Protected Overrides ReadOnly Property VisualChildrenCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
The number of visual child elements for this element.
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement.ZIndex Property

GaugeElementZIndex Property

Gets or sets the z-index of the this element. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int ZIndex { get; set; }
Public Property ZIndex As Integer
    Get
    Set

Property Value

Type: Int32
The z-index of the this element. The default value is 0.
Remarks
This z-index is only used when the visual parent of this element is a GaugeElement.
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement Methods

The GaugeElement type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Overrides FrameworkElementGetVisualChild(Int32).)
 | GetZIndex | Gets the value of the ZIndexProperty attached property for a specified object.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetZIndex | Sets the value of the ZIndexProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement.GetVisualChild Method

GaugeElementGetVisualChild Method

Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Visual GetVisualChild(
    int index
)
Protected Overrides Function GetVisualChild (
    index As Integer
) As Visual

Parameters

index
Type: SystemInt32
The zero-based index of the requested child element in the collection.

Return Value

Type: Visual
The requested child element. This should not return null; if the provided index is out of range, an exception is thrown.
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement.GetZIndex Method

GaugeElementGetZIndex Method

Gets the value of the ZIndexProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static int GetZIndex(
    UIElement element
)
Public Shared Function GetZIndex (
    element As UIElement
) As Integer

Parameters

element
Type: System.WindowsUIElement
The object to which the attached property is retrieved.

Return Value

Type: Int32
The z-index.
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement.SetZIndex Method

GaugeElementSetZIndex Method

Sets the value of the ZIndexProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetZIndex(
    UIElement element,
    int value
)
Public Shared Sub SetZIndex (
    element As UIElement,
    value As Integer
)

Parameters

element
Type: System.WindowsUIElement
The object to which the attached property is written.
value
Type: SystemInt32
The z-index.
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement Fields

The GaugeElement type exposes the following members.

Fields
Name | Description
ZIndexProperty | Identifies the ZIndex dependency property. This field is read-only.
Top
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


GaugeElement.ZIndexProperty Field

GaugeElementZIndexProperty Field

Identifies the ZIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZIndexProperty
Public Shared ReadOnly ZIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZIndex dependency property.
See Also

Reference

GaugeElement Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase Class

Represents a base class for linear pointers.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearPointerBase
ActiproSoftware.Windows.Controls.GaugeLinearPointerBar
ActiproSoftware.Windows.Controls.GaugeLinearPointerLabel
ActiproSoftware.Windows.Controls.GaugeLinearPointerMarker

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LinearPointerBase : PointerBase
Public MustInherit Class LinearPointerBase
    Inherits PointerBase

The LinearPointerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LinearPointerBase | Initializes a new instance of the LinearPointerBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge.
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueExtent | Gets or sets the extent used to display the Value on the linear gauge. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value.
Protected method | CalculateValue(Double) | Calculates the value based on a specified extent.
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Overrides PointerBaseCalculateValue(Point).)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property.
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueExtent | Updates the ValueExtent property.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
Fields
Name | Description
ValueExtentProperty | Identifies the ValueExtent dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase Constructor

Initializes a new instance of the LinearPointerBase class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LinearPointerBase()
Protected Sub New
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase Properties

The LinearPointerBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from PointerBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from PointerBase.)
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property. (Inherited from PointerBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property. (Inherited from PointerBase.)
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property. (Inherited from PointerBase.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property. (Inherited from PointerBase.)
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property. (Inherited from PointerBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from PointerBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from PointerBase.)
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property. (Inherited from PointerBase.)
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property. (Inherited from PointerBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from PointerBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from PointerBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from PointerBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge.
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property. (Inherited from PointerBase.)
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property. (Inherited from PointerBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from PointerBase.)
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property. (Inherited from PointerBase.)
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property. (Inherited from PointerBase.)
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate. (Inherited from PointerBase.)
Public property | Value | Gets or sets the value. This is a dependency property. (Inherited from PointerBase.)
Protected property | ValueExtent | Gets or sets the extent used to display the Value on the linear gauge. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.Orientation Property

LinearPointerBaseOrientation Property

Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Orientation Orientation { get; }
Protected ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The radius.
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.ScaleBarAscent Property

LinearPointerBaseScaleBarAscent Property

Gets the ascent of the bar in the associated ScaleBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ScaleBarAscent { get; }
Protected ReadOnly Property ScaleBarAscent As Double
    Get

Property Value

Type: Double
The ascent of the bar.
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.ScaleBarExtent Property

LinearPointerBaseScaleBarExtent Property

Gets the extent of the bar in the associated ScaleBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ScaleBarExtent { get; }
Protected ReadOnly Property ScaleBarExtent As Double
    Get

Property Value

Type: Double
The extent of the bar.
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.ValueExtent Property

LinearPointerBaseValueExtent Property

Gets or sets the extent used to display the Value on the linear gauge. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ValueExtent { get; set; }
Protected Property ValueExtent As Double
    Get
    Set

Property Value

Type: Double
The value extent. The default value is 0.
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase Methods

The LinearPointerBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value.
Protected method | CalculateValue(Double) | Calculates the value based on a specified extent.
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Overrides PointerBaseCalculateValue(Point).)
Public method | CancelDrag | Cancels a drag operation for the PointerBase. (Inherited from PointerBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from PointerBase.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from PointerBase.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnValueChanged | Invoked when the Value property is changed. (Inherited from PointerBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateDisplayValue | Updates the DisplayValue property.
Protected method | UpdateValue | Updates the value of this pointer based on the specified point. (Inherited from PointerBase.)
Protected method | UpdateValueExtent | Updates the ValueExtent property.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.CalculateExtent Method

LinearPointerBaseCalculateExtent Method

Calculates an extent (not including the left/top offsets) for the specified value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double CalculateExtent(
    double value
)
Protected Function CalculateExtent (
    value As Double
) As Double

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: Double
The extent of the specified value, not including the left/top offsets.
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.CalculateValue Method

LinearPointerBaseCalculateValue Method

Overload List
 | Name | Description
Protected method | CalculateValue(Double) | Calculates the value based on a specified extent.
Protected method | CalculateValue(Point) | Calculates the value based on a specified point. (Overrides PointerBaseCalculateValue(Point).)
Top
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.CalculateValue Method (Double)

LinearPointerBaseCalculateValue Method (Double)

Calculates the value based on a specified extent.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double CalculateValue(
    double extent
)
Protected Function CalculateValue (
    extent As Double
) As Double

Parameters

extent
Type: SystemDouble
The extent.

Return Value

Type: Double
The value of the specified extent.
See Also

Reference

LinearPointerBase Class
CalculateValue Overload
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.CalculateValue Method (Point)

LinearPointerBaseCalculateValue Method (Point)

Calculates the value based on a specified point.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override double CalculateValue(
    Point point
)
Protected Overrides Function CalculateValue (
    point As Point
) As Double

Parameters

point
Type: System.WindowsPoint
The point.

Return Value

Type: Double
The value of specified point.
See Also

Reference

LinearPointerBase Class
CalculateValue Overload
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.OnRenderSizeChanged Method

LinearPointerBaseOnRenderSizeChanged Method

Raises the SizeChanged event, using the specified information as part of the eventual event data.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRenderSizeChanged(
    SizeChangedInfo sizeInfo
)
Protected Overrides Sub OnRenderSizeChanged (
    sizeInfo As SizeChangedInfo
)

Parameters

sizeInfo
Type: System.WindowsSizeChangedInfo
Details of the old and new size involved in the change.
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.UpdateDisplayValue Method

LinearPointerBaseUpdateDisplayValue Method

Updates the DisplayValue property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateDisplayValue()
Protected Overridable Sub UpdateDisplayValue
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.UpdateValueExtent Method

LinearPointerBaseUpdateValueExtent Method

Updates the ValueExtent property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateValueExtent()
Protected Overridable Sub UpdateValueExtent
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase Events

The LinearPointerBase type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed. (Inherited from PointerBase.)
Public event | ValueChanging | Occurs before the Value is changed. (Inherited from PointerBase.)
Top
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase Fields

The LinearPointerBase type exposes the following members.

Fields
Name | Description
ValueExtentProperty | Identifies the ValueExtent dependency property. This field is read-only.
Top
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearPointerBase.ValueExtentProperty Field

LinearPointerBaseValueExtentProperty Field

Identifies the ValueExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected static readonly DependencyProperty ValueExtentProperty
Protected Shared ReadOnly ValueExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueExtent dependency property.
See Also

Reference

LinearPointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickBase Class

Represents the base class for linear tick marks and labels.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickLabelBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickMarkBase

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LinearTickBase : TickBase
Public MustInherit Class LinearTickBase
    Inherits TickBase

The LinearTickBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LinearTickBase | Initializes a new instance of the LinearTickBase class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge.
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickBase Constructor

Initializes a new instance of the LinearTickBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LinearTickBase()
Protected Sub New
See Also

Reference

LinearTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickBase Properties

The LinearTickBase type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge.
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase.
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickBase.Orientation Property

LinearTickBaseOrientation Property

Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Orientation Orientation { get; }
Protected ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The orientation.
See Also

Reference

LinearTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickBase.ScaleBarAscent Property

LinearTickBaseScaleBarAscent Property

Gets the ascent of the bar in the associated ScaleBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ScaleBarAscent { get; }
Protected ReadOnly Property ScaleBarAscent As Double
    Get

Property Value

Type: Double
The ascent of the bar.
See Also

Reference

LinearTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickBase.ScaleBarExtent Property

LinearTickBaseScaleBarExtent Property

Gets the extent of the bar in the associated ScaleBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double ScaleBarExtent { get; }
Protected ReadOnly Property ScaleBarExtent As Double
    Get

Property Value

Type: Double
The extent of the bar.
See Also

Reference

LinearTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickBase Methods

The LinearTickBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickBase.CalculateExtent Method

LinearTickBaseCalculateExtent Method

Calculates an extent (not including the left/top offsets) for the specified value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double CalculateExtent(
    double value
)
Protected Function CalculateExtent (
    value As Double
) As Double

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: Double

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Gauge.Primitives.LinearTickBase.CalculateExtent(System.Double)"]

See Also

Reference

LinearTickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase Class

Represents the base class for linear tick labels.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickLabelBase
ActiproSoftware.Windows.Controls.GaugeLinearTickLabelCustom
ActiproSoftware.Windows.Controls.GaugeLinearTickLabelMajor
ActiproSoftware.Windows.Controls.GaugeLinearTickLabelMinor

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LinearTickLabelBase : LinearTickBase
Public MustInherit Class LinearTickLabelBase
    Inherits LinearTickBase

The LinearTickLabelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LinearTickLabelBase | Initializes a new instance of the LinearTickLabelBase class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property.
Public property | FontSize | Gets or sets the size of the font. This is a dependency property.
Public property | FontStyle | Gets or sets the font style. This is a dependency property.
Public property | FontWeight | Gets or sets the font weight. This is a dependency property.
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element.
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. This field is read-only.
FontSizeProperty | Identifies the FontSize dependency property. This field is read-only.
FontStyleProperty | Identifies the FontStyle dependency property. This field is read-only.
FontWeightProperty | Identifies the FontWeight dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
RoundModeProperty | Identifies the RoundMode dependency property. This field is read-only.
TextFormatProperty | Identifies the TextFormat dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase Constructor

Initializes a new instance of the LinearTickLabelBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LinearTickLabelBase()
Protected Sub New
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase Properties

The LinearTickLabelBase type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family. This is a dependency property.
Public property | FontSize | Gets or sets the size of the font. This is a dependency property.
Public property | FontStyle | Gets or sets the font style. This is a dependency property.
Public property | FontWeight | Gets or sets the font weight. This is a dependency property.
Public property | Foreground | Gets or sets the foreground brush. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Public property | RoundMode | Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | TextFormat | Gets or sets the format used to convert Value to a string. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.FontFamily Property

LinearTickLabelBaseFontFamily Property

Gets or sets the font family. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontFamily FontFamily { get; set; }
Public Property FontFamily As FontFamily
    Get
    Set

Property Value

Type: FontFamily
The font family. The default value is SystemFonts.MessageFontFamily.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.FontSize Property

LinearTickLabelBaseFontSize Property

Gets or sets the size of the font. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit FontSize { get; set; }
Public Property FontSize As Unit
    Get
    Set

Property Value

Type: Unit
The size of the font. The default value is SystemFonts.MesssageFontSize.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.FontStyle Property

LinearTickLabelBaseFontStyle Property

Gets or sets the font style. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontStyle FontStyle { get; set; }
Public Property FontStyle As FontStyle
    Get
    Set

Property Value

Type: FontStyle
The font style. The default value is SystemFonts.MessageFontStyle.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.FontWeight Property

LinearTickLabelBaseFontWeight Property

Gets or sets the font weight. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontWeight FontWeight { get; set; }
Public Property FontWeight As FontWeight
    Get
    Set

Property Value

Type: FontWeight
The font weight. The default value is SystemFonts.MessageFontWeight.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.Foreground Property

LinearTickLabelBaseForeground Property

Gets or sets the foreground brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Foreground { get; set; }
Public Property Foreground As Brush
    Get
    Set

Property Value

Type: Brush
The foreground brush. The default value is WhiteSmoke.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.RoundMode Property

LinearTickLabelBaseRoundMode Property

Gets or sets a RoundMode indicating how to round the values displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RoundMode RoundMode { get; set; }
Public Property RoundMode As RoundMode
    Get
    Set

Property Value

Type: RoundMode
A RoundMode indicating how to round the values displayed. The default value is RoundMode.Round.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.TextFormat Property

LinearTickLabelBaseTextFormat Property

Gets or sets the format used to convert Value to a string. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string TextFormat { get; set; }
Public Property TextFormat As String
    Get
    Set

Property Value

Type: String
The format used to convert Value to a string. The default value is "{0:G}".
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase Methods

The LinearTickLabelBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick label element.
Protected method | GetValueText | Gets the string representation of the specified value, using TextFormat and RoundMode.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.GetValues Method

LinearTickLabelBaseGetValues Method

Gets the values to be rendered by this tick label element.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract DoubleCollection GetValues()
Protected MustOverride Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick label element.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.GetValueText Method

LinearTickLabelBaseGetValueText Method

Gets the string representation of the specified value, using TextFormat and RoundMode.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string GetValueText(
    double value
)
Protected Overridable Function GetValueText (
    value As Double
) As String

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.OnRender Method

LinearTickLabelBaseOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase Fields

The LinearTickLabelBase type exposes the following members.

Fields
Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. This field is read-only.
FontSizeProperty | Identifies the FontSize dependency property. This field is read-only.
FontStyleProperty | Identifies the FontStyle dependency property. This field is read-only.
FontWeightProperty | Identifies the FontWeight dependency property. This field is read-only.
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
RoundModeProperty | Identifies the RoundMode dependency property. This field is read-only.
TextFormatProperty | Identifies the TextFormat dependency property. This field is read-only.
Top
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.FontFamilyProperty Field

LinearTickLabelBaseFontFamilyProperty Field

Identifies the FontFamily dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontFamilyProperty
Public Shared ReadOnly FontFamilyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontFamily dependency property.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.FontSizeProperty Field

LinearTickLabelBaseFontSizeProperty Field

Identifies the FontSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontSizeProperty
Public Shared ReadOnly FontSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontSize dependency property.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.FontStyleProperty Field

LinearTickLabelBaseFontStyleProperty Field

Identifies the FontStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontStyleProperty
Public Shared ReadOnly FontStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontStyle dependency property.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.FontWeightProperty Field

LinearTickLabelBaseFontWeightProperty Field

Identifies the FontWeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontWeightProperty
Public Shared ReadOnly FontWeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FontWeight dependency property.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.ForegroundProperty Field

LinearTickLabelBaseForegroundProperty Field

Identifies the Foreground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundProperty
Public Shared ReadOnly ForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Foreground dependency property.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.RoundModeProperty Field

LinearTickLabelBaseRoundModeProperty Field

Identifies the RoundMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoundModeProperty
Public Shared ReadOnly RoundModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RoundMode dependency property.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickLabelBase.TextFormatProperty Field

LinearTickLabelBaseTextFormatProperty Field

Identifies the TextFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextFormatProperty
Public Shared ReadOnly TextFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TextFormat dependency property.
See Also

Reference

LinearTickLabelBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase Class

Represents the base class for linear tick marks.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickMarkBase
ActiproSoftware.Windows.Controls.GaugeLinearTickMarkCustom
ActiproSoftware.Windows.Controls.GaugeLinearTickMarkMajor
ActiproSoftware.Windows.Controls.GaugeLinearTickMarkMinor

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class LinearTickMarkBase : LinearTickBase
Public MustInherit Class LinearTickMarkBase
    Inherits LinearTickBase

The LinearTickMarkBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LinearTickMarkBase | Initializes a new instance of the LinearTickMarkBase class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property.
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property.
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
TickMarkAscentProperty | Identifies the TickMarkAscent dependency property. This field is read-only.
TickMarkExtentProperty | Identifies the TickMarkExtent dependency property. This field is read-only.
TickMarkTypeProperty | Identifies the TickMarkType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase Constructor

Initializes a new instance of the LinearTickMarkBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected LinearTickMarkBase()
Protected Sub New
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase Properties

The LinearTickMarkBase type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property. (Inherited from TickBase.)
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property. (Inherited from TickBase.)
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property. (Inherited from TickBase.)
Public property | BorderWidth | Gets or sets the border width. This is a dependency property. (Inherited from TickBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Geometry | Gets or sets the custom geometry. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property. (Inherited from TickBase.)
Public property | ImageSource | Gets or sets the source of a custom image. This is a dependency property.
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property. (Inherited from TickBase.)
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale. (Inherited from TickBase.)
Protected property | IsReversed | Gets a value indicating whether this instance is reversed. (Inherited from TickBase.)
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale. (Inherited from TickBase.)
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property. (Inherited from TickBase.)
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Maximum | Gets the maximum value. (Inherited from TickBase.)
Protected property | Minimum | Gets the minimum value. (Inherited from TickBase.)
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property. (Inherited from TickBase.)
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property. (Inherited from TickBase.)
Protected property | Orientation | Gets the associated orientation of this element, which is inherited/set via an attached property on LinearGauge. (Inherited from LinearTickBase.)
Protected property | ScaleBarAscent | Gets the ascent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Protected property | ScaleBarExtent | Gets the extent of the bar in the associated ScaleBase. (Inherited from LinearTickBase.)
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property. (Inherited from TickBase.)
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property. (Inherited from TickBase.)
Public property | TickMarkAscent | Gets or sets the ascent of the tick mark. This is a dependency property.
Public property | TickMarkExtent | Gets or sets the extent of the tick mark. This is a dependency property.
Public property | TickMarkType | Gets or sets the type of tick mark. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.Background Property

LinearTickMarkBaseBackground Property

Gets or sets the background brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Background { get; set; }
Public Property Background As Brush
    Get
    Set

Property Value

Type: Brush
The background brush. The default value is WhiteSmoke.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.Geometry Property

LinearTickMarkBaseGeometry Property

Gets or sets the custom geometry. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry Geometry { get; set; }
Public Property Geometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry. The default value is .
Remarks
This property is only used when TickMarkType is set to TickMarkType.CustomGeometry.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.ImageSource Property

LinearTickMarkBaseImageSource Property

Gets or sets the source of a custom image. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source. The default value is .
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.TickMarkAscent Property

LinearTickMarkBaseTickMarkAscent Property

Gets or sets the ascent of the tick mark. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit TickMarkAscent { get; set; }
Public Property TickMarkAscent As Unit
    Get
    Set

Property Value

Type: Unit
The ascent of the tick mark. The default value is 1 pixel.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.TickMarkExtent Property

LinearTickMarkBaseTickMarkExtent Property

Gets or sets the extent of the tick mark. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit TickMarkExtent { get; set; }
Public Property TickMarkExtent As Unit
    Get
    Set

Property Value

Type: Unit
The extent of the tick mark. The default value is 6 pixels.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.TickMarkType Property

LinearTickMarkBaseTickMarkType Property

Gets or sets the type of tick mark. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TickMarkType TickMarkType { get; set; }
Public Property TickMarkType As TickMarkType
    Get
    Set

Property Value

Type: TickMarkType
The type of tick mark. The default value is TickMarkType.Rectangle.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase Methods

The LinearTickMarkBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateExtent | Calculates an extent (not including the left/top offsets) for the specified value. (Inherited from LinearTickBase.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetValues | Gets the values to be rendered by this tick mark element.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.GetValues Method

LinearTickMarkBaseGetValues Method

Gets the values to be rendered by this tick mark element.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract DoubleCollection GetValues()
Protected MustOverride Function GetValues As DoubleCollection

Return Value

Type: DoubleCollection
Zero or more values to be rendered by this tick mark element.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.OnRender Method

LinearTickMarkBaseOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase Fields

The LinearTickMarkBase type exposes the following members.

Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
TickMarkAscentProperty | Identifies the TickMarkAscent dependency property. This field is read-only.
TickMarkExtentProperty | Identifies the TickMarkExtent dependency property. This field is read-only.
TickMarkTypeProperty | Identifies the TickMarkType dependency property. This field is read-only.
Top
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.BackgroundProperty Field

LinearTickMarkBaseBackgroundProperty Field

Identifies the Background dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundProperty
Public Shared ReadOnly BackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Background dependency property.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.GeometryProperty Field

LinearTickMarkBaseGeometryProperty Field

Identifies the Geometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GeometryProperty
Public Shared ReadOnly GeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Geometry dependency property.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.ImageSourceProperty Field

LinearTickMarkBaseImageSourceProperty Field

Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.TickMarkAscentProperty Field

LinearTickMarkBaseTickMarkAscentProperty Field

Identifies the TickMarkAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMarkAscentProperty
Public Shared ReadOnly TickMarkAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMarkAscent dependency property.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.TickMarkExtentProperty Field

LinearTickMarkBaseTickMarkExtentProperty Field

Identifies the TickMarkExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMarkExtentProperty
Public Shared ReadOnly TickMarkExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMarkExtent dependency property.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


LinearTickMarkBase.TickMarkTypeProperty Field

LinearTickMarkBaseTickMarkTypeProperty Field

Identifies the TickMarkType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMarkTypeProperty
Public Shared ReadOnly TickMarkTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMarkType dependency property.
See Also

Reference

LinearTickMarkBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase Class

Represents a base class for pointers.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularPointerBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearPointerBase

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class PointerBase : GaugeElement
Public MustInherit Class PointerBase
    Inherits GaugeElement

The PointerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PointerBase | Initializes a new instance of the PointerBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property.
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property.
Public property | BorderWidth | Gets or sets the border width. This is a dependency property.
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property.
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property.
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property.
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property.
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property.
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale.
Protected property | IsReversed | Gets a value indicating whether this instance is reversed.
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property.
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property.
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property.
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale.
Protected property | Maximum | Gets the maximum value.
Protected property | Minimum | Gets the minimum value.
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property.
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property.
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property.
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property.
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property.
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate.
Public property | Value | Gets or sets the value. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateValue | Calculates the value based on a specified point.
Public method | CancelDrag | Cancels a drag operation for the PointerBase.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnValueChanged | Invoked when the Value property is changed.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed.
Public event | ValueChanging | Occurs before the Value is changed.
Top
Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderDashStyleProperty | Identifies the BorderDashStyle dependency property. This field is read-only.
BorderWidthProperty | Identifies the BorderWidth dependency property. This field is read-only.
CanDragProperty | Identifies the CanDrag dependency property. This field is read-only.
DampeningMaximumDurationProperty | Identifies the DampeningMaximumDuration dependency property. This field is read-only.
DampeningMinimumDurationProperty | Identifies the DampeningMinimumDuration dependency property. This field is read-only.
DisplayValueProperty | Identifies the read-only DisplayValue dependency property. This field is read-only.
DragCursorProperty | Identifies the DragCursor dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
IsDraggingAnimatedProperty | Identifies the IsDraggingAnimated dependency property. This field is read-only.
IsDraggingProperty | Identifies the read-only IsDragging dependency property. This field is read-only.
IsSnappingEnabledProperty | Identifies the IsSnappingEnabled dependency property. This field is read-only.
IsValueChangedEventRaisedProperty | Identifies the IsValueChangedEventRaised dependency property. This field is read-only.
IsValueChangingEventRaisedProperty | Identifies the IsValueChangingEventRaised dependency property. This field is read-only.
PointerAscentProperty | Identifies the PointerAscent dependency property. This field is read-only.
PointerExtentProperty | Identifies the PointerExtent dependency property. This field is read-only.
RefreshRateProperty | Identifies the RefreshRate dependency property. This field is read-only.
ScaleOffsetProperty | Identifies the ScaleOffset dependency property. This field is read-only.
ScalePlacementProperty | Identifies the ScalePlacement dependency property. This field is read-only.
SnappingIntervalProperty | Identifies the SnappingInterval dependency property. This field is read-only.
ThrottledValueProperty | Identifies the ThrottledValue dependency property. This field is read-only.
ValueChangedEvent | Identifies the ValueChanged routed event. This field is read-only.
ValueChangingEvent | Identifies the ValueChanging routed event. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase Constructor

Initializes a new instance of the PointerBase class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected PointerBase()
Protected Sub New
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase Properties

The PointerBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property.
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property.
Public property | BorderWidth | Gets or sets the border width. This is a dependency property.
Public property | CanDrag | Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property.
Public property | DampeningMaximumDuration | Gets or sets the maximum Duration of the dampening effect. This is a dependency property.
Public property | DampeningMinimumDuration | Gets or sets the minimum Duration of the dampening effect. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayValue | Gets the value currently displayed. This is a dependency property.
Public property | DragCursor | Gets or sets the Cursor used during drag operations. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property.
Public property | IsDragging | Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property.
Public property | IsDraggingAnimated | Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property.
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale.
Protected property | IsReversed | Gets a value indicating whether this instance is reversed.
Public property | IsSnappingEnabled | Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property.
Public property | IsValueChangedEventRaised | Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property.
Public property | IsValueChangingEventRaised | Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property.
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale.
Protected property | Maximum | Gets the maximum value.
Protected property | Minimum | Gets the minimum value.
Public property | PointerAscent | Gets or sets the ascent of the pointer. This is a dependency property.
Public property | PointerExtent | Gets or sets the extent of the pointer. This is a dependency property.
Public property | RefreshRate | Gets or sets the Duration between value updates. This is a dependency property.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property.
Public property | ScalePlacement | Gets or sets the placement of the pointer relative to the scale. This is a dependency property.
Public property | SnappingInterval | Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property.
Public property | ThrottledValue | Gets the throttled Value based on RefreshRate.
Public property | Value | Gets or sets the value. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.Background Property

PointerBaseBackground Property

Gets or sets the background brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Background { get; set; }
Public Property Background As Brush
    Get
    Set

Property Value

Type: Brush
The background brush. The default value is DarkGray.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.BorderBrush Property

PointerBaseBorderBrush Property

Gets or sets the border brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrush { get; set; }
Public Property BorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The border brush. The default value is Black.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.BorderDashStyle Property

PointerBaseBorderDashStyle Property

Gets or sets the border dash style. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DashStyle BorderDashStyle { get; set; }
Public Property BorderDashStyle As DashStyle
    Get
    Set

Property Value

Type: DashStyle
The border dash style. The default value is DashStyle.Solid.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.BorderWidth Property

PointerBaseBorderWidth Property

Gets or sets the border width. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double BorderWidth { get; set; }
Public Property BorderWidth As Double
    Get
    Set

Property Value

Type: Double
The border width. The default value is 0.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.CanDrag Property

PointerBaseCanDrag Property

Gets or sets a value indicating whether the pointer can be dragged by the mouse. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDrag { get; set; }
Public Property CanDrag As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the pointer can be dragged by the mouse, false. The default value is false.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.DampeningMaximumDuration Property

PointerBaseDampeningMaximumDuration Property

Gets or sets the maximum Duration of the dampening effect. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration DampeningMaximumDuration { get; set; }
Public Property DampeningMaximumDuration As Duration
    Get
    Set

Property Value

Type: Duration
The maximum Duration of the dampening effect. The default value is 750 milliseconds.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.DampeningMinimumDuration Property

PointerBaseDampeningMinimumDuration Property

Gets or sets the minimum Duration of the dampening effect. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration DampeningMinimumDuration { get; set; }
Public Property DampeningMinimumDuration As Duration
    Get
    Set

Property Value

Type: Duration
The minimum Duration of the dampening effect. The default value is 250 milliseconds.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.DisplayValue Property

PointerBaseDisplayValue Property

Gets the value currently displayed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double DisplayValue { get; protected set; }
Public Property DisplayValue As Double
    Get
    Protected Set

Property Value

Type: Double
The display value. The default value is 0.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.DragCursor Property

PointerBaseDragCursor Property

Gets or sets the Cursor used during drag operations. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Cursor DragCursor { get; set; }
Public Property DragCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The Cursor used during drag operations. The default value is Cursors.Hand.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.HasDropShadow Property

PointerBaseHasDropShadow Property

Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDropShadow { get; set; }
Public Property HasDropShadow As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance has a drop shadow; otherwise, false. The default value is true.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsDragging Property

PointerBaseIsDragging Property

Gets a value indicating whether the pointer is currently being dragged by the mouse. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get

Property Value

Type: Boolean
true if the pointer is currently being dragged by the mouse; otherwise, false. The default value is false.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsDraggingAnimated Property

PointerBaseIsDraggingAnimated Property

Gets or sets a value indicating whether the pointer is animated when it is being dragged. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDraggingAnimated { get; set; }
Public Property IsDraggingAnimated As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the pointer is animated when it is being dragged; otherwise, false. The default value is false.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsLogarithmic Property

PointerBaseIsLogarithmic Property

Gets a value indicating whether this instance uses a logarithmic scale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool IsLogarithmic { get; }
Protected ReadOnly Property IsLogarithmic As Boolean
    Get

Property Value

Type: Boolean
true if this instance uses a logarithmic scale; otherwise, false.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsReversed Property

PointerBaseIsReversed Property

Gets a value indicating whether this instance is reversed.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool IsReversed { get; }
Protected ReadOnly Property IsReversed As Boolean
    Get

Property Value

Type: Boolean
true if this instance is reversed; otherwise, false.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsSnappingEnabled Property

PointerBaseIsSnappingEnabled Property

Gets or sets a value indicating whether the Value should be snapped to a specified interval. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSnappingEnabled { get; set; }
Public Property IsSnappingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value should be snapped to a specified interval; otherwise, false. The default value is false.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsValueChangedEventRaised Property

PointerBaseIsValueChangedEventRaised Property

Gets or sets a value indicating whether the ValueChanged should be raised. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsValueChangedEventRaised { get; set; }
Public Property IsValueChangedEventRaised As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the ValueChanged should be raised; otherwise, false. The default value is true.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsValueChangingEventRaised Property

PointerBaseIsValueChangingEventRaised Property

Gets or sets a value indicating whether the ValueChanging should be raised. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsValueChangingEventRaised { get; set; }
Public Property IsValueChangingEventRaised As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the ValueChanging should be raised; otherwise, false. The default value is false.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.LogarithmicBase Property

PointerBaseLogarithmicBase Property

Gets the logarithm base when using a logarithmic scale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double LogarithmicBase { get; }
Protected ReadOnly Property LogarithmicBase As Double
    Get

Property Value

Type: Double
The logarithm base.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.Maximum Property

PointerBaseMaximum Property

Gets the maximum value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double Maximum { get; }
Protected ReadOnly Property Maximum As Double
    Get

Property Value

Type: Double
The maximum value.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.Minimum Property

PointerBaseMinimum Property

Gets the minimum value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double Minimum { get; }
Protected ReadOnly Property Minimum As Double
    Get

Property Value

Type: Double
The minimum value.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.PointerAscent Property

PointerBasePointerAscent Property

Gets or sets the ascent of the pointer. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit PointerAscent { get; set; }
Public Property PointerAscent As Unit
    Get
    Set

Property Value

Type: Unit
The ascent of the pointer. The default value is 0 pixels.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.PointerExtent Property

PointerBasePointerExtent Property

Gets or sets the extent of the pointer. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit PointerExtent { get; set; }
Public Property PointerExtent As Unit
    Get
    Set

Property Value

Type: Unit
The extent of the pointer. The default value is 0 pixels.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.RefreshRate Property

PointerBaseRefreshRate Property

Gets or sets the Duration between value updates. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Duration RefreshRate { get; set; }
Public Property RefreshRate As Duration
    Get
    Set

Property Value

Type: Duration
The Duration between value updates. The default value is 0.0 milliseconds.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ScaleOffset Property

PointerBaseScaleOffset Property

Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit ScaleOffset { get; set; }
Public Property ScaleOffset As Unit
    Get
    Set

Property Value

Type: Unit
The scale offset. The default value is 0px.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ScalePlacement Property

PointerBaseScalePlacement Property

Gets or sets the placement of the pointer relative to the scale. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ScalePlacement ScalePlacement { get; set; }
Public Property ScalePlacement As ScalePlacement
    Get
    Set

Property Value

Type: ScalePlacement
The scale placement. The default value is ScalePlacement.Overlay.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.SnappingInterval Property

PointerBaseSnappingInterval Property

Gets or sets an interval to which the value is snapped when IsSnappingEnabled is true. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SnappingInterval { get; set; }
Public Property SnappingInterval As Double
    Get
    Set

Property Value

Type: Double
The interval to which the value is snapped. The default value is 1.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ThrottledValue Property

PointerBaseThrottledValue Property

Gets the throttled Value based on RefreshRate.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ThrottledValue { get; }
Public ReadOnly Property ThrottledValue As Double
    Get

Property Value

Type: Double
The throttled value.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.Value Property

PointerBaseValue Property

Gets or sets the value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value. The default value is 0.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase Methods

The PointerBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | CalculateValue | Calculates the value based on a specified point.
Public method | CancelDrag | Cancels a drag operation for the PointerBase.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnKeyDown | Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnValueChanged | Invoked when the Value property is changed.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateValue | Updates the value of this pointer based on the specified point.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.CalculateValue Method

PointerBaseCalculateValue Method

Calculates the value based on a specified point.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract double CalculateValue(
    Point point
)
Protected MustOverride Function CalculateValue (
    point As Point
) As Double

Parameters

point
Type: System.WindowsPoint
The point.

Return Value

Type: Double
The value of specified point.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.CancelDrag Method

PointerBaseCancelDrag Method

Cancels a drag operation for the PointerBase.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CancelDrag()
Public Sub CancelDrag
Remarks
If a PointerBase is currently dragging, this method removes mouse capture and restores the previous value.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.OnCreateAutomationPeer Method

PointerBaseOnCreateAutomationPeer Method

Creates an appropriate PointerBaseAutomationPeer for this control as part of the WPF infrastructure.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Gauge.Primitives.PointerBase.OnCreateAutomationPeer"]

See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.OnKeyDown Method

PointerBaseOnKeyDown Method

Invoked when an unhandled Keyboard.KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.OnMouseLeftButtonDown Method

PointerBaseOnMouseLeftButtonDown Method

Invoked when an unhandled UIElement.MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. The event data reports that the left mouse button was pressed.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.OnMouseLeftButtonUp Method

PointerBaseOnMouseLeftButtonUp Method

Invoked when an unhandled UIElement.MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. The event data reports that the left mouse button was released.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.OnMouseMove Method

PointerBaseOnMouseMove Method

Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs that contains the event data.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.OnValueChanged Method

PointerBaseOnValueChanged Method

Invoked when the Value property is changed.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnValueChanged(
    double oldValue,
    double newValue
)
Protected Overridable Sub OnValueChanged (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The old property value.
newValue
Type: SystemDouble
The new property value.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.UpdateValue Method

PointerBaseUpdateValue Method

Updates the value of this pointer based on the specified point.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateValue(
    Point point
)
Protected Overridable Sub UpdateValue (
    point As Point
)

Parameters

point
Type: System.WindowsPoint
The point.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase Events

The PointerBase type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the Value is changed.
Public event | ValueChanging | Occurs before the Value is changed.
Top
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ValueChanged Event

PointerBaseValueChanged Event

Occurs when the Value is changed.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DoublePropertyChangedRoutedEventArgs> ValueChanged
Public Event ValueChanged As EventHandler(Of DoublePropertyChangedRoutedEventArgs)

Value

Type: SystemEventHandler DoublePropertyChangedRoutedEventArgs
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ValueChanging Event

PointerBaseValueChanging Event

Occurs before the Value is changed.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<DoublePropertyChangingRoutedEventArgs> ValueChanging
Public Event ValueChanging As EventHandler(Of DoublePropertyChangingRoutedEventArgs)

Value

Type: SystemEventHandler DoublePropertyChangingRoutedEventArgs
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase Fields

The PointerBase type exposes the following members.

Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderDashStyleProperty | Identifies the BorderDashStyle dependency property. This field is read-only.
BorderWidthProperty | Identifies the BorderWidth dependency property. This field is read-only.
CanDragProperty | Identifies the CanDrag dependency property. This field is read-only.
DampeningMaximumDurationProperty | Identifies the DampeningMaximumDuration dependency property. This field is read-only.
DampeningMinimumDurationProperty | Identifies the DampeningMinimumDuration dependency property. This field is read-only.
DisplayValueProperty | Identifies the read-only DisplayValue dependency property. This field is read-only.
DragCursorProperty | Identifies the DragCursor dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
IsDraggingAnimatedProperty | Identifies the IsDraggingAnimated dependency property. This field is read-only.
IsDraggingProperty | Identifies the read-only IsDragging dependency property. This field is read-only.
IsSnappingEnabledProperty | Identifies the IsSnappingEnabled dependency property. This field is read-only.
IsValueChangedEventRaisedProperty | Identifies the IsValueChangedEventRaised dependency property. This field is read-only.
IsValueChangingEventRaisedProperty | Identifies the IsValueChangingEventRaised dependency property. This field is read-only.
PointerAscentProperty | Identifies the PointerAscent dependency property. This field is read-only.
PointerExtentProperty | Identifies the PointerExtent dependency property. This field is read-only.
RefreshRateProperty | Identifies the RefreshRate dependency property. This field is read-only.
ScaleOffsetProperty | Identifies the ScaleOffset dependency property. This field is read-only.
ScalePlacementProperty | Identifies the ScalePlacement dependency property. This field is read-only.
SnappingIntervalProperty | Identifies the SnappingInterval dependency property. This field is read-only.
ThrottledValueProperty | Identifies the ThrottledValue dependency property. This field is read-only.
ValueChangedEvent | Identifies the ValueChanged routed event. This field is read-only.
ValueChangingEvent | Identifies the ValueChanging routed event. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.BackgroundProperty Field

PointerBaseBackgroundProperty Field

Identifies the Background dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundProperty
Public Shared ReadOnly BackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Background dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.BorderBrushProperty Field

PointerBaseBorderBrushProperty Field

Identifies the BorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushProperty
Public Shared ReadOnly BorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrush dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.BorderDashStyleProperty Field

PointerBaseBorderDashStyleProperty Field

Identifies the BorderDashStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderDashStyleProperty
Public Shared ReadOnly BorderDashStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderDashStyle dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.BorderWidthProperty Field

PointerBaseBorderWidthProperty Field

Identifies the BorderWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderWidthProperty
Public Shared ReadOnly BorderWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderWidth dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.CanDragProperty Field

PointerBaseCanDragProperty Field

Identifies the CanDrag dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragProperty
Public Shared ReadOnly CanDragProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDrag dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.DampeningMaximumDurationProperty Field

PointerBaseDampeningMaximumDurationProperty Field

Identifies the DampeningMaximumDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DampeningMaximumDurationProperty
Public Shared ReadOnly DampeningMaximumDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DampeningMaximumDuration dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.DampeningMinimumDurationProperty Field

PointerBaseDampeningMinimumDurationProperty Field

Identifies the DampeningMinimumDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DampeningMinimumDurationProperty
Public Shared ReadOnly DampeningMinimumDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DampeningMinimumDuration dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.DisplayValueProperty Field

PointerBaseDisplayValueProperty Field

Identifies the read-only DisplayValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayValueProperty
Public Shared ReadOnly DisplayValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayValue dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.DragCursorProperty Field

PointerBaseDragCursorProperty Field

Identifies the DragCursor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DragCursorProperty
Public Shared ReadOnly DragCursorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DragCursor dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.HasDropShadowProperty Field

PointerBaseHasDropShadowProperty Field

Identifies the HasDropShadow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasDropShadowProperty
Public Shared ReadOnly HasDropShadowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasDropShadow dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsDraggingAnimatedProperty Field

PointerBaseIsDraggingAnimatedProperty Field

Identifies the IsDraggingAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDraggingAnimatedProperty
Public Shared ReadOnly IsDraggingAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDraggingAnimated dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsDraggingProperty Field

PointerBaseIsDraggingProperty Field

Identifies the read-only IsDragging dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDraggingProperty
Public Shared ReadOnly IsDraggingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDragging dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsSnappingEnabledProperty Field

PointerBaseIsSnappingEnabledProperty Field

Identifies the IsSnappingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSnappingEnabledProperty
Public Shared ReadOnly IsSnappingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSnappingEnabled dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsValueChangedEventRaisedProperty Field

PointerBaseIsValueChangedEventRaisedProperty Field

Identifies the IsValueChangedEventRaised dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsValueChangedEventRaisedProperty
Public Shared ReadOnly IsValueChangedEventRaisedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsValueChangedEventRaised dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.IsValueChangingEventRaisedProperty Field

PointerBaseIsValueChangingEventRaisedProperty Field

Identifies the IsValueChangingEventRaised dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsValueChangingEventRaisedProperty
Public Shared ReadOnly IsValueChangingEventRaisedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsValueChangingEventRaised dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.PointerAscentProperty Field

PointerBasePointerAscentProperty Field

Identifies the PointerAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PointerAscentProperty
Public Shared ReadOnly PointerAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PointerAscent dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.PointerExtentProperty Field

PointerBasePointerExtentProperty Field

Identifies the PointerExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PointerExtentProperty
Public Shared ReadOnly PointerExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PointerExtent dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.RefreshRateProperty Field

PointerBaseRefreshRateProperty Field

Identifies the RefreshRate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RefreshRateProperty
Public Shared ReadOnly RefreshRateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RefreshRate dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ScaleOffsetProperty Field

PointerBaseScaleOffsetProperty Field

Identifies the ScaleOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScaleOffsetProperty
Public Shared ReadOnly ScaleOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScaleOffset dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ScalePlacementProperty Field

PointerBaseScalePlacementProperty Field

Identifies the ScalePlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScalePlacementProperty
Public Shared ReadOnly ScalePlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScalePlacement dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.SnappingIntervalProperty Field

PointerBaseSnappingIntervalProperty Field

Identifies the SnappingInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SnappingIntervalProperty
Public Shared ReadOnly SnappingIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SnappingInterval dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ThrottledValueProperty Field

PointerBaseThrottledValueProperty Field

Identifies the ThrottledValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThrottledValueProperty
Public Shared ReadOnly ThrottledValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThrottledValue dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ValueChangedEvent Field

PointerBaseValueChangedEvent Field

Identifies the ValueChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ValueChangedEvent
Public Shared ReadOnly ValueChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ValueChanged routed event.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ValueChangingEvent Field

PointerBaseValueChangingEvent Field

Identifies the ValueChanging routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ValueChangingEvent
Public Shared ReadOnly ValueChangingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ValueChanging routed event.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


PointerBase.ValueProperty Field

PointerBaseValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

PointerBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase Class

Represents the base class for ranges.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesRangeBase
ActiproSoftware.Windows.Controls.GaugeCircularRange
ActiproSoftware.Windows.Controls.GaugeLinearRange

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class RangeBase : GaugeElement
Public MustInherit Class RangeBase
    Inherits GaugeElement

The RangeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | RangeBase | Initializes a new instance of the RangeBase class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property.
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property.
Public property | BorderWidth | Gets or sets the border width. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the end value of the range. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property.
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale.
Protected property | IsReversed | Gets a value indicating whether this instance is reversed.
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale.
Protected property | Maximum | Gets the maximum value.
Protected property | Minimum | Gets the minimum value.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property.
Public property | ScalePlacement | Gets or sets the placement of the range relative to the scale. This is a dependency property.
Public property | StartValue | Gets or sets the start value of the range. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderDashStyleProperty | Identifies the BorderDashStyle dependency property. This field is read-only.
BorderWidthProperty | Identifies the BorderWidth dependency property. This field is read-only.
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
ScaleOffsetProperty | Identifies the ScaleOffset dependency property. This field is read-only.
ScalePlacementProperty | Identifies the ScalePlacement dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase Constructor

Initializes a new instance of the RangeBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected RangeBase()
Protected Sub New
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase Properties

The RangeBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property.
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property.
Public property | BorderWidth | Gets or sets the border width. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndValue | Gets or sets the end value of the range. This is a dependency property.
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property.
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale.
Protected property | IsReversed | Gets a value indicating whether this instance is reversed.
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale.
Protected property | Maximum | Gets the maximum value.
Protected property | Minimum | Gets the minimum value.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property.
Public property | ScalePlacement | Gets or sets the placement of the range relative to the scale. This is a dependency property.
Public property | StartValue | Gets or sets the start value of the range. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.Background Property

RangeBaseBackground Property

Gets or sets the background brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Background { get; set; }
Public Property Background As Brush
    Get
    Set

Property Value

Type: Brush
The background brush. The default value is DarkGoldenrod.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.BorderBrush Property

RangeBaseBorderBrush Property

Gets or sets the border brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrush { get; set; }
Public Property BorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The border brush. The default value is Black.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.BorderDashStyle Property

RangeBaseBorderDashStyle Property

Gets or sets the border dash style. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DashStyle BorderDashStyle { get; set; }
Public Property BorderDashStyle As DashStyle
    Get
    Set

Property Value

Type: DashStyle
The border dash style. The default value is DashStyle.Solid.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.BorderWidth Property

RangeBaseBorderWidth Property

Gets or sets the border width. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double BorderWidth { get; set; }
Public Property BorderWidth As Double
    Get
    Set

Property Value

Type: Double
The border width. The default value is 0.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.EndValue Property

RangeBaseEndValue Property

Gets or sets the end value of the range. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double EndValue { get; set; }
Public Property EndValue As Double
    Get
    Set

Property Value

Type: Double
The end value of the range. The default value is 0.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.HasDropShadow Property

RangeBaseHasDropShadow Property

Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDropShadow { get; set; }
Public Property HasDropShadow As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance has a drop shadow; otherwise, false. The default value is true.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.IsLogarithmic Property

RangeBaseIsLogarithmic Property

Gets a value indicating whether this instance uses a logarithmic scale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool IsLogarithmic { get; }
Protected ReadOnly Property IsLogarithmic As Boolean
    Get

Property Value

Type: Boolean
true if this instance uses a logarithmic scale; otherwise, false.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.IsReversed Property

RangeBaseIsReversed Property

Gets a value indicating whether this instance is reversed.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool IsReversed { get; }
Protected ReadOnly Property IsReversed As Boolean
    Get

Property Value

Type: Boolean
true if this instance is reversed; otherwise, false.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.LogarithmicBase Property

RangeBaseLogarithmicBase Property

Gets the logarithm base when using a logarithmic scale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double LogarithmicBase { get; }
Protected ReadOnly Property LogarithmicBase As Double
    Get

Property Value

Type: Double
The logarithm base.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.Maximum Property

RangeBaseMaximum Property

Gets the maximum value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double Maximum { get; }
Protected ReadOnly Property Maximum As Double
    Get

Property Value

Type: Double
The maximum value.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.Minimum Property

RangeBaseMinimum Property

Gets the minimum value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double Minimum { get; }
Protected ReadOnly Property Minimum As Double
    Get

Property Value

Type: Double
The minimum value.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.ScaleOffset Property

RangeBaseScaleOffset Property

Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit ScaleOffset { get; set; }
Public Property ScaleOffset As Unit
    Get
    Set

Property Value

Type: Unit
The scale offset. The default value is 0px.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.ScalePlacement Property

RangeBaseScalePlacement Property

Gets or sets the placement of the range relative to the scale. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ScalePlacement ScalePlacement { get; set; }
Public Property ScalePlacement As ScalePlacement
    Get
    Set

Property Value

Type: ScalePlacement
The scale placement. The default value is ScalePlacement.Overlay.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.StartValue Property

RangeBaseStartValue Property

Gets or sets the start value of the range. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double StartValue { get; set; }
Public Property StartValue As Double
    Get
    Set

Property Value

Type: Double
The start value of the range. The default value is 0.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase Methods

The RangeBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase Fields

The RangeBase type exposes the following members.

Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderDashStyleProperty | Identifies the BorderDashStyle dependency property. This field is read-only.
BorderWidthProperty | Identifies the BorderWidth dependency property. This field is read-only.
EndValueProperty | Identifies the EndValue dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
ScaleOffsetProperty | Identifies the ScaleOffset dependency property. This field is read-only.
ScalePlacementProperty | Identifies the ScalePlacement dependency property. This field is read-only.
StartValueProperty | Identifies the StartValue dependency property. This field is read-only.
Top
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.BackgroundProperty Field

RangeBaseBackgroundProperty Field

Identifies the Background dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundProperty
Public Shared ReadOnly BackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Background dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.BorderBrushProperty Field

RangeBaseBorderBrushProperty Field

Identifies the BorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushProperty
Public Shared ReadOnly BorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrush dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.BorderDashStyleProperty Field

RangeBaseBorderDashStyleProperty Field

Identifies the BorderDashStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderDashStyleProperty
Public Shared ReadOnly BorderDashStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderDashStyle dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.BorderWidthProperty Field

RangeBaseBorderWidthProperty Field

Identifies the BorderWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderWidthProperty
Public Shared ReadOnly BorderWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderWidth dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.EndValueProperty Field

RangeBaseEndValueProperty Field

Identifies the EndValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndValueProperty
Public Shared ReadOnly EndValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndValue dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.HasDropShadowProperty Field

RangeBaseHasDropShadowProperty Field

Identifies the HasDropShadow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasDropShadowProperty
Public Shared ReadOnly HasDropShadowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasDropShadow dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.ScaleOffsetProperty Field

RangeBaseScaleOffsetProperty Field

Identifies the ScaleOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScaleOffsetProperty
Public Shared ReadOnly ScaleOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScaleOffset dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.ScalePlacementProperty Field

RangeBaseScalePlacementProperty Field

Identifies the ScalePlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScalePlacementProperty
Public Shared ReadOnly ScalePlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScalePlacement dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RangeBase.StartValueProperty Field

RangeBaseStartValueProperty Field

Identifies the StartValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartValueProperty
Public Shared ReadOnly StartValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartValue dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase Class

Represents a base class for rectangular gauge controls.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesRectangularGaugeBase
ActiproSoftware.Windows.Controls.GaugeDigitalGauge
ActiproSoftware.Windows.Controls.GaugeLinearGauge

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class RectangularGaugeBase : GaugeBase
Public MustInherit Class RectangularGaugeBase
    Inherits GaugeBase

The RectangularGaugeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | RectangularGaugeBase | Initializes a new instance of the RectangularGaugeBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property.
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property.
Public property | BackgroundSizeRatio | Gets or sets the size of the frame background as a ratio of the ActualWidth and ActualHeight properties. This is a dependency property.
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FrameAngle | Gets the angle of the frame, which is used when rendering the background frame.
Public property | FrameType | Gets or sets the type of rectangular frame rendered in the background. This is a dependency property.
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property.
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides GaugeBaseLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property.
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property.
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides GaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides GaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType property.
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType property.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from GaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BackgroundGeometryProperty | Identifies the BackgroundGeometry dependency property. This field is read-only.
BackgroundImageSourceProperty | Identifies the BackgroundImageSource dependency property. This field is read-only.
BackgroundSizeRatioProperty | Identifies the BackgroundSizeRatio dependency property. This field is read-only.
BackgroundTypeProperty | Identifies the BackgroundType dependency property. This field is read-only.
FrameTypeProperty | Identifies the FrameType dependency property. This field is read-only.
GlassTypeProperty | Identifies the GlassType dependency property. This field is read-only.
RimGeometryProperty | Identifies the RimGeometry dependency property. This field is read-only.
RimImageSourceProperty | Identifies the RimImageSource dependency property. This field is read-only.
RimTypeProperty | Identifies the RimType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase Constructor

Initializes a new instance of the RectangularGaugeBase class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected RectangularGaugeBase()
Protected Sub New
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase Properties

The RectangularGaugeBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | BackgroundGeometry | Gets or sets the custom geometry used for the frame background. This is a dependency property.
Public property | BackgroundImageSource | Gets or sets the source of a custom image used for the frame background. This is a dependency property.
Public property | BackgroundSizeRatio | Gets or sets the size of the frame background as a ratio of the ActualWidth and ActualHeight properties. This is a dependency property.
Public property | BackgroundType | Gets or sets the type of frame background to be rendered. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FrameAngle | Gets the angle of the frame, which is used when rendering the background frame.
Public property | FrameType | Gets or sets the type of rectangular frame rendered in the background. This is a dependency property.
Public property | GlassType | Gets or sets the type of glass effect rendered, if any. This is a dependency property.
Public property | IsBackgroundEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the background of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | IsRimEffectEnabled | Gets and sets a value indicating whether a special effect should be rendered for the rim portion of the gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Items | Gets the UIElement objects within the gauge. (Inherited from GaugeBase.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides GaugeBaseLogicalChildren.)
Public property | Origin | Gets or sets the origin of the X and Y coordinates, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimBrush | Gets or sets the rim brush. This is a dependency property. (Inherited from GaugeBase.)
Public property | RimGeometry | Gets or sets the custom geometry used for the frame rim. This is a dependency property.
Public property | RimImageSource | Gets or sets the source of a custom image used for the frame rim. This is a dependency property.
Public property | RimType | Gets or sets the type of frame rim to be rendered. This is a dependency property.
Public property | UnitBaseX | Gets or sets the base value used to convert Unit types to a double along the x-axis. This is a dependency property. (Inherited from GaugeBase.)
Public property | UnitBaseY | Gets or sets the base value used to convert Unit types to a double along the y-axis. This is a dependency property. (Inherited from GaugeBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | X | Gets or sets the X-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | Y | Gets or sets the Y-coordinate of this gauge, which is only used when the gauge is embedded inside another gauge. This is a dependency property. (Inherited from GaugeBase.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.BackgroundGeometry Property

RectangularGaugeBaseBackgroundGeometry Property

Gets or sets the custom geometry used for the frame background. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry BackgroundGeometry { get; set; }
Public Property BackgroundGeometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry for the frame background. The default value is .
Remarks
This property is only used when BackgroundType is set to RectangularBackgroundType.CustomBackgroundGeometry.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.BackgroundImageSource Property

RectangularGaugeBaseBackgroundImageSource Property

Gets or sets the source of a custom image used for the frame background. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource BackgroundImageSource { get; set; }
Public Property BackgroundImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source for the frame background. The default value is .
Remarks
This property is only used when BackgroundType is set to RectangularBackgroundType.CustomBackgroundImage.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.BackgroundSizeRatio Property

RectangularGaugeBaseBackgroundSizeRatio Property

Gets or sets the size of the frame background as a ratio of the ActualWidth and ActualHeight properties. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double BackgroundSizeRatio { get; set; }
Public Property BackgroundSizeRatio As Double
    Get
    Set

Property Value

Type: Double
the size of the frame background as a ratio of the ActualWidth and ActualHeight properties. The default value is 0.88.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.BackgroundType Property

RectangularGaugeBaseBackgroundType Property

Gets or sets the type of frame background to be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RectangularBackgroundType BackgroundType { get; set; }
Public Property BackgroundType As RectangularBackgroundType
    Get
    Set

Property Value

Type: RectangularBackgroundType
The type of frame background to be rendered. The default value is RectangularBackgroundType.RoundedRectangleLightGradient.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.FrameAngle Property

RectangularGaugeBaseFrameAngle Property

Gets the angle of the frame, which is used when rendering the background frame.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual double FrameAngle { get; }
Protected Overridable ReadOnly Property FrameAngle As Double
    Get

Property Value

Type: Double
The frame angle.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.FrameType Property

RectangularGaugeBaseFrameType Property

Gets or sets the type of rectangular frame rendered in the background. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RectangularFrameType FrameType { get; set; }
Public Property FrameType As RectangularFrameType
    Get
    Set

Property Value

Type: RectangularFrameType
The frame type. The default value is RoundedRectangleDarkerGradient.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.GlassType Property

RectangularGaugeBaseGlassType Property

Gets or sets the type of glass effect rendered, if any. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RectangularGlassType GlassType { get; set; }
Public Property GlassType As RectangularGlassType
    Get
    Set

Property Value

Type: RectangularGlassType
The type of glass rendered, if any. The default value is RectangularGlassType.None.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.LogicalChildren Property

RectangularGaugeBaseLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.RimGeometry Property

RectangularGaugeBaseRimGeometry Property

Gets or sets the custom geometry used for the frame rim. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Geometry RimGeometry { get; set; }
Public Property RimGeometry As Geometry
    Get
    Set

Property Value

Type: Geometry
A custom geometry for the frame rim. The default value is .
Remarks
This property is only used when RimType is set to RectangularRimType.CustomRimGeometry.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.RimImageSource Property

RectangularGaugeBaseRimImageSource Property

Gets or sets the source of a custom image used for the frame rim. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ImageSource RimImageSource { get; set; }
Public Property RimImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The image source for the frame rim. The default value is .
Remarks
This property is only used when RimType is set to RectangularRimType.CustomRimImage.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.RimType Property

RectangularGaugeBaseRimType Property

Gets or sets the type of frame rim to be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public RectangularRimType RimType { get; set; }
Public Property RimType As RectangularRimType
    Get
    Set

Property Value

Type: RectangularRimType
The type of frame rim to be rendered. The default value is RectangularRimType.RoundedRectangleDarkerGradient.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase Methods

The RectangularGaugeBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides GaugeBaseArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLocation | Gets the location of the given element assuming the specified size. (Inherited from GaugeBase.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides GaugeBaseMeasureOverride(Size).)
Protected method | OnCreateAutomationPeer | Creates an appropriate GaugeBaseAutomationPeer for this control as part of the WPF infrastructure. (Inherited from GaugeBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from GaugeBase.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderFrameBackground | Renders the background of the frame based on the actual width and height, and the FrameType property.
Protected method | RenderFrameRim | Renders the rim of the frame based on the actual width and height, and the FrameType property.
Public method | ToBitmap | Creates a BitmapSource based on the contents of the gauge. (Inherited from GaugeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateUnitBases | Updates UnitBaseX and UnitBaseY. (Inherited from GaugeBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.ArrangeOverride Method

RectangularGaugeBaseArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.MeasureOverride Method

RectangularGaugeBaseMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.OnRender Method

RectangularGaugeBaseOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.RenderFrameBackground Method

RectangularGaugeBaseRenderFrameBackground Method

Renders the background of the frame based on the actual width and height, and the FrameType property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void RenderFrameBackground(
    DrawingContext drawingContext
)
Protected Overridable Sub RenderFrameBackground (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing context.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.RenderFrameRim Method

RectangularGaugeBaseRenderFrameRim Method

Renders the rim of the frame based on the actual width and height, and the FrameType property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void RenderFrameRim(
    DrawingContext drawingContext
)
Protected Overridable Sub RenderFrameRim (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing context.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase Fields

The RectangularGaugeBase type exposes the following members.

Fields
Name | Description
BackgroundGeometryProperty | Identifies the BackgroundGeometry dependency property. This field is read-only.
BackgroundImageSourceProperty | Identifies the BackgroundImageSource dependency property. This field is read-only.
BackgroundSizeRatioProperty | Identifies the BackgroundSizeRatio dependency property. This field is read-only.
BackgroundTypeProperty | Identifies the BackgroundType dependency property. This field is read-only.
FrameTypeProperty | Identifies the FrameType dependency property. This field is read-only.
GlassTypeProperty | Identifies the GlassType dependency property. This field is read-only.
RimGeometryProperty | Identifies the RimGeometry dependency property. This field is read-only.
RimImageSourceProperty | Identifies the RimImageSource dependency property. This field is read-only.
RimTypeProperty | Identifies the RimType dependency property. This field is read-only.
Top
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.BackgroundGeometryProperty Field

RectangularGaugeBaseBackgroundGeometryProperty Field

Identifies the BackgroundGeometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundGeometryProperty
Public Shared ReadOnly BackgroundGeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundGeometry dependency property.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.BackgroundImageSourceProperty Field

RectangularGaugeBaseBackgroundImageSourceProperty Field

Identifies the BackgroundImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundImageSourceProperty
Public Shared ReadOnly BackgroundImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundImageSource dependency property.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.BackgroundSizeRatioProperty Field

RectangularGaugeBaseBackgroundSizeRatioProperty Field

Identifies the BackgroundSizeRatio dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundSizeRatioProperty
Public Shared ReadOnly BackgroundSizeRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundSizeRatio dependency property.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.BackgroundTypeProperty Field

RectangularGaugeBaseBackgroundTypeProperty Field

Identifies the BackgroundType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundTypeProperty
Public Shared ReadOnly BackgroundTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundType dependency property.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.FrameTypeProperty Field

RectangularGaugeBaseFrameTypeProperty Field

Identifies the FrameType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FrameTypeProperty
Public Shared ReadOnly FrameTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FrameType dependency property.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.GlassTypeProperty Field

RectangularGaugeBaseGlassTypeProperty Field

Identifies the GlassType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GlassTypeProperty
Public Shared ReadOnly GlassTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GlassType dependency property.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.RimGeometryProperty Field

RectangularGaugeBaseRimGeometryProperty Field

Identifies the RimGeometry dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RimGeometryProperty
Public Shared ReadOnly RimGeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RimGeometry dependency property.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.RimImageSourceProperty Field

RectangularGaugeBaseRimImageSourceProperty Field

Identifies the RimImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RimImageSourceProperty
Public Shared ReadOnly RimImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RimImageSource dependency property.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


RectangularGaugeBase.RimTypeProperty Field

RectangularGaugeBaseRimTypeProperty Field

Identifies the RimType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RimTypeProperty
Public Shared ReadOnly RimTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RimType dependency property.
See Also

Reference

RectangularGaugeBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase Class

Represents the base class for scales.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesScaleBase
ActiproSoftware.Windows.Controls.GaugeCircularScale
ActiproSoftware.Windows.Controls.GaugeLinearScale

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class ScaleBase : GaugeElement
Public MustInherit Class ScaleBase
    Inherits GaugeElement

The ScaleBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ScaleBase | Initializes a new instance of the ScaleBase class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BarExtent | Gets or sets the extent of the bar. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property.
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property.
Public property | BorderWidth | Gets or sets the border width. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsBarVisible | Gets or sets a value indicating whether the scale renders an associated bar. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetBarExtent | Gets the value of the BarExtentProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ScaleBaseAutomationPeer for this control as part of the WPF infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetBarExtent | Sets the value of the BarExtentProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
BarExtentProperty | Identifies the BarExtent dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderDashStyleProperty | Identifies the BorderDashStyle dependency property. This field is read-only.
BorderWidthProperty | Identifies the BorderWidth dependency property. This field is read-only.
IsBarVisibleProperty | Identifies the IsBarVisible dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase Constructor

Initializes a new instance of the ScaleBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected ScaleBase()
Protected Sub New
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase Properties

The ScaleBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush. This is a dependency property.
Public property | BarExtent | Gets or sets the extent of the bar. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property.
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property.
Public property | BorderWidth | Gets or sets the border width. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsBarVisible | Gets or sets a value indicating whether the scale renders an associated bar. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.Background Property

ScaleBaseBackground Property

Gets or sets the background brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush Background { get; set; }
Public Property Background As Brush
    Get
    Set

Property Value

Type: Brush
The background brush. The default value is DarkGray.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.BarExtent Property

ScaleBaseBarExtent Property

Gets or sets the extent of the bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit BarExtent { get; set; }
Public Property BarExtent As Unit
    Get
    Set

Property Value

Type: Unit
The extent of the bar. The default value is 90%.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.BorderBrush Property

ScaleBaseBorderBrush Property

Gets or sets the border brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrush { get; set; }
Public Property BorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The border brush. The default value is Black.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.BorderDashStyle Property

ScaleBaseBorderDashStyle Property

Gets or sets the border dash style. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DashStyle BorderDashStyle { get; set; }
Public Property BorderDashStyle As DashStyle
    Get
    Set

Property Value

Type: DashStyle
The border dash style. The default value is DashStyle.Solid.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.BorderWidth Property

ScaleBaseBorderWidth Property

Gets or sets the border width. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double BorderWidth { get; set; }
Public Property BorderWidth As Double
    Get
    Set

Property Value

Type: Double
The border width. The default value is 0.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.IsBarVisible Property

ScaleBaseIsBarVisible Property

Gets or sets a value indicating whether the scale renders an associated bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsBarVisible { get; set; }
Public Property IsBarVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the scale bar visible; otherwise, false. The default value is true.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase Methods

The ScaleBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetBarExtent | Gets the value of the BarExtentProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ScaleBaseAutomationPeer for this control as part of the WPF infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetBarExtent | Sets the value of the BarExtentProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.GetBarExtent Method

ScaleBaseGetBarExtent Method

Gets the value of the BarExtentProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Unit GetBarExtent(
    DependencyObject obj
)
Public Shared Function GetBarExtent (
    obj As DependencyObject
) As Unit

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Unit
The bar width.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.OnCreateAutomationPeer Method

ScaleBaseOnCreateAutomationPeer Method

Creates an appropriate ScaleBaseAutomationPeer for this control as part of the WPF infrastructure.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Gauge.Primitives.ScaleBase.OnCreateAutomationPeer"]

See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.SetBarExtent Method

ScaleBaseSetBarExtent Method

Sets the value of the BarExtentProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetBarExtent(
    DependencyObject obj,
    Unit value
)
Public Shared Sub SetBarExtent (
    obj As DependencyObject,
    value As Unit
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.WindowsUnit
The bar extent.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase Fields

The ScaleBase type exposes the following members.

Fields
Name | Description
BackgroundProperty | Identifies the Background dependency property. This field is read-only.
BarExtentProperty | Identifies the BarExtent dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderDashStyleProperty | Identifies the BorderDashStyle dependency property. This field is read-only.
BorderWidthProperty | Identifies the BorderWidth dependency property. This field is read-only.
IsBarVisibleProperty | Identifies the IsBarVisible dependency property. This field is read-only.
Top
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.BackgroundProperty Field

ScaleBaseBackgroundProperty Field

Identifies the Background dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundProperty
Public Shared ReadOnly BackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Background dependency property.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.BarExtentProperty Field

ScaleBaseBarExtentProperty Field

Identifies the BarExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarExtentProperty
Public Shared ReadOnly BarExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarExtent dependency property.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.BorderBrushProperty Field

ScaleBaseBorderBrushProperty Field

Identifies the BorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushProperty
Public Shared ReadOnly BorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrush dependency property.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.BorderDashStyleProperty Field

ScaleBaseBorderDashStyleProperty Field

Identifies the BorderDashStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderDashStyleProperty
Public Shared ReadOnly BorderDashStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderDashStyle dependency property.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.BorderWidthProperty Field

ScaleBaseBorderWidthProperty Field

Identifies the BorderWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderWidthProperty
Public Shared ReadOnly BorderWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderWidth dependency property.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ScaleBase.IsBarVisibleProperty Field

ScaleBaseIsBarVisibleProperty Field

Identifies the IsBarVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsBarVisibleProperty
Public Shared ReadOnly IsBarVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsBarVisible dependency property.
See Also

Reference

ScaleBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase Class

Represents the base class for tick marks and tick labels.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesCircularTickBase
ActiproSoftware.Windows.Controls.Gauge.PrimitivesLinearTickBase

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TickBase : GaugeElement
Public MustInherit Class TickBase
    Inherits GaugeElement

The TickBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TickBase | Initializes a new instance of the TickBase class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property.
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property.
Public property | BorderWidth | Gets or sets the border width. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property.
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property.
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale.
Protected property | IsReversed | Gets a value indicating whether this instance is reversed.
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale.
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property.
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property.
Protected property | Maximum | Gets the maximum value.
Protected property | Minimum | Gets the minimum value.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property.
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property.
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
AngleProperty | Identifies the Angle dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderDashStyleProperty | Identifies the BorderDashStyle dependency property. This field is read-only.
BorderWidthProperty | Identifies the BorderWidth dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
IntervalOriginProperty | Identifies the IntervalOrigin dependency property. This field is read-only.
MajorIntervalProperty | Identifies the MajorInterval dependency property. This field is read-only.
MajorIntervalTypeProperty | Identifies the MajorIntervalType dependency property. This field is read-only.
MinorIntervalProperty | Identifies the MinorInterval dependency property. This field is read-only.
MinorIntervalTypeProperty | Identifies the MinorIntervalType dependency property. This field is read-only.
ScaleOffsetProperty | Identifies the ScaleOffset dependency property. This field is read-only.
ScalePlacementProperty | Identifies the ScalePlacement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase Constructor

Initializes a new instance of the TickBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TickBase()
Protected Sub New
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase Properties

The TickBase type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle used to render the tick. This is a dependency property.
Public property | BorderBrush | Gets or sets the border brush. This is a dependency property.
Public property | BorderDashStyle | Gets or sets the border dash style. This is a dependency property.
Public property | BorderWidth | Gets or sets the border width. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasDropShadow | Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property.
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property.
Protected property | IsLogarithmic | Gets a value indicating whether this instance uses a logarithmic scale.
Protected property | IsReversed | Gets a value indicating whether this instance is reversed.
Protected property | LogarithmicBase | Gets the logarithm base when using a logarithmic scale.
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property.
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property.
Protected property | Maximum | Gets the maximum value.
Protected property | Minimum | Gets the minimum value.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property.
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property.
Public property | ScaleOffset | Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property.
Public property | ScalePlacement | Gets or sets the placement of the tick relative to the scale. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.Angle Property

TickBaseAngle Property

Gets or sets the angle used to render the tick. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
The angle. The default value is 0.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.BorderBrush Property

TickBaseBorderBrush Property

Gets or sets the border brush. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush BorderBrush { get; set; }
Public Property BorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The border brush. The default value is Black.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.BorderDashStyle Property

TickBaseBorderDashStyle Property

Gets or sets the border dash style. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DashStyle BorderDashStyle { get; set; }
Public Property BorderDashStyle As DashStyle
    Get
    Set

Property Value

Type: DashStyle
The border dash style. The default value is DashStyle.Solid.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.BorderWidth Property

TickBaseBorderWidth Property

Gets or sets the border width. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double BorderWidth { get; set; }
Public Property BorderWidth As Double
    Get
    Set

Property Value

Type: Double
The border width. The default value is 0.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.HasDropShadow Property

TickBaseHasDropShadow Property

Gets or sets a value indicating whether this instance has a drop shadow. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool HasDropShadow { get; set; }
Public Property HasDropShadow As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance has a drop shadow; otherwise, false. The default value is false.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.IntervalOrigin Property

TickBaseIntervalOrigin Property

Gets or sets the interval origin. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IntervalOrigin IntervalOrigin { get; set; }
Public Property IntervalOrigin As IntervalOrigin
    Get
    Set

Property Value

Type: IntervalOrigin
The interval origin. The default value is IntervalOrigin.Minimum.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.IsLogarithmic Property

TickBaseIsLogarithmic Property

Gets a value indicating whether this instance uses a logarithmic scale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool IsLogarithmic { get; }
Protected ReadOnly Property IsLogarithmic As Boolean
    Get

Property Value

Type: Boolean
true if this instance uses a logarithmic scale; otherwise, false.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.IsReversed Property

TickBaseIsReversed Property

Gets a value indicating whether this instance is reversed.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected bool IsReversed { get; }
Protected ReadOnly Property IsReversed As Boolean
    Get

Property Value

Type: Boolean
true if this instance is reversed; otherwise, false.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.LogarithmicBase Property

TickBaseLogarithmicBase Property

Gets the logarithm base when using a logarithmic scale.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double LogarithmicBase { get; }
Protected ReadOnly Property LogarithmicBase As Double
    Get

Property Value

Type: Double
The logarithm base.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.MajorInterval Property

TickBaseMajorInterval Property

Gets or sets the major interval. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MajorInterval { get; set; }
Public Property MajorInterval As Double
    Get
    Set

Property Value

Type: Double
The major interval. The default value is 10.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.MajorIntervalType Property

TickBaseMajorIntervalType Property

Gets or sets the major interval type. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IntervalType MajorIntervalType { get; set; }
Public Property MajorIntervalType As IntervalType
    Get
    Set

Property Value

Type: IntervalType
The major interval type. The default value is IntervalType.Auto.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.Maximum Property

TickBaseMaximum Property

Gets the maximum value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double Maximum { get; }
Protected ReadOnly Property Maximum As Double
    Get

Property Value

Type: Double
The maximum value.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.Minimum Property

TickBaseMinimum Property

Gets the minimum value.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected double Minimum { get; }
Protected ReadOnly Property Minimum As Double
    Get

Property Value

Type: Double
The minimum value.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.MinorInterval Property

TickBaseMinorInterval Property

Gets or sets the minor interval. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MinorInterval { get; set; }
Public Property MinorInterval As Double
    Get
    Set

Property Value

Type: Double
The minor interval. The default value is 2.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.MinorIntervalType Property

TickBaseMinorIntervalType Property

Gets or sets the minor interval type. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IntervalType MinorIntervalType { get; set; }
Public Property MinorIntervalType As IntervalType
    Get
    Set

Property Value

Type: IntervalType
The minor interval type. The default value is IntervalType.Auto.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.ScaleOffset Property

TickBaseScaleOffset Property

Gets or sets the offset from the scale based on the ScalePlacement. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit ScaleOffset { get; set; }
Public Property ScaleOffset As Unit
    Get
    Set

Property Value

Type: Unit
The scale offset. The default value is 0px.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.ScalePlacement Property

TickBaseScalePlacement Property

Gets or sets the placement of the tick relative to the scale. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ScalePlacement ScalePlacement { get; set; }
Public Property ScalePlacement As ScalePlacement
    Get
    Set

Property Value

Type: ScalePlacement
The scale placement. The default value is ScalePlacement.Overlay.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase Methods

The TickBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase Fields

The TickBase type exposes the following members.

Fields
Name | Description
AngleProperty | Identifies the Angle dependency property. This field is read-only.
BorderBrushProperty | Identifies the BorderBrush dependency property. This field is read-only.
BorderDashStyleProperty | Identifies the BorderDashStyle dependency property. This field is read-only.
BorderWidthProperty | Identifies the BorderWidth dependency property. This field is read-only.
HasDropShadowProperty | Identifies the HasDropShadow dependency property. This field is read-only.
IntervalOriginProperty | Identifies the IntervalOrigin dependency property. This field is read-only.
MajorIntervalProperty | Identifies the MajorInterval dependency property. This field is read-only.
MajorIntervalTypeProperty | Identifies the MajorIntervalType dependency property. This field is read-only.
MinorIntervalProperty | Identifies the MinorInterval dependency property. This field is read-only.
MinorIntervalTypeProperty | Identifies the MinorIntervalType dependency property. This field is read-only.
ScaleOffsetProperty | Identifies the ScaleOffset dependency property. This field is read-only.
ScalePlacementProperty | Identifies the ScalePlacement dependency property. This field is read-only.
Top
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.AngleProperty Field

TickBaseAngleProperty Field

Identifies the Angle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AngleProperty
Public Shared ReadOnly AngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Angle dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.BorderBrushProperty Field

TickBaseBorderBrushProperty Field

Identifies the BorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushProperty
Public Shared ReadOnly BorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrush dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.BorderDashStyleProperty Field

TickBaseBorderDashStyleProperty Field

Identifies the BorderDashStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderDashStyleProperty
Public Shared ReadOnly BorderDashStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderDashStyle dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.BorderWidthProperty Field

TickBaseBorderWidthProperty Field

Identifies the BorderWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderWidthProperty
Public Shared ReadOnly BorderWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderWidth dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.HasDropShadowProperty Field

TickBaseHasDropShadowProperty Field

Identifies the HasDropShadow dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasDropShadowProperty
Public Shared ReadOnly HasDropShadowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasDropShadow dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.IntervalOriginProperty Field

TickBaseIntervalOriginProperty Field

Identifies the IntervalOrigin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IntervalOriginProperty
Public Shared ReadOnly IntervalOriginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IntervalOrigin dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.MajorIntervalProperty Field

TickBaseMajorIntervalProperty Field

Identifies the MajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MajorIntervalProperty
Public Shared ReadOnly MajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MajorInterval dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.MajorIntervalTypeProperty Field

TickBaseMajorIntervalTypeProperty Field

Identifies the MajorIntervalType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MajorIntervalTypeProperty
Public Shared ReadOnly MajorIntervalTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MajorIntervalType dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.MinorIntervalProperty Field

TickBaseMinorIntervalProperty Field

Identifies the MinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinorIntervalProperty
Public Shared ReadOnly MinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinorInterval dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.MinorIntervalTypeProperty Field

TickBaseMinorIntervalTypeProperty Field

Identifies the MinorIntervalType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinorIntervalTypeProperty
Public Shared ReadOnly MinorIntervalTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinorIntervalType dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.ScaleOffsetProperty Field

TickBaseScaleOffsetProperty Field

Identifies the ScaleOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScaleOffsetProperty
Public Shared ReadOnly ScaleOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScaleOffset dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickBase.ScalePlacementProperty Field

TickBaseScalePlacementProperty Field

Identifies the ScalePlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScalePlacementProperty
Public Shared ReadOnly ScalePlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScalePlacement dependency property.
See Also

Reference

TickBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase Class

Represents the base class for tick-sets.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesGaugeElement
ActiproSoftware.Windows.Controls.Gauge.PrimitivesTickSetBase
ActiproSoftware.Windows.Controls.GaugeCircularTickSet
ActiproSoftware.Windows.Controls.GaugeLinearTickSet

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TickSetBase : GaugeElement
Public MustInherit Class TickSetBase
    Inherits GaugeElement

The TickSetBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TickSetBase | Initializes a new instance of the TickSetBase class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property.
Public property | IsLogarithmic | Gets or sets a value indicating whether this instance uses a logarithmic scale. This is a dependency property.
Public property | IsReversed | Gets or sets a value indicating whether this instance is reversed. This is a dependency property.
Public property | LogarithmicBase | Gets or sets the base of the logarithm used when IsLogarithmic is set to true. This is a dependency property.
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property.
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property.
Public property | Maximum | Gets or sets the maximum value. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property.
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetIntervalOrigin | Gets the value of the IntervalOriginProperty attached property for a specified object.
 | GetIsLogarithmic | Gets the value of the IsLogarithmicProperty attached property for a specified object.
 | GetIsReversed | Gets the value of the IsReversedProperty attached property for a specified object.
 | GetLogarithmicBase | Gets the value of the LogarithmicBaseProperty attached property for a specified object.
 | GetMajorInterval | Gets the value of the MajorIntervalProperty attached property for a specified object.
 | GetMajorIntervalType | Gets the value of the MajorIntervalTypeProperty attached property for a specified object.
 | GetMaximum | Gets the value of the MaximumProperty attached property for a specified object.
 | GetMinimum | Gets the value of the MinimumProperty attached property for a specified object.
 | GetMinorInterval | Gets the value of the MinorIntervalProperty attached property for a specified object.
 | GetMinorIntervalType | Gets the value of the MinorIntervalTypeProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetIntervalOrigin | Sets the value of the IntervalOriginProperty attached property to a specified object.
 | SetIsLogarithmic | Sets the value of the IsLogarithmicProperty attached property to a specified object.
 | SetIsReversed | Sets the value of the IsReversedProperty attached property to a specified object.
 | SetLogarithmicBase | Sets the value of the LogarithmicBaseProperty attached property to a specified object.
 | SetMajorInterval | Sets the value of the MajorIntervalProperty attached property to a specified object.
 | SetMajorIntervalType | Sets the value of the MajorIntervalTypeProperty attached property to a specified object.
 | SetMaximum | Sets the value of the MaximumProperty attached property to a specified object.
 | SetMinimum | Sets the value of the MinimumProperty attached property to a specified object.
 | SetMinorInterval | Sets the value of the MinorIntervalProperty attached property to a specified object.
 | SetMinorIntervalType | Sets the value of the MinorIntervalTypeProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
IntervalOriginProperty | Identifies the IntervalOrigin dependency property. This field is read-only.
IsLogarithmicProperty | Identifies the IsLogarithmic dependency property. This field is read-only.
IsReversedProperty | Identifies the IsReversed dependency property. This field is read-only.
LogarithmicBaseProperty | Identifies the LogarithmicBase dependency property. This field is read-only.
MajorIntervalProperty | Identifies the MajorInterval dependency property. This field is read-only.
MajorIntervalTypeProperty | Identifies the MajorIntervalType dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinorIntervalProperty | Identifies the MinorInterval dependency property. This field is read-only.
MinorIntervalTypeProperty | Identifies the MinorIntervalType dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Gauge documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase Constructor

Initializes a new instance of the TickSetBase class

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TickSetBase()
Protected Sub New
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase Properties

The TickSetBase type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IntervalOrigin | Gets or sets the interval origin. This is a dependency property.
Public property | IsLogarithmic | Gets or sets a value indicating whether this instance uses a logarithmic scale. This is a dependency property.
Public property | IsReversed | Gets or sets a value indicating whether this instance is reversed. This is a dependency property.
Public property | LogarithmicBase | Gets or sets the base of the logarithm used when IsLogarithmic is set to true. This is a dependency property.
Public property | MajorInterval | Gets or sets the major interval. This is a dependency property.
Public property | MajorIntervalType | Gets or sets the major interval type. This is a dependency property.
Public property | Maximum | Gets or sets the maximum value. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value. This is a dependency property.
Public property | MinorInterval | Gets or sets the minor interval. This is a dependency property.
Public property | MinorIntervalType | Gets or sets the minor interval type. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildren | Gets the visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from GaugeElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZIndex | Gets or sets the z-index of the this element. This is a dependency property. (Inherited from GaugeElement.)
Top
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.IntervalOrigin Property

TickSetBaseIntervalOrigin Property

Gets or sets the interval origin. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IntervalOrigin IntervalOrigin { get; set; }
Public Property IntervalOrigin As IntervalOrigin
    Get
    Set

Property Value

Type: IntervalOrigin
The interval origin. The default value is IntervalOrigin.Minimum.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.IsLogarithmic Property

TickSetBaseIsLogarithmic Property

Gets or sets a value indicating whether this instance uses a logarithmic scale. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsLogarithmic { get; set; }
Public Property IsLogarithmic As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance uses a logarithmic scale; otherwise, false. The default value is false.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.IsReversed Property

TickSetBaseIsReversed Property

Gets or sets a value indicating whether this instance is reversed. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReversed { get; set; }
Public Property IsReversed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is reversed; otherwise, false. The default value is false.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.LogarithmicBase Property

TickSetBaseLogarithmicBase Property

Gets or sets the base of the logarithm used when IsLogarithmic is set to true. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LogarithmicBase { get; set; }
Public Property LogarithmicBase As Double
    Get
    Set

Property Value

Type: Double
The logarithm base. The default value is 10.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MajorInterval Property

TickSetBaseMajorInterval Property

Gets or sets the major interval. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MajorInterval { get; set; }
Public Property MajorInterval As Double
    Get
    Set

Property Value

Type: Double
The major interval. The default value is 10.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MajorIntervalType Property

TickSetBaseMajorIntervalType Property

Gets or sets the major interval type. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IntervalType MajorIntervalType { get; set; }
Public Property MajorIntervalType As IntervalType
    Get
    Set

Property Value

Type: IntervalType
The major interval type. The default value is IntervalType.Auto.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.Maximum Property

TickSetBaseMaximum Property

Gets or sets the maximum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value. The default value is 100.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.Minimum Property

TickSetBaseMinimum Property

Gets or sets the minimum value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value. The default value is 0.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MinorInterval Property

TickSetBaseMinorInterval Property

Gets or sets the minor interval. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MinorInterval { get; set; }
Public Property MinorInterval As Double
    Get
    Set

Property Value

Type: Double
The minor interval. The default value is 2.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MinorIntervalType Property

TickSetBaseMinorIntervalType Property

Gets or sets the minor interval type. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IntervalType MinorIntervalType { get; set; }
Public Property MinorIntervalType As IntervalType
    Get
    Set

Property Value

Type: IntervalType
The minor interval type. The default value is IntervalType.Auto.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase Methods

The TickSetBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GetIntervalOrigin | Gets the value of the IntervalOriginProperty attached property for a specified object.
 | GetIsLogarithmic | Gets the value of the IsLogarithmicProperty attached property for a specified object.
 | GetIsReversed | Gets the value of the IsReversedProperty attached property for a specified object.
 | GetLogarithmicBase | Gets the value of the LogarithmicBaseProperty attached property for a specified object.
 | GetMajorInterval | Gets the value of the MajorIntervalProperty attached property for a specified object.
 | GetMajorIntervalType | Gets the value of the MajorIntervalTypeProperty attached property for a specified object.
 | GetMaximum | Gets the value of the MaximumProperty attached property for a specified object.
 | GetMinimum | Gets the value of the MinimumProperty attached property for a specified object.
 | GetMinorInterval | Gets the value of the MinorIntervalProperty attached property for a specified object.
 | GetMinorIntervalType | Gets the value of the MinorIntervalTypeProperty attached property for a specified object.
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from GaugeElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetIntervalOrigin | Sets the value of the IntervalOriginProperty attached property to a specified object.
 | SetIsLogarithmic | Sets the value of the IsLogarithmicProperty attached property to a specified object.
 | SetIsReversed | Sets the value of the IsReversedProperty attached property to a specified object.
 | SetLogarithmicBase | Sets the value of the LogarithmicBaseProperty attached property to a specified object.
 | SetMajorInterval | Sets the value of the MajorIntervalProperty attached property to a specified object.
 | SetMajorIntervalType | Sets the value of the MajorIntervalTypeProperty attached property to a specified object.
 | SetMaximum | Sets the value of the MaximumProperty attached property to a specified object.
 | SetMinimum | Sets the value of the MinimumProperty attached property to a specified object.
 | SetMinorInterval | Sets the value of the MinorIntervalProperty attached property to a specified object.
 | SetMinorIntervalType | Sets the value of the MinorIntervalTypeProperty attached property to a specified object.
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetIntervalOrigin Method

TickSetBaseGetIntervalOrigin Method

Gets the value of the IntervalOriginProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IntervalOrigin GetIntervalOrigin(
    DependencyObject obj
)
Public Shared Function GetIntervalOrigin (
    obj As DependencyObject
) As IntervalOrigin

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: IntervalOrigin
The major interval.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetIsLogarithmic Method

TickSetBaseGetIsLogarithmic Method

Gets the value of the IsLogarithmicProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsLogarithmic(
    DependencyObject obj
)
Public Shared Function GetIsLogarithmic (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Boolean
The maximum value.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetIsReversed Method

TickSetBaseGetIsReversed Method

Gets the value of the IsReversedProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsReversed(
    DependencyObject obj
)
Public Shared Function GetIsReversed (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Boolean
The major interval.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetLogarithmicBase Method

TickSetBaseGetLogarithmicBase Method

Gets the value of the LogarithmicBaseProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetLogarithmicBase(
    DependencyObject obj
)
Public Shared Function GetLogarithmicBase (
    obj As DependencyObject
) As Double

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Double
The maximum value.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetMajorInterval Method

TickSetBaseGetMajorInterval Method

Gets the value of the MajorIntervalProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetMajorInterval(
    DependencyObject obj
)
Public Shared Function GetMajorInterval (
    obj As DependencyObject
) As Double

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Double
The major interval.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetMajorIntervalType Method

TickSetBaseGetMajorIntervalType Method

Gets the value of the MajorIntervalTypeProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IntervalType GetMajorIntervalType(
    DependencyObject obj
)
Public Shared Function GetMajorIntervalType (
    obj As DependencyObject
) As IntervalType

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: IntervalType
The major interval type.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetMaximum Method

TickSetBaseGetMaximum Method

Gets the value of the MaximumProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetMaximum(
    DependencyObject obj
)
Public Shared Function GetMaximum (
    obj As DependencyObject
) As Double

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Double
The maximum value.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetMinimum Method

TickSetBaseGetMinimum Method

Gets the value of the MinimumProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetMinimum(
    DependencyObject obj
)
Public Shared Function GetMinimum (
    obj As DependencyObject
) As Double

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Double
The minimum value.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetMinorInterval Method

TickSetBaseGetMinorInterval Method

Gets the value of the MinorIntervalProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetMinorInterval(
    DependencyObject obj
)
Public Shared Function GetMinorInterval (
    obj As DependencyObject
) As Double

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: Double
The minor interval.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.GetMinorIntervalType Method

TickSetBaseGetMinorIntervalType Method

Gets the value of the MinorIntervalTypeProperty attached property for a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static IntervalType GetMinorIntervalType(
    DependencyObject obj
)
Public Shared Function GetMinorIntervalType (
    obj As DependencyObject
) As IntervalType

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is retrieved.

Return Value

Type: IntervalType
The minor interval type.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetIntervalOrigin Method

TickSetBaseSetIntervalOrigin Method

Sets the value of the IntervalOriginProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIntervalOrigin(
    DependencyObject obj,
    IntervalOrigin value
)
Public Shared Sub SetIntervalOrigin (
    obj As DependencyObject,
    value As IntervalOrigin
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.Windows.Controls.GaugeIntervalOrigin
The interval origin.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetIsLogarithmic Method

TickSetBaseSetIsLogarithmic Method

Sets the value of the IsLogarithmicProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIsLogarithmic(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsLogarithmic (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The interval origin.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetIsReversed Method

TickSetBaseSetIsReversed Method

Sets the value of the IsReversedProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetIsReversed(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsReversed (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The interval origin.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetLogarithmicBase Method

TickSetBaseSetLogarithmicBase Method

Sets the value of the LogarithmicBaseProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetLogarithmicBase(
    DependencyObject obj,
    double value
)
Public Shared Sub SetLogarithmicBase (
    obj As DependencyObject,
    value As Double
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemDouble
The major interval.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetMajorInterval Method

TickSetBaseSetMajorInterval Method

Sets the value of the MajorIntervalProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetMajorInterval(
    DependencyObject obj,
    double value
)
Public Shared Sub SetMajorInterval (
    obj As DependencyObject,
    value As Double
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemDouble
The major interval.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetMajorIntervalType Method

TickSetBaseSetMajorIntervalType Method

Sets the value of the MajorIntervalTypeProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetMajorIntervalType(
    DependencyObject obj,
    IntervalType value
)
Public Shared Sub SetMajorIntervalType (
    obj As DependencyObject,
    value As IntervalType
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.Windows.Controls.GaugeIntervalType
The major interval type.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetMaximum Method

TickSetBaseSetMaximum Method

Sets the value of the MaximumProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetMaximum(
    DependencyObject obj,
    double value
)
Public Shared Sub SetMaximum (
    obj As DependencyObject,
    value As Double
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemDouble
The maximum value.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetMinimum Method

TickSetBaseSetMinimum Method

Sets the value of the MinimumProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetMinimum(
    DependencyObject obj,
    double value
)
Public Shared Sub SetMinimum (
    obj As DependencyObject,
    value As Double
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemDouble
The minimum value.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetMinorInterval Method

TickSetBaseSetMinorInterval Method

Sets the value of the MinorIntervalProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetMinorInterval(
    DependencyObject obj,
    double value
)
Public Shared Sub SetMinorInterval (
    obj As DependencyObject,
    value As Double
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: SystemDouble
The minor interval.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.SetMinorIntervalType Method

TickSetBaseSetMinorIntervalType Method

Sets the value of the MinorIntervalTypeProperty attached property to a specified object.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetMinorIntervalType(
    DependencyObject obj,
    IntervalType value
)
Public Shared Sub SetMinorIntervalType (
    obj As DependencyObject,
    value As IntervalType
)

Parameters

obj
Type: System.WindowsDependencyObject
The object to which the attached property is written.
value
Type: ActiproSoftware.Windows.Controls.GaugeIntervalType
The minor interval type.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase Fields

The TickSetBase type exposes the following members.

Fields
Name | Description
IntervalOriginProperty | Identifies the IntervalOrigin dependency property. This field is read-only.
IsLogarithmicProperty | Identifies the IsLogarithmic dependency property. This field is read-only.
IsReversedProperty | Identifies the IsReversed dependency property. This field is read-only.
LogarithmicBaseProperty | Identifies the LogarithmicBase dependency property. This field is read-only.
MajorIntervalProperty | Identifies the MajorInterval dependency property. This field is read-only.
MajorIntervalTypeProperty | Identifies the MajorIntervalType dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinorIntervalProperty | Identifies the MinorInterval dependency property. This field is read-only.
MinorIntervalTypeProperty | Identifies the MinorIntervalType dependency property. This field is read-only.
Top
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.IntervalOriginProperty Field

TickSetBaseIntervalOriginProperty Field

Identifies the IntervalOrigin dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IntervalOriginProperty
Public Shared ReadOnly IntervalOriginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IntervalOrigin dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.IsLogarithmicProperty Field

TickSetBaseIsLogarithmicProperty Field

Identifies the IsLogarithmic dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLogarithmicProperty
Public Shared ReadOnly IsLogarithmicProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLogarithmic dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.IsReversedProperty Field

TickSetBaseIsReversedProperty Field

Identifies the IsReversed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReversedProperty
Public Shared ReadOnly IsReversedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReversed dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.LogarithmicBaseProperty Field

TickSetBaseLogarithmicBaseProperty Field

Identifies the LogarithmicBase dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LogarithmicBaseProperty
Public Shared ReadOnly LogarithmicBaseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LogarithmicBase dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MajorIntervalProperty Field

TickSetBaseMajorIntervalProperty Field

Identifies the MajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MajorIntervalProperty
Public Shared ReadOnly MajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MajorInterval dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MajorIntervalTypeProperty Field

TickSetBaseMajorIntervalTypeProperty Field

Identifies the MajorIntervalType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MajorIntervalTypeProperty
Public Shared ReadOnly MajorIntervalTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MajorIntervalType dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MaximumProperty Field

TickSetBaseMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MinimumProperty Field

TickSetBaseMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MinorIntervalProperty Field

TickSetBaseMinorIntervalProperty Field

Identifies the MinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinorIntervalProperty
Public Shared ReadOnly MinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinorInterval dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


TickSetBase.MinorIntervalTypeProperty Field

TickSetBaseMinorIntervalTypeProperty Field

Identifies the MinorIntervalType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Gauge.Primitives
Assembly: ActiproSoftware.Gauge.Wpf (in ActiproSoftware.Gauge.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinorIntervalTypeProperty
Public Shared ReadOnly MinorIntervalTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinorIntervalType dependency property.
See Also

Reference

TickSetBase Class
ActiproSoftware.Windows.Controls.Gauge.Primitives Namespace


ActiproSoftware.Windows.Controls.Grids Namespace

Contains classes that support implementing tree and grid controls.
Classes
 | Class | Description
Public class | PropertyGrid | Represents a property grid control.
Public class | PropertyGridItem | Represents an item for a PropertyGrid control.
Public class | PropertyGridItemActionHandlerDictionary | Represents a dictionary of Type to PropertyGridItemActionHandler objects.
Public class | PropertyGridItemActionRequest | Stores information about a request for a PropertyGridItemActionHandler.
Public class | PropertyGridItemAdapter | Provides an abstract base class for a TreeListBoxItemAdapter that can be used in a PropertyGrid.
Public class | PropertyGridItemStyleSelector | Chooses a Style based on the data object and the data-bound element.
Public class | PropertyGridItemTemplateSelector | Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGridItem.
Public class | PropertyGridNameTemplateSelector | Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGrid name cell.
Public class | PropertyGridValueTemplateSelector | Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGrid value cell.
Public class | PropertyModelChildChangeEventArgs | Provides event arguments for IPropertyModel child change events, such as when a child item is added to or removed from a collection.
Public class | PropertyModelValueChangeEventArgs | Provides event arguments for IPropertyModel value change events.
Public class | TreeListBox | Represents an advanced single-column tree view control.
Public class | TreeListBoxItem | Represents an item for a TreeListBox control.
Public class | TreeListBoxItemAdapter | An adapter that can provide an item's hierarchy and visual state data for usage in a TreeListBox.
Public class | TreeListBoxItemEventArgs | Provides event arguments for TreeListBox item-related events.
Public class | TreeListBoxItemExpansionEventArgs | Provides event arguments for TreeListBox item expand and collapse-related events.
Public class | TreeListBoxItemMenuEventArgs | Provides event arguments for TreeListBox item menu events.
Public class | TreeListView | Represents an advanced multi-column tree view control.
Public class | TreeListViewColumn | Represents a column definition for a TreeListView control.
Public class | TreeListViewColumnEventArgs | Provides event arguments for TreeListViewColumn events.
Public class | TreeListViewColumnHeader | Represents an item for a TreeListBox control.
Public class | TreeListViewColumnMenuEventArgs | Provides event arguments for TreeListViewColumn menu events.
Public class | TreeListViewItem | Represents an item for a TreeListView control.
Public class | TreeListViewItemCell | Represents an item for a TreeListView control.
Interfaces
 | Interface | Description
Public interface | ISelectedTreeItemCollection | Provides the base requirements for a collection of selected tree items.
Public interface | ITreeItemNavigator | Provides the base requirements for an object that can navigate a tree of items.
Public interface | ITreeItemVirtualPlaceholder | Provides the base requirements for an object that is a virtual placeholder for a tree item, used with data virtualization.
Delegates
 | Delegate | Description
Public delegate | PropertyGridItemActionHandler | A delegate that can process the specified PropertyGridItemActionRequest.
Enumerations
 | Enumeration | Description
Public enumeration | ColumnSortDirection | Specifies the direction of a column sort operation.
Public enumeration | TreeExpansionKind | Specifies the kind of expand or collapse.
Public enumeration | TreeItemChildrenQueryMode | Specifies the mode by which a tree item's children are queried.
Public enumeration | TreeItemDropArea | Specifies a drop area when a drag is over a target item.
Public enumeration | TreeItemExpandability | Specifies a tree item's support for expansion toggling.
Public enumeration | TreeListViewColumnAutoWidthMode | Specifies which column cells are used to calculate auto-width.
Public enumeration | TreeListViewColumnHeaderRole | Specifies the role for a TreeListViewColumnHeader within a TreeListView.
Public enumeration | TreeMultiDragKind | Specifies the item multi-drag mode for a tree control.
Public enumeration | TreeMultiSelectionKind | Specifies the item multi-select mode for a tree control.


ColumnSortDirection Enumeration

Specifies the direction of a column sort operation.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ColumnSortDirection
Public Enumeration ColumnSortDirection
Members
Member name | Value | Description
Ascending | 0 | Sorts in ascending order.
Descending | 1 | Sorts in descending order.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


ISelectedTreeItemCollection Interface

Provides the base requirements for a collection of selected tree items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ISelectedTreeItemCollection : IList<Object>,
    ICollection<Object>, IEnumerable<Object>, IEnumerable,
    INotifyCollectionChanged
Public Interface ISelectedTreeItemCollection
    Inherits IList(Of Object), ICollection(Of Object),
    IEnumerable(Of Object), IEnumerable, INotifyCollectionChanged

The ISelectedTreeItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection Object .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection Object .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList Object .)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection Object .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection Object .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection Object .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection Object .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable Object .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList Object .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList Object .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection Object .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList Object .)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeObject | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeObject | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllObject | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


ISelectedTreeItemCollection Properties

The ISelectedTreeItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection Object .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection Object .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList Object .)
Top
See Also

Reference

ISelectedTreeItemCollection Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ISelectedTreeItemCollection Methods

The ISelectedTreeItemCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection Object .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection Object .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection Object .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection Object .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable Object .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList Object .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList Object .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection Object .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList Object .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeObject | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeObject | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllObject | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ISelectedTreeItemCollection Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ISelectedTreeItemCollection Events

The ISelectedTreeItemCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Top
See Also

Reference

ISelectedTreeItemCollection Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator Interface

Provides the base requirements for an object that can navigate a tree of items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITreeItemNavigator
Public Interface ITreeItemNavigator

The ITreeItemNavigator type exposes the following members.

Properties
 | Name | Description
Public property | CurrentItem | Gets the current item.
Public property | Depth | Gets the item depth.
Top
Methods
 | Name | Description
Public method | GoToCommonAncestor | Moves to the common ancestor item of CurrentItem and the specified other item.
Public method | GoToFirstChild | Moves to the first child item.
Public method | GoToFirstVisible | Moves to the first visible item.
Public method | GoToLastVisible | Moves to the last visible item.
Public method | GoToNextSibling | Moves to the next sibling item.
Public method | GoToNextVisible | Moves to the next visible item.
Public method | GoToParent | Moves to the parent item.
Public method | GoToPreviousSibling | Moves to the previous sibling item.
Public method | GoToPreviousVisible | Moves to the previous visible item.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator Properties

The ITreeItemNavigator type exposes the following members.

Properties
 | Name | Description
Public property | CurrentItem | Gets the current item.
Public property | Depth | Gets the item depth.
Top
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.CurrentItem Property

ITreeItemNavigatorCurrentItem Property

Gets the current item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object CurrentItem { get; }
ReadOnly Property CurrentItem As Object
    Get

Property Value

Type: Object
The current item.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.Depth Property

ITreeItemNavigatorDepth Property

Gets the item depth.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Depth { get; }
ReadOnly Property Depth As Integer
    Get

Property Value

Type: Int32
The item depth.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator Methods

The ITreeItemNavigator type exposes the following members.

Methods
 | Name | Description
Public method | GoToCommonAncestor | Moves to the common ancestor item of CurrentItem and the specified other item.
Public method | GoToFirstChild | Moves to the first child item.
Public method | GoToFirstVisible | Moves to the first visible item.
Public method | GoToLastVisible | Moves to the last visible item.
Public method | GoToNextSibling | Moves to the next sibling item.
Public method | GoToNextVisible | Moves to the next visible item.
Public method | GoToParent | Moves to the parent item.
Public method | GoToPreviousSibling | Moves to the previous sibling item.
Public method | GoToPreviousVisible | Moves to the previous visible item.
Top
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.GoToCommonAncestor Method

ITreeItemNavigatorGoToCommonAncestor Method

Moves to the common ancestor item of CurrentItem and the specified other item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToCommonAncestor(
    Object otherItem
)
Function GoToCommonAncestor (
    otherItem As Object
) As Boolean

Parameters

otherItem
Type: SystemObject
The other item.

Return Value

Type: Boolean
true if a common ancestor was found, which could be the same as CurrentItem prior to method invocation; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.GoToFirstChild Method

ITreeItemNavigatorGoToFirstChild Method

Moves to the first child item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToFirstChild()
Function GoToFirstChild As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.GoToFirstVisible Method

ITreeItemNavigatorGoToFirstVisible Method

Moves to the first visible item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToFirstVisible()
Function GoToFirstVisible As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.GoToLastVisible Method

ITreeItemNavigatorGoToLastVisible Method

Moves to the last visible item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToLastVisible()
Function GoToLastVisible As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.GoToNextSibling Method

ITreeItemNavigatorGoToNextSibling Method

Moves to the next sibling item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextSibling()
Function GoToNextSibling As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.GoToNextVisible Method

ITreeItemNavigatorGoToNextVisible Method

Moves to the next visible item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToNextVisible()
Function GoToNextVisible As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.GoToParent Method

ITreeItemNavigatorGoToParent Method

Moves to the parent item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToParent()
Function GoToParent As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.GoToPreviousSibling Method

ITreeItemNavigatorGoToPreviousSibling Method

Moves to the previous sibling item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousSibling()
Function GoToPreviousSibling As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemNavigator.GoToPreviousVisible Method

ITreeItemNavigatorGoToPreviousVisible Method

Moves to the previous visible item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool GoToPreviousVisible()
Function GoToPreviousVisible As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemVirtualPlaceholder Interface

Provides the base requirements for an object that is a virtual placeholder for a tree item, used with data virtualization.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ITreeItemVirtualPlaceholder
Public Interface ITreeItemVirtualPlaceholder

The ITreeItemVirtualPlaceholder type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets the index of the item within its parent collection.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemVirtualPlaceholder Properties

The ITreeItemVirtualPlaceholder type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets the index of the item within its parent collection.
Top
See Also

Reference

ITreeItemVirtualPlaceholder Interface
ActiproSoftware.Windows.Controls.Grids Namespace


ITreeItemVirtualPlaceholder.Index Property

ITreeItemVirtualPlaceholderIndex Property

Gets the index of the item within its parent collection.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the item within its parent collection.
See Also

Reference

ITreeItemVirtualPlaceholder Interface
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid Class

Represents a property grid control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
ActiproSoftware.Windows.Controls.GridsTreeListBox
ActiproSoftware.Windows.Controls.GridsTreeListView
ActiproSoftware.Windows.Controls.GridsPropertyGrid

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGrid : TreeListView,
    IPropertyEditorsProvider
Public Class PropertyGrid
    Inherits TreeListView
    Implements IPropertyEditorsProvider

The PropertyGrid type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGrid | Initializes an instance of the PropertyGrid class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAttachedPropertiesBrowsable | Gets or sets whether attached properties are browsable and are displayed in the property grid.
Public property | AreCategoriesAutoExpanded | Gets or sets whether categories are auto-expanded when they are added into the property grid.
Public property | AreClipboardMenuItemsEnabled | Gets or sets whether the default item context menu should include menu items for clipboard operations such as copying a property value.
Public property | AreColumnHeadersVisible | Gets or sets whether column headers are visible. (Inherited from TreeListView.)
Public property | AreInheritedPropertiesBrowsable | Gets or sets whether inherited properties are browsable and are displayed in the property grid.
Public property | AreNestedCategoriesSupported | Gets or sets whether nested categories are supported, using a special syntax in the category name.
Public property | ArePropertiesAutoExpanded | Gets or sets whether expandable properties are auto-expanded when they are added into the property grid.
Public property | AreReadOnlyPropertiesBrowsable | Gets or sets whether read-only properties are browsable and are displayed in the property grid.
Protected property | AssemblyInfo | Gets the AssemblyInfo to use. (Inherited from TreeListBox.)
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrowsableAttributes | Gets or sets a list of Attribute objects that are used to determine which properties are browsable.
 | CancelPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when an Escape key down event is received by a PropertyGridItem.
Public property | CanColumnsReorder | Gets or sets whether columns can be reordered by the end user. (Inherited from TreeListView.)
Public property | CanColumnsResize | Gets or sets whether columns can be resized by the end user. (Inherited from TreeListView.)
Public property | CanColumnsToggleVisibility | Gets or sets whether columns can have their visibility toggled by the end user. (Inherited from TreeListView.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items. (Inherited from TreeListBox.)
Protected property | CanExpandAll | Gets whether any expand all operations can occur. (Inherited from TreeListBox.)
Public property | CanSummaryAutoSize | Gets or sets whether the user can double-tap the summary splitter to auto-size to the summary area content.
Public property | CategoryEditors | Gets the category editors that can consume and display one or more properties.
Public property | CollectionPropertyDisplayMode | Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.
Public property | ColumnHeaderHeight | Gets the height of the column header. (Inherited from TreeListView.)
Public property | Columns | Gets the collection of columns in the control. (Inherited from TreeListView.)
 | CommitPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when an Enter key down event is received by a PropertyGridItem.
Public property | CopyDisplayNameCommand | Gets the ICommand used to call the CopyDisplayName(IDataModel) method.
Public property | CopyPropertyValueCommand | Gets the ICommand used to call the CopyPropertyValue(IPropertyModel) method.
Public property | DataFactory | Gets or sets the IDataFactory used to return the data models for objects.
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | DataObject | Gets or sets the data object for which the control displays properties.
Public property | DataObjects | Gets or sets the data objects for which the control displays properties.
Public property | DefaultBooleanValueTemplate | Gets or sets a DataTemplate for editing a Boolean value with a two-state CheckBox.
Public property | DefaultBrushValueTemplate | Gets or sets a DataTemplate for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
Public property | DefaultCategoryEditorItemContainerStyle | Gets or sets a default PropertyGridItem container Style used for category editor models.
Public property | DefaultCategoryItemContainerStyle | Gets or sets a default PropertyGridItem container Style used for category models.
Public property | DefaultColorValueTemplate | Gets or sets a DataTemplate for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
Public property | DefaultExtendedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
Public property | DefaultFontFamilyValueTemplate | Gets or sets a DataTemplate for editing a FontFamily value with a ComboBox that contains system font families.
Public property | DefaultFontStretchValueTemplate | Gets or sets a DataTemplate for editing a FontStretch value with a ComboBox that contains font stretch options.
Public property | DefaultFontStyleValueTemplate | Gets or sets a DataTemplate for editing a FontStyle value with a ComboBox that contains font style options.
Public property | DefaultFontWeightValueTemplate | Gets or sets a DataTemplate for editing a FontWeight value with a ComboBox that contains font weight options.
Public property | DefaultLimitedObjectValueTemplate | Gets or sets a DataTemplate for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
Public property | DefaultLimitedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
Public property | DefaultNullableBooleanValueTemplate | Gets or sets a DataTemplate for editing a nullable Boolean with a three-state CheckBox.
 | DefaultPropertyEditors | Gets the collection of property editors that are used by default in all PropertyGrid instances, examined alongside the PropertyEditors collection for each PropertyGrid instance.
Public property | DefaultPropertyItemContainerStyle | Gets or sets a default PropertyGridItem container Style used for property models.
Public property | DefaultStringNameTemplate | Gets or sets a DataTemplate with a read-only TextBlock that can be used for name column cells.
Public property | DefaultStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox.
Public property | DefaultSuggestedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmptyContent | Gets or sets the content to display when there are no items visible in the control. (Inherited from TreeListBox.)
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no items visible in the control. (Inherited from TreeListBox.)
Public property | ExpansionColumnIndex | Gets or sets the index of the columns that contains the indentation and expander button. (Inherited from TreeListView.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility. (Inherited from TreeListView.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level. (Inherited from TreeListBox.)
Public property | IsCategorized | Gets or sets whether properties are categorized.
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled. (Inherited from TreeListBox.)
Public property | IsDefaultColumnHeaderContextMenuEnabled | Gets or sets whether the default column header context menu is enabled. (Inherited from TreeListView.)
Public property | IsDefaultItemContextMenuEnabled | Gets or sets whether the default context menu is enabled for property grid items.
Public property | IsEmpty | Gets whether the control is currently empty (doesn't contain any visible items). (Inherited from TreeListBox.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active. (Inherited from TreeListBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Protected property | IsKeyboardFocusWithinContent | Gets whether keyboard focus is within the content area, and not in any header area. (Inherited from TreeListView.)
Public property | IsReadOnly | Gets or sets whether the value editors are read-only.
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items. (Inherited from TreeListBox.)
Public property | IsSummaryResizable | Gets or sets whether the summary area is resizable.
Public property | IsSummaryToggleAllowed | Gets or sets whether the summary area's visibility is allowed to be toggled.
Public property | IsSummaryVisible | Gets or sets whether the summary area is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc. (Inherited from TreeListBox.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MiscCategoryName | Gets or sets the name used for the miscellaneous category.
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved. (Inherited from TreeListBox.)
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved. (Inherited from TreeListBox.)
Public property | NameColumnIndex | Gets the index of the name column.
Public property | NameColumnMaxWidth | Gets or sets the maximum width of the name column, which comes into play as the property grid or its columns are resized.
Public property | NameContainerStyle | Gets or sets the Style to use for the name column cells.
Public property | NameTemplate | Gets or sets the DataTemplate to use for the name column cells.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for the name column cells.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PastePropertyValueCommand | Gets the ICommand used to call the PastePropertyValue(IPropertyModel) method.
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses. (Inherited from TreeListBox.)
Public property | Properties | Gets the explicitly-defined properties that should be displayed.
Public property | PropertyEditors | Gets the PropertyEditorCollection that contains property editor definitions specifically for this property grid instance.
 | PropertyEditorsModifierKey | Gets the resource key that is loaded by the PropertyGrid, allowing for customization of the property editors directly from XAML.
Public property | PropertyExpandability | Gets or sets a PropertyExpandability that indicates the expandability of properties.
Public property | RootItem | Gets or sets the root item to display in the control. (Inherited from TreeListBox.)
Public property | SelectedItem | Gets or sets the primary selected item. (Inherited from TreeListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from TreeListBox.)
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior. (Inherited from TreeListBox.)
Public property | SizeAllColumnsToFitCommand | Gets the ICommand that sizes all non-star width columns to fit. (Inherited from TreeListView.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting data models.
 | StartPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when a Tab or typing key down event is received by a PropertyGridItem.
Public property | SummaryHeight | Gets or sets the height of the summary area.
Public property | SummaryTemplate | Gets or sets a DataTemplate used to display the selected item in the summary area.
Public property | SummaryTemplateSelector | Gets or sets a DataTemplateSelector used to select a DataTemplate, which is used to display the selected item in the summary area.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToggleSummaryVisibilityCommand | Gets the ICommand used to toggle the IsSummaryVisible property.
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item. (Inherited from TreeListBox.)
Public property | ValueColumnIndex | Gets the index of the value column.
Public property | ValueContainerStyle | Gets or sets the Style to use for the value column cells.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for the value column cells.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for the value column cells.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from TreeListView.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BringItemIntoView | Brings the specified node's container into view. (Inherited from TreeListBox.)
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view. (Inherited from TreeListBox.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Inherited from TreeListView.)
Public method | CollapseAll | Collapses all known tree items. (Inherited from TreeListBox.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | CopyDisplayName | Copies the display name of the specified IDataModel
Public method | CopyPropertyValue | Copies the value of the specified IPropertyModel
Public method | CreateSelectionBatch | Creates an IDisposable object that wraps a batch of selection updates, and allows them to be made without raising selection-related events in between each one. (Inherited from TreeListBox.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | ExpandAll | Expands all known tree items. (Inherited from TreeListBox.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed. (Inherited from TreeListBox.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TreeListViewGetContainerForItemOverride.)
Public method | GetFullPath | Returns the full path of the specified item. (Inherited from TreeListBox.)
Public method | GetItemByFullPath | Returns the item with the specified full path. (Inherited from TreeListBox.)
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item. (Inherited from TreeListBox.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried. (Inherited from TreeListBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TreeListViewIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from TreeListView.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListViewOnApplyTemplate.)
Protected method | OnChildPropertyAdded | Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.
Protected method | OnChildPropertyAdding | Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.
Protected method | OnChildPropertyRemoved | Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.
Protected method | OnChildPropertyRemoving | Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.
Protected method | OnColumnHeaderMenuRequested | Occurs when a column header requests a context menu. (Inherited from TreeListView.)
Protected method | OnColumnHeaderTapped | Occurs when a column's header is tapped. (Inherited from TreeListView.)
Protected method | OnColumnIsVisibleChanged | Occurs when a column's visibility has changed. (Inherited from TreeListView.)
Protected method | OnColumnReordered | Occurs after a column is reordered by the end user. (Inherited from TreeListView.)
Protected method | OnColumnsResized | Occurs after the ActualWidth of one or more columns changes. (Inherited from TreeListView.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TreeListViewOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBox.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBox.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBox.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBox.)
Protected method | OnGotKeyboardFocus | Occurs when the control gains keyboard focus. (Inherited from TreeListBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Inherited from TreeListBox.)
Protected method | OnIsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed. (Inherited from TreeListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Protected method | OnItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu. (Overrides TreeListBoxOnItemMenuRequested(TreeListBoxItemMenuEventArgs).)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource property is changed. (Inherited from TreeListBox.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides TreeListBoxOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyValueChanged | Occurs after the value is set for an IPropertyModel.
Protected method | OnPropertyValueChanging | Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.
Protected method | OnRootItemChanged | Occurs after the RootItem property is changed. (Inherited from TreeListBox.)
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed. (Inherited from TreeListView.)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PastePropertyValue | Pastes a value to the specified IPropertyModel
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from TreeListView.)
Protected method | ProcessKeyDown | Processes a key down event. (Inherited from TreeListBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path. (Inherited from TreeListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | SizeAllColumnsToFit | Sizes all non-star width columns to fit. (Inherited from TreeListView.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TryCommitPropertyValueEdit | Tries to commit a pending property value edit, generally in response to an Enter key press.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ChildPropertyAdded | Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.
Public event | ChildPropertyAdding | Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.
Public event | ChildPropertyRemoved | Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.
Public event | ChildPropertyRemoving | Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.
Public event | ColumnHeaderMenuRequested | Occurs when a column header requests a context menu. (Inherited from TreeListView.)
Public event | ColumnHeaderTapped | Occurs when a column's header is tapped. (Inherited from TreeListView.)
Public event | ColumnIsVisibleChanged | Occurs when a column's visibility has changed. (Inherited from TreeListView.)
Public event | ColumnReordered | Occurs after a column is reordered by the end user. (Inherited from TreeListView.)
Public event | ColumnsResized | Occurs after the ActualWidth of one or more columns changes. (Inherited from TreeListView.)
Public event | IsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed. (Inherited from TreeListBox.)
Public event | ItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Public event | ItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Public event | ItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Public event | ItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Public event | ItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyValueChanged | Occurs after the value is set for an IPropertyModel.
Public event | PropertyValueChanging | Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.
Public event | RootItemChanged | Occurs after the RootItem property is changed. (Inherited from TreeListBox.)
Public event | SelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Top
Fields
Name | Description
AreAttachedPropertiesBrowsableProperty | Identifies the AreAttachedPropertiesBrowsable dependency property. This field is read-only.
AreCategoriesAutoExpandedProperty | Identifies the AreCategoriesAutoExpanded dependency property. This field is read-only.
AreClipboardMenuItemsEnabledProperty | Identifies the AreClipboardMenuItemsEnabled dependency property. This field is read-only.
AreInheritedPropertiesBrowsableProperty | Identifies the AreInheritedPropertiesBrowsable dependency property. This field is read-only.
AreNestedCategoriesSupportedProperty | Identifies the AreNestedCategoriesSupported dependency property. This field is read-only.
ArePropertiesAutoExpandedProperty | Identifies the ArePropertiesAutoExpanded dependency property. This field is read-only.
AreReadOnlyPropertiesBrowsableProperty | Identifies the AreReadOnlyPropertiesBrowsable dependency property. This field is read-only.
BrowsableAttributesProperty | Identifies the BrowsableAttributes dependency property. This field is read-only.
CanSummaryAutoSizeProperty | Identifies the CanSummaryAutoSize dependency property. This field is read-only.
ChildPropertyAddedEvent | Identifies the ChildPropertyAdded routed event. This field is read-only.
ChildPropertyAddingEvent | Identifies the ChildPropertyAdding routed event. This field is read-only.
ChildPropertyRemovedEvent | Identifies the ChildPropertyRemoved routed event. This field is read-only.
ChildPropertyRemovingEvent | Identifies the ChildPropertyRemoving routed event. This field is read-only.
CollectionPropertyDisplayModeProperty | Identifies the CollectionPropertyDisplayMode dependency property. This field is read-only.
DataFactoryProperty | Identifies the DataFactory dependency property. This field is read-only.
DataObjectProperty | Identifies the DataObject dependency property. This field is read-only.
DataObjectsProperty | Identifies the DataObjects dependency property. This field is read-only.
DefaultBooleanValueTemplateProperty | Identifies the DefaultBooleanValueTemplate dependency property. This field is read-only.
DefaultBrushValueTemplateProperty | Identifies the DefaultBrushValueTemplate dependency property. This field is read-only.
DefaultCategoryEditorItemContainerStyleProperty | Identifies the DefaultCategoryEditorItemContainerStyle dependency property. This field is read-only.
DefaultCategoryItemContainerStyleProperty | Identifies the DefaultCategoryItemContainerStyle dependency property. This field is read-only.
DefaultColorValueTemplateProperty | Identifies the DefaultColorValueTemplate dependency property. This field is read-only.
DefaultExtendedStringValueTemplateProperty | Identifies the DefaultExtendedStringValueTemplate dependency property. This field is read-only.
DefaultFontFamilyValueTemplateProperty | Identifies the DefaultFontFamilyValueTemplate dependency property. This field is read-only.
DefaultFontStretchValueTemplateProperty | Identifies the DefaultFontStretchValueTemplate dependency property. This field is read-only.
DefaultFontStyleValueTemplateProperty | Identifies the DefaultFontStyleValueTemplate dependency property. This field is read-only.
DefaultFontWeightValueTemplateProperty | Identifies the DefaultFontWeightValueTemplate dependency property. This field is read-only.
DefaultLimitedObjectValueTemplateProperty | Identifies the DefaultLimitedObjectValueTemplate dependency property. This field is read-only.
DefaultLimitedStringValueTemplateProperty | Identifies the DefaultLimitedStringValueTemplate dependency property. This field is read-only.
DefaultNullableBooleanValueTemplateProperty | Identifies the DefaultNullableBooleanValueTemplate dependency property. This field is read-only.
DefaultPropertyItemContainerStyleProperty | Identifies the DefaultPropertyItemContainerStyle dependency property. This field is read-only.
DefaultStringNameTemplateProperty | Identifies the DefaultStringNameTemplate dependency property. This field is read-only.
DefaultStringValueTemplateProperty | Identifies the DefaultStringValueTemplate dependency property. This field is read-only.
DefaultSuggestedStringValueTemplateProperty | Identifies the DefaultSuggestedStringValueTemplate dependency property. This field is read-only.
IsCategorizedProperty | Identifies the IsCategorized dependency property. This field is read-only.
IsDefaultItemContextMenuEnabledProperty | Identifies the IsDefaultItemContextMenuEnabled dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSummaryResizableProperty | Identifies the IsSummaryResizable dependency property. This field is read-only.
IsSummaryToggleAllowedProperty | Identifies the IsSummaryToggleAllowed dependency property. This field is read-only.
IsSummaryVisibleProperty | Identifies the IsSummaryVisible dependency property. This field is read-only.
MiscCategoryNameProperty | Identifies the MiscCategoryName dependency property. This field is read-only.
NameColumnMaxWidthProperty | Identifies the NameColumnMaxWidth dependency property. This field is read-only.
NameContainerStyleProperty | Identifies the NameContainerStyle dependency property. This field is read-only.
NameTemplateProperty | Identifies the NameTemplate dependency property. This field is read-only.
NameTemplateSelectorProperty | Identifies the NameTemplateSelector dependency property. This field is read-only.
PropertyExpandabilityProperty | Identifies the PropertyExpandability dependency property. This field is read-only.
PropertyValueChangedEvent | Identifies the PropertyValueChanged routed event. This field is read-only.
PropertyValueChangingEvent | Identifies the PropertyValueChanging routed event. This field is read-only.
SortComparerProperty | Identifies the SortComparer dependency property. This field is read-only.
SummaryHeightProperty | Identifies the SummaryHeight dependency property. This field is read-only.
SummaryTemplateProperty | Identifies the SummaryTemplate dependency property. This field is read-only.
SummaryTemplateSelectorProperty | Identifies the SummaryTemplateSelector dependency property. This field is read-only.
ValueContainerStyleProperty | Identifies the ValueContainerStyle dependency property. This field is read-only.
ValueTemplateProperty | Identifies the ValueTemplate dependency property. This field is read-only.
ValueTemplateSelectorProperty | Identifies the ValueTemplateSelector dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid Constructor

Initializes an instance of the PropertyGrid class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGrid()
Public Sub New
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid Properties

The PropertyGrid type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAttachedPropertiesBrowsable | Gets or sets whether attached properties are browsable and are displayed in the property grid.
Public property | AreCategoriesAutoExpanded | Gets or sets whether categories are auto-expanded when they are added into the property grid.
Public property | AreClipboardMenuItemsEnabled | Gets or sets whether the default item context menu should include menu items for clipboard operations such as copying a property value.
Public property | AreColumnHeadersVisible | Gets or sets whether column headers are visible. (Inherited from TreeListView.)
Public property | AreInheritedPropertiesBrowsable | Gets or sets whether inherited properties are browsable and are displayed in the property grid.
Public property | AreNestedCategoriesSupported | Gets or sets whether nested categories are supported, using a special syntax in the category name.
Public property | ArePropertiesAutoExpanded | Gets or sets whether expandable properties are auto-expanded when they are added into the property grid.
Public property | AreReadOnlyPropertiesBrowsable | Gets or sets whether read-only properties are browsable and are displayed in the property grid.
Protected property | AssemblyInfo | Gets the AssemblyInfo to use. (Inherited from TreeListBox.)
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrowsableAttributes | Gets or sets a list of Attribute objects that are used to determine which properties are browsable.
 | CancelPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when an Escape key down event is received by a PropertyGridItem.
Public property | CanColumnsReorder | Gets or sets whether columns can be reordered by the end user. (Inherited from TreeListView.)
Public property | CanColumnsResize | Gets or sets whether columns can be resized by the end user. (Inherited from TreeListView.)
Public property | CanColumnsToggleVisibility | Gets or sets whether columns can have their visibility toggled by the end user. (Inherited from TreeListView.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items. (Inherited from TreeListBox.)
Protected property | CanExpandAll | Gets whether any expand all operations can occur. (Inherited from TreeListBox.)
Public property | CanSummaryAutoSize | Gets or sets whether the user can double-tap the summary splitter to auto-size to the summary area content.
Public property | CategoryEditors | Gets the category editors that can consume and display one or more properties.
Public property | CollectionPropertyDisplayMode | Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.
Public property | ColumnHeaderHeight | Gets the height of the column header. (Inherited from TreeListView.)
Public property | Columns | Gets the collection of columns in the control. (Inherited from TreeListView.)
 | CommitPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when an Enter key down event is received by a PropertyGridItem.
Public property | CopyDisplayNameCommand | Gets the ICommand used to call the CopyDisplayName(IDataModel) method.
Public property | CopyPropertyValueCommand | Gets the ICommand used to call the CopyPropertyValue(IPropertyModel) method.
Public property | DataFactory | Gets or sets the IDataFactory used to return the data models for objects.
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | DataObject | Gets or sets the data object for which the control displays properties.
Public property | DataObjects | Gets or sets the data objects for which the control displays properties.
Public property | DefaultBooleanValueTemplate | Gets or sets a DataTemplate for editing a Boolean value with a two-state CheckBox.
Public property | DefaultBrushValueTemplate | Gets or sets a DataTemplate for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
Public property | DefaultCategoryEditorItemContainerStyle | Gets or sets a default PropertyGridItem container Style used for category editor models.
Public property | DefaultCategoryItemContainerStyle | Gets or sets a default PropertyGridItem container Style used for category models.
Public property | DefaultColorValueTemplate | Gets or sets a DataTemplate for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
Public property | DefaultExtendedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
Public property | DefaultFontFamilyValueTemplate | Gets or sets a DataTemplate for editing a FontFamily value with a ComboBox that contains system font families.
Public property | DefaultFontStretchValueTemplate | Gets or sets a DataTemplate for editing a FontStretch value with a ComboBox that contains font stretch options.
Public property | DefaultFontStyleValueTemplate | Gets or sets a DataTemplate for editing a FontStyle value with a ComboBox that contains font style options.
Public property | DefaultFontWeightValueTemplate | Gets or sets a DataTemplate for editing a FontWeight value with a ComboBox that contains font weight options.
Public property | DefaultLimitedObjectValueTemplate | Gets or sets a DataTemplate for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
Public property | DefaultLimitedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
Public property | DefaultNullableBooleanValueTemplate | Gets or sets a DataTemplate for editing a nullable Boolean with a three-state CheckBox.
 | DefaultPropertyEditors | Gets the collection of property editors that are used by default in all PropertyGrid instances, examined alongside the PropertyEditors collection for each PropertyGrid instance.
Public property | DefaultPropertyItemContainerStyle | Gets or sets a default PropertyGridItem container Style used for property models.
Public property | DefaultStringNameTemplate | Gets or sets a DataTemplate with a read-only TextBlock that can be used for name column cells.
Public property | DefaultStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox.
Public property | DefaultSuggestedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmptyContent | Gets or sets the content to display when there are no items visible in the control. (Inherited from TreeListBox.)
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no items visible in the control. (Inherited from TreeListBox.)
Public property | ExpansionColumnIndex | Gets or sets the index of the columns that contains the indentation and expander button. (Inherited from TreeListView.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility. (Inherited from TreeListView.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level. (Inherited from TreeListBox.)
Public property | IsCategorized | Gets or sets whether properties are categorized.
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled. (Inherited from TreeListBox.)
Public property | IsDefaultColumnHeaderContextMenuEnabled | Gets or sets whether the default column header context menu is enabled. (Inherited from TreeListView.)
Public property | IsDefaultItemContextMenuEnabled | Gets or sets whether the default context menu is enabled for property grid items.
Public property | IsEmpty | Gets whether the control is currently empty (doesn't contain any visible items). (Inherited from TreeListBox.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active. (Inherited from TreeListBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Protected property | IsKeyboardFocusWithinContent | Gets whether keyboard focus is within the content area, and not in any header area. (Inherited from TreeListView.)
Public property | IsReadOnly | Gets or sets whether the value editors are read-only.
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items. (Inherited from TreeListBox.)
Public property | IsSummaryResizable | Gets or sets whether the summary area is resizable.
Public property | IsSummaryToggleAllowed | Gets or sets whether the summary area's visibility is allowed to be toggled.
Public property | IsSummaryVisible | Gets or sets whether the summary area is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc. (Inherited from TreeListBox.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MiscCategoryName | Gets or sets the name used for the miscellaneous category.
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved. (Inherited from TreeListBox.)
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved. (Inherited from TreeListBox.)
Public property | NameColumnIndex | Gets the index of the name column.
Public property | NameColumnMaxWidth | Gets or sets the maximum width of the name column, which comes into play as the property grid or its columns are resized.
Public property | NameContainerStyle | Gets or sets the Style to use for the name column cells.
Public property | NameTemplate | Gets or sets the DataTemplate to use for the name column cells.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for the name column cells.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PastePropertyValueCommand | Gets the ICommand used to call the PastePropertyValue(IPropertyModel) method.
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses. (Inherited from TreeListBox.)
Public property | Properties | Gets the explicitly-defined properties that should be displayed.
Public property | PropertyEditors | Gets the PropertyEditorCollection that contains property editor definitions specifically for this property grid instance.
 | PropertyEditorsModifierKey | Gets the resource key that is loaded by the PropertyGrid, allowing for customization of the property editors directly from XAML.
Public property | PropertyExpandability | Gets or sets a PropertyExpandability that indicates the expandability of properties.
Public property | RootItem | Gets or sets the root item to display in the control. (Inherited from TreeListBox.)
Public property | SelectedItem | Gets or sets the primary selected item. (Inherited from TreeListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from TreeListBox.)
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior. (Inherited from TreeListBox.)
Public property | SizeAllColumnsToFitCommand | Gets the ICommand that sizes all non-star width columns to fit. (Inherited from TreeListView.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting data models.
 | StartPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when a Tab or typing key down event is received by a PropertyGridItem.
Public property | SummaryHeight | Gets or sets the height of the summary area.
Public property | SummaryTemplate | Gets or sets a DataTemplate used to display the selected item in the summary area.
Public property | SummaryTemplateSelector | Gets or sets a DataTemplateSelector used to select a DataTemplate, which is used to display the selected item in the summary area.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToggleSummaryVisibilityCommand | Gets the ICommand used to toggle the IsSummaryVisible property.
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item. (Inherited from TreeListBox.)
Public property | ValueColumnIndex | Gets the index of the value column.
Public property | ValueContainerStyle | Gets or sets the Style to use for the value column cells.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for the value column cells.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for the value column cells.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreAttachedPropertiesBrowsable Property

PropertyGridAreAttachedPropertiesBrowsable Property

Gets or sets whether attached properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreAttachedPropertiesBrowsable { get; set; }
Public Property AreAttachedPropertiesBrowsable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if attached properties are browsable and are displayed in the property grid; otherwise false. The default value is false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreCategoriesAutoExpanded Property

PropertyGridAreCategoriesAutoExpanded Property

Gets or sets whether categories are auto-expanded when they are added into the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreCategoriesAutoExpanded { get; set; }
Public Property AreCategoriesAutoExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if categories are auto-expanded when they are added into the property grid; otherwise false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreClipboardMenuItemsEnabled Property

PropertyGridAreClipboardMenuItemsEnabled Property

Gets or sets whether the default item context menu should include menu items for clipboard operations such as copying a property value.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreClipboardMenuItemsEnabled { get; set; }
Public Property AreClipboardMenuItemsEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the default item context menu should include menu items for clipboard operations such as copying a property value; otherwise false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreInheritedPropertiesBrowsable Property

PropertyGridAreInheritedPropertiesBrowsable Property

Gets or sets whether inherited properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreInheritedPropertiesBrowsable { get; set; }
Public Property AreInheritedPropertiesBrowsable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if inherited properties are browsable and are displayed in the property grid; otherwise false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreNestedCategoriesSupported Property

PropertyGridAreNestedCategoriesSupported Property

Gets or sets whether nested categories are supported, using a special syntax in the category name.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreNestedCategoriesSupported { get; set; }
Public Property AreNestedCategoriesSupported As Boolean
    Get
    Set

Property Value

Type: Boolean
true if nested categories are supported; otherwise false. The default value is false.
Remarks
To specify a nested category, the category names should be separated by a '\'. Individual category names can be wrapped with single or double quotes, as needed.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ArePropertiesAutoExpanded Property

PropertyGridArePropertiesAutoExpanded Property

Gets or sets whether expandable properties are auto-expanded when they are added into the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ArePropertiesAutoExpanded { get; set; }
Public Property ArePropertiesAutoExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if expandable properties are auto-expanded when they are added into the property grid; otherwise false. The default value is false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreReadOnlyPropertiesBrowsable Property

PropertyGridAreReadOnlyPropertiesBrowsable Property

Gets or sets whether read-only properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreReadOnlyPropertiesBrowsable { get; set; }
Public Property AreReadOnlyPropertiesBrowsable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if read-only properties are browsable and are displayed in the property grid; otherwise false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.BrowsableAttributes Property

PropertyGridBrowsableAttributes Property

Gets or sets a list of Attribute objects that are used to determine which properties are browsable.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<Attribute> BrowsableAttributes { get; set; }
Public Property BrowsableAttributes As IEnumerable(Of Attribute)
    Get
    Set

Property Value

Type: IEnumerable Attribute
The list of Attribute objects that are used to determine which properties are browsable. The default value is a list with a single entry of BrowsableAttribute.Yes.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CancelPropertyValueEditHandlers Property

PropertyGridCancelPropertyValueEditHandlers Property

Gets a mapping between control types and associated delegates to be performed when an Escape key down event is received by a PropertyGridItem.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static PropertyGridItemActionHandlerDictionary CancelPropertyValueEditHandlers { get; }
Public Shared ReadOnly Property CancelPropertyValueEditHandlers As PropertyGridItemActionHandlerDictionary
    Get

Property Value

Type: PropertyGridItemActionHandlerDictionary
A mapping between control types and associated delegates.
Remarks
When a KeyDown event is raised on a PropertyGridItem, the PropertyGrid will use the control with focus to find an associated delegate in the CancelPropertyValueEditHandlers dictionary. If a matching entry is found, it will be executed. Exact type matches will be used first, then each base type will be queried.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CanSummaryAutoSize Property

PropertyGridCanSummaryAutoSize Property

Gets or sets whether the user can double-tap the summary splitter to auto-size to the summary area content.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanSummaryAutoSize { get; set; }
Public Property CanSummaryAutoSize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the user can double-tap the summary splitter to auto-size to the summary area content; otherwise, false. The default value is false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CategoryEditors Property

PropertyGridCategoryEditors Property

Gets the category editors that can consume and display one or more properties.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryEditorCollection CategoryEditors { get; }
Public ReadOnly Property CategoryEditors As CategoryEditorCollection
    Get

Property Value

Type: CategoryEditorCollection
The category editors that can consume and display one or more properties.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CollectionPropertyDisplayMode Property

PropertyGridCollectionPropertyDisplayMode Property

Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CollectionPropertyDisplayMode CollectionPropertyDisplayMode { get; set; }
Public Property CollectionPropertyDisplayMode As CollectionPropertyDisplayMode
    Get
    Set

Property Value

Type: CollectionPropertyDisplayMode
A CollectionPropertyDisplayMode that indicates the display mode of collection properties. The default value is CollectionPropertyDisplayMode.Default.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CommitPropertyValueEditHandlers Property

PropertyGridCommitPropertyValueEditHandlers Property

Gets a mapping between control types and associated delegates to be performed when an Enter key down event is received by a PropertyGridItem.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static PropertyGridItemActionHandlerDictionary CommitPropertyValueEditHandlers { get; }
Public Shared ReadOnly Property CommitPropertyValueEditHandlers As PropertyGridItemActionHandlerDictionary
    Get

Property Value

Type: PropertyGridItemActionHandlerDictionary
A mapping between control types and associated delegates.
Remarks
When a KeyDown event is raised on a PropertyGridItem, the PropertyGrid will use the control with focus to find an associated delegate in the CommitPropertyValueEditHandlers dictionary. If a matching entry is found, it will be executed. Exact type matches will be used first, then each base type will be queried.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CopyDisplayNameCommand Property

PropertyGridCopyDisplayNameCommand Property

Gets the ICommand used to call the CopyDisplayName(IDataModel) method.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CopyDisplayNameCommand { get; }
Public ReadOnly Property CopyDisplayNameCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to call the CopyDisplayName(IDataModel) method.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CopyPropertyValueCommand Property

PropertyGridCopyPropertyValueCommand Property

Gets the ICommand used to call the CopyPropertyValue(IPropertyModel) method.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand CopyPropertyValueCommand { get; }
Public ReadOnly Property CopyPropertyValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to call the CopyPropertyValue(IPropertyModel) method.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DataFactory Property

PropertyGridDataFactory Property

Gets or sets the IDataFactory used to return the data models for objects.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDataFactory DataFactory { get; set; }
Public Property DataFactory As IDataFactory
    Get
    Set

Property Value

Type: IDataFactory
The IDataFactory used to return the data models for objects.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DataObject Property

PropertyGridDataObject Property

Gets or sets the data object for which the control displays properties.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object DataObject { get; set; }
Public Property DataObject As Object
    Get
    Set

Property Value

Type: Object
The data object for which the control displays properties.
Remarks
The DataObject property sets that a single object should be browsed in the property grid. If multiple objects are being browsed, this property returns the first one in the list specified by DataObjects. If no objects are being browsed, is returned. Setting this DataObject property replaces the value of the DataObjects property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DataObjects Property

PropertyGridDataObjects Property

Gets or sets the data objects for which the control displays properties.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable DataObjects { get; set; }
Public Property DataObjects As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
The data objects for which the control displays properties.
Remarks
Set this property if multiple data objects should be browsed at the same time. The property grid only displays the properties that are common to all the data objects. Setting this DataObjects property replaces the value of the DataObject property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultBooleanValueTemplate Property

PropertyGridDefaultBooleanValueTemplate Property

Gets or sets a DataTemplate for editing a Boolean value with a two-state CheckBox.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultBooleanValueTemplate { get; set; }
Public Property DefaultBooleanValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultBrushValueTemplate Property

PropertyGridDefaultBrushValueTemplate Property

Gets or sets a DataTemplate for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultBrushValueTemplate { get; set; }
Public Property DefaultBrushValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultCategoryEditorItemContainerStyle Property

PropertyGridDefaultCategoryEditorItemContainerStyle Property

Gets or sets a default PropertyGridItem container Style used for category editor models.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style DefaultCategoryEditorItemContainerStyle { get; set; }
Public Property DefaultCategoryEditorItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
A default PropertyGridItem container Style used for category editor models.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultCategoryItemContainerStyle Property

PropertyGridDefaultCategoryItemContainerStyle Property

Gets or sets a default PropertyGridItem container Style used for category models.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style DefaultCategoryItemContainerStyle { get; set; }
Public Property DefaultCategoryItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
A default PropertyGridItem container Style used for category models.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultColorValueTemplate Property

PropertyGridDefaultColorValueTemplate Property

Gets or sets a DataTemplate for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultColorValueTemplate { get; set; }
Public Property DefaultColorValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultExtendedStringValueTemplate Property

PropertyGridDefaultExtendedStringValueTemplate Property

Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultExtendedStringValueTemplate { get; set; }
Public Property DefaultExtendedStringValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultFontFamilyValueTemplate Property

PropertyGridDefaultFontFamilyValueTemplate Property

Gets or sets a DataTemplate for editing a FontFamily value with a ComboBox that contains system font families.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultFontFamilyValueTemplate { get; set; }
Public Property DefaultFontFamilyValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultFontStretchValueTemplate Property

PropertyGridDefaultFontStretchValueTemplate Property

Gets or sets a DataTemplate for editing a FontStretch value with a ComboBox that contains font stretch options.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultFontStretchValueTemplate { get; set; }
Public Property DefaultFontStretchValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultFontStyleValueTemplate Property

PropertyGridDefaultFontStyleValueTemplate Property

Gets or sets a DataTemplate for editing a FontStyle value with a ComboBox that contains font style options.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultFontStyleValueTemplate { get; set; }
Public Property DefaultFontStyleValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultFontWeightValueTemplate Property

PropertyGridDefaultFontWeightValueTemplate Property

Gets or sets a DataTemplate for editing a FontWeight value with a ComboBox that contains font weight options.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultFontWeightValueTemplate { get; set; }
Public Property DefaultFontWeightValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultLimitedObjectValueTemplate Property

PropertyGridDefaultLimitedObjectValueTemplate Property

Gets or sets a DataTemplate for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultLimitedObjectValueTemplate { get; set; }
Public Property DefaultLimitedObjectValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultLimitedStringValueTemplate Property

PropertyGridDefaultLimitedStringValueTemplate Property

Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultLimitedStringValueTemplate { get; set; }
Public Property DefaultLimitedStringValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultNullableBooleanValueTemplate Property

PropertyGridDefaultNullableBooleanValueTemplate Property

Gets or sets a DataTemplate for editing a nullable Boolean with a three-state CheckBox.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultNullableBooleanValueTemplate { get; set; }
Public Property DefaultNullableBooleanValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultPropertyEditors Property

PropertyGridDefaultPropertyEditors Property

Gets the collection of property editors that are used by default in all PropertyGrid instances, examined alongside the PropertyEditors collection for each PropertyGrid instance.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static PropertyEditorCollection DefaultPropertyEditors { get; }
Public Shared ReadOnly Property DefaultPropertyEditors As PropertyEditorCollection
    Get

Property Value

Type: PropertyEditorCollection
The collection of property editors that are used by default in all PropertyGrid instances.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace
PropertyGridPropertyEditors


PropertyGrid.DefaultPropertyItemContainerStyle Property

PropertyGridDefaultPropertyItemContainerStyle Property

Gets or sets a default PropertyGridItem container Style used for property models.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style DefaultPropertyItemContainerStyle { get; set; }
Public Property DefaultPropertyItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
A default PropertyGridItem container Style used for property models.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultStringNameTemplate Property

PropertyGridDefaultStringNameTemplate Property

Gets or sets a DataTemplate with a read-only TextBlock that can be used for name column cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultStringNameTemplate { get; set; }
Public Property DefaultStringNameTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for name column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultStringValueTemplate Property

PropertyGridDefaultStringValueTemplate Property

Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultStringValueTemplate { get; set; }
Public Property DefaultStringValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultSuggestedStringValueTemplate Property

PropertyGridDefaultSuggestedStringValueTemplate Property

Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate DefaultSuggestedStringValueTemplate { get; set; }
Public Property DefaultSuggestedStringValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsCategorized Property

PropertyGridIsCategorized Property

Gets or sets whether properties are categorized.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCategorized { get; set; }
Public Property IsCategorized As Boolean
    Get
    Set

Property Value

Type: Boolean
true if properties are categorized; otherwise, false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsDefaultItemContextMenuEnabled Property

PropertyGridIsDefaultItemContextMenuEnabled Property

Gets or sets whether the default context menu is enabled for property grid items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDefaultItemContextMenuEnabled { get; set; }
Public Property IsDefaultItemContextMenuEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the default context menu is enabled for property grid items; otherwise false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsReadOnly Property

PropertyGridIsReadOnly Property

Gets or sets whether the value editors are read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if value editors are read-only; otherwise, false. The default value is false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsSummaryResizable Property

PropertyGridIsSummaryResizable Property

Gets or sets whether the summary area is resizable.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSummaryResizable { get; set; }
Public Property IsSummaryResizable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the summary is resizable; otherwise, false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsSummaryToggleAllowed Property

PropertyGridIsSummaryToggleAllowed Property

Gets or sets whether the summary area's visibility is allowed to be toggled.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSummaryToggleAllowed { get; set; }
Public Property IsSummaryToggleAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the summary area's visibility is allowed to be toggled; otherwise, false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsSummaryVisible Property

PropertyGridIsSummaryVisible Property

Gets or sets whether the summary area is visible.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSummaryVisible { get; set; }
Public Property IsSummaryVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the summary area is visible; otherwise, false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.MiscCategoryName Property

PropertyGridMiscCategoryName Property

Gets or sets the name used for the miscellaneous category.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string MiscCategoryName { get; set; }
Public Property MiscCategoryName As String
    Get
    Set

Property Value

Type: String
The name used for the miscellaneous category. The default value is the localized "Misc" text.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.NameColumnIndex Property

PropertyGridNameColumnIndex Property

Gets the index of the name column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int NameColumnIndex { get; }
Public ReadOnly Property NameColumnIndex As Integer
    Get

Property Value

Type: Int32
The index of the name column.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.NameColumnMaxWidth Property

PropertyGridNameColumnMaxWidth Property

Gets or sets the maximum width of the name column, which comes into play as the property grid or its columns are resized.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double NameColumnMaxWidth { get; set; }
Public Property NameColumnMaxWidth As Double
    Get
    Set

Property Value

Type: Double
The maximum width of the name column.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.NameContainerStyle Property

PropertyGridNameContainerStyle Property

Gets or sets the Style to use for the name column cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style NameContainerStyle { get; set; }
Public Property NameContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the name column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.NameTemplate Property

PropertyGridNameTemplate Property

Gets or sets the DataTemplate to use for the name column cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate NameTemplate { get; set; }
Public Property NameTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the name column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.NameTemplateSelector Property

PropertyGridNameTemplateSelector Property

Gets or sets the DataTemplateSelector to use for the name column cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector NameTemplateSelector { get; set; }
Public Property NameTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for the name column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.PastePropertyValueCommand Property

PropertyGridPastePropertyValueCommand Property

Gets the ICommand used to call the PastePropertyValue(IPropertyModel) method.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand PastePropertyValueCommand { get; }
Public ReadOnly Property PastePropertyValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to call the PastePropertyValue(IPropertyModel) method.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.Properties Property

PropertyGridProperties Property

Gets the explicitly-defined properties that should be displayed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModelCollection Properties { get; }
Public ReadOnly Property Properties As PropertyModelCollection
    Get

Property Value

Type: PropertyModelCollection
The explicitly-defined properties that should be displayed.
Remarks
These properties will be merged with the properties generated from the DataObjects property. If DataObjects is null or empty, then only these properties will be displayed.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.PropertyEditors Property

PropertyGridPropertyEditors Property

Gets the PropertyEditorCollection that contains property editor definitions specifically for this property grid instance.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditorCollection PropertyEditors { get; }
Public ReadOnly Property PropertyEditors As PropertyEditorCollection
    Get

Property Value

Type: PropertyEditorCollection
The PropertyEditorCollection that contains property editor definitions specifically for this property grid instance.

Implements

IPropertyEditorsProviderPropertyEditors
Remarks
The DefaultPropertyEditors collection contains other property editors that apply to all PropertyGrid instances.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace
PropertyGridDefaultPropertyEditors


PropertyGrid.PropertyEditorsModifierKey Property

PropertyGridPropertyEditorsModifierKey Property

Gets the resource key that is loaded by the PropertyGrid, allowing for customization of the property editors directly from XAML.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Object PropertyEditorsModifierKey { get; }
Public Shared ReadOnly Property PropertyEditorsModifierKey As Object
    Get

Property Value

Type: Object
A resource key whose value is the string "PropertyGridPropertyEditorsModifierKey".
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.PropertyExpandability Property

PropertyGridPropertyExpandability Property

Gets or sets a PropertyExpandability that indicates the expandability of properties.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyExpandability PropertyExpandability { get; set; }
Public Property PropertyExpandability As PropertyExpandability
    Get
    Set

Property Value

Type: PropertyExpandability
A PropertyExpandability that indicates the expandability of properties. The default value is PropertyExpandability.Default.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.SortComparer Property

PropertyGridSortComparer Property

Gets or sets the DataModelSortComparer to use for sorting data models.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataModelSortComparer SortComparer { get; set; }
Public Property SortComparer As DataModelSortComparer
    Get
    Set

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting data models. The default value is a DataModelSortComparer instance.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.StartPropertyValueEditHandlers Property

PropertyGridStartPropertyValueEditHandlers Property

Gets a mapping between control types and associated delegates to be performed when a Tab or typing key down event is received by a PropertyGridItem.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static PropertyGridItemActionHandlerDictionary StartPropertyValueEditHandlers { get; }
Public Shared ReadOnly Property StartPropertyValueEditHandlers As PropertyGridItemActionHandlerDictionary
    Get

Property Value

Type: PropertyGridItemActionHandlerDictionary
A mapping between control types and associated delegates.
Remarks
When a KeyDown event is raised on a PropertyGridItem, the PropertyGrid will use the control that should gain focus to find an associated delegate in the StartPropertyValueEditHandlers dictionary. If a matching entry is found, it will be executed. Exact type matches will be used first, then each base type will be queried.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.SummaryHeight Property

PropertyGridSummaryHeight Property

Gets or sets the height of the summary area.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SummaryHeight { get; set; }
Public Property SummaryHeight As Double
    Get
    Set

Property Value

Type: Double
The height of the summary area. The default value is 78.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.SummaryTemplate Property

PropertyGridSummaryTemplate Property

Gets or sets a DataTemplate used to display the selected item in the summary area.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate SummaryTemplate { get; set; }
Public Property SummaryTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate used to display the selected item in the summary area. The default value is .
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.SummaryTemplateSelector Property

PropertyGridSummaryTemplateSelector Property

Gets or sets a DataTemplateSelector used to select a DataTemplate, which is used to display the selected item in the summary area.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector SummaryTemplateSelector { get; set; }
Public Property SummaryTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector used to select a DataTemplate, which is used to display the selected item in the summary area. The default value is .
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ToggleSummaryVisibilityCommand Property

PropertyGridToggleSummaryVisibilityCommand Property

Gets the ICommand used to toggle the IsSummaryVisible property.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ToggleSummaryVisibilityCommand { get; }
Public ReadOnly Property ToggleSummaryVisibilityCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to toggle the IsSummaryVisible property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ValueColumnIndex Property

PropertyGridValueColumnIndex Property

Gets the index of the value column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int ValueColumnIndex { get; }
Public ReadOnly Property ValueColumnIndex As Integer
    Get

Property Value

Type: Int32
The index of the value column.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ValueContainerStyle Property

PropertyGridValueContainerStyle Property

Gets or sets the Style to use for the value column cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ValueContainerStyle { get; set; }
Public Property ValueContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ValueTemplate Property

PropertyGridValueTemplate Property

Gets or sets the DataTemplate to use for the value column cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ValueTemplate { get; set; }
Public Property ValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ValueTemplateSelector Property

PropertyGridValueTemplateSelector Property

Gets or sets the DataTemplateSelector to use for the value column cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector ValueTemplateSelector { get; set; }
Public Property ValueTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for the value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid Methods

The PropertyGrid type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from TreeListView.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BringItemIntoView | Brings the specified node's container into view. (Inherited from TreeListBox.)
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view. (Inherited from TreeListBox.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Inherited from TreeListView.)
Public method | CollapseAll | Collapses all known tree items. (Inherited from TreeListBox.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | CopyDisplayName | Copies the display name of the specified IDataModel
Public method | CopyPropertyValue | Copies the value of the specified IPropertyModel
Public method | CreateSelectionBatch | Creates an IDisposable object that wraps a batch of selection updates, and allows them to be made without raising selection-related events in between each one. (Inherited from TreeListBox.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | ExpandAll | Expands all known tree items. (Inherited from TreeListBox.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed. (Inherited from TreeListBox.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TreeListViewGetContainerForItemOverride.)
Public method | GetFullPath | Returns the full path of the specified item. (Inherited from TreeListBox.)
Public method | GetItemByFullPath | Returns the item with the specified full path. (Inherited from TreeListBox.)
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item. (Inherited from TreeListBox.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried. (Inherited from TreeListBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TreeListViewIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from TreeListView.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListViewOnApplyTemplate.)
Protected method | OnChildPropertyAdded | Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.
Protected method | OnChildPropertyAdding | Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.
Protected method | OnChildPropertyRemoved | Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.
Protected method | OnChildPropertyRemoving | Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.
Protected method | OnColumnHeaderMenuRequested | Occurs when a column header requests a context menu. (Inherited from TreeListView.)
Protected method | OnColumnHeaderTapped | Occurs when a column's header is tapped. (Inherited from TreeListView.)
Protected method | OnColumnIsVisibleChanged | Occurs when a column's visibility has changed. (Inherited from TreeListView.)
Protected method | OnColumnReordered | Occurs after a column is reordered by the end user. (Inherited from TreeListView.)
Protected method | OnColumnsResized | Occurs after the ActualWidth of one or more columns changes. (Inherited from TreeListView.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TreeListViewOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBox.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBox.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBox.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBox.)
Protected method | OnGotKeyboardFocus | Occurs when the control gains keyboard focus. (Inherited from TreeListBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Inherited from TreeListBox.)
Protected method | OnIsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed. (Inherited from TreeListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Protected method | OnItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu. (Overrides TreeListBoxOnItemMenuRequested(TreeListBoxItemMenuEventArgs).)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource property is changed. (Inherited from TreeListBox.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides TreeListBoxOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyValueChanged | Occurs after the value is set for an IPropertyModel.
Protected method | OnPropertyValueChanging | Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.
Protected method | OnRootItemChanged | Occurs after the RootItem property is changed. (Inherited from TreeListBox.)
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed. (Inherited from TreeListView.)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PastePropertyValue | Pastes a value to the specified IPropertyModel
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from TreeListView.)
Protected method | ProcessKeyDown | Processes a key down event. (Inherited from TreeListBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path. (Inherited from TreeListBox.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | SizeAllColumnsToFit | Sizes all non-star width columns to fit. (Inherited from TreeListView.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TryCommitPropertyValueEdit | Tries to commit a pending property value edit, generally in response to an Enter key press.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CopyDisplayName Method

PropertyGridCopyDisplayName Method

Copies the display name of the specified IDataModel

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyDisplayName(
    IDataModel model
)
Public Sub CopyDisplayName (
    model As IDataModel
)

Parameters

model
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataModel
The IDataModel to examine.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CopyPropertyValue Method

PropertyGridCopyPropertyValue Method

Copies the value of the specified IPropertyModel

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyPropertyValue(
    IPropertyModel model
)
Public Sub CopyPropertyValue (
    model As IPropertyModel
)

Parameters

model
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.GetContainerForItemOverride Method

PropertyGridGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsItemItsOwnContainerOverride Method

PropertyGridIsItemItsOwnContainerOverride Method

Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnApplyTemplate Method

PropertyGridOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnChildPropertyAdded Method

PropertyGridOnChildPropertyAdded Method

Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnChildPropertyAdded(
    PropertyModelChildChangeEventArgs e
)
Protected Overridable Sub OnChildPropertyAdded (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnChildPropertyAdding Method

PropertyGridOnChildPropertyAdding Method

Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnChildPropertyAdding(
    PropertyModelChildChangeEventArgs e
)
Protected Overridable Sub OnChildPropertyAdding (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnChildPropertyRemoved Method

PropertyGridOnChildPropertyRemoved Method

Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnChildPropertyRemoved(
    PropertyModelChildChangeEventArgs e
)
Protected Overridable Sub OnChildPropertyRemoved (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnChildPropertyRemoving Method

PropertyGridOnChildPropertyRemoving Method

Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnChildPropertyRemoving(
    PropertyModelChildChangeEventArgs e
)
Protected Overridable Sub OnChildPropertyRemoving (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnCreateAutomationPeer Method

PropertyGridOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnItemMenuRequested Method

PropertyGridOnItemMenuRequested Method

Occurs when an item requests a context menu.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnItemMenuRequested(
    TreeListBoxItemMenuEventArgs e
)
Protected Overrides Sub OnItemMenuRequested (
    e As TreeListBoxItemMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItemMenuEventArgs
The TreeListBoxItemMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnKeyDown Method

PropertyGridOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnPropertyValueChanged Method

PropertyGridOnPropertyValueChanged Method

Occurs after the value is set for an IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyValueChanged(
    PropertyModelValueChangeEventArgs e
)
Protected Overridable Sub OnPropertyValueChanged (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.OnPropertyValueChanging Method

PropertyGridOnPropertyValueChanging Method

Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyValueChanging(
    PropertyModelValueChangeEventArgs e
)
Protected Overridable Sub OnPropertyValueChanging (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.PastePropertyValue Method

PropertyGridPastePropertyValue Method

Pastes a value to the specified IPropertyModel

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void PastePropertyValue(
    IPropertyModel model
)
Public Sub PastePropertyValue (
    model As IPropertyModel
)

Parameters

model
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.TryCommitPropertyValueEdit Method

PropertyGridTryCommitPropertyValueEdit Method

Tries to commit a pending property value edit, generally in response to an Enter key press.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool TryCommitPropertyValueEdit()
Public Function TryCommitPropertyValueEdit As Boolean

Return Value

Type: Boolean
true if the commit was handled; otherwise, false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid Events

The PropertyGrid type exposes the following members.

Events
 | Name | Description
Public event | ChildPropertyAdded | Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.
Public event | ChildPropertyAdding | Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.
Public event | ChildPropertyRemoved | Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.
Public event | ChildPropertyRemoving | Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.
Public event | ColumnHeaderMenuRequested | Occurs when a column header requests a context menu. (Inherited from TreeListView.)
Public event | ColumnHeaderTapped | Occurs when a column's header is tapped. (Inherited from TreeListView.)
Public event | ColumnIsVisibleChanged | Occurs when a column's visibility has changed. (Inherited from TreeListView.)
Public event | ColumnReordered | Occurs after a column is reordered by the end user. (Inherited from TreeListView.)
Public event | ColumnsResized | Occurs after the ActualWidth of one or more columns changes. (Inherited from TreeListView.)
Public event | IsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed. (Inherited from TreeListBox.)
Public event | ItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Public event | ItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Public event | ItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Public event | ItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Public event | ItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyValueChanged | Occurs after the value is set for an IPropertyModel.
Public event | PropertyValueChanging | Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.
Public event | RootItemChanged | Occurs after the RootItem property is changed. (Inherited from TreeListBox.)
Public event | SelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Top
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ChildPropertyAdded Event

PropertyGridChildPropertyAdded Event

Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelChildChangeEventArgs> ChildPropertyAdded
Public Event ChildPropertyAdded As EventHandler(Of PropertyModelChildChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelChildChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ChildPropertyAdding Event

PropertyGridChildPropertyAdding Event

Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelChildChangeEventArgs> ChildPropertyAdding
Public Event ChildPropertyAdding As EventHandler(Of PropertyModelChildChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelChildChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ChildPropertyRemoved Event

PropertyGridChildPropertyRemoved Event

Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelChildChangeEventArgs> ChildPropertyRemoved
Public Event ChildPropertyRemoved As EventHandler(Of PropertyModelChildChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelChildChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ChildPropertyRemoving Event

PropertyGridChildPropertyRemoving Event

Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelChildChangeEventArgs> ChildPropertyRemoving
Public Event ChildPropertyRemoving As EventHandler(Of PropertyModelChildChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelChildChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.PropertyValueChanged Event

PropertyGridPropertyValueChanged Event

Occurs after the value is set for an IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelValueChangeEventArgs> PropertyValueChanged
Public Event PropertyValueChanged As EventHandler(Of PropertyModelValueChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelValueChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.PropertyValueChanging Event

PropertyGridPropertyValueChanging Event

Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelValueChangeEventArgs> PropertyValueChanging
Public Event PropertyValueChanging As EventHandler(Of PropertyModelValueChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelValueChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid Fields

The PropertyGrid type exposes the following members.

Fields
Name | Description
AreAttachedPropertiesBrowsableProperty | Identifies the AreAttachedPropertiesBrowsable dependency property. This field is read-only.
AreCategoriesAutoExpandedProperty | Identifies the AreCategoriesAutoExpanded dependency property. This field is read-only.
AreClipboardMenuItemsEnabledProperty | Identifies the AreClipboardMenuItemsEnabled dependency property. This field is read-only.
AreInheritedPropertiesBrowsableProperty | Identifies the AreInheritedPropertiesBrowsable dependency property. This field is read-only.
AreNestedCategoriesSupportedProperty | Identifies the AreNestedCategoriesSupported dependency property. This field is read-only.
ArePropertiesAutoExpandedProperty | Identifies the ArePropertiesAutoExpanded dependency property. This field is read-only.
AreReadOnlyPropertiesBrowsableProperty | Identifies the AreReadOnlyPropertiesBrowsable dependency property. This field is read-only.
BrowsableAttributesProperty | Identifies the BrowsableAttributes dependency property. This field is read-only.
CanSummaryAutoSizeProperty | Identifies the CanSummaryAutoSize dependency property. This field is read-only.
ChildPropertyAddedEvent | Identifies the ChildPropertyAdded routed event. This field is read-only.
ChildPropertyAddingEvent | Identifies the ChildPropertyAdding routed event. This field is read-only.
ChildPropertyRemovedEvent | Identifies the ChildPropertyRemoved routed event. This field is read-only.
ChildPropertyRemovingEvent | Identifies the ChildPropertyRemoving routed event. This field is read-only.
CollectionPropertyDisplayModeProperty | Identifies the CollectionPropertyDisplayMode dependency property. This field is read-only.
DataFactoryProperty | Identifies the DataFactory dependency property. This field is read-only.
DataObjectProperty | Identifies the DataObject dependency property. This field is read-only.
DataObjectsProperty | Identifies the DataObjects dependency property. This field is read-only.
DefaultBooleanValueTemplateProperty | Identifies the DefaultBooleanValueTemplate dependency property. This field is read-only.
DefaultBrushValueTemplateProperty | Identifies the DefaultBrushValueTemplate dependency property. This field is read-only.
DefaultCategoryEditorItemContainerStyleProperty | Identifies the DefaultCategoryEditorItemContainerStyle dependency property. This field is read-only.
DefaultCategoryItemContainerStyleProperty | Identifies the DefaultCategoryItemContainerStyle dependency property. This field is read-only.
DefaultColorValueTemplateProperty | Identifies the DefaultColorValueTemplate dependency property. This field is read-only.
DefaultExtendedStringValueTemplateProperty | Identifies the DefaultExtendedStringValueTemplate dependency property. This field is read-only.
DefaultFontFamilyValueTemplateProperty | Identifies the DefaultFontFamilyValueTemplate dependency property. This field is read-only.
DefaultFontStretchValueTemplateProperty | Identifies the DefaultFontStretchValueTemplate dependency property. This field is read-only.
DefaultFontStyleValueTemplateProperty | Identifies the DefaultFontStyleValueTemplate dependency property. This field is read-only.
DefaultFontWeightValueTemplateProperty | Identifies the DefaultFontWeightValueTemplate dependency property. This field is read-only.
DefaultLimitedObjectValueTemplateProperty | Identifies the DefaultLimitedObjectValueTemplate dependency property. This field is read-only.
DefaultLimitedStringValueTemplateProperty | Identifies the DefaultLimitedStringValueTemplate dependency property. This field is read-only.
DefaultNullableBooleanValueTemplateProperty | Identifies the DefaultNullableBooleanValueTemplate dependency property. This field is read-only.
DefaultPropertyItemContainerStyleProperty | Identifies the DefaultPropertyItemContainerStyle dependency property. This field is read-only.
DefaultStringNameTemplateProperty | Identifies the DefaultStringNameTemplate dependency property. This field is read-only.
DefaultStringValueTemplateProperty | Identifies the DefaultStringValueTemplate dependency property. This field is read-only.
DefaultSuggestedStringValueTemplateProperty | Identifies the DefaultSuggestedStringValueTemplate dependency property. This field is read-only.
IsCategorizedProperty | Identifies the IsCategorized dependency property. This field is read-only.
IsDefaultItemContextMenuEnabledProperty | Identifies the IsDefaultItemContextMenuEnabled dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSummaryResizableProperty | Identifies the IsSummaryResizable dependency property. This field is read-only.
IsSummaryToggleAllowedProperty | Identifies the IsSummaryToggleAllowed dependency property. This field is read-only.
IsSummaryVisibleProperty | Identifies the IsSummaryVisible dependency property. This field is read-only.
MiscCategoryNameProperty | Identifies the MiscCategoryName dependency property. This field is read-only.
NameColumnMaxWidthProperty | Identifies the NameColumnMaxWidth dependency property. This field is read-only.
NameContainerStyleProperty | Identifies the NameContainerStyle dependency property. This field is read-only.
NameTemplateProperty | Identifies the NameTemplate dependency property. This field is read-only.
NameTemplateSelectorProperty | Identifies the NameTemplateSelector dependency property. This field is read-only.
PropertyExpandabilityProperty | Identifies the PropertyExpandability dependency property. This field is read-only.
PropertyValueChangedEvent | Identifies the PropertyValueChanged routed event. This field is read-only.
PropertyValueChangingEvent | Identifies the PropertyValueChanging routed event. This field is read-only.
SortComparerProperty | Identifies the SortComparer dependency property. This field is read-only.
SummaryHeightProperty | Identifies the SummaryHeight dependency property. This field is read-only.
SummaryTemplateProperty | Identifies the SummaryTemplate dependency property. This field is read-only.
SummaryTemplateSelectorProperty | Identifies the SummaryTemplateSelector dependency property. This field is read-only.
ValueContainerStyleProperty | Identifies the ValueContainerStyle dependency property. This field is read-only.
ValueTemplateProperty | Identifies the ValueTemplate dependency property. This field is read-only.
ValueTemplateSelectorProperty | Identifies the ValueTemplateSelector dependency property. This field is read-only.
Top
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreAttachedPropertiesBrowsableProperty Field

PropertyGridAreAttachedPropertiesBrowsableProperty Field

Identifies the AreAttachedPropertiesBrowsable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreAttachedPropertiesBrowsableProperty
Public Shared ReadOnly AreAttachedPropertiesBrowsableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreAttachedPropertiesBrowsable dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreCategoriesAutoExpandedProperty Field

PropertyGridAreCategoriesAutoExpandedProperty Field

Identifies the AreCategoriesAutoExpanded dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreCategoriesAutoExpandedProperty
Public Shared ReadOnly AreCategoriesAutoExpandedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreCategoriesAutoExpanded dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreClipboardMenuItemsEnabledProperty Field

PropertyGridAreClipboardMenuItemsEnabledProperty Field

Identifies the AreClipboardMenuItemsEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreClipboardMenuItemsEnabledProperty
Public Shared ReadOnly AreClipboardMenuItemsEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreClipboardMenuItemsEnabled dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreInheritedPropertiesBrowsableProperty Field

PropertyGridAreInheritedPropertiesBrowsableProperty Field

Identifies the AreInheritedPropertiesBrowsable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreInheritedPropertiesBrowsableProperty
Public Shared ReadOnly AreInheritedPropertiesBrowsableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreInheritedPropertiesBrowsable dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreNestedCategoriesSupportedProperty Field

PropertyGridAreNestedCategoriesSupportedProperty Field

Identifies the AreNestedCategoriesSupported dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreNestedCategoriesSupportedProperty
Public Shared ReadOnly AreNestedCategoriesSupportedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreNestedCategoriesSupported dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ArePropertiesAutoExpandedProperty Field

PropertyGridArePropertiesAutoExpandedProperty Field

Identifies the ArePropertiesAutoExpanded dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArePropertiesAutoExpandedProperty
Public Shared ReadOnly ArePropertiesAutoExpandedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArePropertiesAutoExpanded dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.AreReadOnlyPropertiesBrowsableProperty Field

PropertyGridAreReadOnlyPropertiesBrowsableProperty Field

Identifies the AreReadOnlyPropertiesBrowsable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreReadOnlyPropertiesBrowsableProperty
Public Shared ReadOnly AreReadOnlyPropertiesBrowsableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreReadOnlyPropertiesBrowsable dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.BrowsableAttributesProperty Field

PropertyGridBrowsableAttributesProperty Field

Identifies the BrowsableAttributes dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrowsableAttributesProperty
Public Shared ReadOnly BrowsableAttributesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BrowsableAttributes dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CanSummaryAutoSizeProperty Field

PropertyGridCanSummaryAutoSizeProperty Field

Identifies the CanSummaryAutoSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanSummaryAutoSizeProperty
Public Shared ReadOnly CanSummaryAutoSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanSummaryAutoSize dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ChildPropertyAddedEvent Field

PropertyGridChildPropertyAddedEvent Field

Identifies the ChildPropertyAdded routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ChildPropertyAddedEvent
Public Shared ReadOnly ChildPropertyAddedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ChildPropertyAdded routed event.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ChildPropertyAddingEvent Field

PropertyGridChildPropertyAddingEvent Field

Identifies the ChildPropertyAdding routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ChildPropertyAddingEvent
Public Shared ReadOnly ChildPropertyAddingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ChildPropertyAdding routed event.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ChildPropertyRemovedEvent Field

PropertyGridChildPropertyRemovedEvent Field

Identifies the ChildPropertyRemoved routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ChildPropertyRemovedEvent
Public Shared ReadOnly ChildPropertyRemovedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ChildPropertyRemoved routed event.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ChildPropertyRemovingEvent Field

PropertyGridChildPropertyRemovingEvent Field

Identifies the ChildPropertyRemoving routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ChildPropertyRemovingEvent
Public Shared ReadOnly ChildPropertyRemovingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ChildPropertyRemoving routed event.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.CollectionPropertyDisplayModeProperty Field

PropertyGridCollectionPropertyDisplayModeProperty Field

Identifies the CollectionPropertyDisplayMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CollectionPropertyDisplayModeProperty
Public Shared ReadOnly CollectionPropertyDisplayModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CollectionPropertyDisplayMode dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DataFactoryProperty Field

PropertyGridDataFactoryProperty Field

Identifies the DataFactory dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataFactoryProperty
Public Shared ReadOnly DataFactoryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DataFactory dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DataObjectProperty Field

PropertyGridDataObjectProperty Field

Identifies the DataObject dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataObjectProperty
Public Shared ReadOnly DataObjectProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DataObject dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DataObjectsProperty Field

PropertyGridDataObjectsProperty Field

Identifies the DataObjects dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataObjectsProperty
Public Shared ReadOnly DataObjectsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DataObjects dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultBooleanValueTemplateProperty Field

PropertyGridDefaultBooleanValueTemplateProperty Field

Identifies the DefaultBooleanValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultBooleanValueTemplateProperty
Public Shared ReadOnly DefaultBooleanValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultBooleanValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultBrushValueTemplateProperty Field

PropertyGridDefaultBrushValueTemplateProperty Field

Identifies the DefaultBrushValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultBrushValueTemplateProperty
Public Shared ReadOnly DefaultBrushValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultBrushValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultCategoryEditorItemContainerStyleProperty Field

PropertyGridDefaultCategoryEditorItemContainerStyleProperty Field

Identifies the DefaultCategoryEditorItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultCategoryEditorItemContainerStyleProperty
Public Shared ReadOnly DefaultCategoryEditorItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultCategoryEditorItemContainerStyle dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultCategoryItemContainerStyleProperty Field

PropertyGridDefaultCategoryItemContainerStyleProperty Field

Identifies the DefaultCategoryItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultCategoryItemContainerStyleProperty
Public Shared ReadOnly DefaultCategoryItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultCategoryItemContainerStyle dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultColorValueTemplateProperty Field

PropertyGridDefaultColorValueTemplateProperty Field

Identifies the DefaultColorValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultColorValueTemplateProperty
Public Shared ReadOnly DefaultColorValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultColorValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultExtendedStringValueTemplateProperty Field

PropertyGridDefaultExtendedStringValueTemplateProperty Field

Identifies the DefaultExtendedStringValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultExtendedStringValueTemplateProperty
Public Shared ReadOnly DefaultExtendedStringValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultExtendedStringValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultFontFamilyValueTemplateProperty Field

PropertyGridDefaultFontFamilyValueTemplateProperty Field

Identifies the DefaultFontFamilyValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultFontFamilyValueTemplateProperty
Public Shared ReadOnly DefaultFontFamilyValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultFontFamilyValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultFontStretchValueTemplateProperty Field

PropertyGridDefaultFontStretchValueTemplateProperty Field

Identifies the DefaultFontStretchValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultFontStretchValueTemplateProperty
Public Shared ReadOnly DefaultFontStretchValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultFontStretchValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultFontStyleValueTemplateProperty Field

PropertyGridDefaultFontStyleValueTemplateProperty Field

Identifies the DefaultFontStyleValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultFontStyleValueTemplateProperty
Public Shared ReadOnly DefaultFontStyleValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultFontStyleValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultFontWeightValueTemplateProperty Field

PropertyGridDefaultFontWeightValueTemplateProperty Field

Identifies the DefaultFontWeightValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultFontWeightValueTemplateProperty
Public Shared ReadOnly DefaultFontWeightValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultFontWeightValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultLimitedObjectValueTemplateProperty Field

PropertyGridDefaultLimitedObjectValueTemplateProperty Field

Identifies the DefaultLimitedObjectValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultLimitedObjectValueTemplateProperty
Public Shared ReadOnly DefaultLimitedObjectValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultLimitedObjectValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultLimitedStringValueTemplateProperty Field

PropertyGridDefaultLimitedStringValueTemplateProperty Field

Identifies the DefaultLimitedStringValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultLimitedStringValueTemplateProperty
Public Shared ReadOnly DefaultLimitedStringValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultLimitedStringValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultNullableBooleanValueTemplateProperty Field

PropertyGridDefaultNullableBooleanValueTemplateProperty Field

Identifies the DefaultNullableBooleanValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultNullableBooleanValueTemplateProperty
Public Shared ReadOnly DefaultNullableBooleanValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultNullableBooleanValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultPropertyItemContainerStyleProperty Field

PropertyGridDefaultPropertyItemContainerStyleProperty Field

Identifies the DefaultPropertyItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultPropertyItemContainerStyleProperty
Public Shared ReadOnly DefaultPropertyItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultPropertyItemContainerStyle dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultStringNameTemplateProperty Field

PropertyGridDefaultStringNameTemplateProperty Field

Identifies the DefaultStringNameTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultStringNameTemplateProperty
Public Shared ReadOnly DefaultStringNameTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultStringNameTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultStringValueTemplateProperty Field

PropertyGridDefaultStringValueTemplateProperty Field

Identifies the DefaultStringValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultStringValueTemplateProperty
Public Shared ReadOnly DefaultStringValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultStringValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.DefaultSuggestedStringValueTemplateProperty Field

PropertyGridDefaultSuggestedStringValueTemplateProperty Field

Identifies the DefaultSuggestedStringValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultSuggestedStringValueTemplateProperty
Public Shared ReadOnly DefaultSuggestedStringValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultSuggestedStringValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsCategorizedProperty Field

PropertyGridIsCategorizedProperty Field

Identifies the IsCategorized dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCategorizedProperty
Public Shared ReadOnly IsCategorizedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCategorized dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsDefaultItemContextMenuEnabledProperty Field

PropertyGridIsDefaultItemContextMenuEnabledProperty Field

Identifies the IsDefaultItemContextMenuEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDefaultItemContextMenuEnabledProperty
Public Shared ReadOnly IsDefaultItemContextMenuEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDefaultItemContextMenuEnabled dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsReadOnlyProperty Field

PropertyGridIsReadOnlyProperty Field

Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsSummaryResizableProperty Field

PropertyGridIsSummaryResizableProperty Field

Identifies the IsSummaryResizable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSummaryResizableProperty
Public Shared ReadOnly IsSummaryResizableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSummaryResizable dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsSummaryToggleAllowedProperty Field

PropertyGridIsSummaryToggleAllowedProperty Field

Identifies the IsSummaryToggleAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSummaryToggleAllowedProperty
Public Shared ReadOnly IsSummaryToggleAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSummaryToggleAllowed dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.IsSummaryVisibleProperty Field

PropertyGridIsSummaryVisibleProperty Field

Identifies the IsSummaryVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSummaryVisibleProperty
Public Shared ReadOnly IsSummaryVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSummaryVisible dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.MiscCategoryNameProperty Field

PropertyGridMiscCategoryNameProperty Field

Identifies the MiscCategoryName dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MiscCategoryNameProperty
Public Shared ReadOnly MiscCategoryNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MiscCategoryName dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.NameColumnMaxWidthProperty Field

PropertyGridNameColumnMaxWidthProperty Field

Identifies the NameColumnMaxWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameColumnMaxWidthProperty
Public Shared ReadOnly NameColumnMaxWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameColumnMaxWidth dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.NameContainerStyleProperty Field

PropertyGridNameContainerStyleProperty Field

Identifies the NameContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameContainerStyleProperty
Public Shared ReadOnly NameContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameContainerStyle dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.NameTemplateProperty Field

PropertyGridNameTemplateProperty Field

Identifies the NameTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateProperty
Public Shared ReadOnly NameTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.NameTemplateSelectorProperty Field

PropertyGridNameTemplateSelectorProperty Field

Identifies the NameTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateSelectorProperty
Public Shared ReadOnly NameTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplateSelector dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.PropertyExpandabilityProperty Field

PropertyGridPropertyExpandabilityProperty Field

Identifies the PropertyExpandability dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PropertyExpandabilityProperty
Public Shared ReadOnly PropertyExpandabilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PropertyExpandability dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.PropertyValueChangedEvent Field

PropertyGridPropertyValueChangedEvent Field

Identifies the PropertyValueChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent PropertyValueChangedEvent
Public Shared ReadOnly PropertyValueChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the PropertyValueChanged routed event.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.PropertyValueChangingEvent Field

PropertyGridPropertyValueChangingEvent Field

Identifies the PropertyValueChanging routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent PropertyValueChangingEvent
Public Shared ReadOnly PropertyValueChangingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the PropertyValueChanging routed event.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.SortComparerProperty Field

PropertyGridSortComparerProperty Field

Identifies the SortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortComparerProperty
Public Shared ReadOnly SortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortComparer dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.SummaryHeightProperty Field

PropertyGridSummaryHeightProperty Field

Identifies the SummaryHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SummaryHeightProperty
Public Shared ReadOnly SummaryHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SummaryHeight dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.SummaryTemplateProperty Field

PropertyGridSummaryTemplateProperty Field

Identifies the SummaryTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SummaryTemplateProperty
Public Shared ReadOnly SummaryTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SummaryTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.SummaryTemplateSelectorProperty Field

PropertyGridSummaryTemplateSelectorProperty Field

Identifies the SummaryTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SummaryTemplateSelectorProperty
Public Shared ReadOnly SummaryTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SummaryTemplateSelector dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ValueContainerStyleProperty Field

PropertyGridValueContainerStyleProperty Field

Identifies the ValueContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueContainerStyleProperty
Public Shared ReadOnly ValueContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueContainerStyle dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ValueTemplateProperty Field

PropertyGridValueTemplateProperty Field

Identifies the ValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateProperty
Public Shared ReadOnly ValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGrid.ValueTemplateSelectorProperty Field

PropertyGridValueTemplateSelectorProperty Field

Identifies the ValueTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateSelectorProperty
Public Shared ReadOnly ValueTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplateSelector dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem Class

Represents an item for a PropertyGrid control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.GridsTreeListBoxItem
ActiproSoftware.Windows.Controls.GridsTreeListViewItem
ActiproSoftware.Windows.Controls.GridsPropertyGridItem

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItem : TreeListViewItem
Public Class PropertyGridItem
    Inherits TreeListViewItem

The PropertyGridItem type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItem | Initializes an instance of the PropertyGridItem class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused. (Inherited from TreeListBoxItem.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display. (Inherited from TreeListBoxItem.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GridLineBrush | Gets or sets the Brush used for row grid lines.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented. (Inherited from TreeListBoxItem.)
Public property | IndentIndicatorBackground | Gets or sets the Brush used for the indent indicator background.
Public property | InnerBorderThickness | Gets or sets the Thickness of the inner border. (Inherited from TreeListBoxItem.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed. (Inherited from TreeListBoxItem.)
Public property | IsExpanded | Gets or sets whether the node is expanded. (Inherited from TreeListBoxItem.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected. (Inherited from TreeListBoxItem.)
Public property | IsSelected | Gets or sets whether the node is selected. (Inherited from TreeListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button. (Inherited from TreeListBoxItem.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsLocationOverBackground | Returns whether the specified location is past the end of the content, in owner control background whitespace area. (Inherited from TreeListViewItem.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from TreeListViewItem.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Inherited from TreeListBoxItem.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TreeListViewItemOnCreateAutomationPeer.)
Protected method | OnDoubleTapped | Occurs when the item is double-tapped. (Overrides TreeListBoxItemOnDoubleTapped(InputPointerButtonEventArgs).)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBoxItem.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBoxItem.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed. (Inherited from TreeListViewItem.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from TreeListBoxItem.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides TreeListBoxItemOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBoxItem.)
Protected method | OnLostKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnLostKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Overrides UIElementOnPreviewTextInput(TextCompositionEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Occurs when composed text is input to the control. (Inherited from TreeListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TreeListBoxItem.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryCancelPropertyValueEdit | Tries to cancel a pending property value edit, generally in response to an Escape key press.
Protected method | TryCommitPropertyValueEdit | Tries to commit a pending property value edit, generally in response to an Enter key press.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
GridLineBrushProperty | Identifies the GridLineBrush dependency property. This field is read-only.
IndentIndicatorBackgroundProperty | Identifies the IndentIndicatorBackground dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem Constructor

Initializes an instance of the PropertyGridItem class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItem()
Public Sub New
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem Properties

The PropertyGridItem type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused. (Inherited from TreeListBoxItem.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display. (Inherited from TreeListBoxItem.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GridLineBrush | Gets or sets the Brush used for row grid lines.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented. (Inherited from TreeListBoxItem.)
Public property | IndentIndicatorBackground | Gets or sets the Brush used for the indent indicator background.
Public property | InnerBorderThickness | Gets or sets the Thickness of the inner border. (Inherited from TreeListBoxItem.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed. (Inherited from TreeListBoxItem.)
Public property | IsExpanded | Gets or sets whether the node is expanded. (Inherited from TreeListBoxItem.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected. (Inherited from TreeListBoxItem.)
Public property | IsSelected | Gets or sets whether the node is selected. (Inherited from TreeListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button. (Inherited from TreeListBoxItem.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.GridLineBrush Property

PropertyGridItemGridLineBrush Property

Gets or sets the Brush used for row grid lines.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush GridLineBrush { get; set; }
Public Property GridLineBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used for row grid lines.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.IndentIndicatorBackground Property

PropertyGridItemIndentIndicatorBackground Property

Gets or sets the Brush used for the indent indicator background.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush IndentIndicatorBackground { get; set; }
Public Property IndentIndicatorBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used for the indent indicator background.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem Methods

The PropertyGridItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsLocationOverBackground | Returns whether the specified location is past the end of the content, in owner control background whitespace area. (Inherited from TreeListViewItem.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from TreeListViewItem.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Inherited from TreeListBoxItem.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TreeListViewItemOnCreateAutomationPeer.)
Protected method | OnDoubleTapped | Occurs when the item is double-tapped. (Overrides TreeListBoxItemOnDoubleTapped(InputPointerButtonEventArgs).)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBoxItem.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBoxItem.)
Protected method | OnGotKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed. (Inherited from TreeListViewItem.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from TreeListBoxItem.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides TreeListBoxItemOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBoxItem.)
Protected method | OnLostKeyboardFocus | Occurs when a control within this control's hierarchy gains keyboard focus. (Overrides UIElementOnLostKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewTextInput | Occurs before text input is sent to the control. (Overrides UIElementOnPreviewTextInput(TextCompositionEventArgs).)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Occurs when composed text is input to the control. (Inherited from TreeListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TreeListBoxItem.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | TryCancelPropertyValueEdit | Tries to cancel a pending property value edit, generally in response to an Escape key press.
Protected method | TryCommitPropertyValueEdit | Tries to commit a pending property value edit, generally in response to an Enter key press.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.OnCreateAutomationPeer Method

PropertyGridItemOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.OnDoubleTapped Method

PropertyGridItemOnDoubleTapped Method

Occurs when the item is double-tapped.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDoubleTapped(
    InputPointerButtonEventArgs e
)
Protected Overrides Sub OnDoubleTapped (
    e As InputPointerButtonEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.InputInputPointerButtonEventArgs
The InputPointerButtonEventArgs containing data related to this event.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.OnGotKeyboardFocus Method

PropertyGridItemOnGotKeyboardFocus Method

Occurs when a control within this control's hierarchy gains keyboard focus.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
Protected Overrides Sub OnGotKeyboardFocus (
    e As KeyboardFocusChangedEventArgs
)

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
The KeyboardFocusChangedEventArgs that contains data related to this event.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.OnKeyDown Method

PropertyGridItemOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.OnLostKeyboardFocus Method

PropertyGridItemOnLostKeyboardFocus Method

Occurs when a control within this control's hierarchy gains keyboard focus.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
Protected Overrides Sub OnLostKeyboardFocus (
    e As KeyboardFocusChangedEventArgs
)

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
The KeyboardFocusChangedEventArgs that contains data related to this event.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.OnPreviewTextInput Method

PropertyGridItemOnPreviewTextInput Method

Occurs before text input is sent to the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPreviewTextInput(
    TextCompositionEventArgs e
)
Protected Overrides Sub OnPreviewTextInput (
    e As TextCompositionEventArgs
)

Parameters

e
Type: System.Windows.InputTextCompositionEventArgs
The TextCompositionEventArgs that contains the event data.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.TryCancelPropertyValueEdit Method

PropertyGridItemTryCancelPropertyValueEdit Method

Tries to cancel a pending property value edit, generally in response to an Escape key press.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool TryCancelPropertyValueEdit()
Protected Overridable Function TryCancelPropertyValueEdit As Boolean

Return Value

Type: Boolean
true if the cancel was handled; otherwise, false.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.TryCommitPropertyValueEdit Method

PropertyGridItemTryCommitPropertyValueEdit Method

Tries to commit a pending property value edit, generally in response to an Enter key press.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool TryCommitPropertyValueEdit()
Protected Overridable Function TryCommitPropertyValueEdit As Boolean

Return Value

Type: Boolean
true if the commit was handled; otherwise, false.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem Events

The PropertyGridItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem Fields

The PropertyGridItem type exposes the following members.

Fields
Name | Description
GridLineBrushProperty | Identifies the GridLineBrush dependency property. This field is read-only.
IndentIndicatorBackgroundProperty | Identifies the IndentIndicatorBackground dependency property. This field is read-only.
Top
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.GridLineBrushProperty Field

PropertyGridItemGridLineBrushProperty Field

Identifies the GridLineBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineBrushProperty
Public Shared ReadOnly GridLineBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineBrush dependency property.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItem.IndentIndicatorBackgroundProperty Field

PropertyGridItemIndentIndicatorBackgroundProperty Field

Identifies the IndentIndicatorBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndentIndicatorBackgroundProperty
Public Shared ReadOnly IndentIndicatorBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IndentIndicatorBackground dependency property.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionHandler Delegate

A delegate that can process the specified PropertyGridItemActionRequest.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public delegate bool PropertyGridItemActionHandler(
    PropertyGridItemActionRequest request
)
Public Delegate Function PropertyGridItemActionHandler (
    request As PropertyGridItemActionRequest
) As Boolean

Parameters

request
Type: ActiproSoftware.Windows.Controls.GridsPropertyGridItemActionRequest
The PropertyGridItemActionRequest to examine.

Return Value

Type: Boolean
true if the request was processed successfully; otherwise, false.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionHandlerDictionary Class

Represents a dictionary of Type to PropertyGridItemActionHandler objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary Type, PropertyGridItemActionHandler
ActiproSoftware.Windows.Controls.GridsPropertyGridItemActionHandlerDictionary

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItemActionHandlerDictionary : Dictionary<Type, PropertyGridItemActionHandler>
Public Class PropertyGridItemActionHandlerDictionary
    Inherits Dictionary(Of Type, PropertyGridItemActionHandler)

The PropertyGridItemActionHandlerDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemActionHandlerDictionary | Initializes a new instance of the PropertyGridItemActionHandlerDictionary class
Top
Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Top
Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionHandlerDictionary Constructor

Initializes a new instance of the PropertyGridItemActionHandlerDictionary class

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItemActionHandlerDictionary()
Public Sub New
See Also

Reference

PropertyGridItemActionHandlerDictionary Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionHandlerDictionary Properties

The PropertyGridItemActionHandlerDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Top
See Also

Reference

PropertyGridItemActionHandlerDictionary Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionHandlerDictionary Methods

The PropertyGridItemActionHandlerDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Top
See Also

Reference

PropertyGridItemActionHandlerDictionary Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionRequest Class

Stores information about a request for a PropertyGridItemActionHandler.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.GridsPropertyGridItemActionRequest

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItemActionRequest
Public Class PropertyGridItemActionRequest

The PropertyGridItemActionRequest type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemActionRequest | Initializes a new instance of the PropertyGridItemActionRequest class.
Top
Properties
 | Name | Description
Public property | Container | Gets the PropertyGridItem container.
Public property | Element | Gets the FrameworkElement in the container that is the focus of this request.
Public property | Text | Gets the typed text, if any, that triggered the request.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionRequest Constructor

Initializes a new instance of the PropertyGridItemActionRequest class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItemActionRequest(
    PropertyGridItem container,
    FrameworkElement element,
    string text
)
Public Sub New (
    container As PropertyGridItem,
    element As FrameworkElement,
    text As String
)

Parameters

container
Type: ActiproSoftware.Windows.Controls.GridsPropertyGridItem
The PropertyGridItem container.
element
Type: System.WindowsFrameworkElement
The FrameworkElement in the container that is the focus of this request.
text
Type: SystemString
The typed text, if any, that triggered the request.
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionRequest Properties

The PropertyGridItemActionRequest type exposes the following members.

Properties
 | Name | Description
Public property | Container | Gets the PropertyGridItem container.
Public property | Element | Gets the FrameworkElement in the container that is the focus of this request.
Public property | Text | Gets the typed text, if any, that triggered the request.
Top
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionRequest.Container Property

PropertyGridItemActionRequestContainer Property

Gets the PropertyGridItem container.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItem Container { get; }
Public ReadOnly Property Container As PropertyGridItem
    Get

Property Value

Type: PropertyGridItem
The PropertyGridItem container.
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionRequest.Element Property

PropertyGridItemActionRequestElement Property

Gets the FrameworkElement in the container that is the focus of this request.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FrameworkElement Element { get; }
Public ReadOnly Property Element As FrameworkElement
    Get

Property Value

Type: FrameworkElement
The FrameworkElement in the container that is the focus of this request.
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemActionRequest.Text Property

PropertyGridItemActionRequestText Property

Gets the typed text, if any, that triggered the request.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The typed text, if any, that triggered the request.
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter Class

Provides an abstract base class for a TreeListBoxItemAdapter that can be used in a PropertyGrid.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemAdapter
ActiproSoftware.Windows.Controls.GridsPropertyGridItemAdapter

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItemAdapter : TreeListBoxItemAdapter
Public Class PropertyGridItemAdapter
    Inherits TreeListBoxItemAdapter

The PropertyGridItemAdapter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemAdapter | Initializes a new instance of the PropertyGridItemAdapter class.
Top
Properties
 | Name | Description
Public property | ChildrenBinding | Gets or sets a Binding that can be used to retrieve an IEnumerable of child items. (Inherited from TreeListBoxItemAdapter.)
Public property | ChildrenPath | Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items. (Inherited from TreeListBoxItemAdapter.)
Public property | ChildrenQueryModeDefault | Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried. (Inherited from TreeListBoxItemAdapter.)
Public property | ExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability. (Inherited from TreeListBoxItemAdapter.)
Public property | IsDraggableBinding | Gets or sets a Binding that determines whether an item is draggable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditableBinding | Gets or sets a Binding that determines whether an item is editable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditableDefault | Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditingBinding | Gets or sets a Binding that determines whether an item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedBinding | Gets or sets a Binding that determines whether an item should be expanded. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedDefault | Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsLoadingBinding | Gets or sets a Binding that determines whether an item is currently loading children asynchronously. (Inherited from TreeListBoxItemAdapter.)
Public property | IsLoadingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectableBinding | Gets or sets a Binding that determines whether an item is capable of being selected. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectablePath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectedBinding | Gets or sets a Binding that determines whether an item should be selected. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states. (Inherited from TreeListBoxItemAdapter.)
Public property | PathBinding | Gets or sets a Binding that can retrieve the path of an item. (Inherited from TreeListBoxItemAdapter.)
Public property | SearchTextBinding | Gets or sets a Binding that can retrieve the search text of an item. (Inherited from TreeListBoxItemAdapter.)
Public property | TopLevelExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability. (Inherited from TreeListBoxItemAdapter.)
Top
Methods
 | Name | Description
Public method | CanHaveChildren | Returns whether the specified item is capable of having child items. (Inherited from TreeListBoxItemAdapter.)
Public method | CreateVirtualPlaceholder | Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled. (Inherited from TreeListBoxItemAdapter.)
Public method | Filter | Examines the specified item to see if meets active filter conditions. (Inherited from TreeListBoxItemAdapter.)
Public method | GetChildren | Returns an IEnumerable that will be used to provide child items for the specified parent item. (Overrides TreeListBoxItemAdapterGetChildren(TreeListBox, Object).)
Public method | GetChildrenQueryMode | Returns the children query mode of the specified item. (Inherited from TreeListBoxItemAdapter.)
Public method | GetExpandability | Returns the expandability of the specified item. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIndentAmount | Returns the indent amount of the specified item. (Overrides TreeListBoxItemAdapterGetIndentAmount(TreeListBox, Object, Int32).)
Public method | GetIsDraggable | Returns whether the specified item is draggable. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsEditable | Returns whether the specified item is editable. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsEditing | Returns whether the specified item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsExpanded | Returns whether the specified item is expanded. (Overrides TreeListBoxItemAdapterGetIsExpanded(TreeListBox, Object).)
Public method | GetIsLoading | Returns whether the specified item is currently loading children asynchronously. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsSelectable | Returns whether the specified item is capable of being selected. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsSelected | Returns whether the specified item is selected. (Overrides TreeListBoxItemAdapterGetIsSelected(TreeListBox, Object).)
Public method | GetPath | Returns the item's string path. (Overrides TreeListBoxItemAdapterGetPath(TreeListBox, Object).)
Public method | GetSearchText | Returns the item's text by which to match when searching. (Inherited from TreeListBoxItemAdapter.)
Public method | InitializeDataObject | Initializes a IDataObject based on the specified items. (Inherited from TreeListBoxItemAdapter.)
Public method | InitializeDataObjectWithDisplayName | Initializes a IDataObject with the display name of the specified IDataModel.
Public method | InitializeDataObjectWithPropertyValue | Initializes a IDataObject with the value of the specified IPropertyModel.
Public method | OnDragComplete | Notifies that a drag event from the source control has completed. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDragHover | Notifies that a drag event hovered over a target item, returning whether the target item can be expanded when appropriate. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDragOver | Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDragStart | Notifies that a drag event is about to originate from the source control. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDrop | Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs. (Inherited from TreeListBoxItemAdapter.)
Public method | SetIsEditing | Sets whether the specified item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public method | SetIsExpanded | Sets whether the specified item is expanded. (Overrides TreeListBoxItemAdapterSetIsExpanded(TreeListBox, Object, Boolean).)
Public method | SetIsSelected | Sets whether the specified item is selected. (Overrides TreeListBoxItemAdapterSetIsSelected(TreeListBox, Object, Boolean).)
Public method | SetPropertyValueFromDataObject | Sets the value of the specified IPropertyModel from data in a IDataObject.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter Constructor

Initializes a new instance of the PropertyGridItemAdapter class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItemAdapter()
Public Sub New
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter Properties

The PropertyGridItemAdapter type exposes the following members.

Properties
 | Name | Description
Public property | ChildrenBinding | Gets or sets a Binding that can be used to retrieve an IEnumerable of child items. (Inherited from TreeListBoxItemAdapter.)
Public property | ChildrenPath | Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items. (Inherited from TreeListBoxItemAdapter.)
Public property | ChildrenQueryModeDefault | Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried. (Inherited from TreeListBoxItemAdapter.)
Public property | ExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability. (Inherited from TreeListBoxItemAdapter.)
Public property | IsDraggableBinding | Gets or sets a Binding that determines whether an item is draggable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditableBinding | Gets or sets a Binding that determines whether an item is editable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditableDefault | Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditingBinding | Gets or sets a Binding that determines whether an item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedBinding | Gets or sets a Binding that determines whether an item should be expanded. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedDefault | Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsLoadingBinding | Gets or sets a Binding that determines whether an item is currently loading children asynchronously. (Inherited from TreeListBoxItemAdapter.)
Public property | IsLoadingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectableBinding | Gets or sets a Binding that determines whether an item is capable of being selected. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectablePath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectedBinding | Gets or sets a Binding that determines whether an item should be selected. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states. (Inherited from TreeListBoxItemAdapter.)
Public property | PathBinding | Gets or sets a Binding that can retrieve the path of an item. (Inherited from TreeListBoxItemAdapter.)
Public property | SearchTextBinding | Gets or sets a Binding that can retrieve the search text of an item. (Inherited from TreeListBoxItemAdapter.)
Public property | TopLevelExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability. (Inherited from TreeListBoxItemAdapter.)
Top
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter Methods

The PropertyGridItemAdapter type exposes the following members.

Methods
 | Name | Description
Public method | CanHaveChildren | Returns whether the specified item is capable of having child items. (Inherited from TreeListBoxItemAdapter.)
Public method | CreateVirtualPlaceholder | Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled. (Inherited from TreeListBoxItemAdapter.)
Public method | Filter | Examines the specified item to see if meets active filter conditions. (Inherited from TreeListBoxItemAdapter.)
Public method | GetChildren | Returns an IEnumerable that will be used to provide child items for the specified parent item. (Overrides TreeListBoxItemAdapterGetChildren(TreeListBox, Object).)
Public method | GetChildrenQueryMode | Returns the children query mode of the specified item. (Inherited from TreeListBoxItemAdapter.)
Public method | GetExpandability | Returns the expandability of the specified item. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIndentAmount | Returns the indent amount of the specified item. (Overrides TreeListBoxItemAdapterGetIndentAmount(TreeListBox, Object, Int32).)
Public method | GetIsDraggable | Returns whether the specified item is draggable. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsEditable | Returns whether the specified item is editable. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsEditing | Returns whether the specified item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsExpanded | Returns whether the specified item is expanded. (Overrides TreeListBoxItemAdapterGetIsExpanded(TreeListBox, Object).)
Public method | GetIsLoading | Returns whether the specified item is currently loading children asynchronously. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsSelectable | Returns whether the specified item is capable of being selected. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsSelected | Returns whether the specified item is selected. (Overrides TreeListBoxItemAdapterGetIsSelected(TreeListBox, Object).)
Public method | GetPath | Returns the item's string path. (Overrides TreeListBoxItemAdapterGetPath(TreeListBox, Object).)
Public method | GetSearchText | Returns the item's text by which to match when searching. (Inherited from TreeListBoxItemAdapter.)
Public method | InitializeDataObject | Initializes a IDataObject based on the specified items. (Inherited from TreeListBoxItemAdapter.)
Public method | InitializeDataObjectWithDisplayName | Initializes a IDataObject with the display name of the specified IDataModel.
Public method | InitializeDataObjectWithPropertyValue | Initializes a IDataObject with the value of the specified IPropertyModel.
Public method | OnDragComplete | Notifies that a drag event from the source control has completed. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDragHover | Notifies that a drag event hovered over a target item, returning whether the target item can be expanded when appropriate. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDragOver | Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDragStart | Notifies that a drag event is about to originate from the source control. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDrop | Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs. (Inherited from TreeListBoxItemAdapter.)
Public method | SetIsEditing | Sets whether the specified item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public method | SetIsExpanded | Sets whether the specified item is expanded. (Overrides TreeListBoxItemAdapterSetIsExpanded(TreeListBox, Object, Boolean).)
Public method | SetIsSelected | Sets whether the specified item is selected. (Overrides TreeListBoxItemAdapterSetIsSelected(TreeListBox, Object, Boolean).)
Public method | SetPropertyValueFromDataObject | Sets the value of the specified IPropertyModel from data in a IDataObject.
Top
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.GetChildren Method

PropertyGridItemAdapterGetChildren Method

Returns an IEnumerable that will be used to provide child items for the specified parent item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable GetChildren(
    TreeListBox ownerControl,
    Object item
)
Public Overrides Function GetChildren (
    ownerControl As TreeListBox,
    item As Object
) As IEnumerable

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: IEnumerable
An IEnumerable that will be used to provide child items for the specified parent item.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.GetIndentAmount Method

PropertyGridItemAdapterGetIndentAmount Method

Returns the indent amount of the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override double GetIndentAmount(
    TreeListBox ownerControl,
    Object item,
    int depth
)
Public Overrides Function GetIndentAmount (
    ownerControl As TreeListBox,
    item As Object,
    depth As Integer
) As Double

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.
depth
Type: SystemInt32
The item depth.

Return Value

Type: Double
The indent amount.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.GetIsExpanded Method

PropertyGridItemAdapterGetIsExpanded Method

Returns whether the specified item is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool GetIsExpanded(
    TreeListBox ownerControl,
    Object item
)
Public Overrides Function GetIsExpanded (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is expanded; otherwise, false.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.GetIsSelected Method

PropertyGridItemAdapterGetIsSelected Method

Returns whether the specified item is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool GetIsSelected(
    TreeListBox ownerControl,
    Object item
)
Public Overrides Function GetIsSelected (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is selected; otherwise, false.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.GetPath Method

PropertyGridItemAdapterGetPath Method

Returns the item's string path.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string GetPath(
    TreeListBox ownerControl,
    Object item
)
Public Overrides Function GetPath (
    ownerControl As TreeListBox,
    item As Object
) As String

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: String
The item's string path.
Remarks
The PathBinding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.InitializeDataObjectWithDisplayName Method

PropertyGridItemAdapterInitializeDataObjectWithDisplayName Method

Initializes a IDataObject with the display name of the specified IDataModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool InitializeDataObjectWithDisplayName(
    PropertyGrid sourceControl,
    IDataObject dataObject,
    IDataModel model
)
Public Overridable Function InitializeDataObjectWithDisplayName (
    sourceControl As PropertyGrid,
    dataObject As IDataObject,
    model As IDataModel
) As Boolean

Parameters

sourceControl
Type: ActiproSoftware.Windows.Controls.GridsPropertyGrid
The source control that contains the IDataModel.
dataObject
Type: System.WindowsIDataObject
The IDataObject to initialize.
model
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataModel
The IDataModel to examine.

Return Value

Type: Boolean
true if the IDataObject was initialized; otherwise, false.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.InitializeDataObjectWithPropertyValue Method

PropertyGridItemAdapterInitializeDataObjectWithPropertyValue Method

Initializes a IDataObject with the value of the specified IPropertyModel.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool InitializeDataObjectWithPropertyValue(
    PropertyGrid sourceControl,
    IDataObject dataObject,
    IPropertyModel propertyModel
)
Public Overridable Function InitializeDataObjectWithPropertyValue (
    sourceControl As PropertyGrid,
    dataObject As IDataObject,
    propertyModel As IPropertyModel
) As Boolean

Parameters

sourceControl
Type: ActiproSoftware.Windows.Controls.GridsPropertyGrid
The source control that contains the IPropertyModel.
dataObject
Type: System.WindowsIDataObject
The IDataObject to initialize.
propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.

Return Value

Type: Boolean
true if the IDataObject was initialized; otherwise, false.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.SetIsExpanded Method

PropertyGridItemAdapterSetIsExpanded Method

Sets whether the specified item is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void SetIsExpanded(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overrides Sub SetIsExpanded (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.SetIsSelected Method

PropertyGridItemAdapterSetIsSelected Method

Sets whether the specified item is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void SetIsSelected(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overrides Sub SetIsSelected (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemAdapter.SetPropertyValueFromDataObject Method

PropertyGridItemAdapterSetPropertyValueFromDataObject Method

Sets the value of the specified IPropertyModel from data in a IDataObject.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool SetPropertyValueFromDataObject(
    PropertyGrid sourceControl,
    IDataObject dataObject,
    IPropertyModel propertyModel
)
Public Overridable Function SetPropertyValueFromDataObject (
    sourceControl As PropertyGrid,
    dataObject As IDataObject,
    propertyModel As IPropertyModel
) As Boolean

Parameters

sourceControl
Type: ActiproSoftware.Windows.Controls.GridsPropertyGrid
The source control that contains the IPropertyModel.
dataObject
Type: System.WindowsIDataObject
The IDataObject to examine.
propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel whose value will be set.

Return Value

Type: Boolean
true if the IPropertyModel value was updated; otherwise, false.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemStyleSelector Class

Chooses a Style based on the data object and the data-bound element.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsStyleSelector
ActiproSoftware.Windows.Controls.GridsPropertyGridItemStyleSelector

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItemStyleSelector : StyleSelector
Public Class PropertyGridItemStyleSelector
    Inherits StyleSelector

The PropertyGridItemStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemStyleSelector | Initializes a new instance of the PropertyGridItemStyleSelector class
Top
Properties
 | Name | Description
Public property | CategoryEditorStyle | Gets or sets the Style to use for category editors.
Public property | CategoryStyle | Gets or sets the Style to use for categories.
Public property | PropertyStyle | Gets or sets the Style to use for properties.
Top
Methods
 | Name | Description
Public method | SelectStyle | Returns a Style based on custom logic. (Overrides StyleSelectorSelectStyle(Object, DependencyObject).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemStyleSelector Constructor

Initializes a new instance of the PropertyGridItemStyleSelector class

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItemStyleSelector()
Public Sub New
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemStyleSelector Properties

The PropertyGridItemStyleSelector type exposes the following members.

Properties
 | Name | Description
Public property | CategoryEditorStyle | Gets or sets the Style to use for category editors.
Public property | CategoryStyle | Gets or sets the Style to use for categories.
Public property | PropertyStyle | Gets or sets the Style to use for properties.
Top
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemStyleSelector.CategoryEditorStyle Property

PropertyGridItemStyleSelectorCategoryEditorStyle Property

Gets or sets the Style to use for category editors.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style CategoryEditorStyle { get; set; }
Public Property CategoryEditorStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for category editors.
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemStyleSelector.CategoryStyle Property

PropertyGridItemStyleSelectorCategoryStyle Property

Gets or sets the Style to use for categories.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style CategoryStyle { get; set; }
Public Property CategoryStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for categories.
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemStyleSelector.PropertyStyle Property

PropertyGridItemStyleSelectorPropertyStyle Property

Gets or sets the Style to use for properties.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style PropertyStyle { get; set; }
Public Property PropertyStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for properties.
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemStyleSelector Methods

The PropertyGridItemStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectStyle | Returns a Style based on custom logic. (Overrides StyleSelectorSelectStyle(Object, DependencyObject).)
Top
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemStyleSelector.SelectStyle Method

PropertyGridItemStyleSelectorSelectStyle Method

Returns a Style based on custom logic.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectStyle(
    Object item,
    DependencyObject container
)
Public Overrides Function SelectStyle (
    item As Object,
    container As DependencyObject
) As Style

Parameters

item
Type: SystemObject
The data object.
container
Type: System.WindowsDependencyObject
The data-bound element.

Return Value

Type: Style
The Style to use.
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemTemplateSelector Class

Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGridItem.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsDataTemplateSelector
ActiproSoftware.Windows.Controls.GridsPropertyGridItemTemplateSelector

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItemTemplateSelector : DataTemplateSelector
Public Class PropertyGridItemTemplateSelector
    Inherits DataTemplateSelector

The PropertyGridItemTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemTemplateSelector | Initializes a new instance of the PropertyGridItemTemplateSelector class
Top
Methods
 | Name | Description
Public method | SelectTemplate | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemTemplateSelector Constructor

Initializes a new instance of the PropertyGridItemTemplateSelector class

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItemTemplateSelector()
Public Sub New
See Also

Reference

PropertyGridItemTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemTemplateSelector Methods

The PropertyGridItemTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectTemplate | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Top
See Also

Reference

PropertyGridItemTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridItemTemplateSelector.SelectTemplate Method

PropertyGridItemTemplateSelectorSelectTemplate Method

Returns a DataTemplate based on custom logic.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Public Overrides Function SelectTemplate (
    item As Object,
    container As DependencyObject
) As DataTemplate

Parameters

item
Type: SystemObject
The data object.
container
Type: System.WindowsDependencyObject
The data-bound element.

Return Value

Type: DataTemplate
The DataTemplate to use.
See Also

Reference

PropertyGridItemTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridNameTemplateSelector Class

Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGrid name cell.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsDataTemplateSelector
ActiproSoftware.Windows.Controls.GridsPropertyGridNameTemplateSelector

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridNameTemplateSelector : DataTemplateSelector
Public Class PropertyGridNameTemplateSelector
    Inherits DataTemplateSelector

The PropertyGridNameTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridNameTemplateSelector | Initializes a new instance of the PropertyGridNameTemplateSelector class
Top
Methods
 | Name | Description
Public method | SelectTemplate | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridNameTemplateSelector Constructor

Initializes a new instance of the PropertyGridNameTemplateSelector class

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridNameTemplateSelector()
Public Sub New
See Also

Reference

PropertyGridNameTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridNameTemplateSelector Methods

The PropertyGridNameTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectTemplate | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Top
See Also

Reference

PropertyGridNameTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridNameTemplateSelector.SelectTemplate Method

PropertyGridNameTemplateSelectorSelectTemplate Method

Returns a DataTemplate based on custom logic.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Public Overrides Function SelectTemplate (
    item As Object,
    container As DependencyObject
) As DataTemplate

Parameters

item
Type: SystemObject
The data object.
container
Type: System.WindowsDependencyObject
The data-bound element.

Return Value

Type: DataTemplate
The DataTemplate to use.
See Also

Reference

PropertyGridNameTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridValueTemplateSelector Class

Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGrid value cell.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsDataTemplateSelector
ActiproSoftware.Windows.Controls.GridsPropertyGridValueTemplateSelector

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridValueTemplateSelector : DataTemplateSelector
Public Class PropertyGridValueTemplateSelector
    Inherits DataTemplateSelector

The PropertyGridValueTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridValueTemplateSelector | Initializes a new instance of the PropertyGridValueTemplateSelector class
Top
Methods
 | Name | Description
Protected method | GetDefaultTemplate | Returns a default DataTemplate from the specified PropertyGrid.
Public method | SelectTemplate | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridValueTemplateSelector Constructor

Initializes a new instance of the PropertyGridValueTemplateSelector class

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridValueTemplateSelector()
Public Sub New
See Also

Reference

PropertyGridValueTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridValueTemplateSelector Methods

The PropertyGridValueTemplateSelector type exposes the following members.

Methods
 | Name | Description
Protected method | GetDefaultTemplate | Returns a default DataTemplate from the specified PropertyGrid.
Public method | SelectTemplate | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Top
See Also

Reference

PropertyGridValueTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridValueTemplateSelector.GetDefaultTemplate Method

PropertyGridValueTemplateSelectorGetDefaultTemplate Method

Returns a default DataTemplate from the specified PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DataTemplate GetDefaultTemplate(
    PropertyGrid propGrid,
    DefaultValueTemplateKind kind
)
Protected Function GetDefaultTemplate (
    propGrid As PropertyGrid,
    kind As DefaultValueTemplateKind
) As DataTemplate

Parameters

propGrid
Type: ActiproSoftware.Windows.Controls.GridsPropertyGrid
The PropertyGrid to examine.
kind
Type: ActiproSoftware.Windows.Controls.Grids.PropertyEditorsDefaultValueTemplateKind
The kind of default template to return.

Return Value

Type: DataTemplate
A default DataTemplate from the specified PropertyGrid.
See Also

Reference

PropertyGridValueTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyGridValueTemplateSelector.SelectTemplate Method

PropertyGridValueTemplateSelectorSelectTemplate Method

Returns a DataTemplate based on custom logic.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Public Overrides Function SelectTemplate (
    item As Object,
    container As DependencyObject
) As DataTemplate

Parameters

item
Type: SystemObject
The data object.
container
Type: System.WindowsDependencyObject
The data-bound element.

Return Value

Type: DataTemplate
The DataTemplate to use.
See Also

Reference

PropertyGridValueTemplateSelector Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Class

Provides event arguments for IPropertyModel child change events, such as when a child item is added to or removed from a collection.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyModelChildChangeEventArgs : CancelRoutedEventArgs
Public Class PropertyModelChildChangeEventArgs
    Inherits CancelRoutedEventArgs

The PropertyModelChildChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelChildChangeEventArgs(IPropertyModel, IPropertyModel) | Initializes a new instance of the PropertyModelChildChangeEventArgs class.
Public method | PropertyModelChildChangeEventArgs(IPropertyModel, Object) | Initializes a new instance of the PropertyModelChildChangeEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | ChildPropertyModel | Gets the IPropertyModel for the child being added to or removed from the parent, if known.
Public property | ChildValue | Gets or sets the child value.
Public property | ParentPropertyModel | Gets the IPropertyModel for the parent.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Constructor

Overload List
 | Name | Description
Public method | PropertyModelChildChangeEventArgs(IPropertyModel, IPropertyModel) | Initializes a new instance of the PropertyModelChildChangeEventArgs class.
Public method | PropertyModelChildChangeEventArgs(IPropertyModel, Object) | Initializes a new instance of the PropertyModelChildChangeEventArgs class.
Top
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Constructor (IPropertyModel, IPropertyModel)

Initializes a new instance of the PropertyModelChildChangeEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModelChildChangeEventArgs(
    IPropertyModel parentPropertyModel,
    IPropertyModel childPropertyModel
)
Public Sub New (
    parentPropertyModel As IPropertyModel,
    childPropertyModel As IPropertyModel
)

Parameters

parentPropertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel for the parent.
childPropertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel for the child being added to or removed from the parent, if known.
See Also

Reference

PropertyModelChildChangeEventArgs Class
PropertyModelChildChangeEventArgs Overload
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Constructor (IPropertyModel, Object)

Initializes a new instance of the PropertyModelChildChangeEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModelChildChangeEventArgs(
    IPropertyModel parentPropertyModel,
    Object childValue
)
Public Sub New (
    parentPropertyModel As IPropertyModel,
    childValue As Object
)

Parameters

parentPropertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel for the parent.
childValue
Type: SystemObject
The child value.
See Also

Reference

PropertyModelChildChangeEventArgs Class
PropertyModelChildChangeEventArgs Overload
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Properties

The PropertyModelChildChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | ChildPropertyModel | Gets the IPropertyModel for the child being added to or removed from the parent, if known.
Public property | ChildValue | Gets or sets the child value.
Public property | ParentPropertyModel | Gets the IPropertyModel for the parent.
Top
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelChildChangeEventArgs.ChildPropertyModel Property

PropertyModelChildChangeEventArgsChildPropertyModel Property

Gets the IPropertyModel for the child being added to or removed from the parent, if known.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IPropertyModel ChildPropertyModel { get; }
Public ReadOnly Property ChildPropertyModel As IPropertyModel
    Get

Property Value

Type: IPropertyModel
The IPropertyModel for the child being added to or removed from the parent, if known.
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelChildChangeEventArgs.ChildValue Property

PropertyModelChildChangeEventArgsChildValue Property

Gets or sets the child value.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ChildValue { get; set; }
Public Property ChildValue As Object
    Get
    Set

Property Value

Type: Object
The child value.
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelChildChangeEventArgs.ParentPropertyModel Property

PropertyModelChildChangeEventArgsParentPropertyModel Property

Gets the IPropertyModel for the parent.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IPropertyModel ParentPropertyModel { get; }
Public ReadOnly Property ParentPropertyModel As IPropertyModel
    Get

Property Value

Type: IPropertyModel
The IPropertyModel for the parent.
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelValueChangeEventArgs Class

Provides event arguments for IPropertyModel value change events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.GridsPropertyModelValueChangeEventArgs

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyModelValueChangeEventArgs : CancelRoutedEventArgs
Public Class PropertyModelValueChangeEventArgs
    Inherits CancelRoutedEventArgs

The PropertyModelValueChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelValueChangeEventArgs | Initializes a new instance of the PropertyModelValueChangeEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | PropertyModel | Gets the IPropertyModel for the property whose value is being updated.
Public property | Value | Gets the updated property value.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelValueChangeEventArgs Constructor

Initializes a new instance of the PropertyModelValueChangeEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModelValueChangeEventArgs(
    IPropertyModel propertyModel,
    Object value
)
Public Sub New (
    propertyModel As IPropertyModel,
    value As Object
)

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel for the property whose value is being updated.
value
Type: SystemObject
The updated property value.
See Also

Reference

PropertyModelValueChangeEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelValueChangeEventArgs Properties

The PropertyModelValueChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | PropertyModel | Gets the IPropertyModel for the property whose value is being updated.
Public property | Value | Gets the updated property value.
Top
See Also

Reference

PropertyModelValueChangeEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelValueChangeEventArgs.PropertyModel Property

PropertyModelValueChangeEventArgsPropertyModel Property

Gets the IPropertyModel for the property whose value is being updated.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IPropertyModel PropertyModel { get; }
Public ReadOnly Property PropertyModel As IPropertyModel
    Get

Property Value

Type: IPropertyModel
The IPropertyModel for the property whose value is being updated.
See Also

Reference

PropertyModelValueChangeEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


PropertyModelValueChangeEventArgs.Value Property

PropertyModelValueChangeEventArgsValue Property

Gets the updated property value.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get

Property Value

Type: Object
The updated property value.
See Also

Reference

PropertyModelValueChangeEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeExpansionKind Enumeration

Specifies the kind of expand or collapse.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TreeExpansionKind
Public Enumeration TreeExpansionKind
Members
Member name | Value | Description
Single | 0 | A single item is affected.
Branch | 1 | A branch of items are recursively affected.
All | 2 | All items are recursively affected.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeItemChildrenQueryMode Enumeration

Specifies the mode by which a tree item's children are queried.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TreeItemChildrenQueryMode
Public Enumeration TreeItemChildrenQueryMode
Members
Member name | Value | Description
OnDisplay | 0 | Query the item's children when all of the item's ancestors are expanded. The item is only expandable if there is at least one child item.
OnExpansion | 1 | The item is only expandable by default. When the item is expanded, query the item's children, and disable expandability if there are no child items.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeItemDropArea Enumeration

Specifies a drop area when a drag is over a target item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TreeItemDropArea
Public Enumeration TreeItemDropArea
Members
Member name | Value | Description
None | 0 | The drag is not over a target item.
Before | 1 | The drag is over the top portion of the target item, hinting to to insert before the target item.
On | 2 | The drag is directly over the target item, hinting to insert into the target item.
After | 3 | The drag is over the bottom portion of the target item, hinting to to insert after the target item.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeItemExpandability Enumeration

Specifies a tree item's support for expansion toggling.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TreeItemExpandability
Public Enumeration TreeItemExpandability
Members
Member name | Value | Description
Auto | 0 | Logic is used to determine whether the item supports expansion toggling.
Never | 1 | The item doesn't support expansion toggling.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox Class

Represents an advanced single-column tree view control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
ActiproSoftware.Windows.Controls.GridsTreeListBox
ActiproSoftware.Windows.Controls.GridsTreeListView
ActiproSoftware.Windows.Controls.ShellShellTreeListBox

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListBox : ItemsControl
Public Class TreeListBox
    Inherits ItemsControl

The TreeListBox type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBox | Initializes an instance of the TreeListBox class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Protected property | AssemblyInfo | Gets the AssemblyInfo to use.
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items.
Protected property | CanExpandAll | Gets whether any expand all operations can occur.
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmptyContent | Gets or sets the content to display when there are no items visible in the control.
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no items visible in the control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level.
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled.
Public property | IsEmpty | Gets whether the control is currently empty (doesn't contain any visible items).
Public property | IsFilterActive | Gets or sets whether a filter is currently active.
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Protected property | IsKeyboardFocusWithinContent | Gets whether keyboard focus is within the content area, and not in any header area.
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc.
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved.
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses.
Public property | RootItem | Gets or sets the root item to display in the control.
Public property | SelectedItem | Gets or sets the primary selected item.
Public property | SelectedItems | Gets the collection of selected items.
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BringItemIntoView | Brings the specified node's container into view.
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | CollapseAll | Collapses all known tree items.
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | CreateSelectionBatch | Creates an IDisposable object that wraps a batch of selection updates, and allows them to be made without raising selection-related events in between each one.
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | ExpandAll | Expands all known tree items.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed.
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed.
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetFullPath | Returns the full path of the specified item.
 | GetIsSelectionActive | Gets the value of the IsSelectionActive attached property for the specified object.
Public method | GetItemByFullPath | Returns the item with the specified full path.
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item.
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Overrides UIElementOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Overrides UIElementOnDragLeave(DragEventArgs).)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Overrides UIElementOnDragOver(DragEventArgs).)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Overrides UIElementOnDrop(DragEventArgs).)
Protected method | OnGotKeyboardFocus | Occurs when the control gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnIsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed.
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed.
Protected method | OnItemCollapsing | Occurs before an item is collapsed.
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item.
Protected method | OnItemExpanded | Occurs after an item is expanded.
Protected method | OnItemExpanding | Occurs before an item is expanded.
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu.
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected.
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource property is changed. (Overrides ItemsControlOnItemsSourceChanged(IEnumerable, IEnumerable).)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ItemsControlOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs after the RootItem property is changed.
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed.
Protected method | OnSelectionChanged | Occurs when the selection is changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | ProcessKeyDown | Processes a key down event.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path.
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | IsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed.
Public event | ItemCollapsed | Occurs after an item is collapsed.
Public event | ItemCollapsing | Occurs before an item is collapsed.
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item.
Public event | ItemExpanded | Occurs after an item is expanded.
Public event | ItemExpanding | Occurs before an item is expanded.
Public event | ItemMenuRequested | Occurs when an item requests a context menu.
Public event | ItemSelecting | Occurs before an item is selected.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | RootItemChanged | Occurs after the RootItem property is changed.
Public event | SelectionChanged | Occurs when the selection is changed.
Top
Fields
Name | Description
AutoExpandItemsOnFilterProperty | Identifies the AutoExpandItemsOnFilter dependency property. This field is read-only.
CanDragItemsProperty | Identifies the CanDragItems dependency property. This field is read-only.
DataFilterProperty | Identifies the DataFilter dependency property. This field is read-only.
EmptyContentProperty | Identifies the EmptyContent dependency property. This field is read-only.
EmptyContentTemplateProperty | Identifies the EmptyContentTemplate dependency property. This field is read-only.
IndentIncrementProperty | Identifies the IndentIncrement dependency property. This field is read-only.
IsDataVirtualizationEnabledProperty | Identifies the IsDataVirtualizationEnabled dependency property. This field is read-only.
IsEmptyProperty | Identifies the IsEmpty dependency property. This field is read-only.
IsFilterActiveProperty | Identifies the IsFilterActive dependency property. This field is read-only.
IsRootItemVisibleChangedEvent | Identifies the IsRootItemVisibleChanged routed event. This field is read-only.
IsRootItemVisibleProperty | Identifies the IsRootItemVisible dependency property. This field is read-only.
IsSelectionActiveProperty | Identifies the IsSelectionActive dependency property. This field is read-only.
ItemAdapterProperty | Identifies the ItemAdapter dependency property. This field is read-only.
ItemCollapsedEvent | Identifies the ItemCollapsed routed event. This field is read-only.
ItemCollapsingEvent | Identifies the ItemCollapsing routed event. This field is read-only.
ItemDataFormat | Specifies the data format to use for item data.
ItemDefaultActionExecutingEvent | Identifies the ItemDefaultActionExecuting routed event. This field is read-only.
ItemExpandedEvent | Identifies the ItemExpanded routed event. This field is read-only.
ItemExpandingEvent | Identifies the ItemExpanding routed event. This field is read-only.
ItemMenuRequestedEvent | Identifies the ItemMenuRequested routed event. This field is read-only.
ItemSelectingEvent | Identifies the ItemSelecting routed event. This field is read-only.
MultiDragKindProperty | Identifies the MultiDragKind dependency property. This field is read-only.
MultiSelectionKindProperty | Identifies the MultiSelectionKind dependency property. This field is read-only.
PathSeparatorProperty | Identifies the PathSeparator dependency property. This field is read-only.
RootItemChangedEvent | Identifies the RootItemChanged routed event. This field is read-only.
RootItemProperty | Identifies the RootItem dependency property. This field is read-only.
SelectedItemProperty | Identifies the SelectedItem dependency property. This field is read-only.
SelectionChangedEvent | Identifies the SelectionChanged routed event. This field is read-only.
SelectionModeProperty | Identifies the SelectionMode dependency property. This field is read-only.
TopLevelIndentProperty | Identifies the TopLevelIndent dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | IsSelectionActive |
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox Constructor

Initializes an instance of the TreeListBox class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBox()
Public Sub New
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox Properties

The TreeListBox type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Protected property | AssemblyInfo | Gets the AssemblyInfo to use.
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items.
Protected property | CanExpandAll | Gets whether any expand all operations can occur.
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmptyContent | Gets or sets the content to display when there are no items visible in the control.
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no items visible in the control.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level.
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled.
Public property | IsEmpty | Gets whether the control is currently empty (doesn't contain any visible items).
Public property | IsFilterActive | Gets or sets whether a filter is currently active.
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Protected property | IsKeyboardFocusWithinContent | Gets whether keyboard focus is within the content area, and not in any header area.
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc.
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved.
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses.
Public property | RootItem | Gets or sets the root item to display in the control.
Public property | SelectedItem | Gets or sets the primary selected item.
Public property | SelectedItems | Gets the collection of selected items.
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.AssemblyInfo Property

TreeListBoxAssemblyInfo Property

Gets the AssemblyInfo to use.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual AssemblyInfo AssemblyInfo { get; }
Protected Overridable ReadOnly Property AssemblyInfo As AssemblyInfo
    Get

Property Value

Type: AssemblyInfo
The AssemblyInfo to use.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.AutoExpandItemsOnFilter Property

TreeListBoxAutoExpandItemsOnFilter Property

Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AutoExpandItemsOnFilter { get; set; }
Public Property AutoExpandItemsOnFilter As Boolean
    Get
    Set

Property Value

Type: Boolean
true if items that are included by a filter will be made visible; otherwise, false. The default value is false.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.CanDragItems Property

TreeListBoxCanDragItems Property

Gets or sets whether to allow dragging of selected items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanDragItems { get; set; }
Public Property CanDragItems As Boolean
    Get
    Set

Property Value

Type: Boolean
true if dragging of selected items is allowed; otherwise, false.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.CanExpandAll Property

TreeListBoxCanExpandAll Property

Gets whether any expand all operations can occur.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool CanExpandAll { get; }
Protected Overridable ReadOnly Property CanExpandAll As Boolean
    Get

Property Value

Type: Boolean
true if any expand all operations can occur; otherwise, false. The default value is true.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.DataFilter Property

TreeListBoxDataFilter Property

Gets or sets the IDataFilter to use when IsFilterActive is true.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDataFilter DataFilter { get; set; }
Public Property DataFilter As IDataFilter
    Get
    Set

Property Value

Type: IDataFilter
The IDataFilter to use when IsFilterActive is true.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.EmptyContent Property

TreeListBoxEmptyContent Property

Gets or sets the content to display when there are no items visible in the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object EmptyContent { get; set; }
Public Property EmptyContent As Object
    Get
    Set

Property Value

Type: Object
The content to display when there are no items visible in the control.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.EmptyContentTemplate Property

TreeListBoxEmptyContentTemplate Property

Gets or sets the DataTemplate to display when there are no items visible in the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate EmptyContentTemplate { get; set; }
Public Property EmptyContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to display when there are no items visible in the control.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IndentIncrement Property

TreeListBoxIndentIncrement Property

Gets or sets the incremental amount by which to indent an item for each depth level.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double IndentIncrement { get; set; }
Public Property IndentIncrement As Double
    Get
    Set

Property Value

Type: Double
The incremental amount by which to indent an item for each depth level. The default value is 20.0.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsDataVirtualizationEnabled Property

TreeListBoxIsDataVirtualizationEnabled Property

Gets or sets whether data virtualization is enabled.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDataVirtualizationEnabled { get; set; }
Public Property IsDataVirtualizationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if data virtualization is enabled; otherwise, false. The default value is false.
Remarks
Only set this property to true when using virtualized collections that implement IList. In most scenarios, this data virtualization feature is not needed since UI virtualization is always active in the control.

When the data virtualization feature is enabled, as a query for child items is made, an ITreeItemVirtualPlaceholder will be created for each child item. The only property initially touched on the virtualized collection is Count. Then when an item's UI container is first requested, the ITreeItemVirtualPlaceholder will be used to call into the virtualized collection's indexer and retrieve the real item. This allows for virtualized data retrieval of paged sections as needed, instead of the entire collection at once.

See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsEmpty Property

TreeListBoxIsEmpty Property

Gets whether the control is currently empty (doesn't contain any visible items).

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the control is currently empty (doesn't contain any visible items); otherwise, false. The default value is true.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsFilterActive Property

TreeListBoxIsFilterActive Property

Gets or sets whether a filter is currently active.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsFilterActive { get; set; }
Public Property IsFilterActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a filter is currently active; otherwise, false. The default value is false.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsKeyboardFocusWithinContent Property

TreeListBoxIsKeyboardFocusWithinContent Property

Gets whether keyboard focus is within the content area, and not in any header area.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsKeyboardFocusWithinContent { get; }
Protected Overridable ReadOnly Property IsKeyboardFocusWithinContent As Boolean
    Get

Property Value

Type: Boolean
true if keyboard focus is within the content area; otherwise, false.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsRootItemVisible Property

TreeListBoxIsRootItemVisible Property

Gets or sets whether the RootItem is visible, or whether its children are the top-level node items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsRootItemVisible { get; set; }
Public Property IsRootItemVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the RootItem is the sole top-level node item; otherwise, false. The default value is false.
Remarks
When true, the RootItem itself will be the sole top-level node item. When false, the RootItem's children will be the top-level node items.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemAdapter Property

TreeListBoxItemAdapter Property

Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxItemAdapter ItemAdapter { get; set; }
Public Property ItemAdapter As TreeListBoxItemAdapter
    Get
    Set

Property Value

Type: TreeListBoxItemAdapter
The TreeListBoxItemAdapter that adapts items with the UI.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.MultiDragKind Property

TreeListBoxMultiDragKind Property

Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeMultiDragKind MultiDragKind { get; set; }
Public Property MultiDragKind As TreeMultiDragKind
    Get
    Set

Property Value

Type: TreeMultiDragKind
A TreeMultiDragKind that indicates the dragging support when multiple items are involved. The default value is None, meaning only single item selections can be dragged when CanDragItems is true.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.MultiSelectionKind Property

TreeListBoxMultiSelectionKind Property

Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeMultiSelectionKind MultiSelectionKind { get; set; }
Public Property MultiSelectionKind As TreeMultiSelectionKind
    Get
    Set

Property Value

Type: TreeMultiSelectionKind
A TreeMultiSelectionKind that indicates the selection support when multiple items are involved. The default value is Any.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.PathSeparator Property

TreeListBoxPathSeparator Property

Gets or sets the delimiter string that the tree item full path uses.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string PathSeparator { get; set; }
Public Property PathSeparator As String
    Get
    Set

Property Value

Type: String
The delimiter string that the tree item full path uses. The default value is \.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.RootItem Property

TreeListBoxRootItem Property

Gets or sets the root item to display in the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object RootItem { get; set; }
Public Property RootItem As Object
    Get
    Set

Property Value

Type: Object
The root item to display in the control.
Remarks
Set this property instead of ItemsSource.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.SelectedItem Property

TreeListBoxSelectedItem Property

Gets or sets the primary selected item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object SelectedItem { get; set; }
Public Property SelectedItem As Object
    Get
    Set

Property Value

Type: Object
The primary selected item.
Remarks
This property's setter can be a bottleneck in very large trees where the specified node hasn't yet been exposed to the control by its ancestor nodes all being expanded. In that scenario, a full tree search is required to locate the node.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.SelectedItems Property

TreeListBoxSelectedItems Property

Gets the collection of selected items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ISelectedTreeItemCollection SelectedItems { get; }
Public ReadOnly Property SelectedItems As ISelectedTreeItemCollection
    Get

Property Value

Type: ISelectedTreeItemCollection
The collection of selected items.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.SelectionMode Property

TreeListBoxSelectionMode Property

Gets or sets a SelectionMode that indicates the selection behavior.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SelectionMode SelectionMode { get; set; }
Public Property SelectionMode As SelectionMode
    Get
    Set

Property Value

Type: SelectionMode
A SelectionMode that indicates the selection behavior. The default value is Single.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.TopLevelIndent Property

TreeListBoxTopLevelIndent Property

Gets or sets the amount by which to indent a top-level item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double TopLevelIndent { get; set; }
Public Property TopLevelIndent As Double
    Get
    Set

Property Value

Type: Double
The incremental amount by which to indent a top-level item. The default value is 20.0.
Remarks
When top-level items aren't expandable, set this property to 0 to reclaim the space that would have been used by the expander.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox Methods

The TreeListBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides ControlArrangeOverride(Size).)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BringItemIntoView | Brings the specified node's container into view.
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | CollapseAll | Collapses all known tree items.
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | CreateSelectionBatch | Creates an IDisposable object that wraps a batch of selection updates, and allows them to be made without raising selection-related events in between each one.
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | ExpandAll | Expands all known tree items.
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed.
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed.
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetFullPath | Returns the full path of the specified item.
 | GetIsSelectionActive | Gets the value of the IsSelectionActive attached property for the specified object.
Public method | GetItemByFullPath | Returns the item with the specified full path.
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item.
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Overrides UIElementOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Overrides UIElementOnDragLeave(DragEventArgs).)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Overrides UIElementOnDragOver(DragEventArgs).)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Overrides UIElementOnDrop(DragEventArgs).)
Protected method | OnGotKeyboardFocus | Occurs when the control gains keyboard focus. (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnIsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed.
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed.
Protected method | OnItemCollapsing | Occurs before an item is collapsed.
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item.
Protected method | OnItemExpanded | Occurs after an item is expanded.
Protected method | OnItemExpanding | Occurs before an item is expanded.
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu.
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected.
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource property is changed. (Overrides ItemsControlOnItemsSourceChanged(IEnumerable, IEnumerable).)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ItemsControlOnKeyDown(KeyEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs after the RootItem property is changed.
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed.
Protected method | OnSelectionChanged | Occurs when the selection is changed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | ProcessKeyDown | Processes a key down event.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path.
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ArrangeOverride Method

TreeListBoxArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.BringItemIntoView Method

TreeListBoxBringItemIntoView Method

Brings the specified node's container into view.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool BringItemIntoView(
    Object item
)
Public Function BringItemIntoView (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
The node whose container needs to scroll into view.

Return Value

Type: Boolean
true if the node's container was brought into view; otherwise, false.
Remarks
This method can be a bottleneck in very large trees where the specified node hasn't yet been exposed to the control by its ancestor nodes all being expanded. In that scenario, a full tree search is required to locate the node. For that case, it is recommended to use the BringItemIntoViewByFullPath(String) method that searches by full path instead, since that can be much faster.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.BringItemIntoViewByFullPath Method

TreeListBoxBringItemIntoViewByFullPath Method

Brings the container for the item with the specified full path into view.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool BringItemIntoViewByFullPath(
    string fullPath
)
Public Function BringItemIntoViewByFullPath (
    fullPath As String
) As Boolean

Parameters

fullPath
Type: SystemString
The full path to the item whose container needs to scroll into view.

Return Value

Type: Boolean
true if the item's container was brought into view; otherwise, false.
Remarks
This method requires that the ItemAdapter supplies a path for each item.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ClearContainerForItemOverride Method

TreeListBoxClearContainerForItemOverride Method

Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.CollapseAll Method

TreeListBoxCollapseAll Method

Collapses all known tree items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CollapseAll()
Public Sub CollapseAll
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.CreateSelectionBatch Method

TreeListBoxCreateSelectionBatch Method

Creates an IDisposable object that wraps a batch of selection updates, and allows them to be made without raising selection-related events in between each one.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDisposable CreateSelectionBatch()
Public Function CreateSelectionBatch As IDisposable

Return Value

Type: IDisposable
The IDisposable that was created.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ExpandAll Method

TreeListBoxExpandAll Method

Expands all known tree items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void ExpandAll()
Public Sub ExpandAll
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.FocusItem Method

TreeListBoxFocusItem Method

Focuses the container for the specified node, scrolling it into view as needed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void FocusItem(
    Object item
)
Public Sub FocusItem (
    item As Object
)

Parameters

item
Type: SystemObject
The node whose container should be focused.
Remarks
This method can be a bottleneck in very large trees where the specified node hasn't yet been exposed to the control by its ancestor nodes all being expanded. In that scenario, a full tree search is required to locate the node. For that case, it is recommended to use the FocusItemByFullPath(String) method that searches by full path instead, since that can be much faster.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.FocusItemByFullPath Method

TreeListBoxFocusItemByFullPath Method

Focuses the container for the node with the specified full path, scrolling it into view as needed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void FocusItemByFullPath(
    string fullPath
)
Public Sub FocusItemByFullPath (
    fullPath As String
)

Parameters

fullPath
Type: SystemString
The full path to the node whose container should be focused.
Remarks
This method requires that the ItemAdapter supplies a path for each item.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.GetContainerForItemOverride Method

TreeListBoxGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.GetFullPath Method

TreeListBoxGetFullPath Method

Returns the full path of the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string GetFullPath(
    Object item
)
Public Function GetFullPath (
    item As Object
) As String

Parameters

item
Type: SystemObject
The item to examine.

Return Value

Type: String
The full path of the specified item.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.GetIsSelectionActive Method

TreeListBoxGetIsSelectionActive Method

Gets the value of the IsSelectionActive attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static bool GetIsSelectionActive(
    TreeListBox obj
)
Public Shared Function GetIsSelectionActive (
    obj As TreeListBox
) As Boolean

Parameters

obj
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.GetItemByFullPath Method

TreeListBoxGetItemByFullPath Method

Returns the item with the specified full path.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object GetItemByFullPath(
    string fullPath
)
Public Function GetItemByFullPath (
    fullPath As String
) As Object

Parameters

fullPath
Type: SystemString
The full path to the item.

Return Value

Type: Object
The item with the specified full path.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.GetItemNavigator Method

TreeListBoxGetItemNavigator Method

Returns the ITreeItemNavigator for the specified item, if the item is a visible item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ITreeItemNavigator GetItemNavigator(
    Object item
)
Public Function GetItemNavigator (
    item As Object
) As ITreeItemNavigator

Parameters

item
Type: SystemObject
The visible item to examine.

Return Value

Type: ITreeItemNavigator
The ITreeItemNavigator for the specified item, if the item is a visible item.
Remarks
This navigator can be used to navigate the item tree. No navigator will be returned if the item is not a visible item in this control.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.InvalidateChildren Method

TreeListBoxInvalidateChildren Method

Invalidates the children of the specified item, allowing the children to be requeried.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void InvalidateChildren(
    Object item
)
Public Sub InvalidateChildren (
    item As Object
)

Parameters

item
Type: SystemObject
The item to examine.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsItemItsOwnContainerOverride Method

TreeListBoxIsItemItsOwnContainerOverride Method

Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnApplyTemplate Method

TreeListBoxOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnCreateAutomationPeer Method

TreeListBoxOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnDragEnter Method

TreeListBoxOnDragEnter Method

Occurs when an object is dragged inside of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragEnter(
    DragEventArgs e
)
Protected Overrides Sub OnDragEnter (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnDragLeave Method

TreeListBoxOnDragLeave Method

Occurs when an object is dragged outside of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragLeave(
    DragEventArgs e
)
Protected Overrides Sub OnDragLeave (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnDragOver Method

TreeListBoxOnDragOver Method

Occurs when an object is dragged over the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragOver(
    DragEventArgs e
)
Protected Overrides Sub OnDragOver (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnDrop Method

TreeListBoxOnDrop Method

Occurs when an object is dropped over the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDrop(
    DragEventArgs e
)
Protected Overrides Sub OnDrop (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnGotKeyboardFocus Method

TreeListBoxOnGotKeyboardFocus Method

Occurs when the control gains keyboard focus.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
Protected Overrides Sub OnGotKeyboardFocus (
    e As KeyboardFocusChangedEventArgs
)

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
The KeyboardFocusChangedEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnIsKeyboardFocusWithinChanged Method

TreeListBoxOnIsKeyboardFocusWithinChanged Method

Occurs when the property value has changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnIsRootItemVisibleChanged Method

TreeListBoxOnIsRootItemVisibleChanged Method

Occurs after the IsRootItemVisible property is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnIsRootItemVisibleChanged(
    RoutedEventArgs e
)
Protected Overridable Sub OnIsRootItemVisibleChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnItemCollapsed Method

TreeListBoxOnItemCollapsed Method

Occurs after an item is collapsed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemCollapsed(
    TreeListBoxItemExpansionEventArgs e
)
Protected Overridable Sub OnItemCollapsed (
    e As TreeListBoxItemExpansionEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItemExpansionEventArgs
The TreeListBoxItemExpansionEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnItemCollapsing Method

TreeListBoxOnItemCollapsing Method

Occurs before an item is collapsed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemCollapsing(
    TreeListBoxItemExpansionEventArgs e
)
Protected Overridable Sub OnItemCollapsing (
    e As TreeListBoxItemExpansionEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItemExpansionEventArgs
The TreeListBoxItemExpansionEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnItemDefaultActionExecuting Method

TreeListBoxOnItemDefaultActionExecuting Method

Occurs before the default action is executed for an item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemDefaultActionExecuting(
    TreeListBoxItemEventArgs e
)
Protected Overridable Sub OnItemDefaultActionExecuting (
    e As TreeListBoxItemEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItemEventArgs
The TreeListBoxItemEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnItemExpanded Method

TreeListBoxOnItemExpanded Method

Occurs after an item is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemExpanded(
    TreeListBoxItemExpansionEventArgs e
)
Protected Overridable Sub OnItemExpanded (
    e As TreeListBoxItemExpansionEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItemExpansionEventArgs
The TreeListBoxItemExpansionEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnItemExpanding Method

TreeListBoxOnItemExpanding Method

Occurs before an item is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemExpanding(
    TreeListBoxItemExpansionEventArgs e
)
Protected Overridable Sub OnItemExpanding (
    e As TreeListBoxItemExpansionEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItemExpansionEventArgs
The TreeListBoxItemExpansionEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnItemMenuRequested Method

TreeListBoxOnItemMenuRequested Method

Occurs when an item requests a context menu.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemMenuRequested(
    TreeListBoxItemMenuEventArgs e
)
Protected Overridable Sub OnItemMenuRequested (
    e As TreeListBoxItemMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItemMenuEventArgs
The TreeListBoxItemMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnItemSelecting Method

TreeListBoxOnItemSelecting Method

Occurs before an item is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemSelecting(
    TreeListBoxItemEventArgs e
)
Protected Overridable Sub OnItemSelecting (
    e As TreeListBoxItemEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItemEventArgs
The TreeListBoxItemEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnItemsSourceChanged Method

TreeListBoxOnItemsSourceChanged Method

Occurs when the ItemsSource property is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Protected Overrides Sub OnItemsSourceChanged (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
The old value.
newValue
Type: System.CollectionsIEnumerable
The new value.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnKeyDown Method

TreeListBoxOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnRootItemChanged Method

TreeListBoxOnRootItemChanged Method

Occurs after the RootItem property is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnRootItemChanged(
    RoutedEventArgs e
)
Protected Overridable Sub OnRootItemChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnScrollViewerScrollChanged Method

TreeListBoxOnScrollViewerScrollChanged Method

Occurs when the scroll viewer's scroll is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnScrollViewerScrollChanged(
    ScrollChangedEventArgs e
)
Protected Overridable Sub OnScrollViewerScrollChanged (
    e As ScrollChangedEventArgs
)

Parameters

e
Type: System.Windows.ControlsScrollChangedEventArgs
The ScrollChangedEventArgs that contains data related to the event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.OnSelectionChanged Method

TreeListBoxOnSelectionChanged Method

Occurs when the selection is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSelectionChanged(
    SelectionChangedEventArgs e
)
Protected Overridable Sub OnSelectionChanged (
    e As SelectionChangedEventArgs
)

Parameters

e
Type: System.Windows.ControlsSelectionChangedEventArgs
The SelectionChangedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.PrepareContainerForItemOverride Method

TreeListBoxPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ProcessKeyDown Method

TreeListBoxProcessKeyDown Method

Processes a key down event.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void ProcessKeyDown(
    KeyEventArgs e
)
Protected Overridable Sub ProcessKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.SelectItemByFullPath Method

TreeListBoxSelectItemByFullPath Method

Sets the SelectedItem to the node with the specified full path.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool SelectItemByFullPath(
    string fullPath
)
Public Overridable Function SelectItemByFullPath (
    fullPath As String
) As Boolean

Parameters

fullPath
Type: SystemString
The full path to the node whose container should be selected.

Return Value

Type: Boolean
true if a node was selected; otherwise, false.
Remarks
This method requires that the ItemAdapter supplies a path for each item.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox Events

The TreeListBox type exposes the following members.

Events
 | Name | Description
Public event | IsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed.
Public event | ItemCollapsed | Occurs after an item is collapsed.
Public event | ItemCollapsing | Occurs before an item is collapsed.
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item.
Public event | ItemExpanded | Occurs after an item is expanded.
Public event | ItemExpanding | Occurs before an item is expanded.
Public event | ItemMenuRequested | Occurs when an item requests a context menu.
Public event | ItemSelecting | Occurs before an item is selected.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | RootItemChanged | Occurs after the RootItem property is changed.
Public event | SelectionChanged | Occurs when the selection is changed.
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsRootItemVisibleChanged Event

TreeListBoxIsRootItemVisibleChanged Event

Occurs after the IsRootItemVisible property is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler IsRootItemVisibleChanged
Public Event IsRootItemVisibleChanged As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemCollapsed Event

TreeListBoxItemCollapsed Event

Occurs after an item is collapsed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemExpansionEventArgs> ItemCollapsed
Public Event ItemCollapsed As EventHandler(Of TreeListBoxItemExpansionEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemExpansionEventArgs
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemCollapsing Event

TreeListBoxItemCollapsing Event

Occurs before an item is collapsed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemExpansionEventArgs> ItemCollapsing
Public Event ItemCollapsing As EventHandler(Of TreeListBoxItemExpansionEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemExpansionEventArgs
Remarks
Set the event argument's Cancel property to true to prevent the collapse.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemDefaultActionExecuting Event

TreeListBoxItemDefaultActionExecuting Event

Occurs before the default action is executed for an item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemEventArgs> ItemDefaultActionExecuting
Public Event ItemDefaultActionExecuting As EventHandler(Of TreeListBoxItemEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemEventArgs
Remarks
Set the event argument's Cancel property to true to prevent a default action from executing, which could be executing a DefaultActionCommand or toggling the item's expansion.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemExpanded Event

TreeListBoxItemExpanded Event

Occurs after an item is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemExpansionEventArgs> ItemExpanded
Public Event ItemExpanded As EventHandler(Of TreeListBoxItemExpansionEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemExpansionEventArgs
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemExpanding Event

TreeListBoxItemExpanding Event

Occurs before an item is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemExpansionEventArgs> ItemExpanding
Public Event ItemExpanding As EventHandler(Of TreeListBoxItemExpansionEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemExpansionEventArgs
Remarks
Set the event argument's Cancel property to true to prevent the expansion.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemMenuRequested Event

TreeListBoxItemMenuRequested Event

Occurs when an item requests a context menu.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemMenuEventArgs> ItemMenuRequested
Public Event ItemMenuRequested As EventHandler(Of TreeListBoxItemMenuEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemMenuEventArgs
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemSelecting Event

TreeListBoxItemSelecting Event

Occurs before an item is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemEventArgs> ItemSelecting
Public Event ItemSelecting As EventHandler(Of TreeListBoxItemEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemEventArgs
Remarks
Set the event argument's Cancel property to true to prevent the selection.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.RootItemChanged Event

TreeListBoxRootItemChanged Event

Occurs after the RootItem property is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler RootItemChanged
Public Event RootItemChanged As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.SelectionChanged Event

TreeListBoxSelectionChanged Event

Occurs when the selection is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event SelectionChangedEventHandler SelectionChanged
Public Event SelectionChanged As SelectionChangedEventHandler

Value

Type: System.Windows.ControlsSelectionChangedEventHandler
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox Fields

The TreeListBox type exposes the following members.

Fields
Name | Description
AutoExpandItemsOnFilterProperty | Identifies the AutoExpandItemsOnFilter dependency property. This field is read-only.
CanDragItemsProperty | Identifies the CanDragItems dependency property. This field is read-only.
DataFilterProperty | Identifies the DataFilter dependency property. This field is read-only.
EmptyContentProperty | Identifies the EmptyContent dependency property. This field is read-only.
EmptyContentTemplateProperty | Identifies the EmptyContentTemplate dependency property. This field is read-only.
IndentIncrementProperty | Identifies the IndentIncrement dependency property. This field is read-only.
IsDataVirtualizationEnabledProperty | Identifies the IsDataVirtualizationEnabled dependency property. This field is read-only.
IsEmptyProperty | Identifies the IsEmpty dependency property. This field is read-only.
IsFilterActiveProperty | Identifies the IsFilterActive dependency property. This field is read-only.
IsRootItemVisibleChangedEvent | Identifies the IsRootItemVisibleChanged routed event. This field is read-only.
IsRootItemVisibleProperty | Identifies the IsRootItemVisible dependency property. This field is read-only.
IsSelectionActiveProperty | Identifies the IsSelectionActive dependency property. This field is read-only.
ItemAdapterProperty | Identifies the ItemAdapter dependency property. This field is read-only.
ItemCollapsedEvent | Identifies the ItemCollapsed routed event. This field is read-only.
ItemCollapsingEvent | Identifies the ItemCollapsing routed event. This field is read-only.
ItemDataFormat | Specifies the data format to use for item data.
ItemDefaultActionExecutingEvent | Identifies the ItemDefaultActionExecuting routed event. This field is read-only.
ItemExpandedEvent | Identifies the ItemExpanded routed event. This field is read-only.
ItemExpandingEvent | Identifies the ItemExpanding routed event. This field is read-only.
ItemMenuRequestedEvent | Identifies the ItemMenuRequested routed event. This field is read-only.
ItemSelectingEvent | Identifies the ItemSelecting routed event. This field is read-only.
MultiDragKindProperty | Identifies the MultiDragKind dependency property. This field is read-only.
MultiSelectionKindProperty | Identifies the MultiSelectionKind dependency property. This field is read-only.
PathSeparatorProperty | Identifies the PathSeparator dependency property. This field is read-only.
RootItemChangedEvent | Identifies the RootItemChanged routed event. This field is read-only.
RootItemProperty | Identifies the RootItem dependency property. This field is read-only.
SelectedItemProperty | Identifies the SelectedItem dependency property. This field is read-only.
SelectionChangedEvent | Identifies the SelectionChanged routed event. This field is read-only.
SelectionModeProperty | Identifies the SelectionMode dependency property. This field is read-only.
TopLevelIndentProperty | Identifies the TopLevelIndent dependency property. This field is read-only.
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.AutoExpandItemsOnFilterProperty Field

TreeListBoxAutoExpandItemsOnFilterProperty Field

Identifies the AutoExpandItemsOnFilter dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoExpandItemsOnFilterProperty
Public Shared ReadOnly AutoExpandItemsOnFilterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoExpandItemsOnFilter dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.CanDragItemsProperty Field

TreeListBoxCanDragItemsProperty Field

Identifies the CanDragItems dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragItemsProperty
Public Shared ReadOnly CanDragItemsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragItems dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.DataFilterProperty Field

TreeListBoxDataFilterProperty Field

Identifies the DataFilter dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataFilterProperty
Public Shared ReadOnly DataFilterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DataFilter dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.EmptyContentProperty Field

TreeListBoxEmptyContentProperty Field

Identifies the EmptyContent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmptyContentProperty
Public Shared ReadOnly EmptyContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmptyContent dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.EmptyContentTemplateProperty Field

TreeListBoxEmptyContentTemplateProperty Field

Identifies the EmptyContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmptyContentTemplateProperty
Public Shared ReadOnly EmptyContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmptyContentTemplate dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IndentIncrementProperty Field

TreeListBoxIndentIncrementProperty Field

Identifies the IndentIncrement dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndentIncrementProperty
Public Shared ReadOnly IndentIncrementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IndentIncrement dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsDataVirtualizationEnabledProperty Field

TreeListBoxIsDataVirtualizationEnabledProperty Field

Identifies the IsDataVirtualizationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDataVirtualizationEnabledProperty
Public Shared ReadOnly IsDataVirtualizationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDataVirtualizationEnabled dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsEmptyProperty Field

TreeListBoxIsEmptyProperty Field

Identifies the IsEmpty dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEmptyProperty
Public Shared ReadOnly IsEmptyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEmpty dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsFilterActiveProperty Field

TreeListBoxIsFilterActiveProperty Field

Identifies the IsFilterActive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFilterActiveProperty
Public Shared ReadOnly IsFilterActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFilterActive dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsRootItemVisibleChangedEvent Field

TreeListBoxIsRootItemVisibleChangedEvent Field

Identifies the IsRootItemVisibleChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent IsRootItemVisibleChangedEvent
Public Shared ReadOnly IsRootItemVisibleChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the IsRootItemVisibleChanged routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsRootItemVisibleProperty Field

TreeListBoxIsRootItemVisibleProperty Field

Identifies the IsRootItemVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRootItemVisibleProperty
Public Shared ReadOnly IsRootItemVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRootItemVisible dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsSelectionActiveProperty Field

TreeListBoxIsSelectionActiveProperty Field

Identifies the IsSelectionActive dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectionActiveProperty
Public Shared ReadOnly IsSelectionActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelectionActive dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemAdapterProperty Field

TreeListBoxItemAdapterProperty Field

Identifies the ItemAdapter dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemAdapterProperty
Public Shared ReadOnly ItemAdapterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemAdapter dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemCollapsedEvent Field

TreeListBoxItemCollapsedEvent Field

Identifies the ItemCollapsed routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ItemCollapsedEvent
Public Shared ReadOnly ItemCollapsedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ItemCollapsed routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemCollapsingEvent Field

TreeListBoxItemCollapsingEvent Field

Identifies the ItemCollapsing routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ItemCollapsingEvent
Public Shared ReadOnly ItemCollapsingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ItemCollapsing routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemDataFormat Field

TreeListBoxItemDataFormat Field

Specifies the data format to use for item data.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public const string ItemDataFormat = "ActiproSoftware.TreeListBox.Items"
Public Const ItemDataFormat As String = "ActiproSoftware.TreeListBox.Items"

Field Value

Type: String
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemDefaultActionExecutingEvent Field

TreeListBoxItemDefaultActionExecutingEvent Field

Identifies the ItemDefaultActionExecuting routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ItemDefaultActionExecutingEvent
Public Shared ReadOnly ItemDefaultActionExecutingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ItemDefaultActionExecuting routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemExpandedEvent Field

TreeListBoxItemExpandedEvent Field

Identifies the ItemExpanded routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ItemExpandedEvent
Public Shared ReadOnly ItemExpandedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ItemExpanded routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemExpandingEvent Field

TreeListBoxItemExpandingEvent Field

Identifies the ItemExpanding routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ItemExpandingEvent
Public Shared ReadOnly ItemExpandingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ItemExpanding routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemMenuRequestedEvent Field

TreeListBoxItemMenuRequestedEvent Field

Identifies the ItemMenuRequested routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ItemMenuRequestedEvent
Public Shared ReadOnly ItemMenuRequestedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ItemMenuRequested routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.ItemSelectingEvent Field

TreeListBoxItemSelectingEvent Field

Identifies the ItemSelecting routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ItemSelectingEvent
Public Shared ReadOnly ItemSelectingEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ItemSelecting routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.MultiDragKindProperty Field

TreeListBoxMultiDragKindProperty Field

Identifies the MultiDragKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MultiDragKindProperty
Public Shared ReadOnly MultiDragKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MultiDragKind dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.MultiSelectionKindProperty Field

TreeListBoxMultiSelectionKindProperty Field

Identifies the MultiSelectionKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MultiSelectionKindProperty
Public Shared ReadOnly MultiSelectionKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MultiSelectionKind dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.PathSeparatorProperty Field

TreeListBoxPathSeparatorProperty Field

Identifies the PathSeparator dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PathSeparatorProperty
Public Shared ReadOnly PathSeparatorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PathSeparator dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.RootItemChangedEvent Field

TreeListBoxRootItemChangedEvent Field

Identifies the RootItemChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent RootItemChangedEvent
Public Shared ReadOnly RootItemChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the RootItemChanged routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.RootItemProperty Field

TreeListBoxRootItemProperty Field

Identifies the RootItem dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RootItemProperty
Public Shared ReadOnly RootItemProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RootItem dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.SelectedItemProperty Field

TreeListBoxSelectedItemProperty Field

Identifies the SelectedItem dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedItemProperty
Public Shared ReadOnly SelectedItemProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedItem dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.SelectionChangedEvent Field

TreeListBoxSelectionChangedEvent Field

Identifies the SelectionChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent SelectionChangedEvent
Public Shared ReadOnly SelectionChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the SelectionChanged routed event.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.SelectionModeProperty Field

TreeListBoxSelectionModeProperty Field

Identifies the SelectionMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionModeProperty
Public Shared ReadOnly SelectionModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionMode dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.TopLevelIndentProperty Field

TreeListBoxTopLevelIndentProperty Field

Identifies the TopLevelIndent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TopLevelIndentProperty
Public Shared ReadOnly TopLevelIndentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TopLevelIndent dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox Attached Properties

The TreeListBox type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsSelectionActive |
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBox.IsSelectionActive Attached Property

TreeListBoxIsSelectionActive Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.TreeListBox.IsSelectionActive"]

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetIsSelectionActive
See GetIsSelectionActive

Property Value

Type: Boolean
See Also

Reference

TreeListBox Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem Class

Represents an item for a TreeListBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.GridsTreeListBoxItem
ActiproSoftware.Windows.Controls.GridsTreeListViewItem

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListBoxItem : ContentControl
Public Class TreeListBoxItem
    Inherits ContentControl

The TreeListBoxItem type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItem | Initializes an instance of the TreeListBoxItem class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented.
Public property | InnerBorderThickness | Gets or sets the Thickness of the inner border.
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed.
Public property | IsExpanded | Gets or sets whether the node is expanded.
Public property | IsSelectable | Gets or sets whether the node is capable of being selected.
Public property | IsSelected | Gets or sets whether the node is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsLocationOverBackground | Returns whether the specified location is past the end of the content, in owner control background whitespace area.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Overrides FrameworkElementOnContextMenuOpening(ContextMenuEventArgs).)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDoubleTapped | Occurs when the item is double-tapped.
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Overrides UIElementOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Overrides UIElementOnDragLeave(DragEventArgs).)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Overrides UIElementOnDragOver(DragEventArgs).)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Overrides UIElementOnDrop(DragEventArgs).)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed.
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Occurs when composed text is input to the control. (Overrides UIElementOnTextInput(TextCompositionEventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
DefaultActionCommandProperty | Identifies the DefaultActionCommand dependency property. This field is read-only.
DropIndicatorAreaProperty | Identifies the DropIndicatorArea dependency property. This field is read-only.
IndentAmountProperty | Identifies the IndentAmount dependency property. This field is read-only.
InnerBorderThicknessProperty | Identifies the InnerBorderThickness dependency property. This field is read-only.
IsExpandableProperty | Identifies the IsExpandable dependency property. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
IsSelectableProperty | Identifies the IsSelectable dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
ToggleExpansionButtonStyleProperty | Identifies the ToggleExpansionButtonStyle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem Constructor

Initializes an instance of the TreeListBoxItem class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxItem()
Public Sub New
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem Properties

The TreeListBoxItem type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented.
Public property | InnerBorderThickness | Gets or sets the Thickness of the inner border.
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed.
Public property | IsExpanded | Gets or sets whether the node is expanded.
Public property | IsSelectable | Gets or sets whether the node is capable of being selected.
Public property | IsSelected | Gets or sets whether the node is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.DefaultActionCommand Property

TreeListBoxItemDefaultActionCommand Property

Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand DefaultActionCommand { get; set; }
Public Property DefaultActionCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand to execute when this node is double-tapped or Enter is pressed while it's focused.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.DropIndicatorArea Property

TreeListBoxItemDropIndicatorArea Property

Gets a TreeItemDropArea that specifies the drop indicator to display.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeItemDropArea DropIndicatorArea { get; }
Public ReadOnly Property DropIndicatorArea As TreeItemDropArea
    Get

Property Value

Type: TreeItemDropArea
The TreeItemDropArea that specifies the drop indicator to display.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IndentAmount Property

TreeListBoxItemIndentAmount Property

Gets or sets the amount that this item's content is indented.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double IndentAmount { get; set; }
Public Property IndentAmount As Double
    Get
    Set

Property Value

Type: Double
The amount that this item's content is indented.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.InnerBorderThickness Property

TreeListBoxItemInnerBorderThickness Property

Gets or sets the Thickness of the inner border.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness InnerBorderThickness { get; set; }
Public Property InnerBorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the inner border. The default value is 1.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IsExpandable Property

TreeListBoxItemIsExpandable Property

Gets or sets whether the node is capable of being expanded or collapsed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsExpandable { get; set; }
Public Property IsExpandable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the node is capable of being expanded or collapsed; otherwise, false.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IsExpanded Property

TreeListBoxItemIsExpanded Property

Gets or sets whether the node is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsExpanded { get; set; }
Public Property IsExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the node is expanded; otherwise, false.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IsSelectable Property

TreeListBoxItemIsSelectable Property

Gets or sets whether the node is capable of being selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelectable { get; set; }
Public Property IsSelectable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the node is capable of being selected; otherwise, false.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IsSelected Property

TreeListBoxItemIsSelected Property

Gets or sets whether the node is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the node is selected; otherwise, false.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.ToggleExpansionButtonStyle Property

TreeListBoxItemToggleExpansionButtonStyle Property

Gets or sets the Style to use for the toggle expansion button.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ToggleExpansionButtonStyle { get; set; }
Public Property ToggleExpansionButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the toggle expansion button.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem Methods

The TreeListBoxItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsLocationOverBackground | Returns whether the specified location is past the end of the content, in owner control background whitespace area.
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Overrides FrameworkElementOnContextMenuOpening(ContextMenuEventArgs).)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDoubleTapped | Occurs when the item is double-tapped.
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Overrides UIElementOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Overrides UIElementOnDragLeave(DragEventArgs).)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Overrides UIElementOnDragOver(DragEventArgs).)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Overrides UIElementOnDrop(DragEventArgs).)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed.
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Occurs when composed text is input to the control. (Overrides UIElementOnTextInput(TextCompositionEventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IsLocationOverBackground Method

TreeListBoxItemIsLocationOverBackground Method

Returns whether the specified location is past the end of the content, in owner control background whitespace area.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsLocationOverBackground(
    Point location
)
Protected Overridable Function IsLocationOverBackground (
    location As Point
) As Boolean

Parameters

location
Type: System.WindowsPoint
The location to examine.

Return Value

Type: Boolean
true if the specified location is past the end of the content, in owner control background whitespace area; otherwise, false.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnApplyTemplate Method

TreeListBoxItemOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnContextMenuOpening Method

TreeListBoxItemOnContextMenuOpening Method

Occurs when a context menu is requested.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnContextMenuOpening(
    ContextMenuEventArgs e
)
Protected Overrides Sub OnContextMenuOpening (
    e As ContextMenuEventArgs
)

Parameters

e
Type: System.Windows.ControlsContextMenuEventArgs
The ContextMenuEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnCreateAutomationPeer Method

TreeListBoxItemOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnDoubleTapped Method

TreeListBoxItemOnDoubleTapped Method

Occurs when the item is double-tapped.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnDoubleTapped(
    InputPointerButtonEventArgs e
)
Protected Overridable Sub OnDoubleTapped (
    e As InputPointerButtonEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.InputInputPointerButtonEventArgs
The InputPointerButtonEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnDragEnter Method

TreeListBoxItemOnDragEnter Method

Occurs when an object is dragged inside of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragEnter(
    DragEventArgs e
)
Protected Overrides Sub OnDragEnter (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnDragLeave Method

TreeListBoxItemOnDragLeave Method

Occurs when an object is dragged outside of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragLeave(
    DragEventArgs e
)
Protected Overrides Sub OnDragLeave (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnDragOver Method

TreeListBoxItemOnDragOver Method

Occurs when an object is dragged over the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDragOver(
    DragEventArgs e
)
Protected Overrides Sub OnDragOver (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnDrop Method

TreeListBoxItemOnDrop Method

Occurs when an object is dropped over the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnDrop(
    DragEventArgs e
)
Protected Overrides Sub OnDrop (
    e As DragEventArgs
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnGotFocus Method

TreeListBoxItemOnGotFocus Method

Occurs when the control gains focus.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnIndentAmountChanged Method

TreeListBoxItemOnIndentAmountChanged Method

Occurs when the IndentAmount property is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnIndentAmountChanged()
Protected Overridable Sub OnIndentAmountChanged
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnIsKeyboardFocusWithinChanged Method

TreeListBoxItemOnIsKeyboardFocusWithinChanged Method

Reports that the IsKeyboardFocusWithin property changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIsKeyboardFocusWithinChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnIsKeyboardFocusWithinChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
A DependencyPropertyChangedEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnKeyDown Method

TreeListBoxItemOnKeyDown Method

Occurs when a key is pressed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.InputKeyEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnLostFocus Method

TreeListBoxItemOnLostFocus Method

Occurs when the control loses focus.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.OnTextInput Method

TreeListBoxItemOnTextInput Method

Occurs when composed text is input to the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnTextInput(
    TextCompositionEventArgs e
)
Protected Overrides Sub OnTextInput (
    e As TextCompositionEventArgs
)

Parameters

e
Type: System.Windows.InputTextCompositionEventArgs
A TextCompositionEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.ToString Method

TreeListBoxItemToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem Events

The TreeListBoxItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem Fields

The TreeListBoxItem type exposes the following members.

Fields
Name | Description
DefaultActionCommandProperty | Identifies the DefaultActionCommand dependency property. This field is read-only.
DropIndicatorAreaProperty | Identifies the DropIndicatorArea dependency property. This field is read-only.
IndentAmountProperty | Identifies the IndentAmount dependency property. This field is read-only.
InnerBorderThicknessProperty | Identifies the InnerBorderThickness dependency property. This field is read-only.
IsExpandableProperty | Identifies the IsExpandable dependency property. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
IsSelectableProperty | Identifies the IsSelectable dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
ToggleExpansionButtonStyleProperty | Identifies the ToggleExpansionButtonStyle dependency property. This field is read-only.
Top
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.DefaultActionCommandProperty Field

TreeListBoxItemDefaultActionCommandProperty Field

Identifies the DefaultActionCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultActionCommandProperty
Public Shared ReadOnly DefaultActionCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultActionCommand dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.DropIndicatorAreaProperty Field

TreeListBoxItemDropIndicatorAreaProperty Field

Identifies the DropIndicatorArea dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DropIndicatorAreaProperty
Public Shared ReadOnly DropIndicatorAreaProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DropIndicatorArea dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IndentAmountProperty Field

TreeListBoxItemIndentAmountProperty Field

Identifies the IndentAmount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndentAmountProperty
Public Shared ReadOnly IndentAmountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IndentAmount dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.InnerBorderThicknessProperty Field

TreeListBoxItemInnerBorderThicknessProperty Field

Identifies the InnerBorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InnerBorderThicknessProperty
Public Shared ReadOnly InnerBorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InnerBorderThickness dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IsExpandableProperty Field

TreeListBoxItemIsExpandableProperty Field

Identifies the IsExpandable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsExpandableProperty
Public Shared ReadOnly IsExpandableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsExpandable dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IsExpandedProperty Field

TreeListBoxItemIsExpandedProperty Field

Identifies the IsExpanded dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsExpandedProperty
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsExpanded dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IsSelectableProperty Field

TreeListBoxItemIsSelectableProperty Field

Identifies the IsSelectable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectableProperty
Public Shared ReadOnly IsSelectableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelectable dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.IsSelectedProperty Field

TreeListBoxItemIsSelectedProperty Field

Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItem.ToggleExpansionButtonStyleProperty Field

TreeListBoxItemToggleExpansionButtonStyleProperty Field

Identifies the ToggleExpansionButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToggleExpansionButtonStyleProperty
Public Shared ReadOnly ToggleExpansionButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToggleExpansionButtonStyle dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter Class

An adapter that can provide an item's hierarchy and visual state data for usage in a TreeListBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemAdapter
ActiproSoftware.Windows.Controls.GridsPropertyGridItemAdapter
ActiproSoftware.Windows.Controls.ShellShellObjectItemAdapter

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListBoxItemAdapter
Public Class TreeListBoxItemAdapter

The TreeListBoxItemAdapter type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemAdapter | Initializes a new instance of the TreeListBoxItemAdapter class
Top
Properties
 | Name | Description
Public property | ChildrenBinding | Gets or sets a Binding that can be used to retrieve an IEnumerable of child items.
Public property | ChildrenPath | Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items.
Public property | ChildrenQueryModeDefault | Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried.
Public property | ExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability.
Public property | IsDraggableBinding | Gets or sets a Binding that determines whether an item is draggable.
Public property | IsEditableBinding | Gets or sets a Binding that determines whether an item is editable.
Public property | IsEditableDefault | Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable.
Public property | IsEditingBinding | Gets or sets a Binding that determines whether an item is currently being edited.
Public property | IsEditingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states.
Public property | IsExpandedBinding | Gets or sets a Binding that determines whether an item should be expanded.
Public property | IsExpandedDefault | Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded.
Public property | IsExpandedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states.
Public property | IsLoadingBinding | Gets or sets a Binding that determines whether an item is currently loading children asynchronously.
Public property | IsLoadingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states.
Public property | IsSelectableBinding | Gets or sets a Binding that determines whether an item is capable of being selected.
Public property | IsSelectablePath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities.
Public property | IsSelectedBinding | Gets or sets a Binding that determines whether an item should be selected.
Public property | IsSelectedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states.
Public property | PathBinding | Gets or sets a Binding that can retrieve the path of an item.
Public property | SearchTextBinding | Gets or sets a Binding that can retrieve the search text of an item.
Public property | TopLevelExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability.
Top
Methods
 | Name | Description
Public method | CanHaveChildren | Returns whether the specified item is capable of having child items.
Public method | CreateVirtualPlaceholder | Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled.
Public method | Filter | Examines the specified item to see if meets active filter conditions.
Public method | GetChildren | Returns an IEnumerable that will be used to provide child items for the specified parent item.
Public method | GetChildrenQueryMode | Returns the children query mode of the specified item.
Public method | GetExpandability | Returns the expandability of the specified item.
Public method | GetIndentAmount | Returns the indent amount of the specified item.
Public method | GetIsDraggable | Returns whether the specified item is draggable.
Public method | GetIsEditable | Returns whether the specified item is editable.
Public method | GetIsEditing | Returns whether the specified item is currently being edited.
Public method | GetIsExpanded | Returns whether the specified item is expanded.
Public method | GetIsLoading | Returns whether the specified item is currently loading children asynchronously.
Public method | GetIsSelectable | Returns whether the specified item is capable of being selected.
Public method | GetIsSelected | Returns whether the specified item is selected.
Public method | GetPath | Returns the item's string path.
Public method | GetSearchText | Returns the item's text by which to match when searching.
Public method | InitializeDataObject | Initializes a IDataObject based on the specified items.
Public method | OnDragComplete | Notifies that a drag event from the source control has completed.
Public method | OnDragHover | Notifies that a drag event hovered over a target item, returning whether the target item can be expanded when appropriate.
Public method | OnDragOver | Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback.
Public method | OnDragStart | Notifies that a drag event is about to originate from the source control.
Public method | OnDrop | Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs.
Public method | SetIsEditing | Sets whether the specified item is currently being edited.
Public method | SetIsExpanded | Sets whether the specified item is expanded.
Public method | SetIsSelected | Sets whether the specified item is selected.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter Constructor

Initializes a new instance of the TreeListBoxItemAdapter class

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxItemAdapter()
Public Sub New
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter Properties

The TreeListBoxItemAdapter type exposes the following members.

Properties
 | Name | Description
Public property | ChildrenBinding | Gets or sets a Binding that can be used to retrieve an IEnumerable of child items.
Public property | ChildrenPath | Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items.
Public property | ChildrenQueryModeDefault | Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried.
Public property | ExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability.
Public property | IsDraggableBinding | Gets or sets a Binding that determines whether an item is draggable.
Public property | IsEditableBinding | Gets or sets a Binding that determines whether an item is editable.
Public property | IsEditableDefault | Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable.
Public property | IsEditingBinding | Gets or sets a Binding that determines whether an item is currently being edited.
Public property | IsEditingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states.
Public property | IsExpandedBinding | Gets or sets a Binding that determines whether an item should be expanded.
Public property | IsExpandedDefault | Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded.
Public property | IsExpandedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states.
Public property | IsLoadingBinding | Gets or sets a Binding that determines whether an item is currently loading children asynchronously.
Public property | IsLoadingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states.
Public property | IsSelectableBinding | Gets or sets a Binding that determines whether an item is capable of being selected.
Public property | IsSelectablePath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities.
Public property | IsSelectedBinding | Gets or sets a Binding that determines whether an item should be selected.
Public property | IsSelectedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states.
Public property | PathBinding | Gets or sets a Binding that can retrieve the path of an item.
Public property | SearchTextBinding | Gets or sets a Binding that can retrieve the search text of an item.
Public property | TopLevelExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability.
Top
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.ChildrenBinding Property

TreeListBoxItemAdapterChildrenBinding Property

Gets or sets a Binding that can be used to retrieve an IEnumerable of child items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding ChildrenBinding { get; set; }
Public Property ChildrenBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetChildren(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetChildren(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetChildren(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.ChildrenPath Property

TreeListBoxItemAdapterChildrenPath Property

Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ChildrenPath { get; set; }
Public Property ChildrenPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.ChildrenQueryModeDefault Property

TreeListBoxItemAdapterChildrenQueryModeDefault Property

Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeItemChildrenQueryMode ChildrenQueryModeDefault { get; set; }
Public Property ChildrenQueryModeDefault As TreeItemChildrenQueryMode
    Get
    Set

Property Value

Type: TreeItemChildrenQueryMode
A TreeItemChildrenQueryMode indicating the children query mode. The default value is OnDisplay.
Remarks
This value is returned by GetChildrenQueryMode(TreeListBox, Object).
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.ExpandabilityDefault Property

TreeListBoxItemAdapterExpandabilityDefault Property

Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeItemExpandability ExpandabilityDefault { get; set; }
Public Property ExpandabilityDefault As TreeItemExpandability
    Get
    Set

Property Value

Type: TreeItemExpandability
A TreeItemExpandability indicating the expandability. The default value is Auto.
Remarks
This value is returned by GetExpandability(TreeListBox, Object, Int32).
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsDraggableBinding Property

TreeListBoxItemAdapterIsDraggableBinding Property

Gets or sets a Binding that determines whether an item is draggable.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding IsDraggableBinding { get; set; }
Public Property IsDraggableBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsDraggable(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsDraggable(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsDraggable(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsEditableBinding Property

TreeListBoxItemAdapterIsEditableBinding Property

Gets or sets a Binding that determines whether an item is editable.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding IsEditableBinding { get; set; }
Public Property IsEditableBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsEditable(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsEditable(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsEditable(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsEditableDefault Property

TreeListBoxItemAdapterIsEditableDefault Property

Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEditableDefault { get; set; }
Public Property IsEditableDefault As Boolean
    Get
    Set

Property Value

Type: Boolean
true if all items should be editable; otherwise, false. The default value is false.
Remarks
This value is returned by GetIsEditable(TreeListBox, Object) if no IsEditableBinding is set. Set this property to true to allow all items to be editable. Note that an IsEditableBinding value will override it.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsEditingBinding Property

TreeListBoxItemAdapterIsEditingBinding Property

Gets or sets a Binding that determines whether an item is currently being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding IsEditingBinding { get; set; }
Public Property IsEditingBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsEditing(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsEditing(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsEditing(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsEditingPath Property

TreeListBoxItemAdapterIsEditingPath Property

Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string IsEditingPath { get; set; }
Public Property IsEditingPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsExpandedBinding Property

TreeListBoxItemAdapterIsExpandedBinding Property

Gets or sets a Binding that determines whether an item should be expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding IsExpandedBinding { get; set; }
Public Property IsExpandedBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsExpanded(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsExpanded(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsExpanded(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsExpandedDefault Property

TreeListBoxItemAdapterIsExpandedDefault Property

Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsExpandedDefault { get; set; }
Public Property IsExpandedDefault As Boolean
    Get
    Set

Property Value

Type: Boolean
true if all items should be initially expanded; otherwise, false. The default value is false.
Remarks
This value is returned by GetIsExpanded(TreeListBox, Object) if no IsExpandedBinding is set. Set this property to true to always fully expand a tree. Note that an IsExpandedBinding value will override it.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsExpandedPath Property

TreeListBoxItemAdapterIsExpandedPath Property

Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string IsExpandedPath { get; set; }
Public Property IsExpandedPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsLoadingBinding Property

TreeListBoxItemAdapterIsLoadingBinding Property

Gets or sets a Binding that determines whether an item is currently loading children asynchronously.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding IsLoadingBinding { get; set; }
Public Property IsLoadingBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsLoading(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsLoading(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsLoading(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsLoadingPath Property

TreeListBoxItemAdapterIsLoadingPath Property

Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string IsLoadingPath { get; set; }
Public Property IsLoadingPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsSelectableBinding Property

TreeListBoxItemAdapterIsSelectableBinding Property

Gets or sets a Binding that determines whether an item is capable of being selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding IsSelectableBinding { get; set; }
Public Property IsSelectableBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsSelectable(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsSelectable(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsSelectable(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsSelectablePath Property

TreeListBoxItemAdapterIsSelectablePath Property

Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string IsSelectablePath { get; set; }
Public Property IsSelectablePath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsSelectedBinding Property

TreeListBoxItemAdapterIsSelectedBinding Property

Gets or sets a Binding that determines whether an item should be selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding IsSelectedBinding { get; set; }
Public Property IsSelectedBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsSelected(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsSelected(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsSelected(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.IsSelectedPath Property

TreeListBoxItemAdapterIsSelectedPath Property

Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string IsSelectedPath { get; set; }
Public Property IsSelectedPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.PathBinding Property

TreeListBoxItemAdapterPathBinding Property

Gets or sets a Binding that can retrieve the path of an item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding PathBinding { get; set; }
Public Property PathBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetPath(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetPath(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetPath(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.SearchTextBinding Property

TreeListBoxItemAdapterSearchTextBinding Property

Gets or sets a Binding that can retrieve the search text of an item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Binding SearchTextBinding { get; set; }
Public Property SearchTextBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetSearchText(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetSearchText(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetSearchText(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.TopLevelExpandabilityDefault Property

TreeListBoxItemAdapterTopLevelExpandabilityDefault Property

Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeItemExpandability TopLevelExpandabilityDefault { get; set; }
Public Property TopLevelExpandabilityDefault As TreeItemExpandability
    Get
    Set

Property Value

Type: TreeItemExpandability
A TreeItemExpandability indicating the expandability. The default value is Auto, meaning fall back to the ExpandabilityDefault value.
Remarks
This value is returned by GetExpandability(TreeListBox, Object, Int32).
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter Methods

The TreeListBoxItemAdapter type exposes the following members.

Methods
 | Name | Description
Public method | CanHaveChildren | Returns whether the specified item is capable of having child items.
Public method | CreateVirtualPlaceholder | Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled.
Public method | Filter | Examines the specified item to see if meets active filter conditions.
Public method | GetChildren | Returns an IEnumerable that will be used to provide child items for the specified parent item.
Public method | GetChildrenQueryMode | Returns the children query mode of the specified item.
Public method | GetExpandability | Returns the expandability of the specified item.
Public method | GetIndentAmount | Returns the indent amount of the specified item.
Public method | GetIsDraggable | Returns whether the specified item is draggable.
Public method | GetIsEditable | Returns whether the specified item is editable.
Public method | GetIsEditing | Returns whether the specified item is currently being edited.
Public method | GetIsExpanded | Returns whether the specified item is expanded.
Public method | GetIsLoading | Returns whether the specified item is currently loading children asynchronously.
Public method | GetIsSelectable | Returns whether the specified item is capable of being selected.
Public method | GetIsSelected | Returns whether the specified item is selected.
Public method | GetPath | Returns the item's string path.
Public method | GetSearchText | Returns the item's text by which to match when searching.
Public method | InitializeDataObject | Initializes a IDataObject based on the specified items.
Public method | OnDragComplete | Notifies that a drag event from the source control has completed.
Public method | OnDragHover | Notifies that a drag event hovered over a target item, returning whether the target item can be expanded when appropriate.
Public method | OnDragOver | Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback.
Public method | OnDragStart | Notifies that a drag event is about to originate from the source control.
Public method | OnDrop | Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs.
Public method | SetIsEditing | Sets whether the specified item is currently being edited.
Public method | SetIsExpanded | Sets whether the specified item is expanded.
Public method | SetIsSelected | Sets whether the specified item is selected.
Top
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.CanHaveChildren Method

TreeListBoxItemAdapterCanHaveChildren Method

Returns whether the specified item is capable of having child items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanHaveChildren(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function CanHaveChildren (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is capable of having child items; otherwise, false.
Remarks
The default implementation of this method returns true. This method should only return false if an item is not capable of having child items and is always a 'leaf' node in the tree. It should not return false if the item can have child items, but doesn't at the current time.

Optimizations are in place to not call GetChildren(TreeListBox, Object) when this method returns true. This method should be overridden if OnExpansion is used and certain items are known to be 'leaf' nodes.

See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.CreateVirtualPlaceholder Method

TreeListBoxItemAdapterCreateVirtualPlaceholder Method

Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual ITreeItemVirtualPlaceholder CreateVirtualPlaceholder(
    TreeListBox ownerControl,
    Object parentItem,
    int index
)
Public Overridable Function CreateVirtualPlaceholder (
    ownerControl As TreeListBox,
    parentItem As Object,
    index As Integer
) As ITreeItemVirtualPlaceholder

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
parentItem
Type: SystemObject
The parent item.
index
Type: SystemInt32
The index of the child.

Return Value

Type: ITreeItemVirtualPlaceholder
The ITreeItemVirtualPlaceholder that was created.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.Filter Method

TreeListBoxItemAdapterFilter Method

Examines the specified item to see if meets active filter conditions.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataFilterResult Filter(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function Filter (
    ownerControl As TreeListBox,
    item As Object
) As DataFilterResult

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: DataFilterResult
A DataFilterResult that indicates the filter result.
Remarks
The default implementation of this method uses the DataFilter value to filter the item. If no data filter is available, the method returns Included.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetChildren Method

TreeListBoxItemAdapterGetChildren Method

Returns an IEnumerable that will be used to provide child items for the specified parent item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IEnumerable GetChildren(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetChildren (
    ownerControl As TreeListBox,
    item As Object
) As IEnumerable

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: IEnumerable
An IEnumerable that will be used to provide child items for the specified parent item.
Remarks
The ChildrenBinding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetChildrenQueryMode Method

TreeListBoxItemAdapterGetChildrenQueryMode Method

Returns the children query mode of the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual TreeItemChildrenQueryMode GetChildrenQueryMode(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetChildrenQueryMode (
    ownerControl As TreeListBox,
    item As Object
) As TreeItemChildrenQueryMode

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: TreeItemChildrenQueryMode
A TreeItemChildrenQueryMode indicating the children query mode.
Remarks
The default implementation of this method returns the ChildrenQueryModeDefault property value. That property can be set in XAML, or this method may be overridden for more complex logic.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetExpandability Method

TreeListBoxItemAdapterGetExpandability Method

Returns the expandability of the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual TreeItemExpandability GetExpandability(
    TreeListBox ownerControl,
    Object item,
    int depth
)
Public Overridable Function GetExpandability (
    ownerControl As TreeListBox,
    item As Object,
    depth As Integer
) As TreeItemExpandability

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.
depth
Type: SystemInt32
The item depth.

Return Value

Type: TreeItemExpandability
A TreeItemExpandability indicating the expandability.
Remarks
The default implementation of this method examines the TopLevelExpandabilityDefault property if the item is top-level. If that property return Auto, or if the item isn't top-level, the ExpandabilityDefault property value is returned. Both properties can be set in XAML, or this method may be overridden for more complex logic.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIndentAmount Method

TreeListBoxItemAdapterGetIndentAmount Method

Returns the indent amount of the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual double GetIndentAmount(
    TreeListBox ownerControl,
    Object item,
    int depth
)
Public Overridable Function GetIndentAmount (
    ownerControl As TreeListBox,
    item As Object,
    depth As Integer
) As Double

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.
depth
Type: SystemInt32
The item depth.

Return Value

Type: Double
The indent amount.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsDraggable Method

TreeListBoxItemAdapterGetIsDraggable Method

Returns whether the specified item is draggable.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool GetIsDraggable(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsDraggable (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is draggable; otherwise, false.
Remarks
The IsDraggableBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsEditable Method

TreeListBoxItemAdapterGetIsEditable Method

Returns whether the specified item is editable.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool GetIsEditable(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsEditable (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is editable; otherwise, false.
Remarks
The IsEditableBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value. The IsEditableDefault property can also be set (if IsEditableBinding is not used) to designate the default return value of this method, and that can be set in XAML.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsEditing Method

TreeListBoxItemAdapterGetIsEditing Method

Returns whether the specified item is currently being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool GetIsEditing(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsEditing (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is currently being edited; otherwise, false.
Remarks
The IsEditingBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsExpanded Method

TreeListBoxItemAdapterGetIsExpanded Method

Returns whether the specified item is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool GetIsExpanded(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsExpanded (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is expanded; otherwise, false.
Remarks
The IsExpandedBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value. The IsExpandedDefault property can also be set (if IsExpandedBinding is not used) to designate the default return value of this method, and that can be set in XAML.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsLoading Method

TreeListBoxItemAdapterGetIsLoading Method

Returns whether the specified item is currently loading children asynchronously.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool GetIsLoading(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsLoading (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is currently loading children asynchronously; otherwise, false.
Remarks
The IsLoadingBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsSelectable Method

TreeListBoxItemAdapterGetIsSelectable Method

Returns whether the specified item is capable of being selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool GetIsSelectable(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsSelectable (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is capable of being selected; otherwise, false.
Remarks
The IsSelectableBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsSelected Method

TreeListBoxItemAdapterGetIsSelected Method

Returns whether the specified item is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool GetIsSelected(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsSelected (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is selected; otherwise, false.
Remarks
The IsSelectedBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetPath Method

TreeListBoxItemAdapterGetPath Method

Returns the item's string path.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string GetPath(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetPath (
    ownerControl As TreeListBox,
    item As Object
) As String

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: String
The item's string path.
Remarks
The PathBinding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.GetSearchText Method

TreeListBoxItemAdapterGetSearchText Method

Returns the item's text by which to match when searching.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string GetSearchText(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetSearchText (
    ownerControl As TreeListBox,
    item As Object
) As String

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: String
The item's string search text.
Remarks
The SearchTextBinding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.InitializeDataObject Method

TreeListBoxItemAdapterInitializeDataObject Method

Initializes a IDataObject based on the specified items.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DragDropEffects InitializeDataObject(
    TreeListBox sourceControl,
    IDataObject dataObject,
    IEnumerable<Object> items
)
Public Overridable Function InitializeDataObject (
    sourceControl As TreeListBox,
    dataObject As IDataObject,
    items As IEnumerable(Of Object)
) As DragDropEffects

Parameters

sourceControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The source control that contains the items.
dataObject
Type: System.WindowsIDataObject
The IDataObject to initialize.
items
Type: System.Collections.GenericIEnumerable Object
The items to examine.

Return Value

Type: DragDropEffects
The DragDropEffects that specifies the allowed drag/drop effects for the IDataObject.
Remarks
The default implementation of this method simply return DragDropEffects.None. Override this method to initialize the IDataObject with text and/or other data formats (such as ItemDataFormat for supporting drag/drop), and to return an appropriate DragDropEffects result.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.OnDragComplete Method

TreeListBoxItemAdapterOnDragComplete Method

Notifies that a drag event from the source control has completed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void OnDragComplete(
    InputPointerEventArgs e,
    TreeListBox sourceControl,
    DataObject dataObject,
    DragDropEffects effect
)
Public Overridable Sub OnDragComplete (
    e As InputPointerEventArgs,
    sourceControl As TreeListBox,
    dataObject As DataObject,
    effect As DragDropEffects
)

Parameters

e
Type: ActiproSoftware.Windows.InputInputPointerEventArgs
The InputPointerEventArgs that provides related pointer information.
sourceControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The source control, from which the drag occurred.
dataObject
Type: System.WindowsDataObject
The data object with information about what was dragged.
effect
Type: System.WindowsDragDropEffects
The drop effect.
Remarks
The default implementation of this method does nothing. This method can be overridden in scenarios where a custom adorner needs to be rendered near the pointer as the items are dragged, and the adorner should be removed.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.OnDragHover Method

TreeListBoxItemAdapterOnDragHover Method

Notifies that a drag event hovered over a target item, returning whether the target item can be expanded when appropriate.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual TreeItemExpandability OnDragHover(
    DragEventArgs e,
    TreeListBox targetControl,
    Object targetItem
)
Public Overridable Function OnDragHover (
    e As DragEventArgs,
    targetControl As TreeListBox,
    targetItem As Object
) As TreeItemExpandability

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs with drag information.
targetControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The target control, over which the event occurred.
targetItem
Type: SystemObject
The target item.

Return Value

Type: TreeItemExpandability
A TreeItemExpandability that indicates if the target item should expand.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.OnDragOver Method

TreeListBoxItemAdapterOnDragOver Method

Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual TreeItemDropArea OnDragOver(
    DragEventArgs e,
    TreeListBox targetControl,
    Object targetItem,
    TreeItemDropArea dropArea
)
Public Overridable Function OnDragOver (
    e As DragEventArgs,
    targetControl As TreeListBox,
    targetItem As Object,
    dropArea As TreeItemDropArea
) As TreeItemDropArea

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs whose effects should be updated.
targetControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The target control, over which the event occurred.
targetItem
Type: SystemObject
The target item, which could be if dragging below the last tree item.
dropArea
Type: ActiproSoftware.Windows.Controls.GridsTreeItemDropArea
A TreeItemDropArea indicating the drop area over the target item.

Return Value

Type: TreeItemDropArea
A TreeItemDropArea indicating the allowed drop area, which will be used for visual feedback to the end user. Return TreeItemDropArea.None for no visual feedback.
Remarks
The default implementation of this method sets the e.Effects to DragDropEffects.None and returns that no drop area is allowed. Override this method if you wish to support dropping and add logic to properly handle the dragged data.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.OnDragStart Method

TreeListBoxItemAdapterOnDragStart Method

Notifies that a drag event is about to originate from the source control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void OnDragStart(
    InputPointerEventArgs e,
    TreeListBox sourceControl,
    DataObject dataObject,
    DragDropEffects allowedEffects
)
Public Overridable Sub OnDragStart (
    e As InputPointerEventArgs,
    sourceControl As TreeListBox,
    dataObject As DataObject,
    allowedEffects As DragDropEffects
)

Parameters

e
Type: ActiproSoftware.Windows.InputInputPointerEventArgs
The InputPointerEventArgs that provides related pointer information.
sourceControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The source control, from which the drag will take place.
dataObject
Type: System.WindowsDataObject
The data object with information about what will be dragged.
allowedEffects
Type: System.WindowsDragDropEffects
The allowed effects.
Remarks
The default implementation of this method does nothing. This method can be overridden in scenarios where a custom adorner needs to be rendered near the pointer as the items are dragged, and the adorner should be created.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.OnDrop Method

TreeListBoxItemAdapterOnDrop Method

Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void OnDrop(
    DragEventArgs e,
    TreeListBox targetControl,
    Object targetItem,
    TreeItemDropArea dropArea
)
Public Overridable Sub OnDrop (
    e As DragEventArgs,
    targetControl As TreeListBox,
    targetItem As Object,
    dropArea As TreeItemDropArea
)

Parameters

e
Type: System.WindowsDragEventArgs
The DragEventArgs whose effects should be updated.
targetControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The target control, over which the event occurred.
targetItem
Type: SystemObject
The target item, which could be if dragging below the last tree item.
dropArea
Type: ActiproSoftware.Windows.Controls.GridsTreeItemDropArea
A TreeItemDropArea indicating the drop area over the target item.
Remarks
The default implementation of this method sets the e.Effects to DragDropEffects.None and takes no further action. Override this method if you wish to support dropping and add logic to properly handle the dragged data.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.SetIsEditing Method

TreeListBoxItemAdapterSetIsEditing Method

Sets whether the specified item is currently being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void SetIsEditing(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overridable Sub SetIsEditing (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
Remarks
The IsEditingBinding binding property can be set to a two-way binding for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to set the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.SetIsExpanded Method

TreeListBoxItemAdapterSetIsExpanded Method

Sets whether the specified item is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void SetIsExpanded(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overridable Sub SetIsExpanded (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
Remarks
The IsExpandedBinding binding property can be set to a two-way binding for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to set the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemAdapter.SetIsSelected Method

TreeListBoxItemAdapterSetIsSelected Method

Sets whether the specified item is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void SetIsSelected(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overridable Sub SetIsSelected (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
Remarks
The IsSelectedBinding binding property can be set to a two-way binding for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to set the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemEventArgs Class

Provides event arguments for TreeListBox item-related events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemExpansionEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemMenuEventArgs

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListBoxItemEventArgs : CancelRoutedEventArgs
Public Class TreeListBoxItemEventArgs
    Inherits CancelRoutedEventArgs

The TreeListBoxItemEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemEventArgs | Initializes a new instance of the TreeListBoxItemEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item.
Public property | Item | Gets the TreeListBox data item.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemEventArgs Constructor

Initializes a new instance of the TreeListBoxItemEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxItemEventArgs(
    Object item,
    TreeListBoxItem container
)
Public Sub New (
    item As Object,
    container As TreeListBoxItem
)

Parameters

item
Type: SystemObject
The TreeListBox data item.
container
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItem
The TreeListBoxItem container that wraps the Item.
See Also

Reference

TreeListBoxItemEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemEventArgs Properties

The TreeListBoxItemEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item.
Public property | Item | Gets the TreeListBox data item.
Top
See Also

Reference

TreeListBoxItemEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemEventArgs.Container Property

TreeListBoxItemEventArgsContainer Property

Gets the TreeListBoxItem container that wraps the Item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxItem Container { get; }
Public ReadOnly Property Container As TreeListBoxItem
    Get

Property Value

Type: TreeListBoxItem
The TreeListBoxItem container that wraps the Item.
Remarks
This property may return when the Item is not currently visible. In that case a container might not yet have been generated for the item, or a prior container may have been recycled, both due to UI virtualization.
See Also

Reference

TreeListBoxItemEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemEventArgs.Item Property

TreeListBoxItemEventArgsItem Property

Gets the TreeListBox data item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Item { get; }
Public ReadOnly Property Item As Object
    Get

Property Value

Type: Object
The TreeListBox data item.
See Also

Reference

TreeListBoxItemEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs Class

Provides event arguments for TreeListBox item expand and collapse-related events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemExpansionEventArgs

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListBoxItemExpansionEventArgs : TreeListBoxItemEventArgs
Public Class TreeListBoxItemExpansionEventArgs
    Inherits TreeListBoxItemEventArgs

The TreeListBoxItemExpansionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemExpansionEventArgs | Initializes a new instance of the TreeListBoxItemExpansionEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Item | Gets the TreeListBox data item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Kind | Gets a TreeExpansionKind that specifies the kind of expansion.
Public property | SourceItem | Gets the TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs Constructor

Initializes a new instance of the TreeListBoxItemExpansionEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxItemExpansionEventArgs(
    Object item,
    TreeListBoxItem container,
    TreeExpansionKind kind,
    Object sourceItem
)
Public Sub New (
    item As Object,
    container As TreeListBoxItem,
    kind As TreeExpansionKind,
    sourceItem As Object
)

Parameters

item
Type: SystemObject
The TreeListBox data item.
container
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItem
The TreeListBoxItem container that wraps the Item.
kind
Type: ActiproSoftware.Windows.Controls.GridsTreeExpansionKind
A TreeExpansionKind that specifies the kind of expansion.
sourceItem
Type: SystemObject
The TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.
See Also

Reference

TreeListBoxItemExpansionEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs Properties

The TreeListBoxItemExpansionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Item | Gets the TreeListBox data item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Kind | Gets a TreeExpansionKind that specifies the kind of expansion.
Public property | SourceItem | Gets the TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.
Top
See Also

Reference

TreeListBoxItemExpansionEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs.Kind Property

TreeListBoxItemExpansionEventArgsKind Property

Gets a TreeExpansionKind that specifies the kind of expansion.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeExpansionKind Kind { get; }
Public ReadOnly Property Kind As TreeExpansionKind
    Get

Property Value

Type: TreeExpansionKind
A TreeExpansionKind that specifies the kind of expansion.
See Also

Reference

TreeListBoxItemExpansionEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs.SourceItem Property

TreeListBoxItemExpansionEventArgsSourceItem Property

Gets the TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object SourceItem { get; }
Public ReadOnly Property SourceItem As Object
    Get

Property Value

Type: Object
The TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.
See Also

Reference

TreeListBoxItemExpansionEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs Class

Provides event arguments for TreeListBox item menu events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListBoxItemMenuEventArgs

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListBoxItemMenuEventArgs : TreeListBoxItemEventArgs
Public Class TreeListBoxItemMenuEventArgs
    Inherits TreeListBoxItemEventArgs

The TreeListBoxItemMenuEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemMenuEventArgs | Initializes a new instance of the TreeListBoxItemMenuEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item. (Inherited from TreeListBoxItemEventArgs.)
Public property | IsBackground | Gets whether the pointer location is past the end of the content, in owner control background whitespace area.
Public property | Item | Gets the TreeListBox data item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Menu | Gets or sets the ContextMenu that is about to be displayed.
Public property | PointerLocation | Gets or sets the location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs Constructor

Initializes a new instance of the TreeListBoxItemMenuEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxItemMenuEventArgs(
    Object item,
    TreeListBoxItem container,
    Nullable<Point> pointerLocation,
    bool isBackground
)
Public Sub New (
    item As Object,
    container As TreeListBoxItem,
    pointerLocation As Nullable(Of Point),
    isBackground As Boolean
)

Parameters

item
Type: SystemObject
The TreeListBox data item.
container
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItem
The TreeListBoxItem container that wraps the Item.
pointerLocation
Type: SystemNullable Point
The location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).
isBackground
Type: SystemBoolean
Whether the pointer location is past the end of the content, in owner control background whitespace area.
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs Properties

The TreeListBoxItemMenuEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item. (Inherited from TreeListBoxItemEventArgs.)
Public property | IsBackground | Gets whether the pointer location is past the end of the content, in owner control background whitespace area.
Public property | Item | Gets the TreeListBox data item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Menu | Gets or sets the ContextMenu that is about to be displayed.
Public property | PointerLocation | Gets or sets the location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).
Top
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs.IsBackground Property

TreeListBoxItemMenuEventArgsIsBackground Property

Gets whether the pointer location is past the end of the content, in owner control background whitespace area.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsBackground { get; }
Public ReadOnly Property IsBackground As Boolean
    Get

Property Value

Type: Boolean
true if the pointer location is past the end of the content, in owner control background whitespace area; otherwise, false.
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs.Menu Property

TreeListBoxItemMenuEventArgsMenu Property

Gets or sets the ContextMenu that is about to be displayed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextMenu Menu { get; set; }
Public Property Menu As ContextMenu
    Get
    Set

Property Value

Type: ContextMenu
The ContextMenu that is about to be displayed.
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs.PointerLocation Property

TreeListBoxItemMenuEventArgsPointerLocation Property

Gets or sets the location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Point> PointerLocation { get; set; }
Public Property PointerLocation As Nullable(Of Point)
    Get
    Set

Property Value

Type: Nullable Point
The location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView Class

Represents an advanced multi-column tree view control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
ActiproSoftware.Windows.Controls.GridsTreeListBox
ActiproSoftware.Windows.Controls.GridsTreeListView
ActiproSoftware.Windows.Controls.GridsPropertyGrid
ActiproSoftware.Windows.Controls.ShellShellListView

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListView : TreeListBox
Public Class TreeListView
    Inherits TreeListBox

The TreeListView type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListView | Initializes an instance of the TreeListView class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreColumnHeadersVisible | Gets or sets whether column headers are visible.
Protected property | AssemblyInfo | Gets the AssemblyInfo to use. (Inherited from TreeListBox.)
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanColumnsReorder | Gets or sets whether columns can be reordered by the end user.
Public property | CanColumnsResize | Gets or sets whether columns can be resized by the end user.
Public property | CanColumnsToggleVisibility | Gets or sets whether columns can have their visibility toggled by the end user.
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items. (Inherited from TreeListBox.)
Protected property | CanExpandAll | Gets whether any expand all operations can occur. (Inherited from TreeListBox.)
Public property | ColumnHeaderHeight | Gets the height of the column header.
Public property | Columns | Gets the collection of columns in the control.
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmptyContent | Gets or sets the content to display when there are no items visible in the control. (Inherited from TreeListBox.)
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no items visible in the control. (Inherited from TreeListBox.)
Public property | ExpansionColumnIndex | Gets or sets the index of the columns that contains the indentation and expander button.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility.
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level. (Inherited from TreeListBox.)
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled. (Inherited from TreeListBox.)
Public property | IsDefaultColumnHeaderContextMenuEnabled | Gets or sets whether the default column header context menu is enabled.
Public property | IsEmpty | Gets whether the control is currently empty (doesn't contain any visible items). (Inherited from TreeListBox.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active. (Inherited from TreeListBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Protected property | IsKeyboardFocusWithinContent | Gets whether keyboard focus is within the content area, and not in any header area. (Overrides TreeListBoxIsKeyboardFocusWithinContent.)
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items. (Inherited from TreeListBox.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc. (Inherited from TreeListBox.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved. (Inherited from TreeListBox.)
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved. (Inherited from TreeListBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses. (Inherited from TreeListBox.)
Public property | RootItem | Gets or sets the root item to display in the control. (Inherited from TreeListBox.)
Public property | SelectedItem | Gets or sets the primary selected item. (Inherited from TreeListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from TreeListBox.)
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior. (Inherited from TreeListBox.)
Public property | SizeAllColumnsToFitCommand | Gets the ICommand that sizes all non-star width columns to fit.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item. (Inherited from TreeListBox.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListBoxArrangeOverride(Size).)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BringItemIntoView | Brings the specified node's container into view. (Inherited from TreeListBox.)
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view. (Inherited from TreeListBox.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides TreeListBoxClearContainerForItemOverride(DependencyObject, Object).)
Public method | CollapseAll | Collapses all known tree items. (Inherited from TreeListBox.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | CreateSelectionBatch | Creates an IDisposable object that wraps a batch of selection updates, and allows them to be made without raising selection-related events in between each one. (Inherited from TreeListBox.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | ExpandAll | Expands all known tree items. (Inherited from TreeListBox.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed. (Inherited from TreeListBox.)
 | GetColumnHeaderVisibility | Gets the value of the ColumnHeaderVisibility attached property for the specified object.
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TreeListBoxGetContainerForItemOverride.)
 | GetFrozenColumnsWidth | Gets the value of the FrozenColumnsWidth attached property for the specified object.
Public method | GetFullPath | Returns the full path of the specified item. (Inherited from TreeListBox.)
Public method | GetItemByFullPath | Returns the item with the specified full path. (Inherited from TreeListBox.)
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item. (Inherited from TreeListBox.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried. (Inherited from TreeListBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TreeListBoxIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListBoxOnApplyTemplate.)
Protected method | OnColumnHeaderMenuRequested | Occurs when a column header requests a context menu.
Protected method | OnColumnHeaderTapped | Occurs when a column's header is tapped.
Protected method | OnColumnIsVisibleChanged | Occurs when a column's visibility has changed.
Protected method | OnColumnReordered | Occurs after a column is reordered by the end user.
Protected method | OnColumnsResized | Occurs after the ActualWidth of one or more columns changes.
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TreeListBoxOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBox.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBox.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBox.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBox.)
Protected method | OnGotKeyboardFocus | Occurs when the control gains keyboard focus. (Inherited from TreeListBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Inherited from TreeListBox.)
Protected method | OnIsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed. (Inherited from TreeListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Protected method | OnItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource property is changed. (Inherited from TreeListBox.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from TreeListBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs after the RootItem property is changed. (Inherited from TreeListBox.)
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed. (Overrides TreeListBoxOnScrollViewerScrollChanged(ScrollChangedEventArgs).)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides TreeListBoxPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | ProcessKeyDown | Processes a key down event. (Inherited from TreeListBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path. (Inherited from TreeListBox.)
 | SetColumnHeaderVisibility | Sets the value of the ColumnHeaderVisibility attached property to the specified object.
 | SetFrozenColumnsWidth | Sets the value of the FrozenColumnsWidth attached property to the specified object.
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | SizeAllColumnsToFit | Sizes all non-star width columns to fit.
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ColumnHeaderMenuRequested | Occurs when a column header requests a context menu.
Public event | ColumnHeaderTapped | Occurs when a column's header is tapped.
Public event | ColumnIsVisibleChanged | Occurs when a column's visibility has changed.
Public event | ColumnReordered | Occurs after a column is reordered by the end user.
Public event | ColumnsResized | Occurs after the ActualWidth of one or more columns changes.
Public event | IsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed. (Inherited from TreeListBox.)
Public event | ItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Public event | ItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Public event | ItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Public event | ItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Public event | ItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | RootItemChanged | Occurs after the RootItem property is changed. (Inherited from TreeListBox.)
Public event | SelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Top
Fields
Name | Description
AreColumnHeadersVisibleProperty | Identifies the AreColumnHeadersVisible dependency property. This field is read-only.
CanColumnsReorderProperty | Identifies the CanColumnsReorder dependency property. This field is read-only.
CanColumnsResizeProperty | Identifies the CanColumnsResize dependency property. This field is read-only.
CanColumnsToggleVisibilityProperty | Identifies the CanColumnsToggleVisibility dependency property. This field is read-only.
ColumnHeaderHeightProperty | Identifies the ColumnHeaderHeight dependency property. This field is read-only.
ColumnHeaderMenuRequestedEvent | Identifies the ColumnHeaderMenuRequested routed event. This field is read-only.
ColumnHeaderTappedEvent | Identifies the ColumnHeaderTapped routed event. This field is read-only.
ColumnHeaderVisibilityProperty | Identifies the ColumnHeaderVisibility dependency property. This field is read-only.
ColumnIsVisibleChangedEvent | Identifies the ColumnIsVisibleChanged routed event. This field is read-only.
ColumnReorderedEvent | Identifies the ColumnReordered routed event. This field is read-only.
ColumnsResizedEvent | Identifies the ColumnsResized routed event. This field is read-only.
ExpansionColumnIndexProperty | Identifies the ExpansionColumnIndex dependency property. This field is read-only.
FrozenColumnCountProperty | Identifies the FrozenColumnCount dependency property. This field is read-only.
FrozenColumnsWidthProperty | Identifies the FrozenColumnsWidth dependency property. This field is read-only.
IsDefaultColumnHeaderContextMenuEnabledProperty | Identifies the IsDefaultColumnHeaderContextMenuEnabled dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | ColumnHeaderVisibility |
Public attached property | FrozenColumnsWidth |
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView Constructor

Initializes an instance of the TreeListView class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListView()
Public Sub New
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView Properties

The TreeListView type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreColumnHeadersVisible | Gets or sets whether column headers are visible.
Protected property | AssemblyInfo | Gets the AssemblyInfo to use. (Inherited from TreeListBox.)
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanColumnsReorder | Gets or sets whether columns can be reordered by the end user.
Public property | CanColumnsResize | Gets or sets whether columns can be resized by the end user.
Public property | CanColumnsToggleVisibility | Gets or sets whether columns can have their visibility toggled by the end user.
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items. (Inherited from TreeListBox.)
Protected property | CanExpandAll | Gets whether any expand all operations can occur. (Inherited from TreeListBox.)
Public property | ColumnHeaderHeight | Gets the height of the column header.
Public property | Columns | Gets the collection of columns in the control.
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | EmptyContent | Gets or sets the content to display when there are no items visible in the control. (Inherited from TreeListBox.)
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no items visible in the control. (Inherited from TreeListBox.)
Public property | ExpansionColumnIndex | Gets or sets the index of the columns that contains the indentation and expander button.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility.
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level. (Inherited from TreeListBox.)
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled. (Inherited from TreeListBox.)
Public property | IsDefaultColumnHeaderContextMenuEnabled | Gets or sets whether the default column header context menu is enabled.
Public property | IsEmpty | Gets whether the control is currently empty (doesn't contain any visible items). (Inherited from TreeListBox.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active. (Inherited from TreeListBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Protected property | IsKeyboardFocusWithinContent | Gets whether keyboard focus is within the content area, and not in any header area. (Overrides TreeListBoxIsKeyboardFocusWithinContent.)
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items. (Inherited from TreeListBox.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc. (Inherited from TreeListBox.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved. (Inherited from TreeListBox.)
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved. (Inherited from TreeListBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses. (Inherited from TreeListBox.)
Public property | RootItem | Gets or sets the root item to display in the control. (Inherited from TreeListBox.)
Public property | SelectedItem | Gets or sets the primary selected item. (Inherited from TreeListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from TreeListBox.)
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior. (Inherited from TreeListBox.)
Public property | SizeAllColumnsToFitCommand | Gets the ICommand that sizes all non-star width columns to fit.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item. (Inherited from TreeListBox.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.AreColumnHeadersVisible Property

TreeListViewAreColumnHeadersVisible Property

Gets or sets whether column headers are visible.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreColumnHeadersVisible { get; set; }
Public Property AreColumnHeadersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if column headers are visible; otherwise, false. The default value is true.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.CanColumnsReorder Property

TreeListViewCanColumnsReorder Property

Gets or sets whether columns can be reordered by the end user.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanColumnsReorder { get; set; }
Public Property CanColumnsReorder As Boolean
    Get
    Set

Property Value

Type: Boolean
true if columns can be reordered by the end user; otherwise, false. The default value is false.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.CanColumnsResize Property

TreeListViewCanColumnsResize Property

Gets or sets whether columns can be resized by the end user.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanColumnsResize { get; set; }
Public Property CanColumnsResize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if columns can be resized by the end user; otherwise, false. The default value is true.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.CanColumnsToggleVisibility Property

TreeListViewCanColumnsToggleVisibility Property

Gets or sets whether columns can have their visibility toggled by the end user.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanColumnsToggleVisibility { get; set; }
Public Property CanColumnsToggleVisibility As Boolean
    Get
    Set

Property Value

Type: Boolean
true if columns can have their visibility toggled by the end user; otherwise, false. The default value is false.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnHeaderHeight Property

TreeListViewColumnHeaderHeight Property

Gets the height of the column header.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ColumnHeaderHeight { get; }
Public ReadOnly Property ColumnHeaderHeight As Double
    Get

Property Value

Type: Double
The height of the column header.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.Columns Property

TreeListViewColumns Property

Gets the collection of columns in the control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<TreeListViewColumn> Columns { get; }
Public ReadOnly Property Columns As ObservableCollection(Of TreeListViewColumn)
    Get

Property Value

Type: ObservableCollection TreeListViewColumn
The collection of columns in the control.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ExpansionColumnIndex Property

TreeListViewExpansionColumnIndex Property

Gets or sets the index of the columns that contains the indentation and expander button.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int ExpansionColumnIndex { get; set; }
Public Property ExpansionColumnIndex As Integer
    Get
    Set

Property Value

Type: Int32
The index of the columns that contains the indentation and expander button. The default value is 0.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.FrozenColumnCount Property

TreeListViewFrozenColumnCount Property

Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int FrozenColumnCount { get; set; }
Public Property FrozenColumnCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of non-scrolling columns. The default value is 0.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.IsDefaultColumnHeaderContextMenuEnabled Property

TreeListViewIsDefaultColumnHeaderContextMenuEnabled Property

Gets or sets whether the default column header context menu is enabled.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDefaultColumnHeaderContextMenuEnabled { get; set; }
Public Property IsDefaultColumnHeaderContextMenuEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the default column header context menu is enabled; otherwise, false. The default value is true.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.IsKeyboardFocusWithinContent Property

TreeListViewIsKeyboardFocusWithinContent Property

Gets whether keyboard focus is within the content area, and not in any header area.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsKeyboardFocusWithinContent { get; }
Protected Overrides ReadOnly Property IsKeyboardFocusWithinContent As Boolean
    Get

Property Value

Type: Boolean
true if keyboard focus is within the content area; otherwise, false.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.SizeAllColumnsToFitCommand Property

TreeListViewSizeAllColumnsToFitCommand Property

Gets the ICommand that sizes all non-star width columns to fit.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SizeAllColumnsToFitCommand { get; }
Public ReadOnly Property SizeAllColumnsToFitCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that sizes all non-star width columns to fit.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView Methods

The TreeListView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListBoxArrangeOverride(Size).)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BringItemIntoView | Brings the specified node's container into view. (Inherited from TreeListBox.)
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view. (Inherited from TreeListBox.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides TreeListBoxClearContainerForItemOverride(DependencyObject, Object).)
Public method | CollapseAll | Collapses all known tree items. (Inherited from TreeListBox.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | CreateSelectionBatch | Creates an IDisposable object that wraps a batch of selection updates, and allows them to be made without raising selection-related events in between each one. (Inherited from TreeListBox.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | ExpandAll | Expands all known tree items. (Inherited from TreeListBox.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed. (Inherited from TreeListBox.)
 | GetColumnHeaderVisibility | Gets the value of the ColumnHeaderVisibility attached property for the specified object.
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TreeListBoxGetContainerForItemOverride.)
 | GetFrozenColumnsWidth | Gets the value of the FrozenColumnsWidth attached property for the specified object.
Public method | GetFullPath | Returns the full path of the specified item. (Inherited from TreeListBox.)
Public method | GetItemByFullPath | Returns the item with the specified full path. (Inherited from TreeListBox.)
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item. (Inherited from TreeListBox.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried. (Inherited from TreeListBox.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TreeListBoxIsItemItsOwnContainerOverride(Object).)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides ControlMeasureOverride(Size).)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListBoxOnApplyTemplate.)
Protected method | OnColumnHeaderMenuRequested | Occurs when a column header requests a context menu.
Protected method | OnColumnHeaderTapped | Occurs when a column's header is tapped.
Protected method | OnColumnIsVisibleChanged | Occurs when a column's visibility has changed.
Protected method | OnColumnReordered | Occurs after a column is reordered by the end user.
Protected method | OnColumnsResized | Occurs after the ActualWidth of one or more columns changes.
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TreeListBoxOnCreateAutomationPeer.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBox.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBox.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBox.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBox.)
Protected method | OnGotKeyboardFocus | Occurs when the control gains keyboard focus. (Inherited from TreeListBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnIsKeyboardFocusWithinChanged | Occurs when the property value has changed. (Inherited from TreeListBox.)
Protected method | OnIsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed. (Inherited from TreeListBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Protected method | OnItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource property is changed. (Inherited from TreeListBox.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from TreeListBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs after the RootItem property is changed. (Inherited from TreeListBox.)
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed. (Overrides TreeListBoxOnScrollViewerScrollChanged(ScrollChangedEventArgs).)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides TreeListBoxPrepareContainerForItemOverride(DependencyObject, Object).)
Protected method | ProcessKeyDown | Processes a key down event. (Inherited from TreeListBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path. (Inherited from TreeListBox.)
 | SetColumnHeaderVisibility | Sets the value of the ColumnHeaderVisibility attached property to the specified object.
 | SetFrozenColumnsWidth | Sets the value of the FrozenColumnsWidth attached property to the specified object.
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | SizeAllColumnsToFit | Sizes all non-star width columns to fit.
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ArrangeOverride Method

TreeListViewArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ClearContainerForItemOverride Method

TreeListViewClearContainerForItemOverride Method

Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.GetColumnHeaderVisibility Method

TreeListViewGetColumnHeaderVisibility Method

Gets the value of the ColumnHeaderVisibility attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static Visibility GetColumnHeaderVisibility(
    ScrollViewer obj
)
Public Shared Function GetColumnHeaderVisibility (
    obj As ScrollViewer
) As Visibility

Parameters

obj
Type: System.Windows.ControlsScrollViewer
The object from which the property value is read.

Return Value

Type: Visibility
The object's value.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.GetContainerForItemOverride Method

TreeListViewGetContainerForItemOverride Method

Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.GetFrozenColumnsWidth Method

TreeListViewGetFrozenColumnsWidth Method

Gets the value of the FrozenColumnsWidth attached property for the specified object.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetFrozenColumnsWidth(
    ScrollViewer obj
)
Public Shared Function GetFrozenColumnsWidth (
    obj As ScrollViewer
) As Double

Parameters

obj
Type: System.Windows.ControlsScrollViewer
The object from which the property value is read.

Return Value

Type: Double
The object's value.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.IsItemItsOwnContainerOverride Method

TreeListViewIsItemItsOwnContainerOverride Method

Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.MeasureOverride Method

TreeListViewMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.OnApplyTemplate Method

TreeListViewOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.OnColumnHeaderMenuRequested Method

TreeListViewOnColumnHeaderMenuRequested Method

Occurs when a column header requests a context menu.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnColumnHeaderMenuRequested(
    TreeListViewColumnMenuEventArgs e
)
Protected Overridable Sub OnColumnHeaderMenuRequested (
    e As TreeListViewColumnMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumnMenuEventArgs
The TreeListViewColumnMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.OnColumnHeaderTapped Method

TreeListViewOnColumnHeaderTapped Method

Occurs when a column's header is tapped.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnColumnHeaderTapped(
    TreeListViewColumnEventArgs e
)
Protected Overridable Sub OnColumnHeaderTapped (
    e As TreeListViewColumnEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumnEventArgs
The TreeListViewColumnEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.OnColumnIsVisibleChanged Method

TreeListViewOnColumnIsVisibleChanged Method

Occurs when a column's visibility has changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnColumnIsVisibleChanged(
    TreeListViewColumnEventArgs e
)
Protected Overridable Sub OnColumnIsVisibleChanged (
    e As TreeListViewColumnEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumnEventArgs
The TreeListViewColumnEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.OnColumnReordered Method

TreeListViewOnColumnReordered Method

Occurs after a column is reordered by the end user.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnColumnReordered(
    TreeListViewColumnEventArgs e
)
Protected Overridable Sub OnColumnReordered (
    e As TreeListViewColumnEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumnEventArgs
The TreeListViewColumnEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.OnColumnsResized Method

TreeListViewOnColumnsResized Method

Occurs after the ActualWidth of one or more columns changes.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnColumnsResized(
    RoutedEventArgs e
)
Protected Overridable Sub OnColumnsResized (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.OnCreateAutomationPeer Method

TreeListViewOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.OnScrollViewerScrollChanged Method

TreeListViewOnScrollViewerScrollChanged Method

Occurs when the scroll viewer's scroll is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnScrollViewerScrollChanged(
    ScrollChangedEventArgs e
)
Protected Overrides Sub OnScrollViewerScrollChanged (
    e As ScrollChangedEventArgs
)

Parameters

e
Type: System.Windows.ControlsScrollChangedEventArgs
The ScrollChangedEventArgs that contains data related to the event.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.PrepareContainerForItemOverride Method

TreeListViewPrepareContainerForItemOverride Method

Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: System.WindowsDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.SetColumnHeaderVisibility Method

TreeListViewSetColumnHeaderVisibility Method

Sets the value of the ColumnHeaderVisibility attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetColumnHeaderVisibility(
    ScrollViewer obj,
    Visibility value
)
Public Shared Sub SetColumnHeaderVisibility (
    obj As ScrollViewer,
    value As Visibility
)

Parameters

obj
Type: System.Windows.ControlsScrollViewer
The object to which the attached property is written.
value
Type: System.WindowsVisibility
The value to set.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.SetFrozenColumnsWidth Method

TreeListViewSetFrozenColumnsWidth Method

Sets the value of the FrozenColumnsWidth attached property to the specified object.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetFrozenColumnsWidth(
    ScrollViewer obj,
    double value
)
Public Shared Sub SetFrozenColumnsWidth (
    obj As ScrollViewer,
    value As Double
)

Parameters

obj
Type: System.Windows.ControlsScrollViewer
The object to which the attached property is written.
value
Type: SystemDouble
The value to set.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.SizeAllColumnsToFit Method

TreeListViewSizeAllColumnsToFit Method

Sizes all non-star width columns to fit.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SizeAllColumnsToFit()
Public Sub SizeAllColumnsToFit
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView Events

The TreeListView type exposes the following members.

Events
 | Name | Description
Public event | ColumnHeaderMenuRequested | Occurs when a column header requests a context menu.
Public event | ColumnHeaderTapped | Occurs when a column's header is tapped.
Public event | ColumnIsVisibleChanged | Occurs when a column's visibility has changed.
Public event | ColumnReordered | Occurs after a column is reordered by the end user.
Public event | ColumnsResized | Occurs after the ActualWidth of one or more columns changes.
Public event | IsRootItemVisibleChanged | Occurs after the IsRootItemVisible property is changed. (Inherited from TreeListBox.)
Public event | ItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Public event | ItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Public event | ItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Public event | ItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Public event | ItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | RootItemChanged | Occurs after the RootItem property is changed. (Inherited from TreeListBox.)
Public event | SelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Top
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnHeaderMenuRequested Event

TreeListViewColumnHeaderMenuRequested Event

Occurs when a column header requests a context menu.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListViewColumnMenuEventArgs> ColumnHeaderMenuRequested
Public Event ColumnHeaderMenuRequested As EventHandler(Of TreeListViewColumnMenuEventArgs)

Value

Type: SystemEventHandler TreeListViewColumnMenuEventArgs
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnHeaderTapped Event

TreeListViewColumnHeaderTapped Event

Occurs when a column's header is tapped.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListViewColumnEventArgs> ColumnHeaderTapped
Public Event ColumnHeaderTapped As EventHandler(Of TreeListViewColumnEventArgs)

Value

Type: SystemEventHandler TreeListViewColumnEventArgs
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnIsVisibleChanged Event

TreeListViewColumnIsVisibleChanged Event

Occurs when a column's visibility has changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListViewColumnEventArgs> ColumnIsVisibleChanged
Public Event ColumnIsVisibleChanged As EventHandler(Of TreeListViewColumnEventArgs)

Value

Type: SystemEventHandler TreeListViewColumnEventArgs
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnReordered Event

TreeListViewColumnReordered Event

Occurs after a column is reordered by the end user.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListViewColumnEventArgs> ColumnReordered
Public Event ColumnReordered As EventHandler(Of TreeListViewColumnEventArgs)

Value

Type: SystemEventHandler TreeListViewColumnEventArgs
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnsResized Event

TreeListViewColumnsResized Event

Occurs after the ActualWidth of one or more columns changes.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event RoutedEventHandler ColumnsResized
Public Event ColumnsResized As RoutedEventHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView Fields

The TreeListView type exposes the following members.

Fields
Name | Description
AreColumnHeadersVisibleProperty | Identifies the AreColumnHeadersVisible dependency property. This field is read-only.
CanColumnsReorderProperty | Identifies the CanColumnsReorder dependency property. This field is read-only.
CanColumnsResizeProperty | Identifies the CanColumnsResize dependency property. This field is read-only.
CanColumnsToggleVisibilityProperty | Identifies the CanColumnsToggleVisibility dependency property. This field is read-only.
ColumnHeaderHeightProperty | Identifies the ColumnHeaderHeight dependency property. This field is read-only.
ColumnHeaderMenuRequestedEvent | Identifies the ColumnHeaderMenuRequested routed event. This field is read-only.
ColumnHeaderTappedEvent | Identifies the ColumnHeaderTapped routed event. This field is read-only.
ColumnHeaderVisibilityProperty | Identifies the ColumnHeaderVisibility dependency property. This field is read-only.
ColumnIsVisibleChangedEvent | Identifies the ColumnIsVisibleChanged routed event. This field is read-only.
ColumnReorderedEvent | Identifies the ColumnReordered routed event. This field is read-only.
ColumnsResizedEvent | Identifies the ColumnsResized routed event. This field is read-only.
ExpansionColumnIndexProperty | Identifies the ExpansionColumnIndex dependency property. This field is read-only.
FrozenColumnCountProperty | Identifies the FrozenColumnCount dependency property. This field is read-only.
FrozenColumnsWidthProperty | Identifies the FrozenColumnsWidth dependency property. This field is read-only.
IsDefaultColumnHeaderContextMenuEnabledProperty | Identifies the IsDefaultColumnHeaderContextMenuEnabled dependency property. This field is read-only.
Top
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.AreColumnHeadersVisibleProperty Field

TreeListViewAreColumnHeadersVisibleProperty Field

Identifies the AreColumnHeadersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreColumnHeadersVisibleProperty
Public Shared ReadOnly AreColumnHeadersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreColumnHeadersVisible dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.CanColumnsReorderProperty Field

TreeListViewCanColumnsReorderProperty Field

Identifies the CanColumnsReorder dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanColumnsReorderProperty
Public Shared ReadOnly CanColumnsReorderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanColumnsReorder dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.CanColumnsResizeProperty Field

TreeListViewCanColumnsResizeProperty Field

Identifies the CanColumnsResize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanColumnsResizeProperty
Public Shared ReadOnly CanColumnsResizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanColumnsResize dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.CanColumnsToggleVisibilityProperty Field

TreeListViewCanColumnsToggleVisibilityProperty Field

Identifies the CanColumnsToggleVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanColumnsToggleVisibilityProperty
Public Shared ReadOnly CanColumnsToggleVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanColumnsToggleVisibility dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnHeaderHeightProperty Field

TreeListViewColumnHeaderHeightProperty Field

Identifies the ColumnHeaderHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColumnHeaderHeightProperty
Public Shared ReadOnly ColumnHeaderHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ColumnHeaderHeight dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnHeaderMenuRequestedEvent Field

TreeListViewColumnHeaderMenuRequestedEvent Field

Identifies the ColumnHeaderMenuRequested routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ColumnHeaderMenuRequestedEvent
Public Shared ReadOnly ColumnHeaderMenuRequestedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ColumnHeaderMenuRequested routed event.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnHeaderTappedEvent Field

TreeListViewColumnHeaderTappedEvent Field

Identifies the ColumnHeaderTapped routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ColumnHeaderTappedEvent
Public Shared ReadOnly ColumnHeaderTappedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ColumnHeaderTapped routed event.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnHeaderVisibilityProperty Field

TreeListViewColumnHeaderVisibilityProperty Field

Identifies the ColumnHeaderVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColumnHeaderVisibilityProperty
Public Shared ReadOnly ColumnHeaderVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ColumnHeaderVisibility dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnIsVisibleChangedEvent Field

TreeListViewColumnIsVisibleChangedEvent Field

Identifies the ColumnIsVisibleChanged routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ColumnIsVisibleChangedEvent
Public Shared ReadOnly ColumnIsVisibleChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ColumnIsVisibleChanged routed event.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnReorderedEvent Field

TreeListViewColumnReorderedEvent Field

Identifies the ColumnReordered routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ColumnReorderedEvent
Public Shared ReadOnly ColumnReorderedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ColumnReordered routed event.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnsResizedEvent Field

TreeListViewColumnsResizedEvent Field

Identifies the ColumnsResized routed event. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly RoutedEvent ColumnsResizedEvent
Public Shared ReadOnly ColumnsResizedEvent As RoutedEvent

Field Value

Type: RoutedEvent
The identifier for the ColumnsResized routed event.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ExpansionColumnIndexProperty Field

TreeListViewExpansionColumnIndexProperty Field

Identifies the ExpansionColumnIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ExpansionColumnIndexProperty
Public Shared ReadOnly ExpansionColumnIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ExpansionColumnIndex dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.FrozenColumnCountProperty Field

TreeListViewFrozenColumnCountProperty Field

Identifies the FrozenColumnCount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FrozenColumnCountProperty
Public Shared ReadOnly FrozenColumnCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FrozenColumnCount dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.FrozenColumnsWidthProperty Field

TreeListViewFrozenColumnsWidthProperty Field

Identifies the FrozenColumnsWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FrozenColumnsWidthProperty
Public Shared ReadOnly FrozenColumnsWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FrozenColumnsWidth dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.IsDefaultColumnHeaderContextMenuEnabledProperty Field

TreeListViewIsDefaultColumnHeaderContextMenuEnabledProperty Field

Identifies the IsDefaultColumnHeaderContextMenuEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDefaultColumnHeaderContextMenuEnabledProperty
Public Shared ReadOnly IsDefaultColumnHeaderContextMenuEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDefaultColumnHeaderContextMenuEnabled dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView Attached Properties

The TreeListView type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | ColumnHeaderVisibility |
Public attached property | FrozenColumnsWidth |
Top
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.ColumnHeaderVisibility Attached Property

TreeListViewColumnHeaderVisibility Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.TreeListView.ColumnHeaderVisibility"]

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetColumnHeaderVisibility, SetColumnHeaderVisibility
See GetColumnHeaderVisibility, SetColumnHeaderVisibility

Property Value

Type: Visibility
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListView.FrozenColumnsWidth Attached Property

TreeListViewFrozenColumnsWidth Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.TreeListView.FrozenColumnsWidth"]

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetFrozenColumnsWidth, SetFrozenColumnsWidth
See GetFrozenColumnsWidth, SetFrozenColumnsWidth

Property Value

Type: Double
See Also

Reference

TreeListView Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn Class

Represents a column definition for a TreeListView control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.Controls.GridsTreeListViewColumn

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewColumn : DependencyObject,
    INotifyPropertyChanged
Public Class TreeListViewColumn
    Inherits DependencyObject
    Implements INotifyPropertyChanged

The TreeListViewColumn type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumn | Initializes an instance of the TreeListViewColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the actual width of the column.
Public property | AutoWidthMode | Gets or sets the TreeListViewColumnAutoWidthMode that specifies which column cells are used to calculate auto-width when Width is Auto.
Public property | CanReorder | Gets or sets whether the column can be reordered by the end user.
Public property | CanResize | Gets or sets whether the column can be resized by the end user.
Public property | CanToggleVisibility | Gets or sets whether the column can have its visibility toggled by the end user.
Public property | CellBorderThickness | Gets or sets the Thickness of the border around cells in this column.
Public property | CellContainerStyle | Gets or sets the Style that defines the visual representation of the column's cells.
Public property | CellHorizontalAlignment | Gets or sets the HorizontalAlignment of the cell content in this column.
Public property | CellPadding | Gets or sets the Thickness of the padding in cells in this column.
Public property | CellTemplate | Gets or sets the DataTemplate that defines the visual representation of the column's cells.
Public property | CellTemplateSelector | Gets or sets the DataTemplateSelector that selects which template to use for the column's cells.
Public property | CellVerticalAlignment | Gets or sets the VerticalAlignment of the cell content in this column.
Public property | ClipX | Gets the clip x-location.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberBinding | Gets or sets the data item to bind to for this column.
Public property | Header | Gets or sets the column header content.
Public property | HeaderCellBorderThickness | Gets or sets the Thickness of the border around the header cell in this column.
Public property | HeaderCellPadding | Gets or sets the Thickness of the padding in the header cell in this column.
Public property | HeaderContainerStyle | Gets or sets the Style to use for the column header container.
Public property | HeaderHorizontalAlignment | Gets or sets the HorizontalAlignment of the column header content.
Public property | HeaderTemplate | Gets or sets the DataTemplate that defines the visual representation of the column header.
Public property | HeaderTemplateSelector | Gets or sets the DataTemplateSelector that selects which template to use for the column header.
Public property | Index | Gets the index of the column within its owner control.
Public property | IsFrozen | Gets whether the column is frozen.
Public property | IsResizeGripperEnabled | Gets whether the column's resize gripper is enabled.
Public property | IsVisible | Gets or sets whether the column is visible.
Public property | MaxWidth | Gets or sets the maximum column width.
Public property | MinWidth | Gets or sets the minimum column width.
Public property | SizeToFitCommand | Gets the ICommand that adjusts the width of the column to fit all of its contents.
Public property | SortDirection | Gets or sets the column sort direction.
Public property | Title | Gets or sets the string title of the column, used in context menus and other secondary UI, but not visible within the column itself.
Public property | ToggleVisibilityCommand | Gets the ICommand that can be used to toggle the column's visibility.
Public property | Width | Gets or sets the column width.
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | SizeToFit | Adjusts the width of the column to fit all of its contents.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
Fields
Name | Description
AutoWidthModeProperty | Identifies the AutoWidthMode dependency property. This field is read-only.
CanReorderProperty | Identifies the CanReorder dependency property. This field is read-only.
CanResizeProperty | Identifies the CanResize dependency property. This field is read-only.
CanToggleVisibilityProperty | Identifies the CanToggleVisibility dependency property. This field is read-only.
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property. This field is read-only.
CellContainerStyleProperty | Identifies the CellContainerStyle dependency property. This field is read-only.
CellHorizontalAlignmentProperty | Identifies the CellHorizontalAlignment dependency property. This field is read-only.
CellPaddingProperty | Identifies the CellPadding dependency property. This field is read-only.
CellTemplateProperty | Identifies the CellTemplate dependency property. This field is read-only.
CellTemplateSelectorProperty | Identifies the CellTemplateSelector dependency property. This field is read-only.
CellVerticalAlignmentProperty | Identifies the CellVerticalAlignment dependency property. This field is read-only.
HeaderCellBorderThicknessProperty | Identifies the HeaderCellBorderThickness dependency property. This field is read-only.
HeaderCellPaddingProperty | Identifies the HeaderCellPadding dependency property. This field is read-only.
HeaderContainerStyleProperty | Identifies the HeaderContainerStyle dependency property. This field is read-only.
HeaderHorizontalAlignmentProperty | Identifies the HeaderHorizontalAlignment dependency property. This field is read-only.
HeaderProperty | Identifies the Header dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector dependency property. This field is read-only.
IndexProperty | Identifies the Index dependency property. This field is read-only.
IsFrozenProperty | Identifies the IsFrozen dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
IsVisibleProperty | Identifies the IsVisible dependency property. This field is read-only.
MaxWidthProperty | Identifies the MaxWidth dependency property. This field is read-only.
MinWidthProperty | Identifies the MinWidth dependency property. This field is read-only.
SortDirectionProperty | Identifies the SortDirection dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
WidthProperty | Identifies the Width dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn Constructor

Initializes an instance of the TreeListViewColumn class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewColumn()
Public Sub New
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn Properties

The TreeListViewColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the actual width of the column.
Public property | AutoWidthMode | Gets or sets the TreeListViewColumnAutoWidthMode that specifies which column cells are used to calculate auto-width when Width is Auto.
Public property | CanReorder | Gets or sets whether the column can be reordered by the end user.
Public property | CanResize | Gets or sets whether the column can be resized by the end user.
Public property | CanToggleVisibility | Gets or sets whether the column can have its visibility toggled by the end user.
Public property | CellBorderThickness | Gets or sets the Thickness of the border around cells in this column.
Public property | CellContainerStyle | Gets or sets the Style that defines the visual representation of the column's cells.
Public property | CellHorizontalAlignment | Gets or sets the HorizontalAlignment of the cell content in this column.
Public property | CellPadding | Gets or sets the Thickness of the padding in cells in this column.
Public property | CellTemplate | Gets or sets the DataTemplate that defines the visual representation of the column's cells.
Public property | CellTemplateSelector | Gets or sets the DataTemplateSelector that selects which template to use for the column's cells.
Public property | CellVerticalAlignment | Gets or sets the VerticalAlignment of the cell content in this column.
Public property | ClipX | Gets the clip x-location.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberBinding | Gets or sets the data item to bind to for this column.
Public property | Header | Gets or sets the column header content.
Public property | HeaderCellBorderThickness | Gets or sets the Thickness of the border around the header cell in this column.
Public property | HeaderCellPadding | Gets or sets the Thickness of the padding in the header cell in this column.
Public property | HeaderContainerStyle | Gets or sets the Style to use for the column header container.
Public property | HeaderHorizontalAlignment | Gets or sets the HorizontalAlignment of the column header content.
Public property | HeaderTemplate | Gets or sets the DataTemplate that defines the visual representation of the column header.
Public property | HeaderTemplateSelector | Gets or sets the DataTemplateSelector that selects which template to use for the column header.
Public property | Index | Gets the index of the column within its owner control.
Public property | IsFrozen | Gets whether the column is frozen.
Public property | IsResizeGripperEnabled | Gets whether the column's resize gripper is enabled.
Public property | IsVisible | Gets or sets whether the column is visible.
Public property | MaxWidth | Gets or sets the maximum column width.
Public property | MinWidth | Gets or sets the minimum column width.
Public property | SizeToFitCommand | Gets the ICommand that adjusts the width of the column to fit all of its contents.
Public property | SortDirection | Gets or sets the column sort direction.
Public property | Title | Gets or sets the string title of the column, used in context menus and other secondary UI, but not visible within the column itself.
Public property | ToggleVisibilityCommand | Gets the ICommand that can be used to toggle the column's visibility.
Public property | Width | Gets or sets the column width.
Top
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.ActualWidth Property

TreeListViewColumnActualWidth Property

Gets the actual width of the column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ActualWidth { get; }
Public ReadOnly Property ActualWidth As Double
    Get

Property Value

Type: Double
The actual width of the column.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.AutoWidthMode Property

TreeListViewColumnAutoWidthMode Property

Gets or sets the TreeListViewColumnAutoWidthMode that specifies which column cells are used to calculate auto-width when Width is Auto.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewColumnAutoWidthMode AutoWidthMode { get; set; }
Public Property AutoWidthMode As TreeListViewColumnAutoWidthMode
    Get
    Set

Property Value

Type: TreeListViewColumnAutoWidthMode
The TreeListViewColumnAutoWidthMode that specifies which column cells are used to calculate auto-width when Width is Auto.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CanReorder Property

TreeListViewColumnCanReorder Property

Gets or sets whether the column can be reordered by the end user.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanReorder { get; set; }
Public Property CanReorder As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the column can be reordered by the end user.
Remarks
If set to , the resolved value will use the global CanColumnsReorder setting.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CanResize Property

TreeListViewColumnCanResize Property

Gets or sets whether the column can be resized by the end user.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanResize { get; set; }
Public Property CanResize As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the column can be resized by the end user.
Remarks
If set to , the resolved value will use the global CanColumnsResize setting.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CanToggleVisibility Property

TreeListViewColumnCanToggleVisibility Property

Gets or sets whether the column can have its visibility toggled by the end user.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<bool> CanToggleVisibility { get; set; }
Public Property CanToggleVisibility As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the column can have its visibility toggled by the end user.
Remarks
If set to , the resolved value will use the global CanColumnsToggleVisibility setting.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellBorderThickness Property

TreeListViewColumnCellBorderThickness Property

Gets or sets the Thickness of the border around cells in this column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness CellBorderThickness { get; set; }
Public Property CellBorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the border around cells in this column. The default value is 0.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellContainerStyle Property

TreeListViewColumnCellContainerStyle Property

Gets or sets the Style that defines the visual representation of the column's cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style CellContainerStyle { get; set; }
Public Property CellContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that defines the visual representation of the column's cells.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellHorizontalAlignment Property

TreeListViewColumnCellHorizontalAlignment Property

Gets or sets the HorizontalAlignment of the cell content in this column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public HorizontalAlignment CellHorizontalAlignment { get; set; }
Public Property CellHorizontalAlignment As HorizontalAlignment
    Get
    Set

Property Value

Type: HorizontalAlignment
The HorizontalAlignment of the cell content in this column. The default value is Stretch.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellPadding Property

TreeListViewColumnCellPadding Property

Gets or sets the Thickness of the padding in cells in this column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness CellPadding { get; set; }
Public Property CellPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the padding in cells in this column. The default value is 7, 2.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellTemplate Property

TreeListViewColumnCellTemplate Property

Gets or sets the DataTemplate that defines the visual representation of the column's cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate CellTemplate { get; set; }
Public Property CellTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate that defines the visual representation of the column's cells.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellTemplateSelector Property

TreeListViewColumnCellTemplateSelector Property

Gets or sets the DataTemplateSelector that selects which template to use for the column's cells.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector CellTemplateSelector { get; set; }
Public Property CellTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector that selects which template to use for the column's cells.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellVerticalAlignment Property

TreeListViewColumnCellVerticalAlignment Property

Gets or sets the VerticalAlignment of the cell content in this column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public VerticalAlignment CellVerticalAlignment { get; set; }
Public Property CellVerticalAlignment As VerticalAlignment
    Get
    Set

Property Value

Type: VerticalAlignment
The VerticalAlignment of the cell content in this column. The default value is Center.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.ClipX Property

TreeListViewColumnClipX Property

Gets the clip x-location.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ClipX { get; }
Public ReadOnly Property ClipX As Double
    Get

Property Value

Type: Double
The clip x-location.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.DisplayMemberBinding Property

TreeListViewColumnDisplayMemberBinding Property

Gets or sets the data item to bind to for this column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BindingBase DisplayMemberBinding { get; set; }
Public Property DisplayMemberBinding As BindingBase
    Get
    Set

Property Value

Type: BindingBase
The data item to bind to for this column.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.Header Property

TreeListViewColumnHeader Property

Gets or sets the column header content.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Header { get; set; }
Public Property Header As Object
    Get
    Set

Property Value

Type: Object
The column header content.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderCellBorderThickness Property

TreeListViewColumnHeaderCellBorderThickness Property

Gets or sets the Thickness of the border around the header cell in this column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness HeaderCellBorderThickness { get; set; }
Public Property HeaderCellBorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the border around the header cell in this column. The default value is 0, 0, 1, 1.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderCellPadding Property

TreeListViewColumnHeaderCellPadding Property

Gets or sets the Thickness of the padding in the header cell in this column.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness HeaderCellPadding { get; set; }
Public Property HeaderCellPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the padding in the header cell in this column. The default value is 7, 2.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderContainerStyle Property

TreeListViewColumnHeaderContainerStyle Property

Gets or sets the Style to use for the column header container.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style HeaderContainerStyle { get; set; }
Public Property HeaderContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the column header container.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderHorizontalAlignment Property

TreeListViewColumnHeaderHorizontalAlignment Property

Gets or sets the HorizontalAlignment of the column header content.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public HorizontalAlignment HeaderHorizontalAlignment { get; set; }
Public Property HeaderHorizontalAlignment As HorizontalAlignment
    Get
    Set

Property Value

Type: HorizontalAlignment
The HorizontalAlignment of the column header content.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderTemplate Property

TreeListViewColumnHeaderTemplate Property

Gets or sets the DataTemplate that defines the visual representation of the column header.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate HeaderTemplate { get; set; }
Public Property HeaderTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate that defines the visual representation of the column header.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderTemplateSelector Property

TreeListViewColumnHeaderTemplateSelector Property

Gets or sets the DataTemplateSelector that selects which template to use for the column header.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector HeaderTemplateSelector { get; set; }
Public Property HeaderTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector that selects which template to use for the column header.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.Index Property

TreeListViewColumnIndex Property

Gets the index of the column within its owner control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the column within its owner control.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.IsFrozen Property

TreeListViewColumnIsFrozen Property

Gets whether the column is frozen.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsFrozen { get; }
Public ReadOnly Property IsFrozen As Boolean
    Get

Property Value

Type: Boolean
true if the column is frozen; otherwise, false. The default value is false.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.IsResizeGripperEnabled Property

TreeListViewColumnIsResizeGripperEnabled Property

Gets whether the column's resize gripper is enabled.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsResizeGripperEnabled { get; }
Public ReadOnly Property IsResizeGripperEnabled As Boolean
    Get

Property Value

Type: Boolean
true if the column's resize gripper is enabled; otherwise, false. The default value is true.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.IsVisible Property

TreeListViewColumnIsVisible Property

Gets or sets whether the column is visible.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the column is visible; otherwise, false. The default value is true.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.MaxWidth Property

TreeListViewColumnMaxWidth Property

Gets or sets the maximum column width.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MaxWidth { get; set; }
Public Property MaxWidth As Double
    Get
    Set

Property Value

Type: Double
The maximum column width. The default value is NaN, meaning no maximum.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.MinWidth Property

TreeListViewColumnMinWidth Property

Gets or sets the minimum column width.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MinWidth { get; set; }
Public Property MinWidth As Double
    Get
    Set

Property Value

Type: Double
The minimum column width. The default value is 30.0.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.SizeToFitCommand Property

TreeListViewColumnSizeToFitCommand Property

Gets the ICommand that adjusts the width of the column to fit all of its contents.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand SizeToFitCommand { get; }
Public ReadOnly Property SizeToFitCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that adjusts the width of the column to fit all of its contents.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.SortDirection Property

TreeListViewColumnSortDirection Property

Gets or sets the column sort direction.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<ColumnSortDirection> SortDirection { get; set; }
Public Property SortDirection As Nullable(Of ColumnSortDirection)
    Get
    Set

Property Value

Type: Nullable ColumnSortDirection
The column sort direction. The default value is a null reference, meaning no sort.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.Title Property

TreeListViewColumnTitle Property

Gets or sets the string title of the column, used in context menus and other secondary UI, but not visible within the column itself.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title of the column.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.ToggleVisibilityCommand Property

TreeListViewColumnToggleVisibilityCommand Property

Gets the ICommand that can be used to toggle the column's visibility.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ToggleVisibilityCommand { get; }
Public ReadOnly Property ToggleVisibilityCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to toggle the column's visibility.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.Width Property

TreeListViewColumnWidth Property

Gets or sets the column width.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GridLength Width { get; set; }
Public Property Width As GridLength
    Get
    Set

Property Value

Type: GridLength
The column width. The default value is Auto.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn Methods

The TreeListViewColumn type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | SizeToFit | Adjusts the width of the column to fit all of its contents.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.SizeToFit Method

TreeListViewColumnSizeToFit Method

Adjusts the width of the column to fit all of its contents.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void SizeToFit()
Public Sub SizeToFit
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn Events

The TreeListViewColumn type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.PropertyChanged Event

TreeListViewColumnPropertyChanged Event

Occurs when a property has been changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn Fields

The TreeListViewColumn type exposes the following members.

Fields
Name | Description
AutoWidthModeProperty | Identifies the AutoWidthMode dependency property. This field is read-only.
CanReorderProperty | Identifies the CanReorder dependency property. This field is read-only.
CanResizeProperty | Identifies the CanResize dependency property. This field is read-only.
CanToggleVisibilityProperty | Identifies the CanToggleVisibility dependency property. This field is read-only.
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property. This field is read-only.
CellContainerStyleProperty | Identifies the CellContainerStyle dependency property. This field is read-only.
CellHorizontalAlignmentProperty | Identifies the CellHorizontalAlignment dependency property. This field is read-only.
CellPaddingProperty | Identifies the CellPadding dependency property. This field is read-only.
CellTemplateProperty | Identifies the CellTemplate dependency property. This field is read-only.
CellTemplateSelectorProperty | Identifies the CellTemplateSelector dependency property. This field is read-only.
CellVerticalAlignmentProperty | Identifies the CellVerticalAlignment dependency property. This field is read-only.
HeaderCellBorderThicknessProperty | Identifies the HeaderCellBorderThickness dependency property. This field is read-only.
HeaderCellPaddingProperty | Identifies the HeaderCellPadding dependency property. This field is read-only.
HeaderContainerStyleProperty | Identifies the HeaderContainerStyle dependency property. This field is read-only.
HeaderHorizontalAlignmentProperty | Identifies the HeaderHorizontalAlignment dependency property. This field is read-only.
HeaderProperty | Identifies the Header dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector dependency property. This field is read-only.
IndexProperty | Identifies the Index dependency property. This field is read-only.
IsFrozenProperty | Identifies the IsFrozen dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
IsVisibleProperty | Identifies the IsVisible dependency property. This field is read-only.
MaxWidthProperty | Identifies the MaxWidth dependency property. This field is read-only.
MinWidthProperty | Identifies the MinWidth dependency property. This field is read-only.
SortDirectionProperty | Identifies the SortDirection dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
WidthProperty | Identifies the Width dependency property. This field is read-only.
Top
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.AutoWidthModeProperty Field

TreeListViewColumnAutoWidthModeProperty Field

Identifies the AutoWidthMode dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoWidthModeProperty
Public Shared ReadOnly AutoWidthModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoWidthMode dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CanReorderProperty Field

TreeListViewColumnCanReorderProperty Field

Identifies the CanReorder dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanReorderProperty
Public Shared ReadOnly CanReorderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanReorder dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CanResizeProperty Field

TreeListViewColumnCanResizeProperty Field

Identifies the CanResize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanResizeProperty
Public Shared ReadOnly CanResizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanResize dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CanToggleVisibilityProperty Field

TreeListViewColumnCanToggleVisibilityProperty Field

Identifies the CanToggleVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToggleVisibilityProperty
Public Shared ReadOnly CanToggleVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToggleVisibility dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellBorderThicknessProperty Field

TreeListViewColumnCellBorderThicknessProperty Field

Identifies the CellBorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellBorderThicknessProperty
Public Shared ReadOnly CellBorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellBorderThickness dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellContainerStyleProperty Field

TreeListViewColumnCellContainerStyleProperty Field

Identifies the CellContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellContainerStyleProperty
Public Shared ReadOnly CellContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellContainerStyle dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellHorizontalAlignmentProperty Field

TreeListViewColumnCellHorizontalAlignmentProperty Field

Identifies the CellHorizontalAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellHorizontalAlignmentProperty
Public Shared ReadOnly CellHorizontalAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellHorizontalAlignment dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellPaddingProperty Field

TreeListViewColumnCellPaddingProperty Field

Identifies the CellPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellPaddingProperty
Public Shared ReadOnly CellPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellPadding dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellTemplateProperty Field

TreeListViewColumnCellTemplateProperty Field

Identifies the CellTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellTemplateProperty
Public Shared ReadOnly CellTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellTemplate dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellTemplateSelectorProperty Field

TreeListViewColumnCellTemplateSelectorProperty Field

Identifies the CellTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellTemplateSelectorProperty
Public Shared ReadOnly CellTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellTemplateSelector dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.CellVerticalAlignmentProperty Field

TreeListViewColumnCellVerticalAlignmentProperty Field

Identifies the CellVerticalAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellVerticalAlignmentProperty
Public Shared ReadOnly CellVerticalAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellVerticalAlignment dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderCellBorderThicknessProperty Field

TreeListViewColumnHeaderCellBorderThicknessProperty Field

Identifies the HeaderCellBorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderCellBorderThicknessProperty
Public Shared ReadOnly HeaderCellBorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderCellBorderThickness dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderCellPaddingProperty Field

TreeListViewColumnHeaderCellPaddingProperty Field

Identifies the HeaderCellPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderCellPaddingProperty
Public Shared ReadOnly HeaderCellPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderCellPadding dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderContainerStyleProperty Field

TreeListViewColumnHeaderContainerStyleProperty Field

Identifies the HeaderContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderContainerStyleProperty
Public Shared ReadOnly HeaderContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderContainerStyle dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderHorizontalAlignmentProperty Field

TreeListViewColumnHeaderHorizontalAlignmentProperty Field

Identifies the HeaderHorizontalAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderHorizontalAlignmentProperty
Public Shared ReadOnly HeaderHorizontalAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderHorizontalAlignment dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderProperty Field

TreeListViewColumnHeaderProperty Field

Identifies the Header dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderProperty
Public Shared ReadOnly HeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Header dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderTemplateProperty Field

TreeListViewColumnHeaderTemplateProperty Field

Identifies the HeaderTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderTemplateProperty
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderTemplate dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.HeaderTemplateSelectorProperty Field

TreeListViewColumnHeaderTemplateSelectorProperty Field

Identifies the HeaderTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderTemplateSelectorProperty
Public Shared ReadOnly HeaderTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderTemplateSelector dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.IndexProperty Field

TreeListViewColumnIndexProperty Field

Identifies the Index dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndexProperty
Public Shared ReadOnly IndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Index dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.IsFrozenProperty Field

TreeListViewColumnIsFrozenProperty Field

Identifies the IsFrozen dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFrozenProperty
Public Shared ReadOnly IsFrozenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFrozen dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.IsResizeGripperEnabledProperty Field

TreeListViewColumnIsResizeGripperEnabledProperty Field

Identifies the IsResizeGripperEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizeGripperEnabledProperty
Public Shared ReadOnly IsResizeGripperEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizeGripperEnabled dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.IsVisibleProperty Field

TreeListViewColumnIsVisibleProperty Field

Identifies the IsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsVisibleProperty
Public Shared ReadOnly IsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsVisible dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.MaxWidthProperty Field

TreeListViewColumnMaxWidthProperty Field

Identifies the MaxWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxWidthProperty
Public Shared ReadOnly MaxWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxWidth dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.MinWidthProperty Field

TreeListViewColumnMinWidthProperty Field

Identifies the MinWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinWidthProperty
Public Shared ReadOnly MinWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinWidth dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.SortDirectionProperty Field

TreeListViewColumnSortDirectionProperty Field

Identifies the SortDirection dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortDirectionProperty
Public Shared ReadOnly SortDirectionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortDirection dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.TitleProperty Field

TreeListViewColumnTitleProperty Field

Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumn.WidthProperty Field

TreeListViewColumnWidthProperty Field

Identifies the Width dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WidthProperty
Public Shared ReadOnly WidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Width dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnAutoWidthMode Enumeration

Specifies which column cells are used to calculate auto-width.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TreeListViewColumnAutoWidthMode
Public Enumeration TreeListViewColumnAutoWidthMode
Members
Member name | Value | Description
Both | 0 | Both the header and item cells in this column are used to calculate the width.
HeaderOnly | 1 | Only the header cells in this column are used to calculate the width.
ItemsOnly | 2 | Only the item cells in this column are used to calculate the width.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnEventArgs Class

Provides event arguments for TreeListViewColumn events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListViewColumnEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListViewColumnMenuEventArgs

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewColumnEventArgs : CancelRoutedEventArgs
Public Class TreeListViewColumnEventArgs
    Inherits CancelRoutedEventArgs

The TreeListViewColumnEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumnEventArgs | Initializes a new instance of the TreeListViewColumnEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Column | Gets the target TreeListViewColumn.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnEventArgs Constructor

Initializes a new instance of the TreeListViewColumnEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewColumnEventArgs(
    TreeListViewColumn column
)
Public Sub New (
    column As TreeListViewColumn
)

Parameters

column
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumn
The target TreeListViewColumn.
See Also

Reference

TreeListViewColumnEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnEventArgs Properties

The TreeListViewColumnEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Column | Gets the target TreeListViewColumn.
Top
See Also

Reference

TreeListViewColumnEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnEventArgs.Column Property

TreeListViewColumnEventArgsColumn Property

Gets the target TreeListViewColumn.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewColumn Column { get; }
Public ReadOnly Property Column As TreeListViewColumn
    Get

Property Value

Type: TreeListViewColumn
The target TreeListViewColumn.
See Also

Reference

TreeListViewColumnEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader Class

Represents an item for a TreeListBox control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.GridsTreeListViewColumnHeader

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewColumnHeader : ContentControl
Public Class TreeListViewColumnHeader
    Inherits ContentControl

The TreeListViewColumnHeader type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumnHeader | Initializes an instance of the TreeListViewColumnHeader class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDragging | Gets whether the control is being dragged.
Public property | IsPressed | Gets whether the control is pressed.
Public property | IsResizeGripperEnabled | Gets whether the resizing header gripper is enabled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Role | Gets or sets a TreeListViewColumnHeaderRole that indicates the role of the column header.
Public property | SortDirection | Gets or sets the column sort direction.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Overrides FrameworkElementOnContextMenuOpening(ContextMenuEventArgs).)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
DropIndicatorAreaProperty | Identifies the DropIndicatorArea dependency property. This field is read-only.
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
IsPressedProperty | Identifies the IsPressed dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
RoleProperty | Identifies the Role dependency property. This field is read-only.
SortDirectionProperty | Identifies the SortDirection dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader Constructor

Initializes an instance of the TreeListViewColumnHeader class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewColumnHeader()
Public Sub New
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader Properties

The TreeListViewColumnHeader type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDragging | Gets whether the control is being dragged.
Public property | IsPressed | Gets whether the control is pressed.
Public property | IsResizeGripperEnabled | Gets whether the resizing header gripper is enabled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Role | Gets or sets a TreeListViewColumnHeaderRole that indicates the role of the column header.
Public property | SortDirection | Gets or sets the column sort direction.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.DropIndicatorArea Property

TreeListViewColumnHeaderDropIndicatorArea Property

Gets a TreeItemDropArea that specifies the drop indicator to display.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeItemDropArea DropIndicatorArea { get; }
Public ReadOnly Property DropIndicatorArea As TreeItemDropArea
    Get

Property Value

Type: TreeItemDropArea
The TreeItemDropArea that specifies the drop indicator to display.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.IsDragging Property

TreeListViewColumnHeaderIsDragging Property

Gets whether the control is being dragged.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get

Property Value

Type: Boolean
true if the control is being dragged; otherwise, false. The default value is false.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.IsPressed Property

TreeListViewColumnHeaderIsPressed Property

Gets whether the control is pressed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsPressed { get; }
Public ReadOnly Property IsPressed As Boolean
    Get

Property Value

Type: Boolean
true if the control is pressed; otherwise, false. The default value is false.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.IsResizeGripperEnabled Property

TreeListViewColumnHeaderIsResizeGripperEnabled Property

Gets whether the resizing header gripper is enabled.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsResizeGripperEnabled { get; }
Public ReadOnly Property IsResizeGripperEnabled As Boolean
    Get

Property Value

Type: Boolean
true if the resizing header gripper is enabled; otherwise, false. The default value is false.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.Role Property

TreeListViewColumnHeaderRole Property

Gets or sets a TreeListViewColumnHeaderRole that indicates the role of the column header.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewColumnHeaderRole Role { get; set; }
Public Property Role As TreeListViewColumnHeaderRole
    Get
    Set

Property Value

Type: TreeListViewColumnHeaderRole
A TreeListViewColumnHeaderRole that indicates the role of the column header. The default value is Normal.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.SortDirection Property

TreeListViewColumnHeaderSortDirection Property

Gets or sets the column sort direction.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<ColumnSortDirection> SortDirection { get; set; }
Public Property SortDirection As Nullable(Of ColumnSortDirection)
    Get
    Set

Property Value

Type: Nullable ColumnSortDirection
The column sort direction. The default value is a null reference, meaning no sort.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader Methods

The TreeListViewColumnHeader type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Overrides FrameworkElementOnContextMenuOpening(ContextMenuEventArgs).)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ControlToString.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.OnApplyTemplate Method

TreeListViewColumnHeaderOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.OnContextMenuOpening Method

TreeListViewColumnHeaderOnContextMenuOpening Method

Occurs when a context menu is requested.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnContextMenuOpening(
    ContextMenuEventArgs e
)
Protected Overrides Sub OnContextMenuOpening (
    e As ContextMenuEventArgs
)

Parameters

e
Type: System.Windows.ControlsContextMenuEventArgs
The ContextMenuEventArgs that contains the event data.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.OnGotFocus Method

TreeListViewColumnHeaderOnGotFocus Method

Occurs when the control gains focus.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.OnLostFocus Method

TreeListViewColumnHeaderOnLostFocus Method

Occurs when the control loses focus.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.ToString Method

TreeListViewColumnHeaderToString Method

Returns a String that represents the current Object.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader Events

The TreeListViewColumnHeader type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader Fields

The TreeListViewColumnHeader type exposes the following members.

Fields
Name | Description
DropIndicatorAreaProperty | Identifies the DropIndicatorArea dependency property. This field is read-only.
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
IsPressedProperty | Identifies the IsPressed dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
RoleProperty | Identifies the Role dependency property. This field is read-only.
SortDirectionProperty | Identifies the SortDirection dependency property. This field is read-only.
Top
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.DropIndicatorAreaProperty Field

TreeListViewColumnHeaderDropIndicatorAreaProperty Field

Identifies the DropIndicatorArea dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DropIndicatorAreaProperty
Public Shared ReadOnly DropIndicatorAreaProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DropIndicatorArea dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.IsDraggingProperty Field

TreeListViewColumnHeaderIsDraggingProperty Field

Identifies the IsDragging dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDraggingProperty
Public Shared ReadOnly IsDraggingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDragging dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.IsPressedProperty Field

TreeListViewColumnHeaderIsPressedProperty Field

Identifies the IsPressed dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPressedProperty
Public Shared ReadOnly IsPressedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPressed dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.IsResizeGripperEnabledProperty Field

TreeListViewColumnHeaderIsResizeGripperEnabledProperty Field

Identifies the IsResizeGripperEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizeGripperEnabledProperty
Public Shared ReadOnly IsResizeGripperEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizeGripperEnabled dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.RoleProperty Field

TreeListViewColumnHeaderRoleProperty Field

Identifies the Role dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoleProperty
Public Shared ReadOnly RoleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Role dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeader.SortDirectionProperty Field

TreeListViewColumnHeaderSortDirectionProperty Field

Identifies the SortDirection dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortDirectionProperty
Public Shared ReadOnly SortDirectionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortDirection dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnHeaderRole Enumeration

Specifies the role for a TreeListViewColumnHeader within a TreeListView.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TreeListViewColumnHeaderRole
Public Enumeration TreeListViewColumnHeaderRole
Members
Member name | Value | Description
Normal | 0 | A normal column header.
Padding | 1 | The column header provides padding between the last column and the right end of the control.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnMenuEventArgs Class

Provides event arguments for TreeListViewColumn menu events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
ActiproSoftware.WindowsCancelRoutedEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListViewColumnEventArgs
ActiproSoftware.Windows.Controls.GridsTreeListViewColumnMenuEventArgs

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewColumnMenuEventArgs : TreeListViewColumnEventArgs
Public Class TreeListViewColumnMenuEventArgs
    Inherits TreeListViewColumnEventArgs

The TreeListViewColumnMenuEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumnMenuEventArgs | Initializes a new instance of the TreeListViewColumnMenuEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Column | Gets the target TreeListViewColumn. (Inherited from TreeListViewColumnEventArgs.)
Public property | Menu | Gets or sets the ContextMenu that is about to be displayed.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnMenuEventArgs Constructor

Initializes a new instance of the TreeListViewColumnMenuEventArgs class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewColumnMenuEventArgs(
    TreeListViewColumn column
)
Public Sub New (
    column As TreeListViewColumn
)

Parameters

column
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumn
The target TreeListViewColumn.
See Also

Reference

TreeListViewColumnMenuEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnMenuEventArgs Properties

The TreeListViewColumnMenuEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelRoutedEventArgs.)
Public property | Column | Gets the target TreeListViewColumn. (Inherited from TreeListViewColumnEventArgs.)
Public property | Menu | Gets or sets the ContextMenu that is about to be displayed.
Top
See Also

Reference

TreeListViewColumnMenuEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewColumnMenuEventArgs.Menu Property

TreeListViewColumnMenuEventArgsMenu Property

Gets or sets the ContextMenu that is about to be displayed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ContextMenu Menu { get; set; }
Public Property Menu As ContextMenu
    Get
    Set

Property Value

Type: ContextMenu
The ContextMenu that is about to be displayed.
See Also

Reference

TreeListViewColumnMenuEventArgs Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItem Class

Represents an item for a TreeListView control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.GridsTreeListBoxItem
ActiproSoftware.Windows.Controls.GridsTreeListViewItem
ActiproSoftware.Windows.Controls.GridsPropertyGridItem

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewItem : TreeListBoxItem
Public Class TreeListViewItem
    Inherits TreeListBoxItem

The TreeListViewItem type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewItem | Initializes an instance of the TreeListViewItem class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused. (Inherited from TreeListBoxItem.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display. (Inherited from TreeListBoxItem.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented. (Inherited from TreeListBoxItem.)
Public property | InnerBorderThickness | Gets or sets the Thickness of the inner border. (Inherited from TreeListBoxItem.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed. (Inherited from TreeListBoxItem.)
Public property | IsExpanded | Gets or sets whether the node is expanded. (Inherited from TreeListBoxItem.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected. (Inherited from TreeListBoxItem.)
Public property | IsSelected | Gets or sets whether the node is selected. (Inherited from TreeListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button. (Inherited from TreeListBoxItem.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsLocationOverBackground | Returns whether the specified location is past the end of the content, in owner control background whitespace area. (Overrides TreeListBoxItemIsLocationOverBackground(Point).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListBoxItemOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Inherited from TreeListBoxItem.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TreeListBoxItemOnCreateAutomationPeer.)
Protected method | OnDoubleTapped | Occurs when the item is double-tapped. (Inherited from TreeListBoxItem.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBoxItem.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBoxItem.)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed. (Overrides TreeListBoxItemOnIndentAmountChanged.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from TreeListBoxItem.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from TreeListBoxItem.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBoxItem.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Occurs when composed text is input to the control. (Inherited from TreeListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TreeListBoxItem.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItem Constructor

Initializes an instance of the TreeListViewItem class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewItem()
Public Sub New
See Also

Reference

TreeListViewItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItem Properties

The TreeListViewItem type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused. (Inherited from TreeListBoxItem.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display. (Inherited from TreeListBoxItem.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented. (Inherited from TreeListBoxItem.)
Public property | InnerBorderThickness | Gets or sets the Thickness of the inner border. (Inherited from TreeListBoxItem.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed. (Inherited from TreeListBoxItem.)
Public property | IsExpanded | Gets or sets whether the node is expanded. (Inherited from TreeListBoxItem.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected. (Inherited from TreeListBoxItem.)
Public property | IsSelected | Gets or sets whether the node is selected. (Inherited from TreeListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button. (Inherited from TreeListBoxItem.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListViewItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItem Methods

The TreeListViewItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsLocationOverBackground | Returns whether the specified location is past the end of the content, in owner control background whitespace area. (Overrides TreeListBoxItemIsLocationOverBackground(Point).)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListBoxItemOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuOpening | Occurs when a context menu is requested. (Inherited from TreeListBoxItem.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides TreeListBoxItemOnCreateAutomationPeer.)
Protected method | OnDoubleTapped | Occurs when the item is double-tapped. (Inherited from TreeListBoxItem.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBoxItem.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBoxItem.)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed. (Overrides TreeListBoxItemOnIndentAmountChanged.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from TreeListBoxItem.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from TreeListBoxItem.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBoxItem.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Occurs when composed text is input to the control. (Inherited from TreeListBoxItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TreeListBoxItem.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeListViewItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItem.IsLocationOverBackground Method

TreeListViewItemIsLocationOverBackground Method

Returns whether the specified location is past the end of the content, in owner control background whitespace area.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsLocationOverBackground(
    Point location
)
Protected Overrides Function IsLocationOverBackground (
    location As Point
) As Boolean

Parameters

location
Type: System.WindowsPoint
The location to examine.

Return Value

Type: Boolean
true if the specified location is past the end of the content, in owner control background whitespace area; otherwise, false.
See Also

Reference

TreeListViewItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItem.OnApplyTemplate Method

TreeListViewItemOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

TreeListViewItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItem.OnCreateAutomationPeer Method

TreeListViewItemOnCreateAutomationPeer Method

Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

TreeListViewItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItem.OnIndentAmountChanged Method

TreeListViewItemOnIndentAmountChanged Method

Occurs when the IndentAmount property is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnIndentAmountChanged()
Protected Overrides Sub OnIndentAmountChanged
See Also

Reference

TreeListViewItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItem Events

The TreeListViewItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

TreeListViewItem Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell Class

Represents an item for a TreeListView control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.GridsTreeListViewItemCell

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewItemCell : ContentControl
Public Class TreeListViewItemCell
    Inherits ContentControl

The TreeListViewItemCell type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewItemCell | Initializes an instance of the TreeListViewItemCell class.
Public method | TreeListViewItemCell(TreeListViewColumn) | Initializes an instance of the TreeListViewItemCell class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Column | Gets the TreeListViewColumn in which the cell resides.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this cell's content is indented.
Public property | IsResizeGripperEnabled | Gets whether the resizing header gripper is enabled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ColumnProperty | Identifies the Column dependency property. This field is read-only.
IndentAmountProperty | Identifies the IndentAmount dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell Constructor

Overload List
 | Name | Description
Public method | TreeListViewItemCell | Initializes an instance of the TreeListViewItemCell class.
Public method | TreeListViewItemCell(TreeListViewColumn) | Initializes an instance of the TreeListViewItemCell class.
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell Constructor

Initializes an instance of the TreeListViewItemCell class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewItemCell()
Public Sub New
See Also

Reference

TreeListViewItemCell Class
TreeListViewItemCell Overload
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell Constructor (TreeListViewColumn)

Initializes an instance of the TreeListViewItemCell class.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewItemCell(
    TreeListViewColumn column
)
Public Sub New (
    column As TreeListViewColumn
)

Parameters

column
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumn
The TreeListViewColumn in which the cell resides.
See Also

Reference

TreeListViewItemCell Class
TreeListViewItemCell Overload
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell Properties

The TreeListViewItemCell type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Column | Gets the TreeListViewColumn in which the cell resides.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this cell's content is indented.
Public property | IsResizeGripperEnabled | Gets whether the resizing header gripper is enabled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell.Column Property

TreeListViewItemCellColumn Property

Gets the TreeListViewColumn in which the cell resides.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewColumn Column { get; }
Public ReadOnly Property Column As TreeListViewColumn
    Get

Property Value

Type: TreeListViewColumn
The TreeListViewColumn in which the cell resides.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell.IndentAmount Property

TreeListViewItemCellIndentAmount Property

Gets or sets the amount that this cell's content is indented.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double IndentAmount { get; set; }
Public Property IndentAmount As Double
    Get
    Set

Property Value

Type: Double
The amount that this cell's content is indented.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell.IsResizeGripperEnabled Property

TreeListViewItemCellIsResizeGripperEnabled Property

Gets whether the resizing header gripper is enabled.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsResizeGripperEnabled { get; }
Public ReadOnly Property IsResizeGripperEnabled As Boolean
    Get

Property Value

Type: Boolean
true if the resizing header gripper is enabled; otherwise, false. The default value is false.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell Methods

The TreeListViewItemCell type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell.OnApplyTemplate Method

TreeListViewItemCellOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell Events

The TreeListViewItemCell type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell Fields

The TreeListViewItemCell type exposes the following members.

Fields
Name | Description
ColumnProperty | Identifies the Column dependency property. This field is read-only.
IndentAmountProperty | Identifies the IndentAmount dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell.ColumnProperty Field

TreeListViewItemCellColumnProperty Field

Identifies the Column dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColumnProperty
Public Shared ReadOnly ColumnProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Column dependency property.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell.IndentAmountProperty Field

TreeListViewItemCellIndentAmountProperty Field

Identifies the IndentAmount dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndentAmountProperty
Public Shared ReadOnly IndentAmountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IndentAmount dependency property.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeListViewItemCell.IsResizeGripperEnabledProperty Field

TreeListViewItemCellIsResizeGripperEnabledProperty Field

Identifies the IsResizeGripperEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizeGripperEnabledProperty
Public Shared ReadOnly IsResizeGripperEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizeGripperEnabled dependency property.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.Windows.Controls.Grids Namespace


TreeMultiDragKind Enumeration

Specifies the item multi-drag mode for a tree control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TreeMultiDragKind
Public Enumeration TreeMultiDragKind
Members
Member name | Value | Description
None | 0 | Drags are not allowed when multiple items are selected. Only single item selection drags are permitted.
Any | 1 | Any node can be dragged.
SameType | 2 | Any node that is the same type can be dragged.
SameDepth | 3 | Any node at the same depth can be dragged.
Siblings | 4 | Any node that shares the same parent can be dragged.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


TreeMultiSelectionKind Enumeration

Specifies the item multi-select mode for a tree control.

Namespace: ActiproSoftware.Windows.Controls.Grids
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum TreeMultiSelectionKind
Public Enumeration TreeMultiSelectionKind
Members
Member name | Value | Description
Any | 0 | Any node can be selected.
SameType | 1 | Any node that is the same type can be selected.
SameDepth | 2 | Any node at the same depth can be selected.
Siblings | 3 | Any node that shares the same parent can be selected.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids Namespace


ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace

[Missing <summary> documentation for "N:ActiproSoftware.Windows.Controls.Grids.Automation.Peers"]

Classes
 | Class | Description
Public class | PropertyGridAutomationPeer | Exposes PropertyGrid types to UI Automation.
Public class | PropertyGridItemAutomationPeer | Exposes PropertyGrid data items to UI Automation.
Public class | PropertyGridItemWrapperAutomationPeer | Exposes PropertyGridItem types to UI Automation.
Public class | TreeListBoxAutomationPeer | Exposes TreeListBox types to UI Automation.
Public class | TreeListBoxItemAutomationPeer | Exposes TreeListBox data items to UI Automation.
Public class | TreeListBoxItemWrapperAutomationPeer | Exposes TreeListBoxItem types to UI Automation.
Public class | TreeListViewAutomationPeer | Exposes TreeListView types to UI Automation.
Public class | TreeListViewItemAutomationPeer | Exposes TreeListView data items to UI Automation.
Public class | TreeListViewItemWrapperAutomationPeer | Exposes TreeListViewItem types to UI Automation.


PropertyGridAutomationPeer Class

Exposes PropertyGrid types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
System.Windows.Automation.PeersItemsControlAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListViewAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersPropertyGridAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridAutomationPeer : TreeListViewAutomationPeer
Public Class PropertyGridAutomationPeer
    Inherits TreeListViewAutomationPeer

The PropertyGridAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridAutomationPeer | Initializes a new instance of the PropertyGridAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateItemAutomationPeer | Creates an ItemAutomationPeer for a data item. (Overrides TreeListViewAutomationPeerCreateItemAutomationPeer(Object).)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the ItemsControl that is associated with this ItemsControlAutomationPeer. This method is called by GetChildren. (Inherited from ItemsControlAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from TreeListBoxAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListViewAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the ItemsControl that is associated with this ItemsControlAutomationPeer. (Inherited from ItemsControlAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridAutomationPeer Constructor

Initializes a new instance of the PropertyGridAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridAutomationPeer(
    PropertyGrid owner
)
Public Sub New (
    owner As PropertyGrid
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.GridsPropertyGrid
The owner element.
See Also

Reference

PropertyGridAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridAutomationPeer Properties

The PropertyGridAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

PropertyGridAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridAutomationPeer Methods

The PropertyGridAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateItemAutomationPeer | Creates an ItemAutomationPeer for a data item. (Overrides TreeListViewAutomationPeerCreateItemAutomationPeer(Object).)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the ItemsControl that is associated with this ItemsControlAutomationPeer. This method is called by GetChildren. (Inherited from ItemsControlAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from TreeListBoxAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListViewAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the ItemsControl that is associated with this ItemsControlAutomationPeer. (Inherited from ItemsControlAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PropertyGridAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridAutomationPeer.CreateItemAutomationPeer Method

PropertyGridAutomationPeerCreateItemAutomationPeer Method

Creates an ItemAutomationPeer for a data item.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override ItemAutomationPeer CreateItemAutomationPeer(
    Object item
)
Protected Overrides Function CreateItemAutomationPeer (
    item As Object
) As ItemAutomationPeer

Parameters

item
Type: SystemObject
The data item.

Return Value

Type: ItemAutomationPeer
The ItemAutomationPeer that was created.
See Also

Reference

PropertyGridAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridAutomationPeer.GetLocalizedControlTypeCore Method

PropertyGridAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

PropertyGridAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemAutomationPeer Class

Exposes PropertyGrid data items to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersItemAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxItemAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersPropertyGridItemAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItemAutomationPeer : TreeListBoxItemAutomationPeer
Public Class PropertyGridItemAutomationPeer
    Inherits TreeListBoxItemAutomationPeer

The PropertyGridItemAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemAutomationPeer | Initializes a new instance of the PropertyGridItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | Expand | Displays all child nodes, controls, or content of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides TreeListBoxItemAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that conveys the visual status of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified element represents. (Overrides ItemAutomationPeerGetItemTypeCore.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the Label that is targeted to the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListBoxItemAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the specified UIElement is laid out in a particular direction. (Inherited from ItemAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the specified UIElement currently has keyboard input focus. (Inherited from ItemAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the specified UIElement contains data that is presented to the user. (Inherited from ItemAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets a value that indicates whether the UIElement that is associated with this ItemAutomationPeer is understood by the end user as interactive. (Inherited from ItemAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the specified UIElement can receive and send events. (Inherited from ItemAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the specified UIElement can accept keyboard focus. (Inherited from ItemAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the specified UIElement is off the screen. (Inherited from ItemAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the specified UIElement contains protected content. (Inherited from ItemAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the specified UIElement is required to be completed on a form. (Inherited from ItemAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the specified UIElement. The UIElement corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemAutomationPeer Constructor

Initializes a new instance of the PropertyGridItemAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItemAutomationPeer(
    Object item,
    PropertyGridAutomationPeer itemsControlAutomationPeer
)
Public Sub New (
    item As Object,
    itemsControlAutomationPeer As PropertyGridAutomationPeer
)

Parameters

item
Type: SystemObject
The data item.
itemsControlAutomationPeer
Type: ActiproSoftware.Windows.Controls.Grids.Automation.PeersPropertyGridAutomationPeer
The items control automation peer.
See Also

Reference

PropertyGridItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemAutomationPeer Properties

The PropertyGridItemAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
See Also

Reference

PropertyGridItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemAutomationPeer Methods

The PropertyGridItemAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | Expand | Displays all child nodes, controls, or content of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides TreeListBoxItemAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that conveys the visual status of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified element represents. (Overrides ItemAutomationPeerGetItemTypeCore.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the Label that is targeted to the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListBoxItemAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the specified UIElement is laid out in a particular direction. (Inherited from ItemAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the specified UIElement currently has keyboard input focus. (Inherited from ItemAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the specified UIElement contains data that is presented to the user. (Inherited from ItemAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets a value that indicates whether the UIElement that is associated with this ItemAutomationPeer is understood by the end user as interactive. (Inherited from ItemAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the specified UIElement can receive and send events. (Inherited from ItemAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the specified UIElement can accept keyboard focus. (Inherited from ItemAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the specified UIElement is off the screen. (Inherited from ItemAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the specified UIElement contains protected content. (Inherited from ItemAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the specified UIElement is required to be completed on a form. (Inherited from ItemAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the specified UIElement. The UIElement corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PropertyGridItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemAutomationPeer.GetClassNameCore Method

PropertyGridItemAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

PropertyGridItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemAutomationPeer.GetItemTypeCore Method

PropertyGridItemAutomationPeerGetItemTypeCore Method

Gets a human-readable string that contains the type of item that the specified element represents.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetItemTypeCore()
Protected Overrides Function GetItemTypeCore As String

Return Value

Type: String
The item type.
See Also

Reference

PropertyGridItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemAutomationPeer.GetLocalizedControlTypeCore Method

PropertyGridItemAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

PropertyGridItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemWrapperAutomationPeer Class

Exposes PropertyGridItem types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxItemWrapperAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListViewItemWrapperAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersPropertyGridItemWrapperAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItemWrapperAutomationPeer : TreeListViewItemWrapperAutomationPeer
Public Class PropertyGridItemWrapperAutomationPeer
    Inherits TreeListViewItemWrapperAutomationPeer

The PropertyGridItemWrapperAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemWrapperAutomationPeer | Initializes a new instance of the PropertyGridItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | Expand | Displays all child nodes, controls, or content of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified element represents. (Overrides UIElementAutomationPeerGetItemTypeCore.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListViewItemWrapperAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemWrapperAutomationPeer Constructor

Initializes a new instance of the PropertyGridItemAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItemWrapperAutomationPeer(
    PropertyGridItem owner
)
Public Sub New (
    owner As PropertyGridItem
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.GridsPropertyGridItem
The owner element.
See Also

Reference

PropertyGridItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemWrapperAutomationPeer Properties

The PropertyGridItemWrapperAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

PropertyGridItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemWrapperAutomationPeer Methods

The PropertyGridItemWrapperAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | Expand | Displays all child nodes, controls, or content of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified element represents. (Overrides UIElementAutomationPeerGetItemTypeCore.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListViewItemWrapperAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides FrameworkElementAutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PropertyGridItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemWrapperAutomationPeer.GetItemTypeCore Method

PropertyGridItemWrapperAutomationPeerGetItemTypeCore Method

Gets a human-readable string that contains the type of item that the specified element represents.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetItemTypeCore()
Protected Overrides Function GetItemTypeCore As String

Return Value

Type: String
The item type.
See Also

Reference

PropertyGridItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemWrapperAutomationPeer.GetLocalizedControlTypeCore Method

PropertyGridItemWrapperAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

PropertyGridItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


PropertyGridItemWrapperAutomationPeer.GetNameCore Method

PropertyGridItemWrapperAutomationPeerGetNameCore Method

Gets text that describes the element that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The name.
See Also

Reference

PropertyGridItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxAutomationPeer Class

Exposes TreeListBox types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
System.Windows.Automation.PeersItemsControlAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListViewAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListBoxAutomationPeer : ItemsControlAutomationPeer
Public Class TreeListBoxAutomationPeer
    Inherits ItemsControlAutomationPeer

The TreeListBoxAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxAutomationPeer | Initializes a new instance of the TreeListBoxAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateItemAutomationPeer | Creates an ItemAutomationPeer for a data item. (Overrides ItemsControlAutomationPeerCreateItemAutomationPeer(Object).)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the ItemsControl that is associated with this ItemsControlAutomationPeer. This method is called by GetChildren. (Inherited from ItemsControlAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the ItemsControl that is associated with this ItemsControlAutomationPeer. (Inherited from ItemsControlAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxAutomationPeer Constructor

Initializes a new instance of the TreeListBoxAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxAutomationPeer(
    TreeListBox owner
)
Public Sub New (
    owner As TreeListBox
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.GridsTreeListBox
The owner element.
See Also

Reference

TreeListBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxAutomationPeer Properties

The TreeListBoxAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

TreeListBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxAutomationPeer Methods

The TreeListBoxAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateItemAutomationPeer | Creates an ItemAutomationPeer for a data item. (Overrides ItemsControlAutomationPeerCreateItemAutomationPeer(Object).)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the ItemsControl that is associated with this ItemsControlAutomationPeer. This method is called by GetChildren. (Inherited from ItemsControlAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the ItemsControl that is associated with this ItemsControlAutomationPeer. (Inherited from ItemsControlAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

TreeListBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxAutomationPeer.CreateItemAutomationPeer Method

TreeListBoxAutomationPeerCreateItemAutomationPeer Method

Creates an ItemAutomationPeer for a data item.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override ItemAutomationPeer CreateItemAutomationPeer(
    Object item
)
Protected Overrides Function CreateItemAutomationPeer (
    item As Object
) As ItemAutomationPeer

Parameters

item
Type: SystemObject
The data item.

Return Value

Type: ItemAutomationPeer
The ItemAutomationPeer that was created.
See Also

Reference

TreeListBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxAutomationPeer.GetAutomationControlTypeCore Method

TreeListBoxAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

TreeListBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxAutomationPeer.GetClassNameCore Method

TreeListBoxAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

TreeListBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxAutomationPeer.GetLocalizedControlTypeCore Method

TreeListBoxAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

TreeListBoxAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer Class

Exposes TreeListBox data items to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersItemAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxItemAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersPropertyGridItemAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListViewItemAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListBoxItemAutomationPeer : ItemAutomationPeer,
    IExpandCollapseProvider
Public Class TreeListBoxItemAutomationPeer
    Inherits ItemAutomationPeer
    Implements IExpandCollapseProvider

The TreeListBoxItemAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemAutomationPeer | Initializes a new instance of the TreeListBoxItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Expand | Displays all child nodes, controls, or content of the control.
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that conveys the visual status of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified UIElement represents. (Inherited from ItemAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the Label that is targeted to the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the specified UIElement is laid out in a particular direction. (Inherited from ItemAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides ItemAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the specified UIElement currently has keyboard input focus. (Inherited from ItemAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the specified UIElement contains data that is presented to the user. (Inherited from ItemAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets a value that indicates whether the UIElement that is associated with this ItemAutomationPeer is understood by the end user as interactive. (Inherited from ItemAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the specified UIElement can receive and send events. (Inherited from ItemAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the specified UIElement can accept keyboard focus. (Inherited from ItemAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the specified UIElement is off the screen. (Inherited from ItemAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the specified UIElement contains protected content. (Inherited from ItemAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the specified UIElement is required to be completed on a form. (Inherited from ItemAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the specified UIElement. The UIElement corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer Constructor

Initializes a new instance of the TreeListBoxItemAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxItemAutomationPeer(
    Object item,
    TreeListBoxAutomationPeer itemsControlAutomationPeer
)
Public Sub New (
    item As Object,
    itemsControlAutomationPeer As TreeListBoxAutomationPeer
)

Parameters

item
Type: SystemObject
The data item.
itemsControlAutomationPeer
Type: ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxAutomationPeer
The items control automation peer.
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer Properties

The TreeListBoxItemAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer.ExpandCollapseState Property

TreeListBoxItemAutomationPeerExpandCollapseState Property

Gets the state, expanded or collapsed, of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpandCollapseState ExpandCollapseState { get; }
Public ReadOnly Property ExpandCollapseState As ExpandCollapseState
    Get

Property Value

Type: ExpandCollapseState

Return Value

Type: ExpandCollapseState
The state, expanded or collapsed, of the control.

Implements

IExpandCollapseProviderExpandCollapseState
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer Methods

The TreeListBoxItemAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Expand | Displays all child nodes, controls, or content of the control.
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that conveys the visual status of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified UIElement represents. (Inherited from ItemAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the Label that is targeted to the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the specified UIElement is laid out in a particular direction. (Inherited from ItemAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides ItemAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the specified UIElement currently has keyboard input focus. (Inherited from ItemAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the specified UIElement contains data that is presented to the user. (Inherited from ItemAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets a value that indicates whether the UIElement that is associated with this ItemAutomationPeer is understood by the end user as interactive. (Inherited from ItemAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the specified UIElement can receive and send events. (Inherited from ItemAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the specified UIElement can accept keyboard focus. (Inherited from ItemAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the specified UIElement is off the screen. (Inherited from ItemAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the specified UIElement contains protected content. (Inherited from ItemAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the specified UIElement is required to be completed on a form. (Inherited from ItemAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the specified UIElement. The UIElement corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer.Collapse Method

TreeListBoxItemAutomationPeerCollapse Method

Hides all nodes, controls, or content that are descendants of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Collapse()
Public Sub Collapse

Implements

IExpandCollapseProviderCollapse
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer.Expand Method

TreeListBoxItemAutomationPeerExpand Method

Displays all child nodes, controls, or content of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Expand()
Public Sub Expand

Implements

IExpandCollapseProviderExpand
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer.GetAutomationControlTypeCore Method

TreeListBoxItemAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer.GetClassNameCore Method

TreeListBoxItemAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer.GetLocalizedControlTypeCore Method

TreeListBoxItemAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemAutomationPeer.GetPattern Method

TreeListBoxItemAutomationPeerGetPattern Method

Gets the control pattern that is associated with the specified PatternInterface.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value from the PatternInterface enumeration.

Return Value

Type: Object
The object that implements the pattern interface; if the peer does not support this interface.
Remarks
This method will return a 'this' pointer in the follow cases:
  • If patternInterface is PatternInterface.ExpandCollapse.
See Also

Reference

TreeListBoxItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer Class

Exposes TreeListBoxItem types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxItemWrapperAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListViewItemWrapperAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListBoxItemWrapperAutomationPeer : FrameworkElementAutomationPeer,
    IExpandCollapseProvider
Public Class TreeListBoxItemWrapperAutomationPeer
    Inherits FrameworkElementAutomationPeer
    Implements IExpandCollapseProvider

The TreeListBoxItemWrapperAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemWrapperAutomationPeer | Initializes a new instance of the TreeListBoxItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Expand | Displays all child nodes, controls, or content of the control.
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer Constructor

Initializes a new instance of the TreeListBoxItemAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListBoxItemWrapperAutomationPeer(
    TreeListBoxItem owner
)
Public Sub New (
    owner As TreeListBoxItem
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.GridsTreeListBoxItem
The owner element.
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer Properties

The TreeListBoxItemWrapperAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer.ExpandCollapseState Property

TreeListBoxItemWrapperAutomationPeerExpandCollapseState Property

Gets the state, expanded or collapsed, of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpandCollapseState ExpandCollapseState { get; }
Public ReadOnly Property ExpandCollapseState As ExpandCollapseState
    Get

Property Value

Type: ExpandCollapseState

Return Value

Type: ExpandCollapseState
The state, expanded or collapsed, of the control.

Implements

IExpandCollapseProviderExpandCollapseState
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer Methods

The TreeListBoxItemWrapperAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Expand | Displays all child nodes, controls, or content of the control.
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides UIElementAutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Overrides UIElementAutomationPeerGetPattern(PatternInterface).)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer.Collapse Method

TreeListBoxItemWrapperAutomationPeerCollapse Method

Hides all nodes, controls, or content that are descendants of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Collapse()
Public Sub Collapse

Implements

IExpandCollapseProviderCollapse
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer.Expand Method

TreeListBoxItemWrapperAutomationPeerExpand Method

Displays all child nodes, controls, or content of the control.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Expand()
Public Sub Expand

Implements

IExpandCollapseProviderExpand
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer.GetAutomationControlTypeCore Method

TreeListBoxItemWrapperAutomationPeerGetAutomationControlTypeCore Method

Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer.GetClassNameCore Method

TreeListBoxItemWrapperAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer.GetLocalizedControlTypeCore Method

TreeListBoxItemWrapperAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListBoxItemWrapperAutomationPeer.GetPattern Method

TreeListBoxItemWrapperAutomationPeerGetPattern Method

Gets the control pattern that is associated with the specified PatternInterface.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetPattern(
    PatternInterface patternInterface
)
Public Overrides Function GetPattern (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: System.Windows.Automation.PeersPatternInterface
A value from the PatternInterface enumeration.

Return Value

Type: Object
The object that implements the pattern interface; if the peer does not support this interface.
Remarks
This method will return a 'this' pointer in the follow cases:
  • If patternInterface is PatternInterface.ExpandCollapse.
See Also

Reference

TreeListBoxItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewAutomationPeer Class

Exposes TreeListView types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
System.Windows.Automation.PeersItemsControlAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListViewAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersPropertyGridAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewAutomationPeer : TreeListBoxAutomationPeer
Public Class TreeListViewAutomationPeer
    Inherits TreeListBoxAutomationPeer

The TreeListViewAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewAutomationPeer | Initializes a new instance of the TreeListViewAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateItemAutomationPeer | Creates an ItemAutomationPeer for a data item. (Overrides TreeListBoxAutomationPeerCreateItemAutomationPeer(Object).)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the ItemsControl that is associated with this ItemsControlAutomationPeer. This method is called by GetChildren. (Inherited from ItemsControlAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from TreeListBoxAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListBoxAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the ItemsControl that is associated with this ItemsControlAutomationPeer. (Inherited from ItemsControlAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewAutomationPeer Constructor

Initializes a new instance of the TreeListViewAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewAutomationPeer(
    TreeListView owner
)
Public Sub New (
    owner As TreeListView
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.GridsTreeListView
The owner element.
See Also

Reference

TreeListViewAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewAutomationPeer Properties

The TreeListViewAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

TreeListViewAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewAutomationPeer Methods

The TreeListViewAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateItemAutomationPeer | Creates an ItemAutomationPeer for a data item. (Overrides TreeListBoxAutomationPeerCreateItemAutomationPeer(Object).)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the ItemsControl that is associated with this ItemsControlAutomationPeer. This method is called by GetChildren. (Inherited from ItemsControlAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from TreeListBoxAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListBoxAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the ItemsControl that is associated with this ItemsControlAutomationPeer. (Inherited from ItemsControlAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

TreeListViewAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewAutomationPeer.CreateItemAutomationPeer Method

TreeListViewAutomationPeerCreateItemAutomationPeer Method

Creates an ItemAutomationPeer for a data item.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override ItemAutomationPeer CreateItemAutomationPeer(
    Object item
)
Protected Overrides Function CreateItemAutomationPeer (
    item As Object
) As ItemAutomationPeer

Parameters

item
Type: SystemObject
The data item.

Return Value

Type: ItemAutomationPeer
The ItemAutomationPeer that was created.
See Also

Reference

TreeListViewAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewAutomationPeer.GetLocalizedControlTypeCore Method

TreeListViewAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

TreeListViewAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemAutomationPeer Class

Exposes TreeListView data items to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersItemAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxItemAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListViewItemAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewItemAutomationPeer : TreeListBoxItemAutomationPeer
Public Class TreeListViewItemAutomationPeer
    Inherits TreeListBoxItemAutomationPeer

The TreeListViewItemAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewItemAutomationPeer | Initializes a new instance of the TreeListViewItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | Expand | Displays all child nodes, controls, or content of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides TreeListBoxItemAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that conveys the visual status of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified UIElement represents. (Inherited from ItemAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the Label that is targeted to the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListBoxItemAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the specified UIElement is laid out in a particular direction. (Inherited from ItemAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the specified UIElement currently has keyboard input focus. (Inherited from ItemAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the specified UIElement contains data that is presented to the user. (Inherited from ItemAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets a value that indicates whether the UIElement that is associated with this ItemAutomationPeer is understood by the end user as interactive. (Inherited from ItemAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the specified UIElement can receive and send events. (Inherited from ItemAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the specified UIElement can accept keyboard focus. (Inherited from ItemAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the specified UIElement is off the screen. (Inherited from ItemAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the specified UIElement contains protected content. (Inherited from ItemAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the specified UIElement is required to be completed on a form. (Inherited from ItemAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the specified UIElement. The UIElement corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemAutomationPeer Constructor

Initializes a new instance of the TreeListViewItemAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewItemAutomationPeer(
    Object item,
    TreeListViewAutomationPeer itemsControlAutomationPeer
)
Public Sub New (
    item As Object,
    itemsControlAutomationPeer As TreeListViewAutomationPeer
)

Parameters

item
Type: SystemObject
The data item.
itemsControlAutomationPeer
Type: ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListViewAutomationPeer
The items control automation peer.
See Also

Reference

TreeListViewItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemAutomationPeer Properties

The TreeListViewItemAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
See Also

Reference

TreeListViewItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemAutomationPeer Methods

The TreeListViewItemAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | Expand | Displays all child nodes, controls, or content of the control. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides TreeListBoxItemAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that conveys the visual status of the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the type of item that the specified UIElement represents. (Inherited from ItemAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the Label that is targeted to the specified UIElement. (Inherited from ItemAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListBoxItemAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the UIElement that corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the specified UIElement is laid out in a particular direction. (Inherited from ItemAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from TreeListBoxItemAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the specified UIElement currently has keyboard input focus. (Inherited from ItemAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the specified UIElement contains data that is presented to the user. (Inherited from ItemAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets a value that indicates whether the UIElement that is associated with this ItemAutomationPeer is understood by the end user as interactive. (Inherited from ItemAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the specified UIElement can receive and send events. (Inherited from ItemAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the specified UIElement can accept keyboard focus. (Inherited from ItemAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the specified UIElement is off the screen. (Inherited from ItemAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the specified UIElement contains protected content. (Inherited from ItemAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the specified UIElement is required to be completed on a form. (Inherited from ItemAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the specified UIElement. The UIElement corresponds to the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

TreeListViewItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemAutomationPeer.GetClassNameCore Method

TreeListViewItemAutomationPeerGetClassNameCore Method

Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

TreeListViewItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemAutomationPeer.GetLocalizedControlTypeCore Method

TreeListViewItemAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

TreeListViewItemAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemWrapperAutomationPeer Class

Exposes TreeListViewItem types to UI Automation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListBoxItemWrapperAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersTreeListViewItemWrapperAutomationPeer
ActiproSoftware.Windows.Controls.Grids.Automation.PeersPropertyGridItemWrapperAutomationPeer

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewItemWrapperAutomationPeer : TreeListBoxItemWrapperAutomationPeer
Public Class TreeListViewItemWrapperAutomationPeer
    Inherits TreeListBoxItemWrapperAutomationPeer

The TreeListViewItemWrapperAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewItemWrapperAutomationPeer | Initializes a new instance of the TreeListViewItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | Expand | Displays all child nodes, controls, or content of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListBoxItemWrapperAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemWrapperAutomationPeer Constructor

Initializes a new instance of the TreeListViewItemAutomationPeer class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewItemWrapperAutomationPeer(
    TreeListViewItem owner
)
Public Sub New (
    owner As TreeListViewItem
)

Parameters

owner
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewItem
The owner element.
See Also

Reference

TreeListViewItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemWrapperAutomationPeer Properties

The TreeListViewItemWrapperAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

TreeListViewItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemWrapperAutomationPeer Methods

The TreeListViewItemWrapperAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | Expand | Displays all child nodes, controls, or content of the control. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetChildren. (Inherited from UIElementAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides TreeListBoxItemWrapperAutomationPeerGetLocalizedControlTypeCore.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from TreeListBoxItemWrapperAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

TreeListViewItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


TreeListViewItemWrapperAutomationPeer.GetLocalizedControlTypeCore Method

TreeListViewItemWrapperAutomationPeerGetLocalizedControlTypeCore Method

Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.Windows.Controls.Grids.Automation.Peers
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

TreeListViewItemWrapperAutomationPeer Class
ActiproSoftware.Windows.Controls.Grids.Automation.Peers Namespace


ActiproSoftware.Windows.Controls.Grids.Primitives Namespace

Contains the primitive classes used for Grids product controls.
Classes
 | Class | Description
Public class | FontFamilyComboBox | Provides several helper methods to aid in code compatibility between UI platforms.
Public class | PropertyGridItemContentPanel | Provides a panel for arranging content that spans the width of a PropertyGridItem.
Public class | PropertyGridItemRowPanel | A panel that arranges the cells within a PropertyGridItem.
Public class | PropertyGridSummaryContentControl | Represents a ContentControl that displays summary content for a PropertyGrid and contains a gripper, allowing it to be resized.
Public class | TreeItemExpansionToggleButton | Represents a ToggleButton for toggling the expansion state of a tree item.
Public class | TreeListViewColumnResizeGripper | Represents a resize gripper for a TreeListViewColumn.
Public class | TreeListViewHeaderRowPanel | A panel that arranges a TreeListView header.
Public class | TreeListViewItemRowPanel | A panel that arranges the cells within a TreeListViewItem.
Public class | TreeListViewRowPanelBase | Provides a base panel for arranging a TreeListView header and cells within a TreeListViewItem.
Public class | TreeNodeItemCollection | Stores a collection of tree node items.


FontFamilyComboBox Class

Provides several helper methods to aid in code compatibility between UI platforms.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsComboBox
ActiproSoftware.Windows.Controls.Grids.PrimitivesFontFamilyComboBox

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FontFamilyComboBox : ComboBox
Public Class FontFamilyComboBox
    Inherits ComboBox

The FontFamilyComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | FontFamilyComboBox | Initializes an instance of the FontFamilyComboBox class.
Top
Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Protected method | GetFontFamilies | Refreshes the list with the current system font families.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate is called. (Inherited from ComboBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


FontFamilyComboBox Constructor

Initializes an instance of the FontFamilyComboBox class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontFamilyComboBox()
Public Sub New
See Also

Reference

FontFamilyComboBox Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


FontFamilyComboBox Properties

The FontFamilyComboBox type exposes the following members.

Properties
 | Name | Description
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

FontFamilyComboBox Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


FontFamilyComboBox Methods

The FontFamilyComboBox type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Protected method | GetFontFamilies | Refreshes the list with the current system font families.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate is called. (Inherited from ComboBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

FontFamilyComboBox Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


FontFamilyComboBox.GetFontFamilies Method

FontFamilyComboBoxGetFontFamilies Method

Refreshes the list with the current system font families.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IEnumerable<FontFamily> GetFontFamilies()
Protected Overridable Function GetFontFamilies As IEnumerable(Of FontFamily)

Return Value

Type: IEnumerable FontFamily

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Grids.Primitives.FontFamilyComboBox.GetFontFamilies"]

See Also

Reference

FontFamilyComboBox Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


FontFamilyComboBox Events

The FontFamilyComboBox type exposes the following members.

Events
 | Name | Description
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Top
See Also

Reference

FontFamilyComboBox Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel Class

Provides a panel for arranging content that spans the width of a PropertyGridItem.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Grids.PrimitivesPropertyGridItemContentPanel

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItemContentPanel : Panel
Public Class PropertyGridItemContentPanel
    Inherits Panel

The PropertyGridItemContentPanel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemContentPanel | Initializes a new instance of the PropertyGridItemContentPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel Constructor

Initializes a new instance of the PropertyGridItemContentPanel class

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItemContentPanel()
Public Sub New
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel Properties

The PropertyGridItemContentPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel Methods

The PropertyGridItemContentPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel.ArrangeOverride Method

PropertyGridItemContentPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel.MeasureOverride Method

PropertyGridItemContentPanelMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel Class

A panel that arranges the cells within a PropertyGridItem.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewRowPanelBase
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewItemRowPanel
ActiproSoftware.Windows.Controls.Grids.PrimitivesPropertyGridItemRowPanel

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridItemRowPanel : TreeListViewItemRowPanel
Public Class PropertyGridItemRowPanel
    Inherits TreeListViewItemRowPanel

The PropertyGridItemRowPanel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemRowPanel | Initializes a new instance of the PropertyGridItemRowPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListViewItemRowPanelArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Inherited from TreeListViewItemRowPanel.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides TreeListViewItemRowPanelMeasureOverride(Size).)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Inherited from TreeListViewItemRowPanel.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Inherited from TreeListViewItemRowPanel.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Inherited from TreeListViewItemRowPanel.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel Constructor

Initializes a new instance of the PropertyGridItemRowPanel class

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridItemRowPanel()
Public Sub New
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel Properties

The PropertyGridItemRowPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel Methods

The PropertyGridItemRowPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListViewItemRowPanelArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Inherited from TreeListViewItemRowPanel.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides TreeListViewItemRowPanelMeasureOverride(Size).)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Inherited from TreeListViewItemRowPanel.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Inherited from TreeListViewItemRowPanel.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Inherited from TreeListViewItemRowPanel.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel.ArrangeOverride Method

PropertyGridItemRowPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel.MeasureOverride Method

PropertyGridItemRowPanelMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Class

Represents a ContentControl that displays summary content for a PropertyGrid and contains a gripper, allowing it to be resized.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.Grids.PrimitivesPropertyGridSummaryContentControl

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridSummaryContentControl : ContentControl
Public Class PropertyGridSummaryContentControl
    Inherits ContentControl

The PropertyGridSummaryContentControl type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridSummaryContentControl | Initializes an instance of the PropertyGridSummaryContentControl class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAutoSize | Gets or sets whether the gripper auto-sizes to its content when it is double-tapped.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsResizable | Gets or sets whether the gripper is visible and the control can be resized.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | AutoSize | Auto-sizes the content control to the desired size of its content.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CanAutoSizeProperty | Identifies the CanAutoSize dependency property. This field is read-only.
IsResizableProperty | Identifies the IsResizable dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Constructor

Initializes an instance of the PropertyGridSummaryContentControl class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridSummaryContentControl()
Public Sub New
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Properties

The PropertyGridSummaryContentControl type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CanAutoSize | Gets or sets whether the gripper auto-sizes to its content when it is double-tapped.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsResizable | Gets or sets whether the gripper is visible and the control can be resized.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.CanAutoSize Property

PropertyGridSummaryContentControlCanAutoSize Property

Gets or sets whether the gripper auto-sizes to its content when it is double-tapped.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanAutoSize { get; set; }
Public Property CanAutoSize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the gripper auto-sizes to its content when it is double-tapped; otherwise, false. The default value is true.
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.IsResizable Property

PropertyGridSummaryContentControlIsResizable Property

Gets or sets whether the gripper is visible and the control can be resized.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsResizable { get; set; }
Public Property IsResizable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the gripper is visible and the control can be resized; otherwise, false. The default value is true.
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Methods

The PropertyGridSummaryContentControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | AutoSize | Auto-sizes the content control to the desired size of its content.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.AutoSize Method

PropertyGridSummaryContentControlAutoSize Method

Auto-sizes the content control to the desired size of its content.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AutoSize()
Public Sub AutoSize
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.OnApplyTemplate Method

PropertyGridSummaryContentControlOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Events

The PropertyGridSummaryContentControl type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Fields

The PropertyGridSummaryContentControl type exposes the following members.

Fields
Name | Description
CanAutoSizeProperty | Identifies the CanAutoSize dependency property. This field is read-only.
IsResizableProperty | Identifies the IsResizable dependency property. This field is read-only.
Top
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.CanAutoSizeProperty Field

PropertyGridSummaryContentControlCanAutoSizeProperty Field

Identifies the CanAutoSize dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAutoSizeProperty
Public Shared ReadOnly CanAutoSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAutoSize dependency property.
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.IsResizableProperty Field

PropertyGridSummaryContentControlIsResizableProperty Field

Identifies the IsResizable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizableProperty
Public Shared ReadOnly IsResizableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizable dependency property.
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Class

Represents a ToggleButton for toggling the expansion state of a tree item.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.Controls.PrimitivesButtonBase
System.Windows.Controls.PrimitivesToggleButton
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeItemExpansionToggleButton

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeItemExpansionToggleButton : ToggleButton
Public Class TreeItemExpansionToggleButton
    Inherits ToggleButton

The TreeItemExpansionToggleButton type exposes the following members.

Constructors
 | Name | Description
Public method | TreeItemExpansionToggleButton | Initializes an instance of the TreeItemExpansionToggleButton class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnChecked | Called when a ToggleButton raises a Checked event. (Inherited from ToggleButton.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ToggleButtonAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ToggleButton.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnToggle | Called by the OnClick method to implement toggle behavior. (Inherited from ToggleButton.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Constructor

Initializes an instance of the TreeItemExpansionToggleButton class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeItemExpansionToggleButton()
Public Sub New
See Also

Reference

TreeItemExpansionToggleButton Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Properties

The TreeItemExpansionToggleButton type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeItemExpansionToggleButton Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Methods

The TreeItemExpansionToggleButton type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Protected method | OnChecked | Called when a ToggleButton raises a Checked event. (Inherited from ToggleButton.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ToggleButtonAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ToggleButton.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnToggle | Called by the OnClick method to implement toggle behavior. (Inherited from ToggleButton.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeItemExpansionToggleButton Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Events

The TreeItemExpansionToggleButton type exposes the following members.

Events
 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Top
See Also

Reference

TreeItemExpansionToggleButton Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Class

Represents a resize gripper for a TreeListViewColumn.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewColumnResizeGripper

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewColumnResizeGripper : Control
Public Class TreeListViewColumnResizeGripper
    Inherits Control

The TreeListViewColumnResizeGripper type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumnResizeGripper | Initializes an instance of the TreeListViewColumnResizeGripper class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Constructor

Initializes an instance of the TreeListViewColumnResizeGripper class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewColumnResizeGripper()
Public Sub New
See Also

Reference

TreeListViewColumnResizeGripper Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Properties

The TreeListViewColumnResizeGripper type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListViewColumnResizeGripper Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Methods

The TreeListViewColumnResizeGripper type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeListViewColumnResizeGripper Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Events

The TreeListViewColumnResizeGripper type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

TreeListViewColumnResizeGripper Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel Class

A panel that arranges a TreeListView header.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewRowPanelBase
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewHeaderRowPanel

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewHeaderRowPanel : TreeListViewRowPanelBase
Public Class TreeListViewHeaderRowPanel
    Inherits TreeListViewRowPanelBase

The TreeListViewHeaderRowPanel type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewHeaderRowPanel | Initializes a new instance of the TreeListViewHeaderRowPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Overrides TreeListViewRowPanelBaseCreateCellElement(TreeListViewColumn).)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. (Overrides FrameworkElementGetLayoutClip(Size).)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Overrides TreeListViewRowPanelBaseOnColumnPropertyChanged(TreeListViewColumn, String).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Inherited from TreeListViewRowPanelBase.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementZIndexes.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel Constructor

Initializes a new instance of the TreeListViewHeaderRowPanel class

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewHeaderRowPanel()
Public Sub New
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel Properties

The TreeListViewHeaderRowPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel Methods

The TreeListViewHeaderRowPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Overrides TreeListViewRowPanelBaseCreateCellElement(TreeListViewColumn).)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. (Overrides FrameworkElementGetLayoutClip(Size).)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Overrides TreeListViewRowPanelBaseOnColumnPropertyChanged(TreeListViewColumn, String).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Inherited from TreeListViewRowPanelBase.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementZIndexes.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.ArrangeOverride Method

TreeListViewHeaderRowPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.CreateCellElement Method

TreeListViewHeaderRowPanelCreateCellElement Method

Creates a Control that should be used within a cell.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Control CreateCellElement(
    TreeListViewColumn column
)
Protected Overrides Function CreateCellElement (
    column As TreeListViewColumn
) As Control

Parameters

column
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumn
The

Return Value

Type: Control
A Control that should be used within a cell.
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.GetLayoutClip Method

TreeListViewHeaderRowPanelGetLayoutClip Method

Returns a geometry for a clipping mask.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Geometry GetLayoutClip(
    Size layoutSlotSize
)
Protected Overrides Function GetLayoutClip (
    layoutSlotSize As Size
) As Geometry

Parameters

layoutSlotSize
Type: System.WindowsSize
The layout slot size.

Return Value

Type: Geometry
The clipping mask geometry.
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.MeasureOverride Method

TreeListViewHeaderRowPanelMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.OnColumnPropertyChanged Method

TreeListViewHeaderRowPanelOnColumnPropertyChanged Method

Occurs when a property on a column has changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnColumnPropertyChanged(
    TreeListViewColumn column,
    string propertyName
)
Protected Overrides Sub OnColumnPropertyChanged (
    column As TreeListViewColumn,
    propertyName As String
)

Parameters

column
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumn
The column.
propertyName
Type: SystemString
The property name.
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.UpdateAllCellElementZIndexes Method

TreeListViewHeaderRowPanelUpdateAllCellElementZIndexes Method

Updates all cell element z-indices.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateAllCellElementZIndexes()
Protected Overrides Sub UpdateAllCellElementZIndexes
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Class

A panel that arranges the cells within a TreeListViewItem.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewRowPanelBase
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewItemRowPanel
ActiproSoftware.Windows.Controls.Grids.PrimitivesPropertyGridItemRowPanel

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeListViewItemRowPanel : TreeListViewRowPanelBase
Public Class TreeListViewItemRowPanel
    Inherits TreeListViewRowPanelBase

The TreeListViewItemRowPanel type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewItemRowPanel | Initializes a new instance of the TreeListViewItemRowPanel class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Overrides TreeListViewRowPanelBaseCreateCellElement(TreeListViewColumn).)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Overrides TreeListViewRowPanelBaseOnColumnPropertyChanged(TreeListViewColumn, String).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementContent.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementZIndexes.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Constructor

Initializes a new instance of the TreeListViewItemRowPanel class

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeListViewItemRowPanel()
Public Sub New
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Properties

The TreeListViewItemRowPanel type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Methods

The TreeListViewItemRowPanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Overrides TreeListViewRowPanelBaseCreateCellElement(TreeListViewColumn).)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Overrides TreeListViewRowPanelBaseOnColumnPropertyChanged(TreeListViewColumn, String).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementContent.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementZIndexes.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.ArrangeOverride Method

TreeListViewItemRowPanelArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.CreateCellElement Method

TreeListViewItemRowPanelCreateCellElement Method

Creates a Control that should be used within a cell.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Control CreateCellElement(
    TreeListViewColumn column
)
Protected Overrides Function CreateCellElement (
    column As TreeListViewColumn
) As Control

Parameters

column
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumn
The

Return Value

Type: Control
A Control that should be used within a cell.
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.MeasureOverride Method

TreeListViewItemRowPanelMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.OnColumnPropertyChanged Method

TreeListViewItemRowPanelOnColumnPropertyChanged Method

Occurs when a property on a column has changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnColumnPropertyChanged(
    TreeListViewColumn column,
    string propertyName
)
Protected Overrides Sub OnColumnPropertyChanged (
    column As TreeListViewColumn,
    propertyName As String
)

Parameters

column
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumn
The column.
propertyName
Type: SystemString
The property name.
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.UpdateAllCellElementContent Method

TreeListViewItemRowPanelUpdateAllCellElementContent Method

Updates all cell element content, which occurs when the data context changes but the data type is the same.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateAllCellElementContent()
Protected Overrides Sub UpdateAllCellElementContent
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.UpdateAllCellElementZIndexes Method

TreeListViewItemRowPanelUpdateAllCellElementZIndexes Method

Updates all cell element z-indices.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void UpdateAllCellElementZIndexes()
Protected Overrides Sub UpdateAllCellElementZIndexes
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase Class

Provides a base panel for arranging a TreeListView header and cells within a TreeListViewItem.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewRowPanelBase
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewHeaderRowPanel
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeListViewItemRowPanel

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class TreeListViewRowPanelBase : Panel,
    IOrientedElement
Public MustInherit Class TreeListViewRowPanelBase
    Inherits Panel
    Implements IOrientedElement

The TreeListViewRowPanelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TreeListViewRowPanelBase | Initializes an instance of the TreeListViewRowPanelBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets the Orientation of the child element layout.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell.
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed.
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same.
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase Constructor

Initializes an instance of the TreeListViewRowPanelBase class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected TreeListViewRowPanelBase()
Protected Sub New
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase Properties

The TreeListViewRowPanelBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Orientation | Gets the Orientation of the child element layout.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.Orientation Property

TreeListViewRowPanelBaseOrientation Property

Gets the Orientation of the child element layout.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; }
Public ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The Orientation of the child element layout.

Implements

IOrientedElementOrientation
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase Methods

The TreeListViewRowPanelBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell.
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed.
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same.
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.CreateCellElement Method

TreeListViewRowPanelBaseCreateCellElement Method

Creates a Control that should be used within a cell.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Control CreateCellElement(
    TreeListViewColumn column
)
Protected MustOverride Function CreateCellElement (
    column As TreeListViewColumn
) As Control

Parameters

column
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumn
The

Return Value

Type: Control
A Control that should be used within a cell.
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.OnColumnPropertyChanged Method

TreeListViewRowPanelBaseOnColumnPropertyChanged Method

Occurs when a property on a column has changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract void OnColumnPropertyChanged(
    TreeListViewColumn column,
    string propertyName
)
Protected MustOverride Sub OnColumnPropertyChanged (
    column As TreeListViewColumn,
    propertyName As String
)

Parameters

column
Type: ActiproSoftware.Windows.Controls.GridsTreeListViewColumn
The column.
propertyName
Type: SystemString
The property name.
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.UpdateAllCellElementContent Method

TreeListViewRowPanelBaseUpdateAllCellElementContent Method

Updates all cell element content, which occurs when the data context changes but the data type is the same.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateAllCellElementContent()
Protected Overridable Sub UpdateAllCellElementContent
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.UpdateAllCellElementZIndexes Method

TreeListViewRowPanelBaseUpdateAllCellElementZIndexes Method

Updates all cell element z-indices.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdateAllCellElementZIndexes()
Protected Overridable Sub UpdateAllCellElementZIndexes
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Class

Stores a collection of tree node items.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Grids.PrimitivesTreeNodeItemCollection

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TreeNodeItemCollection : IList<Object>,
    ICollection<Object>, IEnumerable<Object>, ISelectedTreeItemCollection,
    IEnumerable, INotifyCollectionChanged, ICollectionView
Public Class TreeNodeItemCollection
    Implements IList(Of Object), ICollection(Of Object),
    IEnumerable(Of Object), ISelectedTreeItemCollection, IEnumerable, INotifyCollectionChanged,
    ICollectionView

The TreeNodeItemCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TreeNodeItemCollection | Initializes an instance of the TreeNodeItemCollection class.
Top
Properties
 | Name | Description
Public property | CanFilter | Gets whether this view supports filtering via the Filter property.
Public property | CanGroup | Gets whether this view supports grouping via the GroupDescriptions property.
Public property | CanSort | Gets whether this view supports sorting via the SortDescriptions property.
Public property | Count | Gets the count of items in the collection.
Public property | Culture | Gets or sets the cultural info for any operations of the view that may differ by culture, such as sorting.
Public property | CurrentItem | Gets the current item in the view.
Public property | CurrentPosition | Gets the ordinal position of the CurrentItem within the view.
Public property | Filter | Gets or sets a callback used to determine if an item is suitable for inclusion in the view.
Public property | GroupDescriptions | Gets the collection of GroupDescription objects that describe how the items in the collection are grouped in the view.
Public property | Groups | Gets the top-level groups.
Public property | IsCurrentAfterLast | Gets whether the CurrentItem of the view is beyond the end of the collection.
Public property | IsCurrentBeforeFirst | Gets whether the CurrentItem of the view is beyond the beginning of the collection.
Public property | IsEmpty | Gets whether the resulting view is empty.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | Item | Gets the item at the specified index.
Public property | SortDescriptions | Gets a collection of SortDescription objects that describe how the items in the collection are sorted in the view.
Public property | SourceCollection | Gets the underlying collection.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the collection.
Public method | Clear | Removes all items from the collection.
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | DeferRefresh | Enters a defer cycle that you can use to merge changes to the view and delay automatic refresh.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | IndexOf | Determines the index of a specific item in the list.
Public method | Insert | Inserts an item into the collection at the specified index.
Public method | MoveCurrentTo | Sets the specified item to be the CurrentItem in the view.
Public method | MoveCurrentToFirst | Sets the first item in the view as the CurrentItem.
Public method | MoveCurrentToLast | Sets the last item in the view as the CurrentItem.
Public method | MoveCurrentToNext | Sets the item after the CurrentItem in the view as the CurrentItem.
Public method | MoveCurrentToPosition | Sets the item at the specified index to be the CurrentItem in the view.
Public method | MoveCurrentToPrevious | Sets the item before the CurrentItem in the view as the CurrentItem.
Public method | Refresh | Recreates the view.
Public method | Remove | Removes the specified item from the collection.
Public method | RemoveAt | Removes the item at the specified index of the collection.
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection is changed.
Public event | CurrentChanged | Occurs after the CurrentItem has changed.
Public event | CurrentChanging | Occurs after the CurrentItem has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeObject | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeObject | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllObject | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Constructor

Initializes an instance of the TreeNodeItemCollection class.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TreeNodeItemCollection(
    bool useHasSet
)
Public Sub New (
    useHasSet As Boolean
)

Parameters

useHasSet
Type: SystemBoolean
Whether to use a hash set to handle Contains(TreeNode) checks faster. Only use for selection collections.
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Properties

The TreeNodeItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | CanFilter | Gets whether this view supports filtering via the Filter property.
Public property | CanGroup | Gets whether this view supports grouping via the GroupDescriptions property.
Public property | CanSort | Gets whether this view supports sorting via the SortDescriptions property.
Public property | Count | Gets the count of items in the collection.
Public property | Culture | Gets or sets the cultural info for any operations of the view that may differ by culture, such as sorting.
Public property | CurrentItem | Gets the current item in the view.
Public property | CurrentPosition | Gets the ordinal position of the CurrentItem within the view.
Public property | Filter | Gets or sets a callback used to determine if an item is suitable for inclusion in the view.
Public property | GroupDescriptions | Gets the collection of GroupDescription objects that describe how the items in the collection are grouped in the view.
Public property | Groups | Gets the top-level groups.
Public property | IsCurrentAfterLast | Gets whether the CurrentItem of the view is beyond the end of the collection.
Public property | IsCurrentBeforeFirst | Gets whether the CurrentItem of the view is beyond the beginning of the collection.
Public property | IsEmpty | Gets whether the resulting view is empty.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | Item | Gets the item at the specified index.
Public property | SortDescriptions | Gets a collection of SortDescription objects that describe how the items in the collection are sorted in the view.
Public property | SourceCollection | Gets the underlying collection.
Top
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CanFilter Property

TreeNodeItemCollectionCanFilter Property

Gets whether this view supports filtering via the Filter property.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanFilter { get; }
Public ReadOnly Property CanFilter As Boolean
    Get

Property Value

Type: Boolean
true if this view supports filtering via the Filter property; otherwise, false.

Implements

ICollectionViewCanFilter
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CanGroup Property

TreeNodeItemCollectionCanGroup Property

Gets whether this view supports grouping via the GroupDescriptions property.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanGroup { get; }
Public ReadOnly Property CanGroup As Boolean
    Get

Property Value

Type: Boolean
true if this view supports grouping via the GroupDescriptions property; otherwise, false.

Implements

ICollectionViewCanGroup
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CanSort Property

TreeNodeItemCollectionCanSort Property

Gets whether this view supports sorting via the SortDescriptions property.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanSort { get; }
Public ReadOnly Property CanSort As Boolean
    Get

Property Value

Type: Boolean
true if this view supports sorting via the SortDescriptions property; otherwise, false.

Implements

ICollectionViewCanSort
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Count Property

TreeNodeItemCollectionCount Property

Gets the count of items in the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of items in the collection.

Implements

ICollectionTCount
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Culture Property

TreeNodeItemCollectionCulture Property

Gets or sets the cultural info for any operations of the view that may differ by culture, such as sorting.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CultureInfo Culture { get; set; }
Public Property Culture As CultureInfo
    Get
    Set

Property Value

Type: CultureInfo
The cultural info for any operations of the view that may differ by culture, such as sorting.

Implements

ICollectionViewCulture
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CurrentItem Property

TreeNodeItemCollectionCurrentItem Property

Gets the current item in the view.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object CurrentItem { get; }
Public ReadOnly Property CurrentItem As Object
    Get

Property Value

Type: Object
The current item in the view.

Implements

ICollectionViewCurrentItem
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CurrentPosition Property

TreeNodeItemCollectionCurrentPosition Property

Gets the ordinal position of the CurrentItem within the view.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int CurrentPosition { get; }
Public ReadOnly Property CurrentPosition As Integer
    Get

Property Value

Type: Int32
The ordinal position of the CurrentItem within the view.

Implements

ICollectionViewCurrentPosition
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Filter Property

TreeNodeItemCollectionFilter Property

Gets or sets a callback used to determine if an item is suitable for inclusion in the view.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Predicate<Object> Filter { get; set; }
Public Property Filter As Predicate(Of Object)
    Get
    Set

Property Value

Type: Predicate Object
A callback used to determine if an item is suitable for inclusion in the view.

Implements

ICollectionViewFilter
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.GroupDescriptions Property

TreeNodeItemCollectionGroupDescriptions Property

Gets the collection of GroupDescription objects that describe how the items in the collection are grouped in the view.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<GroupDescription> GroupDescriptions { get; }
Public ReadOnly Property GroupDescriptions As ObservableCollection(Of GroupDescription)
    Get

Property Value

Type: ObservableCollection GroupDescription
The collection of GroupDescription objects that describe how the items in the collection are grouped in the view.

Implements

ICollectionViewGroupDescriptions
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Groups Property

TreeNodeItemCollectionGroups Property

Gets the top-level groups.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyObservableCollection<Object> Groups { get; }
Public ReadOnly Property Groups As ReadOnlyObservableCollection(Of Object)
    Get

Property Value

Type: ReadOnlyObservableCollection Object
The top-level groups.

Implements

ICollectionViewGroups
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.IsCurrentAfterLast Property

TreeNodeItemCollectionIsCurrentAfterLast Property

Gets whether the CurrentItem of the view is beyond the end of the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCurrentAfterLast { get; }
Public ReadOnly Property IsCurrentAfterLast As Boolean
    Get

Property Value

Type: Boolean
true if the CurrentItem of the view is beyond the end of the collection; otherwise, false.

Implements

ICollectionViewIsCurrentAfterLast
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.IsCurrentBeforeFirst Property

TreeNodeItemCollectionIsCurrentBeforeFirst Property

Gets whether the CurrentItem of the view is beyond the beginning of the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCurrentBeforeFirst { get; }
Public ReadOnly Property IsCurrentBeforeFirst As Boolean
    Get

Property Value

Type: Boolean
true if the CurrentItem of the view is beyond the beginning of the collection; otherwise, false.

Implements

ICollectionViewIsCurrentBeforeFirst
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.IsEmpty Property

TreeNodeItemCollectionIsEmpty Property

Gets whether the resulting view is empty.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the resulting view is empty; otherwise, false.

Implements

ICollectionViewIsEmpty
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.IsReadOnly Property

TreeNodeItemCollectionIsReadOnly Property

Gets a value indicating whether the collection is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the collection is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Item Property

TreeNodeItemCollectionItem Property

Gets the item at the specified index.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As Object
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the item to return.

Property Value

Type: Object
The item at the specified index.

Implements

IListTItemInt32
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.SortDescriptions Property

TreeNodeItemCollectionSortDescriptions Property

Gets a collection of SortDescription objects that describe how the items in the collection are sorted in the view.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SortDescriptionCollection SortDescriptions { get; }
Public ReadOnly Property SortDescriptions As SortDescriptionCollection
    Get

Property Value

Type: SortDescriptionCollection
A collection of SortDescription objects that describe how the items in the collection are sorted in the view.

Implements

ICollectionViewSortDescriptions
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.SourceCollection Property

TreeNodeItemCollectionSourceCollection Property

Gets the underlying collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable SourceCollection { get; }
Public ReadOnly Property SourceCollection As IEnumerable
    Get

Property Value

Type: IEnumerable
The underlying collection.

Implements

ICollectionViewSourceCollection
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Methods

The TreeNodeItemCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the collection.
Public method | Clear | Removes all items from the collection.
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | DeferRefresh | Enters a defer cycle that you can use to merge changes to the view and delay automatic refresh.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | IndexOf | Determines the index of a specific item in the list.
Public method | Insert | Inserts an item into the collection at the specified index.
Public method | MoveCurrentTo | Sets the specified item to be the CurrentItem in the view.
Public method | MoveCurrentToFirst | Sets the first item in the view as the CurrentItem.
Public method | MoveCurrentToLast | Sets the last item in the view as the CurrentItem.
Public method | MoveCurrentToNext | Sets the item after the CurrentItem in the view as the CurrentItem.
Public method | MoveCurrentToPosition | Sets the item at the specified index to be the CurrentItem in the view.
Public method | MoveCurrentToPrevious | Sets the item before the CurrentItem in the view as the CurrentItem.
Public method | Refresh | Recreates the view.
Public method | Remove | Removes the specified item from the collection.
Public method | RemoveAt | Removes the item at the specified index of the collection.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeObject | Adds the elements of the specified collection to the end of the list. (Defined by ListExtensions.)
Public Extension Method | InsertRangeObject | Inserts the elements of a collection into the list at the specified index. (Defined by ListExtensions.)
Public Extension Method | RemoveAllObject | Removes all the elements that match the conditions defined by the specified predicate. (Defined by ListExtensions.)
Top
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Add Method

TreeNodeItemCollectionAdd Method

Adds an item to the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Add(
    Object item
)
Public Sub Add (
    item As Object
)

Parameters

item
Type: SystemObject
The object to add to the collection.

Implements

ICollectionTAdd(T)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Clear Method

TreeNodeItemCollectionClear Method

Removes all items from the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Contains Method

TreeNodeItemCollectionContains Method

Determines whether the collection contains a specific value.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Contains(
    Object item
)
Public Function Contains (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
The object to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.

Implements

ICollectionTContains(T)
ICollectionViewContains(Object)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CopyTo Method

TreeNodeItemCollectionCopyTo Method

Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void CopyTo(
    Object[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Object(),
    arrayIndex As Integer
)

Parameters

array
Type: SystemObject
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.DeferRefresh Method

TreeNodeItemCollectionDeferRefresh Method

Enters a defer cycle that you can use to merge changes to the view and delay automatic refresh.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDisposable DeferRefresh()
Public Function DeferRefresh As IDisposable

Return Value

Type: IDisposable
An IDisposable object that you can use to dispose of the calling object.

Implements

ICollectionViewDeferRefresh
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.GetEnumerator Method

TreeNodeItemCollectionGetEnumerator Method

Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<Object> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Object)

Return Value

Type: IEnumerator Object
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.IndexOf Method

TreeNodeItemCollectionIndexOf Method

Determines the index of a specific item in the list.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    Object item
)
Public Function IndexOf (
    item As Object
) As Integer

Parameters

item
Type: SystemObject
The object to locate in the list.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Insert Method

TreeNodeItemCollectionInsert Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Insert(
    int index,
    Object item
)
Public Sub Insert (
    index As Integer,
    item As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which the item should be inserted.
item
Type: SystemObject
The item to insert.

Implements

IListTInsert(Int32, T)
Remarks
If index is equal to Count, value is added to the end of the collection.
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentTo Method

TreeNodeItemCollectionMoveCurrentTo Method

Sets the specified item to be the CurrentItem in the view.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveCurrentTo(
    Object item
)
Public Function MoveCurrentTo (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
The item to set.

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentTo(Object)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToFirst Method

TreeNodeItemCollectionMoveCurrentToFirst Method

Sets the first item in the view as the CurrentItem.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveCurrentToFirst()
Public Function MoveCurrentToFirst As Boolean

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToFirst
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToLast Method

TreeNodeItemCollectionMoveCurrentToLast Method

Sets the last item in the view as the CurrentItem.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveCurrentToLast()
Public Function MoveCurrentToLast As Boolean

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToLast
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToNext Method

TreeNodeItemCollectionMoveCurrentToNext Method

Sets the item after the CurrentItem in the view as the CurrentItem.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveCurrentToNext()
Public Function MoveCurrentToNext As Boolean

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToNext
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToPosition Method

TreeNodeItemCollectionMoveCurrentToPosition Method

Sets the item at the specified index to be the CurrentItem in the view.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveCurrentToPosition(
    int position
)
Public Function MoveCurrentToPosition (
    position As Integer
) As Boolean

Parameters

position
Type: SystemInt32
The index to set the CurrentItem to.

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToPosition(Int32)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToPrevious Method

TreeNodeItemCollectionMoveCurrentToPrevious Method

Sets the item before the CurrentItem in the view as the CurrentItem.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool MoveCurrentToPrevious()
Public Function MoveCurrentToPrevious As Boolean

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToPrevious
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Refresh Method

TreeNodeItemCollectionRefresh Method

Recreates the view.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh

Implements

ICollectionViewRefresh
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Remove Method

TreeNodeItemCollectionRemove Method

Removes the specified item from the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Remove(
    Object item
)
Public Function Remove (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
The item to remove.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Grids.Primitives.TreeNodeItemCollection.Remove(System.Object)"]

Implements

ICollectionTRemove(T)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.RemoveAt Method

TreeNodeItemCollectionRemoveAt Method

Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Events

The TreeNodeItemCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection is changed.
Public event | CurrentChanged | Occurs after the CurrentItem has changed.
Public event | CurrentChanging | Occurs after the CurrentItem has changed.
Top
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CollectionChanged Event

TreeNodeItemCollectionCollectionChanged Event

Occurs when the collection is changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CurrentChanged Event

TreeNodeItemCollectionCurrentChanged Event

Occurs after the CurrentItem has changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler CurrentChanged
Public Event CurrentChanged As EventHandler

Value

Type: SystemEventHandler

Implements

ICollectionViewCurrentChanged
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CurrentChanging Event

TreeNodeItemCollectionCurrentChanging Event

Occurs after the CurrentItem has changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.Primitives
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event CurrentChangingEventHandler CurrentChanging
Public Event CurrentChanging As CurrentChangingEventHandler

Value

Type: System.ComponentModelCurrentChangingEventHandler

Implements

ICollectionViewCurrentChanging
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.Windows.Controls.Grids.Primitives Namespace


ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace

Contains the classes used for PropertyGrid model data.
Classes
 | Class | Description
Public class | CachedPropertyModelBase | Provides an abstract base class for a property grid property IDataModel that caches the values returned as an optimization.
Public class | CategoryEditorModel | Represents a property grid category editor IDataModel.
Public class | CategoryModel | Represents a property grid category IDataModel.
Public class | CollectionPropertyDescriptorPropertyModel | Represents a property grid collection property IDataModel that is based on PropertyDescriptor data.
Public class | DataFactoryBase | Provides an abstract base class for an IDataFactory implementation.
Public class | DataModelBase | Provides an abstract base class for a property grid IDataModel.
Public class | DataModelCollection | Represents a collection of IDataModel objects.
Public class | DataModelSortComparer | Provides a comparer implementation for sorting IDataModel objects in order of sort importance, sort order, numeric display name index (if applicable), and finally display name.
Public class | ExpandableCollectionConverter | Represents a type converter that is capable of expanding various collection types.
Protected class | ExpandableCollectionConverterCollectionItemPropertyDescriptor |
Protected class | ExpandableCollectionConverterDictionaryItemPropertyDescriptor |
Protected class | ExpandableCollectionConverterListItemPropertyDescriptor |
Public class | MergedPropertyModel | Represents a property grid property IDataModel that merges a property from multiple data objects.
Public class | PropertyDescriptorPropertyModel | Represents a property grid property IDataModel that is based on PropertyDescriptor data.
Public class | PropertyModel | Represents a property grid property IDataModel that can be easily explicitly-defined and optionally bound to in XAML.
Public class | PropertyModelBase | Provides an abstract base class for a property grid IDataModel that can provide the foundation for an IPropertyModel implementation.
Public class | PropertyModelBooleanFilter | Represents a IDataFilter implementation for IPropertyModel boolean properties.
Public class | PropertyModelCollection | Represents a collection of IPropertyModel objects.
Public class | PropertyModelStringFilter | Represents a IDataFilter implementation for IPropertyModel string properties.
Public class | TypeDescriptorFactory | Implements an IDataFactory that uses type descriptors to return data models.
Interfaces
 | Interface | Description
Public interface | ICategoryEditorModel | Provides the requirements for a property grid category editor IDataModel, that can consume and display one or more properties.
Public interface | ICategoryModel | Provides the requirements for a property grid category IDataModel.
Public interface | ICollectionItemPropertyDescriptor | Identifies an object as a property descriptor for an item in a collection.
Public interface | ICollectionTypeConverter | Identifies an object as a type converter for a collection used to control how and when items should be added.
Public interface | IDataFactory | Provides the requirements for class that can return the data models for requested object values.
Public interface | IDataFactoryRequest | Provides the core requirements of a request made to an IDataFactory.
Public interface | IDataModel | Provides the requirements for a data model class that can represent a property or category in a property grid.
Public interface | IPropertyModel | Provides the requirements for a property grid property IDataModel.
Public interface | IRootModel | Provides the requirements for a data model class that is the root model in the hierarchy.
Enumerations
 | Enumeration | Description
Public enumeration | CollectionPropertyDisplayMode | Specifies the display mode of collection properties in the property grid.
Public enumeration | DataModelSortImportance | Specifies the sort importance of data models.
Public enumeration | PropertyExpandability | Specifies the expandability of properties in the property grid.
Public enumeration | PropertyModelBooleanFilterSource | Specifies the source IPropertyModel boolean properties that can be used by a PropertyModelBooleanFilter.
Public enumeration | PropertyModelStringFilterSource | Specifies the source IPropertyModel string properties that can be used by a PropertyModelStringFilter.
Public enumeration | PropertyRefreshReason | Specifies the reason a property is being refreshed.


CachedPropertyModelBase Class

Provides an abstract base class for a property grid property IDataModel that caches the values returned as an optimization.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataCachedPropertyModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataMergedPropertyModel
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyDescriptorPropertyModel

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class CachedPropertyModelBase : PropertyModelBase,
    IDataModel, IPropertyModel
Public MustInherit Class CachedPropertyModelBase
    Inherits PropertyModelBase
    Implements IDataModel, IPropertyModel

The CachedPropertyModelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CachedPropertyModelBase | Initializes a new instance of the CachedPropertyModelBase class
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent.
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Overrides PropertyModelBaseCanAddChildResolved.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent.
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Overrides PropertyModelBaseCanRemoveResolved.)
Public property | CanResetValue | Gets whether the property can be reset to its default value.
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value.
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Overrides PropertyModelBaseCanResetValueResolved.)
Public property | Category | Gets a category for the property.
Protected property | CategoryCore | Gets a category for the property.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property.
Protected property | ConverterCore | Gets the TypeConverter to use for the property.
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Overrides PropertyModelBaseConverterResolved.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Overrides PropertyModelBaseHasStandardValues.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited.
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Overrides PropertyModelBaseIsImmutableResolved.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets whether the data model has been modified.
Protected property | IsModifiedCore | Gets whether the data model has been modified.
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only.
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Overrides PropertyModelBaseIsValueReadOnlyResolved.)
Public property | Name | Gets the name of the data model.
Protected property | NameCore | Gets the name of the data model.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name.
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name.
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes.
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Overrides PropertyModelBaseShouldNotifyParentOnValueChangeResolved.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | StandardValues | Gets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings.
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings.
Protected property | StandardValuesCore | Gets the standard list of values for the Value property.
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from PropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Overrides PropertyModelBaseStandardValuesResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property.
Protected property | TargetCore | Gets the target object that owns the property.
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Overrides PropertyModelBaseTargetResolved.)
Public property | TargetType | Gets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation.
Protected property | ValueCore | Gets or sets the property value.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Overrides PropertyModelBaseValueResolved.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value.
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value.
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value.
Public property | ValueType | Gets the Type of the Value property.
Protected property | ValueTypeCore | Gets the Type of the Value property.
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Overrides PropertyModelBaseValueTypeResolved.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides PropertyModelBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from PropertyModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase Constructor

Initializes a new instance of the CachedPropertyModelBase class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected CachedPropertyModelBase()
Protected Sub New
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase Properties

The CachedPropertyModelBase type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent.
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Overrides PropertyModelBaseCanAddChildResolved.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent.
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Overrides PropertyModelBaseCanRemoveResolved.)
Public property | CanResetValue | Gets whether the property can be reset to its default value.
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value.
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Overrides PropertyModelBaseCanResetValueResolved.)
Public property | Category | Gets a category for the property.
Protected property | CategoryCore | Gets a category for the property.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property.
Protected property | ConverterCore | Gets the TypeConverter to use for the property.
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Overrides PropertyModelBaseConverterResolved.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Overrides PropertyModelBaseHasStandardValues.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited.
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Overrides PropertyModelBaseIsImmutableResolved.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets whether the data model has been modified.
Protected property | IsModifiedCore | Gets whether the data model has been modified.
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only.
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Overrides PropertyModelBaseIsValueReadOnlyResolved.)
Public property | Name | Gets the name of the data model.
Protected property | NameCore | Gets the name of the data model.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name.
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name.
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes.
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Overrides PropertyModelBaseShouldNotifyParentOnValueChangeResolved.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | StandardValues | Gets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings.
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings.
Protected property | StandardValuesCore | Gets the standard list of values for the Value property.
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from PropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Overrides PropertyModelBaseStandardValuesResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property.
Protected property | TargetCore | Gets the target object that owns the property.
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Overrides PropertyModelBaseTargetResolved.)
Public property | TargetType | Gets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation.
Protected property | ValueCore | Gets or sets the property value.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Overrides PropertyModelBaseValueResolved.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value.
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value.
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value.
Public property | ValueType | Gets the Type of the Value property.
Protected property | ValueTypeCore | Gets the Type of the Value property.
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Overrides PropertyModelBaseValueTypeResolved.)
Top
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanAddChild Property

CachedPropertyModelBaseCanAddChild Property

Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanAddChild { get; }
Public Overridable ReadOnly Property CanAddChild As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.

Implements

IPropertyModelCanAddChild
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanAddChildCore Property

CachedPropertyModelBaseCanAddChildCore Property

Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool CanAddChildCore { get; }
Protected Overridable ReadOnly Property CanAddChildCore As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanAddChildResolved Property

CachedPropertyModelBaseCanAddChildResolved Property

Gets the resolved value for whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed bool CanAddChildResolved { get; }
Protected Overrides NotOverridable ReadOnly Property CanAddChildResolved As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanRemove Property

CachedPropertyModelBaseCanRemove Property

Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanRemove { get; }
Public Overridable ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.

Implements

IPropertyModelCanRemove
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanRemoveCore Property

CachedPropertyModelBaseCanRemoveCore Property

Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool CanRemoveCore { get; }
Protected Overridable ReadOnly Property CanRemoveCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanRemoveResolved Property

CachedPropertyModelBaseCanRemoveResolved Property

Gets the resolved value for whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed bool CanRemoveResolved { get; }
Protected Overrides NotOverridable ReadOnly Property CanRemoveResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanResetValue Property

CachedPropertyModelBaseCanResetValue Property

Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanResetValue { get; }
Public Overridable ReadOnly Property CanResetValue As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.

Implements

IPropertyModelCanResetValue
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanResetValueCore Property

CachedPropertyModelBaseCanResetValueCore Property

Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool CanResetValueCore { get; }
Protected MustOverride ReadOnly Property CanResetValueCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanResetValueResolved Property

CachedPropertyModelBaseCanResetValueResolved Property

Gets the resolved value for whether the property can be reset to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed bool CanResetValueResolved { get; }
Protected Overrides NotOverridable ReadOnly Property CanResetValueResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Category Property

CachedPropertyModelBaseCategory Property

Gets a category for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string Category { get; }
Public Overridable ReadOnly Property Category As String
    Get

Property Value

Type: String
A category for the property.

Implements

IPropertyModelCategory
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CategoryCore Property

CachedPropertyModelBaseCategoryCore Property

Gets a category for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string CategoryCore { get; }
Protected Overridable ReadOnly Property CategoryCore As String
    Get

Property Value

Type: String
A category for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Converter Property

CachedPropertyModelBaseConverter Property

Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual TypeConverter Converter { get; }
Public Overridable ReadOnly Property Converter As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.

Implements

IPropertyModelConverter
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ConverterCore Property

CachedPropertyModelBaseConverterCore Property

Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual TypeConverter ConverterCore { get; }
Protected Overridable ReadOnly Property ConverterCore As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ConverterResolved Property

CachedPropertyModelBaseConverterResolved Property

Gets the resolved TypeConverter to use for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed TypeConverter ConverterResolved { get; }
Protected Overrides NotOverridable ReadOnly Property ConverterResolved As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Description Property

CachedPropertyModelBaseDescription Property

Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string Description { get; }
Public Overridable ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.

Implements

IDataModelDescription
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DescriptionCore Property

CachedPropertyModelBaseDescriptionCore Property

Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string DescriptionCore { get; }
Protected Overridable ReadOnly Property DescriptionCore As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DescriptionResolved Property

CachedPropertyModelBaseDescriptionResolved Property

Gets the resolved description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed string DescriptionResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DescriptionResolved As String
    Get

Property Value

Type: String
The resolved description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DisplayName Property

CachedPropertyModelBaseDisplayName Property

Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string DisplayName { get; }
Public Overridable ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.

Implements

IDataModelDisplayName
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DisplayNameCore Property

CachedPropertyModelBaseDisplayNameCore Property

Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string DisplayNameCore { get; }
Protected Overridable ReadOnly Property DisplayNameCore As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DisplayNameResolved Property

CachedPropertyModelBaseDisplayNameResolved Property

Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed string DisplayNameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DisplayNameResolved As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.HasStandardValues Property

CachedPropertyModelBaseHasStandardValues Property

Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool HasStandardValues { get; }
Public Overrides ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.

Implements

IPropertyModelHasStandardValues
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.HasStandardValuesCore Property

CachedPropertyModelBaseHasStandardValuesCore Property

Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool HasStandardValuesCore { get; }
Protected Overridable ReadOnly Property HasStandardValuesCore As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsImmutable Property

CachedPropertyModelBaseIsImmutable Property

Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsImmutable { get; }
Public Overridable ReadOnly Property IsImmutable As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.

Implements

IPropertyModelIsImmutable
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsImmutableCore Property

CachedPropertyModelBaseIsImmutableCore Property

Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsImmutableCore { get; }
Protected Overridable ReadOnly Property IsImmutableCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsImmutableResolved Property

CachedPropertyModelBaseIsImmutableResolved Property

Gets the resolved value for whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed bool IsImmutableResolved { get; }
Protected Overrides NotOverridable ReadOnly Property IsImmutableResolved As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsLimitedToStandardValues Property

CachedPropertyModelBaseIsLimitedToStandardValues Property

Gets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsLimitedToStandardValues { get; }
Public Overridable ReadOnly Property IsLimitedToStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.

Implements

IPropertyModelIsLimitedToStandardValues
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsLimitedToStandardValuesCore Property

CachedPropertyModelBaseIsLimitedToStandardValuesCore Property

Gets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsLimitedToStandardValuesCore { get; }
Protected Overridable ReadOnly Property IsLimitedToStandardValuesCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsMergeable Property

CachedPropertyModelBaseIsMergeable Property

Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsMergeable { get; }
Public Overridable ReadOnly Property IsMergeable As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.

Implements

IPropertyModelIsMergeable
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsMergeableCore Property

CachedPropertyModelBaseIsMergeableCore Property

Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool IsMergeableCore { get; }
Protected MustOverride ReadOnly Property IsMergeableCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsModified Property

CachedPropertyModelBaseIsModified Property

Gets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsModified { get; }
Public Overridable ReadOnly Property IsModified As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.

Implements

IDataModelIsModified
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsModifiedCore Property

CachedPropertyModelBaseIsModifiedCore Property

Gets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool IsModifiedCore { get; }
Protected MustOverride ReadOnly Property IsModifiedCore As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsModifiedResolved Property

CachedPropertyModelBaseIsModifiedResolved Property

Gets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed bool IsModifiedResolved { get; }
Protected Overrides NotOverridable ReadOnly Property IsModifiedResolved As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsValueReadOnly Property

CachedPropertyModelBaseIsValueReadOnly Property

Gets or sets whether the Value property is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsValueReadOnly { get; set; }
Public Overridable Property IsValueReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.

Implements

IPropertyModelIsValueReadOnly
Remarks
This property can be set to true to force a normally-editable property to be read-only. Some implementations of this property will always return true when the underlying property value is unable to be set.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsValueReadOnlyCore Property

CachedPropertyModelBaseIsValueReadOnlyCore Property

Gets whether the Value property is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool IsValueReadOnlyCore { get; }
Protected MustOverride ReadOnly Property IsValueReadOnlyCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsValueReadOnlyResolved Property

CachedPropertyModelBaseIsValueReadOnlyResolved Property

Gets the resolved value for whether the Value property is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed bool IsValueReadOnlyResolved { get; }
Protected Overrides NotOverridable ReadOnly Property IsValueReadOnlyResolved As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Name Property

CachedPropertyModelBaseName Property

Gets the name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the data model.

Implements

IDataModelName
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameCore Property

CachedPropertyModelBaseNameCore Property

Gets the name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract string NameCore { get; }
Protected MustOverride ReadOnly Property NameCore As String
    Get

Property Value

Type: String
The name of the data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameResolved Property

CachedPropertyModelBaseNameResolved Property

Gets the resolved name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed string NameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property NameResolved As String
    Get

Property Value

Type: String
The resolved name of the data model.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplate Property

CachedPropertyModelBaseNameTemplate Property

Gets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataTemplate NameTemplate { get; }
Public Overridable ReadOnly Property NameTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.

Implements

IPropertyModelNameTemplate
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateCore Property

CachedPropertyModelBaseNameTemplateCore Property

Gets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual DataTemplate NameTemplateCore { get; }
Protected Overridable ReadOnly Property NameTemplateCore As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateKey Property

CachedPropertyModelBaseNameTemplateKey Property

Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Object NameTemplateKey { get; }
Public Overridable ReadOnly Property NameTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.

Implements

IPropertyModelNameTemplateKey
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateKeyCore Property

CachedPropertyModelBaseNameTemplateKeyCore Property

Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Object NameTemplateKeyCore { get; }
Protected Overridable ReadOnly Property NameTemplateKeyCore As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateSelector Property

CachedPropertyModelBaseNameTemplateSelector Property

Gets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataTemplateSelector NameTemplateSelector { get; }
Public Overridable ReadOnly Property NameTemplateSelector As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.

Implements

IPropertyModelNameTemplateSelector
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateSelectorCore Property

CachedPropertyModelBaseNameTemplateSelectorCore Property

Gets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual DataTemplateSelector NameTemplateSelectorCore { get; }
Protected Overridable ReadOnly Property NameTemplateSelectorCore As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ShouldNotifyParentOnValueChange Property

CachedPropertyModelBaseShouldNotifyParentOnValueChange Property

Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldNotifyParentOnValueChange { get; }
Public Overridable ReadOnly Property ShouldNotifyParentOnValueChange As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.

Implements

IPropertyModelShouldNotifyParentOnValueChange
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ShouldNotifyParentOnValueChangeCore Property

CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore Property

Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool ShouldNotifyParentOnValueChangeCore { get; }
Protected Overridable ReadOnly Property ShouldNotifyParentOnValueChangeCore As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ShouldNotifyParentOnValueChangeResolved Property

CachedPropertyModelBaseShouldNotifyParentOnValueChangeResolved Property

Gets the resolved value for whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed bool ShouldNotifyParentOnValueChangeResolved { get; }
Protected Overrides NotOverridable ReadOnly Property ShouldNotifyParentOnValueChangeResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortImportance Property

CachedPropertyModelBaseSortImportance Property

Gets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataModelSortImportance SortImportance { get; }
Public Overridable ReadOnly Property SortImportance As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.

Implements

IDataModelSortImportance
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortImportanceCore Property

CachedPropertyModelBaseSortImportanceCore Property

Gets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual DataModelSortImportance SortImportanceCore { get; }
Protected Overridable ReadOnly Property SortImportanceCore As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortImportanceResolved Property

CachedPropertyModelBaseSortImportanceResolved Property

Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed DataModelSortImportance SortImportanceResolved { get; }
Protected Overrides NotOverridable ReadOnly Property SortImportanceResolved As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortOrder Property

CachedPropertyModelBaseSortOrder Property

Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual int SortOrder { get; }
Public Overridable ReadOnly Property SortOrder As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.

Implements

IDataModelSortOrder
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortOrderCore Property

CachedPropertyModelBaseSortOrderCore Property

Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual int SortOrderCore { get; }
Protected Overridable ReadOnly Property SortOrderCore As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortOrderResolved Property

CachedPropertyModelBaseSortOrderResolved Property

Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed int SortOrderResolved { get; }
Protected Overrides NotOverridable ReadOnly Property SortOrderResolved As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValues Property

CachedPropertyModelBaseStandardValues Property

Gets the standard list of values for the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IEnumerable StandardValues { get; }
Public Overridable ReadOnly Property StandardValues As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.

Implements

IPropertyModelStandardValues
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValuesAsStrings Property

CachedPropertyModelBaseStandardValuesAsStrings Property

Gets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IEnumerable<string> StandardValuesAsStrings { get; }
Public Overridable ReadOnly Property StandardValuesAsStrings As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.

Implements

IPropertyModelStandardValuesAsStrings
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValuesAsStringsCore Property

CachedPropertyModelBaseStandardValuesAsStringsCore Property

Gets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IEnumerable<string> StandardValuesAsStringsCore { get; }
Protected Overridable ReadOnly Property StandardValuesAsStringsCore As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValuesCore Property

CachedPropertyModelBaseStandardValuesCore Property

Gets the standard list of values for the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IEnumerable StandardValuesCore { get; }
Protected Overridable ReadOnly Property StandardValuesCore As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValuesResolved Property

CachedPropertyModelBaseStandardValuesResolved Property

Gets the resolved standard list of values for the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed IEnumerable StandardValuesResolved { get; }
Protected Overrides NotOverridable ReadOnly Property StandardValuesResolved As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Target Property

CachedPropertyModelBaseTarget Property

Gets the target object that owns the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Object Target { get; }
Public Overridable ReadOnly Property Target As Object
    Get

Property Value

Type: Object
The target object that owns the property.

Implements

IPropertyModelTarget
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.TargetCore Property

CachedPropertyModelBaseTargetCore Property

Gets the target object that owns the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Object TargetCore { get; }
Protected MustOverride ReadOnly Property TargetCore As Object
    Get

Property Value

Type: Object
The target object that owns the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.TargetResolved Property

CachedPropertyModelBaseTargetResolved Property

Gets the resolved target object that owns the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed Object TargetResolved { get; }
Protected Overrides NotOverridable ReadOnly Property TargetResolved As Object
    Get

Property Value

Type: Object
The target object that owns the property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.TargetType Property

CachedPropertyModelBaseTargetType Property

Gets the Type of the Target property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Type TargetType { get; }
Public Overridable ReadOnly Property TargetType As Type
    Get

Property Value

Type: Type
The Type of the Target property.

Implements

IPropertyModelTargetType
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Value Property

CachedPropertyModelBaseValue Property

Gets or sets the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Object Value { get; set; }
Public Overridable Property Value As Object
    Get
    Set

Property Value

Type: Object
The property value.

Implements

IPropertyModelValue
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueAsString Property

CachedPropertyModelBaseValueAsString Property

Gets or sets the property value in a string representation.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual string ValueAsString { get; set; }
Public Overridable Property ValueAsString As String
    Get
    Set

Property Value

Type: String
The property value in a string representation.

Implements

IPropertyModelValueAsString
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueAsStringCore Property

CachedPropertyModelBaseValueAsStringCore Property

Gets or sets the property value in a string representation.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string ValueAsStringCore { get; set; }
Protected Overridable Property ValueAsStringCore As String
    Get
    Set

Property Value

Type: String
The property value in a string representation.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueCore Property

CachedPropertyModelBaseValueCore Property

Gets or sets the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Object ValueCore { get; set; }
Protected MustOverride Property ValueCore As Object
    Get
    Set

Property Value

Type: Object
The property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueResolved Property

CachedPropertyModelBaseValueResolved Property

Gets or sets the resolved property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed Object ValueResolved { get; set; }
Protected Overrides NotOverridable Property ValueResolved As Object
    Get
    Set

Property Value

Type: Object
The property value.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Values Property

CachedPropertyModelBaseValues Property

Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IList<Object> Values { get; }
Public Overridable ReadOnly Property Values As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.

Implements

IPropertyModelValues
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValuesCore Property

CachedPropertyModelBaseValuesCore Property

Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IList<Object> ValuesCore { get; }
Protected Overridable ReadOnly Property ValuesCore As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplate Property

CachedPropertyModelBaseValueTemplate Property

Gets the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataTemplate ValueTemplate { get; }
Public Overridable ReadOnly Property ValueTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplate
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateCore Property

CachedPropertyModelBaseValueTemplateCore Property

Gets the DataTemplate to use for use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual DataTemplate ValueTemplateCore { get; }
Protected Overridable ReadOnly Property ValueTemplateCore As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateKey Property

CachedPropertyModelBaseValueTemplateKey Property

Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Object ValueTemplateKey { get; }
Public Overridable ReadOnly Property ValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplateKey
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateKeyCore Property

CachedPropertyModelBaseValueTemplateKeyCore Property

Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Object ValueTemplateKeyCore { get; }
Protected Overridable ReadOnly Property ValueTemplateKeyCore As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateKind Property

CachedPropertyModelBaseValueTemplateKind Property

Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DefaultValueTemplateKind ValueTemplateKind { get; }
Public Overridable ReadOnly Property ValueTemplateKind As DefaultValueTemplateKind
    Get

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Implements

IPropertyModelValueTemplateKind
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateKindCore Property

CachedPropertyModelBaseValueTemplateKindCore Property

Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual DefaultValueTemplateKind ValueTemplateKindCore { get; }
Protected Overridable ReadOnly Property ValueTemplateKindCore As DefaultValueTemplateKind
    Get

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateSelector Property

CachedPropertyModelBaseValueTemplateSelector Property

Gets the DataTemplateSelector to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataTemplateSelector ValueTemplateSelector { get; }
Public Overridable ReadOnly Property ValueTemplateSelector As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplateSelector
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, and finally any value templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateSelectorCore Property

CachedPropertyModelBaseValueTemplateSelectorCore Property

Gets the DataTemplateSelector to use for use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual DataTemplateSelector ValueTemplateSelectorCore { get; }
Protected Overridable ReadOnly Property ValueTemplateSelectorCore As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueType Property

CachedPropertyModelBaseValueType Property

Gets the Type of the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Type ValueType { get; }
Public Overridable ReadOnly Property ValueType As Type
    Get

Property Value

Type: Type
The Type of the Value property.

Implements

IPropertyModelValueType
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, and finally any value templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTypeCore Property

CachedPropertyModelBaseValueTypeCore Property

Gets the Type of the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Type ValueTypeCore { get; }
Protected MustOverride ReadOnly Property ValueTypeCore As Type
    Get

Property Value

Type: Type
The Type of the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTypeResolved Property

CachedPropertyModelBaseValueTypeResolved Property

Gets the resolved Type of the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed Type ValueTypeResolved { get; }
Protected Overrides NotOverridable ReadOnly Property ValueTypeResolved As Type
    Get

Property Value

Type: Type
The Type of the Value property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase Methods

The CachedPropertyModelBase type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides PropertyModelBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from PropertyModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.OnPropertyChanged Method

CachedPropertyModelBaseOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase Events

The CachedPropertyModelBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel Class

Represents a property grid category editor IDataModel.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataCategoryEditorModel

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CategoryEditorModel : DataModelBase,
    IDataModel, ICategoryEditorModel
Public Class CategoryEditorModel
    Inherits DataModelBase
    Implements IDataModel, ICategoryEditorModel

The CategoryEditorModel type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditorModel | Initializes an instance of the CategoryEditorModel class.
Public method | CategoryEditorModel(CategoryEditor) | Initializes an instance of the CategoryEditorModel class.
Top
Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CategoryEditor | Gets the CategoryEditor that was used to create this data model.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | EditorTemplate | Gets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | Name | Gets or sets the name of the data model.
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel Constructor

Overload List
 | Name | Description
Public method | CategoryEditorModel | Initializes an instance of the CategoryEditorModel class.
Public method | CategoryEditorModel(CategoryEditor) | Initializes an instance of the CategoryEditorModel class.
Top
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel Constructor

Initializes an instance of the CategoryEditorModel class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryEditorModel()
Public Sub New
See Also

Reference

CategoryEditorModel Class
CategoryEditorModel Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel Constructor (CategoryEditor)

Initializes an instance of the CategoryEditorModel class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryEditorModel(
    CategoryEditor categoryEditor
)
Public Sub New (
    categoryEditor As CategoryEditor
)

Parameters

categoryEditor
Type: ActiproSoftware.Windows.Controls.Grids.PropertyEditorsCategoryEditor
The CategoryEditor that was used to create this data model.
See Also

Reference

CategoryEditorModel Class
CategoryEditorModel Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel Properties

The CategoryEditorModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CategoryEditor | Gets the CategoryEditor that was used to create this data model.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | EditorTemplate | Gets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | Name | Gets or sets the name of the data model.
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Top
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.CategoryEditor Property

CategoryEditorModelCategoryEditor Property

Gets the CategoryEditor that was used to create this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryEditor CategoryEditor { get; }
Public ReadOnly Property CategoryEditor As CategoryEditor
    Get

Property Value

Type: CategoryEditor
The CategoryEditor that was used to create this data model.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.Description Property

CategoryEditorModelDescription Property

Gets or sets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.

Implements

IDataModelDescription
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.DescriptionResolved Property

CategoryEditorModelDescriptionResolved Property

Gets the resolved description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed string DescriptionResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DescriptionResolved As String
    Get

Property Value

Type: String
The resolved description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.DisplayName Property

CategoryEditorModelDisplayName Property

Gets or sets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.

Implements

IDataModelDisplayName
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.DisplayNameResolved Property

CategoryEditorModelDisplayNameResolved Property

Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed string DisplayNameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DisplayNameResolved As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.EditorTemplate Property

CategoryEditorModelEditorTemplate Property

Gets the DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate EditorTemplate { get; set; }
Public Property EditorTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for editing the properties consumed by this editor.

Implements

ICategoryEditorModelEditorTemplate
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.EditorTemplateKey Property

CategoryEditorModelEditorTemplateKey Property

Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object EditorTemplateKey { get; set; }
Public Property EditorTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the properties consumed by this editor.

Implements

ICategoryEditorModelEditorTemplateKey
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.IsModifiedResolved Property

CategoryEditorModelIsModifiedResolved Property

Gets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsModifiedResolved { get; }
Protected Overrides ReadOnly Property IsModifiedResolved As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.Name Property

CategoryEditorModelName Property

Gets or sets the name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the data model.

Implements

IDataModelName
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.NameResolved Property

CategoryEditorModelNameResolved Property

Gets the resolved name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed string NameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property NameResolved As String
    Get

Property Value

Type: String
The resolved name of the data model.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.SortImportanceResolved Property

CategoryEditorModelSortImportanceResolved Property

Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DataModelSortImportance SortImportanceResolved { get; }
Protected Overrides ReadOnly Property SortImportanceResolved As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.SortOrder Property

CategoryEditorModelSortOrder Property

Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SortOrder { get; set; }
Public Property SortOrder As Integer
    Get
    Set

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.

Implements

IDataModelSortOrder
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel.SortOrderResolved Property

CategoryEditorModelSortOrderResolved Property

Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed int SortOrderResolved { get; }
Protected Overrides NotOverridable ReadOnly Property SortOrderResolved As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel Methods

The CategoryEditorModel type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryEditorModel Events

The CategoryEditorModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel Class

Represents a property grid category IDataModel.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataCategoryModel

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CategoryModel : DataModelBase,
    IDataModel, ICategoryModel
Public Class CategoryModel
    Inherits DataModelBase
    Implements IDataModel, ICategoryModel

The CategoryModel type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryModel | Initializes an instance of the CategoryModel class.
Top
Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | Name | Gets or sets the name of the data model.
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel Constructor

Initializes an instance of the CategoryModel class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryModel(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The category name.
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel Properties

The CategoryModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | Name | Gets or sets the name of the data model.
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Top
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.Description Property

CategoryModelDescription Property

Gets or sets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.

Implements

IDataModelDescription
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.DescriptionResolved Property

CategoryModelDescriptionResolved Property

Gets the resolved description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed string DescriptionResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DescriptionResolved As String
    Get

Property Value

Type: String
The resolved description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.DisplayName Property

CategoryModelDisplayName Property

Gets or sets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.

Implements

IDataModelDisplayName
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.DisplayNameResolved Property

CategoryModelDisplayNameResolved Property

Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed string DisplayNameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DisplayNameResolved As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.IsModifiedResolved Property

CategoryModelIsModifiedResolved Property

Gets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed bool IsModifiedResolved { get; }
Protected Overrides NotOverridable ReadOnly Property IsModifiedResolved As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.Name Property

CategoryModelName Property

Gets or sets the name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the data model.

Implements

IDataModelName
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.NameResolved Property

CategoryModelNameResolved Property

Gets the resolved name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed string NameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property NameResolved As String
    Get

Property Value

Type: String
The resolved name of the data model.
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.SortImportanceResolved Property

CategoryModelSortImportanceResolved Property

Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DataModelSortImportance SortImportanceResolved { get; }
Protected Overrides ReadOnly Property SortImportanceResolved As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.SortOrder Property

CategoryModelSortOrder Property

Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SortOrder { get; set; }
Public Property SortOrder As Integer
    Get
    Set

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.

Implements

IDataModelSortOrder
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel.SortOrderResolved Property

CategoryModelSortOrderResolved Property

Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override sealed int SortOrderResolved { get; }
Protected Overrides NotOverridable ReadOnly Property SortOrderResolved As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel Methods

The CategoryModel type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CategoryModel Events

The CategoryModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Class

Represents a property grid collection property IDataModel that is based on PropertyDescriptor data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataCachedPropertyModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyDescriptorPropertyModel
ActiproSoftware.Windows.Controls.Grids.PropertyDataCollectionPropertyDescriptorPropertyModel

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CollectionPropertyDescriptorPropertyModel : PropertyDescriptorPropertyModel
Public Class CollectionPropertyDescriptorPropertyModel
    Inherits PropertyDescriptorPropertyModel

The CollectionPropertyDescriptorPropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionPropertyDescriptorPropertyModel | Initializes an instance of the CollectionPropertyDescriptorPropertyModel class.
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | AreItemsReadOnly | Gets whether the values of the items in the collection are read-only and cannot be changed.
Public property | AttachedCollectionValue | Gets or sets the collection object that is attached for change notification, if any.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Overrides CachedPropertyModelBaseCanAddChildCore.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Inherited from PropertyDescriptorPropertyModel.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides PropertyDescriptorPropertyModelConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsCollectionReadOnly | Gets whether items can be added to or removed from the collection.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Inherited from PropertyDescriptorPropertyModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Inherited from PropertyDescriptorPropertyModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from PropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from CachedPropertyModelBase.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Inherited from PropertyDescriptorPropertyModel.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Overrides PropertyModelBaseAddChild.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Protected method | CreateExpandableCollectionConverter | Creates a new expandable collection TypeConverter.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides PropertyDescriptorPropertyModelDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides CachedPropertyModelBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyDescriptorPropertyModel.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from PropertyDescriptorPropertyModel.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Constructor

Initializes an instance of the CollectionPropertyDescriptorPropertyModel class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CollectionPropertyDescriptorPropertyModel(
    Object target,
    PropertyDescriptor propertyDescriptor,
    bool isCollectionReadOnly,
    bool areItemsReadOnly
)
Public Sub New (
    target As Object,
    propertyDescriptor As PropertyDescriptor,
    isCollectionReadOnly As Boolean,
    areItemsReadOnly As Boolean
)

Parameters

target
Type: SystemObject
The target object that owns the property.
propertyDescriptor
Type: System.ComponentModelPropertyDescriptor
The PropertyDescriptor for the property be accessed on the target.
isCollectionReadOnly
Type: SystemBoolean
Whether items can be added to or removed from the collection.
areItemsReadOnly
Type: SystemBoolean
Whether the values of the items in the collection are read-only and cannot be changed.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Properties

The CollectionPropertyDescriptorPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | AreItemsReadOnly | Gets whether the values of the items in the collection are read-only and cannot be changed.
Public property | AttachedCollectionValue | Gets or sets the collection object that is attached for change notification, if any.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Overrides CachedPropertyModelBaseCanAddChildCore.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Inherited from PropertyDescriptorPropertyModel.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides PropertyDescriptorPropertyModelConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsCollectionReadOnly | Gets whether items can be added to or removed from the collection.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Inherited from PropertyDescriptorPropertyModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Inherited from PropertyDescriptorPropertyModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from PropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from CachedPropertyModelBase.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Inherited from PropertyDescriptorPropertyModel.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.AreItemsReadOnly Property

CollectionPropertyDescriptorPropertyModelAreItemsReadOnly Property

Gets whether the values of the items in the collection are read-only and cannot be changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreItemsReadOnly { get; }
Public ReadOnly Property AreItemsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the values of the items in the collection are read-only and cannot be changed; otherwise, false.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.AttachedCollectionValue Property

CollectionPropertyDescriptorPropertyModelAttachedCollectionValue Property

Gets or sets the collection object that is attached for change notification, if any.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object AttachedCollectionValue { get; set; }
Public Property AttachedCollectionValue As Object
    Get
    Set

Property Value

Type: Object
The collection object that is attached for change notification, if any.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.CanAddChildCore Property

CollectionPropertyDescriptorPropertyModelCanAddChildCore Property

Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool CanAddChildCore { get; }
Protected Overrides ReadOnly Property CanAddChildCore As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.ConverterCore Property

CollectionPropertyDescriptorPropertyModelConverterCore Property

Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override TypeConverter ConverterCore { get; }
Protected Overrides ReadOnly Property ConverterCore As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.IsCollectionReadOnly Property

CollectionPropertyDescriptorPropertyModelIsCollectionReadOnly Property

Gets whether items can be added to or removed from the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCollectionReadOnly { get; }
Public ReadOnly Property IsCollectionReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if items can be added to or removed from the collection; otherwise, false.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Methods

The CollectionPropertyDescriptorPropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Overrides PropertyModelBaseAddChild.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Protected method | CreateExpandableCollectionConverter | Creates a new expandable collection TypeConverter.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides PropertyDescriptorPropertyModelDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides CachedPropertyModelBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyDescriptorPropertyModel.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from PropertyDescriptorPropertyModel.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.AddChild Method

CollectionPropertyDescriptorPropertyModelAddChild Method

Adds a new child into to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void AddChild()
Public Overrides Sub AddChild
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.CreateExpandableCollectionConverter Method

CollectionPropertyDescriptorPropertyModelCreateExpandableCollectionConverter Method

Creates a new expandable collection TypeConverter.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual TypeConverter CreateExpandableCollectionConverter()
Protected Overridable Function CreateExpandableCollectionConverter As TypeConverter

Return Value

Type: TypeConverter
The TypeConverter that was created.
Remarks
The default implementation of this method creates an ExpandableCollectionConverter instance.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.Dispose Method

CollectionPropertyDescriptorPropertyModelDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides PropertyDescriptorPropertyModelDispose(Boolean).)
Top
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.Dispose Method (Boolean)

CollectionPropertyDescriptorPropertyModelDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
Dispose Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.OnPropertyChanged Method

CollectionPropertyDescriptorPropertyModelOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Events

The CollectionPropertyDescriptorPropertyModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionPropertyDisplayMode Enumeration

Specifies the display mode of collection properties in the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum CollectionPropertyDisplayMode
Public Enumeration CollectionPropertyDisplayMode
Members
Member name | Value | Description
Default | 0 | Indicates that collections will only be expandable if the associated type converter supports it.
Expandable | 1 | Indicates that collections will be forced to be expandable if a custom type converter has not been specified.
EditableInline | 2 | Indicates that collections will be forced to be expandable if a custom type converter has not been specified. In addition, inline editing buttons will be used when possible.
Remarks
The Expandable and EditableInline values will only override default type converters. If a custom type converter is used, the collection may not be expandable.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase Class

Provides an abstract base class for an IDataFactory implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataFactoryBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataTypeDescriptorFactory

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DataFactoryBase : IDataFactory
Public MustInherit Class DataFactoryBase
    Implements IDataFactory

The DataFactoryBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DataFactoryBase | Initializes a new instance of the DataFactoryBase class
Top
Methods
 | Name | Description
Protected method | CategorizeDataModels | Returns a categorized variation of the specified data models collection.
Protected method | CreateCategoryEditorModel | Creates an ICategoryEditorModel for the specified CategoryEditor.
Protected method | CreateCategoryModel | Creates an ICategoryModel for the specified category name.
Protected method | CreateMergedPropertyModel | Creates an IPropertyModel that merges a common property from multiple data objects.
Public method | GetDataModels | Returns the IDataModel collection for the requested object values.
Protected method | GetPropertyModels | Returns the IPropertyModel collection for the specified data object.
Protected method | SortDataModels | Returns a sorted variation of the specified data models collection.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase Constructor

Initializes a new instance of the DataFactoryBase class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DataFactoryBase()
Protected Sub New
See Also

Reference

DataFactoryBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase Methods

The DataFactoryBase type exposes the following members.

Methods
 | Name | Description
Protected method | CategorizeDataModels | Returns a categorized variation of the specified data models collection.
Protected method | CreateCategoryEditorModel | Creates an ICategoryEditorModel for the specified CategoryEditor.
Protected method | CreateCategoryModel | Creates an ICategoryModel for the specified category name.
Protected method | CreateMergedPropertyModel | Creates an IPropertyModel that merges a common property from multiple data objects.
Public method | GetDataModels | Returns the IDataModel collection for the requested object values.
Protected method | GetPropertyModels | Returns the IPropertyModel collection for the specified data object.
Protected method | SortDataModels | Returns a sorted variation of the specified data models collection.
Top
See Also

Reference

DataFactoryBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase.CategorizeDataModels Method

DataFactoryBaseCategorizeDataModels Method

Returns a categorized variation of the specified data models collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IList<IDataModel> CategorizeDataModels(
    IList<IDataModel> models,
    IDataFactoryRequest request
)
Protected Overridable Function CategorizeDataModels (
    models As IList(Of IDataModel),
    request As IDataFactoryRequest
) As IList(Of IDataModel)

Parameters

models
Type: System.Collections.GenericIList IDataModel
The collection of data models to sort.
request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IDataModel
A categorized variation of the specified data models collection.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase.CreateCategoryEditorModel Method

DataFactoryBaseCreateCategoryEditorModel Method

Creates an ICategoryEditorModel for the specified CategoryEditor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual ICategoryEditorModel CreateCategoryEditorModel(
    CategoryEditor categoryEditor,
    IDataFactoryRequest request
)
Protected Overridable Function CreateCategoryEditorModel (
    categoryEditor As CategoryEditor,
    request As IDataFactoryRequest
) As ICategoryEditorModel

Parameters

categoryEditor
Type: ActiproSoftware.Windows.Controls.Grids.PropertyEditorsCategoryEditor
The CategoryEditor that was used to create the data model.
request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: ICategoryEditorModel
The ICategoryEditorModel that was created.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase.CreateCategoryModel Method

DataFactoryBaseCreateCategoryModel Method

Creates an ICategoryModel for the specified category name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual ICategoryModel CreateCategoryModel(
    string name,
    IDataFactoryRequest request
)
Protected Overridable Function CreateCategoryModel (
    name As String,
    request As IDataFactoryRequest
) As ICategoryModel

Parameters

name
Type: SystemString
The category name.
request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: ICategoryModel
The ICategoryModel that was created.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase.CreateMergedPropertyModel Method

DataFactoryBaseCreateMergedPropertyModel Method

Creates an IPropertyModel that merges a common property from multiple data objects.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IPropertyModel CreateMergedPropertyModel(
    IList<IPropertyModel> propertyModels,
    IDataFactoryRequest request
)
Protected Overridable Function CreateMergedPropertyModel (
    propertyModels As IList(Of IPropertyModel),
    request As IDataFactoryRequest
) As IPropertyModel

Parameters

propertyModels
Type: System.Collections.GenericIList IPropertyModel
The collection of IPropertyModel objects to merge.
request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IPropertyModel
The IPropertyModel that was created.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase.GetDataModels Method

DataFactoryBaseGetDataModels Method

Returns the IDataModel collection for the requested object values.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IList<IDataModel> GetDataModels(
    IDataFactoryRequest request
)
Public Overridable Function GetDataModels (
    request As IDataFactoryRequest
) As IList(Of IDataModel)

Parameters

request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IDataModel
A collection of IDataModel objects, if any were returned.

Implements

IDataFactoryGetDataModels(IDataFactoryRequest)
See Also

Reference

DataFactoryBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase.GetPropertyModels Method

DataFactoryBaseGetPropertyModels Method

Returns the IPropertyModel collection for the specified data object.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract IList<IPropertyModel> GetPropertyModels(
    Object dataObject,
    IDataFactoryRequest request
)
Protected MustOverride Function GetPropertyModels (
    dataObject As Object,
    request As IDataFactoryRequest
) As IList(Of IPropertyModel)

Parameters

dataObject
Type: SystemObject
The single object to examine.
request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IPropertyModel
A collection of IPropertyModel objects, if the specified data object has any properties.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataFactoryBase.SortDataModels Method

DataFactoryBaseSortDataModels Method

Returns a sorted variation of the specified data models collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IList<IDataModel> SortDataModels(
    IList<IDataModel> models,
    IDataFactoryRequest request,
    DataModelSortComparer sortComparer
)
Protected Overridable Function SortDataModels (
    models As IList(Of IDataModel),
    request As IDataFactoryRequest,
    sortComparer As DataModelSortComparer
) As IList(Of IDataModel)

Parameters

models
Type: System.Collections.GenericIList IDataModel
The collection of data models to sort.
request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.
sortComparer
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelSortComparer
The DataModelSortComparer to use. Otherwise, fall back to the request's sort comparer.

Return Value

Type: IList IDataModel
A sorted variation of the specified data models collection.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase Class

Provides an abstract base class for a property grid IDataModel.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataCategoryEditorModel
ActiproSoftware.Windows.Controls.Grids.PropertyDataCategoryModel
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModelBase

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class DataModelBase : ObservableObjectBase,
    IDataModel
Public MustInherit Class DataModelBase
    Inherits ObservableObjectBase
    Implements IDataModel

The DataModelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DataModelBase | Initializes a new instance of the DataModelBase class
Top
Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | Children | Gets the collection of child data models.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Protected property | IsModifiedResolved | Gets whether the data model has been modified.
Public property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Protected property | NameResolved | Gets the resolved name of the data model.
Public property | Parent | Gets the parent data model.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | Tag | Gets or sets custom data for the data model.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property.
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase Constructor

Initializes a new instance of the DataModelBase class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected DataModelBase()
Protected Sub New
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase Properties

The DataModelBase type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | Children | Gets the collection of child data models.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Protected property | IsModifiedResolved | Gets whether the data model has been modified.
Public property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Protected property | NameResolved | Gets the resolved name of the data model.
Public property | Parent | Gets the parent data model.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | Tag | Gets or sets custom data for the data model.
Top
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.CanAutoDispose Property

DataModelBaseCanAutoDispose Property

Gets whether the data model should be automatically disposed when it is removed from a parent data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanAutoDispose { get; }
Public Overridable ReadOnly Property CanAutoDispose As Boolean
    Get

Property Value

Type: Boolean
true if the data model should be automatically disposed when it is removed from a parent data model; otherwise, false.

Implements

IDataModelCanAutoDispose
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.Children Property

DataModelBaseChildren Property

Gets the collection of child data models.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataModelCollection Children { get; }
Public ReadOnly Property Children As DataModelCollection
    Get

Property Value

Type: DataModelCollection
The collection of child data models.

Implements

IDataModelChildren
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.DescriptionResolved Property

DataModelBaseDescriptionResolved Property

Gets the resolved description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract string DescriptionResolved { get; }
Protected MustOverride ReadOnly Property DescriptionResolved As String
    Get

Property Value

Type: String
The resolved description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.DisplayNameResolved Property

DataModelBaseDisplayNameResolved Property

Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract string DisplayNameResolved { get; }
Protected MustOverride ReadOnly Property DisplayNameResolved As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.IsExpanded Property

DataModelBaseIsExpanded Property

Gets or sets whether the data model is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsExpanded { get; set; }
Public Property IsExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is expanded; otherwise, false.

Implements

IDataModelIsExpanded
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.IsModifiedResolved Property

DataModelBaseIsModifiedResolved Property

Gets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool IsModifiedResolved { get; }
Protected MustOverride ReadOnly Property IsModifiedResolved As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.IsRoot Property

DataModelBaseIsRoot Property

Gets whether the data model is the root.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsRoot { get; }
Public Overridable ReadOnly Property IsRoot As Boolean
    Get

Property Value

Type: Boolean
true if the data model is the root; otherwise, false.

Implements

IDataModelIsRoot
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.IsSelected Property

DataModelBaseIsSelected Property

Gets or sets whether the data model is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is selected; otherwise, false.

Implements

IDataModelIsSelected
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.NameResolved Property

DataModelBaseNameResolved Property

Gets the resolved name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract string NameResolved { get; }
Protected MustOverride ReadOnly Property NameResolved As String
    Get

Property Value

Type: String
The resolved name of the data model.
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.Parent Property

DataModelBaseParent Property

Gets the parent data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDataModel Parent { get; }
Public ReadOnly Property Parent As IDataModel
    Get

Property Value

Type: IDataModel
The parent data model.
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.SortComparer Property

DataModelBaseSortComparer Property

Gets or sets the DataModelSortComparer to use for sorting this data model's children.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataModelSortComparer SortComparer { get; set; }
Public Property SortComparer As DataModelSortComparer
    Get
    Set

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting this data model's children.

Implements

IDataModelSortComparer
Remarks
If this property doesn't return anything, the default SortComparer will be used.
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.SortImportanceResolved Property

DataModelBaseSortImportanceResolved Property

Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract DataModelSortImportance SortImportanceResolved { get; }
Protected MustOverride ReadOnly Property SortImportanceResolved As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.SortOrderResolved Property

DataModelBaseSortOrderResolved Property

Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract int SortOrderResolved { get; }
Protected MustOverride ReadOnly Property SortOrderResolved As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.Tag Property

DataModelBaseTag Property

Gets or sets custom data for the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
The custom data for the data model.

Implements

IDataModelTag
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase Methods

The DataModelBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property.
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.Dispose Method

DataModelBaseDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Top
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.Dispose Method

DataModelBaseDispose Method

Releases all resources used by the object.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose
See Also

Reference

DataModelBase Class
Dispose Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.Dispose Method (Boolean)

DataModelBaseDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

DataModelBase Class
Dispose Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.Finalize Method

DataModelBaseFinalize Method

Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.RefreshChildren Method

DataModelBaseRefreshChildren Method

Refreshes the contents of the Children property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void RefreshChildren()
Protected Overridable Sub RefreshChildren
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase.ToString Method

DataModelBaseToString Method

Returns a String representation of this instance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String representation of this instance.
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelBase Events

The DataModelBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DataModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelCollection Class

Represents a collection of IDataModel objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataModel
System.Collections.ObjectModelObservableCollection IDataModel
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelCollection

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataModelCollection : ObservableCollection<IDataModel>
Public Class DataModelCollection
    Inherits ObservableCollection(Of IDataModel)

The DataModelCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataModelCollection | Initializes a new instance of the DataModelCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IDataModel .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection IDataModel .)
Public property | ItemString | Gets the IDataModel in this collection that matches the specified name.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IDataModel .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IDataModel .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection IDataModel .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection IDataModel .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IDataModel .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection IDataModel .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IDataModel .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IDataModel .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IDataModel .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IDataModel .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IDataModel .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection IDataModel .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IDataModel .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IDataModel .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection IDataModel .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection IDataModel .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IDataModel .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IDataModel .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection IDataModel .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection IDataModel .)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection IDataModel .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection IDataModel .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelCollection Constructor

Initializes a new instance of the DataModelCollection class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataModelCollection()
Public Sub New
See Also

Reference

DataModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelCollection Properties

The DataModelCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IDataModel .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection IDataModel .)
Public property | ItemString | Gets the IDataModel in this collection that matches the specified name.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IDataModel .)
Top
See Also

Reference

DataModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelCollection.Item Property

DataModelCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection IDataModel .)
Public property | ItemString | Gets the IDataModel in this collection that matches the specified name.
Top
See Also

Reference

DataModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelCollection.Item Property (String)

DataModelCollectionItem Property (String)

Gets the IDataModel in this collection that matches the specified name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDataModel this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As IDataModel
    Get

Parameters

name
Type: SystemString

Property Value

Type: IDataModel
The IDataModel in this collection that matches the specified name.
See Also

Reference

DataModelCollection Class
Item Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelCollection Methods

The DataModelCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IDataModel .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection IDataModel .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection IDataModel .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IDataModel .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection IDataModel .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IDataModel .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IDataModel .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IDataModel .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IDataModel .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IDataModel .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection IDataModel .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IDataModel .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IDataModel .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection IDataModel .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection IDataModel .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IDataModel .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IDataModel .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection IDataModel .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection IDataModel .)
Top
See Also

Reference

DataModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelCollection Events

The DataModelCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection IDataModel .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection IDataModel .)
Top
See Also

Reference

DataModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer Class

Provides a comparer implementation for sorting IDataModel objects in order of sort importance, sort order, numeric display name index (if applicable), and finally display name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelSortComparer

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class DataModelSortComparer : IComparer<IDataModel>
Public Class DataModelSortComparer
    Implements IComparer(Of IDataModel)

The DataModelSortComparer type exposes the following members.

Constructors
 | Name | Description
Public method | DataModelSortComparer | Initializes a new instance of the DataModelSortComparer class
Top
Properties
 | Name | Description
Public property | CanCompareDisplayName | Gets or sets whether display name can be compared.
Public property | CanCompareIndex | Gets or sets whether a numeric index value (e.g. [0]) in the display name can be compared.
Public property | CanCompareSortImportance | Gets or sets whether sort importance can be compared.
Public property | CanCompareSortOrder | Gets or sets whether sort order can be compared.
Top
Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareDisplayName | Compares two DisplayName values and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareIndex | Compares two DisplayName values to see if they contain numeric indices (e.g. [0]) and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareSortImportance | Compares two SortImportance values and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareSortOrder | Compares two SortOrder values and returns a value indicating whether one is less than, equal to or greater than the other.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer Constructor

Initializes a new instance of the DataModelSortComparer class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataModelSortComparer()
Public Sub New
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer Properties

The DataModelSortComparer type exposes the following members.

Properties
 | Name | Description
Public property | CanCompareDisplayName | Gets or sets whether display name can be compared.
Public property | CanCompareIndex | Gets or sets whether a numeric index value (e.g. [0]) in the display name can be compared.
Public property | CanCompareSortImportance | Gets or sets whether sort importance can be compared.
Public property | CanCompareSortOrder | Gets or sets whether sort order can be compared.
Top
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CanCompareDisplayName Property

DataModelSortComparerCanCompareDisplayName Property

Gets or sets whether display name can be compared.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompareDisplayName { get; set; }
Public Property CanCompareDisplayName As Boolean
    Get
    Set

Property Value

Type: Boolean
true if display name can be compared; otherwise, false. The default value is true.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CanCompareIndex Property

DataModelSortComparerCanCompareIndex Property

Gets or sets whether a numeric index value (e.g. [0]) in the display name can be compared.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompareIndex { get; set; }
Public Property CanCompareIndex As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a numeric index value (e.g. [0]) in the display name can be compared; otherwise, false. The default value is true.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CanCompareSortImportance Property

DataModelSortComparerCanCompareSortImportance Property

Gets or sets whether sort importance can be compared.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompareSortImportance { get; set; }
Public Property CanCompareSortImportance As Boolean
    Get
    Set

Property Value

Type: Boolean
true if sort importance can be compared; otherwise, false. The default value is true.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CanCompareSortOrder Property

DataModelSortComparerCanCompareSortOrder Property

Gets or sets whether sort order can be compared.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanCompareSortOrder { get; set; }
Public Property CanCompareSortOrder As Boolean
    Get
    Set

Property Value

Type: Boolean
true if sort order can be compared; otherwise, false. The default value is true.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer Methods

The DataModelSortComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareDisplayName | Compares two DisplayName values and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareIndex | Compares two DisplayName values to see if they contain numeric indices (e.g. [0]) and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareSortImportance | Compares two SortImportance values and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareSortOrder | Compares two SortOrder values and returns a value indicating whether one is less than, equal to or greater than the other.
Top
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer.Compare Method

DataModelSortComparerCompare Method

Compares two objects and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual int Compare(
    IDataModel left,
    IDataModel right
)
Public Overridable Function Compare (
    left As IDataModel,
    right As IDataModel
) As Integer

Parameters

left
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataModel
First object to compare.
right
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataModel
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.

Implements

IComparerTCompare(T, T)
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CompareDisplayName Method

DataModelSortComparerCompareDisplayName Method

Compares two DisplayName values and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual int CompareDisplayName(
    string left,
    string right
)
Protected Overridable Function CompareDisplayName (
    left As String,
    right As String
) As Integer

Parameters

left
Type: SystemString
First object to compare.
right
Type: SystemString
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CompareIndex Method

DataModelSortComparerCompareIndex Method

Compares two DisplayName values to see if they contain numeric indices (e.g. [0]) and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual int CompareIndex(
    string left,
    string right
)
Protected Overridable Function CompareIndex (
    left As String,
    right As String
) As Integer

Parameters

left
Type: SystemString
First object to compare.
right
Type: SystemString
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CompareSortImportance Method

DataModelSortComparerCompareSortImportance Method

Compares two SortImportance values and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual int CompareSortImportance(
    DataModelSortImportance left,
    DataModelSortImportance right
)
Protected Overridable Function CompareSortImportance (
    left As DataModelSortImportance,
    right As DataModelSortImportance
) As Integer

Parameters

left
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelSortImportance
First object to compare.
right
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelSortImportance
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CompareSortOrder Method

DataModelSortComparerCompareSortOrder Method

Compares two SortOrder values and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual int CompareSortOrder(
    int left,
    int right
)
Protected Overridable Function CompareSortOrder (
    left As Integer,
    right As Integer
) As Integer

Parameters

left
Type: SystemInt32
First object to compare.
right
Type: SystemInt32
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DataModelSortImportance Enumeration

Specifies the sort importance of data models.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DataModelSortImportance
Public Enumeration DataModelSortImportance
Members
Member name | Value | Description
BeforeCategory | 0 | Indicates the data model should be sorted before categories.
Category | 1 | Indicates the data model should be sorted as a category.
AfterCategory | 2 | Indicates the data model should be sorted after categories.
BeforeCategoryEditor | 3 | Indicates the data model should be sorted before category editors.
CategoryEditor | 4 | Indicates the data model should be sorted as a category editor.
AfterCategoryEditor | 5 | Indicates the data model should be sorted after category editors.
BeforeProperty | 6 | Indicates the data model should be sorted before properties.
Property | 7 | Indicates the data model should be sorted as a property.
AfterProperty | 8 | Indicates the data model should be sorted after properties.
Remarks
The standard sort order is: categories, category editors, and finally properties. The values of this enumeration allow data models to be placed in or around any of these three groups.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Class

Represents a type converter that is capable of expanding various collection types.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.Windows.Controls.Grids.PropertyDataExpandableCollectionConverter

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExpandableCollectionConverter : TypeConverter,
    ICollectionTypeConverter
Public Class ExpandableCollectionConverter
    Inherits TypeConverter
    Implements ICollectionTypeConverter

The ExpandableCollectionConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ExpandableCollectionConverter | Initializes a new instance of the ExpandableCollectionConverter class.
Public method | ExpandableCollectionConverter(Boolean, Boolean) | Initializes a new instance of the ExpandableCollectionConverter class.
Top
Properties
 | Name | Description
Public property | AreItemsReadOnly | Gets whether the values of the items in the collection are read-only and cannot be changed.
Public property | IsCollectionReadOnly | Gets whether items can be added to or removed from the collection.
Public property | MultipleItemsFormat | Gets or sets the format for text to return when there are multiple items.
Public property | NoItemsText | Gets or sets the text to return when there are no items.
Public property | OneItemText | Gets or sets the text to return when there is one item.
Top
Methods
 | Name | Description
Public method | AddItem | Adds the specified item into to the collection.
Public method | CanAddItem | Gets a value indicating whether a new item can be added to the collection.
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Protected method | CreateCollectionItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the collection item.
Protected method | CreateDictionaryItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the dictionary item.
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateItem | Creates a new item that can be added into to the collection.
Protected method | CreateListItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the list item.
Protected method | GetCollectionProperties | Gets a collection of properties for the specified collection using the specified context and attributes.
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Protected method | GetDictionaryProperties | Gets a collection of properties for the specified dictionary using the specified context and attributes.
Protected method | GetListProperties | Gets a collection of properties for the specified list using the specified context and attributes.
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the value using the specified context and attributes. (Overrides TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties. (Overrides TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Constructor

Overload List
 | Name | Description
Public method | ExpandableCollectionConverter | Initializes a new instance of the ExpandableCollectionConverter class.
Public method | ExpandableCollectionConverter(Boolean, Boolean) | Initializes a new instance of the ExpandableCollectionConverter class.
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Constructor

Initializes a new instance of the ExpandableCollectionConverter class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpandableCollectionConverter()
Public Sub New
See Also

Reference

ExpandableCollectionConverter Class
ExpandableCollectionConverter Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Constructor (Boolean, Boolean)

Initializes a new instance of the ExpandableCollectionConverter class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExpandableCollectionConverter(
    bool isCollectionReadOnly,
    bool areItemsReadOnly
)
Public Sub New (
    isCollectionReadOnly As Boolean,
    areItemsReadOnly As Boolean
)

Parameters

isCollectionReadOnly
Type: SystemBoolean
Whether items can be added to or removed from the collection.
areItemsReadOnly
Type: SystemBoolean
Whether the values of the items in the collection are read-only and cannot be changed.
See Also

Reference

ExpandableCollectionConverter Class
ExpandableCollectionConverter Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Properties

The ExpandableCollectionConverter type exposes the following members.

Properties
 | Name | Description
Public property | AreItemsReadOnly | Gets whether the values of the items in the collection are read-only and cannot be changed.
Public property | IsCollectionReadOnly | Gets whether items can be added to or removed from the collection.
Public property | MultipleItemsFormat | Gets or sets the format for text to return when there are multiple items.
Public property | NoItemsText | Gets or sets the text to return when there are no items.
Public property | OneItemText | Gets or sets the text to return when there is one item.
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.AreItemsReadOnly Property

ExpandableCollectionConverterAreItemsReadOnly Property

Gets whether the values of the items in the collection are read-only and cannot be changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreItemsReadOnly { get; }
Public ReadOnly Property AreItemsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the values of the items in the collection are read-only and cannot be changed; otherwise, false.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.IsCollectionReadOnly Property

ExpandableCollectionConverterIsCollectionReadOnly Property

Gets whether items can be added to or removed from the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsCollectionReadOnly { get; }
Public ReadOnly Property IsCollectionReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if items can be added to or removed from the collection; otherwise, false.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.MultipleItemsFormat Property

ExpandableCollectionConverterMultipleItemsFormat Property

Gets or sets the format for text to return when there are multiple items.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string MultipleItemsFormat { get; set; }
Public Property MultipleItemsFormat As String
    Get
    Set

Property Value

Type: String
The format for text to return when there are multiple items. The default value is "{0} items".
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.NoItemsText Property

ExpandableCollectionConverterNoItemsText Property

Gets or sets the text to return when there are no items.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string NoItemsText { get; set; }
Public Property NoItemsText As String
    Get
    Set

Property Value

Type: String
The text to return when there are no items. The default value is "No items".
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.OneItemText Property

ExpandableCollectionConverterOneItemText Property

Gets or sets the text to return when there is one item.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string OneItemText { get; set; }
Public Property OneItemText As String
    Get
    Set

Property Value

Type: String
The text to return when there is one item. The default value is "1 item".
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Methods

The ExpandableCollectionConverter type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds the specified item into to the collection.
Public method | CanAddItem | Gets a value indicating whether a new item can be added to the collection.
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Protected method | CreateCollectionItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the collection item.
Protected method | CreateDictionaryItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the dictionary item.
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateItem | Creates a new item that can be added into to the collection.
Protected method | CreateListItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the list item.
Protected method | GetCollectionProperties | Gets a collection of properties for the specified collection using the specified context and attributes.
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Protected method | GetDictionaryProperties | Gets a collection of properties for the specified dictionary using the specified context and attributes.
Protected method | GetListProperties | Gets a collection of properties for the specified list using the specified context and attributes.
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the value using the specified context and attributes. (Overrides TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties. (Overrides TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.AddItem Method

ExpandableCollectionConverterAddItem Method

Adds the specified item into to the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool AddItem(
    IPropertyModel propertyModel,
    Object item
)
Public Overridable Function AddItem (
    propertyModel As IPropertyModel,
    item As Object
) As Boolean

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.
item
Type: SystemObject
The item that should be added.

Return Value

Type: Boolean
true if the item was added to the collection; otherwise, false.

Implements

ICollectionTypeConverterAddItem(IPropertyModel, Object)
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CanAddItem Method

ExpandableCollectionConverterCanAddItem Method

Gets a value indicating whether a new item can be added to the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanAddItem(
    IPropertyModel propertyModel
)
Public Overridable Function CanAddItem (
    propertyModel As IPropertyModel
) As Boolean

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.

Return Value

Type: Boolean
true if a new item can be added to the collection; otherwise, false.

Implements

ICollectionTypeConverterCanAddItem(IPropertyModel)
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CanConvertTo Method

ExpandableCollectionConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

ExpandableCollectionConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: SystemType
A Type that represents the type you want to convert to.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

ExpandableCollectionConverter Class
CanConvertTo Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ConvertTo Method

ExpandableCollectionConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

ExpandableCollectionConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo object. If is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

ExpandableCollectionConverter Class
ConvertTo Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CreateCollectionItemPropertyDescriptor Method

ExpandableCollectionConverterCreateCollectionItemPropertyDescriptor Method

Creates an instance of PropertyDescriptor for the collection item.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor CreateCollectionItemPropertyDescriptor(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    ICollection collection,
    int index,
    Object item,
    Type itemType
)
Protected Overridable Function CreateCollectionItemPropertyDescriptor (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    collection As ICollection,
    index As Integer,
    item As Object,
    itemType As Type
) As PropertyDescriptor

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
collection
Type: System.CollectionsICollection
The collection that contains the item.
index
Type: SystemInt32
The index of the item in the collection.
item
Type: SystemObject
The item in the collection.
itemType
Type: SystemType
Type of the item.

Return Value

Type: PropertyDescriptor
An instance of PropertyDescriptor for the collection item.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CreateDictionaryItemPropertyDescriptor Method

ExpandableCollectionConverterCreateDictionaryItemPropertyDescriptor Method

Creates an instance of PropertyDescriptor for the dictionary item.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor CreateDictionaryItemPropertyDescriptor(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    IDictionary dictionary,
    Object key,
    Type itemType
)
Protected Overridable Function CreateDictionaryItemPropertyDescriptor (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    dictionary As IDictionary,
    key As Object,
    itemType As Type
) As PropertyDescriptor

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
dictionary
Type: System.CollectionsIDictionary
The dictionary that contains the item.
key
Type: SystemObject
The key of the item in the dictionary.
itemType
Type: SystemType
Type of the item.

Return Value

Type: PropertyDescriptor
An instance of PropertyDescriptor for the dictionary item.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CreateItem Method

ExpandableCollectionConverterCreateItem Method

Creates a new item that can be added into to the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Object CreateItem(
    IPropertyModel propertyModel
)
Public Overridable Function CreateItem (
    propertyModel As IPropertyModel
) As Object

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.

Return Value

Type: Object
The item that was created.

Implements

ICollectionTypeConverterCreateItem(IPropertyModel)
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CreateListItemPropertyDescriptor Method

ExpandableCollectionConverterCreateListItemPropertyDescriptor Method

Creates an instance of PropertyDescriptor for the list item.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor CreateListItemPropertyDescriptor(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    IList list,
    int index,
    Type itemType
)
Protected Overridable Function CreateListItemPropertyDescriptor (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    list As IList,
    index As Integer,
    itemType As Type
) As PropertyDescriptor

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
list
Type: System.CollectionsIList
The list that contains the item.
index
Type: SystemInt32
The index of the item in the list.
itemType
Type: SystemType
Type of the item.

Return Value

Type: PropertyDescriptor
An instance of PropertyDescriptor for the list item.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetCollectionProperties Method

ExpandableCollectionConverterGetCollectionProperties Method

Gets a collection of properties for the specified collection using the specified context and attributes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor[] GetCollectionProperties(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    ICollection collection
)
Protected Overridable Function GetCollectionProperties (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    collection As ICollection
) As PropertyDescriptor()

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
collection
Type: System.CollectionsICollection
The collection whose properties should be returned.

Return Value

Type: PropertyDescriptor
A PropertyDescriptor array with the properties associated with the specified collection, or if there are no properties.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetDictionaryProperties Method

ExpandableCollectionConverterGetDictionaryProperties Method

Gets a collection of properties for the specified dictionary using the specified context and attributes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor[] GetDictionaryProperties(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    IDictionary dictionary
)
Protected Overridable Function GetDictionaryProperties (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    dictionary As IDictionary
) As PropertyDescriptor()

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
dictionary
Type: System.CollectionsIDictionary
The dictionary whose properties should be returned.

Return Value

Type: PropertyDescriptor
A PropertyDescriptor array with the properties associated with the specified dictionary, or if there are no properties.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetListProperties Method

ExpandableCollectionConverterGetListProperties Method

Gets a collection of properties for the specified list using the specified context and attributes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor[] GetListProperties(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    IList list
)
Protected Overridable Function GetListProperties (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    list As IList
) As PropertyDescriptor()

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
list
Type: System.CollectionsIList
The list whose properties should be returned.

Return Value

Type: PropertyDescriptor
A PropertyDescriptor array with the properties associated with the specified list, or if there are no properties.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetProperties Method

ExpandableCollectionConverterGetProperties Method

Overload List
 | Name | Description
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the value using the specified context and attributes. (Overrides TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetProperties Method (ITypeDescriptorContext, Object, Attribute[])

ExpandableCollectionConverterGetProperties Method (ITypeDescriptorContext, Object, Attribute)

Gets a collection of properties for the value using the specified context and attributes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties (
    context As ITypeDescriptorContext,
    value As Object,
    attributes As Attribute()
) As PropertyDescriptorCollection

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
value
Type: SystemObject
An Object that specifies the type to get the properties for.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.

Return Value

Type: PropertyDescriptorCollection
A PropertyDescriptorCollection with the properties that are exposed for this data type, or if there are no properties.
See Also

Reference

ExpandableCollectionConverter Class
GetProperties Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetPropertiesSupported Method

ExpandableCollectionConverterGetPropertiesSupported Method

Overload List
 | Name | Description
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties. (Overrides TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetPropertiesSupported Method (ITypeDescriptorContext)

ExpandableCollectionConverterGetPropertiesSupported Method (ITypeDescriptorContext)

Gets a value indicating whether this object supports properties.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported (
    context As ITypeDescriptorContext
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.

Return Value

Type: Boolean
true if properties are supported; otherwise, false.
Remarks
The default method implementation always returns true since child items should be accessible as nested properties.
See Also

Reference

ExpandableCollectionConverter Class
GetPropertiesSupported Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor Class

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class

[Missing <summary> documentation for "T:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor"]

Inheritance Hierarchy
SystemObject
System.ComponentModelMemberDescriptor
System.ComponentModelPropertyDescriptor
System.ComponentModelTypeConverterSimplePropertyDescriptor
ActiproSoftware.Windows.Controls.Grids.PropertyDataExpandableCollectionConverterCollectionItemPropertyDescriptor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected class CollectionItemPropertyDescriptor : TypeConverterSimplePropertyDescriptor
Protected Class CollectionItemPropertyDescriptor
    Inherits TypeConverterSimplePropertyDescriptor

The ExpandableCollectionConverterCollectionItemPropertyDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ExpandableCollectionConverterCollectionItemPropertyDescriptor | Initializes a new instance of the ExpandableCollectionConverterCollectionItemPropertyDescriptor class
Top
Properties
 | Name | Description
Protected property | AttributeArray | Gets or sets an array of attributes. (Inherited from MemberDescriptor.)
Public property | Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Public property | Category | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute. (Inherited from MemberDescriptor.)
Public property | ComponentType | Gets the type of component to which this property description binds. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | Converter | Gets the type converter for this property. (Inherited from PropertyDescriptor.)
Public property | Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
Public property | DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
Public property | DisplayName | Gets the name that can be displayed in a window, such as a Properties window. (Inherited from MemberDescriptor.)
Public property | IsBrowsable | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute. (Inherited from MemberDescriptor.)
Public property | IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
Public property | IsReadOnly | (Overrides TypeConverterSimplePropertyDescriptorIsReadOnly.)
Public property | Name | Gets the name of the member. (Inherited from MemberDescriptor.)
Protected property | NameHashCode | Gets the hash code for the name of the member, as specified in GetHashCode. (Inherited from MemberDescriptor.)
Public property | PropertyType | Gets the type of the property. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
Public property | SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
Top
Methods
 | Name | Description
Public method | AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | CanResetValue | Returns whether resetting the component changes the value of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Protected method | CreateAttributeCollection | Creates a collection of attributes using the array of attributes passed to the constructor. (Inherited from MemberDescriptor.)
Protected method | CreateInstance | Creates an instance of the specified type. (Inherited from PropertyDescriptor.)
Public method | Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
Protected method | FillAttributes | Adds the attributes of the PropertyDescriptor to the specified list of attributes in the parent class. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Attribute) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object, Attribute) | Returns a PropertyDescriptorCollection for a given object using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetEditor | Gets an editor of the specified type. (Inherited from PropertyDescriptor.)
Public method | GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
Protected method | GetInvocationTarget | This method returns the object that should be used during invocation of members. (Inherited from PropertyDescriptor.)
Protected method | GetTypeFromName | Returns a type using its name. (Inherited from PropertyDescriptor.)
Public method | GetValue | (Overrides PropertyDescriptorGetValue(Object).)
Protected method | GetValueChangedHandler | Retrieves the current set of ValueChanged event handlers for a specific component (Inherited from PropertyDescriptor.)
Protected method | OnValueChanged | Raises the ValueChanged event that you implemented. (Inherited from PropertyDescriptor.)
Public method | RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | ResetValue | Resets the value for this property of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public method | SetValue | (Overrides PropertyDescriptorSetValue(Object, Object).)
Public method | ShouldSerializeValue | Returns whether the value of this property can persist. (Inherited from TypeConverterSimplePropertyDescriptor.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor Constructor

ExpandableCollectionConverterCollectionItemPropertyDescriptor Constructor

Initializes a new instance of the ExpandableCollectionConverterCollectionItemPropertyDescriptor class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CollectionItemPropertyDescriptor(
    ICollection collection,
    int index,
    Object item,
    Type itemType,
    Attribute[] attributes
)
Public Sub New (
    collection As ICollection,
    index As Integer,
    item As Object,
    itemType As Type,
    attributes As Attribute()
)

Parameters

collection
Type: System.CollectionsICollection

[Missing <param name="collection"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.#ctor(System.Collections.ICollection,System.Int32,System.Object,System.Type,System.Attribute[])"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.#ctor(System.Collections.ICollection,System.Int32,System.Object,System.Type,System.Attribute[])"]

item
Type: SystemObject

[Missing <param name="item"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.#ctor(System.Collections.ICollection,System.Int32,System.Object,System.Type,System.Attribute[])"]

itemType
Type: SystemType

[Missing <param name="itemType"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.#ctor(System.Collections.ICollection,System.Int32,System.Object,System.Type,System.Attribute[])"]

attributes
Type: SystemAttribute

[Missing <param name="attributes"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.#ctor(System.Collections.ICollection,System.Int32,System.Object,System.Type,System.Attribute[])"]

See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionItemPropertyDescriptor Properties

The ExpandableCollectionConverterCollectionItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Protected property | AttributeArray | Gets or sets an array of attributes. (Inherited from MemberDescriptor.)
Public property | Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Public property | Category | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute. (Inherited from MemberDescriptor.)
Public property | ComponentType | Gets the type of component to which this property description binds. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | Converter | Gets the type converter for this property. (Inherited from PropertyDescriptor.)
Public property | Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
Public property | DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
Public property | DisplayName | Gets the name that can be displayed in a window, such as a Properties window. (Inherited from MemberDescriptor.)
Public property | IsBrowsable | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute. (Inherited from MemberDescriptor.)
Public property | IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
Public property | IsReadOnly | (Overrides TypeConverterSimplePropertyDescriptorIsReadOnly.)
Public property | Name | Gets the name of the member. (Inherited from MemberDescriptor.)
Protected property | NameHashCode | Gets the hash code for the name of the member, as specified in GetHashCode. (Inherited from MemberDescriptor.)
Public property | PropertyType | Gets the type of the property. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
Public property | SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
Top
See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor.IsReadOnly Property

ExpandableCollectionConverterCollectionItemPropertyDescriptorIsReadOnly Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.IsReadOnly"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


CollectionItemPropertyDescriptor Methods

The ExpandableCollectionConverterCollectionItemPropertyDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | CanResetValue | Returns whether resetting the component changes the value of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Protected method | CreateAttributeCollection | Creates a collection of attributes using the array of attributes passed to the constructor. (Inherited from MemberDescriptor.)
Protected method | CreateInstance | Creates an instance of the specified type. (Inherited from PropertyDescriptor.)
Public method | Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
Protected method | FillAttributes | Adds the attributes of the PropertyDescriptor to the specified list of attributes in the parent class. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Attribute) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object, Attribute) | Returns a PropertyDescriptorCollection for a given object using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetEditor | Gets an editor of the specified type. (Inherited from PropertyDescriptor.)
Public method | GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
Protected method | GetInvocationTarget | This method returns the object that should be used during invocation of members. (Inherited from PropertyDescriptor.)
Protected method | GetTypeFromName | Returns a type using its name. (Inherited from PropertyDescriptor.)
Public method | GetValue | (Overrides PropertyDescriptorGetValue(Object).)
Protected method | GetValueChangedHandler | Retrieves the current set of ValueChanged event handlers for a specific component (Inherited from PropertyDescriptor.)
Protected method | OnValueChanged | Raises the ValueChanged event that you implemented. (Inherited from PropertyDescriptor.)
Public method | RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | ResetValue | Resets the value for this property of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public method | SetValue | (Overrides PropertyDescriptorSetValue(Object, Object).)
Public method | ShouldSerializeValue | Returns whether the value of this property can persist. (Inherited from TypeConverterSimplePropertyDescriptor.)
Top
See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor.GetValue Method

ExpandableCollectionConverterCollectionItemPropertyDescriptorGetValue Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.GetValue(System.Object)"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetValue(
    Object component
)
Public Overrides Function GetValue (
    component As Object
) As Object

Parameters

component
Type: SystemObject

[Missing <param name="component"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.GetValue(System.Object)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.GetValue(System.Object)"]

See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor.SetValue Method

ExpandableCollectionConverterCollectionItemPropertyDescriptorSetValue Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.SetValue(System.Object,System.Object)"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void SetValue(
    Object component,
    Object value
)
Public Overrides Sub SetValue (
    component As Object,
    value As Object
)

Parameters

component
Type: SystemObject

[Missing <param name="component"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.SetValue(System.Object,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.CollectionItemPropertyDescriptor.SetValue(System.Object,System.Object)"]

See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor Class

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class

[Missing <summary> documentation for "T:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor"]

Inheritance Hierarchy
SystemObject
System.ComponentModelMemberDescriptor
System.ComponentModelPropertyDescriptor
System.ComponentModelTypeConverterSimplePropertyDescriptor
ActiproSoftware.Windows.Controls.Grids.PropertyDataExpandableCollectionConverterDictionaryItemPropertyDescriptor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected class DictionaryItemPropertyDescriptor : TypeConverterSimplePropertyDescriptor,
    ICollectionItemPropertyDescriptor
Protected Class DictionaryItemPropertyDescriptor
    Inherits TypeConverterSimplePropertyDescriptor
    Implements ICollectionItemPropertyDescriptor

The ExpandableCollectionConverterDictionaryItemPropertyDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ExpandableCollectionConverterDictionaryItemPropertyDescriptor | Initializes a new instance of the ExpandableCollectionConverterDictionaryItemPropertyDescriptor class
Top
Properties
 | Name | Description
Protected property | AttributeArray | Gets or sets an array of attributes. (Inherited from MemberDescriptor.)
Public property | Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Public property | CanRemove |
Public property | Category | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute. (Inherited from MemberDescriptor.)
Public property | ComponentType | Gets the type of component to which this property description binds. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | Converter | Gets the type converter for this property. (Inherited from PropertyDescriptor.)
Public property | Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
Public property | DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
Public property | Dictionary |
Public property | DisplayName | Gets the name that can be displayed in a window, such as a Properties window. (Inherited from MemberDescriptor.)
Public property | IsBrowsable | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute. (Inherited from MemberDescriptor.)
Public property | IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
Public property | IsReadOnly | (Overrides TypeConverterSimplePropertyDescriptorIsReadOnly.)
Public property | Key |
Public property | Name | Gets the name of the member. (Inherited from MemberDescriptor.)
Protected property | NameHashCode | Gets the hash code for the name of the member, as specified in GetHashCode. (Inherited from MemberDescriptor.)
Public property | PropertyType | Gets the type of the property. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
Public property | SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
Top
Methods
 | Name | Description
Public method | AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | CanResetValue | Returns whether resetting the component changes the value of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Protected method | CreateAttributeCollection | Creates a collection of attributes using the array of attributes passed to the constructor. (Inherited from MemberDescriptor.)
Protected method | CreateInstance | Creates an instance of the specified type. (Inherited from PropertyDescriptor.)
Public method | Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
Protected method | FillAttributes | Adds the attributes of the PropertyDescriptor to the specified list of attributes in the parent class. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Attribute) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object, Attribute) | Returns a PropertyDescriptorCollection for a given object using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetEditor | Gets an editor of the specified type. (Inherited from PropertyDescriptor.)
Public method | GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
Protected method | GetInvocationTarget | This method returns the object that should be used during invocation of members. (Inherited from PropertyDescriptor.)
Protected method | GetTypeFromName | Returns a type using its name. (Inherited from PropertyDescriptor.)
Public method | GetValue | (Overrides PropertyDescriptorGetValue(Object).)
Protected method | GetValueChangedHandler | Retrieves the current set of ValueChanged event handlers for a specific component (Inherited from PropertyDescriptor.)
Protected method | OnValueChanged | Raises the ValueChanged event that you implemented. (Inherited from PropertyDescriptor.)
Public method | Remove |
Public method | RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | ResetValue | Resets the value for this property of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public method | SetValue | (Overrides PropertyDescriptorSetValue(Object, Object).)
Public method | ShouldSerializeValue | Returns whether the value of this property can persist. (Inherited from TypeConverterSimplePropertyDescriptor.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor Constructor

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Constructor

Initializes a new instance of the ExpandableCollectionConverterDictionaryItemPropertyDescriptor class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DictionaryItemPropertyDescriptor(
    IDictionary dictionary,
    Object key,
    Type itemType,
    Attribute[] attributes,
    bool isCollectionReadOnly,
    bool isReadOnly
)
Public Sub New (
    dictionary As IDictionary,
    key As Object,
    itemType As Type,
    attributes As Attribute(),
    isCollectionReadOnly As Boolean,
    isReadOnly As Boolean
)

Parameters

dictionary
Type: System.CollectionsIDictionary

[Missing <param name="dictionary"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.#ctor(System.Collections.IDictionary,System.Object,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

key
Type: SystemObject

[Missing <param name="key"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.#ctor(System.Collections.IDictionary,System.Object,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

itemType
Type: SystemType

[Missing <param name="itemType"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.#ctor(System.Collections.IDictionary,System.Object,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

attributes
Type: SystemAttribute

[Missing <param name="attributes"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.#ctor(System.Collections.IDictionary,System.Object,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

isCollectionReadOnly
Type: SystemBoolean

[Missing <param name="isCollectionReadOnly"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.#ctor(System.Collections.IDictionary,System.Object,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

isReadOnly
Type: SystemBoolean

[Missing <param name="isReadOnly"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.#ctor(System.Collections.IDictionary,System.Object,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DictionaryItemPropertyDescriptor Properties

The ExpandableCollectionConverterDictionaryItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Protected property | AttributeArray | Gets or sets an array of attributes. (Inherited from MemberDescriptor.)
Public property | Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Public property | CanRemove |
Public property | Category | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute. (Inherited from MemberDescriptor.)
Public property | ComponentType | Gets the type of component to which this property description binds. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | Converter | Gets the type converter for this property. (Inherited from PropertyDescriptor.)
Public property | Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
Public property | DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
Public property | Dictionary |
Public property | DisplayName | Gets the name that can be displayed in a window, such as a Properties window. (Inherited from MemberDescriptor.)
Public property | IsBrowsable | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute. (Inherited from MemberDescriptor.)
Public property | IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
Public property | IsReadOnly | (Overrides TypeConverterSimplePropertyDescriptorIsReadOnly.)
Public property | Key |
Public property | Name | Gets the name of the member. (Inherited from MemberDescriptor.)
Protected property | NameHashCode | Gets the hash code for the name of the member, as specified in GetHashCode. (Inherited from MemberDescriptor.)
Public property | PropertyType | Gets the type of the property. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
Public property | SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
Top
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.CanRemove Property

ExpandableCollectionConverterDictionaryItemPropertyDescriptorCanRemove Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.CanRemove"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanRemove { get; }
Public Overridable ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean

Implements

ICollectionItemPropertyDescriptorCanRemove
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Dictionary Property

ExpandableCollectionConverterDictionaryItemPropertyDescriptorDictionary Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Dictionary"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDictionary Dictionary { get; }
Public ReadOnly Property Dictionary As IDictionary
    Get

Property Value

Type: IDictionary
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.IsReadOnly Property

ExpandableCollectionConverterDictionaryItemPropertyDescriptorIsReadOnly Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.IsReadOnly"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Key Property

ExpandableCollectionConverterDictionaryItemPropertyDescriptorKey Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Key"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Key { get; }
Public ReadOnly Property Key As Object
    Get

Property Value

Type: Object
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


DictionaryItemPropertyDescriptor Methods

The ExpandableCollectionConverterDictionaryItemPropertyDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | CanResetValue | Returns whether resetting the component changes the value of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Protected method | CreateAttributeCollection | Creates a collection of attributes using the array of attributes passed to the constructor. (Inherited from MemberDescriptor.)
Protected method | CreateInstance | Creates an instance of the specified type. (Inherited from PropertyDescriptor.)
Public method | Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
Protected method | FillAttributes | Adds the attributes of the PropertyDescriptor to the specified list of attributes in the parent class. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Attribute) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object, Attribute) | Returns a PropertyDescriptorCollection for a given object using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetEditor | Gets an editor of the specified type. (Inherited from PropertyDescriptor.)
Public method | GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
Protected method | GetInvocationTarget | This method returns the object that should be used during invocation of members. (Inherited from PropertyDescriptor.)
Protected method | GetTypeFromName | Returns a type using its name. (Inherited from PropertyDescriptor.)
Public method | GetValue | (Overrides PropertyDescriptorGetValue(Object).)
Protected method | GetValueChangedHandler | Retrieves the current set of ValueChanged event handlers for a specific component (Inherited from PropertyDescriptor.)
Protected method | OnValueChanged | Raises the ValueChanged event that you implemented. (Inherited from PropertyDescriptor.)
Public method | Remove |
Public method | RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | ResetValue | Resets the value for this property of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public method | SetValue | (Overrides PropertyDescriptorSetValue(Object, Object).)
Public method | ShouldSerializeValue | Returns whether the value of this property can persist. (Inherited from TypeConverterSimplePropertyDescriptor.)
Top
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.GetValue Method

ExpandableCollectionConverterDictionaryItemPropertyDescriptorGetValue Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.GetValue(System.Object)"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetValue(
    Object component
)
Public Overrides Function GetValue (
    component As Object
) As Object

Parameters

component
Type: SystemObject

[Missing <param name="component"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.GetValue(System.Object)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.GetValue(System.Object)"]

See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Remove Method

ExpandableCollectionConverterDictionaryItemPropertyDescriptorRemove Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Remove"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool Remove()
Public Overridable Function Remove As Boolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Remove"]

Implements

ICollectionItemPropertyDescriptorRemove
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.SetValue Method

ExpandableCollectionConverterDictionaryItemPropertyDescriptorSetValue Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.SetValue(System.Object,System.Object)"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void SetValue(
    Object component,
    Object value
)
Public Overrides Sub SetValue (
    component As Object,
    value As Object
)

Parameters

component
Type: SystemObject

[Missing <param name="component"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.SetValue(System.Object,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.SetValue(System.Object,System.Object)"]

See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor Class

ExpandableCollectionConverterListItemPropertyDescriptor Class

[Missing <summary> documentation for "T:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor"]

Inheritance Hierarchy
SystemObject
System.ComponentModelMemberDescriptor
System.ComponentModelPropertyDescriptor
System.ComponentModelTypeConverterSimplePropertyDescriptor
ActiproSoftware.Windows.Controls.Grids.PropertyDataExpandableCollectionConverterListItemPropertyDescriptor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected class ListItemPropertyDescriptor : TypeConverterSimplePropertyDescriptor,
    ICollectionItemPropertyDescriptor
Protected Class ListItemPropertyDescriptor
    Inherits TypeConverterSimplePropertyDescriptor
    Implements ICollectionItemPropertyDescriptor

The ExpandableCollectionConverterListItemPropertyDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ExpandableCollectionConverterListItemPropertyDescriptor | Initializes a new instance of the ExpandableCollectionConverterListItemPropertyDescriptor class
Top
Properties
 | Name | Description
Protected property | AttributeArray | Gets or sets an array of attributes. (Inherited from MemberDescriptor.)
Public property | Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Public property | CanRemove |
Public property | Category | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute. (Inherited from MemberDescriptor.)
Public property | ComponentType | Gets the type of component to which this property description binds. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | Converter | Gets the type converter for this property. (Inherited from PropertyDescriptor.)
Public property | Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
Public property | DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
Public property | DisplayName | Gets the name that can be displayed in a window, such as a Properties window. (Inherited from MemberDescriptor.)
Public property | Index |
Public property | IsBrowsable | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute. (Inherited from MemberDescriptor.)
Public property | IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
Public property | IsReadOnly | (Overrides TypeConverterSimplePropertyDescriptorIsReadOnly.)
Public property | List |
Public property | Name | Gets the name of the member. (Inherited from MemberDescriptor.)
Protected property | NameHashCode | Gets the hash code for the name of the member, as specified in GetHashCode. (Inherited from MemberDescriptor.)
Public property | PropertyType | Gets the type of the property. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
Public property | SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
Top
Methods
 | Name | Description
Public method | AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | CanResetValue | Returns whether resetting the component changes the value of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Protected method | CreateAttributeCollection | Creates a collection of attributes using the array of attributes passed to the constructor. (Inherited from MemberDescriptor.)
Protected method | CreateInstance | Creates an instance of the specified type. (Inherited from PropertyDescriptor.)
Public method | Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
Protected method | FillAttributes | Adds the attributes of the PropertyDescriptor to the specified list of attributes in the parent class. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Attribute) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object, Attribute) | Returns a PropertyDescriptorCollection for a given object using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetEditor | Gets an editor of the specified type. (Inherited from PropertyDescriptor.)
Public method | GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
Protected method | GetInvocationTarget | This method returns the object that should be used during invocation of members. (Inherited from PropertyDescriptor.)
Protected method | GetTypeFromName | Returns a type using its name. (Inherited from PropertyDescriptor.)
Public method | GetValue | (Overrides PropertyDescriptorGetValue(Object).)
Protected method | GetValueChangedHandler | Retrieves the current set of ValueChanged event handlers for a specific component (Inherited from PropertyDescriptor.)
Protected method | OnValueChanged | Raises the ValueChanged event that you implemented. (Inherited from PropertyDescriptor.)
Public method | Remove |
Public method | RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | ResetValue | Resets the value for this property of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public method | SetValue | (Overrides PropertyDescriptorSetValue(Object, Object).)
Public method | ShouldSerializeValue | Returns whether the value of this property can persist. (Inherited from TypeConverterSimplePropertyDescriptor.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor Constructor

ExpandableCollectionConverterListItemPropertyDescriptor Constructor

Initializes a new instance of the ExpandableCollectionConverterListItemPropertyDescriptor class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ListItemPropertyDescriptor(
    IList list,
    int index,
    Type itemType,
    Attribute[] attributes,
    bool isCollectionReadOnly,
    bool isReadOnly
)
Public Sub New (
    list As IList,
    index As Integer,
    itemType As Type,
    attributes As Attribute(),
    isCollectionReadOnly As Boolean,
    isReadOnly As Boolean
)

Parameters

list
Type: System.CollectionsIList

[Missing <param name="list"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.#ctor(System.Collections.IList,System.Int32,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.#ctor(System.Collections.IList,System.Int32,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

itemType
Type: SystemType

[Missing <param name="itemType"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.#ctor(System.Collections.IList,System.Int32,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

attributes
Type: SystemAttribute

[Missing <param name="attributes"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.#ctor(System.Collections.IList,System.Int32,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

isCollectionReadOnly
Type: SystemBoolean

[Missing <param name="isCollectionReadOnly"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.#ctor(System.Collections.IList,System.Int32,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

isReadOnly
Type: SystemBoolean

[Missing <param name="isReadOnly"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.#ctor(System.Collections.IList,System.Int32,System.Type,System.Attribute[],System.Boolean,System.Boolean)"]

See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ListItemPropertyDescriptor Properties

The ExpandableCollectionConverterListItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Protected property | AttributeArray | Gets or sets an array of attributes. (Inherited from MemberDescriptor.)
Public property | Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Public property | CanRemove |
Public property | Category | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute. (Inherited from MemberDescriptor.)
Public property | ComponentType | Gets the type of component to which this property description binds. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | Converter | Gets the type converter for this property. (Inherited from PropertyDescriptor.)
Public property | Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
Public property | DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
Public property | DisplayName | Gets the name that can be displayed in a window, such as a Properties window. (Inherited from MemberDescriptor.)
Public property | Index |
Public property | IsBrowsable | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute. (Inherited from MemberDescriptor.)
Public property | IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
Public property | IsReadOnly | (Overrides TypeConverterSimplePropertyDescriptorIsReadOnly.)
Public property | List |
Public property | Name | Gets the name of the member. (Inherited from MemberDescriptor.)
Protected property | NameHashCode | Gets the hash code for the name of the member, as specified in GetHashCode. (Inherited from MemberDescriptor.)
Public property | PropertyType | Gets the type of the property. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public property | SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
Public property | SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
Top
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.CanRemove Property

ExpandableCollectionConverterListItemPropertyDescriptorCanRemove Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.CanRemove"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanRemove { get; }
Public Overridable ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean

Implements

ICollectionItemPropertyDescriptorCanRemove
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.Index Property

ExpandableCollectionConverterListItemPropertyDescriptorIndex Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.Index"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.IsReadOnly Property

ExpandableCollectionConverterListItemPropertyDescriptorIsReadOnly Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.IsReadOnly"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.List Property

ExpandableCollectionConverterListItemPropertyDescriptorList Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.List"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IList List { get; }
Public ReadOnly Property List As IList
    Get

Property Value

Type: IList
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ListItemPropertyDescriptor Methods

The ExpandableCollectionConverterListItemPropertyDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | CanResetValue | Returns whether resetting the component changes the value of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Protected method | CreateAttributeCollection | Creates a collection of attributes using the array of attributes passed to the constructor. (Inherited from MemberDescriptor.)
Protected method | CreateInstance | Creates an instance of the specified type. (Inherited from PropertyDescriptor.)
Public method | Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
Protected method | FillAttributes | Adds the attributes of the PropertyDescriptor to the specified list of attributes in the parent class. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Attribute) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object, Attribute) | Returns a PropertyDescriptorCollection for a given object using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetEditor | Gets an editor of the specified type. (Inherited from PropertyDescriptor.)
Public method | GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
Protected method | GetInvocationTarget | This method returns the object that should be used during invocation of members. (Inherited from PropertyDescriptor.)
Protected method | GetTypeFromName | Returns a type using its name. (Inherited from PropertyDescriptor.)
Public method | GetValue | (Overrides PropertyDescriptorGetValue(Object).)
Protected method | GetValueChangedHandler | Retrieves the current set of ValueChanged event handlers for a specific component (Inherited from PropertyDescriptor.)
Protected method | OnValueChanged | Raises the ValueChanged event that you implemented. (Inherited from PropertyDescriptor.)
Public method | Remove |
Public method | RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | ResetValue | Resets the value for this property of the component. (Inherited from TypeConverterSimplePropertyDescriptor.)
Public method | SetValue | (Overrides PropertyDescriptorSetValue(Object, Object).)
Public method | ShouldSerializeValue | Returns whether the value of this property can persist. (Inherited from TypeConverterSimplePropertyDescriptor.)
Top
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.GetValue Method

ExpandableCollectionConverterListItemPropertyDescriptorGetValue Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.GetValue(System.Object)"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object GetValue(
    Object component
)
Public Overrides Function GetValue (
    component As Object
) As Object

Parameters

component
Type: SystemObject

[Missing <param name="component"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.GetValue(System.Object)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.GetValue(System.Object)"]

See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.Remove Method

ExpandableCollectionConverterListItemPropertyDescriptorRemove Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.Remove"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool Remove()
Public Overridable Function Remove As Boolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.Remove"]

Implements

ICollectionItemPropertyDescriptorRemove
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.SetValue Method

ExpandableCollectionConverterListItemPropertyDescriptorSetValue Method

[Missing <summary> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.SetValue(System.Object,System.Object)"]

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void SetValue(
    Object component,
    Object value
)
Public Overrides Sub SetValue (
    component As Object,
    value As Object
)

Parameters

component
Type: SystemObject

[Missing <param name="component"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.SetValue(System.Object,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:ActiproSoftware.Windows.Controls.Grids.PropertyData.ExpandableCollectionConverter.ListItemPropertyDescriptor.SetValue(System.Object,System.Object)"]

See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICategoryEditorModel Interface

Provides the requirements for a property grid category editor IDataModel, that can consume and display one or more properties.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICategoryEditorModel : IDataModel
Public Interface ICategoryEditorModel
    Inherits IDataModel

The ICategoryEditorModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | EditorTemplate | Gets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICategoryEditorModel Properties

The ICategoryEditorModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | EditorTemplate | Gets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Top
See Also

Reference

ICategoryEditorModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICategoryEditorModel.EditorTemplate Property

ICategoryEditorModelEditorTemplate Property

Gets the DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DataTemplate EditorTemplate { get; }
ReadOnly Property EditorTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for editing the properties consumed by this editor.
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

ICategoryEditorModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICategoryEditorModel.EditorTemplateKey Property

ICategoryEditorModelEditorTemplateKey Property

Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object EditorTemplateKey { get; }
ReadOnly Property EditorTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

ICategoryEditorModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICategoryModel Interface

Provides the requirements for a property grid category IDataModel.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICategoryModel : IDataModel
Public Interface ICategoryModel
    Inherits IDataModel

The ICategoryModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICategoryModel Properties

The ICategoryModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Top
See Also

Reference

ICategoryModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor Interface

Identifies an object as a property descriptor for an item in a collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICollectionItemPropertyDescriptor
Public Interface ICollectionItemPropertyDescriptor

The ICollectionItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | CanRemove | Gets a value indicating whether the collection item can be removed.
Top
Methods
 | Name | Description
Public method | Remove | Removes this item from the associated collection.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor Properties

The ICollectionItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | CanRemove | Gets a value indicating whether the collection item can be removed.
Top
See Also

Reference

ICollectionItemPropertyDescriptor Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor.CanRemove Property

ICollectionItemPropertyDescriptorCanRemove Property

Gets a value indicating whether the collection item can be removed.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanRemove { get; }
ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the collection item can be removed; otherwise, false.
See Also

Reference

ICollectionItemPropertyDescriptor Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor Methods

The ICollectionItemPropertyDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Remove | Removes this item from the associated collection.
Top
See Also

Reference

ICollectionItemPropertyDescriptor Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor.Remove Method

ICollectionItemPropertyDescriptorRemove Method

Removes this item from the associated collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool Remove()
Function Remove As Boolean

Return Value

Type: Boolean
true if the item was removed; otherwise, false.
See Also

Reference

ICollectionItemPropertyDescriptor Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter Interface

Identifies an object as a type converter for a collection used to control how and when items should be added.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface ICollectionTypeConverter
Public Interface ICollectionTypeConverter

The ICollectionTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds the specified item into to the collection.
Public method | CanAddItem | Gets a value indicating whether a new item can be added to the collection.
Public method | CreateItem | Creates a new item that can be added into to the collection.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter Methods

The ICollectionTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds the specified item into to the collection.
Public method | CanAddItem | Gets a value indicating whether a new item can be added to the collection.
Public method | CreateItem | Creates a new item that can be added into to the collection.
Top
See Also

Reference

ICollectionTypeConverter Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter.AddItem Method

ICollectionTypeConverterAddItem Method

Adds the specified item into to the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AddItem(
    IPropertyModel propertyModel,
    Object item
)
Function AddItem (
    propertyModel As IPropertyModel,
    item As Object
) As Boolean

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.
item
Type: SystemObject
The item that should be added.

Return Value

Type: Boolean
true if the item was added to the collection; otherwise, false.
See Also

Reference

ICollectionTypeConverter Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter.CanAddItem Method

ICollectionTypeConverterCanAddItem Method

Gets a value indicating whether a new item can be added to the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanAddItem(
    IPropertyModel propertyModel
)
Function CanAddItem (
    propertyModel As IPropertyModel
) As Boolean

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.

Return Value

Type: Boolean
true if a new item can be added to the collection; otherwise, false.
See Also

Reference

ICollectionTypeConverter Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter.CreateItem Method

ICollectionTypeConverterCreateItem Method

Creates a new item that can be added into to the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object CreateItem(
    IPropertyModel propertyModel
)
Function CreateItem (
    propertyModel As IPropertyModel
) As Object

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.

Return Value

Type: Object
The item that was created.
See Also

Reference

ICollectionTypeConverter Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactory Interface

Provides the requirements for class that can return the data models for requested object values.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDataFactory
Public Interface IDataFactory

The IDataFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetDataModels | Returns the IDataModel collection for the requested object values.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactory Methods

The IDataFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetDataModels | Returns the IDataModel collection for the requested object values.
Top
See Also

Reference

IDataFactory Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactory.GetDataModels Method

IDataFactoryGetDataModels Method

Returns the IDataModel collection for the requested object values.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<IDataModel> GetDataModels(
    IDataFactoryRequest request
)
Function GetDataModels (
    request As IDataFactoryRequest
) As IList(Of IDataModel)

Parameters

request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IDataModel
A collection of IDataModel objects, if any were returned.
See Also

Reference

IDataFactory Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest Interface

Provides the core requirements of a request made to an IDataFactory.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDataFactoryRequest
Public Interface IDataFactoryRequest

The IDataFactoryRequest type exposes the following members.

Properties
 | Name | Description
Public property | AreAttachedPropertiesBrowsable | Gets whether attached properties are browsable and are displayed in the property grid.
Public property | AreCategoriesAutoExpanded | Gets whether categories are auto-expanded when they are added into the property grid.
Public property | AreInheritedPropertiesBrowsable | Gets whether inherited properties are browsable and are displayed in the property grid.
Public property | AreNestedCategoriesSupported | Gets whether nested categories are supported, using a special syntax in the category name.
Public property | ArePropertiesAutoExpanded | Gets whether expandable properties are auto-expanded when they are added into the property grid.
Public property | AreReadOnlyPropertiesBrowsable | Gets or sets whether read-only properties are browsable and are displayed in the property grid.
Public property | BrowsableAttributes | Gets or sets an array of Attribute objects that are used to determine which properties are browsable.
Public property | CategoryEditors | Gets the category editors that can consume and display one or more properties.
Public property | CollectionPropertyDisplayMode | Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.
Public property | DataObjects | Gets the objects for which data models are being requested.
Public property | IsCategorized | Gets whether properties are categorized.
Public property | IsHostReadOnly | Gets whether the host UI control (e.g. a property grid) is read-only.
Public property | MiscCategoryName | Gets the name used for the miscellaneous category.
Public property | Parent | Gets the IDataModel, if any, that is making the request.
Public property | Properties | Gets the explicitly-defined properties that should be displayed.
Public property | PropertyExpandability | Gets a PropertyExpandability that indicates the expandability of properties.
Public property | SortComparer | Gets the DataModelSortComparer to use for sorting data models.
Public property | Source | Gets the object or control that originally made the request.
Public property | Tag | Gets or sets custom data for the request.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest Properties

The IDataFactoryRequest type exposes the following members.

Properties
 | Name | Description
Public property | AreAttachedPropertiesBrowsable | Gets whether attached properties are browsable and are displayed in the property grid.
Public property | AreCategoriesAutoExpanded | Gets whether categories are auto-expanded when they are added into the property grid.
Public property | AreInheritedPropertiesBrowsable | Gets whether inherited properties are browsable and are displayed in the property grid.
Public property | AreNestedCategoriesSupported | Gets whether nested categories are supported, using a special syntax in the category name.
Public property | ArePropertiesAutoExpanded | Gets whether expandable properties are auto-expanded when they are added into the property grid.
Public property | AreReadOnlyPropertiesBrowsable | Gets or sets whether read-only properties are browsable and are displayed in the property grid.
Public property | BrowsableAttributes | Gets or sets an array of Attribute objects that are used to determine which properties are browsable.
Public property | CategoryEditors | Gets the category editors that can consume and display one or more properties.
Public property | CollectionPropertyDisplayMode | Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.
Public property | DataObjects | Gets the objects for which data models are being requested.
Public property | IsCategorized | Gets whether properties are categorized.
Public property | IsHostReadOnly | Gets whether the host UI control (e.g. a property grid) is read-only.
Public property | MiscCategoryName | Gets the name used for the miscellaneous category.
Public property | Parent | Gets the IDataModel, if any, that is making the request.
Public property | Properties | Gets the explicitly-defined properties that should be displayed.
Public property | PropertyExpandability | Gets a PropertyExpandability that indicates the expandability of properties.
Public property | SortComparer | Gets the DataModelSortComparer to use for sorting data models.
Public property | Source | Gets the object or control that originally made the request.
Public property | Tag | Gets or sets custom data for the request.
Top
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.AreAttachedPropertiesBrowsable Property

IDataFactoryRequestAreAttachedPropertiesBrowsable Property

Gets whether attached properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AreAttachedPropertiesBrowsable { get; }
ReadOnly Property AreAttachedPropertiesBrowsable As Boolean
    Get

Property Value

Type: Boolean
true if attached properties are browsable and are displayed in the property grid; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.AreCategoriesAutoExpanded Property

IDataFactoryRequestAreCategoriesAutoExpanded Property

Gets whether categories are auto-expanded when they are added into the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AreCategoriesAutoExpanded { get; }
ReadOnly Property AreCategoriesAutoExpanded As Boolean
    Get

Property Value

Type: Boolean
true if categories are auto-expanded when they are added into the property grid; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.AreInheritedPropertiesBrowsable Property

IDataFactoryRequestAreInheritedPropertiesBrowsable Property

Gets whether inherited properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AreInheritedPropertiesBrowsable { get; }
ReadOnly Property AreInheritedPropertiesBrowsable As Boolean
    Get

Property Value

Type: Boolean
true if inherited properties are browsable and are displayed in the property grid; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.AreNestedCategoriesSupported Property

IDataFactoryRequestAreNestedCategoriesSupported Property

Gets whether nested categories are supported, using a special syntax in the category name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AreNestedCategoriesSupported { get; }
ReadOnly Property AreNestedCategoriesSupported As Boolean
    Get

Property Value

Type: Boolean
true if nested categories are supported; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.ArePropertiesAutoExpanded Property

IDataFactoryRequestArePropertiesAutoExpanded Property

Gets whether expandable properties are auto-expanded when they are added into the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ArePropertiesAutoExpanded { get; }
ReadOnly Property ArePropertiesAutoExpanded As Boolean
    Get

Property Value

Type: Boolean
true if expandable properties are auto-expanded when they are added into the property grid; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.AreReadOnlyPropertiesBrowsable Property

IDataFactoryRequestAreReadOnlyPropertiesBrowsable Property

Gets or sets whether read-only properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool AreReadOnlyPropertiesBrowsable { get; }
ReadOnly Property AreReadOnlyPropertiesBrowsable As Boolean
    Get

Property Value

Type: Boolean
true if read-only properties are browsable and are displayed in the property grid; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.BrowsableAttributes Property

IDataFactoryRequestBrowsableAttributes Property

Gets or sets an array of Attribute objects that are used to determine which properties are browsable.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<Attribute> BrowsableAttributes { get; }
ReadOnly Property BrowsableAttributes As IEnumerable(Of Attribute)
    Get

Property Value

Type: IEnumerable Attribute
The array of Attribute objects that are used to determine which properties are browsable. The default value is a list with a single entry of BrowsableAttribute.Yes.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.CategoryEditors Property

IDataFactoryRequestCategoryEditors Property

Gets the category editors that can consume and display one or more properties.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<CategoryEditor> CategoryEditors { get; }
ReadOnly Property CategoryEditors As IEnumerable(Of CategoryEditor)
    Get

Property Value

Type: IEnumerable CategoryEditor
The category editors that can consume and display one or more properties.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.CollectionPropertyDisplayMode Property

IDataFactoryRequestCollectionPropertyDisplayMode Property

Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
CollectionPropertyDisplayMode CollectionPropertyDisplayMode { get; }
ReadOnly Property CollectionPropertyDisplayMode As CollectionPropertyDisplayMode
    Get

Property Value

Type: CollectionPropertyDisplayMode
A CollectionPropertyDisplayMode that indicates the display mode of collection properties. The default value is CollectionPropertyDisplayMode.Default.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.DataObjects Property

IDataFactoryRequestDataObjects Property

Gets the objects for which data models are being requested.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<Object> DataObjects { get; }
ReadOnly Property DataObjects As IList(Of Object)
    Get

Property Value

Type: IList Object
The objects for which data models are being requested.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.IsCategorized Property

IDataFactoryRequestIsCategorized Property

Gets whether properties are categorized.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsCategorized { get; }
ReadOnly Property IsCategorized As Boolean
    Get

Property Value

Type: Boolean
true if properties are categorized; otherwise, false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.IsHostReadOnly Property

IDataFactoryRequestIsHostReadOnly Property

Gets whether the host UI control (e.g. a property grid) is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsHostReadOnly { get; }
ReadOnly Property IsHostReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the host UI control (e.g. a property grid) is read-only; otherwise, false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.MiscCategoryName Property

IDataFactoryRequestMiscCategoryName Property

Gets the name used for the miscellaneous category.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string MiscCategoryName { get; }
ReadOnly Property MiscCategoryName As String
    Get

Property Value

Type: String
The name used for the miscellaneous category.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.Parent Property

IDataFactoryRequestParent Property

Gets the IDataModel, if any, that is making the request.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDataModel Parent { get; }
ReadOnly Property Parent As IDataModel
    Get

Property Value

Type: IDataModel
The IDataModel, if any, that is making the request.
Remarks
This property will not return a value if the request is for the root data models.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.Properties Property

IDataFactoryRequestProperties Property

Gets the explicitly-defined properties that should be displayed.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<IPropertyModel> Properties { get; }
ReadOnly Property Properties As IEnumerable(Of IPropertyModel)
    Get

Property Value

Type: IEnumerable IPropertyModel
the explicitly-defined properties that should be displayed
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.PropertyExpandability Property

IDataFactoryRequestPropertyExpandability Property

Gets a PropertyExpandability that indicates the expandability of properties.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PropertyExpandability PropertyExpandability { get; }
ReadOnly Property PropertyExpandability As PropertyExpandability
    Get

Property Value

Type: PropertyExpandability
A PropertyExpandability that indicates the expandability of properties.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.SortComparer Property

IDataFactoryRequestSortComparer Property

Gets the DataModelSortComparer to use for sorting data models.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DataModelSortComparer SortComparer { get; }
ReadOnly Property SortComparer As DataModelSortComparer
    Get

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting data models.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.Source Property

IDataFactoryRequestSource Property

Gets the object or control that originally made the request.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Source { get; }
ReadOnly Property Source As Object
    Get

Property Value

Type: Object
The object or control that originally made the request.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.Tag Property

IDataFactoryRequestTag Property

Gets or sets custom data for the request.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
The custom data for the request.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel Interface

Provides the requirements for a data model class that can represent a property or category in a property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IDataModel
Public Interface IDataModel

The IDataModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | Children | Gets the collection of child data models.
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip.
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Public property | IsInitialized | Gets or sets whether the data model has been initialized.
Public property | IsModified | Gets whether the data model has been modified.
Public property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Public property | Name | Gets the name of the data model.
Public property | Parent | Gets or sets the parent data model.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | Tag | Gets or sets custom data for the data model.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel Properties

The IDataModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | Children | Gets the collection of child data models.
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip.
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Public property | IsInitialized | Gets or sets whether the data model has been initialized.
Public property | IsModified | Gets whether the data model has been modified.
Public property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Public property | Name | Gets the name of the data model.
Public property | Parent | Gets or sets the parent data model.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | Tag | Gets or sets custom data for the data model.
Top
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.CanAutoDispose Property

IDataModelCanAutoDispose Property

Gets whether the data model should be automatically disposed when it is removed from a parent data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanAutoDispose { get; }
ReadOnly Property CanAutoDispose As Boolean
    Get

Property Value

Type: Boolean
true if the data model should be automatically disposed when it is removed from a parent data model; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.Children Property

IDataModelChildren Property

Gets the collection of child data models.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DataModelCollection Children { get; }
ReadOnly Property Children As DataModelCollection
    Get

Property Value

Type: DataModelCollection
The collection of child data models.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.Description Property

IDataModelDescription Property

Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.DisplayName Property

IDataModelDisplayName Property

Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string DisplayName { get; }
ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.IsExpanded Property

IDataModelIsExpanded Property

Gets or sets whether the data model is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsExpanded { get; set; }
Property IsExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is expanded; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.IsInitialized Property

IDataModelIsInitialized Property

Gets or sets whether the data model has been initialized.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsInitialized { get; set; }
Property IsInitialized As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model has been initialized; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.IsModified Property

IDataModelIsModified Property

Gets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsModified { get; }
ReadOnly Property IsModified As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.IsRoot Property

IDataModelIsRoot Property

Gets whether the data model is the root.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsRoot { get; }
ReadOnly Property IsRoot As Boolean
    Get

Property Value

Type: Boolean
true if the data model is the root; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.IsSelected Property

IDataModelIsSelected Property

Gets or sets whether the data model is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsSelected { get; set; }
Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is selected; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.Name Property

IDataModelName Property

Gets the name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the data model.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.Parent Property

IDataModelParent Property

Gets or sets the parent data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IDataModel Parent { get; set; }
Property Parent As IDataModel
    Get
    Set

Property Value

Type: IDataModel
The parent data model.
Remarks
Do not set this property directly, as it will be set when a data model is added as a child of another data model.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.SortComparer Property

IDataModelSortComparer Property

Gets or sets the DataModelSortComparer to use for sorting this data model's children.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DataModelSortComparer SortComparer { get; set; }
Property SortComparer As DataModelSortComparer
    Get
    Set

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting this data model's children.
Remarks
If this property doesn't return anything, the default SortComparer will be used.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.SortImportance Property

IDataModelSortImportance Property

Gets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DataModelSortImportance SortImportance { get; }
ReadOnly Property SortImportance As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.SortOrder Property

IDataModelSortOrder Property

Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int SortOrder { get; }
ReadOnly Property SortOrder As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IDataModel.Tag Property

IDataModelTag Property

Gets or sets custom data for the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
The custom data for the data model.
See Also

Reference

IDataModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel Interface

Provides the requirements for a property grid property IDataModel.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPropertyModel : IDataModel
Public Interface IPropertyModel
    Inherits IDataModel

The IPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Public property | CanResetValue | Gets whether the property can be reset to its default value.
Public property | Category | Gets a category for the property.
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Converter | Gets the TypeConverter to use for the property.
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | StandardValues | Gets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings.
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true.
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Public property | Target | Gets the target object that owns the property.
Public property | TargetType | Gets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value.
Public property | ValueType | Gets the Type of the Value property.
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Refresh | Refreshes the property based on the specified reason.
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel Properties

The IPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Public property | CanResetValue | Gets whether the property can be reset to its default value.
Public property | Category | Gets a category for the property.
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Converter | Gets the TypeConverter to use for the property.
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | StandardValues | Gets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings.
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true.
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Public property | Target | Gets the target object that owns the property.
Public property | TargetType | Gets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value.
Public property | ValueType | Gets the Type of the Value property.
Top
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.AddChildCommand Property

IPropertyModelAddChildCommand Property

Gets the ICommand used to add a new child into to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ICommand AddChildCommand { get; }
ReadOnly Property AddChildCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to add a new child into to an associated collection/parent.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.CanAddChild Property

IPropertyModelCanAddChild Property

Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanAddChild { get; }
ReadOnly Property CanAddChild As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.CanRemove Property

IPropertyModelCanRemove Property

Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanRemove { get; }
ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.CanResetValue Property

IPropertyModelCanResetValue Property

Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CanResetValue { get; }
ReadOnly Property CanResetValue As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.Category Property

IPropertyModelCategory Property

Gets a category for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string Category { get; }
ReadOnly Property Category As String
    Get

Property Value

Type: String
A category for the property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.Converter Property

IPropertyModelConverter Property

Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
TypeConverter Converter { get; }
ReadOnly Property Converter As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.HasStandardValues Property

IPropertyModelHasStandardValues Property

Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool HasStandardValues { get; }
ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.IsHostReadOnly Property

IPropertyModelIsHostReadOnly Property

Gets or sets whether the host UI control (e.g. a property grid) is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsHostReadOnly { get; set; }
Property IsHostReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the host UI control (e.g. a property grid) is read-only; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.IsImmutable Property

IPropertyModelIsImmutable Property

Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsImmutable { get; }
ReadOnly Property IsImmutable As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.IsLimitedToStandardValues Property

IPropertyModelIsLimitedToStandardValues Property

Gets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsLimitedToStandardValues { get; }
ReadOnly Property IsLimitedToStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.IsMergeable Property

IPropertyModelIsMergeable Property

Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsMergeable { get; }
ReadOnly Property IsMergeable As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.IsReadOnly Property

IPropertyModelIsReadOnly Property

Gets whether UI for editing the property value is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the UI for editing the property value is read-only; otherwise, false.
Remarks
This property is a resolved value of IsHostReadOnly and IsValueReadOnly.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.IsValueReadOnly Property

IPropertyModelIsValueReadOnly Property

Gets or sets whether the Value property is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool IsValueReadOnly { get; set; }
Property IsValueReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
Remarks
This property can be set to true to force a normally-editable property to be read-only. Some implementations of this property will always return true when the underlying property value is unable to be set.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.NamePropertyEditor Property

IPropertyModelNamePropertyEditor Property

Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PropertyEditor NamePropertyEditor { get; set; }
Property NamePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.NameTemplate Property

IPropertyModelNameTemplate Property

Gets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DataTemplate NameTemplate { get; }
ReadOnly Property NameTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.NameTemplateKey Property

IPropertyModelNameTemplateKey Property

Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object NameTemplateKey { get; }
ReadOnly Property NameTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.NameTemplateSelector Property

IPropertyModelNameTemplateSelector Property

Gets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DataTemplateSelector NameTemplateSelector { get; }
ReadOnly Property NameTemplateSelector As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.RemoveCommand Property

IPropertyModelRemoveCommand Property

Gets the ICommand used to remove the property from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ICommand RemoveCommand { get; }
ReadOnly Property RemoveCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to remove the property from an associated collection/parent.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ResetValueCommand Property

IPropertyModelResetValueCommand Property

Gets the ICommand used to reset the property value to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
ICommand ResetValueCommand { get; }
ReadOnly Property ResetValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to reset the property value to its default value.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ShouldNotifyParentOnValueChange Property

IPropertyModelShouldNotifyParentOnValueChange Property

Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool ShouldNotifyParentOnValueChange { get; }
ReadOnly Property ShouldNotifyParentOnValueChange As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.StandardValues Property

IPropertyModelStandardValues Property

Gets the standard list of values for the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable StandardValues { get; }
ReadOnly Property StandardValues As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.StandardValuesAsStrings Property

IPropertyModelStandardValuesAsStrings Property

Gets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IEnumerable<string> StandardValuesAsStrings { get; }
ReadOnly Property StandardValuesAsStrings As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.StandardValuesDisplayMemberPath Property

IPropertyModelStandardValuesDisplayMemberPath Property

Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string StandardValuesDisplayMemberPath { get; set; }
Property StandardValuesDisplayMemberPath As String
    Get
    Set

Property Value

Type: String
The display member path for StandardValues when IsLimitedToStandardValues is true.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.Target Property

IPropertyModelTarget Property

Gets the target object that owns the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Target { get; }
ReadOnly Property Target As Object
    Get

Property Value

Type: Object
The target object that owns the property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.TargetType Property

IPropertyModelTargetType Property

Gets the Type of the Target property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Type TargetType { get; }
ReadOnly Property TargetType As Type
    Get

Property Value

Type: Type
The Type of the Target property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.Value Property

IPropertyModelValue Property

Gets or sets the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Value { get; set; }
Property Value As Object
    Get
    Set

Property Value

Type: Object
The property value.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueAsString Property

IPropertyModelValueAsString Property

Gets or sets the property value in a string representation.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
string ValueAsString { get; set; }
Property ValueAsString As String
    Get
    Set

Property Value

Type: String
The property value in a string representation.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ValuePropertyEditor Property

IPropertyModelValuePropertyEditor Property

Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PropertyEditor ValuePropertyEditor { get; set; }
Property ValuePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.Values Property

IPropertyModelValues Property

Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
IList<Object> Values { get; }
ReadOnly Property Values As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueTemplate Property

IPropertyModelValueTemplate Property

Gets the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DataTemplate ValueTemplate { get; }
ReadOnly Property ValueTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueTemplateKey Property

IPropertyModelValueTemplateKey Property

Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object ValueTemplateKey { get; }
ReadOnly Property ValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueTemplateKind Property

IPropertyModelValueTemplateKind Property

Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DefaultValueTemplateKind ValueTemplateKind { get; }
ReadOnly Property ValueTemplateKind As DefaultValueTemplateKind
    Get

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueTemplateSelector Property

IPropertyModelValueTemplateSelector Property

Gets the DataTemplateSelector to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
DataTemplateSelector ValueTemplateSelector { get; }
ReadOnly Property ValueTemplateSelector As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueType Property

IPropertyModelValueType Property

Gets the Type of the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Type ValueType { get; }
ReadOnly Property ValueType As Type
    Get

Property Value

Type: Type
The Type of the Value property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel Methods

The IPropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Refresh | Refreshes the property based on the specified reason.
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Top
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.AddChild Method

IPropertyModelAddChild Method

Adds a new child into to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void AddChild()
Sub AddChild
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.CycleToNextStandardValue Method

IPropertyModelCycleToNextStandardValue Method

Cycles the property value to the next standard value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
bool CycleToNextStandardValue()
Function CycleToNextStandardValue As Boolean

Return Value

Type: Boolean
true if a standard value was set; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.Refresh Method

IPropertyModelRefresh Method

Refreshes the property based on the specified reason.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Refresh(
    PropertyRefreshReason reason
)
Sub Refresh (
    reason As PropertyRefreshReason
)

Parameters

reason
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyRefreshReason
The reason the property needs to be refreshed.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.Remove Method

IPropertyModelRemove Method

Removes the property from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void Remove()
Sub Remove
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IPropertyModel.ResetValue Method

IPropertyModelResetValue Method

Resets the property value to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
void ResetValue()
Sub ResetValue
See Also

Reference

IPropertyModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IRootModel Interface

Provides the requirements for a data model class that is the root model in the hierarchy.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IRootModel : IDataModel,
    IPropertyModel
Public Interface IRootModel
    Inherits IDataModel, IPropertyModel

The IRootModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from IPropertyModel.)
Public property | Category | Gets a category for the property. (Inherited from IPropertyModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from IPropertyModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from IPropertyModel.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from IPropertyModel.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from IPropertyModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from IPropertyModel.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from IPropertyModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from IPropertyModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from IPropertyModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from IPropertyModel.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from IPropertyModel.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from IPropertyModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Source | Gets the object or control that owns the data model hierarchy.
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from IPropertyModel.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from IPropertyModel.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from IPropertyModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Public property | Target | Gets the target object that owns the property. (Inherited from IPropertyModel.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from IPropertyModel.)
Public property | Value | Gets or sets the property value. (Inherited from IPropertyModel.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from IPropertyModel.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from IPropertyModel.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from IPropertyModel.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from IPropertyModel.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from IPropertyModel.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from IPropertyModel.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from IPropertyModel.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from IPropertyModel.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from IPropertyModel.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IRootModel Properties

The IRootModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from IPropertyModel.)
Public property | Category | Gets a category for the property. (Inherited from IPropertyModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from IPropertyModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from IPropertyModel.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from IPropertyModel.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from IPropertyModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from IPropertyModel.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from IPropertyModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from IPropertyModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from IPropertyModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from IPropertyModel.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from IPropertyModel.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from IPropertyModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Source | Gets the object or control that owns the data model hierarchy.
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from IPropertyModel.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from IPropertyModel.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from IPropertyModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Public property | Target | Gets the target object that owns the property. (Inherited from IPropertyModel.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from IPropertyModel.)
Public property | Value | Gets or sets the property value. (Inherited from IPropertyModel.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from IPropertyModel.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from IPropertyModel.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from IPropertyModel.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from IPropertyModel.)
Top
See Also

Reference

IRootModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IRootModel.Source Property

IRootModelSource Property

Gets the object or control that owns the data model hierarchy.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Source { get; }
ReadOnly Property Source As Object
    Get

Property Value

Type: Object
The object or control that owns the data model hierarchy.
See Also

Reference

IRootModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


IRootModel Methods

The IRootModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from IPropertyModel.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from IPropertyModel.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from IPropertyModel.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from IPropertyModel.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from IPropertyModel.)
Top
See Also

Reference

IRootModel Interface
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel Class

Represents a property grid property IDataModel that merges a property from multiple data objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataCachedPropertyModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataMergedPropertyModel

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MergedPropertyModel : CachedPropertyModelBase
Public Class MergedPropertyModel
    Inherits CachedPropertyModelBase

The MergedPropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | MergedPropertyModel | Initializes an instance of the MergedPropertyModel class.
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Overrides CachedPropertyModelBaseCanResetValueCore.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Overrides CachedPropertyModelBaseCategoryCore.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides CachedPropertyModelBaseConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Overrides CachedPropertyModelBaseDescriptionCore.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Overrides CachedPropertyModelBaseDisplayNameCore.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Overrides CachedPropertyModelBaseHasStandardValues.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Overrides CachedPropertyModelBaseIsImmutableCore.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Overrides CachedPropertyModelBaseIsLimitedToStandardValuesCore.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Overrides CachedPropertyModelBaseIsMergeableCore.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Overrides CachedPropertyModelBaseIsModifiedCore.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Overrides CachedPropertyModelBaseIsValueReadOnlyCore.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Overrides CachedPropertyModelBaseNameCore.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateCore.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateKeyCore.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateSelectorCore.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Overrides CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Overrides CachedPropertyModelBaseSortImportanceCore.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides CachedPropertyModelBaseSortOrderCore.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Overrides CachedPropertyModelBaseStandardValuesAsStrings.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Overrides CachedPropertyModelBaseStandardValuesCore.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from PropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Overrides CachedPropertyModelBaseTargetCore.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Overrides CachedPropertyModelBaseTargetType.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Overrides CachedPropertyModelBaseValueCore.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Overrides CachedPropertyModelBaseValuesCore.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateCore.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateKeyCore.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateKindCore.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateSelectorCore.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Overrides CachedPropertyModelBaseValueTypeCore.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Overrides PropertyModelBaseGetErrorMessages(String).)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from CachedPropertyModelBase.)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public method | ResetValue | Resets the property value to its default value. (Overrides PropertyModelBaseResetValue.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel Constructor

Initializes an instance of the MergedPropertyModel class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MergedPropertyModel(
    IList<IPropertyModel> propertyModels
)
Public Sub New (
    propertyModels As IList(Of IPropertyModel)
)

Parameters

propertyModels
Type: System.Collections.GenericIList IPropertyModel
The collection of IPropertyModel objects to merge.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel Properties

The MergedPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Overrides CachedPropertyModelBaseCanResetValueCore.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Overrides CachedPropertyModelBaseCategoryCore.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides CachedPropertyModelBaseConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Overrides CachedPropertyModelBaseDescriptionCore.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Overrides CachedPropertyModelBaseDisplayNameCore.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Overrides CachedPropertyModelBaseHasStandardValues.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Overrides CachedPropertyModelBaseIsImmutableCore.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Overrides CachedPropertyModelBaseIsLimitedToStandardValuesCore.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Overrides CachedPropertyModelBaseIsMergeableCore.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Overrides CachedPropertyModelBaseIsModifiedCore.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Overrides CachedPropertyModelBaseIsValueReadOnlyCore.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Overrides CachedPropertyModelBaseNameCore.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateCore.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateKeyCore.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateSelectorCore.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Overrides CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Overrides CachedPropertyModelBaseSortImportanceCore.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides CachedPropertyModelBaseSortOrderCore.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Overrides CachedPropertyModelBaseStandardValuesAsStrings.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Overrides CachedPropertyModelBaseStandardValuesCore.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from PropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Overrides CachedPropertyModelBaseTargetCore.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Overrides CachedPropertyModelBaseTargetType.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Overrides CachedPropertyModelBaseValueCore.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Overrides CachedPropertyModelBaseValuesCore.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateCore.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateKeyCore.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateKindCore.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateSelectorCore.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Overrides CachedPropertyModelBaseValueTypeCore.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.CanResetValueCore Property

MergedPropertyModelCanResetValueCore Property

Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool CanResetValueCore { get; }
Protected Overrides ReadOnly Property CanResetValueCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.CategoryCore Property

MergedPropertyModelCategoryCore Property

Gets a category for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string CategoryCore { get; }
Protected Overrides ReadOnly Property CategoryCore As String
    Get

Property Value

Type: String
A category for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ConverterCore Property

MergedPropertyModelConverterCore Property

Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override TypeConverter ConverterCore { get; }
Protected Overrides ReadOnly Property ConverterCore As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.DescriptionCore Property

MergedPropertyModelDescriptionCore Property

Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string DescriptionCore { get; }
Protected Overrides ReadOnly Property DescriptionCore As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.DisplayNameCore Property

MergedPropertyModelDisplayNameCore Property

Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string DisplayNameCore { get; }
Protected Overrides ReadOnly Property DisplayNameCore As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.HasStandardValues Property

MergedPropertyModelHasStandardValues Property

Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool HasStandardValues { get; }
Public Overrides ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.

Implements

IPropertyModelHasStandardValues
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsImmutableCore Property

MergedPropertyModelIsImmutableCore Property

Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsImmutableCore { get; }
Protected Overrides ReadOnly Property IsImmutableCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsLimitedToStandardValuesCore Property

MergedPropertyModelIsLimitedToStandardValuesCore Property

Gets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsLimitedToStandardValuesCore { get; }
Protected Overrides ReadOnly Property IsLimitedToStandardValuesCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsMergeableCore Property

MergedPropertyModelIsMergeableCore Property

Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsMergeableCore { get; }
Protected Overrides ReadOnly Property IsMergeableCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsModifiedCore Property

MergedPropertyModelIsModifiedCore Property

Gets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsModifiedCore { get; }
Protected Overrides ReadOnly Property IsModifiedCore As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsValueReadOnlyCore Property

MergedPropertyModelIsValueReadOnlyCore Property

Gets whether the Value property is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValueReadOnlyCore { get; }
Protected Overrides ReadOnly Property IsValueReadOnlyCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.NameCore Property

MergedPropertyModelNameCore Property

Gets the name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string NameCore { get; }
Protected Overrides ReadOnly Property NameCore As String
    Get

Property Value

Type: String
The name of the data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.NameTemplateCore Property

MergedPropertyModelNameTemplateCore Property

Gets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DataTemplate NameTemplateCore { get; }
Protected Overrides ReadOnly Property NameTemplateCore As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.NameTemplateKeyCore Property

MergedPropertyModelNameTemplateKeyCore Property

Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object NameTemplateKeyCore { get; }
Protected Overrides ReadOnly Property NameTemplateKeyCore As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.NameTemplateSelectorCore Property

MergedPropertyModelNameTemplateSelectorCore Property

Gets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DataTemplateSelector NameTemplateSelectorCore { get; }
Protected Overrides ReadOnly Property NameTemplateSelectorCore As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ShouldNotifyParentOnValueChangeCore Property

MergedPropertyModelShouldNotifyParentOnValueChangeCore Property

Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ShouldNotifyParentOnValueChangeCore { get; }
Protected Overrides ReadOnly Property ShouldNotifyParentOnValueChangeCore As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.SortImportanceCore Property

MergedPropertyModelSortImportanceCore Property

Gets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DataModelSortImportance SortImportanceCore { get; }
Protected Overrides ReadOnly Property SortImportanceCore As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.SortOrderCore Property

MergedPropertyModelSortOrderCore Property

Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override int SortOrderCore { get; }
Protected Overrides ReadOnly Property SortOrderCore As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.StandardValuesAsStrings Property

MergedPropertyModelStandardValuesAsStrings Property

Gets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override IEnumerable<string> StandardValuesAsStrings { get; }
Public Overrides ReadOnly Property StandardValuesAsStrings As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.

Implements

IPropertyModelStandardValuesAsStrings
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.StandardValuesCore Property

MergedPropertyModelStandardValuesCore Property

Gets the standard list of values for the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerable StandardValuesCore { get; }
Protected Overrides ReadOnly Property StandardValuesCore As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.TargetCore Property

MergedPropertyModelTargetCore Property

Gets the target object that owns the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object TargetCore { get; }
Protected Overrides ReadOnly Property TargetCore As Object
    Get

Property Value

Type: Object
The target object that owns the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.TargetType Property

MergedPropertyModelTargetType Property

Gets the Type of the Target property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Type TargetType { get; }
Public Overrides ReadOnly Property TargetType As Type
    Get

Property Value

Type: Type
The Type of the Target property.

Implements

IPropertyModelTargetType
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueCore Property

MergedPropertyModelValueCore Property

Gets or sets the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object ValueCore { get; set; }
Protected Overrides Property ValueCore As Object
    Get
    Set

Property Value

Type: Object
The property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValuesCore Property

MergedPropertyModelValuesCore Property

Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<Object> ValuesCore { get; }
Protected Overrides ReadOnly Property ValuesCore As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTemplateCore Property

MergedPropertyModelValueTemplateCore Property

Gets the DataTemplate to use for use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DataTemplate ValueTemplateCore { get; }
Protected Overrides ReadOnly Property ValueTemplateCore As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTemplateKeyCore Property

MergedPropertyModelValueTemplateKeyCore Property

Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object ValueTemplateKeyCore { get; }
Protected Overrides ReadOnly Property ValueTemplateKeyCore As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTemplateKindCore Property

MergedPropertyModelValueTemplateKindCore Property

Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DefaultValueTemplateKind ValueTemplateKindCore { get; }
Protected Overrides ReadOnly Property ValueTemplateKindCore As DefaultValueTemplateKind
    Get

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTemplateSelectorCore Property

MergedPropertyModelValueTemplateSelectorCore Property

Gets the DataTemplateSelector to use for use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override DataTemplateSelector ValueTemplateSelectorCore { get; }
Protected Overrides ReadOnly Property ValueTemplateSelectorCore As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTypeCore Property

MergedPropertyModelValueTypeCore Property

Gets the Type of the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type ValueTypeCore { get; }
Protected Overrides ReadOnly Property ValueTypeCore As Type
    Get

Property Value

Type: Type
The Type of the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel Methods

The MergedPropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Overrides PropertyModelBaseGetErrorMessages(String).)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from CachedPropertyModelBase.)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public method | ResetValue | Resets the property value to its default value. (Overrides PropertyModelBaseResetValue.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.Dispose Method

MergedPropertyModelDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Top
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.Dispose Method (Boolean)

MergedPropertyModelDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

MergedPropertyModel Class
Dispose Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.GetErrorMessages Method

MergedPropertyModelGetErrorMessages Method

Returns the error messages for the target object or one of its properties.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerable GetErrorMessages(
    string columnName
)
Protected Overrides Function GetErrorMessages (
    columnName As String
) As IEnumerable

Parameters

columnName
Type: SystemString
The name of the property to examine, or if the target object itself should be examined.

Return Value

Type: IEnumerable
The error messages that are applicable, if any.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ResetValue Method

MergedPropertyModelResetValue Method

Resets the property value to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void ResetValue()
Public Overrides Sub ResetValue
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


MergedPropertyModel Events

The MergedPropertyModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Class

Represents a property grid property IDataModel that is based on PropertyDescriptor data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataCachedPropertyModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyDescriptorPropertyModel
ActiproSoftware.Windows.Controls.Grids.PropertyDataCollectionPropertyDescriptorPropertyModel

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyDescriptorPropertyModel : CachedPropertyModelBase,
    ITypeDescriptorContext
Public Class PropertyDescriptorPropertyModel
    Inherits CachedPropertyModelBase
    Implements ITypeDescriptorContext

The PropertyDescriptorPropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDescriptorPropertyModel | Initializes an instance of the PropertyDescriptorPropertyModel class.
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Overrides CachedPropertyModelBaseCanRemoveCore.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Overrides CachedPropertyModelBaseCanResetValueCore.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Overrides CachedPropertyModelBaseCategoryCore.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides CachedPropertyModelBaseConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Overrides CachedPropertyModelBaseDescriptionCore.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Overrides CachedPropertyModelBaseDisplayNameCore.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Overrides CachedPropertyModelBaseIsImmutableCore.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Overrides CachedPropertyModelBaseIsMergeableCore.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Overrides CachedPropertyModelBaseIsModifiedCore.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Overrides CachedPropertyModelBaseIsValueReadOnlyCore.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Overrides CachedPropertyModelBaseNameCore.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Overrides CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides CachedPropertyModelBaseSortOrderCore.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from PropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Overrides CachedPropertyModelBaseTargetCore.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from CachedPropertyModelBase.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Overrides CachedPropertyModelBaseValueCore.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Overrides CachedPropertyModelBaseValueTypeCore.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from CachedPropertyModelBase.)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Overrides PropertyModelBaseRemove.)
Public method | ResetValue | Resets the property value to its default value. (Overrides PropertyModelBaseResetValue.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Constructor

Initializes an instance of the PropertyDescriptorPropertyModel class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyDescriptorPropertyModel(
    Object target,
    PropertyDescriptor propertyDescriptor
)
Public Sub New (
    target As Object,
    propertyDescriptor As PropertyDescriptor
)

Parameters

target
Type: SystemObject
The target object that owns the property.
propertyDescriptor
Type: System.ComponentModelPropertyDescriptor
The PropertyDescriptor for the property be accessed on the target.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Properties

The PropertyDescriptorPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Overrides CachedPropertyModelBaseCanRemoveCore.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Overrides CachedPropertyModelBaseCanResetValueCore.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Overrides CachedPropertyModelBaseCategoryCore.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides CachedPropertyModelBaseConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Overrides CachedPropertyModelBaseDescriptionCore.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Overrides CachedPropertyModelBaseDisplayNameCore.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Overrides CachedPropertyModelBaseIsImmutableCore.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Overrides CachedPropertyModelBaseIsMergeableCore.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Overrides CachedPropertyModelBaseIsModifiedCore.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Overrides CachedPropertyModelBaseIsValueReadOnlyCore.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Overrides CachedPropertyModelBaseNameCore.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Overrides CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides CachedPropertyModelBaseSortOrderCore.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true. (Inherited from PropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Overrides CachedPropertyModelBaseTargetCore.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from CachedPropertyModelBase.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Overrides CachedPropertyModelBaseValueCore.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Overrides CachedPropertyModelBaseValueTypeCore.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.CanRemoveCore Property

PropertyDescriptorPropertyModelCanRemoveCore Property

Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool CanRemoveCore { get; }
Protected Overrides ReadOnly Property CanRemoveCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.CanResetValueCore Property

PropertyDescriptorPropertyModelCanResetValueCore Property

Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool CanResetValueCore { get; }
Protected Overrides ReadOnly Property CanResetValueCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.CategoryCore Property

PropertyDescriptorPropertyModelCategoryCore Property

Gets a category for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string CategoryCore { get; }
Protected Overrides ReadOnly Property CategoryCore As String
    Get

Property Value

Type: String
A category for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ConverterCore Property

PropertyDescriptorPropertyModelConverterCore Property

Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override TypeConverter ConverterCore { get; }
Protected Overrides ReadOnly Property ConverterCore As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.DescriptionCore Property

PropertyDescriptorPropertyModelDescriptionCore Property

Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string DescriptionCore { get; }
Protected Overrides ReadOnly Property DescriptionCore As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.DisplayNameCore Property

PropertyDescriptorPropertyModelDisplayNameCore Property

Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string DisplayNameCore { get; }
Protected Overrides ReadOnly Property DisplayNameCore As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.IsImmutableCore Property

PropertyDescriptorPropertyModelIsImmutableCore Property

Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsImmutableCore { get; }
Protected Overrides ReadOnly Property IsImmutableCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.IsMergeableCore Property

PropertyDescriptorPropertyModelIsMergeableCore Property

Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsMergeableCore { get; }
Protected Overrides ReadOnly Property IsMergeableCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.IsModifiedCore Property

PropertyDescriptorPropertyModelIsModifiedCore Property

Gets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsModifiedCore { get; }
Protected Overrides ReadOnly Property IsModifiedCore As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.IsValueReadOnlyCore Property

PropertyDescriptorPropertyModelIsValueReadOnlyCore Property

Gets whether the Value property is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool IsValueReadOnlyCore { get; }
Protected Overrides ReadOnly Property IsValueReadOnlyCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.NameCore Property

PropertyDescriptorPropertyModelNameCore Property

Gets the name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string NameCore { get; }
Protected Overrides ReadOnly Property NameCore As String
    Get

Property Value

Type: String
The name of the data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ShouldNotifyParentOnValueChangeCore Property

PropertyDescriptorPropertyModelShouldNotifyParentOnValueChangeCore Property

Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool ShouldNotifyParentOnValueChangeCore { get; }
Protected Overrides ReadOnly Property ShouldNotifyParentOnValueChangeCore As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.SortOrderCore Property

PropertyDescriptorPropertyModelSortOrderCore Property

Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override int SortOrderCore { get; }
Protected Overrides ReadOnly Property SortOrderCore As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.TargetCore Property

PropertyDescriptorPropertyModelTargetCore Property

Gets the target object that owns the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object TargetCore { get; }
Protected Overrides ReadOnly Property TargetCore As Object
    Get

Property Value

Type: Object
The target object that owns the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ValueCore Property

PropertyDescriptorPropertyModelValueCore Property

Gets or sets the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Object ValueCore { get; set; }
Protected Overrides Property ValueCore As Object
    Get
    Set

Property Value

Type: Object
The property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ValueTypeCore Property

PropertyDescriptorPropertyModelValueTypeCore Property

Gets the Type of the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Type ValueTypeCore { get; }
Protected Overrides ReadOnly Property ValueTypeCore As Type
    Get

Property Value

Type: Type
The Type of the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Methods

The PropertyDescriptorPropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from CachedPropertyModelBase.)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Overrides PropertyModelBaseRemove.)
Public method | ResetValue | Resets the property value to its default value. (Overrides PropertyModelBaseResetValue.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.Dispose Method

PropertyDescriptorPropertyModelDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Top
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.Dispose Method (Boolean)

PropertyDescriptorPropertyModelDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

PropertyDescriptorPropertyModel Class
Dispose Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.Remove Method

PropertyDescriptorPropertyModelRemove Method

Removes the property from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Remove()
Public Overrides Sub Remove
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ResetValue Method

PropertyDescriptorPropertyModelResetValue Method

Resets the property value to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void ResetValue()
Public Overrides Sub ResetValue
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Events

The PropertyDescriptorPropertyModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyExpandability Enumeration

Specifies the expandability of properties in the property grid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PropertyExpandability
Public Enumeration PropertyExpandability
Members
Member name | Value | Description
Default | 0 | Indicates that properties will be expandable if the associated type converter allows sub-properties to be retrieved.
None | 1 | Indicates that properties will never be expandable.
ForceSimple | 2 | Indicates that properties will be forced to be expandable if a custom type converter has not been specified.
ForceAlways | 3 | Indicates that properties will be forced to be expandable even if a custom type converter has been specified. If a custom type converter has been specified, then it will only be overridden if it does not allow the property to be expandable.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel Class

Represents a property grid property IDataModel that can be easily explicitly-defined and optionally bound to in XAML.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModel

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyModel : DependencyObject,
    INotifyPropertyChanged, IDataErrorInfo, IDataModel, IPropertyModel
Public Class PropertyModel
    Inherits DependencyObject
    Implements INotifyPropertyChanged, IDataErrorInfo, IDataModel, IPropertyModel

The PropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModel | Initializes a new instance of the PropertyModel class
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Public property | CanResetValue | Gets or sets whether the property can be reset to its default value.
Public property | Category | Gets or sets a category for the property.
Public property | Children | Gets the collection of child data models.
Public property | Converter | Gets or sets the TypeConverter to use for the property.
Public property | DefaultValue | Gets or sets the default value to use for a reset operation.
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Public property | IsLimitedToStandardValues | Gets or sets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets or sets whether the data model has been modified.
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Protected property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Public property | Name | Gets or sets the name of the data model.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets the parent data model.
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Public property | SortImportance | Gets or sets a DataModelSortImportance that indicates the sort importance of this data model.
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | StandardValues | Gets or sets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets or sets the standard list of values for the ValueAsString property as a list of strings.
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true.
Public property | Tag | Gets or sets custom data for the data model.
Public property | Target | Gets the target object that owns the property.
Public property | TargetType | Gets or sets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value.
Public property | ValueType | Gets or sets the Type of the Value property.
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ConvertFromString | Converts the specified value from a string.
Protected method | ConvertToString | Converts the specified value to a string.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties.
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid.
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid.
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid.
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid.
Public method | Refresh | Refreshes the property based on the specified reason.
Protected method | RefreshChildren | Refreshes the contents of the Children property.
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
Fields
Name | Description
CanResetValueProperty | Identifies the CanResetValue dependency property. This field is read-only.
CategoryProperty | Identifies the Category dependency property. This field is read-only.
ConverterProperty | Identifies the Converter dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
DisplayNameProperty | Identifies the DisplayName dependency property. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
IsHostReadOnlyProperty | Identifies the IsHostReadOnly dependency property. This field is read-only.
IsImmutableProperty | Identifies the IsImmutable dependency property. This field is read-only.
IsLimitedToStandardValuesProperty | Identifies the IsLimitedToStandardValues dependency property. This field is read-only.
IsModifiedProperty | Identifies the IsModified dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
IsValueReadOnlyProperty | Identifies the IsValueReadOnly dependency property. This field is read-only.
NameProperty | Identifies the Name dependency property. This field is read-only.
NamePropertyEditorProperty | Identifies the NamePropertyEditor dependency property. This field is read-only.
NameTemplateKeyProperty | Identifies the NameTemplateKey dependency property. This field is read-only.
NameTemplateProperty | Identifies the NameTemplate dependency property. This field is read-only.
NameTemplateSelectorProperty | Identifies the NameTemplateSelector dependency property. This field is read-only.
SortComparerProperty | Identifies the SortComparer dependency property. This field is read-only.
SortImportanceProperty | Identifies the SortImportance dependency property. This field is read-only.
SortOrderProperty | Identifies the SortOrder dependency property. This field is read-only.
StandardValuesAsStringsProperty | Identifies the StandardValuesAsStrings dependency property. This field is read-only.
StandardValuesDisplayMemberPathProperty | Identifies the StandardValuesDisplayMemberPath dependency property. This field is read-only.
StandardValuesProperty | Identifies the StandardValues dependency property. This field is read-only.
TagProperty | Identifies the Tag dependency property. This field is read-only.
TargetTypeProperty | Identifies the TargetType dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
ValuePropertyEditorProperty | Identifies the ValuePropertyEditor dependency property. This field is read-only.
ValueTemplateKeyProperty | Identifies the ValueTemplateKey dependency property. This field is read-only.
ValueTemplateKindProperty | Identifies the ValueTemplateKind dependency property. This field is read-only.
ValueTemplateProperty | Identifies the ValueTemplate dependency property. This field is read-only.
ValueTemplateSelectorProperty | Identifies the ValueTemplateSelector dependency property. This field is read-only.
ValueTypeProperty | Identifies the ValueType dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel Constructor

Initializes a new instance of the PropertyModel class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModel()
Public Sub New
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel Properties

The PropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Public property | CanResetValue | Gets or sets whether the property can be reset to its default value.
Public property | Category | Gets or sets a category for the property.
Public property | Children | Gets the collection of child data models.
Public property | Converter | Gets or sets the TypeConverter to use for the property.
Public property | DefaultValue | Gets or sets the default value to use for a reset operation.
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Public property | IsLimitedToStandardValues | Gets or sets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets or sets whether the data model has been modified.
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Protected property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Public property | Name | Gets or sets the name of the data model.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets the parent data model.
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Public property | SortImportance | Gets or sets a DataModelSortImportance that indicates the sort importance of this data model.
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | StandardValues | Gets or sets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets or sets the standard list of values for the ValueAsString property as a list of strings.
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true.
Public property | Tag | Gets or sets custom data for the data model.
Public property | Target | Gets the target object that owns the property.
Public property | TargetType | Gets or sets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value.
Public property | ValueType | Gets or sets the Type of the Value property.
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.AddChildCommand Property

PropertyModelAddChildCommand Property

Gets the ICommand used to add a new child into to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand AddChildCommand { get; }
Public ReadOnly Property AddChildCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to add a new child into to an associated collection/parent.

Implements

IPropertyModelAddChildCommand
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.CanAddChild Property

PropertyModelCanAddChild Property

Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanAddChild { get; }
Public Overridable ReadOnly Property CanAddChild As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.

Implements

IPropertyModelCanAddChild
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.CanAutoDispose Property

PropertyModelCanAutoDispose Property

Gets whether the data model should be automatically disposed when it is removed from a parent data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanAutoDispose { get; }
Public ReadOnly Property CanAutoDispose As Boolean
    Get

Property Value

Type: Boolean
true if the data model should be automatically disposed when it is removed from a parent data model; otherwise, false.

Implements

IDataModelCanAutoDispose
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.CanRemove Property

PropertyModelCanRemove Property

Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CanRemove { get; }
Public Overridable ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.

Implements

IPropertyModelCanRemove
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.CanResetValue Property

PropertyModelCanResetValue Property

Gets or sets whether the property can be reset to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool CanResetValue { get; set; }
Public Property CanResetValue As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false. The default value is false.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Category Property

PropertyModelCategory Property

Gets or sets a category for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set

Property Value

Type: String
A category for the property.

Implements

IPropertyModelCategory
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Children Property

PropertyModelChildren Property

Gets the collection of child data models.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataModelCollection Children { get; }
Public ReadOnly Property Children As DataModelCollection
    Get

Property Value

Type: DataModelCollection
The collection of child data models.

Implements

IDataModelChildren
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Converter Property

PropertyModelConverter Property

Gets or sets the TypeConverter to use for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TypeConverter Converter { get; set; }
Public Property Converter As TypeConverter
    Get
    Set

Property Value

Type: TypeConverter
The TypeConverter to use for the property.

Implements

IPropertyModelConverter
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.DefaultValue Property

PropertyModelDefaultValue Property

Gets or sets the default value to use for a reset operation.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object DefaultValue { get; set; }
Public Property DefaultValue As Object
    Get
    Set

Property Value

Type: Object
The default value to use for a reset operation.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Description Property

PropertyModelDescription Property

Gets or sets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.

Implements

IDataModelDescription
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.DisplayName Property

PropertyModelDisplayName Property

Gets or sets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.

Implements

IDataModelDisplayName
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.HasStandardValues Property

PropertyModelHasStandardValues Property

Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool HasStandardValues { get; }
Public Overridable ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.

Implements

IPropertyModelHasStandardValues
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsExpanded Property

PropertyModelIsExpanded Property

Gets or sets whether the data model is expanded.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsExpanded { get; set; }
Public Property IsExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is expanded; otherwise, false.

Implements

IDataModelIsExpanded
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsHostReadOnly Property

PropertyModelIsHostReadOnly Property

Gets or sets whether the host UI control (e.g. a property grid) is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsHostReadOnly { get; set; }
Public Property IsHostReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the host UI control (e.g. a property grid) is read-only; otherwise, false.

Implements

IPropertyModelIsHostReadOnly
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsImmutable Property

PropertyModelIsImmutable Property

Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsImmutable { get; set; }
Public Property IsImmutable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.

Implements

IPropertyModelIsImmutable
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsLimitedToStandardValues Property

PropertyModelIsLimitedToStandardValues Property

Gets or sets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsLimitedToStandardValues { get; set; }
Public Property IsLimitedToStandardValues As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.

Implements

IPropertyModelIsLimitedToStandardValues
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsMergeable Property

PropertyModelIsMergeable Property

Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool IsMergeable { get; }
Public Overridable ReadOnly Property IsMergeable As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.

Implements

IPropertyModelIsMergeable
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsModified Property

PropertyModelIsModified Property

Gets or sets whether the data model has been modified.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsModified { get; set; }
Public Property IsModified As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.

Implements

IDataModelIsModified
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsReadOnly Property

PropertyModelIsReadOnly Property

Gets whether UI for editing the property value is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the UI for editing the property value is read-only; otherwise, false.

Implements

IPropertyModelIsReadOnly
Remarks
This property is a resolved value of IsHostReadOnly and IsValueReadOnly, and also considers whether a parent property is immutable.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsRoot Property

PropertyModelIsRoot Property

Gets whether the data model is the root.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool IsRoot { get; }
Protected Overridable ReadOnly Property IsRoot As Boolean
    Get

Property Value

Type: Boolean
true if the data model is the root; otherwise, false.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsSelected Property

PropertyModelIsSelected Property

Gets or sets whether the data model is selected.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is selected; otherwise, false.

Implements

IDataModelIsSelected
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsValueReadOnly Property

PropertyModelIsValueReadOnly Property

Gets or sets whether the Value property is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsValueReadOnly { get; set; }
Public Property IsValueReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.

Implements

IPropertyModelIsValueReadOnly
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Name Property

PropertyModelName Property

Gets or sets the name of the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the data model.

Implements

IDataModelName
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NamePropertyEditor Property

PropertyModelNamePropertyEditor Property

Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditor NamePropertyEditor { get; set; }
Public Property NamePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.

Implements

IPropertyModelNamePropertyEditor
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplate Property

PropertyModelNameTemplate Property

Gets or sets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate NameTemplate { get; set; }
Public Property NameTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.

Implements

IPropertyModelNameTemplate
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateKey Property

PropertyModelNameTemplateKey Property

Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object NameTemplateKey { get; set; }
Public Property NameTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.

Implements

IPropertyModelNameTemplateKey
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateSelector Property

PropertyModelNameTemplateSelector Property

Gets or sets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector NameTemplateSelector { get; set; }
Public Property NameTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.

Implements

IPropertyModelNameTemplateSelector
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Parent Property

PropertyModelParent Property

Gets the parent data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IDataModel Parent { get; }
Public ReadOnly Property Parent As IDataModel
    Get

Property Value

Type: IDataModel
The parent data model.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.RemoveCommand Property

PropertyModelRemoveCommand Property

Gets the ICommand used to remove the property from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand RemoveCommand { get; }
Public ReadOnly Property RemoveCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to remove the property from an associated collection/parent.

Implements

IPropertyModelRemoveCommand
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ResetValueCommand Property

PropertyModelResetValueCommand Property

Gets the ICommand used to reset the property value to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ResetValueCommand { get; }
Public ReadOnly Property ResetValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to reset the property value to its default value.

Implements

IPropertyModelResetValueCommand
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ShouldNotifyParentOnValueChange Property

PropertyModelShouldNotifyParentOnValueChange Property

Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool ShouldNotifyParentOnValueChange { get; }
Public Overridable ReadOnly Property ShouldNotifyParentOnValueChange As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.

Implements

IPropertyModelShouldNotifyParentOnValueChange
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.SortComparer Property

PropertyModelSortComparer Property

Gets or sets the DataModelSortComparer to use for sorting this data model's children.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataModelSortComparer SortComparer { get; set; }
Public Property SortComparer As DataModelSortComparer
    Get
    Set

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting this data model's children.

Implements

IDataModelSortComparer
Remarks
If this property doesn't return anything, the default SortComparer will be used.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.SortImportance Property

PropertyModelSortImportance Property

Gets or sets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataModelSortImportance SortImportance { get; set; }
Public Overridable Property SortImportance As DataModelSortImportance
    Get
    Set

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.

Implements

IDataModelSortImportance
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.SortOrder Property

PropertyModelSortOrder Property

Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int SortOrder { get; set; }
Public Property SortOrder As Integer
    Get
    Set

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.

Implements

IDataModelSortOrder
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValues Property

PropertyModelStandardValues Property

Gets or sets the standard list of values for the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable StandardValues { get; set; }
Public Property StandardValues As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
The standard list of values for the Value property.

Implements

IPropertyModelStandardValues
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValuesAsStrings Property

PropertyModelStandardValuesAsStrings Property

Gets or sets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<string> StandardValuesAsStrings { get; set; }
Public Property StandardValuesAsStrings As IEnumerable(Of String)
    Get
    Set

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.

Implements

IPropertyModelStandardValuesAsStrings
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValuesDisplayMemberPath Property

PropertyModelStandardValuesDisplayMemberPath Property

Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string StandardValuesDisplayMemberPath { get; set; }
Public Property StandardValuesDisplayMemberPath As String
    Get
    Set

Property Value

Type: String
The display member path for StandardValues when IsLimitedToStandardValues is true.

Implements

IPropertyModelStandardValuesDisplayMemberPath
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Tag Property

PropertyModelTag Property

Gets or sets custom data for the data model.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
The custom data for the data model.

Implements

IDataModelTag
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Target Property

PropertyModelTarget Property

Gets the target object that owns the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Object Target { get; }
Public Overridable ReadOnly Property Target As Object
    Get

Property Value

Type: Object
The target object that owns the property.

Implements

IPropertyModelTarget
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.TargetType Property

PropertyModelTargetType Property

Gets or sets the Type of the Target property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type TargetType { get; set; }
Public Property TargetType As Type
    Get
    Set

Property Value

Type: Type
The Type of the Target property.

Implements

IPropertyModelTargetType
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Value Property

PropertyModelValue Property

Gets or sets the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

Property Value

Type: Object
The property value.

Implements

IPropertyModelValue
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueAsString Property

PropertyModelValueAsString Property

Gets or sets the property value in a string representation.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ValueAsString { get; set; }
Public Property ValueAsString As String
    Get
    Set

Property Value

Type: String
The property value in a string representation.

Implements

IPropertyModelValueAsString
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValuePropertyEditor Property

PropertyModelValuePropertyEditor Property

Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditor ValuePropertyEditor { get; set; }
Public Property ValuePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.

Implements

IPropertyModelValuePropertyEditor
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Values Property

PropertyModelValues Property

Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual IList<Object> Values { get; }
Public Overridable ReadOnly Property Values As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.

Implements

IPropertyModelValues
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplate Property

PropertyModelValueTemplate Property

Gets or sets the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ValueTemplate { get; set; }
Public Property ValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplate
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateKey Property

PropertyModelValueTemplateKey Property

Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object ValueTemplateKey { get; set; }
Public Property ValueTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplateKey
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateKind Property

PropertyModelValueTemplateKind Property

Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DefaultValueTemplateKind ValueTemplateKind { get; set; }
Public Property ValueTemplateKind As DefaultValueTemplateKind
    Get
    Set

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Implements

IPropertyModelValueTemplateKind
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateSelector Property

PropertyModelValueTemplateSelector Property

Gets or sets the DataTemplateSelector to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector ValueTemplateSelector { get; set; }
Public Property ValueTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplateSelector
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueType Property

PropertyModelValueType Property

Gets or sets the Type of the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type ValueType { get; set; }
Public Property ValueType As Type
    Get
    Set

Property Value

Type: Type
The Type of the Value property.

Implements

IPropertyModelValueType
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel Methods

The PropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ConvertFromString | Converts the specified value from a string.
Protected method | ConvertToString | Converts the specified value to a string.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties.
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid.
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid.
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid.
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid.
Public method | Refresh | Refreshes the property based on the specified reason.
Protected method | RefreshChildren | Refreshes the contents of the Children property.
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.AddChild Method

PropertyModelAddChild Method

Adds a new child into to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void AddChild()
Public Overridable Sub AddChild

Implements

IPropertyModelAddChild
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ConvertFromString Method

PropertyModelConvertFromString Method

Converts the specified value from a string.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Object ConvertFromString(
    string stringValue
)
Protected Overridable Function ConvertFromString (
    stringValue As String
) As Object

Parameters

stringValue
Type: SystemString
The string value to convert.

Return Value

Type: Object
An object from the string representation, or .
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ConvertToString Method

PropertyModelConvertToString Method

Converts the specified value to a string.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string ConvertToString(
    Object value
)
Protected Overridable Function ConvertToString (
    value As Object
) As String

Parameters

value
Type: SystemObject
The value to convert.

Return Value

Type: String
A string representation of the specified value, or .
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.CycleToNextStandardValue Method

PropertyModelCycleToNextStandardValue Method

Cycles the property value to the next standard value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CycleToNextStandardValue()
Public Overridable Function CycleToNextStandardValue As Boolean

Return Value

Type: Boolean
true if a standard value was set; otherwise, false.

Implements

IPropertyModelCycleToNextStandardValue
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Dispose Method

PropertyModelDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Dispose Method

PropertyModelDispose Method

Releases all resources used by the object.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose
See Also

Reference

PropertyModel Class
Dispose Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Dispose Method (Boolean)

PropertyModelDispose Method (Boolean)

Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

PropertyModel Class
Dispose Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.GetErrorMessages Method

PropertyModelGetErrorMessages Method

Returns the error messages for the target object or one of its properties.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IEnumerable GetErrorMessages(
    string columnName
)
Protected Overridable Function GetErrorMessages (
    columnName As String
) As IEnumerable

Parameters

columnName
Type: SystemString
The name of the property to examine, or if the target object itself should be examined.

Return Value

Type: IEnumerable
The error messages that are applicable, if any.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NotifyPropertyChanged Method

PropertyModelNotifyPropertyChanged Method

Notifies that a property has changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.OnPropertyChanged Method

PropertyModelOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.RaiseChildPropertyAddedEvent Method

PropertyModelRaiseChildPropertyAddedEvent Method

Raises a collection item property added event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyAddedEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyAddedEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.RaiseChildPropertyAddingEvent Method

PropertyModelRaiseChildPropertyAddingEvent Method

Raises a collection item property adding event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyAddingEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyAddingEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.RaiseChildPropertyRemovedEvent Method

PropertyModelRaiseChildPropertyRemovedEvent Method

Raises a collection item property removed event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyRemovedEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyRemovedEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.RaiseChildPropertyRemovingEvent Method

PropertyModelRaiseChildPropertyRemovingEvent Method

Raises a collection item property removing event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyRemovingEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyRemovingEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.RaisePropertyValueChangedEvent Method

PropertyModelRaisePropertyValueChangedEvent Method

Raises a property value changed event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaisePropertyValueChangedEvent(
    PropertyModelValueChangeEventArgs e
)
Protected Sub RaisePropertyValueChangedEvent (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.RaisePropertyValueChangingEvent Method

PropertyModelRaisePropertyValueChangingEvent Method

Raises a property value changing event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaisePropertyValueChangingEvent(
    PropertyModelValueChangeEventArgs e
)
Protected Sub RaisePropertyValueChangingEvent (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Refresh Method

PropertyModelRefresh Method

Refreshes the property based on the specified reason.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Refresh(
    PropertyRefreshReason reason
)
Public Overridable Sub Refresh (
    reason As PropertyRefreshReason
)

Parameters

reason
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyRefreshReason
The reason the property needs to be refreshed.

Implements

IPropertyModelRefresh(PropertyRefreshReason)
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.RefreshChildren Method

PropertyModelRefreshChildren Method

Refreshes the contents of the Children property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void RefreshChildren()
Protected Overridable Sub RefreshChildren
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.Remove Method

PropertyModelRemove Method

Removes the property from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Remove()
Public Overridable Sub Remove

Implements

IPropertyModelRemove
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ResetValue Method

PropertyModelResetValue Method

Resets the property value to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void ResetValue()
Public Overridable Sub ResetValue

Implements

IPropertyModelResetValue
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ToString Method

PropertyModelToString Method

Returns a String representation of this instance.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String representation of this instance.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel Events

The PropertyModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.PropertyChanged Event

PropertyModelPropertyChanged Event

Occurs when a property has been changed.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel Fields

The PropertyModel type exposes the following members.

Fields
Name | Description
CanResetValueProperty | Identifies the CanResetValue dependency property. This field is read-only.
CategoryProperty | Identifies the Category dependency property. This field is read-only.
ConverterProperty | Identifies the Converter dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
DisplayNameProperty | Identifies the DisplayName dependency property. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
IsHostReadOnlyProperty | Identifies the IsHostReadOnly dependency property. This field is read-only.
IsImmutableProperty | Identifies the IsImmutable dependency property. This field is read-only.
IsLimitedToStandardValuesProperty | Identifies the IsLimitedToStandardValues dependency property. This field is read-only.
IsModifiedProperty | Identifies the IsModified dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
IsValueReadOnlyProperty | Identifies the IsValueReadOnly dependency property. This field is read-only.
NameProperty | Identifies the Name dependency property. This field is read-only.
NamePropertyEditorProperty | Identifies the NamePropertyEditor dependency property. This field is read-only.
NameTemplateKeyProperty | Identifies the NameTemplateKey dependency property. This field is read-only.
NameTemplateProperty | Identifies the NameTemplate dependency property. This field is read-only.
NameTemplateSelectorProperty | Identifies the NameTemplateSelector dependency property. This field is read-only.
SortComparerProperty | Identifies the SortComparer dependency property. This field is read-only.
SortImportanceProperty | Identifies the SortImportance dependency property. This field is read-only.
SortOrderProperty | Identifies the SortOrder dependency property. This field is read-only.
StandardValuesAsStringsProperty | Identifies the StandardValuesAsStrings dependency property. This field is read-only.
StandardValuesDisplayMemberPathProperty | Identifies the StandardValuesDisplayMemberPath dependency property. This field is read-only.
StandardValuesProperty | Identifies the StandardValues dependency property. This field is read-only.
TagProperty | Identifies the Tag dependency property. This field is read-only.
TargetTypeProperty | Identifies the TargetType dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
ValuePropertyEditorProperty | Identifies the ValuePropertyEditor dependency property. This field is read-only.
ValueTemplateKeyProperty | Identifies the ValueTemplateKey dependency property. This field is read-only.
ValueTemplateKindProperty | Identifies the ValueTemplateKind dependency property. This field is read-only.
ValueTemplateProperty | Identifies the ValueTemplate dependency property. This field is read-only.
ValueTemplateSelectorProperty | Identifies the ValueTemplateSelector dependency property. This field is read-only.
ValueTypeProperty | Identifies the ValueType dependency property. This field is read-only.
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.CanResetValueProperty Field

PropertyModelCanResetValueProperty Field

Identifies the CanResetValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanResetValueProperty
Public Shared ReadOnly CanResetValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanResetValue dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.CategoryProperty Field

PropertyModelCategoryProperty Field

Identifies the Category dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CategoryProperty
Public Shared ReadOnly CategoryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Category dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ConverterProperty Field

PropertyModelConverterProperty Field

Identifies the Converter dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ConverterProperty
Public Shared ReadOnly ConverterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Converter dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.DefaultValueProperty Field

PropertyModelDefaultValueProperty Field

Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.DescriptionProperty Field

PropertyModelDescriptionProperty Field

Identifies the Description dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DescriptionProperty
Public Shared ReadOnly DescriptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Description dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.DisplayNameProperty Field

PropertyModelDisplayNameProperty Field

Identifies the DisplayName dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayNameProperty
Public Shared ReadOnly DisplayNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayName dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsExpandedProperty Field

PropertyModelIsExpandedProperty Field

Identifies the IsExpanded dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsExpandedProperty
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsExpanded dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsHostReadOnlyProperty Field

PropertyModelIsHostReadOnlyProperty Field

Identifies the IsHostReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHostReadOnlyProperty
Public Shared ReadOnly IsHostReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHostReadOnly dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsImmutableProperty Field

PropertyModelIsImmutableProperty Field

Identifies the IsImmutable dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsImmutableProperty
Public Shared ReadOnly IsImmutableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsImmutable dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsLimitedToStandardValuesProperty Field

PropertyModelIsLimitedToStandardValuesProperty Field

Identifies the IsLimitedToStandardValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLimitedToStandardValuesProperty
Public Shared ReadOnly IsLimitedToStandardValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLimitedToStandardValues dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsModifiedProperty Field

PropertyModelIsModifiedProperty Field

Identifies the IsModified dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsModifiedProperty
Public Shared ReadOnly IsModifiedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsModified dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsReadOnlyProperty Field

PropertyModelIsReadOnlyProperty Field

Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsSelectedProperty Field

PropertyModelIsSelectedProperty Field

Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.IsValueReadOnlyProperty Field

PropertyModelIsValueReadOnlyProperty Field

Identifies the IsValueReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsValueReadOnlyProperty
Public Shared ReadOnly IsValueReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsValueReadOnly dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NameProperty Field

PropertyModelNameProperty Field

Identifies the Name dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameProperty
Public Shared ReadOnly NameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Name dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NamePropertyEditorProperty Field

PropertyModelNamePropertyEditorProperty Field

Identifies the NamePropertyEditor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NamePropertyEditorProperty
Public Shared ReadOnly NamePropertyEditorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NamePropertyEditor dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateKeyProperty Field

PropertyModelNameTemplateKeyProperty Field

Identifies the NameTemplateKey dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateKeyProperty
Public Shared ReadOnly NameTemplateKeyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplateKey dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateProperty Field

PropertyModelNameTemplateProperty Field

Identifies the NameTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateProperty
Public Shared ReadOnly NameTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplate dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateSelectorProperty Field

PropertyModelNameTemplateSelectorProperty Field

Identifies the NameTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateSelectorProperty
Public Shared ReadOnly NameTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplateSelector dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.SortComparerProperty Field

PropertyModelSortComparerProperty Field

Identifies the SortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortComparerProperty
Public Shared ReadOnly SortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortComparer dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.SortImportanceProperty Field

PropertyModelSortImportanceProperty Field

Identifies the SortImportance dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortImportanceProperty
Public Shared ReadOnly SortImportanceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortImportance dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.SortOrderProperty Field

PropertyModelSortOrderProperty Field

Identifies the SortOrder dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortOrderProperty
Public Shared ReadOnly SortOrderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortOrder dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValuesAsStringsProperty Field

PropertyModelStandardValuesAsStringsProperty Field

Identifies the StandardValuesAsStrings dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardValuesAsStringsProperty
Public Shared ReadOnly StandardValuesAsStringsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardValuesAsStrings dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValuesDisplayMemberPathProperty Field

PropertyModelStandardValuesDisplayMemberPathProperty Field

Identifies the StandardValuesDisplayMemberPath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardValuesDisplayMemberPathProperty
Public Shared ReadOnly StandardValuesDisplayMemberPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardValuesDisplayMemberPath dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValuesProperty Field

PropertyModelStandardValuesProperty Field

Identifies the StandardValues dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardValuesProperty
Public Shared ReadOnly StandardValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardValues dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.TagProperty Field

PropertyModelTagProperty Field

Identifies the Tag dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TagProperty
Public Shared ReadOnly TagProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Tag dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.TargetTypeProperty Field

PropertyModelTargetTypeProperty Field

Identifies the TargetType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TargetTypeProperty
Public Shared ReadOnly TargetTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TargetType dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueProperty Field

PropertyModelValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValuePropertyEditorProperty Field

PropertyModelValuePropertyEditorProperty Field

Identifies the ValuePropertyEditor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValuePropertyEditorProperty
Public Shared ReadOnly ValuePropertyEditorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValuePropertyEditor dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateKeyProperty Field

PropertyModelValueTemplateKeyProperty Field

Identifies the ValueTemplateKey dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateKeyProperty
Public Shared ReadOnly ValueTemplateKeyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplateKey dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateKindProperty Field

PropertyModelValueTemplateKindProperty Field

Identifies the ValueTemplateKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateKindProperty
Public Shared ReadOnly ValueTemplateKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplateKind dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateProperty Field

PropertyModelValueTemplateProperty Field

Identifies the ValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateProperty
Public Shared ReadOnly ValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplate dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateSelectorProperty Field

PropertyModelValueTemplateSelectorProperty Field

Identifies the ValueTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateSelectorProperty
Public Shared ReadOnly ValueTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplateSelector dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTypeProperty Field

PropertyModelValueTypeProperty Field

Identifies the ValueType dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTypeProperty
Public Shared ReadOnly ValueTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueType dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase Class

Provides an abstract base class for a property grid IDataModel that can provide the foundation for an IPropertyModel implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataCachedPropertyModelBase

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class PropertyModelBase : DataModelBase,
    IDataErrorInfo
Public MustInherit Class PropertyModelBase
    Inherits DataModelBase
    Implements IDataErrorInfo

The PropertyModelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PropertyModelBase | Initializes a new instance of the PropertyModelBase class
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent.
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from DataModelBase.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from DataModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited.
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from DataModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from DataModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from DataModelBase.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from DataModelBase.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true.
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property.
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Protected property | TargetResolved | Gets the resolved target object that owns the property.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Protected property | ValueResolved | Gets or sets the resolved property value.
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property.
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Protected method | ConvertFromString | Converts the specified value from a string.
Protected method | ConvertToString | Converts the specified value to a string.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties.
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides ObservableObjectBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid.
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid.
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid.
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid.
Public method | Refresh | Refreshes the property based on the specified reason.
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase Constructor

Initializes a new instance of the PropertyModelBase class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected PropertyModelBase()
Protected Sub New
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase Properties

The PropertyModelBase type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent.
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from DataModelBase.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from DataModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited.
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from DataModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from DataModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from DataModelBase.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from DataModelBase.)
Public property | StandardValuesDisplayMemberPath | Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true.
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property.
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Protected property | TargetResolved | Gets the resolved target object that owns the property.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Protected property | ValueResolved | Gets or sets the resolved property value.
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property.
Top
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.AddChildCommand Property

PropertyModelBaseAddChildCommand Property

Gets the ICommand used to add a new child into to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand AddChildCommand { get; }
Public ReadOnly Property AddChildCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to add a new child into to an associated collection/parent.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.CanAddChildResolved Property

PropertyModelBaseCanAddChildResolved Property

Gets the resolved value for whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool CanAddChildResolved { get; }
Protected MustOverride ReadOnly Property CanAddChildResolved As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.CanRemoveResolved Property

PropertyModelBaseCanRemoveResolved Property

Gets the resolved value for whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool CanRemoveResolved { get; }
Protected MustOverride ReadOnly Property CanRemoveResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.CanResetValueResolved Property

PropertyModelBaseCanResetValueResolved Property

Gets the resolved value for whether the property can be reset to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool CanResetValueResolved { get; }
Protected MustOverride ReadOnly Property CanResetValueResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.ConverterResolved Property

PropertyModelBaseConverterResolved Property

Gets the resolved TypeConverter to use for the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract TypeConverter ConverterResolved { get; }
Protected MustOverride ReadOnly Property ConverterResolved As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.HasStandardValues Property

PropertyModelBaseHasStandardValues Property

Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool HasStandardValues { get; }
Public Overridable ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.IsHostReadOnly Property

PropertyModelBaseIsHostReadOnly Property

Gets or sets whether the host UI control (e.g. a property grid) is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsHostReadOnly { get; set; }
Public Property IsHostReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the host UI control (e.g. a property grid) is read-only; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.IsImmutableResolved Property

PropertyModelBaseIsImmutableResolved Property

Gets the resolved value for whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool IsImmutableResolved { get; }
Protected MustOverride ReadOnly Property IsImmutableResolved As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.IsReadOnly Property

PropertyModelBaseIsReadOnly Property

Gets whether UI for editing the property value is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the UI for editing the property value is read-only; otherwise, false.
Remarks
This property is a resolved value of IsHostReadOnly and IsValueReadOnly, and also considers whether a parent property is immutable.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.IsValueReadOnlyResolved Property

PropertyModelBaseIsValueReadOnlyResolved Property

Gets the resolved value for whether the Value property is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool IsValueReadOnlyResolved { get; }
Protected MustOverride ReadOnly Property IsValueReadOnlyResolved As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.NamePropertyEditor Property

PropertyModelBaseNamePropertyEditor Property

Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditor NamePropertyEditor { get; set; }
Public Property NamePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.RemoveCommand Property

PropertyModelBaseRemoveCommand Property

Gets the ICommand used to remove the property from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand RemoveCommand { get; }
Public ReadOnly Property RemoveCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to remove the property from an associated collection/parent.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.ResetValueCommand Property

PropertyModelBaseResetValueCommand Property

Gets the ICommand used to reset the property value to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ResetValueCommand { get; }
Public ReadOnly Property ResetValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to reset the property value to its default value.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.ShouldNotifyParentOnValueChangeResolved Property

PropertyModelBaseShouldNotifyParentOnValueChangeResolved Property

Gets the resolved value for whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract bool ShouldNotifyParentOnValueChangeResolved { get; }
Protected MustOverride ReadOnly Property ShouldNotifyParentOnValueChangeResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.StandardValuesDisplayMemberPath Property

PropertyModelBaseStandardValuesDisplayMemberPath Property

Gets or sets the display member path for StandardValues when IsLimitedToStandardValues is true.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string StandardValuesDisplayMemberPath { get; set; }
Public Property StandardValuesDisplayMemberPath As String
    Get
    Set

Property Value

Type: String
The display member path for StandardValues when IsLimitedToStandardValues is true.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.StandardValuesResolved Property

PropertyModelBaseStandardValuesResolved Property

Gets the resolved standard list of values for the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract IEnumerable StandardValuesResolved { get; }
Protected MustOverride ReadOnly Property StandardValuesResolved As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.TargetResolved Property

PropertyModelBaseTargetResolved Property

Gets the resolved target object that owns the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Object TargetResolved { get; }
Protected MustOverride ReadOnly Property TargetResolved As Object
    Get

Property Value

Type: Object
The target object that owns the property.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.ValuePropertyEditor Property

PropertyModelBaseValuePropertyEditor Property

Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditor ValuePropertyEditor { get; set; }
Public Property ValuePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.ValueResolved Property

PropertyModelBaseValueResolved Property

Gets or sets the resolved property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Object ValueResolved { get; set; }
Protected MustOverride Property ValueResolved As Object
    Get
    Set

Property Value

Type: Object
The property value.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.ValueTypeResolved Property

PropertyModelBaseValueTypeResolved Property

Gets the resolved Type of the Value property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected abstract Type ValueTypeResolved { get; }
Protected MustOverride ReadOnly Property ValueTypeResolved As Type
    Get

Property Value

Type: Type
The Type of the Value property.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase Methods

The PropertyModelBase type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Protected method | ConvertFromString | Converts the specified value from a string.
Protected method | ConvertToString | Converts the specified value to a string.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties.
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides ObservableObjectBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid.
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid.
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid.
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid.
Public method | Refresh | Refreshes the property based on the specified reason.
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.AddChild Method

PropertyModelBaseAddChild Method

Adds a new child into to an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void AddChild()
Public Overridable Sub AddChild
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.ConvertFromString Method

PropertyModelBaseConvertFromString Method

Converts the specified value from a string.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Object ConvertFromString(
    string stringValue
)
Protected Overridable Function ConvertFromString (
    stringValue As String
) As Object

Parameters

stringValue
Type: SystemString
The string value to convert.

Return Value

Type: Object
An object from the string representation, or .
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.ConvertToString Method

PropertyModelBaseConvertToString Method

Converts the specified value to a string.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual string ConvertToString(
    Object value
)
Protected Overridable Function ConvertToString (
    value As Object
) As String

Parameters

value
Type: SystemObject
The value to convert.

Return Value

Type: String
A string representation of the specified value, or .
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.CycleToNextStandardValue Method

PropertyModelBaseCycleToNextStandardValue Method

Cycles the property value to the next standard value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual bool CycleToNextStandardValue()
Public Overridable Function CycleToNextStandardValue As Boolean

Return Value

Type: Boolean
true if a standard value was set; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.GetErrorMessages Method

PropertyModelBaseGetErrorMessages Method

Returns the error messages for the target object or one of its properties.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IEnumerable GetErrorMessages(
    string columnName
)
Protected Overridable Function GetErrorMessages (
    columnName As String
) As IEnumerable

Parameters

columnName
Type: SystemString
The name of the property to examine, or if the target object itself should be examined.

Return Value

Type: IEnumerable
The error messages that are applicable, if any.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.OnPropertyChanged Method

PropertyModelBaseOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaiseChildPropertyAddedEvent Method

PropertyModelBaseRaiseChildPropertyAddedEvent Method

Raises a collection item property added event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyAddedEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyAddedEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaiseChildPropertyAddingEvent Method

PropertyModelBaseRaiseChildPropertyAddingEvent Method

Raises a collection item property adding event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyAddingEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyAddingEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaiseChildPropertyRemovedEvent Method

PropertyModelBaseRaiseChildPropertyRemovedEvent Method

Raises a collection item property removed event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyRemovedEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyRemovedEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaiseChildPropertyRemovingEvent Method

PropertyModelBaseRaiseChildPropertyRemovingEvent Method

Raises a collection item property removing event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyRemovingEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyRemovingEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaisePropertyValueChangedEvent Method

PropertyModelBaseRaisePropertyValueChangedEvent Method

Raises a property value changed event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaisePropertyValueChangedEvent(
    PropertyModelValueChangeEventArgs e
)
Protected Sub RaisePropertyValueChangedEvent (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaisePropertyValueChangingEvent Method

PropertyModelBaseRaisePropertyValueChangingEvent Method

Raises a property value changing event on the PropertyGrid.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void RaisePropertyValueChangingEvent(
    PropertyModelValueChangeEventArgs e
)
Protected Sub RaisePropertyValueChangingEvent (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.Windows.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.Refresh Method

PropertyModelBaseRefresh Method

Refreshes the property based on the specified reason.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Refresh(
    PropertyRefreshReason reason
)
Public Overridable Sub Refresh (
    reason As PropertyRefreshReason
)

Parameters

reason
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyRefreshReason
The reason the property needs to be refreshed.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.Remove Method

PropertyModelBaseRemove Method

Removes the property from an associated collection/parent.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Remove()
Public Overridable Sub Remove
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase.ResetValue Method

PropertyModelBaseResetValue Method

Resets the property value to its default value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void ResetValue()
Public Overridable Sub ResetValue
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBase Events

The PropertyModelBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyModelBase Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Class

Represents a IDataFilter implementation for IPropertyModel boolean properties.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.Data.FilteringDataFilterBase
ActiproSoftware.Windows.Data.FilteringBooleanFilterBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModelBooleanFilter

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyModelBooleanFilter : BooleanFilterBase
Public Class PropertyModelBooleanFilter
    Inherits BooleanFilterBase

The PropertyModelBooleanFilter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelBooleanFilter | Initializes a new instance of the PropertyModelBooleanFilter class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IncludedFilterResult | Gets or sets the DataFilterResult to return when an item meets filter conditions. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the boolean operation performed by this filter. (Inherited from BooleanFilterBase.)
Public property | Source | Gets or sets the IPropertyModel boolean property to examine with this filter.
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from BooleanFilterBase.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object, Object).)
Protected method | FilterByBoolean | Examines the specified boolean to see if meets filter conditions. (Inherited from BooleanFilterBase.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
Fields
Name | Description
SourceProperty | Identifies the Source dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Constructor

Initializes a new instance of the PropertyModelBooleanFilter class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModelBooleanFilter()
Public Sub New
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Properties

The PropertyModelBooleanFilter type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IncludedFilterResult | Gets or sets the DataFilterResult to return when an item meets filter conditions. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the boolean operation performed by this filter. (Inherited from BooleanFilterBase.)
Public property | Source | Gets or sets the IPropertyModel boolean property to examine with this filter.
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from BooleanFilterBase.)
Top
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter.Source Property

PropertyModelBooleanFilterSource Property

Gets or sets the IPropertyModel boolean property to examine with this filter.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModelBooleanFilterSource Source { get; set; }
Public Property Source As PropertyModelBooleanFilterSource
    Get
    Set

Property Value

Type: PropertyModelBooleanFilterSource
The IPropertyModel boolean property to examine with this filter. The default value is PropertyModelBooleanFilterSource.IsReadOnly.
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Methods

The PropertyModelBooleanFilter type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object, Object).)
Protected method | FilterByBoolean | Examines the specified boolean to see if meets filter conditions. (Inherited from BooleanFilterBase.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter.Filter Method

PropertyModelBooleanFilterFilter Method

Examines the specified item to see if meets filter conditions.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override DataFilterResult Filter(
    Object item,
    Object context
)
Public Overrides Function Filter (
    item As Object,
    context As Object
) As DataFilterResult

Parameters

item
Type: SystemObject
The item to examine.
context
Type: SystemObject
An optional object that provides contextual information for the filter request.

Return Value

Type: DataFilterResult
A DataFilterResult that indicates the filter result.

Implements

IDataFilterFilter(Object, Object)
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Events

The PropertyModelBooleanFilter type exposes the following members.

Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Fields

The PropertyModelBooleanFilter type exposes the following members.

Fields
Name | Description
SourceProperty | Identifies the Source dependency property. This field is read-only.
Top
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter.SourceProperty Field

PropertyModelBooleanFilterSourceProperty Field

Identifies the Source dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SourceProperty
Public Shared ReadOnly SourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Source dependency property.
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource Enumeration

Specifies the source IPropertyModel boolean properties that can be used by a PropertyModelBooleanFilter.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PropertyModelBooleanFilterSource
Public Enumeration PropertyModelBooleanFilterSource
Members
Member name | Value | Description
CanResetValue | 0 | The CanResetValue property should be used as the source.
HasStandardValues | 1 | The HasStandardValues property should be used as the source.
IsLimitedToStandardValues | 2 | The IsLimitedToStandardValues property should be used as the source.
IsMergeable | 3 | The IsMergeable property should be used as the source.
IsModified | 4 | The IsModified property should be used as the source.
IsReadOnly | 5 | The IsReadOnly property should be used as the source.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelCollection Class

Represents a collection of IPropertyModel objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IPropertyModel
System.Collections.ObjectModelObservableCollection IPropertyModel
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModelCollection

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyModelCollection : ObservableCollection<IPropertyModel>
Public Class PropertyModelCollection
    Inherits ObservableCollection(Of IPropertyModel)

The PropertyModelCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelCollection | Initializes a new instance of the PropertyModelCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IPropertyModel .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection IPropertyModel .)
Public property | ItemString | Gets the IPropertyModel in this collection that matches the specified name.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IPropertyModel .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IPropertyModel .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection IPropertyModel .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection IPropertyModel .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IPropertyModel .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection IPropertyModel .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IPropertyModel .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IPropertyModel .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IPropertyModel .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IPropertyModel .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IPropertyModel .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection IPropertyModel .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IPropertyModel .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IPropertyModel .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection IPropertyModel .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection IPropertyModel .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IPropertyModel .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IPropertyModel .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection IPropertyModel .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection IPropertyModel .)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection IPropertyModel .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection IPropertyModel .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelCollection Constructor

Initializes a new instance of the PropertyModelCollection class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModelCollection()
Public Sub New
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelCollection Properties

The PropertyModelCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IPropertyModel .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection IPropertyModel .)
Public property | ItemString | Gets the IPropertyModel in this collection that matches the specified name.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IPropertyModel .)
Top
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelCollection.Item Property

PropertyModelCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection IPropertyModel .)
Public property | ItemString | Gets the IPropertyModel in this collection that matches the specified name.
Top
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelCollection.Item Property (String)

PropertyModelCollectionItem Property (String)

Gets the IPropertyModel in this collection that matches the specified name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IPropertyModel this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As IPropertyModel
    Get

Parameters

name
Type: SystemString

Property Value

Type: IPropertyModel
The IPropertyModel in this collection that matches the specified name.
See Also

Reference

PropertyModelCollection Class
Item Overload
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelCollection Methods

The PropertyModelCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IPropertyModel .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection IPropertyModel .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection IPropertyModel .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IPropertyModel .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection IPropertyModel .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IPropertyModel .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IPropertyModel .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IPropertyModel .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IPropertyModel .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IPropertyModel .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection IPropertyModel .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IPropertyModel .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection IPropertyModel .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection IPropertyModel .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection IPropertyModel .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IPropertyModel .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IPropertyModel .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection IPropertyModel .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection IPropertyModel .)
Top
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelCollection Events

The PropertyModelCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection IPropertyModel .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection IPropertyModel .)
Top
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Class

Represents a IDataFilter implementation for IPropertyModel string properties.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.Data.FilteringDataFilterBase
ActiproSoftware.Windows.Data.FilteringStringFilterBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataPropertyModelStringFilter

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyModelStringFilter : StringFilterBase
Public Class PropertyModelStringFilter
    Inherits StringFilterBase

The PropertyModelStringFilter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelStringFilter | Initializes a new instance of the PropertyModelStringFilter class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IncludedFilterResult | Gets or sets the DataFilterResult to return when an item meets filter conditions. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the string operation performed by this filter. (Inherited from StringFilterBase.)
Public property | RegexOptions | Gets or sets the options used for regex matches performed by this filter. (Inherited from StringFilterBase.)
Public property | Source | Gets or sets the IPropertyModel string property to examine with this filter.
Public property | StringComparison | Gets or sets the string comparison performed by this filter. (Inherited from StringFilterBase.)
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from StringFilterBase.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object, Object).)
Protected method | FilterByString | Examines the specified source string to see if it meets filter conditions. (Inherited from StringFilterBase.)
Public method | GetCaptures | Returns the collection of filter match captures. (Inherited from StringFilterBase.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
Fields
Name | Description
SourceProperty | Identifies the Source dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Constructor

Initializes a new instance of the PropertyModelStringFilter class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModelStringFilter()
Public Sub New
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Properties

The PropertyModelStringFilter type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IncludedFilterResult | Gets or sets the DataFilterResult to return when an item meets filter conditions. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the string operation performed by this filter. (Inherited from StringFilterBase.)
Public property | RegexOptions | Gets or sets the options used for regex matches performed by this filter. (Inherited from StringFilterBase.)
Public property | Source | Gets or sets the IPropertyModel string property to examine with this filter.
Public property | StringComparison | Gets or sets the string comparison performed by this filter. (Inherited from StringFilterBase.)
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from StringFilterBase.)
Top
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter.Source Property

PropertyModelStringFilterSource Property

Gets or sets the IPropertyModel string property to examine with this filter.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyModelStringFilterSource Source { get; set; }
Public Property Source As PropertyModelStringFilterSource
    Get
    Set

Property Value

Type: PropertyModelStringFilterSource
The IPropertyModel string property to examine with this filter. The default value is PropertyModelStringFilterSource.DisplayName.
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Methods

The PropertyModelStringFilter type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object, Object).)
Protected method | FilterByString | Examines the specified source string to see if it meets filter conditions. (Inherited from StringFilterBase.)
Public method | GetCaptures | Returns the collection of filter match captures. (Inherited from StringFilterBase.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter.Filter Method

PropertyModelStringFilterFilter Method

Examines the specified item to see if meets filter conditions.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override DataFilterResult Filter(
    Object item,
    Object context
)
Public Overrides Function Filter (
    item As Object,
    context As Object
) As DataFilterResult

Parameters

item
Type: SystemObject
The item to examine.
context
Type: SystemObject
An optional object that provides contextual information for the filter request.

Return Value

Type: DataFilterResult
A DataFilterResult that indicates the filter result.

Implements

IDataFilterFilter(Object, Object)
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Events

The PropertyModelStringFilter type exposes the following members.

Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Fields

The PropertyModelStringFilter type exposes the following members.

Fields
Name | Description
SourceProperty | Identifies the Source dependency property. This field is read-only.
Top
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter.SourceProperty Field

PropertyModelStringFilterSourceProperty Field

Identifies the Source dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SourceProperty
Public Shared ReadOnly SourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Source dependency property.
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource Enumeration

Specifies the source IPropertyModel string properties that can be used by a PropertyModelStringFilter.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PropertyModelStringFilterSource
Public Enumeration PropertyModelStringFilterSource
Members
Member name | Value | Description
Category | 0 | The Category property should be used as the source.
Description | 1 | The Description property should be used as the source.
DisplayName | 2 | The DisplayName property should be used as the source.
Name | 3 | The Name property should be used as the source.
ValueType | 4 | The ValueType property should be used as the source.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


PropertyRefreshReason Enumeration

Specifies the reason a property is being refreshed.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum PropertyRefreshReason
Public Enumeration PropertyRefreshReason
Members
Member name | Value | Description
ValueChanged | 0 | Indicates that the property's value has changed.
ChildPropertyValueChanged | 1 | Indicates that a child property's value has changed.
CollectionItemAdded | 2 | Indicates that an item was added to the property's collection value.
CollectionItemRemoved | 3 | Indicates that an item was removed from the property's collection value.
StandardValuesChanged | 4 | Indicates that the standard values have changed.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


TypeDescriptorFactory Class

Implements an IDataFactory that uses type descriptors to return data models.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.Grids.PropertyDataDataFactoryBase
ActiproSoftware.Windows.Controls.Grids.PropertyDataTypeDescriptorFactory

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class TypeDescriptorFactory : DataFactoryBase
Public Class TypeDescriptorFactory
    Inherits DataFactoryBase

The TypeDescriptorFactory type exposes the following members.

Constructors
 | Name | Description
Public method | TypeDescriptorFactory | Initializes a new instance of the TypeDescriptorFactory class
Top
Methods
 | Name | Description
Protected method | CategorizeDataModels | Returns a categorized variation of the specified data models collection. (Inherited from DataFactoryBase.)
Protected method | CreateCategoryEditorModel | Creates an ICategoryEditorModel for the specified CategoryEditor. (Inherited from DataFactoryBase.)
Protected method | CreateCategoryModel | Creates an ICategoryModel for the specified category name. (Inherited from DataFactoryBase.)
Protected method | CreateCollectionPropertyModel | Creates an IPropertyModel for the specified collection data object.
Protected method | CreateMergedPropertyModel | Creates an IPropertyModel that merges a common property from multiple data objects. (Inherited from DataFactoryBase.)
Protected method | CreatePropertyModel | Creates an IPropertyModel for the specified mutable data object.
Public method | GetDataModels | Returns the IDataModel collection for the requested object values. (Inherited from DataFactoryBase.)
Protected method | GetPropertyModels | Returns the IPropertyModel collection for the specified data object. (Overrides DataFactoryBaseGetPropertyModels(Object, IDataFactoryRequest).)
Protected method | SortDataModels | Returns a sorted variation of the specified data models collection. (Inherited from DataFactoryBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


TypeDescriptorFactory Constructor

Initializes a new instance of the TypeDescriptorFactory class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public TypeDescriptorFactory()
Public Sub New
See Also

Reference

TypeDescriptorFactory Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


TypeDescriptorFactory Methods

The TypeDescriptorFactory type exposes the following members.

Methods
 | Name | Description
Protected method | CategorizeDataModels | Returns a categorized variation of the specified data models collection. (Inherited from DataFactoryBase.)
Protected method | CreateCategoryEditorModel | Creates an ICategoryEditorModel for the specified CategoryEditor. (Inherited from DataFactoryBase.)
Protected method | CreateCategoryModel | Creates an ICategoryModel for the specified category name. (Inherited from DataFactoryBase.)
Protected method | CreateCollectionPropertyModel | Creates an IPropertyModel for the specified collection data object.
Protected method | CreateMergedPropertyModel | Creates an IPropertyModel that merges a common property from multiple data objects. (Inherited from DataFactoryBase.)
Protected method | CreatePropertyModel | Creates an IPropertyModel for the specified mutable data object.
Public method | GetDataModels | Returns the IDataModel collection for the requested object values. (Inherited from DataFactoryBase.)
Protected method | GetPropertyModels | Returns the IPropertyModel collection for the specified data object. (Overrides DataFactoryBaseGetPropertyModels(Object, IDataFactoryRequest).)
Protected method | SortDataModels | Returns a sorted variation of the specified data models collection. (Inherited from DataFactoryBase.)
Top
See Also

Reference

TypeDescriptorFactory Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


TypeDescriptorFactory.CreateCollectionPropertyModel Method

TypeDescriptorFactoryCreateCollectionPropertyModel Method

Creates an IPropertyModel for the specified collection data object.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IPropertyModel CreateCollectionPropertyModel(
    Object target,
    PropertyDescriptor propertyDescriptor,
    IDataFactoryRequest request
)
Protected Overridable Function CreateCollectionPropertyModel (
    target As Object,
    propertyDescriptor As PropertyDescriptor,
    request As IDataFactoryRequest
) As IPropertyModel

Parameters

target
Type: SystemObject
The target object that owns the property.
propertyDescriptor
Type: System.ComponentModelPropertyDescriptor
The PropertyDescriptor for the property be accessed on the target.
request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IPropertyModel
The IPropertyModel that was created.
See Also

Reference

TypeDescriptorFactory Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


TypeDescriptorFactory.CreatePropertyModel Method

TypeDescriptorFactoryCreatePropertyModel Method

Creates an IPropertyModel for the specified mutable data object.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual IPropertyModel CreatePropertyModel(
    Object target,
    PropertyDescriptor propertyDescriptor,
    IDataFactoryRequest request
)
Protected Overridable Function CreatePropertyModel (
    target As Object,
    propertyDescriptor As PropertyDescriptor,
    request As IDataFactoryRequest
) As IPropertyModel

Parameters

target
Type: SystemObject
The target object that owns the property.
propertyDescriptor
Type: System.ComponentModelPropertyDescriptor
The PropertyDescriptor for the property be accessed on the target.
request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IPropertyModel
The IPropertyModel that was created.
See Also

Reference

TypeDescriptorFactory Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


TypeDescriptorFactory.GetPropertyModels Method

TypeDescriptorFactoryGetPropertyModels Method

Returns the IPropertyModel collection for the specified data object.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyData
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IList<IPropertyModel> GetPropertyModels(
    Object dataObject,
    IDataFactoryRequest request
)
Protected Overrides Function GetPropertyModels (
    dataObject As Object,
    request As IDataFactoryRequest
) As IList(Of IPropertyModel)

Parameters

dataObject
Type: SystemObject
The single object to examine.
request
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IPropertyModel
A collection of IPropertyModel objects, if the specified data object has any properties.
See Also

Reference

TypeDescriptorFactory Class
ActiproSoftware.Windows.Controls.Grids.PropertyData Namespace


ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace

Contains the classes used for PropertyGrid property editors.
Classes
 | Class | Description
Public class | BooleanPropertyEditor | Represents a PropertyEditor for editing a Boolean value with a two-state CheckBox.
Public class | BrushPropertyEditor | Represents a PropertyEditor for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
Public class | CategoryEditor | Provides information for an editor that can consume and display one or more properties in a property grid.
Public class | CategoryEditorCollection | Represents a collection of CategoryEditor objects.
Public class | CategoryEditorProperty | Provides information about a property to be consumed by a CategoryEditor.
Public class | CategoryEditorPropertyCollection | Represents a collection of CategoryEditorProperty objects.
Public class | ColorPropertyEditor | Represents a PropertyEditor for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
Public class | ExtendedStringPropertyEditor | Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
Public class | FontFamilyPropertyEditor | Represents a PropertyEditor for editing a FontFamily value with a ComboBox that contains system font families.
Public class | FontStretchPropertyEditor | Represents a PropertyEditor for editing a FontStretch value with a ComboBox that contains font stretch options.
Public class | FontStylePropertyEditor | Represents a PropertyEditor for editing a FontStyle value with a ComboBox that contains font style options.
Public class | FontWeightPropertyEditor | Represents a PropertyEditor for editing a FontWeight value with a ComboBox that contains font weight options.
Public class | LimitedObjectPropertyEditor | Represents a PropertyEditor for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
Public class | LimitedStringPropertyEditor | Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
Public class | NullableBooleanPropertyEditor | Represents a PropertyEditor for editing a nullable Boolean with a three-state CheckBox.
Public class | PropertyEditor | Provides information used for displaying and manipulating a property value in a property grid.
Public class | PropertyEditorCollection | Represents a collection of PropertyEditor objects.
Public class | PropertyGridPropertyEditorsModifier | Represents a class that can optionally clear or append to the DefaultPropertyEditors collection from XAML, such as in Application.Resources.
Public class | StringPropertyEditor | Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a TextBox.
Public class | SuggestedStringPropertyEditor | Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Interfaces
 | Interface | Description
Public interface | IPropertyEditorsProvider | Provides the base requirements for an object that has a collection of property editors.
Enumerations
 | Enumeration | Description
Public enumeration | DefaultValueTemplateKind | Specifies the kind of default PropertyGrid value cell template.
Public enumeration | ExtendedStringPropertyEditorBehavior | Specifies the read-only/enabled state behavior of controls within an ExtendedStringPropertyEditor.


BooleanPropertyEditor Class

Represents a PropertyEditor for editing a Boolean value with a two-state CheckBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsBooleanPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BooleanPropertyEditor : PropertyEditor
Public Class BooleanPropertyEditor
    Inherits PropertyEditor

The BooleanPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanPropertyEditor | Initializes an instance of the BooleanPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


BooleanPropertyEditor Constructor

Initializes an instance of the BooleanPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BooleanPropertyEditor()
Public Sub New
See Also

Reference

BooleanPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


BooleanPropertyEditor Properties

The BooleanPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

BooleanPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


BooleanPropertyEditor Methods

The BooleanPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BooleanPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


BooleanPropertyEditor Events

The BooleanPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BooleanPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Class

Represents a PropertyEditor for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsBrushPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class BrushPropertyEditor : PropertyEditor
Public Class BrushPropertyEditor
    Inherits PropertyEditor

The BrushPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | BrushPropertyEditor | Initializes an instance of the BrushPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Constructor

Initializes an instance of the BrushPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public BrushPropertyEditor()
Public Sub New
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Properties

The BrushPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Methods

The BrushPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Events

The BrushPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor Class

Provides information for an editor that can consume and display one or more properties in a property grid.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsCategoryEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CategoryEditor : ObservableObjectBase
Public Class CategoryEditor
    Inherits ObservableObjectBase

The CategoryEditor type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditor | Initializes a new instance of the CategoryEditor class
Top
Properties
 | Name | Description
Public property | Category | Gets or sets the category associated with this editor.
Public property | Description | Gets or sets the description of the category editor, often displayed in a summary area or a tooltip.
Public property | DisplayName | Gets or sets the name to use when displaying the category editor.
Public property | EditorTemplate | Gets or sets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | Properties | Gets the properties that are consumed by this category editor.
Top
Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor Constructor

Initializes a new instance of the CategoryEditor class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryEditor()
Public Sub New
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor Properties

The CategoryEditor type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets or sets the category associated with this editor.
Public property | Description | Gets or sets the description of the category editor, often displayed in a summary area or a tooltip.
Public property | DisplayName | Gets or sets the name to use when displaying the category editor.
Public property | EditorTemplate | Gets or sets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | Properties | Gets the properties that are consumed by this category editor.
Top
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor.Category Property

CategoryEditorCategory Property

Gets or sets the category associated with this editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set

Property Value

Type: String
The category associated with this editor.
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor.Description Property

CategoryEditorDescription Property

Gets or sets the description of the category editor, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the category editor, often displayed in a summary area or a tooltip.
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor.DisplayName Property

CategoryEditorDisplayName Property

Gets or sets the name to use when displaying the category editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
The name to use when displaying the category editor.
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor.EditorTemplate Property

CategoryEditorEditorTemplate Property

Gets or sets the DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate EditorTemplate { get; set; }
Public Property EditorTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for editing the properties consumed by this editor.
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor.EditorTemplateKey Property

CategoryEditorEditorTemplateKey Property

Gets or sets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object EditorTemplateKey { get; set; }
Public Property EditorTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor.Properties Property

CategoryEditorProperties Property

Gets the properties that are consumed by this category editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryEditorPropertyCollection Properties { get; }
Public ReadOnly Property Properties As CategoryEditorPropertyCollection
    Get

Property Value

Type: CategoryEditorPropertyCollection
The properties that are consumed by this category editor.
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor Methods

The CategoryEditor type exposes the following members.

Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditor Events

The CategoryEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Class

Represents a collection of CategoryEditor objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection CategoryEditor
System.Collections.ObjectModelObservableCollection CategoryEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsCategoryEditorCollection

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CategoryEditorCollection : ObservableCollection<CategoryEditor>
Public Class CategoryEditorCollection
    Inherits ObservableCollection(Of CategoryEditor)

The CategoryEditorCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditorCollection | Initializes a new instance of the CategoryEditorCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CategoryEditor .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CategoryEditor .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CategoryEditor .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CategoryEditor .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CategoryEditor .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CategoryEditor .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CategoryEditor .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection CategoryEditor .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CategoryEditor .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CategoryEditor .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CategoryEditor .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CategoryEditor .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CategoryEditor .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection CategoryEditor .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CategoryEditor .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CategoryEditor .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection CategoryEditor .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection CategoryEditor .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CategoryEditor .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CategoryEditor .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection CategoryEditor .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection CategoryEditor .)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CategoryEditor .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CategoryEditor .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Constructor

Initializes a new instance of the CategoryEditorCollection class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryEditorCollection()
Public Sub New
See Also

Reference

CategoryEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Properties

The CategoryEditorCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CategoryEditor .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CategoryEditor .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CategoryEditor .)
Top
See Also

Reference

CategoryEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Methods

The CategoryEditorCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CategoryEditor .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CategoryEditor .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CategoryEditor .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CategoryEditor .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection CategoryEditor .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CategoryEditor .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CategoryEditor .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CategoryEditor .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CategoryEditor .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CategoryEditor .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection CategoryEditor .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CategoryEditor .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CategoryEditor .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection CategoryEditor .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection CategoryEditor .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CategoryEditor .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CategoryEditor .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection CategoryEditor .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection CategoryEditor .)
Top
See Also

Reference

CategoryEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Events

The CategoryEditorCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CategoryEditor .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CategoryEditor .)
Top
See Also

Reference

CategoryEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Class

Provides information about a property to be consumed by a CategoryEditor.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsCategoryEditorProperty

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CategoryEditorProperty : ObservableObjectBase
Public Class CategoryEditorProperty
    Inherits ObservableObjectBase

The CategoryEditorProperty type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditorProperty | Initializes a new instance of the CategoryEditorProperty class
Top
Properties
 | Name | Description
Public property | ObjectType | Gets or sets the type of the data object that contains the property.
Public property | PropertyName | Gets or sets the name of the property.
Public property | PropertyType | Gets or sets the type of the property.
Top
Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Constructor

Initializes a new instance of the CategoryEditorProperty class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryEditorProperty()
Public Sub New
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Properties

The CategoryEditorProperty type exposes the following members.

Properties
 | Name | Description
Public property | ObjectType | Gets or sets the type of the data object that contains the property.
Public property | PropertyName | Gets or sets the name of the property.
Public property | PropertyType | Gets or sets the type of the property.
Top
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty.ObjectType Property

CategoryEditorPropertyObjectType Property

Gets or sets the type of the data object that contains the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type ObjectType { get; set; }
Public Property ObjectType As Type
    Get
    Set

Property Value

Type: Type
The type of the data object that contains the property.
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty.PropertyName Property

CategoryEditorPropertyPropertyName Property

Gets or sets the name of the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string PropertyName { get; set; }
Public Property PropertyName As String
    Get
    Set

Property Value

Type: String
The name of the property.
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty.PropertyType Property

CategoryEditorPropertyPropertyType Property

Gets or sets the type of the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type PropertyType { get; set; }
Public Property PropertyType As Type
    Get
    Set

Property Value

Type: Type
The type of the property.
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Methods

The CategoryEditorProperty type exposes the following members.

Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Events

The CategoryEditorProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Class

Represents a collection of CategoryEditorProperty objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection CategoryEditorProperty
System.Collections.ObjectModelObservableCollection CategoryEditorProperty
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsCategoryEditorPropertyCollection

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class CategoryEditorPropertyCollection : ObservableCollection<CategoryEditorProperty>
Public Class CategoryEditorPropertyCollection
    Inherits ObservableCollection(Of CategoryEditorProperty)

The CategoryEditorPropertyCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditorPropertyCollection | Initializes a new instance of the CategoryEditorPropertyCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CategoryEditorProperty .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CategoryEditorProperty .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CategoryEditorProperty .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection CategoryEditorProperty .)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CategoryEditorProperty .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Constructor

Initializes a new instance of the CategoryEditorPropertyCollection class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public CategoryEditorPropertyCollection()
Public Sub New
See Also

Reference

CategoryEditorPropertyCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Properties

The CategoryEditorPropertyCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection CategoryEditorProperty .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Top
See Also

Reference

CategoryEditorPropertyCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Methods

The CategoryEditorPropertyCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection CategoryEditorProperty .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection CategoryEditorProperty .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection CategoryEditorProperty .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection CategoryEditorProperty .)
Top
See Also

Reference

CategoryEditorPropertyCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Events

The CategoryEditorPropertyCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection CategoryEditorProperty .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection CategoryEditorProperty .)
Top
See Also

Reference

CategoryEditorPropertyCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Class

Represents a PropertyEditor for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsColorPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ColorPropertyEditor : PropertyEditor
Public Class ColorPropertyEditor
    Inherits PropertyEditor

The ColorPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ColorPropertyEditor | Initializes an instance of the ColorPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Constructor

Initializes an instance of the ColorPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ColorPropertyEditor()
Public Sub New
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Properties

The ColorPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Methods

The ColorPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Events

The ColorPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind Enumeration

Specifies the kind of default PropertyGrid value cell template.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum DefaultValueTemplateKind
Public Enumeration DefaultValueTemplateKind
Members
Member name | Value | Description
None | 0 | No template is specified.
Boolean | 1 | A template for editing a Boolean value with a two-state CheckBox.
Brush | 2 | A template for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
Color | 3 | A template for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
ExtendedString | 4 | A template for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
FontFamily | 5 | A template for editing a FontFamily value with a ComboBox that contains system font families.
FontStretch | 6 | A template for editing a FontStretch value with a ComboBox that contains font stretch options.
FontStyle | 7 | A template for editing a FontStyle value with a ComboBox that contains font style options.
FontWeight | 8 | A template for editing a FontWeight value with a ComboBox that contains font weight options.
LimitedObject | 9 | A template for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
LimitedString | 10 | A template for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
NullableBoolean | 11 | A template for editing a nullable Boolean with a three-state CheckBox.
String | 12 | A template for editing a String value (or Object value via ValueAsString) with a TextBox.
SuggestedString | 13 | A template for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Class

Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsExtendedStringPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class ExtendedStringPropertyEditor : PropertyEditor
Public Class ExtendedStringPropertyEditor
    Inherits PropertyEditor

The ExtendedStringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedStringPropertyEditor | Initializes an instance of the ExtendedStringPropertyEditor class.
Top
Properties
 | Name | Description
Public property | Behavior | Gets or sets the read-only/enabled state behavior of controls within a template for this property editor.
Public property | ButtonCommand | Gets or sets the ICommand to use on the button in the template.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Overrides PropertyEditorGetIsReadOnly(IPropertyModel).)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Constructor

Initializes an instance of the ExtendedStringPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExtendedStringPropertyEditor()
Public Sub New
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Properties

The ExtendedStringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Gets or sets the read-only/enabled state behavior of controls within a template for this property editor.
Public property | ButtonCommand | Gets or sets the ICommand to use on the button in the template.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor.Behavior Property

ExtendedStringPropertyEditorBehavior Property

Gets or sets the read-only/enabled state behavior of controls within a template for this property editor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ExtendedStringPropertyEditorBehavior Behavior { get; set; }
Public Property Behavior As ExtendedStringPropertyEditorBehavior
    Get
    Set

Property Value

Type: ExtendedStringPropertyEditorBehavior
The read-only/enabled state behavior of controls within a template for this property editor. The default value is Default.
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor.ButtonCommand Property

ExtendedStringPropertyEditorButtonCommand Property

Gets or sets the ICommand to use on the button in the template.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand ButtonCommand { get; set; }
Public Property ButtonCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand to use on the button in the template.
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Methods

The ExtendedStringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Overrides PropertyEditorGetIsReadOnly(IPropertyModel).)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor.GetIsReadOnly Method

ExtendedStringPropertyEditorGetIsReadOnly Method

Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<bool> GetIsReadOnly(
    IPropertyModel propertyModel
)
Protected Overrides Function GetIsReadOnly (
    propertyModel As IPropertyModel
) As Nullable(Of Boolean)

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.

Return Value

Type: Nullable Boolean
true if the property model should be read-only. false if the property model should not be read-only. to allow default logic for determining read-only state to execute.
Remarks
Do not call IsReadOnly from within this method, since the getter for that property calls into this method as part of its default logic.
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Events

The ExtendedStringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditorBehavior Enumeration

Specifies the read-only/enabled state behavior of controls within an ExtendedStringPropertyEditor.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum ExtendedStringPropertyEditorBehavior
Public Enumeration ExtendedStringPropertyEditorBehavior
Members
Member name | Value | Description
Default | 0 | The text is read-only and the button is disabled when IsReadOnly is true.
TextReadOnly | 1 | The text is always read-only. The button is disabled when IsReadOnly is true.
ButtonEnabled | 2 | The text is read-only when IsReadOnly is true. The button is enabled, even when IsValueReadOnly is true, but not when IsHostReadOnly is true.
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Class

Represents a PropertyEditor for editing a FontFamily value with a ComboBox that contains system font families.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsFontFamilyPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FontFamilyPropertyEditor : PropertyEditor
Public Class FontFamilyPropertyEditor
    Inherits PropertyEditor

The FontFamilyPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | FontFamilyPropertyEditor | Initializes an instance of the FontFamilyPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Constructor

Initializes an instance of the FontFamilyPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontFamilyPropertyEditor()
Public Sub New
See Also

Reference

FontFamilyPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Properties

The FontFamilyPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

FontFamilyPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Methods

The FontFamilyPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontFamilyPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Events

The FontFamilyPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontFamilyPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Class

Represents a PropertyEditor for editing a FontStretch value with a ComboBox that contains font stretch options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsFontStretchPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FontStretchPropertyEditor : PropertyEditor
Public Class FontStretchPropertyEditor
    Inherits PropertyEditor

The FontStretchPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | FontStretchPropertyEditor | Initializes an instance of the FontStretchPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Constructor

Initializes an instance of the FontStretchPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontStretchPropertyEditor()
Public Sub New
See Also

Reference

FontStretchPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Properties

The FontStretchPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

FontStretchPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Methods

The FontStretchPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontStretchPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Events

The FontStretchPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontStretchPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Class

Represents a PropertyEditor for editing a FontStyle value with a ComboBox that contains font style options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsFontStylePropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FontStylePropertyEditor : PropertyEditor
Public Class FontStylePropertyEditor
    Inherits PropertyEditor

The FontStylePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | FontStylePropertyEditor | Initializes an instance of the FontStylePropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Constructor

Initializes an instance of the FontStylePropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontStylePropertyEditor()
Public Sub New
See Also

Reference

FontStylePropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Properties

The FontStylePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

FontStylePropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Methods

The FontStylePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontStylePropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Events

The FontStylePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontStylePropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Class

Represents a PropertyEditor for editing a FontWeight value with a ComboBox that contains font weight options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsFontWeightPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class FontWeightPropertyEditor : PropertyEditor
Public Class FontWeightPropertyEditor
    Inherits PropertyEditor

The FontWeightPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | FontWeightPropertyEditor | Initializes an instance of the FontWeightPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Constructor

Initializes an instance of the FontWeightPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public FontWeightPropertyEditor()
Public Sub New
See Also

Reference

FontWeightPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Properties

The FontWeightPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

FontWeightPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Methods

The FontWeightPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontWeightPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Events

The FontWeightPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontWeightPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


IPropertyEditorsProvider Interface

Provides the base requirements for an object that has a collection of property editors.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IPropertyEditorsProvider
Public Interface IPropertyEditorsProvider

The IPropertyEditorsProvider type exposes the following members.

Properties
 | Name | Description
Public property | PropertyEditors | Gets the property editors to append to the collection.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


IPropertyEditorsProvider Properties

The IPropertyEditorsProvider type exposes the following members.

Properties
 | Name | Description
Public property | PropertyEditors | Gets the property editors to append to the collection.
Top
See Also

Reference

IPropertyEditorsProvider Interface
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


IPropertyEditorsProvider.PropertyEditors Property

IPropertyEditorsProviderPropertyEditors Property

Gets the property editors to append to the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
PropertyEditorCollection PropertyEditors { get; }
ReadOnly Property PropertyEditors As PropertyEditorCollection
    Get

Property Value

Type: PropertyEditorCollection
The property editors to append to the collection.
See Also

Reference

IPropertyEditorsProvider Interface
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Class

Represents a PropertyEditor for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsLimitedObjectPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LimitedObjectPropertyEditor : PropertyEditor
Public Class LimitedObjectPropertyEditor
    Inherits PropertyEditor

The LimitedObjectPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | LimitedObjectPropertyEditor | Initializes an instance of the LimitedObjectPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Constructor

Initializes an instance of the LimitedObjectPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LimitedObjectPropertyEditor()
Public Sub New
See Also

Reference

LimitedObjectPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Properties

The LimitedObjectPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

LimitedObjectPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Methods

The LimitedObjectPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

LimitedObjectPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Events

The LimitedObjectPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

LimitedObjectPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Class

Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsLimitedStringPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class LimitedStringPropertyEditor : PropertyEditor
Public Class LimitedStringPropertyEditor
    Inherits PropertyEditor

The LimitedStringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | LimitedStringPropertyEditor | Initializes an instance of the LimitedStringPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Constructor

Initializes an instance of the LimitedStringPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public LimitedStringPropertyEditor()
Public Sub New
See Also

Reference

LimitedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Properties

The LimitedStringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

LimitedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Methods

The LimitedStringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

LimitedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Events

The LimitedStringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

LimitedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Class

Represents a PropertyEditor for editing a nullable Boolean with a three-state CheckBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsNullableBooleanPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class NullableBooleanPropertyEditor : PropertyEditor
Public Class NullableBooleanPropertyEditor
    Inherits PropertyEditor

The NullableBooleanPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableBooleanPropertyEditor | Initializes an instance of the NullableBooleanPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Constructor

Initializes an instance of the NullableBooleanPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public NullableBooleanPropertyEditor()
Public Sub New
See Also

Reference

NullableBooleanPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Properties

The NullableBooleanPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableBooleanPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Methods

The NullableBooleanPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableBooleanPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Events

The NullableBooleanPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableBooleanPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor Class

Provides information used for displaying and manipulating a property value in a property grid.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
More...

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyEditor : ObservableObjectBase
Public Class PropertyEditor
    Inherits ObservableObjectBase

The PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyEditor | Initializes a new instance of the PropertyEditor class
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name.
Public property | ObjectType | Gets or sets the type of the data object that contains the property.
Public property | PropertyName | Gets or sets the name of the property.
Public property | PropertyType | Gets or sets the type of the property.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value.
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result.
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsBooleanPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsBrushPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsColorPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsExtendedStringPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsFontFamilyPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsFontStretchPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsFontStylePropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsFontWeightPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsLimitedObjectPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsLimitedStringPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsNullableBooleanPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsStringPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsSuggestedStringPropertyEditor


PropertyEditor Constructor

Initializes a new instance of the PropertyEditor class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditor()
Public Sub New
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor Properties

The PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name.
Public property | ObjectType | Gets or sets the type of the data object that contains the property.
Public property | PropertyName | Gets or sets the name of the property.
Public property | PropertyType | Gets or sets the type of the property.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value.
Top
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.NameTemplate Property

PropertyEditorNameTemplate Property

Gets or sets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataTemplate NameTemplate { get; set; }
Public Overridable Property NameTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.
Remarks
The priority order of name template specification is NameTemplate, NameTemplateSelector, and finally NameTemplateKey.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.NameTemplateKey Property

PropertyEditorNameTemplateKey Property

Gets or sets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Object NameTemplateKey { get; set; }
Public Overridable Property NameTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.
Remarks
The priority order of name template specification is NameTemplate, NameTemplateSelector, and finally NameTemplateKey.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.NameTemplateSelector Property

PropertyEditorNameTemplateSelector Property

Gets or sets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataTemplateSelector NameTemplateSelector { get; set; }
Public Overridable Property NameTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.
Remarks
The priority order of name template specification is NameTemplate, NameTemplateSelector, and finally NameTemplateKey.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ObjectType Property

PropertyEditorObjectType Property

Gets or sets the type of the data object that contains the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type ObjectType { get; set; }
Public Property ObjectType As Type
    Get
    Set

Property Value

Type: Type
The type of the data object that contains the property.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.PropertyName Property

PropertyEditorPropertyName Property

Gets or sets the name of the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string PropertyName { get; set; }
Public Property PropertyName As String
    Get
    Set

Property Value

Type: String
The name of the property.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.PropertyType Property

PropertyEditorPropertyType Property

Gets or sets the type of the property.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type PropertyType { get; set; }
Public Property PropertyType As Type
    Get
    Set

Property Value

Type: Type
The type of the property.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ValueTemplate Property

PropertyEditorValueTemplate Property

Gets or sets the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataTemplate ValueTemplate { get; set; }
Public Overridable Property ValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, and finally ValueTemplateKind.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ValueTemplateKey Property

PropertyEditorValueTemplateKey Property

Gets or sets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Object ValueTemplateKey { get; set; }
Public Overridable Property ValueTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, and finally ValueTemplateKind.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ValueTemplateKind Property

PropertyEditorValueTemplateKind Property

Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DefaultValueTemplateKind ValueTemplateKind { get; set; }
Public Overridable Property ValueTemplateKind As DefaultValueTemplateKind
    Get
    Set

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, and finally ValueTemplateKind.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ValueTemplateSelector Property

PropertyEditorValueTemplateSelector Property

Gets or sets the DataTemplateSelector to use for editing the property value.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual DataTemplateSelector ValueTemplateSelector { get; set; }
Public Overridable Property ValueTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, and finally ValueTemplateKind.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor Methods

The PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result.
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor.GetIsReadOnly Method

PropertyEditorGetIsReadOnly Method

Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Nullable<bool> GetIsReadOnly(
    IPropertyModel propertyModel
)
Protected Overridable Function GetIsReadOnly (
    propertyModel As IPropertyModel
) As Nullable(Of Boolean)

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.

Return Value

Type: Nullable Boolean
true if the property model should be read-only. false if the property model should not be read-only. to allow default logic for determining read-only state to execute.
Remarks
Do not call IsReadOnly from within this method, since the getter for that property calls into this method as part of its default logic.
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditor Events

The PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Class

Represents a collection of PropertyEditor objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection PropertyEditor
System.Collections.ObjectModelObservableCollection PropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditorCollection

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyEditorCollection : ObservableCollection<PropertyEditor>
Public Class PropertyEditorCollection
    Inherits ObservableCollection(Of PropertyEditor)

The PropertyEditorCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyEditorCollection | Initializes a new instance of the PropertyEditorCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection PropertyEditor .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection PropertyEditor .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection PropertyEditor .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection PropertyEditor .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection PropertyEditor .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection PropertyEditor .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection PropertyEditor .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection PropertyEditor .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection PropertyEditor .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection PropertyEditor .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection PropertyEditor .)
Public method | GetNameEditor | Returns the best PropertyEditor match for selecting a IPropertyModel's name cell template.
Public method | GetValueEditor | Returns the best PropertyEditor match for selecting a IPropertyModel's value cell template.
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection PropertyEditor .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection PropertyEditor .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection PropertyEditor .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection PropertyEditor .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection PropertyEditor .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection PropertyEditor .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection PropertyEditor .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection PropertyEditor .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection PropertyEditor .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection PropertyEditor .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection PropertyEditor .)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection PropertyEditor .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection PropertyEditor .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Constructor

Initializes a new instance of the PropertyEditorCollection class

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditorCollection()
Public Sub New
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Properties

The PropertyEditorCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection PropertyEditor .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection PropertyEditor .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection PropertyEditor .)
Top
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Methods

The PropertyEditorCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection PropertyEditor .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection PropertyEditor .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection PropertyEditor .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection PropertyEditor .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection PropertyEditor .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection PropertyEditor .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection PropertyEditor .)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection PropertyEditor .)
Public method | GetNameEditor | Returns the best PropertyEditor match for selecting a IPropertyModel's name cell template.
Public method | GetValueEditor | Returns the best PropertyEditor match for selecting a IPropertyModel's value cell template.
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection PropertyEditor .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection PropertyEditor .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection PropertyEditor .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection PropertyEditor .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection PropertyEditor .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection PropertyEditor .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection PropertyEditor .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection PropertyEditor .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection PropertyEditor .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection PropertyEditor .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection PropertyEditor .)
Top
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection.GetNameEditor Method

PropertyEditorCollectionGetNameEditor Method

Returns the best PropertyEditor match for selecting a IPropertyModel's name cell template.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditor GetNameEditor(
    IPropertyModel propertyModel
)
Public Function GetNameEditor (
    propertyModel As IPropertyModel
) As PropertyEditor

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.

Return Value

Type: PropertyEditor
The best PropertyEditor match for selecting a IPropertyModel's name cell template.
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection.GetValueEditor Method

PropertyEditorCollectionGetValueEditor Method

Returns the best PropertyEditor match for selecting a IPropertyModel's value cell template.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditor GetValueEditor(
    IPropertyModel propertyModel
)
Public Function GetValueEditor (
    propertyModel As IPropertyModel
) As PropertyEditor

Parameters

propertyModel
Type: ActiproSoftware.Windows.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.

Return Value

Type: PropertyEditor
The best PropertyEditor match for selecting a IPropertyModel's value cell template.
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Events

The PropertyEditorCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection PropertyEditor .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection PropertyEditor .)
Top
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Class

Represents a class that can optionally clear or append to the DefaultPropertyEditors collection from XAML, such as in Application.Resources.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyGridPropertyEditorsModifier

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class PropertyGridPropertyEditorsModifier : DependencyObject,
    IPropertyEditorsProvider
Public Class PropertyGridPropertyEditorsModifier
    Inherits DependencyObject
    Implements IPropertyEditorsProvider

The PropertyGridPropertyEditorsModifier type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridPropertyEditorsModifier | Initializes an instance of the PropertyGridPropertyEditorsModifier class.
Top
Properties
 | Name | Description
Public property | Clear | Gets or sets whether to clear the collection before appending anything.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | PropertyEditors | Gets the property editors to append to the collection.
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
ClearProperty | Identifies the Clear dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Constructor

Initializes an instance of the PropertyGridPropertyEditorsModifier class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyGridPropertyEditorsModifier()
Public Sub New
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Properties

The PropertyGridPropertyEditorsModifier type exposes the following members.

Properties
 | Name | Description
Public property | Clear | Gets or sets whether to clear the collection before appending anything.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | PropertyEditors | Gets the property editors to append to the collection.
Top
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier.Clear Property

PropertyGridPropertyEditorsModifierClear Property

Gets or sets whether to clear the collection before appending anything.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool Clear { get; set; }
Public Property Clear As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the collection should be cleared before appending anything; otherwise, false.
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier.PropertyEditors Property

PropertyGridPropertyEditorsModifierPropertyEditors Property

Gets the property editors to append to the collection.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public PropertyEditorCollection PropertyEditors { get; }
Public ReadOnly Property PropertyEditors As PropertyEditorCollection
    Get

Property Value

Type: PropertyEditorCollection
The property editors to append to the collection.

Implements

IPropertyEditorsProviderPropertyEditors
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Methods

The PropertyGridPropertyEditorsModifier type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Fields

The PropertyGridPropertyEditorsModifier type exposes the following members.

Fields
Name | Description
ClearProperty | Identifies the Clear dependency property. This field is read-only.
Top
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier.ClearProperty Field

PropertyGridPropertyEditorsModifierClearProperty Field

Identifies the Clear dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClearProperty
Public Shared ReadOnly ClearProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Clear dependency property.
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Class

Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a TextBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsStringPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class StringPropertyEditor : PropertyEditor
Public Class StringPropertyEditor
    Inherits PropertyEditor

The StringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | StringPropertyEditor | Initializes an instance of the StringPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Constructor

Initializes an instance of the StringPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StringPropertyEditor()
Public Sub New
See Also

Reference

StringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Properties

The StringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

StringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Methods

The StringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

StringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Events

The StringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

StringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Class

Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.Windows.Controls.Grids.PropertyEditorsSuggestedStringPropertyEditor

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class SuggestedStringPropertyEditor : PropertyEditor
Public Class SuggestedStringPropertyEditor
    Inherits PropertyEditor

The SuggestedStringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SuggestedStringPropertyEditor | Initializes an instance of the SuggestedStringPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Constructor

Initializes an instance of the SuggestedStringPropertyEditor class.

Namespace: ActiproSoftware.Windows.Controls.Grids.PropertyEditors
Assembly: ActiproSoftware.Grids.Wpf (in ActiproSoftware.Grids.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public SuggestedStringPropertyEditor()
Public Sub New
See Also

Reference

SuggestedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Properties

The SuggestedStringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

SuggestedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Methods

The SuggestedStringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

SuggestedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Events

The SuggestedStringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

SuggestedStringPropertyEditor Class
ActiproSoftware.Windows.Controls.Grids.PropertyEditors Namespace


ActiproSoftware.Windows.Controls.MicroCharts Namespace

Contains classes that support implementing micro chart controls for WPF.
Classes
 | Class | Description
Public class | MicroAreaSeries | Represents an area series for use in a MicroXYChart.
Public class | MicroBarSeries | Represents a bar series for use in a MicroXYChart.
Public class | MicroBoxPlot | Represents a box plot control.
Public class | MicroBulletGraph | Represents a bullet graph control that has a primary featured measure and optionally compares that measure to another measure to enrich its meaning, while also displaying this information in the context of qualitative ranges of performance (poor, satisfactory, good, etc.).
Public class | MicroCandlestickChart | Represents a candlestick chart control.
Public class | MicroChartMarker | Represents a control capable of rendering predefined shapes.
Public class | MicroHeatMapPresenter | Represents a HeatMap element.
Public class | MicroLineSeries | Represents a line series for use in a MicroXYChart.
Public class | MicroQualitativeRange | Represents a qualitative range element for use within a MicroBulletGraph.
Public class | MicroQualitativeRangeCollection | Represents a collection of MicroQualitativeRange objects.
Public class | MicroScatterSeries | Represents a scatter series for use in a MicroXYChart.
Public class | MicroSegmentChart | Represents a segment chart control.
Public class | MicroSegmentChartItem | Represents a segment chart item.
Public class | MicroSeriesStyleSelector | Provides a way to apply series styles based on custom logic.
Public class | MicroSeriesStyleSelectorConverter | Represents a type converter for the MicroSeriesStyleSelector type.
Public class | MicroTrendIndicator | Represents a trend indicator.
Public class | MicroWinLossSeries | Represents a win/loss series for use in a MicroXYChart.
Public class | MicroXYChart | Represents a micro chart control that uses an X/Y coordinate system.
Public class | MicroXYDataPoint | Represents a data point presented by a a MicroXYSeriesBase series.
Public class | MicroXYDataPointCollectionView | Represents a collection view that generates MicroXYDataPoint from a specified source collection.
Public class | MicroXYRange | Represents a range for use in a MicroXYChart.
Public class | MicroXYRangeCollection | Represents a collection of MicroXYRange objects.
Public class | MicroXYSeriesCollection | Represents a collection of MicroXYSeriesBase objects.
Enumerations
 | Enumeration | Description
Public enumeration | MicroAggregationKind | Specifies the various kinds of built-in aggregation functions.
Public enumeration | MicroAreaSeriesStyleKinds | Specifies the various alternate styles that can be used when rendering an area.
Public enumeration | MicroBarSeriesStyleKinds | Specifies the various alternate styles that can be used when rendering a bar.
Public enumeration | MicroChartMarkerShapeKind | Specifies the various predefined shapes supported by MicroChartMarker.
Public enumeration | MicroChartMarkerStyleKinds | Specifies the various alternate styles that can be used when rendering a MicroChartMarker.
Public enumeration | MicroChartMarkerVisibility | Specifies the visibility of the various kinds of MicroChartMarker.
Public enumeration | MicroLineSeriesStyleKinds | Specifies the various alternate styles that can be used when rendering a line.
Public enumeration | MicroLineSeriesVisibility | Specifies the visibility of the various kinds of a line.
Public enumeration | MicroXYSeriesLineKind | Specifies the line kinds supported by a MicroLineSeries and MicroAreaSeries series.
Public enumeration | MicroXYSeriesStackKind | Specifies the stacking methods supported by a MicroXYSeriesBase series.


MicroAggregationKind Enumeration

Specifies the various kinds of built-in aggregation functions.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroAggregationKind
Public Enumeration MicroAggregationKind
Members
Member name | Value | Description
Average | 0 | Indicates that the values will be averaged together.
Maximum | 1 | Indicates that the maximum value will be used.
Minimum | 2 | Indicates that the minimum value will be used.
First | 3 | Indicates that the first value will be used.
Last | 4 | Indicates that the last value will be used.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries Class

Represents an area series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroLineSeriesBase
ActiproSoftware.Windows.Controls.MicroChartsMicroAreaSeries

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroAreaSeries : MicroLineSeriesBase
Public Class MicroAreaSeries
    Inherits MicroLineSeriesBase

The MicroAreaSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroAreaSeries | Initializes a new instance of the MicroAreaSeries class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AreaNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | AreaStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | AreaStyleKinds | Gets or sets a MicroAreaSeriesStyleKinds which indicates what style kinds are used for areas along the series. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineVisibility | Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroLineSeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
Fields
Name | Description
AreaNegativeStyleProperty | Identifies the AreaNegativeStyle dependency property. This field is read-only.
AreaStyleKindsProperty | Identifies the AreaStyleKinds dependency property. This field is read-only.
AreaStyleProperty | Identifies the AreaStyle dependency property. This field is read-only.
LineVisibilityProperty | Identifies the LineVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries Constructor

Initializes a new instance of the MicroAreaSeries class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroAreaSeries()
Public Sub New
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries Properties

The MicroAreaSeries type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AreaNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | AreaStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | AreaStyleKinds | Gets or sets a MicroAreaSeriesStyleKinds which indicates what style kinds are used for areas along the series. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineVisibility | Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries.AreaNegativeStyle Property

MicroAreaSeriesAreaNegativeStyle Property

Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style AreaNegativeStyle { get; set; }
Public Property AreaNegativeStyle As Style
    Get
    Set

Property Value

Type: Style
A negative Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries.AreaStyle Property

MicroAreaSeriesAreaStyle Property

Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style AreaStyle { get; set; }
Public Property AreaStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries.AreaStyleKinds Property

MicroAreaSeriesAreaStyleKinds Property

Gets or sets a MicroAreaSeriesStyleKinds which indicates what style kinds are used for areas along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroAreaSeriesStyleKinds AreaStyleKinds { get; set; }
Public Property AreaStyleKinds As MicroAreaSeriesStyleKinds
    Get
    Set

Property Value

Type: MicroAreaSeriesStyleKinds
A MicroAreaSeriesStyleKinds which indicates what style kinds are used for areas along the series. The default value is MicroAreaSeriesStyleKinds.None.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries.LineVisibility Property

MicroAreaSeriesLineVisibility Property

Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroLineSeriesVisibility LineVisibility { get; set; }
Public Property LineVisibility As MicroLineSeriesVisibility
    Get
    Set

Property Value

Type: MicroLineSeriesVisibility
A MicroLineSeriesVisibility indicating which lines are rendered along the series. The default value is MicroLineSeriesVisibility.None.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries Methods

The MicroAreaSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroLineSeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries.PlotSeries Method

MicroAreaSeriesPlotSeries Method

Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overrides Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries Events

The MicroAreaSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries Fields

The MicroAreaSeries type exposes the following members.

Fields
Name | Description
AreaNegativeStyleProperty | Identifies the AreaNegativeStyle dependency property. This field is read-only.
AreaStyleKindsProperty | Identifies the AreaStyleKinds dependency property. This field is read-only.
AreaStyleProperty | Identifies the AreaStyle dependency property. This field is read-only.
LineVisibilityProperty | Identifies the LineVisibility dependency property. This field is read-only.
Top
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries.AreaNegativeStyleProperty Field

MicroAreaSeriesAreaNegativeStyleProperty Field

Identifies the AreaNegativeStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreaNegativeStyleProperty
Public Shared ReadOnly AreaNegativeStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreaNegativeStyle dependency property.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries.AreaStyleKindsProperty Field

MicroAreaSeriesAreaStyleKindsProperty Field

Identifies the AreaStyleKinds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreaStyleKindsProperty
Public Shared ReadOnly AreaStyleKindsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreaStyleKinds dependency property.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries.AreaStyleProperty Field

MicroAreaSeriesAreaStyleProperty Field

Identifies the AreaStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreaStyleProperty
Public Shared ReadOnly AreaStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreaStyle dependency property.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeries.LineVisibilityProperty Field

MicroAreaSeriesLineVisibilityProperty Field

Identifies the LineVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineVisibilityProperty
Public Shared ReadOnly LineVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineVisibility dependency property.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroAreaSeriesStyleKinds Enumeration

Specifies the various alternate styles that can be used when rendering an area.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroAreaSeriesStyleKinds
Public Enumeration MicroAreaSeriesStyleKinds
Members
Member name | Value | Description
None | 0 | Indicates that no alternate styles will be used.
Negative | 1 | Indicates that a negative style can be used.
All | 8388609 | Indicates that all styles can be used.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBarSeries Class

Represents a bar series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroBarSeriesBase
ActiproSoftware.Windows.Controls.MicroChartsMicroBarSeries

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroBarSeries : MicroBarSeriesBase
Public Class MicroBarSeries
    Inherits MicroBarSeriesBase

The MicroBarSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroBarSeries | Initializes a new instance of the MicroBarSeries class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroBarSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroBarSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroBarSeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroBarSeriesBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBarSeries Constructor

Initializes a new instance of the MicroBarSeries class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroBarSeries()
Public Sub New
See Also

Reference

MicroBarSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBarSeries Properties

The MicroBarSeries type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroBarSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroBarSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroBarSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBarSeries Methods

The MicroBarSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroBarSeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroBarSeriesBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroBarSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBarSeries Events

The MicroBarSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
See Also

Reference

MicroBarSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds Enumeration

Specifies the various alternate styles that can be used when rendering a bar.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroBarSeriesStyleKinds
Public Enumeration MicroBarSeriesStyleKinds
Members
Member name | Value | Description
None | 0 | Indicates that no alternate styles will be used.
Negative | 1 | Indicates that a negative style can be used.
High | 2 | Indicates that a high style can be used.
Low | 4 | Indicates that a low style can be used.
All | 7 | Indicates that all styles can be used.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot Class

Represents a box plot control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroChartsMicroBoxPlot

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroBoxPlot : Control
Public Class MicroBoxPlot
    Inherits Control

The MicroBoxPlot type exposes the following members.

Constructors
 | Name | Description
Public method | MicroBoxPlot | Initializes a new instance of the MicroBoxPlot class.
Top
Properties
 | Name | Description
Public property | AreOutliersVisible | Gets or sets a boolean value indicating whether or not outliers should be rendered. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BoxStyle | Gets or sets the Style used to render the box. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IqrMultiplier | Gets or sets a value indicating the amount to multiply the IQR by to find the range of the whiskers. This is a dependency property.
Public property | IsMeanVisible | Gets or sets a boolean value indicating whether or not the mean value bar should be rendered. This is a dependency property.
Public property | IsMedianVisible | Gets or sets a boolean value indicating whether or not the median value bar should be rendered. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendStringFormat | Gets or sets the format that the MicroBoxPlot control will display in a tool tip. This is a dependency property.
Public property | Maximum | Gets or sets the maximum value of the chart. This is a dependency property.
Public property | MeanStyle | Gets or sets the style of the mean value bar. This is a dependency property.
Public property | MedianStyle | Gets or sets the style of the median value bar. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value of the chart. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the MicroBoxPlot. This is a dependency property.
Public property | OutlierStyle | Gets or sets the style of the outlier marker. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Values | Gets or sets the list of data values to be represented by the chart. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WhiskerAscent | Gets or sets a Unit indicating the ascent of the whisker endline. This is a dependency property.
Public property | WhiskerStyle | Gets or sets the style of the whisker line. This is a dependency property.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
AreOutliersVisibleProperty | Identifies the AreOutliersVisible dependency property. This field is read-only.
BoxStyleProperty | Identifies the BoxStyle dependency property. This field is read-only.
IqrMultiplierProperty | Identifies the IqrMultiplier dependency property. This field is read-only.
IsMeanVisibleProperty | Identifies the IsMeanVisible dependency property. This field is read-only.
IsMedianVisibleProperty | Identifies the IsMedianVisible dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MeanStyleProperty | Identifies the MeanStyle dependency property. This field is read-only.
MedianStyleProperty | Identifies the MedianStyle dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
OutlierStyleProperty | Identifies the OutlierStyle dependency property. This field is read-only.
ValuesProperty | Identifies the Values dependency property. This field is read-only.
WhiskerAscentProperty | Identifies the WhiskerAscent dependency property. This field is read-only.
WhiskerStyleProperty | Identifies the WhiskerStyle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot Constructor

Initializes a new instance of the MicroBoxPlot class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroBoxPlot()
Public Sub New
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot Properties

The MicroBoxPlot type exposes the following members.

Properties
 | Name | Description
Public property | AreOutliersVisible | Gets or sets a boolean value indicating whether or not outliers should be rendered. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BoxStyle | Gets or sets the Style used to render the box. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IqrMultiplier | Gets or sets a value indicating the amount to multiply the IQR by to find the range of the whiskers. This is a dependency property.
Public property | IsMeanVisible | Gets or sets a boolean value indicating whether or not the mean value bar should be rendered. This is a dependency property.
Public property | IsMedianVisible | Gets or sets a boolean value indicating whether or not the median value bar should be rendered. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendStringFormat | Gets or sets the format that the MicroBoxPlot control will display in a tool tip. This is a dependency property.
Public property | Maximum | Gets or sets the maximum value of the chart. This is a dependency property.
Public property | MeanStyle | Gets or sets the style of the mean value bar. This is a dependency property.
Public property | MedianStyle | Gets or sets the style of the median value bar. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value of the chart. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the MicroBoxPlot. This is a dependency property.
Public property | OutlierStyle | Gets or sets the style of the outlier marker. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Values | Gets or sets the list of data values to be represented by the chart. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WhiskerAscent | Gets or sets a Unit indicating the ascent of the whisker endline. This is a dependency property.
Public property | WhiskerStyle | Gets or sets the style of the whisker line. This is a dependency property.
Top
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.AreOutliersVisible Property

MicroBoxPlotAreOutliersVisible Property

Gets or sets a boolean value indicating whether or not outliers should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool AreOutliersVisible { get; set; }
Public Property AreOutliersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if outlier values are visible; otherwise, false. The default value is false.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.BoxStyle Property

MicroBoxPlotBoxStyle Property

Gets or sets the Style used to render the box. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style BoxStyle { get; set; }
Public Property BoxStyle As Style
    Get
    Set

Property Value

Type: Style
The Style used to render the box. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.IqrMultiplier Property

MicroBoxPlotIqrMultiplier Property

Gets or sets a value indicating the amount to multiply the IQR by to find the range of the whiskers. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double IqrMultiplier { get; set; }
Public Property IqrMultiplier As Double
    Get
    Set

Property Value

Type: Double
A value indicating the amount to multiply the IQR by to find the range of the whiskers. The default value is 1.5.
Remarks
IQR stands for interquartile range, which is equal to the difference of the upper and lower quartiles.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.IsMeanVisible Property

MicroBoxPlotIsMeanVisible Property

Gets or sets a boolean value indicating whether or not the mean value bar should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMeanVisible { get; set; }
Public Property IsMeanVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the mean value is visible; otherwise, false. The default value is false.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.IsMedianVisible Property

MicroBoxPlotIsMedianVisible Property

Gets or sets a boolean value indicating whether or not the median value bar should be rendered. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsMedianVisible { get; set; }
Public Property IsMedianVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the median value is visible; otherwise, false. The default value is true.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.LegendStringFormat Property

MicroBoxPlotLegendStringFormat Property

Gets or sets the format that the MicroBoxPlot control will display in a tool tip. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format that determines how to display a tool tip. The default value is .
Remarks
The format string will be passed the following parameters:
  • {0} - The minimum value.
  • {1} - The lower whisker value.
  • {2} - The first quartile value.
  • {3} - The median value.
  • {4} - The third quartile value.
  • {5} - The upper whisker value.
  • {6} - The maximum value.
  • {7} - The mean value.
  • {8} - The number of values.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.Maximum Property

MicroBoxPlotMaximum Property

Gets or sets the maximum value of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value of the chart. The default value is NaN.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.MeanStyle Property

MicroBoxPlotMeanStyle Property

Gets or sets the style of the mean value bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MeanStyle { get; set; }
Public Property MeanStyle As Style
    Get
    Set

Property Value

Type: Style
The style of the mean value bar. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.MedianStyle Property

MicroBoxPlotMedianStyle Property

Gets or sets the style of the median value bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MedianStyle { get; set; }
Public Property MedianStyle As Style
    Get
    Set

Property Value

Type: Style
The style of the median value bar. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.Minimum Property

MicroBoxPlotMinimum Property

Gets or sets the minimum value of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value of the chart. The default value is NaN.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.Orientation Property

MicroBoxPlotOrientation Property

Gets or sets the orientation of the MicroBoxPlot. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the MicroBoxPlot. The default value is Horizontal.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.OutlierStyle Property

MicroBoxPlotOutlierStyle Property

Gets or sets the style of the outlier marker. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style OutlierStyle { get; set; }
Public Property OutlierStyle As Style
    Get
    Set

Property Value

Type: Style
The style of the outlier marker. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.Values Property

MicroBoxPlotValues Property

Gets or sets the list of data values to be represented by the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable<double> Values { get; set; }
Public Property Values As IEnumerable(Of Double)
    Get
    Set

Property Value

Type: IEnumerable Double
The the list of data values. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.WhiskerAscent Property

MicroBoxPlotWhiskerAscent Property

Gets or sets a Unit indicating the ascent of the whisker endline. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit WhiskerAscent { get; set; }
Public Property WhiskerAscent As Unit
    Get
    Set

Property Value

Type: Unit
A Unit indicating the ascent of the whisker endline. The default value is 50%.
Remarks
Ascent is height when in a horizontal graph, and width when in a vertical graph.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.WhiskerStyle Property

MicroBoxPlotWhiskerStyle Property

Gets or sets the style of the whisker line. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style WhiskerStyle { get; set; }
Public Property WhiskerStyle As Style
    Get
    Set

Property Value

Type: Style
The style of the whisker line. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot Methods

The MicroBoxPlot type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.OnApplyTemplate Method

MicroBoxPlotOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.OnCreateAutomationPeer Method

MicroBoxPlotOnCreateAutomationPeer Method

When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.OnSizeChanged Method

MicroBoxPlotOnSizeChanged Method

Handles the SizeChanged event of the control.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    Object sender,
    SizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    sender As Object,
    e As SizeChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: System.WindowsSizeChangedEventArgs
The SizeChangedEventArgs instance containing the event data.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.Refresh Method

MicroBoxPlotRefresh Method

Updates the chart based on the current state.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot Events

The MicroBoxPlot type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot Fields

The MicroBoxPlot type exposes the following members.

Fields
Name | Description
AreOutliersVisibleProperty | Identifies the AreOutliersVisible dependency property. This field is read-only.
BoxStyleProperty | Identifies the BoxStyle dependency property. This field is read-only.
IqrMultiplierProperty | Identifies the IqrMultiplier dependency property. This field is read-only.
IsMeanVisibleProperty | Identifies the IsMeanVisible dependency property. This field is read-only.
IsMedianVisibleProperty | Identifies the IsMedianVisible dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MeanStyleProperty | Identifies the MeanStyle dependency property. This field is read-only.
MedianStyleProperty | Identifies the MedianStyle dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
OutlierStyleProperty | Identifies the OutlierStyle dependency property. This field is read-only.
ValuesProperty | Identifies the Values dependency property. This field is read-only.
WhiskerAscentProperty | Identifies the WhiskerAscent dependency property. This field is read-only.
WhiskerStyleProperty | Identifies the WhiskerStyle dependency property. This field is read-only.
Top
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.AreOutliersVisibleProperty Field

MicroBoxPlotAreOutliersVisibleProperty Field

Identifies the AreOutliersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreOutliersVisibleProperty
Public Shared ReadOnly AreOutliersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreOutliersVisible dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.BoxStyleProperty Field

MicroBoxPlotBoxStyleProperty Field

Identifies the BoxStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BoxStyleProperty
Public Shared ReadOnly BoxStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BoxStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.IqrMultiplierProperty Field

MicroBoxPlotIqrMultiplierProperty Field

Identifies the IqrMultiplier dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IqrMultiplierProperty
Public Shared ReadOnly IqrMultiplierProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IqrMultiplier dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.IsMeanVisibleProperty Field

MicroBoxPlotIsMeanVisibleProperty Field

Identifies the IsMeanVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMeanVisibleProperty
Public Shared ReadOnly IsMeanVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMeanVisible dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.IsMedianVisibleProperty Field

MicroBoxPlotIsMedianVisibleProperty Field

Identifies the IsMedianVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMedianVisibleProperty
Public Shared ReadOnly IsMedianVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMedianVisible dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.LegendStringFormatProperty Field

MicroBoxPlotLegendStringFormatProperty Field

Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.MaximumProperty Field

MicroBoxPlotMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.MeanStyleProperty Field

MicroBoxPlotMeanStyleProperty Field

Identifies the MeanStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MeanStyleProperty
Public Shared ReadOnly MeanStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MeanStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.MedianStyleProperty Field

MicroBoxPlotMedianStyleProperty Field

Identifies the MedianStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MedianStyleProperty
Public Shared ReadOnly MedianStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MedianStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.MinimumProperty Field

MicroBoxPlotMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.OrientationProperty Field

MicroBoxPlotOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.OutlierStyleProperty Field

MicroBoxPlotOutlierStyleProperty Field

Identifies the OutlierStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OutlierStyleProperty
Public Shared ReadOnly OutlierStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OutlierStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.ValuesProperty Field

MicroBoxPlotValuesProperty Field

Identifies the Values dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValuesProperty
Public Shared ReadOnly ValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Values dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.WhiskerAscentProperty Field

MicroBoxPlotWhiskerAscentProperty Field

Identifies the WhiskerAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WhiskerAscentProperty
Public Shared ReadOnly WhiskerAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WhiskerAscent dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBoxPlot.WhiskerStyleProperty Field

MicroBoxPlotWhiskerStyleProperty Field

Identifies the WhiskerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WhiskerStyleProperty
Public Shared ReadOnly WhiskerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WhiskerStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph Class

Represents a bullet graph control that has a primary featured measure and optionally compares that measure to another measure to enrich its meaning, while also displaying this information in the context of qualitative ranges of performance (poor, satisfactory, good, etc.).
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroChartsMicroBulletGraph

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroBulletGraph : Control
Public Class MicroBulletGraph
    Inherits Control

The MicroBulletGraph type exposes the following members.

Constructors
 | Name | Description
Public method | MicroBulletGraph | Initializes a new instance of the MicroBulletGraph class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ComparativeMeasureAscent | Gets or sets a Unit indicating the ascent of the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureBrush | Gets or sets the Brush used to render the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureExtent | Gets or sets a Unit indicating the extent of the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureValue | Gets or sets the value represented by the comparative measure bar. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FeaturedMeasureAscent | Gets or sets a Unit indicating the ascent of the featured measure bar. This is a dependency property.
Public property | FeaturedMeasureBrush | Gets or sets the Brush used to render the featured measure bar. This is a dependency property.
Public property | FeaturedMeasureValue | Gets or sets the value represented by the featured measure bar. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendStringFormat | Gets or sets the format that the MicroBulletGraph control will display in a tool tip. This is a dependency property.
Public property | Maximum | Gets or sets the maximum value displayed by the control. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value displayed by the control. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the MicroBulletGraph. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ProjectedMeasureBrush | Gets or sets the Brush used to render the projected measure bar. This is a dependency property.
Public property | ProjectedMeasureValue | Gets or sets the value represented by the projected measure bar. This is a dependency property.
Public property | QualitativeRanges | Gets the chart's collection of qualitative ranges.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ThemeBaseColor | Gets or sets the base Color to use when auto-generating brushes for rendering the graph. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ComparativeMeasureAscentProperty | Identifies the ComparativeMeasureBrush dependency property. This field is read-only.
ComparativeMeasureBrushProperty | Identifies the ComparativeMeasureBrush dependency property. This field is read-only.
ComparativeMeasureExtentProperty | Identifies the ComparativeMeasureExtent dependency property. This field is read-only.
ComparativeMeasureValueProperty | Identifies the ComparativeMeasureValue dependency property. This field is read-only.
FeaturedMeasureAscentProperty | Identifies the FeaturedMeasureAscent dependency property. This field is read-only.
FeaturedMeasureBrushProperty | Identifies the FeaturedMeasureBrush dependency property. This field is read-only.
FeaturedMeasureValueProperty | Identifies the FeaturedMeasureValue dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
ProjectedMeasureBrushProperty | Identifies the ProjectedMeasureBrush dependency property. This field is read-only.
ProjectedMeasureValueProperty | Identifies the ProjectedMeasureValue dependency property. This field is read-only.
ThemeBaseColorProperty | Identifies the ThemeBaseColor dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph Constructor

Initializes a new instance of the MicroBulletGraph class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroBulletGraph()
Public Sub New
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph Properties

The MicroBulletGraph type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ComparativeMeasureAscent | Gets or sets a Unit indicating the ascent of the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureBrush | Gets or sets the Brush used to render the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureExtent | Gets or sets a Unit indicating the extent of the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureValue | Gets or sets the value represented by the comparative measure bar. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FeaturedMeasureAscent | Gets or sets a Unit indicating the ascent of the featured measure bar. This is a dependency property.
Public property | FeaturedMeasureBrush | Gets or sets the Brush used to render the featured measure bar. This is a dependency property.
Public property | FeaturedMeasureValue | Gets or sets the value represented by the featured measure bar. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendStringFormat | Gets or sets the format that the MicroBulletGraph control will display in a tool tip. This is a dependency property.
Public property | Maximum | Gets or sets the maximum value displayed by the control. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value displayed by the control. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the MicroBulletGraph. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | ProjectedMeasureBrush | Gets or sets the Brush used to render the projected measure bar. This is a dependency property.
Public property | ProjectedMeasureValue | Gets or sets the value represented by the projected measure bar. This is a dependency property.
Public property | QualitativeRanges | Gets the chart's collection of qualitative ranges.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | ThemeBaseColor | Gets or sets the base Color to use when auto-generating brushes for rendering the graph. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureAscent Property

MicroBulletGraphComparativeMeasureAscent Property

Gets or sets a Unit indicating the ascent of the comparative measure bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit ComparativeMeasureAscent { get; set; }
Public Property ComparativeMeasureAscent As Unit
    Get
    Set

Property Value

Type: Unit
A Unit indicating the ascent of the comparative measure bar. The default value is 66.7%.
Remarks
Ascent is height when in a horizontal graph, and width when in a vertical graph.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureBrush Property

MicroBulletGraphComparativeMeasureBrush Property

Gets or sets the Brush used to render the comparative measure bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ComparativeMeasureBrush { get; set; }
Public Property ComparativeMeasureBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used to render the comparative measure bar. The default value is .
Remarks
When this value is , a brush will be auto-generated from the ThemeBaseColor.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureExtent Property

MicroBulletGraphComparativeMeasureExtent Property

Gets or sets a Unit indicating the extent of the comparative measure bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit ComparativeMeasureExtent { get; set; }
Public Property ComparativeMeasureExtent As Unit
    Get
    Set

Property Value

Type: Unit
A Unit indicating the extent of the comparative measure bar. The default value is 2.
Remarks
Extent is width when in a horizontal graph, and height when in a vertical graph.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureValue Property

MicroBulletGraphComparativeMeasureValue Property

Gets or sets the value represented by the comparative measure bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ComparativeMeasureValue { get; set; }
Public Property ComparativeMeasureValue As Double
    Get
    Set

Property Value

Type: Double
The value represented by the comparative measure bar. The default value is NaN, meaning don't show a comparative measure.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureAscent Property

MicroBulletGraphFeaturedMeasureAscent Property

Gets or sets a Unit indicating the ascent of the featured measure bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit FeaturedMeasureAscent { get; set; }
Public Property FeaturedMeasureAscent As Unit
    Get
    Set

Property Value

Type: Unit
A Unit indicating the ascent of the featured measure bar. The default value is 33.3%.
Remarks
Ascent is height when in a horizontal graph, and width when in a vertical graph.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureBrush Property

MicroBulletGraphFeaturedMeasureBrush Property

Gets or sets the Brush used to render the featured measure bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush FeaturedMeasureBrush { get; set; }
Public Property FeaturedMeasureBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used to render the featured measure bar. The default value is .
Remarks
When this value is , a brush will be auto-generated from the ThemeBaseColor.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureValue Property

MicroBulletGraphFeaturedMeasureValue Property

Gets or sets the value represented by the featured measure bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double FeaturedMeasureValue { get; set; }
Public Property FeaturedMeasureValue As Double
    Get
    Set

Property Value

Type: Double
The value represented by the featured measure bar. The default value is 0.0.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.LegendStringFormat Property

MicroBulletGraphLegendStringFormat Property

Gets or sets the format that the MicroBulletGraph control will display in a tool tip. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format that determines how to display a tool tip. The default value is .
Remarks
The format string will be passed the following parameters:
  • {0} - The featured measure value.
  • {1} - The projected measure value.
  • {2} - The comparitive measure value.
  • {3} - The minimum value.
  • {4} - The maximum value.
  • {5} - The value of the first qualitative range.
  • {6} - The value of the second qualitative range.
  • {7} - The value of the third qualitative range.
  • {8} - The value of the fourth qualitative range.
  • {9} - The value of the fifth qualitative range.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.Maximum Property

MicroBulletGraphMaximum Property

Gets or sets the maximum value displayed by the control. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value displayed by the control. The default value is NaN, meaning auto-calculate.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.Minimum Property

MicroBulletGraphMinimum Property

Gets or sets the minimum value displayed by the control. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value displayed by the control. The default value is NaN, meaning auto-calculate.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.Orientation Property

MicroBulletGraphOrientation Property

Gets or sets the orientation of the MicroBulletGraph. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the MicroBulletGraph. The default value is Horizontal.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ProjectedMeasureBrush Property

MicroBulletGraphProjectedMeasureBrush Property

Gets or sets the Brush used to render the projected measure bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush ProjectedMeasureBrush { get; set; }
Public Property ProjectedMeasureBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used to render the projected measure bar. The default value is .
Remarks
When this value is , a brush will be auto-generated from the ThemeBaseColor.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ProjectedMeasureValue Property

MicroBulletGraphProjectedMeasureValue Property

Gets or sets the value represented by the projected measure bar. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ProjectedMeasureValue { get; set; }
Public Property ProjectedMeasureValue As Double
    Get
    Set

Property Value

Type: Double
The value represented by the projected measure bar. The default value is NaN, meaning don't display a projected measure.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.QualitativeRanges Property

MicroBulletGraphQualitativeRanges Property

Gets the chart's collection of qualitative ranges.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroQualitativeRangeCollection QualitativeRanges { get; }
Public ReadOnly Property QualitativeRanges As MicroQualitativeRangeCollection
    Get

Property Value

Type: MicroQualitativeRangeCollection
The chart's collection of qualitative ranges. The default value is .
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ThemeBaseColor Property

MicroBulletGraphThemeBaseColor Property

Gets or sets the base Color to use when auto-generating brushes for rendering the graph. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Color ThemeBaseColor { get; set; }
Public Property ThemeBaseColor As Color
    Get
    Set

Property Value

Type: Color
The base Color to use when auto-generating brushes for rendering the graph. The default value is #000000.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph Methods

The MicroBulletGraph type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.OnApplyTemplate Method

MicroBulletGraphOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.OnCreateAutomationPeer Method

MicroBulletGraphOnCreateAutomationPeer Method

When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.OnSizeChanged Method

MicroBulletGraphOnSizeChanged Method

Handles the SizeChanged event of the control.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    Object sender,
    SizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    sender As Object,
    e As SizeChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: System.WindowsSizeChangedEventArgs
The SizeChangedEventArgs instance containing the event data.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.Refresh Method

MicroBulletGraphRefresh Method

Updates the chart based on the current state.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph Events

The MicroBulletGraph type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph Fields

The MicroBulletGraph type exposes the following members.

Fields
Name | Description
ComparativeMeasureAscentProperty | Identifies the ComparativeMeasureBrush dependency property. This field is read-only.
ComparativeMeasureBrushProperty | Identifies the ComparativeMeasureBrush dependency property. This field is read-only.
ComparativeMeasureExtentProperty | Identifies the ComparativeMeasureExtent dependency property. This field is read-only.
ComparativeMeasureValueProperty | Identifies the ComparativeMeasureValue dependency property. This field is read-only.
FeaturedMeasureAscentProperty | Identifies the FeaturedMeasureAscent dependency property. This field is read-only.
FeaturedMeasureBrushProperty | Identifies the FeaturedMeasureBrush dependency property. This field is read-only.
FeaturedMeasureValueProperty | Identifies the FeaturedMeasureValue dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
ProjectedMeasureBrushProperty | Identifies the ProjectedMeasureBrush dependency property. This field is read-only.
ProjectedMeasureValueProperty | Identifies the ProjectedMeasureValue dependency property. This field is read-only.
ThemeBaseColorProperty | Identifies the ThemeBaseColor dependency property. This field is read-only.
Top
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureAscentProperty Field

MicroBulletGraphComparativeMeasureAscentProperty Field

Identifies the ComparativeMeasureBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparativeMeasureAscentProperty
Public Shared ReadOnly ComparativeMeasureAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparativeMeasureBrush dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureBrushProperty Field

MicroBulletGraphComparativeMeasureBrushProperty Field

Identifies the ComparativeMeasureBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparativeMeasureBrushProperty
Public Shared ReadOnly ComparativeMeasureBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparativeMeasureBrush dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureExtentProperty Field

MicroBulletGraphComparativeMeasureExtentProperty Field

Identifies the ComparativeMeasureExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparativeMeasureExtentProperty
Public Shared ReadOnly ComparativeMeasureExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparativeMeasureExtent dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureValueProperty Field

MicroBulletGraphComparativeMeasureValueProperty Field

Identifies the ComparativeMeasureValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparativeMeasureValueProperty
Public Shared ReadOnly ComparativeMeasureValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparativeMeasureValue dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureAscentProperty Field

MicroBulletGraphFeaturedMeasureAscentProperty Field

Identifies the FeaturedMeasureAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FeaturedMeasureAscentProperty
Public Shared ReadOnly FeaturedMeasureAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FeaturedMeasureAscent dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureBrushProperty Field

MicroBulletGraphFeaturedMeasureBrushProperty Field

Identifies the FeaturedMeasureBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FeaturedMeasureBrushProperty
Public Shared ReadOnly FeaturedMeasureBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FeaturedMeasureBrush dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureValueProperty Field

MicroBulletGraphFeaturedMeasureValueProperty Field

Identifies the FeaturedMeasureValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FeaturedMeasureValueProperty
Public Shared ReadOnly FeaturedMeasureValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FeaturedMeasureValue dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.LegendStringFormatProperty Field

MicroBulletGraphLegendStringFormatProperty Field

Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.MaximumProperty Field

MicroBulletGraphMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.MinimumProperty Field

MicroBulletGraphMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.OrientationProperty Field

MicroBulletGraphOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ProjectedMeasureBrushProperty Field

MicroBulletGraphProjectedMeasureBrushProperty Field

Identifies the ProjectedMeasureBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ProjectedMeasureBrushProperty
Public Shared ReadOnly ProjectedMeasureBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ProjectedMeasureBrush dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ProjectedMeasureValueProperty Field

MicroBulletGraphProjectedMeasureValueProperty Field

Identifies the ProjectedMeasureValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ProjectedMeasureValueProperty
Public Shared ReadOnly ProjectedMeasureValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ProjectedMeasureValue dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroBulletGraph.ThemeBaseColorProperty Field

MicroBulletGraphThemeBaseColorProperty Field

Identifies the ThemeBaseColor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThemeBaseColorProperty
Public Shared ReadOnly ThemeBaseColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThemeBaseColor dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart Class

Represents a candlestick chart control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroChartsMicroCandlestickChart

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroCandlestickChart : Control
Public Class MicroCandlestickChart
    Inherits Control

The MicroCandlestickChart type exposes the following members.

Constructors
 | Name | Description
Public method | MicroCandlestickChart | Initializes a new instance of the MicroCandlestickChart class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CloseValue | Gets or sets the closing value of the chart. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GainStyle | Gets or sets the Style used if the closing value is greater than the opening value. This is a dependency property.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HighValue | Gets or sets the highest value of the chart. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendStringFormat | Gets or sets the format that the MicroCandlestickChart control will display in a tool tip. This is a dependency property.
Public property | LossStyle | Gets or sets the Style used if the closing value is less than the opening value. This is a dependency property.
Public property | LowValue | Gets or sets the lowest value of the chart. This is a dependency property.
Public property | Maximum | Gets or sets the maximum value of the chart. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value of the chart. This is a dependency property.
Public property | OpenValue | Gets or sets the opening value of the chart. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the MicroCandlestickChart. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
CloseValueProperty | Identifies the CloseValue dependency property. This field is read-only.
GainStyleProperty | Identifies the GainStyle dependency property. This field is read-only.
HighValueProperty | Identifies the HighValue dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
LossStyleProperty | Identifies the LossStyle dependency property. This field is read-only.
LowValueProperty | Identifies the LowValue dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OpenValueProperty | Identifies the OpenValue dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart Constructor

Initializes a new instance of the MicroCandlestickChart class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroCandlestickChart()
Public Sub New
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart Properties

The MicroCandlestickChart type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CloseValue | Gets or sets the closing value of the chart. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GainStyle | Gets or sets the Style used if the closing value is greater than the opening value. This is a dependency property.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HighValue | Gets or sets the highest value of the chart. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendStringFormat | Gets or sets the format that the MicroCandlestickChart control will display in a tool tip. This is a dependency property.
Public property | LossStyle | Gets or sets the Style used if the closing value is less than the opening value. This is a dependency property.
Public property | LowValue | Gets or sets the lowest value of the chart. This is a dependency property.
Public property | Maximum | Gets or sets the maximum value of the chart. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value of the chart. This is a dependency property.
Public property | OpenValue | Gets or sets the opening value of the chart. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the MicroCandlestickChart. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.CloseValue Property

MicroCandlestickChartCloseValue Property

Gets or sets the closing value of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double CloseValue { get; set; }
Public Property CloseValue As Double
    Get
    Set

Property Value

Type: Double
The closing value of the chart. The default value is 0.0.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.GainStyle Property

MicroCandlestickChartGainStyle Property

Gets or sets the Style used if the closing value is greater than the opening value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style GainStyle { get; set; }
Public Property GainStyle As Style
    Get
    Set

Property Value

Type: Style
The Style used to render the chart.
Remarks
If this style is left the LossStyle will be used with a transparent fill.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.HighValue Property

MicroCandlestickChartHighValue Property

Gets or sets the highest value of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double HighValue { get; set; }
Public Property HighValue As Double
    Get
    Set

Property Value

Type: Double
The highest value of the chart. The default value is 1.0.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.LegendStringFormat Property

MicroCandlestickChartLegendStringFormat Property

Gets or sets the format that the MicroCandlestickChart control will display in a tool tip. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format that determines how to display a tool tip. The default value is .
Remarks
The format string will be passed the following parameters:
  • {0} - The low value.
  • {1} - The high value.
  • {2} - The open value.
  • {3} - The close value.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.LossStyle Property

MicroCandlestickChartLossStyle Property

Gets or sets the Style used if the closing value is less than the opening value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LossStyle { get; set; }
Public Property LossStyle As Style
    Get
    Set

Property Value

Type: Style
The Style used to render the chart.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.LowValue Property

MicroCandlestickChartLowValue Property

Gets or sets the lowest value of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double LowValue { get; set; }
Public Property LowValue As Double
    Get
    Set

Property Value

Type: Double
The lowest value of the chart. The default value is 0.0.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.Maximum Property

MicroCandlestickChartMaximum Property

Gets or sets the maximum value of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value of the chart. The default value is NaN.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.Minimum Property

MicroCandlestickChartMinimum Property

Gets or sets the minimum value of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value of the chart. The default value is NaN.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.OpenValue Property

MicroCandlestickChartOpenValue Property

Gets or sets the opening value of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double OpenValue { get; set; }
Public Property OpenValue As Double
    Get
    Set

Property Value

Type: Double
The opening value of the chart. The default value is 0.0.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.Orientation Property

MicroCandlestickChartOrientation Property

Gets or sets the orientation of the MicroCandlestickChart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the MicroCandlestickChart. The default value is Horizontal.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart Methods

The MicroCandlestickChart type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.OnApplyTemplate Method

MicroCandlestickChartOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.OnCreateAutomationPeer Method

MicroCandlestickChartOnCreateAutomationPeer Method

When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.OnSizeChanged Method

MicroCandlestickChartOnSizeChanged Method

Handles the SizeChanged event of the control.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    Object sender,
    SizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    sender As Object,
    e As SizeChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: System.WindowsSizeChangedEventArgs
The SizeChangedEventArgs instance containing the event data.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.Refresh Method

MicroCandlestickChartRefresh Method

Updates the chart based on the current state.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart Events

The MicroCandlestickChart type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart Fields

The MicroCandlestickChart type exposes the following members.

Fields
Name | Description
CloseValueProperty | Identifies the CloseValue dependency property. This field is read-only.
GainStyleProperty | Identifies the GainStyle dependency property. This field is read-only.
HighValueProperty | Identifies the HighValue dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
LossStyleProperty | Identifies the LossStyle dependency property. This field is read-only.
LowValueProperty | Identifies the LowValue dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OpenValueProperty | Identifies the OpenValue dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.CloseValueProperty Field

MicroCandlestickChartCloseValueProperty Field

Identifies the CloseValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CloseValueProperty
Public Shared ReadOnly CloseValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CloseValue dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.GainStyleProperty Field

MicroCandlestickChartGainStyleProperty Field

Identifies the GainStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GainStyleProperty
Public Shared ReadOnly GainStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GainStyle dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.HighValueProperty Field

MicroCandlestickChartHighValueProperty Field

Identifies the HighValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighValueProperty
Public Shared ReadOnly HighValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighValue dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.LegendStringFormatProperty Field

MicroCandlestickChartLegendStringFormatProperty Field

Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.LossStyleProperty Field

MicroCandlestickChartLossStyleProperty Field

Identifies the LossStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LossStyleProperty
Public Shared ReadOnly LossStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LossStyle dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.LowValueProperty Field

MicroCandlestickChartLowValueProperty Field

Identifies the LowValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LowValueProperty
Public Shared ReadOnly LowValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LowValue dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.MaximumProperty Field

MicroCandlestickChartMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.MinimumProperty Field

MicroCandlestickChartMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.OpenValueProperty Field

MicroCandlestickChartOpenValueProperty Field

Identifies the OpenValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OpenValueProperty
Public Shared ReadOnly OpenValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OpenValue dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroCandlestickChart.OrientationProperty Field

MicroCandlestickChartOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker Class

Represents a control capable of rendering predefined shapes.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroChartsMicroChartMarker

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroChartMarker : Control
Public Class MicroChartMarker
    Inherits Control

The MicroChartMarker type exposes the following members.

Constructors
 | Name | Description
Public method | MicroChartMarker | Initializes a new instance of the MicroChartMarker class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Protected property | Path | Gets the Path associated with the marker.
Public property | ShapeKind | Gets or sets a MicroChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdatePath | Updates the Geometry of the Path element.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ShapeKindProperty | Identifies the ShapeKind dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker Constructor

Initializes a new instance of the MicroChartMarker class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroChartMarker()
Public Sub New
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker Properties

The MicroChartMarker type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Protected property | Path | Gets the Path associated with the marker.
Public property | ShapeKind | Gets or sets a MicroChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker.Path Property

MicroChartMarkerPath Property

Gets the Path associated with the marker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected Path Path { get; }
Protected ReadOnly Property Path As Path
    Get

Property Value

Type: Path
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker.ShapeKind Property

MicroChartMarkerShapeKind Property

Gets or sets a MicroChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroChartMarkerShapeKind ShapeKind { get; set; }
Public Property ShapeKind As MicroChartMarkerShapeKind
    Get
    Set

Property Value

Type: MicroChartMarkerShapeKind
A MicroChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. The default value is MicroChartMarkerShapeKind.Ellipse.
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker Methods

The MicroChartMarker type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdatePath | Updates the Geometry of the Path element.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker.OnApplyTemplate Method

MicroChartMarkerOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker.UpdatePath Method

MicroChartMarkerUpdatePath Method

Updates the Geometry of the Path element.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void UpdatePath()
Protected Overridable Sub UpdatePath
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker Events

The MicroChartMarker type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker Fields

The MicroChartMarker type exposes the following members.

Fields
Name | Description
ShapeKindProperty | Identifies the ShapeKind dependency property. This field is read-only.
Top
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarker.ShapeKindProperty Field

MicroChartMarkerShapeKindProperty Field

Identifies the ShapeKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ShapeKindProperty
Public Shared ReadOnly ShapeKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ShapeKind dependency property.
See Also

Reference

MicroChartMarker Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind Enumeration

Specifies the various predefined shapes supported by MicroChartMarker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroChartMarkerShapeKind
Public Enumeration MicroChartMarkerShapeKind
Members
Member name | Value | Description
Diamond | 0 | Indicates a diamond shape will be rendered.
Ellipse | 1 | Indicates an ellipse shape will be rendered.
Hexagon | 2 | Indicates a hexagon shape will be rendered.
Pentagon | 3 | Indicates a pentagon shape will be rendered.
Octagon | 4 | Indicates an octagon shape will be rendered.
Rectangle | 5 | Indicates a rectangle shape will be rendered.
RoundedRectangle | 6 | Indicates a rounded rectangle shape will be rendered.
Star4Points | 7 | Indicates an 4-pointed star shape will be rendered.
Star5Points | 8 | Indicates an 5-pointed star shape will be rendered.
Star6Points | 9 | Indicates an 6-pointed star shape will be rendered.
Star8Points | 10 | Indicates an 8-pointed star shape will be rendered.
Triangle | 11 | Indicates a triangle shape will be rendered.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds Enumeration

Specifies the various alternate styles that can be used when rendering a MicroChartMarker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroChartMarkerStyleKinds
Public Enumeration MicroChartMarkerStyleKinds
Members
Member name | Value | Description
None | 0 | Indicates that no alternate styles will be used.
Negative | 1 | Indicates that a negative style can be used.
High | 2 | Indicates that a high style can be used.
Low | 4 | Indicates that a low style can be used.
First | 8 | Indicates that a first style can be used.
Last | 16 | Indicates that a last style can be used.
All | 31 | Indicates that all styles can be used.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroChartMarkerVisibility Enumeration

Specifies the visibility of the various kinds of MicroChartMarker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroChartMarkerVisibility
Public Enumeration MicroChartMarkerVisibility
Members
Member name | Value | Description
None | 0 | Indicates that no markers will be visible.
Positive | 1 | Indicates that positive markers will be visible.
Negative | 2 | Indicates that negative markers will be visible.
High | 4 | Indicates that high markers will be visible.
Low | 8 | Indicates that low markers will be visible.
First | 16 | Indicates that the first marker will be visible.
Last | 32 | Indicates that the last marker will be visible.
All | 63 | Indicates that all markers will be visible.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter Class

Represents a HeatMap element.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
ActiproSoftware.Windows.Controls.MicroChartsMicroHeatMapPresenter

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroHeatMapPresenter : ContentControl
Public Class MicroHeatMapPresenter
    Inherits ContentControl

The MicroHeatMapPresenter type exposes the following members.

Constructors
 | Name | Description
Public method | MicroHeatMapPresenter | Initializes a new instance of the MicroHeatMapPresenter class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ColorMaximum | Gets or sets the maximum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | ColorMinimum | Gets or sets the minimum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | ColorValue | Gets or sets a value represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GradientStops | Gets or sets a collection of GradientStops used to the color of the MicroHeatMapPresenter. This is a dependency property.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSizingEnabled | Gets or sets whether or not the control can change size MicroHeatMapPresenter. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendStringFormat | Gets or sets the format that the MicroHeatMapPresenter control will display in a ToolTip. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MarkerStyle | Gets or sets the style of the marker of the MicroHeatMapPresenter. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SizeMaximum | Gets or sets the maximum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | SizeMinimum | Gets or sets the minimum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | SizeValue | Gets or sets a value represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ColorMaximumProperty | Identifies the ColorMaximumProperty dependency property. This field is read-only.
ColorMinimumProperty | Identifies the ColorMinimumProperty dependency property. This field is read-only.
ColorValueProperty | Identifies the ColorValue dependency property. This field is read-only.
GradientStopsProperty | Identifies the GradientStops dependency property. This field is read-only.
IsSizingEnabledProperty | Identifies the IsSizingEnabled dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
SizeMaximumProperty | Identifies the SizeMaximum dependency property. This field is read-only.
SizeMinimumProperty | Identifies the SizeMinimum dependency property. This field is read-only.
SizeValueProperty | Identifies the SizeValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter Constructor

Initializes a new instance of the MicroHeatMapPresenter class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroHeatMapPresenter()
Public Sub New
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter Properties

The MicroHeatMapPresenter type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ColorMaximum | Gets or sets the maximum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | ColorMinimum | Gets or sets the minimum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | ColorValue | Gets or sets a value represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GradientStops | Gets or sets a collection of GradientStops used to the color of the MicroHeatMapPresenter. This is a dependency property.
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsSizingEnabled | Gets or sets whether or not the control can change size MicroHeatMapPresenter. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LegendStringFormat | Gets or sets the format that the MicroHeatMapPresenter control will display in a ToolTip. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | MarkerStyle | Gets or sets the style of the marker of the MicroHeatMapPresenter. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SizeMaximum | Gets or sets the maximum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | SizeMinimum | Gets or sets the minimum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | SizeValue | Gets or sets a value represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorMaximum Property

MicroHeatMapPresenterColorMaximum Property

Gets or sets the maximum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ColorMaximum { get; set; }
Public Property ColorMaximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value of the data set represented by color. The default value is 1.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorMinimum Property

MicroHeatMapPresenterColorMinimum Property

Gets or sets the minimum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ColorMinimum { get; set; }
Public Property ColorMinimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value of the data set represented by color. The default value is 0.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorValue Property

MicroHeatMapPresenterColorValue Property

Gets or sets a value represented by the color of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ColorValue { get; set; }
Public Property ColorValue As Double
    Get
    Set

Property Value

Type: Double
This marker's value to be represented by color. The default value is 0.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.GradientStops Property

MicroHeatMapPresenterGradientStops Property

Gets or sets a collection of GradientStops used to the color of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public GradientStopCollection GradientStops { get; set; }
Public Property GradientStops As GradientStopCollection
    Get
    Set

Property Value

Type: GradientStopCollection
The collection of GradientStops to select the control's color from. The default value is .
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.IsSizingEnabled Property

MicroHeatMapPresenterIsSizingEnabled Property

Gets or sets whether or not the control can change size MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsSizingEnabled { get; set; }
Public Property IsSizingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
A boolean determining if the control can change size. The default value is false.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.LegendStringFormat Property

MicroHeatMapPresenterLegendStringFormat Property

Gets or sets the format that the MicroHeatMapPresenter control will display in a ToolTip. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format that determines how to display a ToolTip. The default value is .
Remarks
The format string will be passed the following parameters:
  • {0} - The value represented by color.
  • {1} - The minimum color value.
  • {2} - The maximum color value.
  • {3} - The value represented by size.
  • {4} - The minimum size value.
  • {5} - The maximum size value.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.MarkerStyle Property

MicroHeatMapPresenterMarkerStyle Property

Gets or sets the style of the marker of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; set; }
Public Property MarkerStyle As Style
    Get
    Set

Property Value

Type: Style
This marker's style. The default value is .
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeMaximum Property

MicroHeatMapPresenterSizeMaximum Property

Gets or sets the maximum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SizeMaximum { get; set; }
Public Property SizeMaximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value of the data set represented by size. The default value is 1.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeMinimum Property

MicroHeatMapPresenterSizeMinimum Property

Gets or sets the minimum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SizeMinimum { get; set; }
Public Property SizeMinimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value of the data set represented by size. The default value is 0.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeValue Property

MicroHeatMapPresenterSizeValue Property

Gets or sets a value represented by the size of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double SizeValue { get; set; }
Public Property SizeValue As Double
    Get
    Set

Property Value

Type: Double
This marker's value to be represented by size. The default value is 1.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter Methods

The MicroHeatMapPresenter type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.OnApplyTemplate Method

MicroHeatMapPresenterOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.OnCreateAutomationPeer Method

MicroHeatMapPresenterOnCreateAutomationPeer Method

When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter Events

The MicroHeatMapPresenter type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter Fields

The MicroHeatMapPresenter type exposes the following members.

Fields
Name | Description
ColorMaximumProperty | Identifies the ColorMaximumProperty dependency property. This field is read-only.
ColorMinimumProperty | Identifies the ColorMinimumProperty dependency property. This field is read-only.
ColorValueProperty | Identifies the ColorValue dependency property. This field is read-only.
GradientStopsProperty | Identifies the GradientStops dependency property. This field is read-only.
IsSizingEnabledProperty | Identifies the IsSizingEnabled dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
SizeMaximumProperty | Identifies the SizeMaximum dependency property. This field is read-only.
SizeMinimumProperty | Identifies the SizeMinimum dependency property. This field is read-only.
SizeValueProperty | Identifies the SizeValue dependency property. This field is read-only.
Top
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorMaximumProperty Field

MicroHeatMapPresenterColorMaximumProperty Field

Identifies the ColorMaximumProperty dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColorMaximumProperty
Public Shared ReadOnly ColorMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ColorMaximumProperty dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorMinimumProperty Field

MicroHeatMapPresenterColorMinimumProperty Field

Identifies the ColorMinimumProperty dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColorMinimumProperty
Public Shared ReadOnly ColorMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ColorMinimumProperty dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorValueProperty Field

MicroHeatMapPresenterColorValueProperty Field

Identifies the ColorValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColorValueProperty
Public Shared ReadOnly ColorValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ColorValue dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.GradientStopsProperty Field

MicroHeatMapPresenterGradientStopsProperty Field

Identifies the GradientStops dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GradientStopsProperty
Public Shared ReadOnly GradientStopsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GradientStops dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.IsSizingEnabledProperty Field

MicroHeatMapPresenterIsSizingEnabledProperty Field

Identifies the IsSizingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSizingEnabledProperty
Public Shared ReadOnly IsSizingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSizingEnabled dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.LegendStringFormatProperty Field

MicroHeatMapPresenterLegendStringFormatProperty Field

Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.MarkerStyleProperty Field

MicroHeatMapPresenterMarkerStyleProperty Field

Identifies the MarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerStyleProperty
Public Shared ReadOnly MarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerStyle dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeMaximumProperty Field

MicroHeatMapPresenterSizeMaximumProperty Field

Identifies the SizeMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeMaximumProperty
Public Shared ReadOnly SizeMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SizeMaximum dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeMinimumProperty Field

MicroHeatMapPresenterSizeMinimumProperty Field

Identifies the SizeMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeMinimumProperty
Public Shared ReadOnly SizeMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SizeMinimum dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeValueProperty Field

MicroHeatMapPresenterSizeValueProperty Field

Identifies the SizeValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeValueProperty
Public Shared ReadOnly SizeValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SizeValue dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroLineSeries Class

Represents a line series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroLineSeriesBase
ActiproSoftware.Windows.Controls.MicroChartsMicroLineSeries

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroLineSeries : MicroLineSeriesBase
Public Class MicroLineSeries
    Inherits MicroLineSeriesBase

The MicroLineSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroLineSeries | Initializes a new instance of the MicroLineSeries class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroLineSeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroLineSeries Constructor

Initializes a new instance of the MicroLineSeries class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroLineSeries()
Public Sub New
See Also

Reference

MicroLineSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroLineSeries Properties

The MicroLineSeries type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroLineSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroLineSeries Methods

The MicroLineSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroLineSeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroLineSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroLineSeries.PlotSeries Method

MicroLineSeriesPlotSeries Method

Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overrides Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroLineSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroLineSeries Events

The MicroLineSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
See Also

Reference

MicroLineSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroLineSeriesStyleKinds Enumeration

Specifies the various alternate styles that can be used when rendering a line.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroLineSeriesStyleKinds
Public Enumeration MicroLineSeriesStyleKinds
Members
Member name | Value | Description
None | 0 | Indicates that no alternate styles will be used.
Negative | 1 | Indicates that a negative style can be used.
All | 8388609 | Indicates that all styles can be used.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroLineSeriesVisibility Enumeration

Specifies the visibility of the various kinds of a line.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroLineSeriesVisibility
Public Enumeration MicroLineSeriesVisibility
Members
Member name | Value | Description
None | 0 | Indicates that no lines will be visible.
Positive | 1 | Indicates that positive lines will be visible.
Negative | 2 | Indicates that negative lines will be visible.
All | 3 | Indicates that all markers will be visible.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange Class

Represents a qualitative range element for use within a MicroBulletGraph.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroChartsMicroQualitativeRange

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroQualitativeRange : Control
Public Class MicroQualitativeRange
    Inherits Control

The MicroQualitativeRange type exposes the following members.

Constructors
 | Name | Description
Public method | MicroQualitativeRange | Initializes a new instance of the MicroQualitativeRange class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroBulletGraph that owns this range.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the MicroQualitativeRange. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the range based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange Constructor

Initializes a new instance of the MicroQualitativeRange class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroQualitativeRange()
Public Sub New
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange Properties

The MicroQualitativeRange type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroBulletGraph that owns this range.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the value of the MicroQualitativeRange. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange.Chart Property

MicroQualitativeRangeChart Property

Gets the MicroBulletGraph that owns this range.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroBulletGraph Chart { get; }
Public ReadOnly Property Chart As MicroBulletGraph
    Get

Property Value

Type: MicroBulletGraph
The MicroBulletGraph that owns this range.
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange.Value Property

MicroQualitativeRangeValue Property

Gets or sets the value of the MicroQualitativeRange. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value of the range. The default value is NaN.
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange Methods

The MicroQualitativeRange type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the range based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange.Refresh Method

MicroQualitativeRangeRefresh Method

Updates the range based on the current state.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange Events

The MicroQualitativeRange type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange Fields

The MicroQualitativeRange type exposes the following members.

Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRange.ValueProperty Field

MicroQualitativeRangeValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Class

Represents a collection of MicroQualitativeRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection MicroQualitativeRange
System.Collections.ObjectModelObservableCollection MicroQualitativeRange
ActiproSoftware.WindowsDeferrableObservableCollection MicroQualitativeRange
ActiproSoftware.Windows.Controls.MicroChartsMicroQualitativeRangeCollection

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroQualitativeRangeCollection : DeferrableObservableCollection<MicroQualitativeRange>
Public Class MicroQualitativeRangeCollection
    Inherits DeferrableObservableCollection(Of MicroQualitativeRange)

The MicroQualitativeRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MicroQualitativeRangeCollection | Initializes a new instance of the MicroQualitativeRangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection MicroQualitativeRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection MicroQualitativeRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection MicroQualitativeRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection MicroQualitativeRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection MicroQualitativeRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection MicroQualitativeRange .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Constructor

Initializes a new instance of the MicroQualitativeRangeCollection class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroQualitativeRangeCollection(
    MicroBulletGraph chart
)
Public Sub New (
    chart As MicroBulletGraph
)

Parameters

chart
Type: ActiproSoftware.Windows.Controls.MicroChartsMicroBulletGraph
The MicroBulletGraph that owns this collection and the associated ranges.
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Properties

The MicroQualitativeRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection MicroQualitativeRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Top
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Methods

The MicroQualitativeRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection MicroQualitativeRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection MicroQualitativeRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection MicroQualitativeRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection MicroQualitativeRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection.ClearItems Method

MicroQualitativeRangeCollectionClearItems Method

Removes all items from the collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection.InsertItem Method

MicroQualitativeRangeCollectionInsertItem Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    MicroQualitativeRange item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As MicroQualitativeRange
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: ActiproSoftware.Windows.Controls.MicroChartsMicroQualitativeRange
The object to insert.
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection.RemoveItem Method

MicroQualitativeRangeCollectionRemoveItem Method

Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection.SetItem Method

MicroQualitativeRangeCollectionSetItem Method

Replaces the element at the specified index.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    MicroQualitativeRange item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As MicroQualitativeRange
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to replace.
item
Type: ActiproSoftware.Windows.Controls.MicroChartsMicroQualitativeRange
The new value for the element at the specified index.
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Events

The MicroQualitativeRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection MicroQualitativeRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection MicroQualitativeRange .)
Top
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroScatterSeries Class

Represents a scatter series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.Windows.Controls.MicroChartsMicroScatterSeries

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroScatterSeries : MicroXYSeriesBase
Public Class MicroScatterSeries
    Inherits MicroXYSeriesBase

The MicroScatterSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroScatterSeries | Initializes a new instance of the MicroScatterSeries class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroScatterSeries Constructor

Initializes a new instance of the MicroScatterSeries class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroScatterSeries()
Public Sub New
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroScatterSeries Properties

The MicroScatterSeries type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroScatterSeries Methods

The MicroScatterSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroScatterSeries.GetMinimumMargin Method

MicroScatterSeriesGetMinimumMargin Method

Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> GetMinimumMargin()
Protected Overrides Function GetMinimumMargin As Nullable(Of Thickness)

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroScatterSeries.PlotSeries Method

MicroScatterSeriesPlotSeries Method

Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overrides Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroScatterSeries Events

The MicroScatterSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart Class

Represents a segment chart control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroChartsMicroSegmentChart

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroSegmentChart : Control
Public Class MicroSegmentChart
    Inherits Control

The MicroSegmentChart type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSegmentChart | Initializes a new instance of the MicroSegmentChart class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DecreaseCommand | Gets the ICommand that can be used to decrease the value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncreaseCommand | Gets the ICommand that can be used to increase the value.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style to use for item containers. This is a dependency property.
Public property | ItemsPanel | Gets or sets the ItemsPanelTemplate to use for positioning segments. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Total | Gets or sets the total number of segments in the chart. This is a dependency property.
Public property | Value | Gets or sets the number of segments that should appear highlighted in the chart. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
DecreaseCommandProperty | Identifies the DecreaseCommand dependency property. This field is read-only.
IncreaseCommandProperty | Identifies the IncreaseCommand dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemsPanelProperty | Identifies the ItemsPanel dependency property. This field is read-only.
TotalProperty | Identifies the Total dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart Constructor

Initializes a new instance of the MicroSegmentChart class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSegmentChart()
Public Sub New
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart Properties

The MicroSegmentChart type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | DecreaseCommand | Gets the ICommand that can be used to decrease the value.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncreaseCommand | Gets the ICommand that can be used to increase the value.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style to use for item containers. This is a dependency property.
Public property | ItemsPanel | Gets or sets the ItemsPanelTemplate to use for positioning segments. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Total | Gets or sets the total number of segments in the chart. This is a dependency property.
Public property | Value | Gets or sets the number of segments that should appear highlighted in the chart. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.DecreaseCommand Property

MicroSegmentChartDecreaseCommand Property

Gets the ICommand that can be used to decrease the value.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand DecreaseCommand { get; }
Public ReadOnly Property DecreaseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to decrease the value.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.IncreaseCommand Property

MicroSegmentChartIncreaseCommand Property

Gets the ICommand that can be used to increase the value.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ICommand IncreaseCommand { get; }
Public ReadOnly Property IncreaseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to increase the value.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.ItemContainerStyle Property

MicroSegmentChartItemContainerStyle Property

Gets or sets the Style to use for item containers. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ItemContainerStyle { get; set; }
Public Property ItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for item containers.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.ItemsPanel Property

MicroSegmentChartItemsPanel Property

Gets or sets the ItemsPanelTemplate to use for positioning segments. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate ItemsPanel { get; set; }
Public Property ItemsPanel As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for positioning segments.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.Total Property

MicroSegmentChartTotal Property

Gets or sets the total number of segments in the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Total { get; set; }
Public Property Total As Integer
    Get
    Set

Property Value

Type: Int32
The total number of segments in the chart. The default value is 10.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.Value Property

MicroSegmentChartValue Property

Gets or sets the number of segments that should appear highlighted in the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set

Property Value

Type: Int32
The number of segments that should appear highlighted in the chart. The default value is 0.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart Methods

The MicroSegmentChart type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.OnApplyTemplate Method

MicroSegmentChartOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart Events

The MicroSegmentChart type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart Fields

The MicroSegmentChart type exposes the following members.

Fields
Name | Description
DecreaseCommandProperty | Identifies the DecreaseCommand dependency property. This field is read-only.
IncreaseCommandProperty | Identifies the IncreaseCommand dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemsPanelProperty | Identifies the ItemsPanel dependency property. This field is read-only.
TotalProperty | Identifies the Total dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.DecreaseCommandProperty Field

MicroSegmentChartDecreaseCommandProperty Field

Identifies the DecreaseCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DecreaseCommandProperty
Public Shared ReadOnly DecreaseCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DecreaseCommand dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.IncreaseCommandProperty Field

MicroSegmentChartIncreaseCommandProperty Field

Identifies the IncreaseCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IncreaseCommandProperty
Public Shared ReadOnly IncreaseCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IncreaseCommand dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.ItemContainerStyleProperty Field

MicroSegmentChartItemContainerStyleProperty Field

Identifies the ItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemContainerStyleProperty
Public Shared ReadOnly ItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemContainerStyle dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.ItemsPanelProperty Field

MicroSegmentChartItemsPanelProperty Field

Identifies the ItemsPanel dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemsPanelProperty
Public Shared ReadOnly ItemsPanelProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemsPanel dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.TotalProperty Field

MicroSegmentChartTotalProperty Field

Identifies the Total dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TotalProperty
Public Shared ReadOnly TotalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Total dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChart.ValueProperty Field

MicroSegmentChartValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem Class

Represents a segment chart item.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroChartsMicroSegmentChartItem

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroSegmentChartItem : Control
Public Class MicroSegmentChartItem
    Inherits Control

The MicroSegmentChartItem type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSegmentChartItem | Initializes a new instance of the MicroSegmentChartItem class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HighlightedBackground | Gets or sets the Brush to use when the item is highlighted. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHighlighted | Gets or sets the whether the item is highlighted. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
HighlightedBackgroundProperty | Identifies the HighlightedBackground dependency property. This field is read-only.
IsHighlightedProperty | Identifies the IsHighlighted dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem Constructor

Initializes a new instance of the MicroSegmentChartItem class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSegmentChartItem()
Public Sub New
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem Properties

The MicroSegmentChartItem type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HighlightedBackground | Gets or sets the Brush to use when the item is highlighted. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsHighlighted | Gets or sets the whether the item is highlighted. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem.HighlightedBackground Property

MicroSegmentChartItemHighlightedBackground Property

Gets or sets the Brush to use when the item is highlighted. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush HighlightedBackground { get; set; }
Public Property HighlightedBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when the item is highlighted.
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem.IsHighlighted Property

MicroSegmentChartItemIsHighlighted Property

Gets or sets the whether the item is highlighted. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsHighlighted { get; set; }
Public Property IsHighlighted As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is highlighted; otherwise, false. The default value is false.
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem Methods

The MicroSegmentChartItem type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem.OnApplyTemplate Method

MicroSegmentChartItemOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem Events

The MicroSegmentChartItem type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem Fields

The MicroSegmentChartItem type exposes the following members.

Fields
Name | Description
HighlightedBackgroundProperty | Identifies the HighlightedBackground dependency property. This field is read-only.
IsHighlightedProperty | Identifies the IsHighlighted dependency property. This field is read-only.
Top
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem.HighlightedBackgroundProperty Field

MicroSegmentChartItemHighlightedBackgroundProperty Field

Identifies the HighlightedBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightedBackgroundProperty
Public Shared ReadOnly HighlightedBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightedBackground dependency property.
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSegmentChartItem.IsHighlightedProperty Field

MicroSegmentChartItemIsHighlightedProperty Field

Identifies the IsHighlighted dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHighlightedProperty
Public Shared ReadOnly IsHighlightedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHighlighted dependency property.
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector Class

Provides a way to apply series styles based on custom logic.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.MicroChartsMicroSeriesStyleSelector
ActiproSoftware.Windows.Controls.MicroCharts.PalettesMicroSeriesPaletteStyleSelector

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroSeriesStyleSelector
Public Class MicroSeriesStyleSelector

The MicroSeriesStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSeriesStyleSelector | Initializes a new instance of the MicroSeriesStyleSelector class
Top
Methods
 | Name | Description
Public method | SelectAreaHighStyle | Returns the high area Style to use for the specified series.
Public method | SelectAreaLowStyle | Returns the low area Style to use for the specified series.
Public method | SelectAreaNegativeStyle | Returns the negative area Style to use for the specified series.
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineNegativeStyle | Returns the negative line Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerFirstStyle | Returns the first marker Style to use for the specified series.
Public method | SelectMarkerHighStyle | Returns the high marker Style to use for the specified series.
Public method | SelectMarkerLastStyle | Returns the last marker Style to use for the specified series.
Public method | SelectMarkerLowStyle | Returns the low marker Style to use for the specified series.
Public method | SelectMarkerNegativeStyle | Returns the negative marker Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector Constructor

Initializes a new instance of the MicroSeriesStyleSelector class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesStyleSelector()
Public Sub New
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector Methods

The MicroSeriesStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectAreaHighStyle | Returns the high area Style to use for the specified series.
Public method | SelectAreaLowStyle | Returns the low area Style to use for the specified series.
Public method | SelectAreaNegativeStyle | Returns the negative area Style to use for the specified series.
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineNegativeStyle | Returns the negative line Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerFirstStyle | Returns the first marker Style to use for the specified series.
Public method | SelectMarkerHighStyle | Returns the high marker Style to use for the specified series.
Public method | SelectMarkerLastStyle | Returns the last marker Style to use for the specified series.
Public method | SelectMarkerLowStyle | Returns the low marker Style to use for the specified series.
Public method | SelectMarkerNegativeStyle | Returns the negative marker Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectAreaHighStyle Method

MicroSeriesStyleSelectorSelectAreaHighStyle Method

Returns the high area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaHighStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaHighStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectAreaLowStyle Method

MicroSeriesStyleSelectorSelectAreaLowStyle Method

Returns the low area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaLowStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaLowStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectAreaNegativeStyle Method

MicroSeriesStyleSelectorSelectAreaNegativeStyle Method

Returns the negative area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectAreaStyle Method

MicroSeriesStyleSelectorSelectAreaStyle Method

Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectLegendMarkerStyle Method

MicroSeriesStyleSelectorSelectLegendMarkerStyle Method

Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectLegendMarkerStyle(
    MicroXYSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLegendMarkerStyle (
    series As MicroXYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectLineNegativeStyle Method

MicroSeriesStyleSelectorSelectLineNegativeStyle Method

Returns the negative line Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectLineNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLineNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectLineStyle Method

MicroSeriesStyleSelectorSelectLineStyle Method

Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectLineStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLineStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerFirstStyle Method

MicroSeriesStyleSelectorSelectMarkerFirstStyle Method

Returns the first marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerFirstStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerFirstStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerHighStyle Method

MicroSeriesStyleSelectorSelectMarkerHighStyle Method

Returns the high marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerHighStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerHighStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerLastStyle Method

MicroSeriesStyleSelectorSelectMarkerLastStyle Method

Returns the last marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerLastStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerLastStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerLowStyle Method

MicroSeriesStyleSelectorSelectMarkerLowStyle Method

Returns the low marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerLowStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerLowStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerNegativeStyle Method

MicroSeriesStyleSelectorSelectMarkerNegativeStyle Method

Returns the negative marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerStyle Method

MicroSeriesStyleSelectorSelectMarkerStyle Method

Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelectorConverter Class

Represents a type converter for the MicroSeriesStyleSelector type.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.Windows.Controls.MicroChartsMicroSeriesStyleSelectorConverter

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class MicroSeriesStyleSelectorConverter : TypeConverter
Public NotInheritable Class MicroSeriesStyleSelectorConverter
    Inherits TypeConverter

The MicroSeriesStyleSelectorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSeriesStyleSelectorConverter | Initializes a new instance of the MicroSeriesStyleSelectorConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelectorConverter Constructor

Initializes a new instance of the MicroSeriesStyleSelectorConverter class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesStyleSelectorConverter()
Public Sub New
See Also

Reference

MicroSeriesStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelectorConverter Methods

The MicroSeriesStyleSelectorConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

MicroSeriesStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelectorConverter.CanConvertFrom Method

MicroSeriesStyleSelectorConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

MicroSeriesStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelectorConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

MicroSeriesStyleSelectorConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether the type converter can convert an object from the specified type to the type of this converter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
sourceType
Type: SystemType
The type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

MicroSeriesStyleSelectorConverter Class
CanConvertFrom Overload
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelectorConverter.ConvertFrom Method

MicroSeriesStyleSelectorConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

MicroSeriesStyleSelectorConverter Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroSeriesStyleSelectorConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

MicroSeriesStyleSelectorConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts from the specified value to the intended conversion type of the converter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The value to convert to the type of this converter.

Return Value

Type: Object
The converted value.
See Also

Reference

MicroSeriesStyleSelectorConverter Class
ConvertFrom Overload
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator Class

Represents a trend indicator.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroChartsMicroTrendIndicator

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroTrendIndicator : Control
Public Class MicroTrendIndicator
    Inherits Control

The MicroTrendIndicator type exposes the following members.

Constructors
 | Name | Description
Public method | MicroTrendIndicator | Initializes a new instance of the MicroTrendIndicator class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HigherTemplate | Gets or sets the DataTemplate to use for a higher value. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LowerTemplate | Gets or sets the DataTemplate to use for a lower value. This is a dependency property.
Public property | NeutralTemplate | Gets or sets the DataTemplate to use for a neutral value. This is a dependency property.
Public property | OriginValue | Gets or sets the origin value. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the current value. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
HigherTemplateProperty | Identifies the HigherTemplate dependency property. This field is read-only.
LowerTemplateProperty | Identifies the LowerTemplate dependency property. This field is read-only.
NeutralTemplateProperty | Identifies the NeutralTemplate dependency property. This field is read-only.
OriginValueProperty | Identifies the OriginValue dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator Constructor

Initializes a new instance of the MicroTrendIndicator class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroTrendIndicator()
Public Sub New
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator Properties

The MicroTrendIndicator type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HigherTemplate | Gets or sets the DataTemplate to use for a higher value. This is a dependency property.
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | LowerTemplate | Gets or sets the DataTemplate to use for a lower value. This is a dependency property.
Public property | NeutralTemplate | Gets or sets the DataTemplate to use for a neutral value. This is a dependency property.
Public property | OriginValue | Gets or sets the origin value. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | Value | Gets or sets the current value. This is a dependency property.
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.HigherTemplate Property

MicroTrendIndicatorHigherTemplate Property

Gets or sets the DataTemplate to use for a higher value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate HigherTemplate { get; set; }
Public Property HigherTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for a higher value.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.LowerTemplate Property

MicroTrendIndicatorLowerTemplate Property

Gets or sets the DataTemplate to use for a lower value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate LowerTemplate { get; set; }
Public Property LowerTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for a lower value.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.NeutralTemplate Property

MicroTrendIndicatorNeutralTemplate Property

Gets or sets the DataTemplate to use for a neutral value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate NeutralTemplate { get; set; }
Public Property NeutralTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for a neutral value.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.OriginValue Property

MicroTrendIndicatorOriginValue Property

Gets or sets the origin value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double OriginValue { get; set; }
Public Property OriginValue As Double
    Get
    Set

Property Value

Type: Double
The origin value. The default value is 0.0.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.Value Property

MicroTrendIndicatorValue Property

Gets or sets the current value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The current value. The default value is 0.0.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator Methods

The MicroTrendIndicator type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.OnApplyTemplate Method

MicroTrendIndicatorOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator Events

The MicroTrendIndicator type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator Fields

The MicroTrendIndicator type exposes the following members.

Fields
Name | Description
HigherTemplateProperty | Identifies the HigherTemplate dependency property. This field is read-only.
LowerTemplateProperty | Identifies the LowerTemplate dependency property. This field is read-only.
NeutralTemplateProperty | Identifies the NeutralTemplate dependency property. This field is read-only.
OriginValueProperty | Identifies the OriginValue dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.HigherTemplateProperty Field

MicroTrendIndicatorHigherTemplateProperty Field

Identifies the HigherTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HigherTemplateProperty
Public Shared ReadOnly HigherTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HigherTemplate dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.LowerTemplateProperty Field

MicroTrendIndicatorLowerTemplateProperty Field

Identifies the LowerTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LowerTemplateProperty
Public Shared ReadOnly LowerTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LowerTemplate dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.NeutralTemplateProperty Field

MicroTrendIndicatorNeutralTemplateProperty Field

Identifies the NeutralTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NeutralTemplateProperty
Public Shared ReadOnly NeutralTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NeutralTemplate dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.OriginValueProperty Field

MicroTrendIndicatorOriginValueProperty Field

Identifies the OriginValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OriginValueProperty
Public Shared ReadOnly OriginValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OriginValue dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroTrendIndicator.ValueProperty Field

MicroTrendIndicatorValueProperty Field

Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroWinLossSeries Class

Represents a win/loss series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroBarSeriesBase
ActiproSoftware.Windows.Controls.MicroChartsMicroWinLossSeries

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroWinLossSeries : MicroBarSeriesBase
Public Class MicroWinLossSeries
    Inherits MicroBarSeriesBase

The MicroWinLossSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroWinLossSeries | Initializes a new instance of the MicroWinLossSeries class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroBarSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Overrides MicroXYSeriesBaseRequiresNormalizedValues.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroBarSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroBarSeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroBarSeriesBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroWinLossSeries Constructor

Initializes a new instance of the MicroWinLossSeries class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroWinLossSeries()
Public Sub New
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroWinLossSeries Properties

The MicroWinLossSeries type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroBarSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Overrides MicroXYSeriesBaseRequiresNormalizedValues.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroBarSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroWinLossSeries.RequiresNormalizedValues Property

MicroWinLossSeriesRequiresNormalizedValues Property

Gets a value indicating whether the values presented by this series must be normalized.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool RequiresNormalizedValues { get; }
Protected Overrides ReadOnly Property RequiresNormalizedValues As Boolean
    Get

Property Value

Type: Boolean
true if the values presented by this series must be normalized; otherwise, false.
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroWinLossSeries Methods

The MicroWinLossSeries type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroBarSeriesBase.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroBarSeriesBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroWinLossSeries Events

The MicroWinLossSeries type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart Class

Represents a micro chart control that uses an X/Y coordinate system.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroChartBase
ActiproSoftware.Windows.Controls.MicroChartsMicroXYChart

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroXYChart : MicroChartBase
Public Class MicroXYChart
    Inherits MicroChartBase

The MicroXYChart type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYChart | Initializes a new instance of the MicroXYChart class.
Top
Properties
 | Name | Description
Public property | AxisBaselineStyle | Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.
Public property | AxisBaselineValue | Gets or sets the baseline value for the oriented axis. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAxisBaselineVisible | Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.
Public property | IsHotTrackingEnabled | Gets or sets a value indicating whether hot tracking is enabled, which is displays a tooltip with the associated value nearest the mouse cursor. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Ranges | Gets the collection of ranges displayed by this chart.
Public property | Series | Gets the collection of series displayed by this chart.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property. (Inherited from MicroChartBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxisMaximum | Gets or sets the maximum value along the X-axis. This is a dependency property.
Public property | XAxisMinimum | Gets or sets the minimum value along the X-axis. This is a dependency property.
Public property | YAxisMaximum | Gets or sets the maximum value along the Y-axis. This is a dependency property.
Public property | YAxisMinimum | Gets or sets the minimum value along the Y-axis. This is a dependency property.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Called before the MouseEnter event occurs. (Overrides UIElementOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | Called before the MouseLeave event occurs. (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseMove | Called before the MouseMove event occurs. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state. (Overrides MicroChartBaseRefresh.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
AxisBaselineStyleProperty | Identifies the AxisBaselineStyle dependency property. This field is read-only.
AxisBaselineValueProperty | Identifies the AxisBaselineValue dependency property. This field is read-only.
IsAxisBaselineVisibleProperty | Identifies the IsAxisBaselineVisible dependency property. This field is read-only.
IsHotTrackingEnabledProperty | Identifies the IsHotTrackingEnabled dependency property. This field is read-only.
XAxisMaximumProperty | Identifies the XAxisMaximum dependency property. This field is read-only.
XAxisMinimumProperty | Identifies the XAxisMinimum dependency property. This field is read-only.
YAxisMaximumProperty | Identifies the YAxisMaximum dependency property. This field is read-only.
YAxisMinimumProperty | Identifies the YAxisMinimum dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart Constructor

Initializes a new instance of the MicroXYChart class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYChart()
Public Sub New
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart Properties

The MicroXYChart type exposes the following members.

Properties
 | Name | Description
Public property | AxisBaselineStyle | Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.
Public property | AxisBaselineValue | Gets or sets the baseline value for the oriented axis. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAxisBaselineVisible | Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.
Public property | IsHotTrackingEnabled | Gets or sets a value indicating whether hot tracking is enabled, which is displays a tooltip with the associated value nearest the mouse cursor. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Ranges | Gets the collection of ranges displayed by this chart.
Public property | Series | Gets the collection of series displayed by this chart.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property. (Inherited from MicroChartBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XAxisMaximum | Gets or sets the maximum value along the X-axis. This is a dependency property.
Public property | XAxisMinimum | Gets or sets the minimum value along the X-axis. This is a dependency property.
Public property | YAxisMaximum | Gets or sets the maximum value along the Y-axis. This is a dependency property.
Public property | YAxisMinimum | Gets or sets the minimum value along the Y-axis. This is a dependency property.
Top
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.AxisBaselineStyle Property

MicroXYChartAxisBaselineStyle Property

Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style AxisBaselineStyle { get; set; }
Public Property AxisBaselineStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape element used to render the baseline along the chart. The default value is .
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.AxisBaselineValue Property

MicroXYChartAxisBaselineValue Property

Gets or sets the baseline value for the oriented axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object AxisBaselineValue { get; set; }
Public Property AxisBaselineValue As Object
    Get
    Set

Property Value

Type: Object
The baseline value for the oriented axis. The default value is , which indicates to automatically calculate the baseline value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.IsAxisBaselineVisible Property

MicroXYChartIsAxisBaselineVisible Property

Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAxisBaselineVisible { get; set; }
Public Property IsAxisBaselineVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a line is rendered at the baseline value; otherwise, false. The default value is false.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.IsHotTrackingEnabled Property

MicroXYChartIsHotTrackingEnabled Property

Gets or sets a value indicating whether hot tracking is enabled, which is displays a tooltip with the associated value nearest the mouse cursor. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsHotTrackingEnabled { get; set; }
Public Property IsHotTrackingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if hot tracking is enabled; otherwise, false. The default value is false.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.Ranges Property

MicroXYChartRanges Property

Gets the collection of ranges displayed by this chart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYRangeCollection Ranges { get; }
Public ReadOnly Property Ranges As MicroXYRangeCollection
    Get

Property Value

Type: MicroXYRangeCollection
The collection of ranges displayed by this chart.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.Series Property

MicroXYChartSeries Property

Gets the collection of series displayed by this chart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYSeriesCollection Series { get; }
Public ReadOnly Property Series As MicroXYSeriesCollection
    Get

Property Value

Type: MicroXYSeriesCollection
The collection of series displayed by this chart.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.XAxisMaximum Property

MicroXYChartXAxisMaximum Property

Gets or sets the maximum value along the X-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object XAxisMaximum { get; set; }
Public Property XAxisMaximum As Object
    Get
    Set

Property Value

Type: Object
The maximum value along the X-axis. The default value is , which indicates to automatically calculate the maximum value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.XAxisMinimum Property

MicroXYChartXAxisMinimum Property

Gets or sets the minimum value along the X-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object XAxisMinimum { get; set; }
Public Property XAxisMinimum As Object
    Get
    Set

Property Value

Type: Object
The minimum value along the X-axis. The default value is , which indicates to automatically calculate the minimum value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.YAxisMaximum Property

MicroXYChartYAxisMaximum Property

Gets or sets the maximum value along the Y-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object YAxisMaximum { get; set; }
Public Property YAxisMaximum As Object
    Get
    Set

Property Value

Type: Object
The maximum value along the Y-axis. The default value is , which indicates to automatically calculate the maximum value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.YAxisMinimum Property

MicroXYChartYAxisMinimum Property

Gets or sets the minimum value along the Y-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object YAxisMinimum { get; set; }
Public Property YAxisMinimum As Object
    Get
    Set

Property Value

Type: Object
The minimum value along the Y-axis. The default value is , which indicates to automatically calculate the minimum value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart Methods

The MicroXYChart type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseEnter | Called before the MouseEnter event occurs. (Overrides UIElementOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | Called before the MouseLeave event occurs. (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseMove | Called before the MouseMove event occurs. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state. (Overrides MicroChartBaseRefresh.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.OnApplyTemplate Method

MicroXYChartOnApplyTemplate Method

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.OnCreateAutomationPeer Method

MicroXYChartOnCreateAutomationPeer Method

When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.OnMouseEnter Method

MicroXYChartOnMouseEnter Method

Called before the MouseEnter event occurs.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseEnter(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseEnter (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The data for the event.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.OnMouseLeave Method

MicroXYChartOnMouseLeave Method

Called before the MouseLeave event occurs.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseLeave(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseLeave (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The data for the event.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.OnMouseMove Method

MicroXYChartOnMouseMove Method

Called before the MouseMove event occurs.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The data for the event.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.OnSizeChanged Method

MicroXYChartOnSizeChanged Method

Handles the SizeChanged event of the control.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    Object sender,
    SizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    sender As Object,
    e As SizeChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: System.WindowsSizeChangedEventArgs
The SizeChangedEventArgs instance containing the event data.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.Refresh Method

MicroXYChartRefresh Method

Updates the chart based on the current state.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart Events

The MicroXYChart type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart Fields

The MicroXYChart type exposes the following members.

Fields
Name | Description
AxisBaselineStyleProperty | Identifies the AxisBaselineStyle dependency property. This field is read-only.
AxisBaselineValueProperty | Identifies the AxisBaselineValue dependency property. This field is read-only.
IsAxisBaselineVisibleProperty | Identifies the IsAxisBaselineVisible dependency property. This field is read-only.
IsHotTrackingEnabledProperty | Identifies the IsHotTrackingEnabled dependency property. This field is read-only.
XAxisMaximumProperty | Identifies the XAxisMaximum dependency property. This field is read-only.
XAxisMinimumProperty | Identifies the XAxisMinimum dependency property. This field is read-only.
YAxisMaximumProperty | Identifies the YAxisMaximum dependency property. This field is read-only.
YAxisMinimumProperty | Identifies the YAxisMinimum dependency property. This field is read-only.
Top
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.AxisBaselineStyleProperty Field

MicroXYChartAxisBaselineStyleProperty Field

Identifies the AxisBaselineStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AxisBaselineStyleProperty
Public Shared ReadOnly AxisBaselineStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AxisBaselineStyle dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.AxisBaselineValueProperty Field

MicroXYChartAxisBaselineValueProperty Field

Identifies the AxisBaselineValue dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AxisBaselineValueProperty
Public Shared ReadOnly AxisBaselineValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AxisBaselineValue dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.IsAxisBaselineVisibleProperty Field

MicroXYChartIsAxisBaselineVisibleProperty Field

Identifies the IsAxisBaselineVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAxisBaselineVisibleProperty
Public Shared ReadOnly IsAxisBaselineVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAxisBaselineVisible dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.IsHotTrackingEnabledProperty Field

MicroXYChartIsHotTrackingEnabledProperty Field

Identifies the IsHotTrackingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHotTrackingEnabledProperty
Public Shared ReadOnly IsHotTrackingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHotTrackingEnabled dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.XAxisMaximumProperty Field

MicroXYChartXAxisMaximumProperty Field

Identifies the XAxisMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XAxisMaximumProperty
Public Shared ReadOnly XAxisMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XAxisMaximum dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.XAxisMinimumProperty Field

MicroXYChartXAxisMinimumProperty Field

Identifies the XAxisMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XAxisMinimumProperty
Public Shared ReadOnly XAxisMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XAxisMinimum dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.YAxisMaximumProperty Field

MicroXYChartYAxisMaximumProperty Field

Identifies the YAxisMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YAxisMaximumProperty
Public Shared ReadOnly YAxisMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YAxisMaximum dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYChart.YAxisMinimumProperty Field

MicroXYChartYAxisMinimumProperty Field

Identifies the YAxisMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YAxisMinimumProperty
Public Shared ReadOnly YAxisMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YAxisMinimum dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint Class

Represents a data point presented by a a MicroXYSeriesBase series.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroDataPointBase
ActiproSoftware.Windows.Controls.MicroChartsMicroXYDataPoint

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroXYDataPoint : MicroDataPointBase
Public Class MicroXYDataPoint
    Inherits MicroDataPointBase

The MicroXYDataPoint type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYDataPoint | Initializes a new instance of the MicroXYDataPoint class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point. (Inherited from MicroDataPointBase.)
Public property | StackedDataPoint | Gets the MicroXYDataPoint that this data point is stacked on top of.
Public property | XValue | Gets the X-value of the data point.
Public property | XValueResolved | Gets the resolved X-value of the data point.
Public property | YValue | Gets the Y-value of the data point.
Public property | YValueResolved | Gets the resolved Y-value of the data point.
Top
Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint Constructor

Initializes a new instance of the MicroXYDataPoint class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint()
Public Sub New
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint Properties

The MicroXYDataPoint type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point. (Inherited from MicroDataPointBase.)
Public property | StackedDataPoint | Gets the MicroXYDataPoint that this data point is stacked on top of.
Public property | XValue | Gets the X-value of the data point.
Public property | XValueResolved | Gets the resolved X-value of the data point.
Public property | YValue | Gets the Y-value of the data point.
Public property | YValueResolved | Gets the resolved Y-value of the data point.
Top
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint.StackedDataPoint Property

MicroXYDataPointStackedDataPoint Property

Gets the MicroXYDataPoint that this data point is stacked on top of.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint StackedDataPoint { get; }
Public ReadOnly Property StackedDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint.XValue Property

MicroXYDataPointXValue Property

Gets the X-value of the data point.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object XValue { get; }
Public ReadOnly Property XValue As Object
    Get

Property Value

Type: Object
The X-value of the data point.
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint.XValueResolved Property

MicroXYDataPointXValueResolved Property

Gets the resolved X-value of the data point.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object XValueResolved { get; }
Public ReadOnly Property XValueResolved As Object
    Get

Property Value

Type: Object
The resolved X-value of the data point.
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint.YValue Property

MicroXYDataPointYValue Property

Gets the Y-value of the data point.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object YValue { get; }
Public ReadOnly Property YValue As Object
    Get

Property Value

Type: Object
The Y-value of the data point.
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint.YValueResolved Property

MicroXYDataPointYValueResolved Property

Gets the resolved Y-value of the data point.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object YValueResolved { get; }
Public ReadOnly Property YValueResolved As Object
    Get

Property Value

Type: Object
The resolved Y-value of the data point.
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint Methods

The MicroXYDataPoint type exposes the following members.

Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPoint Events

The MicroXYDataPoint type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView Class

Represents a collection view that generates MicroXYDataPoint from a specified source collection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroDataPointCollectionViewBase MicroXYDataPoint
ActiproSoftware.Windows.Controls.MicroChartsMicroXYDataPointCollectionView

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class MicroXYDataPointCollectionView : MicroDataPointCollectionViewBase<MicroXYDataPoint>
Public NotInheritable Class MicroXYDataPointCollectionView
    Inherits MicroDataPointCollectionViewBase(Of MicroXYDataPoint)

The MicroXYDataPointCollectionView type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYDataPointCollectionView | Initializes a new instance of the MicroXYDataPointCollectionView class.
Top
Properties
 | Name | Description
Protected property | Collection | Gets or sets the IEnumerableT presented by this view. (Inherited from MicroDataPointCollectionViewBaseT.)
Public property | Count | Gets the number of records in the view. (Inherited from MicroDataPointCollectionViewBaseT.)
Public property | FirstDataPoint | Gets the first data point of the collection.
Public property | LastDataPoint | Gets the last data point of the collection.
Public property | MaxXDataPoint | Gets the maximum data point along the X-axis.
Public property | MaxXValue | Gets the maximum value along the X-axis.
Public property | MaxXValueResolved | Gets the maximum resolved value along the X-axis.
Public property | MaxYDataPoint | Gets the maximum data point along the Y-axis.
Public property | MaxYValue | Gets the maximum value along the Y-axis.
Public property | MaxYValueResolved | Gets the maximum resolved value along the Y-axis.
Public property | MinXDataPoint | Gets the minimum data point along the X-axis.
Public property | MinXValue | Gets the minimum value along the X-axis.
Public property | MinXValueResolved | Gets the minimum resolved value along the X-axis.
Public property | MinYDataPoint | Gets the minimum data point along the Y-axis.
Public property | MinYValue | Gets the minimum value along the Y-axis.
Public property | MinYValueResolved | Gets the minimum resolved value along the Y-axis.
Public property | XType | Gets the Type of data along the X-axis.
Public property | YType | Gets the Type of data along the X-axis.
Top
Methods
 | Name | Description
Protected method | EnsureInitialized | Ensures that this instance is currently initialized. (Inherited from MicroDataPointCollectionViewBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from MicroDataPointCollectionViewBaseT.)
Public method | GetItemFromXValue | Gets a MicroXYDataPoint associated with a specified X value, if that data is available.
Public method | GetItemFromYValue | Gets a MicroXYDataPoint associated with a specified Y value, if that data is available.
Public method | IndexOf | Returns the index at which the specified item is located. (Inherited from MicroDataPointCollectionViewBaseT.)
Protected method | Initialize | Initializes this instance. (Overrides MicroDataPointCollectionViewBaseTInitialize.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView Constructor

Initializes a new instance of the MicroXYDataPointCollectionView class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPointCollectionView(
    MicroXYSeriesBase series,
    Object baselineValue,
    int optimalAggregationCount
)
Public Sub New (
    series As MicroXYSeriesBase,
    baselineValue As Object,
    optimalAggregationCount As Integer
)

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The series associated with the view.
baselineValue
Type: SystemObject
The baseline value.
optimalAggregationCount
Type: SystemInt32
The optimal number of data points used when aggregation is enabled.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView Properties

The MicroXYDataPointCollectionView type exposes the following members.

Properties
 | Name | Description
Protected property | Collection | Gets or sets the IEnumerableT presented by this view. (Inherited from MicroDataPointCollectionViewBaseT.)
Public property | Count | Gets the number of records in the view. (Inherited from MicroDataPointCollectionViewBaseT.)
Public property | FirstDataPoint | Gets the first data point of the collection.
Public property | LastDataPoint | Gets the last data point of the collection.
Public property | MaxXDataPoint | Gets the maximum data point along the X-axis.
Public property | MaxXValue | Gets the maximum value along the X-axis.
Public property | MaxXValueResolved | Gets the maximum resolved value along the X-axis.
Public property | MaxYDataPoint | Gets the maximum data point along the Y-axis.
Public property | MaxYValue | Gets the maximum value along the Y-axis.
Public property | MaxYValueResolved | Gets the maximum resolved value along the Y-axis.
Public property | MinXDataPoint | Gets the minimum data point along the X-axis.
Public property | MinXValue | Gets the minimum value along the X-axis.
Public property | MinXValueResolved | Gets the minimum resolved value along the X-axis.
Public property | MinYDataPoint | Gets the minimum data point along the Y-axis.
Public property | MinYValue | Gets the minimum value along the Y-axis.
Public property | MinYValueResolved | Gets the minimum resolved value along the Y-axis.
Public property | XType | Gets the Type of data along the X-axis.
Public property | YType | Gets the Type of data along the X-axis.
Top
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.FirstDataPoint Property

MicroXYDataPointCollectionViewFirstDataPoint Property

Gets the first data point of the collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint FirstDataPoint { get; }
Public ReadOnly Property FirstDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.LastDataPoint Property

MicroXYDataPointCollectionViewLastDataPoint Property

Gets the last data point of the collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint LastDataPoint { get; }
Public ReadOnly Property LastDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxXDataPoint Property

MicroXYDataPointCollectionViewMaxXDataPoint Property

Gets the maximum data point along the X-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint MaxXDataPoint { get; }
Public ReadOnly Property MaxXDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxXValue Property

MicroXYDataPointCollectionViewMaxXValue Property

Gets the maximum value along the X-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object MaxXValue { get; }
Public ReadOnly Property MaxXValue As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxXValueResolved Property

MicroXYDataPointCollectionViewMaxXValueResolved Property

Gets the maximum resolved value along the X-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object MaxXValueResolved { get; }
Public ReadOnly Property MaxXValueResolved As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxYDataPoint Property

MicroXYDataPointCollectionViewMaxYDataPoint Property

Gets the maximum data point along the Y-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint MaxYDataPoint { get; }
Public ReadOnly Property MaxYDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxYValue Property

MicroXYDataPointCollectionViewMaxYValue Property

Gets the maximum value along the Y-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object MaxYValue { get; }
Public ReadOnly Property MaxYValue As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxYValueResolved Property

MicroXYDataPointCollectionViewMaxYValueResolved Property

Gets the maximum resolved value along the Y-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object MaxYValueResolved { get; }
Public ReadOnly Property MaxYValueResolved As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinXDataPoint Property

MicroXYDataPointCollectionViewMinXDataPoint Property

Gets the minimum data point along the X-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint MinXDataPoint { get; }
Public ReadOnly Property MinXDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinXValue Property

MicroXYDataPointCollectionViewMinXValue Property

Gets the minimum value along the X-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object MinXValue { get; }
Public ReadOnly Property MinXValue As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinXValueResolved Property

MicroXYDataPointCollectionViewMinXValueResolved Property

Gets the minimum resolved value along the X-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object MinXValueResolved { get; }
Public ReadOnly Property MinXValueResolved As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinYDataPoint Property

MicroXYDataPointCollectionViewMinYDataPoint Property

Gets the minimum data point along the Y-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint MinYDataPoint { get; }
Public ReadOnly Property MinYDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinYValue Property

MicroXYDataPointCollectionViewMinYValue Property

Gets the minimum value along the Y-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object MinYValue { get; }
Public ReadOnly Property MinYValue As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinYValueResolved Property

MicroXYDataPointCollectionViewMinYValueResolved Property

Gets the minimum resolved value along the Y-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object MinYValueResolved { get; }
Public ReadOnly Property MinYValueResolved As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.XType Property

MicroXYDataPointCollectionViewXType Property

Gets the Type of data along the X-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type XType { get; }
Public ReadOnly Property XType As Type
    Get

Property Value

Type: Type
The Type of data along the X-axis.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.YType Property

MicroXYDataPointCollectionViewYType Property

Gets the Type of data along the X-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Type YType { get; }
Public ReadOnly Property YType As Type
    Get

Property Value

Type: Type
The Type of data along the X-axis.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView Methods

The MicroXYDataPointCollectionView type exposes the following members.

Methods
 | Name | Description
Protected method | EnsureInitialized | Ensures that this instance is currently initialized. (Inherited from MicroDataPointCollectionViewBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from MicroDataPointCollectionViewBaseT.)
Public method | GetItemFromXValue | Gets a MicroXYDataPoint associated with a specified X value, if that data is available.
Public method | GetItemFromYValue | Gets a MicroXYDataPoint associated with a specified Y value, if that data is available.
Public method | IndexOf | Returns the index at which the specified item is located. (Inherited from MicroDataPointCollectionViewBaseT.)
Protected method | Initialize | Initializes this instance. (Overrides MicroDataPointCollectionViewBaseTInitialize.)
Top
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.GetItemFromXValue Method

MicroXYDataPointCollectionViewGetItemFromXValue Method

Gets a MicroXYDataPoint associated with a specified X value, if that data is available.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint GetItemFromXValue(
    Object value
)
Public Function GetItemFromXValue (
    value As Object
) As MicroXYDataPoint

Parameters

value
Type: SystemObject
The X value.

Return Value

Type: MicroXYDataPoint
A MicroXYDataPoint associated with a specified X value, if that data is available.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.GetItemFromYValue Method

MicroXYDataPointCollectionViewGetItemFromYValue Method

Gets a MicroXYDataPoint associated with a specified Y value, if that data is available.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPoint GetItemFromYValue(
    Object value
)
Public Function GetItemFromYValue (
    value As Object
) As MicroXYDataPoint

Parameters

value
Type: SystemObject
The Y value.

Return Value

Type: MicroXYDataPoint
A MicroXYDataPoint associated with a specified Y value, if that data is available.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.Initialize Method

MicroXYDataPointCollectionViewInitialize Method

Initializes this instance.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void Initialize()
Protected Overrides Sub Initialize
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange Class

Represents a range for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroChartsMicroXYRange

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroXYRange : Control
Public Class MicroXYRange
    Inherits Control

The MicroXYRange type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYRange | Initializes a new instance of the MicroXYRange class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this range.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value of the range. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value of the range. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the range. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotRange | Plots the range to the associated chart using the specified plotter.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the range based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange Constructor

Initializes a new instance of the MicroXYRange class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYRange()
Public Sub New
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange Properties

The MicroXYRange type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this range.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value of the range. This is a dependency property.
Public property | Minimum | Gets or sets the minimum value of the range. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the range. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange.Chart Property

MicroXYRangeChart Property

Gets the MicroXYChart that owns this range.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYChart Chart { get; }
Public ReadOnly Property Chart As MicroXYChart
    Get

Property Value

Type: MicroXYChart
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange.Maximum Property

MicroXYRangeMaximum Property

Gets or sets the maximum value of the range. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Maximum { get; set; }
Public Property Maximum As Object
    Get
    Set

Property Value

Type: Object
The maximum value of the range. The default value is .
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange.Minimum Property

MicroXYRangeMinimum Property

Gets or sets the minimum value of the range. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Object Minimum { get; set; }
Public Property Minimum As Object
    Get
    Set

Property Value

Type: Object
The minimum value of the range. The default value is .
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange.Orientation Property

MicroXYRangeOrientation Property

Gets or sets the orientation of the range. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the range. The default value is Orientation.Horizontal.
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange Methods

The MicroXYRange type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotRange | Plots the range to the associated chart using the specified plotter.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the range based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange.PlotRange Method

MicroXYRangePlotRange Method

Plots the range to the associated chart using the specified plotter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void PlotRange(
    MicroXYChartPlotter plotter
)
Protected Overridable Sub PlotRange (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange.Refresh Method

MicroXYRangeRefresh Method

Updates the range based on the current state.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange Events

The MicroXYRange type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange Fields

The MicroXYRange type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange.MaximumProperty Field

MicroXYRangeMaximumProperty Field

Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange.MinimumProperty Field

MicroXYRangeMinimumProperty Field

Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRange.OrientationProperty Field

MicroXYRangeOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroXYRange Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRangeCollection Class

Represents a collection of MicroXYRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection MicroXYRange
System.Collections.ObjectModelObservableCollection MicroXYRange
ActiproSoftware.WindowsDeferrableObservableCollection MicroXYRange
ActiproSoftware.Windows.Controls.MicroChartsMicroXYRangeCollection

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroXYRangeCollection : DeferrableObservableCollection<MicroXYRange>
Public Class MicroXYRangeCollection
    Inherits DeferrableObservableCollection(Of MicroXYRange)

The MicroXYRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYRangeCollection | Initializes a new instance of the MicroXYRangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection MicroXYRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection MicroXYRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection MicroXYRange .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection MicroXYRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection MicroXYRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection MicroXYRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection MicroXYRange .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection MicroXYRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection MicroXYRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection MicroXYRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection MicroXYRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection MicroXYRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroXYRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroXYRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection MicroXYRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection MicroXYRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection MicroXYRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection MicroXYRange .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRangeCollection Constructor

Initializes a new instance of the MicroXYRangeCollection class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYRangeCollection(
    MicroXYChart chart
)
Public Sub New (
    chart As MicroXYChart
)

Parameters

chart
Type: ActiproSoftware.Windows.Controls.MicroChartsMicroXYChart
The MicroXYChart that owns this collection and the associated ranges.
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRangeCollection Properties

The MicroXYRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection MicroXYRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection MicroXYRange .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection MicroXYRange .)
Top
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRangeCollection Methods

The MicroXYRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection MicroXYRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection MicroXYRange .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection MicroXYRange .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection MicroXYRange .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection MicroXYRange .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection MicroXYRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection MicroXYRange .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection MicroXYRange .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection MicroXYRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroXYRange .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroXYRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection MicroXYRange .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection MicroXYRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRangeCollection.ClearItems Method

MicroXYRangeCollectionClearItems Method

Removes all items from the collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRangeCollection.InsertItem Method

MicroXYRangeCollectionInsertItem Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    MicroXYRange item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As MicroXYRange
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: ActiproSoftware.Windows.Controls.MicroChartsMicroXYRange
The object to insert.
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRangeCollection.RemoveItem Method

MicroXYRangeCollectionRemoveItem Method

Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRangeCollection.SetItem Method

MicroXYRangeCollectionSetItem Method

Replaces the element at the specified index.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    MicroXYRange item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As MicroXYRange
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to replace.
item
Type: ActiproSoftware.Windows.Controls.MicroChartsMicroXYRange
The new value for the element at the specified index.
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYRangeCollection Events

The MicroXYRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection MicroXYRange .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection MicroXYRange .)
Top
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesCollection Class

Represents a collection of MicroXYSeriesBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection MicroXYSeriesBase
System.Collections.ObjectModelObservableCollection MicroXYSeriesBase
ActiproSoftware.WindowsDeferrableObservableCollection MicroXYSeriesBase
ActiproSoftware.Windows.Controls.MicroChartsMicroXYSeriesCollection

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroXYSeriesCollection : DeferrableObservableCollection<MicroXYSeriesBase>
Public Class MicroXYSeriesCollection
    Inherits DeferrableObservableCollection(Of MicroXYSeriesBase)

The MicroXYSeriesCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYSeriesCollection | Initializes a new instance of the MicroXYChart class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection MicroXYSeriesBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection MicroXYSeriesBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection MicroXYSeriesBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection MicroXYSeriesBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection MicroXYSeriesBase .)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesCollection Constructor

Initializes a new instance of the MicroXYChart class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYSeriesCollection(
    MicroXYChart chart
)
Public Sub New (
    chart As MicroXYChart
)

Parameters

chart
Type: ActiproSoftware.Windows.Controls.MicroChartsMicroXYChart
The MicroXYChart that owns this collection and the associated series.
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesCollection Properties

The MicroXYSeriesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection MicroXYSeriesBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Top
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesCollection Methods

The MicroXYSeriesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection MicroXYSeriesBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection MicroXYSeriesBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection MicroXYSeriesBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection MicroXYSeriesBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Top
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesCollection.ClearItems Method

MicroXYSeriesCollectionClearItems Method

Removes all items from the collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesCollection.InsertItem Method

MicroXYSeriesCollectionInsertItem Method

Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    MicroXYSeriesBase item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As MicroXYSeriesBase
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The object to insert.
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesCollection.RemoveItem Method

MicroXYSeriesCollectionRemoveItem Method

Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesCollection.SetItem Method

MicroXYSeriesCollectionSetItem Method

Replaces the element at the specified index.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    MicroXYSeriesBase item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As MicroXYSeriesBase
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to replace.
item
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The new value for the element at the specified index.
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesCollection Events

The MicroXYSeriesCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection MicroXYSeriesBase .)
Top
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesLineKind Enumeration

Specifies the line kinds supported by a MicroLineSeries and MicroAreaSeries series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroXYSeriesLineKind
Public Enumeration MicroXYSeriesLineKind
Members
Member name | Value | Description
Normal | 0 | Indicates a normal line will be used to connect the data points.
Spline | 1 | Indicates a spline will be used to connect the data points.
Step | 2 | Indicates stepped lines will be used to connect the data points.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


MicroXYSeriesStackKind Enumeration

Specifies the stacking methods supported by a MicroXYSeriesBase series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroXYSeriesStackKind
Public Enumeration MicroXYSeriesStackKind
Members
Member name | Value | Description
None | 0 | Indicates the series will not be stacked.
Normal | 1 | Indicates the series will be stacked by adding its values to the values of other stacked series.
Percentage | 2 | Indicates the series will be stacked by calculating percentages of its values based on the total values of all stacked series.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts Namespace


ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers Namespace

Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | AutomationPeerBaseT | The base implementation for Automation Peers.


AutomationPeerBase(T) Class

AutomationPeerBaseT Class

The base implementation for Automation Peers.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.Automation.PeersAutomationPeer
System.Windows.Automation.PeersUIElementAutomationPeer
System.Windows.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.Windows.Controls.MicroCharts.Automation.PeersAutomationPeerBaseT

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class AutomationPeerBase<T> : FrameworkElementAutomationPeer
where T : FrameworkElement

Public Class AutomationPeerBase(Of T As FrameworkElement)
    Inherits FrameworkElementAutomationPeer

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers.AutomationPeerBase`1"]

The AutomationPeerBaseT type exposes the following members.

Constructors
 | Name | Description
Public method | AutomationPeerBaseT | Initializes a new instance of the AutomationPeerBase class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T) Constructor

AutomationPeerBaseT Constructor

Initializes a new instance of the AutomationPeerBase class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public AutomationPeerBase(
    T owner
)
Public Sub New (
    owner As T
)

Parameters

owner
Type: T
The owner.
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T) Properties

AutomationPeerBaseT Properties

The AutomationPeerBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as a source for all the events that come from this AutomationPeer. (Inherited from AutomationPeer.)
Protected property | IsHwndHost | Gets a value that indicates whether the element that is associated with this AutomationPeer hosts hwnds in Windows Presentation Foundation (WPF). (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Top
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T) Methods

AutomationPeerBaseT Methods

The AutomationPeerBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Gets the accelerator key for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAcceleratorKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Gets the access key for the UIElement that is associated with this UIElementAutomationPeer.This method is called by GetAccessKey. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetAutomationControlType. (Inherited from UIElementAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. Called by GetAutomationId. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Gets the Rect that represents the bounding rectangle of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetBoundingRectangle. (Inherited from UIElementAutomationPeer.)
Public method | GetChildren | Gets the collection of GetChildren elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren. (Overrides UIElementAutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides UIElementAutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a Point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a Point that represents the clickable space that is on the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetClickablePoint. (Inherited from UIElementAutomationPeer.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Gets the string that describes the functionality of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetHelpText. (Inherited from FrameworkElementAutomationPeer.)
Protected method | GetHostRawElementProviderCore | Tells UI Automation where in the UI Automation tree to place the hwnd being hosted by a Windows Presentation Foundation (WPF) element. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets a string that communicates the visual status of the UIElement that is associated with this UIElementAutomationPeer. This method is called by GetItemStatus. (Inherited from UIElementAutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an object represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Gets a human-readable string that contains the item type that the UIElement for this UIElementAutomationPeer represents. This method is called by GetItemType. (Inherited from UIElementAutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the Label that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Gets the AutomationPeer for the element that is targeted to the UIElement for this UIElementAutomationPeer. This method is called by GetLabeledBy. (Inherited from UIElementAutomationPeer.)
Public method | GetLocalizedControlType | Gets a human-readable localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | When overridden in a derived class, is called by GetLocalizedControlType. (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text label of the ContentElement that is associated with this ContentElementAutomationPeer. Called by GetName. (Inherited from FrameworkElementAutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is laid out in a specific direction. This method is called by GetOrientation. (Inherited from UIElementAutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern for the UIElement that is associated with this UIElementAutomationPeer. (Inherited from UIElementAutomationPeer.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer currently has keyboard input focus. This method is called by HasKeyboardFocus. (Inherited from UIElementAutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the Automation Client if the properties changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is an element that contains data that is presented to the user. This method is called by IsContentElement. (Inherited from UIElementAutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Gets or sets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is understood by the end user as interactive. Optionally, the user might understand the UIElement as contributing to the logical structure of the control in the GUI. This method is called by IsControlElement. (Inherited from UIElementAutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer can accept keyboard focus. This method is called by IsKeyboardFocusable. (Inherited from UIElementAutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is off the screen. This method is called by IsOffscreen. (Inherited from UIElementAutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer contains protected content. This method is called by IsPassword. (Inherited from UIElementAutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Gets a value that indicates whether the UIElement that is associated with this UIElementAutomationPeer is required to be completed on a form. This method is called by IsRequiredForForm. (Inherited from UIElementAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAsyncContentLoadedEvent | Called by the AutomationPeer to raise the AsyncContentLoadedEvent event. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | ResetChildrenCache | Synchronously resets the tree of child elements by calling GetChildrenCore. (Inherited from AutomationPeer.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Sets the keyboard input focus on the UIElement that is associated with this UIElementAutomationPeer. This method is called by SetFocus. (Inherited from UIElementAutomationPeer.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T).GetChildrenCore Method

AutomationPeerBaseTGetChildrenCore Method

Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override List<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As List(Of AutomationPeer)

Return Value

Type: List AutomationPeer
A list of child AutomationPeer elements.
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T).GetClassNameCore Method

AutomationPeerBaseTGetClassNameCore Method

Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The string that contains the name.
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Automation.Peers Namespace


ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace

Contains types related to micro chart palettes.
Classes
 | Class | Description
Public class | MicroPalette | Provides a palette of colors for use in charts.
Public class | MicroSeriesPaletteStyleSelector | Provides a way to apply series styles based on a palette of colors.
Enumerations
 | Enumeration | Description
Public enumeration | MicroColorSelectionHint | Specifies a hint for how a MicroSeriesPaletteStyleSelector should select colors for a series.
Public enumeration | MicroPaletteKind | Specifies the built-in palette options for a MicroSeriesPaletteStyleSelector.
Public enumeration | MicroSeriesBrushKind | Specifies the kind of brush to use for a series element.


MicroColorSelectionHint Enumeration

Specifies a hint for how a MicroSeriesPaletteStyleSelector should select colors for a series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroColorSelectionHint
Public Enumeration MicroColorSelectionHint
Members
Member name | Value | Description
Sequential | 0 | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
UniformDistribution | 1 | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette Class

Provides a palette of colors for use in charts.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.MicroCharts.PalettesMicroPalette

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroPalette
Public Class MicroPalette

The MicroPalette type exposes the following members.

Constructors
 | Name | Description
Public method | MicroPalette | Initializes a new instance of the MicroPalette class.
Public method | MicroPalette(Color) | Initializes a new instance of the MicroPalette class.
Public method | MicroPalette(MicroPaletteKind) | Initializes a new instance of the MicroPalette class.
Top
Properties
 | Name | Description
Public property | BaseColors | Gets the collection of palette base Color objects used to generate the palette.
Public property | Colors | Gets the read-only collection of Color objects in this palette.
Public property | ColorSelectionHint | Gets or sets a MicroColorSelectionHint that provides a hint on how to perform color selection for this palette.
Public property | IsShadeGenerationEnabled | Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.
Public property | Kind | Gets or sets a MicroPaletteKind that indicates the built-in palette to use.
Top
Methods
 | Name | Description
Protected method | OnChanged | Raises the Changed event.
Top
Events
 | Name | Description
Public event | Changed | Occurs after the palette has been changed.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette Constructor

Overload List
 | Name | Description
Public method | MicroPalette | Initializes a new instance of the MicroPalette class.
Public method | MicroPalette(Color) | Initializes a new instance of the MicroPalette class.
Public method | MicroPalette(MicroPaletteKind) | Initializes a new instance of the MicroPalette class.
Top
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette Constructor

Initializes a new instance of the MicroPalette class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroPalette()
Public Sub New
See Also

Reference

MicroPalette Class
MicroPalette Overload
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette Constructor (Color[])

MicroPalette Constructor (Color)

Initializes a new instance of the MicroPalette class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroPalette(
    params Color[] paletteBaseColors
)
Public Sub New (
    ParamArray paletteBaseColors As Color()
)

Parameters

paletteBaseColors
Type: System.Windows.MediaColor
The palette Color values.
See Also

Reference

MicroPalette Class
MicroPalette Overload
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette Constructor (MicroPaletteKind)

Initializes a new instance of the MicroPalette class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroPalette(
    MicroPaletteKind kind
)
Public Sub New (
    kind As MicroPaletteKind
)

Parameters

kind
Type: ActiproSoftware.Windows.Controls.MicroCharts.PalettesMicroPaletteKind
A MicroPaletteKind that indicates the built-in palette to use.
See Also

Reference

MicroPalette Class
MicroPalette Overload
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette Properties

The MicroPalette type exposes the following members.

Properties
 | Name | Description
Public property | BaseColors | Gets the collection of palette base Color objects used to generate the palette.
Public property | Colors | Gets the read-only collection of Color objects in this palette.
Public property | ColorSelectionHint | Gets or sets a MicroColorSelectionHint that provides a hint on how to perform color selection for this palette.
Public property | IsShadeGenerationEnabled | Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.
Public property | Kind | Gets or sets a MicroPaletteKind that indicates the built-in palette to use.
Top
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette.BaseColors Property

MicroPaletteBaseColors Property

Gets the collection of palette base Color objects used to generate the palette.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ObservableCollection<Color> BaseColors { get; }
Public ReadOnly Property BaseColors As ObservableCollection(Of Color)
    Get

Property Value

Type: ObservableCollection Color
The collection of palette base Color objects used to generate the palette.
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette.Colors Property

MicroPaletteColors Property

Gets the read-only collection of Color objects in this palette.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public ReadOnlyObservableCollection<Color> Colors { get; }
Public ReadOnly Property Colors As ReadOnlyObservableCollection(Of Color)
    Get

Property Value

Type: ReadOnlyObservableCollection Color
The read-only collection of Color objects in this palette.
Remarks
This collection includes the BaseColors values, along with other shade variants if the IsShadeGenerationEnabled property is set to true.
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroPaletteIsShadeGenerationEnabled


MicroPalette.ColorSelectionHint Property

MicroPaletteColorSelectionHint Property

Gets or sets a MicroColorSelectionHint that provides a hint on how to perform color selection for this palette.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroColorSelectionHint ColorSelectionHint { get; set; }
Public Property ColorSelectionHint As MicroColorSelectionHint
    Get
    Set

Property Value

Type: MicroColorSelectionHint
A MicroColorSelectionHint that provides a hint on how to perform color selection for this palette. The default hint is UniformDistribution.
Remarks
See the documentation on the MicroColorSelectionHint for more information on usage.
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette.IsShadeGenerationEnabled Property

MicroPaletteIsShadeGenerationEnabled Property

Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsShadeGenerationEnabled { get; set; }
Public Property IsShadeGenerationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if shade generation is enabled; otherwise, false.
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette.Kind Property

MicroPaletteKind Property

Gets or sets a MicroPaletteKind that indicates the built-in palette to use.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroPaletteKind Kind { get; set; }
Public Property Kind As MicroPaletteKind
    Get
    Set

Property Value

Type: MicroPaletteKind
A MicroPaletteKind that indicates the built-in palette to use.
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette Methods

The MicroPalette type exposes the following members.

Methods
 | Name | Description
Protected method | OnChanged | Raises the Changed event.
Top
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette.OnChanged Method

MicroPaletteOnChanged Method

Raises the Changed event.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnChanged(
    EventArgs e
)
Protected Overridable Sub OnChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette Events

The MicroPalette type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the palette has been changed.
Top
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPalette.Changed Event

MicroPaletteChanged Event

Occurs after the palette has been changed.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event EventHandler Changed
Public Event Changed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

MicroPalette Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind Enumeration

Specifies the built-in palette options for a MicroSeriesPaletteStyleSelector.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroPaletteKind
Public Enumeration MicroPaletteKind
Members
Member name | Value | Description
Default | 0 | The default colors.
Autumn | 1 | Red to green colors.
Beach | 2 | Blue, yellow, and green colors.
Earth | 3 | Yellow and brown colors.
Fishbowl | 4 | Blue, tan, and orange colors.
Forest | 5 | Green, blue, and brown colors.
IceCream | 6 | Muted blue, beige, and pink colors.
Melon | 7 | Muted pastel colors.
Mesa | 8 | Blue/green, tan, and red colors.
Plum | 9 | Purple colors.
Rainbow | 10 | Rainbow colors.
Retro | 11 | Purple, orange, and green colors.
Roman | 12 | Red, tan, and blue colors.
Rose | 13 | Rose reddish colors.
Sand | 14 | Muted blue and tan colors.
Sea | 15 | Blue and green colors.
Tulip | 16 | Red, green, yellow, and purple colors.
Vibrant | 17 | Magenta, blue, and green colors.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind Enumeration

Specifies the kind of brush to use for a series element.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public enum MicroSeriesBrushKind
Public Enumeration MicroSeriesBrushKind
Members
Member name | Value | Description
Default | 0 | Use the exact palette color.
Light | 1 | Use a slightly lighter version of the palette color.
Dark | 2 | Use a slightly darker version of the palette color.
SemiTransparent | 3 | Use a semi-transparent version of the palette color.
DarkToLightGradient | 4 | Use a gradient, from the Dark to Light color.
LightToDarkGradient | 5 | Use a gradient, from the Light to Dark color.
Complement | 6 | Use a complement of the Default color.
ComplementLight | 7 | Use a complement of the Light color.
ComplementDark | 8 | Use a complement of the Dark color.
ComplementSemiTransparent | 9 | Use a semi-transparent version of the Complement color.
ComplementDarkToLightGradient | 10 | Use a gradient, from the ComplementDark to ComplementLight color.
ComplementLightToDarkGradient | 11 | Use a gradient, from the ComplementLight to ComplementDark color.
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Class

Provides a way to apply series styles based on a palette of colors.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.MicroChartsMicroSeriesStyleSelector
ActiproSoftware.Windows.Controls.MicroCharts.PalettesMicroSeriesPaletteStyleSelector

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroSeriesPaletteStyleSelector : MicroSeriesStyleSelector
Public Class MicroSeriesPaletteStyleSelector
    Inherits MicroSeriesStyleSelector

The MicroSeriesPaletteStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSeriesPaletteStyleSelector | Initializes a new instance of the MicroSeriesPaletteStyleSelector class.
Public method | MicroSeriesPaletteStyleSelector(MicroPalette) | Initializes a new instance of the MicroSeriesPaletteStyleSelector class.
Top
Properties
 | Name | Description
Public property | AreaBrushCustom | Gets or sets the custom Brush to use for areas.
Public property | AreaBrushKind | Gets or sets the kind of brush to use for areas.
Public property | AreaHighBrushCustom | Gets or sets the custom Brush to use for the high area.
Public property | AreaHighBrushKind | Gets or sets the kind of brush to use for the high area.
Public property | AreaHighTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaHighBrushKind setting.
Public property | AreaLowBrushCustom | Gets or sets the custom Brush to use for the low area.
Public property | AreaLowBrushKind | Gets or sets the kind of brush to use for the low area.
Public property | AreaLowTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaLowBrushKind setting.
Public property | AreaNegativeBrushCustom | Gets or sets the custom Brush to use for negative areas.
Public property | AreaNegativeBrushKind | Gets or sets the kind of brush to use for negative areas.
Public property | AreaNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaNegativeBrushKind setting.
Public property | AreaTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.
Public property | LineBrushCustom | Gets or sets the custom Brush to use for lines.
Public property | LineBrushKind | Gets or sets the kind of brush to use for lines.
Public property | LineNegativeBrushCustom | Gets or sets the custom Brush to use for negative lines.
Public property | LineNegativeBrushKind | Gets or sets the kind of brush to use for negative lines.
Public property | LineNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the LineNegativeBrushKind setting.
Public property | LineTintColor | Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.
Public property | MarkerBrushCustom | Gets or sets the custom Brush to use for markers.
Public property | MarkerBrushKind | Gets or sets the kind of brush to use for markers.
Public property | MarkerFirstBrushCustom | Gets or sets the custom Brush to use for the first marker.
Public property | MarkerFirstBrushKind | Gets or sets the kind of brush to use for the first marker.
Public property | MarkerFirstTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerFirstBrushKind setting.
Public property | MarkerHighBrushCustom | Gets or sets the custom Brush to use for the high marker.
Public property | MarkerHighBrushKind | Gets or sets the kind of brush to use for the high marker.
Public property | MarkerHighTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerHighBrushKind setting.
Public property | MarkerLastBrushCustom | Gets or sets the custom Brush to use for the last marker.
Public property | MarkerLastBrushKind | Gets or sets the kind of brush to use for the last marker.
Public property | MarkerLastTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerLastBrushKind setting.
Public property | MarkerLowBrushCustom | Gets or sets the custom Brush to use for the low marker.
Public property | MarkerLowBrushKind | Gets or sets the kind of brush to use for the low marker.
Public property | MarkerLowTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerLowBrushKind setting.
Public property | MarkerNegativeBrushCustom | Gets or sets the custom Brush to use for negative markers.
Public property | MarkerNegativeBrushKind | Gets or sets the kind of brush to use for negative markers.
Public property | MarkerNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerNegativeBrushKind setting.
Public property | MarkerTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.
Public property | Palette | Gets or sets the MicroPalette of colors to use.
Top
Methods
 | Name | Description
Public method | SelectAreaHighStyle | Returns the high area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaHighStyle(MicroSeriesBase, Style).)
Public method | SelectAreaLowStyle | Returns the low area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaLowStyle(MicroSeriesBase, Style).)
Public method | SelectAreaNegativeStyle | Returns the negative area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaStyle(MicroSeriesBase, Style).)
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLegendMarkerStyle(MicroXYSeriesBase, Style).)
Public method | SelectLineNegativeStyle | Returns the negative line Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLineNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectLineStyle | Returns the line Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLineStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerFirstStyle | Returns the first marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerFirstStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerHighStyle | Returns the high marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerHighStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerLastStyle | Returns the last marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerLastStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerLowStyle | Returns the low marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerLowStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerNegativeStyle | Returns the negative marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerStyle(MicroSeriesBase, Style).)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Constructor

Overload List
 | Name | Description
Public method | MicroSeriesPaletteStyleSelector | Initializes a new instance of the MicroSeriesPaletteStyleSelector class.
Public method | MicroSeriesPaletteStyleSelector(MicroPalette) | Initializes a new instance of the MicroSeriesPaletteStyleSelector class.
Top
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Constructor

Initializes a new instance of the MicroSeriesPaletteStyleSelector class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesPaletteStyleSelector()
Public Sub New
See Also

Reference

MicroSeriesPaletteStyleSelector Class
MicroSeriesPaletteStyleSelector Overload
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Constructor (MicroPalette)

Initializes a new instance of the MicroSeriesPaletteStyleSelector class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesPaletteStyleSelector(
    MicroPalette palette
)
Public Sub New (
    palette As MicroPalette
)

Parameters

palette
Type: ActiproSoftware.Windows.Controls.MicroCharts.PalettesMicroPalette
The MicroPalette of colors to use.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
MicroSeriesPaletteStyleSelector Overload
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Properties

The MicroSeriesPaletteStyleSelector type exposes the following members.

Properties
 | Name | Description
Public property | AreaBrushCustom | Gets or sets the custom Brush to use for areas.
Public property | AreaBrushKind | Gets or sets the kind of brush to use for areas.
Public property | AreaHighBrushCustom | Gets or sets the custom Brush to use for the high area.
Public property | AreaHighBrushKind | Gets or sets the kind of brush to use for the high area.
Public property | AreaHighTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaHighBrushKind setting.
Public property | AreaLowBrushCustom | Gets or sets the custom Brush to use for the low area.
Public property | AreaLowBrushKind | Gets or sets the kind of brush to use for the low area.
Public property | AreaLowTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaLowBrushKind setting.
Public property | AreaNegativeBrushCustom | Gets or sets the custom Brush to use for negative areas.
Public property | AreaNegativeBrushKind | Gets or sets the kind of brush to use for negative areas.
Public property | AreaNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaNegativeBrushKind setting.
Public property | AreaTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.
Public property | LineBrushCustom | Gets or sets the custom Brush to use for lines.
Public property | LineBrushKind | Gets or sets the kind of brush to use for lines.
Public property | LineNegativeBrushCustom | Gets or sets the custom Brush to use for negative lines.
Public property | LineNegativeBrushKind | Gets or sets the kind of brush to use for negative lines.
Public property | LineNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the LineNegativeBrushKind setting.
Public property | LineTintColor | Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.
Public property | MarkerBrushCustom | Gets or sets the custom Brush to use for markers.
Public property | MarkerBrushKind | Gets or sets the kind of brush to use for markers.
Public property | MarkerFirstBrushCustom | Gets or sets the custom Brush to use for the first marker.
Public property | MarkerFirstBrushKind | Gets or sets the kind of brush to use for the first marker.
Public property | MarkerFirstTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerFirstBrushKind setting.
Public property | MarkerHighBrushCustom | Gets or sets the custom Brush to use for the high marker.
Public property | MarkerHighBrushKind | Gets or sets the kind of brush to use for the high marker.
Public property | MarkerHighTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerHighBrushKind setting.
Public property | MarkerLastBrushCustom | Gets or sets the custom Brush to use for the last marker.
Public property | MarkerLastBrushKind | Gets or sets the kind of brush to use for the last marker.
Public property | MarkerLastTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerLastBrushKind setting.
Public property | MarkerLowBrushCustom | Gets or sets the custom Brush to use for the low marker.
Public property | MarkerLowBrushKind | Gets or sets the kind of brush to use for the low marker.
Public property | MarkerLowTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerLowBrushKind setting.
Public property | MarkerNegativeBrushCustom | Gets or sets the custom Brush to use for negative markers.
Public property | MarkerNegativeBrushKind | Gets or sets the kind of brush to use for negative markers.
Public property | MarkerNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerNegativeBrushKind setting.
Public property | MarkerTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.
Public property | Palette | Gets or sets the MicroPalette of colors to use.
Top
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.AreaBrushCustom Property

MicroSeriesPaletteStyleSelectorAreaBrushCustom Property

Gets or sets the custom Brush to use for areas.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush AreaBrushCustom { get; set; }
Public Property AreaBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for areas.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaBrushKind


MicroSeriesPaletteStyleSelector.AreaBrushKind Property

MicroSeriesPaletteStyleSelectorAreaBrushKind Property

Gets or sets the kind of brush to use for areas.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind AreaBrushKind { get; set; }
Public Property AreaBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for areas.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaBrushCustom
MicroSeriesPaletteStyleSelectorAreaTintColor


MicroSeriesPaletteStyleSelector.AreaHighBrushCustom Property

MicroSeriesPaletteStyleSelectorAreaHighBrushCustom Property

Gets or sets the custom Brush to use for the high area.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush AreaHighBrushCustom { get; set; }
Public Property AreaHighBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the high area.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaHighBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaHighBrushKind


MicroSeriesPaletteStyleSelector.AreaHighBrushKind Property

MicroSeriesPaletteStyleSelectorAreaHighBrushKind Property

Gets or sets the kind of brush to use for the high area.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind AreaHighBrushKind { get; set; }
Public Property AreaHighBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the high area.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaHighBrushCustom
MicroSeriesPaletteStyleSelectorAreaHighTintColor


MicroSeriesPaletteStyleSelector.AreaHighTintColor Property

MicroSeriesPaletteStyleSelectorAreaHighTintColor Property

Gets or sets the tint color to apply to the resulting brush from the AreaHighBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> AreaHighTintColor { get; set; }
Public Property AreaHighTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaHighBrushKind


MicroSeriesPaletteStyleSelector.AreaLowBrushCustom Property

MicroSeriesPaletteStyleSelectorAreaLowBrushCustom Property

Gets or sets the custom Brush to use for the low area.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush AreaLowBrushCustom { get; set; }
Public Property AreaLowBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the low area.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaLowBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaLowBrushKind


MicroSeriesPaletteStyleSelector.AreaLowBrushKind Property

MicroSeriesPaletteStyleSelectorAreaLowBrushKind Property

Gets or sets the kind of brush to use for the low area.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind AreaLowBrushKind { get; set; }
Public Property AreaLowBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the low area.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaLowBrushCustom
MicroSeriesPaletteStyleSelectorAreaLowTintColor


MicroSeriesPaletteStyleSelector.AreaLowTintColor Property

MicroSeriesPaletteStyleSelectorAreaLowTintColor Property

Gets or sets the tint color to apply to the resulting brush from the AreaLowBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> AreaLowTintColor { get; set; }
Public Property AreaLowTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaLowBrushKind


MicroSeriesPaletteStyleSelector.AreaNegativeBrushCustom Property

MicroSeriesPaletteStyleSelectorAreaNegativeBrushCustom Property

Gets or sets the custom Brush to use for negative areas.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush AreaNegativeBrushCustom { get; set; }
Public Property AreaNegativeBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for negative areas.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaNegativeBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaNegativeBrushKind


MicroSeriesPaletteStyleSelector.AreaNegativeBrushKind Property

MicroSeriesPaletteStyleSelectorAreaNegativeBrushKind Property

Gets or sets the kind of brush to use for negative areas.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind AreaNegativeBrushKind { get; set; }
Public Property AreaNegativeBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for negative areas.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaNegativeBrushCustom
MicroSeriesPaletteStyleSelectorAreaNegativeTintColor


MicroSeriesPaletteStyleSelector.AreaNegativeTintColor Property

MicroSeriesPaletteStyleSelectorAreaNegativeTintColor Property

Gets or sets the tint color to apply to the resulting brush from the AreaNegativeBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> AreaNegativeTintColor { get; set; }
Public Property AreaNegativeTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaNegativeBrushKind


MicroSeriesPaletteStyleSelector.AreaTintColor Property

MicroSeriesPaletteStyleSelectorAreaTintColor Property

Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> AreaTintColor { get; set; }
Public Property AreaTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaBrushKind


MicroSeriesPaletteStyleSelector.LineBrushCustom Property

MicroSeriesPaletteStyleSelectorLineBrushCustom Property

Gets or sets the custom Brush to use for lines.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LineBrushCustom { get; set; }
Public Property LineBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for lines.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the LineBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineBrushKind


MicroSeriesPaletteStyleSelector.LineBrushKind Property

MicroSeriesPaletteStyleSelectorLineBrushKind Property

Gets or sets the kind of brush to use for lines.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind LineBrushKind { get; set; }
Public Property LineBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for lines.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineBrushCustom
MicroSeriesPaletteStyleSelectorLineTintColor


MicroSeriesPaletteStyleSelector.LineNegativeBrushCustom Property

MicroSeriesPaletteStyleSelectorLineNegativeBrushCustom Property

Gets or sets the custom Brush to use for negative lines.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush LineNegativeBrushCustom { get; set; }
Public Property LineNegativeBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for negative lines.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the LineNegativeBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineNegativeBrushKind


MicroSeriesPaletteStyleSelector.LineNegativeBrushKind Property

MicroSeriesPaletteStyleSelectorLineNegativeBrushKind Property

Gets or sets the kind of brush to use for negative lines.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind LineNegativeBrushKind { get; set; }
Public Property LineNegativeBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for negative lines.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineNegativeBrushCustom
MicroSeriesPaletteStyleSelectorLineNegativeTintColor


MicroSeriesPaletteStyleSelector.LineNegativeTintColor Property

MicroSeriesPaletteStyleSelectorLineNegativeTintColor Property

Gets or sets the tint color to apply to the resulting brush from the LineNegativeBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> LineNegativeTintColor { get; set; }
Public Property LineNegativeTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineNegativeBrushKind


MicroSeriesPaletteStyleSelector.LineTintColor Property

MicroSeriesPaletteStyleSelectorLineTintColor Property

Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> LineTintColor { get; set; }
Public Property LineTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineBrushKind


MicroSeriesPaletteStyleSelector.MarkerBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerBrushCustom Property

Gets or sets the custom Brush to use for markers.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush MarkerBrushCustom { get; set; }
Public Property MarkerBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for markers.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerBrushKind


MicroSeriesPaletteStyleSelector.MarkerBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerBrushKind Property

Gets or sets the kind of brush to use for markers.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerBrushKind { get; set; }
Public Property MarkerBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for markers.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerBrushCustom
MicroSeriesPaletteStyleSelectorMarkerTintColor


MicroSeriesPaletteStyleSelector.MarkerFirstBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerFirstBrushCustom Property

Gets or sets the custom Brush to use for the first marker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush MarkerFirstBrushCustom { get; set; }
Public Property MarkerFirstBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the first marker.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerFirstBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerFirstBrushKind


MicroSeriesPaletteStyleSelector.MarkerFirstBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerFirstBrushKind Property

Gets or sets the kind of brush to use for the first marker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerFirstBrushKind { get; set; }
Public Property MarkerFirstBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the first marker.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerFirstBrushCustom
MicroSeriesPaletteStyleSelectorMarkerFirstTintColor


MicroSeriesPaletteStyleSelector.MarkerFirstTintColor Property

MicroSeriesPaletteStyleSelectorMarkerFirstTintColor Property

Gets or sets the tint color to apply to the resulting brush from the MarkerFirstBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerFirstTintColor { get; set; }
Public Property MarkerFirstTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerFirstBrushKind


MicroSeriesPaletteStyleSelector.MarkerHighBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerHighBrushCustom Property

Gets or sets the custom Brush to use for the high marker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush MarkerHighBrushCustom { get; set; }
Public Property MarkerHighBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the high marker.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerHighBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerHighBrushKind


MicroSeriesPaletteStyleSelector.MarkerHighBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerHighBrushKind Property

Gets or sets the kind of brush to use for the high marker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerHighBrushKind { get; set; }
Public Property MarkerHighBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the high marker.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerHighBrushCustom
MicroSeriesPaletteStyleSelectorMarkerHighTintColor


MicroSeriesPaletteStyleSelector.MarkerHighTintColor Property

MicroSeriesPaletteStyleSelectorMarkerHighTintColor Property

Gets or sets the tint color to apply to the resulting brush from the MarkerHighBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerHighTintColor { get; set; }
Public Property MarkerHighTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerHighBrushKind


MicroSeriesPaletteStyleSelector.MarkerLastBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerLastBrushCustom Property

Gets or sets the custom Brush to use for the last marker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush MarkerLastBrushCustom { get; set; }
Public Property MarkerLastBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the last marker.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerLastBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLastBrushKind


MicroSeriesPaletteStyleSelector.MarkerLastBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerLastBrushKind Property

Gets or sets the kind of brush to use for the last marker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerLastBrushKind { get; set; }
Public Property MarkerLastBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the last marker.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLastBrushCustom
MicroSeriesPaletteStyleSelectorMarkerLastTintColor


MicroSeriesPaletteStyleSelector.MarkerLastTintColor Property

MicroSeriesPaletteStyleSelectorMarkerLastTintColor Property

Gets or sets the tint color to apply to the resulting brush from the MarkerLastBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerLastTintColor { get; set; }
Public Property MarkerLastTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLastBrushKind


MicroSeriesPaletteStyleSelector.MarkerLowBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerLowBrushCustom Property

Gets or sets the custom Brush to use for the low marker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush MarkerLowBrushCustom { get; set; }
Public Property MarkerLowBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the low marker.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerLowBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLowBrushKind


MicroSeriesPaletteStyleSelector.MarkerLowBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerLowBrushKind Property

Gets or sets the kind of brush to use for the low marker.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerLowBrushKind { get; set; }
Public Property MarkerLowBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the low marker.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLowBrushCustom
MicroSeriesPaletteStyleSelectorMarkerLowTintColor


MicroSeriesPaletteStyleSelector.MarkerLowTintColor Property

MicroSeriesPaletteStyleSelectorMarkerLowTintColor Property

Gets or sets the tint color to apply to the resulting brush from the MarkerLowBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerLowTintColor { get; set; }
Public Property MarkerLowTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLowBrushKind


MicroSeriesPaletteStyleSelector.MarkerNegativeBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerNegativeBrushCustom Property

Gets or sets the custom Brush to use for negative markers.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Brush MarkerNegativeBrushCustom { get; set; }
Public Property MarkerNegativeBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for negative markers.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerNegativeBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerNegativeBrushKind


MicroSeriesPaletteStyleSelector.MarkerNegativeBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerNegativeBrushKind Property

Gets or sets the kind of brush to use for negative markers.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerNegativeBrushKind { get; set; }
Public Property MarkerNegativeBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for negative markers.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerNegativeBrushCustom
MicroSeriesPaletteStyleSelectorAreaHighTintColor


MicroSeriesPaletteStyleSelector.MarkerNegativeTintColor Property

MicroSeriesPaletteStyleSelectorMarkerNegativeTintColor Property

Gets or sets the tint color to apply to the resulting brush from the MarkerNegativeBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerNegativeTintColor { get; set; }
Public Property MarkerNegativeTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerNegativeBrushKind


MicroSeriesPaletteStyleSelector.MarkerTintColor Property

MicroSeriesPaletteStyleSelectorMarkerTintColor Property

Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerTintColor { get; set; }
Public Property MarkerTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerBrushKind


MicroSeriesPaletteStyleSelector.Palette Property

MicroSeriesPaletteStyleSelectorPalette Property

Gets or sets the MicroPalette of colors to use.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroPalette Palette { get; set; }
Public Property Palette As MicroPalette
    Get
    Set

Property Value

Type: MicroPalette
The MicroPalette of colors to use.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Methods

The MicroSeriesPaletteStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectAreaHighStyle | Returns the high area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaHighStyle(MicroSeriesBase, Style).)
Public method | SelectAreaLowStyle | Returns the low area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaLowStyle(MicroSeriesBase, Style).)
Public method | SelectAreaNegativeStyle | Returns the negative area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaStyle(MicroSeriesBase, Style).)
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLegendMarkerStyle(MicroXYSeriesBase, Style).)
Public method | SelectLineNegativeStyle | Returns the negative line Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLineNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectLineStyle | Returns the line Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLineStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerFirstStyle | Returns the first marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerFirstStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerHighStyle | Returns the high marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerHighStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerLastStyle | Returns the last marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerLastStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerLowStyle | Returns the low marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerLowStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerNegativeStyle | Returns the negative marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerStyle(MicroSeriesBase, Style).)
Top
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectAreaHighStyle Method

MicroSeriesPaletteStyleSelectorSelectAreaHighStyle Method

Returns the high area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectAreaHighStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectAreaHighStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectAreaLowStyle Method

MicroSeriesPaletteStyleSelectorSelectAreaLowStyle Method

Returns the low area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectAreaLowStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectAreaLowStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectAreaNegativeStyle Method

MicroSeriesPaletteStyleSelectorSelectAreaNegativeStyle Method

Returns the negative area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectAreaNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectAreaNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectAreaStyle Method

MicroSeriesPaletteStyleSelectorSelectAreaStyle Method

Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectAreaStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectAreaStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectLegendMarkerStyle Method

MicroSeriesPaletteStyleSelectorSelectLegendMarkerStyle Method

Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectLegendMarkerStyle(
    MicroXYSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectLegendMarkerStyle (
    series As MicroXYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectLineNegativeStyle Method

MicroSeriesPaletteStyleSelectorSelectLineNegativeStyle Method

Returns the negative line Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectLineNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectLineNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectLineStyle Method

MicroSeriesPaletteStyleSelectorSelectLineStyle Method

Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectLineStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectLineStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerFirstStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerFirstStyle Method

Returns the first marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectMarkerFirstStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerFirstStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerHighStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerHighStyle Method

Returns the high marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectMarkerHighStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerHighStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerLastStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerLastStyle Method

Returns the last marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectMarkerLastStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerLastStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerLowStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerLowStyle Method

Returns the low marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectMarkerLowStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerLowStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerNegativeStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerNegativeStyle Method

Returns the negative marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectMarkerNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerStyle Method

Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Palettes
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Style SelectMarkerStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: System.WindowsStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.Windows.Controls.MicroCharts.Palettes Namespace


ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace

Contains the primitive classes used for micro charts.
Classes
 | Class | Description
Public class | InvalidPropertyPathException | InvalidPropertyPathException is an exception for use when a PropertyPath is invalid.
Public class | MicroBarSeriesBase | Represents a base class for bar series used in a MicroXYChart.
Public class | MicroChartBase | Provides the base class for a micro chart control.
Public class | MicroChartCanvas | Represents a panel were child elements are positioned using explicit/relative coordinates.
Public class | MicroDataPointBase | Represents a base class for a data point presented by a chart series.
Public class | MicroDataPointCollectionViewBaseT | Represents a base class for collection views into a source collection.
Public class | MicroLegendItem | Represents an item used in a chart legend.
Public class | MicroLineSeriesBase | Represents a base class for line and area series for use in a MicroXYChart.
Public class | MicroSeriesBase | Provides the base class for a micro series.
Public class | MicroSeriesItemsSourceConverter | Represents a type converter for the ItemsSource type.
Public class | MicroXYChartPlotter | Represents a class that is capable of plotting various shapes on to a MicroXYChart.
Public class | MicroXYSeriesBase | Provides the base class for a micro series that uses an X/Y axis.
Interfaces
 | Interface | Description
Public interface | IMicroXYAxis | Provides the base requirements for a axis used by a MicroXYChart.


IMicroXYAxis Interface

Provides the base requirements for a axis used by a MicroXYChart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public interface IMicroXYAxis
Public Interface IMicroXYAxis

The IMicroXYAxis type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the baseline value for the axis.
Public property | Maximum | Gets the maximum value of the axis.
Public property | Minimum | Gets the minimum value of the axis.
Public property | SlotCount | Gets the number of slots for data points of the axis when using slotted layout.
Top
Methods
 | Name | Description
Public method | GetPercentagePosition | Gets a plot coordinate for the specified value using it's overall percentage for the given key.
Public method | GetPosition | Gets a plot coordinate for the specified value.
Public method | GetValue | Gets a value for the specified plot coordinate.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis Properties

The IMicroXYAxis type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the baseline value for the axis.
Public property | Maximum | Gets the maximum value of the axis.
Public property | Minimum | Gets the minimum value of the axis.
Public property | SlotCount | Gets the number of slots for data points of the axis when using slotted layout.
Top
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.Baseline Property

IMicroXYAxisBaseline Property

Gets the baseline value for the axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Baseline { get; }
ReadOnly Property Baseline As Object
    Get

Property Value

Type: Object
The baseline value for the axis.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.Maximum Property

IMicroXYAxisMaximum Property

Gets the maximum value of the axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Maximum { get; }
ReadOnly Property Maximum As Object
    Get

Property Value

Type: Object
The maximum value of the axis.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.Minimum Property

IMicroXYAxisMinimum Property

Gets the minimum value of the axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object Minimum { get; }
ReadOnly Property Minimum As Object
    Get

Property Value

Type: Object
The minimum value of the axis.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.SlotCount Property

IMicroXYAxisSlotCount Property

Gets the number of slots for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
int SlotCount { get; }
ReadOnly Property SlotCount As Integer
    Get

Property Value

Type: Int32
The number of slots for data points of the axis when using slotted layout.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis Methods

The IMicroXYAxis type exposes the following members.

Methods
 | Name | Description
Public method | GetPercentagePosition | Gets a plot coordinate for the specified value using it's overall percentage for the given key.
Public method | GetPosition | Gets a plot coordinate for the specified value.
Public method | GetValue | Gets a value for the specified plot coordinate.
Top
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.GetPercentagePosition Method

IMicroXYAxisGetPercentagePosition Method

Gets a plot coordinate for the specified value using it's overall percentage for the given key.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double GetPercentagePosition(
    Object key,
    Object value
)
Function GetPercentagePosition (
    key As Object,
    value As Object
) As Double

Parameters

key
Type: SystemObject
The key associated with the specified value.
value
Type: SystemObject
The value whose position should be returned.

Return Value

Type: Double
A plot coordinate for the specified value using it's overall percentage for the given key.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.GetPosition Method

IMicroXYAxisGetPosition Method

Gets a plot coordinate for the specified value.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
double GetPosition(
    Object value
)
Function GetPosition (
    value As Object
) As Double

Parameters

value
Type: SystemObject
The value whose position should be returned.

Return Value

Type: Double
A plot coordinate for the specified value.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.GetValue Method

IMicroXYAxisGetValue Method

Gets a value for the specified plot coordinate.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
Object GetValue(
    double position
)
Function GetValue (
    position As Double
) As Object

Parameters

position
Type: SystemDouble
A plot coordinate whose value should be returned.

Return Value

Type: Object
A value for the specified plot coordinate.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Class

InvalidPropertyPathException is an exception for use when a PropertyPath is invalid.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesInvalidPropertyPathException

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InvalidPropertyPathException : Exception
<SerializableAttribute>
Public Class InvalidPropertyPathException
    Inherits Exception
Constructors
 | Name | Description
Public method | InvalidPropertyPathException | Initializes a new instance of the InvalidPropertyPathException class.
Public method | InvalidPropertyPathException(String) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message.
Protected method | InvalidPropertyPathException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidPropertyPathException class with serialized data.
Public method | InvalidPropertyPathException(String, Exception) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Constructor

Overload List
 | Name | Description
Public method | InvalidPropertyPathException | Initializes a new instance of the InvalidPropertyPathException class.
Public method | InvalidPropertyPathException(String) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message.
Protected method | InvalidPropertyPathException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidPropertyPathException class with serialized data.
Public method | InvalidPropertyPathException(String, Exception) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidPropertyPathException Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Constructor

Initializes a new instance of the InvalidPropertyPathException class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException()
Public Sub New
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Constructor (String)

Initializes a new instance of the InvalidPropertyPathException class with a specified error message.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InvalidPropertyPathException class with serialized data.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected InvalidPropertyPathException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Constructor (String, Exception)

Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Class

Represents a base class for bar series used in a MicroXYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroBarSeriesBase
ActiproSoftware.Windows.Controls.MicroChartsMicroBarSeries
ActiproSoftware.Windows.Controls.MicroChartsMicroWinLossSeries

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class MicroBarSeriesBase : MicroXYSeriesBase
Public MustInherit Class MicroBarSeriesBase
    Inherits MicroXYSeriesBase

The MicroBarSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroBarSeriesBase | Initializes a new instance of the MicroBarSeriesBase class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property.
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property.
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Overrides MicroSeriesBaseLogicalOrientation.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Overrides MicroXYSeriesBaseRequiresSlottedLayout.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
Fields
Name | Description
BarHighStyleProperty | Identifies the BarHighStyle dependency property. This field is read-only.
BarLowStyleProperty | Identifies the BarLowStyle dependency property. This field is read-only.
BarNegativeStyleProperty | Identifies the BarNegativeStyle dependency property. This field is read-only.
BarSpacingProperty | Identifies the BarSpacing dependency property. This field is read-only.
BarStyleKindsProperty | Identifies the BarStyleKinds dependency property. This field is read-only.
BarStyleProperty | Identifies the BarStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Constructor

Initializes a new instance of the MicroBarSeriesBase class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MicroBarSeriesBase()
Protected Sub New
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Properties

The MicroBarSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property.
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property.
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Overrides MicroSeriesBaseLogicalOrientation.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Overrides MicroXYSeriesBaseRequiresSlottedLayout.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarHighStyle Property

MicroBarSeriesBaseBarHighStyle Property

Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style BarHighStyle { get; set; }
Public Property BarHighStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape element used to render the high bar along the series. The default value is .
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarLowStyle Property

MicroBarSeriesBaseBarLowStyle Property

Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style BarLowStyle { get; set; }
Public Property BarLowStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape element used to render the low bar along the series. The default value is .
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarNegativeStyle Property

MicroBarSeriesBaseBarNegativeStyle Property

Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style BarNegativeStyle { get; set; }
Public Property BarNegativeStyle As Style
    Get
    Set

Property Value

Type: Style
A negative Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarSpacing Property

MicroBarSeriesBaseBarSpacing Property

Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Unit BarSpacing { get; set; }
Public Property BarSpacing As Unit
    Get
    Set

Property Value

Type: Unit
The amount of spacing applied to either side of the individual bar shapes. The default value is 1px.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarStyle Property

MicroBarSeriesBaseBarStyle Property

Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style BarStyle { get; set; }
Public Property BarStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarStyleKinds Property

MicroBarSeriesBaseBarStyleKinds Property

Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroBarSeriesStyleKinds BarStyleKinds { get; set; }
Public Property BarStyleKinds As MicroBarSeriesStyleKinds
    Get
    Set

Property Value

Type: MicroBarSeriesStyleKinds
A MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. The default value is MicroBarSeriesStyleKinds.None.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.LogicalOrientation Property

MicroBarSeriesBaseLogicalOrientation Property

Gets the logical orientation of the series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Orientation LogicalOrientation { get; }
Protected Overrides ReadOnly Property LogicalOrientation As Orientation
    Get

Property Value

Type: Orientation
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.MarkerVisibility Property

MicroBarSeriesBaseMarkerVisibility Property

Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroChartMarkerVisibility MarkerVisibility { get; set; }
Public Property MarkerVisibility As MicroChartMarkerVisibility
    Get
    Set

Property Value

Type: MicroChartMarkerVisibility
A MicroChartMarkerVisibility indicating which markers are rendered along the series. The default value is MicroChartMarkerVisibility.None.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.Orientation Property

MicroBarSeriesBaseOrientation Property

Gets or sets the orientation of the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the series. The default value is Orientation.Horizontal.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.RequiresSlottedLayout Property

MicroBarSeriesBaseRequiresSlottedLayout Property

Gets a value indicating whether the series requires slotted layout.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override bool RequiresSlottedLayout { get; }
Protected Overrides ReadOnly Property RequiresSlottedLayout As Boolean
    Get

Property Value

Type: Boolean
true if the series requires slotted layout; otherwise, false.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Methods

The MicroBarSeriesBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.GetMinimumMargin Method

MicroBarSeriesBaseGetMinimumMargin Method

Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> GetMinimumMargin()
Protected Overrides Function GetMinimumMargin As Nullable(Of Thickness)

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.PlotSeries Method

MicroBarSeriesBasePlotSeries Method

Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overrides Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Events

The MicroBarSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Fields

The MicroBarSeriesBase type exposes the following members.

Fields
Name | Description
BarHighStyleProperty | Identifies the BarHighStyle dependency property. This field is read-only.
BarLowStyleProperty | Identifies the BarLowStyle dependency property. This field is read-only.
BarNegativeStyleProperty | Identifies the BarNegativeStyle dependency property. This field is read-only.
BarSpacingProperty | Identifies the BarSpacing dependency property. This field is read-only.
BarStyleKindsProperty | Identifies the BarStyleKinds dependency property. This field is read-only.
BarStyleProperty | Identifies the BarStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarHighStyleProperty Field

MicroBarSeriesBaseBarHighStyleProperty Field

Identifies the BarHighStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarHighStyleProperty
Public Shared ReadOnly BarHighStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarHighStyle dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarLowStyleProperty Field

MicroBarSeriesBaseBarLowStyleProperty Field

Identifies the BarLowStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarLowStyleProperty
Public Shared ReadOnly BarLowStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarLowStyle dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarNegativeStyleProperty Field

MicroBarSeriesBaseBarNegativeStyleProperty Field

Identifies the BarNegativeStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarNegativeStyleProperty
Public Shared ReadOnly BarNegativeStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarNegativeStyle dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarSpacingProperty Field

MicroBarSeriesBaseBarSpacingProperty Field

Identifies the BarSpacing dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarSpacingProperty
Public Shared ReadOnly BarSpacingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarSpacing dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarStyleKindsProperty Field

MicroBarSeriesBaseBarStyleKindsProperty Field

Identifies the BarStyleKinds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarStyleKindsProperty
Public Shared ReadOnly BarStyleKindsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarStyleKinds dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarStyleProperty Field

MicroBarSeriesBaseBarStyleProperty Field

Identifies the BarStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarStyleProperty
Public Shared ReadOnly BarStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarStyle dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.MarkerVisibilityProperty Field

MicroBarSeriesBaseMarkerVisibilityProperty Field

Identifies the MarkerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerVisibilityProperty
Public Shared ReadOnly MarkerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.OrientationProperty Field

MicroBarSeriesBaseOrientationProperty Field

Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartBase Class

Provides the base class for a micro chart control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroChartBase
ActiproSoftware.Windows.Controls.MicroChartsMicroXYChart

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class MicroChartBase : Control
Public MustInherit Class MicroChartBase
    Inherits Control

The MicroChartBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroChartBase | Initializes a new instance of the MicroChartBase class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
Fields
Name | Description
SeriesStyleSelectorProperty | Identifies the SeriesStyleSelector dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartBase Constructor

Initializes a new instance of the MicroChartBase class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MicroChartBase()
Protected Sub New
See Also

Reference

MicroChartBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartBase Properties

The MicroChartBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroChartBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartBase.SeriesStyleSelector Property

MicroChartBaseSeriesStyleSelector Property

Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesStyleSelector SeriesStyleSelector { get; set; }
Public Property SeriesStyleSelector As MicroSeriesStyleSelector
    Get
    Set

Property Value

Type: MicroSeriesStyleSelector
A MicroSeriesStyleSelector object that contains logic that chooses the style to use for each element in the associated series. The default value is .
See Also

Reference

MicroChartBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartBase Methods

The MicroChartBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the chart based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroChartBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartBase.Refresh Method

MicroChartBaseRefresh Method

Updates the chart based on the current state.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh
See Also

Reference

MicroChartBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartBase Events

The MicroChartBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Top
See Also

Reference

MicroChartBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartBase Fields

The MicroChartBase type exposes the following members.

Fields
Name | Description
SeriesStyleSelectorProperty | Identifies the SeriesStyleSelector dependency property. This field is read-only.
Top
See Also

Reference

MicroChartBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartBase.SeriesStyleSelectorProperty Field

MicroChartBaseSeriesStyleSelectorProperty Field

Identifies the SeriesStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SeriesStyleSelectorProperty
Public Shared ReadOnly SeriesStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SeriesStyleSelector dependency property.
See Also

Reference

MicroChartBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Class

Represents a panel were child elements are positioned using explicit/relative coordinates.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroChartCanvas

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroChartCanvas : Panel
Public Class MicroChartCanvas
    Inherits Panel

The MicroChartCanvas type exposes the following members.

Constructors
 | Name | Description
Public method | MicroChartCanvas | Initializes a new instance of the MicroChartCanvas class
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
 | GetX | Gets the value of the XProperty attached property for a specified element.
 | GetY | Gets the value of the YProperty attached property for a specified element.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetX | Sets the value of the XProperty attached property to a specified element.
 | SetY | Sets the value of the YProperty attached property to a specified element.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
Top
Attached Properties
 | Name | Description
Public attached property | X |
Public attached property | Y |
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Constructor

Initializes a new instance of the MicroChartCanvas class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroChartCanvas()
Public Sub New
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Properties

The MicroChartCanvas type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Methods

The MicroChartCanvas type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides FrameworkElementArrangeOverride(Size).)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
 | GetX | Gets the value of the XProperty attached property for a specified element.
 | GetY | Gets the value of the YProperty attached property for a specified element.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | SetX | Sets the value of the XProperty attached property to a specified element.
 | SetY | Sets the value of the YProperty attached property to a specified element.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.ArrangeOverride Method

MicroChartCanvasArrangeOverride Method

When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.GetX Method

MicroChartCanvasGetX Method

Gets the value of the XProperty attached property for a specified element.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetX(
    UIElement element
)
Public Shared Function GetX (
    element As UIElement
) As Double

Parameters

element
Type: System.WindowsUIElement
The element to which the attached property is retrieved.

Return Value

Type: Double
The X-coordinate value.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.GetY Method

MicroChartCanvasGetY Method

Gets the value of the YProperty attached property for a specified element.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static double GetY(
    UIElement element
)
Public Shared Function GetY (
    element As UIElement
) As Double

Parameters

element
Type: System.WindowsUIElement
The element to which the attached property is retrieved.

Return Value

Type: Double
The Y-coordinate value.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.MeasureOverride Method

MicroChartCanvasMeasureOverride Method

When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: System.WindowsSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.SetX Method

MicroChartCanvasSetX Method

Sets the value of the XProperty attached property to a specified element.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetX(
    UIElement element,
    double value
)
Public Shared Sub SetX (
    element As UIElement,
    value As Double
)

Parameters

element
Type: System.WindowsUIElement
The element to which the attached property is written.
value
Type: SystemDouble
The X-coordinate value.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.SetY Method

MicroChartCanvasSetY Method

Sets the value of the YProperty attached property to a specified element.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static void SetY(
    UIElement element,
    double value
)
Public Shared Sub SetY (
    element As UIElement,
    value As Double
)

Parameters

element
Type: System.WindowsUIElement
The element to which the attached property is written.
value
Type: SystemDouble
The Y-coordinate value.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Fields

The MicroChartCanvas type exposes the following members.

Fields
Name | Description
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.XProperty Field

MicroChartCanvasXProperty Field

Identifies the X dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XProperty
Public Shared ReadOnly XProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the X dependency property.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.YProperty Field

MicroChartCanvasYProperty Field

Identifies the Y dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YProperty
Public Shared ReadOnly YProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Y dependency property.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Attached Properties

The MicroChartCanvas type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | X |
Public attached property | Y |
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.X Attached Property

MicroChartCanvasX Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.MicroCharts.Primitives.MicroChartCanvas.X"]

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetX, SetX
See GetX, SetX

Property Value

Type: Double
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.Y Attached Property

MicroChartCanvasY Attached Property

[Missing <summary> documentation for "P:ActiproSoftware.Windows.Controls.MicroCharts.Primitives.MicroChartCanvas.Y"]

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
See GetY, SetY
See GetY, SetY

Property Value

Type: Double
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Class

Represents a base class for a data point presented by a chart series.
Inheritance Hierarchy
SystemObject
ActiproSoftware.WindowsObservableObjectBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroDataPointBase
ActiproSoftware.Windows.Controls.MicroChartsMicroXYDataPoint

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class MicroDataPointBase : ObservableObjectBase
Public MustInherit Class MicroDataPointBase
    Inherits ObservableObjectBase

The MicroDataPointBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroDataPointBase | Initializes a new instance of the MicroDataPointBase class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point.
Top
Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Constructor

Initializes a new instance of the MicroDataPointBase class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MicroDataPointBase()
Protected Sub New
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Properties

The MicroDataPointBase type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point.
Top
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase.Index Property

MicroDataPointBaseIndex Property

Gets or sets the index of the data point.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the data point; The default value is 0.
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Methods

The MicroDataPointBase type exposes the following members.

Methods
 | Name | Description
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Events

The MicroDataPointBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T) Class

MicroDataPointCollectionViewBaseT Class

Represents a base class for collection views into a source collection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroDataPointCollectionViewBaseT
ActiproSoftware.Windows.Controls.MicroChartsMicroXYDataPointCollectionView

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class MicroDataPointCollectionViewBase<T> : IEnumerable<T>,
    IEnumerable

Public MustInherit Class MicroDataPointCollectionViewBase(Of T)
    Implements IEnumerable(Of T), IEnumerable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.Windows.Controls.MicroCharts.Primitives.MicroDataPointCollectionViewBase`1"]

The MicroDataPointCollectionViewBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroDataPointCollectionViewBaseT | Initializes a new instance of the MicroDataPointCollectionViewBaseT class
Top
Properties
 | Name | Description
Protected property | Collection | Gets or sets the IEnumerableT presented by this view.
Public property | Count | Gets the number of records in the view.
Top
Methods
 | Name | Description
Protected method | EnsureInitialized | Ensures that this instance is currently initialized.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | IndexOf | Returns the index at which the specified item is located.
Protected method | Initialize | Initializes this instance.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T) Constructor

MicroDataPointCollectionViewBaseT Constructor

Initializes a new instance of the MicroDataPointCollectionViewBaseT class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MicroDataPointCollectionViewBase()
Protected Sub New
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T) Properties

MicroDataPointCollectionViewBaseT Properties

The MicroDataPointCollectionViewBaseT generic type exposes the following members.

Properties
 | Name | Description
Protected property | Collection | Gets or sets the IEnumerableT presented by this view.
Public property | Count | Gets the number of records in the view.
Top
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).Collection Property

MicroDataPointCollectionViewBaseTCollection Property

Gets or sets the IEnumerableT presented by this view.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected IEnumerable<T> Collection { get; set; }
Protected Property Collection As IEnumerable(Of T)
    Get
    Set

Property Value

Type: IEnumerable T
The IEnumerableT presented by this view.
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).Count Property

MicroDataPointCollectionViewBaseTCount Property

Gets the number of records in the view.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Count { get; protected set; }
Public Property Count As Integer
    Get
    Protected Set

Property Value

Type: Int32
The number of records in the view, or –1 if the number of records is unknown.
Remarks
If a filter is set, this property value only includes items that pass the filter. If the underlying collection is of type IEnumerable, this is an O(N) operation. This value is cached until the collection changes.
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T) Methods

MicroDataPointCollectionViewBaseT Methods

The MicroDataPointCollectionViewBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | EnsureInitialized | Ensures that this instance is currently initialized.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | IndexOf | Returns the index at which the specified item is located.
Protected method | Initialize | Initializes this instance.
Top
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).EnsureInitialized Method

MicroDataPointCollectionViewBaseTEnsureInitialized Method

Ensures that this instance is currently initialized.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void EnsureInitialized()
Protected Sub EnsureInitialized
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).GetEnumerator Method

MicroDataPointCollectionViewBaseTGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)

Return Value

Type: IEnumerator T
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).IndexOf Method

MicroDataPointCollectionViewBaseTIndexOf Method

Returns the index at which the specified item is located.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer

Parameters

item
Type: T
The item to locate.

Return Value

Type: Int32
The index at which the specified item is located, or –1 if the item is unknown.
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).Initialize Method

MicroDataPointCollectionViewBaseTInitialize Method

Initializes this instance.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void Initialize()
Protected Overridable Sub Initialize
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLegendItem Class

Represents an item used in a chart legend.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroLegendItem

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroLegendItem
Public Class MicroLegendItem

The MicroLegendItem type exposes the following members.

Constructors
 | Name | Description
Public method | MicroLegendItem | Initializes a new instance of the MicroLegendItem class
Top
Properties
 | Name | Description
Public property | MarkerStyle | Gets the Style applied to the MicroChartMarker used to present the legend item.
Public property | Text | Gets a description of the legend item.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLegendItem Constructor

Initializes a new instance of the MicroLegendItem class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroLegendItem()
Public Sub New
See Also

Reference

MicroLegendItem Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLegendItem Properties

The MicroLegendItem type exposes the following members.

Properties
 | Name | Description
Public property | MarkerStyle | Gets the Style applied to the MicroChartMarker used to present the legend item.
Public property | Text | Gets a description of the legend item.
Top
See Also

Reference

MicroLegendItem Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLegendItem.MarkerStyle Property

MicroLegendItemMarkerStyle Property

Gets the Style applied to the MicroChartMarker used to present the legend item.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; }
Public ReadOnly Property MarkerStyle As Style
    Get

Property Value

Type: Style
See Also

Reference

MicroLegendItem Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLegendItem.Text Property

MicroLegendItemText Property

Gets a description of the legend item.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
See Also

Reference

MicroLegendItem Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Class

Represents a base class for line and area series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroLineSeriesBase
ActiproSoftware.Windows.Controls.MicroChartsMicroAreaSeries
ActiproSoftware.Windows.Controls.MicroChartsMicroLineSeries

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class MicroLineSeriesBase : MicroXYSeriesBase
Public MustInherit Class MicroLineSeriesBase
    Inherits MicroXYSeriesBase

The MicroLineSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroLineSeriesBase | Initializes a new instance of the MicroLineSeriesBase class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
Fields
Name | Description
LineKindProperty | Identifies the LineKind dependency property. This field is read-only.
LineNegativeStyleProperty | Identifies the LineNegativeStyle dependency property. This field is read-only.
LineStyleKindsProperty | Identifies the LineStyleKinds dependency property. This field is read-only.
LineStyleProperty | Identifies the LineStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Constructor

Initializes a new instance of the MicroLineSeriesBase class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MicroLineSeriesBase()
Protected Sub New
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Properties

The MicroLineSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineKind Property

MicroLineSeriesBaseLineKind Property

Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYSeriesLineKind LineKind { get; set; }
Public Property LineKind As MicroXYSeriesLineKind
    Get
    Set

Property Value

Type: MicroXYSeriesLineKind
A MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. The default value is MicroXYSeriesLineKind.Normal.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineNegativeStyle Property

MicroLineSeriesBaseLineNegativeStyle Property

Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LineNegativeStyle { get; set; }
Public Property LineNegativeStyle As Style
    Get
    Set

Property Value

Type: Style
A negative Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineStyle Property

MicroLineSeriesBaseLineStyle Property

Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LineStyle { get; set; }
Public Property LineStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineStyleKinds Property

MicroLineSeriesBaseLineStyleKinds Property

Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroLineSeriesStyleKinds LineStyleKinds { get; set; }
Public Property LineStyleKinds As MicroLineSeriesStyleKinds
    Get
    Set

Property Value

Type: MicroLineSeriesStyleKinds
A MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. The default value is MicroLineSeriesStyleKinds.None.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.MarkerVisibility Property

MicroLineSeriesBaseMarkerVisibility Property

Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroChartMarkerVisibility MarkerVisibility { get; set; }
Public Property MarkerVisibility As MicroChartMarkerVisibility
    Get
    Set

Property Value

Type: MicroChartMarkerVisibility
A MicroChartMarkerVisibility indicating which markers are rendered along the series. The default value is MicroChartMarkerVisibility.None.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Methods

The MicroLineSeriesBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.GetMinimumMargin Method

MicroLineSeriesBaseGetMinimumMargin Method

Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> GetMinimumMargin()
Protected Overrides Function GetMinimumMargin As Nullable(Of Thickness)

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Events

The MicroLineSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Fields

The MicroLineSeriesBase type exposes the following members.

Fields
Name | Description
LineKindProperty | Identifies the LineKind dependency property. This field is read-only.
LineNegativeStyleProperty | Identifies the LineNegativeStyle dependency property. This field is read-only.
LineStyleKindsProperty | Identifies the LineStyleKinds dependency property. This field is read-only.
LineStyleProperty | Identifies the LineStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
Top
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineKindProperty Field

MicroLineSeriesBaseLineKindProperty Field

Identifies the LineKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineKindProperty
Public Shared ReadOnly LineKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineKind dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineNegativeStyleProperty Field

MicroLineSeriesBaseLineNegativeStyleProperty Field

Identifies the LineNegativeStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineNegativeStyleProperty
Public Shared ReadOnly LineNegativeStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineNegativeStyle dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineStyleKindsProperty Field

MicroLineSeriesBaseLineStyleKindsProperty Field

Identifies the LineStyleKinds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineStyleKindsProperty
Public Shared ReadOnly LineStyleKindsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineStyleKinds dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineStyleProperty Field

MicroLineSeriesBaseLineStyleProperty Field

Identifies the LineStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineStyleProperty
Public Shared ReadOnly LineStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineStyle dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.MarkerVisibilityProperty Field

MicroLineSeriesBaseMarkerVisibilityProperty Field

Identifies the MarkerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerVisibilityProperty
Public Shared ReadOnly MarkerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Class

Provides the base class for a micro series.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class MicroSeriesBase : Control,
    INotifyPropertyChanged
Public MustInherit Class MicroSeriesBase
    Inherits Control
    Implements INotifyPropertyChanged

The MicroSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroSeriesBase | Initializes a new instance of the MicroSeriesBase class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed.
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed.
Top
Fields
Name | Description
IndexProperty | Identifies the read-only Index dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Constructor

Initializes a new instance of the MicroSeriesBase class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MicroSeriesBase()
Protected Sub New
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Properties

The MicroSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.Index Property

MicroSeriesBaseIndex Property

Gets the index of this series in the associated chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of this series in the associated chart. The default value is -1.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.ItemsSource Property

MicroSeriesBaseItemsSource Property

Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable ItemsSource { get; set; }
Public Property ItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
A collection used to generate the data points of the MicroSeriesBase. The default value is .
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.LogicalOrientation Property

MicroSeriesBaseLogicalOrientation Property

Gets the logical orientation of the series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Orientation LogicalOrientation { get; }
Protected Overridable ReadOnly Property LogicalOrientation As Orientation
    Get

Property Value

Type: Orientation
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Methods

The MicroSeriesBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed.
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection.
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | Refresh | Updates the series based on the current state.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.NotifyPropertyChanged Method

MicroSeriesBaseNotifyPropertyChanged Method

Notifies that a property has changed.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.OnItemsSourceChanged Method

MicroSeriesBaseOnItemsSourceChanged Method

Occurs when the ItemsSource value is changed.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Protected Overridable Sub OnItemsSourceChanged (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
Old value of the ItemsSource property.
newValue
Type: System.CollectionsIEnumerable
New value of the ItemsSource property.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.OnItemsSourceCollectionChanged Method

MicroSeriesBaseOnItemsSourceCollectionChanged Method

Handles the CollectionChanged event of the ItemsSource collection.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnItemsSourceCollectionChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Protected Overridable Sub OnItemsSourceCollectionChanged (
    sender As Object,
    e As NotifyCollectionChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
The NotifyCollectionChangedEventArgs instance containing the event data.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.OnPropertyChanged Method

MicroSeriesBaseOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.Refresh Method

MicroSeriesBaseRefresh Method

Updates the series based on the current state.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract void Refresh()
Public MustOverride Sub Refresh
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Events

The MicroSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.PropertyChanged Event

MicroSeriesBasePropertyChanged Event

Occurs when a property has been changed.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Fields

The MicroSeriesBase type exposes the following members.

Fields
Name | Description
IndexProperty | Identifies the read-only Index dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
Top
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.IndexProperty Field

MicroSeriesBaseIndexProperty Field

Identifies the read-only Index dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndexProperty
Public Shared ReadOnly IndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Index dependency property.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.ItemsSourceProperty Field

MicroSeriesBaseItemsSourceProperty Field

Identifies the ItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemsSourceProperty
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemsSource dependency property.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter Class

Represents a type converter for the ItemsSource type.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesItemsSourceConverter

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public sealed class MicroSeriesItemsSourceConverter : TypeConverter
Public NotInheritable Class MicroSeriesItemsSourceConverter
    Inherits TypeConverter

The MicroSeriesItemsSourceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSeriesItemsSourceConverter | Initializes a new instance of the MicroSeriesItemsSourceConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter Constructor

Initializes a new instance of the MicroSeriesItemsSourceConverter class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesItemsSourceConverter()
Public Sub New
See Also

Reference

MicroSeriesItemsSourceConverter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter Methods

The MicroSeriesItemsSourceConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Top
See Also

Reference

MicroSeriesItemsSourceConverter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter.CanConvertFrom Method

MicroSeriesItemsSourceConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

MicroSeriesItemsSourceConverter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

MicroSeriesItemsSourceConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether the type converter can convert an object from the specified type to the type of this converter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
sourceType
Type: SystemType
The type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

MicroSeriesItemsSourceConverter Class
CanConvertFrom Overload
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter.ConvertFrom Method

MicroSeriesItemsSourceConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

MicroSeriesItemsSourceConverter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

MicroSeriesItemsSourceConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts from the specified value to the intended conversion type of the converter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The value to convert to the type of this converter.

Return Value

Type: Object
The converted value.
See Also

Reference

MicroSeriesItemsSourceConverter Class
ConvertFrom Overload
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter Class

Represents a class that is capable of plotting various shapes on to a MicroXYChart.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYChartPlotter

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class MicroXYChartPlotter
Public Class MicroXYChartPlotter

The MicroXYChartPlotter type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYChartPlotter | Initializes a new instance of the MicroXYChart class.
Top
Properties
 | Name | Description
Public property | Height | Gets the height of the plot area.
Public property | IsAxisBaselineVisible | Gets a value indicating whether a line is rendered at the baseline value.
Public property | IsHotTracking | Gets a value indicating whether this instance is hot tracking.
Public property | Margin | Gets or sets the margin around the plot area.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series.
Public property | Width | Gets the width of the plot area.
Top
Methods
 | Name | Description
Public method | AddBaseline | Adds a baseline to the associated chart.
Public method | AddHorizontalBaseline | Adds a horizontal baseline to the associated chart.
Public method | AddMarker(Point, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddMarker(Double, Double, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddPolygon | Adds a Polygon to the associated chart using with the given points.
Public method | AddPolyline | Adds a Polyline to the associated chart using with the given points.
Public method | AddShape | Adds the shape to the associated chart.
Public method | AddVerticalBaseline | Adds a vertical baseline to the associated chart.
Public method | GetXAxis | Gets an IMicroXYAxis associated with the specified type for use along the X-axis.
Public method | GetYAxis | Gets an IMicroXYAxis associated with the specified type for use along the Y-axis.
Public method | Plot | Plots the series and ranges on the associated chart.
Public method | StartHotTracking | Starts the hot tracking.
Public method | StopHotTracking | Stops the hot tracking.
Public method | UpdateHotTracking | Updates the hot tracking.
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter Constructor

Initializes a new instance of the MicroXYChart class.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYChartPlotter(
    MicroXYChart chart
)
Public Sub New (
    chart As MicroXYChart
)

Parameters

chart
Type: ActiproSoftware.Windows.Controls.MicroChartsMicroXYChart
The chart associated with the plotter.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter Properties

The MicroXYChartPlotter type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets the height of the plot area.
Public property | IsAxisBaselineVisible | Gets a value indicating whether a line is rendered at the baseline value.
Public property | IsHotTracking | Gets a value indicating whether this instance is hot tracking.
Public property | Margin | Gets or sets the margin around the plot area.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series.
Public property | Width | Gets the width of the plot area.
Top
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.Height Property

MicroXYChartPlotterHeight Property

Gets the height of the plot area.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get

Property Value

Type: Double
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.IsAxisBaselineVisible Property

MicroXYChartPlotterIsAxisBaselineVisible Property

Gets a value indicating whether a line is rendered at the baseline value.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAxisBaselineVisible { get; }
Public ReadOnly Property IsAxisBaselineVisible As Boolean
    Get

Property Value

Type: Boolean
true if a line is rendered at the baseline value; otherwise, false.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.IsHotTracking Property

MicroXYChartPlotterIsHotTracking Property

Gets a value indicating whether this instance is hot tracking.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsHotTracking { get; }
Public ReadOnly Property IsHotTracking As Boolean
    Get

Property Value

Type: Boolean
true if this instance is hot tracking; otherwise, false.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.Margin Property

MicroXYChartPlotterMargin Property

Gets or sets the margin around the plot area.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Thickness Margin { get; set; }
Public Property Margin As Thickness
    Get
    Set

Property Value

Type: Thickness
The margin around the plot area.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.SeriesStyleSelector Property

MicroXYChartPlotterSeriesStyleSelector Property

Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroSeriesStyleSelector SeriesStyleSelector { get; }
Public ReadOnly Property SeriesStyleSelector As MicroSeriesStyleSelector
    Get

Property Value

Type: MicroSeriesStyleSelector
A MicroSeriesStyleSelector object that contains logic that chooses the style to use for each element in the associated series.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.Width Property

MicroXYChartPlotterWidth Property

Gets the width of the plot area.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get

Property Value

Type: Double
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter Methods

The MicroXYChartPlotter type exposes the following members.

Methods
 | Name | Description
Public method | AddBaseline | Adds a baseline to the associated chart.
Public method | AddHorizontalBaseline | Adds a horizontal baseline to the associated chart.
Public method | AddMarker(Point, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddMarker(Double, Double, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddPolygon | Adds a Polygon to the associated chart using with the given points.
Public method | AddPolyline | Adds a Polyline to the associated chart using with the given points.
Public method | AddShape | Adds the shape to the associated chart.
Public method | AddVerticalBaseline | Adds a vertical baseline to the associated chart.
Public method | GetXAxis | Gets an IMicroXYAxis associated with the specified type for use along the X-axis.
Public method | GetYAxis | Gets an IMicroXYAxis associated with the specified type for use along the Y-axis.
Public method | Plot | Plots the series and ranges on the associated chart.
Public method | StartHotTracking | Starts the hot tracking.
Public method | StopHotTracking | Stops the hot tracking.
Public method | UpdateHotTracking | Updates the hot tracking.
Top
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddBaseline Method

MicroXYChartPlotterAddBaseline Method

Adds a baseline to the associated chart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddBaseline(
    double x1,
    double y1,
    double x2,
    double y2
)
Public Sub AddBaseline (
    x1 As Double,
    y1 As Double,
    x2 As Double,
    y2 As Double
)

Parameters

x1
Type: SystemDouble
The X-coordinate of the first point.
y1
Type: SystemDouble
The Y-coordinate of the first point.
x2
Type: SystemDouble
The X-coordinate of the second point.
y2
Type: SystemDouble
The Y-coordinate of the second point.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddHorizontalBaseline Method

MicroXYChartPlotterAddHorizontalBaseline Method

Adds a horizontal baseline to the associated chart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddHorizontalBaseline(
    double y
)
Public Sub AddHorizontalBaseline (
    y As Double
)

Parameters

y
Type: SystemDouble
The Y-coordinate of the baseline.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddMarker Method

MicroXYChartPlotterAddMarker Method

Overload List
 | Name | Description
Public method | AddMarker(Point, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddMarker(Double, Double, Style) | Adds a MicroChartMarker to the associated chart.
Top
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddMarker Method (Point, Style)

MicroXYChartPlotterAddMarker Method (Point, Style)

Adds a MicroChartMarker to the associated chart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddMarker(
    Point point,
    Style style
)
Public Sub AddMarker (
    point As Point,
    style As Style
)

Parameters

point
Type: System.WindowsPoint
The point at which the marker should be added.
style
Type: System.WindowsStyle
The style that should be applied to the marker.
See Also

Reference

MicroXYChartPlotter Class
AddMarker Overload
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddMarker Method (Double, Double, Style)

MicroXYChartPlotterAddMarker Method (Double, Double, Style)

Adds a MicroChartMarker to the associated chart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddMarker(
    double x,
    double y,
    Style style
)
Public Sub AddMarker (
    x As Double,
    y As Double,
    style As Style
)

Parameters

x
Type: SystemDouble
The X coordinate at which the marker should be added.
y
Type: SystemDouble
The Y coordinate at which the marker should be added.
style
Type: System.WindowsStyle
The style that should be applied to the marker.
See Also

Reference

MicroXYChartPlotter Class
AddMarker Overload
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddPolygon Method

MicroXYChartPlotterAddPolygon Method

Adds a Polygon to the associated chart using with the given points.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddPolygon(
    PointCollection points,
    Style style,
    Geometry clip,
    Nullable<Rect> clipBounds
)
Public Sub AddPolygon (
    points As PointCollection,
    style As Style,
    clip As Geometry,
    clipBounds As Nullable(Of Rect)
)

Parameters

points
Type: System.Windows.MediaPointCollection
The points that make up the shape.
style
Type: System.WindowsStyle
The Style to be applied to the shape.
clip
Type: System.Windows.MediaGeometry
The clipping geometry to be used by the shape.
clipBounds
Type: SystemNullable Rect
The clipping bounds of the shape.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddPolyline Method

MicroXYChartPlotterAddPolyline Method

Adds a Polyline to the associated chart using with the given points.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddPolyline(
    PointCollection points,
    Style style,
    Geometry clip,
    Nullable<Rect> clipBounds
)
Public Sub AddPolyline (
    points As PointCollection,
    style As Style,
    clip As Geometry,
    clipBounds As Nullable(Of Rect)
)

Parameters

points
Type: System.Windows.MediaPointCollection
The points that make up the shape.
style
Type: System.WindowsStyle
The Style to be applied to the shape.
clip
Type: System.Windows.MediaGeometry
The clipping geometry to be used by the shape.
clipBounds
Type: SystemNullable Rect
The clipping bounds of the shape.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddShape Method

MicroXYChartPlotterAddShape Method

Adds the shape to the associated chart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddShape(
    Shape shape
)
Public Sub AddShape (
    shape As Shape
)

Parameters

shape
Type: System.Windows.ShapesShape
The shape to add.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddVerticalBaseline Method

MicroXYChartPlotterAddVerticalBaseline Method

Adds a vertical baseline to the associated chart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void AddVerticalBaseline(
    double x
)
Public Sub AddVerticalBaseline (
    x As Double
)

Parameters

x
Type: SystemDouble
The X-coordinate of the baseline.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.GetXAxis Method

MicroXYChartPlotterGetXAxis Method

Gets an IMicroXYAxis associated with the specified type for use along the X-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IMicroXYAxis GetXAxis(
    Type type
)
Public Function GetXAxis (
    type As Type
) As IMicroXYAxis

Parameters

type
Type: SystemType
The type of axis.

Return Value

Type: IMicroXYAxis
An IMicroXYAxis associated with the specified type for use along the X-axis.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.GetYAxis Method

MicroXYChartPlotterGetYAxis Method

Gets an IMicroXYAxis associated with the specified type for use along the Y-axis.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IMicroXYAxis GetYAxis(
    Type type
)
Public Function GetYAxis (
    type As Type
) As IMicroXYAxis

Parameters

type
Type: SystemType
The type of axis.

Return Value

Type: IMicroXYAxis
An IMicroXYAxis associated with the specified type for use along the Y-axis.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.Plot Method

MicroXYChartPlotterPlot Method

Plots the series and ranges on the associated chart.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void Plot()
Public Sub Plot
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.StartHotTracking Method

MicroXYChartPlotterStartHotTracking Method

Starts the hot tracking.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void StartHotTracking(
    Point position
)
Public Sub StartHotTracking (
    position As Point
)

Parameters

position
Type: System.WindowsPoint
The position of the mouse cursor.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.StopHotTracking Method

MicroXYChartPlotterStopHotTracking Method

Stops the hot tracking.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void StopHotTracking()
Public Sub StopHotTracking
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.UpdateHotTracking Method

MicroXYChartPlotterUpdateHotTracking Method

Updates the hot tracking.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public void UpdateHotTracking(
    Point position
)
Public Sub UpdateHotTracking (
    position As Point
)

Parameters

position
Type: System.WindowsPoint
The position of the mouse cursor.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Class

Provides the base class for a micro series that uses an X/Y axis.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.Windows.Controls.MicroChartsMicroScatterSeries
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroBarSeriesBase
ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroLineSeriesBase

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public abstract class MicroXYSeriesBase : MicroSeriesBase
Public MustInherit Class MicroXYSeriesBase
    Inherits MicroSeriesBase

The MicroXYSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroXYSeriesBase | Initializes a new instance of the MicroXYSeriesBase class
Top
Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series.
Public property | DataPoints | Gets the data points associated with this series.
Public property | Description | Gets or sets a description of the series. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property.
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property.
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property.
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property.
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property.
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property.
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized.
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout.
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property.
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter.
Public method | Refresh | Updates the series based on the current state. (Overrides MicroSeriesBaseRefresh.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
Fields
Name | Description
AggregationFactorProperty | Identifies the AggregationFactor dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
IsAggregationEnabledProperty | Identifies the IsAggregationEnabled dependency property. This field is read-only.
LegendItemTemplateProperty | Identifies the LegendItemTemplate dependency property. This field is read-only.
LegendMarkerStyleProperty | Identifies the LegendMarkerStyle dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerFirstStyleProperty | Identifies the MarkerFirstStyle dependency property. This field is read-only.
MarkerHighStyleProperty | Identifies the MarkerHighStyle dependency property. This field is read-only.
MarkerLastStyleProperty | Identifies the MarkerLastStyle dependency property. This field is read-only.
MarkerLowStyleProperty | Identifies the MarkerLowStyle dependency property. This field is read-only.
MarkerNegativeStyleProperty | Identifies the MarkerNegativeStyle dependency property. This field is read-only.
MarkerStyleKindsProperty | Identifies the MarkerStyleKinds dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
PrimaryAggregationKindProperty | Identifies the PrimaryAggregationKind dependency property. This field is read-only.
SecondaryAggregationKindProperty | Identifies the SecondaryAggregationKind dependency property. This field is read-only.
StackKindProperty | Identifies the StackKind dependency property. This field is read-only.
XPathProperty | Identifies the XPath dependency property. This field is read-only.
YPathProperty | Identifies the YPath dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Constructor

Initializes a new instance of the MicroXYSeriesBase class

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected MicroXYSeriesBase()
Protected Sub New
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Properties

The MicroXYSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series.
Public property | DataPoints | Gets the data points associated with this series.
Public property | Description | Gets or sets a description of the series. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property.
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property.
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property.
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property.
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property.
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property.
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized.
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout.
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property.
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.
Top
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.AggregationFactor Property

MicroXYSeriesBaseAggregationFactor Property

Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double AggregationFactor { get; set; }
Public Property AggregationFactor As Double
    Get
    Set

Property Value

Type: Double
A factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. The default value is 0.2.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.Chart Property

MicroXYSeriesBaseChart Property

Gets the MicroXYChart that owns this series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYChart Chart { get; }
Public ReadOnly Property Chart As MicroXYChart
    Get

Property Value

Type: MicroXYChart
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.DataPoints Property

MicroXYSeriesBaseDataPoints Property

Gets the data points associated with this series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYDataPointCollectionView DataPoints { get; }
Public ReadOnly Property DataPoints As MicroXYDataPointCollectionView
    Get

Property Value

Type: MicroXYDataPointCollectionView
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.Description Property

MicroXYSeriesBaseDescription Property

Gets or sets a description of the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
A description of the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.IsAggregationEnabled Property

MicroXYSeriesBaseIsAggregationEnabled Property

Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsAggregationEnabled { get; set; }
Public Property IsAggregationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data points will be an aggregation of the source data; otherwise, false. The default value is true.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendItemTemplate Property

MicroXYSeriesBaseLegendItemTemplate Property

Gets or sets the data template used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate LegendItemTemplate { get; set; }
Public Property LegendItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The data template used when presenting a legend item for the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendMarkerStyle Property

MicroXYSeriesBaseLegendMarkerStyle Property

Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style LegendMarkerStyle { get; set; }
Public Property LegendMarkerStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker used when presenting a legend item for the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendStringFormat Property

MicroXYSeriesBaseLegendStringFormat Property

Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format used when presenting legend item for the series. The default value is "{0}".
Remarks
The format string will be passed the following parameters:
  • {0} - The value of the primary axis. -
  • {1} - The value of the secondary axis. -
  • {2} - The X value. -
  • {3} - The Y value. -
  • {4} - Reserved. -
  • {5} - Description. -
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerFirstStyle Property

MicroXYSeriesBaseMarkerFirstStyle Property

Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerFirstStyle { get; set; }
Public Property MarkerFirstStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker element used to render the first marker along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerHighStyle Property

MicroXYSeriesBaseMarkerHighStyle Property

Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerHighStyle { get; set; }
Public Property MarkerHighStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerLastStyle Property

MicroXYSeriesBaseMarkerLastStyle Property

Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerLastStyle { get; set; }
Public Property MarkerLastStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker element used to render the last marker along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerLowStyle Property

MicroXYSeriesBaseMarkerLowStyle Property

Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerLowStyle { get; set; }
Public Property MarkerLowStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker used to render the low markers along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerNegativeStyle Property

MicroXYSeriesBaseMarkerNegativeStyle Property

Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerNegativeStyle { get; set; }
Public Property MarkerNegativeStyle As Style
    Get
    Set

Property Value

Type: Style
A negative Style, which is applied to the MicroChartMarker used to render the markers along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerStyle Property

MicroXYSeriesBaseMarkerStyle Property

Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; set; }
Public Property MarkerStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker used to render the markers along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerStyleKinds Property

MicroXYSeriesBaseMarkerStyleKinds Property

Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroChartMarkerStyleKinds MarkerStyleKinds { get; set; }
Public Property MarkerStyleKinds As MicroChartMarkerStyleKinds
    Get
    Set

Property Value

Type: MicroChartMarkerStyleKinds
A MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. The default value is MicroChartMarkerStyleKinds.None.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.PrimaryAggregationKind Property

MicroXYSeriesBasePrimaryAggregationKind Property

Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroAggregationKind PrimaryAggregationKind { get; set; }
Public Property PrimaryAggregationKind As MicroAggregationKind
    Get
    Set

Property Value

Type: MicroAggregationKind
A MicroAggregationKind indicating which kind of aggregation to perform along the primary axis. The default value is MicroAggregationKind.Average.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.RequiresNormalizedValues Property

MicroXYSeriesBaseRequiresNormalizedValues Property

Gets a value indicating whether the values presented by this series must be normalized.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool RequiresNormalizedValues { get; }
Protected Overridable ReadOnly Property RequiresNormalizedValues As Boolean
    Get

Property Value

Type: Boolean
true if the values presented by this series must be normalized; otherwise, false.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.RequiresSlottedLayout Property

MicroXYSeriesBaseRequiresSlottedLayout Property

Gets a value indicating whether the series requires slotted layout.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual bool RequiresSlottedLayout { get; }
Protected Overridable ReadOnly Property RequiresSlottedLayout As Boolean
    Get

Property Value

Type: Boolean
true if the series requires slotted layout; otherwise, false.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.SecondaryAggregationKind Property

MicroXYSeriesBaseSecondaryAggregationKind Property

Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroAggregationKind SecondaryAggregationKind { get; set; }
Public Property SecondaryAggregationKind As MicroAggregationKind
    Get
    Set

Property Value

Type: MicroAggregationKind
A MicroAggregationKind indicating which kind of aggregation to perform along the secondary axis. The default value is MicroAggregationKind.First.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.StackKind Property

MicroXYSeriesBaseStackKind Property

Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public MicroXYSeriesStackKind StackKind { get; set; }
Public Property StackKind As MicroXYSeriesStackKind
    Get
    Set

Property Value

Type: MicroXYSeriesStackKind
The kind of stacking applied to the series. The default value is MicroXYSeriesStackKind.None.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.XPath Property

MicroXYSeriesBaseXPath Property

Gets or sets the path to the item property represented along the X-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string XPath { get; set; }
Public Property XPath As String
    Get
    Set

Property Value

Type: String
The path to the item property represented along the X-axis. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.YPath Property

MicroXYSeriesBaseYPath Property

Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string YPath { get; set; }
Public Property YPath As String
    Get
    Set

Property Value

Type: String
The path to the item property represented along the Y-axis. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Methods

The MicroXYSeriesBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter.
Public method | Refresh | Updates the series based on the current state. (Overrides MicroSeriesBaseRefresh.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.GetMinimumMargin Method

MicroXYSeriesBaseGetMinimumMargin Method

Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Nullable<Thickness> GetMinimumMargin()
Protected Overridable Function GetMinimumMargin As Nullable(Of Thickness)

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.NormalizeValue Method

MicroXYSeriesBaseNormalizeValue Method

Normalizes the value using the specified baseline

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual Object NormalizeValue(
    Object value,
    Object baselineValue
)
Protected Overridable Function NormalizeValue (
    value As Object,
    baselineValue As Object
) As Object

Parameters

value
Type: SystemObject
The value to normalize.
baselineValue
Type: SystemObject
The baseline value.

Return Value

Type: Object
A normalized value.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.PlotSeries Method

MicroXYSeriesBasePlotSeries Method

Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overridable Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.PrepareSeries Method

MicroXYSeriesBasePrepareSeries Method

Prepares the series to be plotted to the associated chart using the specified plotter.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected virtual void PrepareSeries(
    MicroXYChartPlotter plotter
)
Protected Overridable Sub PrepareSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.Windows.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.Refresh Method

MicroXYSeriesBaseRefresh Method

Updates the series based on the current state.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Events

The MicroXYSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Top
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Fields

The MicroXYSeriesBase type exposes the following members.

Fields
Name | Description
AggregationFactorProperty | Identifies the AggregationFactor dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
IsAggregationEnabledProperty | Identifies the IsAggregationEnabled dependency property. This field is read-only.
LegendItemTemplateProperty | Identifies the LegendItemTemplate dependency property. This field is read-only.
LegendMarkerStyleProperty | Identifies the LegendMarkerStyle dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerFirstStyleProperty | Identifies the MarkerFirstStyle dependency property. This field is read-only.
MarkerHighStyleProperty | Identifies the MarkerHighStyle dependency property. This field is read-only.
MarkerLastStyleProperty | Identifies the MarkerLastStyle dependency property. This field is read-only.
MarkerLowStyleProperty | Identifies the MarkerLowStyle dependency property. This field is read-only.
MarkerNegativeStyleProperty | Identifies the MarkerNegativeStyle dependency property. This field is read-only.
MarkerStyleKindsProperty | Identifies the MarkerStyleKinds dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
PrimaryAggregationKindProperty | Identifies the PrimaryAggregationKind dependency property. This field is read-only.
SecondaryAggregationKindProperty | Identifies the SecondaryAggregationKind dependency property. This field is read-only.
StackKindProperty | Identifies the StackKind dependency property. This field is read-only.
XPathProperty | Identifies the XPath dependency property. This field is read-only.
YPathProperty | Identifies the YPath dependency property. This field is read-only.
Top
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.AggregationFactorProperty Field

MicroXYSeriesBaseAggregationFactorProperty Field

Identifies the AggregationFactor dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AggregationFactorProperty
Public Shared ReadOnly AggregationFactorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AggregationFactor dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.DescriptionProperty Field

MicroXYSeriesBaseDescriptionProperty Field

Identifies the Description dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DescriptionProperty
Public Shared ReadOnly DescriptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Description dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.IsAggregationEnabledProperty Field

MicroXYSeriesBaseIsAggregationEnabledProperty Field

Identifies the IsAggregationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAggregationEnabledProperty
Public Shared ReadOnly IsAggregationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAggregationEnabled dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendItemTemplateProperty Field

MicroXYSeriesBaseLegendItemTemplateProperty Field

Identifies the LegendItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendItemTemplateProperty
Public Shared ReadOnly LegendItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendItemTemplate dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendMarkerStyleProperty Field

MicroXYSeriesBaseLegendMarkerStyleProperty Field

Identifies the LegendMarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendMarkerStyleProperty
Public Shared ReadOnly LegendMarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendMarkerStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendStringFormatProperty Field

MicroXYSeriesBaseLegendStringFormatProperty Field

Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerFirstStyleProperty Field

MicroXYSeriesBaseMarkerFirstStyleProperty Field

Identifies the MarkerFirstStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerFirstStyleProperty
Public Shared ReadOnly MarkerFirstStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerFirstStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerHighStyleProperty Field

MicroXYSeriesBaseMarkerHighStyleProperty Field

Identifies the MarkerHighStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerHighStyleProperty
Public Shared ReadOnly MarkerHighStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerHighStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerLastStyleProperty Field

MicroXYSeriesBaseMarkerLastStyleProperty Field

Identifies the MarkerLastStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerLastStyleProperty
Public Shared ReadOnly MarkerLastStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerLastStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerLowStyleProperty Field

MicroXYSeriesBaseMarkerLowStyleProperty Field

Identifies the MarkerLowStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerLowStyleProperty
Public Shared ReadOnly MarkerLowStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerLowStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerNegativeStyleProperty Field

MicroXYSeriesBaseMarkerNegativeStyleProperty Field

Identifies the MarkerNegativeStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerNegativeStyleProperty
Public Shared ReadOnly MarkerNegativeStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerNegativeStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerStyleKindsProperty Field

MicroXYSeriesBaseMarkerStyleKindsProperty Field

Identifies the MarkerStyleKinds dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerStyleKindsProperty
Public Shared ReadOnly MarkerStyleKindsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerStyleKinds dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerStyleProperty Field

MicroXYSeriesBaseMarkerStyleProperty Field

Identifies the MarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerStyleProperty
Public Shared ReadOnly MarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.PrimaryAggregationKindProperty Field

MicroXYSeriesBasePrimaryAggregationKindProperty Field

Identifies the PrimaryAggregationKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PrimaryAggregationKindProperty
Public Shared ReadOnly PrimaryAggregationKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PrimaryAggregationKind dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.SecondaryAggregationKindProperty Field

MicroXYSeriesBaseSecondaryAggregationKindProperty Field

Identifies the SecondaryAggregationKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SecondaryAggregationKindProperty
Public Shared ReadOnly SecondaryAggregationKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SecondaryAggregationKind dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.StackKindProperty Field

MicroXYSeriesBaseStackKindProperty Field

Identifies the StackKind dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StackKindProperty
Public Shared ReadOnly StackKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StackKind dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.XPathProperty Field

MicroXYSeriesBaseXPathProperty Field

Identifies the XPath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XPathProperty
Public Shared ReadOnly XPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XPath dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.YPathProperty Field

MicroXYSeriesBaseYPathProperty Field

Identifies the YPath dependency property. This field is read-only.

Namespace: ActiproSoftware.Windows.Controls.MicroCharts.Primitives
Assembly: ActiproSoftware.MicroCharts.Wpf (in ActiproSoftware.MicroCharts.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YPathProperty
Public Shared ReadOnly YPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YPath dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.Windows.Controls.MicroCharts.Primitives Namespace


ActiproSoftware.Windows.Controls.Navigation Namespace

Contains classes that support implementing the controls in the Navigation product.
Classes
 | Class | Description
Public class | Breadcrumb | Represents a bread crumb control.
Public class | BreadcrumbConvertItemEventArgs | Provides event arguments for the ConvertItem routed event.
Public class | BreadcrumbItem | Represents an item in a Breadcrumb control.
Public class | BreadcrumbItemPropertyChangedRoutedEventArgs | Provides event arguments for a BreadcrumbItem property change routed event, indicating the old and new values.
Public class | ExpanderBar | Provides abstract base expander pane container management functionality.
Public class | ExplorerBar | Represents an explorer bar control.
Public class | NavigationBar | Represents a navigation bar control.
Public class | NavigationBarCommands | Contains the commands used for the NavigationBar control.
Public class | NavigationPane | Represents a pane that can be displayed in a navigation bar control.
Public class | ZoomContentControl | Represents a content control that can interactively zoom and pan it's content.
Public class | ZoomContentControlCommands | Contains the commands used for the ZoomContentControl control.
Public class | ZoomContentControlCursors | Contains the cursors used for the ZoomContentControl control.
Public class | ZoomDecorator | Represents a decorator that can interactively zoom and pan it's child element.
Enumerations
 | Enumeration | Description
Public enumeration | BreadcrumbConvertItemTargetType | Specifies the target type of a ConvertItem event.
Public enumeration | NavigationPaneVariantSize | Specifies the variant size of a NavigationPane control.


Breadcrumb Class

Represents a bread crumb control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
ActiproSoftware.Windows.Controls.NavigationBreadcrumb

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public class Breadcrumb : Control, IBreadcrumbCommon
Public Class Breadcrumb
    Inherits Control
    Implements IBreadcrumbCommon

The Breadcrumb type exposes the following members.

Constructors
 | Name | Description
Public method | Breadcrumb | Initializes a new instance of the Breadcrumb class.
Top
Properties
 | Name | Description
Public property | ActionButtons | Gets the action buttons shown on the right side of the Breadcrumb control.
Public property | AutoMinimizeItemCount | Gets or sets the number of items the Breadcrumb control will automatically minimize, starting from the RootContainer. The SelectedContainer will not be automatically minimized, button is included in the count. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ComboBoxIsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the embedded ComboBox control are selectable but not editable. This is a dependency property.
Public property | ComboBoxItemContainerStyle | Gets or sets the Style that is applied to the ComboBoxItem elements generated for items in the embedded ComboBox control. This is a dependency property
Public property | ComboBoxItemContainerStyleSelector | Gets or sets custom logic for choosing a Style that can be applied to ComboBoxItem elements generated by the embedded ComboBox control. This is a dependency property.
Public property | ComboBoxItemsSource | Gets or sets a collection used to generate the content of the embedded ComboBox control. This is a dependency property.
Public property | ComboBoxItemTemplate | Gets or sets the DataTemplate used to display each item in the embedded ComboBox control. This is a dependency property.
Public property | ComboBoxItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item in the embedded ComboBox control. This is a dependency property.
Public property | ComboBoxStaysOpenOnEdit | Gets or sets whether the drop-down control for the embedded ComboBox control will remain open when a user clicks the TextBox. This is a dependency property.
Public property | ComboBoxTextPath | Gets or sets the TextSearch.TextPath used for the items in the embedded ComboBox control. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageMinWidth | Gets or sets the minimum width of the image displayed on the left side of the Breadcrumb. This is a dependency property.
Public property | IsEditable | Gets or sets a value indicating whether the Breadcrumb can enter edit mode. This is a dependency property.
Public property | IsEditing | Gets or sets a value indicating whether the Breadcrumb is currently in edit mode. This is a dependency property.
Public property | IsOverflowButtonVisible | Gets a boolean value indicating whether the overflow button is visible. This is a dependency property.
Public property | IsProgressBarVisible | Gets or sets a value indicating whether the embedded AnimatedProgressBar control is visible. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to BreadcrumbItem elements generated for items in the trail. This is a dependency property.
Public property | ItemContainerStyleSelector | Gets or sets custom logic for choosing a Style that can be applied to BreadcrumbItem elements generated. This is a dependency property.
Public property | ItemMinimizedTemplate | Gets or sets the DataTemplate used to display each minimized item in the trail. This is a dependency property.
Public property | ItemMinimizedTemplateSelector | Gets or sets the custom logic for choosing a template used to display each minimized item in the trail. This is a dependency property.
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item in the trail. This is a dependency property.
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item in the trail. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MaxTailItemCount | Gets or sets the maximum number of tail BreadcrumbItem controls to display below the SelectedItem. This is a dependency property.
Public property | MenuHorizontalOffset | Gets or sets the horizontal distance between the target origin and the content menu alignment point. This is a dependency property.
Public property | MenuItemContainerExpandedStyle | Gets or sets the Style that is applied to the MenuItem elements generated for expanded items in context menus. This is a dependency property.
Public property | MenuItemContainerExpandedStyleSelector | Gets or sets custom logic for choosing a Style that can be applied to MenuItem elements generated for expanded items in context menus. This is a dependency property.
Public property | MenuItemContainerStyle | Gets or sets the Style that is applied to the MenuItem elements generated for items in context menus. This is a dependency property.
Public property | MenuItemContainerStyleSelector | Gets or sets custom logic for choosing a Style that can be applied to MenuItem elements generated for items in context menus. This is a dependency property.
Public property | MenuItemExpandedTemplate | Gets or sets the DataTemplate used to display expanded items in a MenuItem. This is a dependency property.
Public property | MenuItemExpandedTemplateSelector | Gets or sets the custom logic for choosing a template used to display expanded items in a MenuItem. This is a dependency property.
Public property | MenuItemTemplate | Gets or sets the DataTemplate used to display each item in a MenuItem. This is a dependency property.
Public property | MenuItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item in a MenuItem. This is a dependency property.
Public property | MenuVerticalOffset | Gets or sets the vertical distance between the target origin and the content menu alignment point. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the path separator used by the control. This is a dependency property.
Public property | ProgressBarDecreaseDuration | Gets or sets the Duration of the decrease animation of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarIncreaseDuration | Gets or sets the Duration of the increase animation of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarIsAnimationEnabled | Gets or sets value indicating whether the embedded AnimatedProgressBar control should animate Value changes. This is a dependency property.
Public property | ProgressBarIsIndeterminate | Gets or sets a value indicating whether the embedded AnimatedProgressBar control shows actual values or generic, continuous progress feedback. This is a dependency property.
Public property | ProgressBarMaximum | Gets or sets the highest possible ProgressBarValue of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarMinimum | Gets or sets the lowest possible ProgressBarValue of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarState | Gets or sets the state of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarValue | Gets or sets the current value of the embedded AnimatedProgressBar control. This is a dependency property
Public property | RootContainer | Gets the BreadcrumbItem container for the RootItem. This is a dependency property.
Public property | RootItem | Gets or sets the root item in the Breadcrumb control. This is a dependency property.
Public property | SelectedContainer | Gets the container selected in the Breadcrumb control. This is a dependency property.
Public property | SelectedItem | Gets or sets the item selected in the Breadcrumb control. This is a dependency property.
Public property | SelectedPath | Gets or sets the selected path of the Breadcrumb. This is a dependency property.
 | SelectItem | Gets the RoutedCommand used when a BreadcrumbItem is selected.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TailItemOpacity | Gets or sets the opacity of tail items in the Breadcrumb control. This is a dependency property.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VisibleItemCount | Gets the number of visible items in the Breadcrumb. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Protected method | GetPath | Gets the path string for the given item. By default, this method uses the PathConverter, if available, to get the path for the given item.
Protected method | GetTrail(Object) | Gets the location, which is a top-down list indicating the parent items for the specified source. By default, this method uses the LocationConverter, if available, to get the location for the specified source.
Protected method | GetTrail(String) | Gets the location, which is a top-down list indicating the parent items for the specified source. By default, this method uses the LocationConverter, if available, to get the location for the specified source.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MeasureOverride | Called to remeasure a control. (Overrides ControlMeasureOverride(Size).)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnConvertItem | Raises the ConvertItem event.
Protected method | OnCreateAutomationPeer | Creates an appropriate BreadcrumbAutomationPeer for this control as part of the WPF infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Overrides UIElementOnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Overrides UIElementOnKeyDown(KeyEventArgs).)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled Keyboard.LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnLostKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnOverflowButtonClick | Raises the OverflowButtonClick event.
Protected method | OnPreviewKeyDown | Invoked when an unhandled Keyboard.PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRootContainerChanged | Invoked when the RootContainer property is changed.
Protected method | OnRootItemChanged | Invoked when the RootItem property is changed.
Protected method | OnSelectedContainerChanged | Invoked when the SelectedContainer property is changed.
Protected method | OnSelectedItemChanged | Invoked when the SelectedItem property is changed.
Protected method | OnSelectedPathChanged | Invoked when the SelectedPath property is changed.
Protected method | OnSelectItem | Invoked when the SelectItem command is executed.
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Overrides ControlOnTemplateChanged(ControlTemplate, ControlTemplate).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ConvertItem | Occurs when the Breadcrumb needs a data item or path converted.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | OverflowButtonClick | Occurs when the overflow button is clicked, allowing for customization of the ContextMenu it will display.
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | RootContainerChanged | Occurs when the RootContainer is changed.
Public event | RootItemChanged | Occurs when the RootItem is changed.
Public event | SelectedContainerChanged | Occurs when the SelectedContainer is changed.
Public event | SelectedItemChanged | Occurs when the SelectedItem is changed.
Public event | SelectedPathChanged | Occurs when the SelectedPathChanged is changed.
Top
Fields
Name | Description
AutoMinimizeItemCountProperty | Identifies the AutoMinimizeItemCount dependency property. This field is read-only.
ComboBoxIsReadOnlyProperty | Identifies the ComboBoxIsReadOnly dependency property. This field is read-only.
ComboBoxItemContainerStyleProperty | Identifies the ComboBoxItemContainerStyle dependency property. This field is read-only.
ComboBoxItemContainerStyleSelectorProperty | Identifies the ComboBoxItemContainerStyleSelector dependency property. This field is read-only.
ComboBoxItemsSourceProperty | Identifies the ComboBoxItemsSource dependency property. This field is read-only.
ComboBoxItemTemplateProperty | Identifies the ComboBoxItemTemplate dependency property. This field is read-only.
ComboBoxItemTemplateSelectorProperty | Identifies the ComboBoxItemTemplateSelector dependency property. This field is read-only.
ComboBoxStaysOpenOnEditProperty | Identifies the ComboBoxStaysOpenOnEdit dependency property. This field is read-only.
ComboBoxTextPathProperty | Identifies the ComboBoxTextPath dependency property. This field is read-only.
ConvertItemEvent | Identifies the ConvertItem routed event. This field is read-only.
ImageMinWidthProperty | Identifies the ImageMinWidth dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
IsEditingProperty | Identifies the IsEditing dependency property. This field is read-only.
IsOverflowButtonVisibleProperty | Identifies the read-only IsOverflowButtonVisible dependency property. This field is read-only.
IsProgressBarVisibleProperty | Identifies the IsProgressBarVisible dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector dependency property. This field is read-only.
ItemMinimizedTemplateProperty | Identifies the ItemMinimizedTemplate dependency property. This field is read-only.
ItemMinimizedTemplateSelectorProperty | Identifies the ItemMinimizedTemplateSelector dependency property. This field is read-only.
ItemTemplateProperty | Identifies the ItemTemplate dependency property. This field is read-only.
ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector dependency property. This field is read-only.
MaxTailItemCountProperty | Identifies the MaxTailItemCount dependency property. This field is read-only.
MenuHorizontalOffsetProperty | Identifies the MenuHorizontalOffset dependency property. This field is read-only.
MenuItemContainerExpandedStyleProperty | Identifies the MenuItemContainerExpandedStyle dependency property. This field is read-only.
MenuItemContainerExpandedStyleSelectorProperty | Identifies the MenuItemContainerExpandedStyleSelector dependency property. This field is read-only.
MenuItemContainerStyleProperty | Identifies the MenuItemContainerStyle dependency property. This field is read-only.
MenuItemContainerStyleSelectorProperty | Identifies the MenuItemContainerStyleSelector dependency property. This field is read-only.
MenuItemExpandedTemplateProperty | Identifies the MenuItemExpandedTemplate dependency property. This field is read-only.
MenuItemExpandedTemplateSelectorProperty | Identifies the MenuItemExpandedTemplateSelector dependency property. This field is read-only.
MenuItemTemplateProperty | Identifies the MenuItemTemplate dependency property. This field is read-only.
MenuItemTemplateSelectorProperty | Identifies the MenuItemTemplateSelector dependency property. This field is read-only.
MenuVerticalOffsetProperty | Identifies the MenuVerticalOffset dependency property. This field is read-only.
OverflowButtonClickEvent | Identifies the OverflowButtonClick routed event. This field is read-only.
PathSeparatorProperty | Identifies the PathSeparator dependency property. This field is read-only.
ProgressBarDecreaseDurationProperty | Identifies the ProgressBarDecreaseDuration dependency property. This field is read-only.
ProgressBarIncreaseDurationProperty | Identifies the ProgressBarIncreaseDuration dependency property. This field is read-only.
ProgressBarIsAnimationEnabledProperty | Identifies the ProgressBarIsAnimationEnabled dependency property. This field is read-only.
ProgressBarIsIndeterminateProperty | Identifies the ProgressBarIsIndeterminate dependency property. This field is read-only.
ProgressBarMaximumProperty | Identifies the ProgressBarMaximum dependency property. This field is read-only.
ProgressBarMinimumProperty | Identifies the ProgressBarMinimum dependency property. This field is read-only.
ProgressBarStateProperty | Identifies the ProgressBarState dependency property. This field is read-only.
ProgressBarValueProperty | Identifies the ProgressBarValue dependency property. This field is read-only.
RootContainerChangedEvent | Identifies the RootContainerChanged routed event. This field is read-only.
RootContainerProperty | Identifies the read-only RootContainer dependency property. This field is read-only.
RootItemChangedEvent | Identifies the RootItemChanged routed event. This field is read-only.
RootItemProperty | Identifies the RootItem dependency property. This field is read-only.
SelectedContainerChangedEvent | Identifies the SelectedContainerChanged routed event. This field is read-only.
SelectedContainerProperty | Identifies the read-only SelectedContainer dependency property. This field is read-only.
SelectedItemChangedEvent | Identifies the SelectedItemChanged routed event. This field is read-only.
SelectedItemProperty | Identifies the SelectedItem dependency property. This field is read-only.
SelectedPathChangedEvent | Identifies the SelectedPathChanged routed event. This field is read-only.
SelectedPathProperty | Identifies the SelectedPath dependency property. This field is read-only.
TailItemOpacityProperty | Identifies the TailItemOpacity dependency property. This field is read-only.
VisibleItemCountProperty | Identifies the read-only VisibleItemCount dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Top
Remarks
For detailed documentation on this control's features and how to use them, please see the Breadcrumb-related series of documentation topics.
See Also

Reference

ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb Constructor

Initializes a new instance of the Breadcrumb class.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Breadcrumb()
Public Sub New
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb Properties

The Breadcrumb type exposes the following members.

Properties
 | Name | Description
Public property | ActionButtons | Gets the action buttons shown on the right side of the Breadcrumb control.
Public property | AutoMinimizeItemCount | Gets or sets the number of items the Breadcrumb control will automatically minimize, starting from the RootContainer. The SelectedContainer will not be automatically minimized, button is included in the count. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ComboBoxIsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the embedded ComboBox control are selectable but not editable. This is a dependency property.
Public property | ComboBoxItemContainerStyle | Gets or sets the Style that is applied to the ComboBoxItem elements generated for items in the embedded ComboBox control. This is a dependency property
Public property | ComboBoxItemContainerStyleSelector | Gets or sets custom logic for choosing a Style that can be applied to ComboBoxItem elements generated by the embedded ComboBox control. This is a dependency property.
Public property | ComboBoxItemsSource | Gets or sets a collection used to generate the content of the embedded ComboBox control. This is a dependency property.
Public property | ComboBoxItemTemplate | Gets or sets the DataTemplate used to display each item in the embedded ComboBox control. This is a dependency property.
Public property | ComboBoxItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item in the embedded ComboBox control. This is a dependency property.
Public property | ComboBoxStaysOpenOnEdit | Gets or sets whether the drop-down control for the embedded ComboBox control will remain open when a user clicks the TextBox. This is a dependency property.
Public property | ComboBoxTextPath | Gets or sets the TextSearch.TextPath used for the items in the embedded ComboBox control. This is a dependency property.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageMinWidth | Gets or sets the minimum width of the image displayed on the left side of the Breadcrumb. This is a dependency property.
Public property | IsEditable | Gets or sets a value indicating whether the Breadcrumb can enter edit mode. This is a dependency property.
Public property | IsEditing | Gets or sets a value indicating whether the Breadcrumb is currently in edit mode. This is a dependency property.
Public property | IsOverflowButtonVisible | Gets a boolean value indicating whether the overflow button is visible. This is a dependency property.
Public property | IsProgressBarVisible | Gets or sets a value indicating whether the embedded AnimatedProgressBar control is visible. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to BreadcrumbItem elements generated for items in the trail. This is a dependency property.
Public property | ItemContainerStyleSelector | Gets or sets custom logic for choosing a Style that can be applied to BreadcrumbItem elements generated. This is a dependency property.
Public property | ItemMinimizedTemplate | Gets or sets the DataTemplate used to display each minimized item in the trail. This is a dependency property.
Public property | ItemMinimizedTemplateSelector | Gets or sets the custom logic for choosing a template used to display each minimized item in the trail. This is a dependency property.
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item in the trail. This is a dependency property.
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item in the trail. This is a dependency property.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Overrides FrameworkElementLogicalChildren.)
Public property | MaxTailItemCount | Gets or sets the maximum number of tail BreadcrumbItem controls to display below the SelectedItem. This is a dependency property.
Public property | MenuHorizontalOffset | Gets or sets the horizontal distance between the target origin and the content menu alignment point. This is a dependency property.
Public property | MenuItemContainerExpandedStyle | Gets or sets the Style that is applied to the MenuItem elements generated for expanded items in context menus. This is a dependency property.
Public property | MenuItemContainerExpandedStyleSelector | Gets or sets custom logic for choosing a Style that can be applied to MenuItem elements generated for expanded items in context menus. This is a dependency property.
Public property | MenuItemContainerStyle | Gets or sets the Style that is applied to the MenuItem elements generated for items in context menus. This is a dependency property.
Public property | MenuItemContainerStyleSelector | Gets or sets custom logic for choosing a Style that can be applied to MenuItem elements generated for items in context menus. This is a dependency property.
Public property | MenuItemExpandedTemplate | Gets or sets the DataTemplate used to display expanded items in a MenuItem. This is a dependency property.
Public property | MenuItemExpandedTemplateSelector | Gets or sets the custom logic for choosing a template used to display expanded items in a MenuItem. This is a dependency property.
Public property | MenuItemTemplate | Gets or sets the DataTemplate used to display each item in a MenuItem. This is a dependency property.
Public property | MenuItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item in a MenuItem. This is a dependency property.
Public property | MenuVerticalOffset | Gets or sets the vertical distance between the target origin and the content menu alignment point. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the path separator used by the control. This is a dependency property.
Public property | ProgressBarDecreaseDuration | Gets or sets the Duration of the decrease animation of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarIncreaseDuration | Gets or sets the Duration of the increase animation of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarIsAnimationEnabled | Gets or sets value indicating whether the embedded AnimatedProgressBar control should animate Value changes. This is a dependency property.
Public property | ProgressBarIsIndeterminate | Gets or sets a value indicating whether the embedded AnimatedProgressBar control shows actual values or generic, continuous progress feedback. This is a dependency property.
Public property | ProgressBarMaximum | Gets or sets the highest possible ProgressBarValue of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarMinimum | Gets or sets the lowest possible ProgressBarValue of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarState | Gets or sets the state of the embedded AnimatedProgressBar control. This is a dependency property.
Public property | ProgressBarValue | Gets or sets the current value of the embedded AnimatedProgressBar control. This is a dependency property
Public property | RootContainer | Gets the BreadcrumbItem container for the RootItem. This is a dependency property.
Public property | RootItem | Gets or sets the root item in the Breadcrumb control. This is a dependency property.
Public property | SelectedContainer | Gets the container selected in the Breadcrumb control. This is a dependency property.
Public property | SelectedItem | Gets or sets the item selected in the Breadcrumb control. This is a dependency property.
Public property | SelectedPath | Gets or sets the selected path of the Breadcrumb. This is a dependency property.
 | SelectItem | Gets the RoutedCommand used when a BreadcrumbItem is selected.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | TailItemOpacity | Gets or sets the opacity of tail items in the Breadcrumb control. This is a dependency property.
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VisibleItemCount | Gets the number of visible items in the Breadcrumb. This is a dependency property.
Protected property | VisualBitmapEffect | Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ActionButtons Property

BreadcrumbActionButtons Property

Gets the action buttons shown on the right side of the Breadcrumb control.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DeferrableObservableCollection<Button> ActionButtons { get; }
Public ReadOnly Property ActionButtons As DeferrableObservableCollection(Of Button)
    Get

Property Value

Type: DeferrableObservableCollection Button
The action buttons.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.AutoMinimizeItemCount Property

BreadcrumbAutoMinimizeItemCount Property

Gets or sets the number of items the Breadcrumb control will automatically minimize, starting from the RootContainer. The SelectedContainer will not be automatically minimized, button is included in the count. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int AutoMinimizeItemCount { get; set; }
Public Property AutoMinimizeItemCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of items to automatically minimize. The default is 1.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ComboBoxIsReadOnly Property

BreadcrumbComboBoxIsReadOnly Property

Gets or sets a value that enables selection-only mode, in which the contents of the embedded ComboBox control are selectable but not editable. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ComboBoxIsReadOnly { get; set; }
Public Property ComboBoxIsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the embedded ComboBox control is read-only; otherwise, false. The default is false.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ComboBoxItemContainerStyle Property

BreadcrumbComboBoxItemContainerStyle Property

Gets or sets the Style that is applied to the ComboBoxItem elements generated for items in the embedded ComboBox control. This is a dependency property

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ComboBoxItemContainerStyle { get; set; }
Public Property ComboBoxItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that is applied to the ComboBoxItem elements generated for items in the embedded ComboBox control. The default is .
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ComboBoxItemContainerStyleSelector Property

BreadcrumbComboBoxItemContainerStyleSelector Property

Gets or sets custom logic for choosing a Style that can be applied to ComboBoxItem elements generated by the embedded ComboBox control. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StyleSelector ComboBoxItemContainerStyleSelector { get; set; }
Public Property ComboBoxItemContainerStyleSelector As StyleSelector
    Get
    Set

Property Value

Type: StyleSelector
A StyleSelector object that contains logic that chooses the Style to use as the ComboBoxItemContainerStyle. The default is .
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ComboBoxItemsSource Property

BreadcrumbComboBoxItemsSource Property

Gets or sets a collection used to generate the content of the embedded ComboBox control. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public IEnumerable ComboBoxItemsSource { get; set; }
Public Property ComboBoxItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
A collection that is used to generate the content of the embedded ComboBox control. The default is .
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ComboBoxItemTemplate Property

BreadcrumbComboBoxItemTemplate Property

Gets or sets the DataTemplate used to display each item in the embedded ComboBox control. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ComboBoxItemTemplate { get; set; }
Public Property ComboBoxItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that specifies the visualization of the data objects in the embedded ComboBox control. The default is .
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ComboBoxItemTemplateSelector Property

BreadcrumbComboBoxItemTemplateSelector Property

Gets or sets the custom logic for choosing a template used to display each item in the embedded ComboBox control. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector ComboBoxItemTemplateSelector { get; set; }
Public Property ComboBoxItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
A custom DataTemplateSelector object that provides logic and returns a DataTemplate. The default is .
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ComboBoxStaysOpenOnEdit Property

BreadcrumbComboBoxStaysOpenOnEdit Property

Gets or sets whether the drop-down control for the embedded ComboBox control will remain open when a user clicks the TextBox. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool ComboBoxStaysOpenOnEdit { get; set; }
Public Property ComboBoxStaysOpenOnEdit As Boolean
    Get
    Set

Property Value

Type: Boolean
true to keep the drop-down control open when the user clicks on the text area to start editing; otherwise, false. The default is false.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ComboBoxTextPath Property

BreadcrumbComboBoxTextPath Property

Gets or sets the TextSearch.TextPath used for the items in the embedded ComboBox control. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public string ComboBoxTextPath { get; set; }
Public Property ComboBoxTextPath As String
    Get
    Set

Property Value

Type: String
The TextSearch.TextPath used for the items in the embedded ComboBox control. The default is string.Empty.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ImageMinWidth Property

BreadcrumbImageMinWidth Property

Gets or sets the minimum width of the image displayed on the left side of the Breadcrumb. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double ImageMinWidth { get; set; }
Public Property ImageMinWidth As Double
    Get
    Set

Property Value

Type: Double
The minimum width of the image displayed on the left side of the Breadcrumb. The default is 16.0.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.IsEditable Property

BreadcrumbIsEditable Property

Gets or sets a value indicating whether the Breadcrumb can enter edit mode. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Breadcrumb can enter in edit mode; otherwise, false. The default is true.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.IsEditing Property

BreadcrumbIsEditing Property

Gets or sets a value indicating whether the Breadcrumb is currently in edit mode. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsEditing { get; set; }
Public Property IsEditing As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Breadcrumb is currently in edit mode; otherwise, false. The default is false.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.IsOverflowButtonVisible Property

BreadcrumbIsOverflowButtonVisible Property

Gets a boolean value indicating whether the overflow button is visible. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsOverflowButtonVisible { get; }
Public ReadOnly Property IsOverflowButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the overflow button is visible; otherwise, false. The default is false.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.IsProgressBarVisible Property

BreadcrumbIsProgressBarVisible Property

Gets or sets a value indicating whether the embedded AnimatedProgressBar control is visible. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public bool IsProgressBarVisible { get; set; }
Public Property IsProgressBarVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the embedded AnimatedProgressBar control is visible; otherwise, false. The default is false.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ItemContainerStyle Property

BreadcrumbItemContainerStyle Property

Gets or sets the Style that is applied to BreadcrumbItem elements generated for items in the trail. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style ItemContainerStyle { get; set; }
Public Property ItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that is applied to BreadcrumbItem elements generated for items in the trail. The default is .

Implements

IBreadcrumbCommonItemContainerStyle
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ItemContainerStyleSelector Property

BreadcrumbItemContainerStyleSelector Property

Gets or sets custom logic for choosing a Style that can be applied to BreadcrumbItem elements generated. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StyleSelector ItemContainerStyleSelector { get; set; }
Public Property ItemContainerStyleSelector As StyleSelector
    Get
    Set

Property Value

Type: StyleSelector
A StyleSelector object that contains logic that chooses the Style to use as the ItemContainerStyle. The default is .

Implements

IBreadcrumbCommonItemContainerStyleSelector
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ItemMinimizedTemplate Property

BreadcrumbItemMinimizedTemplate Property

Gets or sets the DataTemplate used to display each minimized item in the trail. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ItemMinimizedTemplate { get; set; }
Public Property ItemMinimizedTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that specifies the visualization of the minimized data objects. The default is .

Implements

IBreadcrumbCommonItemMinimizedTemplate
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ItemMinimizedTemplateSelector Property

BreadcrumbItemMinimizedTemplateSelector Property

Gets or sets the custom logic for choosing a template used to display each minimized item in the trail. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector ItemMinimizedTemplateSelector { get; set; }
Public Property ItemMinimizedTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
A custom DataTemplateSelector object that provides logic and returns a DataTemplate. The default is .

Implements

IBreadcrumbCommonItemMinimizedTemplateSelector
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ItemTemplate Property

BreadcrumbItemTemplate Property

Gets or sets the DataTemplate used to display each item in the trail. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplate ItemTemplate { get; set; }
Public Property ItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate

Return Value

Type: DataTemplate
A DataTemplate that specifies the visualization of the data objects. The default is .

Implements

IBreadcrumbCommonItemTemplate
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.ItemTemplateSelector Property

BreadcrumbItemTemplateSelector Property

Gets or sets the custom logic for choosing a template used to display each item in the trail. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public DataTemplateSelector ItemTemplateSelector { get; set; }
Public Property ItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
A custom DataTemplateSelector object that provides logic and returns a DataTemplate. The default is .

Implements

IBreadcrumbCommonItemTemplateSelector
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.LogicalChildren Property

BreadcrumbLogicalChildren Property

Gets an enumerator for logical child elements of this element.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
protected override IEnumerator LogicalChildren { get; }
Protected Overrides ReadOnly Property LogicalChildren As IEnumerator
    Get

Property Value

Type: IEnumerator

Return Value

Type: IEnumerator
An enumerator for logical child elements of this element.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.MaxTailItemCount Property

BreadcrumbMaxTailItemCount Property

Gets or sets the maximum number of tail BreadcrumbItem controls to display below the SelectedItem. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public int MaxTailItemCount { get; set; }
Public Property MaxTailItemCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of tail BreadcrumbItem controls. The default is 0.
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.MenuHorizontalOffset Property

BreadcrumbMenuHorizontalOffset Property

Gets or sets the horizontal distance between the target origin and the content menu alignment point. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public double MenuHorizontalOffset { get; set; }
Public Property MenuHorizontalOffset As Double
    Get
    Set

Property Value

Type: Double
The horizontal distance between the target origin and the context menu alignment point. The default is 0.

Implements

IBreadcrumbCommonMenuHorizontalOffset
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.MenuItemContainerExpandedStyle Property

BreadcrumbMenuItemContainerExpandedStyle Property

Gets or sets the Style that is applied to the MenuItem elements generated for expanded items in context menus. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public Style MenuItemContainerExpandedStyle { get; set; }
Public Property MenuItemContainerExpandedStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that is applied to the MenuItem elements generated for expanded items in context menus. The default is .

Implements

IBreadcrumbCommonMenuItemContainerExpandedStyle
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace


Breadcrumb.MenuItemContainerExpandedStyleSelector Property

BreadcrumbMenuItemContainerExpandedStyleSelector Property

Gets or sets custom logic for choosing a Style that can be applied to MenuItem elements generated for expanded items in context menus. This is a dependency property.

Namespace: ActiproSoftware.Windows.Controls.Navigation
Assembly: ActiproSoftware.Navigation.Wpf (in ActiproSoftware.Navigation.Wpf.dll) Version: 19.1.682.0
Syntax
C#
VB
Copy
public StyleSelector MenuItemContainerExpandedStyleSelector { get; set; }
Public Property MenuItemContainerExpandedStyleSelector As StyleSelector
    Get
    Set

Property Value

Type: StyleSelector
A StyleSelector object that contains logic that chooses the Style to use as the MenuItemContainerExpandedStyle. The default is .

Implements

IBreadcrumbCommonMenuItemContainerExpandedStyleSelector
See Also

Reference

Breadcrumb Class
ActiproSoftware.Windows.Controls.Navigation Namespace